New Features in JMP 11

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF
CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH
THE USE OR PERFORMANCE OF THIS SOFTWARE.

• Telerik RadControls: Copyright © 2002-2012, Telerik. Usage of the included Telerik
RadControls outside of JMP is not permitted.

• ZLIB Compression Library - Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.

• Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.

• Packages - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and
the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions
and the following disclaimer in the documentation and/or other materials provided with the
distribution.

Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or
promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.

All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:

– Redistributions of source code must retain the above copyright notice, this list of conditions
and the following disclaimer.

– Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials provided
with the distribution.

– Neither the name of OpenLink Software Inc. nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

- bzip2, the associated library “libbzip2”, and all documentation, are Copyright © 1996-2010,
  Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and
the following disclaimer.

The origin of this software must not be misrepresented; you must not claim that you wrote the
original software. If you use this software in a product, an acknowledgment in the product
documentation would be appreciated but is not required.

Altered source versions must be plainly marked as such, and must not be misrepresented as being
the original software.

The name of the author may not be used to endorse or promote products derived from this
software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,
OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


- MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and
  international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered
  trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional
  trademarks. Other product or brand names may be trademarks or registered trademarks of their
  respective holders.
Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn about JMP. Visit JMP.com to find the following:

- live and recorded webcasts about how to get started with JMP
- video demos and webcasts of new features and advanced techniques
- schedules for seminars being held in your area
- success stories showing how others use JMP
- a blog with tips, tricks, and stories from JMP staff
- a list of training classes and schedule of public courses
- a forum to discuss JMP with other users

http://www.jmp.com/getstarted/
Contents

New Features in JMP 11

Documentation and Help ................................................................. 3

Basic Analysis ........................................................................... 5
  Fit Y by X ........................................................................... 5
  Bivariate .............................................................................. 5
  Distribution ........................................................................... 5
  Oneway ................................................................................. 6
  Tabulate ................................................................................ 6

Consumer Research ...................................................................... 7
  Categorical ............................................................................ 7
  Choice ................................................................................... 8
  Factor Analysis ...................................................................... 10
  Item Analysis ......................................................................... 12
  Uplift ..................................................................................... 12

Data Filter .................................................................................. 13

Data Tables .................................................................................. 14
  Add Columns .......................................................................... 14
  Clear Selected Row States .................................................... 14
  Color ..................................................................................... 15
  Columns Filter ....................................................................... 15
  Columns Viewer ..................................................................... 15
  Hiding and Excluding Rows .................................................. 15
  Join Tables ............................................................................. 16
  Missing Data Patterns ........................................................... 16
  Profit Matrix .......................................................................... 16
  Recode .................................................................................... 16
  Rename ................................................................................... 16
  Resizing Columns ................................................................... 16
  Save as CSV ........................................................................... 17
  Sorting Columns .................................................................... 17
  Split ....................................................................................... 17
Renew Annual License ................................................................. 35
SAS Datasets ............................................................................. 35
SAS Import Sampling ................................................................. 36
SAS Integration .......................................................................... 36
Select Columns Filter ................................................................. 36
Show Tree Structure ................................................................. 37
Subsetting Text Import Files ................................................... 37
Summary Statistics ................................................................... 37
Touchscreen Support ................................................................ 37
Transform Columns .................................................................... 37
Windows ..................................................................................... 38
Multivariate Methods ............................................................... 38
  Discriminant Analysis ............................................................... 38
  Hierarchical Clustering ............................................................ 39
  Partial Least Squares ............................................................... 39
  Principal Components ............................................................. 40
Profilers ....................................................................................... 40
  Contour Profiler .................................................................... 40
  Prediction Profiler .................................................................. 41
Quality and Process Methods ................................................. 41
  Capability ............................................................................... 41
  Control Chart Builder ............................................................ 41
  Diagrams ................................................................................. 43
  Measurement Systems Analysis ............................................. 43
Reliability and Survival ............................................................ 44
  Degradation ............................................................................ 44
  Fit Parametric Survival ........................................................... 44
  Life Distribution ..................................................................... 44
  Reliability Block Diagram .................................................... 45
  Reliability Growth ................................................................... 46
Sample Data ............................................................................... 47
  Sample Data Tables ............................................................... 47
  Sample Import Data ............................................................... 48
Scripting ...................................................................................... 48
  Add-In Builder ....................................................................... 49
  Application Builder ............................................................... 49
  As List ..................................................................................... 49
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check Box</td>
<td>49</td>
</tr>
<tr>
<td>Column States</td>
<td>50</td>
</tr>
<tr>
<td>Column Switcher</td>
<td>50</td>
</tr>
<tr>
<td>Combo Box</td>
<td>50</td>
</tr>
<tr>
<td>Cytometry Logic</td>
<td>50</td>
</tr>
<tr>
<td>Data Table</td>
<td>50</td>
</tr>
<tr>
<td>Declare Function</td>
<td>51</td>
</tr>
<tr>
<td>Desktop Path Variable</td>
<td>52</td>
</tr>
<tr>
<td>Display Boxes</td>
<td>52</td>
</tr>
<tr>
<td>Formula Editor</td>
<td>52</td>
</tr>
<tr>
<td>Functions</td>
<td>52</td>
</tr>
<tr>
<td>Include</td>
<td>53</td>
</tr>
<tr>
<td>Integrate</td>
<td>53</td>
</tr>
<tr>
<td>JSL Log</td>
<td>53</td>
</tr>
<tr>
<td>JSL Profiler</td>
<td>54</td>
</tr>
<tr>
<td>List Box</td>
<td>54</td>
</tr>
<tr>
<td>Matrix Box and Table Box</td>
<td>54</td>
</tr>
<tr>
<td>Mouse Box</td>
<td>54</td>
</tr>
<tr>
<td>New Window</td>
<td>54</td>
</tr>
<tr>
<td>Number Edit Box</td>
<td>54</td>
</tr>
<tr>
<td>Open Help</td>
<td>55</td>
</tr>
<tr>
<td>Preferences for File Locations</td>
<td>55</td>
</tr>
<tr>
<td>Print Settings</td>
<td>55</td>
</tr>
<tr>
<td>Quasi-Random Sequences Generator</td>
<td>55</td>
</tr>
<tr>
<td>Range Slider Box</td>
<td>55</td>
</tr>
<tr>
<td>Run External Programs</td>
<td>56</td>
</tr>
<tr>
<td>Save Interactive HTML</td>
<td>56</td>
</tr>
<tr>
<td>Script Box</td>
<td>56</td>
</tr>
<tr>
<td>Script Editor</td>
<td>56</td>
</tr>
<tr>
<td>Scroll Box</td>
<td>57</td>
</tr>
<tr>
<td>Spin Box</td>
<td>57</td>
</tr>
<tr>
<td>Splitter Box</td>
<td>57</td>
</tr>
<tr>
<td>Tab Box</td>
<td>57</td>
</tr>
<tr>
<td>Table Box</td>
<td>58</td>
</tr>
<tr>
<td>Table Script</td>
<td>58</td>
</tr>
<tr>
<td>Text Box</td>
<td>58</td>
</tr>
<tr>
<td>Text Edit Box</td>
<td>58</td>
</tr>
<tr>
<td>Toolbar Visibility</td>
<td>58</td>
</tr>
<tr>
<td>Triangulation</td>
<td>59</td>
</tr>
<tr>
<td>Update Data</td>
<td>59</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Week of Year</td>
<td>59</td>
</tr>
<tr>
<td>Specialized Models</td>
<td>60</td>
</tr>
<tr>
<td>Partition</td>
<td>60</td>
</tr>
<tr>
<td>Response Screening</td>
<td>61</td>
</tr>
<tr>
<td>Time Series</td>
<td>62</td>
</tr>
</tbody>
</table>
JMP 11 provides several powerful new analysis platforms, additions to existing platforms, and JMP Scripting Language (JSL) enhancements.

New analysis platforms include the following:

- A Factor Analysis platform helps describe variability among observed, correlated variables in terms of a potentially smaller number of unobserved or latent variables. Plots and reports give insight on the interpretation of the latent factors.
- A Response Screening platform was designed to do a large number of simple fits on Ys by Xs across groups, with the purpose of finding strong relationships in the data. The Response Screening platform performs the same fits as the Fit Y by X platforms, but on a greater scale.
- A Reliability Block Diagram platform analyzes the reliability of the various elements in a large and complex system.
- A Definitive Screening Design platform has been added to the Design of Experiments menu. Definitive screening designs are small three-level designs that provide estimates of main effects that are unbiased by second order effects. They also avoid aliasing of second-order effects. By reducing the need for subsequent experiments, these designs can increase the overall efficiency of the experimental process.
- The Uplift platform helps you identify characteristics of individuals who are likely to respond to an intervention (for example, to optimize marketing decisions). Uplift modeling differs from traditional modeling techniques in that it finds the interactions between a treatment and other variables. It focuses on individuals who are likely to react positively to an action or treatment.

Major additions and changes to existing platforms and menus include the following:

- A new menu option, Consumer Research, has been created under Analyze to house previous and new platforms (Categorical, Factor Analysis, Choice, Uplift, and Item Analysis).
- The Categorical platform has been updated with a redesigned launch window and enhanced reports.
- Attribute and rare event control charts are now available in the Control Chart Builder.
- More personality options (Response Screening, Generalized Regression, and Mixed Models) and a Multiple Comparisons option have been added to the Fit Model platform.
- Missing data handling is available in many Fit Model personalities and an improved approach is taken in the Partition platform.
• More model options and an Analysis of Mean Ranges chart have been added to the Measurement Systems Analysis platform.
• The Screening Design platform offers a new method that constructs designs that are orthogonal or nearly orthogonal in the main effects.
• A cluster-based space-filling design method has been added to the Space-Filling Design platform.
• Space-filling designs and the ability to apply linear constraints have been added to the Mixture Design platform.
• Interval-censored test plans are available in the Accelerated Life Test Design platform.
• Tabulate's user interface for interactive tables has changed. It no longer prompts you for a column role. It assigns default roles and builds the appropriate table based on the selected columns to make a new table or augment an existing one.
• The ability to specify transform columns has been added to all platforms.
• Assess the variable importance of a model in the Profiler platforms.
• The ability to save dynamic reports as interactive HTML has been added. Non JMP users can explore your analyses as they would in JMP.

Other important new features include the following:
• New and reorganized books and help content.
• The ability to combine windows.
• The ability to compress data tables loaded from large text files.
• Drag and drop functionality for project files.
• An Excel Import wizard.
• Support for MATLAB.
• For touchscreens, support for panning and zooming on graphs and axes in JMP.
• JSL tools:
  – A JSL Profiler has been added to analyze execution times.
  – Several JSL files and directory commands have been added.
  – Improvements to the Application Builder interface and features.

indicates features that are available only in JMP Pro.
Documentation and Help

Several JMP books were divided and reorganized into smaller and more focused versions. The new books provide a more coherent structure for topics and enable you to find information quickly.

All books are also combined into one PDF file, called *JMP Documentation Library*, for convenient searching. Open the *JMP Documentation Library* PDF file from the **Help > Books** menu.

For a complete list of contents, view the book descriptions at **Help > Books > Book Descriptions**, or view each individual book at **Help > Books**. Note that this document (*New Features Guide*) is also now available under the Help menu at **Help > New Features**.

The following table provides an overview of how the books were reorganized. For the remainder of this document, new features are described under the appropriate book title heading.

**Table 1.1  New JMP Documentation**

<table>
<thead>
<tr>
<th>JMP 10 Book Title</th>
<th>JMP 11 Book Title</th>
<th>Overview</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Basic Analysis and Graphing</em></td>
<td><em>Basic Analysis</em></td>
<td>Details the more basic analysis platforms and tools.</td>
</tr>
<tr>
<td><em>Essential Graphing</em></td>
<td></td>
<td>Describes how you can visualize your data using graphs and plots from basic distributions, bubble plots, scatterplots, and parallel plots to geographic maps and boundary maps from shape files.</td>
</tr>
</tbody>
</table>
**Highlights in JMP 11**

**Documentation and Help**

- **Modeling and Multivariate Methods**
  - Fitting Linear Models
  
  Describes the Fit Model platform and its many personalities. You can specify many different types of models and effect structures and analyze them using various modeling approaches.

- **Specialized Models**
  
  Details other modeling techniques, such as Partition, Neural Networks, Nonlinear Regression, Gaussian processes, and Time Series analysis. Compare the predictive ability of several models using the Model Comparison platform.

- **Profilers**
  
  Covers the family of JMP profilers along with the Surface Plot platform.

- **Multivariate Methods**
  
  Details the multivariate modeling platforms: Multivariate, Cluster, Discriminant Analysis, Principal Components, and Partial Least Squares.

- **Consumer Research**
  
  Addresses techniques for studying consumer preferences and using that insight to create better products and services.

- **Quality and Reliability Methods**
  
  Quality and Process Methods
  
  Describes methods and tools to evaluate and improve quality. Includes Measurement Systems Analysis, Control Charts, Capability, Pareto Plots, and cause-and-effect Diagrams.

- **Reliability and Survival Methods**
  
  Details platforms used for modeling reliability, from estimating competing causes to making accurate lifetime predictions on products and components.

---

**Table 1.1 New JMP Documentation**

<table>
<thead>
<tr>
<th>JMP 10 Book Title</th>
<th>JMP 11 Book Title</th>
<th>Overview</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Modeling and Multivariate Methods</em></td>
<td><em>Fitting Linear Models</em></td>
<td>Describes the Fit Model platform and its many personalities. You can specify many different types of models and effect structures and analyze them using various modeling approaches.</td>
</tr>
<tr>
<td><em>Specialized Models</em></td>
<td></td>
<td>Details other modeling techniques, such as Partition, Neural Networks, Nonlinear Regression, Gaussian processes, and Time Series analysis. Compare the predictive ability of several models using the Model Comparison platform.</td>
</tr>
<tr>
<td><em>Profilers</em></td>
<td></td>
<td>Covers the family of JMP profilers along with the Surface Plot platform.</td>
</tr>
<tr>
<td><em>Multivariate Methods</em></td>
<td></td>
<td>Details the multivariate modeling platforms: Multivariate, Cluster, Discriminant Analysis, Principal Components, and Partial Least Squares.</td>
</tr>
<tr>
<td><em>Consumer Research</em></td>
<td></td>
<td>Addresses techniques for studying consumer preferences and using that insight to create better products and services.</td>
</tr>
<tr>
<td><em>Quality and Reliability Methods</em></td>
<td><em>Quality and Process Methods</em></td>
<td>Describes methods and tools to evaluate and improve quality. Includes Measurement Systems Analysis, Control Charts, Capability, Pareto Plots, and cause-and-effect Diagrams.</td>
</tr>
<tr>
<td><em>Reliability and Survival Methods</em></td>
<td></td>
<td>Details platforms used for modeling reliability, from estimating competing causes to making accurate lifetime predictions on products and components.</td>
</tr>
</tbody>
</table>
This section describes new features and enhancements in the basic analysis platforms.

Note that Tabulate has moved from the Tables menu to the Analyze menu. For more information about changes within Tabulate, refer to the General Enhancements section.

### Fit Y by X

For all of the types of analyses in the Fit Y by X platform, if you specify multiple Y variables in the launch window, the responses are grouped into a report called Fit Group. You can arrange the reports in rows using the **Arrange in Rows** option, or you can sort the reports for the different Y variables using the **Order by Goodness of Fit** option.

This feature was already implemented for the Fit Model platform, and is now also available for the Fit Y by X platform.

### Bivariate

- A new option, **Fit Robust**, has been added to the Bivariate red triangle menu. The statistics are calculated in a way that is resistant to outliers, using Huber’s M-estimation.

### Distribution

- You can specify the number of plots that appear in a row. This option helps you view plots vertically rather than in one wide row. To access this option, from the red triangle menu next to Distributions, select **Arrange in Rows**.
- New summary statistics, **Robust Mean** and **Robust Std Dev**, have been added. Both statistics are calculated in a way that is resistant to outliers, using Huber’s M-estimation. To show

---

**Table 1.1 New JMP Documentation**

<table>
<thead>
<tr>
<th>JMP 10 Book Title</th>
<th>JMP 11 Book Title</th>
<th>Overview</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Scripting Guide</em></td>
<td><em>Scripting Guide</em></td>
<td>Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications.</td>
</tr>
<tr>
<td><em>JSL Syntax Reference</em></td>
<td></td>
<td>Focuses on functions and their arguments, and messages that can be sent to objects and display boxes. Notes and examples are included.</td>
</tr>
</tbody>
</table>
these statistics, select **Customize Summary Statistics** from the Summary Statistics red triangle menu.

**Oneway**

- A new option, **Robust Fit**, has been added to the Oneway red triangle menu. The statistics are calculated in a way that is resistant to outliers, using Huber’s M-estimation.

**Tabulate**

- Tabulate has moved from the Tables menu to the Analyze menu.
- In previous versions, a pop-up menu appeared when you dragged an item into a zone to select a role for the item. In version 11, the pop-up menus have been removed and JMP populates and creates a table automatically based on the selection (categorical - grouping column; continuous - analysis column). If you drop multiple grouping columns into the initial blank area, JMP creates a separate table for each grouping column. You can right-click the item and select another option (Columns by Categories, Nest Grouping Columns).
- You can now add **Column %** to tables with multiple rows (stacked vertically).
- A **Default Statistics** icon has been added where you can select the default statistics for the analysis and save it as a preference or just for the file.
- You can now add a frequency, weight, or page column in Tabulate by either dragging a column into the appropriate box (**Freq**, **Weight**, **Page Column**) or by entering the name.
- Tabulate now distinguishes between the column name and the statistics name when columns are dragged from the Columns list within Tabulate. If the column is dragged from outside of Tabulate, the statistics name is selected over the column name because the column name can be changed.
- Tabulate now uses a modeling type to determine whether a column is considered a grouping column or an analysis column when you drag the column to the drop zone. Previously, a pop-up appeared where you could select whether the variable should be used for grouping or to be analyzed. Now, the presence of statistics keywords serves as a hint and Tabulate automatically assigns a role to the column. For example, if you drag a numeric non-continuous column with a statistic, the column is treated as an analysis column.
  
You can change the role of a column in the generated table by right-clicking the column name and changing a grouping column to an analysis column, or vice versa. This makes it possible to use a numeric categorical column as an analysis column or a continuous column as a grouping column, without having to change the column’s modeling type.
Consumer Research

A new menu option, Consumer Research, has been created under the Analyze menu to include current and new platforms (Categorical, Factor Analysis, Choice, Uplift, and Item Analysis). These methods support behavioral and marketing research, aid in analyzing survey data, and address needs in various other fields as well.

Categorical

The Categorical platform moved from the Analyze > Modeling menu to a new menu option, Analyze > Consumer Research > Categorical. The launch window has been revised to enhance dragging of response roles and grouping categories. Response roles have been grouped into tabs (Single, Related, Multiple), and there is a Structured tab where you can drag variables to create your own table that allows side-by-side and nesting structures.

Figure 1.1 Categorical Platform Launch Window

New options have been added to the launch window and the visual style of the reports has been improved, including shading consistent with the background color. Alternate lines are shaded also.

More comparison tests have been added to the red triangle menu. You can determine not only significant differences across samples, but also which samples are significantly different from others. Compare Each Pair, which compares each sample level with others, and Compare Each Cell, which compares each cell level with others, have been added to the red triangle menu.
You can now display mean scores for responses in the report. The Mean Score option incorporates either raw numeric codes or a Value Score, which attaches a number to each category. If there are missing value codes, they are denoted as missing. You can also display a comparison to determine mean scores that are different from each other; calculate the standard deviation score; and reorder the reports so that the highest means are displayed at the top. From the red triangle menu, select Mean Score, Mean Score Comparisons, Std Dev Score, or Order by Mean Score.

Warning messages have been added to the Chi-square test for response homogeneity that only show when the Show Warnings item is selected. From the red triangle menu, select Test Options > Show Warnings. Cell Chi-square has also been added to the Test Options menu as a means to calculate the cell chi-square for the results.

**Figure 1.2** Categorical Platform Report Window

### Choice

The Choice platform moved from the Analyze > Modeling menu to a new menu option, Analyze > Consumer Research > Choice.

Two new options are available in the Choice platform:

- **Comparisons** - performs comparisons between specific alternative choice profiles.
- **Willingness to Pay** - calculates price changes equivalent to feature changes.

Comparisons enables you to select factor values and the values that you want to compare. From here you can compare specific configurations, including comparing all settings on the
left or right by selecting the Any check boxes. Using Any does not compare all combinations across features, but rather all combinations of comparisons, one feature at a time, using the left settings as the settings for the other factors. To use the feature, select Comparisons from the Choice Model red triangle menu.

**Figure 1.3 Comparisons Window**

Willingness to Pay calculates how much a price must change allowing for the new feature settings to produce the same predicted outcome. The result is calculated using the Baseline settings (for each background setting) and then determining the outcome after altering the Role, including:

- Feature Factor - a feature in the experiment that you want to price.
- Price Factor - a continuous price factor in the experiment.
- Background Constant - something you want to hold constant at a baseline value.
- Background Variable - something you want to iterate across values.
Figure 1.4 Willingness to Pay

The Include baseline settings in report table option adds the baseline settings with a price change of zero, which is useful if you make an output table of these prices displaying all the baseline settings as well as the featured settings. To use the feature, select Willingness to Pay from the Choice Model red triangle menu.

Factor Analysis

Factor Analysis is now a separate platform from the Principal Components platform. Factor analysis models variability among observed, correlated variables in terms of a smaller number of unobserved, or latent variables. The platform allows multiple fits and rotation, conditional formatting to suppress small values, and provides commands to sort and save factor patterns.

To access the platform, go to Analyze > Consumer Research > Factor Analysis.
The Factor Analysis report headings now list the number of factors in the analysis. New options have been added to the Unrotated Factor Loading and Rotated Factor Loading sections of the report that enable you to specify the threshold level to suppress loadings. You can use a slider or value to Suppress Absolute Loading Values Less Than the specified value, and the Dim Text slider or value to control the table’s font transparency gradient for factor values less than the entered suppressed value entered. You can also set the default values in Preferences > Platforms > Factor Analysis.
**Item Analysis**

The Item Analysis platform moved from the Analyze > Multivariate Methods menu to a new menu option, Consumer Research, in the Analyze menu. To access the platform, select Analyze > Consumer Research > Item Analysis.

**Uplift**

An Uplift platform has been developed to help optimize marketing decisions, define personalized medicine protocols (or, more generally, to identify characteristics of individuals who are likely to respond to an intervention). Uplift studies are used to model the incremental impact of an action on individuals. That action might be a promotional offer for a product or a medical treatment. An uplift model helps identify groups of individuals who are most likely to respond to the action. Identification of these groups leads to efficient and targeted decisions that optimize resource allocation and impact on the individual.

To access the platform, go to Analyze > Consumer Research > Uplift.

**Figure 1.6 Uplift Platform Launch Window**

The Uplift platform fits partition models. Traditional partition models find splits to optimize a prediction, but uplift models find splits to maximize a treatment difference.

The uplift partition model accounts for the fact that some individuals receive the treatment, but others do not. It does this by fitting a linear model to each possible (binary) split. A continuous response is modeled as a linear function of the split, the treatment, and the interaction of the split and treatment. A categorical response is expressed as a logistic function of the split, the treatment, and the interaction of the split and treatment. In both cases, the interaction term measures the difference in uplift between the groups of individuals in the two splits.
Data Filter

This section describes new features and enhancements to the Data Filter.

- A **Favorites** icon has been added to the Data Filter, which saves your current selections in the Data Filter as a favorite.
Highlights in JMP 11

Data Tables

- A new option, Check Box Display, has been added to the Display Options menu on the red triangle menu next to a categorical variable. It adds a check box next to each level in a list display.

- Hierarchical filtering is now based on the order that the column filter is selected. In previous versions, you had to add the columns in the order you wanted them to be considered in the hierarchy. The Hierarchical option has also been renamed to be the Conditional option. For filter columns with hierarchy, you can use the Conditional option to filter what appears in the column lists. Select Conditional from the Data Filter red triangle menu. Clicking Clear removes your selections and enables you to redefine the hierarchy.

- A Find command has been added for the categorical column filter allowing you to find a category without having to scroll through a long list. Select Find from the categorical column filter red triangle menu and then further refine the search from the options that appear. Select Clear Find to close the find options.

- An Inverse command has been added to the Data Filter window that inverts the selections in the column filter (for example, deselects the selected rows and selects the unselected rows).

- A new categorical column filter for multiple responses has been added. The Data Filter automatically adds the column for multiple responses if the column has the Multiple Response column property.

- In Preferences > Tables, a new option enables you to always use a check box display for categorical filter columns. The option is called Data Filter Check Box Display.

Another new option enables you to include responses that are not present in the data, but exist in a value label. The option is called Include Responses Not in Data. This option applies to categorical columns only and is also available in the Categorical platform.

Data Tables

This section describes new features and enhancements to data tables.

Add Columns

Right-clicking anywhere to the right of the last column in a data table to add multiple columns automatically defaults to After Last Column.

Clear Selected Row States

As an alternative to clearing the row states for all rows, you can clear only selected row states using the Rows > Clear Selected Row States option.
Color

Note that if you have applied color to cells through the Color Cells command, the color now remains if you subset the data.

Columns Filter

The following new options have been added to the Column Filter:

- **Name Does Not Contain**—Searches for column names that do not contain the specified text.
- **Exclude Formats**—Excludes columns with specific formats from the column selection list.
- **Column Groups**—Shows or hides grouped columns.
- **Ungrouped Columns**—Shows or hides columns that have not been grouped.

To access the Column Filter, select the red triangle menu within the Select Columns panel in most launch windows.

Columns Viewer

You can now easily view and work with a data table that has a lot of columns through the **Columns Viewer**. From here you can select and show summaries of various sets of columns. Select a range of columns and then click **Show Summary** to view the summary statistics for that set. The set of statistics displayed depends on the type of column selected (categorical or continuous). Select the **Show Quartiles** check box to include the upper and lower quartiles and the interquartile range in the summary statistics. You can also create a subset with the selected columns and rows. Click the **Distribution** button to launch the Distribution Platform for the selected columns.

From the Summary Statistics red triangle menu, select **Data Table View** to view the results in a data table. Note that the row selected in the data table view is linked to the associated column in the source table.

You can also easily locate columns with specific properties through the **Find Columns with Properties** option.

To access the Columns Viewer from a data table, select **Cols > Columns Viewer**.

Hiding and Excluding Rows

If you want to hide a selected row in a plot and exclude it from analysis, you can now do that with one command instead of two. Select **Rows > Hide and Exclude**.
Join Tables

When you join two data tables, select the Copy Formula check box to include formulas from the second table in the columns of the joined table. Select the Suppress Formula Evaluation check box to prevent JMP from evaluating columns’ formulas during the creation of the new table.

Previously, there was only one set of Copy Formula and Suppress Formula Evaluation check boxes. So the same checked option was applied to columns from both tables. Now, the second table has its own set of check boxes, so the checked options are associated to the main table or the second table accordingly.

To access the options, select Tables > Join and then select the options in the Second Table area of the Join tables window.

The Match Flag column has been changed from a continuous to a nominal variable. This facilitates the use of features like Data Filter and Distribution.

Missing Data Patterns

- In addition to the existing Treemap script, a new Cell Plot script has been added to the output table. Run the new script to generate a cell plot of the missing data pattern results.
- A new option, Count Missing Value Codes, has been added that counts missing value codes as missing values.

Profit Matrix

Profit Matrix has been added as a column property. You can use the property to enhance a predictive model by converting it to a decision model and assigning weights to outcomes. To access the feature, select Column Properties > Profit Matrix. From here you can enter profit and cost information and then save the results as a prediction formula. These values are used to create best decision columns. The best decision is the one with the greatest expected profit.

Recode

You can now recode data across multiple columns. To access the feature, select Cols > Standardize Attributes > Recode.

Rename

Notification when a data table is renamed has been added to data table subscriptions. Subscribers to the list get notifications when a data table is renamed.

Resizing Columns

In addition to resizing column widths, you can now resize column name heights. As with widths, simply use the arrows to drag column heights to the desired size.
Save as CSV

JMP now has CSV and TSV extensions listed in the File > Save As dialog to simplify exporting data.

Sorting Columns

When you right-click a column and select Sort, you now have the choice to select either ascending or descending order.

Split

In the Split launch window, a new option, Sort by Value Order, has been added. If you have assigned a Value Ordering column property to the column that you want to split by, then JMP uses it to sort the output.

Subset

To retain the column that you have subsetted by in the output tables, select the Keep by column option in the Subset launch window.

Using Value Labels

Once you have set value labels on a column, you can show or hide the value labels by right-clicking on the column heading and selecting Use Value Labels.

Design of Experiments

This section describes new features and enhancements in the Design of Experiments platforms.

Many of the DOE platforms are now scriptable, including Definitive Screening, Screening, Response Surface, Full Factorial, Mixture, Space Filling, and Augment.

Accelerated Life Test Design

In addition to continuous monitoring, the Accelerated Life Test Design platform now has the option to design interval-censored test plans. To choose this option, select DOE > Accelerated Life Test Design > Monitoring at Intervals on the Accelerated Life Test Plan window. Then enter the number of inspections, the first inspection time, and the time between inspections to design the appropriate test plan.
Definitive Screening Design

A Definitive Screening Design platform has been added to the DOE menu. Definitive screening designs are small three-level designs that provide estimates of main effects that are unbiased by second order effects. They also avoid aliasing of second-order effects. By reducing the need for subsequent experiments, these designs can increase the overall efficiency of the experimental process. Definitive screening designs are considered to be self-foldover because the runs of the design come in pairs that mirror each other.

The purpose of the design is to separate the vital few factors that have a substantial effect on the response from the many trivial factors that have negligible effects. If a factor’s effect is strongly curved, a traditional screening design might miss this effect and screen out that factor. If there is a two-factor interaction, standard screening designs having a similar number of runs to the definitive screening design; the same number of factors require follow-up experimentation to resolve any ambiguity. The definitive screening design reliably accomplishes the task of screening even if there are second order effects.

Definitive screening designs are available only for continuous factors and categorical factors with two levels. To choose this option, select DOE > Definitive Screening Design.

Figure 1.8 Definitive Screening Design Platform Launch Window

Mixture Design

The launch and subsequent windows have been revised for ease of use and customized design generation. To choose this option, select DOE > Mixture Design.
Figure 1.9 Mixture Design Launch Window

A new **Space Filling** design type has been added to the platform that spreads points throughout the design space. You can enter the number of runs you want to include in the experiment. Note that **Linear Constraints** has been relocated. Previously, the option was an Extreme Vertices design type. Now the option is at the top of the Linear Constraints report and can also be associated with the Optimal and Space Filling design types.

**Power Analysis Report**

The **Power Analysis** section of the Design Evaluation output in most platforms has been revamped and enhanced. The results are now directly related to the Parameter Estimates in the Fit Model platform.

The **Variance Inflation Factor** is now known as **Estimation Efficiency** in the Design Evaluation output and the results are reported as percentage increase in CI Length, not variance inflation factor.
Sample Size and Power

You can now select the method for a one sample proportion design from the Sample Size calculation window: Exact Agresti-Coull (default) or Exact Clopper-Pearson. To choose this option, select DOE > Sample Size and Power > One Sample Proportion.

Screening Design

The Screening Design platform offers a new method that constructs designs that are orthogonal or nearly orthogonal in the main effects. This option enables you to find an appropriate screening design when no standard design exists for your situation. Using this method, you can obtain a screening design when you have discrete numeric factors or categorical factors with more than three levels.

You can now specify a Discrete Numeric factor for the model and the number of factors that you want to include from the launch window. The launch and subsequent windows have been revised for ease of use and customized design generation. To choose this option, select DOE > Screening Design.

Figure 1.10  Screening Design Launch Window

After specifying factors, you can select a screening type, including a new option to Generate orthogonal or near orthogonal designs for main effects only.
Selecting the orthogonal option provides an additional section that enables you to select the number of runs (Minimum, Default, or User Specified) you want to include in your experiment. The subsequent Design Evaluation provides further information, including a Power Analysis, Estimation Efficiency, Design Diagnostics, and Output Options. Click Make Table to create a data table that contains the information and runs for your experiment.

**Simulate Responses**

Often, when you define a custom design (or any standard design), it is useful to look at properties of the design with response data before you have collected data. The Simulate Responses command adds random response values to the JMP table that the custom designer creates. To use the command, select it before you click Make Table. When you click Make Table to create the design table, the Y column contains values for simulated responses.

This option has been enhanced to provide you with more control over the values generated.

**Space Filling Design**

A cluster-based space filling design option has been added to the platform, along with revised windows and reports. To choose this option, select DOE > Space Filling Design.

On the launch window, there is now an option for a Cluster Filling design method that includes an optional Fast Flexible Filling factor. The linear constraint enables you to enter factor constraints for the design.
Selecting **Fast Flexible Filling** provides you with a cluster design that displays Factor Settings and Design Diagnostics. Click **Make Table** to create a data table that contains the information and runs for your experiment. This option is also available when creating **Disallowed Combinations** through the Space Filling Design red triangle menu.

**Essential Graphing**

This section describes new features and enhancements in the essential graphing platforms.

- Graph preferences have been improved to enhance visibility and clarity. Preferences have been refined for displays, including the ability to add a y-axis title above the graph, adjust colors, shading, marker sizes and selection colors, line widths, borders, and graph size. To access preferences, select **File > Preferences > Graphs** or **File > Preferences > Styles** (new option).
- You can now plot data on street-level maps, giving you access to geographic features such as cities, roads or bodies of water. The images are created from open source maps data
from OpenStreetMap. The servers generate and return the maps when you select **Street Map Service** from any platform in JMP that supports background maps. You can access this feature by right-clicking in a graph and selecting **Graph > Background Map > Street Map Service** on the Set Background Map window.

**Figure 1.13** Crime Data - Before and After Adding Street Map Service

- New color themes and a color theme picker have been added. To access color themes, select **File > Preferences > Graphs > Color Themes**. Click **Continuous Color Theme** or **Categorical Color Theme** to view all of the associated colors. Color themes can also be accessed through the red triangle menus within Graph Builder and other platforms.
Highlights in JMP 11
Essential Graphing

Figure 1.14 Color Themes

- New axes features on the Axis Specification windows (right-click an axis and select **Axis Settings**) include:
  - A **Label Row Nesting** option for hierarchical date and time is displayed. When set to something higher than 1 (the default), it automatically splits up the current axis format into multiple rows of labels.

Figure 1.15 Label Row Nesting
– A **Base** option on the log scale axis that enables you to customize the base.
– For the log axis, **# Minor Ticks**, now refers to minor tick depth instead of a specific number of tick marks.

**Figure 1.16** Log Base - # Minor Ticks

![Log Base - # Minor Ticks](image)

– A new scale type, **Power**, has been added. Power works similarly to log scale, but instead of the scale conversion being log(x), it is \( x^p \), where \( p \) is a customizable axis option. For example, Power = 2 creates an \( x^2 \) axis.

- Tick marks (including decimal places) are automatically updated when you zoom in on an axis.
- For date formatted axes, date tick intervals are now displayed accurately and on even intervals of the next largest interval (for example, ticks every five minutes always start at an even hour, ticks every two months always start at an even year, and so on).
- The Line Width pop-up now shows the current state and more width options.
- A new built-in map file has been added, which shows the coastline of large and small land masses. It is similar to world countries, but without all of the interior lines.

**Bubble Plot**

- The history of a bubble can be displayed through the **Trail Bubbles** and **Trail Lines** options in the red triangle menu of a bubble plot. Display trails for selected bubbles or all bubbles by selecting **File > Preferences > Platforms > Bubble Plot**. Select **None**, **Selected**, or **All** from the **Trail Bubbles** or the **Trail Lines** drop down.
- You can now stretch the bubble plot to fill the window when the window is re-sized, using the Auto Stretching option in the red triangle menu. Select **Auto**, **On**, or **Off** from the **Auto Stretching** option. The default is Auto.

**Graph Builder**

- The Line element now responds to size and color variables, and legends for line size have been revised.
• The Bar element now responds to a color variable.
• More statistics options (including Standard Deviation, Standard Error, Variance, and Interquartile Range) have been added. The Summary Statistics menu lists the available statistics in the Points and Caption Box sections.
• You can show or hide the title on a grouping variable. Right-click the grouping variable and select Show Title.
• You can change the orientation of the title or the levels of a grouping variable. Right-click the grouping variable and select Title Orientation or Level Orientation.
• Area, Bar, and Box Plots allow continuous Y and continuous X variables.
• In a heat map, placing your cursor over a cell to see a tooltip containing the label for that cell.
• In the Smoother, there is a new option to change the value of the smoothing parameter, lambda, using a slider.
• The legend can now be positioned below the graph. In the red triangle menu, select Legend Position.
• New options let you select default color themes for each graph window. A new color theme dialog has also replaced the list of color theme names from the first beta release.
• Map labeling has been improved and is more adaptable. The labeling readjusts to the view size and prevents overlapping.
• In a multiple or stacked bar chart, multiple bars corresponding to the same X variable can now be selected separately.
• Labels (Value, Percent, and Row Label) can now be added to a bar chart. Label options are also available by right-clicking on the bar chart (Bar > Label).
• You can now match tick marks on the right axis with tick marks on the left axis. Right-click the right axis and select Align Ticks with Left Axis.
• Graph Builder now supports a paging mode for grouping variables. Choose how many graphs you want to see at a time and then you can page through them. Right-click a group header box and select Levels in View, and then select the appropriate level.
• You can now include missing values in categorical axes and as grouping levels in a graph by selecting Include Missing Categories from the red triangle menu in Graph Builder.
• You can now create geospatial scatterplots by combining a shape variable with the Points element. The position of each point is based on the centroid of the corresponding shape. Select the Points element from the list of icons at the top of the Graph Builder window.
• A new Variables panel has been added to the element properties panel. You can hide or show each X or Y variable and any color variable.
• Two new statistics have been added for the Line of Fit element. The Equation option adds the regression equation for the line of fit. The $R^2$ option adds the R squared statistic to the graph.
• Isometric, geodesic graph scaling is now used when X and Y variables have a Latitude/Longitude format or whenever a background map is present.
• The axes in a Mosaic plot align better with the tile slices, including a percent axis on one side.
• Graph Builder is now more scriptable.

**Scatterplot Matrix**

• Add color to an outline and the area within an ellipse. In the red triangle menu, select Density Ellipses > Ellipse Color.
• The red triangle menu option, Shaded Ellipses, changes the shade as well as the outline of an ellipse. The shade color and the outline color now match.
• A Lock Scales option is now available that prevents axis scales and gradient legend scales from automatically adjusting in response to data or filtering changes. In the red triangle menu, select Lock Scales.

**Scatterplot3D**

• When you add Nonparametric Density Contours to a Scatterplot3D, you can adjust the grid size by right-clicking the graph and selecting Settings. From here you can modify the settings, such as text size and line width, and add or remove walls, grids, and axes.
• A legend now appears in the upper right corner of the plot when color roles are assigned. Right-click the plot and select Show Legend to show or hide the legend. You can right-click the legend to change the transparency and color scheme. This option requires the Coloring role to be applied.
• You can now display or remove the ray labels in a Scatterplot3D. In the Scatterplot 3D red triangle menu, select Show Ray Labels. You must have already selected Principal Components, Std Prin Components, or Rotated Components for this option to be active.

**Fitting Linear Models**

This section describes new features and enhancements in the fitting linear models platforms.

**Fit Model**

• There is a new Response Screening personality in Fit Model that is instrumental when analyzing many Xs or Ys. This platform explores relationships and provides tests for effects that take into account multiple-test selection bias through the Benjamini-Hochberg procedure and False Discovery Rate method. To access the feature, select Analyze > Fit Model and then select Response Screening as the Personality.
• A new Generalized Regression personality has been added to Fit Model that builds more accurate predictive models, even with challenging data. It is often necessary to generalize a model to the distribution of a response. This model fits generalized linear models using regularized, or penalized, regression techniques. The regularization techniques include...
Highlights in JMP 11

Fitting Linear Models

maximum likelihood, ridge regression, lasso, elastic net, adaptive lasso, and adaptive elastic net. The capability is important in many areas, such as model selection for screening designs, and data mining models over a very large number of predictors. To access the feature, select Analyze > Fit Model and then select Generalized Regression as the Personality.

• A new Mixed Models personality has been added to Fit Model that analyzes data that involves modeling both time and space. For example, a study design where multiple subjects are measured at multiple times during the course of a drug trial, or crossover designs in the pharmaceutical, manufacturing, or chemical industries. The model enables you to specify fixed, random, and repeated effects; correlate groups of variables; and set up subject and continuous effects. To access the feature, select Analyze > Fit Model and then select Mixed Models as the Personality.

• Multiple Comparisons has been added as a parameter estimates model option in the Fit Model report. The option enables you to specify comparisons among effect levels. These can involve a single effect or you can define flexible custom comparisons. You can compare to the overall mean, to a control mean, or you can obtain all pairwise comparisons using Tukey HSD or Student’s t-test. You can also conduct equivalence tests.

To access the feature after you have run a report, select Estimates > Multiple Comparisons from the red triangle menu. From here, you can specify the type of estimates and the type of comparison that you would like to view initially.

Figure 1.17 Multiple Comparisons Options

• You can now treat missing values as informative categories in most personalities of the Fit Model platform. The Informative Missing option provides a coding system for missing values. This system allows estimation of a predictive model despite the presence of missing values. It is useful in situations where missing data are informative. When a continuous main effect has missing values, a new design matrix column is created. This column is an indicator variable, with values of one if the main effect column is missing and zero if it is not missing.

In addition, missing values for the continuous main effect are replaced with the mean of the nonmissing values. The mean is a neutral value that maintains the interpretability of
parameter estimates. The parameter associated with the indicator variable estimates the
difference between the response predicted by the missing value grouping and the
predicted response if the covariate is set at its mean. When a nominal or ordinal main effect
has missing values, the missing values are coded as a separate level of that effect. As such,
in the Effect Tests report, each categorical main effect with missing values has one
additional parameter.

To access the feature, select Informative Missing from the red triangle menu on the launch
window.

- Within the profilers in the Fit Model platform, confidence intervals are saved in
  Remembered Settings and the desirability column is hidden unless Desirability Functions
  are turned on. After running a profiler, select Factor Settings > Remember Settings to save
  and view the confidence intervals. Select Factor Settings > Desirability Functions to turn on or
  off the desirability settings.

- Like the Nominal Logistic Model, the Ordinal Logistic Model now supports the Validation
column, producing separate ROC and Lift charts for validation and test sets. Validation is
the process of using part of a data set to estimate model parameters, and using the other
part to assess the predictive ability of the model. Select the Validation column in the Fit
Model launch window to subset the original data into parts.

**Stepwise**

- A new preference option, Export Model With Validation, has been added that enables you to
  fit a model with a validation column. The option is on by default, so the validation column
  is used when clicking Make Model or Run Model in a Stepwise report. To access the
  feature, select File > Preferences > Platforms > Fit Stepwise.

- You can now clear or reset the step history. To access the feature, select Clear History from
  the Stepwise Fit red triangle menu.

**General Enhancements**

General enhancements include changes that affect multiple platforms or areas.

**Binning Formulas**

The Make Binning Formula option on the Cols menu lets you preview and customize binned
data values for the selected continuous column. You can then make a formula column of
binned values.

**Bootstrapping**

Bootstrapping enables you to repeat an analysis with different sampling weights and tables. A
new feature enables you to delete the intermediate stacked table if you split it.
Highlights in JMP 11

General Enhancements

To access the bootstrapping option, right-click a statistic in a report and select Bootstrapping. Selecting Discard Stacked Table if Split Works deletes the stacked table if the table split is successful. The default value is On.

Column Switcher

The Column Switcher red triangle menu provides an option to remove the object.

Combine Windows

The ability to combine all open windows into one window is now supported on both Windows and Macintosh. Multiple JMP tables and reports can be combined into a single window, with more flexible options for layout hierarchies and resizable content.

To access this feature on Windows, select Window > Arrange > Combine Selected Windows. To access this feature on Macintosh, select Window > Combine Windows.

Or, you can use the new JSL command Combine Windows.

Compress Columns

Large text files import more quickly through a new preference for automatically compressing data columns during import. Previously, the entire uncompressed file had to fit in memory before a second, smaller, compressed version could be created. Character columns with fewer than 255 distinct values can also be compressed.

To access this feature, select File > Preferences > Text Data Files > Import Settings. Under Try to compress (requires scan whole file), select Numeric columns, Character columns, or Allow List Check.

This feature can be used in conjunction with an option to compress your data as described below.

Compress Data

You can now compress large data tables with whole-file, bit-by-bit compression. This allows up to a 90% reduction in disk space and allows easier provisions for sharing. This compression does not affect the space the data table takes in-memory for analysis in JMP, just the file size.

To set this feature for an individual data table, open the data table and then select Compress file when saved from the table heading red triangle menu. To set as a preference for all files, go to File > Preferences > General and select Save Data Table Columns GZ Compressed.

This feature can be used in conjunction with an option to compress your files as described above.
Database Integration

Speed up database queries by sampling the data. In the Database Open Table window, enter the percentage of rows that you want to appear in the list of tables.

Excel Import Wizard

An Excel Import wizard is now available that enables you to preview and experiment with your Excel files before you import them into JMP. The wizard detects how the data is structured and provides a preview of the data table. You can then modify the settings before importing the data. For example, you can indicate which row the data begins on and whether the spreadsheet contains column headings or hidden cells. JMP can automatically open each worksheet in the spreadsheet as a separate data table. You select this option in the preferences or when you open a spreadsheet. The wizard is available only on Windows.

**Figure 1.18 Excel Import Wizard**

![Excel Import Wizard]

Formula Editor

Tooltips have been added to functions, to help you quickly understand what each function does.
Remember the Image Format Type

When you save part of a report as a graphic with the Selection tool, JMP provides an option to remember the last graphic file type that you chose.

Interactive HTML (HTML 5)

Interactive HTML enables you to share reports that contain dynamic graphs so that even non JMP users can explore the data. The JMP report is saved as a web page in HTML 5 format, which you can e-mail or publish on a website. Users can then explore the data as they would in JMP. The Help page for Interactive HTML, accessible through the report itself, might provide suggestions on the most suitable browser. The feature is supported in most analytical platforms. If an image is not available in HTML, it is displayed as a static image.

![Interactive HTML](image1.png)

Figure 1.19 Interactive HTML

Installation

- On Windows, you can have JMP and JMP Pro installed separately as there are now separate directories for each version, allowing side-by-side installs. This means that JMP, JMP Pro, JMP Clinical, JMP Genomics, JMP Visual Data Discovery Desktop and any other version of JMP can coexist on the same machine without interfering with each other.
- JMP automatically installs all language options.
- Windows installers check the current Java Runtime Environment (JRE) version to determine whether a JRE installation should be done.
  - If a JRE of 1.7 or greater is found, the JRE is not installed.
  - If no JRE is found, or the JRE found is < 1.7, the JMP installer installs the JRE. We currently include JRE for Java 7 (1.7.15).

Both the 32-bit and 64-bit JRE are packaged and matched to whichever version of JMP is installed.
Macintosh

The Macintosh version of JMP now has a Home Window, similar to the Home Window in Windows. Select **Window > JMP Home** to view the Home Window. The Home Window is divided into the following panels:

- **Recent Files**: Shows recently opened files. Double-click a file to open and move the file to the top of the list. You can right-click a file and add it to your **Favorites** list. As you click or key through the recent files, the associated path updates at the bottom of the window. You can single-click the path and open the file or a finder window. You can select **Clear Recent Items** from the icon above **Recent Files** to clear the list.

- **Windows List**: Shows open JMP windows. The panel provides an outline view that groups subsequent windows with the parent window (usually a parent data table). Disclosure triangles expand and collapse to reveal details. Double-clicking an item in the tree brings that window to the foreground. You can right-click a file and close it.

A **Favorites** panel can be shown/hidden via a toggle button in the upper left hand side of the window.

**Figure 1.20** Macintosh Home Window

On a graph or report, you can display the associated data table by selecting **Window > Show Data Table** or clicking on the **Show Data Table** icon in the upper far right corner of the window.
MATLAB

JMP is now integrated with MATLAB. Engineers with large investments in MATLAB can now leverage pre-existing scripts, models, and routines from JMP. You can run MATLAB programs from JMP and retrieve the results for discovery, analysis, and visualization in JMP.

There are now JSL functions that provide access to MATLAB:

- Open and close a connection between JMP and MATLAB.
- Exchange data between JMP and MATLAB.
- Submit code for execution.
- Display graphics produced by MATLAB.

MATLAB must be installed on the same computer as JMP. JMP is not distributed with a copy of MATLAB. Because JMP is supported as both a 32-bit and 64-bit Windows application, you must install the corresponding 32-bit or 64-bit version of MATLAB.

Preferences

To access preferences on Windows, go to File > Preferences. To access preferences on a Macintosh, go to JMP > Preferences.

- JMP now remembers the last section that you accessed in the Preferences window and returns you to that section when Preferences is launched again.
- Non-English versions of JMP can save scripts in either English or your local language. The preference Save Scripts in English is now set as the default. Clear this option to save scripts in your local language. To access preferences, go to File > Preferences > General.
- Creating custom color theme settings has been revised. A preview color palette is available for both continuous and categorical color theme settings. To set custom color themes, go to File > Preferences > Graphs > Custom Color Themes.
- You can now set line thickness in the Graphs preferences menu. To access graph preferences, go to File > Preferences > Graphs.
- You can now change the default number of digits that appear in numeric columns, using the Default Field Width preference. To access table preferences, go to File > Preferences > Tables.

Printing

You can print a data table with colored cells.

Projects

- You can add project files through drag-and-drop functionality from the following locations:
– Recent Files list: Drop a file onto a variety of places:
  • Drop onto a project or project group to add the document.
  • Drop onto other parts of JMP such as the Window list or other JMP window and the file is opened within JMP.
  • Drop onto a Windows folder or desktop and the OS creates a copy of the file there.
  • Drop onto other applications such as Notepad or Word to edit the file.
– Window list: Drop a window onto a project or project group to add the window to the project (some window types are not allowed and an error message appears; for example, JMP Starter cannot be added to a project).
• The right-click menu for .sas files in projects now has the following options:
  – Open: Opens the .sas code in a script editor.
  – Submit to SAS: Attempts to submit the SAS file to the active SAS server connection.
  – Submit this Code when the Project is Opened: Attempts to submit the SAS file to the active SAS server connection. If not connected, a connection prompt appears.
You can also submit documents through JSL with the Submit To SAS() message. This is equivalent to the right-click option above.

Recent Files

On Windows, you can now pin and unpin your favorite or most-frequently used files to the Recent Files list in the Home Window. Pinned items stay at the top of the list and do not migrate off as other items are opened. Click the pin icon to toggle the pinned and unpinned state of an item.

Renew Annual License

The Renew Annual License command in the Help menu lets you select a new site ID (SID) text file or jmp.per file to renew the license. Available only in annual license copies during the 90-day grace period and 31 days before the license expires.

SAS Datasets

• When opening a SAS dataset, JMP now has the option to set column names from either SAS variable labels or SAS variable names, providing more variations to choose from when creating a data table. To access this feature, select File > Open > Select a SAS Database.
• When importing or saving a SAS dataset, you can now include or store JMP metadata (such as, column and table properties) as extended attributes. To access this feature, select Apply table and column properties from SAS 9.4 extended attributes or Store table and column properties in SAS 9.4 extended attributes.
• New sampling options (auto-sampling and specifying the number of columns) have been added when importing SAS data. To access this feature, select **Import Options** on the Browse SAS Data window.

### SAS Import Sampling

Often a SAS data set is too large to open up entirely in memory and on your desktop machine. Or, for exploratory data analysis, it might be advisable to sample a subset of the data set for more efficient modeling, visualization and analysis. The same might be true if your data resides in large, flat text files. Prior to JMP 11, it was difficult to deal with these enormous data sources. Even when taking a sample of the data, the entire data set first had to fit in memory. JMP 11 now uses powerful routines from SAS’ data mining software, SAS Enterprise Miner, so you can sample data sets before importing them into JMP. You have complete flexibility in how you take the sample, so fewer steps are required for pre-analytic data cleanup and preparation. The next time you are faced with a massive SAS data set, remember that you can conduct exploratory data analysis, modeling, and visualization on a subset of the data. Similar sampling provisions also exist for text files that would be otherwise too large to fit in memory.

![SAS Import Options Panel](image)

### SAS Integration

JMP now supports the SAS 9.4 IOM interface. SAS 9.4 connection profiles are placed into a separate file from SAS 9.3 profiles.

- On Windows, SAS 9.4 IOM user profiles are now stored in `ConfigurationV61.xml`. This file is in `%USERPROFILE%\AppData\Local\SAS\MetadataServerProfiles`. WIP profiles are in `JMPWIPProfiles94.xml` in the same directory.

- On Macintosh, SAS 9.4 IOM user profiles are now stored in `JMPMetaProfiles94.xml`. Work in Process (WIP) profiles are in `JMPWIPProfiles94.xml`, in `~/Library/Application Support/JMP`.

### Select Columns Filter

In the Select Columns filter, on certain launch windows, you can exclude columns with certain numeric formats using the **Exclude Formats** options. You can also specify whether to show
grouped and/or ungrouped columns through the Column Groups or Ungrouped Columns options.

**Show Tree Structure**

Show Tree Structure functionality has been improved. Show Tree Structure opens a window that shows the display boxes that make up the report. This is mainly used by JSL programmers who are manipulating or reading parts of the report. The new format is easier to read and browse, and placing your cursor over a section highlights the corresponding box in the platform. Likewise, if you select a box in the platform, the corresponding section is highlighted in the tree.

To access this feature, right-click the disclosure icon on a report and then select Edit > Show Tree Structure.

The old tree structure is still available. Hold down the Shift key and then select Edit > Show Tree Structure.

**Subsetting Text Import Files**

When importing a text file through the text import interface or from JSL, you can specify the first line, the last line, or random lines, as well as an approximate fraction of the data to import. This is important when handling large sets of data.

To edit import settings, go to File > Open > “sample.txt file”. On the Open Data File window, select Data with Preview (Macintosh - select Data (Using Preview)), and then click Open. On the Import preview window, under Subset, select an import option. Click Next and then Import.

**Summary Statistics**

New summary statistics (N Categories, Interquartile Range) have been added to the Tables Summary option, as well as the Tabulate option. They can be found in two places: Tables > Summary > Statistics or Analyze > Tabulate.

**Touchscreen Support**

If you have a touchscreen, you can pan and zoom on most graphs and axes in JMP. Graphs and axes change scale and zoom out if pinched, and zoom in if stretched.

**Transform Columns**

You can now create temporary virtual columns to explore relationships between variables in your data, and create formulas on the fly without having to make a new column or enter a formula. The transform column involves a transformation of a real column in your data. The transform column has a formula but stores no data, and does not appear in your data table until you decide to add it.
Right-click a column name in a Select Columns list to open a menu of common transformations and commands (Date/Time, Character, Transform, Aggregate, Row, Formula). The menu is dependent on the selected column types. Date and time transformations are available only for date-formatted columns.

A Group By submenu exists for nominal and ordinal columns only. The option enables you to toggle columns to act as grouping variables. Once denoted, the variables are indicated by a menu item listing the current grouping by variables.

There are two different lists of numeric transformations, depending on whether there is one or more than one column selected. If multiple numeric columns are selected, a separate menu items appears (Combine). The Aggregate submenu has Column Stat functions and the Formula submenu brings up a Custom Transfer window where you can completely customize the transformation.

Once created, you can right-click the name of the transform column in the list and select Rename to change the name of the transform column, Add to Data Table to add the transform column to your data, or Remove Transform Column to remove the transform column from the list.

Windows

- Many JMP windows that are associated with a file (.jsl, .jmp, and so on) and various host windows (including Application Builder, data tables, Debugger, Log, SAS Code, SAS Log, SAS Output, and Script) remember their previously opened positions and sizes.
- For some JMP file types, you can use the Windows Explorer’s preview pane to view a snapshot of the selected file. This feature works for JMP data tables, journals, and scripts.

Multivariate Methods

This section describes new features and enhancements in the multivariate methods platforms.

Discriminant Analysis

- Results for Total Canonical Structure, Between Canonical Structure, Pooled Within Canonical Structure and Class Means on Canonical Variables were added to the Canonical Plot details section. To view the results, select Canonical Options > Show Canonical Details from the Discriminant Analysis red triangle menu.
- A new section, Score Summaries, has been added to the report. The summary includes the number and percent of mis-classified points, and counts for actual rows by predicted columns.
Hierarchical Clustering

- A new option, **Standardize Robustly**, has been added to the launch window of the Cluster platform. When a column in a hierarchical clustering has outliers, it inflates the estimate of the standard deviation, thus deflating most values of the standardized data, making it less a factor in the multivariate distances used in the clustering. Selecting this option makes the outliers stick out even more, causing more isolated clusters, but the clustering as a whole is richer with the contributions of the previously downweighted columns.

- The command **Save Cluster Tree** has been added to the red triangle menu in the Cluster platform. This command is similar to the existing **Save Cluster Hierarchy**, but generates only one row for each new cluster, instead of three. The feature is useful when comparing cluster trees from JMP and SAS.

- A new option, **Constellation Plot**, has been added to the red triangle menu in the Cluster platform. This option creates a constellation plot that arranges the individuals as endpoints and each cluster join as a new point, with lines drawn that represent membership. The new command **Save Constellation Coordinates** saves the plot coordinates to the data table.

Partial Least Squares

The Partial Least Squares (PLS) platform fits linear models based on factors, namely, linear combinations of the explanatory variables (Xs). These factors are obtained in a way that attempts to maximize the covariance between the Xs and the response or responses (Ys). PLS exploits the correlations between the Xs and the Ys to reveal underlying latent structures.

In contrast to ordinary least squares, PLS can be used when the predictors outnumber the observations. PLS is used widely in modeling high-dimensional data in areas such as spectroscopy, chemometrics, genomics, psychology, education, economics, political science, and environmental science.

Partial least squares performs well in situations such as the following, where the use of ordinary least squares does not produce satisfactory results: More X variables than observations; highly correlated X variables; a large number of X variables; several Y variables and many X variables.

- You can now select specific columns in the VIP vs Coefficients plots and the columns are selected in the data table. You can then launch a platform and the selected columns remain selected in the launch window. To access this feature, select **VIP vs Coefficients Plots** from the red triangle menu in Fit Results. Then, if you want to launch the Partial Least Squares platform, select the **Make Model Using Selection** button. Otherwise, open the desired platform. Alternatively, you can choose the **Make Model Using VIP** button, which populates the launch window with variables whose VIPs exceed the specified threshold.

- Two plots are now displayed as separate reports: the Variable Importance Plot and the Variable Importance Table.

- Missing data imputation on any X or Y variable is now available through an **Impute Missing Data** check box on the launch window. You can impute missing data using an iterative
expectation-maximization method (EM), or the average of the nonmissing values for that variable.

If **Impute Missing Data** is selected, you can select **Save Imputation** from the red triangle menu on the report, which opens a new data table that contains the columns specified as X and Y, with missing values replaced by their imputed values. If a Validation column is specified, this column is also included.

- You can fit a Response Surface model with a Partial Least Squares personality in the Fit Model platform in JMP Pro. To access this feature, select **Analyze > Fit Model** and select **Partial Least Squares** from the Personality list. Then, select **Response Surface** from the Macros list.
- **Standardize X** is a new option, found on the Fit Model launch window when Partial Least Squares is selected. This option centers and scales individual variables that are included in a polynomial effect before applying the Centering and Scaling options.
- Partial Least Squares now allows the option to enter a validation column as do other platforms. If the validation column has more than three levels, then KFold Cross Validation is used. If the validation column has two levels, the smaller value defines the training set and the larger value defines the validation set. If there are three levels, the values define the training, validation, and test sets in order of increasing size.
- You can now choose **Leave-One-Out** as an option under Validation Method. This option performs leave-one-out cross validation for the analysis.

### Principal Components

Select the **Label Variables** box on the Principal Components Report to toggle the labels in Principal Component plots. Labels are turned off by default if there are more than 30 variables.

### Profilers

This section describes new features and enhancements in the profiler platforms.

#### Contour Profiler

The following items have been added to the red triangle menu in the Contour Profiler:

- Go to **Contour Profiler > Grid Density** to alter grid resolution dimensions for a more defined grid. The default resolution has been increased from 30 x 30 to 40 x 40, and additional options of 50 x 50 and 60 x 60 have been added.
- The **Set Contours to Current** option resets contour lines to where the current Y values are located.
- The following commands were added to the Contour Profiler red triangle menu:
- Arrange X Controls Left - rearranges the X and Y controls horizontally with the X controls on the left or vertical with the X controls at the top.
- Hide X Controls - shows or hides the X controls (Factor section).
- Hide Y Controls - shows or hides the Y controls (Response section).

**Prediction Profiler**

A new option, *Assess Variable Importance*, provides methods for assessing the importance of factors in a model-independent fashion. Profilers provide a number of highly interactive cross-sectional views of any response surface. But with large models, the task of assessing variable importance thorough visual inspection can be tedious. The *Assess Variable Importance* option provides a summary report that you can use to perform sensitivity analysis. The report shows each factor’s main effect and total effect importance. From the variable importance report, you can easily reorder the profiler by main or total effect importance. This is a huge time-saver with models, which might have dozens of predictors.

Select *Assess Variable Importance* from the Prediction Profiler red triangle menu to access this feature.

**Quality and Process Methods**

This section describes new features and enhancements in the quality and process platforms.

**Capability**

- You can now work with data sets with one-sided specification limits. If you have one-sided variables, the goal plot and the box plots are color coded to match the LSL (red) or USL (blue) column appropriately. To launch the platform, go to Analyze > Quality and Process > Capability.
- You can reorder box plots, capability indices reports, and individual details reports based on Cpk. To access the feature from the Capability red triangle menu, select Order By and then Initial Order, Reverse Initial Order, CPK Ascending, or CPK Descending.

**Control Chart Builder**

Note that several of the right-click menu options (Points, Limits, Warnings) are now easily accessible on the left-hand side of the window. To launch the platform, go to Analyze > Quality and Process > Control Chart Builder.
- Attribute charts (P, NP, U, and C) are now available.
- You can now assign a By role to a column to identify the variable and produce a separate analysis for each value that appears in the column.
• Rare event charts (G and T) are now available. Rare event charts are helpful when you know your data will not follow a normal distribution (for example, when measuring counts or wait times). If you plot this type of data using a standard Shewhart control chart, you might see many more false signals, as the limits might be too narrow.

Figure 1.22  G Chart Example

• An Event Chooser has been added that allows the chart to respond in real time to selection changes. There are several standard groups of responses that are recognized and pre-scored (for example, pass/fail, yes/no, Likert Scales, conforming/non-conforming, and defective/non-defective). If you are analyzing results from a survey and want to focus solely on a specific sector of the results for one or more questions, you can make the selection on the screen and the chart rescores and replots the chart immediately. The Event Chooser is available for attribute charts and does not appear for continuous variables.
Diagrams

Cause-and-Effect diagrams now accept both character and numeric data values. To launch the platform, go to Analyze > Quality and Process > Diagram.

Measurement Systems Analysis

- More model options (Main, Crossed with Two Factor Interactions, Cross then Nested (3 Factors Only), Nested then Crossed (3 Factors Only)) have been added to the Measurement Systems Analysis platform.

To launch the Measurement Systems Analysis platform, select Analyze > Quality and Process > Measurement Systems Analysis. The following Model Types are available on the Measurement Systems Analysis launch window:

- Main: variables with nominal or ordinal modeling types are treated as main effects.
- Crossed: the model is crossed when every level of every factor occurs with every level of every other factor.
- Crossed with Two Factor Interactions: the model is crossed when each level of two factors occurs with every level of the other factor.
- Nested: the model is nested when all levels of a factor appear within only a single level of any other factor.
- Cross then Nested (3 Factors Only): the factors are crossed and then nested for 3 factors.
Highlights in JMP 11
Reliability and Survival

- Nested then Crossed (3 Factors Only): the factors are nested and then crossed for 3 factors.

- Confidence Intervals have been added to the Shift Detection Profiler. The profiler provides an interactive set of charts that you can adjust to probabilities of getting warnings on process behavior charts and is accessible through the red triangle menu on the Measurement Systems Analysis report.

- You can now change the process sigma value in the Shift Detection Profiler. The value is originally set to the estimated part standard deviation. Select Change Process Sigma from the Shift Detection Profiler red triangle menu to change the value.

- An Analysis of Mean Ranges chart is now included in the report through the Test-Retest Error Comparison option for cases where ranges are used for variance components. An Analysis of Means Variances chart was incorporated in version 10. Select Test-Retest Error Comparison from the Measurement Systems Analysis red triangle menu to view the chart.

---

Reliability and Survival

This section describes new features and enhancements in the reliability and survival platforms.

Degradation

A nonlinear degradation model has been added to the Degradation platform. Although similar to the existing reaction model (Reaction Rate), the Reaction Rate Type 1 model contains an offset term that changes the basic assumption concerning the response value’s sign. To launch the diagram, go to Analyze > Reliability and Survival > Degradation. To model a nonlinear degradation path, select Degradation Path > Nonlinear Path from the Degradation Data Analysis red triangle menu. Then select Reaction Rate Type 1 from the list initially labeled Empty.

Fit Parametric Survival

A Censor value option has been added to the Fit Parametric Survival platform to allow nonzero values (character and numeric) to indicate censored observations in the censor column.

To launch the platform, go to Analyze > Reliability and Survival > Fit Parametric Survival. The Censor Code field is available on the launch window under Distribution.

Life Distribution

- The Mean Remaining Life option has been extended to the following distributions: Normal, SEV, Logistic, and LEV. The calculation estimates the mean remaining life of a unit. This
statistic was already available for the Lognormal, Weibull, Loglogistic, Fréchet, and Exponential distributions.

- The Life Distribution platform now supports several ways of specifying prior information, other than location and scale. To access the feature, under the Parametric Estimate red triangle menu, select **Bayesian Estimates**. Under the **Bayesian Estimates** red triangle menu, select one of three items: **Location and Scale Priors**, **Quantile and Parameter Priors**, or **Failure Probability Priors**. Selecting one shows the corresponding information.

- Histograms have been added to the Posterior Scatterplot report to better display the marginal distribution. An associated one-dimensional plot is also shown if one prior is a point mass. To access the feature, under the **Parametric Estimate** red triangle menu, select **Bayesian Estimates**. On the **Bayesian Estimation** report, select **Fit Model**. The **Posterior Scatterplot** report appears as a one-dimensional histogram plot for the marginal point mass distribution.

- The Competing Cause report now supports nearly all available distributions in the Life Distribution platform, including ZI/TH/DS families, fixed parameter models, and Bayesian models. To view a Competing Cause report, select a **Failure Cause** column in the launch window. The resulting Competing Cause report contains Cause Combinations, Statistics, and Individual Causes reports.

New options on the launch window also enable you to incorporate failure modes using several types of distribution models.

- A new preference, **Weibayes Only for Zero Failure Data**, has been added that ensures the Weibayes method is used for zero failure data analysis. The preference is on by default. If you have zero failure data and want to run a full Bayesian estimation, you can uncheck the option to run a full analysis. The following note has been added to the Weibayes report: Uncheck Weibayes Only for Zero Failure Data preference to allow for more options. To access the option, select **File > Preferences > Platform > Life Distribution**.

**Reliability Block Diagram**

Reliability Block Diagram is a new platform that demonstrates how component reliability contributes to the success or failure of a complex system, and defines the interaction of failures within a system that are required to maintain operation. The Reliability Block Diagram platform predicts the reliability of your whole system and determines the performance that you can expect based on the current performance of the modules.

Use Reliability Block Diagram for system design and fix weak spots in your system. You can create flow diagrams and save the designs into a library. You can then perform what-if analyses by looking at different designs and comparing plots across multiple system designs. You can also determine the best places to add redundancy and decrease the probability of a system failure.

To access the platform, go to **Analyze > Reliability and Survival > Reliability Block Diagram**.
Reliability Growth

- Reliability Growth now handles missing data. Previously, missing observations were deleted.

- A new plot, Duane Plot, has been added to the Reliability Growth report. The plot displays the Cumulative MTBF estimates on the Y axis versus a time to event variable on the X axis. The results demonstrate the visual fit of the Duane model because the fitted line model is straight on log-log paper. To access the plot, click the Duane Plot disclosure button in the Observed Data section on the Reliability Growth report.
Sample Data

Sample Data Tables

New sample data tables demonstrate features such as the new Uplift and Generalized Regression platforms. Several new and legacy sample data tables include scripts that take advantage of Graph Builder mapping features. Reliability sample data were renovated with new scripts, value labels, and other features.

Table 1.2 Sample Data for New Features

<table>
<thead>
<tr>
<th>Data Table</th>
<th>Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consumer Preferences.jmp</td>
<td>Categorical, Columns Viewer, and Response Screening and Categorical</td>
</tr>
<tr>
<td>Adverse Reactions.jmp, Bottle Tops.jmp, Cabinet Defects.jmp, Fan Burnout.jmp, Orange Juice.jmp</td>
<td>Control Chart Builder</td>
</tr>
<tr>
<td>Diabetes.jmp, Fishing.jmp, Liver Cancer.jmp</td>
<td>Generalized Regression</td>
</tr>
<tr>
<td>Cholesterol Stacked.jmp, Split Plot.jmp, Tiretread Stacked.jmp, Uniformity Trial.jmp, Wheat.jmp</td>
<td>Mixed Model</td>
</tr>
<tr>
<td>Drosophila Aging.jmp</td>
<td>Response Screening</td>
</tr>
<tr>
<td>Drug Toxicity.jmp, Weight Measurements.jmp</td>
<td>Robust Fit</td>
</tr>
<tr>
<td>San Francisco Crime.jmp</td>
<td>Street Map Service</td>
</tr>
</tbody>
</table>
Highlights in JMP 11

Scripting

Table 1.2 Sample Data for New Features

<table>
<thead>
<tr>
<th>Data Table</th>
<th>Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hair Care Product.jmp</td>
<td>Uplift</td>
</tr>
</tbody>
</table>

Graph Builder Scripts

Graph Builder scripts, including many map scripts, were added to the following sample data tables:

Big Class.jmp, Car Physical Data.jmp, Children’s Popularity.jmp, Cities.jmp, CrimeData.jmp, Iris.jmp, Napoleon March.jmp, Pollutants Map.jmp (includes a Street Map script), Popcorn.jmp, Profit by Product.jmp, SAT.jmp, SATbyYear.jmp, Titanic Passengers.jmp, US Election.jmp, World Demographics.jmp

The following new sample data tables include Graph Builder scripts in addition to other scripts:


Control Chart Builder Scripts

New Control Chart Builder scripts were added to the following sample data tables:

Airport.jmp, Coating.jmp, Diameter.jmp, Fabric.jmp, Pickles.jmp, Shirts.jmp, Socket Thickness.jmp, Washers.jmp

Other New Sample Data

Air Traffic.jmp, Bacteria.jmp, Body Fat.jmp, Caffeine Time.jmp, Circuit Board Production.jmp, Endometrial Cancer.jmp, Olive Oil.jmp, Restaurant Tips.jmp, Singularity.jmp, Table Production.jmp, Tool Wear.jmp

Updated Data

More recent data were added to the following sample data tables:

Birth Death.jmp, Cities.jmp, Presidential Elections.jmp, World Demographics.jmp

Sample Import Data

Team Results.xlsx was added to the JMP Samples/Import Data folder. In Discovering JMP and Using JMP, the file is used for examples of the Excel Wizard.

Scripting

This section describes new features and enhancements in the scripting area.
Add-In Builder

You can now create multiple levels of submenus and add-ins using the Add-In Builder.

Application Builder

- You can add a view of a JMP data table as a display box. The object is included in the Application Builder window’s list of Data Table objects.
- Multiple data tables and associated reports can be combined into a single application.
- The following sample data tables include JMP application scripts: 2 Factors Crossed.jmp, Big Class.jmp, Hollywood Movies.jmp, and San Francisco Crime.jmp. These are examples of combining a data table and associated reports in a single application.
- General improvements have been made to the interface to make it easier to build custom applications. You can now reference data tables and resize windows. You can also quickly hide or show the left and right panels by selecting Show Sources or Show Objects and Properties Panel through the red triangle menu.
- Application Builder now offers more flexible window combinations, including stretchable window arrangements for embedded data tables and resizable graphics.
- Number Edit Box() includes new formatting features, including the ability to select date and time options. Drag and drop Number Edit Box to the workspace and then select a date and time by clicking Format .... Select Date or Time from the list and then specify the date or time format respectively.
- Splitter Box() and Spin Box() have been added. The Splitter Box enables you to create display layouts that can be dynamically resized. The Spin Box is a button with up and down arrows.
- A new sample application, Graph Launcher.jmpappsource, has been added that lets you enter an equation and axes settings, and then create a graph. The initial window remains open, so you can modify the equation and create new graphs.
- The Instant App Customized.jmpappsource sample application is a modified version of Instant App.jmpappsource. Options for selecting the principal components report, changing the marker size, and showing means are included.

As List

Applying As List() to a matrix with no elements now creates an empty list.

Check Box

You can specify the title for a Check Box() inside a Table Box(). Previously, only String Col Box() and Number Col Box() offered title options in a Table Box.
Column States

The following commands have been added to return the different states of a column:

```julia
col << Get Hidden();
col << Get Excluded();
col << Get Labelled();
col << Get Scroll Locked();
```

Column Switcher

- Use `<< Remove Column Switcher` to remove a column switcher. `obj<<Remove Column Switcher` removes the most recently added Column Switcher, or you can pass the message to a specific Column Switcher object.
- Multiple column switchers are now stacked.
- The following methods were added to `Column Switcher()` to specify the number of columns to display (set n lines) and set the width in terms of number of pixels (set size):
  ```julia
  Column Switcher Object << Set Size
  Column Switcher Object << Set nlines
  ```
- Column Switcher code is included in saved scripts.

Combo Box

`Combo Box()` can return an editable text field. Users select a predefined list item or enter a new value.

```julia
Combo Box( {"hamburger", "salad", "fruit"}, editable )
```

Cytometry Logicle

The following commands have been added to compute the cytometry logicle transformation (or the inverse):

```julia
Cytometry Logicle
Cytometry Logicle Inverse
```

Data Table

- JSL functionality for grouped columns has been embellished. New commands include:
  - `Get column group names()` - gets the list of names of all the column groups
  - `Get column group (xxx)` - gets the list of columns that belong to the group named "xxx"
  - `Select column groups({"g1", "g2"...})` - selects the groups named "g1", "g2", if no groups are given, all the groups are selected
– Deselect column groups({"g1", "g2"...}) - deselects the groups name "g1","g2", if no groups are given, all the groups are deselected
– Rename column group("xxx", "yyy") - renames the group called "xxx" to "yyy"

Enhancements include:

Group columns(name, collist) - where name is the name of the group, collist is a list of columns - adds collist to the group if the group already exists

Group columns(name, collist) - now returns the name of the group

• You can now change the column height through the following commands:
  dt << get header display height; - gets the current column heading display height
  dt << set header display height(30); - changes the column heading display height
  The second command also returns the new height, so you can check whether the height has been successfully changed or not.

• You can also change the column width:
  w = col << get display width; - gets the display width (in pixels) of the column
  w = col << set display width(x); - sets the display width of the column, where x is width in pixels
  w = dt << get row ID width; - gets the display width (in pixels) of the row ID area
  w = dt << set row ID width(x); - sets the display width of the row ID area, where x is width in pixels
  
  where col is a column, dt is a data table, and x is an integer.

• Close the side panel or data table grid. If you close both the panel and the grid in a script, the last one that you closed remains closed.
  dt << Close Side Panels(1);
  dt << Close Data Grid(1);

• The New Data Box message lets you embed a linked data table view inside a display box. Experiment with an example in the JMP Help > Scripting Index.

• To scroll the data table all the way to the left, putting the first column into view, use the following command:
  dt << goto (1);

• The Get Column Reference command returns a list containing references of columns.

• You can now obtain a list of all column properties assigned to a column through the message obj << Get Properties List().

• The Invisible option is available for all table functions.

• Concatenate now accepts a list of table names.

Declare Function

Two new options, Quiet and Verbose, have been added to Load DLL() and Load TKDLL() to suppress or allow the log output of the Declare Function() message.
Desktop Path Variable

In scripts, you can use the $DESKTOP variable as a shortcut to your computer’s desktop.

Display Boxes

A new display message was added to obtain a specific window’s Window Class Name. This differs from obtaining the Class Name of a display object. Results that can be returned from this new message include:

- DataTable
- FormulaEditor
- Starter
- Journal
- Layout
- Launcher
- Report
- Dialog
- DialogWithMenu
- ModalDialog
- FindReplace
- User
- Generic
- ToolWindow
- FindReplace
- AppBuilder
- Debugger

Formula Editor

The following random variable-generating functions have been added to the Formula Editor:

- Random ChiSquare (df, <noncentral=0>)
- Random T (df, <noncentral=0>)
- Random F (dfn, dfd, <noncentral=0>)

Functions

The following JSL functions were added:

- File Size(path) returns the size of a file.
• Is Directory(path) determines whether the given path is a directory.
• Is File(path) determines whether the given path is a file.
• Is File Writable(path) determines whether the given file path is writable.
• Is Directory Writable(path) determines whether the given directory path is writable.
• Set Environment Variable() sets the value of the specified environment variable to the value specified. If the second argument is missing or is an empty string, the environment variable is deleted from the JMP process environment variable table.
• Titlecase() converts to title case; the initial uppercase character and subsequent lowercase characters.
• Collapse Whitespace() trims leading and trailing whitespace and removes duplicate interior whitespaces. If more than one whitespace character is present, the function replaces the two spaces with one space.
• Trim Whitespace() removes leading and trailing whitespace and replaces internal whitespace runs with a single space character.
• Trim() only removes leading and/or trailing whitespace and does not handle internal whitespace runs
• HP Time() returns a high precision time value in microseconds. Only useful relative to another HP Time() value. The time value represents the number of microseconds since the start of the JMP session.

Include

Files recognized as text files can now be processed through the Include() function. This includes files with extensions .txt, .dat, .tsv, and .csv.

Integrate

JMP provides numeric integration with the function Integrate(). The argument and result must be scalar-valued.

result = Integrate(expr,name,lower,upper);

Optional arguments:

Tolerance(1e-10) a requested precision

StoreInfo(name) stores a list in name containing details from integration.

JSL Log

The JSL Log has improved error logging and annotation. The log now highlights the line of code that is failing in your scripts and provides more informative error messages.
JSL Profiler

The JSL Profiler is an option within the JSL Debugger that helps with optimization. You can profile your scripts during execution to see how much time is spent executing particular lines or how many times a particular line is executed. In the JSL Debugger, click the Profile JSL Script icon.

List Box

- `Set Tip()` sets the text to be displayed as a tooltip and can be set for individual items in the list.
- A list box can contain an image. In the following example, an image from the user’s computer appears in the first list item. The JMP nominal icon appears in the second list item.

```julia
New Window( "Example",
   List Box( 
      {{{"first", "c:\photo.gif"}, {"second","nominal"}}},
      width( 200 ),
   )
);
```

Matrix Box and Table Box

Matrix Box() and Table Box() provide a copy command in the right-click menu. In the table or matrix, right-click, and select Copy Column or Copy Table.

Mouse Box

Added messages for marking Mouse Box(). When a user selects a marked mouse box (or presses Enter when a box has focus), a faint highlight appears over the box. SetMark, GetMark, SetMarked, and GetMarked have been added.

New Window

Added support to New Window() modal dialogs to generate a result list consistent with the result value from Dialog(). The Return Result option along with Modal now indicate to the New Window() function to return a result compatible with the deprecated Dialog() function.

Number Edit Box

Number Edit Box() is integrated with the new Spin Box() and supports many new properties. See the Help > Scripting Index for examples.
Open Help

A new JSL function called *Open Help()* opens either the Scripting Index, Statistics Index, or Help Index. The first argument to *Open Help()* is the “type of help” that you want to open.

Preferences for File Locations

JSL functions for setting preferences for file locations on Windows have been added.

```
Preferences(
    File Location Settings(
        Data Files Directory( "<path>" ),
        Help Files Directory( "<path>" ),
        Installation Directory( "<path>" ),
        License File Path( "<path>" ),
        Preferences File Directory( "<path>" ),
        Save As Directory( "<path>" )
    )
)
```

The JMP installation directory is set by default. If you get a location that is not defined, no value is returned.

```
Get Preferences(File Location Settings
    Installation Directory( "C:\Program Files\SAS\JMP11" )
    Data Files Directory( "<path 1>\", 0 ))
```

Print Settings

Options have been added to *Print Settings()* to customize print preferences.

Quasi-Random Sequences Generator

JSL commands have been added that create a scripting interface to generate Sobol and Faure quasi-random, space-filling sequences. The commands can be used as a uniform random number generator, but the sequence is always the same. The matrices returned could be used as space filling sequences or as the basis for numerical integration. Such matrices might be useful for creating designs for large, stochastic simulations.

```
Sobol Quasi Random Sequence(nCol,nRow);
```

The first argument is the number of columns and the second is the number of rows.

Range Slider Box

*Range Slider Box()* returns a slider control that lets the user set both minimum and maximum values. As the sliders’ positions change, the minimum and maximum values become the lowVariable and highVariable values, and the script is run.
Highlights in JMP 11

Scripting

```julia
text = Range Slider Box(minValue, maxValue, lowVariable, highVariable, script)
```

**Run External Programs**

You can now use the `RunProgram()` function to control an external program by sending data to the program and receiving data from the program. You might use `RunProgram` as part of a system that collects data from a local machine or network.

**Save Interactive HTML**

`Save Interactive HTML()` saves the display box as a web page that includes interactive HTML 5 features. Non JMP users can then explore the data.

```julia
rbiv << Save Interactive HTML( "c:\MyInteractiveHTML.htm");
```

**Script Box**

The script editor has two personalities, a JSL Editor and a SAS Program Editor. `Script Box()` now enables you to specify the type of content (JSL, Text, or SAS).

**Script Editor**

- More editing options have been added to the Scripting Editor, including the ability to comment or uncomment code or make a segment of code uppercase or lowercase. To access these options, right-click the code in a Script window and then select Advanced > Comment Block, Uncomment Block, Make Uppercase, or Make Lowercase.
- You can now split windows in the JMP script editor for the following text file types: JSL, Log, SASCode, SASLog, SASOutput, Text, R, MATLAB, and Python.
  
To use window splitting, right-click in any text-based editor window and select Split Window and then select whether you want the split to be horizontal or vertical. Once you are in the Split Window mode you can scroll to different parts of the file being edited. Changes to either view are immediately reflected in the opposite view. To close the Split Window mode, right-click in the appropriate window and select Remove Split.

- Code folding markers have been added that allow for the expanding and collapsing of marked blocks of JSL code. You can also expand and collapse all of the code being edited using the right-click menu items Expand All and Collapse All. These menu options are available only in a read/write editor window containing JSL code. Code remains collapsed after you save the script and then restart JMP.
  
  By default, JSL code folding is disabled. To access this feature, select File > Preferences > Script Editor, and then select JSL code folding and your marker type.

- The Script Editor now has its own embedded log.
Scroll Box

- **Set Scrollers()** sets a flag for horizontal or vertical scrolling. The arguments are Boolean values, with the horizontal value first. The following example returns scroll bars that scroll vertically.

  ```julia
  sb << Set Scrollers( 0, 1 );
  ```

  Get Scrollers returns the state of the scroll bars.

- **Set Scroll Position()** specifies the vertical and horizontal position of the scroll bar. The arguments are in pixels with the horizontal value first. The following example starts the vertical scroll bar 10 pixels from the top of the display box.

  ```julia
  sb << Set Scroll Position( 0, 10 );
  ```

Spin Box

The Spin Box is a button with up and down arrows. The associated script is passed an argument indicating the direction of the click (negative = down arrow, positive = up arrow). A magnitude of 1 indicates a single-click, while larger values might indicate a repeated or accelerated action. The Help > Scripting Index in JMP includes examples for creation and messaging.

Splitter Box

A Splitter Box() has been added that enables you to create display layouts that can be dynamically resized. Like List Box, it can have multiple children and can be horizontal or vertical. Splitter Boxes can be nested to provide flexible display configurations.

To create a Splitter Box through JSL, use HSplitterBox(Size(x,y), <box1>, <box2>, ...) or VSplitterBox(Size(x,y), <box1>, <box2>, ...).

Tab Box

- **Set Style()** options provide more control over the appearance of tabbed reports.

  ```julia
  Tab Box << Set Style(tab | combo | outline | vertical spread | horizontal spread | minimize size)
  ```

  - **tab**, combo, and outline change the appearance of the tab box from a tab to a combo box or outline node.

  - **vertical spread** and **horizontal spread** change the orientation of the tab title.

  - **minimize size** bases the tab style on the width of the tab title. For example, a long tab title appears on a combo box rather than on the default tab box.

- Tips and icons can be displayed on tabs. You can control whether users can close the tab. And the mouse state (such as hovering and hovering over close) is tracked. See the TabListBox category in the Help > Scripting Index for a complete list.
Table Box

- In Table Box(), you can create spanned column headings with Col Span Box(). The top column heading spans two child column headings.
  
  ```
  box = Col Span Box( "string", columns )
  ```
- Set Cell Changed Function() lets you specify a function to call when the users edits a data table cell.
- Table Box() uses smooth scrolling on Macintosh except for tables with locked columns and controls that are shared with Windows.
- You can now sort a table box by a column.

Table Script

- JMP adds a Save to Database table script to any table opened through ODBC. Run this script to save the table back to the database, which replaces the original table.
- Saves a script for all report objects to the current data table. The script is named after the platform unless you specify the script name in quotation marks.
  
  ```
  obj << Save Script for All Objects To Data Table("My Script");
  ```

Text Box

Format text in a text box with HTML tags using the <<Markup message for bold (<b>), italic (<i>) and underline (<u>).

```
  w = NewWindow("Formatted Text",
    Text Box("This is <b>bold</b> text. This is <b><i>bold italic</i></b> text.",
    <<Markup)),
  ```

Text Edit Box

With the Hint() argument, specify placeholder text as a visual cue for the user to enter a value in the box. Placeholder text is formatted as light gray text.

```
  New Window("Example",
    TextEditBox("Current Date"),
    TextEditBox("", Hint("mm/dd/yyyy")))
  ```

Toolbar Visibility

On Windows, you can show or hide a toolbar based on the window type or for all windows through the Set Toolbar Visibility() function.
Triangulation

Two new objects change how JMP computes and displays contours: Triangulation() and Alpha Shape(). To create a triangulation, two numeric columns are required. A third column can be included as a Y. Multiple observations at the same X1, X2 are merged in the output triangulation, with an average Y.

To create a triangulation through JSL, use tri = Triangulation(X(Column1, Column2), <Y(Column)>).

From a JSL script or a JMP application, you can query the Triangulation and create Display Segs to graphically represent points, edges, triangles, or hulls.

Alpha shapes, a family of shapes derived from the Delaunay triangulation, have also been added. While the Delaunay triangulation always results in a convex shape, the Alpha Shape varies based on the selection of a parameter “alpha.” At alpha=0, the result is the same as the Delaunay triangulation. As alpha is increased, triangles are filtered out based on the radius of their circumscribed circle.

The JSL function Alpha Shape(Triangulation) returns another triangulation object, which can then be used with any function that works on triangulations, such as Contour Seg(). Contour Seg returns a Display Seg that represents the contours of a triangulation. From Contour Seg, you can set the contour lines and fill modes (above, below, between).

You can also compute a new triangulation from a subset of the points in a given triangulation. One common subset is to use all of the interior points, eliminating points on the hull to peel the points in layers. Convex Hull peeling has been used as a way to compute multivariate medians and skewness, detect outliers, and create probability contours. The JSL messages are:

newTri = Triangulation << Subset([matrix of indices])
newTri = Triangulation << Peel

Graph Builder and Contour Plot now use the Triangulation object and Contour Seg to compute and display contours. Scaling options are provided in case a normalized scale is more desirable than the default uniform scaling.

Update Data

Update capabilities are available for both JSL and tables that were previously opened with Open Database(). If the JMP data table and database table contain the same number of columns, values in the existing JMP data table (rather than in a data table) are updated when the database is refreshed.

Week of Year

Week of Year() returns the week of the year containing a date-time value. Three new rules determine when the first week of the year begins.

Week of Year( datetime, <rule = n> )
• With rule 1 (the default), weeks start on Sunday, with the first Sunday of the year being week 2. Week 1 is a partial week or empty.
• With rule 2, the first Sunday begins week 1, with previous days being week 0.
• With rule 3, the ISO-8601 week number is returned. Weeks start on Monday. Week 1 is the first week of the year with four days in that year.

Specialized Models

This section describes new features and enhancements in the specialized methods platforms.

Partition

• A Profit Matrix option is now available to enhance your predictive models. Decision rules are important when you need to act based on the consequences of various outcomes, instead of acting based solely on what is most probable. This enables you to convert a prediction model to a decision model by assigning weights to outcomes. To access the feature after you have run a report, select Specify Profit Matrix from the Partition red triangle menu. Enter profit and cost information and then save the results as a prediction formula. Be sure to select Save to column as property to save Profit Matrix as a column property (Profit Matrix is also available as a Column Property). The values are then used to create best decision columns. The best decision is the one with the greatest expected profit. You can then select Save Columns > Save Prediction Formula from the Partition red triangle menu to save the prediction formula, launch the Model Comparison platform and view the Average Profit. Profit Matrix is also available in the Neural, Nominal Logistic, and Ordinal Logistic platforms (as a Column Property).
• You can now treat both continuous and categorical missing values as informative. The Informative Missing option on the launch window, which is selected by default, fits a model that is deterministic.
  - Rows containing missing values for a categorical response or predictor are entered into the analysis as a separate level of the variable.
  - Rows containing missing values for a continuous predictor are assigned to a split as follows. The values of the continuous predictor are sorted. Missing rows are first considered to be on the low end of the sorted values. All splits are constructed. The missing rows are then considered to be on the high end of the sorted values. Again, all splits are constructed. The optimal split is determined using the LogWorth criterion. For further splits on the given predictor, the algorithm commits the missing rows to be treated as high or low values, as determined by the initial split on the predictor.
  - Rows containing missing values for a continuous response are not included in the analysis.
• You can now specify and fit multiple Ys in the platform. Each variable is treated and reported independently.
• You can now select columns using a Partition model for use in other modeling efforts. Do this by selecting the relevant columns in the Column Contributions report (Note that you can sort this report by size of contribution). Selecting the columns in the report also selects them in the data table. Be sure to clear irrelevant column selections before selecting columns in the Column Contributions report.

• New options appear on the Boosted Tree options window:
  – **Early Stopping** - select to perform early stopping. If the option is selected, the boosting process stops fitting additional stages if adding more stages does not improve the validation statistic. If not selected, the boosting process continues until the specified number of stages is reached. This option is available only if validation is used.
  – **Max Splits Per Tree** - the upper end for Splits per Tree.

**Response Screening**

A new Response Screening platform was designed to do a large number of simple fits on Responses (Ys) by Factors (Xs) across groups. The purpose is finding strong relationships in the data. The Response Screening platform performs the same fits as the Fit Y by X platforms, but on a greater scale, producing an output data table, rather than a detailed report. This output table is then easy to sort, summarize, graph, or query.
**Time Series**

A preference was added to the Time Series platform to suppress Lag 0 and start at Lag 1 for autocorrelation (ACF) and partial autocorrelation (PACF) computations. If selected, the ACF and PACF start from Lag 1. If not, then the ACF and PACF start from Lag 0, where the value is always 1. To set the preference to suppress Lag 0, select **File > Preferences > Platforms > Time Series** and select the **Suppress Lag 0 in ACF and PACF** check box. The default is off.