
Data Import, Data Table, Cleanup, 
Data Visualization, General

•	 JMP Query Builder: Ability to perform 
multi-table queries and joins of JMP 
data tables. This helps you discover 
interesting data and make correct  
queries that are repeatable and shar-
able. Additionally, you can bring in  
data from various sources (e.g., Excel, 
JMP, Oracle, SQL) and join them in 
memory using JMP Query Builder.  
Use Query Builder for SQL code  
generation and prototyping. Also 
included are filter enhancements  
for categorical variables, expanded 
preference settings for categorical 
filters, first N rows sampling, run on 
open option, auto-join improvements 
and more. 

•	 Play button to run scripts in a data table 
in one click rather than a menu choice.

•	 Improved support for “big data” 
databases including: Apache Hive, 
Cloudera Impala, Amazon Redshift, 
Amazon Aurora and Amazon MariaDB.

•	 Modeling Types have been 
expanded with None, Multiple 
Response and Unstructured Text.

•	 HDF5 file import: handles simple 
types of HDF5 files with dimension 2 
(data tables without vector cells). 

•	 File > Quick Open lets you search 
for JMP files by name without having 
to navigate through the file browser 
(Windows only).

•	 Support for Virtual Joins: Join two 
or more JMP tables without having 
to make an actual join through the 
Link ID and Link Reference column 
properties.

•	 New HTML-based help system with 
improvements to search, indexing 
and speed.

•	 Retooled formula editor makes it 
easier to create and view formulas.

•	 Modeling utilities have been moved 
to the Screening submenu of the 
Analyze menu. Predictor Screening 
(formerly known as Screen Predictors) 
joins the Screening submenu along 
with Response Screening and the 
Process Screening platforms.

•	 JSON data can be imported and 
exported.

•	 The Excel Import Wizard includes 
options for importing cell coloring, 
specifying separators in multiple- 
row headers, stacking data and  
duplicating headers in spanned rows.

New features in JMP® 13 and JMP® Pro 13

•	 Parallel plot element available in 
Graph Builder.

•	 Improvements to the Treemap 
element in Graph Builder: support 
for n-levels, drill down by clicking a 
subcategory and options for single 
color tree maps. Also, label and font 
improvements for creating easy-to-
read, complex treemaps.

•	 General improvements in Graph 
Builder: Allow specification of alpha 
level for confidence intervals. Add 
right-click menu item for Order By. 
Add option to position legend  
inside the graph (left or right). Line 
element has Connect Through  
Missing options. New Legend  
Settings menu item. Add Centered 
Step option to Line Element. Add 
Geometric Mean. Add Ellipse option 
to show correlation value. Add 
Response Axis property to Points, 
Regression, Smoother, Caption and 
Formula. For Line and Bar, tolerate 
absent X variable. Bar was treating 
no X as a single point at 0. Now it 

With Graph Builder, create a Parallel Plot to 
display multiple variables in a single graph.

If you like digging around in your data to find patterns and trends, you’ll love doing so with JMP® 13 and JMP® Pro 13. 
This newest release of SAS’ statistical discovery software empowers users to play with unstructured as well as structured 
data, reference data from other tables without the data-storage issues of joining tables, and build dashboards in a few 
clicks. Of course, those are just a few of our favorite things about 13; you can get a comprehensive list of new features 
online. Please note: The PRO icon indicates features exclusive to JMP Pro 13.

Details, details, details...
See a comprehensive list of new 
features for JMP 13 and  
JMP Pro 13.
jmp.com/release-notes
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is carried as a single point with a 
missing value, which the Line and Bar 
now handle. Allow up to two color 
and size variables in Graph Builder 
so that different elements can use  
different coloring or sizing. Add 
Show Labels option to gradient 
properties. 

•	 Active data tables, journals and 
scripts are autosaved at regular  
intervals when the Autosave  
Timeout preference is set on the 
General page.

•	 New transforms: Quantile, Day  
of Week Abbr, random sampling,  
moving average, lag.

•	 New lightness constraints in legend 
settings dialog. 

•	 New color themes: Viridis and 
Magma. 

•	 New custom number format option, 
especially useful for axis labels.

Building Dashboards  
and Sharing 

•	 The Dashboard Building mode 
of Application Builder is now the 
default. File > New Dashboard will 
bring up a template screen for easy 
building of a custom dashboard 
of JMP reports and data tables. 
Dashboards provide an interactive 
way to combine reports into a single 
window and can become a visual 
tool that lets you run and present 
reports on a regular basis with no 
scripting required.

•	 Combine Windows now includes 
options for viewing a combined 
report in summary view and/or 
adding a graph (selection) filter on 
creation. Combine Windows now 
creates a JMP dashboard in a  
single click. 

•	 New interactive HTML options 
enhance your sharing ability:

o		View > Create Web Report  
option creates a web page in 
which reports, descriptive text  
and graphics are displayed.  
The generated folder, index page 
and resulting interactive HTML 
reports can be uploaded to a 
web server for sharing interactive 
JMP reports grouped by date or 
project, for example.

o		Partial support for interactive 
HTML reports of Graph Builder.

o		Interactive HTML support for  
dashboard layouts built in  
Dashboard Builder. 

o		Value label support for interactive 
HTML reports.

o		Interactive HTML pre-flight report 
for unsupported JMP elements 
generated to the JMP log.

•	 The Generate Excel Workbook  
command in the View menu enables 
you to save multiple JMP data tables 
in a single Microsoft Excel workbook.

Design of Experiments (DOE)

•	 Fit Definitive Screening available 
in DOE menu. Specifically tailored 
modeling technique for Definitive 
Screening Designs (DSDs).

•	 The DOE menu has been modified 
with many designers grouped under 
new, descriptive headings.

•	 Addition of Number of Extra Runs 
options to the DSD. This creates a 
design that has all the alias proper-
ties of a DSD, but analysis is even 
more powerful with the extra runs. 
There are options for zero, four or 
eight extra runs, which is equivalent 
to adding extra factors and  
dropping them.

•	 Compare Designs platform: In  
previous versions of JMP, it was  
difficult to compare designs –  
especially with more than two 
designs. Now, a single report lets 
you make side-by-side comparisons 
across multiple designs.

•	 Custom Design can now simulate 
realistic data for experiments, gener-
ating count- or pass-fail-based results 
with the addition of Binomial and 
Poisson distributions to the Simulate 
Responses tool. DOE simulate script 
is also saved to the design table so 
that effects and response distribu-
tions can be adjusted after the 
design has been created.

•	 Max Diff (also known as best/worst) 
design creation now available in the 
Consumer Studies submenu of the 
DOE menu.

•	 Simulate response outputs formulas 
for use with general simulation  
functionality.  PRO

Design of Experiments Fit Definitive 
Screening Example.

Use Dashboards for an interactive way 
to combine reports into a single window 
and even run and present reports on a 
regular basis with no scripting required.

Join our User Communities
Ask a question and get answers 
from JMP experts around the 
world. Share and download  
add-ins, scripts and sample  
data. Explore special areas for  
Discovery Summit resources, 
academics, JMP administrators 
and users groups.  
community.jmp.com
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Statistics, Predictive Modeling 
and Data Mining

•	 Text Explorer: New platform to  
analyze unstructured text data. It 
provides basic tools for analyzing 
free text in surveys or engineer-
ing notes. Regular Expressions 
(RegEx) interface for creating and 
storing custom RegExs for extract-
ing part numbers, words between 
HTML tags, phone numbers, email 
addresses, currency and more.

•	 Process Screening performs control 
chart, stability and capability  
calculations for thousands of 
columns and/or groups. Process 
Screening platform joins the suite  
of Screening tools, a submenu  
of the Analyze menu.

•	 Modifications to Fit Least Squares 
default layout: Simplification of 
report output, Studentized Residual 
Outlier plot and Box-Cox transfor-
mations with refit/replace options.

•	 Fit Model and Distribution now  
support multiple response  
modeling type.

•	 Latent Class Analysis (LCA) platform 
added. LCA is a clustering technique 
for categorical variables.

•	 Much improved SVD imputation in 
Explore Missing Values.

•	 Addition of  Two One-Sided Test 
(TOST) equivalence tests in the 
Distribution platform.

•	 New curves added to the Fit Curve 
platform: Probit curve (2P and 4P 
versions); Rodbard and Hill curves. 

Fit Curve has its own launch now 
instead of requiring the Nonlinear 
platform to launch Fit Curve.

•	 Sparse PCA method addition to PCA. 

•	 Addition of a Profiler to the Partition 
platform.

•	 New Clustering submenu in the 
Analyze menu includes hierarchical, 
k-means, normal mixtures, LCA and 
cluster variables.

•	 Cox mixture models now work when 
there are process variables and when 
there is pseudocomponent coding.  
These models are not supported, 
however, for Scheffe cubic models 
or when there are terms higher than 
order 2. Cox component effects 
report added. Hidden column for the 
gradient at the reference mixture so 
that a partial or constrained effect 
can be created.

•	 Text Explorer analytics: Use the SVD 
to do latent semantic analysis.  
Perform topic analysis and LCA. Save 
the document term matrix, SVD or  
cluster probabilities. Options for 
scoring new observations. The  
ability to now use text data as  
potential predictors in other JMP Pro 
models through the SVD and other 
saved columns. PRO

•	 New modeling launch options in 
Boosted Trees and Bootstrap Forest, 
notably the ability to set the random 
seed and suppress multithreading 
for reproducible model fits. Also the 
ability to use a tuning design table 
and the addition of stochastic  
gradient descent. PRO

•	 Addition of Formula Depot platform 
to store and manage formulas. 
Generates score code for SAS, SQL, 
Python, Javascript and C. PRO

•	 Publish commands parallel to save 
commands for formula column 
scripts in many fitting platforms. 
PRO

•	 Double Lasso option added to  
the Generalized Regression  
personality of Fit Model: Performs 
an initial Adaptive Lasso pass for a 

screening and then uses the results’ 
parameters to form weights for a 
second Adaptive Lasso pass. PRO

•	 Addition of Two-Stage Forward 
Selection option to the Generalized 
Regression personality of Fit Model: 
Initial forward selection considers 
only main effects, then a second  
pass of forward selection for the 
interactions and higher-order  
terms. This technique has excellent 
properties for model selection of 
DOEs. PRO

•	 Generalized Regression general 
improvements: New model  
selection criteria, ERIC, which has 
been designed specifically for  
penalized regression problems, full 
model upon launch, ROC, lift curves 
and confusion matrices; CDF and 
quantile Profilers (like parametric 
survival), support for no intercept 
models and ordinal predictors,  
ability to save simulation formula 
that can be used in the Simulate 
utility. PRO

•	 Naive Bayes, a new method available 
in the predictive modeling submenu 
of Analyze. PRO

•	 Gaussian Process in JMP Pro offers 
faster fitting of large data sets  
using composite likelihood methods 
and the Fit Mixed computational 
framework. PRO

•	 Fit Mixed: Interdependence, Toeplitz 
and Heterogeneous variance 
models; Indicator Parameterization 
Estimates option. PRO

•	 General Simulation functionality: 
Power calculations for almost  

Text Explorer offers a highly interactive plat-
form for analyzing unstructured text data.

Watch our webcasts
Expand your skills through our 
complimentary webcast series for 
JMP users of all levels.
jmp.com/mastering
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anything (e.g., logistic regression, 
mixed models, etc.). Support for 
parametric bootstrapping and  
randomization testing. PRO

Quality Engineering, Reliability 
and Six Sigma

•	 Process Capability platform supports 
automated distribution selection  
(letting the data decide the best 
distribution); addition of probability 
plots for assessing distribution  
model fits.

•	 Support for non-normal capability 
analysis.

•	 Concurrent and Parallel systems  
reliability growth tabs added to  
Reliability Growth platform.

•	 Normal and SEV distributions added 
to Fit Parametric Survival, and a Fit 
All distribution.

•	 New addition of Cumulative Damage 
platform for analyzing time-varying-
stress accelerated life test models.

•	 Life Distribution option for Fit All 
Distributions with Cause models will 
produce reports that are hierarchi-
cally organized. 

•	 Life Distribution supports censored 
observation plot for right censored 
data. Must turn on using platform 
preference.

•	 Support for Location-Scale  
distributions in Parametric survival. 

•	 Likelihood interval can be set as the 
default through a preference in Fit 
Life by X. 

•	 Life Distribution format launch of 
Reliability Forecast allows user to 
arrange arbitrary existing risk sets.

•	 Addition of the Repairable Systems 
Simulation platform. PRO

•	 Parametric Survival supports variable 
selection through a bridge to the 
Generalized Regression personality 
of Fit Model using a launch button in 
the report. PRO

•	 The Generalized Regression  
personality of Fit Model now 
handles censored data allowing 
you to do variable selection with 
survival/reliability data; support for 
Cox Proportional Hazards in  
Distribution drop-down menu. 
Supports Weibull, LogNormal and 
Normal distributions. PRO

•	 Addition of Reliability Overlay by 
Component graph to the Reliability 
Block Diagram. PRO

Consumer and Market Research

•	 Choice Models: A “No Choice” 
option for the situation where the 
study participant does not want any 
of the proposed choices. 

•	 MaxDiff (best/worst): A new platform 
providing a variation of choice analy-
ses for ranking customer preference.

•	 New addition of the MaxDiff design 
under DOE > Consumer Studies > 
MaxDiff Design.

•	 Rate Per Response and Multiple 
Responses in outer nests added  
to the Categorical platform.

•	 Multidimensional Scaling (MDS) 
platform addition to the Consumer 
Research submenu of the Analyze 
menu.

•	 Association Analysis (Market Basket),  
a new method available in the  
Screening submenu of Analyze. 
PRO

•	 Hierarchical Bayes analysis in Choice. 
PRO

Select JSL Improvements

•	 Document-specific style support  
in script windows. 

•	 Addition of the Using Namespace (); 
function. 

•	 Significant optimization of the ways  
JSL handles lists.

Create a Multidimensional Scaling Plot 
to make comparisons among items in a 
network.

Use Cumulative Damage platform to  
perform accelerated life tests under 
increasing stress.

To contact your local JMP office, please visit: jmp.com/offices
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Customize styles for analysis, such as text 
exploration, using JSL.


