注意: 名義尺度の因子を含む計画の場合、[X行列の保存]オプションによって保存された「モデル行列」スクリプト内の計画行列は、「モデルのあてはめ」で使用される計画行列とは異なります。「モデルのあてはめ」で使用される計画行列を得るには、「モデル」スクリプトを実行した後、「モデルのあてはめ」レポートで、[列の保存]>[コーディングのテーブルを保存]を選択してください。
メモ: 行列のスクリプトが常に保存されるよう、環境設定で設定しておくことができます。それには、[ファイル]>[環境設定]>[プラットフォーム]>[実験計画(DOE)]を選択します。そして、[X行列の保存]にチェックマークをつけます。
モデル行列は、計画された実験を行列形式に記述したものです。モデル行列には、実験ごとに1つの行、「モデル」アウトラインで指定されたモデルの項ごとに1つの列が含まれます。各実験に対し、モデル行列の該当する行が、モデルの効果をコード変換した値を含みます。
モーメント行列は、モデル項に依存しますが、計画には依存しません。モーメント行列は次のように定義されます。
ここで、は因子のベクトルの組み合わせに対応するモデル効果で、Rは計画領域です。モーメント行列と計画行列の詳細については、Goos and Jones(2011、pp 88-90)およびMyers et al.(2009)を参照してください。なお、「モーメント行列」は、同書(2009; p. 376)で「領域モーメントの行列」(matrix of region moments)と呼ばれています。
前節の情報を含んだスクリプトを作成するには、「カスタム計画」の赤い三角ボタンのメニューから[X行列の保存]を選択しておきます。そうすると、計画のデータテーブルを作成したとき、「カスタム計画」テーブルに「モーメント行列」と「モデル行列」のスクリプトがテーブルプロパティとして保存されます。なお、分割計画の場合は、このときに「V逆行列」スクリプトも保存されます。
「モーメント行列」、「モデル行列」、「V逆行列」のいずれかの赤い三角ボタンから[編集]を選択します。そうすると、該当する行列に関するスクリプトが表示されます。この行列を何らかに再利用したい場合には、このスクリプトをコピーして用いてください。
ヒント: ログを表示するには、[表示]>[ログ](Macintoshでは[ウィンドウ]>[ログ])を選択します。
2.
連続尺度の因子を3個追加し、[続行]ボタンをクリックします。
3.
[交互作用]>[2次]を選択します。
4.
5.
「実験の回数」を「ユーザ定義」で「12」にして、[計画の作成]、次に[テーブルの作成]をクリックします。
スクリプトウィンドウにスクリプトが表示されます。このスクリプトは、「Moments」という名前の変数にモーメント行列を割り当てています
図3.28 「モーメント行列」スクリプト
7.
ログが表示されていないときは、[表示]>[ログ](Macintoshでは[ウィンドウ]>[ログ])を選択します。
ログに、行数がN Row(Moments)=7と表示されます。
10.
[実行]をクリックします。
ログに、行数がN Row(Moments)=12と表示されます。
dt = New Table( "モデル行列" );
dt << Set Matrix( X );
12.
[実行]をクリックします。