
New Features in JMP 8
What’s New in JMP

JMP 8 builds on the improvements seen in previous versions of JMP, adding new data access, statistics, 
and graphics commands. JMP’s scripting language also continues to expand. 

This paper provides an overview of the enhancements. For complete details of each command, see the 
appropriate entry in the main documentation.
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New Platforms

New Platforms

Graph Builder

The Graph Builder allows the interactive display of both continuous and categorical data. A variety of 
graph elements are available (scatterplots, box plots, histograms, trend lines, bar charts, smoothers for 
studying univariate and multivariate relationships). Data can be partitioned by both continuous and 
categorical variables to easily see interactions. 

The most ground-breaking feature of Graph Builder is that its graphs are built through drag-and-drop 
of variables, similar to creating tables with the Tabulate command in the Tables menu. Each drag 
shows a preview of the resulting report, allowing quick visualization of many chart types.

Launch this platform by using Graph > Graph Builder.

Choice

JMP’s Choice platform is designed for use in market research experiments, where the ultimate goal is to 
discover the preference structure of consumers and use this information to design products/services that 
possess the attributes most desired by consumers.

Features provided in JMP’s Choice platform include: 

• the ability to utilize information about consumer traits as well as product attributes;

• the integration of data from one, two, or three sources;

• the ability to use the integrated profiler to understand, visualize, and optimize the response (utility) 
surface;

• providing utility scores for segmenting/clustering your data;

• using a special default bias-corrected maximum likelihood estimator discussed by Firth (1993). 

The Firth method has been shown to produce better estimates and tests than MLEs without bias cor-
rection. In addition, bias-corrected MLEs ameliorate separation problems that tend to occur in logis-
tic-type models. Refer to Heinze and Schemper (2002) for a discussion of the separation problem in 
logistic regression.

Launch this platform by using Analyze > Modeling > Choice.
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New Platforms

Choice Design

The Design of Experiments platform in JMP can make optimal choice designs that can be analyzed in 
the choice platform.

Launch this platform using DOE > Choice Design.

Life Distribution

With this platform, you can find the most suitable distributional fit for your time-to-event data and 
make predictions. Weibull, Lognormal, Fréchet, Extreme Value, and other common distributions used 
in Reliability and Survival analysis are included.

Launch this platform by using Analyze > Reliability and Survival > Life Distribution.

Fit Life by X

The Fit Life by X Platform helps you analyze lifetime events for accelerated test data when only one fac-
tor is present. This platform is listed as the second option under the Reliability and Survival menu.

If the factor is continuous or ordinal numeric, you may choose to model the relationship between the 
event and the factor using various transformations. Available transformations include Arrhenius, volt-
age, and linear. JMP’s Fit Life by X platform also allows you to create a custom transformation of your 
data. 

You can compare different distributions at the same factor level or the same distribution across different 
factor levels.

Launch this platform by using Analyze > Reliability and Survival > Fit Life by X.
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User Assistance Improvements

Projects

• In addition to restoring everything (or nothing) in a project, you can now specify individual items 
that are restored when the project is reopened.

• When opening a previously-archived project file, JMP is now able to detect changes from external 
applications and will prompt to re-save the project when it is closed.

• You can now include a reference to a SAS Stored Process in a JMP project. 

• There is a new option Add All Windows, which adds all currently open JMP windows to a project.

File Import

• The text import previewer has been completely re-written with an improved user interface. Delim-
ited and fixed-width files are now imported using a point-and-click interface.

• The Internet Open facility has been streamlined, and now defaults to importing an HTML table as 
a JMP file.

Data Table Improvements
• The data table grid's cell area now has its own font (set in Preferences).

• International currencies are now supported.

• Columns can be grouped so that they appear as a single item in the data table columns panel and 
launch dialogs. 

• On the Tables Panel, you can now rearrange the table variables and table properties in Table Panel 
by drag and drop.
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Data Table Improvements

• There is now one modeless portable dialog for find/replace. All searchable windows (for example, 
the data grid, a script window, the log) use the same basic dialog. It changes personality depending 
on the active search target.

The dialog now supports host-dependent behavior. 

– On Macintosh, the command Replace replaces the selected text.

– On Windows, the command Replace replaces the selected text only if the selected text matches 
the string in the Find What box. Otherwise, it performs a Find operation.

• ODBC import has been improved to allow better use of schemas and to perform better.

• ODBC import is now asynchronous on Windows, which improves responsiveness.

Column Info

• You can insert a new item before a selected item in the List Check and Value Ordering lists. Just 
select the item you want the new item to precede, then add the item.

• Missing values can now be labeled through Value Labels.

• Value labels now allow ranges for numeric columns.

Table Operations 

• There is now a Keep Dialog Open option in all Tables menu commands to keep dialogs open after 
processing the command.

• All dialogs for Tables menu commands now support Recall.

• JMP 8 now saves numeric data in the host machine’s native format. However, this means that earlier 
versions of JMP (JMP 5 and earlier) might not be able to read JMP 8 data tables if the JMP 8 data 
table is saved on one machine and opened on another. To use JMP 8 data tables for JMP 5 or earlier, 
save the data table using the option Use JMP V5 Format.

Summary

Summary tables now categorize by value labels. If a grouping column has value labels and the option 
Use Value Labels is selected, the data is grouped based on the value labels.

Subset

• A new option is added to Subset to allow stratified random sampling. Proportional allocation is 
used to generate the subset in each group.

• When you select a random sample (by specifying either its sample size or a sampling rate) and the 
sample size is the entire source table, the result is a random shuffle of the rows of the data table. If 
there are stratification columns, then the you get a random shuffle of the rows for each group.

• If sample size is specified and there are stratification columns, the sample size is the size per stratum, 
instead of the size of the whole subset. There are also two columns that can optionally be saved for 
stratified random subsets, Selection Probability and Sampling Weight.



N
e
w

 F
e
a
tu

re
s
 in

 J
M

P
 8

 New Features in JMP 8 7
Design of Experiments Improvements

Stack

• Multiple series stack has a new option, Contiguous, which specifies that the columns for each 
series are contiguous. 

Tabulate

• You can now insert a table between two tables.

• Tabulate now uses the common order for grouping columns.

Rows

• Rows > Row Selection > Select Dominant selects the Pareto frontier points. You are first 
prompted to choose high or low values, and which columns to use.

• Rows > Row Selection > Name Selection in Column lets you assign one value to the selected 
rows, another value to the unselected rows, and store all the values in a new column, which you can 
name.

• Select Where now lets you compare values in two columns of the same data table. 

Design of Experiments Improvements
A new design diagnostics outline node is present for all JMP designs, with reports for

• Prediction Variance Profile

• Fraction of Design Space (FDS) Plot

• Prediction Variance Surface

• Relative Variance of the coefficients, which now has a column showing the power of the design as 
specified to detect effects of a given size

• Alias Matrix

• Design Diagnostics, which includes G&A efficiencies, average variance of prediction, and design 
creation time

Also, the algorithms for designs with constraints and mixture factors have been reworked, and diagnos-
tics like the prediction variance profiler and the FDS plots respect the constraints used to calculate the 
design. 

Analyze Menu Improvements

Distribution

• New distributions are available in the list of fitted distribution:
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Analyze Menu Improvements

GLog (Generalized Logarithm) (µ, σ, λ) This distribution is a transformation to normal. It's 
useful for fitting biological assay data, which are rarely normally distributed and often have 
non-constant variance. When the parameter λ = 0, the distribution reduces to a 
Lognormal(µ, σ).

Beta Binomial (n, p, σ) is useful for fitting overdiserpsed count data. The distribution results 
from assuming that x|p is binomially distributed while p follows a beta distribution. Here, σ is a 
dispersion parameter. When σ < 0, the data are underdispersed. When σ > 0, the data are overd-
ispersed. When σ = 0, the beta binomial reduces to the binomial(n, p).

Gamma Poisson (λ, σ) is useful for fitting count data that exhibit extra Poisson variation. The 
distribution results from assuming that x|λ has a Poisson distribution while λ follows a gamma 
distribution. When σ > 1, the data are overdispersed. When σ = 1, the gamma-Poisson reduces 
to the Poisson(λ).

• All is a new option for continuous distributions under Continuous Fit, at the bottom of the list. All 
fits all available continuous distributions. (Some are not available when the data is negative.) In the 
Compare Distributions report, all the distributions are sorted in order of AICc, where

and

k = the number of parameters and

n = the sample size

AIC = 2k–2log(L)

By default, the distribution with the lowest AICc is fit, the curve is overlaid on the histogram, and 
the fit report is revealed. Click on a box next to other distributions to display the curve and fit 
report.

A smaller AICc represents a better fit.

Fit Model - All Possible Models

The Stepwise Regression fit contains a new optional command, All Possible Models. This feature 
allows you to specify the maximum number of terms to fit in a model as well as the number of best 
models to view. The resulting report shows the number of variables and the RSquare, RMSE, and AICc 
values for each model. The models are listed in increasing order of the number of parameters they con-
tain, and the model with the highest R2 for each number of parameters is highlighted. Radio buttons 
are provided for each model and allow you to select and run an analysis for that model.

Fit Model - Model Averaging

The Stepwise Regression fit now includes a Model Averaging option. 

AICc AIC 2k k 1+( )
n k– 1–
----------------------+=
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You are prompted to enter the maximum number of terms for the resulting model and a value that is 
used as the cutoff of the total AICc weight.

Model averaging is a technique which, instead of picking a single best model, allows you to average the 
fits for a number of models. The result is a model with excellent prediction capability. This feature is 
particularly useful for new and unfamiliar models that you do not want to overfit. Model averaging 
tends to shrink the estimates on the weaker terms, yielding better predictions. The models are averaged 
with respect to the AICc weight, calculated as:

where AICcBest is the smallest AICc value among the fitted models. The AICc Weights are then sorted 
in decreasing order. The AICc weights cumulating to less than one minus the cutoff of the total AICc 
weight are set to zero, allowing the very weak terms to have true zero coefficients instead of extremely 
small coefficient estimates. The Model Averaging report shows average estimates and standard errors 
for each parameter and allows you to save the prediction formula.

You may fit and compare several models by clicking the Model Averaging command repeatedly and 
entering different maximum and cutoff values. 

Fit Model - Least Squares

A new command, Cox Mixtures, produces the Cox Parameterization model estimates corresponding to 
a Scheffe model. A reference mixture must be supplied through scripting or dialog. A property in the 
data table, Reference Mixture, triggers this feature also.

AICcWeight = exp[-0.5(AICc - AICcBest)]
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Fit Model - Loglinear Variance

• The Log Linear Variance platform is now able to create a report with multiple response columns.   
Each response creates a separate Log Linear variance outline, but there is a common profiler for all 
responses. 

Nonlinear

• The Nonlinear model library has been extended to provide graphical and computational methods 
for getting better starting values.

Gaussian Process

• You can now select either a Cubic or Gaussian correlation type in the platform launch dialog. 

• There is now an option to set a minimum value for a correlation parameter.

Hierarchical Cluster

Hierarchical Clustering using Ward’s method became much faster with the Fast Ward method in JMP 
7, but this was only the case when the number of columns in the clustering was small. 

Now Fast Ward has been improved by applying a principal components step, keeping the distances 
between points the same, so that the results are the same, the performance is greatly improved for 
highly correlated data.

Fast Ward is automatically used whenever there are more than 2000 rows.

Graph Menu Improvements

Chart

Error bars are more fully supported in chart. For Version 7 and earlier, only the default, one standard 
error, was available. You could also not have error bars if the y's were overlaid.

In version 8, the chart launch dialog has additional options to let the user control the distance from the 
mean for the error bar. Also, the restriction that error bars are allowed only for un-overlaid y's is 
removed.
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Contour Plot

Now there is a Color Theme menu item in Contour. Choosing one of the JMP themes, like JMP 
Default, results in JMP 7 behavior where the colors are ordered by hue (red, orange, yellow, …) instead 
of the usual order (red, green, blue, …). Otherwise, the themes act as expected.

Bubble Plot

• The Bubble Plot can be saved as a Flash (SWF) application for use in presentations, browsers, and 
other uses.

• In Bubble Plot, the Trails option is now two separate options:

Trail Bubbles Shows trails as bubbles.

Trail Lines Connects the bubble trails with lines.

For compatibility in scripts, the old option Trails is aliased to Trail Bubbles.

Control Chart

All Control Charts have a new option to shade zones.

Variability/Gauge Chart

• There is now a Freq column option to the variability launch. (It’s already in the Attribute charts.)

• There is now a bias report and graph that gives the bias by each standard (reference value) used. 
When more than one part has the same standard, a pooled variance is used for that standard. The 
report displays the standard levels, bias, standard error, t-ratio, and p-values by default. 

Note: The standard errors and confidence limits for bias by operator and bias by part have been 
removed. 

• There is now an option for misclassification probabilities for the Gauge R&R study. This option can 
be accessed under the Gauge Studies menu. 

• One-sided tolerance intervals are now supported, and misclassification probabilities work with them 
as well. 
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• There is now a Spec Limits option in Gauge R&R. This allows the user to enter a lower and upper 
spec limit instead of entering the tolerance range. 

• Parameter-estimates-type reports have been added to the linearity report. Thus, both the slope and 
intercept can be tested. Test the slope to look for linearity issues. If the linearity is not significantly 
different from zero, then test the intercept to make sure bias is not significantly different from zero. 
To avoid duplication of results, the slope test was removed from the third part of the report.

• There is now an option in the Variability launch dialog that allows the user to enter REML conver-
gence settings. This option provides more control over the analysis so that results can be made to 
match results using Fit Model. The user can also check a box to force REML to be used even if the 
data is balanced. 

• There is now an option to make the variability and standard deviation graphs vertical. 

• The Gauge Studies Linearity report now has its own menu. The user can now change the α-value 
from the submenu instead of shift-clicking when the Linearity Studies menu item is selected.

• There is now an option to view Linearity by Groups. It breaks down the linearity by the levels of 
each grouping columns (except for the part). 

• More customizations are available for the Variability graph.

• The Variability platform has a new way to compute variance components using Bayesian estimation. 
In previous versions of JMP, when negative variance components are encountered JMP automati-
cally switches from EMS methods to bounded REML. Because we are using bounded REML, the 
variance components that would have gone negative are bounded at zero. Using Bayesian methods, 
we can make sure that the variance components are always positive values because the posterior 
means are computed by integrating over only the region where the variance components are 
non-negative.

• The bias report has been reorganized and an overall bias report has been added. When Bias Report 
is chosen from the main menu the Overall Measurement Bias and Measurement Bias by 
Standard reports are shown. 

• There is a new submenu under the bias report. The Measurement Error Graphs can be chosen 
from this submenu. Also, the submenu gives an option to see the confidence intervals on the graphs.

Capability

• Goal plots can now draw a defect rate contour.

• Goal plots can now shade Cpk regions.

• Goal plots now have a Cpk slider to let you see the change interactively on the graph.

• Goal plot points are now linked directly to their respective columns in the original data table.

Profilers

• A new Mixture Profiler shows response contours for mixture experiment models, where three or 
more factors in the experiment are components (ingredients) in a mixture. The Mixture Profiler is 
useful for visualizing and optimizing response surfaces resulting from mixture experiments.
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• The Profiler can now be saved as a Flash (SWF) file for use in presentations, web pages, and other 
uses.

• There is now a dialog to alter constraints through a modal dialog in both the profiler and custom 
profiler. The dialog can be accessed through the profiler menu item Alter Linear Constraints. 

The dialog shows all current linear constraints (if any exist). The current constraints can be altered 
except for the mixture sum which is disabled from editing. Also, new constraints can be added by 
clicking on the Add Constraint button. To delete a constraint, enter all zeroes or (missing values) 
for the constraint coefficients. 

This dialog is intended for linear equality and inequality constraints. The bound constraints can be 
altered with the axis specifications. If a bound type constraint is entered, the bounds are updated if it 
makes the bounds tighter, but dropped otherwise. 

• Save Linear Constraints has been added to the profiler and custom profiler for saving constraints 
to the data table Constraint property script. This update goes with the new Alter Linear 
Constraints menu option. Now when the linear constraints are alreted, they can be saved to the 
data table.

Note that these constraints are always saved to the data table in a script titled Constraint. This is 
necessary because the profiler looks for a data table property script with this exact name.

• There is now a choice to Stop at Boundaries or Turn at Boundaries (default) when any linear con-
straints are present (not just mixtures). In version 7 and earlier, the default setting for general linear 
constraints was to Stop at Boundaries. 

• The regular and custom profilers now handle linear constraints.

Surface Plot

• The Surface Plot interface has been simplified.



14 New Features in JMP 8
Graphics/Display Improvements

• You can now add contour lines above a sheet plot, below it, or directly on it. If you add contour lines 
on the sheet, you can specify the line color.

Graphics/Display Improvements
• The axis title font can be specified in JMP’s Preferences

• There are a much larger array of markers available for JMP’s graphs, including customized markers 
that allow any Unicode character to serve as a marker. In addition, marker themes have been added 
to allow, for example, hollow, filled, and other marker families to a plot.

• Color Themes have been added to legends and coloring routines that allow you to choose from 
pre-defined color schemes.

• Color or Mark by Column now has a preview and more options.

• Much greater use of anti-aliasing and translucency improves the appearance of graphics on Windows 
and Linux.

• Enhanced Metafile Plus (EMF+) is now supported, which greatly improves paste operations, partic-
ularly in Microsoft Office.

• Auto-recalc is available for more platforms.

SAS Integration Improvements
• JMP 8 supports connecting to either SAS 9.1.3 or SAS 9.2 servers. Select the version of SAS to con-

nect to using the SAS Server Version preference on the SAS Integration Preferences page. Note that 
the SAS Server Version preference does not have to match the version of SAS if you are running on 
Windows and SAS is installed locally.

• You can now ask for ODS results to be generated by SAS when you submit SAS code. The ODS for-
mat can be HTML, PDF, or RTF. Generated ODS results are automatically retrieved from the SAS 
server and displayed either inside JMP (HTML) or in the appropriate external application (PDF, 
RTF). ODS results generation is controlled by options on the SAS Integration Preferences page.

• New data sets created by submitted SAS code are now tracked. You can optionally have JMP auto-
matically import created data sets after a submit completes (off by default), or you can get a list of 
created data sets from the submit Results object (see below) and open them using SAS Import 
Data.

• There is a new SAS toolbar available, providing faster access to SAS functionality.

• The Browse SAS Data window now works with the local SAS server.

• Sampling is now available in Browse SAS Data.

• There is now a SAS toolbar.

• The SAS Log and Output windows are available per SAS server.
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SAS Integration Improvements

• For users with SAS, several experimental add-in scripts are available to serve as JMP front ends to 
SAS procedures; more will be added in the future. This includes Robust Regression and Thin Plate 
Spline.

SAS Import Data

• You can now see and import data from your local SAS server connection in the Browse SAS Data 
window (JMP/Windows only).

• JMP data tables that result from importing SAS data now have a Source script defined in them to 
facilitate re-doing the same import.

• You now have the option to take a random sample of a SAS data set when importing. Sampling 
requires SAS/STAT to be licensed and installed on the SAS server you are importing data from. JMP 
data tables that result from sampling SAS data are named Sample of <data set>, where <data 
set> is the name of the SAS data set that was sampled. Sampling is available both through the UI, 
via the Import Options section of the Browse SAS Data window, and through JSL, via a new 
Sample option to the SAS Import Data JSL function. 

• The mapping of SAS formats to JMP formats has been greatly improved. SAS currency formats are 
mapped to the new JMP 8 currency formats, and SAS custom formats are mapped to the enhanced 
JMP 8 value labels.

SAS Submit

• When you submit SAS code, you now get a progress bar that displays the SAS language step that is 
currently running and a count of errors that SAS has flagged. The progress bar also has a Cancel 
button, allowing SAS submits to be cancelled. 

• The SAS Log can now be kept separate from the JMP Log. The File > SAS menu has a new item, 
Open SAS Log Window. Selecting that item displays the accumulated SAS Log from the last 25 
submits to the active server. Similarly, the Open SAS Output Window item on that same menu dis-
plays the accumulated SAS Listing output from the last 25 submits.

• SASSubmit (as well as the Submit message to SASServer scriptable objects) has new optional 
arguments, mostly related to the new ODS support, so that submit preferences can be overridden 
for a specific submit.

• Adds a SASGetResults global JSL function and GetResults message to SASServer scriptable 
objects allowing you to retrieve a Results scriptable object after doing a SAS submit. This is the same 
Results scriptable object you get from a stored process object. It allows you to manually process the 
results of a submit – open ODS results, open graphics files returned by the submit, import data sets 
created by the submit, open log or listing results, etc.

• You can now do asynchronous submits of SAS code to any SAS server, local or remote. In JMP 7, 
you could only do asynchronous submits with the local SAS server. This is exposed via the Async 
optional argument to SASSubmit.

• You can now ask a SAS Server for its WORK directory path by using the GetWorkFolder message 
on a SASServer scriptable object. Useful for doing file transfers to and from the SAS server. 
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Metadata Server Connection

• We now have support for metadata server connection profiles. A “profile” is a named set of metadata 
server connection information (machine, port, auth domain, username, password). For JMP 8 and 
SAS 9.2, JMP shares metadata server connection profiles with Enterprise Guide 4.2 and the SAS 
Add-In for Microsoft Office 4.2 (and other SAS clients in future versions). JMP 8 uses profiles on all 
hosts and for both SAS 9.1.3 and 9.2 to be consistent, but sharing will only occur on Windows with 
SAS 9.2. 

• Single Sign-On support: SAS 9.2 allows clients to connect via single sign-on (a.k.a, Integrated Win-
dows Authentication) when both the client and the server are running Windows (support for other 
architectures, on the server side at least, will come post-9.2). Single sign-on means you do not supply 
a username and password when you connect to metadata; your Windows user ID and password are 
automatically used. The connection profile specifies whether or not to use single sign-on. On Win-
dows, you will see a new SAS-supplied DLL called sspiauth.dll in the same directory as JMP.exe, 
which is required to support single sign-on.

• You can now get a SAS Metadata Server scriptable object in JSL. After connecting, the new JSL 
function Current Metadata Connection() returns it. The object has a few messages that it 
supports, mostly informational. Meta Connect does *not* return the scriptable object: it still 
returns 1 or 0 based on whether connection was successful, for backward compatibility. 

SAS 9.2 Support

• Adds support for logical SAS data tables in the SAS Folders tree. “SAS Folders” tree is SAS 9.2 par-
lance for what used to be called the “BIP Tree”. 

If you right-click a table, you can either import the whole thing or ask to show the corresponding 
physical table in the Browse SAS Data window, from which you can import only part of the data if 
you want. You can also get the metadata path from the right-click menu, which is useful for script-
ing. 

• The File > SAS > Browse Stored Processes menu item is now File > SAS > Browse SAS 
Folders, since the tree is not only for stored processes. Browse SAS Folders is used for both SAS 
9.1.3 and SAS 9.2 metadata server connections even though with SAS 9.1.3 you will still only have 
stored processes in that tree. 

• In the SAS Import Data and SAS Get Var Names JSL functions, you can now supply the SAS 
Folders path of a logical SAS data table rather than a libname and member name. 

JMP Scripting Language Updates

Script Editor

• There is a new preference for reformatting with spaces in operator names (for example, 
Insert Into vs. InsertInto).
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JMP Scripting Language Updates

• There is a new preference to show indent guides, which are vertical dashed lines that show levels of 
indentation.

• Auto-completion is now skipped if there is only one choice. 

• A closing quote is not automatically added if the cursor is within string.

• The auto-completion list has been narrowed if an object is a global variable and will only show mes-
sages appropriate to that type of variable. This only applies to global variables.

• There is now a Show Line Numbers option on the context menu in the script editor.

• The following two boolean preferences have been added; their default values are both on.

– Show Operator Tips

– Show Variable Value Tips

They control whether or not a tip is shown when you hover over an operator name or a variable 
name, respectively.

• You can now specify your own syntax coloring in the Script Editor tab of Preferences.

Scripting Commands

New Commands

• There are now JSL statements Get Excluded Rows, Get Hidden Rows, and Get Labelled 
Rows to get a list of excluded, hidden or labelled rows.

• The following functions, used in a graphics callback scripts, determine if modifier keys are being 
pressed.

– Is Shift Key() 

– Is Control Key() 

– Is Alt Key() 

– Is Command Key() 

– Is Context Key() 

– Is Option Key() 

• LPSolve calls a linear programming (LP) solver. It is mainly used internally when an LP optimiza-
tion solver can improve optimization results. However, this function makes the LP solver available 
to users who may need it. 

• The new function Normal Biv Distribution(x, y, r,<mu1>, <s1>, <mu2>, <s2>) com-
putes the probability that an observation (X, Y) is less than or equal to (x, y).

• The new function Multivariate Normal Impute() returns a response vector with imputed val-
ues for the missing values in the vector of responses.

• You can now call DLLs with arbitrary functions signatures. JMP was able to call functions in exter-
nal DLLs previously, but the functions had to have one of three predefined signatures. This is only 
available for 32-bit Windows machines.
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• There is a new function Polytope Uniform Random for finding random uniform points over a 
convex polytope.

• The new functions Set Window Icon allows the user to set specify an icon to use in the corner of 
any window (Windows only).

• Break() causes a For(), While() or For Each Row() loop to exit.

• Continue() causes a For(), While() or For Each Row() loop to continue with the next itera-
tion.

• Current Window() returns the currently active JMP window.

• Close All() is now supported. It closes a group of window types and specifies whether they are to 
be saved or not.

• There are now commands that can be used to create “sheets” of plots arranged in a grid:

– V Sheet Box and H Sheet Box 

– Sheet Part and Excerpt Box 

See the JMP Scripting Guide for details.

• For compatibility, the old option for Bubble Plot, Trails, is aliased to Trail Bubbles for 
scripts.

• dt<<Get Property("value labels") is alias for Get Value Labels(). 

• dt<<Set Property("value labels" (value labels detail) ) is an alias for Set Value 
Labels(). 

• dt<<Delete Property("value labels") is an alias for Remove Value Labels(). 

Changes in Existing Commands

• The JSL operator As Table now provides a mechanism to suppress the window usually produced 
with the data table created from it:
As Table(matrix, <<invisible)

This is useful to speed up Monte Carlo and Bootstrapping scripts.

• You can now specify justification for text boxes: Left, Center, and Right.

• There is a new sampling capability for the SAS Import Data JSL function. This requires the SAS 
server to have SAS/STAT licensed and installed, since we rely on PROC SURVEYSELECT to do the 
sampling. 

• Random Normal Multiv() function is now Multivariate Gaussian Quadrature(). The 
arguments remain the same.

• Select() and Select With() now allows a mix of individual names and list of names.
Select( col1, { col2, col3}, c4)

• Button Box objects now support a Get Button Name message.

• Column Dialog() now supports a Select List Width(width) parameter that allows a user to 
change the width of the column list used in the Column Dialog() function.

• The Col List() function used in Column Dialog() now supports a Width(width) parameter.

• A Window object now supports the Maximize message. This is the opposite of the Minimize mes-
sage.
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JMP Scripting Language Updates

• An Axis Object now supports a Remove Ref Line(expression) message that removes a refer-
ence line with a specific value from a Axis.

• N Cols() is a synonym for N Col().

• N Rows() is a synonym for N Row().

New JSL/Formula Editor Functions

• Digamma(x) is the derivative of the LGamma(x) 

• Trigamma(x) is the derivative of Digamma(x) 

• Beta Binomial Distribution(x, p, n, delta), Beta Binomial Probability(x, p, 
n, delta), and Beta Binomial Quantile(p, n, delta, percentile) 

• Gamma Poisson Distribution(x, lambda, sigma), Gamma Poisson Probability(x, 
lambda, sigma), and Gamma Poisson Quantile(p, lambda, percentile) 

• GLog Distribution(x, mu, sigma, lambda), GLog Density(x, mu, sigma, lambda), 
and GLog Quantile(p, mu, sigma, lambda) 

Glog is an abbreviation for Generalized Logarithm.

• Random Glog(mu, sigma, lambda) 

• Random Beta Binomial(n, p, delta) 
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