New Features in JMP 9

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust
## Contents

New Features in JMP 9

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Windows Environment</td>
<td>1</td>
</tr>
<tr>
<td>Home Window</td>
<td>2</td>
</tr>
<tr>
<td>Window Arrangement Options</td>
<td>2</td>
</tr>
<tr>
<td>View the Associated Data Table</td>
<td>3</td>
</tr>
<tr>
<td>Preview and Open Reports</td>
<td>4</td>
</tr>
<tr>
<td>Switch between Windows</td>
<td>5</td>
</tr>
<tr>
<td>Show and Hide Menus</td>
<td>5</td>
</tr>
<tr>
<td>Menu and Toolbar Customization</td>
<td>5</td>
</tr>
<tr>
<td>Additional Updates in the New Windows Environment</td>
<td>6</td>
</tr>
<tr>
<td>Other Windows Updates</td>
<td>6</td>
</tr>
<tr>
<td>New Platforms</td>
<td>7</td>
</tr>
<tr>
<td>Degradation</td>
<td>8</td>
</tr>
<tr>
<td>Neural</td>
<td>8</td>
</tr>
<tr>
<td>Data Tables</td>
<td>9</td>
</tr>
<tr>
<td>General Table Operations</td>
<td>9</td>
</tr>
<tr>
<td>Importing and Exporting Data</td>
<td>11</td>
</tr>
<tr>
<td>Data Filter</td>
<td>11</td>
</tr>
<tr>
<td>Columns</td>
<td>12</td>
</tr>
<tr>
<td>Column Info Window</td>
<td>13</td>
</tr>
<tr>
<td>Rows</td>
<td>14</td>
</tr>
<tr>
<td>Summary</td>
<td>14</td>
</tr>
<tr>
<td>Subset</td>
<td>14</td>
</tr>
<tr>
<td>Join</td>
<td>14</td>
</tr>
<tr>
<td>Update</td>
<td>14</td>
</tr>
<tr>
<td>Tabulate</td>
<td>15</td>
</tr>
<tr>
<td>Formula Editor</td>
<td>15</td>
</tr>
<tr>
<td>Graph Platforms</td>
<td>16</td>
</tr>
<tr>
<td>Graph Builder</td>
<td>16</td>
</tr>
<tr>
<td>Bubble Plot</td>
<td>18</td>
</tr>
<tr>
<td>Cell Plot</td>
<td>18</td>
</tr>
<tr>
<td>Tree Map</td>
<td>18</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>--------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Working with R</td>
<td>20</td>
</tr>
<tr>
<td>Profilers</td>
<td>20</td>
</tr>
<tr>
<td>Contour Plot</td>
<td>21</td>
</tr>
<tr>
<td>Analysis Platforms</td>
<td>21</td>
</tr>
<tr>
<td>Distribution</td>
<td>21</td>
</tr>
<tr>
<td>Clustering</td>
<td>22</td>
</tr>
<tr>
<td>Discriminant</td>
<td>24</td>
</tr>
<tr>
<td>Fit Life by X</td>
<td>24</td>
</tr>
<tr>
<td>Fit Y by X</td>
<td>26</td>
</tr>
<tr>
<td>Life Distribution</td>
<td>28</td>
</tr>
<tr>
<td>Fit Model</td>
<td>29</td>
</tr>
<tr>
<td>Multivariate</td>
<td>34</td>
</tr>
<tr>
<td>Partition</td>
<td>34</td>
</tr>
<tr>
<td>Principal Components</td>
<td>35</td>
</tr>
<tr>
<td>Matched Pairs</td>
<td>35</td>
</tr>
<tr>
<td>Time Series</td>
<td>35</td>
</tr>
<tr>
<td>Recurrence Analysis</td>
<td>36</td>
</tr>
<tr>
<td>Survival</td>
<td>36</td>
</tr>
<tr>
<td>Nonlinear</td>
<td>37</td>
</tr>
<tr>
<td>Categorical</td>
<td>37</td>
</tr>
<tr>
<td>Design of Experiments (DOE)</td>
<td>39</td>
</tr>
<tr>
<td>Accelerated Life Test Design</td>
<td>40</td>
</tr>
<tr>
<td>Sample Size and Power</td>
<td>40</td>
</tr>
<tr>
<td>Graphics and Display</td>
<td>41</td>
</tr>
<tr>
<td>Microsoft Excel Profiler</td>
<td>44</td>
</tr>
<tr>
<td>JMP Scripting Language</td>
<td>45</td>
</tr>
<tr>
<td>Work with Windows and Files</td>
<td>45</td>
</tr>
<tr>
<td>Work with Data Tables</td>
<td>47</td>
</tr>
<tr>
<td>Preferences, Path Variables, and Environment Variables</td>
<td>49</td>
</tr>
<tr>
<td>Work with the Log</td>
<td>51</td>
</tr>
<tr>
<td>Project Scripting</td>
<td>51</td>
</tr>
<tr>
<td>Formula Editor Functions</td>
<td>53</td>
</tr>
<tr>
<td>Display Box Functions</td>
<td>54</td>
</tr>
<tr>
<td>Updates to JSL Functions</td>
<td>57</td>
</tr>
<tr>
<td>Working with R</td>
<td>58</td>
</tr>
<tr>
<td>SAS Integration</td>
<td>59</td>
</tr>
</tbody>
</table>
Add-Ins ................................................................. 60
Projects ............................................................... 60
Preferences ......................................................... 60
Object Scripting Index ......................................... 62
Macintosh ............................................................ 62
JMP 9 provides major updates to the Microsoft Windows interface and new connections to Microsoft Excel and R. This version also lets you display your data on geographic maps or custom maps, such as an office floorplan.

A new edition of the software, JMP Pro, adds features designed for high-end analytics users. These users have large volumes of data or a need for data mining and predictive modeling.

Important new features include the following:

- a completely revamped Windows environment
- two new platforms: Degradation and Neural
- the Microsoft Excel add-in
- customized add-in support
- Graph Builder enhancements
- interface to R
- graphics and display options
- Design of Experiments (DOE) options and the new Accelerated Life Test Design platform

Quick tips for finding the new features are provided here. Refer to the documentation for information about the more complex options.

**Note:** Features that are available only in JMP Pro, Version 9, are marked as such.

### New Windows Environment

On Windows, windows are now free floating and are no longer attached to a parent window. This design works well with multiple monitors, because each window moves independently.

When you first open JMP 9, the new Home Window appears instead of the JMP Starter. To quickly show the Home Window at any point, click the JMP Home Window button ( ) in the lower right corner of most JMP windows.

You can change the default window to be either the Home Window, the JMP Starter window, or the JMP Window List. Go to File > Preferences > General, and choose the option from the Initial JMP Window list.

This section describes the features of the new Windows environment and other Windows updates. For details, see the *Using JMP* book.
New Features in JMP 9
New Windows Environment

Home Window

JMP’s new Home Window provides quick access to all open JMP windows and files that you recently opened through the File menu or Open button. You can open or close windows quickly in the Home Window rather than manipulate the windows individually.

The Home Window also lets you see a preview of an open report. Place your cursor over a report in the Window List to see the preview.

Figure 1  Report Preview from the Home Window

Window Arrangement Options

You can now arrange multiple windows side-by-side. This feature is particularly helpful when you have generated several graphs from a data table.

- To see a data table next to the corresponding report window, select the arrow in the bottom right corner of the report window and then select Arrange with Data Table.
- To see multiple windows side-by-side, select the check box in each window. Select the arrow and then select Arrange Selected Windows.

Figure 2 shows the arrangement options.
New Features in JMP 9
New Windows Environment

Figure 2  Arrange Options

View the Associated Data Table
In a report window, view the data table associated with a report by clicking on the View Associated Data button (Figure 3).

Figure 3  View Associated Data Button
New Features in JMP 9
New Windows Environment

Preview and Open Reports

A preview of a data table’s open reports appears in the thumbnail panel, located below the data table (Figure 4). Place your cursor over the thumbnail, and the preview appears, and then double-click on a report to work with it. To see additional options, such as arranging reports with their data table, right-click the thumbnail.

Figure 4  Thumbnail Panel Options

The thumbnail panel appears by default. To hide the panel, select File > Preferences > Windows Specific and then deselect Show the thumbnail panel in data table windows.
Switch between Windows

To switch between windows, hold down CTRL and press the TAB key. A preview of each report window appears. Release the keys to open the previewed window.

Show and Hide Menus

In report windows and journals, JMP hides the menu bar by default. Show the menu bar in a specific window by doing one of the following:

- Pressing the ALT key.
- Placing the cursor over the menu strip at the top of the window (Figure 5).
- Clicking the menu strip.

If you would rather always see the menu bar, change the auto-hide preference. Select File > Preferences > Windows Specific, and then select Never from the Auto-hide menu and toolbars list. You can also choose an option to always hide the menu bar regardless of the window size.

Menu and Toolbar Customization

The menus and toolbars are customizable on Windows. This feature has been updated significantly in JMP 9.

- The menu editor is a separate window rather than a docked list.
- You can modify menus and toolbars for specific users (such as the current user or all users) or in a JMP add-in.
- You can specify the translation for each button and tooltip.
- JMP 9 lets you quickly hide a menu, toolbar, or button.

To customize menus or toolbars, select View > Customize > Menus and Toolbars and make your changes.
New Features in JMP 9
New Windows Environment

Additional Updates in the New Windows Environment

- To close JMP and all open windows, hold down the CTRL key and press Q.
- When you close all JMP windows manually, the default window (Home Window, JMP Starter window, or the JMP Window List) appears. When you close the default window, JMP closes.
- To move a toolbar to the left, right, or bottom of the JMP window, right-click the toolbar and select Location.
- The Log now opens in a separate window. You can also modify the Preferences so that the Log opens whenever text is added to it, when JMP opens, or only when you explicitly open the Log. Select File > Preferences > Windows Specific > Open the JMP Log window.
- The menus on the menu bar change depending on the window type. For example, the Edit, Cols, Rows, and Tools menus only appear on windows where you need those options.
- In narrow windows, JMP wraps the main menu so that you can see all menus. You can also choose to show only the menus that fit in narrow windows. Select File > Preferences > Windows Specific and deselect Wrap the main menu in narrow windows.

Other Windows Updates

Customize Menu Has Been Moved
The Customize menu has moved from the Edit menu to the View menu.

JMP 8 Menus
If custom menus and toolbars (.jmpmenu) are found from JMP 8, JMP 9 attempts to save the corresponding .jmpcust file and apply the customizations to JMP 9. If there are problems applying a menu or toolbar customization file, an alert window appears. All details are then written to the JMP Log.

File>Edit Toolbar Update
The File/Edit toolbar now includes the button for opening the Data Filter window.
The Print button on this toolbar has been removed.

Windows Metafile Support
JMP 9 supports the Enhanced Metafile (EMF) graphic formats (including EMF+) to provide the best visual experience.
The Windows Metafile (WMF) graphic format is no longer supported because it is a discontinued format.
Tool Windows Remain in Place

Certain tool windows (such as Data Filter, the Legend window, and the Find and Replace window) remain on top of the windows to which they are attached.

Save Reports and Journals as PDF

You can now save reports and journals as PDF documents. The PDF format is a file type in the Save As window.

New Print Preview Buttons

The following buttons have been added to the File > Print Preview window:

- The **Page Setup** button opens the Page Setup window, where you specify margins and scale your document.
- The **Change Page Orientation** button switches between portrait and landscape layouts.
- The **Show Margins** button lets you see the current margins.
- The **Shrink One Page** button reduces the output size by one page each time it is pressed. More of the report then fits on one printed page.
- The **Restore Scale** button reverts the output size to the original page size. This button only works after you shrink a page.

New Platforms

JMP 9 contains two new platforms: Degradation and Neural. Examples of Degradation and Neural reports are shown in Figure 6.

Note that the Neural platform replaces the **Neural Net** platform and adds significant improvements.

For details about the Degradation platform, see the **Quality and Reliability Methods** book. See the **Modeling and Multivariate Methods** book for details about the Neural platform.
New Features in JMP 9

New Platforms

Figure 6  Examples of Reports from the New Degradation and Neural Platforms

Degradation

The Degradation platform is available on the Analyze > Reliability and Survival menu. You use this platform to analyze product degradation (or deterioration) over time and to anticipate product quality in the future. Data can be analyzed from both non-destructive (repeated measures or stability analysis) and destructive testing.

Neural

Note: Some of these features are available only in JMP Pro, Version 9.

The Neural platform replaces the Neural Net platform. You can still access the Neural Net platform using the JMP Scripting Language (JSL) command Neural Net(). To access the new Neural platform, select Analyze > Modeling > Neural, or use the JSL command Neural().
New Features in JMP 9

The Neural platform contains significant enhancements. Some of the enhancements include:

- the ability to cross validate data based on a validation column
- the option to fit both 1- and 2-layer neural nets
- the ability to transform covariates
- three different activation functions
- richer diagnostics, including several measures of fit and diagnostic plots
- the ability to fit multiple responses simultaneously for both continuous and categorical responses
- improved handling of missing values. The platform can create a category for missing values of both continuous and categorical covariates.
- the ability to fit boosted neural nets

The Neural platform supports one and two layer, fully connected multilayer perceptron neural networks with activation functions that can be hyperbolic tangent, linear, or Gaussian ($\exp(-.5x^2)$). Arbitrary mixtures of continuous and categorical inputs and responses can be modeled.

Data Tables

This section describes the new data table features. For details, see the Using JMP book except where noted.

General Table Operations

Edit Table Property/Script Window

The Script window in a table property lets you define and run a script. This window is no longer modal, so you can keep it open and work with other JMP windows at the same time. You can now run a script or a portion of a script from this window. To run the script, do one of the following:

- Hold down CTRL and press R on Windows (or hold down COMMAND and press R on Macintosh).
- Click the Run button in the Script window.

The window also now has a Save button that lets you save the script without closing the window so that you can continue to work.

Enhanced Numeric Formatting

Data tables support the following new numeric formatting:

- The yyyyQq format returns the four-digit year, the letter “Q,” and the one-digit quarter. To assign the format to a column of data, double-click the column heading and select Format > Date > yyyyQq. To assign the format to an axis in a graph and select Format > Date > yyyyQq.
- You can use a comma as a thousands separator in numeric formats. The check box is not selected by default. To use the thousands separator, select the Use thousands separator (,) check box in the Column Info window.
New Features in JMP 9
Data Tables

Manage the Table Grid
You can now hide the data table grid like you can hide the table panels. Hiding the grid hides all data but still shows the properties, scripts, table variables, column names, and row information.

To close the data table grid, click the disclosure icon in the data table panel next to the table name.

Copy the Table Script
You can copy the script to reproduce the data table and then paste it into a Script window. To copy a table script, click the red triangle icon in the data table panel next to the table name, and then select Copy Table Script.

Add Encrypted Scripts to a Data Table
You can now encrypt a script that is in a data table. See the Scripting Guide book for directions.

Copy and Paste Scripts and Variables in a Data Table
You can now copy and paste scripts and variables that are saved to a data table from the table panel. Select the Copy and Paste commands in the Edit menu. (The Copy and Paste commands are also available in the red triangle menu.)

Undo/Redo Multiple Times
Data tables now support multiple undos and redos. This command works for most modifications to the data table. Changes that do not affect the data cannot be reversed, such as the following:

• all row states operations
• role assignments

JMP does not undo individual data table actions that are sent through a JSL command. (A single JSL command empties the entire data table's undo stack, not just the previous action.)

The Undo command is also now on the Edit menu.

The new Redo command reverses the previous undo.

Color Cells
You can select a background color for cells in the data table grid using one of the following methods:

• Select the color for individual cells by right-clicking the column heading or an individual cell and selecting Color Cells.

• Color entire rows by their row state. Right-click the row number area and then select Color Rows by Row State. From then on, the rows are shaded with the color that you assign to the rows.

• Color the column with the Value Colors or Color Gradient property. Double-click the column and select Column Properties > Value Colors or Color Gradient. Then select the theme from the Color Theme list. When you select the Color by Cell Value check box, the cells in the table are then colored by the color theme. If the option is deselected (which is the default), the colors apply only to the values in the graphs.
Importing and Exporting Data

Import SPSS Data
You can now import SPSS data that is in a single-byte character set (SBCS). JMP maintains value labels, variable labels, and missing value codes defined in the SPSS file. SPSS is also a file type in the Open Data File window.

SPSS can assign certain values in a variable to be treated as missing for analyses. Now numeric missing value coding is supported when importing SPSS data into JMP.

To specify missing values in a column, select Column Properties > Missing Value Codes and enter the values that should be considered missing.

Import HTML Tables into JMP Data Tables
(Windows only) You can open a Web page in JMP that contains tables and import the tables into JMP data tables.

First, select File > Internet Open, enter the Uniform Resource Locator (URL), select Web page in the Open As list, and then click OK. The page opens in JMP’s browser.

Then, select File > Import Table as Data Table in JMP’s browser. The tables in the Web page are listed. Select one or more tables to convert to JMP data tables.

Wide Range of Character EncodingsSupported During Text File Import
- The new preference called Open Text File Charset controls the character encoding for imported text files. This option is on the General page of the Preferences.
- The JSL Open() function now accepts an optional argument that immediately follows the filename to specify the character encoding.

Data Filter

“And” and “Or” Selections
The Data Filter window has two buttons, And (蓬勃发展) and Or (edisheng2), to add filter columns. And restricts the selection, while Or extends the selection. The initial window has only the And button. After you select criteria, both the And and Or buttons are available.

Auto Clear
The new Auto clear check box on the Data Filter window lets you select values from one variable at a time. If you want to select values from multiple variables at the same time, deselect the Auto clear check box.

Save and Restore Current Row States
A new check box called Save and restore current row states is available in the Data Filter window. This option restores the current row states when the Data Filter window is closed.
New Features in JMP 9
Data Tables

Float the Window

A new preference called **Use Floating Window** controls where the Data Filter window appears after you generate a report. Select this option in the Data Filter window’s red triangle menu to attach the Data Filter window to the data table. When you click on the data table, the Data Filter window remains on top of the table. Otherwise, the window moves behind the table when you click in the table. (This preference is selected by default.)

To change this preference, select **Preferences > Tables** and select or deselect **Use a Floating Window for Data Filters**.

Select Missing

The **Select Missing** option for a continuous filter column lets you select missing values for that column. If the option is selected, missing values are treated as one category. The specified interval is treated as the other category joined by an OR. If you select a sub-range and select the **Select Missing** option, then all the rows in the range, including those with missing values, are selected. If you select the **Select Missing** option and do not select a range, then only rows with missing values are selected.

Columns

Compress Selected Columns

A new command on the **Cols** menu compresses selected columns as follows:

- In character columns with fewer than 255 unique values, the List Check property is added to the column.
- In numeric columns, data is compressed to 1-byte, 2-byte, or 4-byte integers when possible.
- A numeric column with non-integer values can also be compressed if there are fewer than 255 unique values. In this case, the List Check property is added to the column.

To compress columns, select the columns, and then select **Cols > Compress Selected Columns**.

Fill Columns with Data

The **Fill** command now supports multiple columns. You can add either a repeating sequence of data or a continuation of values. The pattern that you select in the **Fill** menu applies to all selected columns.

To see the fill options, right-click the cells that contain the values to repeat and select **Fill**.

Random Indicator

The new **Random Indicator** option fills a column with random values. This option initializes the data to three values (0, 1, 2) in the specified proportions. To exclude a value, type 0 next to Proportion.

To see the **Random Indicator** option, double-click on a new empty column and select **Random** from the **Initialize Data** list.
New Features in JMP 9
Data Tables

Color Gradient and Value Colors

You assign the new Color Gradient column property to a continuous column, just as you assign the Value Colors property to nominal or ordinal columns. You can assign the color properties to any column except for row state columns.

To see these color properties, double-click on a column and select Column Properties > Color Gradient or Value Colors.

Copy and Paste Column Properties

You can copy all of the Column Properties for a given column and paste them into another column. Right-click the column heading and select Copy Column Properties. To paste these properties onto another column, right-click the column heading and select Paste Column Properties.

Recode Script

In the Recode command, there is a fourth menu option called Script. This option creates a new script called Recode in the data table. You can apply this script to perform recoding in-place. If you add more recodes later, the script updates (assuming that you select Script as the destination). You can also apply this script later to new data and then copy the script to other data tables. Running the Recode script from your own scripts is also an option.

Access Column Properties from the Column Right-Click Menu

When you right-click a column heading, there is a new command called Column Properties. This command lets you quickly select column properties. Previously, you had to right-click, select Column Info, and then select the column property.

Columns Filter

The Select Columns list in most analysis and graph launch windows lets you quickly select columns using the specified criteria (such as columns that only contain continuous data). The platforms that do not support the filter are as follows:

- Fit Model, Fit Parametric Survival, Fit Proportional Hazards
- Choice

To see the column filters, open a launch window (other than those specified above) and select a filter from the Select Columns red triangle menu.

Column Info Window

Missing Value Codes Option

In the Column Properties list, the new option called Missing Value Codes lets you add column values that should be treated as missing. For example, sometimes the value 99 is a placeholder to represent missing values, or sometimes several values are used to represent different types of missing values.
New Features in JMP 9

Data Tables

Initialize Data

When you are creating a new column, the Initialize Data option can be set to Today. This feature is useful only with the Date or Time formats.

Rows

Select Dominant Command

The Select Dominant command now lets you select high or low values for each column instead of selecting all high values or all low values for all the selected columns.

To change this setting, select Rows > Row Selection > Select Dominant, and select one or more columns. Then select any column’s check box to search for high values, or deselect any column’s check box to search for low values.

Summary

Expanded Values when Dragging and Dropping Columns

When you drag and drop columns from the summary table to the source table, the values are expanded in the source table, as if they were matched by grouping columns. This is also true for BY group tables, where the values are pasted to the rows of the corresponding group.

Create Unlinked Summary Tables

You can now specify that a new summary table is not linked to the original data table. The Summary window has a new check box, Link to original data table, which is selected by default.

Subset

Create Subset Tables Based on the Values in a Column

You can now create subset data tables based on the values of one or more columns. The new option called Subset By is available in the Subset window. For example, if you select a column with two levels, two data tables are created. Each table contains the rows for one of the levels of the original column. Note that you can use Subset By with the other options in the Subset window.

Join

Maintain Order While Joining Tables

The new Join window option called Preserve main table order maintains the order of the original data table in the joined table. Otherwise, JMP sorts by the matching columns.
New Features in JMP 9

Data Tables

Update

Select Columns to Add for Updated Tables
You can now add none, some, or all columns that exist in the update table (but not in the original table) to the original table.

To see this feature, select Tables > Update in the table that you want to update. Select the original table's name, and then do one of the following:

• Select All to add all columns from the new table to the original table.
• Select Selected to add only columns that you are selected in the new table to the original table.
• Select None if you do not want to add any additional columns from the new table to the original table.

Tabulate

Missing Value Codes Supported
Missing value codes for grouping columns are supported. The list of values in the column property Missing Value Codes is treated as missing for the purpose of categorization.

To see this feature, double-click on a column and select Column Properties.

New Statistics
Two new statistics have been added to the statistics list in the Tabulate window: Row % and Col %. To see these statistics, select Tables > Tabulate.

New Content Supported
The main table area now accepts dropped statistics. Continuous columns are accepted as analysis columns.

Delete Items from the Table
When you drag an existing item, such as a statistic keyword, from the table and drop it away from the table, that item is deleted.

Formula Editor

Automatically Fill Match Using Your Data
The Conditional > Match list in the Formula Editor has two new options:

• When you select Add Match Arguments from Data, clauses that correspond to all of the levels in your data are added automatically.
• When you select Don’t Add, you can add each clause individually.
New Features in JMP 9
Graph Platforms

**Note:** To add the clauses automatically, you can also hold down the SHIFT key when inserting a Match operator around a column.

New Date Function
The `Quarter(date)` function returns a quarter value in the range 1 to 4.

Graph Platforms

This section describes the new graph features. For details, see the *Basic Analysis and Graphing* book.

**Figure 7** Example of the New Graph Builder Features

Graph Builder

New Zones and Map Support
Two new zones in Graph Builder add color and geographical boundaries to maps:

- The Shape zone assigns geographical boundaries to a map based on variables in the data table. The shape value determines the x and y axes.

  Boundaries such as U.S. state names, world countries, Canadian provinces, and Japanese prefectures are installed with JMP. You can also create your own boundaries (whether geographical or otherwise) and specify them as **Map Role** column properties in the data table.
New Features in JMP 9

Graph Platforms

- The Color zone applies a color to geographical boundaries. The categorical or continuous color theme selected in your Preferences is applied to each boundary.

Dual Y Axes

To add a y axis on the right side of the graph, drag two or more variables into the left Y drop zone. Then right-click, select Move Right, and select which variable to move to the right y axis.

You cannot drag and drop a right y axis. Instead, right-click and select Move Left or Remove. On the right y axis, the graph contextual menu marks some items as (right). This notation indicates items that are associated with right-hand y variables.

Lock Gradient Scales

The Lock Scales option prevents axis scales and gradient legend scales from automatically adjusting when you filter data. This feature is helpful when you are filtering data over an animation.

To select this option, create a graph in Graph Builder and select Lock Scales from the red triangle menu.

Sampling for Large Data Tables

You can now work with a subset of the data table in Graph Builder as you experiment with different options. Then you can switch to the whole data table for the final visualization.

From the Graph Builder red triangle menu, select Sampling and then enter the sample number that you want to work with. When you want to see the graph for the entire data table, select Sampling again and type 0.

Density Contours

You can now specify the number of density contour levels. This feature is particularly helpful when you want to see patterns in a graph darkened by thousands of data points.

Custom Color Scales and Gradients

There is a gradient color theme legend for continuous color variables in Graph Builder, which allows further customization of how a color theme is applied to data. See “Custom Color Scales and Gradients,” p. 42 for details about the new color features.

Error Bars and Confidence Intervals

Line, Bar, and Points elements in Graph Builder can now show error bars when the Summary Statistic is Mean. The error bars are slightly offset to reduce overstriking. A footer note indicates what type of error bars are in use. To see the error bar option, right-click the graph and select Error Bars from the Line, Bar, or Points option.

Confidence intervals are also available, and the Points option supports summary statistics.
New Features in JMP 9
Graph Platforms

Frequency Variables
A new drop zone under the Group Y area supports a frequency (or Weight) variable. The Histogram, Mosaic, Contour (density) elements use frequency variables for counts. Line, Bar, and Points elements use frequency variables for summary statistics. Box plots use frequency variables for quantiles, and the fit of the Smoother (or spline) is also affected.

Bubble Plot

No Labels
A new option called No Labels lets you select bubbles without having the labels shown. This is useful for identifying trails without seeing the labels. If both the No Labels and All Labels options are selected, the All Labels option prevails.

Click the Bubble Plot red triangle icon to see these options.

Time Label Placement
You can now control the placement of the time variable label by clicking and dragging.

Cell Plot

Custom Color Scales and Gradients
The new custom color scale and gradient feature is available in Cell Plot. See “Custom Color Scales and Gradients,” p. 42 for details about the new color features.

Arrange Plots
If you specify an X, Grouping variable in the launch window, the new Arrange Plots option appears in the red triangle menu. This option lets you specify the number of plots to put on the same row before the next row is created. If you want the maximum across, just enter a large number greater than the number of groups.

Tree Map

Tooltip For Subcategories
Place your cursor over a subcategory to see a tooltip that contains the subcategory’s label.

Specify the Color Range
You can now specify the range mapped to the color gradient for continuous variables. The default range is the range of the means across the groups. The Color Range option, which appears only for continuous color variables, prompts you to enter two values.

The complete range now shows in the legend for continuous variables.
Scatterplot Matrix

Regression Lines
Simple regression lines are now available. To show regression lines, select **Fit Line** from the Scatterplot Matrix red triangle menu.

Nonparametric Densities Option Added
The **Nonpar Density Contour** option has been added to the Scatterplot Matrix menu. The contour shows where most of the points are located and helps distinguish values in a dense structure. Note the following information about this feature:

- Nonparametric density contours use the default bandwidth.
- This feature has not been added to rectangular scatterplot matrices (where the $x$ and $y$ are different variables).

Variability/Gauge Chart

The *Quality and Reliability Methods* book provides more details about the following new features.

Better Detection of Error Variance Heterogeneity
An ANOMV simulation method now tests for variance heterogeneity in Variability. This comes from a permutation simulation method discussed in the following reference:


You can also set the random seed to get the same results each time you run a heterogeneity of variance test. Before selecting **Heterogeneity of Variance Tests** in the Variability red triangle menu, hold down the CTRL and SHIFT keys. Select **Heterogeneity of Variance Tests** from the Variability Gauge red triangle menu, and then enter the random seed.

Historical Mean for Gauge R&R
A new option to enter the Historical Mean has been added to the Gauge R&R window. This optional value should be used only for one-sided tolerance ranges.

To see this option, create a Variability/Gauge chart and select **Gauge Studies > Gauge RR** from the red triangle menu.

Conformance Rate
A new option appears in the Conformance Report for changing the conforming category. (The Conformance Report appears only when there are two rating categories.) JMP assumes that one category is associated with conformance, and the other category is associated with nonconformance. You can switch the category associated with conformance.
New Features in JMP 9

Profilers

To see the Conformance Report, create a Variability/Gauge chart that contains two rating categories. In the Conformance Report red triangle menu, select Change Conforming Category.

Calculate the Escape Rate

The Conformance Report red triangle menu includes an option to calculate the escape rate. The escape rate is the probability of a miss (flagging a nonconforming part as a conforming part) times the probability that the process produces a nonconforming part. You must enter the probability that the process will produce a nonconforming part.

Change Alpha Levels

You can now change the default alpha level of 0.05 in the launch window. To see this feature, select Graph > Variability/Gauge and click on Specify Alpha.

Profilers

Specify Maximization Options with JSL

You can now specify the following maximization options using JSL:

- Number of Trips
- Maximum Cycles
- Convergence Tolerance
- Save Iterations to a log data table
- Use Legacy Optimizer

See the JMP Object Scripting Index (available in the Help menu) for details about scripting maximization options.

Contour Profiler

You can now change the line color for each response. Right-click a response term in the color legend, and select a color from the color palette. Save the command as a JSL script with the <<YColors(… ) command.

The Contour Profiler now uses the Spec Limits of Target LSL and USL as initial values for the Current, Lo Limit, and High Limit respectively.

Simulation Experiments

In the Simulation Experiment window, you can now select which factors you want to include in the experiment.
Simulator: New Options

There are two new random factors features:

- The **External** command lets you sample from any column in the source data table or from any column in a different data table.
- The **Aligned** command applies only to the **External** and **Sample** options. When selected on two or more factors, this feature forces the Simulator to choose values from the same row, so that the correlation structure across the columns is preserved.

Column Properties: Expanding Formulas

There is now a way to prevent formulas from being expanded in the Profiler platform. If the value of the **Expand Formula** column property is zero, then the formulas are not expanded.

To see this feature, double-click the column and select **Other** from the Column Properties list. Type **Expand Formula**, click **OK**, and then type 0 in the Expand Formula window.

Contour Plot

In contour plots, you can show points with missing y values. In the red triangle menu, select **Show Missing Data Points**. The missing data points are marked with black circles by default, just like the non-missing data points.

Analysis Platforms

This section describes the new analysis platform features. Details about the new features are covered in the **Modeling and Multivariate Methods**, **Quality and Reliability Methods**, or **Basic Analysis and Graphing** books as noted.

Distribution

The **Basic Analysis and Graphing** book includes details about the new Distribution features.

Histograms Only

The Distribution launch window has a new option called **Histograms Only**. When you select this option, the Distribution report excludes the following reports:

- Quantiles and Moments reports for continuous variables
- Frequencies reports for nominal and ordinal variables
- Outlier box plots

If you select other options for Distribution in Preferences, they are still included in the report.
New Features in JMP 9
Analysis Platforms

Normal Mixture Fitting Options
Normal Mixture fitting options have been added to the Continuous Fit menu on the red triangle menu for distributions of continuous variables. You can select Normal 2 Mixture or Normal 3 Mixture for two or three clusters. Or you can select Other and enter the number of clusters.

Export Histograms as Flash (.SWF) Files
You can export histograms as Flash (.SWF) files that you view with the Adobe Flash Player. Interactive features, such as highlighting bars and adjusting the axes, are available. For details, visit http://www.jmp.com/support/swfhelp/en/histogram.shtml.

Clustering
The Modeling and Multivariate Methods book includes details about the new Clustering features.

K-Means Clustering
The following new features are available:

- You can run several clusterings, and all are shown in the report. All K-Means clustering options are available on the red triangle menu for each cluster.
- The new multivariate normal mixtures method is available.
- Projected normal contour ellipsoids are shown on biplots.
- Scatterplot Matrix is now available, and it shows projected normal contour ellipsoids.
- The Control Panel has a Declutter button for identifying multivariate outliers.
- The command formerly called Simulate Mixtures is now called Simulate Clusters and works on all clustering methods. It also supports transformations.

The following features have been removed:

- The Centers role in the Cluster launch window to specify a grouping variable to define cluster centers.
- The Seed with Selected Rows option on the red triangle menu.

Updated Algorithm for K-Means Normal Mixtures Clustering
For K-Means normal mixture clustering, previous versions of JMP used a variation of the Newton-Raphson algorithm. JMP 9 has moved to a more stable algorithm, the expectation-maximization (EM) algorithm. JMP 9 uses a Bayesian regularized version of the EM algorithm, which allows JMP to smoothly handle cases where the covariance matrix is singular.

Note: The previous version of Normal Mixtures has been renamed to Robust Normal Mixtures.
Save Cluster Formulas

For the K-Means Clustering, Self Organizing Map, Robust Normal Mixtures, and Normal Mixtures methods, there is a new option to save cluster formulas. Saving cluster formulas creates a column with a formula to evaluate which cluster the row belongs to.

To set this option, select **Save Cluster Formula** in the K Means red triangle menu.

**Hierarchical Clustering**

Distance Matrices

The new Distance Matrix feature is more visible and specific. A new option, **Data is distance matrix**, prompts you to specify a subset of objects to cluster. You can still omit the column specification like in JMP 8.

When you analyze distance matrix data, you need to specify the label of the column containing the column names of the other columns. To specify the Label of the column that contains the other columns’ names, select **Data is distance matrix** in the launch window, and then assign a variable to Label.

There are also two new options:

- **Save Distance Matrix** creates a new data table that contains the distance matrix.
- **Get Distance Matrix** returns the matrix.

To create a new data table that contains the distance matrix, create a hierarchical cluster report and select **Save Distance Matrix** from the red triangle menu.

Clustering with Distance Matrices supports two-way clustering and heat maps.

**Zoom into Dendrograms**

You can now zoom in to see just the selected rows in two ways:

- Double-click on a cluster.
- Select a cluster and then select **Zoom to Selected Rows** from the Hierarchical Clustering red triangle menu.

To see the whole dendrogram again, select **Release Zoom** from the Hierarchical Clustering red triangle menu.

**Reduced Influence of Outliers**

For hierarchical cluster heat maps, JMP chooses the mean as the middle. JMP then divides up the low and high parts of the range with the mean in the middle. This prevents bad clustering caused by a single extreme outlier.
New Features in JMP 9
Analysis Platforms

Positioning Option

There is a new option on the Hierarchical Clustering red triangle menu item called **Positioning**. This option lets you select the placement and position of many parts of the dendrogram as follows:

- **Row Dendrogram Position**: select **Right** or **Left**
- **Row Label Position**: select **Right** or **Left**
- **Row More Position**: select **Right** or **Left** (for color maps)
- **Column Dendrogram Position**: select **Above** or **Below**
- **Column Label Position**: select **Above** or **Below**

Other New Options

Many other new options are available for Hierarchical Clustering in the red triangle menu:

- **Show Dendrogram** turns the dendrogram on and off.
- **Show NCluster Handle** turns the diamond indicator in the dendrogram on and off.
- **Parallel Coord Plots** saves the cluster ID in the data table. JMP launches the Parallel Plot platform using that cluster ID column to produce a parallel plot for each cluster.
- **Pivot on Selected Cluster** interchanges the two clusters underneath the selected cluster.

There is also a line in the distance graph that shows the current number of clusters.

Add Variables to the Cell Plot

You can now add additional variables to the cell plot. To select this option, select **More Color Map Columns** from the Hierarchical Clustering red triangle menu.

**Discriminant**

The *Modeling and Multivariate Methods* book includes details about the new Discriminant features.

**Indicator for Excluded Rows**

When using holdback sets to evaluate prediction accuracy, an indicator column now shows if any rows are excluded.

**Fit Life by X**

The *Quality and Reliability Methods* book includes details about the new Fit Life by X features.
Custom Estimate

Based on a fitted distribution, Custom Estimate creates tables of estimates along with confidence intervals of failure probabilities and quantiles. Both Wald and profile likelihood intervals are supported. To see this feature, click on the report’s **Custom Estimation** tab.

Support for Simultaneous Confidence Bands

In the Nonparametric Overlay plot, simultaneous confidence bands are supported for the Kaplan-Meier estimate. To see this feature, select the **Interval Type**, which can be **Simultaneous** or **Pointwise**.

Lines of Individual Group Fit

The Nonparametric Overlay plot now draws lines of individual group fit for the specified distributions. To see this feature, create a Fit Life by X graph and view the Nonparametric Overlay report.

New Relationships

The Reciprocal, Square Root, and Box-Cox relationships are available.

To see these options, select **Analyze > Reliability and Survival > Fit Life by X** and select the **Relationship** list. If you select **Reciprocal** or **Square Root**, the x axis of Scatterplot is scaled so that the quantile lines are straight. Previously, the x axis was linearly scaled.

Transformation for the X Variable in the Scatterplot

For the Arrhenius Celsius, Arrhenius Fahrenheit, Arrhenius Kelvin, Log, and Logit transformation, the x axis is scaled so that quantile lines are straight. Previously, the x axis was linearly scaled.

To see these options, select **Analyze > Reliability and Survival > Fit Life by X** and select one of the preceding relationships from the **Relationship** list.

Box-Cox Transformation and Likelihood Profile Plot

If you enter the initial lambda value in the Fit Life by X launch window, the sensitivity of likelihood versus the lambda appears in the Sensitivity report.

To see this feature, create a Fit Life by X graph with the Box-Cox relationship and the initial lambda value.

Save Residuals

You can now save residuals in a Cox-Snell Residual P-P Plot by selecting **Save Residuals** from the Cox-Snell Residual P-P Plot red triangle menu.
New Features in JMP 9
Analysis Platforms

Fit Y by X

The Basic Analysis and Graphing book includes details about the new Fit Y by X features.

Logistic

Save Probability Formula is now available for Logistic in Fit Y by X
You can now save the probability formula into the data table.
To see this feature, select Save Probability Formula from the report's red triangle menu.

Oneway

Exact Tests

Note: This feature is available only in JMP Pro, Version 9.
The following exact tests are now available:
• Kolmogorov Smirnov Test
• Median Test
• Van der Waerden Test
• Wilcoxon Rank Sum Test
To run these tests, select Nonparametric > Exact Test in the Oneway red triangle menu and then select the test.

Compare Groups Using Nonparametric Multiple Comparisons
You can now compare groups using nonparametric multiple comparisons. To see this feature, select Nonparametric > Nonparametric Multiple Comparisons from the Oneway red triangle menu.

Select Comparison Circles
If you have comparison circles, you can now use the JSL Select Group command to select a particular circle. The Object Scripting Index (OSI) includes details about this command. (The OSI is available in the JMP Help menu.)

Analysis of Means Methods
The Analysis of Means Methods menu has been added to the Oneway red triangle menu. This feature lets you compare group means or test for unequal variances using various methods.
New Features in JMP 9
Analysis Platforms

Bivariate

New Residual Plots
The following are new plots: Actual by Predicted, Residual by Row, and Residual Normal Quantile. The Residual by Predicted plot has interactive histogram borders.

To see these features, select Fit Line from the Bivariate red triangle menu. Then select Plot Residuals from the Linear Fit red triangle menu.

New Options for Nonpar Density Fits
Three new options have been added to the Quantile Density Contours menu:

- Contour Lines provides the ability to turn off the lines when you only want a fill.
- Contour Fill fills the space between contours with color density corresponding to the contour.
  If grouping is used, the grouping color and transparency (or opaqueness) corresponding to the quantile curves is used. Otherwise, it is colored by its surrounding 10% contour line.
- Select Points by Density lets you enter a low and high probability range for the selection of points.

To see these options, select Quantile Density Contours from the Bivariate red triangle menu.

Contingency

Cochran Armitage Trend Test
This option tests for trends in binomial proportions across levels of a single variable. This test is appropriate only when one variable has two levels.

To see this feature, click the red triangle icon on the Contingency Analysis report.

Exact Agreement Statistic

Note: This feature is available only in JMP Pro, Version 9.

You can now run an exact test for the Kappa statistic and test agreement between variables. This option is available only when the two variables have the same levels.

Exact Cochran Armitage Trend Test

Note: This feature is available only in JMP Pro, Version 9.

This option performs the exact version of the Cochran Armitage Trend Test. The test is available only when one of the variables has two levels.

To see this feature, select Exact Test from the Contingency Analysis red triangle menu.
New Features in JMP 9
Analysis Platforms

Cumulative Cell Statistics Added
Four new cell statistics have been added to the Contingency Table menu, as follows:

- Col Cum (Cumulative Column) and Col Cum %
- Row Cum (Cumulative Row) and Row Cum %

These statistics are particularly relevant for ordinal variables where you want to see the percent at or below for each level.

To see these options, click the red triangle icon in the Contingency Table report.

Analysis of Means for Proportions Option Added
The Analysis of Means for Proportions option has been added to the Contingency platform. This option is available only for data that has a binomial response.

The normal approximation to the binomial distribution is used. A warning message appears if the sample sizes are not large enough to use the normal approximation to the binomial distribution. The report includes a graph and a report with the group proportions, lower and upper limits, and whether the group proportion exceeds one of the limits.

To see this option, click the red triangle icon on the Contingency Table report.

Measures of Association Option Added
The Measures of Association option has been added to the Contingency Analysis red triangle menu. This option produces a report with the following measures: Gamma, Kendall’s Tau-b, Stuart’s Tau-c, Somer Ds, Lambda Asymmetric and Symmetric, Uncertainty Coefficient Asymmetric and Symmetric.

Change the Alpha Level
You can now change the alpha level for all confidence levels in the Contingency platform. Select Set α Level from the Contingency Analysis red triangle menu.

Fisher’s Exact Test

Note: This feature is available only in JMP Pro, Version 9.

You can now perform a Fisher’s Exact test for a table with more than 2x2 levels.

Life Distribution

The Quality and Reliability Methods book includes details about the new Life Distribution features.

Custom Estimate
Custom Estimate creates tables of estimates and confidence intervals of failure probabilities and quantiles based on a fitted distribution. Both Wald and profile likelihood intervals are supported. To see this feature, select Custom Prediction from the Parameter Estimate red triangle menu.
Support for Simultaneous Confidence Bands

In the Compare Distributions plot, simultaneous confidence bands are supported for the Kaplan-Meier estimate. To see this feature, select Interval Type > Simultaneous or Pointwise from the Life Distribution red triangle menu.

Survival Curves

You can plot the probability of survival curves rather than the probability of failure curves throughout the platform. To see this feature, select Show Survival Curve from the Life Distribution red triangle menu. The curves switch from survival to failure.

Fit Model

The Modeling and Multivariate Methods book includes details about the new Fit Model features.

Least Squares

Covariate Values for Contrast

For Least Squares, Generalized Linear Models, and MANOVA Contrast, you can now specify covariate values for cases when the covariate is involved in the contrast.

Joint Profiler for REML Models

When you have multiple responses for REML models, you can now use the Prediction Profiler to optimize all responses at the same time.

Logistic

Confusion Matrix

Note: This feature is available only in JMP Pro, Version 9.

The Nominal and Ordinal Logistic reports now have a Confusion Matrix option in the red triangle menu.

Model Assessment Using Training and Validation Sets

Note: This feature is available only in JMP Pro, Version 9.

You can now assess models by validation and test sets. To create validation and test sets, specify a validation column in the launch window. The values in that column designate which rows are used for training, validation, and test sets. This option is now available in Partition, Neural, and Fit Model (Nominal Logistic and Stepwise).
New Features in JMP 9
Analysis Platforms

Logistic (Nominal and Ordinal) generates validation and test statistics as Neural does.

- The Validation column can now contain character and numeric values.
- The column is treated as a categorical variable with up to three levels: low level for training (except that Stepwise Least Squares supports K-Fold for more than three levels); second level for validation; and third level for Test Set.

Launch Window

Response Surface Macro Allows Categorical Terms

Categorical terms for the Response Surface effect macro can now be selected in the Fit Model launch window. All the main effects and crosses are produced as usual, but square effects for the categorical terms are avoided.

Change the Alpha Level

You can now change the default alpha level (.05) to any valid number. To see this feature, click the red triangle icon on the Model Specification report in the Fit Model launch window and select Set Alpha Level.

Keep the Launch Window Open

You can now choose to keep the launch window open after you run your analysis. Select the check box next to Keep dialog open in the launch window. Alternatively, you can use the new JSL command Modal Dialog in the fitted window.

In addition, the button on the launch window has been changed from Run Model to Run.

Standard Least Squares

Sum of Squares Error Values Added to the Box-Cox

The Box-Cox Transformation Table of Estimates now contains the SSE values. To see this feature, click the red triangle icon on the Standard Least Squares report and select Factor Profiling > Box Cox Y Transformation. Select Table of Estimates from the Box Cox Transformations report red triangle menu. The new Sum of Squares Error column is populated with values.

New Options in the Save Columns Menu

Two options have been added to the Save Columns menu for the Standard Least Squares personality: Mean Confidence Limit Formula and Indiv Confidence Limit Formula.

Alpha specification support has been added to JSL command functionality for all saved confidence limits. Hold down the SHIFT key and select Mean Confidence Limit Formula or Indiv Confidence Limit Formula. You are prompted to enter the alpha level.
Inverse Prediction Improvements

Inverse prediction in the Fit Model platform has been improved. For example, these improvements are useful in drug stability analyses.

The following features have been updated:

- Inverse prediction is now specified by term value rather than regression design row value.
- Virtually any model is allowed, as long as the term of interest participates linearly in the effects. This means that it works in situations like Analysis of Covariance with an interaction.
- The window is modal rather than contained in the platform report.
- Inverse prediction supports prediction for all levels of categorical variables as an alternative to specifying single category values.
- Inverse prediction still does not support REML and quadratic terms of interest.
- A new graph is produced with the confidence intervals.
- The Fit Y by X Logistic and Fit Model Nominal Logistic platforms also now support the new Inverse Prediction facility.
- Inverse prediction now uses a Wald interval if the Fieller interval fails for both sides.
- If only one side of the interval fails, it is set to missing (implying infinity).
- Inverse prediction now supports one-sided intervals using combo box specification or through scripting.

To see the inverse prediction improvements, create a Fit Model report and select Estimates > Inverse Prediction from the red triangle menu. Enter the Y values to include in the inverse prediction.

Overlay LS Means Plots

To further illustrate three-way interactions, multiple overlay LS Means plots now appear in the report window (assuming that your model has a three-way interaction).

Show the Variance Inflation Factor and Confidence Intervals

The Fit Least Squares platform includes two new options on the Preferences menu:

- **Show VIF** always shows the Variance Inflation Factor (VIF) for the Parameter Estimates report.
- **Show All Confidence Intervals** always shows all of the confidence intervals in the Parameter Estimates report that might otherwise be hidden. To turn this feature on and off, select or deselect Regression Reports > Show All Confidence Intervals in the report’s red triangle menu.

Save Standard Error Prediction Formula for Split Plot Models

For the split plot models using the REML method, the report menu option to save the standard error prediction formula (STDErr Pred Formula) is now available.

To see this feature, select **Save Columns > StdErr Pred Formula**.
Stepwise Features

The following Stepwise features have been added:

- Stepwise now supports multiple $y$ variables. Each $y$ variable can be modeled separately. To apply actions to all $y$ variables, hold down the CTRL key and click Go.

- Click the Run Model button to generate all test results in the same report window. JMP uses the current model and directly calls the appropriate personality, such as Standard Least Squares or Ordinal Logistic.

- The fitting statistics have been moved so that they are more easily seen when you fit multiple models. The statistics are now located directly above the Current Estimates report. To make the model-fitting statistics row more visible in the report when fitting multiple models, right-click the other disclosure buttons and select Close All Like This.

- The response variable name is now located in the title bar for each model and is shown as a separate outline. The title bar is labeled Stepwise Fit for YNAME.

- RMSE is now shown instead of MSE in the model-fitting statistics row, but MSE is available as a hidden column. To see the MSE column, right-click in the model-fitting statistics row and select Columns > MSE.

- New columns have been added to the model-fitting statistics row and include p (the number of parameters in the model) and BIC (Bayesian Information Criterion).

- The following new stopping rules are available:
  - Minimum AIC
  - Minimum BIC
  - Validation RSquare (if a validation column is specified)
  
  The old stopping rule (P-value Threshold) is not recommended.

- You can click the radio button for a step to return the model to its previous state in the step history.

Model Assessment Using Training and Validation Sets

Note: This feature is available only in JMP Pro, Version 9.

You can now assess models by validation and test sets. To create validation and test sets, specify a validation column in the launch window. The values in that column designate which rows are used for training, validation, and test sets. This option is now available in Partition, Neural, and Fit Model (Nominal Logistic and Stepwise).

Stepwise generates validation and test statistics as Neural does.

- The Validation column can now contain character and numeric values.

- The column is treated as a categorical variable with up to three levels: low level for training (except that Stepwise Least Squares supports K-Fold for more than three levels); second level for validation; and third level for Test Set.
You select the Validation column in the launch window. The values in that column designate which rows are used for training, validation, and test sets. For continuous responses, you can use both holdback and K-Fold cross validation. For nominal and ordinal responses, you can use only holdback validation.

On the red triangle menu, the **K-Fold Crossvalidation** command starts K-Fold at that time using a random selection. Note that once you begin this process, the process is committed and cannot be disabled.

### Nominal and Ordinal Logistic

**Confidence Intervals Added for Odds Ratios**

- In the Nominal Logistic personality, confidence intervals have been added for the odds ratios for two-level responses.
- The Parameter Estimates report now includes a Covariance of Estimates report. This report shows the variances and covariances of the parameter estimates.

**Whole Model Test Report Updates**

For the Nominal Logistic personality, a new section appears in the Whole Model Test report that includes these columns: Measure, Training, and Definition.

- When you specified a validation set, additional columns appear. The additional column is Validation.
- When there are tied maximums, the misclassification rate contains a message to indicate this. When there are fitted zero probabilities for events that occur in the validation data, a message appears.

For the Nominal and Ordinal Logistic personalities, the Whole Model Test report now includes the corrected Akaike's Information Criterion (AICc) and the Bayesian Information Criterion (BIC) results.

### Proportional Hazard

**Risk Ratio Confidence Intervals Added for Nominal and Ordinal Factors**

Risk Ratio confidence intervals in the Cox Proportional Hazards model are now calculated for both nominal and ordinal factors. Previously, only confidence intervals for continuous factors were calculated. A report called Covariance of Estimates has also been added to the Parameter Estimates report. This report shows the variances and covariances of the parameter estimates.

### Generalized Linear Model

**Inverse Prediction and Additional Diagnostic Plots**

When you want to predict an $x$ value given a $y$ value and the values of all the other factors, you can now use inverse prediction. To see this feature, create a Generalized Linear Model report. Select **Inverse Prediction** from the red triangle menu, and then enter the $y$ values to include in the prediction.
New Features in JMP 9

Analysis Platforms

The following diagnostic plots are also new:

- Regression plot shows the responses and the model on the Y axis and the continuous covariate on the X axis. This plot is available only when you specify one continuous predictor and no more than one categorical predictor. The Regression Plot is generated by default.

  To hide the plot, select Diagnostic Plots > Regression Plot from the Generalized Linear Model red triangle menu.

- Linear Predictor plot shows the linear model plotted on the Y axis and the continuous covariate on the X axis. The inverse link function transformed responses are overlaid. This plot is available only when there is one continuous predictor and no more than one categorical predictor. To see this feature, select Diagnostic Plots > Linear Predictor Plot from the Generalized Linear Model red triangle menu.

Multivariate

The Modeling and Multivariate Methods book includes details about the new Multivariate features.

Multi-Threaded Estimation Methods

Rowwise and pairwise estimation methods are now multithreaded.

To see this feature, select Analyze > Multivariate > Multivariate Methods > Multivariate and select Row-wise or Pairwise from the Estimation Method list.

Partition

The Modeling and Multivariate Methods book includes details about the new Partition features.

Bootstrap Forest and Boosted Tree Options

**Note:** This feature is available only in JMP Pro, Version 9.

The new Bootstrap Forest and Boosted Tree options fit many Partition models and combine them to generate more accurate predictions than a single Partition model can predict.

To see these features, select Analyze > Modeling > Partition and select Bootstrap Forest or Boosted Tree from the Method list. After you click OK, enter the Bootstrap Forest or Boosted Tree specifications.

Model Assessment Using Training and Validation Sets

**Note:** This feature is available only in JMP Pro, Version 9.

You can now assess models by validation and test sets. To create validation and test sets, select Analyze > Modeling > Partition and do one of the following:

- Specify a Validation column in the launch window. The values in that column designate which rows are used for training, validation, and test sets.
- Enter the portion of the data to be used as the validation set next to Validation Portion.
You can also select **Show Fit Details** from the red triangle menu to show several measures of fit and a confusion matrix. The confusion matrix is a two-way classification of actual and predicted response. This feature is for categorical responses only.

**Principal Components**

The *Modeling and Multivariate Methods* book includes details about the new Principal Components features.

**Maximum Likelihood Factor Analysis**

You can now choose Maximum Likelihood as the factoring method. This method is from Magnus and Neudecker, *Matrix Differential Calculus*.

**Add Promax For Factor Analysis**

Promax is a new oblique rotation method available in factor analysis as a factor rotation method.

**Matched Pairs**

The *Basic Analysis and Graphing* book includes details about the new Matched Pairs features.

**Perform a Sign Test**

You can now perform a sign test for matched pairs. This is a nonparametric version of the paired t-test that uses only the sign (positive or negative) of the differences for the test.

To see this feature, select **Sign Tests** from the Matched Pairs red triangle menu.

**Time Series**

The *Modeling and Multivariate Methods* book includes details about the new Time Series features.

**New ARIMA Model Group Option**

You can simultaneously fit a range of ARIMA models. Previously, you could fit only a single model at a time.

**Save Prediction Formula Option**

Creates a new data table containing the forecast formula, which you can use to forecast future values.

To see this feature, click the red triangle icon on the ARIMA Model report and select **Save Prediction Formula**.
New Features in JMP 9
Analysis Platforms

Updated Model Comparison Report
Using the updated Model Comparison report, you can perform the following actions:

- overlay fitted models on a graph of the data
- access new options to simulate future values and fit variations of existing models
- show or hide individual model reports

Recurrence Analysis

The Quality and Reliability Methods book includes details about the new Recurrence Analysis features.

View the MCFs of Individual Groups
The new MCF Plot Each Group option lets you plot each of the individual MCFs separately.
To see this feature, select MCF Plot Each Group from the Recurrence Analysis report red triangle menu.

Recurrence Fitting Models
You can now fit recurrence patterns to one of several models. The models are “good-as-was” or minimal repair models; it is assumed that after an event, the unit is restored to the same condition that it was in before the defect occurred. This is in contrast to renewal models, where the unit is restored to a “good-as-new” state. (You can model renewal models using the Survival/Reliability event failure models.)
The Recurrence platform now fits models for the Recurrence Intensity and Cumulative functions. You can model the parameters as functions of covariates.

Cost-Zero Events
Cost-zero events can now exist anywhere in the time course of a unit. Previously, cost-zero events were used only to represent end-of-service.

Cause Button
A Cause button has been added to the launch window. If you have multiple failure modes, you can specify a cause. The number of MCFs (Mean Cumulant Functions) estimated are the product of the number of causes and the number of groups.

Survival

The Quality and Reliability Methods book includes details about the new Survival features.

Save Confidence Intervals
The Save Estimate command now also saves the confidence intervals for survival, the confidence intervals for failure, the simultaneous confidence intervals for survival, and the simultaneous confidence intervals for failure.
Nonlinear

The *Modeling and Multivariate Methods* book includes details about the new Nonlinear features.

Expand Intermediate Formulas

You can select the **Expand Intermediate Formulas** option on the launch window. This option searches the prediction and loss formulas for column references and replaces them with the columns’ formula where possible. The replacement is recursive. If a column formula references another column that has a formula as well, then both columns are replaced with relevant formulas.

Inverse Prediction Improvements

The inverse prediction option in the Nonlinear platform has been improved substantially so that non-linear degradation models, including the special case of Stability Analysis, can be analyzed. The inverse prediction improvements include:

- You can select from several columns in a model.
- For categorical terms, you can select a level or select all levels.
- You can invert up to eight Y values.
- A confidence interval can be produced, as well as the standard error. This is a Wald interval based on a t quantile.
- The **Save Inverse Prediction** option also allows for multiple columns. You are asked to select the column to invert.

Support for Grouping Columns in the Nonlinear Model Library

For any model in the Nonlinear Model Library, you can select a grouping column. This adds the group column and the appropriate parameters to the formula automatically.

To see this feature, in the Nonlinear launch window, click **Model Library**, Select a model from the list and click **Make Formula**. The **Group** button has been added to the Select Columns window.

Categorical

The *Modeling and Multivariate Methods* book includes details about the new Categorical features.

Count Duplicate Events Only Once

If you have duplicate events, but you only want to count them once for each subject, select the **Unique occurrences within ID** check box on the launch window. This option is useful when you have adverse events so that repeated events are not counted twice.
New Features in JMP 9
Analysis Platforms

New Save Tables Options
In the Save Tables option, you can now save the following information:

- Frequencies
- Share of Responses
- Rate Per Case
- Transposed Frequencies
- Transposed Share of Responses
- Transposed Rate Per Case
- Test Rates
- Test Homogeneity

Select one of these options from the Categorical red triangle menu under Save Tables. JMP then displays the selected information in one or more new data tables.

Relative Risk Report
There is a new option on the red triangle menu for Categorical called Relative Risk. You can choose your sample level of interest, then view the Relative Risk report. The Relative Risk report shows the ratios of rates from one sample to another and their confidence intervals. The report also contains legends and scale headings.

Report Improvements
Reports now show group separators instead of listing the same group values multiple times. Groups are separated by horizontal lines.

Test Options
There are new test options on the Categorical red triangle menu. You can choose from a Likelihood Ratio Chi-Square test, a Pearson Chi-Square test, or both.

Grouping Option
On the launch window, there is a new Grouping option for multiple X variables. You can choose from the following options: Combinations, Each Individually, or Both.

Make Combined Data Table Update
When you right-click a report table and select Make Combined Data Table, a new data table appears. The X grouping variables that you selected in the launch window are included in that data table.

Test Each Response Updates
The Test Each Response report includes a bar chart that shows which group has the most significance.
The **Conditional Association** option computes the conditional probability of one response given a different response. This option is available in the Categorical red triangle menu only when the **Unique occurrences within ID** check box is selected on the launch window.

**Transpose Chart**

The Categorical platform now has an option to lengthen wide charts or shorten long charts automatically. This option is helpful when you are doing categorical analyses with many response categories.

---

**Design of Experiments (DOE)**

This section describes the new DOE features. For details, see the *Design of Experiments* book.

---

**Figure 8  Report from the New Accelerated Lift Test Design Platform**
New Features in JMP 9
Design of Experiments (DOE)

Space Filling Designs Scripting
Scripting support is now available for Space Filling Designs. Theta vectors can be specified for Maximum Entropy designs and for an integrated mean squared error of the Gaussian process (IMSE) designs.

Design methods include the following:

- Sphere Packing
- Latin Hypercube
- Uniform
- Minimum Potential
- Maximum Entropy
- Gaussian Process IMSE Optimal

Color Map On Correlations
The new Color Map On Correlations panel shows the correlations between all model terms and alias terms that you specify in the Alias Terms panel. The colors correspond to the absolute value of the correlations.

Specify Aliasing Terms
You can now specify aliasing terms to be used in the alias matrix. In earlier versions of JMP, the alias matrix was shown only for two-level designs. In JMP 9, model and alias terms are both available, and an alias model always appears. A color map on correlations of all model terms and aliasing terms also appears. Place your cursor over any cell in the color map to see the term.

Alias Optimal Design
For Custom Designs, a new design is available in the red triangle menu. To access the Alias Optimal Design, select Optimality Criterion > Make Alias Optimal Design. This design minimizes the sum of squares of the entries in the alias matrix subject to constraining the d-efficiency of the design to be above some lower bound.

Accelerated Life Test Design
Accelerated Life Test Design is a new DOE platform for designing high stress tests. These tests quickly cause failure. These tests quickly identify product weaknesses. You can design tests based on one or two accelerating factors with either a main effects model or an interaction model for the latter.

You can also optimize your test plan using one of the following options:

- D-optimal
- time I-optimal
- probability I-optimal

Sample Size and Power
Reliability Test Plans
Reliability Test Plans help determine the sample size or the length of study needed to obtain a certain precision about a fitted quantile or probability.
You can specify the following:

- a distribution (Weibull, Lognormal, Fréchet, Loglogistic, Logistic, SEV, LEV, and Normal) and its parameters
- a quantity of interest (Quantile or Probability)
- a desired measure of precision based on a confidence interval around the quantity of interest

You then solve for sample size, censor time, or precision.

**Demonstration Plans**

Demonstration Plans let you design a test to compare the reliability of a new product to a standard. You can specify the following:

- a distribution (Weibull, Lognormal, Fréchet, Loglogistic, Logistic, SEV, LEV, and Normal) and its parameters
- the number of failures tolerated during the demonstration
- a reliability standard

You then solve for sample size or the length of the study.

**Graphics and Display**

This section describes the new graphics and display features. These features are covered in the *Using JMP* book except where noted.

---

**Figure 9**  Example of a Background Map in a Bubble Plot Report
New Features in JMP 9
Graphics and Display

Geographical Images and Boundaries
You can now add different Earth maps to graphs. Right-click in a graph and select Background Map to choose from the following images:

- The Simple Earth and Detailed Earth maps are installed with JMP.
- NASA server provides maps using a protocol called Web Map Service (WMS) to show their most up-to-date maps.
- Web Map Service lets you enter the URL for a Web site that provides maps using the WMS protocol. You also specify the map layer.

Image Manipulation
Image support and image processing is greatly enhanced in JMP 9. Here are some of the new options:

- Drag and drop a graphic file into a graph.
- Resize, rotate, crop, move, and delete the graphic.
- Lock the graphic in place so it cannot be manipulated.
- Set a graphic to be partially transparent.
- Apply any of several filters (for example, despeckle, contrast, reduce noise, and Gaussian blur).

Enhanced Marker Selection Modes
The context menu for any graph lets you determine how selected points are shown:

- Unselected Faded draws points that are not selected in a lighter shade than points that are selected. This is the default behavior for JMP 9.
- Selected Larger draws selected points using a larger marker. This is the behavior for JMP 8 and earlier.
- Selected Outlined draws an outline around selected points.
- Selected Halo draws an outline using the selection color around selected points.

Movable Marker Labels
You can select a label in a graph and drag it to a new location. If you drag a label a certain distance away from the marker, then a tail is added that connects the label to its point.

SHP File Import
JMP uses ESRI SHP files as a source of vector shape data for map charts.

Custom Color Scales and Gradients
The following color options are now supported:

- Create custom color themes. Select File > Preferences > Reports > Customize Themes and create the new color theme.
- Right-click the gradient to interactively edit color stops. The new option called Copy From lets you create a new theme based on a theme that already exists.
• Specify whether the color theme is for continuous or categorical variables.
• All places in JMP that use color themes also support custom color themes. This includes platforms, value colors, color by column, and JSL.
• JSL also supports anonymous custom color themes, which are color theme definitions that are not stored in preferences.
• There is a gradient color theme legend for continuous color themes in Graph Builder, which allows further customization of how a color theme is applied to data.

**Box Plot Enhancements**

Box plots have been enhanced throughout JMP. Currently, box plots support the following:

• median
• colors
• confidence diamonds
• shortest half
• lines styles
• whiskers
• fences
• transparency
• solid fill
• thin box plots

All of the preceding items are customizable.

The following platforms support enhanced box plots:

• Distribution
• Oneway
• Graph Builder
• Control Chart
• Variability/Gauge
• Capability

For details about box plots, see the *Basic Analysis and Graphing* book.

**Save EPS Output**

For the **Save As** and **Save Selection As** options, EPS is now supported as a graphic output format.
New Features in JMP 9

Microsoft Excel Profiler

Show Specification and Response Limits as Reference Lines

For graphs that include an axis, you can now show specification limits and response limits as reference lines. To set one of these options, select either Spec Limits or Response Limits from the Column Properties list. A new check box called Show as graph reference lines appears.

GIF Files

In the Preferences, you can choose GIF as the default HTML graphic format. Note that GIF is also a choice when you select File > Save As and click the Save as type list.

Create Diagonal Labels

You can now change axis labels in the Axis Specification window. These labels are drawn at a 45-degree angle.

Microsoft Excel Profiler

This section describes the new Excel Profiler. For details, see the Modeling and Multivariate Methods book.

Figure 10  New Microsoft Excel Profiler and Sample Report

JMP 9 comes with the new ability to apply JMP’s powerful profiler to Microsoft Excel models. A new JSL command Excel Profiler( Workbook("file path"), Model("model name") ) brings this capability to JSL scripts. In JMP’s user interface, you can find the Excel Profiler here: Graph > Excel Profiler. An Excel Profiler button also appears in the Surface category in the JMP Starter window.

This feature is provided by a Microsoft Excel add-in that has bi-directional connectivity to JMP. In Microsoft Excel, the add-in gives you a new method for transferring Microsoft Excel data to JMP. You select the desired rows and columns and click on Transfer to JMP. JMP 9 opens (if it is not already running), and the selected data is exported to a new data table.
In the Microsoft Excel add-in window, you mark the inputs and the outputs of your computational model(s). This marking of inputs and outputs lets JMP work with Microsoft Excel and use the output of the worksheet’s formula in JMP’s profiler.

Note the following:
- In this initial release, only continuous models are supported.
- The Excel Profiler is compatible with Office 2003, Office 2007, and Office 2010 versions of Excel.

**JMP Scripting Language**

This section describes the new JMP Scripting Language (JSL) features. For details about using JSL, see the *Scripting Guide* book.

**Work with Windows and Files**

**Set Main Window**

You can now set any window as the main window for JMP. This ability can be useful when constructing customized add-ins. The syntax is as follows:

```javascript
w = New Window( "Window Title",
    Text Box( "Main JMP Window" )
);
w << Set Main Window;
```

Setting a custom window as the main window overrides other Preference settings. For example, if the JMP Starter Window is set as the default window, that preference is ignored and the custom window is used instead.

**Saved Scripts**

The property setting `Show(0)` saves hidden states in scripts. This property setting is the same keyword that appears in the modal window.

**Additional Arguments for Pick File**

`Pick File` accepts three new, optional arguments. The syntax is as follows:

```javascript
Pick File(  
    "window name",
    "path",
    {list of filters},
    integer,
    Boolean, /*1-open, 0-save*/
    "filename"
)
```

- The fourth parameter indicates which filter (of the list provided) is initially selected.
New Features in JMP 9

JMP Scripting Language

- The fifth parameter indicates whether the file must exist and determines whether the window should be displayed as a save (0) or open window (1). Open window (1) is the default.
- The sixth parameter is the name of the initial file selected.

The Print Window Message for a Window can Display the Print Window

An optional argument, Show Dialog, causes the print window to appear. The syntax is:

```julia
window << Print Window( Show Dialog );
```

Save a Journal as a PDF File

A new message for a journal, Save PDF(filepath), saves the journal as a PDF to the specified filepath.

Close Journals

You can now close an unsaved journal and specify not to prompt to save the file.

```julia
journal << Close Window( nosave )
```

Work with Zip Files

JMP can now create a JSL object to represent a zip file using the Open function:

```julia
ziparchive = Open("c:\path\filename.ext", zip);
```

where `filename.ext` is the zip file. Note that the `.ext` extension is often .zip but might be, for example, jmpaddin. If you do not include the extension argument, the zip file is opened in your default zip application instead of in JMP.

You can get a list of files in a zip file, get the actual contents as either string or a blob, and you can write a zip file. To delete one or more files in a zip file, you must write a new zip file excluding the files that you want to delete.

```julia
ziparchive << Read("filename", <Format(blob)>);
ziparchive << Write("filename", "string" | blob);
```

Toolbars and Menus in New Window

The default window created by New Window() in the new Windows environment is a window with a menu and toolbars. Several new arguments for New Window() let you hide the menu (Show Menu(False)) or toolbars (Show Toolbars(False)). If you have requested a menu, you can suppress the menu auto-hide behavior (Suppress Auto Hide).

Run Included Scripts in an Independent Namespace

You can now run an included script from another script in a new namespace instead of the calling script’s namespace. The syntax is as follows:

```julia
Include( filename, << New Context );
```

Using the New Context message causes the included script to be executed in its own unique Here namespace, which also has normal access to Global variables.
You can also insulate a script from the current user environment. Unqualified names in a script with the new `Names Default To Here` mode turned on are private to that script. The syntax is as follows:

```
Names Default To Here(1);
```

**Create Modal Windows**

Use the new `<Modal` message for `New Window()` to create a modal window that provides full access to all JSL display boxes. `Dialog()` is deprecated.

**Work with Data Tables**

**Set the Column Label Preference for SAS**

The optional `UseLabelsForVarNames` argument for `Open()` specifies to use SAS labels for variable names when opening SAS data sets.

**Open and Load Text File**

The `Open()` function and the `Load Text File()` function both have two new optional arguments:

- `Charset("string")`: Controls the character encoding when JMP imports a text file. "Best Guess" lets JMP determine the character encoding, or you can specify the character encoding of your choice. For example, "utf-8" or "shift-jis".
- `Force("string")`: Specifies how the function handles any conversion errors. The options are "throw", "alert", or "silent".

**Close All**

`Close All(Data Tables, No Save)` now closes all data tables and their dependent report windows.

**Data View is Expanded**

You can now use the `<Data View()` message to make new data tables of labeled rows, excluded rows, hidden rows, and selected rows. The syntax is:

```
dt << data view(<value>)
```

If no argument is specified, "selected" is assumed. Possible values are:

- `excluded`
- `labeled` or `labelled`
- `hidden`
- `selected`
New Features in JMP 9
JMP Scripting Language

Get Scripts and Table Variables

Two new data table messages have been added:

- `dt << Get Table Script Names` returns a list of names of all of the scripts in the data table.
- `dt << Get Table Variable Names` returns a list of names of all of the table variables in the data table.

Clone Formula Column

A new message for a data table makes a set of formula columns similar to a given column, but mapped to different sets of dependent columns.

```
dt << Clone Formula Column(formula column, n, substitute column reference(column, new column), ...)
```

Note the following:

- **Formula column** is a column with a formula that you want to clone.
- **n** is the number of columns to create.
- For each column in the original formula that you want to change, you should add a **substitute column reference** argument. **Substitute column reference** takes two arguments. **Column** is the column to replace. **new column** is either a column to replace it or a list of columns equal to the number of new columns that you are creating.
- You can also replace **n** with a list of existing columns to standardize formulas across them.

Specify Summary Table Names with Variables

When creating a summary table, you can now use a variable as the name argument.

Stack Either All Columns or Selected Columns

Stack() has two new options:

- **Columns(All Columns)** stacks all the columns in the data table.
- **Columns(All Selected Columns)** stacks all the selected columns in data table.

Trigger Events with Data Table Actions

A JSL application can now subscribe to the data table in such a way that when certain events occur in the data table, the application gets notified. The supported events are as follows:

- when the data table is closed (**onClose**)
- when rows are added or deleted from the data table (**onAdd Rows** or **onDeleteRows**)
- when columns are added or deleted from the data table (**onAddColumns** or **onDeleteColumns**)
The syntax is:
```jsl
current data table() << subscribe("a", onclose(func));
```
where `a` is the name to identify the application and `func` is a JSL function that gets called when the data table is to be closed. The first argument in the JSL function `func` should be the dependent data table.

**Last Modified**

`dt << Last Modified` returns the date and time that the data table was saved on disk. The message returns `missing` if the data table has never been saved.

**Color Gradient**

`<< Set Property` and `<< Get Property` also now handle the new Color Gradient option. For example:
```jsl
column << Get Property( "Color Gradient" );
{"Spectral", Range( 2, 100 )}
```
and
```jsl
column << Set Property( "Color Gradient", {"Spectral", Range( 2, 100 )} );
```

**Column Names for Data Tables**

When you create a data table using the `As Table(matrix)` function, you can specify a list of column names as follows:
```jsl
As Table(matrix, <matrix 2, ...>, <<invisible>, <<Column Names(list)>)
```

### Preferences, Path Variables, and Environment Variables

**Missing Value Rule Preference in Partition**

The Missing Value Rule option has been removed from both the menu and Preferences.

- If you have a script that specifies `Closest` in the platform call, this still works as expected. For example,
  ```jsl
  Partition( ... Missing Value Rule("Closest") ... );
  ```
- However, a script that specifies the `Missing Value Rule` as a Platform preference displays syntax errors in the log. For example:
  ```jsl
  Platform Preferences( Partition ( Missing Value Rule("Closest") ) );
  Partition ( ... );
  ```

**Path Variables**

JMP handles path variables (`$SAMPLE_DATA`, `$SAMPLE_IMPORT_DATA`, `$SAMPLE_SCRIPTS`) and system path variables (`$HOME`, `$DOCUMENTS`, `$TEMP`, `$JMP_HOME`, `$GENOMICS_HOME` if JMP Genomics is installed) more efficiently:

- When you change the language that JMP runs in, the variable definitions are automatically changed to match the language.
New Features in JMP 9
JMP Scripting Language

- When you switch from running one version of JMP to another (for example, JMP 8 to JMP 9), the variable definitions are changed to match the language automatically.
- The path variable `$ENGLISH_SAMPLE_DATA` always defines the English Sample Data folder.

A new path variable, `$ALL_HOME`, now points to a folder that can be accessed by all users on a machine. These folders are different according to the operating system, as shown in Table 1.

Table 1 `$ALL_HOME` Path Variable

<table>
<thead>
<tr>
<th>Operating System</th>
<th>All Users Folder</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7 or Windows Vista</td>
<td>C:\ProgramData\SAS\JMP\9</td>
</tr>
<tr>
<td>Windows XP</td>
<td>C:\Documents and Settings\All Users\Application Data\SAS\JMP\9</td>
</tr>
<tr>
<td>Macintosh</td>
<td>~/Users/Shared/</td>
</tr>
</tbody>
</table>

New Settings for Running Scripts when JMP Starts

There are now two levels of start scripts for JMP: an administrator level and a user level. When JMP starts, JMP looks in the following two locations for `jmpStartAdmin.jsl`:

- C:\Documents and Settings\All Users\Application Data\SAS\JMP\9 (Windows XP)
  - C:\ProgramData\SAS\JMP\9 (Windows Vista and Windows 7)
  - ~/Library/Application Support/JMP/9 (Macintosh)
- C:\Documents and Settings\All Users\Application Data\SAS\JMP (Windows XP)
  - C:\ProgramData\SAS\JMP (Windows Vista and Windows 7)
  - ~/Library/Application Support/JMP (Macintosh)

The first one that is found is run, and the search stops. When either `jmpStartAdmin.jsl` is run, or when this file is not found, JMP then looks in the following two locations for `jmpStart.jsl`:

- C:\Documents and Settings\<user>\Local Settings\Application Data\SAS\JMP\9 (Windows XP)
  - C:\Users\<user>\AppData\Local\SAS\JMP\9 (Windows Vista and Windows 7)
  - ~/Library/Application Support/JMP/9 (Macintosh)
- C:\Documents and Settings\<user>\Local Settings\Application Data\SAS\JMP (Windows XP)
  - C:\Users\<user>\AppData\Local\SAS\JMP (Windows Vista and Windows 7)
  - ~/Library/Application Support/JMP (Macintosh)

Get Values of System Environment Variables

You can now get the values of system environment variables using a new function, `Get Environment Variable(varname)`. If the environment variable does not exist, an empty string is returned.
Work with the Log

**LogCapture**

This new function evaluates an expression argument and returns a string containing the text that was written to the log while the expression was being evaluated. A JSL program can examine the string to determine what to do next. In most cases, this is not necessary, because the JSL functions return information about special conditions. The functions might also return an error that you can investigate with the `Try` function. In other cases, the information only goes to the log, so you use the new `LogCapture` function to determine what happened.

**New Functions to Get JMP Log Contents**

New JSL functions have been added to obtain the contents of the JMP Log:

- `Get Log()` retrieves all lines in the JMP Log and returns a list of those lines as strings.
- `Get Log Head(N)` retrieves the first N lines in the JMP Log and returns a list of those lines as strings.
- `Get Log Tail(N)` retrieves the last N lines in the JMP Log and returns a list of those lines as strings.

**Project Scripting**

Scripting for JMP Projects has been greatly enhanced. Table 2 summarizes the changes from JMP 8 to JMP 9.

**Table 2** Changes in Project Scripting

<table>
<thead>
<tr>
<th>Item</th>
<th>JMP 8 Behavior</th>
<th>JMP 9 Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Log Messages</td>
<td>Any items are returned as project.</td>
<td>A more appropriate name is shown.</td>
</tr>
<tr>
<td></td>
<td>Example</td>
<td>Example</td>
</tr>
<tr>
<td></td>
<td>g1 = p &lt;&lt; Find(&quot;Group1&quot;);</td>
<td>g1 = p &lt;&lt; Find(&quot;Group1&quot;);</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(\text{Project Group:Group1})</td>
</tr>
<tr>
<td>Properties for Group items</td>
<td>The (&lt;\text{Properties}&gt; message did not return any value when sent to a Group item.</td>
<td>The Group item now returns item properties like other project items.</td>
</tr>
</tbody>
</table>
| Navigation functions      | Project navigation messages (for example, \(<\text{FirstChild}\>, \(<\text{NextSibling}\>, \(<\text{GetPreviousSibling}\>, and \(<\text{GetParent}\>) display an error in the log if no more items are available.) | Project navigation messages return empty, which can be tested for with \(\text{IsEmpty()}\). | return empty, which can be tested for with `IsEmpty()`.
New Features in JMP 9
JMP Scripting Language

Table 2  Changes in Project Scripting  (Continued)

<table>
<thead>
<tr>
<th>Item</th>
<th>JMP 8 Behavior</th>
<th>JMP 9 Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>New &lt;&lt; Open message</td>
<td>To open project items, specific messages (for example, &lt;&lt; Open Window) are required.</td>
<td>The specific messages still work. A new and more general &lt;&lt; Open message is available, to which items respond appropriately.</td>
</tr>
<tr>
<td>Output for the &lt;&lt; Properties message for documents</td>
<td>The output of the &lt;&lt; Properties message is a single, large string.</td>
<td>An associative array of properties is returned allowing direct access to the desired property value.</td>
</tr>
<tr>
<td>SAS Stored Processes</td>
<td>There is no JSL method of adding a stored process.</td>
<td>You can now add stored processes to projects.</td>
</tr>
<tr>
<td>&lt;&lt; Properties message for documents</td>
<td>The Last Accessed Date is returned.</td>
<td>The Last Accessed Date is no longer returned.</td>
</tr>
<tr>
<td>Invisible Option</td>
<td>All opened or created projects are visible.</td>
<td>All opened or created projects are visible.</td>
</tr>
<tr>
<td>Get Project List()</td>
<td>Not available</td>
<td>Returns a list of all open projects, including invisible projects.</td>
</tr>
<tr>
<td>Folder items</td>
<td>There is no message to populate child items in a folder project item. The item has to be expanded by using the project tree interface.</td>
<td>When the &lt;&lt; Open message is sent to a folder, child items are populated. Child items are not automatically filled in all folders.</td>
</tr>
<tr>
<td>New &lt;&lt; Add All Windows message</td>
<td>Not available</td>
<td>projectName &lt;&lt; Add All Windows() adds all open windows to the project, and returns a list of the windows that are added.</td>
</tr>
<tr>
<td>The &lt;&lt; Set Restore All On Project Open message is changed</td>
<td>Accepts these arguments:</td>
<td>Accepts these arguments:</td>
</tr>
<tr>
<td></td>
<td>• 0 (restore no windows)</td>
<td>• 0 (restore no windows)</td>
</tr>
<tr>
<td></td>
<td>• 1 (restore all windows)</td>
<td>• 1 (restore all windows)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• -1 (restore marked windows)</td>
</tr>
</tbody>
</table>
Formula Editor Functions

New Dunnett Functions

Dunnett Quantile and Dunnett P Value are now available. The syntax is:

Dunnett Quantile( 1 - alpha, ngroups, dfe, lambdaVec );
Dunnett P value( q, ngroups, dfe, lambdaVec );

New If Min and If Max Functions

These two new functions make executing actions based on the maximum or minimum values easier. The syntax for both is the same, and similar to If().

If Max(expr1, result1, expr2, result2, ..., <allMissingValuesResult>)

New Probability and Random Functions

The following new probability and random functions have been added:

- SEV Density(x, mu, sigma), SEV Distribution(x, mu, sigma), SEV Quantile(p, mu, sigma), Random SEV(mu, sigma)
- LEV Density(x, mu, sigma), LEV Distribution(x, mu, sigma), LEV Quantile(p, mu, sigma), Random LEV(mu, sigma)
- Logistic Density(x, mu, sigma), Logistic Distribution(x, mu, sigma), Logistic Quantile(p, mu, sigma), Random Logistic(mu, sigma)
- Loglogistic Density(x, mu, sigma), Loglogistic Distribution(x, mu, sigma), Loglogistic Quantile(p, mu, sigma), Random Loglogistic(mu, sigma)
- Frechet Density(x, mu, sigma), Frechet Distribution(x, mu, sigma), Frechet Quantile(p, mu, sigma), Random Frechet(mu, sigma)

New Col Rank Function

This function ranks each row's value. One is the lowest value. The number of columns is the highest value. Ties are broken arbitrarily. A new column is added to the data table with the ranks.

Col Rank(column)

Enhanced Date Formats

JSL supports new date formats and functions:

- yyyyQq returns the four-digit year, the letter “Q,” and the one-digit quarter.
- Quarter(date) returns a quarter value in the range 1 to 4.
- two date utility functions:
  Date Increment( dt, intervalName, <incr=1>, <alignment="start"> );
  Returns a new date/time value by adding the incr number of intervals. Alignment can be "start" to truncate lesser field values, "actual" to keep the lesser field values, or "fractional" to honor fractional incr values. For example, Date Increment( Today(), "Month", 100, "actual")"
**New Features in JMP 9**

**JMP Scripting Language**

Date Difference( dt1, dt2, intervalName, <alignment="start"> );
Returns the difference in intervals of two date/time values. 
*alignment* can be "start" to count interval starts, "actual" to count whole intervals, or "fractional" to count fractional intervals. For example:

Date Difference( Date DMY(1, 1, Year(Today())), Today(), "Day", "fractional" )

**Display Box Functions**

Send Unrecognized Messages Sent to a Display Box to the Log

The default behavior is to silently ignore unrecognized display box messages. A new preference requests error messages for invalid display box messages.

**Caution:** Turning on this preference might prevent some perfectly valid scripts from running, and might show errors in scripts that seemed valid but were not behaving as expected.

The syntax is:

Preferences( Report Invalid Display Box Messages( 0 | 1 ) );

**Messages for All Display Boxes**

- For display boxes, the message `<<Save Capture` has been extended to allow it to capture adjacent siblings as follows:

  db <<Save Capture( "path", <picture type>, <Add Sibling( <n> )> );
  
  where *n* is the number of siblings to capture. If *n* is not provided, *n* defaults to 1.

- The `<<Get Size` message returns a list of the horizontal and vertical size in pixels of the display box.

**Number Col Boxes and String Col Boxes**

The `<<Add Element` message appends an element to display boxes. It takes an argument that is a string or a number, a list of strings or numbers, or a matrix.

**Button Boxes**

- You can now create buttons that are menus using `Button Box`. For example,

  New Window( "Button Box Test", b = Button Box( "Select One", Print( b << get menu choice ) ) );
  
  b << Set Menu Items( {"a", "b", "c"} );

- You can add a separator between menu items by adding "-" to the member list. For example:

  {"a", "b", "-", "c", "d"}

- The new `<<Set Icon` message to `Button Box` causes the button to use the specified graphic as an icon. Most common graphic formats are supported, such as GIF, JPG, PNG, BMP, TIF. Currently, only JMP on Windows recognizes the `Set Icon` message. The message is ignored on Macintosh.

  The syntax is:
  
  Button Box( "title", "icon" );
Both the Title and Set Icon arguments are optional. You can create a button with only a text title, with only an icon, or with both a text title and an icon. In the last case, the icon is placed next to the text title.

Check Boxes

There are two new messages, Item Enabled and Enable Item, for Check Boxes. The syntax is:

```<< Item Enabled(item)
/* Returns 0 | 1 depending on whether the specified check box item is enabled (1) or disabled (0) */
<< Enable Item(item, state)
/* Enables/disables/flips a specific check box item:
1 = Enable
0 = Disable
<0 = (any negative value) Flip the current enabled or disabled state */```

Col List Box

A new On Change(expression) argument has been added to Col List Box that runs a script if the contents of the list box is changed. Any time a change is made to the contents of a Col List Box, the expression is evaluated. Drag and drop operations between two column list boxes that both have an On Change argument result in both expressions being evaluated in this order: Target, Source.

Combo Boxes

You can now enable and disable individual combo box items.

Icon Boxes

You can now display a custom icon (PNG, JPEG, and GIF) in an Icon Box. For example:

```
iconBox("$HOME/pictures/GeneralPrefIcon.png")
```

List Boxes

You can now insert one or more new items anywhere inside a list box using <<Append({item1, ..., n}), remove any item using <<Remove Item(n), or remove all items using << Remove All. The n argument is the indexed position within the list.

Outline Boxes

You can now create a custom red triangle menu for any outline box that your script creates. The menu script information is contained in a list of command and script pairs:

```
{"Command1", script1, "Command2", script2, ... }
```

Selecting a command from the menu results in the evaluation of its corresponding script expression.
New Features in JMP 9
JMP Scripting Language

The Outline Box syntax is now:

```
Outline Box( "Title", < "Command1", script1, ..., > display box, ...)
```

You can also get and set menu commands and scripts for an existing outline box as follows:

```
outlinebox << Set Menu Script( {"Command1", script1, "Command2", script2, ...} )
outlinebox << Get Menu Script
```

Panel Boxes

You can get and set the title for a panel box using new messages, <<Set Title and <<Get Title. The syntax is:

```
<< Set Title(\"string\")
Sets the panel box title to the value of the string expression.
<< Get Title
Returns the current title for the specified panel box.
```

Picture Boxes

The new Picture Box() function creates a display box that contains an image. For example:

```
p = Open("abc.png", png);
New Window("title", Picture Box(p));
```

Scroll Boxes

You can now create a scroll box, which is a display box with scroll bars that can hold a larger display box. To create a scroll box, use this syntax:

```
Scroll Box(<Size(h, v),> displayBox, ..., <<Set Background Color(color value|color name)
```

The optional size argument specifies the size of the scroll box. The Set Background Color message changes the background from transparent to the requested color. If more than one display box is specified, they are organized vertically. However, you can use an H List Box to contain all the display boxes to organize them horizontally.

String Col Boxes that are Editable

The following new function creates a String Col Box with editable values.

```
String Col Edit Box("title", list of editable values)
```

Tab Boxes

- The margins for tab boxes are now equal and are set by default to 12 pixels. You can customize the margins using <<Get Tab Margin() and <<Set Tab Margin(values). Set Tab Margin accepts the following values:
  - (n) sets all margins to the same number of pixels provided.
  - (n, m) sets the right and left margins to n pixels and sets the top and bottom margins to m pixels.
– \((n,m,x,y)\) sets the left margin to \(n\) pixels, the top margin to \(m\) pixels, the right margin to \(x\) pixels, and the bottom margin to \(y\) pixels.

• The message \(<\text{Show Tabs(1|0)}\) shows or hides the tabs for tab boxes. If you hide the tabs, you need to provide another way to select and show tabs (such as a list box that contains a list of references to the tabs).

Slider Boxes

New messages for a slider box let you get its current value, the maximum and minimum values possible, set the value, and set a script that links two sliders together. The syntax is:

\[
\begin{align*}
<< \text{Get N} \\
<< \text{Get} \mid << \text{Get(<ItemNumber=0>)} \\
<< \text{Set}(n, <\text{ItemNumber=0}> ) \\
<< \text{Get Min} \mid << \text{Get Min(<ItemNumber=0>)} \\
<< \text{Get Max} \mid << \text{Get Max(<ItemNumber=0>)} \\
<< \text{Set Script(<script>)}
\end{align*}
\]

V List Boxes

You can now set the justification of display boxes that are contained in a V List Box to the right or center. (The default justification is left). The width is determined by the display box that contains the V List Box, not by the window.

Updates to JSL Functions

New Fit Transform to Normal Function

This new function fits the Johnson Su, Johnson Sl, Johnson Sb, and GLog distributions to a vector of data. It uses the same internal functions for estimating parameters as the Distribution platform, but only requires a vector of data rather than a data table. A call to the function appears as follows:

\[
\text{Fit Transform To Normal( Distribution( "name" ), Y( dataVector ), <Freq(freq) > );}
\]

The function returns a list that contains parameter estimates, the covariance matrix, the log-likelihood, AICc, a convergence message, and transformed values.

New Fit Censored Function

This new function fits a specified distribution using censored data. The syntax is:

\[
\text{FitCensored( Distribution(name), YLow(vector) \mid Y(vector), <YHigh(vector)>, <Weight(vector)>, <X(matrix)>, <Z(matrix)>, <HoldParm(vector)> );}
\]

BY Groups in Statistical Functions

BY group arguments are supported for these functions: \texttt{ColMean, ColStdDev, ColNumber, ColNMissing, ColMinimum, and ColMaximum.}
New Features in JMP 9

Working with R

Any number of BY arguments can be specified, and you can use expressions for the BY arguments. BY arguments must be used in a column formula, or in the context of `ForEachRow`. The first argument can also be a general numeric expression.

Contour Function

Contour Function supports the following additional fill arguments and transparency:

- The ZColor argument can be either a scalar or a matrix, but must evaluate to numeric.
- `<<Fill` fills between adjacent contours using the current fill color.
- `<<Transparency(alpha|vector)` sets the transparency level of the fill. A vector of numbers between 0 and 1 are sequenced through and cycled for the z contours.

Gradient Function Supports Transparency

`<<Transparency(alpha)` sets the transparency level of the gradient.

Design Functions

A new feature has been added to the Design functions (Design, DesignNom, DesignOrd) so that the levels are returned as well as the design matrices. Adding the argument `<<Levels` after the first argument triggers the function to return a list of the design matrix and a list of levels. This feature is not supported for designs where levels in extra arguments have already been specified.

Derivative Supports Indirect Arguments

The Derivative function now supports indirect arguments. For example, `Name Expr, Expr, Eval`.

Read Binary Files with the Blob to Matrix Function

The Blob To Matrix function lets you create a matrix by converting each byte in the blob to numbers.

Simulator Experiments

You can now use the Simulation Experiment command in a script to specify the number of runs and factor space portion in a Profiler simulation. See the Object Scripting Index in the JMP Help for more information.

Working with R

R is a programming language and software environment for statistical computing and graphics. JMP now supports a set of JSL functions to access R. The JSL functions provide the following options:

- open and close a connection between JMP and R
- exchange data between JMP and R
- submit R code for execution
- display graphics produced by R
JMP and R each have their own sets of computational methods. R has some methods that JMP does not have. Using JSL functions, you can connect to R and use these R computational methods from within JMP. Textual output and error messages from R appear in the log window.

R must be installed on the same computer as JMP. JMP is not distributed with a copy of R. You can download R from the Comprehensive R Archive Network Web site:

http://cran.r-project.org

Because JMP is supported as both a 32-bit and a 64-bit Windows application, you must install the corresponding 32-bit or 64-bit version of R.

For details, see the Scripting Guide book.

SAS Integration

This section describes the new SAS integration features. For details, see the Using JMP book.

Product and Module Checks

Checks are now made to determine the presence of SAS products and modules with each SAS connection. Results of these checks are stored with the connection so that the results are returned with future queries without rechecking.

ODS Updates

An Outline layer for each <branch> is now made in the ODS XML file. This makes the reports more nested and structured, but more repetitive and indented. This structure is consistent with the hierarchical table of contents used in SAS output browsers.

P-value formats are now supported. Note that, unlike SAS ODS, once a p-value format is set for one cell in a column, that format is used for all cells in that column. This feature works only for SAS 9.2.

Export JMP Data Tables to a SAS Data Set

To export a JMP data table to a SAS server, select File > SAS > Export Data to SAS. You then have the following options:

- Save the whole table or select columns to save
- Export all rows or only rows that are not excluded
- Preserve SAS variable names and formats

Offset Variables

Offset variables are now created in SAS data sets for the Create SAS Job command.
Add-Ins

This section describes the new add-in feature. For details about creating add-ins, see the *Scripting Guide* book.

JSL script writers can create scripts (or add-ins) that extend JMP in many ways. For example, you might write a script to add a custom analytical tool, new JSL functions, or a user interface to communicate with a database. The JMP add-in architecture makes deploying and using these complicated scripts simpler.

You can send co-workers a suite of scripts and tell them how to run them. They can access the add-ins from a network drive. Another option is sending a single add-in file that any JMP user can install and then use just like any other part of JMP.

Projects

This section describes the new feature in projects. For details, see the *Using JMP* book.

Name Projects

When opening a project whose filename was changed outside of JMP, the root project is no longer renamed to match the filename.

Preferences

This section describes the new JMP preferences. For details, see the *Using JMP* book.

Font Preferences

You can now set all the proportional fonts (for all but the Mono font) to the same font. To see this new feature, select File > Preferences > Fonts, and then click the Font Family button.

Windows Preferences

You can select JMP 8-style Window List docking when windows are maximized. To see this new feature, select File > Preferences > Windows Specific and then select Dock the Window List in maximized windows.

A new preference on the Windows Specific page of the Preferences window controls what types of JMP windows show up on the task bar. There are three options:

- **All windows**: This is the default for Windows 7.
- **Main JMP window only**: This is the default for Windows XP and Windows Vista.
- **Main JMP window and data tables**
Note: The Windows Flip 3D in Windows Vista and 7 only shows previews of windows that appear in the task bar. Hold down the START key and press TAB several times to see each 3D window preview.

To set this preference, select File > Preferences > Windows Specific and then select an option from the Show on the Windows task bar list.

Open Log Window

There is a new preference setting that controls when the JMP Log window appears. To see this feature, go to File > Preferences > Windows Specific. The new preference is called Open the JMP Log window, and the settings appear as follows:

- only when I explicitly open it (default setting)
- whenever text is added
- when JMP starts

Save Data Tables and Reports

You can set your preference for saving data tables with reports by using a new preference on the Reports page. The following options are available:

- Embed saves a script that recreates the data table in the report.
- Separate links to the data table in the report. If the report is opened on another machine that does not have the data table, the data table cannot be opened.
- Prompt provides a window when you save a report that asks whether you want to embed or link to the data table.

To set this preference, select File > Preferences > Reports, select the Save table with report list, and then select the option.

Graph Builder Preferences

These new options let you control the formatting of the graph:

- Continuous Points Limit indicates the number of rows at which the Points element is no longer shown initially. The default value is 1500.
- Continuous Alternate indicates the element to display when there are more rows than the Points limit can handle. The default value is none, or you can select Contour (density contour).
- Continuous Smoother indicates whether the Smoother should appear for continuous variables.
- Categorical Point Limits indicates the number of rows at which the Points element is no longer shown initially. The default value is 1500.
- Categorical Alternate indicates the element to display when there are more rows than the Points limit can handle. The default value is Box Plot.
- Jitter indicates whether jittering is on by default. Small spaces are displayed between the data points so that you can see each point more clearly. (Only applies to elements that support jittering.)
To set these preferences, select File > Preferences > Platforms > Graph Builder, and then select the option.

Object Scripting Index

The Object Scripting Index (OSI) capabilities have been expanded. Each message provides the following information:

• Syntax
• Description
• Interactive examples
• Help

The OSI has also been reorganized. Previously, objects were only alphabetically organized, with no hierarchy. Now objects are nested inside their associated platform object. For example, the Test Mean object is now nested inside the Distribution platform object.

Macintosh

This section describes JMP updates on the Macintosh. For details, see the Using JMP book.

Save as EPS

You can now export a report window as an Encapsulated PostScript (EPS) file. Other options are text, Hypertext Markup Language (HTML), Rich Text Format (RTF), Portable Network Graphics (PNG), Tagged Image File Format (TIFF), and Scalable Vector Graphics (SVG).

Open Microsoft Excel Files from the Internet

You can now open Microsoft Excel files from a URL. Select File > Internet Open, and then enter the URL. From the Open As list, select Data, and then click OK.