The smoother is a cubic spline with a default lambda of 0.05 and standardized X values. You can change the value of lambda using the slider. You can obtain the same spline in the Bivariate platform, by performing the following steps:
1.
Select Analyze > Fit Y by X.
2.
Select continuous variables for Y, Response and X, Factor.
3.
6.
Check the Standardize X box.
7.
1.
Open the Students.jmp sample data table.
2.
Select Graph > Graph Builder.
3.
Click height and drag and drop it into the X zone.
Example of a height Plot
4.
Click weight and drag and drop it into the Y zone.
Example of a Scatterplot of weight Versus height
5.
Click sex and drag and drop it into the Group X zone.
Example of a Scatterplot for Each Level of the sex Variable
Side-by-side scatterplots (one for each level of sex) replace the initial scatterplot. You now see weight versus height for males and females.
Start from the graph in Example of a height Plot. Add the weight variable to the left of the height variable. Click weight and drag and drop it into the X axis, to the left of height.
Dragging and Dropping the weight Variable
To demonstrate combining two continuous variables, start from the graph in Example of a height Plot. Merge the weight variable with the height variable. Drag and drop weight to the center of the X zone, slightly above the axis. Before you drop the variable, a blue pentagon appears.
Merging height and weight
A graph element is added for weight that uses the same scale as height.
Example of weight Combined with height
1.
Open the Cars.jmp sample data table.
2.
Select Graph > Graph Builder.
3.
Click Size and drag it into the X zone.
4.
Click Wt and drag and drop it just above the X axis. Before you drop the variable, a blue pentagon appears.
Example of Merging Wt and Size
The levels of Size are now ordered according to the average Wt of all vehicles in that level, in ascending order. Notice that mini and lightweight are now ordered before heavy. The axis label is updated, signifying that an ordering variable is in use.
To verify that Size is actually ordered by Wt, click on Wt under Variables and drag and drop it into the Y zone. Example of Size Ordered by Wt shows that the average Wt increases from the left to right.
Example of Size Ordered by Wt
The default ordering statistic is the mean. To use another statistic, select it from the Order Statistic menu shown in The Right-Click Menu for the X Zone. The available statistics are N, Mean, Median, Min, Max, Range, Sum, and % of Total.
The Right-Click Menu for the X Zone
1.
Open the Popcorn.jmp sample data table.
2.
Select Graph > Graph Builder.
3.
Click popcorn and drag and drop it into Group X.
4.
Click yield and drag and drop it into the Y zone.
Example of yield by popcorn
5.
To place the batch variable above the popcorn variable, drag and drop batch into the left side of the Group X zone. Before you drop the variable, a left-justified blue polygon appears.
Example of Adding batch Above popcorn
6.
To place the batch variable below the popcorn variable, drag and drop batch into the right side of the Group X zone. Before you drop the variable, a right-justified blue polygon appears.
Example of Adding batch Below popcorn
Examples of Popcorn yield Grouped by popcorn and batch
You can replace an existing variable with an incoming variable. To demonstrate replacing variables, start from the graph in Example of yield by popcorn. Replace popcorn with batch in the Group X zone. Drag and drop batch into the center of the Group X zone. Before you drop the variable, a blue quadrilateral appears.
Example of Replacing popcorn with batch
This example uses the Crime.jmp sample data table, which contains data on crime rates for each US state.
1.
Open the Crime.jmp sample data table.
2.
Select Graph > Graph Builder.
3.
Drag and drop State into the Map Shape zone.
4.
Drag and drop murder into the Color zone.
Example of murder by state
The legend shows the colors that correspond to the murder rates. Since murder is a continuous variable, the colors are on a gradient.
1.
Open the Oil Use.jmp sample data table.
2.
Select Graph > Graph Builder.
3.
Drag and drop Country into the Y zone. You can resize the Graph Builder window and the graph if necessary.
Note: Notice that the default ordering for Country is ascending alphabetical (starting point is at the bottom). You can change the sorting order within a data table by using either the Value Ordering or Row Order Levels commands. For details, see the Using JMP book.
Example of Country Assigned to the Y Zone
4.
Drag and drop Production and Consumption to the X zone.
Example of Country versus Production and Consumption
Example of Side-by-Side Bars for Production and Consumption
Example of Stacked Bars for Production and Consumption
7.
Go back to the Oil Use.jmp sample data table.
11.
Click Consumption.
12.
Click +/-.
13.
14.
Select Graph > Graph Builder.
15.
Drag and drop Country into the Y zone. You can resize the Graph Builder window and the graph if necessary.
16.
Drag and drop Production and Negative Consumption to the X zone.
17.
Right-click on the graph and select Points > Change to > Bar.
18.
Right-click on the graph and select Bar > Bar Style > Stacked.
Example of Stacked Bars for Production and Negative Consumption
19.
Drag and drop Consumption into the graph, to the right of the Y zone.
Example of Dragging Consumption into the Y Axis
The Country variables are now ordered by Consumption.
Example of Country Organized by Consumption
1.
Open the Popcorn.jmp sample data table.
3.
Click on the disclosure icon next to Effect Tests to open the report.
The popcorn*batch interaction has a small p-value (0.0026). From this, you conclude that there is a significant interaction between popcorn and batch.
Example of Effect Tests Output
Notice that two new columns are added to the data table: Lower 95% Mean yield and Upper 95% Mean yield.
The Save Columns Menu
6.
Select Graph > Graph Builder.
8.
Drag and drop popcorn into the X zone.
9.
Drag and drop batch into the Group X zone.
10.
Drag and drop oil amt into the Group Y zone.
Example of Three Responses versus Three Factors
Format the graph to see interval bars for Lower 95% Mean yield and Upper 95% Mean yield, and to see points for Pred Formula yield.
The Interval Bar Style
The interval bar style currently spans from Lower 95% Mean yield to Pred Formula yield, but you want it to span up to Upper 95% Mean yield.
14.
Remove the bar element for Pred Formula yield by right-clicking on the graph and deselecting Bar > Y > Pred Formula yield.
Example of Correct Interval Span
Remove the point graph element for Lower 95% Mean yield and Upper 95% Mean yield.
15.
Right-click on the graph and select Points > Y, and deselect the Lower 95% Mean yield and Upper 95% Mean yield individually.
16.
Right-click on the graph, and select the XXL option under Graph > Marker Size. Do this for each quadrant of the graph.
Example of Predicted Values and Confidence Intervals
From Example of Predicted Values and Confidence Intervals, you can see the following relationships:
1.
Open the Diamonds Data.jmp sample data table.
2.
Select Graph > Graph Builder.
3.
Drag and drop Price into the Y zone.
4.
Drag and drop Carat Weight into the X zone.
Example of Points Showing Diamond Characteristics
5.
Right-click on the plot and select Points > Change to > Contour.
Example of Contour Plot of Diamond Characteristics
Save the .shp file with the appropriate name and in the correct directory, as follows:
1.
In JMP, open the Parishes.shp file from the following default location:
On Windows: C:\Program Files\SAS\JMP\<version number>\Samples\Import Data
On Mac: /Library/Application Support/JMP/<version number>/Samples/Import Data
JMP opens the file as Parishes. The .shp file contains the x and y coordinates.
2.
Save the Parishes file with the following name and extension: Parishes-XY.jmp. Save the file here:
On Windows: C:\Users\<user name>\AppData\Local\SAS\JMP\Maps
On Mac: /Users/<user name>/Library/Application Support/JMP/Maps
Note: If the Maps folder does not already exist, you need to create it.
3.
Close the Parishes-XY.jmp file.
1.
Open the Parishes.dbf file from the following default location:
On Windows: C:\Program Files\SAS\JMP\<version number>\Samples\Import Data
On Mac: /Library/Application Support/JMP/<version number>/Samples/Import Data
JMP opens the file as Parishes. The .dbf file contains identifying information.
2.
In the Parishes file, add a new column. Name it Shape ID. Drag and drop it to be the first column.
3.
In the first three rows of the Shape ID column, type 1, 2, and 3.
4.
Select all three cells, right-click, and select Fill > Continue sequence to end of table.
Shape ID Column in Parishes File
5.
Right-click on the PARISH column and select Column Info.
6.
Select Column Properties > Map Role.
7.
Select Shape Name Definition.
8.
9.
Save the Parishes file with the following name and extension: Parishes-Name.jmp. Save the file here:
On Windows: C:\Users\<user name>\AppData\Local\SAS\JMP\Maps
On Mac: /Users/<user name>/Library/Application Support/JMP/Maps
10.
Close the Parishes-Name.jmp file.
Once the map files have been set up, you can use them. The Katrina.jmp data table contains data on Hurricane Katrina’s impact by parish. You want to visually see how the population of the parishes changed after Hurricane Katrina. Proceed as follows:
11.
Open the Katrina.jmp sample data table.
12.
Select Graph > Graph Builder.
13.
Drag and drop Parish into the Map Shape zone.
The map appears automatically, since you defined the Parish column using the custom map files.
14.
Drag and drop Population into the Color zone.
15.
Drag and drop Date into the Group X zone.
Population of Parishes Before and After Katrina
16.
Select the Magnifier tool to zoom in on the Orleans parish.
Orleans Parish
The PopulationByMSA.jmp data table contains population data from the years 2000 and 2010 for the metropolitan statistical areas (MSAs) of the United States. Set up the Map Role column property in the data table, as follows:
1.
Open the PopulationByMSA.jmp sample data table.
2.
Right-click on the Metropolitan Statistical Area column and select Column Info.
3.
Select Column Properties > Map Role.
4.
Select Shape Name Use.
5.
Next to the Map name data table, enter the following path:
On Windows: C:\Program Files\SAS\JMP\11\Samples\Data\US-MSA-Name.jmp
On Mac: /Library/Application Support/JMP/11/Samples/Data/US-MSA-Name.jmp
6.
Next to the Shape definition column, type MSA_Name.
MSA_Name is the specific column within the US-MSA-Name.jmp data table that contains the unique names for each metropolitan statistical area. Notice that the MSA_Name column has the Shape Name Definition Map Role property assigned, as part of correctly defining the map files.
Note: Remember, the Shape ID column in the -Name data table maps to the Shape column in the -XY data table. This means that indicating where the -Name data table resides links it to the -XY data table, so that JMP has everything that it needs to create the map.
Map Role Column Property
7.
Once the Map Role column property has been set up, you can perform your analysis. You want to visually see how the population has changed in the metropolitan statistical areas of the United States between the years 2000 and 2010.
1.
Select Graph > Graph Builder.
2.
Drag and drop Metropolitan Statistical Area into the Map Shape zone.
Since you have defined the Map Role column property on this column, the map appears.
3.
Drag and drop Change in Population to the Color zone.
Change in Population for Metropolitan Statistical Areas
4.
Select the Magnifier tool to zoom in on the state of Florida.
5.
Select the Arrow tool and click on the red area.
Population Change of Palm Coast, Florida
6.
Select the Magnifier tool and hold down the ALT key while clicking on the map to zoom out.
7.
Select the Magnifier tool and zoom in on the state of Utah.
8.
Select the Arrow tool and click on the area that is slightly red.
Population Change of St. George, Utah