To begin, select DOE > Custom Design, or click the Custom Design button on the JMP Starter DOE page. Then, follow the steps below.
1.
To enter one response at a time, click Add Response, and then select a goal type. Possible goal types are Maximize, Match Target, Minimize, or None.
Entering Responses
Tip: To quickly enter multiple responses, click Number of Responses and enter the number of responses you want.
The Minimize goal supports an objective of having the smallest value, such as when the response is impurity or defects.
The Match Target goal supports the objective when the best value for a response is a specific target value, such as a dimension for a manufactured part. The default target value is assumed to be midway between the given lower and upper limits.
To compute and maximize overall desirability, JMP uses the value you enter as the importance weight (step 4 in Entering Responses) of each response. If there is only one response, then importance weight is unnecessary. With two responses you can give greater weight to one response by assigning it a higher importance value.
2.
Before you click Make Table, click the red triangle icon in the title bar and select Simulate Responses.
3.
Click Make Table to create the design table. The Y column contains values for simulated responses.
4.
For custom and augment designs, a window (In Custom and Augment Designs, Specify Values for Simulated Responses) appears along with the design data table. In this window, enter values you want to apply to the Y column in the data table and click Apply. The numbers you enter represent the coefficients in an equation. An example of such an equation, as shown in In Custom and Augment Designs, Specify Values for Simulated Responses, would be, y = 28 + 4X1 + 5X2 + random noise, where the random noise is distributed with mean zero and standard deviation one.
In Custom and Augment Designs, Specify Values for Simulated Responses
1.
To add one factor, click Add Factor and select a factor type. Possible factor types are Continuous, Discrete Numeric, Categorical, Blocking, Covariate, Mixture, Constant, or Uncontrolled. See Types of Factors.
2.
Click a factor and select Add Level to increase the number of levels.
4.
Click to indicate that changing a factor’s setting from run to run is Easy, Hard, or Very Hard. Changing to Hard or Very Hard will cause the resulting design to be a split plot or split-split plot design.
6.
To add multiple factors, type the number of factors in the Add N Factors box, click the Add Factor button, and select the factor type.
Entering Factors in a Custom Design
When adding factors, click the Add Factor button and choose the type of factor.
To indicate the difficulty level of changing a factor’s setting, click in Changes column of the Factors panel for a given factor and select Easy, Hard, or Very Hard from the menu that appears. Changing to Hard results in a split-plot design and Very Hard results in a split-split-plot design.
1.
After you add factors and click Continue, click the disclosure button ( on Windows and on the Macintosh) to open the Define Factor Constraints panel.
2.
Click the Add Constraint button. Note that this feature is disabled if you have already controlled the design region by entering disallowed combinations or chosen a sphere radius.
Add Constraint
4.
To add another constraint, click the Add Constraint button again and repeat the above steps.
To remove the last constraint, click the Remove Last Constraint button.
Initially, the Model panel lists only the main effects corresponding to the factors you entered, as shown in The Model Window. If a factor is Discrete Numeric, polynomial terms are added by default. The higher order terms are defined as estimable If Possible. If you are interested in ensuring estimation of these terms, change their Estimability to Necessary (see Estimability: Necessary and If Possible Terms).
The Model Window
Click the Interactions button and select 2nd, 3rd, 4th, or 5th. For example, if the factors are X1 and X2 and you click Interactions > 2nd, X1*X2 is added to the list of model terms.
Click the RSM button. The design now uses I-Optimality criterion rather than D-Optimality criterion.
3.
Click the Cross button.
Click the Powers button and select 2nd, 3rd, 4th, or 5th.
You can specify Estimability requirements for terms that you add. The custom design that you generate will ensure that terms marked Necessary are estimable. If a term is designed as If Possible, the custom design algorithm will attempt to make that term estimable, as permitted by the number of runs you select. The Bayesian D-Optimal design approach is used to obtain precise estimation of all of the Necessary terms while providing omnibus detectability (and some estimability) for the If Possible terms. For more detail, see Checking for Curvature Using One Extra Run and Bayesian D-Optimality.
Alias Terms
After you click the Make Design button at the bottom of the Custom Design panel, open the Alias Matrix panel in the Design Evaluation panel to see the alias matrix. See Aliasing.
Aliasing
The Design Generation panel (Options for Selecting the Number of Runs) shows the minimum number of runs needed to perform the experiment based on the effects you’ve added to the model. It also shows alternate (default) numbers of runs, or lets you choose your own number of runs. Balancing the cost of each run with the information gained by extra runs you add is a judgment call that you control.
Options for Selecting the Number of Runs
is the smallest number of terms that can create a design. When you use Minimum, the resulting design is saturated (no degrees of freedom for error). This is an extreme and risky choice, and is appropriate only when the cost of extra runs is prohibitive.
You can specify values for the Anticipated Coefficients in the Power Analysis report. When you click Apply Changes to Anticipated Coefficients, the Anticipated Response values and power calculations are updated. Alternatively, you can specify Anticipated Response values. When you click Apply Changes to Anticipated Responses, the Anticipated Coefficients and power calculations are updated.
These diagnostic tools are available in the Design Evaluation report, as shown in Custom Design Evaluation and Diagnostic Tools. JMP always provides the Prediction Variance Profile, but the Prediction Surface Plot only appears if there are two or more variables. The Alias Matrix only appears if Alias Terms have been specified.
Custom Design Evaluation and Diagnostic Tools
Design and Power Analysis Reports shows the Design and Power Analysis reports for a two-factor design that estimates both main effects and the interaction. Factor X1 is continuous and factor X2 is a four-level categorical factor with levels L1, L2, L3, and L4. The terms in the Parameter column in the Power Analysis report that correspond to the three indicator variables for the levels of X2 are denoted X2 1, X2 2, and X2 3. The X1*X2 interaction is also a four-level effect. Its corresponding indicator variables are denoted X1*X2 1, X1*X2 2, and X1*X2 3.
Design and Power Analysis Reports
You can also explore power by specifying Anticipated Response values in the Design report. When you click Apply Changes to Anticipated Responses, the Anticipated Coefficients and power calculations in the Power analysis report are updated.
The example in A Factor Design Layout For a Response Surface Design with 2 Variables shows the prediction variance profile for a response surface model (RSM) with 2 variables and 12 runs. To see a response surface design similar to this:
1.
Chose DOE > Custom Design.
3.
Click Continue.
5.
Click Make Design.
A Factor Design Layout For a Response Surface Design with 2 Variables
Another way to evaluate a design, or to compare designs, is to try and minimize the maximum variance. You can use the Maximize Desirability command on the Prediction Variance Profile title bar to identify the maximum prediction variance for a model. Consider the Prediction Variance profile for the two-factor RSM model shown in Find Maximum Prediction Variance. The plots identify the factor values where the maximum variance (or worst-case scenario) occur, which helps you evaluate the acceptability of the model.
Find Maximum Prediction Variance
The Fraction of Design Space plot displays the same information. The X axis is the proportion of prediction variance values, ranging from 0 to 100%, and the Y axis is the range of prediction variance values. In this simple example, the Fraction of Design plot verifies that 100% of the values are below 0.5 and 0% of the values are below approximately 0.3. You can use the crosshair tool to find the percentage of values for any value of the prediction variance. The example to the right in Variance Profile and Fraction of Design Space shows that 75% of the prediction variance values are below approximately 0.46.
Variance Profile and Fraction of Design Space
When there are two or more factors, the Prediction Variance Surface plots the surface of the prediction variance for any two variables. This feature uses the Graph > Surface Plot platform in JMP, and has all its functionality. Drag on the plot to rotate and change the perspective. Prediction Variance Surface Plot for Two-Factor RSM Model shows the Prediction Variance Surface plot for a two-factor RSM model. The factors are on the x and y axes, and the prediction variance is on the z axis. You can clearly see that there are high and low variance areas for both factors. Compare this plot to the Prediction Variance Profile shown in Find Maximum Prediction Variance.
Prediction Variance Surface Plot for Two-Factor RSM Model
X is the design matrix corresponding to model effects,
is the ith diagonal entry of ,
n is the number of runs.
Alias Matrix
Let X be the design matrix corresponding to the model effects, and Z be the matrix of interested effects (the effects you specify in the Alias Terms panel), then the alias matrix is
For Bayesian D-optimal designs, K2 is a diagonal matrix with values of 16 for If Possible interaction terms, 1 for other If Possible terms, and 0 for Necessary terms. You can control the weights used for If Possible terms by selecting Advanced Options > Prior Parameter Variance from the Custom Design report’s red triangle menu. There you can set prior variances for all model terms by specifying the diagonal elements of K.
The Color Map On Correlations panel (see Color Map of Correlations) shows the correlations between all model terms and alias terms you specify in the Alias Terms panel (see Specifying Alias Terms). The colors correspond to the absolute value of the correlations.
Color Map of Correlations
Open the Design Diagnostics outline node to display a table with relative D-, G-, and A-efficiencies, average variance of prediction, and length of time to create the design. The design efficiencies are computed as follows:
ND is the number of points in the design
p is the number of effects in the model including the intercept
σM is the maximum standard error for prediction over the design points.
Custom Design Showing Diagnostics
Output Options Panel
Run Order lets you designate the order you want the runs to appear in the data table when it is created. Choices are:
When the Design panel shows the layout you want, click Make Table. Parts of the table contain information you might need to continue working with the table in JMP. The upper-left of the design table can have one or more of the following scripts:
a Screening script runs the Analyze > Modeling > Screening platform when appropriate for the generated design.
a Model script runs the Analyze > Fit Model platform with the model appropriate for the design.
a DOE Dialog script that recreates the dialog used to generate the design table, and regenerates the design table.
Example Design Table
2.
Model is a script. Click the red triangle icon and select Run Script to open the Fit Model dialog, which is used to generate the analysis appropriate to the design.
3.
DOE Dialog is a script. Click the red triangle icon and select Run Script to recreate the DOE Custom Dialog and generate a new design table.