Select File > Save As and save as the new name.
On Windows. select Window > Set Title.
A Read-Only File
Note: To save a data table using compression, you must enable saving tables in the extended file format by selecting Preferences > Tables > Save table in extended file format. This preference is selected by default.
In addition, you can configure JMP to always use GZ compression when saving by selecting Preferences > General > Save Data Table Columns GZ Compressed.
Note: The Compress file when saved option only decreases the file size. This command does not affect the memory required to analyze the data. To reduce both the file size and memory required for analyzing, use Cols > Compress Selected Columns. See Compress Selected Columns in Set Column Properties.
Table Variables in the Table Panel
Table variables are used primarily to document tables. Many sample data tables installed with JMP contain a table variable named Notes. This variable provides details about the data (for example, the source of the data). The example in Table Variables in the Table Panel shows a data table that contains Notes as one of its table variables. JMP also automatically creates table variables when you create a design table using the Design of Experiments commands in JMP. The design table has a table variable named Design with the name of the design type as its value.
2.
Select New Table Variable.
4.
Click OK.
Note: Starting in JMP 10, the Script window is non-modal, meaning that you can access other windows and perform other operations while you are in the Script window.
Scripts Saved With the Data Table
1.
Open the Big Class.jmp sample data table.
2.
Select Analyze > Fit Y by X.
3.
Select weight and click Y, Response.
4.
Select height and click X, Factor.
5.
7.
From the red triangle menu, select Script > Save Script to Data Table.
Click the Red Triangle
Tip: If you want a particular script to run automatically every time the data table is opened, name the script OnOpen. Only one script saved in the data table can be set to run automatically. If you name the script Model (or model) in a Fit Model script, the launch window is automatically filled in based on the script when you select Analyze > Fit Model.
Creating a Script
2.
Select New Script.
If you are finished editing the script, click OK. The script appears in the Table panel and the window closes.
If you are not finished editing the script and want to save it, click Save. The script appears in the Table panel and the window remains open for further editing.
JMP can compare two open data tables and report the differences between data, scripts, table variables, column names, column properties, and column attributes. Character values that do not match exactly appear in the report. For numeric data, you can select a relative (or fuzzy) comparison. The numeric values are considered equal if they are within the relative error rate that you specify. The smaller the relative error, the more precise the comparison.
2.
In one of the tables, select Tables > Compare Data Tables.
4.
(Optional) Select Fuzzy Compare and enter the relative error to see numeric differences within the specified rate.
6.
Click Compare.
Basic Information
In Modified Data, Big Class1.jmp (left) and Big Class2.jmp (right) are compared.
The first entry in Modified Data indicates that one row (N) has changed (or been replaced) in the first row of Big Class2.jmp. When you select the entry in the Difference Summary report on the left, the entry is highlighted in yellow, and the row flashes in the data table.
For a graphical view of the comparison, place your cursor over a colored cell in the Difference Plot. Modified Data shows that the name KATIE in Big Class1.jmp was changed to KIM in Big Class2.jmp. The entire first row is highlighted in the Difference Plot, which tells you that all values in that row are different.
Modified Data
In Deleted Rows, the second entry indicates that two rows were deleted beginning at row four. The deleted rows are highlighted in Big Class1.jmp on the left. And the Difference Plot specifies the different values. The name in row four of Big Class1.jmp was JACLYN and TIM in Big Class2.jmp.
Deleted Rows
In Identify New Rows, the third entry tells you that one row was added before what was originally row eight. The name in row eight of Big Class1.jmp was ROBERT. PETER is the name in row six of Big Class2.jmp.
Identify New Rows
Click the Previous difference and Next difference buttons above the Difference Summary to navigate from row to row.
Tip: Save the Difference Summary report to a data table by selecting Save Difference Summary from the red triangle menu.
Select Compare Table Properties from the red triangle menu to see differences in table scripts and variables. For example, Modified Table Script shows that the Distribution script in Big Class2.jmp refers to the height column rather than the weight column.
Modified Table Script
Select Compare Column Attributes and Properties from the red triangle menu to see differences in column notes, cell colors, and the like. For example, Modified Column Attributes and Properties shows that column notes and value colors differ in Big Class2.jmp.
Modified Column Attributes and Properties