To follow along with this example, open Chemical Kinetics.jmp from the Nonlinear Examples folder found in the sample data installed with JMP.
Chemical Kinetics.jmp (Chemical Kinetics.jmp) contains a column (Model (x))whose values are formed by a formula with a poor guess of the parameter values.
Chemical Kinetics.jmp
1.
Select Analyze > Modeling > Nonlinear.
2.
Select Velocity (y) and click Y, Response on the nonlinear launch dialog.
3.
Select Model (x) and click X, Predictor Formula (see Initial Nonlinear Analysis Launch Dialog). Note that the formula given by Model (x) shows in the launch dialog.
Initial Nonlinear Analysis Launch Dialog
4.
Click OK on the launch dialog to see the Nonlinear Fit Control Panel.
5.
Click Go in the Control Panel to obtain the estimates shown in Nonlinear Fit Results.
Nonlinear Fit Results
6.
Click the Confidence Limits button to add confidence intervals to the Solution report.
The ranges for LowerCL and UpperCL are the intervals for VMax and k. They are asymptotically normal. Use these limits to create a nonlinear design in JMP.
7.
Click Save Estimates to add the new fitted parameter values in the Model (x) column in the Chemical Kinetics.jmp data table.
Click the “+” sign next to Model (x) in the Columns panel to view the formula. Select Parameters from the menu in the upper left of the formula editor to view the new parameter estimates.
New Parameter Estimates
1.
With the Chemical Kinetics.jmp data table open, select DOE > Nonlinear Design.
2.
Complete the launch dialog the same way as the Nonlinear Analysis launch dialog shown previously. That is, Select Velocity (y) and click Y, Response. Select Model (x) and click X, Predictor Formula. Initial Nonlinear Design Launch Dialog shows the completed dialog.
Initial Nonlinear Design Launch Dialog
3.
Click OK to see the completed Design panels for factors and parameters, as shown in Nonlinear Design Panels for Factors and Parameters.
Nonlinear Design Panels for Factors and Parameters
Note that in Chemical Kinetics.jmp (Chemical Kinetics.jmp), the range of data for Concentration goes from 0.417 to 6.25. Therefore, these values initially appear as the high and low values in the Factors control panel.
4.
Change the factor range for Concentration to a broader interval—from 0.1 to 7 (Change Values for Factor and Parameters).
Note that the a priori distribution of the parameters VMax and k is Normal, which is correct for this example. Change the current level of uncertainty in the two parameters using the analysis results.
5.
Look back at the analysis report in Nonlinear Fit Results after you added the Confidence Limits. Locate the upper and lower confidence limits for VMax and k in the Solution table. Change the values for VMax and k to correspond to those limits, as shown in Change Values for Factor and Parameters.
Change Values for Factor and Parameters
6.
Select Number of Starts from the menu on the title bar and enter 100 in the text box.
7.
Select Advanced Options > Number of Monte Carlo Samples and enter 2 in the text box.
8.
Click Make Design to preview the design (Selecting the Number of Runs). Your results might differ from those shown for the additional runs.
Selecting the Number of Runs
9.
Click Make Table.
This creates a new JMP design table (Making a Table with the Nonlinear Designer) whose rows are the runs defined by the nonlinear design.
Note: This example creates a new table to avoid altering the sample data table Chemical Kinetics.jmp. In most cases, however, you can augment the original table using the Augment Table option in the Nonlinear Designer instead of making a new table. This option adds the new runs shown in the Design to the existing data table.
Making a Table with the Nonlinear Designer
To follow along with this example, open Reaction Kinetics Start.jmp, found in the Design Experiment folder in the sample data installed with JMP. Notice that the table is a template. That is, the table has columns with properties and formulas, but there are no observations in the table. The design has not yet been created and data have not been collected.
This table is used to supply the formula in the yield model column to the Nonlinear DOE platform. The formula is used to create a nonlinear design for fitting the model’s nonlinear parameters.
Yield Model Formula
1.
With the Reaction Kinetics Start.jmp data table open, select DOE > Nonlinear Design to see the initial launch dialog.
2.
Select observed yield and click Y, Response.
3.
Select yield model (the column with the formula) and click X, Predictor Formula.
Nonlinear Design launch Dialog
4.
Click OK to see the nonlinear design Factors and Parameters panels in Change Factor Values, Parameter Distributions, and Number of Runs.
6.
Change the values of the parameter t1 to 25 and 50, and t3 to 30 and 35.
7.
Click on the Distribution of each parameter and select Uniform from the menu to change the distribution from the default Normal (see Change Factor Values, Parameter Distributions, and Number of Runs).
Change Factor Values, Parameter Distributions, and Number of Runs
9.
Click Make Design, then Make Table. Your results should look similar to those in Design Table.
Design Table
10.
To analyze data that contains values for the response, observed yield, open Reaction Kinetics.jmp from the Design Experiment folder in the sample data installed with JMP (Reaction Kinetics.jmp).
Reaction Kinetics.jmp
11.
Select Graph > Overlay Plot.
13.
Select Reaction Temperature and click Y
14.
Select Reaction Time and click X as shown in the Overlay Plot launch dialog in Create an Overlay Plot.
15.
Click OK to see the overlay plot in Create an Overlay Plot.
Create an Overlay Plot
16.
Select Analyze > Modeling > Nonlinear.
18.
Select observed yield and click Y, Response.
19.
Select yield model and click the X, Predictor Formula, then click OK.
20.
Click Go on the Nonlinear control panel.
21.
Now, choose Profilers > Profiler from the red triangle menu on the Nonlinear Fit title bar.
22.
To maximize the yield, choose Maximize Desirability from the red triangle menu on the Prediction Profiler title bar.
Time and Temperature Settings for Maximum Yield