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Boston Housing 
Model Validation, Comparison and Selection in JMP® Pro 

Key ideas: Model validation, stepwise regression, regression trees, neural networks, validation 
statistics and model comparison. 

 

Background 

The objective of this study is to develop a model to predict the median value of homes in the Boston area. 
The data were originally collected and assembled in the mid-1970s (Harrison and Rubinfield, 1978), so 
this example is a bit dated. However, it is typical of a socioeconomic data set that is used to inform 
economic or public policy decisions, and the data set is well-known throughout the data mining 
community.  

The Task     

Our goal is to use the available data build a model that makes accurate predictions about home values in 
the Boston area. To ensure that the model predicts well for data not used to build the model, we use 
model validation. We will build different models (e.g., multiple regression, regression tree and neural 
network) in JMP Pro, compare the performance of these models, and select the best-performing model.  

The Data Boston Housing BBM.jmp 

Each row in the data table is taken from a census tract (or town) in the Boston area. The response of 
interest is the continuous variable mvalue, which is the median home value (in $1,000) for towns in the 
Boston area in the 1970s.  

Potential predictor variables in the data set are: 

crim Per capita crime rate for the census tract 

zn Proportion of a town’s residential area zoned for lots larger than 25,000 square feet 

indus Proportion of non-retail business acres per town 

chas This is a 0/1 indicator variable. If the town bounds on the Charles River, the value is 0; 

otherwise the value is 1 

Nox Average annual nitrogen oxide concentrations in parts per hundred million 

Rooms Average number of rooms in owner-occupied units 

Age Proportion of owner units built prior to 1940 

Distance Weighted distances to five employment centers in the Boston region 

Radial Index of accessibility to radial highways 

Tax Full value property tax rate (per $10,000)  

Pt Pupil-to-teacher ratio by town school district 

Lstat Proportion of population that is “lower status,” that is, proportion of adults without 

some high school education or that are classified as laborers 
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Analysis  

The focus of this case study is model validation, comparison and selection. As such we omit perhaps the 
most important and time-consuming steps in the analytics process, data exploration and preparation1. A 
variety of graphical and statistical tools are used to identify potential gaps, explore potential data quality 
issues, and develop an in-depth understanding of the data and available variables.   

We recommend the following approach to examining and understanding your data prior to modeling: 

 Explore data one variable at a time, using Cols > Cols Viewer, Analyze > Distribution, and 
Graph > Graph Builder. 

 Explore data two variables at a time, using Graph Builder, Analyze > Tabulate and Fit Y by X.  

 Explore data three or more variables at a time using the same tools, plus Rows > Data Filter, the 
Local Data Filter (from the toolbar), Graph > Scatterplot Matrix, Cols > Column Switcher, and 
other graphical tools.  

 
This initial data exploration provides insights into the available data, along with the steps needed to 
prepare the data for modeling. For example, you may need to address missing values, transform or 
derive new variables, or collect new data.  
 
Note that we will also omit many of the background details for the different modeling approaches used. 
For additional information on multiple regression, regression trees and neural networks, refer to Building 
Better Models With JMP Pro or JMP Help (under the Help menu). 
 
 

What Is Model Validation? 

When we build a predictive model, there is a risk that we will model noise in the particular data set, rather 
than modeling the true relationship between predictors and the response. The resulting model may be 
overly complicated (overfit), or may not perform well when applied to new data. Overfitting can occur 
when a model is so complex that it attributes random noise in the response data to factors being used to 
make predictions. Validation helps us guard against this.   

Here’s the basic idea. When we use model validation, we withhold a subset of our data from the modeling 
process. The portion of data used to build the model is often referred to as the training set, and the data 
withheld is often referred to as the validation set (or the holdout set). We build the model using training 
data, and then apply the model to validation data to determine how well it performs. A third portion of the 
data, a test set, is also recommended. This subset is withheld from the modeling process, and is used to 
evaluate the final model. 

There are different methods for validation available in the JMP modeling platforms: Random holdback, k-
fold cross-validation, excluded rows, and using a validation column (the latter method is only available in 
JMP Pro). In this case study, we focus on using a validation column. With this approach, we divide the 
data set into a training, validation and (optionally) a test subset. In JMP Pro, this is done by creating an 
indicator column in the data table to specify the validation role for each row in the data table. 

                                                      

1 For additional information on data exploration and preparing data for modeling, see Building Better Models, Chapter 3 – Working 
with Data. 
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A validation column, Validation1, has been added to the Boston Housing data table (see the last column 
in the data table shown in Exhibit 1). The first and fourth rows in the data table will be assigned to the 
validation set; the second, third and fifth rows will be assigned to the training set; the sixth row will be 
assigned to the test set, and so on.  

Exhibit 1    A partial view of the data table, with a validation column (Validation1) 

 

Rows in the training set will be used to build the model, rows in the validation set will be used to 
determine how complex the model needs to be, and rows in the test set will be used to assess how well 
the model will perform when applied to new data. 

Note that the specific way in which the validation set is used may differ between modeling platforms2. For 
example: 

 In forward stepwise regression, validation is used to decide when to stop adding additional terms 
into the model,  

 In decision trees, validation is used to decide when to stop splitting the data, and 

 In neural networks, validation is used to determine the best value for the penalty parameter used 
to prevent overfitting of the neural network. 

Creating Training, Validation and Test Subsets  

One way to create a validation column in JMP Pro is to use the Make Validation Column utility (under 
Cols > Model Utilities). In the Make Validation Column dialog in Exhibit 2, we request a 50 percent 
training, 25 percent validation, and 25 percent test split. In this example, we use the Purely Random 
method to create the holdback sets. The name of the validation column that we create is Validation2. 

Note: The Stratified Random option will perform a random selection with balance across variables that 
are currently selected in the data table. For instance, if we want each validation subset to contain the 
same relative proportions of chas = 0 and chas = 1, we could use chas as the stratification variable (that 
is, we would select the variable chas prior to launching the Make Validation Column utility). 

                                                      

2 For more details on how validation is applied in the specific JMP Pro modeling platforms, see Building Better Models, Chapter 8 – 

Using Cross Validation, or refer to Fitting Linear Models or Specialized Models under Help > Books.  
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Exhibit 2    Using the Make Validation Column Utility  

 

A new column, Validation2, is added to the data table (this column was previously created; we will use 
this column throughout this case study).  

Note that the actual values stored are the numbers 0, 1 and 2, but the utility creates a Value Labels 
column property to display descriptive labels Training, Validation and Test in place of numeric values in 
the data table and output reports (to view the column properties, right click on the column name in the 
data table and select Column Info). 

Exhibit 3   The Value Labels column property for the validation column 
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Using Cross-Validation to Build a Linear Regression Model 

We now use the validation column (Validation2) in developing a model to predict the median home value 
for Boston Housing data. Since we have several potential predictors, the first modeling method that we 
use is stepwise regression3.  

We specify the model as shown in Exhibit 4, using the Fit Model dialog (from the Analyze menu). We 
enter mvalue as the Y variable. In this case, we specify a more complicated model than we will likely 
need. We enter all predictor variables as main (linear) effects, and then enter all of their two-factor 
interactions. To do this, we select predictors from the Select Columns list and Factorial to Degree from 
the Macros menu. The default “degree” that the model specification macro uses is “2”.  This adds the 12 
factors (or main effects) plus 66 two-way (second-order) interaction terms to the list of model effects.  

Finally, we specify the Validation2 column for the Validation role, and select Stepwise from the list of 
modeling “Personalities.”  

Exhibit 4   Specifying a Stepwise Model with Interactions and Validation 

 

                                                      

3 For more information on stepwise regression, see Building Better Models With JMP Pro, Chapter 4 – Multiple Linear Regression. 
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Choosing the Regression Model Terms With Stepwise Regression 

We click Run, which opens the stepwise regression dialog (Exhibit 5).  

Since we are using validation, the stopping rule that determines which model is selected is Max 
Validation RSquare. When we click Go, the forward stepwise regression modeling process begins. 
Terms are added to the model one at a time. Each term that is added to the model term (from the 
remaining terms) is the one that has the lowest p-value.  

This process continues until there is no improvement in the RSquare Validation value. JMP will then 
continue to add terms (up to ten) in search of a higher value.  The final model is the one resulting in the 
highest RSquare Validation 

Exhibit 5    Boston Housing Stepwise Initial Dialog 

 

Exhibit 6 shows the history of terms added to the model. For each step we see a number of statistics, 
including the RSquare Validation.  

In Step 18, JMP reports that the best RSquare Validation, across all steps, is 0.8002. This corresponds to 
the RSquare Validation at Step 7. So, the model selected is the model produced at Step 7. 
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Exhibit 6    Boston Housing Stepwise Regression Step History 

 

To get a better feel for how stepwise builds the model, we save the step history to a data table and use 
the Graph Builder to create a graph of step versus RSquare Validation (see Exhibit 7).  

The model that was found after seven steps has a Validation RSquare of 0.8002. After 10 additional 
forward steps, the Validation RSquare does not get any larger. As such, the model that was found at 
Step 7 is chosen as the best model. 

Exhibit 7    Graph of Stepwise Step History 

 

(To save a table of JMP output to a data table, right-click on the table and select Save to Data Table. To 
create the graph, drag Step to the X zone, drag RSquare Validation to the Y zone, and then click on the 
line icon above the graph.) 
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To create the chosen model, we select Make Model in the Stepwise Fit window. This opens the Fit 
Model dialog with the chosen model specified. We then click Run to fit the model.  

The fitted model results for our example are shown in Exhibit 8. As expected, the RSquare for the 
validation set is 0.8002 (see the bottom panel in Exhibit 8). 

Exhibit 8    Fitted Model from Stepwise Regression 

 

Saving the Prediction Formula 

We save the model results (use the red triangle and then select Save Columns > Prediction Formula). 

This creates a new column—Pred Formula mvalue. This saved column contains the formula that 

calculates the predicted value for each row in the data table, and we can use this formula to predict new 
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values. As we will see, we can also use a saved prediction formula to compare the performance of this 
model to others that we have created.  

Using Validation to Build a Decision Tree Model 

Even though the process described above helped us to choose the “best” linear regression model, the 
final chosen model is just one of many options available for building prediction models. Decision trees can 
sometimes have better predictive properties than regression models, so we fit a simple decision tree 
model to predict mvalue. We use validation to guide the decision tree-building process.  

In this situation, splits in the decision tree are determined by the LogWorth statistic4. Here, we again use 
Validation2 to specify the training, validation and test subsets. After each split of the decision tree, the 
validation RSquare is calculated. When the validation RSquare stops improving, the decision tree will 
continue to split in order to determine whether any improvement can be attained. It automatically stops 
splitting if there is no improvement after 10 additional splits.  

Exhibit 9 shows the Partition platform launch dialog. We specify mvalue as the response and all of the 
potential predictors as factors. Validation2 is chosen as the validation role column. (Partition is an option 
under Analyze > Modeling). We use the default settings and click OK to launch the analysis. 

Exhibit 9    Boston Housing Partition Dialog with Validation2 

 

The initial model fit report is shown in Exhibit 10. Since we are using model validation, JMP reports 
Training, Validation and Test RSquare, along with other statistics.  

                                                      

4 See Building Better Models With JMP Pro, Chapter 6 - Decision Trees, or the JMP Help for details. 
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We click Go to begin the automatic decision tree-building process.   

Exhibit 10    Boston Housing Initial Partition Output With Cross-Validation 

 

In Exhibit 11, we see statistics for the final model and the Split History graph. The bottom line in the Split 
History graph corresponds to the validation RSquare, the middle is the test RSquare, and the top line is 
the training RSquare. The largest tree that was built had 29 splits. However, JMP stops adding branches 
to the tree after 10 splits if there is no further improvement in validation RSquare.  

The chosen decision tree model—or the tree with the best validation RSquare (0.670)—has only 19 
splits. Recall that validation RSquare for the stepwise model was 0.8002. Based on this statistic alone, 
the stepwise model outperforms the regression tree. 

Exhibit 11    Fitted Decision Tree Model With Cross-Validation 
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We use the chosen decision tree model and save the prediction formula to the data table (use the top red 
triangle, Save Columns > Save Prediction Formula). This creates a new column, mvalue Predictor.  

Fitting a Neural Network Model Using Validation 

A third model is developed using the Neural platform (Neural is an option under Analyze > Modeling). 

Neural networks are highly flexible, and can be used to model either categorical or continuous responses. 
Due to their flexibility, neural network models can often outperform other modeling methods; however, 
they are also prone to overfitting. As such, some form of validation is required when building neural 
network models in JMP5. 

We fit a neural network, again using the Validation2 as the validation column (Exhibit 12).  

Exhibit 12    Boston Housing Neural Model Launch Dialog With Cross-Validation  

 

The default model has one hidden layer and three “sigmoid” TanH nodes (see Exhibit 13). We use the 
default settings, and click Go to fit the neural model. 

                                                      

5 For more information on fitting neural networks, see Building Better Models With JMP Pro, Chapter 7 – Neural Networks, or refer to 
the JMP Help. 
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Exhibit 13    Boston Housing Neural Model Launch 

 

The results for the fitted model are shown in Exhibit 14.6 The RSquare for the validation set is 0.8151; the 
highest validation RSquare of the three models we’ve created. 

To view the model, we select Diagram from the red triangle for the model. The diagram shows the 
structure of a neural network model. Our model has an input layer with input variables (predictors), a 
hidden layer with three nodes, and an output layer. In each node in the hidden layer, a linear combination 
of input variables is transformed using the TanH function (which is similar to the logistic function). The 
output layer, which is used to predict the response (mvalue), is a linear combination of the outputs from 
the hidden layer.   

                                                      

6 To obtain the same result for the neural model in this example, set the random seed to 1000 prior to launching the neural platform 

using the Random Seed Reset add-in, which can be installed from /community.jmp.com/docs/DOC-6601.  Note that Windows and 
Mac may produce different results with the same random seed. 

 

/community.jmp.com/docs/DOC-6601
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Exhibit 14    Boston Housing Neural Fitted Model with Cross-Validation 

 

As with the two previous models (i.e., stepwise regression and regression tree), we save the prediction 
formula to the data table (from the fitted model’s red triangle, choose Save Columns > Save Profile 
Formulas). The new column is named Predicted mvalue. 

(Note: To view the hidden layer and output layer formulas as described above, select Save Formulas 
instead of Save Profiler Formulas. Formulas for the hidden layers are saved as H1_1, H1_2, and H1_3. 
The formula for the output layer, which is a linear combination of the hidden layers, is saved as Predicted 
mvalue. Right-click on the column names in the data table and select Formula to view the formulas.)  

Model Comparison 

We have fit three different models using the same validation column, and have saved prediction formulas 
for the three models to the data table. In JMP Pro, we use the Model Comparison platform to compare 
the performance of these models (select Analyze > Modeling > Model Comparison).  
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We specify the columns with prediction formulas for each model as Y, Predictors and select Validation2 
as the Group variable. Note that an alternative is to leave the Y, Predictors field blank and use 
Validation2 as the By variable. With this setup, JMP will find columns with saved prediction formulas for 
you. 

Exhibit 15    Model Comparison Dialog 

 

In the resulting Model Comparison report (Exhibit 16), we use statistics from the test set for model 
comparison. Recall that the test set was not used in building our models. Since this set was completely 
withheld from all modeling efforts, it provides an “honest” assessment of model performance. 

In addition to RSquare, the following statistics are provided: 

 RASE (Root Average Squared Error) – this is similar to RMSE (Root Mean Square Error), but is 
not based on the degrees of freedom for the model. This makes it better than RMSE when 
comparing different types of models. For this measure, lower is better. 

 AAE (Average Absolute Error) – a measure of the average prediction error. Lower is better. 

The neural network model has the highest RSquare value (0.8295). It also has the lowest RASE. 
However, the AAE is slightly higher than the AAE for the Least Squares model.  

Exhibit 16    Model Comparison Report 
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If we have to choose only one of these models from the perspective of performance and prediction error, 
we would select the neural network model.  

Additional options for comparing models, such as the Profiler, are available from the top red triangle in 
the model comparison window.  

 

Summary  

Statistical Insights     

The use of validation (or cross-validation) is central to our ability to develop predictive models that 
neither overfit nor underfit our data. As such, it is one of the most important concepts in predictive 
modeling. In many situations, we use two holdout subsets: training and validation. If we also withhold 
a test subset, then we have the ability to assess model performance on an unbiased sample that has 
not been used in the model building or model selection processes. This allows for good model 
evaluation, and makes it easy to compare and choose among competing models. 

Implications      

With the exception of the stepwise regression model—which included two-way interactions—we 
created relatively simple models using the default settings. To create a regression tree, we used the 
decision tree option, however the other tree methods (i.e., bootstrap forest and boosted tree) may 
lead to better performing models. We also created a simple neural network model using the default 
single hidden layer. Adding additional nodes with different activation functions, using two layers, and 
using options such as boosting may lead to models with improved predictive performance (at the cost 
of complexity). 

In this case study we built predictive models for a continuous response. For classification models— 
which have categorical responses—the approach to model validation, comparison and selection is 
analogous. However, other statistics, such as the misclassification rate, are reported instead of RASE 
and AAE. Other options, such as the ROC Curve, Lift Curve, and Confusion Matrix are available 
from the top red triangle in the modeling platforms and in the Model Comparison platform. 

JMP Features and Hints      

We used the Make Validation Column utility to create a validation column, building three predictive 
models: a stepwise regression model using Fit Model, a regression tree (using Partition), and a 
neural network (using Neural). We saved prediction formulas for these models to the data table, and 
then used the Model Comparison platform to compare the performance of the three models on the 
test set. 

 

Exercises    

Exercise 1: Open the example data set Boston Housing BBM.jmp.  

a. Use the Make Validation Column utility to create random training, validation and test 
subsets. Use 50 percent of the data for training, 25 percent for validation and 25 percent for 
the test. 
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b. Repeat Part A, but first select the column chas in the data table, and then create a stratified 
random sample.   

c. When creating a validation column, it is important that the distributions of the variables across 
training, validation and test sets are similar.   

i. Explain why this is important. 

ii. For the validation column produced in part b, use built-in tools such as Distribution, 
Tabulate, and Graph Builder to explore the makeup of training, validation and test 
sets with respect to the response variable and predictor variables. 

Note: If doing this as part of a class exercise, to produce the same validation set as 
others, set the random seed to 1,000 before creating the validation column using the add-
in described in Footnote 6.  

Exercise 2: Use Boston Housing BBM.jmp for this exercise.   

a. Create final prediction models with the validation column that you created in Exercise 1b, 
using the following modeling methods: 

1. Forward stepwise regression 
2. Decision tree 
3. Neural network 

b. Compare the final models using the Model Comparison platform.  

1. Using the default statistics provided, is there one model that stands out as being better?  
2. What criteria did you use to determine the best-performing model? 
3. Describe the criteria that you used in Part 2. 
4. Explore the options available under the red triangle. Explain how the Profiler and first two 

plots can be useful in comparing and selecting the best performing model. 
5. Explain the value of using a test set. Why is it important to use a holdout sample for 

model evaluation and selection? 

Exercise 3: Use the Credit Card Marketing BBM.jmp data for this exercise. This data set is described 
in the classification tree case study, and in Example 1 in Chapter 6 of Building Better Models with 
JMP Pro. The response is Offer Accepted. 

a. Create a distribution of Offer Accepted. The target category is Yes. What percent of offers 
were accepted? 

b. Use the Make Validation Column modeling utility to create training, validation and test sets, 
stratified on Offer Accepted. Again, if doing this as part of a class exercise, set the random 
seed to 1,000 prior to creating the validation column.  

c. Explore this validation column as you did in Exercise 1c. What percent of each set is Offer 
Accepted = Yes and Offer Accepted = No? Are there any issues with using this validation 
column? 

d. Create a decision tree and neural model to predict Offer Accepted using this validation 
column. Then compare these models using the Model Comparison platform.   

Which is your best-performing model? What is the misclassification rate? 
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