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Defect Sampling:
Sampling Distributions and Sample Error

Background

Defect sampling is used in industrial settings to determine the types and amounts of defects in
manufactured items. Items at various stages of production are removed from the process and inspected
for defects. Sustained testing allows operations managers to discover whether some part of the
manufacturing process is failing to meet performance criteria and product standards. To minimize
manufacturing defects, early detection and problem resolution are critical.

ACME Manufacturing produces electronic components used in the assembly of industrial robotic
equipment. The components are technologically sophisticated, and quality must be rigorously monitored
to ensure that specifications are met. Of course, inspection can be a time consuming and costly activity.
ACME production managers must determine how much sampling and testing is needed to minimize costs
and maximize yields.

In the current sampling plan, one component from the production line is randomly selected every 15
minutes. Each component is inspected and tested for major and minor defects. Major defects, which
affect component performance, must be addressed immediately. Fortunately, major defects are rare and
are generally contained and corrected early in the process. Minor defects, such as nicks and scratches,
are those that affect the appearance of a component but not its functionality. Monitoring minor defects to
ensure the rate doesn’t increase is of particular concern to ACME management.

The Task
ACME currently inspects one part every 15 minutes during an eight hour shift. Production managers
have complained this sampling rate is too high, which has driven up costs and decreased output. They

suggest implementing sampling plans involving fewer parts.

In this case, we explore the effectiveness of the current defect sampling plan, and several alternative
plans, in detecting changes in the occurrence of minor defects.

The Data Defects.jmp

The data set contains ten days of data on minor defects. Each day, one item is tested every fifteen
minutes during an eight-hour shift. The variables in the data set are:

Day Day of the test: 1 — 10
Sample Time of the day that sample was taken in military time (e.g., 13:00 is 1pm)
Defects Number of minor defects detected on the sampled item



Analysis

A visual examination of the data set is a good place to start. Exhibit 1 organizes the 15-minute data by

day. The first thing we note is that the production process is far from error-free. That's not too surprising,

since the errors recorded here are minor ones.

Exhibit 1 Defects Split by Day

Sample 1 2 3 4 5 6 7 8 9
1 08:15 12 17 7 11 7 13 10 10
2 08:30 8 12 1" 11 8 9 8 11
30845 o 7 o 8 7 14 15 11
4 09:00 1" 11 16 12 1" 10 3 11
5 09:15 9 7 8 12 7 7 8 14
6 09:30 10 6 12 11 17 7 12 12
7.09:45 12 10 14 12 7 11 5 15
8 10:00 9 11 5 13 8 12 5 10
9 10:15 12 12 13 10 1" 9 14 6
10 10:30 4 7 14 15 3 11 12 13
11 10:45 1" 11 6 12 14 13 16 14
12 11:00 8 6 4 6 7 11 9 10
13 11:15 12 12 14 7 10 12 10 11
14 11:30 12 13 8 5 3 6 10 10
15 11:45 9 1 11 3 11 14 12 9
16 12:00 8 12 10 13 14 12 4 9
17 1215 9 13 6 9 10 10 13 12
18 12:30 10 8 10 11 13 9 9 12
19 12:45 15 14 5 9 16 9 1" 3
20 13:00 1" 12 9 15 12 5 12 10
2113115 14 8 12 12 10 11 12 9
22 13:30 1" 12 12 6 1" 17 7 9
23 13:45 o 12 10 8 1" 13 8 9
24 14:00 7 10 13 11 13 10 15 5
25 1415 15 10 4 14 9 7 1" 11
26 14:30 11 15 6 7 9 5 14 8
27 14:45 13 6 13 7 9 12 13 14
28 15:00 9 12 9 16 13 6 7 17
29 1515 15 13 17 3 12 12 10 7
30 15:30 8 7 15 13 14 4 16 14
311545 7 7 14 16 14 10 10 12
32 16:00 1" 11 12 9 8 14 7 6

(Tables > Split; Use Defects as the Split Column and Day as Split By. Under Remaining Columns select Keep All)
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From Exhibit 2, we see that the average number of defects per item is 10.325 and the standard deviation
is 3.17.

Exhibit 2 Distribution of Defects

4~ Distributions (Return to the original
table. Analyze >
4~ Defects Distribution; Use Defects
— 4 Quantiles 4/~ Summary Statistics as 'Y, Columns.)
- 0 | | 1000% maximum 18 Mean 10.325
99.5% 17.395 Std Dev 31722741
97.5% 16  Std Err Mean 0.1773355
90.0% 14  Upper 95% Mean 10.673895
75.0% quartile 12 Lower 95% Mean 9.9761051
_ 50.0% median 11 N 320
0246811141618  250%  quartie 8
10.0% 6
2.5% 4
0.5% 2.21
0.0%  minimum 1

Over this ten-day period, 320 items were sampled and tested. That's 32 items per day! A summary
report of these tests shows that just over ten defects are detected on average each day (Exhibit 3).

Exhibit 3 Summary of Defects by Day

Defects (Analyze > Tabulate; drag Day in drop zone for rows as a
grouping column, and Defects in the drop zone for column
Day N Mean as an analysis column. Then, drag N and Mean from the
middle panel to the middle of the table.
1 32) 10.34 Note that in JMP versions 10 and earlier Tabulate is under
2| 32| 10.16 the Tables menu.)
3| 32| 10.28
4| 32| 10.22
5| 32| 10.28
6| 32| 10.16
7| 32| 10.25
8| 32| 1044
9| 32| 10.25
10| 32| 10.88

Let’s consider two alternative sampling schemes.

Suppose that instead of sampling every fifteen minutes, we had only sampled once each day, say at
9:30am; we refer to this as Sampling Scheme A. This cuts down the number of samples each day from
32 to 1, presumably a significant decrease in time and money.



Alternatively, we could have sampled twice per day, say at 9:30am and 2:30pm (14:30) and averaged the
morning and afternoon readings. We’'ll call this Sampling Scheme B. Exhibit 4 compares the results of
Schemes A and B.

Exhibit 4 Sampling Schemes A and B

Sampling Scheme A: Sample Once Per Day (9:30am)

Defects 4~ Mean(Defects)

Day1 '1‘ ""ejg — 4~ Summary Statistics
2| 1 6 | — * Mean 112
al 1 12 Std Dev 3.0840089
4 1 11 Std Err Mean 0.9752493
S 17 Upper 95% Mean 13.406167
6 1 7 Lower 95% Mean 8.9938329
d 1 1 RN 10
8 1 12 | | | | I | |
o 1| 13 4 6 8 1012 14 16 18 20
10| 1 12

Sampling Scheme B: Sample Twice per Day (9:30 and 14:30)

Sample = 09:30, 14:30
o 4~ Mean(Defects)

— BefeI\c’:ILsa _ — 4~ Summary Statistics
L il 2 105 l—@A Mean 10.15
2| 2/ 105 Std Dev 2.0956304
i g g Std Err Mean 0.6626965
5/ 2 13 Upper 95% Mean 11.649124
6| 2 6 Lower 95% Mean 8.6508763
14 5 ] L 10
I 1 1 I 1 I I
9 2 9 56 7 8 910111213 14
10| 2/ 115

(Rows > Data Filter; select Sample and click Add. Then, select 9:30 and check the Show and Include boxes. Use the control key
to add 14:30 to the selection. Use Analyze > Tabulate to create the summary table as described earlier. Under the top red triangle
in Tabulate, select “Make Into Data Table”. Then, use Analyze > Distribution to create a distribution of Mean(Defects).)

In Exhibit 4 we note that the Scheme A generated individual observations (i.e., only one sample was
taken each day) with a mean of 11.2 defects and a standard deviation of 3.084. Scheme B, whose
observations are averages of two samples per day, generates an overall average of 10.15 defects with a
standard deviation of 2.096. Note the drop in the standard deviation, from 3 to 2, a decrease of one-third.
The first important result of this case has emerged:

Averages vary less than individual observations.

This result is intuitively appealing since, by their nature, averages “average out” extremes, and, therefore,
vary less.



The histograms in Exhibit 5 show the sample averages for the five different sampling schemes (1, 2, 8, 16
and 32 samples per day). Pay close attention to what happens to the spread of the averages in the
histograms as we collect an increasingly larger number of samples each day. In particular, note that the
sample size, n, increases as you move from Scheme A to Scheme E while at the same time the variation
in the histogram decreases.

Exhibit 5 Five Sampling Schemes

Sampling Scheme A
Sample at 9:30

Sample size each day:
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Sampling Scheme B L
Sample at 9:30 and 14:30

Sample size each day:
n=2
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Sampling Scheme C
Sample every hour
beginning at 8:30

Sample size each day: |‘|
n=38

I T T T T
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Sampling Scheme D
Sample every half-hour
beginning at 8:30

Sample size each day:
n=16

4 6 8 10 12 14 16 18 20

Sampling Scheme E
Sample every 15
minutes

Sample size each day:
n=32

4 6 8 10 12 14 16 18 20




Exhibit 5 illustrates the second important lesson learned from this case:

The variability in averages decreases as the sample size increases.

Now return to Exhibit 3 and note that there appears to have been a subtle shift in the process on Day 10.
The average of Day 10 is larger than the averages on the other days. Exhibit 6 shows daily time series

plots of Sampling Schemes A, C and E. Note the differences in the time series plots with regard to their
ability to detect the shift in the process on Day 10.

Exhibit 6 Average Defects Plotted Over Time

Sampling Scheme A
Sample at 9:30

Sample size each day:

n=1

Sampling Scheme C
Sample every hour
beginning at 8:30

Sample size each day:
n=38

Sampling Scheme E
Sample every 15
minutes

Sample size each day:
n=32
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(Use Data Filter and Tabulate, as described earlier, to create the summarized data tables for each scheme. Then, Graph
> Overlay Plot; Use Mean(Defects) as Y and Day as X, and click OK. In the Overlay Plot window, select “Connect

Through Missing” under the red triangle.)



In Exhibit 6, the upward shift in the process on Day 10 goes undetected in Sampling Scheme A. That’s
because some, but not all, readings taken on Day 10 shifted upward. Sampling Scheme A, with its single
sample each day, has a smaller chance of sampling an item that displays the shift in the process.
Sampling Schemes C and E, with increasingly larger sample sizes each day, more readily detect the shift
on Day 10. By sampling throughout the day, Schemes C and E provide a more representative estimate
of performance on that day, and:

e Averages are comprised of multiple individual observations, some of which will likely be the larger
(or smaller) values if the process has shifted, and

e Averages are not resistant. If a sample contains outliers (in this case, large outliers), the average
will move in the direction of the outlier.

From Exhibit 6 we learn that:

Averages are more likely to detect changes in a process than are individual observations. Up to
a point, the larger the sample size the more likely a shift in the process will be discovered.

Of course, many different sampling plans can be considered — we’ve explored only a few here. The
challenge is to achieve a balance between the cost of inspection and the impact of undetected defects.

Summary
Statistical Insights

With this case, we see that sample statistics, such as averages, are variable. That’s because
different samples drawn from a fixed population will generate different sample averages. For
example, when sampling every fifteen minutes (Exhibit 3), the first daily average was 10.34. The
second day’s average declined to 10.16. By Day 3, the average was 10.28. The averages varied
day to day, depending on the particular sample items chosen. We also learned that:

e When sampling from a fixed population, individual observations vary more than averages.
e The variability in averages decreases as the sample size increases.
e Larger sample sizes are more likely to detect shifts in a process than smaller sample sizes.

The ability to detect a shift also depends on the size or magnitude of the change. Detecting larger
shifts requires less data than detecting smaller shifts.

Note that our focus in this case was sampling distributions and sampling error. A more formal tool for
monitoring a process over time is a control chart, which is a type of time series plot used to plot either
individual values or averages over time. Other statistical tools, such as hypothesis tests and
capability studies, might also be used to analyze minor defect levels.

Managerial Implications

In defect sampling, the decision concerning the number of items to sample has important implications
on both cost and utility:



If a single observation is sampled each day, costs are low. However, expect a lot of
variability in the samples from day to day and keep in mind that the data tend to be slow in
detecting shifts in the process.

Multiple samples each day, whose values are then averaged to create that day’s reading, are
more likely to detect shifts in the process than a single daily reading. However, the costs of
sampling will increase.

Management must weigh the costs of sampling versus the potential cost and consequences of
undetected process changes.

JMP Features and Hints

In this case, we:

Exercises

Used Split to restructure our data into multiple columns,

Used the Data Filter to select specific values in the data table and hide and exclude other
values,

Used Tabulate and Distribution to summarize our data, and

Used Overlay Plot to create time series plots.

Open the Sampling Distribution of Sample Means teaching module in JMP. The module is available
under the Help Menu in JMP at the following path: Sample Data > Examples for Teaching > Teaching
Scripts > Interactive Teaching Modules.

B+ Sampling Distribution of Sample Means v 1.5 - JMP Pro B @@
File Edit Tables Rows Cols DOE Analyze Graph SixSigmaTools Tools Teach Add-Ins View Window Help
FREd| -G k2@ Me pa+@msS0O
4 Population Characteristics 4 Distribution of Sample Data 4 Sample Summary Table
Mean:
Population Shape: [Normal -] |20 Std Dev:
Population Mean: D 15 Sample:
Population Standard Deviation: 10
Name of Variable: 5
i 0
4Demo Characteristics 4 3 5 ) 0 1 2 3 4
Sample Size: Height
Number of Samples:
Animate lllustration? © Yes > Normal Quantile Plot
@ No 4 Distribution of Sample Means
10
4Run Simulation 8
|Draw Samples‘
- 6
4JMP Data Table <
|Create Data Table‘ 2
0 T T T T T T T
-4 -3 2 -1 0 1 2 3 4

4Population Data

|Create Histogram‘

Mean Height

4Means Summary Table
Mean of Sample Means:
Std Dev of Sample Means:
No. of Sample Means:

Jmp

‘ Help "MorelnformationHRestart Demo
.




This module will randomly draw a number of samples from a distribution. By default, samples of size 25
will be drawn from the standard normal distribution (the mean is 0 and the standard deviation is 1.)

1.

Change the Sample Size to 5, and change the Number of Samples to 1000. Click Draw
Samples. The Distribution of Sample Means will display a histogram for the 1000 sample means.

a. What is the shape of the histogram? What is the center of the histogram? How spread out is
the histogram?

b. The Means Summary Table will display the Mean of the Sample Means and the Std Dev of
the Sample Means. Record this information.

Change the Sample Size to 100, and click Draw Samples.

a. Look at the Distribution of Sample Means. How does the shape, center and spread of this
histogram compare to the previous histogram?

b. Record the Mean of the Sample Means and the Std Dev of the Sample Means. How do
these values compare to the previous values? Are these results consistent with what we
have learned in this case study?

Finally, change the Population Shape to Skewed Right, change the Population Standard
Deviation to 5, and click Draw Samples.

a. Samples are being drawn from a population that is highly right skewed (note that the
distribution of the last sample drawn under Distribution of Sample Data is right skewed).
Look at the Distribution of Sample Means. Describe the shape, center and spread of this
histogram.

b. Record the Mean of the Sample Means. How does this value compare to the Population
Mean?
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