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Durability of Mobile Phone Screen - Part 3 
Statistical Modeling: Single Variable Logistic Regression 

Key Ideas 

This case study requires building logistic regression models to evaluate the durability of different mobile 
phone screen types in a drop test across various heights. 

This case study is an extension of previous case studies (JMP032 - Durability of Mobile Phone Screen - 
Part 1 and JMP033 - Durability of Mobile Phone Screen - Part 2. While it isn’t necessary, it is 
recommended to complete those case studies first, since together they present a more comprehensive 
description of each stage of the study and subsequent analyses. 

Background 

The durability of a product is clearly an important quality characteristic for both the end user and the 
manufacturer. For end users, durability is especially important for mobile phones. Dropping a phone on a 
hard surface, for example, can result in the screen cracking or even breaking, rendering the phone 
unusable. To evaluate the durability of these screens, manufacturers subject a sample of screens to a 
variety of tests to simulate typical wear and tear by a user, such as dropping the phone onto a concrete 
surface. 

In case JMP032 - Durability of Mobile Phone Screen - Part 1 material scientists for a screen manufacturer 
experimented with two new formulations of an aluminosilicate glass (A and B). These two formulations 
were produced by making a change to a final processing step that uses a specific level of potassium 
nitrate to strengthen the glass.  

A sample of 10 screens of each type was developed for testing. Each screen was installed into the same 
style of phone. The phones were then dropped in a controlled identical manner from a height of 1 meter 
onto a concrete surface. A binary variable “Success” (no damage) and “Fail” (screen damage) was 
recorded.  

One of company’s goals is that 97% of the screens manufactured would be able to experience a drop of 1 
meter without becoming damaged (i.e., the Population Success Rate). 

The analyses illustrated in case JMP032 - Durability of Mobile Phone Screen - Part 1, which were based 
on 10 phones tested for each Screen Type, failed to generate the statistical evidence needed to 
demonstrate the desired Success Rate. The analyses also failed to find any statistically significant 
difference between the two Screen Types. 

The engineers decided to test an additional 40 phones for each of the two Screen Types. Analyzing the 
results from this expanded test was the objective of the exercises for that case study. 

 
 
In case JMP033 - Durability of Mobile Phone Screen - Part 2, the material scientists developed a third 
Screen Type (C), which required a more expensive process. Tests were done for this Screen Type at 
1.0m, as had been done for Screen Types A and B. In an effort to gain a comprehensive understanding of 
the durability of these screens, the engineers conducted the drop test at two additional heights (0.5 and 
1.5 meters), which resulted in the following data: 
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 0.5m 1.0m 1.5m 

Type A n=40 
S=36 
F=4 

n=50 
S=41 
F=9 

n=50 
S=28 
F=22 

Type B n=40 
S=40 
F=0 

n=50 
S=48 
F=2 

n=50 
S=40 
F=10 

Type C n=40 
S=39 
F=1 

n=50 
S=47 
F=3 

n=50 
S=39 
F=11 

These data were analyzed in case JMP033 - Durability of Mobile Phone Screen - Part 2. 

To continue developing a deeper understanding of the performance of the Screen Types, the engineers 
performed additional tests at Drop Heights of 0.25m, 1.25m, 2.0m, 2.5m and 3.0m. In addition, a sample 
of screens from a leading competitor were obtained and included in the testing, resulting in the following 
data: 

 0.25m 0.5m 1.0m 1.25m 1.5m 2.0m 2.5m 3.0m 
Type A n=25 

S=25 
F=0 

n=40 
S=36 
F=4 

n=50 
S=41 
F=9 

n=50 
S=35 
F=15 

n=50 
S=28 
F=22 

n=40 
S=4 
F=36 

n=40 
S=0 
F=40 

n=25 
S=0 
F=25 

Type B n=25 
S=25 
F=0 

n=40 
S=40 
F=0 

n=50 
S=48 
F=2 

n=50 
S=45 
F=5 

n=50 
S=40 
F=10 

n=40 
S=18 
F=22 

n=40 
S=4 
F=36 

n=25 
S=0 
F=25 

Type C n=25 
S=25 
F=0 

n=40 
S=39 
F=1 

n=50 
S=47 
F=3 

n=50 
S=45 
F=5 

n=50 
S=39 
F=11 

n=40 
S=16 
F=14 

n=40 
S=3 
F=38 

n=25 
S=0 
F=25 

Competitor n=10 
S=10 
F=0 

n=20 
S=19 
F=1 

n=20 
S=18 
F=2 

n=20 
S=16 
F=4 

n=20 
S=13 
F=7 

n=20 
S=5 
F=15 

n=20 
S=1 
F=19 

n=10 
S=0 
F=10 

The Task     

The primary objectives of this analysis are to: 

1. Describe how the performance of each Screen Type changes as the Drop Height changes. 
2. Describe differences in durability between the three Screen Types. 
3. Determine how the company’s three Screen Types compare to the screens of its competitor. 
4. Develop a tool that will estimate the Success Rate at any Drop Height, including those not part of 
the testing.  
5. Determine the Drop Height at which it is estimated that the Success Rate would be at least 97% 
for each Screen Type. 

The Data drop-test-3.jmp 

The data is stored in what’s referred to as Outcome/Frequency Table format. 

Screen Four screen types (A, B, C, and Comp) 
Height Height from which screens were dropped (0.25m, 0.5m, 1.0m, 1.25m,1.5m, 2.0m, 

2.5m, and 3.0m) 
Outcome Two outcomes (Success, Fail) 
Tested Number of screens tested 
Count Number of specimens that resulted in either Success or Fail 
Rate The percentage of phones that succeeded (didn’t experience damage) 

or failed (did experience damage) in the test 
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JMP Tips  

To perform an analysis on a subset of the data in the table, which will be used throughout these analyses, 
you’ll need to filter the data. It can be done either through the Global Data Filter at the data table level 
before running an analysis or with the Local Data Filter within the output window from an analysis. 

For Global Data Filter, select Rows>Data Filter. To choose a variable to filter, select the variable and click 
+. Choose Add to filter by additional variables. Select the values of the variables you wish to include in 
your analysis and then select the Show and Include boxes. Perform the analysis.  

For Local Data Filter, first run the analysis. Then select Local Data Filter under the red triangle at the top 
of the output. To choose a variable to filter, select the variable and click +. Choose Add to filter by 
additional variables. Select the values of the variables by which you wish to subset the data. The 
numerical and graphical results will change to correspond to the data being included in the analysis. The 
tools and analysis options available may change based on attributes of the data being included. 

Analysis  

Graphical  

We begin by summarizing the data graphically. Exhibit 1 displays a scatter plot showing points for each of 
the Success Rates for the four Screen Types and eight Drop Heights. In addition, fitted curves are added 
to visualize how the Success Rate changes across the Drop Heights. 

Exhibit 1    Scatter Plot with Smoother  

(To create this graph from the data table, the data will need to be filtered so that it only uses the rows corresponding 
to the success outcome. To do so, use the Global Data Filter. Choose Rows>Data Filter. Filter the data by the 
variable outcome. See JMP Tips on page 4 for instructions.) 

(To create, Graph>Graph Builder. Select Rate as the Y Variable, Height as the Freq Variable, and Screen as the 
Overlay Variable. Use Local Data Filter to filter only Success as outcome) 

This graph provides a nice visualization of the change in Success Rate across the full range of Drop 
Heights, as well as potential differences between the Screen Types. For example, it appears that the 
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Success Rates for Screen Types B and C are very similar and have the best performance. Screen Type A 
appears to perform the worst; the Success Rate for the competitor’s screen is somewhere in between. 

Single variable logistic regression model 

Though this graphical display provides a valuable visual description of the data, building statistical models 
will allow us to describe the data more precisely, providing us with statistical tools to explain, compare, 
and predict. 

Logistic regression is a valuable statistical modeling framework that is well suited for these data. 

The structure of the logistic regression is: 

log ൬
p

1 − p
൰ = 𝛽଴ + 𝛽ଵ𝑋 

where p is the probability of the event of interest happening. X  is the explanatory variable being studied. 
𝛽଴ , 𝛽ଵ are the parameters in the model to be estimated from the data, and ε  is the random variation in 
the data that the model does not explain.  

For our study, we can define the event of interest as the screen not being damaged in the drop test 
(Success) and the explanatory variable is the Drop Height. 

Another, sometimes more convenient, way to express a logistic regression model is in terms of the 
probability of the event happening. 

Prob(Event) = 
1

1 + 𝑒ି(ఉబାఉభ௑)
 

 We’ll begin our model-building process by fitting a logistic regression model to the data from Screen 
Type A only. You’ll be tasked in the exercises to build similar logistic regression models for Screen Types 
B, C, and the Competitor. 

Exhibits 2 through 5 show the output of a building a logistic regression model for Screen Type A. 

Exhibit 2    Logistic Regression Plot 

 

 

 

 

 

 

 

 

 

 

(For this analysis, the rows corresponding to both Success and Failure outcome need to be used. The data can either 
be filtered so that it only uses the rows corresponding to Screen A, or the variable Screen Type can be used as a By 
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Variable when running the analysis. Filtering the data can be done via the Global Data Filter prior to running the 
analysis or afterward with the Local Data Filter. See JMP Tips on page 4 for instructions.  

To create, Analyze>Fit Y by X. Select Outcome as the Y Variable, Height as the X Variable, and Count as the Freq 
Variable. If choosing to use Screen as the By Variable instead of filtering the data, then select Screen as the By 
Variable. This approach will fit a separate logistic regression model for each Screen. 
 
For these data, it’s best to remove the data points from the Logistic Fit Graph and use the Rate Curve instead. 
Choose Plot Options under the red triangle at the top of the output. Remove the data points by unchecking Show 
Points. Display the Success Rate values by selecting Show Rate Curve.) 
 

This graph is very similar to the one in Exhibit 1. The model fit here is a logistic regression model while 
the fitted model shown in Exhibit 1 uses a model form known as the cubic spline. They are similar for 
these data but not identical. 

A logistic regression analysis contains other numerical output that can be useful to examine. Exhibit 3 
displays some of that output. 

Exhibit 3    Logistic Regression 

The Whole Model Test is testing the following hypothesis in the model  
 

 𝐏𝐫𝐨𝐛(𝐄𝐯𝐞𝐧𝐭) = 
𝟏

𝟏ା𝒆ష൫𝜷𝟎శ𝜷𝟏𝑿൯
 

H0: 𝛽ଵ = 0 

HA: 𝛽ଵ ≠ 0 

If 𝛽ଵ is believed to be 0, then there is no significant impact on the probability of success as the Drop 
Height changes. The p-value for this test is extremely small (< 0.0001), which is very strong statistical 
evidence that 𝛽ଵ is not equal to 0. The estimate of 𝛽ଵ shown in the Parameter Estimate Table is -3.42. A 
95% confidence interval for 𝛽ଵ shown in the exhibit, is [-4.26 , -2.71], an interval not containing 0. (can be 
obtained from top red triangle) 

Thus we would conclude that Drop Height has a statistically significant impact on Success Rate, which is 
quite obviously the result we were expecting as we clearly saw that significant effect in the graphs. 
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Sometimes, however, the impact of a factor on the outcome isn’t obvious and a statistical test is needed 
to determine if that effect is indeed statistically significant. 
 

Using fitted model to make predictions 

In addition to describing relationships between variables, statistical models are also useful for making 
predictions. Using a more general modeling platform in JMP that provides these prediction capabilities, 
including the addition of confidence intervals, we will illustrate how to make predictions. 

Exhibit 4, which uses the Profiler, JMP’s interactive tool that displays the fitted model, shows the 
predicted outcome and 95% confidence intervals for any Drop Height between 0.25 and 3.0 meters. 
 

Exhibit 4    Profiler  

 

 

 

 

 

 

 

(For this analysis, the rows corresponding to both Success and Failure outcome needs to be used. The data can 
either be filtered so that it only uses the rows corresponding to Screen A, or the variable Screen Type can be used as 
a By Variable when running the analysis. Filtering the data can be done via the Global Data Filter prior to running the 
analysis or afterward with the Local Data Filter. See JMP Tips on page 4 for instructions. To create, Analyze>Fit 
Model. Select Outcome as the Y Variable, Height as the Model Effects, Count as the Freq Variable, and Screen as 
the By Variable. Choose Generalized Linear Model under Personality, Binomial as the Distribution, and Logit as the 
Link Function. If choosing to use Screen as the By Variable instead of filtering the data, then select Screen as the By 
Variable. This approach will fit a separate logistic regression model for each Screen.After running the analysis, 
choose Profiler under the red triangle at the upper left of the output.) 

Here we see that the predicted Success Rate at a Height of 1.0m is 83.1%. A 95% confidence interval 
quantifying the uncertainty in that prediction is [76.2%, 88.4%]. That is, we are 95% confident that the 
Population Success Rate for Screen Type A at 1.0m ranges from 76.2% to 88.4%. 

In case JMP032 - Durability of Mobile Phone Screen - Part 1 and case JMP033 - Durability of Mobile 
Phone Screen - Part 2, we estimated the Success Rate at this Drop Height for the different Screen Types. 
In the exercises, you’ll be asked to compare the precision of these estimates via those analyses 
compared to the ones produced by the logistic regression model. 

Inverse prediction is another useful type of prediction to estimate the Drop Height that would achieve a 
given Success Rate. This type of prediction is a different way for us to evaluate the durability of the 
screens. We choose a Success Rate of 0.97, and the model is used to estimate the Drop Height that 
achieves that Success Rate. Exhibit 5 shows the results of making this inverse prediction. 
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Exhibit 5    Inverse Prediction 

 

 

 

 

 

 

 

 

 

 

(Choose Inverse Prediction under the red triangle at the upper left of the output. Enter 0.97 for the 
Probability(Outcome=Success) field.  

Note: The above graph was zoomed in to the area of interest. 

The predicted Drop Height to achieve 97% Success Rate is 0.45m with a 95% confidence interval of 
[0.16, 0.64]. Thus, we are 95% confident that a 97% Success Rate occurs between a Drop Height of 
0.16m and 0.64m. 

The exercises will ask you to build separate logistic regression models for the other three Screen Types, 
interpret the results and make predictions. 

 

Evaluating model performance 

Evaluating model performance can be done by comparing the predicted probability of success from the 
logistic regression model compared to the actual success rate observed in the data. 

Exhibit 6 demonstrates two common ways to visualize prediction error in a logistic regression model. 
These graphs show how large or small the prediction error is. Points close to the reference lines 
represent when the Estimated Success Rate from the logistic regression model is close to the Observed 
Success Rate from the actual data. Points above the line represent when the Observed Success Rate is 
larger than the Estimated Success Rate; points below the line occur when the estimated is larger than the 
observed. For example, the prediction error is the greatest for the 1.5m Drop Height. The Observed 
Success Rate in the data is 100*(28/50) = 56%. The Estimated Success Rate from the model is 47.1%. 

Overall the Estimated Success Rates are close to the Observed Success Rates, indicating that the model 
describes the data quite well. 
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Exhibit 6    Visualizing Prediction Error  

(Save the Estimated Success Rates by selecting Save Columns>Predicted Values under the red triangle in the upper 
left of the output. Create a new column for the difference between the Observed Success Rate and the Estimated 
Success Rate by selecting Cols>New Column, then selecting Column Properties>Formula. Create the formula 
Observed – Estimated via the formula: ‘Rate’ - ‘Pred Outcome’.) 

For the graph on left, the data in the data table will need to be filtered so that it only uses the rows corresponding to 
the Success Outcome. The best way to do this is via the Global Data Filter. Choose Rows>Data Filter. Filter the data 
by the variable Outcome. See JMP Tips on page 4 for instructions.  

To create the graph on the left, Graph>Graph Builder to plot the Observed Success Rate vs. Estimated Success 
Rate. A line was added manually via Tools>Line showing when Observed = Predicted. To add the values as data 
labels, right-click on the Height Column and select Label/Unlabel. Highlight all the data points in the graph. Right-click 
and choose Rows>Row Label. 
 
To create the graph on the right, Graph>Graph Builder to plot the Observed – Estimated values on the Y axis vs. 
Drop Height on the X.) 
 

Summary  

Statistical insights     

The study included eight different Drop Heights ranging from 0.25 meters to 3.0 meters. This data allows 
us to build logistic regression models using an equation to determine that the probability of a screen’s 
success in the drop test is a function of Drop Height. 

The logistic regression model fit to the Screen Type A tests provided us with a tool to estimate the 
probability of a screen being damaged or not across any Drop Height between 0.25 and 3.0 meters, 
including those not part of the study. We demonstrated that using the logistic regression model, it is 
estimated (at 95% confidence) that the Population Success Rate for Screen Type A at 1.0m is between 
76.2% and 88.4%. 
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The logistic regression model also provided us with a tool to perform an inverse prediction, specifically, 
estimating the Drop Height that would result in a given Success Rate. We demonstrated that we estimate 
(at 95% confidence level) that the Drop Height that would achieve a 97% Success Rate for Screen Type 
A occurs between 0.16m and 0.64m. 

We also demonstrated how the model’s Estimated Success Rates can be compared to the Observed 
Success Rates as a means to evaluate the predictive capabilities of a model. 

Implications and next steps      

The exercises will ask you to build logistic regression models for the other Screen Types (B, C, and 
Competitor). You’ll use those models to describe the performance of each Screen Type, make 
predictions, and compare the results. 

 

Exercises    

Use the data in file Drop Test 3.jmp data set to answer the following questions: 
 

1. Create separate logistic regressions models for each Screen Type describing the relationship 
between Success Rate and Drop Height. Show graphs that display the models along with the 
Observed Success Rates for all four Screen Types. 
 

2. For each model, provide a point estimate and a 95% confidence interval estimate of the Success 
Rate at a 1.0m Drop Height. Create a table and a visualization that display the point estimate, 
lower and upper bound of the confidence intervals. Compare the performance of the Screen 
Types at this Drop Height. How does the performance of the Competitor Screen compare to the 
three our engineers developed? Compare the precision in the estimates of the Success Rate for 
each Screen Type. Which ones have the most precision? 

 
3. If case JMP032 - Durability of Mobile Phone Screen - Part 1 or case JMP033 - Durability of 

Mobile Phone Screen - Part 2 were completed, compare the precision of the estimates of the 
Success Rates at the 1.0m Drop Height via the confidence intervals from those analyses to the 
ones done in this case study using the logistic regression model. Which estimates are more 
precise? What are the possible reasons? 
 

4. For each individual logistic regression model, generate a point estimate and a 95% confidence 
interval estimate of the Drop Height that would result in a 97% Success Rate. Create a table and 
a visualization that display the point estimate, confidence intervals, and the width of the CI as a 
means to present all the results together. Which of the models have the smallest and largest 
amount of error in these estimates?   
 

5. Create graphs that display the prediction error for each of the individual logistic regression 
models. Comment on how close the Estimated Success Rates are to the Observed Success 
Rates. 
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