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Why use this connection?

- Use JMP’s dynamic linkage, advanced visuals or powerful
analytics, but also use special R or Python packages.

- Explore new methodology in an R package side-by-side with
validated methods in JMP.

- Develop an add-in to JMP that calls R or Python so that future
users can interact with the GUI add-in without needing to
write the R or Python code themselves.

- Introduce specific open source packages in the classroom but
within a point-and-click environment that wouldn’t require

coding by the student.
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Agenda

Generating Python (or C, JavaScript, SAS or SQL) to deploy
in another environment.

- Housing Prices example deployed in AWS
- Valentine’s Heart example deployed in AWS

Simple Python connection example
Simple R connection example

R add-in example: T-SNE and UMAP
R add-in Builder example

Making an Add-In

Help!
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Using JMP and JMP Pro With Python and R

JMP Synergies With Open Source

Gsas Jmp
By Ruth Hummel, JMP ’ N
JMP is a standalone, full-featured data visualization and
statistical analysis software from SAS for the Windows and
Mac desktop. JMP has the interactivity and dynamic

JMP* Synergies: Using JMP" and JMP" Pro With Python and R

linkage that makes data exploration exciting, insightful and
contains many advanced analytical options, fully satisfying
the needs of data explorers and analysts. Still, there may
be occasions where you'll want (or need) to use JMP in

conjunction with open source tools, like Python or R.

In addition to providing you with the basics, this paper introduces the Python scoring-
code generation, the Python in JMP scripting and the R in JMP scripting. You'll also
discover sample code and advanced examples that will make using the connections and
add-ins provided in JMP easy.

Whatever your motivation for connecting open source (or other) tools with JMP software's
GUI, this guide will help you to get started using the Python and R connections in JMP.

Download Now
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Generating Code: Housing Prices Example

https://s3.amazonaws.com/stlouishousing.web/index.html

 Prediction model developed in JIMP

- Generate Python code and deploy in AWS with a webpage
wrapper

Osas


https://s3.amazonaws.com/stlouishousing.web/index.html

Generating Code: Valentine’s Heart Example

https://s3.amazonaws.com/jmp.valentine/index.html

- simple use case: creating a - neural net developed in JMP
static (self-contained, no server
calls) web app with an
embedded model.

- deployed it in JavaScript and
“wrapped” a visualization and
web page around it

Osas
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Simple Python Example

f SimplePythonExample

Il » E

”

Import as Data

1 Names Default To Here(1);

\/ on n1i :

dt=open("$SAMPLE_DATA\Big Class.jmp");

Python Send(dt);
Python Submit("print (dt)");

[« NoolL Nl » NOLIF -3 1)

[ JON ) #] Big Class.jmp
|~Big Class.jmp >| < ® heigh weig
Locked File /Library/Ap | 3 name age sex t ht
: g:::r'lt:gm 1 KATIE 12 F 59 95
» Oneway 2 LOUISE 12 F 61 123
> Logistic 3 JANE 12 F 55 74
» Contingency 4 JACLYN 12 F 66 145
t gi(tatMSc;?(el lue Labels FILILLIE L2 3 - -
P Set Age ..-...ue Labels 5/ TiM 12/M 60 84
> Graph B...other Line 7 JAMES 12 M 61 128
» Graph B...ar Charts 8 ROBERT 12 M 51 79
» Graph B...ine Chart 9 BARB... 13 F 60 112
» Graph B... Heatmap 10 ALICE 13 F 61 107
[~ Columns (5/0) | 11 SUSAN 13 F 56 67
ik name s 12 JOHN 13 M 65 98
f:gf 13 JOE 13 M 63 105
A 14 MICH... 13 M 58 95
A weight 15 DAVID 183 M 59 79
16 JUDY 14 F 61 81
|@R0WS | 17 ELIZA... 14 F 62 91
R 20 18 LESLIE 14 F 65 142
Selected 0 19 CAROL 14 F 63 84
Excluded 0 20 PATTY 14 F 62 85
Hidden 0 21 FRED... 14 M 63 93
Labelled 0 25 Al FRED 14 M A4 Qg
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the script window

Cut

Copy
Paste
Clear
Select All

v/ Show Line Numbers

Show Embedded Log

Advanced
Wrap Text
Split

Run Script
Debug Script
Reformat Script
Submit to SAS

v

| 2

>

Or go to
Window > Log

Minimize

Zoom

Move Window to Left Side of Screen
Move Window to Right Side of Screen

Hide
Hidden >
Set Report Title

JMP Starter &0

Log 81

JMP Home 82

Show Data Table
Combine Windows...
Move to/from Project...
Bring All To Front

Big Class.jmp

e dt
v SimplePythonExample

Tip: Choose to view the Log
Either right-click within

Log

2 N H

Names Default To Here(1);
Python Init();
dt=open("$SAMPLE_DATA\Big Class.jmp");

Python Send(dt);
it("nrint (dt)'")-

S

name age sex height weight
] KATIE 12 F 59 95
1 LOUISE 12 F 61 123
2 JANE 12 F 55 74
3 JACLYN 12 F 66 145
4 LILLIE 12 F 52 64
5 TIM 12 M 60 84
6 JAMES 12 M 61 128
7 ROBERT 12 M 51 79
8 BARBARA 13 F 60 112
9 ALICE 13 F 61 107
10 SUSAN 13 F 56 67
11 JOHN 13 M 65 98
12 JOE 13 M 63 105
13 MICHAEL 13 M 58 95
14 DAVID 13 M 59 79
15 Jupy 14 F 61 81
16 ELIZABETH 14 F 62 91
17 LESLIE 14 F 65 142
18 CAROL 14 F 63 84
19 PATTY 14 F 62 85
20 FREDERICK 14 M 63 93
21 ALFRED 14 M 64 99
22 HENRY 14 M 65 119
23 LEWIS 14 M 64 92
24 EDWARD 14 M 68 112
25 CHRIS 14 M 64 929
26 JEFFREY 14 M 69 113
27 MARY 15 F 62 92
28 AMY 15 F 64 112
29 ROBERT 15 M 67 128
30 WILLIAM 15 M 65 111
31 CLAY 15 M 66 105
32 MARK 15 M 62 104
33 DANNY 15 M 66 106
34 MARTHA 16 F 65 112
35 MARION 16 F 60 115
36 PHILLIP 16 M 68 128
37 LINDA 17 F 62 116
38 KIRK 17 M 68 134
39 LAWRENCE 17 M 70 172

§gsas



@ C '# SimplePythonExample

. N = Ehl ’\.. S H MR

Run Script Debug Script Reformat Script Balance Import as Data

1 Names Default To Here(1);

Python Submit("\[

2 th The JMP Data table is transferred to Python as a pandas data
3 Python Inlt( ) H #rglﬂeint out the column names
for col in dt.columns:
4 print( col )
5 dt=0pen ( i $SAMPLE_DATA\Blg ClaSS . J mp" ) ; ‘p‘egreiﬁct:ﬁ a new column and apply formula to data, creating pounds
6 # weight / height
7 Python Send(dt); ‘ det my_formutalu,h):
8 P thon Smelt rlnt (dt) ) H dt['lb_inch']l = dt. appl (lambda row:
my_formula(row(['weight'], row['height']), axis=1)
10 Python Submit("\[ dt.head()
11 # The IMP Data table is transferred to Python as a pandas data frame print(at)
13 for col in dt.columns: nane
14  print( col ) pe
15 s
ght
16 # Create a new column and apply formula to data, creating pounds per inch inch e age sex height weight lb_inch
17 _# weiaht / heiaht 1 WUISE 12 F a1 123 2.olese
et my_tormulalw,h): S adW 12 F e s 21097
19 return w / h 4 LILLIE 12 F 52 64 1.230769
20 5 TIM 12 M 60 84 1.400000
6 JAMES 12 M 61 128 2.098361
21 dt['lb_inch'] = dt.apply(lambda row: my_formula(row['weight'],row['height']), axis=1) é aﬁﬁg i§ v § 1? i%%ﬁ
2 e e s e
23 dt.head() 12 JE 13 M 63 105 1.666667
24 13 MICHAEL 13 M 58 95 1.637931
) 14 DAVID 13 M 59 79 1.338983
25 print(dt) 15 Jwy 14 F 61 81 1.327869
N7 ), P .
28 dt2 = Python Get(dt);
29 dt2 << New Data View;

Copyright © SAS Institute Inc. All rights reserved



[ NON ) dt 2
[~dt 2 > =
» Source name age sex height weight Ib_inch
1 KATIE 12 F 59 95 1.6101694915
2 LOUISE 12 F 61 123 2.0163934426
3 JANE 12 F 55 74 1.3454545455
Eig'n‘f:“s (6/0) 4 JACLYN 12 F 66 145 2.196969697
7 5 LILLIE 12 F 52 64 1.2307692308
ik sex 6 TIM 12 M 60 84 1.4
4 height 7 JAMES 12 M 61 128 2.0983606557
1;’;‘9:?12; 8 ROBERT 12 M 51 79 1.5490196078
= 9 BARBARA 13 F 60 112 1.8666666667
10 ALICE 13 F 61 107 1.7540983607
11 SUSAN 13 F 56 67 1.1964285714
12 JOHN 13 M 65 98 1.5076923077
[~ Rows 13 JOE 13 M 63 105 1.6666666667
All rows 40 14 MICHAEL 13 M 58 95 1.6379310345
255322‘:1 g 15 DAVID 13 M 59 79 1.3389830508
T 0 16 JUDY 14 F 61 81 1.3278688525
Labelled 0 17 ELIZABETH 14 F 62 91 1.4677419355
18 LESLIE 14 F 65 142 21846153846

1. Sent data to
Python

2. Ran some
Python code
on it

3. Brought the
resulting data
back into JMP

Gsas
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Now we can do more cool things in JMP with

the results we brought back from Python...

7 SimplePythonExample

Run Script Debug Script Reformat Script Balance Import as Data

27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

dt2 = Python Get(dt);
dt2 << New Data View;

Python Term();

.
» Source
» Set C...orical
P Set ...sponse
| » Distribution
P> Fit w...height
» Fitw...height | =
» Text ...esses

AN

= Columns (7/1)
0 pictures— ¢

ik name

A4 age

bk sex

A height

A weight

"= 41b inch

dt3 = open("$SAMPLE_DATA\Big Class Families.jmp");

Data Table("dt") << Join(
With( Data Table(dt3)),
SelectWith( :picture),
Select( :name, :age, :sex, :height, :weight,
By Row Number,
Output Table("dt")

0
Selected 0
Excluded 0
Hidden 0
Labelled 0

DR RHCIN Y,

0N RWN =

picture

13D B}

b ot acol oy, :

name

ROBERT
ALFRED
ALICE
AMY
BARBARA
34 others

KATIE
LOUISE
JANE
JACLYN
LILLIE
TIM
JAMES
ROBERT
BARBARA
ALICE
SUSAN
JOHN
JOE
MICHAEL
DAVID

dt 2

12

12 F
12 F
12 F
12 F
12 F
12 M
12 M
12 M
13 F
13 F
13 F
13 M
13 M
13 M
13 M

sex

height

70

weight Ib_inch
172 2.46

64 13
95 1.6101694...
123 2.0163934...
74 1.3454545...
145 2.196969697
64 1.2307692...
84 1.4
128 2.0983606...
79 1.5490196...
112 1.8666666...
107 1.7540983...
67 1.1964285...
98 1.5076923...
105 1.6666666...
95 1.6379310...
79 1.3389830...
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dt 2 - Graph Builder

RN % |

wenes

Ib_inch vs. age

2.50

2.25-

1.50

1.25+

B o )
>
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If you need help, go to Help > Scripting Index

@ [ ) Scripting Index
O @ All Categories |5 | Q Python Connect
o PythonConnection = Python
. Process...opab[llty Plots Python Connect Cz)lnnect( < Echo( boo{ean ), > <
rocess C...sis Histogram Python Control Path( Path to Python DLL or
Process C...nteractive Plot Python Execute - — d .
Process Capability Goal Plot Python Get Returns a Python connection scriptable
Process Ca...ility Index Plot Python Get Graphics object.
Process Ca...rformance Plot Python Get Version
© Process History Explorer Python Init
© Process Screening Python Is Connected
© Profiler Python JMP ...o Python Name| | £yompie & See Alsov  Topic Help
Simulator Python Send
() Programming Python Send File lgames Default To Ee re( 1);
h . ythonConnection =
Project Python Submit Python Connect();
PropertyEditorBox Python Submit File x = PythonConnection <<
() Python Python Term Is Connected;
@ Python Connection Show( x ); )
OR PythonConnection << disconnect;
© R Connection
RadioBox
() Random
RangeSeg
RangeSliderBox
) Recurrence Analysis
© Reliability Forecast
Forecast Options
Reliability F...r Dates Format
Reliability F...evada Format
Reliability F... Event Format
) Reliability Growth
Crow AMSAA
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[ NON )
. QA

Run Scrij

~ = = Simple R Example::

# Fitness.jmp

~/Fitness.jmp  *

New Data Table Name

8.17
8.63

166 40
170 48
b

N~ New Data Table... »

//
dt
dt

R
R

R

R|~ Columns (1/0)

//
Jv

//
Ne

NRPRRPRRRRBRRRR
CVONOUDRWNROOONOUIDWNR

r 4 log of RunTime

21 Di

22 ~/Rows

22 Allrows 31
%g Selected 12
27 Excluded 0
o ,, Hidden 0
30 | Labelled 0

318K

4

v

hd

0N O WN =

QN TG G G . Y
aa b ODND -2 O 0

log of RunTime
3.688879454...
3.871201010...
3.806662489...
3.871201010...
3.784189633...
4.007333185...
4.025351690...
3.871201010...
3.891820298...
3.871201010...
4.127134385...
4.204692619...
3.806662489...
3.871201010...
3.912023005...

me

@ @ New Data Table Name - Distribution

2 & @

Window Tools

v ~/Distributions

v ~log of RunTime

—

3.60 3.7 3.8 39

4

4.1

42 43

= Name Sex Age Weight Oxy Runtime RunPulse RstPulse MaxPulse
42 68.15 59.57
38 81.87 60.06

172
186
168

>>

R—
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https://community.jmp.com/t5/JMP-Add-Ins/Data-visualization-

with-t-SNE-and-UMAP/ta-p/177969

JMP-R
connection

used for
JMP Add-In

3t Choose Language

Q 4 MJ sTaFF

Data visualization with t-SNE and UMAP

FEB 27, 2019 8:34 AM
mnistjmp & Q Embedding.v1.2jmpaddin &

Description

Recently, non-linear dimension-reduction and visualization algorithms, most notably t-Distributed Stochastic Neighbor
Embedding (t-SNE) and uniform manifold approximation and projection (UMAP), have been widely applied to various research
areas such as image processing, text mining, and genomics. This Add-in provides access to both t-SNE and UMAP R
packages. It offers a user-friendly interface enabling data table navigation, data quality control, sparsity handling, intuitive
parameterization, and interactive results interpretation.

Usage Example

Here is a screenshot of the interface with MNIST data loaded. Under Model Specifications, | selected the label column as Label
and all the pixels as predictors. | chose both t-SNE and UMAP as the algorithms.

VI Ovpt Dl 2 Pulenty B0 Manier 190

“

4 g

4 ez VA Ovpt Do 2 mreghten TS mapeche 20 e 81

4 gy A d
“


https://community.jmp.com/t5/JMP-Add-Ins/Data-visualization-with-t-SNE-and-UMAP/ta-p/177969

https://community.jmp.com/t5/JMP-Add-Ins/The-JMP-to-R-Add-In-

Builder/ta-p/43879

3t Choose Language

"-' % juliagong STAFF (RETIRED)

The JMP to R Add-In Builder

AUG 31, 2017 8:11 AM
% PAA jmpaddin & % SVM.jmpaddin & % JMPtoRAddinBuilder_Documentation.docx &
% JMPtoRAddinBuilderWithReport.jmpaddin & % SVMWithReport.jmpaddin &

% JMPtoRAddinBuilder.jmpaddin %

Update 27Jun2018: JMPtoRAddinBuilder.jmpaddin now contains unencrypted JSL source files.

Version 2 Update

| am happy to announce that the JMP to R Add-In Builder now supports the output of all output components

(table, plot, etc.) as a single report! To enable this feature, install the attached "JMPtoRAddinBuilderWithReport".

When defining your output components, check the "Return all results as report" box.
To see an example of the updated output format, scroll to the corresponding section in the post below. The SVM
function with the report output enabled is also attached.

What is the JMP to R Add-In Builder?

AV. VI D T W | = P R (N G SN S B « S 1T W 1 o= . S A S B | B 1 oo B P (LY L R PR e I

Easily build a
JMP Add-In
calling R,
without using
any jsi!!!

Jeff_Perkinson ]


https://community.jmp.com/t5/JMP-Add-Ins/The-JMP-to-R-Add-In-Builder/ta-p/43879

Goal: Make this Support Vector Machines Add-In

{7 R Graphics: Device 2 (ACTIVE)

File History Resize

SVM classification plot

8% SVM - JMP Pro
SVM .
Creates an SVM model, prediction column, confusion matrix, and 2
accompanying SVM plot. =
~Select Columns ———————— ~Cast Selected Columns into Roles 2
A ucellsize | e | | required S
A normnucl
A mitoses [V Axis (Plot)] | required i
it class -
| X Axis (Plot)| | required 8
SVM Type | |

Prediction Column Format

mitoses

Predictions |

negative pred y Freq
negative 1| negative negative 434
negative 2 positive negative 24
positive 3 negative positive 12
negative 4 | positive  positive 229
negative

negative

negative S.Sas



8% Configure Your Add-in - JMP Pro = O X
How many components should your add-in have? | 6 |
How many columns should your add-in have? | 2 |

Step 1 of 10 [ Next |

Our goal:

8% SVM - JMP Pro

SVM

Creates an SVM medel, prediction column, confusion matrix, and

-Select Columns

A ucellsize
A normnucl
A mitoses
h class

SVM Type | C-classification ™

Component Types Available:
« Check Box

Column List

« Column Select
- Dropdown Menu
« Numeric Value

Cast Selected Columns into Roles

1 -Action

Factor required

Y Axis (Plot)| | required

X Axis (Plot)| | required

OK

| | Remove |

Prediction Column Format l Mrmee - l

|2 O~

Gsas



8% Configure Your Add-in - JMP Pro —

Component 1: [ Golumnllhst v

Component 2: ’ Dropdown Menu ¥
Component 3: \ Dropdown Menu ¥

|
|
|
Component 4: ’ Column Select v |
|
|

Component 5: \ Column Select ¥

Component 6: [ Column Select v

Step 2 of 10

O X

Please identify the type of component for all 6 compeonents in the
order you'd like them to appear on your add-in, column-wise.

Our goal:

8% SVM - JMP Pro

Component Types Available:
« Check Box

« Column List

« Column Select

- Dropdown Menu
- Numeric Value

SVM
Creates an SVM medel, prediction column, confusion matrix, and
accompanying SVM plot.

SVM Type | C-classification v

-Select Columns ————————— - Cast Selected Columns into Roles

A ucellsize -
A normnucl

oK

A mitoses
|

i class X Axis (Plot)| | required

Prediction Column Format l Mrmee - l I

Gsas



Our goal:

=5 Configure Your Add-in - JMP Pro

Please define what each component should do and in which
column it should go.
Note: All column selects must go in the same column.

Column List: This is updated from your table. [ Columni1 v }

Dropdown Menu: [SVM Type,C-classification, eps-regression ” Columni v ]

Dropdown Menu: [Prediction Column Format,Numeric,Character ” Columni1 ¥ |

Column Select: Required

Column2 v
[] Multiple Columns [ ]

[] Numeric

Column Select: Required
[] Multiple Columns
[] Numeric

Column Select: Required
[] Multiple Columns
[] Numeric

Choose the column for
each component.

Give titles and option text.

Step 3 of 10

SVM
Creates an SVM model, prediction column, confusion matrix, and
accompanying SVM plot.

-Select Columns

A ucellsize
A normnucl
A mitoses
wh class

Cast Selected Columns into Roles

-Action

| Factor | [ required

[ok ]

[V Axis (PIot)| [ required

| Cancel |

[x Axis (PIot)| [ required

SVM Type | C-classification > |
Prediction Column Format | Numeric v

| Remove |

8% Configure Your Add-in - JMP Pro — ] X

Please define the names of each of your column select boxes.

Column Select 1 Name:
Column Select 2 Name: |Y Axis (Plot)
Column Select 3 Name: |X Axis (Plot)

tep 4 of 10

Gsas




% Configure Your Add-in - JMP Pro

Preview of Your Add-in:

-Select Columns

A ucellsize
A normnucl
A mitoses
i class

SVM Type | C-classification "‘

- Cast Selected Columns into Roles

- o X See a preview.

- Action

| Factor ||requined |
IV Axis (Plot)| | required ]

X Axis (Plot)| | required |
| Remove l

Prediction Column Format

Step 5 of 10

|l & ™

g% Configure Your Add-in - JMP Pro — O

o.

Please give a name and optional description to your add-in.

X

Add-in Name: [SVM

Add-in Description (optional): |Creates an SVM medel, prediction
column, confusion matrix, and

accompanying SVM plot.

Step 6 of 10

| Next

—| @Give name and
description.

Gsas



Steps 7, 8, 9, and 10 are about your R code:

R Code for this example:

library(el@71)
library(gridExtra)

theText <- paste("x <- subset(dt, select=-", colnames(factor)[1], "D")
eval(parse(text=theText))

y <- factor

svm_model <- svm(x, y, type=svmType)

modelText <- paste("second.svm <- svm(", colnames(factor)[1], " ~ ., data = dt)")
eval(parse(text=modelText))

summary(svm_model)
summary(second. svm)

pred <- predict(svm_model, x)
pred <- as.vector(pred)

if(is.list(y)) {y <- unlist(y)}
predTable <- table(pred,y)
predTable <- as.data.frame(predTable)

eval(parse(text=paste(colnames(Cy_var)[1], "<- as.vector(as.matrix(y_var))")))
eval(parse(text=paste(colnames(x_var)[1], "<- as.vector(as.matrix(x_var))")))

maxl <- eval(parse(text=paste("max(", colnames(y_var)[1], "D"D))
max2 <- eval(parse(text=paste("max(", colnames(x_var)[1], "D")))
gridSize <- eval(parse(text=paste("max(c(", max1l, ",", max2, "))")))

eval(parse(text=paste("plot(second.svm, dt,

, colnames(Cy_var)[1], " ~ ", colnames(x_var)[1], ", fill=TRUE, grid=gridSize)"

Gsas



8% Configure Your Add-in - JMP Pro -

Please define your R input and output variables.

R input variable name for SVM Type:

Rinput variable name for Prediction Colum

R input variable name for Factor:

Rinput variable name for Y Axis (PI

Rinput variable name for X Axis (PI

List all R output variable names here,
separated by commas (','), no spaces:

Step 7 of 10

8% Configure Your Add-in - JMP Pro = ]

X

Enter all of the R code that your add-in will run. Enter the number
of output display actions your function will have.

Type your R Code (in R syntax) here. Make sure your code
references only the variables you defined earlier.

library(e1071)
library(gridExtra)

theText <- paste("x <- subset(dt, select=-", colnames(factor)[1], ")")
eval(parse(text=theText))

ly <- factor

svm_medel <- svm(x, y, type=svmType)

modelText <- paste("second.svm <- svm(", colnames(factor)[1], " ~ .,
eval(parse(text=modelText))

Number of output displays for this function: |:]

Step 8 of 10

Gsas



8% Configure Your Add-in - JMP Pro — O X

° Choose the output display format for each output.

Output 1 type: | Append Column in Existing Table v |

Output 2 type: | Open Table "7 | 8% Configure Your Add-in - JMP Pro - O X
Output 3 type: | Most Recent R Plot v | Provide the appropriate parameters for each output display.
Step 9 of 10 !
P El ~Column Append Arguments
Column name: IPredictions |
= o o Column type: | User's Choice v]
® 7 R Graphics: Device 2 (ACTIVI - .
Bile Histoyy Besize Our g o a/ 0 Name of R output variable (list) with values: Ipred |
SVM classification plot — "
~Table Argumen
Predictions R input/output variable (contains target table): |predT able |
negative
2 negative ~R Plot Arguments
B negative . a . [E
positive Graphics format (for most recently generated plot in R code):
. negative
: negative Lo
B Regative Step 10 of 10
s P
2 [ ] | "l'\ D v
g
g 3]
pred y Freq
1 negative negative 434
2 positive  negative 24
3 negative positive 12
mitoses 4 | positive  positive 229

Gsas



Now you can share your Add-In for others to install and use:

File Tables DOE Analyze Graph Tools | Add-Ins | View Window Help Get Started

RSN SR N - ! Subset of Demol Data Table Tools » |’”W( -

JMP Skin Lesion Analyzer

Recent Files
JMP to R Function Builder —

Filter (Ctri+F)

PAA
[l DemoData_BreastCancer,jmp SVM

Gsas



5
Lﬂ_,.p jmp.com/learn Ver 11/2019
Add-In Builder

°
Making an A -In
Use a JMP® Add-In to create custom menus and easily distribute JMP scripts, applications, data tables and more.

Create an Add-In with the Add-In Builder

[S s i e -

1. Choose File > New > Add-In (or File > New > New

Add-In Builder Add-In on the Mac).

2. Inthe General Information tab, provide an Add-in

Create custom menus and easily distribute JMP scripts, applications, data > Video Name and an Add-in ID.
tables and more. > One—page guide (PDF) 3. Inthe Menu Items tab, for each menu item: S =
¢ Click Add Command to add the menu item @ and
JMP FEATURES DEMONSTRATED: provide a menu item name @.
File > New > Add-In (or File > New > Add-In on the Mac) o Browse for the JSL script the menu item will run.
Or, copy and paste the script next to Run this JSL
Q.
* Click Add Submenu (if needed) and provide a
0 name to group items below a single heading, or

@ _JMP_File Edit_Tables Rows Cols DOE_Analyze Graph _Tools _Add-Ins _View Window _Help Add Separator to add a separating line @.

Visu 4. If desired, use the Start-Up Script, Exit Script, or Additional Files tabs to add other scripts, graphics or data
(Win{ . tables to the add-in.

e 5. Click Save ®. Edit the file name if desired (the Add-in ID
7 &+ (& L © 55 will default, with a .jmpaddin extension), and click Save.
[ o toms |

— S oART By default, the add-in will automatically install under the Add-in menu in JMP when saved. Test the menu items
or oach addn men tom, click °
and enter the details. to ensure that everything works as intended, and fine-tune as needed. The Add-in Builder will stay open until

Genera

Add Submenu | | Add Command | (X| ¢+ & o " . . N " N
v Menu item name  (Confidence you close it, and saved changes will override the previously installed version of the add-in.
¥ Teaching Scripts Tookip for merw Nem

Share the add-in with other users. When the file is opened in JMP, all files are extracted into the appropriate
G2 folder, and the add-in is installed in the JMP Add-in menu.

Confdence

© Run 5L this e [Uray Assicaion 599 pomse
un this 5

Tips and Limitations

¢ Todisable (remove from menu) or unregister (uninstall) an add-in, use View > Add-Ins.

(9 Use the “Here" namespace for unqualified SL variable names. e To edit an add-in use File > Open, then click the arrow next to Open and select Open ==
- Using Add-In Builder (on Mac, first click “Options” then check “Edit after opening”). Open

O oromse | [ rese * Tosave an application as an add-in, select Script > Save Script to Add-In from the [

Application Builder red triangle (saving an application as an add-in requires JMP 10 or higher).

Cancel

Note: For more information on developing and deploying add-ins, search for “Add-In” in the JMP Help or in the
JMP Scripting Guide (under Help > Books). Explore jmp.com/addins for available add-ins.

How-to-make-an-Add-In: https://www.imp.com/en us/learning-library/using-imp.html| Gsas



https://www.jmp.com/en_us/learning-library/using-jmp.html

Links in the JMP Help

- JMP Help and more examples:
www.jmp.com/support/help/en/15.1/#page/imp/extending-imp.shtm|

- JMP Help for the code generation:
http://www.jmp.com/support/help/en/15.1/#page/imp/formula-
depot.shtml

« Python installation and versioning:
https://www.jmp.com/support/help/en/15.1/#page/imp/install-
python.shtml and
http://www.jmp.com/support/help/en/15.1/#page/imp/troubleshooting-
the-jmp-python-integration.shtml

- Rinstallation and versioning can be found here:
http://www.jmp.com/support/help/en/15.1/#page/imp/installing-r.shtml
(R 3.3.3 or earlier for Mac OS:
https://www.imp.com/support/notes/61/841.html) Ssas
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- JMP with R and Python:
https://www.jmp.com/en us/whitepapers/imp/jmp-synergies-
using-jmp-and-jmp-pro-with-python-and-r.html

- SVM Add-In and JMP-to-R Add-In Builder:
https://community.jmp.com/t5/JMP-Add-Ins/The-JMP-to-R-Add-In-
Builder/ta-p/43879

« T-SNE and UMAP: https://community.jmp.com/t5/JMP-Add-
Ins/Data-visualization-with-t-SNE-and-UMAP/ta-p/177969

- How-to-make-an-Add-In: https://www.jmp.com/en us/learning-
library/using-imp.html

Gsas
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- Help with the R and Python commands in jsl: In JMP, go to Help >
Scripting Index

- Help with jsl: So many resources!
« WWW.imp.com > Learn JMP > Mastering JMP videos

« Training through SAS Education or free courses through your academic
JMP campus license (contact academic@jmp.com to get access)

« Ask and search questions in community.jmp.com

 https://community.jmp.com/t5/Mastering-JIMP/What-Resources-are-
available-to-learn-JSL-JMP-Scripting-Language/ta-p/23370

Gsas
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