Version 14

New Features in JMP 14

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust

JMP, A Business Unit of SAS
SAS Campus Drive
Cary, NC 27513
HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

• Telerik RadControls: Copyright © 2002-2012, Telerik. Usage of the included Telerik
RadControls outside of JMP is not permitted.

• ZLIB Compression Library - Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.

• Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.

• Packages - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

Neither the name of the WhiteBox nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• iODBC software - Copyright © 1995-2006, OpenLink Software Inc and Ke Jin
(www.iodbc.org). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:
- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

- Neither the name of OpenLink Software Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- bzip2, the associated library “libbzip2“, and all documentation, are Copyright © 1996-2010, Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.
- libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
- Neither the name of Florian Reuter nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
• libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar license but with different Copyright notices) all the files are:

Copyright © 1998 - 2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

• Regarding the decompression algorithm used for UNIX files:


The Regents of the University of California. All rights reserved.

This software is provided by the Regents and contributors “as is” and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimed. In no event shall the Regents or contributors be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

• Snowball - Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:

• live and recorded webcasts about how to get started with JMP
• video demos and webcasts of new features and advanced techniques
• details on registering for JMP training
• schedules for seminars being held in your area
• success stories showing how others use JMP
• a blog with tips, tricks, and stories from JMP staff
• a forum to discuss JMP with other users

http://www.jmp.com/getstarted/
## Contents

New Features in JMP 14

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Enhancements</td>
<td>13</td>
</tr>
<tr>
<td>Applications and Dashboards</td>
<td>14</td>
</tr>
<tr>
<td>Data Filter</td>
<td>15</td>
</tr>
<tr>
<td>Data Tables</td>
<td>15</td>
</tr>
<tr>
<td>Databases</td>
<td>16</td>
</tr>
<tr>
<td>Formula Editor</td>
<td>17</td>
</tr>
<tr>
<td>Hover Labels</td>
<td>17</td>
</tr>
<tr>
<td>Importing and Exporting Data</td>
<td>17</td>
</tr>
<tr>
<td>Interactive HTML</td>
<td>18</td>
</tr>
<tr>
<td>Journals</td>
<td>18</td>
</tr>
<tr>
<td>Macintosh</td>
<td>18</td>
</tr>
<tr>
<td>Preferences</td>
<td>19</td>
</tr>
<tr>
<td>Projects</td>
<td>19</td>
</tr>
<tr>
<td>Query Builder</td>
<td>19</td>
</tr>
<tr>
<td>Recode</td>
<td>19</td>
</tr>
<tr>
<td>Reports</td>
<td>20</td>
</tr>
<tr>
<td>Samples</td>
<td>20</td>
</tr>
<tr>
<td>Transform Columns</td>
<td>21</td>
</tr>
<tr>
<td>Windows Automation</td>
<td>22</td>
</tr>
<tr>
<td>Basic Analysis</td>
<td>22</td>
</tr>
<tr>
<td>Bivariate</td>
<td>22</td>
</tr>
<tr>
<td>Distribution</td>
<td>23</td>
</tr>
<tr>
<td>Oneway</td>
<td>23</td>
</tr>
<tr>
<td>Tabulate</td>
<td>23</td>
</tr>
<tr>
<td>Text Explorer</td>
<td>23</td>
</tr>
<tr>
<td>Graphing</td>
<td>24</td>
</tr>
<tr>
<td>Bubble Plot</td>
<td>24</td>
</tr>
<tr>
<td>Graph Builder</td>
<td>25</td>
</tr>
<tr>
<td>Profilers</td>
<td>27</td>
</tr>
<tr>
<td>DOE</td>
<td>27</td>
</tr>
<tr>
<td>Accelerated Life Testing</td>
<td>27</td>
</tr>
<tr>
<td>Balanced Incomplete Block Design</td>
<td>28</td>
</tr>
</tbody>
</table>
Choice Designs ................................................................. 28
Custom Designs ............................................................... 28
Definitive Screening Designs ............................................ 28
Full Factorial Designs ...................................................... 28
MaxDiff Designs ............................................................. 28
Taguchi Designs ............................................................. 29
Fitting Linear Models ...................................................... 29
  Fit Model ................................................................. 29
  Generalized Linear Models ........................................... 29
  Generalized Regression ............................................... 29
  Mixed Model ........................................................... 30
  Nominal and Ordinal Logistic ........................................ 31
  REML ................................................................. 31
  Standard Least Squares ............................................. 31
  Stepwise ................................................................. 32
Predictive and Specialized Modeling ................................. 32
  Association Analysis .................................................. 32
  Bootstrap Forest ....................................................... 33
  Explore Missing Values .............................................. 33
  Explore Outliers ...................................................... 33
  Formula Depot ......................................................... 33
  Functional Data Explorer ............................................ 33
  K Nearest Neighbors .................................................. 33
  Naive Bayes ........................................................... 34
  Nonlinear Curve ....................................................... 34
  Predictor Screening .................................................... 34
  Process Screening ..................................................... 34
  Response Screening ................................................... 35
Multivariate Methods .................................................... 35
  Factor Analysis ........................................................ 35
  K Means Clustering .................................................... 36
  Latent Class Analysis ................................................ 36
  Normal Mixtures ...................................................... 36
  Principal Components ............................................... 37
Quality and Process Platforms ........................................ 37
  Control Chart Builder ................................................ 37
  CUSUM Control Charts ............................................. 37
  Manage Spec Limits .................................................. 38
  Process Capability ..................................................... 38
  Variability/Attribute Gauge Chart ................................. 38
Reliability and Survival ................................................................. 38
Cumulative Damage ................................................................. 39
Fit Life by X ................................................................. 39
Life Distribution ................................................................. 39
Parametric Survival ................................................................. 39
Recurrence Analysis ................................................................. 40
Repairable Systems Simulation .................................................. 40
Consumer Research ................................................................. 40
Categorical ................................................................. 40
Choice ................................................................. 40
Multiple Factor Analysis ................................................................. 41
Scripting ................................................................. 41
New Commands ................................................................. 41
General Enhancements ................................................................. 45
Application Builder ................................................................. 46
JMP 14 provides many bug fixes and feature enhancements.

New analysis platforms include the following:

- Functional Data Explorer
- Balanced Incomplete Block Designs
- CUSUM Control Charts
- Multiple Factor Analysis
- Process History Explorer

This document provides highlights of these platforms and other new features.

indicates features that are available only in JMP Pro.

General Enhancements

This section describes basic enhancements to JMP on Windows and Macintosh. For details, see the Using JMP book.

- The new JMP Trial is a 30-day trial based on standard JMP. The trial features the full functionality of standard JMP along with tips that are written for new users. Download the trial from [https://www.jmp.com/en_us/software/download-jmp-free-trial.html](https://www.jmp.com/en_us/software/download-jmp-free-trial.html).

JMP Help is included. However, the documentation PDF files in the Help > Books menu are omitted. You can download them from [https://www.jmp.com/en_us/support/jmp-documentation.html](https://www.jmp.com/en_us/support/jmp-documentation.html).

- To save a report to the data table, select Save Script > To Data Table from the report’s red triangle menu.

- On Windows, pressing Shift + Ctrl + E enables you to hide and exclude a row.

- The Create Web Report menu option has been moved to the File menu. It is now called “Publish“.

- On Windows, “SQLite Database“ is now an option when you select File > Open. SQL 3 or higher versions are supported.
• The Cols > Use for Marker option lets you specify a column of images, character, or numeric data to use as markers on graphs. If you use a character or numeric column as the marker, the data value is used for the marker.

• On Windows, you can close a report thumbnail in the data table by pressing the middle-click button on your mouse. You can also press the middle-click button to close closeable tabs on Windows.

• Layouts are deprecated. Create journals instead.

• You can change the numeric formatting for columns in a report table by right-clicking and selecting Format Column. The option now lets you change the formatting for multiple columns.

• You can right-click a table in a report and select Select Where to choose a condition on a numeric column.

• After you download an application, dashboard, project, or journal, you are prompted to open the file.

• Platform preferences for Automatic Recalc are available in Distribution, Bivariate, Oneway, Fit Y by X, Variability, and other platforms that support Auto Recalc.

• You can specify a custom format for an axis using the Formula Editor or in the Column Info window for the data table. For example, the unit of measure can be displayed after each number. Select Custom from the Format menu in the Column Info window and then click Set Custom Format.

• The Excel Profiler includes a preference for using the first row as a column name.

• You can determine whether there is a pattern to the missing data in a data table by selecting Tables > Missing Data Pattern and then selecting Add Value Colors Property.

• Record and save options in Local Data Filter, Bubble Plot, and Column Switcher enable you to record the animation and save it as an animated GIF. The option is available only on Windows.

• In launch windows, you can filter columns by selecting Show Filter from the Select Columns list red triangle menu and then entering a search string. This search option is also in the Home Window, Formula Editor, Query Builder, Text Explorer, Scripting Index, and Preferences.

• You can edit many properties of display boxes, including numeric formats, by right-clicking the report’s disclosure icon and selecting Edit > Show Properties.

• You can copy and paste an image into a Expression picture column.

**Applications and Dashboards**

This section describes new features and enhancements in dashboards. For details about applications, see the *Scripting Guide*. For details about dashboards, see the *Using JMP* book.
• You can select the object for a platform in a dashboard or application and edit the script for that platform. Right-click the object and select **Edit Platform Script**.

• The graphs or reports in a dashboard can be created from multiple data tables. The data table used for the first graph on the dashboard is considered the current data table by default. This gives the user the flexibility to use any current data table to create the graph or report. The dashboard author can also hard-code the path. Specifying the name gives the dashboard author control over which data table is used. Select the option when you add the second graph to the dashboard.

### Data Filter

• The **Local Data Filter** option is available in the main red triangle menu to provide more visibility.

• The **Conditional** red triangle menu option enables you to filter columns that have a hierarchy.

• The counts for each level of a variable (including excluded rows) are shown in the Local Data Filter by default. To omit the excluded rows from the count, deselect **Count Excluded Rows** in the Local Data Filter red triangle menu.

### Data Tables

• **Multiple File Import (MFI)** is designed to import multiple data, image, and unstructured text files from one directory and stack them in a data table (or to import them in separate data tables). You can save the import options as a script and then run the script when the data is updated in the future. Select **File > Import Multiple Files** to get started.

• You can add hyperlinks to a text column to provide more information about the data. For example, you could link geographical data to a Google map, or you might want to include a link to a Wikipedia page. Add the Event Handler column property to a column of URL to convert them to hyperlinks, or modify the Event Handler scripts to provide other functionality.

• When you select one data table cell and paste several lines of data, each line is pasted into its own cell. To paste all lines into one cell, right-click and select **Paste into Cell**. Before pasting, you no longer have to select the same number of rows and columns as represented by the data that you are pasting.

• When row states change in one data table that has a virtually joined column, those row states can automatically show up in virtually joined columns in other linked data tables. Specify Row State Synchronization options in the Link Reference column property.

• To be prompted to save a linked summary table when you close it, select **Prompt to save when closing summary tables** in the Summary window.
- The Text to Columns utility lets you specify newline and tab characters as delimiters. Newline includes \r (return character), \n (newline character), and \r\n (return and newline characters).
- To select rows that have duplicate values, select **Rows > Row Selection > Select Duplicate Rows**.
- To create a group of selected scripts, right-click the scripts in the Table panel and select **Group Scripts**.
- When a column contains missing values, you can replace those values with the value in the preceding cell. Select a block of cells that contain the missing and replacement values. Right-click and select **Fill > Replace Missing with Previous Value**.
- You can select a cell in a row state column and then select all cells that contain the selected cell’s attributes. Right-click the cell whose attributes you want to match and select **Select Matching Cells**.
- The Value Labels column property is added to the Match Flag column when you join data tables. “Main” indicates that the data originated from the first (active) table. “With” indicates that the data originated from the second table. “Both” indicates that the data was found in both the first and second tables.
- In Virtual Join, you can specify that the linked column name be used in virtually joined tables that are shown in the Columns list. This option lets you specify a shorter column name (for example, Sex instead of Sex[Subject Identifier]). In the Link Reference column property, select **Use Linked Column Name**. In a script, set the Link Reference column property and then include **Options( "Use Linked Column Name" )**.
- The Cols > Utilities menu provides two new conversion options. **Labels to Codes** turns character data into nominal one-byte integers and puts the original values in the Value Labels column property. **Codes to Labels** does the reverse.
- Downloaded tables, journals, and scripts might be quarantined, which shows a prompt when you open them. See “**Scripting**” on page 41 for details about JSL methods for controlling the behavior.
- When you right-click in a report and select Make into Data Table or Make Combined Data Table, the resulting data table includes a script for recreating the data table that the report came from.
- When the summary table has a Group variable, the summary table is named after the Group variable. If the variable name contains characters that are not allowed in file names, a hyphen is substituted for the character.

**Databases**

- In data imported from a database, the y/m/d format is assigned to date/time data in Japanese JMP.
Formula Editor

- You can customize the Functions list to rearrange categories, rearrange functions, add favorites, and more.
- Right-click a function in the Functions list or in a formula and select **Show in Scripting Index** to read about the function in the Scripting Index and to see an example.
- You can standardize attributes to replicate a column formula while incrementing each column reference in the formula.
- The right-click menu for the Columns list has two replacement options: **Replace all occurrences of selected subexpression** replaces all occurrences of the selected expression with the currently selected column. **Replace the selected subexpression with columns** replaces the selected expression with multiple columns (formerly Shift + Click) for functions that support it (for example, Sum or Plus).
- You can customize the Functions list to make it easier to find the functions that you typically work with. The functions appear at the top of the list.
- To create a table variable from a value in the Formula Editor, right-click the value and select **Create Table Variable from Value**. To create a local variable from an expression, right-click the expression and select **Create Local Variable from Expression**.
- When you turn off formula evaluation, edit a formula, and click **Apply**, you are prompted for whether to evaluate the formula. To allow formula evaluation once, click **Evaluate formula this time**.

Hover Labels

- When you use the Overlay drop zone to generate range and interval Bar charts, the hover label shows both the minimum and maximum values.
- The hover labels for a Line chart show the image that is defined in the data table Expression column.
- To change the text on a pinned hover label, right-click and select **Replace Text**.
- Box plots have hover labels.
- Hover labels are supported in Graph Builder and Distribution platform histograms.

Importing and Exporting Data

- When you select File > Open to import a SAS data set, you can click the arrow on the Open button and click **Select columns** to select the columns to import.
- To import XML as text, select **Text Files** next to the Open window’s File Name field and then select **Plain text into Script window**.
Select **File > Multiple File Import** to automatically import and stack similar files from a directory.

On Windows, the Create Excel Workbook option has been moved to the File menu. On Macintosh, it is an option in the File > Export window’s Excel list.

When you export a report as HTML, the font sizes and colors are preserved.

### Interactive HTML

- Data filters are supported in most browsers except for Internet Explorer and Edge. Note that exclude is not supported and statistics for groups are not recalculated.
- Support for images in hover labels was added for Bubble Plot and Graph Builder line, heatmap, and map elements.
- Treemaps are exported from Graph Builder.
- Histogram hover labels contain more information.
- In Graph Builder stacked area charts, the Missing Factors options are supported.
- Label column values are displayed on hover labels in bar charts.

### Journals

- To edit several links in an outline, right-click the outline and select **Edit Links**.

### Macintosh

- The JMP Home window has been redesigned to add and streamline features. For example, a new way to add favorites, close open windows, and search for recently opened files or opened data tables and reports are new features. More file types are in the Recent Files list. You can toggle the layout so that the Recent Files and Windows lists are horizontally displayed. Files that are unreachable are dimmed, including files that have been deleted or are on an unreachable volume.
- You can copy a file from JMP Home window’s Recent Files list to another document or into the Finder. Select the file in the Recent Files list and then select **Edit > Copy**.
- A button for saving a report’s script to the data table has been added to the toolbar.
- In the JMP Home window, hold the Option or Alt key while selecting a data table from the Active Data Tables list. This activates the data table without bringing it to the front.
- To be able to quickly view the JMP Home window from any JMP window, right-click the window, select **Customize Toolbar**, and drag the JMP Home icon to the toolbar.
- Save a report as PDF with no headers or footers by selecting **File > Export > Image > PDF**.
Preferences

- You can search for preferences. Enter a search term in the Filter box in the upper left corner of the Preferences window.
- In multiple comparison tests, you can permanently hide the Comparison Circles plot. Select File > Preferences > Platforms > Oneway and deselect the Comparison Circles option. The option is deselected by default.
- The Automatic Recalc preference has been added to several platforms that support it, including Distribution, Bivariate, Oneway, Fit Y by X, and Variability. The option is deselected by default.
- The Reports preference Transparent background in report PNG images determines whether reports that are saved as PNG images have transparent backgrounds. The option is deselected by default.

Projects

- Projects have been completely redesigned. In a project, you can gather files related to a specific analysis. After you perform an analysis, the graph and report appear in the project on tabs. You can display multiple reports or graphs, display the log, and run scripts from the project. You can also move open windows to a new or existing project. Reports and graphs remain linked to the data table.

Query Builder

- When a query contains eight tables or more, a search box appears above the table names near the upper left corner of the Query Builder window.

Recode

- The right-click option Group to new value enables you to specify a new value for the selected data.
- The Remove Punctuation red triangle menu item removes special characters (such as quotation marks and ampersands) from the beginning, middle, and end of words.
- If the data table contains value labels, the labels appear in a column in the Recode window called New Labels. Editing the labels also modifies the Value Labels column property. You can also select Replace values with value labels to modify the data in the New Values column.
- When you recode into a new column, the column is added after the selected column.
- Multiple responses can be recoded.
• The Replace String red triangle menu item replaces all occurrences of specified characters with a new string or with nothing.

• The Import from Recode Result Column red triangle menu option imports data from the column that you select, usually the column in which you saved previous recode results.

• When you recode a column, select **Publish to Formula Depot** from the red triangle menu to reuse the recode script in other scripts.

• The **Add value labels** red triangle menu option enables you to assign value labels to each value.

• The **Split on** red triangle menu option enables you to specify the word delimiter to split on.

• Regular expressions are supported in the Filter box and in the Replace String red triangle option.

### Reports

• You can change the numeric format of all columns in a report through the Show Properties pane. Right-click the column and select **Show Properties**. Select the columns and then select an option from the Select list in the Properties pane.

• To copy text from a text box onto the clipboard, right-click the text and select **Copy Text**. To copy text from one column onto the clipboard, right-click the column and select **Copy Column**. To copy an entire table onto the clipboard, right-click the table and select **Copy Table**.

### Samples

• Sample projects to demonstrate new projects features are available in the Samples/Projects folder.

• **Weekly Weather Data.jmp**, **Fermentation Process.jmp**, **Fermentation Process Batch Yield Results.jmp**, and **Fermentation Process Row Functions.jmp** demonstrate the new Functional Data Explorer platform.

• In **Big Class Families.jmp**, the Use for Marker column characteristic was added to the Picture column. A script illustrates using pictures for markers.

• **Semiconductor Capability.jmp** was cleaned up. For example, the decimal points in spec limits were rounded down.

• **SAS Offices.jmp** illustrates how to create hyperlinks in columns.

• Inspired by the classical Anscombe’s Quartet and its most recent revision, the “Datasaur Dozen”, the **JMP Man Dozen.jmp** sample data table illustrates the importance of using data visualization alongside calculations by displaying a set of visually distinct datasets with the same summary statistical (mean, standard deviation, and correlation).
• The Microsoft Excel version of Restaurant Tips.jmp was added to the Samples/Import Data folder.

• Engine Temperature Sensor.jmp demonstrates the new CUSUM Control Chart platform.

• Vial Fill Weights.jmp demonstrates three-way control charts.

• Wine Sensory Data.jmp demonstrates the Multiple Factor Analysis platform.

• Lot Wafer Yield.jmp and Lot Wafer History.jmp demonstrate the Process History Explorer platform.

• Malaria import data are available to demonstrate the Multiple File Import feature: UN Malaria 2009.csv, UN Malaria 2010.csv, UN Malaria 2011.csv, and UN Malaria 2012.csv.

• One Factor Logistic Design.jmp helps illustrate how to create a binomial design in the Design of Experiments Guide.

• NIC Demographics.jmp, NIC Labs.jmp, and NIC Adverse Events.jmp demonstrate how to show row states in data tables with virtually joined columns. Run the Patient Safety Dashboard script in Nic Demographics.jmp to create a dashboard from these data.

• The TestTwoSampleMeans.jsl sample script in Samples > Calculators has a new input method called “Two Samples in Two Columns”. You are prompted to assign two columns after which the data is stacked for you.

• The interactive demos have been updated. You can find these demos by selecting Help > Sample Data and opening the Teaching Scripts outline.

### Transform Columns

• Pairwise transform options are available when the number of selected columns is even and greater than or equal to four.

• Standard Deviation, Geometric Mean, Median, and Quantile have been added to the Combine transform menu.

• Titlecase, Uppercase, and Lowercase have been added to the Character menu.

• When you use transforms to combine several columns, the column names are limited to 30 characters.

• A new transform column is placed immediately after the column being transformed. Previously, it was placed at the end of the columns.

• New transforms for vector data were added.

• The Round option in the Transform menu was added to round numbers.

• The Rank option has been added to the Character menu. Rank returns the rank, ranging from 1 as the lowest, with row-order tie breaking.

• Scale Offset and Log x+1 transforms were added to the Transform menu.
• Normal Quantile and Cumulative Probably transforms were added to the Distributional menu.

**Windows Automation**

The *Automation Reference* in the JMP installation’s Documentation folder provides details about the new automation methods:

• **Normal Mixtures:**
  This automation platform is new to JMP 14.0 and replaces the old KMNormalMixtures method in the Cluster platform.

• **After K Means was separated from Normal Mixtures Clustering, the automation framework for Normal Mixtures no longer works. Normal Mixtures is no longer an option available under K Means but is a stand-alone platform.**

• **Automation methods available to KMNormalMixtures include the following:**
  LaunchAddY, LaunchAddFreq, LaunchAddWeight, LaunchAddBy, SpecifyNClusters(NClusters as Integer), SpecifyNTours(NTours as Integer), SpecifyMaximumIterations(MaxIterations as Integer), SpecifyConvergeCriterion(Criterion as Double), Go(), Biplot, Biplot3D, ParallelCoordinatePlot, ScatterPlotMatrix(Flag as Boolean), SaveColorsToTable, SaveClusterFormula, SaveMixtureFormulas, SaveMixtureProbabilities, SaveDensityFormula(), PublishClusterFormulas(), SimulateClusters(NRows as Integer), BiplotContourDensity(Density as Double).

• **Document:**
  CreateNormalMixtures() As NormalMixtures

• **Cluster:**
  KMNormalMixtures(FlagAsBoolean)

---

**Basic Analysis**

This section describes new features and enhancements in the general analysis platforms. For details, see the *Basic Analysis* book.

**Bivariate**

• You can now save studentized residuals to the data table.

• The Show Summary Statistics red triangle option shows the summary statistics for the plot, such as the correlation and confidence intervals, mean, and standard deviation.
• Lines of equality are not shown when the slope is constrained to 1.
• For nonparametric density contours, you can now change the colors of the contour lines, including selecting a color theme for the lines.

**Distribution**

• The sinh-arcsinh (SHASH) distribution has been added to the Continuous Fit menu. This is a flexible transformation to normality.
• When fitting a distribution, the AICc and BIC values are now added to the fitted distribution report.
• To specify the number of decimal places to show in percent counts next to histogram bars, right-click the histogram, select **Customize > Histogram**, and then specify a value for the Percent Label Dec option.
• The Units column property is supported in histograms and capability animations.
• When you specify a tolerance interval, you can select a normal or nonparametric distribution.
• The Proportion Zero and Proportion Nonzero summary statistics are available. Proportion Zero is the proportion of nonmissing values that are equal to zero. Proportion Nonzero is the proportion of nonmissing values that are not equal to zero.

**Oneway**

• The Friedman Rank Test option has been added to the Nonparametric red triangle menu. The Friedman Rank scores are the ranks of the data within each level of the blocking variable.
• The “Each Step Pairwise, Newman-Keuls” option has been added to the Compare Means red triangle menu. In the Newman-Keuls report, the Smallest Quantile Considered is the quantile of the last Tukey’s HSD test that was performed.

**Tabulate**

• A Tabulate script references all of the data tables created with the Tabulate command.

**Text Explorer**

• For nominal columns, the Score Terms by Column red triangle menu item creates a scoring column for each level of the nominal column. A Treemap script is placed into the Term table to create a Treemap for each level.
- The Display Options red triangle menu now includes a Show Filters for All Tables option. This option shows or hides filters that can be used for searching tables in the report. It applies to the following tables: Stop Words, Specified Phrases, Stem Exceptions, Term List, Phrase List, and the Stem Report.

- When you paste text from a script to a document that supports Rich Text Form (RTF), such as Microsoft Word, the syntax colors are preserved in the Show Text window. The background colors from a Text Explorer script are also preserved.

- In the Regular Expression Editor, you can click + to add a blank regular expression.

- The Latent Semantic Analysis (SVD) report is analogous to the Principal Components platform report. The Topic Analysis report is analogous to a rotated Principal Components report.

- The outline nodes for SVD and Topic Analysis reports contain information about the specifications used to calculate the analysis.

- Text Explorer supports Japanese, Chinese (Simplified), and Chinese (Traditional) as Language options.

- The Latent Class Analysis and Topic Analysis reports now contain options to create separate word clouds for each latent class or topic.

- To remove a phrase from the Term List, right-click the phrase and select Remove Phrase.

- You can now specify a Validation column in Text Explorer launch window.

- Discriminant Analysis on the document-term matrix is available from within the Text Explorer report window.

- The Text Explorer analysis options have been reorganized. Topic Analysis is now available from the SVD red triangle menu after you request Latent Semantic Analysis (SVD).

### Graphing

This section describes new features and enhancements in the graphing platforms. For details, see the Essential Graphing book.

- To broadcast the axis options to multiple graphs, hold down the Ctrl key when you right-click the axis and select Edit > Paste Axis Settings.

- To change the marker size, you can right-click the legend and select Marker Size.

### Bubble Plot

- Images now appear in hover labels in cases where a bubble represents a single row of data.
Graph Builder

- Packed bar charts are available. A hybrid of a bar chart and treemap, packed bar charts are best suited for high cardinality data (over 100 categories) with skewed response data (counts or values). The chart shows the top categories as a bar chart and stacks the other categories as bars on top of those with an approximately rectangular fill. Select Packed from the Bar Style list in the Bar options.
- If you specify both an Overlay and a Color variable, the Color variable now overrides the color from the Overlay variable.
- To undo recent changes to a legend, click Undo.
- Jitter options have been added to the Points element: Auto, Random Uniform, Random Normal, Centered, Centered Grid, and Positive Grid. You can also specify the jitter limit (the amount of overlap or spread).
- You can now add more than five elements from the pop-up menu.
- For continuous variables in the Group X or Group Y zones, you can now sort in ascending or descending order.
- For multiple violin plots, you can now choose different scaling options.
- When variables are nested, sort order is now accounted for in the graph.
- You can now apply variables in the Overlay zone on an element-by-element basis.
- When using several Caption Boxes, the text no longer overlaps.
- For caption boxes, you can now choose which axis to specify as the response.
- You can add multiple statistics to a graph using caption boxes.
- For caption boxes, you can show a caption for multiple Xs or Ys.
- For box plots and caption boxes, you can add a five number summary to the graph that shows values like the median, maximum, minimum, and 1st and 3rd quantiles.
- Maps for regions in France have been updated to reflect the change to 13 regions.
- You can now maintain the aspect ratio when auto-stretching a graph.
- Change the font in a Graph Builder legend by selecting **Legend Settings** from the red triangle menu and clicking Font.
- Options for changing the size of error bars are available through the right-click Customize option.
- To use a column for error bars, assign it to the Interval role. You can also customize the error bars using this role (for example, specify the upper and lower limits for each error bar).
- Two-way error bars are supported. The data must be in a specific form. There should be six Y variables that describe the error bars: xmin, x, xmax, ymin, y, and ymax.
• You can hide the title above the graph by right-clicking and selecting **Hide**.
• Interquartile Range for the mean or median has been added as an Error Bars option.
• Missing Values in the line chart options enables you to specify how missing values are connected.
• A footnote below the graph shows how many rows are excluded.
• The Factor Width option in the right-click Customize > Bar options enables you to specify the size of bars and therefore the space between bars. 1.0 leaves no gap between bars.
• An option to control the smoothness of contours has been added to the Contour options.
• Labels can be displayed on a heatmap. Right-click the heatmap, select Label, and then select the type of label.
• Confidence of fit is now an option for the smoother.
• Select **Show Subtitle** from the Graph Builder red triangle menu to show a placeholder for the subtitle. You can then right-click the subtitle and change the alignment or span.
• Select **Show Title** from the Graph Builder red triangle menu to hide or show the title. You can also right-click the title and change the alignment or span.
• For many types of plots, clicking labels in the legend selects the associated points.
• For ellipses, you can now also show the Pearson’s correlation coefficient in the graph.
• In the Legend Settings window, you can select or deselect all check boxes. Right-click and select **Toggle check box**.
• You can create a dot plot by setting the Jitter option in a Points plot to Positive Grid.
• For histograms, you can now add a one-sample t test or a confidence interval for the mean to the graph. You can also list means and standard deviations in the graph. First and third quartiles are supported for bar charts.
• For mosaic plots, you can add a Pearson chi-square test, and label the cells with counts, percentages, and more.
• Graph contents can be clipped to conform to the natural boundaries of a given polygon. Right-click the graph, select **Customize**, select the display seg that you want to clip, and then select the boundary.
• The Chi-Square Test option has been added to the Mosaic Plot.
• The T Test for Mean At and Confid Percent options have been added to histograms.
• When there are multiple variables in a zone, new Combine Scaled right-click menu items lets you control how the variables are combines. Parallel Merged is for parallel coordinates with a shared scale. Parallel Independent is for parallel coordinates with independent scales.
• Univariate elements now support the parallel axis modes (Points, Contour, Box Plot, and Histogram).
Profilers

This section describes new features and enhancements in the Profiler platforms. For details, see the Profilers book.

- In the Factor Settings red triangle menu, the Broadcast Factor Settings option sends the current profiler’s factor settings to all other profilers. The profilers are unlinked.
- The Show Creator red triangle menu options shows or hides the name of the platform that created the formula in the response column. The platform name appears on the vertical axis.
- In the simulator in the Standard Least Squares platform, Random by Model adds an error term to the generated response based on the model distribution specified in the launch window. In Generalized Regression, Random by Model simulates a response from the fitted model.

DOE

This section describes new features and enhancements in the DOE platforms. For details, see the Design of Experiments Guide.

- Saving factors, restraints, and responses now returns a reference to the data table that is created.
- You can now create a data table with the values from the Color Map on Correlations. Select Table of Correlations from the Color Map on Correlations red triangle menu.
- The Fraction of Design Space Plot take into account disallowed combinations.
- When the profiler is used to profile the variance, the Maximize Desirability red triangle menu item is now named Maximize Variance.

Accelerated Life Testing

- Design optimality criteria labels have changed. Options are now D-Optimal, Quantile Estimate Optimal, and Failure Probability Optimal. The default criterion is now Quantile Estimate Optimal.
- A simple simulator to simulate responses for the design has been added to judge the appropriateness of the design.
- For a design with one accelerating factor, you can specify a quantile instead of the intercept under Prior Mean.
- R Precision Factor (95% CI) profiler has been added.
**Balanced Incomplete Block Design**

- A Balanced Incomplete Block Design (BIBD) is a design with one categorical treatment variable and one blocking factor. BIBDs are commonly used in marketing and agricultural applications. Pairs of treatments occur equally often within a block.

**Choice Designs**

- Choice designs support simulated responses.

**Custom Designs**

- In the Data Table Options, the Include Run Order Column option adds a column to the design data table that corresponds to the design order in the Design outline. Select **Include Run Order Column** when you save your data with a sorted run order. This provides a column of the randomized run order from the design outline.
- JMP has enhanced its ability to reconcile inconsistencies among load type, modeling type, and design role when loading factors.
- You can create A-optimal designs. From the red triangle menu, select **Optimality Criterion > Make A-Optimal Design**.
- After you create design, the buttons are disabled in the Model and Alias Term outlines to make it clear that you cannot change the options at that point.

**Definitive Screening Designs**

- The Save X Matrix red triangle menu option saves the design matrix (also known as the X matrix) as a data table property in the design data table.
- Fit Definitive Screening now has the option to consider quadratic effects and interactions that do not obey effect heredity.

**Full Factorial Designs**

- The same model effects are defined in both the design table and the Fit Model script.

**MaxDiff Designs**

- The Pairwise Incidence Matrix provides a matrix of the number of choice sets in which each pair of treatments appear together. The diagonal of the matrix is the number of choice sets each treatment appears in.
Taguchi Designs

- The Response Limits property is added to the Mean column in a Taguchi design data table.

Fitting Linear Models

This section describes new features and enhancements in the Fit Model personalities. For details, see the *Fitting Linear Models* book.

Fit Model

- In the Macros list, the Grouped Regressors option creates a single effect for up to 10 continuous factors that are treated as one effect in various parts of the report. You can add or remove the grouped effect in the Effect Summary.

Generalized Linear Models

- A $p$-value column has been added to the Variance Components Report in REML.

Generalized Regression

- Ordinal logistic regression is now available. This enables you to fit logistic regression models for ordinal responses.
- Multinomial regression is now available. This enables you to fit logistic regression models for nominal responses that contain more than two levels.
- The following estimation methods have been added: backward elimination, pruned forward selection, best subset regression, and the Dantzig selector.
- The Reset Solution button next to the Solution Path plot enables you to return to the original solution in the path.
- You can now save the linear predictor from a fitted model to a column in the data table.
- When applicable, the model details report now contains the root mean square error (RMSE), the adjusted $R^2$, and the value of the tuning parameter for the $l_1$ penalty.
- You can now use a Validation column with the Two Stage Forward Selection estimation method.
- Censoring is now supported for the Gamma and Exponential response distributions.
- If you use “Survived” or “Survive” as right-censor codes, the Censor Code list on the launch window recognizes them as options.
• Some default behaviors have been changed. The default Estimation Method for observational data is the Lasso. If the data table contains a DOE script and no singularities, the default Estimation Method is Forward Selection with the Effect Heredity option enabled. If the data table contains a DOE script and a singularity in the design matrix, the default Estimation Method is Two-Stage Forward Selection with the Effect Heredity option enabled.

• Proportional hazard models have new save options. You can now save the survival formula, the Cox-Snell residual formula, and the Martingale residual formula.

• You can perform a test of a custom hypothesis for fitted models.

• For a continuous response, the Regression Plot report appears only when there is one continuous predictor and no more than one categorical predictor. It is not available if the Distribution option is set to Multinomial, Ordinal Logistic, or Cox Proportional Hazards. The response must be continuous.

• For least squares models without censoring, you can now produce a normal quantile plot and save hat statistics and Cook’s D to the data table.

• The All Pairwise Comparisons report now includes the All Pairwise Connecting Letters red triangle menu option, which shows a report that illustrates significant and non-significant comparisons with connecting letters. The Save Connecting Letters red triangle menu option creates a data table whose columns contain the levels of the effect.

• An option to view the Least Squares Means plot has been added to the Multiple Comparisons red triangle menu.

• In the Pairwise Comparisons Scatterplot, the Show Reference Lines red triangle menu option shows reference grid lines for the points on the scatterplot.

Mixed Model

• The Compare Slopes red triangle option produces a report that enables you to compare the slopes of each level of the interaction effect in an analysis of covariance (ANCOVA) model. The option is available only when there is one nominal term, one continuous term, and their interaction effect for the fixed effects.

• The All Pairwise Comparisons report now includes the All Pairwise Connecting Letters red triangle menu option, which shows a report that illustrates significant and non-significant comparisons with connecting letters. The Save Connecting Letters red triangle menu option creates a data table whose columns contain the levels of the effect.

• An option to view the Least Squares Means plot has been added to the Multiple Comparisons red triangle menu.

• In the Pairwise Comparisons Scatterplot, the Show Reference Lines red triangle menu option shows reference grid lines for the points on the scatterplot.
• In Fit Mixed, you can now compare the least square means of groups at specified values of the covariate in an analysis. Select the **Multiple Comparisons** red triangle menu and then enter the estimates.

**Nominal and Ordinal Logistic**

• In Nominal Logistic, if the response is nominal and has a Profit Matrix column property, a Decision Matrix report also appears when the Confusion Matrix option is selected.

**REML**

• The All Pairwise Comparisons report now includes the All Pairwise Connecting Letters red triangle menu option, which shows a report that illustrates significant and non-significant comparisons with connecting letters. The Save Connecting Letters red triangle menu option creates a data table whose columns contain the levels of the effect.
• An option to view the Least Squares Means plot has been added to the Multiple Comparisons red triangle menu.
• In the Pairwise Comparisons Scatterplot, the Show Reference Lines red triangle menu option shows reference grid lines for the points on the scatterplot.
• You can now compare the least square means of groups at specified values of the covariate in an analysis. Select **Estimates > Multiple Comparisons**.

**Standard Least Squares**

• The Multiple Comparisons feature is now available for REML models.
• The All Pairwise Comparisons report now includes the All Pairwise Connecting Letters red triangle menu option, which shows a report that illustrates significant and non-significant comparisons with connecting letters. The Save Connecting Letters red triangle menu option creates a data table whose columns contain the levels of the effect.
• In the Pairwise Comparisons Scatterplot, the Show Reference Lines red triangle menu option shows reference grid lines for the points on the scatterplot.
• In the Least Squares Means Estimates report or a User-Defined Estimates report, the Arithmetic Means Estimate columns shows an estimate of the arithmetic mean for each group.
• An option to view the Least Squares Means plot has been added to the Multiple Comparisons red triangle menu.
• When there’s a singularity in a least squares model, the Singularity Details report is shown. The details are now easier to extract using JSL or the right-click Make Into Data Table option.
• The new Plot Residuals by Normal Quantiles shows a Residual Normal Quantile Plot. The residual values are plotted against quantiles of the normal distribution. This plot can help you assess the assumption of normality of the residuals.

• The Press Rsquare statistic has been added to the Press report. Press Rsquare is defined as $1 - \frac{Press}{SS_{Total}}$.

• The Compare Slopes red triangle option produces a report that enables you to compare the slopes of each level of the interaction effect in an analysis of covariance (ANCOVA) model. The option is available only when there is one nominal term, one continuous term, and their interaction effect for the fixed effects.

• The Least Squares Means plots in the Effect Details reports have been updated to provide more display options. The update also includes more options for interaction plots.

**Stepwise**

• In Stepwise models with a categorical response, the Step History report contains columns that show the statistics used to determine entry of an effect into the model.

• Stepwise now uses transform columns when you click Make Model or Run Model. Instead of creating new columns in the data table, temporary transform columns are used in the Fit Model platform.

**Predictive and Specialized Modeling**

This section describes new features and enhancements in the advanced Modeling platforms. For details, see the *Predictive and Specialized Modeling* book.

**Association Analysis**

• When you select SVD from the red triangle menu, you are prompted for the number of vectors. The number of vectors is saved in the SVD script.

• The Save commands for SVD and Topics (Rotated SVD) have been removed from the Association Analysis red triangle menu. They are now in the SVD and Topics red triangle menus with more specific names (Save Transaction Singular Vectors” and “Save Item Singular Vectors for SVD; “Save Transaction Topic Vectors” and “Save Item Topic Vectors” for Topics).

• You can now assign a Multiple Response column to the Item role in the launch window.

• The Freq role has been added to the launch window. A frequency variable works only if the column contains multiple responses.
Bootstrap Forest

- If the approximated time for fitting a model is too long, you can view the current model by selecting **Accept Current Model**.

Explore Missing Values

- The Automated Data Imputation method efficiently determines the best rank for the low rank approximation. The method also allows for streaming capabilities (scoring new rows) without recalculating the low rank fit.

Explore Outliers

- In the K Nearest Neighbors report, the Save NN Distances option saves the distance from each row to its \( n \)th nearest neighbor as new columns in the data table.

Formula Depot

- When a column is selected and you select Add Formula from Column from the red triangle menu, the formula for that column is added to the Formula Depot.
- The Rename New Column red triangle menu option enables you to change the name of the columns generated by this model.
- Formulas can be saved as functions utilizing scalar variables rather than columns.

Functional Data Explorer

- The Functional Data Explorer (FDE) platform takes data that are presented as functions, signals, or series and turns them into a form that can be analyzed in another platform, such as Generalized Regression. You can use FDE to pre-process data through transformations and alignments, and then create a surrogate model by fitting a B-Spline, P-Spline, or Fourier Basis model to the data. You can perform functional principal component analysis (functional PCA) on the surrogate model. You can use functional PCA as a feature extraction or dimension reduction technique or save the functional scores for use in future analysis.

K Nearest Neighbors

- A solution path plot with a slider has been added that updates corresponding plots or confusion matrices.
• Mosaic plots are shown for nominal and ordinal responses.
• The Model Selection report displays a solution path plot across $K$ based on the Misclassification Rate for categorical responses or the RMSE for continuous responses. Plot Actual by Predicted and Plot Residual by Predicted red triangle menu options have been added.

**Naive Bayes**

• If the response has two levels, the ROC curve plot and lift curve plot display an ROC curve for the first level of the response only. If the response has more than two levels, the ROC Curve plot displays a sub-outline of the curves for each response level. Training, Validation, and Test statistics are displayed in separate reports in the Confusion Matrix report.

**Nonlinear Curve**

• The Weibull sigmoid curve is available in Fit Curve.
• The Parameter Estimate report includes chi-square statistics and their $p$-values.

**Predictor Screening**

• The Copy Selected button enables you to copy the selected columns to the clipboard so that you can paste them into a model.

**Process Screening**

• To remove quick graphs, click the Graphs of Selected Items red triangle and select Remove.
• To change the layout of the quick graphs, click the Graphs of Selected Items red triangle and select Number of Plots Across.
• The XBar MR and R and XBar MR and S control chart types are available. These charts are referred to as 3-way charts. Estimates for the between sigma and between-and-within sigma values are added to the Process Screening summary table. The between-and-within sigma estimate is used to calculate the stability ratio.
• The Variable Importance role added to Limits Specification window enables you to specify importance values for processes. If you specify importance values, the processes and groups are sorted in the Summary table in decreasing order by Stability Ratio within Importance.
- Subgroup Size has been added to the Control Limits column property to properly handle unequal sample sizes.
- Derived Sigma in the Limits Specification window enables you to calculate sigma based on the given control limits and subgroup size.
- You can now detect gradual drifts in processes using the Drift Graph.
- The Process Screening red triangle menu includes a Goal Plot option.
- Goal plot coordinates were added to the output.
- The Select Where red triangle menu option was added. You can select specific processes in the Summary table that correspond to a particular condition by using the Comparison menu and Value text box.
- The Shift Graph slider was added.
- The Minimum Process Length launch window option specifies the minimum number of data values that a process must have in order to be included in the analysis.
- The Remove Selected Items red triangle menu option removes the rows selected in the Summary table and reruns the analysis without those processes.
- Each Quick Graph has lines for the spec limits. There is a solid blue line for the target value and dotted blue lines for the LSL and USL values.

**Response Screening**

- The Interval and Slope columns in the Pvalues data table appear when Y and X are both continuous. These columns contain the intercept and slope of the regression model for the corresponding pair of X and Y variables.

**Multivariate Methods**

This section describes new features and enhancements in the Multivariate Methods platforms. For details, see the *Multivariate Methods* book.

- Multiple Correspondence Analysis, Multidimensional Scaling, Factor Analysis, and Item Analysis have been moved to the Multivariate Methods menu.

**Factor Analysis**

- The Unsorted and Unrotated Factor Loading option shows the factor loading matrix before sorting and rotation.
• The reports are shown in the order in which the analyses are performed. For example, when you request an oblique rotation, the Factor Structure matrix comes after Rotation Matrix; the former is based on variables’ correlations with factors after rotation.
• The value for the objective function criterion is displayed when using Maximum Likelihood estimation.
• Measures of factor score determinacy are now available. Select the new Measures of Factor Scores option to select from three measures of factor scores determinacy. These measures are used to evaluate if the factor scores might be useful for secondary analyses.
• Measures of fit are now available. Select the Measures of Fit red triangle menu to select from five measures of fit: Chi-Squared without Bartlett’s Correction, AIC, BIC, Tucker and Lewis’ Index, and the root mean square error of approximation.

K Means Clustering

• The scatterplot matrix is integrated into the main report window.
• The K Means Clustering and Normal Mixtures platforms are separate platforms now. The K Means Clustering interface has been redesigned.
• The K Means NCluster red triangle menu contains the following Save options: Save Cluster Distance, Save Distance Formula, Save K Cluster Distances, and Save K Distance Formulas. These options are not available for self-organizing maps.
• K Means Clustering formulas can now be published to the Formula Depot.
• The Biplot Contour Density option enables you to specify the confidence level for the density contours.
• Below the Biplot, you can change the biplot axes to different principal components.
• When you select Save Colors to Table, the biplot point colors for each cluster match the colors saved to the data table.

Latent Class Analysis

• You can place your cursor over the bars in the LCA graph to view the levels of the variable.

Normal Mixtures

• The Normal Mixtures and K Means Clustering platforms are separate platforms. The Normal Mixtures interface has been redesigned.
• The Biplot Contour Density option enables you to specify the confidence level for the density contours.
• Below the Biplot, you can change the biplot axes to different principal components.
Principal Components

- You can publish the DModX formula based on a specified number of principal components to the Formula Depot platform.
- In the Outlier Analysis report options, the Contribution Proportions Heat Map option shows or hides a heat map of the $T^2$ contribution values for all observations expressed as a proportion of the individual row’s $T^2$. The Save Normalized DModX report option saves the normalized DModX values to a new column in the data table.

By default, the Outlier Analysis report displays the $T^2$ for <A> Principal Components plot. The plot shows the $T^2$ value for each observation and horizontal lines at the Median and Upper Control Limit (UCL). Outlier Analysis options for $T^2$ statistics have been added.

In the Outlier Analysis report options, the Normalized DModX Plot option shows or hides a plot of the Normalized DModX values. DModX values are useful for detecting moderate outliers in the data.

Quality and Process Platforms

This section describes new features and enhancements in the Quality and Process platforms. For details, see the Quality and Process Methods book.

Control Chart Builder

- Use the Show Excluded Points option to hide excluded points, which updates the axis scale.
- Labels for excluded and hidden observations appear on the X axis.
- The within sigma that is used in capability analysis for 3-way control charts is now estimated by the average of ranges instead of by the moving range. Also, an additional between-and-within sigma estimate has been added to the three-way control chart analysis. This estimate is calculated as follows:

$$\text{Between-and-Within Sigma} = \sqrt{\text{Within Sigma}^2 + \text{Between Sigma}^2}$$

CUSUM Control Charts

- The CUSUM Control Chart platform creates a cumulative sum or CUSUM chart with decision limits, similar to a Shewhart chart. This chart is also called a \textit{tabular CUSUM chart.}
Manage Spec Limits

- The new Manage Spec Limits utility enables you to quickly add or edit many specification limits for several columns at once. The specification limits are then used in any future analyses. You can also specify if limits should appear in graphs as reference lines.

Process Capability

- The Process Performance Plot option produces a four-quadrant plot to assess capability and stability of processes.
- The Exponential distribution and Beta distribution are available in Process Capability. The new Calculate Between-and-Within Capability option specifies that the between-and-within subgroup estimate of the standard deviation should be used in the capability analysis. The option is available only with Process Subgrouping.
- For very capable data, F(LSL) or F(USL) can be so close to zero or one, respectively, that LSL or USL cannot be computed. In these cases, JMP automatically switches from the Z-Score method to the Percentile method by default. This gives more meaningful capability indices. To turn off this default option, select File > Preferences > Platforms > Process Capability.
- The Mixture of 2 Normals and Mixture of 3 Normals distributions are available in the Compare Distributions report.

Variability/Attribute Gauge Chart

- Confidence intervals have been added to the REML and EMS variance components. They are not shown for Bayesian variance components. The standard errors and confidence intervals are shown by default for the REML report. You can also right-click the Variance Components report and add them as columns.
- Confidence intervals for the variance components in the Gauge R&R report are available. Right-click the Variance Components for Gauge R&R report and add them as columns.

Reliability and Survival

This section describes new features and enhancements in the Reliability and Survival platforms. For details, see the Reliability and Survival Methods book.
Cumulative Damage

- The Probability Plot of Standardized Residuals red triangle menu option shows a plot of standardized residuals for the model on a probability scale axis.

Fit Life by X

- The Box-Cox transformation in the Fit Life by X platform now matches the Box-Cox transformation in the Cumulative Damage platform.
- If you use “Survived” or “Survive” as right-censor codes, the Censor Code list on the launch window recognizes them as options.
- Groups that contain only censored observations are no longer excluded from the analysis in the Fit Life by X platform. For some cases, degrees of freedom adjustments are made in the Nested Model Tests. These adjustments are noted in the report.
- Bayesian inference is now supported in the Fit Life by X platform. You can specify a prior distribution for the distribution parameters as well as for a quantile at a specified probability.

Life Distribution

- If you specify more than two Y variables in the Compare Groups tab, the report contains a separate analysis computed using each specified variable as time to event data.
- In the Fix Parameter report, a distribution profiler of the unconstrained model is shown below the distribution profiler for the fixed parameter model.
- If you use “Survived” or “Survive” as right-censor codes, the Censor Code list on the launch window recognizes them as options.

Parametric Survival

- Variable Importance has been removed from Profilers in Parametric Survival because it should not be conducted on CDF curves.
- If you use “Survived” or “Survive” as right-censor codes, the Censor Code list on the launch window recognizes them as options.
- Groups that contain only censored observations are no longer excluded from the analysis in Parametric Survival. For some cases, degrees of freedom adjustments are made in the Nested Model Tests. These adjustments are noted in the report.
Recurrence Analysis

- When the response is a timestamp, you can view the Calendar Event Plot, which plots the events using a date-based horizontal axis.
- The Plot Interarrival by Age red triangle menu options shows or hides the Interarrival by Age plot, which plots the time between successive events on the vertical axis and the event times on the horizontal axis.

Repairable Systems Simulation

- The Remove option in the Action Panel has been renamed “Remove Block”.
- The Point Estimation of System Availability graph is now named “Point Estimation of System Availability Profiler”. The Point Estimation of System in Service Estimability graph is now named “Point Estimation of System in Service Probability Profiler”. “Turn On” and “Turn Off” are now named “Turn On Block” and “Turn Off Block”.
- The right-click Diagram Operation menu includes the Show Even Action Links Across Blocks option to avoid drawing links between event-action pairs unless the action node is selected. This option makes the diagram less cluttered.

Consumer Research

This section describes new features and enhancements in the Consumer Research platforms. For details, see the Consumer Research book.

- Multiple Correspondence Analysis, Multidimensional Scaling, Factor Analysis, and Item Analysis have been moved to the Multivariate Methods menu.

Categorical

- In the Save Tables red triangle menu, Save Contingency to Table saves the complete Crosstab Table to a new data table.
- In the Categorical red triangle menu, there is an option to specify formats for Frequencies, Shares, and Rates.

Choice

- Hierarchical Bayes calculations in Choice have improved starting values before the MCMC sampling begins. This reduces shrinkage for variance calculations and model parameters.
Multiple Factor Analysis

- Multiple Factor Analysis (MFA) is an analytical method closely related to principal components analysis (PCA). MFA uses eigenvalue decomposition to transform multiple measurements on the same items into orthogonal principal components that explain how the items are similar and how they are different. MFA is frequently used in sensory analysis to account for differing measures among panelists.

Scripting

This section describes new features and enhancements in the scripting area. For details, see the Scripting Guide and JSL Syntax Reference.

New Commands

- On Windows, JMP integrates with Python 3.6.1 or 3.6.2. You can submit statements to Python from within a JSL script, exchange data between JMP and Python, and display graphics produced by Python.
- Multiple File Import() can import and stack text, CSV, or PNG/JPG files using file name, time, and size filters. MFI is useful for both Text Explorer data preparation and loading text tables into JMP data tables.
- You can add Event Handler scripts to a data table column to create “blue hyperlink” behaviors. A script for clicking the link specifies what happens: open a web page, launch a platform, and so on.
- JMP has the capability to define user-defined custom functions. These functions can then be used in the Formula Editor’s function list, in JSL scripting, as custom formats, and as custom transforms. To define a custom function, use New Custom Function(). After a function is defined, you can add or activate it to the current running instance of JMP using Add Custom Functions(). Similarly, you can remove or deactivate a function using Remove Custom Functions().
- New HTTP Request() and HTTP messages enable JMP to communicate with REST (Representational State Transfer) web services. For example, you can get data from a web service and return it as a data table. Some examples of REST web service providers are Amazon Web Services and DropBox.
- Downloaded data tables might be quarantined. JMP will prompt when opening a quarantined table that contains scripts. In the Open() command, you can control this behavior.

To open the data table and allow scripts to run:
Open( "$DOWNLOADS/file.jmp", Quarantine Action( "Allow Scripts" ) );

To open the data table and block scripts:
Open( "$DOWNLOADS/file.jmp", Quarantine Action( "Block Scripts" ) );

To enable a Try() expression to capture the error:
Try( Open( "$DOWNLOADS/file.jmp", Quarantine Action( "Do Not Open" ) ),
Show( exception_msg ) );

To display the default prompt window to open the file:
Open( "$DOWNLOADS/file.jmp", Quarantine Action( "Show Dialog" ) );

- As Boolean() converts a JSL expression to a JSL Boolean value for use with JSON data.
- The Select All Rows message selects all rows in the data table.
- Functions for the redesigned projects are available. Search the Help > Scripting Index for “project” to see a complete list.
- Dim() returns a row vector with the dimensions of a data table or a matrix. The dimensions are the number of rows and the number of columns and are listed in that order.
- Many messages have been added to enable you to group, ungroup, and move table scripts: Group Scripts, Ungroup Scripts, Move Script Group, Get Script Group, Select Script Group, Ungroup Scripts, Rename Script, and Rename Script Group.
- The Get Exif Data message returns EXIF data from the image (such as the shutter speed and aperture value) in an associative array.
- Report windows now handle the Set Dirty message, just like data tables. When a window is modified, it becomes “dirty” or modified, and a save prompt is issued when the window is closed. You can control the prompt with Set Dirty(Boolean).
- To specify text color or background color in HTML tags, use the markup argument.
  ```javascript
  Text Box( "This is <font color="Red">red text." , markup );
  ```
- Find All() finds all open files of the specified type: data tables, reports, or journals.
- To select any column that is currently deselected and deselect any column that is currently selected, use the Invert Column Selection message.
- Button box<<Style(Toggle) creates a button that behaves similar to a check box when clicked.
- The Set Cell Height(n) message sets the cell height in a data table to the specified number of pixels.
- The Get Data Type Length message returns the data type and length of the data column. Only the data type is returned if the data length is not fixed, as with character columns.
- The Select Columns message provides a quick way to select specified columns in a data table.
New Features in JMP 14  Scripting

- Sending Get Prediction Variances to a DOE object returns a vector of MC variances used for the FDS plots. This could be useful for testing purposes, for comparing FDS plots of 2 designs, or checking for changes that might occur in FDS plot construction. This option is available only in scripts.

- Sending Set Number of FDS Points(n) to a DOE object enables you to specify the number of runs used to generate an FDS plot. This option is available only in scripts.

- The Linear Regression() function fits a linear regression for the assumed model \( y = X \beta + \text{error} \). Returns a list that contains a vector of the estimates, a vector of the standard errors, and a list of diagnostics.

- Design Last() creates a design matrix that contains a column of 1s and 0s for all but the last values of the argument. The last level is coded as a row of 0s.

- You can add custom functions with Add Custom Functions(). Include << Transform(1) to indicate if it's a transform. The custom transforms appear in the transforms Custom list.

- Web reports are scriptable. See the HTML5 category in the Help > Scripting Index.

- The BSpline Coef() function enables you to define the internal knots with a vector or enter the number of desired knots. It returns the spline coefficients that correspond to the entries in x.

- In table boxes, you can now sort by multiple columns by sorting the first column and then sorting the second column.

- Polygon Area() calculates the area of the specified polygon. Polygon Centroid() calculates the centroid of the specified polygon.

- You can control the smoothness of contours in Graph Builder. Smoothnesss(0) displays the default contour edges. Increase the value to increase the smoothness.

- You can add column properties to a transform column.

- Data feed messages have been added. Note that data feeds are supported only on Windows.
  - Write sends a string to the data feed device.
  - Write Line sends a string to the data feed device. If EOL has been set for the data feed, the strings are terminated by the specified EOL value. If EOL has not been set, the line is terminated with CRLF.
  - Write Lines sends a list of strings to the data feed device. EOL characters are handled as with Write Line.

- Get Namespace Names() returns a list of names of all currently defined namespaces.

- Encode64 Blob() encodes a blob into a printable string of base 64 text. Decode64 Blob() decodes a printable string of base 64 text into a blob.

- Gzip Compress() compresses a blob of data into a gzip blob. Gzip Uncompress() uncompresses a blob of gzip data into a blob.
• **Arc Finder()** finds the arcs in the point data and creates a new column that identifies the arcs.

• Graphics that have natural boundaries, such as geographical maps, can be clipped so that the display segs that make up the graphic conform to the boundaries. Most display segs, including reference lines and grid lines, can be clipped. `Clip Shape( Boundaries( "US States" ) )` clips the boundaries around a map of the United States.

• **String Col Edit Box()** supports **Remove Element** to remove an element from the column and **Set Values** to replace the values. `Col Box()`, `Number Col Box()`, `Number Col Edit Box()`, `Plot Col Box()`, `String Col Box()`, and `String Col Edit Box()` support **Remove Element** now.

• The **Save Specific Solving Formula** message creates a new data table column with a formula. The formula solves for an x variable given the y variable and either other x variables in the data or a constant.

• **Fit Circle()** fits a circle that best goes through three or more points using a least squares approach. If only three points are specified, a direct solution can be found, and the sum of squared errors is zero.

• The **Type** argument on `Get Window()` and `Get Window List()` returns a reference to a specific type of window, such as a project.

• The **Utility Profiler in Choice** is scriptable.

• You can define user-defined custom functions and then use them in the Formula Editor’s function list, in JSL scripting, as custom formats and as custom transforms. Use **New Custom Function()** and **Add Custom Functions()** to define the function format, or transform.

• **Lock Namespace** locks all variables or specified named variables in the namespace and prevents variables from being added, changed, or removed.

• You can define classes to create objects using **Define Class()**. You can also define methods to obtain attributes of objects using **Method()**.

• Syntax coloring is supported for JSON files.

• Three functions allow for the roundtripping of JSON text. **Parse JSON()** converts JSON text into an associative array or list based on the structure of the JSON data. **JSON to Data Table()** converts JSON text to a data table. **JSON Literal** returns a valid JSON Boolean or null constant based on the specification of the parameter.

• Formula Depot is now scriptable. Select **Help > Scripting Index** and search for “Formula Depot” to find the commands.
New Features in JMP 14

General Enhancements

- The Scripting Index has been renovated so that finding commands is easier now. There are numerous filtering options, and cross-references to related commands are available in many entries. You can also switch to a smaller window size.
- To display the Scripting Index entry for a function in a script, right-click the function and select Help Scripting Index. You can view information in the help by right-clicking the function and selecting Help Browser.
- Get Color Theme Names() returns a list of all color theme names or color themes of the specified kind. The kinds include “continuous”, “categorical”, “sequential”, “diverging”, “qualitative”, or “chromatic”. Get Color Theme Detail() returns a script for the specified color theme.
- Projects are fully scriptable. New Project() creates the project. The main commands include Set Tools to display the bookmarks or log; Run Script to open a data table and create output; and Set Layout, which specifies the layout of the tabs that show the data table and output.
- The $SAMPLE_PROJECTS variable enables you to open files from the Samples/Projects folder.
- The Pick Color() function enables the user to select a color from a color picker to apply to graphs.
- The Scroll Window message takes a display box argument along with relative and absolute pixels.
- The Get Script message includes the cell height and display width in the script.
- In Create Excel Workbooks(), you can specify data table references as arguments.
- Get Script and Copy Table Script include cell height and display width properties in the script.
- You can pass Tab Page Box() to Tab Box<<Add, <<Append, <<Insert, or <<Replace, and then the Tab Page Box() no longer wraps a Tab Page Box(). Your scripts might need to be updated.
- When tabs in a tab list are not wide enough for the titles, send the Set Overflow Enabled(1) message to Tab Box(). An overflow icon is shown to the right of a tab list, and the tab titles are truncated using ellipses.
- You can now return a list of results from the Return() function using the following syntax: Return(<expression1>, <expression2>, ..., <expressionN>);
- When Save Script to Data Table is sent to a JMP application, the “Name”, Prompt and Replace options are supported.
- Pick Directory() now supports a prompt string on Macintosh.
- You can use an index to specify effects. For example, dt << Fit Model(Y(:y), Effects(1::4)) specifies effects one through four.
• Send Get Data Table to a column reference to find out which open data table the column is in.

• The Text Color message specifies the text color in an outline box.

• Normal Log Distribution() and Normal Log CDistribution() now support sigma and mu.

• Analytical derivatives (in JSL Derivative()) have been added for Normal density, quantile, and cumulative distribution functions. They have also been added for Normal Log Density(), Normal Log Distribution(), and Normal Log C Distribution().

• As Table() now supports an optional private message.

• The private option is available for Open Database().

• Least Squares Solve() now supports an Intercept message.

• Tabs are preserved when you save, close, and reopen a JMP report. Previously, the tabs turned into outline boxes.

• Table Box() supports specifying a column name to sort by, not just the column position.

• To remember the state of folded code when you close and reopen a script, select Save and restore document save information in the Script Editor preferences.

• Layout is deprecated and will be removed in a future release. Use Journal instead.

• In Show Namespaces(), Delete Namespaces(), and Get Namespaces(), and Get Namespace Names(), you can specify zero or more namespaces. You can also use the Force argument in Delete Namespaces() to delete locked namespaces.

• Save Picture("pathname", pdf) saves the picture in PDF with no headers or footers.

• The Multiple k-Nearest Neighbors Outliers message has an unhyphenated alias: Multiple k Nearest Neighbors Outliers.

**Application Builder**

• In Application Builder, the Script > Add to Templates menu item saves the application as a template from which you can create new applications.