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Chapter 1
Learn about JMP

Documentation and Additional Resources

This chapter includes the following information:

• book conventions

• JMP documentation

• JMP Help

• additional resources, such as the following:

‒ other JMP documentation

‒ tutorials

‒ indexes

‒ Web resources

Figure 1.1  The JMP Help Home Window on Windows
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Formatting Conventions

The following conventions help you relate written material to information that you see on 
your screen.

• Sample data table names, column names, pathnames, filenames, file extensions, and 
folders appear in Helvetica font.

• Code appears in Lucida Sans Typewriter font.

• Code output appears in Lucida Sans Typewriter italic font and is indented farther than 
the preceding code.

• Helvetica bold formatting indicates items that you select to complete a task:

‒ buttons

‒ check boxes

‒ commands

‒ list names that are selectable

‒ menus

‒ options

‒ tab names

‒ text boxes

• The following items appear in italics:

‒ words or phrases that are important or have definitions specific to JMP

‒ book titles

‒ variables

• Features that are for JMP Pro only are noted with the JMP Pro icon . For an overview 
of JMP Pro features, visit http://www.jmp.com/software/pro/.

Note: Special information and limitations appear within a Note.

Tip: Helpful information appears within a Tip.

JMP Documentation

JMP offers documentation in various formats, from print books and Portable Document 
Format (PDF) to electronic books (e-books). 

• Open the PDF versions from the Help > Books menu or from the JMP online Help footers.

http://www.jmp.com/software/pro/
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• All books are also combined into one PDF file, called JMP Documentation Library, for 
convenient searching. Open the JMP Documentation Library PDF file from the Help > Books 
menu.

• e-books are available at Amazon, Safari Books Online, and in the Apple iBookstore.

• You can also purchase printed documentation on the SAS website:

http://support.sas.com/documentation/onlinedoc/jmp/index.html

JMP Documentation Library

The following table describes the purpose and content of each book in the JMP library.

Document Title Document Purpose Document Content

Discovering JMP If you are not familiar 
with JMP, start here.

Introduces you to JMP and gets you 
started creating and analyzing data.

Using JMP Learn about JMP data 
tables and how to 
perform basic 
operations.

Covers general JMP concepts and 
features that span across all of JMP, 
including importing data, modifying 
columns properties, sorting data, and 
connecting to SAS.

Basic Analysis Perform basic analysis 
using this document.

Describes these Analyze menu platforms:

• Distribution

• Fit Y by X

• Matched Pairs

• Tabulate

How to approximate sampling 
distributions using bootstrapping is also 
included.

http://support.sas.com/documentation/onlinedoc/jmp/index.html
http://www.amazon.com
http://www.safaribooksonline.com/
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Essential Graphing Find the ideal graph 
for your data. 

Describes these Graph menu platforms:

• Graph Builder

• Overlay Plot

• Scatterplot 3D

• Contour Plot

• Bubble Plot

• Parallel Plot

• Cell Plot

• Treemap

• Scatterplot Matrix

• Ternary Plot

• Chart

Also covers how to create background 
and custom maps.

Profilers Learn how to use 
interactive profiling 
tools, which enable you 
to view cross-sections 
of any response 
surface.

Covers all profilers listed in the Graph 
menu. Analyzing noise factors is 
included along with running simulations 
using random inputs.

Design of 
Experiments Guide

Learn how to design 
experiments and 
determine appropriate 
sample sizes.

Covers all topics in the DOE menu.

Document Title Document Purpose Document Content
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Fitting Linear Models Learn about Fit Model 
platform and many of 
its personalities.

Describes these personalities, all 
available within the Analyze menu Fit 
Model platform:

• Standard Least Squares

• Stepwise

• Generalized Regression

• Mixed Model

• MANOVA 

• Loglinear Variance

• Nominal Logistic

• Ordinal Logistic

• Generalized Linear Model

Specialized Models Learn about additional 
modeling techniques.

Describes these Analyze > Modeling 
menu platforms:

• Partition

• Neural

• Model Comparison

• Nonlinear

• Gaussian Process

• Time Series

• Response Screening

The Screening platform in the Analyze > 
Modeling menu is described in Design of 
Experiments Guide.

Multivariate 
Methods

Read about techniques 
for analyzing several 
variables 
simultaneously.

Describes these Analyze > Multivariate 
Methods menu platforms:

• Multivariate

• Cluster

• Principal Components

• Discriminant

• Partial Least Squares

Document Title Document Purpose Document Content
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Quality and Process 
Methods

Read about tools for 
evaluating and 
improving processes. 

Describes these Analyze > Quality and 
Process menu platforms:

• Control Chart Builder and individual 
control charts

• Measurement Systems Analysis

• Variability / Attribute Gauge Charts

• Capability 

• Pareto Plot

• Diagram

Reliability and 
Survival Methods

Learn to evaluate and 
improve reliability in a 
product or system and 
analyze survival data 
for people and 
products.

Describes these Analyze > Reliability and 
Survival menu platforms:

• Life Distribution

• Fit Life by X

• Recurrence Analysis

• Degradation

• Reliability Forecast

• Reliability Growth

• Reliability Block Diagram

• Survival

• Fit Parametric Survival

• Fit Proportional Hazards

Consumer Research Learn about methods 
for studying consumer 
preferences and using 
that insight to create 
better products and 
services. 

Describes these Analyze > Consumer 
Research menu platforms:

• Categorical

• Factor Analysis

• Choice

• Uplift 

• Item Analysis

Document Title Document Purpose Document Content
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Note: The Books menu also contains two reference cards that can be printed: The Menu Card 
describes JMP menus, and the Quick Reference describes JMP keyboard shortcuts.

JMP Help

JMP Help is an abbreviated version of the documentation library that provides targeted 
information. You can open JMP Help in several ways:

• On Windows, press the F1 key to open the Help system window.

• Get help on a specific part of a data table or report window. Select the Help tool  from 
the Tools menu and then click anywhere in a data table or report window to see the Help 
for that area.

• Within a JMP window, click the Help button.

• Search and view JMP Help on Windows using the Help > Help Contents, Search Help, and 
Help Index options. On Mac, select Help > JMP Help.

• Search the Help at http://jmp.com/support/help/ (English only).

Additional Resources for Learning JMP

In addition to JMP documentation and JMP Help, you can also learn about JMP using the 
following resources:

• Tutorials (see “Tutorials” on page 25)

• Sample data (see “Sample Data Tables” on page 25)

• Indexes (see “Learn about Statistical and JSL Terms” on page 25)

Scripting Guide Learn about taking 
advantage of the 
powerful JMP 
Scripting Language 
(JSL).

Covers a variety of topics, such as writing 
and debugging scripts, manipulating 
data tables, constructing display boxes, 
and creating JMP applications.

JSL Syntax Reference Read about many JSL 
functions on functions 
and their arguments, 
and messages that you 
send to objects and 
display boxes.

Includes syntax, examples, and notes for 
JSL commands.

Document Title Document Purpose Document Content

http://jmp.com/support/help/
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• Tip of the Day (see “Learn JMP Tips and Tricks” on page 26)

• Web resources (see “JMP User Community” on page 26)

• JMPer Cable technical publication (see “JMPer Cable” on page 26)

• Books about JMP (see “JMP Books by Users” on page 27)

• JMP Starter (see “The JMP Starter Window” on page 27)

Tutorials

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu 
is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, then start with the Beginners Tutorial. It steps you through the 
JMP interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as creating a pie chart, 
using Graph Builder, and so on.

Sample Data Tables

All of the examples in the JMP documentation suite use sample data. Select Help > Sample 
Data to do the following actions:

• Open the sample data directory.

• Open an alphabetized list of all sample data tables.

• Find a sample data table within a category.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\JMP\<version_number>\Samples\Data

On Macintosh: \Library\Application Support\JMP\<version_number>\Samples\Data

In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

Learn about Statistical and JSL Terms

The Help menu contains the following indexes:

Statistics Index Provides definitions of statistical terms.

Scripting Index Lets you search for information about JSL functions, objects, and display 
boxes. You can also edit and run sample scripts from the Scripting Index.



26 Learn about JMP Chapter 1
Additional Resources for Learning JMP Design of Experiments Guide

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for 
using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select 
Help > Tip of the Day. Or, you can turn it off using the Preferences window. See the Using JMP 
book for details.

Tooltips

JMP provides descriptive tooltips when you place your cursor over items, such as the 
following:

• Menu or toolbar options

• Labels in graphs

• Text results in the report window (move your cursor in a circle to reveal)

• Files or windows in the Home Window

• Code in the Script Editor

Tip: You can hide tooltips in the JMP Preferences. Select File > Preferences > General (or JMP 
> Preferences > General on Macintosh) and then deselect Show menu tips.

JMP User Community

The JMP User Community provides a range of options to help you learn more about JMP and 
connect with other JMP users. The learning library of one-page guides, tutorials, and demos is 
a good place to start. And you can continue your education by registering for a variety of JMP 
training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, 
and social networking groups.

To access JMP resources on the website, select Help > JMP User Community.

JMPer Cable

The JMPer Cable is a yearly technical publication targeted to users of JMP. The JMPer Cable is 
available on the JMP website:

http://www.jmp.com/about/newsletters/jmpercable/

http://www.jmp.com/about/newsletters/jmpercable/
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JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP 
website:

http://www.jmp.com/support/books.shtml

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data 
analysis. Options are categorized and described, and you launch them by clicking a button. 
The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and 
File menus.

• To open the JMP Starter window, select View (Window on the Macintosh) > JMP Starter.

• To display the JMP Starter automatically when you open JMP on Windows, select File > 
Preferences > General, and then select JMP Starter from the Initial JMP Window list. On 
Macintosh, select JMP > Preferences > Initial JMP Starter Window.

http://www.jmp.com/support/books.shtml
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Chapter 2
Introduction to Designing Experiments

A Beginner’s Tutorial

This tutorial chapter introduces you to the design of experiments (DOE) using JMP’s custom 
designer. It gives a general understanding of how to design an experiment using JMP. Refer to 
subsequent chapters in this book for more examples and procedures on how to design an 
experiment for your specific project.
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About Designing Experiments

Increasing productivity and improving quality are important goals in any business. The 
methods for determining how to increase productivity and improve quality are evolving. They 
have changed from costly and time-consuming trial-and-error searches to the powerful, 
elegant, and cost-effective statistical methods that JMP provides.

Designing experiments in JMP is centered around factors, responses, a model, and runs. JMP 
helps you determine if and how a factor affects a response.

My First Experiment

If you have never used JMP to design an experiment, this section shows you how to design the 
experiment and how to understand JMP’s output.

Tip: The recommended way to create an experiment is to use the custom designer. JMP also 
provides classical designs for use in textbook situations.

The Situation

Your goal is to find the best way to microwave a bag of popcorn. Because you have some 
experience with this, it is easy to decide on reasonable ranges for the important factors:

• how long to cook the popcorn (between 3 and 5 minutes)

• what level of power to use on the microwave oven (between settings 5 and 10)

• which brand of popcorn to use (Top Secret or Wilbur)

When a bag of popcorn is popped, most of the kernels pop, but some remain unpopped. You 
prefer to have all (or nearly all) of the kernels popped and no (or very few) unpopped kernels. 
Therefore, you define “the best popped bag” based on the ratio of popped kernels to the total 
number of kernels.

A good way to improve any procedure is to conduct an experiment. For each experimental 
run, JMP’s custom designer determines which brand to use, how long to cook each bag in the 
microwave and what power setting to use. Each run involves popping one bag of corn. After 
popping a bag, enter the total number of kernels and the number of popped kernels into the 
appropriate row of a JMP data table. After doing all the experimental runs, use JMP’s model 
fitting capabilities to do the data analysis. Then, you can use JMP’s profiling tools to determine 
the optimal settings of popping time, power level, and brand.
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Step 1: Design the Experiment

The first step is to select DOE > Custom Design. Then, define the responses and factors.

Define the Responses: Popped Kernels and Total Kernels

There are two responses in this experiment:

• the number of popped kernels 

• the total number of kernels in the bag. After popping the bag add the number of 
unpopped kernels to the number of popped kernels to get the total number of kernels in 
the bag.

By default, the custom designer contains one response labeled Y (Figure 2.1).

Figure 2.1  Custom Design Responses Panel

You want to add a second response to the Responses panel and change the names to be more 
descriptive:

1. To rename the Y response, double-click the name and type “Number Popped.” Since you 
want to increase the number of popped kernels, leave the goal at Maximize.

2. To add the second response (total number of kernels), click Add Response and choose 
None from the menu that appears. JMP labels this response Y2 by default.

3. Double-click Y2 and type “Total Kernels” to rename it.

The completed Responses panel looks like Figure 2.2.

Figure 2.2  Renamed Responses with Specified Goals
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Define the Factors: Time, Power, and Brand

In this experiment, the factors are:

• brand of popcorn (Top Secret or Wilbur)

• cooking time for the popcorn (3 or 5 minutes)

• microwave oven power level (setting 5 or 10)

In the Factors panel, add Brand as a two-level categorical factor:

1. Click Add Factor and select Categorical > 2 Level.

2. To change the name of the factor (currently named X1), type Brand.

3. To rename the default levels (L1 and L2), click the level names and type Top Secret and 
Wilbur.

Add Time as a two-level continuous factor:

4. Click Add Factor and select Continuous.

5. Change the default name of the factor (X2) by typing Time.

6. Likewise, to rename the default levels (–1 and 1) as 3 and 5, click the current level name 
and type in the new value.

Add Power as a two-level continuous factor:

7. Click Add Factor and select Continuous.

8. Change the name of the factor (currently named X3) by typing Power.

9. Rename the default levels (currently named -1 and 1) as 5 and 10 by clicking the current 
name and typing. The completed Factors panel looks like Figure 2.3.

Figure 2.3  Renamed Factors with Specified Values

10. Click Continue.

Step 2: Define Factor Constraints

The popping time for this experiment is either 3 or 5 minutes, and the power settings on the 
microwave are 5 and 10. From experience, you know that
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• popping corn for a long time on a high setting tends to scorch kernels.

• not many kernels pop when the popping time is brief and the power setting is low.

You want to constrain the combined popping time and power settings to be less than or equal 
to 13, but greater than or equal to 10. To define these limits:

1. Open the Constraints panel by clicking the disclosure button beside the Define Factor 
Constraints title bar (see Figure 2.4).

2. Click the Add Constraint button twice, once for each of the known constraints.

3. Complete the information, as shown to the right in Figure 2.4. These constraints tell the 
Custom Designer to avoid combinations of Power and Time that sum to less than 10 and 
more than 13. Be sure to change <= to >= in the second constraint.

The area inside the parallelogram, illustrated on the left in Figure 2.4, is the allowable region 
for the runs. You can see that popping for 5 minutes at a power of 10 is not allowed and 
neither is popping for 3 minutes at a power of 5.

Figure 2.4  Defining Factor Constraints

Step 3: Add Interaction Terms

You are interested in the possibility that the effect of any factor on the proportion of popped 
kernels may depend on the value of some other factor. For example, the effect of a change in 
popping time for the Wilbur popcorn brand could be larger than the same change in time for 
the Top Secret brand. This kind of synergistic effect of factors acting in concert is called a 
two-factor interaction. You can examine all possible two-factor interactions in your a priori 
model of the popcorn popping process.

1. Click Interactions in the Model panel and select 2nd. JMP adds two-factor interactions to 
the model as shown to the left in Figure 2.5.

In addition, you suspect the graph of the relationship between any factor and any response 
might be curved. You can see whether this kind of curvature exists with a quadratic model 
formed by adding the second order powers of effects to the model, as follows.
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2. Click Powers and select 2nd to add quadratic effects of the continuous factors, Power and 
Time.

The completed Model should look like the one to the right in Figure 2.5.

Figure 2.5  Add Interaction and Power Terms to the Model

Step 4: Determine the Number of Runs

The Design Generation panel in Figure 2.6 shows the minimum number of runs needed to 
perform the experiment with the effects you’ve added to the model. You can use that 
minimum or the default number of runs, or you can specify your own number of runs as long 
as that number is more than the minimum. JMP has no restrictions on the number of runs you 
request. For this example, use the default number of runs, 16. Click Make Design to continue.

Figure 2.6  Model and Design Generation Panels
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Step 5: Check the Design

When you click Make Design, JMP generates and displays a design, as shown on the left in 
Figure 2.7. Note that because JMP uses a random seed to generate custom designs and there is 
no unique optimal design for this problem, your table may be different than the one shown 
here. You can see in the table that the custom design requires 8 runs using each brand of 
popcorn.

Now click Make Table in the Output Options section.

Figure 2.7  Design and Output Options Section of Custom Designer

The resulting data table (Figure 2.8) shows the order in which you should do the experimental 
runs and provides columns for you to enter the number of popped and total kernels. Note that 
the design matrix is updated to match the order of runs, the Time and Power values, and the 
Number Popped and Total Kernels columns are added.

You do not have fractional control over the power and time settings on a microwave oven, so 
you should round the power and time settings, as shown in the data table. Although this 
altered design is slightly less optimal than the one the custom designer suggested, the 
difference is negligible.

Tip: Note that optionally, before clicking Make Table in the Output Options, you could select 
Sort Left to Right in the Run Order menu to have JMP present the results in the data table 
according to the brand. We have conducted this experiment for you and placed the results, 
called Popcorn DOE Results.jmp, in the sample data folder installed with JMP. These results 
have the columns sorted from left to right.
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Figure 2.8  JMP Data Table of Design Runs Generated by Custom Designer

Step 6: Gather and Enter the Data

Pop the popcorn according to the design JMP provided. Then, count the number of popped 
and unpopped kernels left in each bag. Finally, enter the numbers shown below into the 
appropriate columns of the data table.

We have conducted this experiment for you and placed the results in the sample data folder 
installed with JMP. To see the results, open Popcorn DOE Results.jmp from the Design 
Experiment folder in the sample data. The data table is shown in Figure 2.9.

Figure 2.9  Results of the Popcorn DOE Experiment

results from 
experiment

scripts to analyze 
data
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Step 7: Analyze the Results

After the experiment is finished and the number of popped kernels and total kernels have 
been entered into the data table, it is time to analyze the data. The design data table has a 
script, labeled Model, that shows in the top left panel of the table. When you created the 
design, a standard least squares analysis was stored in the Model script with the data table.

1. Click the red triangle for Model and select Run Script.

The default fitting personality in the model dialog is Standard Least Squares. One assumption 
of standard least squares is that your responses are normally distributed. But because you are 
modeling the proportion of popped kernels it is more appropriate to assume that your 
responses come from a binomial distribution. You can use this assumption by changing to a 
generalized linear model.

2. Change the Personality to Generalized Linear Model, Distribution to Binomial, and Link 
Function to Logit, as shown in Figure 2.10.

Figure 2.10  Fitting the Model

3. Click Run.

4. Scroll down to view the Effect Tests table (Figure 2.11) and look in the column labeled 
Prob>Chisq. This column lists p-values. A low p-value (a value less than 0.05) indicates that 
results are statistically significant. There are asterisks that identify the low p-values. You 
can therefore conclude that, in this experiment, all the model effects except for Time*Time 
are highly significant. You have confirmed that there is a strong relationship between 
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popping time (Time), microwave setting (Power), popcorn brand (Brand), and the 
proportion of popped kernels.

Figure 2.11  Investigating p-Values

To further investigate, use the Prediction Profiler to see how changes in the factor settings 
affect the numbers of popped and unpopped kernels:

1. Choose Profilers > Profiler from the red triangle menu on the Generalized Linear Model Fit 
title bar. The Prediction Profiler is shown at the bottom of the report. Figure 2.12 shows the 
Prediction Profiler for the popcorn experiment. Prediction traces are displayed for each 
factor.

Figure 2.12  The Prediction Profiler

2. Move the vertical red dotted lines to see the effect that changing a factor value has on the 
response. For example, drag the red line in the Time graph to the right and left 
(Figure 2.13).

p-values indicate significance. 
Values with * beside them are 
p-values that indicate the results are 
statistically significant.

Prediction trace for 
Brand

predicted value of 
the response

95% confidence 
interval on the mean 
response

Factor values (here, time = 4)

Prediction trace 
for Time

Prediction trace for 
Power
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Figure 2.13  Moving the Time Value from 4 to Near 5

As Time increases and decreases, the curved Brand and Power prediction traces shift their 
slope and maximum/minimum values. The substantial slope shift tells you there is an 
interaction (synergistic effect) between Time and Brand and Time and Power.

Furthermore, the steepness of a prediction trace reveals a factor’s importance. Because the 
prediction trace for Time is steeper than that for Brand or Power for the values shown in 
Figure 2.13, you can predict that cooking time is more important than the brand of popcorn or 
the microwave power setting.

Now for the final steps.

3. Click the red triangle icon in the Prediction Profiler title bar and select Desirability 
Functions.

4. Click the red triangle icon in the Prediction Profiler title bar and select Maximize 
Desirability. JMP automatically adjusts the graph to display the optimal settings at which 
the most kernels will be popped (Figure 2.14).

Our experiment found how to cook the bag of popcorn with the greatest proportion of 
popped kernels: use Top Secret, cook for five minutes, and use a power level of 8. The 
experiment predicts that cooking at these settings will yield greater than 96.5% popped 
kernels.
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Figure 2.14  The Most Desirable Settings

The best settings are the Top Secret brand, cooking time at 5, and power set at 8.
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Chapter 3
Building Custom Designs

The Basic Steps

The use of statistical methods in industry is increasing. Arguably, the most cost-beneficial of 
these methods for quality and productivity improvement is statistical design of experiments. 
A trial-and-error search for the vital few factors that most affect quality is costly and 
time-consuming. The purpose of experimental design is to characterize, predict, and then 
improve the behavior of any system or process. Designed experiments are a cost-effective way 
to accomplish these goals.

JMP’s custom designer is the recommended way to describe your process and create a design 
that works for your situation. To use the custom designer, you first enter the process variables 
and constraints, then JMP tailors a design to suit your unique case. This approach is more 
general and requires less experience and expertise than previous tools supporting the 
statistical design of experiments. 

Custom designs accommodate any number of factors of any type. You can also control the 
number of experimental runs. This makes custom design more flexible and more cost effective 
than alternative approaches.

This chapter presents an overview of using the custom designer. The “Examples Using the 
Custom Designer” chapter on page 87, includes specific examples for creating various types 
of custom designs, such as mixture designs and split plots.
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Creating a Custom Design

To begin, select DOE > Custom Design, or click the Custom Design button on the JMP Starter 
DOE page. Then, follow the steps below.

• Enter responses and factors into the custom designer.

• Describe the model.

• Select the number of runs.

• Check the design diagnostics, if desired.

• Specify output options.

• Make the JMP design table.

The following sections describe each of these steps.

Enter Responses and Factors into the Custom Designer

How to Enter Responses

To enter responses, follow the steps in Figure 3.1.

1. To enter one response at a time, click Add Response, and then select a goal type. Possible 
goal types are Maximize, Match Target, Minimize, or None.

2. (Optional) Double-click to edit the response name.

3. (Optional) Click to change the response goal.

4. Click to enter lower and upper limits and importance weights.

Figure 3.1  Entering Responses

Tip: To quickly enter multiple responses, click Number of Responses and enter the number of 
responses you want.

2 3

4

1
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Specifying Response Goal Types and Lower and Upper Limits

When entering responses, you can tell JMP that your goal is to obtain the maximum or 
minimum value possible, to match a specific value, or that there is no response goal.

The following description explains the relationship between the goal type (step 3 in 
Figure 3.1) and the lower and upper limits (step 4 in Figure 3.1):

• For responses such as strength or yield, the best value is usually the largest possible. A 
goal of Maximize supports this objective.

• The Minimize goal supports an objective of having the smallest value, such as when the 
response is impurity or defects.

• The Match Target goal supports the objective when the best value for a response is a 
specific target value, such as a dimension for a manufactured part. The default target value 
is assumed to be midway between the given lower and upper limits.

Note: If your target response is not equidistant from the lower and upper acceptable bounds, 
you can alter the default target after you make a table from the design. In the data table, open 
the Column Info dialog for the response column (Cols > Column Info) and enter the desired 
target value.

Understanding Response Importance Weights 

To compute and maximize overall desirability, JMP uses the value you enter as the importance 
weight (step 4 in Figure 3.1) of each response. If there is only one response, then importance 
weight is unnecessary. With two responses you can give greater weight to one response by 
assigning it a higher importance value.

Adding Simulated Responses, If Desired

If you do not have values for specific responses, you might want to add simulated responses 
to see a prospective analysis in advance of real data collection.

1. Create the design.

2. Before you click Make Table, click the red triangle icon in the title bar and select Simulate 
Responses.

3. Click Make Table to create the design table. The Y column contains values for simulated 
responses.

4. For custom and augment designs, a window (Figure 3.2) appears along with the design 
data table. In this window, enter values you want to apply to the Y column in the data table 
and click Apply. The numbers you enter represent the coefficients in an equation. An 
example of such an equation, as shown in Figure 3.2, would be, 
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y = 28 + 4X1 + 5X2 + random noise, where the random noise is distributed with mean zero and 
standard deviation one.

Figure 3.2  In Custom and Augment Designs, Specify Values for Simulated Responses

How to Enter Factors

To enter factors, follow the steps in Figure 3.3.

1. To add one factor, click Add Factor and select a factor type. Possible factor types are 
Continuous, Discrete Numeric, Categorical, Blocking, Covariate, Mixture, Constant, or 
Uncontrolled. See “Types of Factors” on page 47.

2. Click a factor and select Add Level to increase the number of levels.

3. Double-click a factor to edit the factor name.

4. Click to indicate that changing a factor’s setting from run to run is Easy, Hard, or Very Hard. 
Changing to Hard or Very Hard will cause the resulting design to be a split plot or 
split-split plot design.

5. Click to enter or change factor values. To remove a level, click it, press the delete key on 
the keyboard, then press the Return or Enter key on the keyboard.

6. To add multiple factors, type the number of factors in the Add N Factors box, click the Add 
Factor button, and select the factor type.

Figure 3.3  Entering Factors in a Custom Design

Types of Factors

When adding factors, click the Add Factor button and choose the type of factor.

1

2

3 4 5

6



48 Building Custom Designs Chapter 3
Creating a Custom Design Design of Experiments Guide

Continuous Continuous factors are numeric data types only. In theory, you can set a 
continuous factor to any value between the lower and upper limits you supply.

Discrete Numeric is a numeric factor that can take only a discrete number of values. The 
values have an implied order. The default model effects for a discrete numeric factor 
include polynomial terms through k-1 for a factor with k levels. This is done so the 
optimality and fitting routines take advantage of the multiple levels. If the polynomial 
terms are not included, then a main effects only design is created.

Categorical Either numeric or character data types. Categorical data types have no implied 
order. If the values are numbers, the order is the numeric magnitude. If the values are 
character, the order is the sorting sequence. The settings of a categorical factor are discrete 
and have no intrinsic order. Examples of categorical factors are machine, operator, and 
gender.

Blocking Either numeric or character data types. Blocking factors are a special kind of 
categorical factor. Blocking factors differ from other categorical factors in that there is a 
limit to the number of runs that you can perform within one level of a blocking factor.

Covariate Either numeric or character data types. Covariate factors are not controllable, but 
their values are known in advance of an experiment.

Mixture Mixture factors are continuous factors that are ingredients in a mixture. Factor 
settings for a run are the proportion of that factor in a mixture and vary between zero and 
one.

Constant Either numeric or character data types. Constant factors are factors whose values 
are fixed during an experiment.

Uncontrolled Either numeric or character data types. Uncontrolled factors have values that 
cannot be controlled during an experiment, but they are factors you want to include in the 
model.

Factors that are Easy, Hard, or Very Hard, to Change: Creating Optimal Split-Plot and 
Split-Split-Plot Designs

Split plot experiments are performed in groups of runs where one or more factors are held 
constant within a group but vary between groups. In industrial experimentation this structure 
is desirable because certain factors may be difficult and expensive to change from one run to 
the next. It is convenient to make several runs while keeping such factors constant. Until now, 
commercial software has not supplied a general capability for the design and analysis of these 
experiments.

To indicate the difficulty level of changing a factor’s setting, click in Changes column of the 
Factors panel for a given factor and select Easy, Hard, or Very Hard from the menu that 
appears. Changing to Hard results in a split-plot design and Very Hard results in a 
split-split-plot design.
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See “Creating Split Plot Designs” on page 65, for more details.

Defining Factor Constraints, If Necessary

Sometimes it is impossible to vary factors simultaneously over their entire experimental 
range. For example, if you are studying the affect of cooking time and microwave power level 
on the number of kernels popped in a microwave popcorn bag, the study cannot 
simultaneously set high power and long time without burning all the kernels. Therefore, you 
have factors whose levels are constrained.

To define the constraints:

1. After you add factors and click Continue, click the disclosure button (  on Windows 
and  on the Macintosh) to open the Define Factor Constraints panel.

2. Click the Add Constraint button. Note that this feature is disabled if you have already 
controlled the design region by entering disallowed combinations or chosen a sphere 
radius.

Figure 3.4  Add Constraint

3. Specify the coefficients and their limiting value in the boxes provided, as shown to the 
right. When you need to change the direction of the constraint, click on the default less 
than or equal button and select the greater than or equal to direction.

4. To add another constraint, click the Add Constraint button again and repeat the above 
steps.

To remove a constraint

To remove the last constraint, click the Remove Last Constraint button.

Describe the Model

Initially, the Model panel lists only the main effects corresponding to the factors you entered, 
as shown in Figure 3.5. If a factor is Discrete Numeric, polynomial terms are added by default. 
The higher order terms are defined as estimable If Possible. If you are interested in ensuring 
estimation of these terms, change their Estimability to Necessary (see “Estimability: Necessary 
and If Possible Terms” on page 50).
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Figure 3.5  The Model Window

Adding Terms to the Model

You can add factor interactions or powers of continuous factors to the model. For example, to 
add all the two-factor interactions and quadratic effects at once, click the RSM button. 
Table 3.1 summarizes the ways to add specific factor types to the model.

Estimability: Necessary and If Possible Terms

You can specify Estimability requirements for terms that you add. The custom design that you 
generate will ensure that terms marked Necessary are estimable. If a term is designed as 
If Possible, the custom design algorithm will attempt to make that term estimable, as 
permitted by the number of runs you select. The Bayesian D-Optimal design approach is used 
to obtain precise estimation of all of the Necessary terms while providing omnibus 

Table 3.1  How to Add Terms to a Model

Action Instructions

Add interaction terms involving 
selected factors. If none are 
selected, JMP adds all of the 
interactions to the specified order.

Click the Interactions button and select 2nd, 3rd, 
4th, or 5th. For example, if the factors are X1 and 
X2 and you click Interactions > 2nd, X1*X2 is 
added to the list of model terms.

Add all second-order effects, 
including two-factor interactions 
and quadratic effects

Click the RSM button. The design now uses 
I-Optimality criterion rather than D-Optimality 
criterion.

Add selected cross product terms 1. Highlight the factor names.

2. Highlight term(s) in the model list.

3. Click the Cross button.

Add powers of continuous factors 
to the model effects

Click the Powers button and select 2nd, 3rd, 4th, 
or 5th.
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detectability (and some estimability) for the If Possible terms. For more detail, see “Checking 
for Curvature Using One Extra Run” on page 99 and “Bayesian D-Optimality” on page 129.

Specifying Alias Terms

You can investigate the aliasing between the model terms and terms you specify in the Alias 
Terms panel.

For example, suppose you specify a design with three main effects in six runs, and you want 
to see how those main effects are aliased by the two-way interactions and the three-way 
interaction. In the Alias Terms panel, specify the interactions as shown in Figure 3.6. Also, 
specify six runs in the Design Generation panel.

Figure 3.6  Alias Terms

After you click the Make Design button at the bottom of the Custom Design panel, open the 
Alias Matrix panel in the Design Evaluation panel to see the alias matrix. See Figure 3.7.

Figure 3.7  Aliasing

In this example, all the main effects are partially aliased with two of the interactions. Also see 
“The Alias Matrix (Confounding Pattern)” on page 60.

Select the Number of Runs

The Design Generation panel (Figure 3.8) shows the minimum number of runs needed to 
perform the experiment based on the effects you’ve added to the model. It also shows 
alternate (default) numbers of runs, or lets you choose your own number of runs. Balancing 
the cost of each run with the information gained by extra runs you add is a judgment call that 
you control.
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Figure 3.8  Options for Selecting the Number of Runs

The Design Generation panel has these options for selecting the number of runs you want. For 
details about Group runs into random blocks of size, see “Creating Random Block Designs” on 
page 64.

Number of Center Points Specifies how many additional runs to add as center points to the 
design. A center point is a run that is located in the center of the range of each continuous 
factor.

Number of Replicates Specifies the number of replicate points to add to the design. This does 
not replicate the entire design, but chooses the optimal design points to replicate. One 
replicate increases the number of runs by 1.

Minimum is the smallest number of terms that can create a design. When you use Minimum, 
the resulting design is saturated (no degrees of freedom for error). This is an extreme and 
risky choice, and is appropriate only when the cost of extra runs is prohibitive.

Default is a custom design suggestion for the number of runs. This value is based on 
heuristics for creating balanced designs with a few additional runs above the minimum.

User Specified is a value that specifies the number of runs you want. Enter that value into 
the Number of Runs text box.

Note: In general, the custom design suggests a number of runs that is the smallest number 
that can be evenly divided by the number of levels of each of the factors and is larger than the 
minimum possible sample size.

When the Design Generation panel shows the number of runs you want, click Make Design. 

The Design Report

When you click Make Design, the Custom Design report updates to show the Design report. 
The Design report shows the runs for the design. It also shows the Anticipated Response text 
input column (Figure 3.10). 
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The values in the Anticipated Response column are calculated using the model defined by the 
terms specified in the Power Analysis report. For each run, the Anticipated Coefficients in the 
Power Analysis report are used to calculate the Anticipated Response. When the Design 
report first appears, the calculation of Anticipated Response values is based on the default 
values of the Anticipated Coefficients. See “Power Analysis” on page 54.

You can specify values for the Anticipated Coefficients in the Power Analysis report. When 
you click Apply Changes to Anticipated Coefficients, the Anticipated Response values and 
power calculations are updated. Alternatively, you can specify Anticipated Response values. 
When you click Apply Changes to Anticipated Responses, the Anticipated Coefficients and 
power calculations are updated.

Understanding Design Evaluation

After making the design, you can preview the design and investigate details by looking at 
various plots and tables that serve as design diagnostic tools.

Although different tools are available depending on the model that you specify, most designs 
display these reports:

• Power Analysis

• Prediction Variance Profile

• Fraction of Design Space Plot 

• Prediction Variance Surface

• Estimation Efficiency

• Alias Matrix

• Color Map on Correlations

• Design Diagnostics

These diagnostic tools are available in the Design Evaluation report, as shown in Figure 3.9. 
JMP always provides the Prediction Variance Profile, but the Prediction Surface Plot only 
appears if there are two or more variables. The Alias Matrix only appears if Alias Terms have 
been specified.
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Figure 3.9  Custom Design Evaluation and Diagnostic Tools

Power Analysis

The Power Analysis report gives you a flexible way to explore power. Power is the probability 
of detecting an active effect of a given size. Power depends on the number of runs, the 
estimated error variation, and the significance level. This report helps you evaluate the ability 
of your design to detect effects of practical importance. In particular, you can determine if 
additional runs are necessary.

Power is calculated both for model parameters and for effects. Power calculations are given 
for continuous, discrete numeric, categorical, blocking, mixture, and covariate factors. Power 
is calculated for both Necessary and If Possible model terms. See “How to Enter Factors” on 
page 47 and “Describe the Model” on page 49.

Figure 3.10 shows the Design and Power Analysis reports for a two-factor design that 
estimates both main effects and the interaction. Factor X1 is continuous and factor X2 is a 
four-level categorical factor with levels L1, L2, L3, and L4. The terms in the Parameter column 
in the Power Analysis report that correspond to the three indicator variables for the levels of 
X2 are denoted X2 1, X2 2, and X2 3. The X1*X2 interaction is also a four-level effect. Its 
corresponding indicator variables are denoted X1*X2 1, X1*X2 2, and X1*X2 3.

Beneath the Apply Changes to Anticipated Coefficients button there is a panel that shows 
power calculations for categorical effects that have more than two levels. In this design, the 
categorical effects are the main effect X2 and the interaction effect X1*X2.
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Figure 3.10  Design and Power Analysis Reports

Delta

In the Power Analysis report, the difference that you are interested in detecting is expressed in 
terms of Anticipated Coefficients for model parameters. The difference to detect is usually 
called delta. You can set the value of delta by selecting Advanced Options > Set Delta for 
Power from the Custom Design report’s red triangle menu. By default, Delta is set to two. See 
“Set Delta for Power” on page 79.

Power Analysis Report Options

The following are elements of the Power Analysis report:

Significance Level The probability of rejecting the hypothesis of no effect, if it is true. The 
power calculations update immediately when you enter a value.

Anticipated RMSE An estimate of the square root of the error variation. The power 
calculations update immediately when you enter a value.

Parameter The model term associated with the parameter.
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Anticipated Coefficients A value for the coefficient. This value is used in the calculations for 
Power and for the Anticipated Response column in the Design report. When you set a new 
value in the Anticipated Coefficients column, click Apply Changes to Anticipated 
Coefficients to update Power and Anticipated Response.

Power For the corresponding parameter, the probability of detecting a difference of twice the 
value of the Anticipated Coefficient at the specified Significance Level with error given by 
the Anticipated RMSE.

If your model contains a categorical effect with more than two levels, then the following 
columns appear below the Apply Changes to Anticipated Coefficients button:

Effect The categorical effect.

Power The power calculation for a test of no effect against the alternative that a change of 
delta in the response mean occurs between a single pair of effect levels. The null 
hypothesis for the test is that all model parameters corresponding to the effect are zero.

Power Analysis Interpretation

The Anticipated Coefficient default values are 1 for continuous effects. For categorical effects, 
they are alternating values of 1 and –1. The value of delta, the difference you want to detect, is 
twice the absolute value of the default value of any Anticipated Coefficient. (See “Delta” on 
page 55 and “Set Delta for Power” on page 79.) The default values that are entered as 
Anticipated Coefficients ensure these properties:

• The power calculation for a numeric effect assumes a change of delta in the response mean 
due to linear main effects as the factor changes from the lowest setting to the highest 
setting in the design region.

• The power calculation for the parameter associated with a two-level categorical factor 
assumes a change of delta in the response mean across the levels of the factor.

• The power calculation for a categorical effect with more than two levels is based on the 
multiple degree of freedom F-test for the null hypothesis that all levels have the same 
response mean. Power is calculated at the values of the response means that are 
determined by the Anticipated Coefficients. Various configurations of the Anticipated 
Coefficients can define a difference in levels as large as delta. However, the power values 
for such configurations will differ based on the Anticipated Coefficients for the other 
levels.

Specification of Anticipated Response

You can also explore power by specifying Anticipated Response values in the Design report. 
When you click Apply Changes to Anticipated Responses, the Anticipated Coefficients and 
power calculations in the Power analysis report are updated.
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The Prediction Variance Profile

The example in Figure 3.11 shows the prediction variance profile for a response surface model 
(RSM) with 2 variables and 12 runs. To see a response surface design similar to this:

1. Chose DOE > Custom Design.

2. In the Factors panel, add 2 continuous factors.

3. Click Continue.

4. In the Model panel, click RSM.

5. Click Make Design.

6. Open the Prediction Variance Profile.

Figure 3.11  A Factor Design Layout For a Response Surface Design with 2 Variables

The prediction variance for any factor setting is the product of the error variance and a 
quantity that depends on the design and the factor setting. Before you collect the data the 
error variance is unknown, so the prediction variance is also unknown. However, the ratio of 
the prediction variance to the error variance is not a function of the error variance. This ratio, 
called the relative variance of prediction, depends only on the design and the factor setting 
and can be calculated before acquiring the data. The prediction variance profile plots the 
relative variance of prediction as a function of each factor at fixed values of the other factors 

After you run the experiment, collect the data, and fit the model, you can estimate the actual 
variance of prediction at any setting by multiplying the relative variance of prediction by the 
mean squared error (MSE) of the least squares fit.

It is ideal for the prediction variance to be small throughout the allowable regions of the 
factors. Generally, the error variance drops as the sample size increases. Comparing the 
prediction variance profilers for two designs side-by-side, is one way to compare two designs. 
A design that has lower prediction variance on the average is preferred.

In the profiler, drag the vertical lines in the plot to change the factor settings to different 
points. Dragging the lines reveals any points that have prediction variances that are larger 
than you would like.
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Another way to evaluate a design, or to compare designs, is to try and minimize the maximum 
variance. You can use the Maximize Desirability command on the Prediction Variance Profile 
title bar to identify the maximum prediction variance for a model. Consider the Prediction 
Variance profile for the two-factor RSM model shown in Figure 3.12. The plots identify the 
factor values where the maximum variance (or worst-case scenario) occur, which helps you 
evaluate the acceptability of the model.

Figure 3.12  Find Maximum Prediction Variance

The Fraction of Design Space Plot

The Fraction of Design Space plot is a way to see how much of the model prediction variance 
lies above (or below) a given value. As a simple example, consider the Prediction Variance plot 
for a single factor quadratic model, shown on the left in Figure 3.13. The Prediction Variance 
plot shows that 100% of the values are smaller than 0.5. You can move the vertical trace and 
also see that all the values are above 0.322. 

The Fraction of Design Space plot displays the same information. The X axis is the proportion 
of prediction variance values, ranging from 0 to 100%, and the Y axis is the range of prediction 
variance values. In this simple example, the Fraction of Design plot verifies that 100% of the 
values are below 0.5 and 0% of the values are below approximately 0.3. You can use the 
crosshair tool to find the percentage of values for any value of the prediction variance. The 
example to the right in Figure 3.13 shows that 75% of the prediction variance values are below 
approximately 0.46.

Note: Monte Carlo sampling of the design space is used in constructing the Fraction of Design 
Space Plot. Therefore, plots for the same design may vary slightly.

The Fraction of Design Space Plot is most useful when there are multiple factors. It 
summarizes the prediction variance, showing the fractional design space for all the factors 
taken together.
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Figure 3.13  Variance Profile and Fraction of Design Space

The Prediction Variance Surface

When there are two or more factors, the Prediction Variance Surface plots the surface of the 
prediction variance for any two variables. This feature uses the Graph > Surface Plot platform 
in JMP, and has all its functionality. Drag on the plot to rotate and change the perspective. 
Figure 3.14 shows the Prediction Variance Surface plot for a two-factor RSM model. The 
factors are on the x and y axes, and the prediction variance is on the z axis. You can clearly see 
that there are high and low variance areas for both factors. Compare this plot to the Prediction 
Variance Profile shown in Figure 3.12.

Figure 3.14  Prediction Variance Surface Plot for Two-Factor RSM Model

You can find complete documentation for the Surface Plot platform in the Profilers book.
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Estimation Efficiency

Open the Estimation Efficiency report to show a table giving the Fractional Increase in 
Confidence Interval (CI) Length and Relative Standard (Std) Error of Parameters for each 
model effect.

The Fractional Increase in Confidence Interval Length is:

where

X is the design matrix corresponding to model effects,

 is the ith diagonal entry of ,

n is the number of runs.

These values describe the fractional increase in the length of the confidence interval for a 
parameter compared to its length given by the ideal design. The ideal design is an orthogonal 
design, but an orthogonal design may not exist. For an orthogonal design, the fractional 
increase would be zero. In selecting a design, you would like the increase to be as small as 
possible.

The Relative Std Error of Parameters is:

These values indicate how large the variances of the model’s parameter estimates are, relative 
to the error standard deviation. 

The Alias Matrix (Confounding Pattern)

Click the Alias Matrix disclosure button (  on Windows and  on the Macintosh) to 
open the alias matrix (Figure 3.15).

The alias matrix shows the aliasing between the model terms and the terms you specify in the 
Alias Terms panel (see “Specifying Alias Terms” on page 51). It allows you to see the 
confounding patterns.

Figure 3.15  Alias Matrix

FI n X'X( )ii
1– 1–=

X'X( )ii
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Alias Matrix Formulas

Let X be the design matrix corresponding to the model effects, and Z be the matrix of 
interested effects (the effects you specify in the Alias Terms panel), then the alias matrix is

.

For designs with hard-to-change or very-hard-to-change factors, the alias matrix is

.

where V is a covariance matrix.

For Bayesian designs, the alias matrix is

For Bayesian D-optimal designs, K2 is a diagonal matrix with values of 16 for If Possible 
interaction terms, 1 for other If Possible terms, and 0 for Necessary terms. You can control the 
weights used for If Possible terms by selecting Advanced Options > Prior Parameter Variance 
from the Custom Design report’s red triangle menu. There you can set prior variances for all 
model terms by specifying the diagonal elements of K.

Color Map on Correlations

The Color Map On Correlations panel (see Figure 3.16) shows the correlations between all 
model terms and alias terms you specify in the Alias Terms panel (see “Specifying Alias 
Terms” on page 51). The colors correspond to the absolute value of the correlations.

Figure 3.16  Color Map of Correlations

A X'X( ) 1– X'Z=
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The Design Diagnostics Table

Open the Design Diagnostics outline node to display a table with relative D-, G-, and 
A-efficiencies, average variance of prediction, and length of time to create the design. The 
design efficiencies are computed as follows:

where 

• ND is the number of points in the design

• p is the number of effects in the model including the intercept

• σM is the maximum standard error for prediction over the design points.

Note: The G-Efficiency is calculated using Monte Carlo sampling of the design space. 
Therefore, calculations for the same design may vary slightly.

These efficiency measures are single numbers attempting to quantify one mathematical 
design characteristic. While the maximum efficiency is 100 for any criterion, an efficiency of 
100% is impossible for many design problems. It is best to use these design measures to 
compare two competitive designs with the same model and number of runs rather than as 
some absolute measure of design quality.

Figure 3.17  Custom Design Showing Diagnostics

Specify Output Options

Use the Output Options panel to specify how you want the output data table to appear.

D-efficiency = 100 1
ND
-------- X′X 1 p/
 
 

A-efficiency = 100
p

trace ND X′X( ) 1–( )
------------------------------------------------
 
 
 

G-efficiency = 100
p

ND

-------

σM
-----------
 
 
 
 
 
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Figure 3.18  Output Options Panel

Run Order lets you designate the order you want the runs to appear in the data table when it is 
created. Choices are:

Keep the Same the rows (runs) in the output table will appear as they do in the Design 
panel.

Sort Left to Right the rows (runs) in the output table will appear sorted from left to right.

Randomize the rows (runs) in the output table will appear in a random order.

Sort Right to Left the rows (runs) in the output table will appear sorted from right to left.

Randomize within Blocks the rows (runs) in the output table will appear in random order 
within the blocks you set up.

Make the JMP Design Table

When the Design panel shows the layout you want, click Make Table. Parts of the table contain 
information you might need to continue working with the table in JMP. The upper-left of the 
design table can have one or more of the following scripts:

• a Screening script runs the Analyze > Modeling > Screening platform when appropriate for 
the generated design.

• a Model script runs the Analyze > Fit Model platform with the model appropriate for the 
design.

• a constraint script that shows any model constraints you entered in the Define Factor 
Constraints panel of the Custom Design dialog.

• a DOE Dialog script that recreates the dialog used to generate the design table, and 
regenerates the design table.
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Figure 3.19  Example Design Table

1. This area identifies the design type that generated the table. Click Custom Design to edit 
the name.

2. Model is a script. Click the red triangle icon and select Run Script to open the Fit Model 
dialog, which is used to generate the analysis appropriate to the design.

3. DOE Dialog is a script. Click the red triangle icon and select Run Script to recreate the DOE 
Custom Dialog and generate a new design table.

Creating Random Block Designs

It is often necessary to group the runs of an experiment into blocks. Runs within a block of 
runs are more homogeneous than runs in different blocks. For example, the experiment 
described in Goos (2002), describes a pastry dough mixing experiment that took several days 
to run. It is likely that random day-to-day differences in environmental variables have some 
effect on all the runs performed on a given day. Random block designs are useful in situations 
like this, where there is a non-reproducible shock to the system between each block of runs. In 
Goos (2002), the purpose of the experiment was to understand how certain properties of the 
dough depend on three factors: feed flow rate, initial moisture content, and rotational screw 
speed. It was only possible to conduct four runs a day. Because day-to-day variation was 
likely, it was important to group the runs so that this variation would not compromise the 
information about the three factors. Thus, blocking the runs into groups of four was necessary. 
Each day's experimentation was one block. The factor, Day, is an example of a random block 
factor.

To create a random block, use the custom design and enter responses and factors, and define 
your model as usual. In the Design Generation panel, check the Group runs into random 
blocks of size check box and enter the number of runs you want in each block. When you 
select or enter the sample size, the number of runs specified are assigned to the blocks.

1

2

3
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Figure 3.20  Assigning Runs to Blocks

In this example, the Design Generation Panel shown here designates four runs per block, and 
the number of runs (12) indicates there will be three days (blocks) of 4 runs. If the number of 
runs is not an even multiple of the random block size, some blocks will have fewer runs than 
others.

Creating Split Plot Designs

Split plot experiments happen when it is convenient to run an experiment in groups of runs 
(called whole plots) where one or more factors stay constant within each group. Usually this is 
because these factors are difficult or expensive to change from run to run. JMP calls these 
factors Hard to change because this is usually how split plotting arises in industrial practice.

In a completely randomized design, any factor can change its setting from one run to the next. 
When certain factors are hard to change, the completely randomized design may require more 
changes in the settings of hard-to-change factors than desired.

If you know that a factor or two are difficult to change, then you can set the Changes setting of 
a factor from the default of Easy to Hard. Before making the design, you can set the number of 
whole plots you are willing to run.

For an example of creating a split plot design, see “Creating a Design with Two 
Hard-to-Change Factors: Split Plot” on page 123.

To create a split plot design using the custom designer:

1. In the factors table there is a column called Changes. By default, changes are Easy for all 
factors. If, however, you click in the changes area for a factor, you can choose to make the 
factor Hard to change.

2. Once you finish defining the factors and click continue, you see an edit box for supplying 
the number of whole plots. You can supply any value as long as it is above the minimum 
necessary to fit all the model parameters. You can also leave this field empty. In this case, 
JMP chooses a number of whole plots to minimize the omnibus uncertainty of the fixed 
parameters.
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Note: If you enter a missing value in the Number of Whole Plots edit box, then JMP considers 
many different numbers of whole plots and chooses the number that maximizes the 
information about the coefficients in the model. It maximizes the determinant 
of where V 

-1 is the inverse of the variance matrix of the responses. The matrix, V, is a 
function of how many whole plots there are, so changing the number of whole plots changes 
V, which can make a difference in the amount of information a design contains.

To create a split plot design every time you use a certain factor, save steps by setting up that 
factor to be “hard” in all experiments. See “Identify Factor Changes Column Property” on 
page 85, for details.

Creating Split-Split Plot Designs

Split-split plot designs are a three stratum extension of split plot designs. Now there are 
factors that are Very-Hard-to-change, Hard-to-change, and Easy-to-change. Here, in the top 
stratum, the Very-Hard-to- change factors stay fixed within each whole plot. In the middle 
stratum the Hard-to-change factors stay fixed within each subplot. Finally, the Easy-to-change 
factors may vary (and should be reset) between runs within a subplot. This structure is natural 
when an experiment covers three processing steps. The factors in the first step are 
Very-Hard-to-change in the sense that once the material passes through the first processing 
stage, these factor settings are fixed. Now the material passes to the second stage where the 
factors are all Hard-to-change. In the third stage, the factors are Easy-to-change.

Schoen (1999) provides an example of three-stage processing involving the production of 
cheese that leads to a split-split plot design. The first processing step is milk storage. Typically 
milk from one storage facility provides the raw material for several curds processing units—
the second processing stage. Then the curds are further processed to yield individual cheeses.

In a split-split plot design the material from one processing stage passes to the next stage in 
such a way that nests the subplots within a whole plot. In the example above, milk from a 
storage facility becomes divided into two curds processing units. Each milk storage tank 
provided milk to a different set of curds processors. So, the curds processors were nested 
within the milk storage unit.

Figure 3.21 shows an example of how factors might be defined for the cheese processing 
example.

X ′V 1– X
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Figure 3.21  Example of Split-Split Response and Factors in Custom Designer Dialog

Creating Strip Plot Designs

In a strip plot design it is possible to reorder material between processing stages. Suppose 
units are labelled and go through the first stage in a particular order. If it is possible to collect 
all the units at the end of the first stage and reorder them for the second stage process, then the 
second stage variables are not nested within the blocks of the first stage variables. For 
example, in semiconductor manufacturing a boat of wafers may go through the first 
processing step together. However, after this step, the wafers in a given boat may be divided 
among many boats for the second stage.

To set up a strip plot design, enter responses and factors as usual, designating factors as Very 
Hard, Hard, or Easy to change. Then, in the Design Generation panel, check the box that says 
Hard to change factors can vary independently of Very Hard to change factors, as shown in 
Figure 3.22. Note that the Design Generation panel specified 6 whole plots, 12 subplots, and 24 
runs.

When you click Make Design, the design table on the right in Figure 3.22 lists the run with 
subplots that are not nested in the whole plots.
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Figure 3.22  Example of Strip Split Factors and Design Generation panel in Custom Designer 
Dialog

Special Custom Design Commands

After you select DOE > Custom Design, click the red triangle icon on the title bar to see the list 
of commands available to the Custom designer (Figure 3.23). The commands found on this 
menu vary, depending on which DOE command you select. However, the commands to save 
and load responses and factors, and the command to set the random seed are available to all 
designers. You should examine the red triangle menu for each designer you use to determine 
which commands are available. If a designer has additional commands, they are described in 
the appropriate chapter.
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Figure 3.23  Click the Red Triangle Icon to Reveal Commands

The following sections describe these menu commands and how to use them.

Save Responses and Save Factors

If you plan to do further experiments with factors and/or responses to which you have given 
meaningful names and values, you can save them for later use.

To save factors or responses:

1. Select a design type from the DOE menu.

2. Enter the factors and responses into the appropriate panels (see “Enter Responses and 
Factors into the Custom Designer” on page 45, for details).

3. Click the red triangle icon on the title bar and select Save Responses or Save Factors.

Save Responses creates a data table containing a row for each response with a column called 
Response Name that identifies the responses. Four additional columns identify more 
information about the responses: Lower Limit, Upper Limit, Response Goal, and Importance.

Save Factors creates a data table containing a column for each factor and a row for each 
factor level. The columns have two column properties (noted with asterisks icons in the 
column panel). These properties include:

Design Role that identifies the factor as a DOE factor and lists its type (continuous, 
categorical, blocking, and so on).

Factor Changes that identifies how difficult it is to change the factor level. Factor Changes 
options are Easy, Hard, and Very Hard.

4. Save the data table.
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Load Responses and Load Factors

If you have saved responses and factors, you can quickly apply them to your design and avoid 
retyping this information each time you run an experiment.

To design an experiment using responses or factors you have previously saved:

1. Open the data table that contains the factor names and levels.

2. Select a design type from the DOE menu.

3. Click the red triangle icon on the title bar and select Load Responses or Load Factors.

Tip: It is possible to create a factors table by keying data into an empty table, but remember to 
assign each column a factor type. Do this by right-clicking the column name, selecting Column 
Info, and then selecting Column Properties > Design Role. Lastly, click the button in the Design 
Role area and select the appropriate role.

Save Constraints and Load Constraints

In custom, augment, and mixture designs, if you set up factor constraints and plan to do 
further experiments with them, you can save them for later use. You can quickly apply these 
constraints to your design and avoid retyping this information each time you run an 
experiment.

To save factor constraints:

1. Select a design type from the DOE menu.

2. Enter the factor constraints into the appropriate panels (see “Enter Responses and Factors 
into the Custom Designer” on page 45, for details).

3. Click the red triangle icon on the title bar and select Save Constraints. Save Constraints 
creates a data table that contains the information you enter into a constraints panel. There 
is a column for each constraint. Each has a column property called Constraint State that 
identifies it as a ‘less than’ or a ‘greater than’ constraint. There is a row for each variable 
and an additional row that has the inequality condition for each variable.

4. Save the data table.

To design an experiment using factor constraints you have previously saved:

1. Open the data table that contains the constraints.

2. Select a design type from the DOE menu.

3. Click the red triangle icon on the title bar and select Load Constraints.
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Set Random Seed: Setting the Number Generator

The design process begins with a random starting design. To set the random seed that the 
custom designer uses to create this starting design, click the red triangle icon in the design title 
bar and select Set Random Seed.

The window that appears shows the generating seed for that design (Figure 3.24). From this 
window, you can set a new random number and then run the design again.

If you use the same seed as a previous design, you will get the same design again.

Figure 3.24  Setting the Random Seed

Note: The random seed is also used when you simulate responses to be used with a design, as 
described next.

Simulate Responses

Often, when you define a custom design (or any standard design), it may be useful to look at 
properties of the design with response data before you have collected data. The Simulate 
Responses command adds random response values to the JMP table that the custom designer 
creates. To use the command, select it before you click Make Table. When you click Make Table 
to create the design table, the Y column contains values for simulated responses.

For custom and augment designs, an additional window appears with the design data table 
that lists coefficients for the design you described in the designer panels. You can enter any 
coefficient values you want and click Apply to see new Y values in the data table. An example 
of an equation for a model with two factors and interaction (Figure 3.25) would be, 

y = 21 + 4X1 + 6X2 – 5X1X2 + random noise, 

where the random noise is distributed with mean zero and standard deviation one.
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Figure 3.25  Example of a Custom Design with Simulated Responses

Save X Matrix

This sections describes how to view the Number of Rows in the Moments Matrix and the 
Design Matrix (X) in the Log.

To create scripts for the Moments Matrix and the Design Matrix, and to save these matrices as 
table properties in the data table that will be generated from the design, click the red triangle 
icon in the Custom Design title bar (Figure 3.23) and select Save X Matrix. After the design and 
table are created, two scripts are saved as table properties and are called the Moments Matrix 
and the Design Matrix. 

Each script can be selected and run from the upper left panel of the resulting data table. 
Results from running each of the scripts are shown in the Log. When you run the script for the 
Moments Matrix, JMP shows the number of rows for the global matrix, called Moments, in the 
Log. Similarly, when you run the script for the Design Matrix, JMP displays the number of 
rows for the global matrix, called X, in the Log. The Moments Matrix and the Design Matrix 
are used to calculate the Average Variance of Prediction, shown in the Design Diagnostics 
section of the Design Evaluation. 

Saving these scripts to the data table provides an easy way to remember and recreate your 
design at a later time and to compare the matrices values with alternate designs. If you do not 
have the log visible, select View > Log (Window > Log on the Macintosh). To illustrate these 
features:

1. Select DOE > Custom Design.

2. Add 3 continuous factors and click Continue.

3. Click on Interactions > 2nd and select Save X Matrix from the drop-down menu of Custom 
Design.

4. Using the Default Number of Runs (12), click Make Design and then Make Table.

5. If it is not already open, select View > Log (Window > Log on the Macintosh).
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6. Click on the Moments Matrix red triangle in the upper left panel of the data table under 
Custom Design and select Run Script. The result shows in the log as N Row(::Moments):7, 
which is the number of rows in the global matrix called Moments. The Moments Matrix is 
dependent upon the model effects but is independent of the design. (The model effects can 
be viewed by clicking the red triangle by Model in the upper left panel of the data table 
and clicking on Run Script.) The Moments Matrix script for this example displays the 
value of each moment and is shown by clicking on the red triangle of the Moments Matrix 
and selecting Edit:
Moments = [1 0 0 0 0 0 0,
0 0.333333333333333 0 0 0 0 0,
0 0 0.333333333333333 0 0 0 0,
0 0 0 0.333333333333333 0 0 0,
0 0 0 0 0.111111111111111 0 0,
0 0 0 0 0 0.111111111111111 0,
0 0 0 0 0 0 0.111111111111111];

7. Click on the Design Matrix red triangle in the upper left panel of the data table under 
Custom Design and select Run Script. The result shows in the log as N Row(::X):8, which 
is the number of rows in the global matrix called X. The X Matrix is dependent upon the 
design for the experiment. The script for this example shows the underlying design of the 
X matrix and is viewed by clicking on the red triangle of the Design Matrix and selecting 
Edit:
X = [1 -1 1 -1 -1 1 -1,
1 1 1 1 1 1 1,
1 -1 -1 -1 1 1 1,
1 1 -1 -1 -1 -1 1,
1 1 1 -1 1 -1 -1,
1 1 -1 1 -1 1 -1,
1 -1 1 1 -1 -1 1,
1 -1 -1 1 1 -1 -1];

Note that the Moments Matrix is defined as:

where M is a moments matrix of the parameter space that is independent of the design and 
can be computed in advance, and where f(x)' denotes a row of the design matrix 
corresponding to factor combinations of x. For additional details concerning moments and 
design matrices, see Myers, Montgomery, and Anderson-Cook (2009, pp. 365-371). Note that 
the moment matrix is called a matrix of region moments in this book. The design matrix is also 
called the model matrix in some books (Goos and Jones, 2011).

M f x( )f x( )' xd
R
=
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Optimality Criterion

To change the design criterion, click the red triangle icon in the Custom Design title bar 
(Figure 3.23) and select Optimality Criterion, then choose one of the options:

• Make D-Optimal Design

• Make I-Optimal Design

• Make Alias Optimal Design

The default criterion for Recommended is D-optimal for all design types unless you have used 
the RSM button in the Model panel to add effects that make the model quadratic. For specific 
information about optimality criterion, see “Technical Discussion” on page 128.

Number of Starts: Changing the Number of Random Starts

To override the default number of random starts, click the red triangle icon in the Custom 
Design title bar (Figure 3.23) and select Number of Starts. When you select this command, the 
window shown in Figure 3.26 appears with an edit box for you to enter the number of random 
starts for the design you want to build. The number you enter overrides the default number of 
starts, which varies depending on the design.

Figure 3.26  Selecting the Number of Starts

Note: If the design iterations are taking too long, click the Cancel button. The Custom 
Designer stops and gives the best design found at that point.

Why Change the Number of Starts?

One difficulty with the creation of optimal designs is that the methods used do not always 
find the globally optimal design in cases where the optimal design is known from theory. For 
example, orthogonal designs are D-optimal with respect to a linear additive model and a cubic 
design space.

As the number of factors and sample size increase, the optimization problem becomes harder. 
It is easy for an optimizer to converge to a local optimum instead of a global optimum.

It is useful to know that:

• If random starts are used for the optimization, the design produced at the end is not 
always the same. Increasing the number of random starts tends to improve the optimality 
of the resulting design.
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• For designs with all two-level factors, there is a formula for the optimal determinant. If the 
determinants that result from the random starts match that optimal determinant, the 
algorithm stops. The design is D-optimal and orthogonal.

Default Choice of Number of Random Starts: Technical Information

JMP does not start over with random designs until a jackpot is hit. The time it takes for one 
iteration of the algorithm (coordinate exchange) increases roughly as the product of the 
sample size and the number of terms in the model increases. By doing a large number of 
random starts for small sample sizes and reducing this number proportional to the square of 
the sample size as the designs get larger, the total time it takes to generate a design is kept 
roughly constant over the range of usual sample sizes.

The Custom Designer always attempts to find globally optimal designs when such designs are 
known from theory. For example, 

• 2-level fractional factorial designs are globally D-optimal for all main effect and two-factor 
interaction models

• Latin-Square designs are D-optimal for main effect models assuming the right sample size 
and numbers of levels of the factors.

• Plackett-Burman designs are D-optimal for main effect models.

If the custom designer can identify one of these special cases, it does many more random 
starts. In general, however, the default number of random starts is controlled by the sample 
size, n, as follows: 

Note the following exceptions:

• If each factor has only two levels, the number of terms in the model is one greater than the 
number of factors, and the sample size is a multiple of 4, then multiply the default number 
of starts shown in the table above by 40.

– If the number of runs is exactly 32 and all factors have 2-levels, then the default 
Number of Starts in Table 3.2 is 15.

Table 3.2  Sample Size and Random Starts

Sample Size Number of Starts

9 or fewer 80

from 10 to 16 40

from 17 to 24 10

from 25 to 32 5

more than 32 2
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• If the design could be a Latin Square, the Custom Designer does 1000 random starts.

• If the number of terms in the model is greater than 100, though, the number of random 
starts is 1.

After each random start, the design is checked to see if it is globally optimal, and if so, the 
iterations stop. Therefore, even if the default number of starts is large, it may only take a small 
fraction of the default number to find the globally optimal design. Again, if the process seems 
to be taking too long, use the Cancel button to see the best design found at that point.

Sphere Radius: Constraining a Design to a Hypersphere

You can constrain custom and augmented designs to a hypersphere by editing the sphere 
radius. Before making the design, click the red triangle icon in the Custom Design title bar 
(Figure 3.23) and select Sphere Radius. Enter the appropriate value and click OK.

Note that hypersphere constraints do not work with other constraints. Also, split plot designs 
cannot be generated with hypersphere constraints.

If you have designed any factor’s changes as Hard (see “Factors that are Easy, Hard, or Very 
Hard, to Change: Creating Optimal Split-Plot and Split-Split-Plot Designs” on page 48, and 
“Creating Random Block Designs” on page 64), the sphere radius item becomes unavailable. 
Conversely, once you set the sphere radius, you cannot make a factor Hard to change.

Disallowed Combinations: Accounting for Factor Level Restrictions

JMP gives you the flexibility to disallow particular combinations of levels of factors. You can 
do this for custom and augmented designs except for experiments with mixture or blocking 
factors. This feature can also be used with continuous factors or mixed continuous and 
categorical factors.

For example, in a market research choice experiment, you might want to exclude a choice that 
allows all the best features of a product at the lowest price. In this case, the factor Feature has 
levels of worst (1), medium (2), and best (3), and the factor Price has levels of high (1), medium 
(2), and low (3). You want to exclude the third Feature level (best) and the third Price level 
(low).

To disallow a combination of factor levels:

1. Begin by adding the factors.

2. Click the red triangle icon in the title bar (Figure 3.23) of the designer window and select 
Disallowed Combinations. Note that this menu item is not available if you have already 
defined linear inequality constraints.

3. Enter a Boolean expression that identifies what you do not want allowed (Figure 3.27). 
JMP evaluates your expression, and when it sees it as true, it disallows the specified 
combination.
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Note: When forming the expression, use the ordinal value of the level instead of the name of 
the level. If the level names of the factor called Price are high, medium, and low, their 
associated ordinal values are 1, 2, and 3.

For example, in Figure 3.27, Feature==3 & Price==3 will not allow a run containing the 
best features at the lowest price. If there were two disallowed combinations in this 
example, you would use Feature==3 & Price==3 | Quality==3 & Price==3, which tells 
JMP to disallow a run with the best features at the lowest price or a run with the best 
quality and lowest price.

Figure 3.27  Enter a Boolean Expression

4. Make the design. It excludes the combination of factors you specified, as shown in 
Figure 3.28.

Figure 3.28  No Row Contains L3 for Both Price and Feature

Advanced Options for the Custom Designer

Select Advanced Options from the Custom Design red triangle menu to select the following 
options.

Mixture Sum

The sum of the mixture components can be set to any positive value. In particular, if you want 
to keep a component of a mixture constant throughout an experiment, you can set the sum of 
the other mixture components to the appropriate value. To alter the mixture sum:

1. Select DOE > Custom Design.
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2. Click the red triangle icon in the title bar (Figure 3.23) of the designer window and select 
Advanced Options > Mixture Sum.

3. Enter a positive number and click OK.

4. Make the design.

Split Plot Variance Ratio

The optimal split plot design depends on the ratio of the variance of the random whole plot 
variance to the error variance. By default, this variance is set to one. If you have some prior 
knowledge of this variance ratio, you can supply it by following these steps:

1. Select DOE > Custom Design.

2. Define Easy and Hard-to-change factors for your split plot design. Or enter Easy, Hard, 
and Very Hard-to-change factors for your split-split plot design.

3. Click the red triangle icon in the title bar (Figure 3.23) of the designer window and select 
Advanced Options > Split Plot Variance Ratio.

4. In the entry field, enter one or two positive numbers, depending on whether you have 
specified a split plot or a split-split plot design. Click OK.

5. Make the design.

Prior Parameter Variance

If you have specified If Possible as the Estimability for any factors in your model, then you can 
use this option to also specify the weight used for these terms. Default values are one. Larger 
values represent more prior information and a smaller variance. Variances are the reciprocals 
of the entered values.

1. Select DOE > Custom Design.

2. Click the red triangle icon in the title bar (Figure 3.23) of the designer window and select 
Advanced Options > Prior Parameter Variance.

3. Enter a positive number for each of the terms for which you want to specify a weight and 
click OK.

4. Make the design.

D Efficiency Weight

Specify the relative importance of D-Efficiency (reducing the variance of the coefficients) 
versus aliasing reduction. Values should be between 0 and 1, with larger values weighting 
more toward D-Efficiency.
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Set Delta for Power

Specify the difference in the mean response that you want to detect for model effects. Power 
calculations are presented in the Power Analysis report, found under Design Evaluation. In 
this report, power is calculated for each model parameter based on detecting the specified 
difference of delta. For categorical effects, a power calculation is provided that is based on 
detecting a maximum change of delta between any two levels.

By default, delta is set to 2. The default coefficient for each continuous effect is set to 1. An 
n-level categorical factor is represented by n–1 indicator variables. The default coefficients for 
the n–1 terms representing a categorical factor are alternating values of 1 and -1. The default 
coefficients for an interaction effect with more than one degree of freedom are also alternating 
values of 1 and -1.

Note: The order in which parameters appear in the Power Analysis report may not be 
identical to their order in the Parameter Estimates report obtained using Standard Least 
Squares. This difference can only occur when the model contains an interaction with more 
than one degree of freedom.

Given a specified value of delta, each coefficient in the Anticipated Coefficients list is set at 
delta/2 multiplied by the default coefficient. For a continuous factor, this assignment ensures 
that a difference of delta is detected with the calculated power. For a categorical factor, this 
assignment of coefficients ensures that a maximum difference of delta between any two levels 
is detected with the calculated power.

Save Script to Script Window

This command creates the script for the design you described in the Custom Designer and 
saves it in an open script window.

Assigning Column Properties

Columns in a data table can contain special column properties. Figure 3.29 shows that a 
column called Stretch has two special properties: Role and Response Limits, that were 
assigned by the Custom Designer when the table was created. To see the example in 
Figure 3.29, open Bounce Data.jmp from the Design Experiment folder found in the sample data 
installed with JMP. Then, right-click the column name in the data table and select Column Info. 
When the Column Info dialog appears, click on the property you want to see.
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Figure 3.29  Column Properties Menu in the Column Info Dialog

All special column properties are covered in the Using JMP. The following discussion gives 
details about properties specific to DOE and that are useful for analyzing DOE data.

Define Low and High Values (DOE Coding) for Columns

For continuous variables, the Coding column property transforms data in the range you 
specify from –1 to +1. When you analyze the coded variable, JMP uses those transformed data 
values to compute meaningful parameter estimates. You can specify the range in which the 
low and high values of the column are transformed.

By default, when JMP generates a design table from values entered in the Factors panel, it uses 
those values as the low and high values of the coding property. If a column has one or more 
limits missing, JMP substitutes the data’s minimum and maximum for the high and low 
values.

You can use the Column Info dialog to manually add or delete a coding property, or change 
the range in which the low and high values are transformed. Figure 3.30 shows the coding 
values for the Temperature variable in the Reactor 8 Runs data table from the Design 
Experiment Sample Data.
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Figure 3.30  Coding Column Property in Column Info Dialog

Set Columns as Factors for Mixture Experiments

You might have a column in a data table that is one of several factors that form 100% of a 
mixture. You can set up the column so JMP uses it to automatically generate a no-intercept 
model when you analyze the data with the Fit Model platform. The following example uses 
the Donev Mixture Data from the Design Experiment sample data.

To set up the CuS04 column as a mixture factor, first select Cols > Column Info to see the 
Column Info dialog for CuS04. Then continue as follows:

1. Select Mixture from the Column Properties drop-down menu. Upper and Lower limits, and 
the sum of the limits appear in a panel on the dialog, as shown in Figure 3.31. You can use 
these limits, or enter your own values.

2. Optionally, check the boxes beside L PseudoComponent Coding, U PseudoComponent 
Coding, or both L and U PseudoComponent Coding. Using the example in Figure 3.31, 
where the mixture sum value is 1, the terms are coded as:

 for the L pseudocomponent 

 for the U pseudocomponent 

where Li and Ui are the lower and upper bounds, L is the sum of Li and U is the sum of Ui.

XiL Xi Li–( ) 1 L–( )⁄=

XiU Ui Xi–( ) U 1–( )⁄=
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Note: If you check either L PseudoComponent Coding or U PseudoComponent Coding for the 
mixture coding of one mixture factor and you check the other alternative for one or more other 
mixture factors in the model, of if you check both boxes for one or more of the mixture factors, 
the Fit Model platform uses the L coding if (1 – L) < (U – 1), and the U coding otherwise. If only 
one coding box is checked consistently for all mixture factors in the model, then only that one 
pseudocomponent coding is used.

In the Fit Model report, the main effects are labeled with the coding transformation. 
Crossed effects are not labeled, but coding values are used. All the features of fitting, such 
as the profilers and saved formulas, respect the pseudocomponent coding but present the 
un-coded values in the tables and plots.

3. Select the Design Role Column Property, and choose Mixture from its drop down menu.

4. Click OK. The properties icon ( ) now appears next to the column name in the columns 
panel, indicating the column contains one or more column properties.

Figure 3.31  Column Info to Create Mixture Column For Analysis

5. Repeat the above steps for any other mixture factors that will be included in the model.



Chapter 3 Building Custom Designs 83
Design of Experiments Guide Assigning Column Properties

Define Response Column Values

You can save response limits in a column, which means you can run analyses without having 
to re-specify response limits each time. Saving these limits in a column facilitates consistency. 
For example, if you run an analysis that employs these limits, then come back later and change 
the data, you can run a new analysis using the same limits without having to reenter them. To 
see the example in Figure 3.32, open Bounce Data.jmp from the Design Experiment folder in the 
sample data installed with JMP.

Figure 3.32 shows the panel with values that specify lower, middle, and upper limits, and a 
desirability value. You can also select a possible goal for a DOE response variable: Maximize, 
Match Target, Minimize, or None. If you have more than one response, you can enter an 
importance value, which lets JMP know how to weigh the importance of one response against 
another.

To enter response limits:

1. Click the column name Stretch in the data grid and select Cols > Column Info. The Column 
Info dialog appears.

2. Select Response Limits from the Column Properties drop-down menu.

3. Select a goal for the response variable. For example, if you are in the prediction profiler 
and want the desired value to be close to 450, select Match Target.

4. When you have two responses, enter a number in the Importance box to indicate the 
amount of weight you want this response to have when JMP computes the overall 
desirability.

5. Enter the lower, middle and upper limits as well as the desirability values.
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Figure 3.32  Completed Response Limits

6. Click OK. The properties icon ( ) now appears next to the column name in the column 
panel of the data table to indicate that the column contains a property.

Assign Columns a Design Role

The Custom designer in JMP assigns design roles to factors when you create the design. 
However, you can assign a property to a column that identifies a factor column as a 
continuous, categorical, blocking, covariate, mixture, constant, signal, or noise factor. The 
example in Figure 3.33 shows the Whole Plots factor in the Vinyl Data.jmp table from the Design 
Experiment sample data assigned the Random Block design role.

To give a column a design role:

1. Click the column name in the data grid then select Cols > Column Info. The Column Info 
window appears.

2. Select Design Role from the Column Properties drop-down menu, as shown in Figure 3.33. 
Design role information appears on the right.

3. Click the Design Role drop-down menu and select how you want JMP to use the factor 
column: Continuous, Categorical, Blocking, Covariate, Mixture, Constant, Signal, Noise, 
Uncontrolled, Random Block, or Discrete Numeric.

4. Click OK to see the property icon ( ) next to the column name in the data table’s column 
panel.
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Figure 3.33  Assign a Design Role to a Factor Column

Note: Although you can save design roles for factors, which are then automatically used each 
time those factors are loaded, you must always verify that the model for the design you create 
is correctly entered into the DOE custom designer.

Identify Factor Changes Column Property

To create split plot or split-split plot designs, you must identify a factor as having values that 
are hard to change, or very hard to change. This is done in the DOE design panel (see 
“Creating Split Plot Designs” on page 65, for details) each time you design an experiment. 
However, if you know that every time you use that factor, you want it to be considered hard or 
very hard to change, you can save yourself steps by setting up a column property to be used in 
all experiments using that factor. To do this:

1. Click the column name in the data grid and then select Cols > Column Info to see the 
Column Info dialog for that column.

2. Select Factor Changes from the Column Properties drop-down menu, as shown in 
Figure 3.34.

3. Click the Factor Changes button and select Easy, Hard, or Very Hard from the Factor 
Changes drop-down menu.

4. Click OK. The properties icon ( ) now appears next to the column name in the column 
panel of the data table.
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Figure 3.34  Factor Changes Column Property

How Custom Designs Work: Behind the Scenes

The custom designer starts with a random set of points inside the range of each factor. The 
computational method is an iterative algorithm called coordinate exchange (Meyer and 
Nachtsheim, 1995). Each iteration of the algorithm involves testing every value of every factor 
in the design to determine if replacing that value increases the optimality criterion. If so, the 
new value replaces the old. This process continues until no replacement occurs for an entire 
iteration.

To avoid converging to a local optimum, the whole process is repeated several times using a 
different random start. The custom designer displays the best of these designs. For more 
details, see the section “Optimality Criterion” on page 74.

Sometimes a design problem can have several equivalent solutions. Equivalent solutions are 
designs with equal precision for estimating the model coefficients as a group. When this is 
true, the design algorithm may generate different (but equivalent) designs when you click the 
Back and Make Design buttons repeatedly. 



Chapter 4
Examples Using the Custom Designer

The use of statistical methods in industry is increasing. Arguably, the most cost-beneficial of 
these methods for quality and productivity improvement is statistical design of experiments. 
A trial-and -error search for the vital few factors that most affect quality is costly and 
time-consuming. The purpose of experimental design is to characterize, predict, and then 
improve the behavior of any system or process. Designed experiments are a cost-effective way 
to accomplish these goals.

JMP’s custom designer is the recommended way to describe your process and create a design 
that works for your situation. To use the custom designer, you first enter the process variables 
and constraints, then JMP tailors a design to suit your unique case. This approach is more 
general and requires less experience and expertise than previous tools supporting the 
statistical design of experiments. 

Custom designs accommodate any number of factors of any type. You can also control the 
number of experimental runs. This makes custom design more flexible and more cost effective 
than alternative approaches.

This chapter presents several examples showing the use of custom designs. It shows how to 
drive its interface to build a design using this easy step-by-step approach:

Figure 4.1  Approach to Experimental Design

For an overview of using the custom designer, see the “Building Custom Designs” chapter on 
page 43.

Describe Design Collect Fit Predict

Key mathematical steps: appropriate 
computer-based tools are empowering.

Key engineering steps: process knowledge and 
engineering judgement are important.

Identify factors 
and responses.

Compute design 
for maximum 
information from 
runs.

Use design to set 
factors: measure 
response for each 
run.

Compute best fit 
of mathematical 
model to data 
from test runs.

Use model to find 
best factor settings 
for on-target 
responses and 
minimum variability.
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Creating Screening Experiments

You can use the screening designer in JMP to create screening designs, but the custom 
designer is more flexible and general. The straightforward screening examples described 
below show that ‘custom’ does not mean ‘exotic.’ The custom designer is a general purpose 
design environment that can create screening designs.

Creating a Main-Effects-Only Screening Design

To create a main-effects-only screening design using the custom designer:

1. Select DOE > Custom Design.

2. Enter six continuous factors into the Factors panel. Figure 4.2 shows the six factors.

3. Click Continue. The default model contains only the main effects.

4. Using the default of 12 runs, click Make Design. 

5. Click the disclosure button (  on Windows and  on the Macintosh) to open the 
Design outline node.

Note: The result is a resolution-three screening design. All the main effects are estimable, but 
they are confounded with two factor interactions.

Figure 4.2  A Main-Effects-Only Screening Design
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6. Click the disclosure buttons beside Design Evaluation and then beside Alias Matrix (  
on Windows and  on the Macintosh) to open the Alias Matrix. Figure 4.3 shows the 
Alias Matrix, which is a table of zeros, ones, and negative ones.

The Alias Matrix shows how the coefficients of the constant and main effect terms in the 
model are biased by any active two-factor interaction effects not already added to the model. 
The column labels identify interactions. For example, for the X1 row, the columns labeled 
X2*X3 and X2*X5 have 0.333. This means that the expected value of the main effect of X1 is 
actually the sum of the main effect of X1 plus 0.333 times the effect of X2*X3, plus 0.333 times 
the effect of X2*X5, and so on for the rest of the X1 row. You are assuming that these 
interactions are negligible in size compared to the effect of X1.

Figure 4.3  The Alias Matrix

Note to DOE experts: The Alias matrix is a generalization of the confounding pattern in 
fractional factorial designs.

Creating a Screening Design to Fit All Two-Factor Interactions

There is risk involved in designs for main effects only. The risk is that two-factor interactions, 
if they are strong, can confuse the results of such experiments. To avoid this risk, you can 
create experiments resolving all the two-factor interactions.

Note to DOE experts: The result in this example is a resolution-five screening design. 
Two-factor interactions are estimable but are confounded with three-factor interactions.

1. Select DOE > Custom Design.

2. Enter five continuous factors into the Factors panel.

3. Click Continue.

4. In the Model panel, select Interactions > 2nd.

5. In the Alias Terms report, select Interactions > 2nd.

Adding the two-factor interactions here lets you view the Alias Matrix report later.

6. In the Design Generation panel, choose Minimum for Number of Runs and click Make 
Design.
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Figure 4.4 shows the runs of the two-factor design with all interactions. The sample size, 16 (a 
power of two) is large enough to fit all the terms in the model. The values in your table may be 
different from those shown below.

Figure 4.4  All Two-Factor Interactions 

7. Click the disclosure button (  on Windows and  on the Macintosh) and to open the 
Design Evaluation outlines, then open Alias Matrix. Figure 4.5 shows the alias matrix table 
of zeros and ones. The columns labels identify the two-way interactions. For example, the 
column labelled X1*X2 refers to the interaction of the first and second effect, the column 
labelled X2*X3 refers to the interaction between the second and third effect, and so forth.

Look at the column labelled X1*X2. There is only one value of 1 in that column. All others 
are 0. The 1 occurs in the row labelled X1*X2. All the other rows and columns are similar. 
This means that the expected value of the two-factor interaction X1*X2 is not biased by any 
other terms. All the rows above the row labelled X1*X2 contain only zeros, which means 
that the Intercept and main effect terms are not biased by any two-factor interactions. (The 
Alias Matrix entries are exactly what you expect, because you asked for a model that 
estimates all two-way interactions.)
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Figure 4.5  Alias Matrix Showing all Two-Factor Interactions Clear of all Main Effects

A Compromise Design Between Main Effects Only and All Interactions

In a screening situation, suppose there are six continuous factors and resources for n = 16 runs. 
The first example in this section showed an eight-run design that fit all the main effects. With 
six factors, there are 15 possible two-factor interactions. The minimum number of runs that 
could fit the constant, six main effects and 15 two-factor interactions is 22. This is more than 
the resource budget of 16 runs. It would be good to find a compromise between the 
main-effects only design and a design capable of fitting all the two-factor interactions. 

This example shows how to obtain such a design compromise using the custom designer’s 
Alias Optimal Design option.

1. Select DOE > Custom Design.

2. Define six continuous factors (X1 - X6).

3. Click Continue. 

The model includes the main effect terms by default. The default estimability of these 
terms is Necessary. Second-order interactions are added to the Alias Matrix.

4. From the Custom Design red triangle menu, select Optimality Criterion and then Make 
Alias Optimal Design.

5. Type 16 in the User Specified edit box in the Number of Runs section, as shown. Although 
the desired number of runs (16) is less than the total number of model terms, the custom 
designer builds a design to estimate as many two-factor interactions as possible.

6. Click Make Design.

After the custom designer creates the design, click the disclosure button beside Design 
Evaluation to open the Alias Matrix (Figure 4.6). The values in your table may be different 
from those shown below, but with a similar pattern.
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Figure 4.6  Alias Matrix

All rows contain only zeros, which means that the Intercept and main effect terms are not 
biased by any two-factor interactions. 

Note to DOE experts: The result in this particular example is a resolution-four screening 
design. Two-factor interactions are estimable but are aliased with other two-factor 
interactions.

Creating “Super” Screening Designs

This section shows how to use the technique shown in the previous example to create “super” 
(supersaturated) screening designs. Supersaturated designs have fewer runs than factors, 
which makes them attractive for factor screening when there are many factors and 
experimental runs are expensive.

In a saturated design, the number of runs equals the number of model terms. In a 
supersaturated design, as the name suggests, the number of model terms exceeds the number 
of runs (Lin, 1993). A supersaturated design can examine dozens of factors using fewer than 
half as many runs as factors.

The Need for Supersaturated Designs

The 27–4 and the 215–11 fractional factorial designs available using the screening designer are 
both saturated with respect to a main effects model. In the analysis of a saturated design, you 
can (barely) fit the model, but there are no degrees of freedom for error or for lack of fit. Until 
recently, saturated designs represented the limit of efficiency in designs for screening.

Factor screening relies on the sparsity principle. The experimenter expects that only a few of 
the factors in a screening experiment are active. The problem is not knowing which are the 
vital few factors and which are the trivial many. It is common for brainstorming sessions to 
turn up dozens of factors. Yet, in practice, screening experiments rarely involve more than ten 
factors. What happens to winnow the list from dozens to ten or so?

If the experimenter is limited to designs that have more runs than factors, then dozens of 
factors translate into dozens of runs. Often, this is not economically feasible. The result is that 
the factor list is reduced without the benefit of data. In a supersaturated design, the number of 
model terms exceeds the number of runs, and you can examine dozens of factors using less 
than half as many runs.
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There are drawbacks: 

• If the number of active factors approaches the number of runs in the experiment, then it is 
likely that these factors will be impossible to identify. A rule of thumb is that the number 
of runs should be at least four times larger than the number of active factors. If you expect 
that there might be as many as five active factors, you should have at least 20 runs.

• Analysis of supersaturated designs cannot yet be reduced to an automatic procedure. 
However, using forward stepwise regression is reasonable and the Screening platform 
(Analyze > Modeling > Screening) offers a more streamlined analysis.

Example: Twelve Factors in Eight Runs

As an example, consider a supersaturated design with twelve factors. Using model terms 
designated If Possible provides the software machinery for creating a supersaturated design.

In the last example, two-factor interaction terms were specified If Possible. In a supersaturated 
design, all terms—including main effects—are If Possible. Note in Figure 4.7, the only primary 
term is the intercept.

To see an example of a supersaturated design with twelve factors in eight runs:

1. Select DOE > Custom Design.

2. Add 12 continuous factors and click Continue.

3. Highlight all terms except the Intercept and click the current estimability (Necessary) to 
reveal the menu. Change Necessary to If Possible.

4. The desired number of runs is eight so type 8 in the User Specified edit box in the Number 
of Runs section.

5. Click the red triangle on the Custom Design title bar and select Simulate Responses.

6. Click Make Design, then click Make Table. A window named Simulate Responses and a 
design table appear, similar to the one in Figure 4.7. The Y column values are controlled by 
the coefficients of the model in the Simulate Responses window. The values in your table 
may be different from those shown below.
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Figure 4.7  Simulated Responses and Design Table

7. Change the default settings of the coefficients in the Simulate Responses dialog to match 
those in Figure 4.8 and click Apply. The numbers in the Y column change. Because you 
have set X2 and X10 as active factors in the simulation, the analysis should be able to 
identify the same two factors.

Note that random noise is added to the Y column formula, so the numbers you see might not 
necessarily match those in the figure. The values in your table may be different from those 
shown below.

Figure 4.8  Give Values to Two Main Effects and Specify the Standard Error as 0.5

To identify active factors using stepwise regression:

1. To run the Model script in the design table, click the red triangle beside Model and select 
Run Script.

2. Change the Personality in the Model Specification window from Standard Least Squares 
to Stepwise.

3. Click Run on the Fit Model dialog.
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4. In the resulting display click the Step button two times. JMP enters the factors with the 
largest effects. From the report that appears, you should identify two active factors, X2 and 
X10, as shown in Figure 4.9. The step history appears in the bottom part of the report. 
Because random noise is added, your estimates will be slightly different from those shown 
below.

Figure 4.9  Stepwise Regression Identifies Active Factors

Note: This example defines two large main effects and sets the rest to zero. In real-world 
situations, it may be less likely to have such clearly differentiated effects.

Screening Designs with Flexible Block Sizes

When you create a design using the Screening designer (DOE > Screening), the available block 
sizes for the listed designs are a power of two. However, custom designs in JMP can have 
blocks of any size. The blocking example shown in this section is flexible because it is using 
three runs per block, instead of a power of two.

After you select DOE > Custom Design and enter factors, the blocking factor shows only one 
level in the Values section of the Factors panel because the sample size is unknown at this 
point. After you complete the design, JMP shows the appropriate number of blocks, which is 
calculated as the sample size divided by the number of runs per block.
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For example, Figure 4.10 shows that when you enter three continuous factors and one 
blocking factor with three runs per block, only one block appears in the Factors panel.

Figure 4.10  One Block Appears in the Factors Panel

The default sample size of 12 requires three blocks. After you click Continue, there are four 
blocks in the Factors panel (Figure 4.11). This is because the default sample size is twelve, 
which requires four blocks with three runs each.

Figure 4.11  Three Blocks in the Factors Panel

If you enter 24 runs in the User Specified box of the Number of Runs section, the Factors panel 
changes and now contains 8 blocks (Figure 4.12).
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Figure 4.12  Number of Runs is 24 Gives Eight Blocks

If you add all the two-factor interactions and change the number of runs to 15, three runs per 
block produces five blocks (as shown in Figure 4.13), so the Factors panel displays five blocks 
in the Values section.
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Figure 4.13  Changing the Runs to 15

Checking for Curvature Using One Extra Run

In screening designs, experimenters often add center points and other check points to a design 
to help determine whether the assumed model is adequate. Although this is good practice, it 
is also ad hoc. The custom designer provides a way to improve on this ad hoc practice while 
supplying a theoretical foundation and an easy-to-use interface for choosing a design robust 
to the modeling assumptions.

The purpose of check points in a design is to provide a detection mechanism for higher-order 
effects that are contained in the assumed model. These higher-order terms are called potential 
terms. (Let q denote the potential terms, designated If Possible in JMP.) The assumed model 
consists of the primary terms. (Let p denote the primary terms designated Necessary in JMP.)
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To take advantage of the benefits of the approach using If Possible model terms, the sample 
size should be larger than the number of Necessary (primary) terms but smaller than the sum 
of the Necessary and If Possible (potential) terms. That is, p < n < p+q. The formal name of the 
approach using If Possible model terms is Bayesian D-Optimal design. This type of design 
allows the precise estimation of all of the Necessary terms while providing omnibus 
detectability (and some estimability) for the If Possible terms.

For a two-factor design having a model with an intercept, two main effects, and an interaction, 
there are p = 4 primary terms. When you enter this model in the custom designer, the default 
minimum runs value is a four-run design with the factor settings shown in Figure 4.14.

Figure 4.14  Two Continuous Factors with Interaction

Now suppose you can afford an extra run (n = 5). You would like to use this point as a check 
point for curvature. If you leave the model the same and increase the sample size, the custom 
designer replicates one of the four vertices. Replicating any run is the optimal choice for 
improving the estimates of the terms in the model, but it provides no way to check for lack of 
fit.

Adding the two quadratic terms to the model makes a total of six terms. This is a way to 
model curvature directly. However, to do this the custom designer requires two additional 
runs (at a minimum), which exceeds your budget of five runs.

The Bayesian D-Optimal design provides a way to check for curvature while adding only one 
extra run. To create this design:

1. Select DOE > Custom Design.

2. Define two continuous factors (X1 and X2).

3. Click Continue.

4. Choose 2nd from the Interactions menu in the Model panel. The results appear as shown 
in Figure 4.15.
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Figure 4.15  Second-Level Interactions

5. Choose 2nd from the Powers button in the Model panel. This adds two quadratic terms.

6. Select the two quadratic terms (X1*X1 and X2*X2) and click the current estimability 
(Necessary) to see the menu and change Necessary to If Possible, as shown in Figure 4.16.

Figure 4.16  Changing the Estimability

Now, the p = 4 primary terms (the intercept, two main effects, and the interaction) are 
designated as Necessary while the q = 2 potential terms (the two quadratic terms) are 
designated as If Possible. The desired number of runs, five, is between p = 4 and p + q = 6.

7. Enter 5 into the User Specified edit box in the Number of Runs section of the Design 
Generation panel.

8. Click Make Design. The resulting factor settings appear in Figure 4.17. The values in your 
design may be different from those shown below.
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Figure 4.17  Five-Run Bayesian D-Optimal Design

9. Click Make Table to create a JMP data table of the runs.

10. Create the overlay plot in Figure 4.18 with Graph > Overlay Plot, and assign X1 as Y and X2 
as X. The overlay plot illustrates how the design incorporates the single extra run. In this 
example the design places the factor settings at the center of the design instead of at one of 
the corners.

Figure 4.18  Overlay Plot of Five-run Bayesian D-Optimal Design

Creating Response Surface Experiments

Response surface experiments traditionally involve a small number (generally 2 to 8) of 
continuous factors. The a priori model for a response surface experiment is usually quadratic.

In contrast to screening experiments, researchers use response surface experiments when they 
already know which factors are important. The main goal of response surface experiments is 
to create a predictive model of the relationship between the factors and the response. Using 
this predictive model allows the experimenter to find better operating settings for the process.

In screening experiments one measure of the quality of the design is the size of the relative 
variance of the coefficients. In response surface experiments, the prediction variance over the 
range of the factors is more important than the variance of the coefficients. One way to 
visualize the prediction variance is JMP’s prediction variance profile plot. This plot is a 
powerful diagnostic tool for evaluating and comparing response surface designs.
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Exploring the Prediction Variance Surface

The purpose of the example below is to generate and interpret a simple Prediction Variance 
Profile Plot. Follow the steps below to create a design for a quadratic model with a single 
continuous factor.

1. Select DOE > Custom Design.

2. Add one continuous factor by selecting Add Factor > Continuous, and click Continue.

3. In the Model panel, select Powers > 2nd to create a quadratic term.

4. In the Design Generation panel, use the default number of runs (six) and click Make 
Design (). The number of runs is inversely proportional to the size of variance of the 
predicted response. As the number of runs increases, the prediction variances decrease.

5. Click the disclosure button (  on Windows and  on the Macintosh) to open the 
Design Evaluation outline node, and then the Prediction Variance Profile, as shown in 
Figure 4.19.

For continuous factors, the initial setting is at the mid-range of the factor values. For 
categorical factors, the initial setting is the first level. If the design model is quadratic, then the 
prediction variance function is quartic. The y-axis is the relative variance of prediction of the 
expected value of the response.

In this design, the three design points are –1, 0, and 1. The prediction variance profile shows 
that the variance is a maximum at each of these points on the interval –1 to 1.

Figure 4.19  Prediction Profile for Single Factor Quadratic Model

The prediction variance is relative to the error variance. When the relative prediction variance 
is one, the absolute variance is equal to the error variance of the regression model. More detail 
on the Prediction Variance Profiler is in “Understanding Design Evaluation” on page 53.

6. To compare profile plots, click the Back button and choose Minimum in the Design 
Generation panel, which gives a sample size of three.

7. Click Make Design and then open the Prediction Variance Profile again. See Figure 4.20.

Now you see a curve that has the same shape as the previous plot, but the maxima are at 1 
instead of 0.5.
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Figure 4.20  Prediction Variance Profiles

Introducing I-Optimal Designs for Response Surface Modeling

The custom designer generates designs using a mathematical optimality criterion. All the 
designs in this chapter so far have been D-Optimal designs. D-Optimal designs are most 
appropriate for screening experiments because the optimality criterion focuses on precise 
estimates of the coefficients. If an experimenter has precise estimates of the factor effects, then 
it is easy to tell which factors’ effects are important and which are negligible. However, 
D-Optimal designs are not as appropriate for designing experiments where the primary goal 
is prediction.

I-Optimal designs minimize the average prediction variance inside the region of the factors. 
This makes I-Optimal designs more appropriate for prediction. As a result I-Optimality is the 
recommended criterion for JMP response surface designs.

An I-Optimal design tends to place fewer runs at the extremes of the design space than does a 
D-Optimal design. As an example, consider a one-factor design for a quadratic model using 
n = 12 experimental runs. The D-Optimal design for this model puts four runs at each end of 
the range of interest and four runs in the middle. The I-Optimal design puts three runs at each 
end point and six runs in the middle. In this case, the D-Optimal design places two-thirds of 
its runs at the extremes versus one-half for the I-Optimal design.

Figure 4.21 compares prediction variance profiles of the one-factor I- and D-Optimal designs 
for a quadratic model with (n = 12) runs. The variance function for the I-Optimal design is less 
than the corresponding function for the D-Optimal design in the center of the design space; 
the converse is true at the edges.
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Figure 4.21  Prediction Variance Profiles for 12-Run I-Optimal (left) and D-Optimal (right) 
Designs

At the center of the design space, the average variance (relative to the error variance) for the 
I-Optimal design is 0.1667 compared to the D-Optimal design, which is 0.25. This means that 
confidence intervals for prediction will be nearly 10% shorter on average for the I-Optimal 
design.

To compare the two design criteria, create a one-factor design with a quadratic model that 
uses the I-Optimality criterion, and another one that uses D-Optimality:

1. Select DOE > Custom Design.

2. Add one continuous factor: X1.

3. Click Continue.

4. Click the RSM button in the Model panel to make the design I-Optimal.

5. Change the number of runs to 12.

6. Click Make Design.

7. Click the disclosure button (  on Windows and  on the Macintosh) to open the 
Design Evaluation outline node.

8. Click the disclosure button (  on Windows and  on the Macintosh) to open the 
Prediction Variance Profile. (The Prediction Variance Profile is shown on the left in 
Figure 4.21.)

9. Repeat the same steps to create a D-Optimal design, but select Optimality Criterion > Make 
D-Optimal Design from the red triangle menu on the custom design title bar. The results in 
the Prediction Variance Profile should look the same as those on the right in Figure 4.21.

A Three-Factor Response Surface Design

In higher dimensions, the I-Optimal design continues to place more emphasis on the center of 
the region of the factors. The D-Optimal and I-Optimal designs for fitting a full quadratic 
model in three factors using 16 runs are shown in Figure 4.22.
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To compare the two design criteria, create a three-factor design that uses the I-Optimality 
criterion, and another one that uses D-Optimality:

1. Select DOE > Custom Design.

2. Add three continuous factors: X1, X2, and X3.

3. Click Continue.

4. Click the RSM button in the Model panel to add interaction and quadratic terms to the 
model and to change the default optimality criterion to I-Optimal.

5. Use the default of 16 runs.

6. Click Make Design.

7. If you want to create a D-Optimal design for comparison, repeat the same steps but select 
Optimality Criterion > Make D-Optimal Design from the red triangle menu on the custom 
design title bar. The design should look similar to those on the right in Figure 4.21. The 
values in your design may be different from those shown below.

Profile plots of the variance function are displayed in Figure 4.22. These plots show slices of 
the variance function as a function of each factor, with all other factors fixed at zero. The 
I-Optimal design has the lowest prediction variance at the center. Note that there are two 
center points in this design.

The D-Optimal design has no center points and its prediction variance at the center of the 
factor space is almost three times the variance of the I-Optimal design. The variance at the 
vertices of the D-Optimal design is not shown. However, note that the D-Optimal design 
predicts better than the I-Optimal design near the vertices.

Figure 4.22  Variance Profile Plots for 16 run I-Optimal and D-Optimal RSM Designs

I-Optimal RSM Design 
with 16 runs

D-Optimal RSM Design 
with 16 runs
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Response Surface with a Blocking Factor

It is not unusual for a process to depend on both qualitative and quantitative factors. For 
example, in the chemical industry, the yield of a process might depend not only on the 
quantitative factors temperature and pressure, but also on such qualitative factors as the batch 
of raw material and the type of reactor. Likewise, an antibiotic might be given orally or by 
injection, a qualitative factor with two levels. The composition and dosage of the antibiotic 
could be quantitative factors (Atkinson and Donev, 1992).

The response surface designer (described in “Response Surface Designs” on page 183) only 
deals with quantitative factors. You could use the response surface designer to produce a 
Response Surface Model (RSM) design with a qualitative factor by replicating the design over 
each level of the factor. But, this is unnecessarily time-consuming and expensive. Using 
custom designer is simpler and more cost-effective because fewer runs are required. The 
following steps show how to accommodate a blocking factor in a response surface design 
using the custom designer:

1. First, define two continuous factors (X1 and X2).

2. Now, click Add Factor and select Blocking > 4 runs per block to create a blocking 
factor(X3). The blocking factor appears with one level, as shown in Figure 4.23, but the 
number of levels adjusts later to accommodate the number of runs specified for the design.

Figure 4.23  Add Two Continuous Factors and a Blocking Factor

3. Click Continue, and then click RSM in the Model panel to add the quadratic terms to the 
model (Figure 4.24). This automatically changes the recommended optimality criterion 
from D-Optimal to I-Optimal. Note that when you click RSM, a message reminds you that 
nominal factors (such as the blocking factor) cannot have quadratic effects.

Figure 4.24  Add Response Surface Terms
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4. Enter 12 in the User Specified text edit box in the Design Generation panel, and note that 
the Factors panel now shows the Blocking factor, X3, with three levels (Figure 4.25). 
Twelve runs defines three blocks with four runs per block.

Figure 4.25  Blocking Factor Now Shows Three Levels

5. Click Make Design.

6. In the Output Options, select Sort Right to Left from the Run Order list.

7. Click Make Table to see an I-Optimal table similar to the one on the left in Figure 4.26.

Figure 4.26 compares the results of a 12-run I-Optimal design and a 12-run D-Optimal Design.

To see the D-Optimal design:

1. Click the Back button.

2. Click the red triangle icon on the Custom Design title bar and select Optimality Criterion > 
Make D-Optimal Design.

3. Click Make Design, then click Make Table.

Figure 4.26  JMP Design Tables for 12-Run I-Optimal and D-Optimal Designs
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Figure 4.27 gives a graphical view of the designs generated by this example. These plots were 
generated for the runs in each JMP table by choosing Graph > Overlay Plot from the main 
menu and using the blocking factor (X3) as the Grouping variable.

Note that there is a center point in each block of the I-Optimal design. The D-Optimal design 
has only one center point. The values in your graph may be different from those shown in 
Figure 4.27.

Figure 4.27  Plots of I-Optimal (left) and D-Optimal (right) Design Points by Block.

Either of the designs in Figure 4.27 supports fitting the specified model. The D-Optimal 
design does a slightly better job of estimating the model coefficients. The diagnostics 
(Figure 4.28) for the designs show beneath the design tables. In this example, the D-efficiency 
of the I-Optimal design is about 51%, and is 55% for the D-Optimal design.
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The I-Optimal design is preferable for predicting the response inside the design region. Using 
the formulas given in “Technical Discussion” on page 128, you can compute the relative 
average variance for these designs. The average variance (relative to the error variance) for the 
I-Optimal design is 0.5 compared to 0.59 for the D-Optimal design (See Figure 4.28). This 
means confidence intervals for prediction will be almost 20% longer on average for D-Optimal 
designs.

Figure 4.28  Design Diagnostics for I-Optimal and D-Optimal Designs

Creating Mixture Experiments

If you have factors that are ingredients in a mixture, you can use either the custom designer or 
the specialized mixture designer. However, the mixture designer is limited because it requires 
all factors to be mixture components and you might want to vary the process settings along 
with the percentages of the mixture ingredients. The optimal formulation could change 
depending on the operating environment. The custom designer can handle mixture 
ingredients and process variables in the same study. You are not forced to modify your 
problem to conform to the restrictions of a special-purpose design approach. The custom 
designer also allows the mixture components to sum to any positive number. See “Mixture 
Sum” on page 77.

Mixtures Having Nonmixture Factors

The following example from Atkinson and Donev (1992) shows how to create designs for 
experiments with mixtures where one or more factors are not ingredients in the mixture. In 
this example:

• The response is the electromagnetic damping of an acrylonitrile powder.

• The three mixture ingredients are copper sulphate, sodium thiosulphate, and glyoxal.

• The nonmixture environmental factor of interest is the wavelength of light.

Though wavelength is a continuous variable, the researchers were only interested in 
predictions at three discrete wavelengths. As a result, they treated it as a categorical factor 
with three levels. To create this custom design:

1. Select DOE > Custom Design.
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2. Create Damping as the response. The authors do not mention how much damping is 
desirable, so right-click the goal and create Damping’s response goal to be None.

3. In the Factors panel, add the three mixture ingredients and the categorical factor, 
Wavelength. The mixture ingredients have range constraints that arise from the mechanism 
of the chemical reaction. Rather than entering them by hand, load them from the sample 
data folder that was installed with JMP: click the red triangle icon on the Custom Design 
title bar and select Load Factors. Open Donev Mixture Factors.jmp, from the Design 
Experiment sample data folder. The custom design panels should now look like those 
shown in Figure 4.29.

Figure 4.29  Mixture Experiment Response Panel and Factors Panel

The model, shown in Figure 4.30 is a response surface model in the mixture ingredients along 
with the additive effect of the wavelength. To create this model:

1. Click Interactions, and choose 2nd. A warning dialog appears telling you that JMP 
removes the main effect terms for non-mixture factors that interact with all the mixture 
factors. Click OK.

2. In the Design Generation panel, type 18 in the User Specified text edit box (Figure 4.30), 
which results in six runs each for the three levels of the wavelength factor.



112 Examples Using the Custom Designer Chapter 4
Creating Mixture Experiments Design of Experiments Guide

Figure 4.30  Mixture Experiment Design Generation Panel

3. Click Make Design, and then click Make Table.

The resulting data table is shown in Figure 4.31. The values in your table may be different 
from those shown below.
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Figure 4.31  Mixture Experiment Design Table

Atkinson and Donev also discuss the design where the number of runs is limited to 10. In that 
case, it is not possible to run a complete mixture response surface design for every 
wavelength.

To view this:

1. Click the Back button.

2. Remove all the effects by highlighting them and clicking Remove Term.

3. Add the main effects by clicking the Main Effects button.

4. In the Design Generation panel, change the number of runs to 10 (Figure 4.32) and click 
Make Design. The Design table to the right in Figure 4.32 shows the factor settings for 10 
runs.

Figure 4.32  Ten-Run Mixture Response Surface Design

Note that there are necessarily unequal numbers of runs for each wavelength. Because of this 
lack of balance it is a good idea to look at the prediction variance plot (top plot in Figure 4.33).
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5. Open the Design Evaluation outline node, then open the Prediction Variance Profile.

The prediction variance is almost constant across the three wavelengths, which is a good 
indication that the lack of balance is not a problem.

The values of the first three ingredients sum to one because they are mixture ingredients. If 
you vary one of the values, the others adjust to keep the sum constant.

6. Select Maximize Desirability from red triangle menu on the Prediction Variance Profile title 
bar.

The maximum prediction variance for this design is 54.76% of the error variance, as shown in 
the bottom plot in Figure 4.33.

Figure 4.33  Prediction Variance Plots for Ten-Run Design

Experiments that are Mixtures of Mixtures

As a way to illustrate the idea of a ‘mixture of mixtures’ situation, imagine the ingredients that 
go into baking a cake and assume the following:

• dry ingredients composed of flour, sugar, and cocoa 

• wet (or non-dry) ingredients consisting of milk, melted butter, and eggs.

These two components (wet and dry) of the cake are two mixtures that are first mixed 
separately and then blended together.

The dessert chef knows that the dry component (the mixture of flour, sugar, and cocoa) 
contributes 45% of the combined mixture and the wet component (butter, milk, and eggs) 
contributes 55%.



Chapter 4 Examples Using the Custom Designer 115
Design of Experiments Guide Creating Mixture Experiments

The objective of such an experiment might be to identify proportions within the two 
components that maximize some measure of taste or consistency.

This is a main effects model except that you must leave out one of the factors in order to avoid 
singularity. The choice of which factor to leave out of the model is arbitrary.

For now, consider these upper and lower levels of the various factors:

Within the dry mixture:

• cocoa must be greater than 10% but less than 20% 

• sugar must be greater than 0% but less than 15% 

• flour must be greater than 20% but less than 30%

Within the wet mixture:

• melted butter must be greater than 10% but less than 20%

• milk must be greater than 25% and less than 35% 

• eggs constitute more than 5% but less than 20%

You want to bake cakes and measure taste on a scale from 1 to 10.

Use the Custom Designer to set up this example, as follows:

1. In the Response Panel, enter one response and call it Taste.

2. Give Taste a Lower Limit of 1 and an Upper Limit of 10. (You are assuming a taste test where 
the respondents reply on a scale of 1 to 10.)

3. In the Factors Panel, enter the six cake factors described above.

4. Enter the given percentage values of the factors as proportions in the Values section of the 
Factors panel.

The completed Response and Factors panels should look like those shown in Figure 4.34.

Figure 4.34  Completed Responses and Factors Panel for the Cake Example
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5. Next, click Continue.

6. Open the Define Factor Constraints pane and click Add Constraint twice.

7. Enter the constraints as shown in Figure 4.35. For the second constraint setting, click on 
the less than or equal to button and select the greater than or equal to direction.

By confining the dry factors to exactly 45% in this way, the mixture role of all the factors 
ensures that the wet factors constitute the remaining 55%.

8. Open the Model dialog and note that it lists all 6 effects. Because these are mixture factors, 
including all effects would render the model singular. Highlight any one of the terms in 
the model and click Remove Term, as shown.

Figure 4.35  Constraints to Define the Double Mixture Experiment

9. To see a completed example, choose Simulate Responses from the menu on the Custom 
Design title bar.

10. In the Design Generation panel, enter 10 as the number of runs for the example. That is, 
you would bake cakes with 10 different sets of ingredient proportions.

11. Click Make Design in the Design Generation panel, and then click Make Table.

The table in Figure 4.36 shows that the two sets of cake ingredients (dry and wet) adhere to the 
proportions 45% and 55% as defined by the entered constraints. In addition, the amount of 
each ingredient in each cake recipe (run) conforms to the upper and lower limits given in the 
factors dialog.
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Figure 4.36  Cake Experiment Conforming to a Mixture of Mixture Design

Note: As a word of caution, keep in mind that it is easy to define constraints in such a way that 
it is impossible to construct a design that fits the model. In such a case, you will get a message 
saying “Could not find a valid starting design. Please check your constraints for consistency.”

Special Purpose Uses of the Custom Designer

While some of the designs discussed in previous sections can be created using other designers 
in JMP or by looking them up in a textbook containing tables of designs, the designs presented 
in this section cannot be created without using the custom designer.

Designing Experiments with Fixed Covariate Factors

Pre-tabulated designs rely on the assumption that the experimenter controls all the factors. 
Sometimes you have quantitative measurements (a covariate) on the experimental units 
before the experiment begins. If this variable affects the experimental response, the covariate 
should be a design factor. The pre-defined design that allows only a few discrete values is too 
restrictive. The custom designer supplies a reasonable design option.

Imagine that you have several lots of material and measurements of some important variables 
on each lot. You want to use items from these lots as the units for an experiment. You plan to 
process different units in a controlled way using an experiment design. 

The measured variables on each lot cannot be changed, so they are covariate factors. This 
example shows how to design the experiment to get most information about the effects of the 
factors that you can control.

Note: Covariate factors cannot have missing values.

Each run sums to 0.45 (45%). Each run sums to 0.55 (55%).
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Build the custom design as follows:

1. Open Reactor 32 Runs.jmp from the Design Experiment sample data folder.

2. Select DOE > Custom Design.

3. Click Add Factor and select Covariate, as shown in Figure 4.37. 

Figure 4.37  Add a Covariate Factor

The Covariate selection displays a list of the variables in the current data table.

4. Select Feed Rate, Temperature, and Concentration from the variable list (Figure 4.38) and 
click OK.

These factors cannot be controlled.

Figure 4.38  Design with Fixed Covariate

5. Click OK.

6. Add three continuous factors and name them Percent Reacted, Catalyst, and Stir Rate 
(Figure 4.39).

These factors can be controlled.
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Figure 4.39  Covariate and Control Factors

The next step is to decide how many of these lots to use in the experiment. The minimum 
number of lots depend on the number of terms in the model. The maximum is 32 because 
that is all the material you have on hand in this experiment.

7. Click Continue.

8. Enter 12 next to Number of Runs.

9. Click Make Design. 

Figure 4.40 shows the resulting design. To generate the design, JMP selects the best 12 out 
of 32 lots. Then, the Percent Reacted, Catalyst, and Stir Rate settings that maximize the 
information about all six factor effects are selected.

Figure 4.40  Twelve-Run Optimal Design for Three Covariate and Three Control Factors

10. Open the Color Map On Correlations report. 

The color map indicates that the design is orthogonal despite measured but not controlled 
covariate factors.
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Figure 4.41  Color Map On Correlations

Creating a Design that is Robust to a Linear Time Trend in the Response

Typically, experiments that are run in a time sequence experience linear drift in the response 
over the course of the experiment. If you randomize the order of the runs, then the drift’s effect 
does not tend to bias the estimated factor effects, but the variance of those effects increases.

Investigators usually randomize the order of their runs or at least randomize the order within 
homogeneous groups of runs (or blocks). However, if there is reason to suspect a strongly 
linear trend in the response over time independent of the factor changes, then there is a better 
way to proceed.

This example shows how to create a design that is robust to linear trend.

1. Create a data table with a continuous column named X1. 

This is the run order variable.

2. Type 1 in the first cell and 2 in the second cell of the column.

3. Select the two cells, right-click, and select Fill > Continue sequence to end of table.

Figure 4.42 shows the data table.
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Figure 4.42  Data Table with Order of Runs

4. Select DOE > Custom Design.

5. Select Add Factor > Covariate, select X1, and click OK.

6. Add seven continuous factors as shown in Figure 4.43 and then click Continue.

Figure 4.43  Design with One Covariate Factor and Seven Continuous Factors

7. In the Alias Terms report, select all terms and click Remove Term. 

The alias terms will be omitted from the correlation color map so you can clearly see the 
main effects.
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Figure 4.44  Removing Alias Terms

8. From the Custom Design red triangle menu, select Number of Starts, enter 100,000, and 
click OK.

This choice controls the number of times the designer starts from a random starting design 
to try to find the best possible design.

9. Click Make Design. 

10. After the design is generated, open the Color Map On Correlations report.

Figure 4.45 shows that the factors X2 through X8 are orthogonal to each other. X1 (the run 
order variable) is orthogonal to X3, X4, X5, X7, and X8. X1 is correlated with X2 and X6, but 
the correlation is only 0.0271. These correlations lead to a variance inflation of less than 
0.1% for the associated main effects. 

The runs are randomized, so your results might differ.

Figure 4.45  Color Map of the Run Order and Factor Settings for Each Run

11. Click Make Table.

The new data table shows the run order and factor settings for each run (Figure 4.46).
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Figure 4.46  Run Order and Factor Settings for the Trend Robust Design

It is not always possible to make the run order so nearly orthogonal to the factor effects as in 
this example. However, even if there are more substantial correlations between your run order 
column and other columns, including the run order as a factor accounts for any linear trend 
effect. Including the run order also allows for the precise estimation of the other factor effects.

Creating a Design with Two Hard-to-Change Factors: Split Plot

While there is substantial research literature covering the analysis of split plot designs, it has 
only been possible in the last few years to create optimal split plot designs (Goos 2002). The 
split plot design capability accessible in the JMP custom designer is the first commercially 
available tool for generating optimal split plot designs.

The split plot design originated in agriculture, but is commonplace in manufacturing and 
engineering studies. In split plot experiments, hard-to-change factors only change between 
one whole plot and the next. The whole plot is divided into subplots, and the levels of the 
easy-to-change factors are randomly assigned to each subplot.

The example in this section is adapted from Kowalski, Cornell, and Vining (2002). The 
experiment studies the effect of five factors on the thickness of vinyl used to make automobile 
seat covers. The response and factors in the experiment are described below:

• Three of the factors are ingredients in a mixture. They are plasticizers whose proportions, 
m1, m2, and m3, sum to one. Additionally, the mixture components are the subplot factors 
of the experiment.

• Two of the factors are process variables. They are the rate of extrusion (extrusion rate) and 
the temperature (temperature) of drying. These process variables are the whole plot factors 
of the experiment. They are hard to change.
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• The response in the experiment is the thickness of the vinyl used for automobile seat 
covers. The response of interest (thickness) depends both on the proportions of the 
mixtures and on the effects of the process variables.

To create this design in JMP:

1. Select DOE > Custom Design.

2. By default, there is one response, Y, showing. Double-click the name and change it to 
thickness. Use the default goal, Maximize (Figure 4.47).

3. Enter the lower limit of 10.

4. To add three mixture factors, type 3 in the box beside Add N Factors, and click Add Factor 
> Mixture.

5. Name the three mixture factors m1, m2, and m3. Use the default levels 0 and 1 for those 
three factors.

6. Add two continuous factors by typing 2 in the box beside Add N Factors, and click Add 
Factor > Continuous. Name these factors extrusion rate and temperature.

7. Ensure that you are using the default levels, –1 and 1, in the Values area corresponding to 
these two factors.

8. To make extrusion rate a whole plot factor, click Easy and select Hard.

9. To make temperature a whole plot factor, click Easy and select Hard. Your dialog should 
look like the one in Figure 4.47.

Figure 4.47  Entering Responses and Factors

10. Click Continue.

11. Next, add interaction terms to the model by selecting Interactions > 2nd (Figure 4.48). This 
causes a warning that JMP removes the main effect terms for non-mixture factors that 
interact with all the mixture factors. Click OK.
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Figure 4.48  Adding Interaction Terms

12. In the Design Generation panel, type 7 in the Number of Whole Plots text edit box.

13. For Number of Runs, type 28 in the User Specified text edit box.

Note: If you enter a missing value in the Number of Whole Plots edit box, then JMP considers 
many different numbers of whole plots and chooses the number that maximizes the 
information about the coefficients in the model. It maximizes the determinant of 

where V 
-1 is the inverse of the variance matrix of the responses. The matrix, V, is a 

function of how many whole plots there are, so changing the number of whole plots changes 
V, which can make a difference in the amount of information a design contains.

14. Click Make Design. The result is shown in Figure 4.49.

Figure 4.49  Partial Listing of the Final Design Structure

15. Click Make Table.

X′V 1– X
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16. From the sample data folder that was installed with JMP, open Vinyl Data.jmp from the 
Design Experiment folder, which contains 28 runs as well as response values. The values in 
the table you generated with the custom designer may be different from those from the 
sample data folder, shown in Figure 4.50.

Figure 4.50  The Vinyl Data Design Table

17. Click the red triangle icon next to the Model script and select Run Script. The dialog in 
Figure 4.51 appears.

The models for split plots have a random effect associated with the whole plots’ effect.

As shown in the dialog in Figure 4.51, JMP designates the error term by appending &Random 
to the name of the effect. REML will be used for the analysis, as indicated in the menu beside 
Method in Figure 4.51. For more information about REML models, see the Fitting Linear Models 
book.
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Figure 4.51  Define the Model in the Fit Model Dialog

18. Click Run to run the analysis. The results are shown in Figure 4.52.
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Figure 4.52  Split Plot Analysis Results

Technical Discussion

This section provides information about I-, D-, Bayesian I-, Bayesian D-, and Alias-Optimal 
designs.

D-Optimality

• is the default design type produced by the custom designer except when the RSM button 
has been clicked to create a full quadratic model.

• minimizes the variance of the model coefficient estimates. This is appropriate for 
first-order models and in screening situations, because the experimental goal in such 
situations is often to identify the active factors; parameter estimation is key.

• is dependent on a pre-stated model. This is a limitation because in most real situations, the 
form of the pre-stated model is not known in advance.

• has runs whose purpose is to lower the variability of the coefficients of this pre-stated 
model. By focusing on minimizing the standard errors of coefficients, a D-Optimal design 
may not allow for checking that the model is correct. It will not include center points when 
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investigating a first-order model. In the extreme, a D-Optimal design may have just p 
distinct runs with no degrees of freedom for lack of fit.

• maximizes D when 

D-optimal split plot designs maximize D when 

where V -1is the block diagonal variance matrix of the responses (Goos 2002).

Bayesian D-Optimality

• is a modification of the D-Optimality criterion that effectively estimates the coefficients in 
a model, and at the same time has the ability to detect and estimate some higher-order 
terms. If there are interactions or curvature, the Bayesian D-Optimality criterion is 
advantageous.

• works best when the sample size is larger than the number of Necessary terms but smaller 
than the sum of the Necessary and If Possible terms. That is, p + q > n > p. The Bayesian 
D-Optimal design is an approach that allows the precise estimation of all of the Necessary 
terms while providing omnibus detectability (and some estimability) for the If Possible 
terms.

• uses the If Possible terms to force in runs that allow for detecting any inadequacy in the 
model containing only the Necessary terms. Let K be the (p + q) by (p + q) diagonal matrix 
whose first p diagonal elements are equal to 0 and whose last q diagonal elements are the 
constant, k. If there are 2-factor interactions then k = 4. Otherwise k = 1. The Bayesian 
D-Optimal design maximizes the determinant of (X'X + K2). The difference between the 
criterion for D-Optimality and Bayesian D-Optimality is this constant added to the 
diagonal elements corresponding to the If Possible terms in the X'X matrix.

I-Optimality

• minimizes the average variance of prediction over the region of the data.

• is more appropriate than D-Optimality if your goal is to predict the response rather than 
the coefficients, such as in response surface design problems. Using the I-Optimality 
criterion is more appropriate because you can predict the response anywhere inside the 
region of data and therefore find the factor settings that produce the most desirable 
response value. It is more appropriate when your objective is to determine optimum 
operating conditions, and also is appropriate to determine regions in the design space 
where the response falls within an acceptable range. Precise estimation of the response 
therefore takes precedence over precise estimation of the parameters.

D det X′X[ ]=

D det X′V 1– X[ ]=
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• minimizes this criterion: If f '(x) denotes a row of the X matrix corresponding to factor 
combinations x, then

where

is a moment matrix that is independent of the design and can be computed in advance.

Bayesian I-Optimality

Bayesian I-Optimality has a different objective function to optimize than the Bayesian 
D-optimal design, so the designs that result are different. The variance matrix of the 
coefficients for Bayesian I-optimality is X'X + K where K is a matrix having zeros for the 
Necessary model terms and some constant value for the If Possible model terms.

The variance of the predicted value at a point x0 is:

The Bayesian I-Optimal design minimizes the average prediction variance over the design 
region:

where M is defined as before.

Alias Optimality

• seeks to minimize the aliasing between model effects and alias effects.

Specifically, let X1 be the design matrix corresponding to the model effects, and let X2 be the 
matrix of alias effects, and let

A = 

be the alias matrix.

Then, alias optimality seeks to minimize the , subject to the D-Efficiency being greater 
than some lower bound. In other words, it seeks to minimize the sum of the squared diagonal 
elements of A.

I f
R
 ′ x( ) X′X( )= 1– f x( )dx Trace X ′X( ) 1– M[ ]=

M f
R
 x( ) f x( )′dx=

var Y
ˆ

x0 
  x0′ X′X K+ 

  1–
 
  x0=

IB Trace X ′X K+( ) 1– M[ ]=

X1′X1( ) 1– X1′X2

tr AA'( )



Chapter 5
Definitive Screening Designs

Factor screening is an important beginning to an experimental program for characterizing and 
then improving the performance of a product or process. The idea behind factor screening (or 
more simply, screening) is to identify the few factors that have the most substantial effects on 
the response of interest. Screening depends on the assumption that the Pareto principle 
applies. That is, most of the variation in any system is generally due to just a few driving 
factors.

Screening designs are popular, in part, because they generally require comparatively few runs 
especially considering the many factors being investigated. Traditional screening designs 
usually consider factors at two-levels (Low and High) to economize on the required number 
of runs.

One consequence of running the most economical of the standard screening designs is that 
main effects might be confounded with two-factor interactions. Also, two-factor interactions 
might be confounded with each other. If a two-factor interaction effect is substantial, then 
practitioners who use such designs must perform additional runs at a later time to resolve the 
remaining ambiguities.

For quantitative factors, engineers and scientists often prefer designs that have three levels 
(Low, Middle, and High) for each factor; two levels are not sufficient to detect nonlinearity, 
which is common in physical systems.

Definitive screening designs address both of the above concerns. They have three levels for 
every quantitative factor, so they can detect and identify any factor causing a strong nonlinear 
effect. Also, main effects are independent of two-factor interactions and two-factor 
interactions are not confounded with each other. This allows users to avoid the need for 
follow-up runs to resolve model ambiguity in many cases.

Note that definitive screening designs are available only for continuous factors and categorical 
factors with two levels. 

Read about the many other benefits of definitive screening in “Definitive Screening Platform 
Overview” on page 133.
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Definitive Screening Platform Overview

With traditional screening designs, correlated main effects and confounded two-factor 
interactions often lead to costly follow-up runs. Definitive screening provides a way to avoid 
model ambiguity due to confounding and identify important factors more quickly.

Definitive screening designs offer the following advantages:

• For continuous factors, the number of required runs is only one more than twice the 
number of factors. Categorical factors require two more than twice the number of factors.

• Unlike resolution III designs, main effects are completely independent of two-factor 
interactions. As a result, estimates of main effects are not biased by the presence of active 
two-factor interactions, regardless of whether the interactions are included in the model.

• Unlike resolution IV designs, two-factor interactions are not completely confounded with 
other two-factor interactions, although they might be correlated.

• Unlike resolution III, IV, and V designs with added center points, all quadratic effects are 
estimable in models comprised of any number of linear and quadratic main-effects terms.

• Quadratic effects are orthogonal to main effects and not completely confounded (though 
correlated) with interaction effects.

• With six through (at least) twelve factors, the designs are capable of estimating all possible 
full quadratic models involving three or fewer factors with very high levels of statistical 
efficiency.1

Table 5.1 shows an example of a definitive design with eight three-level factors. Notice that 
each pair of rows is a foldover pair; each even-numbered row mirrors the previous row. This 
foldover design removes the confounding of two-factor interactions and main effects. Each 
column includes three zero values, which means that quadratic effects are estimable in each 
factor. And the center run in the last row enable you to include all main effects, quadratic 
effects for each factor, and an intercept term in the model.

1. Reprinted with permission. Jones, B. and Nachtsheim, C. (2011a). A Class of Three-Level 
Designs for Definitive Screening in the Presence of Second-Order Effects, Journal of Quality 
Technology, 43, p. 2. The journal article is available on the JMP website at http://
www.jmp.com/software/pdf/definitive_screening.pdf.

http://www.jmp.com/software/pdf/definitive_screening.pdf
http://www.jmp.com/software/pdf/definitive_screening.pdf
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Example of Definitive Screening

Suppose that you gathered data from an aerobics study to see which factors are most 
correlated with physical fitness. With eight continuous factors (such as age and pulse rate), 
you create a definitive screening design to narrow down the two-factor interactions.

To create the definitive screening design, follow these steps:

1. Select DOE > Definitive Screening Design.

2. Change the response name (Y) to Fitness.

3. Add eight continuous factors.

4. Change the factor names (X1-X8) to those shown in Figure 5.1.

Table 5.1  Definitive Screening Design for Eight Three-Level Factors

Run X1 X2 X3 X4 X5 X6 X7 X8
1 0 1 1 1 1 1 1 1
2 0  -1  -1  -1  -1  -1  -1  -1
3 1 0 1 1  -1 1  -1  -1
4  -1 0  -1  -1 1  -1 1 1
5 1  -1 0 1 1  -1 1  -1
6  -1 1 0  -1  -1 1  -1 1
7 1  -1  -1 0 1 1  -1 1
8  -1 1 1 0  -1  -1 1  -1
9 1 1  -1  -1 0 1 1  -1
10  -1  -1 1 1 0  -1  -1 1
11 1  -1 1  -1  -1 0 1 1
12  -1 1  -1 1 1 0  -1  -1
13 1 1  -1 1  -1  -1 0 1
14  -1  -1 1  -1 1 1 0  -1
15 1 1 1  -1 1  -1  -1 0
16  -1  -1  -1 1  -1 1 1 0
17 0 0 0 0 0 0 0 0
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Figure 5.1  Definitive Screening for Eight Continuous Factors

5. Click Continue and open the Color Map On Correlations report (Figure 5.2).
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Figure 5.2  Color Map for Definitive Screening

The Color Map indicates the following:

• The solid blue area shows that second-order effects are all uncorrelated with the main 
effects.

• The red diagonal line indicates that none of the model terms are confounded with each 
other.

6. Select Save Factors from the Definitive Screening Design red triangle menu and name the 
file Design Factors.jmp.

7. Select Save Responses from the same red triangle menu and name the file Design 
Responses.jmp.

The factors and responses are saved in data tables so that you can use the values in the 
next design.

Keep this report open to compare it with that of a fractional factorial design.

1. Select DOE > Screening Design.

2. Select Load Responses from the Screening Design red triangle menu and then select 
Design Responses.jmp, which you created in the preceding steps.

The Fitness response appears in the Responses list.

3. Select Load Factors from the same red triangle menu and then select Design Factors.jmp.
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The continuous factors appear in the Factors list.

4. Click Continue.

5. Select Choose from a list of fractional factorial designs and click Continue.

Potential designs appear in the Design List (Figure 5.3).

Figure 5.3  Fractional Factorial Screening Design

6. Select the second item in the list, which is a sixteen-run fractional factorial design with no 
blocks.

7. Click Continue.

8. In the Design Evaluation report, open the Color Map On Correlations report, and compare 
it to the definitive screening design color map (Figure 5.4).
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Figure 5.4  Color Maps for Fractional Factorial (left) and Definitive Screening (right)

• In the fractional factorial color map on the left, all cells are either blue or red. Each 
two-factor interaction is either completely confounded or completely uncorrelated with 
other two-factor interactions. You would need to run more trials to identify the true source 
of any strong two-factor interactions.

• In the definitive screening color map on the right, the solid blue area shows that 
second-order effects are all uncorrelated with the main effects. And two-factor interactions 
are only mildly correlated, indicated by the light blue cells. Further tests to narrow down 
the interactions are unnecessary.

Example of Definitive Screening versus Plackett-Burman Designs

Plackett-Burman designs are an alternative to fractional factorials for screening. However, 
Plackett-Burman designs have complex aliasing of the main effects by two-factor interactions.

This example shows how to compare definitive screening and Plackett-Burman designs.

1. Select DOE > Definitive Screening Design.

2. Change the response name (Y) to Bicycle Safety.

3. Add four continuous factors as shown in Figure 5.5.
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Figure 5.5  Definitive Screening with Continuous and Categorical Factors

4. Add a categorical factor with the name Type of Bicycle and the values Road and Mountain.

5. Add another categorical factor with the name Gender and the values Male and Female.

6. Click Continue.

7. Open the Color Map On Correlations report (Figure 5.6).
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Figure 5.6  Color Map for Definitive Screening

Note that the categorical main effects have small correlations with each other and with the 
continuous factors’ main effects. These correlations lead to a small reduction in the precision 
of the estimates.

8. Select Save Factors from the Definitive Screening Design red triangle menu and name the 
file Factors.jmp.

9. Select Save Responses from the same red triangle menu and name the file Responses.jmp.

The factors and responses are saved in data tables for use in the Plackett-Burman design. 
Keep the data tables open.

Now create a Plackett-Burman design using the same factors.

1. Select DOE > Screening Design.

2. Display Responses.jmp and select Load Responses from the Screening Design red triangle 
menu.

Bicycle Safety appears in the Responses list.

3. Display Factors.jmp and select Load Factors from the same red triangle menu.

The continuous factors appear in the Factors list.
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4. Click Continue.

5. Select Choose from a list of fractional factorial designs and click Continue.

Potential designs appear in the Design List (Figure 5.7).

Figure 5.7  Plackett-Burman Design

6. Select the Plackett-Burman design, which has 12 runs with no blocks.

7. Click Continue.

8. In the Design Evaluation report, open the Color Map On Correlations report, and compare 
it to the definitive screening design color map (Figure 5.8).
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Figure 5.8  Compare the Plackett-Burman (left) and Definitive Screening (right) Designs

Notice that the two-factor interactions are correlated with main effects in the Plackett-Burman 
design on the left. The Definitive Screening design trades off a small increase in the variance of 
the main effects for complete independence of main effects and two-factor interactions.

For the Plackett-Burman design, the correlations between main effects and two-factor 
interactions means that any non-negligible two-factor interaction will bias several main 
effects. This can lead to failure to identify real main effects and falsely concluding that an 
inactive main effect is active.



Chapter 6
Screening Designs

Screening designs are among the most popular designs for industrial experimentation. They 
are typically used in the initial stages of experimentation. They examine many factors to 
identify those that have the greatest effect on the response or responses. The factors identified 
are then studied using more sensitive designs.

Screening designs generally require fewer experimental runs than other designs. They are 
attractive because they are a relatively inexpensive and efficient way to begin improving a 
process.

In a screening design, each continuous factor is usually set at two levels to economize on the 
number of runs needed. The design consists of only a fraction of the possible combinations of 
factor levels. Tables of standard designs that involve continuous and categorical factors have 
been cataloged.

JMP’s screening designer supplies a list of popular screening designs for two or more factors. 
These factors can be two-level continuous factors or three-level categorical or discrete 
continuous factors.

However, screening situations occur for which standard designs are not available. For these 
situations, JMP generates main effects screening designs. There are designs that are either 
orthogonal or near orthogonal. They focus on estimating main effects in the presence of 
negligible interactions.

In the JMP screening platform, you enter your factors and their levels. If a standard screening 
design exists, you are given the option to choose such a design from a list of standard 
screening designs that includes blocking designs. Alternatively, you can generate a main 
effects screening design, which will assure you of an orthogonal or near-orthogonal design. If 
a standard screening design does not exist, a main effects screening design is automatically 
generated for you.
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Overview

Each continuous factor in a screening design is typically set at two levels. Classical designs can 
also accommodate categorical factors with three levels. When the number of possible factor 
level combinations results in an infeasible design size, response measurements are taken for 
only a fraction of these combinations.

The screening design platform provides screening designs for two-level continuous factors, 
categorical factors, and discrete continuous factors. These designs are of two types:

• Classical designs: For situations where standard screening designs exist, you can choose 
from a list of these designs. 

• Main Effects Screening Designs: For situations where standard designs are not available, 
JMP generates designs that are either orthogonal or near orthogonal. Like some of the 
standard designs, these designs focus on estimating main effects in the presence of 
negligible interactions.

The emphasis on studying main effects early on in the experimentation process is supported 
by the Hierarchical Ordering Principle (Wu and Hamada, 2000). This principle contends that 
lower effects are more likely to be important than higher order effects. For this reason, 
screening designs generally assume that interactions are negligible. In cases where this 
assumption is not reasonable, then screening designs assume that two-factor interactions are 
more important than three-factor interactions, and so on.

The efficiency of screening designs also depends on the critical assumption of effect sparsity. 
Effect sparsity reflects the fact that real-world processes usually have only a few driving 
factors. Other factors are relatively unimportant. To understand the importance of effect 
sparsity, you can contrast screening designs to full factorial designs:

• Full factorial designs consist of all combinations of the levels of the factors. The number of 
runs is the product of the factor levels. For example, a full factorial experiment with three 
two-level factors and a four-level factor has 2 x 2 x 2 x 4 = 32 runs. 

• By contrast, screening designs require only a fraction of the runs in the full factorial 
design. The main effects of the four factors described above can be studied in an eight run 
main effects screening design.

This chapter shows you how to generate and analyze screening designs, pointing out their 
limitations in the process.
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Screening Design Examples

A Standard Design with Two Continuous Factors and One Categorical Factor

Suppose an engineer wants to investigate a process that uses an electron beam welding 
machine to join two parts. The engineer fits the two parts into a welding fixture that holds 
them snugly together. A voltage applied to a beam generator creates a stream of electrons that 
heats the two parts, causing them to fuse. The ideal depth of the fused region is 0.17 inches. 
The engineer wants to study the welding process to determine the best settings for the beam 
generator to produce the desired depth in the fused region.

For this study, the engineer wants to explore the following three inputs, which are the factors 
for the study:

• Operator, who is the technician operating the welding machine

• Rotation Speed, which is the speed at which the part rotates under the beam

• Beam Current, which is a current that affects the intensity of the beam

After each processing run, the engineer cuts the part in half. This reveals an area where the 
two parts have fused. The Length of this fused area is the depth of penetration of the weld. 
This depth of penetration is the response for the study.

The goals of the study are to:

• find which factors affect the depth of the weld

• quantify those effects

• find specific factor settings that predict a weld depth of 0.17 inches

To begin this example, select DOE > Screening Design from the main menu. Note that in the 
Responses panel, there is a single default response called Y. Change the default response as 
follows:

1. Double-click the response name and change it to Depth (in).

2. The default goal for the single default response is Maximize, but the goal of this process is 
to get a target value of 0.17 inches with a lower bound of 0.12 and an upper bound of 0.22. 
Click the Goal box and choose Match Target from the drop-down menu, as shown in 
Figure 6.1.
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Figure 6.1  Screening Design Response With Match Target Goal

3. Click the Lower Limit text edit area and enter 0.12 as the lower limit (minimum acceptable 
value). Then click the Upper Limit text edit area and enter 0.22 as the upper limit 
(maximum acceptable value).

This example has one categorical factor (Operator) and two continuous factors (Speed and 
Current). In the Factors panel:

4. Add the categorical factor by selecting 2 Level from the Categorical list.

5. Add two continuous factors by typing 2 in the Add N Factors box and clicking the 
Continuous button.

6. Double-click the factor names and rename them Operator, Speed, and Current.

7. Assign John and Mary as values for the categorical factor Operator. Set high and low 
values for Speed to 3 and 5 (rpm). Set high and low values for Current to 150 and 165 
(amps). Your Screening Design window should appear as shown in Figure 6.2.

Figure 6.2  Screening Design with Two Continuous and One Categorical Factor

8. Click Continue.

Since there is a standard design in the Design List for the combination of factors and levels 
that you have specified, the Choose Screening Type panel appears (Figure 6.3). You can 
choose between selecting a standard design from a list or generating an orthogonal or 
near-orthogonal design. Accept the default selection to Choose from a list of fractional 
factorial designs and click Continue.

Click the Goal box and 
choose Match Target 
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Figure 6.3  Choose Screening Type Panel

9. Select Full Factorial in the list of designs, as shown in Figure 6.4, and then click Continue.

Figure 6.4  List of Screening Designs for Two Continuous and One Categorical Factors

In the Output Options report, click on the Run Order menu and select Sort Left to Right (see 
Figure 6.8). Then click Make Table to create the JMP table that contains the specified design.

The table in Figure 6.5 appears. Because you have sorted the runs, they are arranged in a 
specific order. This has been done for expository purposes. In general, you want to randomize 
the rows in the data table prior to running your experiment.

The table uses the names for responses, factors, and levels you specified. The Pattern variable 
shows the coded design runs. The table produced in this example is shown in 
DOE Example 1.jmp, found in the Design Experiments subfolder of the sample data folder. 

Figure 6.5  The Design Data Table
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A Standard Design for Five Continuous Factors

As illustrated in the previous section, experiments for screening the effects of many factors 
usually consider only two levels of each factor. This allows the examination of many factors 
with a minimum number of runs.

The following example, adapted from Meyer, et al. (1996), demonstrates how to use JMP’s 
screening designer when you have many factors. In this study, a chemical engineer 
investigates the effects of five factors on the percent reaction of a chemical process. The factors 
are: 

• feed rate, the amount of raw material added to the reaction chamber in liters per minute 

• percentage of catalyst 

• stir rate, the RPMs of a propeller in the chamber

• reaction temperature in degrees Celsius

• concentration of reactant

To start the example:

1. Select DOE > Screening Design.

2. You see one default response called Y. Change the default response name (Y) to Percent 
Reacted.

3. The Goal is to maximize the response, but change the minimum acceptable reaction 
percentage to 90 (Lower Limit), and upper limit to 99 (Upper Limit), as shown in Figure 6.6.

4. Add five continuous factors by entering 5 in the Add N Factors box and clicking 
Continuous.

5. Change the default factor names (X1-X5) to Feed Rate, Catalyst, Stir Rate, Temperature, and 
Concentration.

6. Enter the high and low values, as shown in Figure 6.6.
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Figure 6.6  Screening for Many Factors

7. Click Continue.

8. From the Choose Screening Type panel, accept the default selection to Choose from a list of 
fractional factorial designs. 

Designs for the number of factors you specified are listed in the Design List (Figure 6.7).

9. Select the first item in the list, which is an 8-run fractional factorial design with no blocks 
(Figure 6.7).

Figure 6.7  Screening Design for Five Factors

 

10. Click Continue to see the Output Options panel shown in Figure 6.8.
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The Output Options panel lets you modify the final design by specifying the run order, the 
number of center points, and the number of times the design is replicated. Designs should 
be run in random order. Screening designs are typically not replicated.

11. To show a standard ordering for the design, select Sort Left to Right from the Run Order 
list. 

Figure 6.8  Output Options for Design Table

12. Click Make Table to create the data table. The design table, shown in Figure 6.9, lists the 
runs for the design you selected. Note that it also inserts a column called Percent Reacted 
for recording experimental results. Also included are three scripts, Screening, Model, and 
DOE Dialog.

Figure 6.9  JMP Table of Runs for Screening Example

13. Open the Reactor 8 Runs.jmp sample data table found in the Design Experiments folder in 
the sample data folder.

Note that this design was obtained using different generating rules than those used for the 
design that you just generated.

Of the five factors in the experiment, you expect a few to stand out in comparison to the 
others. You will use this data to identify active effects for experimental results from this 
design.

14. Click the red triangle next to the Screening script in upper left of the data table. Select Run 
Script. Alternatively, you can analyze the data directly by selecting Analyze > Modeling > 
Screening. Select Percent Reacted as Y and all other continuous variables as X. 
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15. Click OK. 

The report is shown in Figure 6.10. Since the p-values are obtained using a 
simulation-based technique, yours will be close to, but not precisely match, those shown 
below.

See the section “Analyzing Screening Data” on page 169 for a complete discussion of the 
screening report.

Figure 6.10  Report for Screening Example

Creating a Screening Design

To begin, select DOE > Screening Design, or click the Screening Design button on the JMP 
Starter DOE page. Then, see the following sections for each step to create a screening design: 

1. “Enter Responses” on page 153

2. “Enter Factors” on page 154

3. “Choose a Design” on page 155

– “Display and Modify Design” on page 159, if you choose a standard design from the 
Design Table

– “Design Generation” on page 163, if you choose to generate a main effects screening 
design

4. “Evaluating Experimental Designs” chapter on page 321
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5. “Specify Output Options” on page 164

6. “View the Design Table” on page 165

Most of the red triangle options for the screening platform are described in “Special Custom 
Design Commands” on page 68 in the “Building Custom Designs” chapter. Three options are 
specific to screening designs:

• Suppress Cotter Designs, described in “Cotter Designs” on page 158

• Number of Starts, described in “Design Generation” on page 163

• Number of Column Starts, described in “Design Generation” on page 163

Enter Responses

To enter responses, follow the steps in Figure 6.11.

1. To enter one response at a time, click and then select a goal type. Possible goal types are 
Maximize, Match Target, Minimize, or None.

2. (Optional) Double-click to edit the response name.

3. (Optional) Click to change the response goal.

4. (Optional) Click to enter lower and upper limits and importance weights.

Figure 6.11  Entering Responses

Tip: To quickly enter multiple responses, click the Number of Responses button and enter the 
number of responses you want.

Specifying Goal Types and Lower and Upper Limits

When entering responses, you can tell JMP that your goal is to obtain the maximum or 
minimum value possible, to match a specific value, or that there is no goal.

The following description explains the relationship between the goal type (step 3 in 
Figure 6.11) and the lower and upper limits (step 4 in Figure 6.11):

2 3

4

1
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• For responses such as strength or yield, the best value is usually the largest possible. A 
goal of Maximize supports this objective.

• The Minimize goal supports an objective of having the smallest value be the most desirable, 
such as when the response is impurity or defects.

• The Match Target goal supports the objective when the best value for a response is a 
specific target value, such as dimensions of a manufactured part. The default target value 
is assumed to be midway between the lower and upper limits.

Note: If your target range is not symmetric around the target value, you can alter the default 
target after you make a table for the design. In the data table, open the response’s Column Info 
dialog by double-clicking the column name, and enter the appropriate target value.

Understanding Importance Weights 

When computing overall desirability, JMP uses the value you enter as the importance weight 
(step 4 in Figure 6.11) to weight each response. If there is only one response, then specifying 
importance is unnecessary. With two responses you can give greater weight to one response 
by assigning it a higher importance value.

Enter Factors

Next, you enter factors. This process is described in Figure 6.12.

1. To enter a continuous factor, click the Continuous button. To enter a Discrete Numeric or a 
Categorical factor, select the appropriate number of levels for the factor from the list.

2. To enter several of one type of factor, enter the number of factors in the box next to Add N 
Factors. Then select the type of factor for which you want to add the specified number of 
factors.

3. To remove a factor from the list, highlight the factor and click the Remove button.

4. Double-click to edit a factor name.

5. Click to enter factor values.

Figure 6.12  Entering Factors

3

4

1

2
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Types of Factors

In general, when designing experiments, you can enter different types of factors in the model. 
Below is a description of factor types from which you can choose when creating screening 
designs:

Continuous Continuous factors have numeric data types only. In theory, you can set a 
continuous factor to any value between the lower and upper limits you supply.

Discrete Numeric Discrete numeric factors are use for factors that are conceptually 
continuous, but which in practice can only be set at discrete levels. Unlike categorical 
factors, discrete numeric factors have a single degree of freedom associated with them.

Categorical Categorical factors (either numeric or categorical data types) have no implied 
order. If the values are numbers, the order is the numeric magnitude. If the values are 
character, the order is the sorting sequence. The settings of a categorical factor are discrete 
and have no intrinsic order. Examples of categorical factors are machine, operator, and 
gender.

After you enter responses and factors, click Continue.

Choose a Design

If a standard design listed in the Design Table applies for your factors and levels, then two 
options appear in the Choose Screening Type panel, below the Factors panel:

• Choose from a list of fractional factorial designs

• Generate orthogonal or near orthogonal designs for main effects only

The first option is the default. If no standard design listed exists, then the Choose Screening 
Type panel does not appear and the second option applies.

Design List

When you select the option to choose from a list of fractional factorial designs, the Design List 
report opens. The list of screening designs you can use includes designs that group the 
experimental runs into blocks of equal sizes where the size is a power of two. Highlight the 
type of screening design you want to use and click Continue.

Figure 6.13  Choosing a Type of Screening Design
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The screening designer provides the following types of designs:

Two-Level Full Factorial

A full factorial design has runs for all combinations of the levels of the factors. The samples 
size is the product of the levels of the factors. For two-level designs, this is 2k where k is the 
number of factors. This can be expensive if the number of factors is greater than 3 or 4.

These designs are orthogonal. This means that the estimates of the effects are uncorrelated. If 
you remove an effect in the analysis, the values of the other estimates remain the same. Their 
p-values change slightly, because the estimate of the error variance and the degrees of freedom 
are different.

Full factorial designs allow the estimation of interactions of all orders up to the number of 
factors. Most empirical modeling involves first- or second-order approximations to the true 
functional relationship between the factors and the responses. The figure to the left in 
Figure 6.14 is a geometric representation of a two-level full factorial design with three factors.

Two-Level Regular Fractional Factorial

A regular fractional factorial design also has a sample size that is a power of two. If k is the 
number of factors, the number of runs in a regular fractional factorial design is 2k – p where p < 
k. The fraction of the full factorial is 2-p. Like the full factorial, regular fractional factorial 
designs are orthogonal.

The trade-off in screening designs is between the number of runs and the resolution of the 
design. If price is no object, you can run several replicates of all possible combinations of m 
factor levels. This provides a good estimate of everything, including interaction effects to the 
mth degree. But because running experiments costs time and money, you typically only run a 
fraction of all possible levels. This causes some of the higher-order effects in a model to 
become nonestimable. An effect is nonestimable when it is confounded with another effect, 
meaning that the effects can not be distinguished from each other. In fact, fractional factorials 
are designed by deciding in advance which interaction effects are confounded with the other 
interaction effects.

Resolution Number: The Degree of Confounding

In practice, few experimenters worry about interactions higher than two-way interactions. 
These higher-order interactions are assumed to be zero.

Experiments can therefore be classified by resolution number into three groups:

• Resolution = 3 means that main effects are confounded with one or more two-way 
interactions, which must be assumed to be zero for the main effects to be meaningful.

• Resolution = 4 means that main effects are not confounded with other main effects or 
two-factor interactions. However, two-factor interactions are confounded with other 
two-factor interactions.
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• Resolution ≥ 5 means there is no confounding between main effects, between two-factor 
interactions, or between main effects and two-factor interactions.

A minimum aberration design is one in which there are a minimum number of confoundings 
for a given resolution. For DOE experts, the minimum aberration design of a given resolution 
minimizes the number of words in the defining relation that are of minimum length.

The figure on the right in Figure 6.14 is a geometric representation of a two-level fractional 
factorial design with three factors.

Figure 6.14  Representation of Full Factorial (Left) and Two-Level Fractional Factorial (Right) 
Designs

Plackett-Burman Designs

Plackett-Burman designs are an alternative to regular fractional factorials for screening. One 
useful characteristic is that the sample size is a multiple of four rather than a power of two. 
There are no two-level fractional factorial designs with sample sizes between 16 and 32 runs. 
However, there are 20-run, 24-run, and 28-run Plackett-Burman designs.

The main effects are orthogonal and two-factor interactions are only partially confounded 
with main effects. This is different from resolution-three fractional factorial where two-factor 
interactions are indistinguishable from main effects.

In cases of effect sparsity, a stepwise regression approach can allow for removing some 
insignificant main effects while adding highly significant and only somewhat correlated 
two-factor interactions. The Screening platform in JMP, Analyze > Modeling > Screening, is a 
streamlined approach for looking at sparse data. This platform can accept multiple responses 
and multiple factors, then automatically fits a two-level design and shows significant effects 
with plots and statistics. See “Analyzing Screening Data” on page 169 for details.

Mixed-Level Designs

For most designs that involve categorical or discrete numeric factors at three or more levels, 
standard designs do not exist. In such cases, the screening platform generates main effects 
screening designs that are orthogonal or nearly orthogonal for main effects.

-1, -1, -1
-1, 1, -1

1, 1, 1

-1, -1, 1

1, -1, -1

1, 1, -1
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The Design List provides fractional factorial designs for pure three-level factorials with up to 
13 factors. For mixed two-level and three-level designs, the Design list includes the complete 
factorials and specialized orthogonal-array designs listed in Table 6.1.

If your number of factors does not exceed the number for a design listed in the table, you can 
use that design by selecting an appropriate subset of columns from the original design. Some 
of these designs are not balanced, even though they are all orthogonal.

Cotter Designs

Cotter designs are used when you have very few resources and many factors, and you believe 
there may be interactions. Suppose you believe in effect sparsity— that very few effects are 
truly nonzero. You believe in this so strongly that you are willing to bet that if you add up a 
number of effects, the sum will show an effect if it contains an active effect. The danger is that 
several active effects with mixed signs will cancel and still sum to near zero and give a false 
negative.

Cotter designs are easy to set up. For k factors, there are 2k + 2 runs. The design is similar to the 
“vary one factor at a time” approach many books call inefficient and naive.

A Cotter design begins with a run having all factors at their high level. Then follow k runs 
each with one factor in turn at its low level, and the others high. The next run sets all factors at 
their low level and sequences through k more runs with one factor high and the rest low. This 
completes the Cotter design, subject to randomizing the runs.

When you use JMP to generate a Cotter design, the design also includes a set of extra columns 
to use as regressors. These are of the form factorOdd and factorEven where factor is a factor 
name. They are constructed by adding up all the odd and even interaction terms for each 
factor. For example, if you have three factors, A, B, and C:

Table 6.1  Table of Mixed-Level Designs

Design Two–Level Factors Three–Level Factors

L18 John 1 7

L18 Chakravarty 3 6

L18 Hunter 8 4

L36 11 12

Table 6.2  Cotter Design Table

AOdd = A + ABC AEven = AB + AC

BOdd = B + ABC BEven = AB + BC

COdd = C + ABC CEven = BC + AC
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Because these columns in a Cotter design make an orthogonal transformation, testing the 
parameters on these combinations is equivalent to testing the combinations on the original 
effects. In the example of factors listed above, AOdd estimates the sum of odd terms involving 
A. AEven estimates the sum of the even terms involving A, and so forth.

Because Cotter designs have a false-negative risk, many statisticians discourage their use.

How to Run a Cotter Design

By default, JMP does not include a Cotter design in the list of available screening designs 
(Figure 6.13). However, if you want to make a Cotter design:

1. Immediately after entering responses and factors (and before clicking Continue), click the 
red triangle icon in the Screening Design title bar.

2. Deselect Suppress Cotter Designs. (The option is initially selected.)

Changing the setting via the red triangle menu applies only to the current design. To alter the 
setting for all screening designs:

1. Select File > Preferences.

2. Click the Platforms icon.

3. Click DOE to highlight it.

4. Uncheck the box beside Suppress Cotter Designs.

Display and Modify Design

If you have chosen a Fractional Factorial design from the Design List, once you click Continue, 
the Display and Modify Design report opens. This report gives you options for modifying 
your design.

Figure 6.15  Display and Modify Options

Change Generating Rules Controls the choice of different fractional factorial designs for a 
given number of factors.

Aliasing of Effects Shows the confounding pattern for fractional factorial designs.

Coded Design Shows the pattern of high and low values for the factors in each run.
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Aliasing of Effects

To see which effects are confounded with which other effects, open the Aliasing of Effects 
outline. It shows effects and confounding up to two-factor interactions.

Figure 6.16  Generating Rules and Aliasing of Effects Panel

For example, a full factorial with five factors requires 25 = 32 runs. Eight runs can only 
accommodate a full factorial with three two-level factors. It is necessary to construct the two 
additional factors in terms of the first three factors.

The price of reducing the number of runs from 32 to eight is effect aliasing (confounding). 
Confounding is the direct result of the assignment of new factor values to products of the 
coded design columns.

In the example above, the values for Temperature are the product of the values for Feed Rate 
and Concentration. This means that you can’t tell the difference of the effect of Temperature and 
the synergistic (interactive) effect of Feed Rate and Concentration. 

The +/- option allows you to specify negative generating relations. This allows you to obtain 
different fractions of the design. When you deselect the +/- option, this switches the signs of 
the levels for design columns generated by the factors in the relation.

In the example shown in Figure 6.16, all the main effects are confounded with two-factor 
interactions. This is an example of a resolution-three design.

Look at the Confounding Pattern

JMP can create a data table that shows the aliasing pattern for a specified level. To create this 
table:

1. Click the red triangle at the bottom of the Aliasing of Effects area.
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2. Select Show Confounding Pattern (Figure 6.17).

Figure 6.17  Show Confounding Patterns

3. Enter the order of confounding you want to see (Figure 6.18).

Figure 6.18  Enter Order of Confounding in Text Edit Box

4. Click OK.

Figure 6.19 shows the third order aliasing for the five-factor reactor example. The effect names 
begin with C (Constant) and are shown by their order number in the design. Thus, 
Temperature appears as “4”, with second order aliasing as “1 5” (Feed Rate and Concentration), 
and third order confounding as “1 2 3” (Feed Rate, Catalyst, and Stir Rate).

Figure 6.19  The Third Level Alias for the Five-Factor Reactor Example
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Understanding Design Codes

In the Coded Design panel, each row represents a run. Plus signs designate high levels and 
minus signs represent low levels. As shown in Figure 6.20, rows for the first three columns of 
the coded design, which represent Feed Rate, Catalyst, and Stir Rate are all combinations of 
high and low values (a full factorial design). The fourth column (Temperature) of the coded 
design is the element-by-element product of the first three columns. Similarly, the last column 
(Concentration) is the product of the second and third columns.

Figure 6.20  Default Coded Designs

Changing the Coded Design

In the Change Generating Rules panel, changing the check marks and clicking Apply changes 
the coded design; it changes the choice of different fractional factorial designs for a given 
number of factors. The Coded Design table in Figure 6.20 shows how the last two columns are 
constructed in terms of the first three columns. The check marks in the Change Generating 
Rules table shown in Figure 6.21 for Temperature now show it is a function of Feed Rate, and 
Catalyst. The check marks for Concentration show it is a function of Feed Rate and Stir Rate.

If you check the options as shown in Figure 6.21 and click Apply, the Coded Design panel 
changes. The first three columns of the coded design remain a full factorial for the first three 
factors (Feed Rate, Catalyst, and Stir Rate). Temperature is now the product of Feed Rate and 
Catalyst, so the fourth column of the coded design is the element by element product of the 
first two columns. Concentration is a function of Feed Rate and Stir Rate.

Temperature Concentration

Feed Rate

Catalyst

Stir Rate



Chapter 6 Screening Designs 163
Design of Experiments Guide Creating a Screening Design

Figure 6.21  Modified Coded Designs and Generating Rules

Design Generation

The Design Generation report appears when you select the option “Generate orthogonal or 
near orthogonal designs for main effects only” or when there are no standard designs for your 
experimental situation. You can specify a number of runs in the panel, accept the default 
number, or select the minimum required number. Click Make Design to see the generated 
design.

The algorithm used to generate the design attempts to construct an orthogonal array of 
strength two. Strength-two orthogonal arrays permit orthogonal estimation of main effects 
when interactions are negligible. These arrays are ideal for screening designs. Regular 
fractional factorial designs of resolution three and Plackett-Burman designs are examples of 
strength two orthogonal arrays.

Consider all possible pairs of levels for factors in the design. The algorithm attempts to 
balance the number of pairs of levels as far as possible. Given that a fixed number of columns 
has been generated, a new balanced column is randomly constructed. A measure is defined 
that reflects the degree of balance achieved for pairs that involve the new column. The 
algorithm attempts to minimized this measure by interchanging levels within the new 
column.

You can control two aspects of the algorithm using options in the red triangle menu:

Number of Column Starts Allows you to specify the maximum number of times that the 
algorithm attempts to optimize a given column before moving on to constructing the next 
column. The default number of column starts is 50.

Number of Starts Allows you to specify the maximum number of times that the algorithm 
regenerates entire designs from scratch, attempting to optimize the overall design. The 
default number of starts is 300.
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Design Evaluation

A complete discussion of the Design Evaluation report is given in “Understanding Design 
Evaluation” on page 53 and the“Evaluating Experimental Designs” chapter on page 321.

Specify Output Options

Use the Output Options panel to specify how you want the output data table to appear. When 
you have finished, click Make Table to construct a data table for the design. Figure 6.22 shows 
the Output Options panel for a standard design. For a main effects screening design, only Run 
Order is available.

Figure 6.22  Select the Output Options

Run Order Lets you designate the order you want the runs to appear in the data table when it 
is created. Choices are:

Keep the Same The rows (runs) in the output table appear as they do in the Coded 
Design panel.

Sort Left to Right The rows (runs) in the output table appear sorted from left to right.

Randomize The rows (runs) in the output table appear in a random order.

Sort Right to Left The rows (runs) in the output table appear sorted from right to left.

Randomize within Blocks The rows (runs) in the output table appear in random order 
within the blocks you specify.

Number of Center Points Specifies how many additional runs to add as center points to the 
design. A center point is a run that is located in the center of the range of each continuous 
factor.

Number of Replicates For designs from the Design List, specifies the number of times to 
replicate the entire design, including center points. Type the number of times you want to 
replicate the design in the associated text box. One replicate doubles the number of runs.
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View the Design Table

Click Make Table to create a data table that contains the runs for your experiment. In the table, 
the high and low values you specified are displayed for each run.

Figure 6.23  The Design Data Table

The name of the table is the design type that generated it. Run the Screening script to screen 
for active effects. The column called Pattern shows the pattern of low values denoted “–” and 
high values denoted “+”. Pattern is especially useful as a label variable in plots.

Creating a Plackett-Burman design

The previous example shows an 8-run fractional factorial design for five continuous factors. 
But suppose you can afford 4 additional runs. First, repeat the steps shown in the previous 
sections. This time, use the Load Responses and Load Factors commands to define the design, 
as follows:

1. Select DOE > Screening Design.

2. Select Load Responses from the red triangle menu on the Screening Design title bar. 
Navigate to the Design Experiment folder in the Sample Data installed with JMP and open 
the file called Reactor Response.jmp.

3. Next, select Load Factors from red triangle menu on the Screening Design title bar. 
Navigate to the Design Experiment folder in the Sample Data installed with JMP and open 
the file called Reactor Factors.jmp.

These two commands complete the DOE screening dialog for you, with the correct response 
and factor names, goal and limits for the response, and the values for the factors.

4. Click Continue on the completed Screening design dialog. In the Choose Screening Type 
panel, click Continue again to see the list of designs in Figure 6.24. Select the 
Plackett-Burman design, as shown.
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Figure 6.24  Design List for 5-factor Plackett-Burman Screening Design

5. Click Continue.

After you select the design from the Design list, the Display and Modify Design and Design 
Evaluation outlines appear. In the Custom designer, you have the ability to form any model 
effects you want. The Screening designer creates the design effects based on the design you 
choose. In particular, the full factorial with all two-factor interactions has no aliasing of the 
included interactions. 

A complete discussion of the Design Evaluation options is in the “Evaluating Experimental 
Designs” chapter on page 321.

To continue with this example, do the following:

6. Choose Sort Left to Right in the Output Options panel.

7. Click Make Table to see the design runs shown in Figure 6.25.

Examine the data table and note the Pattern variable to see the arrangement of plus and minus 
signs that define the runs. This table is used in the analysis sections that follow.
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Figure 6.25  Listing of a 5-factor Placket-Burman Design Table

Creating a Main Effects Screening Design

Main effects screening designs are orthogonal or near-orthogonal designs. These designs are 
offered both in place of standard designs and in situations where standard designs don’t exist. 
Main effects screening designs are excellent designs for estimating main effects when 
interactions are negligible. 

An example will be used to illustrate main effects screening designs. For this experimental 
situation, no standard design exists. You need a design to study 13 factors: 2 are categorical, 
one with 4 levels and one with 6 levels, and 11 are continuous.

Select DOE > Screening Design from the main menu. In the Responses panel, there is a single 
default response called Y. Do the following in the Factors panel:

1. Select 4 Level from the Categorical list. This adds the variable X1 with levels L1, L2, L3, 
and L4.

2. Select 6 Level from the Categorical list. This adds the variable X2, with levels L1, L2, L3, L4, 
L5, and L6.

3. Enter 11 in the box to the right of Add N Factors. 

4. Click Continuous. This adds 11 factors, X3 to X13, each at two levels, -1 and 1. 

When you click Continue, the Design Generation panel appears (Figure 6.26). Note that the 
option of selecting a design from the Design List does not appear, as there is no available 
standard design for this experimental situation.
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Figure 6.26  Screening Design Dialog for 13 Factors, with Design Generation Panel

The Back button gives you the option to return to the Responses and Factors panels. Accept 
the default number of runs (24) and click Make Design.

The randomized design is shown as part of the Screening Design report. The algorithm that 
generates the design is stochastic, so to reproduce this design, you need to save the script with 
the random seed. (To do this, select Save Script to Script Window from the red triangle menu 
next to the report title.)

To see that this specific design is orthogonal, click the disclosure icon next to Design 
Evaluation. Next, click the disclosure icon next to Color Map On Correlations. The color map 
(Figure 6.27) shows red entries corresponding to correlation of one on the main diagonal. 
Off-diagonal correlations are all deep blue, indicating that correlations between the 
parameters are all zero.

Figure 6.27  Color Map on Correlations
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Analyzing Screening Data

After creating and viewing the data table, you can analyze the data in the Screening or Fit 
Model platforms. 

• If your factors are all two-level and orthogonal, then all of the statistics in the Screening 
platform should work well.

• For highly supersaturated main effect designs, the Screening platform is effective in 
selecting factors, but is not as effective at estimating the error or the significance. The 
Monte Carlo simulation to produce p-values uses assumptions that are not valid for this 
case.

• If you have categorical terms with more than two levels, then the Screening platform is not 
appropriate for the design. JMP treats the level numbers as a continuous regressor. The 
variation across the factor is scattered across main and polynomial effects for that term.

• If your data are not orthogonal, then the constructed estimates are different from standard 
regression estimates. JMP can pick out big effects, but it does not effectively test each 
effect. This is because later effects are artificially orthogonalized, making earlier effects 
look more significant.

• The Screening platform is not appropriate for mixture designs.

Comparing Screening and Fit Model

Consider the Reactor Half Fraction.jmp sample data table. The data are derived from a design 
discussed in Box, Hunter, and Hunter (1978). We are interested in a model with main effects 
and two-way interactions. This example uses a model with fifteen parameters for a design 
with sixteen runs.

For this example, select all continuous factors, except the response, Percent Reacted, as the 
screening effects, X. Select Percent Reacted as the response Y. The screening platform 
constructs interactions automatically. This is in contrast to Fit Model, where you manually 
specify the interactions that you want to include in your model.

Figure 6.28 shows the result of using the Fit Model platform, where a factorial to degree 2 
model is specified. This result illustrates why the Screening platform is needed.
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Figure 6.28  Traditional Saturated Reactor Half Fraction.jmp Design Output

JMP can calculate parameter estimates, but degrees of freedom for error, standard errors, 
t-ratios, and p-values are all missing. Rather than use Fit Model, it is better to use the 
Screening platform, which specializes in getting the most information out of these situations, 
leading to a better model. The output from the Screening platform for the same data is shown 
in Figure 6.29.
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Figure 6.29  Reactor Half Fraction.jmp Screening Design Report

Compare the following differences between the Fit Model report and the Screening report.

• Estimates labeled Contrast. Effects whose individual p-value is less than 0.1 are 
highlighted.

• A t-ratio is calculated using Lenth’s PSE (pseudo-standard error). The PSE is shown below 
the Half Normal Plot.

• Both individual and simultaneous p-values are shown. Those that are less than 0.05 are 
shown with an asterisk.

• A Half Normal plot enables you to quickly examine the effects. Effects initially highlighted 
in the effects list are also labeled in this plot.

• Buttons at the bottom of the report also operate on the highlighted variables. The Make 
Model button opens the Fit Model window using the current highlighted factors. The Run 
Model button runs the model immediately.
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For this example, Catalyst, Temperature, and Concentration, along with two of their two-factor 
interactions, are selected.

Launch the Screening Platform

Open the data table called Plackett-Burman.jmp, found in Design Experiment folder in the 
Sample Data installed with JMP. This table contains the design runs and the Percent Reacted 
experimental results for the 12-run Plackett-burman design created in the previous section.

The data table has two scripts called Screening and Model, showing in the upper-left corner of 
the table, that were created by the DOE Screening designer. You can use these scripts to 
analyze the data, however it is simple to run the analyses yourself.

1. Select Analyze > Modeling > Screening to see the completed launch dialog shown in 
Figure 6.30. When you create a DOE design table, the variable roles are saved with the 
data table and used by the launch platform to complete the dialog.

Figure 6.30  Launch Dialog for the Screening Platform

2. Click OK to see the Screening platform result shown in Figure 6.31.
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Figure 6.31  Results of the Screening Analysis

3. Examine the Half Normal plot in Figure 6.31. 

The Screening Report

The Contrasts section of the Screening report lists all possible model effects, a contrast value 
for each effect, Lenth t-ratios (calculated as the contrast value divided by the Lenth PSE 
(pseudo-standard error), individual and simultaneous p-values, and aliases if there are any. 
Significant and marginally significant effects are highlighted. 

Contrasts

The following table describes the information in the Contrasts report.

Table 6.3  Description of the Contrasts Report

Term Name of the factor.
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Half Normal Plot

The Half Normal Plot shows the absolute value of the contrasts against the normal quantiles 
for the absolute value normal distribution. Significant effects appear separated from the line 
towards the upper right of the graph.

The Half Normal Plot is interactive. Select different model effects by dragging a rectangle 
around the effects of interest, or hold down CTRL and click on an effect name in the report.

Using the Fit Model Platform

The Make Model button beneath the Half Normal Plot creates a Fit Model dialog that includes 
all the highlighted effects. However, note that the Catalyst*Stir Rate interaction is highlighted, 
but the Stir Rate main effect is not. Therefore, you should add the Stir Rate main effect to the 
model.

4. Click the Make Model Button beneath the Half Normal Plot.

5. Select Stir Rate and click Add on the Fit Model dialog. 

Contrast Estimate for the factor. For orthogonal designs, this number is the 
same as the regression parameter estimate. This is not the case for 
non-orthogonal designs. An asterisk might appear next to the 
contrast, indicating a lack of orthogonality.

Bar Chart Shows the t-ratios with blue lines marking a critical value at 0.05 
significance.

Lenth t-Ratio Lenth’s t-ratio, calculated as , where PSE is Lenth’s 
Pseudo-Standard Error. See “Lenth’s Pseudo-Standard Error” on 
page 181 for details.

Individual p-Value Analogous to the standard p-values for a linear model. Small 
values of this value indicate a significant effect. Refer to “Statistical 
Details” on page 180 for details.

Do not expect the p-values to be exactly the same if the analysis is 
re-run. The Monte Carlo method should give similar, but not 
identical, values if the same analysis is repeated.

Simultaneous 
p-Value

Similar to the individual p-value, but multiple-comparison 
adjusted.

Aliases Appears only if there are exact aliases of later effects to earlier 
effects.

Table 6.3  Description of the Contrasts Report (Continued)

Contrast
PSE

----------------------
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6. The Emphasis might change to Effect Screening when you add Stir Rate. Change it back to 
Effect Leverage. The dialog is shown in Figure 6.32.

7. Then click Run to see the analysis results.

Figure 6.32  Create Fit Model Dialog and Remove Unwanted Effect

The Actual-by-Predicted Plot

The Whole Model actual-by-predicted plot, shown in Figure 6.33, appears at the top of the Fit 
Model report. You see at a glance that this model fits well. The blue line falls outside the 
bounds of the 95% confidence curves (red-dotted lines), which tells you the model is 
significant. The model p-value (p = 0.0208), R2, and RMSE appear below the plot. The RMSE is 
an estimate of the standard deviation of the process noise, assuming that the unestimated 
effects are negligible.
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Figure 6.33  An Actual-by-Predicted Plot

The Scaled Estimates Report

To see a scaled estimates report, use Effect Screening > Scaled Estimates found in the red 
triangle menu on the Response Percent Reacted title bar. When there are quadratic or 
polynomial effects, the coefficients and the tests for them are more meaningful if effects are 
scaled and coded. The Scaled Estimates report includes a bar chart of the individual effects 
embedded in a table of parameter estimates. The last column of the table has the p-values for 
each effect.

Figure 6.34  Example of a Scaled Estimates Report

A Power Analysis

The Fit Model report has outline nodes for the Catalyst and Temperature effects. To run a 
power analysis for an effect, click the red triangle icon on its title bar and select Power 
Analysis.

This example shows a power analysis for the Catalyst variable, using default value for α (0.05), 
the root mean square error and parameter estimate for Catalyst, for a sample size of 12. The 
resulting power is 0.8926, which means that in similar experiments, you can expect an 89% 
chance of detecting a significant effect for Catalyst.
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Figure 6.35  Example of a Power Analysis

Refer to the Fitting Linear Models book for details.

Additional Screening Analysis Examples

This section provides examples of using the Screening platform.

Analyzing a Plackett-Burman Design

Plackett-Burman designs are an alternative to fractional-factorial screening designs. Two-level 
fractional factorial designs must, by their nature, have a number of runs that are a power of 
two. Plackett-Burman designs exist for 12-, 24-, and 28-run designs.

Weld-Repaired Castings.jmp from the sample data folder uses a Plackett-Burman design, and is 
found in textbooks such as Giesbrecht and Gumpertz (2004) and Box, Hunter, and Hunter 
(1978). Seven factors are thought to be influential on weld quality. The seven factors include 
Initial Structure, Bead Size, Pressure Treatment, Heat Treatment, Cooling Rate, Polish, and Final 
Treatment. A Plackett-Burman design with 12 runs is used to investigate the importance of the 
seven factors. The response is . (There are also four terms that were used to 
model error that are not used in this analysis.)

Using the Screening platform, select the seven effects as X and Log Life as Y. (If terms are 
automatically populated in the Screening Platform launch window, remove the four error 
terms listed as effects.) Click OK. Figure 6.36 appears, showing only a single significant effect.

100 lifetime( )log×
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Figure 6.36  Screening Report for Weld-Repaired Castings.jmp

Note asterisks mark four terms, indicating that they are not orthogonal to effects preceding 
them, and the obtained contrast value was after orthogonalization. So, they would not match 
corresponding regression estimates.

Analyzing a Supersaturated Design

Supersaturated designs have more factors than runs. The objective is to determine which 
effects are active. They rely heavily on effect sparsity for their analysis, so the Screening 
platform is ideal for their analysis.

As an example, look at Supersaturated.jmp, from the sample data folder, a simulated data set 
with 18 factors but only 12 runs. Y is generated by

where ε ~ N(0,1). So, Y has been constructed with three active factors.

Y 2 X7( ) 5 X10( ) 3 X15( )– ε+ +=
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To detect the active factors, run the Screening platform with X1–X18 as X and Y as Y. The 
report shown in Figure 6.37 appears.

Figure 6.37  Screening Report for Supersaturated.jmp

Note that the three active factors have been highlighted. One other factor, X18, has also been 
highlighted. It shows in the Half Normal plot close to the blue line, indicating that it is close to 
the 0.1 cutoff significance value. The 0.1 critical value is generous in its selection of factors so 
you don’t miss those that are possibly active.

The contrasts of 5.1, –3, and 1.8 are close to their simulated values (5, –3, 2). However, the 
similarity of these values can be increased by using a regression model, without the effect of 
orthogonalization.

The p-values, while useful, are not entirely valid statistically, since they are based on a 
simulation that assumes orthogonal designs, which is not the case for supersaturated designs.
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Statistical Details

Operation

The Screening platform has a carefully defined order of operations.

• First, the main effect terms enter according to the absolute size of their contrast. All effects 
are orthogonalized to the effects preceding them in the model. The method assures that 
their order is the same as it would be in a forward stepwise regression. Ordering by main 
effects also helps in selecting preferred aliased terms later in the process.

• After main effects, all second-order interactions are brought in, followed by third-order 
interactions, and so on. The second-order interactions cross with all earlier terms before 
bringing in a new term. For example, with size-ordered main effects A, B, C, and D, B*C 
enters before A*D. If a factor has more than two levels, square and higher-order 
polynomial terms are also considered.

• An effect that is an exact alias for an effect already in the model shows in the alias column. 
Effects that are a linear combination of several previous effects are not displayed. If there 
is partial aliasing ( a lack of orthogonality) the effects involved are marked with an 
asterisk.

• The process continues until n effects are obtained, where n is the number of rows in the 
data table, thus fully saturating the model. If complete saturation is not possible with the 
factors, JMP generates random orthogonalized effects to absorb the rest of the variation. 
They are labeled Null n where n is a number. For example, this situation occurs if there are 
exact replicate rows in the design.

Screening as an Orthogonal Rotation

Mathematically, the Screening platform takes the n values in the response vector and rotates 
them into n new values. The rotated values are then mapped by the space of the factors and 
their interactions.

Contrasts = T’ × Responses

where T is an orthonormalized set of values starting with the intercept, main effects of factors, 
two-way interactions, three-way interactions, and so on, until n values have been obtained. 
Since the first column of T is an intercept, and all the other columns are orthogonal to it, these 
other columns are all contrasts, that is, they sum to zero. Since T is orthogonal, it can serve as 
X in a linear model. It does not need inversion, since T’ is also T-1 and (T’T)T’. The contrasts 
are the parameters estimated in a linear model.
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• If no effect in the model is active after the intercept, the contrasts are just an orthogonal 
rotation of random independent variates into different random independent variates. 
These newly orthogonally rotated variates have the same variance as the original random 
independent variates. To the extent that some effects are active, the inactive effects still 
represent the same variation as the error in the model. The hope is that the effects and the 
design are strong enough to separate the active effects from the random error effects.

Lenth’s Pseudo-Standard Error

At this point, Lenth’s method (Lenth, 1989) identifies inactive effects from which it constructs 
an estimate of the residual standard error, known as the Lenth Pseudo Standard Error (PSE).

The value for Lenth’s PSE is shown at the bottom of the Screening report. From the PSE, 
t-ratios are obtained. To generate p-values, a Monte Carlo simulation of 10,000 runs of n – 1 
purely random values is created and Lenth t-ratios are produced from each set. The p-value is 
the interpolated fractional position among these values in descending order. The 
simultaneous p-value is the interpolation along the max(|t|) of the n – 1 values across the 
runs. This technique is similar to that in Ye and Hamada (2000).

If you want to run more or less than the 10,000 default runs, you must assign a value to a 
global JSL variable named LenthSimN. As an example, using the sample data Reactor Half 
Fraction.jmp:

1. Open the sample data, Reactor Half Fraction.jmp.

2. Select Analyze > Modeling > Screening.

3. Select Percent Reacted as the response variable, Y.

4. Select all the other continuous variables as effects, X.

5. Click OK.

6. Select Script > Save Script to Script Window from the red-triangle menu of the report.

7. Add LenthSimN=50000; to the top of the Script Window (above the code).

8. Highlight LenthSimN=50000; and the remaining code.

9. Run the script from the Script Window.

Note that if LenthSimN=0, the standard t-distribution is used (not recommended).
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Chapter 7
Response Surface Designs

Response surface designs are useful for modeling a curved quadratic surface to continuous 
factors. A response surface model can pinpoint a minimum or maximum response, if one 
exists inside the factor region. Three distinct values for each factor are necessary to fit a 
quadratic function, so the standard two-level designs cannot fit curved surfaces. 

The most popular response surface design is the central composite design, illustrated in the 
figure to the left below. It combines a two-level fractional factorial and two other kinds of 
points:

• Center points, for which all the factor values are at the zero (or midrange) value.

• Axial (or star) points, for which all but one factor are set at zero (midrange) and that one 
factor is set at outer (axial) values.

The Box-Behnken design, illustrated in the figure on the right below, is an alternative to 
central composite designs. One distinguishing feature of the Box-Behnken design is that there 
are only three levels per factor. 

Another important difference between the two design types is that the Box-Behnken design 
has no points at the vertices of the cube defined by the ranges of the factors. This is sometimes 
useful when it is desirable to avoid these points due to engineering considerations. The price 
of this characteristic is the higher uncertainty of prediction near the vertices compared to the 
central composite design.

Figure 7.1  Response Surface Designs

center points

axial points

fractional factorial points

Central Composite Design Box-Behnken Design
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A Box-Behnken Design: The Tennis Ball Example

The Bounce Data.jmp sample data file has response surface data inspired by the tire tread data 
described in Derringer and Suich (1980). The objective of this experiment is to match a 
standardized target value (450) of tennis ball bounciness. The bounciness varies with amounts 
of Silica, Silane, and Sulfur used to manufacture the tennis balls. The experimenter wants to 
collect data over a wide range of values for these variables to see if a response surface can find 
a combination of factors that matches a specified bounce target. To follow this example:

1. Select DOE > Response Surface Design.

2. Load factors by clicking the red triangle icon on the Response Surface Design title bar and 
selecting Load Factors. Navigate to the sample data folder installed with JMP, and open 
Bounce Factors.jmp from the Design Experiment folder.

3. Load the responses by clicking the red triangle icon on the Response Surface Design title 
bar and selecting Load Responses. Navigate to the sample data folder, and open Bounce 
Response.jmp from the Design Experiment folder. Figure 7.2 shows the completed 
Response panel and Factors panel.

Figure 7.2  Response and Factors For Bounce Data

After the response data and factors data are loaded, the Response Surface Design Choice 
dialog lists the designs in Figure 7.3. (Click Continue to see the choices on the right.)

Figure 7.3  Response Surface Design Selection
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The Box-Behnken design selected for three effects generates the design table of 15 runs shown 
in Figure 7.4.

In real life, you would conduct the experiment and then enter the responses into the data 
table. Suppose you completed the experiment and the final data table is Bounce Data.jmp.

1. Open Bounce Data.jmp from the Design Experiment folder found in the sample data 
installed with JMP (Figure 7.4).

Figure 7.4  JMP Table for a Three-Factor Box-Behnken Design

After opening the Bounce Data.jmp data table, run a fit model analysis on the data. The data 
table contains a script labeled Model, showing in the upper left panel of the table.

2. Click the red triangle next to Model and select Run Script to start a fit model analysis.

3. When the Fit Model dialog appears, click Run.

The standard Fit Model analysis results appear in tables shown in Figure 7.5, with parameter 
estimates for all response surface and crossed effects in the model.

The prediction model is highly significant with no evidence of lack of fit. All main effect terms 
are significant as well as the two interaction effects involving Sulfur.
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Figure 7.5  JMP Statistical Reports for a Response Surface Analysis of Bounce Data

See the Multivariate Methods book for more information about interpretation of the tables in 
Figure 7.5.

Note: DOE response surface designs are available for up to eight factors only. In the DOE 
Response Surface Design platform, an error message is generated if more than eight factors 
are specified with a response surface design. Response surface designs with more than eight 
factors can be generated using DOE > Custom Design, where either a D-optimal or an 
I-optimal design can be specified. See “Creating Response Surface Experiments” on page 102 
for how to use the custom designer to create response surface designs. Curvature analysis is 
not shown (no error or warning message is given) for response surface designs of more than 
20 factors when using the custom designer or the Fit Model platform; all other analyses are 
valid and are shown.

The Response Surface report also has the tables shown in Figure 7.6.
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Figure 7.6  Statistical Reports for a Response Surface Analysis

The Response Surface report shows a summary of the parameter estimates.

The Solution report lists the critical values of the surface factors and tells the kind of solution 
(maximum, minimum, or saddle point). The solution for this example is a saddle point. The 
table also warns that the critical values given by the solution are outside the range of data 
values.

The Canonical Curvature report shows eigenvalues and eigenvectors of the effects. The 
eigenvector values show that the dominant negative curvature (yielding a maximum) is 
mostly in the Sulfur direction. The dominant positive curvature (yielding a minimum) is 
mostly in the Silica direction. This is confirmed by the prediction profiler in Figure 7.8.

See the Multivariate Methods book for details about the response surface analysis tables in 
Figure 7.6.

The Prediction Profiler

Next, use the response Prediction Profiler to get a closer look at the response surface and help 
find the settings that produce the best response target. The Prediction Profiler is a way to 
interactively change variables and look at the effects on the predicted response.

1. If the Prediction Profiler is not already open, click the red triangle on the Response Stretch 
title bar and select Factor Profiling > Profiler.

The first three plots in the top row of plots in the Prediction Profiler (Figure 7.7) display 
prediction traces for each x variable. A prediction trace is the predicted response as one variable 
is changed while the others are held constant at the current values (Jones 1991).
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The current predicted value of Stretch, 396, is based on the default factor setting. It is 
represented by the horizontal dotted line that shows slightly below the desirability function 
target value (Figure 7.7). The profiler shows desirability settings for the factors Silica, Silane, 
and Sulfur that give a value for Stretch of 396, which is quite different from the specified target 
of 450.

The bottom row has a plot for each factor, showing its desirability trace. The profiler also 
contains a Desirability column, which graphs desirability on a scale from 0 to 1 and has an 
adjustable desirability function for each y variable. The overall desirability measure is on the 
left of the desirability traces.

Figure 7.7  The Prediction Profiler

2. To adjust the prediction traces of the factors and find a Stretch value that is closer to the 
target, click the red triangle on the Prediction Profiler title bar and select Maximize 
Desirability. This command adjusts the profile traces to produce the response value closest 
to the specified target (the target given by the desirability function). The range of 
acceptable values is determined by the positions of the upper and lower handles.

Figure 7.8 shows the result of the most desirable settings. Finding maximum desirability is an 
iterative process so your results may differ slightly from those shown below.



190 Response Surface Designs Chapter 7
A Box-Behnken Design: The Tennis Ball Example Design of Experiments Guide

Figure 7.8  Prediction Profiler with Maximum Desirability Set for a Response Surface Analysis

See the Multivariate Methods book for further discussion of the Prediction Profiler.

A Response Surface Plot (Contour Profiler)

Another way to look at the response surface is to use the Contour Profiler. Click the red 
triangle on the Response Stretch title bar and select Factor Profiling > Contour Profiler to 
display the interactive contour profiler, as shown in Figure 7.9.

The contour profiler is useful for viewing response surfaces graphically, especially when there 
are multiple responses. This example shows the profile to Silica and Sulfur for a fixed value of 
Silane.

Options on the Contour Profiler title bar can be used to set the grid density, request a surface 
plot (mesh plot), and add contours at specified intervals, like those shown in the contour plot 
in Figure 7.9. The sliders for each factor set values for Current X and Current Y.
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Figure 7.9  Contour Profiler for a Response Surface Analysis

Enter the Lo limit and Hi limit values to shade the unacceptable regions in the contour plot.

Figure 7.10  Contour Profiler with High and Low Limits

The Prediction Profiler and the Contour Profiler are discussed in more detail in the 
Multivariate Methods book.
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Geometry of a Box-Behnken Design

The geometric structure of a design with three effects is seen by using the Scatterplot 3D 
platform. The plot shown in Figure 7.11 illustrates the three Box-Behnken design columns. 
You can clearly see the center points and the 12 points midway between the vertices. For 
details on how to use the Scatterplot 3D platform, see the Essential Graphing book.

Figure 7.11  Scatterplot 3D Rendition of a Box-Behnken Design for Three Effects

Creating a Response Surface Design

Response Surface Methodology (RSM) is an experimental technique invented to find the 
optimal response within specified ranges of the factors. These designs are capable of fitting a 
second-order prediction equation for the response. The quadratic terms in these equations 
model the curvature in the true response function. If a maximum or minimum exists inside the 
factor region, RSM can estimate it. In industrial applications, RSM designs usually involve a 
small number of factors. This is because the required number of runs increases dramatically 
with the number of factors. Using the response surface designer, you choose to use 
well-known RSM designs for two to eight continuous factors. Some of these designs also allow 
blocking.

Response surface designs are useful for modeling and analyzing curved surfaces.

To start a response surface design, select DOE > Response Surface Design, or click the 
Response Surface Design button on the JMP Starter DOE page. Then, follow the steps 
described in the following sections.
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• “Enter Responses and Factors” on page 193

• “Choose a Design” on page 193

• “Specify Axial Value (Central Composite Designs Only)” on page 194

• “Specify Output Options” on page 195

• “View the Design Table” on page 196

Enter Responses and Factors

The steps for entering responses are the same in Screening Design, Space Filling Design, 
Mixture Design, Response Surface Design, Custom Design, and Full Factorial Design. These 
steps are outlined in “Enter Responses and Factors into the Custom Designer” on page 45

Factors in a response surface design can only be continuous. The Factors panel for a response 
surface design appears with two default continuous factors. To enter more factors, type the 
number you want in the Factors panel edit box and click Add, as shown in Figure 7.12.

Figure 7.12  Enter Factors into a Response Surface Design

Click Continue to proceed to the next step.

Choose a Design

Highlight the type of response surface design you want and click Continue. The next sections 
describe the types of response surface designs shown in Figure 7.13.
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Figure 7.13  Choose a Design Type

Box-Behnken Designs 

The Box-Behnken design has only three levels per factor and has no points at the vertices of 
the cube defined by the ranges of the factors. This is sometimes useful when it is desirable to 
avoid extreme points due to engineering considerations. The price of this characteristic is the 
higher uncertainty of prediction near the vertices compared to the central composite design.

Central Composite Designs

The response surface design list contains two types of central composite designs: uniform 
precision and orthogonal. These properties of central composite designs relate to the number of 
center points in the design and to the axial values:

• Uniform precision means that the number of center points is chosen so that the prediction 
variance near the center of the design space is very flat.

• For orthogonal designs, the number of center points is chosen so that the second order 
parameter estimates are minimally correlated with the other parameter estimates.

Specify Axial Value (Central Composite Designs Only)

When you select a central composite (CCD-Uniform Precision) design and then click 
Continue, you see the panel in Figure 7.14. It supplies default axial scaling information. 
Entering 1.0 in the text box instructs JMP to place the axial value on the face of the cube 
defined by the factors, which controls how far out the axial points are. You have the flexibility 
to enter the values you want to use.
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Figure 7.14  Display and Modify the Central Composite Design

Rotatable makes the variance of prediction depend only on the scaled distance from the 
center of the design. This causes the axial points to be more extreme than the range of the 
factor. If this factor range cannot be practically achieved, it is recommended that you 
choose On Face or specify your own value.

Orthogonal makes the effects orthogonal in the analysis. This causes the axial points to be 
more extreme than the –1 or 1 representing the range of the factor. If this factor range 
cannot be practically achieved, it is recommended that you choose On Face or specify your 
own value.

On Face leaves the axial points at the end of the -1 and 1 ranges.

User Specified uses the value you enter in the Axial Value text box.

If you want to inscribe the design, click the box beside Inscribe. When checked, JMP rescales 
the whole design so that the axial points are at the low and high ends of the range (the axials 
are –1 and 1 and the factorials are shrunken based on that scaling).

Specify Output Options

Use the Output Options panel to specify how you want the output data table to appear. When 
the options are specified the way you want them, click Make Table. Note that the example 
shown in Figure 7.15 is for a Box-Behnken design. The Box-Behnken design from the design 
list and the Output Options request 3 center points and no replicates.

Figure 7.15  Select the Output Options
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Run Order provides a menu with options for designating the order you want the runs to 
appear in the data table when it is created. Menu choices are:

Keep the Same the rows (runs) in the output table will appear in the standard order.

Sort Left to Right the rows (runs) in the output table will appear sorted from left to right.

Randomize the rows (runs) in the output table will appear in a random order.

Sort Right to Left the rows (runs) in the output table will appear sorted from right to left.

Randomize within Blocks the rows (runs) in the output table will appear in random order 
within the blocks you set up.

Add additional points with options given by Make JMP Table from design plus:

Number of Center Points Specifies how many additional runs to add as center points to the 
design. A center point is a run that is located in the center of the range of each continuous 
factor.

Number of Replicates Specify the number of times to replicate the entire design, including 
center points. Type the number of times you want to replicate the design in the associated 
text box. One replicate doubles the number of runs.

View the Design Table

Now you have a data table that outlines your experiment, as described in Figure 7.16.

Figure 7.16  The Design Data Table

The name of the table is the design type that generated it.

Run the Model script to fit a model using the values in the design table.
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The column called Pattern identifies the coding of the factors. It shows all the codings with “+” 
for high, “–” for low factor, “a” and “A” for low and high axial values, and “0” for midrange. 
Pattern is suitable to use as a label variable in plots because when you hover over a point in a 
plot of the factors, the pattern value shows the factor coding of the point.The three rows 
whose values in the Pattern column are 000 are three center points.

The runs in the Pattern column are in the order you selected from the Run Order menu.

The Y column is for recording experimental results.
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Chapter 8
Full Factorial Designs

A full factorial design contains all possible combinations of a set of factors. This is the most 
fool proof design approach, but it is also the most costly in experimental resources. The full 
factorial designer supports both continuous factors and categorical factors with up to nine 
levels.

In full factorial designs, you perform an experimental run at every combination of the factor 
levels. The sample size is the product of the numbers of levels of the factors. For example, a 
factorial experiment with a two-level factor, a three-level factor, and a four-level factor has 2 x 
3 x 4 = 24 runs. 

Factorial designs with only two-level factors have a sample size that is a power of two 
(specifically 2f where f is the number of factors). When there are three factors, the factorial 
design points are at the vertices of a cube as shown in the diagram below. For more factors, the 
design points are the vertices of a hypercube.

Full factorial designs are the most conservative of all design types. There is little scope for 
ambiguity when you are willing to try all combinations of the factor settings. 

Unfortunately, the sample size grows exponentially in the number of factors, so full factorial 
designs are too expensive to run for most practical purposes. 

Figure 8.1  Full Factorial Design
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The Five-Factor Reactor Example

The following example, adapted from Meyer et al. (1996) and Box, Hunter, and Hunter (1978), 
shows a five-factor reactor example.

Previously, the screening designer was used to investigate the effects of five factors on the 
percent reaction of a chemical process (see “Screening Designs” on page 143). The factors 
(Feed Rate, Catalyst, Stir Rate, Temperature, and Concentration) are all two-level continuous 
factors. The next example studies the same system using a full factorial design.

1. Select DOE > Full Factorial Design.

2. Click the red triangle icon on the Full Factorial Design title bar and select Load Responses.

3. In the sample data folder (installed with JMP), open Reactor Response.jmp found in the 
Design Experiment folder.

4. Click the red triangle icon on the Full Factorial Design title bar and select Load Factors.

5. In the sample data folder (installed with JMP), open Reactor Factors.jmp found in the 
Design Experiment folder.

The completed dialog should look like the one shown in Figure 8.2.

Figure 8.2  Full Factorial Example Response and Factors Panels

6. Click Continue to see the Output Options panel. In the Output Options panel, select Sort 
Left to Right from the Run Order menu, as shown to the right. This command defines the 
order of runs as they will be in the final JMP design table.



202 Full Factorial Designs Chapter 8
The Five-Factor Reactor Example Design of Experiments Guide

7. Click Make Table.

The design data table (Figure 8.3) contains a run for every combination of high and low values 
for the five variables, which covers all combinations of five factors with two levels each. Since 
there are five variables, there are 25=32 runs. Initially, the table has an empty Y column named 
Percent Reacted for entering response values when the experiment is complete.

To see the completed experiment and continue this example, open Reactor 32 Runs.jmp found 
in the Design Experiment sample data folder.

Figure 8.3  Partial Listing of Reactor 32 Runs.jmp from the Sample Data Folder

Analyze the Reactor Data

Begin the analysis with a quick look at the response data before fitting the factorial model.

1. Select Analyze > Distribution.

2. Highlight Percent Reacted and click Y, Columns. Then click OK.

3. Click the red triangle icon on the Percent Reacted title bar and select Normal Quantile Plot. 
The results are shown in Figure 8.4.
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Figure 8.4  Distribution of Response Variable for Reactor Data

This initial analysis shows some experimental runs with a very high percent reacted response.

Start the formal analysis with a stepwise regression. The data table has a script stored with it 
that automatically defines an analysis of the model with main effects and all two-factor 
interactions.

4. Click the red triangle icon next to the Fit Model script and select Run Script. The stepwise 
analysis begins with the Stepwise Regression Control panel shown in Figure 8.5.

5. Select P-value Threshold from the Stopping Rule list.

6. The probability to enter a factor (Prob to Enter) in the model should be 0.05.

7. The probability to remove a factor (Prob to Leave) should be 0.1.

8. A useful way to use the Stepwise platform is to check all the main effects in the Current 
Estimates table. However, make sure that the menu beside Direction in the Stepwise 
Regression Control panel specifies Mixed (see Figure 8.5).

Figure 8.5  Stepwise Control Panel

9. Check the boxes for the main effects of the factors as shown in Figure 8.6.
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Figure 8.6  Starting Model For Stepwise Process

10. Click Go.

The mixed stepwise procedure removes insignificant main effects and adds important 
interactions. The end result is shown in Figure 8.7. Note that the Feed Rate and Stir Rate 
factors are no longer in the model.

Figure 8.7  Model After Mixed Stepwise Regression

11. Click the Make Model button in the Stepwise Regression Control panel. The Model 
Specification window that appears is automatically set up with the appropriate effects 
(Figure 8.8).
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Figure 8.8  Fitting a Prediction Model

12. Click Run to see the analysis for a candidate prediction model (Figure 8.9).

The figure on the left in Figure 8.9 shows the actual by predicted plot for the model. The 
predicted model covers a range of predictions from 40% to 95% reacted. The size of the 
random noise as measured by the RMSE is only 3.3311%, which is more than an order of 
magnitude smaller than the range of predictions. This is strong evidence that the model has 
good predictive capability.

The figure on the right in Figure 8.9 shows a table of model coefficients and their standard 
errors (labeled Parameter Estimates). All effects selected by the stepwise process are highly 
significant.

Figure 8.9  Actual by Predicted Plot and Prediction Parameter Estimates Table

The factor Prediction Profiler also gives you a way to compare the factors and find optimal 
settings.
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1. To open the Prediction Profiler, click the red triangle on the Response Percent Reacted title 
bar and select Factor Profiling > Profiler.

Figure 8.10 shows the profiler’s initial display. The Prediction Profiler is discussed in more 
detail in the chapter “Response Surface Designs” on page 183, and in the Multivariate 
Methods book.

Figure 8.10  Viewing the Profiler

2. Click the red triangle on the Prediction Profiler title bar and select Maximize Desirability to 
see the profiler in Figure 8.11.

Figure 8.11  Viewing the Prediction Profiles at the Optimum Settings
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The goal is to maximize Percent Reacted. The reaction is unfeasible economically unless the 
Percent Reacted is above 90%. Percent Reacted increases from 65.5 at the center of the factor 
ranges to a predicted maximum of 95.875 ± 2.96 at the most desirable settings. The best 
settings of all three factors are at the ends of their ranges. Future experiments could 
investigate what happens as you continue moving further in this direction.

Creating a Factorial Design

To start a full factorial design, select DOE > Full Factorial Design, or click the Full Factorial 
Design button on the JMP Starter DOE page. Then, follow the steps below:

• “Enter Responses and Factors” on page 207

• “Select Output Options” on page 208

• “Make the Table” on page 208

Enter Responses and Factors

The steps for entering responses are outlined in “Enter Responses and Factors into the Custom 
Designer” on page 45

The steps for entering factors in a full factorial design are unique to this design. To add factors, 
see Figure 8.12.

1. To enter factors, click either the Continuous button or the Categorical button and select a 
factor type, level 2 - 9.

2. Double-click to edit the factor name.

3. Click to enter values or change the level names.

Figure 8.12  Entering Factors in a Full Factorial Design

When you finish adding factors, click Continue.

1

2

3
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Select Output Options

Use the Output Options panel to specify how you want the output data table to appear, as 
illustrated in Figure 8.13:

Figure 8.13  Output Options Panel

Run Order gives options to designate the order you want the runs to appear in the data table 
when it is created. Choices are:

Keep the Same the rows (runs) in the output table will appear in the standard order.

Sort Left to Right the rows (runs) in the output table will appear sorted from left to right.

Randomize the rows (runs) in the output table will appear in a random order.

Sort Right to Left the rows (runs) in the output table will appear sorted from right to left.

Add additional points to the data table with these options:

Number of Center Points Specifies how many additional runs to add as center points to the 
design. A center point is a run that is located in the center of the range of each continuous 
factor.

Number of Replicates Specify the number of times to replicate the entire design, including 
center points. Type the number of times you want to replicate the design in the associated 
text box. One replicate doubles the number of runs.

Make the Table

When you click Make Table, the table shown in Figure 8.14 appears.

Figure 8.14  Factorial Design Table
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The name of the table is the design type that generated it.

Run the Model script to fit a model using values in the design table.

Values in the Pattern column describe the run each row represents.

• For continuous factors, a plus sign represents high levels.

• For continuous factors, a minus sign represents low levels.

• Level numbers represent values of categorical factors.
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Chapter 9
Mixture Designs

The mixture designer supports experiments with factors that are ingredients in a mixture. You 
can choose among several classical mixture design approaches, such as simplex, extreme 
vertices, and lattice. For the extreme vertices approach you can supply a set of linear 
inequality constraints limiting the geometry of the mixture factor space.

The properties of a mixture are almost always a function of the relative proportions of the 
ingredients rather than their absolute amounts. In experiments with mixtures, a factor's value 
is its proportion in the mixture, which falls between zero and one. The sum of the proportions 
in any mixture recipe is one (100%).

Designs for mixture experiments are fundamentally different from those for screening. 
Screening experiments are orthogonal. That is, over the course of an experiment, the setting of 
one factor varies independently of any other factor. Thus, the interpretation of screening 
experiments is relatively simple, because the effects of the factors on the response are 
separable.

With mixtures, it is impossible to vary one factor independently of all the others. When you 
change the proportion of one ingredient, the proportion of one or more other ingredients must 
also change to compensate. This simple fact has a profound effect on every aspect of 
experimentation with mixtures: the factor space, the design properties, and the interpretation 
of the results.

Because the proportions sum to one, mixture designs have an interesting geometry. The 
feasible region for the response in a mixture design takes the form of a simplex. For example, 
consider three factors in a 3-D graph. The plane where the sum of the three factors sum to one 
is a triangle-shaped slice. You can rotate the plane to see the triangle face-on and see the points 
in the form of a ternary plot.

Figure 9.1  Mixture Design

triangular feasible region

x1

x2

x3
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Mixture Design Types

To create a mixture design, choose DOE > Mixture Design, enter the responses and factors into 
the initial mixture designer panel, and click Continue. You then see the Linear Constraints 
report and the Choose Mixture Design Type panel. Both are shown in Figure 9.2.

Three design types support linear constraints: Optimal, Extreme Vertices, and Space Filling. If 
you have linear constraints and plan to use the Extreme Vertices or Space Filling Design 
Types, click the Linear Constraint button and enter these first. If you plan to use the Optimal 
Design Type, click Optimal and add the constraints under Define Factor Constraints in the 
dialog window that opens.

Select one of the design types from the panel. The default values shown for K, Number of 
Levels, Degree, and Runs depend on the number of factors entered. The design types are:

Optimal invokes the custom designer with all the mixture variables already defined.

Simplex Centroid lets you specify the degree to which the factor combinations are made.

Simplex Lattice lets you specify how many levels you want on each edge of the grid.

Extreme Vertices lets you specify linear constraints or restrict the upper and lower bounds to 
be within the 0 to 1 range.

ABCD Design generates a screening design for mixtures devised by Snee (1975).

Space Filling constructs a design that accommodates linear constraints. Design points are 
spread throughout the design space.

Figure 9.2  Mixture Design Selection Dialog
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After you select the design type, enter selections or accept defaults to adjust the number of 
runs in the Design Generation panel. Then click Make Design or Make Table, as appropriate.

The following sections describe each mixture design type and show examples.

The Optimal Mixture Design

The Optimal mixture design choice invokes the custom designer with the mixture variables 
entered into the response and factors panels. To create an optimal mixture design:

1. Select DOE > Mixture Design.

2. Enter factors and responses. The steps for entering responses are outlined in “Enter 
Responses and Factors into the Custom Designer” on page 45.

3. After you enter responses and factors, click Continue.

4. Click Optimal on the Choose Mixture Design Type panel.

5. Open the Define Factor Constraints node and click Add Constraint to add linear 
constraints, if you have any.

6. Add effects to the model using the instructions below.

7. In the Design Generation panel, make selections relative to blocks, center points, replicates, 
and the number of runs.

8. Click Make Design to generate the Mixture Design report, which displays the design and 
Design Evaluation report.

9. Click Make Table in the Output Options panel of the Mixture Design report to generate the 
data table.

Adding Effects to the Model

Initially, the Model panel lists only the main effects corresponding to the factors you entered, 
as shown in Figure 9.3.

Figure 9.3  The Model Panel

However, you can add factor interactions, specific crossed factor terms, powers, or Scheffe 
Cubic terms to the model.
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• To add interaction terms to a model, click the Interactions button and select 2nd, 3rd, 4th, 
or 5th. For example, if you have factors X1 and X2, click Interactions > 2nd and X1*X2 is 
added to the list of model effects.

• To add crossed effects to a model, highlight the factors and effects you want to cross and 
click the Cross button.

• To add powers of continuous factors to the model, click the Powers button and select 2nd, 
3rd, 4th, or 5th.

• When you want a mixture model with third-degree polynomial terms, the Scheffe Cubic 
button provides a polynomial specification of the surface by adding terms of the form 
X1*X2*(X1-X2).

The Simplex Centroid Design

A simplex centroid design of degree k with n factors is composed of mixture runs with 

• all one factor 

• all combinations of two factors at equal levels

• all combinations of three factors at equal levels 

• and so on up to k factors at a time combined at k equal levels.

A center point run with equal amounts of all the ingredients is always included.

Creating the Design

To create a simplex centroid design:

1. Select DOE > Mixture Design.

2. Enter factors and responses. The steps for entering responses are outlined in “Enter 
Responses and Factors into the Custom Designer” on page 45.

3. After you enter responses and factors, click Continue.

4. Enter the number of ingredients in the box under K. JMP will create runs for each 
ingredient without mixing, then create runs that mix equal proportions of K ingredients at 
a time to the specified limit.

5. Click the Simplex Centroid button.

6. View factor settings and Output Options, as illustrated in Figure 9.4.
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Figure 9.4  Example of Factor Settings and Output Options

7. Specify Run Order, which is the order in which you want the runs to appear in the data 
table that you will create. Run order choices are:

Keep the Same the rows (runs) in the output table will appear as they do in the Factor 
Settings panel.

Sort Left to Right the rows (runs) in the output table will appear sorted from left to right.

Randomize the rows (runs) in the output table will appear in a random order.

Sort Right to Left the rows (runs) in the output table will appear sorted from right to left.

Randomize within Blocks the rows (runs) in the output table will appear in random order 
within the blocks you set up.

8. Specify Number of Replicates. The number of replicates is the number of times to replicate 
the entire design, including center points. Type the number of times you want to replicate 
the design in the associated text box. One replicate doubles the number of runs.

9. Click Make Table.

Simplex Centroid Design Examples

The table of runs for a design of degree 1 with three factors (left in Figure 9.5) shows runs for 
each single ingredient followed by the center point. The table of runs to the right is for three 
factors of degree 2. The first three runs are for each single ingredient, the second set shows 
each combination of two ingredients in equal parts, and the last run is the center point.
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Figure 9.5  Three-Factor Simplex Centroid Designs of Degrees 1 and 2 

To generate the two sets of runs in Figure 9.5:

1. Choose DOE > Mixture Design.

2. Enter three mixture factors.

3. Click Continue.

4. Enter 1 in the K box, and click Simplex Centroid to see the design on the left in Figure 9.6.

5. Click the Back button, then click Continue, and enter 2 in the K box. Then click Simplex 
Centroid to see the design on the right in Figure 9.6.

Figure 9.6  Create Simplex Centroid Designs of Degrees 1 and 2 

As another example:

1. Choose DOE > Mixture Design.

2. Enter five factors and click Continue.

3. Use the default value, 4, in the K box.

4. Click Simplex Centroid.

5. Click Make Table.

Figure 9.7 shows part of the 31-run design. Note that your table may look different 
because the design was created with Run Order set to Randomize.
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Figure 9.7  Partial Listing of Factor Settings for Five-Factor Simplex Centroid Design

The Simplex Lattice Design

The simplex lattice design is a space filling design that creates a triangular grid of runs. The 
design is the set of all combinations where the factors’ values are i / m, where i is an integer 
from 0 to m such that the sum of the factors is 1.

To create simplex lattice designs:

1. Select DOE > Mixture Design.

2. Enter factors and responses. The steps for entering responses are outlined in “Enter 
Responses and Factors into the Custom Designer” on page 45.

3. Click Continue.

4. Specify the number of levels you want in the Mixture Design Type dialog (Figure 9.2) and 
click Simplex Lattice.

Figure 9.8 shows the runs for three-factor simplex lattice designs of degrees 3, 4, and 5, with 
their corresponding geometric representations. In contrast to the simplex centroid design, the 
simplex lattice design does not necessarily include the centroid.
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Figure 9.8  Three-Factor Simplex Lattice Designs for Factor Levels 3, 4, and 5

Figure 9.9 lists the runs for a simplex lattice of degree 3 for five effects. In the five-level 
example, the runs creep across the hyper-triangular region and fill the space in a grid-like 
manner.
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Figure 9.9  JMP Design Table for Simplex Lattice with Five Variables, Order (Degree) 3

The Extreme Vertices Design

The extreme vertices design can only be selected if you have modified the ranges on the 
factors in the Factors panel or if you have specified a linear constraint. This design accounts 
for factor limits and selects vertices and their averages (formed by factor limits) as design 
points. Additional limits are usually in the form of range constraints, upper bounds, and 
lower bounds on the factor values.

The extreme vertices design finds the corners (vertices) of a factor space constrained by limits 
specified for one or more of the factors. The property that the factors must be non-negative 
and must add up to one is the basic mixture constraint that makes a triangular-shaped region.

Sometimes other ingredients need range constraints that confine their values to be greater 
than a lower bound or less than an upper bound. Range constraints chop off parts of the 
triangular-shaped (simplex) region to make additional vertices. It is also possible to have a 
linear constraint, which defines a linear combination of factors to be greater or smaller than 
some constant.

The geometric shape of a region bound by linear constraints is called a simplex, and because 
the vertices represent extreme conditions of the operating environment, they are often the best 
places to use as design points in an experiment.
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You usually want to add points between the vertices. The average of points that share a 
constraint boundary is called a centroid point, and centroid points of various degrees can be 
added. The centroid point for two neighboring vertices joined by a line is a second degree 
centroid because a line is two dimensional. The centroid point for vertices sharing a plane is a 
third degree centroid because a plane is three dimensional, and so on.

Creating the Design

Follow these steps to create an extreme vertices design. The next sections show examples with 
specific constraints.

1. Select DOE > Mixture Design.

2. Enter factors and responses. These steps are outlined in “Enter Responses and Factors into 
the Custom Designer” on page 45. If your factor ranges are constrained, enter the limits as 
upper and lower limits in the Factors panel (see Figure 9.10).

3. Click Continue.

4. If you have linear constraints, click Linear Constraints and enter them.

Note: The extreme vertices design can only be selected if you have modified the ranges on the 
factors in the Factors panel or if you have specified a linear constraint.

5. In the Degree text box, enter the degree of the centroid point you want to add. The 
centroid point is the average of points that share a constraint boundary.

6. If you have linear constraints, click the Linear Constraints button for each constraint you 
want to add. Use the text boxes that appear to define a linear combination of factors to be 
greater or smaller than some constant.

7. Click Extreme Vertices to see the factor settings.

8. Specify the Run Order. This determines the order of the runs in the data table when it is 
created. Run order choices are:

Keep the Same—the rows (runs) in the output table will appear as they do in the Design 
panel.

Sort Left to Right—the rows (runs) in the output table will appear sorted from left to right.

Randomize—the rows (runs) in the output table will appear in a random order.

Sort Right to Left—the rows (runs) in the output table will appear sorted from right to left.

Randomize within Blocks—the rows (runs) in the output table will appear in random order 
within the blocks you set up.

9. Enter the sample size you want in the Choose desired sample size text box.
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10. (Optional) Click Find Subset to generate the optimal subset having the number of runs 
specified in sample size box described in Step 8. The Find Subset option uses the row 
exchange method (not coordinate exchange) to find the optimal subset of rows.

11. Click Make Table.

An Extreme Vertices Example with Range Constraints

The following example design table is for five factors with the range constraints shown in 
Figure 9.10, where the ranges are smaller than the default 0 to 1 range.

1. Select DOE > Mixture Design.

2. Add two additional factors (for a total of 5 factors) and give them the values shown in 
Figure 9.10.

3. Click Continue.

4. Enter 4 in the Degree text box (Figure 9.10).

Figure 9.10  Example of Five-factor Extreme Vertices

5. Click Extreme Vertices.

6. Select Sort Left to Right from the Run Order menu.

7. Click Make Table. 

Figure 9.11 shows a partial listing of a resulting design. Note that the Rows panel in the 
data table shows that the table has the default 116 runs.
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Figure 9.11  JMP Design Table for Extreme Vertices with Range Constraints

Suppose you want fewer runs. You can go back and enter a different sample size (number of 
runs).

8. Click Back, then click Continue.

9. Enter 4 in the Degree text box and click Extreme Vertices.

10. In the sample size text box, enter 10 as the sample size.

11. Click Find Subset to generate an optimal subset having the number of runs specified.

The resulting design (Figure 9.12) is an optimal 10-run subset of the 116 current runs. This 
is useful when the extreme vertices design generates a large number of vertices. Your 
design may look different, because there are different subsets that achieve the same 
D-efficiency.
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Figure 9.12  JMP Design Table for 10-Run Subset of the 116 Current Runs

Note: The Find Subset option uses the row exchange method (not coordinate exchange) to 
find the optimal subset of rows.

An Extreme Vertices Example with Linear Constraints

Consider the classic example presented by Snee (1979) and Piepel (1988). This example has 
three factors, X1, X2, and X3, with five individual factor bound constraints and three 
additional linear constraints: 

To enter these constraints:

1. Enter the upper and lower limits in the factors panel.

2. Click Continue.

3. Click the Linear Constraint button three times. Enter the constraints as shown in 
Figure 9.13.

4. Click the Extreme Vertices button.

Table 9.1  Linear Constraints for the Snee and Piepel Example

X1 ≥ 0.1

X1 ≤ 0.5

X2 ≥ 0.1

X2 ≤ 0.7

X3 ≤ 0.7

90 ≤ 85*X1 + 90*X2 + 100*X3

85*X1 + 90*X2 + 100*X3 ≤ 95

.4 ≤ 0.7*X1 + X3



Chapter 9 Mixture Designs 225
Design of Experiments Guide The Extreme Vertices Design

5. Change the run order to Sort Right to Left, and keep the sample size at 13. See Figure 9.13 
for the default Factor Settings and completed Output Options.

6. Click Make Table.

Figure 9.13  Constraints

This example is best understood by viewing the design as a ternary plot, as shown at the end 
of this chapter, in Figure 9.16. The ternary plot shows how close to one a given component is 
by how close it is to the vertex of that variable in the triangle. See “Creating Ternary Plots” on 
page 228, for details.

Extreme Vertices Method: How It Works

If there are linear constraints, JMP uses the CONSIM algorithm developed by R.E. Wheeler, 
described in Snee (1979) and presented by Piepel (1988) as CONVRT. The method is also 
described in Cornell (1990, Appendix 10a). The method combines constraints and checks to 
see if vertices violate them. If so, it drops the vertices and calculates new ones. The method 
named CONAEV for doing centroid points is by Piepel (1988).

If there are no linear constraints (only range constraints), the extreme vertices design is 
constructed using the XVERT method developed by Snee and Marquardt (1974) and Snee 
(1975). After the vertices are found, a simplex centroid method generates combinations of 
vertices up to a specified order.

The XVERT method first creates a full 2nf – 1 design using the given low and high values of the   
nf – 1 factors with smallest range. Then, it computes the value of the one factor left out based 
on the restriction that the factors’ values must sum to one. It keeps the point if it is in that 
factor’s range. If not, it increments or decrements it to bring it within range, and decrements or 
increments each of the other factors in turn by the same amount, keeping the points that still 
satisfy the initial restrictions.
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The above algorithm creates the vertices of the feasible region in the simplex defined by the 
factor constraints. However, Snee (1975) has shown that it can also be useful to have the 
centroids of the edges and faces of the feasible region. A generalized n-dimensional face of the 
feasible region is defined by nf – n of the boundaries and the centroid of a face defined to be 
the average of the vertices lying on it. The algorithm generates all possible combinations of the 
boundary conditions and then averages over the vertices generated on the first step.

The ABCD Design

This approach by Snee (1975) generates a screening design for mixtures. To create an ABCD 
design:

1. Select DOE > Mixture Design.

2. Enter factors and responses. The steps for entering responses are outlined in “Enter 
Responses and Factors into the Custom Designer” on page 45.

3. After you enter responses and factors, click Continue.

4. Click the ABCD Design button.

5. View factor settings and Output Options.

6. Specify Run Order, which is the order you want the runs to appear in the data table when 
it is created. Run order choices are:

Keep the Same The rows (runs) in the output table will appear as they do in the Factor 
Settings panel.

Sort Left to Right The rows (runs) in the output table will appear sorted from left to right.

Randomize The rows (runs) in the output table will appear in a random order.

Sort Right to Left The rows (runs) in the output table will appear sorted from right to left.

Randomize within Blocks The rows (runs) in the output table will appear in random 
order within the blocks you set up.

7. Specify Number of Replicates. The number of replicates is the number of times to replicate 
the entire design, including center points. Type the number of times you want to replicate 
the design in the associated text box. One replicate doubles the number of runs.

8. Click Make Table.

The Space Filling Design

The Space Filling design spreads design points fairly uniformly throughout the design region. 
It accommodates linear constraints. The design is generated in a fashion similar to the Fast 
Flexible Filling design method found under DOE > Space Filling Design (“Fast Flexible Filling 
Designs” on page 271).
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The algorithm begins by generating a large number of uniformly-distributed points within the 
specified design region. These points are then clustered using a Fast Ward algorithm into a 
number of clusters that equals your specified number of Runs. The algorithm places a design 
point at the centroid of each cluster. This method has the property that any point in the design 
space has a design point fairly close to it.

Set Average Cluster Size

The Set Average Cluster Size option is found under Advanced Options in the Mixture Design 
red triangle menu. This option allows you to specify the average number of 
uniformly-generated points used to define each cluster or, equivalently, each design point.

By default, if the number of Runs for the Space Filling design type is 200 or smaller, a total of 
10,000 random uniformly-generated points are used as the basis for the clustering algorithm. 
When the number of Runs exceeds 200, a default value of 50 is used. Increasing this value can 
be particularly useful in designs with a large number of factors.

Note: Depending on the number of factors and the specified value for Runs, you may want to 
increase the average number of initial points per design point by selecting Advanced Options 
> Set Average Cluster Size.

Linear Constraints

The design region can be defined by selecting the Linear Constraint option in the Linear 
Constraints panel. 

When linear constraints are specified using the Add linear constraints option, the random 
points that form the basis for the clustering algorithm are uniformly-distributed within the 
constrained design region. The clustering algorithm uses these points.

A Space Filling Example

To create a space filling design:

1. Select DOE > Mixture Design.

2. Enter factors and responses. The steps for entering responses are outlined in “Enter 
Responses and Factors into the Custom Designer” on page 45.

3. Click Continue.

4. Add Linear Constraints, if you have any.

5. Specify the number of runs you want in the Runs box to the right of the Space Filling 
button in the Mixture Design Type dialog (Figure 9.2).

6. Click Space Filling.



228 Mixture Designs Chapter 9
Creating Ternary Plots Design of Experiments Guide

A Space Filling Example with a Linear Constraint

Consider a three-factor mixture design with the single linear constraint: . 
Figure 9.14 shows a ternary plot for a 30-run Space Filling design that satisfies this constraint. 
(For a discussion of ternary plots, see “Creating Ternary Plots” on page 228.) Note that the 
points fall in the constrained design region and are fairly well spread throughout this region.

Figure 9.14  Space Filling Design with One Linear Constraint

Creating Ternary Plots

A mixture problem in three components can be represented in two dimensions because the 
third component is a linear function of the others. The ternary plot in Figure 9.16 shows how 
close to one (1) a given component is by how close it is to the vertex of that variable in the 
triangle. The plot in Figure 9.15 illustrates a ternary plot.

Figure 9.15  Ternary Plot for Mixture Design

The Piepel (1979) example referenced in “An Extreme Vertices Example with Linear 
Constraints” on page 224 is best understood by the ternary plot shown in Figure 9.16.

0.7*X1 X2+ 0.4≥

X1

X2
X3

(1/2, 1/2, 0)

X1 (1, 0, 0)

X2 (0, 1, 0) X3 (0, 0, 1)

(1/3, 1/3, 1/3)

(0.1, 0.1, 0.8)
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To view a mixture design as a ternary plot:

1. Create the Piepel mixture data as shown previously, or open the table called Piepel.jmp, 
found in the Design Experiments folder of the Sample Data Library.

2. Choose Graph > Ternary Plot.

3. In the ternary plot launch dialog, specify the three mixture components and click OK.

The JMP Ternary plot platform recognizes the three factors as mixture factors, and also 
considers the upper and lower constraints entered into the Factors panel when the design was 
created. The Ternary plot uses shading to exclude the unfeasible areas excluded by those 
constraints.

The Piepel data had additional constraints, entered as linear constraints for the extreme 
vertices design. There are six active constraints, six vertices, and six centroid points shown on 
the plot, as well as two inactive (redundant) constraints. The feasible area is the inner white 
polygon delimited by the design points and constraint lines.

Figure 9.16  Diagram of Ternary Plot Showing Piepel Example Constraints

Fitting Mixture Designs

When fitting a model for mixture designs, you must take into account that the factors sum to a 
constant, and thus a traditional full linear model will not be fully estimable.

The recommended response surface model is called the Scheffé polynomial (Scheffé 1958). See 
the discussion of Cox Mixtures and the Scheffé Cubic macro in the Fitting Linear Models book. 
The Scheffé polynomial model does the following:

• suppresses the intercept

• includes all the linear main-effect terms
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• excludes all the square terms (such as X1*X1)

• includes all the cross terms (such as X1*X2)

To fit a model:

1. Choose DOE > Mixture Design and make the design data table. Remember that to fit a 
model, the Y column in the data table must contain values, so either assign responses or 
click the red triangle menu and select Simulate Responses before you click Make Table.

2. The design data table stores the model in the data table as a table property. This table 
property is a JSL script called Model, located in the left panel of the table.

3. Right-click the model and select Run Script to launch the Fit Model dialog, which is 
automatically filled with the saved model.

4. Click Run on the Fit Model dialog.

In this model, the parameters are easy to interpret (Cornell 1990). The coefficients on the linear 
terms are the fitted response at the extreme points where the mixture consists of a single 
factor. The coefficients on the cross terms indicate the curvature across each edge of the factor 
space.

The model report usually has several sections of interest, including the whole model tests, 
Analysis of Variance reports, and response surface reports, which are described below.

Whole Model Tests and Analysis of Variance Reports

In a whole-model Analysis of Variance table, JMP traditionally tests that all the parameters are 
zero except for the intercept. In a mixture model without an intercept, JMP looks for a hidden 
intercept, in the sense that a linear combination of effects is a constant. If it finds a hidden 
intercept, it does the whole model test with respect to the intercept model rather than a 
zero-intercept model. This test is equivalent to testing that all the parameters are zero except 
the linear parameters, and testing that they are equal.

The hidden-intercept property also causes the R2 to be reported with respect to the intercept 
model rather than reported as missing.

Understanding Response Surface Reports

When there are effects marked as response surface effects “&RS,” JMP creates additional 
reports that analyze the fitted response surface. These reports were originally designed for full 
response surfaces, not mixture models. However, if JMP encounters a no-intercept model and 
finds a hidden intercept with linear response surface terms, but no square terms, then it folds 
its calculations, collapsing on the last response surface term to calculate critical values for the 
optimum. This can be done for any combination that yields a constant and involves the last 
response surface term.
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A Chemical Mixture Example

Three plasticizers (p1, p2, and p3) comprise 79.5% of the vinyl used for automobile seat covers 
(Cornell, 1990). Within this 79.5%, the individual plasticizers are restricted by the following 
constraints: 0.409 ≤ x1 ≤ 0.849, 0 ≤ x2 ≤ 0.252, and 0.151 ≤ x3 ≤ 0.274.

Create the Design

To create Cornell’s mixture design in JMP:

1. Select DOE > Mixture Design.

2. In the Factors panel, use the three default factors but name them p1, p2, and p3, and enter 
the high and low constraints as shown in Figure 9.17. Or, load the factors with the Load 
Factors command in the red triangle on the Mixture Design title bar. To import the factors, 
open Plastifactors.jmp, found in the Design Experiment sample data folder that was 
installed with JMP.

Figure 9.17  Factors and Factor Constraints for the Plasticizer Experiment

3. Click Continue.

4. Enter 3 in the Degree text box.

5. Click Extreme Vertices.

6. Click Make Table. JMP uses the 9 factor settings to generate a JMP table (Figure 9.18).
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Figure 9.18  Extreme Vertices Mixture Design

7. Add an extra five design runs by duplicating the vertex points and center point, to give a 
total of 14 rows in the table.

Note: To identify the vertex points and the center (or interior) point, use the sample data script 
called LabelMixturePoints.jsl in the Sample Scripts folder installed with JMP.

8. Run the LabelMixturePoints.jsl to see the results in Figure 9.19, and highlight the vertex 
points and the interior point as shown.

Figure 9.19  Identify Vertices and Center Point with Sample Script

9. Select Edit > Copy, to copy the selected rows to the clipboard.

10. Select Rows > Add Rows and type 5 as the number of rows to add.

11. Click the At End radio button on the dialog, then click OK.

12. Highlight the new rows and select Edit > Paste to add the duplicate rows to the table.

The Plasticizer data with the results (Y values) that Cornell obtained are available in the 
sample data. Open Plasticizer.jmp in the sample data folder installed with JMP to see this table 
(Figure 9.20).
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Figure 9.20  Plasticizer.jmp Data Table from the Sample Data Library

Analyze the Mixture Model

Use the Plasticizer.jmp data from the sample data library (Figure 9.20) to run the mixture 
model:

1. Click the table property named Model on the upper-left of the data table and select Run 
Script, which runs a script that displays a completed Fit Model dialog. Click Run to see the 
response surface analysis.

2. Plasticizer.jmp contains a column called Pred Formula Y. This column was added after the 
analysis by selecting Save Columns > Prediction Formula from the red triangle menu in the 
Response Y title bar of the analysis report. To see the prediction formula, right-click 
(Ctrl+click on the Mac) the column name and select Formula:
0–50.1465*p1 – 282.198*p2 – 911.648*p3 + p2*p1*317.363 + p2*p1*1464.330 + 

p3*p2*1846.218

Note: These results correct the coefficients reported in Cornell (1990).

The Response Surface Solution report (Figure 9.21) shows that a maximum predicted value of 
19.570299 occurs at point (0.63505, 0.15568, 0.20927).
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Figure 9.21  Mixture Response Surface Analysis

The Prediction Profiler

The report contains a prediction profiler.

1. If the profiler is not visible, click the red triangle in the Response Y title bar and select 
Factor Profiling > Profiler. You should see the initial profiler shown in Figure 9.22.

The crossed effects show as curvature in the prediction traces. Drag one of the vertical 
reference lines, and the other two move in the opposite direction maintaining their ratio.

Note: The axes of prediction profiler traces range from the upper and lower bounds of the 
factors, p1, p2, and p3, entered to create the design and the design table. When you 
experiment moving a variable trace, you see the other traces move such that their ratio is 
preserved. As a result, when the limit of a variable is reached, it cannot move further and only 
the third variable changes.

2. To limit the visible profile curves to bounds that use all three variables, use the Profile at 
Boundary > Stop at Boundaries command from the menu on the Prediction Profiler title 
bar.

3. If needed, select the Desirability Functions command to display the desirability function 
showing to the right of the prediction profile plots in Figure 9.23.

4. Then select Maximize Desirability from the Prediction Profiler menu to see the best factor 
settings.

The profiler in Figure 9.23, displays optimal settings (rounded) of 0.6350 for p1, 0.1557 for p2, 
and 0.2093 for p3, which give an estimated response of 19.5703.
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Figure 9.22  Initial Prediction Profiler

Figure 9.23  Maximum Desirability in Profiler for Mixture Analysis Example

The Mixture Profiler

The Fit Model report also has a Mixture Profiler that is useful for visualizing and optimizing 
response surfaces from mixture experiments.

Many of the features are the same as those of the Contour Profiler however some are unique to 
the Mixture Profiler:

• A ternary plot is used instead of a Cartesian plot, which enables you to view three mixture 
factors at a time.

• If you have more than three factors, radio buttons let you choose which factors to plot.

• If the factors have constraints, you can enter their low and high limits in the Lo Limit and 
Hi Limit columns. This shades non-feasible regions in the profiler.
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Select Factor Profiling > Mixture Profiler from the menu on the Response Y title bar to see the 
mixture profiler for the plasticizer data, shown in Figure 9.24.

Figure 9.24  Mixture Profiler for Plasticizer Example

A Ternary Plot of the Mixture Response Surface

You can also plot the response surface of the plasticizer data as a ternary plot using the 
Ternary graph platform and contour the plot with information from an additional variable:

1. Choose Graph > Ternary Plot.

2. Specify plot variables (p1, p2, and p3) and click X, Plotting, as shown in Figure 9.25. To 
identify the contour variable (the prediction equation), select Pred Formula Y and click the 
Contour Formula button. The contour variable must have a prediction formula to form the 
contour lines, as shown by the ternary plots at the bottom in Figure 9.26. If there is no 
prediction formula, the ternary plot only shows points.
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Figure 9.25  Launch Dialog for the Ternary Plot Platform

3. Click OK and view the results, as shown in Figure 9.26. By default, the ternary plot 
displays contour lines only, but you can request a Fill Above or Fill Below, as shown, with 
the Contour Fill command found in the red triangle menu on the Ternary Plot title bar.

Figure 9.26  Ternary Plot of a Mixture Response Surface
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Chapter 10
Discrete Choice Designs

The Discrete Choice designer creates experiments with factors that are product attributes. A 
collection of attributes is called a product profile. Respondents choose one in each set of 
product profiles. 

Industrial experimentation deals with the question of how to improve processes to deliver 
better products. Choice experiments help a company prioritize product features for their 
market. The purpose of a choice experiment is to define a product that people want to buy.

Choice experiments always involve people comparing prospective products and picking the 
one they prefer. For example, suppose a computer company wants to update its high-end 
laptop. Laptops have many features that are important to customers such as processor speed, 
hard disk size, screen size, battery life, and price. To build a laptop that customers want, the 
computer company needs to know the relative importance of each feature. Most people prefer 
a faster computer with more storage, longer battery life, and a low price. What the company 
does not know is how much more an extra hour of battery life is worth to a customer or 
whether doubling the hard disk size is as important as doubling the processor speed. A choice 
experiment can answer these questions and indicate the optimal set of trade-offs among 
product features.
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Introduction

Most choice experiments involve conducting a market research survey. The survey consists of 
a series of questions about attributes of interest about a potential new product or product 
modification. For example, a computer manufacturer might be interested in manufacturing a 
new laptop and wants information about customer preference before beginning an expensive 
development process. Computer characteristics change so rapidly that it is crucial to quickly 
identify the attributes that help the manufacturers to design and build a new machine most 
likely to capture enough market share to be profitable.

Often, the attributes are obvious. For example, the consumer wants a laptop that has a large 
screen, weighs almost nothing, costs almost nothing, and lasts forever on a single battery 
charge. The question, then, is how much is the customer willing to compromise these desires? 
How important is each of these attributes, and which kinds of trade off is the customer most 
likely to accept and still purchase a new machine?

Assume a simple situation where a computer manufacturer wants to examine preferences for 
four possible laptop configurations. Notice that there are no ‘right’ or ‘wrong’ selections. 
Instead there are just preferences. A well designed questionnaire and proper analysis of 
results can tell a manufacturer how to proceed. The manufacturer wants information about 
the following four laptop attributes.

• size of hard drive disk (40 GB or 80 GB)

• speed of processor (1.5 GHz or 2.0 GHz)

• battery life (4 Hrs or 6 Hrs)

• cost of computer ($1000, $1200 or $1500)

If a survey were constructed that offered the possibility of choosing any combination of these 
attributes, a respondent would be forced to evaluate 24 possible combinations and make a 
single response. Instead each respondent usually evaluates several choice sets and for each 
choice set, chooses the preferred profile. In the simplest situation, each respondent chooses 
between sets of two profiles.

Then, you analyze the choices of multiple respondents. A well designed choice experiment, 
correctly analyzed is a efficient way to give the researcher the most information for the least 
time and expense.

Table 1 shows hypothetical results from a single survey designed to collect information about 
consumer preferences about laptop computers.

• Each column in the survey identifies a laptop attribute.

• Each line in the survey defines a laptop profile, which is a collection of attribute values.

• Each choice set consists of two attribute profiles.

• All of the attribute values are allowed to change across the two profiles in a choice set.
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The DOE Choice designer can create a survey like that shown in Table 10.1. However, to create 
an effective design, the Choice designer needs information about the attributes. For example, 
most laptop attributes have values that are intrinsic preferences. That is, a bigger disk size is 
better, longer battery life is better, and so forth. The purpose of conducting a choice survey is 

Table 10.1  Hypothetical Choice Survey Results from a single Respondent, Subject ID 2

For each pair, please check the combination of attributes you find most appealing.

Disk Size Speed Battery Life Price Preference

1 1 40 GB 1.5 GHz 6 hours $1,000 _X_

2 80 GB 1.5 GHz 4 hours $1,200 ___

2 1 40 GB 1.5 GHz 4 hours $1,500 ___

2 80 GB 2.0 GHz 4 hours $1,200 _X_

3 1 40 GB 2.0 GHz 4 hours $1,200 _X_

2 80 GB 2.0 GHz 6 hours $1,500 ___

4 1 40 GB 2.0 GHz 4 hours $1,000 _X_

2 80 GB 1.5 GHz 6 hours $1,200 ___

5 1 40 GB 1.5 GHz 6 hours $1,000 _X_

2 40 GB 2.0 GHz 4 hours $1,500 ___

6 1 40 GB 2.0 GHz 6 hours $1,200 _X_

2 80 GB 1.5 GHz 4 hours $1,500 ___

7 1 40 GB 2.0 GHz 6 hours $1,500 ___

2 80 GB 1.5 GHz 4 hours $1,000 _X_

8 1 40 GB 1.5 GHz 4 hours $1,200 ___

2 80 GB 2.0 GHz 4 hours $1,000 _X_
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to find out how potential laptop purchasers feel about the advantages of a collection of 
attributes.

One way to gain prior information about attributes in a survey is to conduct a single example 
survey, analyze the results, and use those results as prior information to create the final survey 
instrument.

This chapter shows how to create a sample survey and use its results as prior information for 
a final survey design.

Create an Example Choice Experiment

The Choice design can create a survey like the one in Table 10.1.

1. Choose DOE > Choice Design, and complete the initial dialog as shown in Figure 10.1.

Figure 10.1  Choice Design Dialog with Attributes Defined

2. Click Continue. For this example, use the default values in the Model Control panel and in 
the Design Generation panel, as shown in Figure 10.2.

Optionally, you can use the DOE Model Controls panel to add interactions to the choice model 
in situations where you expect there are interactions and want to generate profile sets that will 
help detect them.
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Figure 10.2  Design Generation Panel for the Laptop Experiment

The values in the Design Generation panel describe the laptop survey.

Number of attributes that can change within a choice set There are four laptop attributes. 
Entering 4 as the number of attributes that can change within a choice set means that the 
Choice designer can change 4 or fewer attribute values within a single choice set. You can 
enter fewer than the total number of attributes to constrain the total number that can be 
changed within a choice set. This might be a reasonable thing to do if you had a large 
number of attributes and you want to make it easier for the respondents to make a choice. 
For example, a survey might be interested in 20 or more attributes of a cell phone, but 
show and change only 5 or fewer attributes in a choice set.

Number of profiles per choice set This example has two profiles per choice set. You can 
design choice experiments with more than two profiles in a choice set.

Number of choice sets per survey There are eight choice sets in the example survey but often 
there are many more.

Number of surveys The example only shows a single survey. Normally you expect multiple 
respondents and would request more than one survey.

Expected number of respondents per survey You might want to give surveys to 10 people, but 
use two different surveys. So you enter 2 as the Number of surveys and 5 as the Expected 
number of respondents per survey.
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Note: Recall that this first example is used to generate prior information, then used to create a 
more realistic survey. This example is a single survey given to a single respondent.

3. Click Make Design to see the example survey results in Figure 10.3.

Figure 10.3  Survey Results based on a Simple Model and Default Prior Information

The Radio buttons beneath the design settings let you choose between having the survey 
settings in one JMP table and gathering survey results in a second table, or generating a single 
table that shows the settings and has an additional column for the choice response.

You can see that there are eight choice sets, each consisting of two laptop profiles. At this point 
you can press Back and modify the design, or click Make Table and generate the JMP table 
shown in Figure 10.4.

This default design was created with no given prior information. Without prior information, 
the Choice designer has no way of knowing which attribute levels are better. That is, the 
Choice designer cannot know that a lower price might be more desirable than a higher price, a 
faster machine is better than a slower machine, and so forth. As a result, you can see that some 
choice sets might not convey useful information. The analysis results are used as prior 
information in a new Choice design dialog.
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Figure 10.4  JMP Data Table for Preliminary Laptop Choice Survey

Analyze the Example Choice Experiment

Once a survey design is complete, a respondent chooses one profile from each set, entering ‘1’ 
for the chosen profile and ‘0’ for the rejected profile. Suppose a respondent completed the 
example survey as shown in Figure 10.5. You can now analyze these results using the Choice 
platform in the Analyze menu (Analyze > Consumer Research > Choice).

Figure 10.5  JMP Table with Survey Choice Sets and Responses

1. Click the Choice script in the Laptop Design sample data table and select Run Script to 
analyze that data with the Choice modeling platform from the Analyze menu.

When you run the Choice model script, the Choice launch dialog shown in Figure 10.6 
appears. The Choice dialog is designed to cover a variety of choice survey results, which can 
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include data saved in multiple data tables. This example has all data contained in a single 
table. For details about using the Choice analysis dialog, see the Choice Modeling chapter in 
the Multivariate Methods book.

Figure 10.6  Choice Model Fitting Dialog

2. Click Run Model on the Choice model fitting dialog.

3. An additional dialog then appears asking if this is a one-table analysis with all the data in 
the Profile Table, which is the case in this sample survey. Click Yes in this dialog to 
continue.

The analysis shows as in Figure 10.7.

To design the final choice survey using prior information, you will need to enter estimates of 
the mean and variance of the attribute parameter estimates. The analysis on the top in 
Figure 10.7 has estimates of the attribute means, called Estimate, and estimates of the standard 
deviation of the attributes, called Std Error. An easy way to see the variance of the attributes is 
to capture the analysis in a JMP table and compute the variance:

4. Right click on the Parameter Estimates report and choose Make into Data Table from the 
menu, as shown.

5. In the new Untitled data table, create a new column and call it Var.

6. Select Formula from the Cols menu (Cols > Formula), or right-click at the top of the Var 
column and select Formula for the menu that shows.

7. In the Formula Editor, click the Std Error column in the column list and click the exponent 
button ( ) on the formula editor panel to compute the variance shown on the right in 
Figure 10.7.
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Figure 10.7  Analysis of the sample Laptop Survey

This preliminary survey with its analysis gives you the information needed to design a final 
survey appropriate for gathering information from multiple respondents. Keep in mind that 
in a real situation, you might have prior information about factor attributes and not need to do 
a sample design.

Note: Leave the Untitled data table with the mean and variance information open to be used in 
the next example.

Design a Choice Experiment Using Prior Information

In some situations, you will know from previous surveys or experience how to give prior 
information to the Choice designer about product attributes. This example continues by 
designing the laptop experiment again, using the analysis information gained from the 
sample design.

1. Choose DOE > Choice Design and enter the attributes and values as before.

2. Click Continue to see the Choice design panels in Figure 10.8.
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3. Now enter the values from the JMP table created by the previous analysis into the Prior 
Mean and Prior Variance Matrix panels of the Choice Design dialog, as shown in 
Figure 10.8. You can copy-and-paste to transfer the values from the data table to the 
Choice dialog panels.

Figure 10.8  Enter Prior Mean and Variance Information from Preliminary Survey

4. Enter the values into the Design Generation panel, as shown in Figure 10.9.

– Four or fewer attribute levels can change within a choice set.

– There are two profiles per choice set.

– Each survey has eight choice sets.

– The design generates two separate surveys.

– Five respondents are expected to complete each survey (for a total of 10 respondents).
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Figure 10.9  Design Specifications for final Laptop Survey

5. Click Make Design. A partial view of the design is shown in Figure 10.10.

Figure 10.10  Design Runs for Two Choice Surveys

6. Click Make Table. The final data table will have runs for ten survey respondents, giving a 
total of 160 observations (2 profiles * 8 choice sets * 2 surveys * 5 respondents = 160 
observations).

Administer the Survey and Analyze Results

The survey data table with its results is stored in the Sample Data Design Experiment folder 
installed with JMP. Figure 10.11 is a partial listing of the survey data table with results. The 
Choice script created by the Choice designer and saved with the survey data table can be used 
to analyze the data. The default data table created by the Choice designer is named Choice 
Profiles. Note in Figure 10.11, the data table name is changed to Laptop Results.
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Initial Choice Platform Analysis

1. To continue the example, open the table called Laptop Results.jmp, saved in the sample 
data folder.

2. To analyze the data, click the Choice script saved with the data and select Run Script from 
the menu to see the completed dialog shown in Figure 10.11.

Note that this dialog has three grouping variables (Respondent, Survey, and Choice Set), 
whereas the dialog shown in Figure 10.6 had only the Choice Set grouping variable because 
there was a single survey and a single respondent. This example included multiple surveys 
and respondents, which must be included in the analysis.

Figure 10.11  Choice Model Fitting Dialog to Analyze the Laptop Survey

3. Click Run Model on the Fit Model dialog. The query again appears asking if the analysis is 
a one-table analysis with all the data in the profile table. Click Yes to see the initial analysis 
result shown in Figure 10.12.

The results are clear. While all the effects are significant, the most significant attribute is 
Speed.
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Figure 10.12  Initial Analysis of the Final Laptop Survey

Find Unit Cost and Trade Off Costs with the Profiler

You would like to know how changing the price, or other characteristics, of a laptop affects the 
desirability as perceived by potential buyers. This desirability is called the utility value of the 
laptop attributes. The profiler shows the utility value and how it changes as the laptop 
attributes change.

1. Select Profiler from the menu on the Choice Model title bar to see the Prediction Profiler in 
Figure 10.13.

Figure 10.13  Default Prediction Profiler for Laptop Choice Analysis

When each attribute value is set to its lowest value, the Utility value is –0.3406. The first thing 
you want to know is the unit utility cost.

2. To find the unit utility cost, move the trace for Price to $1,500 and note how the Utility 
value changes.
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Compare the Utility values in Figure 10.13 and Figure 10.14. The value of Utility changes from 
–0.3406 to –2.3303 when cost is raised from $1,000 to $1,500. That is, raising the price of a 
laptop $500.00 lowers the utility (or desirability) approximately 2 units. Thus, you can say that 
the unit utility cost is roughly $250.00.

Figure 10.14  Compare Change in Utility Over Price

With this unit utility cost estimate you can now vary the other attributes, note the change in 
utility, and find an approximate dollar value associated with that attribute change. For 
example, the most significant attribute is speed (see Figure 10.12).

3. In the Prediction Profiler, set Price to its lowest value and change Speed to its higher value.

You can see in Figure 10.15 that the Utility value changes from the original value shown in 
Figure 10.13 of –0.3406 to 0.9886, for a total change of 1.3292 units. If the unit utility cost is 
estimated to be $250.00, as shown above, then the increase in price for a 2.0 GHz laptop over a 
1.5 GHz laptop can be computed to be 1.3292*$250.00 = $332.30. This is the dollar value the 
Choice survey provides the manufacturer as a basis for pricing different laptop products. You 
can make similar calculations for the other attributes.

Figure 10.15  Change Speed in Profiler and Note Utility Value

This simple Choice survey and its analysis shows how this kind if information can be used to 
help manufacturers and retailers identify important product attributes and assign values to 
them.
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The Choice designer allows more complex designs, such as designs with interactions and 
other terms. The Choice analysis platform can be used to analyze complex designs, and it can 
be used to incorporate data from multiple data sets that include demographic information 
about the respondents.
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Space-Filling Designs

Space-filling designs are useful in situations where run-to-run variability is of far less concern 
than the form of the model. Sensitivity studies of computer simulations is one such situation. 
For this case, and any mechanistic or deterministic modeling problem, any variability is small 
enough to be ignored. For systems with no variability, randomization and blocking are 
irrelevant. Replication is undesirable because repeating the same run yields the same result. In 
space-filling designs, there are two objectives: 

• Prevent replicate points by spreading the design points out to the maximum distance 
possible between any two points. 

• Space the points uniformly.

The following methods are implemented for these types of designs:

• The Sphere-Packing method emphasizes spread of points.

• The Latin Hypercube method is a compromise between spread of points and uniform 
spacing.

• The Uniform method mimics the uniform probability distribution.

• The Minimum Potential method minimizes energy designs in a hypersphere.

• The Maximum Entropy method measures the amount of information contained in the 
distribution of a set of data.

• The Gaussian Process IMSE Optimal method creates a design that minimizes the 
integrated mean squared error of the gaussian process over the experimental region.

• The Fast Flexible Filling method locates points so that, for a given design size, the average 
distance from any point in the design region to the nearest design point is nearly 
minimized. 

Figure 11.1  Space-Filling Design
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Introduction to Space-Filling Designs

Space-filling designs are useful for modeling systems that are deterministic or 
near-deterministic. One example of a deterministic system is a computer simulation. Such 
simulations can be very complex involving many variables with complicated 
interrelationships. A goal of designed experiments on these systems is to find a simpler 
empirical model that adequately predicts the behavior of the system over limited ranges of the 
factors.

In experiments on systems where there is substantial random noise, the goal is to minimize 
the variance of prediction. In experiments on deterministic systems, there is no variance but 
there is bias. Bias is the difference between the approximation model and the true 
mathematical function. The goal of space-filling designs is to bound the bias.

There are two schools of thought on how to bound the bias. One approach is to spread the 
design points out as far from each other as possible consistent with staying inside the 
experimental boundaries. The other approach is to space the points out evenly over the region 
of interest.

The Space Filling designer supports the following design methods: 

Note: If the number of runs is 500 or less, a Gaussian Process model is saved to the data table. 
If the number of runs exceeds 500, a Neural model is saved to the data table.

Sphere Packing maximizes the minimum distance between pairs of design points.

Latin Hypercube maximizes the minimum distance between design points but requires even 
spacing of the levels of each factor. This method produces designs that mimic the uniform 
distribution. The Latin Hypercube method is a compromise between the Sphere-Packing 
method and the Uniform design method.

Uniform minimizes the discrepancy between the design points (which have an empirical 
uniform distribution) and a theoretical uniform distribution.

Minimum Potential spreads points out inside a sphere around the center.

Maximum Entropy measures the amount of information contained in the distribution of a set 
of data.

Gaussian Process IMSE Optimal creates a design that minimizes the integrated mean squared 
error of the Gaussian process over the experimental region.
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Fast Flexible Filling uses cluster methods to construct a design that places a design point close 
to any point in the design region. Accommodates linear constraints and disallowed 
combinations on the design space. You can construct linear constraints using the Linear 
Constraint button. You can specify Disallowed Combinations by selecting that option from 
the report’s red triangle menu. See “Disallowed Combinations: Accounting for Factor 
Level Restrictions” on page 76. 

Sphere-Packing Designs

The Sphere-Packing design method maximizes the minimum distance between pairs of design 
points. The effect of this maximization is to spread the points out as much as possible inside 
the design region.

Creating a Sphere-Packing Design

1. Select DOE > Space Filling Design.

2. Enter responses and factors. (See “Enter Responses and Factors into the Custom Designer” 
on page 45.)

3. Alter the factor level values, if necessary. For example, Figure 11.2 shows the two existing 
factors, X1 and X2, with values that range from 0 to 1 (instead of the default –1 to 1).

Figure 11.2  Space-Filling Dialog for Two Factors
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4. Click Continue.

5. In the design specification dialog, specify a sample size (Number of Runs). Figure 11.3 
shows a sample size of eight.

Figure 11.3  Space-Filling Design Dialog

6. Click Sphere Packing.

JMP creates the design and displays the design runs and the design diagnostics. 
Figure 11.4 shows the Design Diagnostics panel open with 0.518 as the Minimum Distance. 
Your results might differ slightly from the ones below, but the minimum distance will be 
the same.

Figure 11.4  Sphere-Packing Design Diagnostics 

7. Click Make Table. Use this table to complete the visualization example, described next.
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Visualizing the Sphere-Packing Design

To visualize the nature of the Sphere-Packing technique, create an overlay plot, adjust the 
plot’s frame size, and add circles using the minimum distance from the diagnostic report 
shown in Figure 11.4 as the radius for the circles. Using the table you just created:

1. Select Graph > Overlay Plot.

2. Specify X1 as X and X2 as Y, then click OK.

3. Adjust the frame size so that the frame is square by right-clicking the plot and selecting 
Size/Scale > Size to Isometric.

4. Right-click the plot and select Customize. When the Customize panel appears, click the 
plus sign to see a text edit area and enter the following script: 
For Each Row(Circle({:X1, :X2}, 0.518/2)) 
where 0.518 is the minimum distance number you noted in the Design Diagnostics panel. 
This script draws a circle centered at each design point with radius 0.259 (half the 
diameter, 0.518), as shown on the left in Figure 11.5. This plot shows the efficient way JMP 
packs the design points.

5. Now repeat the procedure exactly as described in the previous section, but with a sample 
size of 10 instead of eight.

Remember to change 0.518 in the graphics script to the minimum distance produced by 
10 runs. When the plot appears, again set the frame size and create a graphics script using 
the minimum distance from the diagnostic report as the diameter for the circle. You should 
see a graph similar to the one on the right in Figure 11.5. Note the irregular nature of the 
sphere packing. In fact, you can repeat the process a third time to get a slightly different 
picture because the arrangement is dependent on the random starting point.

Figure 11.5  Sphere-Packing Example with Eight Runs (left) and 10 Runs (right)
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Latin Hypercube Designs

In a Latin Hypercube, each factor has as many levels as there are runs in the design. The levels 
are spaced evenly from the lower bound to the upper bound of the factor. Like the 
sphere-packing method, the Latin Hypercube method chooses points to maximize the 
minimum distance between design points, but with a constraint. The constraint maintains the 
even spacing between factor levels.

Creating a Latin Hypercube Design

To use the Latin Hypercube method:

1. Select DOE > Space Filling Design.

2. Enter responses, if necessary, and factors. (See “Enter Responses and Factors into the 
Custom Designer” on page 45.)

3. Alter the factor level values, if necessary. For example, Figure 11.6 shows adding two 
factors to the two existing factors and changing their values to 1 and 8 instead of the 
default –1 and 1.

Figure 11.6  Space-Filling Dialog for Four Factors

4. Click Continue.

5. In the design specification dialog, specify a sample size (Number of Runs). This example 
uses a sample size of eight.
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6. Click Latin Hypercube (see Figure 11.3). Factor settings and design diagnostics results 
appear similar to those in Figure 11.7, which shows the Latin Hypercube design with four 
factors and eight runs.

Note: The purpose of this example is to show that each column (factor) is assigned each level 
only once, and each column is a different permutation of the levels.

Figure 11.7  Latin Hypercube Design for Four Factors and Eight Runs with Eight Levels

Visualizing the Latin Hypercube Design

To visualize the nature of the Latin Hypercube technique, create an overlay plot, adjust the 
plot’s frame size, and add circles using the minimum distance from the diagnostic report as 
the radius for the circle.

1. First, create another Latin Hypercube design using the default X1 and X2 factors.

2. Be sure to change the factor values so they are 0 and 1 instead of the default –1 and 1.

3. Click Continue.

4. Specify a sample size of eight (Number of Runs).

5. Click Latin Hypercube. Factor settings and design diagnostics are shown in Figure 11.8.
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Figure 11.8  Latin Hypercube Design with two Factors and Eight Runs

6. Click Make Table.

7. Select Graph > Overlay Plot.

8. Specify X1 as X and X2 as Y, then click OK.

9. Right-click the plot and select Size/Scale > Size to Isometric to adjust the frame size so that 
the frame is square.

10. Right-click the plot, select Customize from the menu. In the Customize panel, click the 
large plus sign to see a text edit area, and enter the following script: 
For Each Row(Circle({:X1, :X2}, 0.404/2))

where 0.404 is the minimum distance number you noted in the Design Diagnostics panel 
(Figure 11.8). This script draws a circle centered at each design point with radius 0.202 
(half the diameter, 0.404), as shown on the left in Figure 11.9. This plot shows the efficient 
way JMP packs the design points.

11. Repeat the above procedure exactly, but with 10 runs instead of eight (step 5). Remember 
to change 0.404 in the graphics script to the minimum distance produced by 10 runs.

You should see a graph similar to the one on the right in Figure 11.9. Note the irregular nature 
of the sphere packing. In fact, you can repeat the process to get a slightly different picture 
because the arrangement is dependent on the random starting point.

The minimum 
distance
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Figure 11.9  Comparison of Latin Hypercube Designs with Eight Runs (left) and 10 Runs 
(right)

Note that the minimum distance between each pair of points in the Latin Hypercube design is 
smaller than that for the Sphere-Packing design. This is because the Latin Hypercube design 
constrains the levels of each factor to be evenly spaced. The Sphere-Packing design maximizes 
the minimum distance without any constraints.

Uniform Designs

The Uniform design minimizes the discrepancy between the design points (empirical uniform 
distribution) and a theoretical uniform distribution.

Note: These designs are most useful for getting a simple and precise estimate of the integral of 
an unknown function. The estimate is the average of the observed responses from the 
experiment.

1. Select DOE > Space Filling Design.

2. Enter responses, if necessary, and factors. (See “Enter Responses and Factors into the 
Custom Designer” on page 45.)

3. Alter the factor level values to 0 and 1.

4. Click Continue.

5. In the design specification dialog, specify a sample size. This example uses a sample size 
of eight (Number of Runs).

6. Click the Uniform button. JMP creates this design and displays the design runs and the 
design diagnostics as shown in Figure 11.10.

Note: The emphasis of the Uniform design method is not to spread out the points. The 
minimum distances in Figure 11.10 vary substantially.
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Figure 11.10  Factor Settings and Diagnostics for Uniform Space-Filling Designs with Eight 
Runs

7. Click Make Table.

A Uniform design does not guarantee even spacing of the factor levels. However, increasing 
the number of runs and running a distribution on each factor (use Analyze > Distribution) 
shows flat histograms.

Figure 11.11  Histograms are Flat for each Factor when Number of Runs is Increased to 20
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Comparing Sphere-Packing, Latin Hypercube and Uniform Methods

To compare space-filling design methods, create the Sphere Packing, Latin Hypercube, and 
Uniform designs, as shown in the previous examples. The Design Diagnostics tables show the 
values for the factors scaled from zero to one. The minimum distance is based on these scaled 
values and is the minimum distance from each point to its closest neighbor. The discrepancy 
value is the integrated difference between the design points and the uniform distribution.

Figure 11.12 shows a comparison of the design diagnostics for three eight-run space-filling 
designs. Note that the discrepancy for the Uniform design is the smallest (best). The 
discrepancy for the Sphere-Packing design is the largest (worst). The discrepancy for the Latin 
Hypercube takes an intermediate value that is closer to the optimal value.

Also note that the minimum distance between pairs of points is largest (best) for the 
Sphere-Packing method. The Uniform design has pairs of points that are only about half as far 
apart. The Latin Hypercube design behaves more like the Sphere-Packing design in spreading 
the points out.

For both spread and discrepancy, the Latin Hypercube design represents a healthy 
compromise solution.
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Figure 11.12  Comparison of Diagnostics for Three Eight-Run Space-Filling Methods

Another point of comparison is the time it takes to compute a design. The Uniform design 
method requires the most time to compute. Also, the time to compute the design increases 
rapidly with the number of runs. For comparable problems, all the space-filling design 
methods take longer to compute than the D-optimal designs in the Custom Designer.

Minimum Potential Designs

The Minimum Potential design spreads points out inside a sphere. To understand how this 
design is created, imagine the points as electrons with springs attached to every other point, as 
illustrated to the right. The coulomb force pushes the points apart, but the springs pull them 
together. The design is the spacing of points that minimizes the potential energy of the system.

Sphere- 
Packing

Uniform

Latin 
Hypercube
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Figure 11.13  Minimum Potential Design

Minimum Potential designs:

• have spherical symmetry 

• are nearly orthogonal

• have uniform spacing

To see a Minimum Potential example:

1. Select DOE > Space Filling Design.

2. Add 1 continuous factor. (See “Enter Responses and Factors into the Custom Designer” on 
page 45.)

3. Alter the factor level values to 0 and 1, if necessary.

4. Click Continue.

5. In the design specification dialog (shown on the left in Figure 11.14), enter a sample size 
(Number of Runs). This example uses a sample size of 12.

6. Click the Minimum Potential button. JMP creates this design and displays the design runs 
and the design diagnostics (shown on the right in Figure 11.14).

Figure 11.14  Space-Filling Methods and Design Diagnostics for Minimum Potential Design

7. Click Make Table.

You can see the spherical symmetry of the Minimum Potential design using the Scatterplot 3D 
graphics platform.
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1. After you make the JMP design table, choose the Graph > Scatterplot 3D command.

2. In the Scatterplot 3D launch dialog, select X1, X2, and X3 as Y, Columns and click OK to see 
the initial three dimensional scatterplot of the design points.

3. To see the results similar to those in Figure 11.15, select the Normal Contour Ellipsoids 
option from the menu in the Scatterplot 3D title bar, and make the points larger by 
right-clicking on the plot and selecting Settings, then increasing the Marker Size slider.

Now it is easy to see the points spread evenly on the surface of the ellipsoid.

Figure 11.15  Minimum Potential Design Points on Sphere

Maximum Entropy Designs

The Latin Hypercube design is currently the most popular design assuming you are going to 
analyze the data using a Gaussian-Process model. Computer simulation experts like to use the 
Latin Hypercube design because all projections onto the coordinate axes are uniform.

However, as the example at the top in Figure 11.16 shows, the Latin Hypercube design does 
not necessarily do a great job of space filling. This is a two-factor Latin Hypercube with 16 
runs, with the factor level settings set between -1 and 1. Note that this design appears to leave 
a hole in the bottom right of the overlay plot.
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Figure 11.16  Two-factor Latin Hypercube Design

The Maximum Entropy design is a competitor to the Latin Hypercube design for computer 
experiments because it optimizes a measure of the amount of information contained in an 
experiment. See the technical note below. With the factor levels set between -1 and 1, the 
two-factor Maximum Entropy design shown in Figure 11.17 covers the region better than the 
Latin hypercube design in Figure 11.16. The space-filling property generally improves as the 
number of runs increases without bound.

Figure 11.17  Two-Factor Maximum Entropy Design

Technical Maximum Entropy designs maximize the Shannon information (Shewry and Wynn 
(1987)) of an experiment, assuming that the data come from a normal (m, s2 R) distribution, 
where

Note the empty area in the 
Latin Hypercube design

Rij θk xik xjk–( )2
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is the correlation of response values at two different design points, xi and xj. Computationally, 
these designs maximize |R|, the determinant of the correlation matrix of the sample. When xi 
and xj are far apart, then Rij approaches zero. When xi and xj are close together, then Rij is near 
one.

Gaussian Process IMSE Optimal Designs

The Gaussian process IMSE optimal design is also a competitor to the Latin Hypercube design 
because it minimizes the integrated mean squared error of the Gaussian process model over 
the experimental region.

You can compare the IMSE optimal design to the Latin Hypercube (shown previously in 
Figure 11.16). The table and overlay plot in Figure 11.18 show a Gaussian IMSE optimal 
design. You can see that the design provides uniform coverage of the factor region.

Figure 11.18  Comparison of Two-factor Latin Hypercube and Gaussian IMSE Optimal 
Designs

Note: Both the Maximum Entropy design and the Gaussian Process IMSE Optimal design 
were created using 100 random starts.

Fast Flexible Filling Designs

The algorithm that generates a Fast Flexible Filling design begins by generating a large 
number of uniformly-distributed points within the specified design region. These points are 
then clustered using a Fast Ward algorithm into a number of clusters that equals your 
specified Number of Runs. The algorithm places a design point at the centroid of each cluster. 
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This method has the property that any point in the design space has a design point fairly close 
to it.

Set Average Cluster Size

The Set Average Cluster Size option is found under Advanced Options in the Space Filling 
Design red triangle menu. This option allows you to specify the average number of 
uniformly-generated points used to define each cluster or, equivalently, each design point. 

By default, if the Number of Runs is set to 200 or less, a total of 10,000 random 
uniformly-generated points are used as the basis for the clustering algorithm. When the 
number of Runs exceeds 200, a default value of 50 is used. Increasing this value can be 
particularly useful in designs with a large number of factors or where disallowed 
combinations restrict the distribution of points used in the clustering algorithm.

Note: Depending on the number of factors and the specified value for Number of Runs, you 
may want to increase the average number of initial points per design point by selecting 
Advanced Options > Set Average Cluster Size.

Constraints

The design region can be defined using the Disallowed Combinations option from the Space 
Filling Design red triangle menu or by selecting Add linear constraints under Fast Flexible 
Filling in the list of Space Filling Design Methods. However, the design is generated 
differently for these two methods.

Disallowed Combinations

When disallowed combinations are specified, the random points that form the basis for the 
clustering algorithm are uniformly-distributed within the unconstrained design region. Then 
disallowed points are removed and clustering proceeds with the remaining points.

Note: Depending on the nature of the constraints and the specified Number of Runs, the 
default coverage of the unconstrained design space by the initial uniformly-generated points 
may not be sufficient to produce the required Number of Runs. In this case, you may obtain a 
JMP Alert indicating that the algorithm “Could not find sufficient number of points.” To 
increase the initial number of points that form the basis for the clustering algorithm, specify a 
larger average number of initial points per design point by selecting Advanced Options > Set 
Average Cluster Size. (See “Set Average Cluster Size” on page 272).
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Add Linear Constraints

When linear constraints are specified using the Add linear constraints option, the random 
points that form the basis for the clustering algorithm are uniformly-distributed within the 
constrained design region. The clustering algorithm uses these points.

Creating a Constrained Fast Flexible Filling Design

1. Select DOE > Space Filling Design.

2. Enter responses, if necessary, and factors. (See “Enter Responses and Factors into the 
Custom Designer” on page 45.)

3. Alter the factor level values to 0 and 1.

4. Click Continue.

5. In the design specification dialog, specify a sample size (Number of Runs).

6. Specify linear constraints. Click the Linear Constraint button and add linear constraints. 
(For details on adding constraints, see “Defining Factor Constraints, If Necessary” on 
page 49.)

7. Click the Fast Flexible Filling button. 

JMP creates the design and displays the design runs and the design diagnostics in the 
report.

8. Click Make Table in the Design Table panel to construct the data table.

Figure 11.19 shows the design specification dialog for a two-factor design with one linear 
constraint, . The Number of Runs is set at 200.

Figure 11.19  Design Specification for Fast Flexible Filling Design with One Constraint

X1 X2+ 0.8≤



274 Space-Filling Designs Chapter 11
Fast Flexible Filling Designs Design of Experiments Guide

Visualizing the Fast Flexible Filling Design

To visualize the nature of the Fast Flexible Filling technique, first construct a data table for a 
200-run two-factor design with one linear constraint, . Then, use Graph Builder.

Constructing the Design

1. Select DOE > Space Filling Design.

2. For the two default factors, X1 and X2, alter the factor values to 0 and 1.

3. Click Continue.

4. In the design specification dialog, specify 200 as Number of Runs.

5. Click the Linear Constraint button.

6. Add the constraint  by entering the values 1, 1, and 0.8 as shown in 
Figure 11.19.

7. Click the Fast Flexible Filling button. 

Constructing the Plot

1. With the data table active, select Graph > Graph Builder.

2. Drag X1 to the drop zone labeled X.

3. Drag X2 to the drop zone labeled Y.

4. Remove the Smoother by clicking the smoother icon (the second icon from the left in the 
row of icons directly above the graph).

5. In the Graph Builder red triangle menu, click Show Control Panel to deselect it.

You should see a graph similar to the one in Figure 11.20. Note that the points satisfy the 
linear constraint . Also, consider the distance between any point in the design 
space and its closest design point. Note that there is not much variation in these distances.

X1 X2+ 0.8≤

X1 X2+ 0.8≤

X1 X2+ 0.8≤
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Figure 11.20  Fast Flexible Filling Design with One Linear Constraint

Borehole Model: A Sphere-Packing Example

Worley (1987) presented a model of the flow of water through a borehole that is drilled from 
the ground surface through two aquifers. The response variable y is the flow rate through the 
borehole in m3/year and is determined by the following equation:

There are eight inputs to this model:

rw = radius of borehole, 0.05 to 0.15 m

r = radius of influence, 100 to 50,000 m

Tu = transmissivity of upper aquifier, 63,070 to 115,600 m2/year

Hu = potentiometric head of upper aquifier, 990 to 1100 m

Tl = transmissivity of lower aquifier, 63.1 to 116 m2/year

Hl = potentiometric head of lower aquifier, 700 to 820 m

L = length of borehole, 1120 to 1680 m
Kw = hydraulic conductivity of borehole, 9855 to 12,045 m/year

y
2πTu Hu Hl–( )

r rw⁄( )ln 1
2LTu

r rw⁄( )ln rw
2Kw

-----------------------------------------
Tu
Tl
------+ +

----------------------------------------------------------------------------------------------=
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This example is atypical of most computer experiments because the response can be expressed 
as a simple, explicit function of the input variables. However, this simplicity is useful for 
explaining the design methods.

Create the Sphere-Packing Design for the Borehole Data

To create a Sphere-Packing design for the borehole problem: 

1. Select DOE > Space Filling Design.

2. Click the red triangle icon on the Space Filling Design title bar and select Load Factors.

3. Open the sample data folder installed with JMP. Open Borehole Factors.jmp from the 
Design Experiment folder to load the factors (Figure 11.21).

Figure 11.21  Factors Panel with Factor Values Loaded for Borehole Example

Note: The logarithm of r and rw are used in the following discussion.

4. Click Continue.

5. Specify a sample size (Number of Runs) of 32 as shown in Figure 11.22.
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Figure 11.22  Space-Filling Design Method Panel Showing 32 Runs

6. Click the Sphere Packing button to produce the design.

7. Click Make Table to make a table showing the design settings for the experiment. The 
factor settings in the example table might not have the same ones you see when generating 
the design because the designs are generated from a random seed.

8. To see a completed data table for this example, open Borehole Sphere Packing.jmp from the 
Design Experiment sample data folder installed with JMP. This table also has a table 
variable that contains a script to analyze the data. The results of the analysis are saved as 
columns in the table.

Guidelines for the Analysis of Deterministic Data

It is important to remember that deterministic data have no random component. As a result, 
p-values from fitted statistical models do not have their usual meanings. A large F statistic 
(low p-value) is an indication of an effect due to a model term. However, you cannot make 
valid confidence intervals about the size of the effects or about predictions made using the 
model.

Residuals from any model fit to deterministic data are not a measure of noise. Instead, a 
residual shows the model bias for the current model at the current point. Distinct patterns in 
the residuals indicate new terms to add to the model to reduce model bias.

Results of the Borehole Experiment

The example described in the previous sections produced the following results:

• A stepwise regression of the response, log y, versus the full quadratic model in the eight 
factors, led to the prediction formula column.
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• The prediction bias column is the difference between the true model column and the 
prediction formula column.

• The prediction bias is relatively small for each of the experimental points. This indicates 
that the model fits the data well.

In real world examples, the true model is generally not available in a simple analytical form. 
As a result, it is impossible to know the prediction bias at points other than the observed data 
without doing additional runs.

In this case, the true model column contains a formula that allows profiling the prediction bias 
to find its value anywhere in the region of the data. To understand the prediction bias in this 
example:

1. Select Graph > Profiler.

2. Highlight the prediction bias column and click the Y, Prediction Formula button.

3. Check the Expand Intermediate Formulas box, as shown at the bottom on the Profiler 
dialog in Figure 11.23, because the prediction bias formula is a function of columns that are 
also created by formulas.

4. Click OK.

The profile plots at the bottom in Figure 11.23 show the prediction bias at the center of the 
design region. If there were no bias, the profile traces would be constant between the value 
ranges of each factor. In this example, the variables Hu and Hl show nonlinear effects.

Figure 11.23  Profiler Dialog and Profile of the Prediction Bias in the Borehole Sphere-Packing 
Data
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The range of the prediction bias on the data is smaller than the range of the prediction bias 
over the entire domain of interest. To see this, look at the distribution analysis (Analyze > 
Distribution) of the prediction bias in Figure 11.24. Note that the maximum bias is 1.826 and 
the minimum is –0.684 (the range is 2.51).

Figure 11.24  Distribution of the Prediction Bias

The top plot in Figure 11.25 shows the maximum bias (2.91) over the entire domain of the 
factors. The plot at the bottom shows the comparable minimum bias (–4.84). This gives a range 
of 7.75. This is more than three times the size of the range over the observed data.
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Figure 11.25  Prediction Plots showing Maximum and Minimum Bias Over Factor Domains

Keep in mind that, in this example, the true model is known. In any meaningful application, 
the response at any factor setting is unknown. The prediction bias over the experimental data 
underestimates the bias throughout the design domain.

There are two ways to assess the extent of this underestimation:

• Cross-validation refits the data to the model while holding back a subset of the points and 
looks at the error in estimating those points.

• Verification runs (new runs performed) at different settings to assess the lack of fit of the 
empirical model.



Chapter 12
Accelerated Life Test Designs

Designing Experiments for Accelerated Life Tests

The Accelerated Life Test Design platform can be used to design experimental plans for 
accelerated life testing. You can design initial experiments, or augment existing experiments.

Figure 12.1  Accelerated Life Test Design
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Overview of Accelerated Life Test Designs

Often in reliability studies, the product reliability at use conditions is so high that the time 
required to test the product until it fails is prohibitive. As an alternative, you can test the 
product in conditions that are more extreme than normal use conditions. The extreme 
conditions enable the product to degrade and fail sooner, making a reliability study possible. 
Results are used to predict product reliability at normal use conditions.

The Accelerated Life Testing Design platform can be used to design experimental plans for 
accelerated life testing (ALT) experiments. The ALT Design platform can be used to design 
initial experiments, or augment existing experiments. Augmenting designs is useful if you 
want to obtain more data, so that you can decrease the variance associated with predicting 
product reliability.

The ALT Design platform can create designs for situations involving one or two accelerating 
factors. For two accelerating factors, you can choose to include the interaction. You can use 
D-optimality or two types of I-optimality criterion.

The process requires estimates of acceleration model parameters. Since those parameters 
might not be known in advance, you can specify prior distributions to account for the 
uncertainty. Designs can be created for either Lognormal or Weibull life distributions.

Using the ALT Design Platform

1. To launch the ALT Design platform, select DOE > Accelerated Life Test Design.

Figure 12.2  Initial ALT Design Window

2. Select one or two accelerating factors.

For two factors, you can choose to include the interaction between the factors.

3. Select either Monitoring at Intervals or Continuous Monitoring.

Choose Monitoring at Intervals if you can estimate when the experiment will fail. Enter the 
number of inspections, the time of the first inspection, and the time between inspections. 
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Choose Continuous Monitoring if you are unsure of when the experiment will fail.

4. Click Continue.

A window appears for specifying details of the accelerating factor or factors.

Figure 12.3  Accelerating Factor Details Window

5. Fill in these options:

Factor Name Enter a name for the accelerating factor.

Number of Levels Enter the number of levels of the factor to include in the experiment.

Factor Transformation Select a transformation for the factor. The options are Arrhenius 
Celsius, Reciprocal, Log, Square Root, and Linear.

Low Usage Condition Enter a value for the low usage conditions.

High Usage Conditions Enter a value for the high usage conditions.

6. Click Continue.

A window appears for specifying additional information about the assumed distribution 
and desired experimental conditions.
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Figure 12.4  Distribution Details

7. Fill in these options:

Factors Enter the values of the accelerating factor levels.

Distribution Choice Select the failure distribution, either Weibull or LogNormal.

Prior Mean Enter the acceleration model parameters. These values can be either a best guess 
or the estimates of the parameters from an analysis of previously obtained data.

Prior Variance Matrix Enter variances and covariances for the acceleration model parameters. 
These values can be either a best guess or the estimated variance matrix from an analysis of 
previously obtained data.
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Ignore prior variance Select this option to ignore variances and covariances for model 
parameters. When the variances and covariances are ignored, the design is created for the 
specific fixed parameters entered under Prior Mean. The resulting design is said to be a 
locally optimal design. This design will be good if the prior mean parameters are close to 
the true values. However, the design will not be robust to mis-specified parameters. When 
the variances and covariances are used, a multivariate normal prior distribution is 
assumed for the acceleration model parameters. This is useful when the values entered 
under Prior Mean are estimates or guesses, and you want the design to reflect the 
associated uncertainty.

Diagnostic Choices Enter values for the following:

Time range of interest are values for which you want an estimated probability of failure. 
For example, if you are interested in the probability of failure by 100,000 hours, then enter 
100,000 for both the lower and upper ranges.

Probability of interest is the value for which you want an estimated time of failure. For 
example, if you are most interested in obtaining the time until 10% of units fail, then enter 
0.1.

Design Choices Enter values for the following:

Length of Test is the length of time to run the experiment.

Number of Units Under Test is the number of units in the experiment. If augmenting a 
previous experiment, enter the number of units from the previous experiment plus the 
number of units that you want to run for the next experiment. If designing an initial 
experiment, enter the number of units that you want to run.

8. Click Continue.

New outline nodes appear as shown in Figure 12.5.



Chapter 12 Accelerated Life Test Designs 287
Design of Experiments Guide Using the ALT Design Platform

Figure 12.5  Additional Outline Nodes

Candidate Runs Enter the minimum and maximum number of runs allowed at each level of 
the acceleration factor. If augmenting a previous experiment, enter the number of units 
already run at each level for the Minimum Units.

Parameter Variance for Balanced Design Gives the expected variances and covariances for the 
acceleration model parameters after running and analyzing the balanced design (same 
number of runs at each level of the acceleration factor). These values are valid under the 
assumption that the values for the prior mean and variance are correct.

These values can be compared to the ones entered under Prior Variance Matrix, to see 
whether the balanced design can improve the variances of the parameter estimates. They 
can also be compared to the final parameter variances for the optimal design, after clicking 
Make Design.

Distribution Profiler Use the profiler to visualize the probability that a unit will fail at 
different values of the acceleration factor and time.

9. Click Update Profiler to update the profiler if changes are made to the distribution choice, 
means, variances, design choices, or candidate runs.

10. Click Make Design to create the optimal design and display the results.



288 Accelerated Life Test Designs Chapter 12
Platform Options Design of Experiments Guide

Figure 12.6  Design Results

The information below describes the results you get after clicking Make Design.

The Design report gives the expected number of failures for each level of the acceleration 
factor. Also given is the probability that none of the units at this setting will fail.

The Parameter Variance for Optimal Design report gives the variances and covariances for the 
acceleration model parameters for the optimal design. These values are valid under the 
assumption that the values for the prior mean and variance are correct. These values can be 
compared to those under Parameter Variance for Balanced Design to determine whether the 
optimal design is able to reduce the parameter variances more than the balanced design.

The Optimality Criteria report gives the values of the optimality criterion for the optimal 
design. For more information about the optimality criterion, see “Platform Options” on 
page 288.

The Make Design button updates the optimal design if any changes are made to the 
distribution choice, prior means or variances, design choices, or candidate runs.

The Make Test Plan button creates a data table with the acceleration factor levels and the 
number of units to include in the experiment for each level.

The Make Table button creates a table that can be used for data collection during the 
experiment.

Platform Options

The red triangle menu for Accelerated Life Test Plan has the following options:

Simulate Responses Adds simulated responses to the table when you click Make Table.
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ALT Optimality Criterion Gives three choices for design optimality:

Make D-Optimal Design creates a design that minimizes the variance of the model 
coefficients.

Make Time I-Optimal Design creates a design that minimizes the prediction variance when 
predicting the time to failure for the probability given in “Diagnostic Choices” on page 286.

Make Probability I-Optimal Design creates a design that minimizes the prediction variance 
when predicting the failure probability for the times given in “Diagnostic Choices” on 
page 286.

Advanced Options Gives the N Monte Carlo Spheres option, which affects the speed and 
accuracy of numerical integration. For more information, see “Advanced Options for the 
Nonlinear Designer” on page 309 in the “Nonlinear Designs” chapter.

Example

This example shows how to use the Accelerated Life Test Design to augment an existing 
design.

An accelerated life test was performed, and the results are in the Capacitor ALT.jmp sample 
data table (in the Design Experiment folder). Fifty units were tested at each of three 
temperatures (85o, 105o, and 125o Celsius) for 1500 hours. The resulting model is used to 
predict the probability of failure at 100,000 hours at normal use conditions of 25o.

1. Open the Capacitor ALT.jmp data table in the Design Experiment folder.

2. Run the Fit Life by X table script.

3. In the Distribution Profiler, enter 25 for Temp and 100,000 for Hours.

The profiler is shown in Figure 12.7.

Figure 12.7  Distribution Profiler for Capacitor Model

The predicted probability of failure at 100,000 hours at 25o is 0.00358, with a confidence 
interval of 0.00056 to 0.0227. The analyst wants to decrease the width of the confidence 
interval. To do so, the experiment needs to be augmented with additional data.
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To augment the design in the optimal way, use the Accelerated Life Test Design platform. 
Follow the steps below to use the platform:

1. Select DOE > Accelerated Life Test Design.

2. Select Design for one accelerating factor and click Continue.

3. Enter Temperature for Factor Name.

4. Enter 5 for Number of Levels.

5. Enter 25 for both Low Usage Condition and High Usage Condition.

6. Click Continue.

7. Enter 85, 95, 105, 115, and 125 for the Temperature Level Values.

8. Select Weibull for Distribution Choice.

9. Under Prior Mean, enter the acceleration model parameters from the Fit Life by X 
Estimates report. See Figure 12.8.

– Enter -35.200 for Intercept.

– Enter 1.389 for Temperature.

– Enter 1.305 for scale.

Figure 12.8  Fit Life by X Estimates

In the Fit Life by X output, under the Estimates report, is the Covariance Matrix report. Note 
the variances for the acceleration model parameters are 22, 0.025, and 0.013. These values will 
be compared to our final results at the end.

10. Enter 100,000 for both boxes for Time range of interest.

11. Enter 1500 for Length of Test.

12. Enter 300 for Number of Units Under Test. The previous experiment used 150 units, and the 
next experiment uses 150 units, for a total of 300.

The completed window is shown in Figure 12.9.
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Figure 12.9  Completed Window

13. Click Continue.

14. To account for the units in the previous experiment, enter the following under Candidate 
Runs.

– Enter 50 for Minimum Units for 85o.

– Enter 50 for Minimum Units for 105o.

– Enter 50 for Minimum Units for 125o.

15. From the red triangle menu for Accelerated Life Test Plan, select ALT Optimality Criterion > 
Make Probability I-Optimal Design.

16. Click Make Design.

The optimal experimental design is returned, along with other results. See Figure 12.10.
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Figure 12.10  Optimal Design

The optimal design is computed based on the Number of Units Under Test, Candidate Runs, 
and other information that you specified earlier. The optimal design consists of the following 
number of units at each temperature level:

• 184 units at 85o. Since the previous experiment used 50 units, 134 additional units are 
needed.

• 0 units at 95o. The next experiment will not utilize any units at this level.

• 50 units at 105o. Since the previous experiment already used 50 units, no additional units 
are needed.

• 0 units at 115o. The next experiment will not utilize any units at this level.

• 66 units at 125o. Since the previous experiment used 50 units, 16 additional units are 
needed.

As we entered earlier, a total of 134+16=150 units are used for the new experiment.

An estimate of the acceleration model parameters variances is given. Note that, due to the 
additional data, all three variances are smaller than before from the original Fit Life by X 
report.

In the Profiler, enter 25 for Temperature and 100,000 for Time. The estimated probability of 
failure is 0.00357, with an estimated confidence interval of 0.00106 to 0.01201. This interval is 
narrower than the one from the previous experiment, as a result of the additional units to be 
tested.

To decrease the interval further, try entering more than 300 units to be tested.
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Nonlinear Designs

Design of experiments with models that are nonlinear in their parameters is available using 
either the DOE menu or the JMP Starter DOE category.

Nonlinear designs offer both advantages and disadvantages compared to designs for linear 
models. 

On the positive side, predictions using a well chosen model are likely to be good over a wider 
range of factor settings. It is also possible to model response surfaces with more curvature and 
with asymptotic behavior.

On the negative side, the researcher needs a greater understanding of both the system and of 
the nonlinear design tool.
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Examples of Nonlinear Designs

The Nonlinear Designer allows scientists to generate optimal designs and optimally augment 
data for fitting models that are nonlinear in their parameters. Such models, when they are 
descriptive of the underlying process, can yield more accurate prediction of process behavior 
than is possible with the standard polynomial models.

To use the Nonlinear Designer, you first need a data table that has 

• one column for each factor 

• one column for the response

• a column that contains a formula showing the functional relationship between the factor(s) 
and the response.

This is the same format for a table you would supply to the nonlinear platform for modeling.

The first example in this section describes how to approach creating a nonlinear design when 
there is prior data. The second example describes how to approach creating the design 
without data, but with reasonable starting values for the parameter estimates.

Using Nonlinear Fit to Find Prior Parameter Estimates

Suppose you have already collected experimental data and placed it in a JMP data table. That 
table can be used to create a nonlinear design for improving the estimates of the model’s 
parameters.

To follow along with this example, open Chemical Kinetics.jmp from the Nonlinear Examples 
folder found in the sample data installed with JMP.

Chemical Kinetics.jmp (Figure 13.1) contains a column (Model (x))whose values are formed by a 
formula with a poor guess of the parameter values.
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Figure 13.1  Chemical Kinetics.jmp

First, fit the data to the model using nonlinear least squares to get better parameter values.

1. Select Analyze > Modeling > Nonlinear.

2. Select Velocity (y) and click Y, Response on the nonlinear launch dialog.

3. Select Model (x) and click X, Predictor Formula (see Figure 13.2). Note that the formula 
given by Model (x) shows in the launch dialog.

Figure 13.2  Initial Nonlinear Analysis Launch Dialog
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4. Click OK on the launch dialog to see the Nonlinear Fit Control Panel.

5. Click Go in the Control Panel to obtain the estimates shown in Figure 13.3.

Figure 13.3  Nonlinear Fit Results

6. Click the Confidence Limits button to add confidence intervals to the Solution report.

The ranges for LowerCL and UpperCL are the intervals for VMax and k. They are 
asymptotically normal. Use these limits to create a nonlinear design in JMP.

7. Click Save Estimates to add the new fitted parameter values in the Model (x) column in the 
Chemical Kinetics.jmp data table.

Click the “+” sign next to Model (x) in the Columns panel to view the formula. Select 
Parameters from the menu in the upper left of the formula editor to view the new 
parameter estimates.
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Figure 13.4  New Parameter Estimates

Note: Leave the nonlinear analysis report open because these results are needed in the DOE 
nonlinear design dialog described next.

Now create a design for fitting the model’s nonlinear parameters.

1. With the Chemical Kinetics.jmp data table open, select DOE > Nonlinear Design.

2. Complete the launch dialog the same way as the Nonlinear Analysis launch dialog shown 
previously. That is, Select Velocity (y) and click Y, Response. Select Model (x) and click X, 
Predictor Formula. Figure 13.5 shows the completed dialog.

Figure 13.5  Initial Nonlinear Design Launch Dialog

3. Click OK to see the completed Design panels for factors and parameters, as shown in 
Figure 13.6.
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Figure 13.6  Nonlinear Design Panels for Factors and Parameters

Note that in Chemical Kinetics.jmp (Figure 13.1), the range of data for Concentration goes 
from 0.417 to 6.25. Therefore, these values initially appear as the high and low values in 
the Factors control panel.

4. Change the factor range for Concentration to a broader interval—from 0.1 to 7 
(Figure 13.7).

Note that the a priori distribution of the parameters VMax and k is Normal, which is correct 
for this example. Change the current level of uncertainty in the two parameters using the 
analysis results.

5. Look back at the analysis report in Figure 13.3 after you added the Confidence Limits. 
Locate the upper and lower confidence limits for VMax and k in the Solution table. Change 
the values for VMax and k to correspond to those limits, as shown in Figure 13.7.

Now you have described the current level of uncertainty of the two parameters.
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Figure 13.7  Change Values for Factor and Parameters

Use commands from the menu on the Nonlinear Design title bar to get the best possible 
design:

6. Select Number of Starts from the menu on the title bar and enter 100 in the text box.

7. Select Advanced Options > Number of Monte Carlo Samples and enter 2 in the text box.

8. Click Make Design to preview the design (Figure 13.8). Your results might differ from 
those shown for the additional runs.

Figure 13.8  Selecting the Number of Runs
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9. Click Make Table.

This creates a new JMP design table (Figure 13.9) whose rows are the runs defined by the 
nonlinear design.

Note: This example creates a new table to avoid altering the sample data table Chemical 
Kinetics.jmp. In most cases, however, you can augment the original table using the Augment 
Table option in the Nonlinear Designer instead of making a new table. This option adds the 
new runs shown in the Design to the existing data table.

Figure 13.9  Making a Table with the Nonlinear Designer

The new runs use the wider interval of allowed concentration, which leads to more precise 
estimates of k and Vmax.

Creating a Nonlinear Design with No Prior Data

This next example describes how to create a design when you have not yet collected data, but 
have a guess for the unknown parameters.

To follow along with this example, open Reaction Kinetics Start.jmp, found in the Design 
Experiment folder in the sample data installed with JMP. Notice that the table is a template. 
That is, the table has columns with properties and formulas, but there are no observations in 
the table. The design has not yet been created and data have not been collected.

This table is used to supply the formula in the yield model column to the Nonlinear DOE 
platform. The formula is used to create a nonlinear design for fitting the model’s nonlinear 
parameters.
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Figure 13.10  Yield Model Formula

This model is from Box and Draper (1987). The formula arises from the fractional yield of the 
intermediate product in a consecutive chemical reaction. It is written as a function of time and 
temperature.

1. With the Reaction Kinetics Start.jmp data table open, select DOE > Nonlinear Design to see 
the initial launch dialog.

2. Select observed yield and click Y, Response.

3. Select yield model (the column with the formula) and click X, Predictor Formula.

The completed dialog should look like the one in Figure 13.11.

Figure 13.11  Nonlinear Design launch Dialog 

4. Click OK to see the nonlinear design Factors and Parameters panels in Figure 13.12.

5. Change the two factors’ values to be a reasonable range of values. (In your experiment, 
these values might have to be an educated guess.) For this example, use the values 510 and 
540 for Reaction Temperature. Use the values 0.1 and 0.3 for Reaction Time.

6. Change the values of the parameter t1 to 25 and 50, and t3 to 30 and 35.

7. Click on the Distribution of each parameter and select Uniform from the menu to change 
the distribution from the default Normal (see Figure 13.12).

8. Change the number of runs to 12 in the Design Generation panel.
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Figure 13.12  Change Factor Values, Parameter Distributions, and Number of Runs

9. Click Make Design, then Make Table. Your results should look similar to those in 
Figure 13.13.

Figure 13.13  Design Table

10. To analyze data that contains values for the response, observed yield, open Reaction 
Kinetics.jmp from the Design Experiment folder in the sample data installed with JMP 
(Figure 13.14).
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Figure 13.14  Reaction Kinetics.jmp

First, examine the design region with an overlay plot.

11. Select Graph > Overlay Plot.

12. Remove all existing column assignments.

13. Select Reaction Temperature and click Y 

14. Select Reaction Time and click X as shown in the Overlay Plot launch dialog in 
Figure 13.15.

15. Click OK to see the overlay plot in Figure 13.15.

Figure 13.15  Create an Overlay Plot

Notice that the points are not at the corners of the design region. In particular, there are no 
points at low temperature and high time—the lower right corner of the graph.

16. Select Analyze > Modeling > Nonlinear.

17. Remove all existing column assignments.
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18. Select observed yield and click Y, Response.

19. Select yield model and click the X, Predictor Formula, then click OK.

20. Click Go on the Nonlinear control panel.

21. Now, choose Profilers > Profiler from the red triangle menu on the Nonlinear Fit title bar.

22. To maximize the yield, choose Maximize Desirability from the red triangle menu on the 
Prediction Profiler title bar.

The maximum yield is approximately 63.5% at a reaction temperature of 540 degrees Kelvin 
and a reaction time of 0.1945 minutes.

Figure 13.16  Time and Temperature Settings for Maximum Yield

Creating a Nonlinear Design

To begin, open a data table that has a column whose values are formed by a formula (for 
details about formulas, see the Using JMP). This formula must have parameters.

Select DOE > Nonlinear Design, or click the Nonlinear Design button on the JMP Starter DOE 
page. Then, follow the steps below:

• “Identify the Response and Factor Column with Formula” on page 306

• “Set Up Factors and Parameters in the Nonlinear Design Dialog” on page 306

• “Enter the Number of Runs and Preview the Design” on page 307

• “Make Table or Augment the Table” on page 308
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Identify the Response and Factor Column with Formula

1. Open a data table that contains a column whose values are formed by a formula that has 
parameters. This example uses Corn.jmp from the Nonlinear Examples folder in the sample 
data installed with JMP.

2. Select DOE > Nonlinear Design to see the initial launch dialog.

3. Select yield and click Y, Response. The response column cannot have missing values.

4. Select quad and click X, Predictor Formula. The quad variable has a formula that includes 
nitrate and three parameters (Figure 13.17).

5. Click OK on the launch dialog to see the Nonlinear Design DOE panels.

Figure 13.17  Identify Response (Y) and the Column with the Nonlinear Formula (X)

Set Up Factors and Parameters in the Nonlinear Design Dialog

First, look at the formula for quad, shown in Figure 13.18, and notice there are three 
parameters. These parameters show in the Parameters panel of the Nonlinear design dialog, 
with initial parameter values.

Figure 13.18  Formula for quad has Parameters a, b, and c

Use Figure 13.19 to understand how to set up factor and parameter names and values.

• The initial values for the factor and the parameters are reasonable and do not need to be 
changed.

• If necessary, change the Distribution of the parameters to Uniform, as shown in Figure 13.19.



Chapter 13 Nonlinear Designs 307
Design of Experiments Guide Creating a Nonlinear Design

Figure 13.19  Example of Setting Up Factors and Parameters

Enter the Number of Runs and Preview the Design

1. The Design Generation panel shows 150 as the default number of runs. This number 
includes observations in the current data. 147 runs are desired. Since there are originally 
144 rows, 3 additional runs need to be added. Enter 147 in the Number of Runs edit box.

2. Click Make Design before creating the data table to preview the design. Figure 13.20 shows 
a partial listing of the design.

Double-click to edit the factor or 
parameter name.

Click to enter or change factor values.

Click to edit the distribution: Uniform, Normal, 
Lognormal, or Exponential.
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Figure 13.20  Example Preview Design

Make Table or Augment the Table

3. The last step is to click either Make Table or Augment Table. The Make Table command 
creates a new table (Figure 13.21) with all runs included. The Augment Table command 
adds the new runs to the existing table.

Figure 13.21  Partial Listing of an Example Nonlinear Design Table
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Advanced Options for the Nonlinear Designer

For advanced users, the Nonlinear Designer has the two additional options, as shown in 
Figure 13.22. These advanced options are included because finding nonlinear DOE solutions 
involves minimizing the integral of the log of the determinant of the Fisher information matrix 
with respect to the prior distribution of the parameters. These integrals are complicated and 
have to be calculated numerically.

The way the integration is done for Normal distribution priors uses a numerical integration 
technique where the integral is reparameterized into a radial direction, and the number of 
parameters minus one angular directions. The radial part of the integral is handled using 
Radau-Gauss-Laguerre quadrature with an evaluation at radius=0. A randomized 
Mysovskikh quadrature is used to calculate the integral over the spherical part, which is 
equivalent to integrating over the surface of a hypersphere.

Note: If some of the prior distributions are not Normal, then the integral is reparameterized so 
that the new parameters have normal distribution, and then the radial-spherical integration 
method is applied. However, if the prior distribution set for the parameters does not lend itself 
to a solution, sometimes the process fails and gives the message that the Fisher information is 
singular in a region of the parameter space, and advises changing the prior distribution or the 
ranges of the parameters.

Figure 13.22  Advanced Options for the Nonlinear Designer

The following is a technical description for these two advanced options:

Number of Monte Carlo Samples sets the number of octahedra per sphere. Because each 
octahedron is a fixed unit, this option can be thought of as setting the number of octahedra 
per sphere.

N Monte Carlo Spheres are the number of nonzero radius values used. The default is two 
spheres and one center point. Each radial value requires integration over the angular 
dimensions. This is done by constructing a certain number of hyperoctahedra (the 
generalization of an octagon in arbitrary dimensions), and randomly rotating each of them.
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Technical The reason for the approach given by these advanced options is to get good integral 
approximations much faster than using standard methods. For instance, with six parameters, 
using two radii and one sample per sphere, these methods give a generalized five- point rule 
that needs only 113 observations to get a good approximation. Using the most common 
approach (Simpson’s rule) would need 56 = 15,625 evaluations. The straight Monte Carlo 
approach also requires thousands of function evaluations to get the same level of quality in 
the answer. For more details, see Gotwalt, Jones, and Steinberg (2009).

Keep in mind that if the number of radii is set to zero, then just the center point is used, which 
gives a local design that is optimal for a particular value of the parameters. For some people 
this is good enough for their purposes. These designs are created much faster than if the 
integration is performed.



Chapter 14
Taguchi Designs

Quality was the watchword of 1980s, and Genichi Taguchi was a leader in the growth of 
quality consciousness. One of Taguchi’s technical contributions to the field of quality control 
was a new approach to industrial experimentation. The purpose of the Taguchi method was to 
develop products that worked well in spite of natural variation in materials, operators, 
suppliers, and environmental change. This is robust engineering.

Much of the Taguchi method is traditional. His orthogonal arrays are two-level, three-level, and 
mixed-level fractional factorial designs. The unique aspects of his approach are the use of 
signal and noise factors, inner and outer arrays, and signal-to-noise ratios.

The goal of the Taguchi method is to find control factor settings that generate acceptable 
responses despite natural environmental and process variability. In each experiment, 
Taguchi’s design approach employs two designs called the inner and outer array. The Taguchi 
experiment is the cross product of these two arrays. The control factors, used to tweak the 
process, form the inner array. The noise factors, associated with process or environmental 
variability, form the outer array. Taguchi’s signal-to-noise ratios are functions of the observed 
responses over an outer array. The Taguchi designer supports all these features of the Taguchi 
method. You choose from inner and outer array designs, which use the traditional Taguchi 
orthogonal arrays, such as L4, L8, and L16.

Dividing system variables according to their signal and noise factors is a key ingredient in 
robust engineering. Signal factors are system control inputs. Noise factors are variables that 
are typically difficult or expensive to control.

The inner array is a design in the signal factors and the outer array is a design in the noise 
factors. A signal-to-noise ratio is a statistic calculated over an entire outer array. Its formula 
depends on whether the experimental goal is to maximize, minimize or match a target value 
of the quality characteristic of interest.

A Taguchi experiment repeats the outer array design for each run of the inner array. The 
response variable in the data analysis is not the raw response or quality characteristic; it is the 
signal-to-noise ratio. 

The Taguchi designer in JMP supports signal and noise factors, inner and outer arrays, and 
signal-to-noise ratios as Taguchi specifies. 
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The Taguchi Design Approach

The Taguchi method defines two types of factors: control factors and noise factors. An inner 
design constructed over the control factors finds optimum settings. An outer design over the 
noise factors looks at how the response behaves for a wide range of noise conditions. The 
experiment is performed on all combinations of the inner and outer design runs. A 
performance statistic is calculated across the outer runs for each inner run. This becomes the 
response for a fit across the inner design runs. Table 14.1 lists the recommended performance 
statistics.

Taguchi Design Example

The following example is an experiment done at Baylock Manufacturing Corporation and 
described by Byrne and Taguchi (1986). The objective of the experiment is to find settings of 
predetermined control factors that simultaneously maximize the adhesiveness (pull-off force) 
and minimize the assembly costs of nylon tubing.

To follow along with this example, open the Byrne Taguchi Data.jmp table found in the Design 
Experiment folder of the Sample Data installed with JMP. Or, generate the original design table 
on your own using DOE > Taguchi Arrays.

Table 14.2 shows the signal and noise factors in the Byrne Taguchi Data for this example.

Table 14.1  Recommended Performance Statistics

Goal S/N Ratio Formula

nominal is best
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Table 14.2  Signal and Noise Factors

Factor Name Type Levels Comment

Interfer control 3 tubing and connector interference

Wall control 3 the wall thickness of the connector
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To start this example:

1. Select DOE > Taguchi Arrays.

2. Click the red triangle icon on the Taguchi Design title bar and select Load Factors.

3. When the Open File dialog appears, open the factors table, Byrne Taguchi Factors.jmp 
found in the Design Experiment sample data folder installed with JMP.

The factors panel then shows the four three-level control (signal) factors and three noise 
factors, as shown in Figure 14.1.

Figure 14.1  Response, and Signal and Noise Factors for the Byrne-Taguchi Example

4. Highlight L9-Taguchi to give the L9 orthogonal array for the inner design.

5. Highlight L8 to give an eight-run outer array design.

Depth control 3 insertion depth of the tubing into the 
connector

Adhesive control 3 percent adhesive

Time noise 2 the conditioning time

Temperature noise 2 temperature

Humidity noise 2 the relative humidity

Table 14.2  Signal and Noise Factors (Continued)

Factor Name Type Levels Comment
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6. Click Continue.

The outer design has three two-level factors. A full factorial in eight runs is generated. 
However, it is only used as a guide to identify a new set of eight columns in the final JMP data 
table—one for each combination of levels in the outer design.

7. Click Make Table to create the design table shown in Figure 14.2.

Figure 14.2  Taguchi Design Before Data Entry

Now, suppose the pull-off adhesive force measures are collected and entered into the columns 
containing missing data, as shown in Figure 14.3. The missing data column names are 
appended with the letter Y before the levels (+ or –) of the noise factors for that run. For 
example, Y--- is the column of measurements taken with the three noise factors set at their low 
levels.

8. To see the completed experiment, open the data table, Byrne Taguchi Data.jmp found in the 
Design Experiment sample data folder installed with JMP. Figure 14.3 shows the completed 
design.

Figure 14.3  Complete Taguchi Design Table (Byrne Taguchi Data.jmp)

The column named SN Ratio Y is the performance statistic computed with the formula shown 
below. In this case, it is the “larger-the-better” (LTB) formula, which is –10 times the common 
logarithm of the average squared reciprocal:
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This expression is large when all of the individual y values are large.

Analyze the Data

The data in Byrne Taguchi Data.jmp are now ready to analyze. The goal of the analysis is to find 
factor settings that maximize both the mean and the signal-to-noise ratio.

1. Click the red triangle icon next to Model on the upper left of the data table and select Run 
Script. The Model script produces the Fit Model dialog shown in Figure 14.4.

The Fit Model dialog that appears automatically has the appropriate effects. It includes the 
main effects of the four signal factors. The two responses are the mean (Mean Y) and 
signal-to-noise ratio (SN Ratio Y) over the outer array.

Figure 14.4  Fit Model Dialog for Taguchi Data

2. Click Run on the Fit Model dialog.

The prediction profiler is a quick way to find settings that give the highest signal-to-noise ratio 
for this experiment.

3. To open the Prediction Profiler, click the red triangle on the Response Mean Y title bar and 
select Factor Profiling > Profiler.
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The profile traces (Figure 14.5) indicate that different settings of the first three factors would 
increase SN Ratio Y.

Figure 14.5  The Prediction Profiler

4. To find optimal settings, click the red triangle on the Prediction Profiler title bar and select 
Desirability Functions. This adds the row of traces and a column of function settings to the 
profiler, as shown in Figure 14.6. The default desirability functions are set to 
larger-is-better, which is what you want in this experiment. See the Multivariate Methods 
book for more details about the prediction profiler.

5. Again click the red triangle on the Prediction Profiler title bar and select Maximize 
Desirability to automatically set the prediction traces that give the best results according to 
the desirability functions.

In this example, the settings for Interfer and Wall changed from 1 to 2. (See Figure 14.5 and 
Figure 14.6). The Depth setting changed from 1 to 3. The settings for Adhesive did not change. 
These new settings increased the signal-to-noise ratio from 24.0253 to 26.9075.

Figure 14.6  Best Factor Settings for Byrne Taguchi Data
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Creating a Taguchi Design

To start a Taguchi design, select DOE >Taguchi Arrays, or click the Taguchi Arrays button on the 
JMP Starter DOE page. Then, follow the steps below:

• “Detail the Response and Add Factors” on page 318

• “Choose Inner and Outer Array Designs” on page 319

• “Display Coded Design” on page 319

• “Make the Design Table” on page 320

Detail the Response and Add Factors

The Responses panel has a single default response. The steps for setting up the details of this 
response are outlined in Figure 14.7. For information on importance weights and lower and 
upper limits, see “Understanding Response Importance Weights” on page 46.

1. Double-click to edit the response name.

2. Click to change the response goal: Larger Is Better, Nominal is Best, Smaller is Better, or 
None.

3. Click to enter lower and upper limits and importance weights.

Figure 14.7  Setting Up the Response

The steps for setting up the factors are outlined in Figure 14.8.

1. Click to add a signal, then select a signal type: 2 Level, or 3 Level.

Or click to add a noise.

2. Double-click to edit the factor name.

3. To change the value of a signal or noise, click and then type the new value.

1 2

3
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Figure 14.8  Entering Factors

When you finish adding factors, click Continue.

Choose Inner and Outer Array Designs

Your choice for inner and outer arrays depends on the number and type of factors you have. 
Figure 14.9 shows the available inner array choices when you have eight signal factors. If you 
also have noise factors, choices include designs for the outer array. To follow along, enter eight 
two-level Signal factors and click Continue. Then highlight the design you want and again 
click Continue. This example uses the L12 design.

Figure 14.9  Selecting a Design for Eight Signal Factors

If you did not specify a noise factor, after you click Continue, a dialog appears that asks you to 
specify how many times you want to perform each inner array run. Specify two (2) for this 
example.

Display Coded Design

After you select a design type, the Coded Design (Figure 14.10) is shown below the Factors 
panel.

2

31
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Figure 14.10  Coding for Eight Factor L12 Design

The Coded Design shows the pattern of high and low values for the factors in each run. For 
more details on the coded design, see “Understanding Design Codes” on page 162.

Make the Design Table 

When you click Make Table, a table similar to that shown in Figure 14.11 appears. In the data 
table, each row represents a run. In the values for the Pattern variable, plus signs designate 
high levels and minus signs represent low levels.

Figure 14.11  Taguchi Design Table for Eight Factor L12 Design
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Using the Evaluate Design Platform

Use the Evaluate Design to analyze the diagnostics of an existing experimental design. 
Evaluate your designs to see the impact of a lost run or to assess the estimability of model 
effects. This information can help you understand the strengths or limitations of your 
experimental data. From the results, you can change the model terms and the aliasing terms. 
Then the diagnostics update accordingly.

Note: You do not have to create the design in JMP in order to assess it using the Evaluate 
Design platform.

Some of the diagnostic measures include the following:

• power analysis for model effects

• prediction variance profiles and surface plot

• estimation efficiency

• confounding of effects and alias terms

• correlation between effects and alias terms

• D, G, and A efficiency
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Launching the Evaluate Design Platform

To launch the Evaluate Design platform, open the data table of interest and select DOE > 
Evaluate Design. A populated launch window for the Bounce Data.jmp sample data table, 
found in the Design Experiment subfolder, is shown in Figure 15.1.

Figure 15.1  Evaluate Design Launch Window

The launch window has the following features:

Y, Response Enter the response columns.

X, Factor Enter the effect columns.

The Evaluate Design Report

This section describes the Evaluate Design report. For complete details, see “Creating a 
Custom Design” on page 45 in the “Building Custom Designs” chapter.

Factors Lists the factors in the design and their roles (continuous, discrete numeric, 
categorical, blocking, covariate, mixture, constant, uncontrolled).

Model Lists the terms in the model that you want to fit using the results of the experiment. 
The buttons let you add or remove terms from the model.

Alias Terms Lists the alias terms included in the computation of the alias matrix, and for 
computing correlations between model terms and alias terms. The buttons let you add or 
remove terms from the list of alias terms. By default, second order interactions are 
included as alias terms.

Design Lists the factor level settings for the design. Gives a text column for Anticipated 
Responses. See “The Design Report” on page 52.

Design Evaluation Gives diagnostics for assessing the design. A brief description of each 
section is given in “Design Evaluation” on page 324. Further details are in “Understanding 
Design Evaluation” on page 53.
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Design Evaluation

The Design Evaluation report has several component reports that address various aspects of 
the design. For complete details, see “Understanding Design Evaluation” on page 53 in the 
“Building Custom Designs” chapter. 

Power Analysis

The Power Analysis report (Figure 15.2) allows you to calculate the power of tests for the 
parameters in your model. You can set values for your Significance Level, Anticipated RMSE, 
and Anticipated Coefficients. Click Apply Changes to Anticipate Coefficients to update the 
Power calculations. This action also updates the Anticipated Responses in the Design report. 
Alternatively, you can specify Anticipated Responses in the Design report. Then click Apply 
Changes to Anticipated Responses to update Power in the Power Analysis report.

See “Power Analysis” on page 54 in the “Building Custom Designs” chapter.

Figure 15.2  Power Analysis

Prediction Variance Profile

The Prediction Variance Profile gives a profiler of the relative variance of prediction as a 
function of each factor at fixed values of the other factors. See Figure 15.3. To see how the 
prediction variance changes, drag the vertical dotted lines of the factors. To find the maximum 
prediction variance in the design space, select Maximize Desirability on the red triangle menu.
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Figure 15.3  Prediction Variance Profile

Fraction of Design Space Plot

The Fraction of Design Space Plot shows how much of the model prediction variance lies 
above (or below) a given value. See Figure 15.4. This is most useful when there are multiple 
factors. It summarizes the prediction variance, showing the fractional design space for all the 
factors taken together.

Figure 15.4  Fraction of Design Space Plot

Prediction Variance Surface

The Prediction Variance Surface report plots the prediction variance surface as a function of 
the design factors. See Figure 15.5. Show or hide the controls by selecting Control Panel on the 
red triangle menu.
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Figure 15.5  Prediction Variance Surface

Estimation Efficiency

For each parameter in the model, this report gives the Fractional Increase in CI (Confidence 
Interval) Length and Relative Std (Standard) Error of Parameters. (See Figure 15.6.)

• The Fractional Increase in CI Length compares the width of a parameter’s confidence 
interval as given by the current design to the width that would be given an ideal design. 
The ideal design is an orthogonal design, but an orthogonal design may not exist. For an 
orthogonal design, the fractional increase would be zero. In selecting a design, you would 
like the increase to be as small as possible.

• The Relative Std Error of Parameters gives the ratio of the variance of a parameter’s 
estimate to the error standard deviation.

Figure 15.6  Estimation Efficiency Report
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Alias Matrix

This report shows the alias matrix for the model terms and the alias terms. In the Bounce 
Data.jmp example, the three two-way interactions were automatically added to the list of Alias 
Terms. Therefore, the Alias Matrix gives these three interactions as columns and shows the 
confounding of model terms with these columns (Figure 15.7). Note that the only confounding 
involves two-way interactions with themselves, which is expected.

Figure 15.7  Alias Matrix

Color Map on Correlations

The Color Map on Correlations shows the absolute value of the correlation between each 
model term and alias term. The Color Map on Correlations for the Bounce Data.jmp example is 
shown in Figure 15.8. The deep red coloring indicates correlations of one. Note that there are 
red cells on the diagonal, showing correlations of model terms with themselves. Three red 
cells off the main diagonal show the correlations of the Alias Terms with themselves. This is 
because those three terms appear both in the model and in the Alias Terms list.

Note: Terms that appear in both the model and Alias Terms list appear twice in the Color Map 
on Correlations.

All other cells are either deep blue or light blue, indicating no or little correlation. From the 
perspective of correlation, this is a good design.
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Figure 15.8  Color Map on Correlations

Design Diagnostics

The Design Diagnostics report shows D, G, and A Efficiency values, and the average variance 
of prediction. The design creation time gives the time taken to compute the various 
diagnostics.

Figure 15.9  Design Diagnostics

Examples

This section contains examples of using the Evaluate Design platform to assess designs. The 
first example assesses the impact of lost runs, and the second example assesses the impact of 
changing the model.
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Assessing the Impact of Lost Runs

An experiment was conducted to explore the effect of three factors (Silica, Sulfur, and Silane) 
on tennis ball bounciness (Stretch). After the experiment, the researcher learned that the two 
runs where Silica=0.7 and Silane=50 were not processed correctly. These runs could not be 
included in the analysis of the data. 

Use the Evaluate Design platform to assess the impact of not including those two runs.

1. Open the Bounce Data.jmp sample data table found in the Design Experiment folder.

2. Select DOE > Evaluate Design.

3. Assign Stretch to the Y, Response role.

4. Assign Silica, Sulfur, and Silane to the X, Factor role.

5. Click OK.

6. Return to the data table and exclude the rows for Silica=0.7 and Silane=50. These are rows 1 
and 2.

7. Repeat steps 2-5 to evaluate the reduced experiment.

8. Compare the Fraction of Design Space Plot for both reports. See Figure 15.10.

Figure 15.10  Fraction of Design Space

For small fraction values, the prediction variances are similar. For larger values, the 
prediction variance for the reduced design is a lot higher.

9. One of the available diagnostics is the maximum prediction variance of the designs. In 
both reports, select Maximize Desirability from the Prediction Variance Profile red triangle 
menu.

complete reduced
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Figure 15.11 shows the maximum prediction variance for both the complete and reduced 
designs. For both designs, one of the design points where the maximum prediction 
variance occurs is Silica=0.7, Sulfur=1.8, and Silane=40. The maximum prediction variance 
is 1.396 for the complete design, and 3.02 for the reduced design.

Figure 15.11  Prediction Variance Profilers

Note that for this example, the profiles are symmetric, except the Silica profile for the 
reduced design. A symmetric profile means that there are other design points for which 
the prediction variance is maximized. For example, in the report for the complete design, 
change the Silane value to 60 and notice the variance is still 1.396.

10. Correlations between the model terms and the alias terms can also help you evaluate a 
design. In both reports, open the Color Map On Correlations section to show a color map of 
the correlations. 

Figure 15.12 shows the color maps for both designs.The absolute value of the correlations 
range from 0 (blue) to 1 (red). Place your cursor over a cell with the mouse to see the value 
of the correlation. The color map for the reduced design has more cells with correlations 
that are farther away from 0. For example, the correlation between Sulfur and Silica*Sulfur 
is <.0001 for the complete design, and 0.577 for the reduced design.

Keep in mind that the red off-diagonal cells result from the duplication of the two-way 
interactions induced by the Alias Terms list.

complete

reduced
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Figure 15.12  Correlations between Model and Alias Terms

11. The report also gives several efficiency measures. In both reports, open the Design 
Diagnostics section (Figure 15.13).

The complete design has higher efficiency values, and a lower average prediction variance.

Figure 15.13  Design Diagnostics

Given all these results, the lost runs appear to have a negative impact on the design.

Complete Reduced

Complete Reduced
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Assessing the Impact of Changing the Model

An experiment was conducted to investigate the effects of three factors (Brand, Time, and 
Power) on the number of kernels that pop in a bag of microwave popcorn. For this example, 
we assume that the same number of kernels are in each bag. The goal is to find the 
combination of factors that maximize the number of popped kernels. An initial model was 
created that includes several interactions and quadratic terms. From past studies, there is 
evidence to suggest that there is no quadratic effect for Time and Power, and no interactions 
with Brand. Use the Evaluate Design platform to assess the impact of removing these terms 
from the model.

1. Open the Popcorn DOE Results.jmp sample data table in the Design Experiment folder.

2. Select DOE > Evaluate Design.

3. Assign Brand, Time, and Power to the X, Factor role.

4. Assign Number Popped to the Y, Response role.

5. Click OK.

Note the Model section contains main effects, quadratic terms, and interaction with Brand. 
The results are an assessment of the design relative to fitting the specified model.

6. Repeat steps 2-5.

7. In the Model section, remove the following terms: Power*Power, Time*Time, Brand*Time, 
and Brand*Power.

The results are an assessment of the design relative to fitting the reduced model.

The Fraction of Design Space Plot shows that for almost the entire design space, the reduced 
model has a lower prediction variance than the initial model. See Figure 15.14.

Figure 15.14  Fraction of Design Space

Initial Model Reduced Model
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Open the Power Analysis section in both reports. Figure 15.15 shows the results. For the 
reduced model, the design produces higher power for every effect. The difference is especially 
large for the Time*Power effect.

Figure 15.15  Power Analysis

Open the Design Diagnostics section in both reports. See Figure 15.16. For the reduced model, 
the design produces higher efficiency values, except for G efficiency. The A Efficiency (which 
is related to the variance of the regression coefficients) is a lot larger for the reduced model. 
The average prediction variance for the reduced model is less than half of that for the initial 
model.

Figure 15.16  Design Diagnostics

The assumption is that the quadratic terms of Time and Power and interaction terms with 
Brand are negligible. If this is correct, then using this design to fit the reduced model results in 
predictions with smaller variance, and more powerful effects tests.

Initial Model Reduced Model

Initial Model Reduced Model
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Chapter 16
Augmented Designs

If you treat experimentation as an iterative process, you can master the temptation to assume 
that one successful screening experiment has optimized your process. You can also avoid 
disappointment if a screening experiment leaves behind some ambiguities. The augment 
designer helps facilitate experimentation as an iterative process.

The augment designer modifies an existing design data table, supporting your iterative 
process. It gives the following five choices:

• replicate the design a specified number of times

• add center points

• create a foldover design

• add axial points together with center points to transform a screening design to a response 
surface design

• add runs to the design using a model that can have more terms than the original model

This chapter provides an overview of the augment designer. It also presents a case study of 
design augmentation.



Contents

A D-Optimal Augmentation of the Reactor Example . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 337

Analyze the Augmented Design . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 340

Creating an Augmented Design. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 346

Replicate a Design . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 346

Add Center Points . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 350

Creating a Foldover Design. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 350

Adding Axial Points . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 351

Adding New Runs and Terms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 353

Special Augment Design Commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 356

Save the Design (X) Matrix  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 356

Modify the Design Criterion (D- or I- Optimality)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 357

Select the Number of Random Starts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 357

Specify the Sphere Radius Value . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 357

Disallow Factor Combinations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 357



Chapter 16 Augmented Designs 337
Design of Experiments Guide A D-Optimal Augmentation of the Reactor Example

A D-Optimal Augmentation of the Reactor Example

This example, adapted from Meyer, et al. (1996), demonstrates how to use the augment 
designer in JMP to resolve ambiguities left by a screening design. In this study, a chemical 
engineer investigates the effects of five factors on the percent reaction of a chemical process.

To begin, open Reactor 8 Runs.jmp found in the Design Experiment sample data folder installed 
with JMP. Then select Augment Design from the DOE menu. When the initial launch dialog 
appears:

1. Select Percent Reacted and click Y, Response.

2. Select all other variables except Pattern and click X, Factor.

3. Click OK on the launch dialog to see the Augment Design dialog in Figure 16.1.

Note: You can check Group new runs into separate block to add a blocking factor to any 
design. However, the purpose of this example is to estimate all two-factor interactions in 16 
runs, which can’t be done when there is the additional blocking factor in the model.

Figure 16.1  Augment Design Dialog for the Reactor Example

4. Now click Augment on the Augment Design dialog to see the display in Figure 16.2.

This model shown in Figure 16.2 is the result of the model stored with the data table when it 
was created by the Custom designer. However, the augmented design is to have 16 runs in 
order to estimate all two-factor interactions.
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Figure 16.2  Initial Augmented Model

To continue with the augmented reactor design: 

5. Choose 2nd from the Interactions menu as shown in Figure 16.3. This adds all the 
two-factor interactions to the model. The Minimum number of runs given for the specified 
model is 16, as shown in the Design Generation text edit box.
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Figure 16.3  Augmented Model with All Two-Factor Interactions

6. Click Make Design.

JMP now computes D-optimally augmented factor settings, similar to the design shown in 
Figure 16.4.

Figure 16.4  D-Optimally Augmented Factor Settings

Note: The resulting design is a function of an initial random number seed. To reproduce the 
exact factor settings table in Figure 16.4, (or the most recent design you generated), choose Set 
Random Seed from the popup menu on the Augment Design title bar. A dialog shows the 
most recently used random number. Click OK to use that number again, or Cancel to generate 
a design based on a new random number. The dialog in Figure 16.5 shows the random 
number (12834729) used to generate the runs in Figure 16.4.
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Figure 16.5  Specifying a Random Number

7. Click Make Table to generate the JMP table with D-Optimally augmented runs.

Analyze the Augmented Design

Suppose you have already run the experiment on the augmented data and recorded results in 
the Percent Reacted column of the data table.

1. To see these results, open Reactor Augment Data.jmp found in the Design Experiment 
sample data folder installed with JMP.

It is desirable to maximize Percent Reacted, however its column in this sample data table has a 
response limits column property set to Minimize.

2. Click the asterisk next to the Percent Reacted column name in the Columns panel of the 
data table and select Response Limits, as shown on the left in Figure 16.6.

3. In the Column Info dialog that appears, change the response limit to Maximize, as shown 
on the right in Figure 16.6.

Figure 16.6  Change the Response Limits Column Property for the Percent Reacted Column

You are now ready to run the analysis.

4. To start the analysis, click the red triangle for Model in the upper left of the data table and 
select Run Script from the menu, as shown in Figure 16.7.
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Figure 16.7  Completed Augmented Experiment (Reactor Augment Data.jmp)

The Model script, stored as a table property with the data, contains the JSL commands that 
display the Fit Model dialog with all main effects and two-factor interactions as effects.

5. Change the fitting personality on the Fit Model dialog from Standard Least Squares to 
Stepwise, as shown in Figure 16.8.

Figure 16.8  Fit Model Dialog for Stepwise Regression on Generated Model
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6. When you click Run, the stepwise regression control panel appears. Click the check boxes 
for all the main effect terms.

Note: Choose P-value Threshold from the Stopping Rule menu, Mixed from the Direction 
menu, and make sure Prob to Enter is 0.050 and Prob to Leave is 0.100. These are not the 
default values. Follow the dialog shown in Figure 16.9.

Figure 16.9  Initial Stepwise Model

7. Click Go to start the stepwise regression and watch it continue until all terms are entered 
into the model that meet the Prob to Enter and Prob to Leave criteria in the Stepwise 
Regression Control panel.

Figure 16.10, shows the result of this example analysis. Note that Feed Rate is out of the model 
while the Catalyst*Temperature, Stir Rate*Temperature, and the Temperature*Concentration 
interactions have entered the model.
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Figure 16.10  Completed Stepwise Model

8. After Stepwise is finished, click Make Model on the Stepwise control panel to generate this 
reduced model, as shown in Figure 16.11.

9. Click Run and fit the reduced model to do additional diagnostic work, make predictions, 
and find the optimal factor settings.
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Figure 16.11  New Prediction Model Dialog

The Analysis of Variance and Lack of Fit Tests in Figure 16.12, indicate a highly significant 
regression model with no evidence of Lack of Fit.

Figure 16.12  Prediction Model Analysis of Variance and Lack of Fit Tests

The Sorted Parameter Estimates table in Figure 16.13 shows that Catalyst has the largest main 
effect. However, the significance of the two-factor interactions are of the same order of 
magnitude as the main effects. This is the reason that the initial screening experiment, shown 
in the chapter “Screening Designs” on page 143, had ambiguous results.
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Figure 16.13  Prediction Model Estimates Plot

10. Choose Maximize Desirability from the menu on the Prediction Profiler title bar.

The prediction profile plot in Figure 16.14 shows that maximum occurs at the high levels of 
Catalyst, Stir Rate, and Temperature and the low level of Concentration. At these extreme 
settings, the estimate of Percent Reacted increases from 65.17 to 98.38.

Figure 16.14  Maximum Percent Reacted

To summarize, compare the analysis of 16 runs with the analyses of reactor data from 
previous chapters: 

• “Screening Designs” on page 143, the analysis of a screening design with only 8 runs 
produced a model with the five main effects and two interaction effects with confounding. 
None of the factors effects were significant, although the Catalyst factor was large enough 
to encourage collecting data for further runs.

• “Full Factorial Designs” on page 199, a full factorial of the five two-level reactor factors, 32 
runs, was first subjected to a stepwise regression. This approach identified three main 
effects (Catalyst, Temperature, and Concentration) and two interactions 
(Temperature*Catalyst, Contentration*Temperature) as significant effects.
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• By using a D-optimal augmentation of 8 runs to produce 8 additional runs, a stepwise 
analysis returned the same results as the analysis of 32 runs. The bottom line is that only 
half as many runs yielded the same information. Thus, using an iterative approach to DOE 
can save time and money.

Creating an Augmented Design

The augment designer modifies an existing design data table. It gives the following five 
choices:

Replicate replicates the design a specified number of times. See “Replicate a Design” on 
page 346.

Add Centerpoints adds center points. See “Add Center Points” on page 350.

Fold Over creates a foldover design. See “Creating a Foldover Design” on page 350.

Add Axial adds axial points together with center points to transform a screening design to a 
response surface design. See “Adding Axial Points” on page 351.

Augment adds runs to the design (augment) using a model, which can have more terms than 
the original model. See “Adding New Runs and Terms” on page 353.

Replicate a Design

Replication provides a direct check on the assumption that the error variance is constant. It 
also reduces the variability of the regression coefficients in the presence of large process or 
measurement variability.

To replicate the design a specified number of times:

1. Open a data table that contains a design you want to augment. This example uses Reactor 
8 Runs.jmp from the Design Experiment sample data folder installed with JMP.

2. Select DOE > Augment Design to see the initial dialog for specifying factors and responses.

3. Select Percent Reacted and click Y, Response.

4. Select all other variables (except Pattern) and click X, Factor to identify the factors you 
want to use for the augmented design (Figure 16.15).
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Figure 16.15  Identify Response and Factors

5. Click OK to see the Augment Design panel shown in Figure 16.16.

6. If you want the original runs and the resulting augmented runs to be identified by a 
blocking factor, check the box beside Group New Runs into Separate Block on the 
Augment Design panel.

Figure 16.16  Choose an Augmentation Type

7. Click the Replicate button to see the dialog shown on the left in Figure 16.17. Enter the 
number of times you want JMP to perform each run, then click OK.

Note: Entering 2 specifies that you want each run to appear twice in the resulting design. This 
is the same as one replicate (Figure 16.17).

8. View the design, shown on the right in Figure 16.17.
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Figure 16.17  Reactor Data Design Augmented With Two Replicates

9. In the Design Evaluation section, click the disclosure icons next to Prediction Variance 
Profile and Prediction Variance Surface to see the profile and surface plots shown in 
Figure 16.18.
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Figure 16.18  Prediction Profiler and Surface Plot

10. Click Make Table to produce the design table shown in Figure 16.19.

Figure 16.19  The Replicated Design
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Add Center Points

Adding center points is useful to check for curvature and reduce the prediction error in the 
center of the factor region. Center points are usually replicated points that allow for an 
independent estimate of pure error, which can be used in a lack-of-fit test.

To add center points:

1. Open a data table that contains a design you want to augment. This example uses Reactor 
8 Runs.jmp found in the Design Experiment sample data folder installed with JMP.

2. Select DOE > Augment Design.

3. In the initial Augment Design dialog, identify the response and factors you want to use for 
the augmented design (see Figure 16.15) and click OK.

4. If you want the original runs and the resulting augmented runs to be identified by a 
blocking factor, check the box beside Group new runs into separate block. (Figure 16.16 
shows the check box location directly under the Factors panel.)

5. Click the Add Centerpoints button and type the number of center points you want to add. 
For this example, add two center points, and click OK.

6. Click Make Table to see the data table in Figure 16.20.

The table shows two center points appended to the end of the design.

Figure 16.20  Design with Two Center Points Added

Creating a Foldover Design

A foldover design removes the confounding of two-factor interactions and main effects. This 
is especially useful as a follow-up to saturated or near-saturated fractional factorial or 
Plackett-Burman designs.
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To create a foldover design:

1. Open a data table that contains a design you want to augment. This example uses Reactor 
8 Runs.jmp, found in the Design Experiment sample data folder installed with JMP.

2. Select DOE > Augment Design.

3. In the initial Augment Design dialog, identify the response and factors you want to use for 
the augmented design (see Figure 16.15) and click OK.

4. Check the box to the left of Group new runs into separate block. (Figure 16.16 shows the 
check box location directly under the Factors panel.) This identifies the original runs and 
the resulting augmented runs with a blocking factor.

5. Click the Fold Over button. A dialog appears that lists all the design factors.

6. Choose (select) which factors to fold. The default, if you choose no factors, is to fold on all 
design factors. If you choose a subset of factors to fold over, the remaining factors are 
replicates of the original runs. The example in Figure 16.21 folds on all five factors and 
includes a blocking factor.

7. Click Make Table. The design data table that results lists the original set of runs as block 1 
and the new (foldover) runs are block 2.

Figure 16.21  Listing of a Foldover Design On All Factors 

Adding Axial Points

You can add axial points together with center points, which transforms a screening design to a 
response surface design. To do this:

1. Open a data table that contains a design you want to augment. This example uses Reactor 
8 Runs.jmp, from the Design Experiment sample data folder installed with JMP.

2. Select DOE > Augment Design.



352 Augmented Designs Chapter 16
Creating an Augmented Design Design of Experiments Guide

3. In the initial Augment Design dialog, identify the response and factors you want to use for 
the augmented design (see Figure 16.15) and click OK.

4. If you want the original runs and the resulting augmented runs to be identified by a 
blocking factor, check the box beside Group New Runs into Separate Block (Figure 16.16).

5. Click Add Axial.

6. Enter the axial values in units of the factors scaled from –1 to +1, then enter the number of 
center points you want. When you click OK, the augmented design includes the number of 
center points specified and constructs two axial points for each variable in the original 
design.

Figure 16.22  Entering Axial Values

7. Click Make Table. The design table appears. Figure 16.23 shows a table augmented with 
two center points and two axial points for five variables.

Figure 16.23  Design Augmented With Two Center and Ten Axial Points

center points

axial points
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Adding New Runs and Terms

A powerful use of the augment designer is to add runs using a model that can have more 
terms than the original model. For example, you can achieve the objectives of response surface 
methodology by changing a linear model to a full quadratic model and adding the necessary 
number of runs. Suppose you start with a two-factor, two-level, four-run design. If you add 
quadratic terms to the model and five new points, JMP generates the 3 by 3 full factorial as the 
optimal augmented design.

D-optimal augmentation is a powerful tool for sequential design. Using this feature you can 
add terms to the original model and find optimal new test runs with respect to this expanded 
model. You can also group the two sets of experimental runs into separate blocks, which 
optimally blocks the second set with respect to the first.

To add new runs and terms to the original model:

1. Open a data table that contains a design you want to augment. This example uses Reactor 
Augment Data.jmp, from the Design Experiment sample data folder installed with JMP.

2. Select DOE > Augment Design.

3. In the initial Augment Design dialog, identify the response and factors you want to use for 
the augmented design (see Figure 16.15) and click OK.

4. If you want the original runs and the resulting augmented runs to be identified by a 
blocking factor, check the box beside Group New Runs into Separate Block (not used in this 
example).

5. Click the Augment button. The original number of runs (Figure 16.24) appear in the Factor 
Design panel.
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Figure 16.24  Viewing the Existing Design

6. In the Design Generation panel, enter the number of total runs you want this design to 
contain. The number you enter is the original number of runs plus the number of 
additional runs you want.

7. Click the Make Design button. The new number of runs (Figure 16.25) appear in the 
Design panel.
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Figure 16.25  24 Total Runs

8. If desired, view the prediction variance profile and the prediction variance surface.

9. Click Make Table to create the augmented design JMP table (Figure 16.26) with the 
additional runs.
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Figure 16.26  The Augmented Design Table with New Runs

Special Augment Design Commands

The Augment Design red triangle menu has several options, many of which are commands for 
saving and loading information about variables. They are available in all designs and more 
information is in “Special Custom Design Commands” on page 68. The following sections 
describe commands found in this menu that are specific to augment designs.

Save the Design (X) Matrix

To create a script and save it as a table property in the JMP design data table, click the red 
triangle icon in the Augment Design title bar and select Save X Matrix. Two or three scripts are 
saved to the table. Moments Matrix and Design Matrix scripts are always saved. If the design is 
a split plot design, an additional V Inverse script is also saved. When you run the Moments 
Matrix script, JMP creates a matrix called Moments and displays its number of rows in the log. 
When you run the Design Matrix script, JMP creates a matrix called X and displays its number 
of rows in the log. When you run the V Inverse script, JMP creates the inverse of the variance 
matrix of the responses, and displays its number of rows in the log. If you do not have the log 
visible, select View > Log or Window > Log on the Macintosh.

additional 
runs
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Modify the Design Criterion (D- or I- Optimality)

To modify the design optimality criterion, click the red triangle icon in the Augment Design 
title bar and select Optimality Criterion, then choose Make D-Optimal Design, Make I-Optimal 
Design, or Make Alias Optimal Design. The default criterion for Recommended is D-optimal 
for all design types unless you have used the RSM button in the Model panel to add effects 
that make the model quadratic.

Select the Number of Random Starts

To override the default number of random starts, click the red triangle icon in the Augment 
Design title bar and select Number of Starts. A window appears with an edit box for you to 
enter the number of random starts for the design you want to build. The number you enter 
overrides the default number of starts, which varies depending on the design.

For additional information on the number of starts, see “Why Change the Number of Starts?” 
on page 74.

Specify the Sphere Radius Value

Augment designs can be constrained to a hypersphere. To edit the sphere radius for the 
design in units of the coded factors (–1, 1), click the red triangle icon in the Augment Design 
title bar and select Sphere Radius. Enter the appropriate value and click OK.

Or, use JSL and submit the following command before you build a custom design:

DOE Sphere Radius = 1.0;

In this statement you can replace 1.0 with any positive number.

Disallow Factor Combinations

In addition to linear inequality constraints on continuous factors and constraining a design to 
a hypersphere, you can define general factor constraints on the factors. You can disallow any 
combination of levels of categorical factors if you have not already defined linear inequality 
constraints.

For information on how to do this, see “Disallowed Combinations: Accounting for Factor 
Level Restrictions” on page 76.



358 Augmented Designs Chapter 16
Special Augment Design Commands Design of Experiments Guide



Chapter 17
Prospective Sample Size and Power

Use the DOE > Sample Size and Power command to answer the question “How many runs do 
I need?” The important quantities are sample size, power, and the magnitude of the effect. 
These depend on the significance level, alpha, of the hypothesis test for the effect and the 
standard deviation of the noise in the response. You can supply either one or two of the three 
values. If you supply only one of these values, the result is a plot of the other two. If you 
supply two values, the third value is computed.

The Sample Size and Power platform can answer the question, “Will I detect the group 
differences I am looking for, given my proposed sample size, estimate of within-group 
variance, and alpha level?” In this type of analysis, you must approximate the group means 
and sample sizes in a data table as well as approximate the within-group standard deviation 
(σ).

The sample size and power computations determine the sample size necessary for yielding a 
significant result, given that the true effect size is at least a certain size. It requires that you 
enter two out of three possible quantities; difference to detect, sample size, and power. The 
third quantity is computed for the following cases:

• difference between a one sample mean and a hypothesized value

• difference between two sample means

• differences in the means among k samples

• difference between a standard deviation and a hypothesized value

• difference between a one sample proportion and a hypothesized value

• difference between two sample proportions

• difference between counts per unit in a Poisson-distributed sample and a hypothesized 
value.

The calculations assume that there are equal numbers of units in each group. You can apply 
this platform to more general experimental designs, if they are balanced and an adjustment 
for the number-of-parameters is specified.

You can also compute the required sample sizes needed for reliability studies and 
demonstrations.
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Launching the Sample Size and Power Platform

The Sample Size and Power platform helps you plan your study for a single mean or 
proportion comparison, a two sample mean or proportion comparison, a one-sample standard 
deviation comparison, a k sample means comparison, or a counts per unit comparison. 
Depending upon your experimental situation, you supply one or two quantities to obtain a 
third quantity. These quantities include:

• required sample size

• expected power

• expected effect size

When you select DOE > Sample Size and Power, the panel in Figure 17.1 appears with button 
selections for experimental situations. The following sections describe each of these selections 
and explain how to enter the quantities and obtain the desired computation.

Figure 17.1  Sample Size and Power Choices

 

One-Sample and Two-Sample Means

After you click either One Sample Mean, or Two Sample Means in the initial Sample Size 
selection list (Figure 17.1), a Sample Size and Power window appears. (See Figure 17.2.)
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Figure 17.2  Initial Sample Size and Power Windows for Single Mean (left) and Two Means 
(right)

 

The windows are the same except that the One Mean window has a button at the bottom that 
accesses an animation script.

The initial Sample Size and Power window requires values for Alpha, Std Dev (the error 
standard deviation), and one or two of the other three values: Difference to detect, Sample 
Size, and Power. The Sample Size and Power platform calculates the missing item. If there are 
two unspecified fields, a plot is constructed, showing the relationship between these two 
values:

• power as a function of sample size, given specific effect size

• power as a function of effect size, given a sample size

• effect size as a function of sample size, for a given power.

The Sample Size and Power window asks for these values:

Alpha is the probability of a type I error, which is the probability of rejecting the null 
hypothesis when it is true. It is commonly referred to as the significance level of the test. 
The default alpha level is 0.05. This implies a willingness to accept (if the true difference 
between groups is zero) that, 5% (alpha) of the time, a significant difference is incorrectly 
declared.

Std Dev is the error standard deviation. It is a measure of the unexplained random variation 
around the mean. Even though the true error is not known, the power calculations are an 
exercise in probability that calculates what might happen if the true value is the one you 
specify. An estimate of the error standard deviation could be the root mean square error 
(RMSE) from a previous model fit.
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Extra Parameters is only for multi-factor designs. Leave this field zero in simple cases. In a 
multi-factor balanced design, in addition to fitting the means described in the situation, 
there are other factors with extra parameters that can be specified here. For example, in a 
three-factor two-level design with all three two-factor interactions, the number of extra 
parameters is five. (This includes two parameters for the extra main effects, and three 
parameters for the interactions.) In practice, the particular values entered are not that 
important, unless the experimental range has very few degrees of freedom for error.

Difference to Detect is the smallest detectable difference (how small a difference you want to 
be able to declare statistically significant) to test against. For single sample problems this is 
the difference between the hypothesized value and the true value.

Sample Size is the total number of observations (runs, experimental units, or samples) in 
your experiment. Sample size is not the number per group, but the total over all groups. 

Power is the probability of rejecting the null hypothesis when it is false. A large power value 
is better, but the cost is a higher sample size.

Continue evaluates at the entered values.

Back returns to the previous Sample Size and Power window so that you can either redo an 
analysis or start a new analysis.

Animation Script runs a JSL script that displays an interactive plot showing power or sample 
size. See the section, “Sample Size and Power Animation for One Mean” on page 366, for 
an illustration of the animation script.

Single-Sample Mean

Using the Sample Size and Power window, you can test if one mean is different from the 
hypothesized value.

For the one sample mean, the hypothesis supported is 

and the two-sided alternative is 

where μ is the population mean and μ0 is the null mean to test against or is the difference to 
detect. It is assumed that the population of interest is normally distributed and the true mean 
is zero. Note that the power for this setting is the same as for the power when the null 
hypothesis is H0: μ=0 and the true mean is μ0.

H0: μ μ0=

Ha: μ μ0≠



364 Prospective Sample Size and Power Chapter 17
One-Sample and Two-Sample Means Design of Experiments Guide

Suppose you are interested in testing the flammability of a new fabric being developed by 
your company. Previous testing indicates that the standard deviation for burn times of this 
fabric is 2 seconds. The goal is to detect a difference of 1.5 seconds when alpha is equal to 0.05, 
the sample size is 20, and the standard deviation is 2 seconds. For this example, μ0 is equal to 
1.5. To calculate the power:

1. Select DOE > Sample Size and Power.

2. Click the One Sample Mean button in the Sample Size and Power Window.

3. Leave Alpha as 0.05.

4. Leave Extra Parameters as 0.

5. Enter 2 for Std Dev.

6. Enter 1.5 as Difference to detect.

7. Enter 20 for Sample Size.

8. Leave Power blank. (See the left window in Figure 17.3.)

9. Click Continue.

The power is calculated as 0.8888478174 and is rounded to 0.89. (See right window in 
Figure 17.3.) The conclusion is that your experiment has an 89% chance of detecting a 
significant difference in the burn time, given that your significance level is 0.05, the 
difference to detect is 1.5 seconds, and the sample size is 20.

Figure 17.3  A One-Sample Example

 

Power versus Sample Size Plot

To see a plot of the relationship of Sample Size and Power, leave both Sample Size and Power 
empty in the window and click Continue.
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The plots in Figure 17.4, show a range of sample sizes for which the power varies from about 
0.1 to about 0.95. The plot on the right in Figure 17.4 shows using the crosshair tool to 
illustrate the example in Figure 17.3.

Figure 17.4  A One-Sample Example Plot

 

Power versus Difference Plot

When only Sample Size is specified (Figure 17.5) and Difference to Detect and Power are 
empty, a plot of Power by Difference appears, after clicking Continue.

Figure 17.5  Plot of Power by Difference to Detect for a Given Sample Size
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Sample Size and Power Animation for One Mean

Clicking the Animation Script button on the Sample Size and Power window for one mean 
shows an interactive plot. This plot illustrates the effect that changing the sample size has on 
power. As an example of using the Animation Script:

1. Select DOE > Sample Size and Power.

2. Click the One Sample Mean button in the Sample Size and Power Window.

3. Enter 2 for Std Dev.

4. Enter 1.5 as Difference to detect.

5. Enter 20 for Sample Size.

6. Leave Power blank.

The Sample Size and Power window appears as shown on the left of Figure 17.6.

7. Click Animation Script.

The initial animation plot shows two t-density curves. The red curve shows the 
t-distribution when the true mean is zero. The blue curve shows the t-distribution when 
the true mean is 1.5, which is the difference to be detected. The probability of committing a 
type II error (not detecting a difference when there is a difference) is shaded blue on this 
plot. (This probability is often represented as β in the literature.) Similarly, the probability 
of committing a type I error (deciding that the difference to detect is significant when there 
is no difference) is shaded as the red areas under the red curve. (The red-shaded areas 
under the curve are represented as α in the literature.)

Select and drag the square handles to see the changes in statistics based on the positions of 
the curves. To change the values of Sample Size and Alpha, click on their values beneath 
the plot.
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Figure 17.6  Example of Animation Script to Illustrate Power

Two-Sample Means

The Sample Size and Power windows work similarly for one and two sample means; the 
Difference to Detect is the difference between two means. The comparison is between two 
random samples instead of one sample and a hypothesized mean.

For testing the difference between two means, the hypothesis supported is 

and the two-sided alternative is 

where μ1 and μ2 are the two population means and D0 is the difference in the two means or the 
difference to detect. It is assumed that the populations of interest are normally distributed and 
the true difference is zero. Note that the power for this setting is the same as for the power 
when the null hypothesis is and the true difference is D0.

Suppose the standard deviation is 2 (as before) for both groups, the desired detectable 
difference between the two means is 1.5, and the sample size is 30 (15 per group). To estimate 
the power for this example:

1. Select DOE > Sample Size and Power.

H0: μ1 μ2– D0=

Ha: μ1 μ2– D0≠
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2. Click the Two Sample Means button in the Sample Size and Power Window.

3. Leave Alpha as 0.05.

4. Enter 2 for Std Dev.

5. Leave Extra Parameters as 0.

6. Enter 1.5 as Difference to detect.

7. Enter 30 for Sample Size.

8. Leave Power blank.

9. Click Continue.

The Power is calculated as 0.51. (See the left window in Figure 17.7.) This means that you 
have a 51% chance of detecting a significant difference between the two sample means 
when your significance level is 0.05, the difference to detect is 1.5, and each sample size is 
15.

Plot of Power by Sample Size

To have a greater power requires a larger sample. To find out how large, leave both 
Sample Size and Power blank for this same example and click Continue. Figure 17.7 shows 
the resulting plot, with the crosshair tool estimating that a sample size of about 78 is 
needed to obtain a power of 0.9.

Figure 17.7  Plot of Power by Sample Size to Detect for a Given Difference 
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k-Sample Means

Using the k-Sample Means option, you can compare up to 10 means. Consider a situation 
where 4 levels of means are expected to be in the range of 10 to 13, the standard deviation is 
0.9, and your sample size is 16.

The hypothesis to be tested is:

H0: μ1=μ2=μ3=μ4 versus Ha: at least one mean is different

To determine the power:

1. Select DOE > Sample Size and Power.

2. Click the k Sample Means button in the Sample Size and Power Window.

3. Leave Alpha as 0.05.

4. Enter 0.9 for Std Dev.

5. Leave Extra Parameters as 0.

6. Enter 10, 11, 12, and 13 as the four levels of means.

7. Enter 16 for Sample Size.

8. Leave Power blank.

9. Click Continue.

The Power is calculated as 0.95. (See the left of Figure 17.8.) This means that there is a 95% 
chance of detecting that at least one of the means is different when the significance level is 
0.05, the population means are 10, 11, 12, and 13, and the total sample size is 16.

If both Sample Size and Power are left blank for this example, the sample size and power 
calculations produce the Power versus Sample Size curve. (See the right of Figure 17.8.) 
This confirms that a sample size of 16 looks acceptable.

Notice that the difference in means is 2.236, calculated as square root of the sum of 
squared deviations from the grand mean. In this case it is the square root of (–1.5)2+ 
(–0.5)2+(0.5)2+(1.5)2, which is the square root of 5.
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Figure 17.8  Prospective Power for k-Means and Plot of Power by Sample Size

 

One Sample Standard Deviation

Use the One-Sample Standard Deviation option on the Sample Size and Power window 
(Figure 17.1) to determine the sample size needed for detecting a change in the standard 
deviation of your data. The usual purpose of this option is to compute a large enough sample 
size to guarantee that the risk of a type II error, β, is small. (This is the probability of failing to 
reject the null hypothesis when it is false.) 

In the Sample Size and Power window, specify: 

Alpha is the significance level, usually 0.05. This implies a willingness to accept (if the true 
difference between standard deviation and the hypothesized standard deviation is zero) 
that a significant difference is incorrectly declared 5% of the time.

Hypothesized Standard Deviation is the hypothesized or baseline standard deviation to which 
the sample standard deviation is compared.

Alternative Standard Deviation can select Larger or Smaller from the menu to indicate the 
direction of the change you want to detect.

Difference to Detect is the smallest detectable difference (how small a difference you want to 
be able to declare statistically significant). For single sample problems this is the difference 
between the hypothesized value and the true value.

Sample Size is how many experimental units (runs, or samples) are involved in the 
experiment.
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Power is the probability of declaring a significant result. It is the probability of rejecting the 
null hypothesis when it is false.

In the lower part of the window you enter two of the items and the Sample Size and Power 
calculation determines the third.

Some examples in this chapter use engineering examples from the online manual of The 
National Institute of Standards and Technology (NIST). You can access the NIST manual 
examples at http://www.itl.nist.gov/div898/handbook.

One Sample Standard Deviation Example

One example from the NIST manual states a problem in terms of the variance and difference 
to detect. The variance for resistivity measurements on a lot of silicon wafers is claimed to be 
100 ohm-cm. The buyer is unwilling to accept a shipment if the variance is greater than 155 
ohm-cm for a particular lot (55 ohm-cm above the baseline of 100 ohm-cm).

In the Sample Size and Power window, the One Sample Standard Deviation computations use 
the standard deviation instead of the variance. The hypothesis to be tested is:

H0: σ = σ0, where σ0 is the hypothesized standard deviation. The true standard deviation is 
σ0 plus the difference to detect.

In this example the hypothesized standard deviation, σ0, is 10 (the square root of 100) and σ is 
12.4499 (the square root of 100 + 55 = 155). The difference to detect is 12.4499 – 10 = 2.4499.

You want to detect an increase in the standard deviation of 2.4499 for a standard deviation of 
10, with an alpha of 0.05 and a power of 0.99. To determine the necessary sample size:

1. Select DOE > Sample Size and Power.

2. Click the One Sample Standard Deviation button in the Sample Size and Power Window.

3. Leave Alpha as 0.05.

4. Enter 10 for Hypothesized Standard Deviation.

5. Select Larger for Alternate Standard Deviation.

6. Enter 2.4499 as Difference to Detect.

7. Enter 0.99 for Power.

8. Leave Sample Size blank. (See the left of Figure 17.9.)

9. Click Continue.

The Sample Size is calculated as 171. (See the right of Figure 17.9.) This result is the sample 
size rounded up to the next whole number.

http://www.itl.nist.gov/div898/handbook
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Note: Sometimes you want to detect a change to a smaller standard deviation. If you select 
Smaller from the Alternative Standard Deviation menu, enter a negative amount in the 
Difference to Detect field.

Figure 17.9  Window To Compare Single-Direction One-Sample Standard Deviation

 

One-Sample and Two-Sample Proportions

The Sample Size windows and computations to test sample sizes and power for proportions 
are similar to those for testing means. You enter a true Proportion and choose an Alpha level. 
Then, for the one-sample proportion case, enter the Sample Size and Null Proportion to obtain 
the Power. Or, enter the Power and Null Proportion to obtain the Sample Size. Similarly, to 
obtain a value for Null Proportion, enter values for Sample Size and Power. For the two-sample 
proportion case, either the two sample sizes or the desired Power must be entered. (See 
Figure 17.10 and Figure 17.11.)

The computations to determine sample size and null proportions use exact methods based on 
the binomial distribution. Such methods are more reliable than using the normal 
approximation to the binomial, which can provide erroneous results for small samples or 
proportions close to 0 or 1. 

For a single proportion, results are based on exact power calculations used in conjunction with 
one of the following:

• The “Add two successes and two failures” adjusted Wald test statistic described in Agresti 
and Coull (1998). See also Section 3.3 in the white paper by Barker on the JMP website: 
http://www.jmp.com/blind/whitepapers/wp_jmp_powersample_104887.pdf.

• The Clopper-Pearson exact confidence interval method (Clopper and Pearson, 1934; 
Agresti and Coull, 1998, Section 1)

http://www.jmp.com/blind/whitepapers/wp_jmp_powersample_104887.pdf
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For two proportions, results are based on exact power calculations for the adjusted Wald 
statistic proposed by Agresti and Caffo (2000).

Actual Test Size

The results also show the Actual Test Size. This is the actual Type I error rate for a given 
situation. Since the binomial distribution is discrete, the actual test size can differ significantly 
from the stated Alpha level for small samples or proportions near 0 or 1.

One Sample Proportion

Clicking the One Sample Proportion option on the Sample Size and Power window yields a 
One Proportion window. In this window, you can specify the alpha level and the true 
proportion. The sample size, power, or the hypothesized proportion is calculated. If you 
supply two of these quantities, the third is computed, or if you enter any one of the quantities, 
you see a plot of the other two.

For example, if you have a hypothesized proportion of defects, you can use the One Sample 
Proportion window to estimate a large enough sample size to guarantee that the risk of 
accepting a false hypothesis (β) is small. That is, you want to detect, with reasonable certainty, 
a difference in the proportion of defects.

For the one sample proportion, the hypothesis supported is

and the two-sided alternative is 

where p is the population proportion and p0 is the null proportion to test against. Note that if 
you are interested in testing whether the population proportion is greater than or less than the 
null proportion, you use a one-sided test. The one-sided alternative is either

or

One-Sample Proportion Window Specifications

In the top portion of the Sample Size window, you can specify or enter values for:

Alpha is the significance level of your test. The default value is 0.05.

H0: p p0=

Ha: p p0≠

Ha: p p0<

Ha: p p0>
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Proportion is the true proportion, which could be known or hypothesized. The default value 
is 0.1.

Method is the method to determine the exact confidence interval. Choices are Exact 
Agresti-Coull or Exact Clopper-Pearson. For more details, see “One-Sample and 
Two-Sample Proportions” on page 372. 

One-Sided or Two-Sided Specify either a one-sided or a two-sided test. The default setting is 
the two-sided test.

In the bottom portion of the window, enter two of the following quantities to see the third, 
or a single quantity to see a plot of the other two.

Null Proportion is the proportion to test against (p0) or is left blank for computation. The 
default value is 0.2.

Sample Size is the sample size, or is left blank for computation. If Sample Size is left blank, 
then values for Proportion and Null Proportion must be different.

Power is the desired power, or is left blank for computation.

One-Sample Proportion Example

As an example, suppose that an assembly line has a historical proportion of defects equal to 
0.1, and you want to know the power to detect that the proportion is different from 0.2, given 
an alpha level of 0.05 and a sample size of 100.

1. Select DOE > Sample Size and Power.

2. Click One Sample Proportion.

3. Leave Alpha as 0.05.

4. Leave 0.1 as the value for Proportion.

5. Leave the Method as Exact Agresti-Coull.

6. Accept the default option of Two-Sided. (A one-sided test is selected if you are interested 
in testing if the proportion is either greater than or less than the Null Proportion.)

7. Leave 0.2 as the value for Null Proportion.

8. Enter 100 as the Sample Size.

9. Click Continue.

The Power is calculated and is shown as approximately 0.7 (see Figure 17.10). Note the Actual 
Test Size is 0.0467, which is slightly less than the desired 0.05.



Chapter 17 Prospective Sample Size and Power 375
Design of Experiments Guide One-Sample and Two-Sample Proportions

Figure 17.10  Power and Sample Window for One-Sample Proportions

 

Two Sample Proportions

The Two Sample Proportions option computes the power or sample sizes needed to detect the 
difference between two proportions, p1 and p2.

For the two sample proportion, the hypothesis supported is

and the two-sided alternative is

where p1 and p2 are the population proportions from two populations, and D0 is the 
hypothesized difference in proportions.

The one-sided alternative is either

or

Two Sample Proportion Window Specifications

Specifications for the Two Sample Proportions window include:

Alpha is the significance level of your test. The default value is 0.05.

H0: p1 p2– D0=

Ha: p1 p2– D0≠

Ha: p1 p2–( ) D0<

Ha: p1 p2–( ) D0>
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Proportion 1 is the proportion for population 1, which could be known or hypothesized. The 
default value is 0.5.

Proportion 2 is the proportion for population 2, which could be known or hypothesized. The 
default value is 0.1.

One-Sided or Two-Sided Specify either a one-sided or a two-sided test. The default setting is 
the two-sided test.

Null Difference in Proportion is the proportion difference (D0) to test against, or is left blank 
for computation. The default value is 0.2.

Sample Size 1 is the sample size for population 1, or is left blank for computation.

Sample Size 2 is the sample size for population 2, or is left blank for computation.

Power is the desired power, or is left blank for computation.

If you enter any two of the following three quantities, the third quantity is computed:

• Null Difference in Proportion

• Sample Size 1 and Sample Size 2

• Power 

Example of Determining Sample Sizes with a Two-Sided Test

As an example, suppose you are responsible for two silicon wafer assembly lines. Based on the 
knowledge from many runs, one of the assembly lines has a defect rate of 8%; the other line 
has a defect rate of 6%. You want to know the sample size necessary to have 80% power to 
reject the null hypothesis of equal proportions of defects for each line.

To estimate the necessary sample sizes for this example:

1. Select DOE > Sample Size and Power.

2. Click Two Sample Proportions.

3. Accept the default value of Alpha as 0.05.

4. Enter 0.08 for Proportion 1.

5. Enter 0.06 for Proportion 2.

6. Accept the default option of Two-Sided.

7. Enter 0.0 for Null Difference in Proportion.

8. Enter 0.8 for Power.

9. Leave Sample Size 1 and Sample Size 2 blank.

10. Click Continue.

The Sample Size window shows sample sizes of 2554. (see Figure 17.11.) Testing for a 
one-sided test is conducted similarly. Simply select the One-Sided option.
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Figure 17.11  Difference Between Two Proportions for a Two-Sided Test

 

Example of Determining Power with Two Sample Proportions Using a One-Sided Test

Suppose you want to compare the effectiveness of a two chemical additives. The standard 
additive is known to be 50% effective in preventing cracking in the final product. The new 
additive is assumed to be 60% effective. You plan on conducting a study, randomly assigning 
parts to the two groups. You have 800 parts available to participate in the study (400 parts for 
each additive). Your objective is to determine the power of your test, given a null difference in 
proportions of 0.01 and an alpha level of 0.05. Because you are interested in testing that the 
difference in proportions is greater than 0.01, you use a one-sided test.

1. Select DOE > Sample Size and Power.

2. Click Two Sample Proportions.

3. Accept the default value of Alpha as 0.05.

4. Enter 0.6 for Proportion 1.

5. Enter 0.5 for Proportion 2.

6. Select One-Sided.

7. Enter 0.01 as the Null Difference in Proportion.

8. Enter 400 for Sample Size 1.

9. Enter 400 for Sample Size 2.

10. Leave Power blank.
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11. Click Continue.

Figure 17.12 shows the Two Proportions windows with the estimated Power calculation of 
0.82.

Figure 17.12  Difference Between Two Proportions for a One-Sided Test

You conclude that there is about an 82% chance of rejecting the null hypothesis at the 0.05 
level of significance, given that the sample sizes for the two groups are each 400. Note the 
Actual Test Size is 0.0513, which is slightly larger than the stated 0.05.

Counts per Unit 

You can use the Counts per Unit option from the Sample Size and Power window (Figure 17.1) 
to calculate the sample size needed when you measure more than one defect per unit. A unit 
can be an area and the counts can be fractions or large numbers.

Although the number of defects observed in an area of a given size is often assumed to have a 
Poisson distribution, it is understood that the area and count are large enough to support a 
normal approximation.

Questions of interest are:

• Is the defect density within prescribed limits?

• Is the defect density greater than or less than a prescribed limit?
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In the Counts per Unit window, options include:

Alpha is the significance level of your test. The default value is 0.05.

Baseline Count per Unit is the number of targeted defects per unit. The default value is 0.1.

Difference to detect is the smallest detectable difference to test against and is specified in 
defects per unit, or is left blank for computation.

Sample Size is the sample size, or is left blank for computation.

Power is the desired power, or is left blank for computation.

In the Counts per Unit window, enter Alpha and the Baseline Count per Unit. Then enter two 
of the remaining fields to see the calculation of the third. The test is for a one-sided 
(one-tailed) change. Enter the Difference to Detect in terms of the Baseline Count per Unit 
(defects per unit). The computed sample size is expressed as the number of units, rounded to 
the next whole number.

Counts per Unit Example

As an example, consider a wafer manufacturing process with a target of 4 defects per wafer. 
You want to verify that a new process meets that target within a difference of 1 defect per 
wafer with a significance level of 0.05. In the Counts per Unit window:

1. Leave Alpha as 0.05 (the chance of failing the test if the new process is as good as the 
target).

2. Enter 4 as the Baseline Counts per Unit, indicating the target of 4 defects per wafer.

3. Enter 1 as the Difference to detect.

4. Enter a power of 0.9, which is the chance of detecting a change larger than 1 (5 defects per 
wafer). In this type of situation, alpha is sometimes called the producer’s risk and beta is 
called the consumer’s risk.

5. Click Continue to see the results in Figure 17.13, showing a computed sample size of 38 
(rounded to the next whole number).

The process meets the target if there are less than 190 defects (5 defects per wafer in a sample 
of 38 wafers).
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Figure 17.13  Window For Counts Per Unit Example

Sigma Quality Level

The Sigma Quality Level feature is a simple statistic that puts a given defect rate on a 
“six-sigma” scale. For example, on a scale of one million opportunities, 3.397 defects result in a 
six-sigma process. The computation that gives the Sigma Quality Level statistic is

Sigma Quality Level = NormalQuantile(1 – defects/opportunities) + 1.5

Two of three quantities can be entered to determine the Sigma Quality Level statistic in the 
Sample Size and Power window:

• Number of Defects 

• Number of Opportunities 

• Sigma Quality Level 

When you click Continue, the sigma quality calculator computes the missing quantity.

Sigma Quality Level Example

As an example, use the Sample Size and Power feature to compute the Sigma Quality Level for 
50 defects in 1,000,000 opportunities:

1. Select DOE > Sample Size and Power.

2. Click the Sigma Quality Level button.

3. Enter 50 for the Number of Defects.

4. Enter 1000000 as the Number of Opportunities. (See window to the left in Figure 17.14.) 

5. Click Continue.

The results are a Sigma Quality Level of 5.39. (See right window in Figure 17.14.)
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Figure 17.14  Sigma Quality Level Example 1

 

Number of Defects Computation Example

If you want to know how many defects reduce the Sigma Quality Level to “six-sigma” for 
1,000,000 opportunities:

1. Select DOE > Sample Size and Power.

2. Click the Sigma Quality Level button.

3. Enter 6 as Sigma Quality Level.

4. Enter 1000000 as the Number of Opportunities. (See left window in Figure 17.14.) 

5. Leave Number of Defects blank.

6. Click Continue.

The computation shows that the Number of Defects cannot be more than approximately 
3.4. (See right window in Figure 17.15.)

Figure 17.15  Sigma Quality Level Example 2
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Reliability Test Plan and Demonstration

You can compute required sample sizes for reliability tests and reliability demonstrations 
using the Reliability Test Plan and Reliability Demonstration features.

Reliability Test Plan

The Reliability Test Plan feature computes required sample sizes, censor times, or precision, 
for estimating failure times and failure probabilities.

To launch the Reliability Test Plan calculator, select DOE > Sample Size and Power, and then 
select Reliability Test Plan. Figure 17.16 shows the Reliability Test Plan window.

Figure 17.16  Reliability Test Plan Window
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The Reliability Test Plan window has the following options:

Alpha is the significance level. It is also 1 minus the confidence level.

Distribution is the assumed failure distribution, with the associated parameters.

Precision Measure is the precision measure. In the following definitions, U and L correspond 
to the upper and lower confidence limits of the quantity being estimated (either a time or 
failure probability), and T corresponds to the true time or probability for the specified 
distribution.

Interval Ratio is sqrt(U/L), the square root of the ratio of the upper and lower limits.

Two-sided Interval Absolute Width is U-L, the difference of the upper and lower limits.

Lower One-sided Interval Absolute Width is T-L, the true value minus the lower limit.

Two-sided Interval Relative Width is (U-L)/T, the difference between the upper and lower 
limits, divided by the true value.

Lower One-sided Interval Relative Width is (T-L)/T, the difference between the true value 
and the lower limit, divided by the true value.

Objective is the objective of the study. The objective can be one of the following two:

– estimate the time associated with a specific probability of failure.

– estimate the probability of failure at a specific time.

CDF Plot is a plot of the CDF of the specified distribution. When estimating a time, the true 
time associated with the specified probability is written on the plot. When estimating a 
failure probability, the true probability associated with the specified time is written on the 
plot.

Sample Size is the required number of units to include in the reliability test.

Censor Time is the amount of time to run the reliability test.

Precision is the level of precision. This value corresponds to the Precision Measure chosen 
above.

Large-sample approximate covariance matrix gives the approximate variances and covariance 
for the location and scale parameters of the distribution.

Continue click here to make the calculations.

Back click here to go back to the Power and Sample Size window.

After the Continue button is clicked, two additional statistics are shown:

Expected number of failures is the expected number of failures for the specified 
reliability test.
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Probability of fewer than 3 failures is the probability that the specified reliability test will 
result in fewer than three failures. This is important because a minimum of three failures is 
required to reliably estimate the parameters of the failure distribution. With only one or 
two failures, the estimates are unstable. If this probability is large, you risk not being able 
to achieve enough failures to reliably estimate the distribution parameters, and you should 
consider changing the test plan. Increasing the sample size or censor time are two ways of 
lowering the probability of fewer than three failures.

Example

A company has developed a new product and wants to know the required sample size to 
estimate the time till 20% of units fail, with a two-sided absolute precision of 200 hours. In 
other words, when a confidence interval is created for the estimated time, the difference 
between the upper and lower limits needs to be approximately 200 hours. The company can 
run the experiment for 2500 hours. Additionally, from studies done on similar products, they 
believe the failure distribution to be approximately Weibull (2000, 3).

To compute the required sample size, do the following steps:

1. Select DOE > Sample Size and Power.

2. Select Reliability Test Plan.

3. Select Weibull from the Distribution list.

4. Enter 2000 for the Weibull α parameter.

5. Enter 3 for the Weibull β parameter.

6. Select Two-sided Interval Absolute Width from the Precision Measure list.

7. Select Estimate time associated with specified failure probability.

8. Enter 0.2 for p.

9. Enter 2500 for Censor Time.

10. Enter 200 for Precision.

11. Click Continue. Figure 17.17 shows the results.

Figure 17.17  Reliability Test Plan Results

The required sample size is 217 units if the company wants to estimate the time till 20% 
failures with a precision of 200 hours. The probability of fewer than 3 failures is small, so the 
experiment will likely result in enough failures to reliably estimate the distribution 
parameters.



Chapter 17 Prospective Sample Size and Power 385
Design of Experiments Guide Reliability Test Plan and Demonstration

Reliability Demonstration

A reliability demonstration consists of testing a specified number of units for a specified 
period of time. If fewer than k units fail, you pass the demonstration, and conclude that the 
product reliability meets or exceeds a reliability standard.

The Reliability Demonstration feature computes required sample sizes and experimental 
run-times for demonstrating that a product meets or exceeds a specified reliability standard.

To launch the Reliability Demonstration calculator, select DOE > Sample Size and Power, and 
then select Reliability Demonstration. Figure 17.18 shows the Reliability Demonstration 
window.

Figure 17.18  Reliability Demonstration Window

The Reliability Demonstration window has the following options:

Alpha is the alpha level.

Distribution is the assumed failure distribution. After selecting a distribution, specify the 
associated scale parameter in the text field under the Distribution menu.

Max Failures Tolerated is the maximum number of failures you want to allow during the 
demonstration. If we observe this many failures or fewer, then we say we passed the 
demonstration.

Time is the time component of the reliability standard you want to meet.

Probability of Surviving is the probability component of the reliability standard you want to 
meet.
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Time of Demonstration is the required time for the demonstration.

Number of Units Tested is the required number of units for the demonstration.

Continue click here to make the calculations.

Back click here to go back to the Power and Sample Size window.

After the Continue button is clicked, a plot appears (see Figure 17.19).

Figure 17.19  Reliability Demonstration Plot

The true probability of a unit surviving to the specified time is unknown. The Y axis of the 
plot gives the probability of passing the demonstration (concluding the true reliability meets 
or exceeds the standard) as a function of the true probability of a unit surviving to the 
standard time. Notice the line is increasing, meaning that the further the truth is above the 
standard, the more likely you are to detect the difference.

Example

A company wants to get the required sample size for assessing the reliability of a new product 
against an historical reliability standard of 90% survival after 1000 hours. From prior studies 
on similar products, it is believed that the failure distribution is Weibull, with a β parameter of 
3. The company can afford to run the demonstration for 800 hours, and wants the experiment 
to result in no more than 2 failures.

To compute the required sample size, do the following steps:

1. Select DOE > Sample Size and Power.

2. Select Reliability Demonstration.

3. Select Weibull from the Distribution list.
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4. Enter 3 for the Weibull β.

5. Enter 2 for Max Failures Tolerated.

6. Enter 1000 for Time.

7. Enter 0.9 for Probability of Surviving.

8. Enter 800 for Time of Demonstration.

9. Click Continue. Figure 17.20 shows the results.

Figure 17.20  Reliability Demonstration Results

The company needs to run 118 units in the demonstration. Furthermore, if they observe 2 or 
fewer failures by 800 hours, we can conclude that the new product reliability is at least as 
reliable as the standard.
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ternary plots 228
with nonmixture factors 110

mixture designs
examples 231

mixture experiments (column property) 81
mixture, column properties 81
Model script

Model Specification dialog 172, 186
models

custom design 49
describing 49–50, 214

Monte Carlo simulation 169

N
N factors, adding 47
N Monte Carlo Spheres (nonlinear design 

option) 309
N Responses 45
N Responses button 153
Necessary 50
no-intercept model 81
noise factors 311, 313
nonestimable effect 156
nonlinear design

advanced options 309
augment table 301, 308
create using prior parameter estimates 298
creating 305
creating with no prior data 301
distribution of parameters 302
fitting to find prior parameter estimates 295
introduction 293
launch dialog 298, 306
number of Monte Carlo samples 300
number of starts 300
overlay plot of design points 304
using prior parameter estimates 298

Nonlinear Designs 293–310
advanced options 309
creating 305
examples 295

nonmixture factors in mixture designs 110
Number of Center Points option 52
Number of Monte Carlo Samples (nonlinear 

design option) 309
Number of Replicates option 52
number of runs 43, 51, 87

screening designs 156
number of starts 74

O
On Face option 195
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one-sample and two-sample means (power 
and sample size) 361

one-sample and two-sample proportion 
(power and sample size) 372

one-sample variance (power and sample 
size) 370

opening
JMP Starter window 27

optimal determinant formula 75
optimal subsets (mixture designs) 222
Optimality Criterion 74, 357
optimality criterion 74
order of runs 63, 164, 196, 208, 216, 221, 226
orthogonal array designs 158, 311
orthogonal designs

screening designs 156
screening experiments 211
surface designs 194

Orthogonal option 195
outer arrays, outer designs 311, 313

P
parameters, extra 363
Pattern column 148, 165, 197, 209
patterns, confounding 160
performance statistics 313
Placket-Burman design

creating 165
Plackett-Burman designs 157
Plastifactors.jmp 231
plots

Actual-by-Predicted 175
Scatterplot 3D 192
ternary 211, 228

points
axial 183
center See center points
centroid 221

potential terms (DOE) 99
power and sample size calculations 359–381

analyses 361
animation 366
counts per unit 378
in statistical tests on means 371
k-sample means 369
one-sample and two sample 

proportions 372
one-sample mean 362–363
one-sample variance 370, 373, 375
Sigma quality level 380
two-sample means 367

prediction
profilers 103, 105
traces 188
variances 103, 194

prediction formulas, saving 233
prediction profiler 188
prediction variance profile plot 103
prediction variance surface plot 59
primary terms (Bayesian D-optimal design) 99
profile, discrete choice designs 241
profilers

mixture response surface 234
prediction profilers 105, 188
prediction variance plot 103
prediction Variance profiler 103

properties, columns 79
proportions (power and sample size) 372
prospective power and sample size 359
prospective power and sample size 

calculations (see power and sample 
size) 381

pseudocomponent (mixture column 
property) 81

pure error 350

Q
quadratic model 102–110

R
radius, sphere 76, 357
random block designs 64
random seed, setting 71
random starts 74
Randomize within Blocks 63
randomizing runs 63
range constraints 220
Reaction Kinetics Start.jmp 301–302
Reaction Kinetics.jmp 303
Reactor 8 Runs.jmp 337
Reactor Factors.jmp 201–202
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Reactor Response.jmp 201
regressor columns 158
relative proportions See mixture designs
replicating

designs 347
replicating designs 346
requesting additional runs 52, 164, 196, 208
rescaling designs 195
resolution numbers 156
resolutions of designs 156
response limits, column property 83
Response Surface Designs 183–197

examples 185–191
introduction 192
purpose 183
reports 187
with blocking factors 107
with categorical factors 107

response surface effects 230
Response Surface Methodology (RSM) 192
response surfaces

mixture designs 234
responses

custom designs 45, 153, 193
desirability values 46, 154
goals 45, 153
goals, desirability functions 189
lower limits 46, 154
saving 69
upper limits 46, 154

responses, loading 70
responses, multiple 83
RMSE 175, 205
robust design 120
robust engineering 311
roles, design 84
Rotatable option 195
RSM (Response Surface Methodology) 192
Run Model 171
runs

additional 52, 164, 196, 208
order they appear in table 63, 164, 196, 208, 

216, 221, 226
requesting additional 52, 164, 196, 208
screening designs 156

S
sample means (power and sample size) 361
sample sizes

example comparing single-direction 
one-sample variances 370, 373

example with counts per unit 378
one and two sample means 363
prospective power analysis 370
screening designs 199

saturated designs 52
saving

constraints 70
factors 69
prediction formulas 233
responses 69
X Matrix 72, 356

scaling
axial 194
designs 195

Scatterplot 3D
Box-Behnken designs 192

Scheffé polynomial 229
screening design

Choose Screening Type 155
Design Generation 163
Near Orthogonal designs 163
Number of Starts 163

screening designs 143
custom designs 89
design types 156
dialogs 149, 165
examples 149–196
Number of Column Starts 163

scripts
animation 363
generating the analysis model 172, 186
Model script See Model table property
scripting See JSL

Set Average Cluster Size 227, 272
Set Random Seed command 71
sigma quality level (power and sample 

size) 380
signal factors 311
signal-to-noise ratios 311
simplex 211

centroid designs 215



400 Index
Design of Experiments Guide

lattice designs 218
single-sample means (power and sample 

size) 363
solutions, equivalent 86
Sort Left to Right options 63
Sort Right to Left option 63
Space Filling designs 257–280

borehole problem, sphere packing 
example 276

Cluster Filling 271
Gaussian process IMSE optimal 255, 271
Latin hypercube 255, 261–264
maximum entropy 255, 269
minimum potential 255, 267
Set Average Cluster Size 272
sphere packing 255, 258
uniform 255, 264

Space Filling Mixture designs 226–228
Space Filling Mixture designs, Set Average 

Cluster Size 227
sparsity, effect 145, 157–158
sphere packing design 255, 258
sphere radius 76, 357
split plot designs 48, 65
split-split plot designs 66
star points 183
starts, number of 74
starts, random 74
statistics, performance 313
strip plot designs 67
subsets, finding optimal 222
supersaturated designs 93
surface designs See response surface designs
survey, discrete choice designs 242

T
tables

factors table, creating 70
making in custom designs 63

Taguchi designs 311–317
description 311
methods 311

target values 46, 83, 154
ternary plots 211, 228
three-dimensional scatterplot

Box-Behnken designs 192

tooltips 26
traces, desirability 189
trade-off in screening designs 156
tutorial examples

augment designs 337–346
custom design 29–41
DOE 146
flexible block size 96
full factorial designs 201
mixture designs 231–233
response surface designs 185, 190–191
screening designs 149

tutorials 25
two-level fractional factorials 156
two-level full factorials 156
two-sample and one-sample means 367
two-sample means (power and sample 

size) 361
two-sample proportion (power and sample 

size) 372

U
Uniform (space filling design) 255
uniform (space filling design) 264
uniform precision designs 194
User Defined option 195

V
values

high and low for columns (in DOE) 80
target 46, 154

variance of prediction 195
variance, error and prediction 103
vertices

extreme 220
extreme, finding optimal subsets 222

W-Z
weight, importance of response 45, 69, 83, 153, 

318
Weld-Repaired Castings.jmp 177
whole model test 230
X Matrix, saving 72, 356
XVERT method 225
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