The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.

Marcel Proust
SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to http://support.sas.com/thirdpartylicenses.

**Technology License Notices**

- **Scintilla** - Copyright © 1998-2014 by Neil Hodgson <neilh@scintilla.org>. All Rights Reserved.

  Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation.

  **NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.**

- **Telerik RadControls**: Copyright © 2002-2012, Telerik. Usage of the included Telerik RadControls outside of JMP is not permitted.


- **Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.**

- **Packages** - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved.

  Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

  **THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED**
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• iODBC software - Copyright © 1995-2006, OpenLink Software Inc and Ke Jin (www.iodbc.org). All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
– Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
– Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
– Neither the name of OpenLink Software Inc nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• bzip2, the associated library “libbzip2”, and all documentation, are Copyright © 1996-2010, Julian R Seward. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.
- libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and / or other materials provided with the distribution.
– Neither the name of Florian Reuter nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar licence but with different Copyright notices) all the files are:

Copyright © 1998 - 2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

Regarding the decompression algorithm used for UNIX files:

The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

- Snowball - Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:

- live and recorded webcasts about how to get started with JMP
- video demos and webcasts of new features and advanced techniques
- details on registering for JMP training
- schedules for seminars being held in your area
- success stories showing how others use JMP
- a blog with tips, tricks, and stories from JMP staff
- a forum to discuss JMP with other users

http://www.jmp.com/getstarted/
# Contents

**Profilers**

## 1 Learn about JMP

<table>
<thead>
<tr>
<th>Documentation and Additional Resources</th>
<th>13</th>
</tr>
</thead>
<tbody>
<tr>
<td>Formatting Conventions</td>
<td>14</td>
</tr>
<tr>
<td>JMP Documentation</td>
<td>14</td>
</tr>
<tr>
<td>JMP Documentation Library</td>
<td>15</td>
</tr>
<tr>
<td>JMP Help</td>
<td>21</td>
</tr>
<tr>
<td>Additional Resources for Learning JMP</td>
<td>21</td>
</tr>
<tr>
<td>Tutorials</td>
<td>22</td>
</tr>
<tr>
<td>Sample Data Tables</td>
<td>22</td>
</tr>
<tr>
<td>Learn about Statistical and JSL Terms</td>
<td>22</td>
</tr>
<tr>
<td>Learn JMP Tips and Tricks</td>
<td>22</td>
</tr>
<tr>
<td>Tooltips</td>
<td>23</td>
</tr>
<tr>
<td>JMP User Community</td>
<td>23</td>
</tr>
<tr>
<td>JMPer Cable</td>
<td>23</td>
</tr>
<tr>
<td>JMP Books by Users</td>
<td>23</td>
</tr>
<tr>
<td>The JMP Starter Window</td>
<td>24</td>
</tr>
<tr>
<td>Technical Support</td>
<td>24</td>
</tr>
</tbody>
</table>

## 2 Introduction to Profilers

**Visualize Response Surfaces and Optimize Processes**

<table>
<thead>
<tr>
<th>Profiler Overview</th>
<th>26</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to Profiling</td>
<td>27</td>
</tr>
<tr>
<td>Profiler Features in JMP</td>
<td>27</td>
</tr>
<tr>
<td>Profiler Launch Windows</td>
<td>29</td>
</tr>
<tr>
<td>Fit Group</td>
<td>30</td>
</tr>
<tr>
<td>Interpret the Profiles</td>
<td>30</td>
</tr>
<tr>
<td>Profiler Platform Options</td>
<td>34</td>
</tr>
<tr>
<td>Common Profiler Topics</td>
<td>35</td>
</tr>
<tr>
<td>Linear Constraints</td>
<td>35</td>
</tr>
<tr>
<td>Noise Factors</td>
<td>37</td>
</tr>
</tbody>
</table>

## 3 Profiler

**Explore Cross Sections of Responses across Each Factor**

<table>
<thead>
<tr>
<th>Example of the Prediction Profiler</th>
<th>40</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the Prediction Profiler Platform</td>
<td>41</td>
</tr>
</tbody>
</table>
4 Contour Profiler
Explore Contours of Responses across Two Factors

5 Surface Plot
Explore Contours of Responses across Three Factors
6 Mixture Profiler
 Explore Factor Effects Using Ternary Plots

Mixture Profiler Overview .................................................. 106
Example of the Mixture Profiler ............................................. 107
Launch the Mixture Profiler Platform ................................. 109
The Mixture Profiler Report .................................................. 109
  Factor Settings and Controls ............................................ 109
  Response Settings and Controls ......................................... 110
Explanation of Ternary Plot Axes ......................................... 110
  More Than Three Mixture Factors ....................................... 111
Mixture Profiler Platform Options ....................................... 112
  Customizations for the Mixture Profiler ............................ 113
Linear Constraints ............................................................ 113
Additional Examples of the Mixture Profiler Platform ............. 114
  Single Response .......................................................... 114
  Multiple Responses ....................................................... 118

7 Custom Profiler
 Explore Response Surfaces Using a Numerical Calculator

Custom Profiler Overview .................................................. 124
Example of the Custom Profiler ............................................. 124
Launch the Custom Profiler Platform ................................. 126
The Custom Profiler Report .................................................. 126
  Factor Settings and Controls ............................................ 126
  Response Settings and Controls ......................................... 127
Optimization Settings and Controls ..................................... 127
Custom Profiler Platform Options ....................................... 128

8 Simulator
 Explore the Effects of Variation on Responses

Simulator Overview .......................................................... 130
Example of the Simulator ................................................... 132
Specify Factors .............................................................. 134
Simulator Report Options ................................................... 136
  Responses Report Options ................................................ 137
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simulate to Table Report Options</td>
<td>137</td>
</tr>
<tr>
<td>Spec Limits Report Options</td>
<td>137</td>
</tr>
<tr>
<td>Specification Limits</td>
<td>137</td>
</tr>
<tr>
<td>Simulate General Formulas</td>
<td>139</td>
</tr>
<tr>
<td>Defect Profiler</td>
<td>142</td>
</tr>
<tr>
<td>About Tolerance Design</td>
<td>143</td>
</tr>
<tr>
<td>Graph Scale</td>
<td>144</td>
</tr>
<tr>
<td>Expected Defects</td>
<td>144</td>
</tr>
<tr>
<td>Simulation Method and Details</td>
<td>145</td>
</tr>
<tr>
<td>Notes</td>
<td>145</td>
</tr>
<tr>
<td>Simulation Experiment</td>
<td>145</td>
</tr>
<tr>
<td>Additional Examples of the Simulator</td>
<td>146</td>
</tr>
<tr>
<td>Example of the Defect Profiler</td>
<td>146</td>
</tr>
<tr>
<td>Example of Stochastic Optimization</td>
<td>150</td>
</tr>
<tr>
<td>Statistical Details for the Simulator</td>
<td>159</td>
</tr>
<tr>
<td>Normal Weighted Distribution</td>
<td>159</td>
</tr>
</tbody>
</table>

9 Excel Profiler

Visualize Models Saved in Microsoft Excel                                  161

Excel Profiler Overview                                                   162
Example of an Excel Model                                                 162
Run the JMP Profiler                                                      164
Use Linear Constraints                                                    165
Resolution of Profile Lines                                               165
Use the Excel Profiler from JMP                                           166

A References

Index

Profilers                                                                169
Chapter 1

Learn about JMP
Documentation and Additional Resources

This chapter includes the following information:

- book conventions
- JMP documentation
- JMP Help
- additional resources, such as the following:
  - other JMP documentation
  - tutorials
  - indexes
  - Web resources
  - technical support options
Formatting Conventions

The following conventions help you relate written material to information that you see on your screen.

- Sample data table names, column names, pathnames, filenames, file extensions, and folders appear in *Helvetica* font.
- Code appears in *Lucida Sans Typewriter* font.
- Code output appears in *Lucida Sans Typewriter* italic font and is indented farther than the preceding code.
- **Helvetica bold** formatting indicates items that you select to complete a task:
  - buttons
  - check boxes
  - commands
  - list names that are selectable
  - menus
  - options
  - tab names
  - text boxes
- The following items appear in italics:
  - words or phrases that are important or have definitions specific to JMP
  - book titles
  - variables
  - script output
- Features that are for JMP Pro only are noted with the JMP Pro icon. For an overview of JMP Pro features, visit [http://www.jmp.com/software/pro/](http://www.jmp.com/software/pro/).

**Note:** Special information and limitations appear within a Note.

**Tip:** Helpful information appears within a Tip.

**JMP Documentation**

JMP offers documentation in various formats, from print books and Portable Document Format (PDF) to electronic books (e-books).
Open the PDF versions from the Help > Books menu.

All books are also combined into one PDF file, called JMP Documentation Library, for convenient searching. Open the JMP Documentation Library PDF file from the Help > Books menu.

You can also purchase printed documentation and e-books on the SAS website: http://www.sas.com/store/search.ep?keyWords=JMP

### JMP Documentation Library

The following table describes the purpose and content of each book in the JMP library.

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Discovering JMP</em></td>
<td>If you are not familiar with JMP, start here.</td>
<td>Introduces you to JMP and gets you started creating and analyzing data.</td>
</tr>
<tr>
<td><em>Using JMP</em></td>
<td>Learn about JMP data tables and how to perform basic operations.</td>
<td>Covers general JMP concepts and features that span across all of JMP, including importing data, modifying columns properties, sorting data, and connecting to SAS.</td>
</tr>
</tbody>
</table>
| *Basic Analysis* | Perform basic analysis using this document. | Describes these Analyze menu platforms:  
  - Distribution  
  - Fit Y by X  
  - Tabulate  
  - Text Explorer  
Covers how to perform bivariate, one-way ANOVA, and contingency analyses through Analyze > Fit Y by X. How to approximate sampling distributions using bootstrapping and how to perform parametric resampling with the Simulate platform are also included. |
<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Essential Graphing</em></td>
<td>Find the ideal graph for your data.</td>
<td>Describes these Graph menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Graph Builder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Overlay Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scatterplot 3D</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Contour Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bubble Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Parallel Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cell Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Treemap</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scatterplot Matrix</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ternary Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Chart</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The book also covers how to create background and custom maps.</td>
</tr>
<tr>
<td><em>Profilers</em></td>
<td>Learn how to use interactive profiling tools, which enable you to view cross-sections of any response surface.</td>
<td>Covers all profilers listed in the Graph menu. Analyzing noise factors is included along with running simulations using random inputs.</td>
</tr>
<tr>
<td><em>Design of Experiments Guide</em></td>
<td>Learn how to design experiments and determine appropriate sample sizes.</td>
<td>Covers all topics in the DOE menu and the Specialized DOE Models menu item in the Analyze &gt; Specialized Modeling menu.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>-----------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Fitting Linear Models</td>
<td>Learn about Fit Model platform and many of its personalities.</td>
<td>Describes these personalities, all available within the Analyze menu Fit Model platform:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Standard Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Stepwise</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Regression</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Mixed Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MANOVA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Loglinear Variance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nominal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ordinal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Linear Model</td>
</tr>
</tbody>
</table>


<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Predictive and Specialized Modeling</td>
<td>Learn about additional modeling techniques.</td>
<td>Describes these Analyze &gt; Predictive Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Modeling Utilities</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Neural</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bootstrap Forest</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Boosted Tree</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Nearest Neighbors</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Naive Bayes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Model Comparison</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Formula Depot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Specialized Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Curve</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nonlinear</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Gaussian Process</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Time Series</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Matched Pairs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Screening menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Response Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Predictor Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Association Analysis</td>
</tr>
<tr>
<td>The platforms in the Analyze &gt; Specialized Modeling &gt; Specialized DOE Models menu are described in Design of Experiments Guide.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Multivariate Methods</td>
<td>Read about techniques for analyzing several variables simultaneously.</td>
<td>Describes these Analyze &gt; Multivariate Methods menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multivariate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Principal Components</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Discriminant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partial Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Clustering menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Hierarchical Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Means Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Normal Mixtures</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latent Class Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cluster Variables</td>
</tr>
<tr>
<td>Quality and Process Methods</td>
<td>Read about tools for evaluating and improving processes.</td>
<td>Describes these Analyze &gt; Quality and Process menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Control Chart Builder and individual control charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Measurement Systems Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Variability / Attribute Gauge Charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process Capability</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Pareto Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Diagram</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Reliability and Survival       | Learn to evaluate and improve reliability in a product or system and analyze survival data for people and products. | Describes these Analyze > Reliability and Survival menu platforms:  
  - Life Distribution  
  - Fit Life by X  
  - Cumulative Damage  
  - Recurrence Analysis  
  - Degradation and Destructive Degradation  
  - Reliability Forecast  
  - Reliability Growth  
  - Reliability Block Diagram  
  - Repairable Systems Simulation  
  - Survival  
  - Fit Parametric Survival  
  - Fit Proportional Hazards |
| Survival Methods               |                                                                                   |                                                                                                                                                   |
| Consumer Research              | Learn about methods for studying consumer preferences and using that insight to create better products and services. | Describes these Analyze > Consumer Research menu platforms:  
  - Categorical  
  - Multiple Correspondence Analysis  
  - Multidimensional Scaling  
  - Factor Analysis  
  - Choice  
  - MaxDiff  
  - Uplift  
  - Item Analysis |
| Scripting Guide                | Learn about taking advantage of the powerful JMP Scripting Language (JSL).        | Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications. |
Chapter 1
Profilers

Learn about JMP

Additional Resources for Learning JMP

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>JSL Syntax Reference</td>
<td>Read about many JSL functions on functions and their arguments, and messages that you send to objects and display boxes.</td>
<td>Includes syntax, examples, and notes for JSL commands.</td>
</tr>
</tbody>
</table>

**Note:** The Books menu also contains two reference cards that can be printed: The Menu Card describes JMP menus, and the Quick Reference describes JMP keyboard shortcuts.

**JMP Help**

JMP Help is an abbreviated version of the documentation library that provides targeted information. You can open JMP Help in several ways:

- On Windows, press the F1 key to open the Help system window.
- Get help on a specific part of a data table or report window. Select the Help tool ? from the Tools menu and then click anywhere in a data table or report window to see the Help for that area.
- Within a JMP window, click the Help button.
- Search the Help at http://jmp.com/support/help/ (English only).

**Additional Resources for Learning JMP**

In addition to JMP documentation and JMP Help, you can also learn about JMP using the following resources:

- Tutorials (see “Tutorials” on page 22)
- Sample data (see “Sample Data Tables” on page 22)
- Indexes (see “Learn about Statistical and JSL Terms” on page 22)
- Tip of the Day (see “Learn JMP Tips and Tricks” on page 22)
- Web resources (see “JMP User Community” on page 23)
- JMPPer Cable technical publication (see “JMPPer Cable” on page 23)
- Books about JMP (see “JMP Books by Users” on page 23)
- JMP Starter (see “The JMP Starter Window” on page 24)
Learn about JMP

Additional Resources for Learning JMP

- Teaching Resources (see “Sample Data Tables” on page 22)

Tutorials

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, then start with the Beginners Tutorial. It steps you through the JMP interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment and comparing a sample mean to a constant.

Sample Data Tables

All of the examples in the JMP documentation suite use sample data. Select Help > Sample Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories, select Help > Sample Data.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\JMP\13\Samples\Data
On Macintosh: \Library\Application Support\JMP\13\Samples\Data

In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory. In JMP Shrinkwrap, sample data is installed in the JMP SW directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching Resources section. To learn more about the teaching resources, visit http://jmp.com/tools.

Learn about Statistical and JSL Terms

The Help menu contains the following indexes:

Statistics Index  Provides definitions of statistical terms.

Scripting Index  Lets you search for information about JSL functions, objects, and display boxes. You can also edit and run sample scripts from the Scripting Index.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for using JMP.
To turn off the Tip of the Day, clear the **Show tips at startup** check box. To view it again, select **Help > Tip of the Day**. Or, you can turn it off using the Preferences window. See the *Using JMP* book for details.

**Tooltips**

JMP provides descriptive tooltips when you place your cursor over items, such as the following:

- Menu or toolbar options
- Labels in graphs
- Text results in the report window (move your cursor in a circle to reveal)
- Files or windows in the Home Window
- Code in the Script Editor

**Tip:** On Windows, you can hide tooltips in the JMP Preferences. Select **File > Preferences > General** and then deselect **Show menu tips**. This option is not available on Macintosh.

**JMP User Community**

The JMP User Community provides a range of options to help you learn more about JMP and connect with other JMP users. The learning library of one-page guides, tutorials, and demos is a good place to start. And you can continue your education by registering for a variety of JMP training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, and social networking groups.

To access JMP resources on the website, select **Help > JMP User Community** or visit [https://community.jmp.com/](https://community.jmp.com/).

**JMPer Cable**

The JMPer Cable is a yearly technical publication targeted to users of JMP. The JMPer Cable is available on the JMP website:

[http://wwwjmp.com/about/newsletters/jmpercable/](http://wwwjmp.com/about/newsletters/jmpercable/)

**JMP Books by Users**

Additional books about using JMP that are written by JMP users are available on the JMP website:

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus. The window also lists JMP Pro features and platforms.

- To open the JMP Starter window, select View (Window on the Macintosh) > JMP Starter.
- To display the JMP Starter automatically when you open JMP on Windows, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list. On Macintosh, select JMP > Preferences > Initial JMP Starter Window.

Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP, many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at http://www.jmp.com/support, including the technical support phone number.
Profiling is an approach to visualizing response surfaces by seeing what would happen if you change just one or two factors at a time. Essentially, a profile is a cross-section view. The interactive profilers in JMP promote exploring opportunity spaces. In fitting equations to data, the fitting is only the first step. Interpreting the fit, understanding the fitted response surface, and finding factor values to optimize the responses is desirable.

Figure 2.1 Examples of Profilers
Profiler Overview

Note: For details about the profilers in the Destructive Degradation platform, see the Destructive Degradation chapter in the Reliability and Survival Methods book.

The Profiler displays profile traces (see Figure 2.2) for each X variable. A profile trace is the predicted response as one variable is changed while the others are held constant at the current values. The Profiler recomputes the profiles and predicted responses (in real time) as you vary the value of an X variable.

- The vertical dotted line for each X variable shows its current value or current setting. If the variable is nominal, the x-axis identifies categories.
  
  For each X variable, the value above the factor name is its current value. You change the current value by clicking in the graph or by dragging the dotted line where you want the new current value to be.

- The horizontal dotted line shows the current predicted value of each Y variable for the current values of the X variables.

- The black lines within the plots show how the predicted value changes when you change the current value of an individual X variable. In fitting platforms, the 95% confidence interval for the predicted values is shown by solid blue curves surrounding the prediction trace (for continuous variables) or the height of an error bar (for categorical variables). For continuous variables, the confidence interval region is shaded.

The Profiler is a way of changing one variable at a time and looking at the effect on the predicted response.

Figure 2.2 Illustration of Traces

The Profiler in some situations computes confidence intervals for each profiled column. If you have saved both a standard error formula and a prediction formula for the same column, the
Profiler offers to use the standard errors to produce the confidence intervals rather than profiling them as a separate column.

### Introduction to Profiling

It is easy to visualize a response surface with one input factor $X$ and one output factor $Y$. It becomes harder as more factors and responses are added. The profilers in JMP provide a number of highly interactive cross-sectional views of any response surface.

Desirability profiling and optimization features are available to help find good factor settings and produce desirable responses. Most profilers also incorporate multithreading for faster computation. Simulation and defect profiling features are available for when you need to make responses that are robust and high-quality when the factors have variation.

### Profiler Features in JMP

There are several profiler facilities in JMP, accessible from a number of fitting platforms and the main menu under Graph. They are used to profile data column formulas.

#### Table 2.1  Profiler Features Summary

<table>
<thead>
<tr>
<th>Description</th>
<th>Features</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Profiler (or Prediction Profiler)</strong></td>
<td>Shows vertical slices across each factor, holding other factors at current values</td>
</tr>
<tr>
<td><strong>Contour Profiler</strong></td>
<td>Horizontal slices show contour lines for two factors at a time</td>
</tr>
<tr>
<td><strong>Surface Profiler</strong></td>
<td>3-D plots of responses for 2 factors at a time, or a contour surface plot for 3 factors at a time</td>
</tr>
<tr>
<td><strong>Mixture Profiler</strong></td>
<td>A contour profiler for mixture factors</td>
</tr>
<tr>
<td><strong>Custom Profiler</strong></td>
<td>A non-graphical profiler and numerical optimizer</td>
</tr>
<tr>
<td><strong>Excel Profiler</strong></td>
<td>Visualize models (or formulas) stored in Excel worksheets.</td>
</tr>
</tbody>
</table>

Profiler availability is shown in Table 2.2. The Custom Profiler is available only through the Graph menu. (Model Comparison *does* have Custom Profiler available.)
Table 2.2 Where to Find JMP Profilers

<table>
<thead>
<tr>
<th>Location</th>
<th>Profiler</th>
<th>Contour Profiler</th>
<th>Surface Profiler</th>
<th>Mixture Profiler</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graph Menu (as a Platform)</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Fit Model: Least Squares</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Fit Model: Generalized Regression</td>
<td>Yes</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fit Model: Mixed Model</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Fit Model: Logistic</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fit Model: Loglinear Variance</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fit Model: Generalized Linear Model</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fit Model: Partial Least Squares</td>
<td>Yes</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Neural</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Model Comparison</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Nonlinear: Factors and Response</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nonlinear: Parameters and SSE</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nonlinear: Fit Curve</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gaussian Process</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Partial Least Squares</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Life Distribution</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fit Life by X</td>
<td>Yes</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Recurrence Analysis</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Choice</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Custom Design Prediction Variance</td>
<td>Yes</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Note:** In this guide, we use the following terms interchangeably:

- factor, input variable, X column, independent variable, setting, term(?)
- response, output variable, Y column, dependent variable, outcome

The Profiler (with a capital P) is one of several profilers (lowercase p). Sometimes, to distinguish the Profiler from other profilers, we call it the Prediction Profiler.
Profiler Launch Windows

When a profiler is invoked as a platform from the Graph menu, rather than through a fitting platform, you provide columns with formulas as the Y, Prediction Formula columns. These formulas could have been saved from the fitting platforms.

Figure 2.3 shows an example of most Profiler launch windows.

Figure 2.3  Profiler Launch Window

The columns referenced in the formulas become the X columns (unless the column is also a Y).

Y, Prediction Formula  The response columns containing formulas.

Noise Factors  Only used in special cases for modeling derivatives. For more information, about noise factors, see “Noise Factors” on page 37.

Expand Intermediate Formulas  Tells JMP that if an ingredient column to a formula is a column that itself has a formula, to substitute the inner formula, as long as it refers to other columns. To prevent an ingredient column from expanding, add an Other column property, name it Expand Formula, and assign a value of 0. For more information, see “Expand Intermediate Formulas”.

The Surface Plot platform is discussed in the Surface Plot chapter. The Surface Profiler is very similar to the Surface Plot platform, except Surface Plot has more modes of operation. Neither the Surface Plot platform nor the Surface Profiler have some of the capabilities common to other profilers.

Expand Intermediate Formulas

The Profiler launch window has an Expand Intermediate Formulas check box. When this is checked, when the formula is examined for profiling, if it references another column that has a formula containing references to other columns, then it substitutes that formula and profiles with respect to the end references—not the intermediate column references.
For example, when Fit Model fits a logistic regression for two levels (say A and B), the end formulas (Prob[A] and Prob[B]) are functions of the Lin[x] column, which itself is a function of another column x. If Expand Intermediate Formulas is selected, then when Prob[A] is profiled, it is with reference to x, not Lin[x].

In addition, using the Expand Intermediate Formulas check box enables the Save Expanded Formulas command in the platform red triangle menu. This creates a new column with a formula, which is the formula being profiled as a function of the end columns, not the intermediate columns.

**Fit Group**

For the REML and Stepwise personalities of the Fit Model platform, if models are fit to multiple Y’s, the results are combined into a Fit Group report. This enables the different Y’s to be profiled in the same Profiler. The Fit Group red triangle menu has options for launching the joint Profiler. Profilers for the individual Y’s can still be used in the respective Fit Model reports.

Fit Group reports are also created when a By variable is specified for a Stepwise analysis. This allows for the separate models to be profiled in the same Profiler.

The Fit Group scripting command can be used to fit models in different platforms, and have the individual models profiled in the Profiler. For more details, see the JMP Platforms chapter in the *Scripting Guide*.

**Interpret the Profiles**

The illustration in Figure 2.4 describes how to use the components of the Profiler. There are several important points to note when interpreting a prediction profile:

- The importance of a factor can be assessed to some extent by the steepness of the prediction trace. If the model has curvature terms (such as squared terms), then the traces might be curved.
- If you change the value of a factor, the prediction trace for that factor is not affected, but the prediction traces of all the other factors can change. The Y response line must cross the intersection points of the prediction traces with their current value lines.

**Note:** If there are interaction effects or cross-product effects in the model, the prediction traces can shift their slope and curvature as you change current values of other terms. That is what interaction is all about. If there are no interaction effects, the traces only change in height, not slope or shape.
Prediction profiles are especially useful in multiple-response models to help judge that factor values can optimize a complex set of criteria.

Click a graph or drag the current value line right or left to change the factor’s current value. The response values change as shown by a horizontal reference line in the body of the graph. Double-click in an axis to bring up a window that changes its settings.

**The Profiler as a Cross-Section**

In the following example using Tiretread.jmp, look at the response surface of the expression for MODULUS as a function of SULFUR and SILANE (holding SILICA constant). Now look at how a grid that cuts across SILANE at the SULFUR value of 2.25. Note how the slice intersects the surface. If you transfer that down below, it becomes the profile for SILANE. Similarly, note the grid across SULFUR at the SILANE value of 50. The intersection when transferred down to the SULFUR graph becomes the profile for SULFUR.
Now consider changing the current value of SULFUR from 2.25 to 1.5.
In the Profiler, note the new value just moves along the same curve for SULFUR, the SULFUR curve itself does not change. But the profile for SILANE is now taken at a different cut for SULFUR. The profile for SILANE is also a little higher and reaches its peak in the different place, closer to the current SILANE value of 50.

**Set or Lock Factor Values**

If you ALT-click (Option-click on the Macintosh) in a graph, a window prompts you to enter specific settings for the factor.

**Figure 2.7 Continuous Factor Settings Window**
For continuous variables, you can specify:

**Current Value**  The value used to calculate displayed values in the profiler, equivalent to the red vertical line in the graph.

**Minimum Setting**  The minimum value of the factor’s axis.

**Maximum Value**  The maximum value of the factor’s axis.

**Number of Plotted Points**  Specifies the number of points used in plotting the factor’s prediction traces.

**Show**  Show or hide the factor in the profiler.

**Lock Factor Setting**  Locks the value of the factor at its current setting.

---

### Profiler Platform Options

The red triangle menu on the Profiler title bar has the following options:

**Profiler**  Shows or hides the Profiler.

**Contour Profiler**  Shows or hides the Contour Profiler.

**Custom Profiler**  Shows or hides the Custom Profiler.

**Surface Profiler**  Shows or hides the Surface Profiler.

**Mixture Profiler**  Shows or hides the Mixture Profiler.

**Save for Adobe Flash Platform (.SWF)**  Enables you to save the Profiler (with reduced functionality) as an Adobe Flash file, which can be imported into presentation and web applications. An HTML page can be saved for viewing the Profiler in a browser. The Save for Adobe Flash platform (SWF) command is not available for categorical responses. For more information about this option, go to [http://www.jmp.com/support/swfhelp/](http://www.jmp.com/support/swfhelp/).

The Profiler accepts any JMP function, but the Flash Profiler only accepts the following functions: Add, Subtract, Multiply, Divide, Minus, Power, Root, Sqrt, Abs, Floor, Ceiling, Min, Max, Equal, Not Equal, Greater, Less, GreaterEqual, LessorEqual, Or, And, Not, Exp, Log, Log10, Sine, Cosine, Tangent, SinH, CosH, TanH, ArcSine, ArcCosine, ArcTangent, ArcSineH, ArcCosH, ArcTanH, Squish, If, Match, Choose.

**Note:** Some platforms create column formulas that are not supported by the Save As Flash option.

**Show Formulas**  Opens a JSL window showing all formulas being profiled.

**Formulas for OPTMODEL**  Creates code for the OPTMODEL SAS procedure. Hold down CTRL and SHIFT and then select Formulas for OPTMODEL from the red triangle menu.
The following options are available in many platforms. See the JMP Reports chapter in the *Using JMP* book for more information.

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

---

**Common Profiler Topics**

This section contains information on features that are common to more than one of the profiler platforms.

**Linear Constraints**

The Prediction Profiler, Custom Profiler, and Mixture Profiler can incorporate linear constraints into their operations. Linear constraints can be entered in two ways, described in the following sections.

**Red Triangle Menu Item**

To enter linear constraints via the red triangle menu, select *Alter Linear Constraints* from either the Prediction Profiler or Custom Profiler red triangle menu.

Choose *Add Constraint* from the resulting window, and enter the coefficients into the appropriate boxes. For example, to enter the constraint $p_1 + 2p_2 \geq 0.9$, enter the coefficients as shown in Figure 2.8. As shown, if you are profiling factors from a mixture design, the mixture constraint is present by default and cannot be modified.

**Figure 2.8 Enter Coefficients**

![Image of the Add Constraint window](image)

After you click **OK**, the Profiler updates the profile traces, and the constraint is incorporated into subsequent analyses and optimizations.

If you attempt to add a constraint for which there is no feasible solution, a message is written to the log and the constraint is not added. To delete a constraint, enter zeros for all the coefficients.
Constraints added in one profiler are not accessible by other profilers until saved. For example, if constraints are added under the Prediction Profiler, they are not accessible to the Custom Profiler. To use the constraint, you can either add it under the Custom Profiler red triangle menu, or use the **Save Linear Constraints** command described in the next section.

**Constraint Table Property/Script**

If you add constraints in one profiler and want to make them accessible by other profilers, use the **Save Linear Constraints** command, accessible through the platform red triangle menu. For example, if you created constraints in the Prediction Profiler, choose **Save Linear Constraints** under the Prediction Profiler red triangle menu. The Save Linear Constraints command creates or alters a Table Script called Constraint. An example of the Table Property is shown in Figure 2.9.

**Figure 2.9** Constraint Table Script

![Constraint Table Script](image)

The Constraint Table Property is a list of the constraints, and is editable. It is accessible to other profilers, and negates the need to enter the constraints in other profilers. To view or edit Constraint, right-click the red triangle menu and select **Edit**. The content of the constraint from Figure 2.8 is shown below in Figure 2.10.

**Figure 2.10** Example Constraint

![Example Constraint](image)

The Constraint Table Script can be created manually by choosing **New Script** from the red triangle menu beside a table name.

**Note:** When creating the Constraint Table Script manually, the spelling must be exactly “Constraint”. Also, the constraint variables are case sensitive and must match the column name. For example, in Figure 2.10, the constraint variables are p1 and p2, not P1 and P2.

The Constraint Table Script is also created when specifying linear constraints when designing an experiment.
The Alter Linear Constraints and Save Linear Constraints commands are not available in the Mixture Profiler. To incorporate linear constraints into the operations of the Mixture Profiler, the Constraint Table Script must be created by one of the methods discussed in this section.

**Noise Factors**

**Note:** Noise factor optimization is also available in the Prediction Profiler, Contour Profiler, Custom Profiler, and Mixture Profiler.

Robust process engineering enables you to produce acceptable products reliably, despite variation in the process variables. Even when your experiment has controllable factors, there is a certain amount of uncontrollable variation in the factors that affects the response. This is called transmitted variation. Factors with this variation are called noise factors. Some factors you cannot control at all, like environmental noise factors. The mean for some factors can be controlled, but not their standard deviation is not controllable. This is often the case for intermediate factors that are output from a different process or manufacturing step.

A good approach to making the process robust is to match the target at the flattest place of the noise response surface. Then, the noise has little influence on the process. Mathematically, this is the value where the first derivatives of each response with respect to each noise factor are zero. JMP computes the derivatives for you.

**Figure 2.11** Noise Factor Example

Noise factors (robust process engineering) enables you to produce acceptable products reliably, despite variation in the process variables. Even when your experiment has
controllable factors, there is a certain amount of uncontrollable variation in the factors that affects the response. This is called transmitted variation. Factors with this variation are called noise factors. You cannot control some factors, like environmental noise factors. The mean for some factors can be controlled, but their standard deviation is uncontrollable. This is often the case for intermediate factors that are output from a different process or manufacturing step.

A good approach to making the process robust is to match the target at the flattest place of the noise response surface. Then, the noise has little influence on the process. Mathematically, this is the value where the first derivatives of each response with respect to each noise factor are zero. JMP computes the derivatives for you.

To analyze a model with noise factors:

1. Fit the appropriate model (for example, using the Fit Model platform).
2. Save the model to the data table with the Save > Prediction Formula command.
3. Launch the Profiler (from the Graph menu).
4. Assign the prediction formula to the Y, Prediction Formula role and the noise factors to the Noise Factor role.
5. Click OK.

The resulting profiler shows response functions and their appropriate derivatives with respect to the noise factors, with the derivatives set to have maximum desirability at zero.

6. Select Optimization and Desirability > Maximize Desirability from the Profiler menu.

This finds the best settings of the factors, balanced with respect to minimizing transmitted variation from the noise factors.
Chapter 3
Profiler
Explore Cross Sections of Responses across Each Factor

The Prediction Profiler, or simply, Profiler, gives you a wealth of information about your model. Use the Prediction Profiler to:

- See how your prediction model changes as you change settings of individual factors.
- Set desirability goals for your response or responses, and find optimal settings for your factors.
- Gauge your model’s sensitivity to changes in the factors, where sensitivity is based on your predictive model.
- Assess the importance of your factors relative to model predictions, in a way that is independent of the model.
- Simulate your response distribution based on specified distributions for both factors and responses, and control various aspects of the appearance of the profiler.

Figure 3.1 Profiler for Four Responses with Simulator and Importance Coloring
Example of the Prediction Profiler

This example uses the Tiretread.jmp sample data table. There are three factors (SILICA, SILANE, and SULFUR) and four responses (ABRASION, MODULUS, ELONG, and HARDNESS). The goal is to find the optimal combination of the three factors in the development of a tire tread compound. See Derringer and Suich (1980).

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Select Graph > Profiler.
3. Select Pred Formula Abrasion and click Y, Prediction Formula.

Figure 3.2 Completed Profiler Launch Window

4. Click OK.

Figure 3.3 Profiler Report Window

The profiler is interactive. The vertical red lines correspond to the current value of the factors. The current value of each factor is also shown in red below the horizontal axis. The red value on the vertical axis is the predicted response based on the current values of the factors. Click and drag the vertical red lines to change the current values of the factors. Click a factor’s red value to set the factor to a specific value. To maximize ABRASION, set
Launch the Prediction Profiler Platform

The Prediction Profiler can be accessed in the following ways:

- The Prediction Profiler can be accessed directly from the Graph menu. When you access the Prediction Profiler in this way, the Prediction Profiler launch window appears. See “Profiler Launch Windows” on page 29 in the “Introduction to Profilers” chapter for details.

- The Prediction Profiler can be accessed as a red triangle menu option in many modeling platforms. See “Where to Find JMP Profilers” on page 28 in the “Introduction to Profilers” chapter for details about the availability of the Prediction Profiler in different platforms.

- The Prediction Profiler can be accessed from the Model Comparisons platform. Select Profiler from the Model Comparisons red triangle menu.

- The Prediction Profiler can be accessed from the Formula Depot platform. Select Profiler from the Formula Depot red triangle menu.

Prediction Profiler Options

The red triangle menu on the Prediction Profiler title bar has the following options:

**Optimization and Desirability** Submenu that consists of the following options:

- **Desirability Functions** Shows or hides the desirability functions. Desirability is discussed in “Desirability Profiling and Optimization” on page 47.

- **Maximize Desirability** Sets the current factor values to maximize the desirability functions. Takes into account the response importance weights.

**Note:** If a factor has a Design Role column property value of Discrete Numeric, it is treated as continuous in the optimization of the desirability function. To account for the fact that the factor can assume only discrete levels, it is displayed in the profiler as a categorical term and an optimal allowable level is selected.

- **Maximize and Remember** Maximizes the desirability functions and remembers the associated settings.

- **Maximization Options** Opens the Maximization Options window where you can refine the optimization settings.
**Figure 3.4 Maximization Options Window**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximize for Each Grid Point</td>
<td>Used only if one or more factors are locked. The ranges of the locked factors are divided into a grid, and the desirability is maximized at each grid point. This is useful if the model that you are profiling has categorical factors. Then the optimal condition can be found for each combination of the categorical factors.</td>
</tr>
<tr>
<td>Save Desirabilities</td>
<td>Saves the three desirability function settings for each response, and the associated desirability values, as a Response Limits column property in the data table. These correspond to the coordinates of the handles in the desirability plots.</td>
</tr>
<tr>
<td>Set Desirabilities</td>
<td>Opens the Response Goal window where you can set specific desirability values.</td>
</tr>
</tbody>
</table>

**Figure 3.5 Response Goal Window**

**Save Desirability Formula**  Creates a column in the data table with a formula for Desirability. The formula uses the fitting formula when it can, or the response variables when it cannot access the fitting formula.

**Assess Variable Importance**  Provides different approaches to calculating indices that measure the importance of factors to the model. These indices are independent of the model type and fitting method. Available only for continuous or binary responses. For details, see “Assess Variable Importance” on page 53.

**Bagging**  (Available only when the Prediction Profiler is embedded in certain modeling platforms.) Launches the Bagging window. Bootstrap aggregating (bagging) enables you to create multiple training data sets by sampling with replacement from the original data. For each training set, a model is fit using the analysis platform, and predictions are made. The final prediction is a combination of the results from all of the models. This improves
prediction performance by reducing the error from variance. For details, see “Bagging” on page 56.

**Simulator**  Launches the Simulator. The Simulator enables you to create Monte Carlo simulations using random noise added to factors and predictions for the model. A typical use is to set fixed factors at their optimal settings, and uncontrolled factors and model noise to random values. You then find out the rate of responses outside the specification limits. For details, see the “Simulator” chapter on page 129.

**Interaction Profiler**  Shows or hides interaction plots that update as you update the factor values in the Profiler. Use this option to help visualize third degree interactions by seeing how the plot changes as current values for the factors change. The cells that change for a given factor are the cells that do not involve that factor directly.

**Confidence Intervals**  Shows or hides confidence intervals in the Profiler plot. The intervals are drawn by bars for categorical factors, and curves for continuous factors. These are available when the profiler is used inside certain fitting platforms or when a standard error column has been specified in the Profiler launch dialog.

**Prop of Error Bars**  (Appears when a Sigma column property exists in any of the factor and response variables.) This option displays the $3\sigma$ interval that is implied on the response due to the variation in the factor. Propagation of error (POE) is important when attributing the variation of the response in terms of variation in the factor values when the factor values are not very controllable. See “Propagation of Error Bars” on page 75.

**Sensitivity Indicator**  Shows or hides a purple triangle whose height and direction correspond to the value of the partial derivative of the profile function at its current value (see Figure 3.6). This is useful in large profiles to be able to quickly spot the sensitive cells.
Profile at Boundary  When analyzing a mixture design, JMP constrains the ranges of the factors so that settings outside the mixture constraints are not possible. This is why, in some mixture designs, the profile traces turn abruptly.

When there are mixture components that have constraints, other than the usual zero-to-one constraint, a new submenu, called Profile at Boundary, appears on the Prediction Profiler red triangle menu. It has the following two options:

Turn At Boundaries  Lets the settings continue along the boundary of the restraint condition.

Stop At Boundaries  Truncates the prediction traces to the region where strict proportionality is maintained.

Reset Factor Grid  Displays a window for each factor enabling you to enter a specific value for the factor’s current setting, to lock that setting, and to control aspects of the grid. See the section “Set or Lock Factor Values” on page 33 for details.
Figure 3.7  Factor Settings Window

**Factor Settings**  Submenu that consists of the following options:

- **Remember Settings**  Adds an outline node to the report that accumulates the values of the current settings each time the Remember Settings command is invoked. Each remembered setting is preceded by a radio button that is used to reset to those settings.

- **Set To Data in Row**  Assigns the values of a data table row to the X variables in the Profiler.

- **Copy Settings Script**  Copies the current Profiler’s settings to the clipboard.

- **Paste Settings Script**  Pastes the Profiler settings from the clipboard to a Profiler in another report.

- **Append Settings to Table**  Appends the current profiler’s settings to the end of the data table. This is useful if you have a combination of settings in the Profiler that you want to add to an experiment in order to do another run.

- **Link Profilers**  Links all the profilers together. A change in a factor in one profiler causes that factor to change to that value in all other profilers, including Surface Plot. This is a global option, set, or unset for all profilers.

- **Set Script**  Sets a script that is called each time a factor changes. The set script receives a list of arguments of the form:

  \{factor1 = n1, factor2 = n2, \ldots\}

  For example, to write this list to the log, first define a function:

  ```
  ProfileCallbackLog = Function({arg},show(arg));
  ```

  Then enter `ProfileCallbackLog` in the Set Script dialog.

  Similar functions convert the factor values to global values:

  ```
  ProfileCallbackAssign = Function({arg},evalList(arg));
  ```

  Or access the values one at a time:

  ```
  ProfileCallbackAccess = Function({arg},f1=arg["factor1"];f2=arg["factor2"]);
  ```
Unthreaded Enables you to change to an unthreaded analysis if multithreading does not work.

Default N Levels Enables you to set the default number of levels for each continuous factor. This option is useful when the Profiler is especially large. When calculating the traces for the first time, JMP measures how long it takes. If this time is greater than three seconds, you are alerted that decreasing the Default N Levels speeds up the calculations.

Output Grid Table Produces a new data table with columns for the factors that contain grid values, columns for each of the responses with computed values at each grid point, and the desirability computation at each grid point.

If you have a lot of factors, it is impractical to use the Output Grid Table command, because it produces a large table. A memory allocation message might be displayed for large grid tables. In such cases, you should lock some of the factors, which are held at locked, constant values. To get the window to specify locked columns, ALT- or Option-click inside the profiler graph to get a window that has a Lock Factor Setting check box.

Output Random Table Prompts for a number of runs and creates an output table with that many rows, with random factor settings and predicted values over those settings. This is equivalent to (but much simpler than) opening the Simulator, resetting all the factors to a random uniform distribution, then simulating output. This command is similar to Output Grid Table, except it results in a random table rather than a sequenced one.

The prime reason to make uniform random factor tables is to explore the factor space in a multivariate way using graphical queries. This technique is called Filtered Monte Carlo.

Suppose you want to see the locus of all factor settings that produce a given range to desirable response settings. By selecting and hiding the points that do not qualify (using graphical brushing or the Data Filter), you see the possibilities of what is left: the opportunity space yielding the result that you want.

Some rows might appear selected and marked with a red dot. These represent the points on the multivariate desirability Pareto Frontier - the points that are not dominated by other points with respect to the desirability of all the factors.

Alter Linear Constraints Enables you to add, change, or delete linear constraints. The constraints are incorporated into the operation of Prediction Profiler. See “Linear Constraints” on page 35.

Save Linear Constraints Enables you to save existing linear constraints to a table script called Constraint. See “Linear Constraints” on page 35.

Conditional Predictions Appears when random effects are included in the model. The random effects predictions are used in formulating the predicted value and profiles.

Appearance Submenu that consists of the following options:
**Desirability Profiling and Optimization**

You can define a desirability function for a single response variable or for several response variables. When you are optimizing relative to several responses, there can often be competing criteria. For example, you might want to maximize one response, minimize another, and keep a third response close to some target value.

In desirability profiling, you specify a desirability function for each response. The overall desirability for all responses is defined as the geometric mean of the desirability functions for the individual responses. See Derringer and Suich (1980) for information about combining responses.

To use desirability profiling, select **Optimization and Desirability > Desirability Functions** from the Prediction Profiler red triangle menu.

*Note:* If the response column has a Response Limits property, desirability functions are turned on by default.

This command appends a new row to the bottom of the plot matrix, dedicated to graphing desirability. The row has a plot for each factor showing its desirability trace, as illustrated in Figure 3.8. It also adds a column that has an adjustable desirability function for each $Y$ variable. The overall desirability measure shows on a scale of zero to one at the left of the row of desirability traces.

**Arrange in Rows** Enter the number of plots that appear in a row. This option helps you view plots vertically rather than in one wide row.

**Reorder X Variables** Opens a window where you can reorder the model main effects by dragging them to the desired order.

**Reorder Y Variables** Opens a window where you can reorder the responses by dragging them to the desired order.

**Adapt Y Axis** Re-scales the Y axis if the response is outside the axis range, so that the range of the response is included.
Construction of Desirability Functions

The individual desirability functions are smooth piecewise functions that are crafted to fit the control points.

- The Minimize and Maximize functions are three-part piecewise smooth functions that consist of interpolating cubics between the defining points (Low, Middle, High) and exponentials in the tails.

- The Target function is a piecewise function that is a scale multiple of a normal density on either side of the Middle value (with different curves on each side), which is also piecewise smooth and fit to the control points. Exponential functions are fit to the tails.

- The None function enables you to specify an arbitrary desirability function. In particular, you can specify desirability to be lower at the Middle value than at the Low and High values. You can also construct custom desirability functions using formulas. See “Customized Desirability Functions” on page 51.

The control points are not allowed to reach all the way to zero or one at the tail control points. This approach to constructing the desirability functions results in good behavior as the desirability values switch between the maximize, target, and minimize values.

Note: JMP does not use the Derringer and Suich (1980) functional forms. Because they are not smooth, they do not always work well with JMP’s optimization algorithm.

Desirability Function for Multiple Optimization

When multiple responses are to be optimized, an overall desirability function is constructed and optimized. The overall desirability for all responses is defined as the geometric mean of the desirability functions for the individual responses.
Denote the individual desirability functions for $k$ responses by $d_1, d_2, \ldots, d_k$. Then the overall desirability function is the geometric mean of the individual desirability functions:

$$D = \sqrt[k]{\frac{d_1}{d_2} \cdots \frac{d_k}{d_k}}$$

If Importance values are defined as part of the Response Limits column property or are defined in the Response Goal window, they are integrated into the overall desirability function. The Importance values are scaled so that they sum to 1. Denote the scaled importance values by $w_1, w_2, \ldots, w_k$. Then the overall desirability is defined as a weighted geometric mean of the individual desirability functions:

$$D = \sqrt[k]{w_1 \frac{w_2}{w_2} \cdots \frac{w_k}{w_k}}$$

**Optimization Algorithm**

Optimization of the overall desirability function, or of the single desirability function if there is only one response, is conducted as follows.

- For categorical factors, a coordinate exchange algorithm is used.
- For continuous factors, a gradient descent algorithm is used.
- In the presence of constraints or mixture factors, a Wolfe reduced-gradient approach is used.

**How to Use the Desirability Function**

To use a variable’s desirability function, drag the function handles to represent a response value.

As you drag these handles, the changing response value shows in the area labeled Desirability to the left of the plots. The dotted line is the response for the current factor settings. The overall desirability shows to the left of the row of desirability traces. Alternatively, you can select **Optimization and Desirability > Set Desirabilities** to enter specific values for the points.

Figure 3.9 shows steps to create desirability settings.

**Maximize** The default desirability function setting is maximize ("higher is better"). The top function handle is positioned at the maximum $Y$ value and aligned at the high desirability, close to 1. The bottom function handle is positioned at the minimum $Y$ value and aligned at a low desirability, close to 0.
**Figure 3.9 Maximizing Desirability**

Target  You can designate a target value as “best.” In this example, the middle function handle is positioned at $Y = 70$ and aligned with the maximum desirability of 1. $Y$ becomes less desirable as its value approaches either 40 or 100. The top and bottom function handles at $Y = 40$ and $Y = 100$ are positioned at the minimum desirability close to 0.

**Figure 3.10 Defining a Target Desirability**

Minimize  The minimize (“smaller is better”) desirability function associates high response values with low desirability and low response values with high desirability. The curve is the maximization curve flipped around a horizontal line at the center of plot.

**Figure 3.11 Minimizing Desirability**

Note: Dragging the top or bottom point of a maximize or minimize desirability function across the $y$-value of the middle point results in the opposite point reflecting. A Minimize becomes a Maximize, and vice versa.

**The Desirability Profile**

The last row of plots shows the desirability trace for each factor. The numerical value beside the word Desirability on the vertical axis is the geometric mean of the desirability measures. This row of plots shows both the current desirability and the trace of desirabilities that result from changing one factor at a time.
For example, Figure 3.12 shows desirability functions for two responses. You want to maximize ABRASION and MODULUS. The desirability plots indicate that you could increase the desirability by increasing any of the factors.

**Figure 3.12** Prediction Profile Plot with Adjusted Desirability and Factor Values

![Prediction Profile Plot](image)

**Customized Desirability Functions**

It is possible to use a customized desirability function. For example, suppose you want to maximize using the following function.

**Figure 3.13** Maximizing Desirability Based on a Function

\[
\frac{\text{Pred Formula ABRASION}}{96} + \frac{\text{Pred Formula MODULUS}}{700} + \frac{33}{\left[\left|\text{Pred Formula ELONG-450}\right|+1\right]} + \frac{2}{\left[\left|\text{Pred Formula HARDNESS-67}\right|+1\right]}
\]

First, create a column called Custom Desirability that contains the above formula. Then, select **Graph > Profiler** to launch the platform. Select all the Pred Formula columns and the Custom Desirability column and select **Y, Prediction Formula**. Turn on the desirability functions by selecting **Optimization and Desirability > Desirability Functions** from the red triangle menu. All the desirability functions for the individual effects must be turned off. To do this, first
double-click in a desirability plot window, and then select None in the window that appears (Figure 3.14). Set the desirability for Custom Desirability to be maximized.

**Figure 3.14** Selecting No Desirability Goal

At this point, selecting **Optimization and Desirability > Maximize Desirability** uses only the custom Custom Desirability function.

**Figure 3.15** Maximized Custom Desirability

Desirabilities set to None

Set to Maximize so that Maximize Desirability uses this function
Assess Variable Importance

For continuous and binary responses, the Variable Importance report calculates indices that measure the importance of factors in a model in a way that is independent of the model type and fitting method. The fitted model is used only in calculating predicted values. The method estimates the variability in the predicted response based on a range of variation for each factor. If variation in the factor causes high variability in the response, then that effect is important relative to the model.

**Note:** Assess Variable Importance is not available for categorical responses with more than two levels.

Assess Variable Importance can also be accessed in the Profiler that is obtained through the Graph menu.

For statistical details, see “Assess Variable Importance” on page 74. See also Saltelli, 2002.

**Note:** Assess Variable Importance requires that all columns reside in the same data table.

The Assess Variable Importance Report

The Assess Variable Importance menu has the following options that address the methodology used in constructing importance indices:

**Independent Uniform Inputs** For each factor, Monte Carlo samples are drawn from a uniform distribution defined by the minimum and maximum observed values. Use this option when you believe that your factors are uncorrelated and that their likely values are uniformly spread over the range represented in the study.

**Independent Resampled Inputs** For each factor, Monte Carlo samples are obtained by resampling its set of observed values. Use this option when you believe that your factors are uncorrelated and that their likely values are not represented by a uniform distribution.

**Dependent Resampled Inputs** Factor values are constructed from observed combinations using a $k$-nearest neighbors approach, in order to account for correlation. This option treats observed variance and covariance as representative of the covariance structure for your factors. Use this option when you believe that your factors are correlated. Note that this option is sensitive to the number of rows in the data table. If used with a small number of rows, the results can be unreliable.

**Linearly Constrained Inputs** For each factor, Monte Carlo samples are drawn from a uniform distribution over a region defined by linear constraints. The linear constraints can be defined in the Profiler or constructed in connection with a designed experiment. In addition, the samples are restricted to fall within the minimum and maximum observed
values. Use this option in the presence of linear constraints, when you believe that these constraints impact the distribution of the inputs.

The speed of these algorithms depends on the model evaluation speed. In general, the fastest option is Independent Uniform Inputs and the slowest is Dependent Resampled Inputs. You have the option to Accept Current Indices when the estimation process is unable to complete instantaneously.

**Note:** In the case of independent and linearly constrained inputs, variable importance indices are constructed using Monte Carlo sampling. For this reason, you can expect some variation in importance index values from one run to another.

### Variable Importance Report

Each Assess Variable Importance option presents a Summary Report and Marginal Model Plots. When the Assess Variable Importance report opens, the factors in the Profiler are reordered according to their Total Effect importance indices. When there are multiple responses, the factors are reordered according to the Total Effect importance indices in the Overall report. When you run several Variable Importance reports, the factors in the Profiler are ordered according to their Total Effect indices in the most recent report.

### Summary Report

For each response, a table displays the following elements:

- **Column** The factor of interest.
- **Main Effect** An importance index that reflects the relative contribution of that factor alone, not in combination with other factors.
- **Total Effect** An importance index that reflects the relative contribution of that factor both alone and in combination with other factors. The Total Effect column is displayed as a bar chart. See “Weights” on page 55.
- **Main Effect Std Error** The Monte Carlo standard error of the Main Effect’s importance index. This is a hidden column that you can access by right-clicking in the report and selecting Columns > Main Effect Std Error. By default, sampling continues until this error is less than 0.01. Details of the calculation are given in “Variable Importance Standard Errors” on page 75. (Not available for Dependent Resampled Inputs option.)
- **Total Effect Std Error** The Monte Carlo standard error of the Total Effect’s importance index. This is a hidden column that you can access by right-clicking in the report and selecting Columns > Total Effect Std Error. By default, sampling continues until this error is less than 0.01. Details of the calculation are given in “Variable Importance Standard Errors” on page 75. (Not available for Dependent Resampled Inputs option.)
Weights  A plot that shows the Total Effect indices, located to the right of the final column. You can deselect or reselect this plot by right-clicking in the report and selecting Columns > Weights.

Proportion of function evaluations with missing values  The proportion of Monte Carlo samples for which some combination of inputs results in an inestimable prediction. When the proportion is nonzero, this message appears as a note at the bottom of the table.

Note: When you have more than one response, the Summary Report presents an Overall table followed by tables for each response. The importance indices in the Overall report are the averages of the importance indices across all responses.

Marginal Model Plots
The Marginal Model Plots report (see Figure 3.35) shows a matrix of plots, with a row for each response and columns for the factors. The factors are ordered according to the size of their overall Total Effect importance indices.

For a given response and factor, the plot shows the mean response for each factor value, where that mean is taken over all inputs to the calculation of importance indices. These plots differ from profiler plots, which show cross sections of the response. Marginal Model Plots are useful for assessing the main effects of factors.

Note that your choice of input methodology impacts the values plotted on marginal model plots. Also, because the plots are based on the generated input settings, the plotted mean responses might not follow a smooth curve.

The red triangle options enable you to show or hide the following aspects of the plots:

Estimate  A smoothed estimate of the mean of the simulated values calculated as a function of the factor values.

Note: The estimates of the mean are simulated, so the values change when you rerun the analysis.

Confidence Interval  A 95% confidence band for the simulated means. This band is often narrow and might not be visible unless you expand the scale. Not available for Dependent Resampled Inputs.

Note: The confidence bounds are simulated, so the bands change when you rerun the analysis.

Data  The actual (unsimulated) values of the response plotted against the factor values.

Variable Importance Options
The Variable Importance report has the following red triangle options:
Reorder factors by main effect importance  Reorders the cells in the Profiler in accordance with the importance indices for the main effects (Main Effect).

Reorder factors by total importance  Reorders the cells in the Profiler in accordance with the total importance indices for the factors (Total Effect).

Colorize Profiler  Colors cells in the profiler by Total Effect importance indices using a red to white intensity scale.

Note: You can click rows in the Summary Report to select columns in the data table. This can facilitate further analyses.

Bagging

Bootstrap aggregating (bagging) is a technique to improve predictive performance while also gaining insight into the reliability of predictions. Bagging is especially useful in unstable methods, including neural networks, classification trees, and regression trees.

Bagging creates $M$ training data sets by sampling with replacement from the original data. All training data sets are of the same size as the original. For each training data set, a model is fit using the analysis platform, and predictions are made. Therefore, there are a total of $M$ predictions for each observation in the original data set. The final prediction is the average of the $M$ predictions.

Bagging is available in many analysis platforms. To use bagging, select Save Bagged Predictions from the Prediction Profiler red triangle menu. A window appears with the following options for Bagging:

**Number of Bootstrap Samples**  Sets the number of times that you want to resample the data and build a model. A larger number results in more precise predictions. By default, the number of bootstrap samples is 100.

**Random Seed**  Sets a random seed that you can re-enter in subsequent runs of the bagging analysis to duplicate your current results. By default, no seed is set.

**Fractional Weights**  Performs a Bayesian bagging analysis. In each bootstrap iteration, each observation is assigned a nonzero weight. The model that makes the predictions uses the weighted observations. By default, the Fractional Weights option is not selected, and a simple bagging analysis is conducted.

Tip: Use the Fractional Weights option if the number of observations that are used in your analysis is small or if you are concerned about separation in a logistic regression setting.

Suppose that Fractional Weights is selected. For each bootstrap iteration, each observation that is used in the report is assigned a nonzero weight. These weights sum to $n$, the number of observations used in the model. For more information about how the weights...
are calculated and used, see “Calculation of Fractional Weights” on page 337 in the “Bootstrapping” chapter.

**Save Prediction Formulas** For each bagged prediction, this option saves the formula used to make that prediction in the column properties. This option is available in only a subset of the analysis platforms that offer bagging.

Bagging automatically creates new columns in the original data table. All $M$ sets of bagged predictions are saved as hidden columns. The final prediction is saved in a column named “Pred Formula $<\text{colname}>$ Bagged Mean”. The standard deviation of the final prediction is saved in a column named “$<\text{colname}>$ Bagged Std Dev”. The standard error of the bagged mean is saved in a column named “StdError $<\text{colname}>$ Bagged Mean.” The standard error is the standard deviation divided by $\sqrt{M-1}$. Here, $<\text{colname}>$ identifies the column in the report that was bagged.

The standard error gives insight about the precision of the prediction. A very small standard error indicates a precise prediction for that observation. For more information about bagging, see Hastie et al. (2009).

![Figure 3.16 Bagging Columns](image)

**Additional Examples of the Prediction Profiler**

This section contains additional examples illustrating various aspects of the Prediction Profiler platform and the Prediction Profiler embedded in many analysis platforms.

**Example of Desirability Profiling for Multiple Responses**

A desirability index becomes especially useful when there are multiple responses. The idea was pioneered by Derringer and Suich (1980), who give the following example. Suppose there are four responses, ABRASION, MODULUS, ELONG, and HARDNESS. Three factors, SILICA, SILANE, and SULFUR, were used in a central composite design.

The data are in the Tiretread.jmp table in the sample data folder. Use the RSM For 4 responses script in the data table, which defines a model for the four responses with a full quadratic response surface. The summary tables and effect information appear for all the responses,
followed by the prediction profiler shown in Figure 3.17. The desirability functions are as follows:

1. Maximum ABRASION and maximum MODULUS are most desirable.
2. ELONG target of 500 is most desirable.
3. HARDNESS target of 67.5 is most desirable.

**Figure 3.17** Profiler for Multiple Responses before Optimization

Select **Optimization and Desirability > Maximize Desirability** from the Prediction Profiler red triangle menu to maximize desirability. The results are shown in Figure 3.18. The desirability traces at the bottom decrease everywhere except the current values of the effects, which indicates that any further adjustment could decrease the overall desirability.
As an example, use the Tiretread.jmp sample data set. This data set shows the results of a tire manufacturer's experiment whose objective is to match a target value of HARDNESS=70 based on three factors: SILICA, SILANE, and SULFUR content. Suppose the SILANE and SULFUR content are easily (and precisely) controllable, but SILICA expresses variability that is worth considering.

For comparison, first optimize the factors for hardness without considering variation from the noise factor.

1. Select Graph > Profiler to launch the Profiler.
2. Assign Pred Formula HARDNESS to the Y, Prediction Formula role.
3. Click OK.
4. Select Optimization and Desirability > Desirability Functions in the Prediction Profiler menu.
5. Double-click in the Desirability plot to open the Response Goal window. Select Match Target from the list.
6. Select Optimization and Desirability > Maximize Desirability to find the optimum factor settings for our target value of HARDNESS.
We get the following Profiler display. Notice that the SILICA factor’s optimum value is on a sloped part of a profile curve. This means that variations in SILICA are transmitted to become variations in the response, HARDNESS.

**Note:** You might get different results from these because different combinations of factor values can all hit the target.

**Figure 3.19 Maximizing Desirability for HARDNESS**

Now, we would like to not just optimize for a specific target value of HARDNESS, but also be on a flat part of the curve with respect to Silica. So, repeat the process and add SILICA as a noise factor.

1. Select **Graph > Profiler**.
2. Select Pred Formula HARDNESS and click **Y, Prediction Formula**.
3. Select SILICA and click **Noise Factors**.
4. Click **OK**.
5. Change the Pred Formula Hardness desirability function as before.

The resulting profiler has the appropriate derivative of the fitted model with respect to the noise factor, set to be maximized at zero, its flattest point.
6. Select **Optimization and Desirability > Maximize Desirability** to find the optimum values for the process factor, balancing for the noise factor.

This time, we have also hit the targeted value of HARDNESS, but our value of SILICA is on its flatter region. This means variation in SILICA does not transmit as much variation to HARDNESS.

**Figure 3.20** Derivative of the Prediction Formula with Respect to Silica

**Figure 3.21** Maximize Desirability
You can see the effect this has on the variance of the predictions by following these steps for each profiler (one without the noise factor, and one with the noise factor):

1. Select **Simulator** from the platform menu.
2. Assign **SILICA** to have a random Normal distribution with a standard deviation of 0.05.

**Figure 3.22** Setting a Random Normal Distribution

3. Click **Simulate**.
4. Click the **Make Table** button under the Simulate to Table node.

Doing these steps for both the original and noise-factor-optimal simulations results in two similar data tables, each holding a simulation. In order to make two comparable histograms of the predictions, we need the two prediction columns in a single data table.

5. Copy the **Pred Formula HARDNESS** column from one of the simulation tables into the other table. They must have different names, like **Without Noise Factor** and **With Noise Factor**.

6. Select **Analyze > Distribution** and assign both prediction columns as **Y**.
7. When the histograms appear, select **Uniform Scaling** from the Distribution main title bar.
Figure 3.23 Comparison of Distributions with and without Noise Factors

The histograms show that there is much more variation in Hardness when the noise factor was not included in the analysis.

It is also interesting to note the shape of the histogram when the noise factor was included. In the comparison histograms above, note that the With Noise Factor distribution has data trailing off in only one direction. The predictions are skewed because Hardness is at a minimum with respect to SILICA, as shown in Figure 3.24. Therefore, variation in SILICA can make only HARDNESS increase. When the non-robust solution is used, the variation could be transmitted either way.

Figure 3.24 Profiler Showing the Minima of HARDNESS by SILICA

Example of Variable Importance for One Response

The Boston Housing.jmp sample data table contains data on 13 factors that might relate to median home values. You fit a model using a neural network. Because neural networks do not accommodate formal hypothesis tests, these tests are not available to help assess which variables are important in predicting the response. However, for this purpose, you can use the Assess Variable Importance profiler option.

Note that your results might differ from, but should resemble, those shown here. There are two sources of random variability in this example. When you fit the neural network, k-fold
cross validation is used. This partitions the data into training and validation sets at random. Also, Monte Carlo sampling is used to calculate the factor importance indices.

1. Select Help > Sample Data Library and open Boston Housing.jmp.
2. Select Analyze > Predictive Modeling > Neural.
3. Select mvalue from the Select Columns list and click Y, Response.
4. Select all other columns from the Select Columns list and click X, Factor.
5. Click OK.
6. In the Neural Model Launch panel, select KFold from the list under Validation Method.
   When you select KFold, the Number of Folds defaults to 5.
7. Click Go.
8. From the red triangle menu for the Model NTanH(3) report, select Profiler.
   The Prediction Profiler is displayed at the very bottom of the report. Note the order of the factors for later comparison.
   Because the factors are correlated, you take this into account by choosing Dependent Resampled Inputs as the sampling method for assessing variable importance.
9. From the red triangle menu next to Prediction Profiler, select Assess Variable Importance > Dependent Resampled Inputs.
   The Variable Importance: Dependent Resampled Inputs report appears (Figure 3.25).
   Check that the Prediction Profiler cells have been reordered by the magnitude of the Total Effect indices in the report. In Figure 3.25, check that the Total Effect importance indices identify rooms and lstat as the factors that have most impact on the predicted response.

Figure 3.25 Dependent Resampled Inputs Report
You might be interested in comparing the importance indices obtained assuming that the factors are correlated, with those obtained when the factors are assumed independent.

10. From the red triangle menu next to Prediction Profiler, select **Assess Variable Importance > Independent Resampled Inputs**.

   The resampled inputs option makes sense in this example, because the distributions involved are not uniform. The Variable Importance: Independent Resampled Inputs report is shown in Figure 3.26. Check that the two factors identified as having the most impact on the predicted values are lstat and rooms. Note that the ordering of their importance indices is reversed from the ordering using Dependent Resampled Inputs.

**Figure 3.26 Independent Resampled Inputs Report**

<table>
<thead>
<tr>
<th>Column</th>
<th>Main Effect</th>
<th>Total Effect</th>
<th>.2</th>
<th>.4</th>
<th>.6</th>
<th>.8</th>
</tr>
</thead>
<tbody>
<tr>
<td>lstat</td>
<td>0.226</td>
<td>0.261</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>rooms</td>
<td>0.173</td>
<td>0.205</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>radial</td>
<td>0.149</td>
<td>0.195</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>distance</td>
<td>0.09</td>
<td>0.159</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>tax</td>
<td>0.059</td>
<td>0.112</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>nox</td>
<td>0.047</td>
<td>0.086</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>crim</td>
<td>0.08</td>
<td>0.08</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>pt</td>
<td>0.029</td>
<td>0.038</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>b</td>
<td>0.017</td>
<td>0.028</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>age</td>
<td>0.02</td>
<td>0.02</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>indus</td>
<td>0.019</td>
<td>0.019</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>zn</td>
<td>0.011</td>
<td>0.011</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>chas</td>
<td>0.006</td>
<td>0.006</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Example of Variable Importance for Multiple Responses**

The data in the Tiretread.jmp sample data table are the result of a designed experiment where the factors are orthogonal. For this reason, you use importance estimates based on independent inputs. Suppose that you believe that, in practice, factor values vary throughout the design space, rather than assume only the settings defined in the experiment. Then you should choose Independent Uniform Inputs as the sampling scheme for your importance indices.

1. Select **Help > Sample Data Library** and open Tiretread.jmp.
2. Run the script **RSM for 4 Responses**.
   
   The Prediction Profiler is displayed at the very bottom of the report.
3. From the red triangle menu next to Prediction Profiler, select **Assess Variable Importance > Independent Uniform Inputs**.
The Summary Report is shown in Figure 3.27. Because the importance indices are based on random sampling, your estimates might differ slightly from those shown in the figure.

The report shows tables for each of the four responses. The Overall table averages the factor importance indices across responses. The factors in the Profiler (Figure 3.28) have been reordered to match their ordering on the Overall table’s Total Effect importance.

**Figure 3.27** Summary Report for Four Responses

4. From the red triangle menu next to Variable Importance: Independent Uniform Inputs, select **Colorize Profiler**.

Colors from a red to white intensity scale are overlaid on profiler panels to reflect Total Effect importance. For example, you easily see that the most important effect is that of Silane on Hardness.
The Marginal Model Plots report (Figure 3.29) shows mean responses for each factor across a uniform distribution of settings for the other two factors.

Example of Bagging to Improve Prediction

Bagging is used in a number of situations, one of which is improving predictive power. Bagging is especially helpful for unstable models. This example uses the Tiretread.jmp sample data table. There are three factors (SILICA, SILANE, and SULFUR) and four responses (ABRASION, MODULUS, ELONG, and HARDNESS). First, you fit a neural network model to simultaneously predict the four response variables as a function of the three factors. Then, you
perform bagging on the neural network model. Last, you compare the predictions to show the improvements obtained through bagging.

**Fit Neural Network Model**

1. Select **Help > Sample Data Library** and open Tiretread.jmp.
2. Select **Analyze > Predictive Modeling > Neural**.
3. Select ABRASION, MODULUS, ELONG, and HARDNESS and click **Y, Response**.
4. Select SILICA, SILANE, and SULFUR and click **X, Factor**.
5. Click **OK**.
6. (Optional) Enter 2121 next to Random Seed.

Note: Results vary due to the random nature of choosing a validation set in the Neural Network model. Entering the seed above enables you to reproduce the results shown in this example.

7. Click **Go**.
8. Select **Save Formulas** from the red triangle menu next to Model NTanH(3).

Note: This option saves the predicted values for all response variables from the neural network model to the data table. Later, these values are compared to the predictions that are obtained from bagging.

**Perform Bagging**

Now that the initial model has been constructed, you can perform bagging using that model. Access the Bagging feature through the Profiler.

1. From the red triangle menu next to Model NTanH(3), select **Profiler**.
   The Prediction Profiler appears at the bottom of the report.
2. From the red triangle menu next to Prediction Profiler, select **Save Bagged Predictions**.
3. Enter 100 next to Number of Bootstrap Samples.
4. (Optional) Enter 2121 next to Random Seed.

Note: Results vary due to the random nature of sampling with replacement. To reproduce the exact results in this example, set the Random Seed.

5. Click **OK**.

Return to the data table. For each response variable, there are three new columns denoted as Pred Formula <colname> Bagged Mean, StdError <colname> Bagged Mean, <colname>
Bagged Std Dev. The Pred Formula <colname> Bagged Mean columns are the final predictions.

Figure 3.30 Columns Added to Data Table After Bagging

Compare the Predictions

To see how bagging improves predictive power, compare the predictions from the bagged model to the original model predictions. Use the Model Comparison platform to look at one response variable at a time.

1. Select Analyze > Predictive Modeling > Model Comparison.
2. Select Predicted ABRASION and click Y, Predictors.
3. Select Pred Formula ABRASION Bagged Mean and click Y, Predictors.
4. Click OK.
   A window that contains a list of columns appears.
5. Select ABRASION and click OK.
6. From the red triangle menu next to Model Comparison, select Plot Actual by Predicted.
Figure 3.31 Comparison of Predictions for ABRASION

The Measures of Fit report and the Actual by Predicted Plot are shown in Figure 3.31. The predictions that were obtained from bagging are shown in blue. The predictions that were obtained from the original neural network model are shown in red. In general, the bagging predictions are closer to the line than the original model predictions. Because the bagging predictions are closer to the line, the RSquare value of 0.6699 for the bagged predictions is higher than the RSquare value for the original model predictions. You conclude that bagging has improved predictions for ABRASION.

This example compared the predictions for ABRASION. To compare predictions for another response variable, follow step 2 through step 6, replacing ABRASION with the desired response variable. As another example, Figure 3.32 shows the Measures of Fit report for HARDNESS. The report shows similar findings as the Measures of Fit report for ABRASION. The RSquare value for the bagged predictions is slightly higher than the RSquare value for the original model predictions, which indicates a better fit and improved predictions.
Bagging is also used to indicate the accuracy of the prediction through standard errors and other distributional measures. In platforms where the Save Predicted Formulas option is available in Bagging, you can make predictions on new observations and determine how accurate they are. The Save Predicted Formulas option is available in the Standard Least Squares, Generalized Regression, and Generalized Linear Models platforms.

In the Tiretread.jmp data table, suppose that you are interested in only predicting ABRASION as a function of the three factor variables. In this example, you fit a generalized regression model to predict ABRASION. Then, you perform bagging on that model. Last, you make a prediction for a new observation and investigate the accuracy of that prediction. This is done by obtaining a confidence interval for the prediction.

**Fit a Generalized Regression Model**

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Select Analyze > Fit Model.
3. Select ABRASION and click Y.
4. Select Generalized Regression from the Personality list.
5. Select SILICA, SILANE, and SULFUR and click Add.
6. Click Run.
7. Click Go.
Perform Bagging

1. Select Profilers > Profiler from the red triangle menu next to Adaptive Lasso with AICc Validation. The Prediction Profiler appears at the bottom of the report.
2. From the red triangle menu next to Prediction Profiler, select Save Bagged Predictions.
3. Enter 500 next to Number of Bootstrap Samples.
4. (Optional) Enter 4321 next to Random Seed.

Note: Results vary due to the random nature of sampling with replacement. To reproduce the exact results in this example, set the Random Seed.
5. Confirm that Save Prediction Formulas is selected.
6. Click OK.

Note: This might take longer to run than the “Example of Bagging to Improve Prediction” on page 67. The larger number of samples gives a better estimate of the prediction distributions.

Return to the data table. For each response variable, there are three new columns denoted as Pred Formula <colname> Bagged Mean, StdError <colname> Bagged Mean, <colname> Bagged Std Dev. The Pred Formula ABRASION Bagged Mean column is the final prediction.

Prediction for a New Observation

You now have predictions for ABRASION for each observation in the data table, as well as the standard errors for those predictions. Suppose that you have an observation with new values of 0.9, 43, and 2 for SILICA, SILANE, and SULFUR, respectively. You can predict the ABRASION response and obtain a confidence interval for that prediction because the Save Prediction Formulas option saves the regression equation for each bagged model. Therefore, M predictions are made with the new factor values to create a distribution of possible predictions. The mean is the final prediction, but analyzing the distribution tells you how accurate the prediction is.

1. In the data table, select Rows > Add Rows.
2. Enter 1 in the How many rows to add box and click OK.
3. Under the SILICA column, type 0.9 in the box for the new row.
4. Under the SILANE column, type 43 in the box for the new row.
5. Under the SULFUR column, type 2 in the box for the new row.

The prediction columns for the new row are automatically calculated.
6. Select Tables > Transpose.
7. Select ABRASION Bags (500/0) and click Transpose Columns.
8. Click OK.
10. Select Row 21 and click Y, Columns.

**Note:** Row 21 corresponds to the predictions from the new observation.

11. Click OK.
12. From the red triangle menu next to Row 21, select Display Options > Horizontal Layout.

**Figure 3.34** Distribution Report
The Distribution Report in Figure 3.34 contains information about the distribution of the predicted values of ABRASION from each bagged model. The final prediction of ABRASION for the new observation is 104.45, which is the mean of all the $M$ bagged predictions. This prediction has a standard error of 4.56. You can also create confidence intervals for the new prediction using the quantiles. For example, a 95% confidence interval for the new prediction is 95.89 to 113.00.

**Statistical Details for the Prediction Profiler**

This section contains statistical details for options available in the Prediction Profiler platform.

**Assess Variable Importance**

The details that follow relate to the how the variable importance indices are calculated.

**Background**

Denote the function that represents the predictive model by $f$, and suppose that $x_1, x_2, ..., x_n$ are the factors, or main effects, in the model. Let $y = f(x_1, x_2, ..., x_n)$.

- The expected value of $y$, $E(y)$, is defined by integrating $y$ with respect to the joint distribution of $x_1, x_2, ..., x_n$.
- The variance of $y$, $Var(y)$, is defined by integrating $(y – E(y))^2$ with respect to the joint distribution of $x_1, x_2, ..., x_n$.

**Main Effect**

The impact of the main effect $x_j$ on $y$ can be described by $Var(E(y | x_j))$. Here the expectation is taken with respect to the conditional distribution of $x_1, x_2, ..., x_n$ given $x_j$ and the variance is taken over the distribution of $x_j$. In other words, $Var(E(y | x_j))$ measures the variation, over the distribution of $x_j$, in the mean of $y$ when $x_j$ is fixed.

It follows that the ratio $Var(E(y | x_j))/Var(y)$ gives a measure of the sensitivity of $y$ to the factor $x_j$. The importance index in the Main Effect column in the Summary Report is an estimate of this ratio (see “Adjustment for Sampling Variation” on page 75).

**Total Effect**

The Total Effect column represents the total contribution to the variance of $y = f(x_1, x_2, ..., x_n)$ from all terms that involve $x_j$. The calculation of Total Effect depends on the concept of functional decomposition. The function $f$ is decomposed into the sum of a constant and functions that represent the effects of single variables, pairs of variables, and so on. These component functions are analogous to main effects, interaction effects, and higher-order effects. (See Saltelli, 2002, and Sobol, 1993.)
Those component functions that include terms containing $x_j$ are identified. For each of these, the variance of the conditional expected value is computed. These variances are summed. The sum represents the total contribution to $\text{Var}(y)$ due to terms that contain $x_j$. For each $x_j$, this sum is estimated using the selected methodology for generating inputs. The importance indices reported in the Total Effect column are these estimates (see “Adjustment for Sampling Variation” on page 75).

Consider a simple example with two factors, $x_1$ and $x_2$. Then the Total Effect importance index for $x_1$ is an estimate of:

$$\frac{\text{Var}(E(y \mid x_1)) + \text{Var}(E(y \mid x_1, x_2))}{\text{Var}(y)}$$

Adjustment for Sampling Variation

Due to the fact that they are obtained using sampling methods, the Main Effect and Total Effect estimates shown in the Summary Table might have been adjusted. Specifically, if the Total Effect estimate is less than the Main Effect estimate, then the Total Effect importance index is set equal to the Main Effect estimate. If the sum of the Main Effect estimates exceeds one, then these estimates are normalized to sum to one.

Variable Importance Standard Errors

The standard errors that are provided for independent inputs measure the accuracy of the Monte Carlo replications. Importance indices are computed as follows:

- Latin hypercube sampling is used to generate a set of data values.
- For each set of data values, main and total effect importance estimates are calculated.
- This process is replicated until the estimated standard errors of the Main Effect and Total Effect importance indices for all factors fall below a threshold of 0.01.

The standard errors that are reported are the standard error values in effect when the replications terminate.

Propagation of Error Bars

Propagation of error (POE) is important when attributing the variation of the response in terms of variation in the factor values when the factor values are not very controllable.

In JMP’s implementation, the Profiler first looks at the factor and response variables to see whether there is a Sigma column property (a specification for the standard deviation of the column, accessed through the Cols > Column Info dialog box). If the property exists, then the Prop of Error Bars command becomes accessible in the Prediction Profiler drop-down menu. This displays the $3\sigma$ interval that is implied on the response due to the variation in the factor.
Figure 3.35  Green Propagation of Errors Bars in the Prediction Profiler

The POE is represented in the graph by a green bracket. The bracket indicates the prediction plus or minus three times the square root of the POE variance. The POE variance can be expressed as:

$$\sum_{i=1}^{N} \left( \sigma_{x_i}^2 \times \left( \frac{\partial f}{\partial x_i} \right)^2 \right) + \sigma_y^2$$

where $\sigma_y$ is the user-specified sigma for the response column, and $\sigma_x$ is the user-specified sigma for the factor column.

Currently, these partial derivatives are calculated by numerical derivatives:

- centered, with $\delta=xrange/10000$

POE limits increase dramatically in response surface models when you are over a more sloped part of the response surface. One of the goals of robust processes is to operate in flat areas of the response surface so that variations in the factors do not amplify in their effect on the response.
The Contour Profiler shows response contours for two factors at a time. The interactive contour profiling facility is useful for optimizing response surfaces graphically.

**Figure 4.1 Contour Profiler Example**
Contour Profiler Overview

The Contour Profiler shows response contours for two factors at a time. Other factors can be set to specific values to show how this affects the contours. The interactive contour profiling facility is useful for optimizing response surfaces graphically. Separate surface plots for each response are also graphed. Figure 4.2 shows an example of the Contour Profiler for the Tiretread.jmp sample data.

Figure 4.2 Contour Profiler

Example of the Contour Profiler

This example uses the Tiretread.jmp sample data table. There are three factors (SILICA, SILANE, and SULFUR) and four responses (ABRASION, MODULUS, ELONG, and HARDNESS). This data table already contains saved prediction formula columns for the four response variables.

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Select Graph > Contour Plot.
3. Select Pred Formula ABRASION, Pred Formula MODULUS, Pred Formula ELONG, and Pred Formula HARDNESS and click Y, Prediction Formula.
4. Click OK.

The values for SILICA are on the horizontal axis and the values for SILANE are on the vertical axis. The value for SULFUR is fixed at 2.25. See Figure 4.2.

5. Click the Current X box for SULFUR and type 2. Click anywhere outside the box to set the value.

6. In the Lo Limit box for Pred Formula ABRASION, type 100.

7. In the Hi Limit box for Pred Formula ABRASION, type 160.

8. Click anywhere outside the box to update the plot.

**Figure 4.3 Contour Profiler for Tiretread.jmp**

The contour lines and surface plots differ from those in Figure 4.2 because SULFUR is set at a different value. Move the slider bar for SULFUR to see how different values further change the contour lines and surface plots. The shaded area on the contour plot represents the region of the graph that is not feasible, based on the Lo Limit and Hi Limit values for ABRASION,

---

**Launch the Contour Profiler Platform**

The Contour Profiler can be accessed in the following ways:
The Contour Profiler can be accessed directly from the Graph menu. When you access the Contour Profiler in this way, the Contour Profiler launch window appears. See “Profiler Launch Windows” on page 29 in the “Introduction to Profilers” chapter for details.

The Contour Profiler can be accessed as a red triangle menu option in many modeling platforms. See “Where to Find JMP Profilers” on page 28 in the “Introduction to Profilers” chapter for details about the availability of the Contour Profiler in different platforms.

The Contour Profiler can be accessed from the Model Comparisons platform. Select Profiler from the Model Comparisons red triangle menu. Then, select Contour Profiler from the Profiler red triangle menu.

The Contour Profiler can be accessed from the Formula Depot platform. Select Profiler from the Formula Depot red triangle menu and select the models to be profiled. Then, select Contour Profiler from the Profiler red triangle menu.

---

**The Contour Profiler Report**

The initial Contour Profiler report shows a contour profiler plot, a surface plot for each response, factor settings and controls, and response settings and controls. The colored lines on the graph are the contours for the responses set by the Y slider controls or by entering values in the Contour column. There is a separately colored contour for each response. For each contour, there is a dotted line in the direction of higher response values, so that you get a sense of direction.

**Factor Settings and Controls**

- **Horiz, Vert** Radio buttons to control factor assignments to the horizontal and vertical axes in the contour profiler and surface plots.
- **Factor** The list of factors.
- **Current X** The current factor settings. Click in a box to change the value of a factor or use the slider controls. Right-click the slider control and select Rescale Slider to change the scale of the slider. When one value is changed, the values for the other factors remain the same, but the values in the response settings and controls report change accordingly. The Current X location is shown by the crosshair lines on the graph.
- **Lock** A column that appears for mixture designs with more than three predictors. This column enables you to lock settings for mixture values so that they are not changed when the mixture needs to be adjusted due to other mixture effects being changed. When locked columns exist, the shaded area for a mixture recognizes the newly restricted area.
Response Settings and Controls

**Response**  The list of one or more responses, with a color legend. To change the color of a response, right-click the color legend for that response.

**Contour**  The current value of the contour on the contour profiler. Click in the box to change the value. The slider control can also be used to change the value of the contour.

**Current Y**  The predicted response based on the current X settings. The value is at the red line on the slider control. This value updates as the factor settings are changed.

**Lo Limit**  Enables you to set a lower limit for your response. Click in a box to set the limit or click the left triangle of the slider control for that response. If a response column’s Spec Limits column property has a value for Lower Spec Limit, that value is used as the initial value for Lo Limit.

**Hi Limit**  Enables you to set an upper limit for your response. Click in a box to set the limit or click the right triangle of the slider control for that response. If a response column’s Spec Limits column property has a value for Upper Spec Limit, that value is used as the initial value for Hi Limit.

When response limits are used, the profiler shows regions that are not feasible as shaded in the contour profiler plot.

### Contour Profiler Platform Options

**Grid Density**  Sets the density of the mesh plots in the surface plots.

**Graph Updating**  Contains options to change the frequency of updates for the graph. (The difference might not be noticeable on a fast machine.) The following two options are available:

- **Per Mouse Move**  Updates the graph continuously as you drag the mouse. This is the default setting.

- **Per Mouse Up**  Updates the graph each time the mouse is released.

**Surface Plot**  Shows or hides the mesh plots.
Contour Profiler
Constraint Shading Settings

**Contour Label**  Shows or hides a label for the contour lines. The label colors match the contour colors.

**Contour Grid**  Draws contours on the Contour Profiler plot at intervals that you specify.

**Remove Contour Grid**  Enables you to remove a contour grid once one is drawn.

**Factor Settings**  Provides a submenu of commands that enables you to save and transfer the Contour Profiler’s settings to other parts of JMP. See “Factor Settings” on page 45 in the “Profiler” chapter.

**Simulator**  Launches the Simulator. See the “Simulator” chapter on page 129.

**Up Dots**  Shows or hides dotted lines that correspond to each contour. The dotted lines show the direction of increasing response values.

**Set Contours to Current**  Resets the contour lines to be where the current Y values are located. This means that all contour lines cross where the crosshairs are on the contour plot and the controls agree in the Y sliders.

**Arrange X Controls Left**  Rearranges the X and Y controls horizontally with the X controls on the left or vertical with the X controls at the top.

**Hide X Controls**  Shows or hides the X controls (Factor Settings and Controls).

**Hide Y Controls**  Shows or hides the Y controls (Response Settings and Controls).

---

**Constraint Shading Settings**

If you specify limits for the response columns, the areas of the plot that are outside of the feasible region are shaded. The unshaded white area represents the feasible region. See Figure 4.5.
Figure 4.5 Settings for Contour Shading

Setting appropriate limits on responses

illustrates the feasible region
Contour Profiler
Constraint Shading Settings

Chapter 4
Profiler
Chapter 5

**Surface Plot**

Explore Contours of Responses across Three Factors

The Surface Plot platform functions both as a separate platform and as an option in model fitting platforms. Up to four dependent surfaces can be displayed in the same plot. The dependent variables section, below the plot, has four rows that correspond to the four surfaces. Depending on what you choose to view (sheets, points, isosurfaces, or density grids) and whether you supply a formula variable, different options appear in the dependent variables section.

**Figure 5.1** Example of a Surface Plot
Surface Plot Overview

The Surface Plot platform is used to plot points and surfaces in three dimensions.

Surface plots are available as a separate platform (Graph > Surface Plot) and as options in many reports (known as the Surface Profiler). Its functionality is similar wherever it appears.

The plots can be of points or surfaces. When the surface plot is used as a separate platform (that is, not as a profiler), the points are linked to the data table. The points are clickable, respond to the brush tool, and reflect the colors and markers assigned in the data table. Surfaces can be defined by a mathematical equation, or through a set of points defining a polygonal surface. These surfaces can be displayed smoothly or as a mesh, with or without contour lines. Labels, axes, and lighting are fully customizable.

Surface Plot is built using the 3D scene commands from the JMP Scripting Language (JSL). For details about the Open GLscene commands, see the Three-Dimensional Scenes chapter in the Scripting Guide.

In this platform, you can do the following:

- Use the mouse to drag the surface to a new position.
- Right-click the surface to change the background color or show the virtual ArcBall (which helps position the surface).
- Enable hardware acceleration, which can increase performance if it is supported on your system.
- Drag lights to different positions, assign them colors, and turn them on and off.

Example of the Surface Plot Platform

This example uses the Tiretread.jmp sample data table. There are three factors (SILICA, SILANE, and SULFUR) and four responses (ABRASION, MODULUS, ELONG, and HARDNESS). This data table already contains saved prediction formula columns for the four response variables. Use these prediction formula columns to examine the surfaces of two of the response variables.

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Select Graph > Surface Plot.
3. Select Pred Formula ABRASION and Pred Formula MODULUS and click Columns.
4. Click OK.
When you initially click OK, only the prediction surface for ABRASION is plotted. Also note that in the Independent Variables controls box, there is a large difference between the values for ABRASION and MODULUS. The two responses are on different scales.

5. In the Dependent Variables controls box, select Both Sides from the Surface list for Pred Formula MODULUS.

6. Click the Surface Plot red triangle and select Scale response axes independently.
Figure 5.3  Prediction Surface for ABRASION and MODULUS

Pred Formula ABRASION is on one z-axis and Pred Formula MODULUS is on the other z-axis. Each response has its own scale. In this plot, the two factors considered are SILICA and SILANE. You can rotate the surface plot by clicking and dragging inside the graph. This enables you to view the prediction surfaces from different perspectives. For example, in Figure 5.4, you can see that predictions for ABRASION and MODULUS based on the two listed predictors have a similar surface shape, just on a different scale. Use the Independent Variables controls to see how different combinations of predictors affect the surface plot.

Tip: To see the original view after rotating, right-click anywhere on the surface plot and select Reset.
Launch the Surface Plot Platform

To launch the platform, select Surface Plot from the Graph menu. If there is a data table open, this displays the window in Figure 5.5. If you do not want to use a data table for drawing surfaces plots, click OK without specifying columns. If there is no data table open, you are presented with the default surface plot shown in Figure 5.6.

Figure 5.5 Surface Plot Launch Window
Specify the columns that you want to plot by putting them in the Columns role. Only numeric variables can be assigned to the Columns role. Variables in the By role produce a separate surface plot for each level of the By variable.

When selected, the **Scale response axes independently** option gives a separate scale to each response on the plot. When not selected, the axis scale for all responses is the same as the scale for the first item entered in the Columns role.

**Plot a Single Mathematical Function**

To produce the graph of a mathematical function without any data points, do not fill in any of the roles on the launch window. Simply click **OK** to get a default plot, as shown in Figure 5.6.

**Figure 5.6** Default Surface Plot

Select the **Show Formula** check box to show the formula space.
The default function shows in the box. To plot your own function, enter it in this box.

**Plot Points Only**

To produce a 3-D scatterplot of points, place the $x$-, $y$-, and $z$-columns in the Columns box. For example, using the Tiretread.jmp data, first select **Rows > Clear Row States**. Then select **Graph > Surface Plot**. Assign Silica, Silane, and Sulfur to the **Columns** role. Click **OK**.
Figure 5.7 3-D Scatterplot Launch and Results

Plot a Formula from a Column

To plot a formula (that is, a formula from a column in the data table), place the column in the Columns box. For example, use the Tiretread.jmp data table and select Graph > Surface Plot. Assign Pred Formula ABRASION to the Columns role. Click OK. You do not have to specify the factors for the plot, because the platform automatically extracts them from the formula.
Figure 5.8 Formula Launch and Output

Note that this only plots the prediction surface. To plot the actual values in addition to the formula, assign the ABRASION and Pred Formula ABRASION to the Columns role. Figure 5.9 shows the completed results.
Isosurfaces

Isosurfaces are the 3-D analog to a 2-D contour plot. An isosurface requires a formula with three independent variables. The Resolution slider determines the $n \times n \times n$ cube of points that the formula is evaluated over. The Value slider in the Dependent Variable section selects the isosurface (that is, the contour level) value.

For example, in the Tiretread.jmp data table, the RSM for 4 Responses script produces a response surface model with dependent variables ABRASION, MODULUS, ELONG, and HARDNESS. The predicted formulas for these four responses are in the data table.

Launch Surface Plot and designate Pred Formula ABRASION, Pred FormulaMODULUS, and Pred FormulaELONG as those to be plotted.
When the report appears, select the Isosurface radio button. Under the Dependent Variables outline node, select **Both Sides** for all three variables.

**Figure 5.11** Isosurface of Three Variables

These sliders change the level of the surface. Surfaces are showing.
For the tire tread data, one might set the abrasion at a fixed minimum setting and the elongation at a fixed maximum setting. Use the MODULUS slider to see which values of MODULUS are inside the limits set by the other two surfaces.

### The Surface Plot Report

This section contains information about the Surface Plot report and options. The initial Surface Plot report shows the surface plot, the appearance controls, the Independent Variables controls, and the Dependent Variables controls. If more than one prediction formula column is specified, only the first surface is displayed in the initial report. However, if more than one observed response column is specified, all points are displayed in the initial report.

### Surface Plot Platform Options

The red triangle menu in the main Surface Plot title bar has the following entries.

- **Control Panel** Shows or hides the Control Panel.
- **Scale response axes independently** Scales response axes independently. See explanation of Figure 5.5 on page 89.
- **Fit to Window** Determines whether the plot is resized as you resize the JMP window. The default setting is Auto, which bases the scaling on the contents of the plot. For example, a plot with By variables or used as a Surface Profiler in a Fit Model platform does not stretch to fit the resized window; the plot extends beyond the viewing area. Change the setting to On to always fit the plot inside the window. Change the setting to Off to prevent the plot from resizing.

See the JMP Reports chapter in the *Using JMP* book for more information about the following options:

- **Local Data Filter** Shows or hides the local data filter that enables you to filter the data used in a specific report.
- **Redo** Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.
- **Save Script** Contains options that enable you to save a script that reproduces the report to several destinations.
- **Save By-Group Script** Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

The Control Panel consists of the following groups of options.
Appearance Controls

The first set of controls enables you to specify the overall appearance of the surface plot.

**Figure 5.12** Appearance Controls

*Sheet, points*  Is the setting for displaying sheets, points, and lines.

*Isosurface*  Changes the display to show isosurfaces, described in “Isosurfaces” on page 94.

*Show formula*  Shows the formula edit box, enabling you to enter a formula to be plotted.

The Resolution slider affects how many points are evaluated for a formula. Too coarse a resolution means a function with a sharp change might not be represented very well, but setting the resolution high makes evaluating and displaying the surface slower.

Surface Profiler Appearance Controls in Other Platforms

If you select the Surface Profiler from the Fit Model, Nonlinear, Gaussian Process, or Neural platforms, there is an additional option in the Appearance controls called *data points are*. Choose from the following:

*Off*  Turns the data points off.

*Surface plus Residual*  Shows the difference between the predicted value and actual value on the surface.

*Actual*  Shows the actual data points.

*Residual*  Shows the residual values (if they are not off the plot).

Independent Variables

The independent variables controls are displayed in Figure 5.13.

**Figure 5.13** Variables Controls

Select the variables for the x- and y-axes.

Lock the Z scale.

Sliders and edit boxes set the current value of each variable.
When there are more than two independent variables, you can select which two are displayed on the $x$- and $y$-axes using the radio buttons in this panel. The sliders and text boxes set the current values of each variable. These settings are most important for the variables that are not displayed on the axes. In essence, the plot shows the three-dimensional slice of the surface at the value shown in the text box. Move the slider to see different slices.

Lock Z Scale locks the $z$-axis to its current values. This is useful when moving the sliders that are not on an axis.

Grid check boxes activate a grid that is parallel to each axis. The sliders enable you to adjust the placement of each grid. The resolution of each grid can be controlled by adjusting axis settings. For example, Figure 5.14 shows a surface with the X and Y grids activated.

**Figure 5.14** Activated X and Y Grids

![Activated X and Y Grids](image)

**Dependent Variables**

The dependent variables controls change depending on whether you have selected Sheet, points or Isosurface in the Appearance Controls.

**Controls for Sheet and Points**

The Dependent Variables controls are shown in Figure 5.15 with its default menus.
Figure 5.15  Dependent Variable Controls

![Dependent Variables](image)

**Formula**  Lets you select the formula(s) to be displayed in the plot as surfaces.

**Point Response Column**  Lets you select the column that holds values to be plotted as points.

**Style**  Menus appear after you have selected a Point Response Column. The style menu lets you choose how those points are displayed, as Points, Needles, a Mesh, Surface, or Off (not at all). Points shows individual points, which change according to the color and marker settings of the row in the data table. Needles draws lines from the $x$-$y$ plane to the points, or, if a surface is also plotted, connects the surface to the points. Mesh connects the points into a triangular mesh. Surface overlays a smooth, reflective surface on the points.

**Surface**  Enables you to show or hide the top or bottom of a surface. If Above only or Below only is selected, the opposite side of the surface is darkened.

**Grid**  Slider and check box activate a grid for the dependent variable. Use the slider to adjust the value where the grid is drawn, or enter the value into the Grid Value box above the slider.

Controls for Isosurface

Most of the controls for Isosurface are identical to those of Sheet, points. Figure 5.16 shows the default controls, illustrating the slightly different presentation.

Figure 5.16  Dependent Variable Controls for Isosurfaces

![Dependent Variables](image)

Dependent Variable Options

There are several options for the Dependent Variable, accessed through the red triangle menu.

**Formula**  Reveals or hides the Formula drop-down list.

**Surface**  Reveals or hides the Surface drop-down list.

**Points**  Reveals or hides the Point Response Column drop-down list.
Response Grid  Reveals or hides the Grid controls.

Surface Plot Controls and Settings

This section describes the surface plot controls and settings.

Rotate

The plot can be rotated in any direction by dragging it. Drag the plot to rotate it.

Figure 5.17  Example of Cursor Position for Rotating Plot

Cursor indicates when you can rotate the plot.

The Up, Down, Left, and Right arrow keys can also be used to rotate the plot.

Axis Settings

Double-click an axis to reveal the axis control window shown below. The window enables you to change the Minimum, Maximum, Increment, and tick mark label Format.

Figure 5.18  Axis Settings Controls
Like other JMP graphs, the axes can be adjusted, stretched, and compressed using the grabber tool. Place the cursor over an axis to change it to the grabber.

**Figure 5.19** Grabber Tools

Place grabber in the middle of axis to adjust. Place grabber at the end of axis to stretch or compress.

Notice the orientation of grabber changes from vertical to horizontal

**Lights**

By default, the plot has lights shining on it. There are eight control knobs on the plot for changing the position and color of the lights. This is useful for highlighting different parts of a plot and creating contrast. Four of the eight knobs are shown below.

**Figure 5.20** Control Knobs for Lights

- Right-click a knob to turn that light on or off. More lights turned on brighten a plot, and fewer lights darken it.
- Drag a knob to change the position of a light.
- Change the color of a light by right-clicking on the knob. The default color is white.

**Sheet or Surface Properties**

If you are plotting a **Sheet**, **points**, right-click the sheet inside the plot and select **Sheet Properties** to reveal a window for changing the sheet properties.
Surface Plot Controls and Settings

**Figure 5.21** Sheet Properties Window

![Sheet Properties Window](image)

- **Surface** Enables you to show or hide the top or bottom of a surface. If *Above only* or *Below only* is selected, the opposite side of the surface is darkened.

- **Fill Type** Enables you to color the surface using a solid color, or continuous or discrete gradients. If a gradient is chosen, the Show Legend option appears when you right-click the surface.

- **Mesh** Enables you to turn on or off a surface mesh, for either the X or Y directions or both. If turned on, the Mesh Color option is revealed enabling you to change the color.

- **Contour** Enables you to turn on or off a contour grid, either above, below, or on the surface. If turned on, the Contour Color option is revealed enabling you to change the color.

- **Limit X and Y to Point Response Column** limits the range of the plot to the range of the data in the Point Response Column, if one is activated. If checked, this essentially restricts the plot from extrapolating outside the range of the data in the Point Response Column.

The equivalent JSL command for this option is `Clip Sheet(Boolean)`. You can send this message to a particular response column by appending the number of the response column. For example, `Clip Sheet2(1)` limits the range of the plot to the range of the data of the second response column. See the Scripting Index in the JMP Help menu for an example.

If you are plotting an Isosurface, right-click the surface and select **Surface Properties** to reveal a similar window. You can modify the surface color, opacity, and toggle a mesh.

**Other Properties and Commands**

Right-click anywhere in the plot area to reveal the following options:

- **Show Legend** Shows a legend when the surface is colored using gradients.

- **Reset** Resets the plot to the original viewpoint. Changes in wall and background color are not affected.

- **Settings** Opens a window for changing many plot settings.
Hide Lights Border  Shows or hides lighting controls.

Wall Color  Enables you to change the plot wall color.

Background Color  Enables you to change the plot background color.

Rows  Enables you to change row colors or markers, and also exclude, hide, and label points.

Use Hardware Acceleration  Provides for faster rendering of the display. For example, if the plot redraws slowly when rotating, this option can help it redraw faster.

Show ArcBall  Provides options for using the ArcBall. The ArcBall is a sphere drawn around the plot to help visualize the directions of rotation.

### Keyboard Shortcuts

The following keyboard shortcuts can be used to manipulate the surface plot. To get the plot back to the original viewpoint, right-click the plot and select **Reset**.

**Table 5.1  Surface Plot Keyboard Shortcuts**

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>left, right, up, and down arrows</td>
<td>spin</td>
</tr>
<tr>
<td>Home, End</td>
<td>diagonally spin</td>
</tr>
<tr>
<td>Enter (Return)</td>
<td>toggles ArcBall appearance</td>
</tr>
<tr>
<td>Delete</td>
<td>roll counterclockwise</td>
</tr>
<tr>
<td>Control</td>
<td>boost spin speed 10X</td>
</tr>
<tr>
<td>Shift</td>
<td>allows continual spinning</td>
</tr>
</tbody>
</table>
The Mixture Profiler shows response contours for mixture experiment models, where three or more factors in the experiment are components (ingredients) in a mixture. The Mixture Profiler is useful for visualizing and optimizing response surfaces resulting from mixture experiments.

**Figure 6.1** Mixture Profiler Example
Mixture Profiler Overview

The Mixture Profiler shows response contours for mixture experiment models, where three or more factors in the experiment are components (ingredients) in a mixture. The Mixture Profiler is useful for visualizing and optimizing response surfaces resulting from mixture experiments.

Figure 6.2 shows an example of the Mixture Profiler for the sample data in Plasticizer.jmp. To generate the graph shown, select Mixture Profiler from the Graph menu. In the resulting Mixture Profiler launch window, assign Pred Formula Y to the Y, Prediction Formula role and click OK.

Many of the features shown are the same as those of the Contour Profiler and are described on “Contour Profiler Platform Options” on page 81. Some of the features unique to the Mixture Profiler include:

- A ternary plot is used instead of a Cartesian plot. A ternary plot enables you to view three mixture factors at a time.
- If you have more than three factors, use the radio buttons at the top left of the Mixture Profiler window to graph other factors. For detailed explanation of radio buttons and plot axes, see “Explanation of Ternary Plot Axes” on page 110.
- If the factors have constraints, you can enter their low and high limits in the Lo Limit and Hi Limit columns. This shades non-feasible regions in the profiler. As in Contour Plot, low and high limits can also be set for the responses.
Example of the Mixture Profiler

In this example, you examine the impact of three components (p1, p2, and p3) on a plasticizer with response Y.

1. Select Help > Sample Data Library and open Plasticizer.jmp.
2. Select Graph > Mixture Profiler.
4. Select Y from the Y, Prediction Formula role and click Remove.
Note: The Y column role is set to Y in the Columns list. The role automatically assigns columns in launch windows. In this case, the Y column was assigned to the Y role when the mixture profiler was launched. However, the Y column does not contain a formula, and the Mixture Profiler Y column requires a formula column.

5. Click OK.

Figure 6.3 Example of Mixture Profiler

Use the factor sliders to explore how changes impact the response. The unshaded region is the feasible region for this data set.
Launch the Mixture Profiler Platform

The Mixture Profiler can be accessed in the following ways:

- The Mixture Profiler can be accessed directly from the Graph menu. When you access the Mixture Profiler in this way, the Mixture Profiler launch window appears. See “Profiler Launch Windows” on page 29 in the “Introduction to Profilers” chapter for details.

- The Mixture Profiler can be accessed as a red triangle menu option in many modeling platforms. See “Where to Find JMP Profilers” on page 28 in the “Introduction to Profilers” chapter for details about the availability of the Mixture Profiler in different platforms.

- The Mixture Profiler can be accessed from the Model Comparisons platform. Select Profiler from the Model Comparisons red triangle menu. Then, select Mixture Profiler from the Profiler red triangle menu.

- The Mixture Profiler can be accessed from the Formula Depot platform. Select Profiler from the Formula Depot red triangle menu and select the models to be profiled. Then, select Mixture Profiler from the Profiler red triangle menu.

The Mixture Profiler Report

The initial Mixture Profiler report shows a mixture profiler plot, factor settings and controls, and response settings and controls.

Factor Settings and Controls

**Figure 6.4 Factor Settings and Controls**

<table>
<thead>
<tr>
<th>T</th>
<th>L</th>
<th>R</th>
<th>Factor</th>
<th>Current X</th>
<th>Lo Limit</th>
<th>Hi Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>p1</td>
<td></td>
<td></td>
<td></td>
<td>0.645</td>
<td>0.474</td>
<td>0.649</td>
</tr>
<tr>
<td>p2</td>
<td></td>
<td></td>
<td></td>
<td>0.126</td>
<td>0</td>
<td>0.025</td>
</tr>
<tr>
<td>p3</td>
<td></td>
<td></td>
<td></td>
<td>0.2125</td>
<td>0.151</td>
<td>0.274</td>
</tr>
</tbody>
</table>

**T, L, R** Radio buttons to control factor assignments to the axes in the mixture profiler plot. **T** = top, **L** = left, and **R** = right.

**Factor** The list of factors.

**Current X** The current factor settings. Click in a box to change the value of a factor. The values for the other factors adjust proportionally to maintain the mixture sum. The slider controls can also be used to change factor settings.

**Lo Limit** The lower limit on each factor. Click in a box to change the value.

**Hi Limit** The upper limit on each factor. Click in a box to change the value.
Note: When factor limits are used, the profiler shows regions that are feasible as unshaded.

Change Opens the Factor Settings window. See “Mixture Profiler Platform Options” on page 112.

Response Settings and Controls

Figure 6.5 Response Settings and Controls

<table>
<thead>
<tr>
<th>Response</th>
<th>Contour</th>
<th>Current Y</th>
<th>Lo Limit</th>
<th>Hi Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pred Formula Y</td>
<td></td>
<td>12.5</td>
<td>19.269231</td>
<td></td>
</tr>
</tbody>
</table>

Response The list of one or more responses.

Contour The current value of the contour on the mixture profiler. Click in the box to change the value. The slider control can also be used to change the value of the contour.

Current Y The predicted response based on the current X settings. The value is at the center of the cross hairs on the profiler plot. This value updates as the factor settings are changed.

Lo Limit Enables you to set a lower limit for your response.

High Limit Enables you to set an upper limit for your response.

Note: When response limits are used, the profiler shows regions that are feasible as unshaded.

Explanation of Ternary Plot Axes

The sum of all mixture factor values in a mixture experiment is a constant, usually, and henceforth assumed to be 1. Each individual factor’s value can range between 0 and 1, and three are represented on the axes of the ternary plot.

For a three factor mixture experiment in which the factors sum to 1, the plot axes run from a vertex (where a factor’s value is 1 and the other two are 0) perpendicular to the other side (where that factor is 0 and the sum of the other two factors is 1). See Figure 6.6.

For example, in Figure 6.6, the proportion of p1 is 1 at the top vertex and 0 along the bottom edge. The tick mark labels are read along the left side of the plot. Similar explanations hold for p2 and p3.

For an explanation of ternary plot axes for experiments with more than three mixture factors, see “More Than Three Mixture Factors” on page 111.
Figure 6.6  Explanation of p1 Axis

More Than Three Mixture Factors

The ternary plot can show only three factors at a time. If there are more than three factors in the model that you are profiling, the total of the three on-axis (displayed) factors is 1 minus the total of the off-axis (non-displayed) factors. Also, the plot axes are scaled such that the maximum value a factor can attain is 1 minus the total for the off-axis factors.

For example Figure 6.7 shows the Mixture Profiler for an experiment with 5 factors. The Five Factor Mixture.jmp data table is being used, with the Y1 Predicted column as the formula. The on-axis factors are $x_1$, $x_2$, and $x_3$, and the factors $x_4$ and $x_5$ are off-axis. The value for $x_4$ is 0.1 and the value for $x_5$ is 0.2, for a total of 0.3. This means the sum of $x_1$, $x_2$, and $x_3$ has to equal $1 - 0.3 = 0.7$. In fact, their Current X values add to 0.7. Also, note that the maximum value for a plot axis is now 0.7, not 1.

If you change the value for either $x_4$ or $x_5$, then the values for $x_1$, $x_2$ and $x_3$ change, keeping their relative proportions, to accommodate the constraint that factor values sum to 1.
Figure 6.7 Scaled Axes to Account for Off-Axis Factors Total

Mixture Profiler Platform Options

The commands under the Mixture Profiler red triangle menu are explained below.

**Specify Factor Values**  Opens a dialog for specifying factor values. The entered values should sum to 1. If needed, JMP adjusts the specified values to feasible settings. The option is also available from the Change button on the report window.
Show Current Value  Shows or hides the three-way crosshairs on the plot. The intersection of the crosshairs represents the current factor values. The Current X values above the plot give the exact coordinates of the crosshairs.

Show Constraints  Shows or hides the shading resulting from any constraints on the factors. Those constraints can be entered in the Lo Limits and Hi Limits columns above the plot, or in the Mixture Column Property for the factors.

Up Dots  Shows or hides dotted line corresponding to each contour. The dotted lines show the direction of increasing response values, so that you get a sense of direction.

Contour Grid  Draws contours on the plot at intervals that you specify.

Remove Contour Grid  Removes the contour grid if one is on the plot.

Factor Settings  Is a submenu of commands that enables you to save and transfer the Mixture Profiler settings to other parts of JMP. Details on this submenu are found in the discussion of the profiler on “Factor Settings” on page 45.

Customizations for the Mixture Profiler

Customize the Mixture Profiler by right-clicking on the plot, and selecting Customize.

Choose from the following property options:

Contour  Alter line color, fill color, and level of line transparency. If there are multiple contour lines on the plot, each appears individually on the list of options.

Component Constraints  Alter component constraint properties.

Linear Constraints  Alter linear constraint properties.

Grid Lines  Use Axis Settings window to modify grid lines.

Reference Lines  Use Axis Settings window to modify reference lines.

Double-click an axis on the plot to view the Axis Settings window. Here you can specify axis properties in detail, such as tick marks, grid lines and reference lines.

Crosshairs  Alter the properties of the crosshairs on the plot.

Marker  Alter the properties of the plot marker.

Linear Constraints

The Mixture Profiler can incorporate linear constraints into its operations. To do this, a Constraint Table Script must be part of the data table. For more information about creating the Table Script, see “Linear Constraints” on page 35 in the “Introduction to Profilers” chapter.
When using constraints, unfeasible regions are shaded in the profiler. Figure 6.8 shows an example of a mixture profiler with shaded regions due to four constraints. The unshaded portion is the resulting feasible region. The constraints are below:

- $4p_2 + p_3 \leq 0.8$
- $p_2 + 1.5p_3 \leq 0.4$
- $p_1 + 2p_2 \geq 0.8$
- $p_1 + 2p_2 \leq 0.95$

Figure 6.8 Shaded Regions Due to Linear Constraints

Additional Examples of the Mixture Profiler Platform

This section contains two examples of the Mixture Profiler.

**Single Response**

This example, adapted from Cornell (1990), comes from an experiment to optimize the texture of fish patties. The data is in Fish Patty.jmp. The columns Mullet, Sheepshead, and Croaker represent what proportion of the patty came from that fish type. The column Temperature represents the oven temperature used to bake the patties. The column Rating is the response and is a measure of texture acceptability, where higher is better. A response surface model was fit to the data and the prediction formula was stored in the column Predicted Rating.

To launch the Mixture Profiler, select **Graph > Mixture Profiler**. Assign Predicted Rating to **Y, Prediction Formula** and click **OK**. The output should appear as in Figure 6.9.
The manufacturer wants the rating to be at least 5. Use the slider control for Predicted Rating to move the contour close to 5. Alternatively, you can enter 5 in the Contour edit box to bring the contour to a value of 5. Figure 6.10 shows the resulting contour.
The Up Dots shown in Figure 6.10 represent the direction of increasing Predicted Rating. Enter 5 in the Lo Limit edit box. The resulting shaded region shown in Figure 6.11 represents factor combinations that yield a rating less than 5. To produce patties with at least a rating of 5, the manufacturer can set the factors values anywhere in the feasible (unshaded) region.

The feasible region represents the factor combinations predicted to yield a rating of 5 or more. Notice the region has small proportions of Croaker (<10%), mid to low proportions of Mullet (<70%) and mid to high proportions of Sheepshead (>30%).
Figure 6.11  Contour Shading Showing Predicted Rating of 5 or More.

Up to this point the fourth factor, Temperature, has been held at 400 degrees. Move the slide control for Temperature and watch the feasible region change.

Additional analyses might include:

- Optimize the response across all four factors simultaneously. See the “Custom Profiler” chapter on page 123 or “Desirability Profiling and Optimization” on page 47 in the “Profiler” chapter.
- Simulate the response as a function of the random variation in the factors and model noise. See the “Simulator” chapter on page 129.
Multiple Responses

This example uses data from Five Factor Mixture.jmp. There are five continuous factors (x1–x5), one categorical factor (Type), and three responses, Y1, Y2, and Y3. A response surface model is fit to each response and the prediction equations are saved in Y1 Predicted, Y2 Predicted and Y3 Predicted.

Launch the Mixture Profiler and assign the three prediction formula columns to the Y, Prediction Formula role, and click OK. Enter 3 in the Contour edit box for Y3 Predicted so that the contour shows on the plot. The output appears in Figure 6.12.

Figure 6.12 Initial Output Window for Five Factor Mixture
A few items to note about the output in Figure 6.12.

- All the factors appear at the top of the window. The mixture factors have low and high limits, which were entered previously as a Column Property. See The Column Info Window chapter in the Using JMP book for more information about entering column properties. Alternatively, you can enter the low and high limits directly by entering them in the Lo Limit and Hi Limit boxes.

- Certain regions of the plot are shaded in gray to account for the factor limits.

- The on-axis factors, \(x_1\), \(x_2\), and \(x_3\), radio buttons are selected.

- The categorical factor, Type, has a radio button, but it cannot be assigned to the plot. The current value for Type is L1, which is listed immediately to the right of the Current X box. The Current X box for Type uses a 0 to represent L1.

- All three prediction equations have contours on the plot and are differentiated by color.

A manufacturer desires to hold \(Y_1\) less than 1, hold \(Y_2\) greater than 8 and hold \(Y_3\) between 4 and 5, with a target of 4.5. Furthermore, the low and high limits on the factors need to be respected. The Mixture Profiler can help you investigate the response surface and find optimal factor settings.

Start by entering the response constraints into the Lo Limit and Hi Limit boxes, as shown in Figure 6.13. Colored shading appears on the plot and designates unfeasible regions. The feasible region remains white (unshaded). Use the Response slider controls to position the contours in the feasible region.
Figure 6.13 Response Limits and Shading

The feasible region is small. Use the magnifier tool to zoom in on the feasible region shown with a box in Figure 6.13. The enlarged feasible region is shown in Figure 6.14.
The manufacturer wants to maximize Y1, minimize Y2, and have Y3 at 4.5.

- Use the slider controls or Contour edit boxes for Y1 Predicted to maximize the red contour within the feasible region. Keep in mind the Up Dots show direction of increasing predicted response.

- Use the slider controls or Contour edit boxes for Y2 Predicted to minimize the green contour within the unshaded region.

- Enter 4.5 in the Contour edit box for Y3 Predicted to bring the blue contour to the target value.

The resulting three contours do not all intersect at one spot, so you have to compromise. Position the three-way crosshairs in the middle of the contours to understand the factor levels that produce those response values.
Figure 6.15 Factor Settings

As shown in Figure 6.15, the optimal factor settings can be read from the Current X boxes. The factor values above hold for the current settings of $x_4$, $x_5$, and Type. Select Factor Settings > Remember Settings from the Mixture Profiler red triangle menu to save the current settings. The settings are appended to the bottom of the report window and appear as shown below.

Figure 6.16 Remembered Settings

With the current settings saved, you can now change the values of $x_4$, $x_5$, and Type to see what happens to the feasible region. You can compare the factor settings and response values for each level of Type by referring to the Remembered Settings report.
The Custom Profiler enables you to optimize factor settings without graphical output. This is useful for large problems that would have too many graphs to visualize well.

**Figure 7.1** Custom Profiler Example
Custom Profiler Overview

The Custom Profiler enables you to optimize factor settings without graphical output. The Custom Profiler can be used for problems of any size. It is especially useful for large problems where the standard graphical profiler has too many graphs to visualize well.

The Custom Profiler report has many fields in common with other profilers. The Benchmark field holds a value, or benchmark, of the predicted response. You can compare new results to the benchmark value and update the value based on the current factor settings.

The Optimization report enables you to specify the formula to be optimized and specifications for the optimization.

Figure 7.2 Custom Profiler

Example of the Custom Profiler

This example uses data that demonstrates the flow of water through a borehole that is drilled from the ground surface through two aquifers. You want to optimize the predicted value.

1. Select Help > Sample Data Library > Design Experiment and open Borehole Latin Hypercube.jmp
2. Select Graph > Custom Profiler.
3. Select prediction formula and click Y, Prediction Formula.
4. Click OK.

Note that the Benchmark value is 70.83. The Current Y value is also 70.83. This value is the predicted response with all factors set to their mean values.

5. In the Custom Profiler Report, click Optimize.

The optimization routine found an optimum predicted response at 311.17. In order to obtain the optimum of 311.17, all factors are set either at their minimum or maximum values. The optimum is greater than the initial Benchmark value of 70.83.
Launch the Custom Profiler Platform

The Custom Profiler can be accessed in the following ways:

- The Custom Profiler can be accessed directly from the Graph menu. When you access the Custom Profiler in this way, the Custom Profiler launch window appears. See “Profiler Launch Windows” on page 29 in the “Introduction to Profilers” chapter for details.

- The Custom Profiler can be accessed as a red triangle menu option in many modeling platforms. See “Where to Find JMP Profilers” on page 28 in the “Introduction to Profilers” chapter for details about the availability of the Custom Profiler in different platforms.

- The Custom Profiler can be accessed from the Model Comparisons platform. Select Profiler from the Model Comparisons red triangle menu. Then, select Custom Profiler from the Profiler red triangle menu.

- The Custom Profiler can be accessed from the Formula Depot platform. Select Profiler from the Formula Depot red triangle menu and select the models to be profiled. Then, select Custom Profiler from the Profiler red triangle menu.

The Custom Profiler Report

The initial Custom Profiler report shows settings and controls for the factors, responses, and optimization.

Factor Settings and Controls

**Figure 7.5  Factor Settings and Controls**

<table>
<thead>
<tr>
<th>Factor</th>
<th>Current X</th>
<th>Lock</th>
<th>Lo Limit</th>
<th>Hi Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rw</td>
<td>0.1513561</td>
<td>0.0501187</td>
<td>0.1513561</td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>100</td>
<td>100</td>
<td>50118.723</td>
<td>115600</td>
</tr>
<tr>
<td>Tu</td>
<td>115600</td>
<td>62070</td>
<td>115600</td>
<td></td>
</tr>
<tr>
<td>Hu</td>
<td>1110</td>
<td>990</td>
<td>1110</td>
<td></td>
</tr>
<tr>
<td>HI</td>
<td>700</td>
<td>700</td>
<td>820</td>
<td></td>
</tr>
<tr>
<td>L</td>
<td>1120</td>
<td>1120</td>
<td>1680</td>
<td></td>
</tr>
<tr>
<td>Kw</td>
<td>12045</td>
<td>9835</td>
<td>12045</td>
<td></td>
</tr>
<tr>
<td>log_{10} R</td>
<td>2</td>
<td>2</td>
<td>4.7</td>
<td></td>
</tr>
</tbody>
</table>

**Factor**  The list of model factors.

**Current X**  The current value of each factor. Click in a box to change the value of a factor. The slider controls can also be used to change factor settings.

**Lock**  Enables you to lock a factor so that it is fixed when the optimization is performed. You can change a locked factor using the slider or clicking in the box in the Current X column. The lock applies only to the optimization.
Nominal Column  Unlabeled column to the right of the Lock column that lists the current value of nominal factors.

Note: The Current X column for nominal factors displays a coded (numeric) value for the current nominal factor.

Lo Limit  The lower limit for each factor. Click in a box to change the value.
High Limit  The upper limit for each factor. Click in a box to change the value.

Response Settings and Controls

Figure 7.6  Response Settings and Controls

<table>
<thead>
<tr>
<th>Response</th>
<th>Current Y</th>
<th>Lo Limit</th>
<th>Hi Limit</th>
<th>Benchmark</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>311.17206</td>
<td></td>
<td></td>
<td>70.8.26925</td>
</tr>
</tbody>
</table>

Response  The list of one or more responses.
Current Y  The predicted response based on the current X settings. This value updates as the factor settings are changed.
Lo Limit  Enables you to set a lower limit for your response.
High Limit  Enables you to set an upper limit for your response.
Benchmark  A saved predicted value of the response. Initially, this value is set to the predicted value when all responses are at their mean value.
Reset Benchmark  Updates the benchmark value to the current predicted value.

Optimization Settings and Controls

Figure 7.7  Optimization Settings and Controls

<table>
<thead>
<tr>
<th>Objective</th>
<th>Trips</th>
<th>Max Cycles</th>
<th>Max Iter</th>
<th>Convergence Limit</th>
<th>Convergence Criterion</th>
</tr>
</thead>
<tbody>
<tr>
<td>311.17200129</td>
<td>20</td>
<td>50</td>
<td>250</td>
<td>0.0000001</td>
<td>0</td>
</tr>
</tbody>
</table>

Formula  The formula to be optimized. When a single response is used, the expression is the response column name. When multiple responses are used, the expression is a sum of desirability functions. You can edit the objective expression.
Objective  The current value of the objective function. When a single response is used, the objective expression is the predicted response. When multiple responses are used, the
objective expression is the desirability function. For more information about desirability functions, see “Desirability Profiling and Optimization” on page 47 in the “Profiler” chapter.

**Trips**  The number of random starts in the optimization algorithm. Each trip restarts the algorithm at a different starting point. This guards against finding local solutions.

**Max Cycles**  The maximum number of cycles used in the optimization algorithm. Each cycle is single pass through the input parameters and optimizes each one individually.

**Max Iter**  The maximum number of optimization iterations per cycle for each input parameter.

**Convergence Limit**  The upper limit for the convergence criterion for the optimization algorithm. If the convergence criterion becomes less than this value, the algorithm stops.

**Convergence Criterion**  The value of the convergence criterion for the optimization algorithm.

**Maximize**  Enables you to choose to maximize or minimize the objective function.

**Optimize**  Starts the optimization algorithm.

---

**Custom Profiler Platform Options**

**Factor Settings**  Contains options identical to the Factor Settings submenu in the Prediction Profiler. See “Factor Settings” on page 45 in the “Profiler” chapter.

**Log Iterations**  Creates a data table that contains iterations of the optimization algorithm. The data table appears after the **Optimize** button is clicked.

**Alter Linear Constraints**  Enables you to add, change, or delete linear constraints. The constraints are used in the Custom Profiler. See “Linear Constraints” on page 35 in the “Introduction to Profilers” chapter.

**Save Linear Constraints**  Saves existing linear constraints as a data table script that is named Constraint. See “Linear Constraints” on page 35 in the “Introduction to Profilers” chapter.

**Simulator**  Launches the Simulator. See Chapter 8, “Simulator”.
Simulation enables you to discover the distribution of model outputs as a function of the random variation in the factors and model noise. The simulator in the profilers provides a way to set up the random inputs and run the simulations, producing an output table of simulated values. In the Profiler, the Simulator is integrated into the graphical layout. Factor specifications are aligned below each factor’s profile. A simulation histogram is shown on the right for each response.

Figure 8.1 Profiler with Simulator Example
Simulation enables you to discover the distribution of model outputs as a function of the random variation in the factors and model noise. The simulator in the profilers provides a way to set up the random inputs and run the simulations, producing an output table of simulated values.

An example of the simulator would be to model the defect rate of a process, and see how robust the defect rate is with respect to variation in the model factors. If specification limits have been set for the responses, they are carried over into the simulation output. The inclusion of specification limits allows for a prospective capability analysis of the simulated model.

In the Profiler, the Simulator is integrated into the graphical layout. Factor specifications are aligned below each factor’s profile. A simulation histogram is shown on the right for each response.

The profiler simulator supports mixture terms. The simulation assigns the random value to each mixture factor and then proportionally adjusts the values to maintain the factor constraints.
In the contour and custom profilers, the Simulator is less graphical, and kept separate. There are no integrated histograms, and the interface is textual. However, the internals and output tables are the same.
Example of the Simulator

Tip: The Make Table and Sequencing options are most useful when you have random values. Sequencing options are available for the following distributions only: Normal, Uniform, and Triangular.

Specify the number of runs in the simulation by entering it in the N Runs box.

After the factor and response distributions are set, click the Simulate button to run the simulation. Or, use the Make Table button to create a table with N Runs for the number of rows. Each row is populated with a random draw from the specified distributions, and the corresponding response values are computed. If spec limits are given, the table also contains a column specifying whether a row is in or out of spec.

Use sequencing to examine how the distribution of the response changes when the mean (sequencing location) and variability (sequencing spread) of the inputs change.

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Select Graph > Profiler.
3. Select Pred Formula ABRASION and Pred Formula MODULUS and click Y, Prediction Formula.
4. Click OK.
5. From the red triangle menu next to Prediction Profiler, select Simulator.
6. Change each factor to be Random instead of Fixed.
7. Change the N Runs value to 100.
8. Open Simulate to Table then Sequencing.
You want to examine how the responses change when the mean values change.

9. For SILICA, select **Sequence Location**. Keep the number of steps at 5. Because the mean is 1.25, change the values over a range of 1 (lower) to 2 (upper).

10. For SILANE, select **Sequence Location**. Keep the number of steps at 5. Because the mean is 50, change the values over a range of 40 (lower) to 50 (upper).

11. For SULFUR, select **Sequence Location**. Keep the number of steps at 5. Because the mean is 2.25, change the values over a range of 2 (lower) to 3 (upper).

**Figure 8.4  Sequencing Settings**

12. Click **Make Table**.

You can see that the SILICA Mean, SILANE Mean, and SULFUR Mean columns contain five steps for each range of values (Silica Mean is 1, 1.25, 1.5, 1.75, and 2; Silane Mean is 40, 42.5, 45, 47.5, and 50; and so on.) Pred Formula ABRASION and Pred Formula MODULUS values are calculated for each combination of values, so you can see how the responses change as the factor values change.

13. Select **Analyze > Distribution**.
14. Select Pred Formula ABRASION and SILICA Mean and click Y, Columns.
15. Click OK.

**Figure 8.5** Distribution of SILICA Mean by Pred Formula ABRASION

Click a histogram bar that corresponds to a SILICA mean to see how the prediction formula for ABRASION changes given the selected mean.

---

**Specify Factors**

Factors (inputs) and responses (outputs) are already given roles by being in the Profiler. Additional specifications for the simulator are on how to give random values to the factors, and add random noise to the responses.

For each factor, the choices of how to give values are as follows:

**Fixed**  Fixes the factor at the specified value. The initial value is the current value in the profiler, which might be a value obtained through optimization.

**Random**  Gives the factor the specified distribution and distributional parameters.

See the Formula Functions Reference chapter in the *Using JMP* book for descriptions of most of these random functions. If the factor is categorical, then the distribution is characterized by probabilities specified for each category, with the values normalized to sum to 1.

**Normal weighted**  is normally distributed with the given mean and standard deviation, but a special stratified and weighted sampling system is used to simulate very rare events far
out into the tails of the distribution. This is a good choice when you want to measure very low defect rates accurately. See “Statistical Details for the Simulator” on page 159.

**Normal truncated** is a normal distribution limited by lower and upper limits. Any random realization that exceeds these limits is discarded and the next variate within the limits is chosen. This is used to simulate an inspection system where inputs that do not satisfy specification limits are discarded or sent back.

**Normal censored** is a normal distribution limited by lower and upper limits. Any random realization that exceeds a limit is just set to that limit, putting a density mass on the limits. This is used to simulate a re-work system where inputs that do not satisfy specification limits are reworked until they are at that limit.

**Sampled** means that JMP selects values at random from that column in the data table.

**External** means that JMP selects values at random from a column in another table. You are prompted to choose the table and column.

The **Aligned** check box is used for two or more Sampled or External sources. When checked, the random draws come from the same row of the table. This is useful for maintaining the correlation structure between two columns. If the Aligned option is used to associate two columns in different tables, the columns must have equal number of rows.

In the Profiler, a graphical specification shows the form of the density for the continuous distributions, and provides control points that can be dragged to change the distribution. The drag points for the Normal are the mean and the mean plus or minus one standard deviation. The Normal truncated and censored add points for the lower and upper limits. The Uniform and Triangular have limit control points, and the Triangular adds the mode.

**Figure 8.6** Distributions

**Expression** Allows you to write your own expression in JMP Scripting Language (JSL) form into a field. This gives you flexibility to make up a new random distribution. For example, you could create a censored normal distribution that guaranteed nonnegative values with an expression like `Max(0, RandomNormal(5, 2))`. In addition, character results are supported, so `If(Random Uniform() < 0.2, "M", "F")` works fine. After entering the expression, click the **Reset** button to submit the expression.
**Multivariate**  Allows you to generate a multivariate normal for when you have correlated factors. Specify the mean and standard deviation with the factor, and a correlation matrix separately.

**Figure 8.7** Using a Correlation Matrix

Simulator Report Options

The following options are available from the Simulator red triangle menu:

- **Automatic Histogram Update**  Toggles histogram update, which sends changes to all histograms shown in the Profiler, so that histograms update with new simulated values when you drag distribution handles.

- **Defect Profiler**  Shows the defect rate as an isolated function of each factor. This command is enabled when spec limits are available, as described below.

- **Defect Parametric Profile**  Shows the defect rate as an isolated function of the parameters of each factor’s distribution. It is enabled when the Defect Profiler is launched.

- **N Strata**  Is a hidden option accessible by holding down the Shift key before clicking the Simulator red triangle menu. This option enables you to specify the number of strata in Normal Weighted. For more information also see “Statistical Details for the Simulator” on page 159.

- **Set Random Seed**  Is a hidden option accessible by holding down the Shift key before clicking the Simulator red triangle menu. This option enables you to specify a seed for the simulation starting point. This enables the simulation results to be reproducible, unless the seed is set to zero. The seed is set to zero by default. If the seed is nonzero, then the latest simulation results are output if the Make Table button is clicked.

- **Simulation Experiment**  Runs a designed simulation experiment on the locations of the factor distributions. A window appears, allowing you to specify the number of design points, the portion of the factor space to be used in the experiment, and which factors to include in the experiment. For factors not included in the experiment, the current value shown in the Profiler is the one used in the experiment. For more information, see “Simulation Experiment” on page 145.

- **Spec Limits**  Opens a table to set or edit specification limits.
Responses Report Options

If the model is only partly a function of the factors, and the rest of the variation of the response is attributed to random noise, then you will want to specify this with the responses. The choices are:

**No Noise**  Evaluates the response from the model, with no additional random noise added.

**Add Random Noise**  Obtains the response by adding a normal random number with the specified standard deviation to the evaluated model.

**Add Random Weighted Noise**  Is distributed like Add Random Noise, but with weighted sampling to enable good extreme tail estimates.

**Add Multivariate Noise**  Yields a response as follows: A multivariate random normal vector is obtained using a specified correlation structure, and it is scaled by the specified standard deviation and added to the value obtained by the model.

Simulate to Table Report Options

Saves the results of the simulation to a data table. If a response has specification limits, the table includes a Y in Spec column that indicates if the simulated response is within the specification limits.

Sequencing Report Options

The sequencing allows you to run multiple simulations and save them to a data table. Select an option to sequence the location or spread of the term. Select the number of steps and the range for the sequencing. For each combination of the number of steps the simulation will run N Runs. If you have two terms, each with 5 steps, and N Runs = 100 the resulting simulation table will have 2,500 rows.

Spec Limits Report Options

Allows you to enter or edit specification limits responses. Click the Save button to save specification limits to the response column properties in the data table.

Specification Limits

The profilers support specification limits on the responses, providing a number of features

- In the Profiler, if you do not have the Response Limits property set up in the input data table to provide desirability coordinates, JMP looks for a Spec Limits property and constructs desirability functions appropriate to those Spec Limits.
• If you use the Simulator to output simulation tables, JMP copies Spec Limits to the output data tables, making accounting for defect rates and capability indices easy.

• Adding Spec Limits enables a feature called the Defect Profiler.

In the following example, we assume that the following Spec Limits have been specified.

Table 8.1 Spec Limits for Tiretread.jmp Data Table

<table>
<thead>
<tr>
<th>Response</th>
<th>LSL</th>
<th>USL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abrasion</td>
<td>110</td>
<td></td>
</tr>
<tr>
<td>Modulus</td>
<td></td>
<td>2000</td>
</tr>
<tr>
<td>Elong</td>
<td>350</td>
<td>550</td>
</tr>
<tr>
<td>Hardness</td>
<td>66</td>
<td>74</td>
</tr>
</tbody>
</table>

To set these limits in the data table, highlight a column and select Cols > Column Info. Then, click the Column Properties button and select the Spec Limits property.

If you are already in the Simulator in a profiler, another way to enter them is to use the Spec Limits command in the Simulator red triangle menu.

Figure 8.8 Spec Limits

After entering the spec limits, they are incorporated into the profilers. Click the Save button if you want the spec limits saved back to the data table as a column property.

With these specification limits, and the distributions shown in Figure 8.2, click the Simulate button. Notice the colored spec limit lines in the output histograms. The black dashed lines indicate the mean of the simulations.
Look at the histogram for Abrasion. The lower spec limit is far below the distribution, yet the Simulator is able to estimate a defect rate for it. This despite only having 5000 runs in the simulation. It can do this rare-event estimation when you use a Normal weighted distribution.

Note that the Overall defect rate (0.05229) is close to the defect rate for ELONG (0.04756), indicating that most of the defects are in the ELONG variable.

To see this weighted simulation in action, click the Make Table button and examine the Weight column.

JMP generates extreme values for the later observations, using very small weights to compensate. Because the Distribution platform handles frequencies better than weights, there is also a column of frequencies, which is simply the weights multiplied by $10^{12}$.

The output data set contains a Distribution script appropriate to analyze the simulation data completely with a capability analysis.

**Simulate General Formulas**

Though the profiler and simulator are designed to work from formulas stored from a model fit, they work for any formula that can be stored in a column. A typical application of simulation is to exercise financial models under certain probability scenarios to obtain the
distribution of the objectives. This can be done in JMP—the key is to store the formulas into columns, set up ranges, and then conduct the simulation.

Table 8.2 Factors and Responses for a Financial Simulation

<table>
<thead>
<tr>
<th>Inputs (Factors)</th>
<th>Unit Sales</th>
<th>random uniform between 1000 and 2000</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Unit Price</td>
<td>fixed</td>
</tr>
<tr>
<td></td>
<td>Unit Cost</td>
<td>random normal with mean 2.25 and std dev 0.1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Outputs (Responses)</th>
<th>Revenue</th>
<th>formula: Unit Sales*Unit Price</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Total Cost</td>
<td>formula: Unit Sales*Unit Cost + 1200</td>
</tr>
<tr>
<td></td>
<td>Profit</td>
<td>formula: Revenue – Total Cost</td>
</tr>
</tbody>
</table>

The following JSL script creates the data table below with some initial scaling data and stores formulas into the output variables. It also launches the Profiler.

```javascript
dt = New Table( "Sales Model" );
dt << New Column( "Unit Sales", Values( {1000, 2000} ) );
dt << New Column( "Unit Price", Values( {2, 4} ) );
dt << New Column( "Unit Cost", Values( {2, 2.5} ) );
dt << New Column( "Revenue", Formula( :Unit Sales * :Unit Price ) );
dt << New Column( "Total Cost", Formula( :Unit Sales * :Unit Cost + 1200 ) );
dt << New Column( "Profit", Formula( :Revenue - :Total Cost ), Set Property( "Spec Limits", {LSL( 0 )} ) );
Profiler( Y( :Revenue, :Total Cost, :Profit ), Objective Formula( Profit ) );
```
Once they are created, select the **Simulator** from the Prediction Profiler. Use the specifications from Figure 8.11 to fill in the Simulator.

**Figure 8.11** Specifications for Profiler

Now, run the simulation, which produces the following histograms in the Profiler.
Note: Your numbers might differ from those shown in Figure 8.12.

It looks like we are not very likely to be profitable. By putting a lower specification limit of zero on Profit, the defect report would say that the probability of being unprofitable is 62%.

So we raise the Unit Price to $3.25 and rerun the simulation. Now the probability of being unprofitable is down to about 20%.

Figure 8.13 Results

If unit price cannot be raised anymore, you should now investigate lowering your cost, or increasing sales, if you want to further decrease the probability of being unprofitable.

Defect Profiler

The defect profiler shows the probability of an out-of-spec output defect as a function of each factor, while the other factors vary randomly. This is used to help visualize which factor’s
distributional changes the process is most sensitive to, in the quest to improve quality and decrease cost.

Specification limits define what is a defect, and random factors provide the variation to produce defects in the simulation. Both need to be present for a Defect Profile to be meaningful.

At least one of the Factors must be declared Random for a defect simulation to be meaningful, otherwise the simulation outputs would be constant. These are specified though the simulator Factor specifications.

**Important:** If you need to estimate very small defect rates, use **Normal weighted** instead of just **Normal**. This allows defect rates of just a few parts per million to be estimated well with only a few thousand simulation runs.

**About Tolerance Design**

*Tolerance Design* is the investigation of how defect rates on the outputs can be controlled by controlling variability in the input factors.

The input factors have variation. Specification limits are used to tell the supplier of the input what range of values are acceptable. These input factors then go into a process producing outputs, and the customer of the outputs then judges if these outputs are within an acceptable range.

Sometimes, a Tolerance Design study shows that spec limits on input are unnecessarily tight, and loosening these limits results in cheaper product without a meaningful sacrifice in quality. In these cases, Tolerance Design can save money.

In other cases, a Tolerance Design study might find that either tighter limits or different targets result in higher quality. In all cases, it is valuable to learn which inputs the defect rate in the outputs are most sensitive to.

This graph shows the defect rate as a function of each factor as if it were a constant, but all the other factors varied according to their random specification. If there are multiple outputs with Spec Limits, then there is a defect rate curve color-coded for each output. A black curve shows the overall defect rate—this curve is above all the colored curves.
Simulator  
Defect Profiler

Chapter 8  
Profilers

Figure 8.14 Defect Profiler

Graph Scale

Defect rates are shown on a cubic root scale, so that small defect rates are shown in some detail even though large defect rates might be visible. A log scale is not used because zero rates are not uncommon and need to be shown.

Expected Defects

Reported below each defect profile plot is the mean and standard deviation (SD). The mean is the overall defect rate, calculated by integrating the defect profile curve with the specified factor distribution.

In this case, the defect rate that is reported below all the factors is estimating the same quantity, the rate estimated for the overall simulation below the histograms (that is, if you clicked the Simulate button). Because each estimate of the rate is obtained in a different way, they might be a little different. If they are very different, you might need to use more simulation runs. In addition, check that the range of the factor scale is wide enough so that the integration covers the distribution well.

The standard deviation is a good measure of the sensitivity of the defect rates to the factor. It is quite small if either the factor profile were flat, or the factor distribution has a very small variance. Comparing SD's across factors is a good way to know which factor should get more attention to reducing variation.

The mean and SD are updated when you change the factor distribution. This is one way to explore how to reduce defects as a function of one particular factor at a time. You can click and drag a handle point on the factor distribution, and watch the mean and SD change as you
drag. However, changes are not updated across all factors until you click the Rerun button to do another set of simulation runs.

**Simulation Method and Details**

Assume we want a defect profile for factor \( X_1 \), in the presence of random variation in \( X_2 \) and \( X_3 \). A series of \( n=N \) Runs simulation runs is done at each of \( k \) points in a grid of equally spaced values of \( X_1 \). (\( k \) is generally set at 17.) At each grid point, suppose that there are \( m \) defects due to the specification limits. At that grid point, the defect rate is \( m/n \). With normal weighted, these are done in a weighted fashion. These defect rates are connected and plotted as a continuous function of \( X_1 \).

**Notes**

**Recalculation**  The profile curve is not recalculated automatically when distributions change, though the expected value is. It is done this way because the simulations could take a while to run.

**Limited goals**  Profiling does not address the general optimization problem, that of optimizing quality against cost, given functions that represent all aspects of the problem. This more general problem would benefit from a surrogate model and space filling design to explore this space and optimize to it.

**Jagged Defect Profiles**  The defect profiles tend to get uneven when they are low. This is due to exaggerating the differences for low values of the cubic scale. If the overall defect curve (black line) is smooth, and the defect rates are somewhat consistent, then you are probably taking enough runs. If the Black line is jagged and not very low, then increase the number of runs. 20,000 runs is often enough to stabilize the curves.

**Simulation Experiment**

Used to run a designed simulation experiment on the locations of the factor distributions. A window appears, allowing you to specify the number of design points, the portion of the factor space to be used in the experiment, and which factors to include in the experiment. For factors not included in the experiment, the current value shown in the Profiler is the one used in the experiment.

The experimental design is a Latin Hypercube. The output has one row for each design point. The responses include the defect rate for each response with spec limits, and an overall defect rate. After the experiment, it would be appropriate to fit a Gaussian Process model on the overall defect rate, or a root or a logarithm of it.

A simulation experiment does not sample the factor levels from the specified distributions. As noted above, the design is a Latin Hypercube. At each design point, \( N \) Runs random draws
are generated with the design point serving as the center of the random draws, and the shape
and variability coming from the specified distributions.

**Additional Examples of the Simulator**

This section contains additional examples of the Simulator feature in the Prediction Profiler.

**Example of the Defect Profiler**

To show a common workflow with the Defect profiler, we use Tiretread.jmp. The experimental
data in the Tiretread.jmp sample data table results from an experiment to study the effects of
SILICA, SILANE, and SULFUR on four measures of tire tread performance.

1. Select **Help > Sample Data Library** and open Tiretread.jmp.
2. Select **Graph > Profiler**.
3. Select **Pred Formula ABRASION**, **Pred Formula MODULUS**, **Pred Formula ELONG**, and **Pred Formula HARDNESS** and click **Y, Prediction Formula**.
4. Click **OK**.
5. From the Prediction Profiler’s red triangle menu, select **Simulator**.
6. Select **Spec Limits** from the Simulator red triangle menu.
7. For each response, enter the spec limits as shown in Figure 8.8 on page 138. Click **Save**.
8. For each factor, enter the random specifications as shown in Figure 8.15.

**Figure 8.15** Profiler Random Specifications

9. Select **Defect Profiler** from the Simulator red triangle menu to see the defect profiles. The
curves, Means, and SDs will change from simulation to simulation, but will be relatively
consistent.
Figure 8.16  Defect Profiler

The black curve on each factor shows the defect rate if you could fix that factor at the $x$-axis value, but leave the other features random.

Look at the curve for SILICA. As its values vary, its defect rate goes from the lowest 0.001 at SILICA=0.95, quickly up to a defect rate of 1 at SILICA=0.4 or 1.8. However, SILICA is itself random. If you imagine integrating the density curve of SILICA with its defect profile curve, you could estimate the average defect rate 0.033, also shown as the Mean for SILICA. This is estimating the overall defect rate shown under the simulation histograms, but by numerically integrating, rather than by the overall simulation. The Means for the other factors are similar. The numbers are not exactly the same. However, we now also get an estimate of the standard deviation of the defect rate with respect to the variation in SILICA. This value (labeled SD) is 0.057. The standard deviation is intimately related to the sensitivity of the defect rate with respect to the distribution of that factor.

Looking at the SDs across the three factors, we see that the SD for SULFUR is higher than the SD for SILICA, which is in turn much higher than the SD for SILANE. This means that to improve the defect rate, improving the distribution in SULFUR should have the greatest effect. A distribution can be improved in three ways: changing its mean, changing its standard deviation, or by chopping off the distribution by rejecting parts that do not meet certain specification limits.

10. Select Defect Parametric Profile from the Simulator red triangle menu. This command shows how single changes in the factor distribution parameters affect the defect rate.
Let’s look closely at the SULFUR situation. You might need to enlarge the graph to see more detail.

First, note that the current defect rate (0.03) is represented in four ways corresponding to each of the four curves.

For the red curve, Mean Shift, the current rate is where the red solid line intersects the vertical red dotted line. The Mean Shift curve represents the change in overall defect rate by changing the mean of SULFUR. One opportunity to reduce the defect rate is to shift the mean slightly to the left. If you use the crosshair tool on this plot, you see that a mean shift reduces the defect rate to about 0.02.

For the blue curve, Std Narrow, the current rate represents where the solid blue line intersects the two dotted blue lines. The Std Narrow curves represent the change in defect rate by changing the standard deviation of the factor. The dotted blue lines represent one standard deviation below and above the current mean. The solid blue lines are drawn symmetrically around the center. At the center, the blue line typically reaches a minimum, representing the defect rate for a standard deviation of zero. That is, if we totally eliminate variation in SULFUR, the defect rate is still around 0.003. This is much better than 0.03. If you look at the other Defect parametric profile curves, you can see that this is better than
reducing variation in the other factors, something that we suspected by the SD value for SULFUR.

For the green curve, LSL Chop, there are no interesting opportunities in this example, because the green curve is above current defect rates for the whole curve. This means that reducing the variation by rejecting parts with too-small values for SULFUR will not help.

For the orange curve, USL Chop, there are good opportunities. Reading the curve from the right, the curve starts out at the current defect rate (0.03), then as you start rejecting more parts by decreasing the USL for SULFUR, the defect rate improves. However, moving a spec limit to the center is equivalent to throwing away half the parts, which might not be a practical solution.

Looking at all the opportunities over all the factors, it now looks like there are two good options for a first move: change the mean of SILICA to about 1, or reduce the variation in SULFUR. Because it is generally easier in practice to change a process mean than process variation, the best first move is to change the mean of SILICA to 1.

11. Adjust the Mean of SILICA from 1.2 to 1.0. Click Rerun.

**Figure 8.18** Adjusting the Mean of SILICA

![Figure 8.18](image)

After clicking Rerun, we get a new perspective on defect rates.
Now, the defect rate is down to about 0.004, much improved. Further reduction in the defect rate can occur by continued investigation of the parametric profiles, making changes to the distributions, and rerunning the simulations.

As the defect rate is decreased further, the mean defect rates across the factors become relatively less reliable. The accuracy could be improved by reducing the ranges of the factors in the Profiler a little so that it integrates the distributions better.

This level of fine-tuning is probably not practical, because the experiment that estimated the response surface is probably not at this high level of accuracy. Once the ranges have been refined, you might need to conduct another experiment focusing on the area that you know is closer to the optimum.

**Example of Stochastic Optimization**

This example is adapted from Box and Draper (1987) and uses Stochastic Optimization.jmp. A chemical reaction converts chemical “A” into chemical “B”. The resulting amount of chemical “B” is a function of reaction time and reaction temperature. A longer time and hotter temperature result in a greater amount of “B”. But, a longer time and hotter temperature also result in some of chemical “B” getting converted to a third chemical “C”. What reaction time
and reaction temperature will maximize the resulting amount of “B” and minimize the amount of “A” and “C”? Should the reaction be fast and hot, or slow and cool?

**Figure 8.20** Chemical Reaction

![Chemical Reaction Diagram]

The goal is to maximize the resulting amount of chemical “B”. One approach is to conduct an experiment and fit a response surface model for reaction yield (amount of chemical “B”) as a function of time and temperature. But, due to well known chemical reaction models, based on the Arrhenius laws, the reaction yield can be directly computed. The column Yield contains the formula for yield. The formula is a function of Reaction Time (hours) and reaction rates $k_1$ and $k_2$. The reaction rates are a function of Reaction Temperature (degrees Kelvin) and known physical constants $\theta_1$, $\theta_2$, $\theta_3$, $\theta_4$. Therefore, Yield is a function of Reaction Time and Reaction Temperature.

1. Select **Help > Sample Data Library** and open Stochastic Optimization.jmp
2. Select **Graph > Profiler**.
3. Assign Yield to **Y, Prediction Formula**.
4. Click **Expand Intermediate Formulas**. Click **OK**.
   
   The Prediction Profiler with Desirability Functions enabled appears. For more information on Desirability Functions, see the “Desirability Profiling and Optimization” on page 47 in the “Profiler” chapter.

5. From the Prediction Profiler red triangle menu, select **Optimization and Desirability > Maximize Desirability**.
   
   The Profiler maximizes Yield and sets the graphs to the optimum value of Reaction Time and Reaction Temperature.
The maximum *Yield* is approximately 0.62 at a *Reaction Time* of 0.115 hours and *Reaction Temperature* of 540 degrees Kelvin, or hot and fast. (Your results might differ slightly due to random starting values in the optimization process.)

In a production environment, process inputs cannot always be controlled exactly. What happens to *Yield* if the inputs (*Reaction Time* and *Reaction Temperature*) have random variation? Furthermore, if *Yield* has a spec limit, what percent of batches will be out of spec and need to be discarded? The Simulator can help us investigate the variation and defect rate for *Yield*, given variation in *Reaction Time* and *Reaction Temperature*.

6. Deselect **Desirability Functions** from the Prediction Profiler red triangle menu.

7. Select **Simulator** from the Prediction Profiler red triangle menu.

8. As shown in Figure 8.22, fill in the factor parameters so that *Temperature* is **Normal weighted** with standard deviation of 1, and *Time* is **Normal weighted** with standard deviation of 0.03. The Mean parameters default to the current factor values.

9. Change the number of runs to 15,000.
Yield has a lower spec limit of 0.55, set as a column property, and shows in Figure 8.22 as a red line. With the random variation set for the input factors, you are ready to run a simulation to study the resulting variation and defect rate for Yield.

10. Click the **Simulate** button.
As shown in Figure 8.23, the predicted Yield is 0.62, but if the factors have the given variation, the average Yield is 0.60 with a standard deviation of 0.03.

The defect rate is about 6.0%, meaning that about 6.0% of batches are discarded. A defect rate this high is not acceptable.

What is the defect rate for other settings of Reaction Temperature and Reaction Time?

Suppose you change the Reaction Temperature to 535, then set Reaction Time to the value that maximizes Yield?

Before changing settings, we should save these factor settings that give us the maximum Yield.

11. From the Prediction Profiler red triangle menu, select Factor Settings > Remember Settings.

12. Type “Max Yield” and click OK.

The settings are appended to the report window.

13. Now, change the Mean value for Reaction Temperature to 535.
14. Move the dashed red line in the Reaction Time plot to the value that maximizes Yield (around 0.16). Change the Mean value of Reaction Time to 0.16.

15. Click **Simulate**.

**Figure 8.25** Defect Rate for Temperature of 535

As illustrated in Figure 8.25, the defect rate decreases to about 1.8%, which is much better than 6.0%. So, what you see is that the fixed (no variability) settings that maximize Yield are not the same settings that minimize the defect rate in the presence of factor variation. By running a Simulation Experiment you can find the settings of Reaction Temperature and Reaction Time that minimize the defect rate. To do this you simulate the defect rate at each point of a Reaction Temperature and Reaction Time design, then fit a predictive model for the defect rate and minimize it.

16. Select **Simulation Experiment** from the Simulator red triangle menu.

17. Enter 80 runs, and 1 to use the whole factor space in the experiment. Click **OK**.

A Latin Hypercube design with 80 design points is chosen within the specified factor space, and N Runs random draws are taken at each of the design points. The design points are the center of the random draws, and the shape and variance of the random draws coming from the factor distributions.

A table is created with the results of the experiment. The Overall Defect Rate is given at each design point. You can now fit a model that predicts the defect rate as a function of Reaction Temperature and Reaction Time.

Do not close the Stochastic Optimization Profiler window.

18. From the new table, run the attached Gaussian Process script.
The results are shown in Figure 8.26. Your results will be slightly different due to the random draws in the simulation. The Gaussian Process platform automatically opens the Prediction Profiler.

**Figure 8.26** Results of Gaussian Process Model Fit

19. To find the settings of Temperature and Time that minimizes the defect rate, select **Optimization and Desirability > Maximize Desirability** from the Prediction Profiler red triangle menu.

   The desirability function is already set up to minimize the defect rate.
Figure 8.27  Settings for Minimum Defect Rate

The settings that minimize the defect rate are approximately Reaction Temperature = 526 and Reaction Time = 0.3.

20. Click the **Transfer Factor Settings Back** button.

   This sets Temperature and Time to those settings that minimize the defect rate in the original Profiler report window.

21. Return to the original Profiler report window.

22. From the Prediction Profiler red triangle menu, select **Factor Settings > Remember Settings**.

23. Type “Min Defect” and click **OK**.

Figure 8.28  Minimum Defect Settings

24. With the new settings in place, click the **Simulate** button to estimate the defect rate at the new settings.
At the new settings the defect rate is 0.05%, much better than the 6.0% for the settings that maximize Yield. That is a reduction of about 120x. Recall the average Yield from the first settings is 0.60 and the new average is 0.59. The decrease in average Yield of 0.01 is very acceptable when the defect rate decreases by 120x.

Because we saved the settings using Remember Settings, we can easily compare the old and new settings. The Differences report summarizes the difference.

25. Click the **Remembered Settings** radio buttons to view the profiler for each setting.
The chemist now knows what settings to use for a quality process. If the factors have no variation, the settings for maximum Yield are hot and fast. But, if the process inputs have variation similar to what we have simulated, the settings for maximum Yield produce a high defect rate. Therefore, to minimize the defect rate in the presence of factor variation, the settings should be cool and slow.

Statistical Details for the Simulator

This section contains statistical details for the Simulator profiler.

Normal Weighted Distribution

JMP uses the multivariate radial strata method for each factor that uses the Normal Weighted distribution. This seems to work better than a number of Importance Sampling methods, as a multivariate Normal Integrator accurate in the extreme tails.

First, define strata and calculate corresponding probabilities and weights. For \( d \) random factors, the strata are radial intervals as follows.
Table 8.3 Strata Intervals

<table>
<thead>
<tr>
<th>Strata Number</th>
<th>Inside Distance</th>
<th>Outside Distance</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>$\sqrt{d}$</td>
</tr>
<tr>
<td>1</td>
<td>$\sqrt{d}$</td>
<td>$\sqrt{d + \sqrt{2d}}$</td>
</tr>
<tr>
<td>2</td>
<td>$\sqrt{d + \sqrt{2d}}$</td>
<td>$\sqrt{d + 2\sqrt{2d}}$</td>
</tr>
<tr>
<td>$i$</td>
<td>$\sqrt{d + (i - 1)\sqrt{2d}}$</td>
<td>$\sqrt{d + i\sqrt{2d}}$</td>
</tr>
<tr>
<td>$N_{Strata} - 1$</td>
<td>previous</td>
<td>$\infty$</td>
</tr>
</tbody>
</table>

The default number of strata is 12. To change the number of strata, a hidden command $N_{Strata}$ is available if you hold the Shift key down while clicking on the red triangle next to Simulator. Increase the sample size as needed to maintain an even number of strata.

For each simulation run:

1. Select a strata as $\text{mod}(i - 1, N_{Strata})$ for run $i$.
2. Determine a random $n$-dimensional direction by scaling multivariate Normal (0,1) deviates to unit norm.
3. Determine a random distance using a chi-square quantile appropriate for the strata of a random uniform argument.
4. Scale the variates so that the norm is the random distance.
5. Scale and re-center the variates individually to be as specified for each factor.

The resulting factor distributions are multivariate normal with the appropriate means and standard deviations when estimated with the right weights. Note that you cannot use the Distribution standard deviation with weights, because it does not estimate the desired value. However, multiplying the weight by a large value, like $10^{12}$, and using that as a Freq value results in the correct standard deviation.
The JMP Add-In for Excel uses the JMP Profiler to visualize models (or formulas) stored in Excel worksheets. You can install the Excel add-in when you install JMP.

**Figure 9.1** Example of a Profiler Using an Excel Model
Excel Profiler Overview

The JMP Add-In for Excel uses the JMP Profiler to visualize models (or formulas) stored in Excel worksheets. The Excel add-in is automatically installed when you install JMP. Profiling in the Excel Add-In is a two-step process:

1. Click the **Create/Edit Model** button (Excel 2007 through 2016) to enter information about the model that JMP needs. This needs to be done only once per model. For more information, click **Help** in the Create/Edit Model window.
2. Click the **Run Model** button (Excel 2007 through 2016) to launch the JMP Profiler and run the Excel model. For more information, see “Run the JMP Profiler” on page 164.

**Notes:**

- The Preferences, Data Table, Graph Builder, and Distribution buttons are not needed to profile an Excel model. For more information about these features, see the Import Your Data chapter in the *Using JMP* book.
- A JMP ribbon is added to Microsoft Excel when the add-in is installed. If there is no JMP ribbon, install the add-in by double-clicking the JMP setup.exe file, selecting **Modify**, selecting Excel Add-In, and clicking Next.

Example of an Excel Model

An Excel model consists of one or more Excel formulas. Each formula must be a function of one or more other cells. This example uses the Demand.xls sample import data located in the Samples/Import Data folder.

**Figure 9.2 Demand Model in Excel**
About the Demand.xls Sample Import Data

The formula in cell B8 is a calculation of the Overall Cost associated with having different amounts of product in stock. The formula, which is shown in the Formula Bar, is a function of four cells:

- **Amount Stocked** is the amount of product in stock.
- **Demand** is the customer demand for the product.
- **Air Freight** is the cost per unit to ship additional product by air when the demand exceeds the amount in stock.
- **Expiration Cost** is the cost per unit of disposing of unused product when the demand is less than the amount in stock.

The calculations of the formula are as follows:

- If **Amount Stocked** is less than **Demand**, then the company has to ship additional units, at a cost of \((\text{Demand} - \text{Amount Stocked}) \times \text{Air Freight}\). For example, if the demand is 8, but the company has only 6 in stock, then it has to ship 8 - 6 = 2 units at a cost of \(2 \times 150 = 300\).

- If **Amount Stocked** is greater than **Demand**, then the company has to dispose of unused product, at a cost of \((\text{Amount Stocked} - \text{Demand}) \times \text{Expiration Cost}\). For example, if the demand is 5, but the company has 8 in stock, then it has to dispose of 8 - 5 = 3 units at a cost of \(3 \times 50 = 150\).

- If **Amount Stocked** is equal to **Demand**, then there is no shipping cost or disposal cost.

- There is never both a shipping cost and a disposal cost at the same time.

Create the Model in Excel

1. Select **Help > Sample Data Library** and navigate up one level to the Sample Import Data folder.
2. Double-click **Demand.xls** to open the file in Microsoft Excel.
3. In Microsoft Excel, click the JMP ribbon.
4. Click the **Create/Edit Model** button .
   The name of the worksheet is displayed in the Model and Model Name fields.
   The Inputs and Outputs fields are populated with data from the worksheet.
5. Enter **Customer Demand** in the Model Name field and click **Apply**.
   The Model field is updated.
6. Select **Air Freight** in the Inputs box and then click the down arrow button .
   Air Freight is moved to the bottom of the list because you want it displayed last in the Profiler.
7. Click **OK**.
The Excel model is saved to the worksheet.

Notes:

- If the fields in the Create/Edit Model window are not populated when you set up your model, click **Choose** and select the cell that contains the input name. Specify the values and click **Apply**.
- You can create more than one model for a worksheet. In the Create/Edit Model window, click the plus button next to the Model name. In the Model Name field, change the name if necessary and click the **Apply** button. You can then change the inputs and outputs as necessary and click **OK**.
- You must define the entire model on one worksheet. A model cannot reference cells on another worksheet.

**Run the JMP Profiler**

Once you create the model using the Excel Add-In, you can run it in the JMP Profiler. From the Excel Add-In, perform the following actions:

1. In Microsoft Excel, click the JMP ribbon.
2. Click the **Run Model** button.
3. Select the model that you want to run.
4. Click **Profile in JMP**.
5. Use the JMP Profiler to simultaneously see the effect of all inputs on the output. You can also simulate a range of input combinations to see the resulting range of output values.

**Figure 9.3 Example of the Profiler Using Excel Models**

Note: To ensure that your original Excel worksheet is not altered, JMP runs a hidden copy of Excel in the background that controls all of the Profiler calculations.
Use Linear Constraints

Within the JMP Profiler, you can alter the linear constraints in order to restrict the model input values. You are prompted to save the constraints to the Excel workbook. After constraints are saved to the Excel workbook, whenever the model is profiled from the Excel Add-In, the constraints are incorporated.

1. From the red triangle menu next to Prediction Profiler, select Alter Linear Constraints.
2. Click Add Constraint.
3. Type in the constraining values.
4. Click OK.
5. From the red triangle menu next to Prediction Profiler, select Save Linear Constraints.
   You are prompted to save the constraints to the Excel workbook.
6. Click Yes.

Note: When you save the .xls file, you might see a compatibility error. If so, click Continue to save the file.

The workbook opens in Excel. When you run the model, the constraints are reflected in the JMP Profiler. For more information about linear constraints, see “Linear Constraints” on page 35 in the “Introduction to Profilers” chapter.

Tip: To delete a linear constraint, set all constraint values to zero.

Resolution of Profile Lines

The Default N Levels option on the red triangle menu next to Prediction Profiler affects the resolution of the profile lines. Note the following information:

- This option defaults to 17 when the Profiler runs a model stored in Excel.
- This option defaults to 41 when the model is stored directly in JMP.

If the same model is stored in both Excel and JMP, then the profile lines can appear differently when the models are profiled. Increasing this value causes the Excel Profiler to run slower.
Use the Excel Profiler from JMP

After you have defined model input and outputs in an Excel file, you can profile the model from within JMP.

1. Select **Graph > Excel Profiler**.
2. Locate the Excel file containing the model and then click **Open**.
3. If the Excel file contains multiple models, you are prompted to select the model that you want to profile.

Note that the Excel Profiler is also scriptable, as follows:

```
Excel Profiler( "path to workbook", <"model name"> ) ;
```

If more than one model exists, and no model is specified, a window with the list of available models appears. For more information about scripting the Excel Profiler, see the Extending JMP chapter in the *Scripting Guide.*


Index
Profilers

A
Add Multivariate Noise 137
Add Random Noise 137
Add Random Weighted Noise 137
ALT-click 33
Alter Linear Constraints 46, 128
Append Settings to Table 45
ArcBall 103
Arrhenius 151
Assess Variable Importance with Independent Uniform Inputs 53
Automatic Histogram Update 136

C
Conditional Predictions 46
Confidence Intervals 43
Constraints 35
Contour Grid 82, 113
Contour Label 82
Contour Profiler 37–38, 78
Copy Settings Script 45
cross-product term 30
current predicted value 26
Current Value 34
Custom Profiler 124

D
Data Filter 46
Default N Levels 46
Defect Parametric Profile 136, 147
DefectProfiler 142
Defect Profiler 136, 146
Dependent Resampled Inputs 53
Desirability Functions 41, 47
desirability trace 47
drag 26, 31, 49

E
Excel Profiler 162
Expand Intermediate Formulas 29
Expression 135

F
Factor Settings 45, 128
Filtered Monte Carlo 46
Fish Patty.jmp 114
Fit Group 30
Fit Model platform
example 57–59, 78–83
Fit to Window, Surface Plot 96
Five Factor Mixture.jmp 118
Fixed 134

G
Graph Updating 81
Grid Density 81

H
Hardware Acceleration 103

I
Independent Resampled Inputs 53
Independent Uniform Inputs 53
interaction effect 30
Interaction Profiler 43
Isosurface 94

L
Linear Constraints 113
Linearly Constrained Inputs 53
### Profilers

- **Link Profilers** 45
- **Lock Factor Setting** 34, 46
- **Lock Z Scale** 98
- **Log Iterations** 128
- **LSL Chop** 149

### M

- **Make Table** 132, 139
- **Maximization Options** 41
- **Maximize** 49
- **Maximize Desirability** 41
- **Maximize for Each Grid Point** 42
- **Maximum Value** 34
- **mean shift** 148
- **Mesh** 102
- **Minimize** 50
- **Minimum Setting** 34
- **Mixture Profiler** 106
- **multiple response fitting** 31, 57
- **Multivariate** 136

### N

- **N Runs** 132
- **N Strata** 136
- **No Noise** 137
- **Noise Factors** 37
- **Noise Factors** 29
- **Normal censored** 135
- **Normal Truncated** 135
- **Normal weighted** 134, 139
- **Number of Plotted Points** 34

### O

- **Option-click** 33
- **OPTMODEL formulas** 34
- **Output Grid Table** 46
- **Output Random Table** 46

### P

- **Paste Settings Script** 45
- **Per Mouse Move** 81
- **Per Mouse Up** 81
- **Prediction Profiler** 26
- **ingredient column expansion** 29
- **prevent formula expansion** 29
- **profile trace** 26
- **Profiler**
  - **Assess Variable Importance** 53
  - **Dependent Resampled Inputs** 53
  - **Independent Resampled Inputs** 53
  - **Linearly Constrained Inputs** 53
- **Profiler** 26
- **Profilers, introduction** 25–30
- **Prop of Error Bars** 41, 75

### R

- **Random** 134
- **Ref Lines** 113
- **Remember Settings** 45, 122
- **Remove Contour Grid** 113
- **Reset Factor Grid** 44
- **Response Limits** 137
- **Robust Engineering** 37

### S

- **Sampled** 135
- **Save As Flash (SWF)** 34
- **Save Desirabilities** 42
- **Save Desirability Formula** 42
- **Save Expanded Formulas** 30
- **Save Linear Constraints** 46, 128
- **Sensitivity Indicator** 43
- **Set Desirabilities** 42, 49
- **Set Random Seed** 136
- **Set Script** 45
- **Set To Data in Row** 45
- **Show** 34
- **Show Constraints** 113
- **Show Current Value** 113
- **Show Formulas** 34
- **Sigma** 75
- **Simulate** 144
- **Simulation Experiment** 136
- **simulation histogram** 130
- **Simulator** 46, 130
- **Simulator** 43
- **Spec Limits** 136–138, 146
- **Std Narrow** 148
Index

Profilers

Stochastic Optimization.jmp 150
Stop At Boundaries 44
Surface Fill 102
Surface Plot 86
  Constants 103
  Control Panel 96
  Dependent Variables 98
  Variables 97
Surface Plot 81
Surface Profiler 86

T

Target 50
Tiretread.jmp 31, 59, 91–92, 146
tiretread.jmp 57
transmitted variation 38
Turn At Boundaries 44
tutorial examples
  contour profiler 78–83
  desirability profile 57–59

U

Up Dots 82, 113
USL Chop 149

V

Variable Importance 53

W-Z

Y, Prediction Formula 29