Using JMP

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust
SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to http://support.sas.com/thirdpartylicenses.

**Technology License Notices**

- **Scintilla** - Copyright © 1998-2014 by Neil Hodgson <neilh@scintilla.org>. All Rights Reserved.
  
  Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation.

  **NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.**

- **Telerik RadControls**: Copyright © 2002-2012, Telerik. Usage of the included Telerik RadControls outside of JMP is not permitted.


- **Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.**

- **Packages** - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
  
  Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

  **THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED**
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGligence OR OTHERWise) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• iODBC software - Copyright © 1995-2006, OpenLink Software Inc and Ke Jin
  (www.iodbc.org). All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:
  – Redistributions of source code must retain the above copyright notice, this list of
    conditions and the following disclaimer.
  – Redistributions in binary form must reproduce the above copyright notice, this list
    of conditions and the following disclaimer in the documentation and/or other
    materials provided with the distribution.
  – Neither the name of OpenLink Software Inc. nor the names of its contributors may
    be used to endorse or promote products derived from this software without specific
    prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
THE POSSIBILITY OF SUCH DAMAGE.

• bzip2, the associated library “libbzip2”, and all documentation, are Copyright ©
  1996-2010, Julian R Seward. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.
- libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and / or other materials provided with the distribution.
- Neither the name of Florian Reuter nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

**THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.**

- **libxml2** - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar licence but with different Copyright notices) all the files are:

  Copyright © 1998 - 2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

**THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.**

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

- **Regarding the decompression algorithm used for UNIX files:**

The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

• Snowball - Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:
• live and recorded webcasts about how to get started with JMP
• video demos and webcasts of new features and advanced techniques
• details on registering for JMP training
• schedules for seminars being held in your area
• success stories showing how others use JMP
• a blog with tips, tricks, and stories from JMP staff
• a forum to discuss JMP with other users

http://www.jmp.com/getstarted/
3 Import Your Data
   Create Data Tables .................................................. 63
   About Importing Data to JMP ...................................... 64
   Import Microsoft Excel Files ..................................... 65
      Preview and Import the Microsoft Excel Data ................. 65
      Import a Microsoft Excel File Directly ....................... 76
   Import Data from SAS ................................................ 77
      Import SAS Data Sets ............................................. 78
      Create SAS Transport Files in SAS ............................ 80
      Connect to SAS .................................................... 81
   Open SAS Data Sets with SAS Query Builder .................... 86
   Open SAS Data Sets through a SAS Server ....................... 87
   Using SAS Extended Attributes to Import Metadata ........... 95
   Run Stored Processes ............................................... 96
   Submit SAS Code .................................................... 97
   Generate ODS Results ............................................... 99
   Retrieve Generated SAS Data Sets ................................. 100
   Build SQL Queries in Query Builder ............................. 102
      Connect to a SQL Database .................................... 103
      Select Tables from a SQL Database ......................... 104
   Build the SQL Query ............................................... 108
   Save and Run the Query ............................................ 121
   Open the Selected Data in JMP ................................... 122
   Query Builder Red Triangle Options .............................. 123
   Write SQL Statements in Query Builder ......................... 123
   Import Data from a Database ...................................... 124
      Connect to a Database ........................................... 124
      Open Data from a Database .................................... 125
      Write SQL Statements to Query a Database .................. 127
      Structured Query Language (SQL): A Reference ............. 129
   Import Text Files .................................................... 134
      Text Import Wizard Options .................................. 136
      Open a Text File in a Text Editing Window .................. 140
      Import Text from the Script Editor ............................ 142
   Import Data from the Internet or a Remote Computer ....... 143
   Import SPSS Files ................................................... 145
   Import Triple-S Survey Data ....................................... 146
   Import HDF5 Data ..................................................... 147
   Import JSON Files .................................................... 147
   Import Data from MATLAB ......................................... 148
4 Enter and Edit Data
   Perform Basic Data Table Tasks
      Enter Data .................................................. 154
      Copy and Paste Data .................................. 154
      Add Rows .................................................. 154
      Add Columns ............................................. 154
      Fill Columns with Sequential Data ................. 157
      Enter Cell Formulas ................................... 158
      Locate Next and Previously Selected Rows ....... 160
      Select Columns .......................................... 161
      Select Columns in a Data Table ..................... 162
      Select Columns in the Columns Viewer ............ 163
      Locate Next and Previously Selected Columns .... 168
      Select Cells ............................................. 168
      Resize Rows and Columns .............................. 170
      Delete Rows and Columns .............................. 170
      Rearrange Columns .................................... 171
      Group Columns .......................................... 171
      Move Values ............................................. 172
      Color Cells ............................................. 173
      Edit or Delete Cells ................................... 173
      Edit Column Names ..................................... 173
      Hide and Exclude Rows ................................ 173
      Exclude Rows ............................................ 174
      Hide Rows ............................................... 175
      Exclude Columns ........................................ 176
      Hide Columns .......................................... 177
      View Patterns of Missing Data ....................... 177
      Find and Replace Cell Values ....................... 179
      Use the Row Editor to Edit Cells in a Row ........ 181
      Context Menus for Rows and Columns ............... 183
      Compare Data Tables .................................... 183
      Assign Characteristics to Rows and Columns ...... 187
      Label Rows and Columns ................................ 188
Assign Colors or Markers to Rows ................................................................. 188
Create Color Themes .................................................................................. 191
Delete Custom Color Themes ...................................................................... 195
Delete Row Characteristics ........................................................................ 196
Lock Columns in Place ................................................................................ 196
Restructure Data .......................................................................................... 196
Make a Column into Multiple Columns ...................................................... 196
Make Indicator Columns ............................................................................. 197
Combine Columns ....................................................................................... 197
Compress Selected Columns ....................................................................... 198
Make Binning Formula ................................................................................ 200
Make a New Formula Column .................................................................... 202
Transform Columns ...................................................................................... 202
Recode Data .................................................................................................. 210
Edit the Data Table ...................................................................................... 215
Change Table Names ................................................................................... 215
Lock Tables ................................................................................................... 216
Compress Tables .......................................................................................... 216
Use Table Variables ..................................................................................... 217
Create and Save Scripts .............................................................................. 218

5 The Column Info Window
Set Column Attributes and Properties ....................................................... 223
About the Column Info Window ................................................................... 224
About Modeling Types ................................................................................ 226
The Short-Integer Format ........................................................................... 227
Numeric Formats ......................................................................................... 228
Row State Columns ...................................................................................... 231
Initialize Data .............................................................................................. 233
Column Properties ....................................................................................... 235
Basic Column Properties ........................................................................... 236
Properties That Validate Column Values .................................................. 236
Properties That Attach Information to Column Values ................................ 238
Properties That Control the Display of Columns ........................................ 241
Properties Used in Modeling and DOE ...................................................... 242
Properties Associated with Control Charts and Capability ......................... 243
Properties That Control How Columns Are Used in Platforms ..................... 244
Virtual Join Properties ................................................................................ 252
Additional Properties .................................................................................. 254
Properties Assigned and Controlled by JMP ............................................. 256
Standardize Attributes and Properties Across Columns ............................. 257
Rercode Values ............................................................................................ 257
Standardize Attributes ............................................................................... 258
6 Reshape Data

- Create Subsets, Sort Data, and More ........................................ 261
  - Create a Subset Data Table ............................................. 262
    - Stratified Subsets ................................................... 264
      - Create a Subset Data Table from a Report ......................... 264
  - Sort Data Tables .......................................................... 265
  - Stack Columns .................................................................. 267
    - Example of Stacking into One Column ............................... 269
    - Example of Stacking into More Than One Column .............. 270
  - Split Columns .................................................................. 272
    - Examples of Splitting Columns ...................................... 273
  - Transpose Rows and Columns ........................................... 275
    - Examples of Transposing Rows and Columns .................... 277
  - Concatenate Data Tables ................................................ 279
    - Example of Concatenating Data Tables ......................... 280
    - Example of Concatenating Data Tables and Table Variables .. 281
  - Join Data Tables ............................................................ 282
    - Examples of Joining Data Tables .................................. 285
  - Query and Join Data Tables with JMP Query Builder .......... 293
    - About Links to Data Tables in JMP Queries .................... 295
  - Virtually Join Data Tables ............................................... 296
  - Update Data Tables ......................................................... 300
    - Example of Updating a Data Table ................................ 302
  - Anonymize Data .............................................................. 303

7 Formula Editor

- Construct Formulas .................................................................. 305
  - Formula Overview ................................................................ 306
  - Create a Formula .................................................................. 306
  - Refer to Values in Columns and Table Variables ................. 308
  - Use Local Variables .......................................................... 310
    - Incorporate Parameters .................................................. 312
  - Insert Constants .................................................................. 313
  - Add Operators ..................................................................... 314
    - Keypad Reference .......................................................... 315
  - Use Functions in a Formula ................................................ 316
  - Order Expressions in Formulas .......................................... 319
    - Build a Formula in Order of Precedence ......................... 320
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Formula Editor Options</td>
<td>321</td>
</tr>
<tr>
<td>Calculate Derivatives</td>
<td>321</td>
</tr>
<tr>
<td>Simplify Complex Formulas</td>
<td>322</td>
</tr>
<tr>
<td>Evaluate Formulas</td>
<td>323</td>
</tr>
<tr>
<td>Ignore Errors</td>
<td>323</td>
</tr>
<tr>
<td>View a Formula’s Values from the Formula Editor</td>
<td>323</td>
</tr>
<tr>
<td>View a Formula in JSL</td>
<td>324</td>
</tr>
<tr>
<td>Edit Formulas</td>
<td>324</td>
</tr>
<tr>
<td>Correct Mistakes</td>
<td>324</td>
</tr>
<tr>
<td>Select Expressions</td>
<td>325</td>
</tr>
<tr>
<td>Delete Functions</td>
<td>325</td>
</tr>
<tr>
<td>Cut, Copy, and Paste</td>
<td>326</td>
</tr>
<tr>
<td>Click and Drag</td>
<td>326</td>
</tr>
<tr>
<td>Customize Formulas</td>
<td>326</td>
</tr>
<tr>
<td>Hide and Show Boxing</td>
<td>326</td>
</tr>
<tr>
<td>Change the Font Size</td>
<td>327</td>
</tr>
<tr>
<td>Specify the Matrix Size</td>
<td>327</td>
</tr>
<tr>
<td>Change the Orientation of a Formula</td>
<td>327</td>
</tr>
<tr>
<td>Open and Close Arguments</td>
<td>327</td>
</tr>
<tr>
<td>Examples and Tutorials</td>
<td>328</td>
</tr>
<tr>
<td>Use Basic Formula Editor Features</td>
<td>328</td>
</tr>
<tr>
<td>Use Local Variables in a Formula</td>
<td>329</td>
</tr>
<tr>
<td>Use the Munger Function</td>
<td>330</td>
</tr>
<tr>
<td>Use the Match Conditional Function</td>
<td>331</td>
</tr>
<tr>
<td>Use the Delete Expression Button</td>
<td>332</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>333</td>
</tr>
<tr>
<td>Glossary of Terms</td>
<td>334</td>
</tr>
</tbody>
</table>

8 **Summarize Data**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Table Summary Command</td>
<td>337</td>
</tr>
<tr>
<td>Summarize Columns</td>
<td>338</td>
</tr>
<tr>
<td>Launch Window Roles</td>
<td>338</td>
</tr>
<tr>
<td>Create a Summary Table</td>
<td>338</td>
</tr>
<tr>
<td>Add a Statistics Column to an Existing Summary Table</td>
<td>342</td>
</tr>
<tr>
<td>Explanation of Statistics</td>
<td>343</td>
</tr>
<tr>
<td>Example of Creating a Summary Table</td>
<td>344</td>
</tr>
</tbody>
</table>

9 **JMP Reports**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigate and Customize Report Windows</td>
<td>347</td>
</tr>
<tr>
<td>Navigate Reports</td>
<td>348</td>
</tr>
<tr>
<td>Use the Hand Tool</td>
<td>349</td>
</tr>
<tr>
<td>Access Report Display Options</td>
<td>349</td>
</tr>
<tr>
<td>Show and Hide Parts of a Report</td>
<td>351</td>
</tr>
</tbody>
</table>
Combine Several Reports ................................................................. 351
Rename a Title ...................................................................... 351
Increase Font Sizes ................................................................. 352
Resize a Window ................................................................. 352
Red Triangle Options in a Report .................................................. 352
Local Data Filter ................................................................. 353
Redo Menus ................................................................. 353
Save Script Menus ................................................................. 353
The Data Filter ........................................................................... 356
Types of Filter Columns .................................................. 357
Filtering Modes ................................................................. 357
The Data Filter Control Panel .................................................. 358
Red Triangle Options for the Data Filter .................................. 360
Red Triangle Options for Variables ........................................... 366
Reformat Report Tables ............................................................. 368
Modify Display Box Properties in a Report .............................. 369
Turn a Report Table Into a Matrix ........................................... 369
Use Conditional Formatting .................................................. 369
Select Points in Graphs ............................................................. 375
Select Rows in Graphs ...................................................... 376
Select a Rectangular Area of Points ....................................... 376
Select an Irregular-Shaped Area of Points ............................... 377
Use Markers .............................................................................. 378
Change Marker Shape ...................................................... 378
Change Marker Colors .......................................................... 379
Change Marker Size .............................................................. 379
Change the Marker Drawing Mode and Transparency .......... 379
Add Outlines Around Markers .............................................. 380
Marker Selection Modes .......................................................... 380
Specify Marker Transparency ................................................. 381
Exclude and Hide Markers ...................................................... 382
Add Labels to Markers .......................................................... 382
Change Marker Shape or Colors Based On Values .................. 383
Change the Appearance of Graphs .............................................. 385
Resize Graphs ................................................................. 385
Zoom In and Out ................................................................. 386
Pin Hover Labels on a Graph .................................................. 386
Change Line Widths ................................................................. 388
Change the Background Color in a Graph .................................. 388
Change the Color of Histogram Bars ....................................... 388
Display Coordinates and Temporary Reference Lines ............... 388
Scroll and Scale Axes .............................................................. 389
Customize Axes and Axis Labels in the Axis Settings Window .... 390
10 **Save and Share Data**  
Get Your Data Out of JMP

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customize Axes and Axis Labels Using the Right-Click Menu</td>
<td>399</td>
</tr>
<tr>
<td>Change the Order of Values</td>
<td>401</td>
</tr>
<tr>
<td>Change the Pattern and Format of Selected Objects</td>
<td>402</td>
</tr>
<tr>
<td>Add a Graph to a Data Table</td>
<td>402</td>
</tr>
<tr>
<td>Customize Graphical Elements</td>
<td>403</td>
</tr>
<tr>
<td>Add Images to a Graph or Report</td>
<td>408</td>
</tr>
<tr>
<td>Paste a Background Image into a Graph</td>
<td>408</td>
</tr>
<tr>
<td>Paste an Image at the End of a Report</td>
<td>408</td>
</tr>
<tr>
<td>Drag and Drop an Image into a Graph</td>
<td>408</td>
</tr>
<tr>
<td>Add Geographical Images and Boundaries</td>
<td>411</td>
</tr>
<tr>
<td>Extract Data from an Image</td>
<td>411</td>
</tr>
<tr>
<td>Add Annotations and Shapes to a Report</td>
<td>412</td>
</tr>
<tr>
<td>Add Annotations</td>
<td>412</td>
</tr>
<tr>
<td>Add Shapes</td>
<td>414</td>
</tr>
</tbody>
</table>

Save and Share Data Tables

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save as a Microsoft Excel File</td>
<td>419</td>
</tr>
<tr>
<td>Save as a CSV File</td>
<td>420</td>
</tr>
<tr>
<td>Save as a Text File</td>
<td>421</td>
</tr>
<tr>
<td>Save as a SAS Transport File</td>
<td>422</td>
</tr>
<tr>
<td>Save as a SAS Data Set</td>
<td>423</td>
</tr>
<tr>
<td>Save Data Tables to a Database</td>
<td>424</td>
</tr>
<tr>
<td>Replace a Database with a Data Table</td>
<td>425</td>
</tr>
<tr>
<td>Email a Data Table</td>
<td>425</td>
</tr>
</tbody>
</table>

Save and Share Reports

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Email a Report</td>
<td>427</td>
</tr>
<tr>
<td>Save the Report as Interactive HTML</td>
<td>428</td>
</tr>
<tr>
<td>Create a Web Report</td>
<td>429</td>
</tr>
<tr>
<td>Save as PowerPoint</td>
<td>431</td>
</tr>
<tr>
<td>Save as Flash</td>
<td>433</td>
</tr>
<tr>
<td>Setting the Graphic DPI</td>
<td>433</td>
</tr>
</tbody>
</table>

Save Your Analysis as a Script

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Using the Layout Command</td>
<td>434</td>
</tr>
<tr>
<td>Save Parts of a Report in a Graphic Format</td>
<td>436</td>
</tr>
</tbody>
</table>

Print Reports

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy and Paste Reports</td>
<td>437</td>
</tr>
</tbody>
</table>

JMP Journals

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a New Journal</td>
<td>438</td>
</tr>
<tr>
<td>Prevent Modifications</td>
<td>440</td>
</tr>
<tr>
<td>Append Reports to a Journal</td>
<td>440</td>
</tr>
<tr>
<td>Add and Edit Outline Levels</td>
<td>440</td>
</tr>
</tbody>
</table>
Control the Display of Outline Levels ......................................................... 442
Add a Graph or Graphic .............................................................................. 442
Customize Journal Items .............................................................................. 442
Save the Journal in Another Format ........................................................... 443
Print a Journal .............................................................................................. 443
Delete Items from a Journal ......................................................................... 443
Example of Making a Journal for a Presentation ......................................... 444
Save JMP Sessions ...................................................................................... 445
Save Sessions upon Exiting .......................................................................... 446
Save Sessions Manually ............................................................................... 446
JMP Projects (Windows Only) ...................................................................... 447
Create a JMP Project .................................................................................... 447
Save a JMP Project ....................................................................................... 447
Close a JMP Project ...................................................................................... 448
Open a JMP Project ...................................................................................... 448
Add Items to a JMP Project .......................................................................... 449
Customize the Project .................................................................................. 450
Fix Broken Links .......................................................................................... 451
Save a Log Window ....................................................................................... 451

11 Extend JMP
Create Dashboards ....................................................................................... 453
Combine Reports by Creating a Dashboard .................................................. 454
Example of Creating a Dashboard with Two Reports ................................... 454
Details about Using the Dashboard Builder .................................................. 455
Dashboard Builder Red Triangle Options ..................................................... 456
Sample Dashboards ...................................................................................... 457
Edit a Dashboard ........................................................................................... 457
View a Running Dashboard .......................................................................... 460
Example of Combining Windows to Create a Dashboard .............................. 464
Example of Adding a Selection Filter to a Dashboard .................................... 464
Example of Creating a JMP Query Dashboard and Add-In ............................ 465

12 Personalize JMP
Customize Menus and Toolbars ................................................................... 469
Personalize Toolbars and Menus on Windows .............................................. 470
Change Customization Sets .......................................................................... 471
Create Toolbars ............................................................................................ 472
Create Main Menus ....................................................................................... 475
Create Menu Items and Toolbar Buttons ..................................................... 475
Rearrange Toolbars ...................................................................................... 479
Copy and Paste Menus, Menu Items, Toolbars, and Buttons .......................... 480
Rearrange Custom Menus, Menu Items, and Buttons ................................... 481
This chapter includes the following information:

- book conventions
- JMP documentation
- JMP Help
- additional resources, such as the following:
  - other JMP documentation
  - tutorials
  - indexes
  - Web resources
  - technical support options
Formatting Conventions

The following conventions help you relate written material to information that you see on your screen:

- Sample data table names, column names, pathnames, filenames, file extensions, and folders appear in Helvetica font.
- Code appears in Lucida Sans Typewriter font.
- Code output appears in Lucida Sans Typewriter italic font and is indented farther than the preceding code.
- **Helvetica bold** formatting indicates items that you select to complete a task:
  - buttons
  - check boxes
  - commands
  - list names that are selectable
  - menus
  - options
  - tab names
  - text boxes
- The following items appear in italics:
  - words or phrases that are important or have definitions specific to JMP
  - book titles
  - variables
  - script output
- Features that are for JMP Pro only are noted with the JMP Pro icon 🔄. For an overview of JMP Pro features, visit [http://www.jmp.com/software/pro/](http://www.jmp.com/software/pro/).

**Note:** Special information and limitations appear within a Note.

**Tip:** Helpful information appears within a Tip.
JMP Documentation

JMP offers documentation in various formats, from print books and Portable Document Format (PDF) to electronic books (e-books).

- Open the PDF versions from the **Help > Books** menu.
- All books are also combined into one PDF file, called **JMP Documentation Library**, for convenient searching. Open the **JMP Documentation Library** PDF file from the **Help > Books** menu.

**JMP Documentation Library**

The following table describes the purpose and content of each book in the JMP library.

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discovering JMP</td>
<td>If you are not familiar with JMP, start here.</td>
<td>Introduces you to JMP and gets you started creating and analyzing data.</td>
</tr>
<tr>
<td>Using JMP</td>
<td>Learn about JMP data tables and how to perform basic operations.</td>
<td>Covers general JMP concepts and features that span across all of JMP, including importing data, modifying columns properties, sorting data, and connecting to SAS.</td>
</tr>
<tr>
<td>Basic Analysis</td>
<td>Perform basic analysis using this document.</td>
<td>Describes these Analyze menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Distribution</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Fit Y by X</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Tabulate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Text Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Covers how to perform bivariate, one-way ANOVA, and contingency analyses through Analyze &gt; Fit Y by X. How to approximate sampling distributions using bootstrapping and how to perform parametric resampling with the Simulate platform are also included.</td>
</tr>
<tr>
<td><strong>Document Title</strong></td>
<td><strong>Document Purpose</strong></td>
<td><strong>Document Content</strong></td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><em>Essential Graphing</em></td>
<td>Find the ideal graph for your data.</td>
<td>Describes these Graph menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Graph Builder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Overlay Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scatterplot 3D</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Contour Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bubble Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Parallel Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cell Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Treemap</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scatterplot Matrix</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ternary Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Chart</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The book also covers how to create background and custom maps.</td>
</tr>
<tr>
<td><em>Profilers</em></td>
<td>Learn how to use interactive profiling tools, which enable you to view cross-sections of any response surface.</td>
<td>Covers all profilers listed in the Graph menu. Analyzing noise factors is included along with running simulations using random inputs.</td>
</tr>
<tr>
<td><em>Design of Experiments Guide</em></td>
<td>Learn how to design experiments and determine appropriate sample sizes.</td>
<td>Covers all topics in the DOE menu and the Specialized DOE Models menu item in the Analyze &gt; Specialized Modeling menu.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Fitting Linear Models</td>
<td>Learn about Fit Model platform and many of its personalities.</td>
<td>Describes these personalities, all available within the Analyze menu Fit Model platform:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Standard Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Stepwise</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Regression</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Mixed Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MANOVA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Loglinear Variance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nominal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ordinal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Linear Model</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><em>Predictive and Specialized Modeling</em></td>
<td>Learn about additional modeling techniques.</td>
<td>Describes these Analyze &gt; Predictive Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Modeling Utilities</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Neural</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bootstrap Forest</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Boosted Tree</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Nearest Neighbors</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Naive Bayes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Model Comparison</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Formula Depot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Specialized Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Curve</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nonlinear</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Gaussian Process</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Time Series</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Matched Pairs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Screening menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Response Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Predictor Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Association Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The platforms in the Analyze &gt; Specialized Modeling &gt; Specialized DOE Models menu are described in <em>Design of Experiments Guide</em>.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>----------------</td>
<td>------------------</td>
<td>------------------</td>
</tr>
</tbody>
</table>
| *Multivariate Methods* | Read about techniques for analyzing several variables simultaneously. | Describes these Analyze > Multivariate Methods menu platforms:  
  - Multivariate  
  - Principal Components  
  - Discriminant  
  - Partial Least Squares  
Describes these Analyze > Clustering menu platforms:  
  - Hierarchical Cluster  
  - K Means Cluster  
  - Normal Mixtures  
  - Latent Class Analysis  
  - Cluster Variables |
| *Quality and Process Methods* | Read about tools for evaluating and improving processes. | Describes these Analyze > Quality and Process menu platforms:  
  - Control Chart Builder and individual control charts  
  - Measurement Systems Analysis  
  - Variability / Attribute Gauge Charts  
  - Process Capability  
  - Pareto Plot  
  - Diagram |
<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
</table>
| **Reliability and Survival Methods** | Learn to evaluate and improve reliability in a product or system and analyze survival data for people and products. | Describes these Analyze > Reliability and Survival menu platforms:  
  - Life Distribution  
  - Fit Life by X  
  - Cumulative Damage  
  - Recurrence Analysis  
  - Degradation and Destructive Degradation  
  - Reliability Forecast  
  - Reliability Growth  
  - Reliability Block Diagram  
  - Repairable Systems Simulation  
  - Survival  
  - Fit Parametric Survival  
  - Fit Proportional Hazards |
| **Consumer Research**           | Learn about methods for studying consumer preferences and using that insight to create better products and services. | Describes these Analyze > Consumer Research menu platforms:  
  - Categorical  
  - Multiple Correspondence Analysis  
  - Multidimensional Scaling  
  - Factor Analysis  
  - Choice  
  - MaxDiff  
  - Uplift  
  - Item Analysis |
| **Scripting Guide**             | Learn about taking advantage of the powerful JMP Scripting Language (JSL).       | Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications. |
Chapter 1
Using JMP

Learn about JMP
Additional Resources for Learning JMP

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>JSL Syntax Reference</em></td>
<td>Read about many JSL functions on functions and their arguments, and messages that you send to objects and display boxes.</td>
<td>Includes syntax, examples, and notes for JSL commands.</td>
</tr>
</tbody>
</table>

**Note:** The **Books** menu also contains two reference cards that can be printed: The **Menu Card** describes JMP menus, and the **Quick Reference** describes JMP keyboard shortcuts.

**JMP Help**

JMP Help is an abbreviated version of the documentation library that provides targeted information. You can open JMP Help in several ways:

- On Windows, press the F1 key to open the Help system window.
- Get help on a specific part of a data table or report window. Select the Help tool ? from the **Tools** menu and then click anywhere in a data table or report window to see the Help for that area.
- Within a JMP window, click the **Help** button.
- Search and view JMP Help on Windows using the **Help > Help Contents**, **Search Help**, and **Help Index** options. On Mac, select **Help > JMP Help**.

**Additional Resources for Learning JMP**

In addition to JMP documentation and JMP Help, you can also learn about JMP using the following resources:

- Tutorials (see “Tutorials” on page 30)
- Sample data (see “Sample Data Tables” on page 30)
- Indexes (see “Learn about Statistical and JSL Terms” on page 30)
- Tip of the Day (see “Learn JMP Tips and Tricks” on page 30)
- Web resources (see “JMP User Community” on page 31)
- JMPer Cable technical publication (see “JMPer Cable” on page 31)
- Books about JMP (see “JMP Books by Users” on page 32)
- JMP Starter (see “The JMP Starter Window” on page 32)
• Teaching Resources (see “Sample Data Tables” on page 30)

Tutorials

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, then start with the Beginners Tutorial. It steps you through the JMP interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment and comparing a sample mean to a constant.

Sample Data Tables

All of the examples in the JMP documentation suite use sample data. Select Help > Sample Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories, select Help > Sample Data.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\JMP\13\Samples\Data

On Macintosh: \Library\Application Support\JMP\13\Samples\Data

In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory. In JMP Shrinkwrap, sample data is installed in the JMPSW directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching Resources section. To learn more about the teaching resources, visit http://jmp.com/tools.

Learn about Statistical and JSL Terms

The Help menu contains the following indexes:

Statistics Index   Provides definitions of statistical terms.

Scripting Index   Lets you search for information about JSL functions, objects, and display boxes. You can also edit and run sample scripts from the Scripting Index.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for using JMP.
To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select Help > Tip of the Day. Or, you can turn it off using the Preferences window. See the Using JMP book for details.

**Tooltips**

JMP provides descriptive tooltips when you place your cursor over items, such as the following:

- Menu or toolbar options
- Labels in graphs
- Text results in the report window (move your cursor in a circle to reveal)
- Files or windows in the Home Window
- Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences > General and then deselect Show menu tips. This option is not available on Macintosh.

**JMP User Community**

The JMP User Community provides a range of options to help you learn more about JMP and connect with other JMP users. The learning library of one-page guides, tutorials, and demos is a good place to start. And you can continue your education by registering for a variety of JMP training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, and social networking groups.

To access JMP resources on the website, select Help > JMP User Community or visit https://community.jmp.com/.

**JMPer Cable**

The JMPer Cable is a yearly technical publication targeted to users of JMP. The JMPer Cable is available on the JMP website:

http://www.jmp.com/about/newsletters/jmpercable/
JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP website:


The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus. The window also lists JMP Pro features and platforms.

- To open the JMP Starter window, select View (Window on the Macintosh) > JMP Starter.
- To display the JMP Starter automatically when you open JMP on Windows, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list. On Macintosh, select JMP > Preferences > Initial JMP Starter Window.

Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP, many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at http://www.jmp.com/support, including the technical support phone number.
To get you started with JMP, this chapter covers the following topics:

- learn about the initial windows that appear when you start JMP
- understand data tables
- open data files
- manage open windows
- learn about the anatomy of a typical JMP user session

**Figure 2.1** The JMP Home Window on Windows
Anatomy of a JMP Session

JMP consists of platforms that are organized by the type of statistical analysis. For example, the Distribution platform produces a univariate analysis using histograms, additional graphs, and reports. You might analyze data in the Distribution platform and then choose another platform to examine the data more thoroughly. As a result, several windows are open at once: at a minimum, the data table, platform launch windows, and the results of the analyses.

Figure 2.2 shows a typical JMP session. Note that the windows are not maximized so that you can quickly switch from one window to another.

Figure 2.2 Anatomy of a Typical JMP Session on Windows

The following sections describe the windows that you typically work with.
Data Tables

In JMP, data points are organized into rows and columns referred to as the *data table*. A data table has two parts: the *data table panels* on the left and the *data grid* on the right.

You can enter, view, edit, and manipulate data using data tables. In a data table, each variable is a column, and each observation is a row.

**Figure 2.3 Data Table Features**

- Click a red triangle menu to select column and row options.
- Double-click a thumbnail to see associated reports.
- Right-click the row or column area to select options.
- Launch platforms from the Analyze, Graph, and DOE menus.

The data table has the following characteristics:

- Column names can contain any keyboard character, including spaces, and can be up to 255 characters long.
• The maximum length of the data table’s name depends on your computer’s operating system.

• Consider setting the Autosave Timeout value in the General preferences to automatically save data tables at the specified number of minutes. This autosave value also applies to journals, scripts, projects, and reports.

• Change the default size and font for names and values selecting File > Preferences > Fonts. (On the Macintosh, select JMP > Preferences > Fonts.)

• Column names automatically wrap in the column name area to accommodate the column width that you specify.

• Move column boundaries and enlarge the column to view long values. Adjust widths of all selected columns at once by pressing the Alt key as you drag the double arrow cursor on any of the selected column boundaries.

• The number of rows and columns in a data table is limited only by your computer’s memory.

• Resize rows by dragging one of the row borders. All rows are resized to the same height. Graphics that display inside each cell shrink based on the row height.

  To resize columns to the same width, select the columns and press Control (Windows) or Option (Macintosh); drag one of the column borders. All columns are resized to the same width.

**Data Table Panels**

Data tables contain three panels:

• Table panel
• Columns panel
• Rows panel

These panels are located on the left of the data grid. They contain information about the table and its contents. Each panel has interactive areas. See Figure 2.4.
The Table panel contains the following elements:

- Name of the data table
- Icons indicating the table state
- Red triangle menus containing table and script options
- (Optional) Table variables
- (Optional) Table scripts

### Table Options

Clicking on the red triangle menu next to the data table name shows these options:

**Tables**  Contains the same options as the Tables menu. See “Reshape Data” chapter on page 261.

**New Table Variable**  Creates a new table variable, which can be text or any other constant character value that you always want to be available in the data table. Table variables are normally used to document tables. See “Use Table Variables” on page 217 in the “Enter and Edit Data” chapter for more information.
Note: To rename a table variable, double-click on it and enter a new name in the Name field.

New Script    Creates a JSL script to save with the data table. After selecting this command, name the script and type in the value (the JSL commands). After you click OK, the new script is listed in the Table panel and you can click its red triangle menu to run, edit, or delete it. See “Create and Save Scripts” on page 218 in the “Enter and Edit Data” chapter.

Suppress Formula Eval    Turns off the feature that automatically evaluates formulas. You can turn off evaluation and build sections of a formula, and then turn evaluation on to test the formula.

Lock Data Table    Locks the data table so that data and column properties cannot be edited or added. You can still run analyses, assign characteristics, add rows and columns, and so on. See “Lock Tables” on page 216 in the “Enter and Edit Data” chapter.

Compress file when saved    Compresses the data table when it is saved. After the data table is saved, a compressed file icon appears next to the data table name in the table panel. See “Compress Tables” on page 216 in the “Enter and Edit Data” chapter.

The Compress file when saved option only decreases the file size. This command does not affect the memory required to analyze the data. To reduce both the file size and memory required for analyzing, use Cols > Utilities > Compress Selected Columns. See “Compress Selected Columns” on page 198 in the “Enter and Edit Data” chapter.

Tip: You can also configure JMP to always use GZ compression when saving tables by selecting Preferences > General > Save Data Table Columns GZ Compressed.

Disable Undo    Removes all actions from the undo history and does not record future actions. Undos are disabled only while the data table is open; the setting is not saved with the data table. This option saves memory, especially when you delete many rows or perform other tasks on the data table that require a large amount of memory to record the data.

Copy Table Script    Copies the script that re-creates the table. To re-create the table, put the copied script in a new script and run it. Note that referenced columns in virtually joined tables are not included in the script.

Rerun Formulas    Re-evaluates all columns containing formulas within the data table.

Script Options

To run a script from the data table panel, click the green triangle next to the script name. Right-clicking the script name or green triangle shows these options:

Run Script    Runs the script.
Tip: Run multiple table scripts at once by holding down the Control key, while selecting the table scripts you want to run. Then, right-click inside the empty area under the list of table scripts, and select Run Script.

**Debug Script**  
Opens the script in the JSL Debugger.

**Edit**  
Opens most scripts in the script editor so that you can edit it. Opens a JMP application script in Application Builder.

**Delete**  
Deletes the script.

**Copy**  
Copies the script. You can then paste it into the Table panel of another data table.

**Paste**  
Pastes the script from another data table.

**Additional Options**

In the Table panel, you can also perform the following tasks:

- Double-click a table variable or script name to edit the name and content.
- Drag a table variable or script to rearrange it.

**Columns Panel**

The Columns panel contains the following information:

- Column options (same options as the Cols menu)
- Total number of columns and number of columns selected in the data table
- A list of columns found in the data table
- Icons indicating each column’s modeling type (see “About Modeling Types” on page 226 in the “The Column Info Window” chapter)
- Icons representing characteristics and properties assigned to the columns (not shown, see Figure 2.7)

**Figure 2.6**  
Example of a Columns Panel

Icons to the right of each column name indicate characteristics and properties the columns contain.
Figure 2.7 Icons Indicating Column Characteristics and Properties

Note: Italics indicate that the column is locked into place. When you scroll horizontally, the column remains visible.

Icons that can appear in the Columns panel are described as follows:

- Indicates that points on plots corresponding to the column are labeled by the value instead of the row number. See “Label Rows and Columns” on page 188 in the “Enter and Edit Data” chapter.

- Indicates that the column is excluded from the calculations. See “Exclude Rows” on page 174 in the “Enter and Edit Data” chapter.

- Indicates that the column is not included in graphs. See “Hide Rows” on page 175 in the “Enter and Edit Data” chapter.

- Can be X or Y. Indicates that the column has been assigned the preselected role of x or y. See “Assign a Preselected Analysis Role” on page 260 in the “The Column Info Window” chapter.

- Indicates that the column contains one or more properties. Click to reveal a list of properties the column contains.

- Indicates that the values in the column result from a formula. When formula evaluation is suppressed, the icon appears gray. Double-click to view and edit the formula. See “Use Formula Editor Options” on page 321 in the “Formula Editor” chapter.

- Indicates that the range check or the list check option is turned on. Click to view and edit the range or list. See “Range Check” on page 236 in the “The Column Info Window” chapter and “List Check” on page 237 in the “The Column Info Window” chapter.

- Indicates that the column has been assigned the preselected role of weight. See “Assign a Preselected Analysis Role” on page 260 in the “The Column Info Window” chapter.

- Indicates that the column has been assigned the preselected role of frequency. See “Assign a Preselected Analysis Role” on page 260 in the “The Column Info Window” chapter.

- Indicates that the column values cannot be edited. See “About the Column Info Window” on page 224 in the “The Column Info Window” chapter.
Rows Panel

The Rows panel contains the following information:

- Row options (same options as the Rows menu)
- Total number of rows
- Number of selected (highlighted), excluded, hidden, and labeled rows

Figure 2.8 Example of a Rows Panel

Right-click the categories in the Rows panel to select rows, clear the selection, or to create a data view.

A data view creates a linked subset of the main data table. For example, if several rows are marked hidden, you might want to open a window that shows you only the hidden rows. Right-click Hidden in the Rows panel and select Data View.

Figure 2.9 Creating a Data View from the Rows Panel

When using a data view, continue to do most of your editing in the main data table. When you make changes in either the main data table or in the data view, the changes are reflected in both. You can make minor changes (such as changing some data or adding a column) in the data view. However, if you want to make major changes (like adding a formula) you must make those changes in the main data table.
Data Grid

The data grid is the main part of the data table that contains your data. Figure 2.10 illustrates how to interact with the data grid. See also “Select Rows” on page 158 in the “Enter and Edit Data” chapter.

Figure 2.10  Interacting with the Data Grid

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Hides or shows the data table panels.</td>
</tr>
<tr>
<td>2</td>
<td>Click to deselect any selected columns. To select all columns, hold down the Shift key and click.</td>
</tr>
<tr>
<td>3</td>
<td>Shows the columns menu.</td>
</tr>
<tr>
<td>4</td>
<td>Click to select the column.</td>
</tr>
<tr>
<td></td>
<td>Double-click to view the Column Info window. See “About the Column Info Window” on page 224.</td>
</tr>
<tr>
<td></td>
<td>Right-click for column options. See “Context Menu for Columns” on page 43.</td>
</tr>
<tr>
<td>5</td>
<td>Double-click the column name to edit it in the Column Info window, or select the column name and press Enter.</td>
</tr>
<tr>
<td>6</td>
<td>Click and drag to adjust the width of the column. To simultaneously adjust the widths of all of the selected columns, hold down the Alt key as you click and drag.</td>
</tr>
<tr>
<td>7</td>
<td>Click to select the row.</td>
</tr>
<tr>
<td></td>
<td>Double-click to open the Row Editor. See “Use the Row Editor to Edit Cells in a Row” on page 181 in the “Enter and Edit Data” chapter.</td>
</tr>
<tr>
<td></td>
<td>Right-click for row options. See “Context Menu for Rows” on page 44.</td>
</tr>
</tbody>
</table>
Context Menu for Columns

Right-clicking in a column heading shows these options:

- **Column Info**  Opens the Column Info window. See “About the Column Info Window” on page 224.
- **Column Properties**  Contains a list of column properties. Select one to open the Column Info window and apply it to the column. This list is also available from the Column Info window. See “Column Properties” on page 235 in the “The Column Info Window” chapter.
- **Formula**  Opens the Formula Editor. See the “Formula Editor” chapter on page 305.
- **New Formula Column**  Creates a formula column. See “Make a New Formula Column” on page 202 in the “Enter and Edit Data” chapter for details.
- **Insert Columns**  Inserts one or more columns before the selected column or columns.
- **Delete Columns**  Deletes all selected columns.
- **Label/Unlabel**  Labels or unlabels selected columns in all plots. See “Label Rows and Columns” on page 188 in the “Enter and Edit Data” chapter.
- **Link ID**  Used in virtually joined data tables to mark a column in the auxiliary data table as the ID column. That is, the rows of the data table are uniquely identified by the values of the ID column. The Link ID column property checkbox is selected if the column is the ID column for the data table. See “Virtual Join Properties” on page 252 in the “The Column Info Window” chapter for details.
- **Link Reference**  Used in virtually joined data tables to map a column in the main data table to the ID column in the auxiliary data table. The Link Reference column property specifies the path name of the auxiliary data table. See “Virtual Join Properties” on page 252 in the “The Column Info Window” chapter for details.
- **Sort**  Sorts all of the rows in the table by the values in the selected column. You can choose to sort the rows in ascending or descending order. See “Sort Data Tables” on page 265 in the “Reshape Data” chapter.
- **Copy Column Properties**  Copies all of the column properties for the selected column. Note that if you copy column properties for more than one column and then paste into a single column, all column properties are pasted into that single column.
Paste Column Properties  Paste all of the copied column properties into the selected column or columns.

Copy Multi Columns Properties  Copies all of the column properties for the selected columns. Supports adjacent and non-adjacent columns.

Paste Multi Columns Properties  Paste all of the copied column properties into the selected adjacent or non-adjacent columns. For example, select column one and column two and then select Copy Multi Column Properties. Select column three and column five and then select Paste Multi Column Properties. Column one properties are pasted into column three. Column two properties are pasted into column five.

Context Menu for Rows

Right-clicking in a row heading shows these options:

Hide and Exclude  Hides the selected rows in all plots and graphs and excludes them from analyses. See “Hide and Exclude Rows” on page 173 in the “Enter and Edit Data” chapter.

Exclude/Unexclude  Excludes or includes selected rows from analyses. See “Exclude Rows” on page 174 in the “Enter and Edit Data” chapter.

Hide/Unhide  Hides or shows selected rows in all plots and graphs. See “Hide Rows” on page 175 in the “Enter and Edit Data” chapter.

Label/Unlabel  Labels or unlabels selected rows in all plots. See “Label Rows and Columns” on page 188 in the “Enter and Edit Data” chapter.

Colors  Provides a color palette. Select a color to apply it to the selected rows. The color is used in plots and graphs. See “Assign a Color to Rows” on page 189 in the “Enter and Edit Data” chapter.

Markers  Provides a palette of markers or symbols. Select a marker to apply it to the selected rows. The marker is used in plots and graphs instead of points. See “Add Markers to Rows” on page 189 in the “Enter and Edit Data” chapter.

Color Rows by Row State  Colors the row the same as the current row state color. For more details, see “Assign Colors or Markers to Rows Based on Column Values” on page 189 in the “Enter and Edit Data” chapter.

Select Matching Cells  Selects rows in the active data table with values that match the selected row(s). See “Select Cells” on page 168 in the “Enter and Edit Data” chapter.

Invert Selection  Selects all previously deselected rows, and deselects all currently selected rows.

Clear Row States  Clears all active row states in the data table. All rows become included, visible, unlabeled, and show in plots as black dots. It does not affect row states saved in row state columns. See “Delete Row Characteristics” on page 196 in the “Enter and Edit Data” chapter.
**Add Rows**  Adds the specified number of rows to the data table. See “Add Rows” on page 154 in the “Enter and Edit Data” chapter.

**Delete Rows**  Removes all selected rows from the data table. Use the **Undo** command on the **Edit** menu to undo an accidental deletion. See “Delete Rows and Columns” on page 170 in the “Enter and Edit Data” chapter.

**Cursor Forms**

The cursor takes different forms, depending on its location in the data grid.

**Arrow Cursor**  The standard arrow cursor appears in the following locations:

- In the panels area to the left of the data table
- In the triangular rows and columns area, located in the upper left corner of the data grid
- In the middle or bottom of a column heading

You can perform the following actions with the arrow cursor:

- To select a column using the arrow cursor, click its name in the Columns panel.
- Double-click a column name in the Columns panel to edit it. Or, in the column heading, double-click on the column name to edit it.
- Click the triangular areas in the upper left corner of the data grid to deselect rows and columns.

**Selection (Large Plus) Cursor**  When the cursor is at the top of a column heading, or in a row number area, it becomes a large plus, indicating that you can select rows or columns. When you click, that row or column is selected and highlighted. Click and drag to select multiple rows or columns, and hold down the Control key and click to select discontiguous rows or columns.

- Double-click a column heading area to see the Column Info window for that column.
- Select a column to change the column name. The column highlights. Begin typing (if it is not in a locked column or locked data table).
- Double-click the row number area to edit the rows using the Row Editor.

**I-beam Cursor**  When you select editable text, the cursor becomes a standard I-beam. To edit text, position the I-beam within highlighted text. Click to mark an insertion point, or drag to select text for replacement.

**Double Arrow Cursor**  The cursor changes to a double arrow when it is on a column or a panel boundary. Drag this cursor left or right to change the width of a column or panel. Changing the width of a column does not affect the column field width specified in the Column Info window (accessed by double-clicking a column name).
Tip: You can adjust widths of all selected columns at once by pressing the Alt key as you drag the double arrow cursor on any of the selected column boundaries.

**List Check Cursor**  
The cursor changes form when you move the mouse over values in columns that have data validation in effect. It becomes a small, downward-pointing arrow on a column with list checking. When you click, the value is highlighted and the cursor becomes the I-beam. Enter or edit data as usual with any values defined as valid text or valid numbers. See “List Check” on page 237 in the “The Column Info Window” chapter, for details.

**Pointer Cursor**  
The cursor changes to a pointer over these objects:
- Red triangle menus for options
- Triangular disclosure buttons that open or close panels
- Data table titles for editing
- Table script titles for opening
- Modeling type icons for changing

**Open Data File Options**

Note: For more details about opening files, see the “Import Your Data” chapter on page 63.

To open a data file, select File > Open and select the file type. Some file types have additional features and options that appear in the Open Data File window. See Table 2.1.

Tips:
- Windows only: To open the same file type every time, select the Select this filter the next time this window is invoked check box.
- Open a file by dragging it onto the JMP Home Window.
- To change which directory the File > Open command looks in, see “File Locations” on page 524 in the “JMP Preferences” chapter.
### Table 2.1 File > Open Options by File Type

<table>
<thead>
<tr>
<th>File Type</th>
<th>Additional Features and Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Data Tables</td>
<td>Table notes, the number of columns (Cols), and the number of rows appear.</td>
</tr>
<tr>
<td></td>
<td>Use the <strong>Select Columns</strong> option to select which columns are imported into the data table. On Windows, click the arrow next to <strong>Open</strong> and then use the Select Columns option to specify which columns are imported into the data table. On Macintosh, you can select which columns to import after you click <strong>Open</strong>.</td>
</tr>
</tbody>
</table>
| Excel Files        | • Import the file in the Excel Import Wizard by default to customize the layout and preview the data before you import it.  
                                 • Click the arrow next to **Open** and then select one of the options. Convert the first spreadsheet row into column headings.                                           |
| Text Files         | • To automatically determine data arrangement, select one of the following options:                                                                                       |
|                    | – Open as data using preferences  
                                 – Open as data using a best guess  
                                 – Open as plain text into a script window  
                                 • To manually specify data arrangement, select the **Data with preview** option. See “Text Import Wizard Options” on page 136 in the “Import Your Data” chapter.                             |
| SAS Data Sets      | • Use SAS variables for column names  
                                 • (Windows only) Enter a password when you open a password-protected data set.                                                                                       |
|                    | • (SAS Transport files only) Select columns before opening                                                                                                                |
| SPSS Data Files    | Use SPSS variable or label names for column names.                                                                                                                       |
### Table 2.1  File > Open Options by File Type  *(Continued)*

<table>
<thead>
<tr>
<th>File Type</th>
<th>Additional Features and Options</th>
</tr>
</thead>
</table>
| All Files     | • To automatically determine data arrangement, select one of the following options:  
|               |   – Open as data using preferences  
|               |   – Open as data using a best guess  
|               |   – Open as plain text into a script window  
|               | • To manually specify data arrangement, select the **Data with preview** option.  
|               | • (Windows only) To open text files using your computer’s default text editor, select **Use default program to open**. |
Platforms

JMP consists of platforms that are organized by the type of statistical analysis. For example, the Distribution platform produces a univariate analysis (the distribution of a single variable) using histograms, additional graphs, and reports. You might analyze data in the Distribution platform and then choose another platform to examine the data more thoroughly.

Platforms and reports work together as follows:
1. The data table is the input for a platform. See “Data Tables” on page 35.
2. The platform analysis starts in a launch window. See “Launch Windows” on page 49.
3. The platform results appear in a report window. See “Reports” on page 52.

Figure 2.2 “Anatomy of a Typical JMP Session on Windows” on page 34 shows how a platform interacts with the data table and then displays the results in a report window. Information about using platforms is available in the JMP documentation library.

Launch Windows

The launch window is your point of entry into a platform, where you specify the columns to analyze. Figure 2.2 shows the Distribution launch window.

Figure 2.11 Launch Window Features

(Optional) Click the red triangle menu to select column options.

1. Select a column.
2. Click a button to assign the column to a role.
3. Click OK to launch the analysis.

All launch windows have in common provide the following options:

Select Columns  Lists all of the variables in your current data table. Note the following:
– Right-click the modeling type icon next to a column name to change the modeling type.
– Right-click the column name to create a transform column. See “Transform Columns” on page 202 in the “Enter and Edit Data” chapter.
– Filter and sort the columns using the options in the red triangle menu. See “Column Filter Menu” on page 51.

**Cast Selected Columns into Roles**  Moves selected columns into roles (such as Y, X, and so on.) You cast a column into the role of a variable (like an actor is cast into a role). See “Cast Selected Columns into Roles Buttons” on page 50.

In the Graph Builder window, click the **Dialog** button on the left or select **Redo > Relaunch Analysis** to show this panel.

**Action**  The following options are available:

- **OK**  performs the analysis.
- **Cancel**  stops the analysis and quits the launch window.
- **Remove**  deletes any selected variables from a role.
- **Recall**  populates the launch window with the last analysis that you performed.
- **Help**  takes you to the Help for the launch window.

**Cast Selected Columns into Roles Buttons**

The following buttons frequently appear throughout launch windows. Buttons that are specific to certain platforms are described in the chapter for the specific platform.

- **Y**  Identifies a column as a response or dependent variable whose distribution is to be studied.
- **X**  Identifies a column as an independent, classification, or explanatory variable that predicts the distribution of the Y variable.
- **Weight**  Identifies the data table column whose variables assign weight (such as importance or influence) to the data.
- **Freq**  Identifies the data table column whose values assign a frequency to each row. This option is useful when a frequency is assigned to each row in summarized data. If the value is 0 or a positive integer, then the value represents the frequencies or counts of observations for each row when there are multiple units recorded.
- **Validation**  Identifies the data table column whose values assign rows to training, validation, and test sets for crossvalidation in fitting models.

**Notes:**

- For some platforms, KFold validation is available if you specify more than three levels in the Validation column.
If you click the Validation button with no columns selected in the Select Columns list, you have the option to create a Validation column. For more information about the Make Validation Column utility, see the Modeling Utilities chapter in the *Predictive and Specialized Modeling* book.

**By** Identifies a column that creates a report consisting of separate analyses for each level of the variable.

**Tip:** You can paste a transform column into a Roles box on the launch window. For example, you might copy a transform column from a script. Right-click in the appropriate launch window Cast Selected Columns into Roles box and select Paste. This is an alternative to right-clicking the column in the Select Columns list, selecting the transform, and adding the transform column to a role.

### Column Filter Menu

A Column Filter menu appears in most of the launch windows. The Column Filter menu is found by clicking the red triangle in the Select Columns panel. Use these options to sort columns, show or hide columns, or search columns.

**Figure 2.12** The Column Filter Menu

![Column Filter Menu](image)

- **Reset** Resets the columns to its original list.
- **Sort by Name** Sorts the columns in alphabetical order by name.
- **Modeling Type** Provides options for showing or hiding columns with specific modeling types.
  - **Numeric** Shows or hides columns whose data type is Numeric.
  - **Character** Shows or hides columns whose data type is Character.
  - **Expression** Shows or hides columns whose data type is Expression.
Match case  (Only applicable to the Name options below) Makes your search case-sensitive.

Name Contains  Searches for column names containing specified text. To remove the text box, select Reset.

Name Does Not Contain  Searches for column names that do not contain specified text. To remove the text box, select Reset.

Name Starts With  Searches for column names that begin with specified text. To remove the text box, select Reset.

Name Ends With  Searches for column names that end with specified text. To remove the text box, select Reset.

Exclude Formats  Excludes columns with specific formats from the column selection list. Select from the following formats: date, time, duration, geographic, or all numeric formats.

Column Groups  Shows or hides groups of columns. See “Group Columns” on page 171 in the “Enter and Edit Data” chapter.

Ungrouped Columns  Shows or hides columns that have not been grouped.

Reports

After you launch your analysis, the report window appears. The report window shows the output of your analysis using interactive graphs and text reports. For details, see the “JMP Reports” chapter on page 347.

Figure 2.13 Report Window Features

Place your cursor over the blue bar to reveal the main menu and toolbars.

Click a red triangle menu to access options.

Click a bar or point to highlight the corresponding rows in the data table.

Right-clicking areas in the report window provides additional options.

Click a disclosure button to hide or show parts of the report.
Manage JMP Files and Open Windows

The JMP Home Window provides instant access to open window and files. Opening recently opened files, closing windows, and pinning frequently used files are a few of the options.

JMP Home Window on Windows

On Windows, the JMP Home Window appears when you open JMP.

- Open recent files in the Recent Files list or pin a frequently used file.
- Right-click files in the Recent Files list to perform common tasks.
- Open or close active JMP windows in the Window List.
- Set an open data table as the current data table by selecting it from the data table list at the top.
Get Started
Manage JMP Files and Open Windows

Chapter 2
Using JMP

Figure 2.14 JMP Home Window Actions

JMP Home Window Buttons

On Windows, the JMP Home Window panels can contain the following buttons:

- The Open Selected button opens the selected files in the Recent Files list.
- The Sort By Name button sorts recent files alphabetically.
- The Filter button filters the types of files that appear in the Recent Files and Window List panels.
- Enlarges the font size and icon size of items in the Recent Files list.
- The Close button closes the panel.
Recent Files

On Windows, the Recent Files list provides quick access to files that you recently opened. Keep your favorite files at the top of the list for quick access. Place your cursor over the filename and click the pin icon ᶠ. To unpin a file, click the pin icon ˻. You can drag files from the Recent Files list as follows:

- into the JMP Window List to open the file
- into a Windows folder or on to your desktop to create a copy of the file
- into applications such as Microsoft Notepad or Microsoft Word to edit the file

Right-click files to access the following options:

- Open a file
- Copy the location path to a file
- Open a file within the folder that contains it
- Sort files alphabetically by name or by most recent
- Remove a file or remove files that are no longer in the same location (Alternatively, you can select files and press the DELETE key.)
- (JSL scripts) Edit, run, or debug a script
- (Text files) Change the import method or open as plain text
- (SQL queries) Run an SQL query that you saved in Query Builder. You can also create a new query using an existing query as a template.
- Run or edit a JMP application

When you open a non JMP file from the Recent Files list, JMP applies your import preferences to arrange the data. You can right-click on a text file to change the import method or to open the file in a text editing window. Your import preference is bolded in the right-click menu.

Tip: To prevent scripts from appearing in the Recent Files window, select File > Preferences > General and de-select Add files opened by scripts to the Recent Files list.

Search the Recent Files List for JMP Files

To find a recently opened file in a long list of files, enter part of the file name in the Recent Files Filter box.

The following options are provided:

- Enter part of the file name in the Filter box above the list of files.
- Place your cursor over the Filter box to view search tips.
As the files are filtered, the Up and Down arrow keys change the selected file. Press Enter to open the selected file, or select the file with your cursor.

If a file is selected in the Recent Files list, press Ctrl and then F to activate the Filter box.

Press Esc or click the X button to exit the filtering mode after you typed a search term.

**Window List**

On Windows, the Window List shows open JMP windows, such as data tables, reports, and scripts. You can open, close, rearrange, and hide JMP windows.

- If you place your mouse pointer over a file in the Window List, a thumbnail appears.
- To open the Window List in its own window, select View > Window List.
- To display windows side-by-side, right-click the selected windows and select Arrange.
- To always automatically display the Window List inside maximized windows, select File > Preferences > Windows Specific and select Dock the Window List in maximized windows.

Right-click files to access the following options:

- View a window
- Close a window (Alternatively, you can select files and press the DELETE key.)
- Close all windows except the currently selected window (if the selected window is a report window, the dependent data table also remains open)
- Move a window to the back
- Hide a window from the Windows taskbar or unhide a window
- Select all windows, or clear all selections

**Rearrange Panels in the Home Window**

To rearrange the panels in the Home Window on Windows, click and drag the title bar of the panel. Drop the title bar onto a top, bottom, left, or right arrow to position the panel. A blue box indicates where the panel will be placed. To turn the panels into tabs, drag and drop any panel into the middle of the Home Window.

**Tips:**

- To put the Home Window back into its original order, select View > Home Window Panes > Revert to Factory Layout.
- If you close a panel and want to reopen it, select View > Home Window Panes and select the panel that you want to open.
• Open the JMP Home Window by selecting **View > Home Window** or clicking the **JMP Home Window** button in the lower right corner of most JMP windows. If you cannot see the **JMP Home Window** button, select **View > Status Bars**.

• If you prefer to see the JMP Starter or the Window List upon start-up, you can specify that in the Preferences (Windows only). Select **File > Preferences > General** and select an option from the Initial JMP Window list.

### JMP Home Window on Macintosh

Use the JMP Home window on Macintosh to quickly access JMP files and open windows.

- Open recent files in the Recent Files list.
- Press Control and select files in the Recent Files list to perform common tasks.
- Open or close active JMP windows in the Window List.
- Add a recent file to the Favorites list. Select the file in the Recent Files list, press Control, and select **Add to Favorites**. To remove the file from the list, select the favorite file, press Control, and select **Remove from Favorites**. You can also drag the file onto the desktop to remove it from the Favorites list.
- Set an open data table as the current data table by selecting it from the Set Active Table list.
- Open the log.

The two buttons in the upper left corner of the JMP Home window let you manage recent files and favorites.

- Click `<` to show or hide the Favorites list.
- Click `›` to remove files from the Recent Files list.

Open the JMP Home window on Macintosh by selecting **Window > JMP Home** (Figure 2.15). To view the window each time you open JMP, select **JMP > Preferences > General > Home Window**.
Figure 2.15 Example of the JMP Home Window (Macintosh)

Tip: The Status bar area shows the path for the currently selected file. You can click on a folder to open the folder to view its contents.

Recent Files

On Macintosh, the Recent Files list provides quick access to files that you recently opened. You can drag files from the Recent Files list, as follows:

- into the Window List to open the file
- into the Favorites list to save the file as a favorite

Press the Control key and select a file to access other options. For example, you can run or debug a JSL script by holding down the Control key and selecting Run Script or Debug Script.

Tip: To prevent scripts from appearing in the Recent Files window, select File > Preferences > General and de-select Add files opened by scripts to the Recent Files list.

Window List

On Macintosh, the Window List shows open JMP windows, such as data tables, reports, and scripts.

Press the Control key and click to close a window.

If the selected window is a parent to one or more children, a window appears, prompting you to Hide Data Table, Cancel, or Close All windows. Select Close All to close the parent and all its children windows.
Search for Recently Opened Files on Windows

Recently opened files are listed in the Home Window. You can also search for recently opened files from any JMP window.

Select File > Quick Open or press Alt, Shift, and then O to open the Filter box and enter your search term. This option also lets you view the path of the file. Press Esc or click the X button to close the window after you type a search term.

Close Multiple Files

On Windows, close several files at once from the JMP Home Window. Select the files in the Window List, right-click, and select Close. To leave a single file opened and close the rest, select the single file and then select Close All But This.

On Macintosh, select File > Close Multiple and then select the files that you want to close.

Display and Arrange Open Windows

In JMP, typically you have several windows open at once (for example, data tables, reports, and the JMP Home Window). JMP provides several ways to arrange and display these open windows.

On Windows:

- Press the Control and Tab keys to switch between windows.
- Use the Reveal feature (F9 or Window > Reveal). See “Using the Reveal Feature” on page 61.
- Use the options in the Window menu. Note that Arrange options are also available using the Arrange Menu option in the bottom right corner of most windows. If you cannot see Arrange Menu, JMP Home Window, and View Associated Data buttons, select View > Status Bars.

**Tip:** From the Arrange Menu option on Windows, you can merge open windows by selecting Combine Windows. See “Example of Combining Windows to Create a Dashboard” on page 464 in the “Extend JMP” chapter for details.

- To display the JMP Home Window, click the JMP Home Window button in the lower right corner of most windows, or hold down Control and press 1.
- To show the data table for a report, click View Associated Data button in the bottom right corner of the report.
- To open an associated report when you are viewing a data table, double-click the thumbnail preview of the report in the bottom pane. To enlarge the preview, place your cursor over the thumbnail. See Figure 2.16.
Figure 2.16  Thumbnail Previews of Open Reports

On Macintosh:

- Use the options in the Window menu.
- Use the Expose feature (F9 or F3).

Preview JMP Files

For some JMP file types, you can use Windows Explorer or the Macintosh Finder to view a portion of the selected file. Windows supports a preview of JMP data tables, journals, and scripts. Macintosh supports a preview of data tables and scripts.

To preview a JMP file

1. In Windows Explorer or the Macintosh Finder, select the file that you want to preview.
2. In Windows Explorer, select the Show the preview pane button in the upper right corner. Support in e-mail programs varies.
   In the Macintosh Finder, select the file and press the spacebar, or select the Quick Look option on the context menu or File menu. In Mail, select the Quick Look Attachment option on the context menu or File menu.

   The preview pane shows a portion of the selected file.
Using the Reveal Feature

On Windows, press F9 to use the Reveal feature. The Reveal feature shows a top-level window with thumbnails of all open JMP windows.

- Click on a window to activate it.
- Press the spacebar to turn on Preview mode, where a full-sized view of the thumbnail under the cursor appears in the center of the screen.
- By default, the windows are ordered to match the original ordering on the screen in a top-down, left-to-right order. Press S to sort the thumbnails by name.

To exit the Reveal feature, press F9, Esc, or Alt and Tab and then select another application.

JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus.
To open the JMP Starter window, select **View (Window on the Macintosh) > JMP Starter**.

To display the JMP Starter automatically when you open JMP on Windows, select **File > Preferences > General**, and then select **JMP Starter** from the Initial JMP Window list. On Macintosh, select this option on the **JMP > Preferences > General** page.

Figure 2.18 shows the JMP Starter window for Windows. The Macintosh JMP Starter window is identical.

**Figure 2.18** The JMP Starter Window (Windows)
This chapter covers the following topics:

- How to import data into JMP, such as text files, SPSS files, and SAS data
- How to transfer Excel data into a JMP data table
- How to read in real-time data
- How to create a new data table

**Figure 3.1 Importing a Text File**
About Importing Data to JMP

You can import many file formats into JMP and save them as data tables. JMP opens many files by default. The file formats which JMP does not support by default require specific Open Database Connectivity (ODBC) drivers.

The Following File Formats Are Supported by Default:

- Comma-separated (.csv)
- .dat files that consist of text
- ESRI shapefiles (.shp)
- Flow Cytometry versions 2.0 and 3.0 (.fcs)
- Hierarchical Data Format, Version 5 (.h5)
- HTML (.htm, .html)
- JSON (.json)
- MATLAB (.m, .M)
- Microsoft Excel 1997 through 2016 (.xls, .xlsx on Macintosh)
- Microsoft Excel 2007 through 2016 (*.xlsx, *.xlsm on Windows)
- Minitab Portable Worksheet (.mtp)
- Plain text (.txt)
- R (.r)
- SAS transport (.xpt, .stx)
- SAS versions 7 through 9 on Macintosh (.sas7bdat)
- SAS versions 7 through 9 on Windows (.sas7bdat, .sas7bxat)
- SPSS files (.sav)
- Tab-separated (.tsv)
- Teradata database (.trd)
- Triple-S (.sss, .xml)
- xBase data files (.dbf)

Notes on SAS Support:

On both Windows and Macintosh, you can open SAS data sets directly through the File > Open command. See “Import SAS Data Sets” on page 78 for details.

Another option is connecting to a SAS server by selecting File > SAS > Browse Data. See “Open SAS Data Sets through a SAS Server” on page 87 for details.
The Following Files Require ODBC Drivers:

- Database (dBASE) (.ndx, .mdx) is supported with a V3+ compliant ODBC driver. .dbf files do not require an ODBC driver.
- Microsoft Access Database (.mdb) is supported with a V3+ compliant ODBC driver.

See “Import Data from a Database” on page 124 for details for working with databases.

Your computer’s available memory affects data import. Very large files might load slowly or not at all. Consider splitting up large files before importing them. In JMP, you can then join or concatenate the tables. For more information, see “Concatenate Data Tables” on page 279 in the “Reshape Data” chapter and “Join Data Tables” on page 282 in the “Reshape Data” chapter.

**Note:** You can open R code (.R) and SAS program files (.sas) in JMP, but the text opens in a Script window, not in a data table.

### Import Microsoft Excel Files

Microsoft Excel files open in the Excel Import Wizard by default. The wizard shows a preview of the data. You can then modify the settings before importing the data. For example, you might indicate which row the data begin on and whether the worksheet contains column headers or hidden rows or columns. Microsoft Excel .xls, .xlsm, and .xlsx file formats are supported.

For information about opening a Microsoft Excel file outside the wizard, see “Import a Microsoft Excel File Directly” on page 76.

**Notes:**

- Password-protected Microsoft Excel .xlsx files cannot be opened in JMP.
- Between Windows and Macintosh, the number of digits after a decimal point and the date format of imported data might differ. For example, “10/25/2012” might be formatted as “25Oct2012” on Macintosh. Columns might be imported as character columns on Macintosh but not on Windows.
- Consider setting the Autosave Timeout value in the General preferences to automatically save open data tables. This autosave value also applies to other JMP document types.

### Preview and Import the Microsoft Excel Data

Before you import a worksheet, open the spreadsheet in Excel and decide how you want the data to be structured in the final data table. For example, you need to know whether the worksheet includes hidden or merged cells. In the wizard, you can then exclude hidden columns or rows.
To import a Microsoft Excel file that contains several worksheets, follow these steps:

1. Open the worksheet in Microsoft Excel.
   For the figures in this example, we used the Team Results.xlsx file located in the JMP Samples/Import Data folder. The file has the following characteristics:
   - the data begin on row 4, column 2 and end on row 9, column 5
   - two worksheets
   - the second worksheet has two sets of merged cells
   - no hidden rows or columns

   **Figure 3.2 Team Results.xlsx Worksheet**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Here are the team results for this year's game.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Team</td>
<td>Member Name</td>
<td>Age</td>
<td>Winnings</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>Joe</td>
<td>21</td>
<td>$56.22</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>Mary</td>
<td>22</td>
<td>$34.34</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>Cindy</td>
<td>23</td>
<td>$25.54</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>Mark</td>
<td>22</td>
<td>$52.11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>Bill</td>
<td>23</td>
<td>$43.82</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>2</td>
<td>Jennifer</td>
<td>24</td>
<td>$11.23</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2. To open an Excel file in JMP, select **File > Open**.
   The Open Data File window appears.

   The worksheet opens in the Excel Import Wizard, where a preview of the data appears along with import options (Figure 3.3).

---

**Figure 3.3 Excel Import Wizard**
Chapter 3
Using JMP

Chapter 3
Import Your Data

Using JMP Import Microsoft Excel Files

Figure 3.3 Example Initial Data Preview

Note the following characteristics in the Data Preview:

– Both worksheets are selected for import in the upper right corner.
– The first column has been automatically been removed.
– Text from the first row of the worksheet appears as the column headings. However, you want the text in row 3 of the worksheet to be used as the column headings.
– The first data row is empty.

Note: JMP remembers your previous changes each time you import a worksheet, even after closing and reopening JMP. This feature is helpful when you want to reimport the same worksheet several times and experiment with options. To clear those changes when you import a different worksheet, click Restore Default Settings.

4. Type 3 for Column headers start on row
5. Type 4 for Data starts on row.
6. Select Ungrouped Team Results in the Worksheets pane.
   Only this worksheet will be imported.
7. Deselect Use for all worksheets.
   These settings apply only to Ungrouped Team Results.
   Figure 3.4 shows your changes.
Figure 3.4 Selecting the Column Header Row

See “Individual Worksheet Settings” on page 69 for details about all options.

8. Click **Next** to configure other import settings.

The window displays additional import settings.


10. For **Data ends with column**, type 5.

Figure 3.5 shows your changes.
Figure 3.5 Specifying the Last Column

See “Additional Individual Worksheet Settings” on page 70 for details about all options.

11. Click **Import** to convert the worksheet as you specified (Figure 3.6).

Figure 3.6 Final Data Table

The following sections describe options in the Excel Import Wizard.

**Individual Worksheet Settings**

**Worksheet contains column headers**  Select if the worksheet contains rows with column headers.
**Column headers start on row** Indicates which row the column headers begin on in the worksheet. Click the up arrow until the headers begin on the correct row, or enter the row number and press Enter.

**Number of rows with column headers** Indicates whether the worksheet has multiple rows as column headers. Click the up arrow until the header rows appear correctly, or enter the number of rows and press Enter.

**Data starts on row** Indicates which row the data start on in the worksheet.

**Data starts on column** Indicates which column the data start on in the worksheet.

**Concatenate worksheets and try to match columns** Merges all worksheets into one data table. JMP matches columns that have the same header.

**Create column with worksheet name when concatenating** Adds a new Source Table column that lists the worksheet name for each imported table. This option is available after you select the preceding concatenate option.

**Use for all worksheets** Applies the current import settings to all worksheets that are selected in the upper right corner.

### Additional Individual Worksheet Settings

**Treat multiple column header lines as hierarchies** Indicates that the worksheet contains multiple rows as column headers and you want these headers to be hierarchies. This option is only for stackable data.

**Replicate data in spanned rows** Indicates cells are merged in the worksheet across rows. JMP unspan the cells and copy the cell contents into all of the resulting cells. The option is selected by default.

If you deselect **Replicate data in spanned rows**, JMP unspans the cells and copies the cell contents into the topmost cell. The remaining unspanned cells are left empty.

**Suppress hidden rows** Prevents hidden rows from appearing in the data table.

**Suppress hidden columns** Prevents hidden columns from appearing in the data table.

**Suppress empty columns** Indicates whether an empty column that has a column header is imported. Deselect the option to import the column.

**Data ends with row** Indicates the last row in the worksheet that contains data.

**Data ends with column** Indicates the last column in the worksheet that contains data.

### Advanced Options

**Column Name Separator String** Indicates the separator between each word in a column heading if the headings were originally in different rows. Specify the number of rows with column headers on the first Excel Import Wizard window. Then enter a character or space.
in the Column Name Separator String box. The default string, a hyphen, results in a column heading such as “First-Second-Third”.

**Multiple Series Stack**  Divides subcategories into separate columns in a worksheet with hierarchical headings. You must also select **Treat multiple column header lines as hierarchies**. The main category is imported as the Label column.

**Replicate headers in spanned rows**  Repeats the header text in each cell for rows that are spanned in the worksheet. For example, the State column heading shown in Figure 3.7 was in a merged cell in the worksheet. On the left, the heading is replicated. Deselect the option to avoid repeating the heading as shown on the right.

**Figure 3.7** Replicated Headers in a Microsoft Excel File

<table>
<thead>
<tr>
<th>Replicated headers</th>
<th>Unreplicated headers</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="State-State" /></td>
<td><img src="image" alt="State" /></td>
</tr>
</tbody>
</table>

**Import cell colors**  Applies the cell coloring from the worksheet to the data table. On the Mac, only primary and secondary colors can be reliably imported.

**Limit column type detection**  Scans a maximum of 100 rows to determine the column type. Select this option to speed up the import of large worksheets.

**Tips:**

- JMP remembers your previous changes each time you import a worksheet, even after closing and reopening JMP. This feature is very helpful when you want to reimport the same worksheet several times and experiment with options. To clear those changes when you import a different worksheet, click **Restore Default Settings**.
- Your import settings are saved in a data table script named Source. To reimport the worksheet using the same settings, run the script. The script includes the path to the worksheet, so make sure that other users have access to that location.
- To speed up the data preview in large worksheets, deselect **Update settings on any change** on the first wizard window. Modify the settings and then click **Update now** to refresh the data preview.
- To view all rows in the Data Preview pane, select **Show all rows**. The preview might be slightly delayed depending on the size of the spreadsheet.
• You can combine two worksheets from the same workbook into one data table. The column names are matched on import, so the order of the columns is irrelevant.

**Importing a Microsoft Excel File with Hierarchical Headings**

In an Excel worksheet, multiple header rows can have an implied hierarchy; the second header row contains data that are categories of the first header row. Figure 3.8 shows an example. In the worksheet at the top, the seasons “Winter” and “Spring” are in spanned cells above the months within those seasons. In the JMP data table, you want the seasons in one column and their corresponding months in another column.

**Figure 3.8** The Original Data in Excel and Final Data in JMP
To import the worksheets and maintain multiple column hierarchies, follow these steps.

1. In JMP, select **File > Open**.

2. In the Open Data File window, select *Texas Precipitation.xlsx*, located in the JMP Samples/Import Data folder, and then click **Open**.

   The worksheet opens in the Excel Import Wizard, where a preview of the data appears along with import options.

**Figure 3.9 Excel Import Wizard Preview**

Figure 3.9 shows the default settings for this worksheet:

1. All worksheets are selected for import.

2. Each season is split over several columns.

3. Data from the second heading row of the worksheet appear in the first row.

4. The empty rows at the top have been removed.

3. Under Preview Pane Refresh, make sure that **Update settings on any change** is selected.
This means that the Data Preview automatically refreshes when you make changes.

4. Next to **Number of rows with column headers**, click the up arrow once.
   
   Notice that **Data starts on row** automatically updates to 3.

   Figure 3.10 shows the updated settings.

**Figure 3.10** Updated Settings on Page One

5. Click **Next**.

6. Select **Treat multiple column header lines as hierarchies**.

   Each season and month in the header rows of the worksheet will become categories in the data table.

7. Next to **Data ends with row**, type 6 and press Enter.

   After the first three empty rows are removed from the worksheet, the data end with row 6.

   **Tip:** Instead of you typing the end row number, JMP can calculate the row for you. In the Data Preview pane, select row 9, which is where the data ends in the spreadsheet before the first three empty rows are removed. Click the plus sign next to **Data ends with row**.

   Figure 3.11 shows the updated settings.
Notice that **Replicate data in spanned rows** is selected by default. JMP unmerges data that were merged in the worksheet and copies the cell contents as separate categories. “TX” was originally in a merged cell. In JMP, it will be copied into separate cells.

8. Click **Import**.

The four worksheets open as separate data tables. The data tables contain a Source script, which you can run to import the data into new data tables using the same import settings (Figure 3.12). Your import settings are also saved the next time you open the worksheet in the Excel Wizard in any JMP session.
Import a Microsoft Excel File Directly

Microsoft Excel files open in the Excel Import Wizard by default. This option is helpful when the structure of data in the worksheet is irregular. For example, you might want to exclude hidden columns or convert text in the third row to column headings.

Instead of opening spreadsheets in the Excel Import Wizard, you can select File > Open to open the file. By default, JMP detects whether the first row contains labels and converts them to column headings. You can change this setting in the General preferences. The Excel Open Method preferences are in File > Preferences > General (Windows) and JMP > Preferences > General (Macintosh). From the Use Excel Labels for Headings list, select Always or Never.

To set the Excel Open Method preference

To always open Microsoft Excel files outside the wizard, change the Excel Open Method preference. Choose to open all worksheets at once or select them from a list.

To open a Microsoft Excel file (Windows)

1. After you set the Excel Open Method as described above, select File > Open.
2. Select the Excel Files file type, select the file, or enter the URL.
3. To convert text in the first row to column headings, select Always next to Always enforce Excel Row 1 as labels.
4. To import all worksheets, click Open.
   or
   To select the worksheets that you want to open, click the Open button arrow, and then select Open Selected Worksheets. Select one or more worksheets and click OK.
To open a Microsoft Excel file (Macintosh)

1. Select File > Open and select the file.
2. (.xls only) To convert text in the first row to column headings, select Use Excel Labels as Headings.
3. (.xls only) To open specific worksheets, select Select Individual Excel Worksheets.
4. Click Open.

   If you chose to open specific worksheets, select those worksheets from the list, and then click OK. You can also click Select All if you change your mind and want to import all worksheets.

   If you chose to open specific worksheets, select those worksheets from the list, and then click OK. You can also click Select All if you change your mind and want to import all worksheets.

   If you selected an .xlsx file, a preview of the data appears in the Excel Wizard. See “Preview and Import the Microsoft Excel Data” on page 65 for details.

Import Data from SAS

You can connect to a SAS server and work directly with SAS data sets:

- Import whole SAS data sets or portions of data sets
- Make changes to imported SAS data in JMP and then export those changes as a SAS data set
- Run stored processes
- Submit SAS code from JMP

Java Runtime Environment (JRE) Requirements

- On Windows, Java Runtime Environment (JRE) 7 or later must be installed on your computer to access SAS. However, JRE 7 does not need to be specified as the current version.
- On Macintosh, JRE 7 or later must be installed for SAS integration.

Note: On Windows, the bitness of the JRE must match that of JMP. For example, 64-bit JMP communicates with 32-bit SAS if the 64-bit JRE is installed. 32-bit JMP communicates with 64-bit SAS if the 32-JRE is installed.

Access SAS options from the File > SAS menu:

Browse Data Browse and import data residing on a SAS Server.
Import Your Data

Chapter 3
Import Data from SAS

**SAS Query Builder**  Select and import data on a SAS server without writing SQL statements. See “Build SQL Queries in Query Builder” on page 102 for details.

**Export Data to SAS**  Export JMP data tables to a SAS Server.

**Browse SAS Folders**  Browse and run SAS stored processes or open Metadata-defined data tables.

**New SAS Program**  Opens a script window for writing and submitting SAS code.

**Submit to SAS**  Sends SAS code directly from JMP to the currently active SAS server.

**Open SAS Log Window**  Opens a SAS log window for the active SAS server.

**Open SAS Output Window**  Opens a SAS output window for the active SAS server. This window shows recent SAS output.

**Server Connections**  Administer connections to SAS servers.

You can also find shortcuts for SAS options on the SAS page of the JMP Starter, and there is a SAS toolbar. You can save certain settings pertaining to SAS Integration on the SAS Integration page of the Preferences window (File > Preferences). For more information about setting your SAS Integration preferences, see “SAS Integration” on page 528 in the “JMP Preferences” chapter.

---

**Import SAS Data Sets**

SAS data sets are saved in one of many SAS formats:

- Windows supported formats are `.sas7bdat` and `.sas7bxat`.
- Macintosh supports reading and writing `.sas7bdat` files.
- Windows and Macintosh support reading and writing `.xpt` files

When you open a data set in JMP, the file opens as a data table. JMP uses SAS variable names as column names by default. To use variable labels in a specific file on Windows, select the option when you open the file (see step 5 below).

The following ISO date formats are supported: B8601DA, B8601DN, B8601DT, B8601DZ, B8601LZ, B8601TM, B8601TZ, E8601DA, E8601DN, E8601DT, E8601DZ, E8601LZ, E8601TM, E8601TZ. If the date format is not supported, the data is imported with the Scientific Notation format.

To open a SAS data set:

1. Select **File > Open**.
2. (Windows only) Select **SAS Data Sets** from the list next to **File name** as shown in Figure 3.13.
Note: SAS variable names and formats are preserved and can be saved after changes are made to the SAS data set. See “Save as a SAS Data Set” on page 423 in the “Save and Share Data” chapter.

3. Select the file.

Figure 3.13  Open SAS Data Set

4. (Optional) Select any of the following options:

   **SAS variable labels**  Uses the SAS variable labels (instead of variable names) as the column names in the JMP data table.

   **SAS variable names**  Uses the SAS variable names (instead of the labels) as the column names in the JMP data table.

5. (Optional on Windows) Select any of the following options:
Apply table and column properties from SAS 9.4 extended attributes  If the SAS server supports extended attributes (SAS 9.4), includes the extended attributes when storing JMP metadata. This setting overrides the SAS 9.4 Extended Attributes preference on the SAS Integration page.

Select this filter the next time this dialog is invoked  Sets the default file type choice to the option that you select next to the File name list If selected, the default file type will be SAS Data Sets the next time you reach this window.

6. (Optional) Select any of the following for a SAS Transport (.xpt) file:

Select member  Lets you enter the name of a specific member, or table, for JMP to open. On Macintosh, select Member Tables > Specified and then enter the name.

Open all members  Opens all members, or tables, in the transport file. On Macintosh, select Member Tables > All.

Save all members  Saves the file as a JMP file as soon as you open it. The file is saved to the same directory where the SAS transport file was opened. On Macintosh, the option is Save all.

Select Columns  Tells JMP to open only certain columns from the transport file. Select the columns that you want to import from the list that appears. On Macintosh, the option is Select columns before opening.

7. Click Open.

Note: If you are importing date variables from a SAS file, JMP looks for a SAS date format and translates it to a JMP date column.

Create SAS Transport Files in SAS

JMP can open SAS transport files that were saved using the SAS XPORT engine. For example, below is sample SAS code that creates a transport file called test.

Note: misc and work are SAS libref names.

data test;
  input name $ age weight;
cards;
Susan  12  72
Melanie 10  68
Jonathan 11  77
Sheila 13  67
; 
libname misc xport 'C:/test.xpt';
proc copy in=work out=misc;
run;
Connect to SAS

You can either connect to a SAS Metadata Server or directly to a SAS Workspace Server. Once connected to a SAS Metadata Server, you can browse through SAS servers, libraries, and data sets.

Note: SAS Server version 9.4 is the default setting in the JMP SAS Integration preferences. The earliest supported release of the SAS Metadata Server is version 9.1.3 SP4. Connections to earlier releases of the SAS Metadata Server are experimental and are not supported.

To begin, select File > SAS > Server Connections. The SAS Server Connections window shown in Figure 3.14 appears. All connections are made in this window.

Figure 3.14 SAS Server Connections

The following sections describe how to connect to a SAS server.

- “Connect to a SAS Metadata Server” on page 82
- “Connect to a Remote SAS Workspace Server” on page 84
- “Connect to a SAS Environment (Windows Only)” on page 85
- “Connect to SAS on Your Local Machine (Windows Only)” on page 86
Connect to a SAS Metadata Server

Note: You can be connected to only one Metadata Server at a time. If you make a second connection, your first one is disconnected.

To connect to a Metadata Server

1. Select File > SAS > Server Connections. The SAS Server Connections window shown in Figure 3.14 on page 81 appears.
2. Select the version for the SAS Server. Your SAS Metadata Server administrator should have this information.
   SAS Server version 9.4 is selected by default based on the JMP SAS Integration preferences.
3. Select the profile that you want to use.
   If you do not have a profile set up, see “To create or modify a SAS Metadata Server profile” on page 84.
4. Click Connect.
   If JMP is unable to establish a connection, an error message appears. Common reasons are invalid user names or passwords. If you need to update the information for the profile, see “To create or modify a SAS Metadata Server profile” on page 84.
5. Click Close.

Once you are connected to a SAS Metadata Server, you can connect to any SAS Workspace Servers that the Metadata Server offers.

To connect to a SAS Workspace Server (Windows only)

1. Select File > SAS > Server Connections. The SAS Server Connections window shown in Figure 3.14 on page 81 appears.
2. Select the Workspace Server to connect to (Figure 3.15).

Figure 3.15 Open a Connection to a Workspace Server
Chapter 3
Using JMP

Import Your Data

Import Data from SAS

**Note:** Connect to all available libraries is selected by default based on the SAS Integration preferences. This option connects metadata-defined SAS libraries automatically across all JMP sessions. When the Workspace Server contains a large number of metadata-defined SAS libraries, consider deselecting this option to speed up your connection to the server.

3. Click **Connect**.

   Under Open Workspace Server Connections, the Workspace Server is shown as the current active connection. See Figure 3.16.

![Figure 3.16 Current Active Connection](image)

4. Click **Close**.

   To change the active connection

   **Note:** The active connection is what is used to submit SAS code or handle SAS script commands.

   To change the active connection, you first need to be connected to more than one server. Follow the instructions in “To connect to a SAS Workspace Server (Windows only)” on page 82 to add two or more server connections.

   1. In the Open Workspace Server Connections section, click the drop-down menu and select the desired server.
   2. Click **Set as Active**.
   3. Click **Close**.

   **Tip:** You can change the active server at any time.

   To disconnect from a SAS Workspace Server

   1. In the SAS Server Connections window, select the Workspace Server to disconnect under Open Workspace Server Connections.
   2. Click **Disconnect**.

   To disconnect from a SAS Metadata Server

   1. In the SAS Server Connections window, select the Metadata Server to disconnect.
   2. Click **Disconnect**.
To create or modify a SAS Metadata Server profile

1. In the SAS Server Connections window, select the SAS Server Version.
2. Click Manage Profiles.
3. Click Add to add a new profile, or click Modify to change a profile’s settings.

The Create Profile or Modify Profile window appears. If you are adding a new profile, all fields are empty except the Authentication domain field, which contains DefaultAuth, and the Port field. If you are modifying a profile, the fields contain the current information.

**Figure 3.17 Create or Modify a Metadata Server Profile**

4. Fill in the information needed to connect to a SAS Metadata Server. Your SAS Metadata Server administrator should have this information.

   **Profile name**   Select a name for this profile. This name is shown in the list of profiles.

   **Description**   (Optional) You can enter a short description of this profile.

   **Machine**   The name of the machine that hosts the Metadata Server. (Example: myserver.mycompany.com)

   **Port**   The port through which you should connect to the machine. (Example: 8561)

   **Use Integrated Windows Authentication**   Select this option to use your Windows log in ID and password to access the server. When enabled, the User name and password fields are disabled. This option is disabled by default.

   **User name**   Your user name for the Metadata Server.

   **Password**   Your password. This is always displayed as asterisks.

   **Authentication domain**   The domain you, as a user, belong to.

4. Click Save.

**Connect to a Remote SAS Workspace Server**

You can also connect directly to a SAS Workspace Server, instead of going through a Metadata Server.
To connect to a Remote SAS Workspace Server

1. Select File > SAS > Server Connections. The SAS Server Connections window shown in Figure 3.14 on page 81 appears.
2. Under Establish New Workspace Server Connection, select Connect to remote SAS server on. See Figure 3.18.

**Figure 3.18** Open a Connection to a Remote SAS Server

3. Enter the machine name and the port number. Your SAS server administrator has this information.
4. Click Connect.
5. Enter your user name and password in the window that appears.
6. Click OK.
7. Click Close in the SAS Server Connections window.

To disconnect from a Remote SAS Workspace Server

1. In the SAS Server Connections window, select the server to disconnect under Open Workspace Server Connections.
2. Click Disconnect.

Connect to a SAS Environment (Windows Only)

On Windows, you can connect to a SAS mid-tier (or SAS environment) if SAS Server version 9.3 or 9.4 is selected in JMP’s preferences and your computer or JMP has been configured correctly. (SAS Server version 9.4 is the default setting in the JMP SAS Integration preferences.)

The SAS installer should have set up your computer to find the SAS environment definition file. If not, you can enter the path to the file in the JMP preferences.

To configure your JMP preferences

1. Select File > Preferences > SAS Integration.
2. Select I want to connect to a SAS Environment and then click Configure.
3. To connect to an environment that JMP has already detected, click **Automatic discovery**, and then select the URL from the list if necessary.

4. To enter the path to the SAS environment definition file, click **Manual configuration** and enter the URL.

5. Click **OK**.

**To connect to a SAS Environment**

1. Select **File > SAS > Server Connections** to open the SAS Server Connections window.

2. In the Metadata Server Connection area, select **Connect to a SAS Environment**.
   
   If this option is not available, either your computer or JMP is not configured to find the environment. See “**To configure your JMP preferences**” on page 85 for details.

3. Select the name of the environment from the Environment list if necessary.

4. Click **Connect**.

5. Enter your user name and password if prompted.

**Connect to SAS on Your Local Machine (Windows Only)**

You can also connect directly to SAS on your local machine.

**To connect to SAS on your computer**

1. Select **File > SAS > Server Connections** to open the SAS Server Connections window.

2. Under Establish New Connection, select **Connect to SAS on this machine**.

   This option is disabled if SAS is not installed on the computer.

3. Click **Connect**.

4. Click **Close** in the SAS Server Connections window.

**To disconnect from SAS on your computer**

1. In the SAS Server Connections window, select **Local** under Open Connections.

2. Click **Disconnect**.

**Open SAS Data Sets with SAS Query Builder**

SAS Query Builder is the preferred method for selecting and importing data from a SAS server. You can preview the data before importing it into a data table. You can also save the queries to modify and run later or to reference in a JSL script.

SAS Query Builder provides an alternative to opening SAS data sets with the File > SAS > Browse Data feature.
To open a SAS data set with SAS Query Builder, follow these steps:

1. Select **File > SAS > SAS Query Builder**.

2. In the Connect to SAS Server window, select a Metadata server or a remote server.
   - To connect to a Metadata server that you have already set up in JMP, select the server from the **Connect to metadata-defined SAS server** list.
   - **Connect to all available libraries** is selected by default based on the SAS Integration preferences. This option connects metadata-defined SAS libraries automatically across all JMP sessions. When the Workspace Server contains a large number of metadata-defined SAS libraries, consider deselecting this option to speed up your connection to the server.
   - To add or configure a Metadata server, click **Manage Profiles** and follow steps in “To create or modify a SAS Metadata Server profile” on page 84.
   - To connect to a remote server, enter the machine name and the port number. Your SAS Metadata Server administrator should have this information.

3. Click **OK**.

The SAS Query Builder window appears.

For details about using Query Builder, see “Build SQL Queries in Query Builder” on page 102.

**Notes:**

- All Query Builder queries run in the foreground.
- Extended attributes are not imported by default. To import them, modify the JMP SAS Integration preferences. Select **File > Preferences** (Windows) or **JMP > Preferences** (Macintosh). Select **SAS Integration** and then select **On import, apply table and column properties from extended attributes**.
- SAS Query Builder does not support local server connections.

**Open SAS Data Sets through a SAS Server**

Once you connect to a SAS Workspace Server, you can browse through the SAS libraries on that server and import data into JMP.

To browse the data sets on the SAS server, select **File > SAS > Browse Data**. The Browse SAS Data window appears. See Figure 3.19.
The window is initially populated with a list of servers the SAS Metadata Server provides (if connected). Any physical and local connections are also shown (as listed in Figure 3.18 on page 85).

- Select a server to see a list of libraries that server contains.
- Select a library to see a list of data sets within that library.
- Select a data set to see a list of columns within that data set.

When you close and reopen the Browse SAS Data window, the previously viewed library and data set appear in the window. However, at any time, you can select a different server from the SAS Server list and then select a library and data set.

**Tip:** If a server is unavailable, or if the connections failed, the server’s name is shown in light, italic text. Click it to try to re-establish the connection.

**Browse SAS Data Information**

You can select a SAS data set and see information about its contents before opening it using the Get Details, Column Details, and Data Preview options.

**Data Preview**

When you select a data set, the Data Preview outline shows you the first ten rows and columns in the data set. See Figure 3.20.
Figure 3.20 Data Preview

Data Set Details

Click Get Details in the Browse SAS Data window to see the size and last modification date for each data set in the library. This option helps you estimate whether your computer can process the entire data set.

Column Details

To see information about a particular column in the data set, select it. The Column Details outline shows you some basic information about the data column. See Figure 3.21.
Import Your Data

Chapter 3

Import Data from SAS Using JMP

Figure 3.21 Column Details

<table>
<thead>
<tr>
<th>Name</th>
<th>Column name from the SAS data set.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>Descriptive column label. The label can be longer than the name, and is often helpful to determine what the column name means.</td>
</tr>
<tr>
<td>Type</td>
<td>Specifies whether the column has a character or numeric data type.</td>
</tr>
<tr>
<td>Length</td>
<td>The length in bytes of data in the column.</td>
</tr>
<tr>
<td>Sort Order</td>
<td>How the column is sorted in SAS.</td>
</tr>
<tr>
<td>Format</td>
<td>The format for the SAS column, such as DOLLAR. This format field also contains information about the width of formatted values and the number of decimal places.</td>
</tr>
</tbody>
</table>

Open a SAS Data Set in JMP

You can import SAS data sets directly into JMP.

1. From the Browse SAS Data window, select a data set. By default, JMP specifies All rows for import.
2. Click Import.

The entire SAS data set is imported into a JMP data table. When SAS data is imported, JMP attempts to make the best match to the SAS format.
Chapter 3
Using JMP
Import Your Data
Import Data from SAS

Import a Sample of a SAS Data Set

You can import a sample of a SAS data set directly into JMP.

1. From the Browse SAS Data window, select a data set.
2. Open the Import Options outline. See Figure 3.22.

Figure 3.22  Import Options

3. If you want to import only a portion of a data set, you can do any of the following:
   - Select the first $x$ number of rows only. See “To import the first $x$ number of rows only” on page 91.
   - Select to auto-sample a specified file size. See “To import an auto-sample file of a specified size” on page 91.
   - Select a subset of the columns. See “To select a subset of columns” on page 92.
   - Construct a WHERE clause to filter the data. See “To import using a WHERE clause” on page 92.
   - Take a custom sample of the data. See “Importing a Random Sample of the Data” on page 93.

To import the first $x$ number of rows only

1. In the Import Options section, select **First $x$ rows only** and specify the number of rows to import.
2. In the Browse SAS Data window, click **Import**.
   
   JMP imports the specified number of rows.

To import an auto-sample file of a specified size

1. In the Import Options section, select **Auto-sample** and specify the number of MB to import.
2. In the Browse SAS Data window, click Import.
   JMP imports the specified number of MB.

To select a subset of columns

1. In the Import Options section, click Select Columns.
   The Select Columns window appears. See Figure 3.23.

![Figure 3.23 Select Columns]

2. Select the columns that you want to import.
   To select more than one column at a time, press CTRL and click each column.
3. Click Add.
4. When you have added all the columns that you want, click OK.
5. In the Browse SAS Data window, click Import.

Only the columns that you selected from the SAS data set are imported into a JMP data table.

To import using a WHERE clause

1. Click Where.
2. Use the WHERE clause editor to construct your WHERE clause.
3. Click OK to return to the Browse SAS Data window.
4. Click Import.

Only the data that matches your WHERE clause are imported into a JMP data table.

For information about constructing WHERE clauses and using the WHERE clause editor, see “Use the WHERE Clause Editor” on page 133.

Note: If you import data using both a WHERE clause and sampling, the WHERE clause is applied first, and then a sample of the filtered data is taken.

You can also write your own SQL statements.

To import using a custom SQL statement

You can also open a SAS data set using a custom SQL statement.
1. Open the Custom SQL outline under the Import Options outline. See Figure 3.22.

**Figure 3.24** Custom SQL

![Custom SQL](image)

2. Enter your SQL statement in the window.
3. Click **Execute Custom SQL**.

**Note:** Your SQL is run on the selected server but is not restricted to any selected library or data set.

**Importing a Random Sample of the Data**

You can also import a random sample of the rows of the SAS data set.

**Note:** The sampling feature requires that the SAS server has the SAS/STAT product licensed and installed. If SAS/STAT is not present, sampling is disabled.

In the Sample Imported Data area of the Import Options outline, select the **Custom random sample** check box. By default, 5% of the rows are imported. To change the random sample import settings, click the **Settings** button.
Figure 3.25  Sampling Settings

In this window, you specify any of the following:

**Sample Size**  You can set the sample size be percentage or by number of rows. To ensure that each row is sampled only once, de-select the *With replacement* option. To ensure that any row can be sampled and appear more than once in the imported data, select the option.

**Selecting by Column**  You can select strata by moving columns into the Strata list.

**Handling Multiple Row Sampling**  If *With replacement* is selected, you can specify to either add each duplicated row as a separate row or combine all duplicated rows into one row. If the second option is selected, a column is added to the table that contains a count of how many times each row was sampled.

**Setting minimum and maximum numbers of items selected**  Select the option and enter a number.

**Setting the random number seed**  Select the option and enter a seed. Specifying the seed lets you reproduce the exact same sample multiple times.

**Note:** If you import data using both a WHERE clause and sampling, the WHERE clause is applied first, and then a sample of the filtered data is taken.

**Import Options**

There are additional options that you can use to specify how SAS data is imported into JMP.

**Use labels for imported column names**  When selected, this option switches the column name, which has a limited length and might be difficult to decipher, with the column label. This option is turned off by default. To use the SAS data column names as column names in JMP, deselected this box.
**Add SQL table variable to imported table**  
When selected, this option adds SQL queries to the data table panel as a variable. This option is turned on by default. If you turn off this option, only two variables are added when you import the data table: the SAS server and the data set.

**Tip:** If your data is password-protected, you might want to turn this option off, because your password might be shown in the SQL.

**Table Variables**

After you import the JMP data table, table variables appear in the upper left panel of the data table. These variables show the SAS server, data set, and the SQL query and sampling settings if applicable. There is also a source script added that lets you re-do the import at any time.

**Open Password-Protected Data Sets**

JMP can open SAS version 7 or higher data sets that are password protected. The passwords are not case sensitive.

*To open password-protected data sets*

1. Select **File > Open**.
2. Select **SAS Data Sets** from the **Files of type** list.
3. Select the file.
4. Click **Open**.
5. Enter the password and then click **OK**.

When the password is incorrect, you are prompted to enter it again until you get it right.

**Using SAS Extended Attributes to Import Metadata**

SAS extended attributes are metadata that you define in SAS code to import information such as table scripts, labels, length, and type. You associate the extended attributes with a data set or variable and define them in name-value pairs, such as `_JMP_TABLESCRIPTNAME_2="OnOpen"`. For more information, see the SAS documentation on extended attributes at [http://sas.com/](http://sas.com/).

On export from JMP to SAS, items such as column properties and table scripts are preserved automatically. You map SAS extended attributes to JMP attributes only when importing SAS code into JMP.

Here is an example of defining extended attributes in SAS code. The attributes define a table script name and the table script itself.

```sas
/* specify two table scripts. */
%LET _DS_ATTRIBUTES=_JMP_TABLESCRIPTCOUNT=2
```
The following example shows how to combine PROC DATASETS with extended attributes:

```sas
%LET _DS_ATTRIBUTES = attr-name=attr-value...attr-name=attr-value;
%LET _VAR_ATTRIBUTES= var-name (attr-name=attr-value...)...var-name
(attr-name=attr-value...);

PROC DATASETS NOLIST LIB=WORK;
   MODIFY AttributeReferenceTable;
   XATTR OPTIONS MAXCHUNK=100;
   XATTR SET DS &_DS_ATTRIBUTES;
   XATTR SET VAR &_VAR_ATTRIBUTES;
RUN;
QUIT;
```

See “Conventions for Mapping JMP Attributes to SAS Extended Attributes” on page 599 for details about SAS extended attributes and their corresponding JMP attributes.

Two SAS Integration preferences determine whether extended attributes are imported or exported. Select On export, store table and column properties in extended attributes to export extended attributes. Select On import, apply table and column properties from extended attributes. The options are deselected by default.

To see an example of exporting extended attributes, run the following script:

```sas
dt = Open( "$SAMPLE_DATA/Big Class.jmp" );
sd = dt << Make SAS Data Step Window( SaveJMPMetadata( 1 ) );
```

Run Stored Processes

Stored processes are SAS DATA step code saved on the SAS server that you are connected to. You can run them from JMP and see the results of the script in JMP.
Note: Depending on the preferences that you have set for SAS, error messages are sent either to the JMP log or to a separate SAS log window.

You must be connected to a Metadata Server to view and run stored processes. If you select File > SAS > Browse SAS Folders without such a connection, you are prompted to either make a connection or cancel your action.

To select and run a stored process

   
   The Browse SAS Folders window appears.

2. Browse through the stored processes to find the one that you want to run.

3. Select it and click Run.
   
   The data opens as a JMP data table.

On Windows, you can also right-click a stored process and select Copy Metadata Path. This option copies the path to the clipboard. You can then paste it into a script window to include it as a parameter for the JSL operator Meta Get Stored Process(). For more information, see the JSL Functions chapter in the JSL Syntax Reference.

Note: Static graphs might not appear in the results returned from a SAS stored process when streaming output is selected.

Stored processes send reports to HTML by default, but you can select RTF or PDF instead on the SAS Integration page of the JMP preferences. Select File > Preferences (Windows) or JMP > Preferences (Macintosh) to view the JMP preferences.

Submit SAS Code

You can submit SAS code directly from JMP to the currently active SAS server. If the submitted SAS code generates SAS Listing output, that output is automatically retrieved from the SAS server and displayed in JMP. Also, the generated SAS Log is retrieved, and, if there are any errors in the submitted code, the SAS Log is automatically displayed in the SAS Log window.

All analyses in JMP are run natively within JMP without any dependency on the SAS System. The SAS code that JMP generates is intended to enable you to perform a separate but similar analysis in the SAS System after the initial JMP analysis, or to score new observations in the SAS System using a model that was fit within JMP.
The following JMP platforms generate SAS code:

- Standard Least Squares - PROC GLM
- REML - PROC MIXED
- Stepwise - PROC GLM
- Nominal and Ordinal Logistic - PROC LOGISTIC
- GLM - PROC GENMOD
- Time Series (ARIMA and TFM) - PROC ARIMA
- Neural - SAS Data Step scoring code
- Partition (Decision Tree, Bootstrap Forest, Boosted Tree) - SAS Data Step scoring code

**Note:** Use the JSL function `As SAS Expr( formula );` to turn any prediction formula into an expression that can be used in a SAS Data Step. See the JSL Functions chapter in the *JSL Syntax Reference*.

**To run SAS code directly from JMP**

1. Either open an existing SAS program using **File > Open**, or create a new SAS program. (Create a new SAS program by selecting **File > SAS > New SAS Program** and typing in the SAS code.)
2. Click the **Submit to SAS** icon.

   You can also right-click in the Program Editor window and select **Submit to SAS**. The menu item also includes the name of the active SAS server that the SAS code will be submitted to.

   You can also press the F8 key (press COMMAND-Shift-R on Macintosh).

**To run SAS code using a JSL script**

Write and run a JSL script that uses either the **SAS Submit** or **SAS Submit File** JSL functions. For more information about writing JSL scripts that submit SAS code, see the Extending JMP chapter in the *Scripting Guide*. 

---

**Figure 3.26  SAS Code Submission Example**

<table>
<thead>
<tr>
<th>SAS Code</th>
<th>JMP Code to Submit SAS Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>data a;</td>
<td>SAS Connect(&quot;sasmain&quot;);</td>
</tr>
<tr>
<td>x=1;</td>
<td>SAS Submit(&quot;data a; x=1; proc print; run;&quot;);</td>
</tr>
<tr>
<td>proc print;</td>
<td></td>
</tr>
<tr>
<td>run;</td>
<td></td>
</tr>
</tbody>
</table>

SAS Code

data a;
x=1;
proc print;
run;
To view the SAS Listing output

If the submitted SAS code generates SAS Listing (textual) output, that output is automatically be displayed in a SAS Output window when the job is completed. If you need to view the SAS Listing output again later in the JMP session, select File > SAS > Open SAS Output Window. The SAS Output Window retains the listing output from the previous 25 submits to the active SAS server.

To view the SAS log

If the submitted SAS code contained errors, the SAS Log window for the active SAS server is automatically opened, displaying the SAS Log for the job. However, you can view the SAS Log for the most recent 25 submits to the active server at any time by selecting File > SAS > Open SAS Log Window.

If you prefer that SAS Log information is appended to the JMP log after a submit completes:

1. Select File > Preferences (Windows) or JMP > Preferences (Macintosh).
2. Open the SAS Integration category.
3. In the Show SAS Log section, select JMP Log rather than Separate Window.

Also, in the Show SAS Log section, you can set whether the SAS Log should be displayed Always, Never, or On Error (the default).

Generate ODS Results

The SAS Output Delivery System (ODS) is a powerful mechanism for generating reports in HTML, RTF, PDF, and other formats. ODS output is generally much more attractive and customizable than plain-text SAS Listing output. You can set your submitted SAS code generate ODS results rather than SAS Listing output using Preferences.

To generate ODS results from your submitted SAS code

1. Select File > Preferences (Windows) or JMP > Preferences (Macintosh).
2. Open the SAS Integration category and find the large SAS Submit Options group, as shown in Figure 3.27.
Figure 3.27  SAS Submit Options in Preferences

3. Select the **Automatically generate ODS results** option.
4. From the **ODS Result Format** list, select the format in which to generate the ODS results: HTML, PDF, RTF, or a JMP report.
5. (Optional) You can use other options to specify a style or style sheet to format the results or set the format for generated graphics. For more details, see “SAS Integration” on page 528 in the “JMP Preferences” chapter.

Performing the previous steps causes JMP to generate additional SAS code, including an ODS statement, that is wrapped around the SAS code that you submit. The SAS code that you submit then automatically generates ODS results in the specified format. Those results are downloaded to your computer and displayed either within JMP, when possible, or in an appropriate external application.

### Retrieve Generated SAS Data Sets

SAS code that you submit might generate SAS data sets. You can have them automatically imported into JMP for further analysis.

1. Select **File > Preferences** (Windows) or **JMP > Preferences** (Macintosh).
2. Open the SAS Integration category.
3. Select the **Import generated SAS data sets into JMP** option.

### Export JMP Data Tables to SAS

You can export JMP data tables to a SAS Workspace Server.

1. Connect to the SAS Workspace Server.
2. Open the file that you want to export.
3. Select **File > SAS > Export Data to SAS.**
If necessary, you are connected automatically using your profile’s user name and password.

4. Select the data table that you want to export to SAS from the list of open data tables under Select Data to Export.

**Figure 3.28** Export Data to SAS

5. (Optional) To export only some of the columns in the data table, click **Select Columns**. See “To select columns to export” on page 101 for details.

6. Select the Destination Server.

7. Select the Library.

**Tip:** If your libraries do not appear, see “Show Libraries in the Export Data to SAS Window” on page 102.

A list of the data sets in the library appears.

8. Enter the name as you want it to appear in the SAS library.

9. (Optional) Set the export options that you want to use. See “Export Options” on page 102 for details.

10. Click **Export**.

**To select columns to export**

1. To export only some of the columns in the data table, click **Select Columns**.
2. In the window that appears, select the columns to export and click Add.
3. When all the columns have been added to the Selected Columns list, click OK.

Export Options

The available export options are as follows:

**Ignore ‘excluded’ row state (export all rows)** Select this option to export all rows in the data table. Deselect this option to export only those rows that are not excluded. This option is on by default.

**Preserve SAS variable names** This option is useful for data tables that were imported originally from SAS. When importing a SAS data set, the original SAS variable name is saved in a column property for each column. Select this option to use the SAS variable name for each column when exporting to SAS. Deselect this option to export the JMP variable names. This option is off by default.

**Preserve SAS formats** This option is useful for data tables that were imported originally from SAS. When importing a SAS data set, the original SAS format and informat is saved in a column property for each column. Select this option to use the SAS format and informat for each column when exporting to SAS. Deselect this option to export the JMP formats instead. This option is on by default.

Show Libraries in the Export Data to SAS Window

If your libraries do not appear in the Export Data to SAS window, define the library in one of the following ways:

- Using JSL, submit code to the SAS server. The code defines a library using a `libname` command.
- Define an `autoexec.sas` file that runs a snippet of SAS code every time SAS is invoked. This creates the same `libref`s every time you connect to SAS. For details about `autoexec.sas` files, see the SAS documentation.

Libraries that are defined in metadata (such as libraries defined in the SAS Management Console under the Data Library Manager) cannot be accessed from the Export Data to SAS window.

---

**Build SQL Queries in Query Builder**

Query Builder is the preferred method for selecting and importing data from an SQL database without writing SQL statements. You can preview the data before importing it into a data table. Share your queries so that other users can customize and run the queries.
Query Builder provides an alternative to writing your own queries using the File > Database > Open Table feature. However, you can also start building a query in Query Builder and then add your own SQL statements.

SAS Query Builder is also available for querying SAS data sets on SAS servers. See “Open SAS Data Sets with SAS Query Builder” on page 86 for details.

Notes:
• Database table names that contain the characters $# -+/%&|;? are not supported.
• The Value Ordering column property is not supported. Consider writing a script in the Post-Query Script window to sort the rows.

Connect to a SQL Database

Set up the ODBC connection through the Windows Control Panel or inside JMP.

1. Select File > Database > Query Builder to display the Select Database Connection window. The Connections box lists data sources that you connected to in the current JMP session.
2. If the desired data source is not listed in the Connections box, click New Connection to choose a data source. The method of choosing a data source depends on your operating system and the ODBC driver. See “Connect to a Database” on page 124 for details.
3. Select a table or schema from the Schemas - Tables box and click Next.

Query Builder examples are based on a table named SQBTest, which contains movie rental data.

Figure 3.29 Select the Database Schema
Tip: To find the schema in a long list, enter the name in the search box above the schemas. You can also search for tables above the list of tables. The red triangle menu provides options for matching case and searching with regular expressions.

Select Tables from a SQL Database

After connecting to the SQL database, select the tables that you want to query. Either select a primary table or join several tables to query them all.

By default, JMP attempts to join tables based on key relationships that are assigned in the tables.

• A primary key identifies a column that uniquely describes the data (for example, a customer ID number). All rows from the primary table are included in your query.

• A foreign key in a secondary table matches the primary key in one of the joined tables. Only matching rows from the secondary table are included in your query.

If there are no keys, data are matched by column name, which joins the two tables. By default, only matching rows from the secondary tables are included in the query.

This example shows how to join multiple tables. However, you can also build a query using a single table. In this case, joining is not necessary.

Note: The Query Builder examples are based on a database that is not installed with JMP.

1. Select File > New > Database Query, connect to the database, and select the SQBTest schema. (See “Connect to a Database” on page 124 for details.)

2. Select the schema from the Schemas - Tables list.
   If you also select a table, that table will be the primary table after you click Next.

3. In the Select Tables for Query window, select g6_Customers from the Available Tables list, and then click Primary.
   The Columns tab shows that CustID is the primary key. The data is indexed, which speeds up the query.

4. Select g6_Movies and g6_Rentals from the Available Tables list, and then click Secondary.
   The Left Join icon indicates that the tables were automatically joined (Figure 3.30). CustID is the primary key in g6_Customers and matches a foreign key in one of the other tables.

Tip: After you add a primary or secondary table, click Add Related Tables to add tables that have matching columns. The button is unavailable when no related tables are found or when a primary or secondary table is not selected.
Figure 3.30 shows the completed window.

**Figure 3.30** Selecting Primary and Secondary Tables

**Tip:** To find the schema in a long list, enter the name in the search box above the schemas. You can also search for tables above the list of tables. The red triangle menu provides options for matching case and searching with regular expressions.

5. Click the **Table Snapshot** tab for each table to preview the data (Figure 3.31).
6. Below the primary and secondary tables, click **Preview Join** to see a preview of the table that was created from the specified joins.

**Tips:**

- The icon next to a secondary table indicates that the table is not joined in the query. Click the **Edit Join** button to specify the columns to join. If you cannot find columns to join, click the **Remove** button to remove the table. See “Edit the Conditions for Joining Tables” for details.

- On the Columns tab, the Key column might show multiple keys; some columns can be both primary and foreign keys. A unique key icon does not appear next to primary keys, because all primary keys are unique.

- On the Columns tab, the Reference is specified for foreign keys that match primary keys in another schema. The reference is the name of the schema and column.

- Click **Change Data Source** to query a different schema or database.

- To join data from different sources (for example, a database and Microsoft Excel), use Query Builder to import the database data into a data table; import the Excel data into a data table; use JMP Query Builder in the Tables menu to query and join the tables.

- When you import a table that contains a primary key, the Link ID column property is added to the column in the data table. The column property enables you to virtually join data tables. See “Virtually Join Data Tables” on page 296 in the “Reshape Data” chapter.
**Edit the Conditions for Joining Tables**

In the Select Tables for Query red triangle menu, Auto join Database Tables is initially selected. JMP automatically joins database tables based on key relationships or matching column names.

If there are no keys, or when column names do not match, click **Edit Join** to specify the columns to join.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

**To edit the conditions for joining tables**

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. (See “Connect to a Database” on page 124 for details.)

2. In the Select Tables for Query window, select **g1_books** as the Primary table and **g1_charges** as the Secondary table.

   The icon next to the secondary table indicates that the table is not joined in the query.

3. Select **g1_charges** in the Secondary table pane and click **Edit Join**.

   The Edit Condition window appears.

4. In the Left Column list, select **g1_books**.

5. Select **Book ID** from the Left Column box.

6. Select **ID** from the Right Column box.

7. Make sure that the equal sign is selected between the two boxes.

8. Click **Next**.

   The Edit Join window shows that non-matching rows from **g1_books** will be included in the data table. Rows that are only in **g1_charges** will be omitted.

   To do a full join and import all rows, you would select **Include non-matching rows from g1_charges**. If only one of the non-matching options is available, the database does not support full joins.

9. Click **OK**.

**Note:** The **OK** button is unavailable until all of the secondary tables are joined.
To prevent tables from joining automatically

- Deselect Auto join Database Tables from the Select Tables for Query red triangle menu above the primary table.
- If you frequently query large databases, deselect Automatically join tables added to a query in Preferences > Query Builder to prevent memory issues.

Build the SQL Query

After selecting database tables, you either import the data or build a query. Query Builder enables you to interactively create the database query rather than write SQL expressions.

After selecting database tables (and joining them if necessary), click Build Query to open the Query Builder window. You can continue to refine the query by selecting which columns to include and specifying criteria for sampling and filtering. You can also save the query to edit and run again later.

The columns from all database tables appear in the Available Columns list. Prefixes such as t1 and t2 (also called aliases) associate each column with the corresponding database table.

To skip the Query Builder step and import all data, click Import Now instead.

Note: The JMP Query Builder in the Tables menu provides many of the same options but lets you query and join JMP data tables. See “Query and Join Data Tables with JMP Query Builder” on page 293 in the “Reshape Data” chapter for details.

Select Columns from the Database Table

Suppose that you want to view movie rentals by movie genre, rating, and demographic data such as marital status and age.

Note: The Query Builder examples are based on a database that is not installed with JMP.

1. Select File > New > Database Query, connect to the database, and select the SQBTest schema. (See “Connect to a Database” on page 124 for details.)
2. In the Select Tables for Query window, select g6_Customers and click Primary.
3. Select g6_Movies and g6_Rentals and click Secondary.
4. Click Build Query to show the Query Builder window.
6. Click Add on the Included Columns tab.
Figure 3.33 Selected Columns

Tip: To find a column in a long list, enter the name in the search box below Available Columns. The red triangle menu provides options for matching case and searching with regular expressions. To hide the search box, deselect Show Search Box from the Available Columns red triangle menu.

7. Select the SQL tab below the columns to view the SQL statements for your query. This code is saved as a data table property after you run the query.

8. Click Save in the lower right corner.
   Your work is saved as g6_Customers.jmpquery, which you can open later to return to this point or to run the query.

9. Click Run Query to import the data.
   The data table includes the following scripts:
   – Run the Source script to reconnect to the database and import the data.
   – Run the Modify Query script to open the query in Query Builder.
   – Run the Update From Database script to re-import and refresh the data.

Tips:
• To rename a column, double-click the JMP Name in the Included Columns tab and enter a new name.
• To rename an alias, right-click the table in the Select Tables for Query window and select Change Alias.Aliases are not case sensitive.

• The query runs in the background unless you deselect Run queries in the background when possible from the Query Builder ODBC preferences. You can also check the progress of all ODBC queries by selecting View > Running Queries.

Note: For SAS Query Builder, all queries run in the foreground.

• Deselect Update preview automatically if the preview loads too slowly. Click Update below the Query Preview tab to update the data view. Consider changing the Preview options in the JMP Query Builder preferences if you frequently work with large databases. Consider limiting the maximum number of rows that can be previewed. In the JMP Query Builder preferences, change the value of Maximum number of rows for previews.

• To omit duplicate rows from the database, select Distinct rows only on the Included Columns tab.

Maintain Compatibility with JMP 12

If you add a JMP 13 feature to a query, that query will no longer load in JMP 12. If you are using JMP 13, but you need to create queries that will still run in JMP 12, select Keep this query compatible with JMP 12 in the Query Builder Preferences. After you select the option, features that create compatibility problems are hidden in Query Builder.

When you are ready to move JMP 12 queries to JMP 13, deselect this preference.

Create a Computed Column

You can create a new column from existing columns. You might calculate the mean for two columns and store the mean in a new column. Date-time values might be in the wrong format. Select the columns in the query, right-click, and select Add Computed Column to construct this new column.

Suppose that you want to calculate the maximum number of times you can watch a movie during the rental period. You are querying a database that contains the length of each movie and number of days the movie was checked out. This example shows how to create a new computed column from these data.

Note: The Query Builder examples are based on a database that is not installed with JMP.

1. Select File > New > Database Query, connect to the database, and select the SQBTest schema. (See “Connect to a Database” on page 124 for details.)

2. In the Select Tables for Query window, select g6_Rentals as the Primary table and g6_Movies as the Secondary table.

3. Click Build Query to show the Query Builder window.
4. From the Available Columns red triangle menu, select **Add Computed Column**.

The Computed Column window appears (Figure 3.34). The window contains the JMP Formula Editor.

**Figure 3.34** Computed Column Window with Formula Editor

**Notes:**

- Operators and functions are provided in the list on the right side of the Formula Editor (Figure 3.34). In some instances, you might need to change the server type based on your database.
- The Operators list does not provide a Concatenate (||) operator. You must type the formula in the Formula Editor box.

5. From the g6_Rentals list on the left, select **Days Out** and click the multiplication button.

**Figure 3.35** Computed Column

6. Select the blank box, type (24 * 60, and press Enter.

This formula multiplies the number of hours in a day by the number of minutes in day. Notice that when you type the first parenthesis, then second one is automatically inserted.
7. Click the outer box to select the entire equation and click the division button. 
8. Select \texttt{g2\_Movies} from the list on the left and then select 
\texttt{LengthMins}.

\textbf{Figure 3.37 Second Portion of the Formula}

\begin{figure}
\centering
\includegraphics[width=0.5\textwidth]{figure.png}
\caption{Second Portion of the Formula}
\end{figure}

9. Click \textit{OK}.
   
   A new column named Calc1 is created.
10. Right-click the column and select \textit{Rename Column}.
11. Type \texttt{MaximumTimesWatched} and click \textit{OK}.
12. In the Available Columns list, select \texttt{MaximumTimesWatched} and click \textit{Add}.
13. Select \texttt{t2.Name} and click \textit{Add}.
   
   On the Query Preview tab, notice that Nanny McPhee can be watched 160 times while the movie is rented.

\section*{Group the Common Values}

You can combine (or group) common values in a column before importing the data into JMP. To group common values, select an Aggregation function to determine how the common values are calculated.

\textbf{Note:} Aggregation support is based on your database. See the database documentation for more information.

Suppose that you are interested in the number of times a specific movie was rented. In this example, the count for each item number is calculated, and common movie values are grouped into single rows.

\textbf{Note:} The Query Builder examples are based on a database that is not installed with JMP.

1. Select \textit{File > New > Database Query}, connect to the database, and select the \texttt{SQBTest} schema. (See “\textit{Connect to a Database}” on page 124 for details.)
2. In the Select Tables for Query window, select \texttt{g6\_Movies} as the Primary table and 
\texttt{g6\_Rentals} as the Secondary table.
3. Click **Build Query** to show the Query Builder window.
4. In the Available Columns box, select `t1.Name` and `t2.ItemNo` and click **Add**.
5. Select `t2.ItemNo` and select **Count** from the Aggregation list.
   The Group By check box is selected for `t1.Name` (Figure 3.38). All instances of a specific movie name will be grouped into one row.

**Figure 3.38** Grouped Columns

6. Click **Run Query** to import the data.
7. In the data table, right-click the `Count-ItemNo` column and select **Sort > Descending**.
   Scarface was rented most frequently (Figure 3.39).

**Figure 3.39** Sorted Count-ItemNo Column

**Tips:**
- To clear the grouped rows, select **None** from the column’s Aggregation list.
• The DISTINCT Aggregation functions show only rows that contain distinct values. Rows with duplicate values are omitted. These functions are useful when a database contains many duplicate values.

Import a Sample of the Data

With large databases, consider sampling the data. Sampling returns a subset of rows and decreases the query time. The database query runs, and a smaller portion of data are imported based on options that you select on the Sample tab.

Sampling methods differ based on the database vendor.

• SQL Server supports block sampling by default. A block sample takes an entire page of rows (such as all rows on pages 1 and 5). If you select 1,000 rows, approximately 1,000 rows are imported.

• Oracle and other databases support row sampling. If you select 5,000 rows, between 4,800 and 5,200 rows per sample are typically imported, based on how Oracle cycles through the data.

For major database vendors, JMP detects the capabilities and provides vendor-specific options when possible. Features that are unsupported by the vendor are unavailable on the Sample tab.

Suppose that you want to import a sample of the data. In this example, you select the first 5,000 rows.

Note: The Query Builder examples are based on a database that is not installed with JMP.

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. (See “Connect to a Database” on page 124 for details.)

2. In the Select Tables for Query window, select **g6_Rental** as the Primary table and **g6_Movies** as the Secondary table.

3. Click **Build Query** to show the Query Builder window.

4. Click the **Add All** button on the Included Columns tab.

5. Click the **Sample** tab and select **Sample this result set**.

6. Select **Random N Rows** and type 5,000.

   In the Sample By area, Blocks or Pages is the only option based on which type of sampling the database supports.

7. Click **Run Query** to import the data.

   The new data table consists of approximately 5,000 rows. With block or page sampling, you might get a sample of 4,900 rows one time and 5,600 rows the next time.
Tips:

- To re-create the same sample set each time you run a query, set the Seed value to any positive integer up to 64,000. Suppose that you want to query movie rentals by gender. Type 1 as the Seed value and run the query. The distribution of male customers in the results is low. Type 2 as the Seed value and run the query again. Repeat this process to find the Seed value that results in a similar distribution of males and females.

- To add individual columns to the Included Columns tab, right-click the column and select Include Column or click the Add button.

Select Filters to Import a Subset of the Data

Add filters to import a subset of values from the selected filters into the data table. Some filters are not available if the query is compatible with JMP 12. See “Maintain Compatibility with JMP 12” on page 110 for details.

Filters for Both Continuous and Categorical Columns

Simple Comparison  Matches values using the specified operator.

Age > 14 matches ages that are greater than 14.

Range  Matches a range of values using the specified operator.

12 ≤ Age ≤ 17 matches ages that are between 1 and 17.

Is NULL or Is Not NULL  Matches missing values.

Either NULL or not NULL matches missing values and non-missing values.

Custom Expression  Enables you to write your own SQL expression.

( ( t2.Gender IN ( 'F' ) ) AND ( t2.Age >= 20 ) AND ( t2.Age <= 50 ) )

matches the F Gender. It also matches Age between 20 and 50.

Filters that are Only for Categorical Columns

List Box  Displays a list box from which you select one or more columns. List Box is the default filter for categorical columns based on the Query Builder preferences.

Manual List  Enables you to enter the column names.

Check Box List  Displays a check box list.

Note: List Box, Manual List, and Check Box List include a Not in list option that enables you to retrieve rows that do not match the selected values.
Contains  Matches a string that contains or does not contain the specified value. Supports
 BOOLEAN operators such as AND and OR. If the number of rows cannot be determined
 or the query is canceled, Contains is the default filter.

Contains Comedy OR Romance matches Comedy and Romance.

Like or Not Like  Matches a string that is similar to or not similar to the specified value.
 Supports the % wildcard (zero or more characters) and _ wildcard (exactly one character).

Genre Like %com matches any number of characters before “com”, as in “RomCom”. To
 also match “Comedy”, use %com% or Contains.com.

Match Column Values  Matches the specified column value. Select the table and then select the
 columns. The Select non-matching option enables you to filter all columns except for the
 selected columns. See “Import Matching Data from an Existing Data Table” on page 118
 for an example.

This example shows how to import data for age 30 and over customers, and movies in the
 RomCom and Comedy genres.

Note: The Query Builder examples are based on a database that is not installed with JMP.

1. Select File > New > Database Query, connect to the database, and select the SQBTest
 schema. (See “Connect to a Database” on page 124 for details.)

2. In the Select Tables for Query window, select g6_Rentals from the Available Tables list, and
 then click Primary.

3. Select g6_Customers and G6_Movies and then click Secondary.

4. Click Build Query to show the Query Builder window.

5. In the Available Columns box, select t2.Gender, t2.Age, and t3.Genre, and then click Add on
 the Included Columns tab.

6. Select all columns on the Included Columns tab and click Add Selected Items to Filters
   Filters for the columns appear in the Filters outline.

7. Set the t2.Age filter to ≥ 30.

8. From the t3.Genre red triangle menu, select Like, type %com%, and press Enter.
   The % wildcards match any number of characters before and after “com”. On the Query
   Preview tab, notice that movies in both the RomCom and Comedy genres are shown
   (Figure 3.40).
9. In the Filters red triangle menu, select **All Prompt on Run**.

   Users who run the query can customize the filters.

10. Click **Run Query**.

11. In the Query Prompts window, click **OK** to apply the preselected filters and import the data.

**Notes:**

- For most categorical columns, the filter is a Check Box List by default. For columns that contain over 1,000 levels, the Contains filter is automatically selected. You can change the number of levels in the Query Builder preferences.
- The Conditional option in a filter’s red triangle menu enables you to filter data within hierarchical categories. For example, suppose that you have a State filter and a City filter. To select a state and then display only cities that are in that state, select Conditional from the City red triangle menu.
- The Inverse option at the top of the Filters list enables you to select all but the specified columns for all filters. The option is unavailable for filters that select all rows.
- “<Blank>” in the filter list indicates that the database contains a missing value for that column.
• To create a filter for large columns of categorical data, JMP attempts to determine the number of rows in the table.
  – The Query Builder preference called **Retrieve category levels for tables whose size cannot be determined** is selected by default so that JMP automatically retrieves the levels. If you deselect the preference, the Contains fallback filter type in the Query Builder preferences is selected.
  – If the categorical column has more than 1 million rows, JMP does not automatically retrieve the unique category levels for the filtered column. The Query Builder preference called **Maximum rows in table for which category levels will be automatically retrieved** supports a minimum of -1 (no limit) and a maximum value of 1 billion rows.
• The default filter for categorical columns is a list box unless the **Keep this query compatible with JMP 12** Query Builder preference is selected.

### Import Matching Data from an Existing Data Table

You can also select rows from an open data table that match a column in your query. Consider a database of airline data. The database includes data such as flight duration and tail number. You also have a data table that includes tail number data. Use the Match Column Values filter to import only data for matching tail numbers.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select **Help > Sample Data Library** and open **Air Traffic.jmp**.
2. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. (See “Connect to a Database” on page 124 for details.)
3. In the Select Tables for Query window, select **g5_AIRLINE_ONTIMEPERF** from the Available Tables list, and then click **Primary**.
4. Click **Build Query** to show the Query Builder window.
5. Click **Add All** on the Included Columns tab.
6. Select **t1.TailNum** on the Included Columns tab and click **Add Selected Items to Filters**.
7. From the **t1.TailNum** red triangle menu in the Filters column, select **Filter Type**, and then select **Match Column Values**.
8. Select **Air Traffic** below **Match values from table**.
9. Select the **Tail Number** column and then select **All rows (38,118)** from the list.
   The data view on the Query Preview tab updates to show the filtered values.
10. Click **Run Query** to import the data.
    The data table includes only data for rows that are in the **Tail Number** column.
Write a Custom Expression to Import a Subset of the Data

In addition to selecting filters to subset the data, you can write custom SQL expressions if you do not want to use the filters that are provided.

Note: The Query Builder examples are based on a database that is not installed with JMP.

1. Select the columns that you want to filter (described in “Select Filters to Import a Subset of the Data” on page 115).
2. From the Filters red triangle menu, select Add Custom Expression.
3. Type the following text in the Custom Expression box:
   \[
   \left( \left( t2.Gender \text{ IN } ( 'F' ) \right) \text{ AND } \left( t2.Age \geq 20 \text{ AND } t2.Age \leq 50 \right) \right)
   \]
4. Click outside the Custom Expression box to update the Query Preview tab (Figure 3.41). This expression matches the F Gender. It also matches Age between 20 and 50.

Figure 3.41 Writing a Custom Filter Expression

Sort the Selected Data

You can sort the rows in specific columns by values to control how the data appear in the data table. In this example, you sort the Married column in descending order and sort the data by age and then height.

Note: The Query Builder examples are based on a database that is not installed with JMP.
1. Select File > New > Database Query, connect to the database, and select the SQBTest schema. (See “Connect to a Database” on page 124 for details.)

2. In the Select Tables for Query window, select g4_bigclass as the Primary table.

3. Click Build Query to show the Query Builder window.

4. On the Included Columns tab, click Add All.

5. Select t1.age and t1.height and click Order by the Selected Items. The columns appear in the Order By outline in the right column. The columns are sorted by age first (youngest to oldest) and then height (shortest to tallest).

6. In the Order By outline, select t1.height and then click Sort the values in descending order below the columns. The height column is sorted from tallest to shortest.

7. Select t1.height and click Move the Selected Items Up in the List. The height column is sorted first. Values in the age column are sorted within each level of height. For a height of 68, age is sorted from 14 to 17.
View the Query Status

On the Query Status tab, view the status of a query as it runs in the background. The query name, SQL statements, and number of processed records appear. You can stop a query at any time and view only the processed records. To view background queries from other JMP windows, select View > Running Queries. The status details are unavailable if you deselect Run queries in the background when possible from the Query Builder preferences.

Note: For SAS connections in Query Builder, all queries and query previews run in the foreground.

Write a Post-Query Script

On the Post-Query Script tab, write a JSL script that runs after you run the query. For example, you might want to import the data and then create a distribution.

```
Distribution( Column( :age, :gender ) );
```

This script is part of the Source script in the final data table.

Save and Run the Query

Save your query as a .jmpquery file to modify or run the query later. You are prompted to enter the password if the server connection string does not specify it. The .jmpquery file can also be opened and run by a JSL script.

After you build a query, click Save in the lower right corner to save the settings as a .jmpquery file. Clicking Save again overwrites the file with your latest changes. Clicking Save As saves the query in a new .jmpquery file.
Run the Query

A query file opens in Query Builder by default, where you modify the query and then run it as needed to import the data. After you are satisfied with the query, you can configure it to run when opened instead of opening in Query Builder.

When you are building the query, select Run on Open from the red triangle menu next to the Query Name box in the upper left corner.

To override the Run on Open setting, press the Control key (Windows) or Command key (Macintosh) before opening the file from the file system. On Windows, you can also right-click the query in the JMP Home Window and select Edit Query.

Using the Saved Query as a Template

You can also use the .jmpquery file as a starting point for a new query. This option prevents you from overwriting your original query if you accidentally click Save. It works the same as clicking Save As after you modify the query.

1. Right-click the .jmpquery file in the JMP Home Window’s Recent Files list.
2. Select Open as Template.
3. Modify the query and click Save to create a new .jmpquery file.

Note: The .jmpquery file contains database login information. You must have set up the database connection before running the query. See “Connect to a Database” on page 124 for details.

Open the Selected Data in JMP

After you specify the columns and data to import, click Run Query to open the data in a data table. The SQL statements are saved as a table variable. The following scripts are available:

Source  Runs the query.

Modify Query  Opens the query in Query Builder, where you can change which columns and data are imported and further customize the query.

Update From Database  Connects to the database to refresh the data and then run the query. If the data table and database table contain the same number of columns, values in the existing data table are updated when the database is refreshed.

The existing data table is also updated when only formula columns follow the last column that is refreshed.

Otherwise, the updated data appears in a new data table.
Query Builder Red Triangle Options

The Query Builder red triangle menu provides scripting and custom SQL options. The modify and run scripts are always automatically saved in the final data table.

**Copy Modify Script**  Copies a script to the computer’s clipboard that lets you modify the query.

**Copy Run Script**  Copies a script to the computer’s clipboard that lets you refresh the data and run the query.

**Save Modify Script to Script Window**  Saves the Modify Query script to the script window.

**Save Run Script to Script Window**  Saves the Update From Database script to the script window.

**Convert to Custom SQL**  Shows the query statements in a new script editor window. You must remove prompting filters before selecting this option.

When you save the query from the Custom SQL window, the custom SQL is saved. Interactive components that were present before you customized the query are not saved. Revert to Interactive is also unavailable on the red triangle menu.

**Keep this query compatible with JMP 12**  Makes subsequent changes to the query compatible with JMP 12. Features that cause compatibility issues with JMP 12 are hidden while you edit the query. After you deselect this option and make a change that is supported only in JMP 13 and later, this option is no longer available.

The JMP Query Builder preferences include the same option, which is deselected by default. When you open a query in JMP 13 that is marked as JMP 12 compatible, features that create compatibility problems are hidden regardless of how the preference is set.

**Revert to Interactive**  Displays the interactive query in the Query Builder window. Changes that you made on the Custom SQL tab are not saved when you revert.

Write SQL Statements in Query Builder

Query Builder enables you to interactively create SQL queries without writing SQL statements. You can also build a query in Query Builder and then add custom statements to the query.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. (See “Connect to a Database” on page 124 for details.)
2. In the Select Tables for Query window, select **g6_Rentals** as the Primary table.
3. Select **g6_Movies** and **g6_Customers** as the Secondary tables.
4. Click **Build Query** to show the Query Builder window.
5. Click the **Add All** button on the Included Columns tab.
6. From the Query Builder red triangle menu, select **Convert to Custom SQL** and click **OK**.
   The SQL that Query Builder generated appears on the Custom SQL tab.
7. Click before the semicolon and type the following SQL statement:
   \[
   \text{WHERE ( ( ( t2.Gender IN ('F') ) \ AND \ ( (t2.Age \geq 20) \ AND \ (t2.Age \leq 50) ) ) )}
   \]
8. Click **Run Query** to import the data into JMP.

   The data table scripts include the custom query.

**Note:** If you select **Revert to Interactive** from the red triangle menu, the changes that you made on the Custom SQL tab are not saved. If you save the custom query and reopen it, Revert to Interactive is not available.

See “Structured Query Language (SQL): A Reference” on page 129 for a brief primer of SQL statements.

---

### Import Data from a Database

You can import data from a database if you have an ODBC (Open Database Connectivity) driver for the database and then save the data back to the database.

This section describes how to connect to a database and import the data. Refer to “Build SQL Queries in Query Builder” on page 102 for details about interactively building queries.

**Notes:**
- Database table names that contain the characters $# -+/%()&|;? are not supported.
- Multiple connections to a datasource are not permitted.

### Connect to a Database

Your operating system provides an interface for JMP to communicate with databases using ODBC data sources. Create and configure data sources with operating system software. For example, on Windows 7, use **Control Panel > System and Security > Administrative Tools > Data Sources (ODBC)**; on the Macintosh, use **Applications > Utilities > ODBC Manager**.

After you create the data source in the operating system software, follow these steps to connect to the database in JMP.

1. Select **File > Database > Open Table**. The Connections box lists data sources that you have connected to in the current JMP session.
2. Click **New Connection**.

3. (Windows) In the Select Data Source window (Figure 3.44), click the Machine Data Source tab, select the data source, click **OK**, enter the user name and password, and then click **OK**.
   
   (Macintosh) In the Choose DSN window, select the data source, enter the user name and password, and then click **Choose DSN**.

**Figure 3.44** Select a Data Source (Windows)

The new connection is shown in the Database Open Table window.

**Open Data from a Database**

After you connect to the ODBC database and select a table to import, the data is opened in a data table. Several table scripts are included in the data table.

- Run the Source script to reconnect to the database.
- Run the Update from DB script to re-import and refresh the data.
- Run the Save to DB script to save the data table to the database. The existing data in the database is replaced. This script might contain the user name and password. There is a JSL-only preference called **ODBC Hide Connection String** that can be set to prevent including this possibly sensitive information. See the Extending JMP chapter in the **Scripting Guide** for more details.

**To import data from a database**

1. Select **File > Database > Open Table**.

   The Database Open Table window appears (Figure 3.45).

2. If you are already connected to the database, select it in the Connections box. Follow the steps in “**Connect to a Database**” on page 124.
The Connections box lists data sources to which JMP is connected. The Schemas - Tables box lists schemas for those databases that support them.

**Figure 3.45** Database Open Table Window

When one or more database connections are made, the list of connections shows in the Connections list.

If your database supports schemas (for example, Oracle), this field shows the schema list. It disappears if you select a database that does not support schemas.

If there are tables in the selected database file or directory, they appear in the Tables list.

**Note:** The *Fetch Procedures* check box is disabled if the ODBC driver does not support fetching procedures.

3. If the desired data source is *not* listed in the Connections box, click **Connect** to choose a data source. The method of choosing a data source depends on your operating system. Select a data source and click **OK**.

4. Select the desired data source in the Connections box. The tables list in the Tables box updates accordingly. The update might take a several seconds, depending on the number of tables and the speed of the connection to the database. If your database supports schemas, tables are loaded for the first schema in the list, and on other schemas as you click on them.

5. Control which tables are listed by choosing the options in the **Include in Table List** group of check boxes. Different drivers interpret these labels differently. Your options are as follows:
Chapter 3
Using JMP

Import Your Data

Import Data from a Database

**User Tables**  When clicked, displays all available user tables in the **Tables** list. User tables are specific to which user is logged on to the computer.

**Views**  When clicked, displays “views” in the **Tables** list along with all other file types that can be opened. “Views” are virtual tables that are query result sets updated each time you open them. They are used to extract and combine information from one or more tables.

**System Tables**  When clicked, displays all available system tables in the **Tables** list. System tables are tables that can be used by all users or by a system-wide service.

**Synonyms**  When clicked, displays all available ORACLE synonyms in the **Tables** list.

**Sampling**  Enter the percentage of rows that you want to appear in the list of tables. Selecting this option speeds up queries in large databases. JMP uses the sampling method supported by the database. The check box is unavailable when the database does not support sampling.

6. Select the desired table from the **Tables** list.

**Note:** If you are connected to a dBase database, select the database folder to which you would like to connect. Individual files are grayed out and cannot be selected.

7. Click **Open Table** to import all the data in the selected table, or click **Advanced** to specify a subset of the table to be imported. Some databases require that you enter the user ID and password to access the data.

   You might see a short delay when opening large tables. To see the status of all active ODBC queries, select **View > Running Queries**.

**Note:** If the data were previously exported to a database in JMP and contained an Expression column, the column will be imported as a Character column. Select **Cols > Column Info** and change the Data Type to Expression.

### Write SQL Statements to Query a Database

You can use Structured Query Language (SQL) statements to control what you import from a database. When you open a database file in JMP, you are actually sending an SQL statement to the database. By default, this statement gets all files and records in the database table. In some cases, this is too much data. When you are interested only in a subset of the table’s data, you can customize the SQL request to only request the data that you want. After you execute an SQL query, the code for the query is stored in the data table in the SQL table variable.

This section describes how to write SQL statements to retrieve data. To interactively query data without writing SQL statements, use Query Builder. You can also start creating a query in Query Builder and then add your own SQL. See “Write SQL Statements in Query Builder” on page 123 for details.
1. Select **File > Database > Open Table**.

The Database Open Table window appears (Figure 3.45).

2. Connect to the database if necessary or select an existing database connection. Follow the steps in “**Connect to a Database**” on page 124.

The Connections box lists data sources to which JMP is connected. The Schemas - Tables box lists schemas for those databases that support them.

**Note:** The SQL Query that you run in this window operates only on the tables and procedures that are displayed in the left panes of the window. Running unrelated SQL here has no results.

3. From the Database Open Table window, click the **Advanced** button to open specific subsets of a table.

4. Either type in a valid SQL statement, or modify the default statement. Figure shows a default SQL *Select* statement appropriate for the selected file. See “**Structured Query Language (SQL): A Reference**” on page 129, for a description of SQL statements that you can use.

Instead, you can add expressions by clicking the **Where** button and using the WHERE Clause editor to create expressions. See “**Use the WHERE Clause Editor**” on page 133, for details.

**Figure 3.46** Reading All Variables from the Solubility Table Stored in an Excel File

![Database Operations](image)

- **List of tables that are accessible in the current database**
- **List of columns that appear in the table.**
- **Highlight another table name in the list on left to view its columns**

Type the SQL statement in this box.
5. Click **Execute SQL**. A JMP data table appears with the columns that you selected. (For details, see “Use Table Variables” on page 217 in the “Enter and Edit Data” chapter.)

6. To see the status of all running queries, select **View > Running Queries**.

Note that you can enter any valid SQL statement and click **Execute SQL** to execute the command. Valid SQL varies with the data source and ODBC driver.

**Structured Query Language (SQL): A Reference**

The following sections are a brief introduction to SQL. They give you insight to the power of queries, and they are not meant to be a comprehensive reference.

**Use the SELECT Statement**

The fundamental SQL statement in JMP is the **SELECT** statement. It tells the database which rows to fetch from the data source. When you completed the process in “Write SQL Statements to Query a Database” on page 127 with the Solubility.jmp sample data table, you were actually sending the following SQL statement to your data source:

```sql
SELECT * FROM "Solubility"
```

The * operator is an abbreviation for “all columns.” So, this statement sends a request to the database to return all columns from the specified data table.

Rather than returning all rows, you can replace the * with specific column names from the data table. In the case of the Solubility data table example, you could select the ETHER, OCTANOL, and CHLOROFORM columns only by submitting this statement:

```sql
SELECT ETHER, OCTANOL, CHLOROFORM FROM "Solubility"
```

**Note:** JMP does not require you to end SQL statements with a semicolon.

JMP provides a graphical way of constructing simple **SELECT** statements without typing actual SQL. To select certain columns from a data source, highlight them in the list of columns.

*To highlight several rows*

- Shift-click to select a range of column names
- Ctrl-click (Windows) or Command-click (Macintosh) to select individual column names.

Note that the SQL statement changes appropriately with your selections.

Sometimes, you are interested in fetching only unique records from the data source. That is, you want to eliminate duplicate records. To enable this, use the **DISTINCT** keyword.

```sql
SELECT DISTINCT ETHER, OCTANOL, CHLOROFORM FROM "Solubility"
```
Sort Results

You can have the results sorted by one or more fields of the database. Specify the variables to sort by using the ORDER BY command.

```
SELECT * FROM "Solubility" ORDER BY LABELS
```

selects all fields, with the resulting data table sorted by the LABELS variable. If you want to specify further variables to sort by, add them in a comma-separated list.

```
SELECT * FROM "Solubility" ORDER BY LABELS, ETHER, OCTANOL
```

Use the WHERE Statement

With the WHERE statement, you can fetch certain rows of a data table based on conditions. For example, you might want to select all rows where the column ETHER has values greater than 1.

```
SELECT * FROM "Solubility" WHERE ETHER > 1
```

The WHERE statement is placed after the FROM statement and can use any of the following logical operators.

**Table 3.1 WHERE Operators**

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>!= or &lt;&gt;</td>
<td>Not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less Than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>NOT</td>
<td>Logical NOT</td>
</tr>
<tr>
<td>AND</td>
<td>Logical AND</td>
</tr>
<tr>
<td>OR</td>
<td>Logical OR</td>
</tr>
</tbody>
</table>

When evaluating conditions, NOT statements are processed for the entire statement first, followed by AND statements, and then OR statements. Therefore

```
SELECT * FROM "Solubility" WHERE ETHER > -2 OR OCTANOL < 1 AND CHLOROFORM > 0
```
is equivalent to

```
SELECT * FROM "Solubility" WHERE ETHER > -2 OR (OCTANOL < 1 AND CHLOROFORM > 0)
```

**Use the IN and BETWEEN Statements**

To specify a range of values to fetch, use the IN and BETWEEN statements in conjunction with WHERE. IN statements specify a list of values and BETWEEN lets you specify a range of values. For example,

```
SELECT * FROM "Solubility" WHERE LABELS IN ('Methanol', 'Ethanol', 'Propanol')
```
fetches all rows that have values of the LABELS column Methanol, Ethanol, or Propanol.

```
SELECT * FROM "Solubility" WHERE ETHER BETWEEN 0 AND 2
```
fetches all rows that have ETHER values between 0 and 2.

**Use the LIKE Statement**

With the LIKE statement, you can select values similar to a given string. Use % to represent a string of characters that can take on any value. For example, you might want to select chemicals out of the Solubility data that are alcohols, that is, have the OL ending. The following SQL statement accomplishes this task.

```
SELECT * FROM "Solubility" WHERE LABELS LIKE '%OL'
```

The % operator can be placed anywhere in the LIKE statement. The following example extracts all rows that have labels starting with M and ending in OL:

```
SELECT * FROM "Solubility" WHERE LABELS LIKE 'M%OL'
```

**Use Aggregate Functions**

Aggregate functions are used to fetch summaries of data rather than the data itself. Use any of the following aggregate functions in a SELECT statement.

<table>
<thead>
<tr>
<th>Function</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM( )</td>
<td>Sum of the column</td>
</tr>
<tr>
<td>AVG( )</td>
<td>Average of the column</td>
</tr>
<tr>
<td>MAX( )</td>
<td>Maximum of the column</td>
</tr>
<tr>
<td>MIN( )</td>
<td>Minimum of the column</td>
</tr>
<tr>
<td>COUNT( )</td>
<td>Number of rows in the column</td>
</tr>
</tbody>
</table>
Some examples include:

- The following statement requests the sum of the ETHER and OCTANOL columns:
  
  ```sql
  SELECT SUM(ETHER), SUM(OCTANOL) FROM "Solubility"
  ```

- This statement returns the number of rows that have ETHER values greater than one:
  
  ```sql
  SELECT COUNT(*) FROM "Solubility" WHERE ETHER > 1
  ```

- The following statement lets you know the average OCTANOL value for the data that are alcohols:
  
  ```sql
  SELECT AVG(OCTANOL) FROM "Solubility" WHERE LABELS LIKE '%OL'
  ```

**Note:** When using aggregate functions, the column names in the resulting JMP data table are Expr1000, Expr1001, and so on. You probably want to rename them after the fetch is completed.

**The GROUP BY and HAVING Commands**

The GROUP BY and HAVING commands are especially useful with the aggregate functions. They enable you to execute the aggregate function multiple times based on the value of a field in the data set.

For example, you might want to count the number of records in the data table that have ETHER=0, ETHER=1, and so on, for each value of ETHER.

- `SELECT COUNT(ETHER) FROM "Solubility" GROUP BY (ETHER)` returns a single column of data, with each entry corresponding to one level of ETHER.

- `SELECT COUNT(ETHER) FROM "Solubility" WHERE OCTANOL > 0 GROUP BY (ETHER)` does the same thing as the above statement, but only for rows where OCTANOL > 0.

When using GROUP BY with an aggregate function of a column, include the column itself in the SELECT statement. For example,

- `SELECT ETHER, COUNT(ETHER) FROM "Solubility" GROUP BY (ETHER)` returns a column containing the levels of ETHER in addition to the counts.

**Use Subqueries**

Aggregate functions are also useful for computing values to use in a WHERE statement. For example, you might want to fetch all values that have greater-than-average values of ETHER. In other words, you want to find the average value of ETHER, and then select only those records that have values greater than this average. Remember that `SELECT AVG(ETHER) FROM "Solubility"` fetches the average that you are interested in. So, the appropriate SQL command uses this statement in the WHERE conditional:

- `SELECT * FROM "Solubility" WHERE ETHER > (SELECT AVG(ETHER) FROM "Solubility")`
Save and Load SQL Queries

After constructing a query, you might want to repeat the query at a later time. You do not have to hand-type the query each time you want to use it. Instead, you can export the query to an external file. To do this, click the Export SQL button in the window shown in Figure 3.46. This brings up a window that lets you save your SQL query as a text file.

To load a saved query, click the Import SQL button in the window shown in Figure 3.46. This brings up a window that lets you navigate to your saved query. When you open the query, it is loaded into the window.

Use the WHERE Clause Editor

JMP provides help building WHERE clauses for SQL queries during ODBC import. It provides a WHERE clause editor that helps you build basic expressions using common SQL features, allowing vendor-specific functions. For example, you do not need to know whether SQL uses ‘=’ or ‘==’ for comparison, or avg() or average() for averaging.

In addition, string literals should be enclosed by single quotes (‘string’) rather than double quotes ("string").

To open the WHERE clause editor

1. Connect to a database by following the steps in “Connect to a Database” on page 124.
2. From the Database Open Table window, click the Advanced button.
3. Click the Where button.

USE the WHERE Clause Editor to add any of the following from the work panel: expressions, functions, and terms. They are applied to the highlighted red box.

1. Click the Table Name Browser to select a table. The columns in that table appear in the list.
2. Click the SQL Vendor Name Browser to select the type of SQL that you want to use: GenericSQL, Access, DB2, MySQL, Oracle, SQL Server, or all of the above. Perform an action by clicking a function or operator in the list and selecting an operator from the list that appears.

   Note: The following SQL Server data types are not supported: Binary, Geography, and Geometry.

3. Select an empty formula element in the formula editing area by clicking it. It is selected when there is a red outline around it. All terms within the smallest nesting box relative to the place that you clicked become selected. The subsequent actions apply to those combined elements.
4. Add operators to an expression by clicking buttons on the keypad.
5. (Optional) To customize your WHERE clause, select one of the options from the red triangle menu above the keypad:

**Show Boxing**  Show or hide boxes around the WHERE clause terms.

**Larger Font**  Increase the font size of the formula.

**Smaller Font**  Decrease the font size of the formula.

**Simplify**  Simply the WHERE clause statement as much as possible.

The WHERE clause editor works similarly to the Formula Editor, which is described in the “Formula Editor” chapter on page 305.

Figure 3.47  The WHERE Clause Editor

---

**Import Text Files**

You can open text files with the extensions .txt, .csv, and .tsv, and the text is converted to a data table. Files with the .dat extension that consist of text are also supported. Text files can be delimited using almost any character, or they can be fixed-width files.

Trailing whitespace is removed when you import text files into JMP.

When JMP finds an integer in the text file that is greater than 9,007,199,254,740,991, the column is considered character data. You can set the column to numeric using the Text Import Wizard window or an import script.

To adjust import settings, choose from one of the following options

- Select File > Preferences > Text Data Files to change the import settings so that JMP determines the best way to structure and format the data table.
Manually select the import settings as you open the file (described in this section).

Open the file in the Script Editor, edit the content, and then import the content. This option is helpful when you need to add text delimiters or modify the text.

To import a text file

1. Select File > Open.
2. On Windows, you can set the file type to Text Files.
3. Select the text file that you want to open.

For information about the options, see Table 3.3 and Table 3.4.

Table 3.3 Opening Text Files on Windows

<table>
<thead>
<tr>
<th>Automatically Determining Data Arrangement</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select File &gt; Open.</td>
<td>1. Select File &gt; Open.</td>
</tr>
<tr>
<td>2. From the list next to File name, select Text Files.</td>
<td>2. From the list next to File name, select Text Files.</td>
</tr>
<tr>
<td>3. To use the import rules from the preferences, select Data, using Text Import preferences. (See “Text Data Files” on page 513 in the “JMP Preferences” chapter.)</td>
<td>3. Select Data with Preview next to Open at the bottom of the window.</td>
</tr>
<tr>
<td>To have text import use its best guess to arrange the data, select the Data, using best guess option.</td>
<td>4. Select the file that you want to open.</td>
</tr>
<tr>
<td>(Optional) Select the Select this filter the next time this dialog is invoked option to apply the filter that you chose by default.</td>
<td>5. Click Open.</td>
</tr>
<tr>
<td>4. Select the file that you want to open.</td>
<td>6. Complete the Text Import window. See “Text Import Wizard Options” on page 136, for details.</td>
</tr>
<tr>
<td>5. Click Open.</td>
<td>7. Click Import.</td>
</tr>
</tbody>
</table>

Tip: The JMP Home window provides a shortcut to the above steps if you recently opened the file. Right-click the file in the Recent Files list and select Import (Preferences) or Import (Best Guess). (Your import preference is bolded in the right-click menu.)
Chapter 3
Using JMP

Text Import Wizard Options

When you open a text file that JMP supports, JMP can show a preview of the text before opening the file as a data table. This option lets you manually arrange and format the data. For example, you can specify the end-of-line character or strip quotation marks.

JMP detects the file’s structure and shows options for importing text with either delimiters or fixed width fields. If JMP chooses the wrong file structure, click the Delimited fields or Fixed width fields radio button to import the data as the correct format. (For example, the fixed width window might appear when your file is actually delimited.)

The text import wizard options are shown in Figure 3.48 and Figure 3.49.

Table 3.4 Opening Text Files on Macintosh

<table>
<thead>
<tr>
<th>Automatically Determining Data Arrangement</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select File &gt; Open.</td>
<td>1. Select File &gt; Open.</td>
</tr>
<tr>
<td>2. Select the file that you want to open.</td>
<td>2. Select the file that you want to open.</td>
</tr>
<tr>
<td>3. From the Open As field, select Data (Best Guess) or Data (Using Preferences).</td>
<td>From the Open As field, select Data (Using Preview).</td>
</tr>
<tr>
<td>4. Click Open.</td>
<td>3. Click Open.</td>
</tr>
<tr>
<td></td>
<td>4. Complete the Text Import Wizard window. See “Text Import Wizard Options” on page 136, for details.</td>
</tr>
<tr>
<td></td>
<td>5. Click Import.</td>
</tr>
</tbody>
</table>

Note: On Windows, JMP can open text files in your computer’s default text editor. Select File > Open, and then select All Files (*) from the File name list. Select the text file, and then select Use default program to open. Uncheck to open as text.

For details about importing text from a Script window, see “Import Text from the Script Editor” on page 142.
Figure 3.48 Text Import Wizard for Fixed Width Files

Fixed data format: click to create additional column dividers. Drag the dividers to the proper positions. Drag a divider on top of another divider to delete it. The numbers at the top are the column positions and the column widths. The next step sets the column names and types.

File contains column names on line: [ ] 1
Data starts on line: [ ] 1

Subset

- All
- lines from start of file
- lines from end of file
- random lines in file
- probability per line (0.0 to 1.0)

Compatibility

- Strip enclosing quotation marks
- Two-digit year rule 2000-2099
- Recognize apostrophe as quotation mark (not recommended)
Figure 3.49 Text Import Wizard for Delimited Files

Charset Select the character set used in the imported file, or let JMP detect the character set. If incorrect characters are displayed in the imported file, open the file again and select another character set.

End of Field  (Available only in the Delimited Import window) Select the check boxes beside the character that marks the end of a field. Alternatively, select the check box beside Other and enter a character if the appropriate character is not listed.

End of Line  (Available only in the Delimited Import window) Select the check boxes beside the character that marks the end of a line (row). Alternatively, select the check box beside Other and enter a character if the appropriate character is not listed. Note that when JMP finds double quotation marks, the delimiter rules change to look for an end double quotation mark. Other text delimiters, including spaces embedded within the quotes, are ignored and treated as part of the text string.

File contains column names on line  Tell JMP where to find data to use as column names. For example, if the column names in your text file are on line (row) 3, select this option and type 3 in the check box. Otherwise, JMP uses the data in the first line of the imported file as the column name in the JMP data table or takes the first line as data.

Data starts on line  Specify the number of the first line that contains data.
Number of Lines  Specify the number of lines (rows) that you want to import.

Strip enclosing quotation marks  Available only on fixed-width imports. Select this check box when you want JMP to remove quotation marks that enclose data in the text file.

Two-digit year rule  Specify how to display dates that have two-digit years. Select the 100-year range in which your dates fall. For example, if the earliest date is 2/2/79, and the year is 1979, select 1970-2069. If the earliest date is 2/2/12, and the year is 2012, select 2000-2099. If dates span centuries, you must recode the dates with four-digit years before importing the data.

Recognize apostrophe as quotation mark (not recommended)  (Available only in the Delimited Import window). Use this option only if your data comes from a nonstandard source that places apostrophes around data fields rather than quotation marks.

Use Regional Settings  Specifies whether the operating system’s regional settings are used when importing a text file. If the option is deselected (the default setting), files that use a period for a decimal point and a comma for the value separator import correctly. If the file uses a comma for a decimal point and some other value separator (and the regional settings use a comma for a decimal point), selecting this option imports the text correctly. You must specify the value separator in the Text Data Files import preferences.

When you are finished selecting the settings, click Next. The next window shows each column’s modeling type. To change the default modeling types, do one of the following:

- Click on the data type icon to change the data type from numeric ( ) to character ( ). Clicking the icon cycles between the modeling type and exclude ( ). Exclude means that the column is not imported.
- To change a numeric column’s data format, select the format from the red triangle menu.
- Click on the column heading to modify the text.

The top of the text import window shows a preview of the text file as it appears when imported into a JMP data file. Click the Import button to import the data.
6. When you are finished, click **Import** to complete the text import.

### Open a Text File in a Text Editing Window

You can open a text file in a Script window, where you edit the text. Then you can import the text as a data table. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.

Another option is opening a JMP add-in definition (.def) file as text and then editing it in a Script window.

*To open a text file in a text editing window (Windows)*

Files that you recently opened are listed in the JMP Home window. For most files, right-click the text file and select **Open as Plain Text** to open the file in a text editing window. JMP add-in definition files cannot be opened as plain text from the JMP Home window.

When you are opening the file for the first time, follow these steps:

1. Select **File > Open**.
2. Do one of the following:
   - To open a JMP add-in definition file as text, select **All JMP Files** or **JMP Add-In Files** from the list next to **File name**. Click the **Open** button arrow, and then select **Open as Plain Text**. The file opens in a Script window. Skip the remaining steps.
   - To open other text files, select **Text Files** from the list next to **File name**.
3. (Optional) To set the default option file type to **Text Files**, select the check box beside **Select this filter the next time this dialog is invoked**.

4. Select the file.

5. Select **Plain text into Script window** next to **Open as**.

6. Click **Open**.

   The text appears in a Script window.

---

*To open a text file in a text editing window (Macintosh)*

1. Select **File > Open**.
2. Select the file.
3. Select **Text** from the **Open As** list.
4. Click **Open**.

   The text appears in a Script window.

For details about converting the text to a data table, follow step 3 in “Import Text from the Script Editor” on page 142.

**Import Text from the Script Editor**

You can import text from the Script Editor as a data table. The text can be in a table format (for example, from a Microsoft Word document or Web page) or in plain text format. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.

JMP uses the import settings in the preferences to determine how to structure and format the text. Some options include removing quotation marks around text and specifying the rows that contain column headings and data. See “Text Data Files” on page 513 in the “JMP Preferences” chapter for details.
**Note:** You can also import an entire web page as a data table. See “Import Data from the Internet or a Remote Computer” on page 143 for details.

This section describes how to import text that you paste into the Script Editor. For details about opening a text file in the Script Editor, see “Open a Text File in a Text Editing Window” on page 140.

*To import text from the Script window*

1. Open a new Script window in JMP by selecting **File > New > Script** (Windows) or **File > New > New Script** (Macintosh).
2. Copy and paste the text into the Script Editor.
3. Do one of the following:
   - To import all text from the Script Editor, select **File > Import as Data** (Windows) or **Edit > Import as Data** (Macintosh).
   - To import specific text, select the text, and then select **File > Import as Data** (Windows) or **Edit > Import as Data** (Macintosh).

   The text is imported into a JMP data table.

**Note:** To preview text that you import from the Script Editor, hold down the Shift key before you select File > Import as Data.

---

**Import Data from the Internet or a Remote Computer**

Import data from the Internet, FTP sites, or other computers by selecting **File > Internet Open**. A file path can start with *http*, *ftp*, or *file*; a drive letter; or, the path to a network drive (relative or absolute).

Using Internet Open, you can import data from the Internet or a remote computer and save it as a data table, web page, or text. You can also open a SAS stored process report using this option.

Suppose that you want to import data in a table on a web page and save it as a data table. The web page lists countries by population.

1. Select **File > Internet Open**.
2. Enter the following URL:
   
3. Click **OK**.
4. Keep **Open as** set to **Data**, and click **OK** again.
JMP finds several tables on the specified page.

5. Click **Rank country (or dependent territory)**... and click **OK**.

6. Click OK again

JMP opens a data table that contains the information from the web page table.

**Notes:**

- You can open a remote file as one of the following formats:
  - **Data** Opens the file as a data table.
  - **Web page** Opens the web page in the JMP browser (Windows) or the default browser (Macintosh).

  From the File menu on Windows, you can then choose to save the file or import the data as a data table. Select this option to import data that is generated by web page scripts and server-side requests.

  - **Text** Opens the file in the script editor. If you imported an HTML file, the HTML tags of a web page are displayed.

- When you open a file from an FTP server, an FTP login window appears. For an anonymous account, click **OK**. For an authenticated login, enter your user ID and password. The file then opens as you specified.

**Note:** Some anonymous FTP servers require a user ID. If the data table does not open, try typing either ‘ftp’ or ‘anonymous’ in the User ID text box. Leave the Password text box empty and click **OK**.

- JMP waits 60 seconds before stopping the import due to an error. You can change the Internet Time Out setting on the General preferences page.

- If the table that you are importing contains images, the images are first imported as text. To display the images in your data table, run the automatically generated table script named **Load pictures**. A new expression column that contains the images is added to the data table.

- Running the Source script in a data table enables you to re-import and refresh the data.

To open a SAS stored process report as a data table (Windows only)

1. Select **File > Internet Open** and select the file.

   The file opens in the JMP browser.

2. In the JMP browser, select **File > Import Table as Data Table**.

   A window appears that lists the tables found in the web page.

3. Select the table or tables that you want to import.

4. Click **OK**.
Each table is opened as a new data table.

See “Run Stored Processes” on page 96 for more information about stored process reports.

**Import SPSS Files**

JMP opens SPSS files as data tables and maintains several SPSS features:

- General numeric and character data with minimal formatting are supported.
- SPSS date, datetime, and time formats are supported.
- By default, labels are converted to column headings. When you select this option, and the data contains no labels, the columns are named *Column 1, Column 2*, and so on.

You also have the option of selecting the conversion method for column headings when opening an SPSS file. The method that you select then overrides the preferences.

To change the default conversion method, select **File > Preferences** (or **JMP > Preferences** on Macintosh). On the General page, deselect **Use SPSS labels for column names during import**. Variable names are then imported automatically as column headings.

- The value labels that you defined in the SPSS file are saved as Value Labels column properties. The value label then appears in each data table cell instead of the original value. For details about Value Label properties, see “Value Labels” on page 238 in the “The Column Info Window” chapter.

- SPSS can assign certain values in a variable to be treated as missing for analyses. For example, the value 64 could be regarded as missing for a *Height* variable. Then, the calculation of the distribution of height would ignore values of 64. When you import SPSS into JMP, these values are included in the Missing Value Codes column property for the appropriate variable.

  Missing value ranges of up to 20 numbers are supported. If the range begins with a negative number, the numbers count down to the maximum value (for example, -10 through -5). If the range begins with a positive number, the numbers count up from the minimum value (for example, 1 through 12).

Custom currency formats selected in an SPSS file are not maintained on import. In addition, JMP does not read SPSS data that contains double-byte characters, such as non-Unicode Japanese characters.

**Note:** As with importing other files, you might experience a delay when opening and saving large SPSS files.

To open an SPSS file (Windows)

1. Select **File > Open**.
2. From the list next to File name, select **SPSS Data Files (*.sav)**.
3. Select the SPSS file.
4. (Optional) To specify the column headings, select one of the following **Set JMP column names from** options:
   - **SPSS Labels** creates column headings from SPSS labels.
   - **SPSS Variable Names** creates column headings from variable names.
5. Click **Open**.
   JMP opens the file as a data table.

*To open an SPSS file (Macintosh)*

1. Select **File > Open**.
2. Select the SPSS file.
3. (Optional) To specify the column headings, do one of the following
   - Deselect **Use SPSS Labels as Headings** to convert variable names to column headings.
   - Select **Use SPSS Labels as Headings** to convert labels to column headings.
4. Click **Open**.
   JMP opens the file as a data table.

---

**Import Triple-S Survey Data**

Triple-S (SSS) is a specification for survey data. The survey data is stored in a pair of files: .xml or .sss, and a .csv, .dat, or .asc file. The .xml or .sss file defines the variables and describes the survey. The accompanying .csv, .dat, or .asc file contains the data gathered from each respondent.

Variable labels are converted to column headings by default. To convert variable names to column headings, deselect **Use Triple-S Labels as Headings** in the JMP General preferences.

To import a Triple-S file, follow these steps:

1. Place the pair of Triple-S files in the same folder and use the same root name for both files.
2. Select **File > Open**.
3. On Windows, select **Triple-S Survey Files** from the File name list.
4. Select the SPSS file.
5. (Optional on Windows) To override the Triple-S column heading preference, select Variable Labels or Variable Names next to **Set JMP column names from**.
6. Click **Open**.
JMP opens the file as a data table.

**Import HDF5 Data**

Hierarchical Data Format, Version 5 (HDF5) is a portable file format for storing data. An HDF5 file consists of groups and datasets. When you import the file, JMP opens a group to present the names of the inner datasets. For example, if the file contains data for a group of musical recordings with songs and artists tables, JMP prompts you to open either “songs” or “artists”. If the file does not contain a group, JMP prompts you to open a single table.

JMP handles only tables with numeric (integer, float, double) and string types, and compound files with three or fewer dimensions that contain only simple types. If a data set does not appear in the import window, the file is most likely unsupported.

You can import up to 1,000,000 columns and an unbounded number of rows.

**Note:** Only ASCII characters are supported in HDF5 files. Non-ASCII characters such as French and Chinese characters are not supported.

To import an HDF5 file, follow these steps:

1. Select **File > Open**.
2. On Windows, make sure that **All JMP Files** or **HDF5 Data File** is selected from the File name list.
3. Select the HDF5 file.
   A list of groups or datasets in the file appears.
4. Select the data set that you want to import and click **Import**.
   The data are opened as data tables.

**Import JSON Files**

A JSON file consists of name and value pairs that are imported as column headings and data. In the following example, the first name in each string is appended to “Grocery Store Purchases” and turned into column headings, as in “Grocery Store Purchases.Item”. “avocado” is the value in the first cell of the table. The next column is named “Grocery Store Purchases.Category”, and “Produce” is the value in the first cell of the second column.

```json
{"Grocery Store Purchases": [
    {"Item":"avocado", "Category":"Produce"},
    {"Item":"bread", "Category":"Bakery"},
    {"Item":"chocolate", "Category":"candy"}
]}
```
To open a JSON file in JMP, select **File > Open**, select the file, and then click **Open**. On Windows, make sure that JSON Data File is selected in the Filename list on the Open Data File window.

**Notes:**

- The JSON file does not contain date, time, currency, geographic, percent, and scientific information to determine the column format. After you import the file into JMP, right-click the numeric column, select **Column Properties**, and change the Format.
- The available memory on your computer determines the maximum number of columns rows that can be imported. The limit also depends on the other programs that are running at the time of import.
- Member names in name-value pairs are case insensitive.
- For nested items, JMP repeats the outer item for each row.
- The file cannot have an empty array element. The name must be quoted before the colon in the name-value pair.
- The locale is ignored when you export data to JSON format. The JSON standard accepts decimal numbers with decimal points.

---

**Import Data from MATLAB**

JMP provides a scripting interface to MATLAB. See the Extending JMP chapter in the *Scripting Guide* and the Functions chapter in the *JSL Syntax Reference*.

---

**Import Data from R**

JMP provides a scripting interface to R. See the Extending JMP chapter in the *Scripting Guide* and the Functions chapter in the *JSL Syntax Reference* for details.

---

**Import Data Using the Excel Add-In**

The add-in for Excel provides new capabilities to JMP and Excel users on Windows:

- Transfer selected cells in Excel to JMP data tables. See “Transfer Excel Data to a JMP Data Table” on page 149.
- Use the JMP Profiler with calculation models in Excel workbooks. The profiler tool is designed to bring the power of the JMP profiler to models residing in Excel worksheets. You do not have to recreate your Excel models in JMP, verify that they are correct, and maintain the model in both JMP and Excel. For more information, see the Excel Profiler chapter in the *Profiler* book.
Note: During the JMP installation, select the Excel Add-In. This installs the add-in for your version of Microsoft Excel.

- Microsoft Excel 2007, Microsoft Excel 2010, Microsoft Excel 2013, and Microsoft 2016 are supported.

Transfer Excel Data to a JMP Data Table

You can use the JMP Add In for Excel to transfer a worksheet from Excel to the following JMP destinations:

- a data table
- Graph Builder
- Distribution platform
- Fit Y by X platform
- Fit Model platform
- Time Series platform
- Control Chart platform

You can also create models for profiling in JMP. See the Excel Profiler chapter in the Profilers book.

To transfer data from Excel to a JMP data table and platform

1. In your Excel worksheet, show the JMP add-in on the ribbon.
2. Click the Preferences button.
3. Accept the default Data Table Name (File name_Worksheet name) or type a name.
4. Select Use the first rows as column names if the first row in the worksheet contains column headers.
5. If you selected to use the first rows a column headers, type the number of rows used.
6. Select Transfer Hidden Rows if the worksheet contains hidden rows to be included in the JMP data table.
7. Select Transfer Hidden Columns if the worksheet contains hidden columns to be included in the JMP data table.
8. Click OK to save your preferences.
9. Select the cells to transfer into JMP, including any cells that you want to use as column names.

If you are using cells as column names, they need to be the first rows in your selection. If only one cell (or no cell) is selected, the entire Excel worksheet is transferred to JMP.
10. Select the JMP destination from the toolbar:
   - Data Table
   - Graph Builder
   - Distribution platform
   - Fit Y by X platform
   - Fit Model platform
   - Time Series platform
   - Control Chart platform
   JMP opens, and the selected data is placed in a new JMP data table and the selected launch window appears.

**Note:** Empty cells are imported as missing data, and dates, numbers, and strings are recognized correctly.

**Note:** Your JMP windows might be hidden behind your Excel window, especially if you maximize Excel.

For more information about using the various JMP platforms refer to the proper book.

**About the JMP Add-In for Excel**

The JMP add-in commands are in two groups:

**Transfer to JMP**

**Preferences** Set preferences for transferring data from Excel to JMP.

**Data Table** Transfer the selected data in your Excel file to a JMP data table.

**Graph Builder** Transfer the selected data in your Excel file to a JMP data table and launch the Graph Builder platform.

**Distribution** Transfer the selected data in your Excel file to a JMP data table and launch the Distribution platform.

**Fit Y By X** Transfer the selected data in your Excel file to a JMP data table and launch the Fit Y by X platform.

**Fit Model** Transfer the selected data in your Excel file to a JMP data table and launch the Fit Model platform.

**Time Series** Transfer the selected data in your Excel file to a JMP data table and launch the Time Series platform.
Control Chart  Transfer the selected data in your Excel file to a JMP data table and launch the Control Chart platform.

Profile in JMP

Create/Edit Model  Set up preferences for using the JMP profiler with Excel data.

Run Model  Run the JMP profiler.

Uninstall the Excel Add-In

To uninstall the Excel Add-in, double-click the JMP installer, click Modify, and deselect Excel Add-In.

Create New Data Tables

To create a new data table by entering data manually, follow these steps:

1. Select File > New > Data Table. This shows an empty data table with no rows and one numeric column, labeled Column 1.

2. Move the cursor onto a cell.

3. Click in the cell. The cursor appears as a line in the cell, as shown in Figure 3.53.

Figure 3.53  A New Data Table

4. Enter a value.

There are several ways to fill a table with values:

- Create new rows and columns and type or paste data into the data grid. (See “Enter Data” on page 154 in the “Enter and Edit Data” chapter.)
• Construct a formula to calculate column values. (See “Create a Formula” on page 306 in the “Formula Editor” chapter.)
• Import data from another application. (See “About Importing Data to JMP” on page 64.)
• Copy values from another application and paste them into the table.
• Use a measuring instrument to read external measures. See the Extending JMP chapter in the Scripting Guide for details about data feeds.
• Drag columns from one table to another.

See the “Enter and Edit Data” chapter on page 153 for details about how to format, edit, and work with data tables.
After you import data into JMP or create a new data table, you can format your data to prepare it for analysis.

This chapter contains the following information:

- Change formatting for numeric values
- Add, delete, and select rows and columns
- Use the Row Editor to navigate within rows and edit rows
- Create scripts that are saved to the data table

Figure 4.1 The Rows and Cols Menus
Enter and edit data using the options in the Rows and Cols menus.
Enter Data

This section describes how to add rows and columns, fill columns with sequential data, and enter cell formulas.

Tip: Consider setting the Autosave Timeout value in the General preferences to automatically save open data tables at the specified number of minutes. This autosave value also applies to journals, scripts, projects, and reports.

Copy and Paste Data

When you paste data from another document into a data table, JMP adds rows and columns as needed. Click on a cell and paste the data.

The data type of the copied content needs to match the data type of the cells you’re pasting into. You can add new columns and paste the data, paste the data into cells of the correct data type, or change the data type of the cells if applicable.

Add Rows

To add any number of rows to the table
1. Select Rows > Add Rows.
2. Enter the number of rows to add.
3. Specify where to add the new rows (at the start or end of the data table, or after a specific row).
4. Click OK.

To add a single row to the end of the table
• Below the last row, click anywhere in a cell and begin typing.
• Below the last row, double-click in the empty row number area.

Add Columns

There are several ways to add new columns:
• Double-click the empty space to the right of the last data table column to add one column. See “About the Column Info Window” on page 224 for details about changing attributes after you add the column.
• Select Cols > New Columns. Use this option to add one or more columns and change their attributes.
• Double-click on the upper rectangle in the data table panel and select Add Multiple Columns.

**Note:** When you initially create a column, you can choose to fill it with initial data values. See “Initialize Data” on page 233 in the “The Column Info Window” chapter. However, after you modify the cells, this option no longer appears.

*To add one or more columns using New Columns*

1. (Optional) Select the column before or after which the new column or columns will be added.
2. Select Cols > New Columns.
3. Change the column name.
   By default, the new column names are Column 1, Column 2, and so on.
4. Select the data type, modeling type, and format for all of the columns. See “About the Column Info Window” on page 224.
5. (Optional) Select initial data values for all of the columns. See “Initialize Data” on page 233 in the “The Column Info Window” chapter.
6. Specify where you want to put the new columns. If you do not select an option, the column is added after the last column.
7. (Optional) For multiple columns, specify whether the columns should be grouped. See “Group Columns” on page 171.
8. To add more columns, follow these steps:
   a. Click Apply to add the new column.
   b. Click Next, change the column properties, and then click Apply.
   c. Click Next to add another column.
9. Click OK to save your changes.
Tip: To change the modeling type after the columns are created, click on the modeling type icon in the Columns panel and select a different type.

To add one or more columns using *Add Multiple Columns*

1. Double-click the upper triangular area in the data grid and select *Add Multiple Columns*.
2. Change the prefix for each column.
   By default, the new column names are Column 1, Column 2, and so on.

3. Enter the number of columns to add.

4. Specify whether the columns should be grouped. See “Group Columns” on page 171.

5. Select the data type for all of the columns. See “About the Column Info Window” on page 224.

6. Specify where you want to put the new columns.

7. (Optional) Select initial data values for all of the columns. See “Initialize Data” on page 233 in the “The Column Info Window” chapter.

8. Click OK to save your changes.

**Fill Columns with Sequential Data**

To fill columns with a repeating sequence of data or with a continuation of values

1. Create a sequence of data in a column. See Figure 4.4.

**Figure 4.4** Example of a Sequence of Data

```
<table>
<thead>
<tr>
<th>Column 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
</tbody>
</table>
```

2. Highlight the cells containing the sequenced data. The cells can be in different columns.

3. Right-click the selected cells and select an option under Fill.

**Fill Options**

- **Repeat sequence to end of table** cells below the selection are filled with repeats of the selected cells.
- **Continue sequence to end of table** cells below the selection are filled with a continuation of the pattern found in the selected cells. For example, if the selected cells contain the numbers 1 and 2, then the remaining cells are filled with 3, 4, 5, 6, and so on. If the selected
cells contain the numbers 2 and 4, then the remaining cells are filled with 6, 8, 10, 12, and so on.

**Repeat sequence to**  JMP repeats the pattern found in the selected cells to the row number that you specify.

**Continue sequence to**  JMP continues the pattern found in the selected cells to the row number that you specify.

### Enter Cell Formulas

In numeric columns, you can enter cell expressions preceded by an equal sign (=). JMP evaluates the expression and stores the new number as the cell’s value. Unlike column formulas, a cell expression is not stored. Cell expressions can contain operators, constants, and global and column variables.

*To enter an expression*

1. Click the cell where you want to enter the expression.
2. Type an equal sign (=), and then type the expression. See Table 4.1.
3. Press the ENTER key.

#### Table 4.1  Examples of Expressions in Table Cells

<table>
<thead>
<tr>
<th>Example expression</th>
<th>Cell value</th>
</tr>
</thead>
<tbody>
<tr>
<td>=sqrt(2)</td>
<td>1.41</td>
</tr>
<tr>
<td>=456+890</td>
<td>1346</td>
</tr>
<tr>
<td>=height+weight</td>
<td>Sums the values of cells in columns height and weight located in the same row as the cell that you entered the expression.</td>
</tr>
<tr>
<td>=height[1]</td>
<td>Displays the value found in row 1 of the height column</td>
</tr>
</tbody>
</table>

### Select Rows

*To select one entire row*

- Click in the empty space that contains the row number.

*To select a specific row number*

- Select **Rows > Row Selection > Go to Row** and type in the desired row number.
To select multiple rows

- For continuous selection:
  - Click and drag the cursor over the row numbers.
  - Hold down the Shift key and click the first and last rows of the desired range.
  - Hold down the Shift key and press the up or down arrow key.
- For discontiguous selection:
  - Hold down the Ctrl key and click on each row.

To select or deselect all rows

- To select all rows, select Rows > Row Selection > Select All Rows.
- To deselect all rows, select Rows > Clear Row States.
  or
- Hold down the Shift key and click the lower triangular area in the upper left corner of the data grid to select. Click again in the same area to deselect all rows. See Figure 4.5.
- To clear all highlighted areas in the data table, press the Esc key.

Figure 4.5 Lower Triangular Area

To select random rows

1. Select Rows > Row Selection > Select Randomly.
2. You can randomly select either a specific number of rows, or a proportion of the total number of rows:
   - Enter a whole number to select that number of rows.
   - Enter a value between 0 and 1 to select that proportion of rows.
   For example, enter 10 to select 10 rows. Enter 0.1 to select 10% of the rows.

To invert the row selection

- Select Rows > Row Selection > Invert Row Selection.

To select dominant rows

1. Select Rows > Row Selection > Select Dominant.
2. Choose the column(s) whose values you want to use to determine dominancy.
3. Select the high or low values to dominate by for each column.
4. Click OK.

Note the following about dominant values and rows:

- A value is dominant over another value if it is higher or lower (based on your specification).
- The Select Dominant option selects each row that is not dominated by any other row. A row dominates another row only if all of its values are dominating the other row’s values.
- The resultant set of rows is called the Pareto Frontier.

To save the current row selection in a new column

1. Select Rows > Row Selection > Name Selection in Column.
2. Type a column name.
3. Label the selected and deselected rows.
4. Click OK.

Tip: If you repeat this process after creating the new column and indicate the same column name, the original column is overwritten. Changes that you made in the data table to Unselected or Deselected values are lost. Avoid overwriting those values by clearing the corresponding box in the Name Selection in Column window. For example, to avoid overwriting the Unselected values, clear the Unselected box.

To select excluded, hidden, or labeled rows

1. Select Rows > Row Selection.
2. Select from the following options:
   - Select Excluded
   - Select Hidden
   - Select Labeled

Note: For details about excluded, hidden, or labeled rows, see “Assign Characteristics to Rows and Columns” on page 187.

Locate Next and Previously Selected Rows

You can locate the next selected row after the current row and cause it to flash by selecting Rows > Next Selected. In a script, you can locate the previously selected text before the currently selected text and by selecting Rows > Previous Selected.
Each time you select **Rows > Next Selected**, the next selected row is found and flashes. A beep signals when the last selected row is located.

You might want to use this feature when you have selected rows intermittently in a large data set and want to look through the selected rows in the data table.

**Example of Locating Next Selected Rows**

1. Select **Help > Sample Data Library** and open Diamonds Data.jmp.
2. Select **Analyze > Fit Y by X**.
3. Select **Carat Weight** and click **Y, Response**.
4. Select **Price** and click **X, Factor**.
5. Click **OK**.
6. Select **Tools > Lasso**.
   
   If you cannot see the menu bar, place your mouse pointer over the blue bar below the title bar to reveal it.
7. Lasso some of the points near the 10,000 dollar price at the bottom of the plot. See Figure 4.6.
8. In the data table, select **Rows > Next Selected** (or you can press the F7 key).

You can easily navigate through the selected rows to see the data for each.

**Figure 4.6** Points Selected

---

**Select Columns**

There are several ways to select columns:

- Select columns in the data table itself. See “**Select Columns in a Data Table**” on page 162.
• In a data table that has many columns, select columns by attributes, properties, and statistics in the Columns Viewer. See “Select Columns in the Columns Viewer” on page 163.

**Select Columns in a Data Table**

*To select one entire column*

• In the data grid, click in the empty space around the column name.
  
  or
  
• In the Columns panel, click the column name.

*To select a specific column number*

1. Select **Cols > Column Selection > Go to.**
2. Enter the column number or name and click **OK.**

*To select multiple columns*

• For continuous selection:
  
  – Click and drag the cursor over the column name.
  
  – Hold down the Shift key and click the first and last columns of the desired range.
  
  – Hold down the Shift key and press the left or right arrow key.

• For columns that are not next to each other:
  
  – Hold down the Ctrl key and click on each column.

*To select or deselect all columns*

• Hold down the Shift key and click the upper triangular area in the upper left corner of the data grid to select. Click again in the same area to deselect all columns. See Figure 4.7.

**Figure 4.7 Upper Triangular Area**

<table>
<thead>
<tr>
<th>Big Class</th>
<th>Distribution</th>
<th>Bivariant</th>
<th>Oneway</th>
<th>Logistic</th>
<th>Contingency</th>
<th>Fit Model</th>
<th>Set Sex Value Labels</th>
<th>Set Age Value Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>age</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>KATIE</td>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LOUISE</td>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>JANE</td>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>JACLYN</td>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LILLIE</td>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>TIM</td>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Tip:** To clear all highlighted areas in the data table, press the Esc key.
To invert the column selection

Select **Cols > Column Selection > Invert Column Selection**. Only the previously deselected columns are selected.

**Select Columns in the Columns Viewer**

The Columns Viewer helps you quickly select columns by attributes, properties, and statistics, particularly in a data table that has many columns. You can view summary statistics and properties for those columns, view quartiles in the summary statistics, subset the data, and more. And columns in the Columns Viewer window are also linked to the data table columns (Figure 4.8).

**Figure 4.8 Linked Columns in the Column Viewer**

The Columns Viewer gives you a quick view of data table characteristics. For example, the Summary Statistics report shows which columns contain missing values (Figure 4.9). You can select those columns in the report and then exclude them in the data table.
Figure 4.9 Identify Missing Values

The Summary Statistics report shows the following information:

- the total number of rows (N)
- the number of rows with missing values (N Missing)
- the number of categories (N Categories)
- for continuous data, the Min, Max, Mean, and Std Dev

Other options include the following:

**Clear Select**  Deselects columns in the data table and in the Columns Viewer. This option ensures that no columns are selected before you begin selecting columns.

**Subset**  Creates a linked subset data table from the selected columns.

**Show Summary**  Creates a linked Summary Statistics report for the selected columns.

  Right-click to select options such as sorting by column or creating a data table. Select **Show Quartiles** to include lower quartiles, upper quartiles, and interquartile ranges. And to create a linked data table from all columns in the report, select Data Table View from the Summary Statistics red triangle menu.

**Find Columns with Properties**  Shows a list of column properties in the Columns with Properties report. Select the properties that you want to find and then click **OK** to create a linked report from all columns. Or you can select columns first in the Select Columns list and then show the list of properties just for those columns.

**Tip:** Each time you click the **Show Summary** or **Find Columns with Properties** buttons, a new report is added to the window. To delete a report, select **Remove** from the report’s red triangle menu.
Example of Finding Columns with a Specific Property

This example shows how to find columns that have a Formula property and then view all formulas at once.

1. Select **Help > Sample Data Library** and open **Consumer Preferences.jmp**.
2. Select **Cols > Columns Viewer** to open the Data Table Columns Viewer window.
3. Select **Find Columns with Properties**, select **Formula**, and click **OK**.

   The Columns with Properties report appears. Several columns include the Formula property (Figure 4.10). Because the list is so long, you want to view all formula columns together.

**Figure 4.10** Select the Formula Column Property

4. Right-click the report, select **Sort by Column, Formula**, and then click **OK**.

   Columns that have a Formula property appear at the top of the report (Figure 4.11).
5. Select the Employee Tenure, Position Tenure, and Salary Group columns and select Column Info.

Formulas for the selected columns appear in the data table’s Column Settings window.

**Example of Showing Summary Statistics**

This example shows how to find columns with a low standard deviation. This can be helpful if you want to delete or exclude that data from an analysis.

1. Select Help > Sample Data Library and open Semiconductor Capability.jmp.
2. Select Cols > Columns Viewer to open the Data Table Columns Viewer window.
3. In the Select Columns red triangle menu, select Name Starts With.
4. Type PNP and press Enter to select the PNP columns (Figure 4.12).
5. Click **Show Summary** to add the Summary Statistics report (Figure 4.13).
   The rows show the minimum, maximum, mean, and standard deviation for each column.

**Figure 4.13** Summary Statistics for Selected Columns

6. Right-click in the report and select **Sort by Column**.
7. Select **Std Dev** and **Ascending**, and then click **OK**.
   Notice that PNP6 has no standard deviation, because the minimum, maximum, and mean values are 0.
8. In the Summary Statistics report, select the row for PNP6 and then display the data table.

9. View the data table and press **Delete** to remove the selected column.

   The column is instantly removed from the data table.

10. To close the Columns Viewer, click the **X** button in the upper right corner (Windows) or upper left corner (Macintosh) of the window.

### Locate Next and Previously Selected Columns

You can find the next selected column after the current column by selecting **Cols > Column Selection > Next Selected Column**. Similarly, you can find the previously selected column before the current column by selecting **Cols > Column Selection > Previous Selected Column**.

Each time you select one of these options, the next or previously selected column appears and flashes. The options are available only when columns are selected.

You might want to use this feature to look at intermittently selected columns in a large data table.

### Select Cells

**To select a block of cells**

- Drag the arrow cursor diagonally across the cells.

JMP can find all cells whose values are the same as the ones you currently have highlighted. You can do this within one data table or throughout all open data tables. Highlight the cells that contain the values that you want to locate.

**To find all matching cells within the active data table**

- Select **Rows > Row Selection > Select Matching Cells**

   or
Right-click one of the highlighted row numbers and select **Select Matching Cells**.

**To find all matching cells across all open data tables**

- Select **Rows > Row Selection > Select All Matching Cells**. The rows that contain the same values as the selected ones are highlighted.

**To select cells that contain specific values**

JMP can search for a specific value (or text string) and highlight all of the cells in the data table that contain the specific value.

1. Select **Rows > Row Selection > Select Where**.

**Figure 4.15 Specify Criteria for Selecting Rows**

2. From the column list, highlight the name of the column whose rows you want to select.
3. Use the drop-down menu to select a condition from the list (equals, does not equal, and so on). See Figure 4.15.
4. Type the search value. To search for missing values, leave the box empty.
5. Click **OK**.

You can also specify the following optional features:

- To compare the values of two columns, click the **Compare column** check box. Select from the list of columns for comparison.
- To make the search case-sensitive, click the box beside **Match Case**.

If you currently have rows selected in the data table, you can specify the following optional features:

- Click an option under **Current Selection** to tell JMP how to handle that current selection:
- **Clear** removes the highlight from currently selected rows and selects all rows that contain the specified value.

- **Extend** keeps the currently selected rows selected and also selects the rows in which the specified value has been found.

- **Restrict** selects the rows in the currently selected array that contain the specified values.

- Click **Add Condition** to add a condition to the list.

- To add more conditions to the search, repeat the previous steps. Click the appropriate item in the **Select Rows** area to specify if you would like JMP to select rows conditionally: if all conditions are met, or if any of the conditions are met.

- To keep the window open after you click **OK**, select **Keep dialog open**.

## Resize Rows and Columns

*To resize rows*

Resize rows by dragging one of the row borders. All rows are resized to the same height. Graphics that display inside each cell shrink based on the row height.

*To resize columns*

To resize a column, drag the column border to the right or left.

To resize several columns to the same width, follow these steps:

1. Select the columns that you want to resize.
2. Press the Control key (Windows) or Option key (Macintosh) and drag one of the column borders. All columns are resized to the same width.

## Organize Data

This section describes how to organize data in a table, including editing cells and making changes to rows and columns.

## Delete Rows and Columns

*To delete rows*

1. Highlight the rows that you want to delete.
2. Press the Delete key, or right-click on the row numbers and select **Delete Rows**.
**Caution:** When you try to delete thousands of rows, an alert might appear if your computer has insufficient memory to save data for undo. Either select fewer rows to delete or select Disable Undo from the Table panel red triangle menu. This option removes all actions from the undo history and does not record future actions. When the Disable Undo option is selected, it is in effect only while the data table is open; the setting is not saved with the data table.

To delete columns

1. Highlight the columns to delete.
2. Press the Delete key, or right-click and select Delete Columns.

**Rearrange Columns**

You can rearrange or sort data table columns by their name, data type, or modeling type, or reverse the current order. To reorder columns, select Cols > Reorder Columns and select from one of the following options:

- **Move Selected Columns** moves the selected columns to a particular place in the data table. Specify where to place the selected columns in the Move Selected Columns window:
  - To first: moves the selected columns so that they are in the left-most position in the data table.
  - To last: moves the selected columns so that they are in the right-most position in the data table.
  - After: moves the selected columns so that they are after a column that you identify.

- **Original Order** returns the columns to the order they were in when data table was last saved.

- **Reorder by Name** arranges the columns from left to right in alphabetical order by column name.

- **Reorder By Data Type** arranges the columns from left to right in alphabetic order by data type (row state, character, numeric).

- **Reorder By Modeling Type** arranges the columns from left to right in alphabetic order by modeling type (continuous, ordinal, nominal). Row state columns have no modeling type, and are shown last.

- **Reverse Order** reverses the order of the data table columns.

**Group Columns**

Group columns within a single heading to manage large numbers of columns and facilitate analysis role assignment. Grouped columns appear in an outline format within the Columns panel.
To group or ungroup columns

1. Within the data grid, select the columns that you want to group.
2. From the main menu, select **Cols > Group Columns** or **Cols > Ungroup Columns**.
   or
1. From the Columns panel, select the columns that you want to group.
2. Right-click on the selected columns and select **Group Columns** or **Ungroup Columns**.

**Note:** Grouped columns are automatically retained for data tables generated from the following commands: **Subset**, **Sort**, **Summary**, **Join**, **Stack**, and **Split**. For the **Stack** command, if all the columns in the stack group belong to the same columns group, then the group’s name is used for the column name.

### Move Values

To move values in a data table, select the values, click and pause, and then drag and drop the values into the new location.

**Tip:** Clicking and dragging on a selection without pausing extends the selection.

When dragging and dropping values, note the following:
- Cells retain all of their characteristics and column properties.
- After you move cells, missing values appear in the cells that you initially selected.
- The selected cells and the destination cells must have the same data type.
- If you drag a set of cells to an empty area of the table, new columns are automatically created.
- New columns have the original columns’ display format and modeling types.

To specify where to move rows

1. Highlight the rows that you want to move.
2. Select **Rows > Move Rows**.
3. Specify where you would like to move the rows in the Move Rows window:
   - To the beginning of the table (**At start**)
   - To the end of the table (**At end**)
   - After a specific row number (**After row:**)
Move Content into Another Window

On Windows, you can drag selected content over a minimized window. The minimized window moves to the front and you can paste your content into it. You can do the same thing in JMP. For example, you can drag selected content over the Home Window button (located in the bottom right corner of most windows). Then in the Window List, drag the content over the window that you want to move the content into. That window moves to the front and you can drop in the content.

Tip: If you cannot see the JMP Home Window button, select View > Status Bars.

For example, you can drag a selected column, row, or cell from one data table into another; drag selected text from one script window into another; or drag selected content from a report into a journal.

Color Cells

You can select one or more data table cells and change the color to highlight a specific value. Right-click the cell or cells, select Color Cells, and select a color. If a color is assigned to a cell, right-click and select Clear Color to remove the color.

Edit or Delete Cells

To edit or delete the contents of a cell, follow these steps:

1. Click the cell containing the value that you want to edit or delete.
2. Press the Delete key.
3. To edit the value, click the cell a second time, and then edit the cell’s value.

Edit Column Names

To edit a column name, select the column and begin typing. You can also edit the column name in the Column Info window, or select the header and press Enter.

Hide and Exclude Rows

Apply Hidden and Excluded row states to rows that you do not want to include in analysis or plot calculations and that you do not want to display in plots. These rows are not included in subsequent analyses. Note the following:

- Plots found under the Graph menu, with the exception of Profilers, are immediately recalculated to reflect hidden and excluded rows.
For many platforms, reports and plots are not updated immediately to reflect excluded and hidden observations. You need to rerun the analysis to recalculate analysis results and the related plots. For exceptions, see “Platforms that Update Immediately for Hide and Exclude” on page 174.

When you Exclude and Hide rows, they are excluded and hidden in all open reports and plots that update automatically.

When you Exclude and Hide rows, a circle with a strikethrough (\(\odot\), for Exclude) and a mask icon (\(\bigcirc\), for Hide) appear beside the row number.

Rows remain hidden and excluded until you highlight the rows and select Hide and Exclude again.

To hide and exclude one or more rows

1. Select the rows that you want to hide and exclude.
2. Do one of the following:
   - Right-click on the highlighted area next to the row numbers and select Hide and Exclude.
   - From the Rows menu, select Hide and Exclude.

Platforms that Update Immediately for Hide and Exclude

When you apply Hide and Exclude to rows, for most platforms under the Analyze menu, points or plot elements that correspond directly to rows are usually hidden immediately in plots. However, calculations shown in accompanying reports usually are not updated. For the following platforms, applying Hide and Exclude results in immediate updates to plots and calculations:

- Tabulate
- Control Chart Builder

Exclude Rows

Apply the Excluded row state to rows that you do not want to include in subsequent calculations. Plots are recalculated without the excluded rows. Note the following:

- In most cases, when a row is represented by a point or an individual plot element, excluding the row does not hide it in plots.
- In Graph Builder, when a plot element is represented by a group of rows, the plot is reconstructed using only the unexcluded rows and does not display plot elements corresponding to the excluded rows. Excluded rows are treated as if they are both hidden and excluded.
• Plots found under the Graph menu, with the exception of Profilers, are immediately recalculated to reflect excluded rows.

• For many platforms, reports and plots are not updated immediately to reflect excluded observations. You need to rerun the analysis to recalculate plots and analysis results.

• When you Exclude rows, they are excluded in all open plots and reports that are updated immediately.

• When you Exclude rows, a circle with a strikethrough (\(\boldsymbol{\cdot}\)) appears beside either the row number.

• Rows remain excluded until you highlight the rows and select **Exclude/Unexclude** again.

*To exclude one or more rows*

1. Select rows that you want to exclude.

2. Do one of the following:
   – Right-click on the highlighted area next to the row numbers and select **Exclude/Unexclude**.
   – From the **Rows** menu, select **Exclude/Unexclude**.

**Hide Rows**

Apply the Hidden row state to rows that you do not want to include in subsequent plots. The plots that are updated when you Hide rows are updated immediately.

**Note:** Not all plots hide the elements that correspond to hidden rows. This is often the case when the calculations used to construct the plot elements use the data from the hidden rows. As a general rule, if there is a one-to-one correspondence between rows and plot elements, the points or elements corresponding to the hidden rows are hidden.

Note the following:

• Hiding rows does not exclude them from calculations and analyses. In particular, plots that are constructed using observations use the data from hidden rows unless those rows are also excluded.

• In most cases, plot elements that are calculated using observations are not updated to reflect hidden observations unless those rows are also excluded.

• When each hidden row corresponds to a point or an individual plot element, plots are updated immediately when you apply the Hidden row state to rows.

• For some plots where plot elements correspond to groups of rows, when you Hide rows, the plot is updated to hide plot elements corresponding to hidden rows. See “Plots Where Grouping Elements are Updated for Hide” on page 176.

• When you Hide rows, they are hidden in all open plots that are updated immediately.
- When you Hide rows, a mask icon ( ) appears beside the row number.
- Rows remain hidden until you highlight the rows and select Hide/Unhide again.

To hide one or more rows

1. Select rows that you want to hide.
2. Do one of the following:
   - Right-click on the highlighted area next to the row numbers and select Hide/Unhide.
   - From the Rows menu, select Hide/Unhide.

Plots Where Grouping Elements are Updated for Hide

When you apply Hide to rows, in plots with a one-to-one correspondence between rows and plot elements, the points or plot elements are usually hidden immediately. However, for the following platforms and options, applying Hide results in immediate updates to plot elements that correspond to groups of rows:

- Control Chart Builder. See the Control Chart Builder chapter in the Quality and Process Methods book for details.
- Graph Builder. The Bar chart, Heat Map, and Pie chart are updated to reflect hidden rows. See the Graph Builder chapter in the Essential Graphing book for details.
- Bubble Plot. See the Bubble Plots chapter in the Essential Graphing book for details.

Exclude Columns

When your data table contains columns that you do not want to consider for analysis, you can exclude those columns so that they do not appear in selection lists in launch windows. Note the following:

- Excluded columns remain visible in the data grid.
- A circle with a strikethrough ( ) appears to the right of the column name in the Columns panel.

To exclude columns from launch windows

1. Select one or more columns that you want to exclude.
2. Do one of the following:
   - Right-click on the highlighted column name in the Columns panel and select Exclude/Unexclude.
   - From the Cols menu, select Exclude/Unexclude.
To unexclude columns

1. Select the columns in the Columns panel.
2. Do one of the following:
   - Right-click on the highlighted column name in the Columns panel and select Exclude/Unexclude.
   - From the Cols menu, select Exclude/Unexclude.

Hide Columns

When your data table contains columns that you do not want to see in the data grid, you can hide those columns. Note the following:

- Hidden columns appear in launch windows and are available for analyses.
- A mask icon (️) appears to the right of the column name in the Columns panel.

To hide columns

1. Select one or more columns that you want to hide.
2. Do one of the following:
   - Right-click on the highlighted column name in the Columns panel and select Hide/Unhide.
   - From the Cols menu, select Hide/Unhide.

To unhide columns

1. Select the columns in the Columns panel.
2. Do one of the following:
   - Right-click on the highlighted column name in the Columns panel and select Hide/Unhide.
   - From the Cols menu, select Hide/Unhide.

View Patterns of Missing Data

If your data table contains missing data, you might want to determine whether there is a pattern to the missing data. The pattern might help you make discoveries about your data.

To view patterns of missing data

1. With your data table open, select Tables > Missing Data Pattern.
2. Select the columns for which you would like to find patterns of missing data.
3. Click Add Columns.
4. Select the **Count Missing Value Codes** check box if you want to count missing value codes as missing values.

5. Click OK.

**Example of Viewing Patterns of Missing Data**

1. Select **Help > Sample Data Library** and open Missing Data Pattern.jmp.
2. Select **Tables > Missing Data Pattern**.

**Figure 4.16** The Missing Data Pattern Window

3. Highlight all of the columns.

   **Note:** For details about the options in the red triangle menu, see “**Column Filter Menu**” on page 51 in the “Get Started” chapter.

4. Click **Add Columns**.
5. Click **OK**.

**Figure 4.17** A Missing Data Pattern Table

   **Tip:** To quickly create a Treemap or Cell Plot of the data, click the green triangle next to the Treemap or Cell Plot script in the table panel.
Figure 4.17 shows the following patterns:

- Row 1 shows that there are two instances where all rows in Trial 1, Trial 2, Trial 3, and Trial 4 have no missing values.
- Row 2 shows that there are two rows in the source table whose one missing value is in the Trial 4 column.
- Row 3 shows that there are two rows in the source table whose missing values are in the Trial 3 and Trial 4 columns.
- Row 4 shows that there is one row in the source table whose three missing values are in the Trial 2, Trial 3, and Trial 4 columns.

The Count column is assigned the frequency role. If you now use the Missing Data Pattern data table to run an analysis, JMP automatically uses Count as a frequency. For details, see “Assign a Preselected Analysis Role” on page 260 in the “The Column Info Window” chapter.

**Find and Replace Cell Values**

You can find and replace cell values by selecting the **Edit > Search > Find** options.

**Figure 4.18  The Find Window**

The following rules apply to searching for values:

- To find values in hidden columns, unhide the column.
- Values found in locked columns cannot be modified.
- The **Undo** command works only with **Replace**. You cannot undo **Replace All**.
- If your data table contains value labels, using the **Search** commands searches for actual values, but does not search for labels. See “Value Labels” on page 238 in the “The Column Info Window” chapter.
- If your data table contains formatted values (such as dates, times, or durations) using the **Search** command searches for the formatted values, not the actual values.
Find Window Options

Refine your search with the following options:

**Match Case**  Performs a case sensitive search, which can be useful for locating proper nouns or other capitalized words.

**Match entire cell value**  Detects empty spaces, which lets you search for a series of words in a character column, or locate strings with unwanted leading or trailing empty spaces.

**Tip:** To find missing character values, leave the **Find what** box empty and check **Match entire cell value**. To find missing numeric values, insert a period into the **Find** box and check **Match entire cell value**.

**Use regular expressions**  Assumes the find string to be a regular expression instead of the literal string that you enter in the **Find what** box. The regular expressions follow standard semantics.

**Restrict to selected rows**  Restricts the search to selected rows.

**Restrict to selected columns**  Restricts the search to selected columns.

**Search data**  Searches only data cells (omitting column names).

**Search column names**  Searches only column names (omitting data cells).

**By column**  Searches the table column by column, from top to bottom, until it reaches the last cell in the rightmost column, or until you stop the search.

**By row**  Searches the data table row by row from left to right, to the rightmost cell in the last row or until you stop the search.

**Multiple lines**  Increases the Find and Replace boxes to 3 lines long instead of 1. The Enter key inserts a return into the field.

**Tip:** You can alternatively click and drag on the Find and Replace boxes to make them larger. If you copy and paste, the boxes resize to 1 line long, but all of your text is still there.

**Keep dialog open**  Keeps the Find window open during your search.

Search Actions

This section describes some common searches that you might perform.

Begin by searching for a value in the data table. The search begins with the first cell in the first column and searches every cell until it locates the value or reaches the end of the table.
To replace the currently highlighted cell value

Enter a value in the Replace with box and click Replace. Or, if the Search window is closed, select Edit > Search > Replace. If the replace value is a missing value, the currently highlighted cell content becomes a missing value.

To replace all occurrences of the specified value

Enter a value in the Replace with box and click Replace All. Or, if the Search window is closed, select Edit > Search > Replace All.

To replace the value and search for the next value

Enter a value in the Replace with box and click Replace. Or, if the Search window is closed, select Edit > Search > Replace and Find Next. Or, press CTRL-L.

To use a selected value as the Find what value

In the data table, select a value. Select Edit > Search > Use Selection for Find. Next, select Edit > Search > Find. The value that you selected in the data table is already entered in the Find what field.

To use a selected value as the Replace with value

In the data table, select a value. Select Edit > Search > Use Selection for Replace to populate the Replace with field.

To find the next value when the Search window is closed

Select Edit > Search > Find Next. Or, press CTRL-G, or F3 on Windows.

To find a missing value:

- To find missing character values, leave the Find what field empty and select Match entire cell value.
- To find missing numeric values, type a period into the Find what text box.

Use the Row Editor to Edit Cells in a Row

Use the Row Editor to browse or edit cells one row at a time. Open the Row Editor in one of the following ways:

- Select Rows > Row Editor.
- In a data table, double-click in the row number area. The row that you use is the row that first appears in the Row Editor.
- In a report window, right-click in a plot or graph and select Row Editor.
Enter and Edit Data
Organize Data

Chapter 4
Using JMP

Figure 4.19  Row Editor

Note the following:

• If you have a report window open, and you want edited data to be automatically reflected there, make sure that Automatic Recalc is turned on. See “Automatic Recalc” on page 354 in the “JMP Reports” chapter.

• If your data table contains value labels, the Row Editor displays the label, and when the cell is highlighted for editing, it shows the actual value. See “Value Labels” on page 238 in the “The Column Info Window” chapter.

Row Editor Buttons

Click the arrow buttons to browse through selected rows or the entire data set if no rows are selected. Row Editor buttons are described as follows:

- Shows the previous row.
- Shows the previously selected row.
- Makes the row blink in graphs.
- Shows the next selected row.
- Shows the next row.
- Searches for a row. See “Select Cells” on page 168.
- Creates a new row at the end of the data table.

Note: Changes made to a row using the Row Editor are written to the data table when you change fields in the Row Editor. You still need to save the changes to the data table.

Row Editor Options

The red triangle menu in the Row Editor contains the following options:

Next Selected  displays information for the selected row that is located after the current one.

Prev Selected  displays information for the selected row that is located before the current one.

Next  displays information for the row that is located after the current one, regardless of whether the row is selected.
Prev  displays information for the row that is located before the current one, regardless of whether the row is selected.

Save  saves the data table and any changes that you have made to it via the Row Editor.

New Row  creates a new row in the data table.

Find  displays the same window as if you had selected Rows > Row Selection > Select Where. Select one of the options from the Current Selection menu, and then highlight the column whose rows you want to select. Type in the value for which you want JMP to search. See “Select Cells” on page 168.

Blink  causes the current row’s highlight to flash at a rapid rate.

Note: Text in a locked column or a locked data table cannot be edited. For details, see “Lock” on page 224 in the “The Column Info Window” chapter and “Lock Tables” on page 216.

Context Menus for Rows and Columns

When you right-click in the row number area, or at the top of a column in the column name area, context menus appear. These menus provide quick access to selected commands in the Rows and Columns menus. For details about these options, see “Context Menu for Columns” on page 43 in the “Get Started” chapter and “Context Menu for Rows” on page 44 in the “Get Started” chapter.

Compare Data Tables

JMP can compare two open data tables and report the differences between data, scripts, table variables, column names, column properties, and column attributes. Character values that do not match exactly appear in the report. For numeric data, you can select a relative (or fuzzy) comparison. The numeric values are considered equal if they are within the relative error rate that you specify. The smaller the relative error, the more precise the comparison.

To compare two data tables

1. Open the data tables.
2. In one of the tables, select Tables > Compare Data Tables.
3. If necessary, select the data table that you want to compare from the list.
4. (Optional) Select Fuzzy Compare and enter the relative error to see numeric differences within the specified rate.
5. Click on the red triangle menu and select the following options:
   – which items you want to compare
   – how to show the differences
6. Click **Compare**.

The Difference Summary and Difference Plot are shown by default. The red triangle options that you selected also appear.

**Basic Table Information**

The Tables Info report shows the data table names and locations along with the numbers of columns and rows in each table. In Figure 4.20, you see that **Big Class1.jmp** contains one more row than **Big Class2.jmp**.

**Figure 4.20** Basic Information

![Tables Info](image)

**Compare Data**

The interactive Difference Summary report and Different Plot indicate how rows differ between reports. Each entry in the Difference Summary report shows which action occurred, how many rows are affected, and the first row in which the change occurs.

In Figure 4.21, **Big Class1.jmp** (left) and **Big Class2.jmp** (right) are compared.

- The first entry in Figure 4.21 indicates that one row (N) has changed (or been replaced) in the first row of **Big Class2.jmp**. When you select the entry in the Difference Summary report on the left, the entry is highlighted in yellow, and the row flashes in the data table. For a graphical view of the comparison, place your cursor over a colored cell in the Difference Plot. Figure 4.21 shows that the name KATIE in **Big Class1.jmp** was changed to KIM in **Big Class2.jmp**. The entire first row is highlighted in the Difference Plot, which tells you that all values in that row are different.
Figure 4.21 Modified Data

In Figure 4.22, the second entry indicates that two rows were deleted beginning at row four. The deleted rows are highlighted in Big Class1.jmp on the left. And the Difference Plot specifies the different values. The name in row four of Big Class1.jmp was JACLYN and TIM in Big Class2.jmp.

Figure 4.22 Deleted Rows

In Figure 4.23, the third entry tells you that one row was added before what was originally row eight. The name in row eight of Big Class1.jmp was ROBERT. PETER is the name in row six of Big Class2.jmp.
Figure 4.23 Identify New Rows

Click the Previous difference and Next difference buttons above the Difference Summary to navigate from row to row.

Tip: Save the Difference Summary report to a data table by selecting Save Difference Summary from the red triangle menu.

Compare Table Properties

Select Compare Table Properties from the red triangle menu to see differences in table scripts and variables. For example, Figure 4.24 shows that the Distribution script in Big Class2.jmp refers to the height column rather than the weight column.

Figure 4.24 Modified Table Script

Compare Column Attributes and Properties

Select Compare Column Attributes and Properties from the red triangle menu to see differences in column notes, cell colors, and the like. For example, Figure 4.25 shows that column notes and value colors differ in Big Class2.jmp.
Assign Characteristics to Rows and Columns

This section describes how to exclude, hide, label, color, or mark rows and columns in order to customize the appearance of points in scatterplots and graphs. You can also lock columns so that they stay in place when you scroll through the data table.

The menu for row actions can be accessed from the following places:

- the **Rows** menu in the main menu
- right-click on a row
- the red triangle in the Rows panel
- the left red triangle in the upper left corner of the data grid

Similarly, the menu for columns actions can be accessed from the following places:

- the **Cols** menu in the main menu
- right-click on a column
- the red triangle in the Columns panel
- the right red triangle in the upper left corner of the data grid
Label Rows and Columns

When you position the arrow cursor over a point in a plot, the point’s label appears. By default, row numbers are used as labels. You can customize the labels as follows:

- You can change the label to display column values instead of the row number.
- You can enable the label to always appear, not only when you position the cursor over points.
- A label or yellow tag icon ((Materials) appears beside the column name in the Columns panel, indicating that points on plots are identified by the column value. If there are multiple columns that are labeled, their values appear on plots separated by a comma.
- Data remain labeled until you select Label/Unlabel again.

To change the label to display column values
1. Highlight one or more columns whose values you want to appear as the label in plots.
2. Select Cols > Label/Unlabel from the menu or right-click and select Label/Unlabel.

To enable the label to always appear (not just when you position the cursor over points)
1. Highlight one or more rows whose label you want to always appear in plots.
2. Select Rows > Label/Unlabel from the menu.

To turn off labeling for rows or columns
1. Highlight the labeled rows or columns that you no longer want labeled.
2. Select Label/Unlabel from the Rows menu or Cols menu. You can also right-click columns or rows and select Label/Unlabel.

Tip: A photo can be displayed in the label when you place your cursor over data. For example, the SAS Offices.jmp sample data table contains an Expression column that is labeled. A photo of each office is stored in the column. When you place your cursor over a data point on the map, the photo for that row appears. See “Expression Role” on page 254 in the “The Column Info Window” chapter for details.

Assign Colors or Markers to Rows

- If you assign a color to a row, the points representing the values in that row are colored in the plot.
- If you assign a marker to a row, the point is replaced with the marker in the plot.
- You can also assign colors or markers based on column values.
Assign a Color to Rows

Assigning a color to selected rows means that the points in plots appear in the color that you select. In the data grid, the active color assigned to a row appears next to the row number.

To assign rows a color
1. Highlight one or more rows that you want to assign a color to.
2. Right-click on the highlighted rows and select Rows > Colors.
3. Select one of the available colors.

Tip: To clear an assigned color from the selected rows, assign the color black.

Add Markers to Rows

To replace the standard points in plots with a marker, use the JMP markers palette. In the data table, these markers also appear next to row numbers.

1. Highlight one or more rows that you want to apply the marker to.
2. Right-click on the selected rows and select Markers, and then select the marker shape.
   - Select Other to create custom markers. You can type alphabetic characters, numerals, and other keyboard symbols.

Tip: To return to the default marker, select the initial dot marker.

Assign Colors or Markers to Rows Based on Column Values

You can assign colors or markers to your data table rows based on the values found in a particular column. For example, in a column called Sex, you could assign all rows whose value is F a red circle marker. All rows whose value is M could have a green plus marker. These colors and markers replace the default black dot in plots and appear next to its row number in the data table.

To assign colors or markers to rows based on column values
1. Select Rows > Color or Mark by Column.
2. Select the column to color and or mark. See Figure 4.26.
Enter and Edit Data  
Assign Characteristics to Rows and Columns  

Chapter 4  
Using JMP

Figure 4.26 Color or Mark by Column

3. Select the Colors and Markers schemes to apply.  
   A preview of your selection appears under Row States.

4. (Optional) Select any additional options. See “Color or Mark by Column Options” on page 190.

5. Click OK.

6. (Optional) To shade all rows according to their row state, right-click in the row numbers area within the data grid and select Color Rows by Row State.
   From then on, the rows are shaded with the color that you assign to the rows.

Color or Mark by Column Options

Colors select a color theme to assign different colors to the rows in your data table. Color assignment is based on the values of the selected column.

Continuous Scale assigns colors in a chromatic sequence based on the values in the highlighted column.

Reverse Scale assigns colors in a reversed chromatic sequence based on the values in the highlighted column.

Markers assigns a different marker to each row in your data table based on the values found in the column that you highlighted.

Make Window with Legend Includes a legend with your new characteristics so that you can easily identify which colors and markers correspond with which row.

Save To Column Property saves the color and marker information as a column property. The rows in the selected column of the data table are colored, based on the color theme.

Save To Table Property saves the color and marker information as a table property.

Excluded Rows assigns colors or markers to rows that are excluded.
Create Color Themes

JMP includes several color themes that can distinguish a range of values in a graph. You can also create your own color themes based on an existing color theme or create custom themes.

Note: When you select a default color theme, the colors are not applied to reports that are open. You need to rerun the existing reports to format them with the default color theme.

See “Delete Custom Color Themes” on page 195 for details about deleting custom color themes.

To create a color theme

1. Select File > Preferences > Graphs.
2. To either create a new Continuous Color Theme or Categorical Color Theme, click the appropriate color theme.
   If you are creating a new continuous color theme, the Continuous Color Themes window appears.

Figure 4.27  Continuous Color Themes Window

If you selected to create a new categorical color theme, the Categorical Color Themes window appears.
3. (Optional) To base the theme on an existing theme, select a color theme from the available themes.

4. Click the Custom Color Theme disclosure button to show the Custom Color Theme panel. Figure 4.29 shows the color theme panels for both continuous and categorical themes (respectively).

5. Click New to create a new theme.
   A new color theme is created based on the selected color theme. A temporary name is assigned to the theme.

6. Type a new name in place of the temporary label. On Windows, do not press Enter. The window closes if you do so.

7. To modify the color theme, do any of the following:
   - To modify the gradient of continuous color, move the sliders left or right.
   - To add more colors to the gradient, click the color bar to choose a color. A new slider is displayed under the color bar.
Using JMP Assign Characteristics to Rows and Columns

1. To change the color of a slider, click on the slider to display the Color window and choose another color.
2. To reverse the order of the colors on the gradient, click **Reverse**.
3. To distribute the colors evenly on the gradient, click **Space Evenly**.
4. To list the custom theme in the Sequential pane, select **Sequential** from the list.
5. To list the custom theme in the Diverging pane, select **Diverging** from the list.
6. To list the custom theme in the Chromatic pane, select **Chromatic** from the list.
7. To prevent a theme from appearing in lists of color themes, select **Hidden**.
8. To remove a color from the color theme, click the color’s slider and drag the slider above or below the color bar.
9. To discard your changes, click **Cancel**.

8. Click **Save** to save the custom color theme.

The new custom color theme is appended to the contents of the selected pane.

9. Click **OK** to close the color theme window.

**Continuous and Categorical Color Themes**

The following figure shows examples of the two types of color themes in JMP, continuous and categorical. When a color theme is selected for continuous data, the colors are graduated (as shown on the left). When the same color theme is selected for categorical data, the color consists of distinct blocks of color. (as shown on the right).

**Figure 4.30 Examples of Continuous and Categorical Color Themes**
Custom Color Themes

Custom color themes can be applied in the same way as built-in color themes:

- You can select custom color themes as defaults from the **Continuous Color Theme** and **Categorical Color Theme** drop-down menus in the Graphs preferences. Only continuous color themes are available for continuous data. All color themes are available for categorical data.
- You can apply the custom color themes to components such as markers and data table rows. See “Assign Colors or Markers to Rows Based on Column Values” on page 189 for details.
- In certain reports, such as treemaps and surface plots, you can select specific custom color themes. See the *Essential Graphing* book for details.

Use Custom Color Themes on Multiple Computers

In Windows, the color themes that you create are defined in the JMP preferences file called JMP.PFS. If you use JMP on more than one computer (for example, at home and at work), you can copy the color theme definitions from one JMP preferences file to another. Custom colors are then available on both computers.

In the preferences file, the code for a custom color theme looks like this:

```
Add Color Theme(
    {"Pink to Blue", {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}}}
),
```

In this example, the name of the color theme is “Pink to Blue.” The Red/Green/Blue (RGB) values for each color slider are located in brackets. The first slider defines the RGB values 255, 168, and 255. The second and third groups of brackets define colors for the second and third sliders.

In a text editor (such as Microsoft Notepad) add this color theme to the preferences file on your other computer. The preferences file is located in your Users folder within the JMP or JMPPro folder.

- C:/Users/<user_name>/AppData/Roaming/SAS/JMP/13
- C:/Users/<user_name>/AppData/Roaming/SAS/JMPPro/13
- C:/Users/<user_name>/AppData/Roaming/SAS/JMPSW/13

**Note:** To see the preceding folders, you must configure Windows Explorer to show hidden files and folders. For details, refer to the Windows help.

To transfer color themes to another Windows computer

1. On the computer that contains the customized JMP preferences, select **File > New > Script.**
The Script window appears.

2. Type the following JSL function:
   
   ```jsl
   Show Preferences();
   ```

3. Click **Run Script**.

   Your customized preferences are written to the log.

4. Select **View > Log** (or display the open log).

   The custom color theme that you created appears, for example:

   ```jsl
   Add Color Theme(
   "Pink to Blue", {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}}
   ),
   ```

   This definition might be in the middle of other customized preferences that appear in the log.

5. Save the log as **Log.jsl** and open the file on the computer whose preferences you are updating.

6. On the computer whose preferences you are updating, close JMP.

7. Make a backup of **JMP.PFS**, and then open the original **JMP.PFS** in a text editor.

8. Copy and paste the custom color definition from **Log.jsl** to **JMP.PFS**. The definition goes after **Preferences(** as shown in the following example:

   ```jsl
   Preferences(
   Add Color Theme(
   "Pink to Blue", {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}}
   ),
   );
   ```

   **Note:** Be sure to include the closing parenthesis and comma. The code does not need to be indented. You can put the code in any valid location. Pasting it after **Preferences(** helps ensure that you do not delete any necessary parentheses or commas.

9. Save the file.

   If you open JMP and the new color definition is not displayed in the preferences, delete the updated preferences file and add the definition to the original preferences file. Make sure that you copy and paste the definition in the correct location.

**Delete Custom Color Themes**

1. Select **File > Preferences > Graphs**.
2. To either delete a color theme, select either the Continuous or Categorical Color Theme.

   The relevant Color Themes window appears.

3. Click the Custom Color Theme disclosure button to show the Custom Color Theme panel.
4. From the appropriate pane, select the custom color to delete.

   Note: You can delete only custom color themes.

5. Click Delete.
6. Click OK to save your changes and close the Color Themes window.

Delete Row Characteristics

To clear all row states in the data table, select Rows > Clear Row States. To clear row states only in selected rows, select Rows > Clear Selected Row States.

All rows become included, visible, unlabeled, and show in plots as black dots. The Clear Row States command does not affect row states saved in row state columns.

Lock Columns in Place

You can lock a column in place so that when you scroll horizontally, the column remains visible. Highlight the columns and select Cols > Scroll Lock/Unlock. Note the following:

• Hidden columns cannot be scroll locked.
• The name of a locked column appears in italics in the Columns panel.
• Scroll locked columns are moved to the left in the data grid. Once you unlock them, they are not moved back to their original locations in the data table, but remain on the left.
• Columns remain scroll locked until you highlight the columns and select Scroll Lock/Unlock again.

Restructure Data

This section describes how to restructure and reformat your data. Change your data by using either the Utilities menu options, creating a new formula column, or by creating a temporary transform column.

To restructure a column or multiple columns, select Cols > Utilities and choose from the list of options. At least one column must be selected to enable these menu options.

Make a Column into Multiple Columns

Use the Text to Columns option to make a character column with delimited fields into multiple columns. Highlight a column from a data table and select Cols > Utilities > Text to Columns. The maximum number of delimited fields across all rows determines the number of new columns created.
Note: Text to Columns is case-sensitive.

The Text to Columns window has the following options:

**Delimiter** Specify text, such as a comma, to indicate how the data in the source column is organized into new columns. For example, if the original cell reads “NY, NJ, PA,” and the delimiter is a comma, three new columns are created that contain “NY”, “NJ”, and “PA”.

**Make Indicator Columns** Makes new columns that are named after the distinct fields in the source column with cell values of either 0 or 1.

**Include Missing** Allows any empty rows to be counted as a category. An additional column named Missing is added to the data table. A value of 1 indicates an empty row.

**Make Indicator Columns**

Convert a categorical column into multiple indicator columns based on each distinct category. The columns are named after each level in the column. For example, when you make an indicator column from sex in Big Class.jmp, the indicator columns are named F and M.

Highlight a column in a data table and select Cols > Utilities > Make Indicator Columns. You can then indicate whether you want to prepend the original column name to the indicator column names (as in sex_F and sex_M) and include missing values.

Multiple columns with values of either 0 or 1 are created. A value of 1 indicates that the original column contains that specific category.

If the given column has the Multiple Response modeling type or Multiple Response column property, the categories are determined from the set of responses.

**Combine Columns**

The Combine Columns option is the opposite of Text to Columns. Instead of making multiple columns, you can combine a set of columns into one character column with delimited fields.

To combine indicator columns, follow these steps:

1. Select Help > Sample Data Library and open Consumer Preferences.jmp.
2. Select the columns, Floss After Waking Up, Floss After Meal, and Floss Before Sleep.
4. Type “Combined Floss” for the column name, and keep the default delimiter as a comma.
5. Select Selected Columns are Indicator Columns and click OK.
The selected columns are represented in the Combined Floss column with each field separated by a comma. Only the columns that have a value of 1 are represented in the combined column for each given row.

Note: Value labels show a label in the data table instead of a value. A label appears for each instance of the value in the combined column. You can show the original values by double-clicking a label within a cell. To avoid using value labels, select **No Value Labels** when you combine the columns.

### Compress Selected Columns

JMP lets you compress columns in a data table to minimize the size of the file and reduce the amount of memory required to analyze data. This feature is helpful when numeric columns contain many small integers or when any column contains fewer than 255 unique values. For example, compressing columns in a data table with 389 columns and 85,000 rows might decrease the file size from 250MB to 33MB, depending on the type of data. When you compress columns, JMP verifies whether the data can be stored in a more compact form based on the data type:

- In character columns with fewer than 255 unique values, the List Check property is added to the column where appropriate (shown in Figure 4.32).

The List Check property restricts the values in the selected column to valid values. The List Check property is not applied when the number of values in the selected column is too great. For example, if the number of values is almost the same as the number of rows, the data table does not add the List Check property to the column.
For numeric columns, only those with the Best, Fixed Dec, or Data format are compressed. Data is compressed to 1-byte, 2-byte, or 4-byte integers when possible (shown in Figure 4.33). For details about short integers, see “The Short-Integer Format” on page 227 in the “The Column Info Window” chapter.

A numeric column with non-integer values can also be compressed if there are fewer than 255 unique values. In this case, the List Check property is added to the column.

Caution: In a column with the List Check property, you can enter only a value that is in the list. Otherwise, JMP warns that the cell contains invalid data when you try to enter the new value. For details, see “List Check” on page 237.

To compress columns, select one or more columns and select Cols > Utilities > Compress Selected Columns. (Select all columns if you do not know which columns can be compressed.)

The column or columns are compressed if possible. The log shows which columns were compressed and how they were compressed. (Select View > Log to show the log.)
Note: To compress a numeric column manually, set your Tables preferences to allow short numeric data and then change the column’s data type to 1-byte integer, 2-byte integer, or 4-byte integer. For details about this preference, see “Tables” on page 506 in the “JMP Preferences” chapter.

Make Binning Formula

You can distribute your data into equal width bins using the Make Binning Formula option. Select the column or columns that you want to divide into bins, and select Cols > Utilities > Make Binning Formula. New formula columns are added to the data table.

The Make Binning Formula window contains the following options:

Format  Select a format for displaying the range of values in the bin. You can see a preview by moving the cursor over the graph.

Bin Shape: Offset  Select an offset value for the lower edge of the bins.

Note: Bins are identified by their lower edge. The lower edge is in the bin. The upper edge is in the next bin because it is the next bin’s lower edge.

Bin Shape: Width  Select the width of values for the bins.

Note: The colored bands reflect the offset and the width of the bins with respect to the data.

Labels  Specify whether value labels are shown instead of the data values.

Select Use Value Labels to show a label instead of the value.

Select Use Range Values to include the lower and upper values for each range in the label.

Select No Labels to use the lower edge value as the label.

For more information, see “Value Labels” on page 238 in the “The Column Info Window” chapter.

Tip: Value Labels are recommended in most platforms, many of which do not support range labels. In the Categorical platform, you must use value labels. On some axes, you might find that range labels more clearly identify the values.

Make All Like X  (Appears only if multiple columns are selected) Applies the choices made for the first column (X) to the remaining columns.

Make Formula Columns  Creates the formula columns and closes the window.
Example of Making a Binning Formula

1. Select Help > Sample Data Library and open Big Class.jmp.
2. Select the height column.
3. Select Cols > Utilities > Make Binning Formula.
   You want the range of values to appear as X-X, so keep the range set to Low - High.
4. Change the offset to -0.5.

   **Tip:** For integer data, setting the offset to -0.5 helps disambiguate values on the edge. In this example, one of the bins covers 59.5 to 64.5, so it is clear that 59 and 65 are not included in this bin.
5. Keep the width set to 5.
6. For the labels, keep it set to Use Value Labels, so that you can see the range of values for the bin.

**Figure 4.34** Completed Binning Window

7. Click Make Formula Columns.
   A column called height Binned is added to the Big Class.jmp data table.
8. To see how the formula is calculated, right-click on the height Binned column and select Formula.

**Figure 4.35** Formula
Make a New Formula Column

To perform further analyses on your data, use the New Formula Column menu options from your existing data table. Formula columns use formulas or calculations to define column values.

Right-click a column heading in your data table and select **New Formula Column**. Choose from Transform, Character, Combine, Aggregate, Distributional, Date Time, or Row to calculate column values. A new formula column is added to the data table. See “Transform Columns” on page 202 for a description of these options.

**Note:** The same options exist in both the New Formula Column menu, and the right-click column menu in the launch window. However, performing these tasks in a launch window results in a temporary column, and New Formula Column adds a new column to the original data table.

Right-click options depend on the selected column’s data type and the number of columns selected. If the selected column is a Character column, Character and Row options appear. See “Character Menu” on page 208 and “Row Menu” on page 208 for more information.

**Transform Columns**

Each launch window in JMP enables you to create one or more temporary transform columns for use in performing analyses. These transform columns are not part of the source data table and only can be used within the context of the current launch window. Transform columns use formulas or calculations to define the column values. Closing the launch window or the generated report deletes any transform columns.

Each column listed in the Select Columns pane of the launch window includes an icon representing the column’s modeling type (continuous, ordinal, or nominal) and the column name. Right-click on a column name to create a transform column using Transform, Character, Combine, Aggregate, Distributional, Date Time, Row, or Formula to calculate the column’s values.

Right-click options depend on the selected column’s data type and number of columns selected.
Group By  For ordinal and nominal data, specifies the column to use for grouping data. A separate analysis is computed for each level of the specified column.

Notes:

- The transform column is available only in the current launch window. To make the transform column available outside of the current launch window, right-click the transform column and select Add to Data Table. The transform column is added to the source data table.

- You can paste a transform column into a Roles box on the launch window. For example, you might copy a transform column from a script. Right-click in the appropriate launch window Cast Selected Columns into Roles box and select Paste. This is an alternative to right-clicking the column in the Select Columns list, selecting the transform, and adding the transform column to a role.
Transform Menu

Select a function from the Transform menu to create a transform column containing the calculations based on the selected function. For details, see the Scripting Index in the Help menu or the Model Specification chapter in the *Fitting Linear Models*.

**Note:** You can apply unary functions to multiple columns resulting in multiple transform columns.

**Table 4.2** Descriptions of the Transform Menu Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Square Root</td>
<td>Takes the square root of the values of the selected column.</td>
</tr>
<tr>
<td>Square</td>
<td>Calculates the square for the selected column values.</td>
</tr>
<tr>
<td>Log</td>
<td>Applies the natural logarithm transformation to the selected column.</td>
</tr>
<tr>
<td>Exp</td>
<td>Applies the exponential transformation to the selected column.</td>
</tr>
<tr>
<td>Log10</td>
<td>Applies the base-10 logarithm transformation to the selected column.</td>
</tr>
<tr>
<td>Pow10</td>
<td>Calculates 10 raised to the power of the selected column values.</td>
</tr>
<tr>
<td>Cube Root</td>
<td>Calculates the cube root for the selected column values.</td>
</tr>
<tr>
<td>Cube</td>
<td>Calculates the cube for the selected column values.</td>
</tr>
<tr>
<td>Reciprocal</td>
<td>Calculates the reciprocal (1/column) for the selected column values.</td>
</tr>
<tr>
<td>Absolute Value</td>
<td>Calculates the absolute value for the selected column values.</td>
</tr>
<tr>
<td>Negation</td>
<td>Calculates the negative for the selected column values.</td>
</tr>
<tr>
<td>Arrhenius</td>
<td>Applies the Arrhenius transformation to the variable T (temperature in degrees Centigrade):</td>
</tr>
<tr>
<td></td>
<td>[ X = \frac{11605}{T + 273.15} ]</td>
</tr>
<tr>
<td></td>
<td>This is the component of the Arrhenius relationship that is multiplied by the activation energy.</td>
</tr>
<tr>
<td>Arrhenius Inverse</td>
<td>Applies the inverse of the Arrhenius transformation to the variable X:</td>
</tr>
<tr>
<td></td>
<td>[ T = \frac{11605}{X} - 273.15 ]</td>
</tr>
</tbody>
</table>
Combine Menu

Select multiple columns to access the Combine menu. The Combine menu creates a transform column containing the calculations based on the selected function. For details, see the Scripting Index in the Help menu.

The following functions are included in the menu:

**Sum**  Calculates the sum of the first and second columns (A + B).

**Difference**  Calculates the difference between the first and second columns (A - B).

**Difference (reverse order)**  Calculates the difference between the second and first columns (B - A).

**Product**  Calculates the product of the first and second columns (A X B).

**Ratio**  Calculates the ratio of the first column to the second column (A / B).
**Ratio (reverse order)**  Calculates the ratio of the second column to the first column (B / A).

**Minimum**  Returns the minimum value of the selected columns.

**Maximum**  Returns the maximum value of the selected columns.

**Average**  Returns the average value of the selected columns.

### Aggregate Menu

Select a function from the Aggregate menu to create a transform column containing the statistics calculated from the selected column (or part of a column if you specified a Group By column). For details, see the Scripting Index in the Help menu.

**Note:** The **Group By** option is useful for these functions.

The following functions are included in the menu:

- **Mean**  Returns the average value of the selected column.
- **Sum**  Calculates the sum of the values in the selected column.
- **Count**  Calculates the number of values in the selected column.
- **Median**  Calculates the median value for the selected column.
- **Quantile**  Calculates the quantile of the specified percentage for the selected column.
- **Minimum**  Returns the minimum value of the selected column.
- **Maximum**  Returns the maximum value of the selected column.
- **Standard Deviation**  Calculates the standard deviation of the values in the selected column.

### Distributional Menu

Select a function from the Distributional menu to create a transform column containing the statistics calculated from the selected column. For details, see the Scripting Index in the Help menu.

The following functions are included in the menu:

- **Center**  Subtracts the column mean from each value across all rows of the selected column.
- **Standardize**  Calculates the column mean divided by the standard deviation across all rows of the selected column.
- **Range 0 to 1**  Scales the data up or down so that the minimum value is greater or equal to 0, and the maximum value is less than or equal to 1.
- **Box Cox**  Transforms the data using the Box-Cox equation. For details, see the Standard Least Squares chapter in the *Fitting Linear Models*. 
**Johnson Normalizing**  Transforms the data using one of the Johnson equations. The new column name indicates either Johnson Su, Johnson Sb, or None, depending on which equation was used to calculate the new data.

**Informative Missing**  Creates two columns. The informative column replaces missing values with the column mean. The Is Missing column indicates 1 for missing values, and 0 otherwise.

**Date Time Menu**

For column values containing date or time values, select a function from the Date Time menu to create a transform column containing values calculated from the selected column. For details, see the Scripting Index in the Help menu.

The following functions are included in the menu:

- **Day**  Returns the day of the month for the date in the selected column.
- **Month**  Returns the month number for the date in the selected column.
- **Month Abbr.**  Returns the abbreviated month for the date in the selected column.
- **Year**  Returns the year for the date in the selected column.
- **Month Year**  Returns the month number and year for the date in the selected column.
- **Quarter**  Returns the year’s quarter (1, 2, 3, or 4) for the date in the selected column.
- **Week**  Returns the number of the week in the year for the date in the selected column.
- **Year Quarter**  Returns the year and the year’s quarter (1, 2, 3, or 4) for the date in the selected column.
- **Year Week**  Returns a string representing the ISO-8601 week of year format (for example, June 12, 2013 results in “2013W24”).
- **Day of Year**  Returns the day of the year for the date in the selected column.
- **Day of Week**  Returns the day of the week for the date in the selected column.
- **Day of Week Abbr.**  Returns the abbreviated day of the week for the date in the selected column.
- **Date**  Returns the month, day, and year for the date in the selected column.
- **Time of Day**  Returns the time for the date in the selected column.
- **Hour**  Returns the hour part of the date in the selected column.
- **Minute**  Returns the minute part of the date in the selected column.
- **Second**  Returns the seconds part of the date in the selected column.
Character Menu

Select a function from the Character menu to create a transform column containing strings formed by the selected Character function. For details, see the Scripting Index in the Help menu.

The following functions are included in the menu:

- **Length**  Calculates the number of characters in each string in the selected column or columns.
- **Concatenate**  Concatenates the strings in the selected column or columns into a new string.
- **Concatenate with Space**  Concatenates the strings in the selected column or columns into a new string with each sub-string separated by a whitespace.
- **Concatenate with Comma**  Concatenates the strings in the selected column or columns into a new string with each sub-string separated by a comma character.
- **First Word**  Extracts the first word from a character string in the selected column or columns.
- **Last Word**  Extracts the last word from a character string in the selected column or columns.

Row Menu

Select a function from the Row menu to create a transform column containing calculations determined by the selected Row function. For details, see the Scripting Index in the Help menu.

In addition to the functions described in the appendix, the following functions are included in the menu:

- **Row**  Returns or sets the current row number.
- **Selected**  Returns or sets the selected index.
- **Random Uniform**  Generates random numbers uniformly between 0 and 1.
- **Random Normal**  Generates random numbers that approximate a normal distribution based on the mean and standard deviation of the column or columns selected. The covariance between the two values is zero.
- **Sample without Replacement**  Shuffles the values randomly each time it’s evaluated. The result for the first value does not affect the result for the second value. The covariance between the two values is not zero.
- **Sample with Replacement**  Generates a random integer. The result for the first value affects the result for the second value. The covariance between the two values is zero.
- **Difference**  Calculates the difference of each value in the selected column using the formula:
Note: The Difference function also supports the Group By option.

Lag  Returns the value in the previous row for the selected column.

Lag Multiple  Returns the values from multiple rows for the selected column.

Cumulative Sum  Calculates the cumulative sum for each value in the selected column using the formula:

\[
\begin{align*}
\text{IF} & \text{ Row( ) == 1} \\
& \Rightarrow 0 \\
\text{else} & \Rightarrow k\text{Hours} + \text{Lag( )}
\end{align*}
\]

Note: The Cumulative Sum function also supports the Group By option.

Moving Average  Calculates the exponentially weighted moving average, EWMA (using a smoothing parameter between 0 to 1.0) for each value in the selected column. The following example uses a smoothing parameter of 0.25:

\[
\begin{align*}
\text{IF} & \text{ Row( ) == 1} \\
& \Rightarrow k\text{Hours} \\
\text{else} & \Rightarrow k\text{Hours} \cdot 0.25 + \text{Lag( )} \cdot 0.75
\end{align*}
\]

Weighting  Determines how the values are weighted. Incremental weighting is a ramp or triangle. The exponential moving average is EWMA or EMA.

Items Before  Controls the size of the range (or window) by including the specified number of items before the current item in the average (in addition to the current item). -1 means all prior items.

Items After  Controls the size of the range (or window) by including the specified number of items after the current item in the average (in addition to the current item). -1 means all prior items.

Report missing values for partial window  Controls how missing values are treated. By default, missing values are ignored.

Note: JMP evaluates the formula entered on-demand therefore complex formulas might require a lot of processing time.
Transform Column Options

After creating a transform column, you can perform the following actions:

**Rename**  Renames the transform column.

**Add to Data Table**  Adds the transform column to the data table as a formula column.

**Remove Transform Column**  Removes the transform column from the launch window.

Recode Data

Use the recoding tool to change all of the values in a column at once. For example, suppose you are interested in comparing the sales of computer and pharmaceutical companies. Your current company labels are Computer and Pharmaceutical. You want to change them to Technical and Drug. Going through all 32 rows of data and changing all the values would be tedious, inefficient, and error-prone, especially if you had many more rows of data. Recode is a better option.

**Note:** If you need to recode similar values within multiple columns, use the Recode option in Cols > Standardize Attributes. See “Standardize Attributes” on page 258 in the “The Column Info Window” chapter.

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select the Type column by clicking once on the column heading.
4. In the Recode window, enter the desired values in the New Value boxes. For this example, enter Technical in the Computer row, and Drug in the Pharmaceutical row.
5. Click Done and select the In Place option from the menu.

**Figure 4.37  Recode Window**

All cells are updated automatically to the new values.
Note: If you enter a non-numeric value in a column with a Numeric data type, you are prompted to convert the data type to Character. Click Yes to convert the column and display the new value. Click No to keep the column Numeric and display a missing value.

Recode Options
When you are finished recoding data, click Done to view the following options:

**In Place**  applies any change to the original data column.

**New Column**  creates a new column for the changed data and retains the original column.

**Formula Column**  creates a new column with the changes as a formula instead of values.

Changing a value in the original column in the data table causes the formula column to update that value automatically.

**Script**  creates a new script called Recode in the data table. You can run this script to perform recoding in-place. If you recode additional values later, and want to update your current script, use the Script option again. You are prompted to choose if you want to merge your updates with the saved script, or create a new script. Run the Recode script immediately or after making changes to the data. You can also copy the Recode script to other data tables, or use it inside your custom scripts.

The remaining options are available on the Recode window:

**Undo**  reverses the last change made to the window.

**Redo**  recalls the last change made to the window.

**Filter**  searches for specific values. Add quotes around your search to find an exact phrase that includes whitespace.

**Group**  becomes active when multiple values are selected. Click Group to make highlighted values part of the same group. If you previously edited a value before grouping, the edited value becomes the group representative in the New Value column. Otherwise, the group representative is the value that occurs most often.

Note that when a string ends in whitespace, the string is grouped with only similar strings that end in whitespace.

**Show only Grouped**  shows recoded values that have been grouped.

**Show only Ungrouped**  shows values that have not been grouped.

Red Triangle Options for Recode
The red triangle menu contains options for the Recode window.

**Convert to Titlecase**  converts the first letter of each word to uppercase, and the remaining letters to lowercase.
Convert to Uppercase converts values to uppercase.

Convert to Lowercase converts values to lowercase.

Tab characters, space characters, and line separators are often imported into a data table. Remove these characters using the following commands:

**Trim Whitespace** removes leading and trailing whitespace characters. For example, if an extra space was imported before and after the name John, this command would delete the spaces.

**Collapse Whitespace** removes leading and trailing whitespace characters and removes duplicate interior whitespace characters. That is, if more than one whitespace character is present, the **Collapse Whitespace** command replaces the two spaces with one space.

Use the following commands to group data based on value:

**First Word** groups values based on the first word of the value. For example, if “John Smith” and “John Adams” were values, this command would group them under “John.”

**Last Word** groups values based on the last word of the value.

**All But First Word** groups values based on the remaining value after the first word is excluded.

**All But Last Word** groups values based on the remaining value after the last word is excluded.

**Group Similar Values** enables you to customize how data is grouped. Choose from the grouping options list. See “Grouping Options” below.

**Start Over** returns the window to the default condition.

**Recall** recalls previous changes made in the Recode window.

**Script** view options to import, merge, or save Recode scripts.

- **Import From File:** import a JSL script to recode previously recoded data. Run the same script on different data to recode data the same way.
- **Import From Data Table:** import a JSL script saved to a data table.
- **Save to File:** saves Recode changes to a JSL script. After selecting Save, you are prompted to name and save the file.
- **Save to Data Table:** saves Recode script to current data table.
- **Merge with Data Table Script:** merges changes made in the Recode window to the current Recode script saved to the data table. If there are multiple scripts, you are prompted to choose which script to merge your recoded data with.
- **Save to Script Window:** appends the Recode script to the script window.

**Right-Click Options for Recode**

Right-click values in the Recode window to view the following options:
**Group To** right-click selected values to select a different grouping value, or group representative. The **Group To** command displays the Old Values that occur most often in the data table with their corresponding New Values (if they are different). The list displays the first 8 possible group representatives.

**Swap New Values** when two values are highlighted, select **Swap New Values** to make the new value of the first value adopt the new value of the second value, and vice versa.

**Remove From Group** after values are grouped, right-click a single value or multiple values to remove them from that group.

**Make Representative** right-click a single value from a group and select **Make Representative** to make the selected value the New Value.

**Group Similar Values** right-click a single value to find values that are similar. The Grouping Options window appears. See “Grouping Options” in the section below.

**Grouping Options for Recode**

Select the following **Group Similar Values** commands to increase the accuracy of grouping:

**Ignore Case** item case is ignored.

**Ignore Non-Printable Characters** non-printable characters are ignored. Some data can include non-printable characters (such as file separators) that only the computer can read.

**Ignore Whitespace** white space is ignored.

**Ignore Punctuation** punctuation is ignored.

**Allow Character Edits** allows characters to be replaced by the new value when similar values are grouped.

**Difference Ratio** groups values according to proportional difference. For example, type “.25” to group values that are at most 25% different.

**Max Character Difference** groups values according to a maximum number of nonadjacent character differences. For example, type “5” to group values that differ by 5 characters or less.

**Example of Grouping Based on Character Difference**

You can group similar values according to the number of characters that differ between them.

1. Select **Help > Sample Data Library** and open **Candy Bars.jmp**.
2. Select the **Name** column.
3. Select **Cols > Recode**.
4. From the red triangle menu, select **Group Similar Values**.
5. Select the **Max Character Difference** option and type “6”.
This allows JMP to group values that differ by a maximum of 6 characters.

6. Click OK.

**Figure 4.38** Grouped by Character Difference

![Image of grouped data](image)

In this example, the grouped values have no more than 6 characters different between them. The values shown in the New Value column represents the grouped values in the recoded data table.

7. Right-click Almond Roca and select **Make Representative** to change the new value to represent a different value within the group.

**Figure 4.39** Make Representative

![Image of make representative option](image)

To remove values from a group, right-click and select **Remove from Group**.

8. Click **Done > In Place** to replace the original data with the recoded data in the table.

**Example of Grouping Based on Difference Ratio**

You can group similar values according to the proportion of characters that differ between them.

1. Select **Help > Sample Data Library** and open Candy Bars.jmp.
2. Select the Name column.
3. Select **Cols > Utilities > Recode**.
4. From the red triangle menu, select **Group Similar Values**.
5. Select the **Difference Ratio** option and type “.5”.

6. Click **OK**.

This allows JMP to group values that differ by 50% or less. In other words, values that share at least 50%, or half, of the same characters. The Difference Ratio is determined by comparing the total number of characters of each value and the total amount of unique characters between two given values.

**Figure 4.40** Grouped by Difference Ratio

This allows JMP to group values that differ by 50% or less. In other words, values that share at least 50%, or half, of the same characters. The Difference Ratio is determined by comparing the total number of characters of each value and the total amount of unique characters between two given values.

7. From the red triangle menu, select **Done > New Column** to save the recoded data in a new column in the data table.
   - Making a new column preserves the original data.

---

**Edit the Data Table**

This section describes the following actions that you can perform on data tables:

- Change the data table name
- Lock data tables
- Add table variables
- Add scripts to the data table
- Compare data tables

**Change Table Names**

A data table’s name appears at the top of its window, in the table panel, and on all related analysis reports. You can change a data table’s name in any of the following ways:

- Select **File > Save As** and save as the new name.
- In the table panel, click table name, type the new name, and then press the Enter key.
• On Windows, select **Window > Set Title**.

**Lock Tables**

Locking a JMP data table prevents data and column properties from being added or edited. You can still assign row states, run analyses, and so on. To lock a data table, click the red triangle menu next to the table name in the table panel and select **Lock Data Table**.

A lock icon 🕒 appears next to the data table name. To unlock the file, select **Lock Data Table** again.

If you make a data table read-only outside of JMP (for example, by changing its properties on Windows), the data table contains a note informing you that it is locked. See Figure 4.41. This type of lock allows users to edit the data table, but not save the changes.

**Figure 4.41 A Read-Only File**

![Figure 4.41 A Read-Only File](image)

**Compress Tables**

Compressing a JMP (version 6 or higher) data table reduces the size of the stored file. You can still run analyses, assign characteristics, and so on. To compress a data table, click the red triangle menu next to the table name in the table panel and select **Compress file when saved** and save the data table.

After saving the data table, a compressed icon 📁 appears next to the data table name. To decompress the file, select **Compress file when saved** again.

In addition, you can configure JMP to always use GZ compression when saving by selecting **Preferences > General > Save Data Table Columns GZ Compressed**.

**Note:** The **Compress file when saved** option only decreases the file size. This command does not affect the memory required to analyze the data. To reduce both the file size and memory required for analyzing, use **Cols > Utilities > Compress Selected Columns**. See “**Compress Selected Columns**” on page 198.
Use Table Variables

A table variable can contain textual information (for example, source information for the data), or a value that can be used by column formulas or JSL scripts. Table variable names appear in the table panel at the left of the data grid. See Figure 4.42.

Figure 4.42 Table Variables in the Table Panel

Uses for Table Variables

Use table variables in the following situations:

- To document tables
- In formulas
- In JSL scripts

Use Table Variables to Document Tables

Table variables are used primarily to document tables. Many sample data tables installed with JMP contain a table variable named Notes. This variable provides details about the data (for example, the source of the data). The example in Figure 4.42 shows a data table that contains Notes as one of its table variables. JMP also automatically creates table variables when you create a design table using the Design of Experiments commands in JMP. The design table has a table variable named Design with the name of the design type as its value.

Reference Table Variables in Formulas

Table variables can also be incorporated in formulas that you build using the Formula Editor. These formulas calculate values for a column by referring to a table variable. For details about constructing a formula that uses table variables, see “Refer to Values in Columns and Table Variables” on page 308 in the “Formula Editor” chapter.

Use Table Variables in JSL Scripts

You can also incorporate table variables into JSL scripts. See the Data Table chapter in the Scripting Guide for details.
Table Variable Actions

To add new table variables
1. In the Table panel, click the red triangle menu to the left of the data table name.
2. Select New Table Variable.
3. Give the variable a name and value in the boxes labeled Name and Value.
4. Click OK.
   The table variable appears in the Table panel.

To view or edit table variables
1. Double-click on the content of an existing table variable.
2. Edit the content.

To edit a table variable name
1. Double-click the table variable name.
2. Edit the name.

To delete table variables
Select one or more table variables and press Delete, or right-click the selected variables and select Delete. You can also press Control, right-click the blank area inside the table panel, and then select Delete Selected.

Concatenating Data Tables with Table Variables
See the “Example of Concatenating Data Tables and Table Variables” on page 281 in the “Reshape Data” chapter.

Create and Save Scripts
To automatically complete various analyses and tasks, you can create a JSL script and save it to the data table. See Figure 4.43. For details about writing data table scripts, see the Data Tables chapter in the Scripting Guide.
Save a Report Script to a Data Table

Once you have run an analysis and you are in the report window, you can add a script to the data table. This script generates the JSL that reproduces your analysis.

To save a script to the data table

From the report window, click on the red triangle menu for the platform and select **Save Script > To Data Table**.

Example of Saving a Report Script to a Data Table

First, you create your analysis, then you save the script.

1. Select **Help > Sample Data Library** and open Big Class.jmp.
2. Select **Analyze > Fit Y by X**.
3. Select weight and click **Y, Response**.
4. Select height and click **X, Factor**.
5. Click **OK**.
6. From the red triangle menu for Bivariate Fit, select **Fit Line**.
7. From the red triangle menu, select **Save Script > To Data Table**.
8. In the Script Save As window, enter the name of the script.
9. To replace an existing script with the same name, select **Replace existing script**.
10. To save a script that has the same name as an existing script and use the same name, select **Append unique suffix**.
    A number is added to the end of the script name.
11. Click **OK**.

   The script is added to the bottom of the Table panel.

**Tip:** If you want a particular script to run automatically every time the data table is opened, name the script **OnOpen**. Only one script saved in the data table can be set to run automatically. If you name the script Model (or model) in a Fit Model script, the launch window is automatically filled in based on the script when you select **Analyze > Fit Model**.

**Write a JSL Script for the Data Table**

*To add a script to a data table using JSL*

1. Click the red triangle menu to the left of the data table name in the Table panel. See Figure 4.44.
2. Select **New Script**.

3. Give the script a name by typing it into the box beside **Name**.

4. Add the script by entering JSL code into the box beside **Script**.

5. Perform one of the following actions:
   - If you want to run the JSL Debugger on the script to check it for errors, click **Debug Script**.
   - If you are finished editing the script, click **OK**. The script appears in the Table panel and the window closes.
   - If you are not finished editing the script and want to save it, click **Save**. The script appears in the Table panel and the window remains open for further editing.
   - If you want to run the script, click **Run**.

**Run, Edit, Delete, or Copy Scripts**

*To run, edit, delete, or copy a script that is saved to the data table*

1. In the Table panel, click the red triangle menu beside the script’s name, or right-click on the script name.
2. Select one of the following commands:
   - Run Script
   - Edit
   - Delete
   - Copy

Once you copy a script, you can then paste it into a script window or into the Table panel of another data table.
Use the Column Info window to set specific properties on a column in a data table. Here are some examples of the actions that you can perform on a column:

- Change data and modeling types
- Change numeric formats
- Add formulas
- Specify restrictions on values or missing values
- Order categorical values or row data
- Save specification, control, or response limits
- Enter a known value for sigma

You can also standardize attributes and properties across multiple columns, assign a preselected analysis role to columns, and compress columns in a data table.

**Figure 5.1 The Column Info Window**
About the Column Info Window

Use the Column Info window to specify all of the attributes and properties of a column. You can access the Column Info window in any one of the following ways:

- Select **Cols > New Columns**.
- Click an existing column heading and select **Cols > Column Info**.
- Right-click an existing column heading and select **Column Info**.
- Double-click directly above a column name.
- In the Columns panel, right-click a column and select **Column Info**.

**Figure 5.2** The Column Info Window

The Column Info window contains the following information:

**Column Name**  Type or edit the name of the column.

**Lock**  Lock the column so that none of its values can be edited. After you lock a column, the lock icon (🔒) appears next to the column name in the data table’s Columns panel. If you add a formula to a column, the column automatically locks.

**Data Type**  Select or change the data type of a column, which determines the following:
- How the column’s values are formatted in the data grid
- How the column’s values are saved internally
- Whether the column’s values can be used in calculations

See “About Modeling Types” on page 226.

Choose from the following data types:
- Numeric columns contain only numbers (with or without a decimal point).
Chapter 5
Using JMP

The Column Info Window

225

About the Column Info Window

– Character columns contain any characters, including numbers. In character columns, numbers are seen as characters and are treated as discrete values instead of continuous values. The maximum field width for character values is 32,766 bytes.

– Row State columns contain row state information, which indicates whether the rows are excluded, hidden, labeled, colored, or marked. See “Row State Columns” on page 231.

– Expression columns contain JSL expressions that can range from simple entries to complicated statement sequences. In particular, an expression can correspond to a picture, a matrix, or an expression. You can drag-and-drop expressions, such as an image, from your desktop to cells in an expression column. See “Expression Role” on page 254.

Notes:

– If you change a column’s Data Type from Character to Numeric, any character values become missing data values and are not recoverable.

– If you enter non-numeric data in a column with a Numeric data type, a warning window is displayed, prompting you to change the data type to Character. Click Try Again to return to the data table to re-enter the value. Click Change to change the data type. Click Revert to cancel your edit and return the cell’s value.

– Short-integer formats might also be available. See “The Short-Integer Format” on page 227.

Modeling Type  (Numeric or Character data types only) Select or change the modeling type of a column, which tells JMP how to treat the column’s values during analyses. You can change the modeling type to look at a variable in different ways. See “About Modeling Types” on page 226.

Choose from the following modeling types:

**Continuous**  Only numeric data types. Continuous values are treated as continuous measurement values. JMP platforms use the numeric values directly in computations.

**Ordinal**  Either numeric or character data types. JMP platforms treat ordinal values as discrete categorical values that have an order.

– If the column has a numeric data type, the values are ordered according to their numeric magnitude.

– If the column has a character data type and a Value Order column property is saved to the column, values are ordered according to the Value Order property. Otherwise, values are ordered according to their alphanumeric data value ordering. However, in special cases where the values have an obvious order, values are automatically ordered appropriately. See “Value Ordering” on page 239.

**Nominal**  Either numeric or character data types. JMP platforms treat all values as discrete values with no implicit order.
Multiple Response  Only character data types. Distinct entries in a single cell must be separated by commas. JMP platforms that support multiple response columns treat each entry in the comma-separated list as a separate data value. If your entries are separated by a character other than a comma, use the Multiple Response column property instead. See “Multiple Response” on page 247.

Unstructured Text  Only character data types. These values are generally unique, and are therefore ill-suited ill-suited is an American idiom that is hard to translate and isn’t easy for readers whose language isn’t English to read. “Not appropriate” is one alternative. for categorical analysis. The Text Explorer platform is ideal for analyzing unstructured text values.

Vector  Only expression data types. The entries in the cells are column or row vectors. JMP platforms that support the Vector modeling type recognize the vectors and treat them appropriately in calculations.

None  Any data type. Use None as a modeling type when a column is not well represented by the other modeling types. For example, a column of pictures or ID values might be assigned the None modeling type. JMP launch windows do not allow you to assign roles to columns with the None modeling type.

Tip: You must use the Column Info window to change a column’s modeling type to Multiple Response, Unstructured Text, or Vector.

Format  (Numeric data types only) Select or change the display format of a numeric column. See “Numeric Formats” on page 228.

Initialize Data  (Appears only during new column creation) Specify the type of initial data values that you want to appear in the column. See “Initialize Data” on page 233.

Column Properties  (Contains a list of different properties) Assign properties to columns. See “Column Properties” on page 235.

Tip: Click the Next button to continue adding columns.

About Modeling Types

A column in a JMP data table can contain different types of information. However, all information in a single column must have the same data and modeling types.

• When you import data, JMP guesses which data and modeling types to use. Therefore, you should verify that JMP has guessed correctly.

• When you manually insert data into JMP, you should assign a data type and a modeling type at that time.

Figure 5.3 illustrates the icons that identify the different modeling types.
Chapter 5
Using JMP

The Column Info Window

Figure 5.3 Modeling Type Icons in the Columns Panel

Click on an icon to change the modeling type to **Continuous**, **Nominal**, **Ordinal**, or **None**.
For details, see “Modeling Type” on page 225.

**Tip:** You can select Continuous only if your data type is numeric. If the Continuous option is dimmed on the menu and you want to make the column continuous, you must first change the column’s data type in the Column Info window.

The Short-Integer Format

When you use the correct short-integer format for your data, you do not see any difference in how the numbers appear. However, the numbers occupy less disk space and use less memory. Short-integer formats must be activated in preferences to appear in the Column Info window.

*To make short-integer formats available in the Column Info window*

1. Select **File > Preferences** and click **Tables**.
2. Select the **Allow short numeric data format** option.
3. Click **OK** to return to the data table.

To store numeric data in short-integer format:

1. Double-click above the column name whose values you want to be short-integer. The Column Info window appears.
2. From the Data Type menu, select **1-byte integer**, **2-byte integer**, or **4-byte integer**.

JMP stores values as integers in the range that you selected. The following numbers are examples:

- For 1-byte integer, the range of numbers that you can enter is from -126 to 127.
• For 2-byte integer, the range of numbers that you can enter is from -32,766 to 32,767.
• For 4-byte integer, the range of numbers that you can enter is from -2,147,483,646 to 2,147,483,647.

**Numeric Formats**

For numeric columns, the Format menu appears in the Column Info window. Specify the format to tell JMP how to display numbers in the column. For all format options, you can specify the number of total characters that you want the cells in the column to accommodate. See “Specify Width” on page 228.

For descriptions of the format options, see “Numeric Format Options” on page 228.

**Tip:** To add commas to values that equal a thousand or more, select the Use thousands separator option. You must account a space for each comma in the Width box, or else they might not appear. This option is available for the Best, Fixed Dec, Percent, and Currency formats.

**Specify Width**

When you specify a number in the Width field, be sure to include the total number of possible characters. Characters include: numbers, decimal points, commas, and currency symbols.

**Numeric Format Options**

Choose from the following numeric format options:

**Best**  Allows JMP to consider the precision of each cell value and select the best way to show it. By default, the physical width of the column is 12 characters.

**Fixed Dec**  Shows all values in the column rounded to the number of decimal places that you specify.
  – To see only whole numbers, set the number of decimal places to zero.
  – If the number of integers following the decimal point is smaller than the number of decimal places that you specify, zeros are added to reach the number of decimal places. For example, if the value is 1.23 and you type 5 in the Dec box, JMP shows the number with five decimal places: 1.23000.

**Percent**  Multiplies numeric values by 100 and shows the number followed by a percent sign.

**PValue**  Shows probability values. The default value of the width is 12. If a number is less than 0.0001, the number is displayed as <.0001. The format is mostly used in JSL scripts and rarely needed for a data table column.
Scientific  Shows a number in standard scientific notation. If you enter the number 123456, it appears as 1.23456e+5. Select Dec to show the decimal points and enter the number of points.

Engineering  Similar to Scientific, but the exponent is always a multiple of 3 and the Dec field represents significant digits.

Engineering SI  Same as Engineering, but the exponent is replaced with an SI symbol.

Precision  Rounds the number to a given number of significant digits. Specify the number of significant digits in the Dec field.

Currency  Formats values with two decimal positions, thousands separators, and the currency sign that is specified in your computer's locale settings. The default width of the Currency format is 15. If you have a number that requires a wider field width, the format defaults to the Best format. Once assigned, the currency symbol appears in the column and in graphs that contain the column.

Date  Shows all values in the column as a date. See “Date Formats” on page 230.

Time  Shows all values in the column as a specific instance in time, such as 12/2/03 at 2:23 PM. See “Time Formats” on page 231.

Duration  Shows all values in the column as a duration of time, such as hours, minutes, and seconds.

Geographic  Shows latitude and longitude number formatting for geographic maps. Latitude and longitude options include the following:

Custom  Enables you to define a custom format for a numeric column. Select Custom, click Set Custom Format, and define the format in the Formula Editor window. For example, you might divide the value by 100.
Date Formats

When you choose a Date format, you can also specify an Input Format. The Date format indicates how the date appears in the data table cells, and the Input Format indicates how you enter the date.

If you assign a date format to a numeric column that already contains data, then the numeric values are treated as the number of seconds since January 1, 1904. For example, if you have a numeric column with a cell value of 1,234,567,890 and you change the format to Date > m/d/y, the cell value appears as 02/13/1943.

The examples in Table 5.1 use the date of December 31, 2004.

Table 5.1 Date Formats

<table>
<thead>
<tr>
<th>Format</th>
<th>Appears As</th>
</tr>
</thead>
<tbody>
<tr>
<td>m/d/y</td>
<td>12/31/2004</td>
</tr>
<tr>
<td>mmddyyyy</td>
<td>12312004</td>
</tr>
<tr>
<td>m/y</td>
<td>12/2004</td>
</tr>
<tr>
<td>yyyyQq</td>
<td>2004Q4</td>
</tr>
<tr>
<td>d/m/y</td>
<td>31/12/2004</td>
</tr>
<tr>
<td>ddmmyyyy</td>
<td>31122004</td>
</tr>
<tr>
<td>ddMonyyyy</td>
<td>31Dec2004</td>
</tr>
<tr>
<td>Monddyyyy</td>
<td>Dec312004</td>
</tr>
<tr>
<td>y/m/d</td>
<td>2004/12/31</td>
</tr>
<tr>
<td>yyyyymmdd</td>
<td>20041231</td>
</tr>
<tr>
<td>yyyy-mm-dd</td>
<td>2004-12-31</td>
</tr>
<tr>
<td>Date Long</td>
<td>Friday, December 31, 2004</td>
</tr>
<tr>
<td>Date Abbrev</td>
<td>Dec 31, 2004</td>
</tr>
<tr>
<td>Locale Date</td>
<td>Varies based on local OS setting. Here is an example: in the United States, the local OS setting is mm/dd/yyyy (12/31/2004).</td>
</tr>
</tbody>
</table>

Note: To change how a date appears in a graph without changing how it appears in a data table, see “Change the Numeric Format of an Axis” on page 391 in the “JMP Reports” chapter.
Time Formats

When you choose a Time format, you can also specify an Input Format. The Time format indicates how the time appears in the data table cells, and the Input Format indicates how you enter the time.

- You can add the number of hours, minutes, and seconds after midnight of the prepended date for the following date formats:
  - m/d/y
  - d/m/y
  - y/m/d
  - ddMonyyyy
  - Monddyyyy
  - Locale Date

For example, December 31, 2004 has a numeric value of 3,187,296,600, which represents 12/31/2004 12:10 AM.

- :day:hr:m and :day:hr:m:s show the number of days, hours, minutes, and seconds since January 1, 1904. For example, the results for December 31, 2004 are :36890:00:10: and :36890:00:10:00.

- h:m:s and h:m show the hours, minutes, and seconds portion of the date in the date field. For example, the results for December 31, 2004 at 12:10 AM are 12:10:00 AM and 12:10 AM.

- yyyy-mm-ddThh:mm and yyyy-mm-ddThh:mm:ss show the year, month, day, and time. For example, 2004-12-31T12:10:00. T is a literal value, representing itself.

Note: To change how a time appears in a graph without changing how it appears in a data table, see “Change the Numeric Format of an Axis” on page 391 in the “JMP Reports” chapter.

International Formats

If you are importing or entering data that contains formatting specific to country standards, you might need to make sure that your number formats are interpreted correctly. On Windows, access the Control Panel’s region and language option, and select the country for which the number should be formatted. On the Macintosh, from the Apple menu, select System Preferences > Language & Text > Formats, and select the correct country. On later versions of Macintosh, this option may appear under System Preferences > Language and Region.

Row State Columns

Similar to assigning row states to rows, you can create a column that contains only row state information. A row state column stores information about whether rows are excluded,
hidden, labeled, colored, marked, or selected. To designate a column as a row state column, in the Column Info window next to Data Type, select **Row State**.

**Figure 5.4** Row States in Rows and a Row State Column

Since row state columns store the row states, you can apply them again later. Populate row state columns by copying them from the current row states or with column formulas.

*To create a row state column*

1. Select **Cols > New Columns**.
2. Next to Data Type, select **Row State**.
3. Click **OK**.

Populate the cells with new row state information or copy existing row state information from rows.

*To populate cells with new row state information*

1. To populate only certain rows in the row state column, highlight those rows. Or, to populate all rows in the column, highlight the row state column.
2. Right-click and select **Row States Cells**.
3. Select the row state that you want to apply.

*To copy existing row state information*

1. To populate only certain rows in the row state column, highlight those rows. Or, to populate all rows in the column, highlight the row state column.
2. Click the star icon (⭐) beside the column name in the Columns panel.
3. Select one of the following:
   - **Copy from Row States** replaces the row states in the column with the row states from the rows.
   - **Add from Row States** adds the row states from the rows to the row state column.
   - **Copy to Row States** replaces the row states in the rows with the row states from the column.
– Add to Row States adds the row states from the row state column to the row states in the rows.

Permanently Select Cells

You can save a selection in a row state column just like you save other row state characteristics (hide, exclude, color, and so on). This places a “permanent” highlight on a cell.

To permanently select cells
1. Right-click a cell and select Row States Cells > Select/Deselect.
2. Repeat this for as many cells as you would like to select.
3. To remove the highlight, right-click on the cell and select Row States Cells > Select/Deselect.

Initialize Data

When you first add a new column to a data table, the Initialize Data menu appears in the Column Info window. Specify the type of initial data values that you want to appear in the new column. Initializing data is not available for Row State data types.

Select one of the following options:

Missing/Empty  Places missing values in the column, represented by a black dot (•) for numeric data and a blank space for character data.

Constant  Places one number or character in all of the column’s rows. Enter the number or character into the box that appears. Enter any number of characters.

Today  Places today’s timestamp in the column for each row. This option is relevant only for the Date or Time formats.

Sequence Data  Inserts sequential data based on the parameters that you specify. See “Numeric or Character Sequence Data” on page 234.

Random  Inserts randomly generated data values into the column. Select a method for generating the random values:

Random Integer  Enter minimum and maximum integer values. Integer values within this range are generated so that each occurs with approximately equal frequency.

Random Uniform  Enter a range for continuous values. Random uniform values within this range are generated.

Random Normal  Enter the mean and standard deviation for a normal distribution. Random normal values from this distribution are generated.
**Random Indicator**  Enter up to three values and corresponding desired proportions. The proportions should sum to 1. Values are generated to have a distribution that corresponds as closely as possible to the specified proportions.

**Note:** This method generates values in the exact proportions that you specify unless the number of rows multiplied by one of the proportions results in a fractional value.

Suppose that there are $n$ rows and that the three proportions are $p_1$, $p_2$, and $p_3$. The values are generated as follows:

- Each row is assigned a random uniform value between 0 and 1.
- The rows are ordered according to their random uniform values.
- The rows corresponding to the smallest $\text{Round}(np_1)$ random uniform values are assigned the first value, the rows corresponding to the next smallest $\text{Round}(np_2)$ random uniform values are assigned the second value, and the remaining rows are assigned the third value.

**Numeric or Character Sequence Data**

*To insert sequential data for numeric data*

1. Next to **Data Type**, make sure **Numeric** is selected.
2. Next to **Initialize Data**, select **Sequence Data**.
3. In the From and To boxes, assign a starting and ending point.
4. In the Step box, assign the sequence.
5. (Optional) In the Repeat each value N times box, enter the number of times that you want each numeric value repeated.
6. Click OK.

For example, if you want the column to contain even numbers from 2 to 60, type 2 in the From box, 60 in the To box, and 2 in the Step box.

*To insert sequential data for character data*

1. Next to **Data Type**, make sure **Character** is selected.
2. Next to **Initialize Data**, select **Sequence Data**.
3. In the box next to **Add**, enter the character data and click **Add**.
4. (Optional) In the Repeat each value N times box, enter the number of times that you want each character value repeated.
5. Click OK.
Column Properties

A column property is information that is attached to a column. Once that information is entered, it is saved as part of the data table. You can select column properties and apply them to columns. There are some column properties that JMP creates for your convenience. Often, you can modify these.

Column properties are listed in the Column Info window’s Column Properties menu. The area below the Column Properties menu shows column properties that have been saved to a column. To view or edit a property, select it from this list.

In the Columns panel of the data table, an icon appears next to the name of each column that contains a property, other than the Notes property. The Notes property is not denoted by an icon. Icons include the following:

- ![Icon] Indicates that the range or list check property is applied
- ![Icon] Indicates that the column contains a formula
- ![Icon] Indicates that the column contains a property other than the Note, Range Check, or List Check column property

To assign a column property to one or more columns

1. Select the column or columns to which you want to assign a property.
2. Do one of the following:
   - Right-click the header area, select Column Properties, and select the property.
   - Right-click the header area, select Column Info, and select the property from the Column Properties menu.
   - Select Cols > Column Info and select the property from the Column Properties menu.
3. In the column property panel that appears, specify values and select options as appropriate.
   - Click Apply to add the column property or click OK to add the column property and close the column properties window.

A column might already contain a property that you want to apply to other columns. Use the Standardize Attributes command to apply that property to other columns. See “Standardize Attributes and Properties Across Columns” on page 257.

The following sections describe the properties that you can add to columns.
Basic Column Properties

Basic column properties that apply generally include Formula and Notes.

Formula

Insert a formula into a column to compute the values for that column. After a formula is added, the column is locked so that its data values cannot be manually edited (preventing invalidation of the formula).

- Click Edit Formula to create a formula. For details about creating a formula, see the “Formula Editor” chapter on page 305.
- If you do not want JMP to evaluate the formula, click Suppress Eval.
- If you do not want JMP to alert you about errors in your formula, click Ignore Errors.
- Once you have created a formula:
  - In the Column Info window, a visual of the formula appears at right. However, if your formula is long, only a portion of it might appear. Click and drag the borders of the formula box to resize it.
  - From the data table, edit the formula by clicking ( ) next to the column name in the Columns panel.

Tip: To bypass the Column Info window when creating a formula, right-click on the column and select Formula.

Notes

Adds notes to the selected column.

Properties That Validate Column Values

The following properties help validate values in a column: Range Check, List Check, and Missing Value Codes.

Range Check

Range checking validates the data in a column. Set up the column to accept only numbers that fall within a specified range.

Select which formula to use to set up the range. $x$ is the value entered into the column, $a$ is the beginning of the range, and $b$ is the end of the range.

- $a = \text{the lowest value that the column accepts}$
- $b = \text{the highest value that the column accepts}$
• For a single-sided range check, leave either a or b empty.
• From the data table, modify the range check by clicking (✔) next to the column name in the Columns panel.

*To turn off range checking*
1. From the data table, right-click the column name in the Columns panel.
2. Select **Validation > No Checking**.

**List Check**

List checking validates the data in a column. Set up the column to accept only the individual values that you specify. List checking is useful when you want to specify how to order the data in your graphs or plots.

• Use the buttons to add new values, change, or reverse the order of values, and remove values.
• Once a list check is set on a column, the cursor changes to [ ] when positioned over the cells. If you try to enter a value not included on the validation list, a warning message appears.
• To see a menu of acceptable values, right-click a cell and select **List Check Values**. You can select the cell value from the menu instead of entering it into the cell.
• From the data table, modify the list check by clicking (✔) next to the column name in the Columns panel.

*To turn off list checking*
1. From the data table, right-click the column name in the Columns panel.
2. Select **Validation > No Checking**.

**Missing Value Codes**

Use missing value codes to specify column values that should be treated as missing. For example, sometimes the value 99 is used as a placeholder to represent missing values, or perhaps several values are used to represent different types of missing values.

**Note:** The Missing Value Codes column property is an extended attribute. If you plan to export to a SAS 9.4 server or Save As a SAS 9.4 file format, you should enable extended attributes in the SAS Integration Preference page. See “SAS Integration” on page 528 in the “JMP Preferences” chapter for details. Alternatively, you should select **Store table and column properties in SAS 9.4 extended attributes** in the Save As window. If extended attributes are not selected, JMP exports or saves Missing Value Codes as missing values. Extended attributes are supported only by SAS 9.4. Earlier versions of SAS disregard any extended attributes.
Properties That Attach Information to Column Values

The following column properties attach information that is used in reports and plots to the values in a column:

- Value Labels
- Value Scores
- Value Ordering
- Row Order Levels
- Value Colors
- Color Gradient

Value Labels

Use value labels to show a label in the data table instead of a value. A label appears for each instance of the value. You can show the original values by double-clicking a label within a cell.

- Enter the value that you want to assign a label to in the Value box.
- Enter the label that you want to appear in the Label box.
- To use ranges, click Allow Ranges then specify the lower and upper values. If Allow Ranges is selected, Value Labels can be non-integers. Graph Builder can use the Value Labels for the x- and y-axes.

**Tip:** To assign a label to missing values, enter a period (.) for the lower bound and leave the upper bound empty. To assign a label to all other values, enter three periods (...) for the lower bound and leave the upper bound empty.

- Add, change, or remove labels.

Tips:

- To turn off value labels in the data table without deleting the value labels that you have set up, in the Column Properties window, deselect Use Value Labels. Or, to quickly show or hide value labels in a data table, right-click on a column and check or uncheck Use Value Labels.
- When your data table contains value labels, using the Search commands searches for actual values, but does not search for labels.
- When your data table contains value labels, the Row Editor displays the label, and when the cell is highlighted for editing, it shows the actual value.
- If you copy and paste a cell with a value label, the actual value is pasted.
- In a formula, when you reference a column using value labels, hold your mouse pointer over the value label to see the actual data value.
Value Scores

Use value scores to indicate a value-score pair for categorical data columns. The value is a data value and the score is a number. This property associates a data value with a score (for example, the column’s data value could be “not satisfied”, “satisfied”, “very satisfied”). The user could assign a score of 0 to “not satisfied”, 50 to “satisfied”, and 100 to “very satisfied”. Those scores are then used for computation purposes like computing the mean. See the Categorical chapter in Consumer Research for an example.

To use value scores
1. In the data table, right-click on the column and select Column Info.
2. From the Column Properties list, select Value Scores.
3. Enter the value that you want to assign a label to in the Value box (for example, “satisfied”).
4. Enter the label that you want to appear in the Score box (for example, “50”).
5. Click Add, Change, or Remove.
6. Click OK.

Value Ordering

Value Ordering assigns an ordering to values in a column that is then used in reports and plots. The default ordering for reports and plots is alphanumeric data value ordering, except in the following cases, where values are automatically ordered appropriately:

- January, February, March, April, May, June, July, August, September, October, November, December
- Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
- Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
- Very Low, Low, Medium Low, Medium, Medium High, High, Very High
- Strongly Disagree, Disagree, Neutral, Indifferent, Agree, Strongly Agree
- Failing, Unacceptable, Very Poor, Poor, Bad, Acceptable, Average, Good, Better, Very Good, Excellent, Best

Tip: You can anonymize Value Ordering so that the Value Ordering properties are renumbered. To do this, highlight the column with the Value Ordering column property and select Tables > Anonymize.

When you construct a design using a DOE platform, the Value Ordering column property is automatically assigned to categorical factors. For examples of assigning and editing the Value Ordering column property, see the Column Properties chapter in the Design of Experiments Guide.
**Note:** If you use both the Value Ordering and Row Order Levels properties, the Value Ordering property overrides the Row Order Levels.

**Row Order Levels**

Use the Row Order Levels property to sort the column values by their occurrence in the data, rather than sort by value.

The row ordering applies only to the selected column. To apply it to other columns, repeat the above steps for each column, or use the Standardize Attributes command. See “Standardize Attributes and Properties Across Columns” on page 257.

**Tip:** To show the analyzed row data in another order (besides according to their values or their occurrence in the data table columns) use the Value Ordering property. See “Value Ordering” on page 239. The Value Ordering property overrides the Row Order Levels property when both are evoked.

**Value Colors**

Use value colors to assign the values of a nominal or ordinal column a certain color or range of color themes. The column’s values appear with the assigned color in all applicable graphs, such as mosaic plots and plots with color-coded legends. You can also color the values in the data table column.

- To change the color of a specific value, right-click a color circle and select a color.
- To use a color theme, click **Color Theme** below the list of value colors and then select the color.
- To create a custom color theme, see “Create a Custom Color Theme” on page 240.
- To also color the cells in the data table, select **Color Cell by Value**.
- Select from the options in the Macros menu. See “Macros Options” on page 241.

**Create a Custom Color Theme**

To create a custom color theme

1. Click **Color Theme** below the list of value colors in the column properties.
2. Open the Custom Color Theme outline.
3. Click **New**.
4. Create the color using the sliders.
5. Name the color and click **Save**.
6. Click **OK**.
You can access the new custom color in the Color Theme menu the next time you use the Value Colors property. The color is also saved in your preferences. See “Create Color Themes” on page 191 in the “Enter and Edit Data” chapter for details about creating color themes.

**Macros Options**

The Macros menu contains the following options:

- **Gradient between ends** Sets the colors of the top and bottom values. JMP applies a color gradient across the entire range of values. Use this command to make all of the colors in between for the other levels.

- **Gradient between selected points** Sets the colors of the top and bottom values so that JMP can apply a color gradient to a range of values that you have highlighted in the Value Colors list.

- **Reverse colors** Reverses the color of the values from top to bottom or bottom to top.

- **Revert to old colors** Sets the colors back to their original color values.

**Color Gradient**

Select a color gradient to color a continuous column in a plot. Color gradients are supported in the Graph Builder, Bubble Plot, Treemap, and Cell Plot platforms.

- To also color the cells in the data table, select **Color Cell by Value** above the list of value colors.
- Select a color gradient from the menu.
- Enter the minimum, maximum, and center values:
  - Minimum values reflect the color at the left of the gradient.
  - Maximum values reflect the color at the right of the gradient.
  - Center values reflect the color in the middle of the gradient.

**Note:** To see color gradients in Graph Builder, you must assign the column to the Color zone. To see color gradients in Bubble Plot and Treemap, you must assign the column to the Coloring role.

**Properties That Control the Display of Columns**

The Axis and Units column properties control how column values are displayed.

**Axis**

Use the Axis property to change the default axis settings for a column. JMP automatically uses your settings when the column appears in an analysis. See “Customize Axes and Axis Labels”
in the Axis Settings Window” on page 390 in the “JMP Reports” chapter for details about the properties.

When you add the Axis column property, you can save all column properties or only the properties that you changed. For example, you might want the axis to start at 0 and are not concerned about the upper bounds of the axis. Set the minimum axis value and select **Changed Properties Only** from the Save to column list.

*To set default axis properties for a column from within a graph*

1. Create the graph.
2. Change the axis to your preferred specifications.
3. Right-click the axis and select **Save to Column Property**.

**Units**

Use the Units property to specify the measurement units that were used to collect the data for the column. The units appear in parentheses after the column name in the data table and when the column appears in plots. For example, you might want a column to indicate that age values are measured in months, or that a monetary value is in thousands of dollars.

**Properties Used in Modeling and DOE**

When you construct a design using the DOE platforms, column properties are saved to the resulting design table. However, some of these column properties are useful in general modeling situations. To use the properties more generally, you can specify them yourself.

**Note:** The Column Properties chapter in the *Design of Experiments Guide* describes the properties associated with DOE in detail and presents examples. Only a brief description of these properties is provided here.

The following column properties are used in modeling and DOE:

- Response Limits
- Design Role
- Coding
- Mixture
- Factor Changes
Response Limits

The Response Limits column property defines a desirability function for the response. The Prediction and Contour Profilers use desirability functions to find optimal settings. For more information, see the Column Properties chapter in the Design of Experiments Guide.

Design Role

The Design Role column property indicates how a column is used in both a designed experiment and in the model used to fit the data. For example, a column could represent a continuous factor, a categorical factor, a blocking factor, and so on. For more information, see the Column Properties chapter in the Design of Experiments Guide.

Coding

The Coding column property applies a linear transformation to the data in a numeric column. The data are transformed to –1 and +1 based on bounds that you specify. JMP then uses the transformed data values whenever the column is entered as a model effect in the Fit Model platform. For more information, see the Column Properties chapter in the Design of Experiments Guide.

Mixture

The Mixture column property is useful when a column in a data table represents a component of a mixture. The components of a mixture are constrained to sum to a constant. The Mixture column property identifies a column as a mixture component and defines a coding for that column. For more information, see the Column Properties chapter in the Design of Experiments Guide.

Factor Changes

The Factor Changes column property indicates how difficult it is to change factor settings in a designed experiment. It is used to create and analyze split-plot, split-split-plot, and two-way split-plot designs. For more information, see the Column Properties chapter in the Design of Experiments Guide.

Properties Associated with Control Charts and Capability

The Specification Limits, Control Limits, Sigma, and Process Capability Distribution properties are associated with control charts and capability.
Spec Limits

Specification limits are used when you perform a capability analysis using the Distribution and Capability platforms.

You can specify any combination of a Lower Spec Limit, an Upper Spec Limit, or a Target. The Show as graph reference lines option displays the specification limits and target that you specify as reference lines on appropriate plots.

Control Limits

The Control Limits column property enables you to specify control limits for a column, rather than having JMP calculate control limits from the values in the column. This is useful when you are comparing process data to historical control limits.

The Control Limits column property can be assigned only to a numeric column. To assign the Control Limits column property, select the control chart type and then enter the requested values. If any of these entries are missing, JMP replaces it with a calculated value in the control chart.

Sigma

Use the Sigma property to enter a known sigma value. This value is used by applications such as control charts or any application that requires a sigma value to complete computations. If no sigma value is supplied, sigma is calculated from the sample.

Process Capability Distribution

The Process Capability Distribution column property specifies a process distribution for the column. The Process Capability Distribution column property is used only in the Process Capability platform. See also “Distribution and Process Capability Distribution” on page 245.

Properties That Control How Columns Are Used in Platforms

The following properties control how columns are used in platforms:

- Distribution
- Time Frequency
- Map Role
- Supercategories
- Multiple Response
- Profit Matrix
- Informative Missing
Distribution

For a column that contains continuous numeric data, use the Distribution property to select a distribution type to fit to the column. This distribution is used in the Distribution platform and is used in the Process Capability platform under certain conditions. See “Distribution and Process Capability Distribution” on page 245.

When you obtain a Distribution report (by selecting Analyze > Distribution) for the column, JMP automatically estimates a fit using the specified distribution. A curve representing the fitted distribution is superimposed on the histogram.

If you set both the Distribution property and the Spec Limits property, then the Distribution platform produces a Capability Analysis report that is based on the distribution specified in the Distribution column property.

Distribution and Process Capability Distribution

If you analyze a column that does not contain a Process Capability Distribution property using the Process Capability platform, the distribution specified in the Distribution column property results in a nonnormal fit in the Process Capability platform:

- If the distribution specified in the Distribution property is supported in the Process Capability platform, the Process Capability platform uses the specified distribution.
- If the distribution specified in the Distribution property is not supported in the Process Capability platform, the Process Capability platform uses a Johnson fit.

If both the Distribution and Process Capability Distribution column properties are saved for a given column, then the properties behave as follows:

- The distribution specified in the Distribution column property is used in the Distribution platform.
- The distribution specified in the Process Capability Distribution column property is used in the Process Capability platform.

Time Frequency

When using the Time Series platform, you can assign the Time Frequency property to data. The Time Frequency property specifies the frequency with which the data is reported (such as annually, quarterly, monthly, and so on). Specifying a time frequency allows JMP to take things like leap years and leap days into account. If no frequency is specified, the data is treated as equally spaced numeric data.
Map Role

If you have created a data table that contains boundary data (such as countries, states, provinces, or counties), to see a corresponding map in Graph Builder, use the Map Role property.

Note the following:

• If the custom boundary files reside in the default custom maps directory, then you need to specify only the Map Role property in the -Name file.
• If the custom boundary files reside in an alternate location, then you must specify the Map Role property in the -Name file and in the data table that you are analyzing.
• The columns that contain the Map Role property must contain the same boundary names, but the column names can be different.

For an example using the Map Role property, see the Create Maps chapter in the *Essential Graphing* book.

To add the Map Role property into the -Name data table

1. Right-click on the column containing the boundaries and select **Column Properties > Map Role**.
2. Select **Shape Name Definition**.
3. Click **OK**.
4. Save the data table.

To add the Map Role property into the data table that you are analyzing

**Note:** Perform these steps only if your custom boundary files do not reside in the default custom maps directory.

1. Right-click on the column containing the boundaries and select **Column Properties > Map Role**.
2. Select **Shape Name Use**.
3. Next to **Map name data table**, click to browse to a -Name map data table. You can enter the relative or absolute path.
   - If the map data table is in the same folder, enter only the filename. Quotation marks are not required when the path contains spaces.
4. Next to **Shape definition column**, enter the name of the column in the map data table whose values match those in the selected column.
5. Click **OK**.
6. Save the data table.
When you generate a graph in Graph Builder and assign the modified column to the Shape zone, your boundaries appear on the graph.

**Supercategories**

When a data set contains ratings (for example, on a five-point scale), you might want to know the percent of the responses in a subset of those ratings. Add a Supercategories column property to group specific categories into one category.

Supercategories are supported only in the Categorical platform.

*To add the Supercategory property to a data column*

1. Right-click the column that contains categories that you want to group.
2. Select **Column Properties > Supercategories**.
   
The column properties window shows the Supercategories options (Figure 5.5).
3. Select the categories in the Column’s Categories list that you want to group.
4. Enter a descriptive name next to Supercategory Name.
   
   Leave the name blank, and JMP names the supercategory after the categories that you selected.
5. Click **Add** to create the supercategory.
6. From the **Supercategories** red triangle menu, select from the following options:
   
   – **Options > Hide**: Hides data in the selected supercategory from reports and graphs.
   
   – **Add All**: Creates a supercategory from all of the categories in the column.
   
   – **Add Mean** and **Add Std Dev**: Calculate statistics for value scores. See the *Consumer Research* book for more information.
7. Click **OK** to add the property to the column.

*Figure 5.5  Example Supercategories Configuration*

**Multiple Response**

The term *multiple response* refers to the situation where the cells in a column contain more than one response value. For example, many cells in the Brush Delimited column in the Consumer
Preferences.jmp sample data table contain multiple values. For example, row 6 contains “Wake, After Meal, Before Sleep”.

Add the Multiple Response column property if you want to specify a delimiter other than the comma. Otherwise, change the column’s modeling type to Multiple Response in the Column Info window. See “About Modeling Types” on page 226 for details about the Multiple Response modeling type.

JMP automatically assigns the Multiple Response modeling type to data tables saved in JMP 12 or lower. The column must contain the Multiple Response column property, and the delimiter must be a comma for the automatic assignment to take place. JMP does not remove the Multiple Response column property, though you might choose to do so.

Figure 5.6 Multiple Response Configuration Window

![Multiple Response](image)

**Note:** You can use the Multiple Response property in the Categorical platform. See the Categorical platform chapter in the *Consumer Research* book for details. You can also use this property in the Data Filter. See “The Data Filter” on page 356 in the “JMP Reports” chapter. If the delimiter is a comma, consider using the Multiple Response modeling type instead.

**Profit Matrix**

Use the Profit Matrix column property to assign weights to the levels of a nominal or ordinal response variable for a predictive model. For a nominal response, you can specify the profit matrix entries using a probability threshold.

**Profit Matrix**

When you select **Column Properties > Profit Matrix**, a matrix template appears, with a row and column for each value in the selected column. The Actual levels are shown as rows and the predicted levels are shown as columns. Correct decisions are those on the diagonal, where the predicted level equals the actual level.

- For diagonal entries, enter values that reflect profits or weights for correct decisions.
- For non-diagonal entries, enter values that reflect profits (or losses) or weights for incorrect decisions.
- For situations where no prediction is made, use the Undecided column to indicate associated profits or losses.
Probability Threshold Specification for Profit Matrix

When the response is binary, additional options appear beneath the profit matrix template. These options enable you to specify a probability threshold instead of entering weights directly into the profit matrix.

Specify the Target and Probability Threshold. Then click Set to update the profit matrix.

**Target**  The level whose probability is modeled.

**Probability Threshold**  A threshold for the probability of the target level. If the probability that an observation falls into the target level exceeds the probability threshold, the observation is classified into that level.

**Set**  Enters values into the profit matrix template that reflect your specifications for Target and Probability Threshold. For details, see “Probability Threshold Calculations” on page 249.

Probability Threshold Calculations

Denote the threshold probability by \( t \). When you click Set, the entries in the profit matrix are assigned as follows:

- 0 for each diagonal entry, reflecting no loss from correct decisions
- -1 for a prediction of the target level when the actual value is the non-target level
- \(-\frac{t}{1-t}\) for a prediction of the non-target level when the actual value is the target level

This implies that the profits for classifying into the two levels are given as follows:

\[
\text{Profit for Target Level} = \left(\frac{-t}{1-t}\right) \text{Prob}[\text{Non-Target Level}]
\]

\[
\text{Profit for Non-Target Level} = -\text{Prob}[\text{Target Level}]
\]

The Most Profitable Prediction is the level whose profit is the larger of these two values. It follows from the two Profit equations above that an observation is assigned to the target level whenever \( \text{Prob}[\text{Target Level}] \) is at least \( t \).

Profit Matrix and Predictive Models

For a nominal or ordinal column with the Profit Matrix column property, most modeling platforms enable you to save formula columns that reflect profit matrix entries. Fit your model and then select the Save Prediction Formula or Save Probability Formula option. In addition to saving the usual prediction formulas to the data table, JMP saves the following analogs of the usual formula columns:

- **Profit for <level>**: For each level of the response, a column gives the expected profit for classifying each observation into that level.
• Most Profitable Prediction for <column name>: For each observation, gives the level of the response with the highest expected profit.

• Expected Profit for <column name>: For each observation, gives the expected profit for the classification defined by the Most Profitable Prediction column.

• Actual Profit for <column name>: For each observation, gives the actual profit for classifying that observation into the level specified by the Most Profitable Prediction column.

See “Example of a Profit Matrix for More Than Two Levels” on page 250. For an example of using a profit matrix in modeling, see the Partition chapter in the Predictive and Specialized Modeling book.

Example of a Profit Matrix for More Than Two Levels

The example below (Figure 5.7) shows a profit matrix for the Airline column in the Travel Costs.jmp sample data table.

Figure 5.7 Example of Profit Matrix Window

To see how the values in this profit matrix were assigned, consider a travel agency that uses four airlines, Carrier 1 to Carrier 4, to service its customers. For each ticket sold, the agency realizes a profit that depends on the carrier selected by the customer. When the agency recommends, or predicts, a carrier, it reserves a ticket for a small fee. If the customer decides to use the predicted carrier, the agency profits by a certain amount less the reservation fee. However, if the customer decides to take a different carrier, the agency loses the reservation fee and must pay another reservation fee. The agency’s profit is lower due to the incorrect prediction.
Suppose that the reservation fees for Carriers 1 through Carrier 4 are $15, $20, $30, and $50, respectively, and that the profits from ticket sales are $40, $40, $100, and $110, respectively.

If the agency recommends Carrier 1 to a customer who then decides to purchase the ticket, the agency reserves a ticket for $15 and then receives $40 for a net profit of $25. If the agency predicts that a customer will choose Carrier 4 but the customer chooses Carrier 1, the agency loses $50 for the Carrier 4 reservation and must also pay $15 for the reservation on Carrier 1. This gives the agency a net loss of $40 - $50 - $15 = -$25.

**Example of Using Probability Threshold to Define the Profit Matrix**

The sample data table Liver Cancer.jmp gives disease Severity ratings for 136 patients. You are interested in modeling Severity using the predictors given in the columns from BMI to Jaundice. The usual prediction formulas for a model classify a patient into the Severity level that is most probable. However, classifying a patient as having Low severity when in actuality the patient’s severity is High is a more costly error than classifying a patient as having High severity when in actuality the patient’s severity is Low. As a result, you want to assign a higher cost to misclassifying a patient as Low, when the patient’s severity is actually high.

You can assign this higher cost by setting a probability threshold. With input from experts, you determine that the following is a good strategy: Classify into the High level of Severity any patient whose predicted probability of being in the High level exceeds 0.4.

1. Select **Help > Sample Data Library** and open Liver Cancer.jmp.
2. Change the Target to **High**.
3. Enter 0.4 as the **Probability Threshold**.
4. Click **Set**.
   The profit matrix updates to show the corresponding weights.
The profit matrix shows that the loss for misclassifying a patient with High severity as having Low severity is -1, while the loss for misclassifying a patient with Low severity as having High severity is smaller, -0.6667.

**Informative Missing**

The Informative Missing column property directs most fitting platforms to use a coding system for columns that contain missing values. For continuous columns, the coding system consists of two columns. The first column is a column of the original values with missing values replaced by the mean of the nonmissing values; the second column is an indicator column to denote which rows are missing. For categorical columns, missing values are treated as a distinct level of the column.

**Virtual Join Properties**

Virtual Join links a main data table to one or more auxiliary data tables. The feature enables the main data table to access data from the auxiliary data tables without physically joining the tables. See “Virtually Join Data Tables” on page 296 in the “Reshape Data” chapter for details. The Link ID and Link Reference column properties make the linking possible.

**Notes:**

- The data types of the Link ID and Link Reference columns must match.
• Link ID and Link Reference do not work for Row State and Expression data types.
• Consider adding the Link ID column property before adding the Link Reference column property so that the referencing column in the main table has a column to link to.

**Link ID**

The Link ID column property marks a column in the auxiliary data table as the ID column. That is, the rows of the data table are uniquely identified by the values of the ID column. The data table that has a Link ID column property is referred to as the *referenced* data table.

To add the Link ID column property, select the column, select **Cols > Column Info** and then select **Link ID** from the Column Properties list. Make sure that the Link ID checkbox is selected and click **OK**. The selected checkbox indicates that the column is the ID column for the data table.

**Link Reference**

The Link Reference column property maps a column in the main data table to the ID column in the referenced data table. The column that has a link reference is referred to as the *referencing* column. The referencing column can look up the data of the auxiliary data tables through the ID column.

To add the Link Reference column property, select the column, select **Cols > Column Info**, and then select **Link Reference** from the Column Properties list. Enter the path to the main table and click **OK**. If you enter the path correctly, the referenced columns show up in the Columns panel of the main table after you click OK.

**Notes:**

• The path is case sensitive.
• Consider putting the data tables in the same folder. Then you can omit the directory name from the Link Reference property and include only the data table name. Otherwise, include the full path to the data table (such as `c:\users\marie\My Data.jmp`).
• You can also increase portability by using a JMP path variable in the Link Reference path. Figure 5.9 shows an example. Enter a forward slash in the path to share the data tables with both Windows and Macintosh users. See the Types of Data chapter in the *Scripting Guide* for details about path variables.
• You can avoid entering the path by right-clicking a column to add the Link Reference property. See “Example of Virtually Joining Data Tables” on page 298 in the “Reshape Data” chapter for details.
Additional Properties

There are two additional properties: Expression Role and Other.

Expression Role

The Expression Role column property applies to columns containing expressions. It specifies whether the expression in the column should be interpreted as a Picture, a Matrix, or an Expression. The default is set to Picture. If the Expression Role is set to Picture and the expression is a picture, then the expression evaluates to a picture and the picture appears in the data table. Otherwise, the expression shows as a JSL expression. Change this setting to alter how expressions are used.

Note: Expression columns that contain images greater than 32KB in size are truncated when saved to Microsoft Excel. Those expression columns are not restored when imported back into JMP.

Select from the following options:

**Picture**  If the expression contains picture data, the column evaluates and the picture is displayed.

**Matrix**  If the expression contains a matrix, the column evaluates and the matrix is displayed. Otherwise, the data is displayed as an expression.

**Expression**  If the expression is simply an expression, use this option to display it in the column.

Use Expression when you want to work with an expression that might contain picture data, but you want to prevent JMP from displaying the image.
To drag images into an expression column

1. Create a new column in a data table.
2. Double-click the column heading. Change the data type from Numeric to Expression.
3. Click OK.
4. Navigate to the website that contains the image that you want in your data table. You can also use an image that is on your computer.
5. Select the image, and drag it into an empty cell in the Expression column.
   Resize the cell to make the image larger.
   SAS Offices.jmp shows an example of an Expression column.

   **Tip:** To display the image in a hover label for a graph, add a label to the column.

To add an expression column using Summary

1. Select Help > Sample Data Library and open CrimeData.jmp.
2. Select Tables > Summary.
3. Select State, and click Group.
4. Select Total Rate, and click Statistics > Histogram.
5. Click OK.
   A new data table appears that contains a new expression column with images of histograms. Resize the row to make images larger.
   For more details about Summary, see Chapter 8, “Summarize Data”.
6. Right-click the Histogram(Total Rate) column, and select Column Info.
   Notice the column’s data type is set to Expression.
7. Select Expression Role from the Column Properties menu.
   The Expression Role is automatically set to Picture. In the rare case that a picture needs to be displayed as an Expression, change the setting to Expression.
8. Click OK.
   Expression Role is assigned to the Expression column.

Other

Use the Other column property to create your own column property and assign it any name that you choose. This property is then available for JSL programming.

1. Right-click on the column and select Column Properties > Other.
2. Enter a name for the new property.
Properties Assigned and Controlled by JMP

To control how information flows between platforms, JMP assigns some properties that you cannot control. These properties do not appear on the Column Properties menu.

Response Probability

In Profiler reports, the Response Probability property makes all levels of the categorical response variable appear in a single row. JMP automatically assigns the Response Probability property when certain probability formulas are saved to the data table.

Follow these steps to save the property:
1. Fit a logistic regression model using the Fit Model platform.
2. Select the Save Probability Formula option in the report window.
   - JMP automatically assigns the Response Probability property to the new probability columns.
3. Select Prediction Profiler from the report’s red triangle menu.
   - The levels of the categorical response appear on the vertical axis. Probabilities for each level are shown.

For more details, see the Profilers book.

Predicting

JMP automatically assigns the Predicting column property when you fit a model to a continuous response and save the prediction formula or prediction values. The Predicting column property identifies the platform used to create the prediction formula. That platform is listed as the Creator in the Model Comparison platform.

Informative Missing Terms

Missing levels of a categorical variable are treated as informative missing in certain JMP platforms, either by default or if you request an informative missing fit. In these cases, JMP automatically assigns the Informative Missing Terms column property to a prediction formula column that includes the categorical variable. This column property ensures that the missing value category is treated as a distinct level of the categorical variable in plots and analyses that involve the prediction formula. In particular, profiler plots show the missing values as a level.
**Column ID**

JMP automatically assigns the Column ID column property to the column that is used to split the initial Bootstrap results data table. This column property assists the split operation and ensures that the column names in the split Bootstrap results table are meaningful.

---

**Standardize Attributes and Properties Across Columns**

A column might contain attributes (data types, modeling types, numeric formats, and so on) or properties (formulas, notes, list and range checks, and so on) that you want other columns to have. You can use the existing column to standardize the attributes and properties across columns. This includes both adding and deleting attributes and properties.

*To apply an existing column’s attributes and properties to multiple columns*

1. Select the column or columns containing the desired attributes or properties.
2. Select Cols > Standardize Attributes. The window in Figure 5.10 appears.

![Figure 5.10 Standardizing Attributes across Columns](image)

**Recode Values**

Use the Recode option if you need to recode similar values within multiple columns in the same way. After you click **Recode**, the values that appear are generated from the union of all of the selected columns. For example, suppose that you have two columns with user
responses. One column contains the values Agree and Disagree. The other column contains the values Agree, Disagree, Unsure, and Strongly Disagree. You want to simplify all of the values in both columns to be A, D, U, and SD.

Note: If you want to recode values only in a single column, you can also use the Cols > Utilities > Recode option. See “View Patterns of Missing Data” on page 177 in the “Enter and Edit Data” chapter.

Standardize Attributes

By default, the items within the Standardize Attributes panel are dimmed. To access an item, click the Attributes button and select the items to be duplicated across columns.

Note: The Input Format item is applicable only for the Date, Time, and Duration formats.

To change the values of any of the attributes, use the menus in the Standardize Attributes panel.

Standardize Properties

To standardize properties across columns

1. Select the columns that you want to standardize. One of those columns must contain the property that you want to add to the other columns.
2. Select Cols > Standardize Attributes.
4. Select the property that you want to standardize. Modify the property settings if necessary.
5. Click Apply to standardize the property across selected columns. Changes are shown in the data table, open reports, and open graphs.
   Or click OK to standardize the property across selected columns and close the column properties window.

Delete Properties

To delete the same properties across multiple columns

1. Select the column containing the attributes or properties that you want to delete.
2. Select Cols > Standardize Attributes.
3. Click Column Properties in the Delete Properties area and select the properties that you want to delete.
4. Click OK.

Example of Standardizing a Formula

If you have applied a formula to a column, and you want to apply that same formula to additional columns in the data table, use the **Substitute Column Reference** option.

**Note:** This option is dependent upon the location of the column that is referenced in the original formula. For example, if your original formula is based on the previous column, then any other formulas applied to additional columns are based on their previous columns.

For example, the Blood Pressure.jmp sample data table contains blood pressure measurements taken on five subjects three times each day, over a period of three days. You want to find the log of each blood pressure (BP) column.

1. Select **Help > Sample Data Library** and open **Blood Pressure.jmp**.

Create nine new columns, one for each existing BP column.

2. Select **Cols > New Columns**.
3. Add nine columns.
4. Click **OK**.

Apply your original formula as follows:

5. Right-click **Column 1** and select **Formula**.
6. Select **BP 8M**.
7. Select **Transcendental > Log**.
8. Click **OK**.

Column 1 now contains the log of the BP 8M column. You want the rest of the empty columns to contain the log of the remainder of the BP columns.

9. In the data table, select all of the new columns that you created, including the one with the original formula (columns 1-9).

10. Select **Cols > Standardize Attributes**.
11. In the Standardize Properties panel, click **Column Properties** and select **Formula**.
12. Select the check box next to **Substitute Column Reference**.
13. Click **OK**.

Now all of the new columns are populated with the log of the BP columns, in the order in which they appear. Column 1 contains the log for BP 8M, Column 2 contains the log for BP 12M, and so on.
Assign a Preselected Analysis Role

You can assign an analysis role, such as $x$, $y$, weight, or frequency, to a selected column and save the role with the data table. When you do this and then run an analysis, JMP uses the preselected role to automatically fill in the role boxes in windows. Then you do not have to specify these roles each time you run an analysis. For example, you might want a column named `height` to take the $x$ role in every analysis of that data table. To enforce the $x$ role, you assign the preselected role of $x$ to the column.

When you select Freq, the values in that column are what JMP uses as the frequency of the observation. If $n$ is the value of the Freq variable for a given row, then that row is used in computations $n$ times. If it is less than 1 or is missing, then JMP does not use it to calculate any analyses.

When you select Weight, the values in that column provide weights for each observation in the data table. The variable does not have to be an integer, but it is included only in analyses when its value is greater than zero.

To assign a preselected role to a column

1. Highlight the column.
2. Select Cols > Preselect Role.
3. Select a role: No Role, X, Y, Weight, or Freq.

After you select the appropriate roles, icons in the Columns panel signify what roles have been assigned. Click the icon to access a list of roles and select a different one. See "Icons Representing Column Characteristics and Properties" on page 39 in the “Get Started” chapter.
This chapter covers the following tasks that you can perform on JMP data:

- create a new data table from a subset of rows and columns
- sort by any number of columns
- stack multiple columns into a single column
- split a column into two or more columns
- transpose rows and columns
- concatenate multiple tables end to end
- join two tables side by side
- virtually join tables without physically joining them
- update columns in a table with values from another table
- anonymize the data

**Figure 6.1** Creating a Subset Data Table from a Report
Create a Subset Data Table

You can produce a new data table that is a subset of all rows and columns, only highlighted rows and columns, or randomly selected rows from the active data table.

To create a subset

1. Select Tables > Subset.

Figure 6.2 The Subset Window

2. Specify the content that you want to subset. Select any combination of the following:
   - Subset by (the levels within selected columns)
   - Rows (all, selected, or random)
   - Columns (all or selected)

   In Figure 6.2, the sex column will be subset.

3. Customize your subset table further using the additional options.

4. Click OK to create the subset table.
Subset Options

**Subset by**  Subsets by the levels of a column. Select **Subset by** and then select the columns that you want to categorize for the subset.

Consider the fact that many new data tables might be created. A new data table appears for each level of the column that you specified in the Subset window.

**All Rows**  Creates a subset table that contains all rows from the active table.

**Selected Rows**  Creates a subset table that contains only the selected rows from the active table. Selected by default.

**Random - sampling rate**  Creates a subset table whose data is a random proportion of the active data table. Enter the proportion of the sample that you want in the text box. For example, if you want a random 50% of the data to be included in the new table, enter 0.5 in the text box.

**Random - sample size**  Creates a subset table whose data is a random sample of the active data table. Enter the size of the sample that you want in the text box. For example, if you want 16 random rows to be included in the new table, enter 16 into the text box.

If you select a random sample that is the entire source table, the result is a random shuffle of the rows of the data table. If you specify columns to stratify, the result is a random shuffle of each of the rows for each group. See “Stratified Subsets” on page 264.

**All columns**  Creates a subset table that contains all columns from the active table. Selected by default.

**Selected columns**  Creates a subset table that contains only the selected columns from the active table.

**Keep by columns**  Retains the column that you subbed by in the output data tables.

**Output table name**  Specifies the name of the subset table.

**Link to original data table**  Links the subset table to the original table. When you change values in one table, the other table is updated.

**Copy formula**  Includes formulas from the original table in the output columns. Include all columns needed for the calculation of the formula. Selected by default.

**Suppress formula evaluation**  Prevents JMP from evaluating columns’ formulas when the new table is created. Selected by default.

**Save Default Options**  Saves your current settings.

---

**Note:** Save Default Options only saves the settings for Selected Rows, Selected Columns, Linked to original data table, Copy formula, and Suppress formula evaluation.

**Keep dialog open**  Keeps the Subset window open after you click OK.
Stratified Subsets

If you specify a sample size and add stratification columns, the sample size represents the size per stratum, rather than the size of the whole subset.

Figure 6.3 Stratified Subsets

For stratified random samples with a specified sample size, two columns can be saved: Selection Probability and Sampling Weight. Check the corresponding check box to save these columns.

Create a Subset Data Table from a Report

These two methods produce linked subsets of a data table.

Use a Histogram

Once you have produced output that contains a histogram (by selecting Analyze > Distribution), you can use the histogram to create a new data table. The new data table contains the data in the histogram’s highlighted bars.

To create a subset, double-click a highlighted bar. Or, right-click anywhere in the histogram and select Subset from the menu. The subset table appears, as shown in Figure 6.4.
Chapter 6
Using JMP

Reshape Data

Using JMP Sort Data Tables

Using a Pareto Plot

Once you have produced output that contains a Pareto Plot (by selecting Analyze > Quality and Process > Pareto Plot), you can use the Pareto Plot to create a new data table. The new data table contains the data in the Pareto Plot’s highlighted bars. To create a subset, double-click a highlighted bar.

Sort Data Tables

You can sort a JMP data table by columns in either ascending or descending order. By default, columns sort in ascending order. You can either create a new table that contains the sorted values, or you can replace the original table with the sorted table.

If columns contain value labels, sorting is based on the actual data values, not the value labels. (See “Value Labels” on page 238 in the “The Column Info Window” chapter.) However, the value labels are displayed in the sorted data table.

If your sorted column uses either the Value Ordering property or the List Check property, the column is sorted according to that order.

Example of Sorting Data Tables

1. Select Help > Sample Data Library and open Popcorn.jmp.
2. Select Tables > Sort.
3. Highlight the names of the columns that you want to sort by. For this example, select popcorn and yield.

4. Click By to add the columns to the sort list.

   The columns that you add to the list establish the order of precedence for sorting. The first column in the list is the major sort field. Each variable thereafter is sorted within the previous variable in the sort list. You can drag and drop within the By list to change the sort order.

5. Customize your sort further using the additional options. For this example, highlight yield and click the descending button.

6. Enter a name for the new sorted table in the box beside Output table name. For this example, enter sorted popcorn.

Figure 6.5 The Sort Window

7. Click OK.
Using JMP Stack Columns

Figure 6.7 Sorted in Ascending and Descending Order

<table>
<thead>
<tr>
<th>popcorn</th>
<th>oil ant</th>
<th>batch</th>
<th>yield</th>
<th>trial</th>
</tr>
</thead>
<tbody>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>18.0</td>
<td>1</td>
</tr>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>16.0</td>
<td>2</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>15.0</td>
<td>2</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>12.1</td>
<td>1</td>
</tr>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.8</td>
<td>2</td>
</tr>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.2</td>
<td>1</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.6</td>
<td>1</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
<td>2</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>10.6</td>
<td>1</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>10.4</td>
<td>1</td>
</tr>
<tr>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>10.1</td>
<td>2</td>
</tr>
<tr>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>9.9</td>
<td>1</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>8.8</td>
<td>2</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>8.8</td>
<td>2</td>
</tr>
<tr>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
<td>1</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>7.4</td>
<td>2</td>
</tr>
</tbody>
</table>

Sort Options

Select Columns Filter Menu Contains options to search and filter through columns. See “Column Filter Menu” on page 51 in the “Get Started” chapter.

Replace Table Replaces the original data table with the sorted table instead of creating a new table with the sorted values. This option is not available if there are any open report windows generated from the original table.

Output table name (Optional) Specifies the name of the sorted table.

Keep dialog open Keeps the Sort window open after you click OK.

By Adds the columns that you want to sort by. The columns that you add to the list establish the order of precedence for sorting. The first column in the list is the major sort field. Each variable thereafter is sorted within the previous variable in the sort list.

Remove Removes any highlighted columns.

Ascending and descending buttons (↑ [ ] ↓) You can change the ascending or descending list order of the values for the grouping variables. In the By variable list, select a variable and click the appropriate ascending or descending button. The icon beside the variable changes to indicate the sorting order.

Stack Columns

You can rearrange your data table by stacking two or more columns into a single new column, preserving the values from the other columns. Or, you can stack a set of columns into multiple groups. The various ways that you can stack columns are explained in “Stack Options” on page 268.
To stack columns, follow these steps:

1. Select **Tables > Stack**.

**Figure 6.8** Stack Window

2. Highlight the names of the columns that you want to stack and click **Stack Columns**.

3. Customize your stacking further using the additional options.

4. Click **OK**.

**Stack Options**

**Select Columns Filter Menu**  Contains options to search and filter through columns. See “**Column Filter Menu**” on page 51 in the “Get Started” chapter.

**Multiple series stack**  Stacks selected columns into two or more columns. Specify the number of columns into which you want the selected columns to be stacked by entering the number into the Number of Series box. This box appears when you check the box beside **Multiple series stack**.

Select the **Contiguous** option if the series consists of adjacent columns.

See “**Example of Stacking into More Than One Column**” on page 270.

---

**Note:** The order in which you add columns to the box on the right determines the group to which they belong.

**Stack by Row**  Stacks columns by rows. Deselect the option to stack one column underneath another. Selected by default.

**Eliminate missing rows**  Eliminates missing data from the new table. If Stack by Rows is checked also, only rows with all data missing are eliminated.
**Non-stacked columns**  Includes or drops non-stacked columns from the new data table. Select one of these options:

- **Keep All**  Includes all of the non-stacked columns from the original table in the new table. Selected by default.
- **Drop All**  Omits the non-stacked columns from the new table.
- **Select**  Select the non-stacked columns that you want to include or drop in the new table.

**Keep dialog open**  Keeps the Stack window open after you click **OK**.

**Stack Columns**  Adds the columns that you want to stack.

**Remove**  Removes any highlighted columns.

**Output table name**  (Optional) Specifies the name of the new table.

**Stacked Data Column**  Assigns a name to the column that will contain the data for the stacked columns. The default name is **Data**. Leave the box empty if you do not want this column to appear in the new table.

**Source Label Column**  Assigns a name to the column that will contain the original table’s column names. The default name is **Label**. Leave the box empty if you do not want this column to appear in the new table.

**Copy formula**  Includes formulas from the original table in the output columns. Selected by default.

**Suppress formula evaluation**  Prevents JMP from evaluating columns’ formulas when the new table is created. Selected by default.

**Example of Stacking into One Column**

A researcher has two columns in their data table representing yield, and they want to stack the two columns into a single column. (This new single column is called **Data** by default.)

1. Select **Help > Sample Data Library** and open Popcorn Trials.jmp.
2. Select **Tables > Stack**.
3. Select **yield1** and **yield2** and click **Stack Columns**.
4. Click **OK**.
Stacked Data Table

<table>
<thead>
<tr>
<th>popcorn</th>
<th>cll.amt</th>
<th>batch</th>
<th>Label</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 plain</td>
<td>little</td>
<td>large</td>
<td>yield1</td>
<td>8.2</td>
</tr>
<tr>
<td>2 plain</td>
<td>little</td>
<td>large</td>
<td>yield2</td>
<td>8.8</td>
</tr>
<tr>
<td>3 gourmet</td>
<td>little</td>
<td>large</td>
<td>yield1</td>
<td>8.8</td>
</tr>
<tr>
<td>4 gourmet</td>
<td>little</td>
<td>large</td>
<td>yield2</td>
<td>8.2</td>
</tr>
<tr>
<td>5 plain</td>
<td>lots</td>
<td>large</td>
<td>yield1</td>
<td>10.4</td>
</tr>
<tr>
<td>6 plain</td>
<td>lots</td>
<td>large</td>
<td>yield2</td>
<td>8.8</td>
</tr>
<tr>
<td>7 gourmet</td>
<td>lots</td>
<td>large</td>
<td>yield1</td>
<td>9.2</td>
</tr>
<tr>
<td>8 gourmet</td>
<td>lots</td>
<td>large</td>
<td>yield2</td>
<td>9.6</td>
</tr>
<tr>
<td>9 plain</td>
<td>little</td>
<td>small</td>
<td>yield1</td>
<td>9.9</td>
</tr>
<tr>
<td>10 plain</td>
<td>little</td>
<td>small</td>
<td>yield2</td>
<td>10.1</td>
</tr>
<tr>
<td>11 gourmet</td>
<td>little</td>
<td>small</td>
<td>yield1</td>
<td>12.1</td>
</tr>
<tr>
<td>12 gourmet</td>
<td>little</td>
<td>small</td>
<td>yield2</td>
<td>15.9</td>
</tr>
<tr>
<td>13 plain</td>
<td>lots</td>
<td>small</td>
<td>yield1</td>
<td>10.6</td>
</tr>
<tr>
<td>14 plain</td>
<td>lots</td>
<td>small</td>
<td>yield2</td>
<td>7.4</td>
</tr>
<tr>
<td>15 gourmet</td>
<td>lots</td>
<td>small</td>
<td>yield1</td>
<td>18.0</td>
</tr>
<tr>
<td>16 gourmet</td>
<td>lots</td>
<td>small</td>
<td>yield2</td>
<td>16.0</td>
</tr>
</tbody>
</table>

The Label column represents the Source Label Column that identifies the source of the data. Its values are the column names in the original table from which the stacked values originated.

Example of Stacking into More Than One Column

Suppose that a researcher has data on blood pressure readings. The readings were taken over three days: Monday, Wednesday, and Friday. Three readings were taken each day, at 8am, 12pm, and 6pm.

   
   Each BP (blood pressure) column is delineated according to the date and time. The BP 8M column corresponds to readings that were taken at 8am on Monday. The BP 12W column corresponds to readings that were taken on 12pm on Wednesday, and so on. The researcher wants to stack all of the blood pressure columns into three columns that correspond to each day: Monday, Wednesday, and Friday.

2. Select Tables > Stack.

3. Select all of the BP readings and click Stack Columns.
   
   The order of the columns reflects how the columns in the series should be grouped.

4. Select Multiple series stack.

5. Next to Number of Series, type 3.

6. Because you want to stack the columns vertically, select Contiguous.

7. Rename the Stacked Data Column from Data to BP (for blood pressure).

8. Rename the Source Label Column from Label to Day.
9. Click OK.

Figure 6.11 Stacked Data Table

<table>
<thead>
<tr>
<th>Subject</th>
<th>Dose</th>
<th>Day</th>
<th>BP 1</th>
<th>BP 2</th>
<th>BP 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>1</td>
<td>BP 8M</td>
<td>165</td>
<td>BP 8W</td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>1</td>
<td>BP 12M</td>
<td>174</td>
<td>BP 12W</td>
</tr>
<tr>
<td>3</td>
<td>A</td>
<td>1</td>
<td>BP 6M</td>
<td>180</td>
<td>BP 6W</td>
</tr>
<tr>
<td>4</td>
<td>A</td>
<td>2</td>
<td>BP 12M</td>
<td>172</td>
<td>BP 12W</td>
</tr>
<tr>
<td>5</td>
<td>A</td>
<td>2</td>
<td>BP 6M</td>
<td>180</td>
<td>BP 6W</td>
</tr>
<tr>
<td>6</td>
<td>A</td>
<td>2</td>
<td>BP 12M</td>
<td>172</td>
<td>BP 12W</td>
</tr>
<tr>
<td>7</td>
<td>A</td>
<td>3</td>
<td>BP 8M</td>
<td>180</td>
<td>BP 8W</td>
</tr>
<tr>
<td>8</td>
<td>A</td>
<td>3</td>
<td>BP 12M</td>
<td>172</td>
<td>BP 12W</td>
</tr>
<tr>
<td>9</td>
<td>A</td>
<td>3</td>
<td>BP 6M</td>
<td>180</td>
<td>BP 6W</td>
</tr>
<tr>
<td>10</td>
<td>A</td>
<td>4</td>
<td>BP 8M</td>
<td>180</td>
<td>BP 8W</td>
</tr>
<tr>
<td>11</td>
<td>A</td>
<td>4</td>
<td>BP 12M</td>
<td>172</td>
<td>BP 12W</td>
</tr>
<tr>
<td>12</td>
<td>A</td>
<td>4</td>
<td>BP 6M</td>
<td>180</td>
<td>BP 6W</td>
</tr>
<tr>
<td>13</td>
<td>A</td>
<td>5</td>
<td>BP 8M</td>
<td>180</td>
<td>BP 8W</td>
</tr>
<tr>
<td>14</td>
<td>A</td>
<td>5</td>
<td>BP 12M</td>
<td>172</td>
<td>BP 12W</td>
</tr>
<tr>
<td>15</td>
<td>A</td>
<td>5</td>
<td>BP 6M</td>
<td>180</td>
<td>BP 6W</td>
</tr>
<tr>
<td>16</td>
<td>B</td>
<td>1</td>
<td>BP 8M</td>
<td>171</td>
<td>BP 8W</td>
</tr>
<tr>
<td>17</td>
<td>B</td>
<td>1</td>
<td>BP 12M</td>
<td>176</td>
<td>BP 12W</td>
</tr>
<tr>
<td>18</td>
<td>B</td>
<td>1</td>
<td>BP 6M</td>
<td>180</td>
<td>BP 6W</td>
</tr>
<tr>
<td>19</td>
<td>B</td>
<td>2</td>
<td>BP 8M</td>
<td>175</td>
<td>BP 8W</td>
</tr>
<tr>
<td>20</td>
<td>B</td>
<td>2</td>
<td>BP 12M</td>
<td>175</td>
<td>BP 12W</td>
</tr>
<tr>
<td>21</td>
<td>B</td>
<td>2</td>
<td>BP 6M</td>
<td>180</td>
<td>BP 6W</td>
</tr>
</tbody>
</table>

In the stacked data table, note the following:

- The first Day column represents Monday.
- The Day 2 column represents Wednesday.
- The Day 3 column represents Friday.
Split Columns

You can create a new data table from the active table by splitting one column into several new columns. This column is split according to the values found in another column, referred to as the **Split By** column. You can also split columns according to the values of one or more grouping variables.

**Note:** If the split is on a categorical column that contains a missing value, the column name for the missing category is “.” for a numeric column.

To split columns, follow these steps:

1. Select **Tables > Split**.

**Figure 6.12** Split Window

2. Highlight the names of the column or columns that you want to split and click **Split Columns**.

3. Highlight a column whose values you want to use as the basis for splitting the column.

4. Click **Split By**.

5. Customize your splitting further using the additional options.

6. Click **Split**.

**Split Options**

**Select Columns Filter Menu** Contains options to search and filter through columns. See “**Column Filter Menu**” on page 51 in the “Get Started” chapter.

**Keep All** Includes all columns in the new table.
Split Columns

Drop All  Includes only columns used in the split in the new table. Selected by default.

Select  Selects which columns to keep in the new table and then select which columns to keep in the new table.

Keep dialog open  Keeps the Split window open after you click OK.

Split By  Adds the column whose values you want to use as the new column names, and as the basis for splitting the column.

Split Columns  Adds the column or columns that you want to split.

Group  Specifies a Group variable when you want your data to be split within each group of the selected variable. Each group results in a row in the output table. You must also specify the required variables, Split By, and Split Columns.

Caution: If your grouping variable contains unequal groups, or if your grouping variable is not grouped in order (is random), then you must specify a Group variable. The Group variable ensures that your data is restructured properly.

Sort by Column Property  (Appears if a Value Ordering or Row Order Levels property is found) Sorts the order of the output columns by the Value Ordering or Row Order Levels column property. Value Ordering takes precedence over Row Order Levels. If the column has neither property, and the data has an implied order (such as days or months), the implied order is applied.

Output table name  (Optional) Specifies the name of the new table.

Copy formula  (Appears if there is a formula in the data table) Includes formulas from the original table in the output columns.

Suppress formula evaluation  (Appears if there is a formula in the data table) Prevents JMP from evaluating columns’ formulas when the new table is created.

Examples of Splitting Columns

This section contains two examples using the Split command:

• In the first example, one column is split by a second column. See “Split a Column: Basic Example” on page 273.
• The second example uses a Group variable. See “Split a Column: Grouping Rows Example” on page 274.

Split a Column: Basic Example

In the Popcorn.jmp data table, the data in the trial column shows that there are two trials, 1 and 2. In this example, split the yield column into two new columns: one for trial 1 and one for trial 2. Proceed as follows:
1. Select Help > Sample Data Library and open Popcorn.jmp.
2. Select Tables > Split.
3. Select the yield column and click Split Columns.
4. Select the trial column and click Split By.
5. Under Remaining columns, select Keep All.
   The default is Drop All, which omits any columns that are not in the Split By, Split Columns, or Group fields. Selecting Keep All includes these columns in the new table.
6. (Optional) Type Yield column split by Trial column in the Output table name field.
7. Click OK.

A new data table is created. See Figure 6.13. Notice the following:
- The yield and trial columns are gone.
- The data table has two new columns, named after the unique values (1 and 2) from the original trial column.
- The values from the original yield column are now split into the new columns named 1 and 2.
- The columns other than trial and yield are exactly the same as they were in the original table.
8. (Optional) Rename the new columns to give them meaningful names. For example, rename 1 to yield (trial 1) and rename 2 to yield (trial 2).

Figure 6.13 New Table Created By Splitting yield Column by trial Column

<table>
<thead>
<tr>
<th>popcorn</th>
<th>oil amount</th>
<th>batch</th>
<th>1</th>
<th>2</th>
</tr>
</thead>
<tbody>
<tr>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>2.2</td>
<td>8.8</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.6</td>
<td>8.2</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>10.4</td>
<td>8.0</td>
</tr>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.2</td>
<td>9.8</td>
</tr>
<tr>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>9.9</td>
<td>10.1</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>12.1</td>
<td>15.3</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>10.8</td>
<td>7.4</td>
</tr>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>18.0</td>
<td>16.0</td>
</tr>
</tbody>
</table>

Split a Column: Grouping Rows Example

The Drug Measurements.jmp sample data table contains measurements of three different drugs (a, b, and c) administered to 12 different subjects. You want to split the measurement into different columns, one for each drug type. You also want to group the measurements by subject.

1. Select Help > Sample Data Library and open Drug Measurements.jmp.
2. Select Tables > Split.
3. Select Drug Type and click **Split By**.

4. Select Measurement and click **Split Columns**.

Notice that the Subject variable contains unequal groups. Most of the subjects were given all three drugs, but subject 2 was given only one drug, and subjects 7 and 12 were given only two drugs. In this situation, to ensure that the correct measurements are associated with the correct subject, specify Subject as the Group variable.

5. Select Subject and click **Group**.

6. Click OK.

![Figure 6.14 Drug Measurements.jmp Split by a Grouping Variable](image)

You can see that the appropriate missing values appear for subjects 2, 7, and 12.

### Transpose Rows and Columns

You can create a new JMP table that is a transposed version of the active data table. The columns of the active table are the rows of the new table, and its rows are the new table’s columns.

When you transpose columns, you do the following:

- Select the columns to be transposed.
- Specify a “label” column, from which the new columns get their names (optional).
- Specify “by” columns, which tells JMP to transpose data within groups (optional).

**Note:** Columns that you want to transpose must have the same data type. Also, if columns contain value labels, transposing uses the actual data values, not the value labels. (See “Value Labels” on page 238 in the “The Column Info Window” chapter.)
To transpose rows and columns, follow these steps:

1. Open a data table that contains the rows and columns that you want to transpose.
2. Select Tables > Transpose.

**Figure 6.15 Transpose Window**

3. Highlight the column name(s) you want to transpose in the Select Columns box on the left.
4. Click Transpose Columns.
5. (Optional) Customize your transposed table further using the additional options.
6. Click OK.

**Transpose Options**

- **Select Columns Filter Menu** Contains options to search and filter through columns. See “Column Filter Menu” on page 51 in the “Get Started” chapter.
- **Transpose selected rows only** Transposes only rows that are currently highlighted in the active table.
- **Output table name** (Optional) Specifies the name of the subset table.
- **Label column name** (Applicable only if you have specified a Label column.) Specifies an alternative name for the Label column. Otherwise, the default column name is **Label**.
- **Keep dialog open** Keeps the Transpose window open after you click **OK**.
- **Transpose Columns** Adds the columns that you want to transpose.
- **Label** Uses the data from a column in the original table as the column names in the new table. Follow these steps:
  1. Highlight a column from the Select Columns box on the left.
2. Click **Label**. The column name appears in the Label box.

The default column name is **Label**. You can specify an alternative name for the column using the **Label column name** option. Only one column is created for each distinct value in the label column. Therefore, if there are duplicate values in the label column, JMP creates only one column for the duplicated value using the value from the last duplicated row.

**By** Organizes the transposed columns into groups based on the columns that you put into the By box. Follow these steps:

1. Highlight the column name(s) in the Select Columns box whose values you want to see as a group.
2. Click **By**.

Table 6.1 describes the rules that apply to transposing.

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>The original table has columns but no rows</td>
<td>The new table contains one column that lists those column names.</td>
</tr>
<tr>
<td>The original table has one column and it is assigned to Label</td>
<td>Its values become the column names in the transposed table.</td>
</tr>
<tr>
<td>The original table has multiple columns and contains a label column</td>
<td>JMP automatically inserts the label column into the Label box when the window appears. You can remove this column if you do not want it to appear.</td>
</tr>
<tr>
<td>There is no label column in the original table</td>
<td>The column names in the transposed table are Row 1, Row 2, ..., Row n where n is the number of rows in the original table.</td>
</tr>
</tbody>
</table>

**Examples of Transposing Rows and Columns**

This section contains three examples: a simple example of transposing, an example using the Label option, and an example using a By group.

**Simple Example of Transposing**

1. Select **Help > Sample Data Library** and open Materials1.jmp.
2. Select **Tables > Transpose**.
3. Select plastic, tin, and gold and click **Transpose Columns**.
4. Click **OK**.
### Figure 6.16 Simple Transposed Table

<table>
<thead>
<tr>
<th>Label</th>
<th>Row 1</th>
<th>Row 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>plastic</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>tin</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>gold</td>
<td>3</td>
<td>6</td>
</tr>
</tbody>
</table>

The original table in Figure 6.16 has two rows and three continuous columns called plastic, tin, and gold. The transposed table has a row for each of the three columns in the original table, and columns named Row 1 and Row 2 for the original table’s rows. The additional column called Label has the column names (plastic, tin, and gold) from the original table as values.

### Example Using the Label Option

1. Select Help > Sample Data Library and open Materials2.jmp.
2. Select Tables > Transpose.
3. Select plastic, tin, and gold and click Transpose Columns.
4. Select item and click Label.
5. Click OK.

### Figure 6.17 Transpose with a Label

<table>
<thead>
<tr>
<th>Label</th>
<th>nails</th>
<th>hooks</th>
</tr>
</thead>
<tbody>
<tr>
<td>plastic</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>tin</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>gold</td>
<td>3</td>
<td>6</td>
</tr>
</tbody>
</table>

The values from the item column in the original table are used as column labels in the transposed table.

### Example Using a By Group

1. Select Help > Sample Data Library and open Animals Subset.jmp.
2. Select Tables > Transpose.
3. Select subject and miles and click Transpose Columns.
4. Select season and click Label.
5. Select species and click By.
6. Click OK.
Chapter 6
Using JMP

Reshape Data
Concatenate Data Tables

Figure 6.18 Transpose Using a By Group

The transposed table contains values that have been transposed in groups.

Concatenate Data Tables

When you concatenate data tables in JMP, you combine rows from two or more data tables. You can create a new data table or you can append rows to the first data table. A column name might be the same in the data tables that you want to concatenate. If so, then the column in the new data table lists the values from all of the data tables in the order of concatenation. If the two original data tables have columns with different names, those columns are included in the new data table showing missing values.

To concatenate two data tables with the same column names, follow these steps:

1. Select Tables > Concatenate.

Figure 6.19 Concatenate Window

2. Highlight the names of the data tables that you would like to combine, and click Add. You can concatenate as many data tables as you choose, and you can also add the same data tables multiple times. The number of rows in the new data tables is the sum of the number of rows in all the data tables.

3. (Optional) Click the Save and evaluate formulas choice to request that JMP include all formulas.

If you do not select this option, no formulas are included in the new data table.
Reshape Data
Chapter 6
Concatenate Data Tables

**Note:** Columns with the same name can have different formulas. The formula from the first data table that contains a formula for that column is saved in the concatenated data table. This situation can occur when more than two tables are being concatenated and the second or third on has a formula for the column in question.

4. (Optional) Click the **Create source column** choice to add a column called **Source Table** to the new data table.
   
   This column identifies the name of the source data table in the corresponding rows.

5. (Optional) Select the **Append to first table** choice to append rows to the data table listed first in the **Data Tables to be Concatenated** field. This option is an alternative to creating a new data table.

6. (Optional) Enter a name for the new data table in the **Output table name** field.
   
   If you do not enter a name, JMP names the data table **Untitled** (for example, **Untitled1**). The **Output table name** field is not available if you selected the **Append to first table** choice.

7. Click **OK**.

**Example of Concatenating Data Tables**

Suppose that you want to concatenate two data tables (Trial1 and Trial2) into a new data table.

1. Select **Help > Sample Data Library** and open Trial1.jmp and Trial2.jmp.
2. From the Trial1.jmp table, select **Tables > Concatenate**.
3. In the **Opened Data Table** list, select Trial2 and click **Add**.
4. Click **OK**.

The data tables combine into a new concatenated table with all of the rows from the first data table followed by all of the rows from the second data table. See Figure 6.20.
Concatenated data tables always contain a column for every column name found in the original data tables. However, if the column names do not match exactly, they are not merged. For example, if the yield column was instead named yield1 and yield2, a separate column would be created for each in the concatenated data table.

When you concatenate two or more data tables containing table variables, separate columns are created for each table variable. This ensures that important distinctions are not lost when concatenating data tables.

**Note:** Columns are not created for table variables that begin with the name Notes.

### Example of Concatenating Data Tables and Table Variables

For example, suppose that two cancer trials were conducted at two different hospitals. One of the trials’ data is in the Cancer1.jmp data table, and the other trial’s data is in the Cancer2.jmp data table.

To consolidate the data and the variables into one table, follow these steps:

1. Select Help > Sample Data Library and open Cancer1.jmp and Cancer2.jmp.

   Notice that there are two distinct table variables: Dosage Amount and Location. In the concatenated table, columns are created for these two table variables.

2. From the Cancer1.jmp data table, select Tables > Concatenate.

3. Select Cancer2 and click Add.

4. Click OK.
Chapter 6
Using JMP

Join Data Tables

You can combine two data tables into one new table by selecting Tables > Join. For an overall description of how to join two data tables, see “To join two data tables into a new data table, follow these steps:” on page 282. Tables can be joined in three different ways:

- By combining them according to row number. See “Example of Joining by Row Number” on page 285.
- In a Cartesian fashion, where you form a new table consisting of all possible combinations of the rows from two original tables. See “Examples of a Cartesian Join” on page 287.
- By matching the values in one or more columns that exist in both data tables, or in a single data table. See “Examples of Joining By Matching Columns” on page 289.

Note: The JMP Query Builder option in the Tables menu provides an option to query data before performing a simple join. See “Query and Join Data Tables with JMP Query Builder” on page 293 in the “Reshape Data” chapter for details.

To join two data tables into a new data table, follow these steps:

1. Open the two data tables that you want to join.
2. Select Tables > Join.

In the window that appears, the names of all open tables appear below Join...with, as shown in Figure 6.22.
Chapter 6
Using JMP

Reshape Data
Join Data Tables

283

Figure 6.22 The Join Window

3. In the **Join...with** box, select the table to join with the active table.
4. From the Matching Specification area, select the option that specifies how to join the tables.
5. Enter the name of the new table in the text box beside **Output table name**.
6. (Optional) Customize the join procedure further using the additional options.
7. Click **OK** to create the joined data table.

**Join Options**

**Keep dialog open** Keeps the Join window open after you click **OK**.

**Preserve main table order** Maintains the order of the original data table in the joined table, instead of sorting by the matching columns. Selected by default.

**Update main table with data from second table** Column data from the second table change the data of the same name columns in the original table.

Note the following:

- JMP does not replace data with missing values.
- The output table uses the same columns as the original table. Thus, when you use **Update main table with data from second table**, **Select Columns for joined table** is not applicable.
- The **Update main table with data from second table** option is available only when joining by row number or by matching columns.
Merge same name columns  Data from the second table replaces the data of the same name columns in the original table. Note that missing values in the first table are replaced by nonmissing values in the second.

If you are matching by column, Match Flag is selected when you select Merge same name columns. The new joined table contains a nominal column named Match Flag:

- If a one (1) appears in this column, the data originated from the first (active) table.
- If a two (2) appears in this column, the data originated from the second table.
- If a three (3) appears in this column, the data was found in both the first and second tables.

Match flag  Omits the Match Flag column from the joined data table when you are matching by column.

Copy formula (Main Table and Second Table)  Includes formulas from the main table and/or the second table in the output columns. Selected by default.

Suppress formula evaluation (Main Table and Second Table)  Prevents JMP from evaluating columns’ formulas during the creation of the new table. Selected by default.

By Matching Columns  To join rows, select columns in both tables whose values and data types match. Follow these steps:

1. Highlight a column name from each list in the Source Columns area. The first highlighted column in the top list pairs with the first highlighted column in the bottom list, the second columns are paired, and so on. Rows join only if values and data types match for all the column pairs.

2. Click Match. The selected pair of columns appears in the Match columns box. Matching columns do not have to have the same names and do not have to be in the same relative column position in both tables.

3. (Optional) To include only the first match found, check the boxes associated with Drop multiples in both tables. Only the first match found is written to the new table. If you specify this option for one table, the first match value is joined with all matches in the other table. If you do not check the boxes associated with Drop multiples in either table, a Cartesian join is performed within each group of matching column values.

4. (Optional) To include all rows from the data table, even when there is no matching value, check the boxes associated with Include non-matches. You can specify this option for either or both data tables being joined.

By Row Number  Joins the two tables side by side.

Cartesian Join  Joins two tables using a Cartesian fashion, where it forms a new table consisting of all possible combinations of the rows from two original tables. JMP crosses the data in the first table with the data in the second to display all combinations of the values in each set.
Select Columns for joined table  Selects a subset of columns from either table for inclusion in the output table. Follow these steps:

1. In the Source Columns area, highlight the columns from each table that you want to include in the new table.
2. Click Select in the Output Columns area.

Output table name  Specifies the name of the joined table.

Examples of Joining Data Tables

The following sections provide examples using the Join command.

Example of Joining by Row Number

Joining tables by row number joins the two tables side by side. The new table has all of the columns from both tables, unless you specify to include only certain columns.

To join tables with an unequal number of rows

If the two tables that you want to join have an unequal number of rows, the new table contains values for the rows found in both tables.

1. Select Help > Sample Data Library and open Species1.jmp and Species2.jmp.
2. From the Species1.jmp table, select Tables > Join.
3. In the Join...with box, select Species2.
4. From the Matching Specification area, select By Row Number.
5. Click OK.

Figure 6.23  Joined Tables by Row Number

<table>
<thead>
<tr>
<th>species</th>
<th>season</th>
</tr>
</thead>
<tbody>
<tr>
<td>FOX</td>
<td>spring</td>
</tr>
<tr>
<td>COYOTE</td>
<td>summer</td>
</tr>
<tr>
<td></td>
<td>fall</td>
</tr>
<tr>
<td></td>
<td>winter</td>
</tr>
</tbody>
</table>

If one table with two rows is joined with a table with four rows, then the new table contains four rows.

To join columns with the same name

If the two tables have column names that are the same, the names of these columns in the new table appear as “column name of table name.” For example, suppose that you want to combine
Chapter 6
Using JMP

Join Data Tables

the eight rows from the Trial1.jmp and Trial2.jmp data tables shown in Figure 6.24 into a single table. You want to combine them so that the new table contains all of the columns from both tables.

1. Select Help > Sample Data Library and open Trial1.jmp and Trial2.jmp.
2. From the Trial1.jmp data table, select Tables > Join.
3. In the Join...with box, select Trial2.
4. From the Matching Specification menu, select By Row Number.
5. Click OK.

Figure 6.24 Original Tables and the Joined Table

A column name can be the same in the two original tables. The output column name is then qualified by the source table name. For example, the column names in the new table appear as 
<variable name> of table name.

To join only specified columns

Suppose that you do not want all of the columns from the original data tables to be in the joined table. Proceed as follows:

1. Select Help > Sample Data Library and open Trial1.jmp and Trial2.jmp.
2. From the Trial1.jmp data table, select Tables > Join.
3. In the Join...with box, select Trial2.
4. From the Matching Specification menu, select By Row Number.
5. Click Select columns for joined table to specify the subset of columns that you want to include.
6. In the Source Columns list, select popcorn and yield from the Trial1 list and select yield from the Trial2 list.
   
   Because identical data exists in the popcorn column of both tables, you need to select only one column.
7. Click Select.
8. Click OK.
Chapter 6
Using JMP

Reshape Data
Join Data Tables

287

Figure 6.25 Joining Only Specified Columns

<table>
<thead>
<tr>
<th>popcorn</th>
<th>yield of Trial1</th>
<th>yield of Trial2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 plain</td>
<td>8.2</td>
<td>8.3</td>
</tr>
<tr>
<td>2 gourmet</td>
<td>8.6</td>
<td>8.2</td>
</tr>
<tr>
<td>3 plain</td>
<td>10.4</td>
<td>8.3</td>
</tr>
<tr>
<td>4 gourmet</td>
<td>9.2</td>
<td>9.8</td>
</tr>
<tr>
<td>5 plain</td>
<td>9.9</td>
<td>10.1</td>
</tr>
<tr>
<td>6 gourmet</td>
<td>12.1</td>
<td>15.9</td>
</tr>
<tr>
<td>7 plain</td>
<td>10.6</td>
<td>7.4</td>
</tr>
<tr>
<td>8 gourmet</td>
<td>18.0</td>
<td>16.0</td>
</tr>
</tbody>
</table>

Examples of a Cartesian Join

When doing a Cartesian join, JMP joins two tables in a Cartesian fashion: the new table consists of all possible combinations of the rows from two original tables. This creates cases in the output table where there are one case for each combination of column values.

Simple Example of a Cartesian Join

1. Select Help > Sample Data Library and open Species1.jmp and Species2.jmp.
2. From the Species1.jmp table, select Tables > Join.
3. In the Join...with box, select Species2.
4. From the Matching Specification menu, select Cartesian Join.
5. Click OK.

Figure 6.26 Joining Tables Using Cartesian Join

<table>
<thead>
<tr>
<th>species</th>
<th>season</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 FOX</td>
<td>spring</td>
</tr>
<tr>
<td>2 FOX</td>
<td>summer</td>
</tr>
<tr>
<td>3 FOX</td>
<td>fall</td>
</tr>
<tr>
<td>4 FOX</td>
<td>winter</td>
</tr>
<tr>
<td>5 COYOTE</td>
<td>spring</td>
</tr>
<tr>
<td>6 COYOTE</td>
<td>summer</td>
</tr>
<tr>
<td>7 COYOTE</td>
<td>fall</td>
</tr>
<tr>
<td>8 COYOTE</td>
<td>winter</td>
</tr>
</tbody>
</table>

The data in Species1.jmp is crossed with the data in Species2.jmp to produce the joined table, which shows all combinations of the values in each set.

Complex Example of a Cartesian Join

In this example, use the Tables > Join command twice:

- The first join combines the Oil Amount.jmp table with the Batch.jmp table using the Cartesian option.
The second join combines the resulting table (Cartesian oil amount + batch) with the Popcorn Type.jmp table and produces a final table with all tables joined.

1. Select Help > Sample Data Library and open Oil Amount.jmp, Batch.jmp, and Popcorn Type.jmp.
2. From the Oil Amount.jmp table, select Tables > Join.
3. In the Join...with box, select Batch.
4. From the Matching Specification menu, select Cartesian Join.
5. Under Output table name, type Oil Amount and Batch.
6. Click OK.

Figure 6.27 Oil Amount and Batch Joined Table

<table>
<thead>
<tr>
<th>oil amount</th>
<th>batch</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>little</td>
</tr>
<tr>
<td>2</td>
<td>little</td>
</tr>
<tr>
<td>3</td>
<td>lots</td>
</tr>
<tr>
<td>4</td>
<td>lots</td>
</tr>
</tbody>
</table>

The joined table contains all of the columns from the Oil Amount.jmp and Batch.jmp tables. Add the Popcorn Type.jmp columns, as follows:

7. From the Oil Amount and Batch table that you just created, select Tables > Join.
8. In the Join...with box, select Popcorn Type.
10. Click OK.

Figure 6.28 Oil Amount and Batch Joined with Popcorn Type

<table>
<thead>
<tr>
<th>oil amount</th>
<th>batch</th>
<th>popcorn</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>little</td>
<td>gourmet</td>
</tr>
<tr>
<td>2</td>
<td>little</td>
<td>plain</td>
</tr>
<tr>
<td>3</td>
<td>little</td>
<td>gourmet</td>
</tr>
<tr>
<td>4</td>
<td>little</td>
<td>plain</td>
</tr>
<tr>
<td>5</td>
<td>lots</td>
<td>gourmet</td>
</tr>
<tr>
<td>6</td>
<td>lots</td>
<td>plain</td>
</tr>
<tr>
<td>7</td>
<td>lots</td>
<td>gourmet</td>
</tr>
<tr>
<td>8</td>
<td>lots</td>
<td>plain</td>
</tr>
</tbody>
</table>

The final table contains all of the columns from all three original tables. Keep in mind that the number of rows produced by a Cartesian join is the product of the number of rows in the original tables.
Examples of Joining By Matching Columns

When you join data tables by matching columns, JMP finds specified column values that exist in both tables. All values associated with the specified column values are combined into a new data table.

In order to join by matching columns, the columns must have the same data type (numeric, character, or row state).

You can also join a data table to itself, in order to remove duplicate values or rows from the data table.

To join tables with the same rows in a different order

1. Select Help > Sample Data Library and open Students1.jmp and Students2.jmp.
   - The Students1.jmp data table contains names, ages, and sexes of the students. The Students2.jmp data table contains names, height, and weight of the students. Instead of working with two separate tables, you would like to combine the tables into one. Notice that the students’ names are not in the same order in both tables. For example, Alice is in row 7 and row 9.

2. From the Students1.jmp data table, select Tables > Join.

3. In the Join...with box, select Students2.
   - Because both tables have one column (name) that contains the same values, you need to tell JMP that they are matches. JMP then examines each of the values in the name column of the first table to determine whether there was a corresponding value in the second table’s name column. For example, it detects that Alice is located in both tables. It creates a name column in the new table with Alice as a value. It then takes the age and sex of Alice from table one and puts it in the new table. Then it takes the height and weight of Alice and puts them in the new table.


5. From the Students1 and Students2 lists, select name.

6. Click Match.

7. You want the new table to contain only one row for each name, so select the Drop multiples boxes for both tables.

8. Click OK.
To join tables with different numbers of rows and different column names

Suppose that Sarah and Joe are performing a popcorn experiment. They are popping different types of popcorn (gourmet and plain) in different amounts of oil. They are recording the amount (yield) of popcorn that is produced. Sarah gave you the first trial data in a file named Trial1.jmp. Joe gave you the second trial data in a file named Little.jmp. You want to combine the two tables into one table.

1. Select Help > Sample Data Library and open Trial1.jmp and Little.jmp.
2. From the Trial1.jmp table, select Tables > Join.
3. In the Join...with box, select Little.
   
   You can see that three of the columns (popcorn, oil amt/oil, and batch) contain the same values in both tables. Identify these columns as matches. Also, because Sarah and Joe gave the oil and oil amt columns different names, you can tell JMP that oil amt and oil match.
4. Deselect Preserve main table order.
   
   The joined table is sorted by matching columns, not by the order of data in Trial1.jmp,
5. Select By Matching Columns in the Matching Specification area.
6. From the Trial1 list, select popcorn, oil amt, and batch.
7. From the Little list, select popcorn, oil, and batch.
8. Click Match.

Looking at the two data tables, you can see that they have different numbers of rows. Trial1.jmp has values for eight experimental conditions, and Little.jmp has values for only four of those conditions. Sarah completed her experiment, but Joe only partially completed his experiment. You want the joined table to contain all of the rows in Trial1.jmp, even if that row in the Little.jmp table contains a missing value.
9. Select the Include non-matches boxes for both tables.
In the joined table, you want only one column for popcorn, one column for oil, and one column for batch. However, you want two columns for yield: one representing the yield from Trial1.jmp, and another representing the yield from Little.jmp.

10. Select the box beside **Select columns for joined table**.

11. From the Trial1 list, select all of the columns.

12. Click **Select**.

13. From the Little list, select yield.

14. Click **Select**.

**Figure 6.30** Completed Join Window

15. Click **OK**.
Figure 6.31  Trial1.jmp and Little.jmp Joined

<table>
<thead>
<tr>
<th></th>
<th>popcorn</th>
<th>oil</th>
<th>batch</th>
<th>yield of Trial1</th>
<th>yield of Little</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.6</td>
<td>8.2</td>
</tr>
<tr>
<td>2</td>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>12.1</td>
<td>15.9</td>
</tr>
<tr>
<td>3</td>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.2</td>
<td>*</td>
</tr>
<tr>
<td>4</td>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>18.0</td>
<td>*</td>
</tr>
<tr>
<td>5</td>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
<td>8.8</td>
</tr>
<tr>
<td>6</td>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>9.9</td>
<td>10.1</td>
</tr>
<tr>
<td>7</td>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>10.4</td>
<td>*</td>
</tr>
<tr>
<td>8</td>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>10.6</td>
<td>*</td>
</tr>
</tbody>
</table>

The joined table is sorted by the matching columns. Note that the yield column from the Little.jmp table (Yield of Little) has missing values indicating no matching values with the Trial1.jmp table.

To join a table to itself (to remove duplicate entries)

1. Select Help > Sample Data Library and open Coffee Shop Purchases.jmp.
   You can see that some of the customers had the same drink on the same date. You want to consolidate these duplicate rows using Join.
2. Select Tables > Join.
3. In the Join...with box, select Coffee Shop Purchases.
5. From both Coffee Shop Purchases lists, select all three columns: Date, Customer, and Beverage.
6. Click Match.
7. Select the Drop multiples boxes for both tables (the Main Table and the With Table).
8. Type Coffee Shop Purchases Final for the Output table name.
9. Click OK.
Chapter 6  
Using JMP  
Reshape Data  

Using JMP Query and Join Data Tables with JMP Query Builder

Figure 6.32  Original and Joined Coffee Shop Purchases Data Tables

<table>
<thead>
<tr>
<th>Date</th>
<th>Customer</th>
<th>Beverage</th>
</tr>
</thead>
<tbody>
<tr>
<td>01/05/2013</td>
<td>Jeff</td>
<td>Espresso</td>
</tr>
<tr>
<td>01/05/2013</td>
<td>Mike</td>
<td>Chai tea</td>
</tr>
<tr>
<td>01/05/2013</td>
<td>Sergio</td>
<td>Latte</td>
</tr>
<tr>
<td>01/05/2013</td>
<td>Mike</td>
<td>Espresso</td>
</tr>
<tr>
<td>01/05/2013</td>
<td>Lisa</td>
<td>Espresso</td>
</tr>
<tr>
<td>02/13/2013</td>
<td>Lisa</td>
<td>Chai tea</td>
</tr>
<tr>
<td>02/13/2013</td>
<td>Mike</td>
<td>Chai tea</td>
</tr>
<tr>
<td>02/13/2013</td>
<td>Sergio</td>
<td>Espresso</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Date</th>
<th>Customer</th>
<th>Beverage</th>
</tr>
</thead>
<tbody>
<tr>
<td>01/05/2013</td>
<td>Jeff</td>
<td>Espresso</td>
</tr>
<tr>
<td>01/05/2013</td>
<td>Mike</td>
<td>Chai tea</td>
</tr>
<tr>
<td>01/05/2013</td>
<td>Sergio</td>
<td>Latte</td>
</tr>
<tr>
<td>01/05/2013</td>
<td>Mike</td>
<td>Espresso</td>
</tr>
<tr>
<td>01/05/2013</td>
<td>Lisa</td>
<td>Espresso</td>
</tr>
<tr>
<td>02/13/2013</td>
<td>Lisa</td>
<td>Chai tea</td>
</tr>
<tr>
<td>02/13/2013</td>
<td>Mike</td>
<td>Chai tea</td>
</tr>
<tr>
<td>02/13/2013</td>
<td>Sergio</td>
<td>Espresso</td>
</tr>
</tbody>
</table>

Query and Join Data Tables with JMP Query Builder

The JMP Query Builder option in the Tables menu enables you to query data tables and save selected data into a new data table. This feature is similar to using the Join command but lets you perform queries before saving the data. For example, you can query SAT data and save only data for 2004 test scores in a data table. You can also include a prompt that lets the user run the query and choose a subset of the 2004 test scores.

1. Select Help > Sample Data Library and open SAT.jmp and SATByYear.jmp.
2. Display SATByYear.jmp.
3. Select Tables > JMP Query Builder.
   The current data table, SATByYear.jmp, is selected as the Primary table.
4. Select SAT.jmp in the Available Tables list and click Secondary.
5. Select SAT.jmp next to the Secondary button and view the Columns tab. The Join column shows that two columns have the same name and were joined.
Figure 6.33  Joined Columns

6. Click **Build Query**.

**Add Columns**

2. Click **Add**.
   
   The columns are added to the Included Columns tab.
3. Select **Distinct rows only** to avoid saving duplicate rows.
4. On the Query Preview tab, make sure that **Update preview automatically** is selected so that you can see the selected columns.

**Add Filters**

1. In the Included Columns list, select t2.2004 Verbal and t2.2004 Math, and then click **Add Selected Items to Filter**.
   
   The columns are added to the Filters list.

Figure 6.34  Selected Filters
2. Click the red triangle next to each filter and select **Prompt on Run**. Accept the default prompt message.

**Run the Query**

1. Click **Run Query**.
   
   You are prompted to indicate which math and verbal scores to save in the data table. To save all data, do not change the values in the prompt window.

2. Click **OK** to create the data table.

**Figure 6.35** Queried Data

![Table showing data](image)

See “Build SQL Queries in Query Builder” on page 102 in the “Import Your Data” chapter for more information about features that also appear in Query Builder for databases.

**Tips:**

- To join data from different sources (for example, a database and Microsoft Excel), use Query Builder to import the database data into a data table; import the Excel data into a data table; and use JMP Query Builder in the Tables menu to query and join the tables.
- When you open a query, data tables in the query open as hidden files that you can open from the JMP Home Window. You can also open the hidden files from the Table panel when you build the query.

**About Links to Data Tables in JMP Queries**

When you query data tables, the resulting data table contains scripts for rerunning the query, updating the data, and editing the query. Data tables in these scripts have *absolute paths*. For example, the following portion of these scripts defines where two JMP sample data tables are stored.

```javascript
JMP Tables(
   ["SAT" => "C:\Program Files\SAS\JMPPRO\13\Samples\Data\SAT.jmp",
    "SATByYear" => "C:\Program Files\SAS\JMPPRO\13\Samples\Data\SATByYear.jmp"]
),
```
However, when you save a query as a .jmpquery file, the file contains relative paths to the original data tables if it is possible to create them. The following example shows data tables that are stored in the FuelData subfolder that is relative to the .jmpquery file.

```
JMP Tables( [
  "Cars" => "FuelData\Cars.jmp",
  "Trains" => "FuelData\Trains.jmp"
] )
```

In the .jmpquery file, if a relative path cannot be created, an absolute path is used with path variable substitutions if possible. When you run the query, you are prompted to select the data table if the table cannot be found. JMP then detects whether other missing data tables in the query are in the selected folder.

You can also use path variables to locate the data tables. For example, you might write a script that selects a data table in the $DOCUMENTS folder. Or you can define a path variable in a JSL script and then run a query from the script. See the Types of Data chapter in the Scripting Guide for details about path variables.

---

**Virtually Join Data Tables**

Virtual Join links a main data table to one or more auxiliary data tables. This feature enables the main data table to access data from the auxiliary data tables without physically joining the tables. Virtually joining tables saves memory, because the same data are not replicated in every table that references them. And updating linked data is simpler; linked data can be independently updated in the source table without being updated in the referencing table.

The Link ID and Link Reference column properties make the linking possible.

- The Link ID column property marks a column in the auxiliary data table as the ID column. That is, the rows of the data table are uniquely identified by the values of the ID column. The data table that has a Link ID column property is referred to as the referenced data table.

- The Link Reference column property maps a column in the main data table to the ID column in the referenced data table. The column property specifies the path name of the referenced data table. The column that has a link reference is referred to as the referencing column. The referencing column can look up the data of the auxiliary data tables through the ID column.

Figure 6.36 shows an example of virtually joined data tables. Pizza Profiles.jmp is the referenced data table because the ID column contains a Link ID column property. The ID column contains unique values that correspond to data in the referencing data table, Pizza Responses.jmp.
Figure 6.36 Virtually Joined Data Tables

Note: The key icon in the Columns panel (in Pizza Responses.jmp above) is blue when the columns are linked and the referenced columns appear in the Columns panel. If the key icon is gray, verify your link references in the Column Info window.

With the link column properties set up, all columns from the referenced data tables become part of your main data table. Therefore, if the main data table has a referencing column, the columns of the referenced table automatically appear in the Select Columns list of the launch window.

You can prevent columns of the referenced table from appearing in the main data table by excluding them from the referenced table. Exclude columns by right-clicking them in the Columns panel and selecting Exclude/Unexclude.
Example of Virtually Joining Data Tables

Suppose that respondents in a pizza experiment chose their favorite crust, topping, and cheese. To see which cheese the respondents preferred, follow these steps:

1. Select **Help > Sample Data Library** and open *Pizza Profiles.jmp* and *Pizza Responses.jmp*.
2. First, right-click the ID column in *Pizza Profiles.jmp* and select **Link ID**.
   
   This column contains unique values that correspond to values in *Pizza Responses.jmp*. For example, row one in *Pizza Profiles.jmp* indicates that pizza with thick crust, mozzarella cheese, and pepperoni toppings is nicknamed ThickOni. When all responses in *Pizza Responses.jmp* are “ThickOni”, the subject chose pizza with these attributes.
3. In *Pizza Responses.jmp*, select the three columns that begin with “Choice”.
4. Right-click and select **Link Reference > Pizza Profiles.jmp**.
   
   The selected columns are linked to the ID column in *Pizza Profiles.jmp* and appear in the main data table’s Columns list (Figure 6.36 on page 297).

**Note:** Look at one of the column’s Link Reference properties again and notice that the *Pizza Profiles.jmp* data table is selected. See “Virtual Join Properties” on page 252 in the “The Column Info Window” chapter for information about changing the link.

5. In *Pizza Responses.jmp*, select **Analyze > Distribution**.
6. Scroll down to select the three Cheese columns in the referenced column groups, click **Y, Columns**, and click **OK**.

**Figure 6.37** Distribution Launch Window

More respondents chose Mozzarella in the Choice column. In Choice1 and Choice2, the proportion of Mozzarella to Jack is nearly even.
Figure 6.38 Distribution of Pizza Responses

Notes:

- See the Movie Rentals.jmp sample data table for another example of virtually joined data tables. The data are already joined with Movie Customers.jmp and Movie Inventory.jmp, so you do not need to specify the Link Reference.
- A data table can have only one Link ID column property. The Link ID column cannot have duplicate values.
- A data table can have multiple referencing columns. The columns can reference different or the same data tables.
- A referenced data table can have a referencing column (a column that references another data table).
- If the Link Reference column property is removed from the column, or the referenced data table is closed, the corresponding referenced columns are removed from the main data table.
- The data types of the linked columns must match.
- The Expression and Row State data types do not support the Link Reference or Link ID column properties.
- When the main data table is saved, the referenced columns are not saved. The data tables are relinked when you open them.
- When a referenced data table is renamed, the corresponding Link Reference column property is automatically updated.
• Referenced columns are not included when you select Copy Table Script from the Table panel red triangle menu.

Tips:
• In addition to right-clicking a column to add the Link ID and Link Reference column properties, you can add the properties through the Column Info window. See “Virtual Join Properties” on page 252 in the “The Column Info Window” chapter for details.
• To share the data with another user, you might want to merge the data so that the data tables are permanently joined. This option is helpful because you provide one data table, not the main and auxiliary data tables. To merge the joined columns into the table that has a link reference, select Merge Referenced Data from the red triangle menu in the data table’s left pane. The data are replicated from the auxiliary data table to the main data table. When you save the data table, the actual data are also saved.

Update Data Tables

If you have two data tables and would like to update your original table with data from a new table, select Tables > Update. The Update command is a special case of Join in place. It is a Join with the Update option checked, and it does not result in a new table.

Before you update a table, make sure that the name of the column containing the values that you want to replace is the same as the name of the column containing the data that you want to replace it with.

To replace values in the active table with those found in another open table

1. Click on the original table that you want to update (this is the table whose values you want to replace) to make it the active table.
2. Select Tables > Update.

Figure 6.39 Updating a Table
3. Highlight the new table containing the data that you want to transfer to the original table.

4. (Optional) If you do not want JMP to replace the values in the original table with any missing values found in the new table, select the box next to **Ignore missing**. The original table retains its original values if they correspond to missing values in the new table.

5. If the two tables have one or more columns whose values uniquely describe each row, JMP uses those columns as the **match column values**. That is, JMP updates the rows whose match column values coincide. JMP uses these columns to preserve the sorted order of the data. If your tables do not have matching column values, you can incorporate the updated values according to their row order by continuing here. To proceed with tables containing matching column values, see "To update a table using matching columns" on page 301.

6. From the **Add Columns from Update table area**, select an option. Using these options, you can add columns (that do not exist) from the new table into the original table.
   - Choose **All** to add all columns from the new table into the original table.
   - Choose **Selected** to add only columns that you have selected from the new table into the original table.
   - Choose **None** if you do not want to add any non-existent columns from the new table into the original table.

7. Click **OK**.

**To update a table using matching columns**

1. Follow the first three steps outlined in the previous section, "To replace values in the active table with those found in another open table" on page 300.

2. Select **Match columns**.

**Figure 6.40** This Window Appears When You Click Match Columns

3. Highlight the two column names (in the respective tables) that you want to match.

4. Click **Match**.
5. (Optional) Repeat to match more columns.
6. Click OK.

**Note:** Columns that have different names from the columns in the table that you are updating (and that have not been assigned matches) are appended as separate columns. To avoid this problem, select the None option in the Add Columns from Update table area.

**Example of Updating a Data Table**

Suppose a researcher has a data table containing height measurements for students. The researcher receives an updated table that contains more recent measurements of the students’ heights. The researcher wants to avoid scrolling through the data tables to find the students whose height has changed, and copying and pasting the new values. Using the **Update** command, the researcher can quickly update the original data table with the new height values.

1. Select **Help > Sample Data Library** and open Big Class.jmp and New Heights.jmp. The Big Class.jmp table contains the original data, and the New Heights.jmp table contains the updated data.
2. From the Big Class.jmp table, select **Tables > Update**.
3. In the **Update...with data from** box, select New Heights.
4. Select **Match columns**.
5. In the Big Class and New Heights lists, select name.
6. Click **Match**.
   This tells JMP to use name as the match column value, since it is the column whose values uniquely describe each row.
7. Click **OK**.

**Figure 6.41** The Updated Big Class.jmp Table
You can see that the height values in the updated table no longer match the values in the original table. The values have been updated to use the newer values from the New Heights.jmp table.

### Anonymize Data

The Anonymize Data feature enables you to create a new data table in which certain unique identifiers have been removed.

Data are updated as follows:

- Column headings, character data, and value labels are modified.
- Data in nominal columns are modified.
- Modified data in ordinal columns appear in the same order as in the original data table.
- Data in continuous columns are not modified.
- Column names in column properties are modified.

**Note:** Table scripts and some table variables cannot be anonymized. If your data table contains content that cannot be anonymized, a warning message appears in the log.

“Notes” column properties are removed. Other column properties are modified based on changes in the data table. For example, Value Ordering properties are renamed. Formulas except for prediction formulas are updated. Some column properties might no longer have the desired affect on the column.

To rename data, do one of the following:

- To rename data in specific columns, select the columns and then select **Tables > Anonymize**.
- To rename data in the entire data table, select **Tables > Anonymize**.

The data appear in a new data table.
DISCLAIMER: The Anonymize Data utility is provided merely to assist Users in removing certain unique identifiers from a data table as described above. The Anonymize Data utility might not remove all sensitive or personally identifiable information from a data table. Users should not rely exclusively on the Anonymize Data utility to remove such information where complete anonymization, pseudo-anonymization, or de-identification of data is desired or required by law or policy (such as where data are or might be disclosed to other parties). SAS does not represent, and specifically disclaims, that use of the Anonymize Data utility will by itself result in the User’s compliance with any national, state, local or international laws, regulations, or policies that pertain to the privacy, de-identification, or anonymization of sensitive or personally identifiable information.
Use the JMP Formula Editor to create a column whose values are computed by a formula and store that formula as part of a column’s information. Formulas can be simple assignments of numeric, character, or row state constants, or they can contain complex evaluations based on conditional clauses. The Formula Editor window operates like a calculator with buttons, displays, and a list of functions.

Figure 7.1 The Formula Editor
**Formula Overview**

Formulas are an integral part of a data table for the following reasons:

- They are stored as part of a column’s information when you save the data table.
- You can examine or change them at any time by opening the Formula Editor.
- Their values can be linked to, or dependent on, the values in other columns. Their values are automatically recomputed whenever you edit the values in the columns to which the formula is linked.
- Their values are locked in the data table so that they cannot be manually edited.

This chapter describes the Formula Editor and shows how to build formulas. For details about each function, see the “Formula Functions Reference” chapter on page 537.

**Create a Formula**

A formula is an expression stored in a column that performs operations in order to insert values into that column. Formulas can perform mathematical operations, such as addition and multiplication, or they can compare column values or join values by referring to other areas in the same data table. Formulas can consist of any JMP Scripting Language (JSL) command.

Once you insert a formula into a column, the column is locked: its values can be edited only by changing or removing the formula.

There are three basic steps to building a formula:

1. Open the Formula Editor by right-clicking the column name to which you want to apply the formula and selecting **Formula**.

   or

   Double-click the column name to which you want to apply the formula, select **Formula** from the Column Properties menu, and then click **Edit Formula**.

In the Formula Editor, the empty formula is selected (highlighted in blue). You can start typing or select a column or function.

   - When you type, a small text editor window appears, which enables you to edit the formula. You can click the **Maximize editor** button if you need more room. Long formulas open in the maximized editor by default.
   - When you select a column or function, that item is added to the selected blue box.
   - You can also drag a column from the Columns list into the selected box.
**Note:** An element is selected when there is a blue outline around it. All terms within the smallest nesting box relative to the place that you clicked become selected. The subsequent actions apply to those combined elements.

2. Add expressions, functions, and terms from the formula work panel. Then they appear in the highlighted blue box. The following sections in this chapter provide detailed instructions on how to add constants, elements, operators, and functions.

![Figure 7.2 Building a Formula](image)

Figure 7.2 Building a Formula

See “Use Basic Formula Editor Features” on page 328, for an example of how to use the Formula Editor.

**Notes:**

- In a formula, when you reference a column using value labels, place your cursor over the value label to see the actual data value.
- You can also use the Formula Editor to define a custom format. For example, you might want to convert a number from inches to centimeters using the calculation `Char(:height * 2.54) || " cm"`. Realize that the underlying data, which you see when double-clicking a data table cell, would still be the value of :weight.
Refer to Values in Columns and Table Variables

You can create a formula that refers to values found in other parts of the data table, such as other columns and table variables.

When a formula uses values in other columns, the values in the column with that formula are dependent on the values in those other columns. Whenever a column that the formula refers to changes, the dependent column also changes. If you delete the referenced column, empty terms appear in the column containing the formula.

If you create a formula that refers to values found in table variables, those table variables must already exist in the data table. Table variables are character strings that are available to the entire table. Their names are displayed in the table panel at the left of the data table. (For details, see “Use Table Variables” on page 217 in the “Enter and Edit Data” chapter.)

The following example shows how to re-create a formula column in the Companies.jmp sample data table.

1. Select Help > Sample Data Library and open Companies.jmp.
2. Right-click the last empty column and select New Columns.
   The Column Info window appears.
3. Type “Profit by Sales” next to Column Name.
   You are re-creating the formula found in the existing %profit/sales column.
4. In the Column Properties list, select Formula.
   The Formula Editor opens. The blue outline around the box in the editing window indicates that the box is selected.
5. With the box selected, select Profits (SM) from the Columns list.
Figure 7.3 Adding the Profits ($M) Column

6. With the box selected, click the Divide button $\div$.

Figure 7.4 Adding the Division Symbol

7. With the box selected as shown, select **Sales ($M$)** from the Columns list.

Figure 7.5 Adding the Sales ($M$) Column

8. Select the outer box in the formula editing area by clicking it.

Figure 7.6 Selecting the Formula

9. Click the Multiply button $\times$.
10. With the new box selected, type “100” and press Enter.

11. Click OK.

   The column is filled with the calculated numbers.

12. Right-click the last column and select Column Info.

13. In the Column Info window, select Fixed Dec from the Format list, type “10” next to Width, and type “2” next to Dec.

   The column width and number of decimal places are specified.

14. Click OK.

   The new formula column matches the %profit/sales formula column.

Notes:

- Pressing Alt (Option on Macintosh) and clicking a column replaces both empty and non-empty selected fields with that column.
- The right-click menu for the Columns list has two new items: Replace all occurrences of selected subexpression. replaces all occurrences of the selected expression with the currently selected column. Replace the selected subexpression with columns. replaces the selected expression with multiple columns (formerly Shift + Click) for functions that support it (for example, Sum or Plus).

Use Local Variables

You can create and use temporary numeric variables in expressions. You can use ordinary local variables or you can use parameters, which are special types of local variables. Local variables exist only for the evaluation of the formula in which they are defined. They appear in formulas as bold italic terms.

Local variables are most often used with Assignment functions, which can assign expressions to local variables that are used in a complex equation. (For details, see “Assignment
Functions” on page 593 in the “Formula Functions Reference” chapter. This technique can sometimes simplify building an equation and improve the efficiency of its evaluation.

To build a formula that references values found in local variables, follow these steps:

Step 1: Create the Local Variable

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a blue outline around it.)
3. In the middle pane of the Formula Editor, select Local Variables from the list.
4. Click New Local.
5. Enter a name for the local variable. By default, local variables have the names $t_0$, $t_1$, and so on, and have missing values.
6. Assign a starting value, and click OK.
7. (Optional) To copy, edit, or delete a local variable, right-click (Ctrl-click on the Macintosh) its name and select Copy, Edit, or Delete.

Step 2: Insert a Local Variable into a Formula

1. Select a term in the formula editing area by clicking it. (It is selected when there is a blue outline around it.)
2. Click the local variable name in the Local Variables list. It appears in the formula as a bold italic term.

Notes:

- Double-clicking or pressing Alt and clicking the local variable replaces the portion of the formula that is selected.
- Another way to create local variables is to use the Make Temporary Variable button on the Formula Editor keypad. The button automatically creates and displays local variables and places a semicolon after it. See “Add Operators” on page 314, for details.
- Pressing Alt and Shift and clicking enables you to edit the selected variable in place instead of in a new window.

See “Use Local Variables in a Formula” on page 329, for an example of referencing local variables in a formula.
Incorporate Parameters

Parameters are special types of local variables that are recognized as model parameters in some platforms, such as Nonlinear fitting. They can be used in formulas just as ordinary local variables can.

To view examples of parameters

1. In the sample data folder that was installed when you installed JMP, open the Nonlinear Examples folder and then US Population.jmp.
2. Right-click the column name x-formula and select Formula.
3. In the middle pane of the Formula Editor, select Parameters from the list.

Notes:

• After completing a nonlinear fit or after clicking the Reset button in the nonlinear control panel, the parameter’s value is the most recent value computed by the nonlinear platform.
• Each time the fitting algorithm takes a step, the updated parameter values are shown in the Nonlinear report.
• When you paste a formula with parameters into a column, the parameters are automatically created for that column unless it has existing parameters with the same names.
• Double-clicking or pressing Alt and clicking the local variable replaces the portion of the formula that is selected.
• Pressing Alt, Shift, and clicking enables you to edit the selected parameter in place instead of in a new window.

To build a formula that references values found in parameters

Step 1: Create the Parameter

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Make sure the formula is selected in the formula editing area. (It is selected when there is a blue outline around it.)
3. In the middle pane of the Formula Editor, select Parameters from the list.
4. Click New Parameter.
5. Enter a name for the parameter. By default, parameters have the names b0, b1, and so on, and have missing values.
6. Assign a starting value. It is important to enter this value when using a parameter in a model for the nonlinear platform. After completing a nonlinear fit, the parameter’s value is the most recent value computed by the nonlinear platform.
7. (Optional) To add several parameters (one for each level of a categorical variable, for example) at once, select **Expand into categories, selecting column**. Then select the column for which you want to expand the parameter.

8. Click **OK**.

9. (Optional) To copy, edit, or delete a parameter, right-click (Ctrl-click on the Macintosh) its name and select **Copy**, **Edit**, or **Delete**.

**Step 2: Insert a Parameter into a Formula**

1. Select a term in the formula editing area by clicking it. (It is selected when there is a blue outline around it.)

2. Click the parameter name in the Parameters box. The parameter appears in the formula as bold type.

**Tip:** Pressing Alt and clicking enables you to edit the selected parameter.

---

**Insert Constants**

Formulas can be simple assignments of numeric, character, or row state constants, or they can contain complex evaluations based on conditional clauses. Constants include commonly used numeric terms, such as e, pi, -1, 0, 1, and 2. There are two ways to add a constant value to a formula:

- Enter them manually using the keyboard
- Select them from the list in the middle pane, as shown in Figure 7.9.
To add constants to a formula, follow these steps:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting **Formula**.

2. Select a box in the formula editing area by clicking it. (It is selected when there is a blue outline around it.)

3. Either type in a number or select **Constants** in the middle pane, as shown in Figure 7.9. Then click a value in the list that appears: 0, 1, 2, -1, pi, e. The value appears in the outlined box.

4. Complete the remainder of the formula using the keypad and functions. (See “Refer to Values in Columns and Table Variables” on page 308, “Add Operators” on page 314, and “Use Functions in a Formula” on page 316.)

**Note:** Double-clicking or pressing Alt and clicking the constant replaces the portion of the formula that is selected.

---

**Add Operators**

You can add operators to a formula using the keypad, which contains buttons that help build formulas. It includes common operators (also referred to as functions).
To build a formula using keypad operators at the top of the window, follow these steps:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting **Formula**.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a blue outline around it.) The operator performs its action on the area that is highlighted.
3. Select the column or variable that you want to use in your formula.
4. Click the keypad button(s).

**Keypad Reference**

Table 7.1 describes the keypad buttons.

**Table 7.1  Keypad Buttons in the Formula Editor**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arithmetic</td>
<td>Work as they normally do on a pocket calculator, providing addition,</td>
</tr>
<tr>
<td>buttons</td>
<td>multiplication, subtraction, and division operators.</td>
</tr>
<tr>
<td>Insert</td>
<td>Inserts a new clause or function argument. First select the existing clause</td>
</tr>
<tr>
<td></td>
<td>or argument that you want the new element to follow, and then click this</td>
</tr>
<tr>
<td></td>
<td>button. The new clause appears and is selected. You can also insert a new</td>
</tr>
<tr>
<td></td>
<td>clause or argument by typing a comma.</td>
</tr>
<tr>
<td></td>
<td>Pressing ALT and the Insert icon [ ] inserts a new field before the</td>
</tr>
<tr>
<td></td>
<td>selected field</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes an element’s value, or deletes a clause. The delete button functions</td>
</tr>
<tr>
<td></td>
<td>the same as the Delete key on the keyboard.</td>
</tr>
<tr>
<td>Exponent</td>
<td>Raises a given value to a specified power. It has an exponent of two by</td>
</tr>
<tr>
<td></td>
<td>default.</td>
</tr>
<tr>
<td>Root</td>
<td>Calculates the specified root of the radicand. It has an implied index of</td>
</tr>
<tr>
<td></td>
<td>two (a square root), which is not displayed.</td>
</tr>
<tr>
<td>Switch terms</td>
<td>Looks at the operator that is central to the selected expression and</td>
</tr>
<tr>
<td></td>
<td>switches the expressions on either side of that operator.</td>
</tr>
</tbody>
</table>
Use Functions in a Formula

Tip: Within JMP, tooltips are available to help you understand what each function does.

You can add many types of functions to a formula. All of these functions are organized in the Functions list. The browser groups collections of functions in lists organized by topic. The list contains functions that are commonly used in formulas. Use the Functions list to specify the type of calculation that you want to perform on the elements in a formula.

To create a formula that contains a function, follow these steps:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a blue outline around it.) The function performs its action on the area that is highlighted.
3. Click the menu in the Functions list to view the groups of functions.
4. Select a group of functions to view. See Table 7.2 for details.

The functions that belong to that group are then displayed in the list below the menu. The function groups are briefly described in the following list.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unary sign function</td>
<td>Inverts the sign of the argument. Apply the unary sign function to variable expressions or use it to enter negative constants.</td>
</tr>
<tr>
<td>Local variable (Make Temporary Variable)</td>
<td>Creates and displays a local variable and assigns it the value of the selected expression. The local variable has the default name t0 in an expression and a semicolon after it. See “Use Local Variables” on page 310, for details about creating and inserting local variables. See “Use Local Variables in a Formula” on page 329, for an example.</td>
</tr>
<tr>
<td>Delete expression (Peel)</td>
<td>Removes the outermost expression with the first argument. You can repeat this process to delete a formula term by term. See “Use the Delete Expression Button” on page 332, for an example.</td>
</tr>
</tbody>
</table>
5. Click any function in the Functions list to apply it to the selected item. When you click some items, you reveal a submenu from which you should make a selection.

6. Continue to build the formula by highlighting terms and clicking items in the formula element browser, keypad, or Functions list.

**Notes:**

- Pressing Alt and selecting the function replaces the selected function in a formula with the function that you select from the Functions list or the button that you select from the keypad.
- Pressing Alt (Option on Macintosh) and clicking a column or other element replaces the item even if it is non-empty.
- Most functions give hints about appropriate arguments through gray words inserted in the boxes in the formula editing area. Functions also show a small caret in the argument area if additional arguments can be added.

**Table 7.2 Groups of Functions**

<table>
<thead>
<tr>
<th>Group</th>
<th>Functions Included</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row</td>
<td>Displays a list of functions that contains miscellaneous functions such as Lag, Dif, Subscript, Row, and NRow. See “Row Functions” on page 538 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Numeric</td>
<td>Displays a list of functions that are terms commonly used in formulas. See “Numeric Functions” on page 540 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Transcendental</td>
<td>Displays a list of functions that are functions such as natural log, common log, exponential, root, factorial, combinatorial, beta, and gamma. See “Transcendental Functions” on page 540 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Trigonometric</td>
<td>Displays a list of functions that are the standard trigonometric functions: sine, cosine, tangent, inverse functions, and hyperbolic functions. See “Trigonometric Functions” on page 543 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Character</td>
<td>Displays a list of functions that operate on character arguments such as trimming, finding the length of a string, converting between numbers and characters. See “Character Functions” on page 544 in the “Formula Functions Reference” appendix.</td>
</tr>
</tbody>
</table>
### Table 7.2 Groups of Functions (Continued)

<table>
<thead>
<tr>
<th>Group</th>
<th>Functions Included</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Comparison</strong></td>
<td>Displays a list of functions that are the standard logical comparisons such as less than, less than or equal to, not equal to, and so on. See “Comparison Functions” on page 554 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Conditional</strong></td>
<td>Displays a list of functions that are programming-like functions, such as If, Match, and Choose. See “Conditional Functions” on page 555 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Probability</strong></td>
<td>Displays a list of functions that compute probabilities and quantiles for standard statistical distributions, such as normal, Student’s t, Chi-squared, and F-distributions. See “Probability Functions” on page 560 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Discrete Probability</strong></td>
<td>Displays a list of functions that compute discrete probabilities, such as Poisson, Gamma Poisson, and Hypergeometric. See “Discrete Probability Functions” on page 573 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Statistical</strong></td>
<td>Displays a list of functions that calculate standard statistical quantities such as the mean or standard deviation. See “Statistical Functions” on page 575 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Random</strong></td>
<td>Displays a list of functions that generate random numbers based on predefined distributions such as the uniform, normal, Cauchy, and so on. There is also a function to randomize the order of table rows. See “Random Functions” on page 580 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Date Time</strong></td>
<td>Displays a list of functions that require arguments with the date data type, which is interpreted as the number of seconds since January 1, 1904. Date Time functions return values such as day, week, or month of the year. They can also compute dates and can find data intervals. See “Date Time Functions” on page 584 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Row State</strong></td>
<td>Displays a list of functions that assign or detect row state status of color, marker, label, hidden, excluded, or selected. See “Row State Functions” on page 587 in the “Formula Functions Reference” appendix.</td>
</tr>
</tbody>
</table>
As you build a formula, keep in mind that all functions have an order of precedence shown in the following table, where level one is the highest order of precedence. Expressions with a high order of precedence are evaluated before those at lower levels. When an expression has operators of equal precedence, it is evaluated from left to right. You can use parentheses to override other precedence rules when necessary because any expression within parentheses is always evaluated first. Terms have no order of precedence because they cannot be evaluated further. Table 7.3 shows the first six levels of the order of precedence.

Table 7.3 Order of Precedence of Operators in Formulas

<table>
<thead>
<tr>
<th>Level</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level 1</td>
<td>Parentheses</td>
</tr>
<tr>
<td>Level 2</td>
<td>Functions in the Functions lists, And, Or, Not</td>
</tr>
<tr>
<td>Level 3</td>
<td>*, /, Modulo</td>
</tr>
<tr>
<td>Level 4</td>
<td>+, -</td>
</tr>
<tr>
<td>Level 5</td>
<td>Comparisons: £, £, =, ≠, ≥, &gt;, £ x £, &lt; x £, &lt; x &lt;</td>
</tr>
<tr>
<td>Level 6</td>
<td>Logical Operators &amp;,</td>
</tr>
</tbody>
</table>
**Note:** When a function has an expression as its argument, the argument has a higher order of precedence than it would if enclosed in parentheses outside the function.

**Build a Formula in Order of Precedence**

It is best to build a formula starting with any expression that serves as an argument. This is because functions have a high order of precedence and are always grouped with their corresponding arguments. It is also a good idea to create expressions working from highest to lowest order of precedence when possible. If you need parentheses, be sure to enter the open parenthesis before entering the expression to be enclosed.

For example, given a data table with the columns A, B, and C, use the following steps to compose the expression $A(B + C)$. Note that this expression is not the same as $A \times B + C$, which evaluates as $(A \times B) + C$.

To enter the expression, follow these steps:

1. Click column A in the Columns list.
2. Click the multiplication button $\times$ in the Formula Editor keypad.
3. Enter an open parenthesis.
4. Click column B in the Columns list.
5. Click the addition button $+$ in the Formula Editor keypad.
6. Click column C in the Columns list.

Because the order of precedence determines which arguments are affected by each functions, it also affects the grouping of expressions. Select functions in the formula to verify how the order-of-precedence rules have been applied.

**Structure Formulas for Efficient Evaluation**

Usually, it is not necessary to structure formulas with efficient evaluation in mind. Most formulas evaluate almost instantaneously regardless of their structure. This is because statistical functions and constant expressions are evaluated only once when a column’s values are calculated.

However, when you are creating conditional expressions, keep in mind that Match evaluates faster and uses less memory than an equivalent Condition function, If. (Note that Match ignores trailing spaces and If does not.)

For example, using Big Class.jmp, you can predict a child’s height from his age as shown in Figure 7.10. There is a base height of 58.125 inches to which a quantity is added depending on the value of the age variable.
**Figure 7.10** The Match Conditional Evaluates Faster Than the If Function

The Match conditional evaluates faster than the If function because the *age* variable is evaluated only once for each row in the data table. The If condition must evaluate the *age* variable at each If clause for each row until a clause evaluates as true.

### Use Formula Editor Options

There are several options available to you as you create formulas. The following sections discuss each of these options.

#### Calculate Derivatives

The JMP Formula Editor can find and display the derivative of a function. The derivative is found with respect to the function argument (a single variable name) you highlight. Therefore, in order to differentiate with respect to $x$, $x$ must be one of the arguments in the expression. The red triangle menu next to the keypad contains the Derivative command.

To calculate a derivative, follow these steps:

1. Enter a function.
2. Highlight a variable.
3. Select **Derivative** from the menu. Figure 7.11 shows the completion of these steps.
Simplify Complex Formulas

When the Formula Editor contains a complex formula, JMP can simplify it using various algebraic rules. It can find constant expressions, distribute multiplication over addition, combine terms, and more.

To simplify complex formulas, follow these steps:
1. Select a portion or all of the formula.
2. Click the red triangle menu next to the keypad.
3. Select Simplify from the list as shown in Figure 7.12.

Figure 7.11 Using the Derivative Option

Figure 7.12 Selecting Simplify (Left) Produces a Simplified Formula (Right)
Evaluate Formulas

By default, JMP evaluates each formula that you create. You can turn this evaluation off, or you can use it before you have finished creating a formula.

Suppress Evaluation

Turning off evaluation is a useful formula development mode for building complex formulas. You can turn off evaluation and build sections of a formula, and evaluate only to test it. In particular, you can close the Formula Editor and reopen it at a later time to continue building a formula without JMP evaluating it.

To suppress formula evaluation, click the red triangle menu next to the keypad and select Suppress Eval. When evaluation is suppressed, the formula icon appears dimmed.

Note the following:

- If the icon appears to the right of the red triangle menu in the Formula Editor, it indicates that formula evaluation is suppressed for that formula.
- If the icon appears beside the column name in the Columns panel, it indicates that the values in the column result from a formula. When formula evaluation is suppressed, this plus icon becomes gray. (For details, see “Icons Representing Column Characteristics and Properties” on page 39 in the “Get Started” chapter.)

Ignore Errors

Once you construct a formula and click OK, JMP checks behind the formula for error and alerts you of any errors that it finds. An error message appears for each error and asks whether you want to ignore further errors.

Sometimes you might want to suppress error messages while a formula is under development. For example, you might want the evaluated values for some rows without seeing an error message for each row that causes errors.

To ignore errors, follow these steps:

1. Create a formula.
2. Click the red triangle menu next to the keypad and select Ignore Errors.

View a Formula’s Values from the Formula Editor

While in the Formula Editor, you can see the value of any expression within a formula with the Evaluate command. For column variables, you get the value at row 1. This is also true for parameters and expressions that evaluate to a constant value.
To view values, follow these steps:

1. While in the Formula Editor, select the expression that you want to know about.
2. Right-click the selected expression.
3. Select Evaluate. The current value of the selected expression appears in a box until you move the cursor.

### View a Formula in JSL

You have the option of entering or changing any part of a formula in text mode. Text mode displays the formula in JMP Scripting Language (JSL). The entire formula (or any of its terms) appears in the Script Editor when you double-click the formula. If the formula is long, it opens in a maximized Script Editor window. Otherwise, you can click the Maximize editor button to maximize the window.

Any element of a formula can be displayed in the Script Editor and then edited. After editing formula scripting commands, click outside the formula (or click OK below the maximized window) to see its formatted form and to save the change. To enter an If statement in text form, add pairs of arguments for each If/Then clause in the statement, and a single last argument for the else clause if needed. In text form, the If statement in Figure 7.13 looks like this: If(:total!=0, (:count/:total)*100, 0).

**Figure 7.13  An If Statement in Formula Mode**

\[
\text{If}\left(\begin{array}{l}
\text{total} \neq 0 \\
\text{else}
\end{array}\right) \Rightarrow \left(\frac{\text{count}}{\text{total}}\right) \cdot 100
\]

### Edit Formulas

If you need to change a formula after you have exited the Formula Editor, right-click the column name in the data table and select Formula.

### Correct Mistakes

If you make a mistake while entering a formula, hold down the Ctrl key and press Z. This reverses the effect of the last (undo-able) command.

Other commands to help modify formulas include the following:

- Click the delete button (حار) on the Formula Editor keypad to remove the selected expression.
- Use the cut, copy, and paste keyboard shortcut commands or right-click a highlighted part of the formula and select **Cut**, **Copy**, or **Paste** from the menu.
- Drag portions of the formula to rearrange them.

## Select Expressions

Use the keyboard arrow keys to select expressions for editing. You can also use the arrow keys to view the formula’s order of precedence when either parentheses or the boxing option are not present. (See “Hide and Show Boxing” on page 326.)

Clicking an operator (+, −, *, ÷) in an expression selects the operator and its operands. A blue box appears around the items. Once an operator is selected:

- The left and right arrow keys move the selection across other associative operators having equal precedence within the expression.
- The up arrow extends the current selection by adding the operand and operator of higher precedence to the selection.
- The down arrow reduces the current selection by removing an operand and operator from the selection.

## Delete Functions

Deleting a function also deletes its arguments. Deleting a required argument or missing term from a function sometimes deletes the function as well. You can peel a function to delete it from its argument.

To peel a function from a single argument, follow these steps:

1. Select the function.
2. Click the peel button in the Formula Editor keypad. Or use the hand tool to drag the argument on top of its function.

**Figure 7.14 Peeling an Argument**

3. Complete formula changes.
4. Click **Apply**, and the new values fill the data table column automatically.
5. Once you have created a formula, you can change values in columns that are referenced by your formula. JMP automatically recalculates all affected values in the formula’s column.
Cut, Copy, and Paste

You can cut or copy any expression or an entire formula and paste it into another formula display. Use the cut, copy, and paste shortcut commands or right-click a highlighted part of the formula and select Cut, Copy, or Paste from the menu. The following aspects apply when you cut, copy, and paste a formula:

- When you paste it into another formula display, the formula appears in formatted form.
- The formula is saved on the clipboard as a JSL statement. Thus, if you copy it into other applications, it appears as a JMP Scripting Language (JSL) statement.

Note: Press the Shift key on your keyboard, and then click the red triangle to reveal a command called Copy As SAS Formula.

Click and Drag

You can drag any part of a formula that can be selected to any other location that can be selected.

To click and drag in a formula, follow these steps:

1. Place the arrow cursor inside an expression.
2. Click the expression. It is highlighted and the cursor changes to a hand cursor.
3. Drag across the formula. Destination expressions are highlighted.
4. Drag the selected expression to the new desired location. The selected expression is copied to the new location, where it replaces the existing expression.

Customize Formulas

There are several ways that you can customize formulas in the Formula Editor. The following sections describe how to change font size, show and hide boxing, change the orientation of the formula, and close arguments.

Hide and Show Boxing

By default, JMP outlines specific terms within the formula. This is called boxing. Boxing is useful when you want to select and modify a specific portion of a formula, or need to determine the order of evaluation that takes place.

To turn boxing on or off, follow these steps:

1. Build a formula.
2. Click the red triangle menu next to the keypad and select **Show Boxing**. When a check appears on the menu beside **Show Boxing**, the outline appears in the formula. When it does not, the outline does not appear.

**Change the Font Size**

To incrementally increase or decrease the font used to display the formatted formula, follow these steps:

1. Click the red triangle menu next to the keypad.
2. Select **Larger Font** or **Smaller Font**.
3. Repeat this process to further increase or decrease the font size.

**Specify the Matrix Size**

You can set the maximum width and height of matrices by selecting **Max matrix size to show** from the red triangle menu. If the width or height is greater than the specified size, the matrix dimensions show instead of the data. You can still see the data by editing the formula in the text editor window.

**Change the Orientation of a Formula**

By default, JMP determines the size of a formula and displays it in the Formula Editor in the best orientation (horizontally or vertically). However, if you create a long formula, you might want to display it in a different layout.

To change a formula’s orientation, follow these steps:

1. Build a formula.
2. Highlight an argument or formula.
3. Right-click what you have highlighted.
4. Select **Orientation**.
5. Select from the Orientation options: Best, Horizontal, or Vertical.

**Open and Close Arguments**

When a formula is too large to fit on the screen, you can close formulas and arguments.

To close an argument, follow these steps:

1. Build a formula.
2. Highlight an argument or formula.
3. Right-click what you have highlighted.
Examples and Tutorials

To better familiarize yourself with building formulas, review the following examples and tutorials.

Use Basic Formula Editor Features

The following example uses the Big Class.jmp sample data table to walk you through using the basic features of the Formula Editor. You can find Big Class.jmp in the sample data folder, which was installed when you installed JMP.

Big Class.jmp has a column called weight. Suppose you want a new column that computes standardized weight values.

To create this column using a formula to obtain its values, follow these steps:
1. Select Help > Sample Data Library and open Big Class.jmp.
2. Select Cols > New Columns.
3. Type the new name, standard weight, in the box beside Column Name.
4. Select Formula from the Column Properties menu.
5. Click the empty formula element in the formula editing area to select it.
   When you create a formula and Show Boxing is checked, the selected portion of the formula is outlined with a thin blue line. See “Hide and Show Boxing” on page 326. All terms within the smallest nesting box relative to the place that you clicked become selected, and the subsequent action applies to those combined elements.

Next, enter the formula that standardizes the weight values.
1. While the initial missing term is selected, click weight in the Columns list.
2. Click the minus button in the Formula Editor keypad.
   A new missing term appears after the minus sign as shown in Figure 7.15.
3. Click weight again.
4. Click the Functions list, and select Statistical.
5. Select Col Mean from the Statistical list.
6. Select the entire expression.
   The blue box should now enclose the whole formula.
7. Click the division button in the keypad.
   The result gives a selected missing denominator for the whole expression.
8. Click **weight** again from the column selector list. It becomes selected in the denominator.

9. Select **Col Std Dev** from the Statistical list. Figure 7.15 shows the completed formula.

**Figure 7.15** Building a Formula

10. Close the Formula Editor by clicking **OK**.

11. Close the Column Info window by clicking **OK**.

In the data table, the new **Standard Weight** column fills with values. When a **weight** value changes, the calculated **Standard Weight** value automatically recalculates.

**Use Local Variables in a Formula**

Suppose you want to compute the slope in a simple linear regression of \( y \) on \( x \) using the standard formula shown in Figure 7.16. One way to do this is to create two local variables, and name them **XY** and **Xsqr**. (See “Use Local Variables” on page 310.) Then assign them to the numerator and the denominator calculations of the slope formula. Delimit each assignment with a semicolon, as shown in Figure 7.16. (Statements in the Formula Editor are actually JSL programming statements. Multiple statements in a formula must be separated by a semicolons.) The slope computation is simplified to **XY** divided by **Xsqr**.
Use the Munger Function

The following examples show uses of the Munger function. In these examples, assume that there is a character column of names with “Veronica Layman” as one of its values. To simplify the examples, the literal name “Veronica Layman” is the search string instead of a column name.

For instructions on how to incorporate Character functions, such as Munger, into a formula, see “Character Functions” on page 544 in the “Formula Functions Reference” appendix.

Insert Characters

This Munger example finds the blank between the first and last name, and inserts the middle initial “J.” The formula Munger("Veronica Layman", 1, " ", " J.") inserts the middle initial J., and evaluates as Veronica J. Layman.

Double quotation marks are required by the Munger function for literal strings, including strings that consist of a blank or when leading or trailing blanks are part of a string.

Delete Characters

To delete one or more characters from a string, follow these steps:

1. Designate the characters to delete as the Find string in the Munger function.
2. Enter an empty Replace string; two quotation marks with nothing between them.

For example, the function, Munger("Veronica Layman", 1, "onic", "") removes the “onic” from Veronica and evaluates as Vera Layman.
Note: A Replace field with a null (no value) string enclosed in quotation marks is different from a Replace field with no value. If you delete the Replace string altogether, Munger shows the argument name (“Replace”) in the Formula Editor window and behaves as if that optional argument does not exist. The resulting data type can also change from character to numeric, depending on the value of the Find/Length argument.

Find the Position (Index) of a Value

When the Find/Length field contains characters, Munger behaves like an index function and returns the numeric position of the first instance of the search string if it exists. For example, `Munger("Veronica Layman", 1, " ")` searches for a single blank and finds it in position nine. If the search string is not found, Munger returns a zero. This use of Munger produces the same result as the Contains function, as shown in “Character Functions” on page 544 in the “Formula Functions Reference” appendix.

Find a Substring

Munger can extract substrings. For example, to extract only the first name, `Munger("Veronica Layman", 1, 8,)` starts at position one and reads through position eight. The remaining characters are ignored because the replace argument is not defined. This yields “Veronica” and produces the same result as the Substring, as shown in “Character Functions” on page 544 in the “Formula Functions Reference” appendix.

An alternative way to find a substring is with a start value, any negative find value, and a no replace argument. `Munger("Veronica Layman", 9, –1,)` returns “Layman”.

Use the Match Conditional Function

This example walks you through using the Match conditional function.

Suppose that you want a Match conditional for the nominal variable `Type` from the `Hot Dogs.jmp` sample data table.

1. In the Formula Editor, select `Type` from the Columns list.
2. Select `Conditional` from the Functions list.
3. Select `Match`.
4. Select `Add Arguments from Data`.
   The values are automatically filled in. See Figure 7.17.

Note: Rather than complete step 2 through step 4, hold down the Shift key, select `Conditional` from the Functions list, and then select `Match`. 
Figure 7.17  Automatically Filling a Match Conditional Statement

If you do not want the values filled in for you, select Do Not Add from the Match list instead of Add Arguments from Data.

Use the Delete Expression Button

The following steps illustrate the results of repeatedly clicking the delete expression (or peel) button:

1. Start with a formula.

2. Select a formula element.

3. Click the delete expression button.

4. Click the delete expression again.

5. Click the delete expression again.

6. Click the delete expression again.
7. Click the delete expression again.

8. Click the delete expression again.

9. Click the delete expression again.

Keyboard Shortcuts

Table 7.4 describes the keyboard shortcuts that you can use in the Formula Editor.

Table 7.4  Keyboard Shortcuts in the Formula Editor

<table>
<thead>
<tr>
<th>Insert This Item</th>
<th>Using This Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>A missing element (•)</td>
<td>DELETE</td>
</tr>
<tr>
<td>Subscript</td>
<td>[</td>
</tr>
<tr>
<td>Exponent</td>
<td>^ (Hold down the Shift key and type 6.)</td>
</tr>
<tr>
<td>Set of parentheses ()</td>
<td>(</td>
</tr>
<tr>
<td>Set of quotation marks &quot; &quot;</td>
<td>&quot;</td>
</tr>
<tr>
<td>New argument before the selected field</td>
<td>Alt + [</td>
</tr>
<tr>
<td>* (multiplication symbol)</td>
<td>* on keypad or keyboard</td>
</tr>
<tr>
<td>+</td>
<td>+ on keypad or keyboard</td>
</tr>
<tr>
<td>−</td>
<td>– on keypad or keyboard</td>
</tr>
<tr>
<td>÷</td>
<td>/ on keypad or keyboard</td>
</tr>
</tbody>
</table>
Table 7.4  Keyboard Shortcuts in the Formula Editor  *(Continued)*

<table>
<thead>
<tr>
<th>Insert This Item</th>
<th>Using This Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>+/-</td>
<td>Hold down the Shift key and press the - (Minus) key</td>
</tr>
<tr>
<td>And</td>
<td>&amp;</td>
</tr>
<tr>
<td>Not</td>
<td>!</td>
</tr>
<tr>
<td>Or</td>
<td></td>
</tr>
<tr>
<td>Power</td>
<td>^</td>
</tr>
<tr>
<td>New argument</td>
<td>,</td>
</tr>
<tr>
<td>x&lt;y</td>
<td>&lt;</td>
</tr>
<tr>
<td>x==y</td>
<td>=</td>
</tr>
<tr>
<td>x&gt;y</td>
<td>&gt;</td>
</tr>
</tbody>
</table>

Glossary of Terms

The following terms are used in the Formula Editor:

**Element**  The name of a constant, table variable, local variable, or parameter that appears in the element browser list.

**Argument**  Any element or an entire expression (including mathematical operands) that is operated on by a function. Arguments are always grouped with functions. To find which expressions serve as a function’s arguments, select that function in the formula.

**Term**  Indivisible parts of an expression, such as constants and variables.
**Expression**  Any part of a formula that can be selected as a single unit, including terms, missing terms, and functions grouped with their arguments, as well as the entire formula.

\[
\frac{10}{(A + B + D)}
\]

**Clause**  A complete segment in a conditional function.

\[
\begin{cases}
\text{expr} & \Rightarrow \text{then clause} \\
\text{else} & \Rightarrow \text{else clause}
\end{cases}
\]

**Function**  A mathematical or logical operation that performs a specific action on one or more arguments. Functions include most items in the Functions list and all keypad operators. Functions always operate upon selected expressions, and arguments are always grouped with functions. To find which expressions serve as a function’s arguments, select that function in the formula.

The boxed groupings also show how order-of-precedence rules apply and show which arguments are deleted when you delete a function. See “Order Expressions in Formulas” on page 319 for details.

\[
\text{Col Std Dev (weight)}
\]

**Missing term**  Any empty place holder for an expression, represented by an empty box.

\[
A + \square + D
\]

**Missing value**  Excluded or null data consisting of the missing value mark (●) for numeric data or null character strings for character data.

\[
\begin{array}{c|c}
\text{name} & \text{age} \\
\hline
1 & KATE \\
2 & 12 \\
3 & JANIE
\end{array}
\]
This chapter describes how to create a summary data table, which includes summary statistics such as the mean and median, standard deviation, and minimum and maximum values.

**Figure 8.1 Summary Table for Companies.jmp**
Summarize Columns

The Tables > Summary command calculates various summary statistics, including the mean and median, standard deviation, minimum and maximum value, and so on.

Summary tables have the following characteristics:

- A single row exists for each level of a grouping variable that you specify. If no grouping variable is specified, a single row exists for the full data table.
- When there are several grouping variables, the table contains rows for each combination of levels of all the grouping variables.
- In addition to one column for each grouping variable, the table contains frequency counts in a column named `N Rows` with counts for each grouping level.
- The summary table can be linked to its source table. When you select rows in the summary table, the corresponding rows are highlighted in its source table.
- If the source table’s column(s) contain value labels, the value labels are displayed in the new table.
- A summary table is not saved when you close it unless you select File > Save As to give it a name and location.

Launch Window Roles

**Statistics**  Defines the summary statistics (such as mean, standard deviation, and median) for a numeric column in the source table. See “Add Summary Statistics” on page 339 for details.

**Group**  Summarizes the statistics by group. See “Use One or More Grouping Columns” on page 339 for details.

**Subgroup**  Summarizes the statistics by subgroup. See “Create a Two-Way Table of Summary Statistics by Adding a Subgroup Variable” on page 341 for details.

**Freq**  Identifies a column whose values assign a frequency to each role.

**Weight**  Identifies a column whose values assign a weight to each role.

Create a Summary Table

To create a summary table, follow these steps:

1. Open a data table.
2. Select Tables > Summary.
3. Highlight the columns that you want to summarize.
Chapter 8
Summarize Data

Using JMP Summarize Columns

Note: For details about the options in the red triangle menu, see “Column Filter Menu” on page 51 in the “Get Started” chapter.

4. Add summary statistics, groups, subgroups, frequency variable, weight variable, and select any options needed:
   - “Add Summary Statistics” on page 339
   - “Use One or More Grouping Columns” on page 339
   - “Use Quantile Statistics” on page 340
   - “Change the Format of the Statistics Column Name” on page 341
   - “Link to the Original Data Table” on page 341
   - “Keep the Summary Window Open” on page 341
   - “Create a Two-Way Table of Summary Statistics by Adding a Subgroup Variable” on page 341

5. Name the summary table by typing a name in the box beside Output table name.
6. Click OK.

Add Summary Statistics

You can add columns that display summary statistics (such as mean, standard deviation, median, and so on) for any numeric column in the source table.

1. In the Summary window, highlight the column that you want to use in calculating the statistics.
2. Click the Statistics button.
3. Select one of the standard univariate descriptive statistics from the Statistics list. The statistics are described in “Explanation of Statistics” on page 343.

Use One or More Grouping Columns

If you want the statistics summarized by group, highlight the column(s) that you want to be your grouping variables and click Group to move the variable into the grouping variables list. See “Example of Creating a Summary Table” on page 344, for an example. If you add only grouping variables, the summary table shows a count for each group.

To change the order of the grouping variables

To change the order of the grouping variables (ascending or descending order), select a variable in the grouping variable list and click the ascending or descending button (▲ ▼). The icon beside the variable changes to indicate the sorting order.
You can also change the order of the grouping variables using the Value Ordering column property. See “Value Ordering” on page 239 in the “The Column Info Window” chapter.

To include marginal statistics

To add marginal statistics (for the grouping variables) to the output columns, click the box beside Include marginal statistics. In addition to adding marginal statistics for each grouping variable, JMP adds rows at the end of the table that summarize each level of the first grouping variable.

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Tables > Summary.
3. Select Profits ($M) and click Statistics.
4. Select Mean.
5. Select Type and Size Co and click Group.
6. Select Include marginal statistics.
7. Click OK (or Create). See Figure 8.2 at left.

Figure 8.2 Summary Table with and without Marginal Statistics

<table>
<thead>
<tr>
<th>Type</th>
<th>Size Co</th>
<th>N Rows</th>
<th>Mean/Profit ($M)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer</td>
<td>big</td>
<td>4</td>
<td>1,089.93</td>
</tr>
<tr>
<td>Computer</td>
<td>medium</td>
<td>2</td>
<td>-85.75</td>
</tr>
<tr>
<td>Computer</td>
<td>small</td>
<td>14</td>
<td>44.94</td>
</tr>
<tr>
<td>Computer</td>
<td></td>
<td>20</td>
<td>240.87</td>
</tr>
<tr>
<td>Pharmaceutical</td>
<td>big</td>
<td>5</td>
<td>894.42</td>
</tr>
<tr>
<td>Pharmaceutical</td>
<td>medium</td>
<td>5</td>
<td>698.98</td>
</tr>
<tr>
<td>Pharmaceutical</td>
<td>small</td>
<td>2</td>
<td>156.95</td>
</tr>
<tr>
<td>Pharmaceutical</td>
<td></td>
<td>12</td>
<td>600.08</td>
</tr>
<tr>
<td>Pharmaceutical</td>
<td></td>
<td>32</td>
<td>400.32</td>
</tr>
</tbody>
</table>

Compare the summary table with marginal statistics (at left) to the summary table without marginal statistics (at right). You can see that the marginal statistics are added, and a row showing that there are 32 total Computer and Pharmaceutical companies.

Use Quantile Statistics

To add specific quantile statistics, follow these steps:

1. In the box under For quantile statistics, enter value (%) type the desired quantile value (%) for the first quantile (for example, 25).
2. Select the applicable column and click Statistics.
3. Select Quantiles.
4. (Optional) Repeat this process for any additional quantiles.
Change the Format of the Statistics Column Name

To change the format of the statistics column name in the summary table, select from one of the formats in the **statistics column name format** menu. Table 8.1 illustrates the available options. Assume that you are creating a summary table of the mean profits for a company. Your original column name is **Profits ($M)**.

**Table 8.1 Statistics Column Name Format Options and Examples**

<table>
<thead>
<tr>
<th>Option</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>stat (column)</td>
<td>Mean (Profits ($M))</td>
</tr>
<tr>
<td>column</td>
<td>Profits ($M)</td>
</tr>
<tr>
<td>stat of column</td>
<td>Mean of Profits ($M)</td>
</tr>
<tr>
<td>column stat</td>
<td>Profits ($M) Mean</td>
</tr>
</tbody>
</table>

Link to the Original Data Table

You can select whether to link the summary table to the original data table. By default, the **Link to original data table** option is selected. If you want to edit the data in the summary table, deselect the **Link to original data table** option. When the summary table is linked to the original data table, you cannot edit the data in the summary table, since that would modify and compromise the original data.

Within linked tables, if you drag columns from the summary table into the column heading of a new column in the original data table, the values are expanded as if they were matched by grouping columns.

Keep the Summary Window Open

If you select the **Keep dialog open** option, the Summary window remains open after you click **Create**. Notice that once you select this option, the OK button is replaced by a Create button.

Create a Two-Way Table of Summary Statistics by Adding a Subgroup Variable

1. Highlight the column(s) that you want to be the nested variable(s). These are your “subgroup variable(s).”
2. Click **Subgroup** to move the variable(s) into the subgroup list.
3. Highlight the column for which you want statistics summarized by subgroup.
4. In the Statistics list, select the specific statistic that you want.
5. Click **OK**.

For details about the types of statistics, see “Explanation of Statistics” on page 343.
Add a Statistics Column to an Existing Summary Table

After you have created a summary table, you can add columns of descriptive summary statistics for any numeric column in the source table. To do so, from an existing summary table, click on the upper red triangle in the data grid and select Add Statistics Column.

Example of Adding a Statistics Column to an Existing Table

Suppose that you have already created a summary table, and you want to add more statistics to the existing summary table.

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Tables > Summary.
3. Select Type and Size Co and click Group.
4. Click OK.
5. From the red triangle menu in the upper left corner of the data table grid, select Add Statistics Column.

Figure 8.3  Creating a Summary Statistics Column from Within a Data Table

A modified version of the Summary window appears.

6. Select the column that you want, click Statistics, and select the specific statistic that you want. For this example, select profit/emp and click Statistics, and then select Mean.
7. Click OK.

Figure 8.4  Example of a Summary Table with a Summary Statistics Column

The Mean(profit/emp) column is added to the existing summary table.
**Explanation of Statistics**

You can add columns of descriptive summary statistics for any numeric column in the source table by clicking the **Statistics** button and making a selection from the menu.

The Statistics menu gives these summary statistics for numeric columns:

- **N**  The number of nonmissing values.
- **Mean**  The arithmetic mean of a column’s values. It is the sum of nonmissing values (and if defined, multiplied by the weight variable) divided by the Sum Wgt.
- **Std Dev**  The sample standard deviation, computed for the nonmissing values. It is the square root of the sample variance.
- **Min**  The smallest nonmissing value in a column.
- **Max**  The largest nonmissing value in a column.
- **Range**  The difference between Max and Min.
- **% of Total**  The percent of the total count for each group. Or, if you have so specified, the percent of nonmissing values of the column to the total count for each group.
- **N Missing**  The number of missing values.
- **N Categories**  The number of distinct categories.
- **Sum**  The sum of all values in a column.
- **Sum Wgt**  The sum of all weight values in a column. (See “Column Properties” on page 235 in the “The Column Info Window” chapter.) Or, if no column is assigned the weight role, **Sum Wgt** is the total number of nonmissing values.
- **Variance**  The sample variance, computed for the nonmissing values. It is the sum of squared deviations from the mean, divided by the number of nonmissing values minus one.
- **Std Err**  The standard error of the mean. It is the standard deviation divided by the square root of **N**. If a column is assigned the role of weight, then the denominator is the square root of the sum of the weights.
- **CV (Coefficient of Variation)**  The measure of dispersion, which is the standard deviation divided by the mean multiplied by one hundred.
- **Median**  The 50th percentile, which is the value where half the data are below and half are above or equal to the 50th quantile (median).
- **Geometric Mean**  The \( n \)th root of the product of the data. Zero and negative numbers are treated like missing. For example, you might want to compare two companies based on varying metrics that come from different ranges. The statistic is also helpful when the data contains a large value in a skewed distribution.
- **Interquartile Range**  The difference between the third and first quartiles.
**Summarize Data**

Example of Creating a Summary Table

**Quantiles**  the value at which the specific percentage of the argument is less than or equal to. For example, 75% of the data is less than the 75th quantile. The summary window has an edit box for entering the quantile percentage that you want.

**Histogram**  Generates histograms for different groups. Images of the histograms are saved in data table Expression columns.

---

**Example of Creating a Summary Table**

Suppose a researcher is working with Companies.jmp, which groups companies by Type and Size. Follow along with this next example by opening Companies.jmp from the sample data folder that was installed when you installed JMP.

Suppose that the researcher wants to perform the following tasks:

- Create a table that shows the average profit per employee for small, medium, and big computer and pharmaceutical companies. In other words, create a table that contains a row for each size company and a column for the mean profit per employee of each type of company.
- Create it so the cells hold the mean for the subgroup (defined by the intersection of the row and column).

1. Select **Help > Sample Data Library** and open Companies.jmp.
2. Select **Tables > Summary**.
3. Select **Size Co** and click **Group**.

   The researcher selects Size Co as the grouping variable because he wants the values in that column to become rows in the new table.

4. Select **profit/emp** and click **Statistics**.
5. Select **Mean**.
6. Select **Type** and click **Subgroup**.

   This tells JMP to create a column for the average profit per employee (Mean(profit/emp)) for each level (computer, pharmaceutical) of subgroup variable (type).

Figure 8.5 shows the completed Summary window and the resulting summary table.
Figure 8.5 Summary Statistics for a Subgroup

![Request Summary Statistics by Grouping Columns](image)

<table>
<thead>
<tr>
<th>Size Co</th>
<th>N Rows</th>
<th>Mean(profit/emp, Computer)</th>
<th>Mean(profit/emp, Pharmaceutical)</th>
</tr>
</thead>
<tbody>
<tr>
<td>big</td>
<td>9</td>
<td>4530.478</td>
<td>17140.699</td>
</tr>
<tr>
<td>medium</td>
<td>7</td>
<td>-3462.506</td>
<td>24035.115</td>
</tr>
<tr>
<td>small</td>
<td>16</td>
<td>7998.815</td>
<td>38337.191</td>
</tr>
</tbody>
</table>
Summarize Data
Example of Creating a Summary Table
Most JMP platforms present the results of your analyses in a report window. The report window consists of graphs and statistical reports that are often linked to the data table. When you select data in the graph or report, the data is highlighted in the data table. Figure 9.1 shows an example of selected data in a report window and in a data table.

This chapter describes how to customize the colors, lines, data points, and other graphical elements in a report window.

Figure 9.1  Example of a JMP Report Window and Data Table
Navigate Reports

JMP reports are displayed in standard windows with scroll bars and options to resize. They also have other special buttons and menus like those illustrated in Figure 9.2 and those discussed in the following sections.

Figure 9.2 Basics of the Report Window

Table 9.1 Report Window Actions

<table>
<thead>
<tr>
<th>Number</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Click on the disclosure buttons to hide or show sections of the report.</td>
</tr>
<tr>
<td>2</td>
<td>Click on the red triangle menus to access report options.</td>
</tr>
<tr>
<td>3</td>
<td>Right-click in the table to access formatting options.</td>
</tr>
<tr>
<td>4</td>
<td>Click and drag on the borders to resize graphs.</td>
</tr>
<tr>
<td>5</td>
<td>Right-click anywhere in the graph to access formatting options.</td>
</tr>
<tr>
<td>6</td>
<td>Right-click within the axis to access formatting options.</td>
</tr>
<tr>
<td>7</td>
<td>The arrow cursor turns into a hand when you hold your mouse pointer over an axis. Click and drag using to scroll along the axis or to rescale the axis. See “Scroll and Scale Axes” on page 389.</td>
</tr>
</tbody>
</table>

Tip: Consider setting the Autosave Timeout value in the General preferences to automatically save open reports at the specified number of minutes. This autosave value also applies to data tables, journals, scripts, projects, and reports.
Use the Hand Tool

Select the hand tool using the Tools > Grabber option. There are many functions that you can use with the hand tool (also known as the grabber tool) in a report. Here are some examples of how the hand behaves in graphs and plots:

- On histograms, for continuous variables, use the hand tool to change the number of bars or to shift the boundaries of the bars.
- In all report tables, use the hand tool to click and drag columns for rearranging.
- Use the hand tool to change the displayed range of axis values. See “Scroll and Scale Axes” on page 389.

Access Report Display Options

Right-click a disclosure button to show a menu that lets you rearrange the report and gives you control over report outline levels. The resulting menu has the following report formatting options:

- **Close** Closes (hides) that section of the report. This can also be accomplished by clicking the disclosure button.
- **Horizontal** if available, the option switches the outline of the report between a vertical and horizontal layout.
- **Open All Below** Opens all outline levels beneath the level where this command is selected, including that level.
- **Close All Below** Closes all outline levels beneath the level where this command is selected, including that level.
- **Open All Like This** Opens all of the same type of reports as the one that is present in the analysis window. If you analyze several variables at a time, you often want to open many of the same type of report tables all at once. You might also want to open all of the same type of report tables at once when you select multiple options on a single analysis.
- **Close All Like This** Closes all of the same type of reports as the one that is present in the analysis window.
- **Close Where No Outlines** Closes all parts of the report that do not have sublevels. This command is usually used at the top level of the report outline. It is a quick way to see a nesting structure overview of a report.
- **Outline Close Orientation** Specifies the orientation of the outline box when the disclosure button is clicked closed. Available options are Auto, Horizontal, or Vertical. Default orientation is Auto.
Append Item  Displays a submenu, which lists ways that you can add structural items to the report. Items include text, outline title bars, references to other JMP files and windows, a list of all open JMP files, URLs, and scripts.

Add Text Item  Opens a window that enables you to add up to six text items. You can select whether the text items appear with a bullet or initially appear hidden. **Note:** You must click exactly on a hidden text box for the text item to become visible.

Add Outline Item  Open a window that enables you to add a titled outline box. **Note:** The appended outline box contains a red triangle menu listing the append menu items.

Add Window Reference  Opens a window that enables you to select an open JMP window for adding as a link to the selected outline box.

Add File Reference  Displays the Open Data File window that enables you to select a file for adding as a link to the selected outline box.

Add Directory Reference  Displays the Browse For Folder window that enables you to select a directory for adding as a link to the selected outline box. **Note:** Links to each file in the selected directory are appended to the outline box.

Add All Open Files  For each file open in JMP, a new outline box is added. It contains a link to the file.

Add URL Reference  Opens the Create Link to URL window that enables you to add a Link Name and URL. The URL reference link is added to the selected outline box.

Add Script Button  Opens the Add Script Button window that enables you to add a named link to the selected outline box. Clicking the added link runs the specified script.

Edit  Displays the submenu shown in Figure 9.3, which affect all reports at the outline level where they are used:

Select  Highlights all reports for that outline level.

Deselect  Deselects all selected reports for that outline level.

Journal  Duplicates the report in a separate window titled Journal so that you can edit it or append other reports to it. See “JMP Journals” on page 438 in the “Save and Share Data” chapter.

Copy Picture  Copies the report to the clipboard. You can then open another application and paste it.

Page Break  Inserts a page break for printing purposes.

Show Properties  Lets you modify the formatting of display boxes in the report window.

Show Tree Structure  Opens a window that shows the display boxes that make up the report. This is mainly used by JSL programmers who are manipulating or reading parts of the report. See the Display Trees chapter in the *Scripting Guide* for details.
**Restore Window Size**  Returns the selected window to its original size.

An alternative way to access these options is to hold down the Alt key and right-click the disclosure button ▲. This displays a window, as shown in Figure 9.3, with check boxes for commands and options so that you can select multiple actions at the same time. You can also do the same for the menu under a red triangle menu.

![Figure 9.3 Outline Box Menu Items Window](image)

**Show and Hide Parts of a Report**

JMP reports are organized in a hierarchical outline. Each level of the outline has a triangle-shaped disclosure button ▲. Click the disclosure button to open and close that section of the report.

You can also change which columns appear in a report. Right-click the report and select the column from the Columns list. To select more than one column at once, press Alt before right-clicking.

**Combine Several Reports**

Suppose that you perform multiple analyses and want to show all of the results (and the data table) in one window. You can select and combine the reports and the data table in several ways. See “Example of Combining Windows to Create a Dashboard” on page 464 in the “Extend JMP” chapter for details.

**Rename a Title**

To rename a title in a report, double-click on any of the following titles:

- a title next to a red triangle menu
a title next to a disclosure button
• a column title

Increase Font Sizes

On Windows, change the font size that JMP uses in reports and data tables by selecting **Window > Font Sizes**. Then choose from one of the submenu items:

- **Increase Font Size** Increases the font size. Select again to increase the font size again.
- **Decrease Font Size** Decreases the font size. Select again to decrease the font size again.

On Macintosh, select **View > Make Text Bigger** or **View > Make Text Smaller**.

Resize a Window

Report windows are automatically sized to fit the contents of the window. On Windows, you can automatically resize a window after manually resizing it. Hold down the Ctrl key and click the lower right corner of the window.

Red Triangle Options in a Report

Click the red triangle menu in a report to access a list of options that apply for that particular report. In addition to clicking the red triangle menu, you can also:

• Select multiple actions at the same time. Hold down the Alt key and click the red triangle menu. A panel of all commands and options appears with check boxes.
• Apply a command to all similar reports in the report window. Hold down the Ctrl key and click the red triangle menu. For example, in a One-way analysis, if you hold down the Ctrl key, click the icon, and select **Means/Anova/t Test**, an analysis of variance is performed for all One-way analyses in the active report window.

The red triangle options applicable to each platform in the Analyze and Graph menus are described in the following books:

- **Basic Analysis**
- **Consumer Research**
- **Essential Graphing**
- **Fitting Linear Models**
- **Multivariate Methods**
- **Profilers**
- **Quality and Process Methods**
• Reliability and Survival Methods
• Predictive and Specialized Modeling

Local Data Filter

The Local Data Filter gives you a variety of ways to identify subsets of data. You can interactively select complex subsets of data, hide these subsets in plots, or exclude them from analyses. See “The Data Filter” on page 356 for details.

Redo Menus

After performing an analysis, you might want to run the analysis again using different options or variables. You might also want to perform the analysis again if data in the data table have changed. The Redo red triangle menus provide these options.

Column Switcher  Lets you interactively exchange one column for another on a graph. See “Column Switcher” on page 354.

Redo Analysis  Duplicates the analysis based on the previous launch window settings. The analysis appears in a new report window. This option is helpful if the data have changed.

Relaunch Analysis  Opens the launch window and recalls the settings used to create the report.

Automatic Recalc  Automatically updates analyses and graphics when data table values change. See “Automatic Recalc” on page 354.

Save Script Menus

After completing an analysis and receiving a report, you might want to save the process that you used to create the report as a JSL script. You do this by selecting an option from the Script red triangle menu. Most of the Save Script options are the same throughout JMP. A few platforms add extra options that are described in the specific platform chapters. The following Save Script menu options are common to all platforms.

To Data Table  Saves the script to the data table that was used to produce the report. This enables you to run the script again from the data table to recreate the results.

To Journal  Saves a button that runs the script in a journal. The script is added to the current journal. The script contains the path to the data table. Note that if the data table cannot be found, the script does not run.

To Script Window  Opens a script editor window and adds the script to it. If you have already saved a script to a script window, additional scripts are added to the bottom of the same script window.

To Report  Adds the script to the top of the report window.
To Project  Adds the script to the open project.

For All Objects  If you have By groups or similar multiple reports, a script for each object is saved to the script window. Otherwise, this option is the same as Save Script > To Script Window.

For All Objects To Data Table  If you have By groups or similar multiple reports, a script for each object is saved to the current data table.

Data Table Window  Brings the corresponding data table used to create the report to the front. Available only when the report window contains different platforms.

Script All By-Groups

If you specified a By variable in the launch window, the Save By-Group Script menu enables you to save a script for all levels of the By variable to the script window.

In the Save Script menu, To Data Table (All Objects) and To Script Window (All Objects) save a script for all levels of the By variable.

Automatic Recalc

The Automatic Recalc feature immediately reflects changes that you make to the data table in the corresponding report window. You can make any of the following data table changes:

- exclude or unexclude data table rows
- delete or add data table rows

This powerful feature immediately reflects these changes to the corresponding analyses, statistics, and graphs that are located in a report window.

To turn on Automatic Recalc for a report window, click on the platform red triangle menu and select Redo > Automatic Recalc. To turn it off, deselect the same option. You can also turn on Automatic Recalc using JSL.

Platforms that support Automatic Recalc include a preference in the Platforms preferences.

Note: For some platforms, the Automatic Recalc feature is not appropriate and therefore is not supported. These platforms include the following: DOE, Profilers, Choice, Partition, Nonlinear, Neural, Neural Net, Partial Least Squares, Fit Model (REML, GLM, Log Variance), Gaussian Process, Item Analysis, Cox Proportional Hazard, Response Screening, and Control Charts (except Run Chart).

Column Switcher

Within a report, use the Column Switcher to quickly analyze different variables without having to re-create your analysis. To activate the Column Switcher, from a report window, click on the red triangle menu. Select Redo > Column Switcher.
If you have multiple columns, use the buttons to animate the column switching or step through each column manually. Move the slider control to change the speed of the animation.

**Note:** You cannot copy or move the column switcher within a report. Also, a column switcher cannot be saved to a JMP journal.

**Example of the Column Switcher**

You have data about nutrition information for candy bars. You want to examine different factors, to see which factors best predict calorie levels.

1. Select **Help > Sample Data Library** and open **Candy Bars.jmp**.
2. Select **Graph > Graph Builder**.
3. Click **Total fat g** and drag to the **X** zone.
4. Click **Calories** and drag to the **Y** zone.
5. Click **Cholesterol g** and drag to the **Wrap** zone.
6. From the red triangle next to **Graph Builder**, select **Redo > Column Switcher**.

Choose the column that you want to switch from:

7. Select **Cholesterol g** and click **OK**.

Choose the columns that you want to switch to:

8. Select **Saturated fat g**, **Cholesterol g**, **Sodium mg**, **Carbohydrate g**, **Dietary fiber g**, and **Sugars g** and click **OK**.

**Figure 9.4 Column Switcher in Graph Builder Window**
9. Click the **Play** button to cycle between the different factors. Use the slider to control the speed of the animation. Alternatively, you can step through each factor individually. You can see that the relationship between calories and fat is relatively strong for each level of carbohydrate. Therefore, **Carbohydrate g** appears to be the best predictor of calorie levels.

### The Data Filter

The Data Filter gives you a variety of ways to identify subsets of data. You can interactively select complex subsets of data, hide these subsets in plots, or exclude them from analyses.

1. Select **Rows > Data Filter**.

**Tip:** In addition to the main Data Filter, you can also launch a local Data Filter within a platform report. Click the Local Data Filter icon  from the Report toolbar, or select **Local Data Filter** from the red triangle menu in a report.

#### Figure 9.5 Initial Data Filter Window

2. Select the columns that you want to use as filters, and then click **Add**.

Note the following:

- To restore your current row states when the Data Filter window is closed, select the **Save and restore current row states** option.
- If you have a long list of columns, you can sort, show, hide, or search for columns in the list. Use the options in the Add Filter Columns red triangle menu.
- By default, the Data Filter window is attached to the data table. You can detach it temporarily or persistently, as follows:
  - Detach it temporarily by deselecting the **Use Floating Window** option from the Data Filter red triangle menu.
  - Detach it persistently by selecting **File > Preferences > Tables** and deselecting the **Use a Floating Window for Data Filters** option.
Types of Filter Columns

There are three types of filter columns, as follows:

**Continuous columns**  Numeric columns whose modeling type is set to continuous. A continuous filter column is represented by a slider that spans the data range.

**Categorical columns**  Nominal and ordinal columns. For each categorical column, the Data Filter generates a set of distinct categories. These categories can be displayed in different forms.

*Note:* For categorical columns with value labels, if you want to include responses that are not present in the data, select the **Include Responses Not in Data** option from **File > Preferences > Tables**.

**Multiple Response columns**  Character columns that have the Multiple Response column property or Multiple Response modeling type assigned. Each data cell of the column generally consists of multiple categories, separated by some common separator, like a comma. Since each data cell can contain more than one category, multiple response columns have a richer set of filtering options.

Filtering Modes

There are three modes of filtering: **Select**, **Show**, and **Include**. You can set and clear these modes using the corresponding check boxes in the Data Filter.

*Note:* The Select mode is not available for the local Data Filter.

**Select**  Shows the selected rows in the data table in a highlighted state.

You can turn off the automatic selection of this option using the **Data Filter Select Check** preference. See also “Changing the Row State in the Data Table After Making Data Filter Selections” on page 359.

**Show**  Shows the unselected rows with the Hide icon 📌.

You can turn on the automatic selection of this option using the **Data Filter Show Check** preference. For details about row states, see the “Row State Columns” on page 231 in the “The Column Info Window” chapter.

**Include**  Shows the unselected rows with the Exclude icon 🔴.

You can turn on the automatic selection of this option using the **Data Filter Include Check** preference. For details about row states, see the “Row State Columns” on page 231 in the “The Column Info Window” chapter.
There are two additional options when filtering: **Auto clear** and **Conditional**. These options are available from the red triangle menu for the Data Filter. For more information, see “Red Triangle Options for the Data Filter” on page 360.

**The Data Filter Control Panel**

Once you have added columns in the initial window, the Data Filter control panel appears.

**Figure 9.6** Data Filter Control Panel

The main controls in the Data Filter include the following:

**Clear**  Clears all selections that you have made on variables in the Data Filter window.

**Favorites**  Saves your current data filter criteria as a favorite. Once you have created a favorite, selecting it resets the current conditions to the criteria in the favorite. You can also remove the favorite. To retain favorites once the current session ends, save the data filter script by selecting one of the Save Script options from the Data Filter red triangle menu.

**Select, Show, and Include**  See “Filtering Modes” on page 357.

**Inverse**  Inverts the current selection state of the rows in the data table.

**Note:** Only the rows in the data table are inverted, not the selection in the Data Filter. To invert the selection in the Data Filter, from the column’s red triangle menu, select **Invert Selection**.

**AND**  The AND button opens the Add Filter Columns list. The *and* operator restricts the selection. You can add variables to the filter process at any time.

**OR**  The OR button opens the OR Add Filter Columns list. The *or* operator extends the selection. You can add variables to the filter process at any time.
Changing the Row State in the Data Table After Making Data Filter Selections

If you modify a row state that you have set in the Data Filter and subsequently alter row states in the data table, or select points in a graph or plot, the selections in the Data Filter might not match the selections in the data table. The Data Filter contains a warning message that says: “Your selection was changed in another window”. The **Reset Selection** button appears. Clicking the **Reset Selection** button changes the data table selections back to reflect the selections in the Data Filter.

Example of Modifying Selections

1. Select **Help > Sample Data Library** and open Big Class.jmp.
2. Select **Analyze > Distribution**.
3. Select age and sex and click Y, **Columns**.
4. Click **OK**.
5. Select **Rows > Data Filter**.
6. Select sex and click **Add**.
7. In the Data Filter control panel, select all of the males by clicking on the M block.

**Figure 9.7** Rows Containing Males Highlighted in Data Table and Histograms
You can see that all of the rows containing males are highlighted in the data table and in the histograms. Now you decide that you only want to see the students who are age 12.

8. In the age histogram, select the bar representing age 12.

Now the selection does not match the Data Filter selection. A warning message and a [Reset selection] button appear in the Data Filter window.

**Figure 9.8** Data Filter Warning Message and Reset Button

---

### Red Triangle Options for the Data Filter

The red triangle menu next to Data Filter contains the following options:

- **Auto clear**  If you have more than one nominal or ordinal column selected in the Data Filter, this option clears any other selections before making a new selection. For example, using Big Class.jmp, suppose that you have the columns sex (nominal) and age (ordinal) in your Data Filter. If you have males (M) selected for sex, and you click on an age group, say age 12, your selection of males will be automatically cleared. This means that selecting age 12 is not conditional on selecting males. Conversely, if you turn off Auto clear, you can then select both males and age 12 at the same time. Auto clear is on by default.

- **Conditional**  Limits the categories displayed for the unselected filter column. See “Conditional Data Filters” on page 361.

- **Grouped by AND**  Enables you to control the AND and OR behavior of multiple groups of column filters. See “Grouped by AND in Data Filters” on page 362.

- **Use Floating Window**  Keeps the Data Filter window on top of its associated data table. If you do not want the Data Filter window to remain on top, deselect this option.

- **Start Over**  Closes the current Data Filter session and shows the original Data Filter window.

- **Animation**  Sequentially highlights the values of a single variable in the data table. See “Animation in Data Filters” on page 364.

- **Show Subset**  Creates a new data table that contains only the following:
  - The rows identified by the Data Filter.
– The columns selected in the active data table. If no columns are selected, then all columns are included.

This option is similar to the Tables > Subset command, only without subsetting options.

**Save Where Clause**  Builds a WHERE clause based on the value selections that you make.

**Save Script**  Provides options for saving scripts. See “Save Script Menus” on page 353.

### Conditional Data Filters

For filter columns with hierarchy, you can use the Conditional option to filter what appears in the column lists. For example, you could filter by region so that only the states in the selected region appear in the list.

**Note:** If there is more than one OR group, the conditional filter is not available.

The following example illustrates how the Conditional option helps show the subcategories clearly, without the extra categories that do not belong.

1. Select Help > Sample Data Library and open Cities.jmp.
2. Select Rows > Data Filter.
3. In the Data Filter window, select city, State, and Region, and then click Add.
   The Data Filter window appears, showing a list for each variable.
4. Select Conditional from the Data Filter red triangle menu.
5. Select MW in the Region list.
6. Select OH from the State list.

   The cities that are in Ohio and in the Midwest region are selected in the data table. In the Data Filter window, only Midwestern states appear in the State list, and only cities in Ohio appear in the cities list. See Figure 9.9.
The bracketed number in front of the column name indicates the order in which the column values were selected. In Figure 9.9, Region was selected first, so it has a [1] in front of the column name. State was selected second, so it has a [2] in front of the column name.

When you rearrange hierarchical filters that are in ascending order, the filter number changes to match the ascending position in the hierarchy.

To clear the selections and reset the order of the hierarchy, click Clear.

**Figure 9.9 Using the Conditional Option**

Grouped by AND in Data Filters

When you add a filter, click AND, and add another filter, you create a group of filters. Within that group, columns that meet all criteria are selected in the data table.

When you then click OR and add one or more filters, you create a second filter group. Columns that you select in the first group OR columns that you select in the second group are selected in the data table.

You can reverse the AND and OR behavior by selecting Grouped by AND from the red triangle menu.

1. Select Help > Sample Data Library and open Big Class.jmp.
2. Select **Rows > Data Filter**.
3. In the Data Filter window, select the **age** column and click **Add**.
4. Click **AND** and add the **sex** column.
5. Hold down the Ctrl key, select **14** from the **age** filter, and select **M** from the **sex** filter.
   14-year-old males are selected in the data table.
6. Click **OR** and add the **weight** column.
7. Move the left **weight** slider to approximately 112.
   14-year-old males or students who weigh greater than 112 are selected.

**Figure 9.10** Data Filter with OR Condition

8. Select **Grouped by AND** from the Data Filter red triangle menu.
   14-year-olds or males and students who weigh greater than 112 are selected.
Animation in Data Filters

The animation feature sequentially highlights the values of a single variable. The variable’s values highlight in the data table. However, patterns are more interesting if you first create a plot and then animate a variable using the Data Filter to see how it behaves on the plot.

To use the animation feature, from the red triangle menu next to Data Filter, select Animation. Then select the variable that you want to animate. The highlighted frame around the variable indicates which variable is selected for animation.

The Animation Control panel (Figure 9.12) contains the following controls:

- The middle button ( ) starts and stops the animation. After you start the animation cycles, the button changes to a stop button ( ). By default the animation begins with the first value of the topmost variable.
- The backward arrow ( ) moves the animation backward one cycle. Click more than once to go backward more than one cycle.
- The forward arrow ( ) moves the animation forward one cycle. Click more than once to go forward more than one cycle.

Figure 9.11 Data Filter with Grouped by AND Condition

![Data Filter with Grouped by AND Condition](image)

Figure 9.12 Animation Control Panel in the Data Filter

![Animation Control Panel](image)
• The square button ( ) hides the Animation Control section on the Data Filter window. Select Animation from the menu on the Data Filter title bar again to see the Animation Control.

Use the slider to adjust the speed of the animation (slower to faster).

The Animate drop-down menu contains the following options:

- **Forward** Highlights values from first to last.
- **Backward** Highlights values from last to first.
- **Bounce** Highlights forward and then backward repeatedly.

### Save WHERE Clause in Data Filters

Once you have filtered variable values in the Data Filter, that information can be expressed as a JMP WHERE clause. The WHERE clause is used in JSL (JMP Scripting Language) programs to identify specific rows of data for processing or analysis. The Data Filter builds a WHERE clause based on the value selections that you make.

The options in the Save Where Clause menu include the following:

- **To Clipboard** Creates a WHERE clause from the filter criteria and puts it on the clipboard.
- **To Row State Column** Creates a row state column in the data table that has a formula equivalent to the filter criteria.
- **To Data Table** Creates a WHERE clause from the filter criteria and saves it as a JSL command with the current data table in a table property called Filter.
- **To Script Window** Creates a WHERE clause from the filter criteria and appends it to the current script text window, or creates a new script if one does not exist already.
- **To Journal** Creates the WHERE clause from the filter criteria and appends it to the current journal, or creates a new journal if one does not already exist.

### Example of Saving a WHERE Clause

1. Select Help > Sample Data Library and open Big Class.jmp.
2. Select Rows > Data Filter.
3. Select age, sex, and height and click Add.

Select all females who are twelve and fourteen years old and whose height is between 56 and 60 inches:

4. Hold down the Ctrl key and click on the 12 and 14 blocks and the F block.
5. Click on 51 and type 56.
6. Click on 70 and type 60.
7. From the red triangle menu next to Data Filter, select **Save Where Clause > To Script Window**.

The WHERE clause that is created from this example appears in a script window, as follows:

```
Select Where(
  (:age == 12 | :age == 14) & :sex == "F" & (:height >= 56 & :height <= 60)
);
```

### Red Triangle Options for Variables

Some of the red triangle options for a variable can vary, depending on the type of variable.

#### Options for All Types of Variables

The red triangle menu next to any type of variable contains the following generic options:

- **Delete**  Removes the variable from the Data Filter control panel.
- **Clear Selection**  Clears any selection in effect for that variable only.
- **Invert Selection**  Deselects any selected values, and selects all values previously not selected, for that variable only.

#### Options for Continuous Variables

For continuous variables, values appear in a range with a slider that you can adjust in one of the following ways:

- Click and drag the slider bar. You can drag from either end of the slider bar. The selected values appear above the slider bar.
- Click anywhere in the empty (not selected) part of the slider to set the filter range at that point.
- Click on the number to enter the value that you want.

By default, the range of values includes an equal sign, which includes the endpoints. You can remove the equal sign by holding down the Shift key and clicking on the ≤ or the ≥.

The Select Missing option highlights any missing values in the data table.

#### Options for Nominal or Ordinal Variables

For nominal and ordinal variables, values appear in blocks, in a list, or in a menu. If the variable contains only a small number of categories, the values appear in blocks. If the variable contains a large number of categories, the values appear in a list or in a menu. However, you can change these default settings.
The following options are available for nominal or ordinal variables only:

**Display Options**  Changes the appearance of the display. Options can include the following:
- **Blocks Display** shows each level as a block.
- **List Display** shows each level as a member of a list, followed by its frequency.
- **Single Category Display** shows each level, followed by its frequency, in a menu.
- **Check Box Display** adds a check box next to each value. To make this the default setting, select the **Data Filter Check Box Display** option in File > Preferences > Tables.

**Order by Count**  Orders the values in decreasing sort order by count.

**Find**  Provides a text box where you can enter a search string for the selected column. Press the Enter key to perform the search. Once **Find** is selected, the following Find options appear in the red triangle menu:
- **Clear Find** clears the results of the Find operation and returns the window to its original state.
- **Match Case** uses the case of the search string to return the correct results.
- **Contains** searches the data for values that includes the search string.
- **Does not contain** searches the data for values that do not include the search string.
- **Starts with** searches the data for values that start with the search string.
- **Ends with** searches the data for values that end with the search string.

**Options for Variables with the Multiple Response Modeling Type or Column Property**

The following options are available for variables with the Multiple Response modeling type or column property:

**Match None**  Selects only rows containing values that do not match any of the selections

**Match Any**  Selects all rows that contain values that match any of the selected values. By default, this option is selected.

**Match All**  Selects only rows with values that include all of the selected values.

**Match Exactly**  Selects only those rows with values that exactly match the checked values.

**Match Only**  Selects only those rows with contents exactly matching the checked values.

**Match At Least**  Selects at least \( n \) of the selected values.

**Match At Most**  Selects a maximum of \( n \) of the selected values.

**Match Between**  Selects between \( n \) and \( m \) of the selected values.

**Note:** For more details about the Multiple Response property, see the “Multiple Response” on page 247 in the “The Column Info Window” chapter.
Reformat Report Tables

There are many ways to change the formatting of a report table. Right-click a report table to access the following formatting options:

**Table Style** adds borders, shading, and dividing lines to the table. Select from the following options:
- Underline Headings shows the preference setting for Underline Table Headings.
- Shade Headings shows the preference setting for Shade Table Headings.
- Heading Column Borders shows divider lines between columns in headings.
- Column Borders contains borders outside columns and divider lines between columns.
- Row Borders contains borders outside rows and divider lines between columns.
- Shade Alternate Rows shades alternate rows.
- Shade Cells shades the body of the table. When used with Shade Alternate Rows, a darker shade is used on alternate rows.

*Note:* Change the format of all report tables by selecting the preceding options in the JMP preferences. On Windows, the Report Tables options are in File > Preferences > Styles. On Macintosh, select the Report Tables options in JMP > Preferences > Styles.

**Columns** shows or hides columns in the table.

*Note:* Columns whose names begin with a tilde (~), such as ~Bias, are not applicable to the analysis that you ran and do not appear in the table, even if you place checks next to their names.

**Sort by Column** sorts the columns in descending or ascending order by the selected column.

**Make into Data Table** creates a JMP data table from the report table.

**Make Combined Data Table** searches the report for other tables like the one you selected and combines them into a single data table.

**Make Into Matrix** creates a JMP matrix from a report table. See “Turn a Report Table Into a Matrix” on page 369.

**Copy Column** copies the contents of the right-click column to the Clipboard for pasting into another window or application.

**Copy Table** copies the right-click table to the Clipboard for pasting into another window or application.

**Bootstrap** approximates the sampling distribution of a statistic. For more information, see the Bootstrapping chapter in the *Basic Analysis* book.
Modify Display Box Properties in a Report

For each display box in a report, you can change properties such as the font, text color, padding, and alignment. Your changes are included when you save the report as a script, a graphic, or a journal.

To modify display box properties, follow these steps:
1. Right-click the disclosure icon next to the report and select Edit > Show Properties. The Properties pane appears.
2. Modify the report properties.
3. Click the report to view your changes.

Tips:
• In the Properties pane, use the arrow buttons to navigate among display boxes in the display tree.
• After you open the Properties pane, use the Selection tool to select a specific report and change its properties.

Turn a Report Table Into a Matrix

You can create a JMP matrix from a report table. For example, when working with JMP Scripting Language (JSL), you might want to access a report’s table that has been stored into a JSL variable. Or, you might want to store a report table’s values into a table property as either a table property or as a JSL assignment, which is stored within the data table and is accessible via a script or the Formula Editor.

To store a table in matrix form into a global variable, into a table property, or into a table property as an assignment:
1. Right-click anywhere in a report table.
2. Select Make into Matrix.
3. In the window that appears, tell JMP how you want to store the table.
4. (Optional) Rename the variable or property by entering a new name into the box beside Name.

Use Conditional Formatting

Note: You must enable Show conditional formatting in the Reports preferences for your conditional formatting to appear in JMP reports.
To configure reports to use conditional formatting, you must first set your report preferences to enable showing conditional formatting. See “Reports” on page 498 in the “JMP Preferences” chapter for details.

To configure conditional formatting:

1. Open the JMP Preferences window.
2. Select the Reports preference group.
3. Click **Manage Rules.**

   The Conditional Format Rule window appears.

**Figure 9.13** Conditional Format Rule Window

By default, JMP includes conditional formatting for Correlation, Factor Patterns, and PValue. These rules are enabled by default. The PValue rule is applied to columns that contain probability values.

From this window you can Add, Edit or Delete a rule.

### Disable or Enable a Rule

To disable or enable a rule:

1. Open the JMP Preferences window.
2. Select the Reports preference group.
3. Click **Manage Rules.**
   
   The Conditional Format Rule window appears.
4. Select the rule from the list.
5. If **Rule enabled** is selected, select to disable.
6. If **Rule enabled** is not selected, select to enable.
Add a Rule

To add a rule:
1. Open the JMP Preferences window.
2. Select the Reports preference group.
3. Click Manage Rules.
   The Conditional Format Rule window appears.
4. Click Add.
   A blank Conditional Format Rule window appears.

Figure 9.14 Blank Conditional Format Rule Window

5. Add and format conditions as described in “Add a Condition” on page 372.
6. Click OK to save the new rule and return to the previous Conditional Format Rule window.
7. Select Rule enabled to enable the rule.

Edit a Rule

To change the conditional formatting of a rule:
1. In the Conditional Format Rule window, select the rule from the list.
2. Click Edit.
   The Conditional Format Rule window appears, showing the selected rule’s current conditions.
The default rule for PValue includes two conditions. The order of the list indicates the order that the rules are applied. For example, a $p$-value of 0.04 would not invoke the first rule ($x < 0.01$) but would invoke the second rule ($x < 0.05$).

**Note:** You cannot edit an existing condition within a rule. To edit an existing condition, you must delete the condition and then add it. See “Edit an Existing Condition” on page 375 for details.

**Add a Condition**

To add a condition to a rule:

1. Open the rule to view the Conditional Format Rule window.
2. In the Condition area, select a relation from the drop list and enter a value in the text box.
   
   Or
   
   If you want the condition to include a value range:
   
   – Select $>$ or $\ge$ from the relation drop list and enter the value in the text box.
   
   – Select the check box, select the $<$ or $\le$ relation, and enter the value.
3. Format the condition using the procedure described in “Format a Condition” on page 373.

**Tip:** When you click Add, the condition and its format settings are immediately added to the bottom of the condition list and the Condition and Format areas return to their default settings. Verify your settings before you click Add.

4. After verifying your settings, click Add to add the condition to the rule.
5. Use the $\uparrow$ and $\downarrow$ buttons to position the condition within the list.
6. Click OK to save your changes and return to the previous Conditional Format Rule window.

Delete a Condition

To delete a condition from a rule:

1. In the Conditional Format Rule window, select the condition and click Delete.
2. Click OK to save your changes and return to the previous Conditional Format Rule window.
3. Click OK to return to the Preferences window.

Format a Condition

To format values that fall within a condition:

1. With a Condition entered, select a Text Color from the drop list:
   - Default  The value appears without color.
   - Solid    The value appears in the specified color.
   - Dimmed   The value appears dimmed by the specified transparency.
   - Color Range  For ranged conditions, the values appear in color gradients within the specified color range.
   - Dimmed Range For ranged conditions, values appear in dimmed gradients by the specified transparency range.
2. To specify a text color, click the color swatch and select a color.
3. To specify a transparency, enter the percent value (for example, ‘60%’).
   The Sample area displays a preview of the appearance of the text column.
4. Select a Background Color from the drop list:
   - **Default**  The value appears without a color background.
   - **Solid**    The value appears with the specified color background.
   - **Color Range**  For ranged conditions, the values appear with background color gradients within the specified color range.

5. To specify a background color, click the color swatch and select a color. The Sample area displays a preview of the appearance of the text column.

6. To have condition values noted, select an Annotation from the drop list:
   - **None**   No notation is used on the value.
   - **Box**    The value appears in the table with a box around it.
   - **Circle** The value appears in the table with an ellipse around it.
   - *** (asterisk)**  An asterisk (*) appears to the right of values in the table. The Sample area displays a preview of the appearance of the text column.

7. To style the value text, select the **Font Style** from the drop list:
   - **None**   No style is used to format the value.
   - **Plain**  No style is used to format the value.
   - **Bold**   The value appears bolded in the table.
   - **Italic** The value appears italicized in the table.
   - **Bold Italic**  The value appears bolded and italicized in the table.

**Figure 9.17**  Example Formatting

Note: After configuring the formatting, remember to click **Add** to add the new condition to the rule.
Edit an Existing Condition

To change the formatting for an existing condition:

1. In the Conditional Format Rule window, select the condition and click Delete.
2. Re-create the condition by using the procedure described in “Add a Condition” on page 372.
3. Format the conditional using the procedure described in “Format a Condition” on page 373.

Tip: When you click Add, the condition and its format settings are immediately added to the bottom of the condition list and the Condition and Format areas return to their default settings. Verify your settings before you click Add.

4. After verifying your settings, click Add to add the condition to the rule.
5. Use the and buttons to position the condition within the list.
6. Click OK to save your changes and return to the previous Conditional Format Rule window.

Select Points in Graphs

To select a point in a graph, click the point with the arrow cursor. This selects the point as well as the corresponding row in the current data table. To select multiple points, hold down the Shift key while you select points. A point’s label appears when you place the cursor over the point with or without clicking.

Figure 9.18 Label for a Data Point
Select Points in Graphs Using JMP

Tips:

- You can paste the contents of a label into another document. Right-click the label and select Copy. Paste the text into the other document.

- A photo can be displayed in the label if you store the image in an Expression role column. See “Expression Role” on page 254 in the “The Column Info Window” chapter for details.

Select Rows in Graphs

All graphs and plots that represent the same data table are linked to each other and to the corresponding data table. When you click points in plots or bars of a graph, the corresponding rows highlight in the data table. The example in Figure 9.19 shows a histogram with the SPEEDYTYPE bar highlighted, and the corresponding rows highlighted in the table. You can also extend the selection of bars in a histogram by holding down the Shift key and then making your selection.

Figure 9.19  Highlighting Rows in a Histogram

Select a Rectangular Area of Points

You can select all points that fall in a rectangular area using the arrow cursor. Click and drag the arrow to highlight points. Alternatively, you can use the brush tool. As you move the brush over the graph, points that fall within the rectangle are selected. Any points marked in
the data table as hidden are not selected. See “Hide Rows” on page 175 in the “Enter and Edit Data” chapter.

To select points using the brush tool:

1. Click the brush tool \(\begin{array}{c} \text{brush tool} \end{array}\) in the toolbar.
2. Click and hold the cursor (now brush-shaped) in a plot. A rectangle appears.
3. Move the rectangle over points. As it passes over them, they appear highlighted both in the plot and in the active data table.

   To keep all points selected as you move the brush-shaped cursor over points, press the Shift key before you click on a point in the plot. The selected points are also selected in the data table.

   Figure 9.20 Using the Brush Tool

4. Release the mouse. The points within the rectangle and the data table remain selected.
   - To change the size of the selection rectangle, press the Alt key before you click in the plot. Drag the cursor to resize the selection box. This shape acts like a slicing tool that can traverse and highlight slices of points across either axis. **Note:** The size of the selection box is remembered for the next time you use the brush tool.
   - If you press the Ctrl key and click the brush tool on selected points, the points within the selection rectangle are deselected. Points outside the selection rectangle remain selected.

**Select an Irregular-Shaped Area of Points**

You can use the lasso tool to select points that fall in an irregular-shaped area. Any points marked in the data table as hidden are not selected. See “Hide Rows” on page 175 in the “Enter and Edit Data” chapter.
To select points within an irregularly shaped area, follow these steps:

1. Click the lasso tool in the toolbar.
2. Click and hold the cursor (now lasso-shaped) in a plot.

   **Note:** To keep all points selected as you drag the lasso around several sets of points, press the Shift key before you click in the plot.

3. Drag the lasso around any set of points.

   **Figure 9.21** Using the Lasso Tool

4. Release the mouse. JMP automatically closes the lasso and highlights the points within the enclosed area.

---

### Use Markers

Markers are points on a graph that represent data. Once they are changed from their default setting, they also appear next to rows in the data table. The following sections show you how to change marker shape, size, color, and so on.

### Change Marker Shape

You can assign a character from the JMP markers palette to replace the standard points in scatterplots. These markers also appear next to row numbers in the data table.

1. Highlight one or more markers whose shape you would like to change.
2. Right-click anywhere in the graph. In a histogram, right-click the box plot area on the right.
3. Select **Row Markers**.
4. Select a marker shape from the options that appear, or click **Custom** to enter a character to use as a marker.

**Change Marker Colors**

You can assign any color to highlighted rows. When you do this, the points in scatterplots appear in the color that you select from the colors palette. The active color assigned to a row appears next to the row number in the data grid.

To change the color of markers (points) on a graph:

1. Highlight one or more markers whose color you would like to change.
2. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
3. Select **Row Colors**.
4. Select one of the colors, or click **Custom** to apply a custom color.

**Change Marker Size**

To increase or decrease the size of markers (points) on a graph:

1. Right-click anywhere in a graph. Hold down the Ctrl key and right-click to broadcast the command and apply it to all plots of the same type located in the same window. In a histogram, right-click the box plot area on the right.
2. Select **Marker Size**.
3. Select one of the marker sizes listed.
   
   The default value, Preferred Size, is selected on the Graphs page in the JMP preferences.

**Change the Marker Drawing Mode and Transparency**

When working with a large number of markers on a graph, the markers can appear crowded. If this is the case, you might need to alter the transparency to gain a better view. Altering the transparency might also affect the marker drawing mode, which is the mode JMP uses when it refreshes a report window. As it draws markers on a plot, it uses one of two speeds: normal or fast.

*To change the marker drawing speed*

1. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
2. Select **Marker Drawing Mode**, and then select either **Normal** or **Fast**.
**Normal**  If JMP is in normal drawing mode and the number of markers in a graph are more than the specified threshold number, JMP automatically switches to fast mode. See “Reports” on page 498 in the “JMP Preferences” chapter, for details about setting the marker threshold.

**Fast**  Graphs displaying a large number of markers appear faster if you set the marker drawing speed to Fast. Note that when the drawing speed is set to Fast, marker size reverts to Preferred Size, and marker transparency settings revert to the default opaqueness.

**Outlined**  See “Add Outlines Around Markers” on page 380.

*To fill hollow markers*

In the JMP preferences, select Graphs and then select Fill Hollow Markers. Hollow markers on all graphs are filled with an opaque background.

**Add Outlines Around Markers**

You can add a black outline, or frame, to markers in a plot. Outlined markers are available at the medium, larger, XL, XXL, and XXXL marker size. (See “Change Marker Size” on page 379, for details.)

*To add outlines*

1. Right-click a plot or graph.
2. Select Marker Drawing Mode.
3. Select Outlined.

To use an outline effectively, it is best if your marker is a color other than black.

*To change marker colors*

1. Highlight the markers whose color you want to change.
2. Right-click anywhere in the graph.
3. Select Row Colors.
4. Select a marker color from the options that appear.

**Marker Selection Modes**

When you select markers on a graph, only the selected markers are highlighted. You can change how markers are highlighted on the current graph. The options are applied to the top two triangles in the following figure.
To change the marker highlighting on the current graph, follow these steps:

1. Right-click anywhere in a graph and select **Marker Selection Mode**.
2. Select one of the following options:
   - **Preferred Mode**  the Marker Selection Mode that is selected on the Graphs page in the JMP preferences. The default value is Unselected Faded.
   - **Unselected Faded** only the selected markers are highlighted. Everything else is dimmed by the percent specified by **Faded amount for unselected markers** in Preferences > Graphs.
   - **Selected Larger**  the selected markers are larger than the deselected markers.
   - **Selected Haloed**  the edges of the selected markers are outlined in blue.
   - **Selected Outlined**  the selected markers are outlined in black.
   - **Selected Same Color**  the selected markers are shaded with the Marker Selection Color that is selected in the Graphs preferences.

**Specify Marker Transparency**

You can change the transparency of markers (points) on a graph. For example, this enables you to control the visibility of overlapping points.

**Note:** When the drawing speed is set to Fast, marker transparency settings revert to the default opaqueness and marker size reverts to Preferred Size.
To adjust markers' transparency:

1. In a graph, right-click anywhere and select Transparency. In a histogram, right-click the box plot area on the right and select Transparency.

2. Enter the level of transparency that you want the markers (points) to have on the graph, and click OK.

   A value of 1 indicates total opaqueness and 0 indicates invisibility. Values between 1 and 0 are semi-transparent.

**Exclude and Hide Markers**

Use the Rows > Hide and Exclude command to suppress the appearance and exclude from statistical analyses the highlighted rows. Data remains hidden and excluded until you select Rows > Hide and Exclude again.

Using the Exclude/Unexclude command, you can exclude highlighted rows from statistical analyses. Data remains excluded until you select Rows > Exclude/Unexclude for those highlighted rows.

**Note:** Excluded data are not automatically hidden in plots even though they are excluded from calculations in text reports and graphs.

Using the Hide/Unhide command, you can suppress (hide) the appearance of highlighted points in scatterplots. For example, you can exclude points from analysis and then hide those same points in scatterplots. The data remain hidden until you select Rows > Hide/Unhide for highlighted hidden rows.

**Note:** Hidden points are not automatically excluded from statistical computations that affect text reports and graphs, even though they are not displayed in the plots. To exclude hidden observations from analyses, you must highlight them and select Rows > Exclude/Unexclude characteristic.

To exclude or hide markers (points) from analyses, follow these steps:

1. Highlight the marker(s) that you would like to exclude or hide.
2. Right-click anywhere in a graph.
3. Select Row Exclude or Row Hide.

**Add Labels to Markers**

When you position the arrow cursor over a point in a plot, the point’s label appears. By default, the label is the row number. There are three ways that you can customize the label:
Chapter 9
Using JMP

JMP Reports
Use Markers

- You can change the label so that it displays values found in one or more columns instead of the row number.
- You can enable the label to appear always, not just when you position the cursor over points.
- You can click the label with the Arrow tool and drag it to a new location. If a label is dragged a certain distance away from the marker, then a tail is added connecting the label to its point.

For details about changing the appearance of marker labels, see “Reports” on page 498 in the “JMP Preferences” chapter.

To display values found in one or more columns instead of the row number

1. In the data table, highlight the column(s) whose values you want to appear as the label in plots.
2. Select Label/Unlabel from one of the following places:
   - the Cols menu
   - the red triangle menu in the Columns panel
   - the top red triangle menu in the upper left corner of the data grid

A label or yellow tag icon beside the column name in the Columns panel indicates that points on plots are identified by the column value. If there are multiple labeled columns, their values appear on plots separated by a comma. Data remains labeled until you highlight the column and select Label/Unlabel again.

To enable the label to appear always, not just when you position the cursor over points

1. Highlight the point(s) whose label you want to always appear in plots.
2. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
3. Select Row Label.

A label or yellow tag icon beside the row number in the data table indicates that points on plots corresponding to the row appear with a label.

Change Marker Shape or Colors Based On Values

In some plots, you can change marker shapes or colors based on the values of points by adding a row legend. It is called a row legend because JMP automatically inserts a legend using row color or row marker settings. When you assign markers or colors in this way, it assigns the characteristic(s) to all points in a graph, regardless of what points you have selected. All previous marker and color settings are overwritten.
To add shapes or colors based on column values, follow these steps:

1. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
2. Select **Row Legend**.
3. In the window that appears (Figure 9.23), highlight the column whose values you want to color or mark. A preview of the legend is shown on the right.

**Figure 9.23** Adding a Row Legend

4. Refine your row legend using the following options:
   - **Colors**  Lets you choose among several pre-defined color schemes.
   - **Continuous Scale** Assigns colors on a spectrum that corresponds to the ascending or descending order of the values. Use this option when the highlighted column contains continuous values.
   - **Reverse Scale** Reverses the scale of colors.
   - **Markers** Lets you choose among several marker schemes.
   - **Make Window with Legend** Creates a separate legend window that tells you what colors and shapes correspond to which value.
   - **Save Column Property** Adds a column property that stores the selected color theme.
   - **Save Table Property** Adds a table property that preserves the selected color and marker configuration.
   - **Excluded Rows** Assigns colors or markers to rows that are excluded.

Most legends have one column. However, the following platforms have multi-column legends when there are more than 20 levels:

- Recurrence
- Oneway (for CDF Plot and all three Densities red triangle commands)
- Fit Model (for the Regression Plot in Standard Least Squares)
- Survival
Remove the Row Legend

Delete a row legend by right-clicking it and selecting **Remove.**

---

**Change the Appearance of Graphs**

There are many ways that you can format your report to meet your needs. The sections below detail how to make changes to the graphical portions of your output reports.

**Tip:** If you have a touchscreen, you can pan and zoom most graphs and axes in JMP. Graphs and axes change scale and zoom out if pinched, and zoom in if stretched.

---

**Resize Graphs**

There are two main ways to resize graphs: using the click and drag method or resizing it according to pixel size.

**Note:** You can also change the default size of a graph using the Graph Height option in **File > Preferences > Graphs.**

---

**Use Click and Drag**

To resize a plot or graph using the click and drag method:

1. Place the cursor on the right edge, bottom edge, or lower right corner of the plot frame. The cursor changes to a small double-arrow pointer.
2. Click and drag to change the size of the plot. When you resize, the height and width of all plots in that frame adjust independently of other frames in the same report window. Table 9.2 describes how to adjust the plot.

**Table 9.2 Resizing Actions**

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the plot frame but preserve the proportions (aspect ratio)</td>
<td>Hold down the Shift key and click and drag the corner of the frame.</td>
</tr>
<tr>
<td>Adjust a plot in 8-pixel increments</td>
<td>Hold down the Alt key and click and drag the corner of the frame.</td>
</tr>
</tbody>
</table>
Change the Appearance of Graphs Using JMP

Specify Size in Pixels

To resize a plot or graph to a specific pixel size:
1. Right-click the plot or graph.
2. Select Size/Scale > Frame Size.
3. Enter the number of pixels for the frame’s height and width.

Note: For details about the other options in the Size/Scale menu, see “Scroll and Scale Axes” on page 389.

Table 9.2 Resizing Actions (Continued)

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust all plots of the same type simultaneously</td>
<td>Hold down the Ctrl key and click and drag the corner of one of the plots. If you do this for one scatterplot, the action is broadcast to all scatterplots in the window, and they resize together. Any other types of plots remain unchanged.</td>
</tr>
</tbody>
</table>

Zoom In and Out

The magnifier 🔍 lets you automatically zoom in on any area of a plot. When you click the magnifier, the point or area where you click becomes the center of a new view of the data. The scale of the new view enlarges, giving you a closer look at interesting points or patterns. You can perform any of the following actions:

- Click and drag the magnifier to focus in on a particular region of the plot.
- On a ternary plot, drag the magnifier to zoom the triangular axes.
- Zoom repeatedly to look closer at the data.
- Hold down the Control key and click the magnifier to return to your previous state before the last zoom.
- Double-click or hold down the Alt key and click the magnifier to restore the original plot.

On Windows, you can also zoom by holding down the Control key and using the mouse wheel.

Pin Hover Labels on a Graph

When you place your cursor over data on a graph, a hover label with data values appears. You can pin the label so it always appears on the graph. When you save the graph, the label is saved. When you print the graph, the label prints.
Note: The hover label remains pinned after you redo an analysis. However, if the data changed, you might have to reposition the label.

Figure 9.24  Pinned Labels

To pin a label, place your cursor over the data point until the label appears. Click the pin icon in the upper right corner of the label. You can then drag the label to reposition it.

Right-click the label to select the following formatting options:

- **Background Color**  Applies the selected color to the label background.
- **Frame Color**  Applies the selected color to the label border and tag line.
- **Text Color**  Applies the selected color to the text.
- **Filled**  Applies the background color and frame color to the label. Selected by default.
- **Use Gradient**  Shades the background color vertically from light to dark Selected by default.
- **Font**  Applies the selected font family to the text. The default font is determined by your JMP Font preferences.
  
  If a script with a pinned label refers to a font that is not on the computer, the script does not run.

- **Add Text**  Adds text to the bottom of the label.
- **Tag Line**  Draws a line between the label and the data point. The Frame Color is applied to the line.

- **Close**  Removes the label. You can also remove the label by clicking the X in the upper right corner of the label.

Tip: To return to the default label formatting, remove the label and add it again.
**Change Line Widths**

After fitting a line to a graph, or producing a graph with a line already present, you can adjust the width of the line:

1. Right-click anywhere in a graph.
2. Select **Customize**.
3. Select **Smoother**.
4. Change the line width. The value is in pixels.
5. Click **OK**.

**Change the Background Color in a Graph**

To change the background color in a graph, follow these steps:

1. Right-click anywhere in a graph. (To change only the color of a box plot, right-click the box plot area.)
2. Select **Background Color**.
3. Select one of the predefined colors, or create your own color.
4. Click **OK**.

**Change the Color of Histogram Bars**

To change the color of histogram bars, follow these steps:

1. Right-click anywhere in a histogram and select **Histogram Color**.
2. Click a color, or click **Other** and create your own color.

See your operating system documentation for details about creating your own colors.

**Display Coordinates and Temporary Reference Lines**

You can measure points and distances in graphs, or easily find the exact value, or coordinates, of points and distances on plots and graphs. To do this, click the crosshairs tool ✡ and click and hold anywhere on a graph. The coordinate values appear where the crosshairs intersect the vertical and horizontal axis as you drag the crosshairs within a plot.
Figure 9.25 Using the Crosshairs Tool

On a fitted line or curve, the crosshairs identify the response value for any predicted value. On a ternary plot, this tool displays triangular crosshair lines.

Scroll and Scale Axes

The hand tool (also known as the grabber tool) (⼿) provides a way to change the axes and view of a plot:

- On a y-axis, dragging ⬇️ scrolls the y-axis; dragging ⬇️ or ⬇️ scales the y-axis.
- On an x-axis, dragging ⬇️ scrolls the x-axis; ⬇️ or ⬇️ scales the x-axis.

Tip: When you drag an axis to change its scale, JMP automatically updates the major and minor tick increments based on the new axis width. To prevent this (retaining your original increments), hold down the Shift key while dragging.

You can also right-click in a plot or graph, and select Size/Scale (or Graph > Size/Scale). Choose one of the following options:

- To adjust the scale of the X axis, select X Axis. To adjust the scale of the Y axis, select Y Axis or Right Y Axis. For more details about this window, see “Customize Axes and Axis Labels in the Axis Settings Window” on page 390.
- For details about the Frame Size option, see “Specify Size in Pixels” on page 386.
- Select Size to Isometric when the x- and y-axes are measured in the same units and you want distances on the graph to be represented accurately regardless of direction.
Customize Axes and Axis Labels in the Axis Settings Window

Double-click a numeric axis to customize it using the Axis Settings window. Or, right-click the axis area and select **Axis Settings** to access the window.

**Note:** In the Graph Builder and Distribution platforms, you can also customize nominal axes using the Axis Settings window.

Customization features in the window depend on the data type of the axis and the specific platform JMP uses to create the plot or chart. Figure 9.26 shows a typical Axis Settings window for numeric (continuous) axes.

**Figure 9.26** Axis Settings Window for a Numeric (Continuous) Axis

![Axis Settings Window](image)

The Axis Settings window contains the following panels:

- “Scale” on page 390
- “Tick/Bin Increment” on page 393
- “Axis Label Row” on page 395
- “Reference Lines” on page 398
- The Preview panel shows how your current selections will appear on the axis.

**Scale**

In the Scale panel, you can do the following:

- “Change the Axis Scale Type” on page 391
• “Change the Numeric Format of an Axis” on page 391
• “Establish Minimum and Maximum Axis Values” on page 392

Change the Axis Scale Type

When viewing a graph with a numeric axis, you can change the axis scale to one of the following types:

• Linear
• Log
• Power
• Geodesic
• Geodesic US
• Probability Scales (Normal, Weibull, Fréchet, Logistic, and Exponential)

Notes:

• Specific platforms might use other scale types that are fixed and cannot be changed. For example, Destructive Degradation, Degradation, and the X axis in Fit Y by X scatterplots use custom scales. Do not change the scale in these graphs through the Axis Settings window.
• If you selected a scale type of Log, enter the **Base** to use.
• If you selected a scale type of Power, enter the **Power** to use.

To set a default scale type for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 241 in the “The Column Info Window” chapter.

Change the Numeric Format of an Axis

For plots and charts that contain a numeric axis area, you can change the format of the axis. For details about numeric formats, see “Numeric Formats” on page 228 in the “The Column Info Window” chapter.

Notes:

• If you selected Date, Time, or Duration, you need to specify the format of the increments. See “Add and Remove Axis Labels” on page 400. You can also specify label row nesting. See “Label Row Nesting” on page 394.
• If you selected Fixed Dec, enter the number of decimal places that you want JMP to display in the Dec box.
• If you selected Precision, select whether you want to keep trailing zeros and all whole digits.
• To add commas to values that equal a thousand or more, select the **Use thousands separator** option. You must account a space for each comma in the Width box, or else they
might not appear. This option is available for the Best, Fixed Dec, Percent, and Currency formats.

- For a numeric axis, you can adjust the width of the tick mark labels using the Width box.

**Note:** When you change the numeric format of an axis, you do not change the numeric format of the way the values appear in the corresponding data table. To change how a date or time appears in a data table, see “Numeric Formats” on page 228 in the “The Column Info Window” chapter.

Selecting a date interval from the date increment drop-down menu divides the JMP date (number of seconds) into the appropriate units. This gives the plot scale that you want for your data. The date axis must be a column with a JMP date value and appear in the Axis Settings window in the date format found in the Column Info window. However, you can use the Axis Settings window to format the date’s appearance in the plot.

**Establish Minimum and Maximum Axis Values**

For plots and charts that contain a numeric axis area, you can change the minimum and maximum values that you want the graph to display.

Note the following:

- To restore the default minimum and maximum axis settings of a numeric axis, right-click a numeric axis and select **Revert Axis**.
- Select **Reverse Order** to reverse the axes by reversing the minimum and maximum values.

**Tip:** To set a default minimum and maximum axis value for a variable, which avoids making this change every time you run an analysis, see “**Axis**” on page 241 in the “The Column Info Window” chapter.

The example on the right in Figure 9.27 is an enlargement of the point cluster that shows between 80 and 140 in the plot to the left. The enlarged plot is obtained by reassigning the maximum and minimum axis values and changing the number of minor tick marks to 1. (See “**Extend Divider Lines and Frames for Categorical Axes**” on page 399, for details.)
Chapter 9
Using JMP

JMP Reports
Change the Appearance of Graphs

Figure 9.27  Rescale Axis to Enlarge a Plot Section

Tick/Bin Increment

In the Tick/Bin Increment panel, you can do the following:

- “Change Axis Increments” on page 393
- “Add Minor Tick Marks” on page 394
- “Change the Tick Offset” on page 394
- “Label Row Nesting” on page 394

Change Axis Increments

While viewing a graph, you can change the axis increments.

If the axis Format is set to Date, Time, or Duration, a format menu appears beside Increment. See Figure 9.28. Select which format you want the increments to take.
Figure 9.28 Selecting the Format for Date and Time Increments

Tip: To set a default axis increment for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 241 in the “The Column Info Window” chapter.

Add Minor Tick Marks

You can add tick marks to a numeric axis, or change the number of minor tick marks that appear on a numeric axis. In the Axis Label Row panel, be sure to select the Minor Tick Marks box so that the tick marks appear on the axis.

Tip: To set default minor tick marks for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 241 in the “The Column Info Window” chapter.

Change the Tick Offset

To change the starting point of the tick marks, enter a number in the Tick Offset box. For example, if the Tick Offset is currently set to 0, setting it to 1 will move all the values on the axes up by 1.

Label Row Nesting

This option appears only if you have selected Date, Time, or Duration as the axis Format. Label row nesting enables you to split a date axis into multiple rows based on the format. For example, you might put the year on the outermost row, then the month, then the day:

1. Select Help > Sample Data Library and open Stock Prices.jmp.
2. Select Graph > Graph Builder.
3. Drag Date into the X zone.
4. Drag Open into the Y zone.
5. Double-click the X axis.
6. For Format, select Date > ddMonyyyy.
7. Increase the value for Label Row Nesting to 3.
8. Click OK.
9. Click Done to see the finished graph.

Figure 9.29 Example of Label Row Nesting

Axis Label Row

In the Axis Label Row panel, you can do the following:

- “Change Axis Label Font” on page 396
- “Add Tick Marks, Grid Lines, or Labels” on page 396
- “Change the Orientation for Tick Labels” on page 398

Note: In Graph Builder, if you have nested labels in an axis, tabs appear in the Axis Label Row panel. You can modify each row of labels separately in its own tab.
Change Axis Label Font

You can modify the axis label font on any axis type. Your changes only apply to the active graph. To set the default axis label font, see “Fonts” on page 521 in the “JMP Preferences” chapter.

**Note:** Windows 7 does not support the Adobe Compact Font Format (CFF). As a result, JMP cannot render axis labels using CFF fonts (like certain OpenType fonts). Windows 8 supports CFF fonts. Therefore, JMP correctly renders axis labels using CFF fonts.

To change the current font type and size, perform one of the following steps:

- Right-click an axis label and select **Font**
  or
- Right-click an axis and select **Axis Settings.** Click **Font.**

**Notes:**

- To change the font color, right-click an axis label and select **Font Color.**
- Select **Automatic Font Size** to have JMP attempt to decrease the font size (down to a certain minimum) if all of the labels cannot fit at the default size.

Add Tick Marks, Grid Lines, or Labels

These options can vary depending on whether your axis is continuous or categorical. Figure 9.30 shows axis settings for a categorical axis. Figure 9.26 on page 390 shows axis settings for a continuous axis.

**Note:** Remember that the Axis Settings window is available only for categorical axes in Graph Builder and Distribution.
Figure 9.30 Axis Label Row for a Categorical Axis

Options for continuous axes:

- Select **Automatic Tick Marks** to turn on tick marks only if one or more labels is hidden (due to insufficient space).
- Add major or minor tick marks, grid lines, or labels, by selecting the corresponding check boxes.
- Click the color box to change the color of grid lines.
- Select **Tick marks inside graph frame** to move the tick marks inside the graph.

Options for categorical axes:

- The default is to not show tick marks if all of the labels are visible. To add tick marks, select **Show Tick Marks**.
- Select **Automatic Tick Marks** to turn on tick marks only if one or more labels is hidden (due to insufficient space).
- Add grid lines by selecting **Show Grid**.
- Click the color box to change the color of grid lines.
- Select **Tick marks inside graph frame** to move the tick marks inside the graph.
- Select **Lower Frame** to add a frame around the labels.
• Change the Tick Mark Style by selecting one of the options.
• Modify the labels by entering different values in the Label boxes.

**Tip:** To set default tick marks for a variable, which avoids making this change every time you run an analysis, see “Properties That Control the Display of Columns” on page 241 in the “The Column Info Window” chapter.

### Change the Orientation for Tick Labels

To change the orientation for tick labels, select an option from the Label Orientation list.

- **Automatic**  
  Tick labels are oriented automatically to be readable, depending on the tick increment and length of the labels.

- **Horizontal**  
  Baseline at the bottom.

- **Vertical**  
  Vertical with the baseline on the right.

- **Perpendicular**  
  Horizontal for vertical axes and vertical for horizontal axes.

  **Note:** Parallel and Perpendicular are useful with paired axes, like in Multivariate plots.

- **Parallel**  
  Vertical for vertical axes and horizontal for horizontal axes.

- **Angled**  
  Angled at about 45 degrees.

### Reference Lines

To add reference lines to graphs, proceed as follows:

1. Double-click a numeric axis. Or, right-click a numeric axis and select **Axis Settings**.
2. In the Value text box, enter the value to which you want the reference line to correspond. This is the position on the graph at which the line is placed.

  **Note:** If you opened the Axis Setting window by double-clicking on the graph, the default value corresponds to the point on the graph that you clicked.

3. Enter a Label for the line.
4. You can further customize the reference line by choosing either of these options:
   - Select **Allow Ranges** to enter a minimum and a maximum value, which define the beginning and the end of the reference line. The reference line appears over a range of data.
   - Color changes the line color. You can also specify the opacity.
   - Line Style specifies the line style (when Allow Ranges is not selected). You can also specify the line width.
5. Click **Add**. The value moves into the box to the right of the Add button, indicating that it will be placed on the graph. Your changes appear in the Preview window.
6. To add more lines, repeat the above steps.
7. To modify an existing reference line, make your changes, and then click **Update**.

**Tip:** To set a default reference line for a variable, which avoids making this change every time you run an analysis, see “Properties That Control the Display of Columns” on page 241 in the “The Column Info Window” chapter.

**Customize Axes and Axis Labels Using the Right-Click Menu**

Right-click on an axis to perform the following tasks:

- “Extend Divider Lines and Frames for Categorical Axes” on page 399
- “Add and Remove Axis Labels” on page 400
- “Rotate Axis Labels and Tick Marks” on page 400
- “Copy and Paste Graph Contents” on page 401
- “Copy and Paste Axis Settings” on page 401

**Extend Divider Lines and Frames for Categorical Axes**

Extending the vertical divider line(s) between tick labels is useful when there are many levels of a nominal or ordinal (categorical) variable.

To extend the divider line to the x-axis labels, follow these steps:

1. Right-click a nominal or ordinal axis.
2. Select **Tick Marks > Divider Lines** to add the lines, or **Lower Frame** to add a frame around the axis area.
Add and Remove Axis Labels

You can add or remove labels in a numeric axis. To add an axis label:

1. Right-click a numeric axis and select Add Axis Label.
2. Enter a name for the axis label. The axis area enlarges to hold the number of label lines that you enter.

This command can be used multiple times to add multiple labels. To edit the label after it has been added to the axis, click it and it will turn into an edit box.

To remove an axis label, right-click a numeric axis and select Remove Axis Label. The last label added is removed.

Rotate Axis Labels and Tick Marks

You can modify the axis label on any axis type.

To rotate an axis label, follow these steps:

1. Right-click an axis label.
2. Select Rotate Text.
3. Select which direction to rotate the text: Horizontal, Left, or Right.

**Tip:** To set a default axis label position for a variable, which avoids making this change every time you run an analysis, see “Properties That Control the Display of Columns” on page 241 in the “The Column Info Window” chapter.

On a nominal axis, you can rotate tick marks. Right-click the tick label and select Rotated Tick Labels.
Copy and Paste Graph Contents

After customizing a graph by adding elements such as a fitted line, you can copy and paste the contents from one graph to another compatible graph:

1. Right-click the graph that you have customized.
2. Select Edit > Copy Frame Contents.
3. Right-click the graph to which you would like to copy the settings.
4. Select Edit > Paste Frame Contents.

Note: If you are having difficulty pasting histogram bars, see the JSL workaround in the Scripting Graphs chapter in the Scripting Guide.

Copy and Paste Axis Settings

After customizing an axis (as described in “Customize Axes and Axis Labels in the Axis Settings Window” on page 390), you can copy and paste your new settings to another axis:

1. Right-click the axis that you have customized.
2. Select Edit > Copy Axis Settings.
3. Right-click the axis to which you would like to copy the settings.

Change the Order of Values

Data in a JMP report might not appear in the order that you prefer. To give data a specific order so that it appears that way in a report, assign the column the Value Ordering property before running the analysis, as described in “Value Ordering” on page 239 in the “The Column Info Window” chapter.

If your values include any of the following, they automatically appear in the appropriate order in reports:

- January, February, March, April, May, June, July, August, September, October, November, December
- Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
- Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
- Very Low, Low, Medium Low, Medium, Medium High, High, Very High
- Strongly Disagree, Disagree, Neutral, Indifferent, Agree, Strongly Agree
- Failing, Unacceptable, Very Poor, Poor, Bad, Acceptable, Average, Good, Better, Very Good, Excellent, Best
Change the Pattern and Format of Selected Objects

Patterns appear on some objects such as bars and maps when you select them. You can change the pattern for a specific object in the legend.

Right-click the item in the legend and select Fill Pattern to select a new pattern.

To remove the pattern, right-click the item again and select Revert.

Modify the Format of Selected Objects in All Graphs

Select File > Preferences > Graphs (Windows) or JMP > Preferences > Graphs (Macintosh) to change the Filled Areas preferences.

- To change the highlight on selected objects, select one of the following Filled Selection Mode preferences:
  - Selected Patterned: Striped pattern (the default setting)
  - Selected Darkened: Solid darker color
  - Selected Outlined: Outline
  - Selected Same Color: The Fill Selection Color in the preferences formats the selected object.
- To change the color of selected rows in graphic objects when the Fill Selection Mode is “Selected Same Color”, click the Fill Selection Color bar. The default color is red.

Add a Graph to a Data Table

You can add a graph to a new data table. Right-click on a graph and select Edit > Make table of graphs like this. The graph and the variables appear in a new data table.

Tip: To make the graph larger, resize the table cell.

Figure 9.32  Histogram and Y Variable Added to Data Table
Customize Graphical Elements

Graphs consist of markers, lines, text, and other graphical elements that you can customize. For example, in a Scatterplot Matrix graph, you might want to highlight data points in one of the bivariate graphs with a pink solid marker. In a Contour Plot graph, you can increase the width or transparency of the contour lines.

Example of Customizing a Contour Plot

1. Select Help > Sample Data Library and open Little Pond.jmp.
2. In the Table panel, click the green triangle next to the Contour Plot script.
3. Click on the red triangle next to Contour Plot for Z and deselect Fill Areas.

Figure 9.33 Contour Plot before Customization

4. Right-click on the plot and select Customize.
   The Customize Graph window appears.
5. Click Shape.
6. Change the Line Width to 2.0.
7. Click on the color next to Line Color and select a shade of green.
8. Click OK.
The graphical elements that you can customize differ on each graph. For example, in a Control Chart graph, there are three line elements (Marker, Lower Limit, Upper Limit and Connect Line). In other graphs, the line element might be named Line or Custom.

To customize graphical elements in the current graph, follow these steps:

1. Right-click the graph and select **Customize**.
2. Select the element that you want to change, and then modify the properties.
   - Your changes are immediately shown on the graph.
3. Click **OK** to save your changes to the current graph.

Each element can include properties for line color, marker style and size, text style, and so on. Here are some common properties:

- **Line Color**  Changes the color of the line. Click to select any color in the window. Right-click to choose from more colors.
- **Line Style**  Changes the style of the line. Click to select one of five different styles.
- **Line Width**  Changes the width of the line. Click in the box and enter the desired line width in points.
- **Marker**  Changes the marker shape. For more information about markers, refer to “Use Markers” on page 378.
- **Marker Size**  Changes the size of the marker.
- **Arrow**  Adds an arrowhead to a line at either None, Start, End, or Both ends of the line.
- **Line of Fit**  Changes the color, width, or style of the line.
- **Text Color**  Changes the color of the text.
Font  Changes the font, style, and point size of the text.

Text Style  Changes the text alignment to centered, left-aligned, or right-justified. The Fill option applies the selected color to the background.

Fill Color  Changes the color of objects such as box plots and Fit Confidence regions.

Fill Pattern  Changes the pattern of filled objects.

Transparency  Changes the marker or label transparency. Enter the level of transparency to draw markers (points) on the graph. The degrees of opacity ranges from 0 (clear) to 1 (opaque). For more information about changing the transparency of markers, see “Specify Marker Transparency” on page 381.

Create Scripts for Graphical Elements

In addition to customizing graphical elements, you can write JSL scripts that add elements. These scripts run when you display the graph. You can write the scripts from scratch, or you can select from the following lists of commands and scripts, accessed by clicking on the Add a new script button +:

- Use the Templates list to insert a single JSL command. For example, the Polygon option inserts the Polygon command. The text enclosed in underscores are placeholders for point values, which you replace with your own values.

  \[
  \text{Polygon}([_x0_, _x1_, ...], [_y0_, _y1_, ...]);
  \]

- Use the Samples list to insert a script that creates elements such as bubble plots and sine waves. In this list, the Polygon option shows examples of the Transparency, Fill Color, and Polygon values, which you replace with your own values.

Figure 9.35  The Polygon Sample Script

In some graphs, you can view the JSL that creates graphical elements. Figure 9.36 shows the Group Label script for a Discriminant Analysis graph. The script defines markers and text for group labels. The commands included in these built-in scripts cannot be modified or deleted.
You can insert commands from the Templates or Samples list, but you cannot click in the window and type new commands.

**Figure 9.36 Example of JSL That Creates Group Labels**

For information about JSL, see the *Scripting Guide* and the *JSL Syntax Reference*.

To create a graphics script, follow these steps:

1. Right-click on the graph and select **Customize**.
2. Click the **Add a new script** button ( ) to create a new script.
   - The default name, Script, is highlighted.
3. With the default name highlighted, type a more descriptive name, and then press Enter. (If you already moved the cursor and the name is no longer highlighted, double-click Script, and then enter the new name.)
4. Do one or more of the following:
   - Enter JSL in the Properties window.
   - Select one or more JSL commands from the Templates list, and modify the placeholder text. For example, change the Pen Color option from “blue” to “red.”
   - Select one or more sample scripts from the Samples list and modify, if necessary.
5. (Optional) Click **Apply** to update the graph with your changes without closing the window. Unlike other property changes, script changes to not take effect until you click **Apply** or **OK**.
6. Click **OK** to save your changes.

One of the following occurs:

- The element that you created appears on the graph.
- An error message appears if the script contains an error. Select **View > Log** to read about the error, and then correct the script.

To delete a script that you created, select the script and then select the **Delete selected object** button ( ).
Change the Drawing Order of Graphical Elements

The graphical elements are drawn in the order in which they are listed. The first element on the list is drawn first, so it appears behind all other graphical elements. If one element hides another, you can rearrange the order of the elements.

To rearrange graphical elements

1. Right-click the graph and select Customize.
2. Select the element that you want to move.
3. Click the Move up in drawing order button (↑) or Move down in drawing order (↓) button one or more times until the elements are in the order in which you want them drawn.
4. Click OK.

Save Your Customizations

The graph customizations apply to the current graph and are also used when you redo an analysis. To re-create your graph at a later time with its customizations, select Save Script from the red triangle menu, and then select one of the Save options. For example, you can save the script to the data table, which applies your customized properties each time you run the script. See “Save Your Analysis as a Script” on page 434 in the “Save and Share Data” chapter for details.

Copy Your Customizations

You can copy your customizations from one graph to another. All objects that you created or modified, such as colored text or lines, are pasted to the other graph.

To copy lines from one graph to another, see “Copy and Paste Graph Contents” on page 401.

To copy other objects

1. Right-click in the graph with custom elements and select Edit > Copy Customizations.
2. Right-click in the destination graph and select Edit > Paste Customizations.

The objects appear on the current graph and are added to the list of customized elements.

Notes:

- The customizations are pasted into all similar graphs when you press Ctrl, click, and then paste.
- The copy customizations feature copies only the elements that you added or modified. It does not copy the other contents of the graph.
Add Images to a Graph or Report

To enhance your analyses with logos and other types of graphics, paste or drag and drop graphics into the graph or report. .bmp, .emf, .jpeg, .png, and .rtf graphic formats are supported.

Paste a Background Image into a Graph

1. Open the graphic file in a graphics program and select the graphic. Copy it to the computer’s clipboard.
2. Right-click inside a graph.
3. Select Edit > Paste Background Image. The graphic is inserted at the point in the graph that you right-clicked.

Paste an Image at the End of a Report

You can also add the graphic to the end of a report window. Copy the graphic from a graphics program onto your computer’s clipboard, display the report window, and select Edit > Paste.

Drag and Drop an Image into a Graph

To add an image that you created, generate your report and then drag and drop the image from your computer’s file system onto the graph in the report. After you add the image, JMP provides several options such as resizing, formatting, and rotating an image. Right-click the image and select Image to see these options.

The following example shows a bivariate plot of wind speeds in the Chicago area. The plot on the left includes arrows to illustrate the wind direction and speed. A map image was dropped onto the plot and resized to line up the markers with the stations that provided the wind data (each dot representing a station).
Image Processing

JMP includes a variety of image processing options. Image processing includes filters that can sharpen, blur, resize, and enhance. JMP also allows flipping, rotating, and locking images. This section describes the processing options.

Notes:

• Repeated changes to images can degrade the image quality. If you are not happy with the results of sizing, scaling, or applying filters to the image, remove the image and start again.

• All JMP image filters are supported at the operating system level; images might be processed differently on Windows and Macintosh.

Lock

Locks the image in place so that it cannot be moved.

Size/Scale

• **Fill Graph**: Resizes the image proportionately to fit the graph.

• **Specify Size**: Resizes the image according to the values that you enter. (The units for these values are the same as your graph axes.)

• **Crop**: Crops the image according to the values that you enter. (The units for these values are the same as your graph axes.) For example, the left edge might be positioned at 50. You enter 60 next to Left, and the portion of the image between 50 and 60 is removed from the image.

Flip

• **Flip vertical**: Flips the image top to bottom.
Flip horizontal: Flips the image left to right.

Flip both: Flips the image both horizontally and vertically.

Rotate

Rotates the image the specified number of degrees. Enter a negative value to rotate the image counterclockwise.

Transparency

Changes the image transparency level. Enter a value between 0 and 1 (where 1 is completely opaque).

Filter

Provides filters found in many graphic editing programs to change the appearance of the image. Select a filter repeatedly to increase its effects on the image.

Contrast: Optimizes the light and dark colors. Larger values lighten the image.

Despeckle: Removes pixels that do not blend with surrounding pixels. For example, a black pixel surrounded by white pixels is converted to a white pixel.

Edge: Darkens everything but the outlines of objects.

Enhance: Reduces the contrast between pixels in a noisy image.

Gamma: Balances the brightness of an image and the red, green, and blue (RGB) ratios. Larger values create a lighter image.

Gaussian Blur: Blurs pixels by the specified radius. Larger radii create a smoother image. (In JSL, you can also specify the sigma value. Larger sigma values create a smoother image.)

Median: Replaces each pixel color value with the median value of the surrounding pixels.

Negate: Converts each pixel to its complementary color (such as pink to green and white to black).

Normalize: Removes a percentage of the top and bottom color values. The color values are then stretched to fill the remaining image. This process increases the intensity of the colors.

Reduce Noise: Finds the minimum and maximum color values and replaces them with values more consistent with the surrounding pixels. Larger values create a smoother image.

Sharpen: Makes the edges of pixels more distinct.

Remove

Removes the image from the report.
Add Geographical Images and Boundaries

Adding map images and political boundaries to graphs provides visual context to geospatial data. For example, you can add a map to the graph that displays an image of the U.S. Another option is displaying the boundaries for each state (when data includes the latitudes and longitudes for the U.S.).

The data should have latitudinal and longitudinal coordinates. Otherwise, the map has no meaning in the context of the data. The x and y axes also have range requirements based on the type of map. These requirements are described in the following sections.

Two tools are especially helpful when you are viewing a map:

- The grabber tool (ưởng) lets you scroll horizontally and vertically through a map.
- The magnifier tool (🔍) lets you zoom in and out.

The following sections describe the map images and boundaries that you can add to a graph. For details about adding maps, see the Create Maps chapter in the *Essential Graphing* book.

Extract Data from an Image

JMP provides the ability to extract information from images into a data table and then analyze that information. Researchers at WildTrack.org analyze digital footprint photos in JMP to track endangered species. They drag and drop a footprint image into a JMP report and draw data points to capture the size and shape of the print. A JMP Scripting Language (JSL) script extracts those measurements into a data table. At that point, the researchers can analyze the data and determine whether the footprint is from a new animal. This method helps them track populations of endangered species in specific regions of the world.
Add Annotations and Shapes to a Report

You can add text notes, lines, polygons, ovals, and rectangles to a report using graphics tools found in the toolbar.

Add Annotations

You can add editable text notes to a JMP report using the annotate tool 📝. To add an annotation:

1. Select the annotate tool 📝 from the Tools menu or toolbar.
2. Click the location in the window where you want to add the annotation. Or, click and drag to size the annotation note. A white editable text box appears.
3. Enter text.
4. Click outside the annotation. The annotation turns yellow.

The details for implementing this feature are beyond the scope of this book, because the needs of the user vary widely. For details about writing JSL scripts, see the Scripting Guide and the JSL Syntax Reference.

Analysis shows that the footprint above is from a tiger whom WildTrack has already cataloged.
5. (Optional) Right-click the annotation to access the following options:

- **Background Color**  Provides you with a color palette, from which you can select the background color for the annotation.

- **Text Color**  Provides you with a color palette, from which you can select the color for the annotation’s text. The color of the font also defines the color of the annotation outline. If you select the same color for both the background and the font, the font does not show except for black and white. A black font on a black background changes to white, and a white font on a white background appears black.

- **Font**  Lets you change the current font type, style, and size. To change the default font, see “Fonts” on page 521 in the “JMP Preferences” chapter.

- **Tag Line**  Attaches a line to the annotation that points to a place in the text, as shown below. To move the line with the annotation to a new position, press the Ctrl key and drag the annotation.

- **Filled**  Removes the background color from the annotation so that it looks transparent. A transparent note is handy for putting titles and footnotes on a graph.

- **Editable**  Makes the annotation editable by double-clicking on it.

- **Reanchor**  Reanchors the annotation.

- **Delete**  Deletes the entire annotation.

**Note:** When adding multiple annotations, press the Shift key when selecting the annotation tool for the first time. This causes subsequent clicks to add an annotation, and you do not have to select the annotate tool from the toolbar before the addition of each annotation.

Once you have added an annotation, you can do the following:

**Table 9.3 Using Annotations**

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to or edit an annotation</td>
<td>Click inside the text box.</td>
</tr>
<tr>
<td>Move an annotation</td>
<td>Click inside the annotation box and drag it. When an annotation is moved, it becomes selected, as indicated by a double blue line with handles around the perimeter.</td>
</tr>
<tr>
<td>Resize an annotation</td>
<td>Place the cursor on the handle of a selected note (showing in the middle of the edges and in the corners). The cursor appears as a single crossed arrow; drag to resize the annotation.</td>
</tr>
</tbody>
</table>
Add Shapes

You can add editable lines, polygons, and simple shapes (ovals or rectangles) to a JMP report using the drawing tools. The following sections describe how each of these tools can be used.

**Note:** Each graphics tool remembers the most recent options chosen. This is useful if you need many annotations or other graphics with the same characteristics. For example, suppose you want many thick green lines with an arrow on one end. Create a line the way you want it, set the options, and subsequent lines appear with those options in effect. The options persist until you change them.

### Add a Line

To add a line to a report window:

1. Click the line tool in the tool palette.
2. Click and drag where you want to insert the line. The line appears selected, showing handles on both ends.
3. Click and drag the line to move it.
4. Click a handle and drag to rotate the line.
5. Right-click a line for a menu of options to customize the appearance of the line, as follows:

   - **Point to and Point from** Places arrows on either end (or both ends) of the line.
   - **Thick** Changes the width of a line to thick. Lines are thin by default.
   - **Dashed** Changes the line to dashed. Lines are solid by default.
   - **Color** Displays the JMP color palette to change the color of the shape.
   - **Reanchor** Reanchors the shape.
   - **Delete** Removes the shape from the report surface. You can also remove the shape by selecting it and then pressing the Delete (or Backspace) key.
Add a Polygon or Bezier Curve

To add a polygon (or Bezier curve) to a report window:

1. Click the polygon tool in the tool palette.
2. Click to create the beginning point for the first side of a polygon.
3. Click again at the location where you want to complete the first side and begin an adjacent side. A square selection box with handles appears around the polygon area.
4. Click a third time to complete the second side.
5. Continue this process until the polygon is the way you want it. Each time a side is complete, the selection box adjusts to encompass the polygon sides.
6. Double-click to release the polygon tool.

Once you have added a polygon, you can perform the following actions:

Table 9.4 Working with Polygons

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select or deselect the polygon</td>
<td>Click the edge of a completed polygon.</td>
</tr>
<tr>
<td>Resize the polygon</td>
<td>Select it and drag one of the selection box’s handles.</td>
</tr>
<tr>
<td>Move the polygon</td>
<td>Click between the box’s handles and drag the selection box.</td>
</tr>
<tr>
<td>Change the number of sides of the polygon</td>
<td>Click and drag the sides to form the new shape.</td>
</tr>
</tbody>
</table>

Right-click a polygon for a menu of options to customize its appearance, as follows:

- **Filled**: Fills or empties the area of the shape.
- **Raised**: Displays thick shaded lines around the shape. If the shape is also filled, the lower edge of the figure appears raised, giving it a three-dimensional look.
- **Smooth**: Smooths the vertices of a polygon to produce a Bezier curve. The smoothed figure is reshaped and resized the same way as the polygon, and can be filled and raised.
- **Closed**: Opens or closes the last segment of a polygon.
- **Color**: Displays the JMP color palette to change the color of the shape’s sides, and its fill color when the Filled option is in effect.
- **Reanchor**: Reanchors the shape.
- **Delete**: Removes the shape from the report. You can also remove the shape by selecting it and then pressing the Delete (or Backspace) key.
Add an Oval or Rectangle

To add an oval or rectangle to a report window:

1. Click the simple shape tool in the tool palette.
2. Click and drag where you want to insert the shape. An oval appears with a selection box around it.
3. (Optional) To turn the oval into a rectangle, right-click on the oval and select \texttt{Shape > Rectangle}.
4. Double-click to release the simple shape tool.

Once you have added the shape, you can do the following:

- Select the shape and drag one of the selection box handles to reshape or resize.
- Click and drag an edge of the selection box (located between the handles) to move it.
- Select the shape, and then right-click it for a menu of options to customize its appearance, as follows:
  
  \begin{itemize}
    \item \texttt{Filled} \quad Fills or empties the area of the shape.
    \item \texttt{Raised} \quad Displays thick shaded lines around the shape. If the shape is also filled, the lower edge of the figure appears raised, giving it a three-dimensional look.
    \item \texttt{Shape} \quad Displays a submenu whose options transform the shape into either an oval or a rectangle when selected.
    \item \texttt{Color} \quad Displays the JMP color palette to change the color of the shape’s sides and its fill color when the Filled option is in effect.
    \item \texttt{Reanchor} \quad Reanchors the shape
    \item \texttt{Delete} \quad Removes the shape from the report. You can also remove the shape by selecting it and then pressing the Delete (or Backspace) key.
  \end{itemize}
This chapter covers the following topics:

• Save data tables as text files, SAS data sets, Excel files, and other formats
• Save reports as interactive HTML, Adobe Flash files, and PowerPoint
• Email reports and data tables
• Save analyses as scripts
• Create JMP journals or projects
• Save log windows

The method that you choose depends on how you want to interact with your analyses in the future:

• If you want to interactively present your data, you might choose to create a JMP journal.
• If you want to send data tables, linked reports, and other items to someone, you might choose to create a JMP project.
• If you want to continue to explore a report later, you might choose to create a JMP report.
• If you want to send a report to a non JMP user, you might convert the report to interactive HTML.
Save and Share Data Tables

JMP saves data tables in the formats listed in Table 10.1.

Here are the basic steps for saving a data table:

• On Windows, select **File > Save As** to save in multiple formats.

• On Macintosh, select **File > Save As** to save as a JMP file (**.jmp**) and **File > Export** to save in Text (**.dat**), Microsoft Excel (**.xls** or **.xlsx**), SAS Transport (**.xpt**), and SAS Data Sets (**.sas7bdat**) formats.

**Note:** To save a data table as a journal or layout, select **Edit > Journal** or **Edit > Layout** and then **File > Save As**.

### Table 10.1 Supported File Types for Saving Data Tables

<table>
<thead>
<tr>
<th>File Type(s)</th>
<th>OS Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Data Table (<strong>.jmp</strong>)</td>
<td>All</td>
</tr>
<tr>
<td>Excel Workbook (<strong>.xls</strong>, <strong>.xlsx</strong>)</td>
<td>All</td>
</tr>
<tr>
<td>Text Export File (<strong>.txt</strong>)</td>
<td>All</td>
</tr>
<tr>
<td>Comma-delimited file (<strong>.csv</strong>)</td>
<td>Windows</td>
</tr>
<tr>
<td>Tab-delimited file (<strong>.tsv</strong>)</td>
<td>Windows</td>
</tr>
<tr>
<td>SAS Data Set (<strong>.sas7bdat</strong>)</td>
<td>All</td>
</tr>
<tr>
<td>SAS Data Set with Extended Attributes (<strong>.sas7bxat</strong>)</td>
<td>Windows</td>
</tr>
</tbody>
</table>

**Note:** JMP can save column properties and table properties as extended attributes in a SAS 9.4 **.sas7bxat** file. Select **File > Save As**, select the **SAS Data Set** file type, and then select the check box for saving extended attributes. JMP names the file with the **.sas7bxat** extension. The SAS Integration preferences also include this option, which is off by default.

<table>
<thead>
<tr>
<th>File Type(s)</th>
<th>OS Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAS Transport File (<strong>.xpt</strong>, <strong>.stx</strong>)</td>
<td>All</td>
</tr>
<tr>
<td>JSON (<strong>.jsn</strong>)</td>
<td>All</td>
</tr>
</tbody>
</table>

You can also save files for types that have a corresponding ODBC driver. See “Save Data Tables to a Database” on page 424, for details.
Notes:

- The maximum length of the data table’s name depends on your computer’s operating system. See your operation system documentation for details.
- JMP tries to save any modified files when a crash is detected.

Save as a Microsoft Excel File

There are two options for saving data tables as Microsoft Excel files:

- Save one data table in Microsoft Excel format (.xls or .xlsx). Data from a single table is saved in a workbook named after the data table.
- Generate a workbook in .xlsx format from multiple tables. Data from each table appear on a different worksheet in the workbook.

The .xlsx file includes data table cell colors. The file also provides hidden data and excluded data. Formulas and most formatting are not included.

The maximum length of the Excel filename is determined by your computer’s operating system.

Save One Data Table as a Microsoft Excel Workbook

To save a data table as a Microsoft Excel workbook, follow these steps:

Windows
1. Select File > Save As.
3. Enter a name for your file in the File name box.
4. (Optional) To save the file as an .xls file, select Use Excel 97-2003 Format (*.xls).
5. (Optional) To avoid opening the file in the default spreadsheet program after saving, deselect Open the file after saving.
6. Click Save.

Macintosh
1. Select File > Export.
2. Select Excel and select the format.
3. Click Next.
4. Enter a name for the file in the Save As box.
5. (Optional) To avoid opening the file in the default spreadsheet program after saving, deselect Open the file after saving.
Save and Share Data
Chapter 10
Save and Share Data Tables

6. Click Export.

Note: On Windows, data is split among several worksheets when the number of columns or rows exceeds the number that Excel supports.

Save Multiple Data Tables as a Microsoft Excel Workbook

To save multiple data tables in a new or existing Excel workbook, follow these steps:

1. Open the data tables.
2. Select View > Create Excel Workbook.
3. In the Include Table column, select only the data tables that you want to save.
4. In the Worksheet Name column, specify the name of the worksheet tab if necessary.
5. Enter a name for the workbook in the Workbook Name box.
   The workbook is named after the current data table by default.
6. Click Choose and browse to select a directory to save the file in.
   You can overwrite an existing workbook. Worksheets that already exist in the workbook are replaced. Worksheets that are not in the existing workbook appear at the end of the sheets.
7. Click Save.
   The file is saved as an .xlsx file.

Save as a CSV File

JMP can convert data from a JMP data table to a comma-separated values (CSV) file. To save a data table as a CSV file:

1. With the specific data table open in JMP, select File > Save As.
2. Select CSV (Comma delimited) (*.csv) from the Save as type list.
3. Enter the filename.
4. Select the location for the CSV file.
5. Click Save.

Note: On Windows, exporting a data table to a CSV file uses the comma and carriage return line feed character (CRLF) as file delimiters. Use a different extension and later rename the file with the CSV extension if you need to use different delimiters.
Save as a Text File

JMP can convert data from a JMP data table to standard text format with rows and columns. To save a data table as a text file, follow the steps below based on your operating system and how you want to save the file.

Text formatting options are:

- **Export Column Names to Text File**  To save column headings in the first line of text, and to save labels or header information with the data, select **Export Table Headers**.

- **End of Field** Select the radio button next to the character that marks the end of a field (or cell). Select **Other** and enter a character if the appropriate character is not listed.

- **End of Line** Select the radio button next to the character that marks the end of a line (or row). Select **Other** and enter a character if the appropriate character is not listed.

Notes:

- If double quotation marks are found when importing text data, the delimiter rules change, and JMP looks for an end double quotation mark. Other text delimiters, including spaces embedded within the quotation marks, are ignored and treated as part of the text string.

- When importing text data, columns that contain image data must be converted to Expression column property in order to reveal the image. See “Column Properties” on page 235, for details.

- On Windows, when you save a data table as a text file and then modify the data table, the text file is updated. After you save the data table as a text file, unless you save, close and reopen the data table, changes will be autosaved to the text file, not to the data table.

**Windows**

1. Select **File > Save As**.
2. Select **Text Export File** from the **Save as type** list.
3. Click the **Options** button and specify end-of-line and end-of-field characters, and choose whether to export column headings as text.
4. Click **OK**.
5. (Optional) To avoid opening the file in the default text editor after saving, deselect **Open the file after saving**.
6. Click **Save**.
   An alert appears regarding loss of formulas, formatting information, and other metadata.
7. Click **Yes**.
Macintosh

1. Select File > Export.
2. Select Text and click Next.
3. Enter a name for the file in the Save As box and change the extension to .txt.
4. Specify end-of-line and end-of-field characters, and choose whether to export column headings as text.
5. (Optional) To avoid opening the file in the default text editor after saving, deselect Open the file after saving.
6. Click Export.

Save as a SAS Transport File

You can save a JMP data table in SAS transport file format. JMP replaces spaces in filenames and column names with underscores, converts column headings to uppercase SAS variables, and makes other changes to follow the transport file specifications.

When you save the data table as a transport file, you can opt to append it to an existing transport file. When you reopen the transport file in JMP, the two data tables open in separate windows.

Note: The maximum length for SAS transport filenames is 8 characters. JMP warns that characters beyond that limit are omitted.

Windows

1. Select File > Save As.
2. Select SAS Transport File from the Save as type list.
3. (Optional) Append the data table to an existing SAS transport file. Select the file to which you want to append the data table, and then click the Save arrow. Select Append To, and then click Yes to replace the selected data table.
   
   An alert appears regarding loss of formulas, formatting information, and other metadata.

   Note: Images in Expression columns cannot exceed 200 characters, otherwise they are not supported.

4. Click Yes.
   
   Alerts appear regarding other SAS format modifications.
5. Click OK on each alert.
Macintosh

1. Select File > Export.
2. Select SAS Transport.
3. (Optional) To append the data table to an existing SAS transport file, select the Append check box.
4. Click Next.
5. Do one of the following:
   - If you chose to append the data table, select the file to which you want to append the data table and click Append.
   - Enter a name for the file in the Save As box, and then click Export.
     Alerts appear regarding SAS format modifications.
6. Click OK on each alert.

Save as a SAS Data Set

You can save data tables as SAS version 7 and higher data sets. JMP writes columns as SAS variables, writes rows as SAS observations, and makes other changes to follow the SAS data set specifications.

When you export data to a SAS data set, JMP date columns become SAS date values with the appropriate SAS format.

On Windows, JMP can save column properties and table properties as extended attributes in a SAS 9.4 .sas7bxat file. The option is available in the Save JMP As window and in the SAS Integration preferences.

Windows

1. Select File > Save As.
2. Enter a name for your file in the File name box. The maximum length for the filename is 32 characters. JMP warns that characters beyond that limit are omitted.
3. Select SAS Data Set from the Save as type list.
4. (Optional) To save SAS variable names or SAS formats, select the Preserve SAS column names or Preserve SAS formats check boxes.
5. (Optional) To store JMP metadata as extended attributes for SAS 9.4, select Store table and column properties in SAS 9.4 extended attributes. JMP automatically assigns the .sas7bxat file extension.
6. Click Save.
   An alert appears regarding loss of formulas, formatting information, and other metadata.
7. Click Yes.
8. If other alerts appear, click OK on each alert.

Macintosh

1. Select File > Export.
2. Select SAS and click Next.
3. Enter the filename and select export options.
   - To avoid exporting rows that have the Excluded row state, select Honor Excluded Rows. The other options are described in the preceding section.

Save Data Tables to a Database

You can save a data table to any database on your system that has a compliant ODBC (Open Database Connectivity) driver.

1. First, connect to the database. See “To add a new database connection” on page 425.
2. Select File > Database > Save Table.

Figure 10.1 The Database Save Table Window

3. In the Connections box, highlight the name of the database to which you want to save the file (shown in Figure 10.1). The Connections box contains a list of databases to which your system is connected.
4. From the JMP data table to be saved menu, select the open JMP data table that you want to save to the database.
5. In the Save to database table box, enter the name that you want the table to have when you save it in the database.
6. Click **Save Table**.

*To add a new database connection*

1. Click **Connect**.
2. Select the data source that you want and click **OK**. Or, to create a new source, click the **New** button (Windows) or **Add** button (Macintosh).
   
   Depending on which data source you select (and which database drivers you have installed on your computer), you might be presented with a variety of windows. Use them to create the database source.
3. Select the database to which you want to save the file.

**Replace a Database with a Data Table**

To replace a database with a data table, follow these steps:

1. First, connect to the database. See “To add a new database connection” on page 425.
2. Select **File > Database > Save Table**.
3. In the Connections box, select the name of the database to which you want to replace the file. The Connections box contains a list of databases to which your system is connected.
4. In the Schemas - Tables box, select the database table that you want to replace.
   
   **Note:** Remember the name for the database table. You use this same name for the replacement database table.
5. Click **Drop Table**.
   
   The database table is deleted from the database.
6. From the **JMP data table to be saved** list, select the JMP data table that you want to save to the database.
7. In the **Save to database table** box, enter the name for the deleted database table.
8. Click **Save Table**.
   
   The data table is saved to the database.
9. Click **Disconnect**.
10. Close the Save Database Table window.

**Email a Data Table**

On Windows, you can email a JMP data table by selecting **File > Send**. Your default email application opens with the data table file attached to a new email.
Save and Share Reports

To save a report, select **File > Save As**.

- On Windows, you can save the report as any of the file types listed in Table 10.2.
- On Macintosh, the report is saved as a JMP report (.jrp). Note the following:
  - You can save the report as a journal by selecting **Edit > Journal** and then **File > Save**.
  - If you want to save the report as a text, image, HTML, PowerPoint, or RTF file, select **File > Export**. Supported image files include .eps, .png, .svg, and .tiff.

**Table 10.2 Windows Supported Report File Types**

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Word (.doc)</td>
<td>Word processing format; mixture of pictures, text, and tables.</td>
</tr>
<tr>
<td>Enhanced Metafile (.emf)</td>
<td>Can contain both vector and bitmap components.</td>
</tr>
<tr>
<td>Encapsulated PostScript File (.eps)</td>
<td>Line drawing (or vector image) that can show a bitmap preview of the image.</td>
</tr>
<tr>
<td>CompuServe Graphics Interchange Format (.gif)</td>
<td>Compressed bitmap pictures.</td>
</tr>
<tr>
<td>Hypertext Markup Language (.htm, .html)</td>
<td>Browser format; marked up text and references to separate picture files. Save pictures within the HTML file by selecting one of these formats: PNG, JPEG, SVG, or GIF.</td>
</tr>
<tr>
<td>Interactive HTML (.htm, .html)</td>
<td>Saves the data, reports, and graphs in an interactive web page, so non JMP users can explore the data. See &quot;Save the Report as Interactive HTML&quot; on page 428 for more information.</td>
</tr>
<tr>
<td>Joint Photographic Experts Group (.jpg, .jpeg)</td>
<td>Compressed bitmap pictures; standard for photographs. See &quot;Setting the Graphic DPI&quot; on page 433.</td>
</tr>
</tbody>
</table>
Table 10.2 Windows Supported Report File Types (Continued)

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Journal (.jm)</td>
<td>Analysis report duplicated in a separate window titled Journal. You can edit it or append other reports to it. See “JMP Journals” on page 438. Note that on Macintosh, select Edit &gt; Journal, and then File &gt; Save. On Windows, choose File &gt; Save, and then choose the journal format.</td>
</tr>
<tr>
<td>JMP Report (.jrp)</td>
<td>Analysis report originally created in JMP. It can be reopened for continued analysis. Contains the JSL and embedded data or reference to the data to reproduce a live report. Choose this format if you want to work with the report again, perhaps with new data.</td>
</tr>
<tr>
<td>Portable Document Format (.pdf)</td>
<td>Format for sharing documents regardless of the operating system or application in which they were created.</td>
</tr>
<tr>
<td>Portable Network Graphics (.png)</td>
<td>Compressed bitmap pictures; successor to GIF. See “Setting the Graphic DPI” on page 433.</td>
</tr>
<tr>
<td>Microsoft PowerPoint Presentation (.pptx)</td>
<td>PowerPoint format; mixture of pictures, text, and tables.</td>
</tr>
<tr>
<td>Rich Text Format (.rtf)</td>
<td>Word processing format; mixture of pictures, text, and tables. Save pictures within the RTF file by selecting one of these formats: PNG, JPEG, or EMF.</td>
</tr>
<tr>
<td>Scalable Vector Graphic (.svg)</td>
<td>Pictures stored as text; best used for two-dimensional graphics.</td>
</tr>
<tr>
<td>Tagged Image File Format (.tif, .tiff)</td>
<td>Raster file format. See “Setting the Graphic DPI” on page 433.</td>
</tr>
<tr>
<td>Text Format (.txt)</td>
<td>Plain text format; no pictures.</td>
</tr>
</tbody>
</table>

Email a Report

On Windows, you can email a JMP report by selecting File > Send. Your default email application opens with the report file attached to a new email. Note that the report must be saved before you can email it.
Save the Report as Interactive HTML

Interactive HTML enables you to share JMP reports that contain dynamic graphs so that even non JMP users can explore the data. The JMP report is saved as a web page that includes interactive features, which you can email to users or publish on a website. Users then explore the data as they would in JMP.

Interactive HTML provides a subset of features from JMP:

- Explore interactive graph features, such as selecting histogram bars and viewing data values.
- View data by brushing.
- Show or hide report sections.

Figure 10.2 Brushing Data in Interactive HTML

Many changes that you make to the graphs, such as ordered variables, horizontal histograms, background colors, and colored data points, are saved in the web page. Graphs and tables that are closed when you save the content remain closed on the web page until the user opens them.

Interactive HTML Contains Data

When you save reports as interactive HTML in JMP, your data are embedded in the HTML. The content is unencrypted, because web browsers cannot read encrypted data. To avoid
sharing sensitive data, save your results as a non-interactive web page. (Select \textit{File \> Save As \> HTML File} on Windows, or \textit{File \> Export \> HTML} on Macintosh.)

\textit{To create interactive HTML}

1. In JMP, create the report and make it the active window.
2. Select \textit{File \> Save As} and select \textit{Interactive HTML with Data} from the Save as type list. On Macintosh, select \textit{File \> Export \> Interactive HTML with Data}.
3. (Optional) To avoid opening the HTML file in the default browser after saving, deselect \textit{Open the file after saving}.
4. Name and save the file (or export on Macintosh).
   The output is saved in the selected folder.

\textbf{Which Reports Are Supported}

When you save a report as interactive HTML, the Save Report As window warns when one or more features in the report are not supported.

- If the contents are fully supported, output is created with no warnings.
- Partially or unsupported features are still saved in an interactive web page. When you place your cursor over an unsupported feature, a tooltip states that the feature is not yet interactive.

For information about exploring interactive HTML output, visit \url{http://www.jmp.com/support/help/InteractiveHTML/13/ShareJMPReports.shtml}.

\textbf{Create a Web Report}

The \textit{View \> Create Web Report} option creates a web page in which reports, descriptive text, and graphics are displayed. The web page, graphics, and support files are saved in the directory that you specify so that you can zip the files and send them to another user. This feature is particularly helpful for non JMP users.

Some graphs can be displayed as interactive HTML (for example, bubble plots or background maps). When you click on the thumbnail of the graph in a web report, the interactive graph appears in a new web page.

To generate a web report, follow these steps:

1. Select \textit{Help \> Sample Data Library} and open \textit{SATByYear.jmp}.
2. Run the Graph Builder Map and Bubble Plot by State scripts.
3. From any JMP window, select \textit{View \> Create Web Report}. 
In the Select Reports window that appears, you can select one or more reports to display in the web page. In this example, both reports are displayed in the web page because they are not selected in this window.

Note that the Folder Name box indicates the current date and time. The web report files are saved in this folder.

4. Click **Next**.

5. Enter the descriptions shown in Figure 10.3.

**Figure 10.3** Customizing the Web Report

![Customizing the Web Report](image)

**Note:** The reports are in the order you created them. In this example, the Graph Builder Map script was run first, so the map is the first report. Use the arrows next to the reports to rearrange them.

6. Enter **SAT By Year Reports** in the Web Report Title box.

7. Click **Build Report**.

The web page opens in your default browser.
8. Click on one of the thumbnails to open the report in an interactive web page. See http://www.jmp.com/support/help/InteractiveHTML/13/ShareJMPReports.shtml for details about working with interactive reports.

Web Report Options

**Style Format**  Determines the layout of the reports.

- **Grid**  Shows the reports in rows.
- **Large List**  Shows the reports in a column with large thumbnail graphics.
- **Small List**  Shows the reports in a column with small thumbnail graphics.

**Custom CSS**  Enables you to specify a CSS file to format the web page. The CSS file is copied into a subdirectory called _css. The link to the CSS file is relative so that you can send the report and support files to another user and maintain the CSS formatting.

**Color Theme**  Specifies the color of the web page, headings, and borders. The default web page has a white background, orange headings, and blue borders.

**Add Image**  Specifies an image to display along with the reports. Click the up or down arrow next to the image to move it above or below the reports.

**Toggle Timestamp**  Shows or hides the date and time at which the web page was generated.

**Save as PowerPoint**

Create a presentation by saving JMP results as a Microsoft PowerPoint presentation (.pptx). Rearrange JMP content and edit text in PowerPoint after saving as a .pptx file. Sections of a JMP report are imported into PowerPoint differently. Report headings are imported as
editable text boxes, and graphs are imported as images. Certain graphical elements, such as legends, can be imported as separate images. Images resize once opened in PowerPoint to fit the slide. Typically, each outline in the JMP report appears on separate PowerPoint slides. If an outline in the report is closed when saving as a .pptx file, it is excluded from the PowerPoint. Larger content can spread across multiple PowerPoint slides. Delete unwanted content from the PowerPoint file.

**Note:** On Windows, PowerPoint 2007 is the minimum version required to open .pptx files created in JMP. On Macintosh, at least PowerPoint 2011 is required.

1. In JMP, create the report.
2. (Windows) Select **File > Save As** and select **PowerPoint Presentation** from the Save as type list.
3. (Macintosh) Select **File > Export > PowerPoint Presentation** and click **Next**.
4. Select a graphic file format from the list.
   - On Windows, EMF is the default format. On Macintosh, PDF is the default format.
5. (Optional) To avoid opening the file in the default presentation program after saving, deselect **Open the file after saving**.
6. Name and save the file (or export on Macintosh).

**Tips:**

- The native EMF graphics produced on Windows are not supported on Macintosh. The native PDF graphics produced on Macintosh are not supported on Windows. For cross-platform compatibility, change the default graphics file format by selecting **File > Preferences > General**. Then, change the Image Format for PowerPoint to either PNG or JPEG.
- It is sometimes necessary to auto-resize column widths using PowerPoint. PowerPoint often sizes objects differently from JMP, which can lead to abnormally sized table columns.
- Drag the column separators in PowerPoint to adjust column widths for a nicer layout. You can also double-click a column border to decrease the amount of white space in the column.
- A default PowerPoint template is installed in the JMP directory’s pptx folder. You can save a copy of this PowerPoint template and replace the default template with your own if you want to always use an alternate template when exporting. For example, you might want to create a German PowerPoint template that has German default fonts. See “Custom PowerPoint Templates” for details.
Custom PowerPoint Templates

PowerPoint presentations use the default JMP template. You can use a custom template by overwriting the default template file. To do this, open *JMPExportTemplate.pptx* located in one of the following locations:

C:/Program Files/SAS/JMP/13/pptx/
C:/Program Files/SAS/JMPPro/13/pptx/
C:/Program Files/SAS/JMPSW/13/ptx/

Then, choose your own PowerPoint template, and select **File > Save**. The next time you save JMP content as a PowerPoint, it opens with your custom template. Alternatively, create your custom template in PowerPoint first, and save it as *JMPExportTemplate.pptx*.

**Note:** To use the JMP default template later, make a duplicate copy on your machine before overwriting the file.

Also, you can use a custom template with a JSL script. See `Save Presentation()` in the *JSL Syntax Reference* for more information.

Save as Flash

Certain types of reports can be exported into Flash and saved as a `.swf` file. You can embed `.swf` files into Microsoft PowerPoint presentations.

The following platforms support Flash output:

- Distribution
- Profiler
- Bubble Plot


Setting the Graphic DPI

On Windows, there are several ways to set the resolution (or DPI) for exported graphics:

- To change the default DPI for all graphics, set the DPI to in the Windows Specific preferences. The Default option uses the default setting of your operating system.

- The following script lets you set the default DPI to a different value. Change the number if you want a different DPI and then run the script.

  ```javascript
  Pref( Save Image DPI( 600 ) );
  
  To verify the default DPI after you run the preceding script, run the following script:

  ```javascript
  Get Preferences( Save Image DPI );
  ```
The Windows Specific preferences and Save Report As window show Default as the DPI after you run this script. The setting applies until you change it. On the Save Report As window, select **Always use this setting** to save your choice across multiple JMP sessions.

- For a specific graphic, set the DPI in the Save Report As window.

On Macintosh, you cannot change the default DPI, which is 72.

### Save Your Analysis as a Script

After completing an analysis and receiving a report, you might want to save the process that you used to arrive at the report as a JSL script. You can save the script inside the data table, inside the report, or in a separate script window. To do this, click the red triangle menu in the report title and select the Save Script option that you prefer. See “Save Script Menus” on page 353.

Non-English versions of JMP can save scripts in either English or your local language. See “General” on page 492 in the “JMP Preferences” chapter.

### Save Using the Layout Command

**Note:** The Layout feature will be removed in a future version of JMP. Save your work in a journal instead. Copy the content into an existing journal by selecting **Edit > Select All, Edit > Copy**, and then **Edit > Paste** in the journal. Or select **Edit > Journal** to place the content into a new journal.

You can edit or manipulate the report before you save, enabling you to combine several reports into one or rearrange the report elements. You do this by selecting **Edit > Layout**. Using this command is different from using the **Edit > Journal** command; the Layout command provides additional options that let you ungroup parts of a report and restructure it to best fit your needs.

To create a layout, follow these steps:

1. Select **Edit > Layout**. (Or hold down the Ctrl key and press L.)
   
   The report window is duplicated in a separate window titled Layout.

   In the Layout window, the Layout menu appears between the Edit menu and the Tables menu. Items in the Layout menu are available only when you select an item with the arrow tool.

2. Click inside the layout window. The entire report becomes highlighted. To show the Layout menu, place your cursor over the bar at the top.

3. Select **Layout > Ungroup**, or right-click (hold down the Ctrl key, click on Macintosh) inside the report, and select **Ungroup**.
This performs the first stage of ungrouping report elements, which ungroups (or disconnects) the topmost title bar from its reports and subreports. Each time you ungroup a report outline level title from its reports, the disclosure button for that level disappears and you can no longer close it. However, you can do many of the surface operations available, use the context menu in plots, customize axes, rerun the analysis in a new window, edit scripts, and so on.

4. Select **Layout > Ungroup** again to ungroup the next level of the report outline. Note that only selected items are ungrouped.

5. Continue to select specific report elements (or all elements) and ungroup them until each title and each piece of a report or plot is an object.

   **Note:** You can ungroup a report from its title bar and ungroup all of its major pieces, but you cannot ungroup a column in a report table from its column heading.

6. Click an object to select it and move it anywhere in the layout window, or copy and paste the object into another window. The layout window has as many pages as you want, outlined with gray boundary lines.

7. Select **File > Save As.** JMP saves the file as a journal file (.jrn).

Table 10.3 describes other layout options.

**Table 10.3** Working in a Layout Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit a title bar</td>
<td>Double-click the title bar or report table column heading.</td>
</tr>
<tr>
<td>Quickly ungroup a layout to its smallest objects</td>
<td>Repeatedly press Ctrl and U.</td>
</tr>
<tr>
<td>Rerun the report in a new window</td>
<td>Click the red triangle menu on the title bar and select <strong>Rerun in new window</strong> from the menu.</td>
</tr>
<tr>
<td>Edit a script</td>
<td>Click the red triangle menu on the title bar and select <strong>Edit Script</strong> from the menu.</td>
</tr>
<tr>
<td>Access Layout menu items (on the main menu bar)</td>
<td>Select the arrow cursor.</td>
</tr>
<tr>
<td>Insert a page break</td>
<td>Right-click a disclosure button (↑ or ↓ on Windows and ▼ or ▲ on the Macintosh) on the title bar and select <strong>Edit &gt; Page Break.</strong></td>
</tr>
</tbody>
</table>

This feature applies only to windows that you can print (journals and reports).
Table 10.3 Working in a Layout Window  (*Continued*)

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select and deselect items</td>
<td>Right-click a disclosure button ( † † on Windows and † † on the Macintosh) on the title bar and select <strong>Edit &gt; Select</strong> or <strong>Edit &gt; Deselect</strong>.</td>
</tr>
</tbody>
</table>

The example in Figure 10.5 shows results combined and organized from a bivariate analysis, distribution analysis, and one-way analysis (means and *t* test). The result shows a summary of oxygen uptake as a function of run time in an exercise experiment. This was done by forming a layout window for one analysis, dragging the other desired analysis elements into the layout window, arranging the desired pieces, and deleting unwanted elements.

**Figure 10.5** Multiple Analysis Results in a Layout Window

---

**Save Parts of a Report in a Graphic Format**

You can save part of an analysis report window as a graphic. You can save the selection in .png, .jpg, .gif, .eps, .emf, .pdf, .tiff, and .svg formats. On Macintosh, you can save the selection in .png, .jpg, .gif, .svg, .eps, .pdf, and .pptx formats.

To save a selection, follow these steps:

1. Click the selection tool ( ).
2. Highlight the area that you want to save.
3. On Windows, select **Edit > Save Selection As**. On Macintosh, hold down the Ctrl key and select **File > Save Selection As**.
   The Save Selection As window appears (or the Save window on Macintosh).

4. Enter the filename for the graphic.
   On Macintosh, change the file extension to save the file in a format other than .png, the default format.

5. Change options on Windows:
   - (Windows) Select the graphics file format type to which you want to save the selection. See “Save and Share Reports” on page 426.
   - (Windows) Select the Image DPI Setting. 300 or higher is best for graphics that must be stretched or printed.
   - (Windows) To keep your selected DPI Setting for the current session, select **Always use this setting**.
   - To avoid opening the file in the default graphics program after saving, deselect **Open the file after saving**.
   - (Windows) Select **Select this filter the next time this window is invoked** to save your file type selection for the current session.

   **Note:** If you cannot see the Select this filter option, select a folder location for saving the graphic file.

6. Click **Save**.

**Tips:**

- You can change the default DPI setting selection in the Windows Specific preferences from 96 to 300 DPI. The following script lets you set the default DPI to a different value. Change the number if you want a different DPI and then run the script.

  ```
  Pref( Save Image DPI( 600 ) );
  ```
- On Macintosh, you cannot change the default DPI, which is 72.
- When you export a graph or report that contains a bitmap image to an .svg file, the image is embedded in the .svg file. The exported content is then easier to reuse in other documents.

---

**Print Reports**

To print the report in the active window, select **File > Print**. This command displays the standard window for printing. The appearance of the window depends on your operating system and printer driver.
To insert a page break for printing purposes, follow these steps:
1. Right-click the disclosure button \[\text{ Disclosure Button }\] in the report window.
2. Select Edit > Page Break.

Copy and Paste Reports

When you need to use JMP reports or data tables in another program, you can paste or drag parts of a report or table into another program. For example, you might want to send a colleague a copy of a JMP report in a Microsoft Word file.

1. Click the selection tool \[\text{ Selection Tool }\].
2. Click and drag (or hold down the Shift key and click) to select items in a report window or data table. Clicking near the edge of the report window selects the entire report.
3. Click the selected items and drag them from JMP to the other program. Or, copy the selected items in JMP and paste them into the other program. When you paste an element into another application, the format used depends on the application into which you paste. If you use the applications’ Paste Special command, you can select a format to use, such as text (.rtf), unformatted text (.txt), or bitmap (.bmp).

Note the following actions:

- To copy all text (no graphs) from the active report window as unformatted text, select Edit > Copy As Text. On the Macintosh, select Edit > Copy As Text.
- To copy a graph, which includes labels and axes, right-click the graph and select Edit > Copy Graph.
- To copy anything other than a graph, right-click and select Edit > Copy Picture. For example, to copy a report, right-click on the bar containing the report title and select the option.

JMP Journals

Create a JMP journal when you want to store results and present them. There are two types of presentations that you can create using journals:

- A static presentation embeds the output of one or more JMP reports, fixed at a moment in time. There is no data table, so points cannot be selected, colored, hidden, excluded, and so on. Only cosmetic changes (fonts, axes, sizes) can be made.
- A dynamic presentation is built from outlines containing text and buttons (links) that help you organize, hide, or reveal a set of data tables and reports. This type of journal is dynamic because you can open reports and tables and interact with them, selecting points, subsetting data, or making more graphs.
You can combine static and dynamic presentations. See “Example of Making a Journal for a Presentation” on page 444 for details.

Note the following general information about journals:

- You can save relevant graphs and reports in a journal and then re-arrange the content.
- You can save journals to other formats, such as Microsoft Word, HTML, PDF, and so on.
- Journals support GZ compression to reduce file size. See “General” on page 492 in the “JMP Preferences” chapter.
- Consider setting the Autosave Timeout value in the General preferences to automatically save open journals at the specified number of minutes. This autosave value also applies to data tables, scripts, projects, and reports.

Figure 10.6 shows some of the items that you can add to a journal.

**Figure 10.6  Example of a Journal**

Note: Links to directories of files, windows, and all open files look like other links, so they are not included in the preceding figure.

### Create a New Journal

1. Close all open journals, and do one of the following:
   - To create an empty journal, select File > New > Journal. Or, from the JMP Starter window, select New Journal.
   - To create a journal from an entire report or data table, select Edit > Journal.
   - To create a journal from a specific report or text in a report, click and drag the Selection ( ) tool to select adjacent items in a report or data table. To select discontinuous items, press Shift and click the items with the Selection ( ) tool. Then select Edit > Journal.
   - To create a journal from specific text in a data table, select the text, and then select Edit > Journal.
To create a journal from most graphs, right-click on the graphic, and then select **Edit > Journal**. (Not available for surface plots and 3-D scatterplots.)

Write a JSL script to create a new journal. See the Data Tables chapter in the *Scripting Guide* for more information.

**Tip:** If you prefer keyboard shortcuts, hold down Ctrl (Windows) or COMMAND (Macintosh) and press J to create the new journal.

2. Select **File > Save** and save the journal in .jrn format.

### Prevent Modifications

When a journal is opened, and then journal another report or data table, the second report or data table is added to the end of the first journal.

To prevent modifications to a journal, right-click the blank area at the bottom of the journal and select **Lock**. Additional reports are not added to the journal (as described in the following section). JMP instead finds an open unlocked journal or creates a new journal when you select the **Edit > Journal** command again.

To unlock the journal, right-click the blank area at the bottom of the journal and deselect **Lock**.

Alternatively, place separate reports in separate layout windows by using the **Layout** command, as described in “Save Using the Layout Command” on page 434.

### Append Reports to a Journal

To append other reports to a report that you already journaled, select **Edit > Journal** again. If an area of an analysis window is selected, **Edit > Journal** saves only the selected area instead of the entire window.

**Notes:**

- The journal window has the same functions as the report window: you can click icons, click and drag, and right-click to access menus.
- When a report is journaled, the journaled copy is no longer connected to the data table.

### Add and Edit Outline Levels

You can group text and links in an outline level and then click the gray disclosure icon to expand and collapse the group.


**Note:** Links to files have absolute paths. If you move the journal to another location on your computer, the links continue to work. When adding links to files in the JMP sample data folder, use the pathname `$SAMPLE_DATA/xx`. xx is the absolute path from the sample data directory. (Right-click the link, select **Edit > Set Script**, and then edit the path.)

- To add an outline level, right-click in the journal, and then select **Append Item > Add Outline Item**. You can also add nested outline levels to outline levels that you have created. (When you click the red triangle menu of a graph that you have journaled, the **Add Outline Item** option is unavailable.) Click the outline level’s red triangle menu and select **Add Outline Item**.
- To edit the outline level heading, double-click the heading, enter the new name, and press **Enter**.
- To add text or links within an outline level, click the outline level’s red triangle menu and select an option described in “**Journal Item Options**” on page 441. Note that these options are not available when you click a scripted item’s red triangle menu.
- To add text or links outside an outline level, right-click on the journal and then select one of the options described in “**Journal Item Options**” on page 441.
- To edit a link, right-click the link, select **Edit > Set Script**, edit the path, and then click **OK**.
- To edit the name of the link displayed in the journal, right-click the link, select **Set Button Name**, enter the new name, and then click **OK**.

**Tip:** On Windows, show the preceding options by holding down the Alt key and right-clicking the outline level’s gray disclosure icon.

**Journal Item Options**

**Add Outline Item**  Groups text and links into collapsible and expandable lists.

**Add Text Item**  Enter up to six paragraphs with the option to add a bullet or hide the text. To unhide, right-click the hidden text and deselect **Hide**.

**Note:** To add text outside an outline level, you can also double-click at the end of the journal and enter text in the box that appears. Click outside the box to exit the editing mode.

**Add Window Reference**  Creates a link to a window already opened in JMP.

**Add File Reference**  Creates a link to a file on your computer.

**Add Directory of Files**  Creates links to all files (including non JMP files) in the selected directory.

**Add All Open Files**  Creates outline levels and links to open files in JMP (except for the log). For example, a link to the open `Big Class.jmp` data table and chart is displayed below a
Save and Share Data
Chapter 10
JMP Journals

A collapsible heading named Big Class. Files such as journals, scripts, and tutorials are grouped below a collapsible heading called Other Files.

**Add URL Reference**  Creates a link to files that are delivered through an Internet protocol such as HTTP, FTP, or FILE://.

**Add Script Button**  Creates a link to a JSL script.

**Control the Display of Outline Levels**

You can instantly control which outline levels are displayed (for example, closing all sublevels below the selected level). Click the red triangle menu for that level, select OutlineBox, and then select one of the Open or Close commands. For details about the Open and Close commands, see “Access Report Display Options” on page 349 in the “JMP Reports” chapter.

**Tip:** On Windows, show the OutlineBox options by holding down the Alt key and right-clicking the outline level’s gray disclosure icon.

**Add a Graph or Graphic**

PNG, GIF, JPG, BMP, and TIF files are supported in journals. Do one of the following to add a graphic to a journal:

- Copy a graph from within JMP or a graphic from another application and then select Edit > Paste. JMP places the graphic at the end of the journal.
- Drag and drop the graph or graphic from another window to the journal. (See “Paste a Background Image into a Graph” on page 408 in the “JMP Reports” chapter.) A blue line indicates where you can drop the graphic.

**Customize Journal Items**

- To click and drag journal items to different positions, select the selection tool ( ), select the item, and then drag the item to the new position. A line indicates where you can drag the item.
- To adjust text wrapping, right-click the text and select Set Wrap. Enter the number of desired pixels per line and click OK. To apply the wrap to all text items, select Set Wrap, select Extend this to other text boxes, and then click OK.
- To modify a plot axis, double-click or drag the axis. See “Customize Axes and Axis Labels in the Axis Settings Window” on page 390 in the “JMP Reports” chapter.
- To add text or shapes anywhere in the report, use the drawing tools (Annotate, Line, Polygon, and Simple Shape). For details about the drawing tools, see “Add Annotations and Shapes to a Report” on page 412 in the “JMP Reports” chapter.
To resize plots and graphs, do one of the following:

- Click and drag the edge.
- Right-click the plot or graph, and then select **Size/Scale > Frame Size**. See “Resize Graphs” on page 385 in the “JMP Reports” chapter.

**Save the Journal in Another Format**

You can save a journal in another format (such as HTML or PDF). When you save the journal as HTML, buttons and links are active when the file is viewed in a web browser.

**Note:** The header and footer defined in your printer setup appears in the PDF file. However, you can set the left, center, and right header and footer in a JSL script. For more information, search for the `Set Print Footers` message in the JMP Scripting Index. (Select **Help > Scripting Index** in JMP.)

**Windows**

1. Select **File > Save As**.
2. Select the format. See “Save and Share Reports” on page 426.
3. Click **OK**.

**Macintosh**

1. Select **File > Export**.
2. Select the format. See “Save and Share Reports” on page 426.
3. Click **Next**.
4. Enter a name for the file in the **Save As** box.
5. Click **Export**.

**Print a Journal**

Select **File > Print**.

**Delete Items from a Journal**

1. Click the selection tool ( ).
2. Select the item that you want to delete and press Delete.
Example of Making a Journal for a Presentation

Most people use a presentation application like PowerPoint to give presentations. With JMP journals, you can avoid using a presentation application: all your bullet points can be combined with live links and buttons to help automate the analyses that you want to show. Interactivity is also maintained in reports.

Follow this example to create a presentation using a journal.

2. Right-click in the journal. Start your outline by selecting Add Outline Item.
3. Enter the title of the presentation “My Bivariate Demo.”

**Figure 10.7** Add an Outline Item

A presentation should have outline nodes. The nodes are nested, opened, and closed in sequence, as you give the presentation.

4. Add bullet points into the outline by clicking the red triangle in the My Bivariate Demo title bar and selecting Add Text Item.
5. Enter the text shown in the following figure.
6. Select the Bullet Point check box and click OK.

**Figure 10.8** Add Text Item
Now add a window reference as a link. These links lets you open a file with one click during the presentation.

7. Select Help > Sample Data Library and open Big Class.jmp.
8. Click the red triangle in the My Bivariate Demo title bar and select Add Window Reference.
9. Select Big Class and click OK.

**Figure 10.9  Add Window Reference**

10. Click the window reference to verify the link.
11. Display the window reference as a button by right-clicking the link and deselecting Underline Style.

**Figure 10.10  Change the Link to a Button**

---

**Save JMP Sessions**

Each time you use JMP is called a *session*. A *saved session* is a JSL script that re-opens documents and re-runs analyses to restore JMP’s state when the session script was saved. A saved session can help get you back to a previous state without having to manually re-open files and re-run analyses.

If you are an advanced user, it is important to understand what session information is preserved in a saved session. Any documents (such as data tables, scripts, and journals) that have been saved are re-opened. JMP windows that support script saving are re-run (equivalent to clicking the red triangle in a report and selecting Redo > Redo Analysis). Side effects of running scripts, such as global variable values or custom windows, are not saved. The state of highly interactive analyses is also not saved.
Save Sessions upon Exiting

The most common use of saved sessions is to save the state when JMP exits so that it can be restored when JMP restarts. By default, JMP asks whether you would like to save the state of your session each time you exit the program (Figure 10.11). This enables you to quit JMP, and then return to it later without having to open the files with which you were previously working.

Figure 10.11  Saving Session upon Exiting

To always save the session upon exiting, select Do not ask me again about saving the session and click Yes or No. This option also prevents JMP from saving the session upon exiting.

You can change this option later in Preferences:
1. Choose File > Preferences.
2. Select the General icon.
3. Next to the Save the session when exiting option, choose when you want JMP to save the session. Always, never, and prompt whether you want to save are the options.

Save Sessions Manually

You can also save a session to a location of your choosing and continue working, so you can restore the saved state whenever you like. Manually saving sessions is useful when you want more control of session saving and restoring. This option is especially helpful when you want to maintain multiple independent session states. Each state has a different set of files and analyses.

To create a script of a JMP session
1. Select File > Save Session Script.
2. Enter the name of your script in the window and click Save.

Another way of manually saving a session is by creating a journal of each session. A journal can be a notebook-style or project-style file. With it, you can collect references to files in a project, develop presentation launch pads, document projects, and store many scripts in one place. See “JMP Journals” on page 438 for details.

To create a journal of a JMP session
1. Open the files that you would like to include in the journal.
2. Select File > New > Journal. Or, to append your open files to an existing journal, open that journal.
3. Right-click in the empty journal and select Add All Open Files.

**JMP Projects (Windows Only)**

**Note:** Though you can script and open projects on Macintosh, this section only covers working with projects on Windows.

A JMP project saves and archives multiple JMP file types (data tables, reports, scripts, or other JMP supported formats) into a single file. You can also include non JMP documents, such as Microsoft Word or Adobe PDF files. The single archived JMP project file contains everything needed to re-open all the included files, which makes it different from scripts that are saved in a session. Scripts save the state of the software, and projects save the state of the software and the files.

Projects are useful when you have a multiple files that need to be kept together for archival, transmittal, or organizational purposes. You can send archived projects to others, and everything they need to access the project is there.

**Tip:** If you deselect the Archive all files and folders when project is saved option, only the path name is saved in the project. If changes are made to linked files, they may not be updated, and links may be broken. For information about using this option, see “Save a JMP Project” on page 447.

**Create a JMP Project**

To create a new project, click on the black book icon in the Projects pane. Or, select File > New > Project. The Project window appears.

To name the project, right-click the project name, select Rename, enter the name, and then press ENTER.

**Save a JMP Project**

After you create and name a project, save it using one of the following methods:

- Right-click the project name in the Projects window and select Save “project name”.
- Select the project name and click the Save Selected Project button on the Projects window toolbar.
- In another open JMP window (such as the JMP Home Window), select File > Save Projects.
When you save a project, JMP creates a compressed file with the .jmpprj extension and saves a copy of each item in the project. If you make subsequent changes, the archived copy is modified rather than the original source. Other JMP users on Windows and Mac can then open the project on their computers, and the links remain intact.

JMP maintains the links by creating a folder structure that mirrors the location of the original files. Say that you save a project in the following folder:

C:\MyProjects

The project has a link to the C:\MyDataTables folder.

When you open this project, JMP creates the following file structure in the project’s subdirectory:

C:\MyProjects\Project Name Dependencies\C:\MyDataTables

At times, you might want to continue to modify the original files rather than the archived copies. Here are some examples:

- When you add a file to multiple projects, you are actually modifying three different copies of that file. If sales figures in one of the files need to be updated, you must update three different copies of that file.
- When you add files to a project from a network drive, you and other JMP users can edit those files without having to open the JMP project file.

In these instances, turn off archiving by right-clicking the project in the Projects window and deselecting Archive all files and folders when project is saved.

When you save a project, JMP notifies you when files in the project archive are not found. See “Fix Broken Links” on page 451 for details about fixing the links.

**Close a JMP Project**

To close a project, right-click the project name and select Close.

**Open a JMP Project**

On Windows, open a project by selecting File > Open and selecting JMP Projects from the list next to File name. The file also shows up in the JMP Home Window Recent Files list if you previously opened it with the File > Open command or the Open toolbar button.

On Macintosh, open a project by selecting File > Open and selecting the file. Though there is no project window on Macintosh, the files that are set to open or run automatically appear.
Add Items to a JMP Project

You can add either saved or open files to a JMP project. If a file has not already been saved, you are prompted to save it before it can be added to the project. You can drag and drop files from the Home Window into a project.

Project Menu

To add items using the Project menu, right-click on the project name in the Projects window and select the desired command.

New Group   Adds a collapsible and expandable container that organizes related items.

Add Window   Opens a window that lets you select which open JMP window to add to the project. If the contents of the window has not been saved, you are prompted to do so before the window is added to the project.

Add Document   Adds a copy of a file (if the archiving option is turned on) or a link to the file (when the archiving option is turned off). After selecting this option, the standard File Open window appears.

Add Folder   Adds a Windows folder to the project. You browse to select the folder from your computer.

Add Database Query   Opens the JMP database query Window, where you can create or open a query to a database. This query is then added to the project. For detailed information about creating queries, see “Import Data from a Database” on page 124 in the “Import Your Data” chapter.

Add URL   Opens the Internet Open window, where you specify a URL to add to the project. Select an option from the Open As list to specify how JMP opens the file.

Add SAS Stored Process   Lets you add a SAS Stored Process. If you are not connected to a SAS Metadata Server, you are either connected to the server using your saved profile, or the SAS Server Connection window is opened for you. Once you are connected, you can select the SAS Stored Process to add to the project. See “Run Stored Processes” on page 96 in the “Import Your Data” chapter.

Add All Windows   Adds links to all open windows.

Drag and Drop Files

With the Projects window open, you can drag and drop files into a project from the following programs:

- Windows Explorer
- Microsoft Outlook (such as e-mails, attachments, notes, and calendar entries)
• JMP windows (Hold down the CTRL key, click the title bar, and drag the window to the project.)

Drop the files onto the project name inside the window, not into the empty space.

**Customize the Project**

JMP has several commands that let you organize and customize your project.

**Open Files**

When you open a project, JMP can automatically open most files or run scripts in that project. To open all files or run scripts or database queries automatically, right-click the project name and select *When project is reopened > Restore all items in the project.*

To open or run specific items automatically, do the following:

1. Right-click each file that you want to open or run and select *Restore this item when the project is opened.* The name of the options depends on the file type. For documents, the option is named *Restore this document when the project is opened.* For windows, the option is named *Restore this window when the project is opened.*

2. Right-click the project name and select *When project is reopened > Restore only marked items.* (This is the default project setting.)

Though you cannot create a project on Macintosh, you can open files in a project if you set the files to open automatically.

**Note:** Be careful setting *all* items to open automatically. When you add a folder full of files, opening all of those files might cause a delay.

When you double-click a file in a project, most files open in their default programs. For example, data tables, journals, and scripts open in JMP. Graphics open in your default graphics program. Files that can be imported into JMP (such as Excel files or SAS data sets) are opened based on your text import preferences.

You can also choose how to open a file by right-clicking it and selecting an option. The options differ based on the file type. For example, files that are imported as data have text import options, or you can open them outside of JMP.

**Groups**

Adding a group to a project lets you organize files into collapsible and expandable containers. To add a new group, right-click on the project and select *New Group.* You can add files by right-clicking on the new group, or you can drag and drop existing files into the group.
Notes

JMP enables you to add descriptive notes about a project. Select the Edit Notes command from the Project menu to add or edit a project’s notes. The notes are shown in the project properties. Right-click the project name and select Properties to view the notes.

Fix Broken Links

When you save a project, JMP warns you if the link to a file is broken.

To fix a broken link
1. Click No on the broken link warning window.
2. In the Projects window, right-click the affected file, and select Fix Broken Link.
3. Browse to find the file.
4. Click OK.

Save a Log Window

Selecting View > Log displays a window that monitors JMP activities, such as JSL statements as they execute and script errors. You might also encounter instances where running a formula, matrix, or another operation writes information of interest to the log window.

To save a log
1. Open the Log window.
2. Select File > Save As.

Note: (Windows only) To open the log automatically when text is added to it, select File > Preferences > Windows Specific. In the Open the JMP Log window list, select whenever text is added.
Save a Log Window
JMP is an extensible program that lets you broaden its functionality to create your own JMP components. With Dashboard Builder, you combine reports into a dashboard, a visual tool that lets you run and present reports on a regular basis. No JSL knowledge is required. Start with a template, click report components, insert graphs and pictures, and the dashboard is done. You can also combine windows outside Dashboard Builder to create dashboards.

**Figure 11.1** A Dashboard with Two Reports
Combine Reports by Creating a Dashboard

With Dashboard Builder, you combine reports to create your dashboards without writing JSL scripts. Similar to Application Builder, Dashboard Builder has a drag-and-drop interface but with pre-configured display boxes. In Dashboard Builder, the display boxes do not require customization. You can put reports and graphs in tabs, embed database queries, save the dashboard as an add-in, and more.

You can also quickly create dashboards by combining several open windows using the Window > Combine Windows option. For example, you might combine two reports and a data table to arrange them on a dashboard. See “Example of Combining Windows to Create a Dashboard” for an example.

Example of Creating a Dashboard with Two Reports

Suppose that you created two reports and want to run the reports again the next day against an updated set of data. This example shows how to create a dashboard from the reports.

2. To create the reports, run the table scripts named “Distribution: Profitability by Lead Studio and Genre” and “Graph Builder: World and Domestic Gross by Genre”.
3. From any window, select File > New > Dashboard.
   Templates for common layouts appear.
4. Select the 2x1 Dashboard template.
   A box with room for two reports appears on the workspace.
5. In the Reports list, double-click the report thumbnails to put them on the dashboard (Figure 11.3).
6. Select Preview Mode from the Dashboard Builder red triangle menu.
   A preview of the dashboard appears. Notice that the graphs are linked to each other and the data table. They also have the same red triangle options as the Distribution and Graph Builder platforms.
Figure 11.2 A Dashboard with Two Reports

7. Click Close Preview.
8. In Dashboard Builder, select File > Save, and then save the file as a .jmpapp file.
   Users who have JMP can open the data table and double-click this file to display the dashboard. Note that the .jmpapp file cannot be edited.
9. Return to the Dashboard Builder window, select File > Save As, and then save the file as a .jmpappsource file.
   The dashboard is saved in a file that you can edit in the future.

Note: You might also want to save the dashboard as an add-in. Users then view the dashboard by selecting a menu item in the main Add-Ins menu instead of opening the .jmpapp file. See “Example of Creating a JMP Query Dashboard and Add-In” on page 465 for details.

Details about Using the Dashboard Builder

Figure 11.3 shows a dashboard in development. The two reports in the left pane were generated from the Hollywood Movies.jmp sample data table. Those reports were added to the right pane. “Hollywood Movies.jmp” is displayed in a text box that was added to the dashboard and centered using the toolbar buttons.
Dashboard Builder Red Triangle Options

The Dashboard Builder red triangle menu provides options such as running the dashboard, previewing the dashboard, and saving the dashboard as an add-in.

**Run Dashboard**  Starts the dashboard.

**Preview Mode**  Displays a preview of the dashboard. Click **Close Preview** on the dashboard to return to the dashboard mode.

**Start Over**  Remove objects from the workspace and select a new template.

**Show Grid**  Displays dotted grid lines on the workspace. Selected by default.

**Show Properties**  Shows or hides the Objects and Properties panels for editing display boxes. See the Creating Applications chapter in the *Scripting Guide* for details about editing properties.

**Auto Scroll**  Automatically scrolls horizontally or vertically as you drag an object near the edges of the workspace. Selected by default.
Dashboard Mode  Deselect to display the dashboard in Application Builder, where you can fully customize the application and write scripts. See the Creating Applications chapter in the Scripting Guide for details. Select Dashboard Mode to return to the dashboard.

Source Panel  Shows or hides the Sources panel (the left column in which report components are displayed). Categorizes boxes into Data Table and Display sections.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations. See “Save Script Menus” on page 353 in the “JMP Reports” chapter for details.

Sample Dashboards

Examples of dashboards are shown when you open Dashboard Builder. You can modify these samples instead of starting with an empty dashboard. The dashboards are also installed in the JMP Samples/Dashboards folder.

The following sample dashboards are available:

- **Instant Dashboard.jmpappsource**  Combines two Multivariate reports (Principal Components/Factor Analysis and T Square with All Principal Components).

- **Six Quality Graphs Dashboard.jmpappsource**  Creates three Control Charts, a Distribution report, and a Capability Analysis report.

Edit a Dashboard

“Example of Creating a Dashboard with Two Reports” on page 454 shows how to create a dashboard from two reports. This section shows how to arrange those reports and preview the final dashboard.

Rearrange Reports in Dashboard Edit Mode

To help you rearrange reports while editing a dashboard, the outline around a report includes drop zones. When you drag the report into a different area of the box, a portion of the box is highlighted. The highlight shows where you can drop the box.

Figure 11.4 shows how to create tabbed reports. To put the Distribution report inside a tab, drag the report over the other report until the upper right corner of the bar chart report is highlighted. The Distribution report appears in a tab on top of the other report.

To remove a tabbed report, click the middle of the report and drag it outside of the tab.
Figure 11.4 Working with Tabbed Reports in Dashboard Edit Mode

Figure 11.5 shows an example of placing a data table inside the bottom border of the report. To display the data table below the report instead of inside it, drag the Data Table box onto the dashboard below the report. The box snaps inside the bottom border of the report.

Figure 11.5 Displaying a Data Table Inside a Report

Figure 11.6 shows a data filter that appears to the left of a report.
Format Text in a Text Box

When you edit a dashboard, you can format text in a text box. Drag the text box to the dashboard and click the middle of the text box. Formatting options appear (Figure 11.7).

Figure 11.6 Adding a Data Filter to the Left of a Report

Figure 11.7 Formatting Options for a Text Box
Preview the Dashboard

When you edit the dashboard, you can see a preview of the final dashboard by selecting Preview Mode from the Dashboard Builder red triangle menu. Previewing the dashboard is particularly helpful when testing interactive elements such as data filters and tabbed reports.

Note that if you resize panes in preview mode, your changes are not saved.

View a Running Dashboard

When you view a running dashboard, the same red triangle options that you find in JMP platforms are available in the reports. Dashboard Builder also provides several other options.

View a Summary of the Report

A report that contains graphs and statistics can grow fairly large. To view only the graphs while running the report, select the top red triangle in a report and then select Report View > Summary. The report shown in Figure 11.8 originally showed parameter estimates. In the Summary view, only the graphs are shown.

Figure 11.8 Viewing a Summary of the Report
Rearrange Reports in a Running Dashboard

You rearrange reports in a running dashboard by dragging the reports into highlighted drop zones. The drop zones indicate where you can place the report. Figure 11.9 shows an example of moving a report into a tab. The Distribution report is dropped inside the highlighted drop zone to place it on the first tab.

Figure 11.9 Creating Tabbed Reports in a Running Dashboard

To remove a tabbed report, click the middle of the report and drag it outside of the tab.

Maximize a Report in a Running Dashboard

To see only a specific report while running a dashboard, select the report’s Maximize Tab box (Figure 11.10). Note that the box is named Maximize Tab even if the reports are not in tabs.
Figure 11.10 Maximizing a Tab

To restore the report to its original size, select the Restore Tab box (Figure 11.11).

Figure 11.11 Restoring a Maximized Report

Resize Reports in a Running Dashboard

The thick gray line that appears between reports in a dashboard is called a splitter. Drag the splitter to resize the panes. When the pane is too wide to display the enclosed report, the pane closes. Drag the splitter from the outer edge of the dashboard to see all reports again. Figure 11.12 shows the collapsed and expanded reports.
Figure 11.12 Resizing Panes in a Running Dashboard

You can also drag the edge of a graph. The graph widens as far as the width of the window and the other reports allow.

Share Reports with Users Working Outside JMP

You can share reports with users working outside JMP by saving a dashboard as interactive HTML. In the running dashboard, select File > Save As and then select Interactive HTML with
Data from the list. The reports are saved in a web page that also contains the data. Email the web page to users or publish the page on a website. Users then explore the data as they would in JMP. See “Save the Report as Interactive HTML” for details.

Example of Combining Windows to Create a Dashboard

Instead of creating a dashboard in Dashboard Builder, you can combine open windows to create a dashboard. Dashboard Builder provides more options. However, combining windows is a quick way to create a simple dashboard.

This example shows how to combine two reports from Hollywood Movies.jmp into a dashboard.

2. Run the first two table scripts
4. In the Combine Windows window that appears, make the following changes:
   – In the Combine column, select the two report windows.
   – In the Filter By column, select Hollywood Movies - Distribution.
5. Click OK.

The two reports are combined into one window. Notice the filter icon at the top of the Distribution report. When you select a bar in one of the histograms, the corresponding data in the Graph Builder graph and in the data table are selected.

You can rearrange the reports as shown in “Rearrange Reports in a Running Dashboard” on page 461.

Tips:

- To combine reports on Windows, you can also select Combine Windows from the Arrange Menu option in the lower right corner of JMP windows.
- In the Combine Windows window, select Summary Report View to see only the graphs in a report and omit the statistics.
- Only reports that are in the combined window can be used as a filter.

Example of Adding a Selection Filter to a Dashboard

In a dashboard that contains several reports, you can select data in one report and then view only that data in other reports contained in the same window. This example shows how to add a selection filter to the primary report when you edit a dashboard.

1. Follow step 1 through step 5 in “Example of Creating a Dashboard with Two Reports” on page 454 to create a dashboard.
2. Right-click the center of the left report and select **Use As Selection Filter**.

3. Select **Preview Mode** from the Dashboard Builder red triangle menu.

4. Select one of the bars for the Fantasy genre in the left report.

   In the right report, you can see that Warner Bros and independent studios produced the most Fantasy movies.

**Figure 11.13 Filtering Data**

![Dashboard Image]

**Example of Creating a JMP Query Dashboard and Add-In**

Suppose that you used JMP Query Builder to import portions of two data tables into JMP. A dashboard displays reports of the data. You want to create an add-in that queries the data and shows the updated reports on a dashboard.

**Build the Query**

1. Select **Help > Sample Data Library** and open **Hollywood Movies.jmp**.

2. Select **Tables > JMP Query Builder**.

3. Click **Build Query**.

4. In the Available Columns list, double-click **t1.Movie Name**, **t1.Rotten Tomatoes Score**, **t1.Audience Score**, and **t1.Theaters Opening Wknd** to add them to the Included Columns tab.
5. Click **Run Query**.

The queried data appears in a new data table. Note the Source table script. When you open the dashboard, JMP runs this Source script to query the data in Hollywood Movies.jmp.

6. In the new data table, run the **Graph Builder: Scores by Opening Weekend** table script to create a report.

### Create the Dashboard

1. From the report window, select **File > New > Dashboard**.
2. Select the **Blank Dashboard** template.
3. Double-click the **Data Filter(Local)** box in the left pane to add it to the dashboard.
4. Double-click the Graph Builder report in the left pane to place it next to the local data filter.

![Dashboard for Hollywood Movies](image)

### Figure 11.14 Dashboard for Hollywood Movies

### Create and Run the Add-In

1. From the Dashboard Builder red triangle menu, select **Save Script > To Add-In**.
   
   Add-In Builder opens.
2. Next to Add-In name, type Hollywood Movies Dashboard (the add-in filename).
3. Click the **Menu Items** tab and type Hollywood Movies Dashboard next to **Menu item name** (the name of the add-in menu item).
4. Click **Save** and save the add-in to your desktop.
   
   The add-in is saved and installed in your Add-Ins menu.
5. Click **Close** on the Add-In Builder window.
6. From the JMP main menu, select **Add-Ins** and select **Hollywood Movies Dashboard**.
   
   The Hollywood Movies.jmp data table is queried, and the dashboard opens to show the local data filter and updated report.
Figure 11.15 Hollywood Movies Add-In
Extend JMP
Combine Reports by Creating a Dashboard

Chapter 11
Using JMP
This chapter describes how to customize JMP menus and toolbars to show only the commands that you need. For example, you might remove the SAS option in the File menu if you do not use SAS. Or you might assign a shortcut key to the Run Script command.

Customizing JMP also lets you set up JMP for groups with special interests. If one group does not design experiments, you could remove DOE from the JMP menu.
Personalize Toolbars and Menus on Windows

Toolbars consist of buttons that execute commands and dividers that help you organize the buttons. In Windows, there are many ways to personalize toolbars. For example, you can create, rename, hide, and modify toolbars or buttons. You can also rearrange or delete toolbars and buttons that you create.

Menus consist of commands, submenus, and separators. As with toolbars and buttons, you can create, rename, hide, and modify menus. You can also rearrange or delete menus and menu items that you create.

You personalize toolbars and menus in the Menu Editor. The names of modified items are formatted to indicate which items were created, modified, or hidden, and which items are unsaved, as shown in Figure 12.1.

Figure 12.1 Menu Editor Options

Customization set options.

Item definition.

Green boldface text indicates a modified built-in item.

Blue boldface text indicates a new item.

Green boldface text indicates a modified built-in item.

Asterisks mark unsaved items.

Hidden items are marked out.
Change Customization Sets

JMP gives you the flexibility to specify which users see your customized toolbars and buttons. Your changes are saved in a text file with the .jmpcust extension called a customization set. By default, your customizations are shown only to the current user; other users who log on to the computer and open JMP do not see your personal toolbars and menus.

All customization sets include the built-in JMP buttons and menus. You can also base customization sets on other customization sets. For example, you might create a new customization set that shows the JMP add-in menus and toolbars along with your modifications.

When you modify the Current user customization set, JMP creates a backup file of the set. The file is located in your Windows Users folder within the JMP, JMPPro, or JMPSW folder.

C:/Users/<user name>/AppData/Roaming/SAS/JMP/13/

When you modify the All users customization set, JMP creates a backup file of the set. The file is located in the Windows All Users folder within the JMP, JMPPro, or JMPSW folder.

C:/Users/All Users/SAS/JMP/13/

The All Users folder does not appear when you try to browse for it, so you must type the path into the Windows Explorer address field.

Note: To find the customization set files in Windows Explorer, show all hidden files in the Windows Explorer Folder Options. See your operating system documentation for details.

To change the customization set, follow these steps:

1. Select View > Customize > Menus and Toolbars.
   The Menu Editor appears.

2. Click Change.
   When you try to change the customization set, and changes to the selected set are not saved, you are prompted to save the changes. Click Save Changes.

3. Select the customization set in the Customization Set to Modify area. (By default, changes apply only to the Current user customization set.) “Customization Set Options” on page 472 describes the options.

4. (Optional) To change the set on which the selected customization set is based, select the set in the Starting Set area. (Not available for the All users customization set.) “Customization Set Options” on page 472 describes the options.

5. Click OK.
**Customization Set Options**

**Customization Set to Modify**

- **Current User**  Only you see the changes. The customization file is called usercust.jmpcust. Modifying this file manually might cause unexpected results.

- **All users**  All users who open JMP on the computer see the changes. The customization file is called admincust.jmpcust.

- **JMP Add-In**  Those who use the selected JMP Add-in, and select **JMP Add-In customizations** as the Starting Set, see the changes. When you modify the customization set for a disabled add-in, those changes do not appear until you enable the add-in.

- **Other file**  Changes appear when the selected .jmpcust file is chosen as the customization set. You create this file in a text editor.

- **New**  Changes appear when this new customization is selected. (After you make your changes, click **Save** to name the new file in the selected folder.)

**Starting Set**

- **JMP built-in items**  The selected customization set is based on the default JMP toolbars and menus. (Applies to all customization sets and cannot be deselected.)

- **All Users customizations**  The selected customization set is based on the All users customization set. (Available for the Other file or New customization sets. Cannot be deselected from the Current user customization set.)

- **JMP Add-In customizations**  The selected customization set is based on the JMP Add-In customizations. The add-in customizations are typically installed with the add-in. (Available for all customization sets except for All users.)

- **Current User customizations**  The selected customization set is based on the Current user customization set. (Available only for Other file and New customization sets.)

**Create Toolbars**

JMP includes toolbars that you can add new buttons to, or you can create your own toolbars. By default, the JMP window type determines which bars appear. For example, the File_Edit toolbar is in all windows. In data tables, the Data Tables toolbar also appears.

- **File_Edit**  Shows icons for commands found in the File and Edit menus.

- **Analyze**  Shows icons for common commands found in the Analyze menu.
Chapter 12
Using JMP

Personalize JMP

Chapter 12
Using JMP

Personalize Toolbars and Menus on Windows

**Graph**  Shows icons for commands found in the Graph menu.

**Tools**  Shows icons of tools that you can click and use as your cursor. In some windows, the toolbar is hidden. A blue line appears instead. Place your cursor over the blue line to show the toolbar.

**Data Table List**  Shows a list of open data tables. You select a data table in this list to make it the current table. Note that the current table is not necessarily the front window. To bring a table (or any window) to the front, select its name from the list in the Window menu.

**Tables**  Shows icons for commands in the Tables menu.

**DOE**  Shows icons for commands in the DOE menu.

**SAS**  Shows icons for accessing and browsing SAS data and folders, opening SAS Query Builder, creating a new SAS program, submitting data to SAS, opening the SAS log window and output window, and viewing server connections.

**Home**  Shows frequently used icons from the File menu.

**Application Builder**  Shows icons for commands in Application Builder.

**Data Table**  Shows icons for performing common tasks in a data table, such as opening the Data Filter, Fit Model, and Recode windows.

**Script Editor**  Shows icons for running, debugging, and reformatting scripts.
Personalize JMP
Chapter 12
Personalize Toolbars and Menus on Windows

Report  Shows icons for opening the Local Data Filter, Column Switcher, and saving a script to the data table.

Create your own toolbars for frequently used commands that are not included in the default toolbars. You assign a command to the button and can add other properties such as shortcut keys, icons, and JMP Scripting Language (JSL) scripts.

When you want to create a toolbar based on an existing toolbar, make a copy of the existing toolbar and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons” on page 480 for details.

Step 1: Create the Toolbar

1. Select View > Customize > Menus and Toolbars.
   The Toolbars list appears on the left.
2. (Optional) Change the customization set to control which users see your customizations. See “Change Customization Sets” on page 471 for details.
3. With the Menu Editor still opened, right-click one of the toolbars, such as File_Edit.
   Select any toolbar, because all new toolbars appear at the end of the Toolbars list.
   The toolbar is inserted at the end of the list. The toolbar includes an untitled button, because all toolbars must have at least one button.

Step 2: Specify the Caption and Internal Name

Toolbars have several basic properties:

- The caption appears in the View > Toolbars list, which lets you show or hide the toolbar. Give each toolbar a unique name. JMP merges toolbars with the same name after you close and reopen the Menu Editor.
- The internal name, which is case insensitive. JMP identifies the location of an item by its internal name rather than its caption.

To specify these toolbar properties, follow these steps:

1. With the Menu Editor still opened, select the toolbar.
   The General properties appear on the right.
2. Enter the internal name next to Internal name.
3. Enter a unique name for the toolbar or button in the Caption box.
4. (Optional) To specify the translation for the caption, do the following:
   - Click the Localize button for the item that you want to customize.
– Select the language.
– Enter the translation next to Text.
– Click OK.

5. (Optional) Click Hidden to keep the toolbar hidden after creation.

6. Customize the untitled button as described in “Create Menu Items and Toolbar Buttons” on page 475.

7. Click Save to save your changes.

Create Main Menus

Add your own menu items to the main menu bar in JMP. These menus appear before or after menus such as File, Edit, and Tables. An untitled command is inserted automatically in the menu, because all menus must have at least one command.

When you want to create a main menu based on an existing menu, make a copy of the existing menu and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons” on page 480 for details.

To create a main menu

1. Select View > Customize > Menus and Toolbars.
   The Main Menu list appears on the left.

2. (Optional) Change the customization set to control which users see your customizations. See “Change Customization Sets” on page 471 for details.

3. Right-click the menu next to which you want to add a new menu.

4. Select Insert Before or Insert After.
   An untitled menu and a menu item are added to the list.

5. Complete “Step 2: Specify the Caption and Internal Name” on page 474 to rename the main menu.

6. Customize the menu item as described in “Create Menu Items and Toolbar Buttons” on page 475.

7. Click Save to save your changes.

Create Menu Items and Toolbar Buttons

Menus consist of the following menu items:

• Commands are the items that you click to execute a command (such as Data Table and Script).
• Submenus are menu items that you click to reveal more menu options. An example of a submenu is New inside the top-level File menu. New is also a submenu because it contains commands (such as Data Table and Script).

• Separators (———) are lines that divide or group commands and submenus.

The button on a toolbar is considered a type of command, so you also complete the following steps to create new toolbar buttons.

When you want to create a menu item or button based on an existing item, make a copy of the existing item and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons” on page 480 for details.

**Step 1: Create a New Menu Item or Button**

1. Select **View > Customize > Menus and Toolbars**.
   
   The Menu Editor appears.

2. (Optional) Change the customization set to control which users see your customizations. See “Change Customization Sets” on page 471 for details.

3. Right-click where you want to add the menu item or button.
   
   A list of possible locations appears.

4. Select **Insert Before** or **Insert After**.
   
   The Specify Type window appears.

5. Do one of the following:
   
   – To create a button, select **Command**.
   
   – To create a menu within a menu, select **Submenu**. (Not available for buttons.)
   
   – To create divider between menu items or toolbar buttons, select **Separator**.

6. Click **OK**.

   The new untitled button, submenu, or separator is added.
Step 2: Specify the Caption, Tooltip, and Internal Name

Buttons have several basic properties:

- The caption appears in the View > Toolbars list, which lets you show or hide the toolbar. Give each toolbar a unique name. JMP merges toolbars with the same name after you close and reopen the Menu Editor.
- The tooltip appears when you place the cursor over a menu item or button.
- The internal name, which is case insensitive. JMP identifies the location of an item by its internal name rather than its caption.

Submenu items include many of the same General properties as buttons, except that submenu items do not have tooltips.

To specify these properties, follow these steps:

1. With the Menu Editor still opened, select the menu item or button. The General properties appear on the right.
2. Enter the internal name next to **Internal name**.
3. Enter a unique name for the menu item or button in the Caption box.
4. Enter a description for button in the Tip box.
5. (Optional) To specify the translation for the caption or tip, do the following:
   - Click the **Localize** button for the item that you want to customize.
   - Select the language.
   - Enter the translation next to Text.
   - Click **OK**.
6. Customize the untitled button or menu item as described in the following procedure.

Step 3: Assign Functionality

Clicking a menu item or button either executes a predefined command or runs a JSL script. The script can be stored in a separate file, or you can enter the JSL in the Run this JSL area of the Menu Editor. If users have access to a central location, such as a network, you typically want to run the script from that location. This also simplifies giving users access to updated scripts. Otherwise, store the JSL in the menu item or button definition.

To associate a menu item or button with an add-in JSL script, you have two options:

- Select **Run JSL in this file**, and then browse to find the external file.
- Type the relative path to the JSL script, and select the add-in from the **Use add-in home folder** list. For example, the following command runs the `mds_application.jsl` script from the selected add-in:

  ```plaintext
  $ADDIN_HOME(com.jmp.mdswithr)/mds_application.jsl
  ```
In addition, you can select **Use the “Here” namespace for unqualified JSL variable names** if you include namespaces in the internal or external JSL script. See the Building Blocks chapter in the *Scripting Guide* book for details about namespaces.

To assign this functionality, follow these steps:

1. With the Menu Editor still opened, select the menu item or button that you want to modify. The Action properties appear on the right.
2. Select the action that you want to execute.
3. To run an internal JSL script, delete the placeholder text `print("Not implemented.");` in the Run this JSL area and enter the JSL.
4. (Optional) If your internal or external JSL script includes namespaces, select **Use the “Here” namespace for unqualified JSL variable names**.
5. Click **Save** to save your changes.

**Step 4: Show an Icon on the Menu Item or Button (Optional)**

New menu items have no icon next to the item. New buttons show up as blue squares on the toolbars. You can assign a descriptive icon to the menu item or button. The graphic can reside on your computer or in an add-in folder. .ico, .png, .jpg, and .bmp graphics are supported.

Assigning an icon to a button is particularly important. Otherwise, the user must view the button’s tooltip to see what the button does.

To show an icon on the menu item or button, follow these steps:

1. With the Menu Editor still opened, select the menu item or button. The Icon properties appear on the right.
2. Select one of the following options:
   - **None** Select this option to show a blue square instead of an icon.
   - **Built-in icon** Select this option to show an icon that JMP provides, and then select the icon from the list.
   - **Use image from file** Select this option to show an image that you created. Click **Browse**, select the graphic, and then click **OK**.
   - **Use add-in home folder** Select this option to display an icon from an add-in to the left of the menu item. After you select the checkbox, select the add-in, click **Browse**, and then select the icon. The path to the image is displayed in the **Use image from file** field. The image can be an ICO, PNG, JPG, or BMP graphic.
3. Click **Save** to save your changes.
Step 5: Assign a Shortcut Key (Optional)

A shortcut key executes an action so that you do not have to select the menu item or click the button on the toolbar. This option is also helpful when the button’s toolbar is not shown, but you still want to execute the action.

Shortcuts begin with Ctrl, Ctrl+Shift Ctrl+Alt and end with a number, letter, or symbol that appears on the keyboard. The Function keys (such as F1) are also supported. Many Ctrl + letter and Function shortcuts are already assigned in JMP, but you can reassign them to your buttons if you want.

Shortcut keys appear in menus next to each menu item.

To assign a shortcut key, follow these steps:

1. With the Menu Editor still opened, select the menu item or button.
   The Shortcuts properties appear on the right.

2. Do one of the following:
   – To assign a new shortcut, click in the New shortcut area and press the shortcut keys. If the keystrokes then appear in the Currently assign to box, press another combination of shortcut keys. (You do not have to delete the keystrokes before pressing the shortcut keys.)
   – To change a shortcut that you previously specified, click Remove, click in the New shortcut area and press the shortcut keys.

3. Click Assign.
   The shortcut appears in the Current shortcuts list.

4. Click Save to save your changes.

To remove a shortcut, select the shortcut and click Remove.

Rearrange Toolbars

On Windows, there are two ways to rearrange toolbars:

- To rearrange toolbars quickly for the current user, drag the toolbar above, below, to the left, or to the right of the adjacent toolbar.

- To specify the new location rather than drag the toolbar, right-click the toolbar and select a position from the Location menu. This method lets you move toolbars to the top or bottom of the window. You can also position the toolbars vertically on the left or right side of the window.

In some windows, the toolbar is hidden by default. Specifying a new location shows the toolbar in all windows of that type. On Windows, you can change the toolbar preferences to always show toolbars. See “Windows Specific” on page 517 in the “JMP Preferences” chapter.
To drag a toolbar

1. Click the left corner of the toolbar until the Move cursor appears.
2. Drag the toolbar to the new location. When a toolbar is too wide to show completely, click the arrow to show all of the buttons, as shown in Figure 12.3.

![Figure 12.3 Expanding a Toolbar](image)

To position the toolbar

1. Right-click the toolbar that you want to move.
2. Select Location, and then select the new position.

**Note:** After you move a toolbar to the left, right, or bottom positions, you can add other toolbars to the same position. For example, you might relocate the File_Edit toolbar to the right side of the JMP window. To add other toolbars on the right side, right-click the bar and select the toolbar that you want to add.

**Copy and Paste Menus, Menu Items, Toolbars, and Buttons**

Copying existing items is a shortcut to creating new items in a menu or toolbar. This option lets you change only a few settings in the new item when possible.

**To copy and paste menus and menu items**

1. Select View > Customize > Menus and Toolbars.
2. (Optional) Change the customization set to control which users see your customizations. See “Change Customization Sets” on page 471 for details.
3. Right-click the menu or menu item that you want to copy and select Copy.
4. Right-click the menu or menu item before, after, or into which the item will appear and select Paste.
5. Select the location of the menu by doing one of the following:
   - To paste the item before the selected menu, select Paste before.
   - To paste the menu after the selected menu, select Paste after.
To paste the menu inside the selected menu, select **Paste into**. (Available only when you select a menu as the new location.)

To cancel the action, select **Cancel**.

The item appears as you indicated.

6. Modify the item.
7. Click **Save** to save your changes.

See “Create Main Menus” on page 475 and “Create Menu Items and Toolbar Buttons” on page 475 for details about modifying the items.

**To copy and paste toolbars and buttons**

1. Select **View > Customize > Menus and Toolbars**.
   
The Menu Editor appears.

2. (Optional) Change the customization set to control which users see your customizations.
   
   See “Change Customization Sets” on page 471 for details.

3. Right-click the toolbar or button that you want to copy and select **Copy**.

4. Do one of the following:
   
   – To paste a toolbar, right-click **Toolbar** and select **Paste**. The toolbar appears at the end of the list of toolbars.
   
   – To paste a button, right-click the button before or after which you want the new button, and select **Paste**. If you selected the first button on the toolbar, select the location of the button. Otherwise, the button is pasted below the selected button.

5. Modify the item.
6. Click **Save** to save your changes.

See “Create Toolbars” on page 472 and “Create Menu Items and Toolbar Buttons” on page 475 for details about modifying the items.

**Rearrange Custom Menus, Menu Items, and Buttons**

On Windows, you can rearrange the order of menus, menu items, and buttons that you create. For example, under the **File > New** menu, you could move your custom menu before the **Data Table** command.

In the item’s General properties, the Source determines whether you can move the item. You can move items if the Source is **Custom Item**. Built-in items cannot be moved. Items that are defined in other customization sets can be moved only in that customization set. See “Change Customization Sets” on page 471 for details.
Note: The right-click menu has options for cutting and pasting items. To cut an item, you can also hold down the Ctrl key and press X, or hold down the Shift key and press DELETE. To paste, hold down the Ctrl key and press V, or hold down the Shift key and press INSERT.

To rearrange custom menus and menu items

1. Select View > Customize > Menus and Toolbars.
   The Main Menu list appears on the left.
2. Do the following:
   - Select the item that you want to move.
   - Verify that the Source is Custom Item.
   - If the Source is All Users or JMP Add-In, select the specified customization set and verify that the Source is Custom Item.
3. Right-click the custom menu or menu item that you want to move and select Cut.
4. Right-click the new location of the cut item and select Paste.
   One of the following occurs:
   - A list appears with the possible locations of the cut item. This occurs when you select a menu (such as File or New) or the first item in a menu (such as Data Table in the File > New menu).
   - The cut menu item appears below the selected menu item. Skip to step 6.
5. Select the location of the cut item by doing one of the following:
   - To paste the cut item before the selected item, select Paste before.
   - To paste the cut item after the selected item, select Paste after.
   - To paste the cut item inside the selected menu, select Paste into. (Available only when you select a menu as the new location.)
   - To cancel the move, select Cancel.
   - The item appears as you indicated.
6. Click Save to save your changes.

To rearrange custom buttons

1. Select View > Customize > Menus and Toolbars.
   The Toolbars list appears on the left.
2. Do the following:
   - Select the custom button that you want to move.
   - Verify that the Source is Custom Item.
3. Right-click the custom button that you want to move and select Cut.

4. Right-click the new location of the cut button.

One of the following occurs:

- A list appears with the possible locations of the cut button. This occurs when you select the first button on the toolbar (such as **New Data Table** in the **File_Edit** toolbar).

- The button is pasted at the end of the toolbar. This occurs when you select the name of the toolbar. For example, when you select **File_Edit** and paste, the button appears after the last button, **Run Script**. Skip to step 6.

- The cut button appears after the selected button. Skip to step 6.

5. Select the location of the cut button by doing one of the following:

   - To paste the cut button before the selected button, select **Paste before**.
   
   - To paste the cut button after the selected button, select **Paste after**.

6. Click Save to save your changes.

**Delete Custom Items**

Rather than temporarily showing or hiding toolbars, buttons, menus, and menu items, you can delete items that you created to remove them permanently from JMP. The Source determines whether you can delete the item and which customization set contains the item. Figure 12.4 shows examples of customization Source types.

**Figure 12.4** Examples of Customization Sources

<table>
<thead>
<tr>
<th>Source Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>All Users</strong></td>
<td><strong>Delete the item in the current customization set.</strong></td>
</tr>
<tr>
<td><strong>JMP Add-In</strong></td>
<td><strong>Delete the item from the <strong>All Users</strong> customization set.</strong></td>
</tr>
<tr>
<td><strong>Custom Item</strong></td>
<td><strong>The item cannot be deleted.</strong></td>
</tr>
</tbody>
</table>

Empty menus are not supported. When you delete the only item in a menu, the entire menu is deleted, not just the selected item.

**Note:** Make sure that you really want to delete custom items. They are removed immediately without confirmation.
To delete a custom item, follow these steps:

1. Select View > Customize > Menus and Toolbars.
   The Menu Editor appears.
2. Select the item that you want to delete.
3. Verify whether the item can be deleted, and change the customization set, if necessary.
4. Right-click the selected item and select Delete.
   The item is immediately deleted.
5. Click Save.
   Your changes are saved.

**Show and Hide Items**

In the Menu Editor, you show or hide toolbars, buttons, menus, and menu items in specific customization sets. The item’s Source determines where you show or hide the item. For example:

- When the Source is *All Users*, change the customization set to *All users* to hide the item from all users.
- When the Source is *JMP Add-In*, change the customization set to *JMP Add-In* followed by the name of the add-in. The item is shown or hidden in all sets that include the selected JMP add-in.

If you do not change the customization set, the item is shown or hidden only in the currently selected set. See “Change Customization Sets” on page 471 for details about customization sets.

**Note:** To quickly hide or show toolbars for the current user, select or deselect them from the View > Toolbars list.

To show and hide items in a customization set, follow these steps:

1. Select View > Customize > Menus and Toolbars.
   The Menu Editor appears.
2. Select the customization set that you want to modify.
3. Select the item that you want to show or hide.
4. Select or deselect Hidden in the General properties. See “Step 2: Specify the Caption and Internal Name” on page 474 for details about the General properties.
5. Click Save to save your changes.
Chapter 12
Using JMP

Personalize JMP

Personalize Toolbars and Menus on Windows

Import Customizations

Changes to toolbars and menus are stored in customization sets, or plain text files. You open a customization set in JMP to import your modified toolbars and menus. The customizations are then shown in the Menu Editor. See “Change Customization Sets” on page 471 for details about the menu customization files.

To import customizations, follow these steps:

1. Select **File > Open**.
2. In the File name list, select **All JMP Files** (or **JMP Menu Files**) and then select the customization set.
3. Click **Open**.
   A confirmation is displayed, stating that the customizations have been imported. The Menu Editor is also opened.
4. Display the Menu Editor and click **OK** to save the changes, or click **Cancel** to discard them.

Remove Customizations

As you modify items, you discard unsaved changes by clicking the Menu Editor’s **Cancel** button and clicking **Yes** to confirm. After saving customizations, you can also remove all customizations and revert to the original menus and toolbars.

To remove all of the current user’s customizations

1. Select **View > Customize > Revert to Factory Defaults**.
2. Click **Yes** to remove the current user’s customizations.
   When JMP finds customizations from a previous version of JMP, a confirmation appears. Do one of the following:
   - Select **No** to avoid adding those customizations to the current installation of JMP.
   - Select **Yes** to add those customizations to the current installation of JMP.

   **Note:** Select **Do not ask me again about merging my old menus** for JMP to ignore customizations found in a previous JMP version every time you open JMP. However, when you revert toolbars and menus to the factory defaults, you always have the opportunity to merge old menus, whether you previously checked the merging old menus option.

To remove customizations from another customization set

1. Select **View > Customize > Menus and Toolbars**.
   The Menu Editor appears.
2. Click **Change**.
3. Select the customization set, and click OK.
4. Click Revert All.
   A confirmation window appears.
5. Click Yes to remove your customizations.

To remove customizations from the selected item
1. Select View > Customize > Menus and Toolbars.
   The Menu Editor appears.
2. (Optional) Select the customization set that contains the item.
3. Select the item that you want to modify.
4. Do one of the following:
   – To restore the previous properties of an unsaved item, click Reset.
   – To restore the original properties of a built-in item, click Revert All, and then click Yes to confirm.
5. Click Save to save your changes.

Personalize Toolbars on Macintosh

On the Macintosh, you can set up toolbars to display only the icons that you need. Icons are available based on the type of window. For example, in a script window, icons for options such as reformatting, encrypting, and running the script are available. Table icons are available only for data table toolbars.

You can specify whether the icon, icon and icon name, or just the name appear on the toolbar. Displaying small icons is also an option.

To add, remove, or rearrange toolbar icons
1. Open the type of window whose toolbar you want to customize.
2. Select View > Customize Toolbar.
   A window appears that shows icons relevant to the current type of window.
3. Do any of the following:
   – To add an icon to the toolbar, drag the icon from the window onto the toolbar.
   – To move an icon on the toolbar, drag the icon to its new location onto the toolbar.
   – To remove an icon from the toolbar, drag the icon from the toolbar onto the window.
Your changes are applied to the current window and all open windows of the same type.
Chapter 12
Personalize JMP

487
Personalize Menu Items on Macintosh

Figure 12.5 Add, Rearrange, and Remove Toolbar Buttons on the Macintosh

4. Click **Done**.

When a toolbar is too wide to display completely, click the right arrows on the toolbar to show and then select other icons. Alternatively, you can click and drag the window until the entire toolbar appears.

**Note:** To display the original set of toolbar icons, drag the default set from the bottom of the toolbar customization window to the toolbar.

To change the appearance of toolbar icons
1. Open the type of window whose toolbar you want to customize.
2. Select **View > Customize Toolbar**.

A window containing toolbar icons appears.
3. At the bottom of the window, select one of the following options from the Show list:
   - To display only an icon, select **Icon**.
   - To display an icon and its name, select **Icon and Text**.
   - To display only the icon name, select **Text**.
4. To display small or standard icons, select or deselect **Use small size**.

Your changes are applied to the current window and all open windows of the same type.
5. Click **Done**.

**Personalize Menu Items on Macintosh**

Customize JMP menus to quickly access files or modify existing menu items. Selecting a menu item runs a JSL script from your computer or executes the JSL commands that you specify. For example, you can create a menu item to open a frequently used script. This option is an alternative to adding the script as a favorite on the Home Window.

Features include adding and renaming menu items, hiding menu items, inserting menu item separators, and associating a menu item with JSL.
JMP customizations are stored in <username>/Library/Application Support/JMP/13/usercust.jmpcust.

**Note:** You cannot delete default JMP menus or delete submenus (which open to reveal other menu items). Default and custom submenus also cannot be renamed.

**Example of Adding a Menu Item**

In this example, create a menu item that runs a script.

1. Select View > Customize Menus.
2. Select File > Open.
3. Press Control and then select Add New Menu Item after.
4. Type What is the Current Time? in the New Item Label box.
5. Select Run JSL in this file: and select Library/Application Support/JMP/12/Scripts/timeAnnouncer.jsl.
6. Click Add Item and Close.
7. Select File > What is the Current Time?.
   The Scheduler window appears, and the current time is spoken.

**Example of Adding a Submenu Item**

A submenu opens to reveal submenu items. In this example, create a submenu item that opens a data table.

1. Select View > Customize Menus.
2. In the JMP Menu Editor, select File > Open.
3. Press Control and select Add New Submenu after.
4. Type Open My Data Tables and select JSL Commands.
   - **Note:** Selecting JSL Script lets you select a JSL script from your computer.
5. Click Add Item.
6. Select Open My Data Tables, delete Subitem placeholder in the Menu Label box, and then type Open Napoleons March.jmp.
7. In the Run this JSL box, type Open("$SAMPLE_DATA/Napoleons March.jmp");.
8. Click Save.
9. Select the File menu to see the new menu item.

**Tip:** If the new menu item appears in the menu but not the menu editor, close the menu editor window and reopen it.
To delete a custom menu or submenu item

- Delete one custom menu item by selecting the item and selecting **Delete Selection** from the options list.
- Delete all custom menu items by selecting **Revert All** from the options list.
- To delete items within a submenu, you must delete the entire submenu. Empty menus are not permitted. Select the submenu and select **Delete Selection** from the options list.
JMP preferences enable you to specify general and specific settings and save the settings.

To change preferences

1. Select File > Preferences (Windows) or JMP > Preferences (Macintosh). The window in Figure 13.1 appears with the General preferences category showing.
2. Click a category and make selections. Click Apply to see the results, and then click OK.
Overview

The Preferences command on the File menu (on the JMP menu on Macintosh) displays the Preferences window. See Figure 13.1. Each category is described in this chapter.

Changes that you make to preferences are stored in a version-specific JMP.PFS file located in one of the following folders:

C:/Users/<user name>/AppData/Roaming/SAS/JMP/13/
C:/Users/<user name>/AppData/Roaming/SAS/JMPPro/13/
C:/Users/<user name>/AppData/Roaming/SAS/JMPSW/13/

JMP looks for this file when you open the program and considers your changes to be the factory defaults. And all subsequent changes are stored in this file.

Note: The Reset to Defaults button is on every page of the preferences. Clicking the button on the General, Graphs, Reports, or Styles pages resets preferences on all of those pages. On the remaining pages, clicking the button resets preferences only on the current page.

General

The General page is initially displayed when you open Preferences. Most General preferences customize your JMP session at start-up. Others set preferences for file handling and the general appearance of the JMP workspace.
Figure 13.1 General Preferences

Table 13.1 Preferences on the General Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Tip of the Day at startup</td>
<td>Select this option to show the Tip of the Day window at start-up. This option is selected by default. Clear this option to prevent the Tip of the Day window from appearing at start-up.</td>
</tr>
<tr>
<td>Initial Splash Window</td>
<td>Select this option to show the initial splash window at start-up. This option is selected by default. Clear this option to prevent the initial splash window from appearing at start-up.</td>
</tr>
<tr>
<td>Initial JMP Starter Window</td>
<td>(Macintosh only) Select this option to show the JMP Starter window every time you start JMP. This option is on by default.</td>
</tr>
</tbody>
</table>
### JMP Preferences

#### General

**Initial JMP Window**
(Windows only) Select one of the listed windows as the default window. When JMP starts, this window appears.

**Home Window**
(Macintosh) Select this option to show the JMP Home window when you start JMP on Macintosh.

**Reopen the initial JMP window on last window close**
(Windows only) Select this option to open whichever window you have set as the Initial JMP Window when you close the last JMP window. If this option is turned off, closing the last JMP window also quits JMP.

This option is on by default.

**Excel Open Method**
Select one of the options to determine how JMP imports Microsoft Excel worksheets.

- **Excel Wizard**
  Lets you preview a Microsoft Excel worksheet and modify the settings before importing the data. This is the default setting on Windows. On Macintosh, all .xlsx files open in the Excel Wizard.

- **Open All Sheets**
  Opens all worksheets in the workbook. On Macintosh, this preference is only for .xls files.

- **Select Individual Worksheets**
  Lets you select the worksheets that you want to open from a workbook. On Macintosh, this preference is only for .xls files. The option is also provided on Macintosh when you open an Excel (.xls) file.

On Windows, you can also select **File > Open**, select the workbook, click the **Open** button arrow, and select **Open Selected Worksheets** or **Use Excel Wizard**.

See the Data Tables chapter in the *Scripting Guide* for more information about importing Microsoft Excel workbooks through JSL.

**Use Excel Labels as Headings**
Select this option to allow JMP to use Excel label names as column headings when importing Excel files. Available settings include:

- **Use best guess** (default)
- **Always**
- **Never**

---

**Table 13.1 Preferences on the General Page (Continued)**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Initial JMP Window</strong></td>
<td>(Windows only) Select one of the listed windows as the default window. When JMP starts, this window appears.</td>
</tr>
<tr>
<td><strong>Home Window</strong></td>
<td>(Macintosh) Select this option to show the JMP Home window when you start JMP on Macintosh.</td>
</tr>
<tr>
<td><strong>Reopen the initial JMP window on last window close</strong></td>
<td>(Windows only) Select this option to open whichever window you have set as the Initial JMP Window when you close the last JMP window. If this option is turned off, closing the last JMP window also quits JMP. This option is on by default.</td>
</tr>
<tr>
<td><strong>Excel Open Method</strong></td>
<td>Select one of the options to determine how JMP imports Microsoft Excel worksheets.</td>
</tr>
</tbody>
</table>
|                                                      | **Excel Wizard**
|                                                      | Lets you preview a Microsoft Excel worksheet and modify the settings before importing the data. This is the default setting on Windows. On Macintosh, all .xlsx files open in the Excel Wizard. |
|                                                      | **Open All Sheets**
|                                                      | Opens all worksheets in the workbook. On Macintosh, this preference is only for .xls files. |
|                                                      | **Select Individual Worksheets**
|                                                      | Lets you select the worksheets that you want to open from a workbook. On Macintosh, this preference is only for .xls files. The option is also provided on Macintosh when you open an Excel (.xls) file. |
|                                                      | On Windows, you can also select **File > Open**, select the workbook, click the **Open** button arrow, and select **Open Selected Worksheets** or **Use Excel Wizard**. |
|                                                      | See the Data Tables chapter in the *Scripting Guide* for more information about importing Microsoft Excel workbooks through JSL. |
| **Use Excel Labels as Headings**                     | Select this option to allow JMP to use Excel label names as column headings when importing Excel files. Available settings include: |
|                                                      | - **Use best guess** (default) |
|                                                      | - **Always** |
|                                                      | - **Never** |
### Table 13.1 Preferences on the General Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Image Format for PowerPoint</strong></td>
<td>Select the default file format for images exported to Microsoft PowerPoint. Windows does not support the native PDF graphics produced on Macintosh. Macintosh does not support the native EMF graphics produced on Windows. For cross-platform compatibility, specify the PNG or JPEG graphic format. Additional file formats are available through scripting. See <code>Save Presentation()</code> in the <em>JSL Syntax Reference</em> for details.</td>
</tr>
<tr>
<td><strong>Use SPSS Labels for column names during import</strong></td>
<td>Select this option to allow JMP to use SPSS label names as column headings when importing SPSS files.</td>
</tr>
<tr>
<td><strong>Use Triple-S Labels as Headings</strong></td>
<td>Select this option to allow JMP to use Triple-S label names as column headings.</td>
</tr>
<tr>
<td><strong>Show menu tips</strong></td>
<td><em>(Windows only)</em> Select this option to see tooltips on main menu options and options in red triangle menus. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Annotate error lines in log</strong></td>
<td>Select this option to print more informative error messages to the log. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Show log warnings for JSL compatibility changes in JMP 12</strong></td>
<td>Select this option to print warnings about JSL compatibility to the log.</td>
</tr>
</tbody>
</table>
| **Allow Unquoted Strings in JSL** | Select this option to print a warning to the log when a string value in a platform message is unquoted. Quoted string values are preferred over literal names.  

**Yes (no warning)**  Allows unquoted string values and does not print a warning to the log. This option is selected by default.  

**Yes (warning)**  Allows unquoted string values and prints a warning to the log.  

**No**  Ignores the unquoted string value and does not print a warning to the log. |
| **Open Text File Charset** | Select one of the options from the menu to determine what character encoding JMP uses to open files. Best Guess is the default. |
Table 13.1 Preferences on the General Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Text Files as Unicode</td>
<td>JMP uses the Unicode character set, which supports special characters such as é and ½. It saves files without special Unicode characters as plain text automatically. This option is selected by default. Clear this check box to save all your files as plain text. Note that versions of JMP earlier than 5.1.2 cannot read Unicode files.</td>
</tr>
<tr>
<td>Save Journals GZ Compressed</td>
<td>Select this option to save JMP journals in a compressed format to save disk space. Clear this option to save journals normally. This option is not selected by default.</td>
</tr>
<tr>
<td>Save Data Table Columns GZ Compressed</td>
<td>Select this option to allow JMP to save data tables using GZ compression. For backward compatibility, JMP 10 can read the compressed files but not save them. This option is not selected by default.</td>
</tr>
<tr>
<td>Save Scripts in English</td>
<td>Non-English versions of JMP can save scripts in either English or your local language. User-specified values (such as column names and text strings) in these scripts appear as they do in the data table. However, command words (such as Distribution and Set Value) appear in English rather than the local language in order for the script to run on JMP in English. JMP properly displays non-Roman characters (such as Japanese variable names) in JMP in English when the fonts support the necessary characters. Select this option to save scripts in English no matter what language JMP is using. Clear this option to save scripts in your local language. Note that these scripts run correctly only if JMP is running in the same language. This option is selected by default.</td>
</tr>
<tr>
<td>Preference</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| Display indexes in English | Shows sections of the JMP Indexes in English or the current locale’s language. The preference is selected by default. When you deselect it, the following items are displayed in the current locale’s language:  
- The message list for objects  
- The message list for display boxes.  
- The category list for JSL functions.  
**Note:** The description of each index item is always displayed in the current locale’s language. Examples are always in English. |
| Report Invalid Display Box Messages | Sends information about invalid display box messages to the log. This option is off by default.  
This option can be useful during script development, but can cause unwanted log messages for existing scripts. |
| Add files opened by scripts to the Recent Files list | (Windows only) Select this option to include files opened by the JSL `Open()` command in the Home Window Recent Files pane and the File > Recent Files list. |
| Internet Open Timeout | When you use Internet Open to open a web page, JMP waits the specified number of seconds before stopping the import due to an error. 60 seconds is the default value. |
| Autosave Timeout | Automatically saves the contents of opened data tables, journals, reports, projects, and scripts except for untitled files. The default value is 0 minutes. |
| Autosave Maximum Data Table Rows | Autosaves data tables if the number of rows does not exceed the specified value. 10,000 is the default value. |
| Autosave Maximum Data Table Columns | Autosaves data tables if the number of columns does not exceed the specified value. 1,000 is the default value. |
| Save the session when exiting | This option enables you to save the state of the JMP window when existing JMP. When opening JMP, the saved state is restored, including any open files and windows. |
Reports

Report preferences customize the appearance of reports.

**Figure 13.2 Reports Preferences**

![Preference Group]

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date Title on Output</td>
<td>Select this option to display the date and time the analysis occurred in your report windows. This option is cleared by default.</td>
</tr>
<tr>
<td>Data Table Title on Output</td>
<td>Select this option to display the name of the data table and notes, if there are any, at the top of the report. This option is cleared by default.</td>
</tr>
</tbody>
</table>
### Table 13.2 Preferences on the Reports Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hover Help</td>
<td>On some numeric output, JMP provides tooltip-style help when you circle the mouse over a result. Select this option to see a tooltip where it is available. This option is selected by default.</td>
</tr>
</tbody>
</table>
| Close report action | Select one of the options from the menu to determine what happens when you close a report:  
**Prompt** When you close a report, you are prompted to save it.  
**Discard** When you close a report, you are not prompted to save it, and the report is not saved. This is the default selection.  
**Save / Auto-save** When you close a report, it is automatically saved using the preference selected in the “Auto-save the report to” menu. |
| Auto-save the report to | Select one of the options from the menu to determine where a report is saved:  
**Prompt** When you close a report, you are prompted for a location to save it. This is the default selection.  
**Data Table Script** When you close a report, it is saved as a script in the open data table.  
**Journal Script** When you close a report, it is saved to a journal window.  
**Log Window** When you close a report, its script is written to the log window. |
### Table 13.2 Preferences on the Reports Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Save table with report</strong></td>
<td>Select one of the options from the menu to determine how a table is saved to a report:</td>
</tr>
<tr>
<td><strong>Embed</strong></td>
<td>When you save a report, the table is embedded into the report. Choose this option if you want to share the report with others. The data table that is stored in the report is reopened (unchanged) each time the report is opened. If you make changes to the table, they are not saved into the report unless you re-save the report.</td>
</tr>
<tr>
<td><strong>Separate</strong></td>
<td>When you save a report, the table is referenced in the report.</td>
</tr>
<tr>
<td><strong>Prompt</strong></td>
<td>When you save a report, you are prompted to specify how to save the report: either to embed the table within the report, or to add a reference to the table in the report.</td>
</tr>
<tr>
<td><strong>Prompt</strong> is selected by default.</td>
<td></td>
</tr>
</tbody>
</table>

| **Laser pointer**        | JMP has a built-in laser pointer that enables you to visually emphasize parts of a report. It is off by default. |
|                         | To turn it on, select a color for the laser pointer from the list.                                                                                  |

<p>| <strong>Show conditional formatting</strong> | Conditionally formats the color of the text that represents the values. Available for correlation values, $p$-values, and factor pattern values. |
|                               | Select one of the options from the menu:                                                                                                           |
| <strong>Always</strong>                   | Conditional formatting is always applied to correlation values, $p$-values, and factor pattern values.                                              |
| <strong>Screen Only</strong>              | Conditional formatting is always applied to correlation values, $p$-values, and factor pattern values. However, the conditional formatting does not show when the report is printed. |
| <strong>Never</strong>                    | Conditional formatting is never applied to correlation values, $p$-values, and factor pattern values.                                                 |</p>
<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Rules</td>
<td>Creates custom conditional formatting rules that can be applied to numeric columns or matrices. See “Use Conditional Formatting” on page 369 in the “JMP Reports” chapter.</td>
</tr>
<tr>
<td>Note: Use an Asterisk with the PValue Format</td>
<td>Select this option to display an asterisk (<em>) next to significant p-values. This option is on by default. Note: Verify any conditional formatting rules for PValue to ensure asterisk (</em>) is not used for any defined conditions.</td>
</tr>
</tbody>
</table>

Table 13.2 Preferences on the Reports Page (Continued)

Graphs

Graph preferences customize the appearance of graphs. See “Styles” on page 504 for additional details about configuring the appearance of graphs.

Figure 13.3 Graphs Preferences
### Table 13.3 Preferences on the Graphs Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graph Border</strong></td>
<td>Draws a border line around the area of the graph. This option is not selected by default.</td>
</tr>
<tr>
<td><strong>Y-Axis Title Above Graph</strong></td>
<td>Shows the Title for the Y-Axis above the line rather than beside the line. This option is not selected by default.</td>
</tr>
<tr>
<td><strong>Hide Overlapping Labels</strong></td>
<td>Select this option to hide overlapping chart labels. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Graph Height</strong></td>
<td>Sets the default height (in pixels) for a graph. Default is 240 pixels.</td>
</tr>
<tr>
<td><strong>Line Width</strong></td>
<td>Sets the default width (in pixels) for lines that pertain to content. Default is 2 pixels.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Does not apply to grid lines.</td>
</tr>
<tr>
<td><strong>Graph Marker size</strong></td>
<td>Select a default size for the markers in graphs: Dot, Small, Medium, Large, XL, XXL, or XXXL.</td>
</tr>
<tr>
<td><strong>Graph Marker</strong></td>
<td>Select a default marker shape for the markers in graphs.</td>
</tr>
<tr>
<td><strong>Graph Marker Theme</strong></td>
<td>Select a default theme for the markers in graphs when you mark by row or column.</td>
</tr>
<tr>
<td><strong>Marker Selection Mode</strong></td>
<td>Select the default formatting for selected markers. See “Marker Selection Modes” on page 380 in the “JMP Reports” chapter.</td>
</tr>
<tr>
<td><strong>Marker Selection Color</strong></td>
<td>When the Marker Selection Mode is Selected Same Color, this setting applies the specified color to selected markers. Default color is Red.</td>
</tr>
<tr>
<td><strong>Marker Selection Fade</strong></td>
<td>When the Marker Selection Mode is Unselected Faded, this setting fades the unselected markers by the specified amount (in percent). The default is 65%.</td>
</tr>
</tbody>
</table>
### Table 13.3 Preferences on the Graphs Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Marker Label Color Style</strong></td>
<td>Select the color of the marker label that appears on a graph when you label a column in the data table.</td>
</tr>
<tr>
<td><strong>Marker Color</strong></td>
<td>The marker label is the same color as the marker. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Marker Color Faded</strong></td>
<td>The marker label is faded according to the Marker Selection Fade preference.</td>
</tr>
<tr>
<td><strong>Fixed Color</strong></td>
<td>The marker label color is as specified. The Marker Label Fixed Color preference determines the color.</td>
</tr>
<tr>
<td><strong>Marker Label Fixed Color</strong></td>
<td>Select the color of fixed-color marker labels, an option that you select in the Marker Label Color Style preference. The default color is gray.</td>
</tr>
<tr>
<td><strong>Fast Marker Threshold</strong></td>
<td>When JMP refreshes a report window, it can draw markers on a plot at two different speeds: normal and fast. If JMP is in normal drawing mode, and the number of markers in a graph are more than the specified threshold number, JMP automatically switches to fast mode. Enter the number of markers that separate normal and fast mode. The default is 50,000.</td>
</tr>
<tr>
<td><strong>Fill Hollow Markers</strong></td>
<td>Select this option to apply an opaque background to markers.</td>
</tr>
<tr>
<td><strong>Fill Selection Mode</strong></td>
<td>Select the default highlight for selected rows in graphic objects:</td>
</tr>
<tr>
<td><strong>Selected Patterned</strong></td>
<td>A striped pattern (default)</td>
</tr>
<tr>
<td><strong>Selected Darkened</strong></td>
<td>A solid darker color</td>
</tr>
<tr>
<td><strong>Selected Outlined</strong></td>
<td>An outline</td>
</tr>
<tr>
<td><strong>Selected Same Color</strong></td>
<td>The Fill Selection Color in the preferences formats the selected object.</td>
</tr>
<tr>
<td><strong>Fill Selection Color</strong></td>
<td>Select the default color of selected rows in graphic objects when the Fill Selection Mode is “Selected Same Color”. The default color is red.</td>
</tr>
</tbody>
</table>
Table 13.3 Preferences on the Graphs Page  

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Continuous Color Theme</strong></td>
<td>Select a default color theme for continuous data. The default theme is Blue to Gray to Red. See “Create Color Themes” on page 191 in the “Enter and Edit Data” chapter.</td>
</tr>
<tr>
<td><strong>Categorical Color Theme</strong></td>
<td>Select a default color theme for categorical data. The default theme is JMP Default. See “Create Color Themes” on page 191 in the “Enter and Edit Data” chapter.</td>
</tr>
</tbody>
</table>

**Styles**

The Style pages enables you to customize colors, tick marks and grid lines, and report colors. See “Graphs” on page 501 for additional details about configuring the appearance of graphs.

**Figure 13.4  Styles Preferences**
Table 13.4 Preferences on the Styles Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color Presets</strong></td>
<td>The Color Presets provides a set of predefined colors for use in customizing the appearance of reports, graphs, charts, and so on. Tints of the selected color are applied to the various elements.</td>
</tr>
<tr>
<td><strong>Frame Color</strong></td>
<td>Defines the color applied to a graph frame and tick marks. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Major Grid Line Color</strong></td>
<td>Defines the major grid line color. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Minor Grid Line Color</strong></td>
<td>Defines the minor grid line color. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Graph Background Color</strong></td>
<td>Click the color box to select a background color for all graphs. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Window Background Color</strong></td>
<td>Click the color box to select a background color for all reports and data tables. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Original</strong></td>
<td>Click to restore default color settings.</td>
</tr>
<tr>
<td><strong>Frame Border</strong></td>
<td>Shows borders only on the axes.</td>
</tr>
<tr>
<td><strong>Tick marks inside graph frame</strong></td>
<td>Shows axis tick marks inside the graph frame.</td>
</tr>
<tr>
<td><strong>Major Grid Lines</strong></td>
<td>Shows major grid lines on graphs.</td>
</tr>
<tr>
<td><strong>Minor Grid Lines</strong></td>
<td>Shows minor grid lines on graphs.</td>
</tr>
<tr>
<td><strong>Underline Table Headings</strong></td>
<td>Shows border under table headings.</td>
</tr>
<tr>
<td><strong>Shade Table Headings</strong></td>
<td>Shows table headings with shading.</td>
</tr>
<tr>
<td><strong>Table Heading Column Borders</strong></td>
<td>Shows divider lines between columns in table headings.</td>
</tr>
<tr>
<td><strong>Table Column Borders</strong></td>
<td>Shows borders between table columns.</td>
</tr>
<tr>
<td><strong>Table Row Borders</strong></td>
<td>Shows borders between table rows.</td>
</tr>
<tr>
<td><strong>Shade Alternate Table Rows</strong></td>
<td>Shows alternate table rows with shading.</td>
</tr>
<tr>
<td><strong>Shade Table Cells</strong></td>
<td>Shows table cells with shading.</td>
</tr>
</tbody>
</table>
Table 13.4 Preferences on the Styles Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview Graph</td>
<td>Shows a preview area where you can see your changes before applying them.</td>
</tr>
</tbody>
</table>

Tables

Table preferences customize JMP data tables, including formula handling, appearance, and compatibility with SAS data sets.

Figure 13.5 Tables Preferences
### Table 13.5 Preferences on the Tables Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluate OnOpen Scripts</td>
<td>If you save a script to a data table and name it <code>OnOpen</code> or <code>On Open</code>, JMP can automatically run the script whenever you open the data table. <code>On Open</code> scripts that execute other programs are never run.</td>
</tr>
<tr>
<td></td>
<td>Prompt is selected by default. Your choice is remembered each time you open the data table in the current JMP session.</td>
</tr>
<tr>
<td></td>
<td>Select Always to allow <code>On Open</code> scripts to run without prompting.</td>
</tr>
<tr>
<td></td>
<td>Select Never to prevent <code>On Open</code> scripts from automatically running when a data table is opened.</td>
</tr>
<tr>
<td>Allow short numeric data format</td>
<td>JMP has the ability to store numeric data in as few as 8 bits (one byte). This option makes short-integer formats available to you when you select Cols &gt; Column Info and assign a column a data type. When you use the correct short-integer format for your data, the numbers are not displayed differently, but the data table uses less disk space. See “The Short-Integer Format” on page 227 in the “The Column Info Window” chapter.</td>
</tr>
<tr>
<td>Print Data Grid as is</td>
<td>Select this option to print the JMP data table as it appears on the screen.</td>
</tr>
<tr>
<td></td>
<td>Clear this option to resize column widths to accommodate the content width. This option is cleared by default.</td>
</tr>
<tr>
<td>Preserve SAS variable names when exporting to SAS</td>
<td>Select this option to use variable names that are compliant with SAS when you export a JMP data table to a SAS data set. This option is cleared by default.</td>
</tr>
<tr>
<td>Preserve SAS formats when exporting to SAS</td>
<td>Select this option to use formats that are compliant with SAS when you export a JMP data table to a SAS data set. This option is selected by default.</td>
</tr>
</tbody>
</table>
Table 13.5 Preferences on the Tables Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Show Alternate Column Name** | Select this option to show the name-label pair of the column. A column has name-label pair if the two column properties are defined and the Column Name equals one of the two properties. JMP recognizes the following name-label pairs:  
  • SAS name-label pair, where the properties are “SAS Name” and “SAS Label”  
  • SPSS name-label pair, where the properties are “SPSS Name” and “SPSS Label”  
  • Short-long name-label pair, where the properties are “Short Name” and “Long Name”  
  
  If the preference is checked, then both the name and label appear in the dialog. |
| **Use Thousands Separator**  | Select this option to display numbers using the locale-appropriate thousands separator. This option is not selected by default.             |
| **Default Field Width**      | Changes the number of digits that appear in numeric columns.                                                                                 |
| **Use a Floating Window for Data Filters** | Select this option to float the Data Filter window on top of its associated data table. Clearing this option causes the Data Filter window to behave like any other window. This option is selected by default. |
| **Data Filter Select Check** | Select this option to show the Select check box in the Data Filter. This option is selected by default.                                         |
| **Data Filter Show Check**   | Select this option to show the Show check box in the Data Filter. This option is not selected by default.                                      |
| **Data Filter Include Check** | Select this option to show the Include check box in the Data Filter. This option is not selected by default.                                   |
| **Data Filter Group is AND** | Select this option to reverse the AND and OR behavior between groups in the Data Filter.                                                    |
| **Data Filter Auto Clear**   | Select this option to show the Auto clear option in the Data Filter red triangle menu. This option is selected by default.                   |
| **Data Filter Check Box Display** | Select this option to always use check boxes for categorical filter columns. This option is not selected by default.                        |
Table 13.5 Preferences on the Tables Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include Responses Not in Data</td>
<td>(Categorical columns only) Shows all of the possible responses listed in value labels, even if the response is not present within the data.</td>
</tr>
<tr>
<td>Numeric keypad Enter key moves down</td>
<td>(Windows only) When a data table cell is selected and you press the Enter (or Return) key on the keyboard, the next table cell down is selected. Pressing either the TAB key or the ENTER key on the numeric keypad located to the right of the keyboard selects the next table cell to the right. Select this option to change the behavior of the ENTER key on the numeric keypad to select the next table cell down instead of to the right. This option is cleared by default.</td>
</tr>
<tr>
<td>Suppress Formula Eval on Open</td>
<td>Select this option to prevent columns formulas from being evaluated when you open data tables. Clear this option to allow formulas to be evaluated when you open data tables. This option is cleared by default.</td>
</tr>
<tr>
<td>ODBC Hide Connection String</td>
<td>Select this option to have the Open Database command hide the ODBC connection settings (that is, user ID and password). See the Extending JMP chapter in the <em>Scripting Guide</em> book for additional information.</td>
</tr>
<tr>
<td>Data Table Background Color</td>
<td>Click the color box to select a background color for data tables.</td>
</tr>
<tr>
<td>Data Table Grid Color</td>
<td>Click the color box to select a color for the grid lines in a data table.</td>
</tr>
<tr>
<td>Data Table Header Grid Color</td>
<td>Click the color box to select a background color for the column names.</td>
</tr>
</tbody>
</table>

**Platforms**

Each analysis report has a variety of plot and table options that are shown by default. However, there might be additional options that you want to see each time you run a particular analysis. For example, a bivariate analysis shows a scatterplot by default, but you might also always want to see a linear fit each time. By selecting the Platforms option in the left panel of the Preferences window, you can set the default options for analyses. (Analyses
are run by using platforms, such as the Bivariate platform. Thus, the name of this category is Platforms.)

Highlight an analysis name in the Platforms list. Its available options appear in the Options box with the defaults selected.

Click **Reset Platform to Defaults** to return the selected platform options to the default settings.

Click **Reset to Defaults** to return all platforms to their default settings.

**Figure 13.6 Platforms Preferences**

![Platforms Preferences]

**Graph Builder Preferences**

There are a few preferences in Graph Builder that do not appear as options within JMP and cannot be scripted. Select **Platforms**, and then select **Graph Builder** from the list of platforms to see these preferences.

**Table 13.6 Frequently Used Graph Builder Preferences**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>Show the legend next to the graph. The option is on by default.</td>
</tr>
<tr>
<td>Legend Position</td>
<td>Changes the location of the legend. The default value is Right.</td>
</tr>
<tr>
<td>Show Footer</td>
<td>Shows the footer on the graph. The option is on by default.</td>
</tr>
</tbody>
</table>
### Table 13.6 Frequently Used Graph Builder Preferences (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Lock Scales</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Link Page Axes</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Continuous Points Limit</strong></td>
<td>For continuous variables, this number indicates the number of rows at which the Points element is no longer shown initially. The default value is 1500.</td>
</tr>
<tr>
<td><strong>Continuous Alternate</strong></td>
<td>For continuous variables, indicates the element to display when there are more rows than the Points limit can handle. The default value is None, or you can select Contour (density contour). If None is selected, and the Continuous Smoother is turned off, Points appear when the limit is breached.</td>
</tr>
<tr>
<td><strong>Continuous Smoother</strong></td>
<td>For continuous variables, indicates whether the Continuous Smoother should appear.</td>
</tr>
<tr>
<td><strong>Categorical Points Limit</strong></td>
<td>For categorical variables, this number indicates the number of rows at which the Points element is no longer shown initially. The default value is 1500.</td>
</tr>
</tbody>
</table>
| **Categorical Alternate** | For categorical variables, indicates the element to display when there are more rows than the Points limit can handle. The default value is Box Plot, or you can select from the following options:  
- None  
- Contour  
- Line  
- Smoother  
- Box Plot  
- Bar  
- Histogram |
| **Jitter**             | Indicates whether jittering is on by default. Small spaces are displayed between the data points so that you can see each point more clearly. (Only applies to elements that support jittering.) |
Print

The Print pages enables you to configure default print settings such as, margins, header, and footers.

**Figure 13.7** Print Preferences

![Print Preferences Diagram]

**Table 13.7** Preferences for Print Settings

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Top (margin)</strong></td>
<td>Sets the print page’s top margin. The default value is 0.75 inches.</td>
</tr>
<tr>
<td><strong>Left (margin)</strong></td>
<td>Sets the print page’s left margin. The default value is 0.75 inches.</td>
</tr>
<tr>
<td><strong>Right (margin)</strong></td>
<td>Sets the print page’s right margin. The default value is 0.75 inches.</td>
</tr>
<tr>
<td><strong>Bottom (margin)</strong></td>
<td>Sets the print page’s bottom margin. The default value is 0.75 inches.</td>
</tr>
<tr>
<td><strong>Left (header)</strong></td>
<td>Sets the page’s left-side header information. The default value is &amp;wt; (that is, the title).</td>
</tr>
</tbody>
</table>
Table 13.7 Preferences for Print Settings (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center (header)</td>
<td>Sets the page’s center header information. The default value is blank.</td>
</tr>
<tr>
<td>Right (header)</td>
<td>Sets the page’s right-side header information. The default value is Page &amp;pn; of &amp;pc; (that is, Page # of count).</td>
</tr>
<tr>
<td>Left (footer)</td>
<td>Sets the page’s left-side footer information. The default value is blank.</td>
</tr>
<tr>
<td>Center (footer)</td>
<td>Sets the page’s center footer information. The default value is blank.</td>
</tr>
<tr>
<td>Right (footer)</td>
<td>Sets the page’s right-side footer information. The default value is blank.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Sets the page’s print orientation as either Portrait or Landscape. The default value is Portrait.</td>
</tr>
<tr>
<td>Scale Factor</td>
<td>Sets the page’s print scaling factor (in percent). The default value is 100%.</td>
</tr>
</tbody>
</table>

Note: The code for printing the current date in the header or footer is \&d.

Text Data Files

Text Data File preferences customize the handling of importing and exporting text files.
Table 13.8 Preferences for Import Settings for Text Files

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import Settings</td>
<td>Select the strategy JMP uses to open text files. The default selection is <strong>Use these settings</strong>. In that case, you need to ensure that the settings reflect your text files. If you select <strong>Use Best Guess</strong>, JMP collects statistics in the text file on tabs, commas, blanks, and a few other characters and uses a rule-based system to decide what the file format might be. The rules try to make reasonable field widths and a reasonable number of fields per line. If your data format is too different from what the rules are designed to guess, JMP guesses incorrectly. In that case, either use the wizard or explicitly describe your data in these preference settings.</td>
</tr>
</tbody>
</table>
Table 13.8 Preferences for Import Settings for Text Files (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>End Of Field</td>
<td>Select one or more characters to use as the delimiter that signifies the end of a field when importing text data.</td>
</tr>
<tr>
<td></td>
<td>Select the <strong>Other</strong> option and enter a character to specify a delimiter that is not listed.</td>
</tr>
<tr>
<td>End Of Line</td>
<td>Select one or more characters to use as the delimiter that signifies the end of a line (row).</td>
</tr>
<tr>
<td></td>
<td>Select the <strong>Other</strong> option and enter a character to specify a delimiter that is not listed.</td>
</tr>
<tr>
<td></td>
<td>Note that if double-quotes are encountered when importing text data, the delimiter rules change to look for an end double-quote. Other text delimiters, including spaces, that are embedded within the quotes are ignored and treated as part of the text string.</td>
</tr>
<tr>
<td>Table contains column headers</td>
<td>Select this option if your text file contains columns names. If you select this option, enter the line number where the column names are located in the field next to <strong>Column Names are on line</strong>.</td>
</tr>
<tr>
<td>Column Names are on line</td>
<td>If you select the <strong>Table contains column headers</strong> option, enter the line number where the column names are located in this field.</td>
</tr>
<tr>
<td>Data starts on line</td>
<td>Enter the line number where the data starts in your text file.</td>
</tr>
<tr>
<td>When determining column types</td>
<td>Set how long JMP scans a text file to determine data types for the columns. <strong>Scan whole file</strong> is selected by default. Note that the <strong>Scan whole file</strong> option can cause importing a text file to be slow for large files. Consider selecting <strong>Scan for 5 seconds</strong> instead.</td>
</tr>
<tr>
<td></td>
<td>When your text file contains columns of missing data, select <strong>Treat empty columns as numeric</strong> to import the columns as numeric rather than character. A period, Unicode dot, <em>NaN</em>, or a blank string are possible missing value indicators. This option is deselected by default.</td>
</tr>
<tr>
<td>Two-digit year rule</td>
<td>Select the rule that you want to use to import dates that have two-digit years instead of four. For details about these rules, see “Two-digit year rule” on page 139 in the “Import Your Data” chapter.</td>
</tr>
</tbody>
</table>
Table 13.8 Preferences for Import Settings for Text Files (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Try to compress</strong></td>
<td>Select the options used for compressing text files. Available options are:</td>
</tr>
<tr>
<td></td>
<td>• Numeric columns</td>
</tr>
<tr>
<td></td>
<td>• Character columns</td>
</tr>
<tr>
<td></td>
<td>• Allow List Check</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This feature requires a scan of the entire file.</td>
</tr>
<tr>
<td><strong>Strip enclosing quotation marks</strong></td>
<td>Select this option to remove quotation marks that enclose data in the text file. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Recognize apostrophe as quotation mark</strong></td>
<td>Select this option to treat apostrophes as quotation marks and omit them. This option is off by default.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This option is not recommended unless your data comes from a nonstandard source that places apostrophes around data fields rather than quotation marks.</td>
</tr>
<tr>
<td><strong>Use Regional Settings</strong></td>
<td>Select this option to use the operating system’s regional settings when importing a text file.</td>
</tr>
<tr>
<td></td>
<td>• If the option is deselected (the default setting), files that use a period for a decimal point and a comma for the value separator import correctly.</td>
</tr>
<tr>
<td></td>
<td>• If the file uses a comma for a decimal point and some other value separator (and the regional settings use a comma for a decimal point), selecting this option imports the text correctly. You must specify the value separator in the Text Data Files import preferences.</td>
</tr>
</tbody>
</table>

Table 13.9 Preferences for Export Settings for Text Files

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Export Table Headers</strong></td>
<td>Select this option to include column names when you save data tables as text files.</td>
</tr>
<tr>
<td><strong>End Of Field</strong></td>
<td>Select one or more characters to use as the delimiter signifying the end of a field when exporting text data.</td>
</tr>
<tr>
<td></td>
<td>Select the <strong>Other</strong> option and enter a character to specify a delimiter that is not listed.</td>
</tr>
</tbody>
</table>
Table 13.9 Preferences for Export Settings for Text Files (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>End Of Line</td>
<td>Select one or more characters to use as the delimiter that signifies the end of a line (row). Select the Other option and enter a character to specify a delimiter that is not listed.</td>
</tr>
</tbody>
</table>

Windows Specific

These preferences customize settings for Windows computers, including auto-hiding menus and toolbars and selecting the default graphics format.

Figure 13.9 Windows Specific Preferences
Table 13.10  Windows Specific Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Language</td>
<td>Select the language in which you want to run JMP.</td>
</tr>
<tr>
<td></td>
<td>The locale settings for your operating system normally determine settings for number, date, and currency formats. Select the option below the language menu to use that language to determine these formats instead.</td>
</tr>
<tr>
<td></td>
<td>Text that appears in windows provided by the operating system (for example, File &gt; Open), do not reflect changes in the language setting.</td>
</tr>
<tr>
<td></td>
<td>Notes:</td>
</tr>
<tr>
<td></td>
<td>• After changing the display language, close and restart JMP to have the language settings fully take effect.</td>
</tr>
<tr>
<td></td>
<td>• The languages that you selected in the JMP installation program determine which languages are available. To make a language available, rerun the JMP installation program, select Modify, and then select the language.</td>
</tr>
<tr>
<td>Copy/Drag Graphic Formats</td>
<td>Select one or more graphic formats to use when copying and pasting (or dragging and dropping) graphics from JMP into other applications.</td>
</tr>
<tr>
<td>Resolution (DPI) for PNG and JPEG Images</td>
<td>Specify the DPI to be used when you copy a graphic format. Choose from the Default (96) or 300. 300 is better for images that must be stretched, embedded in trade publications, or printed. However, this setting uses more memory and is slower to generate for large images.</td>
</tr>
<tr>
<td></td>
<td>The following script lets you set the default DPI. Change the number to a different DPI if you want and then run the script.</td>
</tr>
<tr>
<td></td>
<td>Pref( Save Image DPI( 600 ) );</td>
</tr>
<tr>
<td></td>
<td>To verify the default DPI after you run the preceding script, run the following script:</td>
</tr>
<tr>
<td></td>
<td>Get Preferences( Save Image DPI );</td>
</tr>
<tr>
<td></td>
<td>For details about specifying a higher DPI, see “Setting the Graphic DPI” on page 433 in the “Save and Share Data” chapter.</td>
</tr>
</tbody>
</table>
### Table 13.10 Windows Specific Preferences  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graphics Formats</strong></td>
<td>Select the format to use for graphics when you save a JMP report as an RTF file or an HTML file.</td>
</tr>
<tr>
<td></td>
<td>In the Graphic Scale Factor % box, enter the percentage at which you want graphics to appear in other applications. This feature might not work with all versions of your chosen application.</td>
</tr>
<tr>
<td><strong>Enable hardware accelerated graphics</strong></td>
<td>Takes better advantage of the computer’s graphics processing unit (GPU) for better video performance. Consider selecting this option if your computer is sluggish when drawing JMP windows. This is an experimental feature.</td>
</tr>
<tr>
<td><strong>Highlight Outline Headers</strong></td>
<td>Select this option to give title bars in the data table and report windows a light shade of gray. This option is selected by default.</td>
</tr>
<tr>
<td></td>
<td>Clear this option to give the title bars a darker shade of gray.</td>
</tr>
<tr>
<td><strong>JSL Scripts should be run only, not opened,</strong></td>
<td>Select this option to force all scripts to run when opened. If this is selected, the script window for the script is not opened. This option is off by default.</td>
</tr>
<tr>
<td><strong>when selected from Recent Files or a file browser</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Show on the Windows task bar</strong></td>
<td>Select which JMP windows you would like displayed on the Windows task bar. The default selection is All Windows. You can also choose to display the main JMP window and data table windows.</td>
</tr>
<tr>
<td><strong>Open the JMP Log window</strong></td>
<td>Select one of the options to open the log only when text (such as error messages) is added to it or every time you start JMP. The default setting displays the log only when you open it.</td>
</tr>
<tr>
<td><strong>Auto-hide menu and toolbars</strong></td>
<td>Select the rule used to determine when menus and toolbars are hidden. The default value is Based on window size.</td>
</tr>
<tr>
<td><strong>Wrap the main menu in narrow windows</strong></td>
<td>Select this option to wrap the menu to additional lines when the window is narrower than the menu. This option is on by default.</td>
</tr>
<tr>
<td><strong>Show the thumbnail panel in data table windows</strong></td>
<td>Select this option to show the thumbnail panel of reports at the bottom of a data table. This option is on by default.</td>
</tr>
<tr>
<td><strong>Dock the Window List in maximized windows</strong></td>
<td>Select this option to automatically dock the Window List if you maximize your JMP windows. This option is off by default.</td>
</tr>
</tbody>
</table>
Macintosh OS Settings

Macintosh OS Settings preferences customize settings for Macintosh machines, including the graphics formats and file associations.

Figure 13.10 Macintosh OS Settings Preferences

Table 13.11 Macintosh OS Settings

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alternate Image Formats for Clipboard and Drag &amp; Drop</td>
<td>Select one or more graphic formats to use when copying and pasting (or dragging and dropping) graphics from JMP into other applications.</td>
</tr>
<tr>
<td>Clipboard Image Scale Factor</td>
<td>Enter the percentage at which you want graphics to appear in other applications.</td>
</tr>
</tbody>
</table>
Table 13.11 Macintosh OS Settings (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image format for RTF</td>
<td>Select the format to use for graphics when you save a JMP report as an RTF file.</td>
</tr>
<tr>
<td>RTF Image Scale Factor</td>
<td>Enter the percentage at which you want graphics to appear in RTF documents.</td>
</tr>
<tr>
<td>Image format for HTML</td>
<td>Select the format to use for graphics when you save a JMP report as an HTML file.</td>
</tr>
</tbody>
</table>

**Fonts**

Font preferences customize the appearance of reports, data tables, and scripts, including fonts, text size, and font style.

**Figure 13.11 Fonts Preferences**
Table 13.12 Preferences for Customizing Fonts

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Sets the font for the text portion of a JMP analysis report.</td>
</tr>
<tr>
<td>Heading</td>
<td>Sets the font for the heading of columns in an analysis report and a data table.</td>
</tr>
<tr>
<td>Title</td>
<td>Sets the font for the title shown in all title bars.</td>
</tr>
<tr>
<td>Small</td>
<td>Sets the font for small text, which is used in the upper left corner of the data grid to show the number of columns and rows.</td>
</tr>
<tr>
<td>Mono</td>
<td>Sets the font used in the JMP Scripting Language (JSL) editor for script commands.</td>
</tr>
<tr>
<td>Formula Editor</td>
<td>Sets the font for the expressions entered into the Formula Editor.</td>
</tr>
<tr>
<td>Annotation</td>
<td>Sets the default font used in annotations.</td>
</tr>
<tr>
<td>Axis</td>
<td>Sets the font used for the axis tick labels.</td>
</tr>
<tr>
<td>Marker</td>
<td>Sets the font used for alphanumeric markers.</td>
</tr>
<tr>
<td>Axis Title</td>
<td>Sets the font for axis titles.</td>
</tr>
<tr>
<td>Data Table</td>
<td>Sets the font for displaying data in the data table.</td>
</tr>
<tr>
<td>Font Family</td>
<td>Select a proportional font. The font that you select is immediately applied to all settings except for Mono, which is used for scripts.</td>
</tr>
<tr>
<td>Use Greek letters</td>
<td>Select this option to use Greek letters instead of spelling out Greek letters. (For example, π instead of pi.) This option is selected by default.</td>
</tr>
<tr>
<td>Use math symbols</td>
<td>Select this option to use math symbols instead of simple text representations of math symbols. (For example, ± instead of +/-) This option is selected by default.</td>
</tr>
</tbody>
</table>
(Windows only) Communications preferences customize settings for reading data from an external source. These settings need to be specified only if you are using an instrument to do so.

Figure 13.12 Communications Preferences

Table 13.13 Preferences on the Communications Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port</td>
<td>Select the port that your data source uses.</td>
</tr>
<tr>
<td>Baud Rate</td>
<td>Set the baud rate for your data source.</td>
</tr>
<tr>
<td>Data Bits</td>
<td>Set the number of data bits (7 or 8).</td>
</tr>
<tr>
<td>Parity</td>
<td>Set the parity bit. None is the default value.</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>Set the stop bits (1 or 2).</td>
</tr>
</tbody>
</table>
File Locations

(Windows only) File Locations preferences set the default locations of JMP system files. Usually, the files can stay where JMP installs them, and you do not have to change anything here. However, if you do move files, such as Help files, elsewhere, you should update the location here.

Figure 13.13 File Locations Preferences

Table 13.13 Preferences on the Communications Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flow Control</td>
<td>Set the flow control. XON/XOFF is the default value.</td>
</tr>
</tbody>
</table>
### Table 13.14 Preferences on the File Locations Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Files directory</td>
<td>Change the folder in which JMP looks for data files (for example, data tables).</td>
</tr>
<tr>
<td>Help Files directory</td>
<td>Change the folder in which JMP looks for Help files.</td>
</tr>
<tr>
<td>Installation directory</td>
<td>Change the JMP installation folder.</td>
</tr>
<tr>
<td>License file path</td>
<td>Change the folder in which JMP looks for your JMP License file.</td>
</tr>
<tr>
<td>Preferences file directory</td>
<td>Change the folder in which JMP looks for preference information.</td>
</tr>
<tr>
<td>Save As directory</td>
<td>Change the folder in which JMP saves data files when you select File &gt; Save As.</td>
</tr>
<tr>
<td>Always go to this directory when the File Open window is displayed</td>
<td>Select to have JMP always use the selected path when you select File &gt; Open.</td>
</tr>
</tbody>
</table>
Script Editor

Script Editor preferences customize the appearance of the JSL Script Editor, such as tab width, syntax coloring, and tooltips.

Figure 13.14 Script Editor Preferences

Table 13.15 Preferences on the Script Editor Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use tabs</td>
<td>Select this option to enable tabs in your scripts. This option is selected by default. Clear this option to replace any tab that you type with spaces.</td>
</tr>
<tr>
<td>Tab width</td>
<td>Enter how many spaces a tab should indent. If you have disabled tabs, any tab you type is replaced with the number of spaces specified. The default value is 4.</td>
</tr>
<tr>
<td>Preference</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Extra space at bottom of document</td>
<td>Select this option to enable scrolling up from the last blank lines of a script. This option is selected by default on Windows and deselected on Macintosh.</td>
</tr>
<tr>
<td>Auto-complete parentheses and braces</td>
<td>Select this option to enable the script editor to automatically add closing parentheses, square brackets, and curly braces when you type an opening one. This option is selected by default.</td>
</tr>
<tr>
<td>Show line numbers</td>
<td>Select this option to show the line numbers on the left side of the script editor. This option is off by default.</td>
</tr>
<tr>
<td>Show indentation guides</td>
<td>Select this option to see faint vertical lines that mark indentation. This option is selected by default.</td>
</tr>
<tr>
<td>Show operator tips</td>
<td>Select this option to see tooltips for JSL operators. This option is selected by default.</td>
</tr>
<tr>
<td>Show variable value tips</td>
<td>Select this option to see tooltips for variable values. This option is selected by default.</td>
</tr>
<tr>
<td>Wrap Text</td>
<td>Select this option to always wrap text in the script editor. This option is off by default.</td>
</tr>
<tr>
<td>Show embedded log on script window open</td>
<td>Select this option to have an embedded log window appear in the scripting window when editing or running scripts. This option is off default.</td>
</tr>
<tr>
<td>Save and restore document state information</td>
<td>Saves the state of collapsed and expanded code, and restores that state when the script is reopened.</td>
</tr>
<tr>
<td>Auto Save Before Run</td>
<td>Automatically saves the script before you run it. This option is off by default.</td>
</tr>
<tr>
<td>Multiple Selection</td>
<td>Enables you to select lines of code that are not adjacent. Hold down the Ctrl key on Windows or Command key on Macintosh and drag your cursor over the text. Continue this action for any other text that you want to select. This option is on by default.</td>
</tr>
</tbody>
</table>
Table 13.15 Preferences on the Script Editor Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code folding</td>
<td>Select this option to use code folding markers in the script editor, which mark the opening and closing of user defined functions and Expr() blocks. You can expand and collapse these marked blocks of code. This option is off by default. You can also choose the appearance of the marker using the JSL code folding marker menu. See the Scripting Tools chapter in the <em>Scripting Guide</em> for details.</td>
</tr>
<tr>
<td>Allow additional code folding keywords</td>
<td>Select this option to enable using additional keywords for folding markers in the script editor. See the Scripting Tools chapter in the <em>Scripting Guide</em> for details.</td>
</tr>
<tr>
<td>Color unknown object messages</td>
<td>Select this option to always show unknown object messages in color. Unknown object messages will appear in the color specified by “Message unknown color”. This option is off by default.</td>
</tr>
<tr>
<td>Spaces inside parentheses</td>
<td>Select this option to cause the script editor to add spaces between parentheses, brackets, and braces and their contents for automatically formatted scripts. This is on by default.</td>
</tr>
<tr>
<td>Spaces in operator names</td>
<td>Select this option to cause the script editor to add spaces between words within operator names. For example, turning on this option results in New Window instead of NewWindow. This option is selected by default.</td>
</tr>
<tr>
<td>Customize Styles</td>
<td>Select colors and fonts for code elements shown in JSL scripts, SAS scripts, the Text Explorer customization window, text files, and so. Reset All Styles to Defaults restores the original colors for all items in the list. Reset Style to Defaults restores the original colors and font for the selected item on the right. Note that resetting the Fonts preferences does not affect the fonts selected on this page.</td>
</tr>
</tbody>
</table>

**SAS Integration**

SAS Integration preferences customize the default settings for working with SAS servers. For details about using the SAS Integration capabilities, see “Import Data from SAS” on page 77 in the “Import Your Data” chapter.
Note: The SAS Environment options appear after you select SAS 9.3 or 9.4 from the SAS Server Version list.

Figure 13.15 SAS Integration Preferences

Table 13.16 Preferences on the SAS Integration Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAS Server Version</td>
<td>Select the default version for the SAS Server. This can also be changed in the Server Connections window. (See “Connect to a SAS Metadata Server” on page 82 in the “Import Your Data” chapter.) This option does not apply when connecting to local SAS on Windows.</td>
</tr>
<tr>
<td>I want to connect to a SAS Environment</td>
<td>Select this option to always connect to a SAS Environment and click <strong>Configure</strong> to configure the URL of the location.</td>
</tr>
</tbody>
</table>
**Table 13.16 Preferences on the SAS Integration Page (Continued)**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I want to connect to a SAS Metadata Server</td>
<td>Select this option to always connect to a SAS Metadata Server. This option is selected by default.</td>
</tr>
<tr>
<td></td>
<td>Clear this option if you do not have a SAS Metadata Server available, and you connect directly to SAS Workspace Servers instead.</td>
</tr>
<tr>
<td>I will manually connect to SAS workspace servers</td>
<td>Select this option to manually connect to a SAS workspace server.</td>
</tr>
<tr>
<td>Automatically connect metadata-defined SAS libraries</td>
<td>Select this option to connect to metadata-defined SAS libraries automatically across all JMP sessions when you connect to a SAS Workspace Server. Selected by default.</td>
</tr>
<tr>
<td></td>
<td>When the Workspace Server contains a large number of metadata-defined SAS libraries, deselect this option to speed up your connection to the server.</td>
</tr>
<tr>
<td>Automatically generate ODS results</td>
<td>Select this option to generate output delivery system (ODS) results. This option is cleared by default.</td>
</tr>
<tr>
<td>ODS Result Format</td>
<td>Select the format for ODS reports. The default value is HTML.</td>
</tr>
<tr>
<td>ODS Style</td>
<td>Enter the style name for ODS reports. The default value is Statistical.</td>
</tr>
<tr>
<td>ODS Style sheet</td>
<td>Enter the style sheet name for ODS reports.</td>
</tr>
<tr>
<td>Prompt if results are larger than __ MB</td>
<td>Enter the number of MB that triggers a prompt for you to continue or cancel the operation. The default value is 5.</td>
</tr>
<tr>
<td>Graphics Format</td>
<td>Select the format for graphics for ODS reports.</td>
</tr>
<tr>
<td>Generate ODS statistical graphics</td>
<td>Select this option to include statistical graphics in the ODS reports.</td>
</tr>
<tr>
<td>Import generated SAS data sets into JMP</td>
<td>Select this option to import any generated data sets into JMP automatically.</td>
</tr>
<tr>
<td>Prompt if data set has more than __ rows</td>
<td>Enter the number of rows that triggers a prompt for you to continue or cancel the operation. The default value is 100,000.</td>
</tr>
<tr>
<td>Use SAS variable labels for column names during data import</td>
<td>Select this option to use the column labels in the SAS data set as the JMP data table column names when importing a SAS data set into a JMP data table.</td>
</tr>
</tbody>
</table>
Table 13.16 Preferences on the SAS Integration Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert SAS custom formats to JMP value labels</td>
<td>Select this option to use the information in the SAS column formats to set JMP value labels when importing a SAS data set into a JMP data table.</td>
</tr>
<tr>
<td>Warn before closing unsaved imported data</td>
<td>Select this option to trigger a prompt to save any SAS data sets that you imported into JMP and have not saved before closing.</td>
</tr>
<tr>
<td>On export, store table and column properties in extended attributes</td>
<td>Select to allow extended attribute support during SAS 9.4 data export. This option is not selected by default.</td>
</tr>
<tr>
<td>On import, apply table and column properties from extended attributes</td>
<td>Select to allow extended attribute support during SAS 9.4 data import. This option is not selected by default.</td>
</tr>
<tr>
<td>Stored Process Results: Format</td>
<td>Select a report format: <strong>HTML</strong>, <strong>RTF</strong>, or <strong>PDF</strong>.</td>
</tr>
<tr>
<td>Stored Process Results: Graph Format</td>
<td>Select a graph format: <strong>ActiveX Image</strong> (available only on a SAS server that runs on Windows), <strong>Java Image</strong>, <strong>PNG</strong>, <strong>JPEG</strong>, or <strong>GIF</strong>.</td>
</tr>
<tr>
<td>Show SAS Log</td>
<td>Select <strong>Always</strong>, <strong>Never</strong>, or <strong>On Error</strong> to set when the SAS log is displayed</td>
</tr>
<tr>
<td>Location</td>
<td>Select the location for SAS log information: within the JMP log window, or in a separate SAS log window.</td>
</tr>
</tbody>
</table>
JSL Debugger

The JSL Debugger preferences let you show or hide line numbers, create breaks in scripts, and show warnings.

**Figure 13.16 JSL Debugger Preferences**

<table>
<thead>
<tr>
<th>Preference Group</th>
<th>JSL Debugger Communications Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td><img src="image" alt="Preference Options" /></td>
</tr>
<tr>
<td>Show Line Numbers</td>
<td>☑️ Show Line Numbers</td>
</tr>
<tr>
<td></td>
<td>☐️ Break On Multiple Statements Per Line</td>
</tr>
<tr>
<td></td>
<td>☐️ Break On Throw</td>
</tr>
<tr>
<td></td>
<td>☑️ Break On Execution Error</td>
</tr>
<tr>
<td></td>
<td>☑️ Warn On Assignment In Condition</td>
</tr>
<tr>
<td></td>
<td>☑️ Enter Debugger Upon Termination</td>
</tr>
<tr>
<td></td>
<td>☑️ Break For Compatibility Warnings</td>
</tr>
</tbody>
</table>

**Table 13.17 Preferences on the JSL Debugger Page**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Line Numbers</td>
<td>Shows or hides the line numbers for the script in the debugger. The default value is selected.</td>
</tr>
<tr>
<td>Break on Multiple Statements Per Line</td>
<td>Stops executing the script between each expression in a single line. The default value is deselected.</td>
</tr>
</tbody>
</table>
Break On Throw

Breaks when an exception error occurs in a Try() function. For example, the exception error in the Try() function is thrown by a Throw() function. The Debugger breaks on the Throw() instead of continuing through the rest of the codes. This lets you identify where the problem occurred in the script and then return to debugging. The default value is deselected.

Break On Execution Error

Stops executing the script when the error occurs rather than closing the Debugger. The default value is selected.

Warn On Assignment In Condition

Select to show a warning when you enter an assignment expression for the breakpoint condition. For example, if you specify $x = 1$ instead of $x == 1$ in the breakpoint condition, you are prompted to verify the specification. The default value is selected.

Enter Debugger Upon Termination

Select to enter the Debugger when JMP terminates. The default value is selected.

Break for Compatibility Warnings

Stops executing the script when a JSL compatibility issue is encountered. The default value is selected.

Menu Preferences

The Menu preferences show and hide menus based on how you use JMP. This gives you fewer menu items to browse through and streamlines the JMP interface. For example, if you never design experiments, deselect Design of Experiments. Other menus are grouped by area of interest, such as quality engineering, advanced modeling, reliability and survival, SAS options and Excel Modeling.
Figure 13.17 Menu Preferences

Preference Group
- General
- Reports
- Graphs
- Styles
- Tables
- Platforms
- Print
- Test Data Files
- Windows Specific
- Fonts
- Communications
- File Locations
- Script Editor
- SAS Integration
- JMP Updates
- JSL Debugger
- Menu
- Query Builder

Check All  Check None

- **Design of Experiments**
  - For producing plans for efficient experimental designs
  - Used by: R&D engineers, scientists, market researchers, experimenters
  - Shows menus: DOE menu, Screening Platform.

- **Quality Engineering**
  - For monitoring processes
  - Used by: Quality and process engineers, six sigma blackbelts

- **Advanced Modeling**
  - For specialized model fitting beyond the standard linear models
  - Used by: researchers with more advanced or specialized training in modeling
  - Shows menus: Neural, Gaussian Process, PLS, Nonlinear, Choice, Item Analysis, Custom Profiler, Mixture Profiler.

- **Reliability/Survival**
  - For analyzing time-to-event data
  - Used by: reliability engineers, biostatisticians, anyone with time-to-event data
  - Shows menus: Reliability submenu, Accelerated Life Test Design

- **SAS**
  - For interfacing with the SAS System
  - Used by: anyone who has access to SAS
  - Shows menus: the SAS menu items, including Submit to SAS

- **Excel Modeling**
  - For the profiler that runs through models based in Excel
  - Used by: Excel users with spreadsheet-based formula models inside Excel
  - Shows menus: Excel Profiler.
The Query Builder preferences customize SQL queries that you perform in Query Builder.

**Figure 13.18 Query Builder Preferences**

<table>
<thead>
<tr>
<th>Preference Group</th>
<th>Preference Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td>Automatically join tables added to a query</td>
</tr>
<tr>
<td></td>
<td>Refresh the preview when a change occurs</td>
</tr>
<tr>
<td></td>
<td>Maximum number of rows for previews: 5000</td>
</tr>
<tr>
<td></td>
<td>Keep queries compatible with JMP 12 by default</td>
</tr>
<tr>
<td></td>
<td>Filters</td>
</tr>
<tr>
<td></td>
<td>Maximum number of levels for a Check Box List filter: 10000</td>
</tr>
<tr>
<td></td>
<td>Maximum rows in table for which category levels will be automatically retrieved: 1000000</td>
</tr>
<tr>
<td></td>
<td>Retrieve category levels for tables whose size cannot be determined</td>
</tr>
<tr>
<td></td>
<td>Default filter type for categorical columns: List Box</td>
</tr>
<tr>
<td></td>
<td>Fallback filter type for categorical columns: Contains</td>
</tr>
<tr>
<td><strong>ODBC</strong></td>
<td>Run the preview update in the background</td>
</tr>
<tr>
<td></td>
<td>Run queries in the background when possible</td>
</tr>
</tbody>
</table>

**Table 13.18 Preferences on the Query Builder Page**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically join tables added to a query</td>
<td>Automatically joins database tables in Query Builder based on keys and common column names. This option is selected by default. Deselect this option to prevent memory issues with large databases.</td>
</tr>
<tr>
<td>Refresh the preview when a change occurs</td>
<td>Updates the data view on the Query Preview tab when a change occurs. This option is selected by default.</td>
</tr>
<tr>
<td>Maximum number of rows for previews</td>
<td>Limits the number of rows that appear on the Query Preview tab. The default number is 5000.</td>
</tr>
</tbody>
</table>
Table 13.18 Preferences on the Query Builder Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keep queries compatible with JMP 12 by default</td>
<td>Maintains query compatibility with JMP 12. When you open a query that is marked JMP 12 compatible in JMP 13, features that create compatibility problems are hidden regardless of how the preference is set.</td>
</tr>
<tr>
<td>Maximum number of levels for a Check Box List filter</td>
<td>Determines whether the filter for a categorical variable is added as a Check Box List filter. By default, when you add a categorical variable that has more than 1,000 levels, the filter is added as a Contains filter.</td>
</tr>
<tr>
<td>Maximum rows in table for which category levels will be</td>
<td>Specifies the maximum numbers of rows for which unique category levels in the filtered column are retrieved. The minimum value is -1 (no limit). The maximum value is 1 billion. By default, if the categorical column has more than 1 million rows, JMP does not automatically retrieve the unique category levels.</td>
</tr>
<tr>
<td>automatically retrieved</td>
<td></td>
</tr>
<tr>
<td>Retrieve category levels for tables whose size cannot be</td>
<td>Determines whether category levels are retrieved for a filtered column when the number of rows cannot be determined. Selected by default. If this option is not selected, the filter is added as a Contains filter.</td>
</tr>
<tr>
<td>determined</td>
<td></td>
</tr>
<tr>
<td>Default filter type for categorical columns</td>
<td>Specifies a List Box as the default filter type for categorical columns.</td>
</tr>
<tr>
<td>Fallback filter type for categorical columns</td>
<td>Specifies a Contains filter as the default filter type for categorical columns when the number of rows cannot be determined or the query is canceled.</td>
</tr>
<tr>
<td>Run the preview update in the background</td>
<td>Updates the data view Query Preview tab without displaying the status so that you can continue to work while the queries run. This option is selected by default.</td>
</tr>
<tr>
<td>Run queries in the background when possible</td>
<td>Runs database queries without displaying the status so that you that can continue to work Query Builder while the queries run. This option is selected by default.</td>
</tr>
</tbody>
</table>
You can add functions to a formula. All of these functions are organized in the function browser, which groups collections of functions and features in lists organized both alphabetically (Functions (all)) and by topic (Functions (grouped)). This chapter gives a description of functions in the Formula Editor.

More information about functions is available in the following resources:

- The Scripting Index describes all functions and their arguments, demonstrates how the functions work, and links to online Help. In JMP, select Help > Scripting Index to view this interactive resource.

- The JSL Syntax Reference also provides the arguments for JMP functions, not just those available in the Formula Editor. In JMP, select Help > Books > JSL Syntax Reference to open a PDF of the book.

Figure A.1 Functions in the Formula Editor

For instructions on how to create a formula that contains a function, see “Create a Formula” on page 306 in the “Formula Editor” chapter.
Row Functions

Adding a row function to a formula lets you reference specific rows or cells within specific rows. You can also insert values based on an arithmetic sequence. See the JSL Functions chapter in the Scripting Guide for details about syntax.

Sequence

Produces an arithmetic sequence of numbers across the rows in a data table, where the start value, ending limit, and increment are specified as arguments.

Count

Creates a list of values beginning with the from value and ending with the to value. The number of steps specifies the number of values in the list between and including the from and to values. Each value determined by the first three arguments of the count function occurs consecutively the number of times that you specify with the times argument. When the to value is reached, Count starts over at the from value.

Also, you can add the times argument with the insert button on the keyboard. This argument is one by default, but repeats the count process as many times as you specify, as illustrated by the Count4 column in the data table in Figure A.2. To add any argument to the Count function, highlight the argument preceding the one that you want to enter. Either type a comma or use the insert button on the Formula Editor keypad.

The columns in the data table below result from the following formulas:

- Count(1, 9, 2) gives Count 1
- Count(1, 9, 3) gives Count 2
- Count(1, 9, 9) gives Count 3
- Count(1, 9, 3, 3) gives Count 4

Figure A.2 Example of the Count Function

The Count function is useful for generating a column of grid values. For example, the following formulas create a square grid of increment NRow(). NRow() is the Row function that gives the total number of rows in the data table) and axes that range from –5 to 5:

\[
\text{Count}(-5, 5, \text{Root( NRow() )})
\];
Count(-5, 5, Root( NRow() ), Root( NRow() ) );

Lag

Returns the value of the first argument in the row defined by the current row less the second argument. The default Lag is one, which you can change to any number. The value returned for any lag that identifies a row number less than one is missing. Note that Lag(X, n) gives the same result as the subscripted notation, \( X_{\text{Row}}(\ )-n \).

Dif

Returns the difference between the value of the first argument in the current row and its value in the row defined by the current row less the second argument. The default Dif is one, which you can change to any number. Note that Dif(X, n) gives the same result as \( X_{\text{Row}}(\ )-X_{\text{Row}}(\ )-n \), or as \( X_{\text{Row}}(\ )-\text{Lag}(X, n) \).

Subscript

Enables you to use a column’s value from a row other than the current row. After choosing Subscript from the list, enter a numeric expression into the subscript argument. Subscripts that evaluate to nonexistent row numbers produce missing values. Column names with no subscript refers to the current row. To remove a subscript, select the subscript and delete it. Then delete the missing box.

The formula \( \text{Count}_{\text{Row}}(\ ) - \text{Count}_{\text{Row}}(\ )-1 \), where Row() is the row number as described below, uses subscripts to calculate the difference between each pair of values from the column named Count. This result is the same as that given by the Dif() function. When Row() is 1, the computation produces a missing value.

The formula below calculates a column called Fib, which contains the terms of the Fibonacci series (each value is the sum of the two preceding values in the calculated column).

\[
\text{If}\left[\begin{array}{c}
\text{Row}(\ )\leq 2 \\
\text{else}
\end{array}\right. \\
\Rightarrow F_i b_{\text{Row}}(\ )-1 + F_i b_{\text{Row}}(\ )-2
\]

It shows the use of subscripts to do recursive calculations. A recursive formula includes the name of the calculated column, subscripted such that it references only previously evaluated rows (rows 1 through \((i-1)\)). The calculation of the Fibonacci series shown includes a conditional expression and a comparison. See the sections “Conditional Functions” on page 555, and “Comparison Functions” on page 554, for details.

Row

Returns the current row number when an expression is evaluated for that row. You can use Row() in any expression, including column name subscripts. The default subscript of a column name is Row() unless otherwise specified.
NRow

Returns the total number of rows in the active data table.

**Numeric Functions**

You can create a formula that contains arithmetic operators that are commonly used in formulas. See the JSL Functions chapter in the *Scripting Guide* for details about syntax.

**Abs**

Returns a positive number of the same magnitude as the value of its argument. For example, $|5|$ and $|-5|$ both result in 5.

**Modulo**

Returns the remainder when the second argument is divided into the first. For example, \( \text{Modulo}(6, 5) \) results in 1.

**Ceiling**

Returns the smallest integer greater than or equal to its argument. For example, \( \text{Ceiling}(2.3) \) results in 3, while \( \text{Ceiling}(-2.3) \) results in -2.

**Floor**

Returns the largest integer less than or equal to its argument. For example, \( \text{Floor}(2.7) \) results in 2, but \( \text{Floor}(-0.5) \) results in -1.

**Round**

Rounds the first argument to the number of decimal places given by the second argument. For example, \( \text{Round}(3.554, 2) \) rounds to 3.55 and \( \text{Round}(3.555, 2) \) rounds to 3.56.

**Transcendental Functions**

You can create a formula that supports transcendental functions, such as logarithmic functions for any base, functions for combinatorial calculations, the Beta function, and several gamma functions. See the JSL Functions chapter the *Scripting Guide* for details about syntax.

**Exp**

Raises \( e \) to the power that you specify. Thus, \( \text{Exp}(1) = e \).
Ln and LnZ
Calculates the natural logarithm of \( x \), except returns 0 when \( x \) is 0; for use with derivatives.

Log and Log10
Calculates the natural logarithm (base \( e \)). To change the default base, highlight the argument and type a comma or click the insert key on the keypad. The base appears and is editable. The Log argument can be any numeric expressions. The expression \( \text{Log}(e) \) evaluates as 1, and \( \text{Log}(32,2) \) is 5. The Log10 function calculates the logarithm of base 10 only.

Log1P
Returns a more accurate calculation of \( \text{Log}(1+x) \) when \( x \) is very small.

Squash
Computes the function \( 1 / (1 + e^x) \), where \( x \) is any numeric column, variable, or expression.

Logist
Also known as Squish or Logistic, is an efficient computation of the function \( 1 / (1+e^{-x}) \), where \( x \) is any numeric column, variable, or expression.

Root or Square Root
Calculates the root of its argument as specified by the index. Root initially shows with an index of 2. To change the index, highlight the index argument and enter the value that you want.

Factorial
Returns the product of all numbers 1 through the argument that you specify. For example, \( \text{Factorial}(5) \) evaluates as 120.

NChooseK
Returns the number of \( n \) things taken \( k \) at a time (\( n \) select \( k \)) and is computed in the standard way using factorials, as \( n! / (k!(n-k)!) \). For example, \( \text{NChooseK}(5,2) \) evaluates as 10.

Beta
Adds the two parameter Beta function and is written terms of the Gamma function as:

\[
B(m, n) = \frac{\Gamma(m)\Gamma(n)}{\Gamma(m + n)}
\]
Formula Functions Reference
Transcendental Functions

Gamma

Adds the Gamma function, denoted $\Gamma(i)$, and is defined as:

$$\Gamma(i) = \int_{0}^{\infty} (x^{i-1})(e^{-x})dx$$

Gamma with a single argument is the same as $\text{Gamma}(x, \infty)$. The optional second argument changes the upper integer from infinity to the value that you enter. Other interesting gamma function relationships are

- for any $\alpha > 1$, $\Gamma(\alpha) = (\alpha-1) \cdot \Gamma(\alpha-1)$
- for any positive integer, $n$, $\Gamma(n) = (n-1)!$
- $\Gamma(0.5) = \sqrt{\pi}$

LGamma

Is the natural log of the result of the gamma function evaluation. You get the same result using the Log (natural log) function with the Gamma function. However, the LGamma function computes more efficiently than do the Log (natural log) and the Gamma functions together. NChooseK is implemented using LGamma functions. The result is not always an exact integer. If the result is close to an integer, it is rounded up using the Floor function.

Digamma

The logarithmic derivative of the Gamma function.

Trigamma

The derivative of the Digamma function, or the logarithmic second derivative of the Gamma function.

Arrhenius

Calculates the non-specific component of the Arrhenius relationship that is then multiplied by the activation energy in the Arrhenius equation.

$$\frac{11605}{T + 273.15}$$

Arrhenius Inv

The inverse of the Arrhenius function:

$$\left(\frac{11605}{y}\right) - 273.15$$
Logit

Applies the logit transformation to the argument using:

\[
\text{logit}(p) = \log\left(\frac{p}{1-p}\right)
\]

Logit Percent

Calculates the logit as a percent for the argument.

\[
\text{LogitPct}(pct) = \log\left(\frac{\frac{pct}{100}}{1 - \frac{pct}{100}}\right)
\]

Logist Percent

Calculates the logistic as a percent for the argument.

\[
\text{LogisticPct}(x) = \frac{100}{1 + e^{-x}}
\]

Scheffe Cubic

Is used in fitting certain models. Scheffe Cubic \((X_1, X_2)\) is equivalent to \(X_1X_2(X_1-X_2)\).

Trigonometric Functions

You can create a formula that supports transcendental functions, such as logarithmic functions for any base, functions for combinatorial calculations, the Beta function, and several gamma functions. See the JSL Functions chapter in the Scripting Guide for details about syntax.

Sine, Cosine, Tangent

The Sine and Cosine functions calculate the sine and cosine of their respective arguments given in radians. For example, the expression \(\text{Sine}(0)\) evaluates as 0, and \(\text{Cosine}(0)\) evaluates as 1. The tangent function calculates the tangent of an argument given in radians. The expression \(\text{Tan}(\pi/4)\) evaluates as 1.

ArcSine, ArcCosine, ArcTangent

The ArcSine and ArcCosine functions return the inverse sine and inverse cosine of their respective arguments. The returned value is measured in radians. For example, both expressions \(\text{ArcSine}(1)\) and \(\text{ArcCosine}(0)\) evaluate as 1.57080. The ArcTangent function returns
the inverse tangent of its argument. The returned value is measured in radians. The expression \textbf{ArcTangent}(1) evaluates as 0.78540 (=3.14159/4).

\textbf{SinH, CosH, TanH}

The \textbf{SinH} and \textbf{CosH} functions return the hyperbolic sine and hyperbolic cosine of their respective arguments. The expression \textbf{SinH}(1) evaluates as 1.175201, and \textbf{CosH}(0) evaluates as 1.0. The \textbf{TanH} function returns the hyperbolic tangent of its argument. The expression \textbf{TanH}(1) evaluates as 0.761594.

\textbf{ArcSinH, ArcCosH, ArcTanH}

The \textbf{ArcSinH} and \textbf{ArcCosH} functions return the inverse hyperbolic sine and inverse hyperbolic cosine of their respective arguments. The expression \textbf{ArcSinH}(1) evaluates as 0.881374, and \textbf{ArcCosH}(1) is 0. The \textbf{ArcTanH} function returns the inverse hyperbolic tangent of its argument. The expression \textbf{ArcTanH}(0.5) evaluates as 0.549306.

\section*{Character Functions}

You can create a formula that accepts character arguments or returns character strings and converts the data type of a value from numeric to character, or character to numeric. When you create these formulas, note that:

- Character functions can result in either character or numeric data. If you calculate a data type different from the one specified, the data type of the computed column is automatically changed to match the result.
- Arguments that are literal character strings must be enclosed in quotation marks.

See the JSL Functions chapter in the \textit{Scripting Guide} for details about syntax.

\textbf{Char}

Produces a character string that corresponds to the digits in its numeric argument. For example, \textbf{Char}(1.123) evaluates as 1.123. See the Types of Data chapter in the \textit{Scripting Guide} for details.

\textbf{Collapse Whitespace}

Trims leading and trailing whitespace and replaces interior whitespace with single space. That is, if more than one white space character is present, the \textbf{Collapse Whitespace} command replaces the two spaces with one space.

\textbf{Concat}  

Concatenates character strings to produce a new string with the function’s second character argument appended to the first. For example, \texttt{"Dr." || " " || name} produces a new string
Consisting of the title Dr. followed by a space and the contents of the name string. (See also “Concat Items” on page 549.)

Contains

Returns the numeric position within the first argument of the first instance of the second argument, if it exists. The second argument can contain one or more characters. If the second argument does not exist, Contains returns a zero. For example, Contains("Veronica Layman", "ay") evaluates as 11. Contains("Lillie Layman", "L") evaluates as 1. The third argument is optional and is a numeric value that specifies the starting position. If offset is negative, Contains searches backward from offset from the end of the string.

Munger

Computes new character strings from existing strings by inserting or deleting characters. It can also produce substrings, calculate indices, and perform other tasks depending on how you specify its arguments. The Munger function treats uppercase and lowercase letters as different characters.

Text is a character expression. Munger applies the other three arguments to this string to compute a result.

Offset is a numeric expression indicating the starting position to search in the string. If Offset is greater than the position of the first instance of the find argument, the first instance is disregarded.

Find/Length is a character or numeric expression. Use a character string as search criterion, or use a positive integer to return that number of consecutive characters starting from the Offset position. If you specify a negative integer as the Length value, Munger returns all characters from the Offset through to the end of the string.

Replace (optional argument) can be a string or unspecified. If it is a string and the Find/Offset value is numeric, Munger replaces the search criterion with the Replace string to form the result. If the Find/Offset value is numeric and no string is specified, Munger calculates a substring. If the Find/Length value is a character string, Munger always returns the numeric offset, disregarding the Replace value if it exists. To insert the Replace argument, click any argument in the Munger function and then click the insert button. Use the delete key on your keyboard or the delete button (_Delete) on the Formula Editor keypad to remove the Replace argument.

Lowercase, Uppercase

The Lowercase function converts any uppercase character found in its argument to the equivalent lowercase character. For example, Lowercase("VERONICA LAYMAN") evaluates as veronica layman. The Uppercase function converts any lowercase character found in its argument to the equivalent uppercase character. For example, Uppercase("Veronica Layman") evaluates as VERONICA LAYMAN.
Length
Calculates the length of its argument. For example, \texttt{Length("Veronica")} evaluates as 8. If the argument is
- a string, length returns the number of characters;
- a list, length returns the number of items in the list;
- a blob (binary object), the number of bytes.

Num
Produces a numeric value that corresponds to its character string argument when the character string consists of numbers only. If a character string contains a non-numeric value, the result is a missing value. For example, \texttt{Num("1.123")} evaluates as 1.123.

Substr
Extracts the characters that are the portion of the first argument. Begins at the position given by the second argument, and ends based on the number of characters specified in the third argument. The first argument can be either a character column or a literal value. The starting argument and the length argument can be numbers of expressions that evaluate to numbers. For example, to show the first name only, \texttt{Substr("Veronica Layman", 10, 6)} starts at position 10 and reads through position 15, which yields \texttt{Layman}.

If \texttt{start} is negative, \texttt{Substr} searches backward from \texttt{start} from the end of the string. If \texttt{length} is negative or absent, \texttt{Substr} returns a string that begins with \texttt{start} and continues to the end of the text string.

\texttt{Substr} can also be used with lists.

Titlecase
Converts the string to title case, that is, an initial uppercase character and subsequent lowercase characters. For example, \texttt{Titlecase(“Veronica layman“)} results in \texttt{Veronica Layman}.

Trim
Produces a new character string from its argument, removing any leading and trailing whitespace. The second argument determines if whitespace is removed from the \texttt{left}, the \texttt{right}, or \texttt{both} ends of the string. If no second argument is used, whitespace is removed from both ends. For example, \texttt{Trim("john ")} evaluates as \texttt{john}. \texttt{Trim(" john ", both)} also evaluates as \texttt{john}.

Word
Extracts the \(n\)th word from a character string. One or more spaces define where each word begins and ends unless the optional \texttt{delimiters} argument is specified. For example, \texttt{Word(2, "Veronica Layman")} returns the word \texttt{Layman}. 
To insert the `delimiters` argument, click on any argument in the `Word` function and then click the insert button on the Formula Editor keypad. Use the delete key on your keyboard or the delete button on the Formula Editor keypad to remove the `delimiters` argument. If you do not specify a delimiter, space is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate word.

Most special characters act as single delimiters. You can enter any character or set of characters to act as a word delimiter. For example, to extract the last name in the following example, use a comma and blank together as the delimiting characters and ask for the first word. `Word(1, "Layman, Veronica", ", ")` returns the word Layman.

**Words**

Extracts the words from `text` according to the delimiters listed in the optional second argument. The default delimiter is space. For example, `Words("the quick brown fox")` returns `{"the","quick","brown","fox"}`.

If you include a second argument, any and all characters in that argument are taken to be delimiters. For example, `Words("Doe, Jane P.", ", .")` returns `{"Doe","Jane","P"}`.

To insert the `delimiters` argument, click on any argument in the `Words` function and then click the insert button on the Formula Editor keypad. Use the delete key on your keyboard or the delete button on the Formula Editor keypad to remove the `delimiters` argument. If you do not specify a delimiter, white space is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate word.

**Left, Right**

Returns a substring of the left-most or right-most `n` characters of the string `text`, respectively. Both functions also work with lists.

**Starts With, Ends With**

Returns 1 if `whole` begins or ends with `part`, respectively. Returns 0 otherwise. Both functions also work with lists.

**Item**

Is different than the `Word` function because of the way it treats word delimiters. If a delimiter is found multiple times, or you enter a delimiter with multiple characters, the `Word` function treats them as a single delimiter. The `Item` function uses each delimiter to define a new word position. To compare, suppose a name is of the form lastname, firstname. The delimiter is a comma followed by a blank, such as:

`Item(2, "Layman, Veronica", ", ")`

`Word(2, "Layman, Veronica", ", ")`
The Item function returns a missing value because it treats the comma and blank separately and finds nothing between them. The Word function treats the comma and blank as a single delimiter and finds Veronica as the second word.

If you do not specify a delimiter, white space (blank space) is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate item.

Char to Hex, Hex, Hex to Char, Hex to Number

Converts between Hex and other formats.

Hex returns the hexadecimal representation of its argument. If the argument is character (in quotes), then the result is a character string twice as long containing the hexadecimal codes for the character values. For example, Hex("A") returns the string 41.

If the argument is numeric and “integer” is specified, the Hex function returns an 8-hexadecimal-character representation of the integer returned. For example, Hex(12, “integer”) returns the string 0000000C.

Hex to Char converts hexadecimals to characters. The resulting character string might not be valid display characters. All the characters must be in pairs, in the ranges 0-9,A-Z, and a-z. Blanks and commas are allowed and skipped.

Char to Hex converts characters to hexadecimals.

Hex to Number converts hexadecimals to numbers.

For details, see the Types of Data chapter in the Scripting Guide book.

Repeat

Creates a string that is the first argument repeated the number of times specified by the second argument. The first argument can be either a character literal, a character variable, or a character expression. For example, Repeat("Katie", 3) creates KatieKatieKatie.

A third argument applies when Repeat is used in a JSL script to repeat a matrix. When the first argument is a matrix, the second argument is the rowwise repeat and the third argument is the columnwise repeat.

Insert, Insert Into

Insert inserts a new item into the list or expression at the given position. If position is not given, it is inserted at the end.

Insert Into is the same as insert, but it inserts in place.

Remove, Remove From

Remove the character(s) at the indicated position. If n is omitted, the item at position is deleted. If position and n are omitted, the item at the end is removed. There are three possible
arguments: the string, followed by the position, followed by the number of characters to be removed.

**Remove From** returns items removed in place. The function returns the removed item(s), but you do not have to assign them to anything. The first argument is a variable name, followed by the position, followed by the number of characters to be removed.

**Shift, Shift Into**

**Shift** shifts an item or \(n\) items from the front to the back of the list or expression. Shifts items from back to front if \(n\) is negative. **Shift Into** shifts items in place.

**Reverse, Reverse Into**

**Reverse** reverses the characters in the string. **Reverse Into** reverses the characters in place.

**Concat Items**

**Concat Items** converts a list of string expressions into one string, with each item separated by a delimiter. The delimiter is a blank, if unspecified.

**Substitute, Substitute Into**

The first argument is a string, the second is a pattern, and the third is a replacement string. **Substitute** finds all matches to the pattern in the string, and replaces them with the replacement string. **Substitute Into** does the same substitution in place.

**Regex**

The first argument is the source string that Regex searches for a match to the pattern. The second argument is the pattern, in the form of a regular expression. The Formula Editor prompts you for these two required arguments.

**Tip:** For more information about using regular expressions, search the Internet for regular expression tutorial.

By default, Regex performs a case-sensitive search and returns the parts of the source string that match the pattern that you specified (or returns MISSING if the match fails). There are two optional arguments that you can add. You can type a third argument—the format—that specifies the string to return. If you choose, you can use regular expressions to specify replacement text in the returned string. If you specify the third argument, you can also specify **IGNORECASE** so that Regex ignores capitalization when searching the source string for a match.
Table A.1 Regex Examples

<table>
<thead>
<tr>
<th>Sample Regex function</th>
<th>String that is returned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Regex( &quot;@ q3 #&quot;, &quot;([a-z])([0-9])&quot; )</td>
<td>q3</td>
</tr>
<tr>
<td>Regex( &quot;@ Q3 #&quot;, &quot;([a-z])([0-9])&quot;, &quot;/0&quot;,IGNORECASE)</td>
<td>Q3</td>
</tr>
<tr>
<td>Regex( &quot;@ Q3 #&quot;, &quot;([a-z])([0-9])&quot;, &quot;/2/1&quot;,IGNORECASE)</td>
<td>3Q</td>
</tr>
</tbody>
</table>

For more information and an example that you can run, select Help > Scripting Index and do a search for Regex.

XPath Query

XPath Query parses a valid XML document for the expression that you specify. For an example, select Help > Scripting Index and search for the function.

Hex to Blob, Char to Blob, Blob to Char

Hex to Blob converts the hexadecimal to a blob (Binary Large Object).

Char to Blob converts the string to a blob. You can specify the encoding in an optional second argument. The default encoding for the blob is utf-8. utf-16le, utf-16be, us-ascii, iso-8859-1, shift-jis, euc-jp, and ascii-hex are also supported.

Blob to Char converts the blob to a string. You can specify the encoding in an optional second argument. The default encoding for the character string is utf-8. utf-16le, utf-16be, us-ascii, iso-8859-1, shift-jis, euc-jp, and ascii-hex are also supported.

Character Pattern Functions

These functions provide powerful pattern matching abilities. Pattern matching is a flexible method for searching and manipulating strings, and regular expressions are also supported. When you create these formulas, note that:

- First, you define a pattern with one more of the character patterns.
- Then, you use Pat Match to compare a string to the pattern.
• **Pat Match** returns True (1) if the pattern is found in the string, or it returns False (0) if the pattern was not found in the string.

• To use regular expressions instead of patterns, use **Regex Match**.

For examples, see the Types of Data chapter in the *Scripting Guide*.

**Pat Any**
Constructs a pattern that matches a single character in the argument.

**Pat Not Any**
Constructs a pattern that matches a single character that is not in the argument.

**Pat Break**
Constructs a pattern that matches zero or more characters that are not in its argument; it stops or breaks on a character in its argument. It fails if a character in its argument is not found. In particular, it fails to match if it finds the end of the source string without finding a break character.

**Pat Span**
Constructs a pattern that matches one or more (not zero) occurrences of characters in its argument. It is greedy; it always matches the longest possible string. It fails rather than matching zero characters.

**Pat String**
Constructs a pattern that matches its string argument.

**Pat Len**
Constructs a pattern that matches n characters.

**Pat Pos**
Constructs patterns that match the null string if the current position is `int` from the left end of the string, and fail otherwise.

**Pat R Pos**
Constructs patterns that match the null string if the current position is `int` from the right end of the string, and fails otherwise.
Pat Tab
Constructs a pattern that matches forward to position \textit{int} in the source string. It can match 0 or more characters. It fails if it would have to move backwards or beyond the end of the string.

Pat R Tab
Constructs a pattern that matches up to position \textit{n} from the end of the string. It can match 0 or more characters. It fails if it would have to move backwards or beyond the end of the string.

Pat Test
Constructs a pattern that succeeds and matches the null string if \textit{expr} is not zero and fails otherwise.

Pat At
Constructs a pattern that matches the null string and stores the current position in the source string into the specified JSL variable (\textit{varName}). The assignment is immediate, and the variable can be used with \textit{expr()} to affect the remainder of the match.

Pat Rem
Constructs a pattern that matches the remainder of the string. It is equivalent to patRTab(0).

Pat Arb
Constructs a pattern that matches an arbitrary string. Initially it matches the null string. It matches one additional character each time the pattern matcher backs into it.

Pat Succeed
Constructs a pattern that always succeeds, even when the matcher backs into it. It matches the null string.

Pat Fail
Constructs a pattern that fails whenever the matcher attempts to move forward through it. The matcher backs up and tries different alternatives. If and when there are no alternatives left, the match fails and \textit{Pat Match} returns 0.

Pat Abort
Constructs a pattern that immediately cancels the pattern match. The matcher does not back up and retry any alternatives. Conditional assignments are not made. Immediate assignments that were already made are kept.
Pat Fence
Constructs a pattern that succeeds and matches the null string when the matcher moves forward through it, but fails when the matcher tries to back up through it. It is a one-way trap door that can be used to optimize some matches.

Pat Arb No
Constructs a pattern that matches zero or more copies of pattern.

Pat Repeat
Matches pattern between minimum and maximum times.

Pat Conditional
Saves the result of the pattern match, if it succeeds, to a variable named as the second argument (type) after the match is finished.

Pat Immediate
Saves the result of the pattern match to a variable named as the second argument (varName) immediately.

Pat Altern
Constructs a pattern that matches any one of the pattern arguments.

Pat Concat
Constructs a pattern that matches each pattern argument in turn.

Pat Regex
Constructs a pattern that matches the regular expression in the quoted string argument.

Pat Match
Pat Match executes a pattern match using the source in the first argument and the pattern in the second argument. The pattern must be constructed first, either inline or by assigning it to a JSL variable elsewhere. A third argument, if present, is the replacement text for the matched characters in the source argument (if the source argument is a variable). Pat Match returns true if the match succeeds. Additional arguments, in any order, are ANCHOR (match must begin at start of source), FULLSCAN (turn off some optimizations for special situations), and MATCHCASE (by default, A == a).

Pat Match returns true or false rather than a string, so Pat Match is somewhat difficult to use in a formula. You might find the Regex function (“Regex” on page 549) easier to use when you are adding pattern-matching formulas in the Formula Editor.
Regex Match

Regex Match is similar to Pat Match. Regex Match executes a pattern match using the source in the first argument and the pattern in the second argument. Regex Match uses a regular expression for the second argument and returns a list of information about the result of the match.

A simpler function, Regex (“Regex” on page 549), is also available. Regex returns a string value rather than a list, so Regex is usually easier to use in the Formula Editor than RegEx Match.

Comparison Functions

You can create a formula that compare the values of two arguments by using the comparison function. Each comparison relationship evaluates as true or false based on numeric magnitudes or character rankings. A true relationship evaluates as one, and false evaluates as zero.

Comparisons are useful when you include them in conditional expressions, but they can also stand alone as numeric expressions if neither term in comparison is missing. A relational symbol’s arguments can be any two expressions. However, both arguments in a comparison function must be of the same data type. Also note that:

- JMP displays an error if you use a single “=” in a conditional where “==” is expected.
- The Formula Editor uses the International Utilities package when comparing character strings. This package contains different rankings for each international character set and takes diacritical marks into consideration.
- You should not use comparison operators to specifically compare to a missing value. Instead, use the Is Missing function to detect a missing value.

See the JSL Functions chapter in the JSL Syntax Reference for details about syntax.

- Less than
- Greater than
- Less than or equal to
- Greater than or equal to
- Equal to
- Not equal to

\( a < b \leq c \) \quad b \text{ is greater than } a \text{ and less than or equal to } c

\( a \leq b < c \) \quad b \text{ is greater than or equal to } a \text{ and less than } c

Is Missing \quad \text{Returns a one (1) if the value of the argument for the current row is missing, and a zero if the value is not missing.}
Conditional Functions

You can include conditional expressions (called conditionals for short) in your formulas. These expressions let you build a sequence of clauses paired with result expressions. Constructing a sequence of clauses is the way you conditionally assign values to cells in a calculated column. Conditionals follow these rules:

- When no clause is true, the Formula Editor evaluates the result expression that accompanies the else clause.
- All result expressions in a conditional expression must evaluate to the same data type.
- A missing term matches any data type.
- By definition, expressions that evaluate as zero are false.
- If an expression evaluates as missing, no clauses are executed and missing is returned. All other numeric expressions are true.

See the Building Blocks chapter in the Scripting Guide and the JSL Functions chapter in the JSL Syntax Reference for details about syntax.

Use the insert and delete clause buttons on the Formula Editor panel to expand the expression. For maximum efficiency, list the most frequently evaluated clause and result pairs first in the sequence.

Note: Interpolate, Step, For, and While are most often used in conjunction with other commands to build a JSL script. You can use the Formula Editor to create and execute a script in that column, but this is not recommended because of dependencies and ambiguities that can result. Most often, scripts are stored as .jsl files, and can be saved with a data table as a table property. For details about table properties, see “Table Panel” on page 37 in the “Get Started” chapter. For documentation of scripting commands, see the JSL Syntax Reference.

If

Shows a single If condition with a missing expression and a missing then clause. Highlight either expr or then clause and enter a value. For example, to calculate count as a percentage of total when total is not 0, enter the conditional expression (using columns called count and total) in Figure A.3.

Figure A.3 A Conditional Expression
To add a new condition to the if conditional, highlight then clause and click the insert button ( ) on the Formula Editor keypad. Initially, this changes the existing else condition to an expr clause. Click the insert button again to add an else clause. Highlighting then or else and repetitively clicking the insert button changes the else to expr or adds a new expr clause.

To delete a clause, select the then clause above it and press the delete key on your keyboard or click the delete button ( ) on the Formula Editor keypad.

By definition, expressions that evaluate as zero are false. If an expression evaluates as missing, no clauses are executed and missing is returned. All other numeric expressions are true.

Match

Compares an expression to a list of clauses and returns the value of the resulting expression for the first matching clause encountered. You provide the matching expression only once and then give a match value for each clause.

After you select Match in the Formula Editor, a list appears with two options:

- Select Add Match Arguments from Data, and clauses that correspond to all of the levels in your data are added automatically. Alternatively, hold down the Shift key, select Conditional, and then select Match. In Figure A.4, the example on the left shows clauses that were added automatically.
- Select Don’t Add so that you can add each clause individually. In Figure A.4, the example on the right shows an empty clause, which you fill with the missing expressions.

Figure A.4  Examples of Using the Match Function

automatically added Match arguments                     empty Match argument

In an automatically filled argument, you should highlight then clause, and then enter an expression. In an empty argument, you highlight either expr, value, or then clause, and then enter an expression. (Or, if you highlight an expression and click Match, the Formula Editor creates a new Match conditional, with the original highlighted expression as expr and nothing for the value and else clause.) Also, keep in mind that:

- Match evaluates faster and uses less memory than an equivalent If because the variable is evaluated only once for each row in the data table. The If condition must evaluate the variable at each If clause for each row until a clause evaluates as true. See “Comparison Functions” on page 554, for a comparison of Match and If conditionals.
• With **If** and **Match**, the Formula Editor searches down from the top of the sequence for the first true clause and evaluates the corresponding result expression. Subsequent true clauses are ignored.

In the following example, each value is assigned depending on the value of the `age` variable.

**Figure A.5** An Example of Using the Match Function

![Match function example](image)

**Note:** **Match** ignores trailing spaces and **If** does not.

Although **Match** returns missing for any missing values, you can also specifically match missing values.

**Choose**

**Choose** is a special case of **Match** in which the arguments of the condition are a sequence of integers starting at one. The value of `clause` replaces the match condition. An example of a **Choose** condition is shown in Figure A.6. With **Choose**, the Formula Editor goes directly to the correct choice clause and evaluates the result expression.

**Figure A.6** Example of a **Choose** Condition

![Choose function example](image)

When you highlight an expression and click **Choose**, the Formula Editor creates a new conditional expression with one `clause`. Use the insert (✓) and delete (✗) buttons on the keypad to add new clauses or remove unwanted clauses, as described previously for the **If** conditional.

**Choose** evaluates the **Choose** expression and goes immediately to the corresponding result expression to generate the returned value. With **Choose**, you provide a choosing expression that yields sequential integers starting at 1 only once, and then you give a choice for each integer in the sequence.
IfMax
Evaluates the first of each pair of arguments and returns the evaluation of the result expression (the second of each pair) associated with the maximum of the expressions. If more than one expression is the maximum, the first maximum is returned. If all expressions are missing and a final result is not specified, missing is returned. If all expressions are missing and a final result is specified, that final result is returned. The test expressions must evaluate to numeric values, but the result expressions can be anything.

IfMin
Evaluates the first of each pair of arguments and returns the evaluation of the result expression (the second of each pair) associated with the minimum of the expressions. If more than one expression is the minimum, the first minimum is returned. If all expressions are missing and a final result is not specified, missing is returned. If all expressions are missing and a final result is specified, that final result is returned. The test expressions must evaluate to numeric values, but the result expressions can be anything.

And &
Evaluates as 1 when both of its arguments are true. Otherwise, it evaluates as 0. (See Figure A.9.) The formula in Figure A.7 labels Group 1 as drivers only if both comparisons are true.

Figure A.7 Creating an And Function
```
If(sex == "M" & age > 13, "Group 1", "Group 2")
```

Or |
Evaluates as 1 when either of its arguments is true. If both of its arguments are false, then the Or expression evaluates as 0. (See Figure A.9.) The formula in Figure A.8 assigns males and all participants who are more than 13 years old to Group 1.

Figure A.8 Creating an Or Function
```
If(sex == "M" | age > 13, "Group 1", "Group 2")
```

The truth tables on the left in Figure A.9 illustrate the results of the And (&) and Or (|) functions when both arguments have nonmissing values that evaluate to true or false. The table on the right illustrates the result when either the left or right expression (call them a and b) or both have missing values.
**Figure A.9** Evaluations of And and Or Expressions

<table>
<thead>
<tr>
<th></th>
<th>True</th>
<th>False</th>
</tr>
</thead>
<tbody>
<tr>
<td>And</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>True</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>False</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Or</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>True</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>False</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>

**Not !**

Evaluates as 1 when its argument is false. Otherwise, **Not** evaluates as 0. When you apply the **Not** function, use parentheses where necessary to avoid ambiguity. For example, (! (weight==64)) can be either true or false (either 1 or 0), but (! weight)==64 is always false (0) because **Not** can return only 0 or 1. Expressions such as ! (weight==64) can also be entered as weight != 64.

**Interpolate**

Linearly interpolates the $y$-value between two points, $x_1$, $y_1$ and $x_2$, $y_2$ that corresponds to the arguments that you give. You can insert additional pairs of $x$, $y$ arguments with the insert key. **Interpolate** finds the pair of $x$, $y$ points that correspond to the $x$-value and completes the interpolation.

**Figure A.10** Examples of Interpolate

**Step**

Step is like **Interpolate** except that it returns the $y$-value corresponding to the greatest $x$-value less than or equal to the $x$ and $y$ arguments. That is, it finds the corresponding $y$ for a given $x$ from a step function rather than a linear fit between points. Like **Interpolate**, you can have as many $x$ and $y$ argument pairs as you want.

**Figure A.11** Examples of Step
For
Repeats the statements in the body argument as long as the while condition is true. The init and next control the iterations.

While
Repeatedly tests the expr condition and executes the body until expr is no longer true.

Break, Continue
Break stops execution of a loop completely and continues to the statement following the loop. Continue ends the current iteration of a loop and begins the loop at the next iteration.
Both are used in For, While, and For Each Row loops.

Stop
Immediately stops a script that is running.

Probability Functions

You can create a formula that calculates probabilities and quantiles for statistical distributions like beta, Chi-square, F, gamma, normal, Student’s t, Weibull distributions, Tukey HSD, and so on. See the JSL Functions chapter in the JSL Syntax Reference for details about syntax.

Normal Density
Accepts an argument from the range of values for the standard normal distribution, which is all real numbers. It returns the value of the standard normal probability density function (pdf) for the argument. For example, you can create a column of values (X) with the formula count(-3, 3, nrow()). In a second column, insert the formula Normal Density(X) to generate density values. Then select Graph > Graph Builder to plot the normal density by X.

Normal Distribution
Accepts an argument x from the range of values for the standard normal distribution, which is all real numbers. It returns the probability that an observation from the standard normal distribution is less than or equal to x. For example, the expression Normal Distribution(1.96) returns 0.975, the probability that an observation from the standard normal distribution is less than or equal to the 1.96th quantile. Also, you can specify mean and standard deviation parameters to obtain probabilities from nonstandard normal distributions. The Normal Distribution function is the inverse of the Normal Quantile function.
Normal Quantile (Probit)

Accepts a probability argument \( p \), and returns the \( p^{th} \) quantile from the standard normal distribution. For example, the expression **Normal Quantile(0.975)** returns the 97.5\% quantile from the standard normal distribution, which evaluates as 1.96. Also, you can specify parameter values for the mean and standard deviation to obtain quantiles from nonstandard normal distributions. The **Normal Quantile** function is the inverse of the **Normal Distribution** function.

Beta Density

Requires three arguments: quantile argument and the shape parameters alpha and beta. A threshold parameter (\( \theta \)) and a scale parameter (\( \sigma > 0 \)) are additional arguments. It returns the value of the beta probability density function (pdf) for the given arguments. The beta density is useful for modeling the probabilistic behavior of random variables such as proportions constrained to fall in the interval \([0, 1]\).

Beta Distribution

The beta distribution has two shape parameters: \( \alpha > 0 \) and \( \beta > 0 \). A threshold parameter (\( \theta \)) and a scale parameter (\( \sigma \)) are additional arguments, where \( \theta \leq x \leq \theta + \sigma \). The default value for \( \theta \) is 0. The default value for \( \sigma \) is 1.

The beta distribution function is the inverse of the beta quantile function.

Beta Quantile

Accepts a probability argument, \( p \), and shape and scale parameters, \( \alpha > 0 \) and \( \beta > 0 \). It returns the \( p^{th} \) quantile from the standard beta distribution. The beta quantile function is the inverse of the beta distribution function.

Cauchy Density

Accepts an argument \( x \), which can be any real number, and optional arguments *center* and *scale*. If you do not specify values for the optional arguments, the function returns the value at \( x \) of the Cauchy probability density function (pdf) for a distribution with median 0 and third quartile 1.

If you specify values for center and scale, the function returns the value at \( x \) of the Cauchy probability function, characterized as follows:

- The optional parameter *center* is the median of the distribution.
- The optional parameter *scale* is half of the interquartile range, namely, half of the difference between the 0.75 and 0.25 quantiles.
Cauchy Distribution

Accepts an argument $x$, which can be any real number, and optional arguments $center$ and $scale$. If you do not specify values for the optional arguments, the function returns the value at $x$ of the Cauchy cumulative distribution function (cdf) for a distribution with median 0 and third quartile 1. If you specify values for center and scale, the function returns the value at $x$ of the cumulative distribution function for the Cauchy distribution with median given by center and interquartile range given by twice the scale.

Cauchy Quantile

Accepts an argument $prob$, which can be any number between 0 and 1, and optional arguments $center$ and $scale$. If you do not specify values for the optional arguments, the function returns the $p$th quantile, where $p = prob$, of a Cauchy distribution with median 0 and third quartile 1. If you specify values for center and scale, the function returns the $p$th quantile of a Cauchy distribution with median given by center and interquartile range given by twice the scale.

ChiSquare Density

Accepts a quantile argument from the range of values for the Chi-squared distribution, a degrees of freedom argument, and an optional noncentrality parameter. It returns the value of the Chi-squared density function (pdf) for the arguments.

ChiSquare Distribution

Accepts a response argument (range of $x$ values) and three parameter arguments: a quantile, a degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the Chi-squared distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression `ChiSquare Distribution(11.264, 5)` returns the probability that an observation from the Chi-squared distribution centered at 0 with 5 degrees of freedom is less than or equal to 11.264. The expression evaluates as 0.95361.

Furthermore, the `ChiSquare Distribution` function accepts integer and noninteger degrees of freedom. It is centered at 0 by default. The `ChiSquare Distribution` function is the inverse of the `ChiSquare Quantile` function.

ChiSquare Log CDistribution

Returns 1 -log (value) of the Chi-square distribution.

ChiSquare Log Density

Returns the log of the value of the Chi-square probability density.
ChiSquare Log Distribution

Returns the log of the value of the Chi-square distribution.

ChiSquare Noncentrality

Returns the noncentrality parameter \( nc \) such that probability is equal to the probability that a Chi-square distributed random variable with \( df \) degrees of freedom is less than \( x \).

ChiSquare Quantile

Returns the quantile from a Chi-square distribution, the value for which the probability is \( p \) that a random value would be lower.

ChiSquare Quantile

Accepts three arguments: a probability \( p \), a degrees of freedom, and a noncentrality parameter. It returns the \( p \)th quantile from the Chi-squared distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression \( \text{ChiSquare Quantile}(0.95, 3.5, 4.5) \) returns the 95% quantile from the Chi-squared distribution centered at 4.5 with 3.5 degrees of freedom. The expression evaluates as 17.50458.

The \( \text{ChiSquare Quantile} \) function accepts integer and noninteger degrees of freedom. It is centered at 0 by default. The \( \text{ChiSquare Quantile} \) function is the inverse of the \( \text{ChiSquare Distribution} \) function.

Dunnett P Value

Returns the \( p \)-value from Dunnett’s multiple comparison test.

Dunnett Quantile

Returns the quantile needed in Dunnett’s multiple comparison tests.

F Density

Accepts a quantile argument from the range of values for the \( F \)-distribution, numerator and denominator degrees of freedom arguments, and an optional noncentrality parameter. It returns the value of the \( F \)-density function (pdf) for the arguments.

F Distribution

Accepts four arguments: a quantile, a numerator and denominator degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the \( F \)-distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression \( \text{F Distribution}(3.32, 2, 3) \) returns the probability that an observation from the central \( F \)-distribution with 2 degrees of freedom in the numerator
and 3 degrees of freedom in the denominator is less than or equal to 3.32. The expression evaluates as 0.82639.

The $F$-distribution function accepts integer and noninteger degrees of freedom. By default, the non-central parameter is set to 0. The $F$-distribution function is the inverse of the $F$ Quantile function.

**F Log CDistribution**

Returns the log of 1 - $F$-distribution.

**F Log Density**

Returns the log of the $F$ probability density.

**F Log Distribution**

Returns the log of the $F$-distribution.

**F Noncentrality**

Solves the noncentrality such that prob=$f$-distribution (x, ndf, ddf, nc).

**F Power and F Sample Size**

The $F$ Power function calculates the power from a given situation that involves an $F$-test or $t$-test, and the $F$ Sample Size function computes the sample size. The arguments are the values that you specify for computation of a prospective power analysis. (These functions perform the same computations as if you selected DOE > Sample Size and Power. See the Prospective Power and Sample Size chapter in the Design of Experiments Guide for a discussion of power and sample size.) The arguments include:

- **alpha** The significance level that you are willing to tolerate (often 0.05).
- **dfh** The hypothesis degrees of freedom. It is one (1) for a $t$-test.
- **dfm** The model degrees of freedom (such that $dfe = n – dfm$).
- **SquaredSize** The squared effect size scaled by the error variance, which is used for making the noncentrality argument for the $F$-distribution. For this argument, use squared size = $\Delta^2/\sigma^2$ where $\sigma^2$ is the error variance. That is, use:

$$\Delta^2 = (x - \mu)^2$$ for a one-sample $t$-test

$$\Delta^2 = \frac{(x_1 - x_2)^2}{4}$$ for a two-sample $t$-test
Using JMP Probability Functions

• n (found only in the F Power function) The total number of observations (runs, experimental units, or samples) you expect to have. Power (in the F Sample Size function) is the probability that you want to have of declaring a significant result.

F Quantile

Accepts four arguments: a probability p, a numerator and denominator degrees of freedom, and a noncentrality parameter. It returns the pth quantile from the F-distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression F Quantile(0.95, 2, 10, 0) returns the 95% quantile from the F-distribution centered at 0 with 2 degrees of freedom in the numerator and 10 degrees of freedom in the denominator. The expression evaluates as 4.1028.

The F Quantile function accepts integer and noninteger degrees of freedom. By default, the non-central parameter is set to 0. The F Quantile function is the inverse of the F Distribution function.

Frechet Density

Returns the density at x of a Fréchet distribution with location mu and scale sigma.

Frechet Distribution

Returns the probability that a Fréchet distribution with location mu and scale sigma is less than x.

Frechet Quantile

Returns the quantile associated with a cumulative probability p for a Fréchet distribution with location mu and scale sigma.

Gamma Density

Requires a quantile argument. Also accepts an optional alpha shape parameter, which must be greater than zero and defaults to 1. A scale parameter b, which must be greater than zero and defaults to 1, is optional. A threshold parameter, which must be in the range \(-\infty < \theta < +\infty\) and defaults to zero, is optional.

Figure A.12 shows the shape of gamma probability density functions for shape parameters of 1, 3, and 5. The standard gamma density function is strictly decreasing when \(\alpha (shape) \leq 1\). When \(\alpha > 1\) the density function begins at zero when \(x = \theta\), increases to a maximum, and then decreases.
Formula Functions Reference
Probability Functions

Figure A.12 Gamma Density Example

Gamma Distribution
Is based on the standard gamma function, and accepts a single argument with a quantile value. The shape, scale, and threshold parameters are optional, with defaults as described previously in the discussion of the Gamma Density function. It returns the probability that an observation from a standard gamma distribution is less than or equal to the specified \( x \). The Gamma Distribution function is the inverse of Gamma Quantile function.

Gamma Log CDistribution
Returns the log of 1 - Gamma distribution.

Gamma Log Density
Returns the log of the Gamma probability density.

Gamma Log Distribution
Returns the log of the Gamma distribution.
**Gamma Quantile**

Accepts a probability argument \( p \), and returns the \( p^{th} \) quantile from the standard gamma distribution with the shape parameter that you specify. The **Gamma Quantile** function is the inverse of the **Gamma Distribution** function.

**GenGamma Density**

Returns the density at \( x \) of a GenGamma probability distribution with parameters \( \mu \), \( \sigma \), and \( \lambda \).

**GenGamma Distribution**

Returns the probability that a GenGamma distributed random variable (with parameters \( \mu \), \( \sigma \), and \( \lambda \)) is less than \( x \).

**GenGamma Quantile**

Returns the quantile from a GenGamma distribution, the value for which the probability is \( p \) that a random value would be lower. \( \mu \), \( \sigma \), and \( \lambda \) are parameters, respectively.

**GLog Density**

Returns the density or pdf at a particular quantile \( q \) of a generalized logarithm distribution with location \( \mu \), scale \( \sigma \), and shape \( \lambda \). When the shape parameter is equal to zero, the distribution reduces to a Lognormal(\( \mu \), \( \sigma \)).

**GLog Distribution**

Returns the probability or cdf that a generalized logarithm distributed random variable is less than \( q \). When the shape parameter is equal to zero, the distribution reduces to a Lognormal(\( \mu \), \( \sigma \)).

**GLog Quantile**

Returns the quantile, the value for which the probability is \( p \) that a random value would be lower. When the shape parameter is equal to zero, the distribution reduces to a Lognormal(\( \mu \), \( \sigma \)).

**Johnson Sb Distribution**

Returns the probability that a Johnson Sb-distributed random variable is less than \( x \). There are four optional arguments: \( \gamma \), \( \delta \), \( \theta \), and \( \sigma \). For a description of the Johnson Sb distribution and these parameters, see the JSL Functions chapter in the **JSL Syntax Reference** book.
Johnson Sb Quantile

Returns the \( p \)th quantile of the Johnson Sb distribution. There are four optional arguments: \( \gamma \), \( \delta \), \( \theta \), and \( \sigma \). For a description of the Johnson Sb distribution and these parameters, see the JSL Functions chapter in the *JSL Syntax Reference* book.

Johnson Sb Density

Returns the density at \( x \) of a Johnson Sb distribution. There are four optional arguments: \( \gamma \), \( \delta \), \( \theta \), and \( \sigma \). For a description of the Johnson Sb distribution and these parameters, see the JSL Functions chapter in the *JSL Syntax Reference* book.

Johnson Sl Distribution

Returns the probability that a Johnson Sl-distributed random variable is less than \( x \). There are four optional arguments: \( \gamma \), \( \delta \), \( \theta \), and \( \sigma \). For a description of the Johnson Sl distribution and these parameters, see the JSL Functions chapter in the *JSL Syntax Reference* book.

Johnson Sl Quantile

Returns the \( p \)th quantile of the Johnson Sl distribution. There are four optional arguments: \( \gamma \), \( \delta \), \( \theta \), and \( \sigma \). For a description of the Johnson Sl distribution and these parameters, see the JSL Functions chapter in the *JSL Syntax Reference* book.

Johnson Sl Density

Returns the density at \( x \) of a Johnson Sl distribution. There are four optional arguments: \( \gamma \), \( \delta \), \( \theta \), and \( \sigma \). For a description of the Johnson Sl distribution and these parameters, see the JSL Functions chapter in the *JSL Syntax Reference* book.

Johnson Su Distribution

Returns the probability that a Johnson Su-distributed random variable is less than \( x \). There are four optional arguments: \( \gamma \), \( \delta \), \( \theta \), and \( \sigma \). For a description of the Johnson Su distribution and these parameters, see the JSL Functions chapter in the *JSL Syntax Reference* book.

Johnson Su Quantile

Returns the \( p \)th quantile of the Johnson Su distribution. There are four optional arguments: \( \gamma \), \( \delta \), \( \theta \), and \( \sigma \). For a description of the Johnson Su distribution and these parameters, see the JSL Functions chapter in the *JSL Syntax Reference* book.
Johnson Su Density
Returns the density at $x$ of a Johnson Su distribution. There are four optional arguments: $gamma$, $delta$, $theta$, and $sigma$. For a description of the Johnson Su distribution and these parameters, see the JSL Functions chapter in the JSL Syntax Reference book.

LEV Density
Returns the density at $x$ of the largest extreme value distribution with location $mu$ and scale $sigma$.

LEV Distribution
Returns the probability that the largest extreme value distribution with location $mu$ and scale $sigma$ is less than $x$.

LEV Quantile
Returns the quantile associated with a cumulative probability $p$ of the largest extreme value distribution with location $mu$ and scale $sigma$.

LogGenGamma Density
Returns the density at $x$ of a LogGenGamma probability distribution with parameters $mu$, $sigma$, and $lambda$.

LogGenGamma Distribution
Returns the probability that a LogGenGamma distributed random variable (with parameters $mu$, $sigma$, and $lambda$) is less than $x$.

LogGenGammaQuantile
Returns the quantile from a LogGenGamma distribution, the value for which the probability is $p$ that a random value would be lower. $mu$, $sigma$, and $lambda$ are parameters, respectively.

Logistic Density
Returns the density at $x$ of a logistic distribution with location $mu$ and scale $sigma$.

Logistic Distribution
Returns the probability that the logistic distribution with location $mu$ and scale $sigma$ is less than $x$.

Logistic Quantile
Returns the quantile associated with a cumulative probability $p$ of the logistic distribution with location $mu$ and scale $sigma$. 
Loglogistic Density
Returns the density at \( x \) of the loglogistic distribution with location \( \mu \) and scale \( \sigma \).

Loglogistic Distribution
Returns the probability that the loglogistic distribution with location \( \mu \) and scale \( \sigma \) is less than \( x \).

Loglogistic Quantile
Returns the quantile associated with a cumulative probability \( p \) of the loglogistic distribution with location \( \mu \) and scale \( \sigma \).

Lognormal Density
Returns the density at \( x \) of the lognormal distribution with location \( \mu \) and scale \( \sigma \).

Lognormal Distribution
Returns the probability that the lognormal distribution with location \( \mu \) and scale \( \sigma \) is less than \( x \).

Lognormal Quantile
Returns the quantile associated with a cumulative probability \( p \) of a lognormal distribution with location \( \mu \) and scale \( \sigma \).

Normal Biv Distribution
Computes the probability that an observation is less than or equal to \((x, y)\) with correlation coefficient \( r \) where the observation is marginally normally distributed. You can specify the mean and standard deviation for the X and Y coordinates of the observation. The default values are 0 for both means and 1 for both standard deviations.

Normal Log CDistribution
Returns the log of 1 - Normal distribution.

Normal Log Density
Returns the log of the Normal probability density.

Normal Log Distribution
Returns the log of the Normal distribution.
Normal Mixture Density

Returns the density at $q$ of a normal mixture distribution with group means $mean$, group standard deviations $stdev$, and group probabilities $probability$. The $mean$, $stdev$, and $probability$ arguments are all vectors of the same size.

Normal Mixture Distribution

Returns the probability that a normal mixture distributed variable with group means $mean$, group standard deviations $stdev$, and group probabilities $probability$ is less than $q$. The $mean$, $stdev$, and $probability$ arguments are all vectors of the same size.

Normal Mixture Quantile

Returns the quantile, the values for which the probability is $p$ that a random value would be lower. The $mean$, $stdev$, and $probability$ arguments are all vectors of the same size.

SEV Density

Returns the density at $x$ of the smallest extreme distribution with location $mu$ and scale $sigma$.

SEV Distribution

Returns the probability that the smallest extreme distribution with location $mu$ and scale $sigma$ is less than $x$.

SEV Quantile

Returns the quantile associated with a cumulative probability $p$ of the smallest extreme distribution with location $mu$ and scale $sigma$.

t Density

Accepts a quantile argument from the range of values for the $t$-distribution, a degrees of freedom argument, and an optional noncentrality parameter. It returns the value of the $t$-density function (pdf) for the arguments. To compare a $t$-density with 5 df with a standard normal distribution, you can create a column of quantile values ($X$) with the formula $count(-3, 3, nrow())$. In a second column, insert the formula $t \text{ Density}(X, 5)$. In a third column, insert the formula $Normal \text{ Density}(X)$. Then select Graph > Graph Builder to plot the $t$-density and the normal density by $X$. You will see that the $t$-density has slightly more spread than the normal.

t Distribution

Accepts three arguments: a quantile, a degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the Student’s $t$-distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression $t \text{ Distribution}(.9, 5)$ returns the probability that an observation from the Student’s $t$-distribution centered at 0 with 5 degrees of freedom is less than or equal to 0.9.
The expression is evaluated as 0.79531. \( t \)-distribution accepts integer and noninteger degrees of freedom. It is centered at 0 by default, but you can enter a value for the noncentrality parameter. The \( t \text{ Quantile} \) function is the inverse of the \( t \text{ Distribution} \) function.

**t Log CDistribution**

Returns 1 - \( \log \) (value) of the normal distribution function at quantile \( x \) for the \( t \) distribution.

**t Log Density**

Returns the log of the value of the density function at quantile \( x \) for the \( t \) distribution.

**t Log Distribution**

Returns the log of the value of the distribution function at quantile \( x \) for the \( t \) distribution.

**t Log Noncentrality**

Solves the noncentrality such that \( \text{prob} = T \text{ Distribution}(x, df, nc) \).

**t Quantile**

Accepts three arguments: a probability \( p \), a degrees of freedom, and a noncentrality parameter. It returns the \( p^{th} \) quantile from the Student’s \( t \)-distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression \( \text{Student’s t Quantile}(.95, 2.5) \) returns the 95% quantile from the Student’s \( t \)-distribution centered at 0 with 2.5 degrees of freedom. The expression evaluates as 2.558219. The \( t \text{ Quantile} \) function is the inverse of the \( t \text{ Distribution} \) function. This function also accepts integer and noninteger degrees of freedom. It is centered at 0 by default, but you have the option to enter a value for the noncentrality parameter. The \( t \text{ Distribution} \) function is the inverse of the \( t \text{ Quantile} \) function.

**Tukey HSD Quantile**

Accepts a probability argument 1-\( \alpha \), and returns the 1-\( \alpha \)th quantile from Tukey’s HSD test for the parameters that you specify. The \( \alpha \) argument is the significance level that you want. \( nGroups \) is the number of groups in a study. \( dfe \) is the error degrees of freedom (based on the total study sample). This is the quantile used to calculate least significant difference in Tukey’s multiple comparisons test.

**Tukey HSD P Quantile**

Returns the \( p \)-value from Tukey’s HSD multiple comparisons test.

**Weibull Density**

Accepts a quantile argument from the range of values for the Weibull distribution, and optional shape, scale, and threshold arguments. The density function for a Weibull distribution with shape parameter \( \beta \), scale parameter \( \alpha \), and threshold parameter \( \theta \) is given in
the Distributions chapter in the *Basic Analysis* book. The Weibull Density function returns the value of the probability density function (pdf) for the corresponding Weibull distribution.

**Weibull Distribution**

Accepts a quantile argument \( x \) from the range of values for the Weibull distribution, and optional shape, scale, and threshold arguments. The distribution function for a Weibull distribution with shape parameter \( \beta \), scale parameter \( \alpha \), and threshold parameter \( \theta \) is given in the *Basic Analysis* book. The Weibull Distribution function returns the probability that an observation is less than or equal to the specified \( x \) for the Weibull distribution with the shape, scale, and threshold parameters that you specified. The **Weibull Distribution** function is the inverse of **Weibull Quantile** function.

The Weibull distribution has different shapes depending on the values of \( \alpha \) (a scale parameter that affects the \( x \) direction) and \( \beta \) (a shape parameter). It often provides a good model for estimating the length of life, especially for mechanical devices and in biology. The two-parameter Weibull is the same as the three-parameter Weibull with a threshold of zero.

**Weibull Quantile**

Accepts a probability argument \( p \), and returns the \( p^{th} \) quantile from the Weibull distribution with the shape, scale, and threshold parameters that you specify. The **Weibull Quantile** function is the inverse of the **Weibull Distribution** function.

---

**Discrete Probability Functions**

**Gamma Poisson Probability**

Returns the probability or pmf that a gamma-Poisson distributed random variable is equal to \( x \). In general, the gamma Poisson functions accept arguments that are the mean parameter \( \lambda \), the overdispersion parameter \( \sigma \), and the count of interest \( x \). When the overdispersion is equal to one, the Gamma Poisson reduces to a Poisson(\( \lambda \)) distribution.

**Gamma Poisson Distribution**

Returns the probability that a gamma-Poisson distributed random variable is less than or equal to \( x \). In general, the gamma Poisson functions accept arguments that are the mean parameter \( \lambda \), the overdispersion parameter \( \sigma \), and the count of interest \( x \).

**Gamma Poisson Quantile**

Returns the smallest integer quantile for which the cumulative probability of the Gamma Poisson (\( \lambda, \sigma \)) distribution is larger than or equal to \( p \).
Binomial Distribution

Returns the probability that an observation from a binomial distribution with parameters \( p \) and \( n \) is less than or equal to \( k \). In general, the binomial functions accept arguments that are the probability of success \( p \) (the event of interest), the number of trials \( n \), and the number of successes \( k \).

Binomial Probability

Computes the probability that a random variable from a binomial distribution is equal to \( k \). In general, the binomial functions accept arguments that are the probability of success \( p \) (the event of interest), the number of trials \( n \), and the number of successes \( k \).

Binomial Quantile

Returns the smallest integer quantile for which the cumulative probability of the Binomial \((p, n)\) distribution is larger than or equal to the specified probability.

Neg Binomial Distribution

Returns the probability that a negative binomially distributed random variable is less than or equal to \( k \), where the probability of success is \( p \), and the number of successes is \( n \).

Neg Binomial Probability

Returns the probability that a negative binomially distributed random variable is equal to \( k \), where the probability of success is \( p \), and the number of successes is \( n \).

Beta Binomial Distribution

Returns the probability or pmf that a beta binomially distributed random variable is less than or equal to \( x \). In general, the beta binomial functions accept arguments that are the probability of success \( p \) (the event of interest), the overdispersion parameter \( \delta \), and the number of trials \( n \). When the overdispersion parameter for the beta binomial is zero, the distribution reduces to a binomial\((p, n)\).

Beta Binomial Probability

Returns the probability or cmf that a beta binomially distributed random variable is equal to \( x \). When the overdispersion parameter for the beta binomial is zero, the distribution reduces to a binomial\((p, n)\).

Beta Binomial Quantile

Returns the smallest integer quantile for which the cumulative probability of the Beta Binomial \((p, n, \delta)\) distribution is larger than or equal to the specified probability. When the overdispersion parameter for the beta binomial is zero, the distribution reduces to a binomial \((p, n)\).
Appendix A

Using JMP

Statistical Functions Reference

Statistical Functions

There are two types of Statistical functions you can use in a formula:

- The functions with names that have the prefix Col. These functions compute statistics for a column of numbers or expressions involving columns.
- The Mean, Std Dev, Number, Sum, Quantile, Maximum, Minimum, and N Missing functions. These functions evaluate across columns or arguments. The statistic is computed for each row across the series of arguments. You can use the insert key (⌘) on the on-screen keypad, or type a comma to add arguments to the functions that accept multiple arguments. When there are multiple contiguous arguments, select the function and the first argument, and then Shift-click the last argument in the group. These functions then automatically show with the complete list.

See the JSL Functions chapter in the JSL Syntax Reference for details about syntax.

Hypergeometric Distribution

Computes the probability that a random variable from a hypergeometric distribution is less than or equal to \( x \). The hypergeometric distribution models the total number of successes in a fixed sample drawn without replacement from a finite population. The hypergeometric functions accept as arguments the size of the population \( N \), the total number of items with the desired characteristic in the population, \( K \), the number of samples drawn \( n \), and the number of successes in the sample \( x \).

Hypergeometric Probability

Computes the probability that a random variable from a hypergeometric distribution is equal to \( x \).

Poisson Distribution

Computes the probability that a random variable from a Poisson distribution with mean lambda is less than or equal to the count of interest. In general, Poisson functions accept an argument that is the count of interest, and lambda, the mean parameter.

Poisson Probability

Computes the probability that a random variable from a Poisson distribution with mean lambda is equal to the count of interest.

Poisson Quantile

Returns the smallest integer quantile for which the cumulative probability of the Poisson (lambda) distribution is larger than or equal to \( p \).
Col Mean

Calculates the mean (or arithmetic average) of the numeric values identified by its argument. The formula \texttt{Col Mean(age)} calculates the average of all nonmissing values in the \texttt{age} column.

Col Moving Average

Returns the moving average over a given interval based at the current row. Missing values are ignored. Also called Moving Average.

Col Std Dev

Measures the spread around the mean of the distribution identified by its argument. In the normal distribution, about 68% of the distribution is within one standard deviation of the mean. 95% of the distribution is within two standard deviations of the mean. 99% of the distribution is within three standard deviations of the mean.

Col Number

Counts the number of nonmissing values in the column that you specify. A missing numeric value occurs when a cell has no assigned value or is the result of an invalid operation (such as division by zero). Missing values show on the spreadsheet as a missing value mark (•). Missing character values are null character strings. In formulas for row state columns, an excluded row state characteristic is treated as a missing value.

Col N Missing

Counts the number of missing values in the column that you specify. A missing numeric value occurs when a cell has no assigned value or is the result of an invalid operation (such as division by zero). Missing values show in the data grid with a missing value character (•). Missing character values are null character strings.

Col Sum

Computes the sum of the values in its numeric argument. Missing values are ignored.

Col Minimum and Col Maximum

Takes the minimum of its numeric arguments. \texttt{Col Minimum} ignores missing values. \texttt{Col Maximum} takes the maximum of a numeric column argument and ignores missing values.

Col Quantile

Computes the value at which a specific percentage of the values is less than or equal to that value. For example, the value calculated as the 50% quantile, also called the median, is greater than or equal to 50% of the data. Half of the data values are less than the 50\textsuperscript{th} quantile.
The **Col Quantile** function’s quantile argument represents the quantile percentage divided by 100. The 25% quantile, also called the lower quartile, corresponds to \( p = 0.25 \), and the 75% quantile, called the upper quartile, corresponds to \( p = 0.75 \).

The Formula Editor computes a quantile for a column of \( n \) nonmissing values by arranging the values in ascending order. The subscripts of the sorted column values, \( y_1, y_2, \ldots, y_n \), represent the ranks in ascending order.

The \( p \)th quantile value is calculated using the formula \( p(n + 1) \), where \( p \) is the percent value and \( n \) is the total number of nonmissing values. If \( p(n+1) \) is an integer, then the quantile value is \( y_{p(n+1)} \). If \( p(n + 1) \) is not an integer, then the value is interpolated by assigning the integer part of the result to \( i \), assigning the fractional part to \( f \), and applying the formula \( (1 – f)y_i + (f)y_{i+1} \).

For example, suppose a column has values 2, 4, 6, 8, 10, 12, 14, 16, 18, and 20. The 50% quantile is calculated as \( 0.5(10 + 1) = 5.5 \).

Because the result is fractional, the 50% quantile value is interpolated as

\[
(1 – 0.5) \times 10 + (0.5) \times 12 = (0.5)10 + (0.5)12 = 6 + 5 = 11
\]

The following are example **ColQuantile** formulas:

- **ColQuantile(age, 1)** Calculates the maximum age.
- **ColQuantile(age, 0.75)** Calculates the upper quartile age.
- **ColQuantile(age, 0.5)** Calculates the median age.
- **ColQuantile(age, 0.25)** Calculates the lower quartile age.
- **ColQuantile(age, 0)** Calculates the minimum age.

The **ColQuantile** argument can be any expression that evaluates to a value between (and including) 0 and 1. For example, the first formula in Figure A.13 calculates quantile values of age in ascending order for each row. The column then contains the interpolated values of age in ascending order in the calculated column. The second formula lists the interpolated values of age in descending order.

**Figure A.13** Examples of the Quantile Function

<table>
<thead>
<tr>
<th>Col Quantile</th>
<th>Col Quantile</th>
</tr>
</thead>
<tbody>
<tr>
<td>( age, \frac{\text{Row}(i) - 1}{\text{N Row}()} )</td>
<td>( age, \frac{\text{N Row}() - \text{Row}(i) - 1}{\text{N Row}()} )</td>
</tr>
</tbody>
</table>

**Col Rank**

Ranks each row’s value, from 1 for the lowest value to the number of non-missing columns for the highest value. Ties can be broken by reporting the average of the possible rankings, assigning the ranks in the order that they originally appear, giving both values the lowest possible rank, or arbitrarily. (JMP 12 used arbitrary tie breaking.) Distribution’s Normal Quantile output uses average tie breaking.
Col Standardize

Performs the usual standardization on its numeric expression. For each row \( i \),
\[ \text{Col Standardize(\text{height})} = \frac{(\text{HeightRow()–Col Mean(Height)})}{\text{Col Std Dev(Height)}}. \]

Mean

Calculates the arithmetic average of the nonmissing arguments that you specify. The arguments can be constants, numbers, or expressions. The \text{Mean} function initially shows with a single argument. You add arguments with the insert button (\( \text{\textbf{\textcircled{+}}} \)) on the Formula Editor keypad or by typing a comma.

Std Dev

Computes standard deviation of the list of arguments that you specify. The arguments can be constants, numbers, or expressions. The \text{Std Dev} function initially shows with a single argument. You add arguments by clicking the insert button (\( \text{\textbf{\textcircled{+}}} \)) on the Formula Editor keypad or by typing a comma.

Number

Counts the number of nonmissing values in the list of arguments that you specify.

Sum

Returns the sum of the arguments.

Quantile

Calculates the quantile given by its first argument for all the following arguments given.

Summation (\( \Sigma \))

Evaluates for an explicit range of values in a column, as given by the summation indices. This behavior is different from all other statistical functions (except \text{Product}), which \textit{always} evaluate on every row. The \text{Summation} function uses the summation notation shown in Figure A.14. To calculate a sum, replace the missing \textit{body} term with an expression containing the index variable \( i \), or an index variable that you assign. \text{Summation} repeatedly evaluates the expression for \( i = 1, \ i = 2, \) through \( i = \text{NRow()} \) and then adds the nonmissing results together to determine the final result.

You can replace \text{NRow()}, the number of rows in the active spreadsheet, and the index constant, \( i \), with any expression appropriate for your formula. For example, the summation formula in Figure A.14 computes the total for each row of all revenue values for rows 1 through the current row number, filling the calculated column with the cumulative totals of the revenue column.
Using JMP Statistical Functions

Figure A.14 Example of the Summation function

Product (Π)

Evaluates for an explicit range of values in a column, as given by the summation indices, as opposed to all other statistical functions (except Summation), which always evaluate on every row. Product uses the notation shown in the formula in Figure A.15. To calculate a product, replace the missing body term with an expression containing the index variable $j$. Product repeatedly evaluates the expression for $i = 1, i = 2$, through $i = n$ and multiplies the nonmissing results together to determine the final result.

You can replace NRow(), the number of rows in the active spreadsheet and the index constant, $i$, with any expression appropriate for your formula.

For example, the product example in Figure A.15 calculates $i!$ (each row number’s factorial).

Figure A.15 Examples of the Product Function

Minimum and Maximum

Return the minimum and maximum value, respectively, from the list of nonmissing arguments that you specify.

N Missing

Counts the number of missing values in the list of arguments that you specify.

Desirability

Are smooth piecewise functions that are crafted to fit the control points. The minimize and maximize functions are three-part piecewise smooth functions that have exponential tails and a cubic middle.

The target function is a piecewise function. It is a scale multiple of a normal density on either side of the target (with different curves on each side), which is also piecewise smooth and fit to the control points.
**Random Functions**

You can create formulas that generate real numbers by effectively “rolling the dice” within the constraints of the specified distribution. Each time you click **Apply** in the Formula Editor window, these functions produce a new set of random numbers.

**Note:** Random numbers are generated using the Mersenne-Twister technique. This technique has a period length of $2^{19937} - 1$. For details about the generators, see Matsumoto and Nishimura (1998). The new generators are verified to pass all the DIEHARD tests as documented in Marshalled (1996).

See the JSL Functions chapter in the *JSL Syntax Reference* for details about syntax.

**Random Uniform**

Generates random numbers uniformly between 0 and 1. This means that any number between 0 and 1 is as likely to be generated as any other. The result is an approximately even distribution. You can shift the distribution and change its range with constants. For example, $5 + \text{Random Uniform()} \times 20$ generates uniform random numbers between 5 and 25.

**Random Normal**

Generates random numbers that approximate a normal distribution with a mean of 0 and standard deviation of 1 if no arguments are used, or with the mean and standard deviation entered as arguments. The normal distribution is bell shaped and symmetrical. You can also modify the **Random Normal** function with constants if no arguments are entered to give a normal distribution with specific mean and standard deviation. For example, the formula $\text{Random Normal()} \times 5 + 30$ generates a random normal variable with a mean of 30 and a standard deviation of 5.

**Random Exp**

Generates a single parameter exponential distribution for the distribution parameter $\lambda=1$. You can modify the exponential function to use a different $\lambda$.

For example, $\text{Random Exp()} / .1$ generates an exponential distribution for $\lambda=0.1$. The exponential distribution is often used to model simple failure time data, where $\lambda$ is the failure rate.
Random Gamma

Gives a gamma distribution for the parameter, alpha, you enter as the function argument. The gamma distribution describes the time until the kth occurrence of an event. The gamma distribution can also have a scale parameter, beta. A gamma variate with shape parameter alpha and scale beta can be generated with the formula beta*Random Gamma(alpha). If 2*alpha is an integer, a Chi-squared variate with 2*alpha degrees of freedom is generated with the formula 2*Random Gamma(alpha).

Random Beta

Generates a pseudo-random number distributed Beta(alpha, beta).

Random Cauchy

Generates a Cauchy distribution with location parameter 0 and scale parameter 1. The Cauchy distribution is bell shaped and symmetric but has heavier tails than the normal distribution. A Cauchy variate with location parameter alpha and scale parameter beta can be generated with the formula alpha+beta*Random Cauchy().

Random Category

Generates a random category given an alternation of probability and result expressions (for example, Random Category(.2, "A", .3, "B", .4, "C", "D");).

Random Johnson Su

Returns a random number from the Johnson Su distribution.

Random Johnson Sb

Returns a random number from the Johnson Sb distribution.

Random Johnson Sl

Returns a random number from the Johnson Sl distribution.

Random Triangular

Generates a triangular distribution of numbers between 0 and 1, with the midpoint that you enter as the function argument. You can add a constant to the function to shift the distribution and multiply to change its span.

Random Integer

Generates a uniform distribution of integers between 1 and the argument that you enter as n1, if nothing is entered for n2. If you enter both n1 and n2 (n1<n2), Random Integer generates a uniform distribution of the integers between and including n1 and n2.
Random Binomial

Generates random numbers from a binomial distribution with parameters that you enter as function arguments. The first argument is \( n \), the number of trials in a binomial experiment. The second argument is \( p \), the probability that the event of interest occurs. When \( n = 1 \), the binomial function generates a distribution of Bernoulli trials. For example, \( n = 1 \) and \( p = 0.5 \), give the distribution of tossing a fair coin. The mean of the binomial distribution is \( np \), and variance is \( np(1 − p) \).

Random Negative Binomial

Generates a negative binomial distribution for the parameters that you enter as function arguments. The first parameter is the number of successes of interest (\( r \)) and the second argument is the probability of success (\( p \)). The random variable of interest is the number of failures that precede the \( r \)th success. In contrast to the binomial variate, where the number of trials is fixed and the number of successes is variable, the negative binomial variate is for a fixed number of successes and a random number of trials. The mean of the negative binomial distribution is \( (r(1 − p))/p \) and the variance is \( (r(1 − p))/p^2 \).

Random Beta Binomial

Returns random numbers from the beta binomial distribution for \( n \) trials with probability \( p \) and correlation or overdispersion \( delta \).

Random Frechet

Returns a random number from a Fréchet distribution with the location \( mu \) and scale \( sigma \).

Random Geometric

Returns random numbers from the geometric distribution with the parameter that you enter as the function argument. The parameter, \( p \), is the probability that a specific event occurs at any one trial. The number of trials until a specific event occurs for the first time is described by the geometric distribution. The mean of the geometric distribution is \( (1−p)/p \), and the variance is \( (1 − p)/p^2 \).

Random Poisson

Generates a Poisson variate based on the value of the parameter, \( lambda \), you enter as the function argument. Lambda is often the expected number of events occurring per unit time or unit of area. Lambda is both the mean and the variance of the Poisson distribution.

Random Gamma Poisson

Returns random numbers from the gamma Poisson distribution with parameters \( lambda \) and \( sigma \).
Random Weibull
Returns a random number from a Weibull distribution.

Random Logistic
Returns a random number from a logistic distribution with the location $mu$ and scale $sigma$.

Random Loglogistic
Returns a random number from a loglogistic distribution with the location $mu$ and scale $sigma$.

Random Lognormal
Returns a Lognormal-distributed random number with location parameter $mu$ and scale $sigma$.

Random GLog
Returns random numbers from the generalized logarithm distribution with parameters $mu$, $sigma$, and $lambda$. When $lambda$ is equal to zero, the function returns a lognormal($mu, sigma$).

Random Reset
Restarts the random number sequences with a seed that you specify.

Random LEV
Returns a random number from an LEV distribution with the specified location $mu$ and scale $sigma$.

Random SEV
Returns a random number from the smallest extreme distribution with the specified location $mu$ and scale $sigma$.

Col Shuffle
Selects a row number at random from the current data table. Each row number is selected only once. When Col Shuffle is used as a subscript, it returns a value selected at random from the column that serves as its argument. Each value from the original column is assigned only once as Col Shuffle’s result.

For example, to identify a 50% random sample without replacement, use the formula in Figure A.16.
**Figure A.16** Formula Identifying 50% Random Sample

The formula in Figure A.16 selects half the values \( \frac{n}{2} \) from the column \( x \) and assigns them to the first half of the rows in the computed column. The remaining rows of the computed column fill with missing values.

**Resample Freq**

Generates a random selection with replacement frequency counts, suitable for use in bootstrapping. For example, it supports a second *Freq Column* argument, enabling it to do bootstrap samples relating to a pre-existing frequency column specified in the second argument. `Resample Freq()` generates a 100% resample. `ResampleFreq(rate)` generates a rate frequency sample. `Resample(rate, column)` generates a sample that is calculated by the rate multiplied by the sum of the specified column.

---

**Date Time Functions**

JMP stores dates and times in numeric columns using the Macintosh standard of the *number of seconds since January 1, 1904*. When a column has date values, you can assign a date format to that column by double-clicking a column name and selecting *Date* or *Time* from the *Format* menu. See “Numeric Format Options” on page 228 in the “The Column Info Window” chapter.

See the JSL Functions chapter in the *JSL Syntax Reference* for details about syntax.

**In Minutes, In Hours, In Days, In Weeks, In Years**

Converts from the units of the function name to the equivalent number of seconds for the argument. The argument must be a number or numeric expression. For example, `In Minutes(2)` yields 120, and `In Years(1)` yields 31,557,600 (60 seconds * 60 minutes * 24 hours * 365.25 days).

**Date DMY, Date MDY**

Accepts numeric expressions for day, month, and year and return the associated JMP date. For example, `Date DMY(20, 3, 1991)` and `Date MDY(3, 20, 1991)` evaluate to 2,752,272,000.

**Today**

Returns the number of seconds between January 1, 1904 and the current date. For example, at midnight on March 20, 1991 (a Wednesday), the *Today* function returns 2752272000.
(2,752,272,000 seconds) and continues counting. If you evaluate the **Today** function later in the day, it reflects the additional seconds.

**Day, Month, Year,**

Returns the day of the month, the month (as a number from 1 to 12), a four-digit year, respectively. The argument for these functions is interpreted as a JMP date. For example, on March 20, 1991:

- **Day(2752272000)** returns the number 20.
- **Month(2752272000)** returns the number 3.
- **Year(2752272000)** returns the number 1991.

**Quarter**

Returns the annual quarter of a *datetime* value as an integer 1-4.

**Hour, Minute, Second**

Returns the hour, the minute, and the seconds of a date-time value, respectively. The argument for these functions is interpreted as a JMP date. For example, on March 20, 1991:

- **Hour(2752572649)** returns the number 11.
- **Minute(2752572649)** returns the number 30.
- **Second(2752572649)** returns the number 49.

**Day of Week, Day of Year, Week of Year, Time of Day**

The argument for these functions is a JMP date. **Day Of Week** returns a number from 1 to 7, where 1 represents Sunday. **Day Of Year** returns the number of days from the beginning of the year. **Week Of Year** returns a number from 1 to 52 based on the rule specified. Rule 1 (default) has weeks start on Sunday with the first Sunday being week 2 and week 1 is a partial week or empty; rule 2 has the first Sunday begins week 1 with any previous days being week 0; rule 3 returns the ISO week number where the week starts on Monday and week 1 is the first week of the year with four days in that year. With ISO weeks, it is possible for the first or last three days of the year to belong to the neighboring year’s week number. **Time Of Day** returns a number from 0 to 86399 (time of day in seconds). For example, on Wednesday, March 20, 1991:

- **Day Of Week(2752272000)** returns the number 4.
- **Day Of Year(2752272000)** returns the number 79.
- **Week Of Year(2752272000)** returns the number 12.
- **Time Of Day(2752272000)** returns the number 0.
Informat

The argument for the Informat function is a date character string. For example, Informat("03/20/1991") returns the appropriate JMP date value, 2752272000. JMP can read all the date formats except for Abbrev Date and Long Date.

Abbrev Date, Long Date, Short Date

The argument for these date functions is a JMP date. They return character strings that are the formatted representation of the argument. For example:

- Abbrev Date(2752272000) returns Wed, Mar 20, 1991.
- Long Date(2752272000) returns Wednesday, March 20, 1991.
- Short Date(2752272000) returns 3/20/91.

Format

The first argument in the Format function is a JMP date. This function returns the character string representation of the date by the date format that you specify in the second argument, which is a quoted string. If you apply this formula to a numeric column, JMP automatically changes the column’s data type to character.

You can also supply a column for the first argument and leave the rest blank. The result is the formatted value of the column reference. This can be used to extract value labels of a column when the value labels are turned off.

MDYHMS

The argument of MDYHMS is a JMP date. This function shows all date and time fields, appending zeros as time fields if no time information is present. This is useful if a date column is formulated such that not all date information is displayed. The MDYHMS function can be used to see all available date and time information.

Date Increment

Adds 1 or more intervals to a starting datetime value. For example, Date Increment(Today(), "Day", 3) adds three days to the current date. Date Increment(Today(), "Year", 3) adds 3 years to the current date.

Date Difference

Returns the difference of two datetime values. The interval argument can be Second, Minute, Hour, Day, Week, Month, Quarter, Year. The alignment arguments are described here:

Start is used to count the number of times an interval starts.

Actual is used to count whole intervals.

Fractional is used to count fractional intervals.
For example, the following formula returns 207.890243055556, the number of days between the dates:

```
Date Difference(
    01Jan2010:00:00:00, 
    27Jul2010:21:21:57, 
    "Day", 
    "fractional"
);
```

The following formula returns 207, the number of completed days between the dates:

```
Date Difference(
    01Jan2010:00:00:00, 
    27Jul2010:21:21:57, 
    "Day", 
    "actual"
);
```

The following formula returns 9, the number of completed hours between the times:

```
Date Difference(
    01Jan2010:00:00:00, 
    01Jan2010:09:22:57, 
    "Hour", 
    "actual"
);
```

The following formula returns 1, the number of times a new hour started between the times:

```
Date Difference(
    31Dec2010:23:59:59, 
    01Jan2011:00:59:59, 
    "Hour", 
    "start"
);
```

---

**Row State Functions**

There are six characteristics that rows in a data table can have: selected, hidden, excluded, labeled, colored, and marked. If you give rows one or more of these characteristics and then create row state data table columns, you can then create a formula that computes and saves row state conditions. (See “Column Properties” on page 235 in the “The Column Info Window” chapter, and “Row State Columns” on page 231 in the “The Column Info Window” chapter.) This formula processes row state data just as it would process character and numeric data.

See the JSL Functions chapter in the *JSL Syntax Reference* for details about syntax.
**Note:** A row can be assigned any combination of row states; a row state column can have multiple row states as a value.

Table A.2 describes the type of argument each Row State function requires and what each returns.

### Table A.2  Row State Functions

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Argument Type Required</th>
<th>What the Function Returns (Your Column Data Type Should be This Type)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row State</td>
<td>none</td>
<td>row state of current row</td>
</tr>
<tr>
<td>As Row State</td>
<td>numeric</td>
<td>all row states of current row</td>
</tr>
<tr>
<td>Combine States</td>
<td>multiple row state arguments</td>
<td>multiple row state assignments</td>
</tr>
<tr>
<td>Excluded State</td>
<td>positive integer or zero</td>
<td>row state-excluded or not excluded</td>
</tr>
<tr>
<td>Hidden State</td>
<td>positive integer or zero</td>
<td>row state-hidden or not hidden</td>
</tr>
<tr>
<td>Labeled State</td>
<td>positive integer or zero</td>
<td>row state-labeled or not labeled</td>
</tr>
<tr>
<td>Color State</td>
<td>integer or color name or {red, green, blue}</td>
<td>row state color</td>
</tr>
<tr>
<td>Marker State</td>
<td>integer or character</td>
<td>row state marker</td>
</tr>
<tr>
<td>Selected State</td>
<td>positive integer or zero</td>
<td>row state-selected or not selected</td>
</tr>
<tr>
<td>Hue State</td>
<td>integer</td>
<td>row state hue</td>
</tr>
<tr>
<td>Shade State</td>
<td>integer 1-5</td>
<td>row state intensity</td>
</tr>
<tr>
<td>Excluded</td>
<td><strong>Row State()</strong> or row state column</td>
<td>integer 0 (not excluded) or 1 (excluded)</td>
</tr>
<tr>
<td>Hidden</td>
<td><strong>Row State()</strong> or row state column</td>
<td>integer 0 (not hidden) or 1 (hidden)</td>
</tr>
<tr>
<td>Labeled</td>
<td><strong>Row State()</strong> or row state column</td>
<td>integer 0 (not labeled) or 1 (labeled)</td>
</tr>
<tr>
<td>Color Of</td>
<td><strong>Row State()</strong> or row state column</td>
<td>color map integer</td>
</tr>
<tr>
<td>Marker Of</td>
<td><strong>Row State()</strong> or row state column</td>
<td>marker map integer</td>
</tr>
</tbody>
</table>
Appendix A
Formula Functions Reference

Using JMP Row State Functions

Row State

Returns the active row state condition of the current row as true or false. You can use this function to conveniently write conditional clauses that depend on the status of the current row. For example, Figure A.17 assigns a 1 to rows that are currently selected and labeled and 0 otherwise.

Figure A.17  Row State

As Row State

Converts a numeric argument to a row state or set of row state conditions. Row states are stored internally in JMP as a 16-bit number, with each bit assigned to represent one of the possible row states as illustrated in Figure A.3. For example, the binary representation of 1327 is 0000010100101111. As Row State(1327) would therefore set the row state as selected, excluded, hidden, labeled, with marker 2 and color 10.

Table A.2  Row State Functions  (Continued)

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Argument Type Required</th>
<th>What the Function Returns (Your Column Data Type Should be This Type)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selected</td>
<td>Row State() or row state column</td>
<td>integer 0 (not selected) or 1 (selected)</td>
</tr>
</tbody>
</table>

Table A.3  Row States Stored as 16-Bit Numbers: Each Bit Represents a Row State

<table>
<thead>
<tr>
<th>Bit</th>
<th>Row State</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Not selected (0) or Selected (1)</td>
</tr>
<tr>
<td>1</td>
<td>Unexcluded (0) or Excluded (1)</td>
</tr>
<tr>
<td>2</td>
<td>Unhidden (0) or Hidden (1)</td>
</tr>
<tr>
<td>3</td>
<td>Unlabeled (0) or Labeled (1)</td>
</tr>
<tr>
<td>4-7</td>
<td>Marker</td>
</tr>
<tr>
<td>8-14</td>
<td>Color</td>
</tr>
</tbody>
</table>
Combine States

Generates a row state combination with two or more arguments. Use the insert button ( ) on the Formula Editor keypad or type a comma to add arguments to the Combine States function. The currently selected expression becomes the first argument when you select Combine States. Replace each argument with an expression that evaluates to a row state. This formula:

\[
\text{Combine States(}
\text{   Selected State( Modulo( Row(), 2 )},
\text{   Labeled State( Modulo( Row() + 1, 2 )});}
\]

alternately labels or selects each row in the calculated row state column. The Selected State and Labeled State functions are defined later in this section. Use the insert ( ) and delete ( ) buttons on the Formula Editor keypad to add more arguments or remove unwanted arguments.

If you include conflicting row states in a combination, the results are unpredictable.

Excluded State

Interprets a numeric argument as true or false. When an argument evaluates as true, the Excluded State function assigns the excluded condition as the value of the column for that row. For example, Excluded State(Modulo(Row(),2)) assigns the excluded row state as the value of the row state column for each odd numbered row.

Hidden State

Assigns the hidden row state condition when its argument is greater than zero. If the argument is zero, the value in the column for that row is not hidden.

Labeled State

Gives the labeled row state condition when its argument is greater than zero. If the argument is zero the row value in the column for that row is not labeled.

Color State

Returns the color from the JMP color map that corresponds to its integer argument. JMP colors are numbered 0 through 84. Zero maps to black.

Marker State

Returns markers from the JMP marker map that correspond to its integer argument. JMP markers are numbered 0 through 16. The formula Marker State(Row()) assigns all the row state markers in a repeating sequence determined by the current row number to the calculated row state column. A row state column can have multiple row states as a value.
Selected State

Gives the selected row state condition when its argument is greater than zero. If the argument is zero, the value in the column for that row is not selected.

Hue State

Returns the color from the JMP hue map that corresponds to its integer argument. JMP hues are numbered 0 through 11 but larger integers are treated as modulo 12. The Hue State function does not map to black, gray, or white. A hue of zero maps to red and hue of 11 maps to magenta. The formula on the left in Figure A.19 assigns row state colors in a chromatic spread based on the value of $z$. The Hue State function used with a row state data type column.

Figure A.18 Example of Hue State Function

\[
\text{Hue State}\left(\frac{z - \text{Col Quantile}(z, 0.)}{\text{Col Quantile}(z, 1.) - \text{Col Quantile}(z, 0.)}\right) \cdot 12
\]

Shade State

Assigns five shade levels to a color or hue. A shade of –2 is darkest and shade of +2 is lightest. A shade of zero is a pure color. The formula on the right in Figure A.19 assigns shade values based on the value of $z$.

Figure A.19 Example of Shade State Function

\[
\text{Shade State}\left(\frac{z - \text{Col Quantile}(z, 0.)}{\text{Col Quantile}(z, 1.) - \text{Col Quantile}(z, 0.)}\right) \cdot (5 - 2)
\]

To assign all shades of all the colors in the colors palette, you need to use the Hue State and Shade State assignments together. The formula in Figure A.20 uses the Combine States function described at the beginning of this section. The first argument in the Combine States function is the Hue State formula shown previously, and the second argument is the Shade State formula. In addition, the Marker State function with an argument of 2 assigns the X marker to each row, and the Selected State function with an argument of 1 selects each row.
Figure A.20 Combine States Example For Using Both Hue State and Row State

Excluded, Hidden, Labeled, and Selected

Accepts a row state expression argument (row state column or row state constant) that evaluates as either 1 or 0 (true or false). These characteristics are inactive by default. Often, the `Row()` function is the argument, which detects the active row state condition of each row. For example, in Figure A.21, the formula assigns 99 whenever a row is actively selected, and 0 otherwise. Note that this formula is used in a column that has a numeric data type.

Figure A.21 Example of a Formula Using the Selected Function

The example in Figure A.22 assigns row state conditions to a row state column. The formula for the row state column (in the column called x) checks to determine whether the active row state is either Hidden or Excluded, and if so, assigns the Labeled row state.

Figure A.22 Calculate Row State Information in a Row State Column
Color Of

Accepts any row state expression or column, or the `Row State()` function as its argument. Returns a number from the JMP color map that corresponds to the active color state, or zero if there is no assigned color.

Marker Of

Accepts any row state expression or column, or the `Row State()` function as its argument. Returns a number from the JMP marker map that corresponds to the active marker or zero if there is no assigned marker.

Assignment Functions

Assignment functions work in place. That is, the result returned by the operation (on the right of the operator) is stored in the argument on the left of the operator and replaces its current value.

Assignment statements are most often used in conjunction with other commands to build a JSL script. You can use the Formula Editor to create and execute a script in that column, but this is not recommended because of dependencies and ambiguities that can result. Most often, scripts are stored as .jsl files, and can be saved with a data table. See “Create and Save Scripts” on page 218 in the “Enter and Edit Data” chapter. For details about syntax, see the JSL Functions chapter in the JSL Syntax Reference.

Note: The first argument of an assignment function must be capable of being assigned. This means you cannot have an assignment such as 3+=4, because 3 is a constant value that cannot be reassigned. You must first create a variable (a table variable or local variable) whose value is 3. (For details about table variables, see “Use Table Variables” on page 217 in the “Enter and Edit Data” chapter. For details about local variables, see “Refer to Values in Columns and Table Variables” on page 308 in the “Formula Editor” chapter). Then use that variable as the left-hand argument of the assignment function.

= (assign) Puts the value of $b$ into $a$. For example ($a=b$).

+= (add to) Adds the value of $b$ to $a$ and puts the result back into $a$. For example, $a+=b$.

-= (subtract to) Subtracts the value of $b$ and puts the result back into $a$. For example, $a-=b$.

*= (multiply to) Multiplies $b$ with $a$ and puts the result back into $a$. For example, $a*=b$.

/= (divide to) Divides $b$ into $a$ and puts the result back into $a$. For example, $a/=b$.

++ (post increment) Adds one (1) to $a$, in place, so that $a++$. For example, if the initial value of $a$ is 4, the expression $a++$ changes $a$ to 5.
-- (post decrement) Subtracts one (1) from $a$, in place, so that $a--$. For example, if the initial value of $a$ is 4, the expression $a--$ changes $a$ to 3.

**Parametric Model Functions**

This category is a short cut to create three parametric models that are linear functions of set of window-selected columns.

**Linear Model, Interactions Model, Full Quadratic Model**

Selecting each of these opens a column selection box that lets you select one or more columns to be included in the model. The function then creates and populates the chosen model.

**Finance Functions**

Lets you create formulas to calculate principal payments, interest rate, rate of return, and so on.

**Double Declining Balance**

Returns the depreciation of an asset for a specified period of time. The function uses the double-declining balance method or some other depreciation factor.

**Future Value**

Returns the future value of an investment that is based on periodic, constant payments and a constant interest rate.

**Interest Payment**

Returns the interest payment for a given period for an investment that is based on periodic, constant payments and a constant interest rate.

**Interest Rate**

Returns the interest rate per period of an annuity.

**Internal Rate of Return**

Returns the internal rate of return for a series of cash flows in the `values` argument.

**Modified Internal Rate of Return**

Returns the modified internal rate of return for a series of periodic cash flows. The cost of investment and the interest received on reinvested cash is included.
Net Present Value
Returns the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values).

Number of Periods
Returns the number of periods for an investment that is based on periodic, constant payments and a constant interest rate.

Payment
Returns the payment for a loan that is based on constant payments and a constant interest rate.

Present Value
Returns the present value of an investment.

Principal Payment
Returns the payment on the principal for a given period for an investment that is based on periodic, constant payments and a constant interest rate.

Straight Line Depreciation
Returns the straight-line depreciation of an asset for one period.

Sum Of Years Digits Depreciation
Returns the sum-of-years’ digits depreciation of an asset for a specified period.
This chapter contains technical details that apply to multiple platforms in JMP and to SAS integration.
Features That Support Multithreading

Some features in JMP are coded to take advantage of multiple central processing units (CPUs) on a machine, allowing these features to run significantly faster. This process is called multithreading.

The following features support multithreading:

- Boosted Trees
- Bootstrap Forest
- Choice
- Covering Arrays
- Distribution
- Factor Analysis
- Fit Life by X
- Fit Model: Parametric Survival, Mixed Model, Generalized Regression, and Response Screening
- Gaussian (Beginning with JMP 13, Fast GASP and the use of Categorical variables are only in JMP Pro.)
- Latent Class Analysis
- Life Distribution
- Multivariate
- Neural (Some features are only in JMP Pro.)
- Nominal Logistic
- Nonlinear and Nonlinear Curve
- Normal Mixtures in Cluster Analysis
- Partial Least Squares (Some features are only in JMP Pro.)
- Partition
- Predictor Screening
- Principal Components
- Process Screening
- Profiler (Does not apply to Profilers launched from within other platforms.)
- Reliability Forecast
- Repairable Systems Simulation
- Response Screening
- Sparse Principal Components
- SVD Imputation in the Missing Values Screening
- Text Explorer \textsuperscript{PRO} (SVD and Latent Class Analysis are only in JMP Pro.)
- Uplift
- Variable Clustering

Conventions for Mapping JMP Attributes to SAS Extended Attributes

SAS extended attributes are metadata that you define in SAS code to import information such as table scripts, labels, length, and type. You associate the extended attributes with a data set or variable and define them in name-value pairs, such as \texttt{_JMP_TABLESCRIPTNAME_2="OnOpen"}.

This section provides information about SAS extended attributes and their corresponding JMP attributes.

\textbf{Table B.1 Table Attributes}

<table>
<thead>
<tr>
<th>JMP Table Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Variable Count</td>
<td>_JMP_TABLEVARCOUNT</td>
<td>Numeric, 0</td>
<td>Count of table variables</td>
</tr>
<tr>
<td>Table Variable Name 1</td>
<td>_JMP_TABLEVARNAME_1</td>
<td>String</td>
<td>Name of the first table variable</td>
</tr>
<tr>
<td>Table Variable Value 1</td>
<td>_JMP_TABLEVARVALUE_1</td>
<td>String</td>
<td>Value of the first table variable</td>
</tr>
<tr>
<td>Table Variable Name 2</td>
<td>_JMP_TABLEVARNAME_2</td>
<td>String</td>
<td>Name of the second table variable</td>
</tr>
<tr>
<td>Table Variable Value 2</td>
<td>_JMP_TABLEVARVALUE_2</td>
<td>String</td>
<td>Value of the second table variable</td>
</tr>
<tr>
<td>Table Variable Name n</td>
<td>_JMP_TABLEVARNAME_n</td>
<td>String</td>
<td>Name of the n\textsuperscript{th} table variable</td>
</tr>
</tbody>
</table>
### Table B.1 Table Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Table Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Variable Value n</td>
<td><em>JMP_TABLEVARVALUE</em>(n)</td>
<td>String</td>
<td>Value of the (n)th table variable</td>
</tr>
<tr>
<td>Table Script Count</td>
<td>_JMP_TABLESCRIPTCOUNT</td>
<td>Numeric</td>
<td>Count of table scripts</td>
</tr>
<tr>
<td>Table Script Name 1</td>
<td><em>JMP_TABLESCRIPTNAME</em>(1)</td>
<td>String</td>
<td>Name of the first table script</td>
</tr>
<tr>
<td>Table Script Value 1</td>
<td><em>JMP_TABLESCRIPTVALUE</em>(1)</td>
<td>String</td>
<td>Value of the first table script</td>
</tr>
<tr>
<td>Table Script Name 2</td>
<td><em>JMP_TABLESCRIPTNAME</em>(2)</td>
<td>String</td>
<td>Name of the second table script</td>
</tr>
<tr>
<td>Table Script Value 2</td>
<td><em>JMP_TABLESCRIPTVALUE</em>(2)</td>
<td>String</td>
<td>Value of the second table script</td>
</tr>
<tr>
<td>Table Script Name n</td>
<td><em>JMP_TABLESCRIPTNAME</em>(n)</td>
<td>String</td>
<td>Name of the table script (n)</td>
</tr>
<tr>
<td>Table Script Value n</td>
<td><em>JMP_TABLESCRIPTVALUE</em>(n)</td>
<td>String</td>
<td>Value of table script (n)</td>
</tr>
<tr>
<td>Lock Data Table</td>
<td>_JMP_ISLOCKED</td>
<td>Boolean, 0</td>
<td>Locked table</td>
</tr>
<tr>
<td>Suppress Formula Eval</td>
<td>_JMP_SUPPRESSEVAL</td>
<td>Boolean, 0</td>
<td>Suppressed formula evaluation</td>
</tr>
<tr>
<td>Column Group Count</td>
<td>_JMP_COLGRPCOUNT</td>
<td>Numeric, 0</td>
<td>Number of column groups</td>
</tr>
<tr>
<td>Column Group Name 1</td>
<td><em>JMP_COLGRPNAME</em>(1)</td>
<td>String</td>
<td>Name of column group 1</td>
</tr>
<tr>
<td>Column Group Start Col 1</td>
<td><em>JMP_COLGRPSTARTCOL</em>(1)</td>
<td>String</td>
<td>Name of first column in group 1</td>
</tr>
<tr>
<td>Column Group NCols 1</td>
<td><em>JMP_COLGRPNCOLS</em>(1)</td>
<td>Numeric</td>
<td>Number of columns in group 1</td>
</tr>
</tbody>
</table>
### Table B.1 Table Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Table Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Group Name 2</td>
<td>_JMP_COLGRPNAME_2</td>
<td>String</td>
<td>Name of column group 2</td>
</tr>
<tr>
<td>Column Group Start Col 2</td>
<td>_JMP_COLGRPSTARTCOL_2</td>
<td>String</td>
<td>Name of first column in group 2</td>
</tr>
<tr>
<td>Column Group NCols 2</td>
<td>_JMP_COLGRPNCOLS_2</td>
<td>Numeric</td>
<td>Number of columns in group 2</td>
</tr>
<tr>
<td>Column Group Name n</td>
<td>_JMP_COLGRPNAME_n</td>
<td>String</td>
<td>Name of column group n</td>
</tr>
<tr>
<td>Column Group Start Col n</td>
<td>_JMP_COLGRPSTARTCOL_n</td>
<td>String</td>
<td>Name of first column in group n</td>
</tr>
<tr>
<td>Column Group NCols n</td>
<td>_JMP_COLGRPNCOLS_n</td>
<td>Numeric</td>
<td>Number of columns in group n</td>
</tr>
</tbody>
</table>

### Table B.2 Column Attributes

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Name</td>
<td>_JMP_COLNAME</td>
<td>String</td>
<td>Original column name in JMP</td>
</tr>
<tr>
<td>Data Length</td>
<td>_JMP_DATALENGTH</td>
<td>Numeric, 0</td>
<td>Length of the data. For numeric types, the value can be 1, 2, 4, or 8. For character types, 0 (or negative) means variable length, positive values mean fixed-length.</td>
</tr>
<tr>
<td>Row State column?</td>
<td>_JMP_ISROWSTATE</td>
<td>Numeric, 0</td>
<td>0 = not row state, 1 = default row state for table, 2 = row state column</td>
</tr>
</tbody>
</table>
### Table B.2 Column Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>_JMP_ISLABEL</td>
<td>Boolean, 0</td>
<td>Label column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Scroll Lock</td>
<td>_JMP_ISSCROLLLOCK</td>
<td>Boolean, 0</td>
<td>Scroll locked column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Hidden</td>
<td>_JMP_ISHIDDEN</td>
<td>Boolean, 0</td>
<td>Hidden column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Excluded</td>
<td>_JMP_ISEXCLUDED</td>
<td>Boolean, 0</td>
<td>Excluded column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Notes</td>
<td>_SAS_NOTES</td>
<td>String</td>
<td>Notes about the column</td>
</tr>
<tr>
<td>Modeling Type</td>
<td>_SAS_LEVEL</td>
<td>String</td>
<td>Valid values are Binary, Interval, Ordinal, Nominal, Unary. JMP maps Binary and Unary to Nominal and Interval to Continuous.</td>
</tr>
<tr>
<td>Preselect Role</td>
<td>_SAS_MININGROLE</td>
<td>String</td>
<td>Valid values are Assessment, Censor, Classification, Cost, Cross ID, Decision, Frequency, ID, Input, Key, Label, Prediction, Referrer, Rejected, Residual, Segment, Sequence, Target, Text, Text Location, Time ID, Treatment, Web Address, Weight. JMP maps Y to Target, X to Input, Freq to Frequency, and Weight to Weight.</td>
</tr>
<tr>
<td>Distribution</td>
<td>_SAS_DISTRIBUTION</td>
<td>String</td>
<td>Distribution type to fit for this column</td>
</tr>
<tr>
<td>Format Name</td>
<td>_JMP_FORMATNAME</td>
<td>String</td>
<td>Format of the column (such as Fixed Dec or Percent)</td>
</tr>
</tbody>
</table>
Table B.2 Column Attributes  (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format Width</td>
<td>_JMP_FORMATWIDTH</td>
<td>Numeric</td>
<td>Width of the column</td>
</tr>
<tr>
<td>Format Decimals</td>
<td>_JMP_FORMATDECIMALS</td>
<td>Numeric</td>
<td>Number of decimal places</td>
</tr>
<tr>
<td>Format Code</td>
<td>_JMP_FORMATCODE</td>
<td>String</td>
<td>Typically the currency code for currency formats</td>
</tr>
<tr>
<td>Use Thousands Separator</td>
<td>_JMP_USETHOUSANDSSEPARATOR</td>
<td>Boolean, 0</td>
<td>Include thousands separator. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Input Format</td>
<td>_JMP_INFORMAT</td>
<td>String</td>
<td>Input format (for date, time, or duration-formatted columns)</td>
</tr>
<tr>
<td>Formula</td>
<td>_JMP_FORMULA</td>
<td>String</td>
<td>Column formula</td>
</tr>
<tr>
<td>Suppress Formula Eval</td>
<td>_JMP_SUPPRESSEVAL</td>
<td>Boolean, 0</td>
<td>Suppressed formula evaluation. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Lock</td>
<td>_JMP_ISLOCKED</td>
<td>Boolean, 0</td>
<td>Locked column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Range Check Code</td>
<td>_JMP_RANGECHECK_CODE</td>
<td>String</td>
<td>A code that identifies the type of range check. Examples are LE, LT, LTLT, !LT, and !LELE.</td>
</tr>
<tr>
<td>Range Check Low</td>
<td>_JMP_RANGECHECK_LOW</td>
<td>Numeric</td>
<td>First argument to range check</td>
</tr>
<tr>
<td>Range Check High</td>
<td>_JMP_RANGECHECK_HIGH</td>
<td>Numeric</td>
<td>Second optional argument to range check</td>
</tr>
<tr>
<td>List Check</td>
<td>_JMP_LISTCHECK</td>
<td>String</td>
<td>List check</td>
</tr>
<tr>
<td>Missing Value Codes</td>
<td>_JMP_MISSINGCODES</td>
<td>String</td>
<td>Values to be treated as missing</td>
</tr>
</tbody>
</table>
Table B.2 Column Attributes  *(Continued)*

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value Label Count</td>
<td>_JMP_VALUELABEL_COUNT</td>
<td>Numeric</td>
<td>Count of value labels</td>
</tr>
<tr>
<td>Value Label Count</td>
<td>_JMP_VALUELABELCODE_1</td>
<td>String</td>
<td>Code for the value label (such as EQ, LT, LE, LTLT, and LELT.). Always EQ for character variables.</td>
</tr>
<tr>
<td>Value Label Lower Bound</td>
<td>_JMP_VALUELABELLOW_1</td>
<td>Varies</td>
<td>The lower bound of a numeric range, or the only bound if the ranges is unbounded on one side. A string for character columns. Numeric for numeric columns.</td>
</tr>
<tr>
<td>Value Label Upper Bound</td>
<td>_JMP_VALUELABELHIGH_1</td>
<td>Numeric</td>
<td>The upper bound of a numeric range. Not used for character value labels.</td>
</tr>
<tr>
<td>Value Label Display</td>
<td>_JMP_VALUELABELDISPLAY_1</td>
<td>String</td>
<td>The display string for this value label</td>
</tr>
<tr>
<td>Use Value Labels</td>
<td>_JMP_USEVALUELABELS</td>
<td>Boolean, 0</td>
<td>Uses value labels when displaying this column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Value Scores</td>
<td>_JMP_VALUESCORES</td>
<td>String</td>
<td>Associates data values with numerical scores</td>
</tr>
<tr>
<td>Value Ordering</td>
<td>_JMP_VALUEORDER</td>
<td>String</td>
<td>The order of values for the column</td>
</tr>
<tr>
<td>Value Colors</td>
<td>_JMP_VALUECOLORS</td>
<td>String</td>
<td>Maps values to colors.</td>
</tr>
<tr>
<td>Color Gradient</td>
<td>_JMP_COLORGRADIENT</td>
<td>String</td>
<td>Maps values to a color gradient.</td>
</tr>
</tbody>
</table>
Table B.2 Column Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color Cells</td>
<td>_JMP_COLORCELLS</td>
<td>Boolean, 0</td>
<td>Color cells of this column using the specified value colors or color gradient. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Axis</td>
<td>_JMP_AXIS</td>
<td>String</td>
<td>Axis definition</td>
</tr>
<tr>
<td>Coding</td>
<td>_JMP_CODING</td>
<td>String</td>
<td>Code a range of values to -1, 1 for modeling purposes</td>
</tr>
<tr>
<td>Mixture</td>
<td>_JMP_MIXTURE</td>
<td>String</td>
<td>Participation in a mixture of columns adding up to a value. The Mixture column property has numeric values (limits) and string values (L Pseudo Component and U Pseudo Component).</td>
</tr>
<tr>
<td>Row Order Levels</td>
<td>_JMP_ROWORDER</td>
<td>Boolean, 0</td>
<td>Sort the column by occurrence rather than value. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Spec Limits</td>
<td>_JMP_SPECLIMITS</td>
<td>String</td>
<td>Target value and upper and lower spec limits</td>
</tr>
<tr>
<td>Control Limits</td>
<td>_JMP_CONTROLLIMITS</td>
<td>String</td>
<td>Control limits for control chart type</td>
</tr>
<tr>
<td>Response Limits</td>
<td>_JMP_RESPONSELIMITS</td>
<td>String</td>
<td>Bounds on response’s acceptable range, used by profilers</td>
</tr>
<tr>
<td>Design Role</td>
<td>_JMP_DESIGNROLE</td>
<td>String</td>
<td>Role in a designed experiment</td>
</tr>
<tr>
<td>Factor Changes</td>
<td>_JMP_FACTORCHANGES</td>
<td>String</td>
<td>Difficulty of changing a factor, for DOE. Value values: Easy, Hard, Very Hard</td>
</tr>
<tr>
<td>Sigma</td>
<td>_JMP_SIGMA</td>
<td>String</td>
<td>Sigma for Control Charts</td>
</tr>
</tbody>
</table>
### Table B.2 Column Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Units</td>
<td>_JMP_UNITS</td>
<td>String</td>
<td>Units for this variable; can be any string</td>
</tr>
<tr>
<td>Time Frequency</td>
<td>_JMP_TIMEFREQ</td>
<td>String</td>
<td>Numeric, Annual, Quarterly, Monthly, Weekly, Daily, Hourly, By Minutes, By Seconds</td>
</tr>
<tr>
<td>Map Role</td>
<td>_JMP_MAPROLE</td>
<td>String</td>
<td>Role in a map data set</td>
</tr>
<tr>
<td>Multiple Response Separator</td>
<td>_JMP_MRSEP</td>
<td>String, &quot;,&quot;</td>
<td>Separator for a multiple-response column.</td>
</tr>
<tr>
<td>Label Column</td>
<td>_JMP_LABELCOLUMN</td>
<td>Boolean, 0</td>
<td>Is this column a label column? 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Expression Column</td>
<td>_JMP_ISEXPRESSIONCOLUMN</td>
<td>Boolean, 0</td>
<td>Is this column an expression column? 1 for yes. 0 for no.</td>
</tr>
</tbody>
</table>

### Table B.3 Custom Column Properties

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Number of custom column properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom Property Count</td>
<td>_JMP_CUSTCOLPROPCOUNT</td>
<td>Numeric, 0</td>
<td>Count of custom column property</td>
</tr>
<tr>
<td>Custom Property Name 1</td>
<td>_JMP_CUSTCOLPROPNAME_1</td>
<td>String</td>
<td>Name of the custom column property 1</td>
</tr>
<tr>
<td>Custom Property Value 1</td>
<td>_JMP_CUSTCOLPROPVALUE_1</td>
<td>String</td>
<td>Value of the custom column property 1</td>
</tr>
<tr>
<td>Custom Property Name 2</td>
<td>_JMP_CUSTCOLPROPNAME_2</td>
<td>String</td>
<td>Name of the custom column property 2</td>
</tr>
</tbody>
</table>
Table B.3 Custom Column Properties *(Continued)*

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Number of custom column properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom Property Value 2</td>
<td>_JMP_CUSTCOLPROPVALUE_2</td>
<td>String</td>
<td>Value of the custom column property 2</td>
</tr>
<tr>
<td>Custom Property Name n</td>
<td>_JMP_CUSTCOLPROPNAME_n</td>
<td>String</td>
<td>Name of the custom column property n</td>
</tr>
<tr>
<td>Custom Property Value n</td>
<td>_JMP_CUSTCOLPROPVALUE_n</td>
<td>String</td>
<td>Value of the custom column property n</td>
</tr>
</tbody>
</table>
Symbols

! (Not) function 559
!= (not equal to) function 554
.emf 436
.eps 436
.gif 436
.pdf 436
*= (Multiply To) function 593
/= (Divide To) function 593
& (And) function 558
& (And) function and conditional clauses 558
^ See insert button on keypad
+= (Add to) function 593
< (less than) function 554
<= (less than or equal to) function 554
= (Assign) function 593
== (equal to) function 554
> (greater than) function 554
>= (greater than or equal to) function 554
| (Or) function 558

Numerics

1-, 2-, and 4-byte integers 227

A

A tool. See annotate tool
Abbrev Date function 586
Abs function 540
Absolute Value transformation 204
Add All Windows 449
Add Database Query 449
Add Document 449
Add files opened by scripts to the Recent Files list 497
Add Folder 449
add ranges, missing values 238

Add SAS Stored Process 449
Add to (+=) function 593
Add URL 449
Add Window 449
adding
columns 154
graphics and graphics scripts 405
maps and boundaries 411
rows 154
statistics columns 342
add-ins, opening as text 140
Aggregate functions (SQL) 131
Aggregate menu options, launch window 206
Allow Unquoted Strings in JSL 495
allowing short numeric formats 227, 507
analysis roles 260
And (&) function and conditional clauses 558
Annotate error lines in log 495
annotations
creating 412
setting the default font 522
anonymizing data 303
apostrophes in imported data 139
appending horizontally. See joining appending tables. See concatenating tables
ArcCosH function 544
ArcCosine function 543
archive files in project 448
ArcSine function 543
ArcSinH function 544
ArcTangent function 543
ArcTanH function 544
arguments, formula 327
arithmetic buttons, formula editor 315
arranging windows 59
Arrhenius function 542
Arrhenius Inv function 542
Arrhenius Inverse transformation 204
Arrhenius transformation 204
arrow
cursor tool 45
double arrow tool 45
arrow tool 45
As Row State function 588–589
Assign (=) function 593
Assignment functions 593–594
assignment table property 369
asterisk icon 39
attaching tables. See concatenating tables
Auto Scroll 456
Auto-complete parentheses and braces, in
script editor 527
Auto-hide menu and toolbars 519
automatic recalc option 354
Automatically generate ODS results 530
Automatically join tables added to a query 535
Auto-save the report to option 499
autosaving
documents 497
scripts 527
Average function, transforming columns 206
axis
adjusting 349, 390
copying and pasting settings 401
customizing 390
divider lines and frames 399
gridlines 396
increments 389, 393
labels 400
minimum and maximum values 392
numeric format 391
scale 391
scrolling 389
specifications for columns 241
Axis column property 241
Best numeric formats 228
Beta Binomial Distribution function 574
Beta Binomial Probability function 574
Beta Binomial Quantile function 574
Beta Density function 561
Beta Distribution function 561
Beta function 541
Beta Quantile function 561
BETWEEN statement (SQL) 131
Bezier curve 415
binning formula 200
Binomial Distribution function 574
Binomial Probability function 574
Binomial Quantile function 574
Blink button in row editor 183
Blob to Char function 550
boxes around formulas 326
braces in script editor, auto-complete 527
Break function 560
brush tool 377
buttons
copying 480
creating 475
show and hide 484
By Matching Columns option. See joining
C
Cartesian join. See joining
Categorical Color Theme 504
Cauchy distribution 581
Ceiling function 541
cell formulas 158
cells, selecting 168
Change Alias 110
Char function 544
Char to Blob function 550
Char to Hex function 548
character data types 225
Character functions 544–550
Character menu options, launch window 208
Character Pattern functions 550–554
character sets
save text as Unicode 496
select during text import 138
ChiSquare Density function 562
ChiSquare Distribution function 562
background colors 388
background image, pasting 408
backwards compatibility, Unicode 496
bars, histogram colors 388
base e 541
See also natural logarithm
Bernoulli trials 582
ChiSquare Quantile function 563  
Choose function 557  
circle with strikethrough icon 174–176  
cleaning data 177, 210  
closing  
  JMP Starter window 62  
  levels in a report 349  
  several files 59  
Coefficient of Variation 343  
Col functions 576, 583–584  
Col Maximum function 576  
Col Mean function 576  
Col Minimum function 576  
Col N Missing function 576  
Col Number function 576  
Col Quantile function 576  
Col Rank function 577  
Col Shuffle function 583  
Col Standardize function 578  
Col Std Dev function 576  
Col Sum function 576  
Collapse Whitespace function 544  
Color function 588  
Color Of function 593  
Color Presets 505  
Color State function 588, 590  
Color Theme 240  
color themes 193  
Color unknown object messages, in script editor 528  
coloring cells 173  
colors  
  background in graph 388  
  by row state 189  
  histogram bars 388  
  markers 379  
  rows and columns 189  
  shapes added to reports 414–416  
column header text import option 515  
column switcher 353  
columns  
  add properties 235  
  adding 154  
  adjusting widths 36  
  axis specifications 239  
  characteristics 187  
combining 197  
compressing 198  
computed 110  
creating a formula 202  
deleting 154  
design roles 243  
duplicating 172  
excluding 176  
filtering 51  
find selected 168  
fonts used in headings 522  
formulas 236, 306  
hiding 177  
indicator 197  
invert selection 163  
joining 282  
labeling 188  
lock in place 196  
locking 196, 224  
measuring units 242  
moving 172  
names 35, 173  
notes 236  
order of data in reports 240  
panel 39  
preselected analysis roles 260  
properties 257  
rearranging 171  
reordering 171  
resizing 170  
row state 231–232  
selecting 161  
Sigma values 244  
sorting 171  
source column 280  
splitting 272  
stacking 267  
transposing 275  
validating data 236–237  
value labels 238  
Columns Viewer 163  
columnwise statistics functions 575  
Combine menu options, launch window 205  
combine reports 351  
Combine States function 588, 590  
combining columns 197
Communications preferences 523
Compare column 169
comparing data tables 183
Comparison functions 554
Compress file when saved option 38
Compress Selected Columns 198
compressing
  columns 198
  data tables 38, 216
Compuserve Graphics Interchange Format. See
  GIF
computed column in Query Builder 110
Concat function 544
Concat Items function 549
concatenating tables 279
conditional data filter 361
conditional formatting, reports 369
Conditional functions 555–560
confidential data 303
connect to a SAS Environment preference 529
connect to a SAS Metadata Server
  preference 530
Connections, database. See database connection
Contains function 545
Continue function 560
Continuous Color Theme 504
Continuous modeling type 225
control chart column properties 243
Convert SAS custom formats 531
Copy As SAS Formula 326
Copy Formula
  creating a subset 263
  joining tables 284
copy menu and toolbar items 480
Copy Table Script 38
Copy/Drag Graphic Formats 518
copying
  axis frame settings 401
  column properties 43
  graph contents 401
  row states 232
text 438
toolbars 472
CosH function 544
Cosine function 543
Count 206
Count (in a formula) 539
Count column 179
Count function 538
creating
  data tables 151
  menu items and buttons 475
  menus 475
  source columns (when concatenating
  tables) 280
crosshairs tool 388
CSV, saving data table as 420
Cube Root transformation 204
Cube transformation 204
Cumulative Sum 209
currency formats, in columns 229
cursors 45
custom expression, Query Builder 119
customization sets
  changing 471
  importing 485
Customize Styles, in script editor 528
customizing
  axes 390
  graph elements 403
  results 434
  toolbars (Macintosh) 486
  toolbars and menus (Windows) 470

D
  dashboards, creating 454
data
    grid 35
    missing 177
    recoding 177
data filter 356–367
Data Filter Auto Clear 508
Data Filter Check Box Display 508
Data Filter Include Check 508
Data Filter Select Check 508
Data Filter Show Check 508
Data Table Background Color 509
Data Table Grid Color 509
Data Table Header Grid Color 509
data tables
  compare 183–187
  compressing 38, 216
concatenating 279
creating 151
data grid 35–46
disable undo 38
joining 282
locking 38, 216
memory issues 38
names and notes, placing on reports 498
names, changing 215
opening 46
organizing 170
panels 36
preferences 506
replace database with 425
saving 418
saving as Excel file 419
sorting 265
splitting 272
stacking 267
subsetting 262
summarizing 338
transposing 275
updating 300
data types
  character formats 225
date and time formats 228
numeric formats 228
row states 225
specifying 224
database
  connection 124
  replace with data table 425
datafeed. See communications settings
Date Difference function 586
Date DMY function 584
Date Increment function 586
Date MDY function 584
Date Time functions 584–587
Date Time menu options, launch window 207
dates and times
  formats 228–229
  inserting on report window 498
Day function 585
Day of Week function 585
Day of Year function 585
decimal point as comma, text file 516
Default Field Width 508
delete button, formula editor 315
deleting
  columns 154
  functions 325
  menus 483
  rows 154
  toolbars 483
derivatives, calculating in formula 321
descriptive statistics. See statistics columns
deselecting parts of a report 350
Design of Experiments. See DOE 243
design roles 243, 260
Design, table variable 217
Desirability function 579
diamond icon, on a report 351
Dif function 539
Difference 205, 208
Difference (reverse order) 205
Digamma function 542
Disable undo in data table 38
disclosure icon. See diamond icon
  contiguous selection 159, 162
Discrete Probability functions 573–575
Display Language 518
Distribution column property 245
Distributional menu options, launch window 206
Divide To (/=) function 593
Dock the Window List 519
DOE (Design of Experiments)
coding 243
column properties 242
Double Declining Balance function 594
DPI, exporting report graphics 433
dragging and dropping
  in data table 172
  into formulas 325
  into other programs 438
drawing speed of markers 379
drawing tools 414–416
dropping
  columns when splitting tables 273
  columns when stacking tables 269
  duplicates when joining tables 284
Dunnett P Value function 563
Dunnett Quantile function 563
duplicating cells and columns 172

E

**Edit Notes** 451

editing
  - column names 173
  - formulas 324
  - names of data tables 215
  - names of report tables 369
  - reports 350
  - tables 170
  - WHERE clauses 133

efficient evaluations 320

empty box in formula 335

EMS 426

Encapsulated PostScript File 426

End of Field and End of Line options 138

**End of Field and End of Line** options 138

end of field text import option 515

end of line text import option 515

Ends With function 547

end-to-end merging. *See* concatenating tables

Enhanced Metafile 426

EPS support in reports 426

equal to (==) function 554

equation editor. *See* formula editor

errors, ignoring in formulas 323

evaluating columns’ formulas
  - viewing evaluations in formulas 324
  - when creating subsets 263
  - when joining tables 284
  - when splitting columns 273
  - when stacking columns 269

Excel files
  - advanced import options 70
  - hierarchical headings 72
  - import options 69
  - labels as headings 494
  - opening 65
  - opening method 494
  - password-protected 65
  - previewing the data 65
  - saving data table as 419
  - selecting worksheets when opening 494
  - supported versions 64

Excel Import Wizard 65

Excluded function 592

Excluded functions 588, 590

excluding
  - columns when splitting tables 273
  - columns when stacking tables 269
  - duplicates when joining tables 284
  - rows and columns from analyses 174

excluding markers 382

Exp function 540

Exp transformation 204

exponent button, formula editor 315

exporting
  - data tables 418
  - reports 426

Expression Role column property 254

extended attributes
  - importing from SAS 80
  - mapping to JMP attributes 599
  - preferences 531

Extra space at bottom of document, in script editor 527

extracting data from image 411

F

F Density function 563

F Distribution function 563

F Power function 573

F Quantile function 565

F Sample Size function 564

factor, for mixture experiments 243

Factorial function 541

fast marker
  - drawing speed 379
  - threshold 503

Fibonacci series 539

file formats, supported 64

File Locations preferences 524

fill hollow markers 380

fill pattern 402

Fill Selection Mode 503

filling columns with data 233

Filter image 410

filtering data 356

Finance Functions 594

Find/Length expression 545
finding and replacing values  
   See searching for values
Flip image 409
Floor function 540
font size in reports 352
fonts  
   changing in data tables 36
   changing size in data tables 352
Fonts preferences 521
For function 560
For quantile statistics option, summarizing tables 340
Format function 586
format, changing in report 368
formula column, creating 236
formula editor 306–333
formulas  
   arguments, opening and closing 327
   boxes, hiding and showing 326
   cell expressions 158
   constants, adding 313
   creating 306
   creating a column 202
   data table elements, adding 308
   displaying derivatives 321
   editing 324
   entering into cells 158
   evaluating 319, 323, 509
   examples 328
   expressions 325
   fonts 327, 522
   functions, adding 316, 538
   glossary of terms 334
   JSL view 324
   keyboard shortcuts 333
   opening and closing arguments 327
   operators, adding 314
   orientation in formula editor 327
   re-evaluating 38
   shortcuts, keyboard 333
   simplifying complex 322
   tutorials 328
   viewing 324, 326
Frame Border 505
Frame Color 505
frame sizes of plots or graphs 386
freeze columns 196
Freq (Frequency). See preselected role
Full Quadratic Model function 594
function types  
   Add to (+) 593
   And 558
   Assign (=) 593
   Assignment 593
   Beta 541
   Character 544
   Character Pattern 550
   Col 576, 583–584
   Color 588
   Color State 588
   Combine States 588
   Comparison 554
   Conditional 555
   Date Time 584
   Discrete Probability 573
   Divide To 593
   Excluded 588
   Hidden 588
   Hidden State 588
   Hue State 588
   Is Missing 554
   Marker 588
   Match 331
   Multiply To (*=) 593
   Numeric 540
   Parametric Model 594
   Post Decrement (--) and Increment (++=) 594
   Probability 560
   Random 580
   Row 538
   Row State 587
   Shade State 588
   Statistical 575
   Transcendental 540
   trigonometric 543–544
functions  
   adding 316
   aggregate (SQL) 131
columnwise statistics 575
deleting 325
peeling 325
Row States 588
Future Value function 594

G
Gamma Density function 565
Gamma Distribution function 566
Gamma function 542
Gamma Poisson Distribution function 573
Gamma Poisson Probability function 573
Gamma Poisson Quantile function 573
Gamma Quantile function 567
General preferences 491–492
Generate ODS statistical graphics 530
GIF 426–427
global variables, storing a report table 369
GLog Density function 567
GLog Distribution function 567
GLog Quantile function 567
glossary of formula terms 334
Go To command 162
Go To Row command 158
grabber tool. See hand (grabber) tool
gradients 241
Graph Background Color 505
Graph Border 502
Graph Builder preferences 510
Graph Format 531
Graph Height 502
graph marker theme, default 502
graphics
  adding to buttons 478
  reordering 407
  saving reports as graphics 436
  scripts 405
  See also images
Graphics Format, ODS reports 530
Graphics Formats, Windows preference 519
graphs
  copying and pasting contents 401
  copying to data table 402
  customizing elements 403
Graphs preferences 501
greater than (>) function 554
greater than or equal to (>=) function 554
grid. See data grid
gridlines 396
GROUP BY command (SQL) 132
Group By, Query Builder 112
grouping variables
  using when sorting tables 267
  using when splitting tables 272
H
hand (grabber) tool
  using in reports 349
  using to scroll axes 389
HAVING command (SQL) 132
Hex function 548
Hex to Blob function 550
Hex to Char function 548
Hex to Number function 548
Hidden functions 588, 590, 592
Hidden State function 588
Hide Overlapping Labels 502
hiding
  columns 175
  JMP Starter window 493
  menu tips 495
  results 351
  rows 175
  thumbnails of reports 519
  toolbars 470
hiding markers 382
hierarchical data filter 361
Highlight Outline Headers option 519
high-resolution graphics 433
histogram bars, color 388
histograms, bar colors 388
Home Window 53
horizontal
  alignment in reports 349
  formula display 327
Hour function 585
Hover Help 499
HTML 5, save output as 428
Hue State function 588, 591
Hypergeometric Distribution function 575
Hypergeometric Probability function 575
I
I-beam cursors 45
icons
<table>
<thead>
<tr>
<th>term</th>
<th>page numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>asterisk</td>
<td>39</td>
</tr>
<tr>
<td>circle with strikethrough</td>
<td>174–176</td>
</tr>
<tr>
<td>column characteristics</td>
<td>39</td>
</tr>
<tr>
<td>column properties</td>
<td>39</td>
</tr>
<tr>
<td>compress</td>
<td>216</td>
</tr>
<tr>
<td>diamond (disclosure)</td>
<td>351</td>
</tr>
<tr>
<td>list check</td>
<td>39</td>
</tr>
<tr>
<td>lock</td>
<td>39, 216</td>
</tr>
<tr>
<td>mask</td>
<td>39, 176–177</td>
</tr>
<tr>
<td>modeling types</td>
<td>39</td>
</tr>
<tr>
<td>next to column names</td>
<td>39</td>
</tr>
<tr>
<td>plus</td>
<td>39, 236</td>
</tr>
<tr>
<td>preselected roles</td>
<td>260</td>
</tr>
<tr>
<td>range check</td>
<td>39</td>
</tr>
<tr>
<td>red triangle</td>
<td>352</td>
</tr>
<tr>
<td>yellow tag</td>
<td>39, 188</td>
</tr>
<tr>
<td>If function</td>
<td>555</td>
</tr>
<tr>
<td>IfMax function</td>
<td>558</td>
</tr>
<tr>
<td>IfMin function</td>
<td>558</td>
</tr>
<tr>
<td>ignoring</td>
<td></td>
</tr>
<tr>
<td>errors</td>
<td>323</td>
</tr>
<tr>
<td>missing values</td>
<td>301</td>
</tr>
<tr>
<td>image format</td>
<td></td>
</tr>
<tr>
<td>Macintosh preference</td>
<td>521</td>
</tr>
<tr>
<td>Windows preference</td>
<td>519</td>
</tr>
<tr>
<td>Image Format for PowerPoint</td>
<td>495</td>
</tr>
<tr>
<td>images</td>
<td></td>
</tr>
<tr>
<td>adding to maps</td>
<td>411</td>
</tr>
<tr>
<td>dragging into graph</td>
<td>408</td>
</tr>
<tr>
<td>extracting data</td>
<td>411</td>
</tr>
<tr>
<td>filters</td>
<td>410</td>
</tr>
<tr>
<td>pasting in background</td>
<td>408</td>
</tr>
<tr>
<td>Import generated SAS data sets into JMP</td>
<td>530</td>
</tr>
<tr>
<td>import preferences</td>
<td>514</td>
</tr>
<tr>
<td>importing</td>
<td></td>
</tr>
<tr>
<td>data from database</td>
<td>124</td>
</tr>
<tr>
<td>Excel files</td>
<td>65–77</td>
</tr>
<tr>
<td>from a database</td>
<td>125</td>
</tr>
<tr>
<td>HDF5 data</td>
<td>147</td>
</tr>
<tr>
<td>HTML</td>
<td>143</td>
</tr>
<tr>
<td>ODBC</td>
<td>424</td>
</tr>
<tr>
<td>SAS files</td>
<td>78–80</td>
</tr>
<tr>
<td>SPSS files</td>
<td>145</td>
</tr>
<tr>
<td>text files</td>
<td>134–143</td>
</tr>
<tr>
<td>text from the Script window</td>
<td>142</td>
</tr>
<tr>
<td>toolbar and menu customizations</td>
<td>485</td>
</tr>
<tr>
<td>JMP Projects</td>
<td>447–451</td>
</tr>
<tr>
<td>JMP Query Builder</td>
<td>293</td>
</tr>
<tr>
<td>JMP.PFS</td>
<td>492</td>
</tr>
<tr>
<td>Index 617</td>
<td></td>
</tr>
<tr>
<td>Using JMP</td>
<td></td>
</tr>
<tr>
<td>If function</td>
<td>555</td>
</tr>
<tr>
<td>IfMax function</td>
<td>558</td>
</tr>
<tr>
<td>IfMin function</td>
<td>558</td>
</tr>
<tr>
<td>ignoring</td>
<td></td>
</tr>
<tr>
<td>errors</td>
<td>323</td>
</tr>
<tr>
<td>missing values</td>
<td>301</td>
</tr>
<tr>
<td>image format</td>
<td></td>
</tr>
<tr>
<td>Macintosh preference</td>
<td>521</td>
</tr>
<tr>
<td>Windows preference</td>
<td>519</td>
</tr>
<tr>
<td>Image Format for PowerPoint</td>
<td>495</td>
</tr>
<tr>
<td>images</td>
<td></td>
</tr>
<tr>
<td>adding to maps</td>
<td>411</td>
</tr>
<tr>
<td>dragging into graph</td>
<td>408</td>
</tr>
<tr>
<td>extracting data</td>
<td>411</td>
</tr>
<tr>
<td>filters</td>
<td>410</td>
</tr>
<tr>
<td>pasting in background</td>
<td>408</td>
</tr>
<tr>
<td>Import generated SAS data sets into JMP</td>
<td>530</td>
</tr>
<tr>
<td>import preferences</td>
<td>514</td>
</tr>
<tr>
<td>importing</td>
<td></td>
</tr>
<tr>
<td>data from database</td>
<td>124</td>
</tr>
<tr>
<td>Excel files</td>
<td>65–77</td>
</tr>
<tr>
<td>from a database</td>
<td>125</td>
</tr>
<tr>
<td>HDF5 data</td>
<td>147</td>
</tr>
<tr>
<td>HTML</td>
<td>143</td>
</tr>
<tr>
<td>ODBC</td>
<td>424</td>
</tr>
<tr>
<td>SAS files</td>
<td>78–80</td>
</tr>
<tr>
<td>SPSS files</td>
<td>145</td>
</tr>
<tr>
<td>text files</td>
<td>134–143</td>
</tr>
<tr>
<td>text from the Script window</td>
<td>142</td>
</tr>
<tr>
<td>toolbar and menu customizations</td>
<td>485</td>
</tr>
</tbody>
</table>
Johnson Sb Density function 568  
Johnson Sb Distribution function 567  
Johnson Sb Quantile function 568  
Johnson Sl Density function 568  
Johnson Sl Distribution function 568  
Johnson Sl Quantile function 568  
Johnson Su Density function 569  
Johnson Su Distribution function 568  
Johnson Su Quantile function 568  
joining  
   by matching columns 284, 289  
   by row number 284  
   tables, methods 282  
   using Cartesian join 284, 287  
   virtually 296  
Joint Photographics Expert Group (JPEG, JPG) 426, 436  
journals, creating 438  
JPEG, JPG 426, 436  
JRE version 77  
JSL Debugger preferences 532  
JSL scripts  
   adding 218  
   autosaving 527  
   code folding 528  
   copying 221  
   creating from a report 434  
   deleting 39, 221  
   editing 39, 221  
   evaluate automatic execution 507  
   fonts 522  
   formula editor 324  
   graphics 405  
   new 38  
   preferences 526  
   running 221  
   running when a data table is opened 220  
   saving in data tables 38, 218–222  
   saving in English 496  
   viewing in formula editor 324  
JSL Scripts should be run only 519  

K  
Keep All option 272  
kepad, formula editor 133  

L  
Label column name 270  
Labeled and Labeled State functions 588  
Labeled function 592  
Labeled State function 590  
labels  
   axis 400  
   icon 188, 383  
   markers 382  
   pinning 386  
   rows and columns 188  
labels in graphs 376  
Lag function 539  
language preference, JMP indexes 497  
large plus tool 45  
laser pointer 500  
lasso tool 378  
launch windows 49  
layout, creating 434  
Left function 547  
legends  
   adding 383  
   removing 385  
Length function 546  
LEV Density function 569  
LEV Distribution function 569  
LEV Quantile function 569  
LGamma function 542  
library. See SAS transport files  
license file, specify location 525  
LIKE statement (SQL) 131  
line numbers, in script editor 527  
line tool 414  
Line Width 502  
linear axis scale 391  
Linear Model function 594  
lines  
   changing width 388  
   dotted or dashed reference lines 398  
Link Reference and Link ID column  
   properties 43  
linked data table 263, 376  
List Check property 199  
list checking 237  
   cursor 46  
   sorting data 265
Ln and LnZ functions 541
loading, SQL queries 133
local variables
  formula editor 316
  using in formula 310, 329
Location preference 531
locking
columns 224
data tables 38, 216
log
  opening by default 519
  saving 451
  saving a report to 499
  showing DisplayBox messages 497
Log function 541
Log transformation 204
Log window, saving reports to 499
Log, axis scale type 391
Log10 function 541
Log1P function 541
logarithm, natural 541
Logist function 205, 541
Logistic Density function 569
Logistic Distribution function 569
Logistic function 541
Logistic Percent 205
Logistic Percent transformation 205
Logistic Quantile function 569
Logistic transformation 205
Logit function 543
Logit Percent 205
Logit Percent transformation 205
Logit transformation 205
Loglogistic Density function 570
Loglogistic Distribution function 570
Loglogistic Quantile function 570
Lognormal Density function 570
Lognormal Distribution function 570
Lognormal Quantile function 570
Long Date function 586
Lowercase function 545

Major Grid Lines 505
Make Window with Legend 384
making indicator columns 197
Manage Rules 501
manually connect to SAS workspace servers
  preference 530
Map Role column property 246
marginal statistics 340
Marker functions 588
Marker Label Color Style preference 503
Marker Label Fixed Color preference 503
Marker Of function 593
Marker Selection Color 502
Marker Selection Fade 502
marker selection mode 502
Marker State function 590
markers
  adding 189
  changing shape 383
  changing sizes 379
  colors 379
  default shape 502
  default size 502
  drawing speed 379
  excluding 382
  hiding 382
  highlighting 380
  labels 382
  legends 383
  opaque 380
  outlines 380
  point values 384
  shapes 189, 378
  speed 379, 503
  transparency 381
mask icon 176–177
Match flag 284
Match function 331, 556
matching
cases while searching 180
columns when joining tables 289
values of two data tables. See joining
whole words in search 180
Matching Specification in Join 283
matrices in columns 254
matrix, convert report table into 369

M
Macintosh OS Settings preferences 520
magnifier tool 386
Major Grid Line Color preference 505
Max (summary statistics) 343
Maximum function 579
Maximum number of levels for a Check Box
List filter preference 536
MDYHMS function 586
Mean (summary statistics) 343
Mean function 578
measuring units, columns 242
Median 206
Median (summary statistics) 343
members, importing from SAS 80
memory issues 38
Menu preferences 533
menu tips 495
menus
  copying 480
  creating 475
  deleting 483
  merging from old version 485
  rearranging 481
merge horizontally. See joining
merge old menus 485
merge vertically. See concatenating
Mersenne-Twister technique 580
Min (summary statistics) 343
minimum and maximum axis values 392
Minimum function 579
Minor Grid Line Color preference 505
Minor Grid Lines preference 505
Minute function 585
missing data patterns 177
missing SPSS value code 145
missing value codes 237
missing values
  add ranges 238
  assign a label to 238
  coding system 252
  comparing 554
  updating tables 301
modeling types
  Continuous 225
  continuous 225
  icons 39
  Multiple Response 226
  Nominal 225
  None 226
  Ordinal 225
    specifying 226
  Unstructured Text 226
  Vector 226
Modified Internal Rate of Return function 594
Modulo function 540
Month function 585
Month Year 207
moving
  cells and columns 172
  rows 172
  selection in data table 509
Multiple Response column property 247
Multiple Response modeling type 226
multiple selection 527
Multiply To (*=) function 593
multithreading 598
Munger function 330, 545

N

N and N Missing (summary statistics) 343
N Categories (summary statistics) 343
N Missing function 579
naming
  data tables 215
  report tables 369
  reports 351
natural logarithm 541
NChooseK function 541
Neg Binomial Distribution function 574
Neg Binomial Probability function 574
Negation transformation 204
nested variables 341
nesting boxes, formula editor 328
Net Present Value function 595
New Group 449–450
Nominal modeling type 225
Non matches, include when joining tables 284
noncentrality 562–563, 565, 571–572
None modeling type 226
Normal Biv Distribution function 570
Normal Density function 560
Normal Distribution function 560
Normal Quantile function 561
Not (!) function 559
not equal to (!=) function 554
notes
  as table variables 217
  displaying in report windows 498
  saving in a column 236
NRow function 540
Num function 546
Number function 578
Number of Periods function 595
Number of Series option 268
numeric
  allowing short numeric 507
  Best format 228
  formats 228–231
    in axes 391
    short 227
  international formats 231
Numeric functions 540

O

ODBC 125, 424
ODBC drivers for importing data 65
ODBC Hide Connection String 509
ODS Result Format 530
ODS results 99
ODS Style 530
ODS Style sheet 530
Offset expression 545
OnOpen scripts 220, 507
Open All Below 349
Open All Like This 349
Open as Template, Query Builder 122
Open Database Connectivity 424
Open Text File Charset 495
opening
  add-ins as text 140
  data in text editors 140
  databases 125
  Excel files 65
  JMP files 46
  JMP Starter window 62
  journals 46
  SAS data sets 78
  SAS files 78
  SAS stored process report as data table 144
  text files 134
operator
  showing tips in script editor 527
operators
  adding 314
    in assignment functions 593
  Or (|) function 558
ORACLE synonyms 127
order of operations 319
ordering
  columns 171
  row order levels 240
  values 239
Ordinal modeling type 225
orientation of formulas 327
Original color preference 505
outlines
  adding to markers 380
  structure of reports 351
Output Table option
  joining tables 283
  sorting tables 266
oval tool (simple shape tool) 414, 416

P

page breaks, inserting 350, 435, 438
panels. See data table panels
Parametric Model Functions 594
parentheses
  script editor, adding spaces inside 528
  script editor, auto-complete 527
password-protected
  Excel files 65
  SAS data sets 95
Paste Special command 438
Pat Abort function 552
Pat Altern function 553
Pat Any function 551
Pat Arb function 552
Pat Arb No function 553
Pat At function 552
Pat Break function 551
Pat Concat function 553
Pat Conditional function 553
Pat Conditional function 553
Pat Fail function 552
Pat Fence function 553
Pat Immediate function 553
Pat Len function 551
Pat Match function 553
Pat Not Any function 551
Pat Pos function 551
Pat R Pos function 551
Pat R Tab function 552
Pat Regex function 553
Pat Rem function 552
Pat Repeat function 553
Pat Span function 551
Pat String function 551
Pat Succeed function 552
Pat Tab function 552
Pat Test function 552
patterns of missing data 177
Payment function 595
PDF file, headers and footers 443
peel (delete expression), formula editor 316
percent of total (summary statistics) 343
pictures in columns 254
Pin File 55
platforms
  common features 49
  launch windows 50
Platforms preferences 509
plots and graphs
  annotations, adding 412
  appearances, altering 385
  markers, changing 378
  resizing 385
  shapes, adding 414
  statistics, adding 339
PNG 427, 436
points. See markers
Poisson Distribution function 575
Poisson Probability function 575
Poisson Quantile function 575
polygon (spline) tool 415–416
Portable Network Graphics. See PNG
Post Decrement (--) and Increment (++)
  functions 594
Post-Query Script 121
Pow10 transformation 204
power. See Sample Size and Power
PowerPoint
  image format 495
preferences 491
  Communications 523
file location 492
File Locations 524
Fonts 521
General 492
Graph Builder 510
Graphs 501
JSL Debugger 532
Macintosh OS Settings 520
Menu 533
Platforms 509
Print 512
Query Builder 535
Reports 498
reset 492
SAS Integration 528
Script Editor 526
Styles 504
Tables 506
Text Data Files 513
Windows Specific 517
preselected analysis roles 260
Present Value function 595
presentations, journal 444
Preserve SAS formats 423
Preserve SAS formats when exporting to
  SAS 507
Preserve SAS variable names 423
Preserve SAS variable names when exporting
to SAS 507
Preview Graph preference 506
previewing
  JMP files 60
  text on import 136
Principal Payment function 595
Print Data Grid as is 507
Print preferences 512
printing page breaks 435, 438
Probability functions 560–565
Probit function 561
Product function 579
Profit Matrix column property 248
projects
  automatically open files 450
dragging and dropping files into 449
fix broken link 451

Quantile function 578
quantile statistics 340
Quarter function 585
queries, SQL 133
Query Builder 102–124
  Aggregation function 112
  build the query 108
  building the query 108
  compatibility with JMP 12 110, 536
  computed column 110
  connecting to database 103
  custom expression 119
  editing join conditions 107
  filtering the data 115
  Group By 112
  Open query as a template 122
  preferences 535
  red triangle options 123
  run script after query 121
  sampling the data 114
  SAS 86
  saving query as a template 122
  selecting columns 108
  selecting tables 104
  sorting the data 119
  update from database 122
  view running queries 121
  writing custom SQL 119
quotation marks in imported data 139

Random Beta Binomial function 582
Random Beta function 581
Random Binomial function 582
Random Cauchy function 581
random data, adding 233
Random Exp function 580
Random Frechet function 582
Random functions 580–584
Random Gamma function 581
Random Gamma Poisson function 582
Random Geometric function 582
Random GLog function 583
Random Integer function 581
Random Johnson Sb function 581
Random Johnson Sl function 581
Random Johnson Su function 581
Random LEV 583
Random Logistic function 583
Random Loglogistic function 583
Random Lognormal function 583
Random Negative Binomial function 582
Random Normal function 580
Random Poisson function 582
Random Reset function 583
random sample (subset) 263
Random Triangular function 581
Random Uniform function 580
Random Weibull function 583
range checking 46, 236
range comparison function 554
ranges, summary statistics 343
Ratio 205
Ratio (reverse order) 206
read-only data 216
rearranging
cells and columns 172
results 434
rearranging toolbars 479
Recent Files (Macintosh) 58
Recent Files (Windows) 55
Reciprocal transformation 204
recoding data 210
rectangle tool (simple shape tool) 414
red triangle icon 352
re-evaluate formulas 38
Refresh the preview when a change occurs 535
Regex function 549
Regex Match function 554
Remove From function 548
Remove function 548
renaming
data tables 215
reports 351
reopening the initial JMP window on startup 494
reordering columns 171
reordering graphics 407
Index
Using JMP

Repeat function 548
Replace argument 545
replacing
tables (when sorting) 267
values in a data table 179
Report Invalid Display Box Messages 497
report windows
customizing 434
dates and times, adding 498
disclosure button 351
formatting 349
options 352
order of data 239–240
rearranging results 434
red triangle icon 352
renaming 351
saving 426
tables 368
reports
changing format 368
preferences 498
rerun formulas 38
Resample Freq function 584
Reset file associations 520
reset preferences 492
resizing
columns and rows 170
graphs 385
windows 352
restricting search to selected rows or columns 180
Reverse function 549
Reverse Into function 549
reverting columns to original order 171
rich text format. See RTF
Right function 547
roles
design roles 243
preselected analysis roles 260
root button, formula editor 315
Root function 541
Rotate image 410
Round function 540
row editor 181
Row functions 538–540
Row menu options, launch window 208
row state
clearing 196
coloring rows by column values 189
columns 231–232
data types 225, 232
Row State functions 587–589
rows
adding 154
characteristics 187
coloring 189
deleting 154
excluding 174
excluding and hiding 173
hiding 175
inverting selected 44
joining 282
labeling 188, 383
legends 383
markers 189
menu items 45
moving 172
order of data in reports 240
resizing 36, 170
selecting 158
sorting in data tables 265
subsetting 262
summarizing 338
transposing 275
rows panel 41
RTF (Rich Text Format) files 427
Run 536
Run on Open 122
Run the preview update in the background 536
S
sample the data, Query Builder 114
Sampling in databases 127
SAS
browsing data sets 87
connecting
local machine 86
Metadata Server 82
SAS mid-tier environment 85
Workspace Server 84
creating transport files 80
exporting data tables 100
extended attributes 80, 95, 423, 599
generating ODS results 99
importing data sets 78, 90
importing password-protected data sets 95
importing variable labels 530
ISO date formats 78
Query Builder 86
running stored processes 96
saving data table as transport file 422
saving in SAS format 423
submitting code 97
transport files 422
variable names 78
SAS 9.3 preferences 529
SAS Integration preferences 528
SAS metadata server, automatically connect 530
SAS metadata server, supported version 81
SAS server version 85
SAS Server Version preference 529
Save and restore document state information, in script editor 527
Save and Save As menu items 418
Save Data Table Columns GZ Compressed 496
Save Data Table Columns GZ Compressed preference 38
Save Journals GZ Compressed 496
Save Session Script 446
Save the session when exiting 497
saving
column property 242
data table as CSV file 420
data table as SAS data set 423
data table as text file 421
data table to database 424
data tables 418
log windows 451
report as Adobe Flash file 433
report as interactive HTML 428
report as PowerPoint file 431
reports 426
reports as graphics 436
results to a database 424
scripts 434
scripts in English 496
scripts to a data table 218
SQL queries 133
Unicode 496
saving and evaluating formulas (when concatenating tables) 279
Scalable Vector Graphic format 436
scaling a graph 386
scaling axes 389
Scheffe Cubic function 543
Script All By-Groups menu 354
script editor
auto-complete parentheses and braces 527
extra space at bottom of document 527
indent guides, showing 527
line numbers, showing 527
operator tips, showing 527
preferences 526
spaces in operator names 528
spaces inside parentheses 528
tab width 526
use tabs 526
variable value tips, showing 527
scripts. See JSL scripts
scroll lock/unlock 196
scrolling axes 389
searching for values 179
Second function 585
Select Dominant 159
Select Individual Excel Worksheets preference 494
Select Randomly 159
SELECT statement (SQL) 129
Selected function 589, 592
Selected State function 588, 591
selecting
cells 159, 162, 168–169
irregular area of points 377
marker types 384
parts of a report 350
points in plots 376
rectangular area of points 376
rows and columns in data tables 161–168
rows and columns in plots 376
selecting JSL in editor 527
selection (large plus) cursor 45
sequence data, adding 233
Sequence function 538
sessions, saving 445
SEV Density function 571
SEV Distribution function 571
SEV Quantile function 571
Shade Alternate Table Rows 505
Shade State function 588, 591
Shade Table Cells 505
Shade Table Headings 505
Shift function 549
Shift Into function 549
Short Date function 586
short, allowing short numeric 227, 507
shortcuts, keyboard 333
short-integer format 507
Show Alternate Column Name 508
Show conditional formatting 500
Show embedded log on script window open, in
script editor 527
Show indent guides, in script editor 527
Show line numbers, in script editor 527
Show log warnings for JSL compatibility
changes 495
Show menu tips 495
Show on the Windows task bar 519
Show operator tips, in script editor 527
Show SAS Log 531
Show the thumbnail panel 519
Show Tree Structure 350
Show variable value tips, in script editor 527
showing the toolbar 479
Sigma, assigning values 244
simple shape tool (oval or rectangle) 414
simplify formulas 322
Sine function 543
SinH function 544
sizing a graph 386
sizing/scaling 389
slope computation 329
sorting
data tables 265
list check 265
order 267
results by fields in a database (SQL) 130
value labels 265
value ordering 265
Source Flag column 284
Source Label Column 270
Spaces in operator names, in script editor 528
Spaces inside parentheses, in script editor 528
speed, marker 379, 503
splash window 493
Split By column 273
Split Label Col 272
splitting columns 272
SPSS files, importing 145
SQL database
build a query 102
syntax in queries 129
write a query 123
SQL statements 127
Square 204
Square Root transformation 204
Squash function 541
Squish function 205, 541
SSS import 146
stacking columns 267
Standard Deviation 343
Standard Deviation function 578
Standard Error 343
standardizing attributes 258
submit SAS code 97
Subgroups, summary statistics 341
submit SAS code 97
Subqueries (SQL) 132
Subscript function 539
subsetting
from a data table 262
from a histogram 264
Substitute function 549
Substitute Into function 549
Substr function 546
Subtract To (−=) function 593
Sum function 578
Sum Of Years Digits Depreciation function 595
Sum Wgt (summary statistics) 343
summary table, creating 338
Summation function 578
supported version of SAS metadata server 81
suppressing formula evaluation 38, 323
on open 509
when creating a subset 263
when joining tables 284
SVG 427
switch terms button, formula editor 315
synonyms (ORACLE) 127
syntax colors in scripts 528
system tables (ORACLE) 127

t Density function 571
t Distribution function 571
t Quantile function 572
Tab width, in script editor 526
Table Column Borders 505
Table Heading Column Borders 505
Table Row Borders 505
table variables
  adding 217–282
  creating 37, 218
  editing 218
  in formulas 217, 308
  notes 217
Tables preferences 506
tables, in report 368–369
tabs in script editor 526
Tangent function 543
TanH function 544
terms, switching in a formula 315
text
  editing 140
  importing 135
  mode for formulas 324
opening add-ins as text 140
opening text files 134
saving data table as 421
Text Data Files preferences 513
text export preferences 516
text files, saving without Unicode 496
text import preferences 513
Text to Columns 196
threshold of markers 503
Tick marks inside graph frame 505
Time Frequency column property 245
Time of Day function 585
time, adding to reports 498
Tip of the Day window, hiding 493
title bar fonts 522
Titlecase function 546
Today function 584
toolbars
  adding buttons 472
  copy 472
  copying 480
  create 472
  deleting 483
  File_Edit toolbar 472
  hidden 479
  personalizing (Macintosh) 486–487
  rearranging 479
  show and hide 484
  showing by default 519
toolbars and menus, personalizing
  (Windows) 470–486
Transcendental functions 540–543
Transform menu options, launch window 204
transforming columns 204
translating toolbar and button captions 474
transparency, markers 381
transport files, creating 80
transposing rows and columns 275
treat empty columns as numeric 515
Trigamma function 542
trigonometric function types 543
Trim function 546
Triple-S import 146
truth tables 559
Tukey HSD P Quantile function 572
Tukey HSD Quantile function 572
two-digit year rule
  importing data 139
  preference in text import 515
two-way table of summary statistics 341

U
unary sign function button, formula editor 316
Underline Table Headings 505
Ungroup command 434
Unicode, save text files preference 496
units, specifying in column 242
univariate statistics 339
Unstructured Text modeling type 226
Update From Database 122
Update from database, Query Builder 122
updating data tables 300
Uppercase function 545
Use a Floating Window for Data Filters 508
Use an Asterisk with the PValue Format 501
Use SPSS Labels for column names during import 495
Use tabs, in script editor 526
Use Thousands Separator 508
Use Triple-S Labels as Headings 495
User Tables, database connections 127

V
validating data 236–237
value labels, sorting 265
value ordering, sorting data 265
values
  high and low for columns (in DOE) 242
  minimum and maximum 392
  ordering 239
variable names 78
variable value tooltips in script editor 527
variables
  local to a formula 310
  table. See table variables
Variance (summary statistics) 343
Vector modeling type 226
vertical, formula display 327
Views, database 127
virtually joining data tables 296

W-Z
Week 207
Week of Year function 585
Weibull Density function 572
Weibull Distribution function 573
Weibull Quantile function 573
weight, preselected roles 260
WHERE clause editor 133
WHERE statement (SQL) 130
While function 560
wildtrack.org 411
Window Background Color 505
Window List (Macintosh) 58
Window List (Windows) 56
Windows Specific preferences 517
windows, hide splash 493
Word and PowerPoint, copy reports into 438
Word function 546
Word. See Microsoft Word
Words function 547
worksheets, selecting 494
Wrap Text, in script editor 527
Wrap the main menu in narrow windows 519
WWW. See Internet
Y-Axis Title Above Graph 502
Year function 585
Year Quarter 207
yellow tag icon 188, 383
zooming 386