New Features in JMP 13

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust

**New Features in JMP® 13**

Copyright © 2016, SAS Institute Inc., Cary, NC, USA

All rights reserved. Produced in the United States of America.

For a hard-copy book: No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, or otherwise, without the prior written permission of the publisher, SAS Institute Inc.

For a Web download or e-book: Your use of this publication shall be governed by the terms established by the vendor at the time you acquire this publication.

**U.S. Government Restricted Rights Notice:** Use, duplication, or disclosure of this software and related documentation by the U.S. government is subject to the Agreement with SAS Institute and the restrictions set forth in FAR 52.227-19, Commercial Computer Software-Restricted Rights (June 1987).


SAS® and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.

SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to http://support.sas.com/thirdpartylicenses.

**Technology License Notices**

- Scintilla - Copyright © 1998-2014 by Neil Hodgson <neilh@scintilla.org>. All Rights Reserved.

  Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation.

  NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL
HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

- Telerik RadControls: Copyright © 2002-2012, Telerik. Usage of the included Telerik RadControls outside of JMP is not permitted.
- Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.
- Packages - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
  Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- iODBC software - Copyright © 1995-2006, OpenLink Software Inc and Ke Jin (www.iodbc.org). All rights reserved.

  Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
  – Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  – Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
– Neither the name of OpenLink Software Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• bzip2, the associated library “libbzip2”, and all documentation, are Copyright © 1996-2010, Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


• MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a
list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.

- **libopc** is Copyright © 2011, Florian Reuter. All rights reserved.
  Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
  
  - Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  
  - Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  
  - Neither the name of Florian Reuter nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- **libxml2** - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar licence but with different Copyright notices) all the files are:

  Copyright © 1998 - 2003 Daniel Veillard. All Rights Reserved.

  Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

  The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

  THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

• Regarding the decompression algorithm used for UNIX files:


The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

• Snowball - Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and / or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:

• live and recorded webcasts about how to get started with JMP
• video demos and webcasts of new features and advanced techniques
• details on registering for JMP training
• schedules for seminars being held in your area
• success stories showing how others use JMP
• a blog with tips, tricks, and stories from JMP staff
• a forum to discuss JMP with other users

http://www.jmp.com/getstarted/
## Contents

**New Features in JMP 13**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Enhancements</td>
<td>13</td>
</tr>
<tr>
<td>Dashboards</td>
<td>14</td>
</tr>
<tr>
<td>Data Tables</td>
<td>14</td>
</tr>
<tr>
<td>Databases</td>
<td>16</td>
</tr>
<tr>
<td>Documentation</td>
<td>16</td>
</tr>
<tr>
<td>Formula Editor</td>
<td>17</td>
</tr>
<tr>
<td>Graph Builder iPad Application</td>
<td>17</td>
</tr>
<tr>
<td>Importing Data</td>
<td>18</td>
</tr>
<tr>
<td>Interactive HTML</td>
<td>19</td>
</tr>
<tr>
<td>JMP Starter</td>
<td>19</td>
</tr>
<tr>
<td>Preferences</td>
<td>19</td>
</tr>
<tr>
<td>Query Builder</td>
<td>20</td>
</tr>
<tr>
<td>Script Editor</td>
<td>21</td>
</tr>
<tr>
<td>Static HTML</td>
<td>21</td>
</tr>
<tr>
<td>Tabulate</td>
<td>21</td>
</tr>
<tr>
<td>Transform Columns</td>
<td>21</td>
</tr>
<tr>
<td>Windows Enhancements</td>
<td>22</td>
</tr>
<tr>
<td>Automation on Windows</td>
<td>23</td>
</tr>
<tr>
<td>Basic Analysis</td>
<td>23</td>
</tr>
<tr>
<td>ANOVA</td>
<td>23</td>
</tr>
<tr>
<td>Bootstrapping</td>
<td>24</td>
</tr>
<tr>
<td>Distribution</td>
<td>24</td>
</tr>
<tr>
<td>Explore Missing Values</td>
<td>24</td>
</tr>
<tr>
<td>Explore Outliers</td>
<td>24</td>
</tr>
<tr>
<td>Fit Y By X</td>
<td>24</td>
</tr>
<tr>
<td>Oneway</td>
<td>24</td>
</tr>
<tr>
<td>Simulate</td>
<td>25</td>
</tr>
<tr>
<td>Text Explorer</td>
<td>25</td>
</tr>
</tbody>
</table>
New Features in JMP 13

Graphing .......................................................... 25
  Bubble Plot .................................................. 25
  Graph Builder ............................................... 25
  Scatterplot 3D ............................................... 26
  Treemap ...................................................... 26
Profilers .......................................................... 27
DOE ................................................................. 27
  Compare Designs ........................................... 28
  Definitive Screening Designs ......................... 28
  Space Filling Designs .................................... 28
Fitting Linear Models ......................................... 28
  Generalized Linear Models ............................. 28
  Generalized Regression .................................. 28
  Logistic Regression with Nominal or Ordinal Variables .......................... 30
  Mixed Model ................................................ 30
  Nominal and Ordinal Logistic ......................... 30
  Standard Least Squares ................................ 30
  Stepwise ..................................................... 31
Predictive and Specialized Modeling ....................... 31
  Explore Outliers ......................................... 32
  Formula Depot ............................................ 32
  Gaussian .................................................... 32
  Make Validation Column ............................... 32
  Naive Bayes ............................................... 32
  Neural ........................................................ 33
  Nonlinear Curve ......................................... 33
  Partition .................................................... 33
  Process Screening ....................................... 33
  Response Screening ..................................... 33
  Time Series ............................................... 33
Multivariate Methods .......................................... 34
  Clustering .................................................. 34
  Discriminant .............................................. 34
  Latent Class Analysis .................................. 34
  Partial Least Squares ................................. 34
New Features in JMP 13

Principal Components ................................................................. 35
Quality and Process Platforms ...................................................... 36
  Control Chart Builder ............................................................... 36
  Process Capability ................................................................. 36
  Variability/Attribute Gauge Chart ............................................. 36
Reliability and Survival ............................................................... 37
  Cumulative Damage ............................................................... 37
  Destructive Degradation ......................................................... 37
  Fit Life by X ........................................................................... 37
  Life Distribution ....................................................................... 37
  Parametric Survival ................................................................... 38
  Reliability Block Diagram ......................................................... 38
  Reliability Growth ..................................................................... 38
  Repairable Systems Simulation .................................................. 38
Consumer Research ....................................................................... 39
  Association Analysis .................................................................. 39
  Categorical ................................................................................ 39
  Choice ....................................................................................... 39
  Cluster ....................................................................................... 40
  MaxDiff ...................................................................................... 40
  Multidimensional Scaling .......................................................... 40
  Multiple Correspondence Analysis ............................................. 40
  Uplift ......................................................................................... 41
Scripting ....................................................................................... 41
  General Enhancements ............................................................. 41
  Application Builder ................................................................. 43
  New Commands ....................................................................... 43
JMP 13 provides several new analysis platforms, additions to existing platforms, and JMP Scripting Language (JSL) enhancements. Updates to other features have also been made.  

*indicates features that are available only in JMP Pro.*

New analysis platforms include the following:

- Association Analysis
- Cumulative Damage
- DOE Compare Designs
- DOE Fit Definitive Screening
- DOE Simulate Responses
- Formula Depot
- Latent Class Analysis
- MaxDiff
- Multidimensional Scaling
- Naive Bayes
- Processing Screening
- Repairable Systems Simulation
- Text Explorer (Analytics are available in JMP Pro)

This document provides highlights of these platforms and other new features.

## General Enhancements

This section describes basic enhancements to JMP on both Windows and Macintosh. For details, see the *Using JMP* book or *Scripting Guide*.

- The Analyze and DOE menus have been reorganized.
- For shrinkwrap JMP, the license expiration date is now displayed on the Help > About JMP (Windows) or JMP > About JMP (Macintosh) window.
• To select more than one column to display in a table box (for example, Parameter Estimates in Fit Model), hold down the Alt key and select the columns.

• You can paste the contents of a hover label into another document. Right-click the label and select Copy. Paste the text into the other document.

Dashboards

This section describes new features and enhancements in dashboards. For details, see the Using JMP book.

• Dashboard Builder provides an interactive way to combine reports into a dashboard, a visual tool that lets you run and present reports on a regular basis. The tool is similar to Application Builder but requires no JSL scripting. Sample dashboards are available in the JMP Samples/Dashboards folder.

• The Combine Windows option in the Window menu enables you to merge open windows into a dashboard. On Windows, Combine Windows is also available in Arrange Menu, an option that is located in the lower right corner of most windows. Options for viewing a summary of statistical reports and adding a selection filter are included.

• For dockable and moveable tabs that contain a single platform, the top-level outline box is included in the tab title. This means that the red triangle options now appear in the title bar of the tabs.

Data Tables

This section describes new features and enhancements in data tables. For details, see the Using JMP book.

• New modeling types are supported. Multiple Response is for cells in a column that contain more than one response value, often separated by commas. Unstructured Text is for data that contains free text. Vector is for Expression columns in which each data cell is a vector of numbers. None is for data that is not included in analyses.

Unless the column is tagged with one of the new modeling type, the type does not show up when you click a modeling type icon in the Columns panel. To access the new modeling types, select the column and then select Cols > Column Info.

JMP automatically assigns the Multiple Response modeling type to data tables saved in JMP 12 or lower. The column must contain the Multiple Response column property.
• You can virtually join data tables to link a main data table to one or more auxiliary data tables. The feature enables the main data table to access data from the auxiliary data tables without physically joining the tables. Virtually joining tables saves memory, because the same data are not replicated in every table that references them. And updating linked data is simpler; linked data can be independently updated in the source table without being updated in the referencing table.

The Reshaping Data chapter in the Using JMP book provides details.

• You no longer have to select an exact number of rows and columns before pasting data into a data table. Now when you click on a cell and paste data, the data fills the cells as needed as long as the data type matches.

• To add a column to a data table, right-click the column before which the column will appear and select Insert Columns. You can also add more than one column this way. Select the number of columns that you want to add, right-click, and then select Insert Columns.

• You can select data table cells and change the color to highlight a specific value. Right-click the cell or cells, select Color Cells, and select a color. If a color is assigned to a cell, right-click and select Clear Color to remove the color.

• In Data Filter, you can reverse the AND and OR behavior of filter groups by selecting Group by AND from the red triangle menu.

• The Columns menu has been reorganized and simplified. You now add new multiple columns by selecting New Columns. The Validation option has been removed. (You can access list check and range check in the Column Properties.) Modeling Type has been removed. (You can change the modeling type by right-clicking a column in the Columns panel in the left data table panel.) The Use Value Label option is unavailable if the column does not have a value label. The Formula option is unavailable if the column cannot contain a formula (as with derived columns). The right-click Cols menu has also been simplified.

• In Split, “Sort by Value Order” is now named “Sort by Column Property”. This option lets you order the columns by a Value Order column property or a Row Order Levels property. If the column has neither property, and the data has an implied order (such as days or months), the implied order is applied.

• Make Indicator Columns in the Cols > Utilities menu provides options to prepend the original column name to the indicator column names.

• The Axis column property now lets you modify the scale, tick and bin increment, label rows, and reference lines through the Axis Column Property window.

• When you select Save Script > To Data Table from a platform’s red triangle menu, you can name the script.

• To run a script in a data table, click the green Run Script button next to the script name, or right-click the script and select Run Script.

• When a data table cannot be sorted in place, you have the option of canceling the sort.
The modeling type of indicator columns added with the Make Indicator Columns utility is continuous rather than nominal.

The Custom option in the Column Info window’s Format menu enables you to define a format for a numeric column. Select Custom, click Set Custom Format, and define the format in the Formula Editor window. This option is also available in the Axis Column Property window.

The Spec Limit column property enforces the relationships between Upper Spec Limit, (USL), Target, and Lower Spec Limit (LSL) values. The USL must always be greater than the LSL. The Target value must be less than the USL and greater than the LSL value.

The Expression column has been added to the Columns Viewer.

---

**Databases**

This section describes new features and enhancements in databases. For details, see the Using JMP book.

- JMP exports Expression columns to database format. When the data are reimported, the Expression column is imported as a Character column. Change the column type from Character to Expression in the Column Info window.
- Dates are maintained as dates (rather than converted to characters) when imported from a SQLite database.
- JMP saves multiple rows in one database call.
- Data types, column names, and column name case are preserved when possible.
- Data tables are exported to a database quicker.
- DATETIME/TIMESTAMP values that include fractional seconds are exported to a database.
- JMP can save to Hive, Impala, and Cloudera.

---

**Documentation**

This section describes major enhancements to the documentation.

- The online Help system has been completely redesigned. The Help provides more detailed search results and runs in your default browser. The same Help system is installed on Windows and Macintosh.
- The Specialized Models book was renamed Predictive and Specialized Modeling to reflect the new menu structure.
Formula Editor

This section describes new features and enhancements in the Formula Editor. For details, see the Using JMP book.

- The Formula Editor has been extensively redesigned to provide a larger area for editing formulas. The editor features a data table columns selector. The functions list is grouped by category and can be filtered. You can open formulas in a maximized script editor window. In addition, multiple undos are supported.
- The new **Max matrix size to show** red triangle option lets you specify the dimensions of matrices to draw.
- Pressing Ctrl (Command on Macintosh), pressing Shift, and clicking affects only the selection in the Columns list, not a selected cell in the formula. Previously, the key combination selected only one column and replaced the selected cell in the formula.
- Pressing Alt (Option on Macintosh) and clicking a column replaces both empty and non-empty selected fields with that column. Pressing Alt (Option on Macintosh) and clicking a function replaces the selected function, not the entire selected field.
- Pressing Alt and Shift and then clicking the local variable or parameter edits the item in place instead of displaying an edit window.
- The right-click menu for the Columns list has two new items: **Replace all occurrences of selected subexpression**, replaces all occurrences of the selected expression with the currently selected column. **Replace the selected subexpression with columns**, replaces the selected expression with multiple columns (formerly Shift + Click) for functions that support it (for example, Sum or Plus).

Graph Builder iPad Application

This section describes new features and enhancements in the Graph Builder iPad application. For details, see the Using JMP book.

- You can import CSV, XLS, and XLSX files into the Graph Builder iPad application.
- The Map Role column property is supported. The main data table, -XY.jmp, and -Name.jmp data tables must be in your workspace in the Graph Builder application.
- Fill patterns are supported.
- You can import files from Dropbox, Google Drive, Box, One Drive, and Cloud Files.
Importing Data

This section describes new features and enhancements in importing data. For details, see the Using JMP book.

- **JSON data** can be imported and exported.
- **Hierarchical Data Format, Version 5 (HDF5)** files can be imported. JMP handles only tables with numeric (integer, float, double) and string types, and compound files with three or fewer dimensions that contain only simple types.
- The **Create Excel Workbook option** in the View menu enables you to save multiple JMP data tables in a single Microsoft Excel workbook.
- The Excel Import Wizard applies stricter rules to determine which columns to import as character or numeric columns.
- The Excel Import Wizard includes options for importing cell coloring, specifying separators in multiple-row headers, stacking data, and duplicating headers in spanned rows.
- The following ISO date formats are supported for imported SAS data: B8601DA, B8601DN, B8601DT, B8601DZ, B8601LZ, B8601TM, B8601TZ, E8601DA, E8601DN, E8601DT, E8601DZ, E8601LZ, E8601TM, E8601TZ.
- When JMP finds an integer in a text file that is greater than 9,007,199,254,740,991, the column is considered character data on import.
- The **Use Regional Settings option** in the Text Data File preferences enables you to control whether JMP uses your operating system’s regional settings when importing a text file. If the Use Regional Settings is deselected (the default value), files that use a period for a decimal point and a comma for the value separator import correctly. If the file uses a comma for a decimal point and some other separator character, and your regional settings use a comma for a decimal point, then selecting the option and specifying the value separator imports the text correctly.
- To import text from a script window and first show it in the Text Import Preview window, hold down the Shift key and select **File > Import As Data** (Windows) or **Edit > Import as Data** (Macintosh).
- When you import SPSS files into JMP, missing values are included in the Missing Value Codes column property for the appropriate variable. Missing value ranges of up to 20 numbers are supported.
- When you import a SAS Transport file, the variable name is saved as a SAS Name column property. The label is saved as a SAS Label property.
- The **Internet Open Timeout preference** on the General preference page applies to opening web pages with the Internet Open feature. JMP waits the specified number of seconds before stopping the import due to an error. 60 seconds is the default value.
Interactive HTML

This section describes new features and enhancements in interactive HTML. For details, see the *Using JMP* book.

- Most popular Graph Builder features are supported in interactive HTML, including points, smoothers, ellipses, lines, bars, areas, box plots, histograms, heatmaps, mosaic plots, caption boxes, and map shapes.
- Pictures stored in an Expression column are displayed in interactive HTML hover labels.
- In interactive HTML profilers, you can edit X values formatted as dates, times, date-times, durations, or geographic.
- In interactive HTML profilers for constrained models, you can simultaneously apply edits to X values by clicking the Apply button.
- The View > Create Web Report option creates a web page in which reports, descriptive text, and graphics are displayed. You can zip the files and send them to another user.
- Support for interactive HTML profilers was added to the Generalized Regression, Generalized Linear Model, and Neural platforms.

JMP Starter

This section describes new features and enhancements in the JMP Starter.

- The JMP Starter has been redesigned, and a JMP Pro page has been added to highlight JMP Pro platforms and features.

Preferences

This section describes new features and enhancements in the preferences. For details, see the *Using JMP* book.

- Open data tables, journals, reports, and scripts are autosaved at regular intervals when the Autosave Timeout preference is set on the General page. If the number of rows or columns exceed the number specified in the Autosave Maximum Data Table Rows and Autosave Maximum Data Table Columns preferences, data tables are not autosaved. The Script Editor preferences also include an option to autosave any submitted JSL before it is run.
- On the Platforms page, the Automatic Recalc preference has been added for platforms that support automatic recalc.
Query Builder

This section describes new features and enhancements in Query Builder. For details, see the Using JMP book.

- There is now a Query Builder for joining and querying JMP data tables. Open JMP data tables and then select **Tables > JMP Query Builder** to begin building a query. JMP Query Builder has the same features as Query Builder for ODBC data sources, but it is specifically for JMP data tables.

- When you add a filter for a large column of categorical data, JMP attempts to determine the number of rows in the table.
  
  - The Query Builder preference called **Retrieve category levels for tables whose size cannot be determined** is selected by default so that JMP automatically retrieves the levels. If you deselect the preference, the Contains fallback filter type in the Query Builder preferences is selected.
  
  - If the categorical column has more than 1 million rows, JMP does not automatically retrieve the unique category levels for the filtered column. The Query Builder preference called **Maximum rows in table for which category levels will be automatically retrieved** supports a minimum of -1 (no limit) and a maximum value of 1 billion rows.

- Categorical filters can now be set as Conditional using the red triangle menu. A categorical filter that is marked Conditional will only list values from rows that satisfy other filter criteria for the same table that come before it in the Filters panel.

- First N row and Random N row sampling are supported for SQLite.

- The MEDIAN Aggregation option is supported for Oracle databases.

- The List Box, Manual List, and Check Box List filters include a **Not in list** option that enables you to retrieve rows that do not match the selected values. For the Match Columns Values filter, this option is called **Select non-matching**.

- The Simple Comparison and Range filters have been added for categorical columns.

- The Manual List filter enables you to enter the names of the filtered columns.

- The following preferences control the default filter type for categorical columns:
  
  - **Default filter type for categorical columns** specifies a List Box as the default filter type for categorical columns.
  
  - **Fallback filter type for categorical columns** specifies a Contains filter as the default filter type when the number of rows cannot be determined or the query is canceled.

- If you are using JMP 13, but you need to create queries that still run in JMP 12, select **Keep this query compatible with JMP 12** in the Query Builder Preferences. After you select the option, features that create compatibility problems are hidden in Query Builder.
• When you import a table that contains a primary key, the Link ID column property is added to the column in the data table. The column property enables you to virtually join data tables.

• For JMP Query Builder, a set of SQL functions has been defined for use in a computed column (for example, YEAR and DATEDIFF). See Appendix A in the JSL Syntax Reference for a complete list.

• To edit a computed column, right-click the column and select Edit Formula.

• “<Blank>” in the filter list indicates that the database contains an empty value for that column.

**Script Editor**

This section describes new features and enhancements in the Script Editor. For details, see the Using JMP book.

• The Script Editor preferences provide options to change the font and colors in the script editor window.

**Static HTML**

This section describes new features and enhancements in HTML output. For details, see the Using JMP book.

• The design of static HTML web pages is more consistent with Interactive HTML.

**Tabulate**

This section describes new features and enhancements in Tabulate. For details, see the Basic Analysis book.

• The new Geometric Mean statistic provides the $n$th root of the product of $n$ numbers. The statistic is also available in Graph Builder.

**Transform Columns**

This section describes new features and enhancements in transform columns. For details, see the Using JMP book.

• In the Row menu, Lag returns the value in the previous row for the selected column. Multiple Lag creates multiple columns, each with a different lag offset.
• The Sample without Replacement option in the Row menu shuffles the values randomly each time it’s evaluated. Sample with Replacement generates a random integer.

• The Aggregate menu provides a Quantile option. Select the option and specify the percentage to calculate the quantile for the column.

• The Moving Average option in the Row menu calculates the exponentially weighted moving average, EWMA (using a smoothing parameter between 0 to 1.0) for each value in the selected column.

• The Day of Week option in the Date Time menu returns the day of the week for the date in the selected column.

Windows Enhancements

These features are available on Windows. For details, see the Using JMP book.

• You can use a .jmpquery file as a starting point for a new query. Right-click a .jmpquery file in the JMP Home Window Recent Files list and select Edit a Copy.

• 600 and 1200 DPI are new options when you select a portion of a report and save it as a graphic.

• When you save a data table as a Microsoft Excel file, the file opens in the default spreadsheet program. To avoid opening the spreadsheet, deselect Open after save when saving the file.

• You can search for recently opened files in the Windows Home Window. You can also search for recently opened files from any JMP window on Windows by pressing Alt, Shift, O, and then entering the filename.

• If you manually resize the window and want to automatically resize it again, hold down the Ctrl key and click the bottom right corner of the window.

• In the Home Window’s Recent Files list, you can remove files that are no longer in the same location by right-clicking and selecting Remove Missing Items. If the menu item is not available, there are no missing items in the list.

• To display text from the script editor in the Text Import Preview window on Windows, hold down the Shift key before you select File > Import as Data.

• On Windows, English language and support files are installed by default. If you do not select other languages when installing JMP, those languages will not be available. Rerun the JMP installation program, select Modify, and select the languages as desired.

• You can view large icons in the Recent Files list on the Home Window. Right-click in the Home Window and select Large Icon View or click the Change Icon Size in the Recent Files pane.

• JMP is optimized to work with High Contrast Black color themes.
Automation on Windows

- The following Windows Automation methods have been added:
  - Bivariate: FitRobust, FitCauchy; FitLoessWeightConstants; Kernel Smoother
  - Cluster: ParallelCoordPlots, ScatterplotMatrix; ClusterCriterion, ClusterSummary, ConstellationPlot
  - Control Chart: LaunchAddPhase, LaunchRemovePhase
  - Data Table Join: SetJoinMergeColumns
  - Discriminant: ScatterplotMatrix
  - Distribution: SetQuantileIncrement
  - Logistic: RateCurve
  - Matched Pairs: SignTest; SetAlphaLevel
  - Multiple Correspondence Analysis: See the Automation Guide, Multiple Correspondence Analysis section, for a complete list of new methods.
  - Multivariate: CorrelationProbability, CIofCorrelation
  - One way: FitRobust, FitCauchy
  - Partial Least Squares provides new methods for the fully featured Partial Least Squares platform. See the Automation Guide, Partial Least Squares section, for a complete list of new methods.
  - Scatterplot Matrix: ShowCorrelations, ShowPoints, FitLine, NonParDensity; EllipseTransparency
  - Text Explorer. See the Automation Guide, Text Explorer section, for a complete list of new methods.

Basic Analysis

This section describes new features and enhancements in the general analysis platforms. For details, see the Basic Analysis book.

ANOVA

- In the LSMeans Differences Tukey HSD table, there are always at least 15 total letter columns in the Connecting Letters Report. Previously, reports with more than six letters were not completely displayed.
**Bootstrapping**

- Bias-corrected (BC) confidence intervals are now reported in the Distribution report for bootstrap results.
- The split bootstrap results table now contains a Distribution table script, which you can run to see the bootstrap analysis results.
- The pre-split bootstrap results table has a Value Ordering column property. Columns in the split bootstrap results table appear in the same order as in the table that was bootstrapped.
- You can specify the random seed in the Bootstrapping options window.

**Distribution**

- The Test Equivalence option that uses the Two One-Sided Tests (TOST) approach has been added to Distribution. The test determines whether the input target (hypothesized mean) is equivalent to the estimated mean.
- Distribution supports multiple response variables.

**Explore Missing Values**

- Explore Missing Values supports Validation columns.

**Explore Outliers**

- Explore Outliers supports By groups.

**Fit Y By X**

- When the response is binary and has a nominal modeling type, a Target Level menu appears in the launch window. Use this menu to specify the level of the response whose probability you want to model.

**Oneway**

- The Display Options red triangle menu item provides an option to display a legend for Normal Quantile Plot, CDF Plot, and the Densities options.
Simulate

- The Simulate feature provides parametric and nonparametric simulation capability. For example, you can perform parametric bootstrapping and obtain power calculations in nonstandard situations. The Simulate feature is available in many reports, including all of those that support the Bootstrap feature. To access the Simulate feature, right-click in a report.

Text Explorer

- The Text Explorer platform enables you to analyze unstructured text, such as comment fields in surveys or incident reports. The platform treats your data as a bag of words. This enables you to consolidate similar terms, recode misspecified terms, and better understand the underlying patterns in your textual data.

Graphing

This section describes new features and enhancements in the graphing platforms. For details, see the Essential Graphing book.

- The Viridis and Magma color themes are available.
- For gradient color in a map or graph, you can change the range of intensity in the Gradient Settings window.

Bubble Plot

- You can now specify a frequency variable for weighting computations when aggregating bubbles.

Graph Builder

- On ellipses, selecting the Correlation option shows the Pearson correlation coefficient for the X and Y variables on the graph.
- Latitude and longitude columns are automatically assigned to the corresponding x and y axes.
- The Geometric Mean summary statistic provides the $n$th root of the product of $n$ numbers. Zero, and negative numbers are treated like missing.
- You can specify alpha levels by right-clicking outside the graph and selecting Set $\alpha$ Level. This feature affects regression confidence bands and confidence intervals on summary elements (points, bars, and lines).
- Right-click the Graph Builder title and select Font to change the font family and size.
• A new Parallel element has been added so that you can build Parallel plots in Graph Builder.
• To create a separate axis for several continuous variables, select the variables and then hold Shift when clicking on the axis.
• The Response Axis property is available for Points, Regression, Smoother, Caption, and Formula.
• The Color and Size zones support up to two variables. Drag two variables side-by-side in the appropriate zone.
• Select Inside Left or Inside Right from the Graph Builder red triangle menu to place the legend inside the graph.
• The Connection options for the Line element contains a Centered Step option.
• The following new options have been added to treemaps in Graph Builder:
  – show or hide labels or variables or groups (Tile Labels, Group Labels)
  – show or hide group names (Show Group Name)
  – increase the size of labels (Max Label Size)
  – removes the label if the rectangle is not large enough (Label Threshold)
  – move labels to the right, left, or center (Label Justification)
  – show or hide the borders around rectangles (Show Frames)
  – show or hide color, based on a variable or by coloring all rectangles the same (Implicit Color)
  – filter data in a group by double-clicking on a group title

**Scatterplot 3D**

• Jittering displays small spaces between the data points so that you can see each point more clearly. The option can be turned on and off in the red triangle menu.

**Treemap**

• An image can be displayed in the hover label for a treemap.
Profilers

This section describes new features and enhancements in the Profiler platforms. For details, see the Profilers book.

- The Bootstrap Aggregating (bagging) option creates multiple training data sets by sampling with replacement from the original data. For each training set, a model is fit using the analysis platform, and predictions are made. The final prediction is a combination of the results from all of the models. This improves prediction performance by reducing the error from variance.

- The Mixture Profiler supports the direct entry of values without auto-adjustment. Select Reset Factor Grid from the red triangle menu.

- Confidence intervals in profilers are shaded.

- Profilers can model transform variables.

- In the Excel Add-In Create/Edit Model window, the Model list shows only a list of the defined models, and the Model Name now has a separate edit field.

- The simulation experiment workflow has been simplified. To transfer the values from the Gaussian Process profiler to the original profiler, click the Transfer Factor Settings link below the Gaussian Process profiler.

DOE

This section describes new features and enhancements in the DOE platforms. For details, see the Design of Experiments Guide.

- The Fit Definitive Screening menu item in DOE > Definitive Screening provides options for modeling definitive screening designs. The menu item is also in the Analyze > Specialized Modeling > Specialized DOE Models menu. The DOE > Screening Design menu item has been renamed “Fit Two-Level Screening”. This menu item is in the Analyze > Specialized Modeling > Specialized DOE Models menu.

- Most DOE platforms are scriptable, so now the Save Script To Script Window red triangle option is available. Taguchi Arrays, Sample Size & Power, MaxDiff Design, Nonlinear Design, and Compare Designs are not scriptable yet.

- In the Evaluate Design and Augment Design platforms, when interactions terms are added to the Model list, they are not repeated in the Alias Terms list. This prevents double interaction terms from appearing in the Color Map on Correlations.

- For the Prediction Variance Profile report, optimization and desirability options have been moved to the Optimization and Desirability menu.
**Compare Designs**

- The Compare Designs platform enables you to compare designs in a single window.

**Definitive Screening Designs**

- In definitive screening designs, the Model script has been replaced by the Fit Definitive Screening script, which launches the specialized Fit Definitive Screening platform.

**Space Filling Designs**

- Optimization for space filling designs is based on $2 \times n\text{Runs} \times n\text{Factors}/10$ for run sizes greater than $200 \times n\text{Factors} + 1$, where $n$ is the number of runs or factors. Previously, it stopped at $200 \times n\text{Factors}$.

---

**Fitting Linear Models**

This section describes new features and enhancements in the Fit Model personalities. For details, see the *Fitting Linear Models* book.

- The Standard Least Squares, Nominal Logistic, and Mixed Model personalities provide indicator parameterization estimates with standard errors and $t$ tests that transform the current sum-to-zero estimates to the indicator estimates. Select *Indicator Parameterization Estimates* from the red triangle menu.

- When the response is binary and has a nominal modeling type, a Target Level menu appears in the launch window for Nominal Logistic, Ordinal Logistic, and Generalized Regression. Use this menu to specify the level of the response whose probability you want to model.

- Fit Least Squares, Nominal Logistic, and Ordinal Logistic display SAS scoring code in a single window.

- Fit Model supports using Multiple Response and Vector columns as indicators.

**Generalized Linear Models**

- A $p$-value column has been added to the Variance Components Report in REML.

**Generalized Regression**

- Generalized Regression includes a two-stage version of forward selection. Forward selection is performed on the main effects. Given those main effects, forward selection is then performed on all of the higher-order effects that involve those main effects.
• The Double Lasso is a two-stage modeling technique: a first lasso pass is done for variable selection and then a second pass of the lasso is done on the variables identified in the first stage. By doing two passes of the Lasso, the Double Lasso can produce better predictions by separating the process of variable selection and shrinkage into each stage.

• Variable selection with censored data for parametric survival problems is supported.

• Cox regression is available in Generalized Regression.

• The Extended Regularized Information Criterion (ERIC) is available for exponential family distributions fit using the Lasso or adaptive Lasso estimation methods.

• In the Save Columns red triangle menu, the Mean Confidence Interval option enables you to save confidence intervals to the data table.

• The Save Simulation Formula option enables you to save a column to the data table that contains a formula that can be used in the Simulate utility.

• Platform preferences and red triangle menu options now exist to give you more control over the output for Generalized Regression models. The new Active Parameter Estimates report shows only the parameters that are nonzero for the specified model.

• When the specified Distribution is Binomial, a confusion matrix, ROC curves, and Lift curves are now available.

• Distribution Profiler, Quantile Profiler, Survival Profiler, and Hazard Profiler are available. Select them from the Profilers red triangle menu.

• When possible, a maximum likelihood fit is produced by default when you launch Generalized Regression interactively.

• The Relaunch with Active Effects option opens a new Fit Model launch window where the Construct Model Effects list contains only the terms that have nonzero parameter estimates (active effects). All other specifications are those used in the original analysis.

• When the specified Distribution is Normal, Standard Least Squares replaces the Maximum Likelihood Estimation method. The estimate used for the standard deviation is the square root of the unbiased estimator of \( \sigma^2 \). When the specified Distribution is Binomial, Logistic Regression replaces the Maximum Likelihood Estimation method.

• Penalized regression methods (Lasso, Adaptive Lasso, Elastic Net, Adaptive Elastic Net, and Ridge) are available for models that specify the No Intercept option.

• The Publish Prediction Formula option in the Save columns red triangle menu returns the script expression and adds it to the Formula Depot Window.

• Ordinal predictors are treated as ordinal, not nominal.

• A Residual By Predictor Plot is available in the Diagnostic Plots red triangle menu.

• Generalized Regression recognizes the Profit Matrix column property for setting the initial probability threshold.

• The number of parameters appears in the Model Summary report.
• The Show Prediction Expression red triangle option enables you to see the prediction formula in the report.
• The Odds Ratios and Hazard Ratios options have been added to the red triangle menu. Odds Ratios in Logistic Regression displays the odds ratios for per unit change in the regressor and for per change over the entire range. Hazard Ratios work similarly but for hazard ratios in Proportional Hazards.
• The Initial Displayed Solution option has been added to the Advanced Options. This option enables you to choose the solution in the comparable model zones that is displayed when the model is fit.
• A Baseline Survival plot has been added to Fit Proportional Hazard.

**Logistic Regression with Nominal or Ordinal Variables**

• An Indicator Parameterization Estimates option gives parameter estimates for the model where nominal columns are coded using indicator (SAS GLM) parameterization. The columns are treated as continuous.

**Mixed Model**

• A \( p \)-value column has been added to the G-Side parameter table.
• An Indicator Parameterization Estimates option gives parameter estimates for the fixed effects based on a model where nominal fixed effect columns are coded using indicator (SAS GLM) parameterization. The columns are treated as continuous.
• New covariance structures are available: Exchangeable, Exchangeable Unequal Variances, Antedependent, Antedependent Equal Variance, Toeplitz, Toeplitz Unequal Variances, and Unequal Variances.

**Nominal and Ordinal Logistic**

• The Publish Probability Formula red triangle option returns the script expression and adds it to the Formula Depot Window.
• Odds ratios are calculated using a Wald statistic if confidence limits are not already calculated. A profile likelihood limit is used only if the likelihood ratio tests are done, the number of parameters for each response is less than 8, and the number of rows is less than 1000.

**Standard Least Squares**

• The Fit Separately option in the Fit Model launch window enables you fit separate models for multiple Y variables in models with only fixed effects.
• In the Studentized Residuals plot, each point on the plot is computed using an estimate of its standard deviation obtained with the current observation deleted. These residuals are also called RStudent or externally Studentized residuals. Select **Row Diagnostics > Plot Studentized Residuals** from the red triangle menu.

• Cox mixture models now work when there are process variables and when there is pseudocomponent coding.

• The Publish Prediction Formula, Publish Standard Error Formula, Publish Mean Confid Limit Formula, and Publish Indiv Confid Limits Formula options in the Save Columns red triangle menu return the script expression and add it to the Formula Depot Window.

• If a Y column is a transform, and the transform is invertible and a function of one variable, then the expression is inverted around that variable. The original Y variable is profiled instead.

• The Replace with Transform and Refit with Transform commands have been added for Box Cox transformations. Replace with Transform enables you to specify the lambda to define a transformed Y variable and then replaces the existing least squares fit with a fit to the transformed variable. Refit with Transform enables you to specify the lambda to define a transformed Y variable and then provides a least squares fit to the transformed variable.

**Stepwise**

• Green and yellow zones were added to the AICc plot. The green zone starts with the best (lowest) AICc and goes up to the lowest plus 4. The yellow zone starts with the lowest plus 4 and continues to the lowest plus 10.

**Predictive and Specialized Modeling**

This section describes new features and enhancements in the advanced Modeling platforms. For details, see the *Predictive and Specialized Modeling* book.

• The Explore Outliers, Explore Missing Values, and Predictor Screening modeling utilities are now platforms with launch windows, By group support, Local Data Filter, Column Switcher support, and scripting. Explore Outliers, Explore Missing Values, and Predictor Screening are in the Analyze > Screening menu. Make Validation Column is in the Analyze > Predictive Modeling menu. Scripting support has been enhanced.

• Naive Bayes, K Nearest Neighbor, Bootstrap Forest, Boosted Tree, Partition, Neural, and Gaussian provide the Publish Prediction Formulas red triangle menu option. This option builds the script expression and adds it to the Formula Depot window. The Formula Depot enables you to generate scoring code from the predictive platforms.

  Boosted Tree, Bootstrap Forest, and Partition also provide Publish Tolerant Prediction Formula, which also saves the script expression to the Formula Depot window.
Note that Naive Bayes, K Nearest Neighbor, Bootstrap Forest, and Boosted Tree are available only in JMP Pro.

- Neural, Partition, Bootstrap Forest, and Boosted Tree display SAS scoring code in one window.
- Partition, Bootstrap Forest, and Boosted Tree provide multi-threading and random seed options in the specifications windows.
- The Decision Matrix shows the misclassification rate if the matrix is symmetric and the labels are the same. This change Partition and all platforms that support Model Comparison.

Explore Outliers

- In Make Validation Column, a feature has been added to group observations that a given group is all in or all out of the validation set. Click Grouped Random and select the columns.

Formula Depot

- The Formula Depot is a repository to organize, compare, profile, and deploy models. Models are saved to the Formula Depot as column scripts. The scripts contain all of the information needed to add the formula to a data table. From the Formula Depot, you can generate score code in C, Python, JavaScript, SAS, or SQL to deploy models in environments outside of JMP.

Gaussian

- You can analyze models that have categorical factors in the Gaussian platform.

Make Validation Column

- Make Validation Column provides an option to set the random seed. Enter the random seed next to Fixed Random.

Naive Bayes

- The Naive Bayes platform classifies observations into classes that are defined by the levels of a categorical response variable. The variables (or factors) that are used for classification are often called features in the data mining literature.
Neural

- You can specify a random seed in the Neural Model Launch control panel to reproduce the assignment of rows to validation sets.
- Neural uses Mersenne Twister random number generators.
- On the Neural launch window, “Missing Value Coding” is now referred to as “Informative Missing”.

Nonlinear Curve

- Two-parameter and four-parameter Probit curves are available in the Sigmoid Curves red triangle menu.
- Parallelism tests are available for Probit curves in the Test Parallelisms red triangle menu.
- Four-parameter Rodbard curves and four-parameter Hill curves are available in the Sigmoid Curves > Logistic Curves red triangle menu.
- Red triangle menu items were added for Actual by Predicted and Residual by Predicted plots.

Partition

- The Gradient-Boosting Trees Specification window provides options for stochastic boosting, using a design table in Multiple Fits, and reproducing results.
- The Prediction Profiler is available in Partition.

Process Screening

- The Process Screening platform enables you to view a large number of processes across time. The platform calculates control-chart, process stability, and process capability metrics, and detects large process shifts. The platform expedites the evaluation of a very large number of processes by enabling you to quickly focus on the processes that are unstable, not capable of meeting specification limits, or subject to shifts in the mean.

Response Screening

- The Data Filter and Column Switcher are supported.

Time Series

- A Mu column has been added to the report. When Intercept is deselected, the column is not provided.
• The interface for entering future values in a transfer function time series model is enhanced. You can interactively change future values in a plot. You can also import future values from a data table.

**Multivariate Methods**

This section describes new features and enhancements in the Multivariate Methods platforms. For details, see the *Multivariate Methods* book.

**Clustering**

• In Hierarchical Clustering, you can specify the wafer shot weight, horizontal size, and vertical size when adding spatial measures.
• Variable clustering is a separate platform. The Cluster Variables platform constructs components that are linear combinations of variables in a cluster of similar variables. The feature now works well with wide data. A Color Map on Correlations red triangle menu option has also been added to show the correlations between variables after clustering.

**Discriminant**

• The Publish Probability Formula red triangle option returns the script expression and adds it to the Formula Depot Window.

**Latent Class Analysis**

• The new Latent Class Analysis platform enables you to find clusters of observations when your data contain unobservable categorical variables. The platform fits a latent class model and determines the most likely cluster or latent class for each observation.
• The Publish Probability Formula red triangle option returns the script expression and adds it to the Formula Depot Window.

**Partial Least Squares**

• The Publish Prediction Formula and Publish Score Formula red triangle options return the script expression and add it to the Formula Depot Window.
• Save X Score Formula has been renamed Save Score Formula. When Ys are continuous variables, Save Score Formula saves both X and Y score formula. When there is Y categorical variable, only the X score formula is saved.
**Principal Components**

- The Publish Components Formulas red triangle option returns the script expression and adds it to the Formula Depot Window.
- A Scatterplot Matrix red triangle menu option has been added to Principal Components.
- The Save Predicteds red triangle menu option saves the predicted variables with a specified number of principal components to new columns in the data table.
- Supplementary loading has been added to the Loading Matrix.
- The Squared Cosines of Variables red triangle menu option shows a matrix that contains the squared cosines of variables. A plot of the squared cosines for the first three principal components is also included.
- The Partial Contribution of Variables red triangle menu option shows a matrix that contains the partial contributions of variables. A plot of the partial contributions for the first three principal components is also included.
- The Save DModX red triangle menu option saves the observation distance to the principal components model (DModX) to a new column in the data table.
- In the Display Options red triangle menu, the Show Supplementary Variable option shows the arrow lines in the biplot and loading for supplementary variables. This option is available only if there is a supplementary variable.
- The scatterplot matrix arranges both the score plots and the loading plots in one space. The score plots have a yellow shaded background. The loading plots have a blue shaded background.
- From the list next to **Select component**, select the principal components that are graphed on the Score Plot and the Loadings Plot.
- Red triangle menu options have been added to Wide and Sparse PCA reports.
- The new Sparse method is useful when your data are sparse, meaning that they contain many zeros. The method can also reduce computational time when there are a large number of columns in the data. Similar to the Wide method, the Sparse method is based on singular value decomposition. Therefore, the algorithm for the Sparse method avoids computing the covariance matrix and is computationally efficient.
- New red triangle options for Score Plot with Imputation and Save Principal Components with Imputation have been added to PCA. These options are not available for the Wide and Sparse methods.
Quality and Process Platforms

This section describes new features and enhancements in the Quality and Process platforms. For details, see the Quality and Process Methods book.

Control Chart Builder

- In Attribute charts, the Use Event Chooser red triangle option re-scores all Y variables present and sets the modeling type (Continuous when off, and Nominal when on). The option is available when you select one or more Y-variables that are both numeric and non-continuous. The option is not available for character variables and non-integer variables.

Process Capability

- The Process Capability platform now computes and plots capability indices for process measurements with the following distributions: Normal, gamma, Johnson, lognormal, and Weibull. A Best Fit option determines the best fit among these distributions based on a user-selected criterion, and provides capability indices for this fit. There is an option to save the distribution used in Process Capability as a column property. The platform also provides a Nonparametric fit option that gives nonparametric estimates of capability.
  
  For the non-normal methods, estimates are constructed using two approaches: the ISO/Quantile method (Percentiles) and the Bothe/Z-scores method (Z-Score).

- Individual Detail Reports show the estimated parameters for the fitted non-normal distributions. The Compare Distributions report enables easy visual comparison of fits.

- A new Capability Index Plot shows Ppk values for all variables, including variables modeled with non-normal distributions.

- Stability ratios, defined as \((\text{overall sigma/within sigma})^2\), are provided for processes for which you have specified a normal distribution.

- The Compare Distributions report enables you to compare the five distributional fits. The Histogram - Compare Distributions report gives a visual assessment of the fit. The Comparison Details report shows fit statistics for the selected distributions.

Variability/Attribute Gauge Chart

- The standard deviation chart and means chart now line up along the X axes, as long as the Y axes labels have the same orientation.

- The coefficient of variation statistic has been added as a hidden column in the Variance Components report.
• Ordinal effects are automatically converted to nominal effects for options that calculate variance components (such as Variance Components, Gauge RR, Discrimination Ratio, Misclassification Probabilities, or Heterogeneity of Variance Tests).
• The Platform preferences for Variability include an option for showing the Gauge R&R Specification Dialog. The preference is selected by default. Deselect the preference to use the specification limits that are defined in the data table.

Reliability and Survival

This section describes new features and enhancements in the Reliability and Survival platforms. For details, see the Reliability and Survival Methods book.

Cumulative Damage

• The Cumulative Damage platform enables you to model cumulative damage models, which include step-stress models. You can analyze an accelerated life test where the stress levels might be changed over time.

Destructive Degradation

• The Cox-Snell probability plot has been added.
• Probability plot of standardized residuals has been added.
• Standardized residual versus time and standardized residuals versus predicted values are available.

Fit Life by X

• The Confidence Interval Method preference enables you to select the Likelihood method as the default confidence interval method. You can change this preference in Preferences > Platforms > Fit Life by X.

Life Distribution

• You can show censored values in probability plots. In the JMP Platform preferences, the Show Markers for Right Censored Observations preference is on by default.
• Right-censored observation plots have been added to the probability plot.
Parametric Survival

- The platform supports four additional location-scale distributions: Normal, Logistic, SEV, and LEV. To include all location scale distributions in All Distributions, select the Fit Parametric Survival preference called **Include location-scale distributions in All Distributions**.

- Click the **Variable Selection using Generalized Regression** link in the Parameter Estimates report to launch the Generalized Regression platform. This link is available when there are no scale effects; the platform is not embedded (for example, Competing Cause); and the distribution is lognormal, normal, or Weibull.

- The Parametric Survival report provides Distribution Overlay and Quantile Function Overlay plots when there is no Cause and when All Distributions is selected on the launch window. Select the corresponding red triangle menu items to show or hide the plots.

Reliability Block Diagram

- The Reliability Block Diagram platform produces a component reliability functions plot.

Reliability Growth

- All models except Fixed Parameter Crow-AMSAA report an estimate of the Covariance Matrix.

- Two new analysis types have been added to analyze concurrent prototypes and parallel prototypes. The concurrent prototypes are running simultaneously while design changes are incorporated in all prototypes concurrently. And the corresponding analysis regards the reliability growth of the combined system. The parallel prototypes are independent, and the corresponding analysis regards the similarities and differences of their reliability growth patterns.

Repairable Systems Simulation

- The Repairable Systems Simulation (RSS) platform enables you to explore the reliability within complex repairable systems. The RSS platform enables you to simulate different system configurations to optimize your repairable system.
Consumer Research

This section describes new features and enhancements in the Consumer Research platforms. For details, see the Consumer Research book.

Association Analysis

- The new Association Analysis platform enables you to analyze transaction data (also called market baskets). Grocery stores or online merchants can use the analysis to enable them to advertise products that are often bought together.

Categorical

- The Rao-Scott correction is applied only when at least one off-diagonal overlap count is greater than 0.
- To display the rate of response per case (excluding missing values), select Rate per Case Responding from the red triangle menu. The frequency of response divided by the total cases responding is displayed in the table.
- When Mean Score Comparison is selected, $t$ tests are unpooled. The Aspin-Welch-Satterthwaite-Student $t$ test has been implemented.
- The Free Text feature is replaced by the Text Explorer platform.
- JMP applies a correction for the means comparison with overlapping samples in the Repeated Measures response type. The correction is implemented according to the formula for overlapping samples documented in Survey Sampling by Leslie Kish, section 12.4.

Choice

- The Choice platform remembers baseline values and assigned roles from previous Willingness to Pay calculations so that you can do multiple Willingness to Pay comparisons with less work. If there is no factor called Price, but there is a continuous factor used in the analysis, the continuous factor is automatically assigned as the Price factor in the Willingness to Pay window.
- Delta-method confidence limits and standard errors have been added to Willingness to Pay calculations. This means that confidence limits are available only if Price is not included in an interaction or squared effect. A note is printed in the report when confidence limits are unavailable.
- The Profiler, Willingness to Pay report, and Comparison report detect effects that are interaction-only and disallow setting them to different levels across products.
- Subject-specific factors using Bayes calculations have been added. Select Bayesian Subject Effects on the launch window.
• You can compare levels of factors by selecting the Comparisons red triangle menu item and specifying the factors.

• Options in the Utility Comparison window have been updated. Subject effects can be set only once.

• The Choice platform allows respondents not to make a choice from among a set of profiles. The no choice option is treated as an attribute that respondents are allowed to select. No choice profile sets are identified by missing values.

• The Effect Summary report appears if your model contains more than one effect and if it can be calculated quickly. (If the report does not appear, select Likelihood Ratio Tests from the red triangle menu to make both reports appear.) It lists the effects estimated by the model and gives a plot of the LogWorth (or FDR LogWorth) values for these effects. The report also provides controls that enable you to add or remove effects from the model. The model fit report updates automatically based on the changes made in the Effects Summary report.

Cluster

• The new Analyze > Clustering menu provides access to Hierarchical Cluster, K Means Cluster, Normal Mixtures, and the Latent Class Analysis platforms. Note that Robust Normal Mixtures and SOM are still available from the KMeans report window.

MaxDiff

• The MaxDiff platform fits a discrete choice model to data that result from a single-factor MaxDiff experiment. The platform provides an alternative to standard preference scales to determine the relative importance of items being rated.

Multidimensional Scaling

• The Multidimensional Scaling platform enables you to create a visual representation of the pattern of proximities (similarities, dissimilarities, or distances) among a set of objects. For example, given a matrix of distances between cities, you can generate a map of the cities in two dimensions.

Multiple Correspondence Analysis

• Selecting a point in the correspondence analysis plot also selects the corresponding rows in other tables in the report window. However, rows in the data table are not selected. To select all of the points in the plot associated with a particular variable, select the name of the variable in the plot legend.
• You can specify a Supplementary ID variable on the launch window. A supplementary ID column usually has 1s and 0s. The rows associated with ID 0 are treated as supplementary rows.
• A new bar chart enables you to view partial contributions to inertia for the column points.
• Cochran’s Q Test is available in Multiple Correspondence Analysis.

**Uplift**

• Uplift provides the Publish Prediction Formulas red triangle menu option in Save Columns. This option builds the prediction formula and adds it to the Formula Depot window.

**Scripting**

This section describes new features and enhancements in the scripting area. For details, see the Scripting Guide and JSL Syntax Reference books.

**General Enhancements**

• The performance of list operations has been significantly improved.
• The computer does not go into sleep mode when a JSL script is running.
• On Windows, `Mail()` works on 32-bit and 64-bit computers.
• Press Control+M to reformat a script on Windows.
• The `$DOWNLOADS` path variable refers to the user’s default downloads directory.
• You can open and save C++, Python, and standard SQL files in the script editor. Syntax coloring is supported.
• When you use `Show()` to show an item that points to a display box, the class of the display box is returned, as in `DisplayBox[OutlineBox]`.
• The derivative for `Summation()` can be calculated with `Derivative( Summation() )`.
• The `Covariance()` function supports `Freq(vector)` and `Weight(vector)` messages.
• On Windows, the window produced by `Pick Directory()` has been enhanced.
• The `ValueSpace( Boolean )` message for `Line()` draws lines that follow the projection when the line represents a movement of the underlying data, such as in a bubble trail in a bubble plot.
• Script Editor preferences for changing syntax coloring and fonts in JSL scripts, the log, and other files are available.
• Data table can be subscripted like matrices as in `dt[row, col]` or `dt[row1::rowN, {col list}]`. 
• To specify which values to exclude in a data filter script, use the `! =` operator.
• You can resize `Web Browser Box()` by sending `<< Set Max Size( n, n )` and `<< Set Auto Stretching( 1, 1 )` to the display box.
• When `Set Selectable Rows()` is specified in a `Table Box()`, the up and down keyboard arrows move between the rows in the table box.
• The `HTML Table()` argument of the `Open()` function lets you specify the table row that holds the column names and the row that begins the data. Many HTML tables use the `<th>` tag to define the row that contains the column names. If the `<th>` tag is wrong or missing, use `Column Names(n)` to specify the nth row. By default, `Data Starts(n)` will be the next row, or you can specify the `Data Starts` row.
• `Col Quantile()` supports a By argument.
• JSON files can be imported with the `Open()` function and exported with the `Close()` function. JSON files can also be read into a list using the `JSON To List()` function.
• The `Minimize()` and `Maximize()` functions let you input analytical gradients and Hessians; request details such as number of iterations, gradient, and Hessian at the final step; display step-by-step optimizer output in the log; turn off the analytical derivative calculator; and choose the optimizer method Newton-Raphson or Symmetrix Rank-One.
• The comparison function of `Is Missing()` is supported in an Expression column.
• `Col Cumulative Sum()` returns the cumulative sum for the current row. `Col Moving Average()` returns the moving average over a given interval based at the current row. By variables do not need to be sorted.
• `Matrix Box()` supports the `Make Combined Data Table` message for making a data table from all similar matrices.
• `Product()` and `Summation()` support matrices and lists.
• You can manipulate display box children with `Insert Into()`, `N Items()`, `Remove From()`, `Reverse Into()`, and `Shift Into()`.
• In Bubble Plot and Graph Builder scripts, set the `Fit to Window` message to "On" to resize the window when you resize the graph in `Tab Box()`.
• In a Fit Group script, if a fit is already in a Fit Group and `Order by Goodness` is included, JMP uses the existing Fit Group for each level of the By variable instead of creating a new Fit Group.
• `Close All( invisible|private )` closes all invisible or private data tables.
• `Col Rank()` supports a By argument.
• In the JSL Debugger preferences, `Break for Compatibility Warnings` is a new option that stops executing the script when a potential JSL compatibility issue is found. The Debugger stops only once for each potential problem in the script when the option is on. If there are many occurrences in the script, and you determine that they are not a problem, you can turn the option off. The preference is selected by default.
• When you use a 1x1 matrix as a subscript into a matrix or list, now the result is a matrix or a list instead of a scalar number.
• In the Help > Scripting Index, list functions are organized in the new List group.

Application Builder

• Source scripts are used to create tables when possible. The source script must contain `DataTable(...) << Concatenate(...) or New SQL Query(...) << Run(), New SQL Query(...) << Run Foreground(), New SQL Query(...) << Run Background(), or Open(...)`. Change the Location to Full Path or Name if you prefer to reuse the existing data table instead of creating a new data table.

When a data table with a source script is added, you are prompted if the source script includes one of the preceding commands and the table has been saved.

New Commands

• `Random Triangular()` supports three arguments: the lower limit, a midpoint value, and the upper limit. The function is typically used for populations that have a small number of data.
• `Col Cumulative Sum()` returns the cumulative sum for the current row.
• `Col Moving Average()` returns the moving average over a given interval based at the current row.
• To open a preview of a text file to change import options, include the `Text Wizard` argument.

```
Open( "$SAMPLE_IMPORT_DATA/EOF_space.txt", "Text Wizard" );
```
• For `Load Text File()`, the `Base64Compressed(0|1)` argument specifies how the blob is converted to a printable representation. 0, the default and recommended setting, uses JMP’s ASCII–HEX representation. 1 means that the blob is compressed and converted to base 64 when printed.
• `Calendar Box()` creates a pop-up calendar box with selectable dates and times.
• The `User Resizable( width, height )` message enables the user to drag a `Col List Box()`, `FilterColSelector()`, `ListBox()`, `ScrollBox()`, `TextEditBox()`, and `TreeBox()`. Specify a Boolean value to control the width and height resizing.
• `Splitter Box( HSplitter Box() or VSplitterBox() ) and Tab Box() support docking. Tab Page Box() supports moving.
• The `Visibility( "Collapsed" )` message for `Tab Box()` hides the specified tab.
• The `Set Tip` and `Get Tip` messages for `Tree Node()` let you specify and get a tooltip for the node.
• Every display box and display segment includes an `Enabled(Boolean)` option. An object that is enabled responds to keyboard or mouse input.

• The `Set Overflow Enabled(1)` message for `Tab Box()` shows a “^” symbol to the right of a tab list when the list is not wide enough for all titles. You can click this icon to get a list of all tabs open in the tab box.

• `Tab Page Box()` organizes each tab’s content and display boxes into one display box. `Tab Page Box()` can be used alone or inside `Tab Box()`. `Tab Page Box()` can be used to create and interact with individual tab pages directly. (In previous JMP versions, tab pages were sometimes called tab panes, but were not scriptable.)

The new `Set Close` message specifies a script to run when the tab is closed. `Get Close` returns the script. The new `Set Close Tip` specifies the tip for the Close Tab icon. `Get Close Tip` returns the tip.

• `Query()` performs a SQL query on selected data tables, returns the result as a JMP data table object or a single value, and opens the data table.

• The `visibility` argument for `New Table()` determines whether the new data table is shown. `visibility("invisible")` hides the data table from view; it appears only in the JMP Home Window and the Window menu. `visibility("private")` avoids opening the data table. `visibility("visible")` shows the data table. "visible" is the default value.

• `Least Squares Solve()` computes optionally weighted least squares estimates.

• `Constrained Maximize()` finds the values for the listed `x` arguments that maximize the `expr` expression with optional linear constraints. `Constrained Minimize()` finds the values for the `x` arguments that minimize the `expr` expression with optional linear constraints.

• HDF5 files can be imported with the following syntax:

  ```
  Open( "filename.h5", {"list_of", "dataset_names"});
  ```

• `img<<Set Current Frame(n)` sets the frame that shows in a multi-frame TIFF. `img<<Get N Frames` returns the number of frames in a multi-frame TIFF. Previously, only animated GIF files were supported.

• The `Get Base Font`, `Set Base Font`, `Get Font Scale`, and `Set Font Scale` messages are now supported on `Col List Box()`, `Contour Seg()`, `Filter Col Selector()`, `Hier Box()`, `List Box()`, `Number Edit Box()`, `Outline Box()`, `Text Box()`, and `Edit Box()`. If font preferences are changed, or the script is run on a different machine, the font is based on JMP preferences rather than a fixed font size.

• The `Is Enabled` message returns the enabled state of the control. The message is supported in `Busy Light Box()`, `Button Box()`, `Calendar Box()`, `Check Box()`, `Col List Box()`, `Combo Box()`, `Completion Box()`, `Filter Col Selector()`, `gtext()`, `List Box()`, `Number Edit Box()`, `Popup Box()`, `Radio Box()`, `Range Slider Box()`, `Slider Box()`, `Spin Box()`, `Text Edit Box()`, `Tree Box()`, `Tree Map Box()`, and `Tree Map Seg()`.
• **Contains Item**(<x>, <item | list | pattern>, <delimiter>) identifies multiple responses by searching for the specified item, list, pattern, or delimiter. The function can be used on columns with the Multiple Response modeling type or column property.

• The **Varimax()** matrix function does a varimax rotation and returns a list of the rotated matrix and the orthogonal matrix.

• **Get Excel Worksheets**("absolute path") gets a list of worksheets in a Microsoft Excel workbook. The function supports .xlsx and Excel 1997 or later workbooks.

• The **Query Builder Run Foreground** and **Run Background** functions have an **invisible** option. Choose this option to keep the query result hidden while using it in a subsequent query.