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Chapter 1
Learn about JMP

Documentation and Additional Resources

This chapter includes details about JMP documentation, such as book conventions, 

descriptions of each JMP book, the Help system, and where to find other support.
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Formatting Conventions

The following conventions help you relate written material to information that you see on 

your screen:

• Sample data table names, column names, pathnames, filenames, file extensions, and 

folders appear in Helvetica font.

• Code appears in Lucida Sans Typewriter font.

• Code output appears in Lucida Sans Typewriter italic font and is indented farther than 

the preceding code.

• Helvetica bold formatting indicates items that you select to complete a task:

– buttons

– check boxes

– commands

– list names that are selectable

– menus

– options

– tab names

– text boxes

• The following items appear in italics:

– words or phrases that are important or have definitions specific to JMP

– book titles

– variables

• Features that are for JMP Pro only are noted with the JMP Pro icon . For an overview 

of JMP Pro features, visit https://www.jmp.com/software/pro/.

Note: Special information and limitations appear within a Note.

Tip: Helpful information appears within a Tip.

https://www.jmp.com/software/pro/
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JMP Documentation

JMP offers documentation in various formats, from print books and Portable Document 

Format (PDF) to electronic books (e-books).

• Open the PDF versions from the Help > Books menu.

• All books are also combined into one PDF file, called JMP Documentation Library, for 

convenient searching. Open the JMP Documentation Library PDF file from the Help > Books 

menu.

• You can also purchase printed documentation and e-books on the SAS website:

https://www.sas.com/store/search.ep?keyWords=JMP

JMP Documentation Library

The following table describes the purpose and content of each book in the JMP library.

Document Title Document Purpose Document Content

Discovering JMP If you are not familiar 

with JMP, start here.

Introduces you to JMP and gets you 

started creating and analyzing data. Also 

learn how to share your results.

Using JMP Learn about JMP data 

tables and how to 

perform basic 

operations.

Covers general JMP concepts and 

features that span across all of JMP, 

including importing data, modifying 

columns properties, sorting data, and 

connecting to SAS.

https://www.sas.com/store/search.ep?keyWords=JMP
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Basic Analysis Perform basic analysis 

using this document.

Describes these Analyze menu platforms:

• Distribution

• Fit Y by X

• Tabulate

• Text Explorer

Covers how to perform bivariate, 

one-way ANOVA, and contingency 

analyses through Analyze > Fit Y by X. 

How to approximate sampling 

distributions using bootstrapping and 

how to perform parametric resampling 

with the Simulate platform are also 

included.

Essential Graphing Find the ideal graph 

for your data.

Describes these Graph menu platforms:

• Graph Builder

• Scatterplot 3D

• Contour Plot

• Bubble Plot

• Parallel Plot

• Cell Plot

• Scatterplot Matrix

• Ternary Plot

• Treemap

• Chart

• Overlay Plot

The book also covers how to create 

background and custom maps.

Profilers Learn how to use 

interactive profiling 

tools, which enable you 

to view cross-sections 

of any response 

surface.

Covers all profilers listed in the Graph 

menu. Analyzing noise factors is 

included along with running simulations 

using random inputs.

Document Title Document Purpose Document Content
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Design of 

Experiments Guide

Learn how to design 

experiments and 

determine appropriate 

sample sizes.

Covers all topics in the DOE menu and 

the Specialized DOE Models menu item 

in the Analyze > Specialized Modeling 

menu.

Fitting Linear Models Learn about Fit Model 

platform and many of 

its personalities.

Describes these personalities, all 

available within the Analyze menu Fit 

Model platform:

• Standard Least Squares

• Stepwise

• Generalized Regression

• Mixed Model

• MANOVA

• Loglinear Variance

• Nominal Logistic

• Ordinal Logistic

• Generalized Linear Model

Document Title Document Purpose Document Content
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Predictive and 

Specialized Modeling

Learn about additional 

modeling techniques.

Describes these Analyze > Predictive 

Modeling menu platforms:

• Modeling Utilities

• Neural

• Partition

• Bootstrap Forest

• Boosted Tree

• K Nearest Neighbors

• Naive Bayes

• Model Comparison

• Formula Depot

Describes these Analyze > Specialized 

Modeling menu platforms:

• Fit Curve

• Nonlinear

• Functional Data Explorer

• Gaussian Process

• Time Series

• Matched Pairs

Describes these Analyze > Screening 

menu platforms:

• Response Screening

• Process Screening

• Predictor Screening

• Association Analysis

• Process History Explorer

The platforms in the Analyze > 

Specialized Modeling > Specialized DOE 

Models menu are described in Design of 

Experiments Guide.

Document Title Document Purpose Document Content
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Multivariate 

Methods

Read about techniques 

for analyzing several 

variables 

simultaneously.

Describes these Analyze > Multivariate 

Methods menu platforms:

• Multivariate

• Principal Components

• Discriminant

• Partial Least Squares

• Multiple Correspondence Analysis

• Factor Analysis

• Multidimensional Scaling

• Item Analysis

Describes these Analyze > Clustering 

menu platforms:

• Hierarchical Cluster

• K Means Cluster

• Normal Mixtures

• Latent Class Analysis

• Cluster Variables

Quality and Process 

Methods

Read about tools for 

evaluating and 

improving processes.

Describes these Analyze > Quality and 

Process menu platforms:

• Control Chart Builder and individual 

control charts

• Measurement Systems Analysis

• Variability / Attribute Gauge Charts

• Process Capability

• Pareto Plot

• Diagram

• Manage Spec Limits

Document Title Document Purpose Document Content
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Reliability and 

Survival Methods

Learn to evaluate and 

improve reliability in a 

product or system and 

analyze survival data 

for people and 

products.

Describes these Analyze > Reliability and 

Survival menu platforms:

• Life Distribution

• Fit Life by X

• Cumulative Damage

• Recurrence Analysis

• Degradation and Destructive 

Degradation

• Reliability Forecast

• Reliability Growth

• Reliability Block Diagram

• Repairable Systems Simulation

• Survival

• Fit Parametric Survival

• Fit Proportional Hazards

Consumer Research Learn about methods 

for studying consumer 

preferences and using 

that insight to create 

better products and 

services.

Describes these Analyze > Consumer 

Research menu platforms:

• Categorical

• Choice

• MaxDiff

• Uplift

• Multiple Factor Analysis

Scripting Guide Learn about taking 

advantage of the 

powerful JMP 

Scripting Language 

(JSL).

Covers a variety of topics, such as writing 

and debugging scripts, manipulating 

data tables, constructing display boxes, 

and creating JMP applications.

JSL Syntax Reference Read about many JSL 

functions on functions 

and their arguments, 

and messages that you 

send to objects and 

display boxes.

Includes syntax, examples, and notes for 

JSL commands.

Document Title Document Purpose Document Content
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Note: The Books menu also contains two reference cards that can be printed: The Menu Card 

describes JMP menus, and the Quick Reference describes JMP keyboard shortcuts.

JMP Help

JMP Help is an abbreviated version of the documentation library that provides targeted 

information. You can open JMP Help in several ways:

• On Windows, press the F1 key to open the Help system window.

• Get help on a specific part of a data table or report window. Select the Help tool  from 

the Tools menu and then click anywhere in a data table or report window to see the Help 

for that area.

• Within a JMP window, click the Help button.

• Search and view JMP Help on Windows using the Help > Help Contents, Search Help, and 

Help Index options. On Mac, select Help > JMP Help.

• Search the Help at https://jmp.com/support/help/ (English only).

Additional Resources for Learning JMP

In addition to JMP documentation and JMP Help, you can also learn about JMP using the 

following resources:

•

•

•

•

•

•

•

•

Tutorials

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu 

is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, then start with the Beginners Tutorial. It steps you through the 

JMP interface and explains the basics of using JMP.

https://jmp.com/support/help/
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The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment 

and comparing a sample mean to a constant.

Sample Data Tables

All of the examples in the JMP documentation suite use sample data. Select Help > Sample 
Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories, 

select Help > Sample Data.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\JMP\14\Samples\Data

On Macintosh: \Library\Application Support\JMP\14\Samples\Data

In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory. In JMP 

Shrinkwrap, sample data is installed in the JMPSW directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching 

Resources section. To learn more about the teaching resources, visit http://jmp.com/tools.

Learn about Statistical and JSL Terms

The Help menu contains the following indexes:

Statistics Index Provides definitions of statistical terms.

Scripting Index Lets you search for information about JSL functions, objects, and display 

boxes. You can also edit and run sample scripts from the Scripting Index.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for 

using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select 

Help > Tip of the Day. Or, you can turn it off using the Preferences window.

Tooltips

JMP provides descriptive tooltips when you place your cursor over items, such as the 

following:

• Menu or toolbar options

http://jmp.com/tools
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• Labels in graphs

• Text results in the report window (move your cursor in a circle to reveal)

• Files or windows in the Home Window

• Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences > 
General and then deselect Show menu tips. This option is not available on Macintosh.

JMP User Community

The JMP User Community provides a range of options to help you learn more about JMP and 

connect with other JMP users. The learning library of one-page guides, tutorials, and demos is 

a good place to start. And you can continue your education by registering for a variety of JMP 

training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, 

and social networking groups.

To access JMP resources on the website, select Help > JMP User Community or visit 

https://community.jmp.com/.

JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP 

website:

https://www.jmp.com/en_us/software/books.html

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data 

analysis. Options are categorized and described, and you launch them by clicking a button. 

The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and 

File menus. The window also lists JMP Pro features and platforms.

• To open the JMP Starter window, select View (Window on the Macintosh) > JMP Starter.

• To display the JMP Starter automatically when you open JMP on Windows, select File > 
Preferences > General, and then select JMP Starter from the Initial JMP Window list. On 

Macintosh, select JMP > Preferences > Initial JMP Starter Window.

https://community.jmp.com/
https://www.jmp.com/en_us/software/books.html
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Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP, 

many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at https://www.jmp.com/support, including the 

technical support phone number.

https://www.jmp.com/support
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Overview of Modeling Techniques

Predictive and Specialized Modeling provides details about more technical modeling techniques, 

such as Response Screening, Partitioning, and Neural Networks.

• The Modeling Utilities assist in the data cleaning and pre-processing stages of data 

analysis. Each utility has exploratory tools to give you a more thorough understanding of 

your data. See Chapter 3, “Modeling Utilities”.

• The Neural platform implements a fully connected multi-layer perceptron with one or two 

layers. Use neural networks to predict one or more response variables using a flexible 

function of the input variables. See Chapter 4, “Neural Networks”.

• The Partition platform recursively partitions data according to a relationship between the 

X and Y values, creating a decision tree of partitions. See Chapter 5, “Partition Models”.

• The Bootstrap Forest platform enables you to fit an ensemble model by averaging 

many decision trees each of which is fit to a random subset of the training data. See 

Chapter 6, “Bootstrap Forest”.

• The Boosted Tree platform produces an additive decision tree model that is 

composed of many smaller decision trees that are constructed in layers. The tree in each 

layer consists of a small number of splits, typically five or fewer. Each layer is fit using the 

recursive fitting methodology. See Chapter 7, “Boosted Tree”.

• The K Nearest Neighbors platform predicts a response value for a given observation 

using the responses of the observations in that observation’s local neighborhood. It can be 

used with a categorical response for classification and with a continuous response for 

prediction. See Chapter 8, “K Nearest Neighbors”.

• The Naive Bayes platform classifies observations into groups that are defined by the 

levels of a categorical response variable. The variables (or factors) that are used for 

classification are often called features in the data mining literature. See Chapter 9, “Naive 

Bayes”.

•  The Model Comparison platform lets you compare the predictive ability of different 

models. Measures of fit are provided for each model along with overlaid diagnostic plots. 

See Chapter 10, “Model Comparison”.

• The Formula Depot platform enables you to organize, compare, profile, and score 

models for deployment. For model exploration work, you can use the Formula Depot to 

store candidate models outside of your JMP data table. See Chapter 11, “Formula Depot”.
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• The Fit Curve platform provides predefined models, such as polynomial, logistic, 

Gompertz, exponential, peak, and pharmacokinetic models. Compare different groups or 

subjects using a variety of analytical and graphical techniques. See Chapter 12, “Fit 

Curve”.

• The Nonlinear platform lets you fit custom nonlinear models, which include a model 

formula and parameters to be estimated. See Chapter 13, “Nonlinear Regression”.

• The Gaussian Process platform models the relationship between a continuous response 

and one or more continuous predictors. These models are common in areas like computer 

simulation experiments, such as the output of finite element codes, and they often 

perfectly interpolate the data. See Chapter 15, “Gaussian Process”.

• The Functional Data Explorer platform enables you to convert functional data into a form 

that can be analyzed in another JMP platform. See Chapter 14, “Functional Data 

Explorer”.

• The Time Series platform lets you explore, analyze, and forecast univariate time series. See 

Chapter 16, “Time Series Analysis”.

• The Matched Pairs platform compares the means between two or more correlated 

variables and assesses the differences. See Chapter 17, “Matched Pairs Analysis”.

• The Response Screening platform automates the process of conducting tests across a large 

number of responses. Your test results and summary statistics are presented in data tables, 

rather than reports, to enable data exploration. See Chapter 18, “Response Screening”.

• The Process Screening platform enables you to explore a large number of processes across 

time. The platform calculates control chart, process stability, and process capability 

metrics, and detects large process shifts. See Chapter 19, “Process Screening”.

• The Predictor Screening platform enables you to screen a data set for significant 

predictors. See Chapter 20, “Predictor Screening”.

• The Association Analysis platform enables you to identify items that have an affinity 

for each other. It is frequently used to analyze transactional data (also called market 

baskets) to identify items that often appear together in transactions. See Chapter 21, 

“Association Analysis”.

• The Process History Explorer platform enables you to identify problem components in 

complex process histories. See Chapter 22, “Process History Explorer”.
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Exploring Data for Outliers, Missing Values, and Strong Predictors

Modeling Utilities is a collection of utilities that are designed to assist in the data cleaning and 

pre-processing stages of data analysis. Each utility has exploratory tools to give you a more 

thorough understanding of your data. With Modeling Utilities, you can do the following:

• Explore outliers in both the univariate and multivariate cases.

• Explore and impute missing values in your data.

• Create a validation column that divides the data into training, validation, and test 

sets.

• Screen high-dimensional data for strong predictors.

Figure 3.1  Multivariate k-Nearest Neighbor Outlier Example
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Explore Outliers Utility

Exploring and understanding outliers in your data is an important part of analysis. Outliers in 

data can be due to mistakes in data collection or reporting, measurement systems failure, or 

the inclusion of error or missing value codes in the data set. The presence of outliers can 

distort estimates. Therefore, any analyses that are conducted are biased toward those outliers. 

Outliers also inflate the sample variance. Sometimes retaining outliers in data is necessary, 

however, and removing them could underestimate the sample variance and bias the data in 

the opposite direction.

Whether you remove or retain outliers, you must locate them. There are many ways to 

visually inspect for outliers. For example, box plots, histograms, and scatter plots can 

sometimes easily display these extreme values. See the Visualize Your Data chapter in the 

Discovering JMP book for more information.

The Explore Outliers tool provides four different options to identify, explore, and manage 

outliers in your univariate or multivariate data.

Quantile Range Outliers Uses the quantile distribution of each column to identify outliers 

as extreme values. This tool is useful for discovering missing value or error codes within 

the data. This is the recommended method to begin exploring outliers in your data. See 

“Quantile Range Outliers” on page 41.

Robust Fit Outliers Finds robust estimates of the center and spread of each column and 

identifies outliers as those far from those values. See “Robust Fit Outliers” on page 44.

Multivariate Robust Outliers Uses the Multivariate platform with Robust option to find 

outliers based on the Mahalanobis distance from the estimated robust center. See 

“Multivariate Robust Outliers” on page 46.

Multivariate k-Nearest Neighbor Outliers Finds outliers as values far from their k-nearest 

neighbors. See “Multivariate k-Nearest Neighbor Outliers” on page 47.

Example of the Explore Outliers Utility

The Probe.jmp sample data table contains 387 characteristics (the Responses column group) 

measured on 5800 semiconductor wafers. The Lot ID and Wafer Number columns uniquely 

identify the wafer. You are interested in identifying outliers within a select group of columns 

of the data set. Use the Explore Outliers utility to identify outliers that can then be examined 

using the Distribution platform.

1. Select Help > Sample Data Library and open the Probe.jmp sample data table.

2. Select Analyze > Screening > Explore Outliers.
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3. Select columns VDP_M1 through VDP_SICR and click Y, Columns. You should have 14 

columns selected (see Figure 3.2).

Figure 3.2  Explore Outliers Launch Window

4. Click OK.

5. Click Quantile Range Outliers.

The Quantile Range Outliers report shows each column and lists the number and identity 

of the outliers found.

6. In the Quantile Range Outliers report, select the check box named Show only columns with 
outliers. This limits the list of columns to only those that contain outliers.

Note that several columns contain outlier values of 9999. Many industries use nines as a 

missing value code.

7. In the Nines report, select each column.

8. Click Add Highest Nines to Missing Value Codes.

A JMP Alert indicates that you should use the Save As command to preserve your original 

data.

9. Click OK.

10. In the Quantile Range Outliers report, click Rescan.

11. Select the check box named Restrict search to integers.

In most cases of continuous data, integer values are often error codes or other coded data 

values. Notice that no additional error codes are included in this set of columns.

12. Deselect Restrict search to integers.
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Examine the Data

1. Select all of the remaining columns in the Quantile Range Outliers report.

2. Click Select Rows.

3. Select Analyze > Distribution.

4. Assign the selected columns to the Y, Columns role. Because you selected these column 

names in the Quantile Range Outliers report, they are already selected in the Distribution 

launch window.

5. Click OK.

Figure 3.3 shows a simplified version of the report.

Figure 3.3  Distribution of Columns with Outliers Selected

In columns VDP_M1 and VDP_PEMIT, notice that the selected outliers are somewhat close 

to the majority of data. For the rest of the columns, the selected outliers appear distant 

enough to exclude them from your analyses.

Refine Excluded Outliers

1. In the Quantile Range Outliers report, hold Ctrl and deselect columns VDP_M1 and 

VDP_PEMIT.

2. With the remaining columns selected in the report, click Exclude Rows.
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3. Change Q to 20.

4. Click Rescan.

5. Select columns VDP_M1 and VDP_PEMIT in the report. Click Select Rows.

Reexamine the Data

1. Examine the Distributions report again. Notice the selected outliers are now separate 

enough from the majority of the data to select and exclude them from your analyses.

2. In the Quantile Range Outliers report, click Exclude Rows.

3. In the Distributions report, click the red triangle menu next to Distributions.

4. Select Redo > Redo Analysis.

Figure 3.4 shows a simplified version of the report.

Figure 3.4  Distributions of Columns with Outliers Excluded

The displays of the distributions of the data are now more informative without the 

outliers.
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Launch the Explore Outliers Utility

Note: The Explore Outliers commands only analyze columns with a Continuous modeling 

type. Other columns can be entered in the launch window but are ignored.

To launch Explore Outliers, select  Analyze > Screening > Explore Outliers. The launch window 

appears.

Figure 3.5  Explore Outliers Utility Launch Window

In the launch window, select the analysis columns as Y, Columns. You can also specify a By 

variable. After you click OK, the Explore Outliers report appears. You are presented with the 

following four outlier analysis commands:

• “Quantile Range Outliers” on page 41

• “Robust Fit Outliers” on page 44

• “Multivariate Robust Outliers” on page 46

• “Multivariate k-Nearest Neighbor Outliers” on page 47

Tip: To run an outlier analysis across all levels of a By variable, hold down the Ctrl key and 

click the desired outlier analysis command button.

Quantile Range Outliers

The Quantile Range Outliers method of outlier detection uses the quantile distribution of the 

values in a column to locate the extreme values. Quantiles are useful for detecting outliers 

because there is no distributional assumption associated with them. Data are simply sorted 

from smallest to largest. For example, the 20th quantile is the value at which 20% of values are 

smaller. Extreme values are found using a multiplier of the interquantile range, the distance 
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between two specified quantiles. For more details about how quantiles are computed, see the 

“Distributions” chapter in the Basic Analysis book.

The Quantile Range Outliers utility is also useful for identifying missing value codes stored 

within the data. As noted earlier, in some industries, missing values are entered as nines (such 

as 999 and 9999). This utility finds any nines greater than the upper quartile as suspected 

missing value codes. The utility then enables you to add those missing value codes as a 

column property in the data table.

Quantile Range Outliers Options

The Quantile Range Outliers panel enables you to specify how outliers are to be calculated 

and how you want to manage them. Figure 3.6 shows the default Quantile Range Outliers 

window.

Figure 3.6  Quantile Range Outliers Window

An outlier is considered any value more than Q times the interquantile range from the lower 

and upper quantiles. You can adjust the value of Q and the size of the interquantile range.

Tail Quantile The probability for the lower quantile that is used to calculate the 

interquantile range. The probability of the upper quantile is considered 1 - Tail Quantile. 

For example, a Tail Quantile value of 0.1 means that the interquantile range is between the 

0.1 and 0.9 quantiles of the data. The default value is 0.1.

Q The multiplier that helps determine values as outliers. Outliers are considered Q times the 

interquantile range past the Tail Quantile and 1 - Tail Quantile values. Large values of Q 

provide a more conservative set of outliers than small values. The default is 3.

Restrict search to integers Restricts outlier values to only integer values. This setting 

limits the search for outliers in order to find industry-specific missing value codes and 

error codes.

Show only columns with outliers Limits the list of columns in the report to those that 

contain outliers.
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After the report is displayed using your specifications, there are many ways to act on these 

extreme values. You can select the outliers in a column by selecting the specified column in the 

Quantile Range Outliers report.

Select Rows Selects the rows of outliers in the selected columns in the data table.

Exclude Rows Turns on the exclude row state for outliers in the selected columns in the 

Quantile Range Outliers Report. Click Rescan to update the Quantile Range Outliers 

report.

Color Cells Colors the cells of the selected outliers in the data table.

Color Rows Colors the rows containing outliers for the selected columns in the data table

Add to Missing Value Codes Adds the selected outliers to the missing value codes column 

property. Use this option to identify known missing value or error codes within the data. 

Missing value and error codes are often integers and are sometimes either a positive or 

negative series of nines. Click Rescan to update the Quantile Range Outliers report.

Change to Missing Changes the outlier value to a missing value in the data table. Use 

caution when changing values to missing. Change values to missing only if the data are 

known to be invalid or inaccurate. Click Rescan to update the Quantile Range Outliers 

report.

Rescan Rescans the data after outlier actions have been taken.

Note: Hold down the Ctrl key and click Rescan to rescan across all command groups.

Close Closes the Quantile Range Outliers panel.

Note: Hold down the Ctrl key and click Close to close all command windows.

Quantile Range Outliers Report

The Quantile Range Outliers report lists all columns with the outliers found using the 

specified options. The report shows values for the upper and lower quantiles along with their 

low and high thresholds. Values outside of these threshold limits are considered outliers. The 

number of outliers in each column is indicated. The values of each outlier are listed in the last 

column of the report. Outliers that occur more than once in a column are listed with their 

count in parentheses. To remove columns without outliers from the report, select Show only 
columns with outliers.

There are several things to look for when reading this report.
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• Error codes. For some continuous data, suspiciously high integer values are likely to be 

error codes. For example, if your upper and lower quantile values are all less than 0.5, 

outliers such as 1049 or -777 are likely to be error codes.

• Zeros. Sometimes zeros can indicate missing values. If the majority of your data is 

reasonably large and you notice zeros as outliers, they are likely to be due to missing data.

Nines Report

The Nines report within the Quantile Range Outliers window shows a list of columns that 

contain probable missing value codes. These missing value codes are a series of nines (usually 

9999) and are the highest number that is all nines and also higher than the upper quantile. If 

the count is high, it is likely that these outliers are actually missing value codes. If the count is 

very low, you should explore further to determine whether the value is an outlier or a missing 

value code. The Nines Report includes the upper quantile value.

This report is displayed only when probable missing value codes are identified.

Add Highest Nines to Missing Value Codes Adds the selected outlier values to the 

missing value codes column property. You must click Rescan to update the Quantile 

Range Outliers report.

Change Highest Nines to Missing Replaces the selected outlier values with missing values 

in the data table.

Note: The first time you use choose an action (such as Change to Missing or Exclude Rows) to 

change your data, the alert window warns you to use the Save As command to save your data 

table as a new file to preserve a copy of your original data. When this window appears, click 

OK. If you decide to save your new data file, you will automatically be prompted to save the 

file with a new name.

Robust Fit Outliers

Robust estimates of parameters are less sensitive to outliers than non-robust estimates. Robust 

Fit Outliers provides several types of robust estimates of the center and spread of your data to 

determine those values that can be considered extreme. Figure 3.7 shows the default Robust 

Fit Outliers window.
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Figure 3.7  Robust Fit Outliers Window

Robust Fit Outliers Options

Given a robust estimate of the center and spread, outliers are defined as those values that are 

K times the robust spread from the robust center. The Robust Fit Outliers window provides 

several options for calculating the robust estimates and multiplier K as well as provides tools 

to manage the outliers found.

Huber Uses Huber M-Estimation to estimate center and spread. This option is the default. 

See Huber and Ronchetti (2009).

Cauchy Assumes a Cauchy distribution to calculate estimates for the center and spread. 

Cauchy estimates have a high breakdown point and are typically more robust than Huber 

estimates. However, if your data are separated into clusters, the Cauchy distribution tends 

to consider only the half of the data that makes closer clusters, ignoring the rest.

Quartile Uses the interquartile range (IQR) to estimate the spread. The estimate for the 

center is the median. The estimate for spread is the IQR divided by 1.34898. Dividing the 

IQR by this factor makes the spread correspond to one standard deviation if it was 

normally distributed data.

K The multiplier that determines outliers as K times the spread away from the center. Large 

values of K provide a more conservative set of outliers than small values. The default is 4.

Show only columns with outliers Limits the list of columns in the report to those that 

contain outliers.

Once the report is displayed using your specifications, there are many ways to explore these 

extreme values. You can select the outliers in a row by selecting the specified row in the 

Robust Estimates and Outliers report.

Select Rows Selects the rows containing outliers for the selected columns in the data table.

Exclude Rows Sets the Exclude Row state for outliers in the selected columns in the data 

table. Click Rescan to update the Robust Estimates and Outliers report.

Color Cells Colors the cells of the selected outliers in the data table.
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Color Rows Colors the rows containing outliers for the selected columns in the data table.

Add to Missing Value Codes Adds the selected outliers to the missing value codes column 

property for the selected columns. Use this option to identify known missing value or 

error codes within the data. Click Rescan to update the Robust Estimates and Outliers 

report.

Change to Missing Changes the outlier value to a missing value in the data table. Click 

Rescan to update the Robust Estimates and Outliers report.

Rescan Rescans the data after outlier actions have been taken.

Note: Hold down the CTRL key and click Rescan to rescan across all command groups.

Close Closes the Robust Fit Outliers panel.

Note: Hold down the Ctrl key and click Close to close all command windows.

Multivariate Robust Outliers

The Multivariate Robust Fit Outliers tool uses the Robust option in the Multivariate platform 

to examine the relationships between multiple variables. For more information about how the 

Multivariate platform works, see Correlations and Multivariate Techniques in the Multivariate 

Methods book.

Outlier Analysis

The Outlier Analysis calculates the Mahalanobis distances from each point to the center of the 

multivariate normal distribution. This measure relates to contours of the multivariate normal 

density with respect to the correlation structure. The greater the distance from the center, the 

higher the probability that it is an outlier. For more information about the Mahalanobis 

distance and other distance measures, see the Correlations and Multivariate Techniques in the 

Multivariate Methods book.

After the rows are excluded, you are given the option to either rerun the analysis or close the 

utility. Rerunning the analysis recalculates the center of the multivariate distribution without 

those excluded rows. Note that unless you hide the excluded rows in the data table, they still 

appear in the graph.

You can save the distances to the data table by selecting the Save option from the Mahalanobis 

Distances red triangle menu.
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Figure 3.8  Multivariate Robust Outliers Mahalanobis Distance Plot

Figure 3.8 shows the Mahalanobis distances of 16 different columns. The plot contains an 

upper control limit (UCL) of 4.82.This UCL is meant to be a helpful guide to show where 

potential outliers might be. However, you should use your own discretion to determine which 

values are outliers. For more details about this upper control limit (UCL), see Mason and 

Young (2002).

Multivariate with Robust Estimates Options

The red triangle menu for Multivariate with Robust Estimates contains numerous options to 

analyze your multivariate data. For a list and description of these options, see the Correlations 

and Multivariate Techniques in the Multivariate Methods book.

Multivariate k-Nearest Neighbor Outliers

The basic approach of outlier detection is to consider points distant from other points as 

outliers. One way of determining the distance of a point to other clusters of points is explore 

the distance to its nearest neighbors. For each value of K, the Multivariate k-Nearest Neighbor 

Outliers utility displays a plot of the Euclidean distance from each point to it’s Kth nearest 

neighbor. You specify the largest value of K, denoted as k. Plots are provided for 

, skipping values by the Fibonacci sequence to avoid displaying too many 

plots.

This approach is sensitive to the specified value of k. A small value of k can miss identifying 

points as outliers and a large value of k can falsely classify points as outliers:

• Suppose that the specified k is small, so that you are only studying a few neighbors. If 

there is a cluster of more than k points that is far from the rest of the points, then the points 

within the cluster will have small distances to their nearest neighbors. You may be unable 

to detect the cluster of outliers.

• Suppose that the specified k is large, so that you are studying a large number of neighbors. 

If there are clusters with fewer than k data points, then the points within these clusters 

may appear to be outliers. You may overlook the fact that the points form a cluster, 

interpreting the individual cluster members as outliers instead.

K 1 2 3  k   =
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K-Nearest Neighbor Report

When you select Multivariate k-Nearest Neighbor Outliers from the list of commands, you are 

asked to specify the value of k to use as an upper bound for the furthest neighbor to be 

considered. Notice that the default value is set to 8.

The report shows plots for select values of K up to the value k. The value of K for each plot is 

displayed in its vertical axis label, which is of the form Distance to Neighbor K = <a>, where a 

is an integer denoting the ath closest neighbor. Each plot shows the distance from the point in 

the ith row to its ath nearest neighbor. The points that have large distances from their 

neighbors, across multiple values of K, are likely to be outliers.

The buttons above the plots do the following:

Exclude Selected Rows Excludes rows corresponding to selected points from further 

analysis. The rows are assigned the Excluded row state in the data table. You are asked if 

you want to rerun or close the K Nearest Neighbors report. Rerunning the analysis 

identifies new nearest neighbors. The plots are updated and the excluded points are not 

shown.

Scatterplot Matrix Opens a separate window containing a scatterplot matrix for all 

columns in the analysis. You can explore potential outliers by selecting them in the K 

Nearest Neighbors plots and viewing them in the scatterplot matrix.

Save NN Distances Saves the distances from each row to its nth nearest neighbor as new 

columns in the data table.

Close Closes the K Nearest Neighbors report.

Explore Outliers Utility Options

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.
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Additional Examples of the Explore Outliers Utility

Multivariate k-Nearest Neighbor Outliers Example

The Water Treatment.jmp data set contains daily measurement values of 38 sensors in an urban 

waste water treatment plant. You are interested in exploring these data for potential outliers. 

Potential outliers could include sensor failures, storms, and other situations.

1. Select Help > Sample Data Library and open Water Treatment.jmp.

2. Select Analyze > Screening > Explore Outliers.

3. Select the Sensor Measurements column group and click Y, Columns.

4. Click OK.

5. Select Multivariate k-Nearest Neighbor Outliers.

6. Enter 13 for k-nearest neighbors.

7. Click OK.

Figure 3.9  Outliers in Multivariate k-Nearest Neighbor Outliers Example

Notice the three extreme outliers selected in the K Nearest Neighbors plots in Figure 3.9. 

Each of these three rows corresponds to a date when the secondary settler in the water 
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treatment plant was reported as malfunctioning. Because these three data points are due 

to faulty equipment, exclude them from future analyses.

8. Select the three extreme outliers and click Exclude Selected Rows.

You are prompted to Rerun the utility or Close the window.

9. Click Rerun.

10. Type 13 for k-nearest neighbors.

11. Click OK.

Figure 3.10  Outliers in Multivariate k-Nearest Neighbors Example

Now locate the two light-green outliers close to row 400. Notice how they tend to stay 

close to each other as k increases. These two rows correspond to dates when solids 

overloads were experienced by the water treatment plant. Even though these data points 

have a relatively high Distance to Neighbor K=13, because they are due to a situation that 

you want to include in your study, you do not exclude them. Instead, you keep them in 

mind as you conduct further analyses.



Chapter 3 Modeling Utilities 51
Predictive and Specialized Modeling Explore Missing Values Utility

Explore Missing Values Utility

The presence of missing values in a data set can affect the conclusions made using the data. If, 

for example, several healthy participants dropped out of a longitudinal study and their data 

continued on as missing, the results of the study can be biased toward those unhealthy 

individuals who remained. Missing data values must not only be identified, they must also be 

understood before further analysis can be conducted.

The Explore Missing Values utility provides several ways to identify and understand the 

missing values in your data. It also provides methods for conducting multivariate normal 

imputation for missing values. These methods assume that data are missing at random, which 

means that the probability that an observation is missing depends only on the values of the 

other variables in the study. If you suspect that missing values are not missing at random, then 

consider using the Informative Missing procedure, which is available in a number of 

platforms. For more information, see the Model Specification chapter in the Fitting Linear 

Models book.

Caution: Be careful when analyzing data after imputing missing values, as the results have the 

potential to be biased.

Example of the Explore Missing Values Utility

The Arrhythmia.jmp sample data table contains information from 452 patient 

electrocardiograms (ECGs). The data was originally collected to classify different patterns of 

ECGs as cardiac arrhythmia. However, there are missing values in this data table. You are 

primarily interested in exploring these missing values and imputing them when necessary. 

Since you can only conduct missing value imputation for columns that have a continuous 

modeling type, you will conduct your analysis in two stages.

Examine Missing Values

1. Select Help > Sample Data Library and open Arrhythmia.jmp.

2. Select Analyze > Screening > Explore Missing Values.

3. Select all columns (280 in all) and click Y, Columns.

4. Click OK. Select the Show only columns with missing checkbox.
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Figure 3.11  Missing Value Report

The Missing Columns report shown in Figure 3.11 indicates that only five columns have 

missing data. Out of a total of 452 rows, Column J has 376 missing values. Because it is 

largely missing, it is not useful for data analysis, even with imputed values. However, it 

might be useful to model Column J using the Informative Missing option in a platform that 

supports this option to see if values are perhaps not missing at random.

Note that the two Imputation options, Multivariate Imputation and Multivariate SVD 

Imputation, are not shown. A message indicates that imputation is disabled because some 

columns included in the analysis were categorical. The data table contains several columns 

that are numeric, but have a nominal modeling type. These cannot be used for imputation.

Impute Missing Values

The five columns that have missing values are continuous. You proceed to impute values for 

the four columns other than Column J using multivariate imputation for the continuous 

columns in your data table. By doing so, you tacitly assume that the probabilities that values 

are missing depend only on the values of the continuous variables and not on the values of 

excluded nominal variables. To conduct this new analysis, you need to launch the Explore 

Missing Values utility again.

1. Select Analyze > Screening > Explore Missing Values.

2. In the launch window, click the red triangle next to 280 Columns.

You will use the columns filter menu to view only the columns with a Continuous 

modeling type in the Select Columns list.

3. Select Modeling Type > Uncheck All.

This removes all columns from the Select Columns list.

4. Select Modeling Type > Continuous.

The Select Columns list now contains only the 207 columns that are Continuous.

5. Select all 207 columns. Then Ctrl-click the J column (to deselect it) and click Y, Columns.
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6. Click OK.

7. Click Multivariate Normal Imputation.

A window appears and asks whether you want to use a Shrinkage estimator for 

covariances.

8. Click Yes Shrinkage.

A JMP Alert appears, informing you that you should use the Save As command to 

preserve your original data.

9. Click OK.

Figure 3.12  Imputation Report

The Imputation Report in Figure 3.12 indicates how many missing values were imputed 

and the specific imputation details. No missing data remain in the four columns that had 

missing values.

Launch the Explore Missing Values Utility

Launch the Explore Missing Values modeling utility by selecting Analyze > Screening > 
Explore Missing Values. Enter the columns of interest into the Y, Columns list. You can also 

specify a By variable.

Note: You can enter only columns with a Numeric modeling type in the Explore Missing 

Values utility.
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The Missing Value Report

Figure 3.13  Missing Value Report for Continuous Variables in Arrhythmia.jmp.

After you click OK in the launch window, the report opens to show a Commands outline and 

a Missing Columns report. The commands are the following:

• “Missing Value Report” on page 54

• “Missing Value Clustering” on page 55

• “Missing Value Snapshot” on page 55

• “Multivariate Normal Imputation” on page 55 (Not available if you entered a Numeric 

column with a Nominal or Ordinal modeling type in the launch window.)

• “Multivariate SVD Imputation” on page 56 (Not available if you entered a Numeric 

column with a Nominal or Ordinal modeling type in the launch window.)

• “Automated Data Imputation” on page 57 (Not available if you entered a Numeric 

column with a Nominal or Ordinal modeling type in the launch window.)

Tip: To run a missing value command across all levels of a By variable, hold down the Ctrl key 

and click the desired command button.

Missing Value Report

The Missing Value Report opens the Missing Columns report, which lists the name of each 

column and the number of missing values in that column.

Show only columns with missing Removes columns from the list that do not have missing 

values.

Close Closes the Missing Columns report.

Select Rows Selects the rows in the data table that contain missing values for the column(s) 

that you select in the Missing Columns report.
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Exclude Rows Applies the excluded row state for rows in the data table that contain 

missing values for the column(s) that you select in the Missing Columns report.

Color Cells Colors the cells in the data table that contain missing values for the column(s) 

that you select in the Missing Columns report.

Color Rows Colors the rows in the data table that contain missing values for the column(s) 

that you select in the Missing Columns report.

Missing Value Clustering

Missing Value Clustering provides a hierarchical clustering analysis of the missing data.

• The dendrogram to the right of the plot shows clusters of missing data pattern rows. These 

are the rows that you would obtain by using Tables > Missing Data Pattern.

• The dendrogram beneath the plot shows clusters of variables.

Use this report to determine if certain groups of columns tend to have similar patterns of 

missing values.

The rows of the plot are defined by the missing data patterns; there is a row for each pattern. 

The columns correspond to the variables. Each red cell indicates a group of missing values for 

the column listed beneath the plot. Place your cursor in a cell to see the list of values 

represented. Click in the plot to select missing data pattern rows. Vertical bars appear to 

indicate the selected patterns.

Missing Value Snapshot

The Missing Value Snapshot shows a cell plot for the missing values. The columns represent 

the variables. Black cells indicate a missing value. This plot is especially useful in 

understanding missingness for longitudinal data, where subjects may withdraw from a study 

before the end of the data collection period.

Multivariate Normal Imputation

The Multivariate Normal Imputation utility imputes missing values based on the multivariate 

normal distribution. The procedure requires that all variables have a Continuous modeling 

type. The algorithm uses least squares imputation. The covariance matrix is constructed using 

pairwise covariances. The diagonal entries (variances) are computed using all non-missing 

values for each variable. The off-diagonal entries for any two variables are computed using all 

observations that are non-missing for both variables. In cases where the covariance matrix is 

singular, the algorithm uses minimum norm least squares imputation based on the 

Moore-Penrose pseudo-inverse.

Multivariate Normal Imputation allows the option to use a shrinkage estimator for the 

covariances. The use of shrinkage estimators is a way of improving the estimation of the 
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covariance matrix. For more information about shrinkage estimators, see Schäfer and 

Strimmer (2005).

Note: If a validation column is specified, the covariance matrices are computed using 

observations from the Training set.

Multivariate Normal Imputation Report

The imputation report explains the results of the multivariate imputation process. Results 

include the following:

• Method of imputation (either least squares or minimum-norm least squares)

• How many values were replaced

• Shrinkage estimator on/off

• Factor by which the off-diagonals were scaled

• How many rows and columns were affected

• How many different missing value patterns there were

Once the imputation is complete, the cells corresponding to imputed values in the data table 

are colored in light blue. If the Missing Columns report is open, it is updated to show no 

missing values.

Click Undo to undo the imputation and replace the imputed data with missing values.

Multivariate SVD Imputation

The Multivariate SVD Imputation utility imputes missing values using the singular value 

decomposition (SVD). This utility is useful for data with hundreds or thousands of variables. 

Because SVD calculations do not require calculation of a covariance matrix, the SVD method is 

recommended for wide problems that contain large numbers of variables. The procedure 

requires that all variables have a Continuous modeling type.

The singular value decomposition represents a matrix of observations X as X = UDV‘, where U 

and V are orthogonal matrices and D is a diagonal matrix.

The SVD algorithm used by default in the Multivariate SVD Imputation utility is the sparse 

Lanczos method, also known as the implicitly restarted Lanczos bidiagonalization method 

(IRLBA). See Baglama and Reichel (2005). The algorithm does the following:

1. Each missing value is replaced with its column’s mean.

2. An SVD decomposition is performed on the matrix of observations, X.

3. Each cell that had a missing value is replaced by the corresponding element of the UDV‘ 

matrix obtained from the SVD decomposition.

4. Steps 2 and 3 are repeated until the SVD converges to the matrix X.
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Imputation Method Window

When you click Multivariate SVD Imputation, the Imputation Method window opens to show 

recommended settings.

Number of Singular Vectors Number of singular vectors that are computed and used in 

the imputation.

Note: It is important not to specify too many singular vectors, otherwise the SVD and the 

imputations do not change from iteration to iteration.

Maximum Iterations The number of iterations used in imputing the missing values.

Show Iteration Log Opens a Details report that shows the number of iterations and gives 

details on the criteria.

For large problems, a progress bar shows how many dimensions the SVD has completed. You 

can stop the imputation and use that number of dimensions at any time.

Multivariate SVD Imputation Report

The imputation report explains the results of the multiple imputation process.

• Method of imputation

• How many values were replaced

• How many rows and columns were affected

Once the imputation is complete, the Missing Columns report is automatically shown 

indicating no missing values in the columns that were imputed. Imputed values are displayed 

in light blue.

Click Undo to undo the imputation and replace the imputed data with missing values.

Automated Data Imputation

The Automated Data Imputation (ADI) utility imputes missing values using a low-rank 

matrix approximation method, also known as matrix completion. Once trained, the ADI 

model is capable of performing missing data imputations for streaming data through scoring 

formulas. Streaming data are added rows of observations that become available over time and 

were not used for tuning or validating the imputed model. This utility is flexible, robust, and 

automated to select the best dimension for the low-rank approximation. These features enable 

ADI to work well for many different types of data sets. The procedure requires that all 

variables have a Continuous modeling type.

A low-rank approximation of a matrix is of the form X = UDV‘ and can be viewed as an 

extension of singular value decomposition (SVD). ADI uses the Soft-Impute method as the 
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imputation model and is designed such that the data determines the rank of the low-rank 

approximation.

The ADI algorithm performs the following steps:

1. The data are partitioned into training and validation sets.

2. Each set is centered and scaled using the observed values from the training set.

3. For each partitioned data set, additional missing values are added within each column and 

are referred to as induced missing (IM) values.

4. The imputation model is fit on the training data set along a solution path of tuning 

parameters. The IM values are used to determine the best value for the tuning parameter.

5. Additional rank reduction is performed using the training data set by de-biasing the 

results from the chosen imputation model in step 4.

6. Final rank reduction is performed to calibrate the model for streaming data and to prevent 

overfitting. This is done by fitting the imputation model on the validation set, using the 

rank determined in step 5 as an upper bound.

Automated Data Imputation Controls

The ADI utility contains options for saving the imputed values and advanced controls.

Figure 3.14  ADI Controls

Options for Saving Imputed Values The following three options for saving the imputed 

values for the ADI method are available:

Create New Data Table Creates a new data table that has the same dimensions as the 

original data table. In the new data table, the columns selected in the launch window 

contain the imputed values.
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Save Scoring Formula to Current Data Table Saves a column group, named Imputed_, 

to the current data table that contains the imputed columns specified in the launch 

window. A hidden column, ADI Impute Column, is also added to the current data table 

that contains the imputed vectors and the scoring formula used in the data imputation. 

The column formulas automatically update if any additional rows are added to the 

data table, enabling missing data imputation for streaming data. This is the default 

option.

Impute Values in Place Imputes the missing values in the current data table. The 

imputed values are displayed in light blue.

Advanced Controls Contains the following advanced controls, with recommended settings 

based on the data:

Dimension Upper Bound Determines the maximum rank allowed in the low-rank 

approximation. This is determined by the dimension of the matrix formed by the 

chosen columns.

Maximum Iterations Determines the number of values that are iterated over to 

determine the tuning parameter for the imputation model. The default is 10.

Proportion of Observations to Induce as Missing Determines the proportion of IM 

values that are added to the training and validation sets. The default proportion for 

each set is 0.2.

Proportion of Rows to Use for Validation Determines the proportion of rows to use in 

the training and validation sets. The default proportion for the validation set is 0.3.

Set Random Seed Determines the random seed for ADI. Use this option to obtain 

reproducible results.

Explore Missing Values Utility Options

ADI Loading Matrix (Available only for the ADI utility.) Shows or hides a report that 

contains the columns that correspond to the factor loading for each component.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.
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Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Make Validation Column Utility

Validation is the process of using part of a data set to estimate model parameters and using 

another part to assess the predictive ability of a model. With complex data, this can reduce the 

risk of model overfitting.

A validation column partitions the data into two or three parts.

• The training set is used to estimate the model parameters.

• The validation set is used to help choose a model with good predictive ability.

• The testing set checks the model’s predictive ability after a model has been chosen.

A validation column can be used as a validation method in the Fit Model platform.

Example of the Make Validation Column Utility

The Lipid Data.jmp data table contains blood measurements, physical measurements, and 

questionnaire data from 95 subjects at a California hospital. You are interested in using a 

validation column as a way of validation during future analyses.

1. Select Help > Sample Data Library and open Lipid Data.jmp.

2. Select Analyze > Distribution.

3. Assign Gender to the Y, Columns role. Click OK.
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Figure 3.15  Distribution of Gender in Lipid Data.jmp

Figure 3.15 illustrates the distribution of Gender in the data set. Notice that there is not an 

equal proportion of males and females represented. Because there is a scarcity of females 

within the data, you want to be sure to balance the genders across the validation and 

training sets.

4. Select Analyze > Predictive Modeling > Make Validation Column.

5. Click Stratified Random.

6. Select Gender as the column used for validation holdback.

7. Click OK.

A Validation column is added to the data table. You can explore the distribution of the 

validation and training sets by creating a Mosaic Plot.

8. Select Analyze > Fit Y by X.

9. Assign Validation to Y, Response, and Gender to the X, Factor.

10. Click OK.
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Figure 3.16  Distribution of Gender across Validation and Training Sets

Figure 3.16 illustrates the distribution of Gender across each of the validation and training sets. 

Note that about 75% of both females and males are in the training set and about 25% of both 

females and males are in the validation set.

Launch the Make Validation Column Utility

You can launch the Make Validation Column utility in two ways:

• Select Analyze > Predictive Modeling > Make Validation Column. See “Make Validation 

Column Window” on page 62.

• Click Validation in a platform launch window. See “Click Validation in a Platform 

Launch” on page 64.

Make Validation Column Window

In the Make Validation Column window, you specify the proportion or number of rows for 

each of your holdback sets and then you select a method for constructing the holdback sets.
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Figure 3.17  Make Validation Column Window

• Next to Training Set, Validation Set, and Test Set, enter values that represent the 

proportions or numbers of rows that you would like to include in each of these sets. The 

default values construct a training set that contains about 75% of the rows and a validation 

set that contains about 25% of the rows.

• Enter a name for your validation column next to New Column Name.

There are five methods available to create the holdback sets.

Formula Random Partitions the data into sets based on the allocations entered. For 

example, if the default values are entered, each row has a probability of 0.75 to be included 

in the training set and 0.25 probability of being included in the validation set. The formula 

is saved to the column. To see it, click on the plus icon to the right of the column name in 

the Columns panel.

Fixed Random Partitions the data into sets based on the allocations entered. For example, if 

the default values are entered, each row has a probability of 0.75 to be included in the 

training set and 0.25 probability of being included in the validation set. You can specify a 

random seed that enables you to reproduce the allocations in the future. No formula is 

saved to the column.
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Stratified Random Partitions the data into balanced sets based on levels of columns that 

you specify. Use this option when you want a balanced representation of a column’s levels 

in each of the training, validation, and testing sets.

When you click Stratified Random, a window appears that enables you to select one or 

more columns by which to stratify the data. When you click OK, the validation column is 

added to the data table. As in the Fixed Random case, rows are randomly assigned to the 

holdback sets based on the specified allocations. However, this is done at each level or 

combination of levels of the stratifying columns.

A column is added to the data table with a Notes property that gives the stratifying 

variables.

Grouped Random Partitions the data into sets in such a way that entire levels of a specified 

column or combinations of levels of two or more columns are placed in the same holdback 

set. Use this option when splitting levels across holdback sets is not desirable.

When you click Grouped Random, a window appears that enables you to select one or 

more columns to be grouping columns. When you click OK, the levels are randomly 

assigned to holdback sets. When a level is larger than the proportion or number of rows 

you specify, it stays in its assigned holdback set. However, fewer rows are allocated into 

the training set. Because of this, the sizes of the resulting sets vary slightly from the sizes 

that you specified.

Cutpoint Partitions the data into sets based on time series cutpoints. Use this option when 

you want to assign your data to holdback sets based on time periods.

When you click Cutpoint, a window appears that enables you to select one or more 

columns to define time periods. When you click OK, a JMP Alert appears that shows the 

assigned cutpoints. A column that reflects this assignment is added to the data table. The 

training set consists of rows between the first cutpoint and the second cutpoint. The 

validation set consists of rows between the second and third cutpoints. The test set consists 

of the remaining rows. These sets are chosen to reflect the proportions or numbers of rows 

that you specified.

Click Validation in a Platform Launch

Use this method if you are in a platform launch window and need to construct a validation 

column quickly. Note the following:

• The platform must support a Validation column.

• No columns must be selected in the Select Columns list.

Click the Validation button in the platform launch window. A Make Validation Column 

window appears with default settings of 0.7 for the Training Set, 0.3 for the Validation Set, and 

0.0 for the Test Set.
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1. Enter your desired proportions or numbers next to Training Set, Validation Set, and Test 

Set.

2. Type a name for the new column next to New Column Name.

3. Click OK.

The new column appears in the data table with a formula. In the launch window, the new 

column is assigned to the Validation role.

Note: Launching the Make Validation Column utility through a platform launch window is 

equivalent to selecting the Formula Random method from Analyze > Predictive Modeling > 

Make Validation Column.The Fixed Random, Stratified Random, Grouped Random, and 

Cutpoint methods are not available.
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Fit Nonlinear Models Using Nodes and Layers

 Most features in this platform are available only in JMP Pro and noted with this icon.

The Neural platform implements a fully connected multi-layer perceptron with one or two 

layers. Use neural networks to predict one or more response variables using a flexible function 

of the input variables. Neural networks can be very good predictors when it is not necessary 

to describe the functional form of the response surface, or to describe the relationship between 

the inputs and the response.

Figure 4.1  Example of a Neural Network
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Overview of the Neural Platform

Think of a neural network as a function of a set of derived inputs, called hidden nodes. The 

hidden nodes are nonlinear functions of the original inputs. You can specify up to two layers 

of hidden nodes, with each layer containing as many hidden nodes as you want.

Figure 4.2 shows a two-layer neural network with three X variables and one Y variable. In this 

example, the first layer has two nodes, and each node is a function of all three nodes in the 

second layer. The second layer has three nodes, and all nodes are a function of the three X 

variables. The predicted Y variable is a function of both nodes in the first layer.

Figure 4.2  Neural Network Diagram

The functions applied at the nodes of the hidden layers are called activation functions. The 

activation function is a transformation of a linear combination of the X variables. For more 

details about the activation functions, see “Hidden Layer Structure” on page 73.

The function applied at the response is a linear combination (for continuous responses), or a 

logistic transformation (for nominal or ordinal responses).

The main advantage of a neural network model is that it can efficiently model different 

response surfaces. Given enough hidden nodes and layers, any surface can be approximated 

to any accuracy. The main disadvantage of a neural network model is that the results are not 

easily interpretable, since there are intermediate layers rather than a direct path from the X 

variables to the Y variables, as in the case of regular regression.

Launch the Neural Platform

To launch the Neural platform, select Analyze > Predictive Modeling > Neural.

Launching the Neural platform is a two-step process. First, enter your variables on the Neural 

launch window. Second, specify your options in the Model Launch control panel.
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The Neural Launch Window

Use the Neural launch window to specify X and Y variables, a validation column, and to 

enable Informative Missing value coding.

Figure 4.3  The Neural Launch Window

Y, Response Choose the response variable. When multiple responses are specified, the 

models for the responses share all parameters in the hidden layers (those parameters not 

connected to the responses).

X, Factor Choose the input variables.

Freq Choose a frequency variable.

Validation Choose a validation column. For more information, see “Validation 

Method” on page 72. If you click the Validation button with no columns selected in the 

Select Columns list, you can add a validation column to your data table. For more 

information about the Make Validation Column utility, see the Modeling Utilities chapter 

in the Predictive and Specialized Modeling book.

By Choose a variable to create separate models for each level of the variable.

Informative Missing Check this box to enable informative coding of missing values. 

This coding allows estimation of a predictive model despite the presence of missing 

values. It is useful in situations where missing data are informative. If this option is not 

checked, rows with missing values are ignored.

For a continuous variable, missing values are replaced by the mean of the variable. Also, a 

missing value indicator, named <colname> Is Missing, is created and included in the 

model. If a variable is transformed using the Transform Covariates fitting option on the 
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Model Launch control panel, missing values are replaced by the mean of the transformed 

variable.

For a categorical variable, missing values are treated as a separate level of that variable.

The Model Launch Control Panel

Use the Model Launch control panel to specify the validation method, the structure of the 

hidden layer, whether to use gradient boosting, and other fitting options.

Figure 4.4  The Model Launch Control Panel

Validation Method Select the method that you want to use for model validation. For details, 

see “Validation Method” on page 72.

Random Seed Specify a nonzero numeric random seed if you want to reproduce the 

validation assignment for future launches of the Neural platform. By default, the 

Random Seed is set to zero, which does not produce reproducible results. When you 

save the analysis to a script, the random seed that you enter is saved to the script.

Hidden Layer Structure or Hidden Nodes Specify the number of hidden nodes of each 

type in each layer. For details, see “Hidden Layer Structure” on page 73.

JMP Pro JMP
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Note: The standard edition of JMP uses only the TanH activation function, and can fit only 

neural networks with one hidden layer.

Boosting Specify options for gradient boosting. For details, see “Boosting” on page 74.

Fitting Options Specify options for variable transformation and model fitting. For 

details, see “Fitting Options” on page 75.

Go Fits the neural network model and shows the model reports.

After you click Go to fit a model, you can reopen the Model Launch Control Panel and change 

the settings to fit another model.

Validation Method

Neural networks are very flexible models and have a tendency to overfit data. When that 

happens, the model predicts the fitted data very well, but predicts future observations poorly. 

To mitigate overfitting, the Neural platform does the following:

• applies a penalty on the model parameters

• uses an independent data set to assess the predictive power of the model

Validation is the process of using part of a data set to estimate model parameters, and using 

the other part to assess the predictive ability of the model.

• The training set is the part that estimates model parameters.

• The validation set is the part that estimates the optimal value of the penalty, and assesses or 

validates the predictive ability of the model.

• The test set is a final, independent assessment of the model’s predictive ability. The test set 

is available only when using a validation column.

The training, validation, and test sets are created by subsetting the original data into parts. 

Select one of the following methods to subset a data set.

Excluded Rows Holdback Uses row states to subset the data. Rows that are unexcluded 

are used as the training set, and excluded rows are used as the validation set.

For more information about using row states and how to exclude rows, see the Enter and 

Edit Data chapter in the Using JMP book.

Holdback Randomly divides the original data into the training and validation sets. You can 

specify the proportion of the original data to use as the validation set (holdback).
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KFold Divides the original data into K subsets. In turn, each of the K sets is used to validate 

the model fit on the rest of the data, fitting a total of K models. The model giving the best 

validation statistic is chosen as the final model.

This method is best for small data sets, because it makes efficient use of limited amounts of 

data.

Validation Column Uses the column’s values to divide the data into parts. The column 

is assigned using the Validation role on the Neural launch window. See Figure 4.3.

The column’s values determine how the data is split, and what method is used for 

validation:

– If the column has three unique values, then:

the smallest value is used for the Training set.

the middle value is used for the Validation set.

the largest value is used for the Test set.

– If the column has two unique values, then only Training and Validation sets are used.

– If the column has more than three unique values, then K-Fold validation is performed.

Hidden Layer Structure

Note: The standard edition of JMP uses only the TanH activation function, and can fit only 

neural networks with one hidden layer.

The Neural platform can fit one or two-layer neural networks. Increasing the number of nodes 

in the first layer, or adding a second layer, makes the neural network more flexible. You can 

add an unlimited number of nodes to either layer. The second layer nodes are functions of the 

X variables. The first layer nodes are functions of the second layer nodes. The Y variables are 

functions of the first layer nodes.

The functions applied at the nodes of the hidden layers are called activation functions. An 

activation function is a transformation of a linear combination of the X variables. The 

following activation functions are available:

TanH The hyperbolic tangent function is a sigmoid function. TanH transforms values to be 

between -1 and 1, and is the centered and scaled version of the logistic function. The 

hyperbolic tangent function is:

where x is a linear combination of the X variables.

e2x 1–

e2x 1+
-----------------
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Linear The identity function. The linear combination of the X variables is not transformed.

The Linear activation function is most often used in conjunction with one of the non-linear 

activation functions. In this case, the Linear activation function is placed in the second 

layer, and the non-linear activation functions are placed in the first layer. This is useful if 

you want to first reduce the dimensionality of the X variables, and then have a nonlinear 

model for the Y variables.

For a continuous Y variable, if only Linear activation functions are used, the model for the 

Y variable reduces to a linear combination of the X variables. For a nominal or ordinal Y 

variable, the model reduces to a logistic regression.

Gaussian The Gaussian function. Use this option for radial basis function behavior, or when 

the response surface is Gaussian (normal) in shape. The Gaussian function is:

where x is a linear combination of the X variables.

Boosting

Boosting is the process of building a large additive neural network model by fitting a 

sequence of smaller models. Each of the smaller models is fit on the scaled residuals of the 

previous model. The models are combined to form the larger final model. The process uses 

validation to assess how many component models to fit, not exceeding the specified number 

of models.

Boosting is often faster than fitting a single large model. However, the base model should be a 

1 to 2 node single-layer model, or else the benefit of faster fitting can be lost if a large number 

of models is specified.

Use the Boosting panel in the Model Launch control panel to specify the number of 

component models and the learning rate. Use the Hidden Layer Structure panel in the Model 

Launch control panel to specify the structure of the base model.

The learning rate must be 0r  1. Learning rates close to 1 result in faster convergence on a 

final model, but also have a higher tendency to overfit data. Use learning rates close to 1 when 

a small Number of Models is specified.

As an example of how boosting works, suppose you specify a base model consisting of one 

layer and two nodes, with the number of models equal to eight. The first step is to fit a 

one-layer, two-node model. The predicted values from that model are scaled by the learning 

rate, then subtracted from the actual values to form a scaled residual. The next step is to fit a 

different one-layer, two-node model on the scaled residuals of the previous model. This 

process continues until eight models are fit, or until the addition of another model fails to 

improve the validation statistic. The component models are combined to form the final, large 

e x2–
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model. In this example, if six models are fit before stopping, the final model consists of one 

layer and 2 x 6 = 12 nodes.

Fitting Options

The following model fitting options are available:

Transform Covariates Transforms all continuous variables to near normality using either 

the Johnson Su or Johnson Sb distribution. Transforming the continuous variables helps 

mitigate the negative effects of outliers or heavily skewed distributions. See the Save 

Transformed Covariates option in “Model Options” on page 78.

Robust Fit Trains the model using least absolute deviations instead of least squares. This 

option is useful if you want to minimize the impact of response outliers. This option is 

available only for continuous responses.

Penalty Method Choose the penalty method. To mitigate the tendency neural networks 

have to overfit data, the fitting process incorporates a penalty on the likelihood. See 

“Penalty Method” on page 75.

Number of Tours Specify the number of times to restart the fitting process, with each 

iteration using different random starting points for the parameter estimates. The iteration 

with the best validation statistic is chosen as the final model.

Penalty Method

The penalty is p(i), where  is the penalty parameter, and p( ) is a function of the parameter 

estimates, called the penalty function. Validation is used to find the optimal value of the 

penalty parameter.

Table 4.1  Descriptions of Penalty Methods

Method Penalty Function Description

Squared Use this method if you think that most of your X 

variables are contributing to the predictive ability of 

the model.

Absolute Use either of these methods if you have a large 

number of X variables, and you think that a few of 

them contribute more than others to the predictive 

ability of the model.
Weight Decay
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Model Reports

A model report is created for every neural network model. Measures of fit appear for the 

training and validation sets. Additionally, confusion statistics appear when the response is 

nominal or ordinal.

Figure 4.5  Example of a Neural Model Report

Training and Validation Measures of Fit

Measures of fit appear for the training and validation sets. See Figure 4.5.

Generalized RSquare A measure that can be applied to general regression models. It is 

based on the likelihood function L and is scaled to have a maximum value of 1. The value 

is 1 for a perfect model, and 0 for a model no better than a constant model. The 

NoPenalty none Does not use a penalty. You can use this option if 

you have a large amount of data and you want the 

fitting process to go quickly. However, this option 

can lead to models with lower predictive 

performance than models that use a penalty.

Table 4.1  Descriptions of Penalty Methods (Continued)

Method Penalty Function Description
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Generalized RSquare measure simplifies to the traditional RSquare for continuous normal 

responses in the standard least squares setting. Generalized RSquare is also known as the 

Nagelkerke or Craig and Uhler R2, which is a normalized version of Cox and Snell’s 

pseudo R2. See Nagelkerke (1991).

Entropy RSquare Compares the log-likelihoods from the fitted model and the constant 

probability model. Appears only when the response is nominal or ordinal.

RSquare Gives the RSquare for the model.

RMSE Gives the root mean square error. When the response is nominal or ordinal, the 

differences are between 1 and p (the fitted probability for the response level that actually 

occurred).

Mean Abs Dev The average of the absolute values of the differences between the response 

and the predicted response. When the response is nominal or ordinal, the differences are 

between 1 and p (the fitted probability for the response level that actually occurred).

Misclassification Rate The rate for which the response category with the highest fitted 

probability is not the observed category. Appears only when the response is nominal or 

ordinal.

-LogLikelihood Gives the negative of the log-likelihood. See the Fitting Linear Models book.

SSE Gives the error sums of squares. Available only when the response is continuous.

Sum Freq Gives the number of observations that are used. If you specified a Freq variable in 

the Neural launch window, Sum Freq gives the sum of the frequency column.

If there are multiple responses, fit statistics are given for each response, and an overall 

Generalized RSquare and negative Log-Likelihood is given.

Confusion Statistics

For nominal or ordinal responses, a Confusion Matrix report and Confusion Rates report is 

given. See Figure 4.5. The Confusion Matrix report shows a two-way classification of the 

actual response levels and the predicted response levels. For a categorical response, the 

predicted level is the one with the highest predicted probability. The Confusion Rates report is 

equal to the Confusion Matrix report, with the numbers divided by the row totals.
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Model Options

Each model report has a red triangle menu containing options for producing additional 

output or saving results. The model report red triangle menu provides the following options:

Diagram Shows a diagram representing the hidden layer structure.

Show Estimates Shows the parameter estimates in a report.

Profiler Launches the Prediction Profiler. For nominal or ordinal responses, each response 

level is represented by a separate row in the Prediction Profiler. For details about the 

options in the red triangle menu, see the Profiler chapter in the Profilers book.

Categorical Profiler Launches the Prediction Profiler. Similar to the Profiler option, except 

that all categorical probabilities are combined into a single profiler row. Available only for 

nominal or ordinal responses. For details about the options in the red triangle menu, see 

the Profiler chapter in the Profilers book

Contour Profiler Launches the Contour Profiler. This is available only when the model 

contains more than one continuous factor. For details about the options in the red triangle 

menu, see the Contour Profiler chapter in the Profilers book

Surface Profiler Launches the Surface Profiler. This is available only when the model 

contains more than one continuous factor. For details about the options in the red triangle 

menu, see the Surface Plot chapter in the Profilers book.

ROC Curve Creates an ROC curve. Available only for nominal or ordinal responses. For 

details about ROC Curves, see “ROC Curve” on page 104 in the “Partition Models” 

chapter.

Lift Curve Creates a lift curve. Available only for nominal or ordinal responses. For details 

about Lift Curves, see “Lift Curve” on page 105 in the “Partition Models” chapter.

Plot Actual by Predicted Plots the actual versus the predicted response. Available only for 

continuous responses.

Plot Residual by Predicted Plots the residuals versus the predicted responses. Available 

only for continuous responses.

Save Formulas Creates new columns in the data table containing formulas for the 

predicted response and the hidden layer nodes.

Save Profile Formulas Creates new columns in the data table containing formulas for the 

predicted response. Formulas for the hidden layer nodes are embedded in this formula. 
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This option produces formulas that can be used by the Flash or Interactive HTML versions 

of the Profiler.

Save Fast Formulas Creates new columns in the data table containing formulas for the 

predicted response. Formulas for the hidden layer nodes are embedded in this formula. 

This option produces formulas that evaluate faster than the other options, but cannot be 

used in the Flash or Interactive versions of the Profiler.

Publish Prediction Formula Creates prediction formulas and saves them as formula 

column scripts in the Formula Depot platform. If a Formula Depot report is not open, this 

option creates a Formula Depot report. See the “Formula Depot” chapter on page 197.

Make SAS Data Step Creates SAS code that you can use to score a new data set.

Save Validation Creates a new column in the data table that identifies which rows were 

used in the training and validation sets. This option is not available when a Validation 

column is specified on the Neural launch window. See “The Neural Launch Window” on 

page 70.

Save Transformed Covariates Creates new columns in the data table showing the 

transformed covariates. The columns contain formulas that show the transformations. 

This option is available only when the Transform Covariates option is checked on the 

Model Launch control panel. See “Fitting Options” on page 75.

Remove Fit Removes the entire model report.

Example of a Neural Network

This example uses the Boston Housing.jmp data table. Suppose you want to create a model to 

predict the median home value as a function of several demographic characteristics. Follow 

the steps below to build the neural network model:

1. Select Help > Sample Data Library and Boston Housing.jmp.

2. Launch the Neural platform by selecting Analyze > Predictive Modeling > Neural.

3. Assign mvalue to the Y, Response role.

4. Assign the other columns (crim through lstat) to the X, Factor role.

5. Click OK.

6. Enter 0.2 for the Holdback Proportion.

7. Enter 1234 for the Random Seed.
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Note: In general, results vary due to the random nature of choosing a validation set. Entering 

the seed above enable you to reproduce the results shown in this example.

8. Enter 3 for the number of TanH nodes in the first layer.

9. Check the Transform Covariates option.

10. Click Go.

The report is shown in Figure 4.6.

Figure 4.6  Neural Report

Results are provided for both the training and validation sets. Use the results of the validation 

set as a representation of the model’s predictive power on future observations.

The R-Square statistic for the Validation set is 0.913, signifying that the model is predicting 

well on data not used to train the model. As an additional assessment of model fit, select Plot 
Actual by Predicted from the Model red-triangle menu. The plot is shown in Figure 4.7.

Figure 4.7  Actual by Predicted Plot

The points fall along the line, signifying that the predicted values are similar to the actual 

values.
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To get a general understanding of how the X variables are impacting the predicted values, 

select Profiler from the Model red-triangle menu. The profiler is shown in Figure 4.8.

Figure 4.8  Profiler

Some of the variables have profiles with positive slopes, and some negative. For example, 

rooms has a positive slope. This indicates that the more rooms a home has, the higher the 

predicted median value. The variable pt is the pupil teacher ratio by town. This variable has a 

negative slope, indicating that the higher the pupil to teacher ratio, the lower the median 

value.
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Partition Models

Use Decision Trees to Explore and Model Your Data

The Partition platform recursively partitions data according to a relationship between the 

predictors and response values, creating a decision tree. The partition algorithm searches all 

possible splits of predictors to best predict the response. These splits (or partitions) of the data 

are done recursively to form a tree of decision rules. The splits continue until the desired fit is 

reached. The partition algorithm chooses optimum splits from a large number of possible 

splits, making it a powerful modeling, and data discovery tool.

Figure 5.1  Example of a Decision Tree
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Overview of the Partition Platform

The Partition platform recursively partitions data according to a relationship between the 

predictors and response values, creating a decision tree. Variations of partitioning go by many 

names and brand names: decision trees, CARTTM, CHAIDTM, C4.5, C5, and others. The 

technique is often considered as a data mining technique for the following reasons:

• it is useful for exploring relationships without having a good prior model

• it handles large problems easily

• the results are interpretable

A classic application of partitioning is to create a diagnostic heuristic for a disease. Given 

symptoms and outcomes for a number of subjects, partitioning can be used to generate a 

hierarchy of questions to help diagnose new patients.

Predictors can be either continuous or categorical (nominal or ordinal). If a predictor is 

continuous, then the splits are created by a cutting value. The sample is divided into values 

below and above this cutting value. If a predictor is categorical, then the sample is divided 

into two groups of levels.

The response can also be either continuous or categorical (nominal or ordinal). If the response 

is continuous, then the platform fits the means of the response values. If the response is 

categorical, then the fitted value is a probability for the levels of the response. In either case, 

the split is chosen to maximize the difference in the responses between the two nodes of the 

split.

For more information about split criteria, see “Statistical Details for the Partition Platform” on 

page 118.

For more information about recursive partitioning, see Hawkins and Kass (1982) and Kass 

(1980).

Example of the Partition Platform

In this example, you use the Partition platform to construct a decision tree that predicts the 

one-year disease progression (low or high) of patients with diabetes.

1. Select Help > Sample Data Library and Diabetes.jmp.

2. Select Analyze > Predictive Modeling > Partition.

3. Select Y Binary and click Y, Response.

4. Select Age through Glucose and click X, Factor.

5. Enter 0.33 for the Validation Portion.
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Note: In JMP Pro, a validation column can be used for validation. Select Validation and 

click Validation. Set the Validation Portion to 0.

6. Click OK.

7. On the platform report window, click Go to perform automatic splitting.

Note: Because you are using a random Validation Portion, your results differ from those in 

Figure 5.2.

Figure 5.2  Partition Report for Diabetes

Automatic splitting resulted in four splits. The final RSquare for the Validation set is 0.154. 

The decision tree shows the four splits and the counts of observations in each split.

8. Click the red triangle next to Partition for Y Binary and select Column Contributions.
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Figure 5.3  Column Contributions Report

The Column Contributions report shows that LTG and BMI are the only predictors in the 

decision tree model. Each column is used in two splits. Your results can differ. When the 

Validation Portion is used, the validation set is selected at random from the data table. If 

you redo your analysis, a new random validation set is selected and your results can differ 

from your first run.

9. Click the red triangle next to Partition for Y Binary and select  Save Columns > Save 
Prediction Formula.

In the Diabetes.jmp data table, columns called Prob(Y Binary==Low), Prob(Y Binary==High), 
and Most Likely Y Binary are added. To see how these response probabilities are calculated, 

in the Columns panel, next to each column, double-click the Formula icon .

Launch the Partition Platform

Launch the Partition platform by selecting Analyze > Predictive Modeling > Partition.
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Figure 5.4  Partition Launch Window

Y, Response The response variable or variables that you want to analyze.

X, Factor The predictor variables.

Weight A column whose numeric values assign a weight to each row in the analysis.

Freq A column whose numeric values assign a frequency to each row in the analysis.

Validation A numeric column that contains at most three distinct values. See 

“Validation” on page 107.

By A column or columns whose levels define separate analyses. For each level of the 

column, the corresponding rows are analyzed using the other variables that you specify. 

The results appear in separate reports. If more than one By variable is assigned, a separate 

report is produced for each possible combination of the levels of the By variables.

Method Enables you to select the partition method (Bootstrap Forest, Boosted Tree, K 

Nearest Neighbors, or Naive Bayes).

For more details about these methods, see Chapter 6, “Bootstrap Forest”, Chapter 7, 

“Boosted Tree”, Chapter 8, “K Nearest Neighbors”, and Chapter 9, “Naive Bayes”.

Validation Portion The portion of the data to be used as the validation set. See “Validation” 

on page 107.

Informative Missing If selected, enables missing value categorization for categorical 

predictors and informative treatment of missing values for continuous predictors. See 

“Informative Missing” on page 102.



Chapter 5 Partition Models 89
Predictive and Specialized Modeling The Partition Report

Ordinal Restricts Order If selected, restricts consideration of splits to those that preserve 

the ordering.

The Partition Report

The initial Partition report shows a partition plot, control buttons, a summary panel, and a 

decision tree. The partition plot and decision tree are initialized without any splits. The 

reports details are different for categorical and continuous responses.

• “Control Buttons”

• “Report for Categorical Responses”

• “Report for Continuous Responses”

Control Buttons

Use the control buttons to interact with the decision tree.

Split Creates a partition of the data using the optimal split. To specify multiple splits, hold 

the Shift key as you click Split.

Prune Removes the worst split.

Go (Available when you are using validation.) Automatically adds splits to the decision tree 

until the validation statistic is optimized. See “Validation” on page 107. Without 

validation, you simply decide the number of splits to use in the partition model.

Color Points For categorical responses, colors observations according to response level. 

These colors are added to the data table.

Report for Categorical Responses

The sample data table Diabetes.jmp was used to create a report for the categorical response Y 
Binary.
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Figure 5.5  Partition Report for a Categorical Response

Partition Plot

Each point in the Partition Plot represents an observation in the data table. If validation is 

used, the plot is only for the training data. The initial partition plot does not show splits.

Notice the following:

• The left vertical axis is the proportion of each response outcome.

• The right vertical axis shows the order in which the response levels are plotted.

• Horizontal lines divide each split by the response variable. The initial horizontal line 

shows the overall proportion of the first plotted response in the data set.

• Splits are shown below the X axis with a text description and a vertical line that splits the 

observations in the plot. The vertical lines extend into the plot and indicate the boundaries 

for each node. The most recent split appears directly below the horizontal axis and on top 

of existing splits. The plot is updated with each split or prune of the decision tree.
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Summary Report

Figure 5.6  Summary Report for a Categorical Response

The Summary Report provides fit statistics for the training data and validation and test data 

(if used). The fit statistics in the Summary Panel update as you add splits or prune the decision 

tree.

RSquare The current value of R2.

N Number of observations.

Number of Splits Current number of splits in the decision tree.

Node Reports

Each node in the tree has a report and a red triangle menu with additional options. Terminal 

nodes also have a Candidates report.

Figure 5.7  Terminal Node Report for a Categorical Response

Count Number of training observations that are characterized by the node.

G2 A fit statistic used for categorical responses (instead of sum of squares that is used for 

continuous responses). Lower values indicate a better fit. See “Statistical Details for the 

Partition Platform” on page 118.

Candidates For each column, the Candidates report provides details about the optimal split 

for that column. The optimal split over all terms is marked with an asterisk.
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Term Shows the candidate columns.

Candidate G^2 Likelihood ratio chi-square for the best split. Splitting on the predictor 

with the largest G^2 maximizes the reduction in the model G^2.

LogWorth The LogWorth statistic, defined as -log10(p-value). The optimal split is the one 

that maximizes the LogWorth. See “Statistical Details for the Partition Platform” on 

page 118 for additional details.

Cut Point The value of the predictor that determines the split. For a categorical term, the 

levels in the left-most split are listed.

The optimal split is noted by an asterisk. However, there are cases where the Candidate G2 is 

higher for one variable, but the Logworth is higher for a different variable. In this case > and < 

are used to point in the best direction for each variable. The asterisk corresponds to the 

condition where they agree. See “Statistical Details for the Partition Platform” on page 118 for 

details.

Report for Continuous Responses

The sample data table Diabetes.jmp was used to create a report for the continuous response Y.

Figure 5.8  Partition Report for a Continuous Response
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Partition Plot

The partition plot is initialized without any splits. Each point represents an observation in the 

data table. If validation is used, the plot is only for the training data.

Notice the following:

• The vertical axis represents the response value of the observations.

• Horizontal lines show the mean response value for each node of the decision tree. The 

initial horizontal line is at the overall mean of the response.

• Vertical axis divisions represent splits in the decision tree. A text description of the most 

recent split appears below the horizontal axis. Observations are reorganized into their 

respective nodes as splits are created or removed.

Tip: To see tooltips for narrow partitions, place your cursor over the labels on the horizontal 

axis of the partition plot.

Summary Report

Figure 5.9  Summary Report for a Continuous Response

The Summary Report provides fit statistics for the training data and validation and test data 

(if used). The fit statistics in the Summary Panel update as you add splits or prune the decision 

tree.

RSquare The current value of R2.

RMSE The root mean square error.

N The number of observations.

Number of Splits The current number of splits in the decision tree.

AICc The corrected Akaike’s Information Criterion. For more details, see the Statistical 

Details appendix in the Fitting Linear Models book.

Node Reports

Each node in the tree has a report and a red triangle menu with additional options. Terminal 

nodes also have a Candidates report.
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Figure 5.10  Terminal Node Report for a Continuous Response

Count The number of observations (rows) in the branch.

Mean The average response for all observations in that branch.

Std Dev The standard deviation of the response for all observations in that branch.

Candidates For each column, the Candidates report provides details about the optimal split 

for that column. The optimal split over all columns is marked with an asterisk.

Term Shows the candidate columns.

Candidate SS Sum of squares for the best split.

LogWorth The LogWorth statistic, defined as -log10(p-value). The optimal split is the one 

that maximizes the LogWorth. See “Statistical Details for the Partition Platform” on 

page 118 for additional details.

Cut Point The value of the predictor that determines the split. For a categorical term, the 

levels in the left-most split are listed.

The optimum split is noted by an asterisk. However, there are cases where the Candidate SS is 

higher for one variable, but the Logworth is higher for a different variable. In this case > and < 

are used to point in the best direction for each variable. The asterisk corresponds to the 

condition where they agree. See “Statistical Details for the Partition Platform” on page 118 for 

details.
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Partition Platform Options

The Partition red triangle menu options give you the ability to customize reports according to 

your needs. The available options are determined by the type of data that you use for your 

analysis.

Display Options Contains options that show or hide report elements.

Show Points Shows the points. For categorical responses, this option shows the points 

or colored panels.

Show Tree Shows the large tree of partitions.

Show Graph Shows the partition graph.

Show Split Bar (Categorical responses only) Shows the colored bars that indicate the 

split proportions in each leaf.

Show Split Stats Shows the split statistics. For more information about the categorical 

split statistic G2, see “Statistical Details for the Partition Platform” on page 118.

Show Split Prob (Categorical responses only) Shows the Rate and Prob statistics in the 

node reports.

JMP automatically shows the Rate and Prob statistics when you select Show Split 
Count. For more information about Rate and Prob, see “Statistical Details for the 

Partition Platform” on page 118.

Show Split Count (Categorical responses only) Shows frequency counts in the node 

reports. When you select this option, JMP automatically selects Show Split Prob. And 

when you de-select Show Split Prob, the counts do not appear.

Show Split Candidates Shows the Candidates report.

Sort Split Candidates Sorts the Candidates reports by the statistic or the log(worth), 

whichever is appropriate.

Split Best Splits the tree at the optimal split point. This is equivalent to clicking the Split 
button.

Prune Worst Removes the terminal split that has the least discrimination ability. This is 

equivalent to clicking the Prune button.

Minimum Size Split Define the minimum size split allowed by entering a number or a 

fractional portion of the total sample size. To specify a number, enter a value greater than 
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or equal to 1. To specify a fraction of the sample size, enter a value less than 1. The default 

value is set to the maximum of 5, or the floor of the number of rows divided by 10,000.

Lock Columns Interactively lock columns so that they are not considered for splitting. You 

can turn the display off or back on without affecting the individual locks.

Plot Actual by Predicted (Continuous responses only) Shows a plot of actual values by 

predicted values. See “Actual by Predicted Plot” on page 103.

Small Tree View Shows a small version of the partition tree to the right of the partition plot.

Tree 3D Shows a 3-D plot of the tree structure. To access this option, hold down the Shift 

key and click the red triangle menu.

Leaf Report Shows the mean and count or rates for the bottom-level leaves of the report.

Column Contributions Shows a report indicating each input column’s contribution to the 

fit. The report also shows how many times it defined a split and the total G2 or Sum of 

Squares attributed to that column.

Split History Shows a plot of RSquare versus the number of splits. If you use excluded row 

validation, holdback validation, or a validation column, separate curves are drawn for 

training and validation RSquare values. The RSquare curve is blue for the training set and 

red for the validation set. If you select K Fold Crossvalidation, the RSquare curve for all of 

the data is blue, and the curve for the crossvalidation RSquare is green.

K Fold Crossvalidation Shows a Crossvalidation report that gives fit statistics for both the 

training and folded sets. For more information about validation, see “K-Fold 

Crossvalidation” on page 109.

ROC Curve (Categorical responses only) Receiver Operating Characteristic (ROC) curves 

display the efficiency of a model’s fitted probabilities to sort the response levels. See “ROC 

Curve” on page 104.

Lift Curve (Categorical responses only) Lift curves display the predictive ability of a 

partition model. See “Lift Curve” on page 105.

Show Fit Details (Appears only for categorical responses.) The Fit Details report shows 

several measures of fit and provides a Confusion Matrix report. See “Show Fit Details” on 

page 98

Save Columns Contains options for saving model and tree results, and creating SAS code.

Save Residuals Saves the residual values from the model to the data table.

Save Predicteds Saves the predicted values from the model to the data table.
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Save Leaf Numbers Saves the leaf numbers of the tree to a column in the data table.

Save Leaf Labels Saves leaf labels of the tree to the data table. The labels document 

each branch that the row would trace along the tree. Each branch is separated by “&”. 

An example label might be: “size(Small,Medium)&size(Small)”. However, JMP does 

not include redundant information in the form of category labels that are repeated. A 

category label for a leaf might refer to an inclusive list of categories in a higher tree 

node. A caret (‘^”) appears where the tree node with redundant labels occurs. 

Therefore, “size(Small,Medium)&size(Small)” is presented as ^&size(Small).

Save Prediction Formula Saves prediction formulas to a column or multiple columns in 

the data table. The formulas consist of nested conditional clauses that describe the tree 

structure. If the response is continuous, one column that contains a Predicting property 

is added. If the response is categorical, columns that contain a Response Probability 

property are added for each level of the response. Additionally, a Most Likely column 

that contains the response level with the highest probability of occurrence for each 

observation is added.

Save Tolerant Prediction Formula Saves a formula that predicts even when there are 

missing values and when Informative Missing has not been checked. The prediction 

formula tolerates missing values by randomly allocating response values for missing 

predictors to a split. If the response is continuous, the column contains a Predicting 

property. If the response is categorical, the column contains a Response Probability 

property. If you have checked Informative Missing, you can save the Tolerant 

Prediction Formula by holding the Shift key as you click the report’s red triangle.

Save Leaf Number Formula Saves a column containing a formula in the data table that 

computes the leaf number.

Save Leaf Label Formula Saves a column containing a formula in the data table that 

computes the leaf label.

Make SAS DATA Step Creates SAS code for scoring a new data set.

Publish Prediction Formula Creates a prediction formula and saves it as a formula 

column script in the Formula Depot platform. If a Formula Depot report is not open, 

this option creates a Formula Depot report. See the “Formula Depot” chapter on 

page 197.

Publish Tolerant Prediction Formula Creates a tolerant prediction formula and 

saves it as a formula column script in the Formula Depot platform. If a Formula Depot 

report is not open, this option creates a Formula Depot report. See the “Formula 

Depot” chapter on page 197. If you have checked Informative Missing, you can use this 

option by holding the Shift key as you click on the report’s red triangle.
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Specify Profit Matrix (Available only for categorical responses.) Enables you to specify 

profits or costs associated with correct or incorrect classification decisions. For a nominal 

response, you can specify the profit matrix entries using a probability threshold. See 

“Show Fit Details” on page 98.

Profiler Shows an interactive profiler report. Changes in the factor values are reflected in the 

estimated classification probabilities. See the Profiler chapter in the Profilers book.

Color Points (Categorical responses only) Colors points based on their response level. This 

is equivalent to clicking the Color Points button. See “Report for Categorical Responses” 

on page 89.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Show Fit Details

Figure 5.11  Fit Details for Categorical Response (Y Binary from Diabetes.jmp)

Entropy RSquare Compares the log-likelihoods from the fitted model and the constant 

probability model. Values closer to 1 indicate a better fit.
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Generalized RSquare A measure that can be applied to general regression models. It is 

based on the likelihood function L and is scaled to have a maximum value of 1. The 

Generalized RSquare measure simplifies to the traditional RSquare for continuous normal 

responses in the standard least squares setting. Generalized RSquare is also known as the 

Nagelkerke or Craig and Uhler R2, which is a normalized version of Cox and Snell’s 

pseudo R2. See Nagelkerke (1991). Values closer to 1 indicate a better fit.

Mean -Log p The average of -log(p), where p is the fitted probability associated with the 

event that occurred. Smaller values indicate a better fit.

RMSE The root mean square error, where the differences are between the response and p 

(the fitted probability for the event that actually occurred). Smaller values indicate a better 

fit.

Mean Abs Dev The average of the absolute values of the differences between the response 

and p (the fitted probability for the event that actually occurred). Smaller values indicate a 

better fit.

Misclassification Rate The rate for which the response category with the highest fitted 

probability is not the observed category. Smaller values indicate a better fit.

The Confusion Matrix report shows matrices for the training set and for the validation and 

test sets (if defined). The Confusion Matrix is a two-way classification of actual and predicted 

responses.

If the response has a Profit Matrix column property, or if you specify costs using the Specify 

Profit Matrix option, then a Decision Matrix report appears. See “Decision Matrix Report” on 

page 101.

Specify Profit Matrix

A profit matrix can be used with categorical responses. A profit matrix is used to assign costs 

to undesirable outcomes and profits to desirable outcomes.
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Figure 5.12  Specify Profit Matrix Window

You can assign profit and cost values to each combination of actual and predicted response 

categories. To specify the costs of classifying into an alternative category, enter values in the 

Undecided column. To save your assignments to the response column as a property, check 

Save to column as property. Leaving this option unchecked applies the Profit Matrix only to 

the current Partition report.

Probability Threshold Specification for Profit Matrix

When the response is binary, instead of entering weights into the profit matrix, you can 

specify a probability threshold in the Profit Matrix window. For details about how values are 

calculated for the profit matrix, see The Column Info Window chapter in the Using JMP book.

Target The level whose probability is modeled.

Probability Threshold A threshold for the probability of the target level. If the probability 

that an observation falls into the target level exceeds the probability threshold, the 

observation is classified into that level.

When you define costs using the Specify Profit Matrix option and then select Show Fit Details, 

a Decision Matrix report appears. See “Decision Matrix Report” on page 101.

When you specify a profit matrix and save the model prediction formula, the formula 

columns saved to the data table include the following:
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– Profit for <level>: For each level of the response, a column gives the expected profit for 

classifying each observation into that level.

– Most Profitable Prediction for <column name>: For each observation, gives the level of 

the response with the highest expected profit.

– Expected Profit for <column name>: For each observation, gives the expected profit for 

the classification defined by the Most Profitable Prediction column.

– Actual Profit for <column name>: For each observation, gives the actual profit for 

classifying that observation into the level specified by the Most Profitable Prediction 

column.

Decision Matrix Report

Figure 5.13  Fit Details Report with Decision Matrix Report

Note: This report is available only if the response has a Profit Matrix column property or if 

you specify costs using the Specify Profit Matrix option. The report is part of the Fit Details 

report.
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When a profit matrix is defined, the partition algorithm uses the values in the matrix to 

calculate the profit for each decision. When you select Show Fit Details, a Decision Matrix 

report appears.

In the Decision Matrix report, the decision counts reflect the most profitable prediction 

decisions based on the weighting in the profit matrix. The report gives Decision Count and 

Decision Rate matrices for the training set and for validation and test sets (if defined). For 

reference, the profit matrix is also shown.

Note: If you change the weights in your Profit Matrix using the Specify Profit Matrix option, 

the Decision Matrix report automatically updates to reflect your changes.

Decision Count Matrix Shows a two-way classification with actual responses in rows and 

classification counts in columns.

Specified Profit Matrix Gives the weights that define the Profit Matrix.

Decision Rate Matrix Shows rate values corresponding to the proportion of a given row’s 

observations that are classified into each category. If all observations are correctly 

classified, the rates on the diagonal are all equal to one.

Tip: You can obtain a decision rate matrices for a response using the default profit matrix 

with costs of 1 and -1. Select Specify Profit Matrix from the red triangle menu, make no 

changes to the default values, and click OK.

The matrices are arranged in two rows:

• The Decision Count matrices are in the first row.

• The Specified Profit Matrix is to the right in the first row.

• The Decision Rate matrices are in the second row.

Informative Missing

The Informative Missing option enables informative treatment of missing values on the 

predictors. The model that is fit is deterministic. The Informative Missing option is found on 

the launch window and is selected by default. When informative missing is selected the 

missing values are handled as follows:

• Rows containing missing values for a categorical predictor are entered into the analysis as 

a separate level of the variable.

• Rows containing missing values for a continuous predictor are assigned to a split as 

follows: The values of the continuous predictor are sorted. Missing rows are first 

considered to be on the low end of the sorted values. All splits are constructed. The 

missing rows are then considered to be on the high end of the sorted values. Again, all 
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splits are constructed. The optimal split is determined using the LogWorth criterion. For 

further splits on the given predictor, the algorithm commits the missing rows to high or 

low values, as determined by the first split induced by that predictor.

If the Informative Missing option is not selected, the missing values are handled as follows:

• When a predictor with missing values is used as a splitting variable, each row with a 

missing value on that predictor is randomly assigned to one of the two sides of the split.

• The first time a predictor with missing values is used as a splitting variable an Imputes 

column is added to the Summary Report showing the number of imputations. As 

additional imputations are made, the Imputes column updates. See Figure 5.14, where five 

imputations were performed.

Note: The number of Imputes can be greater than the number of rows that contain missing 

values. The imputation occurs at each split. A row with missing values can be randomly 

assigned multiple times. Each time a row is randomly assigned it increments the 

imputation count.

Figure 5.14  Impute Message in Summary Report

Actual by Predicted Plot

For continuous responses, the Actual by Predicted plot is the typical plot of the actual 

response versus the predicted response. When you fit a Decision Tree, all observations in a leaf 

have the same predicted value. If there are n leaves, then the Actual by Predicted plot shows at 

most n distinct predicted values. The actual values form a scatter of points around each leaf 

mean on n vertical lines.

The diagonal line is the Y = X line. For a perfect fit, all the points would be on this diagonal. 

When validation is used, plots are shown for both the training and the validation sets. See 

Figure 5.15.
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Figure 5.15  Actual by Predicted Plots for a Continuous Response

ROC Curve

The ROC Curve option is available only for categorical responses. Receiver Operating 

Characteristic (ROC) curves display the efficiency of a model’s fitted probabilities in sorting 

the response levels. An introduction to ROC curves is found in the Logistic Analysis chapter 

in the Basic Analysis book.

The predicted response for each observation in a partition model is a value between 0 and 1. 

To use the predicted response to classify observations as positive or negative, a cut point is 

used. For example, if the cut point is 0.5, an observation with a predicted response at or above 

0.5 would be classified as positive, and an observation below 0.5 as negative. There are trade 

offs in classification as the cut point is varied.

To generate a ROC curve, each predicted response level is considered as a possible cut point 

and the following values are computed for each possible cut point:

• The sensitivity is the proportion of true positives or the percent of positive observations 

with a predicted response greater than the cut point.

• The specificity is the proportion of true negatives or the proportion of negative 

observations with a predicted response less than the cut point.

The ROC curve plots sensitivity against 1 - specificity. A partition model with n splits has n+1 

predicted values. The ROC curve for the partition model has n+1 line segments.

If your response has more than two levels, the Partition report contains a separate ROC curve 

for each response level versus the other levels. Each curve is the representation of a level as the 

positive response level. If there are only two levels, one curve is the reflection of the other.
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Figure 5.16  ROC Curves for a Three Level Response

If the model perfectly rank-orders the response values, then the sorted data contains all of the 

positive values first, followed by all of the other values. In this situation, the curve moves all 

the way to the top before it moves at all to the right. If the model does not predict well, the 

curve follows the diagonal line from the bottom left to top right of the plot.

In practice, the ROC curve lies above the diagonal. The area under the curve is the indicator of 

the goodness of fit for the model. A value of 1 indicates a perfect fit and a value near 0.5 

indicates that the model cannot discriminate among groups.

When your response has more than two levels, the ROC curve plot enables you to see which 

response categories have the largest area under the curve.

Lift Curve

The Lift Curve option provides another plot to display the predictive ability of a partition 

model. The lift curve plots the lift versus the portion of the observations. Each predicted 

response level defines a portion of the observations that are greater than or equal to that 

predicted response. The lift value is the ratio of the proportion of positive responses in that 

portion to the overall proportion of positive responses.
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Figure 5.17  Lift Curve

Figure 5.18  Lift Table for Lift Curve

Figure 5.18 provides a table of values to demonstrate the calculation of Lift and Portion used 

for the High lift curve shown in Figure 5.17. A partition model with five splits was built to 

predict the response, Y Binary. Y Binary has two levels: Low and High. The lift curve is based 

on 309 observations. There are 83 High responses for an overall rate of 0.27.

• Prob High: The five predicted values from the partition model for the High response level.

• N > Prob High: The number of observations that have a predicted value equal to or greater 

than the value in Prob High.

• Portion: N > Prob High divided by 309.

• N High in Portion: The number of High responses in the portion.

• Portion High: N > Prob High divided by Portion High.

• Lift: Portion High divided by 0.27.

Lift measures how many High responses fall in each portion as compared to the expected 

number of High responses for that portion. For the first 6% of the data set the lift is 3.72. Using 

the model to select the 6% of the observations with the highest predicted values results in 3.72 

more High responses than if that 6% were selected at random.
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Node Options

This section describes the options on the red triangle menu for each node.

Split Best Finds and executes the best split at or below this node.

Split Here Splits at the selected node on the best column to split by.

Split Specific Lets you specify where a split takes place. This is useful in showing what the 

criterion is as a function of the cut point, as well as in determining custom cut points. 

When specifying a splitting column, you can choose the following options for how the 

split is performed:

Optimal Value Splits at the optimal value of the selected variable.

Specified Value Enables you to specify the level where the split takes place.

Output Split Table Produces a data table showing all possible splits and their associated 

split value.

Prune Below Eliminates the splits below the selected node.

Prune Worst Finds and removes the worst split below the selected node.

Select Rows Selects the data table rows corresponding to this leaf. You can extend the 

selection by holding down the Shift key and choosing this command from another node.

Show Details Produces a data table that shows the split criterion for a selected variable. The 

data table, composed of split intervals and their associated criterion values, has an 

attached script that produces a graph for the criterion.

Lock Prevents a node or its subnodes from being chosen for a split. When checked, a lock 

icon appears in the node title.

Validation

If you build a tree with enough splits, partitioning can overfit data. When this happens, the 

model predicts the data used to build the model very well, but predicts future observations 

poorly. Validation is the process of using part of a data set to estimate model parameters, and 

using the other part to assess the predictive ability of the model.

• The training set is the part that is used to estimate model parameters.

• The validation set is the part that assesses or validates the predictive ability of the model.
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• The test set is a final, independent assessment of the model’s predictive ability. The test set 

is available only when using a validation column. See “Launch the Partition Platform” on 

page 87.

When a validation method is used, the Go button appears. The Go button provides for 

repeated splitting without having to repeatedly click the Split button. When you click the Go 

button, splitting occurs until the validation R-Square is better than what the next 10 splits 

would obtain. This rule can result in complex trees that are not very interpretable, but have 

good predictive power.

Using the Go button turns on the Split History command. If using the Go button results in a 

tree with more than 40 nodes, the Show Tree command is turned off.

The training, validation, and test sets are created by subsetting the original data into parts. 

Select one of the following methods to subset a data set:

Excluded Rows Uses row states to subset the data. Rows that are unexcluded are used as 

the training set, and excluded rows are used as the validation set.

For more information about using row states and how to exclude rows, see the Enter and 

Edit Data chapter in the Using JMP book.

Holdback Randomly divides the original data into the training and validation data sets. The 

Validation Portion on the platform launch window is used to specify the proportion of the 

original data to use as the validation data set (holdback). See “Launch the Partition 

Platform” on page 87 for details about the Validation Portion.

KFold Crossvalidation Randomly divides the original data into K subsets. In turn, each of 

the K sets is used to validate the model fit on the rest of the data, fitting a total of K models. 

The final model is selected based on the cross validation RSquare, where a stopping rule is 

imposed to avoid overfitting the model. This method is useful for small data sets, because 

it makes efficient use of limited amounts of data. See “K-Fold Crossvalidation” on 

page 109.

Validation Column Uses a column’s values to divide the data into subsets. A validation 

column must contain at most three numeric values. The column is assigned using the 

Validation role on the Partition launch window. See “Launch the Partition Platform” on 

page 87.

The column’s values determine how the data is split:

– If the validation column has two levels, the smaller value defines the training set and 

the larger value defines the validation set.

– If the validation column has three levels, the values, in order of increasing size, define 

the training, validation, and test sets.
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If you click the Validation button with no columns selected in the Select Columns list, you 

can add a validation column to your data table. For more information about the Make 

Validation Column utility, see “Make Validation Column Utility”.

K-Fold Crossvalidation

In K-Fold cross validation, the entire set of observations is partitioned into K subsets, called 

folds. Each fold is treated as a holdback sample with the remaining observations as a training 

set.

Unconstrained optimization of the crossvalidation RSquare value tends to overfit models. To 

address this tendency, the KFold crossvalidation stopping rule terminates stepping when 

improvement in the crossvalidation RSquare is minimal. Specifically, the stopping rule selects 

a model for which none of the next ten models have a crossvalidation RSquare showing an 

improvement of more than 0.005 units.

When you select the K Fold Crossvalidation option, a Crossvalidation report appears. The 

results in this report update as you split the decision tree. Or, if you click Go, the outline 

shows the results for the final model.

Crossvalidation Report

The Crossvalidation report shows the following:

k-fold Number of folds.

-2LogLike or SSE Gives twice the negative log-likelihood (-2LogLikelihood) values when 

the response is categorical. Gives sum of squared errors (SSE) when the response is 

continuous. The first row gives results averaged over the folds. The second row gives 

results for the single model fit to all observations.

RSquare The first row gives the RSquare value averaged over the folds. The second row 

gives the RSquare value for the single model fit to all observations.

Additional Examples of Partitioning

• “Example of a Continuous Response”

• “Example of Informative Missing”

• “Example of Profit Matrix and Decision Matrix Report”
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Example of a Continuous Response

In this example, you use the Partition platform to construct a decision tree that predicts the 

one-year disease progression measured on a quantitative scale for patients with diabetes.

1. Select Help > Sample Data Library and Diabetes.jmp.

2. Select Analyze > Predictive Modeling > Partition.

3. Select Y and click Y, Response.

4. Select Age through Glucose and click X, Factor.

5. Select a validation procedure based on your JMP installation:

– For JMP Pro, select Validation and click Validation.

– For JMP, enter 0.3 as the Validation Portion.

The completed launch window for JMP users is shown in Figure 5.19.

Note: Results using the validation proportion can differ from those shown here due to the 

random selection of validation rows.

Figure 5.19  Completed Launch Window with Validation Portion = 0.3

6. Click OK.

7. On the platform report window, click Split once to perform a split.
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Figure 5.20  Report after First Split with Decision Tree Hidden

The original 309 values in the training data set are now split into two parts:

– The left leaf, corresponding to LTG < 4.6444, has 165 observations.

– The right leaf, corresponding to LTG >= 4.6444 has 144 observations.

For both the right and left leaf the next split would be on BMI. The Candidate SS for BMI 

on the right leaf is higher than the Candidate SS for BMI on the left leaf. Thus, the next 

split is on the right leaf.

8. Click Go to use automatic splitting.
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Figure 5.21  Report after Automatic Splitting with Validation

The solution found has four splits. The Split History plot shows that there is no further 

improvement in the validation data set after four splits. The RSquare value of 0.39 on the 

validation data does not support this model as a strong predictor of disease progression. The 

scatter across partitions in the partition plot further indicate that this model does not separate 

the Y levels well.

Example of Informative Missing

In this example, you construct a decision tree model to predict if a customer is a credit risk. 

Since your data set contains missing values, you also explore the effectiveness of the 

Informative Missing option.
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Launch the Partition Platform

1. Select Help > Sample Data Library and open Equity.jmp.

2. Select Analyze > Predictive Modeling > Partition.

3. Select BAD and click Y, Response.

4. Select LOAN through DEBTINC and click X, Factor.

5. Click OK.

Create the Decision Tree and ROC Curve with Informative Missing

1. Hold down the Shift key and click Split.

2. Enter 5 for the number of splits and click OK.

3. Click the red triangle next to Partition for BAD and select ROC Curve.

4. Click the red triangle next to Partition for BAD and select Save Columns > Save Prediction 
Formula.

The columns Prob(BAD==Good Risk) and Prob(BAD==Bad Risk) contain the formulas that 

Informative Missing utility uses to classify the credit risk of future loan applicants. You are 

interested in how this model performs in comparison to a model that does not use 

informative missing.

Create the Decision Tree and ROC Curve without Informative Missing

1. Click the red triangle next to Partition for BAD and select Redo > Relaunch Analysis

2. De-select Informative Missing.

3. Click OK and repeat the steps in “Create the Decision Tree and ROC Curve with 

Informative Missing”.

The columns Prob(BAD==Good Risk) 2 and Prob(BAD==Bad Risk) 2 contain the formulas 

that do not use the informative missing utility.

Compare the ROC Curves

Visually compare the ROC curves from the two models. The model at left is with Informative 

Missing, and the model at right is without Informative Missing.
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Figure 5.22  ROC Curves for Models with (Left) and without (Right) Informative Missing

The area under the curve (AUC) for the model with informative missing (0.8695) is higher 

than the AUC for the model without informative missing (0.7283). Because there are only 

two levels for the response, the ROC curves for each model are reflections of one another 

and the AUCs are equal.

Note: Your AUC can differ from that shown for the model without informative missing. 

When informative missing is not used, the assignment of missing rows to sides of a split is 

random. Rerunning the analysis can result in slight differences in results.

Use the Model Comparison Platform

Next, compare the models using the Model Comparison platform to compare the two sets of 

formulas that you created in step 4 and step 3.

1. Select Analyze > Predictive Modeling > Model Comparison.

2. Select Prob(BAD==Good Risk), Prob(BAD==Bad Risk), Prob(BAD==Good Risk) 2, and 

Prob(BAD==Bad Risk) 2 and click Y, Predictors.

The first pair of formula columns contain the formulas from the model with informative 

missing. The second pair of formula columns contain the formulas from the model 

without informative missing.

3. Click OK.
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Figure 5.23  Measures of Fit from Model Comparison

The Measures of Fit report shows that the first model, which was fit with informative 

missing, performs better than the second model, which was not fit with informative 

missing. The first model has higher RSquare values as well as a lower RMSE value and a 

lower Misclassification Rate. These findings align the ROC curves comparison.

Note: Again, your results can differ due to the random differences when Informative 

Missing is not used.

Example of Profit Matrix and Decision Matrix Report

For this example, consider a study of patients who have liver cancer. Based on various 

measurements and markers, you want to classify patients according to their disease severity 

(high or low). There are two errors that one can make in classification of patients: classifying a 

subject who has high severity into the low group, or classifying a patient with low severity 

into the high group. Clinically, the misclassification of a high patient as low is a costly error, as 

that patient might not receive the aggressive treatment needed. Classifying a patient with low 

severity into the high severity group is a less costly error. That patient might receive the more 

aggressive treatment than needed, but this is not a major concern.

In the following example, you define a profit matrix in the context of a liver cancer study and 

obtain a Decision Matrix report. The Decision Matrix report helps you assess your 

classification rates relative to the costs in your profit matrix.

1. Select Help > Sample Data Library and open Liver Cancer.jmp.

2. Select Analyze > Predictive Modeling > Partition.

3. Select Severity and click Y, Response.

4. Select BMI through Jaundice and click X, Factor.

5. Select a validation procedure based on your JMP installation:

– For JMP Pro, select Validation and click Validation.

– For JMP, enter 0.3 as the Validation Proportion.

Note: Results using the validation proportion can differ from those shown here, due to the 

random selection of validation rows.
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Figure 5.24  Completed Launch Window with Validation Portion = 0.3

6. Click OK.

7. Hold down the Shift key and click Split.

8. Enter 10 for the number of splits and click OK.

Check that the Number of Splits is 10 in the panel beneath the plot.

9. Click the red triangle next to Partition for Severity and select Specify Profit Matrix.

10. Change the entries as follows:

– Enter 1 in the High, High box.

– Enter -5 in the High, Low box.

– Enter -3 in the Low, High box.

– Enter 1 in the Low, Low box.

Figure 5.25  Completed Profit Matrix

Tip: You can save this profit matrix as a column property for use in later analyses. Select 

the check box “Save to column as property” at the bottom of the profit matrix window.

Note the following:

– Each value of 1 reflects your profit when you make a correct decision.

– The -3 value indicates that if you classify a Low severity patient as High severity, your 

loss is 3 times as much as the profit of a correct decision.
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– The -5 value indicates that if you classify a High severity patient as Low severity, your 

loss is 5 times as much as the profit of a correct decision.

11. Click OK.

12. Click the red triangle next to Partition for Severity and select Show Fit Details.

Figure 5.26  Confusion Matrix and Decision Matrix Reports

The Confusion Matrix and Decision Matrix reports follow the list of Measures in the Fit 

Details report. Notice that the Confusion Matrix report and the confusion matrices in the 

Decision Matrix report show different counts. This is because the weighting in the profit 

matrix results in different decisions than do the predicted probabilities without weighting.

The Confusion Matrix for the validation set shows classifications based on predicted 

probabilities alone. Based on these, 11 High severity patients would be classified as Low 

severity and 5 Low severity patients would be classified as High severity.

The Decision Matrix report incorporates the profit matrix weights. Using those weights, 

only 6 High severity patients are classified as Low severity. However, this comes at the 

expense of misclassifying 6 Low severity patients into the High severity group (1 

additional patient).

13. Click the red triangle next to Partition for Severity and select Save Columns > Save 
Prediction Formula.

mmmp
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Eight columns are added to the data table.

Tip: To quickly return to the data table, click the View Associated Data icon  in the 

bottom right corner of the report window.

– The first three columns involve only the predicted probabilities. The confusion matrix 

counts are based on the Most Likely Severity column, which classifies a patient into the 

level with the highest predicted probability. These probabilities are given in the 

Prob(Severity == High) and Prob(Severity == Low) columns.

– The last five columns involve the profit matrix weighting. The column called 

Most Profitable Prediction for Severity contains the decision based on the profit matrix. 

The decision for a patient is the level that results in the largest profit. The profits are 

given in the Profit for High and Profit for Low columns.

Statistical Details for the Partition Platform

• “Responses and Factors”

• “Splitting Criterion”

• “Predicted Probabilities in Decision Tree and Bootstrap Forest”

Responses and Factors

The response can be either continuous or categorical (nominal or ordinal):

• If the response is categorical, then it is fitting the probabilities estimated for the response 

levels, minimizing the residual log-likelihood chi-square [2*entropy].

• If the response is continuous, then the platform fits means, minimizing the sum of squared 

errors.

The factors can be either continuous or categorical (nominal or ordinal):

• If the factor is continuous, then the partition is done according to a splitting “cut” value for 

the factor.

• If the factor is categorical, then it divides the X categories into two groups of levels and 

considers all possible groupings into two levels.

Splitting Criterion

Node splitting is based on the LogWorth statistic, which is reported in Candidate reports for 

nodes. LogWorth is calculated as follows:
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-log10(p-value)

where the adjusted p-value is calculated in a complex manner that takes into account the 

number of different ways splits can occur. This calculation is very fair compared to the 

unadjusted p-value, which favors Xs with many levels, and the Bonferroni p-value, which 

favors Xs with small numbers of levels. Details about the method are discussed in Sall (2002).

For continuous responses, the Sum of Squares (SS) is reported in node reports. This is the 

change in the error sum-of-squares due to the split.

A candidate SS that has been chosen is:

SStest = SSparent - (SSright + SSleft) where SS in a node is just s2(n - 1).

Also reported for continuous responses is the Difference statistic. This is the difference 

between the predicted values for the two child nodes of a parent node.

For categorical responses, the G2 (likelihood-ratio chi-square) appears in the report. This is 

actually twice the [natural log] entropy or twice the change in the entropy. Entropy is  -log(p) 

for each observation, where p is the probability attributed to the response that occurred.

A candidate G2 that has been chosen is:

G2 test = G2 parent - (G
2 left + G2 right).

Partition actually has two rates; one used for training that is the usual ratio of count to total, 

and another that is slightly biased away from zero. By never having attributed probabilities of 

zero, this allows logs of probabilities to be calculated on validation or excluded sets of data, 

used in Entropy R-Square.

Predicted Probabilities in Decision Tree and Bootstrap Forest

The predicted probabilities for the Decision Tree and Bootstrap Forest methods are calculated 

as described below by the Prob statistic.

For categorical responses in Decision Tree, the Show Split Prob command shows the following 

statistics:

Rate The proportion of observations at the node for each response level.

Prob The predicted probability for that node of the tree. The method for calculating Prob for 

the ith response level at a given node is as follows:
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where the summation is across all response levels; ni is the number of observations at the 

node for the ith response level; and priori is the prior probability for the ith response level, 

calculated as:

priori = pi+ (1-)Pi

where pi is the priori from the parent node, Pi is the Probi from the parent node, and  is a 

weighting factor currently set at 0.9.

The method for calculating Prob assures that the predicted probabilities are always 

nonzero.

Probi

ni priori+

ni priori+ 
--------------------------------------=
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Fit a Model By Averaging Many Trees

The Bootstrap Forest platform is available only in JMP Pro.

The Bootstrap Forest platform fits an ensemble model by averaging many decision trees each 

of which is fit to a bootstrap sample of the training data. Each split in each tree considers a 

random subset of the predictors. In this way, many weak models are combined to produce a 

more powerful model. The final prediction for an observation is the average of the predicted 

values for that observation over all the decision trees.

Figure 6.1  Example of a Cumulative Validation Report
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Overview of the Bootstrap Forest Platform

The Bootstrap Forest platform predicts a response value by averaging the predicted response 

values across many decision trees. Each tree is grown on a bootstrap sample of the training data. 

A bootstrap sample is a random sample of observations, drawn with replacement. In addition, 

the predictors are sampled at each split in the decision tree. The decision tree is fit using the 

recursive partitioning methodology described in the “Partition Models” chapter.

The fitting process for the training set proceeds as follows:

1. For each tree, select a bootstrap sample of observations.

2. Fit the individual decision tree, using recursive partitioning, as follows:

– Select a random set of predictors for each split.

– Continue splitting until a stopping rule that is specified in the Bootstrap Forest 

Specification window is met.

3. Repeat step 1 and step 2 until the number of trees specified in the Bootstrap Forest 

Specification window is reached or until Early Stopping occurs.

For an individual tree, the bootstrap sample of observations that is used to fit the tree is drawn 

with replacement. You can specify the proportion of observations to be sampled. If you specify 

that 100% of the observations are to be sampled, because they are drawn with replacement, 

the expected proportion of unused observations is 1/e, or approximately 36.8%. For each 

individual tree, these unused observations are called the out-of-bag observations. The 

observations used in fitting the tree are called in-bag observations. For a continuous response, 

the Bootstrap Forest platform provides measures for the error rate for out-of-bag observations, 

called out-of-bag error.

For a continuous response, the predicted value for an observation is the average of its 

predicted values over the collection of individual trees. For a categorical response, the 

predicted probability for an observation is the average of its predicted probabilities over the 

collection of individual trees. The observation is classified into the level for which its predicted 

probability is the highest.

For more information about bootstrap forests, see Hastie et al. (2009).
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Example of Bootstrap Forest with a Categorical 
Response

In this example, you construct a bootstrap forest model to predict whether a customer is a bad 

credit risk. But you are aware that your data set contains missing values, so you also explore 

the degree to which values are missing.

Bootstrap Forest Model

1. Select Help > Sample Data Library and open Equity.jmp.

2. Select Analyze > Predictive Modeling > Bootstrap Forest.

3. Select BAD and click Y, Response.

4. Select LOAN through DEBTINC and click X, Factor.

5. Select Validation and click Validation.

6. Click OK.

7. Next to Maximum Splits per Tree, enter 30.

8. Select Multiple Fits over Number of Terms and enter 5 next to Max Number of Terms.

9. (Optional) Select Suppress Multithreading and enter 123 next to Random Seed.

Because the bootstrap forest method involves random sampling, these actions ensure that 

you will obtain the exact results shown below.

10. Click OK.

Figure 6.2  Overall Statistics Report
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Because the Multiple Fits over Number of Terms option was specified, models were 

created using 3, 4, and 5 as the number of predictors in each split. The Model 

Validation-Set Summaries report shows that the model whose Validation set has the 

highest Entropy RSquare is the five-term model. This is also the model with the smallest 

misclassification rate. This model is determined to be the best model, and the results in the 

Overall report are for this model.

The Overall report shows that the misclassification rates for the Validation and Test sets 

are about 11.3% and 9.9%, respectively. The confusion matrices suggest that the largest 

source of misclassification is the classification of bad risk customers as good risks.

The results for the Test set give you an indication of how well your model extends to 

independent observations. The Validation set was used in selecting the Bootstrap Forest 

model. For this reason, the results for the Validation set give a biased indication of how the 

model generalizes to independent data.

You are interested in determining which predictors contributed the most to your model.

11. Click the red triangle next to Bootstrap Forest for BAD and select Column Contributions.

Figure 6.3  Column Contributions Report

The Column Contributions report suggests that the strongest predictor of a customer’s 

credit risk is DEBTINC, which is the debt to income ratio. The next highest contributors to 

the model are DELINQ, the number of delinquent credit lines, and VALUE, the assessed 

value of the customer.

Missing Values

Next, you explore the extent to which predictor values are missing.

1. Select Analyze > Screening > Explore Missing Values.

2. Select Bad through DEBTINC and click Y, Columns.

3. Click OK in the Alert that appears.
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The columns REASON and JOB are not added to the Y, Columns list because they have a 

Character data type. You can see how many values are missing for these two columns 

using Distribution (not illustrated in this example).

4. Click OK.

Figure 6.4  Missing Values Report

The DEBTINC column contains 1267 missing values, which amounts to about 21% of the 

observations. Most other columns involved in the Bootstrap Forest analysis also contain 

missing values. The Informative Missing option in the launch window ensures that the 

missing values are treated in a way that acknowledges any information that they carry. For 

details, see “Informative Missing” on page 102 in the “Partition Models” chapter.

Example of Bootstrap Forest with a Continuous 
Response

In this example, you construct a bootstrap forest model to predict the percent body fat for 

male subjects.

1. Select Help > Sample Data Library and open Body Fat.jmp.

2. Select Analyze > Predictive Modeling > Bootstrap Forest.

3. Select Percent body fat and click Y, Response.

4. Select Age (years) through Wrist circumference (cm) and click X, Factor.

5. Select Validation and click Validation.

6. Click OK.
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7. (Optional) Select  Suppress Multithreading and enter 123 next to Random Seed.

Because the bootstrap forest method involves random sampling, these actions ensure that 

you will obtain the exact results shown below.

8. Click OK.

Figure 6.5  Overall Statistics

The Overall Statistics report shows that the Validation RSquare is 0.673.

You are interested in obtaining a model-independent indication of the most important 

predictors.

9. Click the red triangle next to Bootstrap Forest for Percent body fat and select Column 
Contributions.

Figure 6.6  Column Contributions

The Column Contributions report suggests that Abdomen circumference (cm), Weight (cm), 
and Chest circumference (cm) are the strongest predictors for Percent body fat.
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Launch the Bootstrap Forest Platform

Launch the Bootstrap Forest platform by selecting Analyze > Predictive Modeling > Bootstrap 
Forest.

Launch Window

Figure 6.7  Bootstrap Forest Launch Window

The Bootstrap Forest platform launch provides the following options:

Y, Response The response variable or variables that you want to analyze.

X, Factor The predictor variables.

Weight A column whose numeric values assign a weight to each row in the analysis.

Freq A column whose numeric values assign a frequency to each row in the analysis.

Validation A numeric column that contains at most three distinct values. See “Validation” 

on page 107 in the “Partition Models” chapter.
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By A column or columns whose levels define separate analyses. For each level of the 

specified column, the corresponding rows are analyzed using the other variables that you 

have specified. The results are presented in separate reports. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.

Method Enables you to select the partition method (Decision Tree, Bootstrap Forest, Boosted 

Tree, K Nearest Neighbors, or Naive Bayes). These alternative methods, except for 

Decision Tree, are available in JMP Pro.

For more details on these methods, see Chapter 5, “Partition Models”, Chapter 7, “Boosted 

Tree”, Chapter 8, “K Nearest Neighbors”, and Chapter 9, “Naive Bayes”.

Validation Portion The portion of the data to be used as the validation set. See “Validation” 

on page 107 in the “Partition Models” chapter.

Informative Missing If selected, enables missing value categorization for categorical 

predictors and informative treatment of missing values for continuous predictors. See 

“Informative Missing” on page 102 in the “Partition Models” chapter.

Ordinal Restricts Order If selected, restricts consideration of splits to those that preserve 

the ordering.

Specification Window

After you select OK in the launch window, the Bootstrap Forest Specification window appears.
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Figure 6.8  Bootstrap Forest Specification Window

Specification Panel

Number of Rows The number of rows in the data table.

Number of Terms The number of columns that are specified as predictors.

Forest Panel

Number of Trees in the Forest Number of trees to grow and then average.

Number of Terms Sampled per Split Number of predictors to consider as splitting 

candidates at each split. For each split, a new random sample of predictors is taken as the 

candidate set.

Bootstrap Sample Rate Proportion of observations to sample (with replacement) for 

growing each tree. A new random sample is generated for each tree.

Minimum Splits Per Tree Minimum number of splits for each tree.

Maximum Splits Per Tree Maximum number of splits for each tree.

Minimum Size Split Minimum number of observations needed on a candidate split.

Early Stopping (Available only if validation is used.) If selected, the process stops growing 

additional trees if adding more trees does not improve the validation statistic. The 

validation statistic is the validation set’s Entropy RSquare value for a categorical response 
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and its RSquare value for a continuous response. If not selected, the process continues 

until the specified number of trees is reached.

Multiple Fits Panel

Multiple Fits over Number of Terms If selected, creates a bootstrap forest for several 

values of number of terms sampled per split. The model for which results are displayed is 

the model whose Validation Set’s Entropy RSquare value (for a categorical response) or 

RSquare (for a continuous response) is the largest.

The lower bound is the Number of Terms Sampled per Split specification. The upper 

bound is specified by the following option:

Max Number of Terms The maximum number of terms to consider for a split.

Use Tuning Table Design Opens a window where you can select a data table containing 

values for the Forest panel tuning parameters, called a tuning design table. A tuning design 

table has a column for each option that you want to specify and has one or multiple rows 

that each represent a single Bootstrap Forest model design. If an option is not specified in 

the tuning design table, the default value is used.

For each row in the table, JMP creates a Bootstrap Forest model using the tuning 

parameters specified. If more than one model is specified in the tuning design table, the 

Model Validation-Set Summaries report lists the RSquare value for each model. The 

Bootstrap Forest report shows the fit statistics for the model with the largest RSquare 

value.

You can create a tuning design table using the Design of Experiments facilities. A 

bootstrap forest tuning design table can contain the following case-insensitive columns in 

any order:

– Number Trees

– Number Terms

– Portion Bootstrap

– Minimum Splits per Tree

– Maximum Splits per Tree

– Minimum Size Split

Reproducibility Panel

Suppress Multithreading If selected, all calculations are performed on a single thread.
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Random Seed Specify a nonzero numeric random seed to reproduce the results for future 

launches of the platform. By default, the Random Seed is set to zero, which does not 

produce reproducible results. When you save the analysis to a script, the random seed that 

you enter is saved to the script.

The Bootstrap Forest Report

After you click OK in the Bootstrap Forest Specification window, a window appears that 

informs you of approximately how long it will take JMP to fit the model. If the approximated 

time is too long, you have the option to view the current model by selecting Accept Current 
Model (Figure 6.9). The Bootstrap Forest report appears after the complete model is fit or after 

the current model is accepted (Figure 6.10 and Figure 6.11).

Figure 6.9  Accept Current Model Dialog

Figure 6.10  Bootstrap Forest Report for a Categorical Response
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Figure 6.11  Bootstrap Forest Report for a Continuous Response

The following reports are provided, depending on whether the response is categorical or 

continuous:

• “Model Validation-Set Summaries” on page 133

• “Specifications” on page 133

• “Overall Statistics” on page 133

• “Cumulative Validation” on page 135

• “Per-Tree Summaries” on page 136

Model Validation-Set Summaries

(Available when you select the Multiple Fits over Number of Terms option in Bootstrap Forest 

Specification window.) Provides fit statistics for all the models fit. See Figure 6.10 and 

“Multiple Fits Panel” on page 131.

Specifications

Shows the settings used in fitting the model.

Overall Statistics

Provides fit statistics for the training set, and for the validation and test sets if they are 

specified. The specific form of the report depends on the modeling type of the response.
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Suppose that multiple models are fit using the Multiple Fits over Multiple Terms option in the 

Bootstrap Forest Specification window. Then the model for which results are displayed in the 

Overall Statistics and Cumulative Validation reports is the model for which the validation set’s 

Entropy RSquare value (for a categorical response) or RSquare (for a continuous response) is 

the largest.

Categorical Response

Measures Report

Gives the following statistics for the training set, and for the validation and test sets if there are 

specified.

Note: For Entropy RSquare and Generalized RSquare, values closer to 1 indicate a better fit. 

For Mean -Log p, RMSE, Mean Abs Dev, and Misclassification Rate, smaller values indicate a 

better fit.

Entropy RSquare One minus the ratio of the negative log-likelihoods from the fitted model 

and the constant probability model. It ranges from 0 to 1.

Generalized RSquare A measure that can be applied to general regression models. It is 

based on the likelihood function L and is scaled to have a maximum value of 1. The value 

is 1 for a perfect model, and 0 for a model no better than a constant model. The 

Generalized RSquare measure simplifies to the traditional RSquare for continuous normal 

responses in the standard least squares setting. Generalized RSquare is also known as the 

Nagelkerke or Craig and Uhler R2, which is a normalized version of Cox and Snell’s 

pseudo R2.

Mean -Log P The average of negative log(p), where p is the fitted probability associated 

with the event that occurred.

RMSE The root mean square error, adjusted for degrees of freedom. The differences are 

between 1 and p, the fitted probability for the response level that actually occurred.

Mean Abs Dev The average of the absolute values of the differences between the response 

and the predicted response. The differences are between 1 and p, the fitted probability for 

the response level that actually occurred.

Misclassification Rate The rate for which the response category with the highest fitted 

probability is not the observed category.

N The number of observations.
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Confusion Matrix

(Available only for categorical responses.) Shows classification statistics for the training set, 

and for the validation and test sets if they are specified.

Decision Matrix

(Available only for categorical responses and if the response has a Profit Matrix column 

property or if you specify costs using the Specify Profit Matrix option.) Gives Decision Count 

and Decision Rate matrices for the training set, and for the validation and test sets if they are 

specified. See “Additional Examples of Partitioning” on page 109 in the “Partition Models” 

chapter.

Continuous Response

Individual Trees Report

Gives RMSE values, which are averaged over all trees, for In Bag and Out of Bag observations. 

Training set observations that are used to construct a tree are called in-bag observations. 

Training observations that are not used to construct a tree are called out-of-bag (OOB) 

observations.

For each tree, the Out of Bag RMSE is computed as the square root of the sum of squared 

errors divided by the number of OOB observations. The squared Out of Bag RMSE for each 

tree is given in the Per-Tree Summaries report as OOB SSE/N.

RSquare and RMSE Report

Gives Rsquare, root mean square error, and the number of observations for the training set, 

and for the validation and test sets, if they are defined.

Cumulative Validation

(Available only if validation is used.) Shows a plot of the fit statistics for the Validation set 

versus the number of trees.

For a continuous response, the single fit statistic is R-Square. For a categorical response, the fit 

statistics are listed below and are described in “Measures Report” on page 134.

• RSquare (Entropy RSquare)

• Avg - Log p (Mean - Log p)

• RMS Error (RMSE)

• Avg Abs Error (Mean Abs Dev)

• MR (Misclassification Rate)
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The Cumulative Details report below the Cumulative Validation plot gives the values used in 

the plot.

Per-Tree Summaries

The Per-Tree Summaries report involves the concepts of in-bag and out-of-bag observations. 

For an individual tree, the bootstrap sample of observations used in fitting the tree is drawn 

with replacement. Even if you specify that 100% of the observations are to be sampled, 

because they are drawn with replacement, the expected proportion of unused observations is 

1/e. For each individual tree, the unused observations are called the out-of-bag observations. 

The observations used in fitting the tree are called in-bag observations.

The Per-Tree Summaries report shows the following summary statistics for each tree:

Splits Number of splits in the decision tree.

Rank Rank of the tree’s OOB Loss in ascending order. The tree with the smallest OOB loss 

has Rank 1.

OOB Loss A measure of the total predictive inaccuracy of the tree when applied to the Out 

Of Bag rows. Lower values indicate a higher predictive accuracy.

OOB Loss/N The OOB Loss divided by the number of OOB rows, OOB N.

RSquare (Available only for continuous responses.) The RSquare value for the tree.

IB SSE (Available only for continuous responses.) Sum of squared errors for the In Bag 

rows.

IB SSE/N (Available only for continuous responses.) Sum of squared errors for the In Bag 

rows divided by the number of In Bag observations. The number of In Bag observations is 

equal to the number of observations in the training set multiplied by the bootstrap 

sampling rate that you specify in the Bootstrap Forest Specification window.

OOB N (Available only for continuous responses.) Number of Out Of Bag rows.

OOB SSE (Available only for continuous responses.) Sum of squared errors when the tree is 

applied to the Out Of Bag rows.

OOB SSE/N (Available only for continuous responses.) The OOB SSE divided by the 

number of OOB rows, OOB N.
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Bootstrap Forest Platform Options

The Bootstrap Forest report red triangle menu has the following options:

Plot Actual by Predicted (Available only for continuous responses.) Provides a plot of 

actual versus predicted values.

Column Contributions Displays a report that shows each input column’s contribution to 

the fit. The report also shows:

– The total number of splits defined by a column.

– The total G2 (for a categorical response) or SS, sum of squares (for a continuous 

response), attributed to the column.

– A bar chart of G2 or SS.

– The proportion of G2 or SS attributed to the column.

Show Trees Provides various options for displaying trees in the Tree Views report. The 

report gives a picture of the tree that is fit at each layer of the boosting process. For a 

description of the Prob column shown by the Show names categories estimates option, see 

“Predicted Probabilities in Decision Tree and Bootstrap Forest” on page 119 in the 

“Partition Models” chapter.

ROC Curve (Available only for categorical responses.) See “ROC Curve” on page 104 in the 

“Partition Models” chapter.

Lift Curve (Available only for categorical responses.) See “Lift Curve” on page 105 in the 

“Partition Models” chapter.

Save Columns Contains options for saving model and tree results, and creating SAS code.

Save Predicteds Saves the predicted values from the model to the data table.

Save Prediction Formula Saves the prediction formula to a column in the data table. 

The formula consists of nested conditional clauses that describe the tree structure. If the 

response is continuous, the column contains a Predicting property. If the response is 

categorical, the column contains a Response Probability property.

Save Tolerant Prediction Formula (The Save Prediction Formula option should be 

used instead of this option. Use this option only when Save Prediction Formula is not 

available.) Saves a formula that predicts even when there are missing values and when 

Informative Missing has not been selected. The prediction formula tolerates missing 

values by randomly allocating response values for missing predictors to a split. If the 

response is continuous, the column contains a Predicting property. If the response is 
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categorical, the column contains a Response Probability property. If you have selected 

Informative Missing, you can save the Tolerant Prediction Formula by holding the Shift 

key as you click on the report’s red triangle.

Save Residuals (Available only for continuous responses.) Saves the residuals to the 

data table.

Save Cumulative Details (Available only if validation is used.) Creates a data table 

containing the fit statistics for each tree.

Publish Prediction Formula Creates a prediction formula and saves it as a formula 

column script in the Formula Depot platform. If a Formula Depot report is not open, 

this option creates a Formula Depot report. See the “Formula Depot” chapter on 

page 197.

Publish Tolerant Prediction Formula (The Publish Prediction Formula option should 

be used instead of this option. Use this option only when Publish Prediction Formula is 

not available.) Creates a tolerant prediction formula and saves it as a formula column 

script in the Formula Depot platform. If a Formula Depot report is not open, this option 

creates a Formula Depot report. See the “Formula Depot” chapter on page 197. If you 

have selected Informative Missing, you can use this option by holding the Shift key as 

you click on the report’s red triangle.

Make SAS DATA Step Creates SAS code for scoring a new data set.

Specify Profit Matrix (Available only for categorical responses.) Enables you to specify 

profit or costs associated with correct or incorrect classification decisions. See “Show Fit 

Details” on page 98 in the “Partition Models” chapter.

Profiler Shows a Prediction Profiler. For more information, see the Profiler chapter in the 

Profilers book.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.
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Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.
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Chapter 7
Boosted Tree

Fit Many Layers of Trees, Each Based on the Previous Layer

The Boosted Tree platform is available only in JMP Pro.

Boosting is the process of building a large, additive decision tree by fitting a sequence of 

smaller decision trees, called layers. The tree at each layer consists of a small number of splits. 

The tree is fit based on the residuals of the previous layers, which allows each layer to correct 

the fit for bad fitting data from the previous layers. The final prediction for an observation is 

the sum of the predictions for that observation over all of the layers.

Figure 7.1  Example of Boosted Tree Layers
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Overview of the Boosted Tree Platform

The Boosted Tree platform produces an additive decision tree model that is based on many 

smaller decision trees that are constructed in layers. The tree in each layer consists of a small 

number of splits, typically five or fewer. Each layer is fit using the recursive fitting 

methodology described in the “Partition Models” chapter. The only difference is that fitting 

stops at a specified number of splits. For a given tree, the predicted value for an observation in 

a leaf is the mean of all observations in that leaf.

The fitting process proceeds as follows:

1. Fit an initial layer.

2. Compute residuals. These are obtained by subtracting the predicted mean for observations 

within a leaf from their actual value.

3. Fit a layer to the residuals.

4. Construct the additive tree. For a given observation, sum its predicted values over the 

layers.

5. Repeat step 2 to step 4 until the specified number of layers is reached, or, if validation is 

used, until fitting an additional layer no longer improves the validation statistic.

The final prediction is the sum of the predictions for an observation over all the layers.

By fitting successive layers on residuals from previous layers, each layer can improve the fit.

For categorical responses, only those with two response levels are supported. For a categorical 

response, the residuals fit at each layer are offsets of linear logits. The final prediction is a 

logistic transformation of the sum of the linear logits over all the layers.

For more information about boosted trees, see Hastie et al. (2009).

Example of Boosted Tree with a Categorical 
Response

In this example, you construct a boosted tree model to predict which printing jobs are affected 

by a defect called banding.

1. Select Help > Sample Data and open Bands Data.jmp.

2. Select Analyze > Predictive Modeling > Boosted Tree.

3. Select Banding? and click Y, Response.

4. Select the Predictors column group and click X, Factor.

5. Enter 0.2 for Validation Portion.
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6. Click OK.

The Boosted Tree Specification window appears.

7. (Optional) In the Reproducibility panel, select  Suppress Multithreading and enter 123 for 

Random Seed.

Because the boosted tree fit involves a random component, these actions ensure that you 

obtain the exact results shown below.

8. Click OK.

Figure 7.2  Overall Statistics for Nominal Response

Because the response, Banding?, is categorical, the Boosted Tree analysis provides a 

Misclassification Rate under Measure and a Confusion Matrix report. The 

Misclassification Rate for the validation set is 0.2222, or about 22%.

9. Click the red triangle next to Boosted Tree for Banding? and select Show Trees > Show 
names categories estimates.

A Tree Views report appears, with outlines for the layers. You can examine the layers to 

see the trees that are fit and the predicted values.
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Figure 7.3  Layer 1 of the Boosted Tree

10. Click the red triangle next to Boosted Tree for Banding? and select Save Columns > Save 
Prediction Formula.

Columns called Prob(Banding?==noband), Prob(Banding?==band), and Most Likely 
Banding? are added to the data table. Examine the Prob(Banding?==noband) column to see 

how model predictions are calculated from the layers.

Example of Boosted Tree with a Continuous 
Response

In this example, you construct a boosted tree model to predict the percent body fat given a 

combination of nominal and continuous factors.

1. Select Help > Sample Data and open the Body Fat.jmp sample data table.

2. Select Analyze > Predictive Modeling > Boosted Tree.

3. Select Percent body fat and click Y, Response.

4. Select  Age (years) through Wrist circumference (cm) and click X, Factor.

5. Select Validation and click Validation.

6. Click OK.

7. Click OK.
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Figure 7.4  Overall Statistics for Continuous Response

The Overall Statistics report provides the R-square and RMSE for the boosted tree model. 

The R-square for the validation set is 0.603. The RMSE for the validation set is about 5.48.

You are interested in obtaining a model-independent indication of the important 

predictors for Percent body fat.

8. Click the red triangle next to Boosted Tree for Percent body fat and select Profiler.

9. Click the red triangle next to Prediction Profiler and select Assess Variable Importance > 
Independent Uniform Inputs.

Note: Because Assess Variable Importance uses randomization, your results will not 

exactly match those in Figure 7.5.

Figure 7.5  Summary Report for Variable Importance

The Summary Report shows that Abdomen circumference (cm) is the most important 

predictor of Percent body fat.

Launch the Boosted Tree Platform

Launch the Boosted Tree platform by selecting Analyze > Predictive Modeling > Boosted Tree.
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Figure 7.6  Boosted Tree Launch Window Using Body Fat.jmp

The Boosted Tree platform launch window has the following options:

Y, Response The response variable or variables that you want to analyze.

X, Factor The predictor variables.

Weight A column whose numeric values assign a weight to each row in the analysis.

Freq A column whose numeric values assign a frequency to each row in the analysis.

Validation A numeric column that contains at most three distinct values. See “Validation” 

on page 107 in the “Partition Models” chapter.

By A column or columns whose levels define separate analyses. For each level of the 

specified column, the corresponding rows are analyzed using the other variables that you 

have specified. The results are presented in separate reports. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.
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Method Enables you to select the partition method (Decision Tree, Bootstrap Forest, Boosted 

Tree, K Nearest Neighbors, or Naive Bayes). These alternative methods, except for 

Decision Tree, are available in JMP Pro.

For more details about these methods, see Chapter 5, “Partition Models”, Chapter 6, 

“Bootstrap Forest”, Chapter 8, “K Nearest Neighbors”, and Chapter 9, “Naive Bayes”.

Validation Portion The portion of the data to be used as the validation set. See “Validation” 

on page 107 in the “Partition Models” chapter.

Informative Missing If selected, enables missing value categorization for categorical 

predictors and informative treatment of missing values for continuous predictors. See 

“Informative Missing” on page 102 in the “Partition Models” chapter.

Ordinal Restricts Order If selected, restricts consideration of splits to those that preserve 

the ordering.

Specification Window

After you select OK in the launch window, the Gradient-Boosted Trees Specification window 

appears.

Figure 7.7  Boosted Tree Specification Window

Boosting Panel

Number of Layers Maximum number of layers to include in the final tree.

Splits per Tree Number of splits for each layer.
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Learning Rate A number such that 0r  1. Learning rates close to 1 result in faster 

convergence on a final tree, but also have a higher tendency to overfit data. Use learning 

rates closer to 1 when a small Number of Layers is specified. The learning rate is a small 

fraction typically between 0.01 and 0.1 that slows the convergence of the model. This 

preserves opportunities for later layers to use different splits than the earlier layers.

Overfit Penalty (Available only for categorical responses.) A biasing parameter that helps 

protect against fitting probabilities equal to zero.See “Overfit Penalty” on page 157.

Minimum Size Split Minimum number of observations needed on a candidate split.

Multiple Fits Panel

Multiple Fits over Splits and Learning Rate If selected, creates a boosted tree for every 

combination of Splits per Tree (in integer increments) and Learning Rate (in 0.1 

increments).

The lower bounds for the combinations are specified by the Splits per Tree and Learning 

Rate options. The upper bounds for the combinations are specified by the following 

options:

Max Splits per Tree Upper bound for Splits per Tree.

Max Learning Rate Lower bound for Learning Rate.

Use Tuning Design Table Opens a window where you can select a data table containing 

values for some tuning parameters, called a tuning design table. A tuning design table has a 

column for each option that you want to specify and has one or multiple rows that each 

represent a single Boosted Tree model design. If an option is not specified in the tuning 

design table, the default value is used.

For each row in the table, JMP creates a Boosted Tree model using the tuning parameters 

specified. If more than one model is specified in the tuning design table, the Model 

Validation-Set Summaries report lists the R-Square value for each model. The Boosted Tree 

report shows the fit statistics for the model with the largest R-Square value.

You can create a tuning design table using the Design of Experiments facilities. A boosted 

tree tuning design table can contain the following case-insensitive columns in any order:

– Number of Layers

– Splits per Tree

– Learning Rate

– Minimum Size Split

– Row Sampling Rate
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– Column Sampling Rate

Stochastic Boosting Panel

Row Sampling Rate Proportion of training rows to sample for each layer.

Note: When the response is categorical, the training rows are sampled using stratified 

random sampling.

Column Sampling Rate Proportion of predictor columns to sample for each layer.

Reproducibility Panel

Suppress Multithreading If selected, all calculations are performed on a single thread.

Random Seed Specify a nonzero numeric random seed to reproduce the results for future 

launches of the platform. By default, the Random Seed is set to zero, which does not 

produce reproducible results. When you save the analysis to a script, the random seed that 

you enter is saved to the script.

Early Stopping

Early Stopping If selected, the boosting process stops fitting additional layers when adding 

more layers does not improve the validation statistic. If not selected, the boosting process 

continues until the specified number of layers is reached. This option appears only if 

validation is used.

The Boosted Tree Report

After you click OK in the Gradient-Boosted Trees Specification window, the Boosted Tree 

report opens.
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Figure 7.8  Boosted Tree Report for a Continuous Response
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Figure 7.9  Boosted Tree Report for a Categorical Response

The following reports are provided, depending on whether the response is categorical or 

continuous:

• “Model Validation - Set Summaries” on page 153

• “Specifications” on page 153

• “Overall Statistics” on page 153

• “Cumulative Validation” on page 154
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Model Validation - Set Summaries

Shows fit statistics for all the models fit if you selected the Multiple Fits over Splits and 

Learning Rate option in the Specification window. See Figure 7.8 and “Multiple Fits Panel” on 

page 149.

Specifications

Shows the settings used in fitting the model.

Overall Statistics

Shows fit statistics for the training set, and for the validation and test sets if they are specified.

Suppose that you fit multiple models using the Multiple Fits over Splits and Learning Rate 

option in the Boosted Tree Specification window. Then the model for which results are 

displayed in the Overall Statistics and Cumulative Validation reports is the model for which 

the validation set’s Entropy R-square value (for a categorical response) or R-square (for a 

continuous response) is the largest.

Measures Report

(Available only for categorical responses.) Gives the following statistics for the training set, 

and for the validation and test sets if there are specified.

Note: For Entropy R-Square and Generalized R-Square, values closer to 1 indicate a better fit. 

For Mean -Log p, RMSE, Mean Abs Dev, and Misclassification Rate, smaller values indicate a 

better fit.

Entropy RSquare One minus the ratio of the negative log-likelihoods from the fitted model 

and the constant probability model. Entropy R-Square ranges from 0 to 1.

Generalized RSquare A measure that can be applied to general regression models. It is 

based on the likelihood function L and is scaled to have a maximum value of 1. The value 

is 1 for a perfect model, and 0 for a model no better than a constant model. The 

Generalized R-Square measure simplifies to the traditional R-Square for continuous 

normal responses in the standard least squares setting. Generalized R-Square is also 

known as the Nagelkerke or Craig and Uhler R2, which is a normalized version of Cox and 

Snell’s pseudo R2.

Mean -Log P The average of negative log(p), where p is the fitted probability associated 

with the event that occurred.
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RMSE The root mean square error, adjusted for degrees of freedom. The differences are 

between 1 and p, the fitted probability for the response level that actually occurred.

Mean Abs Dev The average of the absolute values of the differences between the response 

and the predicted response. The differences are between 1 and p, the fitted probability for 

the response level that actually occurred.

Misclassification Rate The rate for which the response category with the highest fitted 

probability is not the observed category.

N The number of observations.

Confusion Matrix

(Available only for categorical responses.) Shows classification statistics for the training set, 

and for the validation and test sets if they are specified.

Decision Matrix

(Available only for categorical responses and if the response has a Profit Matrix column 

property or if you specify costs using the Specify Profit Matrix option.) Gives Decision Count 

and Decision Rate matrices for the training set, and for the validation and test sets if they are 

specified. See “Additional Examples of Partitioning” on page 109 in the “Partition Models” 

chapter.

Cumulative Validation

(Available only if validation is used.) Shows a plot of the fit statistics for the Validation set 

versus the number of layers.

For a continuous response, the single fit statistic is R-Square. For a categorical response, the fit 

statistics are listed below and are described in “Measures Report” on page 153.

• R-Square (Entropy R-Square)

• Avg - Log p (Mean - Log p)

• RMS Error (RMSE)

• Avg Abs Error (Mean Abs Dev)

• MR (Misclassification Rate)

The Cumulative Details report below the Cumulative Validation plot gives the values used in 

the plot.
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Boosted Tree Platform Options

The Boosted Tree report red-triangle menu has the following options:

Show Trees Provides options for displaying trees in the Tree Views report. The report gives 

a picture of the tree that is fit at each layer of the boosting process.

Plot Actual by Predicted (Available only for continuous responses.) Provides a plot of 

actual versus predicted values.

Column Contributions Displays a report showing each input column’s contribution to the 

fit. The report also shows:

– The total number of splits defined by a column.

– The total G2 (for a categorical response) or SS, sum of squares (for a continuous 

response) attributed to the column.

– A bar chart of G2 or SS.

– The proportion of G2 or SS attributed to the column.

ROC Curve (Available only for categorical responses.) See “ROC Curve” on page 104 in the 

“Partition Models” chapter.

Lift Curve (Available only for categorical responses.) See “Lift Curve” on page 105 in the 

“Partition Models” chapter.

Save Columns Contains options for saving model and tree results, and creating SAS code.

Save Predicteds saves the predicted values from the model to the data table.

Save Prediction Formula Saves the prediction formula to a column in the data table. 

The formula consists of nested conditional clauses that describe the tree structure. If the 

response is continuous, the column contains a Predicting column property. If the 

response is categorical, the column contains a Response Probability column property.

Save Tolerant Prediction Formula (The Save Prediction Formula option should be 

used instead of this option. Use this option only when Save Prediction Formula is not 

available.) Saves a formula that predicts even when there are missing values and when 

Informative Missing has not been selected. The prediction formula tolerates missing 

values by randomly allocating response values for missing predictors to a split. If the 

response is continuous, the column contains a Predicting column property. If the 

response is categorical, the column contains a Response Probability column property. If 

you have selected Informative Missing, you can save the Tolerant Prediction Formula 

by holding the Shift key as you click on the report’s red triangle.
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Save Residuals (Available only for continuous responses.) Saves the residuals to the 

data table.

Save Offset Estimates (Available only for categorical responses.) Saves the sums of the 

linear components. These are the logits of the fitted probabilities.

Save Tree Details Creates a data table containing split details and estimates for each 

layer.

Save Cumulative Details (Available only if validation is used.) Creates a data table 

containing the fit statistics for each layer.

Publish Prediction Formula Creates a prediction formula and saves it as a formula 

column script in the Formula Depot platform. If a Formula Depot report is not open, 

this option creates a Formula Depot report. See the “Formula Depot” chapter on 

page 197.

Publish Tolerant Prediction Formula (The Publish Prediction Formula option should 

be used instead of this option. Use this option only when Publish Prediction Formula is 

not available.) Creates a tolerant prediction formula and saves it as a formula column 

script in the Formula Depot platform. If a Formula Depot report is not open, this option 

creates a Formula Depot report. See the “Formula Depot” chapter on page 197. If you 

have selected Informative Missing, you can use this option by holding the Shift key as 

you click on the report’s red triangle.

Make SAS DATA Step Creates SAS code for scoring a new data set.

Specify Profit Matrix (Available only for categorical responses.) Enables you to specify 

profit or costs associated with correct or incorrect classification decisions. See “Show Fit 

Details” on page 98 in the “Partition Models” chapter.

Profiler Shows a Prediction Profiler. For more information, see the Profiler chapter in the 

Profilers book.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.
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Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Statistical Details for the Boosted Tree Platform

This section describes details specific to the Boosted Tree Platform. For details about recursive 

decision trees, see “Statistical Details for the Partition Platform” on page 118 in the “Partition 

Models” chapter.

Overfit Penalty

When the response is categorical, a parametric penalty is imposed. For each layer, the 

estimates minimize the negative log-likelihood plus the penalty value multiplied by the sum 

of squares of the estimates for each observation. This penalty encourages each new layer not 

to overfit the training data.
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Chapter 8
K Nearest Neighbors

Predict Response Values Using Nearby Observations

The K Nearest Neighbors platform is available only in JMP Pro.

The K Nearest Neighbors platform predicts a response value for a given observation using the 

responses of the observations in that observation’s local neighborhood. It can be used for 

classification of a categorical response as well as for prediction of a continuous response.

K Nearest Neighbors is a nonparametric method that is based on the distance to neighboring 

observations. Because of this fact, K Nearest Neighbors is able to classify observations using 

irregular predictor value boundaries. However, because the algorithm is sensitive to irrelevant 

predictors, the selection of predictors can impact your results.

K Nearest Neighbors has been used successfully in many applications, such as classifying 

satellite imagery and electrocardiogram (EKG) patterns.

Figure 8.1  Example of the K Nearest Neighbors Platform
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Overview of the K Nearest Neighbors Platform

The K Nearest Neighbors platform predicts a response value based on the responses of the k 

nearest neighbors. The k nearest neighbors to a given observation are determined by 

identifying the k smallest Euclidean distances between the predictor values for that 

observation and the predictor values for each of the other observations. The K Nearest 

Neighbors platform models both continuous and categorical responses.

A potential drawback of the k nearest neighbors method is that for large scale problems, the 

prediction formula is often complex and hard to interpret, limiting its usefulness. In addition, 

K Nearest Neighbors does not calculate probabilities for categorical responses. For more 

information about the k nearest neighbors method, see Hastie et al. (2009), Hand et al. (2001), 

and Shmueli et al. (2017).

Continuous Responses

For a continuous response, the predicted value is the average of the responses for the k nearest 

neighbors. Each continuous predictor is scaled by its standard deviation. With this scaling, a 

single predictor with a large range does not excessively influence the distance calculation. 

Missing values for a continuous predictor are replaced by the mean of that predictor. See 

“Example of K Nearest Neighbors with Continuous Response” on page 164.

Categorical Responses

For a categorical response, the predicted value is the most frequent response level for the k 

nearest neighbors. If two or more levels are tied as the most frequent levels, the predicted 

response is assigned by selecting one of these levels at random.

Note: Because ties for most frequent levels in the case of a categorical response are broken at 

random, results from independent runs of the platform might differ. To obtain reproducible 

results, use the Set Random Seed option in the launch window or include the Set Random 

Seed() function in a JSL script.

In the categorical prediction models, each categorical predictor is expressed in terms of 

indicator variables, with one indicator variable representing each level. A row with a missing 

value for a categorical predictor is represented by values of zero on all indicator variables for 

that predictor.
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Example of K Nearest Neighbors with Categorical 
Response

You have historical financial data for 5,960 customers who applied for home equity loans. 

Each customer was classified as being a Good Risk or Bad Risk. There are missing values for 

many of the predictors. You want to construct a model to use in classifying the credit risk of 

future customers.

1. Select Help > Sample Data Library and open Equity.jmp.

2. Select Analyze > Predictive Modeling > K Nearest Neighbors.

3. Select BAD and click Y, Response.

4. Select LOAN through CLNO and click X, Factor.

Because one of the potential predictors, DEBTINC, has many missing values, you do not 

include it in your model. Missing values for continuous predictors are replaced by the 

average of the predictor. This procedure works well for values that are missing at random. 

The high missing rate of the DEBINC indicates that the missing might be informative, 

However, we do not investigate that in this example.

5. Select Validation and click Validation.

6. Click OK.
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Figure 8.2  K Nearest Neighbors Report

For each value of K, JMP constructs a model using only the training set observations. Each 

of these models is used to classify the validation set observations. The validation set results 

are used to select a best model. In this example, the model based on the single nearest 

neighbor (K = 1) has the smallest misclassification rate. The test set verifies that the single 

nearest neighbor model is the best performer for independent data.

7. Click the BAD red triangle and select Publish Prediction Formula.

8. Next to Number of Neighbors, K, leave the default value of 1.

9. Click OK.

The prediction equation is saved in the Formula Depot. You can compare the performance 

of alternative models published to the Formula Depot with that of the K = 1 nearest 

neighbor model using the Model Comparison option in the Formula Depot. Seethe 

Formula Depot chapter in the Predictive and Specialized Modeling book
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Example of K Nearest Neighbors with Continuous 
Response

In this example, you want to predict the percent body fat for males using 13 predictors. The 

Body Fat.jmp sample data table contains percent body fat estimates that are based on 

underwater weighing and on various body circumference measurements.

1. Select Help > Sample Data Library and open Body Fat.jmp.

2. Select Analyze > Predictive Modeling > K Nearest Neighbors.

3. Select Percent body fat and click Y, Response.

4. Select Age (years) through Wrist circumference (cm) and click X, Factor.

5. Select Validation and click Validation.

6. Click OK.

7. Click the Percent body fat red triangle and select Plot Actual by Predicted.
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Figure 8.3  K Nearest Neighbors Report

The K = 8 model had the lowest RMSE for the validation set. Among k nearest neighbor 

models, the model based on 8 nearest neighbors seems to perform the best. The Actual by 

Predicted plot for the training set shows that the points fall along the line, signifying that 

the predicted values are similar to the actual values. Most of the points on the plot for the 

validation set fall along the line, with a few observations on the upper end that are a bit 

farther away.



166 K Nearest Neighbors Chapter 8
Launch the K Nearest Neighbors Platform Predictive and Specialized Modeling

Launch the K Nearest Neighbors Platform

Launch the K Nearest Neighbors platform by selecting Analyze > Predictive Modeling > 
K Nearest Neighbors.

Figure 8.4  K Nearest Neighbors Launch Window

The K Nearest Neighbors launch window provides the following options:

Y, Response The response variable or variables that you want to analyze.

X, Factor The predictor variables.

Validation A numeric column that contains at most three distinct values. See “Validation” 

on page 107 in the “Partition Models” chapter.

By A column or columns whose levels define separate analyses. For each level of the 

specified column, the corresponding rows are analyzed using the other variables that you 

have specified. The results are presented in separate reports. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.

Validation Portion The portion of the data to be used as the validation set. See “Validation” 

on page 107 in the “Partition Models” chapter.

Number of Neighbors, K Maximum number of nearest neighbors to analyze. Models are fit 

for one nearest neighbor up to the value that you specify for K.

Set Random Seed Sets the seed for the randomization process used in tie-breaking for 

nominal and ordinal responses. If you specify a Validation Portion, this option also sets the 
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seed for the rows used for validation. Set Random Seed is useful if you want to reproduce 

an analysis. If you set a random seed and save the script, the seed is automatically saved in 

the script.

The K Nearest Neighbors Report

The K Nearest Neighbors report contains a separate report for each response variable. Each 

response variable report contains information about the fitted model for that response. This 

information includes a Model Selection report and summary information for each of the k 

models that were fit. The report shows tables for the training set and for the validation and 

test sets if you defined these using validation.

The Model Selection report displays a solution path plot across K based on the 

Misclassification Rate for categorical responses or the RMSE for continuous responses. By 

default, the slider is placed on the value of K that corresponds to the best performing model. 

You can drag the slider to change the value of K in the report.

The statistics reported depend on the modeling type of the response. Each row in the 

summary tables corresponds to a model defined by k nearest neighbors, where K ranges from 

one to the value that you specified as Number of Neighbors, K in the launch window.

Continuous Responses

By default, in addition to the Model Selection graph, the report for a continuous response 

contains the Summary Table report.

Summary Table

An asterisk marks the model for the value of K that has the smallest RMSE. The report for a 

continuous response contains the following columns:

K Number of nearest neighbors used in the model. K ranges from 1 to the Number of 

Neighbors, K that you specified in the launch window.

Count Number of observations.

RSquare The RSquare value for the model.

RMSE Root mean square error for the model. The model with the smallest RMSE is marked 

with an asterisk. If there are tied RMSE values, the model with the smallest K is marked 

with the asterisk.

SSE Sum of squared errors for the model.
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Categorical Responses

By default, in addition to the Model Selection graph, the report for a categorical response 

contains the Summary Table, Confusion Matrix, and Mosaic Plot reports.

Summary Table

An asterisk marks the model for the value of K that has the smallest misclassification rate. The 

report for a categorical response contains the following columns:

K Number of nearest neighbors used in the model. K ranges from 1 to the Number of 

Neighbors, K that you specified in the launch window.

Count Number of observations.

Misclassification Rate Proportion of observations misclassified by the model. This is 

calculated as Misclassifications divided by Count. The model with the smallest 

misclassification rate is marked with an asterisk. If there are tied misclassification rates, 

the model with the smallest K is marked with the asterisk.

Misclassifications Number of observations that are incorrectly predicted by the model.

Confusion Matrix

By default, a confusion matrix is shown for the model with the smallest Misclassification Rate. 

If there are ties for the smallest misclassification rate, a confusion matrix is shown for the 

model with the smallest K. If you use validation, confusion matrices for the validation and test 

sets appear. A confusion matrix is a two-way classification of actual and predicted responses. 

Use the confusion matrices and the misclassification rates to evaluate your model.

Tip: If you change the position of the slider in the solution path plot, an additional Confusion 

Matrix is displayed for the chosen value of K. Use the additional confusion matrices to 

compare an alternative model to the default best model.

Mosaic Plot

By default, a mosaic plot is shown for the model with the smallest Misclassification Rate. If 

there are ties for the smallest misclassification rate, a mosaic plot is shown for the model with 

the smallest K. A mosaic plot is a stacked bar chart where each segment is proportional to its 

group’s frequency count. For more information about mosaic plots, see the Contingency 

Analysis chapter in the Basic Analysis book. If you use validation, mosaic plots for the 

validation and test sets are shown.

Tip: If you change the position of the slider in the solution path plot, the mosaic plot updates 

to display the results for the chosen value of K.
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K Nearest Neighbors Platform Options

The K Nearest Neighbors red triangle menu contains the following options:

Save Near Neighbor Rows Saves K columns to the data table. The columns are named 

RowNear <k>. For a given row, the kth column contains the row number of its kth nearest 

neighbor.

Caution: The row numbers in the columns RowNear <k> do not update when you reorder 

the rows in your data table. If you reorder the rows, the values in those columns are 

incorrect.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Model Fit Options

Mosaic Plot (Available only for nominal or ordinal responses.) Shows or hides the mosaic 

plot. See “Mosaic Plot” on page 168.

Plot Actual by Predicted (Available only for continuous responses.) Plots the actual versus 

the predicted responses for the model with the smallest RMSE. If there are ties for the 

smallest RMSE, the plot is based on the model with the smallest K.

Tip: If you change the position of the slider on the solution path plot to a different K, the 

Actual by Predicted plot is updated to reflect the model for the chosen value of K.
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Plot Residual by Predicted (Available only for continuous responses.) Plots the residuals 

versus the predicted responses for the model with the smallest RMSE. If there are ties for 

the smallest RMSE, the plot is based on the model with the smallest K.

Tip: If you change the position of the slider on the solution path plot to a different K, the 

Residual by Predicted plot is updated to reflect the model for the chosen value of K.

Save Predicteds Saves K predicted value columns to the data table. The columns are 

named Predicted <Response> <k>. The kth column contains predictions for the model 

based on the k nearest neighbors, where Response is the name of the response column.

Save Prediction Formula Saves a column that contains a prediction formula for a specific k 

nearest neighbor model. Enter a value for K when prompted. The prediction formula 

contains all the training data, so this option might not be practical for large data tables.

Caution: The values obtained from Save Prediction Formula and Save Predicteds do not 

necessarily match. The values obtained from the Save Prediction Formula option use all of 

the rows in the training set, including the row for the predicted value. The values from the 

Save Predicteds option do not use the row for the predicted value in the training set, only 

all other rows.

Publish Prediction Formula Creates a prediction formula for the specified k nearest 

neighbor model and saves it as a formula column script in the Formula Depot platform. If 

a Formula Depot report is not open, this option creates a Formula Depot report. See the 

Formula Depot chapter in the Predictive and Specialized Modeling book.
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Classify Observations Using Probabilistic Assumptions

The Naive Bayes platform is available only in JMP Pro.

The Naive Bayes platform fits a model to predict the value of a categorical variable. Naive 

Bayes is a fast and computationally simple method. It is especially suitable for situations 

where there are a large number of predictors.

Figure 9.1  Example of Naive Bayes Analysis
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Overview of the Naive Bayes Platform

The Naive Bayes platform classifies observations into classes that are defined by the levels of a 

categorical response variable. The variables (or factors) that are used for classification are 

often called features in the data mining literature.

For each class, the naive Bayes algorithm computes the conditional probability of each feature 

value occurring. If a feature is continuous, its conditional marginal density is estimated. The 

naive Bayes technique assumes that, within a class, the features are independent. (This is the 

reason that the technique is referred to as “naive”.) Classification is based on the idea that an 

observation whose feature values have high conditional probabilities within a certain class has 

a high probability of belonging to that class. See Hastie et al. (2009).

Because the algorithm estimates only one-dimensional densities or distributions, the 

algorithm is extremely fast. This makes it suitable for large data sets, and in particular, data 

sets with large numbers of features. All nonmissing feature values for an observation are used 

in calculating the conditional probabilities.

Each observation is assigned a naive score for each class. An observation’s naive score for a 

given class is the proportion of training observations that belong to that class multiplied by 

the product of the observation’s conditional probabilities. The naive probability that an 

observation belongs to a class is its naive score for that class divided by the sum of its naive 

scores across all classes. The observation is assigned to the class for which it has the highest 

naive probability.

Caution: Because the conditional probabilities of class membership are assumed independent, 

the naive Bayes estimated probabilities are inefficient.

Naive Bayes requires a large number of training observations to ensure representation for all 

predictor values and classes. If an observation in the Validation set is being classified and it 

has a categorical predictor value that was missing in the Training set, then the platform will 

use the non-missing features to predict. If an observation is missing all predictor values, the 

predicted response is the most frequent response. The prediction formulas handle missing 

values by having them contribute nothing to the observation’s score.

For more information about the naive Bayes technique, see Hand et al. (2001), and Shmueli et 

al. (2010).

Example of Naive Bayes

You have baseline medical data for 442 diabetic patients. You also have a binary measure of 

diabetes disease progression obtained one year after each patient’s initial visit. This measure 
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quantifies disease progression as being either Low or High. You want to construct a 

classification model to be used in predicting the disease progression for future patients as 

High or Low.

1. Select Help > Sample Data Library and open Diabetes.jmp.

2. Select Analyze > Predictive Modeling > Naive Bayes.

3. Select Y Binary and click Y, Response.

4. Select Age through Glucose and click  X, Factor.

5. Select Validation and click Validation.

6. Click OK.

Figure 9.2  Naive Bayes Report

The Training Set has about a 21% misclassification rate and the Validation Set has about a 

24% misclassification rate. The Confusion matrix suggests that, for both the Training and 

Validation sets, the larger source of misclassification comes from classifying patients with 

Low disease progression as having High disease progression. The Validation set results 

indicate how your model extends to independent observations.

You are interested in which individual predictors have the greatest impact on the naive 

Bayes classification.

7. Click the red triangle next to Naive Bayes and select Profiler.

Figure 9.3  Prediction Profiler for Disease Progression
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8. Click the red triangle next to Prediction Profiler and select Assess Variable Importance > 
Independent Uniform Inputs.

Figure 9.4  Variable Importance

The Summary Report indicates that HDL, BMI, and LTG have the greatest impact on the 

estimated probabilities.

Figure 9.5  Marginal Model Plots Report

 

The second row of plots in the Marginal Model Plots report shows that higher values of 

HDL are associated with a lower probability of classifying a patient as High. Also, higher 

BMI and LTG values are associated with a higher probability of classifying a patient as 

High.

Launch the Naive Bayes Platform

Launch the Naive Bayes platform by selecting Analyze > Predictive Modeling > Naive Bayes.
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Figure 9.6  Naive Bayes Launch Window

The Naive Bayes launch window provides the following options:

Y, Response The categorical response column whose values are the classes of interest.

X, Factor Categorical or continuous predictor columns.

Weight A column whose numeric values assign a weight to each row in the analysis.

Freq A column whose numeric values assign a frequency to each row in the analysis.

Validation A numeric column that contains at most three distinct values. See “Validation” 

on page 107 in the “Partition Models” chapter.

Note: If neither a Validation column or a Validation Portion is specified in the launch 

window and if there are excluded rows, these rows are treated as a Validation set.

By A column or columns whose levels define separate analyses. For each level of the 

specified column, the corresponding rows are analyzed using the other variables that you 

have specified. The results are presented in separate reports. If more than one By variable 

is assigned, a separate analysis is produced for each possible combination of the levels of 

the By variables.

Validation Portion The portion of the data to be used as the Validation set. See “Validation” 

on page 107 in the “Partition Models” chapter.
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The Naive Bayes Report

After you click OK in the launch window, the Naive Bayes report appears. By default, the 

Naive Bayes report contains reports for fit details, the response column, the Confusion Matrix, 

and the ROC curves.

Figure 9.7  Naive Bayes Report

Fit Details Report

The Fit Details report shows various measures of fit for the model for the Training set, and for 

the Validation and Test sets if they are specified. The Measure column lists the different fit 

statistics and the Definition column shows the formulas for the corresponding fit statistics. For 

more information, see “Measures of Fit for Categorical Responses” on page 192 in the “Model 

Comparison” chapter. By default, the Fit Details report in the Naive Bayes report window is 

closed.

Response Column Report

The response column report shows performance statistics for the naive Bayes classification in 

a summary table for the Training set, and the Validation and Test sets if they are specified. The 

summary tables contain the following columns:

Count Number of observations in the set corresponding to the table (Training, Validation, or 

Test set).

Misclassification Rate Proportion of observations in the corresponding set that are 

misclassified by the model. This is calculated as Misclassifications divided by Count.
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Misclassifications Number of observations in the corresponding set that are classified 

incorrectly.

Confusion Matrix Report

The Confusion Matrix report shows a confusion matrix for the Training set, and for the 

Validation and Test sets if they are specified. A confusion matrix is a two-way classification of 

actual and predicted responses.

ROC Curves

The report displays the Receiver Operating Characteristic (ROC) curve for the Training set, 

and for the Validation and Test sets if they are specified. The ROC curve measures the ability 

of the fitted probabilities to classify response levels correctly. The further the curve from the 

diagonal, the better the fit. An introduction to ROC curves is found in the Logistic Analysis 

chapter in the Basic Analysis book.

If the response has two levels, the ROC curve plot displays an ROC curve for the first level of 

the response only. If the response has more than two levels, the ROC Curve plot displays a 

sub-outline of the curves for each response level. For a given response level, this curve is the 

ROC curve for correct classification into that level. See “ROC Curve” on page 104 in the 

“Partition Models” chapter for more information about ROC curves.

Naive Bayes Platform Options

The Naive Bayes red triangle menu contains the following options:

ROC Curve Shows or hides the ROC plot. The ROC plot is shown by default. See “ROC 

Curves” on page 178.

Lift Curve Shows or hides the lift curve for the model. If you used validation, Lift curve is 

shown for each of the Training, Validation, and Test sets, if specified.

A lift curve shows how effectively response levels are classified as their fitted probabilities 

decrease. The fitted probabilities are plotted along the horizontal axis in descending order. 

The vertical coordinate for a fitted probability is the proportion of correct classifications 

for that probability or higher, divided by the overall correct classification rate. Use the lift 

curve to see whether you can correctly classify a large proportion of observations if you 

select only those with a fitted probability that exceeds a threshold value.

If the response has two levels, the Lift curve plot displays a lift curve for the first level of 

the response only. If the response has more than two levels, the Lift curve plot displays a 



Chapter 9 Naive Bayes 179
Predictive and Specialized Modeling Naive Bayes Platform Options

sub-outline of the curves for each response level. See “Lift Curve” on page 105 in the 

“Partition Models” chapter for more information about lift curves.

Save Predicteds Saves the predicted classifications to the data table in a column called 

Naive Predicted <Y, Response>.

Save Prediction Formula Saves a column called Naive Predicted Formula <Y, Response> to 

the data table. This column contains the prediction formula for the classifications.

Save Probability Formula Saves columns to the data table that contain formulas used for 

classifying each observation. Three groups of columns are saved:

Naive Score <Class>, Sum For each column that represents a class, this column gives a 

score formula that measures strength of membership in the given class. In the Naive 

Score Sum column., these scores are summed across classes. See “Saved Probability 

Formulas” on page 182.

Naive Prob <Class> For each class, this column gives a formula for the conditional 

probability that an observation is in that class. See “Saved Probability Formulas” on 

page 182.

Naive Predicted Formula <Y, Response> Gives the formula for the predicted class.

Publish Probability Formula Creates probability formulas and saves them as formula 

column scripts in the Formula Depot platform. If a Formula Depot report is not open, this 

option opens the Formula Depot window. See the Formula Depot chapter in the Predictive 

and Specialized Modeling book.

Profiler Shows or hides an interactive profiler report. Changes in the factor values are 

reflected in the estimated classification probabilities. See the Profiler chapter in the 

Profilers book for more information.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.
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Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Additional Example of Naive Bayes

You have historical financial data for 5,960 customers who applied for home equity loans. 

Each customer was classified as being a Good Risk or Bad Risk. There is missing data on most 

of the predictors. You want to construct a model to use in classifying the credit risk of future 

customers.

1. Select Help > Sample Data Library and open Equity.jmp.

2. Select Analyze > Predictive Modeling > Naive Bayes.

3. Select BAD and click Y, Response.

One of the potential predictors, DEBTINC, has many missing values that might be 

informative. However, naive Bayes is not prepared to handle large number of missing 

values well, so you do not include DEBTINC in your model.

4. Select LOAN through CLNO and click X, Factor.

5. Select Validation and click Validation.

6. Click OK.

Figure 9.8  Naive Bayes Report for BAD

The Training, Validation, and Test sets show misclassification rates between 18% and 19%. 

The confusion matrices for all of the sets suggest that the largest source of misclassification 

is the classification of Bad Risk customers as Good Risk customers.

You are interested in the probabilities that customers with certain financial background 

values are classified as High Risk.

7. Click the red triangle next to Naive Bayes and select Save Probability Formulas.

Three sets of columns are added to the data table.
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– The three Naive Score columns contain naive score formulas for Good Risk, Bad Risk, 

and the sum of both.

– The two Naive Prob columns contain probability formulas for Good Risk and Bad Risk.

– The Naive Predicted Formula Bad column contains a formula that assigns an 

observation to the class for which the observation has the highest naive probability.

Use these formulas to score new customers. For details about the formula columns, see 

“Saved Probability Formulas” on page 182.

Statistical Details for the Naive Bayes Platform

• “Algorithm”

• “Saved Probability Formulas”

Algorithm

The naive Bayes method classifies an observation into the class for which its probability of 

membership, given the values of its features, is highest. The method assumes that the features 

are conditionally independent within each class.

Denote the possible classifications by C1, …, CK. Denote the features, or predictors, by X1, X2, 

…, Xp.

The conditional probability that an observation with predictor values x1, x2, …, xp belongs in 

the class Ck is computed as

,

where R is a regularization constant. In the formula above, the conditional probability that an 

observation with Xj =  xj belongs to the class Ck, P(xj|Ck), is given as follows:

• If Xj is categorical:

• If Xj is continuous:

P Ck x1  xp   
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Here,  is the standard normal density function, and m and s are the mean and standard 

deviation, respectively, of the predictor values within the class Ck.

The unconditional probability that an observation belongs in class Ck, P(Ck), is given as 

follows:

An observation is classified into the class for which its conditional probability is the largest.

Note: In the formula for P(Ck), 0.5 is the prior bias factor. This value is the default value. To 

change the prior default factor, go to File > Preferences > Platforms > Naive Bayes, select the 

Prior Bias check box and change the value.

Saved Probability Formulas

This section describes the formulas saved using the Save Probability Formula option. The 

conditional probability that an observation with predictor values x1, x2, …, xp belongs in the 

class Ck is slightly different than that given by P(Ck|(x1, ..., xp)), shown in the section 

“Algorithm” on page 181. This is done for computational efficiency.

Naive Score Formulas

The Naive Score formula for a given class Ck, S(Ck), is a variation of the numerator in the 

expression for P(Ck|(x1, ..., xp)) and is given by:

Naive Score Sum Formulas

The Naive Score Sum formula, S, sums the Naive Score formulas over all classes. This is a 

variation of the denominator in the expression for P(Ck|(x1, ..., xp)).

P xj Ck  1
sjk

------ xj mjk–  sjk =

P Ck 
# of observations in Ck 0.5 K +

Total # of observations 0.5+
--------------------------------------------------------------------------------------=

S Ck  1 sjk ln

j 1=

p

 P Ck  Normal Log Density
xj mjk–

sjk
-------------------
 
 
 

R ln–

j 1=

p

+ +
 
 
 
 

exp=

S S Ck 

k 1=

K

=
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Naive Prob Formulas

The Naive Prob formula for a given class Ck equals P(Ck|(x1, ..., xp)). In the JMP formulas,

Naive Predicted Formula

The Naive Predicted Formula for an observation classifies that observation into the class for 

which P(Ck|(x1, ..., xp)) is the largest. This is equivalent to classifying an observation into the 

class for which its Naive Score formula is the largest.

P Ck x1  xp   
S Ck 

S
---------------=
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Chapter 10
Model Comparison

Compare the Predictive Ability of Fitted Models

The Model Comparison platform is available only in JMP Pro.

The Model Comparison platform in JMP Pro lets you compare the predictive ability of 

different models. Measures of fit are provided for each model along with overlaid diagnostic 

plots.

Figure 10.1  Example of Comparing Models
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Example of Model Comparison

This section provides an example of using the Model Comparison platform. The example uses 

demographic data to build a model for median home price. A regression model and a 

bootstrap forest model are compared.

Begin by selecting Help > Sample Data Library and opening Boston Housing.jmp.

Create a Validation Column

1. Create a column called validation.

2. On the Column Info window, select Random from the Initialize Data list.

3. Select the Random Indicator radio button.

4. Click OK.

The rows assigned a 0 are the training set. The rows assigned a 1 are the validation set.

Create the Regression Model and Save the Prediction Formula to a Column

1. Select Analyze > Fit Model.

2. Select mvalue and click Y.

3. Select the other columns (except validation) and click Add.

4. Select Stepwise in the Personality list.

5. Select validation and click Validation.

6. Click the Run button.

7. Select P-value Threshold from the Stopping Rule list.

8. Click the Go button.

9. Click the Run Model button.

The Fit Group report appears, a portion of which is shown in Figure 10.2.

10. Save the prediction formula to a column by selecting Save Columns > Prediction Formula 

on the Response red triangle menu.
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Figure 10.2  Fit Model Report

Create the Bootstrap Forest Model and Save the Prediction Formula to a Column

1. Select Analyze > Predictive Modeling > Partition.

2. Select mvalue and click Y, Response.

3. Select the other columns (except validation) and click X, Factor.

4. Select validation and click Validation.

5. Select Bootstrap Forest in the Method list.

6. Click OK.

7. Select the Early Stopping check box.

8. Select the Multiple Fits over number of terms check box.

9. Click OK.

The Bootstrap Forest report appears, a portion of which is shown in Figure 10.3.

10. Save the prediction formula to a column by selecting Save Columns > Save Prediction 
Formula on the Bootstrap Forest red triangle menu.
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Figure 10.3  Bootstrap Forest Model

Compare the Models

1. Select Analyze > Predictive Modeling > Model Comparison.

2. Select the two prediction formula columns and click Y, Predictors.

3. Select validation and click Group.

4. Click OK.

The Model Comparison report appears (Figure 10.4).

Note: Your results differ due to the random assignment of training and validation rows.

Figure 10.4  Model Comparison Report

The rows in the training set were used to build the models, so the RSquare statistics for 

Validation=0 might be artificially inflated. In this case, the statistics are not representative of 

the models’ future predictive ability. This is especially true for the bootstrap forest model.

Compare the models using the statistics for Validation=1. In this case, the bootstrap forest 

model predicts better than the regression model.
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Related Information

• The Model Specification chapter in the Fitting Linear Models book

• “Partition Models” chapter on page 83

Launch the Model Comparison Platform

To launch the Model Comparison platform, select Analyze > Predictive Modeling > Model 
Comparison.

Figure 10.5  The Model Comparison Launch Window

Y, Predictors The columns that contain the predictions for the models that you want to 

compare. They can be either formula columns or just data columns. Prediction formula 

columns created by JMP platforms have either the Predicting or Response Probability 

column property. If you specify a column that does not contain one of these properties, the 

platform prompts you to specify which column is being predicted by the specified Y 

column.

For a categorical response with k levels, most model fitting platforms save k columns to the 

data table, each predicting the probability for a level. All k columns need to be specified as 

Y, Predictors. For platforms that do not save k columns of probabilities, the column 

containing the predicted response level can be specified as a Y, Predictors column.

If you do not specify any Y, Predictors columns, JMP uses the prediction formula columns 

in the data table that have either the Predicting or Response Probability column property.

Group The column that separates the data into groups, which are fit separately.

The other role buttons are common among JMP platforms. See the Get Started chapter in the 

Using JMP book for details.
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The Model Comparison Report

Figure 10.6 shows an example of the initial Model Comparison report for a continuous 

response.

Figure 10.6  Initial Model Comparison Report

The Predictors report shows all responses and all models being compared for each response. 

The fitting platform that created the predictor column is also listed.

The Measures of Fit report shows measures of fit for each model. The columns are different for 

continuous and categorical responses.

Measures of Fit for Continuous Responses

RSquare The r-squared statistic. In data tables that contain no missing values, the r-squared 

statistics in the Model Comparison report and original models match. However, if there 

are any missing values, the r-squared statistics differ.

RASE The square root of the mean squared prediction error. This is computed as follows:

– Square and sum the prediction errors (differences between the actual responses and the 

predicted responses) to obtain the SSE.

– Denote the number of observations by n.

– RASE is:

AAE The average absolute error.

Freq The column that contains frequency counts for each row.

 RASE SSE
n

-----------=
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Measures of Fit for Categorical Responses

Entropy RSquare One minus the ratio of the negative log-likelihoods from the fitted model 

and the constant probability model. It ranges from 0 to 1.

Generalized RSquare A measure that can be applied to general regression models. It is 

based on the likelihood function L and is scaled to have a maximum value of 1. The value 

is 1 for a perfect model, and 0 for a model no better than a constant model. The 

Generalized RSquare measure simplifies to the traditional RSquare for continuous normal 

responses in the standard least squares setting. Generalized RSquare is also known as the 

Nagelkerke or Craig and Uhler R2, which is a normalized version of Cox and Snell’s 

pseudo R2. See Nagelkerke (1991).

Mean -Log p The average of -log(p), where p is the fitted probability associated with the 

event that occurred.

RMSE The root mean square error, adjusted for degrees of freedom. For categorical 

responses, the differences are between 1 and p (the fitted probability for the response level 

that actually occurred).

Mean Abs Dev The average of the absolute values of the differences between the response 

and the predicted response. For categorical responses, the differences are between 1 and p 

(the fitted probability for the response level that actually occurred).

Misclassification Rate The rate for which the response category with the highest fitted 

probability is not the observed category.

N The number of observations.

Related Information

“Training and Validation Measures of Fit” on page 76 in the “Neural Networks” chapter 

provides more information about measures of fit for categorical responses.

Model Comparison Platform Options

Continuous and Categorical Responses

Model Averaging Makes a new column of the arithmetic mean of the predicted values (for 

continuous responses) or the predicted.probabilities (for categorical responses).
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Continuous Responses

Plot Actual by Predicted Shows a scatterplot of the actual versus the predicted values. The 

plots for the different models are overlaid.

Plot Residual by Row Shows a plot of the residuals by row number. The plots for the 

different models are overlaid.

Profiler Shows a profiler for each response based on prediction formula columns in your 

data. The profilers have a row for each model being compared.

Categorical Responses

ROC Curve Shows ROC curves for each level of the response variable. The curves for the 

different models are overlaid.

AUC Comparison Provides a comparison of the area under the ROC curve (AUC) from 

each model. The area under the curve is the indicator of the goodness of fit, with 1 being a 

perfect fit.

The report includes the following information:

– standard errors and confidence intervals for each AUC

– standard errors, confidence intervals, and hypothesis tests for the difference between 

each pair of AUCs

– an overall hypothesis test for testing whether all AUCs are equal

Lift Curve Shows lift curves for each level of the response variable. The curves for the 

different models are overlaid.

Cum Gains Curve Shows cumulative gains curves for each level of the response variable. A 

cumulative gains curve is a plot of the proportion of a response level that is identified by 

the model against the proportion of all responses. A cumulative gains curve for a perfect 

model would reach 1.0 at the overall proportion of the response level. The curves for the 

different models are overlaid.

Confusion Matrix Shows confusion matrices for each model. A confusion matrix is a 

two-way classification of actual and predicted responses. Count and rate confusion 

matrices are shown. Separate confusion matrices are produced for each level of the Group 

variable.

If the response has a Profit Matrix column property, then Actual by Decision Count and 

Actual by Decision Rate matrices are shown to the right of the confusion matrices. For 

details about these matrices, see “Additional Examples of Partitioning” on page 109 in the 

“Partition Models” chapter.
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Profiler Shows a profiler for each response based on prediction formula columns in your 

data. The profilers have a row for each model being compared.

Related Information

• “ROC Curve” on page 104 in the “Partition Models” chapter

• “Lift Curve” on page 105 in the “Partition Models” chapter

Additional Example of Model Comparison

This example uses automobile data to build a model to predict the size of the purchased car. A 

logistic regression model and a decision tree model are compared.

Begin by selecting Help > Sample Data Library and opening Car Physical Data.jmp.

Create the Logistic Regression Model

1. Select Analyze > Fit Model.

2. Select Type and click Y.

3. Select the following columns and click Add: Country, Weight, Turning Cycle, Displacement, 
and Horsepower.

4. Click Run.

The Nominal Logistic Fit report appears.

5. Save the prediction formulas to columns by selecting Save Probability Formula from the 

Nominal Logistic red triangle menu.

Create the Decision Tree Model and Save the Prediction Formula to a Column

1. Select Analyze > Predictive Modeling > Partition.

2. Select Type and click Y, Response.

3. Select the Country, Weight, Turning Cycle, Displacement, and Horsepower columns and click 

X, Factor.

4. Make sure that Decision Tree is selected in the Method list.

5. Click OK.

The Partition report appears.

6. Click Split 10 times.

7. Save the prediction formulas to columns by selecting Save Columns > Save Prediction 
Formula from the Partition red triangle menu.
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Compare the Models

1. Select Analyze > Predictive Modeling > Model Comparison.

2. Select all columns that begin with Prob and click Y, Predictors.

3. Click OK.

The Model Comparison report appears (Figure 10.7).

Figure 10.7  Initial Model Comparison Report

The report shows that the Partition model has slightly higher values for Entropy RSquare 

and Generalized RSquare and a slightly lower value for Misclassification Rate.

4. Select ROC Curve from the Model Comparison red triangle menu.

ROC curves appear for each Type, one of which is shown in Figure 10.8.

Figure 10.8  ROC Curve for Medium

Examining all the ROC curves, you see that the two models are similar in their predictive 

ability.

5. Select AUC Comparison from the Model Comparison red triangle menu.

AUC Comparison reports appear for each Type, one of which is shown in Figure 10.9.
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Figure 10.9  AUC Comparison for Medium

The report shows results for a hypothesis test for the difference between the AUC values (area 

under the ROC curve). Examining the results, you see there is no statistical difference between 

the values for any level of Type.

You conclude that there is no large difference between the predictive abilities of the two 

models for the following reasons:

• The R Square values and the ROC curves are similar.

• There is no statistically significant difference between AUC values.
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Manage Models and Generate Scoring Code

The Formula Depot Platform is available only in JMP Pro.

The Formula Depot is a repository to organize, compare, and profile models. Scoring code for 

deployment within or outside of JMP can be generated for models published to the Formula 

Depot. For model exploration work, you can use the Formula Depot to store candidate models 

outside of your JMP data table. The model profiler and model compare platforms are 

accessible from the Formula Depot. A model that is selected for further use can be saved to 

your JMP table or saved to a JMP table with new data for scoring. For use in an environment 

outside of JMP, you can generate scoring code in C, Python, JavaScript, SAS, or SQL.

Figure 11.1  Example of the Formula Depot
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Overview of the Formula Depot Platform

The Formula Depot is a repository to organize, compare, profile, and score models for 

deployment. Models are prediction formulas. Prediction formulas are saved to the Formula 

Depot as column scripts. You can add prediction formulas to JMP tables to score data. You can 

also use the Formula Depot to generate scoring code for prediction formulas to facilitate the 

deployment of models in environments outside of JMP.

The Formula Depot enables you to perform the following tasks:

• save prediction formulas outside of data tables

• save prediction formulas from multiple data tables in a common location

• save intermediate cleaning formulas within a prediction formula

• compare models

• profile models

• add prediction formulas to a data table for scoring of new data within JMP

• generate scoring code (C, Python, Java Script, SAS, or SQL) for deploying models outside 

of JMP

• The Formula Depot includes intermediate formulas in the generated scoring code. A 

model constructed from inputs with column formulas includes the corresponding 

formulas in the scoring code. For example, if your model includes a recoded variable the 

recode formula is included in the scoring code. This enables you to apply your prediction 

formula to raw data that has not been processed.

Note: Informative missing is not a supported intermediate formula. 

Example of Formula Depot

The Liver Cancer.jmp sample data table contains data on the severity of liver cancer in patients 

when they entered a study. The file also contains a number of table scripts for models. This 

example uses these scripts to generate models to demonstrate the Formula Depot.

1. Select Help > Sample Data Library and open Liver Cancer.jmp.

2. Click the green triangle next to the Lasso Poisson, Validation Column script.

3. Click the red triangle next to Adaptive Lasso with Validation Column and select Save 
Columns > Publish Prediction Formula.

This option opens a Formula Depot that contains the prediction formula for the Fit 

Generalized model.
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4. To add the prediction formula to the data table, select Run Script from the Fit Generalized 

- Node Count red triangle menu in the Formula Depot.

Note: The result of step 3 and step 4 can be obtained using the Save Columns > Save 
Prediction Formula at step 3. However, then the prediction formula is not part of the 

Formula Depot

5. To generate scoring code for use outside of JMP select a code type from the Fit Generalized 

- Node Count red triangle menu. A script window appears containing the code. See 

“Generating Scoring Code from the Formula Depot Platform” on page 203.

6. To save the Formula Depot, select File > Save.

Note: The Formula Depot is saved as a JMP Report File (*.jrp). 

Figure 11.2  Formula Depot with a Generalized Model

Launch the Formula Depot Platform

Launch the Formula Depot by selecting Analyze > Predictive Modeling > Formula Depot.

Figure 11.3  Empty Formula Depot from Launch

Alternatively, if there is not an open Formula Depot then a Formula Depot opens when you 

select a Publish command.
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Platforms That Publish Prediction Formulas to the Formula 
Depot

The platforms that publish prediction formulas and generate complete scoring code include:

• Discriminant

• Least Squares Regression

• Logistic Regression

• Partition

• Uplift

• K Nearest Neighbors

• Naive Bayes

• Neural

• Latent Class Analysis

• Principal Components

• Generalized Regression

• PLS

• Gaussian Process

In platforms that do not publish prediction formulas to the Formula Depot, you can save the 

prediction formula to the data table. From the data table, add it to the Formula Depot by 

selecting Add Formula from Column. However, the scoring code might not be fully functional 

for such models. For details about scoring code see “Generating Scoring Code from the 

Formula Depot Platform” on page 203.

In addition, you can publish a formula directly from the formula editor. Select the formula, 

right click and select Publish expression to formula depot.

Formula Depot Platform Options

Add Formula From Column Enables you to add existing prediction formulas from data 

table columns to the current formula depot. If your table has only one formula, that 

formula is added to the depot. If you have multiple column formulas a dialog box enables 

you to select the formulas of interest. If your formula columns are selected in your data 

table, they will be pre-selected in the dialog box.

Show Scripts Opens a new Formula Window (or appends to an open Formula Window) 

that contains scripts for all of the formulas that are in the current formula depot.
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Copy Scripts Copies all scripts from the current formula depot to the clipboard.

Copy Formulas as Functions Enables you to select models from the current formula depot 

to be copied. Selected models are copied onto the clipboard as functions for use in JSL or 

other code. The functions act on scalar variables rather than columns.

Copy Formulas as Transforms Enables you to select models from the current formula 

depot to be copied. Selected models are copied onto the clipboard within a Transform 

Columns() statement.

Run Scripts Enables you to save models from the current formula depot to new columns in 

your JMP data table.

Note: If you have more than one data table open, a Choose Table window appears that 

enables you to specify which data table to use for Run Scripts.

Generate C Code, Generate Python Code, Generate JavaScript Code, Generate SAS 
Code, and Generate SQL Code Enables you to select models from the current formula 

depot for code generation. A new script window appears that contains scoring code for 

the selected models in C, Python, JavaScript, SAS DS2, or SQL, respectively. You can use 

this code to facilitate the deployment of the model in the environment or framework of 

your choice. See “Generating Scoring Code from the Formula Depot Platform” on 

page 203.

Model Comparison Enables you to select models from the current formula depot to be 

compared using the model comparison utility. If models from multiple tables are stored in 

the depot you first select the table of interest and then the models of interest. See the 

Model Comparison chapter in the Predictive and Specialized Modeling book.

Note: If you have more than one data table open, a Choose Table window appears that 

enables you to specify which data table to use for the Model Comparison.

Remove Model Comparison Removes all Model Comparison reports from the current 

formula depot.

Profiler Enables you to select models from the current formula depot to be profiled using 

the profiler. If models from multiple tables are stored in the depot you first select the table 

of interest and then the models of interest. See the Profiler chapter in the Profilers book.

Note: If you have more than one data table open, a Choose Table window appears that 

enables you to specify which data table to use for the Profiler.

Remove Profiler Removes all Profilers from the current formula depot.
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See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Formula Depot Model Options

Each prediction formula that is saved in the Formula Depot has an individual options menu. 

In addition to Show, Copy, Run, and Code Generation options that correspond to the main 

menu options, the individual menus include the following options:

Rename New Column Enables you to rename the model. This new name is applied as the 

column name if you run the script to add the prediction formula to a JMP data table. In 

addition, this name is included in generated code.

Remove removes the model from the Formula Depot. This command cannot be undone.

Generating Scoring Code from the Formula Depot 
Platform

Scoring code generation is intended to facilitate using models built in JMP in a production 

environment or other framework of your choice. Many platforms publish prediction formulas 

to the Formula Depot, however; not all prediction formulas generate complete code. Code can 

be complete, it can be a code fragment, or the code can include unsupported functions that 

require additional programming for implementation.

For example, you can perform the following tasks:

• Deploy your model to SAS Model Manager using the generated SAS code.

• Augment your ETL process with in-database scoring using the generated SQL code.

• Create a node for a data transformation pipeline with an application built with the 

generated C code.
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• Create a Jupyter notebook to show live scoring results using the generated Python code.

• Enable customers to score their own data with a web application that includes the 

generated JavaScript.

For the C, Python, and JavaScript languages, you must include supporting code such as .h files 

and utility libraries when deploying or compiling the generated code. These files are available 

in your JMP installation folder inside the Scoring folder.

Tip: To find the location of installation folder on your machine use the JSL command: Get Path 

Variable(ʺ$ALL_HOME/Scoringʺ);

C Code The C scoring code that is generated must be compiled into a library and then 

linked into an application. You might use either a static or a dynamic link approach. The 

files jmp_lib.h, jmp_parms.h, and jmp_score.h needed for compiling and linking can be 

found in the Scoring/C folder in your JMP installation folder.

Python Code The file jmp_score.py that is needed to run your Python scoring application 

can be found in the Scoring/Python folder in your JMP installation folder.

JavaScript Code The file jmp_score.js that is needed to run your JavaScript scoring 

application can be found in Scoring/JavaScript folder.

SAS Code The generated code fragment that once wrapped by PROC DS2 statements can 

be used in SAS applications including the SAS In-Database Code Accelerator. If necessary, 

rename variable names to conform to SAS naming conventions.

Tip: For models with an ifmax call, such as logistic or neural models for a categorical 

response, move temporary variable declarations before the method run() statement.

SQL Code The SQL code fragment that once wrapped in a select statement can be used in 

SQL queries against most major database servers.

Note: Code that contains “placeholder” or “ERROR” indicates an unsupported function call.
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Fit Curve

Fit Built-In Nonlinear Models to Your Data

In many situations, especially in the physical and biological sciences, well-known nonlinear 

equations describe the relationship between variables. For example, pharmacological bioassay 

experiments can demonstrate how the strength of the response to a drug changes as a function 

of drug concentration. Sigmoid curves often accurately model response strength as a function 

of drug concentration. Another example is exponential growth curves, which can model the 

size of a population over time.

The Fit Curve platform does not require you to specify starting values for parameter estimates 

or create model formulas. To specify your own starting values and create model formulas, use 

the more powerful custom Nonlinear platform, which can also fit any nonlinear model. For 

details, see the “Nonlinear Regression” chapter on page 229.

Figure 12.1  Example of Nonlinear Fit in the Fit Curve Platform
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Overview of the Fit Curve Platform

Some models are linear in the parameters (for example, a quadratic or other polynomial); 

others can be transformed to be such (for example, when you use a log transformation of x). 

The Fit Model or Fit Y by X platforms are more appropriate in these situations. An example in 

the Model Specification chapter in the Fitting Linear Models book shows a significant linear 

relationship between oxygen uptake and time spent running. For more information about Fit 

Model, see the Model Specification chapter in the Fitting Linear Models book. For more 

information about Fit Y by X, see the Introduction to Fit Y by X chapter in the Basic Analysis 

book.

The Fit Curve platform enables you to fit models that are nonlinear in the parameters. The 

initial example in this chapter shows the analysis of a nonlinear relationship: drug toxicity as a 

function of concentration. The effect of concentration on toxicity changes from low to high 

doses, so this relationship is nonlinear.

The following are examples of equations for linear and nonlinear functions.

Linear function: 

Nonlinear function: 

The Fit Curve platform provides predefined models, such as polynomial, logistic, probit, 

Gompertz, exponential, peak, and pharmacokinetic models. Specifying a grouping variable 

lets you estimate separate model parameters for each level of the grouping variable. The fitted 

models and estimated parameters can be compared across the levels of the grouping variable.

Fit Curve also enables you to build a model to create the prediction formula. Then you set 

upper and lower parameter limits in Nonlinear. For details, see “Example of Setting Parameter 

Limits” on page 250 in the “Nonlinear Regression” chapter.

Example Using the Fit Curve Platform

This example shows how to build a model for toxicity as a function of the concentration of a 

drug. You have a standard formulation of the drug and want to compare it to three new 

formulations.

You are interested in a toxicity ratio of surviving to non-surviving cells at a specific 

concentration of each drug. From prior research, you know the toxicity ratios for 16 different 

concentrations of each drug formulation. A lower ratio indicates more toxicity, which could be 
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detrimental to development of the drug. Log concentration was calculated to decrease the 

range of concentration values and make it easier to detect differences in the curves.

Follow these steps to build the model:

1. Select Help > Sample Data Library and open Nonlinear Examples/Bioassay.jmp.

2. Select Analyze > Specialized Modeling > Fit Curve.

3. Assign Toxicity to the Y, Response role.

4. Assign log Conc to the X, Regressor role.

5. Assign Formulation to the Group role.

6. Click OK.

The Fit Curve Report appears as shown in Figure 12.2. The Plot report contains an overlaid 

plot of the fitted model of each formulation.

Figure 12.2  Initial Fit Curve Report

7. To see a legend identifying each drug formulation, right-click one of the graphs and select 

Row Legend. Select Formulation for the column and click OK. The plot shown in 

Figure 12.3 appears.
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Figure 12.3  Fit Curve Report with Plot Legend

The curves appear S-shaped, so a sigmoid curve would be an appropriate fit. Table 12.1 

shows formulas and graphical depictions of the different types of models that the Fit 

Curve platform offers.

8. Select Sigmoid Curves > Logistic Curves > Fit Logistic 4P from the Fit Curve red triangle 

menu.
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Figure 12.4  Logistic 4P Report

The Logistic 4P report appears (Figure 12.4). There is also a separate plot for each drug 

formulation. The plot of the fitted curves suggests that formulation B might be different, 

because the test B curve starts to rise sooner than the others. Inflection point parameters 

cause this rise.

9. Select Compare Parameter Estimates from the Logistic 4P red triangle menu.

A portion of the Parameter Comparison report is shown in Figure 12.5.

Figure 12.5  Parameter Comparison Report



Chapter 12 Fit Curve 211
Predictive and Specialized Modeling Launch the Fit Curve Platform

Notice that the Inflection Point parameter for the test B formulation is significantly lower than 

the average inflection point. This agrees with the plots shown in Figure 12.4. Drug 

formulation B has a lower toxicity ratio than the other formulations.

Launch the Fit Curve Platform

To launch the Fit Curve platform, select Analyze > Specialized Modeling > Fit Curve. The 

launch window is shown in Figure 12.6.

Figure 12.6  Fit Curve Platform Launch Window

The Fit Curve platform launch window has the following features:

Y, Response Select the Y variable.

X, Regressor Select the X variable.

Group Specify a grouping variable. The fitted model has separate parameters for each level 

of the grouping variable. This enables you to compare fitted models and estimated 

parameters across the levels of the grouping variable.

Weight Specify a variable that contains the weights of the observations.

Freq Specify a variable that contains the frequencies of the observations.

By Specify a variable to perform a separate analysis for every level of the variable.

The Fit Curve Report

The Fit Curve report initially contains only a plot of Y versus X (Figure 12.7). If you specify a 

Group variable, the report includes overlaid and individual plots for each group of the fitted 

model (shown in Figure 12.7 on the right).
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Figure 12.7  Fit Curve Reports: No Grouping Variable (left) and with Group Variable (right)

After fitting a model, the fitted model appears on the plot (when no grouping variable is 

specified on the platform launch window). A Model Comparison report appears above the 

plots and a Model Report appears below the plot. Each time a new model is fit, it appears in 

the Model Comparison report and a new model report appears in the report window. See 

“Model Comparison Report” on page 213 and “Model Fit Report” on page 214.

Fit Curve Options

Select any of the following built-in models from the Fit Curve red triangle menu. For details, 

see “Model Formulas” on page 221.

Polynomials Fits first degree to fifth degree polynomials.

Sigmoid Curves Fits Logistic, Probit, Gompertz, and Weibull models. These models are 

S-shaped and have both upper and lower asymptotes. The Logistic 2P, 3P, and 4P and 

Probit 2P and 4P models are symmetric. The Logistic 5P and both Gompertz models are 

not symmetric. The Logistic 2P is available only when the response is between 0 and 1. The 

Weibull Growth is available only when both the response values and regressor values are 

non-negative. Examples of Sigmoid curves include learning curves and modeling tumor 

growth, both of which increase initially and then taper off.

Exponential Growth and Decay Fits Exponential, Biexponential, and Mechanistic Growth 

models. The Exponential 2P and 3P are similar, but the 3P model has an asymptote. The 

Biexponential models assume there are two separate growth or decay processes. The 

Mechanistic Growth and Exponential 3P models always increase, but the rate of growth 
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slows so that the model has an asymptote. Examples of exponential growth and decay 

functions are virus spread and drug half-life, respectively.

Peak Models Fits Gaussian Peak and Lorentzian Peak models. These models increase up to 

a peak and then decrease. The Gaussian Peak model is a scaled version of the Gaussian 

probability density function (PDF). The Lorentzian Peak model is a scaled version of the 

Cauchy distribution, a continuous probability distribution. These models can be used for 

some chemical concentration assays and artificial neural networks.

Pharmacokinetic Models Fits the One Compartment Oral Dose model, the Two 

Compartment IV Bolus Dose model, and the Biexponential 4P model. This option is used 

to model the concentration of drugs in the body.

Fit Michaelis-Menten Fits the Michaelis-Menten biochemical kinetics model, which relates 

the rate of enzymatic reactions to substrate concentration.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Model Comparison Report

To create the report shown in Figure 12.8, select Sigmoid Curves > Logistic Curves > Fit 
Logistic 4P and Sigmoid Curves > Fit Gompertz 4P from the Fit Curve red triangle menu.

Figure 12.8  Model Comparison Report
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The Model Comparison report shows fit statistics used for comparing multiple models. The 

statistics are AICc, AICc Weight, BIC, SSE, MSE, RMSE, and R-Square, and are defined below.

AICc Gives a measure of the goodness of fit of an estimated statistical model that can be 

used to compare two or more models. AICc is a modification of the AIC adjusted for small 

samples. AICc can only be computed when the number of data points is at least two 

greater than the number of parameters. The model with the lowest AICc value is the best, 

which is the Logistic 4P in our example. See the Statistical Details appendix in the Fitting 

Linear Models book.

AICc Weight Gives normalized AICc values that sum to one. The AICc weight can be 

interpreted as the probability that a particular model is the true model given that one of 

the fitted models is the truth. Therefore, the model with the AICc weight closest to one is 

the better fit. In our example, the Logistic 4P model is clearly the better fit. The AICc 

weights are calculated using only nonmissing AICc values, as follows:

AICcWeight = exp[-0.5(AICc-min(AICc))] / sum(exp[-0.5(AICc-min(AICc))])

where min(AICc) is the smallest AICc value among the fitted models. The AICc Weight 

column is then sorted in decreasing order.

BIC Gives a measure based on the likelihood function of model fit that is helpful when 

comparing different models. The model with the lower BIC value is the better fit. See the 

Statistical Details appendix in the Fitting Linear Models book.

SSE The sum of the squared differences between each observation and its predicted value.

MSE Gives the average of the squares of the errors of each value.

RMSE The square root of the MSE that estimates the standard deviation of the random 

error.

R-Square Estimates the proportion of variation in the response that can be attributed to the 

model rather than to random error. The model with the R-Square value closest to one is the 

better fit.

The Model Comparison platform provides additional options, such as plotting residual and 

actual values. See the “Model Comparison” chapter on page 185 for more information.

Model Fit Report

A report is created for each fitted model. The red triangle menu for each model report 

provides the following options.

Prediction Model Gives the algebraic form of the prediction formula and the parameters.
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Summary of Fit Gives the same fit statistics as the Model Comparison report.

Parameter Estimates Gives the estimates of the parameters, standard errors, Chi-squared 

statistics, p-values, and confidence intervals. The correlations and covariances of the 

estimates are given also.

Tip: You can sort the Parameter Estimates report table by clicking on the column you wish 

to sort by.

Plot Gives plots of the data with the fitted model. See Figure 12.7. The plots are shown only 

when you select a Grouping variable on the platform launch window.

Model Fit Options

Each model report contains a red triangle menu with some or all of the following options:

Test Parallelism Helps determine whether the curves are similar in shape when they are 

shifted along the X axis. In certain situations, it is important to establish parallelism before 

making further comparisons between groups. This option is available only when a Group 

variable is specified on the platform launch window. This option is available for the 

Sigmoid models (Logistic and Gompertz), as well as the Linear Regression model, with the 

exception of higher-order polynomials. For details, see “Test Parallelism” on page 217.

Area Under Curve Gives the area under the fitted curve. This option is available only for 

the following models: One Compartment, Two Compartment, Gaussian Peak, and 

Lorentzian Peak. The range of integration depends on the type of model and is specified in 

the report.

If a Grouping variable is specified on the platform launch window, an Analysis of Means is 

performed for comparing the estimates across groups. If the result for a group exceeds a 

decision limit, the result is considered different from the overall mean of AUC.

Compare Parameter Estimates Gives an analysis for testing the equality of parameters 

across levels of the grouping variable. This option is available only when a Group variable 

is specified on the platform launch window. For details, see “Compare Parameter 

Estimates” on page 219.

Equivalence Test Gives an analysis for testing the equivalence of models across levels of 

the grouping variable. This option is available only when a Group variable is specified on 

the platform launch window. For details, see “Equivalence Test” on page 220.



216 Fit Curve Chapter 12
Model Fit Options Predictive and Specialized Modeling

Make Parameter Table Saves the parameter estimates, standard errors, and t-ratios in a 

data table. This option is available only when a Group variable is specified on the platform 

launch window.

Plot Actual by Predicted Plots actual Y values on the vertical axis and predicted Y values 

on the horizontal axis.

Plot Residual by Predicted Plots the residuals on the vertical axis and the predicted Y 

values on the horizontal axis.

Profiler Shows or hides a profiler of the fitted prediction function. The derivatives are 

derivatives of the prediction function with respect to the X variable. For more information 

about profilers, see the Profiler chapter in the Profilers book.

Save Formulas Contains options for saving a variety of formula columns in the data table.

Save Prediction Formula Saves the prediction equation.

Save Std Error of Predicted Saves the standard error of the predicted values.

Save Parametric Prediction Formula Saves the prediction equation in parametric 

form. This is helpful if you want to use the fitted model in the custom Nonlinear 

platform.

Save Residual Formula Saves the residuals.

Save Studentized Residual Formula Saves the studentized residual formula, a 

standard residual that is divided by its estimated standard deviation.

Save First Derivative Saves the derivative of the prediction function with respect to the 

X variable.

Save Std Error of First Derivative Saves the equation of the standard error of the first 

derivative.

Save Inverse Prediction Formula Saves the equation for predicting X from Y.

Custom Inverse Prediction Predicts an X value for a specific Y value. For more information 

about inverse prediction, see the Standard Least Squares chapter in the Fitting Linear 

Models book.

Remove Fit Removes the model report, the entry from the Model Comparison report, and 

the fitted line from the plot.



Chapter 12 Fit Curve 217
Predictive and Specialized Modeling Model Fit Options

Test Parallelism

The Test Parallelism option provides an analysis for testing if the fitted models between 

groups have the same shape, but are shifted along the X axis (Figure 12.9). In the Bioassay 

example, the curve for drug formulation B is shifted to the left of the other three curves. 

However, you do not know whether the curves still have the same shape (are parallel), or if 

formulation B is different. The Parallelism Test tells us if the shapes for the different drug 

formulations have similar shapes and are shifted along the horizontal axis. Select Test 
Parallelism from the fitted model’s red triangle menu to add the report.

Figure 12.9  Parallelism Test

The report gives the following results:

Test Results Gives the results of an F Test and a Chi-Square Test for parallelism. The tests 

compare the error sums-of-squares for a full model (Full SSE) and a reduced model (Fit 
SSE). The full model gives each group different parameters. The reduced model forces the 

groups to share every parameter except for the inflection point. A small p-value indicates 
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that the group models are significantly different from one another. Therefore, the reduced 

model with shared parameters is insufficient and the full model should be used. In 

Figure 12.9, the p-value is greater than 0.05, indicating that there is not enough evidence to 

conclude that differences exist between the curves. In this case, the reduced model with 

shared parameters is appropriate.

The fit statistics are calculated as follows:

F Ratio

ChiSquare

Parallel Fit Parameter Estimates Gives the parameter estimates under the reduced model 

(same parameters, except for inflection point). A plot of the fitted curves under the 

reduced model is provided. The inflection point for drug formulation B is much lower 

than that of the other three drug formulations.

Relative Potencies Gives the relative potency for each level of the grouping variable. The 

relative potency is 10^(EC50), where EC50 is the concentration at which the response half 

way between baseline and maximum is obtained. For the Logistic 2P, 3P, and 4P, the 

relative potency is 10^(inflection point parameter).

Fit SSE - Full SSE  NDF  Full SSE DDF 

Fit SSE Full SSE–
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Figure 12.10  Relative Potencies by group

In the Relative Potency versus standard panel from Figure 12.10, note that the relative 

potencies for drug formulations A and C are nearly one. This indicates that their potencies 

are similar to that of the standard formulation. The potency for drug formulation B is 

lower than that of the standard. This means that drug formulation B increases in toxicity as 

a function of concentration faster than the standard.

In the parallelism test, the curves are parallel, which enables you to calculate relative 

potencies. Based on the relative potencies, you conclude that formulation B is more potent 

than the other drug formulations. Taken with the prior findings, drug formulation B appears 

to be more toxic.

Compare Parameter Estimates

The Compare Parameter Estimates report gives results for testing the equality of parameters 

across the levels of the grouping variable. There is an Analysis of Means (ANOM) report for 

each parameter, which tests whether the parameters are equal to an overall mean. If the result 

for a parameter exceeds the decision limits, then the parameter is different from the overall 

mean. Figure 12.11 shows the ANOM report for growth rate estimates. Select Compare 
Parameter Estimates from the fitted model’s red triangle menu to add the report.
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Figure 12.11  Parameter Comparison for Growth Rate Estimates

The Analysis of Means red triangle menu has the following options:

Set Alpha Level Sets the alpha level for the test.

Show Summary Report Shows or hides a report containing the parameter estimates, the 

decision limits, and whether the parameter exceeded the limits.

Display Options Contains options for showing or hiding decision limits, shading, and the 

center line. Also contains options for changing the appearance of the points.

For more information about the Analysis of Means report, see the Oneway chapter in the Basic 

Analysis book.

Equivalence Test

The Equivalence Test report gives an analysis for testing the equivalence of models across 

levels of the grouping variable (Figure 12.12). After selecting the option, you specify the level 

of the grouping variable that you want to test against every other level. There is a report for 

every level versus the chosen level. Select Equivalence Test from the fitted model’s red triangle 

menu to add the report.

The equality of the parameters is tested by analyzing the ratio of the parameters. The default 

decision lines are placed at ratio values of 0.8 and 1.25, representing a 25% difference.

If all of the confidence intervals are inside the decision lines, then the two groups are 

practically equal. If a single interval falls outside the lines (as shown in Figure 12.12), then you 

cannot conclude that the groups are equal. The inflection point for drug formulation B is 

lower than the standard, which agrees with the previous findings.
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Figure 12.12  Equivalence Test

The Equivalence red triangle menu has the following options:

Set Alpha Level Sets the alpha level for the test. The default value is 0.05.

Set Decision Lines Changes the decision limits for the ratio. The default values are set at 

0.8 and 1.25, representing a 25% difference.

Show Summary Report Shows or hides a report containing the parameter estimates, the 

decision limits, and whether the parameter exceeded the limits.

Display Options Contains options for showing or hiding decision limits, shading, and the 

center line. Also contains options for changing the appearance of the points. For additional 

formatting options, right-click the graph and select Customize.

Statistical Details for the Fit Curve Platform

Model Formulas

Table 12.1 provides the formulas for the models on the Fit Curve red triangle menu.

decision lines

The inflection point is 
outside the decision 
limits, so you cannot 
conclude that the 
groups are equal.
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Table 12.1  Fit Curve Model Formulas

Model Formula

Polynomials

where k is the order of the polynomial. These models 

can also be fit using the Fit Model and Fit Y by X 

platforms.

Logistic 2P

a = Growth Rate

b = Inflection Point

Available only when all response values are between 

zero and one.

Logistic 3P

a = Growth Rate

b = Inflection Point

c = Asymptote

Logistic 4P

a = Growth Rate

b = Inflection Point

c = Lower Asymptote

d = Upper Asymptote

0

i
xi

i 1=

k

+

1
1 Exp a– x b–  +
------------------------------------------------

c
1 Exp a– x b–  +
------------------------------------------------

c d c–
1 Exp a– x b–  +
------------------------------------------------+
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Logistic 4P Rodbard

a = Growth Rate

b = Inflection Point

c = Lower Asymptote

d = Upper Asymptote

Available only when the regressor values are positive.

Logistic 4P Hill

a = Growth Rate

b = Inflection Point

c = Lower Asymptote

d = Upper Asymptote

Logistic 5P

a = Growth Rate

b = Inflection Point

c = Asymptote 1

d = Asymptote 2

f = Power

Table 12.1  Fit Curve Model Formulas (Continued)

Model Formula

c d c–

1 x b a+
--------------------------+

c d c–

1 10
a– x b–  

+
----------------------------------------+

c d c–

1 Exp a– x b–  + f
------------------------------------------------------+
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Probit 2P

a = Growth Rate

b = Inflection Point

 = Normal Distribution CDF

Available only when all response values are between 

zero and one.

Probit 4P

a = Growth Rate

b = Inflection Point

c = Asymptote 1

d = Asymptote 2

 = Normal Distribution CDF

Gompertz 3P

a = Asymptote

b = Growth Rate

c = Inflection Point

Gompertz 4P

a = Lower Asymptote

b = Upper Asymptote

c = Growth Rate

d = Inflection Point

Table 12.1  Fit Curve Model Formulas (Continued)

Model Formula

 x b–
a

----------- 
 

c d c–   x b–
a

----------- 
 +

aExp Exp b– x c–  – 

a b a– Exp Exp c– x d–  – +
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Weibull Growth

a = Upper Asymptote

b = Growth Rate

c = Inflection Point

Available only when both the response values and 

regressor values are non-negative.

Exponential 2P

a = Scale

b = Growth Rate

Exponential 3P

a = Asymptote

b = Scale

c = Growth Rate

Biexponential 4P

a = Scale 1

b = Decay Rate 1

c = Scale 2

d = Decay Rate 2

Available only when the response values are positive.

Table 12.1  Fit Curve Model Formulas (Continued)

Model Formula

a 1 Exp x c b– – 

aExp bx 

a bExp cx +

aExp bx–  cExp dx– +



226 Fit Curve Chapter 12
Statistical Details for the Fit Curve Platform Predictive and Specialized Modeling

Biexponential 5P

a = Asymptote

b = Scale 1

c = Decay Rate 1

d = Scale 2

f = Decay Rate 2

Mechanistic Growth

a = Asymptote

b = Scale

c = Growth Rate

Gaussian Peak

a = Peak Value

b = Critical Point

c = Growth Rate

Lorentzian Peak

a = Peak Value

b = Growth Rate

c = Critical Point

Table 12.1  Fit Curve Model Formulas (Continued)

Model Formula

a bExp cx–  dExp fx– + +

a 1 bExp c– x – 

aExp 1
2
---–

x b–
c

----------- 
  2

 
 

ab2

x c– 2 b2+
-------------------------------
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One Compartment Oral Dose

a = Area Under Curve

b = Elimination Rate

c = Absorption Rate

Available only when the response values and the 

regressor values are all positive.

Two Compartment IV Bolus 

Dose

 =

 =

a = Initial Concentration

b = Transfer Rate In

c = Transfer Rate Out

d = Elimination Rate

Available only when the response values and the 

regressor values are all positive.

Michaelis-Menten

a = Max Reaction Rate

b = Inverse Affinity

Available only when the response values and the 

regressor values are all positive.

Table 12.1  Fit Curve Model Formulas (Continued)

Model Formula

pill
process in 
kidneys

elimination
b

abc
c b–
----------- Exp b– x  Exp c– x – 

shot  blood tissue

c

b

d

a
 –
-------------  b– Exp – x   b– Exp – x – 

1
2
--- b c d b c d+ + 2 4bd–+ + + 

1
2
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ax
b x+
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Chapter 13
Nonlinear Regression

Fit Custom Nonlinear Models to Your Data

The Nonlinear platform is a good choice for models that are nonlinear in the parameters. This 

chapter focuses on custom nonlinear models, which include a model formula and parameters 

to be estimated. Use the default least squares loss function or a custom loss function to fit 

models. The platform minimizes the sum of the loss function across the observations.

Figure 13.1  Example of a Custom Nonlinear Fit

The Nonlinear platform also provides predefined models, such as polynomial, logistic, 

Gompertz, exponential, peak, and pharmacokinetic models. See the “Fit Curve” chapter on 

page 205 for more information.

Note: Some models are linear in the parameters (for example, a quadratic or other polynomial) 

or can be transformed to be such (for example, when you use a log transformation of x). The 

Fit Model or Fit Y by X platforms are more appropriate in these situations. For more 

information about these platforms, see the Model Specification chapter in the Fitting Linear 

Models book and the Introduction to Fit Y by X chapter in the Basic Analysis book.
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Example of Fitting a Custom Model

To fit a custom model, you must first create a model column with initial parameter estimates. 

This method does require a few more steps than fitting a built-in model, but it does allow any 

nonlinear model to be fit. Also, you can provide a custom loss function, and specify several 

other options for the fitting process.

This section provides an example of creating the formula column for a model, and fitting the 

model in the Nonlinear platform. The data is in the US Population.jmp data table. The response 

variable is the population (in millions) of the Unites States and the predictor is the year.

1. Select Help > Sample Data Library and open Nonlinear Examples/US Population.jmp.

2. Create a new column called Model.

3. Right-click the Model column and select Column Properties > Formula.

The Formula Editor appears.

4. Select Parameters from the list below the list of columns.

5. Select New Parameter.

6. Type B0 for Name.

7. Type 3.9 for Value. This is the initial estimate of the parameter.

8. Click OK.

9. Select New Parameter.

10. Type B1 for Name and enter 0.022 for Value.

11. Click OK.

12. Enter the model formula using the Formula Editor functions, the column year, and the 

parameters. Figure 13.2 shows the completed model.

Figure 13.2  Completed Model Formula

Tip: Click the gray triangle next to Transcendental to find the Exp command.

13. Click OK.

14. Select Analyze > Specialized Modeling > Nonlinear.

15. Assign Model to the X, Predictor Formula role.

16. Assign pop to the Y, Response role.
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17. Click OK.

18. Click Go on the Control Panel to fit the model.

A portion of the report is shown in Figure 13.3.

Figure 13.3  Plot and Solution Report

The final parameter estimates are shown in the Solution report, along with other fit 

statistics. The fitted model is shown on the plot.

Parameters for Models with a Grouping Variable

In the formula editor, when you add a parameter, note the check box for Expand Into 
Categories, selecting column. This option is used to add several parameters (one for each level 

of a categorical variable for example) at once. When you select this option, a dialog appears 

that enables you to select a column. After selection, a new parameter appears in the 

Parameters list with the name D_column, where D is the name that you gave the parameter. 

When you use this parameter in the formula, a Match expression is inserted, containing a 

separate parameter for each level of the grouping variable.
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Launch the Nonlinear Platform

To launch the Nonlinear platform, select Analyze > Specialized Modeling > Nonlinear. The 

launch window is shown in Figure 13.4.

Figure 13.4  Nonlinear Platform Launch Window

The Nonlinear platform launch window has the following features:

Y, Response Select the Y variable.

X, Predictor Formula Select either the X variable or a column containing the model formula 

with parameters.

Note: If you select a column that does not contain a model formula with parameters, the 

Fit Curve platform is launched instead.

Group Specify a grouping variable. The fitted model has separate parameters for each level 

of the grouping variable. This enables you to compare fitted models and estimated 

parameters across the levels of the grouping variable.

Note: If the formula does not have separate parameters for each group level, the Group 

variable is ignored by JMP.

Weight Specify a variable containing the weights of observations.

Freq Specify a variable representing the frequency of an observation.
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Loss Specify a formula column giving a loss function.

By Specify a variable to perform a separate analysis for every level of the variable.

Model Library Launches the Model Library tool, which helps you choose initial values to 

create a formula column. See “Create a Formula Using the Model Library” on page 241.

Numeric Derivatives Only Uses only numeric derivatives only. This option is useful when 

you have a model for which it is too messy to take analytic derivatives. It can also be 

valuable in obtaining convergence in tough cases. This option is used only when a formula 

column is provided in the X, Predictor Formula role.

Expand Intermediate Formulas Tells JMP that if an ingredient column to the model is a 

column that itself has a formula, to substitute the inner formula, as long as it refers to other 

columns. To prevent an ingredient column from expanding, use the Other column 

property with a name of “Expand Formula” and a value of 0. This option is used only 

when a formula column is provided in the X, Predictor Formula role.

The Nonlinear Fit Report

The initial Nonlinear Fit report includes the following items, shown in Figure 13.5.

Control Panel Provides options for controlling the fitting process.

Go Starts the fitting process.

Stop Stops the fitting process.

Step Proceeds through the fitting process one iteration at a time.

Reset Resets the editable values into the formula, resets the iteration values, and 

calculates the SSE at these new values.

Criterion Shows iteration measures from the fitting process.

Current Shows the current value of each Criterion.

Stop Limit Sets limits on the measures listed under Criterion.

Plot Shows a plot of the X and Y variables for models with only one X variable. The model 

based on the current values is shown on the plot. To change the current values of the 

parameters, use the sliders or edit boxes beneath the plot.
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Figure 13.5  Initial Nonlinear Fit Report

After you click Go to fit a model, the report includes the following additional items, shown in 

Figure 13.6.

Save Estimates Saves the current parameter values to the parameters in the formula 

column.

Confidence Limits Computes confidence intervals for all parameters. The intervals are 

profile likelihood confidence intervals, and are shown in the Solution report. The 

confidence limit computations involve a new set of iterations for each limit of each 

parameter, and the iterations often do not find the limits successfully. The Edit Alpha and 

Convergence Criterion options are for the confidence interval computations For details 

about the Goal SSE for CL, see “Profile Likelihood Confidence Limits” on page 253.

Solution Shows the parameters estimates and other statistics.
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SSE Shows the residual sum of squared errors. SSE is the objective that is to be 

minimized. If a custom loss function is specified, this is the sum of the loss function.

DFE Shows the degrees of freedom for error, which is the number of observations used 

minus the number of parameters fitted.

MSE Shows the mean squared error. It is the estimate of the variance of the residual 

error, which is the SSE divided by the DFE.

RMSE Estimates the standard deviation of the residual error, which is square root of the 

MSE.

Parameter Lists the names that you gave the parameters in the fitting formula.

Estimate Lists the parameter estimates produced. Keep in mind that with nonlinear 

regression, there might be problems with this estimate even if everything seems to 

work.

ApproxStdErr Lists the approximate standard error, which is computed analogously to 

linear regression. It is formed by the product of the RMSE and the square root of the 

diagonals of the derivative cross-products matrix inverse.

Lower CL and Upper CL Shows the confidence limits for the parameters. They are 

missing until you click the Confidence Limits on the Control Panel. For more details 

about the confidence intervals, see “Profile Likelihood Confidence Limits” on page 253.

Excluded Data Shows a report showing fit statistics for excluded rows. This is useful for 

validating the model on observations not used to fit the model. You can use this feature 

in conjunction with the Remember Solution option to change the exclusions, and get a 

new report reflecting the different exclusions

Correlation of Estimates Displays the correlations between the parameter estimates.
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Figure 13.6  Fitted Model Report
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Nonlinear Platform Options

The Nonlinear Fit red triangle menu has the following options:

Parameter Bounds Sets bounds on the parameters. When the option is selected, editable 

boxes appear in the Control Panel. Unbounded parameters are signified by leaving the 

field blank.

Plot Shows or hides a plot of the X and Y variables for models with only one X variable. The 

model shown on the plot is based on the current values of the parameters. To change the 

current values of the parameters, use the sliders or edit boxes beneath the plot. If you 

specify a Group variable at launch, then a curve shows for each group.

Iteration Options Specifies options for the fitting algorithm.

Iteration Log Records each step of the fitting process in a new window.

Numeric Derivatives Only Useful when you have a model that is too messy to take 

analytic derivatives for. It can also be valuable in obtaining convergence in tough cases.

Expand Intermediate Formulas Tells JMP that if an ingredient column to the formula is 

a column that itself has a formula, to substitute the inner formula, as long as it refers to 

other columns. To prevent an ingredient column from expanding, use the Other 
column property with a name of “Expand Formula” and a value of 0.

Newton Specifies whether Gauss-Newton (for regular least squares) or 

Newton-Raphson (for models with loss functions) is the optimization method.

QuasiNewton SR1 Specifies QuasiNewton SR1 as the optimization method.

QuasiNewton BFGS Specifies QuasiNewton BFGS as the optimization method.

Accept Current Estimates Tells JMP to produce the solution report with the current 

estimates, even if the estimates did not converge.

Show Derivatives Shows the derivatives of the nonlinear formula in the JMP log. See 

“Notes Concerning Derivatives” on page 256, for technical information about 

derivatives.

Unthreaded Runs the iterations in the main computational thread. In most cases, JMP 

does the computations in a separate computational thread. This improves the 

responsiveness of JMP while doing other things during the nonlinear calculations. 

However, there are some isolated cases (models that have side effects that call display 

routines, for example) that should be run in the main thread, so this option should be 

turned on.
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Profilers Provides various profilers for viewing response surfaces.

Profiler Shows the Prediction Profiler. The Profiler lets you view vertical slices of the 

surface across each x-variable in turn, as well as find optimal values of the factors.

Contour Profiler Shows the Contour Profiler. The Contour profiler lets you see 

two-dimensional contours as well as three dimensional mesh plots.

Surface Profiler Creates a three-dimensional surface plot. This option is available only 

for models with two or more X variables.

Parameter Profiler Shows the Prediction Profiler and profiles the SSE or loss as a 

function of the parameters.

Parameter Contour Profiler Shows the Contour Profiler and contours the SSE or loss as 

a function of the parameters.

Parameter Surface Profiler Creates a three-dimensional surface plot and profiles the 

SSE or loss as a function of the parameters. This option is available only for models 

with two or more parameters.

SSE Grid Create a grid of values around the solution estimates and compute the error sum 

of squares for each value. The solution estimates should have the minimum SSE. When the 

option is selected, the Specify Grid for Output report is shown with these features:

Parameter Lists the parameters in the model.

Min Displays the minimum parameter values used in the grid calculations. By default, 

Min is the solution estimate minus 2.5 times the ApproxStdErr.

Max Displays the maximum parameter value used in the grid calculations. By default, 

Max is the solution estimate plus 2.5 times the ApproxStdErr.

Number of Points Gives the number of points to create for each parameter. To calculate 

the total number of points in the new grid table, multiply all the Number of Points 

values. Initially Number of Points is 11 for the first two parameters and 3 for the rest. If 

you specify new values, use odd values to ensure that the grid table includes the 

solution estimates. Setting Number of Points to 0 for any parameter records only the 

solution estimate in the grid table.

When you click Go, JMP creates the grid of points in a new table. A highlighted row marks 

the solution estimate row if the solution is in the table.

Revert to Original Parameters Resets the platform to the original parameter values (the 

values given in the formula column parameters).



240 Nonlinear Regression Chapter 13
Nonlinear Platform Options Predictive and Specialized Modeling

Remember Solution Creates a report called Remembered Models, which contains the 

current parameter estimates and summary statistics. Results of multiple models can be 

remembered and compared. This is useful if you want to compare models based on 

different parameter restrictions, or models fit using different options. Click on the radio 

button for a particular model to display that model in the Plot and the parameter estimates 

in the Control Panel.

Custom Estimate Gives an estimate of a function of the parameters. You provide an 

expression involving only parameters. JMP calculates the expression using the current 

parameter estimates, and also calculates a standard error of the expression using a 

first-order Taylor series approximation.

Custom Inverse Prediction Estimates the X value for a given Y value. It also calculates a 

standard error for the estimated X. JMP must be able to invert the model. The standard 

error is based on the first-order Taylor series approximation using the inverted expression. 

The confidence interval uses a t-quantile with the standard error, and is a Wald interval.

Save Pred Confid Limits Saves asymptotic confidence limits for the model prediction. This 

is the confidence interval for the average Y at a given X value.

Save Indiv Confid Limits Saves asymptotic confidence limits for an individual prediction. 

This is the confidence interval for an individual Y value at a given X value.

Save Formulas Gives options for saving model results to data table columns:

Save Prediction Formula Saves the prediction formula with the current parameter 

estimates.

Save Std Error of Predicted Saves the standard error for a model prediction. This is the 

standard error for predicting the average Y for a given X. The formula is of the form 

Sqrt(VecQuadratic(matrix1,vector1)). matrix1 is the covariance matrix associated 

with the parameter estimates, and vector1 is a composition of the partial derivatives of 

the model with respect to each parameter.

Save Std Error of Individual Saves the standard error for an individual prediction. This 

is the standard error for predicting an individual Y value for a given X value. The 

formula is of the form Sqrt(VecQuadratic(matrix1,vector1)+mse). matrix1 is the 

covariance matrix associated with the parameter estimates, vector1 is a composition of 

the partial derivatives of the model with respect to each parameter, and mse is the 

estimate of error variance.

Save Residual Formula Saves the formula for computing the residuals.

Save Pred Confid Limit Formula Saves the formula to calculate the confidence interval 

for a model prediction. This is a confidence interval for the average Y for a given X.
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Save Indiv Confid Limit Formula Saves the formula to calculate the confidence interval 

for an individual prediction. This is a confidence interval for an individual Y for a 

given X.

Save Inverse Prediction Formula Saves formulas for the inverse of the model, the 

standard error of an inverse prediction, and the standard error of an individual inverse 

prediction.

Save Specific Solving Formula Equivalent to Save Inverse Prediction Formula in 

simple cases. However, this command allows the formula to be a function of several 

variables and allows expressions to be substituted. This feature works only for solving 

easily invertible operators and functions that occur just once in the formula.

After selecting this command, a dialog appears that enables you to select the variable to 

solve for. You can also edit the names of the columns in the resulting table. You can also 

substitute values for the names in the dialog. In these cases, the formula is solved for 

those values.

Note: The standard errors, confidence intervals, and hypothesis tests are correct only if 

least squares estimation is done, or if maximum likelihood estimation is used with a 

proper negative log-likelihood.

Show Prediction Expression Shows the prediction model or the loss function at the top of 

the report.

Create a Formula Using the Model Library

The Model Library can assist you in creating the formula column with parameters and initial 

values. Click the Model Library button on the Nonlinear launch window to open the library. 

Select a model in the list to see its formula in the Formula box (Figure 13.7).
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Figure 13.7  Nonlinear Model Library Dialog

Click Show Graph to show a 2-D theoretical curve for one-parameter models and a 3-D surface 

plot for two-parameter models. No graph is available for models with more than two 

explanatory (X) variables. On the graph window, change the default initial values of 

parameters using the slider, or clicking and entering values in directly. See Figure 13.8.
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Figure 13.8  Example Graph in Model Library

The Reset button sets the initial values of parameters back to their default values.

Click Show Points to overlay the actual data points to the plot. The dialog in Figure 13.9 

opens, asking you to assign columns into X and Y roles, and an optional Group role. The 

Group role allows for fitting the model to every level of a categorical variable. If you specify a 

Group role here, also specify the Group column on the platform launch window.

Figure 13.9  Select Roles

For most models, the starting values are constants. Showing points enables you to adjust the 

parameter values to see how well the model fits for different values of the parameters. For the 

US population example, the points are shown in Figure 13.10.
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Figure 13.10  Show Points

Clicking Make Formula at this point (after using Show Points) creates a new data table column 

named after the model that you chose from the Model Library. This column has the formula as 

a function of the latest parameter starting values.

Note: If you click Make Formula before using the Show Graph or Show Points buttons, you are 

asked to provide the X and Y roles, and an optional Group role. See Figure 13.9. After that, 

you are brought back to the plot so that you have the opportunity to adjust the parameters 

starting values if desired. At that point click Make Formula again to create the new column.

Once the formula is created in the data table, continue the analysis by assigning the new 

column as the X, Predictor Formula in the Nonlinear launch dialog.

Customize the Nonlinear Model Library

The Model Library is created by a built-in script named NonlinLib.jsl, located in the 

Resources/Builtins folder in the folder that contains JMP (Windows) or in the Application 

Package (Macintosh). You can customize the nonlinear library script by modifying this script.

To add a model, you must add three lines to the list named Listofmodellist#. These three 

lines are actually a list themselves, which consists of the following three parts.

• Model name, a quoted string

• Model formula, an expression
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• Model scale

For example, suppose you want to add a model called “Simple Exponential Growth” that has 

the form

Add the following lines to the NonlinLib.jsl script

{//Simple Exponential Growth
"Simple Exponential Growth",
Expr(Parameter({b1=2, k=0.5}, b1*exp(k * :X))),
lowx = -1; highx = 2; lowy = 0;  highy = 2},

Some things to note:

• The first line is simply an open bracket (starting the list) and an optional comment. The 

second line is the string that is displayed in the model library window.

• The values of lowx, highx, logy, and highy specify the initial window for the theoretical 

graph.

• There is a comma as the last character in the example above. If this is the final entry in the 

Listofmodellist# list, the comma can be omitted.

• If the model uses more than two parameters, replace the last line (containing the graph 

limits) with the quoted string “String Not Available”.

To delete a model, delete the corresponding three-lined list from the Listofmodellist# 

list.

Additional Examples

• “Example of Maximum Likelihood: Logistic Regression”

• “Example of a Probit Model with Binomial Errors: Numerical Derivatives”

• “Example of a Poisson Loss Function”

• “Example of Setting Parameter Limits”

Example of Maximum Likelihood: Logistic Regression

This example shows how to use the Nonlinear platform to minimize a loss function. The loss 

function is the negative of a log-likelihood function, thus producing maximum likelihood 

estimates.

y b1e
kx

=
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The Logistic w Loss.jmp data table in the Nonlinear Examples sample data folder has an 

example for fitting a logistic regression using a loss function. The Y column contains ones for 

events and zeros for non-events. The Model Y column has the linear model, and the Loss 

column has the loss function. In this example, the loss function is the negative log-likelihood 

for each observation, or the negative log of the probability of getting the observed response.

Run the model by following the steps below:

1. Select Help > Sample Data Library and open Nonlinear Examples/Logistic w Loss.jmp.

2. Select Analyze > Specialized Modeling > Nonlinear.

3. Assign Model Y to the X, Predictor Formula role.

4. Assign Loss to the Loss role.

Figure 13.11  Nonlinear Launch Window

5. Click OK.

The Nonlinear Fit Control Panel appears.
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Figure 13.12  Nonlinear Fit Control Panel

6. Click Go.

The parameter estimates are shown in the Solution report. See Figure 13.13.

Figure 13.13  Solution Report

The Loss value in the Solution report is the negative log-likelihood evaluated at the parameter 

estimates.

Example of a Probit Model with Binomial Errors: Numerical 
Derivatives

The Ingots2.jmp sample data table includes the numbers of ingots tested for readiness after 

different treatments of heating and soaking times. The response variable, NReady, is binomial, 

depending on the number of ingots tested (Ntotal) and the heating and soaking times. 

Maximum likelihood estimates for parameters from a probit model with binomial errors are 

obtained using:

• numerical derivatives

• the negative log-likelihood as a loss function

• the Newton-Raphson method.
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The average number of ingots ready is the product of the number tested and the probability 

that an ingot is ready for use given the amount of time it was heated and soaked. Using a 

probit model, the P column contains the model formula:

Normal Distribution(b0+b1*Heat+b2*Soak)

The argument to the Normal Distribution function is a linear model of the treatments.

To specify binomial errors, the loss function, Loss, has the formula

-(Nready*Log(p) + (Ntotal - Nready)*Log(1 - p))

Follow these steps to fit the model:

1. Select Help > Sample Data Library and open Ingots2.jmp.

2. Select Analyze > Specialized Modeling > Nonlinear.

3. Assign P to the X, Predictor Formula role,

4. Assign Loss to the Loss role.

5. Select the Numeric Derivatives Only option.

6. Click OK.

7. Click Go.

The platform used the Numerical SR1 method to obtain the parameter estimates shown in 

Figure 13.14.

Figure 13.14  Solution for the Ingots2 Data

Example of a Poisson Loss Function

A Poisson distribution is often used to model count data.

where  can be a single parameter, or a linear model with many parameters. Many texts and 

papers show how the model can be transformed and fit with iteratively reweighted least 

squares (Nelder and Wedderburn 1972). However, in JMP it is more straightforward to fit the 

P Y n=  e
– n

n!
--------------- , n 0 1 2   = =
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model directly. For example, McCullagh and Nelder (1989) show how to analyze the number 

of reported damage incidents caused by waves to cargo-carrying vessels.

The data are in the Ship Damage.jmp sample data table. The model formula is in the model 
column, and the loss function (or negative log-likelihood) is in the Poisson column. To fit the 

model, follow the steps below:

1. Select Help > Sample Data Library and open Ship Damage.jmp.

2. Select Analyze > Specialized Modeling > Nonlinear.

3. Assign model to the X, Predictor Formula role.

4. Assign Poisson to the Loss role.

5. Click OK.

6. Set the Current Value (initial value) for b0 to 1, and the other parameters to 0 (Figure 13.15).

Figure 13.15  Enter New Parameters

7. Click Go.

8. Click the Confidence Limits button.

The Solution report is shown in Figure 13.16. The results include the parameter estimates and 

confidence intervals, and other summary statistics.
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Figure 13.16  Solution Table for the Poisson Loss Example

Note: The standard errors, confidence intervals, and hypothesis tests are correct only if least 

squares estimation is done, or if maximum likelihood estimation is used with a proper 

negative log-likelihood.

Example of Setting Parameter Limits

The Fit Curve personality enables you to fit a model and then use the prediction equation in 

the full personality of the Nonlinear platform. This method requires more steps and user 

input but allows any nonlinear model to be fit.

Complete “Example Using the Fit Curve Platform” on page 207 in the “Fit Curve” chapter to 

fit the model. This example shows how to save the prediction formula from Fit Curve and 

then set parameter limits in Nonlinear.

1. From the Logistic 4P red triangle menu, select Save Formulas > Save Parametric Prediction 
Formula.

A new column named Toxicity Predictor appears in the data table.

2. Select Analyze > Specialized Modeling > Nonlinear.

3. Assign Toxicity to the Y, Response role.

4. Assign Toxicity Predictor to the X, Predictor Formula role.

5. Assign Formulation to the Group role.

6. Click OK.

The Nonlinear Fit window appears (Figure 13.17). In the Control Panel, parameter values 

and locking options are shown. The letters listed before each parameter correspond to 

variables from the Prediction Model in the Fit Curve function.
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Figure 13.17  Nonlinear Fit Control Panel

Tip: You can lock parameters if you know the values from prior information.

7. Select the red triangle menu next to Nonlinear Fit and then select Parameter Bounds.

Options for setting the lower and upper parameters appear next to the parameters.

8. Set the lower bounds for the parameters as shown in Figure 13.18. You know from prior 

experience that the maximum toxicity of the drug is at least 1.1.
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Figure 13.18  Setting Parameter Bounds

9. Click Go.

The final parameter estimates are shown in the Solution report, along with other fit 

statistics (Figure 13.19). The fitted model is shown on the plot.
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Figure 13.19  Nonlinear Fit Plot and Parameter Estimates

Options below the plot allow for adjusting parameter limits and estimates (Figure 13.19).

Statistical Details for the Nonlinear Platform

• “Profile Likelihood Confidence Limits”

• “How Custom Loss Functions Work”

• “Notes Concerning Derivatives”

• “Notes on Effective Nonlinear Modeling”

Profile Likelihood Confidence Limits

The upper and lower confidence limits for the parameters are based on a search for the value 

of each parameter after minimizing with respect to the other parameters. The search looks for 

values that produce an SSE greater by a certain amount than the solution’s minimum SSE. The 

goal of this difference is based on the F-distribution. The intervals are sometimes called 
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likelihood confidence intervals or profile likelihood confidence intervals (Bates and Watts 1988; 

Ratkowsky 1990).

Profile confidence limits all start with a goal SSE. This is a sum of squared errors (or sum of 

loss function) that an F test considers significantly different from the solution SSE at the given 

alpha level. If the loss function is specified to be a negative log-likelihood, then a Chi-square 

quantile is used instead of an F quantile. For each parameter’s upper confidence limit, the 

parameter value is increased until the SSE reaches the goal SSE. As the parameter value is 

moved up, all the other parameters are adjusted to be least squares estimates subject to the 

change in the profiled parameter. Conceptually, this is a compounded set of nested iterations. 

Internally there is a way to do this with one set of iterations developed by Johnston and 

DeLong. See the SAS/ETS User’s Guide (SAS Institute Inc. 2017).

Figure 13.20 shows the contour of the goal SSE or negative likelihood, with the least squares 

(or least loss) solution inside the shaded region:

• The asymptotic standard errors produce confidence intervals that approximate the region 

with an ellipsoid and take the parameter values at the extremes (at the horizontal and 

vertical tangents).

• Profile confidence limits find the parameter values at the extremes of the true region, 

rather than the approximating ellipsoid.

Figure 13.20  Diagram of Confidence Limits for Parameters

Likelihood confidence intervals are more trustworthy than confidence intervals calculated 

from approximate standard errors. If a particular limit cannot be found, computations begin 

for the next limit. When you have difficulty obtaining convergence, try the following:

• use a larger alpha, resulting in a shorter interval, more likely to be better behaved

• relax the confidence limit criteria.
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How Custom Loss Functions Work

The nonlinear facility can minimize or maximize functions other than the default sum of 

squares residual. This section shows the mathematics of how it is done.

Suppose that f() is the model. Then the Nonlinear platform attempts to minimize the sum of 

the loss functions defined as follows:

The loss function  for each row can be a function of other variables in the data table. It 

must have nonzero first- and second-order derivatives. The default  function, 

squared-residuals, is

To specify a model with a custom loss function, construct a variable in the data table and build 

the loss function. After launching the Nonlinear platform, select the column containing the 

loss function as the loss variable.

The nonlinear minimization formula works by taking the first two derivatives of  with 

respect to the model, and forming the gradient and an approximate Hessian as follows:

If  is linear in the parameters, the second term in the last equation is zero. If not, you can 

still hope that its sum is small relative to the first term, and use

The second term is probably small if  is the squared residual because the sum of residuals is 

small. The term is zero if there is an intercept term. For least squares, this is the term that 

distinguishes Gauss-Newton from Newton-Raphson.
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Note: The standard errors, confidence intervals, and hypothesis tests are correct only if least 

squares estimation is done, or if maximum likelihood estimation is used with a proper 

negative log-likelihood.

Notes Concerning Derivatives

The nonlinear platform takes symbolic derivatives for formulas with most common 

operations. This section shows what type of derivative expressions result.

If you open the Negative Exponential.jmp nonlinear sample data example, the actual formula 

for the Nonlinear column looks something like this:

Parameter({b0=0.5, b1=0.5}, b0*(1-Exp(-b1*X)))

The Parameter block in the formula is hidden if you use the formula editor. That is how it is 

stored in the column and how it appears in the Nonlinear Launch dialog. Two parameters 

named b0 and b1 are given initial values and used in the formula to be fit.

The Nonlinear platform makes a separate copy of the formula, and edits it to extract the 

parameters from the expression. Then it maps the references to them to the place where they 

are estimated. Nonlinear takes the analytic derivatives of the prediction formula with respect 

to the parameters. If you use the Show Derivatives command, you get the resulting formulas 

listed in the log, like this:

Prediction Model:

b0 * First(T#1=1-(T#2=Exp(-b1*X)), T#3=-(-1*T#2*X))

The Derivative of Model with respect to the parameters is:

{T#1, T#3*b0}

The derivative facility works like this:

• In order to avoid calculating subexpressions repeatedly, the prediction model is threaded 

with assignments to store the values of subexpressions that it needs for derivative 

calculations. The assignments are made to names like T#1, T#2, and so on.

• When the prediction model needs additional subexpressions evaluated, it uses the First 

function, which returns the value of the first argument expression, and also evaluates the 

other arguments. In this case additional assignments are needed for derivatives.

• The derivative table itself is a list of expressions, one expression for each parameter to be 

fit. For example, the derivative of the model with respect to b0 is T#1; its thread in the 

prediction model is 1–(Exp(-b1*X)). The derivative with respect to b1 is T#3*b0, which is 

–(–1*Exp(-b1*X)*X)*b0 if you substitute in the assignments above. Although many 

optimizations are made, it does not always combine the operations optimally. You can see 

this by the expression for T#3, which does not remove a double negation.
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If you specify a loss function, then the formula editor takes derivatives with respect to 

parameters, if it has any. And it takes first and second derivatives with respect to the model, if 

there is one.

If the derivative mechanism does not know how to take the analytic derivative of a function, 

then it takes numerical derivatives, using the NumDeriv function. If this occurs, the platform 

shows the delta that it used to evaluate the change in the function with respect to a delta 

change in the arguments. You might need to experiment with different delta settings to obtain 

good numerical derivatives.

Tips

There are always many ways to represent a given model, and some ways behave much better 

than other forms. Ratkowsky (1990) covers alternative forms in his text.

If you have repeated subexpressions that occur several places in a formula, then it is better to 

make an assignment to a temporary variable. Then refer to it later in the formula. For example, 

one of the model formulas above was this:

If(Y==0, Log(1/(1+Exp(model))), Log(1 - 1/(1 + Exp(model))));

This could be simplified by factoring out an expression and assigning it to a local variable:

temp=1/(1+Exp(model));
If(Y==0, Log(temp), Log(1-temp));

The derivative facility can track derivatives across assignments and conditionals.

Notes on Effective Nonlinear Modeling

We strongly encourage you to center polynomials.

Anywhere you have a complete polynomial term that is linear in the parameters, it is always 

good to center the polynomials. This improves the condition of the numerical surface for 

optimization. For example, if you have an expression like

a1 + b1x + c1x2

you should transform it to

The two models are equivalent, apart from a transformation of the parameters, but the second 

model is far easier to fit if the model is nonlinear.

The transformation of the parameters is easy to solve.

a2 b2 x x–  c2 x x– 2+ +
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If the number of iterations still goes to the maximum, increase the maximum number of 

iterations or relax one of the convergence criteria.

There is really no one omnibus optimization method that works well on all problems. JMP has 

options like Newton, QuasiNewton BFGS, QuasiNewton SR1, and Numeric Derivatives Only to 

expand the range of problems that are solvable by the Nonlinear Platform.

If the default settings are unable to converge to the solution for a particular problem, using 

various combinations of these settings to increase the odds of obtaining convergence.

Some models are very sensitive to starting values of the parameters. Working on new starting 

values is often effective. Edit the starting values and click Reset to see the effect. The plot often 

helps. Use the sliders to visually modify the curve to fit better. The parameter profilers can 

help, but might be too slow for anything but small data sets.

a1 a2 b2x– c2x+=

b1 b2 2c2x–=

c1 c2=
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Perform Functional Data Analysis

The Functional Data Explorer platform is available only in JMP Pro.

The Functional Data Explorer (FDE) platform is designed for data that are functions, signals, 

or series. It can be used as an exploratory data analysis tool or as a dimension-reduction 

technique. In the case of dimension reduction, the FDE platform converts functional data into 

a form that can be analyzed in another JMP platform.

Data preprocessing tools are available in the FDE platform, including several types of 

transformations for output data and alignments for input data. A surrogate model is created 

by fitting a B-spline, P-spline, or Fourier basis model to the data. When a model is fit, 

functional principal components analysis (functional PCA) is automatically performed on the 

surrogate model. Results from the functional PCA, such as the functional scores, can be saved 

to a separate data table and used for feature extraction or dimension reduction.

Figure 14.1  B-Spline Model Selection in FDE
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Overview of the Functional Data Explorer Platform

Functional data can be defined as data that are recorded over a continuous domain, where a 

set of measurements taken together present as some form of curve or image. Often, the 

domain is time and the sets of measurements are defined by an ID variable. A functional data 

observation for ID level i at a specific point t on the domain is written as fi(t). The Functional 

Data Explorer platform enables you to explore and analyze functional data.

The form of functional data can be dense or sparse. Dense functional data occur when 

observations are on the same equally spaced grid of points for all levels of the ID variable. 

Sparse functional data occur when ID levels have different numbers of observations that are 

unequally spaced across the domain. The Functional Data Explorer platform can handle both 

forms of functional data.

Although functional data can be expressed in many ways, it can generally be classified into 

the following two cases:

• The response of interest, Y(t), has a functional form.

• There are one or more covariates, X(t)’s, that have functional forms. These are sometimes 

referred to as functional or signal processes.

The Functional Data Explorer platform can be used as an exploratory tool for any type of 

functional data. However, the strength of the platform is taking many functional processes 

(that might be associated with a scalar response) and extracting key features to use in further 

modeling. This is done by first fitting a surrogate model to the data using a B-spline, P-spline, 

or Fourier basis model. Then, a functional principal components analysis (functional PCA) is 

performed on the surrogate model. Results from the functional PCA, such as the functional 

scores, can be saved and used for feature extraction and analysis in another modeling 

platform, such as the Generalized Regression personality of the Fit Model platform.

For more information about functional data analysis, see Ramsay and Silverman (2005).

Example of Functional Data Explorer

This example analyzes weekly weather data collected from 16 weather stations across the 

United States. Run the Weather Station Locations script in the data table to view a map of the 

locations. Daily temperatures are summarized as weekly averages. Not every weather station 

has a weekly temperature measurement for every week of the year. This is an example of 

sparse functional data.

1. Select Help > Sample Data Library and open Weekly Weather Data.jmp.

2. Select Analyze > Specialized Modeling > Functional Data Explorer.
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3. Select TMAX and click Y, Output.

4. Select Week of Year and click X, Input.

5. Select NAME and click ID, Function.

6. Click OK.

Figure 14.2  Initial Functional Data Explorer Report

The initial Functional Data Explorer report contains plots of the raw data, summary 

statistics, and summary plots for the functional mean and functional standard deviation of 

the data. Prior to modeling, it is often a good idea to center your output data.

7. Click the Data Processing red triangle and select Transform > Center.

The data plots and summary statistics are updated based on the specified transformation. 

Center is added to Steps list.

8. Click the Functional Data Explorer red triangle and select Models > Fourier Basis.
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Figure 14.3  Fourier Basis Model Report

The Fourier Basis report includes Model Selection and Model Summary reports, which 

contain information about the selected model. The displayed model is the best fitting 

model according to the BIC fit criterion. For the weather data, the Fourier Basis model that 

is chosen has a period of 53 and three basis function pairs. Fit statistics and coefficients are 

also shown for the model. Scroll down to view the Functional PCA report.
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Figure 14.4  Functional PCA Report

The Functional PCA report shows that while it takes three eigenvalues to explain almost 

99% of the variation in the data, the first eigenvalue alone explains 92%. You can use the 

score plot to detect functions that are outliers from the other functions. In the score plot, 

most of the locations are clustered together except for the Miami Beach, FL US and 

Greenville Maine Forestry Service, ME US locations. Scroll to the individual function 

plots. The function for the Miami Beach location is flatter than the rest of the locations and 

the function for the Greenville Forestry location is consistently colder than the other 

locations.

Tip: Deselect the Label variables option in the Score Plot report to better identify outliers.

Launch the Functional Data Explorer Platform

Launch the Functional Data Explorer platform by selecting Analyze > Specialized Modeling > 
Functional Data Explorer.
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Figure 14.5  Functional Data Explorer Launch Window

The Launch Window includes tabs for three different types of data formats.

Stacked Data Format In this data format, each row corresponds to a single observation. 

There are separate columns for the output, input, and ID variables.

Note: The Stacked Data Format is the only data format that enables you to specify multiple 

functional processes. If you assign more than one column to Y, Output in the Stacked Data 

Format tab, each Y variable is analyzed separately. A Fit Group report contains the 

individual reports for the Y variables.

Rows as Functions In this data format, each row corresponds to the full output function 

for one level of the ID variable. Each column is a level of the input variable.

Caution: The Rows as Functions format does not allow you to specify an input variable 

and instead uses the column numbers. This data format assumes that your observations 

are equally spaced in the input domain.

Columns as Functions In this data format, each column corresponds to the entire output 

function for one level of the ID variable. Each row corresponds to a level of the input 

variable.

Launch Window Options

Y, Output Assigns the functional process, f(t). There must be at least two observed output 

values for each level of the ID variable.

X, Input (Available for Stacked Data Format and Columns as Functions.) Assigns the input 

variable t. If no variable is specified for X, Input, the row number is used instead. Using 

the row number assumes that the observations are equally spaced in the input domain.
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ID, Function (Available for Stacked Data Format and Rows as Functions.) Assigns the ID 

variable to each function. If no ID variable is assigned in the Stacked Data Format tab, all 

observations are assumed to come from only one function.

Freq (Available only for Stacked Data Format.) Assigns a column whose numeric values 

represent a frequency for each row in the analysis. The effect of a frequency column is to 

expand the data table, so that any row with integer frequency k is expanded to k identical 

rows.

Validation Assigns an optional numeric column containing two distinct values. The smaller 

value defines the training set and the larger value defines the validation set. If there are 

more than two values, the smallest value defines the training set and all other values 

define the validation set.

Note: The Validation option enables you to hold out complete functions, not a sample of 

observations from each function. Therefore, all observations that have the same ID value 

must be classified as either test or validation. You cannot have observations with the same 

ID value in both sets. For more information on this type of validation column, see 

“Grouped Random” on page 64 in the “Modeling Utilities” chapter.

If you click the Validation button with no columns selected in the Select Columns list, you 

can add a validation column to your data table. For more information about the Make 

Validation Column utility, see “Make Validation Column Utility” on page 60 in the 

“Modeling Utilities” chapter.

By Assigns a column that creates a report consisting of separate analyses for each level of the 

variable. If more than one By variable is assigned, a separate analysis is produced for each 

possible combination of the levels of the By variables.

The Functional Data Explorer Report

The initial Functional Data Explorer report contains a Data Processing report and a 

Summaries report.
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Figure 14.6  Initial Functional Data Explorer Report

The Data Processing Report includes an initial data plot of all observations, as well as a matrix 

of individual data plots for each level of the ID variable. All graphs plot the functional 

response data over the values of the input variable.

The Summaries report contains a table of overall summary statistics, including the number of 

observations, number of functions, and the overall mean, standard deviation, minimum, and 

maximum values. There are also plots of the functional mean and functional standard 

deviation. The functional summary statistics displayed in the plots are computed at each 

unique value of the input variable.

The Data Processing and Summaries reports are useful for preprocessing your data prior to 

fitting a model. There are data cleaning, transformation, and alignment options available in 

the Data Processing red triangle menu. See “Data Processing Report Options” on page 273. 

Each time you perform a preprocessing step, the graphs and summary results are 
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automatically updated. You can perform multiple preprocessing steps in sequence. Each step 

is added to the list in the Steps outline of the Data Processing report. To remove the most 

recent step, click the Remove Last Step button below the Steps outline.

Model Reports

Use the options in the Models submenu in the Functional Data Explorer red triangle menu to 

fit models to your data. See “Models” on page 271 for the available models. Each time you fit a 

different type of model to the data, a model report appears. Each model report contains the 

following reports:

• “Model Controls” on page 268

• “Model Selection” on page 269

• “Diagnostic Plots” on page 269

• “Model Summary” on page 269

• “Functional PCA” on page 270

Model Controls

The Model Controls report enables you to define parameters of models to compare in the 

Model Selection report. You can specify the following parameters:

Number of Knots (Available only for B-Spline and P-Spline models.) Add, remove, or 

specify a range for the number of knots in each spline.

Spline Degree (Available only for B-Spline and P-Spline models.) Add or remove spline 

degree fits from the Model Selection report.

Number of Fourier Pairs (Available only for Fourier Basis models.) Add, remove, or specify 

a range for the number of Fourier pairs to compare.

Period (Available only for Fourier Basis.) Change the period of the function.

After you specify the model controls, click Go to view the updated models in the Model 

Selection report.

Tip: To specify the Model Controls prior to fitting a model, hold down the Shift key and select 

the desired model from the Functional Data Explorer red triangle menu. See “Models” on 

page 271.
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Model Selection

The Model Selection report contains a solution path plot, an overall prediction plot, and a grid 

of individual prediction plots for each level of the ID variable. The solution path plot shows a 

model selection criterion plotted over values of a model parameter. The Bayesian Information 

Criterion (BIC) is the default fitting criterion. See “Model Report Options” on page 274. For 

B-Spline and P-Spline models, there is a separate curve in the solution path for each spline 

degree plotted across the defined number of knots. For Fourier Basis models, the solution path 

is plotted across the number of Fourier pairs.

The current solution is designated by the dotted vertical line in the solution path plot. By 

default, the slider is placed at the number of knots or Fourier pairs that corresponds to the 

model that has the smallest model selection criterion value. You can drag the slider at the top 

of the dotted vertical line to change the number of knots or Fourier pairs in the current model. 

Dragging the slider automatically updates the prediction plots in the Model Selection report, 

the plots in the Diagnostic Plots report, and the information in the Model Summary report.

The prediction plots show the raw data and prediction curves that correspond to the current 

model. For spline models, the default model selected is the degree of spline with the best fit. 

Click on a specific spline in the solution path plot to change the current model selection. The 

curve in the overall prediction plot is a prediction of the mean. The curves in the individual 

prediction plots are prediction curves for each specific function. For B-Spline models, the 

overall prediction plot also displays the location of the knots. You can change the location of 

the knots by dragging the blue slider bars to different locations. To update the model reports 

according to the new knot locations, click the Update Models button. To reset the knots to their 

default locations, click the Reset Knots button.

Diagnostic Plots

The Diagnostic Plots report contains the Actual by Predicted plot and the Residual by 

Predicted plot. These plots help assess how well the current model fits the data. The 

Diagnostic Plots report is closed by default.

Model Summary

The Model Summary report contains the following items:

Model Description Displays a statement that describes the type of model that was fit.

Fit Statistics Displays the -2 Log Likelihood, the values for the AICc, BIC, and GCV model 

fitting criterion, and a value for <Y, Output> Std Dev. <Y, Output> Std Dev is the residual 

sigma from the fitted model. When a P-Spline model is selected, the penalty parameter  is 

also displayed.
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Function Summaries Displays summaries from the Functional PCA for each level of the ID 

variable. The first three functional principal components are displayed by default, as well 

as the mean, standard deviation, integrated difference, median, minimum, and maximum. 

The integrated difference is the average difference between points on the ID-specific curve 

and the mean curve. The Function Summaries report has the following red triangle menu 

options:

Customize Function Summaries Displays a window that enables you to select which 

summary statistics are shown in the Function Summaries report.

Tip: If you have multiple functional processes, you can customize all Function Summaries 

reports to show the same summary values by clicking Ctrl and selecting Customize 

Function Summaries.

Save Summaries Saves the summary statistics specified in the Function Summaries 

report to a new data table. The name of the new data table describes the model fit.

Basis Function Coefficients Displays the estimated basis function coefficients and their 

standard deviations. To view standard errors and confidence intervals for the coefficients, 

right-click in the table and select Columns.

Random Coefficients by Function Displays the estimated random coefficients for each 

basis function and functional process combination. 

Functional PCA

Functional principal components analysis (functional PCA) is performed on the surrogate 

(fitted) model. The Functional PCA report lists the eigenvalues that correspond to each 

principal component in order from largest to smallest. The bar chart shows the percent of 

variation accounted for by each principal component, as well as a cumulative percent curve. 

There is a graph for each component that shows the values of the eigenvector. Principal 

components that explain more than 1% variation in the data are included in the report. The 

percent of variation explained by each principal component is also shown on the plot axis.

The Functional PCA report also contains a score plot of the functional PCA scores. Use the list 

under Select Component to specify which principal components are plotted in the Score Plot. 

Score plots are useful for detecting outliers. In the case of functional PCA scores, the Score Plot 

can be used to detect levels of the ID variable that have outlier functions.

Note: If JMP is unable to perform Functional PCA, an error message appears in the Functional 

PCA report.
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Functional Data Explorer Platform Options

The red triangle menu for the Functional Data Explorer report has the following options:

Summaries A submenu of the following options for functional summary statistics:

Plot Mean Shows or hides a plot of the functional mean in the Summaries report. On by 

default.

Plot Standard Deviation Shows or hides a plot of the functional standard deviation in 

the Summaries report. On by default.

Plot Median Shows or hides a plot of the functional median in the Summaries report.

Models A submenu of the following model options:

B-Splines Fits a basis spline (B-Spline) model to the data. Use the B-Spline model for 

non-periodic data.

P-Splines Fits a penalized basis spline (P-Spline) model to the data.

Fourier Basis Fits a Fourier Basis model to the data. Use the Fourier Basis model for 

periodic data. See “Fourier Basis Model” on page 280.

Note: If there are fewer than three unique input values, a Fourier basis cannot be fit to the 

data, and a warning message appears.

Tip: To use the Model Controls prior to fitting a model, hold down the Shift key and select the 

desired model.

Save Data Saves the processed data to a new data table. The processed data are saved in the 

stacked data format.

Save Model Summaries for All Y (Available only when there are multiple functional 

processes.) Saves the model summaries for each level of the ID variable for each output to 

a new data table.

Note: A warning message appears if no models are fit or if there are some processes 

without models.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:
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Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Fit Group Options

Fit Group options are available only when a By variable is used in the analysis or when there 

are multiple functional processes specified in the Stacked Data Format tab in the launch 

window.

Arrange in Rows Specifies how many reports are displayed across the window.

Order by Goodness of Fit (Applicable only after fitting a model to each functional 

process.) Reorders the individual reports by goodness of fit.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.
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Data Processing Report Options

The red triangle menu for the Data Processing report has the following options:

Cleanup A submenu of the following data cleanup options:

Remove Zeros Removes observations with zero values. If there are no zeros in the data, 

an alert appears indicating that no zero values were found.

Remove Value Displays a specifications window that enables you to specify a value to 

remove from the data.

Remove Selected (Available only for Stacked Data Format.) Removes observations that 

correspond to rows that are selected in the data table.

Remove Unselected (Available only for Stacked Data Format.) Removes observations 

that correspond to rows that are not selected in the data table.

Note: The remove options exclude the specified observations from the analysis report, but 

the observations remain unchanged in the data table.

Transform A submenu of the following options to transform the output data:

Center Centers the output.

Standardize Standardizes the output by centering and scaling the data to have mean 0 

and variance 1.

Range 0 to 1 Scales the output to lie within the range of 0 and 1.

Square Root Transforms the data by computing the square root of the output. The 

output values must be nonnegative.

Square Transforms the data by computing the square of the output.

Log Transforms the data by computing the natural logarithm of the output.

Exp Transforms the data by computing the exponential function of the output.

Negation Transforms the data by negating the output.

Logit Transforms the data by computing the logit function of the output. The output 

values must be between 0 and 1.

Align A submenu of the following options to align the input data:

Row Alignment Replaces the input values with the row number.
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Align Maximum Aligns the functions using the observed maximum output value for 

each ID level. The input value associated with the observed maximum output value is 

set to zero for each ID level and the other input values are shifted up or down based on 

this.

Align Minimum Aligns the functions using the observed minimum output value for each 

ID level. The input value associated with the observed minimum output value is set to 

zero for each ID level and the other input values are shifted up or down based on this.

Align Range 0 to 1 Aligns the output functions such that the range of the input values is 

0 to 1.

Model Report Options

Model Selection Displays a submenu of choices to use as the model selection criteria. The 

choices are AICc, BIC, and GCV. For more information, see the Statistical Details appendix 

in the Fitting Linear Models book.

Plot Basis Shows or hides a plot of all the basis functions on one graph.

Diagnostic Plots Shows or hides the Diagnostics Plots report. See “Diagnostic Plots” on 

page 269

Model Summary Shows or hides the Model Summary report. See “Model Summary” on 

page 269.

Functional PCA Shows or hides the Functional PCA report. See “Functional PCA” on 

page 270.

Save Data Saves the modeled data to a new data table. The modeled data are saved in the 

stacked data format.

Save Summaries Saves the model summary statistics for each function to a new data table. 

The name of the new data table describes the model fit. The summary statistics included 

are the summary statistics that are specified in the Function Summaries report. See 

“Function Summaries” on page 270.

Remove Fit Removes the model report for the specified fit.
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Additional Example of the Functional Data 
Explorer Platform

Example for Multiple Functional Processes

This example uses the Fermentation Process.jmp and Fermentation Process Batch Yield 
Results.jmp sample data tables to analyze enzyme production. Yield is the amount of an 

enzyme produced by genetically modified yeast. There are 100 process measurements per 

batch that were taken at equally-spaced times over a 12-hour period.

The Functional Data Explorer platform is used to fit models to the data and save functional 

principal components to a new data table. The functional principal components are then 

analyzed in the Generalized Regression personality of the Fit Model platform.

Fit Functional Models

1. Select Help > Sample Data Library and open Fermentation Process.jmp.

2. Select Analyze > Specialized Modeling > Functional Data Explorer.

3. In the Stacked Data Format tab, select Ethanol through pH and click Y, Output.

4. Select Time and click X, Input.

5. Select BatchID and click ID, Function.

6. Click OK.

7. Press Ctrl, click any Data Processing red triangle, and select Align > Align Range 0 to 1. 

This aligns the input variable to be between 0 and 1 in each Functional Data Explorer 

report.

8. Press Ctrl, click any Functional Data Explorer red triangle, and select Models > B-Splines. 

This fits a B-spline model to each of the functional processes.
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Figure 14.7  Functional Data Explorer Report for Ethanol
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Figure 14.8  Model Summary Report for Ethanol

Figure 14.7 and Figure 14.8 show the model reports for one of the functional process 

variables, Ethanol. Scroll through the full report to view the models fit for each of the 

process variables. Next, you will use the FPCs in the Function Summaries report in an 

analysis.

Save FPCs and Link Yield Results

1. Press Ctrl, click any Function Summaries red triangle, and select Customize Function 
Summaries.

2. Deselect all summary statistics, except for FPC 1, FPC 2, and FPC 3.

3. Click OK.

4. Click any Functional Data Explorer red triangle and select Save Model Summaries for All Y.
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5. Select Help > Sample Data Library and open Fermentation Process Batch Yield Results.jmp.

6. In the Functional Data Explorer Model Summaries.jmp data table, right-click BatchID and 

deselect Link ID.

7. In the Functional Data Explorer Model Summaries.jmp data table, right-click BatchID and 

select Link Reference > Fermentation Process Batch Yield Results.jmp.

This virtually joins the yield data table and the summaries data table.

Fit a Generalized Regression Model

Use the Generalized Regression personality of the Fit Model platform to determine how Yield 

is affected by the functional process variables.

1. In the Functional Data Explorer Model Summaries.jmp data table, select Analyze > Fit Model.

2. Select Yield[BatchID] and click Y.

3. Select the remaining columns, except BatchID, and click Add.

4. Change the Personality to Generalized Regression.

5. Click Run.

6. Click Go.



Chapter 14 Functional Data Explorer 279
Predictive and Specialized Modeling Statistical Details for the Functional Data Explorer Platform

Figure 14.9  Generalized Regression Report for Batch Yield

The Generalized Regression report shows that Yield is significantly affected by certain 

components of Ethanol, Molasses Feed, NH3 Feed, and Air. The RSquare for the model is 

0.7999. By using FDE to perform dimension reduction on the functional processes first, you 

greatly reduce the number of variables, while still retaining a good prediction models.

Statistical Details for the Functional Data Explorer 
Platform

All of the model fits in the Functional Data Explorer platform rely on basis function 

expansion. Basis functions are a set of independent functions. Any function, f(t), can be 

approximated by taking a linear combination of K basis functions, denoted as k. In general, a 

function is approximated as follows:
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where the ck’s are the basis coefficients. The amount of smoothing is determined by the 

number of basis functions, K. For more information about basis function expansion, see 

Ramsay and Silverman (2005).

Fourier Basis Model

The k = 1,..., K functions that define the Fourier basis are defined such that 0 = 1, 

2k-1 = sin(rt), and 2k = cos(rt). Then, the approximated function is as follows:

This approximates a periodic function with period A defined as A = 2/. The coefficients are 

a combination of fixed basis function coefficients and random coefficients by function. Each c 

is defined as follows:

where k is the fixed coefficient for basis function k and ik is the random coefficient for basis 

function k for a specific functional process i. For the Fourier Basis model, the estimates for the 

k and ik parameters are found in the Basis Function Coefficients table and Random 

Coefficients by Function table, respectively.

Fourier basis models have an intercept term and an equal number of sine and cosine terms, 

which are referred to as Fourier pairs. Therefore, K is always odd. For example, if K = 7, there 

is an intercept term and three Fourier pairs.

f̂ t  ckk t 

k 1=

K

=

f̂i t  ci0 ci1 t ci2 t ci3 2t ci4 2t +cos+sin+cos+sin+=

cik k ik+=
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Fit Data Using Smoothing Models

Use the Gaussian Process platform to model the relationship between a continuous response 

and one or more predictors. These types of models are common in computer simulation 

experiments, such as the output of finite element codes, and they often perfectly interpolate 

the data. Gaussian processes can deal with these no-error-term models, in which the same 

input values always results in the same output value.

The Gaussian Process platform fits a spatial correlation model to the data. The correlation of 

the response between two observations decreases as the values of the independent variables 

become more distant.

One purpose for using this platform is to obtain a prediction formula that can be used for 

further analysis and optimization.

Figure 15.1  Gaussian Process Prediction Surface Example
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Example of Gaussian Process

This example uses data from a space filling design in two variables with a deterministic 

equation for Y (the response). You can use the Gaussian Process platform to find the 

explanatory power of X1 and X2 on Y. You can view the equation for Y in the column formula.

1. Select Help > Sample Data Library and open 2D Gaussian Process Example.jmp.

2. Select Analyze > Specialized Modeling > Gaussian Process.

3. Select X1 and X2 and click X.

4. Select Y and click Y

5. Select Correlation Type > Cubic.

6. Deselect Fast GASP.

7. Click OK.

Figure 15.2  Gaussian Process Report

Note: The estimated parameters can be different due to different starting points in the 

minimization routine, the choice of correlation type, and the inclusion of a nugget parameter.
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Now, visualize the fitted surface compared to the original surface.

8. Click the red triangle next to Gaussian Process Model of Y and select Save Prediction 
Formula.

9. Select Graph > Surface Plot.

10. Select X1 through Y Prediction Formula and click Columns.

11. Click OK.

12. In the Surface column, select Both sides for the Y Prediction Formula.

Figure 15.3  3D Surface Plot of the Actual and Predicted Ys

The two surfaces are similar. The impact of X1 and X2 on the response Y can be visualized. 

You can rotate the plot to view it from different angles. Marginal plots are another tool to 

use to understand the impact of the factors on the response.

Launch the Gaussian Process Platform

Launch the Gaussian Process platform by selecting Analyze > Specialized Modeling > 
Gaussian Process.
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Figure 15.4  Gaussian Process Launch Window

Y Assigns the continuous columns to analyze.

X Assigns the columns to use as explanatory variables. Categorical variables are allowed in 

JMP Pro when the Fast GASP option is specified.

Estimate Nugget Parameter introduces a ridge parameter into the estimation procedure. 

A ridge parameter is useful if there is noise or randomness in the response, and you want 

the prediction model to smooth over the noise instead of perfectly interpolating.

Fast GASP Option to use the Fast GASP algorithm. Fast GASP breaks the Gaussian 

process model into small pieces (called blocks) to speed computation time. Blocks allow 

for the use of multiple CPUs and parallel processing.

Note: When there are more than 2,500 observations, the Fast GASP algorithm is required.

For additional information about Fast GASP, see Parker (2015).

Correlation Type Choose the correlation structure for the model. The platform fits a spatial 

correlation model to the data, where the correlation of the response between two 

observations decreases as the values of the independent variables become more distant.

Gaussian Restricts the correlation between two points to always be nonzero, no matter 

the distance between the points.

Cubic Allows the correlation between two points to be zero for points that are far 

enough apart. This method is a generalization of a cubic spline.

The Fast GASP algorithm does not support the cubic correlation function.

Minimum Theta Value Sets the minimum theta value to use in the fitted model. The default 

is 0. The theta values are analogous to a slope parameter in regular regression models. 

Small theta values indicate that a variable has little influence on the predicted values.
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Block Size Number of observations in each computational block used by the Fast 

GASP algorithm. There must be at least 25 observations per block and a maximum of the 

number of rows in the data set up to a maximum of 2,500.

The Gaussian Process Report

• “Actual by Predicted Plot”

• “Model Report”

• “Marginal Model Plots”

Actual by Predicted Plot

The Actual by Predicted plot shows the actual Y values on the Y axis and the jackknife 

predicted values on the X axis. One measure of goodness-of-fit is how well the points lie along 

the diagonal (Y = X) of the plot.

The jackknife values are not true jackknife values in that the model is not re-fit with the 

associated row for each Y excluded. Rather, the row is excluded from the prediction model for 

each associated Y but the correlation parameters retain the contribution of the row in them. 

For Gaussian processes that perfectly interpolate the data this jackknife procedure provides 

predictions that are not equal to the input.

Model Report

The Model Report shows a functional ANOVA table for the model parameter estimates. 

Specifically, it is an analysis of variance table where the variation is computed using a 

function-driven method.

Theta Gaussian Process model parameter estimates. See “Statistical Details for the Gaussian 

Process Platform” on page 291.

Total Sensitivity Sum of the main effect and all interaction terms for each factor. It is a 

measure of the amount of influence a factor and all its two-way interactions have on the 

response variable.

Total variation is the integrated variability over the entire experimental space.

Main Effect The functional main effect of each factor is the integrated total variation due to 

that factor alone. The main effect is the ratio of the functional effect and the total variation 

for each factor in the model.

Interactions Functional interaction effects are computed in a similar way to main effects.
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Categorical Input When the model includes categorical factors, a correlation matrix 

for each categorical factor is provided. The off-diagonal entries correspond to Gaussian 

Process model parameter estimates. See “Models with Categorical Predictors” on 

page 292.

Mu and Sigma2 Mean and variance model parameters.

Nugget Estimated nugget value. A nugget value is reported if you selected estimate nugget 
parameter in the Gaussian Process launch window. A nugget value is also reported if JMP 

has added a nugget parameter in order to avoid a singular covariance matrix.

-2LogLikelihood Estimated value of the minimized -2log likelihood function.

Marginal Model Plots

A marginal plot appears for each factor in the model. It shows the response across the levels of 

a factor where all other factors are set to their average value.

Gaussian Process Platform Options

Use the options in the Gaussian Process red triangle menu to customize the report according 

to your individual needs.

Profiler Opens the standard Profiler. For details, see the Profiler chapter in the Profilers book.

Contour Profiler Opens the Contour Profiler. For details, see the Contour Profiler chapter in 

the Profilers book.

Surface Profiler Opens the Surface Profiler. For details, see the Surface Plot chapter in the 

Profilers book.

Save Prediction Formula Creates a new prediction formula column in the active data table.

Save Variance Formula Creates a new variance formula column in the active data table.

Publish Prediction Formula Creates a prediction formula and saves it as a formula 

column script in the Formula Depot platform. If a Formula Depot report is not open, this 

option creates a Formula Depot report. See the “Formula Depot” chapter on page 197.

Publish Variance Formula Creates a variance formula and saves it as a formula 

column script in the Formula Depot platform. If a Formula Depot report is not open, this 

option creates a Formula Depot report. See the “Formula Depot” chapter on page 197.
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Save Jackknife Predicted Values Saves the jackknife predicted values to the active data 

table. These are the X-axis values for the Actual by Predicted Plot.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Additional Examples of the Gaussian Process 
Platform

• “Example of a Gaussian Process Model”

• “Example of Gaussian Process Model with Categorical Predictors”

Example of a Gaussian Process Model

This example uses data that demonstrates the flow of water through a Borehole that is drilled 

from the ground surface through two aquifers. Given a specified engineering model the 

Gaussian process lets us understand the impact of factors included in the model on the 

response, Y.

1. Select Help > Sample Data Library and open Design Experiment/Borehole Latin 
Hypercube.jmp.

2. Select Analyze > Specialized Modeling > Gaussian Process.

3. Select log10 Rw through Kw and click X.

4. Select Y and click Y.

5. In JMP Pro, to run the analysis faster, leave the Fast GASP checked.

6. Click OK.
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Figure 15.5  Borehole Latin Hypercube Report

The data on the actual by predicted plot fall along the Y = X line, indicating that the 

Gaussian process prediction model is a good approximation of the true function. In the 

Model Report, you see that the first factor, log10 Rw, has the highest total sensitivity. The 

estimated total sensitivity for log10 Rw explains more than 90% of the variation in the 

response. Factors with small theta values have little (or no) impact on the prediction 

formula.

Note: Your estimates can differ from those shown in Figure 15.5, which were found using 

the Fast GASP algorithm.

Example of Gaussian Process Model with Categorical Predictors

This example uses the Algorithm Data.jmp sample data table. These data are simulated 

CPU times from a 50 run space filling designed experiment. The  Algorithm Factors.jmp sample 

data table provides the factors and settings for the design. The design has three continuous 
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and two categorical factors. The goal is to predict CPU Time using a Gaussian Process model 

that contains both continuous and categorical factors.

1. Select Help > Sample Data Library and open Design Experiment/Algorithm Data.jmp.

2. Select Analyze > Specialized Modeling > Gaussian Process.

3. Select Alpha through Compiler and click X.

4. Select CPU Time and click Y.

5. To run the analysis, leave the Fast GASP checked. Click OK.

Note: The Fast GASP option must be used for models that contain categorical factors. See 

“Models with Categorical Predictors” on page 292 for details.

Figure 15.6  Algorithm Data Report
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The actual by predicted plot shows a strong correlation between the actual and predicted 

CPU times. This in an indication that the Gaussian process prediction model is a good 

approximation of the true function. In the Model Report, the Beta predictor has the highest 

total sensitivity. This indicates that of the continuous predictors, Beta explains the most 

variation in the response. There is a separate Categorical Input matrix for each of the 

categorical predictors, Algorithm and Compiler. These matrices are correlation matrices and 

show the correlation between levels for each categorical predictor. The off-diagonals of the 

matrices are the  parameters.

Statistical Details for the Gaussian Process Platform

• “Models with Continuous Predictors”

• “Models with Categorical Predictors”

• “Variance Formula Parameterization”

• “Model Fit Details”

Models with Continuous Predictors

If the Gaussian Process model contains only continuous predictors, the Gaussian Process 

platform implements two possible correlation structures, the Gaussian and the Cubic.

The Gaussian correlation structure uses the product exponential correlation function with a 

power of 2 as the estimated model. This model assumes that Y is normally distributed with 

mean  and covariance matrix 2R. The elements of the R matrix are defined as follows:

where
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The Cubic correlation structure also assumes that Y is normally distributed with mean  and 

covariance matrix 2R. The R matrix consists of the following elements:

where

For more information, see Santer (2003). The theta parameter used in the Cubic correlation 

structure is the reciprocal of the parameter often used in the literature. The reciprocal is used 

so that when theta has no effect on the model, then rho has a value of zero, rather than infinity.

Models with Categorical Predictors

If the Gaussian Process model includes categorical predictors, the Gaussian correlation 

structure is used for the correlation structure. The elements of the R matrix are defined as 

follows:

where

rij 
k
 d k; =

d xik xjk–=

 d ; 

1 6 d 2– 6 d  3+ d
1

2
------

2 1 d – 3 1
2
------ d

1

---

0
1

--- d











=

rij pij

p 1=

P


 
 
 
 

k xik xjk– 2

k 1=

K

–
 
 
 
 

exp=

K # of continuous predictors=

P # of categorical predictors=

k theta parameter for the k
th

 continuous predictor=

xik the value of the k
th

 continous predictor for subject i=

xjk the value of the k
th

 continous predictor for subject j=



Chapter 15 Gaussian Process 293
Predictive and Specialized Modeling Statistical Details for the Gaussian Process Platform

There is a  parameter for each combination of levels of a categorical variable, with ij 

corresponding to the unique combination formed by the observed levels of subject i and 

subject j. Thus, the covariance element, rij, depends on the combination of levels of the 

categorical predictors obtained from the ith and jth observations. For more information, see 

Qian et al. (2012).

Variance Formula Parameterization

The saved variance formula uses the previously defined parameterization of R, except when 

the model includes categorical predictors. When the Gaussian Process model includes 

categorical predictors, the saved variance formula uses the following parameterization of R:

where  and all other variables are as previously defined.

Model Fit Details

The model parameters are fit via maximum likelihood. The fitted parameters are provided in 

the platform report. The parameters are as follows:

•  is the Gaussian Process mean,

•  is the Gaussian Process variance,

• Theta corresponds to the values of k in the definition of R.

• The off-diagonals of the categorical input correlation matrices correspond to the values of 

pij in the definition of R.

Note: If your report contains the note  Nugget parameters set to avoid singular variance 
matrix, JMP has added a ridge parameter to the variance matrix so that it is invertible.

pij
the correlation between the observed level of predictor p for subject i

            and the observed level of predictor p for subject j
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Fit Time Series Models and Transfer Functions

The Time Series platform enables you to explore, analyze, and forecast univariate time series. 

A time series is a set of observations taken over a series of equally spaced time periods. 

Observations that are close together in time are typically correlated. Time series methodology 

takes advantage of this dependence between observations to better predict what the series will 

look like in the future.

Characteristics that are common in time series data include seasonality, trend, and 

autocorrelation. The Time Series platform provides options to handle these characteristics. 

Graphs such as variograms, autocorrelation plots, partial autocorrelation plots, and spectral 

density plots can be used to identify the type of model appropriate for describing and 

predicting (forecasting) the time series. There are also several decomposition methods in the 

platform that enable you to remove seasonal or general trends in the data to simplify the 

analysis. Alternatively, the platform can fit more sophisticated ARIMA models that have the 

ability to incorporate seasonality and long term trends all in one model.

The Time Series platform can also fit transfer function models when supplied with an input 

series.

Figure 16.1  Forecast Plot



296 Time Series Analysis Chapter 16
Predictive and Specialized Modeling

Contents
Overview of the Time Series Platform . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 297

Example of the Time Series Platform . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 297

Launch the Time Series Platform  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 299

The Time Series Analysis Report  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 301

Time Series Graph. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 301

Time Series Basic Diagnostics Chart  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 302

Time Series Platform Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 304

Time Series Diagnostics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 304

Differencing and Decomposition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 305

ARIMA and Seasonal ARIMA Models  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 307

Smoothing Models  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 309

Transfer Function Models  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 310

Smoothing Model Specification Windows  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 312

Reports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 315

Difference Report  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 315

Decomposition Reports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 315

Model Comparison Report  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 317

Model Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 319

Transfer Function Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 323

Spectral Density Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 325

Additional Example of the Time Series Platform. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 326

Statistical Details for the Time Series Platform. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 330

Statistical Details for Spectral Density . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 330

Statistical Details for X-11 Decomposition  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 331

Statistical Details for Smoothing Models. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 331

Statistical Details for ARIMA Models  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 335

Statistical Details for Transfer Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 336



Chapter 16 Time Series Analysis 297
Predictive and Specialized Modeling Overview of the Time Series Platform

Overview of the Time Series Platform

A time series is a set y1, y2, ... ,yN of observations that are observed over a series of equally 

spaced time periods. Some examples of time series data include quarterly sales reports, 

monthly average temperatures, and counts of sunspots. The Time Series platform enables you 

to explore patterns and trends found in these types of data. You can then use these patterns 

and trends to forecast, or predict, into the future.

Characteristics that are common in time series data include seasonality, trend, and 

autocorrelation. Seasonality refers to patterns that occur over a known period of time. For 

example, data that are collected monthly might look similar in summer months across all 

years of data collection. Trend refers to long term movements of a series, such as gradual 

increases or decreases of values across time. Autocorrelation is the degree to which each point 

in a series is correlated with earlier values in the series.

There are many different models and forecasting methods available in the Time Series 

platform. However, not all methods can handle trend or seasonality. In order to choose an 

appropriate model, it is essential to determine which characteristics are present in the series. 

The Time Series platform provides graphs such as variograms, autocorrelation plots, partial 

autocorrelation plots, and spectral density plots that can be used to identify the type of model 

appropriate for describing and forecasting the evolution of the time series. There are also 

several differencing and decomposition methods in the platform that enable you to remove 

seasonal or general trends in the data to explore and simplify the analysis.

Alternatively, the platform can fit more sophisticated models that can incorporate seasonality 

and long term trends. One such model in the platform that has this ability is Winter’s Additive 

Method, which is an advanced exponential smoothing model. In addition, the platform can fit 

AutoRegressive Integrated Moving Average, or ARIMA, models. These models are the most 

statistically complex, but also provide the most flexibility. Both advanced exponential 

smoothing and ARIMA models are harder to interpret, but they are excellent tools for 

forecasting.

The Time Series platform can also fit transfer function models when supplied with an input 

series.

Example of the Time Series Platform

This example uses the Raleigh Temps.jmp sample data table, which contains maximum 

monthly temperatures measured in degrees Fahrenheit from 1980 to 1990. Use the Time Series 

platform to examine the series and predict the maximum monthly temperatures for the next 

two years.

1. Select Help > Sample Data Library and open Time Series/Raleigh Temps.jmp.
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2. Select Analyze > Specialized Modeling > Time Series.

3. Select Temperature and click Y, Time Series.

4. Select Month/Year and click X, Time ID.

5. In the box next to Forecast Periods, type 24.

This is the number of future periods that are forecast by the models fit to the data. You 

want to predict the monthly temperature for the next two years, which is 24 months.

6. Click OK.

Figure 16.2  Time Series Analysis Report for Raleigh Temps.jmp

The Time Series graph shows that the series is cyclic. This cyclic component is also 

apparent in the autocorrelation chart. Points that are 1 lag apart are positively correlated, 

with an AutoCorr value of 0.8007. As points become farther apart, they become negatively 

correlated, then positively correlated again, and then the pattern repeats. The Time Series 

graph and the autocorrelation chart provide evidence of seasonality in the time series.

7. Click the Time Series red triangle and select ARIMA.

8. Set p, the autoregressive order, to 1 because the series showed evidence of autocorrelation.
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9. Click Estimate.

10. Click the Time Series red triangle and select Seasonal ARIMA.

11. In the ARIMA box, set p, the autoregressive order, to 1 because the series showed evidence 

of autocorrelation.

12. In the Seasonal ARIMA box, set D, the seasonal differencing order, to 1 because the series 

showed evidence of seasonality.

13. Click Estimate.

14. In the Model Comparison table, check the box under Graph for both models.

Figure 16.3  Model Comparison Table for Raleigh Temps.jmp

The Model Comparison table is sorted by the AIC statistic, in decreasing order. This means 

that the best fitting model appears at the top of the report. The AIC value for the seasonal 

ARIMA model (693.4) is much smaller than the value for the regular ARIMA model 

(924.5). The graph shows that while the ARIMA model predicts the observed points 

relatively well, the residuals are larger than those from the Seasonal ARIMA model. Also, 

the Seasonal ARIMA model has more realistic predictions for future observations with 

narrower prediction intervals. These results make sense since the series showed evidence 

of a seasonal component.

Launch the Time Series Platform

Launch the Time Series platform by selecting Analyze > Specialized Modeling > Time Series. 

The Time Series launch window for the Seriesg.jmp sample data table is shown in Figure 16.4.
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Figure 16.4  The Time Series Launch Window

The Time Series platform launch window contains the following options:

Y, Time Series Assigns one or more columns as time series variables. Displayed on the Y 

axis.

Input List Assigns one or more columns as input series variables. Displayed in the Input 

Time Series Panel and used in transfer function models. The input series variable must be 

numeric, either as a time series or an indicator.

X, Time ID Assigns one variable for labeling the time axis (X axis). If no variable is specified 

for Time ID, the row number is used instead.

Note: If you use an X, Time ID variable, you can specify the time frequency by using the 

Time Frequency column property. You can choose Annual, Quarterly, Monthly, Weekly, 

Daily, Hourly, By Minute, and By Second. This helps JMP determine the spacing of the 

data when plotting the forecast values. If no frequency is specified, the data is treated as 

equally spaced numeric data.

Caution: It is assumed that the observations of the variable assigned to X, Time ID are 

equally spaced. However, the Time Series platform only checks whether the time stamps 

are increasing. The platform does not check if the observations are equally spaced.

By Assigns a column that creates a report consisting of separate analyses for each level of the 

variable. If more than one By variable is assigned, a separate analysis is produced for each 

possible combination of the levels of the By variables.

Note: If you use a By variable, you might have to change the number of autocorrelation 

lags depending on how many observations there are for each level of the By variable. The 

number of lags must be greater than one but less than the number of observations per 

level.
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Autocorrelation Lags Specifies the number of lags to use in computing the autocorrelations 

and partial correlations. This is the maximum number of periods between points used in 

the computation of these correlations. It must be greater than one but less than the number 

of rows. The default number of lags is 25.

Tip: A commonly used rule for the maximum number of lags is n/4, where n is the number 

of observations.

Forecast Periods Specifies the number of future periods that are forecast using each model 

fitted to the data. The default number of forecast periods is 25.

The Time Series Analysis Report

The initial Time Series report displays the time series graph, summary statistics and tests for 

the time series variable, and a basic diagnostics report. If a column is specified for Input List in 

the launch window, the Transfer Function Analysis and Input Time Series Panel reports are 

shown. Both the Transfer Function Analysis report and the Input Time Series Panel report 

contain the same initial information as the Time Series report.

• “Time Series Graph”

• “Time Series Basic Diagnostics Chart”

Time Series Graph

The Time Series graph plots each times series by the time ID. If no time ID is specified, the row 

number is used instead. The platform also performs several tests for stationarity using 

Augmented Dickey-Fuller (ADF) tests. The following tests and summary statistics are displayed 

next to the time series graph:

Mean The sample mean.

SD The sample standard deviation.

N The series length.

Zero Mean ADF A test against a random walk with zero mean, which is defined as follows:

Single Mean ADF A test against a random walk with a non-zero mean, which is defined as 

follows:

xt xt 1– et+=
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Trend ADF A test against a random walk with a non-zero mean and a linear trend, which is 

defined as follows:

Time Series Basic Diagnostics Chart

The information that is shown in the Time Series Basic Diagnostics chart depends on the Time 

Series Report red triangle menu options. The red triangle menu options that show or hide 

information from the diagnostics chart are Autocorrelation, Partial Autocorrelation, 

Variogram, and AR Coefficients. By default, Autocorrelation and Partial Autocorrelation are 

shown.

Autocorrelation Chart

The Autocorrelation option shows or hides the following columns in the Time Series Basic 

Diagnostics chart:

Lag The number of periods between points.

Note: The number of lags begins with 0 as the default. To compute correlations beginning 

with lag 1, modify the JMP preferences before generating the graph. Select File > 
Preferences > Platforms > Time Series, and then select Suppress Lag 0 in ACF and PACF.

AutoCorr The autocorrelation for the kth lag, computed as follows:

 where 

and  is the mean of the N non-missing points in the time series. By definition, the first 

autocorrelation (lag 0) always has length 1.

The bars graphically depict the autocorrelations. The blue curves represent twice the 

large-lag standard error ( 2 standard errors), computed as follows:
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Ljung-Box Q Used to test whether a group of autocorrelations is significantly different from 

zero, or to test that the residuals from a model can be distinguished from white noise. 

Q is the test statistic.

p-Value The p-value from the Ljung-Box test.

Partial Autocorrelation Chart

The Partial Autocorrelation option shows or hides the following columns in the Time Series 

Basic Diagnostics chart:

Lag The number of periods between points.

Partial The partial autocorrelation for the kth lag.

The bars graphically depict the partial autocorrelations. The blue lines represent  2 

standard errors for approximate 95% prediction limits, where the standard error is 

computed as follows:

 for all k

Variogram Chart

The Variogram option shows or hides the following columns in the Time Series Basic 

Diagnostics chart:

Lag The number of periods between points.

Variogram The variogram measures the variance of the differences of points k lags apart 

and compares it to that for points one lag apart. The variogram is computed from the 

autocorrelations as follows:

where rk is the autocorrelation at lag k.

AR Coefficients Chart

The AR Coefficients option shows or hides the following columns in the Time Series Basic 

Diagnostics chart:

Lag The number of periods between points.

AR Coef The coefficients approximate those that you would obtain from fitting a 

high-order, purely autoregressive model.
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Time Series Platform Options

• “Time Series Diagnostics”

• “Differencing and Decomposition”

• “ARIMA and Seasonal ARIMA Models”

• “Smoothing Models”

• “Transfer Function Models”

• “Smoothing Model Specification Windows”

Time Series Diagnostics

Graph Shows a submenu of options to control the time series plot appearance.

Time Series Graph Shows or hides the time series graph.

Show Points Shows or hides the points in the time series graph.

Connecting Lines Shows or hides the lines connecting the points in the time series 

graph.

Mean Line Shows or hides a horizontal line in the time series graph that depicts the 

mean of the time series.

Autocorrelation Shows or hides the Autocorrelation plot in the Time Series Basic 

Diagnostics Chart. The autocorrelation graph describes the correlation between all pairs of 

points in the time series for a given separation in time (lag). See “Autocorrelation Chart” 

on page 302.

Tip: The autocorrelation graph of the sample is often called the sample autocorrelation 

function.

Partial Autocorrelation Shows or hides the Partial Autocorrelation plot in the Time Series 

Basic Diagnostics Chart. The partial autocorrelation graph describes the partial correlation 

between all the pairs of points in the time series for a given separation in time (lag). See 

“Partial Autocorrelation Chart” on page 303.

Tip: The Autocorrelation and Partial Autocorrelation graphs can help you determine 

whether the time series is stationary (meaning it has a fixed mean and standard deviation 

over time) and what model might be appropriate to fit the time series.
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Variogram Shows or hides the graph of the variogram in the Time Series Basic Diagnostics 

Chart. See “Variogram Chart” on page 303.

AR Coefficients Shows or hides the graph of the least squares estimates of the 

autoregressive (AR) coefficients in the Time Series Basic Diagnostics Chart. See “AR 

Coefficients Chart” on page 303.

Spectral Density Shows or hides graphs of the spectral density as a function of period and 

frequency. The spectral density option also displays the White Noise test report, which 

gives results from two tests on the data. See “Spectral Density Report” on page 325 and 

“Statistical Details for Spectral Density” on page 330.

Differencing and Decomposition

Difference Shows the Differencing Specification window, shown in Figure 16.5. The 

window enables you to specify the differencing operation that you want to apply to the 

time series. Differencing the values in a time series can transform a nonstationary series 

into a stationary series. The differenced series is given by the following equation:

where t is the time index and B is the backshift operator defined by Byt = yt-1.

Note: Many time series do not exhibit a fixed mean, such as time series with trend or 

seasonality. Such nonstationary series are not suitable for description by time series 

models that assume a stationary time series such as ARMA models. Removing the trend 

and/or seasonality creates a differenced series that is stationary and enables you to 

describe the series using the models that assume stationarity.

Figure 16.5  Differencing Specification Window

The Differencing Specification window enables you to specify the Nonseasonal 

Differencing Order, d, the Seasonal Differencing Order, D, and the number of 

Observations per Period, s. Selecting zero for the value of the differencing order is 

equivalent to no differencing of that kind. Each time you specify a differencing operation 
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and click Estimate, a new Difference Report is displayed in the report window. For more 

information, see “Additional Example of the Time Series Platform” on page 326.

Decomposition Shows a submenu of decomposition methods. Decomposition of time 

series data isolates and removes linear trends and seasonal cycles from a time series. This 

can help with better model estimation. Three Decomposition options are provided.

Remove Linear Trend Estimates the linear trend of the time series using a linear 

regression model and removes the linear trend from the data. A Time Series report for 

the detrended series is added to the report window, along with the linear trend 

information. See “The Time Series Analysis Report” on page 301 and “Linear Trend 

Report” on page 316.

Remove Cycle Estimates the cyclic component of a time series using a single cosine 

wave and then removes the cyclic component from the data. When you select the 

Remove Cycle option, the Define Cycle dialog appears. This dialog window enables 

you to specify the number of units per cycle and indicate whether a constant should be 

subtracted from the data. A Time Series report for the decycled series is added to the 

report window, along with the cycle information. See “The Time Series Analysis 

Report” on page 301 and “Cycle Report” on page 316.

X11 Removes trend and seasonal effects using the X-11 method developed by the US 

Bureau of the Census (Shiskin et. al. 1967). For details about the X-11 method, see 

“Statistical Details for X-11 Decomposition” on page 331. When selected, the Select 

Decomposition Type dialog appears. This dialog window enables you to specify a 

multiplicative or additive X-11 adjustment. Once you click OK, an X11 report is added 

to the report window. See “X11 Report” on page 316.

The X11 option is available only for monthly or quarterly data. The X, Time ID column 

must contain numeric values equally spaced by month or quarter without any gaps or 

missing values. JMP returns an error if you request X11 for a time column that does not 

satisfy these requirements.

Note: When you select the Remove Linear Trend or the Remove Cycle options, JMP adds a 

column to the data table that contains the detrended or decycled data. If this column is 

already present in the data table when you select the option, JMP overwrites the existing 

column.

Tip: Typically, you would begin decomposition by removing any linear trend, and then 

removing long cycles, such as a 12-month cycle. Then you could start removing short 

cycles, such as 6-month cycles.

Show Lag Plot Shows or hides a plot with observations at time t on the Y axis and 

observations at time t +/- p on the X axis. The +/- p is known as the lag. This plot is useful in 
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determining how an observation at time t is related to another observation at time t +/- p. If 

there is not an identifiable structure to the plot, the observations are not related. However, 

if there is a structure to the plot, this indicates that there is some relationship between 

observations across time. Identifying the structure helps when building a time series 

model.

Cross Correlation (Available only in the Transfer Function Analysis red triangle menu.) 

Shows or hides a cross-correlation plot to the report. The length of the plot is twice that of 

an autocorrelation plot, or 2xACF length + 1. The plot includes plots of the output series 

versus all input series, in both numerical and graphical forms. The blue lines indicate two 

standard errors.

Note: For the cross correlation plot, the standard errors are calculated under the null 

hypothesis as 1/sqrt(n - k), where n is the number of nonmissing data values and k is the 

number of autocorrelation lags.

Prewhitening (Available only in the Input Series red triangle menu.) Shows the 

Prewhitening Specification window that enables you to set the prewhitening order. 

Prewhitening is a technique used to help identify the transfer function model. This 

technique involves fitting an ARIMA model to the input series such that the residuals are 

equivalent to white noise. The same model is then used to estimate the output series. You 

can use the cross correlation between the filtered input and filtered output series to 

determine an appropriate lag for the transfer function model. For information about 

prewhitening, see Box et al. (1994).

ARIMA and Seasonal ARIMA Models

ARIMA Shows the ARIMA Specification window, which enables you to specify the ARIMA 

model that you want to fit. An ARIMA model predicts future values of a time series by a 

linear combination of its past values and a series of errors (also known as random shocks or 

innovations). The ARIMA model performs a maximum likelihood fit of the specified 

ARIMA model to the time series. See “ARIMA Model” on page 335.

Note: An ARIMA model is commonly denoted ARIMA(p,d,q). If any of p, d, or q are zero, 

the corresponding letters are often dropped. For example, if p and d are zero, then the 

model would simply be a moving average model, denoted as MA(q).
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Figure 16.6  ARIMA Specification Window

p, Autoregressive Order The order p of the polynomial B operator.

d, Differencing Order The order d of the differencing operator.

q, Moving Average Order The order q of the differencing operator B.

Prediction Interval Enables you to set the prediction level between 0 and 1 for the 

forecast prediction intervals.

Intercept Determines whether the intercept term is a part of the model.

Constrain fit If checked, the fitting procedure constrains the autoregressive parameters 

to always remain within the stable region and the moving average parameters within 

the invertible region.

Tip: Deselect the Constrain fit option if the fitter is having difficulty finding the true 

optimum or if you want to speed up the fit. You can use the Model Summary table to see 

whether the resulting fitted model is stable and invertible.

Once you specify the model and click Estimate, a Model Report is added to the report 

window. See “Reports” on page 315.

Seasonal ARIMA Shows the Seasonal ARIMA Specification window, which enables you to 

specify the Seasonal ARIMA model that you want to fit. This window has the same 

elements as the ARIMA specification window, but it also contains the seasonal element 

specifications. The additional Observations per Period option enables you to specify the 

number of observations per period, denoted as s. For more information about the Seasonal 

ARIMA model, see “Seasonal ARIMA Model” on page 336.

Note: Seasonal ARIMA models are denoted as Seasonal ARIMA(p,d,q)(P,D,Q)s.

Once you specify the model and click Estimate, a Model Report is added to the report 

window. See “Reports” on page 315.
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Smoothing Models

Shows a submenu of smoothing models. Once you select a smoothing model, a specification 

window appears. See “Smoothing Model Windows” on page 313. For each model that is 

specified, a Smoothing Model Report appears in the report window. See “Model Report” on 

page 319. Smoothing models represent the evolution of a time series by the model:

where

t is the time-varying mean term

t is the time-varying slope term

s(t) is one of the s time-varying seasonal terms

at are the random shocks

For more information about the general smoothing model equation, see “Statistical Details for 

Smoothing Models” on page 331. The following smoothing models are available:

Simple Moving Average A model that estimates values by using an average of several 

adjacent points, defined by the smoothing window. The Simple Smoothing Average 

Specification window enables you to specify aspects of the smoothing window. Once 

specified, a Simple Moving Average report is shown. By default, this report produces 

plotted values that are equal to the average of consecutive observations in a time window. 

Multiple Simple Moving Average models can be added and shown on the same plot. For 

details, see “Simple Smoothing Average Specification Window” on page 312.

Simple Exponential Smoothing  A model with a level component. See “Simple 

Exponential Smoothing” on page 332.

Double Exponential Smoothing  A model with a level component and a trend component. 

This is a special case of Linear Exponential Smoothing. See “Double (Brown) Exponential 

Smoothing” on page 332.

Linear Exponential Smoothing  A model with a level component and a trend component. 

See “Linear (Holt) Exponential Smoothing” on page 333.

Damped-Trend Linear Exponential Smoothing  A model with a level component and a 

damped trend component. This model is appropriate for a series that exhibits a trend more 

complicated than a linear trend. See “Damped-Trend Linear Exponential Smoothing” on 

page 333.

Seasonal Exponential Smoothing A model with a level component and a seasonal 

component. See “Seasonal Exponential Smoothing” on page 334.

yt t tt s t  at+ + +=
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Winters Method  A model with a level component, a trend component, and a seasonal 

component. See “Winters Method (Additive)” on page 335.

Note: Each smoothing model has an ARIMA model equivalent. You might not be able to 

specify the equivalent ARIMA model using the ARIMA option because some smoothing 

models intrinsically constrain the ARIMA model parameters in ways that the ARIMA option 

does not allow.

Transfer Function Models

Transfer Function (Available only in the Transfer Function Analysis red triangle menu.) 

Shows the Transfer Function Model Specification window. Building a transfer function 

model is similar to building an ARIMA model; it is an iterative process of exploring, 

fitting, and comparing models. Before building a model and during the data exploration 

process, it is sometimes useful to prewhiten the data. See “Prewhitening” on page 307. For 

more information about transfer functions, see “Statistical Details for Transfer Functions” 

on page 336.

Note: Currently, the transfer function model platform has limited capability of supporting 

missing values.

Figure 16.7  Transfer Function Model Specification Window

The Transfer Function Model Specification window contains the following sections:

Noise Series Orders Contains specifications for the noise series. Lowercase letters are 

coefficients for non-seasonal polynomials, and uppercase letters are coefficients for 

seasonal polynomials.
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Choose Inputs Enables you select the input series for the model.

Input Series Orders Contains specifications for the input series. The first three orders 

relate to non-seasonal polynomials. The next four orders relate to seasonal 

polynomials. The final option is for an input lag.

There are three additional options that control model fitting:

Intercept Specifies whether the model has an intercept. If unchecked, it is assumed that 

 is zero.

Alternative Parameterization Specifies whether the general regression coefficient is 

factored out of the numerator polynomials.

Constrain Fit Toggles the constraining of the AR and MA coefficients.

Forecast Periods Specifies the number of forecasting periods that are used for 

forecasting. If there are rows at the end of the data table that contain missing values for 

the Y variable and nonmissing values for the input variables, these rows are used in the 

initial forecasting settings. The values for the input variables are treated as future 

values of the input variables.

Prediction Interval Specifies the confidence level for the prediction interval.

ARIMA Model Group Shows the ARIMA Model Group window, which enables you to fit a 

range of ARIMA or Seasonal ARIMA models by specifying the range of orders. As you 

enter ranges into the window, the Total Number of Models updates accordingly.

Figure 16.8  ARIMA Model Group Specification Window

Once you specify the models and click Estimate, a Model Report for each specified model 

is added to the report window. See “Reports” on page 315.

Save Spectral Density Creates a new data table containing the spectral density and 

periodogram where the (i+1)th row corresponds to the frequency fi = i / N (that is, the ith 

harmonic of 1 / N). The new data table has the following columns:
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Period The period of the ith harmonic, 1 / fi.

Frequency The frequency of the harmonic, fi.

Angular Frequency The angular frequency of the harmonic, 2fi.

Sine The Fourier sine coefficients, ai.

Cosine The Fourier cosine coefficients, bi.

Periodogram The periodogram, I(fi).

Spectral Density The spectral density, a smoothed version of the periodogram.

Number of Forecast Periods Shows a window that enables you to set the number of future 

periods that are forecast for the fitted models. The initial value is set in the Time Series 

launch window. All existing and future forecast results will use the new number of 

periods once it is changed.

Maximum Iterations Shows a window that enables you to reset the maximum number of 

iterations for future optimizations used in fitting ARIMA models.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Smoothing Model Specification Windows

Simple Smoothing Average Specification Window

The Simple Smoothing Average Specification window appears when you select Simple 

Moving Average as the smoothing model. Let w be the smoothing window width in a simple 
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moving average (SMA) model. Let ft=(yt+yt-1+yt-2+...yt-(w-2)+yt-(w-1))/w be the average of w 

consecutive observations for some time point t.

Figure 16.9  Simple Smoothing Average Specification Window

Enter smoothing window width The smoothing window width, w, that defines the number 

of consecutive points to average. The larger the window width, the more the series is 

smoothed.

No Centering The smoothing window is constructed from the points leading up to and 

including the time point, t, the point at which the series is being estimated. In other words, 

ft is the plotted value for time t.

Centered The smoothing window is centered around the time point at which the series is 

being estimated.

– For odd w, ft is the plotted value for time t-(w-1)/2.

– For even w, ft is the plotted value for time t-(w-1)/2. When saved to a data table, ft is at 

t-(w-2)/2.

Centered and Double Smoothed for Even Number of Terms For even w, the smoothing 

window cannot be centered around the time point at which the series is being estimated. 

This option creates two smoothing windows that are almost centered, and averages them 

together. The smoothing estimates are calculated as follows:

Smoothing Model Windows

The Smoothing Model specification windows appear when you select one of the smoothing 

model options other than Simple Moving Average. The title of the window and the available 

options depend on the smoothing model option that you select.
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Figure 16.10  Smoothing Model Specification Window

Prediction Interval Enables you to set the prediction level for the forecast prediction 

intervals.

Observations per Period (Available only for seasonal smoothing models.) Enables you to 

set the number of observations per period in a seasonal smoothing model.

Constraints Enables you to specify what type of constraint you want to enforce on the 

smoothing weights during the fit. The constraint options are as follows:

Zero To One Constrains the values of the smoothing weights to the range zero to one.

Unconstrained Allows the parameters to range freely.

Stable Invertible Constrains the parameters such that the equivalent ARIMA model is 

stable and invertible.

Custom Expands the dialog to enable you to set constraints on individual smoothing 

weights. Each smoothing weight can be Bounded, Fixed, or Unconstrained as 

determined by the setting of the popup menu next to the weight’s name. When 

entering values for fixed or bounded weights, the values can be positive or negative 

real numbers.

Figure 16.11  Custom Smoothing Weights

The example shown in Figure 16.11 has the Level weight () fixed at a value of 0.3 and 

the Trend weight () bounded by 0.1 and 0.8. In this case, the value of the Trend weight 

is allowed to move within the range 0.1 to 0.8 while the Level weight is held constant at 

0.3. Note that you can specify all the smoothing weights in advance by using these 

custom constraints. In that case, none of the weights would be estimated from the data 

although forecasts and residuals would still be computed.
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Reports

• “Difference Report”

• “Decomposition Reports”

• “Model Comparison Report”

• “Model Report”

• “Transfer Function Report”

• “Spectral Density Report”

Difference Report

The Difference Report contains graphs of the autocorrelations and partial autocorrelations of 

the differenced series. These graphs can be used to determine whether the differenced series is 

stationary.

The ARIMA and Seasonal ARIMA models that are available in the Time Series platform 

accommodate a differencing operation. In a two step process, these models first difference the 

time series according to the differencing operation, and then fit the differenced series. The 

Difference option is a useful preprocessing tool for determining the order of differencing to 

specify for the ARIMA model.

The Difference red triangle menu contains the following options:

Graph Shows a submenu of options to control the appearance of the differenced series plot. 

See “Time Series Platform Options” on page 304.

Autocorrelation Shows or hides the autocorrelation of the differenced series.

Partial Autocorrelation Shows or hides the partial autocorrelations of the differenced 

series.

Variogram Shows or hides the variogram of the differenced series.

Save Saves a new column that contains the values in the differenced series to the original 

data table. Some of the leading elements are lost in the differencing process. They are 

represented as missing values in the saved Difference column.

Decomposition Reports

This section provides details about the reports obtained from the three decomposition 

options:

• “Linear Trend Report” on page 316
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• “Cycle Report” on page 316

• “X11 Report” on page 316

Linear Trend Report

Contains the values of 0 and 1 from the linear regression model that is fit to the data:

The detrended series is equal to Dt = Ot - Trendt, where Ot is the original time series.

Cycle Report

Contains the values of the cyclical component that is fit to the data:

The parameter values are defined as follows:

• C is the (optional) Constant

• A is the Amplitude of the cosine wave

• U is the number of Units per Cycle

• P is the Phase of the cosine wave

• t is one less than the row number of a given observation

The decycled series is equal to Dt = Ot - Cyclet, where Ot is the original time series.

X11 Report

Depending on your selection of Decomposition Type, the X11 option adds an X11 - 

Multiplicative report or an X11 - Additive report. The reports contain the same four plots:

Original and Adjusted Overlays the X11-adjusted time series on the original time series, Ot. 

The X11-adjusted values are  for the multiplicative adjustment and  for the 

additive adjustment.

D10 - Final Seasonal Factors Plots the seasonal factor components, St, over time.

D12 - Final Trend Cycle Plots the trend cycle components, Ct, over time.

D13 - Final Irregular Series Plots the irregular components, It, over time.

Trendt 0 1time+=

Cyclet C A 2  1
U
---- 
  t P+ 
   

 cos+=

Ot St Ot St–
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X11 Report Options

The X11 reports have the following red triangle options:

Show Tables Shows or hides the X11 summary tables, as described in Shiskin et. al. (1967). 

The tables are grouped into five categories (labeled B through F), described in Table 16.1.

Save Columns Saves four columns to the data table: the seasonally adjusted time series, the 

seasonal components (St), the trend cycle components (Ct), and the irregular series 

components (It).

Save All Columns Saves columns to the data table for all of the tables produced in the 

report by the Show Tables option.

For details about the contents of the X11 output tables, see Shisken et. al. (1967) or SAS/ETS 

13.1 User’s Guide (search for “The output from PROC X11”).

Model Comparison Report

Once a model is fit, the Model Comparison Report is displayed in the report window. This 

report contains the Model Comparison table and plots for the models. Each time a new model 

is fit, a new row is added to the Model Comparison table, with a unique color-coding. The 

Model Comparison table summarizes the fit statistics for each model and is used to compare 

several models fitted to the same time series. By default, the models are sorted by the AIC 

statistic, in decreasing order. To sort the model by a different statistic, right-click on any 

column in the Model Comparison Table and select Sort by Column. For definitions of the fit 

statistics, see “Model Summary Table” on page 319. The only fit statistic that is unique to the 

Table 16.1  Descriptions of the Categories of X11 Output Tables

Letter Prefix Category Description

B preliminary estimates of seasonal, trend cycle, and irregular 

components

C intermediate estimates of seasonal, trend cycle, and irregular 

components

D final estimates of seasonal, trend cycle, and irregular components

E analytical tables

F summary measures
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Model Comparison Table is Weights. This fit statistic is the normalized AIC Weight. The AIC 

Weight for a model is calculated as follows:

K is the total number of models, AICk is the AIC value for model k, and BestAIC is the AIC 

value for the model with the minimum AIC value.

Figure 16.12  Model Comparison Table

You can select which full model reports are shown in the report window using the Report 
checkbox. Two model plots appear to the right of the Model Comparison table. The top plot is 

a time series plot of the data, forecasts, and prediction limits. Below that are plots of the 

autocorrelation and partial autocorrelation functions. You can select which models are 

displayed on the model plots using the Graph checkbox.

Figure 16.13  Model Plots

Model Comparison Report Options

Each model in the Model Comparison report has the following red triangle menu options:

AICWeight = exp[-0.5(AIC - BestAIC)]/ exp 0.5 AICk BestAIC– –  

k 1=

K


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Fit New Opens a specification window for the model. You can change the settings to fit a 

different model.

Simulate Once Provides one simulation of the model out k time periods. The simulation is 

shown on the Model Comparison time series plot. To change k, use the Number of 

Forecast Periods option in the Time Series red triangle menu.

Simulate More Provides the specified number of simulations of the model out k time 

periods. The simulations are shown on the Model Comparison time series plot. To change 

k, use the Number of Forecast Periods option in the Time Series red triangle menu.

Remove Model Simulation Removes the simulations for the model.

Remove All Simulation Removes the simulations for all models.

Generate Simulation Generates simulations for the model, and stores the results in a data 

table. You can specify the random seed, number of simulations, and the number of forecast 

periods.

Set Seed Specifies the seed for generating the simulated forecast values.

Model Report

The time series modeling options are used to fit theoretical models to the series and use the 

fitted model to predict (forecast) future values of the series. These options also produce 

statistics and residuals that enable you to determine the adequacy of the model that you have 

chosen to use. You can select the modeling options multiple times. Each time you select a 

model, that model is added to the Model Comparison table. a report of the results of the fit 

and a forecast is added to the Time Series report window. When the Report checkbox next to a 

model in the Model Comparison table is selected, a report is produced for that model. The 

report specifies the model in its title.

The following reports are shown by default:

• Model Summary Table

• Parameter Estimates Table

• Forecast Plot

• Residuals

• Iteration History

Model Summary Table

The Model Summary table contains fit statistics for the model. In the formulas below, n is the 

length of the series and k is the number of fitted parameters in the model.
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DF The number of degrees of freedom in the fit, n – k.

Sum of Squared Errors The sum of the squared residuals.

Variance Estimate The unconditional sum of squares (SSE) divided by the number of 

degrees of freedom (n – k). The variance estimate is computed as SSE / (n – k). This is the 

sample estimate of the variance of the random shocks at, described in the section “ARIMA 

Model” on page 335.

Standard Deviation The square root of the variance estimate. This is a sample estimate of 

the standard deviation of the random shocks at.

Akaike’s Information Criterion [AIC] Smaller AIC values indicate better fit. AIC is 

computed as follows:

Schwarz’s Bayesian Criterion [SBC or BIC] Smaller SBC values indicate better fit. 

Schwarz’s Bayesian Criterion is equivalent to the Bayesian Information Criterion (BIC). 

SBC is computed as follows:

RSquare RSquare is computed as follows:

where

 are the one-step-ahead forecasts

 is the mean yi

If the model does not fit the series well, the model error sum of squares, SSE, might be 

larger than the total sum of squares, SST. As a result, R2 can be negative.

RSquare Adj The adjusted R2 is computed as follows:

AIC 2loglikelihood– 2k+=

SBC 2loglikelihood– k n ln+=

R
2

1 SSE
SST
---------–=

SST yi yi– 
2

i 1=

n

=

SSE yi ŷi– 
2

i 1=

n

=

ŷi

yi
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MAPE The Mean Absolute Percentage Error is computed as follows:

MAE The Mean Absolute Error is computed as follows:

–2LogLikelihood Twice the negative log-likelihood function evaluated at the best-fit 

parameter estimates. Smaller values are better fits. See the Statistical Details appendix in 

the Fitting Linear Models book.

Stable Indicates whether the autoregressive operator is stable. That is, whether all the roots 

of zlie outside the unit circle.

Invertible Indicates whether the moving average operator is invertible. That is, whether all 

the roots of z lie outside the unit circle.

Note: The  and  operators are defined in the section “ARIMA Model” on page 335.

Parameter Estimates Table

There is a Parameter Estimates table for each selected fit, which gives the estimates for the 

time series model parameters. Each type of model has its own set of parameters, which are 

described in the sections on specific time series models. Each Parameter Estimates table 

contains the following columns:

Term The name of the parameter, which are described in the sections for each model type. 

Some models contain an intercept or mean term. In those models, the related constant 

estimate is also shown. The definition of the constant estimate is given under the 

description of ARIMA models.

Factor (Shown only for multiplicative Seasonal ARIMA models.) The factor of the model 

that contains the parameter. In the multiplicative seasonal models, Factor 1 is nonseasonal 

and Factor 2 is seasonal.

Lag (Shown only for ARIMA and Seasonal ARIMA models.) The degree of the lag or 

backshift operator that is applied to the term to which the parameter is multiplied.

1
n 1– 
n k– 
----------------- 1 R

2
– –

100
n
---------

yi ŷi–

yi

---------------

i 1=

n



1
n
--- yi ŷi–

i 1=

n


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Estimate The parameter estimates of the time series model.

Std Error The estimates of the standard errors of the parameter estimates. These estimates 

are used to calculate tests and prediction intervals.

t Ratio The test statistics for the hypotheses that each parameter is zero. The test statistic for 

a parameter is the ratio of the parameter estimate to its standard error. If the hypothesis is 

true, then this statistic has an approximate Student’s t distribution. Looking for a t-ratio 

greater than 2 in absolute value is a common rule for judging significance because it 

approximates the 0.05 significance level.

Prob>|t| The observed p-value calculated for each parameter. The p-value is the probability 

of getting, by chance alone, a t-ratio greater (in absolute value) than the computed value, 

given a true hypothesis.

Constant Estimate Shown for models that contain an intercept or mean term. The 

definition of the constant estimate is given under ARIMA model.

Mu (Shown only for ARIMA and Seasonal ARIMA models.) The estimate for the intercept 

value of an ARIMA or seasonal ARIMA model.

Forecast Plot

Each model has its own Forecast plot. The Forecast plot shows both the observed and 

predicted values for the time series. The plot is divided by a vertical line into two regions. To 

the left of the vertical line, the one-step-ahead forecasts are overlaid with the observed data 

points. To the right of the vertical line are the future values forecast by the model and the 

prediction intervals for the forecast.

You can control the number of future forecast values by changing the setting of the Forecast 

Periods option in the platform launch window or by selecting Number of Forecast Periods 

from the Time Series red triangle menu.

Residuals

The graphs in the Residuals report show the values of the residuals based on the fitted model. 

These values are the observed values of the time series minus the one-step-ahead predicted 

values. The autocorrelation and partial autocorrelation reports for these residuals are also 

shown. These reports can be used to determine whether the fitted model is adequate to 

describe the data. If the fitted model is adequate, the points in the residual plot should be 

normally distributed about zero and the autocorrelation and partial autocorrelation of the 

residuals should not have any significant components for lags greater than zero.

Iteration History

The model parameter estimation is an iterative procedure by which the log-likelihood is 

maximized by adjusting the estimates of the parameters. The Iteration History report is shown 
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for each model, and it contains the value of the objective function at each iteration. This can be 

useful for diagnosing problems with the fitting procedure. Attempting to fit a model that is 

poorly suited to the data can result in a failure to converge on an optimum value for the 

likelihood. The Iteration History table contains the following quantities:

Iter The iteration number.

Iteration History The objective function value for each step.

Step The type of iteration step.

Obj-Criterion The norm of the gradient of the objective function.

Model Report Options

Each model report has a red triangle menu that contains the following options:

Show Points Shows or hides the data points in the forecast graph.

Show Prediction Interval Shows or hides the prediction intervals in the forecast graph.

Save Columns Creates a new data table that contains columns that represent the results of 

the model.

Save Prediction Formula Saves the data and prediction formula to a new data table.

Create SAS Job Creates SAS code that duplicates the model analysis in SAS.

Submit to SAS Submits SAS code to SAS that duplicates the model analysis. If you are not 

connected to a SAS server, this option guides you through the connection process.

Residual Statistics Controls the displays of residual statistics are shown for the model. 

These displays are described in the section “Time Series Platform Options” on page 304. 

However, they are applied to the series of residuals.

Transfer Function Report

Each transfer function model is added to the Model Comparison table. If the Report checkbox 

for a transfer function model in the Model Comparison table is selected, a Transfer Function 

Model report is produced. Each Transfer Function Model report contains the following 

reports:

• Model Summary

• Parameter Estimates

• Residuals
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• Interactive Forecasting

• Iteration History

The information in the Model Summary, Parameter Estimates, Residuals, and Iteration 

History reports is the same as in the Time Series report. For more information about these 

reports, see “Model Report” on page 319. The Parameter Estimates table is followed by the 

formula of the model, where B is the backshift operator.

Interactive Forecasting

The Interactive Forecasting report provides a forecasting graph based on a prediction interval 

specified in the Transfer Function Specification window. The prediction interval around the 

prediction is shown in blue. Change the confidence level for this prediction interval by 

entering a number in the Prediction Interval box above the graph.

You can drag the plus sign in the graph to change the number of forecast periods in the graph. 

In the forecast periods, you can change the input values using the Import Inputs from Table 

button or by dragging points in the input graph to different values. The results of your 

changes are reflected in the forecast periods of the output graph.

Figure 16.14  Interactive Forecasting Graph
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Spectral Density Report

Figure 16.15  Spectral Density Plots and White Noise Test Report

The White Noise Test report contains the following statistics:

Fisher’s Kappa Tests the null hypothesis that the values in the series are drawn from a 

normal distribution with variance 1 against the alternative hypothesis that the series has a 

periodic component. Kappa is the ratio of the maximum value of the periodogram, I(fi), 

and its average value.

Prob > Kappa The probability of observing a value larger than Kappa if the null hypothesis 

is true, given by the following equation:

where

q = N / 2 if N is even, q = (N - 1) / 2 if N is odd

 is the observed value of Kappa

The null hypothesis is rejected if this probability is less than the significance level .

Bartlett’s Kolmogorov-Smirnov Compares the normalized cumulative periodogram to the 

cumulative distribution function of the uniform distribution on the interval (0, 1). The test 

statistic equals the maximum absolute difference of the cumulative periodogram and the 

uniform CDF. If it exceeds , then one typically rejects the hypothesis that the series 

comes from a normal distribution. The values a = 1.36 and a = 1.63 correspond to 

significance levels 5% and 1% respectively.

Pr k   1 1– j q

j 
 
 

max 1 jk
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----– 0 
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–=
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Additional Example of the Time Series Platform

This example uses the SeriesP.jmp sample data table to show how to perform a time series 

analysis. You first create a new column that is appropriate for the Time ID.

Create Appropriate Time ID Column

1. Select Help > Sample Data Library and open Time Series/SeriesP.jmp.

The SeriesP.jmp data table contains a Year column and a Quarter column to identify the 

time period during which the responses were observed. However, the Time Series 

platform requires one column with unique, equally spaced time points to label the X axis. 

If no Time ID is specified, then the row number is used to identify the time periods. To 

avoid this and make the report easier to interpret, you construct a Time ID column from 

Year and Quarter.

2. Select Cols > New Columns. In the Column Name box, type Year.Quarter.

3. Select Column Properties > Formula.

4. Select Year and then click the plus sign.

5. Select Quarter and then click the division sign. Type in 4 and press Enter.

6. Click OK.

The completed New Column dialog box should appear as in Figure 16.16.

Figure 16.16  New Column

7. Click OK.
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Time Series Analysis

Now that the data table contains an appropriate Time ID column, proceed with the analysis.

1. Select Analyze > Specialized Modeling > Time Series.

2. Select GDP and click Y, Time Series.

3. Select Year.Quarter and click X, Time ID.

4. Click OK.

Figure 16.17  Time Series Report for SeriesP.jmp

The series shows an increasing trend over time that is fairly linear. In addition, the 

autocorrelation chart shows that there is strong correlation between points that are close 

together. The AutoCorr values for points with lags of 1, 2, and 3 are 0.9551, 0.9112, 0.8666, 

respectively.

5. Click the Time Series GDP red triangle and select Difference.

6. Select 1 for the Nonseasonal Differencing Order and click Estimate.
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Figure 16.18  Difference Report for SeriesP.jmp

The Difference report helps determine an appropriate model to be fit to the original time 

series. The plot of differences shows that the differenced series no longer has the trend 

observed in the original data. This indicates that lag-1 differencing is an appropriate 

choice. Also, even after removing the trend, the series shows no sign of seasonality. For 

these reasons, models to fit the original series should be able to handle linear trends, but 

do not necessarily need to handle seasonality. Linear exponential smoothing and ARIMA 

models would be appropriate.

7. Click the Time Series GDP red triangle and select Smoothing Model > 
Linear Exponential Smoothing.

8. Click Estimate.

9. Click the Time Series GDP red triangle and select ARIMA Model Group. This enables you to 

fit multiple ARIMA models for a range of values of (p,d,q)(P,D,Q).

10. In the ARIMA box, set the following ranges:

– Fix d, the differencing order, at 1 by setting the range from 1 to 1 because the 

differencing report showed lag-1 differencing was appropriate.
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– Set p, the autoregressive order, to range from 0 to 1 because the original series showed 

evidence of autocorrelation.

– Set q, the moving average order, to range from 0 to 1.

Note: In most cases, it is sufficient to keep p and q small.

– Leave P, D, and Q set at 0, since the series showed no evidence of seasonality.

These settings lead to the fitting of 4 total models.

Figure 16.19  ARIMA Model Group Specification

11. Click Estimate.

Figure 16.20  Model Comparison Table

The Model Comparison Table is sorted such that the best fitting model, according to the AIC 

criterion, is at the top of the list. In this case, the ARIMA(0,1,0) model (denoted I(1) in the 

report) best fits the original time series. It should also be noted that although the I(1) model is 

“best,” all of the models have extremely similar values for the fit statistics. They could all be 

considered appropriate.
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Figure 16.21  Model Report for ARIMA(0,1,0)

The model report for I(1) shows the forecast graph. The blue lines indicate the prediction 

intervals. GDP is predicted to continue increasing at a linear rate.

Statistical Details for the Time Series Platform

• “Statistical Details for Spectral Density”

• “Statistical Details for X-11 Decomposition”

• “Statistical Details for Smoothing Models”

• “Statistical Details for ARIMA Models”

• “Statistical Details for Transfer Functions”

Statistical Details for Spectral Density

The least squares estimates of the coefficients of the Fourier series are computed as follows:

at
2

N
---- yt 2fit cos

i 1=

N

=
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Then the fi = i/N are combined to form the periodogram I(fi) = (N/2)(ai
2 + bi

2), which represents 

the intensity at frequency fi.

The periodogram is then smoothed and scaled by 1/(4) to form the spectral density.

Statistical Details for X-11 Decomposition

This method adjusts the original time series using either a multiplicative or an additive 

decomposition. The model is fit using an iterative process to estimate the three X-11 

components: trend cycle, seasonal, and irregular. The trend cycle component contains both the 

long-term trend and the long-term cyclical effects. The irregular component contains the 

effects of variation unexplained by the trend and seasonal components. For a historical 

overview of the development of the X-11 method, see SAS/ETS 13.1 User’s Guide (search for 

“Historical Development of X-11”).

The multiplicative adjustment fits the following model:

where

Ot is the original time series

Ct is the trend cycle component

St is the seasonal component

It is the irregular component

The adjusted multiplicative trend is Ot /St.

The additive adjustment fits the following model:

The adjusted additive trend is Ot - St.

Statistical Details for Smoothing Models

Smoothing models are defined as follows:

where

bt
2

N
---- yt 2fit sin

i 1=

N

=

Ot Ct St It=

Ot Ct St It+ +=

yt t tt s t  at+ + +=
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t is the time-varying mean term

t is the time-varying slope term

s(t) is one of the s time-varying seasonal terms

at are the random shocks

Models without a trend have t = 0 and nonseasonal models have s(t) = 0. The estimators for 

these time-varying terms are defined as follows:

Lt is a smoothed level that estimates t

Tt is a smoothed trend that estimates t

St - j for j = 0, 1, ..., s - 1 are the estimates of the s(t)

Each smoothing model defines a set of recursive smoothing equations that describe the 

evolution of these estimators. The smoothing equations are written in terms of model 

parameters called smoothing weights:

 is the level smoothing weight

 is the trend smoothing weight

 is the trend damping weight

 is the seasonal smoothing weight

While these parameters enter each model in a different way (or not at all), they have the 

common property that larger weights give more influence to recent data while smaller 

weights give less influence to recent data.

Simple Exponential Smoothing

The model for simple exponential smoothing is yt = t + t.

The smoothing equation, Lt = yt + (1 – )Lt-1, is defined in terms of a single smoothing weight 

. This model is equivalent to an ARIMA(0, 1, 1) model where the following is true:

 where 

The moving average form of the model is defined as follows:

Double (Brown) Exponential Smoothing

The model for double exponential smoothing is yt = t + 1t + at.

1 B– yt 1 B– t=  1 –=

yt at at j–
j 1–



+=
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The smoothing equations, defined in terms of a single smoothing weight , are defined as 

follows:

This model is equivalent to an ARIMA(0, 1, 1)(0, 1, 1)1 model where the following is true:

 where  with 

The moving average form of the model is defined as follows:

Linear (Holt) Exponential Smoothing

The model for linear exponential smoothing is yt = t + tt + at.

The smoothing equations, in terms of smoothing weights  and , are defined as follows:

This model is equivalent to an ARIMA(0, 2, 2) model where the following is true:

 with  and 

The moving average form of the model is defined as follows:

Damped-Trend Linear Exponential Smoothing

The model for damped-trend linear exponential smoothing is yt = t + tt + at.

The smoothing equations, in terms of smoothing weights , , and , are defined as follows:
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2
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2
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This model is equivalent to an ARIMA(1, 1, 2) model where the following is true:

where

The moving average form of the model is defined as follows:

Seasonal Exponential Smoothing

The model for seasonal exponential smoothing is yt = t + s(t) + at.

The smoothing equations in terms of smoothing weights  and  are defined as follows:

This model is equivalent to a seasonal ARIMA(0, 1, s+1)(0, 1, 0)s model:

where

The moving average form of the model is defined as follows:

 where 
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Winters Method (Additive)

The model for the additive version of the Winters method is yt = t + tt + s(t) + at.

The smoothing equations in terms of weights , , and  are defined as follows:

This model is equivalent to a seasonal ARIMA(0, 1, s+1)(0, 1, 0)s model defined as follows:

The moving average form of the model is defined as follows:

where

Statistical Details for ARIMA Models

ARIMA Model

For a response series {yi}, the general form for the ARIMA model is as follows:

where

t is the time index

B is the backshift operator defined as Byt = yt - 1

wt = (1 - B)d yt is the response series after differencing

 is the intercept or mean term

(B) and(B) are the autoregressive operator and the moving average operator, 
respectively, and are written as follows:
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where

at are the sequence of random shocks

The at are assumed to be independent and normally distributed with mean zero and 

constant variance.

The model can be rewritten as follows:

The constant estimate  is given by the relation:

Seasonal ARIMA Model

In the case of Seasonal ARIMA modeling, the differencing, autoregressive, and moving 

average operators are the product of seasonal and nonseasonal polynomials:

where s is the number of observations per period. The first index on the coefficients is the 

factor number (1 indicates nonseasonal, 2 indicates seasonal) and the second is the lag of the 

term.

Statistical Details for Transfer Functions

A typical transfer function model with m inputs can be represented as follows:

where

Yt denotes the output series
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X1 to Xm denote m input series

et represents the noise series

X1, t–d1 indicates the series X1 is indexed by t with a d1-step lag

 represents the mean level of the model

(B) and (B) represent autoregressive and moving average polynomials from an ARIMA 
model

k(B) and k(B) represent numerator and denominator factors (or polynomials) for 

individual transfer functions, with k representing an index for the 1 to m individual inputs.

Each polynomial in the above model can contain two parts, either nonseasonal, seasonal, or a 

product of the two as in seasonal ARIMA. When specifying a model, leave the default 0 for 

any part that you do not want to include in the model.
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Chapter 17
Matched Pairs Analysis

Compare Measurements on the Same Subject

The Matched Pairs platform compares the means between two or more correlated variables 

and assesses the differences. For example, you might compare a blood pressure measurement 

taken on the same subject before a treatment and again after the treatment. A statistical 

method called the paired t-test takes the correlated responses into account.

The platform produces a graph of the paired differences by the paired means, and the paired 

t-test results for all three alternative hypotheses. Additional features provide for more than 

two matched responses and for a grouping column to test across samples, in a simple version 

of repeated measures analysis.

Figure 17.1  Example of Matched Pairs Analysis
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Overview of the Matched Pairs Platform

The Matched Pairs platform compares row-by-row differences between two response 

columns using a paired t-test. Often, the two columns represent measurements on the same 

subject before and after some treatment. Alternatively, the measurements could represent data 

taken on the same subject with two different instruments.

If you have paired data arranged in two data table columns, then you are ready to use the 

Matched Pairs platform. However, if all of your measurements are in a single column, then 

perform one of the following tasks:

• Use the Split option in the Tables menu to split the column of measurements into two 

columns. Then you can use the Matched Pairs platform.

• For two response columns, create a third column that calculates the difference between the 

two responses. Then test that the mean of the difference column is zero with the 

Distribution platform.

• For the two responses stored in a single column, you can do a two-way analysis of 

variance. One factor (the ID variable) identifies the two responses and the other factor 

identifies the subject. Use the Fit Y by X Oneway platform with a blocking variable (the 

subject column), or use the Fit Model platform to do a two-way ANOVA. The test on the 

ID factor is equivalent to the paired t-test.

Note: If the data are paired, do not do a regular independent t-test. Do not stack the data into 

one column and use the Fit Y by X One-way ANOVA on the ID without specifying a block 

variable. To do this has the effect of ignoring the correlation between the responses. This 

causes the test to overestimate the effect if responses are negatively correlated, or to 

underestimate the effect if responses are positively correlated.

Example of Comparing Matched Pairs

This example uses the Therm.jmp sample data table. The data contains temperature 

measurements on 20 people. Temperature is measured using two types of thermometers: oral 

and tympanic (ear). You want to determine whether the two types of thermometers produce 

equal temperature readings. Note that the differences in temperature between the different 

people are not important. The matched pairs analysis is testing the differences between the 

thermometers.

1. Select Help > Sample Data Library and open Therm.jmp.

2. Select Analyze > Specialized Modeling > Matched Pairs.

3. Select Oral and Tympanic and click Y, Paired Response.
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4. Click OK.

The report window appears.

Figure 17.2  The Matched Pairs Report Window

The results show that, on average, the tympanic thermometer measures 1.12 degrees higher 

than the oral thermometer. The small p-value (Prob > |t|) indicates that this difference is 

statistically significant, and not due to chance.

Note that this matched pairs analysis does not indicate which thermometer is correct (if 

either), but only indicates that there is a difference between the thermometers.

Launch the Matched Pairs Platform

Launch the Matched Pairs platform by selecting Analyze > Specialized Modeling > Matched 
Pairs.
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Figure 17.3  The Matched Pairs Launch Window

Y, Paired Response Provide the two response columns. For information about analyzing 

more than two responses, see “Multiple Y Columns” on page 343.

X, Grouping Provide a grouping variable to compare the differences across groups. For 

more information, see “Across Groups” on page 345.

Weight Identifies one column whose numeric values assign a weight to each row in the 

analysis.

Freq Identifies one column whose numeric values assign a frequency to each row in the 

analysis.

By Performs a separate matched pairs analysis for each level of the By variable.

For more information about the launch window, see the Get Started chapter in the Using JMP 

book.

After you click OK, the Matched Pairs report window appears. See “The Matched Pairs 

Report” on page 344.

Multiple Y Columns

You can have more than two responses. If the number of responses is odd, all possible pairs 

are analyzed. The following table shows an example for three responses.

If the number of responses is even, the Matched Pairs platform asks whether you want to do 

all possible pairs. If you do not do all possible pairs, adjacent responses are analyzed as a pair. 

The following table shows the arrangement of analyses for four responses.

Y1 by Y2 Y1 by Y3

Y2 by Y3
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The Matched Pairs Report

Follow the instructions in “Example of Comparing Matched Pairs” on page 341 to produce the 

report window shown in Figure 17.4.

The Matched Pairs report shows a Tukey mean-difference plot, summary statistics, and the 

results of the paired t-test. See “Difference Plot and Report” on page 345. If you specified an X, 
Grouping variable, the report also includes the Across Groups report. See “Across Groups” on 

page 345.

Figure 17.4  Example of Matched Pairs Report

Note: The red triangle menu provides additional options that can add reports to the initial 

report window. See “Matched Pairs Platform Options” on page 345.

Y1 by Y2 Y3 by Y4
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Difference Plot and Report

The Difference plot shows differences by means. In the Difference plot, note the following:

• The mean difference is shown as the horizontal line, with the 95% confidence interval 

above and below shown as dotted lines. If the confidence region includes zero, then the 

means are not significantly different at the 0.05 level. In this example the difference is 

significant.

• If you add a reference frame, the mean of pairs is shown by the vertical line. For details 

about a reference frame, see “Matched Pairs Platform Options” on page 345.

The Difference report shows the mean of each response, the difference of the means, and a 

confidence interval for the difference. The Difference report also shows the results of the 

paired t-test.

Across Groups

Note: The Across Groups report appears only if you have specified an X, Grouping variable.

The Across Groups analysis corresponds to a simple repeated measures analysis. (You can get 

the same test results using the Manova personality of the Fit Model platform.)

Mean Difference Shows the mean of the difference across rows in each group between the 

two paired columns. In other words, this is the within-subject by across-subject 

interaction, or split-plot by whole-plot interaction.

Mean Mean Shows the mean of the mean across rows in each group across the two paired 

columns. In other words, this is the across-subject or whole-plot effect.

Test Across Groups Two F-tests determine whether the across-groups values are different:

Mean Difference Tests that the change across the pair of responses is different in 

different groups.

Mean Mean Tests that the average response for a subject is different in different groups

Related Information

• “Example Comparing Matched Pairs across Groups” on page 347

Matched Pairs Platform Options

The Matched Pairs red triangle menu contains the following options:
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Plot Dif by Mean Shows or hides the plot of the paired differences by paired means. For a 

detailed description of this plot, see “Difference Plot and Report” on page 345.

Plot Dif by Row Shows or hides the plot of paired differences by row number.

Reference Frame Shows or hides the reference frame on the Plot Dif by Mean plot. A 

rectangle showing where a plot of Y2 by Y1 would be located inside the plot, tilted and 

possibly squished. A vertical red line is shown representing the mean of means. The 

reference frame is shown initially when the range of the differences is greater than half the 

range of the data.

Wilcoxon Signed Rank Shows or hides the Wilcoxon signed rank test. The Wilcoxon signed 

rank test is applied to the paired differences. It is a nonparametric test that compares the 

sizes of the positive differences to the sizes of the negative differences. The test uses the 

Pratt method to address zero differences. The test also assumes that the distribution of 

differences is symmetric. For details, see the Distributions chapter in the Basic Analysis 

book. See also Lehman (2006), Conover (1999, p. 350), and Cureton (1967).

Sign Test Shows or hides the sign test. This is a nonparametric version of the paired t-test 

that uses only the sign (positive or negative) of the difference for the test.

Set  Level Changes the alpha level used in the analyses. Affects the confidence intervals in 

the report and on the plot.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.
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Example Comparing Matched Pairs across Groups

This example uses the Dogs.jmp sample data table. This example shows you how to produce 

both a Matched Pairs Across Groups report and the corresponding MANOVA report using Fit 

Model.

1. Select Help > Sample Data Library and open Dogs.jmp.

2. Select Analyze > Specialized Modeling > Matched Pairs.

3. Select LogHist0 and LogHist1 and click Y, Paired Response.

4. Select drug and click X, Grouping.

5. Click OK.

The report on the left in Figure 17.5 appears.

Now produce the Fit Model report using the same data table.

1. Select Analyze > Fit Model.

2. Select LogHist0 and LogHist1 and click Y.

3. Select drug and click Add.

4. Select the Manova personality.

5. Click Run Model.

6. In the Response Specification report, select Repeated Measures from the Choose 
Response menu.

7. Click OK.
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Figure 17.5  Examples of Matched Pairs Across Groups and Fit Model MANOVA with 
Repeated Measures

The F Ratio for the Mean Difference in the Across Groups report corresponds to the F Ratio for 

Time*drug under the Within Subjects report. The F Ratio for the Mean Mean in the Across 

Groups report corresponds to the F Ratio for drug under Between Subjects in the Manova Fit 

report.

Statistical Details for the Matched Pairs Platform

• “Graphics for Matched Pairs”

• “Correlation of Responses”

Graphics for Matched Pairs

The primary graph in the platform is a Tukey mean-difference (Cleveland 1994, p. 130), which 

plots the difference of the two responses on the vertical axis against the mean of the two 

responses on the horizontal axis. This graph is the same as a scatterplot of the two original 



Chapter 17 Matched Pairs Analysis 349
Predictive and Specialized Modeling Statistical Details for the Matched Pairs Platform

variables, but turned 45 degrees. A 45 degree rotation and rescaling turns the original 

coordinates into a difference and a mean.

Figure 17.6  Example of Transforming to Difference by Mean, Rotated by 45 Degrees

Correlation of Responses

In most cases where the pair of measurements is taken from the same individual at different 

times, they are positively correlated. However, if they represent competing responses, the 

correlation can be negative.

Figure 17.7 shows how the positive correlation of the two responses becomes the small 

variance on the difference (the vertical axis). If the correlation is negative, the ellipse is 

oriented in the other direction and the variance of the rotated graph is large on the vertical 

axis.
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Figure 17.7  Examples of Positive Correlation Before and After Rotation
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Chapter 18
Response Screening

Test Many Responses in Large-Scale Data

The analysis of large-scale data sets, where hundreds or thousands of measurements are taken 

on a part or an organism, requires innovative approaches. But testing many responses for the 

effects of factors can be challenging, if not misleading, without appropriate methodology.

Response Screening automates the process of conducting tests across a large number of 

responses. Your test results and summary statistics are presented in data tables, rather than 

reports, to enable data exploration. A False-Discovery Rate approach guards against incorrect 

declarations of significance. Plots of p-values are scaled using the LogWorth, making them 

easily interpretable.

Because large scale data sets are often messy, Response Screening presents methods that 

address irregularly distributed and missing data. A robust estimate method allows outliers to 

remain in the data, but reduces the sensitivity of tests to these outliers. Missing data options 

allow missing values to be included in the analysis. These features enable you to analyze your 

data without first conducting an extensive analysis of data quality.

When you have many observations, even differences that are of no practical interest can be 

statistically significant. Response Screening presents tests of practical difference, where you 

specify the difference that you are interested in detecting. On the other hand, you might want 

to know whether differences do not exceed a given magnitude, that is, if the means are 

equivalent. For this purpose, Response Screening presents equivalence tests.

Figure 18.1  Example of a Response Screening Plot
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Overview of the Response Screening Platform

Response Screening automates the process of conducting tests across a large number of 

responses. It tests each response that you specify against each factor that you specify. 

Response screening addresses two main issues connected with large-scale data. These are the 

need to conduct many tests, and the requirement to deal effectively with outliers and missing 

values.

Response screening is available as a platform and as a Fit Model personality. In both cases, it 

performs tests analogous to those found in the Fit Y by X platform, as shown in Table 18.1. As 

a personality, it performs tests of the response against the individual model effects.

To facilitate and support the multiple inferences that are required, Response Screening 

provides these features:

Data Tables Results are shown in data tables, as well as in a report, to enable you to 

explore, sort, search, and plot your results. Statistics that facilitate plot interpretation are 

provided, such as the LogWorth of p-values.

False Discovery Rates Because you are conducting a large number of tests, you need to 

control the overall rate of declaring tests significant by chance alone. Response screening 

controls the false discovery rate. The False Discovery Rate (FDR) is the expected proportion 

of significant tests that are incorrectly declared significant (Benjamini and Hochberg 1995; 

Westfall et al. 2011).

Tests of Practical Significance When you have many observations, even small effects that 

are of no practical consequence can result in statistical significance. To address this issue, 

you can define an effect size that you consider to be of practical significance. You then 

conduct tests of practical significance, thereby only detecting effects large enough to be of 

pragmatic interest.

Equivalence Tests When you are studying many factors, you are often interested in those 

that have essentially equivalent effects on the response. In this case, you can specify an 

effect size that defines practical equivalence and then conduct equivalence tests.

To address issues that arise when dealing with messy data, Response Screening provides 

features to deal with outliers and missing data. These features enable you to analyze your data 

directly, without expending effort to address data quality issues:

Robust Estimation Outliers in your data increase estimates of standard error, causing tests 

to be insensitive to real effects. Select the Robust option to conduct Huber M-estimation. 

Outliers remain in the data, but the sensitivity of tests to these outliers is reduced.

Missing Value Options The platform contains an option to treat missing values on 

categorical predictors in an informative fashion.
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The Response Screening platform generates a report and a data table: the Response Screening 

report and the PValues table. The Response Screening personality generates a report and two 

data tables: the Fit Response Screening report, the PValues table, and the Y Fits table.

The JSL command Summarize Y by X performs the same function as the Response Screening 

platform but without creating a platform window. See Summarize YByX in the JSL Syntax 

Reference book for details.

Example of Response Screening

The Probe.jmp sample data table contains 387 characteristics (the Responses column group) 

measured on 5800 wafers. The Lot ID and Wafer Number columns uniquely identify the wafer. 

You are interested in which of the characteristics show different values across a process 

change (Process).

1. Select Help > Sample Data Library and open Probe.jmp.

2. Select Analyze > Screening > Response Screening.

The Response Screening launch window appears.

3. Select the Responses column group and click Y, Response.

4. Select Process and click X.

5. Enter 100 in the MaxLogWorth box.

A log worth of 100 or larger corresponds to an extremely small p-value. Setting a value for 

the MaxLogWorth helps control the scale of plots.

6. Click OK.

The Response Screening report appears, along with a data table of supporting information. 

The report (Figure 18.2) shows the FDR PValue Plot, but also contains two other plot reports. 

The table contains a row for each of the 387 columns that you entered as Y, Response.

Table 18.1  Analyses Performed by Response Screening

Response Factor Fit Y by X Analysis Description

Continuous Categorical Oneway Analysis of Variance

Continuous Continuous Bivariate Simple Linear Regression

Categorical Categorical Contingency Chi-Square

Categorical Continuous Logistic Simple Logistic Regression
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The FDR PValue Plot shows two types of p-values, FDR PValue and PValue, for each of the 387 

tests. These are plotted against Rank Fraction. PValue is the usual p-value for the test of a Y 

against Process. The FDR PValue is a p-value that is adjusted to guarantee a given false 

discover rate (FDR), here 0.05. The FDR PValues are plotted in blue and the PValues are 

plotted in red. The Rank Fraction ranks the FDR p-values from smallest to largest, in order of 

decreasing significance.

Both the horizontal blue line and the sloped red line on the plot are thresholds for FDR 

significance. Tests with FDR p-values that fall below the blue line are significant at the 0.05 

level when adjusted for the false discovery rate. Tests with ordinary p-values that fall below 

the red line are significant at the 0.05 level when adjusted for the false discovery rate. In this 

way, the plot enables you to read FDR significance from either set of p-values.

Figure 18.2  Response Screening Report for 387 Tests against Process

The FDR PValue Plot shows that more than 60% of the tests are significant. A handful of tests 

are significant using the usual p-value, but not significant using the FDR p-value. These tests 

correspond to the red points that are above the red line, but below the blue line.
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To identify the characteristics that are significantly different across Process, you can drag a 

rectangle around the appropriate points in the plot. This selects the rows corresponding to 

these points in the PValues table, where the names of the characteristics are given in the first 

column. Alternatively, you can select the corresponding rows in the PValues table.

The PValues data table (Figure 18.3) contains 387 rows, one for each response measure in the 

Responses group. The response is given in the first column, called Y. Each response is tested 

against the effect in the X column, namely, Process.

Figure 18.3  PValues Data Table, Partial View

The remaining columns give information about the test of Y against X. Here the test is a 

Oneway Analysis of Variance. In addition to other information, the table gives the test’s 

p-value, LogWorth, FDR (False Discovery Rate) p-value, and FDR LogWorth. Use this table to 

sort by the various statistics, select rows, or plot quantities of interest.

Notice that LogWorth and FDR LogWorth values that correspond to p-values of 1e-100 or less 

are reported as 100, because you set MaxLogWorth to 100 in the launch window. Also, cells 

corresponding to FDR LogWorth values greater than two are colored with an intensity 

gradient.

See “The Response Screening Report” on page 359 for details about the report and PValues 

table.
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Launch the Response Screening Platform

Launch the Response Screening platform by selecting Analyze > Screening > Response 
Screening.

Figure 18.4  Response Screening Launch Window

Launch Window Roles

Y, Response Identifies the response columns containing the measurements to be analyzed.

X Identifies the columns against which you want to test the responses.

Grouping For each level of the specified column, analyzes the corresponding rows 

separately, but presents the results in a single table and report.

Weight Identifies a column whose values assign a weight to each row. These values are used 

as weights in the analysis. For details, see the Weight section in the Model Specification 

chapter in the Fitting Linear Models book.

Freq Identifies a column whose values assign a frequency to each row. These values enable 

you to account for pre-summarized data. For details, see the Frequency section in the 

Model Specification chapter in the Fitting Linear Models book.
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By For each level of the specified column, analyzes the corresponding Ys and Xs and 

presents the results in separate tables and reports.

Launch Window Options

Robust For continuous responses, uses robust (Huber) estimation to down weight outliers. 

If there are no outliers, these estimates are close to the least squares estimates. Note that 

this option increases processing time.

Cauchy Assumes that the errors have a Cauchy distribution. A Cauchy distribution has 

fatter tails than the normal distribution, resulting in a reduced emphasis on outliers. This 

option can be useful if you have a large proportion of outliers in your data. However, if 

your data are close to normal with only a few outliers, this option can lead to incorrect 

inferences. The Cauchy option estimates parameters using maximum likelihood and a 

Cauchy link function.

Poisson Y Fits each Y response as a count having a Poisson distribution. The test is only 

performed for categorical X. This option is appropriate when your responses are counts.

Kappa Adds a new column called Kappa to the data table. If Y and X are both categorical 

and have the same levels, kappa is provided. This is a measure of agreement between Y 

and X.

Corr The Corr option computes the Pearson product-moment correlation in terms of the 

indices defined by the value ordering.

If X and Y are both binary, the Pearson product-moment calculation gives Spearman’s rho 

and Kendallʹs Tau-b. Otherwise, a value of Corr that is large in magnitude indicates an 

association; a Corr value that is small in magnitude does not preclude an association.

Same Y Scale Aligns all the Y responses to the same scale when you run individual 

analyses using the report’s Fit Selected Items options.

Missing is category For any categorical X variable, treats missing values on X as a category.

Force X Categorical Ignores the modeling type and treats all X columns as categorical.

Force X Continuous Ignores the modeling type and treats all X columns as continuous.

Force Y Categorical Ignores the modeling type and treats all Y columns as categorical.

Force Y Continuous Ignores the modeling type and treats all Y columns as continuous.

Paired X and Y Performs tests only for Y columns paired with X columns according to their 

order in the Y, Response and X lists. The first Y is paired with the first X, the second Y with 

the second X, and so on.
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Unthreaded Suppresses multithreading.

Practical Difference Portion The fraction of the specification range, or of an estimated six 

standard deviation range, that represents a difference that you consider pragmatically 

meaningful. If Spec Limits is not set as a column property, a range of six standard 

deviations is estimated for the response. The standard deviation estimate is computed 

from the interquartile range (IQR), as .

If no Practical Difference Proportion is specified, its value defaults to 0.10. Tests of 

practical significance and equivalence tests use this difference to determine the practical 

difference. See “Compare Means Data Table” on page 368.

MaxLogWorth Use to control the scale of plots involving LogWorth values (-log10 of 

p-values). LogWorth values that exceed MaxLogWorth are plotted as MaxLogWorth to 

prevent extreme scales in LogWorth plots. See “Example of the MaxLogWorth Option” on 

page 376 for an example.

OK Conducts the analysis and displays the results.

Cancel Closes the launch window.

Remove Removes the selected variable from the assigned role.

Recall Populates the launch window with the previous model specification that you ran.

Help Opens the Help topics for the Response Screening launch window.

The Response Screening Report

The Response Screening report consists of several Graph Builder plots. These plots focus on 

False Discovery Rate (FDR) statistics. For details, see “The False Discovery Rate” on page 383.

The default plots are the FDR PValue Plot, the FDR LogWorth by Effect Size, and the FDR 

LogWorth by RSquare. If you select the Robust option on the launch window, Robust versions 

of each of these reports are also presented. In addition, a Robust LogWorth by LogWorth plot 

is presented to help assess the impact of using the robust fit. The standard Graph Builder red 

triangle options for each plot are available. For details, see the Graph Builder chapter in the 

Essential Graphing book.

FDR PValue Plot

The FDR PValue Plot report shows a plot of FDR PValues and PValues against the Rank 

Fraction. The Rank Fraction ranks the PValues in order of decreasing significance. FDR 

PValues are plotted in blue and PValues in red.

̂ IQR  1.3489795 =
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A blue horizontal line shows the 0.05 significance level. Note that you can change this level by 

double-clicking the vertical axis, removing the current reference line, and adding a new 

reference line.

A red increasing line provides an FDR threshold for unadjusted p-values. A p-value falls 

below the red line precisely when the FDR-adjusted p-value falls below the blue line. This 

enables you to read significance relative to the FDR from either the adjusted or unadjusted 

p-values.

Figure 18.5 shows the FDR PValue Plot for the Probe.jmp sample data table. Note that some 

tests are significant according to the usual p-value but not according to the FDR p-value.

Figure 18.5  FDR PValue Plot

FDR LogWorth by Effect Size

When you have large effects, the associated p-values are often very small. Visualizing these 

small values graphically can be challenging. When transformed to the LogWorth 

(-log10(p-value)) scale, highly significant p-values have large LogWorths and nonsignificant 
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p-values have low LogWorths. A LogWorth of zero corresponds to a nonsignificant p-value of 

1. Any LogWorth above 2 corresponds to a p-value below 0.01.

In the FDR LogWorth by Effect Size plot, the vertical axis is the FDR LogWorth and the 

horizontal axis is the Effect Size. Generally, larger effects lead to more significant p-values and 

larger LogWorths. However, this relationship is not necessarily strong because significance 

also depends on the error variance. In fact, large LogWorths can be associated with small 

effects, and small LogWorths can be associated with large effects, because of the size of the 

error variance. The FDR LogWorth by Effect Size plot enables you to explore this relationship.

Figure 18.6 shows the FDR LogWorth by Effect size plot for the Probe.jmp sample data table 

with MaxLogWorth set to 100. Most FDR LogWorth values exceed 2, which indicates that most 

effects are significant at the 0.01 level. The FDR LogWorth values of 100 correspond to 

extremely small p-values.

Figure 18.6  FDR LogWorth by Effect Size

FDR LogWorth by RSquare

The FDR LogWorth by RSquare plot shows the FDR LogWorth on the vertical axis and 

RSquare values on the horizontal axis. Larger LogWorth values tend to be associated with 

larger RSquare values, but this relationship also depends on the number of observations.
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The PValues Data Table

The PValues data table contains a row for each pair of Y and X variables. If you specified a 

column for Group, the PValues data table contains a first column called Group. A row appears 

for each level of the Group column and for each pair of Y and X variables. The PValues data 

table also contains a table variable called Original Data that gives the name of the data table 

that was used for the analysis. If you specified a By variable, JMP creates a PValues table for 

each level of the By variable, and the Original Data variable gives the By variable and its level.

Figure 18.7 shows the PValues data table created in “Example of Response Screening” on 

page 354.

Figure 18.7  PValues Data Table, Partial View

PValues Data Table Columns

The PValues data table displays columns containing measures and statistics that are 

appropriate for the selected fit and combination of Y and X modeling types. The columns in 

the data table include:

Y The specified response columns.

X The specified factor columns.

Count The number of rows used for testing, or the corresponding sum of the Freq or Weight 

variable.
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PValue The p-value for the significance test corresponding to the pair of Y and X variables. 

For details about Fit Y by X statistics, see the Introduction to Fit Y by X chapter of the Basic 

Analysis book.

LogWorth The quantity -log10(p-value). This transformation adjusts p-values to provide an 

appropriate scale for graphing. A value that exceeds 2 is significant at the 0.01 level 

(because -log10(0.01) = 2).

FDR PValue The False Discovery Rate p-value calculated using the Benjamini-Hochberg 

technique. This technique adjusts the p-values to control the false discovery rate for 

multiple tests. If there is no Group variable, the set of multiple tests includes all tests 

displayed in the table. If there is a Group variable, the set of multiple tests consists of all 

tests conducted for each level of the Group variable. For details about the FDR correction, 

see Benjamini and Hochberg (1995). For details about the false discovery rate, see “The 

False Discovery Rate” on page 383.

FDR LogWorth The quantity -log10(FDR PValue). This is the best statistic for plotting and 

assessing significance. Note that small p-values result in high FDR LogWorth values. Cells 

corresponding to FDR LogWorth values greater than two (p-values less than 0.01) are 

colored with an intensity gradient.

Effect Size Indicates the extent to which response values differ across the levels or values of 

X. Effect sizes are scale invariant.

– When Y is continuous, the effect size is the square root of the average sum of squares 

for the hypothesis divided by a robust estimate of the response standard deviation. If 

the interquartile range (IQR) is nonzero, the standard deviation estimate is 

IQR/1.3489795. If the IQR is zero, the sample standard deviation is used.

– When Y is categorical and X is continuous, the effect size is the square root of the 

average ChiSquare value for the whole model test.

– When Y and X are both categorical, the effect size is the square root of the average 

Pearson ChiSquare.

Rank Fraction The rank of the FDR LogWorth expressed as a fraction of the number of tests. 

If the number of tests is m, the largest FDR LogWorth value has Rank Fraction 1/m, and the 

smallest has Rank Fraction 1. Equivalently, the Rank Fraction ranks the p-values in 

increasing order, as a fraction of the number of tests. The Rank Fraction is used in plotting 

the PValues and FDR PValues in rank order of decreasing significance.

YMean The mean of Y.

SSE Appears when Y is continuous. The sum of squares for error.

DFE Appears when Y is continuous. The degrees of freedom for error.
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MSE Appears when Y is continuous. The mean squared error.

F Ratio Appears when Y is continuous. The F Ratio for the analysis of variance or regression 

test.

RSquare Appears when Y is continuous. The coefficient of determination, which measures 

the proportion of total variation explained by the model.

Intercept Appears when Y and X are both continuous. The intercept of the regression model 

relating the corresponding pair of Y and X variables.

Slope Appears when Y and X are both continuous. The slope of the regression model 

relating the corresponding pair of Y and X variables.

DF Appears when Y and X are both categorical. The degrees of freedom for the ChiSquare 

test.

LR Chisq Appears when Y and X are both categorical. The value of the Likelihood Ratio 

ChiSquare statistic.

Columns Added for Robust Option

If you suspect that your data contains outliers, select the Robust option on the launch window 

to reduce the sensitivity of tests for continuous responses to outliers. With this option, Huber 

M-estimates (Huber and Ronchetti 2009) are used in fitting regression and ANOVA models. 

Huber M-estimates are fairly close to least squares estimates when there are no outliers, but 

use outlier-downweighting when there are outliers.

The following columns are added to the PValues data table when the Robust option is selected 

in the launch window. The Robust option only applies when Y is continuous, so Robust 

column cells are empty when Y is categorical. See the Bivariate chapter in the Basic Analysis 

book for additional details about Huber M-estimation. For an example, see “Example of 

Robust Fit” on page 378.

Robust PValue The p-value for the significance test corresponding to the pair of Y and X 

variables using a robust.

Robust LogWorth The quantity -log10(Robust PValue).

Robust FDR PValue The False Discovery Rate calculated for the Robust PValues using the 

Benjamini-Hochberg technique. If there is no Group variable, the multiple test adjustment 

applies to all tests displayed in the table. If there is a Group variable, the multiple test 

adjustment applies to all tests conducted for each level of the Group variable.

Robust FDR LogWorth The quantity -log10(Robust FDR PValue).
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Robust Rank Fraction The rank of the Robust FDR LogWorth expressed as a fraction of the 

number of tests.

Robust Chisq The chi-square value associated with the robust test.

Robust Sigma The robust estimate of the error standard deviation.

Robust Outlier Portion The portion of the values whose distance from the robust mean 

exceeds three times the Robust Sigma.

Robust CpuTime Time in seconds required to create the Robust report.

PValues Data Table Scripts

Relevant scripts are saved to the PValues data table. All but one of these reproduce plots 

provided in the report. When you select rows in the PValues table, the Fit Selected script 

produces the appropriate Fit Y by X analyses.

Response Screening Platform Options

The Response Screening red triangle menu contains options to customize the display and to 

compute and save calculated data.

Fit Selected Items For selected relationships, adds the appropriate Fit Y by X reports to the 

Response Screening report. You can select relationships by selecting rows in the PValue 

data table or points in the plots.

Select Columns Selects the columns in the original data table that correspond to rows that 

you select in the PValues table or to points that you select in plots in the Response 

Screening report window. Select the rows or points first, then select Select Columns. The 

corresponding columns in the data table are selected. You can select columns 

corresponding to additional rows in the PValues table or points in plots by first selecting 

them and then selecting Select Columns again. To select columns corresponding to 

different rows or points, first clear the current column selection in the original data table.

Save Means For continuous Ys and categorical Xs, creates a data table with the counts, 

means, and standard deviations for each level of the categorical variable. If the Robust 

option is selected, the robust mean is included.

Save Compare Means For continuous Ys and categorical Xs, tests all pairwise comparisons 

across the levels of the categorical variable. For each comparison, the data table gives the 

usual t-test, a test of practical significance, an equivalence test, and a column that uses 

color coding to summarize the results. The data table also contains a script that plots 
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Practical LogWorth by Relative Practical Difference. See “Compare Means Data Table” on 

page 368. For an example, see “Example of Tests of Practical Significance and 

Equivalence” on page 374.

Save Std Residuals Saves a new group of columns to the original data table and places 

these in a column group call Residual Group. For each continuous Y and categorical X, a 

column is constructed containing the residuals divided by their estimated standard 

deviation. In other words, the column contains standardized residuals. The column is 

defined by a formula.

If the Robust option is selected, standardized residual columns are constructed using 

robust fits and robust estimates.

Save Outlier Indicator Saves a new group of columns to the original data table and places 

these in a column group call Outlier Group. Save Outlier Indicator is most effective when 

you have selected the Robust option.

For each continuous Y and categorical X, a column that indicates outliers is constructed. 

An outlier is a point whose distance to the predicted value exceeds three times an estimate 

of sigma. In other words, an outlier is a point whose standardized residual exceeds three. 

The column is defined by a formula.

If the Robust option is selected, robust fits and robust estimates are used. An outlier is a 

point whose distance to the predicted value exceeds three times the robust estimate of 

sigma.

The Cluster Outliers script is added to the original data table. The script shows outliers on 

a hierarchical cluster plot of the data.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.
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Means Data Table

The Means data table contains a row for each combination of response and X level. For the 

Probe.jmp sample data table, there are 387 response variables, each tested against Process at 

two levels. The Means table contains 387x2 = 774 rows (Figure 18.8).

Figure 18.8  Means Data Table

The Means data table includes the following columns:

Y The continuous response variables.

X The categorical variables.

Level The level of the categorical X variable.

Count The count of values in the corresponding Level.

Mean The mean of the Y variable for the specified Level.

StdDev The standard deviation of the Y variable for the specified Level.

Robust Mean The robust M-estimate of the mean. Appears when you select the Robust 

option on the launch window.
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Compare Means Data Table

When your data table consists of a large number of rows (large n), the standard error used in 

testing can be very small. As a result, tests might be statistically significant, when in fact, the 

observed difference is too small to be of practical consequence. Tests of practical significance 

enable you to specify the size of the difference that you consider worth detecting. This 

difference is called the practical difference. Instead of testing that the difference is zero, you test 

whether the difference exceeds the practical difference. As a result, the tests are more 

meaningful, and fewer tests need to be scrutinized.

Equivalence tests enable you to determine whether two levels have essentially the same effect, 

from a practical perspective, on the response. In other words, an equivalence test tests 

whether the difference is smaller than the practical difference.

The Compare Means data table provides results for both tests of practical difference and tests 

of practical equivalence. Each row compares a response across two levels of a categorical 

factor. Results of the pairwise comparisons are color-coded to facilitate interpretation. See 

“Practical Difference” on page 369 for a description of how the practical difference is 

specified. See “Example of Tests of Practical Significance and Equivalence” on page 374 for an 

example.

Figure 18.9  Compare Means Data Table

The Compare Means data table contains a script that plots Practical LogWorth by Relative 

Practical Difference. Relative Practical Difference is defined as the actual difference divided by 

the practical difference.

Y The continuous response variables.

X The categorical variables.

Leveli The level of the categorical X variable.

Levelj The level of the categorical X variable being compared to Leveli.



Chapter 18 Response Screening 369
Predictive and Specialized Modeling Response Screening Platform Options

Difference The estimated difference in means across the two levels. If the Robust option is 

selected, robust estimates of the means are used.

Std Err Diff The standard error of the difference in means. This is a robust estimate if the 

Robust option is selected.

Plain Dif PValue The p-value for the usual Studentʹs t-test for a pairwise comparison. This is 

the robust version of the t-test when the Robust option is selected. Tests that are significant 

at the 0.05 level are highlighted.

Practical Difference The difference in means that is considered to be of practical interest. If 

you assign a Spec Limit property to the Y variable, the practical difference is computed as 

the difference between the specification limits multiplied by the Practical Difference 

Proportion. If no Practical Difference Proportion has been specified, the Practical 

Difference is the difference between the specification limits multiplied by 0.10.

If you do not assign a Spec Limit property to the Y variable, an estimate of its standard 
deviation is computed from its interquartile range (IQR). This estimate is 

. The Practical Difference is computed as  multiplied by the 

Practical Difference Proportion. If no Practical Difference Proportion has been specified, 

the Practical Difference is computed as  multiplied by 0.10.

Practical Dif PValue The p-value for a test of whether the absolute value of the mean 

difference in Y between Leveli and Levelj is less than or equal to the Practical Difference. A 

small p-value indicates that the absolute difference exceeds the Practical Difference. This 

indicates that Leveli and Levelj account for a difference that is of practical consequence.

Practical Equiv PValue Uses the Two One-Sided Tests (TOST) method to test for a practical 

difference between the means (Schuirmann 1987). The Practical Difference specifies a 

threshold difference for which smaller differences are considered practically equivalent. 

One-sided t tests are constructed for two null hypotheses: the true difference exceeds the 

Practical Difference; the true difference is less than the negative of the Practical Difference. 

If both tests reject, this indicates that the absolute difference in the means falls within the 

Practical Difference. Therefore, the groups are considered practically equivalent.

The Practical Equivalence PValue is the largest p-value obtained on the one-sided t tests. A 

small Practical Equiv PValue indicates that the mean response for Leveli is equivalent, in a 

practical sense, to the mean for Levelj.

Practical Result A description of the results of the tests for practical difference and 

equivalence. Values are color-coded to help identify significant results.

– Different (Pink): Indicates that the absolute difference is significantly greater than the 

practical difference.

̂ IQR  1.3489795 = 6̂

6̂
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– Equivalent (Green): Indicates that the absolute difference is significantly within the 

practical difference.

– Inconclusive (Gray): Indicates that neither the test for practical difference nor the test 

for practical equivalence is significant.

The Response Screening Personality in Fit Model

If you are interested in univariate tests against linear model effects, you can fit the Response 

Screening personality in Fit Model. The report and tables produced test all responses against 

all model effects.

• “Launch Response Screening in Fit Model”

• “The Fit Response Screening Report”

• “PValues Data Table”

• “Y Fits Data Table”

Launch Response Screening in Fit Model

Select Analyze > Fit Model. Enter your Ys and model effects. Select Response Screening from 

the Personality list (Figure 18.10).

Figure 18.10  Response Screening from the Fit Model Window
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Note that a Robust Fit check box is available. Selecting this option enables robust estimation 

for tests involving continuous responses. These tests use robust (Huber) estimation to down 

weight outliers. If there are no outliers, these estimates are close to the least squares estimates. 

Selecting this option increases processing time.

The Informative Missing option provides a coding system for missing values (Figure 18.11). 

The Informative Missing coding allows estimation of a predictive model despite the presence 

of missing values. It is useful in situations where missing data are informative. Select this 

option from the Model Specification red triangle menu.

Figure 18.11  Informative Missing Option

For details about the Fit Model window, see the Model Specification chapter in the Fitting 

Linear Models book.

The Fit Response Screening Report

The Fit Response Screening report shows two plots:

• The FDR PValue Plot

• The FDR LogWorth by Rank Fraction Plot

The FDR PValue Plot is interpreted in the same way as for the platform itself. See“The 

Response Screening Report” on page 359.

The FDR LogWorth by Rank Fraction plot shows FDR LogWorth values plotted against the 

ranks of the p-values. The plotted points decrease or remain constant as rank fraction 

increases. The plot gives an indication of what proportion of tests are significant. An example 
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using the Response Screening personality is given in “Response Screening Personality” on 

page 382.

Model Dialog Opens a window containing the model dialog that you have run to obtain the 

given report.

Save Estimates Opens a data table in which each row corresponds to a response and the 

columns correspond to the model terms. The entries are the parameter estimates obtained 

by fitting the specified model. This data table also contains a table variable called Original 

Data that gives the name of the data table that was used for the analysis. If you specified a 

By variable, JMP creates an estimates table for each level of the By variable, and the 

Original Data variable gives the By variable and its level.

Save Prediction Formula Adds columns to the original data table containing prediction 

equations for all responses.

Save Least Squares Means Opens a data table where each row corresponds to a response 

and a combination of effect settings. The row contains the least squares mean and 

standard error for that combination of settings.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

PValues Data Table

The PValues data table contains a row for each pair consisting of a Y variable and a model 

Effect. The columns in the table include the following. If you select the Robust Fit option on 

the launch window, the models are fit using Huber M-estimation.

Y The specified response columns.

Effect The specified model effects.
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FRatio The test statistic for a test of the Effect. This is the value found in the Effect Tests 

report in Least Squares Fit.

PValue The p-value for the significance test corresponding to the FRatio. See the Standard 

Least Squares chapter in the Fitting Linear Models book for additional details about Effect 

Tests.

LogWorth The quantity -log10(p-value). This transformation adjusts p-values to provide an 

appropriate scale for graphing. A value that exceeds 2 is significant at the 0.01 level 

(because -log10(0.01) = 2).

FDR PValue The False Discovery Rate p-value calculated using the Benjamini-Hochberg 

technique. This technique adjusts the p-values to control the false discovery rate for 

multiple tests. For details about the FDR correction, see Benjamini and Hochberg (1995). 

For details about the false discovery rate, see “The False Discovery Rate” on page 383 or 

Westfall et al. (2011).

FDR LogWorth The quantity -log10(FDR PValue). This is the best statistic for plotting and 

assessing significance. Note that small p-values result in high FDR LogWorth values.

Rank Fraction The rank of the FDR LogWorth expressed as a fraction of the number of tests. 

If the number of tests is m, the largest FDR LogWorth value has Rank Fraction 1/m, and the 

smallest has Rank Fraction 1. Equivalently, the Rank Fraction ranks the p-values in 

increasing order, as a fraction of the number of tests. The Rank Fraction is used in plotting 

the PValues and FDR PValues in rank order of decreasing significance.

Test DF The degrees of freedom for the effect test.

The PValues data table also contains a table variable called Original Data that gives the name 

of the data table that was used for the analysis. If you specified a By variable, JMP creates a 

PValues table for each level of the By variable, and the Original Data variable gives the By 

variable and its level.

Y Fits Data Table

The Y Fits data table contains a row for Y variable. For each Y, the columns in the table 

summarize information about the model fit. If you select the Robust Fit option on the launch 

window, the models are fit using Huber M-estimation.

Y The specified response columns.

RSquare The multiple correlation coefficient.

RMSE The Root Mean Square Error.

Count The number of observations (or sum of the Weight variable).
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Overall FRatio The test statistic for model fit from the Analysis of Variance report in Least 

Squares Fit.

Overall PValue The p-value for the overall test of model significance.

Overall LogWorth The LogWorth of the p-value for the overall test of model significance.

Overall FDR PValue The overall p-value adjusted for the false discovery rate. (See “The 

Response Screening Report” on page 359.)

Overall FDR LogWorth The LogWorth of the Overall FDR PValue.

Overall Rank Fraction The rank of the Overall FDR LogWorth expressed as a fraction of the 

number of tests. If the number of tests is m, the largest Overall FDR LogWorth value has 

Rank Fraction 1/m, and the smallest has Rank Fraction 1.

<Effect> PValue These columns contain p-values for tests of each model effect. These 

columns are arranged in a group called PValue in the columns panel.

<Effect> LogWorth These columns contain LogWorths for the p-values for tests of each 

model effect. These columns are arranged in a group called LogWorth in the columns 

panel.

<Effect> FDR LogWorth These columns contain FDR LogWorths for tests of each model 

effect. These columns are arranged in a group called FDR LogWorth in the columns panel.

The Y Fits data table also contains a table variable called Original Data that gives the name 

of the data table that was used for the analysis. If you specified a By variable, JMP creates a 

Y Fits table for each level of the By variable, and the Original Data variable gives the By 

variable and its level.

Additional Examples of Response Screening

• “Example of Tests of Practical Significance and Equivalence”

• “Example of the MaxLogWorth Option”

• “Example of Robust Fit”

• “Response Screening Personality”

Example of Tests of Practical Significance and Equivalence

This example tests for practical differences using the Probe.jmp sample data table.

1. Select Help > Sample Data Library and open Probe.jmp.
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2. Select Analyze > Screening > Response Screening.

The Response Screening Launch window appears.

3. Select the Responses column group and click Y, Response.

4. Select Process and click X.

5. Type 0.15 in the Practical Difference Portion box.

6. Click OK.

7. From the Response Screening report’s red triangle menu, select Save Compare Means.

Figure 18.12 shows a portion of the data table. For each response in Y, the corresponding 

row gives information about tests of the New and the Old levels of Process.

Figure 18.12  Compare Means Table, Partial View

Because specification limits are not saved as column properties in Probe.jmp, JMP 

calculates a value of the practical difference for each response. The practical difference of 

0.15 that you specified is multiplied by an estimate of the 6 range of the response. This 

value is used in testing for practical difference and equivalence. It is shown in the Practical 
Difference column.

The Plain Difference column shows responses whose p-values indicate significance. The 

Practical Diff PValue and Practical Equiv PValue columns give the p-values for tests of 

practical difference and practical equivalence. Note that many columns show statistically 

significant differences, but do not show practically significant differences.

8. Display the Compare Means data table and select Analyze > Distribution.
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9. Select Practical Result and click Y, Columns.

10. Click OK.

Figure 18.13 shows the distribution of results for practical significance. Only 37 tests are 

different, as determined by testing for the specified practical difference. For 5 of the 

responses, the tests were inconclusive. You cannot tell whether the responses result in a 

practical difference across Process.

Figure 18.13  Distribution of Practical Significance Results

The 37 responses can be selected for further study by clicking on the corresponding bar in the 

plot.

Example of the MaxLogWorth Option

When data sets have a large number of observations, p-values can be very small. LogWorth 

values provide a useful way to study p-values graphically in these cases. But sometimes 

p-values are so small that the LogWorth scale is distorted by huge values.

1. Select Help > Sample Data Library and open Probe.jmp.

2. Select Analyze > Screening > Response Screening.

3. In the Response Screening Launch window, select the Responses column group and click 

Y, Response.

4. Select Process and click X.

5. Select the Robust check box.
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6. Click OK.

The analysis is numerically intensive and may take some time to complete.

7. In the Response Screening report, open the Robust FDR LogWorth by Effect Size report.

The detail in the plot is hard to see, because of the huge Robust FDR LogWorth value of 

about 58,000 (Figure 18.14). To ensure that your graphs show sufficient detail, you can set 

a maximum value of the LogWorth.

Figure 18.14  Robust FDR LogWorth vs. Effect Size, MaxLogWorth Not Set

8. Repeat step 1 through step 5.

9. Type 1000 in the MaxLogWorth box at the bottom of the launch window.

10. Click OK.

The analysis may take some time to complete.

11. In the Response Screening report, open the Robust FDR LogWorth by Effect Size report.

Now the detail in the plot is apparent (Figure 18.15).
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Figure 18.15  Robust FDR LogWorth vs. Effect Size, MaxLogWorth = 1000

Example of Robust Fit

1. Open the Drosophila Aging.jmp table.

2. Select Analyze > Screening > Response Screening.

3. Select all of the continuous columns and click Y, Response.

4. Select line and click X.

5. Check Robust.

6. Click OK.

The Robust FDR PValue Plot is shown in Figure 18.16. Note that a number of tests are 

significant using the unadjusted robust p-values, as indicated by the red points that are 

less than 0.05. However, only two tests are significant according to the robust FDR 

p-values.
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Figure 18.16  Robust FDR PValue Plot for Drosophila Data

These two points are more easily identified in a plot that shows FDR LogWorths.

7. Click the Robust FDR LogWorth by Effect Size disclosure icon.

8. Drag a rectangle around the two points with Robust FDR LogWorth values that exceed 1.5.

9. In the PValues data table, select Rows > Label/Unlabel.

The plot shown in Figure 18.17 appears. Points above the red line at 2 have significance 

levels below 0.01. A horizontal line at about 1.3 corresponds to a 0.05 significance level.
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Figure 18.17  Robust LogWorth by Effect Size for Drosophila Data

10. Click the Robust LogWorth by LogWorth disclosure icon.

The plot shown in Figure 18.18. If the robust test for a response were identical to the usual 

test, its corresponding point would fall on the diagonal line in Figure 18.18. The circled 

point in the plot does not fall near the line, because it has a Robust LogWorth value that 

exceeds its LogWorth value.
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Figure 18.18  Robust LogWorth by LogWorth for Drosophila Data

11. Drag a rectangle around this point in the plot.

12. Find the row for this point in the PValues data table.

Note that the response, log2in_CG8237 has PValue 0.9568 and Robust PValue 0.0176.

13. In the Response screening report, select Fit Selected Items from the red triangle menu.

A Fit Selected Items report is displayed containing a Oneway Analysis for the response 

log2in_CG8237. The plot shows two outliers for the ORE line (Figure 18.19). These outliers 

indicate why the robust test and the usual test give disparate results. The outliers inflate 

the error variance for the non-robust test, which makes it more difficult to see a significant 

effect. In contrast, the robust fit down-weights these outliers, thereby reducing their 

contribution to the error variance.
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Figure 18.19  Oneway Analysis for log2in_CG8237

Response Screening Personality

The Response Screening personality in Fit Model allows you to study tests of multiple 

responses against linear model effects. This example analyses a model with two main effects 

and an interaction.

1. Open the Drosophila Aging.jmp table.

2. Select Analyze > Fit Model.

3. Select all the continuous columns and click Y.

4. Select channel and click Add.

5. Select sex, line, and age and select Macros > Full Factorial.

6. Select Response Screening from the Personality list.

7. Click Run.

The Fit Response Screening report appears. Two data tables are also presented: Y Fits 

summarizes the overall model tests, and PValues tests the individual effects in the model 

for each Y.

To get a general idea of which effects are important, do the following:

8. Run the FDR LogWorth by Rank Fraction script in the PValues data table.

9. Select Rows > Data Filter.

10. In the Data Filter window, select Effect and click Add.

11. In the Data Filter, click through the list of the model effects, while you view the selected 

points in the FDR LogWorth by Rank Fraction plot.
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Keep in mind that values of LogWorth that exceed 2 are significant at the 0.01 level. The 

Data Filter helps you see that, with the exception of sex and channel, the model effects are 

rarely significant at the 0.01 level. Figure 18.20 shows a reference line at 2. The points for 

tests of the line*age interaction effect are selected. None of these are significant at the 0.01 

level.

Figure 18.20  FDR LogWorth vs Rank Fraction Plot with line*age Tests Selected

Statistical Details for the Response Screening 
Platform

The False Discovery Rate

All of the Response Screening plots involve p-values for tests conducted using the FDR 

technique described in Benjamini and Hochberg (1995). See also Westfall et al. (2011). This 

method assumes that the p-values are independent and uniformly distributed.

JMP uses the following procedure to control the false discovery rate at level :

1. Conduct the m hypothesis tests of interest to obtain p-values p1, p2, ..., pm.

2. Rank the p-values from smallest to largest. Denote these by .p 1  p 2   ... p m  
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3. Find the largest p-value for which . Suppose this first p-value is the kth 

largest, p(k).

4. Reject the k hypotheses associated with p-values less than or equal to p(k).

This procedure ensures that the expected false discovery rate does not exceed .

The p-values adjusted for the false discovery rate, denoted p(i), FDR, are computed as:

If a hypothesis has an FDR-adjusted p-value that falls below , then it is rejected by the 

procedure.

p i  i m 

p i  FDR

p m                                                for i m=

min p i 1+  FDR
m
i
---- 
  p i                         for i m 1–  1 =
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




=



Chapter 19
Process Screening

Screen Many Processes for Stability and Capability

Use the Process Screening platform for exploring a large number of processes across time. The 

platform calculates process stability and process capability metrics. The platform creates 

control charts and detects large process shifts. The platform is intended to expedite the 

evaluation of a very large number of processes by enabling you to quickly focus on the 

processes that are unstable, not capable of meeting specification limits, or subject to shifts in 

the mean.

Based on your initial results, you can choose to explore specific processes graphically or in 

greater analytical depth. You can easily access the Control Chart Builder and Process 

Capability platforms. You can save detailed results for all of your processes or for specific 

processes.

Figure 19.1  Example of a Process Performance Graph
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Overview of the Process Screening Platform

The Process Screening platform facilitates the task of assessing data from a large number of 

processes for stability and capability. The results are largely based on control chart 

calculations to determine when a process is out of control. The Process Screening platform 

enables you to do the following:

• Specify a constant subgroup size or use a variable containing subgroup identifiers for 

control chart calculations using subgroups.

• Use grouping variables. For each combination of values of the group variables, an analysis 

is provided for each process variable.

• Use medians to make your centerline and sigma calculations robust to outliers.

• Obtain information about the location of large shifts in the mean of your processes.

You can customize the Summary report to show specific control chart tests, including tests for 

changes in process mean and spread. The report also provides capability information when 

you supply specification limits. The Process Performance Graph gives you a visual 

representation of the performance of your processes in terms of stability and capability. The 

Shift Graph shows locations of upshifts and downshifts.

Tip: For information about adding specification limits, see the Column Info Window chapter 

in the Using JMP book.

Process Screening makes it easy to select specific processes for further analysis. The platform 

provides small run charts for these processes - the size of the plots makes it easy for you to 

view a substantial number at a time. You can also link to Control Chart Builder and the 

Process Capability platform for analyses of select processes.

You can save data tables containing results in various forms, either for your entire set of 

processes or only for select processes.

Example of Process Screening

The Semiconductor Capability.jmp sample data table contains 128 columns of process 

measurements. Each column contains 1,455 measurements. You are interested in identifying 

unstable processes. Also, each column contains a Spec Limits column property. If a process is 

stable, it is appropriate to calculate its process capability. You proceed to assess both stability 

and capability for this data table.

1. Select Help > Sample Data Library and open Semiconductor Capability.jmp.

2. Select Analyze > Screening > Process Screening.
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3. Select the Processes column group and click Process Variables.

Notice that the Control Chart Type is set to Indiv and MR.

4. Click OK.

Figure 19.2  Partial View of Initial Report

The Process Screening window appears, showing a table of results for each process. The 

table is sorted by Stability Ratio. This is a measure of the stability of a process, where a 

stable process has a stability ratio near 1. Higher values of the stability ratio indicate a less 

stable process. (The sorting is indicated by the caret beside Stability Ratio in the report.) 

You want to take a closer look at processes with a stability ratio greater than 1.05.

5. In the report window, select processes PMS1 through NPN9.

Each of these first 10 processes has a value of 1.05 or larger in the Stability Ratio column.

6. Right-click the selected processes and select Quick Graph for Selected Items.

Figure 19.3  Quick Graphs for Highest Alarm Rate Processes
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You decide to take a closer look at IVP8 (row 3, column 1 in the Graphs of Selected Items).

7. Select the second process in the Summary table, which corresponds to IVP8.

8. Right-click the selected process and select Control Charts for Selected Items.

Figure 19.4  Control Chart Builder Report for IVP8

A Control Chart Builder report appears. Because IVP8 has a Spec Limits column property, 

the report also includes a capability analysis.
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Launch the Process Screening Platform

Launch the Process Screening platform by selecting Analyze > Screening > Process Screening.

Figure 19.5  Response Screening Launch Window

Launch Window Roles

Process Variables The columns of process data containing the measurements to be 

analyzed. The columns must have a Numeric data type. If a process variable has a Control 

Limits column property, the Process Screening platform uses those limits to calculate the 

Derived Sigma.

Grouping Columns assigned as grouping variables. Each process variable is analyzed at 

each combination of levels of the grouping variables. The results are presented in a single 

report.

Subgroup A column whose values assign a subgroup identifier to each row. The process 

data are sorted by the Subgroup variable before calculations are performed.

Note: The process data are not sorted by the Subgroup variable if the control chart type is 

Indiv and MR.
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Time A numeric column whose values are used for the time order for the data. Use the Time 

role for data that are time-stamped. The time stamp is used for the time axis in quick 

graphs and shift graphs. The process data are sorted by the Time variable before 

calculations are performed.

By A column whose levels define separate analyses. For each level of the specified column, 

the corresponding rows are analyzed using the other variables that you have specified. 

The results are presented in separate tables and reports. If more than one By variable is 

assigned, a separate analysis is produced for each possible combination of the levels of the 

By variables.

Launch Window Options

Control Chart Type Select one of five control chart types: Indiv and MR (Individual 

Measurement and Moving Range); XBar and R; XBar and S; XBar, MR, and R; or XBar, MR, 

and S. The XBar, MR, and R control chart and the XBar, MR, and S control chart are also 

referred to as 3-way charts. For more information about statistical details, see the Control 

Chart Builder chapter in the Quality and Process Methods book.

Note: The 3-way charts are available only when the subgroup sizes are bigger than 1. If a 

3-way chart is selected and the subgroup sizes are 1, an error message appears.

Subgroup Sample Size Specify a constant sample size for subgroups. The minimum 

subgroup size is 2. A subgroup size of 5 is the default. The Subgroup Sample Size 

specification is ignored for Indiv and MR charts or when a subgroup variable is specified.

Shift Threshold Specify a value that controls the sensitivity of the Shift Graph. Shift 

Threshold is set to three by default. After outlier removal, the Shift Graph shows a plot of 

the time occurrence of all process shifts that exceed the number of within-sigma units 

specified by the Shift Threshold. See “Shift Graph” on page 401.

Outlier Threshold Specify a value that controls the sensitivity of outlier removal for 

detection of large recent shifts and for the Shift Graph. Outlier Threshold is set to five by 

default. If the number of within sigma units from an observation to both of its neighboring 

observations exceeds the specified Outlier Threshold, that observation is replaced with a 

value that is one within-sigma unit away from its closest neighboring observation. See 

“Shift Magnitudes and Positions” on page 398.

Shift Lambda Enables you to change the exponentially weighted moving average (EWMA) 

weight used in the Shift Graph. See “Shift Magnitudes and Positions” on page 398.

Drift Beta The weight used in the exponentially weighted moving average (EWMA) for 

drift detection. Drift Beta is set to 0.05 by default.
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Minimum Process Length The minimum number of data values that a process must have 

in order to be included in the analysis. By default, this value is set to 3.

Use Limits Table Enables you to import historical control limits and specification limits 

from a data table. When you select this option and click OK in the launch window, a 

Choose limits table window appears. Once you choose a limits tables and click OK, a 

Limits Specification window appears. Assign columns in your limits table to appropriate 

roles and click OK. For details. See “Limits Table” on page 392.

Note: If you do not select this option, limits are obtained from the Control Limit and 

Specification Limit column properties for the Process Variables.

Use Medians instead of Means Estimates the center line using the median of the 

observations. Sigma is estimated using scaling factors obtained using Monte Carlo 

simulation. The table of factors is given in “Statistical Details for the Process Screening 

Platform” on page 406. The calculation depends on the type of chart selected:

– For XBar and R chart or Indiv and MR chart calculations, sigma is estimated using the 

scaled median of the ranges.

– For XBar and S chart calculations, sigma is estimated using the scaled median of the 

standard deviations.

– For unequal subgroup sizes, the scaling factor corresponds to the average subgroup 

size rounded to the nearest integer.

When one or more outliers influence the location of the center line, many subgroups can 

appear out of control. Using the median alleviates this problem.

Note: When Use Medians instead of Means is selected, the results obtained from the 

Control Charts for Selected Items or the Process Capability for Selected Items red triangle 

menu options do not match the Process Screening results. These platforms have no 

method that uses the median instead of the mean.

Limits Table

A Limits Table contains a row for each process defined by the Process Variables and Grouping 

variables in your table of process data. When you use a Limits Table, the Limits Specifications 

window enables you to specify variables with the roles listed below. You do not need to 

specify variables for all of these roles. All of these roles are optional.
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Figure 19.6  Limits Specifications Window

Columns in the Limits Table that have appropriate names or names that match the role 

buttons are auto-filled. For example, any column called “Process”, “Column”, or “Parameter” 

is auto-filled into the Process Variables list.

If you have control limits but do not have columns for Center or Sigma, then you can use the 

Derived Sigma options.

Process Variables A column that contains values corresponding to the column names in 

your table of process data.

Grouping One or more columns that contain the values of the grouping variables for your 

table of process data.

Center A column containing values for the center line for each process. This is usually the 

historical process mean.

Sigma A column containing values for the within standard deviation for each process. This 

is usually the historical standard deviation.

Derived Sigma Calculates sigma based on the given control limits and subgroup size. The 

derived sigma is calculated as follows:



394 Process Screening Chapter 19
The Process Screening Report Predictive and Specialized Modeling

Sigma = d*(UCL - LCL)/6

where d is the square root of the subgroup size.

LCL A column containing the lower control limits for each process.

UCL A column containing the upper control limits for each process.

Subgroup Size A column containing the subgroup size for each process.

LSL A column containing lower specification limits for each process.

USL A column containing upper specification limits for each process.

Target A column containing a target value for each process.

Importance A column containing an importance value for each process. The Importance 

column provides a mechanism to sort processes in the order that you prefer.

The Process Screening Report

The Process Screening report opens with a Summary table that contains results about process 

stability. There is a label above the summary table that shows the type of control chart on 

which the results are based. The summary table also contains capability results if you have 

provided specification limits. The processes and groups are initially sorted in decreasing 

order by Stability Ratio. If Importance values are specified by the user, the processes and 

groups are sorted in decreasing order by Stability Ratio within Importance.

Tip: To sort the report by a column, click on the column name. A caret appears to the right of 

the column name. The direction of the caret indicates whether the sorting is descending or 

ascending. To change the order of the sorting, click on the column name again.

The control chart calculations in the Summary table include Nelson tests and a Range Limit 

Exceeded test. These tests assume the following about the control chart limits:

• The center line for the XBar or X control charts is given by the mean of all measurements. If 

you use the Medians instead of Means option, the center line is given by the median of the 

observations.

• Control limits are placed at three sigma units from the center line.

• Sigma is estimated using the conventions that correspond to the control chart type that 

you specified or, if you use Medians instead of Means, as described in “Use Medians 

instead of Means” on page 392.
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Tip: The eight Nelson tests in the Process Screening platform follow the test settings in the 

Control Chart Builder platform preferences. You can customize the tests at File > Preferences > 

Platforms > Control Chart Builder.

The Summary table can contain the following information:

Column The columns that you entered as Process. There is a row for each distinct 

combination of Process and Grouping columns. This column is suppressed if there is only 

one process column.

Tip: To access options that operate on selected items, right-click the Column column.

Grouping Columns There is a report column for each column in the data table that you 

entered as Grouping. The levels of the Grouping columns are listed so that there is a 

unique row in the report table for each distinct combination of Process name and 

Grouping columns values.

Importance (Appears only when there are importance values specified by the user, as 

inputs from a limits table.) The user-specified importance value for the processes.

Variability Contains the following columns:

Stability Ratio A measure of stability of the process. A stable process has stability ratio 

near one. Higher values indicate less stability. The stability ratio is defined as follows:

If a 3-way chart is selected in the launch, the stability ratio is defined as follows:

Within Sigma An estimate of the standard deviation based on within subgroup 

variation. The estimate is based on the control chart type that you specified, and is a 

short-term measure of variation. See the Process Capability chapter in the Quality and 

Process Methods book for statistical details. If you select Medians instead of Means, 

Within Sigma is computed as described in “Use Medians instead of Means” on 

page 392.

Overall Sigma The usual estimate of standard deviation based on all observations.

Between Sigma (Appears only when 3-way chart is selected in the launch window.) An 

estimate of the standard deviation based on the variation between subgroups. See the 

Process Capability chapter in the Quality and Process Methods book for statistical details.

Overall Sigma Within Sigma 2

Overall Sigma Between-and-Within Sigma 2
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Between-and-Within Sigma (Appears only when 3-way chart is selected in the launch 

window.) An estimate of the standard deviation based on the variation between 

subgroups and the variation within subgroups. The Between-and-Within Sigma 

estimate is defined as follows:

Specified Sigma The standard deviation specified by a sigma control limit in the Limits 

Specification dialog or an estimate of the standard deviation derived from the control 

limits and subgroup size. See “Derived Sigma” on page 393. The control limits and 

subgroup size can be specified using a limits table or a Control Limits column property.

Summary Contains the following columns:

Centerline (Appears if you do one of the following: select Use Medians instead of Means 

in the launch window, import a Center value using a limits table, or import control 

limits to derive sigma.) The value listed under Centerline is used in control chart 

calculations as the center line.

– If you select Use Medians instead of Means in the launch window, the overall median 

of the observations is displayed.

– If you import a Center value from a limits table, that value is displayed.

– If you import control limits, the value displayed is calculated as (UCL + LCL)/2.

Mean The average of all observations.

Count The number of observations.

Subgroups The number of subgroups.

Control Chart Alarms Contains information about the subgroups that result in alarms for a 

variety of tests, including each of the 8 Western Electric rules. In the descriptions below, for 

an Indiv and MR chart, the single measurement is considered a subgroup of size 1. The 

standard deviation estimate is the Within Sigma value. By default, only the Alarm Rate, 

Test 1, and Latest Alarm columns are shown in the Summary table.

Alarm Rate The number of subgroups that resulted in alarms for any of the tests 

selected under the Choose Test option (Any Alarm) divided by the number of 

subgroups (Subgroups).

Any Alarm (Appears only when more than one Test column is shown.) The number of 

subgroups that trigger alarms for any of the tests selected under the Choose Test 

option. These are the eight Nelson tests and the test for Range Limit Exceeded.

Between-and-Within Sigma Within Sigma
2

Between Sigma
2

+=
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Tip: The eight Nelson tests in the Process Screening platform follow the test settings in the 

Control Chart Builder platform preferences. You can customize the tests at File > 

Preferences > Platforms > Control Chart Builder.

Test 1 One point is more than three standard deviations from the center line. The 

subgroup associated with that point triggers the alarm.

Test 2 Nine or more consecutive points are on the same side of the center line. The 

subgroup associated with the ninth point triggers the alarm.

Test 3 Six or more consecutive points are continually increasing or decreasing. The 

subgroup associated with the sixth point triggers the alarm.

Test 4 Fourteen consecutive points alternate in direction: increasing and then decreasing 

or decreasing and then increasing. The subgroup associated with the 14th point 

triggers the alarm.

Test 5 Two out of three consecutive points on the same side of the center line are more 

than two standard deviations from the center line. The subgroup associated with the 

second point that exceeds two standard deviations triggers the alarm.

Test 6 Four out of five consecutive points on the same side of the center line are more 

than one standard deviation from the center line. The subgroup associated with the 

fourth point that exceeds one standard deviation triggers the alarm.

Test 7 Fifteen consecutive points, on either side of the center line, are all within one 

standard deviation of the center line. The subgroup associated with the 15th point 

triggers the alarm.

Test 8 Eight consecutive points, on either side of the center line, all fall beyond one 

standard deviation of the center line. The subgroup associated with the eighth point 

triggers the alarm.

Range Limit Exceeded The number of subgroups that exceed the upper control limit 

on the R, S, or MR chart calculation.

Moving Range Limit Exceeded The number of subgroups that exceed the moving 

range limit on the 3-way chart calculation.

Latest Alarm The position of the subgroup, counting from the last subgroup, that 

signaled the most recent alarm for any of the Nelson or Range Limit Exceeded tests.

Capability (Appears only when there are Spec Limits specified for some processes.) 

Contains the following options:

Out of Spec Count The number of observations that fall outside the specification limits.
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Out of Spec Rate The proportion of observations that fall outside the specification 

limits.

Latest Out of Spec The number of observations, counting from the last observation to 

the most recent observation that falls outside the specification limits.

Cpk Capability index based on Within Sigma or Between-and-Within Sigma and 

assuming a normal distribution. See the Process Capability chapter in the Quality and 

Process Methods book for statistical details.

Ppk Capability index based on Overall Sigma and assuming a normal distribution. See 

the Process Capability chapter in the Quality and Process Methods book for statistical 

details.

(Mean-Tgt)/SpecRange The spec centered mean. This is the same as the Mean Shift 

Standardized to Spec in Process Capability. See the Process Capability chapter in the 

Quality and Process Methods book for statistical details.

StdDev/SpecRange The spec scaled standard deviation. This is the same as the Std 

Deviation Standardized to Spec in Process Capability. See the Process Capability 

chapter in the Quality and Process Methods book for statistical details.

Shift Magnitudes and Positions (Shown only if you have selected a Shift Detection option 

from the Process Screening red triangle menu.) Shift detection is performed to identify 

shifts that exceed one within-sigma unit. The algorithm uses outlier-correction and an 

EWMA smoothing approach for the individual observations.

– Outliers are removed so that single outliers do not indicate shifts. The value specified 

as Outlier Threshold (five by default) on the launch window controls the sensitivity of 

outlier removal. If the number of within-sigma units from an observation to both of its 

neighboring observations exceeds the specified Outlier Threshold, that observation is 

replaced with a value that is one within-sigma unit away from its closest neighboring 

observation.

– An EWMA fit is constructed for the subgroup means in forward time order and 

another EWMA fit is constructed for the subgroup means in reverse time order. The 

EWMA fits have lambda equal to 0.3.

– The largest positive and negative differences between successive EWMA values that 

exceed one within-sigma unit are identified.

– The absolute values of these differences, divided by the within estimate of sigma, are 

the values reported as Largest Upshift and Largest Downshift.

– The locations of the first subgroups involved in these largest shifts define the Upshift 

Position and Downshift Position.
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Largest Upshift The magnitude of the largest upward shift that exceeds one 

within-sigma unit, reported in within-sigma units.

Upshift Position or Upshift <Time Variable> The position of the subgroup having the 

largest Upshift. If you specify a Time variable, the column in the Summary table is 

named Upshift <Time Variable> and the position of the shift is given in terms of the 

Time variable.

Largest Downshift The magnitude of the largest downward shift that exceeds one 

within-sigma unit, reported in within-sigma units.

Downshift Position or Downshift <Time Variable> The position of the subgroup 

having the largest Downshift. If you specify a Time variable, the column in the 

Summary table is named Downshift <Time Variable> and the position of the shift is 

given in terms of the Time variable.

Process Screening Platform Options

The Process Screening red triangle menu contains options to customize the display and to 

save calculated statistics. The options that operate on selected items are also accessible by 

right-clicking the Column column in the Summary table.

Summary Shows or hides the Summary table. See “The Process Screening Report” on 

page 394.

Find and Select Enter search strings for columns that you entered as Process Variables or 

Grouping in the launch window. A panel appears for each column. The corresponding 

processes are selected in the Summary table.

Select Where Opens the Select Where window. You can select specific processes in the 

Summary table that correspond to a particular condition by using the Comparison menu 

and Value text box. For example, you can select all processes such that Ppk < 1.33. After 

you click OK, the processes are selected in the Summary table.

Tip: You can also access the Select Where window by right-clicking anywhere in the 

Summary table.

Quick Graph for Selected Items Plots small graphs of the processes that you select in the 

Summary table in a Graphs of Selected Items report. The report makes it possible to view 

and compare many processes at once. The plots are ordered according to their order of 

entry on the launch window. Each quick graph also has lines for the spec limits. There is a 

solid blue line for the target value and dotted blue lines for the LSL and USL values. To 
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remove the quick graphs, click the Graphs of Selected Items red triangle and select 

Remove.

Tip: To change the layout of the quick graphs, click the Graphs of Selected Items red 

triangle and select Number of Plots Across.

Control Charts for Selected Items Opens a Control Chart Builder report window for the 

processes that you selected in the Summary table. The control chart corresponds to your 

selections in the Process Screening launch window.

Process Capability for Selected Items Opens a Process Capability report window 

showing Individual Detail Reports for the processes that you select in the Summary table. 

If you select a process for which specification limits are not specified, a Spec Limits 

window appears. In this window, you can specify specification limits by selecting a data 

table or entering values directly.

The Process Capability analysis assumes normal distributions and uses within sigma 

values that correspond to your Control Chart Type selection in the Process Screening 

launch window:

– Moving range for Indiv and MR

– Average of ranges for XBar and R

– Average of unbiased standard deviations for XBar and S

Note: If you specify sigma using a sigma control limit or the Derived Sigma option in the 

Limits Specifications window, this value is not used in Process Capability. This is because 

the Process Screening and Process Capability platforms use these control limits differently.

Color Selected Items Applies a color of your choosing to the values in the selected rows of 

the Summary table.

Remove Selected Items Removes the rows selected in the Summary table and reruns the 

analysis without those processes.

Show Tests Shows or hides test results for Nelson tests that are selected under the Choose 

Tests option in the Process Screening report’s summary table.

Choose Tests Enables you to choose the tests that you want to include in the calculation of 

Alarm Rate and Any Alarm.

Tip: To select multiple tests, press the Alt key and click the Process Screening red triangle 

to open a menu of all platform options.
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Shift Detection Provides options for detecting shifts after outlier removal. See “Shift 

Magnitudes and Positions” on page 398.

Largest Upshift Adds columns for Largest Upshift and Upshift Position to the 

Summary table. The largest upward shift in the series that exceeds one within-sigma 

unit is identified. See “Shift Magnitudes and Positions” on page 398.

Largest Downshift Adds columns for Largest Downshift and Downshift Position to the 

Summary table. The largest downward shift in the series that exceeds one within-sigma 

unit is identified. See “Shift Magnitudes and Positions” on page 398.

Shift Graph (Available only when some processes have shifts that exceed the Shift 

Threshold.) Shows a plot of the time occurrence of all process shifts that exceed the 

number of within-sigma units specified by the Shift Threshold (three by default). You 

can also change the Shift Threshold by using the slider bar on the Shift Graph. Position 

your pointer over the diamond to see the value. Green markers indicate upshifts and 

red markers indicate downshifts. The markers are located at the local peaks of the 

shifts.

To identify the processes that correspond to one or more shift occurrences, select the 

points and click Select Process. The corresponding processes are selected in the 

Summary table. Processes that have no shifts exceeding the Shift Threshold number of 

within-sigma units are not plotted.

Note: The Shift Graph does not show the positions of Largest Upshift and Largest 

Downshift values that appear in the Summary table if the shifts are less than the specified 

Shift Threshold number of within-sigma units in magnitude. See “Additional Example of 

Process Screening” on page 404.

Show Shifts in Quick Graphs (Available only when a Quick Graph has been added to 

the report window.) Shows the location of the shifts in the Quick Graphs using green 

and red vertical lines.

Drift Summaries Adds columns for Mean Up Drift, Mean Down Drift, and Mean Abs 

Drift to the Summary Table.

Drift Graph Selected Displays a drift graph for each process that you select in the 

Summary Table. Drift graphs enable you to detect smaller, more gradual changes in the 

selected processes. The values plotted are the slope estimates from a Holt 

Double-Exponential Smoother.

Process Performance Graph Shows a four-quadrant graph that assesses the performance 

of processes in terms of stability and capability. Each process for which specification limits 

are provided is represented by a point. If you define importance values for the processes, 

an open circle marker is displayed for processes with importance values greater than the 
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75% quantile of all importance values. Its horizontal coordinate equals the stability ratio of 

the process and its vertical coordinate equals the capability of the process, given as Ppk. 

The graph is divided into four quadrants based on the following default boundaries:

– A stability ratio that exceeds 1.5 indicates that the process is unstable.

– A Ppk that is smaller than 1.33 indicates that the process is not capable.

Selecting points in the graph selects the corresponding processes in the Summary table.

Process Performance Graph Boundaries (Available only once the Process Performance 

Graph is in the report window.) Opens a window where you can set values for the Process 

Performance Graph’s stability ratio and Ppk capability boundaries.

Tip: You can set preferences for your desired boundaries for Stability Ratio and Ppk 

Capability in File > Preferences > Platforms > Process Screening.

Goal Plot (Available only when specification limits are defined.) The Goal Plot shows, for 

each variable, the spec-normalized mean shift on the X axis, and the spec-normalized 

standard deviation on the Y axis. It is useful for getting a quick, summary view of how the 

variables are conforming to specification limits. See the Process Capability chapter in the 

Quality and Process Methods book for more information about goal plots and their features.

The Goal Plot red triangle menu has the following options:

Show Within Sigma Points Shows or hides the points calculated using the within 

sigma estimate.

Show Within or Between-and-Within Sigma Points (Available only when 3-way chart 

is selected in the launch window.) Shows or hides the points calculated using the 

between-and-within sigma estimate.

Show Overall Sigma Points Shows or hides the points calculated using the overall 

sigma estimate.

Shade Levels Shows or hides the Ppk level shading. This is turned on by default. The 

shaded areas are described as follows, with p representing the value shown in the box 

beneath Ppk. By default, p = 1.33.

– Points in the red area have Ppk < p.

– Points in the yellow area have p < Ppk < 2p.

– Points in the green area have 2p < Ppk.

Label Within Sigma Points Shows or hides labels for points calculated using the within 

sigma estimate.
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Label Within or Between-and-Within Sigma Points (Available only when a 3-way 

chart is selected in the launch window.) Shows or hides labels for points calculated 

using the between-and-within sigma estimate.

Label Overall Sigma Points Shows or hides labels for points calculated using the 

overall sigma estimate.

Defect Rate Contour Shows or hides a contour representing a specified defect rate.

Show Capability Shows or hides the Capabilities in the Summary table. All capabilities 

except for Spec Centered Mean and Spec Scaled Std Dev are shown by default.

Note: Spec Centered Mean and Spec Scaled Std Dev are displayed in the Summary table as 

(Mean-Tgt)/SpecRange and StdDev/SpecRange.

Save Summary Table Saves all of the information that can appear in the Summary table to 

a Process Summary data table. The Process Summary data table also contains specification 

limit details, if these are specified for at least one process.

Save Details Table Saves detailed information about control chart calculations to a Process 

Details data table. For each combination of process and grouping variables, the table 

contains a row for each subgroup showing:

– The values of the subgroup sample statistics.

– The control limits.

– The subgroup size.

– A list of indicators for which, if any, alarms were triggered. Alarms for the Nelson tests 

are indicated with the numbers for the tests. An alarm for the Range Limit Exceeded 

test is indicated with an R.

– The Drift

Save Selected Details For the selected rows in the Summary table, saves a Process Details 

table with the information that is saved when you select Save Details Table.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.
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Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Additional Example of Process Screening

The following example illustrates the use of a Grouping column and the construction of a Shift 

Graph using Consumer Prices.jmp.

The consumer price index data table contains monthly data on 17 products. The time periods 

vary by product. The data are arranged so that all 17 products are listed in a single column 

called Series. To separate the products, you must treat Series as a Grouping column.

1. Select Help > Sample Data Library and open Consumer Prices.jmp.

2. Select Analyze > Screening > Process Screening.

3. Select Price and click Process Variables.

4. Select Series and click Grouping.

This ensures that each level of Series is treated as a separate process.

5. Select Date and click Time.

6. Set the Control Chart Type to XBar and R.

7. Set the Subgroup Sample Size to 3.

Because the data are given monthly, subgroups of size three represent quarters.

8. Click OK.

9. Press Alt and click the red triangle next to Process Screening.

This opens a window showing the available red triangle options. You can select multiple 

options at once in this window.

10. Check the following: Largest Upshift, Largest Downshift, and Shift Graph.

11. Click OK.

The columns Largest Upshift, Upshift Date, Largest Downshift, and Downshift Date are 

added to the Summary table. The shifts are the largest shifts exceeding one within-sigma 

unit. The position of each shift is given in terms of the Time variable, Date. See“Shift 

Magnitudes and Positions” on page 398.

A Shift Graph also appears. The Shift Graph shows all shifts that exceed the number of 

Shift Threshold within-sigma units, which is set to three by default. See “Shift Graph” on 

page 401. Green points correspond to upshifts and red points correspond to downshifts.
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Notice that Gasoline, All has values for both Largest Upshift and Largest Downshift in the 

Summary table. The Largest Downshift value, 1.8296, is less than three. Because the Shift 

Graph shows shifts of only three or more within-sigma units, the Largest Downshift value 

for Gasoline, All is not plotted on the Shift Graph.

Also notice that Tomatoes is not included on the Shift Graph. For Tomatoes, no shifts of 

three or more within-sigma units were found.

12. Double click on the horizontal axis of the Shift Graph to open the X Axis Settings window.

13. In the Tick/Bin Increment panel, set # Minor Ticks to 1.

14. Set Label Row Nesting to 2.

15. Click OK.

Figure 19.7  Shift Graph

Most series show primarily upshifts. Price Coffee, however, has several alternating 

downshifts and upshifts. To better understand this series, obtain a control chart.

16. Select any point to the right of Price Coffee in the Shift Graph and click Select Process.

This action selects the row of the Summary table corresponding to Coffee.

17. Right-click the selected process in the Summary table and select Control Charts for 
Selected Items.
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Figure 19.8  Control Chart for Coffee

The control chart shows the upshifts and downshifts that are identified in the Shift Graph.

The Summary table indicates that the largest upshift (25.399 within-sigma units) occurs for 

the subgroup that includes September 1994. In the control chart in Figure 19.8, this is the 

subgroup in position 59. The Summary table also indicates that the largest downshift 

(9.1674 within-sigma units) occurs for the subgroup that includes March 1981. This is the 

subgroup in position 5 in the control chart.

Because shifts are calculated using EWMA-smoothed series and an outlier-correction 

algorithm, the shift positions might not precisely correspond to the subgroups that seem 

to start the shifts on a Shewhart control chart.

Statistical Details for the Process Screening 
Platform

Scaling Factors for Using Medians to Estimate Sigma

When you select Use Medians instead of Means, sigma is estimated using a scaled median 

range or median standard deviation. The table below gives the scaling factors, which were 

obtained using Monte Carlo simulation.
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For subgroups of size n drawn from a normal distribution, the following are true:

• The theoretical median of the ranges is approximately d2_Median*, where d2_Median is 

the value corresponding to n.

• The theoretical median of the standard deviations is approximately c4_Median*, where 

c4_Median is the value corresponding to n.

Table 19.1  Scaling Constants for Median Range and Median Standard Deviation

n d2_Median c4_Median

2 0.953 0.675

3 1.588 0.833

4 1.978 0.888

5 2.257 0.917

6 2.471 0.933

7 2.646 0.944

8 2.792 0.952

9 2.915 0.959

10 3.024 0.963

11 3.118 0.967

12 3.208 0.969

13 3.286 0.972

14 3.357 0.975

15 3.422 0.976

16 3.483 0.978

17 3.539 0.979

18 3.590 0.980

19 3.640 0.981

20 3.685 0.982

21 3.731 0.983

22 3.770 0.984
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23 3.811 0.984

24 3.846 0.985

25 3.883 0.986

Table 19.1  Scaling Constants for Median Range and Median Standard Deviation (Continued)

n d2_Median c4_Median
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Screen Many Predictors for Significant Effects

The analysis of large data sets, where hundreds to thousands of measurements on a part, 

process, or sample are taken requires innovative approaches. The Predictor Screening 

platform provides a method of screening many predictors for their ability to predict an 

outcome. For example, predictor screening can be used to help identify biomarkers from 

thousands tested in samples from patients with and without a condition to predict the 

condition.

Predictor screening differs from response screening. Response screening tests factors one at a 

time as a predictor of the response. Predictor screening uses bootstrap forest partitioning to 

evaluate the contribution of predictors on the response. The partition models are built on 

multiple predictors. Predictor screening can identify predictors that might be weak alone but 

strong when used in combination with other predictors. See “Response Screening” chapter on 

page 351 for details.

Figure 20.1  Example of a Predictor Screening Report
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Overview of the Predictor Screening Platform

Predictor screening is useful for the identification of significant predictors from a large 

number of candidates. Suppose you had hundreds of Xs and needed to determine which of 

those were most significant as predictors of an outcome.

The predictor screening platform uses a bootstrap forest to identify potential predictors of 

your response. For each response, a bootstrap forest model using 100 decision trees is built. 

The column contributions to the bootstrap forest model for each predictor are ranked. Because 

the bootstrap forest method involves a random component, column contributions can differ 

when you rerun the report. For more information about decision trees, see the Partition 

Models chapter in the Predictive and Specialized Modeling book

Example of Predictor Screening

The Bands Data.jmp data table contains measurements from machinery in the rotogravure 

printing business. The data set contains 539 records and 38 variables. The response Y is the 

column Banding? and its values are “BAND” and “NOBAND”. You are interested in 

understanding what properties are most likely to contribute to the response.

1. Select Help > Sample Data Library and open Bands Data.jmp.

2. Select Analyze > Screening > Predictor Screening.

3. Select Banding? as Y, Response.

4. Select the grouped columns grain screened to chrome content and click X.

5. Click OK.
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Figure 20.2  Ranked Column Contributions

Note: Because this analysis is based on the Bootstrap Forest method that has a random 

selection component, your results can differ slightly from those in Figure 20.2. See “Bootstrap 

Forest” on page 121.

The columns are sorted and ranked in order of contribution in the bootstrap forest model. 

Predictors with the highest contributions are strong candidate predictors for the response of 

interest.

Launch the Predictor Screening Platform

Launch the Predictor Screening platform by selecting Analyze > Screening > Predictor 
Screening.
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Figure 20.3  Predictor Screening Launch Window

Y, Response The response columns.

X Predictor columns.

By A column or columns whose levels define separate analyses. For each level of the 

specified column, the corresponding rows are analyzed using the other variables that you 

have specified. The results are presented in separate reports. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.

Number of Trees The number of decision trees in the bootstrap forest model.

The Predictor Screening Report

The report (Figure 20.2) shows the list of predictors with their respective contributions and 

rank. Predictors with the highest contributions are likely to be important in predicting Y.

The Contribution column shows the contribution of each predictor to the bootstrap forest 

model. The Portion column in the report shows the percent contribution of each variable.

You can select the important predictors in the Predictor Screening report. Selecting the 

important predictors selects the corresponding columns in the data table, enabling you to 

easily enter these columns into the launch windows for modeling platforms. The Copy 

Selected button enables you to copy the selected columns to the clipboard so that you can 

paste them into a model as well. In this way, the Predictor Screening enhances the modeling 

process.
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Predictor Screening Platform Options

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.
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Perform Market Basket Analysis

The Association Analysis platform is available only in JMP Pro.

Association analysis enables you to identify items that have an affinity for each other. It is 

frequently used to analyze transactional data (also called market baskets) to identify items that 

often appear together in transactions. For example, grocery stores and online merchants use 

association analysis to strategically organize and recommend products that tend to be 

purchased together.

Association analysis is also used for identifying dependent or associated events. For example, 

you can identify car parts that seem to fail around the same time. In this application, car 

inspections are treated as the market baskets and you analyze the associations among groups 

of faulty parts found in each inspection.

Figure 21.1  Example of Singular Value Decomposition Plots
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Overview of the Association Analysis Platform

The Association Analysis platform identifies connections among groups of items in an 

independent event or transaction. In association analysis, an item is the basic object of interest. 

For example, an item could be a product, a web page, or a service. An item set is a list of one or 

more items.

The relationship between two item sets is defined by an association rule. An association rule 

consists of a condition item set and a consequent item set. Antecedents are the individual items in 

the condition item set. Association analysis identifies association rules, which predict that a 

consequent item set will be in a transaction, given that the condition item set is already in the 

transaction. Some association rules are stronger, and therefore more useful, than others. The 

following three performance measures describe the strength of an association rule:

• Support is the proportion of transactions in which an item set appears. A high value for 

support indicates that the item set occurs frequently.

• Confidence is the proportion of transactions that contain the consequent item set, given that 

the condition item set is in the transaction. Confidence measures the strength of 

implication, or the predictive power, of an association rule.

• Lift is the ratio of an association rule’s confidence to its expected confidence, assuming that 

the condition and consequent item sets appear in transactions independently. Lift 

measures how much the consequent item set depends on the presence of the condition 

item set. The minimum value for lift is 0.

– A lift ratio less than 1 indicates that the condition and consequent repel each other, 

because they occur together less frequently than one would expect by chance alone.

– A lift ratio close to 1 indicates that the consequent occurs at the same rate in 

transactions that contain the condition as one would expect from chance alone.

– A lift ratio greater than 1 indicates that the consequent item set has an affinity for the 

condition item set. The consequent item set occurs more often with the condition item 

set than one would expect by chance alone.

For more information about these performance measures, see “Association Analysis 

Performance Measures” on page 431.

The Association Analysis platform also enables you to perform singular value decomposition. 

Singular value decomposition (SVD) groups similar transactions and also groups similar 

items using a matrix reducing methodology that is different from what is used in association 

analysis. Use the SVD methodology to gain insights that complement what you learn from 

association analysis.

For more information about association analysis, see Hastie et al. (2009) and Shmueli et al. 

(2010). For more information about singular value decomposition, see Jolliffe (2002).
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Example of the Association Analysis Platform

This example uses the Grocery Purchases.jmp sample data table, which contains transactional 

data reported by a grocery store. The data table lists the items purchased by 1001 customers, 

each assigned a unique customer ID. You want to explore the associations among items in 

order to identify patterns in consumer behavior.

1. Select Help > Sample Data Library and open Grocery Purchases.jmp.

2. Select Analyze > Screening > Association Analysis.

3. Select Product and click Item.

4. Select Customer ID and click ID.

5. Click OK.

By default, the Rules report is sorted in decreasing order by Confidence. However, 

association rules with extremely high confidence also tend to have a higher number of 

items in the condition set. Since you want to view association rules with smaller condition 

sets, sort the report by Confidence, but in increasing order.

6. Right-click in the Rules report and select Sort By Column.

The Select Columns window appears.

7. Select Confidence and the check the ascending order option.

8. Click OK.

Figure 21.2  Association Analysis Report

9. Scroll down the report to where the Confidence values are 58%.
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There is an entry in the Rules report table that indicates that 58% of customers who bought 

an avocado also bought an artichoke. The value of Lift is 1.908, indicating that there is a 

likely dependency. You want to verify that avocados and artichokes occur in a significant 

portion of transactions.

10. Click the disclosure icon next to Frequent Item Sets.

Figure 21.3  Frequent Item Sets Report

The Frequent Item Sets report shows that 36% of customers purchased avocados. The 

Rules report in Figure 21.2 shows that 58% of these customers also bought artichokes. 

Because of the large proportion of customers who follow this behavior, the grocery store 

management might use this information to strategically locate avocados and artichokes.

You also decide to look at the association rules with the highest lift.

11. Right-click in the Rules report table and select Sort By Column.

The Select Columns window appears.

12. Select Lift and click OK.

The Rules table is sorted by decreasing values of lift. Notice that the second association 

rule has a lift of 6.912 and 97% confidence. You want to verify that both the condition set, 

{Coke, Heineken, sardines}, and the consequent item set, {chicken, ice cream}, have 

adequate support.

13. Right-click in the Frequent Item Sets report and select Sort By Column.

The Select Columns window appears.

14. Select Item Set and the check the ascending order option.
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15. Click OK.

The Frequent Item Sets table is sorted alphabetically by item set. Scroll through the list to 

see that the condition item set, {Coke, Heineken, sardines}, has 12% support. The 

consequent item set, {chicken, ice cream}, has 14% support. This association rule has high 

lift, but represents fewer transactions than the first association rule that you examined.

Launch the Association Analysis Platform

Launch the Association Analysis platform by selecting Analyze > Screening > Association 
Analysis.

Figure 21.4  Association Analysis Launch Window

Item The categorical column that contains the item data to be analyzed. If the column has 

the Multiple Response modeling type, each of the multiple responses in each row is 

treated as an item.

ID The column that identifies the transaction to which an item belongs. The ID role is 

required, unless the Item role is filled by a column with the Multiple Response modeling 

type.

Note: When the Item role is filled by a column with the Multiple Response modeling type 

and an ID role is specified, all rows with the same ID are combined into one transaction.

Freq The column that identifies a frequency for the transactions in the Item column. For 

example, if a transaction has a frequency of 3, that is treated as three identical transactions 

that contain the items in the Item column.

Note: The Freq role is ignored if the Item role is filled by a column that does not have the 

Multiple Response modeling type.
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By Produces a separate report for each level of the By variable. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.

Minimum Support Specifies a minimum value for the proportion of occurrences of an item 

set. This value must be between 0 and 1. Only item sets with support equal to or exceeding 

this value are considered in the analysis.

Minimum Confidence Specifies a minimum value for the proportion of occurrences that a 

consequent item set occurs within transactions that contain the conditional item set. This 

value must be between 0 and 1. Only association rules with confidence equal to or 

exceeding this value appear in the report.

Minimum Lift Specifies a minimum dependency ratio. Lift values must be 0 or greater. Only 

association rules with lift equal to or exceeding this value appear in the report.

Maximum Antecedents  Specifies the maximum number of items in the condition item set. 

Association rules with more than this number of items in the condition set are not 

considered in the analysis.

Maximum Rule Size Specifies the maximum number of items that appear in the union of 

the condition and consequent item sets. Association rules with more than this combined 

number of items are not considered in the analysis.

Note: You can use the minimum support, maximum antecedent, and maximum rule size 

options in the launch window to reduce computational time for large data sets. For more 

information about these measures, see “Statistical Details for the Association Analysis 

Platform” on page 430.

Data Format

There are two data formats that are accepted in the Association Analysis platform:

• You can specify a single item response in each row in the Item role and identify which 

items are included in each transaction using the ID role. In this format, the Item and ID 

roles are required and the Freq role is ignored.

• You can specify a Multiple Response modeling type column for the Item role. In this 

format, the Item role is required, the ID and Freq roles are optional. If an ID role is 

specified, all rows with the same ID are combined into one transaction. If a Freq role is 

specified, the frequency applies to the transaction, not the specific items in the transaction.
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The Association Analysis Report

By default, the Association Analysis report contains the following reports:

• “Frequent Item Sets” on page 422

• “Rules” on page 422

Tip: To order the contents of a table in a report by any of its columns, right-click in the table 

and select Sort by Column.

Frequent Item Sets

The Frequent Item Sets report lists item sets in decreasing order of support. The listed item 

sets meet the Minimum Support value that you specified in the launch window. Each item set 

is considered as a conditional and as a consequent item set to form association rules. The table 

contains the following columns:

Item Set The item sets that are considered as conditional or consequent sets for the 

association rules.

Support The proportion of transactions in which all of the items in the Item Set occur.

N Items The number of items in the Item Set.

Rules

The Rules report shows a table of association rules that are sorted in decreasing order of 

confidences. Only association rules that meet the Minimum Support, Minimum Confidence, 

Minimum Lift, Maximum Antecedents, and Maximum Rule Size requirements that you 

specified in the launch window appear in this report.

The Rules report table contains the following columns:

Rule The association rules formed by combining Condition and Consequent item sets.

Condition The item set that is thought to influence the presence of a Consequent item set 

within transactions.

Consequent The item set whose presence is thought to be influenced by the presence of 

a Condition item set.
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Confidence The proportion of transactions that contain the Consequent item set, given that 

the condition item set is in the transaction. Confidence measures the strength of 

implication, or the predictive power, of an association rule.

Lift The ratio of an association rule’s confidence to its expected confidence, assuming that 

the condition and consequent item sets appear in transactions independently. Lift 

measures how much the Consequent item set depends on the presence of the Condition 

item set. The minimum value for lift is 0.

– A lift ratio less than 1 indicates that the Condition and Consequent item sets repel each 

other, because they occur together less frequently than one would expect by chance 

alone.

– A lift ratio close to 1 indicates that the Consequent item set occurs at the same rate in 

transactions that contain the Condition item set as one would expect from chance 

alone.

– A lift ratio greater than 1 indicates that the Consequent item set has an affinity for the 

Condition item set. The Consequent item set occurs more often with the Condition item 

set than one would expect by chance alone.

Association Analysis Platform Options

The Association Analysis red triangle menu contains the following options:

Transaction Listing Shows or hides a table listing each Transaction ID value and the items 

included in that transaction. The table is sorted by the Transaction ID column.

Frequent Item Sets Shows or hides a list of item sets whose support exceeds the Minimum 

Support value specified in the launch window. See “Frequent Item Sets” on page 422.

Rules Shows or hides a table of association rules that meet the Minimum Support, 

Minimum Confidence, Minimum Lift, Maximum Antecedents, and Maximum Rule Size 

requirements specified in the launch window. See “Rules” on page 422.

SVD Shows or hides a report of a partial singular value decomposition (SVD) of the 

incidence matrix for the items. This decomposition reduces the incidence matrix into a 

user-specified number of dimensions for analysis. The SVD report also contains options to 

visualize the singular vectors, cluster transactions and items, save out singular vectors, 

and perform a rotated SVD analysis. See “Singular Value Decomposition” on page 424.

See the JMP Reports chapter in the Using JMP book for more information about the following 

options:
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Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Singular Value Decomposition

Singular value decomposition (SVD) complements association analysis by providing another 

method to identify items that have an affinity for each other. Singular value decomposition of 

the transaction item matrix reduces the matrix to a manageable number of dimensions, 

thereby enabling you to group similar transactions and similar items. The SVD analysis is 

equivalent to performing principal components analysis (PCA) on a correlation matrix.

The transaction item matrix is a matrix for which each row corresponds to a transaction and 

each column corresponds to an item. The entries of the matrix are zeros and ones. If an item 

occurs in a transaction, the corresponding row and column entry is one. Otherwise, the row 

and column entry is zero. Because the transaction item matrix usually contains more values of 

zero than one, it is called a sparse matrix.

The partial singular value decomposition approximates the transaction item matrix using 

three matrices: U, S, and V‘. The relationship between these matrices is defined as follows:

Transaction Item Matrix ≈ U * S * V‘

Define nTran as the number of transactions (rows) in the transaction item matrix, nItem as the 

number of items (columns) in the transaction item matrix, and nVec as the specified number of 

singular vectors. Note that nVec must be less than or equal to min(nTran, nItem). It follows that 

U is an nTran by nVec matrix that contains the left singular vectors of the transaction item 

matrix. S is a diagonal matrix of dimension nVec. The diagonal entries in S are the singular 

values in the transaction item matrix. V‘ is an nVec by nItem matrix. The rows in V‘ (or 

columns in V) are the right singular vectors.

The right singular vectors capture connections among different items with similar functions or 

topic areas. If three items tend to appear in the same transactions, the SVD is likely to produce 

a singular vector in V‘ with large values for those three items. The U singular vectors 

represent the transactions projected into this new item space.
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The SVD also captures indirect connections. If two items never appear together in the same 

transaction, but they generally appear in transactions with another third item, the SVD is able 

to capture some of that connection. If two transactions have no items in common but contain 

items that are connected in the dimension-reduced space, they map to similar vectors in the 

SVD plots.

The SVD transforms transaction data into a fixed-dimensional vector space, making it 

amenable to clustering, classification, and regression techniques. The Save options enable you 

to export this vector space to be analyzed in other JMP platforms.

The transaction item matrix is centered, scaled, and divided by nTran minus 1 before the 

singular value decomposition is carried out. This analysis is equivalent to a PCA of the 

correlation matrix of the transaction item matrix. The SVD implementation takes advantage of 

the sparsity of the transaction item matrix.

SVD Report

The SVD option produces two SVD plots and a table of the singular values from the singular 

value decomposition.

SVD Plots

The first plot contains a point for each transaction. For a given transaction, the point that is 

plotted is defined by the transaction’s values in the first two singular vectors (the first two 

columns of the U matrix) multiplied by the diagonal singular values matrix (S). This plot is 

equivalent to the Score Plot in the Principal Components platform. Each point in this plot 

represents a transaction. In the Transaction SVD plot, points that are visibly grouped together 

indicate transactions with a similar composition.

The second plot contains a point for each item. For a given item, the point that is plotted is 

defined by the item’s values in the first two singular vectors (the first two rows of the V‘ 

matrix) multiplied by the diagonal singular values matrix (S). This plot is equivalent to the 

Loadings Plot in the Principal Components platform. Each point in this plot represents an 

item. In the Item SVD plot, items that are visibly grouped together indicate items that have 

similar functions or topic areas.

Singular Values

Below the transaction and item SVD plots, a table of the singular values appears. These are the 

diagonal entries of the S matrix in the singular value decomposition of the transaction item 

matrix. The Singular Values table also contains a column of corresponding eigenvalues for the 

equivalent principal components analysis. Like in the Principal Components platform, there 

are columns for the percent and cumulative percent of variation explained by each eigenvalue 
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(or singular value). You can use the Cum Percent column to decide what percent of variance 

from the transaction item matrix you want to preserve, and then use the corresponding 

number of singular vectors.

SVD Report Options

The SVD red triangle menu contains the following options:

SVD Scatterplot Matrix Shows or hides a scatterplot matrix of the item and transaction 

singular value decomposition vectors. You are prompted to select the size of the 

scatterplot matrix when you select this option. This scatterplot matrix enables you to 

visualize more than the first two dimensions of the singular value decomposition.

Topic Analysis, Rotated SVD Performs a varimax rotated partial singular value 

decomposition of the item transaction matrix to produce groups of items called topics. You 

can select this option multiple times to find different numbers of topics. See “Topic 

Analysis” on page 426.

Cluster Items Shows or hides a hierarchical clustering analysis of the items in the data. To 

the right of the dendrogram, there are options to set the number of clusters and save the 

clusters to a data table. For each item, this data table contains its frequency, the number of 

transactions that contain it, and its assigned cluster.

Cluster Transactions Shows or hides a hierarchical clustering analysis of the transactions 

in the data. To the right of the dendrogram, there are options to set the number of clusters, 

save the clusters to a column in the data table, and show the transactions in a selected 

branch of the dendrogram plot.

Save Transaction Singular Vectors Creates a data table that contains a number of singular 

vectors that you specify for each transaction. These are the left singular values in the 

transaction item matrix. See “Singular Value Decomposition” on page 424.

Save Item Singular Vectors Creates a data table that contains a number of singular vectors 

that you specify for each item. These are the right singular values in the transaction item 

matrix. See “Singular Value Decomposition” on page 424.

Topic Analysis

The Topic Analysis, Rotated SVD option performs a varimax rotation on the partial singular 

value decomposition (SVD) of the transaction item matrix. See “Singular Value 

Decomposition” on page 424. You must specify a number of rotated singular vectors, which 
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corresponds to the number topics that you want to retain from the transaction item matrix. 

After you specify a number of topics, the Topic Analysis report appears.

Topic analysis is equivalent to a rotated principal component analysis (rotated PCA). The 

varimax rotation takes a set of singular vectors and rotates them to make them point more 

directly in the coordinate directions (toward the items). This rotation makes the vectors help 

explain the composition of the transactions as each rotated vector orients toward a set of 

items. Negative values indicate a repulsion force. The items with negative values occur in a 

topic less frequently compared to the items with positive values.

Topic Analysis Report

The Topic Analysis report shows the items that have the largest loadings in each topic after 

rotation. There are additional reports that show the components of the rotated singular value 

decomposition.

The Top Loadings by Topic report shows a table for each topic. The items in each table are the 

ones that have the largest loadings in absolute value for each topic. Each table is sorted in 

descending order by the absolute value of the loading. These tables can be used to determine 

conceptual themes that correspond to each topic.

The Topic Analysis report also contains the following reports:

Topic Loadings Contains a matrix of the loadings across topics for each item. This matrix is 

equivalent to the factor loading matrix in a rotated PCA.

Word Clouds by Topic Contains a matrix of word clouds, one for each topic.

Topic Scores Contains a matrix of transaction scores for each topic. Transactions with 

higher scores in a topic are more likely to be associated with that topic.

Topic Scores Plots Shows the topic scores for all transactions in one-dimensional 

scatterplots. Negative values indicate transactions that are negatively associated with a 

topic. Use these plots to explore the distribution of transactions within each topic.

Variance Explained by Each Topic Contains a table of the variance explained by each 

topic. The table also contains columns for the percent and cumulative percent of the 

variation explained by each topic.

Rotation Matrix Contains the rotation matrix for the varimax rotation.

Topic Analysis Report Options

The Topic Analysis red triangle menu contains the following options:



428 Association Analysis Chapter 21
Additional Example: SVD Analysis Predictive and Specialized Modeling

Topic Scatterplot Matrix Shows or hides a scatterplot matrix of the rotated singular value 

decomposition vectors.

Display Options Contains options to show or hide content that appears in the Topic 

Analysis report. See “Topic Analysis Report” on page 427.

Save Transaction Topic Vectors Saves a user-specified number of singular vectors from 

the rotated singular value decomposition as columns to the data table.

Save Item Topic Vectors Saves the topic vectors as columns to a new Item Topic Scores 

data table.

Remove Removes the Topic Analysis report from the SVD report.

Additional Example: SVD Analysis

In this example, you use singular value decomposition of the transaction item matrix to gain 

further insight into the Grocery Purchases.jmp sample data.

1. Select Help > Sample Data Library and open Grocery Purchases.jmp.

2. Select Analyze > Screening > Association Analysis.

3. Select Product and click Item.

4. Select Customer ID and click ID.

5. Click OK.

6. Click the red triangle next to Association Analysis and select SVD.

7. Click OK.

Figure 21.5  SVD Plots
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The transaction SVD plot suggests that there might be two or three groups of transactions. 

In the upper right corner of the item SVD plot, notice that the points that represent Coke 

and ice cream overlap. The proximity of these two items indicates that there is a strong 

affinity between them.

8. Click the red triangle next to SVD and select Topic Analysis, Rotated SVD.

9. Type 3 next to Number of topics (rotated singular vectors) and click OK.

The Topic Items and Topic Scores reports appear.

Figure 21.6  Topic Items Report

Three groups, or topics, are created and shown in the Topic Items report. The first items 

listed in the Topic Item tables represent the primary items for that group. For example, 

Topic 1 is a group that is identified primarily by transactions that do not contain avocados, 

but do contain olives.

Figure 21.7  Topic Scores

The topic scores that are assigned to each of the 1001 transactions are plotted in the Topic 

Scores report. Select groups of points for a topic to see how those transactions relate to 

other topics. For example, transactions with very high values on Topic 1 tend to have low 

values on Topics 2 and 3.

10. Open the Singular Values report.
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Figure 21.8  Singular Values Table

As seen in Figure 21.8, the first two singular values explain only about 30% of the 

variability in the grocery store data. Additional dimensions might be required to explain a 

sufficient amount of variability.

Statistical Details for the Association Analysis 
Platform

• “Frequent Item Set Generation”

• “Association Analysis Performance Measures”

Frequent Item Set Generation

The Association Analysis platform uses the Apriori algorithm to reduce computational time 

when generating frequent item sets. The Apriori algorithm leverages the fact that an item set’s 

support is never larger than the support of its subsets. The platform generates larger item sets 

from combinations of smaller item sets that meet the minimum support level. In addition, the 

platform does not generate item sets that exceed either the specified maximum number of 

antecedents or the maximum rule size. These options are useful when working with large data 

sets, because the total possible number of rules increases exponentially with the number of 

items. For more information about the Apriori algorithm, see Agrawal and Srikant (1994).
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Association Analysis Performance Measures

This section defines the performance measures used in Association Analysis. Denote the 

condition item set by X and the consequent item set by Y. Denote an association rule with 

condition set X and consequent set Y by .

Support

Support is the proportion of transactions in which an item set occurs.

Confidence

Confidence is the proportion of transactions that contain the consequent item set, given that 

the transaction contains the condition item set.

An association rule with a confidence of 0% has a consequent item set that does not appear in 

any transaction with the condition item set. A confidence of 100% indicates that every 

transaction that contains the condition item set also contains the consequent item set.

Lift

Lift measures dependency between X and Y.

The numerator for lift is the proportion of transactions where X and Y occur jointly. The 

denominator is an estimate of the expected joint occurrence of X and Y, assuming that they 

occur independently.

A lift value of 1 indicates that X and Y jointly occur in transactions with the frequency that 

would be expected by chance alone. Increasing lift values suggest that Y occurs more often 

than expected when X is present.

X Y

Support X  Number of Transactions Containing X
Total Number of Transactions

-----------------------------------------------------------------------------------------------------=

Confidence X Y  Support X Y 
Support X 

------------------------------------------=

Lift X Y  Support X Y 
Support X  Support Y 
--------------------------------------------------------------------=
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Chapter 22
Process History Explorer

Identify Problem Components in Complex Process Histories

Note: The Process History Explorer platform is new and experimental. It is subject to change 

in future releases.

In complex manufacturing situations, such as in semiconductor factories, a defective tool or 

route combination might lead to poor yield or reduced quality. However, there might be 

hundreds of steps that a unit passes through that involve many different tools. It can be 

difficult to determine the exact combination of factors that leads to the poor yield.

The Process History Explorer platform organizes all of the production tracking data and 

enables you to identity factors that seem to be associated with poor yield. You can then 

perform stepwise regression. You can analyze the time that a unit spends waiting between 

steps or tools in the process and see how that waiting time is related to yield. You can also 

analyze the effect on yield of transitions from one tool to another.

Figure 22.1  Process History Explorer Report
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Example of Process History Explorer

This example uses two data tables. The first data table that contains step-by-step history of 25 

wafers in 50 lots that went through a complex manufacturing process. The second data table 

contains the yield for each wafer in each lot.

1. Select Help > Sample Data Library and open Quality Control > Lot Wafer History.jmp and 

Quality Control > Lot Wafer Yield.jmp.

2. From the Lot Wafer History.jmp data table, select Analyze > Screening > Process History 
Explorer.

3. Select Lot and Wafer and click ID.

4. Select Tool and Route and click X, Process.

5. Select Layer and Operation and click Step.

6. Select TimeIn and TimeOut and click Timestamp.

7. Click OK.

A window appears that enables you to select the corresponding yield table.

8. Select Lot Wafer Yield and click OK.

A window appears that enables you to select the yield column.

9. Select Yield and click OK.

10. Click the Process History Explorer red triangle and select Levels with Lowest Yield.
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Figure 22.2  Process History Explorer Report

The report contains information about the process, including the number of units, steps, 

operations, and levels in the X columns. The Levels with Lowest Yields table contains counts 

and yield information for the 195 levels in the X columns. Notice that the PlanarTool008 tool 

had the lowest yield and 1,000 units went through that tool.

Launch the Process History Explorer Platform

Launch the Process History Explorer platform by selecting Analyze > Screening > Process 
History Explorer.
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Figure 22.3  Process History Explorer Launch

Launch Window Roles

ID Specifies one or more columns that identify a unit in the process.

Note: The ID columns must have corresponding columns in the yield table.

X, Process Specifies one or more columns that identify the components or specific details 

that make up the steps of the process.

Step Optional columns that specify the steps and sub-steps that a unit goes through. For 

example, the layer and the type of operation within the layer.

Timestamp Specifies the time of the operation. The time can be specified as a single time 

point or as a pair of time points that indicate the times that the operation started and 

ended.

Order Optional column that specifies the order that a batch of units went through the 

components specified in the X, Process role.

By Produces a separate report for each level of the By variable. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.

Launch Window Options

Goal is to Minimize Y Specifies that the goal of the analysis is to minimize the response. By 

default, the analysis seeks to maximize the response.
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Note: The response is specified in a second data table, not in the data table used to launch 

the platform.

Data Format

The data for Process History Explorer must be specified in two data tables. The first table is 

used to launch the platform and contains the steps and details of the process. The second table 

contains the response, or yield, for each level of the ID columns.

The sample data tables Quality Control > Lot Wafer History and Quality Control > Lot Wafer Yield 

provide an example of how the data are specified in two data tables.

The Process History Explorer Report

The initial Process History Explorer Report provides a summary of the information in the data 

table(s). The summary information is as follows:

• The number of Units, determined by the ID columns. If there is more than one ID column, 

this is the number of unique combinations.

• The number of Steps, determined by the Step columns. If there is more than one Step 

column, this is the number of unique combinations.

• The number of Operations, determined by the Timestamp columns. This is the same as the 

number of rows in your data table.

• The number of levels, determined by the X, Process columns. If there is more than one 

X, Process column, this is the sum of the number of levels in each column.

• The number of responses, determined by the Yield columns.

Select options from the Process History Explorer red triangle menu to continue your analysis. 

See “Process History Explorer Platform Options” on page 438.

Process History Explorer Platform Options

The red triangle menu for the Process History Explorer report has the following options:

Levels with Lowest Yield Displays a table of summary statistics for the yield for each level 

of each X, Process variable. The summary statistics provided for each level are the number 

of operations, and the mean, standard error, and standard deviation of the yield. By 

default, the table is sorted in ascending order by mean yield.
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Levels with Lowest Yield with Time Filter Displays a table of summary statistics for the 

time intervals of the top 50 levels with the lowest yields. The routine searches for a time 

interval for each of the top 50 levels in the Levels with Lowest Yield table that minimizes 

the mean yield within the interval. The interval must contain at least 25% of the operations 

in that level. The summary statistics provided for each level are the number of operations 

in the identified interval, the mean yield in the identified interval, the timestamps for the 

first and last operations in the level (First Time and Last Time), and the timestamps for the 

first and last operations in the identified interval (RunStart Time and RunEnd Time).

Stepwise Regression Displays a Stepwise Regression window that enables you to specify 

options for a stepwise regression analysis. You can use stepwise regression to find 

problems in the process, where a problem is something that causes your yield to decrease. 

At each step in the regression, a term enters according to which term has the largest 

negative yield. This helps you identify process steps that most impact the yield. Stepwise 

Regression provides a table that shows the order in which terms entered the model at each 

step of the regression.

Note: If the Goal is to Minimize Y option is selected in the launch window, Stepwise 

Regression adjusts to detect terms that cause the yield to increase.

Goal Specifies the criterion used in the stepwise regression model. The Biggest 

individual difference option identifies the terms that individually cause the yield to 

change the most. The Biggest total difference option identifies the terms that cause the 

biggest total difference, which is the difference multiplied by the number of units 

affected. The Most predictive option produces a traditional stepwise regression model.

Time Filtering Enables you to use the starting time of a component in the stepwise 

regression model. If you choose the None option, the times are averaged over the entire 

time period. If you choose the Starting Time option, the component is allowed to fail at 

a particular starting time. The starting time is the time that maximizes the negative 

yield affect. If you choose the Starting Time option, the Stepwise Regression report 

table contains a Start Time column.

X Transform Enables you to use the regular count data or the Log(Count + 1) data for 

the X, Process variables in the stepwise regression. The Log(Count + 1) option 

transforms the variables in the regression such that high frequency counts have less of 

a linear influence in the regression. If you choose the None option, high frequency 

counts have a linear influence in the regression.

Number of Regression Steps The number of steps in the Stepwise Regression analysis. 

The default is ten.
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Figure 22.4  Stepwise Regression Window

Waiting Time Analysis (Available only when two Timestamp variables are specified.) Each 

unique ID can go through only one level of a step at a time. In addition, each step can 

process only one ID at a time. Waiting Time Analysis provides a table of waiting time 

summary statistics for each ID. In this table, waiting time is the amount of time between 

when an ID is done with one step and when it starts another step. Additional Waiting 

Time Analysis tables are also provided. These tables contain waiting time summary 

statistics for each ID within the levels of each Step variable. In these tables, waiting time is 

the amount of time between when an ID is done with a particular level of a Step variable 

and when it goes through that same level again. The tables provide the following statistics:

Waiting Sum The sum of the waiting times for the given combination of ID and Step 

variable levels.

Waiting Count The number of waiting times for the given combination of ID and Step 

variable levels.

Waiting Mean The mean of the waiting times for the given combination of ID and Step 

variable levels.

Waiting Max The maximum waiting time for the given combination of ID and Step 

variable levels.

Transition Analysis Displays a report that helps you identify transitions from one 

component to another that are problematic for the resulting yield. This report can help you 

identify alignment and registration issues in the process. For instance, some levels of the 

process column may be out of alignment with respect to other levels of the process 

column. If there is a transition problem, you would expect that items that repeat a specific 
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level to have better yields than items that go through different levels of the process 

column.

When you select this option, you must choose one or more X, Process columns and one or 

more levels in each of those columns to include in the analysis. For each column that you 

specify for the analysis, a report appears that contains four tables. The first shows yields 

and counts for transitions from a specific level of the column to another specific level of the 

column. The second shows yields and counts for transitions away from specific levels of 

the column. The third shows yields and counts for transitions to specific levels of the 

column. The fourth shows yields and counts for transitions where the unit repeats a 

specific level of the column.

Order Interaction (Available only if an Order variable is specified in the launch window.) 

Displays a report of a one-way analysis of the yield on the Order column. The report 

contains a table for each X, Process column. In each table, the levels of the process column 

are listed in descending order of LogWorth of the corresponding analysis of variance 

model. The tables also contain the p-values and a heat map for each level of the process 

column.

Save Count Table Creates a new data table that contains counts of how many units went 

through each level of the X, Process variables. The count table has a row for each unique 

unit, determined by the ID values.

Save Log Count Table Creates a new data table that is the same format as the Count table, 

except with entries of Log(Count + 1).

Save Waiting Time (Available only when two Timestamp variables are specified.) Saves 

each table in the Waiting Time Analysis report to a separate data table.
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Appendix A
Platforms that Support Validation

This appendix lists the types of crossvalidation available in each platform.

Parent 
Platform

Platform Use Excluded 
Rows as 
Validation 
Holdback

Random 
Validation 
Holdback

K-Fold 
Cross-Validat
ion

Validation Role 
Column

Fit Model Fit Least 

Squares

No No No Yes (only for 

model 

evaluation)

Fit Model Forward 

Stepwise 

Regression

No No Yes 

(continuous 

response 

models 

only)

Yes

Fit Model Logistic 

Regression

No No No Yes (only for 

model 

evaluation)

Fit Model Generalized 

Regression

No Yes Yes Yes

Fit Model Partial 

Least 

Squares

No Yes Yes Yes

Partition Decision 

Tree

Yes Yes Yes Yes

Partition Bootstrap 

Forest

Yes Yes No Yes

Partition Boosted 

Tree

Yes Yes No Yes
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Partition K Nearest 

Neighbors

Yes Yes No Yes

Partition Naive 

Bayes

Yes Yes No Yes

Neural Neural Yes Yes Yes Yes

Parent 
Platform

Platform Use Excluded 
Rows as 
Validation 
Holdback

Random 
Validation 
Holdback

K-Fold 
Cross-Validat
ion

Validation Role 
Column



Appendix B
References

Agrawal, R., and Srikant, R. (1994). “Fast Algorithms for Mining Association Rules.” In 
Proceedings of the 20th VLDB Conference. Santiago, Chile: IBM Almaden Research Center. 
Retrieved July 5, 2016 from http://rakesh.agrawal-family.com/papers/vldb94apriori.pdf.

Baglama, J., and Reichel, L. (2005). “Augmented implicitly restarted Lanczos bidiagonalization 
methods.” SIAM Journal on Scientific Computing, 27:19–42.

Bates, D. M., and Watts, D. G. (1988). Nonlinear Regression Analysis and Its Applications. New 
York: John Wiley & Sons.

Benjamini, Y., and Hochberg, Y. (1995). “Controlling the False Discovery Rate: A Practical and 
Powerful Approach to Multiple Testing.” Journal of the Royal Statistical Society, Series B 
57:289–300.

Box, G. E. P., Jenkins, G. M., and Reinsel, G. C. (1994). Time Series Analysis: Forecasting and 
Control. 3rd ed. Englewood Cliffs, NJ: Prentice-Hall.

Cleveland, W. S. (1994). Visualizing Data, Summit, NJ: Hobart Press.

Conover, W. J. (1999). Practical Nonparametric Statistics. 3rd ed. New York: John Wiley & Sons.

Cureton, E. E. (1967). “The Normal Approximation to the Signed-Rank Sampling Distribution 
when Zero Differences are Present.” Journal of the American Statistical Association 62: 319, 
1068–1069.

Hand, D. J., Mannila, H., and Smyth, P. (2001). Principles of Data Mining. Cambridge, MA: MIT 
Press.

Hastie, T. J., Tibshirani, R. J., and Friedman, J. H. (2009). The Elements of Statistical Learning: 
Data Mining, Inference, and Prediction. 2nd ed. New York: Springer-Verlag.

Hawkins D. M., and Kass G. V. (1982). “Automatic Interaction Detection.” In Topics in Applied 
Multivariate Analysis, edited by D. M. Hawkins, 267–300. Cambridge: Cambridge 
University Press.

Huber, P. J., and Ronchetti, E. M. (2009). Robust Statistics. 2nd ed. New York: John Wiley & 
Sons.

Jolliffe, I. T. (2002). Principal Component Analysis. New York: Springer-Verlag.

Kass, G. V. (1980). “An Exploratory Technique for Investigating Large Quantities of 
Categorical Data.” Journal of the Royal Statistical Society, Series C 29:119–127

Lehman, E. L. (2006). Nonparametrics: Statistical Methods Based on Ranks. 2nd ed. New York: 
Springer.

Mason, R. L., and Young, J. C. (2002). Multivariate Statistical Process Control with Industrial 
Applications. Philadelphia: SIAM.

http://rakesh.agrawal-family.com/papers/vldb94apriori.pdf


446 References Appendix B
Predictive and Specialized Modeling

McCullagh, P., and Nelder, J. A. (1989). Generalized Linear Models. 2nd ed. London: Chapman & 
Hall.

Nagelkerke, N. J. D. (1991). “A Note on a General Definition of the Coefficient of 
Determination.” Biometrika 78:691–692.

Nelder, J. A., and Wedderburn, R. W. M. (1972). “Generalized Linear Models.” Journal of the 
Royal Statistical Society, Series A 135:370–384.

Parker, R. J. (2015). Efficient Computational Methods for Large Spatial Data. Ph.D. diss., 
Department of Statistics, North Carolina State University. Retrieved June 30, 2016 from 
http://repository.lib.ncsu.edu/ir/bitstream/1840.16/10572/1/etd.pdf.

Qian, P. Z., Huaiquing, W., and Wu, C. F. (2012). “Gaussian process models for computer 
experiments with qualitative and quantitative factors.” Technometrics 50:383–396.

Ramsay, J. O., and Silverman, B. W. (2005). Functional Data Analysis. 2nd ed. New York: 
Springer.

Ratkowsky, D. A. (1990). Handbook of Nonlinear Regression Models. New York: Marcel Dekker.

Sall, J. (2002). “Monte Carlo Calibration of Distributions of Partition Statistics.” SAS Institute 
Inc.,Cary, NC. Retrieved July 29, 2015 from 
http://www.jmp.com/content/dam/jmp/documents/en/white-papers/montecarlocal.pdf.

Santer, T., Williams, B., and Notz, W. (2003). The Design and Analysis of Computer Experiments. 
New York: Springer-Verlag.

SAS Institute Inc. (2017). SAS/ETS User’s Guide, Version 14.3. Cary, NC: SAS Institute Inc. 
http://support.sas.com/documentation/onlinedoc/ets/143/etsug.pdf

Schäfer, J., and Strimmer, K. (2005). “A Shrinkage Approach to Large-Scale Covariance Matrix 
Estimation and Implications for Functional Genomics.” Statistical Applications in Genetics 
and Molecular Biology 4, Article 32.

Schuirmann, D. J. (1987). “A Comparison of the Two One-sided Tests Procedure and the Power 
Approach for Assessing the Equivalence of Average Bioavailability.” Journal of 
Pharmacokinetics and Biopharmaceutics 15:657–680.

Shiskin, J., Young, A. H., and Musgrave, J. C. (1967). The X-11 Variant of the Census Method II 
Seasonal Adjustment Program. Technical Report 15, US Department of Commerce, Bureau of 
the Census.

Shmueli, G., Patel, N. R., and Bruce, P. C. (2010). Data Mining For Business Intelligence: Concepts, 
Techniques, and Applications in Microsoft Office Excel with XLMiner. 2nd ed. Hoboken, NJ: 
John Wiley & Sons.

Shmueli, G., Bruce, P. C., Stephens M. L., and Patel, N. R. (2017). Data Mining For Business 
Intelligence: Concepts, Techniques, and Applications with JMP Pro. Hoboken, NJ: John Wiley & 
Sons.

Westfall, P. H., Tobias, R. D., and Wolfinger, R. D. (2011). Multiple Comparisons and Multiple 
Tests Using SAS. 2nd ed. Cary, NC: SAS Institute Inc.

http://repository.lib.ncsu.edu/ir/bitstream/1840.16/10572/1/etd.pdf
http://www.jmp.com/content/dam/jmp/documents/en/white-papers/montecarlocal.pdf
http://support.sas.com/documentation/onlinedoc/ets/143/etsug.pdf


Index
Specialized and Predictive Modeling

Symbols

^, redundant leaf labels 97

A
AAE 191
AAE, model comparison 191
Add Highest Nines to Missing Value Codes 

option 44
ADF tests 301
antecedent, Association Analysis 417
ApproxStdErr 236
ARIMA 307–308
ARIMA lag 321
Association Analysis

antecedent 417
association rules 417
condition 417
Frequent Item Sets report 422
lift ratio 417
Maximum Antecedents 421
Maximum Rule Size 421
Minimum Confidence 421
Minimum Lift 421
Minimum Support 421
Rules report 422
SVD 424
Topic Words Matrix 427

association rules
Association Analysis 417

AUC Comparison 193
Augmented Dickey-Fuller test 301
Autocorrelation 302

B
Bartlett’s Kolmogorov-Smirnov 325

Boston Housing.jmp 187, 194
Brown smoothing 332
By variable 358

C
Cauchy option 358
Change Highest Nines to Missing option 44
Close All Below (Partition Platform) 107
Color Points 98
Column Contributions 96
Compare Parameter Estimates 219
comparing models 191
condition, Association Analysis 417
Confidence Limits 236, 249
consequent, Association Analysis

Association Analysis
consequent 417

Contour Profiler 239
Corr option 358
Correlation Type 285
Cross Correlation 307
crossvalidation 443
Cubic 285
custom loss function 255

D
damped-trend linear exponential 

smoothing 333
decision trees 85
derivative 256–257
DFE 236
double exponential smoothing 332
Downshift Position 399

E
Entropy RSquare 192
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Equivalence Test 220
equivalence tests 353
Estimate 236
Estimate Nugget Parameter 285
Expand Intermediate Formulas 234
Expand Into Categories, selecting column 232
Explore Missing Values utility 51–60

See also Missing Value Clustering
See also Missing Value Snapshot
See also Multivariate Normal Imputation 

utility
Explore Outliers utility 37–50

examples 37, 49
See also Multivariate k-Nearest Neighbor 

Outliers utility
See also Multivariate Robust Outliers utility
See also Quantile Range Outliers utility
See also Robust Fit Outliers utility

F
False Discovery Rate 353
FDR 353
First 256
Fisher’s Kappa 325
Fit Curve 207–227
Force X Categorical option 358
Force X Continuous option 358
Force Y Categorical option 358
Force Y Continuous option 358

forecast 295–337
Forecast plot 322
Frequent Item Sets report

Association Analysis 422

G
Gaussian 285
Gaussian Process 281
Gaussian Process 284
Gauss-Newton method 255
Generalized RSquare 192
Go 239, 249
goal SSE 254
Grouping 357

H
Hessian 255
Holt smoothing 333

I
Informative Missing 102
Ingots2.jmp 247

K
K Fold Crossvalidation 96
Kappa option 358

L
lag,ARIMA 321
Largest Downshift 399
Largest Upshift 399
Leaf Report 96
Lift Curve 105, 193
lift ratio, Association Analysis 417
likelihood confidence intervals 254
linear exponential smoothing 333
Lock 107
Lock Columns

Partition platform 96
Logistic platform

example 245
Logistic w Loss.jmp 246
Loss 246
loss function

custom 255
Lower CL and Upper CL 236

M
Mahalanobis Distance 37, 46
Make SAS DATA Step 156
Make Validation Column utility 60–64
market basket analysis 415
Matched Pairs platform 339, 341

examples 341–342, 347–348
launching 342
multiple Y columns 343
options 345
report window 344–345
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statistical details 348
Tukey mean-difference plot 344–345

Max 239
Maximum Antecedents

Association Analysis 421
Maximum Rule Size

Association Analysis 421
MaxLogWorth setting 359
Mean Abs Dev 192
Mean -Log p 192
Measures of Fit report 191
Min 239
Minimum Confidence

Association Analysis 421
Minimum Lift

Association Analysis 421
Minimum Size Split 95
Minimum Support

Association Analysis 421
Minimum Theta Value 285
Misclassification Rate 192
Missing is category option 358
Missing Value Clustering 55
Missing Value Snapshot 55
missing values

codes in Explore Outliers utility 43–44
codes in Quantile Range Outliers utility 42
Explore Missing Values utility 55

Model Averaging 192
Model Comparison platform 185

example 187–189, 194–196
launch 190
options 192
report 191

Model Library 241
MSE 236
Multivariate k-Nearest Neighbor Outliers 

utility 37, 47
Multivariate Normal Imputation utility 55
Multivariate Robust Outliers utility 37, 46–47
Multivariate SVD Imputation utility 56

N
Negative Exponential.jmp 256
Neural

Boosting options 72

Confusion Matrix, Confusion Rates 
report 77

example 79
Fitting options 72
Hidden Layer Structure, Hidden Nodes 

options 71
Informative Missing option 70
launch window 70
Model Launch control panel 71
overview of networks 69
Random Seed option 71
red triangle options 78
Training report 76
Validation

Excluded Rows Holdback 72
Holdback 72
KFold 73
launch option 70
method 71
report 76

Newton-Raphson method 255
nonlinear fit options 238
nonlinear fit, setting parameter limits 250
Nonlinear Model Library 241

Customizing 244
Nonlinear platform 246

derivatives 256–257
Nonlinear platform, builtin models 205
Nonlinear platform, custom models 229–258
nonstationary time series 305
Nugget parameters 293
Number of Forecast Periods 312
Number of Points 239
NumDeriv 257
Numeric Derivatives Only 234, 248

O
Optimal Value 107
Outlier Threshold 391
Output Split Table 107

P
p, d, q parameters 307
paired t-test 339, 341
Paired X and Y option 358
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Parameter 236, 239
Parameter Contour Profiler 239
parameter limits, nonlinear fit 250
Parameter Profiler 239
Parameter Surface Profiler 239
Partial Autocorrelation 303
Partition

Informative Missing 102
Partition platform 83
periodicity 336
periodogram 331
Plot Actual by Predicted 193
Plot Actual by Predicted (Partition) 96
Plot Dif by Mean option 346
Plot Dif by Row option 346
Plot Residual by Row 193
Poisson loss function 248–250
Poisson Y option 358
Practical Difference Portion setting 359
Practical Significance 353
Predictor role 246, 249
Predictor Screening 413

options 414
report 413

Predictors report 191
probit example 247–248
Process Performance Graph 401
Process Screening

By variable 391
Grouping variable 390

profile confidence limits 254
profile likelihood confidence intervals 254
Profiler 239
Prune Below 107
Prune Worst 95, 107
Purely Random option 63
PValues data table 362, 372

Q
Q option 42
Quantile Range Outliers utility 37, 41

R
RASE 191
RASE, model comparison 191

Reference Frame option 346
Remember Solution 236
Response Screening

equivalence tests 353
False Discovery Rate 353
FDR 353
Practical Significance 353

Response Screening platform
By variable 358
Force X Categorical option 358
Force X Continuous option 358
Force Y Categorical option 358
Force Y Continuous option 358
Grouping variable 357
Kappa option 358
MaxLogWorth setting 359
Missing is category option 358
options 365
Paired X and Y option 358
Poisson Y option 358
Practical Difference Portion setting 359
PValues data table 362, 372
Robust option 358
Same Y Scale option 358
Unthreaded option 359
Weight variable 357
X variable 357
Y, Response 357

rho see loss function
RMSE 192
RMSE 236
RMSE, model comparison 192
Robust Fit Outliers utility 37, 44–46
Robust option 358
ROC Curve 193
ROC Curve 104
R-Square 191
Rules report

Association Analysis 422

S
Same Y Scale option 358
sample autocorrelation function 304
Save Cumulative Details 156
Save Inverse Prediction Formula 241
Save Leaf Label Formula 97
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Save Leaf Labels 97
Save Leaf Number Formula 97
Save Leaf Numbers 97
Save Offset Estimates 156
Save Predicted 96, 137, 155
Save Prediction Formula 97, 137, 155, 240
Save Residual Formula 240
Save Residuals 96, 138, 156
Save Specific Solving Formula 241
Save Spectral Density 311
Save Std Error of Individual 240
Save Std Error of Predicted 240
Save Tolerant Prediction Formula 97
Save Tree Details 156
Seasonal ARIMA 308, 336
seasonal ARIMA factor 321
seasonal exponential smoothing 334
seasonal smoothing weight 332
Second Derivatives 234
Select Rows 107
Set Alpha Level option

for Matched Pairs 346
Shift detection, Process Screening 401
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