Quality and Process Methods

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust
Other brand and product names are trademarks of their respective companies.

SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to http://support.sas.com/thirdpartylicenses.

**Technology License Notices**

- Scintilla - Copyright © 1998-2017 by Neil Hodgson <neilh@scintilla.org>. All Rights Reserved.
  
  Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation.
  
  **NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.**

- Telerik RadControls: Copyright © 2002-2012, Telerik. Usage of the included Telerik RadControls outside of JMP is not permitted.


- Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.

- Packages - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved.
  
  Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
  
  Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  
  Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  
  Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• iODBC software - Copyright © 1995-2006, OpenLink Software Inc and Ke Jin (www.iodbc.org). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

– Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

– Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

– Neither the name of OpenLink Software Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• bzip2, the associated library “libbzip2“, and all documentation, are Copyright © 1996-2010, Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.
- libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and / or other materials provided with the distribution.
– Neither the name of Florian Reuter nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar license but with different Copyright notices) all the files are:

Copyright © 1998 - 2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

- Regarding the decompression algorithm used for UNIX files:

The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

• Snowball - Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton.
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be
used to endorse or promote products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:

- live and recorded webcasts about how to get started with JMP
- video demos and webcasts of new features and advanced techniques
- details on registering for JMP training
- schedules for seminars being held in your area
- success stories showing how others use JMP
- a blog with tips, tricks, and stories from JMP staff
- a forum to discuss JMP with other users

http://www.jmp.com/getstarted/
## Contents

### Quality and Process Methods

1. **Learn about JMP**
   - Documentation and Additional Resources
     - Formatting Conventions ........................................... 19
     - JMP Documentation ............................................. 20
       - JMP Documentation Library .................................. 20
       - JMP Help ..................................................... 26
     - Additional Resources for Learning JMP ......................... 26
       - Tutorials .................................................... 26
       - Sample Data Tables .......................................... 27
       - Learn about Statistical and JSL Terms ....................... 27
       - Learn JMP Tips and Tricks .................................. 27
       - Tooltips ..................................................... 27
     - JMP User Community .......................................... 28
     - JMP Books by Users .......................................... 28
     - The JMP Starter Window ...................................... 28
     - Technical Support ............................................ 29

2. **Introduction to Quality and Process Methods**
   - Tools for Process and Product Improvement ...................... 31

3. **Control Chart Builder**
   - Create Control Charts Interactively
     - Overview of the Control Chart Builder ......................... 35
     - Example of the Control Chart Builder .......................... 35
     - Control Chart Types .......................................... 37
       - Shewhart Control Charts for Variables ....................... 37
       - Shewhart Control Charts for Attributes ....................... 38
       - Rare Event Control Charts .................................. 39
       - Control Chart Types ........................................ 40
     - Launch the Control Chart Builder ................................ 43
     - The Control Chart Builder Window .............................. 45
     - Control Chart Builder Options ................................ 46
       - Red Triangle Menu Options .................................. 47
Options Panel and Right-Click Chart Options .......................................................... 48
Right-Click Axis Options ......................................................................................... 57
Work with Control Limits ....................................................................................... 57
  Example of Control Limits .................................................................................... 58
Excluded and Hidden Samples ............................................................................... 66
  Additional Examples of the Control Chart Builder ............................................. 67
    X-Bar and R Chart Phase Example ................................................................. 67
    p-chart Example .............................................................................................. 70
    np-chart Example ........................................................................................... 72
    c-chart Example ............................................................................................. 73
    u-chart Example ............................................................................................. 75
    g-chart Example ............................................................................................. 76
    t-chart Example ............................................................................................. 77
    3-Way Chart Example ..................................................................................... 78
Statistical Details for the Control Chart Builder Platform ...................................... 80
  Control Limits for X-bar and R-charts ............................................................... 81
  Control Limits for X-bar and S-charts ............................................................... 82
  Control Limits for Individual Measurement and Moving Range Charts ............. 83
  Control Limits for p- and np-charts .................................................................. 83
  Control Limits for u-charts and c-charts ........................................................... 84
  Levey-Jennings Charts ...................................................................................... 85
  Control Limits for g-charts ................................................................................ 85
  Control Limits for t-charts ............................................................................... 86
  Control Limits for 3-way charts ..................................................................... 86

4 Shewhart Control Charts
Create Variable and Attribute Control Charts .................................................... 89
  Overview of the Control Chart Platform .......................................................... 91
  Example of the Control Chart Platform .......................................................... 91
  Shewhart Control Chart Types ...................................................................... 93
    Control Charts for Attributes ...................................................................... 94
  Launch the Control Chart Platform .................................................................. 96
    Process Information ....................................................................................... 97
    Chart Type Information ............................................................................... 99
    Limits Specifications ..................................................................................... 99
    Specified Statistics ..................................................................................... 100
  The Control Chart Report ............................................................................... 101
  Control Chart Platform Options ..................................................................... 103
    Control Chart Window Options .................................................................. 103
    Individual Control Chart Options .............................................................. 106
5 CUSUM Control Charts

Create Tabular CUSUM Control Charts with Decision Limits

Overview of the CUSUM Control Chart Platform ................................. 133
Example of CUSUM Control Chart ....................................................... 133
Launch the CUSUM Control Chart Platform ........................................ 134
The CUSUM Control Chart Platform Report ...................................... 135
  Control Panel .................................................................................. 136
  CUSUM Chart ................................................................................ 137
CUSUM Control Chart Platform Options ............................................. 137
  Average Run Length (ARL) Report .................................................. 139
Additional Example of CUSUM Control Charts .................................. 140
  Example of the Data Units Option ..................................................... 140
  Example of CUSUM Chart with Subgroups ...................................... 141
Statistical Details for the CUSUM Control Chart Platform ................. 142
  Statistical Details for CUSUM Control Chart Construction ................ 142
  Statistical Details for Shift Detection ............................................... 144
  Statistical Details for Average Run Length ...................................... 144

6 V-Mask CUSUM Control Charts

Use a V-Mask to Detect Small Shifts in the Process Mean

Overview of V-Mask CUSUM Control Charts .................................. 147
## 7 Multivariate Control Charts

Monitor Multiple Process Characteristics Simultaneously

- Overview of Multivariate Control Charts .................................................. 163
- Example of a Multivariate Control Chart .................................................. 163
  - Step 2: Save Target Statistics .................................................................. 164
  - Step 3: Monitor the Process .................................................................... 164
- Launch the Multivariate Control Chart Platform ........................................ 165
- The Multivariate Control Chart ................................................................. 166
- Multivariate Control Chart Platform Options ............................................. 168
  - T Square Partitioned .............................................................................. 169
  - Change Point Detection ......................................................................... 169
  - Principal Components ........................................................................... 170
- Additional Examples of Multivariate Control Charts ................................. 171
  - Example of Monitoring a Process Using Sub-Grouped Data ................. 171
  - Example of T Square Partitioned ......................................................... 174
  - Example of Change Point Detection .................................................... 176
- Statistical Details for Multivariate Control Charts ..................................... 177
  - Statistical Details for Individual Observations ...................................... 178
  - Statistical Details for Observations in Rational Subgroups .................... 179
  - Statistical Details for Change Point Detection ...................................... 182

## 8 Measurement Systems Analysis

Evaluate a Continuous Measurement Process Using the EMP Method

- Overview of Measurement Systems Analysis .......................................... 189
- Example of Measurement Systems Analysis .......................................... 189
- Launch the Measurement Systems Analysis Platform ............................ 192
- Measurement Systems Analysis Platform Options .................................. 194
  - Average Chart ....................................................................................... 196
  - Range Chart or Standard Deviation Chart ............................................. 197
  - EMP Results ......................................................................................... 197
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Effective Resolution</td>
<td>199</td>
</tr>
<tr>
<td>Shift Detection Profiler</td>
<td>199</td>
</tr>
<tr>
<td>Bias Comparison</td>
<td>204</td>
</tr>
<tr>
<td>Test-Retest Error Comparison</td>
<td>205</td>
</tr>
<tr>
<td>Additional Example of Measurement Systems Analysis</td>
<td>205</td>
</tr>
<tr>
<td>Statistical Details for Measurement Systems Analysis</td>
<td>211</td>
</tr>
<tr>
<td><strong>9 Variability Gauge Charts</strong></td>
<td>213</td>
</tr>
<tr>
<td>Evaluate a Continuous Measurement Process Using Gauge R&amp;R</td>
<td></td>
</tr>
<tr>
<td>Overview of Variability Charts</td>
<td>215</td>
</tr>
<tr>
<td>Example of a Variability Chart</td>
<td>216</td>
</tr>
<tr>
<td>Launch the Variability/Attribute Gauge Chart Platform</td>
<td>217</td>
</tr>
<tr>
<td>The Variability Gauge Chart</td>
<td>218</td>
</tr>
<tr>
<td>Variability Gauge Platform Options</td>
<td>220</td>
</tr>
<tr>
<td>Heterogeneity of Variance Tests</td>
<td>222</td>
</tr>
<tr>
<td>Variance Components</td>
<td>223</td>
</tr>
<tr>
<td>About the Gauge R&amp;R Method</td>
<td>225</td>
</tr>
<tr>
<td>Gauge R&amp;R Option</td>
<td>226</td>
</tr>
<tr>
<td>Discrimination Ratio</td>
<td>229</td>
</tr>
<tr>
<td>Misclassification Probabilities</td>
<td>229</td>
</tr>
<tr>
<td>Bias Report</td>
<td>230</td>
</tr>
<tr>
<td>Linearity Study</td>
<td>230</td>
</tr>
<tr>
<td>Additional Examples of Variability Charts</td>
<td>231</td>
</tr>
<tr>
<td>Example of the Heterogeneity of Variance Test</td>
<td>231</td>
</tr>
<tr>
<td>Example of the Bias Report Option</td>
<td>233</td>
</tr>
<tr>
<td>Statistical Details for Variability Charts</td>
<td>236</td>
</tr>
<tr>
<td>Statistical Details for Variance Components</td>
<td>236</td>
</tr>
<tr>
<td>Statistical Details for the Discrimination Ratio</td>
<td>237</td>
</tr>
<tr>
<td><strong>10 Attribute Gauge Charts</strong></td>
<td>239</td>
</tr>
<tr>
<td>Evaluate a Categorical Measurement Process Using Agreement Measures</td>
<td></td>
</tr>
<tr>
<td>Overview of Attribute Gauge Charts</td>
<td>241</td>
</tr>
<tr>
<td>Example of an Attribute Gauge Chart</td>
<td>241</td>
</tr>
<tr>
<td>Launch the Variability/Attribute Gauge Chart Platform</td>
<td>242</td>
</tr>
<tr>
<td>The Attribute Gauge Chart and Reports</td>
<td>244</td>
</tr>
<tr>
<td>Agreement Reports</td>
<td>245</td>
</tr>
<tr>
<td>Effectiveness Report</td>
<td>246</td>
</tr>
<tr>
<td>Attribute Gauge Platform Options</td>
<td>248</td>
</tr>
<tr>
<td>Statistical Details for Attribute Gauge Charts</td>
<td>249</td>
</tr>
<tr>
<td>Statistical Details for the Agreement Report</td>
<td>251</td>
</tr>
</tbody>
</table>
## 11 Process Capability

Measure the Variability of a Process over Time

Overview of the Process Capability Platform .................................................. 255
Example of the Process Capability Platform with Normal Variables .................. 257
Example of the Process Capability Platform with Nonnormal Variables ............. 259
Launch the Process Capability Platform ......................................................... 264
  Process Selection .................................................................................. 266
  Process Subgrouping ........................................................................ 266
  Historical Information ...................................................................... 267
  Distribution Options ........................................................................ 267
  Other Specifications .......................................................................... 269
Entering Specification Limits ........................................................................... 269
  Spec Limits Window .......................................................................... 269
  Limits Data Table ............................................................................ 270
  Spec Limits Column Property ............................................................. 271
The Process Capability Report ......................................................................... 272
  Goal Plot ......................................................................................... 273
  Capability Box Plots ...................................................................... 276
  Capability Index Plot ...................................................................... 278
Process Capability Platform Options .............................................................. 280
  Individual Detail Reports ................................................................... 283
  Normalized Box Plots ...................................................................... 290
  Process Performance Plot ................................................................ 291
  Summary Reports ............................................................................ 292
  Make Goal Plot Summary Table ......................................................... 293
Additional Examples of the Process Capability Platform ................................... 294
  Process Capability for a Stable Process .............................................. 294
  Process Capability for an Unstable Process ......................................... 298
Simulation of Confidence Limits for a Nonnormal Process Ppk ....................... 302
Statistical Details for the Process Capability Platform ..................................... 308
  Variation Statistics .......................................................................... 308
  Notation for Goal Plots and Capability Box Plots ............................... 311
  Goal Plot ....................................................................................... 311
  Capability Box Plots for Processes with Missing Targets .................... 313
  Capability Indices for Normal Distributions ....................................... 314
  Capability Indices for Nonnormal Distributions: Percentile and Z-Score Methods .......... 317
  Parameterizations for Distributions .................................................... 319
12 Pareto Plots

Focus Improvement Efforts on the Vital Few

Overview of the Pareto Plot Platform .......................... 325
Example of the Pareto Plot Platform .......................... 325
Launch the Pareto Plot Platform .......................... 328
The Pareto Plot Report .......................... 329
Pareto Plot Platform Options .......................... 330
  Causes Options .......................... 332
Additional Examples of the Pareto Plot Platform .......................... 332
  Threshold of Combined Causes Example .......................... 333
  Using a Constant Size across Groups Example .......................... 334
  Using a Non-Constant Sample Size across Groups Example .......................... 335
One-Way Comparative Pareto Plot Example .......................... 337
Two-Way Comparative Pareto Plot Example .......................... 339
Statistical Details for the Pareto Plot Platform .......................... 340

13 Cause-and-Effect Diagrams

Identify Root Causes

Overview of Cause-and-Effect Diagrams .......................... 345
Example of a Cause-and-Effect Diagram .......................... 345
Prepare the Data .......................... 346
Launch the Diagram Platform .......................... 346
The Cause-and-Effect Diagram .......................... 347
  Right-Click Menus .......................... 347
Save the Diagram .......................... 350
  Save the Diagram as a Data Table .......................... 351
  Save the Diagram as a Journal .......................... 351
  Save the Diagram as a Script .......................... 351

A Statistical Details

Quality and Process Methods

Manage Spec Limits Utility .......................... 355
  Manage Spec Limits Options .......................... 357

B References

Index

Quality and Process Methods
Chapter 1

Learn about JMP
Documentation and Additional Resources

This chapter includes details about JMP documentation, such as book conventions, descriptions of each JMP book, the Help system, and where to find other support.
Contents

Formatting Conventions ................................................................. 19
JMP Documentation ........................................................................ 20
  JMP Documentation Library ......................................................... 20
  JMP Help ....................................................................................... 26
Additional Resources for Learning JMP .......................................... 26
  Tutorials ....................................................................................... 26
  Sample Data Tables ...................................................................... 27
  Learn about Statistical and JSL Terms ......................................... 27
  Learn JMP Tips and Tricks ............................................................ 27
  Tooltips ......................................................................................... 27
  JMP User Community ................................................................... 28
  JMP Books by Users ................................................................... 28
  The JMP Starter Window .............................................................. 28
Technical Support .......................................................................... 29
Formatting Conventions

The following conventions help you relate written material to information that you see on your screen:

- Sample data table names, column names, pathnames, filenames, file extensions, and folders appear in *Helvetica* font.
- Code appears in *Lucida Sans Typewriter* font.
- Code output appears in *Lucida Sans Typewriter* italic font and is indented farther than the preceding code.
- **Helvetica bold** formatting indicates items that you select to complete a task:
  - buttons
  - check boxes
  - commands
  - list names that are selectable
  - menus
  - options
  - tab names
  - text boxes
- The following items appear in italics:
  - words or phrases that are important or have definitions specific to JMP
  - book titles
  - variables
- Features that are for JMP Pro only are noted with the JMP Pro icon. For an overview of JMP Pro features, visit [https://www.jmp.com/software/pro/](https://www.jmp.com/software/pro/).

**Note:** Special information and limitations appear within a Note.

**Tip:** Helpful information appears within a Tip.
JMP Documentation

JMP offers documentation in various formats, from print books and Portable Document Format (PDF) to electronic books (e-books).

- Open the PDF versions from the Help > Books menu.
- All books are also combined into one PDF file, called JMP Documentation Library, for convenient searching. Open the JMP Documentation Library PDF file from the Help > Books menu.
- You can also purchase printed documentation and e-books on the SAS website: https://www.sas.com/store/search.ep?keyWords=JMP

JMP Documentation Library

The following table describes the purpose and content of each book in the JMP library.

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discovering JMP</td>
<td>If you are not familiar with JMP, start here.</td>
<td>Introduces you to JMP and gets you started creating and analyzing data. Also learn how to share your results.</td>
</tr>
<tr>
<td>Using JMP</td>
<td>Learn about JMP data tables and how to perform basic operations.</td>
<td>Covers general JMP concepts and features that span across all of JMP, including importing data, modifying columns properties, sorting data, and connecting to SAS.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Basic Analysis</td>
<td>Perform basic analysis using this document.</td>
<td>Describes these Analyze menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Distribution</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Y by X</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Tabulate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Text Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Covers how to perform bivariate, one-way ANOVA, and contingency analyses through Analyze &gt; Fit Y by X. How to approximate sampling distributions using bootstrapping and how to perform parametric resampling with the Simulate platform are also included.</td>
</tr>
<tr>
<td>Essential Graphing</td>
<td>Find the ideal graph for your data.</td>
<td>Describes these Graph menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Graph Builder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scatterplot 3D</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Contour Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bubble Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Parallel Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cell Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scatterplot Matrix</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ternary Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Treemap</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Chart</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Overlay Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The book also covers how to create background and custom maps.</td>
</tr>
<tr>
<td>Profilers</td>
<td>Learn how to use interactive profiling tools, which enable you to view cross-sections of any response surface.</td>
<td>Covers all profilers listed in the Graph menu. Analyzing noise factors is included along with running simulations using random inputs.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>------------------------------</td>
<td>----------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Design of Experiments Guide</td>
<td>Learn how to design experiments and determine appropriate sample sizes.</td>
<td>Covers all topics in the DOE menu and the Specialized DOE Models menu item in the Analyze &gt; Specialized Modeling menu.</td>
</tr>
<tr>
<td>Fitting Linear Models</td>
<td>Learn about Fit Model platform and many of its personalities.</td>
<td>Describes these personalities, all available within the Analyze menu Fit Model platform:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Standard Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Stepwise</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Regression</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Mixed Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MANOVA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Loglinear Variance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nominal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ordinal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Linear Model</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><em>Predictive and Specialized Modeling</em></td>
<td>Learn about additional modeling techniques.</td>
<td>Describes these Analyze &gt; Predictive Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Modeling Utilities</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Neural</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bootstrap Forest</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Boosted Tree</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Nearest Neighbors</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Naive Bayes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Model Comparison</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Formula Depot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Specialized Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Curve</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nonlinear</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Functional Data Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Gaussian Process</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Time Series</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Matched Pairs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Screening menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Response Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Predictor Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Association Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process History Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The platforms in the Analyze &gt; Specialized Modeling &gt; Specialized DOE Models menu are described in <em>Design of Experiments Guide</em>.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>---------------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Multivariate Methods</strong></td>
<td>Read about techniques for analyzing several variables simultaneously.</td>
<td>Describes these Analyze &gt; Multivariate Methods menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multivariate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Principal Components</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Discriminant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partial Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multiple Correspondence Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Factor Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multidimensional Scaling</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Item Analysis</td>
</tr>
<tr>
<td><strong>Quality and Process Methods</strong></td>
<td>Read about tools for evaluating and improving processes.</td>
<td>Describes these Analyze &gt; Clustering menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Hierarchical Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Means Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Normal Mixtures</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latent Class Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cluster Variables</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Quality and Process menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Control Chart Builder and individual control charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Measurement Systems Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Variability / Attribute Gauge Charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process Capability</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Pareto Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Diagram</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Manage Spec Limits</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-----------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Reliability and Survival Methods</td>
<td>Learn to evaluate and improve reliability in a product or system and analyze survival data for people and products.</td>
<td>Describes these Analyze &gt; Reliability and Survival menu platforms: • Life Distribution • Fit Life by X • Cumulative Damage • Recurrence Analysis • Degradation and Destructive Degradation • Reliability Forecast • Reliability Growth • Reliability Block Diagram • Repairable Systems Simulation • Survival • Fit Parametric Survival • Fit Proportional Hazards</td>
</tr>
<tr>
<td>Consumer Research</td>
<td>Learn about methods for studying consumer preferences and using that insight to create better products and services.</td>
<td>Describes these Analyze &gt; Consumer Research menu platforms: • Categorical • Choice • MaxDiff • Uplift • Multiple Factor Analysis</td>
</tr>
<tr>
<td>Scripting Guide</td>
<td>Learn about taking advantage of the powerful JMP Scripting Language (JSL).</td>
<td>Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications.</td>
</tr>
<tr>
<td>JSL Syntax Reference</td>
<td>Read about many JSL functions on functions and their arguments, and messages that you send to objects and display boxes.</td>
<td>Includes syntax, examples, and notes for JSL commands.</td>
</tr>
</tbody>
</table>
Learn about JMP

Chapter 1

Additional Resources for Learning JMP

Note: The Books menu also contains two reference cards that can be printed: The Menu Card describes JMP menus, and the Quick Reference describes JMP keyboard shortcuts.

JMP Help

JMP Help is an abbreviated version of the documentation library that provides targeted information. You can open JMP Help in several ways:

• On Windows, press the F1 key to open the Help system window.
• Get help on a specific part of a data table or report window. Select the Help tool 🕵️‍♂️ from the Tools menu and then click anywhere in a data table or report window to see the Help for that area.
• Within a JMP window, click the Help button.
• Search and view JMP Help on Windows using the Help > Help Contents, Search Help, and Help Index options. On Mac, select Help > JMP Help.
• Search the Help at https://jmp.com/support/help/ (English only).

Additional Resources for Learning JMP

In addition to JMP documentation and JMP Help, you can also learn about JMP using the following resources:

• “Tutorials”
• “Sample Data Tables”
• “Learn about Statistical and JSL Terms”
• “Learn JMP Tips and Tricks”
• “Tooltips”
• “JMP User Community”
• “JMP Books by Users”
• “The JMP Starter Window”

Tutorials

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, then start with the Beginners Tutorial. It steps you through the JMP interface and explains the basics of using JMP.
The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment and comparing a sample mean to a constant.

**Sample Data Tables**

All of the examples in the JMP documentation suite use sample data. Select Help > Sample Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories, select Help > Sample Data.

Sample data tables are installed in the following directory:

- On Windows: C:\Program Files\SAS\JMP\14\Samples\Data
- On Macintosh: \Library\Application Support\JMP\14\Samples\Data

In JMP Pro, sample data is installed in the JMP PRO (rather than JMP) directory. In JMP Shrinkwrap, sample data is installed in the JMP SW directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching Resources section. To learn more about the teaching resources, visit [http://jmp.com/tools](http://jmp.com/tools).

**Learn about Statistical and JSL Terms**

The Help menu contains the following indexes:

- **Statistics Index**  Provides definitions of statistical terms.
- **Scripting Index**  Lets you search for information about JSL functions, objects, and display boxes. You can also edit and run sample scripts from the Scripting Index.

**Learn JMP Tips and Tricks**

When you first start JMP, you see the Tip of the Day window. This window provides tips for using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select Help > Tip of the Day. Or, you can turn it off using the Preferences window.

**Tooltips**

JMP provides descriptive tooltips when you place your cursor over items, such as the following:

- Menu or toolbar options
• Labels in graphs
• Text results in the report window (move your cursor in a circle to reveal)
• Files or windows in the Home Window
• Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences > General and then deselect Show menu tips. This option is not available on Macintosh.

JMP User Community

The JMP User Community provides a range of options to help you learn more about JMP and connect with other JMP users. The learning library of one-page guides, tutorials, and demos is a good place to start. And you can continue your education by registering for a variety of JMP training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, and social networking groups.

To access JMP resources on the website, select Help > JMP User Community or visit https://community.jmp.com/.

JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP website:


The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus. The window also lists JMP Pro features and platforms.

• To open the JMP Starter window, select View (Window on the Macintosh) > JMP Starter.
• To display the JMP Starter automatically when you open JMP on Windows, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list. On Macintosh, select JMP > Preferences > Initial JMP Starter Window.
Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP, many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at https://www.jmp.com/support, including the technical support phone number.
Chapter 2

Introduction to Quality and Process Methods
Tools for Process and Product Improvement

This book describes a number of methods and tools that are available in JMP to help you evaluate and improve quality and process performance:

- Control charts provide feedback on key variables and show when a process is in, or out of, statistical control. Chapter 3, “Control Chart Builder” and Chapter 4, “Shewhart Control Charts” describe the JMP approach to creating control charts, including an interactive control chart platform called Control Chart Builder. Chapter 5, “CUSUM Control Charts” describes decision-making based on cumulative sum control charts. When you need to detect smaller shifts in a process or monitor multiple process characteristics simultaneously, see Chapter 6, “V-Mask CUSUM Control Charts” and Chapter 7, “Multivariate Control Charts” respectively.

- The Measurement Systems Analysis platform assesses the precision, consistency, and bias of a system. Before you can study a process, you need to make sure that you can accurately and precisely measure the process. If variation comes from the process itself, then you are not reliably learning about the process. Use this analysis to find out how your system is performing. For more information, see Chapter 8, “Measurement Systems Analysis”.

- The Variability/Attribute Gauge Chart platform creates variability or attribute gauge charts. Variability charts analyze continuous measurements and reveal how your system is performing. Attribute charts analyze categorical measurements and show you measures of agreement across responses. You can also perform a gauge study to see measures of variation in your data. For more information, see Chapter 9, “Variability Gauge Charts” and Chapter 10, “Attribute Gauge Charts” respectively.

- The Process Capability platform measures the ability of a process to meet specification limits. You can compare process performance, summarized by process centering and variability, to specification limits. The platform calculates capability indices based on both long-term and short-term variation. The analysis helps identify the variation relative to the specifications; this enables you to achieve increasingly higher conformance values. For more information, see Chapter 11, “Process Capability”.

- The Pareto Plot platform shows the frequency of problems in a quality related process or operation. Pareto plots help you decide which problems to solve first by highlighting the frequency and severity of problems. For more information, see Chapter 12, “Pareto Plots”.

- The Diagram platform constructs cause-and-effect diagrams, which organize the sources of a problem for brainstorming or as a preliminary analysis to identify variables for further
experimentation. Once complete, further analysis can be done to identify the root cause of the problem. For more information, see Chapter 13, “Cause-and-Effect Diagrams”.
A control chart is a graphical and analytic tool for monitoring process variation. Use Control Chart Builder to create control charts of your process data. Select the variables that you want to chart and drag them into zones. JMP automatically chooses the appropriate chart type based on the data. The instant feedback encourages further exploration of the data. You can change your mind and quickly create another type of chart, or change the current settings on the existing chart.

Figure 3.1 Control Chart Builder Example
Contents

Overview of the Control Chart Builder .......................................................... 35
Example of the Control Chart Builder ............................................................ 35
Control Chart Types ...................................................................................... 37
  Shewhart Control Charts for Variables ................................................. 37
  Shewhart Control Charts for Attributes ............................................. 38
  Rare Event Control Charts ................................................................... 39
  Control Chart Types .............................................................................. 40
Launch the Control Chart Builder ................................................................. 43
The Control Chart Builder Window .............................................................. 45
Control Chart Builder Options ................................................................. 46
  Red Triangle Menu Options ................................................................. 47
  Options Panel and Right-Click Chart Options .................................... 48
  Right-Click Axis Options ...................................................................... 57
Work with Control Limits ............................................................................ 57
  Example of Control Limits .................................................................... 58
Excluded and Hidden Samples ..................................................................... 66
Additional Examples of the Control Chart Builder ................................. 67
  X-Bar and R Chart Phase Example ....................................................... 67
  p-chart Example .................................................................................. 70
  np-chart Example ............................................................................... 72
  c-chart Example .................................................................................. 73
  u-chart Example .................................................................................. 75
  g-chart Example .................................................................................. 76
  t-chart Example ................................................................................... 77
  3-Way Chart Example .......................................................................... 78
Statistical Details for the Control Chart Builder Platform ..................... 80
  Control Limits for X-bar and R-charts .................................................. 81
  Control Limits for X-bar and S-charts .................................................. 82
  Control Limits for Individual Measurement and Moving Range Charts .............................................................................. 83
  Control Limits for p- and np-charts ....................................................... 83
  Control Limits for u-charts and c-charts ............................................ 84
  Levey-Jennings Charts ......................................................................... 85
  Control Limits for g-charts .................................................................... 85
  Control Limits for t-charts .................................................................... 86
  Control Limits for 3-way charts ............................................................ 86
Overview of the Control Chart Builder

A control chart is a graphical way to filter out routine variation in a process. Filtering out routine variation helps manufacturers and other businesses determine whether a process is stable and predictable. If the variation is more than routine, the process can be adjusted to create higher quality output at a lower cost.

This version of JMP continues a shift in the approach to control charts. We are moving toward an all-in-one, interactive workspace called the Control Chart Builder. The Control Chart Builder enables you to create several types of control charts (Shewhart Variables, Shewhart Attribute, and Rare Event) and is intended to be an interactive tool for problem solving and process analysis. Shewhart control charts are broadly classified into control charts for variables and control charts for attributes. Rare event charts are useful for events that occur so infrequently that a traditional chart is inappropriate.

To use Control Chart Builder, you do not need to know the name of a particular chart beforehand. When you drag a data column to the workspace, Control Chart Builder creates an appropriate chart based on the data type and sample size. Once the basic chart is created, use the menus and other options to:

- Change the type of chart. You can switch between Attribute, Variables, and Rare Event charts without relaunching the platform.
- Change the statistic on the chart. You can add, remove, and switch variables without relaunching the platform.
- Format the chart and create subgroups that are defined by multiple X variables.
- Add additional charts, including three-in-one charts: subgroup means, within-subgroup variation, and between-subgroup variation.

Example of the Control Chart Builder

This example uses the Socket Thickness.jmp sample data table, which includes measurements for the thickness of sockets. There has been an increase in the number of defects during production and you want to investigate why this is occurring. Use Control Chart Builder to investigate the variability in the data and the control of the process.

1. Select Help > Sample Data Library and open Quality Control/Socket Thickness.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Thickness to the Y zone.
4. Drag Hour to the Subgroup zone (at bottom).
**Figure 3.2** Control Charts for Socket Thickness

Looking at the Average chart, you can see that there are several points below the lower control limit of 7.788772. You want to see whether another variable might be contributing to the problem.

5. Drag Cavity into the **Phase** zone.

**Figure 3.3** Control Charts for Each Cavity
From the Average chart, you can conclude the following:

- There are differences between the cavities, each deserving separate control limits.
- Cavity 1 is producing sockets with a higher average thickness, indicating that further investigation of the differences between cavities is warranted.
- All of the cavities have points that are outside the control limits. Therefore, you should investigate the lack of control in the data for each cavity.

The Range chart for each cavity shows that the within-subgroup measurements are in control.

**Control Chart Types**

The Control Chart Builder (CCB) enables you to create several types of control charts (Shewhart Variables, Shewhart Attribute, and Rare Event). To create a chart, you do not need to know the name or structure of a particular chart beforehand. Select the variables (or columns) that you want to chart, and then drag and drop them into zones. When you drag a data column to the workspace, Control Chart Builder creates an appropriate chart based on the data type and sample size. Once the basic chart is created, you can use the menus and other options to change the type, the statistic, and the format of the chart.

**Shewhart Control Charts for Variables**

Control charts for variables are classified according to the subgroup summary statistic plotted on the chart.

- $\bar{X}$-charts display subgroup means (averages) and are referred to as location charts.
- $R$-charts display subgroup ranges (maximum – minimum) and are referred to as dispersion charts.
- $S$-charts display subgroup standard deviations.
- Presummarize charts display subgroup means and standard deviations.
- Individual Measurement charts display individual measurements.
- Moving Range charts display moving ranges of two successive measurements.

**Note:** If you remove a dispersion chart or turn off the preference Show Two Shewhart Charts, you'll see only the location chart. Any associated scripts will contain the JSL option Show Two Shewhart Charts set to off (0).
XBar-, R-, and S- Charts

For quality characteristics measured on a continuous scale, a typical analysis shows both the process mean and its variability with a mean chart aligned above its corresponding R- or S-chart.

Individual Measurement Charts

Individual Measurement charts displays individual measurements. Individual Measurement charts are appropriate when only one measurement is available for each subgroup sample. If you are charting individual measurements, the individual measurement chart shows above its corresponding moving range chart. Moving Range charts displays moving ranges of two successive measurements.

Presummarize Charts

If your data consist of repeated measurements of the same process unit, you can combine these into one measurement for the unit. Pre-summarizing is not recommended unless the data have repeated measurements on each process or measurement unit.

Presummarize summarizes the process column into sample means and/or standard deviations, based either on the sample size or sample label chosen. Then it charts the summarized data based on the options chosen in the window.

Levey-Jennings Charts

Levey-Jennings charts show a process mean with control limits based on a long-term sigma. The control limits are placed at 3σ distance from the center line. The standard deviation, $s$, for the Levey-Jennings chart is calculated the same way standard deviation is in the Distribution platform.

Shewhart Control Charts for Attributes

In the previous types of charts, measurement data was the process variable. This data is often continuous, and the charts are based on theory for continuous data. Another type of data is count data or level counts of character data, where the variable of interest is a discrete count of the number of defects or blemishes per subgroup. For discrete count data, attribute charts are applicable, as they are based on binomial and Poisson models. Because the counts are measured per subgroup, it is important when comparing charts to determine whether you have a similar number of items in the subgroups between the charts. Attribute charts, like variables charts, are classified according to the subgroup sample statistic plotted on the chart.
The CCB makes a few decisions for you based on the variable selected. For example, if there is no X variable, a c-chart is originally created because there is no way to estimate the binomial distributions. Upon adding an X variable (or lot size), the platform switches to a np-chart if the count per subgroup is less than the subgroup sample size. Once the basic chart is created, you can use the menus and other options to change the type, the statistic, and the format of the chart.

- p-charts display the proportion of nonconforming (defective) items in subgroup samples, which can vary in size. Because each subgroup for a p-chart consists of $N_i$ items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in a subgroup is $N_i$.
- np-charts display the number of nonconforming (defective) items in subgroup samples. Because each subgroup for a np-chart consists of $N_i$ items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in subgroup $i$ is $N_i$.
- c-charts display the number of nonconformities (defects) in a subgroup sample that usually, but does not necessarily, consists of one inspection unit.
- u-charts display the number of nonconformities (defects) per unit in subgroup samples that can have a varying number of inspection units.

### Rare Event Control Charts

A Rare Event chart is a control chart that provides information about a process where the data comes from rarely occurring events. Tracking processes that occur infrequently on a traditional control chart tend to be ineffective. Rare event charts were developed in response to the limitations of control charts in rare event scenarios. The Control Chart Builder provides two types of rare event charts (g- and t-charts).

A g-chart is used to count the number of events between rarely occurring errors or nonconforming incidents, and creates a chart of a process over time. Each point represents the number of units between occurrences of a relatively rare event. For example, in a production setting, where an item is produced daily, an unexpected line shutdown can occur. You can use

<table>
<thead>
<tr>
<th>Statistic</th>
<th>Sigma</th>
<th>Proportion</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binomial</td>
<td>p-chart</td>
<td>np-chart</td>
<td></td>
</tr>
<tr>
<td>Poisson</td>
<td>u-chart</td>
<td>c-chart</td>
<td></td>
</tr>
</tbody>
</table>

### Table 3.1  Attribute Chart Determination
a g-chart to look at the number of units produced between line shutdowns. A traditional plot of data such as this is not conducive to control chart interpretation. The g-chart helps visualize such data in traditional control chart form.

A t-chart measures the time elapsed since the last event and creates a picture of a process over time. Each point on the chart represents an amount of time that has passed since a prior occurrence of a rare event. A traditional plot of this data might contain many points at zero and an occasional point at one. A t-chart avoids flagging numerous points as out of control. The t-chart helps identify special and common cause variation, so that appropriate improvements can be made.

A t-chart can be used for numeric, nonnegative data, date/time data, and time-between data:

- Numeric, nonnegative data contain the number of intervals between events. The number of intervals can be continuous or integer-valued.
- Date/time data contain records of the date and time of each event. Each data value must be greater than or equal to the preceding value.
- Time-between data (also known as elapsed-time data) represent the elapsed time between event $i$ and event $i-1$.

Like the g-chart, the t-chart is used to detect changes in the rate at which the adverse event occurs. When reading the t-chart, the points above the upper control limit indicate that the amount of time between events has increased. Thus, the rate of the events has decreased. Points below the lower control limit indicate that the rate of adverse events has increased.

Because of how time is measured for these charts, one fundamental difference is that a point flagged as out of control above the limits is generally considered a desirable effect because it represents a significant increase in the time between events. The difference between a g- and t-chart is the scale used to measure distance between events. The g-chart uses a discrete scale, whereas the t-chart uses a continuous scale.

<table>
<thead>
<tr>
<th>Table 3.2 Rare Event Chart Determination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Statistic</td>
</tr>
<tr>
<td>Sigma</td>
</tr>
<tr>
<td>Count</td>
</tr>
<tr>
<td>Negative Binomial</td>
</tr>
<tr>
<td>g-chart</td>
</tr>
<tr>
<td>Weibull</td>
</tr>
<tr>
<td>t-chart</td>
</tr>
</tbody>
</table>

**Control Chart Types**

The most common control charts are available in the Control Chart Builder and in the Control Chart platform. Use the Control Chart Builder as your first choice to easily and quickly
generate charts. JMP automatically chooses the appropriate chart type based on the data. Table 3.3 through Table 3.7 summarize the different control chart types.

**Table 3.3** Variable Charts Without Grouping (X) Variable or Nonsummarized Data

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Points &gt; Statistic</td>
</tr>
<tr>
<td>Individual</td>
<td>Individual</td>
</tr>
<tr>
<td>Moving Range on Individual</td>
<td>Moving Range</td>
</tr>
<tr>
<td>Levey Jennings</td>
<td>Individual</td>
</tr>
</tbody>
</table>

**Table 3.4** Variable Charts with Grouping (X) Variables or Summarized Data

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Points &gt; Statistic</td>
</tr>
<tr>
<td>XBar (limits computed on range)</td>
<td>Average</td>
</tr>
<tr>
<td>XBar (limits computed on standard deviation)</td>
<td>Average</td>
</tr>
<tr>
<td>R</td>
<td>Range</td>
</tr>
<tr>
<td>S</td>
<td>Standard Deviation</td>
</tr>
<tr>
<td>Levey Jennings</td>
<td>Individual measurements. Control limits are based on an estimate of long-term sigma.</td>
</tr>
</tbody>
</table>

**Table 3.5** Presummarize Charts

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Points &gt; Statistic</td>
</tr>
<tr>
<td>Individual on Group Means</td>
<td>Average</td>
</tr>
</tbody>
</table>
### Table 3.5 Presummarize Charts *(Continued)*

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Individual on Group Std Devs</td>
<td>Points &gt; Statistic Standard Deviation</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Moving Range</td>
</tr>
<tr>
<td>Moving Range on Group Means</td>
<td>Points &gt; Statistic Moving Range on Means</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Moving Range</td>
</tr>
<tr>
<td>Moving Range on Group Std Devs</td>
<td>Points &gt; Statistic Moving Range on Std Dev</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Moving Range</td>
</tr>
</tbody>
</table>

### Table 3.6 Attribute Charts

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>p-chart</td>
<td>Points &gt; Statistic Proportion</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Binomial</td>
</tr>
<tr>
<td>np-chart</td>
<td>Points &gt; Statistic Count</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Binomial</td>
</tr>
<tr>
<td>c-chart</td>
<td>Points &gt; Statistic Count</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Poisson</td>
</tr>
<tr>
<td>u-chart</td>
<td>Points &gt; Statistic Proportion</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Poisson</td>
</tr>
</tbody>
</table>

### Table 3.7 Rare Event Charts

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>g-chart</td>
<td>Points &gt; Statistic Count</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Negative Binomial</td>
</tr>
<tr>
<td>t-chart</td>
<td>Points &gt; Statistic Count</td>
</tr>
<tr>
<td></td>
<td>Limits &gt; Sigma Weibull</td>
</tr>
</tbody>
</table>
Launch the Control Chart Builder

Launch the Control Chart Builder by selecting Analyze > Quality and Process > Control Chart Builder.

Figure 3.4 Initial Control Chart Builder Window

To begin creating a control chart, drag variables from the Select Columns box into the zones. If you drop variables in the center, JMP guesses where to put them based on whether the variables are continuous or categorical. The Control Chart Builder contains the following zones:

Y Assigns the process variable.

Subgroup Assigns subgroup variables. To define subgroup levels as a combination of multiple columns, add multiple variables to the Subgroup zone. When a subgroup variable is assigned, each point on the control chart corresponds to a summary statistic for all of the points in the subgroup.

Phase Assigns phase variables. When a Phase variable is assigned, separate control limits are computed for each phase. See also “Add Color to Delineate Phases” on page 69

The initial Control Chart Builder window contains the following buttons:
**Undo**  Reverses the last change made to the window.

**Start Over**  Returns the window to the default condition, removing all data, and clearing all zones.

**Done**  Hides the buttons and the **Select Columns** box and removes all drop zone outlines. In this presentation-friendly format, you can copy the graph to other programs. To restore the window to the interactive mode, click **Show Control Panel** on the Control Chart Builder red triangle menu.

**By**  Identifies the variable and produces a separate analysis for each value that appears in the column.

**Shewhart Variables/Shewhart Attribute/Rare Event**  Allows you to select Shewhart Variables, Shewhart Attribute, or Rare Event control chart types. If you select an Attribute chart type, an **n Trials** box and zone appear on the chart.

**n Trials**  Assigns a lot size when an attribute control chart is selected. Appears if you select an Attribute chart type.

**New Y Chart**  Produces a copy of the current chart for every column selected in the **Select Columns** box. The new charts use the selected columns in the **Y** role.

Once you drag variables to the chart, other buttons and options appear at left that enable you to show, hide or switch items on the chart (See Figure 3.5). Many of these functions (Points, Limits, Warnings, etc.) are the same as the functions available when you right-click the chart. For more information, refer to “Options Panel and Right-Click Chart Options” on page 48. For information about warnings and rules, see “Tests” on page 52 and “Westgard Rules” on page 55.

**3-way Chart**  Enables you to produce a three-way chart for variable chart types. The subgroup size must be greater than one. The plotting statistic is based on subgroup averages, within-subgroup variation, or between-subgroup variation. The default set of three includes a presummarized chart of the averages using Moving Range limits, a Moving Range chart and a Range chart.

**Event Chooser**  Allows the chart to respond in real time to selection changes. There are several standard groups of responses that are recognized and pre-scored (for example, pass/fail, yes/no, Likert Scales, conforming/non-conforming, and defective/non-defective). If you are analyzing results from a survey and want to focus solely on a specific sector of the results for one or more questions, you can make the selection on the screen and the chart rescores and replots the chart immediately. The levels selected in the Event Chooser are counted as events, and all other levels are counted as non-events.

The **Event Chooser** is available for attribute charts with response columns that have a modeling type of nominal or ordinal. If you want the Event Chooser to work on a numeric
integer-valued nominal or ordinal response column, you must select the Use Event Chooser option from the red triangle menu. The Event Chooser does not appear for response columns with a modeling type of continuous.

The Control Chart Builder Window

The analysis produces a chart that can be used to determine whether a process is in a state of statistical control. The report varies depending on which type of chart you select. Control charts update dynamically as data is added or changed in the data table. Figure 3.5 displays the Control Chart Builder window for the Bottle Tops.jmp sample data table.

To create the chart:

1. Select Help > Sample Data Library and open Quality Control/Bottle Tops.jmp. 
2. Select Analyze > Quality and Process > Control Chart Builder. 
3. Drag Status to the Y zone. 
4. Drag Sample to the Subgroup zone (at bottom).

Figure 3.5 Control Chart Builder Window

You can drag other variables into the various zones to augment the analysis and use the “Control Chart Builder Options” to further examine the data. Some of the right-click chart options (for example, show or hide points, limits, warnings, and zones; select statistic and sigma options) also appear on the left hand side of the chart for easy access.
Control charts have the following characteristics:

- Each point plotted on the chart represents an individual process measurement or summary statistic. Subgroups should be chosen rationally, that is, they should be chosen to maximize the probability of seeing a true process signal between subgroups.
- The vertical axis of a control chart is scaled in the same units as the summary statistic.
- The horizontal axis of a control chart identifies the subgroup samples and is time ordered. Observing the process over time is important in assessing if the process is changing.

The green line is the center line, or the average of the data. The center line indicates the average (expected) value of the summary statistic when the process is in statistical control. Measurements should appear equally on both sides of the center line. If not, this is possible evidence that the process average is changing.

- The two red lines are the upper and lower control limits, labeled UCL and LCL. These limits give the range of variation to be expected in the summary statistic when the process is in statistical control. If the process is exhibiting only routine variation, then all the points should fall randomly in that range.
- A point outside the control limits signals the presence of a special cause of variation.

Options in the Control Chart Builder window create control charts that can be updated dynamically as samples are received and recorded or added to the data table. When a control chart signals abnormal variation, action should be taken to return the process to a state of statistical control if the process degraded. If the abnormal variation indicates an improvement in the process, the causes of the variation should be studied and implemented.

When you double-click the axes, the appropriate Axis Specification window appears for you to specify the format, axis values, number of ticks, gridline, reference lines, and other options to display.

Control Chart Builder Options

Control Chart Builder options appear in the red triangle menu or by right-clicking on a chart or axis. Some of the right-click chart options also appear on the bottom left hand side of the chart for easy access. You can also set preferences for many of the options in the Control Chart Builder at File > Preferences > Platforms > Control Chart Builder.

- “Red Triangle Menu Options”
- “Options Panel and Right-Click Chart Options”
- “Right-Click Axis Options”
Red Triangle Menu Options

Show Control Panel  Shows or hides the following elements:
  – buttons
  – the Select Columns box
  – the drop zone borders

Show Limit Summaries  Shows or hides the Limit Summaries report. This report shows the control limits (LCL and UCL), the center line (Avg), the Points and Limits plotted, and the Sample Size for the chart. Sample size is not shown for rare event charts.

Show Capability  (Available only for Shewhart Variables charts that have a column with a Spec Limits column property.) Shows or hides the Process Capability Analysis report. For more information about the Process Capability Analysis report, see “The Process Capability Report” on page 272.

Note: Show Capability is not available if the response variable has no variation.

Get Limits  Retrieves the control limits that are stored in a data table.

Show Excluded Region  Shows or hides the regions of the chart where samples have been excluded.

Set Subgroup Size  Sets a subgroup size. Missing values are taken into account when computing limits and sigma.

Save Limits  Saves the control limits in one of the following ways:
  in Column  Saves control limits as a column property in the existing data table for the response variable. If the limits are constant, LCL, Avg, and UCL values for each chart type in the report are saved. This option is not available with phase charts. In addition, the option has no effect if the sample sizes are not constant for each chart.
  in New Table  Saves the standard deviation and mean for each chart into a new data table. If the limits are constant, the LCL, Avg, and UCL for each chart are saved as well. If there are phases, a new set of values is saved for each phase.

Save Summaries  Creates a new data table containing such information as the sample label, sample sizes, statistic being plotted, center line, control limits, and any tests, warnings and failures. The specific statistics included in the table depend on the type of chart.

Include Missing Categories  Enables the graph to collect rows with missing values in a categorical column, and displays the missing values on the graph as a separate category. If
this option is disabled, all rows with a missing X value are removed from the calculations, in addition to being hidden from the graph.

This option is not available for continuous X variables or categorical Y variables because there is no compelling way to display the collected missing values on the relevant axes. By default, this option is enabled.

**Note:** If Include Missing Categories is enabled, capability analysis results in Control Chart Builder do not match those in the Process Capability platform if a categorical X variable has missing values.

**Use Event Chooser**  (Applies only for attribute charts with numeric non-continuous Y variables.) Categorizes ordinal numeric data and offers individual numeric-level modeling selections.

See the JMP Reports chapter in the *Using JMP* book for more information about the following options:

**Local Data Filter**  Shows or hides the local data filter that enables you to filter the data used in a specific report.

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

**Note:** Column Switcher is available only for a single Y variable having two or fewer associated charts. Based on the selected chart type, only columns that are appropriate for the Y role are included in the Column Switcher column list.

**Note:** In Control Chart Builder, the Automatic Recalc option is turned on by default and cannot be turned off.

**Options Panel and Right-Click Chart Options**

The following options appear on the left hand side of the chart for easy access and when you right-click a chart.

**Points**  Provides the following options:

**Statistic**  Changes the statistic plotted on the chart. See “Statistic” on page 50.
**Individual Points**  Show or hides individual observations in a subgroup. Available only with a subgroup variable or Set Sample Size. This option is not available for Attribute chart types or Rare Event charts.

**Show Connect Line**  Shows connecting lines between the points.

**Show Points**  Shows or hides the points on the chart.

**Limits**  Provides the following options:

**Sigma**  Specifies the method of computing sigma. See “Sigma” on page 51.

**Zones**  Shows or hides the zones on the chart. The zones are defined as one, two, and three sigmas on either side of the mean. Control Chart Builder does not extend the size of one zone over another. If the limits are not centered around the mean, \((UCL - \text{Avg})/3\) is used as the width of each zone. Zones are not drawn below the LCL or above the UCL. Available only for Variables and Attribute chart types.

**Spec Limits**  Shows or hides the specification limits on the chart. Appears only if the data table has a Spec Limits column property. The Column Info Window chapter in the Using JMP book includes details about adding this column property.

**Set Control Limits**  Enables you to enter control limits for tests. After you click OK in the Set Control Limits window, the specified control limits are set uniformly across groups. Select this option again to remove the specified control limits.

**Add Limits**  Specifies additional control limits to be plotted on the chart. These limits are not used in tests.

**Show Limits**  Shows or hides the control limits on the chart.

**Show Center Line**  Shows or hides the center line on the chart.

**Add Dispersion Chart**  Adds a dispersion chart to the chart area. Change the chart type with the Points options. A dispersion chart illustrates the variation in the data by plotting one of many forms of dispersion, including the range, standard deviation, or moving range. Available only for Variables chart types.

**Set Subgroup Size**  Sets a subgroup size. Missing values are taken into account when computing limits and sigma.

**Warnings**  Provides the following options:
**Customize Tests**  Enables you to design custom tests and select or deselect multiple tests at once. After the option is selected, the Customize Tests window appears for designing the tests. Select a test description, and enter the desired number (n) and label. You can save the settings to preferences and also restore the default settings. Available only for Variables and Attribute chart types.

**Tests**  Enables you to select which statistical control tests to enable. For more information about tests, see “Tests” on page 52. Available only for Variables and Attribute chart types.

**Note:** Move your cursor over a flagged point on the chart to see a description of the test that failed.

**Westgard Rules**  Enables you to select which Westgard statistical control tests to enable. Because Westgard rules are based on sigma and not the zones, they can be computed without regard to constant sample size. For more information about tests, see “Westgard Rules” on page 55. Available only for Variables and Attribute chart types.

**Test Beyond Limits**  Enables the test for any points beyond the control limits. These points are identified on the chart. This test works on all charts with limits, regardless of the sample size being equal.

**Remove Graph**  Removes the control chart.

**Note:** For a description of the Rows, Graph, Customize, and Edit menus, see the *Using JMP* book.

**Statistic**

You can change the statistic represented by the points on the chart. The options available depend on the chart type selected.

For Variables chart types, you can change the statistic represented by the points on the chart using the following options:

**Individual**  Creates a chart where each point represents an individual value in the data table.

**Average**  Creates a chart where each point represents the average of the values in a subgroup.

**Range**  Creates a chart where each point represents the range of the values in a subgroup.

**Standard Deviation**  Creates a chart where each point represents the standard deviation of the values in a subgroup.
Moving Range on Means  Computes the difference in the range between two consecutive subgroup means.

Moving Range on Std Dev  Computes the difference in the range between two consecutive subgroup standard deviations.

Moving Range  Creates a chart where each point is the difference between two consecutive observations.

Note: The Average, Range, Standard Deviation, Moving Range on Means, and Moving Range on Std Dev methods appear only if a subgroup variable with a sample size greater than one is specified or a sample size is set.

For Attribute chart types, you can change the statistic represented by the points on the chart using the following options:

Proportion  Creates a chart where each point represents the proportion of items in subgroup samples.

Count  Creates a chart where each point represents the number of items in subgroup samples.

For Rare Event chart types, the statistic represented by the points on the chart uses the Count option.

Sigma

You can change the method for computing sigma for the chart. The options available depend on the chart type selected.

For Variables chart types, you can use the following options:

Range  Uses the range of the data in a subgroup to estimate sigma.

Standard Deviation  Uses the standard deviation of the data in a subgroup to estimate sigma.

Moving Range  Uses the moving ranges to estimate sigma. The moving range is the difference between two consecutive points.

Levey-Jennings  Uses the standard deviation of all the observations to estimate sigma. If your chart has phases, sigma is calculated for each phase separately.

For Attribute chart types, you can use the following options:
Binomial  Uses the binomial distribution model to estimate sigma. The model indicates the number of successes in a sequence of experiments, each of which yields success with some probability. Selecting Binomial yields either a p- or np-chart.

Poisson  Uses the Poisson distribution model to estimate sigma. The model indicates the number of events and the time at which these events occur in a given time interval. Selecting Poisson yields either a c- or u-chart.

For Rare Event chart types, you can use the following options:

Negative Binomial  Uses the negative binomial distribution model to estimate sigma. The model indicates the number of successes in a sequence of trials before a specified number of failures occur. Selecting Negative Binomial yields a g-chart.

Weibull  Uses the Weibull distribution model to estimate sigma. The model indicates the mean time between failures. Selecting Weibull yields a t-chart.

Tests

The Warnings option in the right-click menu or on the left hand side of the window displays a submenu for Tests selection. You can select one or more tests for special causes (Western Electric rules) from the menu. Nelson (1984) developed the numbering notation used to identify special tests on control charts. The tests work with both equal and unequal sample sizes.

If a selected test is positive for a particular sample, that point is labeled with the test number. When you select several tests for display and more than one test signals at a particular point, the label of the numerically lowest test specified appears beside the point. You can move your cursor over a flagged point on the chart to see a description of the test that failed.

Tip: To add or remove several tests at once, select or deselect the tests in the Control Panel under Warnings > Tests.

Table 3.8 on page 53 lists and interprets the eight tests, and Figure 3.7 illustrates the tests. The following rules apply to each test:

- The area between the upper and lower limits is divided into six zones, each with a width of one standard deviation.
- The zones are labeled A, B, C, C, B, A with zones C nearest the center line.
- A point lies in Zone B or beyond if it lies beyond the line separating zones C and B. That is, if it is more than one standard deviation from the center line.
- Any point lying on a line separating two zones lines is considered belonging to the innermost zone. So, if a point lies on the line between Zone A and Zone B, the point is considered to be in Zone B.
Notes:

- Tests 1 through 8 apply to all Shewhart chart types.
- Tests 1, 2, 5, and 6 apply to the upper and lower halves of the chart separately.
- Tests 3, 4, 7, and 8 apply to the whole chart.
- Once a runs test (one that is based on consecutive observations) is triggered, the counts do not reset to 0 when moving to the next sample.
- Because excluded observations change the sample, the excluded state of a row is not considered for runs tests (ones that are based on consecutive observations).

See Nelson (1984, 1985) for further recommendations on how to use these tests.

Figure 3.6 Zones for Western Electric Rules

Table 3.8 Description and Interpretation of Tests for Special Causes

<table>
<thead>
<tr>
<th>Test</th>
<th>Description</th>
<th>Interpretation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test 1</td>
<td>One point beyond Zone A</td>
<td>Detects a shift in the mean, an increase in the standard deviation, or a single aberration in the process. For interpreting Test 1, any dispersion chart ($R$, $S$, or $MR$) can be used to rule out increases in variation.</td>
</tr>
<tr>
<td>Test 2</td>
<td>Nine points in a row in a single (upper or lower) side of Zone C or beyond</td>
<td>Detects a shift in the process mean.</td>
</tr>
</tbody>
</table>
Table 3.8 Description and Interpretation of Tests for Special Causes\textsuperscript{a} (Continued)

<table>
<thead>
<tr>
<th>Test</th>
<th>Description</th>
<th>Interpretation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test 3</td>
<td>Six points in a row steadily increasing or decreasing</td>
<td>Detects a trend or drift in the process mean.</td>
</tr>
<tr>
<td>Test 4</td>
<td>Fourteen points in a row alternating up and down</td>
<td>Detects systematic effects such as two alternately used machines, vendors, or operators.</td>
</tr>
<tr>
<td>Test 5</td>
<td>Two out of three points in a row in Zone A or beyond and the point itself is in Zone A or beyond.</td>
<td>Detects a shift in the process average or increase in the standard deviation. Any two out of three points provide a positive test.</td>
</tr>
<tr>
<td>Test 6</td>
<td>Four out of five points in a row in Zone B or beyond and the point itself is in Zone B or beyond.</td>
<td>Detects a shift in the process mean. Any four out of five points provide a positive test.</td>
</tr>
<tr>
<td>Test 7</td>
<td>Fifteen points in a row in Zone C, above and below the center line</td>
<td>Detects stratification of subgroups when the observations in a single subgroup come from various sources with different means. Also detects a reduction in variation.</td>
</tr>
<tr>
<td>Test 8</td>
<td>Eight points in a row on both sides of the center line with none in Zones C</td>
<td>Detects stratification of subgroups when the observations in one subgroup come from a single source, but subgroups come from different sources with different means.</td>
</tr>
</tbody>
</table>

\textsuperscript{a} Nelson (1984, 1985)
Westgard Rules

Westgard rules are implemented under the Westgard Rules submenu of the Warnings option when you right-click on a chart or on the left hand side of the window. The different tests are abbreviated with the decision rule for the particular test. For example, $1\, 2s$ refers to a test where one point is two standard deviations away from the mean.

Notes:

- Once a runs test (one that is based on consecutive observations) is triggered, the counts do not reset to 0 when moving to the next sample.
- Because excluded observations change the sample, the excluded state of a row is not considered for runs tests (ones that are based on consecutive observations).

Rule 1 2S is commonly used with Levey-Jennings charts, where control limits are set 2 standard deviations away from the mean. The rule is triggered when any one point goes beyond these limits.

Rule 1 3S refers to a rule common to Levey-Jennings charts where the control limits are set 3 standard deviations away from the mean. The rule is triggered when any one point goes beyond these limits.

Rule 2 2S is triggered when two consecutive control measurements are farther than two standard deviations from the mean.

Rule R 4S is triggered when one measurement is greater than two standard deviations from the mean and the previous measurement is greater than two standard deviations from the mean in the opposite direction such that the difference is greater than 4 standard deviations.
Quality and Process Methods

Chapter 3: Control Chart Builder

Work with Control Limits

Control limits are based on the performance of your process, and tell you about the variability in your process. Upper control limits (UCLs), center lines, and lower control limits (LCLs) are calculated from the data when a control chart is created. You can use these calculated control limits to tell you when your process has changed and adjustments need to be made.

Rule 4 1S is triggered when four consecutive measurements are more than one standard deviation from the mean.

Rule 10 X is triggered when ten consecutive points are on one side of the mean.

Right-Click Axis Options

Remove  Removes a variable.

Remove Graph  Removes the entire graph.

For details about the Axis Settings, Revert Axis, Add or Remove Axis Label, and Edit options, see the JMP Reports chapter in the *Using JMP* book.
It is important to note that control limits are different from specification limits, which are often used in capability analysis.

**Table 3.9  Control Limits versus Specification Limits**

<table>
<thead>
<tr>
<th>Control Limits</th>
<th>Specification Limits</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculated from data</td>
<td>Given by customer or design</td>
</tr>
<tr>
<td>Based on variability</td>
<td>Based on system requirements</td>
</tr>
<tr>
<td>Applied to summary statistics</td>
<td>Applied to individual measurements</td>
</tr>
<tr>
<td>Applied to process measurements, perhaps on product, perhaps not</td>
<td>Applied to product characteristics</td>
</tr>
<tr>
<td>The voice of the process</td>
<td>The voice of the customer</td>
</tr>
</tbody>
</table>

**Example of Control Limits**

In this example, consider a company’s printing process. Variations can cause distortion in the line, including skew, thickness, and length problems. In this example, we’ll consider the length of the line. A line is considered good if it has a printed length of 16 cm +/- 0.2 cm. Any longer and the sentence may run off of the page. Any shorter and there would be a lot of wasted space on the page. For every print run, the first and last books are taken for measurement. The line lengths are measured on a specified page in the middle of each book.

You want to know: Is this process in control (stable)? Are we getting consistent print quality? To answer these questions, we need to create control charts and use control limits.

This example is in three parts. In most cases, you would start with “Create the Baseline Control Chart”, where you let JMP calculate the control limits for you. Then, to apply these control limits to new data, you would either “Specify Control Limits” or “Specify Multiple Sets of Control Limits” (for phase data).

**Create the Baseline Control Chart**

First, examine whether the existing process is in control. If it is, we can use the control limits created by JMP as our baseline/historical limits.

1. Select Help > Sample Data Library and open Quality Control/Line Length.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Length to the Y zone.
An Individual and Moving Range chart of Length appears. This chart is appropriate if you have no natural subgrouping in your data. However, in this example, there is a natural subgrouping, which is each print run.

4. Drag Run to the Subgroup zone (at bottom).

**Figure 3.8** XBar and R Chart of Line Length by Print Run

The XBar and R charts have three lines drawn horizontally across them. These are the calculated LCL (lower control limit), Avg (average) and UCL (upper control limit).

Ideally, we would like for all of our points to fall within the control limits, and we would like for the points to be randomly placed within these limits. Looking at the graph, we see that no points fall outside of the control limits, and there does not appear to be a pattern to the points. To investigate further, perform Nelson/Western Electric Tests to check for patterns and see if any of these tests fail.

5. In the XBar chart, right-click and select **Warnings > Tests > All Tests**.

Notice that no points were circled or flagged. This means that our process is in control or stable.

If we had determined that our process was not in control, we would do further research to figure out how we could alter our process so that it is in control. For this example, since the process is already in control or stable, we can skip that step. Now, you can use these control limits with new data. Proceed to “Specify Control Limits” on page 60, or “Specify Multiple Sets of Control Limits” on page 64 (to see an example with phase data).
Specify Control Limits

Since we established that the process is in control, we can use these historical limits with new data to see how the new data compares to the existing process. This means we need to specify control limits instead of having JMP calculate them.

There are several ways to specify control limits in JMP:

- “Set Control Limits Option” on page 60
- “Add a Column Property” on page 61
- “Use the Get Limits Option” on page 62
- “Exclude Rows” on page 63

Set Control Limits Option

One simple way to specify control limits is to use the Set Control Limits option in Control Chart Builder.

1. Select Help > Sample Data Library and open Quality Control/New Length Data.jmp. This is the table that contains your new data.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Length to the Y zone.
4. Drag Run to the Subgroup zone (at bottom).
5. Right-click in the Average (XBar) chart and select Limits > Set Control Limits.
6. Enter these limits:
   - LCL - 15.90519
   - Avg - 15.99825
   - UCL - 16.09131
   These are the historical limits from the Average (XBar) chart in Figure 3.8.
7. Click OK.
8. Right-click in the Range (R) chart and select Limits > Set Control Limits.
9. Enter these limits:
   - LCL - 0
   - Avg - 0.0495
   - UCL - 0.161693
   These are the historical limits from the Range (R) chart in Figure 3.8.
10. Click OK.
Rather than calculating limits from the data, JMP used the historical control limits that you defined. In the Length Limit Summaries table, notice that the Limits Sigma now says User Defined. Many points now fall outside of the limits. Also, the averages are higher than those of the baseline process. This process is different from the original process that we used to calculate the baseline control limits.

Add a Column Property

Another way to specify control limits is to add the Control Limits column property to a column in your new data table.

1. Select Help > Sample Data Library and open Quality Control/New Length Data.jmp. This is the table that contains your new data.
2. Select the Length column and click Cols > Column Info.
3. Click Column Properties > Control Limits.
4. XBar is selected, so enter these fixed limits for the Average (XBar) chart:
   - Avg - 15.99825
   - LCL - 15.90519
   - UCL - 16.09131

These are the historical limits from the Average (XBar) chart in Figure 3.8. Leave the value for Subgroup Size as missing. This value is not used in the Control Chart Builder platform.
5. Click XBar > R. Enter these fixed limits for the Range (R) chart:
   - Avg - 0.0495
   - LCL - 0
   - UCL - 0.161693
   These are the historical limits from the Range (R) chart in Figure 3.8.
   Leave the value for Subgroup Size as missing. This value is not used in the Control Chart Builder platform.
6. Click OK.
   You have entered control limits for XBar and R charts for the Length column. Now you can create a control chart.
7. Select Analyze > Quality and Process > Control Chart Builder.
8. Drag Length to the Y zone.
9. Drag Run to the Subgroup zone (at bottom).
   The graph is identical to Figure 3.9.

Use the Get Limits Option

The Get Limits method of specifying control limits is the most flexible. You should use this method in the following cases:

- If you have control limits for many different processes
- If you have different control limits for each phase (see “Specify Multiple Sets of Control Limits” on page 64)

To use the Get Limits method, you need a data table that defines your historical limits. For detailed information about how to create a limits table, see “Saving and Retrieving Limits” on page 109 in the “Shewhart Control Charts” chapter.

In the following example, a limits data table has already been created.
1. Select Help > Sample Data Library and open Quality Control/New Length Data.jmp.
   This is the table that contains your new data.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Length to the Y zone.
4. Drag Run to the Subgroup zone (at bottom).
5. Click the Control Chart Builder red triangle and select Get Limits. Navigate and open the limits data table for this example, called Length Limits.jmp. By default, the file is located here:
   - On Windows: C:\Program Files\SAS\JMP\<version>\Samples\Data
The graph is identical to Figure 3.9.

**Exclude Rows**

Another way to specify control limits is to exclude rows in a data table. One advantage to this method is that you can see both the historical data and new data in the same graph. This can help to determine differences.

To use this method, you must meet the following criteria:

- New and old data must reside in the same data table.
- Historical data and new data must all have equal subgroup sizes.
- All new data must be excluded in the data table (using Rows > Exclude/Unexclude).

In the following example, new data have already been excluded.

1. Select **Help > Sample Data Library** and open **Quality Control/Combined.jmp**. This table contains old and new data, and new data is excluded.

2. Select **Analyze > Quality and Process > Control Chart Builder**.

3. Drag **Length** to the **Y** zone.

4. Drag **Run** to the **Subgroup** zone (at bottom).

**Figure 3.10** XBar and R Chart of Line Length with Excluded Data
JMP uses only the unexcluded rows (historical data) to create the control limits. The new data (excluded data) is still plotted on the graph (dimmed), but these data were not used in any of the calculations.

**Specify Multiple Sets of Control Limits**

In this example, you want to set different control limits for different phases of a process. The column property, set control limits, and excluded row state methods will not work in this situation because these methods are limited to only one set of control limits for the entire chart. For a control chart with phases, you need to use the get limits method.

In the printing company, the goal is to reduce the variability of the force needed to break the bond between paper and the book spine for three different sites. Each site has different machines, different operators, and is also located in different countries; therefore, each site has a unique set of historical limits and information. For all three sites, the company does the following:

1. Creates a baseline control chart based on the existing process data.
2. Changes the process, based upon a designed experiment.
3. Gathers data from the new process.
4. Creates a new control chart based on the new process data.

The goal is to plot the new data on a control chart using historical limits from the old process. This way, the printing company can compare the new process to the old process limits.

**Create a Control Chart Based on Existing Process**

1. Select Help > Sample Data Library and open Quality Control/Phase Historical Data.jmp.
   This table contains the existing process data for all three sites.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Force to the Y zone.
4. Drag Run to the Subgroup zone (at bottom).
5. Drag Site to the Phase zone.
Create a Control Chart Based on Updated Process

1. From the report in Figure 3.11, click the red triangle next to Control Chart Builder and select **Save Limits > in New Table**. This creates a limits table.

2. Save this new limits table to any location, so you can access it later.

3. Select **Help > Sample Data Library** and open Quality Control/Phase New Data.jmp. This data was collected from all three sites after the change was made to the process.

4. Select **Analyze > Quality and Process > Control Chart Builder**.

5. Drag **Force** to the **Y** zone.

6. Drag **Run** to the **Subgroup** zone (at bottom).

7. Drag **Site** to the **Phase** zone.

8. Click the red triangle next to Control Chart Builder and select **Get Limits**. Open the limits table you saved in step 2. This applies the historical limits to the new data in the Control Chart Builder report.
Now you can see how the new data (after the process change) compares with the historical information (before the process change). None of the points fall outside of the control limits for either the location or dispersion chart. The goal was to reduce variability. Looking at the moving range chart, you can see that most points fall below the average line. Especially for sites 1 and 2, it is clear that the variability of force needed to break the bond between pages and the book spine has been decreased. Site 3 is not as obvious as sites 1 and 2. It appears that the variability may have been reduced some. However, it is unclear if this is a significant change. The improvements to the printing process have succeeded in reducing the variability.

Excluded and Hidden Samples

The following bullets summarize the effects of various conditions on samples and subgroups:

- Excluded subgroups are not used in the calculations, but appear in the chart (although dimmed).
- Hidden observations are used in the calculations, but do not appear in the chart.
- Both hidden and excluded rows are included in the count of points for Tests for Special Causes. An excluded row can be labeled with a special cause flag. A hidden point cannot be labeled. If the flag for a Tests for Special Causes is on a hidden point, it will not appear in the chart.
- For partially excluded subgroups, if one or more observations within a subgroup is excluded, and at least one observation within the subgroup is included, the excluded observation is not included in the calculations of either the point statistic or the limits.
• Checks for negative and non-integer data happen on the entire data (even excluded values).
• Tests continue to apply to all excluded subgroups. Excluded samples are flagged when tests are turned on.

Additional Examples of the Control Chart Builder

Note: In this section, some examples show the Control Panel while others do not. To show or hide the Control Panel, select Show Control Panel from the red triangle menu.

• “X-Bar and R Chart Phase Example”
• “p-chart Example”
• “np-chart Example”
• “c-chart Example”
• “u-chart Example”
• “g-chart Example”
• “t-chart Example”
• “3-Way Chart Example”

X-Bar and R Chart Phase Example

A manufacturer of medical tubing collected tube diameter data for a new prototype. The data was collected over the past 40 days of production. After the first 20 days (phase 1), some adjustments were made to the manufacturing equipment. Analyze the data to determine whether the past 20 days (phase 2) of production are in a state of control.

1. Select Help > Sample Data Library and open Quality Control/Diameter.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag DIAMETER to the Y role.
4. Drag DAY to the Subgroup role (at bottom).
The first 20 days appear to have high variability, and in the Average chart, there are three observations that are outside of the control limits. An adjustment was made to the manufacturing equipment and new control limits were incorporated.

To compute separate control limits for each phase:

5. Drag Phase to the Phase role.

6. In the Average chart, right-click and select Warnings > Test Beyond Limits.
Including the **Phase** variable means that the control limits for phase 2 are based only on the data for phase 2. None of the phase 2 observations are outside the control limits. Therefore, you can conclude that the process is in control after the adjustments were made.

**Add Color to Delineate Phases**

If you have distinct phases in your control chart, you can illustrate them by adding different background colors to the different phases.

1. Starting from Figure 3.14, double-click in the X axis.
2. Select **Allow Ranges**.
3. Enter -0.5 for the **Min Value** (the scale minimum).
4. Enter 19.5 for the **Max Value** (the dividing line).
5. Choose a color, say yellow. Change the opacity to 40%.
6. Click **Add**.
7. Click **Allow Ranges**.
8. Enter 19.5 for the **Min Value** (the dividing line).
9. Enter 39.5 for the **Max Value** (the maximum of the axis).
10. Choose a color, say light blue. Change the opacity to 40%.
11. Click **Add**.
You can see from the preview how the chart will look.

12. Click OK.

**Figure 3.15** Diameter Phases with Color

---

**p-chart Example**

The Washers.jmp sample data contains defect data for two different lot sizes from the *ASTM Manual on Presentation of Data and Control Chart Analysis*, American Society for Testing and Materials (1976). To view the differences between constant and variable sample sizes, you can compare charts for Lot Size and Lot Size 2.

1. Select Help > Sample Data Library and open Quality Control/Washers.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag # defective to the Y role.
   
   An Individual & Moving Range chart appears.
4. Select Shewhart Attribute from the drop down to change the chart to an attribute chart.
   
   A c-chart appears.
5. Change the Sigma to Binomial to change the chart to a np-chart.
6. Change the Statistic from Count to Proportion to change the chart to a p-chart.
7. Drag Lot Size to the nTrials role.

**Figure 3.17** p-chart of # defective with sample size
To view the differences between constant and variable sample sizes, you can compare charts for Lot Size and Lot Size 2 by simply dragging the variables to the nTrials zone.

**np-chart Example**

The Bottle Tops.jmp sample data contains simulated data from a bottle top manufacturing process. Sample is the sample ID number for each bottle. Status indicates whether the bottle top conformed to the design standards. In the Phase column, the first phase represents the time before the process adjustment. The second phase represents the time after the process adjustment. Notes on changes in the process are also included.

1. Select **Help > Sample Data Library** and open Quality Control/Bottle Tops.jmp.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag **Sample** to the **Subgroup** role.
4. Drag **Status** to the **Y** role.

![Figure 3.18 np-chart of Status (Nonconforming)](image)

The original observations appear to have high variability and there are five observations (Samples 13, 15, 21, 22 and 23) that are outside of the upper control limit. Samples 15 and 23 note that new material and a new operator were introduced into the process, respectively. At the end of the phase, an adjustment was made to the manufacturing
equipment. Therefore, the control limits for the entire series should not be used to assess the control during phase 2.

To compute separate control limits for each phase:

5. Drag Phase to the Phase zone.

**Figure 3.19 np-chart by Phase**

Including the Phase variable means that the control limits for phase 2 are based only on the data for phase 2. None of the phase 2 observations are outside the control limits. Therefore, you can conclude that the process is in control after the adjustment.

**c-chart Example**

The Cabinet Defects.jmp sample data table contains data concerning the various defects discovered while manufacturing cabinets over two time periods.

1. Select Help > Sample Data Library and open Quality Control/Cabinet Defects.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Type of Defect to the Y role.
4. Drag Lot Number to the Subgroup role (at bottom).
   
   A np-chart of Type of Defect appears.
5. To change to a c-chart, select **Poisson** from the Sigma list.

6. Open the **Type of Defect** disclosure icon. Note that all of the defect types are listed, but only **Bruised veneer** is selected and displayed in the chart. You could select additional defect types and the chart would update immediately. Leave it as is for now.

**Figure 3.20** c-chart of Type of Defect

7. To add to phase variable, drag **Date** to the **Phase** zone.

**Figure 3.21** c-chart of Type of Defect with Phases
You can now view the results on the two different days. Both appear to be within limits. To examine other defect type behavior, select another defect type under the Event Chooser and view the results as the limits are updated.

**u-chart Example**

The Shirts.jmp sample data table contains data concerning the number of defects found in a number of boxes of shirts.

1. Select Help > Sample Data Library and open Quality Control/Shirts.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag # Defects to the Y role.
4. Drag Box to the Subgroup role.
   
   An Individual & Moving Range chart for # defects appears.
5. To change the chart to an Attribute chart, select Shewhart Attribute from the drop-down list.
   
   A c-chart of # Defects appears.
6. Change the Statistic from Count to Proportion to change the chart to a u-chart.

**Figure 3.22 u-chart of # Defects**

All of the points are within the control limits.
**g-chart Example**

Rare event charts are helpful when you know your data will not follow a normal distribution (for example, when measuring counts or wait times). The g-chart is an effective way to understand whether rare events are occurring more frequently than expected and warrant an intervention. A g-chart counts the number of possible opportunities since the last event. If you plot this type of data using a standard Shewhart control chart, you might see many more false signals, as the limits might be too narrow. The Adverse Reactions.jmp sample data table contains simulated data about adverse drug events (ADEs) reported by a group of hospital patients. An ADE is any type of injury or reaction the patient suffered after taking the drug. The date of the reaction and the number of days since the last reaction were recorded.

1. Select **Help > Sample Data Library** and open **Quality Control/Adverse Reactions.jmp**.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag **Doses since Last ADE** to the **Y** role.
4. Drag **Date of ADE** to the **Subgroup** role.
   
   An Individual & Moving Range chart of Doses since Last ADE appears.
5. To change the chart to a Rare Event chart, select **Rare Event** from the drop-down list.
   
   A g-chart of Doses since Last ADE appears showing the number of doses given since the last event.

**Figure 3.23** g-chart of Doses since Last ADE
**t-chart Example**

Rare event charts are helpful when you know your data will not follow a normal distribution (for example, when measuring counts or wait times). t-charts are used to measure the time that has elapsed since the last event. If you plot this type of data using a standard Shewhart control chart, you might see many more false signals, as the limits might be too narrow. The Fan Burnout.jmp sample data table contains simulated data for a fan manufacturing process. The first column identifies each fan that burned out. The second column identifies the number of hours between each burnout.

1. Select **Help > Sample Data Library** and open Quality Control/Fan Burnout.jmp.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag Hours between Burnouts to the **Y** role.
4. Drag Burnout to the **Subgroup** role.

**Figure 3.24** Individual and Moving Range Chart of Hours Between Burnouts

5. To change the chart to a Rare Event chart, select **Rare Event** from the drop-down list.
   A g-chart of Hours between Burnouts appears. All points appear to be within the control limits.

6. Change the **Sigma** from **Negative Binomial** to **Weibull** to change the chart to a t-chart.
In the t-chart, all points appear to be within the control limits. It’s clear that the Individual & Moving Range chart was inappropriate for the analysis, as the limits were too narrow.

3-Way Chart Example

Three-way charts are useful when there is variation between batches and variation within batches.

1. Select Help > Sample Data Library and open Quality Control/Vial Fill Weights.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Fill Weight to the Y role.
4. Drag Sample to the Subgroup role (at bottom).
Figure 3.26  XBar & R Chart for Fill Weight

Notice that the Range chart (R-chart) plots the ranges of each sample. The limits for the Average (XBar) chart are calculated using the averages in the Range chart.

5. At bottom left, click 3-Way Chart.

Figure 3.27  3-Way Chart for Fill Weight
A Moving Range chart appears between the Range and Average charts. The limits on the Average (XBar) chart are now calculated using the moving range between each level of wafer in lot ID.

Statistical Details for the Control Chart Builder Platform

**Note:** For charts created with the Control Chart platform instead of the Control Chart Builder, replace 3 in the formulas with \( k \).

**Note:** JMP uses methods described in American Society for Testing and Materials (1951), which defines control chart constants up to samples sizes of 25. For samples with a sample size greater than 25, JMP uses the control chart constant values for sample size 25 in both the sigma and Control Limit calculations.

- “Control Limits for X-bar and R-charts”
- “Control Limits for X-bar and S-charts”
- “Control Limits for Individual Measurement and Moving Range Charts”
- “Control Limits for p- and np-charts”
Control Limits for X-bar and R-charts

JMP generates control limits for \( \bar{X} \)- and \( R \)-charts as:

\[
\begin{align*}
\text{LCL for } \bar{X} \text{ chart} &= \bar{X}_w - \frac{3\hat{\sigma}}{\sqrt{n_i}} \\
\text{UCL for } \bar{X} \text{ chart} &= \bar{X}_w + \frac{3\hat{\sigma}}{\sqrt{n_i}} \\
\text{LCL for } R \text{ chart} &= \max \left( \frac{d_2(n_i)\hat{\sigma} - 3d_3(n_i)\hat{\sigma}}{\sqrt{n_i}}, 0 \right) \\
\text{UCL for } R \text{ chart} &= d_2(n_i)\hat{\sigma} + 3d_3(n_i)\hat{\sigma}
\end{align*}
\]

Center line for \( R \)-chart: By default, the center line for the \( i \text{th} \) subgroup (where 3 is the sigma multiplier) indicates an estimate of the expected value of \( R_i \). This value is computed as:

\[ d_2(n_i)\hat{\sigma}, \text{ where } \hat{\sigma} \text{ is an estimate of } \sigma. \]

The standard deviation of an \( \bar{X}/R \) chart is estimated by:

\[ \hat{\sigma} = \frac{R_1}{\frac{d_2(n_1)}{N}} + \ldots + \frac{R_N}{\frac{d_2(n_N)}{N}} \]

where:

\( \bar{X}_w \) = weighted average of subgroup means

\( \sigma \) = process standard deviation

\( n_i \) = sample size of \( i \text{th} \) subgroup

\( d_2(n) \) is the expected value of the range of \( n \) independent normally distributed variables with unit standard deviation

\( d_3(n) \) is the standard deviation of the range of \( n \) independent observations from a normal population with unit standard deviation
Control Chart Builder
Statistical Details for the Control Chart Builder Platform

Chapter 3
Quality and Process Methods

\[ R_i \] is the range of \( i^{th} \) subgroup
\[ N \] is the number of subgroups for which \( n_i \geq 2 \)

**Control Limits for X-bar and S-charts**

JMP generates control limits for \( \bar{X} \) - and \( S \)-charts as:

LCL for \( \bar{X} \) chart = \( \bar{X}_w - \frac{3\hat{\sigma}}{\sqrt{n_i}} \)

UCL for \( \bar{X} \) chart = \( \bar{X}_w + \frac{3\hat{\sigma}}{\sqrt{n_i}} \)

LCL for S-chart = \( \max\left(c_4(n_i)\hat{\sigma} - 3c_5(n_i)\hat{\sigma}, 0\right) \)

UCL for S-chart = \( c_4(n_i)\hat{\sigma} + 3c_5(n_i)\hat{\sigma} \)

Center line for S-chart: By default, the center line for the \( i^{th} \) subgroup (where 3 is the sigma multiplier) indicates an estimate of the expected value of \( s_i \). This value is computed as \( c_4(n_i)\hat{\sigma} \), where \( \hat{\sigma} \) is an estimate of \( \sigma \).

The estimate for the standard deviation in an \( \bar{X}/S \) chart is:

\[ \hat{\sigma} = \frac{s_1}{c_4(n_1)} + \ldots + \frac{s_N}{c_4(n_N)} \]

where:

\( \bar{X}_w \) = weighted average of subgroup means
\( \sigma \) = process standard deviation
\( n_i \) = sample size of \( i^{th} \) subgroup
\( c_4(n) \) is the expected value of the standard deviation of \( n \) independent normally distributed variables with unit standard deviation
\( c_5(n) \) is the standard deviation of the standard deviation of \( n \) independent observations from a normal population with unit standard deviation
\( N \) is the number of subgroups for which \( n_i \geq 2 \)
$s_i$ is the sample standard deviation of the $i^{th}$ subgroup

**Control Limits for Individual Measurement and Moving Range Charts**

Control limits for Individual Measurement charts are computed as follows.

\[
\text{LCL for Individual Measurement Chart} = \bar{X} - 3\hat{\sigma}
\]

\[
\text{UCL for Individual Measurement Chart} = \bar{X} + 3\hat{\sigma}
\]

Control limits for Moving Range charts are computed as follows.

\[
\text{LCL for Moving Range Chart} = 0
\]

\[
\text{UCL for Moving Range Chart} = d_2(n)\hat{\sigma} + 3d_3(n)\hat{\sigma}
\]

The standard deviation for Individual Measurement and Moving Range charts is estimated by:

\[
\hat{\sigma} = \frac{\bar{MR}}{d_2(n)}
\]

where:

- $\bar{X}$ is the mean of the individual measurements
- $\bar{MR}$ is the mean of the nonmissing moving ranges computed as $(MR_2 + MR_3 + \ldots + MR_N)/(N-1)$ where $MR_i = |x_i - x_{i-1}|$.
- $\sigma$ is the process standard deviation
- $d_2(n)$ is expected value of the range of $n$ independent normally distributed variables with unit standard deviation.
- $d_3(n)$ is standard deviation of the range of $n$ independent observations from a normal population with unit standard deviation.

**Note:** Moving Range charts in the Control Chart Builder platform use a range span of $n=2$.

**Control Limits for $p$- and $np$-charts**

The lower and upper control limits, LCL, and UCL, respectively, are computed as:

\[
\text{p-chart LCL} = \max(\bar{p} - 3\sqrt{\bar{p}(1 - \bar{p})/n_i}, 0)
\]

\[
\text{p-chart UCL} = \bar{p} + 3\sqrt{\bar{p}(1 - \bar{p})/n_i}
\]
p-chart UCL = \( \min(\bar{p} + 3 \sqrt{\bar{p}(1 - \bar{p})/n_i}, 1) \)

np-chart LCL = \( \max(n_i \bar{p} - 3 \sqrt{n_i \bar{p}(1 - \bar{p})}, 0) \)

np-chart UCL = \( \min(n_i \bar{p} + 3 \sqrt{n_i \bar{p}(1 - \bar{p})}, n_i) \)

where:

\( \bar{p} \) is the average proportion of nonconforming items taken across subgroups

\[
\bar{p} = \frac{n_1 p_1 + \ldots + n_N p_N}{n_1 + \ldots + n_N} = \frac{X_1 + \ldots + X_N}{n_1 + \ldots + n_N}
\]

\( n_i \) is the number of items in the \( i \)th subgroup

**Control Limits for u-charts and c-charts**

The lower and upper control limits, LCL, and UCL, are computed as:

\[
u\text{-chart LCL} = \max(\bar{u} - 3 \sqrt{\bar{u}/n_i}, 0)\]

\[
u\text{-chart UCL} = \bar{u} + 3 \sqrt{\bar{u}/n_i}\]

\[
c\text{-chart LCL} = n_i \bar{u} - 3 \sqrt{n_i \bar{u}}\]

\[
c\text{-chart UCL} = n_i \bar{u} + 3 \sqrt{n_i \bar{u}}\]

The limits vary with \( n_i \).

\( u_i \) is the number of nonconformities per unit in the \( i \)th subgroup. In general, \( u_i = c_i/n_i \).

\( c_i \) is the total number of nonconformities in the \( i \)th subgroup

\( n_i \) is the number of inspection units in the \( i \)th subgroup

\( \bar{u} \) is the average number of nonconformities per unit taken across subgroups. The quantity \( \bar{u} \) is computed as a weighted average

\[
\bar{u} = \frac{n_1 u_1 + \ldots + n_N u_N}{n_1 + \ldots + n_N} = \frac{c_1 + \ldots + c_N}{n_1 + \ldots + n_N}
\]

\( N \) is the number of subgroups
Levey-Jennings Charts

Levey-Jennings charts show a process mean with control limits based on a long-term sigma. The control limits are placed at 3\(s\) distance from the center line.

The standard deviation, \(s\), for the Levey-Jennings chart is calculated the same way standard deviation is in the Distribution platform.

\[
s = \sqrt{\frac{N}{N-1} \sum_{i=1}^{N} (y_i - \bar{y})^2}
\]

Control Limits for g-charts

The negative binomial distribution is an extension of the geometric (Poisson) distribution and allows for over-dispersion relative to the Poisson. The negative binomial distribution can be used to construct both exact and approximate control limits for count data. Approximate control limits can be obtained based on a chi-square approximation to the negative binomial. All data is used as individual observations regardless of subgroup size.

Let \(X\) have a negative binomial distribution with parameters \((\mu, k)\). Then:

\[
P(X \leq r) \sim P(X^2_v \leq \frac{2r+1}{1+\mu k})
\]

where:

\(X^2_v\) is a chi-square variate with \(v = 2\mu/(1+\mu k)\) degrees of freedom.

Based on this approximation, approximate upper and lower control limits can be determined. For a nominal level \(\alpha\) Type 1 error probability in one direction, an approximate upper control limit is a limit \(UCL\) such that:

\[
P(X > UCL) = 1 - P(X^2_v \leq \frac{2UCL+1}{1+\mu k}) = \alpha
\]

Likewise, an approximate lower control limit, \(LCL\), is a limit such that:

\[
P(X < LCL) = 1 - P(X^2_v \geq \frac{2LCL+1}{1+\mu k}) = \alpha
\]

Thus, an approximate level lower and upper control limits, \(LCL\) and \(UCL\), respectively, are computed as:

\[
UCL = \frac{X^2_v, \frac{1}{1-\alpha(1+\mu k)} - 1}{2}
\]
Control Limits for t-charts

If there are no 0s in the data, the estimates of the shape and scale parameters are calculated from the data and used to obtain the percentiles of the Weibull distribution.

To estimate limits from the data:

If:

\[ p_1 = \text{normalDist}(-3) \text{ for Normal (0,1)} \]
\[ p_2 = \text{normalDist}(0) \text{ for Normal (0,1)} \]
\[ p_3 = \text{normalDist}(3) \text{ for Normal (0,1)} \]

Then:

\[ CL = \text{Weibull Quantile (p}_2, \beta, \alpha) \]
\[ UCL = \text{Weibull Quantile (p}_1, \beta, \alpha) \]
\[ LCL = \text{Weibull Quantile (p}_3, \beta, \alpha) \]

where:

\( \beta \) is the shape parameter and \( \alpha \) is the scale parameter for the Weibull Quantile function. For more information about the Weibull Quantile function, see Help > Scripting Index.

Control Limits for 3-way charts

Within Sigma

The within sigma estimate for 3-way charts is estimated using the average of ranges, so it is only appropriate for the Individual on Means, Moving Range on Means and R chart.

\[
\hat{\sigma}_{\text{within}} = \frac{R_1}{d_2(n_1)} + \ldots + \frac{R_N}{d_2(n_N)} \frac{1}{N}
\]
The formula uses the following notation:

\[ R_i = \text{range of } i^{th} \text{ subgroup} \]

\[ n_i = \text{sample size of } i^{th} \text{ subgroup} \]

\[ d_2(n_i) = \text{expected value of the range of } n_i \text{ independent normally distributed variables with unit standard deviation} \]

\[ N = \text{number of subgroups for which } n_i \geq 2 \]

**Between Sigma**

The between sigma estimate for 3-way charts is estimated using the moving range of subgroup means.

\[ \hat{\sigma}_{\text{between}} = \sqrt{\frac{\overline{MR}}{d_2(2)}} \frac{\hat{\sigma}_{\text{within}}}{d_2(2)} \]

The formula uses the following notation:

\[ \overline{MR} = \text{the mean of the nonmissing moving ranges computed as } (MR_2+MR_3+...+MR_N)/(N-1) \]

where \( MR_i = |y_i - y_{i-1}| \).

\[ d_2(2) = \text{expected value of the range of two independent normally distributed variables with unit standard deviation}. \]

\[ H = \frac{N}{\frac{1}{n_1} + \frac{1}{n_2} + \ldots + \frac{1}{n_N}}, \text{ the harmonic mean of subgroup sample sizes.} \]

**Note:** If between Sigma is estimated as a negative value, it is set to 0.

**Between-and-Within Sigma**

The between-and-within sigma estimate for 3-way charts is estimated using a combination of the within sigma and between sigma estimates.

\[ \hat{\sigma}_{\text{between-and-within}} = \sqrt{\hat{\sigma}_{\text{within}}^2 + \hat{\sigma}_{\text{between}}^2} \]
A control chart is a graphical and analytic tool for monitoring process variation. The natural variation in a process can be quantified using a set of control limits. Control limits help distinguish common-cause variation from special-cause variation. Typically, action is taken to eliminate special-cause variation and bring the process back in control. It is also important to quantify the common-cause variation in a process, as this determines process capability.

The Control Chart platform in JMP provides a variety of control charts, as well as run charts. To support process improvement initiatives, most of the control chart options display separate control charts for different phases of a project on the same chart.

- Run Chart
- $\bar{X}$-, $R$-, and $S$-charts
- Individual and Moving Range Charts
- $p$-, $np$-, $c$-, and $u$-charts
- UWMA and EWMA Charts
- CUSUM Charts
- Presummarize, Levey-Jennings, and Multivariate Control Charts
- Phase Control Charts for $\bar{X}$-, $R$-, $S$-, $IR$-, $p$-, $np$-, $c$-, $u$-, Presummarize, and Levey-Jennings Charts.

**Figure 4.1** Control Chart Example
Contents

Overview of the Control Chart Platform ............................................................... 91
Example of the Control Chart Platform ............................................................ 91
Shewhart Control Chart Types ............................................................................ 93
  Control Charts for Variables ........................................................................... 93
  Control Charts for Attributes .......................................................................... 94
Launch the Control Chart Platform .................................................................... 96
  Process Information ......................................................................................... 97
  Chart Type Information ................................................................................... 99
  Limits Specifications ......................................................................................... 99
  Specified Statistics ......................................................................................... 100
The Control Chart Report .................................................................................... 101
Control Chart Platform Options ......................................................................... 103
  Control Chart Window Options ..................................................................... 103
  Individual Control Chart Options .................................................................. 106
Saving and Retrieving Limits ............................................................................ 109
Excluded, Hidden, and Deleted Samples ............................................................ 112
Additional Examples of the Control Chart Platform ......................................... 114
  Run Chart Example ......................................................................................... 114
  X Bar- and R-charts Example ......................................................................... 115
  X-Bar- and S-charts with Varying Subgroup Sizes Example ......................... 117
  Individual Measurement and Moving Range Charts Example ..................... 118
  p-chart Example .............................................................................................. 119
  np-chart Example ........................................................................................... 120
  c-chart Example ............................................................................................. 121
  u-chart Example ............................................................................................. 122
  UWMA Chart Example ................................................................................... 123
  EWMA Chart Example ................................................................................... 124
  Presummarize Chart Example ....................................................................... 125
  Phase Example ................................................................................................. 127
Statistical Details for the Control Chart Platform .............................................. 128
  Control Limits for Median Moving Range Charts ......................................... 128
  Control Limits for UWMA Charts .................................................................. 128
  Control Limits for EWMA Charts .................................................................. 129
Overview of the Control Chart Platform

A control chart is a graphical way to filter out routine variation in a process. Filtering out routine variation helps manufacturers and other businesses determine whether a process is stable and predictable. If the variation is more than routine, the process can be adjusted to create higher quality output at a lower cost.

All processes exhibit variation as the process is measured over time. There are two types of variation in process measurements:

- **Routine** or **common-cause** variation. Even measurements from a stable process exhibit these random ups and downs. When process measurements exhibit only common-cause variation, the measurements stay within expected limits.

- **Abnormal** or **special-cause** variation. Examples of special-cause variation include a change in the process mean, points above or below the control limits, or measurements that trend up or down. These changes can be caused by factors such as a broken tool or machine, equipment degradation, and changes to raw materials. A change or defect in the process is often identifiable by abnormal variation in the process measurements.

Control charts quantify the routine variation in a process, so that special causes can be identified. One way control charts filter out routine variation is by applying control limits. Control limits define the range of process measurements for a process that is exhibiting only routine variation. Measurements between the control limits indicate a stable and predictable process. Measurements outside the limits indicate a special cause, and action should be taken to restore the process to a state of control.

Control chart performance is dependent on the sampling scheme used. The sampling plan should be **rational**, that is, the subgroups are representative of the process. **Rational subgrouping** means that you sample from the process by selecting subgroups in such a way that special causes are more likely to occur between subgroups rather than within subgroups.

Shewhart control charts are broadly classified into control charts for variables and control charts for attributes. Control charts for variables include moving average and CUSUM charts. CUSUM charts are also a type of attribute chart. For details, see “Moving Average Charts” on page 94 and the “V-Mask CUSUM Control Charts” chapter on page 145.

Example of the Control Chart Platform

The following example uses the Coating.jmp sample data table in the Quality Control sample data folder (taken from the ASTM Manual on Presentation of Data and Control Chart Analysis).
The quality characteristic of interest is the Weight column. A subgroup sample of four is chosen.

1. Select Help > Sample Data Library and open Quality Control/Coating.jmp.
2. Select Analyze > Quality And Process > Control Chart > XBar.
   Note the selected chart types of XBar and R.
4. Select Sample and click Sample Label.
5. Click OK.

**Figure 4.2** Variables Charts for Coating Data

An X̄-chart and an R-chart for the process are shown in Figure 4.2. Sample six indicates that the process is not in statistical control. To check the sample values, click the sample six summary point on either control chart. The corresponding rows highlight in the data table.

**Note:** If an S chart is chosen with the X̄-chart, then the limits for the X̄-chart are based on the standard deviation. Otherwise, the limits for the X̄-chart are based on the range.
Shewhart Control Chart Types

Shewhart control charts are broadly classified into control charts for variables and control charts for attributes.

Control Charts for Variables

Control charts for variables are classified according to the subgroup summary statistic plotted on the chart:

- Run charts display data as a connected series of points
- $\overline{X}$-charts display subgroup means (averages)
- $R$-charts display subgroup ranges (maximum – minimum)
- $S$-charts display subgroup standard deviations
- Presummarize charts display subgroup means and standard deviations

The IR selection gives additional chart types:

- Individual Measurement charts display individual measurements
- Moving Range charts display moving ranges of two or more successive measurements

Run Charts

Run charts display a column of data as a connected series of points. Run charts can also plot the group means when the Sample Label role is used, either on the window or through a script.

XBar-, R-, and S- Charts

For quality characteristics measured on a continuous scale, a typical analysis shows both the process mean and its variability with a mean chart aligned above its corresponding $R$- or $S$-chart.

Individual Measurement Charts

Individual Measurement charts displays individual measurements. Individual Measurement charts are appropriate when only one measurement is available for each subgroup sample.

Moving Range charts displays moving ranges of two or more successive measurements. Moving ranges are computed for the number of consecutive measurements that you enter in the Range Span box. The default range span is 2. Because moving ranges are correlated, these charts should be interpreted with care.
Moving Average Charts

In a Moving Average chart, the quantities that are averaged can be individual observations instead of subgroup means. However, a Moving Average chart for individual measurements is not the same as a control (Shewhart) chart for individual measurements or moving ranges with individual measurements plotted.

Uniformly Weighted Moving Average Charts

Each point on a Uniformly Weighted Moving Average (UWMA) chart, also called a Moving Average chart, is the average of the $w$ most recent subgroup means, including the present subgroup mean. When you obtain a new subgroup sample, the next moving average is computed by dropping the oldest of the previous $w$ subgroup means and including the newest subgroup mean. The constant, $w$, is called the span of the moving average, and indicates how many subgroups to include to form the moving average. The larger the span ($w$), the smoother the UWMA line, and the less it reflects the magnitude of shifts. This means that larger values of $w$ guard against smaller shifts.

Exponentially Weighted Moving Average Charts

Each point on an Exponentially Weighted Moving Average (EWMA) chart, also referred to as a Geometric Moving Average (GMA) chart, is the weighted average of all the previous subgroup means, including the mean of the present subgroup sample. The weights decrease exponentially going backward in time. The weight ($0 < \text{weight} \leq 1$) assigned to the present subgroup sample mean is a parameter of the EWMA chart. Small values of weight are used to guard against small shifts.

Presummarize Charts

If your data consist of repeated measurements of the same process unit, you can combine these into one measurement for the unit. Pre-summarizing is not recommended unless the data have repeated measurements on each process or measurement unit.

Presummarize summarizes the process column into sample means and/or standard deviations, based either on the sample size or sample label chosen. Then it charts the summarized data based on the options chosen in the launch window. You can also append a capability analysis by checking the appropriate box in the launch window.

Control Charts for Attributes

In the previous types of charts, measurement data was the process variable. This data is often continuous, and the charts are based on theory for continuous data. Another type of data is count data, where the variable of interest is a discrete count of the number of defects or blemishes per subgroup. For discrete count data, attribute charts are applicable, as they are
based on binomial and Poisson models. Because the counts are measured per subgroup, it is important when comparing charts to determine whether you have a similar number of items in the subgroups between the charts. Attribute charts, like variables charts, are classified according to the subgroup sample statistic plotted on the chart.

Determining Which Attribute Chart to Use

Each item is judged as either conforming or non-conforming:

**p-chart**  Shows the *proportion* of defective items.

**np-chart**  Shows the *number* of defective items.

The number of defects is counted for each item:

**c-chart**  Shows the *number* of defective items.

**u-chart**  Shows the *proportion* of defective items.

For attribute charts, specify the column containing the defect count or defective proportion as the Process variable. The data are interpreted as counts, unless the column contains non-integer values between 0 and 1.

- p-charts display the proportion of nonconforming (defective) items in subgroup samples, which can vary in size. Since each subgroup for a p-chart consists of $N_i$ items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in a subgroup is $N_i$.

- np-charts display the number of nonconforming (defective) items in subgroup samples. Because each subgroup for a np-chart consists of $N_i$ items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in subgroup $i$ is $N_i$.

**Note:** To use the Sigma column property for $P$- or $NP$- charts, the value needs to be equal to the proportion. JMP calculates the sigma as a function of the proportion and the sample sizes.

- c-charts display the number of nonconformities (defects) in a subgroup sample that usually, but does not necessarily, consists of one inspection unit.

**Caution:** For a c-chart, if you do not specify a Sample Size or Constant Size, then the Sample Label is used as the sample size.

- u-charts display the proportion of nonconformities (defects) in each subgroup sample that can have a varying number of inspection units.

**Caution:** For a u-chart, if you do not specify a Unit Size or Constant Size, then the Sample Label is used as the unit size.
Levey-Jennings Charts

Levey-Jennings charts show a process mean with control limits based on a long-term sigma. The control limits are placed at 3σ distance from the center line. The standard deviation, σ, for the Levey-Jennings chart is calculated the same way standard deviation is in the Distribution platform.

Launch the Control Chart Platform

When you launch the Control Chart platform by selecting Analyze > Quality And Process > Control Chart, you will see a Control Chart Launch window similar to Figure 4.3. The exact controls vary depending on which type of chart you select. Initially, the window shows the following types of information:

- Process information, for measurement variable selection
- Chart type information
- Limits specifications
- Specified statistics

Specific information shown for each section varies according to the type of chart that you select. Through interaction with the Launch window, you specify exactly how you want your charts to be created. The following sections describe the window elements.

Figure 4.3 XBar Control Chart Launch Window
Process Information

The Launch window displays a list of columns in the current data table. Here, you specify the variables to be analyzed and the subgroup sample size.

Process

The Process role selects variables for charting.

- For variables charts, specify measurements as the process.
- For attribute charts, specify the defect count or defective proportion as the process. The data are interpreted as counts, unless it contains non-integer values between 0 and 1.

Note: The rows of the table must be sorted in the order in which you want them to appear in the control chart. Even if there is a Sample Label variable specified, you still must sort the data accordingly.

Sample Label

The Sample Label role enables you to specify a variable whose values label the horizontal axis and can also identify unequal subgroup sizes. If you do not specify a sample label variable, the samples are identified by their subgroup sample number.

- If the sample subgroups are the same size, select the Sample Size Constant option and enter the size in the text box. If you entered a Sample Label variable, its values are used to label the horizontal axis. The sample size is used in the calculation of the limits regardless of whether the samples have missing values.
- If the sample subgroups have an unequal number of rows or have missing values and you have a column identifying each sample, select the Sample Grouped by Sample Label option and enter the sample identifying column as the sample label.

For attribute charts (p-, np-, c-, and u-charts), this variable is the subgroup sample size. Additional options appear on the launch window, including Sample Size, Constant Size, and/or Unit Size, depending on your selection. In variables charts, it identifies the sample. When the chart type is IR, a Range Span text box appears. The range span specifies the number of consecutive measurements from which the moving ranges are computed.

Notes:

- The rows of the table must be sorted in the order in which you want them to appear in the control chart. Even if there is a Sample Label variable specified, you still must sort the data accordingly.
- The non-integer part of the value for Constant Size is truncated. If you have a constant non-integer subgroup sample size, you must specify a column of constant values.
The illustration in Figure 4.4 shows an $\bar{X}$-chart for a process with unequal subgroup sample sizes, using the Coating.jmp sample data from the Quality Control sample data folder.

**Figure 4.4 Variables Charts with Unequal Subgroup Sample Sizes**

**Phase**

The **Phase** role enables you to specify a column identifying different phases, or sections. A *phase* is a group of consecutive observations in the data table. For example, phases might correspond to time periods during which a new process is brought into production and then put through successive changes. Phases generate, for each level of the specified Phase variable, a new sigma, set of limits, zones, and resulting tests.

On the window for $\bar{X}$-, $R$-, $S$-, $IR$-, $P$-, $NP$-, $C$-, $U$-, Presummarize, and Levey-Jennings charts, a **Phase** variable button appears. If a phase variable is specified, the phase variable is examined, row by row, to identify to which phase each row belongs. Saving to a limits file reveals the sigma and specific limits calculated for each phase. See “Phase Example” on page 127 for an example.

**By**

The **By** role identifies a variable to produce a separate analysis for each value that appears in the column.
Chart Type Information

Shewhart control charts are broadly classified as variables charts and attribute charts. Moving average charts and CUSUM charts can be thought of as special types of variables charts.

Figure 4.5 Window Options for Variables Control Charts

- **XBar** charts menu selection gives XBar, R, and S check boxes.
- The **IR** menu selection has check box options for the Individual Measurement, Moving Range, and Median Moving Range charts.
- The uniformly weighted moving average (UWMA) and exponentially weighted moving average (EWMA) selections are special charts for means.
- The **CUSUM** chart is a special chart for means or individual measurements.
- **Presummarize** enables you to specify information about pre-summarized statistics.
- **P**, **NP**, **C**, and **U** charts, **Run Chart**, and **Levey-Jennings** charts have no additional specifications.

The types of control charts are discussed in “Overview of the Control Chart Platform” on page 91.

Limits Specifications

You can specify computations for control limits by entering a value for $k$ (K Sigma), or by entering a probability for $\alpha$ (Alpha), or by retrieving a limits value from the process columns' properties or a previously created Limits Table. Limits Tables and the GetLimits button are
discussed in the section “Saving and Retrieving Limits” on page 109. There must be a specification of either K Sigma or Alpha. The window default for K Sigma is 3.

**KSigma**

The KSigma parameter option allows specification of control limits in terms of a multiple of the sample standard error. KSigma specifies control limits at $k$ sample standard errors above and below the expected value, which shows as the center line. To specify $k$, the number of sigmas, click the radio button for KSigma and enter a positive $k$ value into the text box. The usual choice for $k$ is 3, which is three standard deviations. The examples shown in Figure 4.6 compare the $X$-chart for the Coating.jmp data with control lines drawn with KSigma = 3 and KSigma = 4.

**Figure 4.6** K Sigma = 3 (left) and K Sigma=4 (right) Control Limits

![XBar of Weight](image)

**Alpha**

The Alpha parameter option specifies control limits (also called probability limits) in terms of the probability $\alpha$ that a single subgroup statistic exceeds its control limits, assuming that the process is in control. To specify alpha, click the Alpha radio button and enter the probability that you want. Reasonable choices for $\alpha$ are 0.01 or 0.001. For $X$-charts under the assumption of normality and known in-control parameters, the Alpha value equivalent to a KSigma of 3 is 0.0027.

**Specified Statistics**

After specifying a process variable, if you click the Specify Stats (when available) button on the Control Chart Launch window, a tab with editable fields is appended to the bottom of the window. This lets you enter historical statistics (that is, statistics obtained from historical data) for the process variable. The Control Chart platform uses those entries to construct control
charts. The example here shows 1 as the standard deviation of the process variable and 20 as the mean measurement.

**Figure 4.7** Example of Specify Stats

![Known Statistics for XBar Chart]

<table>
<thead>
<tr>
<th>Weight 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sigma</td>
</tr>
<tr>
<td>Mean(measure)</td>
</tr>
<tr>
<td>Mean(range)</td>
</tr>
</tbody>
</table>

**Note:** When the mean is user-specified, it is labeled in the plot as μ₀.

If you check the **Capability** option on the Control Chart launch window (see Figure 4.3), a window appears as the platform is launched asking for specification limits. The standard deviation for the control chart selected is sent to the window and appears as a Specified Sigma value, which is the default option. After entering the specification limits and clicking OK, capability output appears in the same window next to the control chart. For information about how the capability indices are computed, see the Distributions chapter in the *Basic Analysis* book.

---

**The Control Chart Report**

The analysis produces a chart that can be used to determine whether a process is in a state of statistical control. The report varies depending on the type of chart that you select. Figure 4.8 displays the parts of a simple control chart. Control charts update dynamically as data is added or changed in the data table.

**Figure 4.8** Example of a Control Chart
Control charts have the following characteristics:

- Each point plotted on the chart represents an individual process measurement or summary statistic. In Figure 4.8, the points represent the average for a sample of measurements.

  Subgroups should be chosen *rationally*, that is, they should be chosen to maximize the probability of seeing a true process change *between* subgroups.

- The vertical axis of a control chart is scaled in the same units as the summary statistic.

- The horizontal axis of a control chart identifies the subgroup samples and is time ordered. Observing the process over time is important in assessing if the process is changing.

- The green line is the center line, or the average of the data. The center line indicates the average (expected) value of the summary statistic when the process is in statistical control. Measurements should appear equally on both sides of the center line. If not, this is possible evidence that the process average is changing.

- The two red lines are the upper and lower control limits, labeled UCL and LCL. These limits give the range of variation to be expected in the summary statistic when the process is in statistical control. If the process is exhibiting only routine variation, then all the points should fall randomly in that range. In Figure 4.8, one measurement is above the upper control limit. This is evidence that the measurement could have been influenced by a special cause, or is possibly a defect.

- A point outside the control limits (or the V-mask of a CUSUM chart) signals the presence of a special cause of variation.

Options within each platform create control charts that can be updated dynamically as samples are received and recorded or added to the data table.

When a control chart signals abnormal variation, action should be taken to return the process to a state of statistical control if the process degraded. If the abnormal variation indicates an improvement in the process, the causes of the variation should be studied and implemented.

When you double-click the x or y axis, the appropriate Axis Specification window appears for you to specify the format, axis values, number of ticks, gridline, reference lines, and other options to display on the axis.

For example, the *Pickles.jmp* data lists measurements taken each day for three days. In Figure 4.9, by default, the x axis is labeled at every other tick. Sometimes this gives redundant labels, as shown to the left in Figure 4.9. If you specify a label at an increment of eight, the x axis is labeled once for each day, as shown in the chart on the right.
Figure 4.9  Example of Labeled x Axis Tick Marks

Tip: For information about warnings and rules, see “Tests” on page 52 and “Westgard Rules” on page 55 in the “Control Chart Builder” chapter of this guide.

Control Chart Platform Options

Control Charts have red triangle menus that affect various parts of the platform:

- The menu on the top-most title bar affects the whole platform window. Its items vary with the type of chart that you select. See “Control Chart Window Options” on page 103.
- There is a menu of items on the chart type title bar with options that affect each chart individually. See “Individual Control Chart Options” on page 106.

Control Chart Window Options

The red triangle menu on the window title bar lists options that affect the report window. If you request XBar and R at the same time, you can check each chart type to show or hide it. The specific options that are available depend on the type of control chart you request. Unavailable options show as grayed menu items.

Show Limits Legend  Shows or hides the Avg, UCL, and LCL values to the right of the chart.

Connect Through Missing  Connects points when some samples have missing values. In Figure 4.10, the left chart has no missing points. The middle chart has samples 2, 11, 19, and 27 missing with the points not connected. The right chart appears if you select the Connect Through Missing option, which is the default.
Figure 4.10  Example of Connected through Missing Option

<table>
<thead>
<tr>
<th>No missing points</th>
<th>Missing points are not connected</th>
<th>Missing points are connected</th>
</tr>
</thead>
</table>

![Graphs showing connected through missing options](image)

Use Median  For Run Charts, when you select the Show Center Line option in the individual Run Chart red triangle menu, a line is drawn through the center value of the column. The center line is determined by the Use Median setting of the main Run Chart red triangle menu. When Use Median is selected, the median is used as the center line. Otherwise, the mean is used. When saving limits to a file, both the overall mean and median are saved.

Capability  Performs a Capability Analysis for your data. A popup window is first shown, where you can enter the Lower Spec Limit, Target, and Upper Spec Limit values for the process variable.

Figure 4.11  Capability Analysis Window

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Lower Spec Limit</td>
<td>16.5</td>
</tr>
<tr>
<td>Target</td>
<td>21.5</td>
</tr>
<tr>
<td>Upper Spec Limit</td>
<td>23.0</td>
</tr>
</tbody>
</table>

![Capability Analysis Window](image)

An example of a capability analysis report is shown in Figure 4.12 for Coating.jmp when the Lower Spec Limit is set as 16.5, the Target is set to 21.5, and the Upper Spec Limit is set to 23.
For additional information about Capability Analysis, see the Distributions chapter in the *Basic Analysis* book.

**Save Sigma**  Saves the computed value of sigma as a column property in the process variable column in the JMP data table.

**Save Limits**  Saves the control limits in one of the following ways:

- **in Column**  Saves control limits as a column property in the existing data table for the response variable. If the limits are constant, LCL, Avg, and UCL values for each chart type in the report are saved. This option is not available with phase charts. In addition, the option has no effect if the sample sizes are not constant for each chart.

- **in New Table**  Saves the standard deviation and mean for each chart into a new data table. If the limits are constant, the LCL, Avg, and UCL for each chart are saved as well. If there are phases, a new set of values is saved for each phase. You can use this data table to use the limits later. On the Control Chart launch window, click **Get Limits** and then select the saved data table. See the section "Saving and Retrieving Limits" on page 109 for more information.

**Save Summaries**  Creates a new data table that contains the sample label, sample sizes, the statistic being plotted, the center line, and the control limits. The specific statistics included in the table depend on the type of chart.
Alarm Script  Enables you to write and run a script that indicates when the data fail special causes tests. Results can be written to the log or spoken. See “Tests” on page 52 in the “Control Chart Builder” chapter of this guide for more information. See the Platforms chapter in the Scripting Guide for more information about writing custom Alarm Scripts.

See the JMP Reports chapter in the Using JMP book for more information about the following options:

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Individual Control Chart Options

The red triangle menu of chart options appears when you click the icon next to the chart name. Some options are also available under Chart Options when you right-click the chart.

Box Plots  Superimposes box plots on the subgroup means plotted in a Mean chart. The box plot shows the subgroup maximum, minimum, 75th percentile, 25th percentile, and median. Markers for subgroup means show unless you deselect the Show Points option. The control limits displayed apply only to the subgroup mean. The Box Plots option is available only for X-charts. It is most appropriate for larger subgroup sample sizes (more than 10 samples in a subgroup).

Needle  Connects plotted points to the center line with a vertical line segment.

Connect Points  Shows or hides the line that connects the data points.

Show Points  Shows or hides the points representing summary statistics. Initially, the points show. You can use this option to suppress the markers denoting subgroup means when the Box Plots option is in effect.

Connect Color  Displays the JMP color palette for you to choose the color of the line segments used to connect points.

Center Line Color  Displays the JMP color palette for you to choose the color of the line segments used to draw the center line.
**Limits Color**  Displays the JMP color palette for you to choose the color of the line segments used in the upper and lower limits lines.

**Line Width**  Allows you to select the width of the control lines. Options are Thin, Medium, or Thick.

**Point Marker**  Allows you to select the marker used on the chart.

**Show Center Line**  Initially displays the center line in green. Deselecting Show Center Line removes the center line and its legend from the chart.

**Show Control Limits**  Shows or hides the chart control limits and their legends.

**Limits Precision**  Sets the decimal limit for labels.

**Tests**  Shows a submenu that enables you to choose which tests to mark on the chart when the test is positive. Tests apply only for charts whose limits are $3\sigma$ limits. Tests 1 to 4 apply to Mean, Individual, and attribute charts. Tests 5 to 8 apply to Mean charts, Presummarize, and Individual Measurement charts only. If tests do not apply to a chart, the Tests option is dimmed. When sample sizes are unequal, the Test options are grayed out. If the samples change while the chart is open and they become equally sized, and the zone and/or test option is selected, the zones and/or tests are applied immediately and appear on the chart. These special tests are also referred to as the Western Electric Rules. For more information about special causes tests, see “Tests” on page 52 in the “Control Chart Builder” chapter.

**Westgard Rules**  Westgard rules are control rules that help you decide whether a process is in or out of control. The different tests are abbreviated with the decision rule for the particular test. See the text and chart in “Westgard Rules” on page 55 in the “Control Chart Builder” chapter.

**Test Beyond Limits**  Flags as a “*” any point that is beyond the limits. This test works on all charts with limits, regardless of the sample size being constant, and regardless of the size of $k$ or the width of the limits. For example, if you had unequal sample sizes, and wanted to flag any points beyond the limits of an $r$-chart, you could use this command.

**Show Zones**  Shows or hides the zone lines. The zones are labeled A, B, and C as shown here in the Mean plot for weight in the Coating.jmp sample data. Control Chart tests use the zone lines as boundaries. The seven zone lines are set one sigma apart, centered on the center line.
Shewhart Control Charts

Chapter 4

Control Chart Platform Options

Quality and Process Methods

Figure 4.13  Show Zones

Shade Zones  Shows or hides the default green, yellow, and red colors for the three zone areas and the area outside the zones. Green represents the area one sigma from the center line, yellow represents the area two and three sigmas from the center line, and red represents the area beyond three sigma. Shades can be shown with or without the zone lines.

Figure 4.14  Shade Zones

OC Curve  Gives Operating Characteristic (OC) curves for specific control charts. OC curves are defined in JMP only for $\bar{X}$-, $p$-, $np$-, $c$-, and $u$-charts. The curve shows how the probability of accepting a lot changes with the quality of the sample. When you choose the OC Curve option from the control chart option list, JMP opens a new window containing the curve, using all the calculated values directly from the active control chart. Alternatively, you can run an OC curve directly from the Control category of the JMP Starter. Select the chart on which you want the curve based, then a window prompts you for Target, Lower Control Limit, Upper Control Limit, $k$, Sigma, and Sample Size. You can also perform both single and double acceptance sampling in the same manner. To engage this feature, choose View > JMP Starter > Control (under Click Category) > OC Curves. A pop-up window enables you to specify whether single or double acceptance sampling is desired. A second pop-up window is invoked, where you can specify acceptance failures,
number inspected, and lot size (for single acceptance sampling). Clicking OK generates the desired OC curve.

## Saving and Retrieving Limits

JMP can use previously established control limits for control charts:

- Upper and lower control limits, and a center line value.
- Parameters for computing limits such as a mean and standard deviation.

The control limits or limit parameter values must be either in a JMP data table, referred to as the *Limits Table*, or stored as a column property in the process column. When you specify the Control Chart command, you can retrieve the Limits Table with the Get Limits button on the Control Chart launch window.

**Tip:** To add specification limits to several columns at once, see the Statistical Details appendix in the *Quality and Process Methods* book.

The easiest way to create a Limits Table is to save results computed by the Control Chart platform. The Save Limits command in the red triangle menu for each control chart automatically saves limits from the sample values. The type of data saved in the table varies according to the type of control chart in the analysis window. You can also use values from any source and create your own Limits Table.

All Limits Tables must have:

- A column of special keywords that identify each row.
- A column for each of the variables whose values are the known standard parameters or limits. This column name must be the same as the corresponding process variable name in the data table to be analyzed by the Control Chart platform.

The following table describes the limit keywords and their associated control chart for both Shewhart Control Charts and charts created with Control Chart Builder.

<table>
<thead>
<tr>
<th>Keywords</th>
<th>For Charts</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>_KSigma</td>
<td>All except Control Chart Builder</td>
<td>multiples of the standard deviation of the statistics to calculate the control limits; set to missing if the limits are in terms of the alpha level</td>
</tr>
</tbody>
</table>
### Table 4.1 Limits Table Keys with Appropriate Charts and Meanings (Continued)

<table>
<thead>
<tr>
<th>Keywords</th>
<th>For Charts</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>_Alpha</td>
<td>All except Control Chart Builder</td>
<td>Type I error probability used to calculate the control limits</td>
</tr>
<tr>
<td>_Range Span</td>
<td>IM, MR, MMR</td>
<td>number of consecutive measurements for which moving ranges are computed. Not applicable in the Control Chart Builder platform, where the range span is always equal to 2.</td>
</tr>
<tr>
<td>_Std Dev</td>
<td>$\bar{X}$, $R$, $S$, IM, MR</td>
<td>known process standard deviation</td>
</tr>
<tr>
<td>_U</td>
<td>$c$, $u$</td>
<td>known average number of nonconformities per unit</td>
</tr>
<tr>
<td>_P</td>
<td>$np$, $p$</td>
<td>known value of average proportion nonconforming</td>
</tr>
<tr>
<td>_LCL, _UCL</td>
<td>$\bar{X}$, IM, $p$, $np$, $c$, $u$, $g$, $t$</td>
<td>lower and upper control limit for Mean Chart, Individual Measurement chart, or any attribute or rare event chart</td>
</tr>
<tr>
<td>_AvgR</td>
<td>$R$, MR</td>
<td>average range or average moving range</td>
</tr>
<tr>
<td>_LCLR, _UCLR</td>
<td>$R$, MR</td>
<td>lower control limit for R- or MR chart</td>
</tr>
<tr>
<td></td>
<td></td>
<td>upper control limit for R- or MR chart</td>
</tr>
<tr>
<td>_AvgS, _LCLS, _UCLS</td>
<td>S-Chart</td>
<td>average standard deviation, upper and lower control limits for S-chart</td>
</tr>
</tbody>
</table>

Table 4.1 Limits Table Keys with Appropriate Charts and Meanings (Continued)
You can save limits in a new data table or as properties of the response column. When you save control limits using the **in New Table** command, the limit keywords written to the table depend on the current chart types displayed.

Figure 4.15 shows examples of control limits saved to a data table using `Coating.jmp`. The rows with values `_Mean`, `_LCL`, and `_UCL` are for the Individual Measurement chart. The values with the `R` suffix (`_AvgR`, `_LCLR`, and `_UCLR`) are for the Moving Range chart. If you create these charts again using this Limits Table, the Control Chart platform identifies the appropriate limits from keywords in the `_LimitsKey` column.

### Table 4.1 Limits Table Keys with Appropriate Charts and Meanings (Continued)

<table>
<thead>
<tr>
<th>Keywords</th>
<th>For Charts</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>_AvgR_PreMeans</code></td>
<td>IM, MR</td>
<td>Mean, upper, and lower control limits based on pre-summarized group means or standard deviations.</td>
</tr>
<tr>
<td><code>_AvgR_PreStdDev</code></td>
<td>I</td>
<td></td>
</tr>
<tr>
<td><code>_LCLR_PreMeans</code></td>
<td>MR</td>
<td></td>
</tr>
<tr>
<td><code>_LCLR_PreStdDev</code></td>
<td>I</td>
<td></td>
</tr>
<tr>
<td><code>_UCLR_PreMeans</code></td>
<td>MR</td>
<td></td>
</tr>
<tr>
<td><code>_UCLR_PreStdDev</code></td>
<td>I</td>
<td></td>
</tr>
<tr>
<td><code>_Avg_PreMeans</code></td>
<td>IM, MR</td>
<td></td>
</tr>
<tr>
<td><code>_Avg_PreStdDev</code></td>
<td>I</td>
<td></td>
</tr>
<tr>
<td><code>_LCL_PreMeans</code></td>
<td>MR</td>
<td></td>
</tr>
<tr>
<td><code>_LCL_PreStdDev</code></td>
<td>I</td>
<td></td>
</tr>
<tr>
<td><code>_UCL_PreMeans</code></td>
<td>MR</td>
<td></td>
</tr>
<tr>
<td><code>_UCL_PreStdDev</code></td>
<td>I</td>
<td></td>
</tr>
</tbody>
</table>
Excluded, Hidden, and Deleted Samples

The following table summarizes the effects of various conditions on samples and subgroups:

Table 4.2 Excluded, Hidden, and Deleted Samples

<table>
<thead>
<tr>
<th>Condition</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>All rows of the sample are</td>
<td>Sample is not included in the calculation of the limits, but it appears on the graph.</td>
</tr>
</tbody>
</table>
Some additional notes:

- Hide and Exclude operate only on the row state of the first observation in the sample. For example, if the second observation in the sample is hidden, while the first observation is not hidden, the sample will still appear on the chart.

- An exception to the exclude/hide rule: Both hidden and excluded rows are included in the count of points for Tests for Special Causes. An excluded row can be labeled with a special cause flag. A hidden point cannot be labeled. If the flag for a Tests for Special Causes is on a hidden point, it will not appear in the chart.

- Because of the specific rules in place (see Table 4.2 on page 112), the control charts do not support the Automatic Recalc script.
Additional Examples of the Control Chart Platform

- “Run Chart Example”
- “X Bar- and R-charts Example”
- “X-Bar- and S-charts with Varying Subgroup Sizes Example”
- “Individual Measurement and Moving Range Charts Example”
- “p-chart Example”
- “np-chart Example”
- “c-chart Example”
- “u-chart Example”
- “UWMA Chart Example”
- “EWMA Chart Example”
- “Presummarize Chart Example”
- “Phase Example”

Run Chart Example

Run charts display a column of data as a connected series of points. The following example is a Run chart for the Weight variable from Coating.jmp in the Quality Control sample data folder (taken from the ASTM Manual on Presentation of Data and Control Chart Analysis).

1. Select Help > Sample Data Library and open Quality Control/Coating.jmp.
2. Select Analyze > Quality and Process > Control Chart > Run Chart.
4. Select Sample and click Sample Label.
5. Click OK.
Quality and Process Methods

Additional Examples of the Control Chart Platform

X Bar- and R-charts Example

The following example uses the Coating.jmp data table. The quality characteristic of interest is the Weight column. A subgroup sample of four is chosen. An $\bar{X}$-chart and an $R$-chart for the process are shown in Figure 4.17.

1. Select Help > Sample Data Library and open Quality Control/Coating.jmp.
2. Select Analyze > Quality and Process > Control Chart > XBar.
   Note the selected chart types of XBar and R.
4. Select Sample and click Sample Label.
5. Click OK.

Sample six indicates that the process is not in statistical control. To check the sample values, click the sample six summary point on either control chart. The corresponding rows highlight in the data table.

Note: If an S chart is chosen with the $\bar{X}$-chart, then the limits for the $\bar{X}$-chart are based on the standard deviation. Otherwise, the limits for the $\bar{X}$-chart are based on the range.
6. Right-click in the XBar of Weight plot and select **Chart Options > Box Plots**.

7. Double-click on the Y axis (Mean of Weight) and change the Minimum value to 16, then click OK.
Chapter 4
Quality and Process Methods

Shewhart Control Charts

Additional Examples of the Control Chart Platform

Figure 4.18  Box Plots for Coating Data

The box plots in Figure 4.18 show that the sixth sample has a small range of high values.

X-Bar- and S-charts with Varying Subgroup Sizes Example

The following example uses the Coating.jmp data table. This quality characteristic of interest is the Weight 2 column. An $\bar{X}$-chart and an $S$ chart for the process are shown in Figure 4.19.

1. Select Help > Sample Data Library and open Quality Control/Coating.jmp.
2. Select Analyze > Quality and Process > Control Chart > XBar.
3. Select the chart types of XBar and S.
4. Select Weight 2 and click Process.
5. Select Sample and click Sample Label.
   The Sample Size option should automatically change to Sample Grouped by Sample Label.
6. Click OK.
Weight 2 has several missing values in the data, so you might notice the chart has uneven limits. Although, each sample has the same number of observations, samples 1, 3, 5, and 7 each have a missing value.

**Note:** When sample sizes are unequal, the Test options are grayed out. If the samples change while the chart is open and they become equally sized, and the zone and/or test option is selected, the zones and/or tests will be applied immediately and appear on the chart.

**Individual Measurement and Moving Range Charts Example**

The Pickles.jmp data in the Quality Control sample data folder contains the acid content for vats of pickles. Because the pickles are sensitive to acidity and produced in large vats, high acidity ruins an entire pickle vat. The acidity in four vats is measured each day at 1, 2, and 3 PM. The data table records day, time, and acidity measurements. You can create Individual Measurement and Moving Range charts with date labels on the horizontal axis.

1. Select **Help > Sample Data Library** and open Quality Control/Pickles.jmp.
2. Select **Analyze > Quality and Process > Control Chart > IR**.
3. Select both **Individual Measurement** and **Moving Range** chart types.
4. Select Acid and click **Process**.
5. Select Date and click **Sample Label**.
6. Click **OK**.

The individual measurement and moving range charts shown in Figure 4.20 monitor the acidity in each vat produced.

**Note:** A Median Moving Range chart can also be evaluated. If you choose a Median Moving Range chart and an Individual Measurement chart, the limits on the Individual Measurement chart use the Median Moving Range as the sigma, rather than the Average Moving Range.

---

**Figure 4.20** Individual Measurement and Moving Range Charts for Pickles Data

---

**p-chart Example**

**Note:** When you generate a $p$-chart and select **Capability**, JMP launches the Binomial Fit in Distribution and gives a Binomial-specific capability analysis.
The Washers.jmp data in the Quality Control sample data folder contains defect counts of 15 lots of 400 galvanized washers. The washers were inspected for finish defects such as rough galvanization and exposed steel. If a washer contained a finish defect, it was deemed nonconforming or defective. Thus, the defect count represents how many washers were defective for each lot of size 400. Using the Washers.jmp data table, specify a sample size variable, which would allow for varying sample sizes. This data contains all constant sample sizes.

1. Select Help > Sample Data Library and open Quality Control/Washers.jmp.
2. Select Analyze > Quality and Process > Control Chart > P.
4. Select Lot and click Sample Label.
5. Select Lot Size and click Sample Size.
6. Click OK.

Figure 4.21  p-chart

The $p$-chart shows the proportion of defects. Note that although the points on the chart look the same as the $np$-chart in Figure 4.22, the $y$ axis, Avg and limits are all different since they are now based on proportions.

**np-chart Example**

*Note:* When you generate a $np$-chart and select Capability, JMP launches the Binomial Fit in Distribution and gives a Binomial-specific capability analysis.

The following example uses the Washers.jmp data table.

1. Select Help > Sample Data Library and open Quality Control/Washers.jmp.
2. Select Analyze > Quality and Process > Control Chart > NP.
4. Change the Constant Size to 400.
5. Click OK.

**Figure 4.22 np-chart**

An \( np \)-chart for the number of defects appears. Points 4 and 9 are above the upper control limit.

**c-chart Example**

c-charts monitor the number of nonconformities in an entire subgroup, made up of one or more units.

**Note:** When you generate a c-chart and select Capability, JMP launches the Poisson Fit in Distribution and gives a Poisson-specific capability analysis.

In this example, a clothing manufacturer ships shirts in boxes of ten. Prior to shipment, each shirt is inspected for flaws. Because the manufacturer is interested in the average number of flaws per shirt, the number of flaws found in each box is divided by ten and then recorded.

1. Select Help > Sample Data Library and open Quality Control/Shirts.jmp.
2. Select Analyze > Quality and Process > Control Chart > C.
4. Select Box and click Sample Label.
5. Select Box Size and click Sample Size.
6. Click OK.
Figure 4.23  c-chart

u-chart Example

The Braces.jmp data in the Quality Control sample data folder records the defect count in boxes of automobile support braces. A box of braces is one inspection unit. The number of boxes inspected (per day) is the subgroup sample size, which can vary. The \( u \)-chart in Figure 4.24 is monitoring the number of brace defects per subgroup sample size. The upper and lower bounds vary according to the number of units inspected.

**Note:** When you generate a \( u \)-chart, and select **Capability**, JMP launches the Poisson Fit in Distribution and gives a Poisson-specific capability analysis. To use the **Capability** feature, the unit sizes must be equal.

1. Select **Help > Sample Data Library** and open Quality Control/Braces.jmp.
2. Select **Analyze > Quality and Process > Control Chart > U**.
3. Select **# defects** and click **Process**.
4. Select **Date** and click **Sample Label**.
5. Select **Unit size** and click **Unit Size**.
6. Click **OK**.
UWMA Chart Example

In the sample data table Clips1.jmp, the measure of interest is the gap between the ends of manufactured metal clips. To monitor the process for a change in the average gap, subgroup samples of five clips are selected daily. A UWMA chart with a moving average span of three is examined.

1. Select Help > Sample Data Library and open Quality Control/Clips1.jmp.
2. Select Analyze > Quality and Process > Control Chart > UWMA.
4. Select Sample and click Sample Label.
5. Change the Moving Average Span to 3.
6. Click OK.

The result is the chart in Figure 4.25. The point for the first day is the mean of the five subgroup sample values for that day. The plotted point for the second day is the average of subgroup sample means for the first and second days. The points for the remaining days are the average of subsample means for each day and the two previous days.

The average clip gap appears to be decreasing, but no sample point falls outside the 3σ limits.
**EWMA Chart Example**

The following example uses the Clips1.jmp data table.

1. Select Help > Sample Data Library and open Quality Control/Clips1.jmp.
2. Select Analyze > Quality and Process > Control Chart > EWMA.
4. Select Sample and click Sample Label.
5. Change the Weight to 0.5.
6. Click OK.

**Figure 4.25 UWMA Charts for the Clips1 data**

![UWMA Chart](image)

**Figure 4.26 EWMA Chart**

![EWMA Chart](image)

The EWMA chart appears for the same data shown in Figure 4.25. This EWMA chart was generated for weight = 0.5.
Presummarize Chart Example

The following example uses the Coating.jmp data table.

1. Select Help > Sample Data Library and open Quality Control/Coating.jmp.
2. Select Analyze > Quality and Process > Control Chart > Presummarize.
4. Select Sample and click Sample Label.
5. Select both Individual on Group Means and Moving Range on Group Means. The Sample Grouped by Sample Label button is automatically selected when you choose a Sample Label variable.

When using Presummarize charts, you can select either On Group Means options or On Group Std Devs options or both. Each option creates two charts (an Individual Measurement, also known as an X chart, and a Moving Range chart) if both IR chart types are selected.

The On Group Means options compute each sample mean and then plot the means and create an Individual Measurement and a Moving Range chart on the means.

The On Group Std Devs options compute each sample standard deviation and plot the standard deviations as individual points. Individual Measurement and Moving Range charts for the standard deviations then appear.

6. Click OK.
Although the points for $\bar{X}$- and $S$-charts are the same as the Individual on Group Means and Individual on Group Std Devs charts, the limits are different because they are computed as Individual charts.

Another way to generate the presummarized charts, with the Coating.jmp data table:

1. Choose Tables > Summary.
2. Select Sample and click Group.
3. Select Weight, then click Statistics > Mean and Statistics > Std Dev.
4. Click OK.
5. Select Analyze > Quality and Process > Control Chart > IR.
6. Select Mean(Weight) and Std Dev(Weight) and click Process.
7. Click OK.

The resulting charts match the presummarized charts.
Phase Example

Open Diameter.jmp, found in the Quality Control sample data folder. This data set contains the diameters taken for each day, both with the first prototype (phase 1) and the second prototype (phase 2).

1. Select Help > Sample Data Library and open Quality Control/Diameter.jmp.
2. Select Analyze > Quality and Process > Control Chart > XBar.
4. Select DAY and click Sample Label.
5. Select Phase and click Phase.
6. Select S and XBar.
7. Click OK.

The resulting chart has different limits for each phase.

Figure 4.28 Phase Control Chart
Statistical Details for the Control Chart Platform

- “Control Limits for Median Moving Range Charts”
- “Control Limits for UWMA Charts”
- “Control Limits for EWMA Charts”

**Note:** For details on other types of charts (such as $\bar{X}$- and $R$-charts, $p$- and np-charts, and more) see the “Statistical Details for the Control Chart Builder Platform” on page 80 in the “Control Chart Builder” chapter.

### Control Limits for Median Moving Range Charts

Control limits for Median Moving Range charts are computed as follows.

\[
\begin{align*}
\text{LCL}_{\text{MMR}} &= \max(0, \text{MMR} - kd_3(n) \hat{\sigma}) \\
\text{UCL}_{\text{MMR}} &= \text{MMR} + kd_3(n) \hat{\sigma}
\end{align*}
\]

where:

- MMR is the median of the nonmissing moving ranges.
- $\hat{\sigma} = \text{MMR}/0.954$
- $d_3(n)$ is the standard deviation of the range of $n$ independent observations from a normal population with unit standard deviation.

### Control Limits for UWMA Charts

Control limits for UWMA charts are computed for each subgroup $i$ as follows.

\[
\begin{align*}
\text{LCL}_i &= \bar{X}_w - k \frac{\hat{\sigma}}{\min(i, w)} \left[ \frac{1}{n_i} + \frac{1}{n_{i-1}} + \ldots + \frac{1}{n_{1 + \max(i - w, 0)}} \right] \\
\text{UCL}_i &= \bar{X}_w + k \frac{\hat{\sigma}}{\min(i, w)} \left[ \frac{1}{n_i} + \frac{1}{n_{i-1}} + \ldots + \frac{1}{n_{1 + \max(i - w, 0)}} \right]
\end{align*}
\]

where:

- $w$ is the span parameter (number of terms in moving average)
- $n_i$ is the sample size of the $i^{th}$ subgroup
- $k$ is the number of standard deviations
\( \bar{X}_w \) is the weighted average of subgroup means
\( \hat{\sigma} \) is the estimated process standard deviation

**Control Limits for EWMA Charts**

Control limits for EWMA charts are computed as:

\[
\text{LCL} = \bar{X}_w - k\hat{\sigma}r \sqrt{\sum_{j=0}^{i-1} \frac{(1-r)^{2j}}{n_{i-j}}}
\]

\[
\text{UCL} = \bar{X}_w + k\hat{\sigma}r \sqrt{\sum_{j=0}^{i-1} \frac{(1-r)^{2j}}{n_{i-j}}}
\]

where:

- \( r \) is the EWMA weight parameter (0 < \( r \) ≤ 1)
- \( x_{ij} \) is the \( j \)th measurement in the \( i \)th subgroup, with \( j = 1, 2, 3, ..., n_i \)
- \( n_i \) is the sample size of the \( i \)th subgroup
- \( k \) is the number of standard deviations
- \( \bar{X}_w \) is the weighted average of subgroup means
- \( \hat{\sigma} \) is the estimated process standard deviation
CUSUM Control Charts
Create Tabular CUSUM Control Charts with Decision Limits

Cumulative Sum (CUSUM) control charts enable you to detect small shifts in a process. They are useful in detecting shifts that occur over time, such as a gradual drift, and that are not necessarily accompanied by a sudden shift. The CUSUM Control Chart platform creates a CUSUM chart with decision limits, similar to a Shewhart chart. This chart is also called a tabular CUSUM chart. To create a V-mask cumulative sum control chart, see Chapter 6, “V-Mask CUSUM Control Charts”.

The CUSUM Control Chart platform also provides information about average run length (ARL). The average run length is the average number of samples or observations that can be expected to occur before an out-of-control signal occurs. You can use the average run length to assess the performance of a CUSUM chart, given specific parameters and assuming constant variance.

Figure 5.1 CUSUM Control Chart
Contents

Overview of the CUSUM Control Chart Platform .......................................................... 133
Example of CUSUM Control Chart ........................................................................... 133
Launch the CUSUM Control Chart Platform ............................................................... 134
The CUSUM Control Chart Platform Report .............................................................. 135
  Control Panel ............................................................................................................. 136
  CUSUM Chart .......................................................................................................... 137
CUSUM Control Chart Platform Options ................................................................. 137
  Average Run Length (ARL) Report ........................................................................... 139
Additional Example of CUSUM Control Charts ...................................................... 140
  Example of the Data Units Option .......................................................................... 140
  Example of CUSUM Chart with Subgroups ............................................................ 141
Statistical Details for the CUSUM Control Chart Platform ...................................... 142
  Statistical Details for CUSUM Control Chart Construction .................................. 142
  Statistical Details for Shift Detection ...................................................................... 144
  Statistical Details for Average Run Length ............................................................. 144
Overview of the CUSUM Control Chart Platform

A tabular CUSUM chart consists of two one-sided decision limits charts superimposed on one chart. The chart contains decision limits that signal when the process is out of control and places a shift line on the chart where the shift is suspected to have occurred. To use the CUSUM Control Chart platform, you must determine the smallest change in the mean that you consider important. You can view the CUSUM control chart in standard deviation units or in data units. For more information about tabular CUSUM charts, see Woodall and Adams (1998) and Montgomery (2013).

Another form of a cumulative sum control chart is the V-mask chart. To create a V-mask CUSUM chart, see “V-Mask CUSUM Control Charts” chapter on page 145.

Note: The summary results in the CUSUM Control Chart platform do not always match the summary results in the V-mask CUSUM platform. Specifically, the summary results for a two-sided V-mask CUSUM chart do not match those from a CUSUM Control Chart with both Upper Side and Lower Side options selected. However, the one-sided summary reports from the CUSUM Control Chart platform and the V-mask CUSUM platform do match.

Example of CUSUM Control Chart

You want to detect small shifts in the temperature of an engine. The data table contains temperature measurements from the engine thermostat.

2. Select Analyze > Quality and Process > CUSUM Control Chart.
3. Select Y and click Y.
4. Click OK.
5. In the Target box, type 100.
6. In the Sigma box, type 10.
7. Select the Lower Side box.
CUSUM Control Charts

Launch the CUSUM Control Chart Platform

**Figure 5.2** CUSUM Control Chart Report

![CUSUM Control Chart Report](image)

The vertical line on the CUSUM Chart indicates that a shift in the temperature measurements started around sample 26.

**Note:** You can compare this result to the Individual Moving Range control chart by running the IMR Chart table script in Engine Temperature Sensor.jmp. The IMR chart does not trigger any of the Nelson tests.

---

**Launch the CUSUM Control Chart Platform**

Launch the CUSUM Control Chart platform by selecting **Analyze > Quality and Process > CUSUM Control Chart**.

**Figure 5.3** The CUSUM Control Chart Launch Window

![CUSUM Control Chart Launch Window](image)

**Y** Identifies the variables that you want to chart.
Note: The rows of the data table must be sorted in the order in which you want them to appear in the control chart.

X  Identifies a subgroup variable whose values label the horizontal axis. If a value of this column is present more than once, the average response at each X value is plotted on the CUSUM chart.

By  Produces a separate report for each level of the By variable. If more than one By variable is assigned, a separate report is produced for each possible combination of the levels of the By variables.

Data Units  Specifies that data units be used in the report rather than standard deviation units. By default, the chart and parameters are shown in standard deviation units. However, if you select the Data Units option in the launch window, the chart and parameters are shown in the units of the data column that is being analyzed.

When you use standard deviation units, values for the $h$ and $k$ parameters do not depend on the process standard deviation. This can be an advantage.

For more information about the launch window, see the Get Started chapter in the Using JMP book.

The CUSUM Control Chart Platform Report

By default, the CUSUM Control Chart platform produces a report that contains a parameter control panel and a CUSUM chart.
Control Panel

The Control Panel report contains the current values for the chart parameters. The current values are in boxes that enable you to update the parameter values. There are also boxes for Upper Side and Lower Side. If you have specified the Data Units option in the launch window, this setting is denoted in the Control Panel below the check boxes.

The options that appear in the Control Panel report are as follows:

**Target**  The known value of the mean. This is the value of the center line in the chart. By default, this parameter is set to the overall average of the Y column.

**Sigma**  The known value of the standard deviation. By default, this parameter is set to the average moving range of the Y column. If there is an X variable, the Sigma parameter is set to the average moving range of the summary data.

**Head Start**  The value of the cumulative sums before the first sample. Starting the cumulative sums at a nonzero value increases the sensitivity of the CUSUM chart near the beginning of the samples. This parameter is also known as the fast initial response (FIR) value. By default, this parameter is set to 0.

**h or H**  The value of the parameter that defines the limits. If the Data Units option was not selected in the launch window, this is the h parameter. If the Data Units option was selected in the launch window, this is the H parameter. Note that H is equal to h times Sigma. By default, h is equal to 5 and H is equal to 5 times Sigma.

**k or K**  The value of the parameter that defines the smallest change in the mean that is valuable to detect. If the Data Units option was not selected in the launch window, this is...
the k parameter. If the Data Units option was selected in the launch window, this is the K parameter. Note that K is equal to k times Sigma. By default, k is equal to 0.5 and K is equal to one half of Sigma.

**Upper Side**  Shows or hides the positive values for the cumulative sum on the chart. These values are the \( C^+ \) values.

**Lower Side**  Shows or hides the negative values for the cumulative sum on the chart. These values are the \( C^- \) values.

**Using Data Units**  The presence of this text indicates that the Data Units option was selected in the launch window and that the values in the CUSUM chart are centered but not standardized.

### CUSUM Chart

The CUSUM Chart report contains the cumulative sum control chart with decision limits that are determined by the current values of the chart parameters. The samples (or subgroups if an X variable is specified) are denoted on the horizontal axis. The vertical axis contains centered values of the positive and negative values for the cumulative sum. If the Data Units option was not selected in the launch window, the vertical axis represents cumulative sums for standardized response values. If the Data Units option was selected in the launch window, the vertical axis represents cumulative sums for unstandardized response values.

### CUSUM Control Chart Platform Options

The CUSUM Control Chart red triangle menu contains the following options:

**Show Limits**  Shows or hides the upper and lower decision limits in the CUSUM Chart.

**Show Center Line**  Shows or hides the center line in the CUSUM Chart.

**Show Shift Lines**  (Available only when there is a shift detected in the data.) Shows or hides the lines in the CUSUM Chart that designate shifts. Shift lines are drawn at the start of a shift.

- A positive shift occurs when the value of \( C^+ \) exceeds the upper limit on the chart. The start of the shift is defined as the first point after the most recent zero value for \( C^+ \).
- A negative shift occurs when the value of \( C^- \) exceeds the lower limit on the chart. The start of the shift is defined as the first point after the most recent zero value for \( C^- \).

**Show ARL**  Shows or hides the Average Run Length (ARL) report. See “Average Run Length (ARL) Report” on page 139.
ARL Profiler  Shows or hides a profiler of average run length versus the parameters h and k. If you have specified the Data Units option in the launch window, the profiler plots average run length versus the parameters H and K.

The average run length (ARL) for a specified shift is the average number of runs expected before an out-of-control signal occurs. For example, the ARL at 0 represents the average number of runs expected before a false-alarm signal occurs when the process is in control. When the process is in control, the shift size is 0.

The ARL Profiler enables you to explore how various settings of the parameters affect the performance of the corresponding CUSUM chart. As the parameters in the Control Panel report are updated, the ARL Profiler is updated as well. An ideal CUSUM chart has a high ARL(0) value and a low ARL(Δ) value, where Δ is the size shift that is of interest.

The ARL Profiler depends on the settings of the Upper Side and Lower Side options in the Control Panel report:

– If both the Upper Side and Lower Side options are selected, the profiler represents the average run length for crossing either the upper or lower decision limits on the CUSUM chart.

– If only the Upper Side option is selected, the profiler represents the average run length for the upper decision limit on the CUSUM chart.

– If only the Lower Side option is selected, the profiler represents the average run length for the lower decision limit on the CUSUM chart.

For more information about the options in the red triangle menu next to ARL Profiler, see the Profiler chapter in the Profilers book.

Control Panel  Shows or hides a report of the current values of the parameters. This report enables you to change the parameter values as well as the sidedness of the CUSUM chart.

Parameters Report  Shows or hides a report of the current values of the parameters.

Save Summaries  Creates a new data table that contains statistics for each subgroup in the CUSUM chart. The following statistics are saved to the new data table: the subgroup number and size, the subgroup sample mean, an indicator of shift starts, the upper and lower cumulative sums and corresponding consecutive run counts, and the LCL and UCL values.

Reset to Defaults  Resets all parameters back to their default values.

See the JMP Reports chapter in the Using JMP book for more information about the following options:

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.
**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

**Save By-Group Script**  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

## Average Run Length (ARL) Report

The Average Run Length (ARL) report contains a table and a graph of ARL values. The average run length (ARL) for a specified shift is the average number of runs expected before an out-of-control signal occurs. For example, the ARL at 0 represents the average number of runs expected before seeing a false-alarm signal when the process is in control. When the process is in control, the shift size is 0.

The table and graph in the ARL report enables you to explore how various settings of the parameters affect the performance of the corresponding CUSUM chart. As the $h$ and $k$ parameters in the Control Panel report are updated, the ARL report is updated as well. An ideal CUSUM chart has a high ARL(0) value and a low ARL($\Delta$) value, where $\Delta$ is the size shift that is of interest.

The Average Run Length (ARL) report depends on the settings of the Upper Side and Lower Side options in the Control Panel report. If only one option is selected, the ARL report uses calculations for the corresponding one-sided CUSUM chart. If both options are selected, the ARL report uses calculations for the two-sided CUSUM chart. Note that the two-sided ARL values are related to the positive and negative one-sided ARL values by the following equation:

$$\frac{1}{\text{ARL}} = \frac{1}{\text{Positive ARL}} + \frac{1}{\text{Negative ARL}}$$

### ARL Table

The ARL Table shows the average run length for shifts ($\Delta$) between zero and three at 0.25 increments. If the Data Units option is specified, the shift is represented by $2*K/\Sigma^2$. If the Data Units option is not specified, the shift is represented by $2*k/\Sigma$.

### ARL Graph

The ARL Graph shows the average run length for shifts ($\Delta$) between 0 and 3. This graph contains the same data points as the ARL Table to the left of the ARL Graph.
Additional Example of CUSUM Control Charts

- “Example of the Data Units Option”
- “Example of CUSUM Chart with Subgroups”

Example of the Data Units Option

This example uses the Data Units option and reproduces the analysis in “Example of CUSUM Control Chart” on page 133. You want to detect small shifts in the temperature of an engine. The data table contains temperature measurements from the engine thermostat.

2. Select Analyze > Quality and Process > CUSUM Control Chart.
3. Select Y and click Y.
4. Select the box next to Data Units.
5. Click OK.
6. In the Target box, type 100.
7. In the Sigma box, type 10.
   Note that the options below Head Start are H and K, instead of h and k. These parameters are now specified in units of the data column, rather than in standard deviation units.
8. Check the box next to Lower Side.

Figure 5.5 CUSUM Control Chart Report
Like in the example using sigma units, the vertical line on the CUSUM Chart indicates that a shift in the temperature measurements started around sample 26.

**Example of CUSUM Chart with Subgroups**

A machine fills 8-ounce cans of two-cycle engine oil additive. The filling process is believed to be in statistical control. The process is set so that the average weight of a filled can ($\mu_0$) is 8.10 ounces. Previous analysis shows that the standard deviation of fill weights ($\sigma_0$) is 0.05 ounces.

Subgroup samples of four cans are selected and weighed every hour for twelve hours. Each observation in the Oil1 Cusum.jmp data table contains one value of weight and its associated value of hour. The observations are sorted so that the values of hour are in increasing order. You want to be able to detect a $2\sigma$ shift in the process.

1. Select **Help > Sample Data Library** and open Quality Control/Oil1 Cusum.jmp.
2. Select **Analyze > Quality and Process > CUSUM Control Chart**.
3. Select **weight** and click **Y**.
4. Select **hour** and click **X**.
5. Click **OK**.
6. In the **Target** box, type 8.1.
   This is the target mean for the process.
7. In the **Sigma** box, type 0.05.
   This is the known standard deviation for the process.
8. In the **h** box, type 2.
   This defines the decision limits to be 2 standard deviations in each direction.
9. Select the box next to **Lower Side**.
The CUSUM Chart does not show any points outside of the upper or lower decision limits. There is no evidence that a shift in the process has occurred.

Note: Montgomery (2013) states that “only if there is some significant economy of scale or some other valid reason for taking samples of size greater than one should subgroups of size greater than one be used with the CUSUM.” The use of rational subgroups in the tabular CUSUM chart does not always improve the performance of the chart.

Statistical Details for the CUSUM Control Chart Platform

- “Statistical Details for CUSUM Control Chart Construction”
- “Statistical Details for Shift Detection”
- “Statistical Details for Average Run Length”

Statistical Details for CUSUM Control Chart Construction

This section defines the statistics that are used in the construction of the CUSUM Chart. Some of these statistics are also saved in the data table that is created by the Save Summaries command.
One-Sided Upper and Lower Cumulative Sums

The definitions of $C^+$ and $C^-$ depend on the setting of the Data Units option.

**Note:** In the Save Summaries data table, $C^+$ and $C^-$ are labeled Upper Cumulative Sum and Lower Cumulative Sum, respectively.

### Cumulative Sums in Standardized Units

If the Data Units option is not selected, $C^+$ and $C^-$ for each step are defined as follows:

\[
C_i^+ = \max\left(0, \frac{x_i - T}{\sigma} - k + C_{i-1}^+\right)
\]

\[
C_i^- = \min\left(0, \frac{x_i - T}{\sigma} + k + C_{i-1}^-\right)
\]

where:

- $x_i$ is the value of the response at the $i^{th}$ step
- $T$ is the target of the process
- $\sigma$ is the standard deviation of the process
- $k$ is the reference value, in units of standard deviations

If a value is specified for Head Start, that value is used as the initial $C^+$ value and the negative of that value is used as the initial $C^-$ value. Otherwise, the initial values of $C^+$ and $C^-$ are zero.

### Cumulative Sums in Data Units

If the Data Units option is selected, $C^+$ and $C^-$ for each step are defined as follows:

\[
C_i^+ = \max(0, (x_i - T) - K + C_{i-1}^+)
\]

\[
C_i^- = \min(0, (x_i - T) + K + C_{i-1}^-)
\]

where:

- $x_i$ is the value of the response at the $i^{th}$ step
- $T$ is the target of the process
- $\sigma$ is the standard deviation of the process
- $K$ is the reference value, in units of the data

If a value is specified for Head Start, that value is used as the initial $C^+$ value and the negative of that value is used as the initial $C^-$ value. Otherwise, the initial values of $C^+$ and $C^-$ are zero.
Counters for Positive and Negative Runs

$N^+$ at each step is the number of steps since the most recent zero value for $C^+$. $N^-$ at each step is the number of steps since the most recent zero value for $C^-$.  

**Note:** In the Save Summaries data table, $N^+$ and $N^-$ are labeled Positive Runs and Negative Runs, respectively.

Statistical Details for Shift Detection

A positive shift occurs when the value of $C^+$ exceeds the upper limit on the chart. The start of the shift is defined as the first point after the most recent zero value for $C^+$.  

A negative shift occurs when the value of $C^-$ exceeds the lower limit on the chart. The start of the shift is defined as the first point after the most recent zero value for $C^-$.  

Statistical Details for Average Run Length

The one-sided average run length (ARL) values are calculated using the integral equation method (with 24 Gaussian points) described by Goel and Wu (1971). If the Head Start value is greater than 0, the values are calculated according to the method in Appendix A.1 of Lucas and Crosier (1982).

Note that the two-sided ARL values are related to the positive and negative one-sided ARL values by the following equation:

$$\frac{1}{\text{ARL}} = \frac{1}{\text{Positive ARL}} + \frac{1}{\text{Negative ARL}}$$

Lucas and Crosier (1982) describe the properties of a Head Start value for CUSUM charts in which the initial CUSUM $S_0$ is set to a nonzero value. This is sometimes referred to as a fast initial response (FIR) feature. Average run length calculations given by them show that the FIR feature has little effect when the process is in control and that it leads to a faster response to an initial out-of-control condition than a standard CUSUM chart.
V-Mask CUSUM Control Charts

Use a V-Mask to Detect Small Shifts in the Process Mean

CUSUM charts show cumulative sums of subgroup or individual measurements from a target value. CUSUM charts can help you decide whether a process is in a state of statistical control by detecting small, sustained shifts in the process mean. In comparison, Shewhart charts can detect sudden and large changes in measurement, such as a two or three sigma shift, but they are less effective at spotting smaller changes, such as a one sigma shift.

Figure 6.1  Example of a V-Mask CUSUM Chart
## Contents

Overview of V-Mask CUSUM Control Charts .......................................................... 147
Example of a V-Mask CUSUM Chart ................................................................. 147
Launch the V-Mask CUSUM Control Chart Platform ........................................ 149
The V-Mask CUSUM Control Chart ....................................................................... 151
  Interpret a Two-Sided V-Mask CUSUM Chart ................................................ 152
  Interpret a One-Sided CUSUM Chart ............................................................... 153
V-Mask CUSUM Control Chart Platform Options ............................................... 154
Example of a One-Sided CUSUM Chart ............................................................... 155
Statistical Details for V-Mask CUSUM Control Charts ...................................... 156
  One-Sided CUSUM Charts .............................................................................. 157
  Two-Sided CUSUM Charts ............................................................................. 158
Overview of V-Mask CUSUM Control Charts

V-Mask Cumulative Sum (CUSUM) control charts show cumulative sums of subgroup or individual measurements from a target value. CUSUM charts can help you decide whether a process is in a state of statistical control by detecting small, sustained shifts in the process mean. In comparison, Shewhart charts can detect sudden and large changes in measurement, such as a two or three sigma shift, but they are less effective at spotting smaller changes, such as a one sigma shift.

Another form of a cumulative sum control chart is the tabular CUSUM chart. To create a tabular CUSUM chart, see “CUSUM Control Charts” chapter on page 131. The tabular CUSUM chart is recommended over the V-mask chart for a variety of reasons, including the following:

- The V-mask must be moved with each observation, not simply placed on the last observation.
- The cumulative sums in the V-mask procedure can end up a long way from the center of the graph, even for an on-target process.

Caution: Montgomery (2013) strongly “advises against using the V-mask procedure.”

Example of a V-Mask CUSUM Chart

A machine fills 8-ounce cans of two-cycle engine oil additive. The filling process is believed to be in statistical control. The process is set so that the average weight of a filled can ($\mu_0$) is 8.10 ounces. Previous analysis shows that the standard deviation of fill weights ($\sigma_0$) is 0.05 ounces.

Subgroup samples of four cans are selected and weighed every hour for twelve hours. Each observation in the Oil1 Cusum.jmp data table contains one value of weight and its associated value of hour. The observations are sorted so that the values of hour are in increasing order.

1. Select Help > Sample Data Library and open Quality Control/Oil1 Cusum.jmp.
2. Select Analyze > Quality And Process > Control Chart > CUSUM.
4. Select hour and click Sample Label.
5. Select the Two Sided check box if it is not already checked.
6. In the Parameters area, click the H button and type 2.
7. Click Specify Stats.
8. Type 8.1 next to Target.
8.1 is the average weight in ounces of a filled can. This is the target mean.

9. Type 1 next to **Delta**.

   1 is the absolute value of the smallest shift to be detected as a multiple of the process standard deviation or of the standard error.

10. Type 0.05 next to **Sigma**.

    0.05 is the known standard deviation of fill weights ($\sigma$) in ounces.

**Figure 6.2** Completed Launch Window

11. Click OK.
You can interpret the chart by comparing the points with the V-mask. The right edge of the V-mask is centered at the most recent point (the 12th hour). Because none of the points cross the arms of the V-mask, there is no evidence that a shift in the process has occurred. See “Interpret a Two-Sided V-Mask CUSUM Chart” on page 152.

Launch the V-Mask CUSUM Control Chart Platform

Launch the V-Mask CUSUM Control Chart platform by selecting Analyze > Quality And Process > Control Chart > CUSUM.

**Process**  Identifies the variables that you want to chart.
Note: The rows of the data table must be sorted in the order in which you want them to appear in the control chart. Even if there is a Sample Label variable specified, you still must sort the data accordingly.

Sample Label Specify a variable whose values label the horizontal axis and can also identify unequal subgroup sizes. If no sample label variable is specified, the samples are identified by their subgroup sample number. See “Sample Label” on page 97 in the “Shewhart Control Charts” chapter.

By Identifies a column that creates a report consisting of separate analyses for each level of the variable.

Two Sided Requests a two-sided CUSUM chart when selected. If it is not selected, a one-sided chart is used and no V-mask appears. If an H value is specified, a decision interval is displayed.

Data Units Specifies that the cumulative sums be computed without standardizing the subgroup means or individual values. The vertical axis of the CUSUM chart is then scaled in the same units as the data.

Note: Data Units requires that the subgroup sample size be designated as constant.

K Sigma Specifies control limits in terms of a multiple of the sample standard error. Enter the K Sigma value in the box that appears below H. Control limits are specified at k sample standard errors above and below the expected value, which appears as the shift.

H H is the vertical distance \( h \) between the origin for the V-mask and the upper or lower arm of the V-mask for a two-sided chart (for an illustration, see Figure 6.6). For a one-sided chart, H is the decision interval. Choose H as a multiple of the standard error.

K Specifies reference value k, where k is greater than zero.

Sample Grouped by Sample Label Indicates the column that identifies each sample. See “Sample Label” on page 97 in the “Shewhart Control Charts” chapter.

Sample Size Constant Indicates that the sample subgroups are the same size. See “Sample Label” on page 97 in the “Shewhart Control Charts” chapter.

Specify Stats Enter the following process variable specifications in the Known Statistics for CUSUM Chart area:

- **Target** is the target mean (goal) for the process or population. The target mean must be scaled in the same units as the data.

- **Delta** specifies the absolute value of the smallest shift to be detected as a multiple of the process standard deviation or of the standard error. This depends on whether the shift
is viewed as a shift in the population mean or as a shift in the sampling distribution of the subgroup mean, respectively. Delta is an alternative to the Shift option (described next). The relationship between Shift and Delta can be computed as follows:

\[ \delta = \frac{\Delta}{(\sigma/(\sqrt{n}))} \]

where \( \delta \) represents Delta, \( \Delta \) represents the shift, \( \sigma \) represents the process standard deviation, and \( n \) is the (common) subgroup sample size.

- **Shift** is the minimum value that you want to detect on either side of the target mean. You enter the shift value in the same units as the data, and you interpret it as a shift in the mean of the sampling distribution of the subgroup mean. You can choose either Shift or Delta.

- **Sigma** specifies a known standard deviation, \( \sigma_0 \), for the process standard deviation, \( \sigma \). By default, the Control Chart platform estimates sigma from the data.

- **Head Start** specifies an initial value for the cumulative sum, \( S_0 \), for a one-sided CUSUM chart (\( S_0 \) is usually zero). Enter the **Head Start** value as a multiple of standard error.

**Delete Stats** Deletes all statistics in the Known Statistics for CUSUM Chart area.

**Get Limits** Uses previously established limits that exist in a JMP data table. See “Saving and Retrieving Limits” on page 109 in the “Shewhart Control Charts” chapter.

**Capability** Measures the conformance of a process to given specification limits. Once you click **OK** in the launch window, if you have not already defined these as a column property, you are prompted to enter specification limits and a target. See the Distributions chapter in the *Basic Analysis* book.

For more information about the launch window, see the Get Started chapter in the *Using JMP* book.

---

**The V-Mask CUSUM Control Chart**

CUSUM charts can be one-sided or two-sided. One-sided charts detect a shift in one direction from a specified target mean. Two-sided charts detect a shift in either direction.

Follow the instructions in “Example of a V-Mask CUSUM Chart” on page 147 to produce the results shown in Figure 6.5.
Note the following:

- If you use the grabber tool and click on a point, the shift and V-mask adjust to reflect the process condition at that point.
- If you add new data to the data table for an existing CUSUM chart, the corresponding chart updates automatically.

For information about additional options, see “V-Mask CUSUM Control Chart Platform Options” on page 154.

Interpret a Two-Sided V-Mask CUSUM Chart

Note: See also “Example of a V-Mask CUSUM Chart” on page 147.

To interpret a two-sided CUSUM chart, compare the points with limits that compose a V-mask. A V-mask is a shape in the form of a V on its side that is superimposed on the graph of the cumulative sums. The V-mask is formed by plotting V-shaped limits. The origin of a V-mask is the most recently plotted point, and the arms extended backward on the x-axis, as in Figure 6.6. As data are collected, the cumulative sum sequence is updated and the origin is relocated at the newest point.
Shifts in the process mean are visually easy to detect on a CUSUM chart because they produce a change in the slope of the plotted points. The point where the slope changes is the point where the shift occurs. A condition is out-of-control if one or more of the points previously plotted crosses the upper or lower arm of the V-mask. Points crossing the lower arm signal an increasing process mean, and points crossing the upper arm signal a downward shift.

There are important differences between CUSUM charts and Shewhart charts:

- A Shewhart control chart plots points based on information from a single subgroup sample. In CUSUM charts, each point is based on information from all samples taken up to and including the current subgroup.
- On a Shewhart control chart, horizontal control limits define whether a point signals an out-of-control condition. On a CUSUM chart, the limits can be either in the form of a V-mask or a horizontal decision interval.
- The control limits on a Shewhart control chart are commonly specified as 3σ limits. On a CUSUM chart, the limits are determined from average run length.

A CUSUM chart is more efficient for detecting small shifts in the process mean. Lucas (1976) states that a V-mask detects a 1σ shift about four times as fast as a Shewhart control chart.

**Interpret a One-Sided CUSUM Chart**

Use a one-sided CUSUM chart to identify data approaching or exceeding the side of interest.
The decision interval or horizontal line is set at the H value that you entered in the launch window. In this example, it is 0.25. Any values exceeding the decision interval of 0.25 indicate a shift or out-of-control condition. In this example, observation 4 appears to be where a shift occurred. Also note that no V-mask appears for one-sided CUSUM charts.

V-Mask CUSUM Control Chart Platform Options

For a description of the options in the red triangle menu next to Control Chart, see “Control Chart Window Options” on page 103 in the “Shewhart Control Charts” chapter. The red triangle menu next to CUSUM contains the following options:

**Show Points**  Shows or hides the sample data points.

**Connect Points**  Connects the sample points with a line.

**Mask Color**  (Applicable only when Show V Mask is selected) Select a line color for the V-mask.

**Connect Color**  (Applicable only when Connect Points is selected) Select a color for the connect line.

**Center Line Color**  (Applicable only when Show Shift is selected) Select a color for the center line, or shift.

**Show Shift**  Shows or hides the shift that you entered in the launch window.

**Show V Mask**  Shows or hides the V-mask based on the statistics that you specified in the CUSUM Control Charts launch window.
Show Parameters  Shows or hides a report that summarizes the CUSUM charting parameters.

Show ARL  Shows or hides the average run length (ARL) information. The average run length is the expected number of samples taken before an out-of-control condition is signaled, as follows:

- ARL (Delta), sometimes denoted ARL1, is the average run length for detecting a shift in the size of the specified Delta.
- ARL(0), sometimes denoted ARL0, is the in-control average run length for the specified parameters (Montgomery 2013).

Example of a One-Sided CUSUM Chart

Consider the data used in “Example of a V-Mask CUSUM Chart” on page 147, where the machine fills 8-ounce cans of engine oil. In order to cut costs, the manufacturer is now concerned about significant over-filling (and not so concerned about under-filling). Use a one-sided CUSUM chart to identify any instances of over-filling. Anything that is 0.25 ounces beyond the mean of 8.1 is considered a problem.

1. Select Help > Sample Data Library and open Quality Control/Oil1 Cusum.jmp.
2. Select Analyze > Quality And Process > Control Chart > CUSUM.
3. Deselect Two Sided.
4. Select weight and click Process.
5. Select hour and click Sample Label.
6. Click H and type 0.25.
7. Click Specify Stats.
8. Type 8.1 next to Target.
   8.1 is the average weight in ounces of a filled can. This is the target mean.
9. Type 1 next to Delta.
   1 is the absolute value of the smallest shift to be detected as a multiple of the process standard deviation or of the standard error.
10. Type 0.05 next to Sigma.
    0.05 is the known standard deviation of fill weights (σ₀) in ounces.
11. Click OK.
The decision interval is set at the H value that you entered (0.25). You can see that at the fourth hour, some significant over-filling occurred.

Statistical Details for V-Mask CUSUM Control Charts

The following notation is used in these formulas:

- \( \mu \) denotes the mean of the population, also referred to as the process mean or the process level.
- \( \mu_0 \) denotes the target mean (or goal) for the population. Sometimes, the symbol \( \bar{X}_0 \) is used for \( \mu_0 \). See the American Society for Quality Statistics Division (2004). You can provide \( \mu_0 \) as the Target in the Known Statistics for CUSUM Chart area on the launch window.
- \( \sigma \) denotes the population standard deviation. \( \hat{\sigma} \) denotes an estimate of \( \sigma \).
- \( \sigma_0 \) denotes a known standard deviation. You can provide \( \sigma_0 \) as the Sigma in the Known Statistics for CUSUM Chart area on the launch window.
- \( n \) denotes the nominal sample size for the CUSUM chart.
- \( \delta \) denotes the shift in \( \mu \) to be detected, expressed as a multiple of the standard deviation. You can provide \( \delta \) as the Delta in the Known Statistics for CUSUM Chart area on the launch window.
- \( \Delta \) denotes the shift in \( \mu \) to be detected, expressed in data units. If the sample size \( n \) is constant across subgroups, then the following computation applies:

\[
\Delta = \delta \sigma \bar{X} = (\delta \sigma) / \sqrt{n}
\]
You can provide $\Delta$ as the Shift in the Known Statistics for CUSUM Chart area on the launch window.

**Note:** Some authors use the symbol $D$ instead of $\Delta$.

### One-Sided CUSUM Charts

#### Positive Shifts

If the shift $\delta$ to be detected is positive, the CUSUM for the $t^{th}$ subgroup is computed as follows:

$$S_t = \max(0, S_{t-1} + (z_t - k))$$

$t = 1, 2, ..., n$, where $S_0 = 0$, $z_t$ is defined as for two-sided charts, and the parameter $k$, termed the reference value, is positive. If the parameter $k$ is not specified in the launch window, $k$ is set to $\delta/2$. The CUSUM $S_t$ is referred to as an upper cumulative sum. $S_t$ can be computed as follows:

$$\max\left(0, S_{t-1} + \frac{\bar{X}_t - (\mu_0 + k\sigma_{\bar{X}_t})}{\sigma_{\bar{X}_t}}\right)$$

The sequence $S_t$ cumulates deviations in the subgroup means greater than $k$ standard errors from $\mu_0$. If $S_t$ exceeds a positive value $h$ (referred to as the decision interval), a shift or out-of-control condition is signaled.

#### Negative Shifts

If the shift to be detected is negative, the CUSUM for the $t^{th}$ subgroup is computed as follows:

$$S_t = \max(0, S_{t-1} - (z_t + k))$$

$t = 1, 2, ..., n$, where $S_0 = 0$, $z_t$ is defined as for two-sided charts, and the parameter $k$, termed the reference value, is positive. If the parameter $k$ is not specified in the launch window, $k$ is set to $\delta/2$. The CUSUM $S_t$ is referred to as a lower cumulative sum. $S_t$ can be computed as follows:

$$\max\left(0, S_{t-1} - \frac{\bar{X}_t - (\mu_0 - k\sigma_{\bar{X}_t})}{\sigma_{\bar{X}_t}}\right)$$

The sequence $S_t$ cumulates the absolute value of deviations in the subgroup means less than $k$ standard errors from $\mu_0$. If $S_t$ exceeds a positive value $h$ (referred to as the decision interval), a shift or out-of-control condition is signaled.
Note that $S_t$ is always positive and $h$ is always positive, regardless of whether $\delta$ is positive or negative. For charts designed to detect a negative shift, some authors define a reflected version of $S_t$ for which a shift is signaled when $S_t$ is less than a negative limit.

Lucas and Crosier (1982) describe the properties of a fast initial response (FIR) feature for CUSUM charts in which the initial CUSUM $S_0$ is set to a “head start” value. Average run length calculations given by them show that the FIR feature has little effect when the process is in control and that it leads to a faster response to an initial out-of-control condition than a standard CUSUM chart. You can provide a Head Start value in the Known Statistics for CUSUM Chart area on the launch window.

**Constant Sample Sizes**

When the subgroup sample sizes are constant (= $n$), it might be preferable to compute CUSUMs that are scaled in the same units as the data. CUSUMs are then computed as follows:

$$ S_t = \max(0, S_{t-1} + (\bar{X}_t - (\mu_0 + k \sigma / \sqrt{n}))) $$

where $\delta > 0$

$$ S_t = \max(0, S_{t-1} - (\bar{X}_t - (\mu_0 - k \sigma / \sqrt{n}))) $$

where $\delta < 0$. In either case, the parameter $k$ is rescaled to $k' = k \sigma / \sqrt{n}$. If the parameter $k$ is not specified in the launch window, $k'$ is set to $\delta/2$. A shift is signaled if $S_t$ exceeds $h' = h \sigma / \sqrt{n}$. Some authors use the symbol $H$ for $h'$.

**Two-Sided CUSUM Charts**

If the CUSUM chart is two-sided, the cumulative sum $S_t$ plotted for the $t$th subgroup is as follows:

$$ S_t = S_{t-1} + z_t $$

$t = 1, 2, ..., n$. Here $S_0=0$, and the term $z_t$ is calculated as follows:

$$ z_t = (\bar{X}_t - \mu_0) / (\sigma / \sqrt{n_t}) $$

where $\bar{X}_t$ is the $t$th subgroup average, and $n_t$ is the $t$th subgroup sample size. If the subgroup samples consist of individual measurements $x_t$, the term $z_t$ simplifies to the following computation:

$$ z_t = (x_t - \mu_0) / \sigma $$
The first equation can be rewritten as follows:

\[ S_t = \frac{1}{\sigma \bar{X}} \sum_{i=1}^{t} (\bar{X}_i - \mu_0) = \frac{1}{\sqrt{n} \sigma} \sum_{i=1}^{t} (\bar{X}_i - \mu_0) \]

where the sequence \( S_t \) cumulates standardized deviations of the subgroup averages from the target mean \( \mu_0 \).

In many applications, the subgroup sample sizes \( n_i \) are constant \((n_i = n)\), and the equation for \( S_t \) can be simplified, as follows:

\[ S_t = \frac{1}{\sigma \bar{X}} \sum_{i=1}^{t} (\bar{X}_i - \mu_0) = \frac{1}{\sqrt{n} \sigma} \sum_{i=1}^{t} (\bar{X}_i - \mu_0) \]

In some applications, it might be preferable to compute \( S_t \) as follows:

\[ S_t = \sum_{i=1}^{t} (\bar{X}_i - \mu_0) \]

which is scaled in the same units as the data. In this case, the procedure rescales the V-mask parameters \( h \) and \( k \) to \( h' = h\sigma/\sqrt{n} \) and \( k' = k\sigma/\sqrt{n} \), respectively. Some authors use the symbols \( F \) for \( k' \) and \( H \) for \( h' \).

If the process is in control and the mean \( \mu \) is at or near the target \( \mu_0 \), the random walk model applies. Therefore, the points might wander away from zero, but they will not exhibit a large trend since positive and negative displacements from \( \mu_0 \) tend to cancel each other. If \( \mu \) shifts in the positive direction, the points exhibit an upward trend, and if \( \mu \) shifts in the negative direction, the points exhibit a downward trend.
Multivariate control charts are used to monitor two or more interrelated process variables. Where univariate control charts are used to monitor a single independent process characteristic, multivariate control charts are necessary when process variables are correlated. The Multivariate Control Chart platform enables you to build Hotelling $T^2$ charts. You can use the platform to determine whether a process is stable as well as to monitor a process as new data are collected.

**Figure 7.1** Example of a Multivariate Control Chart
Contents

Overview of Multivariate Control Charts .......................................................... 163
Example of a Multivariate Control Chart ........................................................... 163
  Step 1: Determine Whether the Process Is Stable .......................................... 163
  Step 2: Save Target Statistics ........................................................................ 164
  Step 3: Monitor the Process ........................................................................... 164
Launch the Multivariate Control Chart Platform .............................................. 165
The Multivariate Control Chart ....................................................................... 166
Multivariate Control Chart Platform Options .................................................. 168
  T Square Partitioned ...................................................................................... 169
  Change Point Detection .................................................................................. 169
  Principal Components .................................................................................... 170
Additional Examples of Multivariate Control Charts ........................................ 171
  Example of Monitoring a Process Using Sub-Grouped Data ....................... 171
  Example of T Square Partitioned ................................................................. 174
  Example of Change Point Detection ............................................................. 176
Statistical Details for Multivariate Control Charts .......................................... 177
  Statistical Details for Individual Observations ............................................. 178
  Statistical Details for Observations in Rational Subgroups ....................... 179
  Statistical Details for Change Point Detection ............................................. 182
Overview of Multivariate Control Charts

Multivariate control charts are used to monitor two or more interrelated process variables. Where univariate control charts are used to monitor a single independent process characteristic, multivariate control charts are necessary when process variables are correlated. A Hotelling $T^2$ chart, or just $T^2$ chart for short, is one type of multivariate control chart. A $T^2$ chart can detect shifts in the mean or the relationship between several interrelated variables. The observations can either be individual observations of the process variables or they can be grouped into rational subgroups.

You can construct a multivariate control chart using current or historical data. The control chart is said to be a Phase I chart if it is constructed using current data; the control chart is said to be a Phase II chart if it is constructed using target statistics from a historical data set. In Phase I, you check that the process is stable and establish a historical data set from which to calculate target statistics for the process. In Phase II, the multivariate control chart uses the target statistics from Phase I in order to monitor new process observations.

To construct a Phase II multivariate control chart, first identify a period of time during which the process is stable and capable.

1. Develop a Phase I control chart to verify that the process is stable over this period.
   The data used in Phase I provides a historical data set
2. Save the target statistics for this historical data set.
3. Monitor the on-going process using a Phase II control chart based on the target statistics that were saved in step 2.

Example of a Multivariate Control Chart

The following example illustrates constructing a control chart for data that are not sub-grouped. The data are measurements on a steam turbine engine. For an example that uses sub-grouped data, “Example of Monitoring a Process Using Sub-Grouped Data” on page 171.

Step 1: Determine Whether the Process Is Stable

1. Select Help > Sample Data Library and open Quality Control/Steam Turbine Historical.jmp.
2. Select Analyze > Quality and Process > Control Chart > Multivariate Control Chart.
3. Select all of the columns and click Y, Columns.
4. Click OK.
The process seems to be in reasonable statistical control, because there is only one out-of-control point. Therefore, it is appropriate to create targets based on this data.

**Step 2: Save Target Statistics**

1. From the red triangle menu, select **Save Target Statistics**.
   
   This creates a new data table containing target statistics for the process.

   **Figure 7.3** Target Statistics for Steam Turbine Data

<table>
<thead>
<tr>
<th>Ref_Stats</th>
<th>Fuel</th>
<th>Steam Flow</th>
<th>Steam Temp</th>
<th>MW</th>
<th>Cool Temp</th>
<th>Pressure</th>
</tr>
</thead>
<tbody>
<tr>
<td>SampleSize</td>
<td>28</td>
<td>28</td>
<td>28</td>
<td>28</td>
<td>28</td>
<td>28</td>
</tr>
<tr>
<td>NumSample</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Mean</td>
<td>237595.7857</td>
<td>178015.7857</td>
<td>8493928574</td>
<td>53.264714286</td>
<td>29.13928574</td>
<td></td>
</tr>
<tr>
<td>Std</td>
<td>7247.6859825</td>
<td>4374.3036819</td>
<td>2.946185703</td>
<td>0.5134955026</td>
<td>0.049734761</td>
<td></td>
</tr>
<tr>
<td>Corr_Fuel</td>
<td>1</td>
<td>0.08714382899</td>
<td>-0.549875041</td>
<td>0.8558570808</td>
<td>-0.270039819</td>
<td>-0.46928962</td>
</tr>
<tr>
<td>Corr_Steam_Flow</td>
<td>0.6714368299</td>
<td>1</td>
<td>-0.6290239279</td>
<td>0.9852529223</td>
<td>-0.2230127002</td>
<td>-0.533056185</td>
</tr>
<tr>
<td>Corr_Steam_Temp</td>
<td>-0.549875041</td>
<td>1</td>
<td>0.695214609</td>
<td>0.2475387217</td>
<td>0.2192147319</td>
<td></td>
</tr>
<tr>
<td>Corr_MW</td>
<td>0.8558570808</td>
<td>0.6852529223</td>
<td>-0.595214609</td>
<td>1</td>
<td>-0.207305813</td>
<td>-0.50447312</td>
</tr>
<tr>
<td>Corr_Cool_Temp</td>
<td>-0.270049819</td>
<td>-0.223127002</td>
<td>0.2475387217</td>
<td>1</td>
<td>0.3617461646</td>
<td></td>
</tr>
</tbody>
</table>

2. Save the new data table as **Steam Turbine Targets.jmp**.

Now that target statistics have been established, create the multivariate control chart that monitors the process.

**Step 3: Monitor the Process**

1. Select **Help > Sample Data Library** and open **Quality Control/Steam Turbine Current.jmp**.
This sample data table contains recent observations from the process.

2. Select Analyze > Quality and Process > Control Chart > Multivariate Control Chart.
3. Select all of the columns and click Y, Columns.
4. Click Get Targets.
5. Open the Steam Turbine Targets.jmp table that you saved.
6. Click OK.

The default alpha level is set to 0.05. Change it to 0.001.

7. From the red triangle menu, select Set Alpha Level > Other.
8. Type 0.001 and click OK.

**Figure 7.4** Steam Turbine Control Chart

Figure 7.4 shows out-of-control conditions occurring at observations 2, 3, 4, 5, and 8. This result implies that these observations do not conform to the historical data from Steam Turbine Historical.jmp, and that the process should be further investigated. To find an assignable cause, you might want to examine individual univariate control charts or perform another univariate procedure.

**Launch the Multivariate Control Chart Platform**

Launch the Multivariate Control Chart platform by selecting Analyze > Quality And Process > Control Chart > Multivariate Control Chart.
Figure 7.5 The Multivariate Control Chart Launch Window

Y, Columns Specify the columns to be analyzed.

Subgroup Enter a column with sub-grouped data. Hierarchically, this group is nested within Group.

Group Enter a column that specifies group membership at the highest hierarchical level.

Weight Identifies the data table column whose variables assign weight (such as importance or influence) to the data.

Freq Identifies the data table column whose values assign a frequency to each row. Can be useful when your data table contains summarized data.

By Identifies a column that creates a report consisting of separate analyses for each level of the variable.

Get Targets Click to select a JMP table that contains historical targets for the process.

The Multivariate Control Chart

Use the multivariate control chart to quickly identify shifts in your process and to monitor your process for special cause indications.

Follow the instructions in “Example of a Multivariate Control Chart” on page 163 to produce the results shown in Figure 7.6.
The multivariate control chart plots Hotelling’s $T^2$ statistic. The calculation for the control limit differs based on whether targets have been specified. To understand how the $T^2$ statistic and the UCL (Upper Control Limit) are calculated, see “Statistical Details for Multivariate Control Charts” on page 177. For more details about control limits, see Tracy et al. (1992).

In this example, the Principal Components reports for both data sets indicate that the first eigenvalue, corresponding to the first principal component, explains about 95% of the total variation in the variables. The values in both Eigenvectors tables indicate that the first principal component is driven primarily by the variables Fuel and Steam Flow. You can use this information to construct a potentially more sensitive control chart based only on this first
component. For more details about the Principal Components reports, see “Principal Components” on page 170.

**Multivariate Control Chart Platform Options**

The following options are available from the platform red triangle menu:

**T Square Chart**  Shows the $T^2$ chart. Hotelling’s $T^2$ chart is a multivariate extension of the X-bar chart that takes correlation into account.

**T Square Partitioned**  Constructs multivariate control charts based on the principal components of Y. Specify the number of major principal components for $T^2$. See “T Square Partitioned” on page 169.

**Set Alpha Level**  Set the $\alpha$ level used to calculate the control limit. The default is $\alpha=0.05$.

**Show Covariance**  Shows the covariance. Covariance is a measure of the linear relationship between two variables.

**Show Correlation**  Shows the correlation report.

**Show Inverse Covariance**  Shows the inverse, or if it is singular, a generalized inverse of the covariance matrix.

**Show Inverse Correlation**  Shows the inverse, or if it is singular, a generalized inverse of the correlation matrix.

**Show Means**  Shows the means for each group.

**Save T Square**  Creates a new column in the data table containing $T^2$ values.

**Save T Square Formula**  Creates a new column in the data table. Stores a formula in the column that calculates the $T^2$ values.

**Save Target Statistics**  Creates a new data table containing target statistics for the process. Target statistics include: sample size, the number of samples, mean, standard deviation, and any correlations.

**Change Point Detection**  (Not available for sub-grouped data) Shows a Change Point Detection plot of test statistics by row number and indicates the row number where the change point appears. See “Change Point Detection” on page 169.

**Principal Components**  Shows reports showing eigenvalues and their corresponding eigenvectors. Principal components help you understand which of the many variables you
might be monitoring are primarily responsible for the variation in your process. See “Principal Components” on page 170.

Save Principal Components Creates new columns in the data table that contain the scaled principal components.

T Square Partitioned

If you are monitoring a large number of correlated process characteristics, you can use the T Square Partitioned option to construct a control chart based on principal components. If a small number of principal components explains a large portion of the variation in your measurements, then a multivariate control chart based on these big components might be more sensitive than a chart based on your original, higher-dimensional data.

The T Square Partitioned option is also useful when your covariance matrix is ill-conditioned. When this is the case, components with small eigenvalues, explaining very little variation, can have a large, and misleading, impact on $T^2$. It is useful to separate out these less important components when studying process behavior.

Once you select the T Square Partitioned option, you need to decide how many major principal components to use.

The option creates two multivariate control charts: T Square with Big Principal Components and T Square with Small Principal Components. Suppose that you enter $r$ as the number of major components when you first select the option. The chart with Big Principal Components is based on the $r$ principal components corresponding to the $r$ largest eigenvalues. These are the $r$ components that explain the largest amount of variation, as shown in the Percent and Cum Percent columns in the Principal Components: on Covariances reports. The chart with Small Principal Components is based on the remaining principal components.

For a given subgroup, its $T^2$ value in the Big Principal Components chart and its $T^2$ value in the Small Principal Components chart sum to its overall $T^2$ statistic presented in the $T^2$ with All Principal Components report. For more information about how the partitioned $T^2$ values are calculated, see Kourti and MacGregor (1996).

Change Point Detection

When the data set consists of multivariate individual observations, a control chart can be developed to detect a shift in the mean vector, the covariance matrix, or both. This method partitions the data and calculates likelihood ratio test statistics for a shift. The statistic that is plotted on the control chart is an observation’s likelihood ratio test statistic divided by the product of the following:

- Its approximate expected value assuming no shift.
• An approximate value for an upper control limit.

Division by the approximate upper control limit allows the points to be plotted against an effective upper control limit of 1. A Change Point Detection plot readily shows the change point for a shift occurring at the maximized value of the control chart statistic. The Change Point Detection implementation in JMP is based on Sullivan and Woodall (2000) and is described in “Statistical Details for Change Point Detection” on page 182.

Note: The Change Point Detection method is designed to show a single shift in the data. Detect multiple shifts by recursive application of this method.

Note the following about the Change Point Detection plot:
• Values above 1.0 indicate a possible shift in the data.
• Control chart statistics for the Change Point Detection plot are obtained by dividing the likelihood ratio statistic of interest (either a mean vector or a covariance matrix) by a normalizing factor.
• The change point of the data occurs for the observation having the maximum test statistic value for the Change Point Detection plot.

Note the following about the scatterplot matrix:
• This plot shows the shift in the sample mean vector.
• In the “Example of Change Point Detection” on page 176, data are divided into two groups. The first 24 observations are classified as the first group. The remaining observations are classified as the second group.

**Principal Components**

The Principal Components report contain the following information:

**Eigenvalue**  Eigenvalues for the covariance matrix.

**Percent**  Percent variation explained by the corresponding eigenvector. Also shows an accompanying bar chart.

**Cum Percent**  Cumulative percent variation explained by eigenvectors corresponding to the eigenvalues.

**ChiSquare**  Provides a test of whether the correlation remaining in the data is of a random nature. This is a Bartlett test of sphericity. When this test rejects the null hypothesis, this implies that there is structure remaining in the data that is associated with this eigenvalue.

**DF**  Degrees of freedom associated with the Chi-square test.
Additional Examples of Multivariate Control Charts

- “Example of Monitoring a Process Using Sub-Grouped Data”
- “Example of T Square Partitioned”
- “Example of Change Point Detection”

Example of Monitoring a Process Using Sub-Grouped Data

The workflow for monitoring a multivariate process with sub-grouped data is similar to the one for individual data. See “Example of a Multivariate Control Chart” on page 163. You create an initial control chart to save target statistics and then use these targets to monitor the process.

Step 1: Determine Whether the Process Is Stable

1. Select Help > Sample Data Library and open Quality Control/Aluminum Pins Historical.jmp.
2. Select Analyze > Quality and Process > Control Chart > Multivariate Control Chart.
4. Select subgroup and click Subgroup.
5. Click OK.
The process appears to be in statistical control, making it appropriate to create targets using this data.

**Step 2: Save Target Statistics**

1. From the red triangle menu, select **Save Target Statistics**.
   This creates a new data table containing target statistics for the process.
2. Save the new data table as Aluminum Pins Targets.jmp.
   Now that target statistics have been established, create the multivariate control chart for process monitoring.

**Step 3: Monitor the Process**

1. Select **Help > Sample Data Library** and open Quality Control/Aluminum Pins Current.jmp.
   This sample data table contains recent observations from the process.
2. Select **Analyze > Quality and Process > Control Chart > Multivariate Control Chart**.
3. Select all of the Diameter and Length columns and click **Y, Columns**.
4. Select subgroup and click **Subgroup**.
5. Click **Get Targets**.
6. Open the Aluminum Pins Targets.jmp table that you saved.
7. Click **OK**.
8. From the red triangle menu, select **Show Means**.
   The Show Means option gives the means for each subgroup. You can then observe which groups are most dissimilar from each other.
Figure 7.8 Multivariate Control Chart for Sub-Grouped Data, Step 3

Figure 7.8 shows indications of instability at subgroups 4-7, 9-11, 18, and 20. This result implies that these observations do not conform to the historical data from Aluminum Pins Historical.jmp, and that the process should be further investigated. To determine why the process was out of control at these points, you might want to examine individual univariate control charts or perform another univariate procedure.
An alternative method to monitoring this process is based on the big principal components. In this example, for the historical data, the first three principal components account for about 98% of the variation. Based on this, you might construct a chart for the first three principal components. Then you would monitor current data using those three components. The control limits for the chart used in monitoring the process should be based on the corresponding chart for the historical data.

**Example of T Square Partitioned**

Use T Square Partitioned to separate out the more important components from the less important components when studying process behavior. In this example, the coating on each of 50 bars was measured at 12 uniformly spaced locations across the bar. You want to examine the variation in the measurements and determine whether the causes of variation need to be investigated further.

1. Select Help > Sample Data Library and open Quality Control/Thickness.jmp.
2. Select Analyze > Quality and Process > Control Chart > Multivariate Control Chart.
3. Select all of the Thickness columns and click Y, Columns.
4. Click OK.
   
   The current alpha level is set to 0.05, which corresponds to a 5% false alarm rate. You want to set the false alarm rate to 1%.
5. Change the alpha level by selecting Set Alpha Level and choosing 0.01 from the red triangle menu.
Figure 7.9 Initial Multivariate Control Chart for Thickness.jmp

The overall control chart in Figure 7.9 suggests that special causes affected bars 1, 2, 4, 5, and 22. Looking at the Principal Components report, you can see that almost 95% of the variation in the 12 thickness measurements is explained by the first principal component. You want to study the variation associated with this principal component further.

6. From the red triangle menu, select **T Square Partitioned**.

7. Accept the default value of 1 principal component by clicking **OK**.
In contrast to the Principal Components report, the T Square with Big Principal Components chart, which reflects variation for only the first component, shows no evidence of special causes. The T Square with Small Principal Components chart shows that the special cause indications reside in the remaining smaller components. These smaller components do not explain much variation, and likely represent random noise. Therefore, you might conclude that the variation in the thickness measurements is not a major cause for concern.

**Example of Change Point Detection**

Use change point detection to find the point at which a shift occurs in your data.

1. Select **Help > Sample Data Library** and open Quality Control/Gravel.jmp.
2. Select **Analyze > Quality and Process > Control Chart > Multivariate Control Chart**.
3. Select Large and Medium and click **Y, Columns**.
4. Click **OK**.
5. From the red triangle menu, select **Change Point Detection**.

**Figure 7.11** Change Point Detection for Gravel.jmp

![Change Point Detection plot](image)

**Tip:** You might need to drag the axes to see the density ellipses for the two groups, depending on your data.

In the Change Point Detection plot, values above 1.0 indicate a possible shift in the data. At least one shift is apparent; the change point occurs at observation 24 and the shift occurs immediately after observation 24. The 95% prediction regions for the two groups have approximately the same size, shape, and orientation, visually indicating that the sample covariance matrices are similar.

---

**Statistical Details for Multivariate Control Charts**

- “Statistical Details for Individual Observations”
- “Statistical Details for Observations in Rational Subgroups”
- “Statistical Details for Change Point Detection”
**Statistical Details for Individual Observations**

Consider measurements that are not sub-grouped, that is, where the natural subgroup size is \( n = 1 \). Denote the number of observations by \( m \) and the number of variables measured by \( p \). A \( T^2 \) statistic is calculated and plotted for each observation. The calculation of the \( T^2 \) statistic and upper control limit (UCL) depends on the source of the target statistics. In a Phase I chart, the limits are based on the same data that is being plotted on the control chart. In a Phase II chart, the limits are based on target statistics that were calculated from a historical data set. For more information about \( T^2 \) statistic and control limit calculations for Hotelling \( T^2 \) control charts, see Montgomery (2013).

**Calculations for Phase I Control Charts**

In Phase I control charts, the \( T^2 \) statistic for the \( i^{th} \) observation is defined as follows:

\[
T_i^2 = (Y_i - \bar{Y})S^{-1}(Y_i - \bar{Y})
\]

where:

- \( Y_i \) is the column vector of \( p \) measurements for the \( i^{th} \) observation
- \( \bar{Y} \) is the column vector of sample means of the \( p \) variables
- \( S^{-1} \) is the inverse of the sample covariance matrix

The \( T_i^2 \) value for each of the \( i \) observations are the points plotted on the multivariate control chart.

When computing Phase I control limits, the UCL is based on the beta distribution. Specifically, the upper control limit (UCL) is defined as follows:

\[
UCL = \frac{(m-1)^2}{m} \beta \left[ 1 - \frac{p}{2} \cdot \frac{m-p-1}{2} \right]
\]

where:

- \( p = \) number of variables
- \( m = \) number of observations

\[
\beta \left[ 1 - \frac{p}{2} \cdot \frac{m-p-1}{2} \right] = (1-\alpha)^{th} \text{quantile of a Beta} \left( \frac{p}{2}, \frac{m-p-1}{2} \right) \text{distribution}
\]

**Calculations for Phase II Control Charts**

In Phase II control charts, define the historical data set as \( X \). Then the \( T^2 \) statistic for the \( i^{th} \) observation is defined as follows:
Chapter 7  
Quality and Process Methods  
Statistical Details for Multivariate Control Charts

\[ T_i^2 = (Y_i - \bar{X})S_X^{-1}(Y_i - \bar{X}) \]

where:
- \( Y_i \) is the column vector of \( p \) measurements for the \( i^{th} \) observation
- \( \bar{X} \) is the column vector of sample means of the \( p \) variables, calculated from the historical data set
- \( S_X^{-1} \) is the inverse of the sample covariance matrix, calculated from the historical data set

The \( T_i^2 \) value for each of the \( i \) observations are the points plotted on the multivariate control chart.

When computing Phase II control limits, new observations are independent of the historical data set. In this case, the upper control limit (UCL) is a function of the \( F \) distribution and partially depends on the number of observations in the historical data set from which the targets are calculated. The UCL is defined as follows:

\[
UCL = \begin{cases} 
\frac{p(m + 1)(m - 1)}{m(m - p)} F_{[1 - \alpha, p, m - p]} & \text{if } m \leq 100 \\
\frac{p(m - 1)}{m - p} F_{[1 - \alpha, p, m - p]} & \text{if } m > 100 
\end{cases}
\]

where:
- \( p \) = number of variables
- \( m \) = number of observations in the historical data set
- \( F_{[1 - \alpha, p, m - p]} = (1 - \alpha)^{th} \) quantile of an \( F(p, m - p) \) distribution

Statistical Details for Observations in Rational Subgroups

Consider the case where \( p \) variables are monitored and \( m \) subgroups of size \( n > 1 \) are obtained. A \( T^2 \) statistic is calculated and plotted for each subgroup. The calculation of the \( T^2 \) statistic and upper control limit (UCL) depends on the source of the target statistics. In a Phase I chart, the limits are based on the same data that is being plotted on the control chart. In a Phase II chart, the limits are based on target statistics that were calculated from a historical data set. For more information about \( T^2 \) statistic and control limit calculations for Hotelling \( T^2 \) control charts, see Montgomery (2013).

Calculations for Phase I Control Charts

For Phase I control charts, the \( T^2 \) statistic for the \( j^{th} \) subgroup is defined as follows:
\[ T_j^2 = (\bar{Y}_j - \bar{Y})S_p^{-1}(\bar{Y}_j - \bar{Y}) \]

where:

\( \bar{Y}_j \) is the mean of the \( n \) column vectors of \( p \) measurements for the \( j^{th} \) subgroup

\[ \bar{Y} = \frac{1}{m} \sum_{j=1}^{m} \bar{Y}_j \] is the mean of the subgroup means

\( S_j \) is the sample covariance matrix for the \( n \) observations in the \( j^{th} \) subgroup

\[ S_p = \frac{1}{m} \sum_{j=1}^{m} S_j \] is the pooled covariance matrix, calculated as the mean of the within-subgroup covariance matrices

The Phase I upper control limit (UCL) is defined as follows:

\[ \text{UCL} = \frac{p(m-1)(n-1)}{mn-m-p+1} F_{1-\alpha, p, mn-m-p+1} \]

where:

\( p \) = number of variables

\( n \) = sample size for each subgroup

\( m \) = number of subgroups

\[ F_{1-\alpha, p, mn-m-p+1} = (1-\alpha)^{th} \] quantile of an \( F(p, mn-m-p+1) \) distribution

**Calculations for Phase II Control Charts**

In Phase II control charts, define the historical data set from which the target statistics are calculated as \( X \). Then the \( T^2 \) statistic for the \( j^{th} \) subgroup is defined as follows:

\[ T_j^2 = (\bar{Y}_j - \bar{X})S_p^{-1}(\bar{Y}_j - \bar{X}) \]

where:

\( \bar{Y}_j \) is the mean of the \( n \) column vectors of \( p \) measurements for the \( j^{th} \) subgroup

\( \bar{X}_k \) is the mean of the \( n \) column vectors of \( p \) measurements for the \( k^{th} \) subgroup from the historical data set

\[ \bar{X} = \frac{1}{m} \sum_{k=1}^{m} \bar{X}_k \] is the overall mean of the observations
Chapter 7
Multivariate Control Charts

Quality and Process Methods
Statistical Details for Multivariate Control Charts

$S_k$ is the sample covariance matrix for the $n$ observations in the $k^{th}$ subgroup from the historical data set

$$S_p = \frac{1}{m} \sum_{k=1}^{m} S_k$$

is the pooled covariance matrix, calculated as the mean of the within-subgroup covariance matrices

The Phase II upper control limit (UCL) is defined as follows:

$$UCL = \frac{p(m+1)(n-1)}{mn - m - p + 1} F_{1-\alpha, p, mn - m - p + 1}$$

where:

- $p =$ number of variables
- $n =$ subgroup sample size
- $m =$ number of subgroups in the historical data set
- $F_{1-\alpha, p, mn - m - p + 1} =$ $(1-\alpha)^{th}$ quantile of an $F(p, mn - m - p + 1)$ distribution

**Additivity of Test Statistics for Observations in Rational Subgroups**

When a sample of $mn$ independent normal observations is grouped into $m$ rational subgroups each of size $n$, define $T^2_M$ as the distance between the mean $\bar{Y}_j$ of the $j^{th}$ subgroup and the target value. ($T^2_M$ is equivalent to $T^2$ in the previous sections for observations in rational subgroups.) You can also calculate $T^2$ statistics related to the internal variability in each subgroup and the overall variability around the target value. The components of the $T^2$ statistic are additive, much like sums of squares. Specifically, the following relationship is true for each of the $m$ subgroups:

$$T^2_{A_j} = T^2_{M_j} + T^2_{D_j}$$

In all of the following definitions, $S_p$ is defined as it is in the previous sections, depending on whether the control chart is a Phase I or a Phase II control chart. Also, define $\mu$ as $\bar{Y}$ for Phase I control charts and as $\bar{X}$ for Phase II control charts.

The distance from the target value for the $j^{th}$ subgroup is defined as follows:

$$T^2_{M_j} = n(\bar{Y}_j - \mu)^{\prime}S_p^{-1}(\bar{Y}_j - \mu)$$

The internal variability for the $j^{th}$ subgroup is defined as follows:

$$T^2_{D_j} = \sum_{i=1}^{n} (Y_{ji} - \bar{Y}_j)^{\prime}S_p^{-1}(Y_{ji} - \bar{Y}_j)$$
where $Y_{ji}$ is the $i$th column vector of $p$ measurements for the $j$th subgroup.

The overall variability for the $j$th subgroup is defined as follows:

$$T^2_{A_j} = \sum_{i=1}^{n} (Y_{ji} - \mu)'SP^{-1}(Y_{ji} - \mu)$$

where $Y_{ji}$ is the $i$th column vector of $p$ measurements for the $j$th subgroup.

**Note:** When you select the **Save T Square** or **Save T Square Formula** options from the Multivariate Control Chart red triangle menu, the three values saved in each row correspond to one value of $i$ in the three definitions above.

### Statistical Details for Change Point Detection

This discussion follows the development in Sullivan and Woodall (2000).

**Assumptions**

Denote a multivariate distribution of dimension $p$ with mean vector $\mu_i$ and covariance matrix $\Sigma_i$ by $N_p(\mu_i, \Sigma_i)$. Suppose that the $x_i$ are $m$ (where $m > p$) independent observations from such a distribution:

$$x_i \sim N_p(\mu_i, \Sigma_i), \quad i = 1, \ldots, m$$

If the process is stable, the means $\mu_i$ and the covariance matrices $\Sigma_i$ equal a common value so that the $x_i$ have a $N_p(\mu, \Sigma)$ distribution.

Suppose that a single change occurs in either the mean vector or the covariance matrix, or both, between the $m_1$ and $m_1+1$ observations. Then the following conditions hold:

- Observations $1$ through $m_1$ have the same mean vector and the same covariance matrix $(\mu_a, \Sigma_a)$.
- Observations $m_1 + 1$ to $m$ have the same mean vector and covariance matrix $(\mu_b, \Sigma_b)$.
- One of the following occurs:
  - If the change affects the mean, $\mu_a \neq \mu_b$.
  - If the change affects the covariance matrix, $\Sigma_a \neq \Sigma_b$.
  - If the change affects both the mean and the covariance matrix, $\mu_a \neq \mu_b$ and $\Sigma_a \neq \Sigma_b$.

**Overview**

A likelihood ratio test approach is used to identify changes in one or both of the mean vector and covariance matrix. The likelihood ratio test statistic is used to compute a control chart.
statistic that has an approximate upper control limit of 1. The control chart statistic is plotted for all possible \( m_1 \) values. If any observation’s control chart statistic exceeds the upper control limit of 1, this is an indication that a shift occurred. Assuming that exactly one shift occurs, that shift is considered to begin immediately after the observation with the maximum control chart statistic value.

**Likelihood Ratio Test Statistic**

The maximum value of twice the log-likelihood function for the first \( m_1 \) observations is given as follows:

\[
l_1 = -m_1 k_1 \log(2\pi) - m_1 \log |S_1|_{k_1} - m_1 k_1
\]

The equation for \( l_1 \) uses the following notation:

- \( S_1 \) is the maximum likelihood estimate of the covariance matrix for the first \( m_1 \) observations.
- \( k_1 = \text{Min}[p, m_1 - 1] \) is the rank of the \( p \times p \) matrix \( S_1 \).
- The notation \( |S_1|_{k_1} \) denotes the generalized determinant of the matrix \( S_1 \), which is defined as the product of its \( k_1 \) positive eigenvalues \( \lambda_j \):

\[
|S_1|_{k_1} = \prod_{j = 1}^{k_1} \lambda_j
\]

The generalized determinant is equal to the ordinary determinant when \( S_1 \) has full rank.

Denote the maximum of twice the log-likelihood function for the subsequent \( m_2 = m - m_1 \) observations by \( l_2 \), and the maximum of twice the log-likelihood function for all \( m \) observations by \( l_0 \). Both \( l_2 \) and \( l_0 \) are given by expressions similar to that given for \( l_1 \).

The likelihood ratio test statistic compares the sum \( l_1 + l_2 \) to \( l_0 \). The sum \( l_1 + l_2 \) is twice the log-likelihood that assumes a possible shift at \( m_1 \). The value \( l_0 \) is twice the log-likelihood that assumes no shift. If \( l_0 \) is substantially smaller than \( l_1 + l_2 \), the process is assumed to be unstable.

The likelihood ratio test statistic for a test of whether a change begins at observation \( m_1 + 1 \) is given as follows:

\[
\text{lrt}[m_1] = (l_1 + l_2 - l_0) \\
= (m_1(p - k_1) + m_2(p - k_2))(1 + \log(2\pi)) \\
+ m \log(|S|) - m_1 \log |S_1|_{k_1} - m_2 \log |S_2|_{k_2}
\]
The distribution of the likelihood ratio test statistic is asymptotically chi-square distributed with \( p(p + 3)/2 \) degrees of freedom. Large log-likelihood ratio values indicate that the process is unstable.

**The Control Chart Statistic**

Simulations indicate that the expected value of \( \text{lrt}[m_1] \) varies based on the observation’s location in the series, and, in particular, depends on \( p \) and \( m \). See Sullivan and Woodall (2000).

Approximating formulas for the expected value of \( \text{lrt}[m_1] \) are derived by simulation. To reduce the dependence of the expected value on \( p \), \( \text{lrt}[m_1] \) is divided by its asymptotic expected value, \( p(p + 3)/2 \).

The formulas for the approximated expected value of \( \text{lrt}[m_1] \) divided by \( p(p+3)/2 \) are given as follows:

\[
\text{ev}[m,p,m_1] = \begin{cases} 
  a_p + m_1 b_p, & \text{if } m_1 < p + 1 \\
  a_p + (m - m_1) b_p', & \text{if } m - m_1 < p + 1 \\
  1 + \frac{m - 2p - 1}{(m_1 - p)(m - p - m_1)'}, & \text{otherwise}
\end{cases}
\]

where

\[
a_p = \frac{0.08684(p - 14.69)(p - 2.036)}{(p - 2)}
\]

and

\[
b_p = \frac{0.1228(p - 1.839)}{(p - 2)}
\]

For \( p = 2 \), the value of \( \text{ev}[m,p,m_1] \) when \( m_1 \) or \( m_2 = 2 \) is 1.3505.

**Note:** The formulas above are not accurate for \( p > 12 \) or \( m < (2p + 4) \). In such cases, simulation should be used to obtain approximate expected values.

An approximate upper control limit that yields a false out-of-control signal with probability approximately 0.05, assuming that the process is stable, is given as follows:

\[
\text{UCL}[m,p] \equiv 3.338 - 2.115\log[p] + 0.8819(\log[p])^2 - 0.1382(\log[p])^3 + (0.6389 - 0.3518\log[p] + 0.01784(\log[p])^3)\log[m].
\]

Note that this formula depends on \( m \) and \( p \).
The control chart statistic is defined to be twice the log of the likelihood ratio test statistic divided by $p(p + 3)$, divided by its approximate expected value, and also divided by the approximate value of the control limit. Because of the division by the approximate value of the UCL, the control chart statistic can be plotted against an upper control limit of 1. The approximate control chart statistic is given as follows:

$$\hat{y}[m_1] = \frac{2\text{lrt}[m_1]}{p(p + 3)(\text{ev}[m,p,m_1]UCL[m,p])}$$
The Measurement Systems Analysis (MSA) platform assesses the precision, consistency, and bias of a measurement system. Before you can study the process itself, you need to make sure that you can accurately and precisely measure the process. If most of the variation that you see comes from the measuring process itself, then you are not reliably learning about the process. Use MSA to find out how your measurement system is performing.

This chapter covers the EMP method. The Gauge R&R method is described in the “Variability Gauge Charts” chapter on page 213.

Figure 8.1  Example of a Measurement System Analysis
## Contents

- Overview of Measurement Systems Analysis .................................................. 189
- Example of Measurement Systems Analysis .................................................... 189
- Launch the Measurement Systems Analysis Platform ...................................... 192
- Measurement Systems Analysis Platform Options ......................................... 194
  - Average Chart .............................................................................................. 196
  - Range Chart or Standard Deviation Chart ...................................................... 197
  - EMP Results ............................................................................................... 197
  - Effective Resolution ................................................................................... 199
  - Shift Detection Profiler ............................................................................. 199
  - Bias Comparison ....................................................................................... 204
  - Test-Retest Error Comparison .................................................................. 205
- Additional Example of Measurement Systems Analysis ............................... 205
- Statistical Details for Measurement Systems Analysis ................................. 211
Overview of Measurement Systems Analysis

The EMP (Evaluating the Measurement Process) method in the Measurement Systems Analysis platform is largely based on the methods presented in Donald J. Wheeler’s book *EMP III Using Imperfect Data* (2006). The EMP method provides visual information and results that are easy to interpret and helps you improve your measurement system to its full potential.

The Gauge R&R method analyzes how much of the variability is due to operator variation (reproducibility) and measurement variation (repeatability). Gauge R&R is available for many combinations of crossed and nested models, regardless of whether the model is balanced. For more information, see the “Variability Gauge Charts” chapter on page 213.

Within the Six Sigma DMAIC methodology, MSA (Measurement System Analysis) addresses the Measure phase and process behavior charts (or control charts) address the Control phase. MSA helps you predict and characterize future outcomes. You can use the information gleaned from MSA to help you interpret and configure your process behavior charts.

For more information about Control Charts, see the “Control Chart Builder” on page 33.

Example of Measurement Systems Analysis

In this example, three operators measured the same five parts. See how the measurement system is performing, based on how much variation is found in the measurements.

1. Select Help > Sample Data Library and open Variability Data/Gasket.jmp.
3. Assign Y to the Y, Response role.
4. Assign Part to the Part, Sample ID role.
5. Assign Operator to the X, Grouping role.
   Notice that the MSA Method is set to EMP, the Chart Dispersion Type is set to Range, and the Model Type is set to Crossed. See Figure 8.5.
6. Click OK.
The Average Chart shows the average measurements for each operator and part combination. In this example, the means of the part measurements are generally beyond the control limits. This is a desirable outcome, because it indicates that you can detect part-to-part variation.

The Range Chart shows the variability for each operator and part combination. In this example, the ranges are within the control limits. This is a desirable outcome, because it indicates that the operators are measuring parts in the same way and with similar variation.

The color coding for each part is shown in the legend below the charts.

7. From the red triangle menu next to Measurement Systems Analysis for Y, select Parallelism Plots.
The Parallelism Plots chart shows the average measurements for each part by operator. Because the lines are generally parallel and there is no major crossing, you conclude that there is no interaction between operators and parts.

**Tip:** Interactions indicate a serious issue that requires further investigation.

8. From the red triangle menu next to Measurement Systems Analysis for Y, select **EMP Results**.

---

**Figure 8.4 EMP Results Report**

<table>
<thead>
<tr>
<th>EMP Test</th>
<th>Results</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test-Retest Error</td>
<td>3.7812</td>
<td>Within Error</td>
</tr>
<tr>
<td>Degrees of Freedom</td>
<td>13.39</td>
<td>Amount of information used to estimate within error</td>
</tr>
<tr>
<td>Probable Error</td>
<td>2.5504</td>
<td>Median error for a single measurement</td>
</tr>
<tr>
<td>Intraclass Correlation (no bias)</td>
<td>0.9745</td>
<td>Proportion of variation attributed to part variation without including bias factors</td>
</tr>
<tr>
<td>Intraclass Correlation (with bias)</td>
<td>0.9437</td>
<td>Proportion of variation attributed to part variation with bias factors</td>
</tr>
<tr>
<td>Bias Impact</td>
<td>0.0308</td>
<td>Amount by which the bias factors reduce the intraclass correlation</td>
</tr>
</tbody>
</table>

**System Classification**

- Current (with bias)  First Class
- Potential (no bias)  First Class

**Monitor Classification Legend**

<table>
<thead>
<tr>
<th>Classification</th>
<th>Intraclass Correlation</th>
<th>Attenuation of Process Signal</th>
<th>Probability of Warning Test 1 Only*</th>
<th>Probability of Warning Tests 1-4*</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Class</td>
<td>0.80 - 1.00</td>
<td>Less than 11%</td>
<td>0.99 - 1.00</td>
<td>1.00</td>
</tr>
<tr>
<td>Second Class</td>
<td>0.50 - 0.80</td>
<td>11% - 20%</td>
<td>0.88 - 0.99</td>
<td>1.00</td>
</tr>
<tr>
<td>Third Class</td>
<td>0.20 - 0.50</td>
<td>29% - 55%</td>
<td>0.40 - 0.88</td>
<td>0.92 - 1.00</td>
</tr>
<tr>
<td>Fourth Class</td>
<td>0.00 - 0.20</td>
<td>More than 55%</td>
<td>0.03 - 0.40</td>
<td>0.08 - 0.92</td>
</tr>
</tbody>
</table>

* Probability of warning for a 3 standard error shift within 10 subgroups using Wheeler’s tests, which correspond to Nelson’s tests 1, 2, 5, and 6.
The EMP Results report computes several statistics to help you assess and classify your measurement system. The Intraclass Correlation indicates the proportion of the total variation that you can attribute to the part.

From the EMP Results report, you can conclude the following:

- The Intraclass Correlation values are close to 1, indicating that most of the variation is coming from the part instead of the measurement system.
- The classification is First Class, meaning that the strength of the process signal is weakened by less than 11%.
- There is at least a 99% chance of detecting a warning using Test 1 only.
- There is 100% chance of detecting a warning using Tests 1-4.

**Note:** For more information about tests and detecting process shifts, see “Shift Detection Profiler” on page 199.

There is no interaction between operators and parts, and there is very little variation in your measurements (the classification is First Class). Therefore, you conclude that the measurement system is performing quite well.

---

**Launch the Measurement Systems Analysis Platform**

Launch the Measurement Systems Analysis platform by selecting **Analyze > Quality and Process > Measurement Systems Analysis.**
The Measurement Systems Analysis window contains the following features:

**Select Columns** lists all of the variables in your current data table. Move a selected column into a role.

**MSA Method** select the method to use: EMP (Evaluating the Measurement Process) or Gauge R&R. This chapter covers the EMP method. For details about the Gauge R&R method, see the “Variability Gauge Charts” chapter on page 213.

**Chart Dispersion Type** designates the type of chart for showing variation. Select the Range option or the Standard Deviation option.

**Note:** For the EMP method, the chart dispersion type determines how the statistics in the EMP Results report are calculated. If the Range option is selected, and you have a one factor or a two factor, balanced, crossed model, the statistics in this report are based on ranges. Otherwise, the statistics in this report are based on standard deviations.

**Model Type** designates the model type:

- Main: variables with nominal or ordinal modeling types are treated as main effects.
- Crossed: the model is crossed when every level of every factor occurs with every level of every other factor.
- Crossed with Two Factor Interactions: the model is crossed when each level of two factors occurs with every level of the other factor.
– Nested: the model is nested when all levels of a factor appear within only a single level of any other factor.
– Cross then Nested (3 Factors Only): the factors are crossed and then nested for 3 factors.
– Nested then Crossed (3 Factors Only): the factors are nested and then crossed for 3 factors.

Options contains the following options:
– Analysis Settings sets the REML maximum iterations and convergence.
– Specify Alpha specifies the 1-alpha confidence level.

Y, Response is the column of measurements.

Part, Sample, ID is the column designating the part or unit.

X, Grouping is the column(s) representing grouping variables.

By identifies a column that creates a report consisting of separate analyses for each level of the variable.

---

Measurement Systems Analysis Platform Options

Platform options appear within the red triangle menu next to Measurement Systems Analysis. Selecting an option creates the respective graph or report in the MSA report window. Deselecting an option removes the graph or report. Choose from the following options:

Average Chart A plot of the average measurement values for each combination of the part and X variables. The Average Chart helps you detect product variation despite measurement variation. In an Average Chart, out of control data is desirable because it detects part-to-part variation. See “Average Chart” on page 196.

Range Chart A plot of the variability statistic for each combination of the part and X variables. Appears only if you selected Range as the Chart Dispersion Type in the launch window. The Range Chart helps you check for consistency within subgroups. In a Range Chart, data within limits is desirable, indicating homogeneity in your error. See “Range Chart or Standard Deviation Chart” on page 197.

Std Dev Chart A plot of the standard deviation statistic for each combination of the part and X variables. Appears only if you selected Standard Deviation as the Chart Dispersion Type in the launch window. The Standard Deviation Chart helps you check for consistency within subgroups. In a Standard Deviation Chart, data within limits is desirable,
indicating homogeneity in your error. See “Range Chart or Standard Deviation Chart” on page 197.

**Parallelism Plots**  An overlay plot that reflects the average measurement values for each part. If the lines are relatively not parallel or crossing, there might be an interaction between the part and X variables.

**Tip:** Interactions indicate a serious issue that requires further investigation. For example, interactions between parts and operators mean that operators are measuring different parts differently, on average. Therefore, measurement variability is not predictable. This issue requires further investigation to find out why the operators do not have the same pattern or profile over the parts.

**EMP Results**  a report that computes several statistics to help you assess and classify your measurement system. See “EMP Results” on page 197.

**Effective Resolution**  a report containing results for the resolution of a measurement system. See “Effective Resolution” on page 199.

**Bias Comparison**  an Analysis of Means chart for testing if the X variables have different averages. See “Bias Comparison” on page 204.

**Test-Retest Error Comparison**  an Analysis of Means for Variances or Analysis of Means Ranges chart for testing if any of the groups have different test-retest error levels. See “Test-Retest Error Comparison” on page 205.

**Shift Detection Profiler**  an interactive set of charts that you can adjust to see the probabilities of getting warnings on your process behavior chart. See “Shift Detection Profiler” on page 199.

**Variance Components**  a report containing the estimates of the variance components for the given model. The calculations in this report are based on variances, not ranges. Balanced data uses the EMS method. Unbalanced data uses the REML method.

**Note:** This report is similar to the Variance Components report in the Variability Chart platform, except that it does not compute Bayesian variance component estimates. For more information, see “Variance Components” on page 223 in the “Variability Gauge Charts” chapter.

**EMP Gauge R&R Results**  a report that partitions the variability in the measurements into part variation and measurement system variation. The calculations in this report are based on variances, not ranges.
Note: This report is similar to the Gauge R&R report in the Variability Chart platform, except that the calculation for Reproducibility does not include interactions. For more information about Gauge R&R studies, see “About the Gauge R&R Method” on page 225 in the “Variability Gauge Charts” chapter.

See the JMP Reports chapter in the Using JMP book for more information about the following options:

Local Data Filter  Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Average Chart

The red triangle menu next to Average Chart contains the following options:

Show Grand Mean  draws the overall mean of the Y variable on the chart.

Show Connected Means  draws lines connecting all of the average measurement values.

Show Control Limits  draws lines representing the Upper Control Limit (UCL) and the Lower Control Limit (LCL) and defines those values.

Show Control Limits Shading  adds shading between the UCL and LCL.

Show Separators  draws vertical lines to delineate between the X variables.

Show Data  adds the data points to the chart.

Note: You can replace variables in the Average Chart in one of two ways: swap existing variables by dragging and dropping a variable from one axis to the other axis; or, click on a variable in the Columns panel of the associated data table and drag it onto an axis.
**Range Chart or Standard Deviation Chart**

The red triangle menu next to Range Chart or Standard Deviation Chart contains the following options:

- **Show Average Dispersion**  draws the average range or standard deviation on the chart.
- **Show Connected Points**  draws lines connecting all of the ranges or standard deviations.
- **Show Control Limits**  draws lines representing the Upper Control Limit (UCL) and the Lower Control Limit (LCL) and defines those values.
- **Show Control Limits Shading**  adds shading between the UCL and LCL.
- **Show Separators**  draws vertical lines to delineate between the X variables.

**Note:** You can replace variables in the Range or Standard Deviation Charts in one of two ways: swap existing variables by dragging and dropping a variable from one axis to the other axis; or, click on a variable in the Columns panel of the associated data table and drag it onto an axis.

**EMP Results**

**Note:** The statistics in this report are based on ranges in the following instances: if you selected EMP as the MSA Method and Range as the Chart Dispersion Type, and you have a one factor or a two factor, balanced, crossed model. Otherwise, the statistics in this report are based on variances.

The EMP Results report computes several statistics to help you assess and classify your measurement system. Using this report, you can determine the following:

- How your process chart is affected.
- Which tests to set.
- How much the process signal is attenuated.
- How much the bias factors are affecting your system and reducing your potential intraclass correlation coefficient.

The EMP Results report contains the following calculations:

- **Test-Retest Error**  indicates measurement variation or repeatability (also known as within error or pure error).
- **Degrees of Freedom**  indicates the amount of information used to estimate the within error.
Probable Error the median error for a single measurement. Indicates the resolution quality of your measurement and helps you decide how many digits to use when recording measurements. For more information, see “Effective Resolution” on page 199.

Intraclass Correlation indicates the proportion of the total variation that you can attribute to the part. If you have very little measurement variation, this number is closer to 1.

- Intraclass Correlation (no bias) does not take bias or interaction factors into account when calculating the results.
- Intraclass Correlation (with bias) takes the bias factors (such as operator, instrument, and so on) into account when calculating the results.
- Intraclass Correlation (with bias and interaction) takes the bias and interaction factors into account when calculating the results. This calculation appears only if the model is crossed and uses standard deviation instead of range.

Bias Impact the amount by which the bias factors reduce the Intraclass Correlation.

Bias and Interaction Impact the amount by which the bias and interaction factors reduce the Intraclass Correlation. This calculation appears only if the model is crossed and uses standard deviation instead of range.

Classes of Process Monitors

In order to understand the System and Classification parameters, you must first understand the Monitor Classification Legend.

Figure 8.6 Monitor Classification Legend

This legend describes the following classifications: First, Second, Third, and Fourth Class. Each classification indicates the following:

- the corresponding Intraclass Correlation values
- the amount of process signal attenuation (decrease)
- the chance of detecting a 3 standard error shift within 10 subgroups, using Wheeler’s test one or all four tests
Wheeler (2006) identifies four detection tests known as the Western Electric Zone Tests. Within the Shift Detection Profiler, there are eight tests that you can select from. The tests that correspond to the Wheeler tests are the first, second, fifth, and sixth tests.

**Tip:** To prevent the legend from appearing, deselect **Show Monitor Classification Legend** in the EMP Measurement Systems Analysis platform preferences.

### Effective Resolution

The Effective Resolution report helps you determine how well your measurement increments are working. You might find that you need to add or drop digits when recording your measurements, or your current increments might be effective as is. Note the following:

- The Probable Error calculates the median error of a measurement.
- The Current Measurement Increment reflects how many digits you are currently rounding to and is taken from the data as the nearest power of ten. This number is compared to the Smallest Effective Increment, Lower Bound Increment, and Largest Effective Increment. Based on that comparison, a recommendation is made.
- Large measurement increments have less uncertainty in the last digit, but large median errors. Small measurement increments have small median errors, but more uncertainty in the last digit.

### Shift Detection Profiler

Use the Shift Detection Profiler to assess the sensitivity of the control chart that you use to monitor your process. The Shift Detection Profiler estimates the probability of detecting shifts in the product mean or product standard deviation. The control chart limits include sources of measurement error variation. Based on these limits, the Shift Detection Profiler estimates the Probability of Warning. This is the probability that a control chart monitoring the process mean signals a warning over the next $k$ subgroups.

You can set the subgroup size that you want to use for your control chart. Note the following:

- If the Subgroup Size equals one, the control chart is an Individual Measurement chart.
- If the Subgroup Size exceeds one, the control chart is an X-bar chart.

You can explore the effect of Subgroup Size on the control chart’s sensitivity. You can also explore the benefits of reducing bias and test-retest error.

Figure 8.7 shows the Shift Detection Profiler report for the *Gasket.jmp* sample data table, found in the Variability Data folder.
Probability of Warning

The Probability of Warning is the probability of detecting a change in the process. A change is defined by the Part Mean Shift and the Part Std Dev settings in the Shift Detection Profiler. The probability calculation assumes that the tests selected in the Customize and Select Tests outline are applied to the Number of Subgroups specified in the Profiler.

The control limits for the Individual Measurement chart (Subgroup Size = 1) and the X-bar chart (Subgroup Size > 1) are based on the In-Control Chart Sigma. The In-Control Sigma takes into account the bias factor (reproducibility) variation and the test-retest (repeatability) variation. These are initially set to the values obtained from your MSA study. The In-Control Chart Sigma also incorporates the In-Control Part Std Dev. Both of these values appear beneath the profiler, along with the False Alarm Probability, which is based on the In-Control Chart Sigma.
**In-Control Part Std Dev**  The standard deviation for the true part values, exclusive of measurement errors, for the stable process. The default value for In-Control Part Std Dev is the standard deviation of the part component estimated by the MSA analysis and found in the Variance Components report.

Often, parts for an MSA study are chosen to have specific properties and do not necessarily reflect the part-to-part variation seen in production. For this reason, you can specify the in-control part standard deviation by selecting **Change In-Control Part Std Dev** from the Shift Detection Profiler red triangle menu.

**In-Control Chart Sigma**  The value of sigma used to compute control limits. This value is computed using the In-Control Part Std Dev, the Bias Factors Std Dev, and Test-Retest Std Dev specified in the Shift Detection Profiler, and the Subgroup Size. The reproducibility factors are assumed to be constant within a subgroup.

For a subgroup of size $n$, control limits are set at the following values:

$$
\pm 3\left(\text{In-Control Chart Sigma}\right) / (\sqrt{n})
$$

It follows that the In-Control Chart Sigma is the square root of the sum of the squares of the following terms:

- In-Control Part Std Dev
- Bias Factors Std Dev, as specified in the Shift Detection Profiler, multiplied by $\sqrt{n}$
- Test-Retest Std Dev, as specified in the Shift Detection Profiler

The Bias Factors Std Dev is multiplied by $\sqrt{n}$ to account for the assumption that the reproducibility factors are constant within a subgroup.

JMP updates the In-Control Chart Sigma when you change the In-Control Part Std Dev, the Bias Factors Std Dev, the Test-Retest Std Dev, or the Subgroup Size.

**False Alarm Probability**  The probability that the control chart tests signal a warning when no change in the part mean or standard deviation has occurred. JMP updates the False Alarm Probability when you change the Number of Subgroups or the tests in Customize and Select Tests.

For more information about the Variance Components report, see “Variance Components” on page 223 in the “Variability Gauge Charts” chapter.

**Shift Detection Profiler Settings**

**Number of Subgroups**  The number of subgroups over which the probability of a warning is computed. If the number of subgroups is set to $k$, the profiler gives the probability that the control chart signals at least one warning based on these $k$ subgroups. The Number of
Subgroups is set to 10 by default. Drag the vertical line in the plot to change the Number of Subgroups.

**Part Mean Shift**  The shift in the part mean. By default, the profiler is set to detect a 1 sigma shift. The initial value is the standard deviation of the part component estimated by the MSA analysis and found in the Variance Components report. Drag the vertical line in the plot or click the value beneath the plot to change the Part Mean Shift.

**Part Std Dev**  The standard deviation for the true part values, exclusive of measurement errors. The initial value for Part Std Dev is the standard deviation of the part component estimated by the MSA analysis and is found in the Variance Components report. Drag the vertical line in the plot or click the value beneath the plot to change the Part Std Dev.

**Bias Factors Std Dev**  The standard deviation of factors related to reproducibility. Bias factors include operator and instrument. The bias factor variation does not include part and repeatability (within) variation. The initial value is derived using the reproducibility and interaction variance components estimated by the MSA analysis and is found in the Variance Components report. Drag the vertical line in the plot or click the value beneath the plot to change the Bias Factors Std Dev.

**Test-Retest Std Dev**  The standard deviation of the test-retest, or repeatability, variation in the model. The initial value is the standard deviation of the Within component estimated by the MSA analysis and is found in the Variance Components report. Drag the vertical line in the plot or click the value beneath the plot to change the Test-Retest Std Dev.

**Subgroup Size**  The sample size used for each subgroup. This is set to 1 by default. You can increase the sample size to investigate improvement in control chart performance. Increasing the sample size from 1 demonstrates what happens when you move from an Individual Measurement chart to an XBar chart. Drag the vertical line in the plot to change the Subgroup Size.

**Shift Detection Profiler Options**

The red triangle menu for the Shift Detection Profiler provides several options. Only one option is described here.

**Change In-Control Part Std Dev**  Specify a value for the part standard deviation for the stable process. The in-control part standard deviation should reflect the variation of the true part values, exclusive of measurement errors. Enter a new value and click OK.

The In-Control Part Std Dev is originally set to the standard deviation of the part component estimated by the MSA analysis, found in the Variance Components report.

This option is useful if the parts chosen for the EMP study were not a random sample from the process.
**Reset Factor Grid**  Displays a window for each factor allowing you to enter a specific value for the factor’s current setting, to lock that setting, and to control aspects of the grid. See the Introduction to Profilers chapter in the *Profilers* book for details.

**Factor Settings**  Submenu that consists of the following options:

- **Remember Settings**  Adds an outline node to the report that accumulates the values of the current settings each time the Remember Settings command is invoked. Each remembered setting is preceded by a radio button that is used to reset to those settings.

- **Copy Settings Script**  Copies the current Profiler’s settings to the clipboard.

- **Paste Settings Script**  Pastes the Profiler settings from the clipboard to a Profiler in another report.

- **Set Script**  Sets a script that is called each time a factor changes. The set script receives a list of arguments of the form:

  `{factor1 = n1, factor2 = n2, ...}`

  For example, to write this list to the log, first define a function:

  ```
  ProfileCallbackLog = Function({arg},show(arg));
  ```

  Then enter `ProfileCallbackLog` in the Set Script dialog.

  Similar functions convert the factor values to global values:

  ```
  ProfileCallbackAssign = Function({arg},evalList(arg));
  ```

  Or access the values one at a time:

  ```
  ProfileCallbackAccess = Function({arg},f1=arg["factor1"];f2=arg["factor2"]);
  ```

**Shift Detection Profiler Legend**

This panel gives a brief description of four of the Shift Detection Profiler settings. For further details, see “Shift Detection Profiler Settings” on page 201.

**Tip:** To prevent the legend from appearing, deselect *Show Shift Detection Profiler Legend* in the EMP Measurement Systems Analysis platform preferences.

**Customize and Select Tests**

In the Customize and Select Tests panel, select and customize the tests that you want to apply to the \( k \) subgroups in your control chart. The eight tests are based on Nelson (1984). For more details about the tests, see “Tests” on page 52 in the “Control Chart Builder” chapter.
The Shift Detection Profiler calculations take these tests into account. The Probability of Warning and False Alarm Probability values increase as you add more tests. Because the calculations are based on a quasi-random simulation, there might be a slight delay as the profiler is updated.

The Customize and Select Tests panel has the following options:

**Restore Default Settings** If no settings have been saved to preferences, this option resets the selected tests to the first test only. The values of $n$ are also reset to the values described in “Tests” on page 52 in the “Control Chart Builder” chapter. If settings have been saved to preferences, this option resets the selected tests and the values of $n$ to those specified in the preferences.

**Save Settings to Preferences** Saves the selected tests and the values of $n$ for use in future analyses. These preferences are added to the Control Chart Builder platform preferences.

**Bias Comparison**

The Bias Comparison option creates an Analysis of Means chart. This chart shows the mean values for each level of the grouping variables and compares them with the overall mean. You can use this chart to see whether an operator is measuring parts too high or too low, on average.

The red triangle menu next to Analysis of Means contains the following options:

**Set Alpha Level** select an option from the most common alpha levels or specify any level using the Other selection. Changing the alpha level modifies the upper and lower decision limits.

**Show Summary Report** shows a report containing group means and decision limits, and reports if the group mean is above the upper decision limit or below the lower decision limit.

**Display Options** include the following options:

- **Show Decision Limits** draws lines representing the Upper Decision Limit (UDL) and the Lower Decision Limit (LDL) and defines those values.
- **Show Decision Limit Shading** adds shading between the UDL and the LDL.
- **Show Center Line** draws the center line statistic that represents the average.
- **Point Options** changes the chart display to needles, connected points, or points.
Test-Retest Error Comparison

The Test-Retest Error Comparison option creates a type of Analysis of Means for Variances or Analysis of Means Ranges chart. This chart shows if there are differences in the test-retest error between operators. For example, you can use this chart to see whether there is an inconsistency in how each operator is measuring. The Analysis of Mean Ranges chart is displayed when ranges are used for variance components.

- For information about the options in the red triangle menu next to Operator Variance Test, see “Bias Comparison” on page 204.
- For more information about Analysis of Means for Variances charts, see “Variance Components” on page 223 in the “Variability Gauge Charts” chapter.

Additional Example of Measurement Systems Analysis

In this example, three operators have measured a single characteristic twice on each of six wafers. Perform a detailed analysis to find out how well the measurement system is performing.

Perform the Initial Analysis

1. Select Help > Sample Data Library and open Variability Data/Wafer.jmp.
3. Assign Y to the Y, Response role.
4. Assign Wafer to the Part, Sample ID role.
5. Assign Operator to the X, Grouping role.
   Notice that the MSA Method is set to EMP, the Chart Dispersion Type is set to Range, and the Model Type is set to Crossed.
6. Click OK.
The Average Chart shows that some of the average part measurements fall beyond the control limits. This is desirable, indicating measurable part-to-part variation.

The Range Chart shows no points that fall beyond the control limits. This is desirable, indicating that the operator measurements are consistent within part.

**Examine Interactions**

Take a closer look for interactions between operators and parts. From the red triangle menu next to Measurement Systems Analysis for Y, select Parallelism Plots.
Looking at the parallelism plot by operator, you can see that the lines are relatively parallel and that there is only some minor crossing.

**Examine Operator Consistency**

Take a closer look at the variance between operators. From the red triangle menu next to Measurement Systems Analysis for Y, select **Test-Retest Error Comparison**.

Looking at the Test-Retest Error Comparison, you can see that none of the operators have a test-retest error that is significantly different from the overall test-retest error. The operators appear to be measuring consistently.
Just to be sure, you decide to look at the Bias Comparison chart, which indicates whether an operator is measuring parts too high or too low. From the red triangle menu next to Measurement Systems Analysis for Y, select **Bias Comparison**.

**Figure 8.11** Bias Comparison

Looking at the Bias Comparison chart, you make the following observations:

- Operator A and Operator B have detectable measurement bias, as they are significantly different from the overall average.
- Operator A is significantly biased low.
- Operator B is significantly biased high.
- Operator C is not significantly different from the overall average.

**Classify Your Measurement System**

Examine the EMP Results report to classify your measurement system and look for opportunities for improvement. From the red triangle menu next to Measurement Systems Analysis for Y, select **EMP Results**.
The classification is Second Class, which means that there is a better than 88% chance of detecting a three standard error shift within ten subgroups, using Test one only. You notice that the bias factors have an 11% impact on the Intraclass Correlation. In other words, if you could eliminate the bias factors, your Intraclass Correlation coefficient would improve by 11%.

**Explore the Ability of a Control Chart to Detect Process Changes**

Use the Shift Detection Profiler to explore the probability that a control chart will be able to detect a change in your process. From the red triangle menu next to Measurement Systems Analysis for Y, select **Shift Detection Profiler**.
By default, the only test selected is for a point beyond the 3 sigma limits. Also note that the default Subgroup Size is 1, indicating that you are using an Individual Measurement chart.

Explore your ability to detect a shift in the mean of two part standard deviations in the 10 subgroups following the shift. Click the Part Mean Shift value of 2.1701 and change it to 4.34 (2.17 multiplied by 2). The probability of detecting a shift of twice the part standard deviation is 56.9%.

Next, see how eliminating bias affects your ability to detect the shift of two part standard deviations. Change the Bias Factors Std Dev value from 1.1256 to 0. The probability of detecting the shift increases to 67.8%.

Finally, add more tests to see how your ability to detect the two part standard deviation shift changes. In addition to the first test, select the second, fifth, and sixth tests (Wheeler’s Rules 4, 2, and 3). With these four tests and no bias variation, your probability of detecting the shift is 99.9%.

You can also explore the effect of using a control chart based on larger subgroup sizes. For subgroup sizes of two or more, the control chart is an X-bar chart. Change the Bias Factors Std Dev value back to 1.1256 and deselect all but the first test. Set the Subgroup Size in the profiler to 4. The probability of detecting the two part standard deviation shift is 98.5%.
Examine Measurement Increments

Finally, see how well your measurement increments are working. From the red triangle menu next to Measurement Systems Analysis for Y, select **Effective Resolution**.

**Figure 8.14 Effective Resolution**

<table>
<thead>
<tr>
<th>Source</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Probable Error</td>
<td>( \sigma_p )</td>
<td>Median error for a single measurement</td>
</tr>
<tr>
<td>Current Measurement Increment</td>
<td>( \sigma_{MB} )</td>
<td>Measurement increment estimated from data (in tenths)</td>
</tr>
<tr>
<td>Lower Bound Increment</td>
<td>( 0.11 \sigma_p )</td>
<td>Measurement increment should not be below this value</td>
</tr>
<tr>
<td>Smallest Effective Increment</td>
<td>( 0.22 \sigma_p )</td>
<td>Measurement increment is more effective above this value</td>
</tr>
<tr>
<td>Largest Effective Increment</td>
<td>( 2.27 \sigma_p )</td>
<td>Measurement increment is more effective below this value</td>
</tr>
</tbody>
</table>

**Action: Drop a digit**

Reason: The measurement increment of 0.01 is below the lowest measurement increment bound and should be adjusted to record fewer digits.

The Current Measurement Increment of 0.01 is below the Lower Bound Increment of 0.09, indicating that you should adjust your future measurements to record one less digit.

---

**Statistical Details for Measurement Systems Analysis**

Intraclass Correlation without bias is computed as follows:

\[
 r_{pe} = \frac{\sigma_p^2}{\sigma_p^2 + \sigma_{pe}^2}
\]

Intraclass Correlation with bias is computed as follows:

\[
 r_b = \frac{\sigma_p^2}{\sigma_p^2 + \sigma_b^2 + \sigma_{pe}^2}
\]

Intraclass Correlation with bias and interaction factors is computed as follows:

\[
 r_{int} = \frac{\sigma_p^2}{\sigma_p^2 + \sigma_b^2 + \sigma_{int}^2 + \sigma_{pe}^2}
\]

Probable Error is computed as follows:
Note the following:

\[ Z_{0.75} \times \hat{\sigma}_{pe} \]

\[ \hat{\sigma}_{pe}^2 = \text{variance estimate for pure error} \]

\[ \hat{\sigma}_p^2 = \text{variance estimate for product} \]

\[ \hat{\sigma}_b^2 = \text{variance estimate for bias factors} \]

\[ \hat{\sigma}_{int}^2 = \text{variance estimate for interaction factors} \]

\[ Z_{0.75} = \text{the 75}\% \text{ quantile of standard normal distribution} \]
Variability gauge charts analyze continuous measurements and can reveal how your measurement system is performing. You can also perform a gauge study to see measures of variation in your data.

**Tip:** This chapter covers only variability charts. For details about attribute charts, see the “Attribute Gauge Charts” chapter on page 239.

**Figure 9.1  Example of a Variability Chart**
# Contents

Overview of Variability Charts ................................................................. 215  
Example of a Variability Chart ............................................................... 216  
Launch the Variability/Attribute Gauge Chart Platform ....................... 217  
The Variability Gauge Chart ................................................................. 218  
Variability Gauge Platform Options ....................................................... 220  
  Heterogeneity of Variance Tests ......................................................... 222  
  Variance Components ................................................................. 223  
  About the Gauge R&R Method .......................................................... 225  
  Gauge R&R Option ........................................................................ 226  
  Discrimination Ratio ....................................................................... 229  
  Misclassification Probabilities .......................................................... 229  
  Bias Report ..................................................................................... 230  
  Linearity Study ............................................................................. 230  
Additional Examples of Variability Charts ............................................. 231  
Example of the Heterogeneity of Variance Test ................................... 231  
Example of the Bias Report Option ...................................................... 233  
Statistical Details for Variability Charts ............................................... 236  
  Statistical Details for Variance Components ...................................... 236  
  Statistical Details for the Discrimination Ratio .................................... 237
Overview of Variability Charts

Tip: The traditional name for a variability chart is a multi vari chart, but because that name is not well known, the more generic term variability chart is used instead.

Just as a control chart shows variation across time in a process, a variability chart shows the same type of variation across categories such as parts, operators, repetitions, and instruments. A variability chart plots the data and means for each level of grouping factors, with all plots side by side. Along with the data, you can view the mean, range, and standard deviation of the data in each category, seeing how they change across the categories. The report options are based on the assumption that the primary interest is how the mean and variance change across the categories.

Variability charts are commonly used for measurement systems analysis such as Gauge R&R. This analysis examines how much of the variability is due to operator variation (reproducibility) and measurement variation (repeatability). Gauge R&R is available for many combinations of crossed and nested models, regardless of whether the model is balanced.
Example of a Variability Chart

Suppose that you have data containing part measurements. Three operators, Cindy, George, and Tom, each took measurements of 10 parts. They measured each part three times, making a total of 90 observations. You want to identify the variation between operators.

1. Select Help > Sample Data Library and open Variability Data/2 Factors Crossed.jmp.
2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.
3. For Chart Type, select Variability.
5. Select Operator and click X, Grouping.
6. Select part# and click Part, Sample ID.
7. Click OK.
8. From the red triangle menu for Variability Gauge, select Show Group Means and Connect Cell Means.

Figure 9.2  Example of a Variability Chart
Looking at the Std Dev chart, you can see that Cindy and George have more variation in their measurements than Tom, who appears to be measuring parts the most consistently. George seems to have the most variation in his measurements, so he might be measuring parts the most inconsistently.

Launch the Variability/Attribute Gauge Chart Platform

Launch the Variability/Attribute Gauge Chart platform by selecting Analyze > Quality and Process > Variability/Attribute Gauge Chart. Set the Chart Type to Variability.

Figure 9.3 The Variability/Attribute Gauge Chart Launch Window

**Chart Type** Choose between a variability gauge analysis (for a continuous response) or an attribute gauge analysis (for a categorical response, usually “pass” or “fail”).

**Note:** The content in this chapter covers only the **Variability** chart type. For details about the **Attribute** chart type, see the “Attribute Gauge Charts” chapter on page 239.

**Model Type** Choose the model type (Main Effect, Crossed, Nested, and so on). See “Statistical Details for Variance Components” on page 236.

**Analysis Settings** Specify the method for computing variance components. See “Analysis Settings” on page 223.

**Specify Alpha** Specify the alpha level used by the platform.

**Y, Response** Specify the measurement column. Specifying more than one Y column produces a separate variability chart for each response.
Standard  Specify a standard or reference column that contains the “true” or known values for the measured part. Including this column enables the Bias and Linearity Study options. These options perform analysis on the differences between the observed measurement and the reference or standard value. See “Bias Report” on page 230 and “Linearity Study” on page 230.

X, Grouping  Specify the classification columns that group the measurements. If the factors form a nested hierarchy, specify the higher terms first. If you are doing a gauge study, specify the operator first and then the part.

Freq  Identifies the data table column whose values assign a frequency to each row. Can be useful when you have summarized data.

Part, Sample ID  Identifies the part or sample that is being measured.

By  Identifies a column that creates a report consisting of separate analyses for each level of the variable.

For more information about the launch window, see the Get Started chapter in the Using JMP book.

The Variability Gauge Chart

The variability chart and the standard deviation chart show patterns of variation. You can use these charts to identify possible groups of variation (within subgroups, between subgroups, over time). If you notice that any of these sources of variation are large, you can then work to reduce the variation for that source.

Follow the instructions in “Example of a Variability Chart” on page 216 to produce the results shown in Figure 9.4.
The charts show the response on the y-axis and a multilevel, categorized x-axis.

In Figure 9.4, the Measurement chart shows the range of measurements for each operator by part. Each measurement appears on the chart. Maximum and minimum bars indicate the range of values for each cell, and a cell means bar indicates the median value for each combination of values. The Std Dev chart plots the standard deviation of the measurements taken on each part by operator.

You can add features to the charts, as illustrated in Figure 9.4. See “Variability Gauge Platform Options” on page 220.

To replace variables in charts, do one of the following:

- Swap existing variables by dragging a variable from one axis label to the other axis label. When you drag a variable over a chart or click on an axis label, the axis labels are highlighted. This indicates where to drop the variable.
- Click on a variable in the Columns panel of the associated data table and drag it onto an axis label.

In other platforms, rows that are excluded in the associated data table still appear on the charts or plots. However, in variability charts, excluded rows do not appear on the charts.
Variability Gauge Platform Options

Use the red triangle options to modify the appearance of the chart, perform Gauge R&R analysis, and compute variance components.

**Note:** Figure 9.4 illustrates some of these options.

**Tip:** To set the default behavior of these options, select File > Preferences > Platforms > Variability Chart.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Charts</td>
<td>Changes the layout to horizontal or vertical.</td>
</tr>
<tr>
<td>Variability Chart</td>
<td>Shows or hides the variability chart.</td>
</tr>
<tr>
<td>Show Points</td>
<td>Shows or hides the points for individual rows.</td>
</tr>
<tr>
<td>Show Range Bars</td>
<td>Shows or hides the bars indicating the minimum and the maximum value of each cell.</td>
</tr>
<tr>
<td>Show Cell Means</td>
<td>Shows or hides the mean mark for each cell.</td>
</tr>
<tr>
<td>Connect Cell Means</td>
<td>Connects or disconnects cell means within a group of cells.</td>
</tr>
<tr>
<td>Show Separators</td>
<td>Shows or hides the separator lines between levels of the X, Grouping variables.</td>
</tr>
<tr>
<td>Show Group Means</td>
<td>(Available only if you have two or more X, Grouping variables or one X, Grouping variable and one Part, Sample ID variable) Shows or hides the mean for groups of cells, represented by a horizontal solid line. A window appears, prompting you to select one of the grouping variables.</td>
</tr>
<tr>
<td>Show Grand Mean</td>
<td>Shows or hides the overall mean, represented by a gray dotted line across the entire graph.</td>
</tr>
<tr>
<td>Show Grand Median</td>
<td>Shows or hides the overall median, represented by a blue dotted line across the entire graph.</td>
</tr>
<tr>
<td>Show Box Plots</td>
<td>Shows or hides box plots.</td>
</tr>
<tr>
<td>Mean Diamonds</td>
<td>Shows or hides mean diamonds. The confidence intervals use the within-group standard deviation for each cell.</td>
</tr>
<tr>
<td>XBar Control Limits</td>
<td>Shows or hides lines at the UCL and LCL on the variability chart.</td>
</tr>
</tbody>
</table>
Points Jittered  Adds some random noise to the plotted points so that coincident points do not plot on top of one another.

Show Standard Mean  (Available only if you have specified a Standard variable) Shows or hides the mean of the standard column.

Variability Summary Report  Shows or hides a report that gives the mean, standard deviation, standard error of the mean, lower and upper confidence intervals, and the minimum, maximum, and number of observations.

Std Dev Chart  Shows or hides a separate graph that shows cell standard deviations across category cells.

Mean of Std Dev  Shows or hides a line at the mean standard deviation on the Std Dev chart.

S Control Limits  Shows or hides lines showing the LCL and UCL in the Std Dev chart.

Group Means of Std Dev  Shows or hides the mean lines on the Std Dev chart.

Heterogeneity of Variance Tests  Performs a test for comparing variances across groups. See “Heterogeneity of Variance Tests” on page 222.

Variance Components  Estimates the variance components for a specific model. Variance components are computed for these models: main effects, crossed, nested, crossed then nested (three factors only), and nested then crossed (three factors only). See “Variance Components” on page 223.

Gauge Studies  Contains the following options:

- Gauge R&R interprets the first factors as grouping columns and the last factor as Part, and creates a gauge R&R report using the estimated variance components. (Note that there is also a Part field in the launch window). See “Gauge R&R Option” on page 226.

- Discrimination Ratio characterizes the relative usefulness of a given measurement for a specific product. It compares the total variance of the measurement with the variance of the measurement error. See “Discrimination Ratio” on page 229.

- Misclassification Probabilities show probabilities for rejecting good parts and accepting bad parts. See “Misclassification Probabilities” on page 229.

- Bias Report shows the average difference between the observed values and the standard. A graph of the average biases and a summary table appears. This option is available only when you specify a Standard variable in the launch window. See “Bias Report” on page 230.

- Linearity Study performs a regression using the standard values as the X variable and the bias as the Y variable. This analysis examines the relationship between bias and the size of the part. Ideally, you want the slope to equal 0. A nonzero slope indicates that
your gauge performs differently with different sized parts. This option is available only when you specify a Standard variable in the launch window. See “Linearity Study” on page 230.

- **Gauge R&R Plots** shows or hides **Mean Plots** (the mean response by each main effect in the model) and **Std Dev** plots. If the model is purely nested, the graphs appear with a nesting structure. If the model is purely crossed, interaction graphs appear. Otherwise, the graphs plot independently at each effect. For the standard deviation plots, the red lines connect $\sqrt{mean\,weighted\,variance}$ for each effect.

- **AIAG Labels** enables you to specify that quality statistics should be labeled in accordance with the AIAG standard, which is used extensively in automotive analyses.

See the JMP Reports chapter in the *Using JMP* book for more information about the following options:

**Local Data Filter**  Shows or hides the local data filter that enables you to filter the data used in a specific report.

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

**Save By-Group Script**  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

### Heterogeneity of Variance Tests

**Note:** See “Example of the Heterogeneity of Variance Test” on page 231.

The **Heterogeneity of Variance Tests** option performs a test for comparing variances across groups. The test is an Analysis of Means for Variances (ANOMV) based method. This method indicates whether any of the group standard deviations are different from the square root of the average group variance.

To be robust against non-normal data, the method uses a permutation simulation to compute decision limits. For complete details about this method, see Wludyka and Sa (2004). Because the method uses simulations, the decision limits can be slightly different each time. To obtain the same results each time, hold down CTRL and SHIFT and select the option, and then specify the same random seed.

The red triangle menus for the test reports contain the following options:
**Set Alpha Level**  Sets the alpha level for the test.

**Show Summary Report**  Shows or hides a summary report for the test. The values in the report are the same values that are shown in the plot.

**Display Options**  Shows or hides the decision limits, shading, center line, and needles.

**Variance Components**

The **Variance Components** option models the variation from measurement to measurement. The response is assumed to be a constant mean plus random effects associated with various levels of the classification.

**Note:** Once you select the **Variance Components** option, if you did not select the **Model Type** in the launch window (if you selected **Decide Later**), you are prompted to select the model type. For more information about model types, see “Launch the Variability/Attribute Gauge Chart Platform” on page 217.

**Figure 9.5** Example of the Variance Components Report

The Analysis of Variance report appears only if the EMS method of variance component estimation is used. This report shows the significance of each effect in the model.

The Variance Components report shows the estimates themselves. See “Statistical Details for Variance Components” on page 236.

**Analysis Settings**

From the launch window, click **Analysis Settings** to choose the method for computing variance components.
Choose best analysis (EMS, REML, or Bayesian) Chooses the best analysis from EMS, REML, or Bayesian, using the following logic:

- If the data are balanced, and if no variance components are negative, the EMS (expected mean squares) method is used to estimate the variance components.
- If the data are unbalanced, the REML (restricted maximum likelihood) method is used, unless a variance component is estimated to be negative, then the Bayesian method is used.
- If any variance component is estimated to be negative using the EMS method, the Bayesian method is used.
- If there is confounding in the variance components, then the bounded REML method is used, and any negative variance component estimates are set to zero.

Choose best analysis (EMS or REML) Chooses the best analysis from EMS or REML, using the same logic as the Choose best analysis (EMS, REML, or Bayesian) option. However, this option never uses the Bayesian method, even for negative variance components. The bounded REML method is used and any negative variance component is forced to be 0.

Use REML analysis Uses the bounded REML method, even if the data are balanced. The bounded REML method can handle unbalanced data and forces any negative variance component to be 0.

Use Bayesian analysis Uses the Bayesian method. The Bayesian method can handle unbalanced data and forces all variances components to be positive and nonzero. If there is confounding in the variance components, then the bounded REML method is used, and any negative variance component estimates are set to zero. The method implemented in JMP computes the posterior means using a modified version of Jeffreys’ prior. For details, see Portnoy (1971) and Sahai (1974).

Maximum Iterations (Applicable only for the REML method) For difficult problems, you might want to increase the number of iterations. Increasing this value means that JMP will try more times to find a solution in the optimization phase.
Convergence Limit  (Applicable only for the REML method) For problems where you want greater precision, you might want to change the convergence limit to be smaller. Decreasing this value means that JMP will find the solution to a higher level of accuracy in the optimization phase. However, this can increase the time taken to find a solution. Providing a larger convergence value returns quicker results, but is less precise.

Number of Iteration Abscissas  (Applicable only for the Bayesian method) For greater accuracy, you might want to increase the number of iteration abscissas. However, this can increase the time taken to find a solution. Providing a smaller number returns quicker results, but is less precise.

Maximum Number of Function Evaluations  (Applicable only for the Bayesian method) For greater accuracy, you might want to increase the maximum number of function evaluations. However, this can increase the time taken to find a solution. Providing a smaller number returns quicker results, but is less precise.

About the Gauge R&R Method

The Gauge R&R method analyzes how much of the variability in your measurement system is due to operator variation (reproducibility) and measurement variation (repeatability). Gauge R&R studies are available for many combinations of crossed and nested models, regardless of whether the model is balanced.

Tip: Alternatively, you can use the EMP method to assess your measurement system. See the “Measurement Systems Analysis” chapter on page 187.

Before performing a Gauge R&R study, you collect a random sample of parts over the entire range of part sizes from your process. Select several operators at random to measure each part several times. The variation is then attributed to the following sources:

- The process variation, from one part to another. This is the ultimate variation that you want to be studying if your measurements are reliable.
- The variability inherent in making multiple measurements, that is, repeatability. In Table 9.1 on page 226, this is called the within variation.
- The variability due to having different operators measure parts—that is, reproducibility.

A Gauge R&R analysis then reports the variation in terms of repeatability and reproducibility.
A Shewhart control chart can identify processes that are going out of control over time. A variability chart can also help identify operators, instruments, or part sources that are systematically different in mean or variance.

### Gauge R&R Option

The **Gauge R&R** option shows measures of variation interpreted for a gauge study of operators and parts.

Once you select the **Gauge R&R** option, if you have not already selected the model type, you are prompted to do so. Then, modify the Gauge R&R specifications.

**Note:** The Platform preferences for Variability include the Gauge R&R Specification Dialog option. The preference is selected by default. Deselect the preference to use the spec limits that are defined in the data table.

### Enter/Verify Gauge R&R Specifications

The Enter/Verify Gauge R&R Specifications window contains these options:
**Choose tolerance entry method**  Choose how to enter the tolerance, as follows:

Select **Tolerance Interval** to enter the tolerance directly, where tolerance = USL – LSL.

Select **LSL and/or USL** to enter the specification limits and then have JMP calculate the tolerance.

**K, Sigma Multiplier**  K is a constant value that you choose to multiply with sigma. For example, you might type 6 so that you are looking at 6\*sigma or a 6 sigma process.

**Tip:** Modify the default value of K by selecting File > Preferences > Platforms > Variability Chart.

**Tolerance Interval, USL-LSL**  Enter the tolerance for the process, which is the difference between the upper specification limits and the lower specification limits.

**Spec Limits**  Enter upper and lower specification limits. For more information, see the Column Info Window chapter in the Using JMP book.

**Historical Mean**  Computes the tolerance range for one-sided specification limits, either USL-Historical Mean or Historical Mean-LSL. If you do not enter a historical mean, the grand mean is used.

**Historical Sigma**  Enter a value that describes the variation (you might have this value from history or past experience).
The Gauge R&R Report

Figure 9.7  Example of the Gauge R&R Report

Note: To generate the reduced Gauge R&R report, select File > Preferences > Platforms > Variability Chart > Reduced Gauge R&R Report.

In this example, the values in the Variation column are the square roots of sums of variance components scaled by the value of $k$ (6 in this example).

Table 9.2 shows guidelines for measurement variation, as suggested by Barrentine (1991).

<table>
<thead>
<tr>
<th>Acceptable Percent Measurement Variation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt; 10%</td>
<td>excellent</td>
</tr>
<tr>
<td>11% to 20%</td>
<td>adequate</td>
</tr>
<tr>
<td>21% to 30%</td>
<td>marginally acceptable</td>
</tr>
<tr>
<td>&gt; 30%</td>
<td>unacceptable</td>
</tr>
</tbody>
</table>

Note the following:
- If you have provided a Tolerance Interval in the Enter/Verify Gauge R&R Specifications window, a % of Tolerance column appears in the Gauge R&R report. This column is computed as $100\times(Variation/Tolerance)$. Also, a Precision-to-Tolerance ratio appears at the
bottom of the report. This ratio represents the proportion of the tolerance or capability interval that is lost due to gauge variability.

- If you have provided a **Historical Sigma** in the Enter/Verify Gauge R&R Specifications window, a % Process column appears in the Gauge R&R report. This column is defined as follows: 100*(Variation/(K*Historical Sigma)).
- The Number of Distinct Categories (NDC) is defined as (1.41*(PV/RR)), rounded down to the nearest integer.

**Discrimination Ratio**

The discrimination ratio characterizes the relative usefulness of a given measurement for a specific product. Generally, when the discrimination ratio is less than 2, the measurement cannot detect product variation, implying that the measurement process needs improvement. A discrimination ratio greater than 4 adequately detects unacceptable product variation, implying that the production process needs improvement.

See “**Statistical Details for the Discrimination Ratio**” on page 237 for more information.

**Misclassification Probabilities**

Due to measurement variation, good parts can be rejected and bad parts can be accepted. This is called misclassification. Once you select the **Misclassification Probabilities** option, if you have not already done so, you are prompted to select the model type and enter specification limits.

**Figure 9.8** Example of the Misclassification Probabilities Report

<table>
<thead>
<tr>
<th>Description</th>
<th>Probability</th>
</tr>
</thead>
<tbody>
<tr>
<td>P(Good part is falsely rejected)</td>
<td>0.0802</td>
</tr>
<tr>
<td>P(Bad part is falsely accepted)</td>
<td>0.2787</td>
</tr>
<tr>
<td>P(Part is good and is rejected)</td>
<td>0.0735</td>
</tr>
<tr>
<td>P(Part is good and is accepted)</td>
<td>0.0235</td>
</tr>
<tr>
<td>P(Part is good)</td>
<td>0.9157</td>
</tr>
</tbody>
</table>

Note the following:

- The first and second values are conditional probabilities.
- The third and fourth values are joint probabilities.
- The fifth value is a marginal probability.
- The first four values are probabilities of errors that decrease as the measurement variation decreases.
Bias Report

The Bias Report shows a graph for Overall Measurement Bias with a summary table and a graph for Measurement Bias by Standard with a summary table. The average bias, or the differences between the observed values and the standard values, appears for each level of the X variable. A t test for the bias is also given.

The Bias Report option is available only when a Standard variable is provided in the launch window.

The Measurement Bias Report contains the following red triangle options:

Confidence Intervals  Calculates confidence intervals for the average bias for each part and places marks on the Measurement Bias Report by Standard plot.

Measurement Error Graphs  Produces a graph of Measurement Error versus all grouping columns together. There are also graphs of Measurement Error by each grouping column separately.

Linearity Study

The Linearity Study performs a regression analysis using the standard variable as the X variable and the bias as the Y variable. This analysis examines the relationship between bias and the size of the part. Ideally, you want to find a slope of zero. If the slope is significantly different from zero, you can conclude that there is a significant relationship between the size of the part or variable measured as a standard and the ability to measure.

The Linearity Study option is available only when a Standard variable is provided in the launch window.

The report shows the following information:

• Bias summary statistics for each standard.
• An ANOVA table that tests if the slope of the line is equal to zero.
• The line parameters, including tests for the slope (linearity) and intercept (bias). The test for the intercept is useful only if the test on the slope fails to reject the hypothesis of slope = 0.
• The equation of the line appears directly beneath the graph.

The Linearity Study report contains the following red triangle options:

Set Alpha Level  Changes the alpha level that is used in the bias confidence intervals.

Linearity by Groups  Produces separate linearity plots for each level of the X, Grouping variables that you specified in the launch window.
Additional Examples of Variability Charts

- “Example of the Heterogeneity of Variance Test”
- “Example of the Bias Report Option”

Example of the Heterogeneity of Variance Test

Suppose that you have data containing part measurements. Three operators (Cindy, George, and Tom) each took measurements of 10 parts. They measured each part three times, making a total of 90 observations. You want to examine the following:

- whether the variance of measurements for each operator are the same or different
- whether the variance for each part is the same or different
- whether the variance for each Operator*part combination is the same or different

Ideally, you want all of the variances for each of the groups to be considered the same statistically.

1. Select Help > Sample Data Library and open Variability Data/2 Factors Crossed.jmp.
2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.
4. Select Operator and click X, Grouping.
5. Select part# and click Part, Sample ID.
6. Click OK.
7. From the red triangle menu, select Heterogeneity of Variance Tests.
8. Select Crossed.
9. Click OK.
**Figure 9.9** Heterogeneity of Variances Tests Report

**Note:** Because the method uses simulations, the decision limits can be slightly different each time.

In the Operator Variance test, all three levels exceed the upper and lower decision limits. From this, you conclude that each operator has a different variability from the square root of the average group variance. You might want to examine why the variation between each operator is different.
For the part# Variance test and the interaction (Operator*part#) Variance test, none of the levels exceed the decision limits. From this, you conclude that the variances are not statistically different from the square root of the average group variance. Each part has a similar variance to the other parts, and each Operator*part# combination has similar variance to the other Operator*part# combinations.

**Example of the Bias Report Option**

**Note:** These data come from the Automotive Industry Action Group (2002).

Assume that as a plant supervisor, you are introducing a new measurement system into your process. As part of the Production Part Approval Process (PPAP), the bias and linearity of the measurement system needs to be evaluated. Five parts were chosen throughout the operating range of the measurement system, based on documented process variation. Each part was measured by layout inspection to determine its reference value. Each part was then measured twelve times by the lead operator. The parts were selected at random during the day. In this example, you want to examine the overall bias and the individual measurement bias (by standard).

1. Select **Help > Sample Data Library** and open Variability Data/MSALinearity.jmp.
2. Select **Analyze > Quality and Process > Variability / Attribute Gauge Chart**.
3. Select **Response** and click **Y, Response**.
4. Select **Standard** and click **Standard**.
5. Select **Part** and click **X, Grouping**.
6. Click **OK**.
7. From the red triangle menu, select **Gauge Studies > Bias Report**.
The bias (Response minus Standard) is calculated for every measurement. The Overall Measurement Bias Report shows a histogram of the bias and a t-test to see whether the average bias is equal to 0. You can see that the Average Bias is not zero, it is -0.0533. However, zero is contained within the confidence interval (-0.1152,0.0085), which means that the Average Bias is not significantly different from 0. Using a significance level of 0.05, you can see that the p-value is greater than 0.05, which also shows that the Average Bias is not significantly different from 0.

The Measurement Bias Report by Standard shows average bias values for each part. The bias averages are plotted on the graph along with the actual bias values for every part, so that you can see the spread. In this example, part number 1 (with a standard value of 2) is biased high and parts 4 and 5 (with standard values of 8 and 10) are biased low.

Tip: To see confidence intervals for the bias, right-click in the table and select Columns > Lower 95% and Upper 95%.
Example of a Linearity Study

Using the same data and scenario as the Bias Report option, you can now examine the linearity to determine whether there is a significant relationship between the size of the parts and the operator’s ability to measure them.

1. Select Help > Sample Data Library and open Variability Data/MSALinearity.jmp.
2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.
5. Select Part and click X, Grouping.
6. Click OK.
7. From the red triangle menu, select Gauge Studies > Linearity Study.
8. In the window that prompts you to Specify Process Variation, type 16.5368.

Figure 9.11 Linearity Study

Note the following:

- The slope is -0.131667. This value appears as part of the equation below the graph, and also in the third table.
- The p-value associated with the test on the slope is quite small, <.0001. The t test for the slope is testing whether the bias changes with the standard value.
Because the $p$-value is small, you can conclude that there is a significant linear relationship between the size of the parts and the operator’s ability to measure them. You can also see this in the graph. If the part or standard value is small, the bias is high, and vice versa.

### Statistical Details for Variability Charts

- “Statistical Details for Variance Components”
- “Statistical Details for the Discrimination Ratio”

#### Statistical Details for Variance Components

The exact model type that you choose depends on how the data was collected. For example, are the operators measuring the same parts (in which case you have a crossed design) or are they measuring different parts (in which case you have a nested design)? To illustrate, in a model where $B$ is nested within $A$, multiple measurements are nested within both $B$ and $A$, and there are $na \cdot nb \cdot nw$ measurements, as follows:

- $na$ random effects are due to $A$
- $na \cdot nb$ random effects due to each $nb$ $B$ levels within $A$
- $na \cdot nb \cdot nw$ random effects due to each $nw$ levels within $B$ within $A$:

$$y_{ijk} = u + Za_i + Zb_{ij} + Zw_{ijk}.$$  

The $Z$s are the random effects for each level of the classification. Each $Z$ is assumed to have a mean of zero and to be independent from all other random terms. The variance of the response $y$ is the sum of the variances due to each $z$ component:

$$\text{Var}(y_{ijk}) = \text{Var}(Za_i) + \text{Var}(Zb_{ij}) + \text{Var}(Zw_{ijk}).$$

Table 9.3 shows the supported models and what the effects in the model would be.

### Table 9.3 Models Supported by the Variability Charts Platform

<table>
<thead>
<tr>
<th>Model</th>
<th>Factors</th>
<th>Effects in the Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main Effects</td>
<td>1</td>
<td>A</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>A, B</td>
</tr>
<tr>
<td></td>
<td>unlimited</td>
<td>and so on, for more factors</td>
</tr>
</tbody>
</table>
The discrimination ratio compares the total variance of the measurement, \( M \), with the variance of the measurement error, \( E \). The discrimination ratio is computed for all main effects, including nested main effects. The discrimination ratio, \( D \), is computed as follows:

\[
D = \sqrt[4]{2\left(\frac{P}{T-P}\right) + 1}
\]

where:

\( P \) = estimated variance for a factor
\( T \) = estimated total variance
Attribute charts analyze categorical measurements and can help show you measures of agreement across responses, such as raters. In *attribute data*, the variable of interest has a finite number of categories. Typically, data has only two possible results, such as pass or fail. You can examine aspects such as how effective raters were at classifying a part, how much they agreed with each other, and how much they agreed with themselves over the course of several ratings.

**Tip:** This chapter covers only attribute charts. For details about variability charts, see the “Variability Gauge Charts” chapter on page 213.

**Figure 10.1** Example of an Attribute Chart
Contents

Overview of Attribute Gauge Charts ................................................................. 241
Example of an Attribute Gauge Chart ............................................................. 241
Launch the Variability/Attribute Gauge Chart Platform ................................. 242
The Attribute Gauge Chart and Reports .......................................................... 244
  Agreement Reports ......................................................................................... 245
  Effectiveness Report ..................................................................................... 246
Attribute Gauge Platform Options ................................................................. 248
Statistical Details for Attribute Gauge Charts ............................................... 249
  Statistical Details for the Agreement Report ................................................. 251
Overview of Attribute Gauge Charts

Before you create an attribute gauge chart, your data should be formatted using the following guidelines:

- In order to compare agreement among raters, each rater in the data table must be in a separate column. These columns are then assigned to the **Y, Response** role in the launch window. In Figure 10.2, each rater (A, B, and C) is in a separate column.
- Responses in the different columns can be character (pass or fail) or numeric (0 or 1). In Figure 10.2, rater responses are numeric (0 for pass, 1 for fail). All response columns must have the same data type.
- Any other variables of interest that you might want to use as **X, Grouping** variables should appear stacked in one column each (see the Part column in Figure 10.2). You can also define a Standard column, which produces reports that compare raters with the standard. The Standard column and response columns must have the same data type.

**Figure 10.2** Attribute Gauge Data

Example of an Attribute Gauge Chart

Suppose that you have data containing pass or fail ratings for parts. Three raters, identified as A, B, and C, each noted a 0 (pass) or a 1 (fail) for 50 parts, three times each. You want to examine how effective the raters were in correctly classifying the parts, and how well the raters agreed with each other and with themselves over the course of the ratings.

1. Select **Help > Sample Data Library** and open **Attribute Gauge.jmp**.
2. Select **Analyze > Quality and Process > Variability / Attribute Gauge Chart**.
3. For **Chart Type**, select **Attribute**.
4. Select A, B, and C and click **Y, Response**.
5. Select Standard and click **Standard**.

7. Click OK.

**Figure 10.3** Example of an Attribute Chart

The first chart (Part) shows how well the raters agreed with each other for each part. For example, here you can see that the percent agreement dropped for part 6, 12, 14, 21, 22, and so on. These parts might have been more difficult to categorize.

The second chart (Rater) shows each rater’s agreement with him or herself and the other raters for a given part, summed up over all of the parts. In this example, it looks like the performance of the raters is relatively similar. Rater C had the lowest agreement, but the difference is not major (about 89% instead of 91%).

---

**Launch the Variability/Attribute Gauge Chart Platform**

Launch the Variability/Attribute Gauge Chart platform by selecting **Analyze > Quality and Process > Variability/Attribute Gauge Chart**. Set the **Chart Type** to **Attribute**.
Chapter 10
Quality and Process Methods

Attribute Gauge Charts

Launch the Variability/Attribute Gauge Chart Platform

Figure 10.4 The Variability/Attribute Gauge Chart Launch Window

Chart Type  Choose between a variability gauge analysis (for a continuous response) or an attribute gauge analysis (for a categorical response, usually “pass” or “fail”).

Note: The content in this chapter covers only the Attribute chart type. For details about the Variability chart type, see “Variability Gauge Charts” chapter on page 213.

Specify Alpha  Specify the alpha level used by the platform.

Y, Response  Specify the columns of ratings given by each rater. You must specify more than one rating column.

Standard  Specify a standard or reference column that contains the “true” or known values for the part. In the report window, an Effectiveness Report and an additional section in the Agreement Comparisons report appear, which compare the raters with the standard.

X, Grouping  Specify the classification columns that group the measurements. If the factors form a nested hierarchy, specify the higher terms first.

Freq  Identifies the data table column whose values assign a frequency to each row. Can be useful when you have summarized data.

By  Identifies a column that creates a report consisting of separate analyses for each level of the variable.

For more information about the launch window, see the Get Started chapter in the Using JMP book.
The Attribute Gauge Chart and Reports

Attribute gauge chart plots the percent Agreement, which is a measurement of rater agreement for every part in the study. The agreement for each part is calculated by comparing the ratings for every pair of raters for all ratings of that part. See “Statistical Details for Attribute Gauge Charts” on page 249.

Follow the instructions in “Example of an Attribute Gauge Chart” on page 241 to produce the results shown in Figure 10.5.

Figure 10.5  Attribute Gauge Chart

The first chart in Figure 10.5 uses all X grouping variables (in this case, the Part) on the x-axis. The second chart uses all Y variables on the x-axis (typically, and in this case, the Rater).

- In the first graph, you can look for parts with a low percent Agreement value, and investigate to determine why raters do not agree about the measurement of that particular part.
- In the second graph, you can look for raters with a low percent Agreement value, and investigate to determine why they do not agree with the other raters or with themselves.

For information about additional options, see “Attribute Gauge Platform Options” on page 248.
Agreement Reports

**Note:** The Kappa value is a statistic that expresses agreement. The closer the Kappa value is to 1, the more agreement there is. A Kappa value closer to 0 indicates less agreement.

The Agreement Report shows agreement summarized for each rater and overall agreement. This report is a numeric form of the data presented in the second chart in the Attribute Gauge Chart report. See Figure 10.5.

The Agreement Comparisons report shows each rater compared with all other raters, using Kappa statistics. The rater is compared with the standard only if you have specified a Standard variable in the launch window.

The Agreement within Raters report shows the number of items that were inspected. The confidence intervals are score confidence intervals, as suggested by Agresti and Coull (1998). The Number Matched is the sum of the number of items inspected, where the rater agreed with him or herself on each inspection of an individual item. The Rater Score is the Number Matched divided by the Number Inspected.

The Agreement across Categories report shows the agreement in classification over that which would be expected by chance. It assesses the agreement between a fixed number of raters when classifying items.
Effectiveness Report

The Effectiveness Report appears only if you have specified a Standard variable in the launch window. For a description of a Standard variable, see “Launch the Variability/Attribute Gauge Chart Platform” on page 242. This report compares every rater with the standard.
The Agreement Counts table shows cell counts on the number correct and incorrect for every level of the standard. In Figure 10.7, the standard variable has two levels, 0 and 1. Rater A had 45 correct responses and 3 incorrect responses for level 0, and 97 correct responses and 5 incorrect responses for level 1.

Effectiveness is defined as follows: the number of correct decisions divided by the total number of opportunities for a decision. For example, say that rater A sampled every part three times. On the sixth part, one of the decisions did not agree (for example, pass, pass, fail). The other two decisions would still be counted as correct decisions. This definition of effectiveness is different from the MSA 3rd edition. According to MSA, all three opportunities for rater A on part six would be counted as incorrect. Including all of the inspections separately gives you more information about the overall inspection process.

In the Effectiveness table, 95% confidence intervals are given about the effectiveness. These are score confidence intervals. It has been demonstrated that score confidence intervals provide increased coverage probability, particularly where observations lie near the boundaries. See Agresti and Coull (1998).

The Misclassifications table shows the incorrect labeling. The rows represent the levels of the standard or accepted reference value. The columns contain the levels given by the raters.
Conformance Report

The Conformance Report shows the probability of false alarms and the probability of misses. The Conformance Report appears only when the rating has two levels (such as pass or fail, or 0 or 1).

The following descriptions apply:

**False Alarm**  The part is determined to be non-conforming, when it actually is conforming.

**Miss**  The part is determined to be conforming, when it actually is not conforming.

\[ P(\text{False Alarms}) \]  The number of parts that have been incorrectly judged to be nonconforming divided by the total number of parts that are judged to be conforming.

\[ P(\text{Miss}) \]  The number of parts that have been incorrectly judged to be conforming divided by the total number of parts that are actually nonconforming.

The Conformance Report red triangle menu contains the following options:

**Change Conforming Category**  Reverses the response category that is considered conforming.

**Calculate Escape Rate**  Calculates the Escape Rate, which is the probability that a non-conforming part is produced and not detected. The Escape Rate is calculated as the probability that the process will produce a non-conforming part times the probability of a miss. You specify the probability that the process will produce a non-conforming part, also called the Probability of Nonconformance.

*Note:* Missing values are treated as a separate category in this platform. To avoid this separate category, exclude rows of missing values in the data table.

---

**Attribute Gauge Platform Options**

The Attribute Gauge red triangle menu contains the following options:

**Attribute Gauge Chart**  Shows or hides the gauge attribute chart and the efficiency chart.

**Show Agreement Points**  Shows or hides the agreement points on the charts.

**Connect Agreement Points**  Connects the agreement points in the charts.

**Agreement by Rater Confid Intervals**  Shows or hides the agreement by rater confidence intervals on the efficiency chart.
Show Agreement Group Means  Shows or hides the agreement group means on the gauge attribute chart. This option is available when you specify more than one X, Grouping variable.

Show Agreement Grand Mean  Shows or hides the overall agreement mean on the gauge attribute chart.

Show Effectiveness Points  Shows or hides the effectiveness points on the charts.

Connect Effectiveness Points  Draws lines between the effectiveness points in the charts.

Effectiveness by Rater Confid Intervals  Shows or hides confidence intervals on the second chart in the Attribute Gauge Chart report. See Figure 10.5.

Effectiveness Report  Shows or hides the Effectiveness report. This report compares every rater with the standard, using the Kappa statistic.

See the JMP Reports chapter in the Using JMP book for more information about the following options:

Local Data Filter  Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Statistical Details for Attribute Gauge Charts

For the first chart in Figure 10.5 that plots all X, Grouping variables on the x-axis, the percent Agreement is calculated as follows:

\[
\text{% Agreement for part } i = \frac{\sum_{l=1}^{k} \binom{\text{number of responses for level } l}{2}}{\left(\binom{N_i}{2}\right)}
\]
For the second chart in Figure 10.5 that plots all Y, Response variables on the x-axis, the percent Agreement is calculated as follows:

\[
\text{% Agreement for rater } k = \frac{\sum_{i=1}^{n} \left( \sum_{j=1}^{r_i} \text{number of uncounted matching levels for this rater } k \text{ within part } i \text{ for rep } j \right)}{\sum_{i=1}^{n} \left( \sum_{j=1}^{N_i} N_i - j \right)}
\]

Note the following:

- \( n \) = number of parts (grouping variables)
- \( r_i \) = number of reps for part \( i \) (\( i = 1, \ldots, n \))
- \( m \) = number of raters
- \( k \) = number of levels
- \( N_i = m \times r_i \). Number of ratings on part \( i \) (\( i = 1, \ldots, n \)). This includes responses for all raters, and repeat ratings on a part. For example, if part \( i \) is measured 3 times by each of 3 raters, then \( N_i \) is \( 3 \times 3 = 9 \).

For example, consider the following table of data for three raters, each having three replicates for one part.

**Table 10.1** Three Replicates for Raters A, B, and C

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Using this table, you can make these calculations:

\[
\text{% Agreement} = \frac{4}{9} + \frac{5}{9} = \frac{16}{36} = 0.444
\]

\[
\text{% Agreement [rater A]} = \text{percent Agreement [rater B]} = \frac{4+3+3}{8+7+6} = \frac{10}{21} = 0.476 \text{ and }
\]

\[
\text{% Agreement [rater C]} = \frac{4+3+2}{8+7+6} = \frac{9}{21} = 0.4286
\]
Statistical Details for the Agreement Report

The simple Kappa coefficient is a measure of inter-rater agreement.

\[ \hat{\kappa} = \frac{P_0 - P_e}{1 - P_e} \]

where:

\[ P_0 = \sum_i p_{ii} \]

and:

\[ P_e = \sum_i p_i p_{.i} \]

If you view the two response variables as two independent ratings of the \( n \) parts, the Kappa coefficient equals +1 when there is complete agreement of the raters. When the observed agreement exceeds chance agreement, the Kappa coefficient is positive, and its magnitude reflects the strength of agreement. Although unusual in practice, Kappa is negative when the observed agreement is less than the chance agreement. The minimum value of Kappa is between -1 and 0, depending on the marginal proportions.

Estimate the asymptotic variance of the simple Kappa coefficient with the following equation:

\[ \text{var} = \frac{A + B - C}{(1 - P_e)^2 n} \]

where:

\[ A = \sum_i p_{ii} \left[ 1 - (p_{i.} + p_{.i})(1 - \hat{\kappa}) \right] \]

\[ B = (1 - \hat{\kappa})^2 \sum_i \sum_{i \neq j} p_{ij} (p_{i.} + p_{.j})^2 \]

and:

\[ C = \left[ \hat{\kappa} - P_e (1 - \hat{\kappa}) \right]^2 \]

The Kappas are plotted and the standard errors are also given.

**Note:** The Kappa statistics in the Attribute Chart platform are shown even when the levels of the variables are unbalanced.
Categorical Kappa statistics (Fleiss 1981) are found in the Agreement Across Categories report.

Given the following assumptions:

- \( n \) = number of parts (grouping variables)
- \( m \) = number of raters
- \( k \) = number of levels
- \( r_i \) = number of reps for part \( i \) (\( i = 1, \ldots, n \))
- \( N_i = m \times r_i \). Number of ratings on part \( i \) (\( i = 1, 2, \ldots, n \)). This includes responses for all raters, and repeat ratings on a part. For example, if part \( i \) is measured 3 times by each of 2 raters, then \( N_i \) is 3 \times 2 = 6.
- \( x_{ij} \) = number of ratings on part \( i \) (\( i = 1, 2, \ldots, n \)) into level \( j \) (\( j = 1, 2, \ldots, k \))

The individual category Kappa is as follows:

\[
\hat{\kappa}_j = 1 - \frac{\sum_{i=1}^{n} x_{ij}(N_i - x_{ij})}{(\bar{p}_j \bar{q}_j) \sum_{i=1}^{n} N_i(N_i - 1)}
\]

where

\[
\bar{p}_j = \frac{\sum_{i=1}^{n} x_{ij}}{n} \quad \bar{q}_j = 1 - \bar{p}_j
\]

The overall Kappa is as follows:

\[
\hat{\kappa} = \frac{\sum_{j=1}^{k} \bar{q}_j \bar{p}_j \hat{\kappa}_j}{\sum_{j=1}^{k} \bar{p}_j \bar{q}_j}
\]

The variance of \( \hat{\kappa}_j \) and \( \hat{\kappa} \) are as follows:

\[
\text{var}(\hat{\kappa}_j) = \frac{2}{nN(N-1)}
\]

\[
\text{var}(\hat{\kappa}) = \left( \sum_{j=1}^{k} \bar{p}_j \bar{q}_j \left( \frac{2}{nN(N-1)} \right)^2 \right)^2 \times \left[ \sum_{j=1}^{k} \bar{p}_j \bar{q}_j \left( \frac{2}{nN(N-1)} \right)^2 \right] - \left[ \sum_{j=1}^{k} \bar{p}_j \bar{q}_j \left( \bar{q}_j - \bar{p}_j \right) \right]
\]

The standard errors of \( \hat{\kappa}_j \) and \( \hat{\kappa} \) are shown only when there are an equal number of ratings per part (for example, \( N_i = N \) for all \( i = 1, \ldots, n \)).
Process capability analysis, used in process control, measures how well a process is performing compared to given specification limits. A good process is one that is stable and consistently produces product that is well within specification limits. A capability index is a measure that relates process performance, summarized by process centering and variability, to specification limits.

Graphical tools such as a goal plot and box plots give you quick visual ways of identifying which process or product characteristics are within specifications. Individual detail reports display a capability report for each variable in the analysis. The analysis enables you to identify variation relative to the specifications or requirements; this enables you to achieve increasingly higher conformance values.

You can specify subgroups to compare the overall variation of the process to the within subgroup variation. You can compute capability indices for processes that produce measurements that follow various distributions. For data that follow none of the specified distributions, you can compute nonparametric capability indices.

**Figure 11.1** Example of the Process Capability Platform
Contents

Overview of the Process Capability Platform ........................................... 255
Example of the Process Capability Platform with Normal Variables .......... 257
Example of the Process Capability Platform with Nonnormal Variables ..... 259
Launch the Process Capability Platform .................................................. 264
  Process Selection ................................................................................. 266
  Process Subgrouping .......................................................................... 266
  Historical Information ......................................................................... 267
  Distribution Options ........................................................................... 267
  Other Specifications ............................................................................. 269
Entering Specification Limits ................................................................. 269
  Spec Limits Window ............................................................................ 269
  Limits Data Table ................................................................................. 270
  Spec Limits Column Property .............................................................. 271
The Process Capability Report ............................................................... 272
  Goal Plot ............................................................................................... 273
  Capability Box Plots ............................................................................ 276
  Capability Index Plot .......................................................................... 278
Process Capability Platform Options ....................................................... 280
  Individual Detail Reports ...................................................................... 283
  Normalized Box Plots ......................................................................... 290
  Process Performance Plot ................................................................... 291
  Summary Reports ................................................................................ 292
  Make Goal Plot Summary Table .......................................................... 293
Additional Examples of the Process Capability Platform ....................... 294
  Process Capability for a Stable Process .............................................. 294
  Process Capability for an Unstable Process ......................................... 298
Simulation of Confidence Limits for a Nonnormal Process Ppk ............. 302
Statistical Details for the Process Capability Platform ............................ 308
  Variation Statistics ................................................................................ 308
  Notation for Goal Plots and Capability Box Plots ............................... 311
  Goal Plot ............................................................................................... 311
  Capability Box Plots for Processes with Missing Targets .................. 313
  Capability Indices for Normal Distributions ....................................... 314
  Capability Indices for Nonnormal Distributions: Percentile and Z-Score Methods ......................................................... 317
  Parameterizations for Distributions ..................................................... 319
Overview of the Process Capability Platform

The Process Capability platform provides the tools needed to measure the compliance of a process to given specifications. By default, JMP shows a Goal Plot, Capability Box Plots, and a Capability Index Plot for the variables that you fit with normal distributions. Capability indices for nonnormal variables are plotted on the Capability Index Plot. You can add normalized box plots, summary reports, and individual detail reports for the variables in your analysis.

You can supply specification limits in several ways:

- in the data table, using a column property
- by requesting the Spec Limits Dialog in the launch window
- by loading the limits from a specification limits data table
- using the Manage Spec Limits utility (Analyze > Quality and Process > Manage Spec Limits)

You can specify two-sided, one-sided, or asymmetric specification limits.

**Note:** The Process Capability platform expands significantly on the Capability analyses that are available through Analyze > Distribution and through Analyze > Quality and Process > Control Chart.

### Capability Indices

A capability index is a ratio that relates the ability of a process to produce product that meets specification limits. The index relates estimates of the mean and standard deviation of the quality characteristic to the specification limits. Within estimates of capability are based on an estimate of the standard deviation constructed from within-subgroup variation. Overall estimates of capability use an estimate of standard deviation constructed from all of the process data. See “Capability Indices for Normal Distributions” on page 314 and “Variation Statistics” on page 308.

Estimates of the mean or standard deviation are well-defined only if the processes related to centering or spread are *stable*. Therefore, interpretation of within capability indices requires that process spread is stable. Interpretation of overall capability indices requires that both process centering and spread are stable.

Capability indices constructed from small samples can be highly variable. The Process Capability platform provides confidence intervals for most capability indices. Use these to determine the range of potential values for your quality characteristic’s actual capability.
Note: When confidence intervals are not provided (for example, for nonnormal distributions) you can use the Simulate feature to construct confidence intervals. For an example, see “Simulation of Confidence Limits for a Nonnormal Process Ppk” on page 302.

Guidelines for values of capability indices can be found in Montgomery (2013). The minimum recommended value is 1.33. Six Sigma initiatives aim for much higher capability levels that correspond to extremely low rates of defective parts per million.

**Capability Indices for Nonnormal Processes**

The Process Capability platform constructs capability indices for process measurements with the following distributions: Normal, Beta, Exponential, Gamma, Johnson, Lognormal, and Weibull. A Best Fit option determines the best fit among these distributions and provides capability indices for this fit. The platform also provides a Nonparametric fit option that gives nonparametric estimates of capability.

For the nonnormal methods, estimates are constructed using two approaches: the ISO/Quantile method (Percentiles) and the Bothe/Z-scores method (Z-Score). For details about these methods, see “Capability Indices for Nonnormal Distributions: Percentile and Z-Score Methods” on page 317.

Note: Process Capability analysis for individual responses is accessible through Analyze > Quality and Process > Control Chart Builder. However, nonnormal distributions are available only in the Process Capability platform.

**Overall and Within Estimates of Sigma**

Most capability indices in the Process Capability platform can be computed based on estimates of the overall (long-term) variation and the within-subgroup (short-term) variation. If the process is stable, these two measures of variation should yield similar results since the overall and within subgroup variation should be similar. The normalized box plots and summary tables can be calculated using either the overall or the within-subgroup variation. See “Additional Examples of the Process Capability Platform” on page 294 for examples of capability indices computed for stable and unstable processes.

You can specify subgroups for estimating within-subgroup variation in the launch window. You can specify a column that defines subgroups or you can select a constant subgroup size. For each of these methods, you can choose to estimate the process variation using the average of the unbiased standard deviations or using the average of the ranges. If you do not specify subgroups, the Process Capability platform constructs a within-subgroup estimate of the process variation using a moving range of subgroups of size two. Finally, you can specify a historical sigma to be used as an estimate of the process standard deviation.
Chapter 11
Quality and Process Methods

Example of the Process Capability Platform with Normal Variables

Capability Index Notation

The Process Capability platform provides two sets of capability indices. See “Capability Indices for Normal Distributions” on page 314 for details about the calculation of the capability indices.

- Cpk, Cpl, Cpu, Cp, and Cpm. These indices are based on a within-subgroup (short-term) estimate of the process standard deviation.
- Ppk, Ppl, Ppu, Pp, and Cpm. These indices are based on an overall (long-term) estimate of the process standard deviation. Note that the process standard deviation does not exist if the process is not stable. See Montgomery (2013).

The Process Capability platform uses the appropriate AIAG notation for capability indices: Ppk labeling denotes an index constructed from an overall variation estimate and Cpk denotes an index constructed from a within-subgroup variation estimate.

Note: The AIAG (Ppk) Labeling platform preference is selected by default. You can change the reporting to use Cp notation only by deselecting this preference under Process Capability.

For more information about process capability analysis, see Montgomery (2013) and Wheeler (2004).

Example of the Process Capability Platform with Normal Variables

This example uses the Semiconductor Capability.jmp sample data table. The variables represent standard measurements that a semiconductor manufacturer might make on a wafer as it is being processed. Specification limits for the variables have been entered in the data table through the Column Properties > Spec Limits property.

1. Select Help > Sample Data Library and open Semiconductor Capability.jmp.
3. Click the white triangle next to Processes to view all of the continuous variables.
4. Select PNP1, PNP2, NPN2, PNP3, IVP1, PNP4, NPN3, and IVP2, and click Y, Process.
5. Click OK.
6. Select Label Overall Sigma Points from the Goal Plot red triangle menu.
7. Select Label Overall Sigma Points from the Capability Index Plot red triangle menu.
The Goal Plot in Figure 11.2 shows the spec-normalized mean shift on the x-axis and the spec-normalized standard deviation on the y-axis for each variable. The triangular region defined by the red lines in the bottom center of the plot is the goal triangle. It defines a region of capability index values. You can adjust the goal triangle using the Ppk slider below the plot. When the slider is set to 1, note that PNP1, PNP3, IVP1, and IVP2 are outside of the goal triangle and possibly out of specification.

The Capability Box Plots report shows a box plot for each variable in the analysis. The values for each column are centered by their target value and scaled by the specification range. In this example, all process variables have both upper and lower specification limits, and these are
symmetric about the target value. It follows that the solid green line shows where the target should be and the dashed lines represent the specification limits.

It appears that the majority of points for IVP1 are above its upper specification limit (USL), and the majority of points for IVP2 are less than its target. PNP2 seems to be on target with all data values inside the specification limits.

The Capability Index Plot plots the Ppk values for each variable. Four variables come from very capable processes, with Ppk values of 2 or more. Four variables have Ppk values below 1.

---

**Example of the Process Capability Platform with Nonnormal Variables**

The Process Measurements.jmp data table contains measurements made on seven different processes used to construct a product. For each process, specification limits are saved as column properties. You begin by examining the distributions of your process data. You see that the distributions are not normal. Then you use the nonnormal capability features of the Process Capability platform to compute capability indices.

**View the Distributions**

1. Select **Help > Sample Data Library** and open Process Measurements.jmp.
2. Select **Analyze > Distribution**.
3. Select all seven columns from the **Select Columns** list and click **Y, Columns**.
4. Check the box next to **Histograms Only**.
5. Click **OK**.

For most processes, the histograms show evidence that the theoretical distribution of measurements is skewed and does not follow a normal distribution. Therefore, for each process, you find the best fitting distributions among all of the available parametric distributions.

**Perform a Capability Analysis**

1. Select **Analyze > Quality and Process > Process Capability**.
2. Select all seven columns from the **Columns** list and click **Y, Process**.
3. Select all seven columns in the **Y, Process** list.
4. Open the **Distribution Options** panel and select **Best Fit** from the **Distribution** list.
5. Click **Set Process Distribution**.

The suffix &Dist(Best Fit) is added to each variable name in the Y, Process list. The Best Fit option specifies that the best-fitting parametric distribution should be fit to each variable.
The available parametric distributions are normal, beta, exponential, gamma, Johnson, lognormal, and Weibull. See Figure 11.3.

6. Open the **Nonnormal Distribution Options** outline. Note that the Nonnormal Capability Indices Method is set to **Percentiles**, the Johnson Distribution Fitting Method is set to **Quantile Matching**, and the Distribution Comparison Criterion is set to **AICc**.

**Figure 11.3** Completed Launch Window

The Quantile Matching method is the default method used for fitting Johnson distributions because of its stability and speed as compared to Maximum Likelihood. Note that Maximum Likelihood is used in the Distribution platform.

7. Click **OK**.

8. Select **Label Overall Sigma Points** from the **Goal Plot** red triangle menu.

9. Select **Label Overall Sigma Points** from the Capability Index Plot red triangle menu.
Figure 11.4 Initial Report with Variables Labeled

Note: Click on a label in the plot and drag it to make the plot more interpretable. Click on the right side frame of the Capability Index Plot and drag it to the right to make the labels easier to distinguish.
The Goal Plot shows only one point and it corresponds to Process 7. The Capability Box Plots report shows a single box plot for Process 7. This is because the best fit for Process 7 is a normal distribution.

10. Beneath the Capability Index Plot, set the Ppk value to 2.

   The Capability Index Plot shows Ppk values for all seven processes. Only two processes, Process 2 and Process 7, have capability values that exceed 2. Note that the best fitting nonnormal distributions are shown in parentheses to the right of the variable names in the Capability Index Plot. The best fitting distribution for Process 7 is not shown because it is a normal distribution.

11. Select Individual Detail Reports from the Process Capability red triangle menu.

   Because you requested Best Fit in the launch window, the Compare Distributions option has been selected from each distribution’s red triangle menu.

The title of the report for Process 4 indicates that the capability calculations are based on a lognormal fit. All of the check boxes in the Compare Distributions report, except the boxes for Nonparametric and Beta, are checked, indicating that these six distributions are fit. (This is because you requested a Best Fit in the launch window.) The button that is selected
in the Selected column indicates that the Lognormal distribution is the distribution that is used in the remainder of the Process 4(Lognormal) Capability report to estimate capability and nonconformance.

The Compare Distributions report enables you to compare the five distributional fits. The Histogram - Compare Distributions report gives a visual assessment of the fit and the Comparison Details report shows fit statistics for the selected distributions. Both the plot and the fit statistics indicate that the lognormal distribution gives the best fit among the selected distributions.

The Individual Detail Report information that is shown by default includes a histogram showing the estimated best-fit distribution, a summary of the process information, capability indices based on an overall estimate of sigma, parameter estimates for the fitted lognormal distribution, and observed and expected nonconformance levels.

Launch the Process Capability Platform

Launch the Process Capability Platform by selecting Analyze > Quality and Process > Process Capability. In Figure 11.6, which uses the Semiconductor Capability jmp data table, all outlines and panels have been opened.
The Process Capability launch window contains the following outlines and options:

- “Process Selection” on page 266
- “Process Subgrouping” on page 266
- “Historical Information” on page 267
- “Distribution Options” on page 267
- “Other Specifications” on page 269

After you click OK in the launch window, the Spec Limits window appears unless one of the following occurs:

- All of the columns contain specification limits.
- You selected No (skip columns with no spec limits) on the launch window.

The Spec Limits window also appears if you select Yes on the launch window. Otherwise, the Process Capability report window appears.
Process Selection

Select the process variables to include in the capability analysis.

**Y, Process** Assigns the variables that you want to analyze.

**Notes:**
- The Transform menu is not available for the Select Column list in the Process Capability launch window. Right-click a column heading in the data table and select New Formula Column to create a transform column for use in Process Capability. See the Enter and Edit Data chapter in the *Using JMP* book for more information about creating new formula columns.
- Reference columns for virtually joined tables are not available in the Process Capability platform.

Process Subgrouping

This group of options enables you to assign each variable in the Y, Process list a subgroup ID column or a constant subgroup size.

**Create Subgroups Using an ID Column**

1. Select a variable or variables in the Y, Process list.
2. Select Subgroup ID Column from the Subgroup with options.
3. Select a subgroup ID column in the Select Columns list.
4. Click Nest Subgroup ID Column.

The subgroup ID column appears in brackets to the right of the variable names in the Y, Process list.

**Create Subgroups Using a Constant Subgroup Size**

1. Select a variable or variables in the Y, Process list.
2. Select Constant Subgroup Size from the Subgroup with options.
3. Enter the subgroup size next to Set Constant Subgroup Size.
4. Click Subgroup by Size.

The subgroup size appears in brackets to the right of the variable names in the Y, Process list.

**Nest Subgroup ID Column** Available when you select Subgroup ID Column. Assigns a column that you select from the Select Columns list to define the subgroups for the selected Y, Process columns.
Subgroup by Size  Available when you select Constant Subgroup Size. Assigns the subgroup size that you specify in the Set Constant Subgroup Size box to define the subgroups for the selected Y, Process columns.

Set Constant Subgroup Size  Available when you select Constant Subgroup Size. Specify the constant subgroup size for the selected Y, Process columns. You need to assign this value using Subgroup by Size.

Within-Subgroup Variation Statistic  Available when Process Subgrouping is used. Specifies if the within-subgroup estimate of standard deviation is calculated using standard deviations or ranges.

Calculate Between-and-Within Capability  Available when Process Subgrouping is used. Specifies that the between-and-within subgroup estimate of the standard deviation should be used in the capability analysis.

Historical Information

Use this outline to assign historically accepted values of the standard deviation to variables in the Y, Process list.

1. Select a variable or variables in the Y, Process list.
2. Enter a value next to Set Historical Sigma.
3. Select Use Historical Sigma to assign that value to the selected variables.

The specified value appears in parentheses in the expression “&Sigma()” to the right of the variable names in the Y, Process list.

Note: If you set a historical sigma, then subgroup assignments for the selected process variable are no longer relevant and are removed.

Distribution Options

Unless otherwise specified, all Y, Process variables are analyzed using the assumption that they follow a normal distribution. Use the Distribution Options outline to assign other distributions or calculation methods to variables in the Y, Process list and to specify options related to nonnormal calculations.

- The available distributions are the Normal, Beta, Exponential, Gamma, Johnson, Lognormal, Mixture of 2 Normals, Mixture of 3 Normals, and Weibull distributions. Except for Johnson distributions, maximum likelihood estimation is used to fit distributions. See “Johnson Distribution Fit Method” on page 268.
• The Best Fit option determines the best fit among the available distributions and applies this fit.
• The Nonparametric option fits a distribution using kernel density estimation.

For more options related to nonnormal fits, see “Nonnormal Distribution Options” on page 268.

Specify a Distribution
1. Select a variable or variables in the Y, Process list.
2. Select a distribution from the Distribution list.
3. Select Set Process Distribution to assign that distribution to the selected variables.

The specified distribution appears in parentheses in the expression “&Dist()” to the right of the variable names in the Y, Process list.

Note: If you select a distribution other than Normal, you cannot assign a Subgroup ID column or a Historical Sigma. These selections are not supported by the methods used to calculate nonnormal capability indices. See “Capability Indices for Nonnormal Distributions: Percentile and Z-Score Methods” on page 317.

Nonnormal Distribution Options

Nonnormal Capability Indices Method Specifies the method used to compute capability indices for nonnormal distributions. See “Capability Indices for Nonnormal Distributions: Percentile and Z-Score Methods” on page 317.

Johnson Distribution Fit Method Specifies the method used to find the best-fitting Johnson distribution. Before estimating the parameters, the best-fitting family of distributions is determined from among the Johnson Su, Sb, and Sl families. The procedure described in Slifker and Shapiro (1980) is used to find the best-fitting family.

Quantile Matching The default method. It is more stable and faster than Maximum Likelihood. Quantile Matching Parameter estimates, assuming the best-fitting family, are obtained using a quantile-matching approach. See Slifker and Shapiro (1980).

Maximum Likelihood Parameters for the best-fitting family are determined using maximum likelihood.

Distribution Comparison Criterion (Available when a Best Fit Distribution is selected.) Specify the criterion that you want to use in determining a Best Fit. This criterion also determines the ordering of distributions in the Comparison Details report. See “Order by Comparison Criterion” on page 290.
Other Specifications

**By**  Produces a separate report for each level of the By variable. If more than one By variable is assigned, a separate report is produced for each possible combination of the levels of the By variables.

**Specify Alpha Level**  Specifies the significance level for confidence limits.

**Show Spec Limits Dialog**  Specifies how to handle columns that do not have specification limits.

**Note:** It is good practice to ensure that specification limits for all process variables are specified as Spec Limits column properties or to load specification limits from a Limits Data table (see “Limits Data Table” on page 270). Otherwise, you can specify limits interactively in the Spec Limits window that appears after you click OK in the launch window (unless you select **No (skip columns with no spec limits)** on the launch window).

## Entering Specification Limits

The lower specification limit (LSL), upper specification limit (USL), and target define the lower bound, upper bound, and target value for a quality process.

There are several ways to enter specification limits:

- Enter limits in the Spec Limits window after selecting columns in the launch window. See “Spec Limits Window” on page 269.
- Import limits from a JMP data table (known as a Limits Table). See “Limits Data Table” on page 270.
- Enter limits as Spec Limits column properties in the data table. See “Spec Limits Column Property” on page 271.
- If you are creating a Process Capability report by running a JSL script, enter limits in the script. See “The Process Capability Report” on page 272.

Only one specification limit is required for a selected column. If only the USL is specified, the box plots and Goal Plot point are colored blue. If only the LSL is specified, the box plots and Goal Plot point are colored red.

### Spec Limits Window

After you click OK on the launch window, the Spec Limits window appears if any of the columns do not contain limits and you did not select **No (skip columns with no spec limits)** on
the launch window. The Spec Limits window also appears if you select Yes on the launch window. Figure 11.7 shows the Spec Limits window for the Cities.jmp sample data table after selecting OZONE, CO, SO2, and NO as process variables in the launch window. Enter the known specification limits and click OK to view the Process Capability report.

**Figure 11.7 Spec Limits Window for Cities.jmp**

![Spec Limits Window for Cities.jmp](image)

**Limits Data Table**

You can also specify a limits data table with the Load spec limits from data table option from the Spec Limits window. Click the Select Data Table button and then select the appropriate data table that contains the specification limits for the analysis. After you select the appropriate limits table, the values populate the window. Click OK to view the Process Capability report.

A limits data table can be in two different formats: tall or wide. A tall limits data table has one column for the responses and the limits key words are the other columns. A wide limits data table has a column for each response with one column to label the limits keys. Either of these formats can be read using the Load spec limits from data table option.

- A tall table contains four columns and has one row for each process. The first column has a character data type and contains the names of the columns analyzed in the Process Capability platform. The other three columns need to be named LSL, Target, and USL. These column names can also be preceded by an underscore character.

**Figure 11.8 Example of a Tall Specification Limits Table**

<table>
<thead>
<tr>
<th>Process</th>
<th>LSL</th>
<th>Target</th>
<th>USL</th>
</tr>
</thead>
<tbody>
<tr>
<td>OZONE</td>
<td>0.075</td>
<td>0.15</td>
<td>0.25</td>
</tr>
<tr>
<td>CO</td>
<td>5</td>
<td>7</td>
<td>12</td>
</tr>
<tr>
<td>SO2</td>
<td>0.01</td>
<td>0.04</td>
<td>0.02</td>
</tr>
<tr>
<td>NO</td>
<td>0.01</td>
<td>0.025</td>
<td>0.04</td>
</tr>
</tbody>
</table>
A wide table contains three rows and one column for each column analyzed in the Process Capability platform plus a _LimitsKey column. In the _LimitsKey column, the three rows need to contain the identifiers _LSL, _Target, and _USL.

**Figure 11.9** Example of a Wide Specification Limits Table

![Wide Specification Limits Table](image)

The easiest way to create a limits data table is to save results computed by the Process Capability platform. The Save Spec Limits option in the Process Capability red triangle menu automatically saves limits from the sample values. After entering or loading the specification limits, you can do the following:

- **Select** **Save Spec Limits as Column Properties** to save the limits to the columns in the data table.
- **Select** **Save Spec Limits to New Table** to save the limits to a new tall specification limits data table. If you have selected at least one nonnormal distribution, a column called Distribution that contains the specified distributions is also added to the limits data table.

For more information, see “Process Capability Platform Options” on page 280.

**Spec Limits Column Property**

When you perform a capability analysis, you can use Column Properties > Spec Limits to save specification limits as a column property. The Spec Limits property applies only to numeric columns.

Some processes have one-sided specifications. Some have no target. You can enter any of these that apply: a lower specification limit, an upper specification limit, or a target value.

**Figure 11.10** displays the Spec Limits section of the Column Properties window for **OZONE** in the sample data table **Cities.jmp**.
The Process Capability Report

By default, the Process Capability platform provides the following reports:

- **“Goal Plot”** on page 273 (provided only if at least one variable is fit with a normal distribution and shows only points for variables fit with normal distributions)
- **“Capability Box Plots”** on page 276 (provided only if at least one variable is fit with a normal distribution and shows only box plots for variables fit with normal distributions)
- **“Capability Index Plot”** on page 278

Figure 11.2 on page 258 shows an example of a default Process Capability report.

Using the Process Capability red triangle menu, you can add individual detail reports, normalized box plots, and summary reports. The red triangle menu also has options for identifying out-of-spec values in your data table, creating a summary data table, changing the display order of analyzed columns, and saving out spec limits. These options are described in “Process Capability Platform Options” on page 280.

You can change the default report at File > Preferences > Platforms > Process Capability. You can also make changes to the appearance of reports produced by options by selecting the relevant Process Capability topic at File > Preferences > Platforms.
Goal Plot

The Goal Plot shows, for each variable, the spec-normalized mean shift on the x-axis, and the spec-normalized standard deviation on the y-axis. It is useful for getting a quick, summary view of how the variables are conforming to specification limits. By default, the Goal Plot shows only those points for each column that are calculated using the overall sigma. Hold your cursor over each point to view the variable name and the sigma method used to calculate the point. See “Goal Plot” on page 311 for details about the calculation of the coordinates for the Goal Plot.

Note: Process variables with distributions other than Normal are not plotted on the Goal Plot.

Goal Plot Points

Points on the Goal Plot correspond to columns, not rows. Selecting a point in the Goal Plot selects the corresponding column in the data table.

The points on the Goal Plot are also linked to the rows of the Goal Plot Summary Table, where each row corresponds to a column. You can select a point in the Goal Plot, right-click, and apply row states. These row states are applied to the rows of the Goal Plot Summary Table. Row states that you apply in the Goal Plot Summary Table are reflected in the Goal Plot. To see this table, select Make Goal Plot Summary Table from the Process Capability red triangle menu. See “Make Goal Plot Summary Table” on page 293.

Tip: If you hide a point in the Goal Plot, you can show the point again by changing the corresponding row state in the Goal Plot Summary Table.

Goal Plot Triangle

The goal plot triangle appears in the center of the bottom of the Goal Plot. The slider beneath the plot enables you to adjust the size of goal triangle in the plot.

By default, the Ppk slider and the value beneath it are set to Ppk = 1. This approximates a non-conformance rate of 0.0027, if the distribution is normal. The goal triangle represents the Ppk shown in the box. To change the Ppk value, move the slider or enter a number in the box.

JMP gives the Goal Plot in terms of Ppk values by default. You can change this preference at File > Preferences > Platforms > Process Capability. When the AIAG (Ppk) Labeling preference is unchecked, all of the Ppk labeling is changed to Cpk labeling, including the label of the slider under the goal plot.

Goal Plot Options

The Goal Plot red triangle menu has the following options:
**Show Within Sigma Points**  Shows or hides the points calculated using the within sigma estimate.

**Show Within or Between-and-Within Sigma Points**  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides the points calculated using the within sigma estimate or, if specified, the between-and-within sigma estimate.

**Show Overall Sigma Points**  Shows or hides the points calculated using the overall sigma estimate.

**Shade Levels**  Shows or hides the Ppk level shading. See Figure 11.11. When you select Shade Levels, shaded areas appear in the plot. The shaded areas are described as follows, with $p$ representing the value shown in the box beneath Ppk:

- Points in the red area have $Ppk < p$.
- Points in the yellow area have $p < Ppk < 2p$.
- Points in the green area have $2p < Ppk$.

**Label Within Sigma Points**  Shows or hides labels for points calculated using the within sigma estimate.

**Label Within or Between-and-Within Sigma Points**  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides labels for points calculated using the within sigma estimate or, if specified, the between-and-within sigma estimate.

**Label Overall Sigma Points**  Shows or hides labels for points calculated using the overall sigma estimate.

**Defect Rate Contour**  Shows or hides a contour representing a specified defect rate.

Figure 11.11 shows the Goal Plot for the entire data set for the *Semiconductor Capability.jmp* sample data table after selecting Shade Levels and Show Within Sigma Points from the Goal Plot red triangle menu.
One-Sided or Missing Specification Limits

When there is only one specification limit for a column, markers and colors are used in the following ways:

- If only the upper specification limit (USL) is specified, the point on the Goal Plot is represented by a right-pointing triangle and is colored blue.
- If only the lower specification limit (LSL) is specified, the point on the Goal Plot is represented by a left-pointing triangle and is colored red.
- If at least one process has only an upper specification limit, the right half of the goal triangle is blue.
- If at least one process has only a lower specification limit, the left half of the goal triangle is red.

Processes with only an upper specification limit are represented by blue and should be compared to the blue (right) side of the goal triangle. Processes with only a lower specification limit are represented by red and should be compared to the red (left) side of the goal triangle.

For details about how the coordinates of points are calculated, see “Goal Plot” on page 311.
Capability Box Plots

The Capability Box Plots show a box plot for each variable selected in the analysis. The values for each column are centered by their target value and scaled by the difference between the specification limits. If the target is not centered between the specification limits, the values are scaled by twice the minimum difference between the target and specification limits. For each process column $Y_j$ (see “Notation for Goal Plots and Capability Box Plots” on page 311 for a description of the notation):

$$Z_{ij} = \frac{Y_{ij} - T_j}{2 \times \min(T_j - LSL_j, USL_j - T_j)}$$

For a process with a one-sided specification, see “One-Sided or Missing Specification Limits” on page 275. For the situation where no target is specified, see “Capability Box Plots for Processes with Missing Targets” on page 313.

**Note:** Process variables with distributions other than Normal are not plotted on the Capability Box Plot.

Figure 11.11 shows a Capability Box Plots report for eight variables in the Semiconductor Capability.jmp sample data table.
The plot displays dotted green lines drawn at ±0.5.

- For a process with a target that is centered between its specification limits, the dotted green lines represent the standardized specification limits.
- For a process with a target that is not centered between its specification limits, one of the dotted green lines represents the standardized specification limit for the limit closer to the target. The other dotted green line represents the same distance in the opposite direction.

This plot is useful for comparing variables with respect to their specification limits. For example, in Figure 11.12, the majority of points for IVP1 are above its USL, and the majority of its points for IVP2 are less than its target. PNP2 seems to be on target with all data points in the specification limits.

**One-Sided or Missing Specification Limits**

When there is only one specification limit for a column, colors are used in the following ways:

- If only the upper specification limit (USL) is specified, the box plot is colored blue.
- If only the lower specification limit (LSL) is specified, the box plot is colored red.
- If at least one process has only an upper specification limit, the dotted line at 0.5 is blue.
- If at least one process has only a lower specification limit, the dotted line at -0.5 is red.
Suppose that only the lower specification limit is specified and that the process target is specified. The capability box plot is based on the following values for the transformed observations. See “Notation for Goal Plots and Capability Box Plots” on page 311 for a description of the notation:

\[ Z_{ij} = \frac{Y_{ij} - T_j}{2(T_j - LSL_j)} \]

Suppose that only the upper specification limit is specified and that the process target is specified. The capability box plot is based on the following values for the transformed observations:

\[ Z_{ij} = \frac{Y_{ij} - T_j}{2(U_SL_j - T_j)} \]

For details about how missing targets are handled with one-sided specification limits, see “Single Specification Limit and No Target” on page 313.

**Capability Index Plot**

The Capability Index Plot shows Ppk values for all variables that you entered as Y, Process.

- Each variable name appears on the horizontal axis. If you fit a nonnormal distribution, the fitted distribution name appears in the plot as a parenthetical suffix to the variable name.
- The vertical axis shows Ppk values.
- A horizontal line is placed at the Ppk value specified by the slider beneath the plot.

Figure 11.13 shows a Capability Index Plot report for the Process Measurements.jmp sample data table. Seven of the variables are fit with nonnormal distributions. Process 7 is fit with a normal distribution. Points have been labeled using the Label Overall Sigma Points option that is available in the Capability Index Plot red triangle menu.
Figure 11.13  Capability Index Plot with Nonnormal Distributions

Capability Index Plot Options

The Capability Index Plot red triangle menu has the following options:

**Show Within Sigma Points**  Shows or hides the points calculated using the within sigma estimate.

**Show Within or Between-and-Within Sigma Points**  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides the points calculated using the within sigma estimate or, if specified, the between-and-within sigma estimate.

**Show Overall Sigma Points**  Shows or hides the points calculated using the overall sigma estimate.

**Shade Levels**  Shows or hides the Ppk level shading. When you select Shade Levels, shaded areas appear in the plot. The shaded areas are described as follows, with \( p \) representing the value shown in the box beneath Ppk:

- Points in the red area have \( Ppk < p \).
- Points in the yellow area have \( p < Ppk < 2p \).
– Points in the green area have $2p < P_{pk}$.

**Label Within Sigma Points**  Shows or hides labels for points calculated using the within sigma estimate.

**Label Within or Between-and-Within Sigma Points**  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides labels for points calculated using the within sigma estimate or, if specified, the between-and-within sigma estimate.

**Label Overall Sigma Points**  Shows or hides labels for points calculated using the overall sigma estimate.

---

**Process Capability Platform Options**

The Process Capability red triangle menu contains the following options:

**Individual Detail Reports**  Shows or hides individual detail reports for each variable in the analysis. See “Individual Detail Reports” on page 283 for more information.

**Goal Plot**  Shows or hides a goal plot for the data. The Goal Plot shows the spec-normalized mean shift on the x-axis and the spec-normalized standard deviation on the y-axis for each variable. See “Goal Plot” on page 273 for more information. (Only variables for which you specify normal distributions are shown on the plot.)

**Capability Box Plots**  Shows or hides a capability box plot for each variable in the analysis. The values for each column are centered by their target value and scaled by twice the minimum difference between the target value and the specification limits. See “Capability Box Plots” on page 276 for more information. (Box plots are shown only for variables for which you specify normal distributions.)

**Normalized Box Plots**  Provides two options for plots that show normalized box plots for each process variable. Each column is standardized by subtracting its mean and dividing by an estimate of the column’s standard deviation. The box plot is constructed using quantiles for the standardized values. See “Normalized Box Plots” on page 290 for more information. (Normalized box plots are shown only for variables for which you specify normal distributions.)

**Within Sigma Normalized Box Plots**  Shows or hides a plot called Within Sigma Normalized Box Plots. The box plots are constructed using the within-subgroup estimate of standard deviation.
Within or Between-and-Within Sigma Normalized Box Plots  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides labels a plot called Within or Between-and-Within Normalized Box Plots. The box plots are constructed using the within group estimate of the standard deviation or, if specified, the between-and-within estimate.

Overall Sigma Normalized Box Plots  Shows or hides a plot called Overall Sigma Normalized Box Plots. The box plots are constructed using the overall estimate of standard deviation.

Capability Index Plot  Shows overall Ppk values for all variables that you entered as Y, Process. See “Capability Index Plot” on page 278.

Process Performance Plot  Shows or hides a four-quadrant plot of capability versus stability. Each process that has at least one specification limit is represented by a point. See “Process Performance Plot” on page 291.

Summary Reports  Provides two options for summary reports of capability indices. See “Summary Reports” on page 292.

Within Sigma Summary Report  Shows or hides a summary report of capability indices calculated using the within-subgroup estimate of standard deviation. (Results are available only for variables with specified normal distributions.)

Within or Between-and-Within Sigma Summary Report  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides a summary report of capability indices calculated using the within group estimate of the standard deviation or, if specified, the between-and-within group estimate.

Overall Sigma Summary Report  Shows or hides a summary report of capability indices calculated using the overall estimate of standard deviation.

Action Options

The following red triangle menu options perform actions:

Out of Spec Values  Provides options for the cells in the data table containing values that are out of spec.

Select Out of Spec Values  Selects all rows and columns in the data table that contain at least one value that does not fall within the specification limits.

Color Out of Spec Values  Colors the cells in the data table that correspond to values that are out of spec. The cell is colored blue if the value is above the USL and red if the value is below the LSL.
Tip: To remove colors in specific cells, select all cells of interest. Right-click in one of the cells and select Clear Color. To remove colors in all cells, deselect Color Out of Spec Values.

Make Goal Plot Summary Table  Creates a summary table for the points plotted in the Goal Plot. This table includes the variable’s name, its spec-normalized mean shift, and its spec-normalized standard deviation. Each variable has two rows in this table: one for each sigma type (within and overall). See “Make Goal Plot Summary Table” on page 293 for more information.

Order By  Reorders the box plots, summary reports, and individual detail reports. You can reorder by Initial Order, Reverse Initial Order, Within Sigma Cpk Ascending, Within or Between-and-Within Sigma Cpk Ascending, Within Sigma Cpk Descending, Within or Between-and-Within Sigma Cpk Descending, Overall Sigma Ppk Ascending, or Overall Sigma Ppk Descending. The options that order by Within Sigma reorder plot elements only for variables with specified normal distributions.

Note: The options to order by Within or Between-and-Within Sigma are available only if Calculate Between-and-Within Capability is selected for at least one process in the launch window.

Save Spec Limits  Provides options for saving specification limits.

Save Spec Limits as Column Properties  Saves the specification limits to a column property for each variable in the analysis. If no spec limit column property is present, the column property is created. If a spec limit column property is present, the values in the column property are overwritten. See “Spec Limits Column Property” on page 271 for more information.

Save Spec Limits to New Table  Saves the specification limits to a limits data table in tall format. See “Limits Data Table” on page 270 for more information.

Save Distributions as Column Properties  Saves the distribution used in calculating capability as a Process Capability Distribution column property. See the Column Info Window chapter in the Using JMP book.

If a column contains the Distribution property specifying a nonnormal distribution and no Process Capability Distribution property, then the Process Capability platform applies a nonnormal fit. The Process Capability platform uses the distribution specified in the Distribution column property, or a Johnson fit if that distribution is not supported in Process Capability. If a column contains the Process Capability Distribution property, then the Process Capability platform uses the distribution specified in the Process Capability Distribution column property.
Note: If you want to use a specific distribution in the Process Capability platform, save it as a Process Capability Distribution column property.

Relaunch Dialog  Opens the platform launch window and recalls the settings used to create the report.

See the JMP Reports chapter in the *Using JMP* book for more information about the following options:

Local Data Filter  Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

**Individual Detail Reports**

The Individual Detail Reports option displays a capability report for each variable in the analysis.

**Normal Distributions**

Figure 11.14 shows the Individual Detail Report for PNP1 from the Semiconductor Capability.jmp sample data table as described in “Example of the Process Capability Platform with Normal Variables” on page 257.
The Individual Details report for a variable with a normal distribution shows a histogram, process summary details, and capability and nonconformance statistics. The histogram shows the distribution of the values, the lower and upper specification limits and the process target (if they are specified), and one or two curves showing the assumed distribution. The histogram in Figure 11.14 shows two normal curves, one based on the overall estimate of standard deviation and the other based on the within-subgroup estimate.

When you fit your process with a normal distribution, the Process Summary includes the Stability Ratio, which is a measure of stability of the process. The stability ratio is defined as follows:

$$(\text{Overall Sigma/Within Sigma})^2$$

If Calculate Between-and-Within Capability is specified for a process in the launch window, the stability ratio for that process is defined as follows:

$$(\text{Overall Sigma/Between-and-Within Sigma})^2$$

A stable process has stability ratio near one. Higher values indicate less stability.
Nonnormal Distributions

Note: Capability indices based on within-subgroup variation and stability ratios are not available for processes for which you have specified nonnormal distributions.

Figure 11.15 shows the Individual Detail Report for Process 1 from the Process Measurements.jmp sample data table as described in “Example of the Process Capability Platform with Nonnormal Variables” on page 259.

Figure 11.15 Individual Detail Report for Process 1

The report opens with a note summarizing the Nonnormal Distribution Options that you selected in the launch window.

The Individual Details report for a variable with a nonnormal distribution shows a histogram, process summary details, and capability and nonconformance statistics. The histogram shows the distribution of the values, the lower and upper specification limits and the process target (if they are specified). A curve showing the fitted distribution is superimposed on the histogram. If you selected a Nonparametric distribution, the curve shown in the histogram is the nonparametric density.
The report also shows a Parameter Estimates report if you selected a nonnormal parametric distribution or a Nonparametric Density report if you selected a Nonparametric fit. See “Parameter Estimates” on page 287 and “Nonparametric Density” on page 288.

**Individual Detail Report Options**

The outline title for each variable in the Individual Detail Reports section is of the form `<Variable Name> Capability`. However, if you request nonnormal capability, the relevant distribution name is shown parenthetically in the outline title.

Each Capability report has a red triangle menu with the following options:

- **Compare Distributions**  Shows or hides the control panel for comparing distributions for the process. See “Compare Distributions” on page 288.

- **Process Summary**  Shows or hides the summary statistics for the variable, including the overall sigma estimate, and, if you have specified a normal distribution, the within sigma estimate and the stability ratio. If you have specified Calculate Between-and-Within Capability for at least one process in the launch window, estimates for the between sigma and the between-and-within sigma are also included.

- **Histogram**  Shows or hides the histogram of the values of the variable. The histogram report includes a red triangle menu that controls the following features of the histogram:
  
  - **Show Spec Limits**  Shows or hides vertical red lines on the histogram at the specification limits for the process.
  
  - **Show Target**  Shows or hides a vertical green line on the histogram at the process target.
  
  - **Show Within Sigma Density**  Shows or hides an approximating normal density function on the histogram with mean given by the sample mean and standard deviation given by the within estimate of sigma.

  - **Show Between-and-Within Sigma Density**  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides an approximating normal density function on the histogram with mean given by the sample mean and standard deviation given by the between-and-within estimate of sigma.

  - **Show Overall Sigma Density**  Shows or hides an approximating normal density function on the histogram with mean given by the sample mean and standard deviation given by the overall estimate of sigma.

  - **Show Count Axis**  Shows or hides an additional axis to the right of the histogram plot showing the count of observations.
Show Density Axis  Shows or hides an additional axis to the right of the histogram plot showing the proportion of observations.

Capability Indices  Controls display of the following capability index reports:

Within Sigma Capability  (Available when distribution is Normal.) Shows or hides capability indices (and confidence intervals) based on the within (short-term) sigma.

Between-and-Within Sigma Capability  (Available only when distribution is Normal and Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides capability indices (and confidence intervals) based on the between-and-within sigma.

Within Sigma Z Benchmark  (Available when distribution is Normal.) Shows or hides Z benchmark indices based on the within (short-term) sigma.

Between-and-Within Sigma Z Benchmark  (Available only when distribution is Normal and Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides Z benchmark indices (and confidence intervals) based on the between-and-within sigma.

Overall Sigma Capability  Shows or hides capability indices (and confidence intervals) based on the overall (long-term) sigma.

Overall Sigma Z Benchmark  (Available when distribution is Normal.) Shows or hides Z benchmark indices based on the overall (long-term) sigma.

Nonconformance  Shows or hides the observed and expected percentages of observations below the LSL, above the USL, and outside of the specification limits. The Nonconformance table contains hidden columns for observed and expected PPM and counts.

Parameter Estimates  (Available when a distribution other than Normal or Nonparametric is selected.) Shows or hides the Parameter Estimates report, which gives estimates for the parameters of the selected distribution.

The estimates for all except the Johnson family distributions are obtained using maximum likelihood. For details about Johnson family fits, see “Johnson Distribution Fit Method” on page 268.

The parameters and probability density functions for the normal, beta, exponential, gamma, Johnson, lognormal, and Weibull distributions are described in “Capability Indices for Nonnormal Distributions: Percentile and Z-Score Methods” on page 317. These are the same parameterizations used in the Distribution platform, with the exception that Process Capability does not support threshold parameters. See the Distributions chapter in the Basic Analysis book.
Nonparametric Density  (Available when Nonparametric is selected as the distribution.)
Shows or hides the Nonparametric Density report, which gives the kernel bandwidth used in fitting the nonparametric distribution. The kernel bandwidth is given by the following, where \( n \) is the number of observations and \( S \) is the uncorrected sample standard deviation:

\[
\text{bandwidth} = \frac{0.9 S}{n^{1/5}}
\]

Compare Distributions

The Compare Distributions report enables you to compare and apply various distributional fits. Note the following:

- Your selected distribution is indicated in the Selected column.
- The report initially shows fit statistics for your Selected distribution and other fitted distributions in the Comparison Details report. If you selected Best Fit, the Comparison Details report initially shows statistics for all parametric fits.
- Check the distributions in the Distribution list that you want to compare.
  - The probability density function for the best fitting distribution in each family that you select is superimposed on the histogram in the Histogram - Compare Distributions report.
  - If the distribution is parametric, a row for that family containing fit results is added to the Comparison Details report.
  - If Nonparametric is checked in the Distribution list, the Nonparametric Density report, showing the automatically selected kernel bandwidth, is added to the Compare Distributions report. See “Nonparametric Density” on page 288.
  - You can change your selected distribution by selecting its radio button under Selected. The capability report is updated to show results for the selected distribution.

Figure 11.16 shows the Compare Distributions report for Process 1 in the Process Measurements.jmp sample data table. The Selected distribution, which is Lognormal, is being compared to a Normal distribution. The Comparison Details report shows fit statistics for both distributions.

You can obtain probability plots by selecting the Probability Plots option from the Compare Distributions red triangle menu. The points in the probability plot for the normal distribution in Figure 11.16 do not follow the line closely. This indicates a poor fit.
Figure 11.16 Compare Distributions with Probability Plot for Normal

Compare Distributions Options

The following options are available in the Compare Distributions red triangle menu.

Comparison Details  For each distribution, gives AICc, BIC, and -2Loglikelihood values. See the Statistical Details appendix in the Fitting Linear Models book. (Not available for a Nonparametric fit.)

Comparison Histogram  Shows or hides the Histogram report.

Probability Plots  Shows or hides a report that displays probability plots for each parametric distribution that you fit. See Figure 11.16. An observation’s horizontal coordinate is its observed data value. An observation’s vertical coordinate is the value of the quantile of the
fitted distribution for the observation’s rank. For the normal distribution, the overall estimate of sigma is used in determining the fitted distribution.

The red triangle menus associated with each Probability Plot contain the following options.

**Simultaneous Empirical Confidence Limits**  Shows or hides confidence limits that have a simultaneous 95% confidence level of containing the true probability function, given that the data come from the selected parametric family. These limits have the same estimated precision at all points. Use them to determine whether the selected parametric distribution fits the data well. See Nair (1984) and Meeker and Escobar (1998).

**Simultaneous Empirical Confidence Limits Shading**  Shows or hides shading of the region between the Simultaneous Empirical Confidence Limits.

**Parametric Fit Line**  Shows or hides the line that shows the predicted probabilities for the observations based on the fitted distribution.

**Parametric Fit Confidence Limits Shading**  Shows or hides shading of the region between parametric fit confidence intervals. The parametric fit confidence limits have confidence level $(1 - \alpha)$, where $\alpha$ is the value that you specify in the launch window. (Available only when the parametric fit confidence limits are meaningful and when it is possible to calculate them.)

When possible, the intervals are computed by expressing the parametric distribution $F$ as a location-scale family, so that $F(y) = G(z)$, where $z = (y - \mu)/\sigma$. The approximate standard error of the fitted location-scale component at a point is computed using the delta method. Using the standard error estimate, a Wald confidence interval for $z$ is computed for each point. The confidence interval for the cumulative distribution function $F$ is obtained by transforming the Wald interval using $G$. Note that, in some cases, special accommodations are required to provide appropriate intervals near the endpoints of the interval of process measurements.

**Order by Comparison Criterion**  Orders the distributions in the Comparison Details report according to the criterion that you select. The default ordering is by AICc, unless you selected another criterion in the Distribution Comparison Criterion panel in the launch window.

**Normalized Box Plots**

The Normalized Box Plots options show or hide box plots that have been normalized using the specified sigma in the title. When drawing normalized box plots, JMP standardizes each column by subtracting the mean and dividing by the standard deviation. The box plots are formed for each column using these standardized values.
Figure 11.17 shows the Within Sigma Normalized Box Plot for a selection of the process variables in the Semiconductor Capability.jmp sample data table using wafer as a subgroup variable.

The green vertical lines represent the specification limits for each variable normalized by the mean and standard deviation of each variable. The gray dotted vertical lines are drawn at ±0.5, since the data is standardized to a standard deviation of 1.

**Process Performance Plot**

The Process Performance Plot option shows or hides a four-quadrant plot of capability versus stability. Each process that has specification limits is represented by a point. The horizontal coordinate of each point equals the stability ratio of the process and the vertical coordinate of each point equals the overall Ppk capability of the process. The plot is divided into four shaded quadrants based on the following default boundaries:

- A stability ratio that exceeds 1.5 indicates that the process is unstable.
- A Ppk that is smaller than 1.0 indicates that the process is not capable.

The boundaries that define the four quadrants can be adjusted using the Ppk and Stability Ratio slider controls below the plot. You can also set preferences for your desired Capability and Stability boundaries in File > Preferences > Platforms > Process Performance Plot.
The legend contains descriptions of the shaded regions. If any of the processes are missing a lower or upper specification limit, the legend also shows the markers used for those processes. If the markers do not appear in the legend, then all of the processes in the plot contain both lower and upper specification limits. See “One-Sided or Missing Specification Limits” on page 275.

The Process Performance Plot red triangle menu contains the following option:

**Show Labels**  Shows or hides labels for each point in the Process Performance Plot.

**Figure 11.18** Process Performance Plot

![Process Performance Plot](image)

Figure 11.18 shows the Process Performance Plot for a selection of the process variables in the Semiconductor Capability.jmp sample data table using wafer as a subgroup variable.

**Summary Reports**

The Summary Report options show or hide a table that contains the following statistics for each variable: LSL, Target, USL, Sample Mean, various Sigma estimates, Stability Ratio, $\text{Cpk}$, $\text{Cpl}$, $\text{Cpu}$, $\text{Cp}$, $\text{Cpm}$, and Nonconformance statistics. These statistics are calculated using the sigma estimate specified in the report title. Figure 11.19 shows a subset of columns for both
summary reports as described in “Example of the Process Capability Platform with Normal Variables” on page 257. The following optional columns are available for this report:

- Confidence intervals for Cpk, Cpl, Cpu, CP, and Cpm
- Expected and observed PPM statistics (outside, below LSL, above USL)

**Note:** The expected PPM statistics are the percentages you would expect to see based on the distribution chosen. By default, the distribution is normal. The observed PPM statistics are the percentages based on the actual data.

- Sample standard deviation
- The sample size (N), the minimum, and the maximum.

To reveal these optional columns, right-click on the report and select the column names from the Columns submenu.

Note that the report (based on overall sigma) shows the overall capability indices Ppk, Ppl, Ppu, and Pp instead of the within capability indices Cpk, Cpl, Cpu, and Cp. The labeling of the overall capability indices depends on the setting of the AIAG (Ppk) Labeling preference.

**Figure 11.19** Within Sigma and Overall Sigma Capability Summary Reports

---

**Make Goal Plot Summary Table**

The Make Goal Plot Summary Table option produces a summary data table that includes each variable’s name, its spec-normalized mean shift (Mean Shift Standardized to Spec), and its spec-normalized standard deviation (Std Dev Standardized to Spec). For each variable, there is a row for each of the sigma types.
**Note:** If a variable is fit with a distribution other than normal, the name of the fitted distribution is appended parenthetically to the variable name. The Mean Shift Standardized to Spec and Std Dev Standardized to Spec values are not provided for nonnormal variables.

The points in the Goal Plot are linked to the rows in the Goal Plot Summary Table. If you apply row states to a point in the Goal Plot, you can change the corresponding row states in the Goal Plot Summary Table. Conversely, if you apply row states in the Goal Plot Summary Table, they are reflected on the Goal Plot.

Figure 11.20 shows the Goal Plot Summary Table for the Semiconductor Capability.jmp sample data table as described in “Example of the Process Capability Platform with Normal Variables” on page 257.

**Figure 11.20 Summary Table**

<table>
<thead>
<tr>
<th>Process</th>
<th>Sigma Type</th>
<th>Mean Shift Standardized to Spec</th>
<th>Std Dev Standardized to Spec</th>
</tr>
</thead>
<tbody>
<tr>
<td>PNP1</td>
<td>Within</td>
<td>0.0605058038</td>
<td>0.2240448185</td>
</tr>
<tr>
<td>PNP2</td>
<td>Within</td>
<td>-0.00733452</td>
<td>0.0638873257</td>
</tr>
<tr>
<td>NPN2</td>
<td>Within</td>
<td>0.0581098256</td>
<td>0.0621427935</td>
</tr>
<tr>
<td>PNP3</td>
<td>Within</td>
<td>0.3154424678</td>
<td>0.2653278331</td>
</tr>
<tr>
<td>IVP1</td>
<td>Within</td>
<td>1.388169325</td>
<td>0.5591421926</td>
</tr>
<tr>
<td>IVP2</td>
<td>Within</td>
<td>0.0300774244</td>
<td>0.056663241</td>
</tr>
<tr>
<td>NPN3</td>
<td>Within</td>
<td>-0.05674631</td>
<td>0.050316157</td>
</tr>
<tr>
<td>NPN2</td>
<td>Within</td>
<td>-0.65593547</td>
<td>1.194593146</td>
</tr>
<tr>
<td>PNP1</td>
<td>Overall</td>
<td>0.0605056038</td>
<td>0.2199861461</td>
</tr>
<tr>
<td>PNP2</td>
<td>Overall</td>
<td>-0.00733452</td>
<td>0.063496074</td>
</tr>
<tr>
<td>NPN2</td>
<td>Overall</td>
<td>0.0581098256</td>
<td>0.0612473972</td>
</tr>
<tr>
<td>PNP3</td>
<td>Overall</td>
<td>0.3154424678</td>
<td>0.261014796</td>
</tr>
<tr>
<td>IVP1</td>
<td>Overall</td>
<td>1.388169325</td>
<td>0.553695044</td>
</tr>
<tr>
<td>PNP4</td>
<td>Overall</td>
<td>0.0300774244</td>
<td>0.0556117297</td>
</tr>
<tr>
<td>NPN3</td>
<td>Overall</td>
<td>-0.05674631</td>
<td>0.0503568396</td>
</tr>
<tr>
<td>IVP2</td>
<td>Overall</td>
<td>-0.65593547</td>
<td>1.1818006873</td>
</tr>
</tbody>
</table>

**Additional Examples of the Process Capability Platform**

- “Process Capability for a Stable Process”
- “Process Capability for an Unstable Process”
- “Simulation of Confidence Limits for a Nonnormal Process Ppk”

**Process Capability for a Stable Process**

In this example, you verify the assumptions that enable you to estimate PPM defective rates based on a capability analysis. You access Process Capability through Control Chart Builder.
and then directly. The data consist of 22 subgroups of size five. There are six missing readings, with three in each of two consecutive subgroups.

**Process Capability through Control Chart Builder**

You can use Control Chart Builder to check process stability and the normality assumption for your process characteristic. You can also obtain Process Capability information directly within Control Chart Builder.

1. Select **Help > Sample Data Library** and open **Quality Control/Clips2.jmp**.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag **Date** to the **Subgroup** zone.
4. Drag **Gap** to the **Y** zone.

**Figure 11.21** XBar and R Control Chart for Gap

The control chart indicates that **Gap** is stable over time. Because **Gap** has the Spec Limits column property, a Process Capability Analysis report appears to the right of the control chart.
The histogram and fitted normal blue curve suggest that the distribution of Gap is approximately normal. Although the process is stable, the distribution of Gap is shifted to the right of the specification range.

The Process Summary report shows the specification limits that are saved to the Spec Limits column property. It also shows that the estimate of sigma calculated from within-subgroup variation (Within Sigma) does not differ greatly from the overall estimate given by the sample standard deviation (Overall Sigma). Consequently, the Stability Ratio is near one (0.958966). This is expected because the process is stable.

5. Right-click in the body of the Nonconformance report and select **Expected Within PPM** from the Columns submenu.

The Cpk value calculated using subgroup variation is 0.966, indicating that the process is not very capable. The Cpl value suggests good performance, but this is because the process is shifted away from the lower specification limit. Defective parts generally result from large values of Gap.

Note that the confidence interval for Cpk is wide; it ranges from 0.805 to 1.128. This occurs even though there are 104 observations. Capability indices are surprisingly variable, due
to the fact that they are ratios. It is easy to reach incorrect conclusions based on the point estimate of a capability index.

The estimates of out-of-specification product given in the Nonconformance report provide a direct measure of process performance. The PPM values in the Nonconformance report indicate that Gap hardly ever falls below the lower specification limit (1.4 parts per million). However, the number of parts for which Gap falls above the upper specification limit is 1869.0 parts per million.

For an uncentered process, the Cp value indicates potential capability if the process were adjusted to be centered. If this process were adjusted to be centered at the target value of 14.8, then its capability would be 1.264, with a confidence interval from 1.071 to 1.457.

**Process Capability Platform**

Now that you have verified stability and normality for Gap, you can obtain additional information in the Process Capability platform.

1. Select **Analyze > Quality and Process > Process Capability**.
2. Select Gap and click **Y, Process**.
3. Open the **Process Subgrouping** outline.
4. Select Date in the Select Columns list and Gap in the Roles list.
5. Click **Nest Subgroup ID Column**.
   
   By default, the Within-Subgroup Variation Statistic selection is set to Average of Unbiased Standard Deviations. In the Control Chart Builder example (“Process Capability through Control Chart Builder” on page 295), subgroup ranges were used.
6. Click **OK**.
Figure 11.24 Goal Plot and Box Plot for Gap

The Goal Plot shows the Ppk index for Gap as being essentially equal to 1. The box plot shows that most values fall within specifications, but the preponderance of data values are shifted to the right within the specification range.

7. From the Process Capability red triangle menu, select Individual Detail Reports.

The report is the one obtained using Control Chart Builder, except that the Within Sigma is based on average standard deviations rather than average ranges. See “Histogram in Process Capability Analysis for Gap” on page 296 and “Capability Indices and Nonconformance Report” on page 296.

Process Capability for an Unstable Process

The following example shows a case where the overall variation differs from the within variation because the process is not stable. It uses the Coating.jmp data table from the Quality Control folder of Sample Data (taken from the ASTM Manual on Presentation of Data and Control
The process variable of interest is the Weight column, grouped into subgroups by the Sample column.

**Process Capability Platform**

1. Select Help > Sample Data Library and open Quality Control/Coating.jmp.
4. Open the Process Subgrouping outline.
5. Select Sample in the Select Columns list on the left.
6. Select Weight in the Cast Selected Columns into Roles list on the right.
7. Click Nest Subgroup ID Column.
8. Click OK.
9. Enter 16 for LSL, 20 for Target, and 24 for USL in the Spec Limits window.
10. Click OK.
11. Select Show Within Sigma Points from the Goal Plot red triangle menu.
12. Select Individual Detail Reports from the Process Capability red triangle menu.
Figure 11.25 Process Capability Report for Coating.jmp Data
Figure 11.25 shows the resulting Process Capability report. The Goal Plot shows two points that represent the mean shift and standard deviation standardized to the specification limits. The point labeled Overall Sigma is calculated using the overall sample standard deviation. The point labeled Within Sigma is calculated using a within-subgroup estimate of the standard deviation.

The point calculated using Overall Sigma is outside the goal triangle corresponding to a Ppk of 1. This indicates that the variable Weight results in non-conforming product.

However, the point calculated using Within Sigma is inside the goal triangle. This indicates that, if the process were stable, Weight values would have a high probability of falling within the specification limits.

**Control Chart to Assess Stability**

Use Control Chart Builder to determine whether the Weight measurements are stable.

1. Select Help > Sample Data Library and open Quality Control/Coating.jmp.
1. Select Analyze > Quality and Process > Control Chart Builder.
2. Drag Sample to the Subgroup zone.
3. Drag Weight to the Y zone.

**Figure 11.26** XBar and R Chart for Weight
The control chart indicates that the Weight measurements are unstable. The process is affected by special causes and is unpredictable. This makes the interpretation of capability indices and nonconformance estimates highly questionable. Even estimates based on Overall Sigma are questionable, because the process is not predictable.

The histogram in Figure 11.25 shows the distribution of the Weight values with normal density curves using both sigma estimates superimposed over the histogram. The normal curve that uses the Overall Sigma estimate is flatter and wider than the normal curve that uses the Within Sigma estimate. This normal curve is more dispersed because the estimate of Overall Sigma is inflated by the special causes that make the process unstable. If the process were stable, the narrower normal curve would reflect process behavior.

You can also compare the Cpk estimate (1.142) to the Ppk estimate (0.814). The fact that Ppk is much smaller than Cpk is additional evidence that this is an unpredictable process. The Cpk estimate is a forecast of the capability that you would achieve by bringing the process to a stable state.

**Note:** The Individual Detail Reports Cutoff preference determines whether the Individual Reports appear by default. If the preference is enabled, the Individual Reports appear by default if the number of process variables is less than or equal to the number specified in the preference. You can change this preference in Preferences > Platforms > Process Capability.

**Simulation of Confidence Limits for a Nonnormal Process Ppk**

In this example, you first perform a capability analysis for the three nonnormal variables in Tablet Measurements.jmp. You then use Simulate to find confidence limits for the nonconformance percentage for the variable Purity.

**Nonnormal Capability Analysis**

If you prefer not to follow the steps below, you can obtain the results in this section by running the Process Capability table script in Tablet Measurements.jmp.

1. Select Help > Sample Data Library and open Tablet Measurements.jmp.
4. Select Weight, Thickness, and Purity in the Cast Selected Columns into Roles list on the right.
5. Open the Distribution Options outline.
6. From the Distribution list, select Best Fit.
7. Click Set Process Distribution.
The &Dist(Best Fit) suffix is added to each column name in the list on the right.

8. Click OK.

A Capability Index Plot appears, showing the Ppk values. Note that only the Thickness variable appears above the line that denotes Ppk = 1. Purity is nearly on the line. Although the number of measurements, 250, seems large, the estimated Ppk value is still quite variable. For this reason, you construct a confidence interval for the true Purity Ppk value.

**Note:** Because a Goal Plot is not shown, you can conclude that a normal distribution fit was not the best fit for any of the three variables.


The best fits are as follows:
- Weight: Lognormal
- Thickness: Johnson Sb (see the note immediately beneath the Thickness(Johnson) Capability report title)
- Purity: Weibull

**Construct the Simulation Column**

To use the Simulate utility to estimate Ppk confidence limits, you need to construct a simulation formula that reflects the fitted Weibull distribution. If you prefer not to follow the steps below, you can obtain the results in this section by running the Add Simulation Column table script.


**Figure 11.27** Weibull Parameter Estimates for Purity

![Parameter Estimates](image)

These are the parameter estimates for the best fitting distribution, which is Weibull.

2. In the Tablet Measurements.jmp sample data table, select Cols > New Columns.

3. Next to Column Name, enter Simulated Purity.

4. From the Column Properties list, select Formula.

5. In the formula editor, select Random > Random Weibull.

6. The placeholder for beta is selected. Click the insertion element (^).
This adds a placeholder for the parameter \( \alpha \).

7. Right-click in the Parameter Estimates report table and select **Make into Data Table**.

8. Copy the entry in Row 2 in the **Estimate** column (1589.7167836).

9. In the formula editor window, select the placeholder for \( \beta \) in the **Random Weibull** formula and paste 1589.7167836 into the placeholder for \( \beta \).

10. In the data table that you created from the Parameter Estimates report, copy the entry in Row 1 in the **Estimate** column (99.918708989).

11. In the formula editor window, select the placeholder for \( \alpha \) in the **Random Weibull** formula and paste 99.918708989 into the placeholder for \( \alpha \).

**Figure 11.29** Completed Formula Window

\[
\text{Random Weibull}(1589.7167836, 99.918708989)
\]

12. Click **OK** in the formula editor window.

13. Click **OK** in the New Column window.

   The **Simulated Purity** column contains a formula that simulates values from the best-fitting distribution.

**Simulate Confidence Intervals for Purity Ppk and Expected Percent Nonconforming**

When you use Simulate, the entire analysis is run the number of times that you specify. To shorten the computing time, you can minimize the computational burden by running only the required analysis. In this example, because you are interested only in Purity with a fitted Weibull distribution, you perform only this analysis before running Simulate.
**Note:** If you do not care about computing time, you can use the same report you created in the previous section and start with step 7.

1. In the Process Capability report, select **Relaunch Dialog** from the Process Capability red triangle menu.
2. (Optional) Close the Process Capability report.
3. In the launch window, from the **Cast Selected Columns into Roles** list, select **Weight&Dist(Lognormal)** and **Thickness&Dist(Johnson)**.
4. Click **Remove**.
5. Click **OK**.
6. Select **Individual Detail Reports** from the Process Capability red triangle menu,
   Both Ppk and Ppl values are provided, but they are identical because Purity has only a lower specification limit.
7. In the Overall Sigma Capability report, right-click the **Estimate** column and select **Simulate**.
   In the **Column to Switch Out** list, make sure Purity is selected. In the **Column to Switch In** list, make sure Simulated Purity is selected.
8. Next to **Number of Samples**, enter 500.
   **Note:** The next step is not required. However, it ensures that you obtain exactly the simulated values shown in this example.
9. (Optional) Next to **Random Seed**, enter 12345.
10. Click **OK**.
    The calculation might take several seconds. A data table entitled Process Capability Simulate Results (Estimate) appears. The Ppk and Ppl columns in this table each contain 500 values calculated based on the Simulated Purity formula. The first row, which is excluded, contains the values for Purity obtained in your original analysis. Because Purity has only a lower specification limit, the Ppk values are identical to the Ppl values.
11. In the Process Capability Simulate Results (Estimate) data table, click the green triangle next to the **Distribution** script.
Two Distribution reports are shown, one for Ppk and one for Ppl. But Purity has only a lower specification limit, so that the Ppk and Ppl values are identical. For this reason, the Distribution reports are identical.

The Simulation Results report shows that a 95% confidence interval for Ppk is 0.909 to 1.145. The true Ppk value could be above 1.0, which would place Purity above the Ppk = 1 line in the Capability Index Plot you constructed in “Nonnormal Capability Analysis” on page 302.

12. In the Process Capability report, right-click the Expected Overall % column in the Nonconformance report and select Simulate.

   In the Column to Switch Out list, make sure Purity is selected. In the Column to Switch In list, make sure Simulated Purity is selected.
13. Next to **Number of Samples**, enter **500**.

14. (Optional) Next to **Random Seed**, enter **12345**.

15. Click **OK**.

The calculation might take several seconds. A data table entitled Process Capability Simulate Results (Expected Overall %) appears. Because Purity has only a lower specification limit, the **Below LSL** values are identical to the **Total Outside** values.

16. In the Process Capability Simulate Results (Expected Overall %) data table, click the green triangle next to the **Distribution** script.

**Figure 11.31** Distribution of Simulated Total Outside Values for Purity

Again, two identical Distribution reports appear. The Simulation Results report shows that a 95% confidence interval for the Expected Overall % nonconforming is 0.055 to 0.238.
Statistical Details for the Process Capability Platform

- "Variation Statistics"
- "Notation for Goal Plots and Capability Box Plots"
- "Goal Plot"
- "Capability Box Plots for Processes with Missing Targets"
- "Capability Indices for Normal Distributions"
- "Capability Indices for Nonnormal Distributions: Percentile and Z-Score Methods"
- "Parameterizations for Distributions"

Variation Statistics

Denote the standard deviation of the process by $\sigma$. The Process Capability platform provides two types of capability indices. The Ppk indices are based on an estimate of $\sigma$ that uses all of the data in a way that does not depend on subgroups. This overall estimate can reflect special cause as well as common cause variation. The Cpk indices are based on an estimate that attempts to capture only common cause variation. The Cpk indices are constructed using within-subgroup or between-and-within-subgroup estimates of $\sigma$. In this way, they attempt to reflect the true process standard deviation. When a process is not stable, the different estimates of $\sigma$ can differ markedly.

Overall Sigma

The overall sigma does not depend on subgroups. JMP calculates the overall estimate of $\sigma$ as follows:

$$\hat{\sigma} = \sqrt{\frac{1}{N-1} \sum_{i=1}^{N} (y_i - \bar{y})^2}$$

The formula uses the following notation:

$N$ = number of nonmissing values in the entire data set

$y_i$ = value of the $i^{th}$ observation

$\bar{y}$ = mean of nonmissing values in the entire data set
Caution: When the process is stable, the Overall Sigma estimates the process standard deviation. If the process is not stable, the overall estimate of $\sigma$ is of questionable value, since the process standard deviation is unknown.

Estimates of Sigma Based on Within-Subgroup Variation

An estimate of $\sigma$ that is based on within-subgroup variation can be constructed in one of three ways:

- Within sigma estimated by average of ranges
- Within sigma estimated by average of unbiased standard deviations
- Within sigma estimated by moving range

If you specify a subgroup ID column or a constant subgroup size on the launch window, you can specify your preferred within-subgroup variation statistic. See “Launch the Process Capability Platform” on page 264. If you do not specify a subgroup ID column, a constant subgroup size, or a historical sigma, JMP estimates the within sigma using the third method (moving range of subgroups of size two).

Within Sigma Based on Average of Ranges

Within sigma estimated by the average of ranges is the same as the estimate of the standard deviation of an $\bar{X}/R$ chart:

$$\sigma = \frac{\frac{R_1}{d_2(n_1)} + \cdots + \frac{R_N}{d_2(n_N)}}{N}$$

The formula uses the following notation:

- $R_i =$ range of $i^{th}$ subgroup
- $n_i =$ sample size of $i^{th}$ subgroup
- $d_2(n_i) =$ expected value of the range of $n_i$ independent normally distributed variables with unit standard deviation
- $N =$ number of subgroups for which $n_i \geq 2$

Within Sigma Based on Average of Unbiased Standard Deviations

Within sigma estimated by the average of unbiased standard deviations is the same as the estimate for the standard deviation in an $\bar{X}/S$ chart:
Process Capability
Chapter 11
Statistical Details for the Process Capability Platform
Quality and Process Methods

\[ \hat{\sigma} = \frac{s_1}{c_4(n_1)} + \ldots + \frac{s_N}{c_4(n_N)} \]

The formula uses the following notation:

- \( n_i \) = sample size of \( i^{th} \) subgroup
- \( c_4(n_i) \) = expected value of the standard deviation of \( n_i \) independent normally distributed variables with unit standard deviation
- \( N \) = number of subgroups for which \( n_i \geq 2 \)
- \( s_i \) = sample standard deviation of the \( i^{th} \) subgroup.

Within Sigma Based on Moving Range

Within sigma estimated by moving range is the same as the estimate for the standard deviation for Individual Measurement and Moving Range charts:

\[ \hat{\sigma} = \frac{MR}{d_2(2)} \]

The formula uses the following notation:

- \( \overline{MR} \) = the mean of the nonmissing moving ranges computed as \( (MR_2+MR_3+\ldots+MR_N)/(N-1) \)
  where \( MR_i = |y_i - y_{i-1}| \).
- \( d_2(2) \) = expected value of the range of two independent normally distributed variables with unit standard deviation.

Estimate of Sigma Based on Between Group Variation

Between Sigma Based on Moving Range

The estimate of \( \sigma \) that is based on between-subgroup variation is estimated by the moving range of subgroup means:

\[ \hat{\sigma} = \sqrt{\frac{\overline{MR}^2}{d_2(2)}} \cdot \hat{\sigma}_{Within} \cdot \frac{1}{H} \]

The formula uses the following notation:

- \( \overline{MR} \) = the mean of the nonmissing moving ranges computed as \( (MR_2+MR_3+\ldots+MR_N)/(N-1) \)
  where \( MR_i = |y_i - y_{i-1}| \).
- \( d_2(2) \) = expected value of the range of two independent normally distributed variables with unit standard deviation.
unit standard deviation.

\[ \sigma_{\text{within}}^2 = \text{the specified within sigma estimate.} \]

\[ H = \frac{N}{\frac{1}{n_1} + \frac{1}{n_2} + \ldots + \frac{1}{n_N}}, \text{ the harmonic mean of subgroup sample sizes.} \]

**Estimate of Sigma Based on Between and Within Group Variation**

**Between-and-Within Sigma**

The estimate of sigma that is based on the combined between and within group variation is defined as follows:

\[ \hat{\sigma} = \sqrt{\frac{\hat{\sigma}_{\text{within}}^2 + \hat{\sigma}_{\text{between}}^2}{N}} \]

**Notation for Goal Plots and Capability Box Plots**

The formulas for the Goal Plot and Capability Box Plots use the following notation:

\[ Y_{ij} = \text{the } i^{th} \text{ observation for process } j \]

\[ \bar{Y}_j = \text{mean of the observations on process } j \]

\[ SD(Y_j) = \text{standard deviation of the observations on process } j \]

\[ T_j = \text{target value for process } j \]

\[ LSL_j = \text{lower specification limit for process } j \]

\[ USL_j = \text{upper specification limit for process } j \]

**Goal Plot**

This section provides details about the calculation of the mean shift and standard deviation standardized to specification quantities plotted in the Goal Plot. This section uses the notation defined in “Notation for Goal Plots and Capability Box Plots” on page 311.

The mean shift and the standard deviation standardized to the specification limits for the \( j \)th column are defined as follows:

\[ \text{Mean Shift Standardized to Spec} = \frac{\bar{Y}_j - T_j}{2 \times \min(T_j - LSL_j, USL_j - T_j)} \]
Std Dev Standardized to Spec = \( \frac{SD(Y_j)}{2 \times \min(T_j - LSL_j, USL_j - T_j)} \)

**Note:** If either LSL\(_j\) or USL\(_j\) is missing, twice the distance from the target to the nonmissing specification limit is used in the denominators of the Goal Plot coordinates.

**Goal Plot Points for Processes with Missing Targets**

Suppose that the process has both a lower and an upper specification limit but no target. Then the formulas given in “Goal Plot” on page 311 are used, replacing \( T_j \) with the midpoint of the two specification limits.

Suppose that the process has only one specification limit and no target. To obtain \((x, y)\) coordinates for a point on the Goal Plot, the capability indices of the process are used. (See “Capability Indices for Normal Distributions” on page 314 for definitions in terms of the theoretical mean and standard deviation.) For sample observations, the following relationships hold:

\[
C_{pu} = \frac{USL_j - \bar{Y}_j}{3SD(Y_j)}
\]

\[
C_{pl} = \frac{\bar{Y}_j - LSL_j}{3SD(Y_j)}
\]

If a process has two specification limits and a target at the midpoint of the limits, then the \((x, y)\) coordinates for the point on the Goal Plot satisfy these relationships:

\[
C_{pu} = \frac{(0.5 - x)}{3y}
\]

\[
C_{pl} = \frac{(0.5 + x)}{3y}
\]

To obtain coordinates when there is only one specification limit and no target, these relationships are used. To identify a unique point requires an assumption about the slope of the line from the origin on which the points fall. A slope of 0.5 is assumed for the case of an upper specification limit and of -0.5 for a lower specification limit. When capability values are equal to one and the Ppk slider for the goal plot triangle is set to 1, these slopes place the points on the goal plot triangle lines.

Consider the case of only an upper specification limit and no target. Using the assumption that the \((x, y)\) coordinates fall on a line from the origin with slope 0.5, solving for \(x\) and \(y\) gives the following coordinates:
Consider the case of only a lower specification limit and no target. Using the assumption that the \((x,y)\) coordinates fall on a line from the origin with slope \(-0.5\), solving for \(x\) and \(y\) gives the following coordinates:

\[
\begin{align*}
  x &= -1/(3C_{pl} + 2) \\
  y &= 1/(6C_{pl} + 4)
\end{align*}
\]

**Note:** If either \(C_{pu}\) or \(C_{pl}\) is less than -0.6, then it is set to -0.6 in the formulas above. At the value \(-2/3\), the denominator for \(x\) assumes the value 0. Bounding the capability values at -0.6 prevents the denominator from assuming the value 0 or switching signs.

### Capability Box Plots for Processes with Missing Targets

A column with no target can have both upper and lower specification limits, or only a single specification limit. This section uses the notation defined in “Notation for Goal Plots and Capability Box Plots” on page 311.

#### Two Specification Limits and No Target

When no target is specified for the \(j^\text{th}\) column, the capability box plot is based on the following values for the transformed observations:

\[
Z_{ij} = \frac{Y_{ij} - (LSL_j + USL_j)/2}{USL_j - LSL_j}
\]

#### Single Specification Limit and No Target

Suppose that only the lower specification limit is specified. (The case where only the upper specification limit is specified in a similar way.)

When no target is specified for the \(j^\text{th}\) column, the capability box plot is based on the following values for the transformed observations:

\[
Z_{ij} = \frac{Y_{ij} - \overline{Y}_j}{2(\overline{Y}_j - LSL_j)}
\]
Note: When a column has only one specification limit and no target value, and the sample mean falls outside the specification interval, no capability box plot for that column is plotted.

**Capability Indices for Normal Distributions**

This section provides details about the calculation of capability indices for normal data.

For a process characteristic with mean $\mu$ and standard deviation $\sigma$, the population-based capability indices are defined as follows. For sample observations, the parameters are replaced by their estimates:

\[
C_p = \frac{USL - LSL}{6\sigma}
\]

\[
C_{pl} = \frac{\mu - LSL}{3\sigma}
\]

\[
C_{pu} = \frac{USL - \mu}{3\sigma}
\]

\[
C_{pk} = \min(C_{pl}, C_{pu})
\]

\[
C_{pm} = \frac{\min(T - LSL, USL - T)}{3\sigma \sqrt{1 + \left(\frac{T - \mu}{\sigma}\right)^2}}
\]

The formulas use the following notation:

$LSL$ = Lower specification limit

$USL$ = Upper specification limit

$T$ = Target value

For estimates of Within Sigma capability, $\sigma$ is estimated using the subgrouping method that you specified. For estimates of Overall Sigma capability, $\sigma$ is estimated using the sample standard deviation. If either of the specification limits is missing, the capability indices containing the missing specification limit are reported as missing.

Note: With the default AIAG (Ppk) Labeling, the indices based on Overall Sigma are denoted by Pp, Ppl, Ppu, and Ppk. The labeling for the index Cpm does not change when Overall Sigma is used. The formulas in this section are defined using Cp labels.
Confidence Intervals for Capability Indices

Confidence intervals for capability indices are available only for processes with normal distributions. Confidence intervals are calculated for both Within and Overall Sigma capability and are shown in the Individuals Detail Reports.

Cp

The 100(1 - \(\alpha\))% confidence interval for Cp is calculated as follows:

\[
\left( \hat{C}_p \sqrt{\frac{\chi^2_{\alpha/2, df}}{df}}, \hat{C}_p \sqrt{\frac{\chi^2_{1 - \alpha/2, df}}{df}} \right)
\]

where

\(\hat{C}_p\) is the estimated value for Cp

\(\chi^2_{\alpha/2, df}\) is the (\(\alpha/2\))th quantile of a chi-square distribution with \(df\) degrees of freedom

\(df\) is the degrees of freedom

\(N\) is the number of observations

For Overall Sigma capability, the degrees of freedom is equal to \(N - 1\).

For Within Sigma capability with unbalanced subgroups, the degrees of freedom is equal to \(N - m\), where \(m\) is the number of subgroups.

For Within Sigma capability with balanced subgroups, the degrees of freedom calculation depends on the within sigma estimation method. When Within Sigma is estimated by the average of the unbiased standard deviations, \(N - m\) is multiplied by a scale factor between 0.875 and 1. See Bissell (1990). When Within Sigma is estimated by the average of ranges, the degrees of freedom is calculated using a formula based on the subgroup sample size. See David (1951).

Cpk

The 100(1 - \(\alpha\))% confidence interval for Cpk is calculated as follows:

\[
\left( \hat{C}_{pk} \left[ 1 - \Phi^{-1}_1 - \frac{\alpha}{2} \left( \frac{1}{9N\hat{C}_{pk}^2} + \frac{1}{2df} \right) \right], \hat{C}_{pk} \left[ 1 + \Phi^{-1}_1 - \frac{\alpha}{2} \left( \frac{1}{9N\hat{C}_{pk}^2} + \frac{1}{2df} \right) \right] \right)
\]

where

\(\hat{C}_{pk}\) is the estimated value for Cpk
\( \Phi^{-1}_{1 - \alpha/2} \) is the \((1 - \alpha/2)\)th quantile of a standard normal distribution

\( N \) is the number of observations

\( df \) is the degrees of freedom

For Overall Sigma capability, the degrees of freedom is equal to \( N - 1 \).

For Within Sigma capability with unbalanced subgroups, the degrees of freedom is equal to \( N - m \), where \( m \) is the number of subgroups.

For Within Sigma capability with balanced subgroups, the degrees of freedom calculation depends on the within sigma estimation method. When Within Sigma is estimated by the average of the unbiased standard deviations, \( N - m \) is multiplied by a scale factor between 0.875 and 1. See Bissell (1990). When Within Sigma is estimated by the average of ranges, the degrees of freedom is calculated using a formula based on the subgroup sample size. See David (1951).

**Cpm**

**Note:** The confidence interval for Cpm is computed only when the target value is centered between the lower and upper specification limits.

The 100(1 - \( \alpha \))% confidence interval for Cpm is calculated as follows:

\[
\left( \hat{Cpm} \pm \frac{2}{\sqrt{N}} \chi_{\alpha/2, \gamma} , \hat{Cpm} \pm \frac{2}{\sqrt{N}} \chi_{1 - \alpha/2, \gamma} \right)
\]

where

\( \hat{Cpm} \) is the estimated value for Cpm

\( \chi_{\alpha/2, \gamma} \) is the \((\alpha/2)\)th quantile of a chi-square distribution with \( \gamma \) degrees of freedom

\[
\gamma = \frac{N\left(1 + \left(\frac{\bar{x} - T}{s}\right)^2\right)^2}{1 + 2\left(\frac{\bar{x} - T}{s}\right)^2}
\]

\( N \) is the number of observations

\( \bar{x} \) is the mean of the observations

\( T \) is the target value

\( s \) is the sigma estimate
For Overall Sigma capability, \( s \) is the Overall Sigma estimate. For Within Sigma capability, \( s \) is replaced by the Within Sigma estimate.

Tip: For more information on confidence intervals for \( \text{Cp}, \text{Cpk}, \) and \( \text{Cpm} \), see Pearn and Kotz (2006).

**Cpl and Cpu**

Lower and upper confidence limits for Cpl and Cpu are computed using the method of Chou et al. (1990).

The 100(1 - \( \alpha \))% confidence limits for Cpl (denoted by CPL\( _L \) and CPL\( _U \)) satisfy the following equations:

\[
\Pr \left[ t_{n-1} (\delta_L) \geq 3 \hat{C}_{pl} \sqrt{n} \right] = \frac{\alpha}{2} \quad \text{where} \quad \delta_L = 3 \text{CPL}_L \sqrt{n}
\]

\[
\Pr \left[ t_{n-1} (\delta_U) \leq 3 \hat{C}_{pl} \sqrt{n} \right] = \frac{\alpha}{2} \quad \text{where} \quad \delta_U = 3 \text{CPL}_U \sqrt{n}
\]

where

- \( t_{n-1}(\delta) \) has a non-central \( t \)-distribution with \( n - 1 \) degrees of freedom and noncentrality parameter \( \delta \)
- \( \hat{C}_{pl} \) is the estimated value for Cpl

The 100(1 - \( \alpha \))% confidence limits for Cpu (denoted by CPU\( _L \) and CPU\( _U \)) satisfy the following equations:

\[
\Pr \left[ t_{n-1} (\delta_L) \geq 3 \hat{C}_{pu} \sqrt{n} \right] = \frac{\alpha}{2} \quad \text{where} \quad \delta_L = 3 \text{CPU}_L \sqrt{n}
\]

\[
\Pr \left[ t_{n-1} (\delta_U) \leq 3 \hat{C}_{pu} \sqrt{n} \right] = \frac{\alpha}{2} \quad \text{where} \quad \delta_U = 3 \text{CPU}_U \sqrt{n}
\]

where

- \( t_{n-1}(\delta) \) has a non-central \( t \)-distribution with \( n - 1 \) degrees of freedom and noncentrality parameter \( \delta \)
- \( \hat{C}_{pu} \) is the estimated value for Cpu

**Capability Indices for Nonnormal Distributions: Percentile and Z-Score Methods**

This section describes how capability indices are calculated for nonnormal distributions. Two methods are described: the Percentile (also known as ISO/Quantile) method and the Z-Score (also known as Bothe/Z-scores) method. When you select a distribution for a nonnormal
process variable, you can fit a parametric distribution or a nonparametric distribution. You can use either the Percentile or the Z-Score methods to calculate capability indices for the process variable of interest. However, unless you have a very large amount of data, a nonparametric fit might not accurately reflect behavior in the tails of the distribution.

**Note:** For both the Percentile and the Z-Score methods, if the data are normally distributed, the capability formulas reduce to the formulas for normality-based capability indices.

The descriptions of the two methods use the following notation:

- \( LSL \) = Lower specification limit
- \( USL \) = Upper specification limit
- \( T \) = Target value

**Percentile (ISO/Quantile) Method**

The percentile method replaces the mean in the standard capability formulas with the median of the fitted distribution and the 6\( \sigma \) range of values with the corresponding percentile range. The method is described in AIAG (2005).

Denote the \( \alpha \times 100^{th} \) percentile of the fitted distribution by \( P_{\alpha} \). Then Percentile method capability indices are defined as follows:

\[
P_{pk} = \min\left( \frac{P_{0.5} - LSL}{P_{0.5} - P_{0.00135}}, \frac{USL - P_{0.5}}{P_{0.99865} - P_{0.5}} \right)
\]

\[
P_{pl} = \frac{P_{0.5} - LSL}{P_{0.5} - P_{0.00135}}
\]

\[
P_{pu} = \frac{USL - P_{0.5}}{P_{0.99865} - P_{0.5}}
\]

\[
P_{p} = \frac{USL - LSL}{P_{0.99865} - P_{0.00135}}
\]

\[
C_{pm} = \sqrt{\frac{1}{1 + \left( \frac{P_{0.5} - P_{0.00135}}{P_{0.99865} - P_{0.5}} \right)^2}}
\]

\[
1 + \left( \frac{\mu - T}{\sigma} \right)^2
\]
Z-Score (Bothe/Z-Scores) Method

The Z-Score method transforms the specification limits to values that have the same probabilities on a standard normal scale. It computes capability measures that correspond to a normal distribution with the same risk levels as the fitted nonnormal distribution.

Let $F$ denote the fitted distribution for a process variable with lower and upper specification limits given by LSL and USL. Define equivalent standard normal specification limits as follows:

$$
\begin{align*}
LSL_F &= \Phi^{-1}(F(LSL)) \\
USL_F &= \Phi^{-1}(F(USL))
\end{align*}
$$

Then the Z-Score method capability indices are defined as follows:

$$
\begin{align*}
P_{pk} &= \min(-LSL_F/3, USL_F/3) \\
P_{pl} &= -LSL_F/3 \\
P_{pu} &= USL_F/3 \\
P_p &= (USL_F - LSL_F)/6
\end{align*}
$$

**Note:** Because Cpm is a target-based measure, it cannot be calculated using the Z-Scores method.

**Note:** For very capable data, $F(LSL)$ or $F(USL)$ can be so close to zero or one, respectively, that $LSL_F$ or $USL_F$ cannot be computed. In these cases, JMP automatically switches from the Z-Score method to the Percentile method by default. This gives more meaningful capability indices. To turn off this default setting, select File > Preferences > Platforms > Process Capability.

Parameterizations for Distributions

This section gives the density functions $f$ for the distributions used in the Process Capability platform. It also gives expected values and variances for all but the Johnson distributions.
Normal

\[ f(x|\mu, \sigma) = \frac{1}{\sigma \sqrt{2\pi}} \exp\left[-\frac{1}{2\sigma^2}(x - \mu)^2\right], \quad -\infty < x < \infty, \quad -\infty < \mu < \infty, \quad \sigma > 0 \]

\[ E(X) = \mu \]

\[ \text{Var}(X) = \sigma^2 \]

Beta

\[ f(x|\alpha, \beta) = \frac{1}{B(\alpha, \beta)} x^{\alpha-1}(1-x)^{\beta-1}, \quad 0 \leq x \leq 1, \quad \alpha > 0, \quad \beta > 0 \]

\[ E(X) = \frac{\alpha}{\alpha + \beta} \]

\[ \text{Var}(X) = \frac{\alpha\beta}{(\alpha + \beta)^2(\alpha + \beta + 1)} \]

where \( B(\cdot) \) is the Beta function.

Exponential

\[ f(x|\sigma) = \frac{1}{\sigma} \exp(-x/\sigma), \quad x > 0, \quad \sigma > 0 \]

\[ E(X) = \sigma \]

\[ \text{Var}(X) = \sigma^2 \]

Gamma

\[ f(x|\alpha, \sigma) = \frac{1}{\Gamma(\alpha)\sigma^\alpha} x^{\alpha-1} \exp(-x/\sigma), \quad x > 0, \quad \alpha > 0, \quad \sigma > 0 \]

\[ E(X) = \alpha\sigma \]

\[ \text{Var}(X) = \alpha\sigma^2 \]

where \( \Gamma(\cdot) \) is the gamma function.

Johnson

**Johnson Su**

\[ f(x|\gamma, \delta, \sigma, \theta) = \frac{\delta}{\sigma} \left[1 + \left(\frac{x - \theta}{\sigma}\right)^2\right]^{-1/2} \exp\left[\gamma + \delta \sinh^{-1}\left(\frac{x - \theta}{\sigma}\right)\right], \quad -\infty < x, \theta, \gamma < \infty, \quad \theta > 0, \quad \delta > 0 \]
Johnson Sb

\[ f(x|\gamma, \delta, \sigma, \theta) = \phi \left[ \gamma + \delta \ln \left( \frac{x - \theta}{\sigma - (x - \theta)} \right) \right] \left( \frac{\delta \sigma}{(x - \theta)(\sigma - (x - \theta))} \right), \theta < x < \theta + \sigma, \sigma > 0 \]

Johnson SI

\[ f(x|\gamma, \delta, \sigma, \theta) = \frac{\delta}{|x - \theta|} \phi \left[ \gamma + \delta \ln \left( \frac{x - \theta}{\sigma} \right) \right], \text{for } x > \theta \text{ if } \sigma = 1, x < \theta \text{ if } \sigma = -1 \]

where \( \phi(\cdot) \) is the standard normal probability density function.

Lognormal

\[ f(x|\mu, \sigma) = \frac{1}{\sigma \sqrt{2\pi}} \exp \left( -\frac{(\log(x) - \mu)^2}{2\sigma^2} \right), x > 0, -\infty < \mu < \infty, \sigma > 0 \]

\[ \text{E}(X) = \exp(\mu + \sigma^2/2) \]

\[ \text{Var}(X) = \exp(2(\mu + \sigma^2)) - \exp(2\mu + \sigma^2) \]

Mixture of Normals

The Mixture of 2 Normals and Mixture of 3 Normals options for Distribution share the following parameterization:

\[ f(x|\mu_i, \sigma_i, \pi_i) = \sum_{i=1}^{k} \frac{\pi_i}{\sigma_i} \phi \left( \frac{x - \mu_i}{\sigma_i} \right) \]

\[ \text{E}(X) = \sum_{i=1}^{k} \pi_i \mu_i \]

\[ \text{Var}(X) = \sum_{i=1}^{k} \pi_i (\mu_i^2 + \sigma_i^2) - \left( \sum_{i=1}^{k} \pi_i \mu_i \right)^2 \]

where \( \mu_i, \sigma_i, \text{ and } \pi_i \) are the respective mean, standard deviation, and proportion for the \( i^{th} \) group, and \( \phi(\cdot) \) is the standard normal probability density function. For the Mixture of 2 Normals, \( k \) is equal to 2. For the Mixture of 3 Normals distribution, \( k \) is equal to 3. A separate mean, standard deviation, and proportion of the whole is estimated for each group in the mixture.
Weibull

\[ f(x | \alpha, \beta) = \frac{\beta}{\alpha^\beta} x^{\beta-1} \exp \left[ -\left( \frac{x}{\alpha} \right)^\beta \right], \quad \alpha > 0, \beta > 0 \]

\[ E(X) = \alpha \Gamma \left( 1 + \frac{1}{\beta} \right) \]

\[ \text{Var}(X) = \alpha^2 \left\{ \Gamma \left( 1 + \frac{2}{\beta} \right) - \Gamma^2 \left( 1 + \frac{1}{\beta} \right) \right\} \]

where \( \Gamma(\cdot) \) is the gamma function.
Chapter 12
Pareto Plots
Focus Improvement Efforts on the Vital Few

Improve the statistical quality of your process or operation using Pareto plots. A Pareto plot is a chart that shows severity (frequency) of problems in a quality-related process or operation. Pareto plots help you decide which problems to solve first by highlighting the frequency and severity of problems.

**Figure 12.1** Pareto Plot Examples
## Contents

- Overview of the Pareto Plot Platform ............................................. 325
- Example of the Pareto Plot Platform ........................................... 325
- Launch the Pareto Plot Platform .................................................. 328
- The Pareto Plot Report ................................................................. 329
- Pareto Plot Platform Options ....................................................... 330
  - Causes Options ................................................................. 332
- Additional Examples of the Pareto Plot Platform ......................... 332
  - Threshold of Combined Causes Example ................................. 333
  - Using a Constant Size across Groups Example ....................... 334
  - Using a Non-Constant Sample Size across Groups Example .... 335
  - One-Way Comparative Pareto Plot Example ............................ 337
  - Two-Way Comparative Pareto Plot Example ............................ 339
- Statistical Details for the Pareto Plot Platform .......................... 340
  - Likelihood Ratio Chi-Square Test ........................................... 340
Overview of the Pareto Plot Platform

The Pareto Plot platform produces charts to display the relative frequency or severity of problems in a quality-related process or operation. The Pareto plot is displayed initially as a bar chart that shows the classification of problems arranged in decreasing order. The column whose values are the cause of a problem is assigned the Y role and is called the *process variable*. You can also generate a comparative Pareto plot, which combines two or more Pareto plots for the same process variable. The single display shows plots for each value in a column assigned the X role, or combination of levels from two X variables. Columns assigned the X role are called *classification variables*.

The Pareto plot can chart a single Y (process) variable with no X classification variables, with a single X, or with two X variables. The Pareto function does not distinguish between numeric and character variables or between modeling types. You can switch between a bar chart and a pie chart. All values are treated as discrete, and bars or wedges represent either counts or percentages.

Example of the Pareto Plot Platform

This example uses the Failure.jmp sample data table, which contains failure data and a frequency column. It lists causes of failure during the fabrication of integrated circuits and the number of times each type of defect occurred. From the analysis, you can determine which factors contribute most toward process failure.

1. Select Help > Sample Data Library and open Quality Control/Failure.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
3. Select failure and click Y, Cause.
   This column lists the causes of failure. It is the variable that you want to inspect.
4. Select N and click Freq.
   This column list the number of times that each type of failure occurred.
5. Click OK.
The left axis represents the count of failures, and the right axis represents the percent of failures in each category. The bars are in decreasing order with the most frequently occurring failure to the left. The curve indicates the cumulative failures from left to right.

6. Select **Label Cum Percent Points** from the red triangle menu next to Pareto Plot.

   Note that Contamination accounts for approximately 45% of the failures. The point above the Oxide Defect bar shows that Contamination and Oxide Defect together account for approximately 71% of the failures.

7. From the red triangle menu, deselect **Label Cum Percent Points** and **Show Cum Percent Curve**.

8. Click on the label for the y-axis labeled N and rename it **Count**.

9. Double-click the y-axis to display the **Y Axis Settings** window.
   - In the **Maximum** field, type 15.
   - In the **Increment** field, type 2.
   - In the **Axis Label Row** panel, select **Grid Lines** for the **Major** grid line.
   - Click **OK**.

10. From the red triangle menu, select **Category Legend**.
Figure 12.3 Pareto Plot with Display Options

Figure 12.3 shows the counts of different types of failures and has a category legend. The vertical count axis is rescaled and has grid lines at the major tick marks.

11. To view the data as a pie chart, select Pie Chart from the red triangle menu.

Figure 12.4 Pareto Plot as a Pie Chart

Contamination and Oxide Defect clearly represent the majority of the failures.
Launch the Pareto Plot Platform

Launch the Pareto Plot platform by selecting Analyze > Quality and Process > Pareto Plot.

**Figure 12.5 The Pareto Plot Launch Window**

The Pareto Plot launch window contains the following options:

- **Y, Cause**: Identifies the column whose values are the cause of a problem. It is called the process variable and is the variable that you want to inspect.

- **X, Grouping**: Identifies the grouping factor. The grouping variable produces one Pareto plot window with side-by-side plots for each value. You can have no grouping variable, one grouping variable (see “One-Way Comparative Pareto Plot Example” on page 337), or two grouping variables (see “Two-Way Comparative Pareto Plot Example” on page 339).

- **Weight**: Assigns a variable to give the observations different weights.

- **Freq**: Identifies the column whose values hold the frequencies.

- **By**: Identifies a variable to produce a separate analysis for each value that appears in the column.

- **Threshold of Combined Causes**: Enables you to specify a threshold for combining causes by specifying a minimum rate or count. Select the option and then select Tail % or Count and enter the threshold value. The Tail percent option combines smaller count groups against the percentage specified of the total (combined small groups count/total group count). The Count option enables you to specify a specific count threshold. For an example, see “Threshold of Combined Causes Example” on page 333.

- **Per Unit Analysis**: Enables you to compare defect rates across groups. JMP calculates the defect rate as well as 95% confidence intervals of the defect rate. Select the option and then select Constant or Value in Freq Column and enter the sample size value or cause code, respectively. The Constant option enables you to specify a constant sample size on the
launch window. The Value In Freq Column option enables you to specify a unique sample size for a group through a special cause code to designate the rows as cause rows.

Although causes are allowed to be combined in Pareto plots, the calculations for these analyses do not change correspondingly.

For examples, see “Using a Constant Size across Groups Example” on page 334 and “Using a Non-Constant Sample Size across Groups Example” on page 335.

The Pareto Plot Report

The Pareto plot combines a bar chart displaying percentages of variables in the data with a line graph showing cumulative percentages of the variables.

Figure 12.6 Pareto Plot Example

The Pareto plot can chart a single \( Y \) (process) variable with no \( X \) classification variables, with a single \( X \), or with two \( X \) variables. The Pareto plot does not distinguish between numeric and character variables or between modeling types. All values are treated as discrete, and bars represent either counts or percentages. The following list describes the arrangement of the Pareto plot:

- A \( Y \) variable with no \( X \) classification variables produces a single chart with a bar for each value of the \( Y \) variable. For an example, see “Example of the Pareto Plot Platform” on page 325.
• A $Y$ variable with one $X$ classification variable produces a row of Pareto plots. There is a plot for each level of the $X$ variable with bars for each $Y$ level. These plots are referred to as the *cells* of a comparative Pareto plot. There is a cell for each level of the $X$ (classification) variable. Because there is only one $X$ variable, this is called a *one-way comparative Pareto plot*. For an example, see “One-Way Comparative Pareto Plot Example” on page 337.

• A $Y$ variable with two $X$ variables produces rows and columns of Pareto plots. There is a row for each level of the first $X$ variable and a column for each level of the second $X$ variable. Because there are two $X$ variables, this is called a *two-way comparative Pareto plot*. The rows have a Pareto plot for each value of the first $X$ variable, as described previously. The upper left cell is called the *key cell*. Its bars are arranged in descending order. The bars in the other cells are in the same order as the key cell. You can reorder the rows and columns of cells. The cell that moves to the upper left corner becomes the new key cell and the bars in all other cells rearrange accordingly. For an example, see “Two-Way Comparative Pareto Plot Example” on page 339.

• Each bar is the color for which the rows for that $Y$ level are assigned in the associated data table. Otherwise, a single color is used for all of the bars whose $Y$ levels do not have rows with an assigned color. If the rows for a $Y$ level have different colors, the bar for that $Y$ level is the color of the first row for that $Y$ level in the data table.

You can change the type of scale and arrangement of bars and convert the bars into a pie chart using the options in the Pareto Plot red triangle menu. For more information, see “Pareto Plot Platform Options” on page 330.

### Pareto Plot Platform Options

The red triangle menu next to Pareto Plot has commands that customize the appearance of the plots. It also has options in the *Causes* submenu that affect individual bars within a Pareto plot. The following commands affect the appearance of the Pareto plot as a whole:

- **Percent Scale**  Shows or hides the count and percent left vertical axis display.
- **N Legend**  Shows or hides the total sample size in the plot area.
- **Category Legend**  Shows or hides labeled bars and a separate category legend.
- **Pie Chart**  Shows or hides the bar chart and pie chart representation.
- **Reorder Horizontal, Reorder Vertical**  Reorders grouped Pareto plots when there is one or more grouping variables.
- **Ungroup Plots**  Splits up a group of Pareto charts into separate plots.
Count Analysis  Performs defect per unit analyses. Enables you to compare defect rates and perform ratio tests across and within groups:

Per Unit Rates  Compares defect rates across groups. If a sample size is specified, Defects Per Unit (DPU) and Parts Per Million (PPM) columns are added to the report.

Test Rate Within Groups  Performs a likelihood ratio Chi-square test to determine whether the rates across causes are the same within a group. For details, see “Statistical Details for the Pareto Plot Platform” on page 340.

Test Rates Across Groups  Performs a likelihood ratio Chi-square test to determine whether the rate for each cause is the same across groups. For details, see “Statistical Details for the Pareto Plot Platform” on page 340.

Show Cum Percent Curve  Shows or hides the cumulative percent curve above the bars and the cumulative percent axis on the vertical right axis.

Show Cum Percent Axis  Shows or hides the cumulative percent axis on the vertical right axis.

Show Cum Percent Points  Shows or hides the points on the cumulative percent curve.

Label Cum Percent Points  Shows or hides the labels on the points on the cumulative curve.

Cum Percent Curve Color  Changes the color of the cumulative percent curve.

Causes  Has options that affect one or more individual chart bars. See “Causes Options” on page 332, for a description of these options.

See the JMP Reports chapter in the Using JMP book for more information about the following options:

Local Data Filter  Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.
Causes Options

You can highlight a bar by clicking on it. Use Control-click to select multiple bars that are not contiguous. When you select bars, you can access the commands on the red triangle menu that affect Pareto plot bars. They are found on the Causes submenu on the red triangle menu. These options are also available with a right-click anywhere in the plot area. The following options apply to highlighted bars instead of to the chart as a whole:

**Combine Causes**  Combines selected (highlighted) bars. You can select either Selected, Last Causes, First Causes or select from a list of variables as shown in Figure 12.7.

**Figure 12.7** Combine Causes Window

Separate Causes  Separates selected bars into their original component bars.

**Move to First**  Moves one or more highlighted bars to the left (first) position.

**Move to Last**  Moves one or more highlighted bars to the right (last) position.

Colors  Shows the colors palette for coloring one or more highlighted bars.

Markers  Shows the markers palette for assigning a marker to the points on the cumulative percent curve, when the Show Cum Percent Points command is in effect.

**Label**  Displays the bar value at the top of all highlighted bars.

Additional Examples of the Pareto Plot Platform

- “Threshold of Combined Causes Example”
- “Using a Constant Size across Groups Example”
- “Using a Non-Constant Sample Size across Groups Example”
- “One-Way Comparative Pareto Plot Example”
“Two-Way Comparative Pareto Plot Example”

Threshold of Combined Causes Example

This example uses the Failure.jmp sample data table, which contains failure data and a frequency column. It lists causes of failure during the fabrication of integrated circuits and the number of times each type of defect occurred. A threshold value of 2 is specified for this example.

1. Select Help > Sample Data Library and open Quality Control/Failure.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
3. Select failure and click Y, Cause.
4. Select N and click Freq.
5. Select Threshold of Combined Causes and then select Count.
6. Enter 2 as the threshold value.
7. Click OK.

Figure 12.8 Pareto Plot with a Threshold Count of 2

Figure 12.8 displays the plot after specifying a count of 2. All causes with counts 2 or fewer are combined into the final bar labeled 4 Others.

8. To separate the combined bars into original categories as shown in Figure 12.9, select Causes > Separate Causes.
Using a Constant Size across Groups Example

This example uses the Failures.jmp sample data table, which contains failure data and a frequency column. It lists causes of failure during the fabrication of integrated circuits and the number of times each type of defect occurred for two processes. A constant sample size of 1000 is specified for this example.

1. Select **Help > Sample Data Library** and open Quality Control/Failures.jmp.
2. Select **Analyze > Quality and Process > Pareto Plot**.
3. Select Causes and click **Y, Cause**.
4. Select Process and click **X, Grouping**.
5. Select Count and click **Freq**.
6. Select **Per Unit Analysis** and then select **Constant**.
7. Enter **1000** in **Sample Size**.
8. Click **OK**.
Figure 12.10 Pareto Plot Report Window

Process A indicates Contamination as the top failure while Process B indicates Oxide Defect as the leading failure.

9. Select Count Analysis > Test Rates Across Groups from the red triangle menu.

Figure 12.11 Test Rates across Groups Results

Note that the DPU for Contamination across groups (Process A and B) is around 0.06.

Using a Non-Constant Sample Size across Groups Example

This example uses the Failuresize.jmp sample data table, which contains failure data and a frequency column. It lists causes of failure during the fabrication of integrated circuits and the number of times each type of defect occurred for two processes. Among the other causes
(Oxide Defect, Silicon Defect, and so on) is a cause labeled size. Specifying size as the cause code designates the rows as size rows.

1. Select Help > Sample Data Library and open Quality Control/Failures/size.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
4. Select Process and click X, Grouping.
5. Select Count and click Freq.
6. Select Per Unit Analysis and then select Value in Freq Column.
7. Enter size in Cause Code.
8. Click OK.

Figure 12.12 Pareto Plot Report Window

9. Select Count Analysis > Per Unit Rates and Count Analysis > Test Rates Across Groups from the red triangle menu.
Figure 12.13 Per Unit Rates and Test Rates across Groups Results

Note that the sample size of 101 is used to calculate the DPU for the causes in group A. However, the sample size of 145 is used to calculate the DPU for the causes in group B. If there are two group variables (say, Day and Process), Per Unit Rates lists DPU or rates for every combination of Day and Process for each cause. However, Test Rate Across Groups only tests overall differences between groups.

One-Way Comparative Pareto Plot Example

This example uses the Failure2.jmp sample data table. This table records failures in a sample of capacitors manufactured before cleaning a tube in the diffusion furnace and in a sample manufactured after cleaning the furnace. For each type of failure, the variable clean identifies the samples with the values “before” or “after.”

1. Select Help > Sample Data Library and open Quality Control/Failure2.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
3. Select failure and click Y, Cause.
4. Select clean and click X, Grouping.
5. Select N and click Freq.
6. Click OK.
Figure 12.14 displays the side-by-side plots for each value of the variable, clean.

**Figure 12.14** One-way Comparative Pareto Plot

The horizontal and vertical axes are scaled identically for both plots. The bars in the first plot are in descending order of the \( y \)-axis values and determine the order for all cells.

1. Rearrange the order of the plots by clicking the title (after) in the first tile and dragging it to the title of the next tile (before).

A comparison of these two plots shows a reduction in oxide defects after cleaning. However, the plots are easier to interpret when presented as the before-and-after plot shown in Figure 12.15. Note that the order of the causes changes to reflect the order based on the first cell.
Figure 12.15 One-way Comparative Pareto Plot with Reordered Cells

![Figure 12.15 Pareto Plot]

Two-Way Comparative Pareto Plot Example

This example uses the Failure3.jmp sample data table. The data monitors production samples before and after a furnace cleaning for three days for a capacitor manufacturing process. The data table has a column called date with values OCT 1, OCT 2, and OCT 3.

1. Select Help > Sample Data Library and open Quality Control/Failure3.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
3. Select failure and click Y, Cause.
4. Select clean and date and click X, Grouping.
5. Select N and click Freq.
6. Click OK.

Figure 12.16 displays the Pareto plot with a two-way layout of plots that show each level of both X variables. The upper left cell is called the key cell. Its bars are arranged in descending order. The bars in the other cells are in the same order as the key cell.

7. Click Contamination and Metallization in the key cell and the bars for the corresponding categories highlight in all other cells.
The Pareto plot shown in Figure 12.16 illustrates highlighting the *vital few*. In each cell of the two-way comparative plot, the bars representing the two most frequently occurring problems are selected. Contamination and Metallization are the two vital categories in all cells. After furnace cleaning, Contamination is less of a problem.

**Statistical Details for the Pareto Plot Platform**

**Likelihood Ratio Chi-Square Test**

**Notation**

The likelihood ratio Chi-square test statistic computed in the Pareto Plot platform uses the following notation:

- \( n_{ij} \) is the count for Cause \( i \) in Group \( j \).
• $E_j$ is the expected count for Group $j$. This is the mean count of each group, across causes.
• $E_i$ is the expected count for Cause $i$. This is the mean count of each cause, across groups.

Likelihood Ratio Chi-Square Test Statistic within Groups

$$G_j^2 = 2 \sum_{i=1}^{K} n_{ij} \ln \left( \frac{n_{ij}}{E_j} \right)$$

Likelihood Ratio Chi-Square Test Statistic across Groups

$$G_i^2 = 2 \sum_{j=1}^{J} n_{ij} \ln \left( \frac{n_{ij}}{E_i} \right)$$
Use the Diagram platform to construct cause-and-effect diagrams, also known as *Ishikawa charts* or *fishbone charts*. Use these diagrams to:

- Organize the causes of an effect (sources of a problem)
- Brainstorm
- Identify variables in preparation for further experimentation

**Figure 13.1** Example of a Cause-and-Effect Diagram
Contents

Overview of Cause-and-Effect Diagrams ............................................................ 345
Example of a Cause-and-Effect Diagram .......................................................... 345
Prepare the Data ............................................................................................... 346
Launch the Diagram Platform ............................................................................ 346
The Cause-and-Effect Diagram ........................................................................ 347
  Right-Click Menus .......................................................................................... 347
Save the Diagram .............................................................................................. 350
  Save the Diagram as a Data Table ................................................................. 351
  Save the Diagram as a Journal ...................................................................... 351
  Save the Diagram as a Script ........................................................................ 351
Overview of Cause-and-Effect Diagrams

Use the Diagram platform to construct cause-and-effect diagrams, also known as *Ishikawa charts* or *fishbone charts*. Use these diagrams to:

- Organize the causes of an effect (sources of a problem)
- Brainstorm
- Identify variables in preparation for further experimentation

Example of a Cause-and-Effect Diagram

You have data about defects in a circuit board. You want to examine the major factors and possible causes of the defects in a diagram.

1. Select *Help > Sample Data Library* and open *Ishikawa.jmp*.
2. Select *Analyze > Quality and Process > Diagram*.
3. Select Parent and click *X, Parent*.
4. Select Child and click *Y, Child*.
5. Click *OK*.

*Figure 13.2  Ishikawa.jmp Diagram*

The major factors are Inspection, Solder process, Raw card, Components, and Component insertion. From each major factor, possible causes branch off, such as Inspection, Measurement, and Test coverage for the Inspection factor.

You can focus on one area at a time to further examine the possible causes or sources of variation for each major factor.
Prepare the Data

Before you produce the diagram, begin with your data in two columns of a data table.

**Figure 13.3** Example of the Ishikawa.jmp Data Table

<table>
<thead>
<tr>
<th>Parent</th>
<th>Child</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Defects in circuit board</td>
<td>Inspection</td>
</tr>
<tr>
<td>2 Defects in circuit board</td>
<td>Solder process</td>
</tr>
<tr>
<td>3 Defects in circuit board</td>
<td>Raw card</td>
</tr>
<tr>
<td>4 Defects in circuit board</td>
<td>Components</td>
</tr>
<tr>
<td>5 Defects in circuit board</td>
<td>Component insertion</td>
</tr>
<tr>
<td>6 Inspection</td>
<td>Measurement</td>
</tr>
<tr>
<td>7 Inspection</td>
<td>Test coverage</td>
</tr>
<tr>
<td>8 Inspection</td>
<td>Inspector</td>
</tr>
<tr>
<td>9 Solder process</td>
<td>Splatter</td>
</tr>
<tr>
<td>10 Solder process</td>
<td>Flux</td>
</tr>
<tr>
<td>11 Solder process</td>
<td>Chain speed</td>
</tr>
<tr>
<td>12 Solder process</td>
<td>Temperature</td>
</tr>
<tr>
<td>13 Solder process</td>
<td>Wave pump</td>
</tr>
<tr>
<td>14 Temperature</td>
<td>Setup</td>
</tr>
</tbody>
</table>

Notice that the Parent value Defects in circuit board (the effect) has five major factors, listed in the Child column. One of these major factors is Inspection, which has its own causes listed in the Child column. Parent values have children, and children can have their own children (and therefore be listed in both the Parent and Child columns.)

Launch the Diagram Platform

Launch the Diagram platform by selecting **Analyze > Quality And Process > Diagram**.

**Figure 13.4** The Diagram Launch Window
Tip: To create a basic diagram that is not based on a data table, leave the Y, Child, and X, Parent fields empty and click OK. Then edit the nodes using the options in the right-click menu. See “Right-Click Menus” on page 347.

**Y, Child**  Represents the child factors contributing to the parent factors.

**X, Parent**  Represents the parent factors (including the effect) that have child factors.

**Label**  Includes the text from the Label columns in the nodes of the diagram.

**By**  Produces separate diagrams for each value of the By variable.

### The Cause-and-Effect Diagram

In Figure 13.5, the effect or problem, Defects in circuit board, appears on the right as the center line. The major contributing factors appear at the end of the branches (Inspection, Solder process, Raw Card, and so on.) Possible causes branch off each major factor.

**Figure 13.5  Cause-and-Effect Diagram**

![Cause-and-Effect Diagram](image)

### Right-Click Menus

Right-click on a highlighted node to modify text, insert new nodes, change the diagram type, and more. Note the following:

- Right-click on a title to change the font and color, positioning, visibility, or formatting.
- Click and highlight a node to rename it.
- Click and drag a node to move it.

### Text Menu

The Text menu contains the following options:
Font  Select the font of the text or numeric characters.

Color  Select the color of the text or numeric characters.

Rotate Left, Rotate Right, Horizontal  Rotates the text or numbers to be horizontal, 90 degrees left, or 90 degrees right.

Insert Menu

Use the Insert menu to insert items onto existing nodes. The Insert menu contains the following options:

Before  Inserts a new node to the right of the highlighted node. For example, Figure 13.6 inserts Child 1.5 before Child 2.

Figure 13.6  Insert Before

After  Inserts a new node to the left of the highlighted node. For example, Figure 13.7 inserts Child 3 after Child 2.

Figure 13.7  Insert After

Above  Inserts a new node at a level above the current node. For example, Figure 13.8 inserts Grandparent at a level above Parent.

Figure 13.8  Insert Above

Below  Inserts a new node at a level below the current node. For example, Figure 13.9 inserts Grandchild at a level below Child 2.
Move Menu

Use the Move menu to move nodes or branches. The Move menu contains the following options:

**First**  Moves the highlighted node to the first position under its parent.

**Last**  Moves the highlighted node to the last position under its parent.

**Other Side**  Moves the highlighted node to the opposite side of its parent line.

**Force Left**  Makes all horizontally drawn elements appear to the left of their parent.

**Force Right**  Makes all horizontally drawn elements appear to the right of their parent.

**Force Up**  Makes all vertically drawn elements appear above their parent.

**Force Down**  Makes all vertically drawn elements appear below their parent.

**Force Alternate**  Draws children on alternate sides of the parent line.
Other Menu Options

The right-click menu for a highlighted node also contains these options:

- **Change Type**  Changes the entire chart type to **Fishbone**, **Hierarchy**, or **Nested**.
- **Uneditable**  Disables all other commands except **Move** and **Change Type**.
- **Text Wrap Width**  Specifies the width of labels where text wrapping occurs.
- **Make Into Data Table**  Converts the currently highlighted node into a data table. Convert the all nodes by highlighting the whole diagram (effect).
- **Close**  Shows the highlighted node.
- **Delete**  Deletes the highlighted node and all of its children.

Save the Diagram

There are different ways to save your diagram. Choose from one of the following:

- save the diagram as a data table
- save the diagram as a journal
- save the diagram as a script
Save the Diagram as a Data Table

Note the following about this approach:

- If you have other processes that need to update the data table, this can be a good approach to choose.
- Very little customization is available, because the data table cannot represent the customization.

*To save the diagram as a data table:*
1. Highlight the entire diagram.
2. Right-click and select Make Into Data Table.
3. Save the new data table.

Save the Diagram as a Journal

Note the following about this approach:

- This option can be a good choice for impromptu work. For example, you can manually build the diagram, save it as a journal, then reopen the journal later and continue building and editing the diagram.
- Any customization exists only in the journal, and the journal is not connected to the data table.

*To save the diagram as a journal:*
1. Highlight the entire diagram.
2. Right-click and select Edit > Journal.
3. Save the new journal.

Save the Diagram as a Script

Note the following about this approach:

- If you have other processes that need to update the data table, this can be a good approach to choose.
- If you created the diagram from a data table, a simple script appears that relaunches against the data table with no customization.
- If you created the diagram without using a data table (or from a journal), a more complex script appears that contains all the commands needed to add and customize each area of the diagram.
To save the diagram as a script:

1. From the red triangle menu, select **Save Script > To Script Window**.
2. Save the new script.
This appendix covers statistical details common to many of the platforms in the Analyze > Quality and Process menu. Specifically, the Manage Spec Limits utility is discussed.
Contents

Manager Spec Limits Utility ................................................................. 355
  Example of the Manage Spec Limits Utility ........................................... 355
Manager Spec Limits Options ............................................................... 357
Manage Spec Limits Utility

The Manage Spec Limits utility enables you to quickly add or edit many specification limits for several columns at once. The specification limits are then used in any future analyses. You can also specify if limits should appear in graphs as reference lines.

Example of the Manage Spec Limits Utility

1. Select Help > Sample Data Library and open Cities.jmp.
2. Select Analyze > Quality and Process > Manage Spec Limits.
3. Specify the columns you want to set specification limits on. For this example, select OZONE, CO, SO2, and NO, and click Process Variables.

Figure A.1 Specify Columns

4. Click OK.
5. Add your specification limits. You can do this by loading existing limits from a JMP data table (Load from Limits Table) or by entering limits manually. For this example, enter the following limits manually:
   - OZONE: LSL 0.12, USL 0.2
   - CO: LSL 6, USL 12
   - SO2: LSL 0.015, USL 0.06
   - NO: LSL 0.02, USL 0.04
6. From the red triangle next to Manage Spec Limits, select Show Limits All.
Specification limits for all columns will appear in graphs for any future analyses. If you want to show the specification limits only for individual columns, check the **Show Limits** box next to those columns.

**Figure A.2** Set Specification Limits

7. Choose how you want to save the specification limits. For this example, click **Save to Column Properties**. This saves them as column properties in the corresponding data table. You could also save them to a new data table (tall or wide format).

   In the Cities.jmp data table Columns panel, notice that asterisks indicating the Spec Limits column property appear next to OZONE, CO, SO2, and NO.

8. To see values that are outside the limits in the data table, from the red triangle next to Manage Spec Limits, select **Color Out of Spec Values**. Go to the Cities.jmp data table, and you can see that any values that are outside the limits are now colored.

9. Now, you can run any analysis. For this example, select **Analyze > Distribution**.

10. Select OZONE, CO, SO2, and NO, and click **Y, Columns**.

11. Click **OK**.
The specification limits that you added to the OZONE column appear in the histogram. Because the column contains a Spec Limits column property, the Distribution report also contains a Capability Analysis report.

**Manage Spec Limits Options**

In the window where you set specification limits, there are buttons to save and load specification limits, and options in the red triangle menu next to Manage Spec Limits.

**Buttons**

- **Load from Limits Table** Loads specification limits from a JMP data table.
**Save to Column Properties**  Saves the specification limits as column properties in the associated data table.

**Save to Spec Limits Table (Wide or Tall)**  Saves the specification limits to a new data table in a wide or tall format.

**Red Triangle Options**

**Show Limits All**  Selects boxes under Show Limits for all of the columns. If Show Limits is selected for a column, the Show as Graph Reference Lines option is selected in the Spec Limits column property. The Show as Graph Reference Lines option displays the specification limits and target that you specify as reference lines on appropriate plots.

**Note:** If all boxes under Show Limits are selected, the Show Limits All option deselects all of the boxes under Show Limits.

**Round Decimals**  Sets the number of decimal places to which you want the specification limits rounded.

**Color Out of Spec Values**  Colors any values in the data table that are outside the specification limits for the columns.

See the JMP Reports chapter in the *Using JMP* book for more information about the following options:

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.


Symbols
_LimitsKey 271

A
Add Dispersion Chart 49
Add Limits option 49
Agreement Comparisons 245
Agreement Counts 247
Agreement Report 245
Agreement within raters 245
Aluminum Pins Historical.jmp 171
Analysis Settings 194
Attribute data 239
Average Chart 194

B
Bayesian variance components 225
Bias and Interaction Impact 198
Bias Comparison 195
Bias Impact 198

C
Capability Analysis 94
   with Control Charts 101
Capability Index Notation, Process
   Capability 257
   capability indices
      nonnormal processes 256
      normal processes 255
Category Legend 330
cause-and-effect diagram 343
Causes 330–331
c-Chart 121
Chart Dispersion Options 193
classification variables 325
Colors 332
Combine Causes 332
   comparative Pareto chart 325, 330
Conformance Report 248
Connect Cell Means 220
Control Chart Builder
   deselect multiple tests 52
   example 67–69
   launch 43
   options 45–57
Control Charts
c 121
   Individual Measurement 38, 93
   Moving Average 38, 94
   Moving Range 93
p 120
R 38, 93
S 38, 93
u 121
   V-Mask Cusum 131–159
   XBar 38, 93
Count Analysis 331
Cum Percent Curve Color 331
   cumulative frequency chart 323
Customize Tests option 50
Cusum Control Charts 131–144

E
Effective Resolution 195
Effectiveness Report 246–247
EMP Gauge RR Results 195
EMP Results 195
EWMA 94

F
fishbone chart 343
frequency chart 323
frequency sort 323
### G
- Gauge R&R analysis: 215, 220, 225–228
- Gauge Std Dev: 222
- Gauge Studies: 221
- Get Limits:
  - Control Chart Builder: 47
  - Control Chart platform: 109
- Get Targets: 166
- Group Means of Std Dev: 221

### H
- Hotelling $T^2$ chart: 163

### I
- Import Spec Limits: 270
- Include Missing Categories: 47
- Individual Measurement: 93
- Individual Measurement Chart: 38, 93
- Individual Points option: 49
- Intraclass Correlation: 198
- Ishikawa diagram: 343

### K
- key cell: 330, 339

### L
- Label: 332
- Label Cum Percent Points: 331
- Levey-Jennings: 99
- Limits options: 49
- Linearity Study: 230

### M
- Markers: 332
- Mean Diamonds: 220
- Mean of Std Dev: 221
- Mean Plots: 222
- Measurement Systems Analysis (see MSA):
- Misclassification Probabilities: 229
- Model Type: 193
- Move to First: 332
- Move to Last: 332

### Moving Average Chart
- 38, 94

### Moving Range Chart
- 93

### MSA
- example: 189–192, 205–211
- launch: 192
- monitor classification legend: 198
- statistical details: 211

### MSA Method: 193
- multi vari chart: 215
- Multivariate Control Chart: 165–185
- multivariate control chart: 163

### N
- N Legend: 330
- New Y Chart: 44
- nonnormal distribution options, Process Capability: 268
- nonnormal process, Process Capability: 256

### O
- OC Curve: 108
- one-way comparative Pareto chart: 330
- Operating Characteristic curves: 108
- overall and within estimates, Process Capability: 256

### P
- Parallelism Plots: 195
- Pareto Plot:
  - examples: 332
  - options: 332
- p-Chart: 120
- Percent Scale: 330
- Phase: 43
- Phase Detection: 168
- Pie Chart: 330
- Points Jittered: 221
- Points options: 48
- Presummarize: 38, 94, 99
- Principal Components: 168
- Probable Error: 198
- Process role: 325
Index
Quality and Process Methods

R
Range Chart 194
Rational subgrouping 91
R-Chart 38, 93
relative frequency chart 323
Remove Graph 50
Remove option 57
Reorder Horizontal 330
Reorder Vertical 330
Reset Factor Grid 203
Run Charts 99

S
S Control Limits 221
Save Limits
  Control Chart Builder 47
  Control Chart platform 109
Save Principal Components 169
Save Summaries 47, 105
Save T Square 168
Save T Square Formula 168
Save Target Statistics 164, 168
S-Chart 38, 93
Script 220
Separate Causes 332
Set Alpha Level 168
Set Sample Size 49
Set Script 203
Shift Detection Profiler 195, 199
Show Box Plots 220
Show Cell Means 220
Show Center Line 104
Show Center Line option 49
Show Control Panel 47
Show Correlation 168
Show Covariance 168
Show Cum Percent Axis 331
Show Cum Percent Curve 331
Show Cum Percent Points 331–332
Show Grand Mean 220
Show Grand Median 220
Show Group Means 220
Show Inverse Correlation 168
Show Inverse Covariance 168
Show Limit Summaries 47
Show Limits option 49
Show Means 168
Show Points 220
Show Points option 49
Show Range Bars 220
Show Separators 220
Sigma options 49, 51
Specify Alpha 194
Statistic options, control chart 50
Std Dev Chart 194, 221
Steam Turbine Current.jmp 164
Steam Turbine Historical.jmp 163
Subgroup 43

T
T Square Partitioned 168
T2 Chart 168
Tabular Cusum Control Charts 131–144
Test Beyond Limits option 50
Test Rate Within Groups 331
Test Rates Across Groups 331
Test-Retest Error Comparison 195
Tests option 50

U
u-Chart 121
Ungroup Plots 330
Use Median 104
UWMA 94

V
Variability Chart platform 218–223
  Gauge R&R 225–228
  launch 222
  options 220
Variability Summary Report 221
Variance Components 195, 221, 223
Vertical Charts 220
vital few 340
V-Mask Cusum Control Charts 145–159

W–Z
Warnings options 49
Western Electric Rules 52
Westgard Rules 50, 55
XBar Chart 38, 93
XBar Chart Limits 220
Y, Cause role 328
Zones option 49