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SAS® and all other SAS Institute Inc. product or service names are registered trademarks or
trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA
registration.

Other brand and product names are trademarks of their respective companies.

SAS software may be provided with certain third-party software, including but not limited
to open-source software, which is licensed under its applicable third-party software license
agreement. For license information about third-party software distributed with SAS
software, refer to http://support.sas.com/thirdpartylicenses.

Technology License Notices

Scintilla - Copyright © 1998-2017 by Neil Hodgson <neilh@scintilla.org>.
All Rights Reserved.

Permission to use, copy, modify, and distribute this software and its documentation for
any purpose and without fee is hereby granted, provided that the above copyright
notice appear in all copies and that both that copyright notice and this permission
notice appear in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING
ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL
HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Telerik RadControls: Copyright © 2002-2012, Telerik. Usage of the included Telerik
RadControls outside of JMP is not permitted.

ZLIB Compression Library - Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.
Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.
Packages - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.



Neither the name of the WhiteBox nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

iODBC software - Copyright © 1995-2006, OpenLink Software Inc and Ke Jin
(www.iodbc.org). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

— Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

— Redistributions in binary form must reproduce the above copyright notice, this list
of conditions and the following disclaimer in the documentation and/or other
materials provided with the distribution.

— Neither the name of OpenLink Software Inc. nor the names of its contributors may
be used to endorse or promote products derived from this software without specific
prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
THE POSSIBILITY OF SUCH DAMAGE.



bzip2, the associated library “libbzip2”, and all documentation, are Copyright ©
1996-2010, Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

The origin of this software must not be misrepresented; you must not claim that you
wrote the original software. If you use this software in a product, an acknowledgment
in the product documentation would be appreciated but is not required.

Altered source versions must be plainly marked as such, and must not be
misrepresented as being the original software.

The name of the author may not be used to endorse or promote products derived from
this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
SUCH DAMAGE.

R software is Copyright © 1999-2012, R Foundation for Statistical Computing.

MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S.
and international patents. See www.mathworks.com/patents. MATLAB and Simulink
are registered trademarks of The MathWorks, Inc. See
www.mathworks.com/trademarks for a list of additional trademarks. Other product or
brand names may be trademarks or registered trademarks of their respective holders.

libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

— Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.



— Redistributions in binary form must reproduce the above copyright notice, this list
of conditions and the following disclaimer in the documentation and / or other
materials provided with the distribution.

— Neither the name of Florian Reuter nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c
and the trio files, which are covered by a similar license but with different Copyright
notices) all the files are:

Copyright © 1998 - 2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL
VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in
advertising or otherwise to promote the sale, use or other dealings in this Software
without prior written authorization from him.



Regarding the decompression algorithm used for UNIX files:
Copyright © 1985, 1986, 1992, 1993
The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

Snowbeall - Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton.
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be
used to endorse or promote products derived from this software without specific prior
written permission.



THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS \”AS IS\” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

Pako - Copyright © 2014-2017 by Vitaly Puzrin and Andrei Tuputcyn.

Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.



Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn
about JMP.

Visit JMP.com to find the following:

¢ live and recorded webcasts about how to get started with J]MP

* video demos and webcasts of new features and advanced techniques
® details on registering for JMP training

¢ schedules for seminars being held in your area

® success stories showing how others use JMP

* ablog with tips, tricks, and stories from JMP staff

e aforum to discuss JMP with other users

http://www.jmp.com/getstarted/
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About This Book

Discovering JMP provides a general introduction to the JMP software. This guide assumes that
you have no knowledge of JMP. Whether you are an analyst, researcher, student, professor, or
statistician, this guide gives you a general overview of JMP’s user interface and features.

This guide introduces you to the following information:

Starting JMP

The structure of a JMP window

Preparing and manipulating data

Using interactive graphs to learn from your data
Performing simple analyses to augment graphs
Customizing JMP and special features

Sharing your results

This guide contains six chapters. Each chapter contains examples that reinforce the concepts
presented in the chapter. All of the statistical concepts are at an introductory level. The sample
data used in this book are included with the software. Here is a description of each chapter:

Chapter 2, “Introducing JMP” provides an overview of the JMP application. You learn
how content is organized and how to navigate the software.

Chapter 3, “Work with Your Data” describes how to import data from a variety of sources,
and prepare it for analysis. There is also an overview of data manipulation tools.

Chapter 4, “Visualize Your Data” describes graphs and charts that you can use to visualize
and understand your data. The examples range from simple analyses involving a single
variable, to multiple-variable graphs that enable you to see relationships between many
variables.

Chapter 5, “Analyze Your Data” describes many commonly used analysis techniques.
These techniques range from simple techniques that do not require the use of statistical
methods, to advanced techniques, where knowledge of statistics is useful.

Chapter 6, “The Big Picture” shows you how to analyze distributions, patterns, and
similar values in several platforms.

Chapter 7, “Save and Share Your Work” describes sharing your work with non JMP users
in PowerPoint presentations, interactive HTML, and Adobe Flash. Saving analyses as
scripts and saving work in journals and projects for JMP users are also covered.
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e Chapter 8, “Special Features” describes how to automatically update graphs and analyses
as data changes, how to use preferences to customize your reports, and how JMP interacts

with SAS.

After reviewing this guide, you will be comfortable navigating and working with your data in
JMP.

JMP is available for both Windows and Macintosh operating systems. However, the material
in this guide is based on a Windows operating system.



Gallery of JMP Graphs

Various Graphs and Their Platforms

Here are pictures of many of the graphs that you can create with JMP. Each picture is labeled
with the platform used to create it. For more information about the platforms and these and
other graphs, see the documentation on the Help > Books menu.
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Chapter 1

Learn about JMP

Documentation and Additional Resources

This chapter includes details about JMP documentation, such as book conventions,
descriptions of each JMP book, the Help system, and where to find other support.
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Discovering JMP Formatting Conventions

Formatting Conventions

The following conventions help you relate written material to information that you see on
your screen:

Sample data table names, column names, pathnames, filenames, file extensions, and
folders appear in Helvetica font.

Code appears in Lucida Sans Typewriter font.

Code output appears in Lucida Sans Typewriteritalic font and is indented farther than
the preceding code.

Helvetica bold formatting indicates items that you select to complete a task:
— buttons

— check boxes

— commands

— list names that are selectable

- menus

— options

— tab names

— text boxes

The following items appear in italics:

— words or phrases that are important or have definitions specific to JMP
— book titles

— variables

Features that are for JMP Pro only are noted with the JMP Pro icon i’NII{O . For an overview
of JMP Pro features, visit https://www jmp.com/software/pro/.

Note: Special information and limitations appear within a Note.

Tip: Helpful information appears within a Tip.


https://www.jmp.com/software/pro/
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JMP Documentation

JMP offers documentation in various formats, from print books and Portable Document

Format (PDF) to electronic books (e-books).

* Open the PDF versions from the Help > Books menu.

* All books are also combined into one PDF file, called JMP Documentation Library, for
convenient searching. Open the JMP Documentation Library PDF file from the Help > Books

menu.

* You can also purchase printed documentation and e-books on the SAS website:

https://www.sas.com/store/search.ep?keyWords=]MP

JMP Documentation Library

The following table describes the purpose and content of each book in the JMP library.

Document Title Document Purpose

Discovering JMP If you are not familiar
with JMP, start here.

Using JMP Learn about JMP data
tables and how to
perform basic
operations.

Document Content

Introduces you to JMP and gets you
started creating and analyzing data. Also
learn how to share your results.

Covers general JMP concepts and
features that span across all of JMP,
including importing data, modifying
columns properties, sorting data, and
connecting to SAS.


https://www.sas.com/store/search.ep?keyWords=JMP

Chapter 1
Discovering JMP

Document Title

Basic Analysis

Essential Graphing

Profilers

Document Purpose

Perform basic analysis
using this document.

Find the ideal graph
for your data.

Learn how to use
interactive profiling
tools, which enable you
to view cross-sections
of any response
surface.

Learn about JMP 41

JMP Documentation

Document Content
Describes these Analyze menu platforms:

¢ Distribution
e FitYbyX

e Tabulate

* Text Explorer

Covers how to perform bivariate,
one-way ANOVA, and contingency
analyses through Analyze > Fit Y by X.
How to approximate sampling
distributions using bootstrapping and
how to perform parametric resampling
with the Simulate platform are also
included.

Describes these Graph menu platforms:

® Graph Builder
¢ Scatterplot 3D
e Contour Plot

e Bubble Plot

e Parallel Plot

e Cell Plot

® Scatterplot Matrix
¢ Ternary Plot

¢ Treemap

* Chart

e Overlay Plot

The book also covers how to create
background and custom maps.

Covers all profilers listed in the Graph
menu. Analyzing noise factors is
included along with running simulations
using random inputs.
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Document Title Document Purpose Document Content
Design of Learn how to design Covers all topics in the DOE menu and
Experiments Guide experiments and the Specialized DOE Models menu item
determine appropriate  in the Analyze > Specialized Modeling
sample sizes. menu.

Fitting Linear Models Learn about Fit Model =~ Describes these personalities, all
platform and many of  available within the Analyze menu Fit
its personalities. Model platform:

e Standard Least Squares
* Stepwise

* Generalized Regression
* Mixed Model

¢ MANOVA

¢ Loglinear Variance

* Nominal Logistic

* Ordinal Logistic

e Generalized Linear Model
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Document Title

Predictive and
Specialized Modeling

Document Purpose

Learn about additional
modeling techniques.

Learn about JMP
JMP Documentation

Document Content

Describes these Analyze > Predictive
Modeling menu platforms:

* Modeling Utilities

* Neural

¢ TPartition

¢ Bootstrap Forest

* Boosted Tree

* K Nearest Neighbors
* Naive Bayes

* Model Comparison

e Formula Depot

Describes these Analyze > Specialized
Modeling menu platforms:

e Fit Curve

¢ Nonlinear

* Functional Data Explorer
¢ Gaussian Process

¢ Time Series

¢ Matched Pairs

Describes these Analyze > Screening
menu platforms:

¢ Response Screening
® Process Screening

® Predictor Screening
® Association Analysis

® Process History Explorer

The platforms in the Analyze >
Specialized Modeling > Specialized DOE
Models menu are described in Design of
Experiments Guide.
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Document Title

Multivariate
Methods

Quality and Process
Methods

Document Purpose

Read about techniques
for analyzing several
variables
simultaneously.

Read about tools for
evaluating and
improving processes.

Chapter 1
Discovering JMP

Document Content

Describes these Analyze > Multivariate
Methods menu platforms:

Multivariate

Principal Components
Discriminant

Partial Least Squares

Multiple Correspondence Analysis
Factor Analysis

Multidimensional Scaling

Item Analysis

Describes these Analyze > Clustering
menu platforms:

Hierarchical Cluster
K Means Cluster
Normal Mixtures
Latent Class Analysis

Cluster Variables

Describes these Analyze > Quality and
Process menu platforms:

Control Chart Builder and individual
control charts

Measurement Systems Analysis
Variability / Attribute Gauge Charts
Process Capability

Pareto Plot

Diagram

Manage Spec Limits
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Discovering JMP JMP Documentation
Document Title Document Purpose Document Content
Reliability and Learn to evaluate and Describes these Analyze > Reliability and
Survival Methods improve reliability ina  Survival menu platforms:

product or system and
analyze survival data
for people and * FitLife by X
products. ¢ Cumulative Damage

Life Distribution

® Recurrence Analysis

¢ Degradation and Destructive
Degradation

¢ Reliability Forecast

* Reliability Growth

¢ Reliability Block Diagram

* Repairable Systems Simulation

* Survival

¢ Fit Parametric Survival

¢ Fit Proportional Hazards

Consumer Research Learn about methods Describes these Analyze > Consumer

for studying consumer = Research menu platforms:

preferences and using

¢ Categorical
that insight to create &

better products and * Choice
services. e  MaxDiff
e Uplift
e Multiple Factor Analysis
Scripting Guide Learn about taking Covers a variety of topics, such as writing
advantage of the and debugging scripts, manipulating
powerful JMP data tables, constructing display boxes,
Scripting Language and creating JMP applications.
(JSL).
JSL Syntax Reference  Read about many JSL Includes syntax, examples, and notes for

functions on functions  JSL commands.
and their arguments,

and messages that you

send to objects and

display boxes.
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Note: The Books menu also contains two reference cards that can be printed: The Menu Card
describes JMP menus, and the Quick Reference describes JMP keyboard shortcuts.

JMP Help

JMP Help is an abbreviated version of the documentation library that provides targeted
information. You can open JMP Help in several ways:

* On Windows, press the F1 key to open the Help system window.

® Get help on a specific part of a data table or report window. Select the Help tool ¢ from
the Tools menu and then click anywhere in a data table or report window to see the Help
for that area.

e Within a JMP window, click the Help button.

® Search and view JMP Help on Windows using the Help > Help Contents, Search Help, and
Help Index options. On Mac, select Help > JMP Help.

e Search the Help at https://jmp.com/support/help/ (English only).

Additional Resources for Learning JMP

In addition to JMP documentation and JMP Help, you can also learn about JMP using the
following resources:

e “Tutorials”

e “Sample Data Tables”

e “Learn about Statistical and JSL Terms”
* “Learn JMP Tips and Tricks”

e “Tooltips”

e “JMP User Community”

e “JMP Books by Users”

e “The JMP Starter Window”

Tutorials
You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu
is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, then start with the Beginners Tutorial. It steps you through the
JMP interface and explains the basics of using JMP.


https://jmp.com/support/help/
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The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment
and comparing a sample mean to a constant.

Sample Data Tables
All of the examples in the JMP documentation suite use sample data. Select Help > Sample
Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories,
select Help > Sample Data.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\UMP\14\Samples\Data
On Macintosh: \Library\Application Support\JMP\14\Samples\Data

In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory. In JMP
Shrinkwrap, sample data is installed in the JMPSW directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching
Resources section. To learn more about the teaching resources, visit https://jmp.com/tools.

Learn about Statistical and JSL Terms

The Help menu contains the following indexes:
Statistics Index Provides definitions of statistical terms.

Scripting Index Lets you search for information about JSL functions, objects, and display
boxes. You can also edit and run sample scripts from the Scripting Index.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for
using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select
Help > Tip of the Day. Or, you can turn it off using the Preferences window.

Tooltips

JMP provides descriptive tooltips when you place your cursor over items, such as the
following:

* Menu or toolbar options


http://jmp.com/tools
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e Labels in graphs
e Text results in the report window (move your cursor in a circle to reveal)
e Files or windows in the Home Window

¢ Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences >
General and then deselect Show menu tips. This option is not available on Macintosh.

JMP User Community

The JMP User Community provides a range of options to help you learn more about J]MP and
connect with other JMP users. The learning library of one-page guides, tutorials, and demos is
a good place to start. And you can continue your education by registering for a variety of JMP
training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts,
and social networking groups.

To access JMP resources on the website, select Help > JMP User Community or visit
https://community jmp.com/.

JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP
website:

https://www .jmp.com/en_us/software/books.html

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data
analysis. Options are categorized and described, and you launch them by clicking a button.
The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and
File menus. The window also lists JMP Pro features and platforms.

e To open the JMP Starter window, select View (Window on the Macintosh) > JMP Starter.

e To display the JMP Starter automatically when you open JMP on Windows, select File >
Preferences > General, and then select JMP Starter from the Initial JMP Window list. On
Macintosh, select JMP > Preferences > Initial JMP Starter Window.


https://community.jmp.com/
https://www.jmp.com/en_us/software/books.html
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Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP,
many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at https://www.jmp.com/support, including the
technical support phone number.


https://www.jmp.com/support
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Chapter 2

Introducing JMP

Basic Concepts

JMP (pronounced jump) is a powerful and interactive data visualization and statistical

a

nalysis tool. Use JMP to learn more about your data by performing analyses and interacting

with the data using data tables, graphs, charts, and reports.

JMP enables researchers to perform a wide range of statistical analyses and modeling. J]MP is
equally useful to the business analyst who wants to quickly uncover trends and patterns in
data. With JMP, you do not have to be an expert in statistics to get information from your data.

F

F

4

or example, you can use JMP to do the following:

Create interactive graphs and charts to explore your data and discover relationships.
Discover patterns of variation across many variables at once.
Explore and summarize large amounts of data.

Develop powerful statistical models to predict the future.

igure 2.1 Examples of JMP Reports
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Concepts That You Should Know

Before you begin using JMP, you should be familiar with these concepts:

e Enter, view, edit, and manipulate data using JMP data tables.

® Select a platform from the Analyze, Graph, or DOE menus. Platforms contain interactive
windows that you use to analyze data and work with graphs.

* Platforms use these windows:
— Launch windows where you set up and run your analysis.
— Report windows showing the output of your analysis.
* Report windows normally contain the following items:
— A graph of some type (such as a scatterplot or a chart).
— Specific reports that you can show or hide using the disclosure icon 4 .

— Platform options that are located within red triangle menus '=!.

How Do | Get Started?

The general workflow in JMP is simple:

1. Get your data into JMP.
2. Select a platform and complete its launch window.

3. Explore your results and discover where your data takes you.
This workflow is described in more detail in “Understanding the JMP Workflow” on page 58.

Typically, you start your work in JMP by using graphs to visualize individual variables and
relationships among your variables. Graphs make it easy to see this information, and to see
the deeper questions to ask. Then you use analysis platforms to dig deeper into your problems
and find solutions.

* The “Work with Your Data” chapter on page 65 shows you how to get data into JMP.

* The “Visualize Your Data” chapter on page 95 shows you how to use some of the useful
graphs JMP provides to look more closely at your data.

* The “Analyze Your Data” chapter on page 131 shows you how to use some of the analysis
platforms.

® The “The Big Picture” chapter on page 167 shows you how to analyze distributions,
patterns, and similar values in several platforms.
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Each chapter teaches through examples. The following sections in this chapter describe data
tables and general concepts for working in JMP.

Starting JMP

Start JMP in two ways:

* Double-click the JMP icon, normally found on your desktop. This starts JMP but does not
open any existing JMP files.

* Double-click an existing JMP file. This starts JMP and opens the file.

The initial view of JMP includes the Tip of the Day window and the Home Window on
Windows; on Macintosh, the Tip of the Day and JMP Starter, and Home Window initially
appear.

The JMP Starter window classifies actions and platforms using categories.

Figure 2.2 The JMP Starter
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[‘g - Create a new Data Table, and display as a grid in a new window.
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) b Dpen a JMP file containing a data table, or import it from another
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Clustening P
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Graph 3
Surface 7 Open a file containing text, a script for example.
Measure o
Control Journal
Consumer Research =
DOE i Create a new Journal window.
Tables -
SAS :Jﬁ Open a file containing journaled JMP output.
IMP Pro B

Project

. Create a new project used to group data, reports, scripts, and
Q related material.
£ o
l,ﬁ? Open a project file.

Miscellaneous
[:_"'—é m Get data from a database.

3 'J Organized sample data with script examples.
J maamlne and set system preferences.
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On the left is a list of categories. Click a category to see the features and the commands related
to that category. The JMP Starter also lists JMP Pro features and platforms.

The Home Window helps you organize and access files in JMP.

Figure 2.3 The Home Window on Windows
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To open the Home Window on Windows, select View > Home Window. On Macintosh, select
Window > JMP Home. The Home Window includes links to the following;:

e the data tables and report windows that are currently open
e files that you have opened recently
For more details about the Home Window, see the Get Started chapter in the Using [MP book.

Almost all JMP windows contain a menu bar and a toolbar. You can find most JMP features in
three ways:

* using the menu bar
* using the toolbar buttons

¢ using the buttons on the JMP Starter window
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About the Menu Bar and Toolbars

The menus and toolbars are hidden in many windows. To see them, place your mouse pointer
over the blue bar under the window’s title bar. The menus in the JMP Starter window, the
Home Window, and all data tables are always visible.

Using Sample Data

The examples in this book and the other JMP books use sample data tables. The default
location on Windows for the sample data is:

C:/Program Files/SAS/JMP/14/Samples/Data
C:/Program Files/SAS/JMPPro/14/Samples/Data
C:/Program Files/SAS/JMPSW/14/Samples/Data

The Sample Data Index groups the data tables by category. Click a disclosure icon to see a list
of data tables for that category, and then click a link to open a data table.

Macintosh sample data is installed in /Library/Application Support/JMP/14/Samples/Data.

Opening a JMP Sample Data Table

1. From the Help menu, select Sample Data.

2. Open the Data Tables used in Discovering JMP list by clicking on the disclosure icon next
to it.

3. Click the name of the data table to use it in the examples in this book.

Sample Import Data
Use files from other applications to learn how to import data into JMP.
The default location on Windows for the sample import data is:

C:/Program Files/SAS/JMP/14/Samples/Import Data
C:/Program Files/SAS/JMPPro/14/Samples/Import Data
C:/Program Files/SAS/JMPSW/14/Samples/Import Data

Understanding Data Tables

A data table is a collection of data organized in rows and columns. It is similar to a Microsoft®
Excel® spreadsheet, but with some important differences that are discussed in “How is JMP
Different from Excel?” on page 63. A data table might also contain other information like
notes, variables, and scripts. These supplementary items are discussed in later chapters.
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Understanding Data Tables

Open the VA Lung Cancer data table to see the data table described here.

Figure 2.4 A Data Table
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information about the observations. In Figure 2.4, each row corresponds to a test subject,

and there are twelve columns of information. Although all twelve columns cannot be
shown in the data grid, the Columns panel lists them all. The information given about
each test subject includes the time, cell type, treatment, and more. Each column has a

header, or name. That name is not part of the table’s total count of rows.

Table panel The table panel can contain table variables or table scripts. In Figure 2.4, there is
one saved script called Model that can automatically re-create an analysis. This table also
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has a variable named Notes that contains information about the data. Table variables and
table scripts are discussed in a later chapter.

Columns panel The columns panel shows the total number of columns, whether any
columns are selected, and a list of all the columns by name. The numbers in parentheses
(12/0) show that there are twelve columns, and that no columns are selected. An icon to the
left of each column name shows that column’s modeling type. Modeling types are
described in “Understand Modeling Types” on page 136 in the “Analyze Your Data”
chapter. Icons to the right show any attributes assigned to the column. See “View or
Change Column Information” on page 79 in the “Work with Your Data” chapter for more
information about these icons.

Rows panel The rows panel shows the number of rows in the data table, and how many
rows are selected, excluded, hidden, or labeled. In Figure 2.4, there are 137 rows in the
data table.

Thumbnail links to report windows This area shows thumbnails of all reports based on the
data table. Place your mouse pointer over a thumbnail to see a larger preview of the report
window. Double-click a thumbnail to bring the report window to the front.

Interacting with the data grid, which includes adding rows and columns, entering data, and
editing data, is discussed in the “Work with Your Data” chapter on page 65. If you open
multiple data tables, each one appears in a separate window.

Understanding the JMP Workflow

Once your data is in a data table, you can create graphs or plots, and perform analyses. All
features are located in platforms, which are found primarily on the Analyze or Graph menus.
They are called platforms because they do not just produce simple static results. Platform
results appear in report windows, are highly interactive, and are linked to the data table and
to each other.

The platforms under the Analyze and Graph menus provide a variety of analytical features
and data exploration tools.

The general steps to produce a graph or analysis are as follows:

Open a data table.

Select a platform from the Graph or Analyze menu.

Complete the platform launch window to set up your analysis.

Click OK to create the report window that contains your graphs and statistical analyses.

Customize your report by using report options.

AL N O

Save, export, and share your results with others.



Chapter 2
Discovering JMP

Introducing JMP
Understanding the JMP Workflow

Later chapters discuss these concepts in greater detail.
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The following example shows you how to perform a simple analysis and customize it in four
steps. This example uses the Companies.jmp file sample data table to show a basic analysis of

the variable Profits ($M).

Step 1: Launching a Platform and Viewing Results

1. Select Help > Sample Data Library and open Companies.jmp.

2. Select Analyze > Distribution to open the Distribution launch window.

3. Select Profits ($M) in the Select Columns box and click the Y, Columns button.

The variable Profits (M) appears in the Y, Columns role. See Figure 2.5 for the completed

window.

Another way to assign variables is to click and drag columns from the Select Columns box

to any of the roles boxes.

Figure 2.5 Assign Profits ($M)

The distribution of values in each column

Select Columns Cast Selected Columns into Roles
~| 8 Columns @| Al Profits ($M)
‘T}'PE optional
thsize Co
dlsales (3M)
¥ Profits ($M) -
Weight optional numeric
4 troploy | weight |
dprofitiemp Freq | optional numeric
dlAssets
dlztprofit/sales E' T

[C] Histograms Only

4. Click OK.

The Distribution report window appears.

Action
oK |
Cancel |

Rermove |
Recall |
Help |
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Figure 2.6 Distribution Report Window on Windows
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The report window contains basic plots or graphs and preliminary analysis reports. The
results appear in an outline format, and you can show or hide any report by clicking on the
disclosure icon.

Red triangle menus contain options and commands to request additional graphs and analyses
at any time.

¢ On Windows, place your mouse pointer over the blue bar at the top of the window to see
the menu bar and the toolbars.

* On Windows, click the data table button in the lower right corner to view the data table
that was used to create this report. On Macintosh, click the Show Data Table button in the
upper right corner of the report window.

* On Windows, click the JMP Home Window button in the lower right corner to view the
Home Window. On Macintosh, select Window > JMP Home.
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Step 2: Removing the Box Plot

Continue using the Distribution report that you created earlier.

1. Click the red triangle next to Profits ($M) to see a menu of report options.
2. Deselect Outlier Box Plot to turn the option off.

The outlier box plot is removed from the report window.

Figure 2.7 Removing the Outlier Box Plot
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Step 3: Requesting Additional Output

Continue to use the same report window.

1. From the red triangle menu next to Profits ($M), select Test Mean.
The Test Mean window appears.

2. Enter 500 in the Specify Hypothesized Mean box.

3. Click OK.

The test for the mean is added to the report window.

61
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Figure 2.8 Test for the Mean
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Step 4: Interacting with Platform Results

All platforms produce results that are interactive, for example, the following results:

* Reports can be shown or hidden.
* Additional graphs and statistical details can be added or removed to suit your purposes.

e DPlatform results are connected to the data table and to each other.

For example, to close the Quantiles report, click the disclosure icon next to Quantiles.

Figure 2.9 Close the Quantiles Report

Quantiles [ Quantiles
100.0% maximum 3758 4= Summary Statistics
SEliges S Mean 409.31875
97.5% 3758
gy AERA Std Dev 780.28708
Click here to collapse i ! i Std Err Mean 137.93657
. Ta.0% guarile 730.525 u 955 M o0 4224
the Quantiles report 50.0%  median 2017 LA san Ba7
X Lower 95% Mean 127.99526
25.0% guartile 42975 M 13
10.0% -332.92
25% -680.4
0.5% -680.4

0.0% minimum  -680.4
£ = Summary Statistics

Mean 409.31875
Std Dev 780.28708
Std Err Mean 137 93657

Upper 95% Mean BH90.64224
Lower 95% Mean 127.99526
N 32

Platform results are connected to the data table. The histogram in Figure 2.10 shows that a
group of companies makes a much higher profit that the others. To quickly identify that
group, click on the histogram bar for them. The corresponding rows in the data table are
selected.
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Figure 2.10 Connection between Platform Results and Data Table
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In this case, the group includes only one company, and that one row is selected.

How is JMP Different from Excel?

There are a number of important differences between JMP and Excel or other spreadsheet
applications.

Table 2.1 JMP and Excel Differences

Formulas
Excel Formulas are applied to individual cells.
JMP Formulas are applied only to entire columns. “Calculate Values with

Formulas” on page 81 in the “Work with Your Data” chapter describes
how to use formulas.

Column Names

Excel Column names are part of the grid. Numbered rows and labeled columns
extend past the data. Numeric and character data reside in the same
column.
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Table 2.1 JMP and Excel Differences (Continued)

JMP Column names are not part of the grid. There are no rows and columns
beyond the existing data. The grid is only as big as the data. A column is
either numeric or character. If a column contains both character and
numeric data, the entire column’s data type is character, and the numbers
are treated as character data.

“Understand Modeling Types” on page 136 in the “Analyze Your Data”
chapter describes how data type influences platform results.

Tables and Worksheets

Excel A single spreadsheet contains several tables, or worksheets.
JMP JMP does not have the concept of worksheets. Each data table is a separate
Jmp file and appears in a separate window.
Data Grid
Excel Data can be located anywhere in the data grid.
JMP Data always begins in row 1 and column 1.

Analysis and Graph Reports
Excel All data, analyses, and graphs are placed inside the data grid.

JMP Results appear in a separate window.
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Before graphing or analyzing your data, the data has to be in a data table and in the proper
format. This chapter shows some basic data management tasks, including the following;:

¢ Creating new data tables
¢ Opening existing data tables
* Importing data from other applications into JMP

* Managing your data

Figure 3.1 Example of a Data Table
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Get Your Data into JMP

To copy and paste data from another application, see “Copy and Paste Data” on page 67.
To import data from another application, see “Import Data” on page 67.
To enter data directly into a data table, see “Enter Data” on page 70

To open a data table, double-click on the file, or use the File > Open command.

You can also import data into JMP from a database. For more information, see the Import Your
Data chapter in the Using [MP book.

This chapter uses sample data tables and sample import data that is installed with JMP. To
find these files, see “Using Sample Data” on page 56 in the “Introducing JMP” chapter.

Copy and Paste Data

You can move data into JMP by copying and pasting from another application, such as Excel
or a text file.

1. Open the VA Lung Cancer.xls file in Excel. This file is located in the Sample Import Data
folder.

2. Select all of the rows and columns, including the column names. There are 12 columns and
138 rows.
Copy the selected data.

4. InJMP, select File > New > Data Table to create an empty table.
Select Edit > Paste with Column Names to paste the data and column headings.
If the data that you are pasting into JMP does not have column names, then you can use
Edit > Paste.

Import Data

You can move data into JMP by importing data from another application, such as Excel, SAS,
or text files. The basic steps to import data are as follows:

1.
2.
3.

Select File > Open.
Navigate to your file’s location.

If your file is not listed in the Open Data File window, select the correct file type from the
Files of type menu.

Click Open.
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Example of Importing a Microsoft Excel File

1. Select File > Open.
2. Navigate to the Samples/Import Data folder.
3. Select Team Results.xls.

Note the rows and columns on which the data begin. The spreadsheet also contains two
worksheets. In this example, you import the Ungrouped Team Results worksheet.

4. Click Open.

The spreadsheet opens in the Excel Import Wizard, where a preview of the data appears
along with import options.

Text from the first row of the spreadsheet are column headings. However, you want text in
row 3 of the spreadsheet to be converted to column headings.

5. Next to Column headers start on row, type 3, and press Enter. The column headings are
updated in the data preview. The value for the first row of data is updated to 4.

6. Save the settings only for this worksheet:
— Deselect Use for all worksheets in the lower left corner of the window.
— Select Ungrouped Team Results in the upper right corner of the window.

7. Click Import to convert the spreadsheet as you specified.

When you import Excel files, JMP predicts whether columns headings exist, and if the column
names are on row one. The copy and paste method is recommended for the following
situations:

e If the column names are located in a row other than row one
e If the file does not include column names and the data does not start in row one

e If the file contains column names and the data does not start in row two

See “Copy and Paste Data” on page 67 and the Import Your Data chapter in the Using JMP
book for more information about importing Excel files.

Example of Importing a Text File

One way to import a text file is to let JMP assume the data’s format and place the data in a data
table. This method uses settings that you can specify in Preferences. See the JMP Preferences
chapter in the Using JMP book for information about setting text import preferences.

Another way to import a text file is to use a Text Preview window to see what your data table
will look like after importing, and make adjustments. The following example shows you how
to use Text Import Preview window.

1. Select File > Open.
2. Navigate to the Samples/Import Data folder.
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3. Select Animals_line3.txt.

Work with Your Data
Get Your Data into JMP

4. At the bottom of the Open window, select Data with Preview.

5. Click Open.

Figure 3.2 Initial Preview Window
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This text file has a title on the first line, column names on the third line, and the data starts
on line four. If you opened this directly in JMP, the Animals Data line would be the first

column name, and all the column names and data afterward would be out of sync. The

Preview window lets you adjust the settings before you open the file, and see how your
adjustments affect the final data table.

6. Enter 3 in the File contains column names on line field.

7. Enter 4 in the Data starts on line field.

Click Next.

In the second window, you can exclude columns from the import and change the data

modeling of the columns. For this example, use the default settings.

9. Click Import.

The new data table has columns named species, subject, miles, and season. The species and

season columns are character data. The subject and miles columns are continuous numeric

data.
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Tip: You can import several text files at once to create a data table. See the Import Your Data
chapter in the Using JMP book for details.

Enter Data

You can enter data directly in a data table. The following example shows you how to enter
data that was collected over several months into a data table.

Scenario

Table 3.1 shows the data from a study that investigated a new blood pressure medication.
Each individual’s blood pressure was measured over a six-month period. Two doses (300mg
and 450mg) of the medication were used, along with a control and placebo group. The data
shows the average blood pressure for each group.

Table 3.1 Blood Pressure Data

Month Control Placebo 300mg 450mg
March 165 163 166 168
April 162 159 165 163
May 164 158 161 153
June 162 161 158 151
July 166 158 160 148
August 163 158 157 150

Enter Data in a New Data Table

1. Select File > New > Data Table to create an empty data table.
A new data table has one column and no rows.

2. Select the column name and change the name to Month. See Figure 3.3.

Note: To rename a column, you can also double-click the column name or select the
column and press Enter.
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Figure 3.3 Entering a Column Name

~ | Untitled b < =

= Columns (1/1)

Fcolumn 1

Click once to select the column.

3. Select Rows > Add Rows.
The Add Rows window appears.

4. Since you want to add six rows, type 6.

Work with Your Data
Get Your Data into JMP

~ Untitled b4 ! | Manth

= Columns (1/0)
4 Column 1

Then type “Month”.

Click OK. Six empty rows are added to the data table.

6. Enter the Month information by clicking in a cell and typing.

Figure 3.4 Month Column Completed

~ | Untitled Rl

-

Columns panel

\anIumns (/0)

Month
Modeling type icon /-.

Month
1 |March.
2 April
3 May
4 | June
5 July
6 August
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In the columns panel, look at the modeling type icon to the left of the column name. It has
changed to reflect that Month is now nominal (previously it was continuous). Compare the

modeling type shown for Column 1 in Figure 3.3 and for Month in Figure 3.4. This
difference is important and is discussed in “View or Change Column Information” on

page 79.

7. Double-click in the space on the right side of the Month column to add the Control column.

8. Change the name to Control.

9. Enter the Control data as shown in Table 3.1. Your data table now consists of six rows and

two columns.

10. Continue adding columns and entering data as shown in Table 3.1 to create the final data

table with six rows and five columns.

Change the Data Table Name

1. Double-click on the data table name (Untitled) in the Table Panel.

2. Type the new name (Blood Pressure).
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Figure 3.5 Changing the Data Table Name

Double-click here. Type the new name.
4

You can use the JMP Add In for Excel to transfer a spreadsheet from Excel to JMP:

~ Untitled b4 ~Blood Pressure [

Transfer Data from Excel

¢ adatatable

* Graph Builder

¢ Distribution platform
e FitY by X platform

e Fit Model platform

e Time Series platform

¢ Control Chart platform

Set JMP Add In Preferences in Excel

To configure JMP Add In Preferences:

1. In Excel, select JMP > Preferences.

The JMP Preferences window appears.

Figure 3.6 JMP Add In Preferences

r
['ata Table Hame

|&[File] &[T ab]

[ Use first rows az column names

1 Fow(z] &z column names

¥ Transfer Hidden Rows
¥ Transfer Hidden Columns

Ok | Cancel |

2. Accept the default Data Table Name (File name_Worksheet name) or type a name.

3. Select to Use the first rows as column names if the first row in the worksheet contains
column headers.
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4. If you selected to use the first rows a column headers, type the number of rows used.
Select to Transfer Hidden Rows if the worksheet contains hidden rows to be included in the
JMP data table.
6. Select to Transfer Hidden Column if the worksheet contains hidden columns to be included
in the JMP data table.
7. Click OK to save your preferences.
Transfer to JMP

To transfer an Excel worksheet to JMP:

1.
2.
3.

Open the Excel file.

Select the worksheet to transfer.

Select JMP and then select the JMP destination:

Data Table

Graph Builder
Distribution platform
Fit Y by X platform
Fit Model platform
Time Series platform

Control Chart platform

The Excel worksheet is opened as a data table in JMP and the selected platform’s launch
window appears.

Work with Data Tables

This section contains the following information:

“Edit Data”

“Select, Deselect, and Find Values”

“View or Change Column Information”

“Calculate Values with Formulas”
“Filter Data”

Tip: Consider setting the Autosave Time Out value in the General preferences to
automatically save open data tables at the specified number of minutes. This autosave value

also applies to journals, scripts, projects, and reports.
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Edit Data

You can enter or change data, either a few cells at a time or for an entire column. This section
contains the following information:

* “Change Values”

e  “Recode Values”

e “Create Patterned Data”

Change Values

To change a value, select a cell and type the change. You can also double-click a cell to edit it.

Note: Double-clicking in a cell is not the same as selecting a cell. A single click selects a cell.
You can select more than one cell at the same time, and you can perform certain actions on
selected cells. Double-clicking only lets you edit a cell. For more information about selecting
rows, columns, and cells, see “Select, Deselect, and Find Values” on page 75.

Recode Values

Use the recoding tool to change all of the values in a column at once. For example, suppose
that you are interested in comparing the sales of computer and pharmaceutical companies.
Your current company labels are Computer and Pharmaceutical. You want to change them to
Technical and Drug. Going through all 32 rows of data and changing all the values would be
tedious, inefficient, and error-prone, especially if you had many more rows of data. Recode is
a better option.

1. Select Help > Sample Data Library and open Companies.jmp.

2. Select the Type column by clicking once on the column heading.
3. Select Cols > Recode.
4

In the New Value column of the Recode window, type Technical in the Computer row and
Drug in the Pharmaceutical row.

5. Click Done and select the In Place option from the list.
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Figure 3.7 Recode Window
4= Type
New Column v | Name: |Type 2 | Filter P~
Count Old Values (2) New Values (2) B Group controls
12 Pharmaceutical |Drug _ [ View Groups
20 Computer Technical

[] Show Only Grouped
[ Show Only Ungrouped

Group
Latest change: Pharmaceutical -> Drug

|Recode || Close || Help

All cells are updated automatically to the new values.

Create Patterned Data

Use the Fill options to populate a column with patterned data. The Fill options are especially
useful if your data table is large, and typing in the values for each row would be cumbersome.

Example of Filling a Column with the Pattern
1. Add anew column.
Enter 1 in the first cell, 2 in the second cell, and 3 in the third cell.

2
3. Select the three cells, and right-click anywhere in the selected cells to see a menu.
4

Select Fill > Repeat sequence to end of table.

The rest of the column is filled with the sequence (1, 2, 3, 1, 2, 3, ...).

To continue a pattern instead of repeating it (1, 2, 3, 4, 5, 6, ...), select Continue sequence to end
of table. This command can also be used to generate patterns like (1,1, 1,2, 2,2, 3, 3, 3, ...).

The Fill options can recognize simple arithmetic and geometric sequences. For character data,
the Fill options only repeat the values.

Select, Deselect, and Find Values

You can select rows, columns, or cells within a data table. For example, to create a subset of an
existing data table, you must first select the parts of the table that you want to subset. Also,
selecting rows can make data points stand out on a graph. Select rows and columns manually

by clicking, or select rows that meet certain search criteria. This section contains the following
information:

® “Select and Deselect Rows” on page 76

® “Select and Deselect Columns” on page 76
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® “Select and Deselect Cells” on page 77

® “Search for Values” on page 78

Select and Deselect Rows

Table 3.2 Selecting and Deselecting Rows

Task Action

Select rows one at a time Click on the row number.

Select multiple adjacent rows Click and drag on the row numbers.
or

Select the beginning row, and then hold down the Shift
key and click the last row number.

Select multiple non-adjacent Select the first row, and then hold down the Ctrl key
rows and click the other row numbers.

Deselect rows one at a time Hold down the Ctrl key and click the row numbers.
Deselect all rows Click in the lower-triangular space in the top left corner

of the table. See Figure 3.8.

Figure 3.8 Deselecting Rows

Todeselectallrows at
once, click here.

g /
Type

1 Computer
2 |Pharmaceutical
3 Computer
4 |Pharmaceutical

Select and Deselect Columns

Table 3.3 Selecting and Deselecting Columns

Task Action

Select columns one at a time Click the column heading.
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Table 3.3 Selecting and Deselecting Columns (Continued)

Task

Select multiple adjacent columns

Select multiple non-adjacent
columns

Deselect columns one at a time

Deselect all columns

Figure 3.9 Deselecting Columns

Todeselect all columns
at once, click here.

e

- Type
1 Computer
2 |Pharmaceutical
3 Computer
4 |Pharmaceutical

Select and Deselect Cells

Action
Click and drag across the column headings.
or

Select the beginning column, and then hold down
the Shift key and click the last header.

Select the first column, and then hold down the Ctrl
key and click the other column headings.

Hold down the Ctrl key and click the column
heading.

Click in the upper-triangular space in the top left
corner of the table. See Figure 3.9.

Table 3.4 Selecting and Deselecting Cells

Task
Select cells one at a time

Select multiple adjacent cells

Select multiple non-adjacent
cells

Action

Click each cell individually.
Click and drag across the cells.
or

Select the beginning cell, and then hold down the Shift
key and click the last cell.

Select the first cell, and then hold down the Ctrl key and
click the other cells.

77
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Table 3.4 Selecting and Deselecting Cells (Continued)

Task Action

Deselect all cells Click in the upper and lower triangular spaces in the
top left corner of the table.

Search for Values

In a data table that has thousands or tens of thousands of rows, it can be difficult to locate a
particular cell by scrolling through the table. If you are looking for specific information, use
the Search feature to find it. If data match the search criteria, the cell is selected and the data
grid scrolls to show it in the window. For example, the Companies.jmp data table contains
information about a company that has total sales of $11,899. Use the Search feature to find that
cell.

Example of Searching for a Value

1. Select Edit > Search > Find to launch the Search window.
2. In the Find what box, enter 11899.
3. Click Find. JMP finds the first cell that has 11,899 in it, and selects it.

If multiple cells meet the search criteria, click Find again to find the next cell that matches the
search term.

You can also search for multiple rows at once, with each row matching some criteria.

Example of Select All Rows That Correspond to Medium-Sized Companies

1. Select Rows > Row Selection > Select Where to open the Select rows window.
2. In the column list box on the left, select Size Co.

3. In the text box on the right, enter medium.

4. Click OK.
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Figure 3.10 Select Rows Window

Select your target Enter your search
column here criteria here

Select rows in the data fable that match specified criteria

Action
[] Comparg column
Cancel |
Al Sales (3M)

A profits (5M) Recall |
all# Employ E|

A profit/emp
Al Assets

dll %profit/sales
[] Match case

Current Selection @|

Selectrows | if 5| conditions are met

[equals

Add Condition|

[Rem ove Selected Conditions

[] Keep dialog open

JMP selects all of the rows that have Size Co equal to medium. There are seven.

View or Change Column Information

Information about a column is not limited to the data in the column. Data type, modeling
type, format, and formulas can also be set.

To view or change column characteristics, double-click the column heading. Or, right-click the
column heading and select Column Info. The Column Info window appears.
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Figure 3.11 Column Info Window

‘Yeprofit/sales’ in table 'Companies’
Column Name |%profitfsa|es

V| Lock Apply
DR g Numeric ¥
R Continuous v

[] Use thousands separator ()

Column Properties =
Formula Formula

- [] Suppress Eval
Edit Formula| ™7 5nore Errors
Profits ($M)

—— 100

Sales ($M)

]

Column Name Enter or change the column name. No two columns can have the same
column name.

Data Type Select one of the following data types:
— Numeric specifies the column values as numbers.
— Character specifies the column values as non-numeric, such as letters or symbols.
— Row State specifies the column values as row states. This is an advanced topic. See The

Column Info Window chapter in the Using JMP book.

Modeling Type Modeling types define how values are used in analyses. Select one of the
following modeling types:

— Continuous values are numeric only.
— Ordinal values are either numeric or character, and are ordered categories.
— Nominal values are either numeric or character, but not ordered.

Format Select a format for numeric values. This option is not available for character data.
Here are a few of the most common formats:

— Best lets JMP choose the best display format.
— Fixed Dec specifies the number of decimal places that appear.

— Date specifies the syntax for date values.
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— Time specifies the syntax for time values.

— Currency specifies the type of currency and decimal points that are used for currency
values.

Column Properties Set special column properties such as formulas, notes, and value
orders. See The Column Info Window chapter in the Using [MP book.

Lock Lock a column, so that the values in the column cannot be changed.

Calculate Values with Formulas

Use the Formula Editor to create columns that contain calculated values.

Scenario

The sample data table On-Time Arrivals.jmp reflects the percent of on-time arrivals for several
airlines. The data was collected for March, June, and August of 1999.

Create the Formula

Suppose that you want to create a new column containing the average on-time percentage for
each airline.

1. Add a new column.

2. Right-click the column heading of the new column and select Formula. The Formula Editor
window appears.
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Figure 3.12 Formula Editor

functions table columns keypad

B % | Mp Pro - O 'Y

£ ' |[=)5 Coumns T =X s A s 8)X)

Y Y Y Y Y Y Y Y Y YYXYTYTYYIYYY

Airline

Ro [ 5

¥ :’1 ; 4 March 1999
M 4 lune 1939

Transcendental A August 1999
Trigonometric Al

Character
Comparison
Conditional
Probability
Discrete Probability
Statistical

s
Date Time

Row State

Assignment

Parametric Model

Finance

MumberStuff

Table Variables e
Locked File

Source > Preview
Motes |

0K | Cancel | Apply Help

formula
elements

Create the formula for the average on-time percentage of each airline:

3.

4
5.
6

From the Columns list, select March 1999.
Click the [#] button on the keypad.

Select June 1999, followed by another [#/ sign.
Select August 1999.

Figure 3.13 Sum of the Months
March 1999 + | June 1999 +|August 1999

Notice that only August 1999 is selected (has the blue box around it).

7. Click on the box surrounding the entire formula.

Figure 3.14 Entire Formula Selected

| March 1999 + June 1999 + August 1999 |

8. Click the [¥ button.
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9. Type a 3 in the denominator box, and then click outside of the formula in any of the white
space.

Figure 3.15 Completed Formula

[ Warch 1999 + June 1999 + August 7999 |
3

10. Click OK

The new column contains the averages.

The Formula Editor has many built-in arithmetic and statistical functions. For example,
another way to calculate the average on-time arrival percentage is to use the Mean function in
the Statistical functions list. For details about all of the Formula Editor functions, see the
Formula Editor chapter in the Using JMP book.

Filter Data

Use the Data Filter to interactively select complex subsets of data, hide these subsets in plots,
or exclude them from analyses. For example, look at profit per employee for computer and
pharmaceutical companies.

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Analyze > Distribution.

3. Select profit/emp and click Y, Columns.
4. Click OK.
5

From the red triangle menu for profit/emp, select Display Options > Horizontal Layout.

Figure 3.16 Distribution of profit/emp

£ |~ Distributions

4 = profit/emp
— 4 Quantiles 4 [=|Summary Statistics
. e I . 100.0% maximum 66530.134582  Mean 1267918
99.5% 66530.134582  Std Dev 18382173
07.5% 66530134582 Std ErMean 32495300
90.0% 36850.360886  Upper05% Mean 1930666
75.0%  quartile 20481330706 Lower05% Mean 60516998
50.0%  median 09753126108 N 32

25.0% quartile 5421.5147598

10.0% -8428.620046
'—,— 2.5% -37800
0.5% -37800

-40000 -20000 O 20000 40000 60000 80000 0.0%  minimurm -37800

6. Turn on Automatic Recalc by selecting Redo > Automatic Recalc from the red triangle
menu for Distributions.
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When this option is on, every change that you make (for example, hiding or excluding
points) causes your report window to automatically update itself.

7. In the data table, select Rows > Data Filter.
8. Select Type and click Add.
9. Make sure that Select is selected.

10. To filter out the Pharmaceutical companies from the Distribution results, and include only
the Computer companies, click the Computer box in the Data Filter window.

The distribution results update to only include Computer companies.

Figure 3.17 Filter for Computer Companies

£ = Data Filter

[ Clear |[Fav0rites V|[ Help
Select [ Show [ Include

20 matching rows
[ Inverse

> Type (2)
[ i
anND || oR |

Click the Computer box to include only
computer companies in the
Distribution results.

4 [~ Distributions

4 = prefit/emp
— 4 Quantiles 4 =/ Summary Statistics
. = 100.0% maximum 66530134582  Mean 12670.18
99.5% 66530.134582  Std Dev 18382173
The graph and the 97.5% 66530.134582  Std Err Mean 32495399
it 90.0% 36850.2608%5  Upper95% Mean 1930666
Stat'St'CS_ report 75.0%  quartile 20481.330706  Lower 5% Mean 60516998
automatically reflect only 50.0%  median 9975.3126108 N 32
25.0%  quartile 54215147598
the rows that are i W Tt
selected. 2.5% -37800
0.5% -37800
-40000 -20000 O 20000 40000 60000 80000  0.0%  minimum -37800

Conversely, to change the Distribution results to include only the Pharmaceutical companies,
click the Pharmaceutical box on the Data Filter window.

Manage Data

The commands on the Tables menu (and Tabulate on the Analyze menu) summarize and
manipulate data tables into the format that you need for graphing and analyzing. This section
describes five of these commands:

Summary Creates a table that contains summary statistics that describe your data.
Tabulate Provides a drag and drop workspace to create summary statistics.

Subset Creates a table that contains a subset of your data.
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Join Joins the data from two data tables into one new data table.

Sort Sorts your data by one or more columns.

For complete details about these and the other Tables menu commands, see the Reshape Data
chapter in the Using [MP book.

View Summary Statistics

Summary statistics, such as sums and means, can instantly provide useful information about
your data. For example, if you look at the annual profit of each company out of thirty-two
companies, it’s difficult to compare the profits of small, medium, and large companies. A
summary shows that information immediately.

Create summary tables by using either the Summary or Tabulate commands. The Summary
command creates a new data table. As with any data table, you can perform analyses and
create graphs from the summary table. The Tabulate command creates a report window with a
table of summary data. You can also create a table from the Tabulate report.

Summary

A summary table contains statistics for each level of a grouping variable. For example, look at
the financial data for computer and pharmaceutical companies. Suppose that you want to
calculate the mean of sales and the mean of profits, for each combination of company type and
size.

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Tables > Summary.

3. Select Type and Size Co and click Group.

4. Select Sales ($M) and Profits ($M) and click Statistics > Mean.
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Figure 3.18 Completed Summary Window

Request Summary Statistics by Grouping Celumns.

Select Columns
| & Columns

Profits ($M)
dlz Employ
dprofit/emp
dlpssets
dlztprofit/sales
[] Include marginal statistics

For guantile statistics, enter value (3£)

i

: =)

statistics column name format

stat(column) -

Cutput table name:

Link to criginal data table

[] Keep dialeg open

5. Click OK.

Size Co

| Weight || o

Action

Mean(Sales ($M)) oK
hType Mean(Profits ($M))
thsize Co optional

Cancel

Rernove

Help
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JMP calculates the mean of Sales ($M) and the mean of Profit ($M) for each combination of Type

and Size Co.

Figure 3.19 Summary Table

-

|v Companies By (Type... [>| q

> Source - Type Size Co | N Rows | Mean(Sales ($M))
1 |Computer big 4 2059748

=) Columns (5/0) | 2 | Computer medium 2 301885

th Type & 3 Computer small 14 1758.06

:Ezscc’g 4 | Pharmaceutical | big 5 747404

A e 5 Pharmaceutical medium 5 426106

dll Mean(Profits ($M)] & 6 |Pharmaceutical small 2 108375

|v Rows |

All rows 6

Selected 0

Excluded 0

Hidden 0

Labelled ]

The summary table contains the following:

Mean(Profits
sM)

108993

-85.75

4494

89442

69898

156.95

¢ There are columns for each grouping variable (in this example, Type, and Size Co).

¢ The N Rows column shows the number of rows from the original table that correspond to
each combination of grouping variables. For example, the original data table contains 14
rows corresponding to small computer companies.
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e There is a column for each summary statistic requested. In this example, there is a column
for the mean of Sales ($M) and a column for the mean of Profits ($M).

The summary table is linked to the source table. Selecting a row in the summary table also
selects the corresponding rows in the source table.

Tabulate

Use the Tabulate command to drag columns into a workspace, creating summary statistics for
each combination of grouping variables. This example shows you how to use Tabulate to
create the same summary information that you just created using Summary.

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Analyze > Tabulate.

Figure 3.20 Tabulate Workspace

4= Tabulate

Interactive table ~ |

To use the interactive table, drag and drop columns or Drop zone for columns
statistics into a drop zone.

> 8 Columns M
‘T)rpe Mean
th 5ize Co Std Dev Drop zone for Resulting Cells
 Sales (SM) Min rows
Al Profits (SM) Max
Al #Employ Range
dll profit/emp % of Total
il Assets N Missing
dll %profit/sales N Categories

Sum

Sum Wgt
Weight I:I Variance

Std Err
age Column oV

Median
Quantiles
Column %

Row %
All
[C] Include missing for grouping columns
[C] Order by count of grouping columns
[C] Add Aggregate Statistics

Default Statistics|

3. Select both Type and Size Co.

4. Drag and drop them into the Drop zone for rows.
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Figure 3.21 Dragging Columns to the Row Zone

£ =/ Tabulate

Interactive table +

To use the interactive table, drag and drop columns or
statistics into a drop zone.

I8 Columns N

Asales (3M)
AProfits ($M)

5. Right-click a heading and select Nest Grouping Columns.

The initial tabulation shows the number of rows per group.

Figure 3.22 Initial Tabulation

Type Size Co
Computer big
medium
small 1
Pharmaceutical |big
medium
small

R NN e R e |

Drop zone for columns

Drop zone for
rows

Resulting Cells

Chapter 3
Discovering JMP

6. Select both Sales ($M) and Profits ($M), and drag and drop them over the N in the table.

Figure 3.23 Adding Sales and Profit

To add to the table, drag and drop celumns or statistics
into the column header or row label area of the table.

[ Undo ][StartOverH Done
I8 Columns

hType
WhSize Co

Type Size Co N
Computer biq/ 4
/meclium 2
small 14
Pharmaceutical |big 5
medium 5
small 2

The tabulation now shows the sum of Sales ($M) and the sum of Profits ($§M) per group.

Figure 3.24 Tabulation of Sums

Sales ($M)| Profits ($M)

Type Size Co Sum Sum
Computer big 823809 43597
medium 6037.7 -171.5
small 24612.8 629.1
Pharmaceutical |big 373702 44721
medium 21305.3 34949
small 2167.5 3139
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7. The final step is to change the sums to means. Right-click Sum (either of them) and select
Statistics > Mean.

Figure 3.25 Final Tabulation

Sales ($M) | Profits (SM) |

Type Size Co Mean Mean
Computer big 2059748 10899
medium 3018.85 -85.75

small 175806 4404

Pharmaceutical |big 747404 §94.42
medium 4261.06 608.98

small 108375 156.95

The means are the same as those obtained using the Summary command. Compare
Figure 3.25 to Figure 3.19.

Create Subsets

If you want to look closely at only part of your data table, you can create a subset. For
example, suppose that you have already compared the sales and profits of big, medium, and
small computer and pharmaceutical companies. Now you want to look at the sales and profits
of only the medium-sized companies.

Creating a subset is a two-step process. First select the target data, and then extract the data
into a new table.

Subset with the Subset Command

1. Select Help > Sample Data Library and open Companies.jmp.

Selecting the Rows and Columns That You Want to Subset

2. Select Rows > Row Selection > Select Where.

Select Size Co in the column list box on the left.

Click OK.

3

4. Enter medium in the text enter box.

5

6. Hold down the Ctrl key and select the Type, Sales ($M), and Profits ($M) columns.

Creating the Subset Table

7. Select Tables > Subset to launch the Subset window.



20 Work with Your Data

Chapter 3
Manage Data

Discovering JMP

Figure 3.26 Subset Window
Creates a new data table from the selected rows and celumns of the
source data table, or within each group generated with the 'by’ columns.

Subset by Action

Rows E'
All rows Cancel |

@ Selected Rows

Random - sampling rate : 05 Recall |
Random - sample size : 16
Stratify E'

Columns

@ All columns () Selected columns
Keep by columns

Cutput table name: |Subset of Companies

Link to criginal data table
| Copy formula

| Suppress formula evaluation
Save Default Options|

Keep dialog open

8. Select Selected columns to subset only the columns that you selected. You can also
customize your subset table further by selecting additional options.

9. Click OK.
The resulting subset data table has seven rows and three columns. For complete details about

the Subset command, see the Reshape Data chapter in the Using JMP book.

Subset with the Distribution Platform
Another way to create subsets uses the connection between platform results and data tables.

Example of Creating a Subset Using the Distribution Command
Select Help > Sample Data Library and open Companies.jmp.
Select Analyze > Distribution.

Select Type and click Y, Columns.

Click OK.

U e

Double-click on the histogram bar that represents Computer to create a subset table of the
Computer companies.

Caution: This method creates a linked subset table. This means if you make any changes to the
data in the subset table, the corresponding value changes in the source table.
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Join Data Tables

Use the Join option to combine information from multiple data tables into a single data table.
For example, suppose that you have a data table containing results from an experiment on
popcorn yields. In another data table, you have the results of a second experiment on popcorn
yields. To compare the two experiments or to analyze the trials using both sets of results, you
need to have the data in the same table. Also, the experimental data was not entered into the
data tables in the same order. One of the columns has a different name, and the second
experiment is incomplete. This means that you cannot copy and paste from one table into
another.

Example of Joining Two Data Tables

9.

NS ol e

Select Help > Sample Data Library and open Trial1.jmp and Little.jmp.

Click on Trial1.jmp to make it the active data table.

Select Tables > Join.

In the Join ‘Trial1’ With box, select Little.

From the Matching Specification menu, select By Matching Columns.

In the Source Columns boxes, select popcorn in both boxes, and then click Match.
In the same way, match batch and oil amt to oil in both boxes.

Your matching columns do not have to have the same name.

Select Include non-matches for both tables.

Since one experiment is partial, you want to include all rows, including any with missing
data.

To avoid duplicate columns, select the Select columns for joined table option.

10. From Triall1, select all four columns and click Select.

11. From Little, select only yield and click Select.
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Figure 3.27 Completed Join Window
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Sort Tables

Use the Sort command to sort a data table by one or more columns in the data table. For
example, look at financial data for computer and pharmaceutical companies. Suppose that
you want to sort the data table by Type, then by Profits ($M). Also, you want Profits ($M) to be in
descending order within each Type.

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Tables > Sort.

3. Select Type and click By to assign Type as a sorting variable.
4. Select Profits ($M) and click By.

At this point, both variables are set to be sorted in ascending order. See the ascending icon
next to the variables in Figure 3.29.

Figure 3.29 Sort Ascending Icon
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Cutput table name:
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5. To change Profits ($M) to sort in descending order, select Profits ($M) and click the
descending button.

Figure 3.30 Change Profits to Descending

oy )= e

Remove | optiona
5

Descending button

The icon next to Profits ($M) changes to descending.
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6. Select the Replace Table check box.

When selected, the Replace Table option tells JMP to sort the original data table instead of
creating a new table with the sorted values. This option is not available if there are any
open report windows created from the original data table. Sorting a data table with open
report windows might change how some of the data is displayed in the report window,
especially in graphs.

7. Click OK.

The data table is now sorted by type alphabetically, and by descending profit totals within
type.
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Visualize Your Data
Common Graphs

Visualizing your data is an important first step. The graphs described in this chapter help you
discover important details about your data. For example, histograms show you the shape and
range of your data, and help you find unusual data points.

This chapter presents several of the most common graphs and plots that enable you to
visualize and explore data in JMP. This chapter is an introduction to some of JMP’s graphical
tools and platforms. Use JMP to visualize the distribution of single variables, or the
relationships among multiple variables.

Figure 4.1 Visualizing Data with JMP
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Analyze Single Variables

Single-variable graphs, or univariate graphs, let you look closely at one variable at a time.
When you begin to look at your data, it’s important to learn about each variable before looking
at how the variables interact with each other. Univariate graphs let you visualize each variable
individually.

This section covers two graphs that show the distribution of a single variable:

¢ “Histograms” on page 97, for continuous variables

e “Bar Charts” on page 99, for categorical variables

Use the Distribution platform to create both of these graphs. Distribution produces a graphical
description and descriptive statistics for each variable.

Histograms
The histogram is one of the most useful graphical tools for understanding the distribution of a
continuous variable. Use a histogram to find the following in your data:

* the average value and variation

e extreme values

Figure 4.2 Example of a Histogram
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Scenario

This example uses the Companies.jmp data table, which contains data on profits for a group of
companies.

A financial analyst wants to explore the following questions:

* Generally, how much profit does each company earn?

e What is the average profit?
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® Are there any companies that earn either extremely high or extremely low profits
compared to the other companies?

To answer these questions, use a histogram of Profits ($M).

Create the Histogram

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Analyze > Distribution.
3. Select Profits ($M) and click Y, Columns.

Figure 4.3 Distribution Window for Profits ($M)

The distribution of values in each column

Select Columns Cast Selected Columns into Roles Action

* |8 Columns Y, Columns| ll Profits (SM) oK |
i Type optional
i Size Co @|
A Sales ($M)
A Profits ($M) - optional numeric
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A Seprofit/sales By | optional Help |

[T] Histograms Only

4. Click OK.

Figure 4.4 Histogram of Profits ($M)
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Interpret the Histogram

The histogram provides these answers:

® Most companies’ profits are between $-1000 and $1500.

All the bars except for one are located in this range. Also, more companies’ profits range
from $0 to $500 than any other range. The bar representing that range is much longer than
the others.
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* The average profit is a little less than $500.

The middle of the diamond in the box plot indicates the mean value. In this case, the mean
is slightly lower than the $500 mark.

¢ One company has significantly higher profits than the others, and might be an outlier. An
outlier is a data point that is separated from the general pattern of the other data points.

This outlier is represented by a single, very short bar at the top of the histogram. The bar is
small and represents a small group (in this case, a single company), and it is widely
separated from the rest of the histogram bars.

In addition to the histogram, this report includes the following:

¢ The box plot, which is another graphical summary of the data. For detailed information
about the box plot, see the Graph Builder chapter in the Essential Graphing book.

* Quantiles and Summary Statistics reports. These reports are discussed in “Analyze
Distributions” on page 139 in the “Analyze Your Data” chapter.

Interact with the Histogram

Data tables and reports are all connected in JMP. Click on a histogram bar to select the
corresponding rows in the data table.

Bar Charts

Use a bar chart to visualize the distribution of a categorical variable. A bar chart looks similar
to a histogram, since they both have bars that correspond to the levels of a variable. A bar
chart shows a bar for every level of the variable, whereas the histogram shows a range of
values for the variable.

Figure 4.5 Example of a Bar Chart
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Scenario

This example uses the Companies.jmp data table, which contains data on the size and type of a
group of companies.

A financial analyst wants to explore the following questions:

*  What is the most common type of company?

e What is the most common size for a company?

To answer these questions, use bar charts of Type and Size Co.

Create the Bar Chart

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Analyze > Distribution.

3. Select Type and Size Co and click Y, Columns.

4. Click OK.

Figure 4.6 Bar Charts of Type and Size Co

4|~ Distributions

4= Type 4|~ Size Co
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Bar Charts
medium
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big
4 Frequencies 4 Frequencies
Summary Level Count Prob Level Count Prob
Information Computer 20 0.62500 big 9 028125
Pharmaceutical 12 0.37500 medium 7 021875
Total 32 1.00000 small 16 0.50000
M Missing 0 Total 32 1.00000
2 Levels M Missing 0
3 Levels

Interpret the Bar Charts

The bar charts provide these answers:

¢ There are more computer companies than pharmaceutical companies.
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The bar that represents computer companies is larger than the bar that represents
pharmaceutical companies.

¢ The most common company size is small.
The bar that represents small companies is larger than the bars that represent medium and

big companies.

The additional summary output gives detailed frequencies. This report is discussed in
“Distributions of Categorical Variables” on page 142 in the “Analyze Your Data” chapter.

Interact with the Bar Charts

As is the case with histograms, click on individual bars to highlight rows of the data table. If
more than one graph is created, clicking on a bar in one bar chart highlights the corresponding
bar or bars in the other bar chart.

For example, suppose that you want to see the distribution of company size for the
pharmaceutical companies. Click the Pharmaceutical bar in the Type bar chart, and the
pharmaceutical companies are highlighted on the Size Co bar chart. Figure 4.7 shows that
although most companies in this data table are small, most of the pharmaceutical companies
are medium or big.

Also, the corresponding rows in the data table are selected.

Figure 4.7 Clicking Bars

Click on this bar to select the corresponding data in the other chart.
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Compare Multiple Variables

Use multiple-variable graphs to visualize the relationships and patterns between two or more
variables. This section covers the following graphs:

Table 4.1 Multiple-Variable Graphs

“Scatterplots” on page 102

“Scatterplot Matrix” on
page 106

“Side-by-Side Box Plots”
on page 109

“Opverlay Plots” on
page 112

“Variability Chart” on
page 115

“Graph Builder” on
page 118

“Bubble Plots” on page 124

Use scatterplots to compare two continuous variables.

Use scatterplot matrices to compare several pairs of
continuous variables.

Use side-by-side box plots to compare one continuous and
one categorical variable.

Use overlay plots to compare one or more variables on the
Y-axis to another variable on the X-axis. Overlay plots are
especially useful if the X variable is a time variable, because
you can compare how two or more variables change across
time.

Use variability charts to compare one continuous Y variable
to one or more categorical X variables. Variability charts
show differences in means and variability across several
categorical X variables.

Use Graph Builder to create and change graphs interactively.

Bubble plots are specialized scatterplots that use color and
bubble sizes to represent up to five variables at once. If one
of your variables is a time variable, you can animate the plot
to see your other variables change through time.

Scatterplots

The scatterplot is the simplest of all the multiple-variable graphs. Use scatterplots to
determine the relationship between two continuous variables and to discover whether two
continuous variables are correlated. Correlation indicates how closely two variables are related.
When you have two variables that are highly correlated, one might influence the other. Or,
both might be influenced by other variables in a similar way.
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Figure 4.8 Example of a Scatterplot
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Scenario

This example uses the Companies.jmp data table, which contains sales figures and the number
of employees of a group of companies.

A financial analyst wants to explore the following questions:

* What is the relationship between sales and the number of employees?
* Does the amount of sales increase with the number of employees?

e (Can you predict average sales from the number of employees?

To answer these questions, use a scatterplot of Sales ($M) versus # Employ.

Create the Scatterplot

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Analyze > Fit Y by X.

3. Select Sales ($M) and Y, Response.

4. Select # Employ and X, Factor.
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Figure 4.9 FitY by X Window
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Figure 4.10 Scatterplot of Sales ($M) versus # Employ
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Interpret the Scatterplot

One company has a large number of employees and high sales, represented by the single
point at the top right of the plot. The distance between this data point and all the rest makes it
difficult to visualize the relationship between the rest of the companies. Remove the point
from the plot and re-create the plot by following these steps:

1. Click on the point to select it.

2. Select Rows > Hide and Exclude. The data point is hidden and no longer included in
calculations.
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Note: The difference between hiding and excluding is important. Hiding a point removes
it from any graphs but statistical calculations continue to use the point. Excluding a point
removes it from any statistical calculations but does not remove it from graphs. When you
both hide and exclude a point, you remove it from all calculations and from all graphs.

3. To re-create the plot without the outlier, select Redo > Redo Analysis from the red triangle
menu for Bivariate. You can close the original report window.

Figure 4.11 Scatterplot with the Outlier Removed
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The updated scatterplot provides these answers:

* There is a relationship between the sales and the number of employees.

The data points have a discernible pattern. They are not scattered randomly throughout
the graph. You could draw a diagonal line that would be near most of the data points.

¢ Sales do increase with the number of employees, and the relationship is linear.

If you drew that diagonal line, it would slope from bottom left to top right. This slope
shows that as the number of employees increases (left to right on the bottom axis), sales
also increases (bottom to top on the left axis). A straight line would be near most of the
data points, indicating a linear relationship. If you would have to curve your line to be
near the data points, there would still be a relationship (because of the pattern of the
points). However, that relationship would not be linear.

* You can predict average sales from the number of employees.

The scatterplot shows that sales generally increase as the number of employees does. You
could predict the sales for a company if you knew only the number of employees of that
company. Your prediction would be on that imaginary line. It would not be exact, but it
would approximate the real sales.
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Interact with the Scatterplot

As with other JMP graphics, the scatterplot is interactive. Place your mouse pointer over the
point in the bottom right corner with the mouse to reveal the row number and the x and y
values.

Figure 4.12 Place Your Mouse Pointer Over a Point
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Click on a point to highlight the corresponding row in the data table. Select multiple points by
doing one of the following:

* C(lick and drag with the mouse around the points. This selects points in a rectangular area.

® Select the lasso tool, and then click and drag around multiple points. The lasso tool selects
an irregularly shaped area.

Scatterplot Matrix

A scatterplot matrix is a collection of scatterplots organized into a grid (or matrix). Each
scatterplot shows the relationship between a pair of variables.
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Figure 4.13 Example of a Scatterplot Matrix

4|~ Scatterplot Matrix

3]
2]
14 .
0. "=
A4 - -

Chloroform

Benzene

Hexane
AN
1

-5 I-IIIIIIII'I-'I'I'I'I II'-I'I'I'II
15001020 210123 21012
Ether Chloroform Benzene

Scenario

This example uses the Solubility.jmp data table, which contains data for solubility
measurements for 72 different solutes.

A lab technician wants to explore the following questions:

¢ Is there a relationship between any pair of chemicals? (There are six possible pairs.)

¢ Which pair has the strongest relationship?

To answer these questions, use a scatterplot matrix of the four solvents.

Create the Scatterplot Matrix

1. Select Help > Sample Data Library and open Solubility.jmp.
2. Select Graph > Scatterplot Matrix.

3. Select Ether, Chloroform, Benzene, and Hexane, and click Y, Columns.
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Figure 4.14 Scatterplot Matrix Window
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4. Click OK.

Figure 4.15 Scatterplot Matrix
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Interpret the Scatterplot Matrix

The scatterplot matrix provides these answers:

Action

oK
Cancel

Remove

Recall

Help

* All six pairs of variables are positively correlated.

As one variable increases, the other variable increases too.

¢ The strongest relationship appears to be between Benzene and Chloroform.

Chapter 4
Discovering JMP

The data points in the scatterplot for Benzene and Chloroform are the most tightly clustered

along an imaginary line.
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Interact with the Scatterplot Matrix

If you select a point in one scatterplot, it is selected in all the other scatterplots.

For example, if you select a point in the Benzene versus Chloroform scatterplot, the same point
is selected in the other five plots.

Figure 4.16 Selected Points
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Side-by-Side Box Plots

Side-by-side box plots show the following:

¢ the relationship between one continuous variable and one categorical variable

e differences in the continuous variable across levels of the categorical variable
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Figure 4.17 Example of Side-by-Side Box Plots
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Scenario

This example uses the Analgesics.jmp data table, which contains data on pain measurements
taken on patients using three different drugs.

A researcher wants to explore the following questions:

Are there differences in the average amount of pain control among the drugs?

Does the variability in the pain control given by each drug differ? A drug with high
variability would not be as reliable as a drug with low variability.

To answer these questions, use a side-by-side box plot for the pain levels and the drug
categories.

Create the Side-by-Side Box Plots

1
2
3.
4

Select Help > Sample Data Library and open Analgesics.jmp.
Select Analyze > Fit Y by X.
Select pain and click Y, Response.

Select drug and click X, Factor.
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Figure 4.18 FitY by X Window
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5. Click OK.
6. From the red triangle menu, select Display Options > Box Plots.

Figure 4.19 Side-by-Side Box Plots
box plot
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Interpret the Side-by-Side Box Plots

Box plots are designed according to the following principles:

* The line through the box represents the median.

* The middle half of the data is within the box.

¢ The majority of the data falls between the ends of the whiskers.
* A data point outside the whiskers might be an outlier.

The box plots in Figure 4.19 show these answers:

e There is evidence to believe that patients on drug A feel less pain, since the box plot for
drug A is lower on the pain scale than the others.

111
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* Drug B appears to have higher variability than Drugs A and C, since the box plot is taller.

There is one point for drug C that is a lot lower than the other points for drug C. Place your
mouse pointer over it with your mouse to see that it is row 26 of the data table. That point
looks like it is more similar to the data in drug group A or B. The information in row 26
deserves investigation. There might have been a typographical error when the data was
recorded.

Overlay Plots

Like scatterplots, overlay plots show the relationship between two or more variables.
However, if one of the variables is a time variable, an overlay plot shows trends across time
better than scatterplots do.

Figure 4.20 Example of an Overlay Plot
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Note: To plot data over time, you can also use Graph Builder, bubble plots, control charts, and
variability charts. For complete details about Graph Builder and bubble plots, see the Graph
Builder chapter in the Essential Graphing book. Refer to the Control Chart Builder chapter and
the Variability Gauge Charts chapter in the Quality and Process Methods book for information
about control charts and variability charts.

Scenario

This example uses the Stock Prices.jmp data table, which contains data on the price of a stock
over a three-month period.

A potential investor wants to explore the following questions:

¢ Has the stock’s closing price changed over the past three months?

To answer this question, use an overlay plot of the stock’s closing price over time.
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e How do the stock’s high and low prices relate to each other?

To answer this question, use another overlay plot of the stock’s high and low prices over
time.

Create the first overlay plot to answer the first question, and then create a second overlay plot
to answer the second question.

Create the Overlay Plot of the Stock’s Price over Time

1. Select Help > Sample Data Library and open Stock Prices.jmp.
2. Select Graph > Legacy > Overlay Plot.

3. Select Close and click Y.

4. Select Date and click X.

Figure 4.21 Overlay Plot Window
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5. Click OK.
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Figure 4.22 Overlay Plot of the Closing Price over Time
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Interpret and Interact with the Overlay Plot

The overlay plot shows that the closing stock price has been decreasing over the last several
months. To see the trend more clearly, connect the points and add grid lines.

1. From the red triangle menu, select Connect Thru Missing.
2. Double-click the Y axis.

3. Select the Major Grid Lines check box.

4. Click OK.

Figure 4.23 Connected Points and Grid Lines
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The potential investor can see that although the stock price has gone up and down over the
past three months, the overall trend has been downward.
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Create the Overlay Plot of the Stock’s High and Low Prices

Use an overlay plot to plot more than one Y variable. For example, suppose that you want to
see both the high and the low prices on the same plot.

1. Follow the steps in “Create the Overlay Plot of the Stock’s Price over Time” on page 113,
this time assigning both High and Low to the Y role.

2. Connect the points and add grid lines as shown in “Interpret and Interact with the Overlay
Plot” on page 114.

Figure 4.24 Two Y Variables
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The legend at the bottom of the plot shows the colors and markers used for the High and Low
variables in the graph. The overlay plot shows that the High price and Low price track each
other very closely.

Answer the Questions

Both of the overlay plots answer the two questions asked at the beginning of this example.

e The first plot shows that the price of this stock has not remained the same, but has been
decreasing.

® The second plot shows that the high and low prices of this stock are not very different
from each other. The stock price does not vary wildly on any given day.

Variability Chart

In the graphs described so far, you specified only a single X variable. Use a variability chart to
specify multiple X variables and see differences in means and variability across all of your
variables at once.
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Figure 4.25 Example of a Variability Chart
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Scenario

This example uses the Popcorn.jmp data table with data from a popcorn maker. The yield (the
volume of popcorn for a given measure of kernels) was measured for each combination of
popcorn style, batch size, and amount of oil used.

The popcorn maker wants to explore the following question:
*  Which combination of factors results in the highest popcorn yield?

To answer this question, use a variability chart of the yield versus the style, batch size, and oil
amount.

Create the Variability Chart

Select Help > Sample Data Library and open Popcorn.jmp.

Select Analyze > Quality and Process > Variability/Attribute Gauge Chart.
Select yield and click Y, Response.

Select popcorn and click X, Grouping.

Select batch and click X, Grouping.

AL N A

Select oil amt and click X, Grouping.

Note: The order in which you assign the variables to the X, Grouping role is important,
because the order in this window determines their nesting order in the variability chart.
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Figure 4.26 Variability Chart Window
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7. Click OK.

The top chart is the variability chart, showing the yield broken down by each combination
of the three variables. The bottom chart shows the standard deviation for each
combination of the three variables. Since the bottom chart does not show the yield, hide it.

8. Deselect Std Dev Chart on the red triangle menu.

Figure 4.27 Results Window
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Interpret the Variability Chart

The variability chart for yield indicates that small, gourmet batches produce the highest yield.

To be more specific, the popcorn maker might ask this additional question: Is the yield high
because those batches are small, or because those batches are gourmet?

The variability chart shows the following;:
¢ The yield from small, plain batches is low.
e The yield from large, gourmet batches is low.

Given this information, the popcorn maker can conclude that only the combination of small
and gourmet at the same time results in batches with high yield. It would have been
impossible to reach this conclusion with a chart that only allowed a single variable.

Graph Builder

Use Graph Builder to interactively create and modify graphs. Most graphs in JMP are created
by launching a platform and specifying variables. If you want to create a different type of
graph, you launch a specific platform from the Graph menu. However, with Graph Builder,
you can change the variables and change the type of graph at any time.

Use Graph Builder to accomplish the following tasks:
* Change variables by dragging and dropping them in and out of the graph.

* Create a different type of graph with a few mouse clicks.

¢ Partition the graph horizontally or vertically.



Chapter 4 Visualize Your Data 119
Discovering JMP Compare Multiple Variables

Figure 4.28 Example of a Graph That Was Created with Graph Builder
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Note: Only some of the Graph Builder features are covered here. For complete details, see the
Graph Builder chapter in the Essential Graphing book.

Scenario

This example uses the Profit by Product.jmp data table, which contains profit data for multiple
product lines.

A business analyst wants to explore the following question:
* How is the profitability different between product lines?

To answer this question, use a line plot that displays revenue, product cost, and profit data
across different product lines.

Create the Graph

1. Select Help > Sample Data Library and open Profit by Product.jmp.
2. Select Graph > Graph Builder.
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Figure 4.29 Graph Builder Workspace
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3. Click Quarter and then drag and drop it onto the X zone to assign Quarter as the X variable.

4. Click Revenue, Product Cost, and Profit, and drag and drop them onto the Y zone to assign

—

Map
Shape

Freq

Page

all three variables as Y variables.

The X and Y zones are now axes.

Note: You can also click on variables and then click a zone to assign them. However, after

a zone becomes an axis, drag and drop additional variables onto the axis rather than
clicking on the variables and axis.
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Figure 4.30 After Adding Y and X Variables
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Based on the variables that you are using, Graph Builder shows side-by-side box plots.

5. To change the box plots to a line plot, click the Line ~/ icon.
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Figure 4.31 Line Plot
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6. To create a separate chart for each product, click Product Line, and drag and drop it into

the Wrap zone.

A separate line plot is created for each product.
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Figure 4.32 Final Line Plots
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Figure 4.32 shows revenue, cost, and profit broken down by product line. The business
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analyst was interested in seeing the difference in profitability between product lines. The line

plots in Figure 4.32 can provide some answers, as follows:

¢ Credit products, deposit products, and revolving credit products produce more revenue
than fee-based products, third-party products, and other products.

* However, the profits of all the product lines are similar.

The data table also includes data on sales channels. The business analyst wants to see how

revenue, product cost, and profit differ between different sales channels.

1. To remove Product Line from the graph, click the title of the graph (Product Line) and drag

and drop it into any empty area within Graph Builder.

2. To add Channel as the wrap variable, click Channel and drag and drop it into the Wrap
zone.
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Figure 4.33 Line Plots Showing Sales Channels
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Figure 4.33 provides this answer: revenue and product cost for ATMs are the highest and are

growing the most quickly.

Bubble Plots

A bubble plot is a scatterplot that represents its points as bubbles. You can change the size and
color of the bubbles, and even animate them over time. With the ability to represent up to five
dimensions (x position, y position, size, color, and time), a bubble plot can produce dramatic

visualizations and make data exploration easy.
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Figure 4.34 Example of a Bubble Plot
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This example uses the PopAgeGroup.jmp data table, which contains population statistics for

116 countries or territories between the years 1950 to 2004. Total population numbers are

broken out by age group, and not every country has data for every year.

A sociologist wants to explore the following question:
* Is the age of the population of the world changing?

To answer this question, look at the relationship between the oldest (more than 59) and the

youngest (younger than 20) portions of the population. Use a bubble plot to determine how
this relationship changes over time.

Create the Bubble Plot

1. Select Help > Sample Data Library and open PopAgeGroup.jmp.
2. Select Graph > Bubble Plot.
3. Select Portion60+ and click Y.

This corresponds to the Y variable on the bubble plot.

4. Select Portion 0-19 and click X.
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This corresponds to the X variable on the bubble plot.
5. Select Country and click ID.
Each unique level of the ID variable is represented by a bubble on the plot.
6. Select Year and click Time.
This controls the time indexing when the bubble plot is animated.
7. Select Pop and click Sizes.
This controls the size of the bubbles.
8. Select Region and click Coloring.

Each level of the Coloring variable is assigned a unique color. So in this example, all the
bubbles for countries located in the same region have the same color. The bubble colors
that appear in Figure 4.36 are the JMP default colors.

Figure 4.35 Bubble Plot Launch Window
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9. Click OK.
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Figure 4.36 Initial Bubble Plot
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Interpret the Bubble Plot

Because the time variable (in this case, year) starts in 1950, the initial bubble plot shows the
data for 1950. Animate the bubble plot to cycle through all the years by clicking the play/pause
button. Each successive bubble plot shows the data for that year. The data for each year
determines the following:

® The X and Y coordinates
* The bubble’s sizes

* The bubble’s coloring

* Bubble aggregation

Note: For detailed information about how the bubble plot aggregates information across
multiple rows, see the Bubble Plots chapter in the Essential Graphing book.

The bubble plot for 1950 shows that if a country’s proportion of people younger than 20 is
high, then the proportion of people more than 59 is low.
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Click the play/pause button to animate the bubble plot through the range of years. As time
progresses, the Portion 0-19 decreases and the Portion60+ increases.

E plays the animation, turns to a pause button after you click it.

[ 1] pauses the animation.

manually controls the animation back one unit of time.

manually controls the animation forward one unit of time.
Year is used to change the time index manually.
Speed controls the speed of the animation.

Bubble Size controls the absolute sizes of the bubbles, while maintaining the relative sizes

The sociologist wanted to know how the age of the world’s population is changing. The
bubble plot indicates that the population of the world is getting older.

Interact with the Bubble Plot

Click to select a bubble to see the trend for that bubble over time. For example, in the 1950
plot, the large bubble in the middle is Japan.

To See the Pattern of Population Changes in Japan through the Years
1. Click in the middle of the Japan bubble to select it.

2. From the red triangle menu, select Trail Bubbles > Selected.

3. Click the play button.

As the animation progresses through time, the Japan bubble leaves a trail of bubbles that
illustrates its history.
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Figure 4.37 Japan’s History of Population Shifts
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Focusing on the Japan bubble, you can see the following over time:

The proportion of the population 19 years old or less decreased.

The proportion of the population 60 years old or more increased.

129
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Analyze Your Data
Distributions, Relationships, and Models

Analyzing your data helps you make informed decisions. Data analysis often involves these
actions:

¢ Examining distributions
¢ Discovering relationships
* Hypothesis testing

* Building models

Figure 5.1 Analysis Examples
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About This Chapter

Before you analyze your data, review the following information:

“The Importance of Graphing Your Data” on page 133
“Understand Modeling Types” on page 136

The rest of this chapter shows you how to use some basic analytical methods in JMP:

“Analyze Distributions” on page 139
“Analyze Relationships” on page 145

For a description of advanced modeling and analysis techniques, refer to the following JMP
books:

Fitting Linear Models

Multivariate Methods

Predictive and Specialized Modeling
Consumer Research

Reliability and Survival Methods
Quality and Process Methods

The Importance of Graphing Your Data

Graphing, or visualizing, your data is important to any data analysis, and should always
occur before the use of statistical tests or model building. To illustrate why data visualization
should be an early step in your data analysis process, consider the following example:

1.

Select Help > Sample Data Library and open Anscombe.jmp (F. ]. Anscombe (1973),
American Statistician, 27, 17-21).

This data consists of four pairs of X and Y variables.
In the Table panel, click the green triangle next to the The Quartet script.

The script creates a simple linear regression on each pair of variables using Fit Y by X. The
Show Points option is turned off, so that none of the data can be seen on the scatterplots.
Figure 5.2 shows the model fit and other summary information for each regression.
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Figure 5.2 Four Models
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Model for
pair 3

Model for
pair 4

Notice that all four models and the RSquare values are nearly identical. The fitted model in
each case is essentially Y =3 + 0.5X, and the RSquare value in each case is essentially 0.66. If
your data analysis took into account only the above summary information, you would likely
conclude that the relationship between X and Y is the same in each case. However, at this
point, you have not visualized your data. Your conclusion might be wrong.

To Visualize the Data, Add the Points to All Four Scatterplots

1. Hold down the Ctrl key.

2. From the red triangle menu for any one of the Bivariate Fits, select Show Points.
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Figure 5.3 Scatterplots with Points Added
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The scatterplots show that the relationship between X and Y is not the same for the four pairs,
although the lines describing the relationships are the same:

e Plot 1 represents a linear relationship.

* Plot 2 represents a non-linear relationship.

* Plot 3 represents a linear relationship, except for one outlier.

® Plot 4 has all the data at x = 8, except for one point.

This example illustrates that conclusions that are based on statistics alone can be inadequate.
A visual exploration of the data should be an early part of any data analysis.
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Understand Modeling Types

In JMP, data can be of different types. JMP refers to this as the modeling type of the data.
Table 5.1 describes the three modeling types in J]MP.

Table 5.1 Modeling Types

Modeling Type and Examples
Description
Continuous Height

Numeric data only. Used in ~ Temperature
operations like sums and
means.

Time

Ordinal Month (1,2,...,12)

Numeric or character data. Letter grade (A, B,...F)

Values belong to ordered Size (small, medium, large)

categories.
Nominal Gender (M or F)
Numeric or character data. Color

Values belong to categories,
but the order is not
important.

Test result (pass or fail)

Example of Viewing Modeling Type Results

Specific Example

The time to complete a test
might be 2 hours, or 2.13
hours.

The month of the year can
be 2 (February) or 3
(March), but not 2.13.
February comes before
March.

The gender can be M or F,
with no order. Gender
categories can also be
represented by a number
(M=1 and F=2).

Different modeling types produce different results in JMP. To see an example of the
differences, follow these steps:

1.

2
3.
4

Select Analyze > Distribution.
Select Age and Weight and click Y, Columns.
Click OK.

Select Help > Sample Data Library and open Linnerud.jmp.
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Figure 5.4 Distribution Results for Age and Weight
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Although Age and Weight are both numeric variables, they are not treated the same. Table 5.2
compares the differences between the results for weight and age.

Table 5.2 Results for weight and age

Variable
Weight

Age

Modeling Type

Continuous

Ordinal

Results

Histogram, Quantiles, and Summary Statistics

Bar chart and Frequencies

Change the Modeling Type

To treat a variable differently, change the modeling type. For example, in Figure 5.4, the
modeling type for Age is ordinal. Remember that for an ordinal variable, JMP calculates
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frequency counts. Suppose that you wanted to find the average age instead of frequency
counts. Change the modeling type to continuous, which shows the mean age.

1. Double-click the Age column heading. The Column Info window appears.

2. Change the Modeling Type to Continuous.

Figure 5.5 Column Info Window

‘Age' in table 'Linnerud" oK |
Column Name |Age @|
o (heey |

Format Fixed Dec | Width | 5] Dec[ 0]

[] Use thousands separator ()

Column Properties '|

[ Notes

optionat ttem Click to edit and key in comments about
column

Effect variable (X) for multiple
regression analysis, Use Fit Medel,
Rernove |
Click OK.

4. Repeat the steps in the example (see “Example of Viewing Modeling Type Results” on
page 136) to create the distribution. Figure 5.6 shows the distribution results when Age is
ordinal and continuous.
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Figure 5.6 Different Modeling Types for Age
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Continuous

When age is ordinal, you can see the frequency counts for each age. For example, age 48
appears two times. When age is continuous, you can find the mean age, which is nearly 48

(47.677)

Analyze Distributions

To analyze a single variable, you can examine the distribution of the variable, using the
Distribution platform. Report content for each variable varies, depending on whether the
variable is categorical (nominal or ordinal) or continuous.

Note: For complete details about the Distribution platform, see the Distributions chapter in the

Basic Analysis book.
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Distributions of Continuous Variables

Analyzing a continuous variable might include questions such as the following:

Does the shape of the data match any known distributions?

Are there any outliers in the data?

What is the average of the data?

Is the average statistically different from a target or historical value?

How spread out are the data? In other words, what is the standard deviation?

What are the minimum and maximum values?

You can answer these and other questions with graphs, summary statistics, and simple
statistical tests.

Scenario

This example uses the Car Physical Data.jmp data table, which contains information about 116
different car models.

A planning specialist has been asked by a railroad company to determine the possible issues
involved in transporting cars by train. Using the data, the planning specialist wants to explore
the following questions:

What is the average car weight?
How spread out are the cars” weights (standard deviation)?
What are the minimum and maximum weights of cars?

Are there any outliers in the data?

Use a histogram of weight to answer these questions.

Create the Histogram

O e

Select Help > Sample Data Library and open Car Physical Data.jmp.
Select Analyze > Distribution.

Select Weight and click Y, Columns.

Click OK.

To rotate the report window, select Display Options > Horizontal Layout from the red
triangle menu next to Weight.
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Figure 5.7 Distribution of Weight
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The report window contains three sections:

¢ A histogram and a box plot to visualize the data.
* A Quantiles report that shows the percentiles of the distribution.

* A Summary Statistics report that shows the mean, standard deviation, and other statistics.

Interpret the Distribution Results
Using the results presented in Figure 5.7, the planning specialist can answer the questions.
What is the average car weight? The Histogram shows a weight of around 3,000 lbs.

How spread out are the weights (standard deviation)? The Summary Statistics show a

weight of around 2,958 Ibs. The Summary Statistics show a standard deviation of around
536 Ibs.

What are the minimum and maximum weights? The Histogram shows a minimum of
around 1,500 Ibs. and a maximum of around 4,500 Ibs. The Quantiles show a minimum of
around 1,695 Ibs. and a maximum of around 4,285 Ibs.

Are there any outliers? No.

The default report window in Figure 5.7 provides a minimal set of graphs and statistics.
Additional graphs and statistics are available on the red triangle menu.

Draw Conclusions

Based on other research, the railroad company has determined that an average weight of 3000
pounds is the most efficient to transport. Now, the planning specialist needs to find out
whether the average car weight in the general population of cars that they might transport is
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3000 pounds. Use a t-test to draw inferences about the broader population based on this

sample of the population.

Test Conclusions

1. From the red triangle menu for Weight, select Test Mean.

2. In the window that appears, type 3000 in the Specify Hypothesized Mean box.

3. Click OK.

Figure 5.8 Test Mean Results

4 [=| Distributions
4 »'Weight
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2850 2950 3000 3050 3100

Interpret the t-Test

Distributions of Categorical Variables

The primary result of a t-test is the p-value. In this example, the p-value is 0.396 and the
analyst is using a significance level of 0.05. Since 0.396 is greater than 0.05, you cannot
conclude that the average weight of car models in the broader population is significantly
different from 3000 pounds. Had the p-value been lower than the significance level, the
planning specialist would have concluded that the average car weight in the broader

population is significantly different from 3000 pounds.

Analyzing a categorical (ordinal or nominal) variable might include questions such as the

following:

¢ How many levels does the variable have?
e How many data points does each level have?
e [s the data uniformly distributed?

¢ What proportions of the total do each level represent?
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See the scenario in “Distributions of Continuous Variables” on page 140.

Now that the railroad company has determined that the average weight of the cars is not
significantly different from the target weight, there are more questions to address.

The planning specialist wants to answer these questions for the railroad company:

What are the types of cars?

What are the countries of origin?

To answer these questions, look at the distribution for Type and Country.

Create the Distribution

Figure 5.9 Distribution for Country and Type

1
2
3.
4

Select Help > Sample Data Library and open Car Physical Data.jmp.

Select Analyze > Distribution.

Select Country and Type and click Y, Columns.

Click OK.
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Interpret the Distribution Results

The report window includes a bar chart and a Frequencies report for Country and Type. The
bar chart is a graphical representation of the frequency information provided in the
Frequencies report. The Frequencies report contains the following:

* Categories of data. For example, Japan is a category of Country, and Sporty is a category of
Type.
* Total counts for each category.

* Proportion of the total each category represents.

For example, there are 22 compact cars, or about 19% of the 116 observations.

Interact with the Distribution Results

Selecting a bar in one chart also selects the corresponding data in the other chart. For example,
select the Japan bar in the Country bar chart to see that a large number of Japanese cars are

sporty.

Figure 5.10 Japanese Cars

4 = Country 4= Type

Large

UsA
Medium
Other Compact
Srnall

Japan
Sporty

Select the Other category to see that a majority of these cars are small or compact, and almost
none are large.
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Figure 5.11 Other Cars
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Analyze Relationships

Scatterplots and other such graphs can help you visualize relationships between variables.
Once you have visualized relationships, the next step is to analyze those relationships so that
you can describe them numerically. That numerical description of the relationship between
variables is called a model. Even more importantly, a model also predicts the average value of
one variable (Y) from the value of another variable (X). The X variable is also called a
predictor. Generally, this model is called a regression model.

With JMP, the Fit Y by X platform and the Fit Model platform creates regression models.
Note: Only the basic platforms and options are covered here. For complete details and
explanations of all platform options, see Basic Analysis, Essential Graphing, and the books listed

in “About This Chapter” on page 133.

Table 5.3 shows the four primary types of relationships.

Table 5.3 Relationship Types

X Y Section
Continuous Continuous ¢ “Use Regression with One Predictor” on
page 146

’

¢ “Use Regression with Multiple Predictors”
on page 160
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Table 5.3 Relationship Types (Continued)

X Y Section
Categorical Continuous e “Compare Averages for One Variable” on
page 151
* “Compare Averages for Multiple Variables”
on page 156
Categorical Categorical “Compare Proportions” on page 154
Continuous Categorical Logistic regression is an advanced topic. See the
Logistic Analysis chapter in the Basic Analysis
book.

Use Regression with One Predictor

Scenario

This example uses the Companies.jmp data table, which contains financial data for 32
companies from the pharmaceutical and computer industries.

Intuitively, it makes sense that companies with more employees can generate more sales
revenue than companies with fewer employees. A data analyst wants to predict the overall
sales revenue for each company based on the number of employees.

To accomplish this task, do the following:

e “Discover the Relationship” on page 146
e “Fit the Regression Model” on page 147
e “Predict Average Sales” on page 149

Discover the Relationship

First, create a scatterplot to see the relationship between the number of employees and the
amount of sales revenue. This scatterplot was created in “Create the Scatterplot” on page 103
in the “Visualize Your Data” chapter. After hiding and excluding one outlier (a company with
significantly more employees and higher sales), the plot in Figure 5.12 shows the result.
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Figure 5.12 Scatterplot of Sales ($M) versus # Employ
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This scatterplot provides a clearer picture of the relationship between sales and the number of
employees. As expected, the more employees a company has, the higher sales that it can
generate. This visually confirms the data analyst’s guess, but it does not predict sales for a

given number of employees.

Fit the Regression Model

To predict the sales revenue from the number of employees, fit a regression model. From the
red triangle for Bivariate Fit, select Fit Line. A regression line is added to the scatterplot and

reports are added to the report window.
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Figure 5.13 Regression Line
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Within the reports, look at the following results:

e the p-value of <.0001
e the RSquare value of 0.618

From these results, the data analyst can conclude the following:

* The p-value for the #Employ model term is small. This supports that at the 0.05
significance level the coefficient for #Employ is not zero. Therefore, including the number
of employees in the prediction model significantly improves the ability to predict average
sales over a model without the number of employees.

¢ The RSquare value of 0.618 indicates that this model explains about 62% of the variability
in sales. The RSquare value is the coefficient of determination and indicates the proportion
of the variance in the dependent (response) variable that is explained by your model.
RSquare can range from 0 to 1. A model with an RSquare of 0 has no explanatory power. A
model with an RSquare of 1 predicts the response perfectly.
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Predict Average Sales

Use the regression model to predict the average sales a company might expect if they have a
certain number of employees. The prediction equation for the model is included in the report:

Average sales = 1059.68 + 0.092*employees
For example, in a company with 70,000 employees sales are predicted to be about $7,500:
$7,499.68 = 1059.68 + 0.092*70,000

In the lower right area of the current scatterplot, there is an outlier that does not follow the
general pattern of the other companies. The data analyst wants to know whether the
prediction model changes when this outlier is excluded.

Exclude the Outlier

1. Click on the outlier.
2. Select Rows > Exclude/Unexclude.
3. Fit this model by selecting Fit Line from the red triangle menu for Bivariate Fit.
The following are added to the report window (see Figure 5.14):
® anew regression line
* anew Linear Fit report, which includes:
— anew prediction equation

— anew RSquare value



150 Analyze Your Data
Analyze Relationships

Figure 5.14 Comparing the Models
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<4—— New regression line

90000

New prediction equation

New RSquare value

Using the results in Figure 5.14, the data analyst can make the following conclusions:

The outlier was pulling down the regression line for the larger companies, and pulling the

line up for the smaller companies.

The new model for the data without the outlier is a stronger model than the first model.
The new RSquare value of 0.88 is higher and closer to 1 than the initial analysis.
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Draw Conclusions
Using the new prediction equation, the predicted average sales for a company with 70,000
employees can be calculated as follows:
$8961.37 = 631.37 + 0.119*70,000

The prediction from the first model was about $7500. The second model predicts a sales total
of about $8960 or an increase of $1460 as compared to the first model.

The second model, after removing the outlier, describes and predicts sales totals based on the
number of employees better than the first model. The data analyst now has a good model to
use.

Compare Averages for One Variable

If you have a continuous Y variable, and a categorical X variable, you can compare averages
across the levels of the X variable.

Scenario

This example uses the Companies.jmp data table, which contains financial data for 32
companies from the pharmaceutical and computer industries.

A financial analyst wants to explore the following question:

* How do the profits of computer companies compare to the profits of pharmaceutical
companies?

To answer this question, fit Profits ($M) by Type.

Discover the Relationship

1. Select Help > Sample Data Library and open Companies.jmp.

2. If you still have the Companies.jmp sample data table open, you might have rows that are
excluded or hidden. To return the rows to the default state (all rows included and none
hidden), select Rows > Clear Row States.

Select Analyze > Fit Y by X.

Select Profits ($M) and click Y, Response.
Select Type and click X, Factor.

Click OK.

AL N
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Figure 5.15 Profits by Company Type
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There is an outlier in the Computer Type. The outlier is stretching the scale of the plot and
making it difficult to compare the profits. Exclude and hide the outlier:

1.

2
3.
4

Click on the outlier.
Select Rows > Exclude/Unexclude. The data point is no longer included in calculations.
Select Rows > Hide/Unhide. The data point is hidden from all graphs.

To re-create the plot without the outlier, select Redo > Redo Analysis from the red triangle
menu for Oneway Analysis. You can close the original Scatterplot window.

Figure 5.16 Updated Plot
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Removing the outlier gives the financial analyst a clearer picture of the data.

5.

To continue analyzing the relationship, select these options from the red triangle menu for
Oneway Analysis:

— Display Options > Mean Lines. This adds mean lines to the scatterplot.
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— Means and Std Dev. This displays a report that provides averages and standard
deviations.

Figure 5.17 Mean Lines and Report
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Interpret the Results

The financial analyst wanted to know how the profits of computer companies compared to the
profits of pharmaceutical companies. The updated scatterplot shows that pharmaceutical
companies have higher average profits than computer companies. In the report, if you
subtract one mean value from the other, the difference in profit is about $635 million. The plot
also shows that some of the computer companies have negative profits and all of the
pharmaceutical companies have positive profits.

Perform the T-test

The financial analyst has looked at only a sample of companies (the companies in the data
table). The financial analyst now wants to examine these questions:

* Does a difference exist in the broader population, or is the difference of $635 million due to
chance?

e [f there is a difference, what is it?

To answer these questions, perform a two-sample t-test. A t-test lets you use data from a
sample to make inferences about the larger population.

To perform the t-test, select Means/Anova/Pooled t from the red triangle for Oneway Analysis.
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Figure 5.18 t Test Results
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The p-value of 0.0001 is less than the significance level of 0.05, which indicates statistical
significance. Therefore, the financial analyst can conclude that the difference in average profits
for the sample data is not due to chance alone. This means that in the larger population, the
average profits for pharmaceutical companies are different from the average profits for
computer companies.

Draw Conclusions

Use the confidence interval limits to determine how much difference exists in the profits of
both types of companies. Look at the Upper CL Dif and Lower CL Dif values in Figure 5.18. The
financial analyst concludes that the average profit of pharmaceutical companies is between
$343 million and $926 million higher than the average profit of computer companies.

Compare Proportions

If you have categorical X and Y variables, you can compare the proportions of the levels
within the Y variable to the levels within the X variable.

Scenario

This example continues to use the Companies.jmp data table. In “Compare Averages for One
Variable” on page 151, a financial analyst determined that pharmaceutical companies have
higher profits on average than do computer companies.

The financial analyst wants to know whether the size of a company affects profits more for
one type of company than the other? However, before examining this question, the financial
analyst needs to know whether the populations of computer and pharmaceutical companies
consist of the same proportions of small, medium, and big companies.

Discover the Relationship

1. Select Help > Sample Data Library and open Companies.jmp.

2. If you still have the Companies.jmp data file open from the previous example, you might
have rows that are excluded or hidden. To return the rows to the default state (all rows
included and none hidden), select Rows > Clear Row States.
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Select Analyze > Fit Y by X.

3
4. Select Size Co and click Y, Response.
5. Select Type and click X, Factor.

6

Click OK.

Figure 5.19 Company Size by Company Type
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The Contingency Table contains information that is not applicable for this example. From the

red triangle menu for Contingency Table deselect Total % and Col % to remove that
information. Figure 5.20 shows the updated table.
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Figure 5.20 Updated Contingency Table
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Interpret the Results

The statistics in the Contingency Table are graphically represented in the Mosaic Plot.
Together, the Mosaic Plot and the Contingency Table compare the percentages of small,
medium, and big companies between the two industries. For example, the Mosaic Plot shows
that the computer industry has a higher percentage of small companies compared to the
pharmaceutical industry. The Contingency Table shows the exact statistics: 70% of computer
companies are small, and about 17% of pharmaceutical companies are small.

Interpret the Test

The financial analyst has looked at only a sample of companies (the companies in the data
table). The financial analyst needs to know whether the percentages differ in the broader
populations of all computer and pharmaceutical companies.

To answer this question, use the p-value from the Pearson test in the Tests report. See
Figure 5.19. Since the p-value of 0.011 is less than the significance level of 0.05, the financial
analyst concludes the following:

e The differences in the sample data are not due to chance alone.
* The percentages differ in the broader population.

Now the financial analyst knows that the proportions of small, medium, and big companies
are different, and can answer the question: Does the size of company affect profits more for
one type of company than the other?

Compare Averages for Multiple Variables

The section “Compare Averages for One Variable” on page 151, compared averages across the
levels of a categorical variable. To compare averages across the levels of two or more variables
at once, use the Analysis of Variance technique (or ANOVA).
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The financial analyst can answer the question that we started to work through in the
Comparing Proportions section, which is: Does the size of the company have a larger effect on
the company’s profits, based on type (pharmaceutical or computer)?

To answer this question, compare the company profits by these two variables:

Type (pharmaceutical or computer)

Size (small, medium, big)

Discover the Relationship

157

To visualize the differences in profit for all of the combinations of type and size, use a graph:

A A

Select Help > Sample Data Library and open Companies.jmp.

Select Graph > Graph Builder. The Graph Builder window appears.

Click Profits ($M) and drag and drop it into the Y zone.

Click Size Co and drag and drop it into the X zone.

Click Type and drag and drop it into the Group X zone.

Figure 5.21 Graph of Company Profits
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The graph shows that one big computer company has very large profits. That outlier is
stretching the scale of the graph, making it difficult to compare the other data points.

6. Select the outlier, then right-click and select Rows > Row Exclude. The point is removed,
and the scale of the graph automatically updates.

7. Click on the Bar ﬂﬂﬂ icon. Comparing mean profits is easier with bar charts than with
points.

Figure 5.22 Graph with Outlier Removed
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The updated graph shows that pharmaceutical companies have higher average profits. The
graph also shows that profits differ between company sizes for only the pharmaceutical
companies. When the effect of one variable (company size) changes for different levels of
another variable (company type), this is called an interaction.

Quantify the Relationship

Because this data is only a sample, the financial analyst needs to determine the following;:

e if the differences are limited to this sample and due to chance

or

e if the same patterns exist in the broader population
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1. Return to the Companies.jmp sample data table that has the data point excluded. See
“Discover the Relationship” on page 157.

N o gl LN

Select Analyze > Fit Model.

Select Profits (M) and click Y.

Select both Type and Size Co.

Click the Macros button and select Full Factorial.
From the Emphasis menu, select Effect Screening.

Select the Keep dialog open option.

Figure 5.23 Completed Fit Model Window
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8. Click Run. The report window shows the model results.

To decide whether the differences in profits are real, or due to chance, examine the Effect Tests

report.

Note: For complete details about all of the Fit Model results, see the Model Specification
chapter in the Fitting Linear Models book.

View Effect Tests

The Effect Tests report (see Figure 5.24) shows the results of the statistical tests. There is a test
for each of the effects included in the model on the Fit Model window: Type, Size Co, and

Type*Size Co.
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Figure 5.24 Effect Tests Report

4 Effect Tests

Sum of
Source Mparm DF Squares F Ratio Prob>F
Type 1 1 14018474 101368 0.0039*
Size Co 2 2 T24616.2 26198 00927
Type*Size Co 2 2 448061.5 1.6200 0.2180

First, look at the test for the interaction in the model: the Type*Size Co effect. Figure 5.22
showed that the pharmaceutical companies appeared to have different profits between
company sizes. However, the effect test indicates that there is no interaction between type and
size as it relates to profit. The p-value of 0.218 is large (greater than the significance level of
0.05). Therefore, remove that effect from the model, and re-run the model.

1. Return to the Fit Model window.

2. In the Construct Model Effects box, select the Type*Size Co effect and click Remove.

3. Click Run.

Figure 5.25 Updated Effect Tests Report

< Effect Tests

Sum of

Source MNparm DF Squares F Ratio Prob>F
Type 1 1 1,356,298 9.3768  0.0049*
Size Co 2 2 434,161.3 15008  0.2410

The p-value for the Size Co effect is large, indicating that there are no differences based on size
in the broader population. The p-value for the Type effect is small, indicating that the
differences that you saw in the data between computer and pharmaceutical companies is not
due to chance.

Draw Conclusions

The financial analyst wanted to know whether the size of the company has a larger effect on
the company’s profits, based on type (pharmaceutical or computer).The financial analyst can
now answer the question as follows:

* There is a real difference in profits between computer and pharmaceutical companies in
the broader population.

® There is no correlation between the company’s size and type and its profits.

Use Regression with Multiple Predictors

The section “Use Regression with One Predictor” on page 146 showed you how to build
simple regression models consisting of one predictor variable and one response variable.
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Multiple regression predicts the average response variable using two or more predictor
variables.

Scenario
This example uses the Candy Bars.jmp data table, which contains nutrition information for
candy bars.
A dietitian wants to predict calories using the following information:
¢ Total fat
* Carbohydrates

e Protein

Use multiple regression to predict the average response variable using these three predictor
variables.

Discover the Relationship

To visualize the relationship between calories and total fat, carbohydrates, and protein, create
a scatterplot matrix:

Select Help > Sample Data Library and open Candy Bars.jmp.
Select Graph > Scatterplot Matrix.

Select Calories and click Y, Columns.

Select Total fat g, Carbohydrate g, and Protein g, and click X.
Click OK.

A

Figure 5.26 Scatterplot Matrix Results
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The scatterplot matrix shows that there is a positive correlation between calories and all three
variables. The correlation between calories and total fat is the strongest. Now that the dietitian
knows that there is a relationship, the dietitian can build a multiple regression model to
predict average calories.

Build the Multiple Regression Model

Continue to use the Candy Bars.jmp sample data table.

1. Select Analyze > Fit Model.

2. Select Calories and click Y.

3. Select Total Fat g, Carbohydrate g, and Protein g and click Add.
4

Next to Emphasis, select Effect Screening.

Figure 5.27 Fit Model Window
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5. Click Run.

The report window shows the model results. To interpret the model results, focus on these
areas:

* “View the Actual by Predicted Plot” on page 163
e “Interpret the Parameter Estimates” on page 163

® “Use the Prediction Profiler” on page 164

Note: For complete details about all of the model results, see the Model Specification chapter
in the Fitting Linear Models book.



Chapter 5 Analyze Your Data 163
Discovering JMP Analyze Relationships

View the Actual by Predicted Plot

The Actual by Predicted Plot shows the actual calories versus the predicted calories. As the
predicted values come closer to the actual values, the points on the scatterplot fall closer
around the red line. See Figure 5.28. Because the points are all very close to the line, you can
see that the model predicts calories based on the chosen factors well.

Figure 5.28 Actual by Predicted Plot
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Another measure of model accuracy is the RSq value (which appears below the plot in
Figure 5.28). The RSq value measures the percentage of variability in calories, as explained by

the model. A value closer to 1 means a model is predicting well. In this example, the RSq value
is 0.99.

Interpret the Parameter Estimates

The Parameter Estimates report shows the following information:
* The model coefficients

e P-values for each parameter

Figure 5.29 Parameter Estimates Report

Model coefficients P-values

4 Parameter Estimates

Term Estimate\ Std Error tRatio
Intercept -5.964301 | 2.899986  -2.06
Totalfatg 8.9899516 | 0.144981  62.01
Carbohydrate g 4.097505 | 0.071025  57.69
Protein g 44013313/ 039785 11.06

In this example, the p-values are all very small (<.0001). This indicates that all three effects (fat,
carbohydrate, and protein) contribute significantly when predicting calories.
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You can use the model coefficients to predict the value of calories for particular values of fat,
carbohydrate, and protein. For example, suppose that you want to predict the average calories
for any candy bar that has these characteristics:

e Fat=1lg

e (Carbohydrate=43 g

* Protein=2g

Using these values, you can calculate the predicted average calories as follows:
277.92 =-5.9643 + 8.99*11 + 4.0975*43 + 4.4013*2

The characteristics in this example are the same as the Milky Way candy bar (on row 59 of the
data table). The actual calories for the Milky Way are 280, showing that the model predicts
well.

Use the Prediction Profiler

Use the Prediction Profiler to see how changes in the factors affect the predicted values. The
profile lines show the magnitude of change in calories as the factor changes. The line for Total
fat g is the steepest, meaning that changes in total fat have the largest effect on calories.

Figure 5.30 Prediction Profiler
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Click and drag the vertical line for each factor to see how the predicted value changes. You can

also click the current factor values and change them. For example, click on the factor values
and type the values for the Milky Way candy bar (row 59).
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Figure 5.31 Factor Values for the Milky Way
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Note: For complete details about the Prediction Profiler, see the Profiler chapter in the Profilers
book.

Draw Conclusions

The dietitian now has a good model to predict calories of a candy bar based on its total fat,
carbohydrates, and protein.
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Chapter 6

The Big Picture

Exploring Data in Multiple Platforms

JMP provides a host of statistical discovery platforms to help you explore different aspects of
your data. You might start with a simple look at individual variables in histograms and then
progress to multivariate and cluster analyses to get a deeper look. Each step of the way, you

learn more about your data.

This chapter steps through an analysis of the Cereal.jmp sample data table that is installed
with JMP. You learn how to explore the data in the Distribution, Multivariate, and Hierarchical

Clustering platforms.

Figure 6.1 Linked Analyses in J]MP
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Fun Fact: Linked Analyses

One of the powerful features in JMP is its linked analyses. The graphs and reports that you
create are linked to each other through the data table. As shown in Figure 6.1, data that are
selected in the data table are also selected in the three report windows. The linked analyses
enable you to select data in one window and see where it occurs in the other windows. As you
work through the examples in this chapter, keep the JMP windows open to see these
interactions yourself.

Explore Data in Multiple Platforms

Which cereals are part of a healthy diet? The Cereal.jmp sample data (real data gathered from
boxes of popular cereals) provides statistics on fiber content, calories, and other nutritional

information. To identify the most healthful cereals, you step through interpreting histograms
and descriptive statistics, correlations and outlier detection, scatterplots, and cluster analysis.

Analyze Distributions

The Distribution platform illustrates the distribution of a single variable (univariate analysis)
using histograms, additional graphs, and reports. The word univariate simply means
involving one variable instead of two (bivariate) or many (multivariate). However, you can
examine the distribution of several individual variables within a single report. The report
content for each variable changes depending on whether the variable is categorical (nominal
or ordinal) or continuous.

e For categorical variables, the initial graph is a histogram. The histogram shows a bar for
each level of the ordinal or nominal variable. The reports show counts and proportions.

e For continuous variables, the initial graphs show a histogram and an outlier box plot. The
histogram shows a bar for grouped values of the continuous variable. The reports show
selected quantiles and summary statistics.

Once you know how your data are distributed, you can plan the appropriate type of analysis

going forward.

Note: For details about the Distribution platform, see the Distributions chapter in the Basic
Analysis book.
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Scenario

You want to view the nutritional values of cereals so that you can eat a more healthful diet.
Analyzing distributions of cereal data reveals answers to the following questions:

*  Which cereals are highest in fiber?

* What is the average, minimum, and maximum number of calories?
e  What is the median amount of fat?

e Which cereal contains the most fat?

® Are there any outliers in the data?

Create the Distributions

1. Select Help > Sample Data Library and open Cereal.jmp.
2. Select Analyze > Distribution.

3. DPress Ctrl and click Manufacturer, Calories, Fat, and Fiber.
4. Click Y, Columns and then click OK.

Figure 6.2 Distributions for Manufacturer, Calories, Fat, and Fiber
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In the Fiber distributions, notice the following:
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— Fiber One and All-Bran with Extra Fiber contain the most fiber as shown in the Fiber
box plot. These cereals are outliers in terms of fiber content.

The row that contains Fiber One in Cereal.jmp is labeled. This label shows the name of
the cereal next to a data point in graphs. To see the entire label, drag the right-most
vertical border to the right. Place your cursor over the unlabeled data point to see “All
Bran with Extra Fiber”.

In the Fat distributions, notice the following;:

— Place your cursor over the top data point (the x marker) in the Fat box plot to see that
100% Nat. Bran Oats & Honey is the highest in fat.

— In the Fat Quantiles report, the median amount of fat is 1 gram.
In the Calories Quantiles report, notice the following:

— The maximum number of calories is 250.

— The minimum number of calories is 50.

5. In the Manufacturer histogram, click on the bar for Nabisco.

Figure 6.3 Distributions for Nabisco Cereals
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The Calories, Fat, and Fiber distributions for Nabisco cereals are highlighted in the other
histograms. You can view the Calories, Fat, and Fiber distributions for the Nabisco cereals
relative to the Calories, Fat, and Fiber distributions for the overall data. For example, the
Fat distribution of Nabisco cereals seems to be lower than the Fat distribution for the
overall data.

6. Click below the last Fiber bar to deselect all bars.

7. Press Shift and, in the Fiber histogram, click all histogram bars with a value above 8.
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Figure 6.4 High-Fiber Cereals
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The highest-fiber cereals are highlighted in the Calories and Fat histograms. Because the
histograms are linked, note that some of the high-fiber cereals are also low in fat.

8. Press Ctrl and Shift and deselect the two Calories histogram bars that are at or near 200.

High calorie cereals are eliminated from the histograms.

Figure 6.5 High-Fiber and Low-Calorie Cereals
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Tip: Leave the Distributions report open. You will use it later in a cluster analysis. See
“Analyze Similar Values” on page 177.

Interpret the Results

Looking at the results, you can answer the following questions:

Which cereals are highest in fiber? The Fiber box plot shows that All-Bran with Extra
Fiber and Fiber One have the highest amount of fiber. These two cereals are outliers.
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What is the average, minimum, and maximum number of calories? The Calories
histogram shows that the number of calories ranges from 50 to 275. The Calories Quantiles

show that the number of calories ranges from 50 to 250, and the median number of calories
is 120. The distribution is not uniform.

What is the median amount of fat? The Fat Quantiles report shows that the median
amount of fatis 1 gram.

Which cereal contains the most fat? The Fat box plot shows that 100% Nat. Bran Oats &
Honey is the highest in fat. This cereal is an outlier.

Draw Conclusions

To increase the amount of fiber in your diet, you decide to try All-Bran with Extra Fiber and
Fiber One. These cereals are lower in calories and fat. Most cereals do not greatly increase the
amount of fat in your diet, but you plan to avoid the high fat 100% Nat. Bran Oats & Honey.
And although most cereals are relatively low in fat, they are not necessarily low in calories.

Analyze Patterns and Relationships

Now that you have identified which cereals to eat or avoid, you want to see how the cereal
variables relate to each other. The Multivariate platform enables you to observe patterns and
relationships between variables. From the Multivariate report, you can do the following:

* summarize the strength of the linear relationships between each pair of response variables
using the Correlations table

¢ identify dependencies, outliers, and clusters using the Scatterplot Matrix

* use other techniques to examine multiple variables, such as partial, inverse, and pairwise
correlations, covariance matrices, and principal components

Note: For details about the Multivariate platform, see the Correlations and Multivariate
Techniques chapter in the Multivariate Methods book.

Scenario
You want to see the relationships between variables such as fat and calories. Analyzing the
cereal data in the Multivariate platform reveals answers to the following questions:

®  Which pairs of variables are highly correlated?

*  Which pairs of variables are not correlated?
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Create the Multivariate Report
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1. In the Cereal.jmp data table, click the bottom triangle at the top of the Columns panel to

deselect the rows (Figure 6.6).

Figure 6.6 Deselecting Rows

Click here to deselect the rows.

100% Bran

2 |100% Nat. Bran Cats & Honey
3 |100% Nat. Low Fat Grancla w raisins

e
_ All-Bran with Extra Fiber

2. Select Analyze > Multivariate Methods > Multivariate.

““

3. Select Calories through Potassium, click Y, Columns, and then click OK.

The Multivariate report appears. The report contains the Correlations report and
Scatterplot Matrix by default. The Correlations report is a matrix of correlation coefficients
that summarizes the strength of the linear relationships between each pair of response (Y)

variables. The dark numbers indicate a lower degree of correlation.

Figure 6.7 Correlations Report

4 Correlations
Calories Protein
Calories 1.0000
Protein 0.7041
Fat 0.6460
Sodium 0.1996
Fiber 0.1953
Complex Carbos 0.6688
Tot Carbo 0.9076
Sugars 0.5060
Calories fr Fat 0.6709 0.4288
Potassium 0.4451 0.6782
Note the following:

Sedium
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0.9076
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1.0000
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0.4636
0.5375

Sugars Calories fr Fat Potassium
0. 5060

0.1166

0.6709
0.4288
0.9013
0.0572
0.2553
0.1558
0.4636
0.4369
1.0000
0.2694

0.4451
0.6782
0.2420
0.0459
0.8326
0.2693
0.5375
0.1166
0.2694
1.0000

— In the Calories column, the number of calories is highly correlated with all variables
except for sodium and fiber.

— In the Fiber column, fiber and potassium appear to be highly correlated.

— In the Sodium column, sodium is not highly correlated with the other variables.

The density ellipses in the Scatterplot Matrix further illustrates relationships between
variables. Figure 6.8 shows a portion of the plot.
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Figure 6.8 Portion of the Scatterplot Matrix
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By default, a 95% bivariate normal density ellipse is in each scatterplot. Assuming that
each pair of variables has a bivariate normal distribution, this ellipse encloses
approximately 95% of the points. If the ellipse is fairly round and is not diagonally
oriented, the variables are uncorrelated. If the ellipse is narrow and diagonally oriented,

the variables are correlated.

Note the following:

The ellipses are fairly round in the Sodium row. This shape indicates that Sodium is
uncorrelated with other variables.

The blue x markers, which represent Nat. Bran Oats & Honey, Cracklin’ Oat Bran, and
Banana Nut Crunch, appear outside the ellipses in the Fat row. This placement
indicates that the datum is an outlier (because of the amount of fat in the cereal).

You will further explore a scatterplot matrix later.

4. Select Pairwise Correlations from the Multivariate red triangle menu to display the

Pairwise Correlations report.

Figure 6.9 Portion of the Pairwise Correlations Report
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The Pairwise Correlations report lists the Pearson product-moment correlations for each
pair of Y variables. The report also shows significance probabilities and compares the
correlations in a bar chart.

5. To quickly see which pairs are highly correlated, right-click in the report and select the
Sort by Column, Signif Prob, Ascending check box, and then click OK.

The most highly correlated pairs appear at the top of the report. The small p-values for the
pairs indicate evidence of correlation. The most significant correlation is between Tot
Carbo (total carbohydrates) and Calories.

Figure 6.10 Small P-values for Pairs

< Pairwise Correlations
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Interpret the Results

Looking at the results, you can answer the following questions:

Which pairs of variables are highly correlated? The Correlations report and Scatterplot
Matrix show that the number of calories is highly correlated with all variables except for
sodium and fiber. The Pairwise Correlations report shows that Tot Carbo (total
carbohydrates) and Calories is the most correlated pair of variables.

Which pairs of variables are not correlated? The Correlations report and Scatterplot
Matrix show that Sodium is not correlated with the other variables.

Draw Conclusions

You confirm the previous decision to avoid the high fat 100% Nat. Bran Oats & Honey. Trying
All-Bran with Extra Fiber and Fiber One was also a smart decision. These two high-fiber
cereals have the added benefit of contributing a lower number of calories, fat, and sugars and
a higher amount of potassium. You also decide to avoid high-carbohydrate cereals because
they likely contain a large number of calories.
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Analyze Similar Values

Clustering is a multivariate technique that groups observations together that share similar
values across a number of variables. Hierarchical clustering combines rows in a hierarchical
sequence that is portrayed as a tree. Cereals with certain characteristics, such as high fiber, are
grouped in clusters so that you can view similarities among cereals.

Note: For details about hierarchical clustering, see the Hierarchical Cluster chapter in the
Multivariate Methods book.

Scenario

You want to know which cereals are similar to each other and which ones are dissimilar.
Analyzing clusters of cereal data reveals answers to the following questions:

e Which cluster of cereals provides little nutritional value?

*  Which cluster of cereals is high in vitamins and minerals and contains a low amount of
sugar and fat?

¢ Which cluster of cereals is high in fiber and low in calories?

Create the Hierarchical Cluster Graph

1. With Cereal.jmp displayed, select Analyze > Clustering > Hierarchical Cluster.
2. Select Calories through Enriched, click Y, Columns, and then click OK.

The Hierarchical Clustering report appears. Figure 6.11 shows a portion of the report. The
clusters are colored according to the data table row states.

Figure 6.11 Portion of the Hierarchical Clustering Report

£ =|Hierarchical Clustering
Methed = Ward
< Dendrogram

3. Select Color Clusters from the Hierarchical Clustering red triangle menu.
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The clusters are colored according to their relationships in the dendrogram.

Figure 6.12 Colored Clusters

o

100% Bran
-
ith Extra Fiber -1 — clusterone
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cluster three
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Past Premium Raisin Ban
BranTwo Scoops

cluster seven

cluster eight

The cereals have similar characteristics within each cluster. For example, judging by the
names of the cereals in cluster one, you guess that the cereals are high in fiber.

Notice how All-Bran with Extra Fiber and Fiber One are grouped in cluster one. These
cereals are more similar to each other than the other two cereals in the cluster.

Figure 6.13 Similar Cereals in Cluster One

4. To select cluster one, click on the red horizontal line on the right.

The four cereals are highlighted in red.
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Figure 6.14 Selecting a Cluster
B
:_

5. To see the similar characteristics in the cluster, select Cluster Summary from the red
triangle menu.

The Cluster Summary graph at the bottom of the report shows the mean value of each
variable across each cluster. For example, the cereals in this cluster contain more fiber and
potassium than cereals in other clusters.

Figure 6.15 Cluster Summary
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6. Select Scatterplot Matrix from the red triangle menu.
This option is an alternative to creating a scatterplot matrix in the Multivariate platform.

Note the Fiber plot in the Potassium row. The selected cereals are located on the right side
of the plot between 8 and 13 grams. This location indicates that the cereals in cluster one
are high in fiber and potassium.
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Figure 6.16 Cluster One Characteristics
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Note: The points are also selected in the previous scatterplot matrix that you created if it is still
open.

Interpret the Results

Clicking through the clusters and looking at the Cluster Summary report, you can see the
following characteristics:

Cluster one cereals, such as Fiber One and All-Bran, contain high fiber and potassium and
low calories.

Cluster two cereals, which contain many favorite children’s cereals, are high in sugar and
low in fiber, complex carbohydrates, and protein.

Cluster three cereals (Puffed Rice and Puffed Wheat) are low in calories but provide little
nutritional value.

Cluster four cereals, such as Total Corn Flakes and Multi-Grain Cheerios, provide 100% of
your daily requirement of vitamins and minerals. They are low in fat, fiber, and sugar.

Cluster five cereals are high in protein and fat and low in sodium. The cluster consists of
cereals such as Banana Nut Crunch and Quaker Oatmeal.

Cluster six cereals are low in fat and high in sodium and carbohydrates. Traditional cereals
such as Wheaties and Grape-Nuts are in this cluster.

Cluster seven cereals are high in calories and low in fiber. Many cereals that include dried
fruit are in this cluster (Mueslix Healthy Choice, Low Fat Granola w Raisins, Oatmeal
Raisin Crisp, Raisin Nut Bran, and Just Right Fruit & Nut).

Cluster eight cereals are low in sodium and sugar, and high in complex carbohydrates,
protein, and potassium. Shredded Wheat and Mini-Wheat cereals are in this cluster.

By looking at the joins in the dendrogram, you can see which cereals in each cluster are most
similar.

In cluster one, Fiber One is similar in nutritional value to All-Bran with Extra Fiber. 100%
Bran and All-Bran are also similar. Each pair of similar cereals are made by different
companies, so the cereals are competing against each other.
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® In cluster two, Frosted Flakes and Honey Frosted Wheaties are similar even though one is
a corn flake and the other is a wheat flake. Lucky Charms and Frosted Cheerios are
similar. Cap’n’Crunch and Trix are also similar.

Draw Conclusions

Based on your desire to eat more fiber and fewer calories, you decide to try the cereals in
cluster one. You will avoid cereals in cluster three, which consists of puffed wheat and puffed
rice and have little nutritional value. And you will try cereals in the highly nutritious cluster
four.
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Chapter 7

Save and Share Your Work
Save and Re-create Results

Once you have generated results from your data, JMP provides you with multiple ways to
share your work with others. Here are some of the ways that you can share your work:

® Saving platform results as journals, projects, or web reports
* Saving results, data tables, and other files in projects

* Saving scripts to reproduce results in data tables

* Creating Adobe Flash (SWF) versions of platform results

* Saving results as Interactive HTML (.htm, html)

® Saving results as a PowerPoint presentation (.pptx)

¢ Sharing results in a dashboard

Figure 7.1 Example of a Web Report

Jmp SAT By Year Reports

Click any of the thumbnails below to launch interactive JMP reports.

s catamd vy Eepamams (T 09/28/2017 10:04 AM

| Graph Builder State Colored by Expenditure

e * Place your cursor over the state to see the mean expenditure.

09/28/2017 10:04 AM

3 Bubble Plot of SAT Verbal by SAT Math Sized by % Taking (2004)
" Across Year |ID State

f Click the Play butten to animate the plot
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Save Platform Results in Journals

Save platform reports for future viewing by creating a journal of the report window. The
journal is a copy of the report window. You can edit or append additional reports to an
existing journal. The journal is not connected to the data table. A journal is an easy way to save
the results from several report windows in a single report window that you can share with
others.

Example of Creating a Journal

Select Help > Sample Data Library and open Companies.jmp.

Select Analyze > Distribution.

Select both Type and Size Co and click Y, Columns.

Click OK.

From the red triangle menu for Type, select Histogram Options > Show Counts.

From the red triangle menu for Size Co, select Mosaic Plot.

NS ol L=

Select Edit > Journal to journal these results. The results are duplicated in a journal
window.

Figure 7.2 Journal of Distribution Results

4 = | Distributions

4= Type 4 = |Size Co
small
Pharmaceutical 1z small
medium
I medium
Computer 0
big big
4 Frequencies 4 Frequencies
Level Count Prob Level Count Prob
Computer 20 0.62300 big 9 0.28125
Pharmaceutical 12 0.37300 medium 7 0.21875
Total 32 1.00000 small 16 0.50000
M Missing 0 Total 32 1.00000
2 Levels N Missing 0

3 Levels
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The results in the journal are not connected to the data table. In the Type bar chart, if you click
the Computer bar, no rows are selected in the data table.

Since the journal is a copy of your results, most of the red triangle menus do not exist. A
journal does have a red triangle menu for each new report that you add to the journal. This
menu has two options:

Rerun in new window If you have the original data table that was used to create the
original report, this option runs the analysis again. The result is a new report window.

Edit Script This option opens a script window that contains a JSL script to re-create the
analysis. JSL is a more advanced topic that is covered in the Scripting Guide and JSL Syntax
Reference.

Add Analyses to a Journal

If you perform another analysis, you can add the results of the analysis to the existing journal.

1. With a journal open, select Analyze > Distribution.
2. Select profit/emp and click Y, Columns.
3. Click OK.
4

Select Edit > Journal. The results are appended to the bottom of the journal.

Create a Project

A JMP project provides a way to organize files that you use in an analysis. You can add JMP
files (reports, data tables, scripts, journals, and so on) and non JMP files, such as Microsoft
PowerPoint or Adobe PDF files. After you perform an analysis, the graph and report appear in
the project on tabs. You can display multiple reports or graphs, display the log, and run scripts
from the project. Reports and graphs remain linked to the data table.

Projects help you avoid overlapping or concealed JMP windows. You can maximize the
project window to have a bigger view of the project. And when you save the project, the state
of the project is saved (for example, the open reports and the layout of the window).

Create a New Project and Add Data Tables

1. To start a new project, select File > New > Project. A window appears that shows the
untitled project.

2. Select File > Open and browse to the JMP Samples/Data folder.
Press Shift and click Car Physical Data.jmp and Car Poll.jmp.
Click Open.
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The data tables are added to the project.

5. Select File > Save Project and save the file as Cars.jmpprj.

Figure 7.3 Initial Project

- []Bookmarks [ Car Physical Data Elcarpoll O %
= Car Poll i K >
Locked File C:\Program Files\SAS\I| o sex  maritalstatus age | country  size | type
T}Otg?si?gﬂgﬁ data for categorica 1| Male N_'\arried 34 American Large Family
> Contingency 2 Male Single 36 Japanese Small Sporty
= Partition 3 Male Married 23 Japanese Small Family
P+ Multiple Corre...dence Analysis 4 Male  Single 29 American Llarge  Family
> R AE 5 |Male Married 39 American Medium Family
6 Male Single 34 Japanese Medium Family
QWindowLis‘t 7 Female Married 42 American Large Family
8 Female Married 40 European Medium Family
Sl(ar kbyicaliPat 9 Male Married 28 American Medium Sporty
Bl car ol 10 |Female Married 26 American Medium Family
11 |Female Married 26 European Small Sporty
12 | Male Single 26 European Medium Sporty

Tip: When you open a file using File > Open, and a project is active, the file will be added to
the project automatically.

Add and Organize Bookmarks
Bookmarks provide quick access to files that you regularly open.

1. Inthe Window List, right-click one of the file names and select Bookmark All.
You can also drag the files from the Window List to the Bookmarks pane.

2. Create a group for the data tables by selecting New Group from the Bookmarks red triangle
menu. The group organizes the files but does not move them on your computer.

Enter Data and click OK.
4. In the Bookmarks pane, select the Car data tables and drag them into the Data group.

Figure 7.4 Bookmarked Files
- = Bookmarks

4 [ Data
%% Car Physical Datajmp
% car Polljmp

Rearrange Reports

You can rearrange reports to display them in a separate pane. As you drag the report tab,
zones appear that show you where to place, or “dock”, the report.
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1. In Car Physical Data.jmp, run the Contingency script.
2. In Car Poll.jmp, run the Distribution script.

The data tables and reports appear in tabs.

Figure 7.5 Tabbed Reports

L @Bookmarks E¥lCar Physical Data FEl car Poll Car Physical Data - Contingency of Country by Type [E= Car Poll - Distribution [] %
4 QPETE 4 = Distributions
B car Physical Data.jmp
% Car Polljmp 4>jage
60 | .
55 .
50 ¢
45 T
[DyWindow List
= 40
4 Blcar Physical Data
i1 Contingency of Countr, 35
4 Bl carpol
[E=Distribution 30 {
25
20

3. Drag the Distribution report tab to the right until the Dock right zone appears on the far
right.
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Figure 7.6 Dragging a Report

1ybu pog
Wb e

Car Poll - Distribution

stributions

age

4. Drop the report into the Dock right zone.

The tab appears in a new pane.

Figure 7.7 Report in New Pane

= [BJBookmarks x| carp.alData » [T CarPoll  EiCar Physical Data .f Country by Type O X ¥ | |- Car Poll - Distribution o
4 ata A‘F]Contingency Analysis of Country By Type ~ | 4 = Distributi |
"% Car Physical Datajmp = =
& Car Polljmp “Mosalc Plot ‘| ¥ age ‘
1.00
60 .
55 .
@ .
DyWindow List x B
£
4 [ car Physical Data &
LH Contingency of Countr,
4 [ carpoll
[ Distribution
Japan
Sporty Small Compact Medium Large
Type

5. Drag the Contingency tab to the middle of the Distribution report.
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6. When the Dock tab zone appears, drop the report.

Figure 7.8 Docked Report Tabs

~| [EBookmarks  * | ] car Physical Data » | Eicarpoll O % ¥ | & Car Poll - Distribution » 1l Car Physical Data - Contingency of Country by Type 1 %
4 D‘ Data ~|Car Poll pl 4 - 4 = Contingency Analysis of Country By Type
' Car Physical Data. [ poied ile Ci\Program Files | sex  maritalstatus | age A Mosaic Plot
B car polljmp Notes Example data for cat CoENE A
B Distribution 1|Male Married 34 ~
b Contingency 2 | Male Single 36
P> Partition 3|Male  Married 23
P> Multiple C...nce Analysis 4 Male  Single 29
> Multiple C...ary Variable 5 Male Married 39
< > 6 | Male Single 34
Qwinduwhst 7 Female Married 42
g 8 Female Married 40
4 [ Car Physical Data
{i! contingency of C¢ 9 |Male_ | Married 8
10 |Female Married 26
4 [Elcarpol !
[E=Distribution 11 |Female Married 26
12 |Male Single 26
= Columns (6/0) 13 |Female Married 37
th sex K 14 |Male Single 25
ik marital status 3¢ 15 |Female  Single 27 Sporty Small Cumpact Medium Large
A age 16 Male  Married 41 Type
Tips:

¢ Keyboard shortcuts that work in JMP windows outside of projects work the same in
projects. For example, press Ctrl and then W to close a selected pane (for example, the
Window List) or press Ctrl and then S to save a document.

e If the data table associated with a report is updated on your computer, the report in your
project is updated when you reopen the project.

Save Files in a Project

When you modify a file (for example, a data table or script) inside a project, an asterisk
appears on the tab to indicate that the file is not saved. Select File > Save and save the file to
your computer. Then, select File > Save Project to save the project.

You can also create and save new files from within the project.

1. Follow step 1 through step 4 in “Create a New Project and Add Data Tables” on page 186
to create a project.

In the project, select the Car Poll.jmp tab.

Select Tables > Subset.

Select Subset by.

ATl

Select country from the Columns list and click OK.

Three new data tables subset by country are created in the project. Notice the asterisk on
the tab of each new data table.
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Figure 7.9 New Subset Data Tables

E¥] Car Physical Data 25 Car Poll E¥] country...merican* % country...uropean® Eflcountry...apanese*r [0 % ¥
¥ | country=Japanese Pl < -
country Japanese | o sex  marital status = age size type
T’Otgzufizmp'e L 1 Male  Single 36 Small  Sporty
> Distribution 2 |Male  Married 23 Small Family
| Contingency 3 Male  Single 34 Medium Family
E E?Ftlit_ioln c _— 4 Male Single 25 Small  Sporty
» Multiple Corr...nce Analysis 5 i .
b Multiple Corr...tary Variable 5 |Female Single 27 Medium Family
6 (Male  Married 28 Small Family
6. Select each new tab, select File > Save, and save the file on your computer.
Tip: If you plan to share the project, save the data table in the same folder as (or in a
subfolder of) the project.
7. Select File > Save Project to save the data tables in the project.

Save Files in a Different Format and Save to the Project

You can save a graph in another format (such as Interactive HTML or PowerPoint) and then
bookmark it in the project.

1.
2.

Select File > New > Project to create an empty project.

Select File > Open, browse to the JMP Samples/Data folder, and open Big Class
Families.jmp.

Run the Graph Builder script.

(Windows) Select File > Save As and select PowerPoint Presentation from the Save as Type
list.

Tip: Select Bookmark in project to add a bookmark to the file.

Browse to the desktop and click Save.

The PowerPoint file opens automatically.

(Macintosh) Select File > Export (Macintosh) and select Microsoft PowerPoint .
Click Next, browse to the desktop, and then click Export.

The PowerPoint file opens automatically.

In JMP, from the Bookmarks red triangle menu, select Add Files, navigate to the Graph
Builder.pptx file that you created, and then click Open (Windows) or Choose (Macintosh).

The PPTX file is added to the Bookmarks pane.
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Figure 7.10 Bookmarked PPTX File
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Move Files to a Project

Suppose you generated graphs and reports from open data tables and you want to put all the
files in a new project. The Move to/from Project option in the Window menu enables you to
quickly combine open windows into a project. You can move windows to a new project or
move to windows to an open project.

Select Help > Sample Data Library.

Open Big Class Families.jmp.

Run the Distribution, Text Explorer, and Graph Builder scripts.
From any window, select Window > Move to/from Project.

Leave Source Project as “(None)” because you are not moving files from another project.

AL A

Leave Destination Project as “(New Project)” because you want to put the files in a new
project.
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7. Select the check box next to Big Class Families.jmp.
The graphs associated with the data table are also selected.

8. Click Bookmark next to Big Class Families.

A bookmark to the data table will be included in the project.

Figure 7.11 Moving Files to a New Project
Source Project: (None) -

Destination Project: (New Project) v

| Move All |[Bookmark All|

Move Window Bookmark
Big Class Families

Big Class Families - Distribution

Big Class Families - Graph Builder

Big Class Families - Text Explorer of reported illnesses

NERE

oK | | Cancel
9. Click OK.
A new project with the selected files and bookmark appears.
Figure 7.12 New Project
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Window List -
2 2 sibling ages 6 M 12 M 60 84 Basketball
4 [EBig Class Families 2 sports £
5 Text Explorer of reported il % countries visited =
Eﬁraph Builder _=- fam“l'!;(;'; 7 % JAMES 2 M 61 128 22 Volleyball
— = reported ilinesses olleybal
[ Distribution 1 oo vicis A z\
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Share the Project

Sometimes you want to archive a project and share it with others. JMP zips the files in the
project and saves the state of the project (the bookmarks, open panes, pane sizes, and so on).

When other users open the archived project on their computer, the links are resolved as

follows:

1. If the file is in the same folder as the project or in a subfolder, the link contains a relative
path, such as My Data/Corn Trials.jmp.

2. If the file is in a directory that JMP represents as a path variable, such as the desktop or
documents directory, the links contain the path variable, such as $DESKTOP/Corn
Trials.jmp. See the Types of Data chapter in the Scripting Guide for more information.

3. Otherwise, the link contains an absolute path, such as C:/2017Data/Corn Trials.jmp.

Caution: An absolute path does not work on other users’ computers unless their file
system is set up like yours.

To archive a project

1.

2
3.
4

Make sure the project is saved.

Select File > Archive Project.

Browse to the folder where you want to save the project files.
Click Save.

To unarchive a project

1.

2.
3.

Use Windows Explorer or Macintosh Finder to create the folder in which you want to
extract the files.

Open the archive in J]MP.
Select the folder that you just created and click Extract.

Save and Run Scripts

Most platform options in JMP are scriptable, meaning that most actions that you perform can
be saved as a JMP Scripting Language (JSL) script. You can use a script to reproduce your
actions or results at any time.
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Example of Saving and Running a Script

Create a Report
1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Analyze > Distribution.
3. Select Type and profit/emp and click Y, Columns.
4. Click OK.
5. From the red triangle menu for Type, select these options:
— Histogram Options > Show Counts
— Confidence Interval > 0.95
6. From the red triangle menu for profit/emp, select these options:
— Outlier Box Plot, to remove the outlier box plot
— CDF Plot

7. From the red triangle menu for Distributions, select Stack.

Save the Script to the Data Table and Run It

1. To save this analysis, select Save Script > To Data Table from the red triangle menu for

Distributions. The new script appears in the Table panel.

Figure 7.13 Distribution Script

= |Companies ] 4 i
Motes Selected Data on the Fortune | [™ Type Size Co
|+ Distribution of Type, profit/emp 1 | Computer srmall

2 |Pharmaceutical  big

Distribution script

2. Close the Distribution report window.

3. To re-create the analysis, click the green triangle next to the Distribution script.

195
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Figure 7.14 Running the Distribution Script
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Tip: Right-click the table script to view more options.

About Scripts and JSL

The script that you saved in this section contains JMP Scripting Language (JSL) commands.
JSL is a more advanced topic that is covered in the Scripting Guide and JSL Syntax Reference.

Save Reports as Interactive HTML

Interactive HTML enables JMP users to share reports that contain dynamic graphs so that
even non JMP users can explore the data. The JMP report is saved as a web page in HTML 5
format, which you can email to users or publish on a website. Users then explore the data as

they would in JMP.
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Interactive HTML provides a subset of features from JMP:

e Explore interactive graph features, such as selecting histogram bars and viewing data
values.

* View data by brushing.
* Show or hide report sections.
® Place your cursor over the report for tooltips.

e Increase the marker size.

Figure 7.15 Brushing Data in Interactive HTML
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Many changes that you make to the graphs, such as ordered variables, horizontal histograms,
background colors, and colored data points, are saved in the web page. Graphs and tables that

are closed when you save the content remain closed on the web page until the user opens
them.

Interactive HTML Contains Data

When you save reports as interactive HTML in JMP, your data are embedded in the HTML.
The content is unencrypted, because web browsers cannot read encrypted data. To avoid
sharing sensitive data, save your results as a non-interactive web page. (Select File > Save As >
HTML File on Windows, or File > Export > HTML on Macintosh.)
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Example of Creating Interactive HTML

Create a Report

1.

2
3.
4

Select Help > Sample Data Library and open Big Class.jmp.
Select Analyze > Distribution.

Select height and click Y, Columns.

Click OK.

Save as Interactive HTML

1.

2.

On Windows, select File > Save As and select Interactive HTML with Data from the Save as
type list. On Macintosh, select File > Export > Interactive HTML with Data.

Name and save the file (or export on Macintosh).

The output appears in your default browser.

Figure 7.16 Interactive HTML Output
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For information about exploring interactive HTML output, visit
https://www.jmp.com/support/help/InteractiveHTML/14/Share]MPReports.shtml.


https://www.jmp.com/support/help/InteractiveHTML/14/ShareJMPReports.shtml
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Create a Web Report

The File > Publish option creates a web page in which reports, descriptive text, and graphics
are displayed. The web page, graphics, and support files are saved in the directory that you
specify so that you can zip the files and send them to another user. This feature is particularly
helpful for non JMP users.

Some graphs can be displayed as interactive HTML (for example, bubble plots or background
maps). When you click on the thumbnail of the graph in a web report, the interactive graph
appears on a new web page.

To generate a web report, follow these steps:

1. Select Help > Sample Data Library and open SATByYear.jmp.
2. Run the Graph Builder Map and Bubble Plot by State scripts.
3. From any JMP window, select File > Publish.

In the Select Reports window that appears, you can select one or more reports to display in
the web page. In this example, both reports are displayed in the web page because they are
not selected in this window.

Note that the Folder Name box indicates the current date and time. The web report files
are saved in this folder.

4. Click Next.

Enter the descriptions shown in Figure 7.17.

Note: If you selected one report, you have the option of generating an index page. The
index page shows a thumbnail of the report. You click the thumbnail to view the report.
Figure 7.18 shows an example.
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Figure 7.17 Customizing the Web Report
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Across Year |ID State
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Web Report Description:
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Click any of the thumbnails below to launch interactive JMP
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Note: The reports are in the order you created them. In this example, the Graph Builder
Map script was run first, so the map is the first report. Use the arrows next to the reports to
rearrange them. Also, after you remove a report, a Restore Reports button appears in case

you want to add the report again.

Enter SAT By Year Reports in the Web Report Title box.

7. Click Build Report.

The web page opens in your default browser.
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Figure 7.18 Web Report
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Save a Report as a PowerPoint Presentation

Create a presentation by saving JMP results as a Microsoft PowerPoint presentation (.pptx).

Rearrange JMP content and edit text in PowerPoint after saving as a .pptx file. Sections of a

JMP report are exported into PowerPoint differently.

® Report headings are exported as editable text boxes.

® Graphs are exported as images. Certain graphical elements, such as legends, are exported

as separate images. Images resize to fit the slide in PowerPoint.

Use the selection tool to select the sections that you want to save in your presentation. Delete

unwanted content once after you open the file in PowerPoint.

Note: On Windows, PowerPoint 2007 is the minimum version required to open .pptx files

created in JMP. On Macintosh, at least PowerPoint 2011 is required.

1. In JMP, create the report.

2. (Windows) Select File > Save As and select PowerPoint Presentation from the Save as type

list.
(Macintosh) Select File > Export > PowerPoint Presentation and click Next.

4. Select a graphic file format from the list.
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On Windows, EMF is the default format. On Macintosh, PDF is the default format.
5. Name and save the file (or export on Macintosh).

The file opens in Microsoft PowerPoint because Open the file after saving is selected by
default.

Note: The native EMF graphics produced on Windows are not supported on Macintosh. The
native PDF graphics produced on Macintosh are not supported on Windows. For
cross-platform compatibility, change the default graphics file format by selecting File >
Preferences > General. Then, change the Image Format for PowerPoint to either PNG or JPEG.

Create Adobe Flash Versions of the Profiler, Bubble
Plot, or Distribution Platforms

To share the interactive results of a profiler, bubble plot, or distribution outside of JMP, you
can export an SWF file and use the Adobe Flash Player to view it. You can import the SWF file
into presentations and applications. You can also save the results as an HTML page with the
SWF output embedded.

Example of Saving an Adobe Flash Version of a Bubble Plot

Create a Bubble Plot in JMP

Select Help > Sample Data Library and open PopAgeGroup.jmp.
Select Graph > Bubble Plot.

Select Portion60+ and click Y.

Select Portion 0-19 and click X.

Select Country and click ID.

Select Year and click Time.

Select Pop and click Sizes.

Select Region and click Coloring.

Click OK.

o X N Ak wh =
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Figure 7.19 Initial Bubble Plot
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Save the Bubble Plot as an SWF File
1. Select Save for Adobe Flash Platform (SWF) from the red triangle menu.

2. In the Save As SWF window, select the location to which you want to save the file.

3. Click Save. The Adobe Flash version of the Bubble Plot is saved as HTML and appears in a
web browser.
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Figure 7.20 Adobe Flash Version of Bubble Plot
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Additional Information
The JMP website has additional information about the following;:

e more details about Adobe Flash versions of the Profiler, Bubble Plot, and Distribution
platforms

* instructions on importing the Adobe Flash versions into Microsoft PowerPoint

Visit https://www.jmp.com/support/swthelp/en/ for details.

Create Dashboards

A dashboard is a visual tool that lets you run and present reports on a regular basis. You can
show reports, data filters, selection filters, data tables, and graphics on a dashboard. The
content shown on the dashboard is updated when you open the dashboard.


https://www.jmp.com/support/swfhelp/en/
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Example of Combining Windows

You can quickly create dashboards by merging several open windows in JMP. Combining
windows provides options to view a summary of statistics and include a selection filter.

1. Select Help > Sample Data Library and open Birth Death.jmp.

2. Run the Distribution and Bivariate table scripts.

3. Select Window > Combine Windows.
The Combine Windows window appears.
Tip: On Windows, you can also select Combine Windows from the Arrange Menu option
in the lower right corner of JMP windows.

4. Select Summary Report View to display the graphs and omit the statistical reports

In the Combine column, select Birth Death - Bivariate of death by birth and Birth Death -
Distribution.

6. In the Filter By column, select Birth Death - Distribution.

Figure 7.21 Combine Windows Options

Mame: |Dashboard |
Summary Report View
Fitter By Combine Window

] Birth Death
] Birth Death - Bivariate of death by birth
Birth Death - Distribution
7. Click OK.

The two reports are combined into one window. Notice the filter icon ¥ at the top of the
Distribution report. When you select a bar in one of the histograms, the corresponding
data in the Bivariate graph are selected.
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Figure 7.22 Combined Windows
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Example of Creating a Dashboard with Two Reports

Suppose that you created two reports and want to run the reports again the next day against
an updated set of data. This example shows how to create a dashboard from the reports in

Dashboard Builder.

1. Select Help > Sample Data Library and open Hollywood Movies.jmp.

2. Run the table scripts named “Distribution: Profitability by Lead Studio and Genre” and
“Graph Builder: World and Domestic Gross by Genre”.

3. From any window, select File > New > Dashboard.
Templates for common layouts appear.

4. Select the 2x1 Dashboard template.
A box with room for two reports appears on the workspace.

5. In the Reports list, double-click the report thumbnails to put them on the dashboard.

6. Select Preview Mode from the Dashboard Builder red triangle menu.

A preview of the dashboard appears. Notice that the graphs are linked to each other and
the data table. They also have the same red triangle options as the Distribution and Graph
Builder platforms.

Click Close Preview.
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Figure 7.23 Dashboard with Two Reports
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For more information about creating dashboards, see the Extend JMP chapter in the Using
JMP book.



208 Save and Share Your Work Chapter 7
Create Dashboards DiscoveringJMP



Chapter 8

Special Features
Automatic Analysis Updates and SAS Integration

Using some of the special features in JMP, you can do the following:

¢ Update analyses or graphs automatically
e Customize platform results

¢ Integrate with SAS to use advanced analytical features

Figure 8.1 Examples of Special Features
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DATA Candy Bars; INPUT Calories Total_fat_g Carbohydrate_g Protein_g; Lines;
3le 2@ 28 6

23 12 27 4

228 12 24 3

17e 8 21 3

28 2.5 43 1

268 1 26 5

19 1.5 42 2

1% 11 21 2

238 12 28 3

H
RUN ;
PROC GLM DATA=Candy_Bars ALPHA=0.85;

MODEL Calories = Total_fat g Carbohydrate_g Protein_g;
RUN;
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Automatically Update Analyses and Graphs

When you make a change to a data table, you can use the Automatic Recalc feature to
automatically update analyses and graphs that are associated with the data table. For
example, if you exclude, include, or delete values in the data table, that change is instantly
reflected in the associated analyses or graphs. Note the following information:

e Some platforms do not support Automatic Recalc. For more information, see the JMP
Reports chapter in the Using JMP book.

e For the supported platforms in the Analyze menu, Automatic Recalc is turned off by
default. However, for the supported platforms in the Quality and Process menu,
Automatic Recalc is turned on by default, except for the Variability/Attribute Gauge Chart,
Capability, and Control Chart.

¢ For the supported platforms in the Graph menu, Automatic Recalc is turned on by default.

Example of Using Automatic Recalc

This example uses the Companies.jmp sample data table, which contains financial data for 32
companies from the pharmaceutical and computer industries.

Select Help > Sample Data Library and open Companies.jmp.
Select Analyze > Fit Y by X.

Select Sales ($M) and click Y, Response.

Select # Employ and click X, Factor.

Click OK.

A

Figure 8.2 Initial Scatterplot
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The initial scatterplot shows that one company has significantly more employees and sales
than the other companies. You decide that this company is an outlier, and you want to exclude
that point. Before you exclude the point, turn on Automatic Recalc so that your scatterplot is
updated automatically when you make the change.

6.

Turn on Automatic Recalc by selecting Redo > Automatic Recalc from the red triangle
menu.

Click on the outlier to select it.

Select Rows > Exclude/Unexclude. The point is excluded from the analysis and the
scatterplot is automatically updated.

Figure 8.3 Updated Scatterplot
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If you fit a regression line to the data, the point in the lower right corner is an outlier, and
influences the slope of the line. If you then exclude the outlier with Automatic Recalc
turned on, you can see the slope of the line change.

Fit a regression line by selecting Fit Line from the red triangle menu. Figure 8.4 shows the
regression line and analysis results added to the report window.
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Figure 8.4 Regression Line and Analysis Results
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10. Click on the outlier to select it.

11. Select Rows > Exclude/Unexclude. The regression line and analysis results are
automatically updated, reflecting the exclusion of the point.

Tip: When you exclude a point, the analyses are recalculated without the data point, but
the data point is not hidden in the scatterplot. To also hide the point in the scatterplot,
select the point, and then select Rows > Hide and Exclude.
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Figure 8.5 Updated Regression Line and Analysis Results
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Change Preferences

You can change preferences in JMP using the Preferences window. To open the Preferences
window, select File > Preferences (Windows) or JMP > Preferences (Macintosh).
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Figure 8.6 Preferences Window
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On the left side of the Preferences window is a list of Preference groups. On the right side of
the window are all of the preferences that you can change for the selected category.

Every platform report window has options that you can turn on or off. However, your

Example of Changing Preferences

changes to these options are not remembered the next time you use the platform. If you want
JMP to remember your changes every time you use the platform, change those options in the
Preferences window.

This example shows how to set the Distribution platform so that an Outlier Box Plot is not

added to the initial report.
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Create a Distribution Using the Default Preference Setting

1. Select Help > Sample Data Library and open Companies.jmp.
2. Select Analyze > Distribution.

3. Select Profits ($M) and click Y, Columns.

4. Click OK.

Figure 8.7 Distribution Report Window
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The histogram is vertical, and the graphs includes an outlier box plot. To change the histogram
to horizontal and remove the outlier box, select the appropriate options from the red triangle
menu for Profits ($M). However, if you want those preferences to be in effect every time you
use the platform, then change them in the Preferences window.

Change the Preference for the Outlier Box Plot and Run Distribution Again

1. Select File > Preferences (Windows) or JMP > Preferences (Macintosh).

2. Select Platforms from the preference group.
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3. Select Distribution from the Platforms list.

4. Select the Horizontal Layout option to turn it on.

5. Deselect the Outlier Box Plot option to turn it off.

Figure 8.8 Distribution Preferences
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7. Repeat the Distribution analysis. See “Create a Distribution Using the Default Preference
Setting” on page 216.

The histogram is now horizontal and the outlier box plot does not appear. These preferences

remain the same until you change them.

For details about all of the preferences, see the JMP Preferences chapter in the Using JMP book.

Integrate JMP and SAS

Note: You must have access to SAS, either on your local machine or on a server, to use SAS

through JMP.
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Using JMP, you can interact with SAS as follows:

e  Write or create SAS code in JMP.

e Submit SAS code and view the results in JMP.

e Connect to a SAS Metadata Server or a SAS Server on a remote machine.
® Connect to SAS on your local machine.

* Open and browse SAS data sets.

® Retrieve and view data sets generated by SAS.

For complete details about integrating JMP and SAS, see the Import Your Data chapter in the
Using JMP.

Example of Creating SAS Code

This example uses the Candy Bars.jmp sample data table, which contains nutrition data for
candy bars.

1. Select Help > Sample Data Library and open Candy Bars.jmp.
2. Select Analyze > Fit Model.

3. Select Calories and click Y.

4. Select Total fat g, Carbohydrate g, and Protein g, and click Add.
5

From the red triangle menu for Model Specification, select Create SAS Job.

Figure 8.9 shows the SAS code. (Not all of the data is shown.)

Figure 8.9 SAS Code

DATA Candy Bars; INPUT Calories Total_fat_g Carbohydrate_g Protein_g; Lines;
3le 2@ 28 6

23 12 27 4

228 12 24 3

17e 8 21 3

28 2.5 43 1

268 1 26 5

19 1.5 42 2

1% 11 21 2

238 12 28 3

H
RUN ;
PROC GLM DATA=Candy_Bars ALPHA=0.85;

MODEL Calories = Total_fat g Carbohydrate_g Protein_g;
RUN;

Example of Submitting SAS Code

1. Select Help > Sample Data Library and open Candy Bars.jmp.
2. Select Analyze > Fit Model.
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Select Calories and click Y.

3

4. Select Total fat g, Carbohydrate g, and Protein g, and click Add.

5. From the red triangle menu for Model Specification, select Submit to SAS.
6

In the Connect to SAS Server window (see Figure 8.10), choose a method to connect to
SAS (if you are not already connected). For this example, select Connect to SAS on this
machine.

Figure 8.10 Connect to SAS Server

Connect to metadata-defined SAS server:

Manage Profiles...|

@ Connect to remote SAS server on:

) Connect to SAS on this machine

Cancel |

7. Click OK.

JMP connects to SAS. SAS runs the model and sends the results back to JMP. The results can
appear as SAS output, HTML, RTF, PDF, or JMP report format (you can choose the format
using JMP Preferences). Figure 8.11 shows the results formatted as a JMP report. For details,
see the Import Your Data chapter in the Using JMP book.
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Figure 8.11 SAS Results Formatted as a JMP Report

The SAS System
The GLM Procedure

4 The GLM Procedure
4 Data
<4 Number of Observations

Number of Observations Read 75
Number of Cbservations Used 75
Dependent Variable: Calories
< Analysis of Variance
4 Calories

< Overall ANOVA

Sum of
Source DF Squares MeanSquare FValue Pr>F
Model 3 282358 941193 323758 <0001°
Error 71 206403 20,0709
Corrected Total 74 284422
< Fit Statistics
Calories

R-Square CoeffVar Root MSE Mean
0.00274 221858  5.30174 243027

<4 Typel Model ANOVA

Source DF TypelSS5 MeanSquare FValue
Total_fat_g 1 185260 185260 637268
Carbohydrate_g 1 935404 935404 321767
Protein_g 1 355786 3557.86 122.386
< Type IIl Model ANOVA
Source DF TypelISS MeanSquare FValue
Total_fat_g 1 111777 111777 384407 -
Carbohydrate_g 1 067561 067561 332828 <0001
Protein_g 1 3557.86 355786 122386 «.0001
4 Solution
Standard
Parameter Estimate Error tValue Pr> |t
Intercept -5.9643  2.89999 -2.0567 0.0434
Total_fat_g 898995 0.14498 62.0078

Carbohydrate_g 40875 0.07102 57.6913 -
Protein_g 440133 039785 11.0628 -
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data points
excluding 104
including 104
selecting 106
data tables 53
See also modeling types
adding
columns 71
rows 71
changing name of 71

Column Properties menu 81

columns panel 58
creating 70
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box plot and 141
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rotating the report window 140
Summary Statistics report 141

t-tests 142
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Effect Tests report 159
example, analyses 131
excluding data 104
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Fill options 75
filtering data 83
Fit Model platform

Actual by Predicted plot 163

analyzing variable relationships 145

Effect Tests report 159
launching 162

Parameter Estimates report 163

Prediction Profiler 164
Fit Y by X platform

analyzing variable relationships 145

contingency table 155
launching 151

Means and Std Dev report 153
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Graph Builder 118
changing box plots to line plots 121
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example 119
interpreting graphs 123
launching 157
graphing data 133
graphs
automatically updating 211-214
creating 119
multiple variable 102
See also Graph Builder
single variable 97
grid lines, adding to overlay plots 114

H

hierarchical clustering 177
histograms 97
creating 98
Distribution platform and 141
example 97
interacting with 99, 144
interpreting 98
Home window 54
HTML 5, save output as 196

icons, modeling type 71

importing data 67

interaction 158

interactive HTML, save report as 196

J

JMP 51
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creating SAS code in 218
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starting J]MP 54
submitting SAS code in 218
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JMP scripting language 196
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journals
adding analyses 186
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JSL (JMP scripting language) 196

L

lasso tool 106
launch windows 53
line plots, changing box plots to 121
linear fit report 149
lines
adding mean lines 152
titting 147
locking columns 81

M

mean lines 152
mean, testing 142
Means and Std Dev report 153
Microsoft Excel
importing data 68
versus JMP 63
modeling types
See also categorical variables
changing 137
continuous 80, 136
example 136
icons 71
nominal 80, 136
ordinal 80, 136
Mosaic Plot 156
multiple regression 160, 162
multivariate analysis 173



224

N

names
columns 80
data tables 71
nominal modeling type 80
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numeric data type 80
numeric values, formatting 80

(0

ordinal modeling type 80, 136
See also categorical variables

outlier box plots 61

outliers 99, 111
example 146, 149
excluding 149
implications of 152, 158
removing 104

overlay plots 112-113
adding grid lines 114
connecting points 114
example 112
interacting with 114
interpreting 114
legends 115
multiple variables and 115

P

Parameter Estimates report 163
patterned data, creating 75
platforms 53, 58

examples 59-63

launch windows 53

launching 59

report windows and 53, 60, 62

saving results 185

viewing results 59
plots

See specific plot type
PowerPoint, saving report as 201
Prediction Profiler 164
predictor variables 145
preferences, changing 214

Profiler platform, creating Adobe Flash
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results 202
proportions, comparing 154

Q

Quantiles report 141

R

recoding data 74
red triangle menus 53, 60
regression
multiple 160, 162
one predictor 146
two predictors 160
report windows 60
closing or opening 62
description 53
disclosure icons 53, 60
interacting with 62
platform options 53
red triangle menus 53, 60
reports in 53
rotating 140
reports
Effect Tests 159
Linear Fit 149
Means and Std Dev 153
Parameter Estimates 163
Quantiles 141
Summary Statistics 141
Tests 156
results, saving platform 185
rotating the report window 140
row state data type 80
rows
adding 71
clear row states 154
excluding or unexcluding 104
returning to default state 154
selecting or deselecting 76
rows panel 58

S

sample data tables 56
SAS
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scatterplot matrices 106 variability 110
creating 107 variability charts 115
example 107 creating 116
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interpreting 108 grouping order 116
scatterplot matrix 175 hiding 117
Scatterplot Matrix platform interpreting 118
example 161 variables
launching 161 analyzing relationships 145
scatterplots 102-103 categorical 142, 145, 151, 154
example 103 comparing averages for multiple 156
interacting with 106 comparing averages for single 151
interpreting 104 continuous 136, 140, 145-147, 151
scripts graphs with multiple 102
creating 194 graphs with single 97
JSL and 196 modeling types 136
running 194 overlay plots with multiple 115
searching for values 78 predictor 145
side-by-side box plots types of relationships 145
See box plots
sorting data tables by columns 93 W-Z
standard deviations 153 )
starting JMP 54 windows

statistics, summary 85 ]MP Starter wind.ow 54
subsetting data tables 89 Tip of the Day window 54

summary statistics 85
Summary Statistics report 141

T

table panel 57

testing means 142

Tests report 156

Tip of the Day window 54

trail bubbles 128

t-tests
Distribution platform 142
Fit Y by X platform 153
two-sample 153

'
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