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 Highlights in JMP 15
What’s New in JMP and JMP Pro

JMP 15 provides many bug fixes and feature enhancements.

New analysis platforms include the following:

•  Structural Equation Models

•  Support Vector Machines

• Model Driven Multivariate Control Chart

• Time Series Forecast

• Group Orthogonal Supersaturated Design

• Fit Group Orthogonal Supersaturated

This document provides highlights of these platforms and other new features.

 indicates features that are available only in JMP Pro.

General Enhancements

This section describes basic enhancements to JMP on Windows and Macintosh. For details, see 

the Using JMP book.

Axis

• The Wrap Lines option in categorical axis settings wraps a long label across lines.

Column Properties

• The Value Order column property window has been updated to provide rules for sorting. 

Notice that the column property is now “Value Order” instead of “Value Ordering”.

• List Check columns are now 16-bit; they support up to 65,535 categories.



10 Highlights in JMP 15 New Features 
General Enhancements  

Data Filter

• To create an indicator column, select the Save Where Clause > To Formula Column red 

triangle option. This option creates a numeric column with a value of “1” for rows that 

match the filter criteria, and “0” for all other rows.

• Bars have been added to categorical filters in the List Display and Check Box Display 

modes to represent the number of items in each category. Continuous filters use a new 

range selector display, drawn on top of a histogram for reference.

• To show or hide histograms and bars in the data filter, select the Show Histograms and 
Bars red triangle option.

• After you filter time series data in data filters, you can zoom in on the data filter histogram 

to see smaller time increments.

• Radio buttons are a display option for data filter when a column has nominal or ordinal 

data type.

Data Tables

• Click the histogram to the left of the column headers, and a histogram of the data in each 

column appears. This is an alternative to running a distribution. Right-click the histograms 

to find options such as showing or hiding minimum and maximum labels, and 

determining the number of bins.

• Table variables named “Notes” from the original data tables are included in new data 

tables after you join or concatenate them.

• In Virtual Join, you can add a Link ID column property and a Link Reference column 

property to the same column.

The Link Reference column property includes the Auto Open option. This option specifies 

whether the linked table is automatically opened when the main data table is opened.

• The Copy Table Script (No Data) data table red triangle option copies a script that 

re-creates the table but omits the data.

• The Rows > Row Selection > Select Where option provides a Save Script red triangle 

option. This option saves the script for the Select Where window to the clipboard, data 

table, or script window.

• Place your cursor over a referenced column in the Columns panel to see the source column 

of the virtually joined column.

• To copy the entire numeric value, select Edit > Copy With Full Precision. The option applies 

only to the fixed decimal format.

• In colored cells, the borders of selected cells are bolded and formatted in gray.

• To remove color from cells, select the cells and select Cols > Clear Cell Colors.
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• In Summary, a new statistics column name format called “stat” has been added. The name 

of the specified statistics appears in the column header.

• In Summary, the Units column property is retained from the source table.

• The Save Script to Source Table option is available in the Summary, Subset, Sort, Join, 

Transpose, Split, and Stack windows. The Source data table script enables you to rerun the 

operation.

• The right-click column commands called Copy Columns and Paste Columns are new.

– The Copy Columns command copies the script to recreate the columns. It copies all the 

attributes and properties. If there are selected rows, the data are also included in the 

script.

– The Paste Columns command creates new columns from the script generated by Copy 

Columns. The column will be placed after the selected column. If no column is selected, 

the new columns are placed at the end of the data table. The new columns populate (in 

the destination table) as many rows as there are data in the script.

• Copy Multi Columns Properties and Paste Multi Columns Properties have been renamed 

Copy Column Properties and Paste Column Properties. Copy Column Properties copies 

the column properties. Paste Column Properties pastes column properties as a single Add 

Column Properties script.

• In Rows > Row Selection > Name Selection in Column, the default label value for 

Unselected is missing rather than 0 to avoid overwriting data.

• Right-clicking a missing value and selecting Fill > Fill to end of table is supported.

• The images in an expression column can be displayed as hover labels over bar charts.

• In Tables > Update, two options have been added: Add Columns from Update Table and 

Replace Columns in Main Table. The options enable you to control which columns are to 

be added and which columns are to be replaced.

The new option Add Columns from Update Table replaces the earlier option Selected 

Columns. Add Columns from Update Table behaves exactly like Selected Columns if 

given a list of selected columns.

Formula Editor

• You can drag any part of a formula that can be selected to any other location that can be 

selected. A dotted line appears over the destination.

• To rearrange functions in the Functions list, select Customize Functions List from the 

Formula Editor red triangle menu.

• The Formula Editor recognizes the Excluded state and removes those rows from 

calculations.
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• If a function is used in a formula that is not in your Formula Editor function list, you can 

add it to your custom function list. Select that function in the Formula Editorʹs workspace, 

right-click, and then select Add to Category.

Home Window

• When you attempt to open a missing file (or a file that is on an unmounted drive), you are 

prompted to confirm to remove the file.

• In the Window List, the active data table is formatted with dark text. The active window is 

formatted with bolded text.

Hover Labels

• Data visualization hover labels can be customized with three new extensions:

– Textlets support descriptive text, with support for markup-driven rich text styles (bold, 

italic, text colors, different fonts) and data-driven contents.

– Gridlets support full customization of the hover label list of name-value pairs that 

reflect the underlying visual element data. Entries can be added, removed, renamed, 

and you can change their style and numeric formats.

– Graphlets support embedding graphical images on the hover label. That includes both 

static images (loaded from disk, data table, or the web), and preview thumbnails for a 

visualization in a secondary platform. Click the images to launch custom actions, or to 

launch the secondary platform as an independent window, providing the basis for a 

drill-down exploratory workflow.

All extensions are available for user customization in most visualizations that part of the 

JMP Platforms. The graphlet extension is already integrated with visualizations in 

numerous analytical platforms:

– Functional Data Explorer (FDE)

– Process Screening

– Principal Components

– Multivariate Control Chart

– Process Capabilities

Importing and Exporting Data

• To export JMP files to a variety of formats, select File > Export. This option is an alternative 

to selecting File > Save As.
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• To specify how XML elements are imported and to preview them, select File > Open and 

then select Data (Using Preview). To import the XML without previewing it, select File > 
Open and then select Data (Best Guess)

• Open a PDF file to import the file in the PDF Import Wizard.

• To import Google Sheets, select File > Internet Open > Google Sheets. To export a data 

table to Google Sheets, select File > Export and then select Google Sheets.

• When you open a data table with Internet Open, well-formed HTML links are maintained 

in the data table.

• When you import a Microsoft Excel file, you can right-click a numeric column header in 

the Data Preview pane to change the format.

• You can import Triple-S version 3 files.

• In Multiple File Import, select Include subfolders to import files from a subfolder.

• UTF-8 encoding for Japanese characters is supported in SPSS SAV files.

• On Windows, you can import password-protected XLSX files.

• The BF and 0A characters are recognized in ANSI CSV files.

• Creating Flash output is disabled by default. In JMP 16.0, the feature will be removed 

entirely. To enable Flash output, select File > Preferences > Menu and select Adobe Flash 
Export.

• The JSON and XML import wizards allow you to specify the same name for multiple 

columns if you want to combine them. If you import JSON with keys that are only 

different in case, JMP no longer automatically combines them into a single key.

Interactive HTML

• Support for the following Profiler platforms have been enhanced: LogLinear Variance, 

Partition, Bootstrap Forest, and Boosted Trees (with the same limitations as the previously 

supported platforms).

• Conditional data filters are supported. They enable you to filter data within hierarchical 

categories

• Support for line and area plots has been improved: lines and areas with X response

• Area charts have been merged into line charts by adding fill options and a stacking option 

to the line element.

• In Graph Builder, categorical lines of fit are interactive and include horizontal fit lines and 

rectangular confidence intervals.

• Y function plots (used in Capability analysis, among other platforms) are supported.

• Side-by-side interval bars are supported.
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• The new modern interface includes gray and light color themes, touchscreen detection 

(mode switches now appear only on mobile), and new styles for both desktop computers 

and mobile.

• Summary statistics for Color and Size roles are supported in Graph Builder.

• Control Chart Builder charts are partially supported. More features will be available in 

JMP 15.1.

JMP Help

• The Help (accessed from the Help > JMP Help menu) is available on jmp.com to allow for 

more frequent updates.

If you do not have an Internet connection, select Help > JMP Documentation Library to 

search all documentation PDF files.

• The Help > Books menu has been removed. Please visit 

https://www.jmp.com/documentation to download the documentation PDF files that are 

currently available.

JMP Live

JMP 14 users might be familiar with JMP Public, a platform for sharing JMP data, 

visualizations and dashboards, even those who do not have JMP.

JMP Live is a web based collaboration platform being introduced in JMP 15. Users of JMP will 

be able to publish to JMP Live if they have purchased this separate product.

• Column switchers are interactive in JMP Live.

• The social sharing buttons (Facebook, Twitter, and LinkedIn) are not shown by default. 

The administrator needs to add ALLOW_SOCIAL_SHARING=1 to the .env file and restart JMP 

Live to enable social sharing.

JMP Starter

• The JMP Starter includes an Import page that provides access to the import wizards.

JMP Subscription

• When you upgrade JMP 15 Subscription to the next release, menu and toolbar 

customizations are retained. In other JMP versions, you must customize the menus and 

toolbars after each upgrade.

https://www.jmp.com/documentation
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Mac

• On MacOS Mojave 10.14, Dark Mode is supported. This MacOS system preference 

changes the interface of the entire system and all applications to use a darker color theme.

• The JMP web browser is supported.

• Printing preferences have been added, and printing quality is improved.

• Selecting File > Internet Open > Web Page now opens the web page in the JMP browser 

instead ofo the default browser.

Preferences

• Items in the Preferences groups have been rearranged, and new preferences groups have 

been added.

– Open Text File Charset and Save Text Files as Unicode are on the Text Data Files page.

– The new Third-Party page contains options for importing Microsoft Excel files, 

Microsoft PowerPoint files, SPSS files, and Triple-S files.

– Internet Open and proxy settings are on the new Internet Options page.

Projects

• The new Recent Files pane lists files that were recently used in JMP.

• Pressing Shift + Esc returns the focus to the current tab.

Recode

• To recode column names, select Cols > Utilities > Recode Column Names.

• See File > Preferences > Recode for new recode preferences.

• To modify the recoding in a saved script, right-click the script in the data table and select 

Edit with Recode. After making changes, select Script > Save to Data Table from the red 

triangle menu to save your changes in a new script.

• Selecting rows on the Recode window also selects them in the data table.

• By default, recoded data appears in a new column. To always recode the column that you 

selected, select File > Preferences (Windows) or JMP > Preferences (Macintosh), select 

Recode, and then select In Place from the Commit Style list.

• To convert character values to numeric, select the Parse to Numbers red triangle option.
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• To copy a column from the Recode window, right-click the column and select Copy 
Selected Column Rows. To copy the data for all columns in the selected row, right-click the 

row and select Copy Selected Table Rows.

• To save your actions to a script and omit the data, select Script sequence of actions on the 

Recode window. This option attempts to capture the sequences of the actions when 

available.

• Select Advanced > Choose Closest to map values in the column of a “master” data table to 

the column that you are recoding.

Reports

• The main menu includes an option to edit display box properties. In a report window, 

select Edit > Properties (Windows) or View > Show Properties (Macintosh). Click the node 

that you want to edit.

• When you sort a string column in a report, you can select Numerical Ordering to sort the 

sorted column numerically. After you do that, the Numerical Ordering option is available 

when you right-click the column.

Samples

• The following sample import data have been added to demonstrate the new PDF Import 

Wizard: Iris.pdf, Groundhog Day Predictions.pdf, and Food Distribution.pdf.

• The Book.xml sample import data demonstrates the new XML Import Wizard.

• Flight Delays.jmp in the Quality Control folder demonstrates the new Model Driven 

Multivariate Control Chart platform.

• Billion Dollar Events.jmp demonstrates a packed bar chart.

• Nicardipine Lab Patterns.jmp demonstrates the Explore Patterns platform.

• The new Functional Data folder contains Anodic Bond.jmp, Dynamic DOE - Surface Tension 
Curve.jmp, Mill DOE.jmp, Simple Linear Functional Data.jmp, Formulation For Homogeneity 
DOE.jmp, Weekly Weather Data.jmp, Fermentation Process.jmp, Fermentation Process Batch 
Yield Results.jmp, and Fermentation Process Row Functions.jmp.

Note that Weekly Weather Data.jmp has been moved from the Samples/Data folder to the 

Samples/Data/Functional Data folder.

• A Functional Data section has been added to the Help > Sample Data window.

• Discovery US 2018 Survey.jmp contains data from a survey given to Discovery US 2018 

attendees. The results are displayed in a parallel plot.

• The following sample data tables contain scripts that demonstrate the new graphlet 

feature: Diabetes.jmp, JMP Man Dozen.jmp, San Francisco Crime.jmp, and Solubility.jmp.
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• M3C Quarterly.jmp demonstrates the Time Series Forecast platform.

• Employee Master.jmp, Education History.jmp, and Predicted Termination.jmp demonstrate 

Virtual Join.

• State Abbrevations.jmp and State Capitals.jmp demonstrate the Recode advanced option for 

applying mapping from a data table. Recode state names in State Capitals.jmp using the 

State Abbrevations.jmp data table. The option is in Recode > Advanced > Apply Mapping 

from Table.

• Cochrans Q.jmp demonstrates the Multiple Correspondence Analysis platform.

• Job Satisfaction.jmp demonstrates the new Structural Equation Models platform.

Transform Columns

• The SHASH transform is available in Graph Builder on the transformation Distributional 

list. The transform calculates the cumulative distribution function (cdf) evaluated at x of 

the sinh-arcsinh (SHASH) distribution. In the launch window’s Select Columns list, 

right-click the column and select Distributional > SHASH.

• The Rank (reverse order) transform has been added to the Character and Distributional 

lists. It returns the rank, ranging from 1 as the highest, with row-order tie-breaking. In the 

launch window’s Select Columns list, right-click a character column and select Character > 
Rank (reverse order). For a distribution, right-click and select Distributional > Rank (reverse 
order).

Visualization

• The Cividis continuous color theme is available. Cividis is a form a Viridis that is designed 

for viewing with color deficiencies.

Windows

• The auto-hide menu strip in reports is more noticeable. Look for a blue bar with a centered 

ellipse.

Basic Analysis

This section describes new features and enhancements in the general analysis platforms. For 

details, see the Basic Analysis book.



18 Highlights in JMP 15 New Features 
Basic Analysis  

Bivariate

• In the Local Smoother report, the Sampling Delta red triangle option controls the amount 

of sampling that is used in the fitting process. By default, the sampling delta is zero, which 

means that none of the points are skipped.

Distribution

• Preferences for Tolerance Interval Confidence Level, Tolerance Interval Proportion, 

Tolerance Interval Type, and Tolerance Interval Method have been added. In the Tolerance 

Intervals report, a hidden column shows the K-factor (tolerance factor) when the 

parametric normal method is used.

• The capability report has been replaced with the newer Process Capability Analysis report 

that is in the Process Capability platform and Control Chart Builder.

• To hide box plot confidence diamonds in all box plots, select File > Preferences > Platforms 

> Distribution and deselect Show Box Plot Confidence Diamond.

• To hide the shortest half bracket in all outlier box plots, select File > Preferences > 

Platforms > Distribution and deselect Show Outlier Box Plot Shortest Half.

• Bias adjustment constants d2, d3, and d4 are now computed for sample sizes up to 50.

• The distribution fitting features have been updated and improved:

– The reports now include PP plots, QQ plots, and profilers for the CDF and quantile 

functions.

– Cauchy, Negative Binomial, ZI Poisson, and ZI Negative Binomial distributions are 

available.

– The binning for the Pearson Chi-Square Goodness of fit test has been improved.

– The Anderson Darling Goodness of Fit tests have been added for continuous 

distributions.

– New save commands have been added: Save Simulation Formula and Save 

Distribution Formula.

Oneway

• You can modify categorical axis properties in Oneway.

Tabulate

• Tabulate responds from selections in the data table.
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• With a single-click, you can place columns in drop zones instead of requiring dragging 

like other platforms. Select one or more columns in the Columns list, select one or more of 

the statistics, and then Alt-click (Option-click on Macintosh) on a drop zone.

Text Explorer

• Formula columns saved from Text Explorer now support text preparation options, 

including phrases, stop words, regular expressions, recodes, and stemming.

• You can rename topics and clusters in a Text Explorer analysis report. The new names 

are used in saved columns and saved scripts.

Graphing

This section describes new features and enhancements in the graphing platforms. For details, 

see the Essential Graphing book.

• In points, line charts, bar charts, and area charts, selecting the Save Summary Formula red 

triangle option saves fit formulas and upper and lower confidence intervals for a single 

variable to the data table. In the smoother and line of fit, the Save Formula red triangle 

option saves fit formulas and upper and lower confidence intervals for multiple variables 

to the data table.

• With a categorical column in Blocks mode, you can drag over several levels of a mosaic 

plot to do a multiple selection. This option also works in mosaic plots (for example, in the 

Categorical platform and data filters).

• A new Fill Pattern option called None is available. Right-click the graph, select Customize, 

and then select Histogram to specify the fill patterns.

Bubble Plots

• In bubble plots that contain a time variable, select the Show Time Annotation red triangle 

option to show or hide the time that appears on the graph.

• Creating Flash output is disabled by default. In JMP 16.0, it will be removed entirely. To 

enable Flash output, select File > Preferences > Menu and select Adobe Flash Export.

Graph Builder

• On the Fonts page of the preferences, font settings are available for graph titles, captions, 

graph labels, and legends.
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• For the Line of Fit element, you can choose from Polynomial, Robust Cauchy, or Time 

Series fits. You can also save the formula for the fit to the data table.

• Treemap, Chart, and Overlay Plot have been moved to the Graph > Legacy menu. Please 

use Graph Builder to create these graphs.

• Area charts have been merged with Line charts. Fill options and a stacking options are 

available. The Fill options include at least fill-below and fill-between to reproduce Area 

behavior. Regarding stacking, if there are multiple responses, the values are stacked in the 

order of the variables. If there is an overlay, the values are stacked in the order of the 

overlays. If there are both multiple responses and an overlay, then the values are 

accumulated for the responses within each overlay.

• When both overlay and color variables are applied to points, the marker color and marker 

shape legend items are better distinguished.

• More control is provided over the basis for percents:

– % of Total: Response divided by the sum of like responses over all factor levels.

– % of Factor: Response divided by the sum of all responses for the same factor level.

When % of Factor is combined with stacked bar style, you get a bar chart in which the 

total is 100%.

– % of Grand Total: Response divided by the sum of all responses over all factor levels.

• In Graph Builder legends, row state colors are used instead of the default colors. In the 

Color Settings red triangle menu, select the Use row colors for levels option to specify this 

behavior.

• Individual points (in summary mode), line charts, bar charts, treemaps, heatmaps, and 

contour plots (in violin mode) can have a different summary statistic. Select the statistic 

from the Summary Statistic list in the Properties area.

• To customize the jitter on error bars, select the Error Bar Offset red triangle option and 

adjust the offset.

• If outliers are turned off, the axes readjust to exclude minimum and maximum values.

• In mosaic plots, right-click the plot, select Customize > Mosaic, and then select the line 

color, line style, or line width to show between cells.

• To save all BY groups to the data table, journal, script window, or clipboard, select the 

Save By-Group Script red triangle option.

• By default, 200 pages are shown. You can change that limit in the Graph Builder 

preferences.

• To initialize legend levels with row colors, select Use row colors for levels in the Color 

Settings.
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Box Plots

• Color support has been added to box plots.

• You can change the width of box plots and whiskers to align the width of the boxes in the 

graph.

Contour Plots

• Two-dimensional Highest Density Regions (HDR) plots are supported. The following 

three options are available for continuous X-Y data: Nonpar density, Bagplot, and HDR.

• One-dimensional HDR plots are supported. Select HDR from the Contour Type list in the 

Properties area.

• Fill, Line, and Boundary options are supported. These options enable you to create a 

contour plot in Graph Builder based on bivariate data.

• To color by density, right-click a density contour plot legend and select Density Gradient or 

Gradient Transparency.

• Two-dimensional bagplots for continuous X-Y data are supported in contour plots. The 

bagplot consists of two polygons, a set of outlier points, and a median point. All 

computations are based on first computing the Tukey depth (bivariate depth) of each point 

in the data.

• Both one-dimensional density (violin and HDR) and two-dimensional density (nonpar 

density and HDR) have added smoothing support. The default value of 0 uses a default 

smoothing level, while negative values smooth less and positive values smooth more.

• An alpha slider option is available for value contours.

Ellipses

• To show the mean point of each ellipse, select Mean Point in the Ellipse options.

Heatmaps

• In heatmaps, the options are now Line Color, Line Style, Line Width, Transparency, and 

Fill Pattern. Line Color, Style and Width are used for the borders of the rectangles. 

Right-click the heatmap and select Customize to see these options.

Histograms

• Counts or percentages of column values are supported on Y axes.

• You can overlay density curves on histograms. Histograms have a new Histogram Style 

setting with four options: Bar, Shadowgram, Polygon, and Kernel Density.
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The New Counts and Percents check boxes enable you to display counts and percents 

above each histogram bar.

• You can overlay smoother curves on histograms. To create the overlay, add two histogram 

elements and give one an empty fill.

• A new Overlap slider appears in the Properties area for nominal or ordinal columns on the 

non-response axis. This option enables you to scale the response axis of the histogram.

• Smaller bin sizes are displayed more accurately.

Line Charts

• Shaded intervals are available for line charts. The Error Bars option has been renamed 

“Error Interval” on line, bar, and points charts. Interval Style has been added to line charts 

with the options of Error Bars and Bands.

Mosaic Plots

• To add a label, right-click a cell, select Mosaic > Cell Labeling, and then select the type of 

label that you want to add.

Points

• The Band Interval Style option shows a shaded band for each point.

Smoother

• To save predicted values from a smoother, right-click the smoother and select Smoother > 
Save Formula.

Treemaps

• The statistic term is shown for Size variables.

Maps

• When you import a DBF file, the Shape column is created for you.

Scatterplot Matrix

• Confidence intervals for the means and individuals are shown when the x variables are 

categorical and y variables are continuous.
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Profilers

This section describes new features and enhancements in the Profiler platforms. For details, 

see the Profilers book.

• In the Contour Profiler, the Multiple Contour Frames red triangle option enables you to 

add one or more contour plots to the report that represent different combinations of factor 

settings. When you select this option, the Multiple Contour Frames window appears. 

Specify additional individual contour plots or a matrix of contour plots in this window.

• The Remember Settings red triangle menu includes options to remove selected settings or 

all settings.

DOE

This section describes new features and enhancements in the DOE platforms. For details, see 

the Design of Experiments Guide.

Group Orthogonal Supersaturated Design

• The Group Orthogonal Supersaturated Design platform enables you to design a 

supersaturated design with improved active effect identification as compared to 

traditional supersaturated designs.

Fit Group Orthogonal Supersaturated

• The Fit Group Orthogonal Supersaturated platform enables you to analyze group 

orthogonal supersaturated designs.

Fitting Linear Models

This section describes new features and enhancements in the Fit Model personalities. For 

details, see the Fitting Linear Models book.

Fit Model

• In the Construct Model Effects box in the launch window, you can drag effects to 

rearrange them.
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 Generalized Regression

• You can fit different response distributions in a single report window. A Model 

Comparison report has been added to the top of the window so that you can quickly sort 

the fitted models by the various fit statistics.

• You can now view a summary of the points in the solution path using the Solution Path 

Summary report under Regression Reports.

• The covariance and correlation matrices no longer contain rows or columns corresponding 

to the zeroed terms.

• The Adaptive option is no longer selected by default for the Lasso and Elastic Net fits.

• The Relaunch Active Set menu contains options that open a Fit Model launch window 

where the Construct Model Effects list contains a set of terms based on the terms that have 

nonzero parameter estimates. These terms are the active effects. All other specifications in 

the launch window are those used in the original analysis.

Standard Least Squares

• When the Effect Screening emphasis is selected, a Box-Cox transformation is calculated. If 

the confidence interval for the estimated lambda does not contain 1, the Box-Cox 

Transformations report appears.

• When you specify a Validation column, observations from the Validation and Test sets are 

marked as “v” and “t”, respectively, in plots in the report.

• The number of observations (“N”) has been added to the Least Square Means Estimates 

table. It specifies the number of observations used to calculate the mean for each group.

• In the Actual by Predicted plot, the label for RSquare uses a format with more decimal 

places when the RSquare value is less than 0.02 or greater than 0.98.

• In the Fit Model Specification window, you can specify that pure error or a user-specified 

error be used in the Standard Least Squares platform rather than the default error 

estimate.

Predictive and Specialized Modeling

This section describes new features and enhancements in the advanced Modeling platforms. 

For details, see the Predictive and Specialized Modeling book.
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Association Analysis

• In Association Analysis, the default value for the Maximum Rule Size option is 4. 

Previously, the default value was 99.

Fit Curve

• The following Model Fit red triangle options have been added:

– Time to Peak Response shows the estimate of the regressor, X, at the peak of the fitted 

curve. The standard error of the estimate is also shown. This option is available for Cell 

Growth 4P and One Compartment models

– Peak to Response shows the estimate of the response, Y, at the peak of the fitted curve. 

The standard error of the estimate is also shown. This option is available for Cell 

Growth 4P and One Compartment models.

• The Cell Growth 4P model formula is available when the response values are positive and 

the regressor values are non-negative.

 K Nearest Neighbors

• To save K columns to the data table, select Save Near Neighbor Distances from the red 

triangle menu. The columns are named Distance <k>. For a given row, the kth column 

contains the distance to that row’s kth nearest neighbor.

 Make Validation Column

• Make Validation Column is now a platform that is available in the Analyze > Predictive 

Modeling menu. Previously, it was a utility.

• Creating a validation column based on a cutpoint now supports the use of proportions, 

number of rows, specific dates, and elapsed time.

• All validation column generation methods now support the creation of a formula column.

Modeling Utilities

• The Explore Patterns modeling utility enables you to detect suspicious patterns in your 

data.

Neural

• You can set a random seed on the launch window when fitting using a validation column.
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Partition

• Bootstrap is available for Partition, Bootstrap Forest, and Boosted.

Process Screening

• To create the Process Summary data table with an additional column titled Graph, select 

the Save Summary Table with Graphs red triangle option. The Graph column contains a 

quick graph for each process in the Process Summary title.

• In goal plots and process performance plots, place your cursor over a point to view the 

quick graph for that process. Click Quick Graph to add it to the report window.

• In the Process Screening report, the Capability > Expected Out of Spec Rate red triangle 

option shows the expected proportion of observations that fall outside of the specification 

limits. The option appears only when there are Spec Limits specified for some processes.

• Markers in the performance plots and goal plots are sized by importance, if importance 

values are defined.

• More fields in the Process Capability Limits Specifications window automatically fill from 

fields in the tall format limits tables created in Control Chart Builder.

• Bias adjustment constants d2, d3, and d4 are now computed for sample sizes up to 50.

 Support Vector Machines

• The Support Vector Machines (SVM) platform provides a machine learning tool for binary 

and multi-class classification problems. The SVM algorithm is a supervised learning 

algorithm where one of the goals is to use training data to learn how to classify new data. 

The platform is available in the Analyze > Predictive Modeling menu.

Model Comparison

• The Model Comparison platform recognizes when all specified models use a common 

validation column. In this situation, JMP provides the option to add the validation column 

as a grouping column for the model comparison.

Time Series Forecast

• The Time Series Forecast platform enables you to forecast multiple time series, where the 

number of series could be very large. The platform is available in the Analyze > 

Specialized Modeling menu.
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Multivariate Methods

This section describes new features and enhancements in the Multivariate Methods platforms. 

For details, see the Multivariate Methods book.

Multidimensional Scaling

• Upper-diagonal matrices are supported.

Multivariate

• To customize the look of a scatterplot matrix, select Matrix Options from the Scatterplot 

Matrix red triangle menu.

• The Partial Correlation Probability red triangle menu shows or hides the Partial 

Correlation Probability report, which is a matrix of p-values.

• New options for nonparametric correlations have been added.

– Create color maps for four measures of association between variables: Spearman’s rho, 

Kendall’s tau, Hoeffding’s D, and pairwise correlations.

– All of the correlation color maps in multivariate have been modernized.

– You can customize the legend and axes.

– You can adjust the fill pattern and transparency of the color maps.

Partial Least Squares

• To save T2 values to the data table, select the Save Columns > Save T Square red triangle 

option. These values are used in the T Square Plot.

Principal Components

• Place your cursor over a point in the T2 Plot to view the T2 Contribution Proportion Plot 

for that observation. Click the T2 Contribution Proportion Plot to add it to the report 

window.

• The Score Ellipses red triangle option shows or hides ellipses on the summary score plot 

for each pair of principal components. The ellipses are constructed as either confidence 

ellipses based on the alpha level or a control limit ellipses based on how far the 

observations are from the center. The Score Ellipse Coverage red triangle option shows a 

submenu that enables you to change how the score ellipses are constructed. Specify the 

score ellipses by confidence level or the distance from the center in terms of k-sigma.
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 Structural Equation Models

• The Structural Equation Models (SEM) platform enables you to fit a variety of models, 

including confirmatory factor analysis, path models with or without latent variables, 

measurement error models, and latent growth curve models. The platform is available in 

the Analyze > Multivariate Methods menu.

Quality and Process Platforms

This section describes new features and enhancements in the Quality and Process platforms. 

For details, see the Quality and Process Methods book.

Control Chart Builder

• Preferences have been added for Control Chart Builder to specify different dispersion 

chart preferences: one for summarized data and one for non-summarized data.

• When no subgroup variable is specified, the Get Limits option now uses the subgroup size 

(_Sample Size) from the limits table. Also, when the limits are missing in the file, JMP also 

looks for the sigma (_Std Dev). When no LCL or UCL are specified in the limits file (if both 

the average and sigma are found, and the subgroup size is constant), the option sets the 

limits based on the average, subgroup size, and sigma.

• Bias adjustment constants d2, d3, and d4 are now computed for sample sizes up to 50.

• The Save Limits > in New Tall Table red triangle option saves the standard deviation and 

mean for each chart into a new data table.

• The Sort by Row Order red triangle option sorts all subgroup and phase variables in the 

order in which the levels appear in the data table.

• The tall limits table reports a sigma that can be used in Process Screening.

• The Show Sigma Report red triangle option shows or hides the Process Sigma Report, 

which is a table of sigma values. The Process Sigma Report contains the overall sample 

size, subgroup sample size, sample mean, overall sigma, within sigma, and stability index.

• IR, XBar, Runs Chart, P, NP, C, U, Levey Jennings, Presummarize, and CUSUM charts have 

been moved to the Analyze > Quality and Process > Legacy Control Charts menu. Please 

use Control Chart Builder to create these charts.

• Launch windows for specific types of charts in Control Chart Builder are available in the 

Analyze > Quality and Process > Control Chart menu.

• The Control Chart Dialog red triangle option opens the Control Chart launch window 

with the original settings that were used to create the control chart.
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• To show or hide a table that gives information about out-of-control samples, select the 

Show Alarm Report red triangle option. The report reflects failures in the first chart for 

currently enabled tests and updates automatically as different tests are enabled and 

disabled.

• In the right-click Axis options, if there is more than one chart type on the graph, a 

submenu for Remove is shown. This submenu lists the different charts. You can select 

which chart to remove.

• For Variables chart types, the Sigma Median Moving Range option uses the median 

moving range to estimate sigma, rather than the average moving range.

• In the Alarm report table, the Alarm Rate columns shows the total number of 

out-of-control samples divided by the total number of samples. This is also known as the 

Proportion Out of Control.

• The Points > Box Plots option in the Options panel and the right-click menu shows or 

hides box plots.

• The Limits > Shade Zones option in the Options panel and the right-click menu shows or 

hides shading zones by ranges.

• To write an alarm script, select Alarm Script from the red triangle menu. The script enables 

you to write and run a script that indicates when the data fail special causes tests.

• Select File > Preferences > Platforms and then deselect Show Lower Control Limit to hide 

lower control limits. They are shown by default.

Control Charts

• The CUSUM Control Charts menu item has been moved to the Control Chart menu.

• Bias adjustment constants d2, d3, and d4 are now computed for sample sizes up to 50.

Measurement Systems Analysis

• Bias adjustment constants d2, d3, and d4 are now computed for sample sizes up to 50.

Manage Spec Limits Utility

• You can specify importance values for each process and indicate whether limits should 

appear in graphs as reference lines.
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Process Capability

• If you specify process importance values in the Spec Limits column property, markers in 

the process performance plot, the goal plot, and the capability index plot are sized by the 

importance values.

• Clicking the Select All Show Limits button selects the Show Limits option for all processes.

• If there is at least one non-missing process importance value, an Importance column is 

included in the Summary Report.

• Place your cursor over a point in the Process Performance plot, Goal plot, or Capability 

Index plot to view a control chart for that process. Click the control chart to launch Control 

Chart Builder with the corresponding control chart and capability report.

• In the Individual Details Report, the Fix Parameters red triangle option shows a window 

that enables you to fix a subset of parameter values in a nonnormal distribution.

• In the launch window, the Moving Range Options outline enables you to specify which 

moving range statistic is used in the within sigma estimate.

• You can use unbiased pooled standard deviation to estimate the within sigma when there 

are subgroups.

• Bias adjustment constants d2, d3, and d4 are now computed for sample sizes up to 50.

• The SHASH distribution is available in the list of available distributions.

• In the Individual Details Report, selecting the Interactive Capability Plot option enables 

you to change the value of one or more summary statistics and see how the changes affect 

the capability analysis.

• The Within Sigma Target Index is a new command under Capability Indices. If you select 

it, the Within Sigma Target Index outline appears.

• By default, the confidence intervals for the capability indices are constructed based on α = 

0.05. To change the default confidence level, select File > Preferences > Platforms > 
Process Capability.

Variability Chart

• The Variability Summary report contains the coefficient of variation (CV).

• To change the color of the group means lines, right-click the chart, select Customize, and 

then select a color in the Group Means category.

Model Driven Multivariate Control Charts

• The Model-Driven Multivariate Control Chart platform enables you to build control charts 

based on principal components or partial least squares models. Model-driven multivariate 
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control charts are control charts used to monitor multiple processes parameters. The 

platform is available in the Analyze > Quality and Process menu.

Reliability and Survival

This section describes new features and enhancements in the Reliability and Survival 

platforms. For details, see the Reliability and Survival Methods book.

Degradation

• In the Degradation Data analysis red triangle menu, the Graph Options > Show Fitted 

Lines option is on by default.

Destructive Degradation

• If you specify a reference temperature (X0), this value is also displayed at the top of the 

Estimate report.

• Time Transformation is included in Model List report.

Fit Life by X

• To show or hide confidence intervals around the quantile lines, select the Show Quantile 
Line CI Bands red triangle option. The Set Level of Quantile Line CI Bands red triangle 

option specifies the confidence level for the confidence intervals around the quantile lines.

Recurrence

• In the Fitted Recurrence Model red triangle menu, select Publish Intensity Formula to 

create the Intensity formula and save it as a formula column script in the Formula Depot 

platform. Select Publish Cumulative Formula to create the Cumulative formula and save it 

as a formula column script in the Formula Depot platform.

Reliability Block Diagram

• To import configuration settings for the system diagram from a data table, select the 

Import Component Distribution Settings red triangle option.
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Repairable Systems Simulation

• To import configuration settings for the system diagram from a data table, select the 

Import Component Distribution Settings red triangle option.

Consumer Research

This section describes new features and enhancements in the Consumer Research platforms. 

For details, see the Consumer Research book.

Categorical

• On the Structured tab, you can drag columns into the new Multiple Aligned zone. This 

enables you to summarize data from multiple columns with the same response levels in a 

single report.

Choice

• BY groups are supported in the Choice platform.

• The Coding column property is supported. The column property applies a linear 

transformation to the data in a numeric column.

MaxDiff

• BY groups are supported in the MaxDiff platform.

Scripting

This section describes new features and enhancements in the scripting area. For details, see 

the Scripting Guide and the JSL Syntax Reference.

New Commands

• SAS Viya uses Cloud Analytic Services (CAS) code to perform calculations in the cloud. 

This feature provides a way for SAS Viya users and JMP users to collaborate. You can 

write CAS code in JMP to import data from and export data to the CAS server, convert 
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CAS JSON text to a JMP data table, get a list of available CAS libraries, and more. See the 

SAS Viya REST API documentation at https://developer.sas.com/guides/rest.html.

• In jmpStartAdmin.jsl, the administrator can enable or disable publishing to specific 

locations.

Enable JMP Live URL("*"); // enable publishing to all JMP Live URLs
Disable JMP Live URL("*public.jmp.com"); // disable http://public.jmp.com and 

https://public.jmp.com.
Disable JMP Live URL("*") // disable every JMP Live connection

The administrator can also completely disable publishing with Disable JMP Live("*"). 

Then users can only publish to a file.

• In jmpStartAdmin.jsl, the administrator can add read-only bookmarks. These bookmarks 

appear on the Select Reports window when a user publishes reports to JMP Live and JMP 

Public.

Add JMP Live Bookmark("JMP Public 15", URL("https://public.jmp.com"));
Add JMP Live Bookmark("JMP Live 15", URL("https://live.company.com"));

The user can also add bookmarks in the Select Reports window during the publishing 

process.

• Items(string, <delimiters>) returns a list of (possibly empty) substrings separated 

by exactly one of any of the characters that are specified in the delimiters argument. If 

delimiters is omitted, ASCII characters are used. If delimiters is an empty string, each 

character is treated as a separate item.

• Check Box(Get Selected Indices) returns a list of all selected indices.

• The base(number) argument has been added to the Hex() function to allow for converting 

a binary string to a decimal number, and a decimal number to a binary string. The new pad 

to(number) argument specifies the padded width of the hexadecimal output.

• In categorical local data filters, the Display(Find(Set Text(string)) expression finds 

the specified string in the filtered data.

• Text Font() sets the font for text strings.

• Random Multivariate Normal() returns a random vector from a multivariate normal 

distribution with mean vector mean and covariance matrix covar.

• Range() returns the minimum and maximum values of the arguments. The result is 

returned as a two-element row vector that contains the minimum and the maximum.

• Median(), V Median(), Col Median(), and V Quantile() functions have been added. 

Median() the median of the arguments or of the values within a single matrix or list 

argument. V Median() returns a row vector containing the median of each column of 

matrix. Col Median() calculates the median across all rows of the specified column. V 

Quantile() returns a row vector containing the pth quantile of each column of matrix.

• Specify the size of a new window with the Set Window Size or Size Window message.

https://developer.sas.com/guides/rest.html
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• The display box Prev Sib message returns the previous sibling of the display box.

• The Google Sheet Export() function enables you to export a data table to Google Sheets. 

The Google Sheet Import() function enables you to import Google Sheets.

• Col Simple Exponential Smoothing() enables you to create a formula column that 

computes exponential smoothing predictions based on a fixed smoothing constant.

General Enhancements

• Now that overlay plots are deprecated, scripting support has been removed for them. Use 

Graph Builder to create overlay plots.

• When a script fails, the file and line number are reported in the log.

• Specifying new MATLAB, JavaScript, C, and SQL languages enables syntax highlighting 

for the specified language in Script Box().

• Capture the list of imported files in the log when the user clicks the Import button on the 

Multiple File Import window. See the Data Tables chapter in the Scripting Guide for an 

example.

• In Web(string, <JMP Window>), <JMP Window> is now supported on both 

Windows and Macintosh.

• Row names and column names are supported in Matrix Box().

• When the Markup message is sent to a text box, you can change the font size with <font 

size="...">.

• The display box Set Page Setup message now affects print output (in addition to PDF 

output).

• The Col functions honor excluded rows through the Excluded(Row State()) function.

Col Maximum( :height, :sex, Excluded( Row State() ) );

• The following functions were updated to include a frequency parameter:

– Col Cumulative Sum()

– Col Mean()

– Col Median()

– Col Number()

– Col Quantile()

– Col Std Dev()

– Col Sum()

• Matrix() now supports row vector expressions in nested lists.

• Shape() takes an nrow or an optional ncol argument. The optional bycol message 

specifies that the values be placed into the reshaped matrix column-by-column, instead of 

row-by-row. A scalar or matrix first argument are supported.
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• When moving selected columns in a data table, you can use a list to specify the column 

names.

• Delete Row is an alias of Delete Rows.

• The Copy Multi Columns Properties and Paste Multi Columns Properties messages 

have been renamed Copy Column Properties and Paste Column Properties. Copy Multi 

Columns Properties and Paste Multi Columns Properties are still supported for 

backward compatibility.

• General expressions are supported in Select Where() expressions for table boxes. This 

enables you to specify more complex conditions.

• Tree nodes support the following messages:

– Get Dimmed(<node>) gets the option to dim text (decrease the opacity) for the node.

– Set Dimmed(Boolean) sets the option to dim text for the node.

– Get Font Style(<node>) gets the font style for the node.

– Set Font Style("Plain"|"Bold") specifies the font style for the node.

• Write a workspace start-up script to perform certain actions in a project automatically 

without running a separate script. For example, you can construct a new customized 

window in a workspace start-up script to put a copy of that window in each project.

• In Constrained Maximize() and Constrained Minimize(), you must specify either lower 

and upper bounds in parentheses for each argument or with the optional Set Variable 

Limit message.

• Get Column References is an alias for Get Column Reference.

• Word(), Words(), Item(), and Items() have an optional delimiters argument to treat 

punctuation and white space as delimiters. If delimiters is not specified, an ASCII space 

is used. If delimiters is an empty string, each character is treated as a separate word.
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