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Get the Most from JMP

Whether you are a first-time or a long-time user, there is always something to learn about
JMP.

Visit JMP.com to find the following:

* live and recorded webcasts about how to get started with J]MP

* video demos and webcasts of new features and advanced techniques
¢ details on registering for JMP training

¢ schedules for seminars being held in your area

® success stories showing how others use JMP

* ablog with tips, tricks, and stories from JMP staff

e aforum to discuss JMP with other users

https://www.jmp.com/getstarted
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Chapter 1

Learn about JMP

Documentation and Additional Resources

This chapter includes details about JMP documentation, such as book conventions,
descriptions of each JMP document, the Help system, and where to find other support.



10 Learn about JMP Chapter 1

JSL Syntax Reference
Contents

Formatting Conventions ............ ... i 11
IMP HEID oo 12
JMP Documentation Library . ......... ... 12
Additional Resources for Learning JMP ............. ... ... . o o oo 18
Tutorials . ... 18
Sample Data Tables. . ... ... 18
Learn about Statistical and JSL Terms ... ...ttt it 19
Learn JMP Tipsand Tricks. .. ... 19
TOOIPS . . oo 19
JMP User Community ....... ... i 20
Free Online Statistical Thinking Course ............. ... ... ... . i ... 20
New User Welcome Kit ... ... e 20
Statistics Knowledge Portal. . ........ ... .. . . 20
JMP Training . . ..ot 20
JMP Books by USers . . ... 21
The JMP Starter Window . . ... .ot e e e e e 21

Technical Support ... ... 21



Chapter 1

Learn about JMP 11

JSL Syntax Reference Formatting Conventions

Formatting Conventions

The following conventions help you relate written material to information that you see on
your screen:

Sample data table names, column names, pathnames, filenames, file extensions, and
folders appear in Helvetica (or sans-serif online) font.

Code appears in Lucida Sans Typewriter (or monospace online) font.

Code output appears in Lucida Sans Typewriter italic (or monospace italic online) font
and is indented farther than the preceding code.

Helvetica bold formatting (or bold sans-serif online) indicates items that you select to
complete a task:

— buttons

— check boxes

— commands

— list names that are selectable

— menus

— options

— tab names

— text boxes

The following items appear in italics:
— words or phrases that are important or have definitions specific to JMP
— book titles

— variables

Features that are for JMP Pro only are noted with the JMP Pro icon f’NEO . For an overview
of JMP Pro features, visit https://www.jmp.com/software/pro.

Note: Special information and limitations appear within a Note.

Tip: Helpful information appears within a Tip.


https://www.jmp.com/software/pro
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JMP Help

JMP Help in the Help menu enables you to search for information about JMP features,
statistical methods, and the JMP Scripting Language (or JSL). You can open JMP Help in
several ways:

e Search and view JMP Help on Windows by selecting the Help > JMP Help.
* On Windows, press the F1 key to open the Help system in the default browser.

* Get help on a specific part of a data table or report window. Select the Help tool % from
the Tools menu and then click anywhere in a data table or report window to see the Help
for that area.

¢  Within a JMP window, click the Help button.

Note: The JMP Help is available for users with Internet connections. Users without an Internet
connection can search all books in a PDF file by selecting Help > JMP Documentation Library.
See “JMP Documentation Library” on page 12 for more information.

JMP Documentation Library

The Help system content is also available in one PDF file called JMP Documentation Library.
Select Help > JMP Documentation Library to open the file. If you prefer searching individual
PDF files of each document in the JMP library, download the files from
https://www . jmp.com/documentation.

The following table describes the purpose and content of each document in the JMP library.

Document Title Document Purpose Document Content

Discovering JMP If you are not familiar ~ Introduces you to JMP and gets you
with JMP, start here. started creating and analyzing data. Also

learn how to share your results.

Using JMP Learn about JMP data Covers general JMP concepts and
tables and how to features that span across all of JMP,
perform basic including importing data, modifying
operations. columns properties, sorting data, and

connecting to SAS.


https://www.jmp.com/documentation
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Document Title

Basic Analysis

Essential Graphing

Profilers

Document Purpose

Perform basic analysis
using this document.

Find the ideal graph
for your data.

Learn how to use
interactive profiling
tools, which enable you
to view cross-sections
of any response
surface.

Learn about JMP
JMP Documentation Library

Document Content
Describes these Analyze menu platforms:

¢ Distribution
e FitYbyX

e Tabulate

* Text Explorer

Covers how to perform bivariate,
one-way ANOVA, and contingency
analyses through Analyze > Fit Y by X.
How to approximate sampling
distributions using bootstrapping and
how to perform parametric resampling
with the Simulate platform are also
included.

Describes these Graph menu platforms:

® Graph Builder
¢ Scatterplot 3D
e Contour Plot

e Bubble Plot

e Parallel Plot

e Cell Plot

® Scatterplot Matrix
¢ Ternary Plot

¢ Treemap

* Chart

e Overlay Plot

The book also covers how to create
background and custom maps.

Covers all profilers listed in the Graph
menu. Analyzing noise factors is
included along with running simulations
using random inputs.
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Document Title Document Purpose Document Content
Design of Learn how to design Covers all topics in the DOE menu.
Experiments Guide experiments and

determine appropriate
sample sizes.

Fitting Linear Models Learn about Fit Model =~ Describes these personalities, all
platform and many of  available within the Analyze menu Fit
its personalities. Model platform:

e Standard Least Squares
* Stepwise

* Generalized Regression
* Mixed Model

¢ MANOVA

¢ Loglinear Variance

¢ Nominal Logistic

* Ordinal Logistic

e Generalized Linear Model
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Document Title

Predictive and
Specialized Modeling

Document Purpose

Learn about additional
modeling techniques.

Learn about JMP 15
JMP Documentation Library

Document Content

Describes these Analyze > Predictive
Modeling menu platforms:

* Neural

e Partition

¢ Bootstrap Forest

* DBoosted Tree

* K Nearest Neighbors

¢ Naive Bayes

* Support Vector Machines
* Model Comparison

* Make Validation Column

¢ Formula Depot

Describes these Analyze > Specialized
Modeling menu platforms:

¢ Fit Curve

¢ Nonlinear

* Functional Data Explorer
¢ Gaussian Process

e Time Series

¢ Matched Pairs

Describes these Analyze > Screening
menu platforms:

* Modeling Utilities

* Response Screening
® Process Screening

* Predictor Screening
* Association Analysis

* Process History Explorer
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Document Title Document Purpose

Multivariate Read about techniques

Methods for analyzing several
variables
simultaneously.

Quality and Process ~ Read about tools for
Methods evaluating and
improving processes.

Chapter 1
JSL Syntax Reference

Document Content

Describes these Analyze > Multivariate
Methods menu platforms:

e Multivariate

® Principal Components

¢ Discriminant

e Partial Least Squares

* Multiple Correspondence Analysis
* Structural Equation Models

¢ Factor Analysis

* Multidimensional Scaling

e Item Analysis

Describes these Analyze > Clustering
menu platforms:

e Hierarchical Cluster
¢ K Means Cluster

¢ Normal Mixtures

e Latent Class Analysis

e (Cluster Variables

Describes these Analyze > Quality and
Process menu platforms:

e Control Chart Builder and individual
control charts

¢ Measurement Systems Analysis
* Variability / Attribute Gauge Charts
* Process Capability

e Model Driven Multivariate Control
Chart

e TPareto Plot
¢ Diagram

* Manage Spec Limits
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Document Title

Reliability and
Survival Methods

Consumer Research

Scripting Guide

JSL Syntax Reference

Document Purpose

Learn to evaluate and
improve reliability in a
product or system and
analyze survival data
for people and
products.

Learn about methods
for studying consumer
preferences and using
that insight to create
better products and
services.

Learn about taking
advantage of the
powerful JMP
Scripting Language
(JSL).

Read about many JSL
functions on functions
and their arguments,
and messages that you
send to objects and
display boxes.

Learn about JMP 17
JMP Documentation Library

Document Content

Describes these Analyze > Reliability and
Survival menu platforms:

Life Distribution
e FitLifeby X
¢ Cumulative Damage
® Recurrence Analysis
* Degradation
® Destructive Degradation
* Reliability Forecast
* Reliability Growth
* Reliability Block Diagram
* Repairable Systems Simulation
* Survival
e Fit Parametric Survival

¢ Fit Proportional Hazards

Describes these Analyze > Consumer
Research menu platforms:

e Categorical

e Choice
e  MaxDiff
e Uplift

* Multiple Factor Analysis

Covers a variety of topics, such as writing
and debugging scripts, manipulating
data tables, constructing display boxes,
and creating JMP applications.

Includes syntax, examples, and notes for
JSL commands.
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Additional Resources for Learning JMP

In addition to reading JMP help, you can also learn about JMP using the following resources:

e “Tutorials”

e “Sample Data Tables”

e “Learn about Statistical and JSL Terms”
e “Learn JMP Tips and Tricks”

e  “Tooltips”

e “JMP User Community”

* “Free Online Statistical Thinking Course”
e “New User Welcome Kit”

* “Statistics Knowledge Portal”

e “JMP Training”

e “JMP Books by Users”

e “The JMP Starter Window”

Tutorials
You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu
is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, start with the Beginners Tutorial. It steps you through the JMP
interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment
and comparing a sample mean to a constant.

Sample Data Tables
All of the examples in the JMP documentation suite use sample data. Select Help > Sample
Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories,
select Help > Sample Data.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\UJMP\15\Samples\Data
On macQOS: \Library\Application Support\dJMP\15\Samples\Data
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In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching
Resources section. To learn more about the teaching resources, visit https://jmp.com/tools.

Learn about Statistical and JSL Terms

The Help menu contains the following indexes:
Statistics Index Provides definitions of statistical terms.

Scripting Index Lets you search for information about JSL functions, objects, and display
boxes. You can also edit and run sample scripts from the Scripting Index and get help on
the commands.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for
using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select
Help > Tip of the Day. Or, you can turn it off using the Preferences window.

Tooltips

JMP provides descriptive tooltips (or hover labels) when you place your cursor over items, such
as the following:

¢ Menu or toolbar options

¢ Labels in graphs

* Text results in the report window (move your cursor in a circle to reveal)
¢ Files or windows in the Home Window

* Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences >
General and then deselect Show menu tips. This option is not available on macOS.


https://jmp.com/tools
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JMP User Community

The JMP User Community provides a range of options to help you learn more about J]MP and
connect with other JMP users. The learning library of one-page guides, tutorials, and demos is
a good place to start. And you can continue your education by registering for a variety of JMP
training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts,
and social networking groups.

To access JMP resources on the website, select Help > JMP User Community or visit
https://community.jmp.com.

Free Online Statistical Thinking Course

Learn practical statistical skills in this free online course on topics such as exploratory data
analysis, quality methods, and correlation and regression. The course consists of short videos,
demonstrations, exercises, and more. Visit https://www jmp.com/statisticalthinking.

New User Welcome Kit

The New User Welcome Kit is designed to help you quickly get comfortable with the basics of
JMP. You’'ll complete its thirty short demo videos and activities, build your confidence in
using the software, and connect with the largest online community of JMP users in the world.
Visit https://www.jmp.com/welcome.

Statistics Knowledge Portal

The Statistics Knowledge Portal combines concise statistical explanations with illuminating
examples and graphics to help visitors establish a firm foundation upon which to build
statistical skills. Visit https://www.jmp.com/skp.

JMP Training

SAS offers training on a variety of topics led by a seasoned team of JMP experts. Public
courses, live web courses, and on-site courses are available. You might also choose the online
e-learning subscription to learn at your convenience. Visit https://www.jmp.com/training.


https://community.jmp.com
https://www.jmp.com/statisticalthinking
https://www.jmp.com/welcome
https://www.jmp.com/skp
https://www.jmp.com/training
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JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP
website. Visit https://www.jmp.com/books.

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data
analysis. Options are categorized and described, and you launch them by clicking a button.
The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and
File menus. The window also lists JMP Pro features and platforms.

e To open the JMP Starter window, select View (Window on macOS) > JMP Starter.

e To display the JMP Starter automatically when you open JMP on Windows, select File >
Preferences > General, and then select JMP Starter from the Initial JMP Window list. On
macQOS, select JMP > Preferences > Initial JMP Starter Window.

Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP,
many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at https://www.jmp.com/support, including the
technical support phone number.


https://www.jmp.com/books
https://www.jmp.com/support
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JSL Functions

Summary of Functions, Operators, and Messages

This topic provides abbreviated descriptions for many of JMP’s functions, operators, and
general object messages. For complete information about functions, see the JMP Scripting
Index. In JMP, select Help > Scripting Index.

For information about platform messages, see the Scripting Platforms chapter in the Scripting
Guide.
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Assignment Functions

JSL also provides operators for in-place arithmetic, or assignment operators. These operations
are all done in place, meaning that the result of the operation is assigned to the first argument.
The most basic assignment operator is the = operator (or the equivalent function Assign). For
example, if a is 3 and you do a+=4, then a becomes 7.

The first argument to an assignment function must be something capable of being assigned
(an L-value). You cannot do something like 3+=4, because 3 is just a value and cannot be
reassigned. However, you can do something like a+=4, because 4 is a variable whose value you

can set.
Add To(a, b)
a+=b

Description

Adds a and b and places the sum into a.
Returns

The sum.
Arguments

a Must be a variable.

b Can be a variable, a list of variables, a number, or a matrix.
Notes

The first argument must be a variable or list of variables, because its value must be able to
accept a value change. A number as the first argument produces an error.

For Add To(Q): Only two arguments are permitted. If one or no argument is specified, Add
To() returns a missing value. Any arguments after the first two are ignored.

For a+=b: More than two arguments can be strung together. JMP evaluates pairs from right
to left, and each sum is placed in the left-hand variable. All arguments except the last must
be a variable.

Example
a+=b+=c

JMP adds b and c and places the sum into b. Then JMP adds a and b and places the sum
into a.

See Also

The Data Structures chapter in the Scripting Guide.
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Assign(a, b)
a=b
Description
Places the value of binto a.
Returns
The new value of a.
Arguments
a Must be a variable.
b Can be a variable, number, or matrix.
Notes

amust be a variable, because it must be able to accept a value change. A number as the first
argument produces an error. If bis some sort of expression, it’s evaluated first and the
result is placed into a.

Divide To(a, b)
a/=b
Description
Divides aby b and places the result into a.
Returns
The quotient.
Arguments
a Must be a variable.
b Can be a variable, number, or matrix.
See Also

The Data Structures chapter in the Scripting Guide.

Multiply To(a, b)
a*=b
Description
Multiplies a and b and places the product into a.
Returns
The product.
Arguments
a Must be a variable.

b Can be a variable, number, or matrix.
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Notes

The first argument must be a variable, because its value must be able to accept a value
change. A number as the first argument produces an error.

For Multiply To(Q: Only two arguments are permitted. If one or no argument is specified,
Multiply To(Q) returns a missing value. Any arguments after the first two are ignored.

For a*=b: More than two arguments can be strung together. JMP evaluates pairs from right
to left, and each product is placed in the left-hand variable. All arguments except the last
must be a variable.

Example
a*=b*=c
JMP multiplies b and c and places the product into b. Then JMP multiplies a and b and
places the product into a.
See Also

The Data Structures chapter in the Scripting Guide.

PostDecrement(a)
a--
Description
Post-decrement. Subtracts 1 from a and places the difference into a.
Returns
a-1
Argument
a Must be a variable.
Notes

If a-- or Post Decrement(a) is inside another expression, the expression is evaluated first,
and then the decrement operation is performed. This expression is mostly used for loop

control.
PostIncrement(a)
a++
Description

Post-increment. Adds 1 to a and places the sum into a.
Returns

a+l
Argument

a Must be a variable.
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Notes

If a++ or PostIncrement(a) is inside another expression, the expression is evaluated first,
and then the increment operation is performed. Mostly used for loop control.

Subtract To(a, b)
a-=b
Description
Subtracts b from a and places the difference into a.
Returns
The difference.
Arguments
a Must be a variable.
b Can be a variable, number, or matrix.
Notes

The first argument must be a variable, because its value must be able to accept a value
change. A number as the first argument produces an error.

For SubtractTo(): Only two arguments are permitted. If fewer than two or more than two
arguments is specified, SubtractTo() returns a missing value.

For a-=b: More than two arguments can be strung together. JMP evaluates pairs from right
to left, and each difference is placed in the left-hand variable. All arguments except the last
must be a variable.

Example
a-=b-=c
JMP subtracts ¢ from b and places the difference into b. Then JMP subtracts b from a and
places the difference into a.
See Also

The Data Structures chapter in the Scripting Guide.

Character Functions

Most character functions take character arguments and return character strings, although
some take numeric arguments or return numeric data. Arguments that are literal character
strings must be enclosed in quotation marks.

The Types of Data chapter in the Scripting Guide provides more information about some of the
functions.
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BLOB To Char(blob, <encoding>)

Description
Reinterpret binary data as a Unicode string.

Returns
A string.

Arguments
blob A binary large object.
encoding (Optional) A quoted string that specifies an encoding. The default encoding for

the character string is utf-8. utf-161e, utf-16be, us-ascii, is0-8859-1, ascii~hex,
shift-jis, and euc-jp are also supported.

Notes
The optional argument ascii is intended to make conversions of blobs containing normal

ASCII data simpler when the data might contain CR, LF, or TAB characters (for example)
and those characters do not need any special attention.

BLOB To Matrix(blob, type, bytes, endian, <nCols>)
Description

Creates a matrix by converting each byte in the bTob to numbers.
Returns

A matrix that represents the blob.
Arguments

blob A blob or reference to a blob.

type A quoted string that contains the named type of number. The options are "int",
"uint", or "float".

bytes Byte size of the data in the blob. Options are 1, 2, 4, or 8.

endian A quoted string that contains a named type that indicates whether the first byte is
the most significant. Options are as follows:

"big" indicates that the first byte is the most significant.
"Tittle" indicates that the first byte is the least significant.
— "native" indicates that the machine’s native format should be used.

<nCol1s> The number of columns in the matrix. The default value is 1.

Char(x, <width>, <decimal>, < <<Use Locale(Boolean)>)
Description

Converts an expression or numeric value into a character string.
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Returns
A string.
Arguments

X an expression or a numeric value. An expression must be quoted with Expr().
Otherwise, its evaluated value is converted to a string.

width (Optional) A number that sets the maximum number of characters in the string.

decimal (Optional) A number that sets the maximum number of places after the decimal
that is included in the string.
Use Locale(Boolean) (Optional) Preserves locale-specific numeric formatting.
Note

The width argument overrides the decimal argument.

Example
Char( PiQ, 10, 4
"3.1416"

Char(C PiQ, 3, 4
"3.1"

Char To BLOB("string", <"encoding">)
Description
Converts a string of characters into a binary (blob).
Returns
A binary object.
Arguments
string Quoted string or a reference to a string.

encoding (Optional) A quoted string that specifies an encoding. The default encoding for
the blob is utf-8. utf-161e, utf-16be, us-ascii, is0-8859-1, ascii~hex, shift-jis,
and euc-jp are also supported.

Notes

Converting BLOBS into printable format escapes \ (in additionto ~ " ! and characters
outside of the printable ASCII range) into hex notation (~5C for the backslash character).
X = Char To BLOB( "abc\def\!n" );

y = BLOB To Char( x, encoding = "ASCII~HEX" );
If(

y == "abc~5Cdef~0A", "IMP 12.2 and later behavior",
y == "abc\def~0A", "Pre-JMP 12.2 behavior"

);
"JMP 12.2 and Tlater behavior" // output
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Char To Hex(value, <"integer"|encoding="enc">)

Hex(value, <"integer"|encoding="enc"|Base(nhum)|Pad To(number)>)
Description

Returns the hexadecimal (or other base number system) text corresponding to the given
value and encoding, which can be a number a string or a blob. If the value is a number,
IEEE 754 64-bit encoding is used unless one of the optional arguments, integer, or base, is
provided.

Arguments
value Any number, quoted string, or blob.
integer (Optional) A switch that causes the value to be interpreted as an integer.

encoding (Optional) A quoted string that specifies an encoding. The default encoding is
utf-8. utf-161e, utf-16be, us-ascii, 1s0-8859-1, ascii~hex, shift-jis, and euc-jp
are also supported.

base(number) (Optional) An integer value between 2 and 36 inclusive. If base is specified,
the function returns the text corresponding to the specified number in that base number
system instead of hexadecimal.

pad to(number) (Optional) A value to specify the padded width of the hex output.

Collapse Whitespace("text")
Description

Trims leading and trailing whitespace and replaces interior whitespace with a single space.
That is, if more than one white space character is present, the Col1apse Whitespace
function replaces the two spaces with one space.

Returns
A quoted string.
Arguments

text A quoted string.

Concat(a, b)
Concat(A, B)
allb
Al|B
Description
For strings: Appends the string b to the string a. Neither argument is changed.
For lists: Appends the list b to the list a. Neither argument is changed.

For matrices: Horizontal concatenation of two matrices, A and B.
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Returns
For strings: A string composed of the string a directly followed by the string b.
For lists: A list composed of the list a directly followed by the list b.
For matrices: A matrix.

Arguments
Two or more strings, string variables, lists, or matrices.
Notes

More than two arguments can be strung together. Each additional string is appended to the
end, in left to right order. Each additional matrix is appended in left to right order.

Example
a="Hello"; b=""; c="World"; a || b || c;
"Hello World"
d = {"apples", "bananas"}; e = {"peaches", "pears"}; Concat( d, e );

{"apples", "bananas", "peaches", "pears'}
A=1[123]; B=1[45 6]; Concat( A, B );
[123456]

Concat Items

See “Concat Items({string1, string?2, ...}, <delimiter>})” on page 164.

Concat To(a, b)
Concat To(a, b)

all=b
Al |=B
Description
For strings: Appends the string b to the string a and places the new concatenated string into
a
For matrices: Appends the matrix b to the matrix a and places the new concatenated matrix
into a.
For lists: Appends the list b to the list and places the new concatenated list into a.
Returns
For strings: A string composed of the string a directly followed by the string b.
For matrices: A matrix.
For lists: A list composed of the list a directly followed by the list b.
Arguments

Two or more strings, string variables, matrices, or lists. The first variable must be a variable
whose value can be changed.
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Notes

More than two arguments can be strung together. Each additional string, matrix, or list is
appended to the end, in left to right order.

Example
a = "Hello"; b=""; c = "World"; Concat To( a, b, c ); Show( a );

a = "Hello World"

=[12 3]; B=1[45 6]; Concat To( A, B ); Show( A );

A=[123456];

d = {"apples", "bananas"}; e = {"peaches", "pears"}; Concat to(d,e); Show( d
)
d

= {"apples", "bananas", '"peaches', "pears"};

Contains(whole, part, <start>)
Description
Determines whether part is contained within whoTe.
Returns

If partis found: For lists, strings, and namespaces, the numeric position where the first
occurrence of part is located. For associative arrays, 1.

If partis not found, 0 is returned in all cases.
Arguments
whole A string, list, namespace, or associative array.
part For a string or namespace, a string that can be part of the string whoTe. For a list, an

item that can be an item in the list whoTe. For an associative array, a key that can be one
of the keys in the map whoTe.

start (Optional) A numeric argument that specifies a starting point. within whoTe. If
startis negative, contains searches whole for part backwards, beginning with the
position specified by the length of whole — start. Note that startis meaningless for
associative arrays and is ignored.

Example
nameList={"Katie", "Louise", "Jane", "Jaclyn"};
r = Contains(nameList, "Katie");

The example returns a 1 because “Katie” is the first item in the list.

Contains Item(x, <item | {Tist} | pattern>, <delimiter>)

Description

Identifies multiple responses by searching for the specified item, list, pattern, or delimiter.
The function can be used on columns with the Multiple Response modeling type or column

property.
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Returns

Returns a Boolean that indicates whether the word (item), one of a list of words (1ist), or
pattern (pattern) matches one of the words in the text represented by x. Words are
delimited by the characters in the optional delimiter (deTimiter) string. A comma, ",",

character is the default delimiter. Blanks are trimmed from the ends of each extracted word
from the input text string (x).

Example

The following example searches for “pots” followed by a comma and then outputs the

result.

x = "Franklin Garden Supply is a leading online store featuring garden decor,
statues, pots, shovels, benches, and much more.";

b = Contains Item( x, "pots", "," );

If( b,
Write( "The specified items were found." ), Write( "No match." )

);

The specified items were found.

Ends With("string", substring)
Description
Determines whether substring appears at the end of string.
Returns
1 if string ends with substring, otherwise 0.
Arguments
string A quoted string or a string variable. Can also be a list.

substring A quoted string or a string variable. Can also be a list.
Equivalent Expression
Right("string", Length(substring)) == substring

Hex(value, <"integer"|encoding="enc"|Base(number)|Pad To(number)>)

See “Char To Hex(value, <"integer" | encoding="enc">)" on page 31.

Hex To BLOB("string™)
Description

Converts the quoted hexadecimal string (including whitespace characters) to a blob
(binary large object).
Example
Hex To BLOB( "4A4D50" );
Char To BLOB("IMP", "ascii~hex'")
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Hex To Char("string", <encoding>)
Description
Converts the quoted hexadecimal string to its character equivalent.
Example
Hex To Char( "30" ) results in “0”.
Notes

The default encoding for character string is utf-8. utf-161e, utf-16be, us-ascii,
150-8859-1, ascii~hex, shift-jis, and euc-jp are also supported.

Hex To Number("string", <Base(number)>)
Description
Returns the number corresponding to the hexadecimal (or other base number system) text.
Arguments
string A quoted hexadecimal string.

base(number) (Optional) An integer value between 2 and 36 inclusive. If base is specified,
the text is treated as a string representing the number in that base.

Example
Hex To Number( "80" );
128

Note

16-digit hexadecimal numbers are converted as IEEE 754 64-bit floating point numbers.
Otherwise, the input is treated as a hexadecimal integer.

Whitespace between bytes (or pairs of digits) and in the middle of bytes is permitted (for
example, FF 1919 and F F1919).

Insert

See “Insert(source, item, <position>)" on page 164.

Insert Into

See “Insert Into(source, item, <position>)” on page 165.

Item(n|[first last], string, <delimiter>, <Unmatched(result string)>,
<Include Boundary Delimiters(Boolean)>)
Description
Returns the nth item or the span from the first to last item of the stringaccording to the
quoted string delimiters given. If you include a fourth argument, any and all characters
in that argument are taken to be delimiters.
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Arguments
n The position of the word being extracted.
[first last] A matrix that defines the beginning and end word range to return.
string The string that is evaluated.

deTimiter (Optional) The character used as a boundary. If de1imiter is absent, an ASCII
space is used. If delim1iter is the empty string, each character is treated as a separate
word. If delimiter is an empty string, each character is treated as a separate word.

Unmatched(result string) The string to print if no match is found.

Include Boundary Delimiters(Boolean) (Optional) Includes the delimiters in the
returned string.

Example

In Item(), consecutive delimiters are treated as though they have a word between them. In
this example, the delimiters are a comma and a space.
Item( 4,"the quick, brown fox"™, ", " ); // quick is preceded by two spaces

The expression is processed as follows:

the<delim[space]><word2><delim[space]>quick<delim[comma]><word
4><delim[space]>brown<delim[space]>fox

Because word4 is empty, this expression returns an empty string.

Item() is the same as Word() except that ITtem() treats each delimiter character as a
separate delimiter, and Word() treats several adjacent delimiters as a single delimiter.

Word( 4,"the quick, brown fox", ", " ); // quick is preceded by two spaces
This expression is processed as follows:
the<delim[2 spaces]>quick<delim[comma + space]>brown<delim[space]>fox

It returns "fox".

Left("string"™, n, <filler>)
Left({1list}, n, <filler>)

Description
Returns a truncated or padded version of the original stringor 1ist. The result contains
the left n characters or list items, padded with any f777er on the right if the length of
stringis less than n.

Length("string")
Description

Returns the length of the given string (in characters), list (in items), associative array (in
number of keys), BLOB (in bytes), matrix (in elements), namespace (in number of functions
and variables), or class (in number of methods, functions, and variables).
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Lowercase("string")
Description

Converts any upper case character found in quoted string to the equivalent lowercase
character.

Matrix to BLOB(matrix, type, bytesEach, endian)

Description

Makes a BLOB from a matrix by converting the matrix elements to 1-byte, 2-byte, or 4-byte
signed or unsigned integers or 4-byte or 8-byte floating point numbers.

Argument
matrix The matrix.
type The type of BLOB: int, uint, or float.

bytesEach The number of bytes in each int, uint, or float. Integers can be 1, 2, or 4 bytes
each, and floats can be 4 or 8 bytes each.

endian The endian-ness of your system: big (the first byte is most significant), little (the
first byte is the least significant), or native (the machine’s native format).

Munger("string", offset, find|length)
Munger("string", offset, find, replace)
Description

Computes new character strings from the quoted stringby inserting or deleting
characters. It can also produce substrings, calculate indexes, and perform other tasks
depending on how you specify its arguments.

Offsetis a numeric expression indicating the starting position to search in the string. If the
offset is greater than the position of the first instance of the find argument, the first
instance is disregarded. If the of fset is greater than the search string’s length, Munger uses
the string’s length as the offset.

Num("string™)
Description

Converts a character string into a number.

Regex("source", "pattern", (<replacementString>, <GLOBALREPLACE>),
<format>, <IGNORECASE>)

Description
Searches for the pattern within the source string.
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Returns

The matched text as a string or numeric missing if there was no match.
Arguments

source A quoted string.

pattern A quoted regular expression.

format (Optional) A backreference to the capturing group. The default is \0, which is the
entire matched string. \n returns the nth match.

IGNORECASE (Optional) The search is case sensitive, unless you specify IGNORECASE.

GLOBALREPLACE (Optional) A replacement string. Applies the regular expression to the
source string repeatedly until all matches are found.

Remove

See “Remove(source, position, <n>)" on page 166.

Remove From

See “Remove From(source, position, <n>)" on page 167.

Repeat(source, a)
Repeat(matrix, a, b)
Description

Returns a copy of source concatenated with itself a times. Or returns a matrix composed of
arow repeats and b column repeats. The source can be text, a matrix, or a list.

Reverse

See “Reverse(source)” on page 167.

Reverse Into

See “Reverse Into(source)” on page 167.

Right("string", n, <Filler>)
Right({Tist}, n, <Filler>)
Description

Returns a truncated or padded version of the original stringor 1ist. The result contains
the right n characters or list items, padded with any f777er on the left if the length of
stringis less than n.
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Shift

See “Shift(source, <n>)" on page 167.

Shift Into

See “Shift Into(source, <n>)" on page 168.

Starts With("string", "substring")
Description
Determines whether substring appears at the start of string.
Returns
1if string starts with substring, otherwise 0.
Arguments
string A quoted string or a reference to one. Can also be a list.
substring A quoted string or a reference to one. Can also be a list.

Equivalent Expression
Left("string", Length("substring™)) = = "substring"

Substitute

"on non

See “Substitute("string", "substring", "replacementString", ...)” on page 168.

Substitute Into

See “Substitute Into("'string", substring, replacementString, ...)” on page 169.

Substr("string", start, Tength)

Description

Extracts the characters that are the portion of the first argument beginning at the position

39

given by the second argument and ending based on the number of characters specified in
the third argument. The first argument can be a character column or value, or an expression

evaluating to same. The starting argument and the length argument can be numbers or

expressions that evaluate to numbers.
Example
This example extracts the first name:
Substr( "Katie Layman", 1, 5 );

The function starts at position 1, reads through position 5, and ignores the remaining
characters, which yields “Katie.”
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Text Score(text column, text-to-number, <weighting>, <{support vectors}>,
<text explorer setup>)

Description
Used to create scoring formulas in Text Explorer. Not supported for use with the Stem for
Combining option.
Returns
Returns a vector of scores.
Arguments
text column The data table column.
text-to-number An associative array that maps lowercase words to numbers.

weighting "Binary", "Ternary", "Count", "LogCount"”, "LCA", or an arrray of inverse
document frequency weights for TFLogIDF. "Count" is the default value.

support vectors A list of vectors that are used in the text scoring. The number and
length of the vectors depends on the weighting argument.

text explorer setup An expression that contains a block of Text Explorer setup
information.

Titlecase("text")

Description

Converts the string to title case, that is, each word in the string has an initial uppercase
character and subsequent lowercase characters.

Returns
A quoted string.
Arguments
text A quoted string.
Example
For example, the following function:
Titlecase( "veronica Tayman ')

returns the following string:
"Veronica Layman"

Trim("text",<left|right|both>)
Trim Whitespace("text",<left|right|both>)

Description

Removes leading and trailing whitespace.
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Results
A quoted string.
Arguments

text A quoted string.

Teft|right|both (Optional) The second argument determines if whitespace is removed
from the left, the right, or both ends of the string. If no second argument is used,
whitespace is removed from both ends.

Example

For example, the following command:

Trim(C " John ", both )
returns the following string:
"John"

Uppercase("string")
Description

Converts any lower case character found in the quoted string to the equivalent uppercase
character.

Word(n| [first Tast], string, <delimiter>, <Unmatched(result string)>)
Description

Returns the nth item of the string, where words are sub-strings separated by any number of
any characters in the delimiter argument.

Arguments
n The position of the word being extracted.
[first last] A matrix that defines the beginning and end word range to return.
string The string that is evaluated.
delimiter (Optional) The character used as a boundary. If delim1iteris absent, an ASCII

space is used. If de1imiteris the empty string, each character is treated as a separate
word. If delimiter is an empty string, each character is treated as a spate word.

Unmatched(result string) The string to print if no match is found.
Examples
This example returns the last name:
Word( 2, "Katie Layman" );
Note

See “Item(n | [first last], string, <deTimiter>, <Unmatched(result string)>, <Include
Boundary Delimiters(Boolean)>)” on page 35 for examples of how Word() differs from
ItemQ).
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Words

See “Words("string", <delimiter>)” on page 169.

XPath

Query( xml, "xpath_expression)

Description
Runs an XPath expression on an XML document.

Returns
A list.

Arguments
xm1 A valid XML document.

xpath_expression A quoted XPath 1.0 expression.
Example

Suppose that you created a report of test results in JMP and exported important details to
an XML document. The test results are enclosed in <result> tags.

The following example stores the XML document in a variable. The XPath Query
expression parses the XML to find the text nodes inside the <result> tags. The results are
returned in a list.

rpt =

"\[<?xml version="1.0" encoding="utf-8"7>

<IMP><report><title>Production Report</title>

<result>November 21st: Pass</result>

<result>November 22nd: Fail</result>

<note>Tests ran at 3:00 a.m.</note></report>

</IMP> 1\";

results = XPath Query( rpt, "//result/textQ" );

{"November 21st: Pass", "November 22nd: Fail'}

Character Pattern Functions

See the Types of Data chapter in the Scripting Guide for more detailed information on
constructing and using pattern matching expressions.

Pat Abort()

Description

Constructs a pattern that immediately stops the pattern match. The matcher does not back
up and retry any alternatives. Conditional assignments are not made. Immediate
assignments that were already made are kept.
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Returns
0 when a match is stopped.
Argument

none

Pat Altern(patternl, <pattern 2, ...>)
Description
Constructs a pattern that matches any one of the pattern arguments.
Returns
A pattern.
Argument

One or more patterns.

Pat Any("string™)
Description
Constructs a pattern that matches a single character in the argument.
Returns
A pattern.
Argument

string astring.

Pat Arb(

Description

Constructs a pattern that matches an arbitrary string. It initially matches the null string. It
then matches one additional character each time the pattern matcher backs into it.
Returns
A pattern.
Argument
none
Example
p = "the beginning" + Pat Arb() >? stuffInTheMiddle + "the end";
Pat Match( "in the beginning of the story, and not near the end, there are
three bears", p );

Show( stuffInTheMiddle );
stuffInTheMiddle = " of the story, and not near "
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Pat Arb No(pattern)
Description
Constructs a pattern that matches zero or more copies of pattern.
Returns
A pattern.
Argument
pattern a pattern to match against.

Example

adjectives = "large" | "medium" | "small" | "warm" | "cold" | "hot" | "sweet";
rc = Pat Match( "I would Tike a medium hot, sweet tea please",
Pat Arbno( adjectives | Pat Any(", ") ) >> adj +
("tea" | "coffee" | "milk"™) );
Show( rc, adj );
rc = 1;
adj ="

",

medium hot, sweet ";

Pat At(varName)
Description

Constructs a pattern that matches the null string and stores the current position in the
source string into the specified JSL variable (varName). The assignment is immediate, and
the variable can be used with expr() to affect the remainder of the match.

Returns
A pattern.
Argument
varName the name of a variable to store the result in.

Example

p=":"+ Pat At( TlistStart ) + Expr(
If( 1listStart == 1,
Pat Immediate( Pat Len( 3 ), early ),
Pat Immediate( Pat Len( 2 ), late )
)
s
early = "";
Tate = "";
Pat Match( ":123456789", p );
Show( early, late );
early = "";
Tate = "";
Pat Match( " :123456789", p );
Show( early, late );
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First this is produced:

early = "123"
7ate = mnr

and later this:

mnmn

early =
late = "12"

Pat Break("string")

Description
Constructs a pattern that matches zero or more characters that are not in its argument; it
stops or breaks on a character in its argument. It fails if a character in its argument is not
found (in particular, it fails to match if it finds the end of the source string without finding a
break character).

Returns
A pattern.

Argument

string astring.

Pat Concat(patternl, pattern2 <pattern 3, ...>)
Patternl + Pattern2 +
Description
Constructs a pattern that matches each pattern argument in turn.
Returns
A pattern.
Argument

Two or more patterns.

Pat Conditional(pattern, varName)

Description
Saves the result of the pattern match, if it succeeds, to a variable named as the second
argument (varName) after the match is finished.

Returns
A pattern.

Arguments
pattern a pattern to match against.

varName the name of a variable to store the result in.
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Example
type = "undefined";
rc = Pat Match(
"green apples",
Pat Conditional( "red" | "green", type ) +
);
Show( rc, type );
rc = 1;
type =

apples"”

ngr,eenn;

Pat Fail(Q)

Description

Constructs a pattern that fails whenever the matcher attempts to move forward through it.
The matcher backs up and tries different alternatives. If and when there are no alternatives
left, the match fails and Pat Match returns 0.

Returns
0 when a match fails.
Argument

none

Pat Fence()
Description

Constructs a pattern that succeeds and matches the null string when the matcher moves
forward through it, but fails when the matcher tries to back up through it. It is a one-way
trap door that can be used to optimize some matches.

Returns
1 when the match succeeds, 0 otherwise.
Argument

none

Pat Immediate(pattern, varName)

Description

Saves the result of the pattern match to a variable named as the second argument (varName)
immediately.

Returns
A pattern.

Arguments

pattern a pattern to match against.
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varName the name of a variable to store the result in.

Example
type = "undefined";
rc = Pat Match(
"green apples",

1]

("red" | "green") >> type + " pears"
s
Show( rc, type );

rc =0

type = "green"

Even though the match failed, the immediate assignment was made.

Pat Len(int)
Description
Constructs a pattern that matches n characters.
Returns
A pattern.
Argument

int an integer that specifies the number of characters.

Pat Look Ahead(pattern, Boolean)
Description
A zero-width pattern match after the current position.
Arguments
pattern the pattern.

Boolean 0 (the default) indicates a match. 1 designates a negative match or non-match.

Pat Look Behind(pattern, Boolean)
Description
A zero-width pattern match before the current position.
Arguments
pattern the pattern.

Boolean O (the default) indicates a match. 1 designates a negative match or non-match.
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Pat Match(SourceText, Pattern, <ReplacementText>, <NULL>, <ANCHOR>,
<MATCHCASE>, <FULLSCAN>)

Description

Pat Match executes the Pattern against the SourceText. The pattern must be constructed
first, either inline or by assigning it to a JSL variable elsewhere.

Returns
1 if the pattern is found, 0 otherwise.
Arguments
SourceText A string or string variable that contains the text to be searched.
Pattern A pattern or pattern variable that contains the text to be searched for.
ReplacementText Optional string that defines text to replace the pattern in the source text.

NULL A placeholder for the third argument if ANCHOR, MATCHCASE, or FULLSCAN
are necessary and there is no replacement text.

ANCHOR Optional command to start the pattern match to the beginning of the string. The
following match fails because the pattern, “cream”, is not found at the beginning of the
string:

Pat Match( "coffee with cream and sugar", "cream", NULL, ANCHOR );

MATCHCASE Optional command to consider capitalization in the match. By default, Pat

Match () is case insensitive.
FULLSCAN Optional command to force Pat Match to try all alternatives, which uses more

memory as the match expands. By default, Pat Match() does not use FULLSCAN, and
makes some assumptions that allow the recursion to stop and the match to succeed.

Pat Not Any("string")
Description
Constructs a pattern that matches a single character that is not in the argument.
Returns
A pattern.
Argument

string astring.

Pat Pos(int)
Description

Constructs patterns that match the null string if the current position is 7nt from the left end
of the string, and fail otherwise.
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Returns
A pattern.
Argument

int an integer that specifies a position in a string.

Pat R

Pos(int)
Description

Constructs patterns that match the null string if the current position is 7nt from the right
end of the string, and fails otherwise.

Returns
A pattern.
Argument

int an integer that specifies a position in a string.

Pat R

Tab(int)

Description
Constructs a pattern that matches up to position n from the end of the string. It can match 0
or more characters. It fails if it would have to move backwards or beyond the end of the
string.

Returns
A pattern.

Argument

int an integer that specifies a position in a string.

Pat Regex("string")

Description

Constructs a pattern that matches the regular expression in the quoted string argument.
Returns

A pattern.
Argument

string astring.

Pat Rem()

Description

Constructs a pattern that matches the remainder of the string. It is equivalent to Pat R
Tab(0).
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Returns
A pattern.

Argument
none

Pat Repeat(pattern, minimum, maximum, GREEDY|RELUCTANT)
Description
Matches patternbetween minimumand maximumtimes.
Returns
A pattern.
Arguments
pattern a pattern to match against.
minimum An integer that must be smaller than maximum.
maximum An integer that must be greater than minimum.

GREEDY |RELUCTANT If GREEDY is specified, it tries the maximum first and works back to the

minimum. If RELUCTANT is specified, it tries the minimum first and works up to the
maximum.

Notes
Pat Arbno(p) is the same as Pat Repeat(p, 0, infinity, RELUCTANT)
Pat Repeat(p) is the same as Pat Repeat(p, 1, infinity, GREEDY)
Pat Repeat(p, n) is the same as Pat Repeat(p, n, infinity, GREEDY)
Pat Repeat(p, n, m) isthe same as Pat Repeat(p, n, m, GREEDY)

Pat Span("string")
Description

Constructs a pattern that matches one or more (not zero) occurrences of characters in its

argument. It is greedy; it always matches the longest possible string. It fails rather than
matching zero characters.

Returns
A pattern.
Argument

string astring.

Pat String("string")
Description

Constructs a pattern that matches its string argument.
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Returns
A pattern.
Argument

string astring.

Pat Succeed()

Description

Constructs a pattern that always succeeds, even when the matcher backs into it. It matches
the null string.

Returns
1 when the match succeeds.

Argument
none

Pat Tab(int)

Description
Constructs a pattern that matches forward to position 7nt in the source string. It can match
0 or more characters. It fails if it would have to move backwards or beyond the end of the
string.

Returns
A pattern.

Argument

int aninteger that specifies a position in a string.

Pat Test(expr)
Description

Constructs a pattern that succeeds and matches the null string if expr is not zero and fails
otherwise.

Returns

A pattern.
Argument

expr An expression.
Note

Usually the argument is wrapped with expr() because the test needs to be made on the
current value of variables set by Pat Immediate, Pat Conditional, and Pat At. Without
expr, the test is based on values that were known when the pattern was constructed, which
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means the test always succeeds or always fails at pattern execution time, which is probably

not what you want.

Example
nCats = 0;
whichCat = 3;
string = "catch a catnapping cat in a catsup factory";
rc = Pat Match(
string,
"cat" + Pat Test(
Expr(
nCats = nCats + 1;
nCats == whichCat;
)
) ’
"dog"
J;
Show( rc, string, nCats );
rc =1
string = "catch a catnapping dog in a catsup factory"
nCats = 3

Regex Match(source, pattern, <replacement>|<MATCHCASE>, <NULL>)

Description
Executes the pattern match in pattern against the quoted source string.
Returns
A pattern.
Required Arguments
source a string.
pattern a pattern.
Optional Arguments
replacement The string that specifies the text to replace the source with.
MATCHCASE The search is case insensitive unless you specify MATCHCASE.
NULL Indicates that the expression contains MATCHCASE but you don’t want to specify a
replacement.

Examples
Regex Match(
"person=Fred id=77 friend= favorite=tea", // source
"AwH)=AS*) QAwH)=(\S*) Qw+H)=(\S*) Qw+)=(\S*)" // pattern
J;
{"person=Fred id=77 friend= favorite=tea", "person", "Fred", "id", "77",
"friend", "", "favorite", "tea"}
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// case-insensitive, no replacement

Regex Match( "beliEve", "([aeioul)(.*?)A\L)" );
{"eliE", "e", "1i", "E"}

// case-sensitive, no replacement

Regex Match( "beliEve", "([aeioul)(.*?)(\D)", NULL, MATCHCASE );
{"eliEve", "e", "TiEv", "e"}

Comment Functions

// comment
Description
Comments to end of line.
Notes

Everything after the // is ignored when running the script.

/* comment */
Description
A comment that can appear in the middle of a line of script.
Notes

Anything between the beginning tag /* and the end tag */ is ignored when running the
script. This comment style can be used almost anywhere, even inside lists of arguments. If
you place a comment inside a double-quoted string, the comment is treated merely as part
of the string and not a comment. You cannot place comments in the middle of operators.

Examples
+/*comment* /=
1 /*comment*/name
are invalid and produce errors. The first comment interrupts += and the second interrupts
:name.
sums = {(a+b /*comment*/), /*comment*/ (cA2)}

is valid JSL; the comments are both ignored.

/]!
Description

If placed on the first line of a script, this comment line causes the script to be run when
opened in JMP without opening into the script editor window.
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Notes

You can over-ride this comment when opening the file. Select File > Open. Hold the Ctrl key
while you select the JSL file and click Open. Or right-click the file in the Home Window
Recent Files list and select Edit Script. The script opens into a script window instead of
being executed.

/*debug step*/

/*debug run*/

Description
If placed on the first line of a script, the script is opened into the debugger when it is run.
Notes

All letters must be lower case. There must be one space between debug and step or run, and
there must be no other spaces present. Only one of these lines can be used, and it must be
the first line of the script; a first line that is blank followed by this comment negates the
debug command.

Comparison Functions

The comparison operators (<, <=, >, >=) work for numbers, strings, and matrices. For matrices,
they produce a matrix of results. If you compare mixed arguments, such as strings with
numbers or matrices, the result is a missing value. Comparisons involving lists are not
allowed and also return missing values.

The equality operators (== and !=) work for numbers, strings, matrices, and lists. For matrices,
they produce a matrix of results; for lists, they produce a single result. If you test equality of
mixed results (for example. strings with numbers or matrices) the result is 0 or unequal.

Range check operators let you check whether something falls between two specified values:

a=1;
Show( 1 <= a < 3 );
b =2;
Show( 2 < b <= 3 );
l<=a<3=1;
2<b<=3=0;

Expressions with comparison operators are evaluated all at once, not in sequence

All the comparison operators are eliding operators. That means JMP treats arguments joined by
comparison operators as one big clause, as opposed to the way most expressions are evaluated
one operator at a time. Evaluating as a single clause produces different results than the more

usual method of evaluating in pieces. For example, the following two statements are different:
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12 < a < 13;
(12 < a) < 13;

The first statement checks whether a is between 12 and 13, because all three arguments and
both operators are read and evaluated together. The second statement uses parentheses to
regroup the operations explicitly to evaluate from left to right, which would be the normal
way to evaluate most expressions. Thus it first checks whether 12 is less than 4, returning 1 if
true or 0 if false. Then it checks whether the result is less than 13, which is always true because
0 and 1 are both less than 13.

All the comparison operators are elided when they are used in matched pairs or in the
unmatched pairs <... <= and <=... <. What this means is that if you want a comparison
statement to be evaluated one comparison operator at a time, you should use parentheses ()
to control the order of operations explicitly.

Equal(a, b, ...)
Description
Compares all the listed values and tests if they are all equal to each other.
Returns
1 (true) if all arguments evaluate to the same value.
0 (false) otherwise.

Arguments
Two or more variables, references, matrices, or numbers.

Notes

If more than two arguments are specified, a 1 is returned only if all arguments are exactly
the same. This is typically used in conditional statements and to control loops.

The comparison is case-sensitive for string comparisons.

Greater(a, b, ...)
a>b>. ..
Description
Compares all the list values and tests if, in each pair, the left value is greater than the right.

Returns
1 (true) if a evaluates strictly greater than b (and b evaluates strictly greater than ¢, and so
on).
0 (false) otherwise.

Arguments
Two or more variables, references, matrices, or numbers.
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Notes
If more than two arguments are specified, a 1 is returned only if each argument is greater
than the one that follows it. This is typically used in conditional statements and to control
loops.
Greater, Less, GreaterOrEqual, and LessOrEqual can also be strung together. If you do not
group with parentheses, JMP evaluates each pair left to right. You can also use parentheses
to explicitly tell JMP how to evaluate the expression.

Greater or Equal(a, b, ...)
a>=b>=...
Description
Compares all the list values and tests if, in each pair, the left value is greater than or equal to
the right.
Returns

1 (true) if a evaluates strictly greater than or equal to b (and b evaluates strictly greater than
or equal to ¢, and so on).

0 (false) otherwise.
Arguments
Two or more variables, references, matrices, or numbers.
Notes

If more than two arguments are specified, a 1 is returned only if each argument is greater
than or equal to the one that follows it. This is typically used in conditional statements and
to control loops.

Greater, Less, GreaterOrEqual, and LessOrEqual can also be strung together. If you do not
group with parentheses, JMP evaluates each pair left to right. You can also use parentheses
to explicitly tell JMP how to evaluate the expression.

Is Missing(expr)
Description

Returns 1 if the expression yields a missing value and 0 otherwise.

Less(a, b, ...)
a<b<...
Description
Compares all the list values and tests if, in each pair, the left value is less than the right.
Returns
1 (true) if a evaluates strictly less than b (and b evaluates strictly less than ¢, and so on).
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0 (false) otherwise.
Arguments
Two or more variables, references, matrices, or numbers.
Notes
If more than two arguments are specified, a 1 is returned only if each argument is less than
the one that follows it. This is typically used in conditional statements and to control loops.

Greater, Less, GreaterOrEqual, and LessOrEqual can also be strung together. If you do not
group with parentheses, JMP evaluates each pair left to right. You can also use parentheses
to explicitly tell JMP how to evaluate the expression.

Less LessEqual(a, b, c, ...)
a<b<=c<=...
Description
Range check, exclusive below and inclusive above.
Returns
1 (true) if bis greater than a and less than or equal to c.
0 (false) otherwise.
Arguments
a, b, c variables, references, matrices, or numbers.
Notes

Returns 1 when two conditions are met: the first argument is less than the second
argument, and each remaining argument is less than or equal to its argument on the right.
This is typically used in conditional statements and to control loops.

Less or Equal(a, b, ...)
a<=b<=...
Description
Compares all the list values and tests if, in each pair, the left value is less than or equal to
the right.
Returns

1 (true) if a evaluates strictly less than or equal to b (and b evaluates strictly less than or
equal to ¢, and so on).

0 (false) otherwise.

Arguments
Two or more variables, references, matrices, or numbers.
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Notes
If more than two arguments are specified, a 1 is returned only if each argument is less than
or equal to the one that follows it. This is typically used in conditional statements and to
control loops.
Greater, Less, GreaterOrEqual, and LessOrEqual can also be strung together. If you do not
group with parentheses, JMP evaluates each pair left to right. You can also use parentheses
to explicitly tell JMP how to evaluate the expression.

LessEqual Less(a, b, c, ...)
a<=b<c<...
Description

Range check, inclusive below and exclusive above.

Returns
1 (true) if bis greater than or equal to a and less than c.

0 (false) otherwise.

Arguments
a, b, c variables, references, matrices, or numbers.

Notes
Returns 1 when two conditions are met: the first argument is less than or equal to the
second argument, and each remaining argument is less than its argument on the right. This
is typically used in conditional statements and to control loops.

Not Equal(a, b)
al=b
Description
Compares a and b and tests if they are equal.

Returns
0 (false) if a and b evaluate to the same value.

1 (true) otherwise.

Argument
a, b Any variable or number.

Notes
Mostly used for conditional statements and loop control.
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Conditional and Logical Functions

And(a, b)
a&b
Description
Logical And.
Returns

1 (true) if both a and b are true.
0 (false) if either a or bis false or if both a and b are false.

Missing if either a or b is a missing value or if both a and b are missing values.

Arguments
Two or more variables or expressions.

Notes

More than two arguments can be strung together. a&b returns 1 (true) only if all arguments
evaluate to true.

AndMZ(a, b)

a:&b

Description

Returns the logical AND of all arguments. Missing values are treated as zeroes.
Returns

1 (true) if both a and b are true.

0 (false) if either a or bis false or if both a and b are false.

0 (false) if either a or b is a missing value or if both a and b are missing values.

Arguments
Two or more variables or expressions.

Notes

More than two arguments can be strung together. a:&b returns 1 (true) only if all arguments
evaluate to true.

Break ()

Description

Stops execution of a loop completely and continues to the statement following the loop.
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Note

Break works with For and While loops, and also with For Each Row.

Choose(expr, rl1, r2, r3, ..., rElse)
Description

Evaluates expr. If the value of expris 1, r1is returned;if 2, the value of r2is returned, and
so on. If no matches are found, the last argument (rE7se) is returned.

Returns

The value whose index in the list of arguments matches expr, or the value of the last
argument.

Arguments
expr an expression or a value.

rl, r2, r3, ... anexpression or a value.

Continue()
Description
Ends the current iteration of a loop and begins the loop at the next iteration.
Note
Continue works with For and While loops, and also with For Each Row.

For(init, while, increment, body)
Description

Repeats the statement(s) in the body as long as the whi1e condition is true. Initand
increment control iterations.

Returns
Null
Arguments
init Initialization of loop control counter.

while Condition for loop to continue or end. As long as the conditional statement while is
true, the loop is iterated one more time. As soon as while is false, the loop is exited.

increment Increments (or decrements) the loop counter after while is evaluated every
time the loop is executed.

body Any number of valid JSL expressions, glued together if there are more than one.

Example
mysum = 0; myprod = 1;
For( i =1, i <= 10, i++, mysum += i; myprod *= 1i; );

Show( mysum, myprod );
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mysum = 55;
myprod = 3628800;

For Each Row(<dt,> script)

Description
Repeats the script on each row of the data table.

Returns
Null

Argument
dt Optional positional argument: a reference to a data table. If this argument is not in the

form of an assignment, then it is considered a data table expression.

script Any valid JSL expressions.

Example
The following example creates data table references and then iterates over each row in Big
Class.jmp. If the value of age in a row is greater than 15, the age is printed to the log.

dt = Open( "$SAMPLE_DATA/Big Class.jmp" );
For Each Row( dt, If( :age > 15, Show( :age ) ) );

If(conditionl, resultl, <condition2, result2,> ..., <elseResult>)
Description

Evaluates the first of each pair of arguments and returns the evaluation of the result
expression associated with the first condit7on argument that evaluates to a nonzero result.
The condition arguments are evaluated in order. If all of the condition arguments
evaluate to zero, the optional eTseResultis evaluated and the result is returned. If no
elseResultis specified, and none of the conditions are true, a missing value is returned. If
all of the condition arguments evaluate to missing, a missing value is returned.

IfMax(exprl, resultl, expr2, result2, ... <all missing result>)
Description

Evaluates the first of each pair of arguments and returns the evaluation of the result
expression (the second of each pair) associated with the maximum of the expressions. If
more than one expression is the maximum, the first maximum is returned. If all expressions
are missing and a final result is not specified, missing is returned. If all expressions are
missing and a final result is specified, that final result is returned. The test expressions must
evaluate to numeric values, but the result expressions can be anything.

Returns

The result expression associated with the maximum of the expressions
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IfMin(exprl, resultl, expr2, result2, ... <all missing result>)
Description

Evaluates the first of each pair of arguments and returns the evaluation of the result
expression (the second of each pair) associated with the minimum of the expressions. If
more than one expression is the minimum, the first minimum is returned. If all expressions
are missing and a final result is not specified, missing is returned. If all expressions are
missing and a final result is specified, that final result is returned. The test expressions must
evaluate to numeric values, but the result expressions can be anything.

Returns

The result expression associated with the minimum of the expressions

IfMZ(conditionl, resultl, <condition2, result2,> ..., <elseResult>)

Description
Evaluates the first of each pair of arguments and returns the evaluation of the result
expression associated with the first condit7on argument that evaluates to a nonzero result.
The condition arguments are evaluated in order. If all of the condition arguments
evaluate to zero or missing, the optional eTseResuTt is evaluated and the result is
returned. If no elseResult is specified, and none of the conditions are true, a missing
value is returned.

Notes
The test arguments are evaluated in order until the first nonzero result. If all test results
return zero or missing, the eJseExpr argument is evaluated.

IfMZ() is equivalent to If() where missing values for evaluated condition arguments are
treated as zero.

Interpolate(x, x1, yl, x2, y2)
Interpolate(x, xmatrix, ymatrix)

Description

Linearly interpolates the y-value corresponding to a given x-value between two points (x1,
y1), and (x2, y2) or by matrices xmatrix and ymatrix. The points must be in ascending
order.

Is Associative Array(name)

Description

Returns 1 if the evaluated argument is an associative array, or 0 otherwise.
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Is
Is
Is

Empty(global)

Empty(dt)

Empty(col)
Description

Returns 1 if the global variable, data table, or data column is undefined or holds the
Empty() value, or 0 otherwise.

Is

Expr(x)
Description

Returns 1 if the evaluated argument is an expression, or 0 otherwise.

Is

List

See “Is List(x)” on page 165.

Is

Name (x)
Description

Returns 1 if the evaluated argument is a name, or 0 otherwise.

Is

Namespace (namespace)

Description

Returns 1 if the namespace argument is a namespace; returns 0 otherwise.

Is

Number (x)
Description

Returns 1 if the evaluated argument is a number or missing numeric value, or 0 otherwise.

Is

Scriptable(x)

Description

Returns 1 if the evaluated argument is a scriptable object, or 0 otherwise.

Is

String(x)
Description

Returns 1 if the evaluated argument is a string, or 0 otherwise.
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Match(x, valuel, resultl, value2, result2, ..., resultElse)
Description

If ais equal to valuel, then resultlis returned. If ais equal to value2, result2is
returned, and so on.

Note

The Match() function explicitly checks to see if the compare expression x is missing and if
the value of valuelis missing, then it returns the value of resultl; otherwise it continues
to compare the expression x to each valueN value in each valueN/resultN pair, ignoring
any missing values. If the expression x is equal to any of the vaTueN value, then the
corresponding resulTtN value is returned. If no matching valueN value is found, then the
resultElse value is returned.

MatchMZ(x, valuel, exprl, value2, expr2, ..., exprElse)
Description

Evaluates and returns the exprN argument that equals x or evaluates and returns the
exprETlse argument if no value equals x.

Note

The MatchMZ () function works the same as the Match() function except that missing values
are treated as 0.

Not(a)
fa
Description
Logical Not.
Returns
0 (false) if a>0.
1 (true) if a<=0.
Missing value if a is missing.
Argument
a Any variable or number. The variable must have a numeric or matrix value.
Notes

Mostly used for conditional statements and loop control.
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Or(a, b)
alb
Description
Logical Or.
Returns

1 (true) if either of or both a and b are true.
0 (false) otherwise.
Missing if either are missing.
Arguments
a, b Any variable or number.
Notes

Mostly used for conditional statements and loop control.

OrMZ(a, b)
a:|b
Description

Returns the logical OR of all arguments with missing values treated as zeroes: 1 if any
arguments are nonzero and 0 otherwise.

Returns
1 (true) if either of or both a and b are true.
0 (false) otherwise.

Arguments
a, b Any variable or number.

Notes

Mostly used for conditional statements and loop control. When opening a JMP 3 data table,
this function is automatically used for any Or function.

0r(Q) returns missing if any evaluated argument is missing. OrMZ() returns 0 if any
evaluated argument is missing.

Return(<Exprl>, <Expr2>, ..., <ExprN>)
Description
Returns an expression value from a user-defined function.
Example

This example returns the evaluation of both expressions in the Return() function as a list.
The Return() function can have more than one argument. If only one is present, then the
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value of the expression is returned. If more than one is present, then the values of all the
expressions is returned in a list.
f = Function( {a, b},
Return( a - b, a + b )
);
{lo, hi} = fC 10, 1 );
Show( 1o, hi );
Show( fC 7, 15 ) );

Tlo = 9;
hi = 11;
f(7, 15) = {-8, 22};

Note

Return() not enclosed by a function, method, or recursive function call causes an error.

Step(x0, x1, yl, x2, y2, ...)
Step(x0, [x1, x2, ...]1, [yl, y2, ...1)
Description

Returns the y argument corresponding to the largest x argument that is less than or equal to
x0. The x points must be specified in ascending order.

StopQ)

Description

Immediately stops a script that is running.

WhiTe(expr, body)
Description

Repeatedly tests the expr condition and executes the body until the expr condition is no
longer true.

Zero Or Missing(expr)
Description

Returns 1 if expryields a missing value or zero, 0 otherwise.

Constant Functions

JMP provides functions for two useful constant functions.

Note: These functions do not take an argument, but the parentheses are required.
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e

Description
Returns the constant ¢, which is 2.7182818284590451...

PiQO
Description
Returns the constant ©t, which is 3.1415926535897931...

Date and Time Functions

Datetime values are handled internally as numbers of seconds since midnight, January 1,
1904.

The expression x=01Jan1904 sets x to zero, since the indicated date is the base date or “zero
date” in JMP. If you examine the values of dates, they should be appropriately large numbers
(for example, 50ct1998 is 2990390400).

Abbrev Date(date)
Description
Converts the provided date to a string.
Returns
A string representation of the date.
Argument

date Can be the number of seconds since the base date (midnight, January 1, 1904), or any
date-time operator.

Example
Abbrev Date( 29Feb2004 );
02/29/2004

See Also

The Types of Data chapter in the Scripting Guide.

As Date(x)
Description

Formats the number or expression x so that it shows as a date or duration when displayed
in a text window. Values that represent one year or more are returned as dates. Values that
represent less than a year are returned as durations.
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Returns

A date that is calculated from the number or expression provided.
Argument

x Number or expression.
See Also

The Types of Data chapter in the Scripting Guide.

Date Difference(datetimel, datetime2, "interval_name", <"alignment">)
Description
Returns the difference in intervals of two date-time values.
Returns
A number.
Arguments
datetimel, datetime2 Datetime values.

interval_name A quoted string that contains a date-time interval, such as "Month",
"Day", or "Hour".

alignment An optional string. Options are as follows:
"start" includes full or partial intervals.
— "actual" counts only whole intervals.

"fractional" returns fractional differences using averages for "Year", "Quarter", and
"Month" intervals.

Date DMY(day, month, year)
Description
Constructs a date value from the arguments.
Returns
The specified date, expressed as the number of seconds since midnight, 1 January 1904.
Arguments

day number, day of month, 1-31. Note that there is no error-checking, so you can enter
February 31.

month number of month, 1-12.

year number of year.

Date Increment(datetime, "interval_name", <increment>, <"alignment'">)
Description

Adds 1 or more intervals to a starting datetime value.
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Returns
Returns the new datetime value.

Arguments

datetime The starting datetime value.

interval_name A quoted string that contains the name of a datetime interval. "Year",
"Quarter", "Month", "Week", "Day", "Hour", "Minute", and "Second" are supported.

increment An optional number that specifies the number of intervals. The default value is
1.

alignment An optional quoted string that contains a keyword:

"start" truncates the date to the nearest interval prior to adding the increment. For
example, it removes the time and outputs the date. "start" is the default value.

— "actual" retains the full input datetime value.

— "fractional" allows fractional incremental values using averages for the duration of

"Year", "Quarter", and "Month" intervals.

Date MDY(month, day, year)
Description
Constructs a date value from the arguments.
Returns
The specified date, expressed as the number of seconds since midnight, 1 January 1904.
Arguments
month number of month, 1-12.

day number, day of month, 1-31. Note that there is no error-checking, so you can enter
February 31.

year number of year.

Day(datetime)
Description
Determine the day of the month supplied by the datetime argument.
Returns
Returns an integer representation for the day of the month of the date supplied.
Arguments

datetime Number of seconds since midnight, 1 January 1904. This can also be an
expression.

Example
dl = Date DMY( 12, 2, 2003 );
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3127852800

Day( 3127852800 );
12

Day( d1 );
12

Day Of Week(datetime)
Description
Determine the day of the week supplied by the datetime argument.
Returns
Returns an integer representation for the day of the week of the date supplied.

Arguments

datetime Number of seconds since midnight, 1 January 1904. This can also be an
expression.

Day Of Year(datetime)
Description
Determine the day of the year supplied by the datetime argument.
Returns
Returns an integer representation for the day of the year of the date supplied.
Arguments

datetime Number of seconds since midnight, 1 January 1904. This can also be an
expression.



Chapter 2 JSL Functions 71
JSL Syntax Reference Date and Time Functions

Format(x, width|<width, decimal places>, <"Use thousands separator">)
Format(x, "Best", <width>, <"Use thousands separator">)

Format(x, ("Fixed Dec"|"Percent"), width|<width, decimal places>, <"Use
thousands separator"s)

Format(x, "Pvalue", <width>)

Format(x, ("Scientific"|"Engineering"|"Engineering SI"), <width>]|<width,
decimal places>)

Format(x,"Precision", width|<width, decimal places>, <"Use thousands
separator">, <"Keep trailing zeroes">, <"Keep all whole digits">)

Format(x, "Currency", <"currency code">, <width>|<width, decimal places>,
<"Use thousands separator">, < <<Use Locale(0|1) >)

Format(x, "datetime", <width>)

Format(x, ("Latitude DDD"|"Latitude DDM"|"Latitude DMS"|"Longitude
DDD" |"Longitude DDM"|"Longitude DDM"), width|<width, decimal places>,
("PUN"|"DIR"|"PUNDIR"))

Format(x, "Custom", Formula(), <width>)
Description
Converts the value x into the "format" that you specify in the subsequent arguments.
Returns
Returns the text that corresponds to the number in the specified format.
Arguments

See The Column Info Window chapter in Using JMP for more information about the
arguments. The arguments are also shown in the data table Column Info window.

Examples
Format( x, 10, 2, "Use thousands separator');
Format( x, "Currency", "EUR", 20, <<Use Locale(0)); // ignores computer locale

Format( x, "m/d/y", 10 );

Format( x, "Precision", 10, 2, "Keep trailing zeroes", "Keep all whole digits"
s

Format( x, "Latitude DDD", "PUNDIR"); // "PUN" for punctuation, "DIR" for
direction, PUNDIR for both

Format( x, "Custom", Formula( Abs( value ) ), 15 );

Notes

¢ For more information about formatting currency, see the Types of Data chapter in the
Scripting Guide.

* You must always precede the number of decimal places with the width.
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Format Date(x, "datetime", <width>)
Description

Converts the value of x into the "datetime" that you specify in the second argument.
Format choices are those shown in the data table Column Info window.

Returns
Returns the number in the specified format.
Arguments

See The Column Info Window chapter in Using JMP for more information about the
arguments.

Example
Format Date( Today(), "yyyQq" );

Hour(datetime, <12]|24>)
Description
Determines the hour supplied by the datetime argument.
Returns
Returns an integer representation for the hour part of the date-time value supplied.
Arguments

datetime Number of seconds since midnight, 1 January 1904. This can also be an
expression.

12|24 Changes the mode to 12 hours (with am and pm). The default is 24-hour mode.

HP Time()
Description

Returns a high precision time value (in microseconds). This function is only useful relative
to another HP Time() value. The time value represents the number of microseconds since
the start of the JMP session.

Note

For less precise time values use Tick SecondsQ).

In Days(n)
Description

Returns the number of seconds per n days. Divide by this function to express seconds as
days.
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Informat("string", "format")
Parse Date("string", "format")

Description

Parses a stringof a given "format" and returns a date/time value. The value is expressed
as if surrounded by the As Date() function, returning the date in "ddMonyyyy" format.

Example
Informat( "07152000", "MMDDYYYY" );
15Jul12000
Notes

¢ To see the format options, open the Column Info window in a data table, select a date/time
value for the format, and view the Input Format list.

* See the Types of Data chapter in the Scripting Guide for more examples.
® See “As Date(x)” on page 67.

In Hours(n)

Description

Returns the number of seconds per nhours. Divide by this function to express seconds as
hours.

In Minutes(n)
Description

Returns the number of seconds per n minutes. Divide by this function to express seconds as
minutes.

In Weeks(n)

Description

Returns the number of seconds per n weeks. Divide by this function to express seconds as
weeks.

In Years(n)
Description

Returns the number of seconds per n years. Divide by this function to express seconds as
years.
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Long Date(date)
Description

Returns a locale-specific string representation for the date supplied, formatted like
"Sunday, February 29, 2004" or "Wednesday, November 9, 2011".

MDYHMS (date)

Description

Returns a string representation for the date supplied, formatted like "2/29/04 00:02:20".

Minute(datetime)
Description
Determines the minute supplied by the datetime argument, 0-59.
Returns

Returns an integer representation for the minute part of the date-time value supplied.

Month(date)
Description

Returns an integer representation for the month of the date supplied.

Parse Date()

See “Informat("string", "format")” on page 73.

Quarter(datetime)
Description

Returns the annual quarter of a datetime value as an integer 1-4.

Second(datetime)
Description
Determines the second supplied by the datetime argument.
Returns
Returns an integer representation for the second part of the date-time value supplied.
Argument

datetime Number of seconds since midnight, 1 January 1904. This can also be an
expression.
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Short Date(date)
Description

Returns a string representation for the date supplied, in the format mm/dd/yy. For
example, "2/29/04" for the next Leap Day.

Tick Seconds()
Description
Measures the time taken for a script to run, measured down to the 60th of a second.
Note

For higher time value resolution (for example, microseconds) use the HP Time() function.

Time Of Day(datetime)

Description

Returns an integer representation for the time of day of the datetime supplied.

Today ()
Description

Returns the current date and time expressed as the number of seconds since midnight, 1
January 1904. No arguments are available, but the parentheses are still necessary.

Week Of Year(date, <rule_m>)

Description
Returns the week of the year that contains a date-time value. Three rules determine when
the first week of the year begins.

— With rule 1 (the default), weeks start on Sunday, with the first Sunday of the year being
week 2. Week 1 is a partial week or empty.

—  With rule 2, the first Sunday begins with week 1, with previous days being week 0.

— With rule 3, the ISO-8601 week number is returned. Weeks start on Monday. Week 1 is
the first week of the year with four days in that year. It is possible for the first or last
three days of the year to belong to the neighboring year’s week number.

Year (date)
Description

Returns an integer representation for the year of date.
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Discrete Probability Functions

Beta Binomial Distribution(k, p, n, delta)

Description
Returns the cumulative distribution function (cdf) of the beta binomial distribution. This is
the probability that a beta binomially distributed random variable is less than or equal to k.
The cdf is calculated as the summation of the beta binomial pmf for values of X from 0 to k.
Arguments
k The count of interest. k must be an integer.
p The probability of success for each trial, which must be between 0 and 1.
n The number of trials, which must be greater than 1.

delta The overdispersion parameter, which must be between Maximum|[-p/(n-p-1),
-(1-p)/(n-2+p)] and 1. When the overdispersion parameter is zero, the distribution
reduces to Binomial(n, p).

Beta Binomial Probability(k, p, n, delta)

Description

Returns the probability mass function (pmf) of the beta binomial distribution. This is the
probability that a beta binomially distributed random variable is equal to k. The pmf is

parameterized as follows:
r(% - 1)1"[k + p(% - 1)}1"[11 k(1 p)(% - 1)}

F[p(é - 1)Jr[(1 - p)(% - 1)Jr(n T % -1)

P(X =kip,n,8) = (Z)

Arguments
k The count of interest. k must be an integer.
p The probability of success for each trial, which must be between 0 and 1.
n The number of trials, which must be greater than 1.
deTta The overdispersion parameter 5, which must be between Maximum[-p/(n-p-1),
-(1-p)/(n-2+p)] and 1. When the overdispersion parameter is zero, the distribution
reduces to Binomial(n, p).
Notes

The beta binomial distribution results from assuming that X|x follows a Binomial(n,7)
distribution and n follows a Beta(p(1-6)/5,(1-p)(1-6)/3) distribution. It is useful when the
data are a combination of several Binomial distributions that each have different
probabilities of success. See the Distributions chapter in Basic Analysis.
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Beta Binomial Quantile(p, n, delta, cumprob)
Description

Returns the smallest integer quantile for which the cumulative probability of the Beta
Binomial(p, n, delta) distribution is larger than or equal to cumprob.

Arguments
p The probability of success for each trial. p must be between 0 and 1.
n The number of trials, which must be greater than 1.

deTta The overdispersion parameter 8, which must be between Maximum[-p/(n-p-1),
-(1-p)/(n-2+p)] and 1. When the overdispersion parameter is zero, the distribution
reduces to Binomial(n, p).

cumprob The cumulative probability of the quantile desired. cumprob must be between 0
and 1.

Binomial Distribution(p, n, k)
Description

Returns the cumulative distribution function (cdf) of the binomial distribution. This is the
probability that a binomially distributed random variable is less than or equal to k. The cdf
is calculated as the summation of the binomial pmf for values of X from 0 to k.

Arguments
p The probability of success for each trial. p must be between 0 and 1.
n The number of trials.

k The number of successes, which must be less than or equal to n.

Binomial Probability(p, n, k)

Description

Returns the probability mass function (pmf) of the binomial distribution. This is the
probability that a binomially distributed variable is equal to k. The pmf is parameterized as
follows:

P(X=kp,n) = (Z)pk(l —p)n_k

Arguments
p The probability of success for each trial. p must be between 0 and 1.
n The number of trials.

k The number of successes, which must be less than or equal to 7.
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Binomial Quantile(p, n, cumprob)
Description

Returns the smallest integer quantile for which the cumulative probability of the
Binomial(p, n) distribution is larger than or equal to cumprob.

Arguments
p The probability of success for each trial. p must be between 0 and 1.
n The number of trials.

cumprob The cumulative probability of the quantile desired. cumprob must be between 0
and 1.

Gamma Poisson Distribution(k, Tambda, sigma)

Description
Returns the cumulative distribution function (cdf) of the gamma-Poisson distribution. This
is the probability that a gamma-Poisson distributed random variable is less than or equal to
k. The cdf is calculated as the summation of the gamma-Poisson pmf for values of X from 0
to k.

Arguments
k The count of interest. k must be an integer.
Tambda The shape parameter A, which much be greater than 0. This is the mean of the

distribution.

sigma The overdispersion parameter o, which must be greater than or equal to 1. When
the overdispersion parameter is 1, the distribution reduces to a Poisson()) distribution.

Gamma Poisson Probability(k, Tambda, sigma)
Description
Returns the probability mass function (pmf) of the gamma-Poisson distribution. This is the

probability that a gamma-Poisson distributed random variable is equal to k. The pmf is
parameterized as follows:

A
P(X =k, 6) = F(k%*l) ‘5‘1)

T(k+ 1)r(ﬁ) °

e

where I'(-) is the Gamma function.
Arguments

k The count of interest. k must be an integer.
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Tambda The shape parameter A, which much be greater than 0. This is the mean of the
distribution.

sigma The overdispersion parameter o, which must be greater than or equal to 1. When
the overdispersion parameter is 1, the distribution reduces to a Poisson(}) distribution.

Notes

The gamma Poisson distribution results from assuming that X |p follows a Poisson(p)
distribution and p follows a Gamma(A/(c-1),6-1) distribution. It is useful when the data are
a combination of several Poisson(u) distributions that each have different values of p. See
the Distributions chapter in Basic Analysis.

Gamma Poisson Quantile(lambda, sigma, cumprob)

Description

Returns the smallest integer quantile for which the cumulative probability of the Gamma
Poisson(lambda, sigma) distribution is larger than or equal to