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Get the Most from JMP

Whether you are a first-time or a long-time user, there is always something to learn about
JMP.

Visit JMP.com to find the following:

* live and recorded webcasts about how to get started with J]MP

* video demos and webcasts of new features and advanced techniques
¢ details on registering for JMP training

¢ schedules for seminars being held in your area

® success stories showing how others use JMP

* ablog with tips, tricks, and stories from JMP staff

e aforum to discuss JMP with other users

https://www.jmp.com/getstarted
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Chapter 1

Learn about JMP

Documentation and Additional Resources

This chapter includes details about JMP documentation, such as book conventions,
descriptions of each JMP document, the Help system, and where to find other support.



10 Learn about JMP Chapter 1

Profilers
Contents

Formatting Conventions ............ ... i 11
IMP HEID oo 12
JMP Documentation Library . ......... ... 12
Additional Resources for Learning JMP ............. ... ... . o o oo 18
Tutorials . ... 18
Sample Data Tables. . ... ... 18
Learn about Statistical and JSL Terms ... ...ttt it 19
Learn JMP Tipsand Tricks. .. ... 19
TOOIPS . . oo 19
JMP User Community ....... ... i 20
Free Online Statistical Thinking Course ............. ... ... ... . i ... 20
New User Welcome Kit ... ... e 20
Statistics Knowledge Portal. . ........ ... .. . . 20
JMP Training . . ..ot 20
JMP Books by USers . . ... 21
The JMP Starter Window . . ... .ot e e e e e 21

Technical Support ... ... 21



Chapter 1
Profilers

Learn about JMP 11
Formatting Conventions

Formatting Conventions

The following conventions help you relate written material to information that you see on
your screen:

Sample data table names, column names, pathnames, filenames, file extensions, and
folders appear in Helvetica (or sans-serif online) font.

Code appears in Lucida Sans Typewriter (or monospace online) font.

Code output appears in Lucida Sans Typewriter italic (or monospace italic online) font
and is indented farther than the preceding code.

Helvetica bold formatting (or bold sans-serif online) indicates items that you select to
complete a task:

— buttons

— check boxes

— commands

— list names that are selectable

— menus

— options

— tab names

— text boxes

The following items appear in italics:
— words or phrases that are important or have definitions specific to JMP
— book titles

— variables

Features that are for JMP Pro only are noted with the JMP Pro icon f’NEO . For an overview
of JMP Pro features, visit https://www.jmp.com/software/pro.

Note: Special information and limitations appear within a Note.

Tip: Helpful information appears within a Tip.


https://www.jmp.com/software/pro

12 Learn about JMP Chapter 1
JMP Help Profilers

JMP Help

JMP Help in the Help menu enables you to search for information about JMP features,
statistical methods, and the JMP Scripting Language (or JSL). You can open JMP Help in
several ways:

e Search and view JMP Help on Windows by selecting the Help > JMP Help.
* On Windows, press the F1 key to open the Help system in the default browser.

* Get help on a specific part of a data table or report window. Select the Help tool % from
the Tools menu and then click anywhere in a data table or report window to see the Help
for that area.

¢  Within a JMP window, click the Help button.

Note: The JMP Help is available for users with Internet connections. Users without an Internet
connection can search all books in a PDF file by selecting Help > JMP Documentation Library.
See “JMP Documentation Library” on page 12 for more information.

JMP Documentation Library

The Help system content is also available in one PDF file called JMP Documentation Library.
Select Help > JMP Documentation Library to open the file. If you prefer searching individual
PDF files of each document in the JMP library, download the files from
https://www . jmp.com/documentation.

The following table describes the purpose and content of each document in the JMP library.

Document Title Document Purpose Document Content

Discovering JMP If you are not familiar ~ Introduces you to JMP and gets you
with JMP, start here. started creating and analyzing data. Also

learn how to share your results.

Using JMP Learn about JMP data Covers general JMP concepts and
tables and how to features that span across all of JMP,
perform basic including importing data, modifying
operations. columns properties, sorting data, and

connecting to SAS.


https://www.jmp.com/documentation
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Document Title Document Purpose Document Content

Basic Analysis Perform basic analysis ~ Describes these Analyze menu platforms:

using this document. e Distribution

e FitYbyX
e Tabulate
* Text Explorer

Covers how to perform bivariate,
one-way ANOVA, and contingency
analyses through Analyze > Fit Y by X.
How to approximate sampling
distributions using bootstrapping and
how to perform parametric resampling
with the Simulate platform are also
included.

Essential Graphing Find the ideal graph

for your data.

Describes these Graph menu platforms:
® Graph Builder

¢ Scatterplot 3D

¢ Contour Plot

e Bubble Plot

e Parallel Plot

e Cell Plot

® Scatterplot Matrix
¢ Ternary Plot

¢ Treemap

e Chart

e Overlay Plot

The book also covers how to create
background and custom maps.

Profilers Learn how to use Covers all profilers listed in the Graph

interactive profiling
tools, which enable you
to view cross-sections
of any response
surface.

menu. Analyzing noise factors is
included along with running simulations
using random inputs.
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Document Title Document Purpose Document Content
Design of Learn how to design Covers all topics in the DOE menu.
Experiments Guide experiments and

determine appropriate
sample sizes.

Fitting Linear Models Learn about Fit Model =~ Describes these personalities, all
platform and many of  available within the Analyze menu Fit
its personalities. Model platform:

e Standard Least Squares
* Stepwise

* Generalized Regression
* Mixed Model

¢ MANOVA

¢ Loglinear Variance

¢ Nominal Logistic

* Ordinal Logistic

e Generalized Linear Model
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Document Title Document Purpose

Predictive and Learn about additional
Specialized Modeling ~ modeling techniques.

Learn about JMP 15
JMP Documentation Library

Document Content

Describes these Analyze > Predictive
Modeling menu platforms:

* Neural

e Partition

¢ Bootstrap Forest

* DBoosted Tree

* K Nearest Neighbors

¢ Naive Bayes

* Support Vector Machines
* Model Comparison

* Make Validation Column

¢ Formula Depot

Describes these Analyze > Specialized
Modeling menu platforms:

¢ Fit Curve

¢ Nonlinear

* Functional Data Explorer
¢ Gaussian Process

e Time Series

¢ Matched Pairs

Describes these Analyze > Screening
menu platforms:

* Modeling Utilities

* Response Screening
® Process Screening

* Predictor Screening
* Association Analysis

* Process History Explorer
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Document Title Document Purpose

Multivariate Read about techniques

Methods for analyzing several
variables
simultaneously.

Quality and Process ~ Read about tools for
Methods evaluating and
improving processes.

Chapter 1
Profilers

Document Content

Describes these Analyze > Multivariate
Methods menu platforms:

e Multivariate

® Principal Components

¢ Discriminant

e Partial Least Squares

* Multiple Correspondence Analysis
* Structural Equation Models

¢ Factor Analysis

* Multidimensional Scaling

e Item Analysis

Describes these Analyze > Clustering
menu platforms:

e Hierarchical Cluster
¢ K Means Cluster

¢ Normal Mixtures

e Latent Class Analysis

e (Cluster Variables

Describes these Analyze > Quality and
Process menu platforms:

e Control Chart Builder and individual
control charts

¢ Measurement Systems Analysis
* Variability / Attribute Gauge Charts
* Process Capability

e Model Driven Multivariate Control
Chart

e TPareto Plot
¢ Diagram

* Manage Spec Limits
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Document Title

Reliability and
Survival Methods

Consumer Research

Scripting Guide

JSL Syntax Reference

Document Purpose

Learn to evaluate and
improve reliability in a
product or system and
analyze survival data
for people and
products.

Learn about methods
for studying consumer
preferences and using
that insight to create
better products and
services.

Learn about taking
advantage of the
powerful JMP
Scripting Language
(JSL).

Read about many JSL
functions on functions
and their arguments,
and messages that you
send to objects and
display boxes.

Learn about JMP 17
JMP Documentation Library

Document Content

Describes these Analyze > Reliability and
Survival menu platforms:

Life Distribution
e FitLifeby X
¢ Cumulative Damage
® Recurrence Analysis
* Degradation
® Destructive Degradation
* Reliability Forecast
* Reliability Growth
* Reliability Block Diagram
* Repairable Systems Simulation
* Survival
e Fit Parametric Survival

¢ Fit Proportional Hazards

Describes these Analyze > Consumer
Research menu platforms:

e Categorical

e Choice
e  MaxDiff
e Uplift

* Multiple Factor Analysis

Covers a variety of topics, such as writing
and debugging scripts, manipulating
data tables, constructing display boxes,
and creating JMP applications.

Includes syntax, examples, and notes for
JSL commands.
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Additional Resources for Learning JMP

In addition to reading JMP help, you can also learn about JMP using the following resources:

e “Tutorials”

e “Sample Data Tables”

e “Learn about Statistical and JSL Terms”
e “Learn JMP Tips and Tricks”

e  “Tooltips”

e “JMP User Community”

* “Free Online Statistical Thinking Course”
e “New User Welcome Kit”

* “Statistics Knowledge Portal”

e “JMP Training”

e “JMP Books by Users”

e “The JMP Starter Window”

Tutorials
You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu
is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, start with the Beginners Tutorial. It steps you through the JMP
interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment
and comparing a sample mean to a constant.

Sample Data Tables
All of the examples in the JMP documentation suite use sample data. Select Help > Sample
Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories,
select Help > Sample Data.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\UJMP\15\Samples\Data
On macQOS: \Library\Application Support\dJMP\15\Samples\Data
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In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching
Resources section. To learn more about the teaching resources, visit https://jmp.com/tools.

Learn about Statistical and JSL Terms

The Help menu contains the following indexes:
Statistics Index Provides definitions of statistical terms.

Scripting Index Lets you search for information about JSL functions, objects, and display
boxes. You can also edit and run sample scripts from the Scripting Index and get help on
the commands.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for
using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select
Help > Tip of the Day. Or, you can turn it off using the Preferences window.

Tooltips

JMP provides descriptive tooltips (or hover labels) when you place your cursor over items, such
as the following:

¢ Menu or toolbar options

¢ Labels in graphs

* Text results in the report window (move your cursor in a circle to reveal)
¢ Files or windows in the Home Window

* Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences >
General and then deselect Show menu tips. This option is not available on macOS.


https://jmp.com/tools
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JMP User Community

The JMP User Community provides a range of options to help you learn more about J]MP and
connect with other JMP users. The learning library of one-page guides, tutorials, and demos is
a good place to start. And you can continue your education by registering for a variety of JMP
training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts,
and social networking groups.

To access JMP resources on the website, select Help > JMP User Community or visit
https://community.jmp.com.

Free Online Statistical Thinking Course

Learn practical statistical skills in this free online course on topics such as exploratory data
analysis, quality methods, and correlation and regression. The course consists of short videos,
demonstrations, exercises, and more. Visit https://www jmp.com/statisticalthinking.

New User Welcome Kit

The New User Welcome Kit is designed to help you quickly get comfortable with the basics of
JMP. You’'ll complete its thirty short demo videos and activities, build your confidence in
using the software, and connect with the largest online community of JMP users in the world.
Visit https://www.jmp.com/welcome.

Statistics Knowledge Portal

The Statistics Knowledge Portal combines concise statistical explanations with illuminating
examples and graphics to help visitors establish a firm foundation upon which to build
statistical skills. Visit https://www.jmp.com/skp.

JMP Training

SAS offers training on a variety of topics led by a seasoned team of JMP experts. Public
courses, live web courses, and on-site courses are available. You might also choose the online
e-learning subscription to learn at your convenience. Visit https://www.jmp.com/training.


https://community.jmp.com
https://www.jmp.com/statisticalthinking
https://www.jmp.com/welcome
https://www.jmp.com/skp
https://www.jmp.com/training
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JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP
website. Visit https://www.jmp.com/books.

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data
analysis. Options are categorized and described, and you launch them by clicking a button.
The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and
File menus. The window also lists JMP Pro features and platforms.

e To open the JMP Starter window, select View (Window on macOS) > JMP Starter.

e To display the JMP Starter automatically when you open JMP on Windows, select File >
Preferences > General, and then select JMP Starter from the Initial JMP Window list. On
macQOS, select JMP > Preferences > Initial JMP Starter Window.

Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP,
many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at https://www.jmp.com/support, including the
technical support phone number.


https://www.jmp.com/books
https://www.jmp.com/support
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Introduction to Profilers
Visualize Response Surfaces and Optimize Processes

Profiling is an approach to visualizing response surfaces by seeing what would happen if you
change just one or two factors at a time. Essentially, a profile is a cross-section view. The
interactive profilers in JMP promote exploring opportunity spaces. In fitting equations to data,
the fitting is only the first step. Interpreting the fit, understanding the fitted response surface,
and finding factor values to optimize the responses is desirable.

Figure 2.1 Examples of Profilers
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Overview of the Profiler Platform

The Prediction Profiler displays profile traces (Figure 2.2) for each X variable. A profile trace is
the predicted response as one variable is changed while the others are held constant at the
current values. The Prediction Profiler recomputes the profiles and predicted responses (in
real time) as you vary the value of an X variable.

The vertical dotted line for each X variable shows its current value or current setting. If the
variable is nominal, the X axis identifies categories.

For each X variable, the value above the factor name is its current value. Change the
current value by clicking in the graph or by dragging the dotted line where you want the
new current value to be.

The horizontal dotted line shows the current predicted value of each Y variable for the
current values of the X variables.

The black lines within the plots show how the predicted value changes when you change
the current value of an individual X variable. In fitting platforms, the 95% confidence

interval for the predicted values is shown by solid blue curves surrounding the prediction
trace (for continuous variables) or the height of an error bar (for categorical variables). For

continuous variables, the confidence interval region is shaded.

The Prediction Profiler is a way of changing one variable at a time and looking at the effect on

the predicted response.

Figure 2.2 Illustration of Traces

current predicted value 4 (= |Prediction Profiler current value of factor,
of response, changes by\ 100 :/changeg by dragging the
dragging a factor value 65.5 gg /dotted line
> [61.8366, i i
£9.1634]
95% confidence interval
on the mean response
current factor values traces, lines, and error
bars show predicted
values

The Prediction Profiler in some situations computes confidence intervals for each profiled
column. If you have saved both a standard error formula and a prediction formula for the
same column, the Prediction Profiler offers to use the standard errors to produce the
confidence intervals rather than profiling them as a separate column.
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Introduction to Profiling

It is easy to visualize a response surface with one input factor X and one output factor Y. It
becomes harder as more factors and responses are added. The profilers in JMP provide a
number of highly interactive cross-sectional views of any response surface. In this guide we
use the following terms interchangeably.

e factor, input variable, X column, independent variable, setting, term

® response, output variable, Y column, dependent variable, outcome

Desirability profiling and optimization features are available to help find good factor settings
and produce desirable responses. Most profilers also incorporate multithreading for faster

computation. Simulation and defect profiling features are available for when you need to
make responses that are robust and high-quality when the factors have variation.

e “Profiler Features in JMP”
e “Profiler Launch Windows”

e “Fit Group”

Profiler Features in JMP

There are several profiler facilities in JMP, accessible from a number of fitting platforms and
the main menu under Graph. They are used to profile data column formulas.

Table 2.1 Profiler Features Summary

Description Features
Prediction Shows vertical slices across each factor, Desirability,
Profiler holding other factors at current values Optimization,

Simulator, Propagation
of Error

Contour Profiler Horizontal slices show contour lines for two Simulator
factors at a time

Surface Profiler  3-D plots of responses for 2 factors at a time, ~ Surface Visualization
or a contour surface plot for 3 factors at a time

Mixture Profiler A contour profiler for mixture factors Ternary Plot and
Contours
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Table 2.1 Profiler Features Summary (Continued)

Description

Custom Profiler A non-graphical profiler and numerical

Introduction to Profilers 27
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Features

General Optimization,

optimizer Simulator
Excel Profiler Visualize models (or formulas) stored in Excel =~ Profile using Excel
worksheets. Models

Profiler availability is shown in Table 2.2. The Custom Profiler is available only through the
Graph menu. (Model Comparison does have Custom Profiler available.)

Table 2.2 Where to Find JMP Profilers

Location

Graph Menu (as a Platform)

Fit Model: Least Squares

Fit Model: Generalized Regression
Fit Model: Mixed Model

Fit Model: Logistic

Fit Model: Loglinear Variance

Fit Model: Generalized Linear Model
Fit Model: Partial Least Squares
Neural

Model Comparison

Nonlinear: Factors and Response
Nonlinear: Parameters and SSE
Nonlinear: Fit Curve

Gaussian Process

Partial Least Squares

Life Distribution

Fit Life by X

Profiler

Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes

Contour
Profiler

Yes
Yes

Yes

Yes
Yes

Yes
Yes
Yes
Yes

Yes

Surface Mixture
Profiler Profiler
Yes Yes
Yes Yes
Yes Yes
Yes

Yes

Yes

Yes Yes
Yes

Yes

Yes

Yes
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Table 2.2 Where to Find JMP Profilers (Continued)

Location Profiler Contour Surface Mixture
Profiler Profiler Profiler

Recurrence Analysis Yes

Choice Yes

Custom Design Prediction Variance Yes Yes

Profiler Launch Windows

When a profiler is invoked as a platform from the Graph menu, rather than through a fitting
platform, you provide columns with formulas as the Y, Prediction Formula columns. These
formulas could have been saved from the fitting platforms.

Figure 2.3 Profiler Launch Window

Explore how the factors affect the response formulas
Select Celumns Cast Selected Columns into Roles Action
~ dABRASION Y, Prediction Formula| | required numeric oKk |
dnobuLus optional numeric
deLoNG @'
AHARDNESS
yige | Noise Factors |
. Moise Factors optional numeric Remove
AsiLaNE | :|
AsULFUR Recall |
dPred Formula ABRASION
: Hel
dPred Formula MODULUS o E'
dPred Formula ELONG ALY Columns must have formulas. Specify Noise
dPred Formula HARDNESS Factors only if you want to study robustness (flatness)
) with respect to transmitted variation from these factors.
[] Expand Intermediate Formulas

For more information about the options in the Select Columns red triangle menu, see the Get
Started chapter in Using JMP.

The columns referenced in the formulas become the X columns (unless the column is also a Y).
Y, Prediction Formula The response columns containing formulas.

Noise Factors Used only in special cases for modeling derivatives. For more information
about noise factors, see “Noise Factors” on page 36.

Expand Intermediate Formulas Tells JMP that if an ingredient column to a formula is itself a
formula column that refers to other columns, to substitute the original columns into the
inner formula. To prevent an ingredient column from expanding, add an Other column
property, name it Expand Formula, and assign a value of 0. See “Expand Intermediate
Formulas”.
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The Surface Plot platform is discussed in the “Surface Plot” chapter on page 95. The Surface
Profiler is very similar to the Surface Plot platform, except Surface Plot has more modes of
operation. Neither the Surface Plot platform nor the Surface Profiler have some of the
capabilities common to other profilers.

Expand Intermediate Formulas

The Profiler launch window has an Expand Intermediate Formulas check box. When this box
is checked, the formula that is being profiled is handled differently. If the profiled formula
contains another formula column that references other columns, then the original columns are
substituted into the inner formula. Therefore, the formula being profiled is profiled with
respect to the original columns instead of the intermediate column references. Expand
Intermediate Formula also expands formula columns that have the Vector modeling type.

For example, when Fit Model fits a logistic regression for two levels (A and B), the end
formulas (Prob[A] and Prob[B]) are functions of the Lin[x] column, which itself is a function of
another column x. If Expand Intermediate Formulas is selected, then when Prob[A] is profiled,
it is with reference to x, not Lin[x].

In addition, using the Expand Intermediate Formulas check box enables the Save Expanded
Formulas command in the platform red triangle menu. This creates a new column with a
formula, which is the formula being profiled as a function of the end columns, not the
intermediate columns.

Fit Group

For the REML and Stepwise personalities of the Fit Model platform, if models are fit to
multiple Y’s, the results are combined into a Fit Group report. This enables the different Y’s to
be profiled in the same Profiler. The Fit Group red triangle menu has options for launching the
joint Profiler. Profilers for the individual Y’s can still be used in the respective Fit Model
reports.

Fit Group reports are also created when a By variable is specified for a Stepwise analysis. This
allows for the separate models to be profiled in the same Profiler.

The Fit Group scripting command can be used to fit models in different platforms, and profile
the individual models in the Profiler. See the Scripting Platforms chapter in the Scripting
Guide.
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Interpret the Profiles

The illustration in Figure 2.4 describes how to use the components of the Prediction Profiler.
There are several important points to note when interpreting a prediction profile:

* The importance of a factor can be assessed to some extent by the steepness of the
prediction trace. If the model has curvature terms (such as squared terms), then the traces
might be curved.

e If you change the value of a factor, the prediction trace for that factor is not affected, but
the prediction traces of all the other factors can change. The Y response line must cross the
intersection points of the prediction traces with their current value lines.

Note: If there are interaction effects or cross-product effects in the model, the prediction traces
can shift their slope and curvature as you change current values of other terms. That is what

interaction is all about. If there are no interaction effects, the traces change only in height, not
slope or shape.

Figure 2.4 Changing One Factor from 0 to 0.75
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Prediction profiles are especially useful in multiple-response models to help judge which
factor values can optimize a complex set of criteria.
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Click a graph or drag the current value line right or left to change the factor’s current value.
The response values change as shown by a horizontal reference line in the body of the graph.
Double-click in an axis to bring up a window that changes its settings.

The Profiler as a Cross-Section

In the following example using Tiretread.jmp, look at the response surface of the expression for
MODULUS as a function of SULFUR and SILANE (holding SILICA constant). Now look at how a
grid that cuts across SILANE at the SULFUR value of 2.25. Note how the slice intersects the
surface. If you transfer that down below, it becomes the profile for SILANE. Similarly, note the
grid across SULFUR at the SILANE value of 50. The intersection when transferred down to the
SULFUR graph becomes the profile for SULFUR.

Figure 2.5 Profiler as a Cross-Section
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Now consider changing the current value of SULFUR from 2.25 to 1.5.
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Figure 2.6 Profiler as a Cross-Section
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In the Prediction Profiler, note the new value just moves along the same curve for SULFUR, the
SULFUR curve itself does not change. But the profile for SILANE is now taken at a different cut
for SULFUR. The profile for SILANE is also a little higher and reaches its peak in the different
place, closer to the current SILANE value of 50.

Set or Lock Factor Values

If you press Alt (Option on macOS) and click in a graph, a window prompts you to enter
specific settings for the factor.

Figure 2.7 Continuous Factor Settings Window
Current Settings for SILANE
Current Value:
Minimum Setting: 3367
Maximum Setting: 66.33
Mumber of Plotted Points:

41
Show

Lock Factor Setting:

wn
=
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For continuous variables, you can specify the following;:

Current Value The value used to calculate displayed values in the profiler, equivalent to the
red vertical line in the graph.

Minimum Setting The minimum value of the factor’s axis.
Maximum Value The maximum value of the factor’s axis.

Number of Plotted Points Specifies the number of points used in plotting the factor’s
prediction traces.

Show Show or hide the factor in the profiler.

Lock Factor Setting Locks the value of the factor at its current setting.

Profiler Platform Options

The Profiler red triangle menu contains the following options:

Profiler Shows or hides the Prediction Profiler.

Contour Profiler Shows or hides the Contour Profiler.

Custom Profiler Shows or hides the Custom Profiler.

Surface Profiler Shows or hides the Surface Profiler.

Mixture Profiler Shows or hides the Mixture Profiler.

Show Formulas Opens a JSL window showing all formulas being profiled.

Formulas for OPTMODEL Creates code for the OPTMODEL SAS procedure. Hold down
Ctrl and Shift and then select Formulas for OPTMODEL from the red triangle menu.

The following options are available in many platforms. See the JMP Reports chapter in Using
JMP.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.
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Common Profiler Topics

e “Linear Constraints”

e “Noise Factors”

Linear Constraints

The Prediction Profiler, Custom Profiler, and Mixture Profiler can incorporate linear
constraints into their operations. Linear constraints can be entered in two ways, described in
the following sections.

Red Triangle Menu ltem

To enter linear constraints via the red triangle menu, select Alter Linear Constraints from either
the Prediction Profiler or Custom Profiler red triangle menu.

Choose Add Constraint from the resulting window, and enter the coefficients into the
appropriate boxes. For example, to enter the constraint p1 + 2*p2 > 0.9, enter the coefficients as
shown in Figure 2.8. As shown, if you are profiling factors from a mixture design, the mixture
constraint is present by default and cannot be modified.

Figure 2.8 Enter Coefficients

Add Constraint|

| 1]p1+] 1]p2 +| 1]p3 |- 1| Mixture Constraint "
|| 1 | o1+ | 5 | 02 + | = | B E"‘@—/ enter coefficients

[ 0K H Cancel H Help |

After you click OK, the Profiler updates the profile traces, and the constraint is incorporated
into subsequent analyses and optimizations.

If you attempt to add a constraint for which there is no feasible solution, a message is written
to the log and the constraint is not added. To delete a constraint, enter zeros for all the
coefficients.

Constraints added in one profiler are not accessible by other profilers until saved. For
example, if constraints are added under the Prediction Profiler, they are not accessible to the
Custom Profiler. To use the constraint, you can either add it under the Custom Profiler red
triangle menu, or use the Save Linear Constraints command described in the next section.
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Constraint Table Property/Script

If you add constraints in one profiler and want to make them accessible by other profilers, use
the Save Linear Constraints command, accessible through the platform red triangle menu. For
example, if you created constraints in the Prediction Profiler, choose Save Linear Constraints
under the Prediction Profiler red triangle menu. The Save Linear Constraints command
creates or alters a Table Script called Constraint. An example of the Table Property is shown in
Figure 2.9.

Figure 2.9 Constraint Table Script

w | Plasticizer PI4 =

Constraint Locked File C\Program Files)

script Design Extreme Vertices | ™ (4l
b Model : 1] 04n4
I Ternary Plot . 2| 0726
T om
The Constraint Table Property is a list of the constraints, and is editable. It is accessible to
other profilers, and negates the need to enter the constraints in other profilers. To view or edit

Constraint, right-click the red triangle menu and select Edit. The content of the constraint from
Figure 2.8 is shown below in Figure 2.10.

Figure 2.10 Example Constraint

Name:|Constraint |[ ok |

Script: {1 * :pl + 2 * :p2 >= 0.9} . E'
Save |
Cancel |

The Constraint Table Script can be created manually by choosing New Script from the red
triangle menu beside a table name.

Note: When creating the Constraint Table Script manually, the spelling must be exactly
“Constraint”. Also, the constraint variables are case sensitive and must match the column
name. For example, in Figure 2.10, the constraint variables are p1 and p2, not P1 and P2.

The Constraint Table Script is also created when specifying linear constraints when designing
an experiment.

The Alter Linear Constraints and Save Linear Constraints commands are not available in the
Mixture Profiler. To incorporate linear constraints into the operations of the Mixture Profiler,
the Constraint Table Script must be created by one of the methods discussed in this section.
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Noise Factors

Note: Noise factor optimization is also available in the Prediction Profiler, Contour Profiler,
Custom Profiler, and Mixture Profiler.

Noise factors (robust process engineering) enables you to produce acceptable products
reliably, despite variation in the process variables. Even when your experiment has
controllable factors, there is a certain amount of uncontrollable variation in the factors that
affects the response. This is called transmitted variation. Factors with this variation are called
noise factors. Some factors you cannot control at all, like environmental noise factors. The
mean for some factors can be controlled, but not their standard deviation. This is often the
case for intermediate factors that are output from a different process or manufacturing step.

A good approach to making the process robust is to match the target at the flattest place of the
noise response surface. Then, the noise has little influence on the process. Mathematically, this
is the value where the first derivatives of each response with respect to each noise factor are
zero. JMP computes the derivatives for you.

Figure 2.11 Noise Factor Example
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To analyze a model with noise factors:
1. Fit the appropriate model (for example, using the Fit Model platform).
2. Save the model to the data table with the Save > Prediction Formula command.

3. Launch the Profiler (from the Graph menu).
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Assign the prediction formula to the Y, Prediction Formula role and the noise factors to the
Noise Factor role.

Click OK.

The resulting profiler shows response functions and their appropriate derivatives with
respect to the noise factors. The derivatives are set to have maximum desirability at zero.

Select Optimization and Desirability > Maximize Desirability from the Profiler menu.

This finds the best settings of the factors, balanced with respect to minimizing transmitted
variation from the noise factors.



38 Introduction to Profilers Chapter 2
Common Profiler Topics Profilers



Chapter 3

Profiler

Explore Cross Sections of Responses across Each Factor

The Prediction Profiler gives you a wealth of information about your model. Use the

Prediction Profiler to do the following:

See how your prediction model changes as you change settings of individual factors.

Set desirability goals for your response or responses, and find optimal settings for your

factors.

Gauge your model’s sensitivity to changes in the factors, where sensitivity is based on
your predictive model.

Assess the importance of your factors relative to model predictions, in a way that is

independent of the model.

Simulate your response distribution based on specified distributions for both factors and
responses, and control various aspects of the appearance of the profiler.

Figure 3.1 Prediction Profiler for Four Responses with Simulator and Importance Coloring
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Example of the Prediction Profiler

This example uses the Tiretread.jmp sample data table. There are three factors (SILICA, SILANE,
and SULFUR) and four responses (ABRASION, MODULUS, ELONG, and HARDNESS). The goal
is to find the optimal combination of the three factors in the development of a tire tread
compound. See Derringer and Suich (1980).

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Select Graph > Profiler.

3. Select Pred Formula Abrasion and click Y, Prediction Formula.

Figure 3.2 Completed Prediction Profiler Launch Window
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4. Click OK.

Figure 3.3 Prediction Profiler Report Window
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The profiler is interactive. The vertical red lines correspond to the current value of the
factors. The current value of each factor is also shown in red below the horizontal axis. The
red value on the vertical axis is the predicted response based on the current values of the
factors. Click and drag the vertical red lines to change the current values of the factors.
Click a factor’s red value to set the factor to a specific value.
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Click the Prediction Profiler red triangle and select Optimize and Desirability > Desirability
Functions.

Click the Prediction Profiler red triangle and select Optimize and Desirability > Maximize
Desirability.

Tip: You might need to adjust the vertical axis of the prediction profiler to view the
maximum value of ABRASION in the plot.

Figure 3.4 Maximize Desirability Report
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By maximizing the desirability, you see that to maximize ABRASION, all factors are set to
their highest levels.

Launch the Prediction Profiler Platform

The Prediction Profiler can be accessed in the following ways:

The Prediction Profiler can be accessed directly from the Graph menu. When you access
the Prediction Profiler in this way, the Prediction Profiler launch window appears. See
“Profiler Launch Windows” on page 28 in the “Introduction to Profilers” chapter.

The Prediction Profiler can be accessed as a red triangle menu option in many modeling
platforms. See “Where to Find JMP Profilers” on page 27 in the “Introduction to Profilers”
chapter for more information about the availability of the Prediction Profiler in different
platforms.

The Prediction Profiler can be accessed from the Model Comparisons platform. Select
Profiler from the Model Comparisons red triangle menu.
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o ‘ﬁ,"ﬂ’o The Prediction Profiler can be accessed from the Formula Depot platform. Select
Profiler from the Formula Depot red triangle menu.

Prediction Profiler Options

The red triangle menu on the Prediction Profiler title bar has the following options:
Optimization and Desirability Submenu that consists of the following options:

Desirability Functions Shows or hides the desirability functions. Desirability is discussed
in “Desirability Profiling and Optimization” on page 49.

Maximize Desirability Sets the current factor values to maximize the desirability
functions. Takes into account the response importance weights.

Note: In many situations, the settings that optimize the desirability function are not
unique. The Maximize Desirability option gives one such setting. The Contour Profiler is a
good tool for finding alternative factor combinations that optimize desirability. For an
example, see “Explore Optimal Settings” on page 91 in the “Contour Profiler” chapter.

Note: If a factor has a Design Role column property value of Discrete Numeric, it is treated
as continuous in the optimization of the desirability function. To account for the fact that
the factor can assume only discrete levels, it is displayed in the profiler as a categorical
term and an optimal allowable level is selected.

Maximize and Remember Maximizes the desirability functions and remembers the
associated settings.

Maximization Options Opens the Maximization Options window where you can refine
the optimization settings.

Figure 3.5 Maximization Options Window
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Maximize for Each Grid Point Used only if one or more factors are locked. The ranges of
the locked factors are divided into a grid, and the desirability is maximized at each grid
point. This is useful if the model that you are profiling has categorical factors. Then the
optimal condition can be found for each combination of the categorical factors.

Save Desirabilities Saves the three desirability function settings for each response, and
the associated desirability values, as a Response Limits column property in the data
table. These correspond to the coordinates of the handles in the desirability plots.

Set Desirabilities Opens the Response Goal window where you can set specific
desirability values.

Figure 3.6 Response Goal Window
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Save Desirability Formula Creates a column in the data table with a formula for
Desirability. The formula uses the fitting formula when it can, or the response variables
when it cannot access the fitting formula.

Assess Variable Importance Provides different approaches to calculating indices that
measure the importance of factors to the model. These indices are independent of the
model type and fitting method. See “Assess Variable Importance” on page 55.

Bagging (Available only when the Prediction Profiler is embedded in certain modeling
platforms.) Launches the Bagging window. Bootstrap aggregating (bagging) enables you
to create multiple training data sets by sampling with replacement from the original data.
For each training set, a model is fit using the analysis platform, and predictions are made.
The final prediction is a combination of the results from all of the models. This improves
prediction performance by reducing the error from variance. See “Bagging” on page 58.

Simulator Launches the Simulator. The Simulator enables you to create Monte Carlo
simulations using random noise added to factors and predictions for the model. A typical
use is to set fixed factors at their optimal settings, and uncontrolled factors and model
noise to random values. You then find out the rate of responses outside the specification
limits. See the “Simulator” chapter on page 141.

Interaction Profiler Shows or hides interaction plots that update as you update the factor
values in the Prediction Profiler. Use this option to help visualize third degree interactions
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by seeing how the plot changes as current values for the factors change. The cells that
change for a given factor are the cells that do not involve that factor directly.

Confidence Intervals Shows or hides confidence intervals in the Prediction Profiler plot. The
intervals are drawn by bars for categorical factors, and curves for continuous factors.
These are available when the profiler is used inside certain fitting platforms or when a
standard error column has been specified in the Prediction Profiler launch dialog.

Prop of Error Bars (Appears when a Sigma column property exists in any of the factor and
response variables.) This option displays the 3¢ interval that is implied on the response
due to the variation in the factor. Propagation of error (POE) is important when attributing
the variation of the response in terms of variation in the factor values when the factor
values are not very controllable. See “Propagation of Error Bars” on page 80.

Sensitivity Indicator Shows or hides a purple triangle whose height and direction
correspond to the value of the partial derivative of the profile function at its current value.
This is useful in large profiles to be able to quickly spot the sensitive cells.

Figure 3.7 Sensitivity Indicators
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Profile at Boundary When analyzing a mixture design, JMP constrains the ranges of the
factors so that settings outside the mixture constraints are not possible. This is why, in
some mixture designs, the profile traces turn abruptly.

When there are mixture components that have constraints, other than the usual
zero-to-one constraint, a new submenu, called Profile at Boundary, appears on the
Prediction Profiler red triangle menu. It has the following two options:
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Turn At Boundaries Lets the settings continue along the boundary of the restraint
condition.

Stop At Boundaries Truncates the prediction traces to the region where strict
proportionality is maintained.

Reset Factor Grid Displays a window for each factor enabling you to enter a specific value
for the factor’s current setting, to lock that setting, and to control aspects of the grid. See
the section “Set or Lock Factor Values” on page 32.

Figure 3.8 Factor Settings Window
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Factor Settings Submenu that consists of the following options:

Remember Settings Adds an outline node to the report that accumulates the values of
the current settings each time the Remember Settings command is invoked. Each
remembered setting is preceded by a radio button that is used to reset to those settings.

There are options to remove selected settings or all settings in the Remember Settings
red triangle menu.

Set To Data in Row Assigns the values of a data table row to the X variables in the
Prediction Profiler.

Copy Settings Script Copies the current Prediction Profiler’s settings to the clipboard.

Paste Settings Script Pastes the Prediction Profiler settings from the clipboard to a
Prediction Profiler in another report.

Append Settings to Table Appends the current profiler’s settings to the end of the data
table. This is useful if you have a combination of settings in the Prediction Profiler that
you want to add to an experiment in order to do another run.

Broadcast Factor Settings Sends the current profiler’s factor settings to all other
profilers, but does not link the profilers. A change in a factor in one profiler does not
cause changes in any other profilers unless Broadcast Factor Settings is selected again.



Chapter 3 Profiler 47
Profilers Prediction Profiler Options

Link Profilers Links all the profilers together. A change in a factor in one profiler causes
that factor to change to that value in all other profilers, including Surface Plot. This is a
global option, set, or unset for all profilers.

Set Script Sets a script that is called each time a factor changes. The set script receives a
list of arguments of the form:

{factorl = nl, factor2 = n2, ...}

For example, to write this list to the log, first define a function:
ProfileCallbackLog = Function({arg},show(arg));

Then enter ProfileCallbackLog in the Set Script dialog.
Similar functions convert the factor values to global values:

ProfileCallbackAssign Function({arg},evallList(arg));

Or access the values one at a time:

ProfileCallbackAccess =
Function({arg},fl=arg["factorl"];f2=arg["factor2"]);

Unthreaded Enables you to change to an unthreaded analysis if multithreading does not
work.

Default N Levels Enables you to set the default number of levels for each continuous factor.
This option is useful when the Prediction Profiler is especially large. When calculating the
traces for the first time, JMP measures how long it takes. If this time is greater than three
seconds, you are alerted that decreasing the Default N Levels speeds up the calculations.

Output Grid Table Produces a new data table with columns for the factors that contain grid
values, columns for each of the responses with computed values at each grid point, and
the desirability computation at each grid point.

If you have a lot of factors, it is impractical to use the Output Grid Table command,
because it produces a large table. A memory allocation message might be displayed for
large grid tables. In such cases, you should lock some of the factors, which are held at
locked, constant values. To get the window to specify locked columns, ALT- or
Option-click inside the profiler graph to get a window that has a Lock Factor Setting check
box.

Output Random Table Prompts for a number of runs and creates an output table with that
many rows, with random factor settings and predicted values over those settings. This is
equivalent to (but much simpler than) opening the Simulator, resetting all the factors to a
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random uniform distribution, then simulating output. This command is similar to Output
Grid Table, except it results in a random table rather than a sequenced one.

The prime reason to make uniform random factor tables is to explore the factor space in a
multivariate way using graphical queries. This technique is called Filtered Monte Carlo.

Suppose you want to see the locus of all factor settings that produce a given range to
desirable response settings. By selecting and hiding the points that do not qualify (using
graphical brushing or the Data Filter), you see the possibilities of what is left: the
opportunity space yielding the result that you want.

Some rows might appear selected and marked with a red dot. These represent the points
on the multivariate desirability Pareto Frontier - the points that are not dominated by
other points with respect to the desirability of all the factors.

Alter Linear Constraints Enables you to add, change, or delete linear constraints. The
constraints are incorporated into the operation of Prediction Profiler. See “Linear
Constraints” on page 34.

Save Linear Constraints Enables you to save existing linear constraints to a table script
called Constraint. See “Linear Constraints” on page 34.

Conditional Predictions Appears when random effects are included in the model. The
random effects predictions are used in formulating the predicted value and profiles.

Appearance Submenu that consists of the following options:

Arrange in Rows Enter the number of plots that appear in a row. This option helps you
view plots vertically rather than in one wide row.

Reorder X Variables Opens a window where you can reorder the model main effects by
dragging them to the desired order.

Reorder Y Variables Opens a window where you can reorder the responses by dragging
them to the desired order.

Adapt Y Axis Re-scales the vertical axis if the response is outside the axis range, so that
the range of the response is included.

Show Creator Shows or hides the name of the platform that created the formula in the
response column. The platform name appears on the vertical axis. (Available only if the
response column contains a “Creator” named argument in the “Predicting” column

property.)
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Desirability Profiling and Optimization

You can define a desirability function for a single response variable or for several response
variables. When you are optimizing relative to several responses, there can often be competing
criteria. For example, you might want to maximize one response, minimize another, and keep
a third response close to some target value.

In desirability profiling, you specify a desirability function for each response. The overall
desirability for all responses is defined as the geometric mean of the desirability functions for
the individual responses. See Derringer and Suich (1980) for information about combining
responses.

To use desirability profiling, select Optimization and Desirability > Desirability Functions from
the Prediction Profiler red triangle menu.

Note: If the response column has a Response Limits property, desirability functions are turned
on by default.

This command appends a new row to the bottom of the plot matrix, dedicated to graphing
desirability. The row has a plot for each factor showing its desirability trace, as illustrated in
Figure 3.9. It also adds a column that has an adjustable desirability function for each Y
variable. The overall desirability measure shows on a scale of zero to one at the left of the row
of desirability traces.

Figure 3.9 The Desirability Prediction Profiler
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Construction of Desirability Functions

The individual desirability functions are smooth piecewise functions that pass through three
defining points. These points are called control points (Low, Middle, High) and can be used to
interactively control the shape of the desirability function.

¢ The Minimize and Maximize functions are three-part piecewise smooth functions that
consist of interpolating cubics between the control points and exponentials in the tails.

® The Target function is a piecewise function that is a scale multiple of a normal density on
either side of the Middle value (with different curves on each side), which is also piecewise
smooth and fit to the control points. Exponential functions are fit to the tails.

* The None function enables you to specify an arbitrary desirability function. In particular,
you can specify desirability to be lower at the Middle value than at the Low and High
values. You can also construct custom desirability functions using formulas. See
“Customized Desirability Functions” on page 53.

The Low and High control points are not allowed to reach all the way to zero or one. This
approach to constructing the desirability functions results in good behavior as the desirability
values switch between the maximize, target, and minimize values.

Note: JMP does not use the Derringer and Suich (1980) functional forms. Because they are not
smooth, they do not always work well with JMP’s optimization algorithm.

Desirability Function for Multiple Optimization

When multiple responses are to be optimized, an overall desirability function is constructed
and optimized. The overall desirability for all responses is defined as the geometric mean of
the desirability functions for the individual responses.

Denote the individual desirability functions for k responses by d;, d,,...,d;. Then the overall
desirability function is the geometric mean of the individual desirability functions:

1/k 1/k 1/k
D =dy "dy "...d;
If Importance values are defined as part of the Response Limits column property or are
defined in the Response Goal window, they are integrated into the overall desirability
function. The Importance values are scaled so that they sum to 1. Denote the scaled
importance values by wy, w, wj. Then the overall desirability is defined as a weighted
geometric mean of the individual desirability functions:

Wy Wy Wy
D=d dy"...d
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Optimization Algorithm

Optimization of the overall desirability function, or of the single desirability function if there
is only one response, is conducted as follows.

* For categorical factors, a coordinate exchange algorithm is used.
¢ For continuous factors, a gradient descent algorithm is used.

* In the presence of constraints or mixture factors, a Wolfe reduced-gradient approach is
used.

How to Use the Desirability Function

To use a variable’s desirability function, drag the function handles to represent a response
value.

As you drag these handles, the changing response value shows in the area labeled Desirability
to the left of the plots. The dotted line is the response for the current factor settings. The
overall desirability shows to the left of the row of desirability traces. Alternatively, you can
select Optimization and Desirability > Set Desirabilities to enter specific values for the points.

Figure 3.10 shows steps to create desirability settings.

Maximize The default desirability function setting is maximize (“higher is better”). The High
control point is positioned at the maximum Y value and aligned at the high desirability,
close to 1. The Low control point is positioned at the minimum Y value and aligned at a
low desirability, close to 0.

Figure 3.10 Maximizing Desirability
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Target You can designate a target value as “best.” In this example, the middle control point
is positioned at Y = 70 and aligned with the maximum desirability of 1. Y becomes less
desirable as its value approaches either 40 or 100. The High and Low control points at
Y =40 and Y =100 are positioned at the minimum desirability close to 0.
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Figure 3.11 Defining a Target Desirability
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Minimize The minimize (“smaller is better”) desirability function associates high response
values with low desirability and low response values with high desirability. The curve is
the maximization curve flipped around a horizontal line at the center of plot.

Figure 3.12 Minimizing Desirability
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Note: Dragging the High or Low control point of a maximize or minimize desirability
function across the y-value of the middle point results in the opposite point reflecting. A
Minimize becomes a Maximize, and vice versa.

The Desirability Profile

The last row of plots shows the desirability trace for each factor. The numerical value beside
the word Desirability on the vertical axis is the geometric mean of the desirability measures.
This row of plots shows both the current desirability and the trace of desirabilities that result
from changing one factor at a time.

For example, Figure 3.13 shows desirability functions for two responses. You want to
maximize ABRASION and MODULUS. The desirability plots indicate that you could increase
the desirability by increasing any of the factors.



Chapter 3 Profiler 53
Profilers Desirability Profiling and Optimization

Figure 3.13 Prediction Profile Plot with Adjusted Desirability and Factor Values
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Customized Desirability Functions

It is possible to use a customized desirability function. For example, suppose you want to
maximize using the following function.

Figure 3.14 Maximizing Desirability Based on a Function
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First, create a column called Custom Desirability that contains the above formula. Then, select
Graph > Profiler to launch the platform. Select all the Pred Formula columns and the Custom
Desirability column and select Y, Prediction Formula. Check the Expand Intermediate Formula
option. Turn on the desirability functions by selecting Optimization and Desirability >
Desirability Functions from the red triangle menu. All the desirability functions for the
individual effects must be turned off. To do this, first double-click in a desirability plot
window, and then select None in the window that appears. Set the desirability for Custom
Desirability to be maximized.
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Figure 3.15 Selecting No Desirability Goal
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At this point, selecting Optimization and Desirability > Maximize Desirability uses only the
custom Custom Desirability function.

Figure 3.16 Maximized Custom Desirability
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Assess Variable Importance

The Variable Importance report calculates indices that measure the importance of factors in a
model in a way that is independent of the model type and fitting method. The fitted model is
used only in calculating predicted values. The method estimates the variability in the
predicted response based on a range of variation for each factor. If variation in the factor
causes high variability in the response, then that effect is important relative to the model.

Note: In some platforms, Assess Variable Importance is not available for categorical responses
with more than two levels.

Assess Variable Importance can also be accessed in the Prediction Profiler that is obtained
through the Graph menu.

For statistical details, see “Assess Variable Importance” on page 78. See also Saltelli (2002).

Note: Assess Variable Importance requires that all columns reside in the same data table.

The Assess Variable Importance Report

The Assess Variable Importance menu has the following options that address the
methodology used in constructing importance indices:

Independent Uniform Inputs For each factor, Monte Carlo samples are drawn from a
uniform distribution defined by the minimum and maximum observed values. Use this
option when you believe that your factors are uncorrelated and that their likely values are
uniformly spread over the range represented in the study. This is the appropriate option
for designed experiments that do not involve constraints or mixture factors.

Independent Resampled Inputs For each factor, Monte Carlo samples are obtained by
resampling its set of observed values. Use this option when you believe that your factors
are uncorrelated and that their likely values are not represented by a uniform distribution.

Dependent Resampled Inputs Factor values are constructed from observed combinations
using a k-nearest neighbors approach, in order to account for correlation. This option
treats observed variance and covariance as representative of the covariance structure for
your factors. Use this option when you believe that your factors are correlated. Note that
this option is sensitive to the number of rows in the data table. If used with a small number
of rows, the results can be unreliable.
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Note: The Independent Resampled Inputs and Dependent Resampled Inputs options are
intended for observational studies. The Independent option is faster than the Dependent
option, but the Dependent option handles multicollinearity better and does not extrapolate
into regions far away from the data.

Linearly Constrained Inputs For each factor, Monte Carlo samples are drawn from a
uniform distribution over a region defined by linear constraints. The linear constraints can
be defined in the Prediction Profiler or constructed in connection with a designed
experiment. In addition, the samples are restricted to fall within the minimum and
maximum observed values. Use this option in the presence of linear constraints, when you
believe that these constraints impact the distribution of the inputs.

The speed of these algorithms depends on the model evaluation speed. In general, the fastest
option is Independent Uniform Inputs and the slowest is Dependent Resampled Inputs. You
have the option to Accept Current Indices when the estimation process is unable to complete
instantaneously.

Note: Variable importance indices are constructed using Monte Carlo sampling. For this
reason, you can expect some variation in importance index values from one run to another.

Variable Importance Report

Each Assess Variable Importance option presents a Summary Report and Marginal Model
Plots. When the Assess Variable Importance report opens, the factors in the Prediction Profiler
are reordered according to their Total Effect importance indices. When there are multiple
responses, the factors are reordered according to the Total Effect importance indices in the
Overall report. When you run several Variable Importance reports, the factors in the
Prediction Profiler are ordered according to their Total Effect indices in the most recent report.

Summary Report
For each response, a table displays the following elements:

Column The factor of interest.

Main Effect An importance index that reflects the relative contribution of that factor alone,
not in combination with other factors.

Total Effect An importance index that reflects the relative contribution of that factor both
alone and in combination with other factors. The Total Effect column is displayed as a bar
chart. See “Weights” on page 57.

Main Effect Std Error The Monte Carlo standard error of the Main Effect’s importance index.
This is a hidden column that you can access by right-clicking in the report and selecting
Columns > Main Effect Std Error. By default, sampling continues until this error is less than
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0.01. Details of the calculation are given in “Variable Importance Standard Errors” on
page 80. (Not available for Dependent Resampled Inputs option.)

Total Effect Std Error The Monte Carlo standard error of the Total Effect’s importance index.
This is a hidden column that you can access by right-clicking in the report and selecting
Columns > Total Effect Std Error. By default, sampling continues until this error is less than
0.01. Details of the calculation are given in “Variable Importance Standard Errors” on
page 80. (Not available for Dependent Resampled Inputs option.)

Weights A plot that shows the Total Effect indices, located to the right of the final column.
You can deselect or reselect this plot by right-clicking in the report and selecting
Columns > Weights.

Proportion of function evaluations with missing values The proportion of Monte Carlo
samples for which some combination of inputs results in an inestimable prediction. When
the proportion is nonzero, this message appears as a note at the bottom of the table.

Note: When you have more than one response, the Summary Report presents an Overall table
followed by tables for each response. The importance indices in the Overall report are the
averages of the importance indices across all responses.

Marginal Model Plots

The Marginal Model Plots report (Figure 3.37) shows a matrix of plots, with a row for each
response and columns for the factors. The factors are ordered according to the size of their
overall Total Effect importance indices.

For a given response and factor, the plot shows the mean response for each factor value, where
that mean is taken over all inputs to the calculation of importance indices. These plots differ
from profiler plots, which show cross sections of the response. Marginal Model Plots are
useful for assessing the main effects of factors.

Note that your choice of input methodology impacts the values plotted on marginal model
plots. Also, because the plots are based on the generated input settings, the plotted mean
responses might not follow a smooth curve.

The red triangle menu options enable you to show or hide the following aspects of the plots:

Estimate A smoothed estimate of the mean of the simulated values calculated as a function
of the factor values.

Note: The estimates of the mean are simulated, so the values change when you rerun the
analysis.
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Confidence Interval A 95% confidence band for the simulated means. This band is often
narrow and might not be visible unless you expand the scale. Not available for Dependent
Resampled Inputs.

Note: The confidence bounds are simulated, so the bands change when you rerun the
analysis.

Data The actual (unsimulated) values of the response plotted against the factor values.

Variable Importance Options
The Variable Importance red triangle menu contains the following options:

Reorder factors by main effect importance Reorders the cells in the Prediction Profiler in
accordance with the importance indices for the main effects (Main Effect).

Reorder factors by total importance Reorders the cells in the Prediction Profiler in
accordance with the total importance indices for the factors (Total Effect).

Colorize Profiler Colors cells in the profiler by Total Effect importance indices using a red to
white intensity scale.

Note: You can click rows in the Summary Report to select columns in the data table. This can
facilitate further analyses.

Bagging

Bootstrap aggregating (bagging) is a technique to improve predictive performance while also
gaining insight into the reliability of predictions. Bagging is especially useful in unstable
methods, including neural networks, classification trees, and regression trees.

Bagging creates M training data sets by sampling with replacement from the original data. All
training data sets are of the same size as the original. For each training data set, a model is fit
using the analysis platform, and predictions are made. Therefore, there are a total of M
predictions for each observation in the original data set. The final prediction is the average of
the M predictions.

Bagging is available in many analysis platforms. To use bagging, select Save Bagged
Predictions from the Prediction Profiler red triangle menu. A window appears with the
following options for Bagging:

Number of Bootstrap Samples Sets the number of times that you want to resample the data
and build a model. A larger number results in more precise predictions. By default, the
number of bootstrap samples is 100.
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Random Seed Sets a random seed that you can re-enter in subsequent runs of the bagging
analysis to duplicate your current results. By default, no seed is set.

Fractional Weights Performs a Bayesian bagging analysis. In each bootstrap iteration, each
observation is assigned a nonzero weight. The model that makes the predictions uses the
weighted observations. By default, the Fractional Weights option is not selected, and a
simple bagging analysis is conducted.

Tip: Use the Fractional Weights option if the number of observations that are used in your
analysis is small or if you are concerned about separation in a logistic regression setting.

Suppose that Fractional Weights is selected. For each bootstrap iteration, each observation
that is used in the report is assigned a nonzero weight. These weights sum to #, the
number of observations used in the model. For more information about how the weights
are calculated and used, see “Calculation of Fractional Weights” on page 370 in the
“Bootstrapping” chapter.

Save Prediction Formulas For each bagged prediction, this option saves the formula used to
make that prediction in the column properties. This option is available in only a subset of
the analysis platforms that offer bagging.

Note: If Save Prediction Formulas is not available, a note appears, stating that only the
predicted values will be saved.

Bagging automatically creates new columns in the original data table. All M sets of bagged
predictions are saved as hidden columns. The final prediction is saved in a column named
“Pred Formula <colname> Bagged Mean”. The standard deviation of the final prediction is
saved in a column named “<colname> Bagged Std Dev”. The standard error of the bagged
mean is saved in a column named “StdError <colname> Bagged Mean.” The standard error is

the standard deviation divided by /M -1 . Here, <colname> identifies the column in the report
that was bagged.

The standard error gives insight about the precision of the prediction. A very small standard

error indicates a precise prediction for that observation. For more information about bagging,
see Hastie et al. (2009).

Figure 3.17 Bagging Columns
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Additional Examples of the Prediction Profiler

This section contains additional examples illustrating various aspects of the Prediction
Profiler platform and the Prediction Profiler embedded in many analysis platforms.

¢ “Example of Desirability Profiling for Multiple Responses”
e “Example of a Noise Factor in the Prediction Profiler”

¢ “Example of Variable Importance for One Response”

e “Example of Variable Importance for Multiple Responses”
e “Example of Bagging to Improve Prediction”

¢ “Example of Bagging to Indicate the Accuracy of Predictions”

Example of Desirability Profiling for Multiple Responses

A desirability index becomes especially useful when there are multiple responses. The idea
was pioneered by Derringer and Suich (1980), who give the following example. Suppose there
are four responses, ABRASION, MODULUS, ELONG, and HARDNESS. Three factors, SILICA,
SILANE, and SULFUR, were used in a central composite design.

The desirability functions are as follows:

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Click the green triangle next to RSM for 4 Responses to run the script.

This script defines a model for the four responses with a full quadratic response surface.
The summary tables and effect information appear for all the responses, followed by the
prediction profiler shown in Figure 3.18.
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Figure 3.18 Prediction Profiler for Multiple Responses before Optimization
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Note the following about the desirability functions:

— Maximum ABRASION and maximum MODULUS are most desirable.
— ELONG target of 500 is most desirable.

— HARDNESS target of 67.5 is most desirable.

3. Select Optimization and Desirability > Maximize Desirability from the Prediction Profiler red
triangle menu to maximize desirability.
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Figure 3.19 Prediction Profiler after Optimization
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The desirability traces at the bottom decrease everywhere except the current values of the
effects, which indicates that any further adjustment could decrease the overall desirability.

Example of a Noise Factor in the Prediction Profiler

For example, use the Tiretread.jmp sample data set. This data set shows the results of a tire
manufacturer’s experiment whose objective is to match a target value of HARDNESS= 70 based
on three factors: SILICA, SILANE, and SULFUR content. Suppose the SILANE and SULFUR
content are easily (and precisely) controllable, but SILICA expresses variability that is worth
considering.

For comparison, first optimize the factors for hardness without considering variation from the
noise factor.

1. Select Graph > Profiler to launch the Prediction Profiler.

2. Assign Pred Formula HARDNESS to the Y, Prediction Formula role.
3. Click OK.
4

Select Optimization and Desirability > Desirability Functions in the Prediction Profiler
menu.
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5. Double-click in the Desirability plot to open the Response Goal window. Select Match
Target from the list.

6. Select Optimization and Desirability > Maximize Desirability to find the optimum factor
settings for our target value of HARDNESS.

We get the following Prediction Profiler display. Notice that the SILICA factor’s optimum
value is on a sloped part of a profile curve. This means that variations in SILICA are
transmitted to become variations in the response, HARDNESS.

Note: You might get different results from these because different combinations of factor
values can all hit the target.

Figure 3.20 Maximizing Desirability for HARDNESS
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Now, we would like to not just optimize for a specific target value of HARDNESS, but also be
on a flat part of the curve with respect to Silica. So, repeat the process and add SILICA as a
noise factor.

1. Select Graph > Profiler.
2. Select Pred Formula HARDNESS and click Y, Prediction Formula.

3. Select SILICA and click Noise Factors.

4. Click OK.

5. Change the Pred Formula Hardness desirability function as before.

The resulting profiler has the appropriate derivative of the fitted model with respect to the
noise factor, set to be maximized at zero, its flattest point.
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Figure 3.21 Derivative of the Prediction Formula with Respect to Silica
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Select Optimization and Desirability > Maximize Desirability to find the optimum values for
the process factor, balancing for the noise factor.

This time, we have also hit the targeted value of HARDNESS, but our value of SILICA is on
its flatter region. This means variation in SILICA does not transmit as much variation to
HARDNESS.

Figure 3.22 Maximize Desirability

A=

dPred Formula Pred Formula

HARDNESS/@SILICA

Desirability

Prediction Profiler
80

75

22347 0

HARDMESS
1
oo
=R =1

0.994987 05

oW
b S~
k=1 k=1

SILANE SULFUR Desirability




Chapter 3
Profilers

Profiler 65
Additional Examples of the Prediction Profiler

You can see the effect this has on the variance of the predictions by following these steps for
each profiler (one without the noise factor, and one with the noise factor):

1. Select Simulator from the platform menu.

2. Assign SILICA to have a random Normal distribution with a standard deviation of 0.05.

Figure 3.23 Setting a Random Normal Distribution
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Click Simulate.

4. Click the Make Table button under the Simulate to Table node.

Doing these steps for both the original and noise-factor-optimal simulations results in two
similar data tables, each holding a simulation. In order to make two comparable
histograms of the predictions, we need the two prediction columns in a single data table.

5. Copy the Pred Formula HARDNESS column from one of the simulation tables into the other
table. They must have different names, like Without Noise Factor and With Noise Factor.

Select Analyze > Distribution and assign both prediction columns as Y.

7. When the histograms appear, select Uniform Scaling from the Distribution main title bar.
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Figure 3.24 Comparison of Distributions with and without Noise Factors

£ |~ | Distributions
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The histograms show that there is much more variation in Hardness when the noise factor was
not included in the analysis.

It is also interesting to note the shape of the histogram when the noise factor was included. In
the comparison histograms above, note that the With Noise Factor distribution has data trailing
off in only one direction. The predictions are skewed because Hardness is at a minimum with
respect to SILICA, as shown in Figure 3.25. Therefore, variation in SILICA can make only
HARDNESS increase. When the non-robust solution is used, the variation could be transmitted
either way.

Figure 3.25 Prediction Profiler Showing the Minima of HARDNESS by SILICA
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Example of Variable Importance for One Response

The Boston Housing.jmp sample data table contains data on 13 factors that might relate to
median home values. You fit a model using a neural network. Because neural networks do not
accommodate formal hypothesis tests, these tests are not available to help assess which
variables are important in predicting the response. However, for this purpose, you can use the
Assess Variable Importance profiler option.
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Note that your results might differ from, but should resemble, those shown here. There are
two sources of random variability in this example. When you fit the neural network, k-fold
cross validation is used. This partitions the data into training and validation sets at random.
Also, Monte Carlo sampling is used to calculate the factor importance indices.

AL A

10.

Select Help > Sample Data Library and open Boston Housing.jmp.

Select Analyze > Predictive Modeling > Neural.

Select mvalue from the Select Columns list and click Y, Response.

Select all other columns from the Select Columns list and click X, Factor.

Click OK.

In the Neural Model Launch panel, select KFold from the list under Validation Method.
When you select KFold, the Number of Folds defaults to 5.

(Optional) Enter 123 next to Random Seed.

Note: Results vary due to the random nature of choosing a validation set in the Neural
Network model. Entering the seed above enables you to reproduce the results shown in
this example.

Click Go.
Click the red triangle next to Model NTanH(3) and select Profiler.

The Prediction Profiler is displayed at the very bottom of the report. Note the order of the
factors for later comparison.

Because the factors are correlated, you take this into account by choosing Dependent
Resampled Inputs as the sampling method for assessing variable importance.

Click the Prediction Profiler red triangle and select Assess Variable Importance >
Dependent Resampled Inputs.

The Variable Importance: Dependent Resampled Inputs report appears. Check that the
Prediction Profiler cells have been reordered by the magnitude of the Total Effect indices
in the report. In Figure 3.26, check that the Total Effect importance indices identify rooms
and Istat as the factors that have most impact on the predicted response.
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Figure 3.26 Dependent Resampled Inputs Report

£ = Variable Importance: Dependent Resampled Inputs

< Summary Report
Column  Main Effect TotalEffect .2 4 6 B
Istat 0.147 0305
rooms 0.129 0266 ]
chas 02 02 I
pt 0,041 0.009 7]
nox 0.081 0.081 ]
crim 0.08 003
distance 0.05 0.079 1
indus 0.067 0.067 [
zn 0.052 0.0521
tax 0,043 0.043]]
b 0,043 0.043]]
age 0,035 0.035]
radial 0.032 0.032]

[/ =/ Marginal Model Plots

You might be interested in comparing the importance indices obtained assuming that the
factors are correlated, with those obtained when the factors are assumed independent.

11. Click the Prediction Profiler red triangle and select Assess Variable Importance >
Independent Resampled Inputs.

The resampled inputs option makes sense in this example, because the distributions
involved are not uniform. The Variable Importance: Independent Resampled Inputs report
is shown in Figure 3.27. Check that the two factors identified as having the most impact on
the predicted values are Istat and radial.

Figure 3.27 Independent Resampled Inputs Report

£ = Variable Importance: Independent Resampled Inputs

< Summary Report
Column Main Effect Total Effect .2 4 .6 B

Istat 0.337 0.536
radial 0.164 0.249
nox 0.032 0.122 |
pt 0.06 0.118 |1
distance 0.026 01l
tax 0.023 0.082 ]
rooms 0.034 0.075 [
crim 0.018 0.03 |
indus 0.011 0.036 |
age 0.008 0.021 |
b 0.008 0.019 |
chas 0.006 0.012 |
zn 0.004 0.011 |

[ =/Marginal Model Plots
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Example of Variable Importance for Multiple Responses

The data in the Tiretread.jmp sample data table are the result of a designed experiment where
the factors are orthogonal. For this reason, you use importance estimates based on
independent inputs. Suppose that you believe that, in practice, factor values vary throughout
the design space, rather than assume only the settings defined in the experiment. Then you
should choose Independent Uniform Inputs as the sampling scheme for your importance
indices.

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Run the script RSM for 4 Responses.
The Prediction Profiler is displayed at the very bottom of the report.

3. Click the Prediction Profiler red triangle and select Assess Variable Importance >
Independent Uniform Inputs.

The Summary Report is shown in Figure 3.28. Because the importance indices are based
on random sampling, your estimates might differ slightly from those shown in the figure.

The report shows tables for each of the four responses. The Overall table averages the
factor importance indices across responses. The factors in the Prediction Profiler
(Figure 3.29) have been reordered to match their ordering on the Overall table’s Total
Effect importance.
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Figure 3.28 Summary Report for Four Responses

4 ~|Variable Importance: Independent Uniform Inputs
4 Summary Report

4 Qverall
Column Main Effect Total Effect .2 4 .6 .8
SILANE 0372 04160 ] :
sica 0367 0398 L]
SULFUR 0208 02510
4 ABRASION
Column Main Effect Total Effect .2 4 .6 .8
SILANE 0391 0471 L
SILICA 0339 0404 0
SULFUR 0146 02470 :
“ MODULUS
Column Main Effect Total Effect .2 4 .6 .8
SILICA 0357 o406
SILANE 0332 0.391
SULFUR 0221 0204 0
4 ELONG
Column Main Effect Total Effect .2 4 .6 .8

SILICA 0599 06 |

SULFUR 0327 03270 :
SILANE 0.074 0074l |

4 HARDNESS
Column Main Effect Total Effect .2 4 .6 .8
SILANE 0.69 0727 :
sica 0172 oas1[ ] o
SULFUR 0138 01380

4. Click the red triangle next to Variable Importance: Independent Uniform Inputs and select
Colorize Profiler.

Colors from a red to white intensity scale are overlaid on profiler panels to reflect Total
Effect importance. For example, you easily see that the most important effect is that of
Silane on Hardness.
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Figure 3.29 Prediction Profiler for Four Responses
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The Marginal Model Plots report shows mean responses for each factor across a uniform
distribution of settings for the other two factors.

Figure 3.30 Marginal Model Plots for Four Responses
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Example of Bagging to Improve Prediction

Bagging is used in a number of situations. One situation is to improve predictive power.
Bagging is especially helpful for unstable models. This example uses the Tiretread.jmp sample
data table. There are three factors (SILICA, SILANE, and SULFUR) and four responses
(ABRASION, MODULUS, ELONG, and HARDNESS). First, you fit a neural network model to
simultaneously predict the four response variables as a function of the three factors. Then, you
perform bagging on the neural network model. Last, you compare the predictions to show the
improvements obtained through bagging.

Fit Neural Network Model

AL

Select Help > Sample Data Library and open Tiretread.jmp.

Select Analyze > Predictive Modeling > Neural.

Select ABRASION, MODULUS, ELONG, and HARDNESS and click Y, Response.

Select SILICA, SILANE, and SULFUR and click X, Factor.

Click OK.

(Optional) Enter 2121 next to Random Seed.

Note: Results vary due to the random nature of choosing a validation set in the Neural

Network model. Entering the seed above enables you to reproduce the results shown in
this example.

Click Go.
Click the red triangle next to Model NTanH(3) and select Save Formulas.
Note: This option saves the predicted values for all response variables from the neural

network model to the data table. Later, these values are compared to the predictions that
are obtained from bagging.

Perform Bagging

Now that the initial model has been constructed, you can perform bagging using that model.
Access the Bagging feature through the Prediction Profiler.

1.

Click the red triangle next to Model NTanH(3) and select Profiler.

The Prediction Profiler appears at the bottom of the report.

Click the Prediction Profiler red triangle and select Save Bagged Predictions.
Enter 100 next to Number of Bootstrap Samples.

(Optional) Enter 2121 next to Random Seed.



Chapter 3 Profiler 73
Profilers Additional Examples of the Prediction Profiler

Note: Results vary due to the random nature of sampling with replacement. To reproduce
the exact results in this example, set the Random Seed.

5. Click OK.

Return to the data table. For each response variable, there are three new columns denoted
as Pred Formula <colname> Bagged Mean, StdError <colname> Bagged Mean, <colname>
Bagged Std Dev. The Pred Formula <colname> Bagged Mean columns are the final
predictions.

Figure 3.31 Columns Added to Data Table After Bagging

= | Columns (423/0)

[» ABRASION Bags (100/0)

[» MODULUS Bags (100/0)

[» ELONG Bags(100/0)

[» HARDMESS Bags (100/0)

dll Pred Formula ABRASION Bagged Mean p
l StdError ABRASION Bagged Mean o

4l ABRASION Bagged Std Dev o

dll Pred Formula MODULUS Bagged Mean op
dl StdError MODULUS Bagged Mean o

4l MODULUS Bagged Std Dev o

dll Pred Formula ELONG Bagged Mean op

dl StdError ELONG Bagged Mean op

4l ELONG Bagged Std Dev b

4l Pred Formula HARDMESS Bagged Mean op
dll StdError HARDNESS Bagged Mean o

4l HARDNESS Bagged Std Dev

Compare the Predictions

To see how bagging improves predictive power, compare the predictions from the bagged
model to the original model predictions. Use the Model Comparison platform to look at one
response variable at a time.

1. Select Analyze > Predictive Modeling > Model Comparison.

2. Select Predicted ABRASION and click Y, Predictors.

3. Select Pred Formula ABRASION Bagged Mean and click Y, Predictors.

4. Click OK.

A window that contains a list of columns appears.

Select ABRASION and click OK.

6. Click the Model Comparison red triangle and select Plot Actual by Predicted.

S
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Figure 3.32 Comparison of Predictions for ABRASION

< Measures of Fit for ABRASION

Predictor Creator .2.4.6.8 RSquare RASE AAE Freqg
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The Measures of Fit report and the Actual by Predicted Plot are shown in Figure 3.32. The
predictions that were obtained from bagging are shown in blue. The predictions that were
obtained from the original neural network model are shown in red. In general, the bagging
predictions are closer to the line than the original model predictions. Because the bagging
predictions are closer to the line, the RSquare value of 0.6699 for the bagged predictions is
higher than the RSquare value for the original model predictions. You conclude that bagging
improves predictions for ABRASION.

This example compared the predictions for ABRASION. To compare predictions for another
response variable, follow step 2 through step 6, replacing ABRASION with the desired
response variable. As another example, Figure 3.33 shows the Measures of Fit report for
HARDNESS. The report shows similar findings as the Measures of Fit report for ABRASION.
The RSquare value for the bagged predictions is slightly higher than the RSquare value for the
original model predictions, which indicates a better fit and improved predictions.



Chapter 3 Profiler 75
Profilers Additional Examples of the Prediction Profiler

Figure 3.33 Comparison of Predictions for HARDNESS

< Measures of Fit for HARDNESS

Predictor Creator .2.4.6.8 RSquare RASE AAE Freqg
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Example of Bagging to Indicate the Accuracy of Predictions

Bagging is also used to indicate the accuracy of the prediction through standard errors and
other distributional measures. In platforms where the Save Predicted Formulas option is
available in Bagging, you can make predictions on new observations and determine how
accurate they are. The Save Predicted Formulas option is available in the Standard Least
Squares, Generalized Regression, and Generalized Linear Models platforms.

In the Tiretread.jmp data table, suppose that you are interested in only predicting ABRASION as
a function of the three factor variables. In this example, you fit a generalized regression model
to predict ABRASION. Then, you perform bagging on that model. Last, you make a prediction
for a new observation and investigate the accuracy of that prediction. This is done by
obtaining a confidence interval for the prediction.

Fit a Generalized Regression Model

Select Help > Sample Data Library and open Tiretread.jmp.

Select Analyze > Fit Model.

Select ABRASION and click Y.

Select Generalized Regression from the Personality list.

Select SILICA, SILANE, and SULFUR and click Macros > Full Factorial.
This adds all terms, including interactions, to the model.

6. Click Run.

A
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7. Click Go.

Figure 3.34 Parameter Estimates From Generalized Regression Report

< Parameter Estimates for Original Predictors

Wald Prob >
Term Estimate  StdError ChiSquare ChiSquare Lower95% Upper 95%
Intercept -46.03865  7.526013 3744455 <0 -60.31113 -31.30617
SILICA 32087280 22710897  210.97194 28.536036 374385343
SILANE 17880765 0.1194432  224.10381 <.000 1.5539721 2,0221800
(SILICA-1.2)*(SILANE-50) 1025 02316574 19.577413 <,0001* 0.5700598 147090402
SULFUR 21.813077 14913761  213.92398 <,0001* 18.800033 2473612
(SILICA-1.2)*(SULFUR-2.3) 285 4.6331484  37.8387%96 <,0001* 10.41919 37.580804
(SILAME-50)*(SULFUR-2.3) 1575 0.2316574 46224125 <,0001* 1.1200508 2,0200402
(SILICA-1.2)*(SILANE-50)*(SULFUR-2.3) 155 04633148 11.192085 0.0008* 0.6419196 2.4580804
Normal Distribution Wald Prob >
Parameters Estimate Std Error ChiSquare ChiSquare Lower 95% Upper95%
Scale 52681724 07750427 46.005727 <,0001* 37473527  6.7389921

Perform Bagging
1. Click the red triangle next to Normal Lasso with AICc Validation and select Profilers >
Profiler.
The Prediction Profiler appears at the bottom of the report.
2. Click the Prediction Profiler red triangle and select Save Bagged Predictions.
Enter 500 next to Number of Bootstrap Samples.
4. (Optional) Enter 4321 next to Random Seed.

Note: Results vary due to the random nature of sampling with replacement. To reproduce
the exact results in this example, set the Random Seed.

5. Confirm that Save Prediction Formulas is selected.
6. Click OK.

Note: This might take longer to run than the “Example of Bagging to Improve Prediction”
on page 72. The larger number of samples gives a better estimate of the prediction
distributions.

Return to the data table. For each response variable, there are three new columns denoted
as Pred Formula <colname> Bagged Mean, StdError <colname> Bagged Mean, <colname>
Bagged Std Dev. The Pred Formula ABRASION Bagged Mean column is the final prediction.
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Prediction for a New Observation

77

You now have predictions for ABRASION for each observation in the data table, as well as the
standard errors for those predictions. Suppose that you have an observation with new values
of 0.9, 43, and 2 for SILICA, SILANE, and SULFUR, respectively. You can predict the

ABRASION response and obtain a confidence interval for that prediction because the Save

Prediction Formulas option saves the regression equation for each bagged model. Therefore,
M predictions are made with the new factor values to create a distribution of possible

predictions. The mean is the final prediction, but analyzing the distribution tells you how

accurate the prediction is.

1.

2
3
4.
5

In the data table, select Rows > Add Rows.

Enter 1 in the How many rows to add box and click OK.

Under the SILICA column, type 0.9 in the box for the new row.
Under the SILANE column, type 43 in the box for the new row.
Under the SULFUR column, type 2 in the box for the new row.

All of the prediction columns for the new row are automatically calculated.

Figure 3.35 Values for New Row

0 *® N

ABRASION MODULUS ELONG HARDNESS | SILICA | SILANE | SULFUR | Pred Formula ABRASION = Pred Formula MODULUS

1 102 900 470 67.5 0.7 40 28
2 120 860 410 65 1.7 40 1.8
3 17 800 570 5 0.7 60 1.8
4 198 2294 240 74.5 1.7 60 28
5 103 490 640 62.5 0.7 40 1.8
6 132 1289 270 67 17 40 28
7 132 1270 410 78 0.7 60 28
8 139 1090 380 70 i 60 1.8
9 102 770 590 76 03835 50 23
10 154 1690 260 70 2.0165 50 2.3
1 96 700 520 63 1.2 33.67 23
12 163 1540 380 75 1.2 66.33 23
13 116 2184 520 65 1.2 50 14835
14 153 1784 290 71 1.2 50 3.1165
15 133 1300 380 70 1.2 50 2.3
16 133 1300 380 68.5 ) 50 23
17 140 1145 430 68 1.2 50 23
18 142 1090 430 68 1.2 50 2.3
19 145 1260 390 69 1.2 50 2.3
20 142 1344 390 70 1.2 50 2.3
21 . . . . 0.9 43 2

Select Tables > Transpose.
Select ABRASION Bags (500/0) and click Transpose Columns.
Click OK.

Select Analyze > Distribution.

96.7475395
113.421752
114.695993
195.496359
104.934463
133.734829

138.00907
143.683282
101.492758
155.361002
100.727591

159.12617
117.116503
152.737257
139.119239
139.119239
139.119239
139.119239
139.119239
139.119239
114.489091

747.638719
1074.97186
1011.176
2173.94727
865.669653
1333.44092
1310.64507
14979782
600.398164
1476.17966
525.749229
1330.8286
1564.51067
2020.06715
1261.13314
1261.13314
1261.13314
1261.13314
1261.13314
1261.13314
931.321632
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10. Select Row 21 and click Y, Columns.
Note: Row 21 corresponds to the predictions from the new observation.

11. Click OK.
12. Click the red triangle next to Row 21 and select Display Options > Horizontal Layout.

Figure 3.36 Distribution Report

£ |~ | Distributions

£~ Row 21

— £ Quantiles £ =/ Summary Statistics
Ao ooy —{P|—PostRen o . 100.0% maximum 15836529239 Mean 112.30276
99.5% 147.78319109  Std Dev £.2036088
97.5% 12792630742 Std Err Mean 0.2850349
90.0% 11777494068  Upper 95% Mean 112.86455
75.0%  quartile 11409096311  Lower35% Mean 111.74008
50.0%  median 111.67631707 N 500

25.0%  quartile 109.93570255

10.0% 106.95588835

= 2.5% 100.84534774

90 100 110 120 130 140 150 160 0.5% 88.190714761

0.0%  minimum 87.132670178

The Distribution Report in Figure 3.36 contains information about the distribution of the
predicted values of ABRASION from each bagged model. The final prediction of ABRASION
for the new observation is 112.3, which is the mean of all the M bagged predictions. This
prediction has a standard error of 6.39. You can also create confidence intervals for the new
prediction using the quantiles. For example, a 95% confidence interval for the new prediction
is 100.85 to 127.93.

Statistical Details for the Prediction Profiler

e “Assess Variable Importance”

* “Propagation of Error Bars”

Assess Variable Importance

The details that follow relate to the how the variable importance indices are calculated.
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Background

Denote the function that represents the predictive model by f, and suppose that x4, xy, ..., x;,
are the factors, or main effects, in the model. Let y = f(xy, x5 ..., x,,).

* The expected value of y, E(y), is defined by integrating y with respect to the joint
distribution of x7, x5, ..., X,

e The variance of y, Var(y), is defined by integrating (i — E(y))? with respect to the joint
distribution of x7, x5, ..., X,

Main Effect

The impact of the main effect x; on y can be described by Var(E(y |x;)). Here the expectation is
taken with respect to the conditional distribution of xy, x,, ..., x,, given x; and the variance is
taken over the distribution of Xj. In other words, Var(E(y Ix]-)) measures the variation, over the
distribution of x; in the mean of y when x; s fixed.

It follows that the ratio Var(E(y Ix;))/Var(y) gives a measure of the sensitivity of y to the factor
xj. The importance index in the Main Effect column in the Summary Report is an estimate of
this ratio (see “Adjustment for Sampling Variation” on page 80).

Total Effect

The Total Effect column represents the total contribution to the variance of y = f(x4, x; ..., x,)
from all terms that involve x;. The calculation of Total Effect depends on the concept of
functional decomposition. The function fis decomposed into the sum of a constant and
functions that represent the effects of single variables, pairs of variables, and so on. These
component functions are analogous to main effects, interaction effects, and higher-order
effects. See Saltelli (2002); Sobol (1993).

Those component functions that include terms containing X;are identified. For each of these,
the variance of the conditional expected value is computed. These variances are summed. The
sum represents the total contribution to Var(y) due to terms that contain x;. For each x;, this
sum is estimated using the selected methodology for generating inputs. The importance
indices reported in the Total Effect column are these estimates (see “Adjustment for Sampling
Variation” on page 80).

Consider a simple example with two factors, x; and x,. Then the Total Effect importance index
for x7 is an estimate of the following:

Var(E(y |x1)) + Var(E(y |x{, x,))
Var(y)
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Adjustment for Sampling Variation

Due to the fact that they are obtained using sampling methods, the Main Effect and Total
Effect estimates shown in the Summary Table might have been adjusted. Specifically, if the
Total Effect estimate is less than the Main Effect estimate, then the Total Effect importance
index is set equal to the Main Effect estimate. If the sum of the Main Effect estimates exceeds
one, then these estimates are normalized to sum to one.

Variable Importance Standard Errors

The standard errors that are provided for independent inputs measure the accuracy of the
Monte Carlo replications. Importance indices are computed as follows:

® Latin hypercube sampling is used to generate a set of data values.
* For each set of data values, main and total effect importance estimates are calculated.

¢ This process is replicated until the estimated standard errors of the Main Effect and Total
Effect importance indices for all factors fall below a threshold of 0.01.

The standard errors that are reported are the standard error values in effect when the
replications terminate.

Propagation of Error Bars

Propagation of error (POE) is important when attributing the variation of the response in
terms of variation in the factor values when the factor values are not very controllable.

In JMP’s implementation, the Prediction Profiler first looks at the factor and response variables
to see whether there is a Sigma column property (a specification for the standard deviation of
the column, accessed through the Cols > Column Info dialog box). If the property exists, then
the Prop of Error Bars command becomes accessible in the Prediction Profiler drop-down
menu. This displays the 36 interval that is implied on the response due to the variation in the
factor.
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Figure 3.37 Green Propagation of Errors Bars in the Prediction Profiler
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The POE is represented in the graph by a green bracket. The bracket indicates the prediction
plus or minus three times the square root of the POE variance. The POE variance can be
expressed as follows:

5 (62 x(Z)) o

where oy is the user-specified sigma for the response column, and o, is the user-specified
sigma for the factor column.

Currently, these partial derivatives are calculated by numerical derivatives:
centered, with d=xrange/10000

POE limits increase dramatically in response surface models when you are over a more sloped
part of the response surface. One of the goals of robust processes is to operate in flat areas of
the response surface so that variations in the factors do not amplify in their effect on the
response.
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Chapter 4

Contour Profiler
Explore Contours of Responses across Two Factors

The Contour Profiler shows plots of response contours for two factors at a time. Multiple
contour plots for different combinations of factors can be viewed at the same time. The
interactive contour profiling facility is useful for optimizing response surfaces graphically.

Figure 4.1 Contour Profiler Example
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Overview of the Contour Profiler

The Contour Profiler shows plots of response contours for two factors at a time. Multiple
contour plots for different combinations of factors can be viewed at the same time. Factors can
be set to specific values to show how this affects the contours. The interactive contour
profiling facility is useful for optimizing response surfaces graphically. Separate surface plots
for each response are also available. Figure 4.2 shows an example of the Contour Profiler for
the Tiretread.jmp sample data.

Figure 4.2 Contour Profiler
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Example of the Contour Profiler

This example uses the Tiretread.jmp sample data table. There are three factors (SILICA, SILANE,
and SULFUR) and four responses (ABRASION, MODULUS, ELONG, and HARDNESS). This data
table already contains saved prediction formula columns for the four response variables.

1. Select Help > Sample Data Library and open Tiretread.jmp.
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Select Graph > Contour Profiler.

Select Pred Formula ABRASION, Pred Formula MODULUS, Pred Formula ELONG, and
Pred Formula HARDNESS and click Y, Prediction Formula.

Click OK.

Click the Contour Profiler red triangle and select Multiple Contour Frames.
Under Horizontal Factor, select SILICA and under Vertical Factor, select SULFUR.
Click OK.

@

N o e

On both contour plots, the values for SILICA are on the horizontal axis. The values for
SILANE and SULFUR are on the vertical axes. In the first contour plot, the value for
SULFUR is fixed at 2.25. In the second contour plot, the value for SILANE is fixed at 50
(Figure 4.2).

8. Click the Current X box for SULFUR and type 2. Click anywhere outside the box to set the
value.

9. In the Lo Limit box for Pred Formula ABRASION, type 100.
10. In the Hi Limit box for Pred Formula ABRASION, type 160.
11. Click anywhere outside the box to update the plot.
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Figure 4.3 Contour Profiler for Tiretread.jmp
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The contour lines in the first contour plot differ from those in Figure 4.2 because SULFUR is set
at a different value. This can be seen in the placement of the horizontal line at 2 in the second
contour plot. Move the slider bar for SULFUR to see how different values further change the
contour lines in the first contour plot. Move the slider bar for SILANE to see how different
values change the contour lines in the second contour plot. The shaded area on the contour
plots represent the regions of the graphs that are not feasible, based on the Lo Limit and Hi
Limit values for ABRASION.

Launch the Contour Profiler Platform

The Contour Profiler can be accessed in the following ways:

* The Contour Profiler can be accessed directly from the Graph menu. When you access the
Contour Profiler in this way, the Contour Profiler launch window appears. See “Profiler
Launch Windows” on page 28 in the “Introduction to Profilers” chapter.

* The Contour Profiler can be accessed as a red triangle menu option in many modeling
platforms. See “Where to Find JMP Profilers” on page 27 in the “Introduction to Profilers”
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chapter for more information about the availability of the Contour Profiler in different
platforms.

¢ The Contour Profiler can be accessed from the Model Comparisons platform. Select
Profiler from the Model Comparisons red triangle menu. Then, select Contour Profiler
from the Profiler red triangle menu.

o ‘i,”"’ The Contour Profiler can be accessed from the Formula Depot platform. Select

Profiler from the Formula Depot red triangle menu and select the models to be profiled.
Then, select Contour Profiler from the Profiler red triangle menu.

The Contour Profiler Report

The initial Contour Profiler report shows a contour profiler plot, factor settings and controls,
and response settings and controls. The colored lines on the graph are the contours for the
responses set by the Y slider controls or by entering values in the Contour column. There is a
separately colored contour for each response. For each contour, there is a dotted line in the
direction of higher response values, so that you get a sense of direction. To change the factor
assignments to the horizontal and vertical axes of a contour plot, click the red triangle on the
axis and select a factor. If you select the factor that is on the opposite axis, the factor
assignments are interchanged.

* “Factor Settings and Controls”

* “Response Settings and Controls”

Factor Settings and Controls

Factor The list of factors.

Current X The current factor settings. Click in a box to change the value of a factor or use the
slider controls. Right-click the slider control and select Rescale Slider to change the scale
of the slider. When one value is changed, the values for the other factors remain the same,
but the values in the response settings and controls report change accordingly. The
Current X location is shown by the crosshair lines on the graph.

Lock A column that appears for mixture designs with more than three predictors. This
column enables you to lock settings for mixture values so that they are not changed when
the mixture needs to be adjusted due to other mixture effects being changed. When locked
columns exist, the shaded area for a mixture recognizes the newly restricted area.
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Figure 4.4 Lock Column
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Response Settings and Controls

Response The list of one or more responses, with a color legend. To change the color of a
response, right-click the color legend for that response.

Contour The current value of the contour on the contour profiler. Click in the box to change
the value. The slider control can also be used to change the value of the contour.

CurrentY The predicted response based on the current X settings. The value is at the red line
on the slider control. This value updates as the factor settings are changed.

Lo Limit Enables you to set a lower limit for your response. Click in a box to set the limit or
click the left triangle of the slider control for that response. If a response column’s Spec
Limits column property has a value for Lower Spec Limit, that value is used as the initial
value for Lo Limit.

High Limit Enables you to set an upper limit for your response. Click in a box to set the limit
or click the right triangle of the slider control for that response. If a response column’s Spec
Limits column property has a value for Upper Spec Limit, that value is used as the initial
value for Hi Limit.

When response limits are used, the profiler shows regions that are not feasible as shaded in
the contour profiler plot.

Contour Profiler Platform Options

Grid Density Sets the density of the mesh plots in the surface plots.

Graph Updating Contains options to change the frequency of updates for the graph. (The
difference might not be noticeable on a fast machine.) The following two options are
available:

Per Mouse Move Updates the graph continuously as you drag the mouse. This is the
default setting.
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Per Mouse Up Updates the graph each time the mouse is released.
Surface Plot Shows or hides the mesh plots.

Contour Label Shows or hides a label for the contour lines. The label colors match the
contour colors.

Contour Grid Draws contours on the Contour Profiler plot at intervals that you specify.
Remove Contour Grid Enables you to remove a contour grid once one is drawn.

Factor Settings Provides a submenu of commands that enables you to save and transfer the
Contour Profiler’s settings to other parts of JMP. See “Factor Settings” on page 46 in the
“Profiler” chapter.

Simulator Launches the Simulator. See the “Simulator” chapter on page 141.

Up Dots Shows or hides dotted lines that correspond to each contour. The dotted lines show
the direction of increasing response values.

Set Contours to Current Resets the contour lines to be where the current Y values are
located. This means that all contour lines cross where the crosshairs are on the contour
plot and the controls agree in the Y sliders.

Arrange X Controls Left Rearranges the X and Y controls horizontally with the X controls on
the left or vertical with the X controls at the top.

Hide X Controls Shows or hides the X controls (Factor Settings and Controls).
Hide Y Controls Shows or hides the Y controls (Response Settings and Controls).

Multiple Contour Frames Enables you to add one or more contour plots to the report that
represent different combinations of factor settings. When you select this option, the
Multiple Contour Frames dialog appears. Use the dialog to specify additional individual
contour plots or a matrix of contour plots. You can specify a lower triangular, upper
triangular, or full square matrix of contour frames. By default, the new contour plots will
be added to the current contour plots in the report. Click the Remove previous frames
check box to remove the current contour plots and replace them with your new selections.
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Constraint Shading Settings

If you specify limits for the response columns, the areas of the plot that are outside of the

feasible region are shaded. The unshaded white area represents the feasible region.

Figure 4.5 Settings for Contour Shading
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Additional Example of the Contour Profiler

Explore Optimal Settings

Desirability functions are often used to determine the optimal settings for a response surface.

The Maximize Desirability feature in the Prediction Profiler provides one combination of
factor level settings that results in a predicted response that optimizes the desirability.
However, there are often many factor level combinations that can optimize the desirability
function. The Contour Profiler is a useful tool for finding alternative settings that optimize

desirability.
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This example uses the Bounce Data.jmp data table, which contains data for a tire tread
experiment. The response, Stretch, is a function of three variables, Silica, Silane, and Sulfur. A
model is built and the optimal settings are determined such that the value of Stretch
maximizes the desirability function using the Maximize Desirability option in the Prediction
Profiler. You use the Contour Profiler to explore other optimal settings for the specified value
of Stretch.

1. Select Help > Sample Data Library and open Design Experiment/Bounce Data.jmp.
2. Click the green triangle next to the Model script, and then click Run in the launch window.

3. Click the Prediction Profiler red triangle and select Optimization and Desirability >
Maximize Desirability.

Figure 4.6 Maximize Desirability Settings
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The value of Stretch that maximizes the desirability function is 450. One combination of
factor level settings that results in a predicted Stretch of 450 is Silica=1.0101, Sulfur =
2.0437, and Silane = 43.5792.

4. Click the Response Stretch red triangle and select Factor Profiling > Contour Profiler.

To ensure that your new setting combinations maximize desirability, you want to make
sure that the settings predict Stretch within 2 units of 450. In addition, you would like a
high level of Silane, a fixed value of 60.
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Figure 4.7 Contour Profiler for Bounce Data.jmp
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The initial plot shows the contour values of Silica and Sulfur for Stretch at 425 and Silane at
50.

5. In the response controls, set the Contour value for Stretch to 450. Set the Lo Limit and High
Limit for Stretch to 448 and 452, respectively. Press Enter.

6. Set the Current X for Silane to 60.
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Figure 4.8 Contour Profiler for Optimal Settings
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The values on the solid red curve are the Silica and Sulfur values that predict Stretch to be 450.
The values within the unshaded band predict values of Stretch between 448 and 452. You can

drag the crosshairs that appear on the plot to the unshaded sections to find specific settings for
Silica and Sulfur. One such setting is seen in Figure 4.8.
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A surface plot is a three-dimensional plot with one or more dependent variables represented by
a smooth surface. You can display up to four dependent variables on the same surface plot.
JMP produces surface plots in the following two situations:

® The Surface Plot platform creates a stand-alone report that contains a surface plot for

formulas. The formulas can be formula columns in your data table or mathematical
formulas that do not involve any data points.

The Surface Profiler option in many model fitting platforms produces a surface plot for the
fitted model in the existing platform report.

Figure 5.1 Example of a Surface Plot
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Overview of the Surface Plot and Surface Profiler

The Surface Plot and Surface Profiler platforms are used to plot points and surfaces in three
dimensions.

Surface plots are available as a separate platform (Graph > Surface Plot) and as options in
many reports (known as the Surface Profiler). The surface plot functionality is similar in both
situations.

The plots can be of points or surfaces or both. When the points are visible in the surface plot,
the points are linked to the data table. You can click the points or use the Brush tool to select
rows in the data table. The colors and markers assigned in the data table are also reflected in
the surface plot.

Surfaces can be defined by a mathematical equation, or through a set of points defining a
polygonal surface. Each surface can be displayed as a smooth surface or as a mesh, with or
without contour lines. The labels, axes, and lighting for the surface plot are fully customizable.

The Surface Plot is built using the 3D scene commands from the JMP Scripting Language
(JSL). When you right-click in the surface plot, the pop-up menu contains Open GL Scene
commands. For more information about the Open GL Scene commands, see the
Three-Dimensional Scenes chapter in the Scripting Guide.

Example of the Surface Plot Platform

This example uses the Tiretread.jmp sample data table. There are three factors (SILICA, SILANE,
and SULFUR) and four responses (ABRASION, MODULUS, ELONG, and HARDNESS). This data
table already contains saved prediction formula columns for the four response variables. Use
these prediction formula columns to examine the surfaces of two of the response variables.

1. Select Help > Sample Data Library and open Tiretread.jmp.

2. Select Graph > Surface Plot.

3. Select Pred Formula ABRASION and Pred Formula MODULUS, click Columns, and then click
OK.
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Figure 5.2 Initial Surface Plot Report
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Initially, only the prediction surface for ABRASION appears in the plot. Note that in the
Independent Variables report, there is a large difference between the values for
ABRASION and MODULUS. The two responses are on different scales.

4. Inthe Dependent Variables report, select Both Sides from the Surface list for Pred Formula
MODULUS.

5. Click the Surface Plot red triangle and select Scale response axes independently.
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Figure 5.3 Prediction Surface for ABRASION and MODULUS
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Pred Formula ABRASON is on one Z axis and Pred Formula MODULUS is on the other Z
axis. Each response has its own scale. In this plot, the two factors considered are SILICA
and SILANE. You can rotate the surface plot by clicking and dragging inside the graph.
This enables you to view the prediction surfaces from different perspectives. For example,

in Figure 5.4, you can see that predictions for ABRASION and MODULUS based on the
two listed predictors have a similar surface shape, just on a different scale. Use the

Independent Variables controls to see how different combinations of predictors affect the
surface plot.

Tip: To see the original view after rotating, right-click anywhere on the surface plot and select
Reset.
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Figure 5.4 Rotated Prediction Surfaces
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Launch the Surface Plot Platform

The Surface Plot Profiler can be accessed in the following ways:

To launch the Surface Plot Profiler platform directly, select Surface Plot from the Graph
menu. If there is a data table open, this displays the window in Figure 5.5. If you do not

want to use a data table for drawing surface plots, click OK without specifying any

columns. If there is no data table open, you are presented with the default surface plot

shown in Figure 5.13.

The Surface Plot Profiler can be accessed as a red triangle menu option in many modeling
platforms. In the red triangle menus, it is referred to as Surface Profiler. See “Where to

Find JMP Profilers” on page 27 in the “Introduction to Profilers” chapter for more
information about the availability of the Surface Profiler in different platforms.

The Surface Plot Profiler can be accessed from the Model Comparisons platform. Select
Profiler from the Model Comparisons red triangle menu. Then, select Surface Profiler from

the Profiler red triangle menu.



Chapter 5 Surface Plot 101
Profilers Launch the Surface Plot Platform

o ‘l',"ﬂ’o The Surface Plot Profiler can be accessed from the Formula Depot platform. Select
Profiler from the Formula Depot red triangle menu and select the models to be profiled.

Then, select Surface Profiler from the Profiler red triangle menu.

Figure 5.5 Surface Plot Launch Window
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[T] Scale response axes independently

Columns Specifies the columns that you want to plot. Only numeric variables can be
assigned to the Columns role.

By Specifies a variable to create separate surface plots for each level of the variable.

Scale response axes independently Assigns a separate scale to each response on the surface
plot.

Note: When not selected, the axis scale for all responses is the same as the scale for the first
item entered in the Columns role.
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The Surface Plot Report

The initial Surface Plot report shows the surface plot, the appearance controls, the
Independent Variables controls, and the Dependent Variables controls. If more than one
prediction formula column is specified, only the first surface is displayed in the initial report.
However, if more than one observed response column is specified, all points are displayed in

the initial report.

Figure 5.6 Example of the Surface Plot Report
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The Surface Plot

Grid —=r—— [

The surface plot has the following controls and settings:

Rotate Click anywhere that the cursor appears with a circular arrow icon

plot and drag to rotate the plot in any direction.

on the surface

Note: The Up, Down, Left, and Right arrow keys can also be used to rotate the plot.

Axis Settings Double-click an axis to reveal the axis settings window. The axis settings
window enables you to change the scale, tick mark increment, and axis label settings. Like
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other JMP graphs, the axes can be adjusted, stretched, and compressed using the grabber
tool. Place the cursor over an axis to use the grabber tool.

Lights By default, the plot has lights shining on it. There are eight control knobs on the plot
for changing the position and color of the lights. This is useful for highlighting different
parts of a plot and creating contrast. Four of the eight knobs are shown in Figure 5.7.

You can perform the following actions to adjust the lights shining on the surface:

— Right-click a knob to turn that light on or off. More lights turned on brighten a plot,
and fewer lights darken it.

— Drag a knob to change the position of a light.
— Change the color of a light by right-clicking on the knob. The default color is white.

Figure 5.7 Control Knobs for Lights

Right-click the border to Light is off. Right-click knob
Activated light reset lights. to turniit on.

Y éA\

Appearance Controls

If you select the Surface Profiler option from the red triangle menu of a modeling platform, the
Appearance Control options are different than the Appearance Controls in the stand-alone
Surface Plot platform. See Figure 5.8 for an example of what the Appearance Controls look
like in a modeling platform.

Surface Plot Appearance Controls

The set of controls in the top right of the report enables you to specify the overall appearance
of the surface plot.

Sheet, points The setting for displaying sheets, points, and lines.
Isosurface Changes the display to show isosurfaces. See “Plotting Isosurfaces” on page 113.

Show formula Shows the formula edit box, which enables you to edit the formula of the
surface. The formula edit box appears only if you specified a column that contains a
formula in the launch window.
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Resolution A slider that affects how many points are evaluated for a formula. If the
resolution is too coarse, a function with a sharp change might not be represented very
well. However, if the resolution is set too high, evaluating and displaying the surface is
slower than for lower resolutions.

Surface Profiler Appearance Controls

Figure 5.8 Appearance Controls

£ Appearance

data peints are @ Off
Surface plus Residual
Actual
Residual
Resolution ——=r———
Orthographic projection

Contour | off - |

The Appearance Controls in modeling platforms contain the following controls:

data points are Contains the following options that control the appearance of the data
points:

Off Turns the data points off.

Surface plus Residual Shows the difference between the predicted value and actual
value on the surface.

Actual Shows the actual data points.
Residual Shows the residual values (if they are not off the plot).

Resolution A slider that affects how many points are evaluated for a formula. If the
resolution is too coarse, a function with a sharp change might not be represented very
well. However, if the resolution is set too high, evaluating and displaying the surface is
slower than for lower resolutions.

Orthogonal Projection Changes the view of the graph, such that the axes form right angles.

Contour Determines the placement of the contour lines on the plot in relation to the surface.
Options are off, below, above, and on surface.
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Independent Variables

The Independent Variables report contains the following controls:

X, Y Radio buttons that enable you to select which independent variables are displayed on
the x- and y-axes. This feature is useful when you have more than two independent
variables.

Value The sliders and text boxes set the current values of each variable. These settings are
most important for the variables that are not displayed on the axes. The plot shows the
three-dimensional slice of the surface at the value shown in the text box. Move the slider to
see different slices.

Lock Z Scale Locks the Z axis to its current values. This is useful when moving the sliders
that are not on an axis.

Grid Selecting a check box activates a grid that is perpendicular to the selected variables axis.
The sliders enable you to adjust the placement of each grid. The resolution of each grid can
be controlled by adjusting axis settings. Figure 5.9 shows a surface with the X and Y grids
activated.

Figure 5.9 Activated X and Y Grids

Dependent Variables

The Dependent Variables controls that are available depend on whether you have selected
Sheet, points or Isosurface in the Appearance Controls.
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Controls for Sheet and Points

The Dependent Variables controls that appear by default when Sheet, points is selected are
shown in Figure 5.6.

Formula Enables you to select one or more formulas that are displayed as surfaces in the
plot.

Point Response Column Enables you to select the column that contains values that are
plotted as points.

Style (Menus appear only after you have selected a Point Response Column.) The Style
menu enables you to choose how the points are displayed. The menu has the following
options:

Points Shows individual points, which change according to the color and marker
settings of the row in the data table.

Needles Draws lines from the x-y plane to the points, or, if a surface is also plotted,
connects the surface to the points.

Mesh Connects the points into a triangular mesh.
Surface Overlays a smooth, reflective surface on the points.
Off Points are not shown at all.

Surface Enables you to show or hide the top or bottom of a surface. If Above only or Below
only is selected, the opposite side of the surface is darkened.

Grid, Grid Value Provides a slider and check box that activate a grid for the dependent
variable. You can use the slider to adjust the value at which the grid is drawn. You can also
enter the value into the Grid Value text box above the slider.

Controls for Isosurface

Most of the controls for Isosurface are identical to those of Sheet, points. Figure 5.10 shows the
default controls, illustrating the slightly different presentation.

Figure 5.10 Dependent Variable Controls for Isosurfaces

£ ~|Dependent Variables
Formula Value Surface
[Pred Formula ABRASION ~ | (= [130.11023872266 | [Bothsides ~ |

[editformula v| B —=— U| [Of‘f v|

[editformula v| B —— | D| [Oﬁ: v|

[editformula v| B —— | D| [Oﬁ: v|
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Value Slider and text box that activate an isosurface for the dependent variable. You can use
the slider to adjust the value at which the isosurface is drawn. You can also enter the value
into the text box next to the slider.

Surface Plot Platform Options

The Surface Plot red triangle menu contains the following options:

Control Panel Shows or hides the Control Panel, which includes the controls for
Appearance, Independent Variables, and Dependent Variables.

Scale response axes independently Scales response axes independently. See “Launch the
Surface Plot Platform” on page 100.

Fit to Window Determines whether the plot is resized as you resize the report window.

Auto (default) Bases the scaling on the contents of the plot. For example, a plot with By
variables or used as a Surface Profiler in a Fit Model platform does not stretch to fit the
resized window; the plot extends beyond the viewing area.

On Always fits the plot inside the window.
Off Prevent the plot from resizing.
See the JMP Reports chapter in Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the

platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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Pop-Up Menu Options

You can right-click in the plot area to reveal the following pop-up menu options:

Sheet Properties (Option appears only if you right-click the sheet.) Displays the Sheet

Properties window. Available only if Sheet, points is selected in the Appearance Controls.
See “Sheet or Surface Properties” on page 109.

Surface Properties (Options appears only if you click the surface.) Displays the Surface
Properties window. Available only if Isosurface is selected in the Appearance Controls. See
“Sheet or Surface Properties” on page 109.

Show Legend Shows or hides a legend.

Reset Resets the plot to the original viewpoint. Changes in wall and background color are
not affected.

Settings Opens a window for changing many plot settings. For more information about the

OpenGL Scene commands, see the Three-Dimensional Scenes chapter in the Scripting
Guide.

Figure 5.11 OpenGL View Settings

E% OpenGL View Settings X

Walls

Grids

Axes

Box

Zoom i
Orthographic (]

Perspective =
Marker Size G
Marker Quality =
Marker Transparency =
TextSize ——
Line Width =

Hide Lights Border Shows or hides lighting controls.

Wall Color Enables you to change the plot wall color.

Background Color Enables you to change the plot background color.

Rows Enables you to change row colors or markers, and also exclude, hide, and label points.

Use Hardware Acceleration Provides for faster rendering of the display. For example, if the
plot redraws slowly when rotating, this option can help it redraw faster.

Show ArcBall Provides options for using the ArcBall. The ArcBall is a sphere drawn around
the plot to help visualize the directions of rotation.
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Dependent Variables Options

The Dependent Variables red triangle menu provides the following options:
Formula Shows or hides the Formula column in the Dependent Variables controls.
Surface Shows or hides the Surface column in the Dependent Variables controls.

Points Shows or hides the Point Response Column column in the Dependent Variables
controls.

Response Grid Shows or hides the Grid controls.

Sheet or Surface Properties

If you have selected the Sheet, points option in the Appearance Controls, you can right-click
the sheet inside the plot and select Sheet Properties to reveal a window that enables you to
change the sheet properties. If you are plotting an Isosurface, right-click the surface and select
Surface Properties to reveal a similar window. The Sheet Properties and Surface Properties
windows enable you to modify the appearance of the surface plot, including the surface color,
opacity, and contours. You can also show or hide a mesh that appears on the surface plot.

Figure 5.12 Sheet Properties Window
Surface Both sides - |

FillType  [solid ~|
Solid Color

Mesh Off - |
Contour Off - |

Limit X and ¥ to Point Response Column

Cancel |

Surface Enables you to show or hide the top or bottom of a surface. If Above only or Below
only is selected, the opposite side of the surface is darkened.

Fill Type Enables you to color the surface using a solid color, or continuous or discrete
gradients.

Solid Color (Available only when Solid is selected for Fill Type.) Enables you to choose a
color for the surface.
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Surface Fill (Available only when a gradient is selected for Fill Type.) Specifies the
dependent variable’s surface to which the fill type is applied. When Continuous Gradients
is selected for Fill Type, you can also choose the Custom option for Surface Fill.

Custom (Available only when Continuous Gradients is selected for Fill Type and when
Custom is selected for Surface Fill.) Enables you to specify an equation that defines a
response value. This equation is specified using JSL and can refer to columns in the data
table using column scoping.

Surface Color Theme (Available only when a gradient is selected for Fill Type.) Enables you
to change the color theme for the surface or define a custom color theme. For more
information about color themes, see the Enter and Edit Data chapter in Using JMP.

Gradient Levels (Available only when Discrete Gradients is selected for Fill Type.) Enables
you to specify the number of different colors used on the surface plot.

Surface Color Range (Available only when a gradient is selected for Fill Type.) Enables you
to choose the endpoints for the color gradient. If you choose Data, the endpoints of the
color gradient are determined by the range of the data in the column selected for Surface.
If you choose Axis, the endpoints of the color gradient are determined by the range of the
axis for the dependent variable.

Caution: If you choose Axis for Surface Color Range and change the endpoints of the axis
in the surface plot, the cutoff values for the color gradient change as well.

Lighting Enables you to change the lighting of the surface plot. Choose between None, Low
Reflection, and Normal.

Mesh Enables you to turn on or off a surface mesh, for either the X or Y directions or both.

Mesh Color (Available only when a value other than Off is selected for Mesh.) Enables you
to select the color for the surface mesh.

Contour Enables you to turn on or off a contour grid, either above, below, or on the surface.
If turned on, the Contour Color option is revealed enabling you to change the color.

Contour Color (Available only when a value other than Off is selected for Contour.) Enables
you to select the color for the contour grid.

Limit X and Y to Point Response Column Enables you to limit the range of the plot to the
range of the data in the Point Response Column, if one is activated. If checked, this option
essentially restricts the plot from extrapolating outside the range of the data in the Point
Response Column.
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Note: The equivalent JSL command for this option is C1ip Sheet( Boolean ). You can
send this message to a particular response column by appending the number of the
response column. For example, C1ip Sheet2( 1 ) limits the range of the plot to the range
of the data of the second response column. See the Scripting Index in the JMP Help menu
for an example.

Keyboard Shortcuts

The following keyboard shortcuts can be used to manipulate the surface plot.

Table 5.1 Surface Plot Keyboard Shortcuts

Key Function

left, right, up, and down arrows spin

Home, End diagonally spin

Enter (Return) toggles ArcBall appearance
Delete roll counterclockwise
Control boost spin speed 10X

Shift allows continual spinning

Additional Examples of the Surface Plot Platform

* “Construct a Surface Plot for a Single Mathematical Function”

¢ “Plotting Isosurfaces”

Construct a Surface Plot for a Single Mathematical Function

You can use the Surface Plot platform to produce the graph of a mathematical function
without any data points.

1. Select Graph > Surface Plot.

Note: This can be done with or without a data table open.
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2. Click OK.

When you click OK in the Surface Plot launch window without selecting any columns, the
default surface plot report appears. If no data tables are open, the launch window does not

appear and this step can be skipped.
3. Inthe Appearance Controls, select the Show Formula check box to show the formula space.

Figure 5.13 Default Surface Plot with Formula

4 |« |Surface Plot
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7] Lock Z Scale
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[e) 2 > o]
o @
4 |»| Dependent Variables
Surface Grid Value
= Eoth sides -
if(x <= 2.5, sin{sqri{x*x+y*y) ), if{y <=25,y/5,-1))

[ off -

o

=

Grid ——=—— [0

The default function shows in the box. To plot your own function, enter it in this box.
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Additional Examples of the Surface Plot Platform

Isosurfaces are the 3-D equivalent to a 2-D contour plot. An isosurface requires a formula with
three independent variables. The Resolution slider determines the # x n x n cube of points
over which the formula is evaluated. The Value slider in the Dependent Variable section
selects the isosurface (that is, the contour level) value.

This example uses the Tiretread.jmp data table. The RSM for 4 Responses script produces a
response surface model for dependent variables ABRASION, MODULUS, ELONG, and
HARDNESS. The predicted formulas for these four responses are in the data table.

1.
2.
3.

click Columns.
Click OK.

Select Help > Sample Data Library and open Tiretread.jmp.
Select Graph > Surface Plot.
Select Pred Formula ABRASION, Pred FormulaMODULUS, and Pred FormulaELONG and

Select the Isosurface radio button in the appearance controls.

variables.

Figure 5.14 Isosurface of Three Variables
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For the tire tread data, one might set the abrasion at a fixed minimum setting and the
elongation at a fixed maximum setting. Use the MODULUS slider to see which values of
MODULUS are inside the limits set by the other two surfaces.
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The Mixture Profiler displays response contours on a ternary plot for mixture models, where
three or more factors in the model are components (ingredients) in a mixture. The Mixture
Profiler is useful for visualizing and optimizing response surfaces resulting from mixture
experiments.

Figure 6.1 Mixture Profiler Example
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Overview of the Mixture Profiler

The Mixture Profiler shows response contours on a ternary plot for mixture models, where
three or more factors in the model are components (ingredients) in a mixture. The Mixture
Profiler is useful for visualizing and optimizing response surfaces resulting from mixture
experiments.

Many of the Mixture Profiler features are similar to those of the Contour Profiler as described
in “Contour Profiler Platform Options” on page 89. Unique to the Mixture Profiler is the use of
a ternary plot.

Ternary Plot Overview

A ternary plot is a two-dimensional representation of three mixture components that sum to a
constant. The plot is an equilateral triangle with an edge for each component. When
unconstrained, each vertex of the triangle corresponds to a pure blend where one component
is 1 (100%) and all other components are 0. When components are constrained, the feasible
mixtures are represented by a portion of the ternary plot. Shading is used to exclude infeasible
portions of the plot.

Figure 6.2 displays three components P1, P2, and P3. The three components are unconstrained
with the range of each proportion ranging from 0 to 1 (100%). Three points are labeled with
their coordinates (P1, P2, P3). One point (0.2, 0.2, 0.6) includes blue lines along the axis grid
lines for each mixture component to guide you in reading the axes.
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Figure 6.2 Ternary Plot Example
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The ternary plot can display only three components at a time. For a model with more than
three components, the total of the three on-axis (displayed) components is 1 minus the total of
the off-axis (non-displayed) components. The plot axes are scaled such that the maximum

value a component can attain is 1 minus the total for the off-axis components.

Figure 6.3 shows the Mixture Profiler Ternary Plot for an experiment with 5 factors. The Five
Factor Mixture.jmp data table is being used, with the Y1 Predicted column as the formula. The

on-axis factors are x1, x2, and x3, and the factors x4 and x5 are off-axis. There are no

constraints on any of the mixture components. Note that all Lo Limit values are set to 0 and all
Hi Limit values set to 1. The value for x4 is 0.1 and the value for x5 is 0.2, for a total of 0.3. The
sum of x1, x2, and x3 is equal 1 — 0.3 = 0.7. Note that the maximum value for a plot axis is now

0.7, not 1.

If you change the value for either x4 or x5, then the values for x1, x2, and x3 change,

maintaining their relative proportions, to accommodate the constraint that factor values sum

to 1.
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Figure 6.3 Ternary Plot with Scaled Axes to Account for Off-Axis Factors
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Example of the Mixture Profiler

This example uses the Plasticizer.jmp sample data table There are three mixture components
(p1, p2, and p3) and one response (Y). There are constraints on the component levels. This data
table already contains a saved prediction formula column for the response.

1. Select Help > Sample Data Library and open Plasticizer.jmp.
2. Select Graph > Mixture Profiler.

3. Select Pred Formula Y and click Y, Prediction Formula.

4

Select Y from the Y, Prediction Formula role and click Remove.

Note: The Y column role is set to Y in the Columns list. The role automatically assigns
columns in launch windows. In this case, the Y column was assigned to the Y role when
the mixture profiler was launched. However, the Y column does not contain a formula,
and the Mixture Profiler Y column requires a formula column.
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5. Click OK.

Figure 6.4 Example of Mixture Profiler
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Use the factor sliders to explore how changes impact the response. The unshaded region is
the feasible region for this data set.

Launch the Mixture Profiler Platform

The Mixture Profiler can be accessed in the following ways:

* The Mixture Profiler can be accessed directly from the Graph menu. When you access the
Mixture Profiler in this way, the Mixture Profiler launch window appears. See “Profiler
Launch Windows” on page 28 in the “Introduction to Profilers” chapter.

e The Mixture Profiler can be accessed as a red triangle menu option in many modeling
platforms. See “Where to Find JMP Profilers” on page 27 in the “Introduction to Profilers”
chapter for more information about the availability of the Mixture Profiler in different
platforms.
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* The Mixture Profiler can be accessed from the Model Comparisons platform. Select
Profiler from the Model Comparisons red triangle menu. Then, select Mixture Profiler
from the Profiler red triangle menu.

o #ﬂb The Mixture Profiler can be accessed from the Formula Depot platform. Select

Profiler from the Formula Depot red triangle menu and select the models to be profiled.
Then, select Mixture Profiler from the Profiler red triangle menu.

The Mixture Profiler Report

The initial Mixture Profiler report shows a mixture profiler plot, factor settings and controls,
and response settings and controls.

® “Factor Settings and Controls”

* “Response Settings and Controls”

Factor Settings and Controls

Figure 6.5 Factor Settings and Controls

T L R Factor Current X Lo Limit Hi Limit
o pl —— 0.6615 0.474 0.pag| Chanae
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T,L, R Radio buttons to control factor assignments to the axes in the mixture profiler plot. T
= top, L = left, and R =right.

Factor The list of factors.

Current X The current factor settings. Click in a box to change the value of a factor. The
values for the other factors adjust proportionally to maintain the mixture sum. The slider
controls can also be used to change factor settings.

Lo Limit The lower limit on each factor. Click in a box to change the value.

Hi Limit The upper limit on each factor. Click in a box to change the value.

Note: When factor limits are used, the profiler shows regions that are feasible as
unshaded.

Change Opens the Factor Settings window. See “Mixture Profiler Platform Options” on
page 122
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Response Settings and Controls

Figure 6.6 Response Settings and Controls
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Response The list of one or more responses.

Contour The current value of the contour on the mixture profiler. Click in the box to change
the value. The slider control can also be used to change the value of the contour.

Current Y The predicted response based on the current X settings. The value is at the center
of the cross hairs on the profiler plot. This value updates as the factor settings are changed.

Lo Limit Enables you to set a lower limit for your response.

High Limit Enables you to set an upper limit for your response.

Note: When response limits are used, the profiler shows regions that are feasible as unshaded.

Mixture Profiler Platform Options

Specify Factor Values Opens a dialog for specifying factor values. The entered values
should sum tol. If needed, JMP adjusts the specified values to feasible settings. The option
is also available from the Change button on the report window.

Show Points Shows or hides the individual points on the plot.

Show Current Value Shows or hides the three-way crosshairs on the plot. The intersection of
the crosshairs represents the current factor values. The Current X values above the plot give
the exact coordinates of the crosshairs.

Show Constraints Shows or hides the shading resulting from any constraints on the factors.
Those constraints can be entered in the Lo Limits and Hi Limits columns above the plot, or
in the Mixture Column Property for the factors.

Up Dots Shows or hides the dotted lines corresponding to each contour. The dotted lines
show the direction of increasing response values, so that you get a sense of direction.

Contour Grid Draws contours on the plot at intervals that you specify.

Remove Contour Grid Removes the contour grid if one is on the plot.
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Factor Settings A submenu of commands that enables you to save and transfer the Mixture
Profiler settings to other parts of JMP. For more information on this submenu, see the
discussion of the profiler in “Factor Settings” on page 46.

Customizations for the Mixture Profiler

Customize the Mixture Profiler by right-clicking on the plot, and selecting Customize.

Contour Alter line color, fill color, and level of line transparency. If there are multiple
contour lines on the plot, each appears individually on the list of options.

Component Constraints Alter component constraint display properties.
Linear Constraints Alter linear constraint display properties.

Grid Lines Use Axis Settings window to modify grid lines.

Reference Lines Use Axis Settings window to modify reference lines.

Double-click an axis on the plot to view the Axis Settings window. Here you can specify axis
properties in detail, such as tick marks, grid lines and reference lines.

Crosshairs Alter the display properties of the crosshairs on the plot.

Marker Alter the display properties of the plot marker.

Linear Constraints

The Mixture Profiler can display linear constraints. To do this, a Constraint Table Script must
be part of the data table. For more information about creating the Table Script, see “Linear
Constraints” on page 34 in the “Introduction to Profilers” chapter.

When using constraints, unfeasible regions are shaded in the profiler. Figure 6.7 shows an
example of a mixture profiler with shaded regions due to four constraints. The unshaded
portion is the resulting feasible region. The constraints are below:

e 4*p2+p3<0.8
* p2+15"p3<0.4
e pl+2*p22>0.8
e pl+2%p2<0.95
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Figure 6.7 Shaded Regions Due to Linear Constraints
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Additional Examples of the Mixture Profiler Platform

e “Mixture Variables with a Process Variable”

* “Multiple Responses with Five Mixture Variables”

Mixture Variables with a Process Variable

This example uses the Fish Patty.jmp sample data table. The data, adapted from Cornell (1990),
comes from an experiment to optimize the texture of fish patties. The columns Mullet,
Sheepshead, and Croaker are mixture components. Each column represents the proportion of
a fish type in the fish patty. The Temperature column is a process variable. It is the oven
temperature used to bake the patties. The column Rating is the response and is a measure of
texture acceptability, where higher is better. A response surface model was fit to the data and
the prediction formula was stored in the column Predicted Rating.

1. Select Help > Sample Data Library and open Fish Patty.jmp.
2. Select Graph > Mixture Profiler.

3. Select Predicted Rating and click Y, Prediction Formula.

4. Click OK.
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Figure 6.8 Initial Output for Mixture Profiler
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5. The manufacturer wants the rating to be at least 5. Use the slider control for Predicted
Rating to move the contour close to 5. Alternatively, you can enter 5 in the Contour edit box

to set the contour to 5.
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Figure 6.9 Contour Showing a Predicted Rating of 5

4 = Profiler
4 [»|Mixture Profiler
T L R Factor CurrentX  Lolimit _Hilimit
@ Mullet = 0.2333222 0 1| =hanae
® O Sheepshead —= 0.2333222 0 1
® Croaker =5 0.2333222 0 1
Temperature ——=—— 400 375 425

Response Contour CurrentY LoLimit  HiLimit
~— Predicted Rating —————1» 5 4,55 )

0
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1 0.9
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The Up Dots shown along the contour indicate the direction of increasing Predicted Rating.

6. Enter 5 in the Lo Limit edit box for the Predicted Rating. The resulting shaded region
represents factor combinations that yield a rating less than 5. To produce patties with at
least a rating of 5, the manufacturer can set the factors values anywhere in the feasible
(unshaded) region. The region has small proportions of Croaker (<10%), mid to low
proportions of Mullet (<70%) and mid to high proportions of Sheepshead (>30%). This
region is for a baking temperature of 400 degrees.
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Figure 6.10 Contour Shading Showing Predicted Rating of 5 or More.

4 =|Profiler
4 = Mixture Profiler
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7. Move the slide control for Temperature to observe how the feasible region changes for
different temperature settings.

Additional analyses might include:

* Optimize the response across all four factors simultaneously. See the “Custom Profiler”
chapter on page 133 or “Desirability Profiling and Optimization” on page 49 in the
“Profiler” chapter.

* Simulate the response as a function of the random variation in the factors and model noise.
See the “Simulator” chapter on page 141.

Multiple Responses with Five Mixture Variables

This example uses the Five Factor Mixture.jmp sample data table. There are five components
(x1 to x5), one categorical process factor (Type), and three responses, Y1, Y2, and Y3. A
response surface model is fit to each response and the prediction equations are saved in Y1
Predicted, Y2 Predicted, and Y3 Predicted.

1. Select Help > Sample Data Library and open Five Factor Mixture.jmp.
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2. Select Graph > Mixture Profiler.
3. Select Y1 Predicted, Y2 Predicted, and Y3 Predicted and click Y, Predicted.
4. Click OK.
5

Enter 3 in the Contour edit box for Y3 Predicted so that the contour is visible on the plot.

Figure 6.11 Mixture Profiler with Y3 Predicted Contour Set to 3

4 [=|Mixture Profiler

T L R Factor Current X LoLimit  HiLimit
o X 0.2296414 01 0g| Change
® O x2 03292305 02 07
O] 0.2275595 01 06
X4 0.1059883 0.05 02
X5 = 0.1075804 0.05 02
Type =r——— 0jL1 -05 15
Response Contour CurrentY  LoLimit  Hilimit
— Y1 Predicted ———— 25 0.8690262
— ¥2 Predicted —————— 10 5.814812
— ¥3 Predicted ———=F— 3] 3.8027478

0
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-

2
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Pag

0
0.7864314 0.7077882 0.6291451 0.550502 0.4718588 0.3932157 0.3145726 0.23592%4 0.1572863 0.0786431 0
x2

A few items to note about the output.

* The on axis factors are X1, X2, and X3 as indicated by the axes labels and the radio buttons
in the factor settings. All of the factors have low and high limits, which were entered
previously as Column Properties. See The Column Info Window chapter in Using JMP for
more information about entering column properties. Alternatively, you can enter the low
and high limits directly by entering them in the Lo Limit and Hi Limit boxes.

® The white unshaded region is the feasible region. This is determined by the factor limits.

e The on-axis factors, x1, x2, and x3, radio buttons are selected.
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* The categorical factor, Type, has a radio button, but it cannot be assigned to the plot. The
current value for Type is L1, which is listed immediately to the right of the Current X box.
The Current X box for Type uses a 0 to represent L1.

e All three prediction equations have contours on the plot and are differentiated by color.

Suppose the manufacturer desires to hold Y1 less than 1, Y2 greater than 8 and Y3 between 4
and 5, with a target of 4.5. The Mixture Profiler can help you investigate the response surface
and find optimal factor settings.

6. Enter 1in the Y1 Predicted Hi Limit edit box. Enter 8 in the Y2 Predicted Lo Limit edit box.
Enter 4 in theY3 Predicted Lo Limit edit box and 5 in the Y3 Predicted Hi Limit edit box.

7. The feasible region remains white (unshaded). Use the Response slider controls to position
the contours in the feasible region. Alternatively, move the cross hair into the feasible
region

Figure 6.12 Feasible Region After Setting Response Limits

4 =|Mixture Profiler
T L R Factor Current X LoLimit  HiLimit
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X4 ——=—— [0.1059883 0.05 02
X5 ———— [ 0.1075804 005 02
Type —r——— ol 05 15
Response Contour CurrentY| LoLimit HiLimit
— ¥1 Predicted ——{x—> 25| 0.8690262 ) 1
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8. Select the magnifier tool p to zoom in on the feasible region.
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Figure 6.13 Ternary Plot with Enlarged Feasible Region
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The manufacturer wants to maximize Y1, minimize Y2, and have Y3 at 4.5.

9. Use the slider controls or Contour edit boxes for Y1 Predicted to maximize the red contour
within the feasible region. The Up Dots show direction of increasing predicted response.

10. Use the slider controls or Contour edit boxes for Y2 Predicted to minimize the green
contour within the unshaded region.

11. Enter 4.5 in the Contour edit box for Y3 Predicted to set the blue contour to the target
value.

The resulting three contours do not all intersect at one spot. Y1 and Y2 cannot be optimized
with Y3 on target, so you have to compromise. Position the three-way crosshairs in the middle
of the contours to explore the factor levels that produce those response values. Note that these
response contours are for the current settings of x4, x5, and Type.
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Figure 6.14 Factor Settings for Optimal Results
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12. Click the Mixture Profiler red triangle and select Factor Settings > Remember Settings to
save the current settings. The settings are appended to the bottom of the report window.

Figure 6.15 Remembered Settings

£~ Remembered Settings
Setting X1 X2 X3 X4 X5 Type Y1 Predicted Y2 Predicted Y3 Predicted
(O Setting1 0.1352764 0.359975  0.29118 0.1059883 0.1075804 L1 0.9244518 8.5514568 4.3705523

With the current settings saved, you can now change the values of x4, x5 and Type to explore
their impact on the feasible region. You can compare the factor settings and response values
for each level of Type by referring to the Remembered Settings report.
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Custom Profiler
Explore Response Surfaces Using a Numerical Calculator

The Custom Profiler enables you to optimize factor settings without graphical output. This is
useful for large problems that would have too many graphs to visualize well.

Figure 7.1 Custom Profiler Example

A = Profiler
£ = |Custom Profiler
Factor Current X Lock Lo Limit Hi Limit
SILICA :: 1.25 [0 0.3835 2.0165
SILAME :: 5000 3367 Ho.33
SULFUR ——=——— 2.25 0 1.4835 3.1165
Response CurrentY Lolimit  HiLlimit Benchmark
Pred Formula ABRASION <F——=]———> 130.55088 . .| 129.55088

Reset Benchm ark|

£ Optimization

" Formula
Convergence Convergence
Objective  Trips Max Cycles Max Iter Limit Criterion
139.55088213 20 50 250 0.000001 0

Mazximize - |[ Optimize
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Overview of the Custom Profiler

The Custom Profiler enables you to optimize factor settings without graphical output. The
Custom Profiler can be used for problems of any size. It is especially useful for large problems
where the standard graphical profiler has too many graphs to visualize well.

The Custom Profiler report has many fields in common with other profilers. The Benchmark
field holds a value, or benchmark, of the predicted response. You can compare new results to
the benchmark value and update the value based on the current factor settings.

The Optimization report enables you to specify the formula to be optimized and specifications
for the optimization.

Figure 7.2 Custom Profiler

A = Profiler
4 = Custom Profiler
Factor Current X Lock Lo Limit Hi Limit
SILICA :‘: 125 0.3835 20165
SILAME :: 50 3367 66.33
SULFUR, ———— 2.25 14835 31165
Response CurremtY LolLimit HilLimit Benchmark
Pred Formula ABRASION <{——=]———> 139.55088 . .| 139.55088

Rezet Benr_hmark|

£ Optimization

I Formula
Convergence Convergence
Objective  Trips Max Cycles Max Iter Limit Criterion
139.55088213 20 50 250 0.000001 0

Maxirmize - |[ Optirmize

Example of the Custom Profiler

This example uses data that demonstrates the flow of water through a borehole that is drilled
from the ground surface through two aquifers. You want to optimize the predicted value.

1.

Select Help > Sample Data Library > Design Experiment and open Borehole Latin
Hypercube.jmp

Select Graph > Custom Profiler.
Select prediction formula and click Y, Prediction Formula.
Click OK.



136

Custom Profiler Chapter 7
Example of the Custom Profiler Profilers

Figure 7.3 Custom Profiler Report

£ = |Profiler
£ = Custom Profiler

Factor Current X Lock Lo Limit Hi Limit
R c 4 01|71 | 0.0501187 0.1513561
R - 25000 ] 100| 50118723
Tu - 893351 63070| 115600
Hu - 10501 990 1110
HI - 760 ] 700 820
L - 1400/] 1120 1680
K ¢ - 10950 ] 9855 12045
loglOR ¢ - 335/ 2 47
Response CurrentY Lolimit HiLimit Benchmark
prediction formula <} ) 1> 70.826925 . .| 70.826025

Reset Ben chmark|

< Optimization

P Formula
Convergence Convergence
Objective  Trips Max Cycles Max Iter Limit Criterion
70.826025404 20 50 250 0.000001 0

Maximize v| Optimize|

Note that the Benchmark value is 70.83. The Current Y value is also 70.83. This value is the
predicted response with all factors set to their mean values.

You would like to find the X values of the factors that optimize the predicted value.
However, of the factors in the model, only those related to the borehole can be
manipulated in practice. The other factors are out of human control. You can lock the
uncontrollable factors at their mean values and optimize the factors that can be controlled.

Note: To view the description of a factor, right-click the corresponding column in the data
table and select Column Info.

In the Custom Profiler Report, select the Lock check box next to R, Tu, Hu, HI, and log10 R.
In the Custom Profiler Report, click Optimize.
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Figure 7.4 Optimized Custom Profiler Report

£ = |Profiler

£ = Custom Profiler

Factor Current X Lock Lolimit  HiLimit
Rw C 1) 0.1513561 0.0501187| 0.1513561
R iy 25000 ¥ 100| 50118723
Tu iy 89335 [ 63070 115600
Hu iy 1050 (¥ 990 1110
HI iy 760 [ 700 820
L F ) 1120 1120 1680
Kw C L) 12045 0855 12045
loglOR ¢ iy ) 335 2 47
Response CurrentY Lolimit HiLimit Benchmark
prediction formula <f iy {) 221.6604 . .| 70.826025
Reset Benchmark|
< Optimization
I’ Formula
Convergence Convergence
Objective  Trips Max Cycles Max Iter Limit Criterion
221.66030196 20 50 250 0.000001 0
Maximize - |

The optimization routine found an optimum predicted response at 221.66. In order to
obtain the optimum of 221.66, Rw and Kw are set to their maximum values and L is set to
its minimum value. The optimum is greater than the initial Benchmark value of 70.83.

Launch the Custom Profiler Platform

The Custom Profiler can be accessed in the following ways:

The Custom Profiler can be accessed directly from the Graph menu. When you access the
Custom Profiler in this way, the Custom Profiler launch window appears. See “Profiler
Launch Windows” on page 28 in the “Introduction to Profilers” chapter.

The Custom Profiler can be accessed as a red triangle menu option in many modeling
platforms. See “Where to Find JMP Profilers” on page 27 in the “Introduction to Profilers”
chapter for more information about the availability of the Custom Profiler in different
platforms.

The Custom Profiler can be accessed from the Model Comparisons platform. Select
Profiler from the Model Comparisons red triangle menu. Then, select Custom Profiler
from the Profiler red triangle menu.

pro The Custom Profiler can be accessed from the Formula Depot platform. Select Profiler

from the Formula Depot red triangle menu and select the models to be profiled. Then,
select Custom Profiler from the Profiler red triangle menu.
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The Custom Profiler Report

The initial Custom Profiler report shows settings and controls for the factors, responses, and
optimization.

* “Factor Settings and Controls”
* “Response Settings and Controls”

* “Optimization Settings and Controls”

Factor Settings and Controls

Figure 7.5 Factor Settings and Controls

Factor Current X Lock Lo Limit Hi Limit
Rw =3[ 01513561 [ ] 0.0501187 | 0.1513561
R ——— 100 [0 100 50118723
Tu ———)| 115600[7] 63070 115600
Hu ———— 1110[7] 990 1110
HI [om—— 70001 700 820
L ———— 1120[7] 1120 1680
Kw ) 12045 7] 0855 12045
logl0R (m—————— 2[00 2 47

Factor The list of model factors.

Current X The current value of each factor. Click in a box to change the value of a factor. The
slider controls can also be used to change factor settings.

Lock Enables you to lock a factor so that it is fixed when the optimization is performed. You
can change a locked factor using the slider or clicking in the box in the Current X column.
The lock applies only to the optimization.

Nominal Column Unlabeled column to the right of the Lock column that lists the current
value of nominal factors.

Note: The Current X column for nominal factors displays a coded (numeric) value for the
current nominal factor.

Lo Limit The lower limit for each factor. Click in a box to change the value.

High Limit The upper limit for each factor. Click in a box to change the value.
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Response Settings and Controls

Figure 7.6 Response Settings and Controls

Response CurrentY LolLimit Hilimit Benchmark
prediction formula ::1 311.17206 ) | 708268925

Reset Benchmark|

Response The list of one or more responses.

139

Current Y The predicted response based on the current X settings. This value updates as the

factor settings are changed.
Lo Limit Enables you to set a lower limit for your response.
High Limit Enables you to set an upper limit for your response.

Benchmark A saved predicted value of the response. Initially, this value is set to the
predicted value when all factors are at their mean value.

Reset Benchmark Updates the benchmark value to the current predicted value.

Optimization Settings and Controls

Figure 7.7 Optimization Settings and Controls

< Optimization

P Formula
Convergence Convergence
Objective  Trips Max Cycles Max Iter Limit Criterion
311.17206129 20 50 250 0.000001 0

[Maximize x |[ Optirnize |

Formula The formula to be optimized. When a single response is used, the expression is the

response column name. When multiple responses are used, the expression is a sum of

desirability functions. You can edit the objective expression.

Objective The current value of the objective function. When a single response is used, the

objective expression is the predicted response. When multiple responses are used, the

objective expression is the desirability function. For more information about desirability

functions, see “Desirability Profiling and Optimization” on page 49 in the “Profiler”

chapter.

Trips The number of random starts in the optimization algorithm. Each trip restarts the

algorithm at a different starting point. This guards against finding local solutions.
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Max Cycles The maximum number of cycles used in the optimization algorithm. Each cycle
is single pass through the input parameters and optimizes each one individually.

Max lter The maximum number of optimization iterations per cycle for each input
parameter.

Convergence Limit The upper limit for the convergence criterion for the optimization
algorithm. If the convergence criterion becomes less than this value, the algorithm stops.

Convergence Criterion The value of the convergence criterion for the optimization
algorithm.

Maximize Enables you to choose to maximize or minimize the objective function.

Optimize Starts the optimization algorithm.

Custom Profiler Platform Options

Factor Settings Contains options identical to the Factor Settings submenu in the Prediction
Profiler. See “Factor Settings” on page 46 in the “Profiler” chapter.

Log lterations Creates a data table that contains iterations of the optimization algorithm.
The data table appears after the Optimize button is clicked.

Alter Linear Constraints Enables you to add, change, or delete linear constraints. The
constraints are used in the Custom Profiler. See “Linear Constraints” on page 34 in the
“Introduction to Profilers” chapter.

Save Linear Constraints Saves existing linear constraints as a data table script that is named
Constraint. See “Linear Constraints” on page 34 in the “Introduction to Profilers” chapter.

Simulator Launches the Simulator. See “Simulator” on page 141 in the “Simulator” chapter.
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Explore the Effects of Variation on Responses

Simulation enables you to discover the distribution of model outputs as a function of the
random variation in the model inputs and noise. The Simulator in the profilers enables you to
define random inputs, run simulations, and produce output tables of simulated values.

In the Prediction Profiler, the Simulator is integrated into the graphical layout. Factor
specifications are displayed below each factor’s profile. A simulation histogram is shown for
each response.

Figure 8.1 Prediction Profiler with Simulator Example
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Overview of the Simulator

Simulation enables you to discover the distribution of model outputs as a function of the
random variation in the model inputs and noise. The Simulator in the profilers enables you to
define random inputs, run simulations, and produce output tables of simulated values.

For example, you can use the simulator to model the defect rate of a process and to explore the
robustness of the defect rate with respect to variation in the model factors. If specification
limits have been set for the responses, they are displayed in the simulation output. The
inclusion of specification limits enables you to perform a prospective capability analysis of the
simulated model. For information about adding specification limits, see the Column Info
Window chapter in Using JMP.

You can access the Simulator through the Prediction, Contour, and Custom Profilers. The
appearance of the Simulator depends on the profiler platform in which it appears.

Prediction Profiler

In the Prediction Profiler, the Simulator is integrated into the graphical layout. Factor
specifications are displayed below each factor’s profile. A simulation histogram is shown on
the right for each response.

Contour Profiler and Custom Profiler

In the Contour and Custom profilers, the Simulator is not integrated into the graphical layout.
There are no integrated histograms, and the interface is textual. However, the process is the
same and the resulting output tables are the same as in other profilers.

Note: The Simulator supports mixture terms. The simulation assigns the random value to
each mixture factor and then proportionally adjusts the values to maintain the factor
constraints.

Example of the Simulator

Use sequencing to examine how the distribution of the response changes when the mean
(sequencing location) and variability (sequencing spread) of the inputs change.

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Select Graph > Profiler.

3. Select Pred Formula ABRASION and Pred Formula MODULUS and click Y, Prediction
Formula.
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4. Click OK.
Click the Prediction Profiler red triangle and select Simulator.

6. Beneath each factor select Random.
Note: The default random distribution is a normal distribution.

7. Change the N Runs value to 1000.

Open Simulate to Table outline and then open the Sequencing outline.

Figure 8.2 Simulator Settings

SILICA SILAME SULFUR
[Random = | [Random = | [Random = |
[Normal = | [Normal = | [Normal = |
Mean 1.25 Mean 50 Mean 2.25
sD 0.3266 sD 6.532 sD 0.3266
4 =|Simulator
< Responses
Pred Formula ABRASION [No Moise - |
Pred Formula MODULUS [No Moise - |
N Runs: 1000
4 Simulate to Table
Make Table|
£ Sequencing
Term  Sequence Number of Steps Lower  Upper

SILICA  (Not Sequenced || 5] 03835 20163
SILANE | Not Sequenced v|| 5] 3367 6633
SULFUR @” 5] 14835] 3.1165]

You want to examine how the responses change as the input factors change locations. To
explore changes in factor mean, use sequence location. To instead explore changes in the
variability of the factor, use sequence spread.

9. For SILICA, select Sequence Location. Leave the number of steps set to 5. Set the Lower
limit to 1 and the Upper limit to 2.

10. For SILANE, select Sequence Location. Leave the number of steps set to 5. Set the Lower
limit to 40 and the Upper limit to 60.

11. For SULFUR, select Sequence Location. Leave the number of steps set to 5. Set the values
Lower limit to 2 and the Upper limit to 3.
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Figure 8.3 Sequencing Settings

£ Sequencing
Term  Sequence Number of Steps Lower  Upper
SILICA Sequence Location « || 5 " 1 " 2 |
SILANE Sequence Location « || 5 " 40 " 60 |
s 2] 3]

SULFUR [ sequence Location ~ |

12. Click Make Table.

Simulator 145
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The SILICA Mean, SILANE Mean, and SULFUR Mean columns contain five steps across their
respective range of values. For example, the Silica Mean values are 1, 1.25, 1.5, 1.75, and 2.
The SILICA, SILANE, and SULFUR columns are the simulated values from a normal
distribution with a mean defined by the corresponding mean columns and a fixed
standard deviation. Pred Formula ABRASION and Pred Formula MODULUS values are
calculated for set of simulated values, so that you can explore how the responses change as

the factor values change.

13. Select Analyze > Distribution.

14. Select SILICA Mean and Pred Formula ABRASION and click Y, Columns.

15. Click OK.

Figure 8.4 Distribution of SILICA Mean by Pred Formula ABRASION
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Click a histogram bar that corresponds to a SILICA Mean to see how the predicted value for
abrasion varies across the simulated silane and sulfur ranges given the selected value of silica.
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Launch the Simulator

The Simulator can be accessed as a red triangle menu option in the Prediction Profiler, the
Contour Profiler, and the Custom Profiler. When you launch the Simulator from the
Prediction Profiler, factor specifications are displayed below each factor’s profile. When you
launch the Simulator from the Contour or Custom profilers, factor specifications appear in a
Factors report, located below the respective profiler report. See “Factors Simulation Settings”
on page 146.

Once the Simulator is accessed, you can define simulation parameters for the responses in the
Responses report. See “Response Simulation Settings” on page 149. The Responses report also
enables you to set the number of simulations.

A histogram is also added to the right of each response when the Simulator is accessed from
the Prediction Profiler. Below the histograms is a Simulate button. Once you specify settings
for the factors and responses, click Simulate to simulate response values. The histograms of
the simulated responses are updated each time the simulate button is clicked. To simulate
responses in the Contour and Custom profilers, open the Simulate to Table report and click
Make Table. See “Defect Profiler” on page 150.

Factors Simulation Settings

By default, factors (inputs) and responses (outputs) are defined by the functions that you
select when the Profiler is launched. Simulation options enable you to modify how your
factors and responses are simulated. There are controls for location, error, and noise.

Fixed Fixes the factor at the current value in the profiler for all simulation runs.

Random Draws a random value of the factor for each simulation run from the specified
distribution and distributional parameters. When you select Random, distribution options
appear. For more information about the options, see “Continuous Factors” on page 147
and “Categorical Factors” on page 148.

Note: The default random distribution is a normal distribution with a mean at the current
factor setting and a standard deviation estimated by the range of the factor divided by 5.
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Figure 8.5 Example of Three Random Distributions

[Random = | [Random = | [Random = |
1]
ey 1E
[Normal = | [Normal truncated - | [Triangular =
Mean 1.25 Mean 50 Lower 1.5
sD 03 sD 2 Peak 2
Lower 40 Upper 3
Upper 60

Expression Generates values for the factor based on a JSL expression. This gives you
flexibility to use a random distribution of your choice. For example, you could create a
censored normal distribution that guaranteed nonnegative values with an expression such
as the following:

Max (0,RandomNormal (5,2))

After entering the expression, click the Reset button to submit the expression.

Multivariate = Generates values for the factor based on a multivariate normal distribution.
Specify the mean and standard deviation for each factor. The correlation matrix is defined
separately in the X Correlation Specification report. You can use this option to
accommodate correlated factors.

Figure 8.6 Defining a Correlation Matrix for the Multivariate Option

Multivariate « |

Mean 23
sD 03

£ X Correlation Specification
Factor  SILANE SULFUR
SILICA 0 0.82
SILANE 0

Continuous Factors

Many of the distributions available use standard random functions that are described in the
Formula Functions Reference chapter in Using JMP. Descriptions of the specialized
distributions available follow:

Normal weighted Generates values from a weighted normal distribution with the given
mean and standard deviation. The weighting is a specific sampling scheme used to
simulate rare events from the tails of the distribution. This is a good choice when you want
to simulate very low defect rates. See “Statistical Details for the Simulator” on page 171.

Normal truncated Generates values from a normal distribution limited by lower and upper
limits. Any randomly generated value that exceeds a limit is discarded and another value



148

Simulator Chapter 8
Launch the Simulator Profilers

is generated. This is a good choice when you want to simulate an inspection system where
inputs that do not satisfy specification limits are discarded.

Normal censored Generates values from a normal distribution limited by lower and upper
limits. Any randomly generated value that exceeds a limit is set to that limit, putting a
density mass at the limits. This is a good choice when you want to simulate systems where
inputs that do not satisfy specification limits are reworked until they are at the
specification limit.

Sampled Generates factor values by selecting a value at random from that factor’s column in
the data table.

External Generates factor values by selecting a value at random from a column in another
table. You are prompted to choose the table and column.

Note: The Aligned check box appears when you select Sampled or External. It is used when
two or more factors are set to Sampled or External. When checked, the random draws come
from the same row of the table. This maintains the correlation structure between two columns.
If the Aligned option is used to associate two columns in different tables, the columns must
have the same number of rows.

Categorical Factors

If a factor is categorical, then the random distribution is characterized by probabilities
specified for each category. By default, the probabilities are set to the observed probabilities in
the data table. You can change the probabilities using the handles in the plot or by changing
the numerical values in the Prob column. The probabilities must sum to 1.

Note: If the probabilities that you select do not sum to 1, they are automatically regularized to
sum to 1 once you click the Simulate button.

When the simulation for a factor is set to Random, a graphical representation of the random
distribution density is shown. The graph shows the form of the density for the continuous
distributions, and provides control points that can be dragged to change the distribution. The
drag points for the Normal are the mean and the mean plus or minus one standard deviation.
The Normal truncated and censored add points for the lower and upper limits. The Uniform
and Triangular have limit control points, and the Triangular adds the mode.
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Response Simulation Settings

Simulation settings for the responses enable you to simulate random noise in the responses.
Often your factors explain part of the variation in the response with the rest of the variation of
the response attributed to random noise. This is how the random noise is specified in your
simulation.

No Noise Generates the response from the model based on the factor settings. No random
noise added to the response.

Add Random Noise Adds a normal random value with mean zero and specified standard
deviation to the generated response.

Add Random Weighted Noise Adds an error term to the generated response based on a
weighted sampling scheme used to simulate rare events from the tails of the distribution.

Add Multivariate Noise Adds an error term to the generated response based on a
multivariate normal distribution. Specify the standard deviation for the response. Specify
the correlation structure between responses in the Y Correlation Specification report.

Random by Model (Available only within the Standard Least Squares and Generalized
Regression personalities of the Fit Model platform.) Adds an error term to the generated
response based on the model distribution specified in the Fit Model launch window.

The Simulator Report

The Simulator report contains the following items:

Simulate to Table Contains a Make Table button that saves the results of the simulation to a
data table. If a response has specification limits, the table includes a Y In Spec column that
indicates whether the simulated response is within the specification limits. The table also
includes an Objective column, labeled Obj. If you added Desirability functions to your
profiler prior to simulation, this column is the evaluation of the desirability function. If the
Desirability functions were not present prior to simulation, the column contains all
missing values.

Sequencing (Available only when the distribution is Normal, Uniform, or Triangular
random.) Sequencing enables you to simulate across a range of locations or spreads for
each factor. The simulations are saved to a data table. Select an option to sequence the
location or spread of each factor. Specify the number of steps and the range for the
sequencing. For each combination of the number of steps, the simulation runs N Runs. If
you have two terms, each with 5 steps, and N Runs = 100, the resulting simulation table
has 2,500 rows.
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The Simulator Report Options

The Simulator red triangle menu contains the following options:

Automatic Histogram Update Toggles the histogram update. When this option is selected,
the histograms update with new simulated values when you drag factor setting handles.
By default, this option is not selected.

Defect Profiler (Available only when spec limits are specified.) Shows the defect rate as an
isolated function of each factor. See “Defect Profiler” on page 150.

Defect Parametric Profile (Available when the Defect Profiler is launched.) Shows the defect
rate as an isolated function of the parameters of each factor’s distribution. See “Defect
Parametric Profiler” on page 154.

N Strata (Appears only when you hold down the Shift key before clicking the Simulator red
triangle menu.) Enables you to specify the number of strata for the Normal Weighted
distribution. See “Statistical Details for the Simulator” on page 171.

Set Random Seed (Appears only when you hold down the Shift key before clicking the
Simulator red triangle menu.) Enables you to specify a seed for the simulation starting
point. This enables the simulation results to be reproducible, unless the seed is set to zero.
The seed is set to zero by default. If the seed is nonzero, then the latest simulation results
are output when the Make Table button is clicked.

Simulation Experiment (Available for Normal, Uniform, and Triangular random
distributions.) Runs a designed simulation experiment on the locations of the factor
distributions. A window appears that enables you to specify the number of design points,
the portion of the factor space to be used in the experiment, and which factors to vary in
the experiment. Factors that are not selected for the experiment are set to their current
Profiler value. See “Simulation Experiment” on page 154.

Spec Limits Opens a table to set or edit specification limits for the responses. Click the Save
button to save specification limits to the response column properties in the data table. See
“Specification Limits” on page 155.

Defect Profiler

To use the Defect Profiler, spec limits must be defined for at least one response. The Defect
Profiler shows the probability of an out-of-spec output defect as a function of each factor
while the other factors vary randomly. This is used to help visualize the changes in a factor’s
distribution that the process is most sensitive to, often as part of tolerance design.
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Defect Profiler

Specification limits are used to define a defect, and the random distributions assigned to each
factor are used to simulate responses.

Define at least one of the factors as Random in the simulation settings to obtain useful results.
Otherwise, the simulation outputs are constant and the defect rate is zero if the outcome falls
within spec or one if the outcome falls out of spec.

Tip: If you need to estimate very small defect rates, consider the Normal weighted random
option. This random distribution estimates stable defect rates of just a few parts per million
with only a few thousand simulation runs.

Introduction to Tolerance Design

Tolerance design is the investigation of how defect rates can be controlled by controlling
variability in the input factors.

Input factors have variation. Specification limits are used to define acceptable ranges for each
input. The variability in the input factors impacts the outputs. Specification limits are also
used to define the acceptable range for output variables.

Sometimes, a tolerance design study shows that spec limits on an input are unnecessarily
tight. Loosening such limits can result in reduced costs without sacrificing product quality. In
these cases, tolerance design can save money.

In other cases, a tolerance design study might find that either tighter limits or different targets
result in higher quality. In all cases, it is valuable to understand how the inputs and their
variability impact that the defect rates.

The Defect Profiler shows the defect rate as a function of each factor fixed at the specified
mean value while all other factors are varied according to their random specification. If there
are multiple outputs with spec limits, each has a different colored defect rate curve. A black
curve shows the overall defect rate.
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Figure 8.7 Defect Profiler
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Graph Scale

Defect rates are shown on a cubic root scale, so that both large and small defect rates are
shown in some detail.

Defect Rates

The mean and standard deviation (SD) of the simulated overall defect rate are reported below
each defect profile plot. This mean is calculated by integrating the defect profile curve with
the specified factor distribution. Because of numerical error in the estimations, the overall
mean defect rate reported under each factor can differ slightly.

The defect rates that are reported in the Defect Profiler are estimates of the simulated overall
defect rate. This rate is also reported in the Rate column of the defect table that is in the
Prediction Profiler outline.

Note: The defect table is added to the Prediction Profiler outline after you run a simulation
and one or more of your responses has defined spec limits.

Because the rate estimates are obtained differently, by integration and simulation, they might
differ slightly. If they are very different, you might consider increasing the number of
simulation runs. In addition, verify that the range of the factor scale is wide enough so that the
integration covers the distribution well.
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The standard deviation is a measure of the sensitivity of the defect rate to the factor. It is small
when either the factor profile is flat or the factor distribution has a small variance. The larger
the standard deviation, the larger the impact that changes in that factor have on the defect rate
variability. Comparing SDs across factors enables you to select factors for improvement to
reduce defect rates.

The mean and SD values are updated when you change the factor distribution settings. This is
one way to explore how to reduce defects as a function of one particular factor at a time. You
can click and drag a handle point on the factor distribution and watch the mean and SD
change as you drag. However, changes are not updated across all factors until you click the
Rerun button to generate updated simulation runs.

Simulation Method and Details

Suppose you want a defect profile for factor X1, in the presence of random variation in X2 and
X3. A series of n = N Runs simulation runs is done at each of k points in a grid of equally
spaced values of X1. (By default, k is set at 17.) At each grid point, suppose that there are m
defects due to the specification limits. At that grid point, the defect rate is m/n. These defect
rates are connected and plotted as a continuous function of X1.

Notes

¢ The profile curve is not recalculated automatically when distributions change. Click Rerun
to update the curve.

¢ Defect Profiling does not address the general optimization problem of optimizing quality
against cost, given functions that represent all aspects of the problem. This more general
problem would benefit from a surrogate model and space filling design.

® The defect profiles tend to be uneven when they are low. This is due, in part, to the use of
the cubic scale where differences in low values are exaggerated. Jagged defect profiles
could be due to limited simulation runs. If the overall defect curve (black line) is smooth,
and the individual defect rates are fairly consistent, then your simulation probably has
enough runs to provide a stable solution. If the overall defect rate curve is jagged, then
consider increasing the number of runs. 20,000 runs is generally enough to stabilize the
curves.
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Defect Parametric Profiler

The Defect Parametric Profiler report shows the impact of process changes on the defect rate.
The impacts are based on the simulation parameter settings for each factor. Four scenarios are
considered.

Mean Shift The impact of shifting the mean is shown by a red curve. The current mean is
shown by a red dotted vertical line.

Std Narrow The impact of a reduction in variability is shown by a blue curve. The dotted
blue vertical lines are set at the mean plus and minus one standard deviation. The
minimum value on the curve corresponds to the defect rate when there is no variability.

LSL Chop The impact of inspection to remove all parts below the lower specification limit is
shown by a green curve.

USL Chop The impact of inspection to remove all parts above the upper specification limit is
shown by an orange curve.

Figure 8.8 Defect Parametric Profile
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Simulation Experiment

Use the Simulation Experiment option to run a designed simulation experiment on the
locations of the factor distributions. When you select Simulation Experiment, you to specify
the number of design points, the portion of the factor space to be used in the experiment, and
which factors to include in the experiment. For factors that are not included in the experiment,
the current value set in the Profiler is used in the experiment.
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The experimental design is a Latin Hypercube. At each design point, N Runs random draws
are generated with the design point serving as the center of the random draws. The shape and
variability come from the specified distributions. The output has one row for each design
point. The responses include the defect rate for each response with spec limits and an overall
defect rate. You can use a Gaussian Process model to model the overall defect rate from the
simulation experiment. For more information about Gaussian Process models, see the
Gaussian Process chapter in Predictive and Specialized Modeling.

Specification Limits

To add specification limits to a variable, right-click the desired column and select Column
Properties > Spec Limits. In the Column Properties window, there are boxes to enter values for
the Lower Spec Limit, Target, and Upper Spec Limit. Alternatively, you can define
Specification Limits using the Spec Limits option in the Simulator red triangle menu.

The profilers support specification limits on the responses and provide a number of features:

® In the Profiler, if the Response Limits are not set up in the input data table to provide
desirability coordinates, JMP looks for a Spec Limits column property and constructs
desirability functions appropriate to those spec limits. For more information about
Response Limits see the Column Info Window chapter in Using JMP.

¢ If you use the Simulator to output simulation tables, JMP includes the Spec Limits column
properties in the output data tables. This makes accounting for defect rates and capability
indices easy.

* Adding spec limits enables the Defect Profiler.

Additional Examples of the Simulator

e “Example of the Defect Profiler”
e “Example of Stochastic Optimization”

¢ “Example of Simulating General Formulas”
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Example of the Defect Profiler

To demonstrate a possible workflow with the Defect Profiler, we use Tiretread.jmp. The
experimental data in the Tiretread.jmp sample data table comes from an experiment to study
the effects of SILICA, SILANE, and SULFUR on four measures of tire tread performance.

Add Specification Limits in the Simulator

1.
2.
3.

8.
9.

Select Help > Sample Data Library and open Tiretread.jmp.
Select Graph > Profiler.

Select Pred Formula ABRASION, Pred Formula MODULUS, Pred Formula ELONG, and Pred
Formula HARDNESS and click Y, Prediction Formula.

Click OK.
Click the Prediction Profiler red triangle and select Simulator.

Click the Simulator red triangle and select Spec Limits.

Note: If your columns have spec limits saved as a column property, those spec limits are
shown in the Simulator Spec Limits table.

Set the spec limits as follows:

— For ABRASION set the LSL to 110.

— For MODULUS set the USL to 2000.

— For ELONG set the LSL to 350 and the USL to 550.

— For HARDNESS set the LSL to 66 and the USL to 74.
Click Save to save the Spec Limits to the data table.

Beneath each factor, select Random.

10. For each factor, enter the random specifications as shown in Figure 8.9.

Figure 8.9 Profiler Random Specifications
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Open the Defect Profiler and Defect Parametric Profile

1.

Click the Simulator red triangle and select Defect Profiler.
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Figure 8.10 Defect Profiler
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Note: The defect profiler is based on simulation with random inputs. The values that you
obtain might differ from those shown in Figure 8.10.

The black curves show the overall defect rate for each factor fixed at the X axis value while
all other factors vary.

Consider the overall curve for SILICA. As silica varies, the defect rate goes from the lowest
rate of 0.001 when silica is about 1 and increases quickly up to a defect rate of nearly 1 as
silica increases or decreases from 1. However, SILICA is itself random. If you integrate the
density curve of SILICA, you would estimate the average defect rate to be about 0.03,
which is shown as the Mean for SILICA. This estimate of the overall defect rate estimated
by the simulation is shown in the defect table under the simulation histograms. The Mean
value for the overall defect rate for all factors are similar.

The Defect Profiler also includes an estimate of the standard deviation of the defect rate
with respect to the variation in each factor. This value (labeled SD) is 0.057 for SILICA. The
standard deviation is related to the sensitivity of the defect rate with respect to the
distribution of that factor. Comparing the SD values across the three factors, the SD for
SULFUR is higher than the SD values for SILICA and SILANE. This indicates that to improve
the defect rate, shifting the distribution in SULFUR should have the greatest effect. A
distribution can be shifted by changing its mean, changing its standard deviation, or by
truncating the distribution by rejecting inputs that do not meet certain specification limits.

Click the Simulator red triangle and select Defect Parametric Profile.
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Figure 8.11 Defect Parametric Profile
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Consider SULFUR and note that the current defect rate (0.03) is represented in four ways
corresponding to each of the four curves in the Parametric Profiler.

For the red curve, Mean Shift, the current rate is where the red curve intersects the vertical
red dotted line. The Mean Shift curve represents the change in overall defect rate as the
mean of SULFUR changes. One opportunity to reduce the defect rate is to shift the mean
slightly to the left. If you use the crosshair tool on this plot, you see that a shift down in the
mean reduces the defect rate to about 0.02.

For the blue curve, Std Narrow, the current defect rate is where the blue curve intersects
the two dotted blue lines. The Std Narrow curves represent the change in defect rate as the
standard deviation changes. The dotted blue lines represent one standard deviation below
and above the current mean. The blue curve is drawn symmetrically around the center. At
the center, the blue curve reaches a minimum, representing the defect rate for a standard
deviation of zero. That is, if we totally eliminate variation in SULFUR, the defect rate is
about 0.003. This is much lower than the current rate of 0.03. If you look at the other defect
parametric profile curves, you can see that this is better than reducing variation in the
other factors, something that we suspected by the SD value for SULFUR.

For the green curve, LSL Chop, there are no interesting opportunities for improvement in
the defect rate. The green curve is above current defect rates for the entire range of the
curve. This indicates that reducing the variation by rejecting parts with too-small values
for SULFUR does not help reduce the defect rate.

The orange curve, USL Chop, suggests a way to improve the defect rate. Reading the curve
from the right, the curve starts out at the current defect rate (0.03). Then as you start
rejecting more parts by decreasing the USL for SULFUR, the defect rate improves.
However, moving a spec limit to the center of the distribution is equivalent to throwing
away half the parts, which might not be a practical solution.

Looking at all the opportunities over all factors, it now looks like there are two good
options for further investigation. You could shift the mean of SILICA to about 1 or reduce
the variation in SULFUR. Because it is generally easier in practice to change a process mean
than a process variation, the best first adjustment might be to shift the mean of SILICA to 1.
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3. In the Prediction Profiler, adjust the Mean of SILICA from 1.2 to 1.0.
4. Below the Defect Profiler, click Rerun.

The Defect Profiler updates based on the adjusted SILICA value.

Figure 8.12 Adjusted Defect Rates
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By shifting the mean of SILICA from 1.2 to 1.0, the defect rate has decreased from 0.03 to about
0.004, which is a good improvement. Investigating other defect reduction scenarios is easy to
do by making changes to the distributions and rerunning the simulations.

Example of Stochastic Optimization

This example is adapted from Box and Draper (2007) and uses Stochastic Optimization.jmp. A
chemical reaction converts chemical A into chemical B and B into C. The resulting amount of

chemical B is a function of reaction time and reaction temperature. Use the profiler and

simulator to explore factor settings to optimize the yield of B.
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Figure 8.13 Chemical Reaction

k1 k2

For this reaction the yield of B can be computed using the Arrhenius laws. The column Yield
contains the formula for yield. The formula is a function of Reaction Time (hours) and reaction
rates k1 and k2. The reaction rates are a function of Reaction Temperature (degrees Kelvin) and
known physical constants 6y, 8,, 83, 84. Therefore, Yield is a function of Reaction Time and
Reaction Temperature.

Maximize Yield Using Desirability Function

1. Select Help > Sample Data Library and open Stochastic Optimization.jmp.
2. Select Graph > Profiler.

3. Select Yield and click Y, Prediction Formula.

4. Click Expand Intermediate Formulas and then click OK.

The Prediction Profiler with Desirability Functions enabled appears. For more information
about Desirability Functions, see the “Desirability Profiling and Optimization” on page 49
in the “Profiler” chapter.

5. Click the Prediction Profiler red triangle and select Optimization and Desirability >
Maximize Desirability.

The Prediction Profiler maximizes Yield and sets the graphs to the optimum value of
Reaction Time and Reaction Temperature.

Figure 8.14 Yield Maximum
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The maximum Yield is approximately 0.62 at a Reaction Time of 0.115 hours and Reaction
Temperature of 540 degrees Kelvin, or hot and fast. (Your results might differ slightly due
to random starting values in the optimization process.)

Simulate Defect Rate for Maximum Yield

In a production environment, process inputs cannot always be controlled exactly. What
happens to Yield if the inputs (Reaction Time and Reaction Temperature) have random
variation? Furthermore, if Yield has a spec limit, what percent of batches are out of spec? The
Simulator can help you investigate the variation and defect rate for Yield, given variation in
Reaction Time and Reaction Temperature.

1. Click the Prediction Profiler red triangle and deselect Optimization and Desirability >
Desirability Functions.

2. Click the Prediction Profiler red triangle and select Simulator.

3. Set the simulation parameters for Reaction Temperature to Random > Normal Weighted
with Mean =540 and SD =1.

4. Set the simulation parameters for Reaction Time to Random > Normal Weighted with Mean
=0.115 and SD = 0.03.

5. Set the N Runs value to 15,000.

Figure 8.15 Initial Simulator Settings
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Yield has a lower spec limit of 0.55, set as a column property, and shows in Figure 8.15 as a
dashed red line.
6. Click the Simulate button.

Note: Your numbers might differ from those shown in Figure 8.16 due to the random
draws in the simulation.

Figure 8.16 Simulation Results

4 [=|Prediction Profiler

............ mean
————————_____defective batches

below specification

Yield

0.621252

DP.D.G.D cooa | o
SERsETTEES

defect rate = 6.0%

A Simulate
540 o:. 115468 ° Defect Rate  Mean sSD
Renction i Yield 0.06005 0.60034 0.03442 \
Temperature Time >~ mean and standard
Random = | [Random =

deviation

il

[Normalweighted v| [Normalweighted =

Mean 540 Mean | 0.11547
sD 1 sD 0.03
4 = Simulator
4 Responses
Vield [No Noise -
N Runs:

P Simulate to Table

The predicted Yield is 0.62 for Reaction Temperature of 540 and Reaction Time of 0.115.
The simulation estimates an average defect rate of about 6% with a standard deviation of
0.03 given the assumed variation in the temperature and time. The defect rate of 6.0%,
indicates that about 6.0% of batches would be out of specification.

Use the simulator to explore other settings of Reaction Temperature and Reaction Time that
might maintain a high Yield but with a lower defect rate. Before changing settings, save
these factor settings that give us the maximum Yield for later use.

7. Click the Prediction Profiler red triangle and select Factor Settings > Remember Settings.
8. Type “Max Yield” and click OK.

The settings are appended to the report window.
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Figure 8.17 Remembered Settings for Maximum Yield

£~ Remembered Settings

Reaction Reaction
Setting Temperature Time Yield

O Max Yield 540  0.113468 0.6212525

10.
11.

Set the Mean value for Reaction Temperature to 535.

Using the dashed red line in the Reaction Time plot, you can explore and determine the
approximate value that maximized Yield. This value should be around 0.16.

Set the Mean value of Reaction Time to 0.16.
Click Simulate.

Note: Your numbers might differ from those shown in Figure 8.18 due to the random
draws in the simulation.

Figure 8.18 Defect Rate for Temperature of 535
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By making slight changes to the input factor settings, the defect rate decreases to about
1.8% with a decrease of less than 0.01 in the predicted yield. The fixed (no variability)
settings that maximize Yield are not the same settings that minimize the defect rate in the
presence of factor variation.
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Simulation Experiment

You can run a simulation experiment to find the settings of Reaction Temperature and Reaction
Time that minimize the defect rate. To do this, simulate the defect rate at each point in an
experimental design for Reaction Temperature and Reaction Time. Then fit a predictive model
for the defect rate and find factor settings to minimize the defect rate.

1. Click the Simulator red triangle and select Simulation Experiment.

2. Set the number of experimental runs to 80 and the portion of the design space to 1 to use
the whole factor space in the experiment.

3. Click OK.

A Latin Hypercube design with 80 design points is generated within the specified factor
space, and N Runs random draws are taken at each of the design points. The design points
are the center of the random draws, and the shape and variance of the random draws
come from the factor distribution settings.

A data table is created with the results of the experiment. The Overall Defect Rate is given
at each design point. You can now fit a model that predicts the defect rate as a function of
Reaction Temperature and Reaction Time.

Note: Do not close the Stochastic Optimization Profiler window. You come back to it later.

4. From the new data table, click the green triangle next to the Gaussian Process script.
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Figure 8.19 Results of Gaussian Process Model Fit
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Note: Your results might be slightly different due to the random draws in the simulation.

5. To find the settings of Reaction Temperature and Reaction Time that minimizes the defect
rate, click the Prediction Profiler red triangle and select Optimization and Desirability >
Maximize Desirability.

The desirability function is already set up to minimize the defect rate.
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Figure 8.20 Settings for Minimum Defect Rate
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The settings that minimize the defect rate are approximately Reaction Temperature = 526
and Reaction Time =0.3.

6. Click the Transfer Factor Settings Back button.

This updates the original Profiler report to use the setting for Reaction Temperature and
Reaction Time that minimize the defect rate.

7. Return to the original Profiler report window.
Click the Prediction Profiler red triangle and select Factor Settings > Remember Settings.
Type “Min Defect” and click OK.

Figure 8.21 Minimum Defect Settings
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10. With the new settings in place, click the Simulate button to estimate the defect rate at the
new settings.
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Figure 8.22 Lower Defect Rate
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Simulate
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At the new settings the defect rate is 0.05%. This is much lower than the 6.0% for the
settings that maximize Yield. That is a reduction of about 120x. Recall that the average Yield
from the first settings is 0.62, and the new average is 0.59. The decrease in average Yield of
0.03 is the trade off for lowering the defect rate by 120x.

Because you saved the settings using Remember Settings, you can easily compare the old
and new settings. The Differences report summarizes the difference.

11. Click the Remembered Settings radio buttons to view the profiler for each setting.
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Figure 8.23 Settings Comparison
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The chemist now knows what settings to use for a quality process. If the factors have no
variation, the settings for maximum Yield are hot and fast. But, if the process inputs have
variation similar to what we have simulated, the settings for maximum Yield produce a
high defect rate. Therefore, to minimize the defect rate in the presence of factor variation,
the settings should be cool and slow.

Example of Simulating General Formulas

Though the profiler and simulator are designed to work from formulas stored from a model
fit, they work for any formula that is stored in a column. A typical application of simulation is
to exercise financial models under certain probability scenarios to obtain the distribution of
the objectives. This can be done in JMP. The key is to store the formulas into columns, set up
ranges, and then conduct the simulation.

1. In the JMP Home Window, select File > New > Script. This opens a new script window.

2. Copy and paste the following JSL script into the new script window.

dt = New Table( "Sales Model" );
dt << New Column( "Unit Sales", Values( {1000, 2000} ) );
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dt << New Column( "Unit Price", Values(C {2, 4} ) );
dt << New Column( "Unit Cost", Values( {2, 2.5} ) );
dt << New Column( "Revenue",
Formula( :Unit Sales * :Unit Price )
s
dt << New Column( "Total Cost",
Formula( :Unit Sales * :Unit Cost + 1200 )
s
dt << New Column( "Profit",
Formula( :Revenue - :Total Cost ),
Set Property( "Spec Limits", {LSLC 0 )} )

)

Profiler(
Y( :Revenue, :Total Cost, :Profit ),
Objective Formula( Profit )

s

Click the Run Script icon 2] to run the script. Alternatively, you can select Ctrl-R.

The script creates the data table in Figure 8.24 with some initial scaling data and stores
formulas into the output variables. It also launches the Prediction Profiler.

Figure 8.24 Data Table Created from Script
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4. Click the Prediction Profiler red triangle and select the Simulator.
In the menus beneath Unit Sales and Unit Cost, select Random.

6. Fill in the factor parameters as follows:

-1200
1800

— Unit Sales is Uniform with Lower limit 1000 and Upper limit 2000.

— Unit Price is Fixed at 3.

— Unit Cost is Normal with mean of 2.25 and standard deviation of 0.1.

169
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Figure 8.25 Specifications for Prediction Profiler
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7. Click the Simulate button.
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Note: Your numbers might differ from those shown in Figure 8.26 due to the random

draws in the simulation.

Figure 8.26 Simulator
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It appears that the models are unlikely to be profitable. By putting a lower specification
limit of zero on Profit, the defect report tells you that the probability of being unprofitable

is 62%.

8. Change the fixed value of Unit Price to 3.25.

9. C(lick the Simulate button.
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Figure 8.27 Results

Defect Rate Mean 5D
Revenue 0 487057 942877
Total Cost 0 45734 666997
(Profit 0.2162 297174 330.16)
Al 0.2162

Now the probability of being unprofitable is down to about 21%.

If unit price cannot be raised anymore, you should now investigate lowering your cost or
increasing sales, if you want to further decrease the probability of being unprofitable.

Statistical Details for the Simulator

Normal Weighted Distribution

JMP uses the multivariate radial strata method for each factor that uses the Normal Weighted
distribution. This seems to work better than a number of importance sampling methods and is
accurate at estimating in the extreme tails.

First, define the number of strata. The strata are a net of hyperspheres that are centered
around 0. For d random factors, the strata are defined by their radial intervals as follows.

Table 8.1 Strata Intervals

Strata Number Inside Distance Outside Distance
0 0 Ji
1

JJd Jd+ J2d
2 Jd+ J2d Jd+2.2d
i Jd+(i-1)2d Nd +iy2d

NStrata_l A/dJr{(NStrata_l)_l}m A/dJr(NStrata_l)m

The default number of strata is 16. To change the number of strata, a hidden command
N Strata is available if you hold the Shift key down while clicking on the red triangle next to
Simulator. Increase the sample size as needed to maintain an even number of strata.
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For each simulation run, the following is done:

1. Select a strata as mod(i — 1, Ng,,) for run i.

2. Determine a random n-dimensional direction by scaling multivariate Normal (0,1)
deviates to unit norm.

3. Determine a random distance using a chi-square quantile appropriate for the strata of a
random uniform argument.

4. Scale the variates so that the norm is the random distance.

5. Scale and re-center the variates individually to be as specified for each factor.

The resulting factor distributions are multivariate normal with the appropriate means and
standard deviations when estimated with the right weights. Note that you cannot use the
Distribution standard deviation with weights, because it does not estimate the desired value.
However, multiplying the weight by a large value, like 10'%, and using that as a Freq value
results in the correct standard deviation.
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The JMP Add-In for Excel uses the JMP Profiler to visualize models (or formulas) stored in
Excel worksheets. You can install the Excel add-in when you install JMP.

Figure 9.1 Example of a Prediction Profiler Using an Excel Model
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Overview of the Excel Profiler

The JMP Add-In for Excel uses the JMP Profiler to visualize models (or formulas) stored in
Excel worksheets. You can choose to install the Excel Add-In when you install JMP. Profiling
in the Excel Add-In is a two-step process:

1. Click the Create/Edit Model button (Excel 2010 through 2016) to enter information about
the model that JMP needs. This needs to be done only once per model. For more
information, click Help in the Create/Edit Model window.

2. Click the Run Model button (Excel 2010 through 2016) to launch the JMP Profiler and run
the Excel model. See “Run the JMP Profiler” on page 177.

Notes:

® The Preferences, Data Table, Graph Builder, Distribution, Fit Y by X, Fit Model, Time
Series, and Control Chart buttons are not needed to profile an Excel model. For more
information about these features, see the Import Your Data chapter in Using [MP.

e A JMP ribbon is added to Microsoft Excel when the add-in is installed. If there is no JMP
ribbon, install the add-in by double-clicking the JMP setup.exe file, selecting Modify,
selecting Excel Add-In, and clicking Next.

Example of an Excel Model

An Excel model consists of one or more Excel formulas. Each formula must be a function of
one or more other cells. This example uses the Demand.xls sample import data located in the
Samples/Import Data folder.

Figure 9.2 Demand Model in Excel
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About the Demand.xls Sample Import Data

The formula in cell B8 is a calculation of the Overall Cost associated with having different
amounts of product in stock. The formula, which is shown in the Formula Bar, is a function of
four cells:

Amount Stocked is the amount of product in stock.
Demand is the customer demand for the product.

Air Freight is the cost per unit to ship additional product by air when the demand exceeds
the amount in stock.

Expiration Cost is the cost per unit of disposing of unused product when the demand is less
than the amount in stock.

The calculations of the formula are as follows:

If Amount Stocked is less than Demand, then the company has to ship additional units, at a
cost of (Demand-Amount Stocked) x Air Freight. For example, if the demand is 8, but the
company has only 6 in stock, then it has to ship 8 - 6 =2 units at a cost of 2 x 150 = 300.

If Amount Stocked is greater than Demand, then the company has to dispose of unused
product, at a cost of (Amount Stocked - Demand) x Expiration Cost. For example, if the
demand is 5, but the company has 8 in stock, then it has to dispose of 8 - 5 =3 units at a
cost of 3 x 50 = 150.

If Amount Stocked is equal to Demand, then there is no shipping cost or disposal cost.

There is never both a shipping cost and a disposal cost at the same time.

Create the Model in Excel

1.

Select Help > Sample Data Library and navigate up one level to the Samples/Import Data
folder.

Double-click Demand.xls to open the file in Microsoft Excel.

In Microsoft Excel, click the JMP ribbon.

Click the Create/Edit Model button |~ .

The name of the workbook is displayed in the Model and Model Name fields.

The Inputs and Outputs fields are populated with data from the worksheet.
Enter Customer Demand in the Model Name field and click Apply.

The Model field is updated.

Select Air Freight in the Inputs box and then click the down arrow button &|.

Air Freight is moved to the bottom of the list because you want it displayed last in the
Profiler.

Click OK.
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The Excel model is saved to the worksheet.

Notes:

If the fields in the Create/Edit Model window are not populated when you set up your
model, click Choose and select the cell that contains the input or output name.

— For inputs, specify the values and click Apply. Inputs must be values, not formulas.

— For outputs, the specified cell must be a formula containing only information from the
Input cells.

You can create more than one model for a worksheet. In the Create/Edit Model window,
click the plus button +| next to the Model name. In the Model Name field, change the
name if necessary and click the Apply button. You can then change the inputs and outputs
as necessary and click OK.

You must define the entire model on one worksheet. A model cannot reference cells on
another worksheet.

Run the JMP Profiler

Once you create the model using the Excel Add-In, you can run it in the JMP Profiler. From the
Excel Add-In, perform the following actions:

1.

2
3
4.
5

In Microsoft Excel, click the JMP ribbon.
Click the Run Model button.

Select the model that you want to run.
Click Profile in JMP.

Use the JMP Profiler to simultaneously see the effect of all inputs on the output. You can
also simulate a range of input combinations to see the resulting range of output values.

Figure 9.3 Example of the Prediction Profiler Using Excel Models
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Note: To ensure that your original Excel worksheet is not altered, JMP runs a hidden copy of
Excel in the background that controls all of the Profiler calculations. Since the Excel worksheet
and the Profiler are not dynamically linked, after you update a formula in the worksheet, you
must relaunch the JMP Profiler to reflect the changes.

Use Linear Constraints

Within the JMP Profiler, you can alter the linear constraints in order to restrict the model input
values. You are prompted to save the constraints to the Excel workbook. After constraints are
saved to the Excel workbook, whenever the model is profiled from the Excel Add-In, the
constraints are incorporated.

1. Click the Prediction Profiler red triangle and select Alter Linear Constraints.

2. Click Add Constraint.

3. Type in the constraining values.

4. Click OK.

5. Click the Prediction Profiler red triangle and select Save Linear Constraints.
You are prompted to save the constraints to the Excel workbook.

6. Click Yes.

Note: When you save the .xls file, you might see a compatibility error. If so, click Continue to
save the file.

The workbook opens in Excel. When you run the model, the constraints are reflected in the
JMP Profiler. For more information about linear constraints, see “Linear Constraints” on
page 34 in the “Introduction to Profilers” chapter.

Tip: To delete a linear constraint, set all constraint values to zero.

Resolution of Profile Lines

The Default N Levels option on the Prediction Profiler red triangle menu affects the resolution
of the profile lines. Note the following information:

e This option defaults to 17 when the Profiler runs a model stored in Excel.

e This option defaults to 41 when the model is stored directly in JMP.
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If the same model is stored in both Excel and JMP, then the profile lines can appear differently
when the models are profiled. Increasing this value causes the Excel Profiler to run slower.

Use the Excel Profiler from JMP

After you have defined model input and outputs in an Excel file, you can profile the model
from within JMP.

1. Select Graph > Excel Profiler.
2. Locate the Excel file containing the model and then click Open.

3. If the Excel file contains multiple models, you are prompted to select the model that you
want to profile.

Note that the Excel Profiler is also scriptable, as follows:
Excel Profiler( "path to workbook", <"model name"> ) ;

If more than one model exists, and no model is specified, a window with the list of available
models appears. For more information about scripting the Excel Profiler, see the Extending
JMP chapter in the Scripting Guide.
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Appendix B

Technology License Notices

Scintilla - Copyright © 1998-2017 by Neil Hodgson <neilh@scintilla.org>.
All Rights Reserved.

Permission to use, copy, modify, and distribute this software and its documentation for
any purpose and without fee is hereby granted, provided that the above copyright notice
appear in all copies and that both that copyright notice and this permission notice appear
in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING
ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL
HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Progressé® Telerik® UI for WPF: Copyright © 2008-2019 Progress Software Corporation.
All rights reserved. Usage of the included Progress® Telerik® UI for WPF outside of JMP is
not permitted.

ZLIB Compression Library - Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.
Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.
Packages - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

Neither the name of the WhiteBox nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
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(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

¢ iODBC software - Copyright © 1995-2006, OpenLink Software Inc and Ke Jin
(www.iodbc.org). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

— Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

— Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

— Neither the name of OpenLink Software Inc. nor the names of its contributors may be
used to endorse or promote products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.

e This program, “bzip2”, the associated library “libbzip2”, and all documentation, are
Copyright © 996-2019 Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. The origin of this software must not be misrepresented; you must not claim that you
wrote the original software. If you use this software in a product, an acknowledgment in
the product documentation would be appreciated but is not required.

3. Altered source versions must be plainly marked as such, and must not be
misrepresented as being the original software.
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4. The name of the author may not be used to endorse or promote products derived from
this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

Julian Seward, jseward@acm.org
bzip2/libbzip2 version 1.0.8 of 13 July 2019
R software is Copyright © 1999-2012, R Foundation for Statistical Computing.

MATLARB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and
international patents. See www.mathworks.com/patents. MATLAB and Simulink are
registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a
list of additional trademarks. Other product or brand names may be trademarks or
registered trademarks of their respective holders.

libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

— Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

— Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and / or other materials
provided with the distribution.

— Neither the name of Florian Reuter nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
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USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

¢ libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and
the trio files, which are covered by a similar license but with different Copyright notices)
all the files are:

Copyright © 1998 - 2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS 1S”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in
advertising or otherwise to promote the sale, use or other dealings in this Software
without prior written authorization from him.

¢ Regarding the decompression algorithm used for UNIX files:
Copyright © 1985, 1986, 1992, 1993
The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.
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2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

Snowbeall - Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton.
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used
to endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS \”AS IS\” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

Pako - Copyright © 2014-2017 by Vitaly Puzrin and Andrei Tuputcyn.

Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.
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THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.

HDF5 (Hierarchical Data Format 5) Software Library and Utilities Copyright 2006 —2015
by The HDF Group. NCSA HDF5 (Hierarchical Data Format 5) Software Library and
Utilities Copyright 1998-2006 by the Board of Trustees of the University of Illinois. All
rights reserved. DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF GROUP
AND THE CONTRIBUTORS “AS IS” WITH NO WARRANTY OF ANY KIND, EITHER
EXPRESSED OR IMPLIED. In no event shall The HDF Group or the Contributors be liable
for any damages suffered by the users arising out of the use of this software, even if
advised of the possibility of such damage.

agl-aglfn technology is Copyright © 2002, 2010, 2015 by Adobe Systems Incorporated. All
Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

— Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

— Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

— Neither the name of Adobe Systems Incorporated nor the names of its contributors
may be used to endorse or promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
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dmlc/xgboost is Copyright © 2019 SAS Institute.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file
except in compliance with the License. You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the
License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS
OF ANY KIND, either express or implied. See the License for the specific language
governing permissions and limitations under the License.

libzip is Copyright (C) 1999-2019 Dieter Baron and Thomas Klausner.

This file is part of libzip, a library to manipulate ZIP archives. The authors can be
contacted at <libzip@nih.at>.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. The names of the authors may not be used to endorse or promote products derived from
this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHORS "AS IS" AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
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