Design of Experiments Guide

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust
The correct bibliographic citation for this manual is as follows: SAS Institute Inc. 2020–2021. 

JMP® 16 Design of Experiments Guide
Copyright © 2020–2021, SAS Institute Inc., Cary, NC, USA

All rights reserved. Produced in the United States of America.

U.S. Government License Rights; Restricted Rights: The Software and its documentation is commercial computer software developed at private expense and is provided with RESTRICTED RIGHTS to the United States Government. Use, duplication or disclosure of the Software by the United States Government is subject to the license terms of this Agreement pursuant to, as applicable, FAR 12.212, DFAR 227.7202-1(a), DFAR 227.7202-3(a) and DFAR 227.7202-4 and, to the extent required under U.S. federal law, the minimum restricted rights as set out in FAR 52.227-19 (DEC 2007). If FAR 52.227-19 is applicable, this provision serves as notice under clause (c) thereof and no other notice is required to be affixed to the Software or documentation. The Government’s rights in Software and documentation shall be only those set forth in this Agreement.


March 2021

August 2021

SAS® and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration. Other brand and product names are trademarks of their respective companies.

SAS software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with SAS software, refer to http://support.sas.com/thirdpartylicenses.
Get the Most from JMP

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:

- live and recorded webcasts about how to get started with JMP
- video demos and webcasts of new features and advanced techniques
- details on registering for JMP training
- schedules for seminars being held in your area
- success stories showing how others use JMP
- the JMP user community, resources for users including examples of add-ins and scripts, a forum, blogs, conference information, and so on

https://www.jmp.com/getstarted
# Contents

## Design of Experiments Guide

### 1 Learn about JMP

**Documentation and Additional Resources**
- Formatting Conventions in JMP Documentation ................................................................. 23
- JMP Help ................................................................................................................................. 24
- JMP Documentation Library ................................................................................................. 24
- Additional Resources for Learning JMP .............................................................................. 30
  - JMP Tutorials ....................................................................................................................... 30
  - Sample Data Tables ............................................................................................................ 30
  - Learn about Statistical and JSL Terms .............................................................................. 31
  - Learn JMP Tips and Tricks ................................................................................................. 31
  - JMP Tooltips ....................................................................................................................... 31
  - JMP User Community ......................................................................................................... 32
  - Free Online Statistical Thinking Course ............................................................................ 32
- JMP New User Welcome Kit ................................................................................................. 32
- Statistics Knowledge Portal ................................................................................................. 32
- JMP Training .......................................................................................................................... 32
- JMP Books by Users .............................................................................................................. 33
- The JMP Starter Window ...................................................................................................... 33
- JMP Technical Support ......................................................................................................... 33

### 2 Introduction to DOE

**Overview of Design of Experiment Platforms**

### 3 Starting Out with DOE

**Example and Key Concepts**
- Overview of Experimental Design and the DOE Workflow ................................................ 43
- The Coffee Strength Experiment ......................................................................................... 44
  - Define the Study and Goals ............................................................................................... 45
  - Create the Design ............................................................................................................... 47
  - Run the Experiment ............................................................................................................ 52
  - Analyze the Data ................................................................................................................ 53
- The DOE Workflow: Describe, Specify, Design .................................................................. 59
  - Define Responses and Factors .......................................................................................... 60
### Contents

#### 4 Custom Designs

**Construct Designs That Meet Your Needs**
- Overview of Custom Design ........................................... 69
- Example of a Custom Design ........................................... 71
- Build a Custom Design ................................................. 88
  - Responses .................................................................. 88
  - Factors ..................................................................... 90
  - Define Factor Constraints ........................................... 97
  - Alias Terms ............................................................. 102
- Design Generation ......................................................... 103
- Design ................................................................. 106
- Design Evaluation ......................................................... 106
- Output Options ........................................................... 107
- Custom Design Options ................................................ 109
  - Simulate Responses .................................................. 113
  - Save X Matrix ......................................................... 115
  - Number of Starts ...................................................... 117
  - Design Search Time .................................................. 118
- Technical Details for Custom Designs ......................... 119
  - Designs with Randomization Restrictions .................. 119
  - Covariates with Hard-to-Change Levels ..................... 128
  - Numbers of Whole Plots and Subplots ....................... 128
  - Optimality Criteria .................................................. 129
  - D-Efficiency ............................................................ 134
  - Coordinate-Exchange Algorithm ................................. 134

#### 5 Examples of Custom Designs

**Perform Experiments That Meet Your Needs**
- Screening Experiments .................................................. 137
  - Design That Estimates Main Effects Only .................... 137
  - Design That Estimates All Two-Factor Interactions ....... 140
Design of Experiments Guide

Contents

Design That Avoids Aliasing of Main Effects and Two-Factor Interactions 143
Supersaturated Screening Designs 146
Design for Fixed Blocks 154
Response Surface Experiments 159
Response Surface Design 159
Response Surface Design with Flexible Blocking 165
Comparison of a D-Optimal and an I-Optimal Response Surface Design 168
Response Surface Design With Constraints and Categorical Factor 172
Mixture Experiments 178
Mixture Design with Nonmixture Factors 178
Mixture of Mixtures Design 182
Experiments with Covariates 187
Design with Fixed Covariates 187
Design with Hard-to-Change Covariates 190
Design with a Linear Time Trend 194
Experiments with Randomization Restrictions 197
Split-Plot Experiment 197
Two-Way Split-Plot Experiment 202
Experiments for Robust Process and Product Design 210

6 Augment Designs 213
Add Additional Runs to an Existing Design 215
Example Using the Augment Design Platform 215
Launch the Augment Design Platform 221
Augment Design Window 222
Factors 222
Define Factor Constraints 223
Augmentation Choices 226
Augment Design Platform Options 227
Additional Examples of Augmentation Choices 231
Replicate a Design 231
Add Center Points to a Design 233
Create a Foldover Design 234
Add Axial Points to a Design 235
Space Filling Augmentation 236
Statistical Details 237

7 Definitive Screening Designs 239
Overview of Definitive Screening Design 241
Examples of Definitive Screening Designs 243
Contents

Definitive Screening Design .......................................................... 244
Comparison with a Fractional Factorial Design .................................. 246
Definitive Screening Design with Blocking ........................................ 248
Comparison of a Definitive Screening Design with a Plackett-Burman Design .......................................................... 252
Definitive Screening Design Window .................................................. 255
Responses .............................................................................. 256
Factors ................................................................................ 258
Design Options ......................................................................... 260
Design ................................................................................... 262
Design Evaluation ..................................................................... 262
Output Options .......................................................................... 263
Definitive Screening Design Options .................................................. 265
Simulate Responses .................................................................. 267
Technical Details ......................................................................... 270
Structure of Definitive Screening Designs ........................................ 270
Analysis of Experimental Data ....................................................... 272

8 The Fit Definitive Screening Platform ................................................. 275
Analyze Data from Definitive Screening Experiments

Overview of the Fit Definitive Screening Platform ................................ 277
Identification of Active Effects in DSDs ............................................. 277
Effective Model Selection for DSDs .................................................. 277
Example of the Fit Definitive Screening Platform ................................ 278
Fit the Model ........................................................................... 278
Examine Results ........................................................................ 279
Reduce the Model ....................................................................... 280
Launch the Fit Definitive Screening Platform ....................................... 282
Fit Definitive Screening Report .......................................................... 282
Stage 1 - Main Effect Estimates ....................................................... 283
Stage 2 - Even Order Effect Estimates ............................................. 284
Combined Model Parameter Estimates ............................................ 285
Main Effects Residual Plots .............................................................. 285
Prediction Profiler ....................................................................... 286
Fit Definitive Screening Platform Options ........................................... 286
Technical Details for the Fit Definitive Screening Platform ................. 286
The Effective Model Selection for DSDs Algorithm ................................. 286

9 Screening Designs .......................................................................... 291

Overview of Screening Designs .......................................................... 293
Underlying Principles ...................................................................... 293
Analysis of Screening Design Results .......................................................... 294
Examples of Screening Designs ..................................................................... 294
  Compare a Fractional Factorial Design and a Main Effects Screening Design .... 294
  Main Effects Screening Design where No Standard Design Exists ............. 302
Screening Design Window ............................................................................. 305
  Responses ..................................................................................................... 306
  Factors ........................................................................................................ 308
  Choose Screening Type ............................................................................. 310
  Choose from a List of Fractional Factorial Designs .................................... 311
  Design Type ............................................................................................... 311
  Resolution as a Measure of Confounding .................................................. 314
  Display and Modify Design ..................................................................... 315
Main Effects Screening Designs .................................................................... 318
Design Generation ....................................................................................... 319
Design .......................................................................................................... 320
Design Evaluation ....................................................................................... 320
Output Options ............................................................................................ 321
Make Table .................................................................................................. 322
Screening Design Options ............................................................................ 323
Additional Examples of Screening Designs .................................................. 325
  Modify Generating Rules in a Fractional Factorial Design ....................... 326
  Plackett-Burman Design ......................................................................... 331

10  The Fit Two Level Screening Platform.

Analyze Data from Screening Experiments .................................................. 337
  Overview of the Fit Two Level Screening Platform .................................. 339
  Example of Fit Two Level Screening Platform ....................................... 339
  Launch the Fit Two Level Screening Platform ....................................... 342
The Screening Report .................................................................................... 343
  Contrasts .................................................................................................... 344
  Half Normal Plot ..................................................................................... 344
  Make or Run Model .................................................................................. 345
Additional Fit Two Level Screening Analysis Examples ................................ 345
  Analyze a Plackett-Burman Design ....................................................... 345
  Effect Heredity Example ........................................................................ 346
  Analyze a Supersaturated Design ............................................................ 348
Technical Details for the Fit Two Level Screening Platform ......................... 350
  Order of Effect Entry ............................................................................... 350
  Fit Two Level Screening as an Orthogonal Rotation .................................. 350
  Lenth’s Pseudo-Standard Error ............................................................... 351
## 11 Response Surface Designs

- Overview of Response Surface Designs ................................................................. 357
- Example of a Response Surface Design ............................................................... 359
  - Construct a Box-Behnken Design ......................................................................... 360
  - Analyze the Experimental Data ........................................................................... 361
  - Explore Optimal Settings ..................................................................................... 363
- Response Surface Design Window ........................................................................... 366
  - Responses ........................................................................................................... 367
  - Factors ............................................................................................................... 369
  - Choose a Design ................................................................................................ 371
  - Specify Output Options ....................................................................................... 372
  - Make Table ........................................................................................................ 373
- Response Surface Design Options ........................................................................... 374

## 12 Full Factorial Designs

- Overview of Full Factorial Design .......................................................................... 379
- Example of a Full Factorial Design ......................................................................... 379
  - Construct the Design ............................................................................................ 379
  - Analyze the Experimental Data ........................................................................... 381
- Build a Full Factorial Design .................................................................................... 385
  - Responses ........................................................................................................... 385
  - Factors ............................................................................................................... 388
  - Select Output Options ......................................................................................... 389
  - Make Table ........................................................................................................ 391
- Full Factorial Design Options ................................................................................... 392

## 13 Mixture Designs

### Designs for Formulations

- Overview of Mixture Designs .................................................................................... 397
- Mixture Design Window ........................................................................................... 397
  - Responses ........................................................................................................... 398
  - Factors ............................................................................................................... 400
  - Ternary Plot Overview ......................................................................................... 401
- Examples of Mixture Design Types .......................................................................... 402
  - Optimal Mixture Design ....................................................................................... 402
  - Simplex Centroid Design .................................................................................... 404
  - Simplex Lattice Design ....................................................................................... 406
### Extreme Vertices Design
- ABCD Design .................................................. 411
- Space Filling Design ........................................... 412

### Fitting Mixture Designs
- Whole Model Tests and Analysis of Variance Reports .... 415
- Understanding Response Surface Reports .................. 415

### Taguchi Designs
**Designs with Noise Factors**
- Overview of Taguchi Designs .................................. 425
- Example of a Taguchi Design ................................. 425
- Build a Taguchi Design ........................................ 429
  - Responses ....................................................... 430
  - Factors ......................................................... 430
- Choose Taguchi Inner and Outer Array Designs ......... 431
- Display Coded Design ......................................... 431
- Make the Design Table ....................................... 432
- Taguchi Design Options ..................................... 432

### Evaluate Designs
**Explore Properties of Your Design**
- Overview of the Evaluate Design Platform ................. 437
- Example of Evaluate Design .................................... 438
  - Assessing the Impact of Lost Runs ....................... 438
  - Evaluating Power Relative to a Specified Model ....... 445
- Evaluate Design Launch Window ......................... 447
- Evaluate Design Window ....................................... 447
  - Factors ......................................................... 449
  - Model ......................................................... 449
  - Alias Terms .................................................. 450
  - Design ......................................................... 451
- Design Evaluation .............................................. 451
- Power Analysis ............................................... 451
- Prediction Variance Profile .................................. 458
- Fraction of Design Space Plot .............................. 459
- Prediction Variance Surface ............................... 460
16 Compare Designs ................................................................................................................................. 471

Compare and Evaluate Designs Simultaneously
Overview of the Compare Designs Platform .......................................................................................... 473
Examples of Comparing Designs ............................................................................................................. 473
  Designs of Same Run Size ..................................................................................................................... 473
  Designs of Different Run Sizes ............................................................................................................. 478
  Split Plot Designs with Different Numbers of Whole Plots ................................................................. 482
Launch the Compare Designs Platform .................................................................................................. 486
Compare Designs Window: Specify Model and Alias Terms ..................................................................... 488
  Reference Design ................................................................................................................................. 488
  Factors ................................................................................................................................................. 488
  Model .................................................................................................................................................... 488
  Alias Terms ......................................................................................................................................... 489
Compare Designs Window: Design Evaluation .......................................................................................... 489
  Power Analysis ..................................................................................................................................... 490
  Prediction Variance Profile .................................................................................................................. 493
  Fraction of Design Space Plot .............................................................................................................. 495
  Relative Estimation Efficiency .............................................................................................................. 496
  Alias Matrix Summary ......................................................................................................................... 498
  Absolute Correlations ........................................................................................................................... 500
  Design Diagnostics ............................................................................................................................... 502
Compare Designs Options .......................................................................................................................... 504

17 Prospective Sample Size and Power .................................................................................................... 505

Launch the Sample Size and Power Platform .......................................................................................... 508
One Sample Mean Calculator ................................................................................................................... 509
  Examples of the One Sample Mean Calculator .................................................................................. 510
  One Sample Mean Calculator Fields .................................................................................................. 514
  Statistical Details for the One Sample Mean Calculator ...................................................................... 515
Two Sample Means Calculator ................................................................................................................. 516
  Example of the Two Sample Means Calculator .................................................................................. 516
  Two Sample Means Calculator Fields .................................................................................................. 517
  Statistical Details for the Two Sample Means Calculator ...................................................................... 518
k Sample Means Calculator ...................................................................................................................... 519
Choice Designs

Create a Design for Selecting Preferred Product Profiles

Overview of Choice Designs
Choice Design Terminology
Bayesian D-Optimality
Example of a Choice Design
Example of a Choice Design with Analysis
## Contents

Create a Choice Design for a Pilot Study .................................................. 553
Analyze the Pilot Study Data ................................................................. 555
Design the Final Choice Experiment Using Prior Information .................. 556
Run the Design and Analyze the Results ............................................... 558
Choice Design Window ........................................................................... 561
   Attributes ......................................................................................... 561
   Model .............................................................................................. 562
   Design Generation ........................................................................... 563
   Design ............................................................................................. 564
   Make Table ..................................................................................... 566
Choice Design Options ........................................................................... 566
Technical Details .................................................................................... 567
   Bayesian D-Optimality and Design Construction ............................... 567
   Utility-Neutral and Local D-Optimal Designs ................................... 568

### 19 MaxDiff Design ................................................................................. 569
   Create a Design for Selecting Best and Worst Items ......................... 571
      Overview of the MaxDiff Design Platform .................................... 571
      Example of a MaxDiff Design ....................................................... 571
      MaxDiff Design Launch Window ................................................... 575
      MaxDiff Window .......................................................................... 575
         Design Options Outline .............................................................. 575
         Design Outline .......................................................................... 576
         Pairwise Incidence Matrix ......................................................... 576
         Make Table ................................................................................ 576
      MaxDiff Options .......................................................................... 576

### 20 Covering Arrays ................................................................................ 579
   Detecting Component Interaction Failures ........................................ 581
      Overview of Covering Arrays ......................................................... 581
      Example of a Covering Array with No Factor Level Restrictions ....... 583
         Create the Design ...................................................................... 583
         Analyze the Experimental Data .................................................. 585
      Example of a Covering Array with Factor Level Restrictions .......... 587
         Create the Design ...................................................................... 588
         Analyze the Experimental Data .................................................. 592
      Covering Array Window ............................................................... 593
         Factors ....................................................................................... 594
         Restrict Factor Level Combinations ........................................... 595
         Design ....................................................................................... 597
         Metrics ....................................................................................... 600
21 Space-Filling Designs ................................................................. 607

Overview of Space-Filling Designs .............................................. 609
Build a Space Filling Design ...................................................... 610
  Responses ............................................................................. 610
  Factors ................................................................................. 612
  Define Factor Constraints ...................................................... 614
  Space Filling Design Methods ............................................... 618
  Design .................................................................................. 618
  Design Diagnostics ............................................................... 618
  Design Table ......................................................................... 619
Space Filling Design Options .................................................... 619
Sphere-Packing Designs ........................................................... 621
  Creating a Sphere-Packing Design .......................................... 621
  Visualizing the Sphere-Packing Design .................................. 623
Latin Hypercube Designs .......................................................... 624
  Creating a Latin Hypercube Design ........................................ 624
  Visualizing the Latin Hypercube Design .................................. 626
Uniform Designs ................................................................. 628
Comparing Sphere-Packing, Latin Hypercube, and Uniform Methods 630
Minimum Potential Designs ....................................................... 632
Maximum Entropy Designs ....................................................... 634
Gaussian Process IMSE Optimal Designs .................................. 636
Fast Flexible Filling Designs ..................................................... 637
  FFF Optimality Criterion ...................................................... 637
  Set Average Cluster Size for FFF Designs ............................... 639
  Constraints ......................................................................... 639
  Creating and Viewing a Constrained Fast Flexible Filling Design 640
  Creating a Space-Filling Design for a Map Shape .................... 641
Example of a Sphere-Packing Design ........................................ 646
  Create the Sphere-Packing Design for the Borehole Data .......... 646
  Guidelines for the Analysis of Deterministic Data ...................... 647
22  **Accelerated Life Test Designs** ................................................................. 651

**Designing Experiments for Accelerated Life Tests**

Overview of Accelerated Life Test Designs .............................................. 653
Example of an Accelerated Life Test Design ........................................... 653
Example of Augmenting an Accelerated Life Test Design ........................ 660
Build an Accelerated Life Test Design .................................................... 665
  Specify the Design Structure .............................................................. 666
  Specify Acceleration Factors ............................................................ 666
  Specify Design Details ................................................................. 667
  Review and Update Specifications for ALT Plans ................................... 669
  Create and Assess the Optimal .......................................................... 671
  Create Design Tables ......................................................................... 673

Accelerated Life Test Options ............................................................... 673
Statistical Details for the ALT Design Platform ........................................ 674
  Failure Distributions for ALT Designs ................................................ 674
  R Precision Factor (for a 95% CI) ...................................................... 676
  Optimality Criterion for Accelerated Life Tests ................................... 677

23  **Nonlinear Designs** ............................................................................. 679

Overview of Nonlinear Designs ............................................................... 681
Examples of Nonlinear Designs ............................................................... 682
  Create a Nonlinear Design with No Prior Data .................................... 682
  Augment a Design Using Prior Data .................................................... 687
  Create a Design for a Binomial Response ............................................ 691
Nonlinear Design Launch Window ............................................................ 694
Nonlinear Design Window ...................................................................... 695
  Factors ....................................................................................................... 695
  Parameters .............................................................................................. 696
  Design Generation ................................................................................. 696
  Design ........................................................................................................ 696
  Make Table or Augment Table .............................................................. 697
Nonlinear Design Options ......................................................................... 697
Statistical Details for Nonlinear Designs .................................................. 698
  Nonlinear Models .................................................................................... 698
  Radial-Spherical Integration of the Optimality Criterion ....................... 699
  Finding the Optimal Design .................................................................. 699

24  **Balanced Incomplete Block Designs** .................................................... 701

Example of Balanced Incomplete Block Designs ..................................... 703
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build a Balanced Incomplete Block Design</td>
<td>705</td>
</tr>
<tr>
<td>Specify Treatments, Blocks, and Make Design</td>
<td>705</td>
</tr>
<tr>
<td>Verify Design and Make Table</td>
<td>706</td>
</tr>
<tr>
<td>Balanced Incomplete Block Design Options</td>
<td>707</td>
</tr>
<tr>
<td>Statistical Details for Balanced Incomplete Block Designs</td>
<td>708</td>
</tr>
<tr>
<td><strong>25 MSA Designs</strong></td>
<td>709</td>
</tr>
<tr>
<td>Overview of MSA Designs</td>
<td>711</td>
</tr>
<tr>
<td>Example of MSA Design</td>
<td>711</td>
</tr>
<tr>
<td>Build an MSA Design</td>
<td>714</td>
</tr>
<tr>
<td>Responses</td>
<td>714</td>
</tr>
<tr>
<td>Factors</td>
<td>717</td>
</tr>
<tr>
<td>MSA Design</td>
<td>718</td>
</tr>
<tr>
<td>MSA Design Diagnostics</td>
<td>719</td>
</tr>
<tr>
<td>MSA Design Table</td>
<td>719</td>
</tr>
<tr>
<td>MSA Design Options</td>
<td>719</td>
</tr>
<tr>
<td>Statistical Details for the MSA Design Platform</td>
<td>720</td>
</tr>
<tr>
<td><strong>26 Group Orthogonal Supersaturated Designs</strong></td>
<td>723</td>
</tr>
<tr>
<td>Overview of Group Orthogonal Supersaturated Designs</td>
<td>725</td>
</tr>
<tr>
<td>Example of Group Orthogonal Supersaturated Designs</td>
<td>725</td>
</tr>
<tr>
<td>Build a Group Orthogonal Supersaturated Design</td>
<td>727</td>
</tr>
<tr>
<td>Specify Factors, Structure, and Make Design</td>
<td>727</td>
</tr>
<tr>
<td>Verify Design and Make Table</td>
<td>728</td>
</tr>
<tr>
<td>Group Orthogonal Supersaturated Design Options</td>
<td>729</td>
</tr>
<tr>
<td>Statistical Details for Group Orthogonal Supersaturated Designs</td>
<td>730</td>
</tr>
<tr>
<td><strong>27 The Fit Group Orthogonal Supersaturated Platform</strong></td>
<td>731</td>
</tr>
<tr>
<td>Overview of the Fit Group Orthogonal Supersaturated Platform</td>
<td>733</td>
</tr>
<tr>
<td>Example of the Fit Group Orthogonal Supersaturated Platform</td>
<td>733</td>
</tr>
<tr>
<td>Launch the Fit Group Orthogonal Supersaturated Platform</td>
<td>736</td>
</tr>
<tr>
<td>The Fit Group Orthogonal Supersaturated Report</td>
<td>737</td>
</tr>
<tr>
<td>Fit Group Orthogonal Supersaturated Platform Options</td>
<td>738</td>
</tr>
<tr>
<td><strong>28 Sample Size Explorers</strong></td>
<td>739</td>
</tr>
<tr>
<td>Overview of the Sample Size Explorers Platform</td>
<td>741</td>
</tr>
<tr>
<td>Example of Sample Size Explorers</td>
<td>741</td>
</tr>
<tr>
<td>Launch Sample Size Explorers</td>
<td>742</td>
</tr>
</tbody>
</table>
A Column Properties

Understanding Column Properties Assigned by DOE

Adding and Viewing Column Properties

Response Limits

Response Limits Example

Editing Response Limits

Detection Limits

Functional Response

Design Role

Design Role Example

Coding

Low and High Values

Coding Column Property and Center Polynomials

Coding Example

Assigning Coding

Mixture

Mixture Example

Factor Changes

Margin of Error for One Sample Mean

Margin of Error for One Sample Proportion

Margin of Error for One Sample Variance

Margin of Error for Two Independent Sample Means

Margin of Error for Two Independent Sample Proportions

Margin of Error for Two Independent Sample Variances

Margin of Error for Two Independent Sample Equivalence

Margin of Error for One Sample Mean

Margin of Error for One Sample Proportion

Margin of Error for One Sample Variance

Margin of Error for Two Independent Sample Means

Margin of Error for Two Independent Sample Proportions

Margin of Error for Two Independent Sample Variances

Margin of Error for Two Independent Sample Equivalence

Margin of Error for One Sample Equivalence

Margin of Error for One Sample Variance

Margin of Error for One Sample Proportion

Margin of Error for One Sample Mean

Power Explorers for Hypothesis Tests

Power for One Sample Mean

Power for One Sample Proportion

Power for One Sample Variance

Power for One Sample Equivalence

Power for Two Independent Sample Means

Power for Two Independent Sample Proportions

Power for Two Independent Sample Variances

Power for Two Independent Sample Equivalence

Power for ANOVA

Confidence Interval Calculators

Margin of Error for One Sample Mean

Margin of Error for One Sample Proportion

Margin of Error for One Sample Variance

Margin of Error for Two Independent Sample Means

Margin of Error for Two Independent Sample Proportions

Margin of Error for Two Independent Sample Variances

Confidence Interval Calculators

Margin of Error for One Sample Mean

Margin of Error for One Sample Proportion

Margin of Error for One Sample Variance

Margin of Error for Two Independent Sample Means

Margin of Error for Two Independent Sample Proportions

Margin of Error for Two Independent Sample Variances

Power for ANOVA

Power for Two Independent Sample Equivalence

Power for Two Independent Sample Variances

Power for Two Independent Sample Proportions

Power for Two Independent Sample Means

Power for One Sample Equivalence

Power for One Sample Variance

Power for One Sample Proportion

Power for One Sample Mean

Nonparametric Reliability Demonstration

Parametric Reliability Demonstration

Saved Settings in the Sample Size Explorers

A Column Properties

Understanding Column Properties Assigned by DOE

Adding and Viewing Column Properties

Response Limits

Response Limits Example

Editing Response Limits

Detection Limits

Functional Response

Design Role

Design Role Example

Coding

Low and High Values

Coding Column Property and Center Polynomials

Coding Example

Assigning Coding

Mixture

Mixture Example

Factor Changes

64
## Contents

- **Factor Changes Example** ................................................................. 811
- **Value Order** ..................................................................................... 813
- **Value Order Example** ................................................................. 815
- **Assigning Value Order** ............................................................. 816
- **Value Labels** .................................................................................. 817
- **Value Labels Example** ............................................................... 817
- **RunsPerBlock** ................................................................................ 819
- **RunsPerBlock Example** ............................................................... 819
- **ConstraintState** ............................................................................ 820
- **ConstraintState Example** ........................................................... 821

## B  Technical Details ............................................................................. 823

- **The Alias Matrix** ........................................................................... 825
- **Designs with Hard or Very Hard Factor Changes** ...................... 825
- **Designs with If Possible Effects** ................................................ 826
- **Power Calculations** ........................................................................ 826
- **Power for a Single Parameter** ..................................................... 826
- **Power for a Categorical Effect** .................................................... 828
- **Relative Prediction Variance** ....................................................... 829

## C  References ........................................................................................ 831

## D  Technology License Notices ............................................................. 837
Learn about JMP documentation, such as book conventions, descriptions of each JMP document, the Help system, and where to find additional support.
Contents

Formatting Conventions in JMP Documentation ................................................................. 23
JMP Help .......................................................................................................................... 24
JMP Documentation Library ............................................................................................ 24
Additional Resources for Learning JMP ........................................................................ 30
  JMP Tutorials ................................................................................................................ 30
  Sample Data Tables ....................................................................................................... 30
  Learn about Statistical and JSL Terms ......................................................................... 31
  Learn JMP Tips and Tricks. ........................................................................................... 31
  JMP Tooltips ................................................................................................................ 31
  JMP User Community .................................................................................................. 32
  Free Online Statistical Thinking Course ...................................................................... 32
  JMP New User Welcome Kit ....................................................................................... 32
  Statistics Knowledge Portal ......................................................................................... 32
  JMP Training ................................................................................................................ 32
  JMP Books by Users ................................................................................................... 33
    The JMP Starter Window .......................................................................................... 33
  JMP Technical Support ............................................................................................... 33
Formatting Conventions in JMP Documentation

These conventions help you relate written material to information that you see on your screen:

- Sample data table names, column names, pathnames, filenames, file extensions, and folders appear in *Helvetica* (or sans-serif online) font.
- Code appears in *Lucida Sans Typewriter* (or monospace online) font.
- Code output appears in *Lucida Sans Typewriter italic* (or monospace italic online) font and is indented farther than the preceding code.
- **Helvetica bold** formatting (or bold sans-serif online) indicates items that you select to complete a task:
  - buttons
  - check boxes
  - commands
  - list names that are selectable
  - menus
  - options
  - tab names
  - text boxes
- The following items appear in italics:
  - words or phrases that are important or have definitions specific to JMP
  - book titles
  - variables
- Features that are for JMP Pro only are noted with the JMP Pro icon. For an overview of JMP Pro features, visit [https://www.jmp.com/software/pro](https://www.jmp.com/software/pro).

**Note:** Special information and limitations appear within a Note.

**Tip:** Helpful information appears within a Tip.
JMP Help

JMP Help in the Help menu enables you to search for information about JMP features, statistical methods, and the JMP Scripting Language (or JSL). You can open JMP Help in several ways:

- Search and view JMP Help on Windows by selecting Help > JMP Help.
- On Windows, press the F1 key to open the Help system in the default browser.
- Get help on a specific part of a data table or report window. Select the Help tool from the Tools menu and then click anywhere in a data table or report window to see the Help for that area.
- Within a JMP window, click the Help button.

**Note:** The JMP Help is available for users with Internet connections. Users without an Internet connection can search all books in a PDF file by selecting Help > JMP Documentation Library. See “JMP Documentation Library” for more information.

JMP Documentation Library

The Help system content is also available in one PDF file called JMP Documentation Library. Select Help > JMP Documentation Library to open the file. You can also download the Documentation PDF Files add-in if you prefer searching individual PDF files of each document in the JMP library. Download the available add-ins from https://community.jmp.com.

The following table describes the purpose and content of each document in the JMP library.

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discovering JMP</td>
<td>If you are not familiar with JMP, start here.</td>
<td>Introduces you to JMP and gets you started creating and analyzing data. Also learn how to share your results.</td>
</tr>
<tr>
<td>Using JMP</td>
<td>Learn about JMP data tables and how to perform basic operations.</td>
<td>Covers general JMP concepts and features that span across all of JMP, including importing data, modifying columns properties, sorting data, and connecting to SAS.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Basic Analysis   | Perform basic analysis using this document. | Describes these Analyze menu platforms:  
• Distribution  
• Fit Y by X  
• Tabulate  
• Text Explorer  
Covers how to perform bivariate, one-way ANOVA, and contingency analyses through Analyze > Fit Y by X. How to approximate sampling distributions using bootstrapping and how to perform parametric resampling with the Simulate platform are also included. |
| Essential Graphing | Find the ideal graph for your data. | Describes these Graph menu platforms:  
• Graph Builder  
• Scatterplot 3D  
• Contour Plot  
• Bubble Plot  
• Parallel Plot  
• Cell Plot  
• Scatterplot Matrix  
• Ternary Plot  
• Treemap  
• Chart  
• Overlay Plot  
The book also covers how to create background and custom maps. |
<p>| Profilers        | Learn how to use interactive profiling tools, which enable you to view cross-sections of any response surface. | Covers all profilers listed in the Graph menu. Analyzing noise factors is included along with running simulations using random inputs.                                                                              |</p>
<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design of Experiments Guide</td>
<td>Learn how to design experiments and determine appropriate sample sizes.</td>
<td>Covers all topics in the DOE menu.</td>
</tr>
</tbody>
</table>
| Fitting Linear Models     | Learn about Fit Model platform and many of its personalities.                    | Describes these personalities, all available within the Analyze menu Fit Model platform:  
<p>|                           |                                                                                 | • Standard Least Squares                                                          |
|                           |                                                                                 | • Stepwise                                                                       |
|                           |                                                                                 | • Generalized Regression                                                          |
|                           |                                                                                 | • Mixed Model                                                                    |
|                           |                                                                                 | • MANOVA                                                                        |
|                           |                                                                                 | • Loglinear Variance                                                             |
|                           |                                                                                 | • Nominal Logistic                                                               |
|                           |                                                                                 | • Ordinal Logistic                                                               |
|                           |                                                                                 | • Generalized Linear Model                                                       |</p>
<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Predictive and Specialized Modeling</em></td>
<td>Learn about additional modeling techniques</td>
<td>Describes these Analyze &gt; Predictive Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Neural</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bootstrap Forest</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Boosted Tree</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Nearest Neighbors</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Naive Bayes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Support Vector Machines</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Model Comparison</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Model Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Make Validation Column</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Formula Depot</td>
</tr>
<tr>
<td>Describes these Analyze &gt; Specialized Modeling menu platforms:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Curve</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nonlinear</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Functional Data Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Gaussian Process</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Time Series</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Matched Pairs</td>
</tr>
<tr>
<td>Describes these Analyze &gt; Screening menu platforms:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Modeling Utilities</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Response Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Predictor Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Association Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process History Explorer</td>
</tr>
<tr>
<td><strong>Table Summary:</strong></td>
<td></td>
<td><strong>Document Title:</strong> Predictive and Specialized Modeling</td>
</tr>
<tr>
<td><strong>Document Purpose:</strong></td>
<td></td>
<td><strong>Learn about additional modeling techniques.</strong></td>
</tr>
<tr>
<td><strong>Document Content:</strong></td>
<td></td>
<td><strong>Describes these Analyze &gt; Predictive Modeling menu platforms:</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Neural</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bootstrap Forest</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Boosted Tree</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Nearest Neighbors</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Naive Bayes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Support Vector Machines</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Model Comparison</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Model Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Make Validation Column</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Formula Depot</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Describes these Analyze &gt; Specialized Modeling menu platforms:</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Curve</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nonlinear</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Functional Data Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Gaussian Process</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Time Series</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Matched Pairs</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Describes these Analyze &gt; Screening menu platforms:</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Modeling Utilities</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Response Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Predictor Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Association Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Process History Explorer</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><em>Multivariate Methods</em></td>
<td>Read about techniques for analyzing several variables simultaneously.</td>
<td>Describes these Analyze &gt; Multivariate Methods menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multivariate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Principal Components</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Discriminant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partial Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multiple Correspondence Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Structural Equation Models</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Factor Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multidimensional Scaling</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Item Analysis</td>
</tr>
<tr>
<td><em>Quality and Process Methods</em></td>
<td>Read about tools for evaluating and improving processes.</td>
<td>Describes these Analyze &gt; Clustering menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Hierarchical Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Means Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Normal Mixtures</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latent Class Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cluster Variables</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| **Reliability and Survival Methods** | Learn to evaluate and improve reliability in a product or system and analyze survival data for people and products. | Describes these Analyze > Reliability and Survival menu platforms:  
• Life Distribution  
• Fit Life by X  
• Cumulative Damage  
• Recurrence Analysis  
• Degradation  
• Destructive Degradation  
• Reliability Forecast  
• Reliability Growth  
• Reliability Block Diagram  
• Repairable Systems Simulation  
• Survival  
• Fit Parametric Survival  
• Fit Proportional Hazards |
| **Consumer Research** | Learn about methods for studying consumer preferences and using that insight to create better products and services. | Describes these Analyze > Consumer Research menu platforms:  
• Categorical  
• Choice  
• MaxDiff  
• Uplift  
• Multiple Factor Analysis |
| **Scripting Guide** | Learn about taking advantage of the powerful JMP Scripting Language (JSL). | Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications. |
| **JSL Syntax Reference** | Read about many JSL functions on functions and their arguments, and messages that you send to objects and display boxes. | Includes syntax, examples, and notes for JSL commands. |
Additional Resources for Learning JMP

In addition to reading JMP help, you can also learn about JMP using the following resources:

- “JMP Tutorials”
- “Sample Data Tables”
- “Learn about Statistical and JSL Terms”
- “Learn JMP Tips and Tricks”
- “JMP Tooltips”
- “JMP User Community”
- “Free Online Statistical Thinking Course”
- “JMP New User Welcome Kit”
- “Statistics Knowledge Portal”
- “JMP Training”
- “JMP Books by Users”
- “The JMP Starter Window”

**JMP Tutorials**

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, start with the Beginners Tutorial. It steps you through the JMP interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment and comparing a sample mean to a constant.

**Sample Data Tables**

All of the examples in the JMP documentation suite use sample data. Select Help > Sample Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories, select Help > Sample Data.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\JMP\16\Samples\Data

On macOS: \Library\Application Support\JMP\16\Samples\Data
In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching Resources section. To learn more about the teaching resources, visit https://jmp.com/tools.

Learn about Statistical and JSL Terms

For help with statistical terms, select Help > Statistics Index. For help with JSL scripting and examples, select Help > Scripting Index.

Statistics Index  Provides definitions of statistical terms.

Scripting Index  Lets you search for information about JSL functions, objects, and display boxes. You can also edit and run sample scripts from the Scripting Index and get help on the commands.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select Help > Tip of the Day. Or, you can turn it off using the Preferences window.

JMP Tooltips

JMP provides descriptive tooltips (or hover labels) when you hover over items, such as the following:

- Menu or toolbar options
- Labels in graphs
- Text results in the report window (move your cursor in a circle to reveal)
- Files or windows in the Home Window
- Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences > General and then deselect Show menu tips. This option is not available on macOS.
JMP User Community

The JMP User Community provides a range of options to help you learn more about JMP and connect with other JMP users. The learning library of one-page guides, tutorials, and demos is a good place to start. And you can continue your education by registering for a variety of JMP training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, and social networking groups.

To access JMP resources on the website, select Help > JMP User Community or visit https://community.jmp.com.

Free Online Statistical Thinking Course

Learn practical statistical skills in this free online course on topics such as exploratory data analysis, quality methods, and correlation and regression. The course consists of short videos, demonstrations, exercises, and more. Visit https://www.jmp.com/statisticalthinking.

JMP New User Welcome Kit

The JMP New User Welcome Kit is designed to help you quickly get comfortable with the basics of JMP. You’ll complete its thirty short demo videos and activities, build your confidence in using the software, and connect with the largest online community of JMP users in the world. Visit https://www.jmp.com/welcome.

Statistics Knowledge Portal

The Statistics Knowledge Portal combines concise statistical explanations with illuminating examples and graphics to help visitors establish a firm foundation upon which to build statistical skills. Visit https://www.jmp.com/skp.

JMP Training

SAS offers training on a variety of topics led by a seasoned team of JMP experts. Public courses, live web courses, and on-site courses are available. You might also choose the online e-learning subscription to learn at your convenience. Visit https://www.jmp.com/training.
JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP website. Visit https://www.jmp.com/books.

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus. The window also lists JMP Pro features and platforms.

- To open the JMP Starter window, select View (Window on macOS) > JMP Starter.
- To display the JMP Starter automatically when you open JMP on Windows, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list. On macOS, select JMP > Preferences > Initial JMP Starter Window.

JMP Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP, many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at https://www.jmp.com/support, including the technical support phone number.
The JMP DOE platforms help you to design, evaluate, and analyze experiments. Most of the platforms focus on constructing designs. Other platforms support the design effort. This section provides a quick overview of each of the platforms found under the DOE menu.

**Design Construction Platforms**

**Custom Design**  Constructs designs that fit a wide variety of settings. Custom designs tend to be more cost effective and flexible than approaches based exclusively on classical designs.

Custom designs accommodate various types of factors, constraints, and disallowed combinations. You can specify which effects are necessary to estimate and which are desirable to estimate, given the number of runs. You can specify a number of runs that matches the budget for your experimental situation. Custom designs also support hard-to-change and very-hard-to-change factors, allowing you to construct split-plot and related designs.

The Custom Design platform constructs many special design types:

- screening
- response surface
- mixture
- random block
- split-plot
- split-split-plot
- two-way split-plot

You can construct classical screening, response surface, and mixture designs using other platforms. However, the Custom Design platform gives you flexibility that is not available in the other platforms. Constructing designs for split-plot situations can be done only using the Custom Design platform.

**Definitive Screening Design**  Constructs screening designs for continuous and two-level categorical factors. Definitive screening designs are useful if you suspect active interactions or curvature. Definitive screening designs enable you to identify the source of
strong nonlinear effects while avoiding complete confounding between any effects up through the second order.

Definitive screening designs are most appropriate for experimentation with four or more factors. Definitive screening designs support grouping runs into blocks. The number of blocks is user-specified.

Screening Design  Constructs screening designs for continuous, discrete numeric, and categorical factors with an arbitrary number of levels. When standard designs exist, you have two options:

- Choose from a list of classical screening designs. These designs allow two-level continuous factors or two- or three-level categorical or discrete continuous factors.
- Generate a design that is orthogonal or nearly orthogonal for main effects. Near-orthogonal designs allow for categorical and discrete numeric factors with any number of levels, as well as two-level continuous factors. These designs focus on estimating main effects in the presence of negligible interactions.

For many screening situations, standard designs are not available. In these situations, you can construct near-orthogonal screening designs.

Response Surface Design  Constructs designs that model a quadratic function of continuous factors. To fit the quadratic effects, response surface designs require three settings for each factor. JMP provides response surface designs for up to eight factors.

You can choose from a list of Central Composite or Box-Behnken designs. When appropriate, Central Composite designs that block orthogonally are included in the list. Various modifications to Central Composite designs are supported.

Full Factorial Design  Constructs full factorial designs for any number of continuous or categorical factors, both with arbitrarily many levels. A full factorial design has a run at every combination of settings of the factors. Full factorial designs tend to be large. The number of runs equals the product of the numbers of factor levels.

Mixture Design  Constructs designs that you use when factors are ingredients in a mixture. In a mixture experiment, a change in the proportion of one ingredient requires that one or more of the remaining ingredients change to maintain the sum. Choose from among several design types, including some classical mixture design approaches: optimal, simplex centroid, simplex lattice, extreme vertices, ABCD, and space filling. For optimal, extreme vertices, and space filling mixture designs, you can specify linear inequality constraints to limit the design space.

Taguchi Arrays  Constructs designs that you use for signal-to-noise analysis. The designs are based on Taguchi’s inner and outer array approach. Control factor settings constitute the
inner array and noise factor settings form the outer array. The mean and signal-to-noise ratio are the responses of interest.

An alternative to using a Taguchi array is to construct a custom design that includes control factors, noise factors, and control-by-noise interactions. Such designs, called combined arrays, are generally more cost-effective and informative than Taguchi arrays.

**Choice Design**  Constructs designs that you can use to compare prospective products. The factors in a choice design are product attributes. The design arranges product profiles, which are combinations of various attributes, in pairs or in groups of three or four. The experiment consists of having respondents indicate which profile in a pair of profiles that they prefer. You can generate a choice design that reflects prior information about the product attributes.

**MaxDiff**  Constructs a design consisting of choice sets that can be presented to respondents as part of a MaxDiff study. Respondents report only the most and least preferred options from among a small set of choices. This forces respondents to rank options in terms of preference, which often results in rankings that are more definitive than rankings obtained using standard preference scales.

**Covering Array**  Constructs combinatorial designs that you can use to test software, networks, and other systems. A strength $t$ covering array has the property that every combination of levels of every $t$ factors appears in at least one run. Covering arrays allow for any number of categorical factors, each with an arbitrary number of levels. Disallowed combinations can be specified.

**Space Filling Design**  Constructs designs for situations where the system of interest is deterministic or near-deterministic. A standard application involves creating a simpler surrogate model of a highly complex deterministic computer simulation model.

In a deterministic system, there is no variation. The goal is to minimize the difference between the fitted model and the true model (bias). Space-filling designs attempt to meet this goal either by spreading the design points out as far from each other as possible or by spacing the points evenly over the design region.

JMP provides seven space-filling design approaches. One of these approaches, the fast flexible filling design, accommodates categorical factors with any number of levels and supports linear constraints.

**Accelerated Life Test Design**  Constructs and augments designs useful for testing products at extreme conditions which are intended to accelerate failure time. Use experimental results to predict reliability under normal operating conditions.

The life distribution can be lognormal or Weibull. Designs can include one or two accelerating factors. If there are two accelerating factors, you can choose to include their interaction. You can specify prior distributions for the acceleration model parameters. D-optimal and two types of I-optimal designs are available.
Nonlinear Design  Constructs and augments designs that you use to fit models that are nonlinear in their parameters. You can construct a design using estimates from a model fit to existing data. You can also construct a design by applying prior knowledge if you do not have model-based estimates.

Balanced Incomplete Block Design  Constructs design for testing $a$ treatments in $b$ blocks where only $k$ treatments ($k < a$) can be run in any one block.

Group Orthogonal Supersaturated Design  Constructs supersaturated screening designs. They are appropriate in early stage work when the number of factors to be investigated is larger than the number of feasible runs. A group orthogonal supersaturated design is a special class of two-level supersaturated designs with properties that are desirable for model selection.

Supporting Platforms

Augment Design  Adds runs to existing designs in such a way that the resulting design is optimal. Augment Design enables you to conduct experiments in an iterative fashion. You can replicate the design, add center points, create a fold-over design, add axial points, add points to create a space-filling design, or augment the design with a specified number of runs. You can group runs into blocks to distinguish the original runs from the augmented runs. You can add model effects that were not in the original model and specify requirements for these effects.

Fit Definitive Screening Design  Analyzes definitive screening designs using a methodology called Effective Model Selection for DSDs. This methodology takes advantage of the special structure of definitive screening designs.

Fit Group Orthogonal Supersaturated  Analyzes group orthogonal supersaturated designs. This analysis technique takes advantage of the group orthogonal structure of group orthogonal supersaturated designs.

Evaluate Design  Provides diagnostics for an existing experimental design. The Evaluate Design platform provides various ways for you to assess the strengths and limitations of your design. The platform can be used with any data table, not only designs created using JMP.

Several diagnostics are provided:

- power analysis
- prediction variance plots
- estimation efficiency for parameters
- the alias matrix, showing the bias structure for model effects
- a color map showing absolute correlations among effects
- design efficiency values
**Compare Designs**  Compares up to four designs to a reference design. Use to explore, evaluate, and compare design performance. Diagnostics show how the designs perform relative to each other and how they perform in an absolute sense.

**Sample Size and Power**  Provides sample size and power calculations for a variety of testing situations: one or more sample means, a standard deviation, one or two proportions, counts per unit (Poisson mean), and sigma quality level. For these options, you specify two of three quantities to compute the third. These three quantities are the difference you want to detect, the sample size, and the power. If you supply only one of these values, a plot of the relationship between the other two values is provided.

You can compute the sample size required for a reliability test plan, where your goal is to estimate failure probabilities. You can also compute the sample size required for a reliability demonstration, where your goal is to demonstrate that a product meets or exceeds a specified standard.
A designed experiment is a controlled set of tests designed to model and explore the relationship between factors and one or more responses. JMP includes a variety of tools that enable you to create efficient experimental designs that work for your situation. In particular, these classes of designs are available:

- The Custom Design platform customizes a design for your unique situation. It constructs designs that accommodate any number of factors of any type and factors that are difficult to change (split plot situations). You control the number of runs.
- The Definitive Screening Design platform constructs an innovative class of screening designs where main effects are not aliased with each other or with two-way interactions. These designs also allow estimation of quadratic terms.

The Evaluate Design and Augment Design platforms provide tools for evaluating and augmenting existing design. The Sample Size and Power platform addresses sample size and power calculations for specialized situations.

This chapter presents an example that illustrates the JMP approach to DOE. This chapter also discusses the framework for DOE, the workflow that supports design creation, and principles that are fundamental to DOE.
Contents

Overview of Experimental Design and the DOE Workflow ......................................................... 43
The Coffee Strength Experiment ................................................................................................. 44
  Define the Study and Goals .................................................................................................. 45
  Create the Design .................................................................................................................. 47
  Run the Experiment ............................................................................................................... 52
  Analyze the Data ................................................................................................................... 53
The DOE Workflow: Describe, Specify, Design ..................................................................... 59
  Define Responses and Factors .............................................................................................. 60
  Specify the Model .................................................................................................................. 61
  Generate the Design .............................................................................................................. 62
  Evaluate the Design .............................................................................................................. 63
  Make the Table ..................................................................................................................... 63
Principles and Guidelines for Experimental Design ................................................................. 64
  Effect Hierarchy .................................................................................................................... 64
  Effect Heredity .................................................................................................................... 64
  Effect Sparsity ...................................................................................................................... 65
  Center Points, Replicate Runs, and Testing ........................................................................ 65
Overview of Experimental Design and the DOE Workflow

A six-step framework provides the structure for designing an experiment, running the experimental trials, and analyzing the results. Sound engineering and process knowledge is critical to all of these steps.

Figure 3.2 Framework for Experimental Design

<table>
<thead>
<tr>
<th>Describe</th>
<th>Specify</th>
<th>Design</th>
<th>Collect</th>
<th>Fit</th>
<th>Predict</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identify goal, responses, and factors.</td>
<td>Identify effects for an assumed model.</td>
<td>Generate a design and evaluate it for suitability.</td>
<td>Run trials using design settings. Measure response for each run.</td>
<td>Determine a model that best fits experimental data.</td>
<td>Use the model to optimize factor settings or to predict process performance.</td>
</tr>
</tbody>
</table>

You perform the first three steps in the DOE platforms. The end result is a design that can be run in your work environment. For a detailed description of the workflow for these three steps, see “The DOE Workflow: Describe, Specify, Design”.

**Describe**  Determine the goal of your experiment. Identify responses and factors.

Your goal might be to identify active factors, to find optimal factor settings, or to build a predictive model.

**Specify**  Determine or specify an assumed model that you believe adequately describes the physical situation.

Your *assumed* model is an initial model that ideally contains all the effects that you want to estimate. In some platforms, you can explicitly build the model of interest. In others, the model is implicit in the choices that you make. For example, in the Screening Design platform, you might select a model with a given resolution. The resolution of the design determines which effects are confounded. Confounding of effects potentially leads to ambiguity about which effect is truly active.

**Design**  Generate a design that is consistent with your assumed model. Evaluate this design to understand its strengths and limitations, and to ensure that it provides the information that you need, given your model and goals.

The Design Evaluation or Design Diagnostics outline in the design generation platform give you insight about the properties of your design.
The next step is the data collection phase, where the experiment is run under controlled conditions.

**Collect**  Conduct each of the trials and record the response values.

After you run your experiment, scripts in the generated data table help you fit a model using platforms such as Fit Model and Screening. Depending on your goal, the model can help you identify active effects or find optimal settings.

**Fit**  Fit your assumed model to the experimental data.

Use the JMP modeling platforms to fit and refine your model. In some situations, you might need to augment the design and perform additional runs to resolve model ambiguity.

**Predict**  Use your refined model to address your experimental goals.

Determine which effects are active, find factor levels to optimize responses, or build a predictive model.

Designed experiments are typically used sequentially to construct process knowledge. A design strategy often begins with a screening design to narrow the list of potentially active factors. Then the identified factors are studied in designs that focus on building a better understanding of interactions and quadratic effects. Sometimes there is a need to augment a design to resolve ambiguities relating to the factors responsible for effects. The steps outlined in this section relate to conducting and analyzing a single experiment. However, you may require a sequence of experiments to achieve your goals.

The example in “The Coffee Strength Experiment” explicitly illustrates the steps in the DOE workflow process. It also shows how to use a data table script to analyze your experimental data. Many examples in the *Design of Experiments Guide* illustrate both the workflow that supports a good design and the analysis of the experimental data from the study.

---

The Coffee Strength Experiment

- “Define the Study and Goals”
- “Create the Design”
- “Run the Experiment”
- “Analyze the Data”
**Define the Study and Goals**

Your employer is a local mid-size coffee roaster. You need to address the strength of individually brewed twelve ounce cups of coffee. Your goal is to determine which factors have an effect on coffee strength and to find optimal settings for those factors.

**Response**

The response is coffee Strength. It is measured as total dissolved solids, using a refractometer. The coffee is brewed using a single cup coffee dripper and measured five minutes after the liquid is released from the grounds.

Previous studies indicate that a strength reading of 1.3 is most desirable, though the strength is still acceptable if it falls between 1.2 and 1.4.

**Factors**

Four factors are identified for the study: Grind, Temperature, Time, and Charge. Coffee is brewed at three stations in the work area. To account for variation due to brewing location, Station is included in the study as a blocking factor. The following describes the factors:

- **Grind** is the coarseness of the grind. Grind is set at two levels, Medium and Coarse.
- **Temperature** is the temperature in degrees Fahrenheit of the water measured immediately before pouring it over the grounds. Temperature is set at 195 and 205 degrees Fahrenheit.
- **Time** is the brewing time in minutes. Time is set at 3 or 4 minutes.
- **Charge** is the amount of coffee placed in the cone filter, measured in grams of coffee beans per ounce of water. Charge is set at 1.6 and 2.4.
- **Station** is the location where the coffee is brewed. The three stations are labeled as 1, 2, and 3.

*Table 3.1* summarizes information about the factors and their settings. The factors and levels are also given in the Coffee Factors.jmp sample data table, located in the Design Experiment folder.

<table>
<thead>
<tr>
<th>Factor</th>
<th>Role</th>
<th>Range of Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grind</td>
<td>Categorical</td>
<td>Medium, Coarse</td>
</tr>
<tr>
<td>Temperature</td>
<td>Continuous</td>
<td>195 - 205</td>
</tr>
<tr>
<td>Time</td>
<td>Continuous</td>
<td>3 - 4</td>
</tr>
<tr>
<td>Charge</td>
<td>Continuous</td>
<td>1.6 - 2.4</td>
</tr>
</tbody>
</table>
Note the following:

- Grind is categorical with two levels.
- Temperature, Time, and Charge are continuous.
- Station is a blocking factor with three levels.

All factors can be varied and reset for each run. There are no hard-to-change factors for this experiment.

The apparatus used in running the coffee experiment is shown in Figure 3.3. This is the setup at one of the three brewing stations. The two other stations have the same type of equipment.

Figure 3.3 Coffee Experiment Apparatus

Table 3.1 Factors and Range of Settings for Coffee Experiment *(Continued)*

<table>
<thead>
<tr>
<th>Factor</th>
<th>Role</th>
<th>Range of Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Station</td>
<td>Blocking</td>
<td>1, 2, 3</td>
</tr>
</tbody>
</table>

Number of Runs

Based on the resources and time available, you determine that you can conduct 12 runs in all. Since there are three stations, you conduct 4 runs at each station.
Create the Design

Create the design following the steps in the design workflow process outlined in “The DOE Workflow: Describe, Specify, Design”:

- “Define Responses and Factors”
- “Specify the Model”
- “Generate the Design”
- “Evaluate the Design”
- “Make the Table”

Define Responses and Factors

In the first outlines that appear, enter information about your response and factors.

Responses

1. Select **DOE > Custom Design**.
2. Double-click **Y** under **Response Name** and type **Strength**.
   - Note that the default Goal is **Maximize**. Your goal is to find factor settings that enable you to brew coffee with a target strength of 1.3, within limits of 1.2 and 1.4.
3. Click the default Goal of **Maximize** and change it to **Match Target**.

**Figure 3.4** Selection of Match Target as the Goal

4. Click under **Lower Limit** and type 1.2.
5. Click under **Upper Limit** and type 1.4.
6. Leave the area under **Importance** blank.
   - Because there is only one response, that response is given Importance 1 by default.

The completed Responses outline appears in **Figure 3.5**.
Factors

Enter factors either manually or from a pre-existing table that contains the factors and settings. If you are designing a new experiment, you must first enter the factors manually. Once you have saved the factors to a data table using the Save Factors option, you can load them using the saved table.

For this example, you can choose either option. See “Entering Factors Manually” or see “Entering Factors Using Load Factors”.

Entering Factors Manually

1. Click **Add Factor > Categorical > 2 Level**.
2. Type **Grind** over the default Name of X1.
   
   Note that Role is set to Categorical, as requested. The Changes attribute is set to Easy by default, indicating that Grind settings can be reset for every run.
3. Click the default Values, L1 and L2, and change them to Coarse and Medium.
4. Type 3 next to **Add N Factors**. Then click **Add Factor > Continuous**.
5. Type the factor names and values over the default entries:
   
   - Temperature (195 and 205)
   - Time (3 and 4)
   - Charge (1.6 and 2.4)
6. Click **Add Factor > Blocking > 4 runs per block**.
   
   Recall that your run budget allows for 12 runs. You want to balance these runs among the three stations.
7. Type Station over the default Name of X5.
   
   Notice that Role is set to Blocking and that only one setting for Values appears. This is because JMP cannot determine the number of blocks until the desired number of runs is specified. Once you specify the Number of Runs in the Design Generation outline, JMP updates the number of levels for Station to what is required.
8. Click **Continue**.

   The following outlines are added to the Custom Design window:
   - Define Factor Constraints (not used in this example)
   - Model
   - Alias Terms
   - Design Generation

### Entering Factors Using Load Factors

Enter factors using a table containing factor information:

1. Click the Custom Design red triangle and select **Load Factors**.
2. Select **Help > Sample Data Library** and open Design Experiment/Coffee Factors.jmp.

   After loading the factors, the Custom Design window is updated with additional outlines:
   - Define Factor Constraints (not used in this example)
   - Model
   - Alias Terms
   - Design Generation

### Define Factor Constraints

The Define Factor Constraints outline appears once you have entered your factors manually and clicked Continue, or once you have loaded the factors from the factor table. Adding factor constraints, if you have any, is part of the Responses and Factors step. Since there are no constraints on factor settings for this design, leave this outline unchanged.
Specify the Model

Model Outline

Figure 3.7 shows the Model outline. The Model outline is where you specify your assumed model, which contains the effects that you want to estimate. See “Specify”. The list that appears by default shows all main effects as Necessary, indicating that the design is capable of estimating all main effects. Because your main interest at this point is in the main effects of the factors, you do not add any effects to the Model outline.

Steps to Duplicate Results (Optional)

Because the Custom Design algorithm begins with a random starting design, your design might differ from the one shown in Figure 3.8. To obtain a design with exactly the same runs, set the random seed and number of starts before generating your design:

1. Click the Custom Design red triangle and select Set Random Seed.
2. Type 569534903.
3. Click OK.
4. Click the Custom Design red triangle and select Number of Starts.
5. Type 100.
6. Click OK.

Note: Setting the Random Seed and Number of Starts reproduces the exact design shown in this example. However, the rows in the design table might be in a different order. In constructing a design on your own, these steps are not necessary.

Generate the Design

In the Design Generation outline, you can enter additional details about the structure and size of your design. The Default design is shown as having 12 runs. Recall that your design budget allows for 12 runs (“Number of Runs”).
1. Click **Make Design**.

The Design and Design Evaluation outlines are added to the Custom Design window. The Output Options panel also appears.

The Design outline shows the design (Figure 3.8). If you did not set the random seed and number of starts as described in “Steps to Duplicate Results (Optional)”, your design might be different from the one in Figure 3.8. This is because the algorithm used to generate the design begins with a random starting design.

**Evaluate the Design**

The Design Evaluation outline provides various ways to evaluate your design. This is an important topic, but for simplicity, it is not covered in the context of this example. See “Evaluate Designs”.

**Make the Table**

Specify the order of runs in your data table using the Output Options panel. The default selection, **Randomize within Blocks**, is appropriate. This selection arranges the runs in a random order for each Station.
Figure 3.9 Output Options

1. Click **Make Table**.

   The data table shown in Figure 3.10 opens. Keep in mind that, if you did not set the random seed and number of starts as described in “Steps to Duplicate Results (Optional)”, your design table might be different. Your design table represents an alternative optimal design.

Figure 3.10 Custom Design Table

Note the asterisks in the Columns panel to the right of the factors and response. These indicate column properties that have been saved to the columns in the data table. These column properties are used in the analysis of the data. See “Factors” and “Factor Column Properties”.

**Run the Experiment**

At this point, you perform the experiment. At each Station, four runs are conducted in the order shown in the design table. Equipment and material are reset between runs. For example, if two consecutive runs require water at 195 degrees, separate 12-ounce batches of water are heated to 195 degrees after the heating container cools. The Strength measurements are recorded.
Your design and the experimental results for Strength are given in the Coffee Data.jmp sample data table (Figure 3.11), located in the Design Experiment folder.

**Figure 3.11**  Coffee Design with Strength Results

<table>
<thead>
<tr>
<th></th>
<th>Grind</th>
<th>Temperature</th>
<th>Time</th>
<th>Charge</th>
<th>Station</th>
<th>Strength</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Medium</td>
<td>205</td>
<td>4</td>
<td>2.4</td>
<td>1</td>
<td>1.78</td>
</tr>
<tr>
<td>2</td>
<td>Coarse</td>
<td>195</td>
<td>3</td>
<td>1.6</td>
<td>1</td>
<td>1.25</td>
</tr>
<tr>
<td>3</td>
<td>Medium</td>
<td>205</td>
<td>3</td>
<td>1.6</td>
<td>1</td>
<td>1.10</td>
</tr>
<tr>
<td>4</td>
<td>Coarse</td>
<td>195</td>
<td>4</td>
<td>2.4</td>
<td>1</td>
<td>1.63</td>
</tr>
<tr>
<td>5</td>
<td>Coarse</td>
<td>205</td>
<td>4</td>
<td>1.6</td>
<td>2</td>
<td>1.26</td>
</tr>
<tr>
<td>6</td>
<td>Medium</td>
<td>195</td>
<td>4</td>
<td>2.4</td>
<td>2</td>
<td>1.63</td>
</tr>
<tr>
<td>7</td>
<td>Medium</td>
<td>195</td>
<td>3</td>
<td>1.6</td>
<td>2</td>
<td>1.22</td>
</tr>
<tr>
<td>8</td>
<td>Coarse</td>
<td>205</td>
<td>3</td>
<td>2.4</td>
<td>2</td>
<td>1.51</td>
</tr>
<tr>
<td>9</td>
<td>Coarse</td>
<td>205</td>
<td>4</td>
<td>1.6</td>
<td>3</td>
<td>1.07</td>
</tr>
<tr>
<td>10</td>
<td>Coarse</td>
<td>195</td>
<td>3</td>
<td>2.4</td>
<td>3</td>
<td>1.26</td>
</tr>
<tr>
<td>11</td>
<td>Medium</td>
<td>195</td>
<td>4</td>
<td>1.6</td>
<td>3</td>
<td>1.13</td>
</tr>
<tr>
<td>12</td>
<td>Medium</td>
<td>205</td>
<td>3</td>
<td>2.4</td>
<td>3</td>
<td>1.25</td>
</tr>
</tbody>
</table>

**Analyze the Data**

The Custom Design platform facilitates the task of data analysis by saving a Model script to the design table that it creates (Figure 3.10). Run this script after you conduct your experiment and enter your data. The script opens a Fit Model window containing the effects that you specified in the Model outline of the Custom Design window.

**Fit the Model**

1. Select **Help > Sample Data Library** and open Design Experiment/Coffee Data.jmp.
   - In the Table panel, notice the Model script created by Custom Design.
2. Click the green triangle next to the Model script.
   - The Model Specification window shows the effects that you specified in the Model outline.
3. Select the **Keep dialog open** option.
4. Click **Run**.

**Analyze the Model**

The Effect Summary and Actual by Predicted Plot reports give high-level information about the model.
Note the following:

- The Actual by Predicted Plot shows no evidence of lack of fit.
- The model is significant, as indicated by the Actual by Predicted Plot. The notation $P = 0.0041$, shown below the plot, gives the significance level of the overall model test.
- The Effect Summary report shows that Charge, Station, and Time are significant at the 0.05 level.
- The Effect Summary report also shows that Temperature and Grind are not significant.

**Reduce the Model**

Because Temperature and Grind appear not to be active, they contribute random noise to the model. Refit the model without these effects to obtain more precise estimates of the model parameters associated with the active effects.

1. In the Model Specification window, select Temperature and Grind in the Construct Model Effects list.
2. Click **Remove**.
3. Confirm that the model **Emphasis** is set to **Effect Screening**.
   
   The Effect Screening emphasis presents reports (such as the Prediction Profiler) that are useful for analyzing experimental designs.
4. Click **Run**.
Note the following:

- The Effect Tests report shows that all three effects remain significant.
- The Scaled Estimates report further indicates that the Station[1] and Station[3] means differ significantly from the average response of Strength.
- Note that the Estimates that appear in the Parameter Estimates report are identical to their counterparts in the Scaled Estimates report. This is because the effects are coded. See “Coding”.
- The estimate of the Station[3] effect only appears in the Scaled Estimates report, where nominal factors are expanded to show estimates for all their levels.
- The Parameter Estimates report gives estimates for the model coefficients where the model is specified in terms of the coded effects.

**Explore the Model**

The Prediction Profiler appears at the bottom of the report.
Recall that, in designing your experiment, you set a response Goal of Match Target with limits of 1.2 and 1.4. JMP uses this information to construct a desirability function to reflect your specifications. See “Factors”.

Note the following in Figure 3.15:

- The first two plots in the top row of the graph show how Strength varies for one of the factors, given the setting of the other factor. For example, when Charge is 2, the line in the plot for Time shows how predicted Strength changes with Time.
- The values to the left of the top row of plots give the Predicted Strength (in red) and a confidence interval for the mean Strength for the selected factor settings.
- The right-most plot in the top row shows the desirability function for Strength. The desirability function indicates that the target of 1.3 is most desirable. Desirability decreases as you move away from that target. Desirability is close to 0 at the limits of 1.2 and 1.4.
- The plots in the bottom row show the desirability trace for each factor at the setting of the other factor.
- The value to the left of the bottom row of plots gives the Desirability of the response value for the selected factor settings.

Explore various factor settings by dragging the red dashed vertical lines in the columns for Time and Charge. Since there are no interactions in the model, the profiler indicates that increasing Charge increases Strength. Also, Strength seems to be more sensitive to changes in Charge than to changes in Time.

Since Station is a blocking factor, it does not appear in the Prediction Profiler. However, you might like to see how predicted Strength varies by Station. Include Station in the Prediction Profiler:

1. Click the Prediction Profiler red triangle and select Reset Factor Grid.
A Factor Settings window appears with columns for Time, Charge, and Station. Under Station, notice that the box corresponding to Show is not selected. This indicates that Station is not shown in the Prediction Profiler.

2. Select the box under Station in the row corresponding to Show.
3. Deselect the box under Station in the row corresponding to Lock Factor Setting.

**Figure 3.16** Factor Settings Window

4. Click OK.

Plots for Station appear in the Prediction Profiler.

5. Click in either plot above Station to insert a dashed red vertical line.
6. Move the dashed red vertical line to Station 1.

**Figure 3.17** Prediction Profiler Showing Results for Station 1

7. Move the dashed red vertical line to Station 3.
Figure 3.18 Prediction Profiler Showing Results for Station 3

<table>
<thead>
<tr>
<th>Station</th>
<th>Predicted Strength</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1.44</td>
</tr>
<tr>
<td>3</td>
<td>1.18</td>
</tr>
</tbody>
</table>

The predicted Strength in the center of the design region for Station 1 is 1.44. For Station 3, the predicted Strength is about 1.18. The magnitude of the difference indicates that you need to address Station variability. Better control of Station variation should lead to more consistent Strength. Once Station consistency is achieved, you can determine common optimal settings for Time and Charge.

The process that you used to construct the design for the coffee experiment followed the steps in the DOE workflow. The next section describes the DOE workflow in more detail.

The DOE Workflow: Describe, Specify, Design

The DOE platforms are structured as a series of steps that present the workflow that is intrinsic to designing experiments. Once you complete each step, you click Continue to move to the next step. The elements described in this section are common to nine of the design of experiments platforms. These are the platforms that are addressed in this section:

- Custom Design
- Definitive Screening Design
- Screening Design
- Response Surface Design
- Full Factorial Design
- Mixture Design
- **JMP Pro** Covering Array
- Space Filling Design
- Taguchi Arrays
Three special-purpose platforms differ substantially: Choice Designs, Accelerated Life Test Design, and Nonlinear Design. These three platforms are not addressed in this section.

This section describes the steps in the DOE workflow. It also discusses their implementation in the various design platforms.

**Define Responses and Factors**

In the Describe step of the experimental design framework:

- You identify the responses and factors of interest.
- You determine your goals for the experiment. Do you want to maximize the response, or hit a target? What is that target? Or do you simply want to identify which factors have an effect on the response?
- You identify factor settings that describe your experimental range or design space.

When they open, most of the JMP DOE platforms display outlines where you can list your responses and your factors. The Responses outline is common across platforms. There you insert your responses and additional information, such as the response goal, lower limit, upper limit, and importance.

The Factors outline varies across platforms. This is to accommodate the types of factors and specific design situations that each platform addresses. In certain platforms, once responses and factors are entered, a Define Factor Constraints outline appears after you click Continue. In this outline, you can constrain the values of the factors that are available for the design.

Figure 3.19 shows the Responses and Factors outline using the Custom Design platform for constructing the design in the Box Corrosion Split-Plot.jmp sample data table, located in the Design Experiment folder. Also shown is the Define Factor Constraints outline, which appears once you click Continue. The Define Constraints outline enables you to specify restrictions that your factor settings must satisfy.
Specify the Model

Once you have completed filling in the Responses and Factors outlines, click the Continue button. This brings you to the next phase of design construction, where you either explicitly or implicitly choose an assumed model.

The Custom Design platform enables you to explicitly specify the model that you want to fit. The design that is generated is optimal for this model. The other design platforms do not allow you to explicitly specify your model. For example, in the screening platform, one option enables you to choose from a list of full factorial, fractional factorial, and Plackett-Burman designs. The aliasing relationships in these designs implicitly define the models that you can fit.

In Custom Design, when you click Continue after filling in the Responses and Factors, you see the Model outline. An example, for the design used in the Box Corrosion Split-Plot.jmp sample data table, is shown in Figure 3.20. The assumed model requires that the Furnace Temp and Coating main effects, and their interaction, be estimable. The design that is generated guarantees estimability of these effects.

In most other platforms, clicking Continue gives you a collection of designs to choose from. In Full Factorial, Continue takes you directly to Output Options, since the design is determined once the Factors outline is completed.
Generate the Design

Most of the DOE platforms give you some control over the size of the final design. In Custom Design, you can specify the number of runs and, when appropriate, the number of center points and replicate runs. In other platforms, you have various degrees of flexibility. Often you can specify the number of center points, replicate runs, or replicates of the design.

Once you have specified your options in terms of the number of runs, click Make Design. The DOE window is updated to show your design in a Design outline.

The Design outline for a 24-run custom design for the Box Corrosion Split-Plot.jmp experiment is shown in Figure 3.21. Because Changes for Furnace Temp was specified as Hard, a Whole Plots factor is constructed to represent the random blocks of settings for Furnace Temp.

Figure 3.21  Design Outline for Box Corrosion Split-Plot Experiment
Note: For a custom design, once you have created your design, the controls in the Model and Alias Outlines are disabled. Use the Back button to change model or alias terms.

Evaluate the Design

When you click Make Design, in most platforms, a Design Evaluation outline appears. Here you can explore the design that you created in terms of its power to detect effects, its prediction variance, its estimation efficiency, its aliasing relationships, the correlations between effects, and other design efficiency measures. The Design Evaluation outline for a Custom Design is shown in Figure 3.22. Design Evaluation is covered in “Evaluate Designs”.

For some platforms, other types of design diagnostics are appropriate. For example, Space Filling Design provides a Design Diagnostics outline with metrics specific to space-filling designs. Covering Array provides a Metrics outline with measures that are specific to coverage.

Figure 3.22  Design Evaluation Outline in Custom Design

Make the Table

Most platforms provide an Output Options node or panel. Depending on the platform and the design, you can use the Output Options panel to specify additional design structure. For example, you can specify the number of runs, center points, replicates, or the order in which you want the design runs to appear in the generated data table.

The Output Options panel shown in Figure 3.23 is for the experiment in the Wine Data.jmp sample data table, located in the Design Experiment folder. In this example, you can choose various Run Order options and construct the design data table. Or, you can choose to go Back and restructure your design.
Principles and Guidelines for Experimental Design

Certain principles underlie the design of experiments and the analysis of experimental data. The principles of effect hierarchy, effect heredity, and effect sparsity relate primarily to model selection. These principles help you reduce the set of possible models in searching for a best model. See Hamada and Wu (1992), Wu and Hamada (2009), and Goos and Jones (2011).

- “Effect Hierarchy”
- “Effect Heredity”
- “Effect Sparsity”
- “Center Points, Replicate Runs, and Testing”

Effect Hierarchy

In regression modeling, the principle of effect hierarchy maintains that main (first-order) effects tend to account for the largest amounts of variation in the response. Second-order effects, that is, interaction effects and quadratic terms, are next in terms of accounting for variation. Then come higher-order terms, in hierarchical order.

Here are the implications for modeling: main effects are more likely to be important than second-order effects; second-order effects are more likely to be important than third-order effects; and so on, for higher-order terms.

Effect Heredity

The principle of effect heredity relates to the inclusion in the model of lower-order components of higher-order effects. The motivation for this principle is observational evidence that factors with small main effects tend not to have significant interaction effects.
Strong effect heredity requires that all lower-order components of a model effect be included in the model. Suppose that a three-way interaction (ABC) is in the model. Then all of its component main effects and two-way interactions (A, B, C, AB, AC, BC) must also be in the model.

Weak effect heredity requires that only a sequence of lower-order components of a model effect be included. If a three-way interaction is in the model, then the model must contain one of the factors involved and one two-way interaction involving that factor. Suppose that the three-way interaction ABC is in the model. Then if B and BC are also in the model, the model satisfies weak effect heredity.

For continuous factors, effect heredity ensures that the model is invariant to changes in the location and scale of the factors.

Effect Sparsity

The principle of effect sparsity asserts that most of the variation in the response is explained by a relatively small number of effects. Screening designs, where many effects are studied, rely heavily on effect sparsity. Experience shows that the number of runs used in a screening design should be at least twice the number of effects that are likely to be significant.

Center Points, Replicate Runs, and Testing

Several DOE platforms enable you to add center points (for continuous factors), replicate runs, or full replicates of the design, to your design. Here is some background relative to adding design points.

Adding Center Points

Center points for continuous factors enable you to test for lack of fit due to nonlinear effects. Testing for lack of fit helps you determine whether the error variance estimate has been inflated due to a missing model term. This can be a wise investment of runs.

You can replicate runs solely at center points or you can replicate other design runs. JMP uses replicate runs to construct a model-independent error estimate (pure-error estimate). This pure-error estimate enables you to test for lack of fit.

Be aware that center points do not help you obtain more precise estimates of model effects. They enable you to test for evidence of curvature, but do not identify the responsible nonlinear effects.

To identify the source of curvature, you must set continuous factors at a minimum of three levels. Definitive screening designs are three-level designs with the ability to detect and identify any factors causing strong nonlinear effects on the response. See “Definitive Screening Designs”.
Adding Replicate Runs

If your run budget allows, you can either replicate runs or distribute new runs optimally within the design space. Adding replicate runs adds precision for some estimates and improves the power of the lack of fit test. However, for a given run budget, adding replicate runs generally lowers the ability of the design to estimate model effects. You are not able to estimate as many terms as you could by distributing the runs optimally within the design space.

Testing for Lack of Fit

Designed experiments are typically constructed to require as few runs as possible, consistent with the goals of the experiment. With too few runs, only extremely large effects can be detected. For example, for a given effect, the \( t \) test statistic is the ratio of the change in response means to their standard error. If there is only one error degree of freedom (df), then the critical value of the test exceeds 12. So, for such a nearly saturated design to detect an effect, it has to be very large.

A similar observation applies to the lack-of-fit test. The power of this test to detect lack-of-fit depends on the numbers of degrees of freedom in the numerator and denominator. If you have only 1 df of each kind, you need an \( F \) value that exceeds 150 to declare significance at the 0.05 level. If you have 2 df of each kind, then the \( F \) value must exceed 19. In order for the test to be significant in this second case, the lack-of-fit mean square must be 19 times larger than the pure error mean square. It is also true that the lack-of-fit test is sensitive to outliers.

For more information about the Lack of Fit test, see Fitting Linear Models.

Determining the Number of Runs

In industrial applications, each run is often very costly, so there is incentive to minimize the number of runs. To estimate the fixed effects of interest, you need only as many runs as there are terms in the model. To determine whether the effects are active, you need a reasonable estimate of the error variance. Unless you already have a good estimate of this variance, consider adding at least 4 runs to the number required to estimate the model terms.
Use the Custom Design platform to construct optimal designs that are custom built for your specific experimental setting. Generally, a custom design is more cost-effective than a design obtained using alternative methods. You can perform the following tasks:

- Enter factors of many different types.
- Specify constraints on the design space.
- Indicate which effects are necessary to estimate and which are desirable to estimate, if possible, given the number of runs.
- Specify a number of experimental runs that matches your budget.

The Custom Design platform constructs a wide variety of designs, including these special design types: Screening, Response Surface, Mixture, Random Block, Split Plot, Split-Split-Plot, and Two-Way Split Plot.

This chapter contains a detailed example of how to use the Custom Design platform, followed by information about the platform. See also “Examples of Custom Designs”.

**Figure 4.1** Color Map for Absolute Correlations
Contents

Overview of Custom Design ........................................................................................................... 69
Example of a Custom Design ........................................................................................................... 71
Build a Custom Design .................................................................................................................... 88
  Responses ....................................................................................................................................... 88
  Factors ........................................................................................................................................... 90
  Define Factor Constraints ............................................................................................................. 97
  Alias Terms ................................................................................................................................... 102
Design Generation ............................................................................................................................ 103
Design .............................................................................................................................................. 106
Design Evaluation .............................................................................................................................. 106
Output Options ................................................................................................................................ 107
Custom Design Options .................................................................................................................... 109
  Simulate Responses ......................................................................................................................... 113
  Save X Matrix ................................................................................................................................. 115
  Number of Starts ............................................................................................................................. 117
  Design Search Time ........................................................................................................................ 118
Technical Details for Custom Designs .............................................................................................. 119
  Designs with Randomization Restrictions ...................................................................................... 119
  Covariates with Hard-to-Change Levels ......................................................................................... 128
  Numbers of Whole Plots and Subplots ........................................................................................... 128
  Optimality Criteria .......................................................................................................................... 129
  D-Efficiency ................................................................................................................................... 134
  Coordinate-Exchange Algorithm .................................................................................................... 134
Overview of Custom Design

Use the Custom Design platform to construct an optimal design custom built for your specific experimental needs.

You can include a wide range of factor types, including the following:

- Continuous
- Discrete numeric (with any number of levels)
- Categorical (with any number of levels)
- Blocking (with a specified number of runs per block)
- Covariate
- Mixture
- Constant
- Uncontrolled

Specify the Region of Operability

You can restrict your experimental region to reflect your operating conditions using linear factor constraints or disallowed combinations. In particular, restrictions can be specified for categorical, continuous, and discrete numeric factors. See “Define Factor Constraints”.

Specify Factors with Hard-to-Change Levels

For continuous, discrete numeric, categorical, and mixture factors, you can indicate two levels of difficult-to-change factors. These difficulty levels are represented by whole plots or whole plots and split plots. You can also specify hard-to-change covariates.

Specify the Effects of Primary Interest

You can explicitly specify your assumed model. Your assumed model is an initial model that ideally contains all the effects that you want to estimate. Your model can contain any combination of main effects, interactions, response surface effects, and polynomial effects (up to the fifth power). You can specify the effects for which estimability is necessary and those for which estimability is desired. Custom Design uses a Bayesian optimality approach to estimate effects whose estimability is desired, subject to the number of runs. See “Model”.
Specify the Number of Runs

The Custom Design platform enables you to specify the number of runs that matches the budget for your experimental situation. The platform indicates the minimum number of runs that can be used to estimate the required effects and provides a default number of runs. These values can serve as a guide for determining a feasible number of runs. See “Design Generation”.

Construct the Appropriate Design Type

Custom Design can construct a wide variety of design types. These include classical designs and random block designs. For examples of different design types, see “Examples of Custom Designs”.

Construct an Optimal Design

Given your specific requirements, the Custom Design platform constructs a design that is optimal. The algorithm supports several optimality criteria:

- D optimality
- I optimality
- Bayesian D and I optimality (using If Possible effects)
- A optimality
- Alias optimality

See “Optimality Criteria”.

Designs are constructed using the coordinate-exchange algorithm (Meyer and Nachtsheim, 1995). See “Coordinate-Exchange Algorithm”.
**Example of a Custom Design**

Use the custom designer to design an experiment to investigate the effect of wine processing factors on wine taste. Your employer grows two varieties of Pinot Noir grapes that can be processed in different ways. Your goal is to determine which factors affect the taste of Pinot Noir wine. Before the grapes are processed, you set up your experimental design. Once processed, the wine samples are aged for 12 months, then filtered and bottled. At this point, the wine samples are rated for quality by expert wine tasters.

**Response**

Most of your vineyard’s product is sold to five large wine distributors. You arrange for a wine-tasting expert from each distributor to evaluate the wine samples for quality. To maximize the number of factors that you can study, you decide that each expert must rate eight different samples. This means that your design needs to have 40 wine samples, or runs.

The ratings follow a 0 – 20 scale, where 0 is the worst and 20 is the best. Rating, the variable consisting of the experts’ ratings, is the response of interest. You want to identify the wine-related factors that maximize the response.

**Blocking Factor**

A blocking factor is used to account for variation that is not necessarily of direct interest. A blocking factor is particularly effective when observations taken at one factor level are expected to be more similar than observations at different levels. In your experiment, ratings by one expert are likely to have similar characteristics and to differ from ratings by a different expert. Yet, you are interested in which properties of the wine lead to high ratings by all experts.

Because each rater tastes eight wines, Rater is a blocking factor with eight runs per block. For this experiment, only these five raters are of concern. You are not interested in generalizing to a larger population of raters.

**Process Factors**

You have identified nine process factors for the study. These include the grape variety, the field on which the grapes were grown, and seven other factors related to processing. You can experiment with any combination of these factors. Also, the factors can be varied at will as part of the experiment. Relative to the experiment, these factors are all “Easy” to change. For information about specifying factor changes, see “Changes and Random Blocks”.

The factors and their levels appear in Table 4.1. Note that all of these factors are categorical. The factors and their levels are also given in the factor table Wine Factors.jmp in the Design Experiment folder of Sample Data.
To experiment with all possible combinations of these factors would require a staggering \( 4 \times 2^8 = 1024 \) runs. However, in this example, you are able to construct a compelling design in only 40 runs.

Table 4.1 Process Factors and Levels for Wine Tasting Experiment

<table>
<thead>
<tr>
<th>Factor</th>
<th>Levels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variety</td>
<td>Bernard, Dijon</td>
</tr>
<tr>
<td>Field</td>
<td>1, 2, 3, 4</td>
</tr>
<tr>
<td>De-Stem</td>
<td>No, Yes</td>
</tr>
<tr>
<td>Yeast</td>
<td>Cultured, Wild</td>
</tr>
<tr>
<td>Temperature</td>
<td>High, Low</td>
</tr>
<tr>
<td>Press</td>
<td>Hard, Soft</td>
</tr>
<tr>
<td>Barrel Age</td>
<td>New, 2 Years</td>
</tr>
<tr>
<td>Barrel Seasoning</td>
<td>Air, Kiln</td>
</tr>
<tr>
<td>Filtering</td>
<td>No, Yes</td>
</tr>
</tbody>
</table>

Now that the experimental goals, factors, and responses have been defined, you can build your custom design.

Add Responses

For this custom design example add your response, the response Goal, and, if appropriate, the Lower Limit, Upper Limit, and Importance. Here, the response is Rating.

1. Select **DOE > Custom Design**.
2. Double-click **Y** under Response Name and type Rating.
   - Note that the default Goal is Maximize. Because you want to maximize the taste rating, do not change the goal.
3. Click under Lower Limit and type 0.
   - The least desirable rating is 0.
4. Click under Upper Limit and type 20.
   - The most desirable rating is 20.
5. Leave the area under Importance blank.
   - Because there is only one response, that response is given Importance 1 by default.
Figure 4.2 shows the completed Responses outline.

Add Factors Manually or Automatically

For this custom design example, enter factors either manually or automatically using a pre-existing table that contains the factors and settings.

- If you are designing a new experiment, you must first enter the factors manually. See “Add Factors Manually”.
- Once you have saved the factors using the Save Factors option, you can load them automatically using the saved table. See “Add Factors Automatically Using Load Factors”.

Both methods add these four outlines to the Custom Design window: Define Factor Constraints, Model, Alias Terms, and Design Generation.

Add Factors Manually

1. First, add the blocking factor, Rater. Click Add Factor > Blocking > 8 runs per block.
2. Type Rater over the default Name of X1.
   Note that Role is set to Blocking. Note also that only one setting for Values appears. This is because the number of blocks cannot be determined until the desired number of runs is specified. Once you specify the Number of Runs in the Design Generation outline, the number of levels for Rater updates to what is required.
3. Click Add Factor > Categorical > 2 Level.
4. Type Variety over the default Name of X2.
   Note that Role is set to Categorical, as requested, and that Changes is set to Easy by default.
5. Click L1 and L2 and change them to Bernard and Dijon.
6. Click Add Factor > Categorical > 4 Level.
7. Type Field over the default Name of X3.
8. Click L1, L2, L3, and L4, and change them to 1, 2, 3, and 4.
9. Click Add Factor > Categorical > 2 Level.
10. Type De-Stem over the default Name of X4.
11. Click L1 and L2 and change them to No and Yes.
12. Type 6 next to Add N Factors, and then click Add Factor > Categorical > 2 Level. This adds six categorical two-level factors to your design.
13. Change the default factor names and values:
   - Yeast (Cultured and Wild)
– Temperature (High and Low)
– Press (Hard and Soft)
– Barrel Age (New and Two Years)
– Barrel Seasoning (Air and Kiln)
– Filtering (No and Yes)

**Figure 4.2** Completed Responses and Factors Outlines

<table>
<thead>
<tr>
<th>Response Name</th>
<th>Goal</th>
<th>Lower Limit</th>
<th>Upper Limit</th>
<th>Importance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rating</td>
<td>Maximize</td>
<td>0</td>
<td>20</td>
<td>1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>Role</th>
<th>Changes</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rate</td>
<td>Blocking</td>
<td>Easy</td>
<td>1</td>
</tr>
<tr>
<td>Variety</td>
<td>Categorical</td>
<td>Easy</td>
<td>Bernard, Dijon</td>
</tr>
<tr>
<td>Field</td>
<td>Categorical</td>
<td>Easy</td>
<td>1, 2, 3, 4</td>
</tr>
<tr>
<td>De Stem</td>
<td>Categorical</td>
<td>Easy</td>
<td>No, Yes</td>
</tr>
<tr>
<td>Yeast</td>
<td>Categorical</td>
<td>Easy</td>
<td>Cultured, Wild</td>
</tr>
<tr>
<td>Temperature</td>
<td>Categorical</td>
<td>Easy</td>
<td>High, Low</td>
</tr>
<tr>
<td>Press</td>
<td>Categorical</td>
<td>Easy</td>
<td>Hard, Soft</td>
</tr>
<tr>
<td>Barrel Age</td>
<td>Categorical</td>
<td>Easy</td>
<td>New, 2 Years</td>
</tr>
<tr>
<td>Barrel Seasoning</td>
<td>Categorical</td>
<td>Easy</td>
<td>Air, Kiln</td>
</tr>
<tr>
<td>Filtering</td>
<td>Categorical</td>
<td>Easy</td>
<td>No, Yes</td>
</tr>
</tbody>
</table>

14. Click **Continue**.

The following outlines are added to the Custom Design window:

- Define Factor Constraints (not used in this example)
- Model
- Alias Terms
- Design Generation

**Add Factors Automatically Using Load Factors**

Enter factors using a table containing factor information:

1. Select **Help > Sample Data Library** and open Design Experiment/Wine Factors.jmp.
2. Click the Custom Design red triangle and select **Load Factors**.

After loading the factors, the Custom Design window automatically updates. The following outlines are added to the Custom Design window:

- Define Factor Constraints (not used in this example)
- Model
Define the Model

For this custom design example, the Model outline shows all main effects as Necessary, indicating that the design needs to be capable of estimating all main effects. Your assumed model reflects your interest in main effects only. However, if you wanted to estimate other effects, you could add them to the Model outline. For more information about models, see “Model”.

Figure 4.3 Model Outline

<table>
<thead>
<tr>
<th>Name</th>
<th>Estimability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intercept</td>
<td>Necessary</td>
</tr>
<tr>
<td>Variety</td>
<td>Necessary</td>
</tr>
<tr>
<td>Field</td>
<td>Necessary</td>
</tr>
<tr>
<td>De-Stem</td>
<td>Necessary</td>
</tr>
<tr>
<td>Yeast</td>
<td>Necessary</td>
</tr>
<tr>
<td>Temperature</td>
<td>Necessary</td>
</tr>
<tr>
<td>Press</td>
<td>Necessary</td>
</tr>
<tr>
<td>Barrel Age</td>
<td>Necessary</td>
</tr>
<tr>
<td>Barrel Seasoning</td>
<td>Necessary</td>
</tr>
<tr>
<td>Filtering</td>
<td>Necessary</td>
</tr>
<tr>
<td>Rater</td>
<td>Necessary</td>
</tr>
</tbody>
</table>

Define Alias Terms

The Alias Terms outline specifies the effects to be shown in the Alias Matrix, which appears later. The Alias Matrix shows the aliasing relationships between the Model terms and the effects listed in the Alias Terms outline. Open the Alias Terms outline node to verify that all two-factor interactions are listed. For more information about the alias matrix, see “Alias Matrix”.
Set Random Seed to Duplicate Design

The Custom Design algorithm begins with a random starting design. To duplicate a design such as in this example, or in a teaching setting, set the random seed used to define the starting design. If you want to obtain a design with exactly the same runs and run order as the one shown in Figure 4.5, set the random seed and number of starts:

1. Click the Custom Design red triangle and select Set Random Seed.
2. Type 100526291 (the random seed).
3. Click OK.
4. Click the Custom Design red triangle and select Number of Starts.
5. Type 2.
6. Click OK.

Note: Setting the Random Seed and Number of Starts reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

Generate the Design

In the Design Generation outline, you can enter additional details about the structure and size of your design. In this example, the Default design shows 16 runs. But you have five raters, each of whom can sample eight wines. This means that you want a design with 40 runs. Change the number of design runs:

1. Under Number of Runs, type 40 in the User Specified box.
   Because you do not want to replicate runs, leave the Number of Replicate Runs set to 0.
2. Click Make Design.

The Design and Design Evaluation outlines are added to the Custom Design window. The Output Options panel also appears.
Verify the Design

The Design outline shows the runs in the custom design that you have constructed. Later, you are able to randomize the order under Output Options. For now, verify that this design is appropriate for your experiment. For example, check that each of five Raters evaluates eight wines, that all necessary factors are shown, and that none of the settings represent infeasible combinations.

**Figure 4.5 Design for Wine Experiment**

<table>
<thead>
<tr>
<th>Run</th>
<th>Rater</th>
<th>Variety</th>
<th>Field</th>
<th>De-Stem</th>
<th>Yeast</th>
<th>Temperature</th>
<th>Press</th>
<th>Barrel Age</th>
<th>Seasoning</th>
<th>Filtering</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Dijon</td>
<td>3</td>
<td>No</td>
<td>Wild</td>
<td>High</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>Bernard</td>
<td>4</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>New</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>Bernard</td>
<td>2</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>Bernard</td>
<td>1</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>Dijon</td>
<td>1</td>
<td>Yes</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>Dijon</td>
<td>2</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>Dijon</td>
<td>1</td>
<td>No</td>
<td>Cultured</td>
<td>High</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>8</td>
<td>3</td>
<td>Dijon</td>
<td>4</td>
<td>No</td>
<td>Cultured</td>
<td>High</td>
<td>Soft</td>
<td>New</td>
<td>Air</td>
<td>Yes</td>
</tr>
<tr>
<td>9</td>
<td>4</td>
<td>Dijon</td>
<td>4</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>10</td>
<td>5</td>
<td>Bernard</td>
<td>2</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>Yes</td>
</tr>
<tr>
<td>11</td>
<td>1</td>
<td>Bernard</td>
<td>3</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>12</td>
<td>2</td>
<td>Dijon</td>
<td>1</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
</tr>
<tr>
<td>13</td>
<td>3</td>
<td>Bernard</td>
<td>4</td>
<td>Yes</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>2 Years</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>Bernard</td>
<td>3</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>15</td>
<td>5</td>
<td>Dijon</td>
<td>2</td>
<td>No</td>
<td>Cultured</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>16</td>
<td>1</td>
<td>Dijon</td>
<td>1</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>17</td>
<td>2</td>
<td>Bernard</td>
<td>2</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>18</td>
<td>3</td>
<td>Dijon</td>
<td>2</td>
<td>Yes</td>
<td>Cultured</td>
<td>High</td>
<td>Hard</td>
<td>New</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>19</td>
<td>4</td>
<td>Bernard</td>
<td>1</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>20</td>
<td>5</td>
<td>Bernard</td>
<td>3</td>
<td>Yes</td>
<td>Cultured</td>
<td>High</td>
<td>Hard</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
</tr>
<tr>
<td>21</td>
<td>1</td>
<td>Bernard</td>
<td>4</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>2 Years</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>22</td>
<td>2</td>
<td>Bernard</td>
<td>4</td>
<td>Yes</td>
<td>Cultured</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>23</td>
<td>3</td>
<td>Dijon</td>
<td>1</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>24</td>
<td>4</td>
<td>Dijon</td>
<td>2</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>25</td>
<td>5</td>
<td>Bernard</td>
<td>1</td>
<td>No</td>
<td>Cultured</td>
<td>High</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>26</td>
<td>1</td>
<td>Bernard</td>
<td>2</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>27</td>
<td>2</td>
<td>Dijon</td>
<td>3</td>
<td>No</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>28</td>
<td>3</td>
<td>Bernard</td>
<td>1</td>
<td>No</td>
<td>Wild</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
</tr>
<tr>
<td>29</td>
<td>4</td>
<td>Bernard</td>
<td>3</td>
<td>Yes</td>
<td>Cultured</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>30</td>
<td>5</td>
<td>Dijon</td>
<td>3</td>
<td>Yes</td>
<td>Wild</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Klin</td>
<td>No</td>
</tr>
<tr>
<td>31</td>
<td>1</td>
<td>Dijon</td>
<td>4</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>32</td>
<td>2</td>
<td>Bernard</td>
<td>2</td>
<td>Yes</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>33</td>
<td>3</td>
<td>Bernard</td>
<td>3</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Soft</td>
<td>2 Years</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>34</td>
<td>4</td>
<td>Dijon</td>
<td>2</td>
<td>No</td>
<td>Cultured</td>
<td>High</td>
<td>Hard</td>
<td>2 Years</td>
<td>Klin</td>
<td>Yes</td>
</tr>
<tr>
<td>35</td>
<td>5</td>
<td>Dijon</td>
<td>4</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Air</td>
<td>Yes</td>
</tr>
<tr>
<td>36</td>
<td>1</td>
<td>Bernard</td>
<td>1</td>
<td>Yes</td>
<td>Cultured</td>
<td>High</td>
<td>Soft</td>
<td>New</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>37</td>
<td>2</td>
<td>Dijon</td>
<td>3</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>38</td>
<td>3</td>
<td>Dijon</td>
<td>3</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>39</td>
<td>4</td>
<td>Dijon</td>
<td>4</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Air</td>
<td>No</td>
</tr>
<tr>
<td>40</td>
<td>5</td>
<td>Bernard</td>
<td>4</td>
<td>No</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Evaluate the Design

The Design Evaluation outline provides different ways to evaluate your custom design. For this example, open the Design Evaluation outline, and examine the Color Map on Correlations, the Alias Matrix, and Design Diagnostics.

**Note:** For more information about the Design Evaluation outline, see “Evaluate Designs”.

Color Map on Correlations

The Color Map on Correlations shows the absolute value of the correlation between any two effects that appear in either the Model or the Alias Terms outline.

*Figure 4.6  Color Map on Correlations*

The main effects are represented by the 15 terms in the upper left corner of the map. The white corresponding to the correlations of main effects with other main effects indicate correlations of 0. This means that all main effects are orthogonal and can be estimated independently.
The only black in Figure 4.6 is on the main diagonal. Black indicates absolute correlations of one, reflecting that each term is perfectly correlated with itself. It follows that no main effect is completely confounded with any two-way interaction. In fact, the absolute values of the correlations of main effects with two-way interactions are fairly low. This means that estimates of main effects might be only slightly biased by the presence of active two-way interactions.

**Tip:** Hover over cells in the color map to see the absolute correlations between effects. Right-click below the legend to save the correlations to a data table.

### Alias Matrix

In the Alias Matrix, model effects are listed in the column on the left. For a given model effect, a column entry indicates the degree to which the column effect (if active) biases the estimate of the model effect.

**Figure 4.7 Partial View of Alias Matrix**

<table>
<thead>
<tr>
<th>Alias Matrix</th>
<th>Effect</th>
<th>Variety*Field 1</th>
<th>Variety*Field 2</th>
<th>Variety*Field 3</th>
<th>Variety*Stem</th>
<th>Variety*Yeast</th>
<th>Variety*Temperature</th>
<th>Variety*Press</th>
<th>Variety*Barrel Age</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intercept</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Variety</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Field 1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0.141</td>
<td>0.141</td>
<td>0.082</td>
<td>-0.24</td>
<td>-0.33</td>
</tr>
<tr>
<td>Field 2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0.082</td>
<td>-0.24</td>
<td>0.141</td>
<td>0</td>
<td>0.141</td>
</tr>
<tr>
<td>Field 3</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0.346</td>
<td>0.346</td>
<td>0.141</td>
<td>0</td>
<td>0.141</td>
</tr>
<tr>
<td>De-Stem</td>
<td>0.141</td>
<td>0.082</td>
<td>-0.12</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>-0.2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Yeast</td>
<td>0.141</td>
<td>-0.24</td>
<td>0.346</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Temperature</td>
<td>0</td>
<td>-0.33</td>
<td>0.115</td>
<td>-0.2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Press</td>
<td>-0.14</td>
<td>0.082</td>
<td>-0.12</td>
<td>0</td>
<td>-0.2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Barrel Age</td>
<td>0.283</td>
<td>0.327</td>
<td>-0.12</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>-0.2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Barrel Seasoning</td>
<td>0.288</td>
<td>0.163</td>
<td>0.115</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>-0.2</td>
<td>0.2</td>
<td>0</td>
</tr>
<tr>
<td>Filtering</td>
<td>-0.14</td>
<td>-0.08</td>
<td>0.115</td>
<td>-0.2</td>
<td>-0.2</td>
<td>0</td>
<td>-0.2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Rater 1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>-0.16</td>
<td>-0.16</td>
<td>0</td>
<td>0</td>
<td>-0.16</td>
<td>0.158</td>
</tr>
<tr>
<td>Rater 2</td>
<td>-0.26</td>
<td>0.149</td>
<td>-0.21</td>
<td>-0.27</td>
<td>0.274</td>
<td>-0.37</td>
<td>-0.09</td>
<td>-0.09</td>
<td>-0.09</td>
</tr>
<tr>
<td>Rater 3</td>
<td>0.091</td>
<td>-0.05</td>
<td>0.075</td>
<td>0</td>
<td>-0.19</td>
<td>-0.06</td>
<td>-0.26</td>
<td>-0.26</td>
<td>-0.26</td>
</tr>
<tr>
<td>Rater 4</td>
<td>0.354</td>
<td>-0.2</td>
<td>0.289</td>
<td>0</td>
<td>0.25</td>
<td>-0.25</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

For example, consider the model effect Barrel Seasoning. If Variety*Press is active, then the expected value of the estimate for the Barrel Seasoning effect differs from an unbiased estimate of that effect. The amount by which it differs is equal to 0.4 times the effect of Variety*Press. Therefore, what appears to be a significant Barrel Seasoning estimated effect could in reality be a significant Variety*Press effect.

### Design Diagnostics

The Design Diagnostics outline provides information about the efficiency of the design. Efficiency measures compare your design to a theoretically optimal design, which might not exist. The efficiency values are ratios, expressed as percents, of the efficiency of your design to the efficiency of this optimal design. For more information about the efficiency measures, see “Estimation Efficiency”.
Notice that the D-, G-, and A-efficiency values are all 100%. Because your design is orthogonal for main effects, the design is optimal for the main effects model relative to all three efficiency criteria.

The first line in the Design Diagnostics outline indicates that your design was constructed to optimize the D-efficiency criterion. See the Optimality Criterion description in “Custom Design Options”. In this case, your design has D Efficiency of 100%.

**Specify Design Table Options**

The final steps of your custom design generation are to specify options for the design table and to make the table. Specify the order of runs in your data table using the Output Options panel. The default selection, Randomize within Blocks, is appropriate for this example. Simply click Make Table.

A Custom Design table is created and opens, similar to the one in Figure 4.9.

*Note:* Your table might look different because the algorithm that creates it uses a random starting design. To obtain the precise table shown in Figure 4.9, set the random seed and number of starts as described in “Set Random Seed to Duplicate Design”.
Figure 4.9 Custom Design Table

<table>
<thead>
<tr>
<th>Rater</th>
<th>Variety</th>
<th>Field</th>
<th>De-Stem</th>
<th>Yeast</th>
<th>Temperature</th>
<th>Press</th>
<th>Barrel Age</th>
<th>Barrel Seasoning</th>
<th>Filtering</th>
<th>Rating</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Dijon</td>
<td>4</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
<td>•</td>
</tr>
<tr>
<td>2</td>
<td>Bernard 1</td>
<td>Yes</td>
<td>Cultured</td>
<td>High</td>
<td>Soft</td>
<td>New</td>
<td>Air</td>
<td>No</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Bernard 3</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>No</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Dijon</td>
<td>1</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
<td>•</td>
</tr>
<tr>
<td>5</td>
<td>Dijon</td>
<td>2</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
<td>•</td>
</tr>
<tr>
<td>6</td>
<td>Dijon</td>
<td>3</td>
<td>No</td>
<td>Wild</td>
<td>High</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
<td>•</td>
</tr>
<tr>
<td>7</td>
<td>Bernard 2</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Bernard 4</td>
<td>No</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>2 Years</td>
<td>Klin</td>
<td>No</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Bernard 4</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>New</td>
<td>Klin</td>
<td>No</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Bernard 2</td>
<td>Yes</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>Yes</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Bernard 2</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Bernard 4</td>
<td>Yes</td>
<td>Cultured</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Dijon</td>
<td>3</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>No</td>
<td>•</td>
</tr>
<tr>
<td>14</td>
<td>Dijon</td>
<td>3</td>
<td>No</td>
<td>Wild</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Klin</td>
<td>Yes</td>
<td>•</td>
</tr>
<tr>
<td>15</td>
<td>Dijon</td>
<td>1</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
<td>•</td>
</tr>
<tr>
<td>16</td>
<td>Dijon</td>
<td>1</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>No</td>
<td>•</td>
</tr>
<tr>
<td>17</td>
<td>Bernard 4</td>
<td>Yes</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>2 Years</td>
<td>Klin</td>
<td>No</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>Dijon</td>
<td>3</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>Yes</td>
<td>•</td>
</tr>
<tr>
<td>19</td>
<td>Bernard 2</td>
<td>Yes</td>
<td>Wild</td>
<td>High</td>
<td>Hard</td>
<td>New</td>
<td>Air</td>
<td>No</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Bernard 3</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Soft</td>
<td>2 Years</td>
<td>Klin</td>
<td>Yes</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Bernard 1</td>
<td>No</td>
<td>Wild</td>
<td>High</td>
<td>Soft</td>
<td>2 Years</td>
<td>Air</td>
<td>Yes</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Dijon</td>
<td>1</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Hard</td>
<td>2 Years</td>
<td>Klin</td>
<td>Yes</td>
<td>•</td>
</tr>
<tr>
<td>23</td>
<td>Dijon</td>
<td>2</td>
<td>Yes</td>
<td>Cultured</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Klin</td>
<td>No</td>
<td>•</td>
</tr>
<tr>
<td>24</td>
<td>Dijon</td>
<td>4</td>
<td>No</td>
<td>Cultured</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Air</td>
<td>Yes</td>
<td>•</td>
</tr>
<tr>
<td>25</td>
<td>Dijon</td>
<td>4</td>
<td>No</td>
<td>Wild</td>
<td>Low</td>
<td>Soft</td>
<td>New</td>
<td>Air</td>
<td>No</td>
<td>•</td>
</tr>
</tbody>
</table>

Note the following:

- In the Table panel, the Model, Evaluate Design, and DOE Dialog scripts are added during the design creation process. The Model script opens a Fit Model window containing the effects that you specified as Necessary in the Custom Design dialog window. The DOE Dialog script re-creates the window used to generate the design table.

- In the Columns panel, the asterisks to the right of the factors and response indicate column properties that have been saved to the columns in the data table. These column properties are used in the analysis of the data. For more information about column properties, see “Factors” and “Factor Column Properties”.

Analyze the Custom Design

After running an experiment and compiling the data you are ready to analyze the results. Use the Rating column of your Custom Design table to record the Rating data.

1. Select Help > Sample Data Library and open Design Experiment/Wine Data.jmp.

   The Wine Data.jmp table is exactly the same as the Custom Design table shown in Figure 4.9, except that it contains your recorded experimental results.

2. In the Table panel, click the green triangle next to the Model script.
Notice that Rater, the blocking factor, is added as a fixed effect, rather than as a random block effect. This is appropriate because the five raters were specifically chosen and are not a random sample from a larger population.

3. Click **Run**.

**Interpret the Full Model Results**

The model output from our custom design example is shown below.
Figure 4.11 Partial Model Fit Results

Note the following:

- The Actual by Predicted Plot shows no obvious evidence of lack of fit.
- The model is significant, as indicated by the Actual by Predicted Plot and by the $p$-value beneath it.
- The Effect Tests report indicates that seven of the model terms are significant at the 0.05 level. Field, Temperature, and Barrel Age are not significant.
• The Effect Summary report lists these effects in decreasing order of significance. Larger LogWorth values correspond to smaller PValues and greater significance.

Reduce the Model

Reduce the model for the custom design results by removing the effects that you identified as inactive:

1. In the Effect Summary report, press Control and select Temperature, Field, and Barrel Age.
2. Click Remove.
   
   The report updates to show the model fit with these three effects removed.

Interpret the Model Results with the Profiler

The Actual by Predicted Plot for the reduced model shows no lack of fit issues. The Effect Summary and the Effect Test report show that the remaining seven terms are significant at the 0.05 level. Use the prediction profiler to further explore your reduced model.

Figure 4.12 shows the Prediction Profiler. Recall that you specified a response goal of Maximize, with lower and upper limits of 0 and 20. Setting these limits caused a Response Limits column property to be saved to the Rating column in the Custom Design table. The Prediction Profiler uses the Response Limits information to construct a Desirability function, which appears in the right-most plot in the top row in Figure 4.12. The bottom row displays Desirability traces.

The first six plots in the top row show traces of the predicted model. For each factor, the line in the plot shows how Rating varies when all other factors are set at the values defined by the red dashed vertical lines. By default, the profiler appears with categorical factors set at their low settings. By varying the settings for the factors, you can see how the predicted Rating for wines changes. Notice that a confidence interval is given for the mean predicted Rating.

Observe that Rater is not included among the factors shown in the profiler. This is because Rater is a block variable. You included Rater to explain variation, but Rater is not of direct interest in terms of optimizing process factor settings. The predicted Rating for a wine with the given settings is the average of the predicted ratings for that wine by all raters.
Design of Experiments Guide Example of a Custom Design

Figure 4.12  Profiler for Reduced Model

Optimize Factor Settings

Use the prediction profiler to identify optimal settings based on your custom design results. You would like to identify settings that maximize Rating across raters.

1. Click the Prediction Profiler red triangle and select Optimization and Desirability > Maximize Desirability.

   The red dashed vertical lines in the Prediction Profiler update to show optimal settings for each factor. The optimal settings result in a predicted rating of 19.925. In general, there can be different sets of factor settings that result in the same optimal value.

2. To see predicted ratings for all runs, save the Prediction Formula. Click the Response Rating red triangle and select Save Columns > Prediction Formula.

   A column called Pred Formula Rating is added to the data table. Note that one of the runs, row 33, was given the maximum rating of 20 by Rater 5. The predicted rating for that run by Rater 5 is 19.550. But the row 33 trial was run at the optimal settings. The predicted...
value of 19.925 given for these settings in the Prediction Profiler is obtained by averaging the predicted ratings for that run over all five raters.

**Lock a Factor Level**

You can lock factors in the profiler to explore optimization under specific conditions. When you maximized your design response, you learned that the optimal rating is achieved with the Dijon variety of grapes (Figure 4.13). Your manager points out that it would be cost-prohibitive to replant the fields that are growing Bernard grapes with young Dijon vines. Therefore, you need to find optimal process settings and the predicted rating for Bernard grapes.

1. In the Variety plot of the Prediction Profiler, drag the red dashed vertical line to Bernard.
2. Press Control and click in one of the Variety plots.
   
The Factor Settings window appears.
3. Select **Lock Factor Setting** and click **OK**.
4. Click the Prediction Profiler red triangle and select **Optimization and Desirability > Maximize Desirability**.

**Figure 4.14** Prediction Profiler with Optimal Settings for Bernard Variety

The optimal settings are unchanged because the model contains no interaction terms. The predicted rating at these settings is 17.975.

**Add the Rater to the Profiler**

If you want to see the Profiler traces for the levels of Rater, perform the following steps:

1. Click the Prediction Profiler red triangle and select **Reset Factor Grid**.
A Factor Settings window appears with columns for all of the factors, including **Rater**. The box under **Rater** and next to **Show** is not checked. This indicates that **Rater** is not shown in the Prediction Profiler.

2. Check the box under **Rater** in the row corresponding to **Show**.

3. Deselect the box under **Rater** in the row corresponding to **Lock Factor Setting**.

4. Click **OK**.

   The Profiler updates to show a plot for **Rater**.

5. Click in either plot above **Rater**.

**Figure 4.15** Profiler for Reduced Model Showing Rater

A dashed vertical red line appears. Drag this line to see the traces for each of the raters. Keep in mind that **Variety** is still locked at Bernard. To unlock **Variety**, press Control and click in one of the **Variety** plots. In the Factor Settings window that appears, deselect **Lock Factor Setting**.
Summary of Custom Design Example

In your wine tasting experiment, using only 40 runs, you have identified six (out of nine) factors that have an effect on ratings for Pinot Noir grapes. You found that you could achieve a predicted rating of 19.925 (out of a possible 20) at the optimal settings for those factors. You also identified optimal settings for both varieties of grapes.

In this section, you constructed a design using the outlines in the Custom Design window. The next section explains each outline and the design steps in more detail.

Build a Custom Design

Build a Custom Design by selecting DOE > Custom Design. First define your responses and factors. Next, continue to the design options, generation, and evaluation. The design process follows the flow in Figure 4.16.

Figure 4.16  Custom Design Flow

Responses

Use the Responses outline to specify one or more responses.

Tip: When you have completed the Responses outline, consider selecting Save Responses from the red triangle menu. This option saves the response names, goals, limits, and importance values in a data table that you can later reload in DOE platforms.

Figure 4.17  Responses Outline

Add Response  Enters a single response with a goal type of Maximize, Match Target, Minimize, None, or Functional. If you select Match Target, enter limits for your target value. If you select Maximize or Minimize, entering limits is not required but can be useful if you intend to use desirability functions.
**Functional** (Available only in JMP Pro.) Adds multiple Y columns with FDE column properties to the design data table. These columns can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.

**Remove** Removes the selected responses.

**Number of Responses** Enters additional responses so that the number that you enter is the total number of responses. If you have entered a response other than the default Y, the Goal for each of the additional responses is the Goal associated with the last response entered. Otherwise, the Goal defaults to Match Target. Click the Goal type in the table to change it.

The Responses outline contains the following columns:

**Response Name** The name of the response. When added, a response is given a default name of Y, Y2, and so on. To change this name, double-click it and enter the desired name.

**Goal, Lower Limit, Upper Limit** The Goal tells JMP that you want to maximize or minimize your response, match a target, or that you have no goal for your response. JMP assigns a Response Limits column property, based on these specifications, to each response column in the design table. It uses this information to define a desirability function for each response. The Profiler and Contour Profiler use these desirability functions to find optimal factor settings. For further details, see the Profiler chapter in Profilers and “Response Limits”.

- A Goal of Maximize indicates that the best value is the largest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.
- A Goal of Minimize indicates that the best value is the smallest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.
- A Goal of Match Target indicates that the best value is a specific target value. The default target value is assumed to be midway between the Lower Limit and Upper Limit.
- A Goal of None indicates that there is no goal in terms of optimization. No desirability function is constructed.

**Note:** If your target response is not midway between the Lower Limit and the Upper Limit, you can change the target after you generate your design table. In the data table, open the Column Info window for the response column (**Cols > Column Info**) and enter the desired target value.

**Importance** When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for
the responses. If there is only one response, then specifying the Importance is unnecessary because it is set to 1 by default.

**Detection Limits** The lower and upper detection limits are bounds beyond which the response cannot be measured. The detection limits are saved as a column property. You can use these limits to specify a censored response in the Generalized Regression platform. See the Generalized Regression chapter in *Fitting Linear Models*.

**Editing the Responses Outline**

In the Responses outline, note the following:

- Double-click a response to edit the response name.
- Click the goal to change it.
- Click on a limit or importance weight to change it.
- For multiple responses, you might want to enter values for the importance weights.

**Response Limits Column Property**

The Goal, Lower Limit, Upper Limit, and Importance that you specify when you enter a response are used in finding optimal factor settings. For each response, the information is saved in the generated design data table as a Response Limits column property. JMP uses this information to define the desirability function. The desirability function is used in the Prediction Profiler to find optimal factor settings. For further details about the Response Limits column property and examples of its use, see “Response Limits”.

If you do not specify a Lower Limit and Upper Limit, JMP uses the range of the observed data for the response to define the limits for the desirability function. Specifying the Lower Limit and Upper Limit gives you control over the specification of the desirability function. For more details about the construction of the desirability function, see the Profiler chapter in *Profilers*.

**Factors**

Add factors to study in a custom design in the Factors outline.

**Tip:** When you have completed the Factors outline, consider selecting **Save Factors** from the red triangle menu. This saves the factor names, roles, changes, and values in a data table that you can later reload.
Figure 4.18  Factors Outline

Add Factor  Select the factor type. See “Factor Types”.

Remove  Removes the selected factors.

Note: If you attempt to remove all factors after clicking the Continue or Back button, one continuous factor remains. You can delete it after you add new factors.

Add N Factors  Adds multiple factors. Enter the number of factors to add, click Add Factor, and then select the factor type. Repeat Add N Factors to add multiple factors of different types.

Factors Outline

The Factors outline contains the following columns:

Name  The name of the factor. When added, a factor is given a default name of X1, X2, and so on. To change this name, double-click it and enter the desired name.

Role  Specifies the Design Role of the factor. The Design Role column property for the factor is saved to the data table. This property ensures that the factor type is modeled appropriately.

Changes  Indicates whether the factor levels are Easy, Hard, or Very Hard to change. Click the default value of Easy to change it. When you specify factors as Hard or Very Hard to change, your design reflects these restrictions on randomization. A factor cannot be designated as Very Hard unless the Factors list contains a factor designated as Hard. The Factor Changes column property is saved to the data table. See “Changes and Random Blocks”.

Values  The experimental settings for the factors. To insert Values, click the default values and enter the desired values.
Editing the Factors Outline

In the Factors outline, note the following:

- To edit a factor name, double-click the factor name.
- Categorical factors have a down arrow to the left of the factor name. Click the arrow to add a level.
- To remove a factor level, click the value, click Delete, and click outside the text box.
- To modify the entry under Changes, click the value in the Changes column and select the appropriate entry.
- To edit a value, click the value in the Values column.

Factor Types

To choose a factor type, click Add Factor in Custom Design.

**Note:** A Design Role column property containing each factor’s role is added to that factor’s column in the design table that is generated. The Design Role column property ensures that the factor is modeled correctly.

**Continuous**  Numeric data types only. A continuous factor is a factor that you can conceptually set to any value between the lower and upper limits you supply, given the limitations of your process and measurement system.

**Discrete Numeric**  Numeric data types only. A discrete numeric factor can assume only a discrete number of values. These values have an implied order.

The default values for a discrete numeric factor with $k$ levels, where $k > 2$, are the integers $1, 2, ..., k$. The default values for a discrete numeric factor with $k = 2$ levels are -1 and 1. Replace the default values with the settings that you plan to use in your experiment.

**Note:** Not all levels of a discrete numeric factor appear in the design. The levels that appear are determined by your specifications in the Model outline. If you need all levels to appear in your design, consider using the Screening Design platform.

In the assumed model, the effects for a discrete numeric factor with $k$ levels include polynomial terms in that effect through order $k-1$. For $k$ greater than 6, powers up to the 5th level are included. The Estimability for polynomial effects (powers of two or higher) is set to If Possible. This allows the algorithm to use the multiple levels as permitted by the run size. If the polynomial terms are not included, then a main effects only design is...
created. For more information about how discrete numeric factors are treated in the assumed model, see “Model”.

Fit Model treats a discrete numeric factor as a continuous predictor. The Model script that is saved to the design table does not contain any polynomial terms of order greater than two.

**Categorical** Either numeric or character data types. The data type in the resulting data table is categorical. The value order of the levels is the order of the values, as entered from left to right. This ordering is saved in the Value Order column property after the design data table is created.

**Blocking** Either numeric or character data types. A blocking factor is a special type of categorical factor that can enter the model only as a main effect. When you define a blocking factor, you specify the number of runs per block. The RunsPerBlock column property is saved to the design table. The Default run size always assumes that there are at least two blocks. If you specify a run size that is not an integer multiple of the number of runs per block, JMP tries to balance the design to the extent possible. In balancing the design, JMP ensures that there are at least two runs per block.

**Covariate** Either numeric or character data types. Use the mixture column property to include mixture covariates in your design. The values of a covariate factor are measurements on experimental units that are known in advance of an experiment. If the covariates are mixture variables, they must represent all of the mixture variables in the design.

Covariate values are selected to ensure the optimality of the resulting design relative to the optimality criterion. See “Changes and Random Blocks” and “Covariates with Hard-to-Change Levels”.

JMP obtains the covariate factors and their values from an open data table that contains the measured covariates for the available experimental units. Make this data table your current data table. Use **Add Factors** or click **Select Covariate Factors** in the Covariate/Candidate Runs outline to add covariates. When you add a covariate, a list of columns in the current data table opens, and you select the columns containing covariates from this list. The addition of covariate factors loads a table with the candidate rows into the Covariate/Candidate Runs outline. Once loaded, you can select rows to force into the design. To force selected covariate rows into your design, use the Design Generation option **Include all selected covariate rows in the design**.

If the design has fewer runs than the number of covariate rows, then the design table includes a Covariate Row Index column. This column indicates the row from the covariate table that corresponds to each experimental run.

In some situations, you might want to select a small set of design points from a larger set of candidate settings. For example, you might have multiple measurement columns (factors) for a large batch of units. You want to treat the measurements for each unit as a
candidate run. From these candidate runs, you want to select a small but optimal collection for which you measure a response. In this case, make the data table of all candidate runs the active table, select Add Factor > Covariate, and enter all of your measurement columns as covariates. Specify your desired run size. The Custom Design platform identifies an optimal collection of design settings.

**Note:** When you have covariates, the Design Generation outline contains two options. The first option allows you to specify that selected rows in your covariate table are included in the design. The second option allows covariate rows to be repeated in the design.

**Mixture** Continuous factors that represent ingredients in a mixture. The values for a mixture factor must sum to a constant. By default, the values for all mixture factors sum to one. To set the sum of the mixture components to some other positive value, select **Advanced Options > Mixture Sum** from the red triangle menu. The Mixture column property is saved to the data table.

**Constant** Either numeric or character data types. A constant factor is a factor whose values are fixed during an experiment. Constant factors are not included in the Model outline or in the Model script that is saved to the data table.

**Uncontrolled** Either numeric or character data types. An uncontrolled factor is one whose values cannot be controlled during production, but it is a factor that you want to include in the model. It is assumed that you can record the factor’s value for each experimental run.

An empty column with a Continuous Modeling Type is created in the design table. You can change the column’s Data Type and Modeling Type in the Column Info window if required. Enter your data in this column. Uncontrolled factors are included in the Model outline and the Model script that is saved to the data table.

### Changes and Random Blocks

Specifying the relative difficulty of changing a factor from run to run is useful in industrial experimentation. It is often convenient to make several runs while keeping factors that are hard-to-change fixed at some setting. A Changes value of Hard results in a split-plot design. A Changes value of Very Hard results in a split-split-plot design or a two-way split-plot design.

You can set Changes for Continuous, Discrete Numeric, Categorical, and Mixture factors to Hard and Very Hard. To set a factor to Very Hard, the list must contain another factor that is set to Hard.

You can set Changes for a Covariate factor to Hard. In this case, all other covariates are also set to Hard and the remaining factors are set to Easy. The algorithm requires a combination of row exchange and coordinate exchange. For this reason, even moderately sized designs might take some time to generate.
For designs with Hard or Very Hard to change factors, Custom Design strives to find a design that is optimal, given your specified optimality criterion. See “Optimality Criteria”. For more information about the methodology used to generate split-plot designs, see Jones and Goos (2007). For more information about designs with hard-to-change covariates, see Jones and Goos (2015).

Figure 4.19 shows a split-split-plot scenario, using the factors from the Cheese Factors.jmp sample data table (located in the Design Experiment folder).

If you assign Changes as Hard for one or more factors, but no factors are assigned Changes that are Very Hard, a categorical factor called Whole Plots is added to the design. This situation results in a split-plot design:

- Each level of Whole Plots corresponds to a block of constant settings of the hard-to-change factors.
- The Model script in the design table applies the Random Effect attribute to the factor Whole Plots.
- The factor Whole Plots is assigned the Design Role column property with a value of Random Block.
When you designate Changes as both Hard and Very Hard, categorical factors called Subplots and Whole Plots are added to the design. This situation results in a split-split-plot design:

- Each level of Subplots corresponds to a block of constant settings of the hard-to-change factors.
- Each level of Whole Plots corresponds to a block of constant settings of the very-hard-to-change factors.
- The Model script in the design table applies the Random Effect attribute to the Whole Plots and Subplots effects.
- The levels of the hard-to-change factor are assumed to be nested within the levels of the very-hard-to-change factor by default.
- In the design table, both of the factors Whole Plots and Subplots are assigned the Design Role column property with a value of Random Block.

To construct a two-way split-plot design, select the **Hard to change factors can vary independently of Very Hard to change factors** option under Design Generation. The option crosses the levels of the hard-to-change factor with the levels of the very-hard-to-change factor. See “Two-Way Split-Plot Designs”.

Use the Number of Whole Plots and Number of Subplots text boxes to specify values for the numbers of whole plots or subplots. These boxes are initialized to suggested numbers of whole plots and subplots. For information about how these values are obtained, see “Numbers of Whole Plots and Subplots”.

For more information and scenarios that illustrate random block split-plot, split-split-plot, and two-way split-plot designs, see “Designs with Randomization Restrictions”. For more information about designs with hard-to-change covariates, see “Covariates with Hard-to-Change Levels”.

**Factor Column Properties**

For each factor, various column properties are saved to the data table. You can find more information about these column properties and related examples in “Column Properties”.

**Design Role** Each factor is given the Design Role column property. The Role that you specify in defining the factor determines the value of its Design Role column property. When you add a random block under Design Generation, that factor is assigned the Random Block value. The Design Role property reflects how the factor is intended to be used in modeling the experimental data. Design Role values are used in the Augment Design platform. See “Design Role”.

**Factor Changes** Each factor is assigned the Factor Changes column property. The value that you specify under Changes determines the value of its Factor Changes column property. The Factor Changes property reflects how the factor is used in modeling the experimental
data. Factor Changes values are used in the Augment Design and Evaluate Design platforms. See “Factor Changes”.

**Coding**  If the Role is Continuous, Discrete Numeric, a continuous Covariate, or Uncontrolled, the Coding column property for the factor is saved. This property transforms the factor values so that the low and high values correspond to –1 and +1, respectively. See “Coding”.

**Value Order**  If the Role is Categorical or Blocking, the Value Order column property for the factor is saved. This property determines the order in which levels of the factor appear. See “Value Order”.

**Mixture**  If the Role is Mixture, the Mixture column property for the factor is saved. This property indicates the limits for the factor and the mixture sum. It also enables you to choose the coding for the mixture factors. See “Mixture”.

**RunsPerBlock**  For a blocking factor, indicates the maximum allowable number of runs in each block. When a Blocking factor is specified in the Factors outline, the RunsPerBlock column property is saved for that factor. See “RunsPerBlock”.

### Define Factor Constraints

Use Define Factor Constraints to restrict the design space. Unless you have loaded a constraint or included one as part of a script, the None option is selected. To specify constraints, select one of the other options:

- **Specify Linear Constraints**  Specifies inequality constraints on linear combinations of factors. Available only for factors with a Role of Continuous or Mixture. See “Specify Linear Constraints”.

  **Note:** When you save a script for a design that involves a linear constraint, the script expresses the linear constraint as a less than or equal to inequality (\( \leq \)).

- **Use Disallowed Combinations Filter**  Defines sets of constraints based on restricting values of individual factors. You can define both AND and OR constraints. See “Use Disallowed Combinations Filter”.

- **Use Disallowed Combinations Script**  Defines disallowed combinations and other constraints as Boolean JSL expressions in a script editor box. See “Use Disallowed Combinations Script”.

  **Note:** When you analyze a design that has factor constraints, the model profiler honors the constraints.
Specify Linear Constraints

In cases where it is impossible to vary continuous factors independently over the design space, you can specify linear inequality constraints. Linear inequalities describe factor level settings that are allowed. For an example, see “Mixture of Mixtures Design”.

Click **Add** to enter one or more linear inequality constraints.

**Add** Adds a template for a linear expression involving all the continuous factors in your design. Enter coefficient values for the factors and select the direction of the inequality to reflect your linear constraint. Specify the constraining value in the box to the right of the inequality. To add more constraints, click **Add** again.

**Note:** The Add option is disabled if you have already constrained the design region by specifying a Sphere Radius.

**Remove Last Constraint** Removes the last constraint.

**Check Constraints** Checks the constraints for consistency. This option removes redundant constraints and conducts feasibility checks. A JMP alert appears if there is a problem. If constraints are equivalent to bounds on the factors, a JMP alert indicates that the bounds in the Factors outline have been updated.

Use Disallowed Combinations Filter

This option uses an adaptation of the Data Filter to facilitate specifying disallowed combinations. For detailed information, see *Using JMP*.

Select factors from the Add Filter Factors list and click **Add**. Then specify the disallowed combinations by using the slider (for continuous factors) or by selecting levels (for categorical factors). For an example, see “Response Surface Design With Constraints and Categorical Factor”.

The red triangle options for the Add Filter Factors menu are those found in the Select Columns panel of many platform launch windows. See *Using JMP*.

When you click Add, the Disallowed Combinations control panel shows the selected factors and provides options for further control. Factors are represented as follows, based on their modeling types:

**Continuous Factors** For a continuous factor, a double-ended slider that spans the range of factor settings appears. You can specify disallowed settings by dragging the slider ends or by setting the endpoints by clicking on the text value under the slider. In the slider, a solid blue highlight represents the disallowed values.

**Categorical Factor** For a categorical factor, the possible levels are displayed either as labeled blocks or, when the number of levels is large, as list entries. Select a level to disallow it. To
select multiple levels, hold the Control key. The block or list entries are highlighted to indicate the levels that have been disallowed. When you add a categorical factor to the Disallowed Combinations panel, the number of levels of the categorical factor is given in parentheses following the factor name.

**Disallowed Combinations Options**

The control panel has the following controls:

- **Clear**  Clears all disallowed factor level settings that you have specified. This does not clear the selected factors.

- **Start Over**  Removes all selected factors and returns you to the initial list of factors.

- **AND**  Opens the Add Filter Factors list. Selected factors become an AND group. Any combination of factor levels specified within an AND group is disallowed.

  To add a factor to an AND group later on, click the group’s outline to see a highlighted rectangle. Select AND and add the factor.

  To remove a single factor, select **Delete** from its red triangle menu.

- **OR**  Opens the Add Filter Factors list. Selected factors become a separate AND group. For AND groups separated by OR, a combination is disallowed if it is specified in at least one AND group.

**Red Triangle Options for Factors**

A factor can appear in several OR groups. An occurrence of the factor in a specific OR group is referred to as an *instance* of the factor.

- **Delete**  Removes the selected instance of the factor from the Disallowed Combinations panel.

- **Clear Selection**  Clears any selection for that instance of the factor.

- **Invert Selection**  Deselects the selected values and selects the values not previously selected for that instance of the factor.

- **Display Options**  Available only for categorical factors. Changes the appearance of the display. Options include showing each level as a block, list, or single category, or adding a check box next to each value.

- **Find**  Available only for categorical factors. Provides a text box beneath the factor name where you can enter a search string for levels of the factor. Press the Enter key or click outside the text box to perform the search. Once **Find** is selected, Find options appear in the red triangle menu, such as Does not contain, Match Case, Starts with or Ends with, or Clear Find.
Use Disallowed Combinations Script

Use this option to disallow particular combinations of factor levels using a JSL script. This option can be used with continuous factors or mixed continuous and categorical factors.

This option opens a script window where you insert a script that identifies the combinations that you want to disallow. The script must evaluate as a Boolean expression. When the expression evaluates as true, the specified combination is disallowed.

When forming the expression for a categorical factor, use the ordinal value of the level or the name of the level. If a factor’s levels are high, medium, and low, specified in that order in the Factors outline, their associated ordinal values are 1, 2, and 3. For example, suppose that you have two continuous factors, X1 and X2, and a categorical factor X3 with three levels: L1, L2, and L3, in order. You want to disallow levels where the following is true:

\[ e^{X_1} + 2X_2 < 0 \text{ and } X_3 = L2 \]

Enter the expression \((\text{Exp}(X1) + 2^*X2 < 0) \& (X3 == 2)\) into the script window.

Figure 4.20 Expression in Script Editor

(In the figure, unnecessary parentheses were removed by parsing.) Notice that functions can be entered as part of the Boolean expression. The expression \((\text{Exp}(X1) + 2^*X2 < 0) \& (X3 == “L2”)\) is also valid.

Model

Specify your assumed model (which contains all the effects that you want to estimate) in the Model outline. For each effect that you specify, you can designate that effect’s Estimability. The Estimability value indicates whether it is Necessary to estimate that effect, or if you are content to estimate that effect If Possible.

The initial Model outline includes the main effects for all factors. If you have entered a discrete numeric factor with three or more levels, polynomial terms are also included in the initial model. The Estimability of second-and higher-order terms is set to If Possible. If you want to ensure that these terms are estimable, change their Estimability to Necessary.
Note: You can ensure that the estimability of discrete numeric polynomial terms is always set to Necessary. Select File > Preferences > Platforms > DOE. Check Discrete Numeric Powers Set to Necessary.

Figure 4.21 Model Outline

When you construct your design table, JMP saves a Model script to the data table. Except for discrete numeric factors, the Model script contains the effects shown in the Model outline. For a discrete numeric factor, the Model script contains only its main effect and quadratic term.

The Model outline contains the following buttons and fields:

**Main Effects**  Adds main effects for all factors in the model, and polynomial terms for discrete numeric factors.

**Interactions**  Adds interaction effects. If no factors are selected in the Factors outline, select 2nd, 3rd, 4th, or 5th to add all appropriate interactions up to that order. Add interactions up to a given order for specific factors by selecting the factor names in the Factors outline, selecting Interactions, and then specifying the appropriate order. Interactions between non-mixture and mixture factors, and interactions with blocking and constant factors, are not added.

**RSM**  Adds interaction and quadratic terms up to the second order (response surface model terms) for all continuous factors. Categorical factors are not included in RSM terms. Main effects for non-mixture factors that interact with all the mixture factors are removed.

**Cross**  Adds specific interaction terms. Select factor names in the Factors outline and effect names in the Model outline. Click Cross to add the crossed terms to the Model outline.

**Powers**  Adds polynomial terms. If no factor names are selected in the Factors outline, adds polynomial terms for all continuous factors. If factor names are selected in the Factors outline, adds polynomial terms for only those factors. Select 2nd, 3rd, 4th, or 5th to add polynomial terms of that order.
**Scheffé Cubic**  (Available for mixture factors.) Adds Scheffé cubic terms for all mixture factors. These terms are used to specify a mixture model with third-degree polynomial terms.

**Remove Term**  Removes selected effects.

**Name**  The name of the effect.

**Estimability**  A designation of your need to estimate the effect.

- If Estimability is set to Necessary, the algorithm ensures that the effect is estimable.
- If Estimability is set to If Possible, the algorithm attempts to make that effect estimable, as permitted by the number of runs that you specify.

Except for polynomial terms for discrete numeric factors, all effects are specified as Necessary by default. Click an effect’s Estimability value to change it.

**Bayesian D-Optimality and Estimation of If Possible Effects**

The Bayesian D-Optimal design approach obtains precise estimation of all Necessary terms while providing omnibus detectability (and some estimability) for If Possible terms. For more detail, see “Response Surface Experiments” and “Bayesian D-Optimality”. If any main effect model term is set to If Possible, the Bayesian Information matrix is used for design diagnostic calculations.

**Alias Terms**

In the Alias Terms outline, add potentially active effects that are not in your assumed model but might bias the estimates of model terms. It is possible that effects not included in your assumed model are active. Once you generate your design, the Alias Matrix outline appears under Design Evaluation. The Alias Matrix entries represent the degree of bias imparted to model parameters by the effects that you specified in the Alias Terms outline. See the “The Alias Matrix”.

By default, the Alias Terms outline includes all two-way interaction effects that are not in your Model outline (with the exception of terms involving blocking factors). Add terms using the buttons. For a description of how to use these buttons to add effects to the Alias Terms table, see “Model”.

**Note:** For interaction terms, only interactions of the selected order are added. This differs from the Model outline where interactions of the selected order and all lower orders are added to the model.
For example, suppose that you specify a design with three continuous factors. Your assumed model, specified in the Model outline, contains only those three main effects. You can afford only six runs. You want to see how estimates of the main effects might be biased by active two-way interactions and the three-way interaction.

The Alias Terms table includes all two-way interactions by default. You can add the three-way interaction by selecting **Interactions > 3rd**.

**Figure 4.22**  Alias Terms Outline

![Alias Terms Outline](image)


**Figure 4.23**  Alias Matrix

<table>
<thead>
<tr>
<th>Effect</th>
<th>X1*X2</th>
<th>X1*X3</th>
<th>X2*X3</th>
<th>X1<em>X2</em>X3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intercept</td>
<td>0</td>
<td>0</td>
<td>0.5</td>
<td>-0.5</td>
</tr>
<tr>
<td>X1</td>
<td>0</td>
<td>0</td>
<td>-0.5</td>
<td>0.5</td>
</tr>
<tr>
<td>X2</td>
<td>0.5</td>
<td>-0.5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>X3</td>
<td>-0.5</td>
<td>0.5</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

The Alias Matrix indicates that each main effect is partially aliased with two of the interactions. See “**Alias Matrix**” and “**The Alias Matrix**”.

**Design Generation**

The Design Generation outline gives you choices relating to blocking, center points, replication, and the number of runs in your design. Typically, the input area has two parts:

- Design structure options
- Number of runs options
Figure 4.24  Design Generation Outline

Design Structure Options

**Group runs into random blocks of size**  (Not available if a blocking factor is specified.) To construct a random block design, enter the number of runs that you want in each block. When you specify the sample size, a factor called Random Block is created. Its levels define blocks of a size that is consistent with the block size that you entered, given the specified number of runs. If the number of runs is an integer multiple of the block size, the block sizes equal your specified value.

**Number of Whole Plots**  Appears when you specify a hard or very-hard-to-change factor. The factor Whole Plots corresponds to the very-hard-to-change factors (split-split-plot design), if there are any, otherwise to the hard-to-change factors (split-plot design). JMP suggests a value for the number of whole plots that maximizes the information about the coefficients in the model. Or, you can enter a value for the number of whole plots. See “Numbers of Whole Plots and Subplots”.

**Number of Subplots**  Appears when you specify a very-hard-to-change factor. The factor Subplots corresponds to the hard-to-change factors in the split-split-plot design. JMP suggests values for the number of whole plots and subplots that maximize the information about the coefficients in the model. Or, you can enter a value for the number of subplots. See “Numbers of Whole Plots and Subplots”.

**Hard to change factors can vary independently of Very Hard to change factors**  Select this option to create a strip-plot (also known as two-way split-plot or split block) design. This option creates a design where the hard-to-change factors are randomized within the levels of the very-hard-to-change factors. They are *not* nested within the very-hard-to-change factors.

**Number of Center Points**  Appears only if the design contains factors with a Continuous or Mixture factor type. Specify how many additional runs you want to add as center points to
the design. A center point is a run whose setting for each continuous factor is midway between the high and low settings. See “Center Points, Replicate Runs, and Testing”.

If a design contains both continuous and other types of factors, center points might not be balanced relative to the levels of the other factors. Custom Design chooses the center points to maximize the D-, I-, or alias efficiency of the design.

**Number of Replicate Runs**  Specify the number of replicate trials that you want to add to the design. This does not replicate the entire design, but chooses the optimal design points to replicate. See “Center Points, Replicate Runs, and Testing”.

**Number of Runs Options**

**Minimum**  A lower bound on the number of runs necessary to avoid failures in design generation. When you select Minimum, the resulting design is saturated. There are no degrees of freedom for error.

**Note:** If you select the Minimum number of runs, there will be no error term for testing. You will not be able to test parameter estimates. This choice is appropriate only when the cost of additional runs is prohibitive.

**Default**  Suggests the number of runs. This value is based on heuristics for creating a balanced design with at least four runs more than the Minimum number of runs.

**User Specified**  Specify the number of runs that you want. Enter that value into the Number of Runs text box. This option enables you to balance the cost of additional runs against the potential gain in information.

**Number of Runs**  This is the only option that appears when a covariate factor with Changes set to Easy is specified. The number of runs shown is the number of rows in the data table associated with your covariate or covariates. You can specify a smaller number of runs. In that case, the covariate runs that are selected optimize the design criterion.

**Make Design**

Once you have completed the Design Generation outline, click Make Design. Custom Design generates the design, presents it in the Design outline, and provides evaluation information in the Design Evaluation outline. Notice the controls in the Model and Alias Outlines are disabled. Use the Back button to change model or alias terms. The Output Options panel also appears, enabling you to create the design table.

**Note:** Sometimes several designs can optimize the optimality criterion. When this is the case, the design algorithm might generate different designs when you click the Back and Make Design buttons repeatedly.
Design

The Design outline shows the runs for the custom design. The design is optimal, given the conditions that you have specified. The runs might not appear to be randomized. You can select Run Order options in the Output Options panel before generating your design table.

Design Evaluation

The Design Evaluation red triangle menu and outlines provide a number of ways to evaluate the properties of the generated custom design.

**Use Bayesian Information**  Select to use the Bayesian Information matrix in the design diagnostic calculations for designs with *If Possible* model effects that are not estimable. For more information about the Bayesian Information adjustments see “Bayesian D-Optimality”.

**Note:** If all model effects are estimable, the Design Diagnostics are presented for all effects without making the Bayesian Information adjustment. If some terms are inestimable, only the *Necessary* model terms are presented unless the **Use Bayesian Information** option is selected.

**Power Analysis**  Enables you to explore your ability to detect effects of given sizes.

**Prediction Variance Profile**  Shows the prediction variance over the range of factor settings.

**Fraction of Design Space Plot**  (or above) a given value.

**Prediction Variance Surface**  Shows a surface plot of the prediction variance for any two continuous factors.

**Estimation Efficiency**  For each parameter, gives the fractional increase in the length of a confidence interval compared to that of an idealized (orthogonal) design, which might not exist. Also gives the relative standard error of the parameters.

**Alias Matrix**  Gives coefficients that indicate the degree by which the model parameters are biased by effects that are potentially active, but not in the model. You specify the terms representing potentially active effects in the Alias Terms table. See “The Alias Matrix”.

**Color Map on Correlations**  Shows the absolute correlation between effects on a plot using an intensity scale.

**Note:** The default intensity scale is a gray scale. To change the color scale, click the Color Map on Correlations red triangle and select **Blue to Gray to Red**. For a custom color scale, right-click in the plot and select **Color Theme**.
**Design Diagnostics**  Indicates the optimality criterion used to construct the design. Also gives efficiency measures for your design. See Optimality Criterion in “Custom Design Options” and “Optimality Criteria”.

**Note:** The Design Diagnostics outline does not provide the following statistics when the model includes factors with Changes set to Hard or Very Hard or with Estimability set to If Possible: D Efficiency, G Efficiency, A Efficiency.

For more information about the Design Evaluation outline, see “Design Evaluation”.

**Output Options**

Use the Output Options panel to save your custom design X Matrix, simulate responses, or customize your design data table. You can perform the following tasks:

- specify how you want the custom design data table to appear
- construct the design table
- return to a previous point in the Custom Design window

In most cases, the Output Options panel appears as shown in Figure 4.25.

**Figure 4.25  Output Options Panel**

The Output Options panel contains these options:

- “Data Table Options”
- “Run Order”
- “Make Table”
- “Back”

**Data Table Options**

The Data Table Options includes the Save X Matrix option (“Save X Matrix”), the Simulate Response option (“Simulate Responses”) as well as an Include Run Order Column option.
**Include Run Order Column**   Adds a column to the design data table that corresponds to the design order in the Design outline.

**Tip:** Use the Include Run Order Column when you save your data with a sorted run order. This provides a column of the randomized run order from the design outline.

**Run Order**

The **Run Order** options determine the order of the runs in the design table. Choices include the following:

- **Keep the Same**   Rows in the design table are in the same order as in the Design outline.
- **Sort Left to Right**   Columns in the design table are sorted from left to right.
- **Randomize**   Rows in the design table are in random order.
- **Sort Right to Left**   Columns in the design table are sorted from right to left.
- **Randomize within Blocks**   Rows in the design table are in random order within the blocks.

**Make Table**

Click **Make Table** to construct the custom design data table. In the Custom Design table, the Table panel (in the upper left) can contain scripts, as appropriate given your design. The Model, Evaluate Design, and DOE Dialog scripts are always provided. To run a script, click the green triangle next to the script name. If your design includes covariates, the design table includes a covariate row index column unless all covariate rows are used in the design.

**Figure 4.26  Custom Design Table Showing Scripts**

Possible scripts include the following:

- **Model**   Runs the Analyze > Fit Model platform. The model described by the script is determined by your choices in the Model outline and by the type of design.
Chapter 4 Custom Designs

Custom Design Options

The Custom Design red triangle menu contains options for design setup and generation.

**Save Responses**  Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.

**Load Responses**  Loads responses that you saved using the Save Responses option.

**Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

**Note:** It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting **Column Properties > Design Role**. In the Design Role area, select the appropriate role.

**Load Factors**  Loads factors that you saved using the Save Factors option.
**Save Constraints**  (Unavailable for some platforms) Saves factor constraints that you defined in the Define Factor Constraints or Linear Constraints outline into a data table, with a column for each constraint. You can then quickly load the constraints into most DOE windows.

In the constraint table, the first rows contain the coefficients for each factor. The last row contains the inequality bound. Each constraint’s column contains a column property called `ConstraintState` that identifies the constraint as a “less than” or a “greater than” constraint. See “`ConstraintState`”.

**Load Constraints**  (Unavailable for some platforms) Loads factor constraints that you saved using the Save Constraints option.

**Set Random Seed**  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:

- initializing search algorithms for design generation
- randomizing Run Order for design construction
- selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking **Make Design**.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

**Simulate Responses**  Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

- A set of simulated response values is added to each response column.
- For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
- A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

**Note:** Not all distributions are available for all design types.

- A script called **DOE Simulate** is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a
new column called <Y> Simulated, where Y is the name of the response. Clicking Apply again updates the formula and values in <Y> Simulated.

For additional details, see “Simulate Responses”.

**Note:** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in *Basic Analysis*.

**Save X Matrix** Saves the Moments Matrix and Model Matrix to table scripts in the design data table. These scripts contain the moments and design matrices. See “Save X Matrix”.

**Caution:** For a design with nominal factors, the Model Matrix saved by the Save X Matrix option is not the coding matrix used in fitting the linear model. You can obtain the coding matrix used for fitting the model by selecting the option Save Columns > Save Coding Table in the Fit Model report that you obtain when you run the Model script.

**Optimality Criterion** Changes the design optimality criterion. The default criterion, **Recommended**, specifies D-optimality for all design types, unless you added quadratic effects using the RSM button in the Model outline. For more information about the D-, I-, and alias-optimal designs, see “Optimality Criteria”.

**Note:** You can set a preference to always use a given optimality criterion. Select File > Preferences > Platforms > DOE. Check Optimality Criterion and select your preferred criterion.

**Number of Starts** Enables you to specify the number of random starts used in constructing the design. See “Number of Starts”.

**Design Search Time** Maximum number of seconds spent searching for a design. The default search time is based on the complexity of the design. See “Design Search Time” and “Number of Starts”.

If the iterations of the algorithm require more than a few seconds, a Computing Design progress window appears. If you click **Cancel** in the progress window, the calculation stops and gives the best design found at that point. The progress window also displays D-efficiency for D-optimal designs that do not include factors with Changes set to Hard or Very Hard or with Estimability set to If Possible.

**Note:** You can set a preference for Design Search Time. Select File > Preferences > Platforms > DOE. Check Design Search Time and enter the maximum number of seconds. In certain situations where more time is required, JMP extends the search time.
**Sphere Radius** Constrains the continuous factors in a design to a hypersphere. Specify the radius and click **OK**. Design points are chosen so that their distance from 0 equals the Sphere Radius. Select this option before you click Make Design.

**Note:** Sphere Radius constraints cannot be combined with constraints added using the Specify Linear Constraints option. Also, the option is not available when hard-to-change factors are included (split-plot designs).

**Advanced Options > Mixture Sum** Set the sum of the mixture factors to any positive value. Use this option to keep a component of a mixture constant throughout an experiment.

**Advanced Options > Split Plot Variance Ratio** Specify the ratio of the variance of the random whole plot and the subplot variance (if present) to the error variance. Before setting this value, you must define a hard-to-change factor for your split-plot design, or hard and very-hard-to-change factors for your split-split-plot design. Then you can enter one or two positive numbers for the variance ratios, depending on whether you have specified a split-plot or a split-split-plot design.

**Advanced Options > Prior Parameter Variance** (Available only when the Model outline is available.) Specify the weights that are used for factors whose Estimability is set to If Possible. The option updates to show the default weights when you click Make Design. Enter a positive number for each of the terms for which you want to specify a weight. The value that you enter is the square root of the reciprocal of the prior variance. A larger value represents a smaller variance and therefore more prior information that the effect is not active.

Bayesian D- or I-optimality is used in constructing designs with If Possible factors. The default values used in the algorithm are 0 for Necessary terms, 4 for interactions involving If Possible terms, and 1 for If Possible terms. See “The Alias Matrix” and “Optimality Criteria”.

**Advanced Options > A- Optimality Parameter Weights** (Use for A-Optimal designs.) Specify weights for the model parameters. This enables you to place more weight on the variance of the main effects over say 2nd order effects. For more information about parameter weights see Morgan and Stallings (2017).

**Advanced Options > D Efficiency Weight** Specify the relative importance of D-efficiency to alias optimality in constructing the design. Select this option to balance reducing the variance of the coefficients with obtaining a desirable alias structure. Values should be between 0 and 1. Larger values give more weight to D-Efficiency. The default value is 0.5. This option has an effect only when you select Make Alias Optimal Design as your Optimality Criterion.

For the definition of D-efficiency, see “Optimality Criteria”. For more information about alias optimality, see “Alias Optimality”.
Save Script to Script Window  Creates the script for the design that you specified in the Custom Design window and places it in an open script window.

Simulate Responses

Use simulated responses for design exploration prior to data collection or in a classroom setting. When simulate responses is selected and you click Make Table to create your design table, the Simulate Responses option does the following for each response:

- It adds random response values to the response column in your design table.
- It adds a new column containing a simulation model formula to the design table. The formula and values are based on the model that is specified in the design window.

A Model window appears where you can specify parameter values and select a response distribution for simulation. When you click Apply in the Model window, each column containing a simulation model formula is updated.

Control Window

Figure 4.27 shows the Model window for a design with one continuous factor (X1) and one three-level categorical factor (X2). Notice that X2 is represented by two model terms.

Figure 4.27  Simulate Responses Control Window

The initial window shows values for the coefficients of either 1 or -1, and a Normal distribution with error standard deviation equal to 1. If you have set Anticipated Coefficients as part of Power Analysis under Design Evaluation in the DOE window, then the default values in the Simulate Responses outline are the values that you specified as Anticipated Coefficients and Anticipated RMSE (Error Std) in the Power Analysis outline. If it is not possible to fit the model specified in the data table’s Model script, the intercept and coefficients have default values of 0.
Simulate Responses

To specify a model for simulated values, do the following:

1. For each term in the list of Effects, enter coefficients for the linear model used to simulate the response values. These define a linear function, \( L(x, \beta) = x'\beta \). See the Simulate Responses outline in Figure 4.27:
   - The vector \( x \) consists of the terms that define the effects listed under Effects.
   - The vector \( \beta \) is the vector of model coefficients that you specify under Y.

2. Under Distribution, select a response distribution.

3. Click Apply. A \(<Y>\) Simulated column containing simulated values and their formula is added to the design table, where \( Y \) is the name of the response column.

Distribution

Choose from one of the available distributions in the Simulate Responses window:

**Normal**  
Simulates values from a normal distribution. Enter a value for Error \( \sigma \), the standard deviation of the normal error distribution. If you have designated factors to have Changes of Hard in the Factors outline, you can enter a value for Whole Plots \( \sigma \), the whole plot error. If you have designated factors to have Changes of Hard and Very Hard, you can enter values for both the subplot and whole plot errors. When you click Apply, random values and a formula containing a random response vector based on the model are entered in the column \(<Y>\) Simulated.

**Binomial**  
Simulates values from a binomial distribution. Enter a value for \( N \), the number of trials. Random integer values are generated according to a binomial distribution based on \( N \) trials with probability of success \( 1/(1 + \exp(-L(x, \beta))) \). When you click Apply, random values and their formula are entered in the column \(<Y>\) Simulated. A column called \( N \) Trials that contains the value \( N \) is also added to the data table.

**Poisson**  
Simulates random integer values according to a Poisson distribution with parameter \( \exp((L(x, \beta))) \). When you click Apply, random values and their formula are entered in the column \(<Y>\) Simulated.

**Note:** You can set a preference to simulate responses every time you click Make Table. To do so, select **File > Preferences > Platforms > DOE.** Select **Simulate Responses.**
Save X Matrix

This option saves scripts called Moments Matrix and Model Matrix that contain the moments matrix and the model matrix to the design data table. The moments matrix and the model matrix are used to calculate the Average Variance of Prediction, which appears in the Design Diagnostics section of the Design Evaluation outline. See Goos and Jones (2011). If the design is a split-plot design, a V Inverse script is also saved. The V Inverse script contains the inverse of the covariance matrix of the responses.

**Caution:** For a design with nominal factors, the Model Matrix saved by the Save X Matrix option is *not* the coding matrix used in fitting the linear model. You can obtain the coding matrix used for fitting the model by selecting the option Save Columns > Save Coding Table in the Fit Model report that you obtain when you run the Model script.

**Note:** You can set a preference to always save the matrix script. Select *File > Preferences > Platforms > DOE*. Check Save X Matrix.

Model Matrix

The *model matrix* describes the design for the experiment. The model matrix has a row for each run and a column for each term of the model specified in the Model outline. For each run, the corresponding row of the model matrix contains the coded values of the model terms:

- Continuous terms are coded to span the range from -1 to 1.
- Nominal terms are coded by applying the Gram-Schmidt orthogonalization procedure to the coding vectors used in fitting linear models.

For more information about the Gram-Schmidt orthogonalization procedure, see Horn and Johnson (2012).

**Note:** Coding for power analysis matches that of fitting linear models. For more information about the coding used for nominal terms in fitting linear models, see *Fitting Linear Models*.

Moments Matrix

The *moments matrix* is dependent upon the model effects but is independent of the design. It is defined as follows:

\[
M = \int_{R} f(x)f(x)'dx
\]
where \( f(x) \) denotes the model effects corresponding to factor combinations of the vector of factors, \( x \), and \( R \) denotes the design space. For more information about moments and design matrices, see Goos and Jones (2011) and Myers et al. (2009). Note that the moments matrix is called a matrix of region moments in Myers et al. (2009).

**Scripts**

From the Custom Design red triangle menu, select **Save X Matrix**. After the design and the table are created, in the Custom Design table, the Moments Matrix and Model Matrix scripts, and if the design is a split plot, the V Inverse script, are saved as table scripts.

- Right-click and Select **Edit** from either the Moments Matrix, Model Matrix, or V Inverse script. The script shows the corresponding matrix. You can copy this matrix into scripts that you write.
- When you run the Moments Matrix script, the log shows the number of rows in the moments matrix, called Moments.
- When you run the script Model Matrix, the log displays the number of rows in the model matrix, called \( X \).
- When you run the script V Inverse, the log displays the number of rows in the inverse covariance matrix, called \( V^{-1} \).

**Example**

This example illustrates use of the model matrix script:

**Tip:** To see the log, select **View > Log** (Window > Log on macOS).

1. Select **DOE > Custom Design**.
2. Add 3 continuous factors and click **Continue**.
3. Click **Interactions > 2nd**.
4. Click the Custom Design red triangle and select **Save X Matrix**.
5. Using the Default Number of Runs (12), click **Make Design** and then **Make Table**.
6. In the Table panel, right-click the Moments Matrix script and select **Edit**.

   The script appears in a script window. The script shows the moments matrix, which is called **Moments**.
7. If it is not already open, select View > Log (Window > Log on the macOS).

8. In the Table panel, click the green triangle next to the Moments Matrix script.

   The number of rows appear in the log as $N \text{ Row}(\text{Moments})=7$.

9. In the Table panel, right-click the Model Matrix script and select Edit.

   The script appears in a script window. The script shows the model matrix, which is called $X$.

10. Click Run.

    The number of rows appears in the log as $N \text{ Row}(X)=12$.

11. To view the Model Matrix as a data table, add these lines to the script:

    ```
    dt = New Table( "Model Matrix" );
    dt << Set Matrix( X );
    ```

12. Click Run.

**Number of Starts**

The number of starts is the number of times that the coordinate-exchange algorithm initiates with a new design. See “Coordinate-Exchange Algorithm”. You can specify your own value using the Number of Starts option. Increasing the number of random starts tends to improve the optimality of the resulting design.

Unless you specify a value for Number of Starts and click OK, the number of starts is controlled by Design Search Time. To see how many starts were used to construct a design, click Make Design. Then select Number of Starts. The value in the text box is the number of starts used to construct the specific design.

In certain special cases, the globally optimal design is known from theory. If the coordinate-exchange algorithm detects that it has found an optimal design, it stops searching and returns that design.
Tip: To reproduce a specific design, you need to specify the Number of Starts and the Random Seed originally used to produce the design. Obtain these values from the red triangle options after you click Make Design.

In examples of custom designs in the documentation, the random seed and number of starts are often provided so that you can reconstruct the exact design being discussed.

Design Search Time

Design Search Time is the amount of time allocated to finding an optimal design. Custom Design’s coordinate-exchange algorithm consists of finding near-optimal designs based on random starting designs. See “Coordinate-Exchange Algorithm”. The Design Search Time determines how many designs are constructed based on random starting designs.

You can specify your own value using the Design Search Time option. Increasing the search time tends to improve the optimality of the resulting design.

Keep in mind that designs produced by rerunning the algorithm can differ. Even with the same random seed, the numbers of starting designs used to construct the final design might differ because of variations in computing speed and other factors.

Note: The number of starting designs is given by the value in the Number of Starts text box. However, this value is not updated until after you construct your design by clicking Make Design.

In certain special cases, the globally D-optimal design is known from theory. These cases include:

- Two-level fractional factorial designs or nonregular orthogonal arrays. These are globally D-optimal for all main effect and two-factor interaction models.
- Latin-square designs. These are D-optimal for main effect models assuming the right sample size and numbers of levels of the factors.
- Plackett-Burman designs. These are D-optimal for main effect models.

If the coordinate-exchange algorithm detects that it has found an optimal design, it stops searching and returns that design.
Technical Details for Custom Designs

- “Designs with Randomization Restrictions”
- “Covariates with Hard-to-Change Levels”
- “Numbers of Whole Plots and Subplots”
- “Optimality Criteria”
- “D-Efficiency”
- “Coordinate-Exchange Algorithm”

Designs with Randomization Restrictions

It is not always feasible to run a completely randomized design. Logistical or physical restrictions to randomization have to be considered when designing an experiment. This section describes how the Custom Design platform handles various types of designs where random assignment of experimental units to factor level settings is restricted. Random block designs and various types of split-plot designs are included.

Random Block Designs

A random block design groups the runs of an experiment into blocks that are considered to be randomly chosen from a larger population. Runs within a block of runs are usually more homogeneous than runs in different blocks. In these instances, you are often better able to discern other effects if you account for the variation explained by the blocking variables.

Scenario for a Random Block Design

Goos (2002) presents an example involving a pastry dough mixing experiment. The purpose of the experiment is to understand how certain properties of the dough depend on three factors: feed flow rate, initial moisture content, and rotational screw speed. Since it was possible to conduct only four runs a day, the experiment required several days to run. It is likely that random day-to-day differences in environmental variables have some effect on all of the runs that are performed on a given day. To account for the day-to-day variation, the runs were grouped into blocks of size four so that this variation would not compromise the information about the three factors.

The blocking factor, Day, consists of each day’s runs. The days on which the trials were conducted are representative of a large population of days with different environmental conditions. Day is a random blocking factor.
**Setup for a Random Block Design**

To create a random block design, use the Custom Design platform to enter responses and factors and define your model as usual. In the Design Generation outline, select the **Group runs into random blocks of size** option and enter the number of runs you want in each block. See “Design Structure Options”.

**Note:** To define a fixed blocking factor, enter a blocking factor in the Factors outline. To define a random blocking factor, do not enter a blocking factor in the Factors outline. Instead, select the **Group runs into random blocks of size** option under Design Generation.

**Split-Plot Designs**

Split-plot designs are used in situations where the settings of certain factors are held constant for groups of runs. In industry, these are usually factors that are difficult or expensive to change from run to run. Factors whose settings need to be held constant for groups of runs are classified as *hard-to-change* in JMP.

Because certain factors are hard-to-change, it is not practical to randomly allocate them to experimental units. Instead, they are allocated to groups of units. This imposes a restriction on randomization that must be considered in generating a design and in analyzing the results.

**Scenario for a Split-Plot Design**

Box et al. (2005) presents an experiment to study the corrosion resistance of steel bars. The bars are placed in a furnace for curing. Afterward, a coating is applied to increase resistance to corrosion. The two factors of interest are:

- **Furnace Temp** in degrees centigrade, with levels 360, 370, and 380
- **Coating**, with levels C1, C2, C3, and C4 depicting four different types of coating

Furnace Temp is a hard-to-change factor, due to the time it takes to reset the temperature in the furnace. For this reason, four bars are processed for each setting of furnace temperature. At a later stage, the four coatings are randomly assigned to the four bars.

The experimental units are the bars. Furnace Temp is a hard-to-change factor whose levels define whole plots. Within each whole plot, the Coating factor is randomly assigned to the experimental units to which the whole plot factor was applied.
Figure 4.29 Factors and Design Outlines for Split-Plot Design

The Factors outline for the corrosion experiment has Changes set to Hard for Furnace Temp and Easy for Coating. The 15-run design consists of five whole plots, within which the settings of Temperature are held constant.

Setup for a Split-Plot Design

In general, several factors can be applied to a processing step where settings are hard-to-change. In the furnace example, you might consider a furnace location factor, as well as temperature. In the Factors outline, under the Changes column, you would specify a Changes value of Hard for such factors.

When a custom design involves only easy-to-change and hard-to-change factors, the runs of the hard-to-change factors are grouped using a new factor called Whole Plots. The values of Whole Plots designate blocks of runs with identical settings for the hard-to-change factors. The Model script that is saved to the design table treats Whole Plots as a random effect. See “Changes” and “Design Structure Options”.

For an example of creating a split-plot design and analyzing the experimental data, see “Split-Plot Experiment”.
**Split-Split-Plot Designs**

A split-split-plot design is used when there are two levels of factors that are hard-to-change. In industry, such designs often occur when batches of material or experimental units from one processing stage pass to a second processing stage. Factors are applied to batches of material at the first stage. Then those batches are divided for second-stage processing, where additional factors are studied. The first stage factors are considered very-hard-to-change, and the second-stage factors are considered hard-to-change. Additional factors can be applied to experimental units after the second processing stage. These factors are considered easy-to-change.

In a split-split-plot design, the batches are considered to be random blocks. Since the batches are divided for second-stage processing, the second-stage factors are nested within the first-stage factors.

**Scenario for a Split-Split-Plot Design**

Schoen (1999) presents an example of a split-split-plot design that relates to cheese quality. The factors are given in the Cheese Factors.jmp data table found in the Design Experiment folder. The experiment consists of three stages of processing:

- Milk is received from farmers and stored in a large tank.
- Milk from this tank is distributed to smaller tanks used for curd processing.
- The curds from each tank are transported to presses for processing individual cheeses.

The experiment consists of testing:

- Two factors that are applied when the milk is in the large storage tank.
- Five factors that are applied to the smaller curd processing tanks.
- Three factors that are applied to the individual cheeses from a curds processing tank.

Notice that the levels of factors applied to the curd processing tanks (subplots) are nested within the levels of factors applied to the milk storage tank (whole plots).

The Factors outline have Changes set as Very Hard, Hard, or Easy:

- Very Hard for the two storage tank factors.
- Hard for the five curd processing tank factors.
- Easy for the three factors that can be randomly assigned to cheeses.
The default number of whole plots is 5 and the default number of subplots is 10. The number of runs is set to 22. If only 10 subplots are used the design does not have enough whole plots to estimate the subplot variance. Change the number of subplots to 11 and click **Make Design** to see a 22-run design.
Figure 4.31 Split-Split-Plot Design for Cheese Scenario

<table>
<thead>
<tr>
<th>Run</th>
<th>Whole Plots</th>
<th>Subplots</th>
<th>storage 1</th>
<th>storage 2</th>
<th>curds 1</th>
<th>curds 2</th>
<th>curds 3</th>
<th>curds 4</th>
<th>curds 5</th>
<th>cheese 1</th>
<th>cheese 2</th>
<th>cheese 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>2</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>2</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>3</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l2</td>
<td>1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
<td>4</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>4</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>5</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>9</td>
<td>2</td>
<td>5</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>10</td>
<td>2</td>
<td>5</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>11</td>
<td>3</td>
<td>6</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>12</td>
<td>3</td>
<td>6</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>13</td>
<td>3</td>
<td>6</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>14</td>
<td>3</td>
<td>7</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>15</td>
<td>4</td>
<td>8</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>16</td>
<td>4</td>
<td>8</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>17</td>
<td>4</td>
<td>9</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>18</td>
<td>4</td>
<td>9</td>
<td>1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
<td>-1</td>
<td>l1</td>
</tr>
<tr>
<td>19</td>
<td>5</td>
<td>10</td>
<td>-1</td>
<td>l1</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
</tr>
<tr>
<td>20</td>
<td>5</td>
<td>10</td>
<td>-1</td>
<td>l1</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
</tr>
<tr>
<td>21</td>
<td>5</td>
<td>11</td>
<td>-1</td>
<td>l1</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
</tr>
<tr>
<td>22</td>
<td>5</td>
<td>11</td>
<td>-1</td>
<td>l1</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
<td>1</td>
<td>l2</td>
</tr>
</tbody>
</table>

The five whole plots correspond to the storage factors; storage 1 and storage 2. The settings of the storage factors are constant within a whole plot. If consecutive whole plots have the same setting for a whole plot factor, the factor should be reset between the plots. For example, you should reset the level for storage 1 between runs 10 and 11 and between runs 14 and 15, and you should reset the level for storage 2 between runs 18 and 19. Resetting the factor between whole plots, even when the specified settings are the same, is required in order to capture whole plot variation.

The 11 subplots correspond to the curds factors. Within a subplot, the settings of the curds factors are constant. Each level of Subplots appears only within one level of Whole Plots, indicating that the levels of Subplots are nested within the levels of Whole Plots.

Levels of the cheese factors vary randomly from run to run.

Setup for a Split-Split-Plot Design

In a split-split-plot design, the Factors outline contains factors with Changes set to Very Hard and Hard. The design can also contain factors with Changes set to Easy. Two factors are created:

- A factor called Whole Plots represents the blocks of constant levels of the factors with Changes set to Very Hard.
- A factor called Subplots represents the blocks of constant levels of the factors with Changes set to Hard.
- The factor Subplots reflects the nesting of the levels of the factors with Changes set to Hard within the levels of the factors with Changes set to Very Hard.
• The levels of factors with Changes set to Easy are randomly assigned to units within subplots.
• The factors Whole Plots and Subplots are treated as random effects in the Model script that is saved to the design table.

See the Changes description under “Factors Outline” and “Design Structure Options”.

Two-Way Split-Plot Designs

A two-way split-plot (also known as strip plot or split block) design consists of two split-plot components. In industry, these designs arise when batches of material or experimental units from one processing stage pass to a second processing stage. But, after the first processing stage, it is possible to divide the batches into sub-batches. The second-stage processing factors are applied randomly to these sub-batches. For a specific second-stage experimental setting, all of the sub-batches assigned to that setting can be processed simultaneously. Additional factors can be applied to experimental units after the second processing stage.

In contrast to a split-split-plot design, the second-stage factors are not nested within the first-stage factors. After the first stage, the batches are subdivided and formed into new batches. Therefore, both the first- and second-stage factors are applied to whole batches.

Although factors at both stages might be equally hard-to-change, to distinguish these factors, JMP denotes the first stage factors as very-hard-to-change, and the second-stage factors as hard-to-change. Additional factors applied to experimental units after the second processing stage are considered easy-to-change.

Scenario for a Two-Way Split-Plot Design

Vivacqua and Bisgaard (2004) describe an experiment to improve the open circuit voltage in battery cells. Two stages of processing are of interest:

• First stage: A continuous assembly process
• Second stage: A curing process with a 5-day cycle time

The engineers want to study six two-level factors:

• Four factors, X1, X2, X3, and X4, that are applied to the assembly process
• Two factors, X5 and X6, that are applied to the curing process

A full factorial design with all factors at two levels would require $2^6 = 64$ runs, and would require a prohibitive $64*5 = 320$ days. Also, it is not practical to vary assembly conditions for individual batteries. However, assembly conditions can be changed for large batches, such as batches of 2000 batteries.
Both the first- and second-stage factors are hard-to-change. In a sense, there are two split-plot designs. However, the batches of 2,000 batteries from the first-stage experiment can be divided into four sub-batches of 500 batteries each. These sub-batches can be randomly assigned to the four settings of the two second-stage factors. All of the batches assigned to a given set of curing conditions can be processed simultaneously. In other words, the first- and second-stage factors are crossed.

To distinguish between the first- and second-stage factors, you designate the Changes for the first-stage factors as Very Hard, and the Changes for the second-stage factors as Hard (Figure 4.32). Also, under Design Generation, note the following option: **Hard to change factors can vary independently of Very Hard to change factors.** If this is not checked, the design is treated as a split-split-plot design, with nesting of factors at the two levels. Check this option to create a two-way split-plot design.

**Figure 4.32** Factors and Design Generation Outline for Two-Way Split Plot Design

The default number of whole plots is 7; the default number of subplots is 14. Click **Make Design** to see the 28-run design.
The seven whole plots correspond to the first-stage factors, X1, X2, X3, and X4. The settings of these factors are constant within a whole plot. The 14 subplots correspond to the second-stage factors, X5 and X6. For example, the sub-batches for runs 1 and 15 (from different whole plots) are subject to the same subplot treatment, where X5 is set at 1 and X6 at -1.

**Setup for a Two-Way Split-Plot Design**

A two-way split-plot design requires factors with Changes set to Very Hard and to Hard. As described in “Setup for a Split-Split-Plot Design”, factors called Whole Plots and Subplots are created. However, in a two-way split-plot design, Subplots does not nest the levels of factors with Changes set to Hard within the levels of factors with Changes set to Very Hard. Both Whole Plots and Subplots are treated as random effects in the Model script that is saved to the design table.

You need to ensure that the factor Subplots is not nested within the factor Whole Plots. Select the option **Hard to change factors can vary independently of Very Hard to change factor** in the Design Generation outline (Figure 4.32). See “Changes” and “Design Structure Options”.

For an example of creating a split-plot design and analyzing the experimental data, see “Two-Way Split-Plot Experiment”.

---

**Figure 4.33 Two-Way Split-Plot Design for Battery Cells**

<table>
<thead>
<tr>
<th>Run</th>
<th>Whole Plots</th>
<th>Subplots</th>
<th>X1</th>
<th>X2</th>
<th>X3</th>
<th>X4</th>
<th>X5</th>
<th>X6</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>2</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>3</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>4</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>5</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
<td>6</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>7</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>8</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>3</td>
<td>9</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>10</td>
<td>3</td>
<td>10</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>11</td>
<td>3</td>
<td>11</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>12</td>
<td>3</td>
<td>12</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>13</td>
<td>4</td>
<td>13</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>14</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>15</td>
<td>4</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>16</td>
<td>4</td>
<td>2</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>17</td>
<td>5</td>
<td>3</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>18</td>
<td>5</td>
<td>4</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>19</td>
<td>5</td>
<td>5</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>20</td>
<td>5</td>
<td>6</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>21</td>
<td>6</td>
<td>7</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>22</td>
<td>6</td>
<td>8</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>23</td>
<td>6</td>
<td>9</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>24</td>
<td>6</td>
<td>10</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>25</td>
<td>7</td>
<td>11</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>26</td>
<td>7</td>
<td>12</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>27</td>
<td>7</td>
<td>13</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>28</td>
<td>7</td>
<td>14</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
</tbody>
</table>
Covariates with Hard-to-Change Levels

The Custom Design platform enables you to designate covariates as hard-to-change. Suppose that you have measurements on batches of material that are available for use in testing experimental factors. Or suppose that you have measurements on individuals who might be selected to participate in testing experimental factors. These measurements are known in advance of the experiment and are considered to be covariates.

The batches or individuals correspond to whole plots. You might want to use only some of these whole plots in your experiment. Because information about the whole plots in the form of covariates is available, the design should choose the whole plots in an optimal fashion.

The model, as given by the terms that you include in the Model outline, can include interactions and powers constructed using covariates and experimental factors.

Note: When you set Changes for a Covariate factor to Hard, all other covariates are also set to Hard. The remaining factors must be set to Easy. Because the algorithm requires a combination of row exchange and coordinate exchange, even moderately sized designs might take some time to generate.

Scenario for an Experiment with a Hard-to-Change Covariate

An experiment involving batches of polypropylene plates is discussed in Goos and Jones (2011, Chapter 9) and Jones and Goos (2015). Large batches of polypropylene plates are produced according to various formulations determined by several variables. Some plates are used immediately, and the remainder are stored for future experimental purposes. The compositions of these stored batches are known.

A customer has certain requirements regarding the plate formulation. Future experiments involve customizing the gas plasma treatment to the types of formulations required by the customer. The composition variables are considered hard-to-change covariates. Gas plasma treatment factors can be applied to sub-batches of plates with a given formulation.

The optimal design identifies the batches (defined by the covariates) to use, determines the number of plates from each batch to use, and provides settings for the gas plasma levels. Note that the optimal number of batches and plates from a given batch depend on the covariates.

An example is provided in “Examples of Custom Designs”.

Numbers of Whole Plots and Subplots

JMP suggests default values for the Number of Whole Plots and Number of Subplots. These values are based on heuristics for creating a balanced design that allows for estimation of the effects specified in the Model outline.
If you enter missing values for Number of Whole Plots or Number of Subplots, JMP chooses values that maximize the D-efficiency of the design. The algorithm uses the values specified in the Split Plot Variance Ratio option. See “Advanced Options > Split Plot Variance Ratio”. The D-efficiency is given by the determinant of $X'V^{-1}X$, where $V^{-1}$ is the inverse of the variance matrix of the responses. See Goos (2002).

If you enter values for the Number of Whole Plots and Number of Subplots, Custom Design attempts to maximize the optimality of the resulting design. For more information about split-plot designs, see Jones and Goos (2007). For more information about designs with hard-to-change covariates, see Jones and Goos (2015).

**Optimality Criteria**

Custom designs are created using search routines that depend on an optimality criteria. This section provides information about the optimality options for creating a custom design:

- “D-Optimality”
- “Bayesian D-Optimality”
- “I-Optimality”
- “Bayesian I-Optimality”
- “A-Optimality”
- “Alias Optimality”

**D-Optimality**

By default, the Custom Design platform optimizes the D-optimality criterion except when a full quadratic model is created using the RSM button. In that case, an I-optimal design is constructed.

The D-optimality criterion minimizes the determinant of the covariance matrix of the model coefficient estimates. It follows that D-optimality focuses on precise estimates of the effects. This criterion is desirable in the following cases:

- screening designs
- experiments that focus on estimating effects or testing for significance
- designs where identifying the active factors is the experimental goal

The D-optimality criterion is dependent on the assumed model. This is a limitation because often the form of the true model is not known in advance. The runs of a D-optimal design optimize the precision of the coefficients of the assumed model. In the extreme, a D-optimal design might be saturated, with the same number of runs as parameters and no degrees of freedom for lack of fit.
Specifically, a D-optimal design maximizes \( D \), where \( D \) is defined as follows:

\[
D = \det[X'X]
\]

and where \( X \) is the model matrix as defined in “Simulate Responses”.

D-optimal split-plot designs maximize \( D \), where \( D \) is defined as follows:

\[
D = \det [X'V^{-1}X]
\]

and \( V^{-1} \) is the block diagonal covariance matrix of the responses (Goos 2002).

Since a D-optimal design focuses on minimizing the standard errors of coefficients, it might not allow for checking that the model is correct. For example, a D-optimal design does not include center points for a first-order model. When there are potentially active terms that are not included in the assumed model, a better approach is to specify If Possible terms and to use a Bayesian D-optimal design.

**Bayesian D-Optimality**

*Bayesian D-optimality* is a modification of the D-optimality criterion. The Bayesian D-optimality criterion is useful when there are potentially active interactions or non-linear effects. See DuMouchel and Jones (1994) and Jones et al (2008).

Bayesian D-optimality estimates a specified set of model parameters precisely. These are the effects whose Estimability you designate as Necessary in the Model outline. But at the same time, Bayesian D-optimality has the ability to estimate other, typically higher-order effects, as allowed by the run size. These are the effects whose Estimability you designate as If Possible in the Model outline. To the extent possible given the run size restriction, a Bayesian D-optimal design allows for detecting inadequacy in a model that contains only the Necessary effects.

The Bayesian D-optimality criterion is most effective when the number of runs is larger than the number of Necessary terms, but smaller than the sum of the Necessary and If Possible terms. When this is the case, the number of runs is smaller than the number of parameters that you would like to estimate. Using prior information in the Bayesian setting allows for precise estimation of all of the Necessary terms while providing the ability to detect and estimate some If Possible terms.

To allow for a meaningful prior distribution to apply to the parameters of the model, responses and factors are scaled to have certain properties (DuMouchel and Jones, 1994, Section 2.2).

Consider the following notation:

- \( X \) is the model matrix as defined in “Simulate Responses”
- \( K \) is a diagonal matrix with values as follows:

\[
D = \det [X'V^{-1}X]
\]
– $k = 0$ for Necessary terms
– $k = 1$ for If Possible main effects, powers, and interactions involving a categorical factor with more than two levels
– $k = 4$ for all other If Possible terms

The prior distribution imposed on the vector of If Possible parameters is multivariate normal, with mean vector $\mathbf{0}$ and diagonal covariance matrix with diagonal entries $1/k^2$. Therefore, a value $k^2$ is the reciprocal of the prior variance of the corresponding parameter.

The values for $k$ are empirically determined. If Possible main effects, powers, and interactions with more than one degree of freedom have a prior variance of 1. Other If Possible terms have a prior variance of 1/16. In the notation of DuMouchel and Jones (1994) $k = 1/\tau$.

To control the weights for If Possible terms, select **Advanced Options > Prior Parameter Variance** from the red triangle menu. See “Advanced Options > Prior Parameter Variance”.

The posterior distribution for the parameters has the covariance matrix $(\mathbf{X}'\mathbf{X} + K^2)^{-1}$. The Bayesian D-optimal design is obtained by maximizing the determinant of the inverse of the posterior covariance matrix:

$$\det(\mathbf{X}'\mathbf{X} + K^2)$$

**I-Optimality**

I-optimal designs minimize the average variance of prediction over the design space. The I-optimality criterion is more appropriate than D-optimality if your primary experimental goal is not to estimate coefficients, but rather to do the following:

- predict a response
- determine optimum operating conditions
- determine regions in the design space where the response falls within an acceptable range

In these cases, precise prediction of the response takes precedence over precise estimation of the parameters.

The prediction variance relative to the unknown error variance at a point $x_0$ in the design space can be calculated as follows:

$$\text{var}(\hat{Y}|x_0) = f(x_0)'(\mathbf{X}'\mathbf{X})^{-1}f(x_0)$$

where $\mathbf{X}$ is the model matrix as defined in “Simulate Responses”.
I-optimal designs minimize the integral $I$ of the prediction variance over the entire design space, where $I$ is given as follows:

$$ I = \int_{\mathcal{R}} f(x)'(X'X)^{-1}f(x)dx = \text{trace}[(X'X)^{-1}M] $$

Here $M$ is the moments matrix:

$$ M = \int_{\mathcal{R}} f(x)f(x)'dx $$

See “Simulate Responses”.

The moments matrix does not depend on the design and can be computed in advance. The row vector $f(x)'$ consists of a 1 followed by the effects corresponding to the assumed model. For example, for a full quadratic model in two continuous factors, $f(x)'$ is defined as follows:

$$ f(x)' = (1, x_1, x_2, x_1x_2, x_1^2, x_2^2) $$

### A-Optimality

Use an A-optimal design when you want to put emphasis on certain model effects. An A-optimal design enables you to assign weights to your model parameters. These weights are used in the A-optimality criterion to select the design. The resulting design will place more emphasis on factor combinations that lower the variance of the estimates for highly weighted terms than for terms with lower weights. For example, you may have a group of interactions that are more important to estimate than other interactions. You can increase the weights on the key interactions to decrease the variance of their estimates as compared to the other interactions.

The A-optimality criterion minimizes the trace of the covariance matrix of the model coefficient estimates. The trace is the sum of the main diagonal elements of a matrix. An A-optimal design minimizes the sum of the variances of the regression coefficients.

### Bayesian I-Optimality

The Bayesian I-optimal design minimizes the average prediction variance over the design region for Necessary and If Possible terms.

Consider the following notation:

- $X$ is the model matrix, defined in “Simulate Responses”
- $K$ is a diagonal matrix with values as follows:
  - $k = 0$ for Necessary terms
– $k = 1$ for If Possible main effects, powers, and interactions involving a categorical factor with more than two levels
– $k = 4$ for all other If Possible terms

The prior distribution imposed on the vector of If Possible parameters is multivariate normal, with mean vector $0$ and diagonal covariance matrix with diagonal entries $1/k^2$. (For more information about the values $k$, see “Bayesian D-Optimality”.)

The posterior variance of the predicted value at a point $x_0$ is as follows:

$$\text{var}(\hat{Y}|x_0) = f(x_0)'(X'X + K^2)^{-1}f(x_0)$$

The Bayesian I-optimal design minimizes the average prediction variance over the design region, as follows:

$$I_B = \text{trace}[(X'X + K^2)^{-1}M]$$

where $M$ is the moments matrix. See “Simulate Responses”.

**Alias Optimality**

Alias optimality seeks to minimize the aliasing between effects that are in the assumed model and effects that are not in the model but are potentially active. Effects that are not in the model but that are of potential interest are called *alias effects*. For more information about alias-optimal designs, see Jones and Nachtsheim (2011b).

Specifically, let $X_1$ be the model matrix corresponding to the terms in the assumed model, as defined in “Simulate Responses”. The design defines the model that corresponds to the alias effects. Denote the matrix of model terms for the alias effects by $X_2$.

The *alias matrix* is the matrix $A$, defined as follows:

$$A = (X_1'X_1)^{-1}X_1'X_2$$

The entries in the alias matrix represent the degree of bias associated with the estimates of model terms. See “The Alias Matrix” for the derivation of the alias matrix.

The sum of squares of the entries in $A$ provides a summary measure of bias. This sum of squares can be represented in terms of a trace as follows:

$$\text{trace}(A'A)$$
Designs that reduce the trace criterion generally have lower D-efficiency than the D-optimal design. Consequently, alias optimality seeks to minimize the trace of $A'A$ subject to a lower bound on D-efficiency. For the definition of D-efficiency, see “Optimality Criteria”. The lower bound on D-efficiency is given by the D-efficiency weight, which you can specify under Advanced Options. See “Advanced Options > D Efficiency Weight”.

**D-Efficiency**

Let $X$ denote the design, or model, matrix for a given assumed model with $p$ parameters. For the definition of the model matrix, see “Simulate Responses”. Let $X_D$ denote the model matrix for a D-optimal design for the assumed model. Then the D-efficiency of the design given by $X$ is as follows:

$$D\text{-Efficiency} = \left[ \frac{\det(X'X)}{\det(X_D'X_D)} \right]^{1/p}$$

**Coordinate-Exchange Algorithm**

The Custom Designer constructs a design that seeks to optimize one of several optimality criteria. (See “Optimality Criteria”.) To optimize the criterion, Custom Design uses the coordinate-exchange algorithm (Meyer and Nachtsheim, 1995). The algorithm begins by randomly selecting values within the specified design region for each factor and each run to construct a starting design.

Suppose your study requires continuous factors, no factor constraints, and a main-effects model. An iteration consists of testing each value of the model matrix, as follows:

- The current value of each factor is replaced by its two most extreme values.
- The optimality criterion is computed for both of these replacements.
- If one of the values increases the optimality criterion, this value replaces the old value.

The process continues until no replacement occurs for an entire iteration.

Appropriate adjustments are made to the algorithm to account for polynomial terms, nominal factors, and factor constraints.

The design obtained using this process is optimal in a large class of neighboring designs. But it is only locally optimal. To improve the likelihood of finding a globally optimal design, the coordinate-exchange algorithm is repeated a large number of times. Goos and Jones (2011, p. 36) recommend using at least 1,000 random starts for all but the most trivial design situations. The number of starting designs is controlled by the Number of Starts option. See “Number of Starts”. Custom Design provides the design that maximizes the optimality criterion among all the constructed designs.
Use the Custom Design platform as your primary tool for constructing a wide range of experimental designs. You can construct a variety of design types and fine tune them to your specific experimental needs and resource budget.

Custom Design provides more options and control than the Screening, Response Surface, Full Factorial, and Mixture Design platforms. The designs that you construct are created specifically to meet your goals. This eliminates the struggle to find a classical design that only comes close to meeting your goals.

The flexible special-purpose designs that you can construct using Custom Design include:

- Screening designs, including supersaturated screening designs
- Response surface designs, including those with categorical factors
- Mixture designs, including those with process factors, and mixture of mixture designs
- Designs that include covariates or that are robust to linear time trends
- Fixed and random block designs
- Split-plot, split-split-plot, and two-way split-plot (strip-plot) designs

In this chapter you construct most of these design types within the Custom Design platform. In many cases, you also analyze the experimental results. For help with using the Custom Design platform, see “Custom Designs”.

**Figure 5.1** Fraction of Design Space Plot
Contents

Screening Experiments ............................................................... 137
  Design That Estimates Main Effects Only .................................. 137
  Design That Estimates All Two-Factor Interactions .................... 140
  Design That Avoids Aliasing of Main Effects and Two-Factor Interactions ......................................................... 143
  Supersaturated Screening Designs ............................................. 146
Design for Fixed Blocks .............................................................. 154
Response Surface Experiments .................................................. 159
  Response Surface Design ........................................................ 159
  Response Surface Design with Flexible Blocking ....................... 165
  Comparison of a D-Optimal and an I-Optimal Response Surface Design ............................................................... 168
Response Surface Design With Constraints and Categorical Factor .... 172
Mixture Experiments ..................................................................... 178
  Mixture Design with Nonmixture Factors ................................... 178
  Mixture of Mixtures Design ...................................................... 182
Experiments with Covariates ....................................................... 187
  Design with Fixed Covariates .................................................... 187
  Design with Hard-to-Change Covariates ..................................... 190
  Design with a Linear Time Trend ............................................... 194
Experiments with Randomization Restrictions ............................... 197
  Split-Plot Experiment ............................................................. 197
  Two-Way Split-Plot Experiment ................................................ 202
Experiments for Robust Process and Product Design ....................... 210
Screening Experiments

In the early stages of studying a process, you identify a list of factors that potentially affect your response or responses. You are interested in identifying the active factors, that is, the factors that actually do affect your response or responses. A screening design helps you determine which factors are likely to be active. Once the active factors are identified, you can construct more sophisticated designs, such as response surface designs, to model interactions and curvature.

Screening designs constructed using the Custom Design platform are often equivalent to the classical designs provided in the Screening Design platform. However, Custom Design can construct designs for cases where classical screening designs are not available.

The Custom Design platform constructs screening designs using either the D-optimality or Bayesian D-optimality criterion. The D-optimality criterion minimizes the determinant of the covariance matrix of the model coefficient estimates. It follows that D-optimality focuses on precise estimates of the effects. See “Optimality Criteria”.

- “Design That Estimates Main Effects Only”
- “Design That Estimates All Two-Factor Interactions”
- “Design That Avoids Aliasing of Main Effects and Two-Factor Interactions”
- “Supersaturated Screening Designs”
- “Design for Fixed Blocks”

Design That Estimates Main Effects Only

Note: For more information about main effects only screening designs, see “Screening Designs”.

In this example, you are interested in studying the main effects of six factors. You construct a screening design where all of the main effects are orthogonal. However, the main effects are aliased with two-factor interactions.

1. Select DOE > Custom Design.
2. In the Factors outline, type 6 next to Add N Factors.
3. Click Add Factor > Continuous.
4. Click Continue.

The Model outline appears. It includes only main effects with Estimability designated as Necessary. This means that all main effects are estimable in the design that is generated.
Keep the default of 12 runs.

**Note:** Setting the Random Seed in step 5 and Number of Starts in step 6 reproduces the exact results shown in this example. When constructing a design on your own, these steps are not necessary.

5. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 12345, and click **OK**.

6. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 1, and click **OK**.

7. Click **Make Design**.
Figure 5.3  Design for Main Effects Only

8. Open the **Design Evaluation > Color Map on Correlations** outline.

**Figure 5.4  Color Map on Correlations**

Notice the following:
- The main effects are represented by the six terms in the upper left corner of the map.
- The white coloring corresponding to the correlations of the six main effects with other main effects indicates correlations of 0. This means that all main effects are orthogonal and can be estimated independently of each other.
- The light gray color in the squares corresponding to some two-way interactions indicates that the corresponding effects are correlated. This means that these effects cannot be estimated independently of other effects. Hover over these squares to see the exact correlation.
– Notice that no effects are completely confounded with each other. The black squares, indicating absolute correlations of 1, are only on the main diagonal.


**Figure 5.5** Alias Matrix

The Alias Matrix shows how the coefficients of the main effect terms in the model are biased by potentially active two-factor interaction effects. The column labels identify interactions. For example, in the X1 row, the column X2*X3 has a value of -0.33 and the column X2*X4 has a value of 0.333. This means that the expected value of the main effect of X1 is the sum of the main effect of X1 plus -0.33 times the effect of X2*X3, plus 0.333 times the effect of X2*X4, and so on, for the rest of the X1 row. In order for the estimate of the main effect of X1 to be meaningful, you must assume that these interactions are negligible in size compared to the effect of X1.

**Tip:** The Alias Matrix is a generalization of the confounding pattern in fractional factorial designs.

**Design That Estimates All Two-Factor Interactions**

The Alias Matrix in Figure 5.5 shows partial aliasing of effects. In other cases, main effects might be fully aliased, or *confounded*, with two-factor interactions. In both of these cases, strong two-factor interactions can confuse the results of main effects only experiments. To avoid this risk, create a design that resolves all two-factor interactions.

In this example, you create a resolution V screening design. Two-factor interactions are orthogonal, but they are confounded with three-factor interactions.

1. Select **DOE > Custom Design**.
2. Type 5 next to **Add N Factors**.
3. Click **Add Factor > Continuous**.
4. Click **Continue**.
5. In the Model outline, select **Interactions > 2nd**.
6. Click **Minimum** to accept 16 for the number of runs.

   **Note:** Setting the Random Seed in step 7 and Number of Starts in step 8 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

7. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 12345, and click **OK**.

8. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 1, and click **OK**.

9. Click **Make Design**.

   Figure 5.7 shows the runs of the design. All main effects and two-factor interactions are estimable because their Estimability was designated as Necessary (by default) in the Model outline.
Figure 5.7 Design to Estimate All Two-Factor Interactions

10. Open the **Design Evaluation > Color Map on Correlations** outline.

Figure 5.8 Color Map on Correlations

The Color Map indicates that the five main effects and the ten two-way interactions are all mutually orthogonal.
Design That Avoids Aliasing of Main Effects and Two-Factor Interactions

Suppose that your primary interest is in estimating the main effects of six continuous factors. However, you want to do this in a way that minimizes aliasing of main effects with potentially active two-factor interactions.

Your budget allows for only 16 runs. With six factors, there are 15 possible two-factor interactions. The minimum number of runs required to fit the constant, the six main effects, and the 15 two-factor interactions is 22.

In this example, you find a compromise between an 8-run main effects only design (see “Design That Estimates Main Effects Only”) and a 22-run design capable of fitting all the two-factor interactions. You use Alias Optimality as the optimality criterion to achieve your goal.

1. Select **DOE > Custom Design**.
2. Type 6 next to **Add N Factors**.
3. Click **Add Factor > Continuous**.
4. Click **Continue**.

   The model includes the main effect terms by default. The default estimability of these terms is Necessary. In the Alias Terms outline, notice that second-order interactions are added. By default, all two-way interactions not included in the assumed model are added to the Alias Terms list.

5. Click the Custom Design red triangle and select **Optimality Criterion > Make Alias Optimal Design**.

   The Make Alias Optimal Design selection tells JMP to generate a design that balances reduction in aliasing with D-efficiency. See “Alias Optimality”.

6. Click **User Specified** and change the number of runs to 16.
Figure 5.9 Factors, Model, Alias Terms, and Number of Runs

Note: Setting the Random Seed in step 7 and Number of Starts in step 8 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

7. (Optional) Click the Custom Design red triangle, select Set Random Seed, type 12345, and click OK.

8. (Optional) Click the Custom Design red triangle, select Number of Starts, type 10, and click OK.

9. Click Make Design.
10. Open the **Design Evaluation > Alias Matrix** outline.

**Figure 5.10** Alias Matrix

![Alias Matrix](image)

All rows contain only zeros, which means that the Intercept and main effect terms are not biased by any two-factor interactions.

11. Open the **Design Evaluation > Color Map on Correlations** outline.

**Figure 5.11** Color Map on Correlations

![Color Map on Correlations](image)

The Color Map on Correlations shows that main effects can be estimated independently of two-way interactions. However, some two-way interactions are fully aliased with other two-way interactions. Hover over the off-diagonal red squares to see which two-way interactions are confounded.

It turns out that this particular design is a resolution IV orthogonal screening design. Main effects are not aliased with each other or with two-way interactions. But two-way interactions are fully aliased with other two-way interactions.
Supersaturated Screening Designs

It is common for brainstorming sessions to identify dozens of potentially active factors. Rather than reduce the list without the benefit of data, you can use a supersaturated design.

In a saturated design, the number of runs equals the number of model terms. In a supersaturated design, the number of model terms exceeds the number of runs (Lin, 1993). A supersaturated design can examine dozens of factors using fewer than half as many runs as factors. This makes it an attractive choice for factor screening when there are many factors and experimental runs are expensive.

Alternatively, use a group orthogonal supersaturated design for improved active effect identification over traditional supersaturated designs. See “Group Orthogonal Supersaturated Designs”.

Limitations of Supersaturated Designs

There are drawbacks to supersaturated designs:

- If the number of active factors is more than half the number of runs in the experiment, then it is likely that these factors will be impossible to identify. A general rule is that the number of runs should be at least four times larger than the number of active factors. In other words, if you expect that there might be as many as five active factors, you should plan on at least 20 runs.

- Analysis of supersaturated designs cannot yet be reduced to an automatic procedure. However, using forward stepwise regression is reasonable. In addition, the Screening platform (DOE > Classical > Two Level Screening > Fit Two Level Screening) offers a streamlined analysis.

Generate a Supersaturated Design

In this example, you want to construct a supersaturated design to study 12 factors in 8 runs. To create a supersaturated design, you set the Estimability of all model terms (except the intercept) to If Possible.

Note: This example is for illustration only. You should have at least 14 runs in any supersaturated design. If there are as many as four active factors, it is very difficult to interpret the results of an 8-run design. See “Limitations of Supersaturated Designs”.

1. Select DOE > Custom Design.
2. Type 12 next to Add N Factors.
3. Click Add Factor > Continuous.
4. Click Continue.
5. In the Model outline, select all terms except the Intercept.

6. Click Necessary next to any effect and change it to If Possible.

   Setting the effects to If Possible ensures that JMP uses the Bayesian D-optimality criterion to obtain the design.

**Figure 5.12** Factors, Model, and Number of Runs

7. In the Alias Terms outline, select all effects and click **Remove Term**.

   This ensures that only the main effects appear in the Color Map on Correlations. This plot is constructed once the design is created.
8. Click the Custom Design red triangle and select **Simulate Responses**.

   This option generates random responses that appear in your design table. You will use these responses to see how to analyze experimental data.

   Keep the Number of Runs set to the Default of 8.

   **Note:** Setting the Random Seed in step 9 and Number of Starts in step 10 reproduces the design shown in this example. In constructing a design on your own, these steps are not necessary. Your **Y Simulated** values may not be the same as those shown in Figure 5.13.

9. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 12345, and click **OK**.

10. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 5, and click **OK**.

11. Click **Make Design**.

12. Click **Make Table**.

   Do not close your Custom Design window. You return to it later in this example.

**Figure 5.13** Design Table with Simulated Responses

<p>| | | | | | | | | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1.02544456856</td>
<td>1.02544499</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-0.379735685</td>
<td>-0.379735</td>
</tr>
<tr>
<td>3</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0.9400641447</td>
<td>0.94006414</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-0.838928267</td>
<td>-0.8389285</td>
</tr>
<tr>
<td>5</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1.213695159</td>
<td>-1.2136952</td>
</tr>
<tr>
<td>6</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>0.0143439541</td>
<td>0.01434359</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>2.100004765</td>
<td>2.1000048</td>
</tr>
<tr>
<td>8</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>0.335011257</td>
<td>0.33501126</td>
</tr>
</tbody>
</table>

The response columns, **Y** and **Y Simulated**, are initiated with the same simulated values. The values are random values from a \( N(0, s) \) distribution. where \( s \) is the RMSE from the power analysis dialog with a default of 1. The **Y Simulated** values are updated with randomly generated values using the model defined by the parameter values in the Simulate Responses window. The **Y** column is intended for your true responses after the experiment has be run.
The Simulate Responses window shows default coefficients of 0 for all terms, a Normal distribution selection and Error $\sigma$ of 1. The values in the Y and Y Simulated column currently reflect only random variation.

13. Change the values of the coefficients in the Simulate Responses window as shown in Figure 5.15.
14. Click **Apply**.

The response values in the Y Simulated column change.

**Note:** The response values are randomly generated. Your values will not match those in Figure 5.16 exactly.

In your simulation, you specified X1 and X11 as active factors with large effects relative to the error variation. For this reason, your analysis of the data should identify these two factors as active.
Analyse a Supersaturated Design Using the Screening Platform

The Screening platform provides a way to identify active factors. Use the screening platform to analyze the Y Simulated values in the design table (Figure 5.16). The Screening platform is located under the DOE > Classical menu.

**Note:** Your data table has slightly different Y Simulated values than those in this example. The exact values in your reports will differ from the results shown here.

1. Select **DOE > Classical > Two Level Screening > Fit Two Level Screening**.
2. Select Y Simulated and click Y.
3. Select X1 through X12, click X and click OK.

**Figure 5.17** Screening Report for Supersaturated Design

The factors X1 and X11 have large contrast and Lenth t-Ratio values. Also, their Simultaneous p-Values are small. In the Half Normal Plot, both X1 and X11 fall far from the line. The Contrasts and the Half Normal Plot reports indicate that X1 and X11 are active. Although X12 has an Individual p-Value less than 0.05, its effect is much smaller than that of X1 and X11.

Because the design is supersaturated, *p*-values might be smaller than they would be in a model where all effects are estimable. This is because effect estimates are biased by other
potentially active main effects. In Figure 5.17, a note directly above the Make Model button warns you of this possibility.

You might also want to check whether the effects that appear active could be highly correlated with other effects. When this occurs, one effect can mask the true significance of another effect. The Color Map in Figure 5.19 displays absolute correlations between effects.

4. Click Make Model.

The constructed model contains only the effects $X_1$, $X_{11}$, and $X_{12}$.

5. Click Run in the Model Specification window.

Figure 5.18 Parameter Estimates for Model

| Term    | Estimate | Std Error | t Ratio | Prob > |t|
|---------|----------|-----------|---------|---------|
| Intercept| 100.12645| 0.319502  | 313.38  | <.0001* |
| $X_{11}$| 11.34777 | 0.360447  | 31.18   | <.0001* |
| $X_1$   | 9.8309384| 0.319502  | 30.74   | <.0001* |
| $X_{12}$| -1.1329  | 0.360447  | -3.14   | 0.0347* |

Note that the parameter estimates for $X_{11}$ and $X_1$ are close to the theoretical values that you used to simulate the model. See Figure 5.15, where you specified a model with $X_1 = 10$ and $X_{11} = 10$. The significance of the factor $X_{12}$ is an example of a false positive.

6. In your Custom Design window, open the Design Evaluation > Color Map on Correlations outline.

Figure 5.19 Color Map on Correlations Outline
Hover over cells to see the absolute correlations. Notice that X1 has correlations as high as 0.5 with other main effects (X4, X5, X7). (Figure 5.19 uses JMP default colors.)

**Analyze a Supersaturated Design Using Stepwise Regression**

Stepwise regression is another way to identify active factors. The design table in Figure 5.16 contains three scripts. The Model script analyzes your data using stepwise regression in the Fit Model platform.

**Note:** Your data table has slightly different Y Simulated values than those in this example. The exact values in your reports will differ from the results shown here.

1. In the Table panel of the design table, click the green triangle next to the **Model** script.
2. Change the **Personality** from **Standard Least Squares** to **Stepwise**.
3. Click **Run**.
4. In the Stepwise Fit for Y report, change the **Stopping Rule** to **Minimum AICc**.
   
   For designed experiments, BIC is typically a more lenient stopping rule than AICc as it tends to allow inactive effects into the model.
5. Click **Go**.
**Figure 5.20** Stepwise Regression for Supersaturated Design

Figure 5.20 shows that the selected model consists of the two active factors, $X_1$ and $X_{11}$. The step history appears in the bottom part of the report. Keep in mind that correlations between $X_1$ and $X_{11}$ and other factors could mask the effects of other active factors (Figure 5.19).

**Note:** This example defines two large main effects and sets the rest to zero. Real-world situations can be less likely to have such clearly differentiated effects.

**Design for Fixed Blocks**

Traditional screening designs require block sizes to be a power of two. However, the Custom Design platform can create designs with fixed blocks of any size.
Suppose that you want to study three factors. You can run only three trials per day and you expect substantial day-to-day variation. Consequently, you need to block your design over multiple days. Also, in this study, you are interested in estimating all two-factor interactions. In this example, you construct a design with three runs per block.

1. Select **DOE > Custom Design**.
2. In the Factors outline, type 3 next to **Add N Factors**.
3. Click **Add Factor > Continuous**.
4. Click **Add Factor > Blocking > 3 runs per block**.
   
The blocking factor X4 shows only one level under **Values**. This is because the run size is unknown at this point.

**Figure 5.21** Factors Outline Showing One Block for X4

5. Click **Continue**.
**Figure 5.22** Factors Outline Showing Three Blocks for X4

The Factors outline now shows an appropriate number of blocks, calculated as the Default run size divided by the number of runs per block. For this example, the default sample size of 9 requires three blocks. The Factors outline now shows that X4 has three values, indicating the three blocks.

**Note:** If you specify a different number of runs, the Factors outline updates to show the appropriate number of values for the blocking factor.

6. Select the three continuous factors, X1, X2, and X3, in the Factors outline.

7. In the Model outline, click **Interactions > 2nd**.
Figure 5.23  Factors Outline Showing Six Blocks for X4

The Number of Runs panel now shows that 18 is the Default run size. The Factors outline now shows six values for X4, indicating six blocks.

Note: Setting the Random Seed in step 8 and Number of Starts in step 9 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

8. (Optional) Click the Custom Design red triangle, select Set Random Seed, type 12345, and click OK.
9. (Optional) Click the Custom Design red triangle, select Number of Starts, type 5, and click OK.
10. Click Make Design.
In the design, look at the blocking factor, $X_4$. The six blocks are represented. When you conduct your experiment, each day you will run three trials, where $X_4 = 1$ on the first day, $X_4 = 2$ on the second day, and so on. So you want the design table to randomize the trials within blocks. In the Output Options panel, the Randomize within Blocks option is already selected for Run Order.

11. Click **Make Table**.

The rows in the design table are grouped by each day’s runs. This design enables you to estimate the block effect, all main effects, and two-factor interactions.
Response Surface Experiments

Response surface experiments typically involve a small number (generally 2 to 8) of continuous factors that have been identified as active. The main goal of a response surface experiment is to develop a predictive model of the relationship between the factors and the response. Often, you use the predictive model to find better operating settings for your process. For this reason, your assumed model for a response surface experiment is usually quadratic.

Because a screening design is focused on identifying active effects, a measure of its quality is the size of the relative variance of the coefficients. You want these relative variances to be small. D-optimality addresses these relative variances.

In response surface experiments, the prediction variance over the range of the factors is more important than the variance of the coefficients. The prediction variance over the design space is addressed by I-optimality. An I-optimal design tends to place fewer runs at the extremes of the design space than does a D-optimal design. For more information about D- and I-optimality, see “Optimality Criteria”.

By default, Custom Design uses the Recommended option for the Optimality Criterion. Custom Design uses the I-optimality criterion as the Recommended criterion whenever you add quadratic effects using the RSM button in the Model outline. Otherwise, Custom Design uses the D-optimality criterion as the Recommended criterion. See “Optimality Criteria”.

• “Response Surface Design”
• “Response Surface Design with Flexible Blocking”
• “Comparison of a D-Optimal and an I-Optimal Response Surface Design”
• “Response Surface Design With Constraints and Categorical Factor”

Response Surface Design

This example contains these sections:

• “Construct a Response Surface Design”
• “Analyze the Experimental Results”

Construct a Response Surface Design

Construct a response surface design for three continuous factors that you have identified as active. You want to find process settings to maintain your response(Y) within specifications. The lower and upper specification limits for Y are 54 and 56, respectively, with a target of 55.

1. Select DOE > Custom Design.
2. In the Responses outline, click **Maximize** and select **Match Target**.

3. Type 54 as the **Lower Limit** and 56 as the **Upper Limit**.

4. Leave **Importance** blank.
   Because there is only one response, the Importance value is set to 1 by default.

5. Type 3 next to **Add N Factors**.

6. Click **Add Factor > Continuous**.
   This adds three continuous factors: X1, X2, and X3.

7. Click **Continue**.

8. In the Model outline, click the **RSM** button.
   This adds quadratic and interaction terms to the model. It also sets the value of the Recommended optimality criterion to I-optimality. You can verify this in the Design Diagnostics outline once you click Make Design.

   Leave the Default Number of Runs set to 16.

   **Note:** Setting the Random Seed in step 9 and Number of Starts in step 10 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

9. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 929281409, and click **OK**.

10. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 40, and click **OK**.

11. Click **Make Design**.
   The Design outline shows the design.

**Figure 5.26** RSM Design
In order to estimate quadratic effects, a response surface design uses three levels for each factor. Note that the design in Figure 5.26 is a face-centered Central Composite Design with two center points.


**Figure 5.27** Design Diagnostics Outline

![Design Diagnostics Table](image)

<table>
<thead>
<tr>
<th>Design Diagnostics</th>
<th>I Optimal Design</th>
<th>Efficiency</th>
<th>G Efficiency</th>
<th>A Efficiency</th>
<th>Average Variance of Prediction</th>
<th>Design Creation Time (seconds)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>42.99905</td>
<td>88.62743</td>
<td>30.68124</td>
<td>0.340517</td>
<td>0.033333</td>
</tr>
</tbody>
</table>

The first line in the Design Diagnostics outline identifies the optimality criterion being used. This design is I-optimal.


**Figure 5.28** Prediction Variance Profile

![Prediction Variance Profile Graph](image)

The vertical axis shows the relative prediction variance of the expected value of the response. The relative prediction variance is the prediction variance divided by the error variance. When the relative prediction variance is one, its absolute variance equals the error variance of the regression model.

The profiler shows values of the relative prediction variance over the design space. You can move the sliders to explore the prediction variance’s behavior. The prediction variance is smallest in the center of the design space. It is fairly constant, with values only slightly larger than 0.2, for factor settings between -0.5 and 0.5. The prediction variance increases as the settings approach the design space boundaries.

14. Click the Prediction Variance Profile red triangle and select Maximize Variance.
Figure 5.29 Prediction Variance Profile with Relative Variance Maximized

The profiler shows that the maximum value of the relative prediction variance is 0.79569.

15. Open the **Design Evaluation > Fraction of Design Space Plot** outline.

Figure 5.30 Fraction of Design Space Plot

The blue curve in the plot shows the relative prediction variance as a function of the fraction of design space. The red dashed cross hairs indicate that, for 50% of the design space, the prediction variance is about 0.32 or less. Use the cross hair tool to draw other inferences. For example, when the Fraction of Space is 0.95, the Prediction Variance is about 0.52. This means that for 95% of the design space, the relative prediction variance is below 0.52.

**Analyze the Experimental Results**

The Custom RSM.jmp sample data table contains the results of the experiment. The Model script opens a Fit Model window showing all of the effects specified in the DOE window’s Model outline. This script was saved to the data table by the Custom Design platform.

1. Select **Help > Sample Data Library** and open Design Experiment/Custom RSM.jmp.
2. In the Table panel, click the green triangle next to the **Model** script.
3. Click **Run**.
The Effect Summary report shows the LogWorth and PValue for each effect in the model. The vertical blue line in the plot is set at the value 2. A LogWorth that exceeds 2 is significant at the 0.01 level.

**Figure 5.31** Effect Summary Report

The report shows that $X_1$, $X_2$, $X_1^\times X_1$, and $X_2^\times X_2$ are significant at the 0.01 level. None of the other effects are significant at even the 0.10 level. Reduce the model by removing these insignificant effects.

4. In the Effect Summary report, select $X_3$, $X_1^\times X_2$, $X_3^\times X_3$, $X_1^\times X_3$, and $X_2^\times X_3$.

**Figure 5.32** Effect Summary Report with Insignificant Effects Selected

5. Click **Remove**.

The Fit Least Squares report is updated to show a model containing only the significant effects: $X_1$, $X_2$, $X_1^\times X_1$, and $X_2^\times X_2$.

Use the Prediction Profiler (at the bottom of the Fit Least Squares window) to explore how the predicted response ($Y$) changes as you vary the factors $X_1$ and $X_2$. Note the quadratic behavior of $Y$ across the values of $X_1$ and $X_2$.

Remember that you entered response limits for $Y$ in the Responses outline of the Custom Design window. As a result, the Response Limit column property is attached to the $Y$ column in the design table. The Desirability function for $Y$ (in the top plot at right) is based on the information contained in the Response Limit column property. JMP uses this
function to calculate Desirability as a function of the settings of $X_1$ and $X_2$. The traces of the Desirability function appear in the bottom row of plots.

6. Click the Prediction Profiler red triangle and select **Optimization and Desirability > Maximize Desirability**.

**Figure 5.33** Prediction Profiler with Desirability Maximized

The predicted response achieves the target value of 55 at the process settings shown in red above $X_1$ and $X_2$. **Figure 5.33** shows that a value of $X_1$ near $-0.65$ also achieves a predicted value of 55 when $X_2 = -0.75062$. In fact, your Prediction Profiler might show different settings as those that maximize desirability. This is because the predicted response is 55 for many settings of $X_1$ and $X_2$.

7. Click the Response Y red triangle and select **Factor Profiling > Contour Profiler**.

8. In the Contour Profiler report, type 55 as the value for **Contour**.
The settings of $X_1$ and $X_2$ that correspond to the red contour have predicted response values of 55. You might want to select from among these process settings based on cost efficiency.

### Response Surface Design with Flexible Blocking

When optimizing a process, you might need to include qualitative factors in your experiment as well as continuous factors. You might need to block by qualitative factors such as batch or day, or include qualitative factors such as machine or delivery mechanism. But the Response Surface Design platform supports only continuous factors. To obtain a response surface design with a qualitative factor, you can replicate the design over each level of the factor. However, this is inefficient. The Custom Design platform constructs an optimal design with fewer runs.

In this example, you construct a response surface design that accommodates two continuous factors and a blocking factor with four runs per block. You can include categorical or discrete numeric factors in a similar fashion.

1. Select **DOE > Custom Design**.
2. Type 2 next to **Add N Factors**.
3. Click **Add Factor > Continuous**.
4. Click **Add Factor > Blocking > 4 runs per block**.

   Notice that only one level appears under Values. This is because the number of blocks cannot be determined until the number of runs is determined.

**Figure 5.35** Factors Outline with Two Continuous Factors and a Blocking Factor

<table>
<thead>
<tr>
<th>Factors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>---------</td>
</tr>
<tr>
<td>X1</td>
</tr>
<tr>
<td>X2</td>
</tr>
<tr>
<td>X3</td>
</tr>
</tbody>
</table>

5. Click **Continue**.

   The Default number of runs is 12. The Factors outline updates to show three levels for the Blocking factor, X3. Because you required X3 to have four runs per block, the 12 runs allow three blocks.

6. Click **RSM**.

   An informational JMP Alert window reminds you that the blocking factor cannot appear in interaction or quadratic terms. JMP adds only the appropriate RSM terms to the list.

7. Click **OK** to dismiss the message.

   Quadratic and interactions terms for X1 and X2 are added to the model. Because you added RSM terms, the Recommended optimality criterion changes from D-Optimal to I-Optimal. You can see this later in the Design Diagnostics outline.

**Figure 5.36** Model Outline with Response Surface Effects

<table>
<thead>
<tr>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>-------</td>
</tr>
<tr>
<td>Intercept</td>
</tr>
<tr>
<td>X1</td>
</tr>
<tr>
<td>X2</td>
</tr>
<tr>
<td>X3</td>
</tr>
<tr>
<td>X1*X1</td>
</tr>
<tr>
<td>X1*X2</td>
</tr>
<tr>
<td>X2*X2</td>
</tr>
</tbody>
</table>

**Note:** Setting the Random Seed in step 8 and Number of Starts in step 9 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

8. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 12345, and click **OK**.
9. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 5, and click **OK**.

10. Click **Make Design**.

11. Open the **Design Evaluation > Design Diagnostics** outline.

**Figure 5.37** Design Diagnostics Outline

The first line in the Design Diagnostics outline identifies the optimality criterion being used. This design is I-optimal.

12. Click **Make Table**.

**Figure 5.38** Design Table with Blocking Factor

Because the default Run Order was Randomize within Blocks, the levels of the blocking factor (X3) are sorted.

13. In the Table panel of the design table, click the green triangle next to the **Model** script.
Notice the following:

- The blocking factor \( X_3 \) is entered as an effect.
- No interactions involving \( X_3 \) are included.
- The other five effects define a response surface model for \( X_1 \) and \( X_2 \).

**Comparison of a D-Optimal and an I-Optimal Response Surface Design**

In this example, you explore the differences between I-optimality and D-optimality in the context of a two-factor response surface design.

**I-Optimal Design**

1. Select **DOE > Custom Design**.
2. Type 2 next to **Add N Factors**.
3. Click **Add Factor > Continuous**.
4. Click **Continue**.
5. Click **RSM**.

Quadratic and interactions terms for \( X_1 \) and \( X_2 \) are added to the model. Because you added RSM terms, the Recommended optimality criterion changes from D-Optimal to I-Optimal. You can see this later in the Design Diagnostics outline.
Note: Setting the Random Seed in step 6 and Number of Starts in step 7 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

6. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 383570403, and click **OK**.

7. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 8, and click **OK**.

8. Click **Make Design**.

**Figure 5.40** I-Optimal Design

<table>
<thead>
<tr>
<th>Run</th>
<th>X1</th>
<th>X2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>-1</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>8</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>10</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>11</td>
<td>0</td>
<td>-1</td>
</tr>
<tr>
<td>12</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

In this I-optimal design, runs 1, 4, 7, and 10 are at the center point \((X1 = 0 \text{ and } X2 = 0)\). I-optimal designs tend to place more runs in the center (and consequently fewer runs at the extremes) of the design space than do D-optimal designs. You can compare this design to the D-optimal design shown in **Figure 5.42**.

9. Open the **Design Evaluation > Prediction Variance Profile** outline.

**Figure 5.41** Prediction Variance Profile for I-Optimal Model

The relative prediction variance of the expected response is smallest in the center of the design space.

10. Open the **Fraction of Design Space Plot** outline.
The Fraction of Design Space Plot appears on the left in Figure 5.44. When the Fraction of Space is 0.95, the vertical coordinate of the blue curve is about 0.5. This means that for about 95% of the design space, the relative prediction variance is below 50% of the error variance.

This Custom Design window contains your I-optimal design. Keep this window open. In the next section, you generate a D-optimal design, and compare the two.

**D-Optimal Design**

To compare Prediction Variance Profile and Fraction of Design Space plots for the I- and D-optimal designs:

1. In the Custom Design window containing your I-optimal design, click the Custom Design red triangle and select **Save Script to Script Window**.
   A window appears, showing a script that reproduces your work.

2. In this new script window, select **Edit > Run Script**.
   A duplicate Custom Design window appears, but with the Design Evaluation outlines closed.

3. In this new Custom Design window, click **Back**.

4. Click the Custom Design red triangle and select **Optimality Criterion > Make D-Optimal Design**.

5. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 383570403, and click **OK**.

6. Click **Make Design**.
   You current Custom Design window contains your D-optimal design.

**Figure 5.42** D-Optimal Design

In this D-optimal design, run 1 is the only run at the center point. D-optimal designs tend to place more runs at the extremes of the design space than do I-optimal designs. Recall that the I-optimal design had four center runs (Figure 5.40).

7. Open the **Design Evaluation > Prediction Variance Profile** outline.
Chapter 5
Examples of Custom Designs

Design of Experiments Guide
Response Surface Experiments

Figure 5.43 Prediction Variance Profile for D-Optimal Model

At the center of the design region, the relative prediction variance is 0.53562, as compared to 0.208333 for the I-optimal design (Figure 5.41). This means that the relative standard error is 0.732 for the D-optimal design and 0.456 for the I-optimal design. All else being equal, at the center of the design region, confidence intervals for the expected response based on the D-optimal design are about 60% wider than those based on the I-optimal design.

The Design outline shows that the D-optimal design has nine design points, one for every combination of $X_1$ and $X_2$ set to -1, 0, 1. The D-optimality criterion attempts to keep the relative prediction variance low at each of these design points. Explore the variance at the extremes of the design region by moving the sliders for $X_1$ and $X_2$ to -1 and 1. Note that the variance at these extreme points is usually smaller than the variance for the I-optimal design at these points.

8. Open the Design Evaluation > Fraction of Design Space Plot outline.

The Fraction of Design Space Plot appears on the right in Figure 5.44.

Figure 5.44 Fraction of Design Space Plots (I-Optimal on left, D-Optimal on right)
The red cross-hairs in each plot indicate the maximum prediction variance for 50% of the design space. For 50% of the design space, the prediction variance for the I-optimal design falls below about 0.27. For the D-optimal design, the prediction variance is about 0.4.

9. Right-click in the Fraction of Design Space Plot for your I-optimal design. Select **Edit > Copy Frame Contents**.

10. Right-click in the Fraction of Design Space Plot for your D-optimal design. Select **Edit > Paste Frame Contents**.

**Figure 5.45** Fraction of Design Space Plots Superimposed

The variance curve for the I-optimal design is below the curve for the D-optimal design over at least 90% of the design space. This reflects the fact that I-optimality attempts to minimize prediction variance over all of the design space. In contrast, D-optimality focuses on reducing prediction variance at the design points.

**Response Surface Design With Constraints and Categorical Factor**

In this example, you create a design to optimize the yield of a chemical reaction. Your experimental factors include a categorical factor at three levels, where constraints involve two of the levels. In this example, you will use the Disallowed Combinations Filter to enter the constraints.

Your response is **Yield**. You have three factors:

- **Time**: The range of interest is 500 to 560 seconds.
- **Temperature**: The range of interest is 350 to 750 degrees Kelvin.
- **Catalyst**: Three catalysts A, B, and C, must be tested.

Your design must allow for constraints on two of the levels of **Catalyst**:

- When catalyst B is used, the temperature must be above 400.
• When catalyst C is used, the temperature must be below 650.

Define the Response and Factors

1. Select DOE > Custom Design.
2. In the Response outline, double-click Y and change it to Yield. Because your goal is to maximize Yield, leave the Goal set to Maximize.
3. In the Factors outline, type 2 next to Add N Factors.
4. Click Add Factor > Continuous.
5. Click Add Factor > Categorical > 3 Level.
6. Rename the factors Time, Temperature, and Catalyst.
7. Change the Values for Time to 500 and 560.
8. Change the Values for Temperature to 350 and 750.
9. Change the Values for Catalyst to A, B, and C.

Figure 5.46  Factor Settings

10. Click Continue.

Define the Constraints

1. Select Use Disallowed Combinations Filter in the Define Factor Constraints outline.
2. Select Temperature and Catalyst from the Add Filter Factors list.
3. Click Add.
4. Click 750 in the equation that appears above the Temperature slider and change it to 400. Press Enter (or click elsewhere). This disallows factor settings with Temperature values below 400.
5. Click the B block under Catalyst. Together with the constraint on Temperature, this disallows factor settings for which Catalyst is B and Temperature is below 400.
6. Click OR. This allows you to define your second constraint.
7. Select Temperature and Catalyst from the Add Filter Factors list. (Your earlier selection may have been retained.)

8. Click Add.

9. In the panel that appears beneath the word OR, click 350 in the equation that appears above the Temperature slider and change it to 650. Press Enter (or click elsewhere). This disallows factor settings with Temperature values above 650.

10. Click the C block under Catalyst. Together with the constraint on Temperature, this disallows factor settings for which Catalyst is C and Temperature is above 650.

Figure 5.47 Constraints Defined

Note: The (3) after Catalyst indicates the number of catalyst levels.

Add Response Surface Terms and Make Design

1. In the Model outline, select RSM. A JMP Alert informs you that only quadratic terms for continuous factors are being added to the model.

2. Click OK to dismiss the alert. JMP adds only the appropriate response surface terms to the model.
**Note:** Setting the Random Seed in step 3 and Number of Starts in step 4 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

3. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 654321, and click **OK**.

4. (Optional) Click the Custom Design red triangle, select **Number of Starts** and set it to 1000. Click **OK**.

5. Click **Make Design**.

**Figure 5.48** Design Satisfying Constraints

Because you added RSM terms to the Model outline, this is an I-optimal design. It satisfies your constraints:

- When catalyst B is used, the temperature must be above 400.
- When catalyst C is used, the temperature must be below 650.

**View the Design**

Recall that the design region consists of settings of Time between 500 and 560 and Temperature between 350 and 750. Generate a graph to obtain a geometric view of the design points within the design region:

1. Click **Make Table**.

2. Select **Graph > Graph Builder**.

3. Select Time and Temperature and drag them to the center of the template.

4. Deselect the **Smoother** icon. This is the second icon from the left above the template.

5. Select Catalyst and drag it to the **Group X** zone at the top of the template.
6. Double-click the Temperature axis.

7. Under Reference Lines, add two reference lines:
   - Next to Value, enter 350.
   - Click Add.
   - Next to Value, enter 750.
   - Click Add.

8. Click OK.
9. Double-click the Time axis.

10. Under Reference Lines, add two reference lines:
    - Next to Value, enter 500.
    - Click Add.
    - Next to Value, enter 560.
    - Click Add.

11. Click OK.

12. Click Done.

**Note:** The plot in Figure 5.51 is vertically resized.
Six of the settings for Catalyst A fall on the edges of the design region. All Temperature setting for Catalyst B are above the 400 degree constraint and all Temperature settings for Catalyst C are below the 650 degree constraint.

Mixture Experiments

Both the Custom Design and Mixture Design platforms construct designs for situations where all of your factors are ingredients in a mixture. However, mixture experiments can involve non-mixture process variables, or process factors. In addition to mixture only designs, the Custom Design platform can construct designs to accommodate both mixture and process factors. The Custom Design platform also allows the mixture components to sum to any positive number. See the Mixture description in “Factor Types”.

- “Mixture Design with Nonmixture Factors”
- “Mixture of Mixtures Design”

Mixture Design with Nonmixture Factors

In this example from Atkinson and Donev (1992), you create a design for an experiment involving both mixture factors and process factors. The design is an 18-run design that is balanced with respect to the levels of a categorical factor. The design enables you to fit a full response surface. You use Design Evaluation plots and results to examine the relative prediction variance of the design.

The design consists of a single response, three mixture factors, and a non-mixture factor:

- The response is Damping, which measures the electromagnetic damping of an acrylonitrile powder.
• The three mixture ingredients are:
  – CuSO4 (copper sulphate), ranging from 0.2 to 0.8
  – Na2S2O3 (sodium thiosulphate), ranging from 0.2 to 0.8
  – Glyoxal (glyoxal), ranging from 0 to 0.6

• The nonmixture environmental factor of interest is Wavelength (the wavelength of an
  electromagnetic wave) at three levels denoted L1, L2, and L3.

  Wavelength is a continuous variable. However, the researchers were interested only in
  predictions at three specific wavelengths. For this reason, you treat Wavelength as a
  categorical factor with three levels.

There are two parts to this example:

• “Create the Design”
• “Evaluate the Design”

Create the Design

1. Select DOE > Custom Design.
2. Double-click Y under Response Name and type Damping.
3. Click Maximize under Goal and change it to None.

  The goal is set to None because the authors of the study do not mention how much
  damping is desirable.Select Help > Sample Data Library and open Design
  Experiment/Donev Mixture Factors.jmp.

4. Click the Custom Design red triangle and select Load Factors.

  This loads the three mixture ingredients and the categorical environmental factor. Note
  that the bounds on the values of the three mixture factors are also loaded.

Figure 5.52 Responses Outline and Factors Outline

5. In the Model outline, click Interactions > 2nd.
An informational JMP Alert window reminds you that JMP removes the main effect terms for non-mixture factors that interact with all the mixture factors. This means that the main effect of Wavelength is removed, but all two-way interactions of mixture factors with Wavelength are added.

6. Click OK to dismiss the message.

The effects in the Model outline define a response surface model in the mixture ingredients along with the additive effect of the wavelength. See Scheffé (1958).

Figure 5.53 Model and Design Generation Outlines

7. Leave the default number of runs at 18.

The choice of 18 runs allows six runs for each of the three levels of the wavelength factor.

Note: Setting the Random Seed in step 8 and Number of Starts in step 9 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

8. (Optional) Click the Custom Design red triangle, select Set Random Seed, type 12345, and click OK.

9. (Optional) Click the Custom Design red triangle, select Number of Starts, type 5, and click OK.

10. Click Make Design.
You can check that there are six runs for each level of Wavelength.

**Evaluate the Design**

1. Open the Design Evaluation > Prediction Variance Profile outline.

**Figure 5.55** Prediction Variance Profile for 18-Run Design

Move the slider for Wavelength to verify that the relative prediction variance profiles for the mixture factors do not change across the levels of Wavelength. Move the slider for any one of the mixture factors. The sliders for the other two mixture factors adjust to make the mixture ingredients sum to one. Notice that the smallest relative prediction variances occur near the center settings for the mixture factors.

2. Click the Prediction Variance Profile red triangle and select Maximize Variance.

Notice that the maximum relative prediction variance over the design space is 0.8 times the error variance.

3. Open the Fraction of Design Space Plot outline.
Over the entire design space, the relative prediction variance is below 0.8. The minimum relative prediction variance is about 0.32. As seen in Figure 5.55, the minimum occurs near the center settings for the mixture factors.

4. Open the **Design Diagnostics** outline.

The design is optimal relative to the D-optimality criterion, even though its D-efficiency is very low (3.6%). Because mixture designs are far from orthogonal due to the mixture constraint, they typically have very low D-efficiencies. The Average (relative) Variance of Prediction is 0.412864. This is consistent with the Fraction of Design Space plot in Figure 5.56.

**Mixture of Mixtures Design**

In this example, construct a design for a mixture of mixtures situation.

Consider the ingredients that go into a cake. Dry ingredients include flour, sugar, and cocoa. Wet ingredients include milk, melted butter, and eggs. The wet and dry components of the cake are two mixtures that are first mixed separately and then blended together. **Table 5.1** lists the factors and the ranges over which you vary them as part of your experiment.
The dry components (the mixture of cocoa, sugar, and flour) comprise 45% of the combined mixture. The wet components (butter, milk, and eggs) comprise 55%.

Table 5.1 Dry and Wet Components and Experimental Ranges

<table>
<thead>
<tr>
<th>Mixture</th>
<th>Ingredient</th>
<th>Lower and Upper Levels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dry</td>
<td>Cocoa</td>
<td>0.1 - 0.2</td>
</tr>
<tr>
<td></td>
<td>Sugar</td>
<td>0 - 0.15</td>
</tr>
<tr>
<td></td>
<td>Flour</td>
<td>0.2 - 0.3</td>
</tr>
<tr>
<td>Wet</td>
<td>Butter</td>
<td>0.1 - 0.2</td>
</tr>
<tr>
<td></td>
<td>Milk</td>
<td>0.25 - 0.35</td>
</tr>
<tr>
<td></td>
<td>Eggs</td>
<td>0.05 - 0.20</td>
</tr>
</tbody>
</table>

The dry components (the mixture of cocoa, sugar, and flour) comprise 45% of the combined mixture. The wet components (butter, milk, and eggs) comprise 55%.

**Note:** With the constraints on the dry and wet ingredients, if you include all 6 factors in the mixture model, a model singularity exists.

The goal of your experiment is to optimize a Taste rating. Taste is rated on a scale of 1 to 10, with 10 representing the best taste.

You construct a 10-run design to fit a main effects model. Because of the constraint on the proportions of dry and wet ingredients, you need to include only five factors in the Model outline to avoid singularity. The choice of which factor not to include is arbitrary.

This example contains two parts:

- “Create the Design”
- “Analyze the Experimental Results”

**Create the Design**

1. Select **DOE > Custom Design**.
2. Double-click **Y** under Response Name and type **Taste**.
   
   Note that the default goal is Maximize. Because you want to maximize the Taste rating, do not change the goal.
3. Click under Lower Limit and type 0.
   
   The least desirable rating is 0.
4. Click under Upper Limit and type 10.
The most desirable rating is 10.

5. Leave the area under Importance blank.

Because there is only one response, that response is given Importance 1 by default.

6. Select Help > Sample Data Library and open Design Experiment/Cake Factors.jmp.

7. Click the Custom Design red triangle and select Load Factors.

**Figure 5.58 Completed Responses and Factors Outlines**

<table>
<thead>
<tr>
<th>Responses</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Taste</td>
<td>Maximize</td>
<td>10</td>
<td>10</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

Note that the factors are all mixture factors. The Values that define the range of settings for the experiment vary from factor to factor.

8. In the Define Factor Constraints outline, select Specify Linear Constraints.

9. In the Linear Constraints panel, click Add twice.

10. Enter the constraints shown in **Figure 5.59**.

**Figure 5.59 Define Factor Constraints**

Note that the second constraint is equivalent to specifying that the sum of Cocoa, Sugar, and Flour is greater than or equal to 0.45. The two constraints together imply that Cocoa, Sugar, and Flour comprise exactly 45% of the mixture, ensuring that the wet factors constitute the remaining 55%.
11. In the Model outline, select Eggs and click **Remove Term**.
   Because of the equality constraint, a model containing all six effects would be singular.

12. Type 10 next to **User Specified**.
   Your experiment requires baking 10 cakes.

   **Note:** Setting the Random Seed in step 13 and Number of Starts in step 14 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

13. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 12345, and click **OK**.

14. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 40, and click **OK**.

15. Click **Make Design**.
   A JMP Alert informs you that your factor constraints include an equality constraint. This was what you intended, because the sum of the dry ingredient proportions is constrained to 45%.

16. Click **OK** to dismiss the JMP Alert.

17. Click **Make Table**.

**Figure 5.60** Mixture of Mixtures Design

<table>
<thead>
<tr>
<th></th>
<th>Cocoa</th>
<th>Sugar</th>
<th>Flour</th>
<th>Butter</th>
<th>Milk</th>
<th>Eggs</th>
<th>Taste</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.1</td>
<td>0.15</td>
<td>0.2</td>
<td>0.2</td>
<td>0.3</td>
<td>0.05</td>
<td>•</td>
</tr>
<tr>
<td>2</td>
<td>0.1</td>
<td>0.15</td>
<td>0.2</td>
<td>0.1</td>
<td>0.35</td>
<td>0.1</td>
<td>•</td>
</tr>
<tr>
<td>3</td>
<td>0.1</td>
<td>0.15</td>
<td>0.2</td>
<td>0.1</td>
<td>0.25</td>
<td>0.2</td>
<td>•</td>
</tr>
<tr>
<td>4</td>
<td>0.1</td>
<td>0.05</td>
<td>0.3</td>
<td>0.2</td>
<td>0.25</td>
<td>0.1</td>
<td>•</td>
</tr>
<tr>
<td>5</td>
<td>0.15</td>
<td>0</td>
<td>0.3</td>
<td>0.35</td>
<td>0.25</td>
<td>0.1</td>
<td>•</td>
</tr>
<tr>
<td>6</td>
<td>0.1</td>
<td>0.05</td>
<td>0.3</td>
<td>0.15</td>
<td>0.35</td>
<td>0.05</td>
<td>•</td>
</tr>
<tr>
<td>7</td>
<td>0.2</td>
<td>0.05</td>
<td>0.2</td>
<td>0.1</td>
<td>0.25</td>
<td>0.2</td>
<td>•</td>
</tr>
<tr>
<td>8</td>
<td>0.2</td>
<td>0</td>
<td>0.25</td>
<td>0.2</td>
<td>0.25</td>
<td>0.1</td>
<td>•</td>
</tr>
<tr>
<td>9</td>
<td>0.1</td>
<td>0.05</td>
<td>0.3</td>
<td>0.1</td>
<td>0.25</td>
<td>0.2</td>
<td>•</td>
</tr>
<tr>
<td>10</td>
<td>0.2</td>
<td>0.05</td>
<td>0.15</td>
<td>0.35</td>
<td>0.05</td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>

The settings for the dry ingredients, Cocoa, Sugar, and Flour, sum to 45% of the mixture and the settings for the wet ingredients, Butter, Milk, and Eggs, sum to 55% of the mixture. The settings also conform to the upper and lower limits given in the Factors outline.
Analyze the Experimental Results

The Cake Data.jmp sample data table shows the results of the experiment. The design table contains a Model script that opens a Fit Model window showing the five main effects specified in the DOE window’s Model outline. Notice that the main effect of Eggs is not included in the Model outline for this design. The level of Eggs can be determined by the settings of the other 5 factors and the constraint on the dry ingredients. This script was saved to the data table when it was created by Custom Design.

1. Open the Cake Data.jmp sample data table, located in the Design Experiment folder.
2. In the Table panel of the design table, click the green triangle next to the Model script.
   The main effect due to Eggs is not included. To avoid model singularities, the Eggs effect was excluded from the Model outline in the Custom Design window. The five effects are designated as Response Surface and Mixture effects.
3. Click Run.
   A JMP Alert appears, notifying you that the Profiler cannot be shown because of the mixture of mixtures constraint on the subsets of factors.
4. Click OK to dismiss the JMP Alert.

The Parameter Estimates report indicates that Sugar and Flour are significant at the 0.05 level.

Figure 5.61 Parameter Estimates Report
Experiments with Covariates

Sometimes measurements on the experimental units that are intended for an experiment are available. These measurements might affect the experimental response. It is useful to include these variables, called covariates, as design factors. Although you cannot directly control these values, you can ensure that the levels of the other design factors are chosen to yield the most precise estimates of all the effects.

The Custom Design platform constructs a design that selects covariate values in an optimal fashion. Covariate values are selected from an existing data table that provides covariate information about the potential experimental units. You can specify a number of runs that is smaller than the number of experimental units listed in your data table. You can also specify covariates that are hard-to-change. When you make your design and the design has fewer runs than the number of rows in the covariate table, the design table includes a Covariate Row Index column. This column indicates the row from the covariate table that corresponds to each experimental run.

**Note:** The number of rows in the covariate data table where covariate factors have nonmissing values must be greater than or equal to the specified Number of Runs.

- “Design with Fixed Covariates”
- “Design with Hard-to-Change Covariates”
- “Design with a Linear Time Trend”

Design with Fixed Covariates

In this example, you are interested in modeling the Shrinkage of parts produced by an injection molding process. The Thermoplastic.jmp sample data table in the Design Experiment folder lists 25 batches of raw (thermoplastic) material for potential use in your study. For each batch, material was removed to obtain measurements of Specific Gravity and Tensile Strength. A third covariate, Supplier, is also available.

You want to study the effects of three controllable factors, Temperature (mold temperature), Speed (screw speed), and Time (hold time), on Shrinkage. But you also want to study the effects of the covariates: Specific Gravity, Tensile Strength, and Supplier. Your resources allow for 12 runs.

Create the Design

1. Select Help > Sample Data Library and open Design Experiment/Thermoplastic.jmp.
2. Select DOE > Custom Design.
3. Double-click Y under Response Name and type Shrinkage.
4. Click **Maximize** under Goal and change it to **Minimize**.

5. Click **Add Factor** and select **Covariate**.

6. Select Specific Gravity, Tensile Strength, and Supplier from the list and click **OK**.
   These are covariates and cannot be controlled.

7. Type 3 next to **Add N Factors**.

8. Click **Add Factor > Continuous**.

9. Rename the three continuous factors Temperature, Speed, and Time.
   These are factors that can be controlled.

**Figure 5.62** Responses and Factors Outlines

10. Click **Continue**.

    The Number of Runs shows the number of rows with covariate values available. You have 25 batches with measured covariates.

11. Type 12 next to **Number of Runs**.

    **Note:** Setting the Random Seed in step 12 and Number of Starts in step 13 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

12. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 84951, and click **OK**.

13. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 40, and click **OK**.

14. Click **Make Design**.
Figure 5.63  Twelve-Run Optimal Design

<table>
<thead>
<tr>
<th>Run</th>
<th>Specific Gravity</th>
<th>Tensile Strength</th>
<th>Supplier</th>
<th>Temperature</th>
<th>Speed</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1.107</td>
<td>8.07</td>
<td>B</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>1.144</td>
<td>6.82</td>
<td>B</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>3</td>
<td>1.004</td>
<td>6.52</td>
<td>C</td>
<td>1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>4</td>
<td>1.015</td>
<td>7.46</td>
<td>A</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>5</td>
<td>1.129</td>
<td>6.97</td>
<td>A</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>6</td>
<td>1.139</td>
<td>6.94</td>
<td>C</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>7</td>
<td>1.004</td>
<td>7.12</td>
<td>C</td>
<td>1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>1.067</td>
<td>6.7</td>
<td>B</td>
<td>-1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>1.047</td>
<td>6.42</td>
<td>A</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>10</td>
<td>1.033</td>
<td>7.34</td>
<td>B</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>11</td>
<td>1.094</td>
<td>6.48</td>
<td>A</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>12</td>
<td>1.113</td>
<td>6.89</td>
<td>C</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
</tr>
</tbody>
</table>

This design is D-optimal, given the potential covariate values. It selects the best sets of covariate values and the best settings for the three controllable factors.

Evaluate the Design

The seven terms corresponding to main effects appear in the upper left corner of the color map. Notice that these seven terms are close to orthogonal. The largest absolute correlation is between Tensile Strength and Supplier 2. This absolute correlation of about 0.43 is a consequence of the available covariate values. (Figure 5.64 uses JMP default colors.)

Design with Hard-to-Change Covariates

In this example, you construct a design for developing a running shoe for serious runners that has good wear (Wear) properties. Your experiment includes four factors:

- sole thickness (Thickness)
- amount of gel cushioning (Gel)
- outsole material (Outsole)
- midsole material (Midsole)
To obtain generalizable conclusions, you need to test your shoes on a broad base of serious runners. To accommodate your experimental budget, each runner must test several experimental combinations.

Your company has collected data on 100 suitable runners willing to participate in your study. The concomitant variables (covariates) measured on these runners are average daily miles run (Miles), weight (Weight), and the foot’s strike point (Strike Point).

Create your design:

1. Select Help > Sample Data Library and open Design Experiment/Runners Covariates.jmp.
2. Select DOE > Custom Design.
3. Double-click Y under Response Name and type Wear.
4. Click Maximize under Goal and change it to Minimize.
5. Click Add Factor and select Covariate.
6. Select Miles, Weight, and Strike Point from the list and click OK.
   These are the hard-to-change covariates associated with the runners.
7. For one of the factors Miles, Weight, and Strike Point, under Changes, click Easy and change it to Hard.
   Note that Changes for all three covariates change to Hard.

To add the remaining factors manually, follow step 8 through step 16. Or, to load factors from a saved table, select Load Factors from the Custom Design red triangle. Open the Runners Factors.jmp sample data table, located in the Design Experiment folder. If you select Load Factors, skip step 8 through step 16.

8. Type 2 next to Add N Factors.
9. Click Add Factor > Continuous.
10. Rename the two factors Thickness and Gel.
11. Change the Values for Thickness to 5 and 20.
12. Change the Values for Gel to 1 and 10.
13. Type 2 next to Add N Factors.
14. Click Add Factor > Categorical > 3 Level.
15. Rename the two factors Outsole and Midsole.
   Keep the default Values for these factors.
16. Click **Continue**.

17. Select **Interactions > 2nd**.

   The specified model fits all two-factor interactions, including covariate by experimental factor interactions.

18. Set the Number of Whole Plots, or runners, to 32 (if it is not already set to that number).

19. Type 64 next to User Specified under Number of Runs (if it is not already set to that number).

   **Note:** Setting the Random Seed in step 20 and Number of Starts in step 21 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

20. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 12345, and click **OK**.

21. (Optional) Click the Custom Design red triangle, select **Number of Starts** and set it to 1 (if it is not already set to that number). Click **OK**.

22. Click **Make Design**.
Chapter 5  
Examples of Custom Designs

Design of Experiments Guide  
Experiments with Covariates

Figure 5.66 First 20 Runs of Design for Hard-to-Change Covariates

<table>
<thead>
<tr>
<th>Run</th>
<th>Whole Plots</th>
<th>Miles</th>
<th>Weight</th>
<th>Strike Point</th>
<th>Thickness</th>
<th>Gel</th>
<th>Outsole</th>
<th>Midsole</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>7.6</td>
<td>144</td>
<td>Midfoot</td>
<td>5</td>
<td>10</td>
<td>L3</td>
<td>L2</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>7.6</td>
<td>144</td>
<td>Midfoot</td>
<td>20</td>
<td>1</td>
<td>L2</td>
<td>L1</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>7.6</td>
<td>145</td>
<td>Midfoot</td>
<td>20</td>
<td>10</td>
<td>L3</td>
<td>L3</td>
</tr>
<tr>
<td>4</td>
<td>2</td>
<td>7.6</td>
<td>145</td>
<td>Midfoot</td>
<td>5</td>
<td>1</td>
<td>L1</td>
<td>L1</td>
</tr>
<tr>
<td>5</td>
<td>3</td>
<td>14.8</td>
<td>141</td>
<td>Midfoot</td>
<td>20</td>
<td>1</td>
<td>L1</td>
<td>L3</td>
</tr>
<tr>
<td>6</td>
<td>3</td>
<td>14.8</td>
<td>141</td>
<td>Midfoot</td>
<td>5</td>
<td>10</td>
<td>L2</td>
<td>L1</td>
</tr>
<tr>
<td>7</td>
<td>4</td>
<td>6.4</td>
<td>146</td>
<td>Heel</td>
<td>20</td>
<td>10</td>
<td>L1</td>
<td>L2</td>
</tr>
<tr>
<td>8</td>
<td>4</td>
<td>6.4</td>
<td>146</td>
<td>Heel</td>
<td>5</td>
<td>1</td>
<td>L2</td>
<td>L3</td>
</tr>
<tr>
<td>9</td>
<td>5</td>
<td>11.2</td>
<td>138</td>
<td>Heel</td>
<td>5</td>
<td>1</td>
<td>L2</td>
<td>L3</td>
</tr>
<tr>
<td>10</td>
<td>5</td>
<td>11.2</td>
<td>138</td>
<td>Heel</td>
<td>20</td>
<td>10</td>
<td>L3</td>
<td>L2</td>
</tr>
<tr>
<td>11</td>
<td>6</td>
<td>11.2</td>
<td>144</td>
<td>Forefoot</td>
<td>20</td>
<td>1</td>
<td>L3</td>
<td>L3</td>
</tr>
<tr>
<td>12</td>
<td>6</td>
<td>11.2</td>
<td>144</td>
<td>Forefoot</td>
<td>5</td>
<td>10</td>
<td>L2</td>
<td>L1</td>
</tr>
<tr>
<td>13</td>
<td>7</td>
<td>12.8</td>
<td>139</td>
<td>Heel</td>
<td>5</td>
<td>10</td>
<td>L3</td>
<td>L1</td>
</tr>
<tr>
<td>14</td>
<td>7</td>
<td>12.8</td>
<td>139</td>
<td>Heel</td>
<td>20</td>
<td>1</td>
<td>L1</td>
<td>L2</td>
</tr>
<tr>
<td>15</td>
<td>8</td>
<td>14</td>
<td>139</td>
<td>Midfoot</td>
<td>5</td>
<td>1</td>
<td>L1</td>
<td>L2</td>
</tr>
<tr>
<td>16</td>
<td>8</td>
<td>14</td>
<td>139</td>
<td>Midfoot</td>
<td>20</td>
<td>10</td>
<td>L2</td>
<td>L3</td>
</tr>
<tr>
<td>17</td>
<td>9</td>
<td>6</td>
<td>150</td>
<td>Heel</td>
<td>20</td>
<td>10</td>
<td>L2</td>
<td>L2</td>
</tr>
<tr>
<td>18</td>
<td>9</td>
<td>6</td>
<td>150</td>
<td>Heel</td>
<td>5</td>
<td>1</td>
<td>L3</td>
<td>L3</td>
</tr>
<tr>
<td>19</td>
<td>10</td>
<td>10.8</td>
<td>143</td>
<td>Forefoot</td>
<td>20</td>
<td>1</td>
<td>L3</td>
<td>L1</td>
</tr>
<tr>
<td>20</td>
<td>10</td>
<td>10.8</td>
<td>143</td>
<td>Forefoot</td>
<td>5</td>
<td>10</td>
<td>L2</td>
<td>L2</td>
</tr>
</tbody>
</table>

Of the 100 runners, 32 are selected based on their covariate values. The rows corresponding to the selected runners are selected in the RunnersCovariates.jmp sample data table. Settings of the experimental factors Thickness, Gel, Insole, and Outsole are determined so that the design is optimal for the model described in the Model Outline.

23. With the RunnersCovariates.jmp sample data table as the active table, select Analyze > Distribution.

24. Select all three columns as Y, Columns.

25. Check Histograms Only.

26. Click OK.

Figure 5.67 Histograms for 100 Runners with Selected Runner Data Shaded
Examples of Custom Designs
Chapter 5
Experiments with Covariates

The histograms illustrate how the design selected runners to balance runs across the covariates. The distribution of selected runners is similar to the overall distribution of all runners for each covariate.

Design with a Linear Time Trend

Often, experiments conducted in a time sequence experience a linear drift in the response. If you randomize the order of the runs, then the drift’s effect does not generally bias the estimated factor effects. However, by accounting for the drift, you can reduce the variance of those effects.

Suppose that there is reason to suspect a strong linear trend in the response over time independent of the factor changes. Then you can construct a design that includes a linear covariate to account for the trend. The resulting design is optimal, given this trend covariate.

In this example, you design an experiment for 7 factors. You construct a 16-run design that is robust to linear trend.

1. Select File > New > Data Table.
2. Right-click Column1 and select Column Info.
3. Change the column name to Run Order.
4. From the list of Initialize Data options, select Sequence Data.
5. Type 16 next to To.
6. Click OK.
   Consecutive integers from 1 to 16 have been entered in the data table.
7. Select DOE > Custom Design.
8. Click Add Factor > Covariate.
9. Select Run Order and click OK.
10. Type 7 next to Add N Factors.
11. Click Add Factor > Continuous.
Figure 5.68 Responses and Factors Outlines

12. Click **Continue**.

13. Open the **Alias Terms** outline.

14. Select all of the effects in the list and click **Remove Term**.

   This omits the interaction effects from the correlation color map, leaving only the main effects.

   **Note:** Setting the Random Seed in step 15 and Number of Starts in step 16 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

15. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 1234, and click **OK**.

16. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 100, and click **OK**.

17. Click **Make Design**.

**Figure 5.70** Color Map Showing Absolute Correlations with Run Order

The Color Map shows the following:
- The seven continuous factors, X2 through X8, are orthogonal to each other.
- Run Order, the linear time trend variable, has extremely low absolute correlation with X2 through X8.

The small absolute correlations of Run Order with X2 through X8 result in very small increases in confidence interval lengths, relative to an ideal orthogonal design. The increases in the lengths of confidence intervals for X2 through X8 are all less than about 0.1%.

In this example, the run order factor is nearly orthogonal to the factor effects. In some cases, your design might have more substantial correlations between the run order factor and other factors. Even in such a situation, including the run order as a factor accounts for any linear trend effect. Including the run order also allows for more precise estimation of the other factor effects.

Experiments with Randomization Restrictions

The Custom Design platform constructs split-plot, split-split-plot, and two-way split-plot (strip-plot) designs that are D-optimal or I-optimal. For more information about constructing these designs, see Goos (2002).

- “Split-Plot Experiment”
- “Two-Way Split-Plot Experiment”

Split-Plot Experiment

Split-plot designs originated in agriculture, but are commonplace in manufacturing and engineering studies. In a split-plot experiment, hard-to-change factors are reset only between one whole plot and the next whole plot. The whole plot is divided into subplots, and the levels of the easy-to-change factors are randomly assigned to each subplot.
The example in this section is adapted from Kowalski, Cornell, and Vining (2002). You are interested in the effects of five factors on the thickness of vinyl that is used to make automobile seat covers. The response and factors in the experiment are described below:

- The response is the thickness of the vinyl that is produced. You want to maximize thickness. A lower limit for thickness values is 10.
- The whole plot factors are the rate of extrusion (extrusion rate) and the temperature (temperature) of drying. These are process variables and are hard to change.
- The subplot factors are three plasticizers whose proportions (m1, m2, and m3) sum to one. These factors are mixture components.

Your experimental budget allows for running 7 settings of these whole plot factors. For each whole plot, you can conduct 4 runs of the subplot factors. This gives you a total of 28 runs.

Create the Design

1. Select DOE > Custom Design.
2. Double-click Y under Response Name and type thickness. Keep the default goal set to Maximize.
3. Enter a Lower Limit of 10.
4. Type 2 next to Add N Factors.
5. Click Add Factor > Continuous.
6. Rename these factors extrusion rate and temperature. Keep the default Values of –1 and 1 for these two factors.
7. Click Easy and select Hard for both extrusion rate and temperature. This defines extrusion rate and temperature to be whole plot factors.
8. Type 3 next to Add N Factors.
9. Click Add Factor > Mixture.
10. Rename the three mixture factors m1, m2, and m3. Keep the default Values of 0 and 1 for those three factors.
11. Click **Continue**.
12. Click **Interactions > 2nd**.
13. Click **OK** to dismiss the informative message.
   
   Note that 3 is the default value for the Number of Whole Plots.
14. Type 7 next to **Number of Whole Plots**.
15. Type 28 next to **User Specified**.

   **Note:** Setting the Random Seed in step 16 and Number of Starts in step 17 reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

16. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 12345, and click **OK**.
17. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 5, and click **OK**.
18. Click **Make Design**.
Note that the whole plot factors, extrusion rate and temperature, are reset seven times in accordance with the levels of the factor Whole Plots. Within each level of Whole Plots, the settings for the mixture ingredients, m1, m2, and m3, are assigned at random.

### Analyze the Results

The Vinyl Data.jmp sample data table contains experimental results using a design created in a previous version of JMP.

1. Select **Help > Sample Data Library** and open Design Experiment/Vinyl Data.jmp.

   This sample data table contains 28 runs and response values. The design settings in the table that you created using the Custom Design platform might differ from those used in the Vinyl Data.jmp design.

2. In the Table panel, click the green triangle next to the **Model** script.
Figure 5.74  Fit Model Window

Notice the following in the Fit Model window:

- The factor Whole Plots has the Attribute called Random Effects (**Random**). This specifies that the levels of Whole Plots are random realizations. They have an associated error term.

- The analysis method is **REML (Recommended)**. This method is specified precisely because the model contains a random effect. For more information about REML models, see *Fitting Linear Models*.

**Tip:** In the Fit Model window, JMP Pro users can change the Personality to Mixed Model.

3. Click **Run**.
The Parameter Estimates report shows that the three mixture ingredients, as well as the extrusion rate*temperature interaction, are significant at the 0.05 level.

The REML Variance Component Estimates report indicates that the variance component associated with Whole Plots is 2.476748. This is 38.838% of the total variation. It follows that the error term associated with whole plot replication is smaller than the residual (or within-plot) error term.

**Two-Way Split-Plot Experiment**

A two-way split-plot (also known as strip-plot or split-block) design consists of two split-plot components. In industry, these designs arise when batches of material or experimental units from one processing stage pass to a second processing stage. To use a two-way split-plot design, you must be able to reorder the units between stages.

After the first processing stage, you must be able to divide the batches into sub-batches. The second-stage processing factors are applied randomly to these sub-batches. For a specific second-stage experimental setting, all of the sub-batches assigned to that setting can be processed simultaneously. Additional factors can be applied to experimental units after the second processing stage.

In contrast to a split-split-plot design, the second-stage factors are not nested within the first-stage factors. After the first stage, the batches are subdivided and formed into new batches. Therefore, both the first- and second-stage factors are applied to whole batches.
Although factors at both stages might be equally hard-to-change, in order to distinguish these factors, JMP denotes the first stage factors as very-hard-to-change and the second-stage factors as hard-to-change. Additional factors applied to experimental units after the second processing stage are considered easy-to-change.

**Scenario for a Two-Way Split-Plot Design**

This example is based on an experiment to improve the open circuit voltage (OCV) in battery cells (Vivacqua and Bisgaard, 2004). You need to minimize the OCV in order to keep the cells from discharging on their own.

Battery cells move through two stages of processing:

- First stage: A continuous assembly process where batteries are processed in batches of 2000.
- Second stage: A curing process with a 5-day cycle time in a chamber that can accommodate 4000 batteries.

You want to study six two-level continuous factors:

- Four factors (A1, A2, A3, and A4) are applied to the assembly process. You can run 16 trials for the first-stage factors.
- Two factors (C5 and C6) are applied to the curing process. Because curing requires a 5-day cycle time, you can run only 6 cycles (30 days) for the second-stage factors. Using six curing cycles gives you partial replication of the curing settings, enabling you to test for curing effects.

Both the first- and second-stage factors are hard-to-change, suggesting two split-plots. However, the batches of 2,000 batteries from the first-stage experiment can be divided into sub-batches of 500 batteries each. Eight of these sub-batches can be randomly selected and processed simultaneously in the curing chamber.

The experiment has 48 experimental units. Note that the first- and second-stage factors are crossed.

**Create the Design**

To design a two-way split-plot experiment:

1. Select **DOE > Custom Design**.
2. Double-click **Y** under **Response Name** and type **OCV**.
3. Under **Goal**, click **Maximize** and select **Minimize**.
4. To add factors manually, follow **step 5 through step 10**. Or, to load factors from a saved table:
   a. Click the Custom Design red triangle and select **Load Factors**.
b. Open the Battery Factors.jmp sample data table, located in the Design Experiment folder.

c. Proceed to step 11.

5. Type 6 next to **Add N Factors**.

6. Click **Add Factor > Continuous**.

7. Rename the factors A1, A2, A3, A4, C1, and C2.

   Keep the default Values of -1 and 1 for these factors.

8. For each of the factors A1, A2, A3, and A4, under Changes, click **Easy** and change it to **Very Hard**.

   To distinguish between the first- and second-stage factors, you designate the Changes for the first-stage factors as Very Hard, and the Changes for the second-stage factors as Hard.

9. For each of the factors C1 and C2, under Changes, click **Easy** and change it to **Hard**.

**Figure 5.76** Responses and Factors Outlines

10. Click **Continue**.

11. Select **Interactions > 2nd** in the Model outline.

12. In the Design Generation outline, select the option **Hard to change factors can vary independently of Very Hard to change factors**.

   See **Figure 5.77**. Checking this option creates a two-way split-plot design. If this option is not checked, the design is treated as a split-split-plot design, with nesting of factors at the two levels.

13. Type 16 as the **Number of Whole Plots**.

   This is the number of trials that you can run for the first-stage factors.

14. Type 6 as the **Number of Subplots**.
This is the number of trials that you can run for the second-stage factors.

15. Under Number of Runs, type 48 next to **User Specified**.

This is the total number of experimental units.

**Figure 5.77** Design Generation Outline

<table>
<thead>
<tr>
<th>Design Generation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Whole Plots: 16</td>
</tr>
<tr>
<td>Number of Subplots: 6</td>
</tr>
<tr>
<td>Number of Runs:</td>
</tr>
<tr>
<td>- Minimum: 22</td>
</tr>
<tr>
<td>- Default: 30</td>
</tr>
<tr>
<td>- User Specified: 48</td>
</tr>
</tbody>
</table>

**Note:** Setting the Random Seed in **step 16** and Number of Starts in **step 17** reproduces the exact results shown in this example. In constructing a design on your own, these steps are not necessary.

16. (Optional) Click the Custom Design red triangle, select **Set Random Seed**, type 1866762673, and click **OK**.

17. (Optional) Click the Custom Design red triangle, select **Number of Starts**, type 21, and click **OK**.

18. Click **Make Design**.

19. Click **Make Table**.

**Figure 5.78** Partial View of Design Table

<table>
<thead>
<tr>
<th>Whole Plots</th>
<th>Subplots</th>
<th>A1</th>
<th>A2</th>
<th>A3</th>
<th>A4</th>
<th>C1</th>
<th>C2</th>
<th>OCV</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>*</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>9</td>
<td>3</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>10</td>
<td>4</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>11</td>
<td>5</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>*</td>
</tr>
<tr>
<td>12</td>
<td>6</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>*</td>
</tr>
<tr>
<td>13</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>*</td>
</tr>
<tr>
<td>14</td>
<td>2</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>*</td>
</tr>
<tr>
<td>15</td>
<td>3</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>*</td>
</tr>
<tr>
<td>16</td>
<td>4</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>*</td>
</tr>
</tbody>
</table>


The design table shows 16 levels for Whole Plots. For each level of Whole Plots, the settings of the four assembly factors are constant. From each level of Whole Plots, three batches of 500 batteries (Subplots) are randomly assigned to settings of the curing factors. Two sets of curing conditions are replicated (C1 = -1, C2 = 1 and C1 = 1, C2 = 1). To see this, select columns C1 and C2, right-click in the header area, and select **Sort > Ascending**.

**Analyze the Results**

The Battery Data.jmp sample data table contains experimental results for the design that you generated.

1. Select **Help > Sample Data Library** and open Design Experiment/Battery Data.jmp.
2. In the Table panel, click the green triangle next to the **Model** script.
   
   Notice the following in the Fit Model window:

   - The factor Whole Plots has the Attribute called Random Effects (**&Random**). This specifies that the levels of Whole Plots are random realizations. They have an associated error term.
   - The factor Subplots also has the Random Effects Attribute (**&Random**).
   - The analysis Method is **REML (Recommended)**. This method is specified precisely because the model contains random effects. For more information about REML models, see **Fitting Linear Models**.

   **Tip:** In the Fit Model window, JMP Pro users can change the Personality to Mixed Model.

3. Check the option to **Keep dialog open**.
4. Click **Run**.
The Parameter Estimates report indicates that four two-way interactions, $A_1*C_1$, $A_1*C_2$, $A_2*C_1$, and $A_4*C_2$, and two main effects, $A_1$ and $A_4$, are significant at the 0.05 level.

5. In the Table panel of Battery Data.jmp, click the green triangle next to the Reduced Model 1 script.

The script opens a Fit Model window where insignificant interactions have been removed. The remaining effects are all main effects and the four two-way interactions $A_1*C_1$, $A_1*C_2$, $A_2*C_1$, and $A_4*C_2$. You are reducing the model in a conservative fashion.

6. Click Run.
Figure 5.80  Report for Preliminary Reduced Model

| Term     | Estimate | Std Error | DFDen | t Ratio | Prob>|t| |
|----------|----------|-----------|-------|---------|-------|
| Intercept| 38.24953 | 1.37327   | 7.723 | 27.86   | <.0001*|
| A1       | -4.72306 | 1.17502   | 8.5   | -4.02   | 0.0034*|
| A2       | 0.049717 | 1.165418  | 8.228 | 0.04    | 0.9669 |
| A3       | 0.7560417| 1.165418  | 8.228 | 0.65    | 0.5342 |
| A4       | 4.2320825| 1.2076954| 9.16  | 3.90    | 0.0065*|
| C1       | -2.195626| 0.8066042| 1.083 | -2.54   | 0.2294 |
| C2       | -1.57922 | 0.840903 | 1.068 | -1.877  | 0.0331*|
| A1*C1    | -3.28225 | 0.452505  | 25.17 | -7.26   | <.0001*|
| A1*C2    | 3.8075938| 0.44986   | 24.42 | 8.46    | <.0001*|
| A2*C1    | 1.8797279| 0.462505  | 25.17 | 4.15    | 0.0003*|
| A2*C2    | 1.3877066| 0.482556  | 24.95 | 2.88    | 0.0081*|

Notice that the main effect C2 is now significant at the 0.05 level (Prob>|t| = 0.0331)

7. In the Fit Model window, remove A3.
   The main effect A3 is the only main effect that is not significant and not involved in a two-way interaction.

8. Click Run.

Figure 5.81  Report for Reduced Model

The REML Variance Component Estimates report shows that the variance component associated with Whole Plots is about six times as large as the variance component for Subplots. This suggests that the assembly process is more variable than the curing process. Also, the within (Residual) error is larger than that for Subplots. Efforts to reduce variation should focus on the assembly process and on battery-to-battery differences.

9. Click the Response OCV red triangle and select Factor Profiling > Profiler.
10. Click the Prediction Profiler red triangle and select **Optimization and Desirability > Maximize Desirability**.

**Figure 5.82** Prediction Profiler with Settings That Minimize OCV

![Prediction Profiler](image)

The profiler shows the five factors identified as active and settings that minimize OCV.
Experiments for Robust Process and Product Design

Often processes or products are impacted by noise factors. These are factors that are not easy or cost effective to control. Finding process or product settings of controllable factors that are least impacted by noise factors is desirable. Historically, Taguchi designs provided a method for experimenting in the presence of noise factors. Note that noise factors must be controlled during an experiment.

Alternatives to Taguchi designs include combined arrays and mixed resolution designs (Borror and Montgomery, 2000). The mixed resolution designs are used to obtain designs that contain both control and noise factors. The goal of such a design is to find robust settings for control variables. The key is the ability to estimate specific effects. In particular, one is interested in estimating main effects of the control variables, main effects of the noise variables, control by control interactions, noise by control interactions, and quadratic terms for the control variables.

Use the custom designer to generate a design for studying robust process settings.

In this example, you are interested in finding optimal settings for four control settings in the presence of three noise factors.

1. Select **DOE > Custom Design**.
2. In the Factors outline, type 4 next to **Add N Factors**.
3. Click **Add Factor > Continuous**.
4. In the Factors outline, type 3 next to **Add N Factors**.
5. Click **Add Factor > Continuous**.
6. Double-click X5 and change it to Z1 to designate a noise factor. Repeat to change X6 and X7 to Z2 and Z3.

**Figure 5.83** Factor Outline for Design with 4 Control and 3 Noise Factors

7. Click Continue.

Next you set up the model that for exploring optimal settings for the control factors that are least impacted by the noise factors.

8. The model contains all main effects by default.
9. Click **Interactions > 2nd** to add all two-way interactions.
   This enters the control by control interactions, the control by noise interactions, and the noise by noise interactions. You do not want to estimate the interaction between noise factors.

10. Scroll to the bottom of the list, highlight $Z_1Z_2$, $Z_1Z_3$, and $Z_2Z_3$ and click Remove Term. This removes the noise by noise interactions.

11. In the Factors outline, select $X_1$, $X_2$, $X_3$, and $X_4$.

12. In the Model outline, click Powers > 2nd to add the control variable quadratic terms.

**Figure 5.84** Model Outline for Design with Noise Factors

13. Add two center points by entering 2 In the **Number of Center Points:** text box.

14. Click **Make Design**.

The result is a 36 run design that enables you to evaluate and optimize your control factors in the presence of your three noise factors. The goal of your analysis is to determine which effects are important and then to select settings for the control factors that are least impacted by the noise factors.
Chapter 6

Augment Designs

Add Additional Runs to an Existing Design

Use the Augment Design platform to add runs to an existing experimental design. Experimentation is often a sequential process and augmenting a designed experiment can help resolve ambiguities that result from a single design.

For an existing design table, the Augment Design platform constructs additional runs that optimize the overall design. You can add runs to accomplish the following objectives:

- Replicate the design a specified number of times.
- Add center points.
- Create a foldover design.
- Add axial points together with center points to transform a screening design to a response surface design.
- Add space filling points to a design.
- Add runs to the design in order to fit a specific model.

For more information about augmenting designs see Goos and Jones (2011).

Figure 6.1 Original Design Runs (+) with Augmented Runs (o)
## Contents

- **Example Using the Augment Design Platform** ........................................ 215
- **Launch the Augment Design Platform** .................................................. 221
- **Augment Design Window** ...................................................................... 222
  - Factors ................................................................................................... 222
  - Define Factor Constraints ................................................................. 223
  - Augmentation Choices ........................................................................ 226
- **Augment Design Platform Options** ....................................................... 227
- **Additional Examples of Augmentation Choices** .................................... 231
  - Replicate a Design .............................................................................. 231
  - Add Center Points to a Design ......................................................... 233
  - Create a Foldover Design .................................................................. 233
  - Add Axial Points to a Design .............................................................. 234
  - Space Filling Augmentation ................................................................. 235
- **Statistical Details** .................................................................................. 237
Example Using the Augment Design Platform

Use the Augment Design Platform to add additional runs to a design. This example demonstrates how to use the Augment Design platform to resolve ambiguities in the results of a screening design. In this study, a chemical engineer investigates the effects of five factors on the percent reaction of a chemical process. The original design was an 8-run design suitable for fitting main effects. This example augments the 8-run design such that all two-factor interactions can be estimated using a total of 16 runs.

1. Select **Help > Sample Data Library** and open Design Experiment/Reactor 8 Runs.jmp.
2. Select **DOE > Augment Design**.
3. Select Percent Reacted and click **Y, Response**.
4. Select Feed Rate, Catalyst, Stir Rate, Temperature, and Concentration, and click **X, Factor**.
5. Click **OK**.

**Figure 6.2** Factors for the Reactor Example

<table>
<thead>
<tr>
<th>Name</th>
<th>Role</th>
<th>Changes</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed Rate</td>
<td>Continuous</td>
<td>Easy</td>
<td>10</td>
</tr>
<tr>
<td>Catalyst</td>
<td>Continuous</td>
<td>Easy</td>
<td>1</td>
</tr>
<tr>
<td>Stir Rate</td>
<td>Continuous</td>
<td>Easy</td>
<td>100</td>
</tr>
<tr>
<td>Temperature</td>
<td>Continuous</td>
<td>Easy</td>
<td>140</td>
</tr>
<tr>
<td>Concentration</td>
<td>Continuous</td>
<td>Easy</td>
<td>3</td>
</tr>
</tbody>
</table>

**Note:** You can select **Group new runs into separate block** to add a blocking factor to any design. However, recall that this example estimates all two-factor interactions in 16 runs, and that cannot be done when there is an additional blocking factor in the model.

6. Click **Augment**.

The model shown in **Figure 6.3** is defined using the Model script in the data table. With 8 runs, you can estimate up to 7 effects. The model in the script contains all 5 main effects and two interaction terms. All terms are defined as necessary for the model. For more information about effect estimability, see “Model”.
7. In the Model outline, select **Interactions > 2nd**.

   This adds all the two-factor interactions to the model. The minimum number of runs given for the specified model is 16, as shown in the Design Generation text edit box.

   **Note:** Setting the Random Seed in **step 8** and Number of Starts in **step 9** reproduces the exact results shown in **Figure 6.4**. When you are constructing a design on your own, these steps are optional.

8. (Optional) Click the Augment Design red triangle, select **Set Random Seed**, type 282322901, and click **OK**.

9. (Optional) Click the Augment Design red triangle, select **Number of Starts**, type 800, and click **OK**.

10. Click **Make Design**.

11. Click the **Design** disclosure icon to view the design.
12. Click Make Table to generate a design table containing the original design with results and the augmented runs.

### Analyze the Augmented Design

Continuing the augmented design example, suppose you have conducted the additional experimental runs and have recorded results to analyze.

1. Select Help > Sample Data Library and open Design Experiment/Reactor Augment Data.jmp. You want to maximize Percent Reacted. Note that the column’s Response Limits column property in this sample data table is set to Maximize. The lower and upper limits are set to 90 and 100, respectively.
2. In the Table panel of the data table, click the green triangle next to the Model script. The Model script opens the Fit Model window with all main effects and two-factor interactions as effects.

3. Change the fitting personality from Standard Least Squares to Stepwise and then click Run.

4. In the Stepwise Regression Control panel, select P-value Threshold from the Stopping Rule menu and Mixed from the Direction menu. Enter 0.05 for the Prob to Enter and 0.05 for the Prob to Leave.

5. In the Current Estimates panel, select the Entered check boxes for all the main effect terms (Feed Rate - Concentration).
6. Click **Go**.

Stepwise regression, beginning with the main effects and using a \( p \)-value based search, results in a model with three main effects and two interaction terms. Click **Make Model** on the Stepwise Regression Control panel.

This launches the Fit Model platform for the model built using the stepwise procedure.

7. Click **Run**.
The Actual by Predicted Plot indicates that the overall model is significant (PValue < .0001). Both the Actual by Predicted Plot and the Lack of Fit tests show no evidence of model misspecification. The Effect Summary report shows that Catalyst is the most significant effect.

8. Click the Prediction Profiler red triangle and select Optimization and Desirability > Maximize Desirability.
The prediction profile plot shows that the maximum percent reaction occurs at high Catalyst and Temperature and low Concentration. At these extreme settings, the estimate of Percent Reacted is 95.7. The desirability profiles flatten in regions where the predicted response falls outside of the response limits.

Launch the Augment Design Platform

Launch the Augment Design platform by selecting **DOE > Augment Design** from the data table that contains the design that you want to augment.

**Y, Response**  Enter the numeric response column or columns. Entering a response is required.

**X, Factor**  Enter the factor columns. Factors can be of any data type or modeling type.
Augment Design Window

The initial Augment Design window consists of the Factors and Define Factor Constraints outlines, and the Augmentation Choices panel.

Figure 6.10 Initial Augment Design Window Using Reactor 8 Runs.jmp

Factors

The factors are those you specified in the Augment Design launch window.

Name  Lists all factors listed as X, Factor in the Augment Design launch window except for factors with the Random Block design role column property.

Role  Specifies the Design Role of the factor specified in the column property. If the factor does not have a Design Role column property and is constant, then Constant appears in the Role column. Otherwise, the factor’s modeling type appears in the Role column.

Changes  Indicates whether the factor levels are Easy, Hard, or Very Hard to change as specified by the Factor Changes column property in the data table. If the factor does not have a Factor Changes column property, then Changes is specified as Easy.

Note: If a factor has a Factor Changes column property that is set to Hard or Very Hard, then the corresponding whole plot factor must be included in the X, Factor list in the Augment Design launch window.

Values  For continuous factors, shows the minimum and maximum values. For categorical factors, shows the levels.
Tip: Factors that have a role of Categorical or Constant appear in the Name column with a down arrow icon. Click the down arrow to add levels. If the factor is Constant and has a categorical modeling type, multiple levels can be added. If the factor is Constant and has a continuous modeling type, only one level can be added.

Group new runs into separate block Adds a blocking factor to the design with a block for the original design and a block for the augmented runs.

Define Factor Constraints

If you augment a design using the Space Filling or Augment options, you can define restrictions on the design space for the added runs.

Use Define Factor Constraints to restrict the design space. Unless you have loaded a constraint or included one as part of a script, the None option is selected. To specify constraints, select one of the other options:

Specify Linear Constraints Specifies inequality constraints on linear combinations of factors. Available only for factors with a Role of Continuous or Mixture. See “Specify Linear Constraints”.

Note: When you save a script for a design that involves a linear constraint, the script expresses the linear constraint as a less than or equal to inequality ($ \leq $).

Use Disallowed Combinations Filter Defines sets of constraints based on restricting values of individual factors. You can define both AND and OR constraints. See “Use Disallowed Combinations Filter”.

Use Disallowed Combinations Script Defines disallowed combinations and other constraints as Boolean JSL expressions in a script editor box. See “Use Disallowed Combinations Script”.

Note: When you analyze a design that has factor constraints, the model profiler honors the constraints.

Specify Linear Constraints

In cases where it is impossible to vary continuous factors independently over the design space, you can specify linear inequality constraints. Linear inequalities describe factor level settings that are allowed. For an example, see “Mixture of Mixtures Design”.
Click **Add** to enter one or more linear inequality constraints.

**Add**  Adds a template for a linear expression involving all the continuous factors in your design. Enter coefficient values for the factors and select the direction of the inequality to reflect your linear constraint. Specify the constraining value in the box to the right of the inequality. To add more constraints, click **Add** again.

**Note:** The Add option is disabled if you have already constrained the design region by specifying a Sphere Radius.

**Remove Last Constraint**  Removes the last constraint.

**Check Constraints**  Checks the constraints for consistency. This option removes redundant constraints and conducts feasibility checks. A JMP alert appears if there is a problem. If constraints are equivalent to bounds on the factors, a JMP alert indicates that the bounds in the Factors outline have been updated.

**Use Disallowed Combinations Filter**

This option uses an adaptation of the Data Filter to facilitate specifying disallowed combinations. For detailed information, see *Using JMP*.

Select factors from the Add Filter Factors list and click **Add**. Then specify the disallowed combinations by using the slider (for continuous factors) or by selecting levels (for categorical factors). For an example, see “Response Surface Design With Constraints and Categorical Factor”.

The red triangle options for the Add Filter Factors menu are those found in the Select Columns panel of many platform launch windows. See *Using JMP*.

When you click Add, the Disallowed Combinations control panel shows the selected factors and provides options for further control. Factors are represented as follows, based on their modeling types:

**Continuous Factors**  For a continuous factor, a double-ended slider that spans the range of factor settings appears. You can specify disallowed settings by dragging the slider ends or by setting the endpoints by clicking on the text value under the slider. In the slider, a solid blue highlight represents the disallowed values.

**Categorical Factor**  For a categorical factor, the possible levels are displayed either as labeled blocks or, when the number of levels is large, as list entries. Select a level to disallow it. To select multiple levels, hold the Control key. The block or list entries are highlighted to indicate the levels that have been disallowed. When you add a categorical factor to the Disallowed Combinations panel, the number of levels of the categorical factor is given in parentheses following the factor name.
**Disallowed Combinations Options**

The control panel has the following controls:

**Clear**  Clears all disallowed factor level settings that you have specified. This does not clear the selected factors.

**Start Over**  Removes all selected factors and returns you to the initial list of factors.

**AND**  Opens the Add Filter Factors list. Selected factors become an AND group. Any combination of factor levels specified within an AND group is disallowed.

To add a factor to an AND group later on, click the group’s outline to see a highlighted rectangle. Select AND and add the factor.

To remove a single factor, select **Delete** from its red triangle menu.

**OR**  Opens the Add Filter Factors list. Selected factors become a separate AND group. For AND groups separated by OR, a combination is disallowed if it is specified in at least one AND group.

**Red Triangle Options for Factors**

A factor can appear in several OR groups. An occurrence of the factor in a specific OR group is referred to as an *instance* of the factor.

**Delete**  Removes the selected instance of the factor from the Disallowed Combinations panel.

**Clear Selection**  Clears any selection for that instance of the factor.

**Invert Selection**  Deselects the selected values and selects the values not previously selected for that instance of the factor.

**Display Options**  Available only for categorical factors. Changes the appearance of the display. Options include showing each level as a block, list, or single category, or adding a check box next to each value.

**Find**  Available only for categorical factors. Provides a text box beneath the factor name where you can enter a search string for levels of the factor. Press the Enter key or click outside the text box to perform the search. Once **Find** is selected, Find options appear in the red triangle menu, such as Does not contain, Match Case, Starts with or Ends with, or Clear Find.

**Use Disallowed Combinations Script**

Use this option to disallow particular combinations of factor levels using a JSL script. This option can be used with continuous factors or mixed continuous and categorical factors.
This option opens a script window where you insert a script that identifies the combinations that you want to disallow. The script must evaluate as a Boolean expression. When the expression evaluates as true, the specified combination is disallowed.

When forming the expression for a categorical factor, use the ordinal value of the level or the name of the level. If a factor’s levels are high, medium, and low, specified in that order in the Factors outline, their associated ordinal values are 1, 2, and 3. For example, suppose that you have two continuous factors, X1 and X2, and a categorical factor X3 with three levels: L1, L2, and L3, in order. You want to disallow levels where the following is true:

\[ e^{X_1} + 2X_2 < 0 \text{ and } X_3 = L2 \]

Enter the expression \((\text{Exp}(X1) + 2\times X2 < 0) \& (X3 == 2)\) into the script window.

**Figure 6.11 Expression in Script Editor**

(In the figure, unnecessary parentheses were removed by parsing.) Notice that functions can be entered as part of the Boolean expression. The expression \((\text{Exp}(X1) + 2\times X2 < 0) \& (X3 == \text{"L2"})\) is also valid.

**Augmentation Choices**

The Augment Design platform has the following choices for augmentation:

**Replicate** Replicates the design a specified number of times. See “Replicate a Design”.

**Add Centerpoints** Adds center points. Specify how many runs you want to add as center points to the design. A center point is a run whose setting for each continuous factor is midway between the high and low settings. See “Center Points, Replicate Runs, and Testing”.

If a design contains both continuous and other types of factors, center points might not be balanced relative to the levels of the other factors. Augment Design chooses the center points to maximize the D-, I-, or alias efficiency of the design.

See “Add Center Points to a Design”.

**Fold Over** Creates a foldover design. See “Create a Foldover Design”.
Add Axial  Adds axial points and center points to a design. Add Axial can be used to generate a central composite design from a screening design. See “Add Axial Points to a Design”.

Space Filling  Adds additional runs to any design consisting of continuous factors. Additional runs are constructed using the fast flexible filling methodology. See “Space Filling Augmentation”. Space Filling does not support grouping new runs in a separate block.

Augment  Adds runs to the design using a model. This model typically has more terms than the original model. See “Example Using the Augment Design Platform”.

### Augment Design Platform Options

The Accelerated Life Test Plan red triangle menu contains the following options:

**Save Responses**  Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.

**Load Responses**  Loads responses that you saved using the Save Responses option.

**Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

**Note:** It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting **Column Properties > Design Role**. In the Design Role area, select the appropriate role.

**Load Factors**  Loads factors that you saved using the Save Factors option.

**Save Constraints**  (Unavailable for some platforms) Saves factor constraints that you defined in the Define Factor Constraints or Linear Constraints outline into a data table, with a column for each constraint. You can then quickly load the constraints into most DOE windows.

In the constraint table, the first rows contain the coefficients for each factor. The last row contains the inequality bound. Each constraint’s column contains a column property called **ConstraintState** that identifies the constraint as a “less than” or a “greater than” constraint. See “**ConstraintState**”.

**Load Constraints**  (Unavailable for some platforms) Loads factor constraints that you saved using the Save Constraints option.
**Set Random Seed**  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:

- initializing search algorithms for design generation
- randomizing Run Order for design construction
- selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking **Make Design**.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

**Simulate Responses**  Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

- A set of simulated response values is added to each response column.
- For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
- A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

**Note:** Not all distributions are available for all design types.

- A script called **DOE Simulate** is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a new column called \(<Y> Simulated\), where \(Y\) is the name of the response. Clicking Apply again updates the formula and values in \(<Y> Simulated\).

For additional details, see “**Simulate Responses**”.

**Note:** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in *Basic Analysis*.

**Save X Matrix**  Saves scripts called Moments Matrix and Model Matrix to the design data table. These scripts contain the moments and design matrices. See “**Save X Matrix**”.
**Caution:** For a design with nominal factors, the matrix in the Model Matrix script saved by the Save X Matrix option is not the coding matrix used in fitting the linear model. You can obtain the coding matrix used for fitting the model by selecting the option Save Columns > Save Coding Table in the Fit Model report that you obtain when you run the Model script.

**Optimality Criterion** Changes the design optimality criterion. The default criterion, **Recommended**, specifies D-optimality for all design types, unless you added quadratic effects using the RSM button in the Model outline. For more information about the D-, I-, and alias-optimal designs, see “Optimality Criteria”.

**Note:** You can set a preference to always use a given optimality criterion. Select File > Preferences > Platforms > DOE. Select Optimality Criterion and choose your preferred criterion.

**Number of Starts** Enables you to specify the number of random starts used in constructing the design. See “Number of Starts”.

**Design Search Time** Maximum number of seconds spent searching for a design. The default search time is based on the complexity of the design. See “Design Search Time” and “Number of Starts”.

If the iterations of the algorithm require more than a few seconds, a Computing Design progress window appears. If you click **Cancel** in the progress window, the calculation stops and gives the best design found at that point. The progress window also displays D-efficiency for D-optimal designs that do not include factors with Changes set to Hard or Very Hard or with Estimability set to If Possible.

**Note:** You can set a preference for Design Search Time. Select File > Preferences > Platforms > DOE. Select Design Search Time and enter the maximum number of seconds. In certain situations where more time is required, JMP extends the search time.

**Sphere Radius** Constrains the continuous factors in a design to a hypersphere. Specify the radius and click **OK**. Design points are chosen so that their distance from 0 equals the Sphere Radius. Select this option before you click Make Design.

**Note:** Sphere Radius constraints cannot be combined with constraints added using the Specify Linear Constraints option. Also, the option is not available when hard-to-change factors are included (split-plot designs).
Advanced Options

**Mixture Sum**  Sets the sum of the mixture factors to any positive value. Use this option to keep a component of a mixture constant throughout an experiment.

**Split Plot Variance Ratio**  Specifies the ratio of the variance of the random whole plot and the subplot variance (if present) to the error variance. Before setting this value, you must define a hard-to-change factor for your split-plot design, or hard and very-hard-to-change factors for your split-split-plot design. Then you can enter one or two positive numbers for the variance ratios, depending on whether you have specified a split-plot or a split-split-plot design.

**Prior Parameter Variance**  (Available only when the Model outline is available.) Specifies the weights that are used for factors whose Estimability is set to If Possible. The option is updated to show the default weights when you click Make Design. Enter a positive number for each of the terms for which you want to specify a weight. The value that you enter is the square root of the reciprocal of the prior variance. A larger value represents a smaller variance and therefore more prior information that the effect is not active.

Bayesian D- or I-optimality is used in constructing designs with If Possible factors. The default values used in the algorithm are 0 for Necessary terms, 4 for interactions involving If Possible terms, and 1 for If Possible terms. See “The Alias Matrix” and “Optimality Criteria”.

**A- Optimality Parameter Weights**  (Use for A-Optimal designs.) Specifies weights for the model parameters. This enables you to place more weight on the variance of the main effects over say 2nd order effects. For more information about parameter weights see Morgan and Stallings (2017).

**D Efficiency Weight**  Specifies the relative importance of D-efficiency to alias optimality in constructing the design. Select this option to balance reducing the variance of the coefficients with obtaining a desirable alias structure. Values should be between 0 and 1. Larger values give more weight to D-Efficiency. The default value is 0.5. This option has an effect only when you select Make Alias Optimal Design as your Optimality Criterion.

For the definition of D-efficiency, see “Optimality Criteria”. For more information about alias optimality, see “Alias Optimality”.

**Save Script to Script Window**  Creates the script for the design that you specified in the Custom Design window and places it in an open script window.
Additional Examples of Augmentation Choices

- “Replicate a Design”
- “Add Center Points to a Design”
- “Create a Foldover Design”
- “Add Axial Points to a Design”
- “Space Filling Augmentation”

Replicate a Design

Augment a design with replication for a direct check on the assumption that the error variance is constant. Replication also reduces the variability of the regression coefficients in the presence of large process or measurement variability.

This example replicates an 8 run design.

1. Select Help > Sample Data Library and open Design Experiment/Reactor 8 Runs.jmp.
2. Select DOE > Augment Design.
3. Select Percent Reacted and click Y, Response.
4. Select Feed Rate, Catalyst, Stir Rate, Temperature, and Concentration and click X, Factor.
5. Click OK.

Figure 6.12 Choose an Augmentation Type

6. Select Group new runs into separate block to add a blocking variable to the design.
7. Click Replicate, enter 2, and then click OK.

Note: The replicate dialog box asks for the number of times each run is to be performed. Entering 2 specifies that you want each run to appear twice in the resulting design. This results in a single replicate of your original design.
Figure 6.13 Reactor Data Design Augmented with a Replicate

<table>
<thead>
<tr>
<th>Run</th>
<th>Feed Rate</th>
<th>Catalyst</th>
<th>Stir Rate</th>
<th>Temperature</th>
<th>Concentration</th>
<th>Block</th>
<th>Block</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>15</td>
<td>2</td>
<td>100</td>
<td>140</td>
<td>3</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>10</td>
<td>2</td>
<td>120</td>
<td>140</td>
<td>6</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>15</td>
<td>1</td>
<td>120</td>
<td>140</td>
<td>3</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>10</td>
<td>2</td>
<td>100</td>
<td>180</td>
<td>3</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>10</td>
<td>1</td>
<td>120</td>
<td>180</td>
<td>3</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>10</td>
<td>1</td>
<td>100</td>
<td>140</td>
<td>6</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>15</td>
<td>2</td>
<td>120</td>
<td>180</td>
<td>6</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>15</td>
<td>1</td>
<td>100</td>
<td>180</td>
<td>6</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>15</td>
<td>2</td>
<td>100</td>
<td>140</td>
<td>3</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>2</td>
<td>120</td>
<td>140</td>
<td>6</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>15</td>
<td>1</td>
<td>120</td>
<td>140</td>
<td>3</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>10</td>
<td>2</td>
<td>100</td>
<td>180</td>
<td>3</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>10</td>
<td>1</td>
<td>120</td>
<td>180</td>
<td>3</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>10</td>
<td>1</td>
<td>100</td>
<td>140</td>
<td>6</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>15</td>
<td>2</td>
<td>120</td>
<td>180</td>
<td>6</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>15</td>
<td>1</td>
<td>100</td>
<td>180</td>
<td>6</td>
<td>2</td>
<td></td>
</tr>
</tbody>
</table>

The original 8 runs are in Block 1 and the replicated runs are in Block 2.

**Note:** The full design can be evaluated from the Augment Design Platform. For more information about design evaluation, see “Evaluate Designs”.

8. Click **Make Table**.

Figure 6.14 The Replicated Design

<table>
<thead>
<tr>
<th>Feed Rate</th>
<th>Catalyst</th>
<th>Stir Rate</th>
<th>Temperature</th>
<th>Concentration</th>
<th>Block</th>
<th>Percent Reacted</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>15</td>
<td>2</td>
<td>100</td>
<td>140</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>10</td>
<td>2</td>
<td>120</td>
<td>140</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>15</td>
<td>1</td>
<td>120</td>
<td>140</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>10</td>
<td>2</td>
<td>100</td>
<td>180</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>10</td>
<td>1</td>
<td>120</td>
<td>180</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>10</td>
<td>1</td>
<td>100</td>
<td>140</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>7</td>
<td>15</td>
<td>2</td>
<td>120</td>
<td>180</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>15</td>
<td>1</td>
<td>100</td>
<td>180</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>15</td>
<td>2</td>
<td>100</td>
<td>140</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>2</td>
<td>120</td>
<td>140</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>11</td>
<td>15</td>
<td>1</td>
<td>120</td>
<td>140</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>12</td>
<td>10</td>
<td>2</td>
<td>100</td>
<td>180</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>13</td>
<td>10</td>
<td>1</td>
<td>120</td>
<td>180</td>
<td>3</td>
<td>1</td>
</tr>
<tr>
<td>14</td>
<td>10</td>
<td>1</td>
<td>100</td>
<td>140</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>15</td>
<td>15</td>
<td>2</td>
<td>120</td>
<td>180</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>16</td>
<td>15</td>
<td>1</td>
<td>100</td>
<td>180</td>
<td>6</td>
<td>1</td>
</tr>
</tbody>
</table>

The table includes the original design and results in Block 1. The augmented runs are in Block 2. The percent reacted values can be added to the table after the augmented runs have been measured.
Add Center Points to a Design

Augment a design with center points to check for curvature and reduce the prediction error in the center of the factor region. Center points are usually replicated points that allow for an independent estimate of pure error, which can be used in a lack-of-fit test.

This example adds two center points to an 8-run design.

1. Select Help > Sample Data Library and open Design Experiment/Reactor 8 Runs.jmp.
2. Select DOE > Augment Design.
3. Select Percent Reacted and click Y, Response.
4. Select Feed Rate, Catalyst, Stir Rate, Temperature, and Concentration and click X, Factor.
5. Click OK.
6. Select Group new runs into separate block to add a blocking variable to the design.
7. Click Add Centerpoints, enter 2, and then click OK.
8. Click Make Table.

Figure 6.15 Design with Two Center Points Added

After data has been collected for the two center runs you can then test for curvature in your model.

Create a Foldover Design

Augment a design with a foldover to remove the confounding of two-factor interactions and main effects. A foldover design is especially useful as a follow-up to saturated or near-saturated fractional factorial or Plackett-Burman designs.

This example creates a foldover design of an 8-run design.

1. Select Help > Sample Data Library and open Design Experiment/Reactor 8 Runs.jmp.
2. Select DOE > Augment Design.
3. Select Percent Reacted and click Y, Response.
4. Select Feed Rate, Catalyst, Stir Rate, Temperature, and Concentration and click X, Factor.
5. Click OK.
6. Select Group new runs into separate block to add a blocking variable to the design.
7. Click Fold Over and then click OK.

In the fold over dialog box, if you select no factors, then all design factors are included in the fold over. If you choose a subset of factors to fold over, the remaining factors are replicates of the original runs.

**Figure 6.16** Foldover Design on All Factors

<table>
<thead>
<tr>
<th>Factor Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run</td>
</tr>
<tr>
<td>-----</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td>13</td>
</tr>
<tr>
<td>14</td>
</tr>
<tr>
<td>15</td>
</tr>
<tr>
<td>16</td>
</tr>
</tbody>
</table>

8. Click Make Table.

Each run in Block 2 can be obtained by changing the factor levels (from low to high or from high to low) of a run from Block 1.

**Add Axial Points to a Design**

Augment a design with axial and center points to augment a screening design in order to obtain a response surface design. This enables you to fit a response surface model to your data to optimize the settings of your factors with respect to your response.

This example augments an 8 run screening design with axial and center points.
1. Select Help > Sample Data Library and open Design Experiment/Reactor 8 Runs.jmp.
2. Select DOE > Augment Design.
3. Select Percent Reacted and click Y, Response.
4. Select Feed Rate, Catalyst, Stir Rate, Temperature, and Concentration and click X, Factor.
5. Click OK.
6. Select Group new runs into separate block to add a blocking variable to the design.
7. Click **Add Axial**, enter 1 for axial value, 2 for number of center points, and then click **OK**.
8. Click **Make Table**.
9. From the Augmented Design table, select **Rows > Color or Mark by Column**.
10. Select Block, from Markers select **Standard**, and then click **OK**.
11. Select **Graph > Graph Builder**.
12. Drag Feed Rate to Y and drag Catalyst to X. Then click the smoother icon to remove.

**Figure 6.17** Graphical View of the Augmented Design for Two Factors

The “+” points in the graph of Feed Rate versus Catalyst are the added axial and center points. The axial points are on the face of the design space. Increasing or decreasing the axial value in the augmentation of the design would move the axial points beyond or within the design space.

**Space Filling Augmentation**

Augment a design with space filling to add points to a design consisting of continuous factors. The Space Filling choice accommodates constraints on the design space. You can specify linear constraints or disallowed combinations. For more information about the algorithm used, see “**Statistical Details**”.
This example augments a design to explore a constrained area of the design space where the response, Depth, was maximized, with added constraints on both factors.

1. Select **Help > Sample Data Library** and open Design Experiment/DOE Example 1.jmp.
2. Select **DOE > Augment Design**.
3. Select Depth and click **Y, Response**.
4. Select Speed and Current, click **X, Factor**, and then click **OK**.
5. Open the Define Factor Constraints outline.
6. Select **Specify Linear Constraints** and click **Add**.
7. Enter 1 for Speed, select greater than or equal to, and then enter 4 for the lower bound on Speed.
8. Click **Add**.
9. Enter 1 for Current, select greater than or equal to, and then enter 155 for the lower bound on Current.
10. Click **Space Filling**.
11. Enter 10 and click **OK**.
12. Click **Make Table**.
13. From the Augmented Design table, select Graph Builder.
14. Drag Speed to the X drop zone and drag Current to the Y drop zone.

**Figure 6.18** Space Filling Augmented Runs
The augmented runs fill the space in the upper right corner of the design space. This is the constrained design space.

**Statistical Details**

This section contains statistical details about the algorithm used to select points for the space-filling augmentation choice.

The algorithm that is used to augment designs begins by generating a large number of random points within the specified design region. These points are then clustered using a Fast Ward algorithm into a number of clusters that equals the Number of Additional Runs that you specify.

The final design points are obtained by optimizing the MaxPro (maximum projection) criterion over the existing and additional runs. For $p$ factors and $n$ equal to the number of existing and additional runs, the MaxPro criterion strives to find points in the clusters that minimize the following criterion:

$$
C_{MaxPro} = \sum_{i}^{n-1} \sum_{j=i+1}^{n} \left[ \frac{1}{p} \prod_{k=1}^{p} (x_{ik} - x_{jk})^2 \right]
$$

The MaxPro criterion maximizes the product of the distances between design points in a way that involves all factors. This supports the goal of providing good space-filling properties on projections of factors. See Joseph et al. (2015).
Definitive screening designs (DSD) are screening designs. They are appropriate for early stage experimentation work, typically with four or more factors. DSD can be used for combinations of continuous or two-level categorical factors. They work best when most of the factors are continuous. Each continuous factor has three levels allowing one to investigate quadratic model terms for continuous factors.

Here are areas where definitive screening designs are superior to standard screening designs:

- They help identify the causes of nonlinear effects by fielding each continuous factor at three levels. In standard screening designs, continuous factors have only two levels. You can add center points to screening designs, but these points establish only if curvature exists. They do not allow you to identify the factors responsible for quadratic effects.

- They avoid confounding between any effects up through the second order. For continuous factors, definitive screening designs have main effects that are orthogonal to each other and orthogonal to two-factor interactions and quadratic effects. Two-factor interactions are not completely confounded with each other. Confounding occurs in many standard screening designs with a similar number of runs.

- They avoid the need for costly additional experimentation to resolve ambiguity from the initial results of standard screening designs.

**Figure 7.1** Plot of Response against Factor Values Showing Curvature
Contents

Overview of Definitive Screening Design .................................................. 241
Examples of Definitive Screening Designs ................................................. 243
  Definitive Screening Design ................................................................. 244
  Comparison with a Fractional Factorial Design .................................... 246
  Definitive Screening Design with Blocking .......................................... 248
  Comparison of a Definitive Screening Design with a Plackett-Burman Design ...... 252
Definitive Screening Design Window ...................................................... 255
  Responses ...................................................................................... 256
  Factors ......................................................................................... 258
  Design Options .............................................................................. 260
  Design .......................................................................................... 262
  Design Evaluation ......................................................................... 262
  Output Options ............................................................................. 263
Definitive Screening Design Options ......................................................... 265
  Simulate Responses ....................................................................... 267
Technical Details .................................................................................... 270
  Structure of Definitive Screening Designs ............................................ 270
  Analysis of Experimental Data ........................................................... 272
Overview of Definitive Screening Design

Investigators use screening designs when they want to identify the factors that have the most substantial effects on a response. A screening design enables you to study a large number of factors in a fairly small experiment.

Many standard screening designs focus on estimating main effects. Definitive screening designs offer advantages over standard screening designs. They avoid confounding of effects and can identify factors having a nonlinear effect on the response. For more information about the advantages and construction of definitive screening designs, see Jones and Nachtsheim (2011a).

For designs containing only continuous factors, compare these properties of definitive screening designs versus standard screening designs:

**Note:** When quadratic effects are mentioned, the standard screening designs are assumed to have center points.

- Main effects are orthogonal to two-factor interactions.
  - Definitive Screening Designs: Always
  - Standard Screening Designs: Only for Resolution IV or higher
- No two-factor interaction is completely confounded with any other two-factor interaction.
  - Definitive Screening Designs: Always
  - Standard Screening Designs: Only for Resolution V or higher
- All quadratic effects are estimable in models containing only main and quadratic effects.
  - Definitive Screening Designs: Always
  - Standard Screening Designs: Never

These properties are described more fully in the remainder of this section.

**Standard Screening Designs**

Standard screening designs, such as fractional factorial or Plackett-Burman designs, attempt to study many factors with a relatively small allocation of resources. However, standard screening designs have several undesirable features:

- They can alias some main effects with two-factor interactions. In Plackett-Burman designs, for example, main effects are correlated with several two-factor interactions. If one or more two-factor interaction effects are substantial, then the experimenter must perform additional runs to resolve the ambiguities.
• They can also confound some two-factor interactions with each other. Consequently, if a two-factor interaction effect is substantial, then the experimenter must perform additional runs to resolve the remaining ambiguities.

• Continuous factors are usually set at only two levels (low and high). However, engineers and scientists often prefer designs where continuous factors are set at three levels (low, middle, and high). This is because two levels are not sufficient to detect nonlinearity, which is common in physical systems. You can use a traditional screening design with added center points to detect nonlinearity, but such a design does not identify the responsible factors.

Definitive Screening Designs

Using definitive screening designs, you can do the following:

• Avoid model ambiguity, enabling you to identify important factors more quickly and efficiently.

• Identify the cause of nonlinear effects while avoiding confounding any terms up to second order. So not only can you detect nonlinearity, as you might with center points in a traditional screening design, but you can identify the responsible factors.

Definitive screening designs offer the following advantages:

• Definitive screening designs require only a small number of runs. For six or more factors, the minimum number of required runs is usually only a few more than twice the number of factors. For more detail on the number of runs, see “Conference Matrices and the Number of Runs”.

• Main effects are orthogonal to two-factor interactions. This means that estimates of main effects are not biased by the presence of active two-factor interactions, whether these interactions are included in the model or not. Note that resolution III screening designs confound some main and interaction effects. Also, Plackett-Burman designs produce biased main effect estimates if there are active two-factor interactions.

• No two-factor interaction is completely confounded with any other two-factor interaction. However, a two-factor interaction might be correlated with other two-factor interactions. Note that resolution IV screening designs completely confound some two-factor interaction effects.

• All quadratic effects are estimable in models comprised only of main effects and quadratic terms. This enables you to identify the factors that account for nonlinearity. Note that traditional screening designs with added center points do not allow estimation of all quadratic effects in models consisting of main and quadratic effects.

• Quadratic effects are orthogonal to main effects and not completely confounded with two-factor interactions. A quadratic effect might be correlated with interaction effects.

• For 6 through at least 30 factors, it is possible to estimate the parameters of any full quadratic model involving three or fewer factors with high precision.
• For 18 factors or more, they can fit full quadratic models in any 4 factors. For 24 factors or more, they can fit full quadratic models in any 5 factors.

**Definitive Screening Design Platform**

The Definitive Screening Design platform enables you to construct definitive screening designs for continuous factors and for two-level categorical factors. It also enables you to construct blocked designs. You can add extra non-center runs that enhance the ability of the design to reliably detect effects when many effects are active.

To view the absolute values of the correlations among effects, use the Color Map on Correlations provided as part of the Design Evaluation outline in the Definitive Screening Design window. You can compare the aliasing structure of definitive screening designs to that of other designs by comparing their color maps on correlations. See “Color Map on Correlations”.

For more information about the structure of definitive screening designs, see “Structure of Definitive Screening Designs”. For information about definitive screening designs with blocks, see “Blocking in Definitive Screening Designs”. For suggestions on how to analyze data obtained using definitive screening designs, see “Analysis of Experimental Data”.

**Fit Definitive Screening Platform**

After you run a Definitive Screening Design (DSD), analyze your results using the Fit Definitive Screening platform. Standard model selection methods applied to DSDs can fail to identify active effects. To identify active main effects and second-order effects, the Fit Definitive Screening platform uses an algorithm called *Effective Model Selection for DSDs*. This algorithm leverages the special structure of DSDs. See “The Fit Definitive Screening Platform”.

If you create your DSD in JMP, the design table contains a script called Fit Definitive Screening that automatically runs an analysis using the Effective Model Selection for DSDs methodology.

---

**Examples of Definitive Screening Designs**

• “Definitive Screening Design”
• “Comparison with a Fractional Factorial Design”
• “Definitive Screening Design with Blocking”
• “Comparison of a Definitive Screening Design with a Plackett-Burman Design”
Definitive Screening Design

Suppose that you need to determine which of six factors have an effect on the yield of an extraction process.

Create the Design

The factors and their settings are given in the data table Extraction Factors.jmp. You create a definitive screening design to investigate.

1. Select **DOE > Definitive Screening > Definitive Screening Design**.
2. Double-click **Y** under Response Name and type **Yield**.
3. Select **Help > Sample Data Library** and open **Design Experiment/Extraction Factors.jmp**.
4. Click the red triangle next to Definitive Screening Design and select **Load Factors**
   The factor names and ranges are added to the Factors outline.

![Figure 7.2 Responses and Factors for Extraction Design](image)

5. Click **Continue**.

   The Design Options outline opens. Here you can specify a blocking structure. There is no need to block in this example, so you accept the default selection of **No Blocks Required**.

   You can also choose to add Extra Runs, which greatly enhance your ability to detect second-order effects. A minimum of four Extra Runs is highly recommended and is the default.

6. Click **Make Design**.
The Definitive Screening Design window updates to show a Design outline and a Design Evaluation outline.

**Figure 7.3 Design Outline**

<table>
<thead>
<tr>
<th>Run</th>
<th>Methanol</th>
<th>Ethanol</th>
<th>Propanol</th>
<th>Butanol</th>
<th>pH</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>5</td>
<td>10</td>
<td>10</td>
<td>10</td>
<td>9</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>5</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>10</td>
<td>5</td>
<td>0</td>
<td>0</td>
<td>10</td>
<td>6</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>5</td>
<td>0</td>
<td>0</td>
<td>9</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>10</td>
<td>0</td>
<td>5</td>
<td>10</td>
<td>9</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
<td>10</td>
<td>5</td>
<td>0</td>
<td>6</td>
<td>2</td>
</tr>
<tr>
<td>7</td>
<td>10</td>
<td>0</td>
<td>5</td>
<td>2</td>
<td>9</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>0</td>
<td>10</td>
<td>10</td>
<td>5</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>10</td>
<td>10</td>
<td>0</td>
<td>0</td>
<td>7.5</td>
<td>2</td>
</tr>
<tr>
<td>10</td>
<td>0</td>
<td>0</td>
<td>10</td>
<td>10</td>
<td>7.5</td>
<td>1</td>
</tr>
<tr>
<td>11</td>
<td>10</td>
<td>0</td>
<td>10</td>
<td>0</td>
<td>6</td>
<td>1.5</td>
</tr>
<tr>
<td>12</td>
<td>0</td>
<td>10</td>
<td>0</td>
<td>10</td>
<td>9</td>
<td>1.5</td>
</tr>
<tr>
<td>13</td>
<td>10</td>
<td>10</td>
<td>0</td>
<td>0</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>14</td>
<td>0</td>
<td>0</td>
<td>10</td>
<td>2</td>
<td>9</td>
<td>1</td>
</tr>
<tr>
<td>15</td>
<td>10</td>
<td>10</td>
<td>10</td>
<td>0</td>
<td>9</td>
<td>1</td>
</tr>
<tr>
<td>16</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>10</td>
<td>6</td>
<td>2</td>
</tr>
<tr>
<td>17</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>7.5</td>
<td>1.5</td>
</tr>
</tbody>
</table>

7. Open the **Design Evaluation > Color Map on Correlations** outline.

   The Color Map on Correlations assigns a color intensity scale to the absolute values of correlations among all main effects and two-factor interactions.

**Figure 7.4 Color Map on Correlations for Extraction Design**
Note the following:

- The solid white area shows that there is no correlation between main effects or between main effects and two-factor interactions.
- The shaded gray areas indicate that the absolute correlations between two-factor interactions are small.
- The black squares indicate absolute correlations of 1. These all appear on the diagonal, reflecting the expected correlation of an effect with itself.

In the Output Options panel, note that the Run Order is set to Randomize.

8. Click Make Table to obtain the data table shown in Figure 7.5.

Note: The runs in your design might appear in a different order than the order shown in Figure 7.5.

Comparison with a Fractional Factorial Design

Suppose that you had chosen a traditional screening design instead of the definitive screening design in “Definitive Screening Design”. This example compares the two designs in terms of confounding.

1. Select DOE > Classical > Two Level Screening > Screening Design.
2. Double-click Y under Response Name and type Yield.
4. Click the red triangle next to and select Load Factors.
   The factor names and ranges are added to the Factors outline.
5. Click **Continue**.

6. Select **Choose from a list of fractional factorial designs**.

7. Click **Continue**.


**Figure 7.6** Screening Design List for Six Continuous Factors

8. Select the sixteen-run fractional factorial design with no blocks, shown highlighted in **Figure 7.6**.

9. Click **Continue**.

10. Open the **Display and Modify Design > Aliasing of Effects** outline.

**Figure 7.7** Aliasing of Effects for Fractional Factorial Design

The Aliasing of Effects outline for the 16-run fractional factorial design shows that every two-factor interaction is confounded with at least one other two-factor interaction. In this fractional factorial design, the **Ethanol**\(^*\)Time interaction is confounded with **Methanol**\(^*\)pH. To determine which interaction is active, you need to run additional trials. If the factors had been entered in a different order, the **Ethanol**\(^*\)Time interaction might have been aliased with two other two-factor interactions.
In the section “Definitive Screening Design”, you constructed a 17-run definitive screening design. The Color Map on Correlations for this DSD (Figure 7.4) shows that no two-factor interactions are confounded with any other two-factor interactions. For the fractional factorial design, there are seven instances of confounded two-factor interactions. If you suspect that there are active two-factor effects, the DSD is the better choice.

You can conduct a more thorough comparison of the two designs using the Compare Designs platform (DOE > Design Diagnostics > Compare Designs). See “Compare Designs”.

**Definitive Screening Design with Blocking**

Suppose that, due to raw material constraints, the extraction experiment requires that you run it using material from two separate lots. You can generate a definitive screening design with a blocking variable to account for the potential lot variation.

**Create the Design**

The extraction factors and their settings are given in the data table Extraction Factors.jmp. Generate a definitive screening design with a block:

1. Select **DOE > Definitive Screening > Definitive Screening Design**.
2. Double-click **Y** under Response Name and type **Yield**.
3. Select **Help > Sample Data Library** and open Design Experiment/Extraction Factors.jmp.
4. Click the red triangle next to Definitive Screening Design and select **Load Factors**.
   - The factor names and ranges are added to the Factors outline.
5. Click **Continue**.
   - The Design Options outline opens. Here you can specify a blocking structure.
6. Select **Add Blocks with Center Runs to Estimate Quadratic Effects**.
   - Leave **Number of Blocks** set at 2.
   - You are recreating the design for the Extraction2 Data.jmp sample data table, which was created without Extra Runs. Although four Extra Runs are strongly recommended, you will not add Extra Runs in this example.
7. Next to **Number of Extra Runs**, select 0.
8. Click **Make Design**.
   - The Definitive Screening Design window updates to show a Design outline and a Design Evaluation outline.
   - Check that **Block** has been added to the Factors outline and to the Design.
9. In the Factors outline, Double-click **Block** and type **Lot**.
   - In the Output Options panel, note that the Run Order is set to Randomize within Blocks.
10. Click **Make Table**.

**Note:** The runs in your design might appear in a different order than the order shown in Figure 7.8.

**Figure 7.8** Definitive Screening Design with Block for Extraction Process

<table>
<thead>
<tr>
<th>Lot</th>
<th>Methanol</th>
<th>Ethanol</th>
<th>Propanol</th>
<th>Butanol</th>
<th>pH</th>
<th>Time</th>
<th>Yield</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>7.5</td>
<td>1.5</td>
<td>•</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>5</td>
<td>10</td>
<td>10</td>
<td>9</td>
<td>2</td>
<td>•</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>5</td>
<td>0</td>
<td>0</td>
<td>6</td>
<td>1</td>
<td>•</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>10</td>
<td>0</td>
<td>5</td>
<td>9</td>
<td>2</td>
<td>•</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>10</td>
<td>7.5</td>
<td>2</td>
<td>•</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>0</td>
<td>10</td>
<td>5</td>
<td>10</td>
<td>6</td>
<td>1</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>10</td>
<td>10</td>
<td>10</td>
<td>7.5</td>
<td>1</td>
<td>•</td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>10</td>
<td>5</td>
<td>0</td>
<td>10</td>
<td>9</td>
<td>•</td>
</tr>
<tr>
<td>9</td>
<td>2</td>
<td>10</td>
<td>0</td>
<td>0</td>
<td>9</td>
<td>1.5</td>
<td>•</td>
</tr>
<tr>
<td>10</td>
<td>2</td>
<td>0</td>
<td>10</td>
<td>5</td>
<td>9</td>
<td>1</td>
<td>•</td>
</tr>
<tr>
<td>11</td>
<td>2</td>
<td>10</td>
<td>0</td>
<td>10</td>
<td>6</td>
<td>1.5</td>
<td>•</td>
</tr>
<tr>
<td>12</td>
<td>2</td>
<td>0</td>
<td>5</td>
<td>10</td>
<td>6</td>
<td>2</td>
<td>•</td>
</tr>
<tr>
<td>13</td>
<td>2</td>
<td>10</td>
<td>10</td>
<td>0</td>
<td>5</td>
<td>6</td>
<td>2</td>
</tr>
<tr>
<td>14</td>
<td>2</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>7.5</td>
<td>1.5</td>
<td>•</td>
</tr>
</tbody>
</table>

Notice that run 1 is a center point run in Lot 1 and run 14 is a center point run in Lot 2.

**Analyze the Experimental Data**

At this point, you conduct your experiment and record your data in the **Yield** column of the design table (Figure 7.8). The Extraction2 Data.jmp sample data table contains your experimental results. The runs in the Extraction2 Data.jmp sample data table are in a different order than those in Figure 7.8.

To explore all second-order effects, one option is to use All Possible Models regression. Another option is to use forward stepwise regression. However, these standard methods often fail to identify active effects. For this reason, you use the Fit Definitive Screening platform.

1. Select **Help > Sample Data Library** and open Design Experiment/Extraction2 Data.jmp.
2. In the Table panel of the design table, click the green triangle next to the **Fit** Definitive Screening script.
The effects identified by Fit Definitive Screening as potentially active are listed in the Combined Model Parameter Estimates report.

3. Click the Run Model button at the bottom of the Combined Model Parameter Estimates report.

This fits a standard least squares model to the effects identified as potentially active.
Figure 7.10  Standard Least Squares Report

The Actual by Predicted Plot shows no evidence of lack of fit. The Effect Summary report shows that Methanol*Ethanal and Methanol*Methanol are not significant. You decide to remove these effects from the model.


Figure 7.11  Final Set of Active Effects

The remaining effects are all significant. You conclude that these are the active effects.
Comparison of a Definitive Screening Design with a Plackett-Burman Design

Plackett-Burman designs are an alternative to fractional factorials for screening. However, Plackett-Burman designs have complex aliasing of the main effects by two-factor interactions.

This example shows how to compare a definitive screening with a Plackett-Burman design using the Evaluate Design platform. For an extensive example using the Compare Designs platform, see “Designs of Same Run Size”.

The Definitive Screening Design

1. Select **DOE > Definitive Screening > Definitive Screening Design**.
2. Type 4 in the **Add N Factors** box and click **Continuous**.
3. Type 2 in the **Add N Factors** box and click **Categorical**.
   
   Your window should appear as shown in Figure 7.12.

**Figure 7.12** Definitive Screening Dialog with 4 Continuous and 2 Categorical Factors

4. Click **Continue**.
   
   This example does not require a block. Under the Design Options Outline, check that the No Blocks Required option is selected.
   
   In order to compare designs of approximately equal sizes, do not add Extra Runs.
5. Next to **Number of Extra Runs**, select 0.
6. Click **Make Design**.
   The design that is generated has 14 runs.

7. Open the **Design Evaluation > Color Map On Correlations** outline.

**Figure 7.13** Color Map for Definitive Screening Design

Notice that the categorical main effects have small correlations with each other and with the continuous factors’ main effects. These correlations lead to a small reduction in the precision of the estimates.

8. Do not close your Definitive Design Screening window until you compare the color map with that of the Plackett-Burman design, below.

**The Plackett-Burman Design**

Now create a Plackett-Burman design using the same factor structure.

1. Select **DOE > Classical > Two Level Screening > Screening Design**.
2. Type **4** in the **Add N Factors** box and click **Continuous**.
3. Type **2** in the **Add N Factors** box and click **Categorical > 2 Level**.
4. Click **Continue**.
5. Select **Choose from a list of fractional factorial designs** and click **Continue**.
6. Select the 12 run Plackett-Burman design (Figure 7.14).
7. Click Continue.
   Compare the color map for the 12-run Plackett-Burman design to the color map for the 14-run definitive screening design.
**Figure 7.15** Plackett-Burman Correlations (left) and Definitive Screening Correlations (right)

**Figure 7.15** shows both color maps, but shows only the portion of the Plackett-Burman color map that involves main effects and two-way interactions. (To construct the color map for the Plackett-Burman design without the three-way interactions, construct the design. Then obtain the color map using Evaluate Design.)

In the color map for the Plackett-Burman design on the left, you see that most two-factor interactions are correlated with main effects. This means that any non-negligible two-factor interaction will bias several main effects. This can lead to a failure to identify an active main effect or the false conclusion that an inactive main effect is active.

Contrast this with the color map for the definitive screening design on the right. With only two additional runs, the definitive screening design trades off a small increase in the variance of the main effects for complete independence of main effects and two-factor interactions.

---

**Definitive Screening Design Window**

The definitive screening design window updates as you work through the design steps. See “The DOE Workflow: Describe, Specify, Design”. The outlines, separated by buttons that update the outlines, follow the flow in **Figure 7.16**.

**Figure 7.16** Definitive Screening Design Flow
Responses

Use the Responses outline to specify one or more responses.

**Tip:** When you have completed the Responses outline, consider selecting **Save Responses** from the red triangle menu. This option saves the response names, goals, limits, and importance values in a data table that you can later reload in DOE platforms.

**Figure 7.17** Responses Outline

<table>
<thead>
<tr>
<th>Responses</th>
<th>Add Response</th>
<th>Remove</th>
<th>Number of Responses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Response Name</td>
<td>Goal</td>
<td>Lower Limit</td>
<td>Upper Limit</td>
</tr>
<tr>
<td>Y</td>
<td>Maximize</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Add Response** Enters a single response with a goal type of Maximize, Match Target, Minimize, None, or Functional. If you select Match Target, enter limits for your target value. If you select Maximize or Minimize, entering limits is not required but can be useful if you intend to use desirability functions.

**Functional** (Available only in JMP Pro.) Adds multiple Y columns with FDE column properties to the design data table. These columns can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.

**Remove** Removes the selected responses.

**Number of Responses** Enters additional responses so that the number that you enter is the total number of responses. If you have entered a response other than the default Y, the Goal for each of the additional responses is the Goal associated with the last response entered. Otherwise, the Goal defaults to Match Target. Click the Goal type in the table to change it.

The Responses outline contains the following columns:

**Response Name** The name of the response. When added, a response is given a default name of Y, Y2, and so on. To change this name, double-click it and enter the desired name.

**Goal, Lower Limit, Upper Limit** The Goal tells JMP that you want to maximize or minimize your response, match a target, or that you have no goal for your response. JMP assigns a Response Limits column property, based on these specifications, to each response column in the design table. It uses this information to define a desirability function for each response. The Profiler and Contour Profiler use these desirability functions to find optimal factor settings. For further details, see the Profiler chapter in *Profilers* and “Response Limits”. 
– A Goal of Maximize indicates that the best value is the largest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

– A Goal of Minimize indicates that the best value is the smallest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

– A Goal of Match Target indicates that the best value is a specific target value. The default target value is assumed to be midway between the Lower Limit and Upper Limit.

– A Goal of None indicates that there is no goal in terms of optimization. No desirability function is constructed.

**Note:** If your target response is not midway between the Lower Limit and the Upper Limit, you can change the target after you generate your design table. In the data table, open the Column Info window for the response column (Cols > Column Info) and enter the desired target value.

**Importance** When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for the responses. If there is only one response, then specifying the Importance is unnecessary because it is set to 1 by default.

**Detection Limits** The lower and upper detection limits are bounds beyond which the response cannot be measured. The detection limits are saved as a column property. You can use these limits to specify a censored response in the Generalized Regression platform. See the Generalized Regression chapter in *Fitting Linear Models*.

**Editing the Responses Outline**

In the Responses outline, note the following:

- Double-click a response to edit the response name.
- Click the goal to change it.
- Click on a limit or importance weight to change it.
- For multiple responses, you might want to enter values for the importance weights.
Response Limits Column Property

The Goal, Lower Limit, Upper Limit, and Importance that you specify when you enter a response are used in finding optimal factor settings. For each response, the information is saved in the generated design data table as a Response Limits column property. JMP uses this information to define the desirability function. The desirability function is used in the Prediction Profiler to find optimal factor settings. For further details about the Response Limits column property and examples of its use, see “Response Limits”.

If you do not specify a Lower Limit and Upper Limit, JMP uses the range of the observed data for the response to define the limits for the desirability function. Specifying the Lower Limit and Upper Limit gives you control over the specification of the desirability function. For more details about the construction of the desirability function, see the Profiler chapter in Profilers.

Factors

Add factors in the Factors outline.

Figure 7.18 Factors Outline

The factors outline contains the following buttons.

Continuous Enters the number of continuous factors specified in Add N Factors.

Categorical Enters the number of nominal factors specified in Add N Factors.

Remove Removes the selected factors.

Add N Factors Adds multiple factors of a given type. Enter the number of factors to add and click Continuous or Categorical. Repeat Add N Factors to add multiple factors of different types.

Tip: When you have completed your Factors panel, select Save Factors from the red triangle menu. This saves the factor names and values in a data table that you can later reload. See “Definitive Screening Design Options”.
The Factors outline contains the following columns:

**Name**  The name of the factor. When added, a factor is given a default name of X1, X2, and so on. To change this name, double-click it and enter the desired name.

**Role**  Specifies the Design Role of the factor. The Design Role column property for the factor is saved to the data table. This property ensures that the factor type is modeled appropriately.

**Values**  The experimental settings for the factors. To insert Values, click the default values and type the desired values.

**Editing the Factors Outline**

In the Factors outline, note the following:

- To edit a factor name, double-click the factor name.
- To edit a value, click the value in the Values column.

**Factor Types**

**Continuous**  Numeric data types only. A continuous factor is a factor that you can conceptually set to any value between the lower and upper limits you supply, given the limitations of your measurement system.

**Categorical**  Either numeric or character data types with two levels. For a categorical factor, the value ordering is the order of the values, as entered from left to right. This ordering is saved in the Value Order column property after the design data table is created.

**Factor Column Properties**

For each factor, various column properties are saved to the data table.

**Design Role**  Each factor is assigned the Design Role column property. The Role that you specify in defining the factor determines the value of its Design Role column property. When you add a block under Design Options, that factor is assigned the Blocking value. The Design Role property reflects how the factor is intended to be used in modeling the experimental data. Design Role values are used in the Augment Design platform.

**Factor Changes**  Each factor is assigned the Factor Changes column property with a setting of Easy. In definitive screening designs, it is assumed that factor levels can be changed for each experimental run. Factor Changes values are used in the Evaluate Design and Augment Design platforms.

**Coding**  If the Design Role is Continuous, the Coding column property for the factor is saved. This property transforms the factor values so that the low and high values correspond to –
1 and +1, respectively. The estimates and tests in the Fit Least Squares report are based on the transformed values.

**Value Order**  If the Design Role is Categorical or Blocking, the Value Order column property for the factor is saved. This property determines the order in which levels of the factor appear.

**RunsPerBlock**  Indicates the number of runs in each block. When a Block is selected in the Design Options outline and you then click Make Design, a factor with the default name Block is added to the Factors list. The RunsPerBlock column property is saved for that factor.

### Design Options

The Design Options outline enables you to specify the blocking structure, the number of blocks, and the number of extra runs. Block effects are orthogonal to the main effects. Block sizes need not be equal.

The outline contains the following options:

**No Blocks Required**  Indicates that the design will not contain a blocking factor. This is the default selection.

**Add Blocks with Center Runs to Estimate Quadratic Effects**  Adds the number of blocks specified in the Number of Blocks text box. Constructs a design where block effects are orthogonal to main effects and where the model consisting of all main and quadratic effects is estimable. See “Add Blocks with Center Runs to Estimate Quadratic Effects”

**Add Blocks without Extra Center Runs**  Adds the number of blocks specified in the Number of Blocks text box. Adds only as many center runs as required by the design structure. Constructs a design where block effects are orthogonal to main effects, but the model consisting of all main effects and quadratic effects might not be estimable. See “Add Blocks without Extra Center Runs”.

**Note:** Use the **Add Blocks without Extra Center Runs** option only if you can assume that not all quadratic effects are important.

**Number of Blocks**  Indicates the number of blocks to add. The number of blocks that you can add ranges from two to the number of factors.

**Number of Extra Runs**  Adds non-center runs that enable you to conduct effective model selection. See “Extra Runs” and “Effective Model Selection for DSDs”.

- \[
  1 \text{ and } +1, \text{ respectively. The estimates and tests in the Fit Least Squares report are based on the transformed values.}
  
  \textbf{Value Order} \quad \text{If the Design Role is Categorical or Blocking, the Value Order column property for the factor is saved. This property determines the order in which levels of the factor appear.}
  
  \textbf{RunsPerBlock} \quad \text{Indicates the number of runs in each block. When a Block is selected in the Design Options outline and you then click Make Design, a factor with the default name Block is added to the Factors list. The RunsPerBlock column property is saved for that factor.}
  
  \textbf{Design Options}
  
  The Design Options outline enables you to specify the blocking structure, the number of blocks, and the number of extra runs. Block effects are orthogonal to the main effects. Block sizes need not be equal.

  The outline contains the following options:

  \textbf{No Blocks Required} \quad \text{Indicates that the design will not contain a blocking factor. This is the default selection.}

  \textbf{Add Blocks with Center Runs to Estimate Quadratic Effects} \quad \text{Adds the number of blocks specified in the Number of Blocks text box. Constructs a design where block effects are orthogonal to main effects and where the model consisting of all main and quadratic effects is estimable. See “Add Blocks with Center Runs to Estimate Quadratic Effects”}

  \textbf{Add Blocks without Extra Center Runs} \quad \text{Adds the number of blocks specified in the Number of Blocks text box. Adds only as many center runs as required by the design structure. Constructs a design where block effects are orthogonal to main effects, but the model consisting of all main effects and quadratic effects might not be estimable. See “Add Blocks without Extra Center Runs”.}

  \textbf{Note:} Use the **Add Blocks without Extra Center Runs** option only if you can assume that not all quadratic effects are important.

  \textbf{Number of Blocks} \quad \text{Indicates the number of blocks to add. The number of blocks that you can add ranges from two to the number of factors.}

  \textbf{Number of Extra Runs} \quad \text{Adds non-center runs that enable you to conduct effective model selection. See “Extra Runs” and “Effective Model Selection for DSDs”.}
Tip: Adding runs to your design with the Extra Runs option enhances your ability to detect effects in the presence of many active effects. The recommended number of Extra Runs is four, which dramatically improves the power of the design to identify active second-order effects.

Make Design  Generates the design, presents it in the Design outline, and provides evaluation information in the Design Evaluation outline. The Output Options panel also appears, enabling you to create the design table.

Blocking in Definitive Screening Designs

This section describes the two blocking options:

- “Add Blocks with Center Runs to Estimate Quadratic Effects”
- “Add Blocks without Extra Center Runs”

Add Blocks with Center Runs to Estimate Quadratic Effects

Note: For more information about the construction and properties of blocked designs that estimate quadratic effects, see Jones and Nachtsheim (2016). The paper also contains information about treating the blocks as random effects.

The Add Blocks with Center Runs to Estimate Quadratic Effects option constructs a design with these properties:

- Block effects are orthogonal to main effects.
- The model consisting of all main and quadratic effects is estimable.

If a design contains only continuous factors, a blocked design for \( k \) factors having these properties can be constructed:

- Remove the center run from the DSD design for \( k \) factors.
- Assign conference matrix foldover pairs to the same block.
- Add one center run to each block.

When some factors are categorical, the Add Blocks with Center Runs to Estimate Quadratic Effects option adds pairs of center runs within certain blocks. This structure ensures orthogonality and the ability to estimate all main and quadratic effects.

Because the only requirement on block size is that a block contains a foldover pair, the number of blocks can range from 2 to \( k \), if \( k \) is even and from 2 to \( k+1 \), if \( k \) is odd. See “Conference Matrices and the Number of Runs”. JMP attempts to construct blocks of equal size.
Add Blocks without Extra Center Runs

The **Add Blocks without Extra Center Runs** option constructs a design that has a single center run when all factors are continuous and two center runs when some factors are categorical. The resulting design has these properties:

- Block effects are orthogonal to main effects.
- Block effects might be confounded with a linear combination of quadratic effects. This implies that the model consisting of all main and quadratic effects might *not* be estimable.

For this reason, use this option only if you can assume that some quadratic effects are negligible.

Construct a blocked design for \( k \) factors without extra center runs:

- Assign conference matrix foldover pairs to the same block.
- If all factors are continuous, assign the single center run to a single block.
- If there are categorical factors, the unblocked definitive screening design requires the addition of two center runs to the foldover pairs defined by the conference matrix. See “Conference Matrices and the Number of Runs”. To construct the blocked design without extra center runs, these two center runs are added to a single block.

Because the only requirement on block size is that a block contains a foldover pair, the number of blocks can range from 2 to \( k \), if \( k \) is even and from 2 to \( k+1 \), if \( k \) is odd. See “Conference Matrices and the Number of Runs”. JMP attempts to construct blocks of equal size.

**Design**

The Design outline shows the runs for the definitive screening design. The runs are given in a standard order. To change the run order for your design table, you can select Run Order options in the Output Options panel before generating the table.

| Note: | Definitive screening designs for four or fewer factors are based on a five-factor design. See “Definitive Screening Designs for Four or Fewer Factors”. |

**Design Evaluation**

| Note: | The Design Evaluation outline is not shown for Cotter designs. |

The Design Evaluation outline provides a number of ways to evaluate the properties of the generated design. Open the Design Evaluation outline to see the following options:

- **Power Analysis** Enables you to explore your ability to detect effects of given sizes.
**Prediction Variance Profile**  Shows the prediction variance over the range of factor settings.

**Fraction of Design Space Plot**  Shows how much of the model prediction variance lies below (or above) a given value.

**Prediction Variance Surface**  Shows a surface plot of the prediction variance for any two continuous factors.

**Estimation Efficiency**  For each parameter, gives the fractional increase in the length of a confidence interval compared to that of an ideal (orthogonal) design, which might not exist. Also gives the relative standard error of the parameters.

**Alias Matrix**  Gives coefficients that indicate the degree by which the model parameters are biased by effects that are potentially active, but not in the model.

**Color Map on Correlations**  Shows the absolute correlation between effects on a plot using an intensity scale.

**Design Diagnostics**  Indicates the optimality criterion used to construct the design. Also gives efficiency measures for your design.

**Note:** The model used for the design diagnostics contains all main effects and two-factor interactions when all two-factor interactions are estimable. Otherwise, the model contains all main effects.

For more details about the Design Evaluation panel, see “Design Evaluation”.

**Output Options**

Use the Output Options panel to perform the following tasks:

- specify the order for the runs in the design data table
- construct the design table
- return to a previous point in the Definitive Screening Design window

**Figure 7.19  Output Options Panel**

The Output Options panel contains these options:
Run Order

The Run Order options determine the order of the runs in the design table. Choices include the following:

**Keep the Same**  Rows in the design table are in the same order as in the Design outline.

**Sort Left to Right**  Columns in the design table are sorted from left to right.

**Randomize**  Rows in the design table are in random order.

**Sort Right to Left**  Columns in the design table are sorted from right to left.

**Randomize within Blocks**  Rows in the design table are in random order within the blocks.

Make Table

Click Make Table to construct the Definitive Screening Design data table.

In the Definitive Screening Design table, the Table panel (in the upper left) contains the following scripts. To run a script, click the green triangle next to the script name.

**Fit Definitive Screening**  Runs the DOE > Definitive Screening > Fit Definitive Screening platform. See “The Fit Definitive Screening Platform”.

**Evaluate Design**  Runs the DOE > Design Diagnostics > Evaluate Design platform. See “Evaluate Designs”.

**DOE Dialog**  Re-creates the Definitive Screening Design window that you used to generate the design table.
**Figure 7.20** Definitive Screening Design Table Showing Scripts

<table>
<thead>
<tr>
<th>Block</th>
<th>X1</th>
<th>X2</th>
<th>X3</th>
<th>X4</th>
<th>X5</th>
<th>X6</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>L1</td>
<td>L1</td>
<td>•</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>L1</td>
<td>L1</td>
<td>•</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>0</td>
<td>1</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>0</td>
<td>-1</td>
<td>L1</td>
<td>•</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>0</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>L1</td>
<td>•</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>8</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>L1</td>
<td>•</td>
</tr>
<tr>
<td>9</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>10</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>11</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>12</td>
<td>1</td>
<td>-1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>13</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>14</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>15</td>
<td>1</td>
<td>-1</td>
<td>0</td>
<td>-1</td>
<td>-1</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>16</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>0</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>17</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>L2</td>
<td>•</td>
</tr>
<tr>
<td>18</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>L2</td>
<td>•</td>
</tr>
</tbody>
</table>

**Back**

The Back button takes you back to where you were before clicking Make Design. You can make changes to the previous outlines and regenerate the design.

**Definitive Screening Design Options**

The red triangle menu in the Definitive Screening Design platform contains these options:

- **Save Responses**  Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.

- **Load Responses**  Loads responses that you saved using the Save Responses option.

- **Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.
Note: It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting Column Properties > Design Role. In the Design Role area, select the appropriate role.

Load Factors  Loads factors that you saved using the Save Factors option.

Save Constraints  (Unavailable for some platforms) Saves factor constraints that you defined in the Define Factor Constraints or Linear Constraints outline into a data table, with a column for each constraint. You can then quickly load the constraints into most DOE windows.

In the constraint table, the first rows contain the coefficients for each factor. The last row contains the inequality bound. Each constraint’s column contains a column property called ConstraintState that identifies the constraint as a “less than” or a “greater than” constraint. See “ConstraintState”.

Load Constraints  (Unavailable for some platforms) Loads factor constraints that you saved using the Save Constraints option.

Set Random Seed  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:

– initializing search algorithms for design generation
– randomizing Run Order for design construction
– selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking Make Design.

Note: The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

Simulate Responses  Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

– A set of simulated response values is added to each response column.
– For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
– A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.
Note: Not all distributions are available for all design types.

- A script called **DOE Simulate** is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a new column called `<Y> Simulated`, where `Y` is the name of the response. Clicking Apply again updates the formula and values in `<Y> Simulated`.

For additional details, see “Simulate Responses”.

Note: **JMP** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in Basic Analysis.

**Save X Matrix** Saves the Moments Matrix and Model Matrix to table scripts in the design data table. These scripts contain the moments and design matrices. See “Save X Matrix”.

**Caution:** For a design with nominal factors, the Model Matrix saved by the Save X Matrix option is not the coding matrix used in fitting the linear model. You can obtain the coding matrix used for fitting the model by selecting the option Save Columns > Save Coding Table in the Fit Model report that you obtain when you select **run model** from the definitive model fit.

**Save Script to Script Window** Creates the script for the design that you specified in the Definitive Screening Design Design window and saves it in an open script window.

**Simulate Responses**

When you click Make Table to create your design table, the Simulate Responses option does the following for each response:

- It adds random response values to the response column in your design table.
- It adds a new a column containing a simulation model formula to the design table. The formula and values are based on a main effects model.

A Model window opens where you can add and remove effects to define a model, specify parameter values, and select a response distribution for simulation. When you click Apply in the Model window, each column containing a simulation model formula is updated.
Control Window

Figure 7.21 shows the Model window for a design with two continuous factors (X1 and X2) and one two-level categorical factor (X3).

Figure 7.21 Simulate Responses Control Window

The window has three outlines:

- Factors
- Simulate Responses
- Distribution

The initial Simulate Responses outline shows terms for a main effects model with values of 1 for all coefficients. The Distribution outline shows a Normal distribution with error standard deviation equal to 1. If you have set Anticipated Coefficients as part of Power Analysis under Design Evaluation in the DOE window, then the initial values in the Simulate Responses outline are the values that you specified as Anticipated Coefficients and Anticipated RMSE (Error Std) in the Power Analysis outline.

Factors

Add terms to the simulation model using the Factors outline.

Interactions  Select factors in the list. Then select the interaction order from the Interactions menu. Those interactions are added to the list of Effects in the Simulate Responses outline.

RSM  Adds all possible response surface terms to the list of Effects in the Simulate Responses outline.
**Powers**  Select factors in the list. Then select the order from the Powers menu. Those powers are added to the list of Effects in the Simulate Responses outline.

**Simulate Responses**

To specify a model for simulated values, do the following:

1. For each term in the list of Effects, enter coefficients for the linear model used to simulate the response values. These define a linear function, \( L(x, \beta) = x'\beta \). See the Simulate Responses outline in Figure 7.21:
   - The vector \( x \) consists of the terms that define the effects listed under Effects.
   - The vector \( \beta \) is the vector of model coefficients that you specify under \( Y \).
2. Under Distribution, select a response distribution.
3. Click **Apply**. A \(<Y>\) Simulated column containing simulated values and their formula is added to the design table, where \( Y \) is the name of the response column.

**Reset coefficients**  Sets all coefficients to 0.

**Remove Term**  Remove terms from the list of Effects. Select the effects to remove and click Remove Term. Note that you cannot remove main effects.

**Distribution**

Choose from one of the available distributions in the Simulate Responses window:

**Normal**  Simulates values from a normal distribution. Enter a value for Error \( \sigma \), the standard deviation of the normal error distribution. If you have designated factors to have Changes of Hard in the Factors outline, you can enter a value for Whole Plots \( \sigma \), the whole plot error. If you have designated factors to have Changes of Hard and Very Hard, you can enter values for both the subplot and whole plot errors. When you click Apply, random values and a formula containing a random response vector based on the model are entered in the column \(<Y>\) Simulated.

**Binomial**  Simulates values from a binomial distribution. Enter a value for \( N \), the number of trials. Random integer values are generated according to a binomial distribution based on \( N \) trials with probability of success \( 1/(1 + \exp(-L(x, \beta))) \). When you click Apply, random values and their formula are entered in the column \(<Y>\) Simulated. A column called \( N \) Trials that contains the value \( N \) is also added to the data table.

**Poisson**  Simulates random integer values according to a Poisson distribution with parameter \( \exp(L(x, \beta)) \). When you click Apply, random values and their formula are entered in the column \(<Y>\) Simulated.

**Note:** You can set a preference to simulate responses every time you click Make Table. To do so, select **File > Preferences > Platforms > DOE**. Select **Simulate Responses**.
Technical Details

- “Structure of Definitive Screening Designs”
- “Analysis of Experimental Data”

Structure of Definitive Screening Designs

Figure 7.22 shows an example of a definitive design with eight continuous factors and four Extra Runs that correspond to fake factors. Notice the following:

- Each pair of rows is a foldover pair; each even-numbered row is -1 times the previous row. The foldover aspect of the design removes the confounding of two-factor interactions and main effects.
- Each factor is set at its center value for three runs; this, together with the design’s construction, makes all quadratic effects estimable.
- Rows 17 through 20 are the Extra Runs that correspond to the fake factors.
- Adding the center run in the last row enables you to fit a model that includes an intercept and all main and quadratic effects.

This structure is typical of definitive screening designs for continuous factors.

Figure 7.22  Definitive Screening Design for Eight Continuous Factors

<table>
<thead>
<tr>
<th>Run</th>
<th>X1</th>
<th>X2</th>
<th>X3</th>
<th>X4</th>
<th>X5</th>
<th>X6</th>
<th>X7</th>
<th>X8</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>0</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>-1</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>-1</td>
<td>0</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>6</td>
<td>-1</td>
<td>1</td>
<td>0</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>-1</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>9</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>10</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>0</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>11</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>0</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>12</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>0</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>13</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>0</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>14</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>15</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>0</td>
</tr>
<tr>
<td>16</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>17</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>18</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>19</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
</tr>
<tr>
<td>20</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>21</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
Conference Matrices and the Number of Runs

Definitive screening designs in JMP are constructed using *conference matrices* (Xiao et al., 2012). A conference matrix is an \( m \times m \) matrix \( C \) where \( m \) is even. The matrix \( C \) has 0s on the diagonal, off-diagonal entries equal to 1 or –1, and satisfies

\[
C'C = (m - 1)I_{m \times m}.
\]

**Note:** For certain even values of \( m \), it is not known if a conference matrix exists.

Suppose that the number of factors, \( k \), is five or larger. For the case of \( k \leq 4 \) factors, see “Definitive Screening Designs for Four or Fewer Factors”.

Consider the case of \( k \) continuous factors and suppose that a conference matrix is available.

- **When** \( k \) is even, the \( k \times k \) conference matrix is used to define \( k \) runs of the design. Its negative, \(-C\), defines the foldover runs. A center point is added to the design to ensure that a model containing an intercept, main effects, and quadratic effects is estimable. So, for \( k \) even, the minimum number of runs in the definitive screening design is \( 2k + 1 \).
- **When** \( k \) is odd, a \((k+1) \times (k+1)\) conference matrix is used, with its last column deleted. A center point is added. Thus, for \( k \) odd, the minimum number of runs in the screening design is \( 2k + 3 \).

A similar procedure is used when some factors are categorical and a conference matrix is available. See Jones and Nachtsheim (2013).

- Instead of a single center point, two additional runs are required. These two runs are center runs where all continuous factors are set at their middle values.
- **When** there are \( k \) factors and \( k \) is even, the number of runs in the design is \( 2k + 2 \).
- **When** \( k \) is odd, the number of runs is \( 2k + 4 \).

For those values of \( m \) for which a conference matrix is not available, a definitive screening design can be constructed using the next largest conference matrix. As a result, the required number of runs might exceed \( 2k + 3 \), in the continuous case, and \( 2k + 4 \), in the categorical case.

**Extra Runs**

Extra runs are constructed using fictitious, or *fake*, factors. Adding \( f \) fake factors to a design results in \( 2^f \) additional runs.

Denote the number of factors in your experimental study by \( k \). Four or eight extra runs can be added to a design. Extra runs are constructed by creating a design for \( k + f \) factors, as described in “Conference Matrices and the Number of Runs”, and then dropping the last \( f \) columns. As few as four extra runs can be highly beneficial in model selection.

For information about how extra runs are used, see “Effective Model Selection for DSDs”.
Definitive Screening Designs for Four or Fewer Factors

Definitive screening designs for four or fewer factors are constructed using the five-factor definitive screening design as a base. This is because designs for \( k \leq 4 \) factors constructed strictly according to the conference matrix approach have undesirable properties. In particular, it is difficult to separate second-order effects.

If you specify \( k \leq 4 \) factors, a definitive screening design for five factors is constructed and unnecessary columns are dropped. For this reason, the number of runs for an unblocked design with \( k \leq 4 \) factors is 13 if all factors are continuous or 14 if some factors are categorical.

Analysis of Experimental Data

In general, you want to fit a model that permits the possibility that two-way interactions are active. You also might want to include pure quadratic terms in your model. You might want to postulate a full second-order model, or you might want to specify an a priori model containing only certain second-order terms.

Two-Way Interactions

In fitting such a model, you need to be mindful of two facts:

- two-way interaction effects and quadratic effects are often correlated
- two-way interaction and quadratic effects cannot all be estimated simultaneously

Figure 7.23 shows a Color Map on Correlations for the design with eight continuous factors shown in Figure 7.22. The color map is for a full quadratic design. The eight pure quadratic effects are listed to the far right. You can construct this plot by using DOE > Design Diagnostics > Evaluate Design and entering the appropriate terms into the Alias Terms list. See “Alias Terms”.
Figure 7.23  Color Map on Correlations for Full Quadratic Model

Hover over the cells of the color map in order to see the absolute correlations between effects. You see that main effects are uncorrelated with all two-way interaction and pure quadratic effects. You also see that none of the effects are completely confounded with other effects because the only black cells are on the main diagonal. But note that some of the absolute correlations between two-factor interactions are substantial, with some at 0.75. Note also that absolute correlations between two-factor interactions and pure quadratic effects are either 0 or 0.3118.

If only main and pure quadratic effects are active, you can fit a saturated model that contains main effects and quadratic effects. This model will result in effect estimates that are unbiased, assuming no active three-way or higher order effects.

Because of the correlations involving second-order effects, you must be careful in fitting a model with two-way interactions. Analysis methodologies include the following, where the first is preferred:

- The method of Efficient Model Selection performs well, especially if many effects are likely to be active. See “Effective Model Selection for DSDs”.

- Forward stepwise or all possible subsets regression performs adequately if the following conditions hold:
  - The number of active effects is no more than half the number of runs.
  - There are at most two active two-way interactions or at most one active quadratic effect.
See “Forward Stepwise Regression or All Possible Subsets Regression”.

**Forward Stepwise Regression or All Possible Subsets Regression**

This method consists of first specifying a full response surface model. Then do one of the following:

- Use forward stepwise regression with the Stopping Rule set to Minimum AICc and the Rules set to Combine to ensure model heredity.
- Use All Possible Models regression, where you select the option that imposes the heredity restriction and use the AICc criterion for model selection.

You cannot fit the full response surface model because the number of runs is less than the number of parameters. So your analysis depends on the assumption of effect sparsity, where you assume that the number of active effects is less than the number of runs. This approach has some limitations:

- If the number of active effects exceeds half the number of runs, both stepwise and all possible models regression have difficulty finding the correct model.
- The power of tests to detect moderate quadratic effects is low. A quadratic effect must exceed three times the error standard deviation for the power to exceed 0.9.
- Because of effect confounding, several models might be equivalent. Additional runs will be necessary to resolve the confounding.
Use the Fit Definitive Screening platform to analyze definitive screening designs (DSDs) using a methodology called *Effective Model Selection for DSDs*. This methodology takes advantage of the unique structure of definitive screening designs.

Standard model selection methods applied to DSDs can fail to identify active effects. To identify active main effects and second-order effects, the Effective Model Selection for DSDs algorithm leverages the structure of DSDs.

**Figure 8.1 Fit Definitive Screening Results**
Contents

Overview of the Fit Definitive Screening Platform ................................................. 277
   Identification of Active Effects in DSDs .......................................................... 277
   Effective Model Selection for DSDs ................................................................. 277
Example of the Fit Definitive Screening Platform .................................................. 278
   Fit the Model ...................................................................................................... 278
   Examine Results ................................................................................................. 279
   Reduce the Model ............................................................................................... 280
Launch the Fit Definitive Screening Platform ............................................................ 282
Fit Definitive Screening Report .................................................................................. 282
   Stage 1 - Main Effect Estimates ........................................................................ 283
   Stage 2 - Even Order Effect Estimates .............................................................. 284
   Combined Model Parameter Estimates ............................................................ 285
   Main Effects Residual Plots ............................................................................... 285
   Prediction Profiler .............................................................................................. 286
Fit Definitive Screening Platform Options ............................................................... 286
Technical Details for the Fit Definitive Screening Platform ...................................... 286
   The Effective Model Selection for DSDs Algorithm ........................................... 286
Overview of the Fit Definitive Screening Platform

The Fit Definitive Screening platform analyzes definitive screening designs (DSDs) using a methodology that takes advantage of their special structure. The methodology is called Effective Model Selection for DSDs. If you created your design in JMP, the design table contains a script called Fit Definitive Screening that automatically runs an analysis using the Effective Model Selection for DSDs methodology.

Identification of Active Effects in DSDs

DSDs are three-level designs that are valuable for identifying main effects and second-order effects in a single experiment. A minimum run-size DSD is capable of correctly identifying active terms with high probability if the number of active effects is less than about half the number of runs and if the effects sizes exceed twice the standard deviation.

However, by augmenting a minimum run-size DSD with four or more properly selected runs, you can identify substantially more effects with high probability. These runs are called Extra Runs, and correspond to fictitious inactive factors, called fake factors. For information about Extra Runs, see “Structure of Definitive Screening Designs”.

Extra Runs substantially increase the design’s ability to detect second-order effects. For this reason, Jones and Nachtsheim (2016) strongly encourage the inclusion of at least four Extra Runs.

Effective Model Selection for DSDs

When standard model selection methods are applied to DSDs, they can fail to identify active effects. See Errore et al. (2017). Also, standard selection methods do not leverage the structure of DSDs. The Fit Definitive Screening platform uses the Effective Model Selection for DSDs approach, which takes full advantage of the structure of the DSD.

Jones and Nachtsheim (2016) report on simulation studies using Effect Model Selection for DSDs as well as standard approaches. Denote by \( c \) the sum of the number of factors and the number of fake factors in a DSD. In many situations, if the number of active main effects exceeds three, then up to \( c/2 \) active second-order effects can be reliably identified. Assuming strong effect heredity, if there are three or fewer active main effects, then all active second-order effects can be reliably identified. Reliable identification means that the ratio of the absolute value of the coefficient to the error standard deviation exceeds three and that the power to detect the effect exceeds 0.80.
The Fit Definitive Screening platform default settings assume strong effect heredity. Strong effect heredity means that the A*B interaction can only be considered for inclusion in the model if both A and B have been included. Strong effect heredity requires that all lower-order components of a model effect be included in the model. In identifying active second-order effects, the algorithm uses strong effect heredity and the results cited earlier about how many active second-order effects can be reliably identified.

In a DSD, main effects and second-order effects are orthogonal to each other. The Effective Model Selection for DSDs approach takes advantage of this fact. The linear space of the response is separated into the subspace spanned by the main effects and the orthogonal complement of this subspace. Miller and Sitter (2005) refer to the linear subspace spanned by the main effects as the odd space, because it contains all the information about odd effects: main effects, 3-factor effects, 5-factors effects, and so on. They refer to its orthogonal complement as the even space, because it contains all the information about even effects: the intercept, 2-factor effects, 4-factor effects, and so on.

Fit Definitive Screening follows this thinking. The subspace spanned by the main effects is the odd space. Its orthogonal complement, the even space, contains the second-order effects and the block variable, if one exists. For more information about the algorithm, see “The Effective Model Selection for DSDs Algorithm” and Jones and Nachtsheim (2016).

Example of the Fit Definitive Screening Platform

The design in the sample data table Extraction 3 Data.jmp is a definitive screening design for six factors in two blocks. The Add Blocks with Center Runs to Estimate Quadratic Effects option was selected and 4 Extra Runs were added in the design generation. The resulting design has 18 runs. This design is used to explore the analysis of a definitive screening design.

• “Fit the Model”
• “Examine Results”
• “Reduce the Model”

Note: For an example of a design with continuous and categorical factors, open the sample data file Peanut Data.jmp and run the Fit Definitive Screening table script.

Fit the Model

1. Select Help > Sample Data Library and open Design Experiment/Extraction 3 Data.jmp.
2. Select DOE > Definitive Screening > Fit Definitive Screening.
3. Select Yield and click Y.
4. Select Lot through Time and click X.

5. Click OK.

The fit performs a two-stage analysis. For more information about the algorithm, see “Technical Details for the Fit Definitive Screening Platform”.

Examine Results

Stage 1: Main Effect Estimates

Stage 1 determines which main effects are likely to be active.

Figure 8.2 Stage 1 Report for Main Effects

| Term      | Estimate | Std Error | t Ratio | Prob>|t| |
|-----------|----------|-----------|---------|-----|---|
| Methanol  | 9.7133   | 0.3674    | 26.438  | <0.001* |
| Ethanol   | 2.3165   | 0.3674    | 63.055  | 0.0015* |
| Time      | 4.0798   | 0.3674    | 11.104  | 0.0001* |

Note: The fake factors do not appear in the design or as factors in the analysis.

A two-degree-of-freedom error sum of squares is computed from the four runs corresponding to the two fake factors. Because the fake factors are, by construction, inactive, this estimate of error variance is unbiased. For each main effect, the main effects response $Y_{ME}$ is tested against this estimate. In this example, three factors, Methanol, Ethanol, and Time, have $p$-values smaller than the threshold value and are retained as active. For more information about the threshold values, see “Stage 1 Methodology”.

The variability from the three inactive factors, Propanol, Butanol, and pH, is pooled with the fake factor sum of squares to produce the five-degree-of-freedom RMSE statistic shown in Figure 8.2.

Stage 2: Even Order Effect Estimates

Stage 2 uses guided subset selection to arrive at a list of second-order effects that are likely to be active. Interactions and quadratic terms are second-order or even order effects.
Because three main effects are identified as active in Stage 1, the guided subset selection procedure for active second-order effects can continue until all second-order effects are included. Because all six second-order effects are reported in Stage 2, it follows that the Stage 2 RMSE remained larger than the Stage 1 RMSE. See “Stage 2 Methodology”.

The two-degree-of-freedom RMSE given in the Stage 2 report is the error estimate obtained from the final subset of all six second-order effects.

**Combined Results**

The effects selected for the model are listed in the Combined Model Parameter Estimates report.

**Reduce the Model**

The Make Model button enters the model for the listed terms in a Fit Model specification window. To run the model directly using standard least squares, click the Run Model button.

1. Click **Run Model**.
The Actual by Predicted Plot shows no lack of fit. The Effect Summary report suggests that you can reduce the model further.

**Figure 8.5** Actual by Predicted Plot and Effect Summary Report

2. Select Methanol*Ethanol in the Effect Summary report and click **Remove**. Methanol*Time has \( p \)-value 0.33750. Remove it next.
3. Select Methanol*Time in the Effect Summary report and click **Remove**. Ethanol*Ethanol has \( p \)-value 0.15885. Remove it next.
4. Select Ethanol*Ethanol in the Effect Summary report and click **Remove**.

**Figure 8.6** Effect Summary Report Showing Effects in Final Model

The remaining effects are significant. You conclude that these are the active effects.
Launch the Fit Definitive Screening Platform

To launch the Fit Definitive Screening platform, select **DOE > Definitive Screening > Fit Definitive Screening**. The launch window in **Figure 8.7** uses Extraction3 Data.jmp.

**Note:** If you created your design in JMP, the design table contains a script called Fit Definitive Screening. Run this script to run the analysis directly.

**Figure 8.7** Fit Definitive Screening Launch Window

- **Y** One or more numeric response variables.
- **X** Continuous or two-level categorical factors. Because the platform uses the unique features of a DSD in performing the analysis, these factors must define a DSD or a fold-over design.
- **By** A column whose levels define separate analyses. For each level of the specified column, the corresponding rows are analyzed. The results appear in separate reports. If more than one By variable is assigned, a separate analysis is produced for each possible combination of the levels of the By variables.

For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

**Fit Definitive Screening Report**

- “Stage 1 - Main Effect Estimates”
- “Stage 2 - Even Order Effect Estimates”
- “Combined Model Parameter Estimates”
- “Main Effects Residual Plots”
- “Prediction Profiler”
Stage 1 - Main Effect Estimates

The Main Effect Estimates report lists main effects that are identified as active. Main effects with \( p \)-values less than the threshold \( p \)-value are considered active.

- If fake factors or center point replicates are available, an estimator of error variance that is independent of the model is constructed. The main effects are tested against this estimate.
- If no fake factors or center point replicates are available, subsets of main effects are tested sequentially against an estimate of error variance constructed from the inactive main effects. For this procedure to be viable, at least one of the main effects must be inactive.

In either case, variability from the inactive main effects is pooled into the error variance used to test the main effects.

Figure 8.8 Stage 1 Report

| Term | Estimate | Std Error | t Ratio | Prob>|t| |
|------|----------|-----------|--------|-------|
| Methanol | 9.7133 | 0.3674 | 26.438 | <.0001* |
| Ethanol  | 2.3166 | 0.3674 | 6.3055 | 0.0015* |
| Time    | 4.0798 | 0.3674 | 11.104 | 0.0001* |

**Term** Main effects identified as active. These effects have \( p \)-values less than the threshold when tested as described in “Stage 1 Methodology”.

**Estimate** Parameter estimate for a regression fit of Y on the main effects.

**Std Error** The standard error of the estimate, computed using the Stage 1 RMSE.

**t Ratio** The Estimate divided by its Std Error.

**Prob>|t|** The \( p \)-value computed using the t Ratio and the degrees of freedom for error (DF).

**RMSE** The square root of the mean square error that results from the Stage 1 analysis.

- If fake factors or centerpoint replicates are available, the mean square error is the estimate of variance from fake factors and centerpoints pooled with the variance estimate constructed from the main effects that are not identified as active.
- If no fake factors or centerpoint replicates are available, the mean square error is the estimate of variance constructed from the main effects that are not identified as active.

**DF** The degrees of freedom associated with the error estimate used to construct RMSE.

- If fake factors or centerpoint replicates are available, DF is the sum of the number of fake factors, centerpoint replicates, and main effects not identified as active.
– If no fake factors or centerpoint replicates are available, DF is the number of main effects that are not identified as active.

**Quadratic Terms Obey Strong Heredity** Check or uncheck to control heredity rules applied to quadratic terms in Stage 2.

**Interactions Obey Strong Heredity** Check or uncheck to control heredity rules applied to interactions in Stage 2.

**Note:** Strong effect heredity means that the A*B interaction can only be considered for inclusion in the model if both A and B have been included. Strong effect heredity requires that all lower-order components of a model effect be included in the model.

### Stage 2 - Even Order Effect Estimates

The Even Order Effect Estimates report lists second-order effects that are identified as active. Active second-order effects are identified using the guided variable selection procedure or forward selection as described in “Stage 2 Methodology”. The block effect (if one is included) is also listed, whether it is significant or not.

**Figure 8.9 Stage 2 Report**

| Term                  | Estimate | Std Error | t Ratio | Prob>|t| |
|-----------------------|----------|-----------|---------|------|
| Intercept             | 34.546   | 1.346     | 25.683  | 0.0015*|
| Log[10]               | 17.197   | 0.757     | 22.171  | 0.0020*|
| Methanol*Ethanol      | -0.397   | 0.712     | -0.551  | 0.6281 |
| Methanol*Time         | 0.5266   | 0.712     | 0.7393  | 0.5369 |
| Ethanol*Time          | 9.8258   | 0.8534    | 11.514  | 0.0075*|
| Methanol*Methanol     | 7.637    | 1.4914    | 5.1208  | 0.00061*|
| Ethanol*Ethanol       | -1.449   | 1.477     | -0.981  | 0.4299 |
| Time*Time             | -3.297   | 1.477     | -2.532  | 0.1392 |

**Term** The block factor and second-order effects identified as active.

**Estimate** Parameter estimates for a regression fit of Y on the Stage 2 second-order effects defined by \( Y_{2nd} \). See “Decomposition of Response”.

**Std Error** The standard error of the estimate, computed using the Stage 2 RMSE.

**t Ratio** The Estimate divided by its Std Error.

**Prob>|t|** The \( p \)-value computed using the t Ratio and the degrees of freedom for error (DF).

**RMSE** The square root of the mean square error that results from the Stage 2 analysis. RMSE is estimated as the residual variance from \( Y_{2nd} \) after fitting the second order effects identified as active. See “Decomposition of Response”.

284 The Fit Definitive Screening Platform
Chapter 8
Fit Definitive Screening Report
Design of Experiments Guide
DF  The degrees of freedom associated with the error estimate used to construct RMSE.

**Combined Model Parameter Estimates**

The Combined Model Parameter Estimates report lists the terms in the final model and their usual standard least squares estimates, standard errors, t ratios, \( p \)-values, RMSE, and model degrees of freedom.

Below the report are buttons that construct or run the combined model.

**Figure 8.10** Combined Model Parameter Estimates Report

![Combined Model Parameter Estimates Table]

| Term            | Estimate | Std Error | t Ratio | Prob>|t| |
|-----------------|----------|-----------|---------|-----|---|
| Intercept       | 34.568   | 1.0452    | 33.074  | <.0001*|
| Lot[1]          | 17.197   | 0.6023    | 28.552  | <.0001*|
| Methanol        | 9.7133   | 0.4281    | 22.691  | <.0001*|
| Ethanol         | 2.2165   | 0.4281    | 5.4118  | .0001* |
| Time            | 4.0758   | 0.4281    | 9.3307  | <.0001*|
| Methanol*Ethanol| -0.367   | 0.5534    | -0.663  | 0.5287 |
| Methanol*Time   | 0.5265   | 0.5534    | 0.9516  | 0.3730 |
| Ethanol*Time    | 9.6258   | 0.8827    | 14.828  | <.0001*|
| Methanol*Ethanol| 7.637    | 1.1981    | 6.5945  | 0.0003*|
| Ethanol*Ethanol | 1.440    | 1.1469    | 1.264   | 0.2466 |
| Time*Time       | -3.297   | 1.1469    | -2.875  | 0.0238*|

**Make Model**  Creates a model for the Fit Model window containing the model terms in the Combined Model Parameter Estimates report and the response specified for the Fit Definitive Screening analysis. The Standard Least Squares personality is specified.

**Run Model**  Runs a standard least squares fit for the model terms in the Combined Model Parameter Estimates report and the response specified for the Fit Definitive Screening analysis.

**Main Effects Residual Plots**

Shows a plot of the residuals from a main effects model fit to all other factors versus the levels of the plotted factor. A factor with residuals that differ across levels indicates an important main effect.

**Note:** There is not a plot for a block factor.
Prediction Profiler

Shows a prediction profiler for the combined model. For more information about the prediction profiler, see Profilers.

Fit Definitive Screening Platform Options

Set Stage 1 p value  Set the p-value threshold used for Stage 1. See “Stage 1 Methodology”.

Set Stage 2 ratio  Specify the ratio of the Stage 2 MSE to the Stage 1 MSE. See “Stage 2 Methodology”.

See Using JMP for more information about the following options:

Local Data Filter  Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Technical Details for the Fit Definitive Screening Platform

The Effective Model Selection for DSDs Algorithm

This section provides a summary of the algorithm used in the Fit Definitive Screening platform. See Jones and Nachtsheim (2016).

Decomposition of Response

The Effective Model Selection algorithm expresses the response, Y, in terms of two responses $Y_{ME}$ and $Y_{2nd}$, so that $Y = Y_{ME} + Y_{2nd}$.

- $Y_{ME}$ is the predicted value obtained from a regression of $Y$ on the main effects and fake factors.
There is no need to include the block factor in $Y_{ME}$ because of the fold-over structure of the design. The block factor is included in $Y_{2nd}$.

- $Y_{2nd}$ is given by $Y_{2nd} = Y - Y_{ME}$.

**Note:** In a DSD, the columns $Y_{ME}$ and $Y_{2nd}$ are orthogonal.

The analysis proceeds in two stages:

- **Stage 1:** The response $Y_{ME}$ is used to identify main effects. Stage 1 identifies the main effects that are considered active.
- **Stage 2:** The response $Y_{2nd}$ is used to identify second-order effects. Stage 2 considers all second-order terms in the active main effects from Stage 1 and determines a subset of these containing effects considered to be active.

**Note:** If there is a blocking factor, it is included in the Stage 2 list of effects even if it is not significant.

### Stage 1 Methodology

The Stage 1 methodology depends on whether the design contains fake factors or centerpoint replicates.

#### Case 1: Fake Factors or Centerpoint Replicates Available

1. Using the fake factors or center point replicates, an estimator of error variance that is independent of the model is constructed. Assuming that there are no active third or higher odd order effects, this estimate is unbiased.

2. Using $Y_{ME}$, main effects are tested against this estimate. Main effects with $p$-values less than a threshold $p$-value are considered active. The threshold values are the following:
   - For one error degree of freedom, the threshold value is 0.20.
   - For two error degrees of freedom, the threshold value is 0.10.
   - For more than two error degrees of freedom, the threshold value is 0.05.
   - User specified $p$-value is the threshold.

   **Note:** To specify a different $p$-value threshold select **Set Stage 1 p value** from the Fit Definitive Screening red triangle menu.

3. If no main effect has a $p$-value less than the threshold value, conclude that there are no active main effects and no active two-factor effects. The procedure terminates.

4. If active main effects are found, then variability from the inactive main effects is pooled into the error variance constructed in (1).
Note: If Categorical factors are in the design, the estimated coefficients are recalculated each time a main effect is chosen as active.

Case 2: No Fake Factors or Centerpoint Replicates Available

In this case, there is no model-independent estimator of error variance available. Subsets of main effects are tested sequentially against an estimate of error variance constructed from the inactive main effects. Suppose that there are $m$ main effects.

1. The absolute values of the estimated effects, using $Y_{ME}$ as the response, are ordered from largest to smallest.
2. For each $1 \leq i < m$, the effect with the $i^{th}$ largest absolute value is tested against the adjusted residual sum of squares for the model containing that effect and all effects with larger absolute values.
3. The effects in the model with the smallest $p$-value are considered to be the active effects.
4. If active main effects are found, then variability from the inactive main effects is used to construct an estimate of error variance, using $Y_{ME}$ as the response.

Note: For the Fit Definitive Screening procedure to work properly in Case 2, at least one of the main effects must be active and at least one must be inactive. If no main effects are active, or if all main effects are active, the procedure will identify a set of main effects, but the procedure for arriving at that subset is compromised.

Stage 2 Methodology

In Stage 2, the factors considered depend on the Strong Heredity options. When strong heredity is selected, only second-order effects involving the factors whose main effects are identified as active in Stage 1 are considered. The Stage 2 methodology depends on the number of active main effects identified in Stage 1.

Case 1: Seven or Fewer Active Main Effects

Stage 2 uses a guided subset selection procedure. The goal is to continue to add second-order effects to the model as long as the ratio of the RMSE from Stage 2 to the RMSE from Stage 1 is greater than the specified threshold. When the ratio is less than or equal to the threshold, this indicates that there are no additional second-order effects to add to the model. The default threshold is 1. Smaller thresholds increases the number of terms likely to identified as active as compared to larger thresholds.

Note: To specify a RMSE ratio threshold other than one, select Set Stage 2 ratio from the Fit Definitive Screening red triangle menu.
For Stage 2:

- For one error degree of freedom, the threshold value is 0.20.
- For two error degrees of freedom, the threshold value is 0.10.
- For more than two error degrees of freedom, the threshold value is 0.05.
- User specified $p$-value is the threshold.

1. The variability for $Y_{2nd}$ is tested against the error estimate from Stage 1 to determine if there is additional variability due to second-order effects.
   - If the $p$-value for this test exceeds the threshold value the procedure terminates and no active second-order effects are identified.

2. If the $p$-value for this test is less than or equal to the threshold value, then subsets of size $k$, $k = 1, 2, 3, ...$ are successively tested, starting with $k = 1$.

3. For each $k$, the residual sum of squares for each subset of that size is tested against the error estimate from Stage 1. The subset with the smallest RMSE is identified.

4. The procedure continues until a $k$ is found with a ratio of RMSE to the Stage 1 RMSE smaller than the Stage 2 ratio.

5. The effects in the subset preceding the one that corresponds to the terminal value of $k$ are considered to be the active two-factor effects.

**Case 2: Eight or More Active Main Effects**

Stage 2 uses forward selection for second order terms when eight or more active main effects are identified in Stage 1.
Screening designs are among the most popular designs for industrial experimentation. Typically used in the initial stages of experimentation, they examine many factors in order to identify those factors that have the greatest effect on the response. The factors that are identified are then studied using more sensitive designs. Because screening designs generally require fewer experimental runs than other designs, they are a relatively inexpensive and efficient way to begin improving a process.

If a standard screening design exists for your experimental situation, you can choose from several standard screening designs. The list includes blocked designs when applicable. Your factors can be two-level continuous factors, three-level categorical factors, or continuous factors that can assume only discrete values (discrete numeric factors).

However, there are situations where standard screening designs are not available. In these cases, the Screening Design platform constructs a main effects screening design. A main effects screening design is either orthogonal or near orthogonal. It focuses on estimating main effects in the presence of negligible interactions.

Note that JMP also provides two compelling alternatives to screening designs:

- Definitive screening designs are particularly useful if you suspect active two-factor interactions or if you suspect that a plot of a continuous factor’s effect on the response might exhibit strong curvature. See “Definitive Screening Designs”.
- Custom designs are highly flexible and often more cost-effective than a design obtained using alternative methods. See “Custom Designs”.

**Figure 9.1** Results from a Fractional Factorial Design
Contents

Overview of Screening Designs .......................................................... 293
Underlying Principles ........................................................................ 293
Analysis of Screening Design Results ............................................... 294
Examples of Screening Designs .......................................................... 294
Compare a Fractional Factorial Design and a Main Effects Screening Design .............. 294
Main Effects Screening Design where No Standard Design Exists ..................... 302
Screening Design Window .................................................................... 305
Responses ......................................................................................... 306
Factors .............................................................................................. 308
Choose Screening Type ........................................................................ 310
Choose from a List of Fractional Factorial Designs .................................. 311
Design Type ....................................................................................... 311
Resolution as a Measure of Confounding ........................................... 314
Display and Modify Design .................................................................. 315
Main Effects Screening Designs ........................................................... 318
Design Generation ............................................................................. 319
Design ............................................................................................... 320
Design Evaluation ............................................................................... 320
Output Options ................................................................................... 321
Make Table ......................................................................................... 322
Screening Design Options .................................................................... 323
Additional Examples of Screening Designs ........................................... 325
Modify Generating Rules in a Fractional Factorial Design ............................... 326
Plackett-Burman Design ...................................................................... 331
Overview of Screening Designs

Screening experiments tend to be small and are aimed at identifying the factors that affect a response. Because identification is the goal (rather than sophisticated modeling), continuous factors in a screening design are typically set at only two levels. However, a screening situation might also involve discrete numeric or categorical factors, in which case classical screening designs might not fit your situation. The Screening Design platform can handle all three types of factors: two-level continuous factors, categorical factors, and discrete numeric factors.

There are two types of designs:

- Classical designs: For situations where standard screening designs exist, you can choose from a list that includes fractional factorial designs, Plackett-Burman, Cotter, and mixed-level designs.
- Main effects screening designs: Whether a standard design is available, you can ask JMP to construct a main effects screening design. These designs are orthogonal or near orthogonal and focus on estimating main effects in the presence of negligible interactions. See “Main Effects Screening Designs”.

Underlying Principles

The emphasis on studying main effects early on in the experimentation process is supported by the empirical principle of effect hierarchy. This principle maintains that lower order effects are more likely to be important than higher order effects. For this reason, screening designs focus on identifying active main effects. In cases where higher order interactions are of interest, screening designs assume that two-factor interactions are more important than three-factor interactions, and so on. See “Effect Hierarchy” and Wu and Hamada (2009).

The efficiency of screening designs also depends on the principle of effect sparsity. Effect sparsity asserts that most of the variation in the response is explained by a relatively small number of effects. See “Effect Sparsity”.

To appreciate the importance of effect sparsity, consider an example where you have seven two-level factors. Contrast a full factorial design to a screening design:

- A full factorial design consists of all combinations of the levels of the factors. The number of runs is the product of the numbers of levels for each factor. In this example, a full factorial design has $2^7 = 128$ runs.
- In contrast, a screening design requires only a fraction of the runs in the full factorial design. The main effects of the seven factors can be studied in an eight-run screening design.
Analysis of Screening Design Results

Screening designs are often used to test a large number of factors or interactions. When there are degrees of freedom for error, allowing construction of an error estimate, the experimental results can be analyzed using the usual regression techniques (Analyze > Fit Model).

However, sometimes there are no degrees of freedom for error. In this case, assuming effect sparsity, the Screening platform (DOE > Classical > Two Level Screening > Fit Two Level Screening) provides a way to analyze the results of a two-level design. The Screening platform accepts multiple responses and multiple factors. It automatically shows significant effects with plots and statistics. See “Screening Designs”. For an examples in the current chapter, see “Modify Generating Rules in a Fractional Factorial Design” and “Plackett-Burman Design”.

Examples of Screening Designs

- “Compare a Fractional Factorial Design and a Main Effects Screening Design”
- “Main Effects Screening Design where No Standard Design Exists”

Compare a Fractional Factorial Design and a Main Effects Screening Design

In this example, suppose an engineer wants to investigate a process that uses an electron beam welding machine to join two parts. The engineer fits the two parts into a welding fixture that holds them snugly together. A voltage applied to a beam generator creates a stream of electrons that heats the two parts, causing them to fuse. The ideal depth of the fused region is 0.17 inches. The engineer wants to study the welding process to determine the best settings for the beam generator to produce the desired depth in the fused region.

For this study, the engineer wants to explore the following seven factors:

- **Operator** is the technician operating the welding machine. Two technicians typically operate the machine.
- **Speed** (in rpm) is the speed at which the part rotates under the beam.
- **Current** (in amps) is a current that affects the intensity of the beam.
- **Mode** is the welding method used.
- **Wall Size** (in mm) is the thickness of the part wall.
- **Geometry** indicates whether the joint is a single-bevel joint or a double-bevel joint.
- **Material** is the type of material being welded.
Notice that three of these factors are continuous: Speed, Current, and Wall Size. Four are categorical: Operator, Mode, Geometry, and Material. Each of these categorical factors has two levels.

After each processing run, the engineer cuts the part in half. This reveals an area where the two parts have fused. The length of this fused area, measured in inches, is the depth of penetration of the weld. The depth of penetration is the response for the study.

The goals of the study are the following:
- Find which factors affect the depth of the weld.
- Quantify those effects.
- Find specific factor settings that predict a weld depth of 0.17 inches with a tolerance of ±0.05 inches.

Your experimental budget allows you at most 12 runs. Construct and compare two designs for your experimental situation. The first is a classical fractional factorial design using eight runs. The second is a main effects screening design using 12 runs.

**Constructing a Standard Screening Design**

In this section, construct a standard screening design for this experimental situation.

**Specify the Response**

1. Select **DOE > Classical > Two Level Screening > Screening Design**.
2. In the Responses panel, double-click Y under Response Name and type Depth.
   
   Note that the default Goal is Maximize. Your goal is to find factor settings that enable you to obtain a target depth of 0.17 inches with limits of 0.12 and 0.22.
3. Click the default Goal of Maximize and change it to **Match Target**.
4. Click under **Lower Limit** and type 0.12.
5. Click under **Upper Limit** and type 0.22.
6. Leave the area under **Importance** blank.

   Because there is only one response, that response is given Importance 1 by default.

The completed Responses outline appears in **Figure 9.2**. Now, specify the factors.

**Specify Factors**

You can enter the factors manually or automatically:
- To enter the factors manually, see “**Specify Factors Manually**”.
- To enter the factors automatically, use the Weld Factors.jmp data table:
1. Select **Help > Sample Data Library** and open Design Experiment/Weld Factors.jmp.
2. Click the Screening Design red triangle and select **Load Factors**. Proceed to “Choose a Design”.

### Specify Factors Manually

1. Type **3** in the **Add N Factors** box and click **Continuous**.
2. Double-click **X1** and type **Speed**.
3. Use the Tab key to move through the rest of the values and factors. Make the following changes:
   a. Change the **Speed** values to 3 and 5.
   b. Change **X2** to **Current**, with values of 150 and 165.
   c. Change **X3** to **Wall Size**, with values of 20 and 30.
4. Type **4** in the **Add N Factors** box and select **Categorical > 2 Level**.
5. Double-click **X4** and type **Operator**.
6. Use the Tab key to move through the rest of the values and factors. Make the following changes:
   a. Change the **Operator** values to John and Mary.
   b. Change **X5** to **Mode**, with values of Conductance and Keyhole.
   c. Change **X6** to **Geometry**, with values of Double and Single.
   d. Change **X7** to **Material**, with values of Aluminum and Magnesium.
Figure 9.2 Responses and Factors Outlines for Weld Experiment

Choose a Design

1. Click **Continue**.

   Because the combination of factors and levels that you have specified can be accommodated by a standard fractional factorial design, the Choose Screening Type panel appears. You can either select a standard design from a list or construct a main effects design.

   **Note:** Setting the Random Seed in the next step reproduces the results shown in this example. When you are constructing a design on your own, this step is not necessary.

2. (Optional) Click the Screening Design red triangle, select **Set Random Seed**, type 12345, and click **OK**.

3. Accept the default selection to **Choose from a list of fractional factorial designs** and click **Continue**.

4. Select the first Fractional Factorial design.
Figure 9.3 Design List for Three Continuous Factors and Four Categorical Factors

This specifies an eight-run Resolution 3 fractional factorial design. For information about resolution, see “Resolution as a Measure of Confounding”.

5. Click **Continue**.

In the Output Options outline, note that **Run Order** is set to **Randomize**. This means that the design runs will appear in random order. This is the order you should use to conduct your experimental runs.
6. Open the Aliasing of Effects outline under Display and Modify Design.

Recall that you selected a Resolution 3 design (Figure 9.3). In a Resolution 3 design, some main effects are confounded with two-way interactions. The Aliasing of Effects outline indicates that, for this Resolution 3 design, every main effect is completely confounded with three two-way interactions. If you suspect that two-way interactions are active, this is a poor design. For a description of confounding, see “Two-Level Regular Fractional Factorial”.

7. Click Make Table.
Figure 9.6  The Design Data Table

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Speed</th>
<th>Current</th>
<th>Wall Size</th>
<th>Operator</th>
<th>Mode</th>
<th>Geometry</th>
<th>Material</th>
<th>Depth</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>5</td>
<td>165</td>
<td>30</td>
<td>Mary</td>
<td>Keyhole</td>
<td>Single</td>
<td>Magnesium</td>
<td>•</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>165</td>
<td>20</td>
<td>Mary</td>
<td>Conductance</td>
<td>Single</td>
<td>Aluminum</td>
<td>•</td>
</tr>
<tr>
<td>3</td>
<td>5</td>
<td>150</td>
<td>30</td>
<td>John</td>
<td>Conductance</td>
<td>Single</td>
<td>Aluminum</td>
<td>•</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>150</td>
<td>20</td>
<td>John</td>
<td>Keyhole</td>
<td>Single</td>
<td>Magnesium</td>
<td>•</td>
</tr>
<tr>
<td>5</td>
<td>3</td>
<td>165</td>
<td>30</td>
<td>John</td>
<td>Keyhole</td>
<td>Double</td>
<td>Aluminum</td>
<td>•</td>
</tr>
<tr>
<td>6</td>
<td>5</td>
<td>165</td>
<td>20</td>
<td>John</td>
<td>Conductance</td>
<td>Double</td>
<td>Magnesium</td>
<td>•</td>
</tr>
<tr>
<td>7</td>
<td>3</td>
<td>150</td>
<td>20</td>
<td>John</td>
<td>Keyhole</td>
<td>Double</td>
<td>Magnesium</td>
<td>•</td>
</tr>
<tr>
<td>8</td>
<td>3</td>
<td>150</td>
<td>30</td>
<td>Mary</td>
<td>Conductance</td>
<td>Double</td>
<td>Magnesium</td>
<td>•</td>
</tr>
</tbody>
</table>

Notice the following:
- The table uses the names for the responses, factors, and levels that you specified.
- The Pattern column shows the assignment of high and low settings for the design runs.
- This fractional factorial design is a Resolution 3 design. It enables you to study the main effects of seven factors in eight runs.

Constructing a Main Effects Screening Design

Main effects screening designs are orthogonal or near orthogonal designs. In this section, construct a main effects screening design for your seven factors.

1. Open your Screening Design window. If you have closed it, then run the DOE Dialog script in the Design Data table.
2. Click Back.
3. Click Continue.

**Note:** Setting the Random Seed and the Number of Starts in the next two steps reproduces the exact results shown in this example. When constructing a design on your own, these steps are not necessary.

4. (Optional) Click the Screening Design red triangle, select Set Random Seed, type 12345, and click OK.
5. (Optional) Click the Screening Design red triangle, select Number of Starts, type 50, and click OK.
6. In the Choose Screening Type panel, select the Construct a main effects screening design option.
7. Click Continue.

Under Number of Runs, the selected option is Default with the number of runs set to 12. Keep this setting.
8. Click Make Design.
9. Open the Design Evaluation outline and then open the Color Map on Correlations outline.

The Color Map on Correlations shows that the main effects are uncorrelated with each other. This is indicated by the white off-diagonal cells in the upper left corner of the color map. Each main effect is partially aliased with some two-way interactions, indicated by the gray cells. Hover over one of the gray cells to see that the absolute correlations are 0.333.

In this case, the 12-run main effects screening design is a Plackett-Burman design, which you could have obtained in the Design List. However, in many design situations, the partial aliasing that occurs in a main effects design is preferable to the complete
Main Effects Screening Design where No Standard Design Exists

Main effects screening designs are orthogonal or near orthogonal designs for the main effects. You can use them in place of standard designs and in situations where standard designs do not exist. Main effects screening designs are excellent for estimating main effects when interactions are negligible.

In this experimental situation, no standard design exists. You need a design to study 13 factors: 2 are categorical, one with 4 levels and one with 6 levels, and 11 are continuous.

1. Select **DOE > Classical > Two Level Screening > Screening Design.**
   
   In the Responses panel, there is a single default response called **Y**. Keep this as the default response.

2. In the Factors panel, click **Categorical** and select **4 Level**.
   
   This adds the variable **X1** with levels L1 through L4.

3. Click **Categorical** and select **6 Level**.
   
   This adds the variable **X2**, with levels L1 through L6.

4. Enter 11 next to **Add N Factors**.

5. Click **Continuous**.
   
   This adds 11 factors, **X3** to **X13**, each at two levels, -1 and 1.

6. Click **Continue**.
   
   The Design Generation panel appears.

   There is no option to select a design from the Design List since there are no available standard designs in this situation.

   Keep the default number of runs, which is 24.
7. Click **Make Design**. A Design and a Design Evaluation outline appear.

8. Open the Design outline to see the randomized design.

   **Note:** The algorithm that generates the design uses a random starting design. To reproduce this design, save the script with the random seed by selecting **Save Script to Script Window** from the red triangle menu next to the report title.

Next, examine the Color Map on Correlations to see that this specific design is orthogonal.

9. Open the **Design Evaluation > Color Map on Correlations** outline.

   The color map (Figure 9.10) shows black entries (using JMP default colors) on the main diagonal, indicating correlations of one. This is because each diagonal cell corresponds to the correlation of a term with itself, which is one. Off-diagonal correlations are all white, indicating that correlations between distinct terms are zero. Hover over any cell to see the relevant terms and their absolute correlation.
Figure 9.10 Color Map on Correlations

10. Click **Make Table** to construct the design table.

The table contains the runs for your experiment in random order. Conduct the experiment in this randomized order and insert the results in column Y. Run the **Model** script in the data table to analyze your results.
Screening Design Window

The Screening Design window updates as you work through the design steps. See “The DOE Workflow: Describe, Specify, Design”. The outlines that appear are separated by buttons that update the window. These follow the flow in the figures below.

Figure 9.11 Screening Design Flow when a Standard Design Exists
**Figure 9.12** Screening Design Flow when No Standard Design Exists

![Screening Design Flow Diagram](image)

**Responses**

Use the Responses outline to specify one or more responses.

- **Tip:** When you have completed the Responses outline, consider selecting **Save Responses** from the red triangle menu. This option saves the response names, goals, limits, and importance values in a data table that you can later reload in DOE platforms.

**Figure 9.13** Responses Outline

<table>
<thead>
<tr>
<th>Responses</th>
<th>Add Response</th>
<th>Remove</th>
<th>Number of Responses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Response Name</td>
<td>Goal</td>
<td>Lower Limit</td>
<td>Upper Limit</td>
</tr>
<tr>
<td>Y</td>
<td>Maximize</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Add Response** Enter a single response with a goal type of Maximize, Match Target, Minimize, None, or Functional. If you select Match Target, enter limits for your target value. If you select Maximize or Minimize, entering limits is not required but can be useful if you intend to use desirability functions.

- **Functional** (Available only in JMP Pro.) Adds multiple Y columns with FDE column properties to the design data table. These columns can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.

- **Remove** Removes the selected responses.

- **Number of Responses** Enters additional responses so that the number that you enter is the total number of responses. If you have entered a response other than the default Y, the Goal for each of the additional responses is the Goal associated with the last response entered. Otherwise, the Goal defaults to Match Target. Click the Goal type in the table to change it.

The Responses outline contains the following columns:

- **Response Name** The name of the response. When added, a response is given a default name of Y, Y2, and so on. To change this name, double-click it and enter the desired name.

- **Goal, Lower Limit, Upper Limit** The Goal tells JMP that you want to maximize or minimize your response, match a target, or that you have no goal for your response. JMP assigns a Response Limits column property, based on these specifications, to each response column.
in the design table. It uses this information to define a desirability function for each response. The Profiler and Contour Profiler use these desirability functions to find optimal factor settings. For further details, see the Profiler chapter in Profilers and “Response Limits”.

- A Goal of Maximize indicates that the best value is the largest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

- A Goal of Minimize indicates that the best value is the smallest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

- A Goal of Match Target indicates that the best value is a specific target value. The default target value is assumed to be midway between the Lower Limit and Upper Limit.

- A Goal of None indicates that there is no goal in terms of optimization. No desirability function is constructed.

**Note:** If your target response is not midway between the Lower Limit and the Upper Limit, you can change the target after you generate your design table. In the data table, open the Column Info window for the response column (Cols > Column Info) and enter the desired target value.

**Importance** When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for the responses. If there is only one response, then specifying the Importance is unnecessary because it is set to 1 by default.

**Detection Limits** The lower and upper detection limits are bounds beyond which the response cannot be measured. The detection limits are saved as a column property. You can use these limits to specify a censored response in the Generalized Regression platform. See the Generalized Regression chapter in Fitting Linear Models.

**Editing the Responses Outline**

In the Responses outline, note the following:

- Double-click a response to edit the response name.
- Click the goal to change it.
- Click on a limit or importance weight to change it.
- For multiple responses, you might want to enter values for the importance weights.
Response Limits Column Property

The Goal, Lower Limit, Upper Limit, and Importance that you specify when you enter a response are used in finding optimal factor settings. For each response, the information is saved in the generated design data table as a Response Limits column property. JMP uses this information to define the desirability function. The desirability function is used in the Prediction Profiler to find optimal factor settings. For further details about the Response Limits column property and examples of its use, see “Response Limits”.

If you do not specify a Lower Limit and Upper Limit, JMP uses the range of the observed data for the response to define the limits for the desirability function. Specifying the Lower Limit and Upper Limit gives you control over the specification of the desirability function. For more details about the construction of the desirability function, see the Profiler chapter in Profilers.

Factors

Add factors in the Factors outline.

**Tip:** When you have completed the Factors outline, consider selecting Save Factors from the red triangle menu. This option saves the factor names, roles, changes, and values in a data table that you can later reload in DOE platforms.

**Figure 9.14** Factors Outline

---

Continuous  Adds a Continuous factor. The data type in the resulting data table is Numeric. A continuous factor is a factor that you can conceptually set to any value between the lower and upper limits you supply, given the limitations of your process and measurement system.
**Discrete Numeric**  Adds a Discrete Numeric factor. A discrete numeric factor can assume only a discrete number of numeric values. These values have an implied order. The data type in the resulting data table is Numeric.

A screening design includes all levels of a discrete numeric factor and attempts to balance the levels. Fit Model treats a discrete numeric factor as a continuous predictor.

The default values for a discrete numeric factor with \( k \) levels, where \( k > 2 \), are the integers 1, 2, ..., \( k \). The default values for a discrete numeric factor with \( k = 2 \) levels are -1 and 1. Replace the default values with the settings that you plan to use in your experiment.

**Categorical**  Adds a Categorical factor. Click to select or specify the number of levels. The data type in the resulting data table is Character. The value ordering of the levels is the order of the values, as entered from left to right. This ordering is saved in the Value Order column property after the design data table is created.

The default values for a categorical factor are \( L_1, L_2, \ldots, L_k \), where \( k \) is the number of levels that you specify. Replace the default values with level names that are relevant for your experiment.

**Remove**  Removes the selected factors.

**Add N Factors**  Adds multiple factors. Enter the number of factors to add, click Add Factor, and then select the factor type. Repeat Add N Factors to add multiple factors of different types.

**Factors Outline**

The Factors outline contains the following columns:

**Name**  The name of the factor. When added, a factor is given a default name of \( X_1, X_2 \), and so on. To change this name, double-click it and enter the desired name.

**Role**  The Design Role of the factor. The Design Role column property for the factor is saved to the data table. This property ensures that the factor type is modeled appropriately. The Role of the factor determines other factor properties that are saved to the data table. See “Factor Column Properties”.

**Values**  The experimental settings for the factors.

**Editing the Factors Outline**

In the Factors outline, note the following:

- To edit a factor name, double-click the factor name.
- To edit a value, click the value in the Values column.
Factor Column Properties

For each factor, various column properties are saved to the design table after you create the design by selecting Make Table in the Screening Design window. These properties are also saved automatically to the data table that is created when you select the Save Factors option. You can find more information about these column properties and related examples in “Column Properties”.

Coding  If the Role is Continuous or Discrete Numeric, the Coding column property for the factor is saved. This property transforms the factor values so that the low and high values correspond to –1 and +1, respectively. See “Coding”.

Value Order  If the Role is Categorical or if a Block variable is constructed, the Value Order column property for the factor is saved. This property determines the order in which levels of the factor appear. See “Value Order”.

Design Role  Each factor is given the Design Role column property. The Role that you specify in defining the factor determines the value of its Design Role column property. When you select a design with a block, that Block factor is assigned the Blocking value. The Design Role property reflects how the factor is intended to be used in modeling the experimental data. Design Role values are used in the Augment Design platform. See “Design Role”.

Factor Changes  Each factor is assigned the Factor Changes column property with the value of Easy. The Factor Changes property reflects how the factor is used in modeling the experimental data. Factor Changes values are used in the Augment Design and Evaluate Design platforms. See “Factor Changes”.

RunsPerBlock  For a blocking factor, indicates the maximum allowable number of runs in each block. When a Blocking factor is specified in the Factors outline, the RunsPerBlock column property is saved for that factor. See “RunsPerBlock”.

Choose Screening Type

After you enter your responses and factors and click Continue, one of the following results occurs:

- If a standard design can accommodate your factors and levels, two options appear in the Choose Screening Type panel. See “Choose Screening Type Options”.
- If no listed standard design exists for your factors and levels, then the Choose Screening Type panel does not appear. The Design Generation outline for constructing a main effects screening design opens. See “Design Generation”.
Choose Screening Type Options

Choose from a list of fractional factorial designs  Enables you to select from a list of designs. This option is the default. See “Choose from a List of Fractional Factorial Designs”.

Construct a main effects screening design  Opens the Design Generation outline where you can specify the number of runs in the main effects screening design. For more information about main effects screening designs, see “Main Effects Screening Designs”.

Choose from a List of Fractional Factorial Designs

The list of screening designs that you can choose from includes designs that group the experimental runs into blocks of equal sizes where the size is a power of two. Select the type of screening design that you want to use and click Continue.

Figure 9.15  Choosing a Type of Fractional Factorial Design

The Design List contains the following columns:

Number of Runs  Total number of runs in the design.

Block Size  Number of runs in a block. The number of blocks is the Number of Runs divided by Block Size.

Design Type  Description of the type of design. See “Design Type”.

Resolution  Gives the resolution of the design and a brief description of the type of aliasing. See “Resolution as a Measure of Confounding”.

Design Type

The Design List provides the following types of designs:

• “Two-Level Full Factorial”
• “Two-Level Regular Fractional Factorial”
• “Plackett-Burman Designs”
Screening Designs
Chapter 9
Screening Design Window

• “Mixed-Level Designs”
• “Cotter Designs”

Two-Level Full Factorial

A full factorial design has runs for all combinations of the levels of the factors. The sample size is the product of the levels of the factors. For two-level designs, this is \(2^k\) where \(k\) is the number of factors.

Full factorial designs are orthogonal for all effects. It follows that estimates of the effects are uncorrelated. Also, if you remove an effect from the analysis, the values of the other estimates do not change. Their \(p\)-values change slightly, because the estimate of the error variance and the degrees of freedom are different.

Full factorial designs allow the estimation of interactions of all orders up to the number of factors. However, most empirical modeling involves only first- or second-order approximations to the true functional relationship between the factors and the responses. From this perspective, full factorial designs are an inefficient use of experimental runs.

Two-Level Regular Fractional Factorial

A regular fractional factorial design also has a sample size that is a power of two. For two-level designs, if \(k\) is the number of factors, the number of runs in a regular fractional factorial design is \(2^k - p\) where \(p < k\). A \(2^k - p\) fractional factorial design is a \(2^{-p}\) fraction of the \(k\)-factor full factorial design. Like full factorial designs, regular fractional factorial designs are orthogonal.

A full factorial design for \(k\) factors provides estimates of all interaction effects up to degree \(k\). But because experimental runs are typically expensive, smaller designs are preferred. In a smaller design, some of the higher-order effects are confounded with other effects, meaning that the effects cannot be distinguished from each other. Although a linear combination of the confounded effects is estimable, it is not possible to attribute the variation to a specific effect or effects.

In fact, fractional factorials are designed by deciding in advance which interaction effects are confounded with other interaction effects. Experimenters are usually not concerned with interactions involving more than two factors. Three-way and higher-order interaction effects are often assumed to be negligible.

Plackett-Burman Designs

Plackett-Burman designs are an alternative to regular fractional factorials for screening. The number of runs in a Plackett-Burman design is a multiple of four rather than a power of two. There are no two-level fractional factorial designs with run sizes between 16 and 32. However, there are 20-run, 24-run, and 28-run Plackett-Burman designs.
In a Plackett-Burman design, main effects are orthogonal and two-factor interactions are only partially confounded with main effects. By contrast, in a regular Resolution 3 fractional factorial design, some two-factor interactions are indistinguishable from main effects. Plackett-Burman designs are useful when you are interested in detecting large main effects among many factors and where interactions are considered negligible.

**Mixed-Level Designs**

For most designs that involve categorical or discrete numeric factors at three or more levels, standard designs do not exist. In such cases, the screening platform generates *main effects screening designs*. These designs are orthogonal or near orthogonal for main effects.

For cases where standard mixed-level designs exist, the possible designs are given in the Design List. The Design List provides fractional factorial designs for pure three-level factorials with up to 13 factors. For mixed two-level and three-level designs, the Design list includes the complete factorials and the orthogonal-array designs listed in Table 9.1.

If your number of factors does not exceed the number for a design listed in the table, you can adapt that design by using an appropriate subset of its columns.

**Table 9.1  Table of Mixed-Level Designs**

<table>
<thead>
<tr>
<th>Design</th>
<th>Two–Level</th>
<th>Three–Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>L18 John and L18 Taguchi</td>
<td>1</td>
<td>7</td>
</tr>
<tr>
<td>L18 Chakravarty</td>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>L18 Hunter</td>
<td>8</td>
<td>4</td>
</tr>
<tr>
<td>L36 Taguchi</td>
<td>11</td>
<td>12</td>
</tr>
</tbody>
</table>

**Cotter Designs**

*Note:* By default, Cotter designs are not included in the Design List. To include Cotter designs, deselect *Suppress Cotter Designs* in the Screening Design red triangle menu. To always show Cotter designs, select *File > Preferences > Platforms > DOE* and deselect *Suppress Cotter Designs*. 
Cotter designs are useful when you must test many factors, some of which might interact, in a very small number of runs. Cotter designs rely on the principle of effect sparsity. They assume that the sum of effects shows an effect if one of the components of the sum has an active effect. The drawback is that several active effects with mixed signs might sum to near zero, thereby failing to signal an effect. Because of this false-negative risk, many statisticians discourage their use.

For $k$ factors, a Cotter design has $2k + 2$ runs. The design structure is similar to the “vary one factor at a time” approach.

The Cotter design is constructed as follows:

- A run is defined with all factors set to their high level.
- For each of the next $k$ runs, one factor in turn is set at its low level and the others high.
- The next run sets all factors at their low level.
- For each of the next $k$ runs, one factor in turn is set at its high level and the others low.
- The runs are randomized.

When you construct a Cotter design, the design data table includes a set of columns to use as regressors. The column names are of the form `<factor name> Odd` and `<factor name> Even`. They are constructed by summing the odd-order and even-order interaction terms, respectively, that contain the given factor.

For example, suppose that there are three factors, A, B, and C. Table 9.2 shows how the values in the regressor columns are calculated.

<table>
<thead>
<tr>
<th>Table 9.2 Cotter Design Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Effects Summed for Odd and Even Regressor Columns</td>
</tr>
<tr>
<td>AOdd = A + ABC</td>
</tr>
<tr>
<td>BOdd = B + ABC</td>
</tr>
<tr>
<td>COdd = C + ABC</td>
</tr>
</tbody>
</table>

The Odd and Even columns define an orthogonal transformation. For this reason, tests for the parameters of the odd and even columns are equivalent to testing the combinations on the original effects.

**Resolution as a Measure of Confounding**

The *resolution* of a design is a measure of the degree of confounding in the design. The trade-off in screening designs is between the number of runs and the resolution of the design.
Experiments are classified by *resolution number* into these groups:

- Resolution 3 means that some main effects are confounded with one or more two-factor interactions. In order for the main effects to be meaningful, these interactions must be assumed to be negligible.

- Resolution 4 means that main effects are not confounded with other main effects or two-factor interactions. However, some two-factor interactions are confounded with other two-factor interactions.

- Resolution 5 means that there is no confounding between main effects, between main effects and two-factor interactions, and between pairs of two-factor interactions. Some two-factor interactions are confounded with three-factor interactions.

- Resolution 5+ means that the design has resolution greater than 5 but is not a full factorial design.

- Resolution 6 means that there is no confounding between effects of any order. The design is a full factorial design.

A *minimum aberration* design is one that minimizes the number of confoundings for a given resolution. A minimum aberration design of a given resolution minimizes the number of *words* in the defining relation that are of minimum length. For a description of *words*, see “Change Generating Rules”. For a discussion of minimum aberration designs, see Fries and Hunter (1984).

**Display and Modify Design**

In the Design List, if you select a fractional factorial design with all continuous or two-level categorical factors, and possibly a blocking factor, the Display and Modify Design outline opens after you click Continue. Modify your design using the reports in this outline. See “Modify Generating Rules in a Fractional Factorial Design” for an example of changing the generating rules to construct a design.

**Note:** The Change Generating Rules and Aliasing of Effects outlines do not appear for Plackett-Burman designs or Cotter designs, because interactions are not identically equal to main effects.

**Change Generating Rules** Specify the defining relation for the design. The defining relation determines which fraction of the full factorial design that JMP provides. See “Change Generating Rules”.

**Aliasing of Effects** Shows the confounding pattern for the fractional factorial design. Click the red arrow at the bottom of the panel to see interactions to a specified order. The interactions and their aliases are presented in a data table.

**Coded Design** Shows the pattern of high and low values for the factors in each run.
Note: For Cotter designs, the Change Generating Rules and Aliasing of Effects outlines do not apply and are not shown.

Change Generating Rules

The generating rules define the relation used to construct a specific fractional factorial design. The default generator in the screening platform results in a minimum aberration design. A minimum aberration design minimizes the aliasing of lower-order effects. Your experimental situation might require that you define a fraction of the design that provides a coding or aliasing structure that is different from the standard fraction. You can do this by changing the generating rules in the Display and Modify Design outline. For more information about defining relations and generating rules, see Montgomery (2009).

Tip: If you want to create a design to estimate particular effects, consider using the Custom Designer. For more information about custom designs see “Custom Designs”.

The defining relation for a design is determined by the words in the generating rules. A word is represented by a product of factors, but it is interpreted as the element wise product of the entries in the design matrix for those columns. A defining relation consists of words whose product is a column of ones, called the identity.

Figure 9.16 shows the default-generating rules for a $2^{5-2}$ fractional factorial design (five factors and eight runs).

Figure 9.16  Generating Rules for the Standard $2^{5-2}$ Design
In each column of the Change Generating Rules panel, the factor listed at the top and the factors in the column whose boxes are selected form a word in the defining relation. For example, the first column indicates that Temperature = Feed Rate*Catalyst*Stir Rate is a word in the defining relation.

- If the +/- box is selected, the sign associated with the generating rule is positive and the corresponding word equals the identity.
- If the +/- box is not selected, the sign associated with the generating rule is negative and the corresponding word equals minus the identity.

See “Obtain the Defining Relations in the $2^5-2$ Design”.

The principal fraction of a full factorial design is the fractional factorial design obtained by setting all the defining relations equal to the identity. By default, the factorial design that JMP provides is the principal fraction. Notice that the +/- box is selected by default for all generating rules, so that each word in the defining relation equals the identity.

Generating rules determine the coding and aliasing of effects for the design. In some cases, you might want to use a fraction that results in a coding or an aliasing structure that differs from that of the standard fraction.

- To change the generating rules, select the appropriate boxes.
- To see the effect of your selections on the Aliasing of Effects results and on the Coded Design, click **Apply**.

For an example, see “Change the Generating Rules to Obtain a Different Fraction”.

**Obtain the Defining Relations in the $2^5-2$ Design**

Figure 9.16 shows two columns of check boxes:

- The first column represents the word Temperature = Feed Rate*Catalyst*Stir Rate.
- The second column represents the word Concentration = Catalyst*Stir Rate.

Define I to represent a column consisting of the values +1. Because all factor levels are -1 or +1, the word in the first column is equivalent to Temperature*Feed Rate*Catalyst*Stir Rate = I. The word in the second column is equivalent to Concentration*Catalyst*Stir Rate = I. Together, these give the defining relations for the $2^5-2$ design:

$$I = \text{Temperature} \times \text{Feed Rate} \times \text{Catalyst} \times \text{Stir Rate} = \text{Concentration} \times \text{Catalyst} \times \text{Stir Rate}$$

**Obtain the Aliasing of Effects Relations in the $2^5-2$ Design**

The aliasing structure in the Aliasing of Effects outline is determined by the defining relations and the fact that factor levels are +1 and -1. Recall that the first generating rule is Temperature = Feed Rate*Catalyst*Stir Rate and the second is Concentration = Catalyst*Stir Rate.
To obtain the first relation in the Aliasing of Effects outline, notice that applying these two generating rules gives the expression:

\[
\text{Temperature} = \text{Feed Rate} \times \text{Catalyst} \times \text{Stir Rate} = \text{Feed Rate} \times \text{Concentration}
\]

- The second equality follows from replacing \(\text{Catalyst} \times \text{Stir Rate}\) by \(\text{Concentration}\) using the second generating rule.

Now, post-multiply the first and third expressions by \(\text{Concentration}\) to obtain the following expression:

\[
\text{Temperature} \times \text{Concentration} = \text{Feed Rate} \times \text{Concentration} \times \text{Concentration}
\]

Because the column for \(\text{Concentration}\) in the design matrix contains values of -1 and +1, the term \(\text{Concentration} \times \text{Concentration}\) represents a column of +1 values. The expression becomes the first alias relation shown in the Aliasing of Effects outline:

\[
\text{Temperature} \times \text{Concentration} = \text{Feed Rate} \times \text{I} = \text{Feed Rate}
\]

The other alias relations can be obtained using similar calculations.

### Main Effects Screening Designs

If an experiment involves categorical or discrete numeric factors, or if the number of runs is constrained, it might not be possible to construct an orthogonal design for screening main effects. However, a main effects screening design can be constructed. See Lekivetz et al. (2015).

A main effects screening design is a design with good balance properties as described by a Chi-square criterion. See “Chi-Square Efficiency”. Such designs have desirable statistical properties for main effect models.

The algorithm used to generate the design attempts to construct an orthogonal array of strength two. Strength-two orthogonal arrays permit orthogonal estimation of main effects when interactions are negligible. These arrays are ideal for screening designs. Regular fractional factorial designs of Resolution 3 and Plackett-Burman designs are examples of strength-two orthogonal arrays.

Consider all possible pairs of levels for factors in the design. The algorithm attempts to balance the number of pairs of levels as far as possible. Given that a fixed number of columns has been generated, a new balanced column is randomly constructed. A measure is defined that reflects the degree of balance achieved for pairs that involve the new column. The algorithm attempts to minimize this measure by interchanging levels within the new column.
Chi-Square Efficiency

Suppose that a design has \( n \) runs and \( p \) factors corresponding to the columns of the design matrix.

- Denote the levels of factors \( k \) and \( l \) by \( a = 0, 1, \ldots, s_k - 1 \) and \( b = 0, 1, \ldots, s_l - 1 \), respectively.
- Denote the number of times that the combination of levels \((a,b)\) appears in columns \( k \) and \( l \) by \( n_{kl}(a,b) \).

A measure of the lack of orthogonality evidenced by columns \( k \) and \( l \) is given by the following expression:

\[
\chi^2_{kl} = \sum_{a=0}^{s_k-1} \sum_{b=0}^{s_l-1} \frac{[n_{kl}(a,b) - n/(s_k s_l)]^2}{n/(s_k s_l)}
\]

A measure of the average non-orthogonality of the design is given by this expression:

\[
\chi^2 = \sum_{1 \leq k < l \leq p} \frac{\chi^2_{kl}}{[p(p-1)/2]}
\]

The maximum possible value of \( \chi^2 \), denoted \( \chi_{max}^2 \), is obtained. The chi-square efficiency of a design is defined as follows:

\[
\text{Chi-Square Efficiency} = 100 \left( 1 - \frac{\chi^2}{\chi_{max}^2} \right)
\]

Chi-square efficiency indicates how close \( \chi^2 \) is to zero, relative to a design in which pairs of levels show extreme lack of balance.

Design Generation

When you construct a main effects screening design, the Design Generation outline enables you to specify the number of runs. To generate the design, click **Make Design**.

**Minimum**  
A lower bound on the number of runs necessary to avoid failures in design generation. When you select Minimum, the resulting design is saturated. There are no degrees of freedom for error.

**Note:** If you select the Minimum number of runs, there is no error term for testing. You cannot test parameter estimates. This choice is appropriate only when the cost of additional runs is prohibitive.

**Default**  
Suggests the number of runs. This value is based on heuristics for creating a balanced design with at least four runs more than the Minimum number of runs.
User Specified Specify the number of runs that you want. Enter that value into the Number of Runs text box. This option enables you to balance the cost of additional runs against the potential gain in information.

Design

The Design outline shows the runs for the main effects screening design. To change the run order for your design table, you can select Run Order options in the Output Options panel before generating the table.

Design Evaluation

**Note:** The Design Evaluation outline is not shown for Cotter designs.

The Design Evaluation outline provides a number of ways to evaluate the properties of the generated design. Open the Design Evaluation outline to see the following options:

- **Power Analysis** Enables you to explore your ability to detect effects of given sizes.
- **Prediction Variance Profile** Shows the prediction variance over the range of factor settings.
- **Fraction of Design Space Plot** Shows how much of the model prediction variance lies below (or above) a given value.
- **Prediction Variance Surface** Shows a surface plot of the prediction variance for any two continuous factors.
- **Estimation Efficiency** For each parameter, gives the fractional increase in the length of a confidence interval compared to that of an ideal (orthogonal) design, which might not exist. Also gives the relative standard error of the parameters.
- **Alias Matrix** Gives coefficients that indicate the degree by which the model parameters are biased by effects that are potentially active, but not in the model.
- **Color Map on Correlations** Shows the absolute correlation between effects on a plot using an intensity scale.
- **Design Diagnostics** Indicates the optimality criterion used to construct the design. Also gives efficiency measures for your design.

**Note:** The model used for the design diagnostics contains all main effects and two-factor interactions when all two-factor interactions are estimable. Otherwise, the model contains all main effects.

For more details about the Design Evaluation panel, see “Design Evaluation”.

Output Options

Specify details for the output data table in the Output Options panel. When you have finished, click Make Table to construct the data table for the design. Figure 9.17 shows the Output Options panel for a standard design selected from the Design List. For a main effects screening design, only Run Order is available.

Figure 9.17  Select the Output Options

Run Order

The Run Order options determine the order of the runs in the design table.

Keep the Same  Rows in the design table are in the same order as in the Coded Design or Design outlines.

Sort Left to Right  Columns in the design table are sorted from left to right.

Randomize  Rows in the design table are in random order.

Sort Right to Left  Columns in the design table are sorted from right to left.

Randomize within Blocks  Rows in the design table are in random order within the blocks.
(Not available if you select Construct a main effects screening design.)

Center Points and Replicates

Number of Center Points  Specifies how many additional runs to add as center points to the design. A center point is a run where every continuous factor is set at the center of the factor's range. This option is not available if you select Construct a main effects screening design.

Suppose that your design includes both continuous and categorical factors. If you request center points in the Output Options panel, the center points are distributed as follows:

1. The settings for the categorical factors are ordered using the value ordering specified in the Factors outline.

2. One center point is assigned to each combination of the settings of the categorical factors in order, and this is repeated, until all center points are assigned.
**Number of Replicates**  For designs in the Design List, specify the number of times to replicate the entire design, including center points. One replicate doubles the number of runs. This option is not available if you select **Construct a main effects screening design**.

**Note:** If you request center points or replicates and click Make Table repeatedly, these actions are applied to the most recently constructed design table.

**Make Table**

Click **Make Table** to create a data table that contains the runs for your experiment. In the table, the high and low values that you specified appear for each run.

**Figure 9.18 The Design Data Table**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Feed Rate</th>
<th>Catalyst</th>
<th>Stir Rate</th>
<th>Temperature</th>
<th>Concentration</th>
<th>Percent Reacted</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>10</td>
<td>2</td>
<td>120</td>
<td>140</td>
<td>6</td>
<td>•</td>
</tr>
<tr>
<td>2</td>
<td>15</td>
<td>1</td>
<td>120</td>
<td>140</td>
<td>3</td>
<td>•</td>
</tr>
<tr>
<td>3</td>
<td>10</td>
<td>2</td>
<td>100</td>
<td>180</td>
<td>3</td>
<td>•</td>
</tr>
<tr>
<td>4</td>
<td>15</td>
<td>2</td>
<td>120</td>
<td>180</td>
<td>6</td>
<td>•</td>
</tr>
<tr>
<td>5</td>
<td>10</td>
<td>1</td>
<td>120</td>
<td>180</td>
<td>3</td>
<td>•</td>
</tr>
<tr>
<td>6</td>
<td>15</td>
<td>1</td>
<td>100</td>
<td>180</td>
<td>6</td>
<td>•</td>
</tr>
<tr>
<td>7</td>
<td>10</td>
<td>1</td>
<td>100</td>
<td>140</td>
<td>6</td>
<td>•</td>
</tr>
<tr>
<td>8</td>
<td>15</td>
<td>2</td>
<td>100</td>
<td>140</td>
<td>3</td>
<td>•</td>
</tr>
</tbody>
</table>

The name of the table is the design type that generated it.

The design table includes the following scripts:

**Screening**  Runs the DOE > Classical > Two Level Screening > Fit Two Level Screening platform. Only provided when all factors are at two levels.

**Model**  Runs the Analyze > Fit Model platform.

**Evaluate Design**  Runs the DOE > Design Diagnostics > Evaluate Design platform.

**DOE Dialog**  Re-creates the Screening Design window that you used to generate the design table. The script also contains the random seed used to generate your design.

Run the **Screening** or **Model** scripts to analyze the data.
If the design was selected from the Design List, the design table contains a Pattern column. The Pattern column contains entries that summarize the run in the given row. Low settings are denoted by “−”, high settings by “+”, and center points by “0”. Pattern can be useful as a label variable in plots.

### Screening Design Options

The Screening Design red triangle menu contains the following options:

- **Save Responses**  Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.

- **Load Responses**  Loads responses that you saved using the Save Responses option.

- **Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

  **Note:** It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting **Column Properties > Design Role**. In the Design Role area, select the appropriate role.

- **Load Factors**  Loads factors that you saved using the Save Factors option.

- **Save Constraints**  (Unavailable for some platforms) Saves factor constraints that you defined in the Define Factor Constraints or Linear Constraints outline into a data table, with a column for each constraint. You can then quickly load the constraints into most DOE windows.

  In the constraint table, the first rows contain the coefficients for each factor. The last row contains the inequality bound. Each constraint’s column contains a column property called **ConstraintState** that identifies the constraint as a “less than” or a “greater than” constraint. See “**ConstraintState**”.

- **Load Constraints**  (Unavailable for some platforms) Loads factor constraints that you saved using the Save Constraints option.

- **Set Random Seed**  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:
  - initializing search algorithms for design generation
– randomizing Run Order for design construction
– selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking Make Design.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

### Simulate Responses

Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

– A set of simulated response values is added to each response column.
– For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
– A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

**Note:** Not all distributions are available for all design types.

– A script called **DOE Simulate** is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a new column called `<Y> Simulated`, where `Y` is the name of the response. Clicking Apply again updates the formula and values in `<Y> Simulated`.

For additional details, see “Simulate Responses”.

**Note:** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in *Basic Analysis*.

### Save X Matrix

Saves the Moments Matrix and Model Matrix to table scripts in the design data table. These scripts contain the moments and design matrices. See “Save X Matrix”.

**Caution:** For a design with nominal factors, the Model Matrix saved by the Save X Matrix option is not the coding matrix used in fitting the linear model. You can obtain the coding matrix used for fitting the model by selecting the option Save Columns > Save Coding Table in the Fit Model report that you obtain when you run the Model script.
**Suppress Cotter Designs**  Excludes Cotter designs from the Design List. This option is selected by default. Deselect it to show Cotter designs in the Design List.

**Note:** You can set a preference to always show Cotter designs. Select File > Preferences > Platforms > DOE and deselect Suppress Cotter Designs.

**Number of Starts**  (Available only for Main Effects Screening Designs.) Specify the maximum number of times that the algorithm regenerates entire designs from scratch, attempting to optimize the final design.

**Design Search Time**  (Available only for Main Effects Screening Designs.) Specify the maximum number of seconds spent searching for a design. The default search time is 15 seconds.

If the iterations of the algorithm require more than a few seconds, a Computing Design progress window appears. The progress bar displays *Chi2 Efficiency*. See “Chi-Square Efficiency”. If you click Cancel in the progress window, the calculation stops and gives the best design found at that point.

**Note:** You can set a preference for Design Search Time. Select File > Preferences > Platforms > DOE. Select Design Search Time and enter the maximum number of seconds. If an orthogonal array is found, the search terminates. In certain situations where more time is required, JMP automatically extends the search time.

**Number of Column Starts**  (Available only for Main Effects Screening Designs.) Specify the maximum number of times that the algorithm attempts to optimize a given column before moving on to constructing the next column. The default number of column starts is 50. See “Main Effects Screening Designs”.

**Save Script to Script Window**  Creates the script for the design that you specified in the Screening Design window and places it in an open script window.

### Additional Examples of Screening Designs

- “Modify Generating Rules in a Fractional Factorial Design”
- “Plackett-Burman Design”
**Modify Generating Rules in a Fractional Factorial Design**

This example, adapted from Meyer, et al. (1996), shows how to use the Screening Design platform when you have many factors. In this example, a chemical engineer investigates the effects of five factors on the percent reaction of a chemical process. The factors are:

- Feed Rate - the amount of raw material added to the reaction chamber in liters per minute
- Catalyst (as a percent)
- Stir Rate - the RPMs of a propeller in the chamber
- Temperature (in degrees Celsius)
- Concentration of reactant

Production constraints limit the size of the experiment to no more than twelve runs. You decide to consider the 8-run fractional factorial design and the 12-run Plackett-Burman design. Also, you suspect the following statements to be true:

- The Temperature*Concentration interaction is active, so you want a design that does not alias this interaction with a main effect.
- The Catalyst*Temperature* interaction is not likely to be active.
- The Stir Rate*Concentration interaction is not likely to be active.

Use this information in constructing your design.

**Create the Standard Fractional Factorial Design**

To create the standard fractional factorial design, do the following:

- “Specify the Response”
- “Specify the Factors” or “Specify Factors Manually”
- “Choose a Design”

**Specify the Response**

1. Select **DOE > Classical > Two Level Screening > Screening Design**.
2. Double-click Y under Response Name and type **Percent Reacted**.
   
   Note that the default Goal is Maximize. The Goal is to maximize the response, but the minimum acceptable reaction percentage is 90 (Lower Limit) and the upper limit is 100 (Upper Limit).
3. Click under Lower Limit and type 90.
4. Click under Upper Limit and type 100.
5. Leave the area under Importance blank.
   
   Because there is only one response, that response is given Importance 1 by default.
See Figure 9.19 for the completed Responses outline. Now, specify the factors.

**Specify the Factors**

You can enter the factors manually or automatically:

- To enter the factors automatically, use the Reactor Factors.jmp data table:
  1. Select Help > Sample Data Library and open Design Experiment/Reactor Factors.jmp.
  2. Click the Screening Design red triangle and select Load Factors. Proceed to “Choose a Design”.

- To enter the factors manually, follow the steps below.

**Specify Factors Manually**

1. Add five continuous factors by entering 5 in the Add N Factors box and clicking Continuous.

2. Change the default factor names (X1-X5) to Feed Rate, Catalyst, Stir Rate, Temperature, and Concentration.

3. Enter the low and high values for each factor:
   - Feed Rate: 10, 15
   - Catalyst: 1, 2
   - Stir Rate: 100, 120
   - Temperature: 140, 180
   - Concentration: 3, 6

**Figure 9.19  Responses and Factors Outlines**
Choose a Design

1. Click **Continue**.

2. From the Choose Screening Type pane, accept the default selection to Choose from a list of fractional factorial designs and click **Continue**.

   Designs for the factors and levels that you specified are listed in the Design List (Figure 9.20).

**Figure 9.20** Fractional Factorial Designs for Five Continuous Factors

3. The design that you want is the first in the list and happens to be selected by default (Figure 9.20). Accept that selection and click **Continue**.

   Because you are limited to eight runs and have no blocking factor, your best design option is the 8-run fractional factorial design with no blocks. This design is a $2^{5-2}$ fractional factorial design. It is one quarter of the full factorial design for five factors.

Change the Generating Rules to Obtain a Different Fraction

In this example, you want to know whether the Temperature*Concentration interaction is confounded with a main effect. Use the Display and Modify Design outline to view the aliasing structure for the design that you selected and to change it, if appropriate.

1. Open the Aliasing of Effects outline.
The Temperature*Concentration interaction, which you suspect is active, is confounded with Feed Rate, a main effect. You want to change the generating rules to construct a design where Feed Rate is aliased with effects that you suspect are inactive, and where the Temperature*Concentration interaction is not aliased with a main effect.

2. Open the Change Generating Rules outline.

The default-generating rules give you the standard (or principal) one-quarter fraction of the full factorial design. Recall that you suspect that the Catalyst*Temperature and Stir Rate*Concentration interactions are not likely to be active. Redefine the generating rules so that these two interactions are confounded with Feed Rate. The redefined generating rules give you a different one-quarter fraction of the full factorial design.

3. Do the following:
   – Deselect Stir Rate in the Temperature column.
   – Deselect Catalyst in the Concentration column.
   – Select Feed Rate in the Concentration column.

4. Click Apply.
In the design that you have defined, Feed Rate is confounded with Catalyst*Temperature and Stir Rate*Concentration. Also, the Temperature*Concentration interaction is now confounded with the two-way interaction Catalyst*Stir Rate.

5. In the Output Options outline, accept the default Run Order setting of Randomize and click Make Table.

Figure 9.24 Eight-Run Fractional Factorial Design Table

The design table shows the design that you constructed. Notice that the table contains a column for the response that you defined in the Screening window, Percent Reacted, where you can record your experimental results.

The Screening, Model, and DOE Dialog scripts are also included. For more information about these scripts, see “Make Table”.

Analyze the Results

Next you conduct the experiment, record your data, and proceed to analyze the results.

1. Select Help > Sample Data Library and open Design Experiment/Reactor 8 Runs.jmp.

   You can estimate seven effects with your eight runs. Of these, you expect only a few to be active. Because you want to estimate seven effects, there are no degrees of freedom for error. For these reasons, you use the Screening platform to analyze the results.

2. Run the Screening script in the data table.

   The Screening script launches the Screening platform (DOE > Classical > Two Level Screening > Fit Two Level Screening) for your response and factors.
Figure 9.25 Report for Screening Example

Note: Since the \( p \)-values are obtained using a simulation-based technique, your \( p \)-values might not precisely match those shown here.

The report shows both Individual and Simultaneous \( p \)-values based on Lenth t-ratios. None of the effects are significant, even with respect to the Individual \( p \)-values. The Half Normal Plot suggests that the effects reflect only random noise.

For more information about the Screening report, see “The Screening Report”.

Plackett-Burman Design

The Fractional Factorial example shows an 8-run fractional factorial design for five continuous factors. But suppose you can afford 4 additional runs. In this example, construct a 12-run Plackett-Burman design. To facilitate completing the Screening window, use the Load Responses and Load Factors commands.

Create the Plackett-Burman Design

1. Select DOE > Classical > Two Level Screening > Screening Design.
2. Select Help > Sample Data Library and open Design Experiment/Reactor Response.jmp.
3. Click the Screening Design red triangle and select Load Responses.
4. Select Help > Sample Data Library and open Design Experiment/Reactor Factors.jmp.
5. Click the Screening Design red triangle and select **Load Factors**.
   The **Load Responses** and **Load Factors** commands fill in the Responses and Factors outlines with the response and factor names, goal and limits for the response, and values for the factors. See Figure 9.19 for the completed Responses and Factors outlines.

6. Click **Continue**.

   **Note:** Setting the random seed in the next step reproduces the run order shown in this example. In constructing a design on your own, this step is not necessary.

7. (Optional) Click the Screening Design red triangle, select **Set Random Seed**, type 34567, and click **OK**.

8. From the Choose Screening Type panel, accept the default selection to **Choose from a list of fractional factorial designs** and click **Continue**.

9. Select the Plackett-Burman design.
   Plackett-Burman designs with run sizes that are not a power of two tend to have complex aliasing structures. In particular, main effects can be partially aliased with several two-way interactions. See “Evaluate the Design”. Notice that the 12-run Plackett-Burman design is designated as having Resolution 3.

Figure 9.26  Design List Showing Plackett-Burman Screening Design

10. Click **Continue**.

11. Click **Make Table**.
A column called Percent Reacted is included in the design table. You should conduct your experimental runs in the order shown in the table, recording your results in the Percent Reacted column.

**Evaluate the Design**

1. Return to your Screening Design window. If you have closed this window, run the DOE Dialog script in your design table.
2. Open the **Design Evaluation > Color Map on Correlations** outline.
The diagonal cells have correlations of one, as expected. White cells correspond to effects that have correlations equal to 0. The gray and black cells correspond to effects that have correlations greater than zero. Hover over cells to see the effects involved and their absolute correlations. For example, notice that Feed Rate is correlated with several two-way and three-way interactions.

**Note:** The color map from the screening design contains 3-way interactions for designs with 8 or fewer factors. The color map from the design evaluation script only contains up to 2-way interactions.

3. Open the Alias Matrix outline.

**Figure 9.29** Alias Matrix - Partial View Showing Up to Two-Way Interactions
Because the design is orthogonal for the main effects, the Alias Matrix gives the numerical values of the correlations between effects. See “Alias Matrix”. For example, notice that Feed Rate is partially aliased with six two-way interactions and with four three-way interactions. These are the interactions corresponding to the entries of 0.333 and -0.33 in the row for Feed Rate.

**Analyze the Results**

The data table Plackett-Burman.jmp contains the results of the designed experiment. Recall that you suspect that the Temperature*Concentration interaction is active. You proceed under the assumption that this is the only potentially active interaction.

1. Select Help > Sample Data Library and open Design Experiment/Plackett-Burman.jmp.
2. Run the Model script by clicking the icon to its left.
3. Select Temperature in the Select Columns list and Concentration in the Construct Model Effects list.
4. Click Cross.
5. Click Run.

**Figure 9.30** Parameter Estimates for Full Model

The Actual by Predicted Plot indicates no lack of model fit. The Parameter Estimates report shows that Catalyst is significant at the 0.05 level and that the Concentration*Temperature interaction is almost significant at the 0.10 level.

**Reduce the Model**

You want to identify those effects that have the most impact on the response. To see these active effects more clearly, remove insignificant effects using the Effect Summary outline.

**Figure 9.31** Effect Summary Outline for Full Model
Although Concentration is the least significant effect, it is involved in a higher-order interaction (Concentration*Temperature), as indicated by the caret to the right of its PValue. Based on the principle of effect heredity, Concentration should not be removed from the model while the Concentration*Temperature interaction remains in the model. See “Effect Heredity”. The next least significant effect is Stir Rate.

1. In the Effect Summary outline, select Stir Rate and click **Remove**.
   Feed Rate is the next least significant effect that can be removed.

2. In the Effect Summary outline, select Feed Rate and click **Remove**.

**Figure 9.32** Effect Summary Outline for Reduced Model

![Effect Summary Table]

The PValue column indicates that the Catalyst main effect and the Concentration*Temperature interaction are both significant at the 0.05 level. The model should not be reduced any further. If all other interactions are inactive or negligible, then you can conclude that Catalyst and the Concentration*Temperature interaction are active effects.
The Fit Two Level Screening platform is a modeling platform that you can use to analyze experimental data results from a screening design. The Fit Two Level Screening platform helps you identify effects that have a large impact on the response.

The Fit Two Level Screening platform is based on the principle of effect sparsity (Box and Meyer 1986). This principle asserts that relatively few of the effects that you study in a screening design are active. Most are inactive, meaning that their true effects are negligible and that their estimates can be treated as random error.

A screening design often provides no degrees of freedom for error when the model of interest includes interaction terms. Consequently, classical tests for effects are not available. In such cases, the Fit Two Level Screening platform is particularly useful.

**Figure 10.1** Half Normal Plot from Fit Two Level Screening Report
## Contents

- Overview of the Fit Two Level Screening Platform .................................................. 339
- Example of Fit Two Level Screening Platform ................................................................. 339
- Launch the Fit Two Level Screening Platform ............................................................... 342
- The Screening Report ........................................................................................................ 343
  - Contrasts ......................................................................................................................... 344
  - Half Normal Plot ............................................................................................................. 344
  - Make or Run Model ....................................................................................................... 345
- Additional Fit Two Level Screening Analysis Examples .................................................. 345
  - Analyze a Plackett-Burman Design .............................................................................. 345
  - Effect Heredity Example ............................................................................................... 346
  - Analyze a Supersaturated Design ............................................................................... 348
- Technical Details for the Fit Two Level Screening Platform ............................................. 350
  - Order of Effect Entry .................................................................................................... 350
  - Fit Two Level Screening as an Orthogonal Rotation ................................................... 350
  - Lenth’s Pseudo-Standard Error ...................................................................................... 351
  - Lenth t-Ratios ............................................................................................................... 351
Overview of the Fit Two Level Screening Platform

The analysis of screening designs depends on the principle of *effect sparsity*, where most of the variation in the response is explained by a small number of effects. Under this principle, effects with small estimates are used to estimate the error in the model. This then allows one to test whether the larger effects are active.

You can analyze data from a screening experiment using Fit Model (Analyze > Fit Model) or Fit Two Level Screening (DOE > Classical > Two Level Screening > Fit Two Level Screening). Use the following guidelines to select the appropriate modeling platform:

- If your factors are all two-level and orthogonal, all of the statistics in the Fit Two Level Screening platform are appropriate.
- If you have data from a highly supersaturated main effect design, the Fit Two Level Screening platform is effective in selecting active factors, but it is not effective at estimating the error or the significance. The Monte Carlo simulation to produce *p*-values uses assumptions that are not valid for this case.
- If you have a categorical or a discrete numeric factor with more than two levels, the Fit Two Level Screening platform is not appropriate. JMP treats the associated model terms as continuous. For such factor, the variation is scattered across main effects and polynomial effects. In this situation, it is recommended that you use the Fit Model platform.
- If your data are not orthogonal, the constructed estimates in the Fit Two Level Screening Platform are different from standard regression estimates. JMP can identify large effects, but it does not effectively test each effect. This is because effects are artificially orthogonalized as they are entered into the model, making effects that enter early in the model appear less significant than in standard regression. See “Order of Effect Entry”.
- For mixture designs, the Fit Two Level Screening platform is not appropriate. See instead “Fitting Mixture Designs”.

Example of Fit Two Level Screening Platform

The Reactor Half Fraction.jmp sample data table contains the results of an experiment derived from a design discussed in Box et al. (1978). You are interested in identifying significant effects in a model that contains main effects and two-way interactions. This example uses a model with fifteen parameters for a design with sixteen runs. The example illustrates the analysis both with the Fit Two Level Screening Platform and the Fit Model Platform.

Fit Two Level Screening

1. Select Help > Sample Data Library and open Reactor Half Fraction.jmp.
2. Select **DOE > Classical > Two Level Screening > Fit Two Level Screening.**

3. Select Percent Reacted and click **Y.**

4. Select Feed Rate through Concentration, click **X,** and then click **OK.**

**Note:** The Fit Two Level Screening Platform automatically constructs a model with interaction terms. This is in contrast to the Fit Model Platform, where you manually specify the interactions that you want to include in your model.

**Figure 10.2 Reactor Half Fraction.jmp Fit Two Level Screening Design Report**

Note the following features of the Screening report:

- The effects that have an individual $p$-value less than 0.10 are selected.
- A $t$-ratio is calculated using Lenth’s PSE (pseudo-standard error). The Lenth PSE value is shown below the Half Normal Plot.
- Both individual and simultaneous $p$-values are shown. Those that are less than 0.05 are shown with an asterisk.
– The Half Normal Plot enables you to quickly examine the effects. The effects that are initially selected in the effects list are also labeled in this plot.

In this example, Catalyst, Temperature, and Concentration, along with two of their two-factor interactions, are selected. Alternatively, you can fit the same model in the Fit Model Platform.

**Fit Model**

1. From the Reactor Half Fraction.jmp table, select **Analyze > Fit Model**.
2. Select Percent Reacted, **click Y**.
3. Select Feed Rate through Concentration, and then select ** Macros > Factorial to Degree**.
4. **Click Run**.
5. Open the Parameter Estimates outline.

**Figure 10.3** Saturated Reactor Half Fraction.jmp Design Parameter Estimates

Since there are 16 observations and 16 model terms, there are not enough observations to estimate an error term. Without an estimate of error, it is not possible to conduct standard tests. Parameter estimates are provided, but because there are no degrees of freedom for error, standard errors, \( t \)-ratios, and \( p \)-values are all missing. This illustrates the strength of the Fit Two Level Screening platform for getting the most information out of a screening design.
Launch the Fit Two Level Screening Platform

Launch the Fit Two Level Screening platform by selecting **DOE > Classical > Two Level Screening > Fit Two Level Screening**.

**Figure 10.4** Launch Window for the Fit Two Level Screening Platform

- **Y** The columns to be analyzed. These must have a Numeric data type.
- **X** Continuous or discrete two-level orthogonal factors.
- **By** A column whose level define separate analyses. For each level of the specified column, the corresponding rows are analyzed. The results appear in separate reports. If more than one By variable is assigned, a separate analysis is produced for each possible combination of the levels of the By variables.

**Note:** If you created your design in the Screening Design Platform from a list of fractional factorial designs, the design table contains a script called **Screening**. Run this script to run the analysis directly.
The Fit Two Level Screening report shows a summary table of the design contrasts (candidate model terms) and a half normal plot. You can launch or run the selected model from the report.

**Figure 10.5  Screening Report**

- "Contrasts"
- "Half Normal Plot"
- “Make or Run Model”
The Contrasts report lists model effects, a contrast value, Lenth t-ratios, individual and simultaneous p-values, and aliases (if there are any). Effects are entered into the analysis following a hierarchical ordering. See “Order of Effect Entry”. Effects that have an Individual p-Value less than 0.10 are selected.

**Term**  
The name of the factor.

**Contrast**  
Estimate for the factor. For orthogonal designs, this number is the same as the regression parameter estimate. This is not the case for non-orthogonal designs. An asterisk might appear next to the contrast, indicating a lack of orthogonality.

**Bar Chart**  
Shows the Lenth t-ratios with blue vertical lines that indicate a value that is significant at the 0.10 level.

**Lenth t-Ratio**  
Lenth’s t-ratio, calculated as Contrast/PSE, where PSE is Lenth’s Pseudo-Standard Error. See “Lenth’s Pseudo-Standard Error”.

**Individual p-Value**  
Analogous to the standard p-values for a linear model. Small individual p-values indicate a significant effect. See “Lenth’s Pseudo-Standard Error”.

**Note:** Do not expect the p-values to be exactly the same if the analysis is re-run. The Monte Carlo method should give similar, but not identical, values if the same analysis is repeated.

**Simultaneous p-Value**  
A multiple-comparison adjusted p-value.

**Aliases**  
Appears only if there are exact aliases of later effects to earlier effects.

## Half Normal Plot

The Half Normal Plot shows the absolute value of the contrasts plotted against the absolute value of quantiles for the half-normal distribution. The blue line passes through the origin with a slope of the Lenth’s estimate of σ. Effects that are small are considered error terms and assumed to have a normal distribution with mean zero and standard deviation σ. These terms fall on the blue line. Significant effects are those that have nonzero means and do not fall on

The Half Normal Plot is interactive. You can select model effects by dragging a rectangle around the effects of interest. You can also press Ctrl and click an effect name(s) in the report.
Make or Run Model

The Make Model button launches a Fit Model window that is populated with the selected effects.

The Run Model button runs an effect screening model for the selected effects.

Note: A JMP alert appears if your selected model does not follow effect heredity. You can Cancel, use the Make Model button to launch the Fit Model window, and add the missing terms. Or, you can Continue and build a model that does not follow effect heredity rules. See “Effect Heredity”.

Additional Fit Two Level Screening Analysis Examples

- “Analyze a Plackett-Burman Design”
- “Effect Heredity Example”
- “Analyze a Supersaturated Design”

Analyze a Plackett-Burman Design

Plackett-Burman designs are an alternative to fractional-factorial screening designs. Two-level fractional factorial designs must, by their nature, have a number of runs that are a power of two. However, Plackett-Burman designs exist for 12-, 24-, and 28-run designs.

The Weld-Repaired Castings.jmp sample data table uses a Plackett-Burman design, and is found in Box et al. (1978). Seven factors are thought to be influential on weld quality. The seven factors include Initial Structure, Bead Size, Pressure Treatment, Heat Treatment, Cooling Rate, Polish, and Final Treatment. A Plackett-Burman design with 12 runs is used to investigate the importance of the seven factors. The response is $100 \times \log(\text{lifetime})$. (The sample data table also contains four terms that were used to model error, but those terms are not used in this analysis.)

1. Select Help > Sample Data Library and open Weld-Repaired Castings.jmp.
2. Select DOE > Classical > Two Level Screening > Fit Two Level Screening.

   The launch window is populated based on the column properties. Log Life (x100) is the response $Y$.

   The seven factors Initial Structure, Bead Size, Pressure Treatment, Heat Treatment, Cooling Rate, Polish, and Final Treatment are specified for $X$. 
3. Scroll to the bottom of the X window. Select $\varepsilon_1$, $\varepsilon_2$, $\varepsilon_3$, and $\varepsilon_4$, and click **Remove**.

4. **Click OK**.

**Figure 10.6** Screening Report for Weld-Repaired Castings.jmp

The only significant effect identified is **Polish**. Note that asterisks mark four terms, indicating that they are not orthogonal to the effects preceding them. The contrast values obtained for these effects are after orthogonalization. As a result, these estimates do not match estimates obtained from a corresponding regression analysis. You can use the **Run Model** button to fit the single-factor model.

**Effect Heredity Example**

This example illustrates building a model when the Fit Two Level Screening platform identifies a model that does not follow effect heredity.

1. Select **Help > Sample Data Library** and open Design Experiment/Plackett-Burman.jmp.
2. Select **DOE > Classical > Two Level Screening > Fit Two Level Screening**.
3. Select Percent Reacted and click **Y**.
4. Select Feed Rate through Concentration and click **X**.
5. Click **OK**.

**Figure 10.7** Model Contrasts

<table>
<thead>
<tr>
<th>Term</th>
<th>Contrast</th>
<th>Lenth t-Ratio</th>
<th>Individual p-Value</th>
<th>Simultaneous p-Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catalyst</td>
<td>8.33333</td>
<td>2.88</td>
<td>0.0896</td>
<td>0.1786</td>
</tr>
<tr>
<td>Temperature</td>
<td>5.00000</td>
<td>1.73</td>
<td>0.0979</td>
<td>0.3545</td>
</tr>
<tr>
<td>Feed Rate</td>
<td>-4.50000</td>
<td>-1.55</td>
<td>0.1248</td>
<td>0.6650</td>
</tr>
<tr>
<td>Stir Rate</td>
<td>-0.83333</td>
<td>-0.29</td>
<td>0.7970</td>
<td>1.0000</td>
</tr>
<tr>
<td>Concentration</td>
<td>-0.50000</td>
<td>-0.17</td>
<td>0.8796</td>
<td>1.0000</td>
</tr>
<tr>
<td>Catalyst*Temperature</td>
<td>5.46531 *</td>
<td>1.25</td>
<td>0.1092</td>
<td>0.4932</td>
</tr>
<tr>
<td>Catalyst*Feed Rate</td>
<td>-0.27217 *</td>
<td>-0.09</td>
<td>0.9235</td>
<td>1.0000</td>
</tr>
<tr>
<td>Temperature*Feed Rate</td>
<td>-0.38490 *</td>
<td>-0.13</td>
<td>0.9054</td>
<td>1.0000</td>
</tr>
<tr>
<td>Catalyst*Stir Rate</td>
<td>5.06842 *</td>
<td>1.75</td>
<td>0.0846</td>
<td>0.5300</td>
</tr>
<tr>
<td>Temperature*Stir Rate</td>
<td>1.92450 *</td>
<td>0.66</td>
<td>0.5510</td>
<td>1.0000</td>
</tr>
<tr>
<td>Feed Rate*Stir Rate</td>
<td>-1.93793 *</td>
<td>-0.67</td>
<td>0.4720</td>
<td>1.0000</td>
</tr>
</tbody>
</table>

The Catalyst*Stir Rate interaction is highlighted, but the Stir Rate main effect is not. In accordance with the principle of Effect Heredity, you should add the Stir Rate main effect to the model. See “Effect Heredity”.

6. Click **Make Model**.
7. Select Stir Rate and click **Add** in the Construct Model Effects section.
8. Click **Run**.
The ^ symbol to the right of the PValue for Stir Rate and Temperature show that while not significant, these effects are contained in significant higher-order effect.

**Analyze a Supersaturated Design**

Supersaturated designs have more factors than runs. They rely heavily on effect sparsity for their analysis, so the Fit Two Level Screening platform is ideal for their analysis. The objective is to determine which effects are active.

In this example, a simulated design with 18 factors but only 12 runs is considered. Y is generated by:

\[ Y = 2(X7) + 5(X10) - 3(X15) + \varepsilon \]

where \( \varepsilon \sim N(0,1) \). So, Y has been constructed with three active factors.

1. Select Help > Sample Data Library and open Supersaturated.jmp.
2. Select DOE > Classical > Two Level Screening > Fit Two Level Screening.
3. Select Y and click Y.
4. Select X1 through X18 and click X.
5. Click OK.
Note that four factors have been highlighted. Factors $X_{10}$, $X_{15}$, and $X_{7}$ are active based on a 0.05 critical value criteria. In the Half Normal Plot, $X_{18}$ is close to the blue line, which indicates that it is close to the 0.1 cutoff value for significance. The 0.1 critical value is generous in its selection of factors so that you do not miss those that are possibly active.

The contrast estimates for $X_{10}$, $X_{15}$, and $X_{7}$ of 5.1, $-3$, and 1.8 are close to their simulated values (5, $-3$, 2).

The $p$-values are not entirely valid statistically, since they are based on a simulation that assumes orthogonal designs, which is not the case for supersaturated designs. However, as shown, they can be useful in identifying effects for further investigation.
Technical Details for the Fit Two Level Screening Platform

- “Order of Effect Entry”
- “Fit Two Level Screening as an Orthogonal Rotation”
- “Lenth’s Pseudo-Standard Error”
- “Lenth t-Ratios”

Order of Effect Entry

The Fit Two Level Screening platform has a carefully defined order of operations:

1. First, the main effect terms enter the model according to the absolute size of their contrast. All effects are orthogonalized to the effects preceding them in the model. This method assures that their order is the same as it would be in a forward stepwise regression. Ordering by main effects also helps in selecting preferred aliased terms later in the process.

2. After main effects, all second-order interactions enter the model, followed by third-order interactions, and so on. The second-order interactions cross with all earlier terms before bringing in a new term because B and C are both larger than D. The complete order of entry is AB, AC, BC, AD, BD, and then CD.

3. An effect that is an exact alias for an effect already in the model appears in the Alias column. Effects that are a linear combination of several previous effects do not appear. If there is partial aliasing (due to a lack of orthogonality), the effects involved are marked with an asterisk.

4. The process continues until \( n \) effects are obtained, where \( n \) is the number of rows in the data table, thus fully saturating the model. If complete saturation is not possible with the factors, JMP generates random orthogonalized effects to absorb the rest of the variation. They are labeled \( \text{Null} n \) where \( n \) is a number. For example, this situation occurs if there are exact replicate rows in the design.

Fit Two Level Screening as an Orthogonal Rotation

Mathematically, the Fit Two Level Screening platform takes the \( n \) values in the response vector and rotates them into \( n \) new values. The rotated values are then mapped by the space of the factors and their interactions.

\[
\text{Contrasts} = T' \times \text{Responses}
\]
In the above equation, \( T \) is an \( n \) by \( n \) orthonormalized set of values starting with the intercept, main effects of factors, two-way interactions, three-way interactions, and so on, until \( n \) values have been obtained. Since the first column of \( T \) is an intercept, and all the other columns are orthogonal to it, these other columns are all contrasts, that is, they sum to zero. Since \( T \) is orthogonal, it can serve as \( X \) in a linear model. It does not need inversion, since \( T' \) is equivalent to \( T^{-1} \) and \( (TT')T' \). The contrasts are the parameters estimated in a linear model.

If no effect in the model is active other than the intercept, the contrasts are just an orthogonal rotation of random independent variates into different random independent variates. These orthogonally-rotated random variates have the same variance as the original random independent variates. To the extent that some effects are active, the inactive effects still represent the same variation as the error in the model. The hope is that the effects and the design are strong enough to separate the active effects from the random error effects.

**Lenth’s Pseudo-Standard Error**

Lenth’s method (Lenth 1989), known as the *Lenth Pseudo Standard Error (PSE)*, constructs an estimate of the residual standard error using effects that appear to be inactive. Lenth’s PSE can be used to estimate the standard error for experiments where contrasts are independent and have a common variance.

If there are \( n \) rows, the platform constructs \( n - 1 \) contrasts. Denote these contrasts by \( \hat{C}_i \), where \( i = 1, ..., n - 1 \).

To obtain Lenth’s PSE, first calculate the following:

\[
\nu = 1.5[\text{median}_{i = 1, ..., n - 1}|\hat{C}_i|]
\]

Lenth’s PSE is based on the effects that are likely to be inactive and is defined as follows:

\[
PSE = 1.5[\text{median}(|\hat{C}_i| < 2.5\nu|\hat{C}_i|)]
\]

The value for Lenth’s PSE is shown at the bottom of the Screening report.

**Lenth t-Ratios**

For each contrast, a \( t \)-ratio is computed by dividing the contrast by the PSE. The reference distribution of these \( t \)-ratios under the null hypothesis is not computationally tractable. Therefore, it is obtained by simulation. The method, described below, is based on a discussion in Ye and Hamada (2000).
Denote the $t$-ratio for the $i^{th}$ contrast by $t_i$:

$$t_i = \frac{\hat{C}_i}{(PSE)}$$

Of primary importance in screening experiments is the \textit{individual error rate}, namely the probability of declaring a given effect as active when it is not. For the $i^{th}$ effect, this occurs when $|t_i|$ is large and falls into the upper tail of its reference distribution.

Because the platform constructs a relatively large number of effects, the \textit{experimentwise error rate} is also of importance. The experimentwise error rate is the probability of declaring \textit{any} effect as active when no effects are active. An experimentwise error occurs when no effects are active and the maximum of the absolute $t$-ratios, $\max |t_i|$, is large and falls into the upper tail of its reference distribution.

The Fit Two Level Screening platform obtains reference distributions for both types of error rates using Monte Carlo simulation. Consider a set of $n - 1$ values that is simulated from a normal distribution with mean 0 and standard deviation equal to PSE. This set of values represents potential contrast values for the experiment under the null hypothesis of no active effects. In all, 10,000 sets of $n - 1$ random contrast values are generated.

\textbf{Individual p-Values}

Consider the $i^{th}$ contrast. Lenth $t$-ratios are constructed using each of the 10,000*(n - 1) simulated values. The reference distribution for the individual error rate is approximated by the absolute values of these $t$-ratios. The Individual $p$-value is the interpolated fractional position of the observed absolute Lenth $t$-Ratio among the 10,000*(n - 1) simulated absolute $t$-ratios arranged in descending order. This approximates the area to the right of the absolute value of the observed absolute Lenth $t$-Ratio with respect to the reference distribution.

\textbf{Simultaneous p-Values}

An experimentwise error occurs if any $t$-ratio leads to rejecting the null hypothesis when all effects are inactive. Equivalently, an experimentwise error occurs if the maximum of the absolute $t$-ratios, $\max |t_i|$, leads to rejecting the null hypothesis.

To obtain a reference distribution in this case, consider the maximum of the computed absolute $t$-ratios in each of the 10,000 simulations. These 10,000 maximum values form the reference distribution. The Simultaneous $p$-value is the interpolated fractional position of the observed absolute Lenth $t$-Ratio among the 10,000 simulated maximum absolute $t$-ratios arranged in descending order. This approximates the area to the right of the absolute value of the absolute Lenth $t$-Ratio with respect to the reference distribution based on the simulated maximum absolute $t$-ratios.
Monte Carlo Simulation Options

To change the number of default sets of simulations from 10,000, you must assign a value to a global JSL variable named LenthSimN. The number of simulations used to derive the \( p \)-values is reported in the report window.

The following example sets the number of simulations to 50,000.

1. Select Help > Sample Data Library and open Reactor Half Fraction.jmp.
2. Select DOE > Classical > Two Level Screening > Fit Two Level Screening.
3. Select Percent Reacted and click Y.
4. Select Feed Rate through Concentration, click X, and then click OK.
5. Click the red triangle next to Screening for Percent Reacted and select Save Script > To Script Window.
6. Insert \texttt{LenthSimN=50000;} as the first line of the script.

\begin{verbatim}
LenthSimN=50000;
Fit Two Level Screening(
   Y( :Percent Reacted),
   X( :Feed Rate, :Catalyst, :Stir Rate, :Temperature, :Concentration )
);
\end{verbatim}
7. Right-click in the script window and select Run Script.

Figure 10.10 Fit Two Level with N = 50,000 Simulations for \( p \)-Value Derivations

The number of simulations is stated in the report window.
Note: If LenthSimN=0, the standard $t$-distribution is used and simultaneous $p$-values are not provided. This approach is not recommended.
Response surface designs are useful for modeling quadratic surfaces. A response surface model can identify a point where a minimum or maximum value of the response occurs, if one exists inside the design region. Three distinct values for each factor are necessary to fit a quadratic function, so standard two-level designs are not appropriate for fitting curved surfaces.

Response surface designs are capable of fitting a second-order prediction equation for the response. The quadratic terms in these equations model the curvature in the true response function. If a maximum or minimum exists inside the design region, the point where that value occurs can be estimated.

Figure 11.1 Model for Response Surface Design Results
Contents

Overview of Response Surface Designs .......................................................... 357
Example of a Response Surface Design ......................................................... 359
  Construct a Box-Behnken Design ............................................................... 360
  Analyze the Experimental Data ................................................................. 361
  Explore Optimal Settings ............................................................................. 363
Response Surface Design Window ................................................................. 366
  Responses ..................................................................................................... 367
  Factors ......................................................................................................... 369
  Choose a Design ......................................................................................... 370
  Specify Output Options .............................................................................. 372
  Make Table ................................................................................................ 373
Response Surface Design Options ................................................................. 374
Overview of Response Surface Designs

The Response Surface Design platform provides the classical central composite and Box-Behnken designs, including blocked versions of these designs. For central composite designs, you can control the placement of axial points and other aspects of the design. Response surface designs are available for continuous factors only and are provided for up to eight factors.

**Tip:** You can use DOE > Custom Design to construct optimal response surface designs that accommodate your specific experimental situation. Custom Design constructs response surface designs that are much more flexible than classical response surface designs. In particular, you can use the Custom Design platform to create response surface designs that involve categorical factors or more than eight continuous factors. You can also specify the number of runs and restrictions on the design space. For examples, see “Response Surface Experiments”.

A central composite design (Figure 11.2) combines a two-level fractional factorial design and two other types of points:

- *Center points*, where all the factor values are set to the midrange value.
- *Axial points*, where one factor is set to a high or low value (an axial value) and all other factors are set to the midrange value.

Depending on your selections relative to axial points, a central composite design can have as many as five distinct settings for each factor and the axial points can extend beyond the specified range of the factors.
A Box-Behnken design (Figure 11.3) has only three levels per factor and has no design points at the vertices of the cube defined by the ranges of the factors. This type of design can be useful when you must avoid these points due to engineering considerations. But, the lack of design points at the vertices of the cube means that a Box-Behnken design has higher prediction variance, and so less precision, near the vertices compared to a central composite design.
In JMP, you can construct a response surface design in two ways:

- Using the Response Surface Design platform (for up to eight continuous factors)
- Using the Custom Design platform (and clicking the RSM button in the Model outline)

In both cases, the design table contains a Model script that you can run to fit a model. The Model script applies the Response Surface Effect attribute to each main effect, so that the main effects appear with a \&RS suffix in the Fit Model window. This attribute ensures that the Fit Least Squares report contains a Response Surface report. For more information about this report, see Fitting Linear Models.

Note: The Response Surface outline in the Standard Least Squares report is not shown for response surface designs that contain more than 20 continuous factors.

Example of a Response Surface Design

In this example, you construct a Box-Behnken design for a tire tread experiment. Your objective is to match a target value of 450 for a measure of elongation (Stretch). The stretch varies as a function of the amounts of Silica, Silane, and Sulfur used to manufacture the tire tread compound. You want to experiment over a wide range of factor settings to find the settings that achieve the target.

- “Construct a Box-Behnken Design”
- “Analyze the Experimental Data”
- “Explore Optimal Settings”
Construct a Box-Behnken Design

In this example, for convenience, you load the responses and factors from existing tables. When designing a new experiment on your own, enter the responses and factors manually. See “Responses” and “Factors”.

1. Select **DOE > Classical > Response Surface Design**.
2. Select **Help > Sample Data Library** and open **Design Experiment/Bounce Response.jmp**.
3. Click the Response Surface Design red triangle and select **Load Responses**.
4. Select **Help > Sample Data Library** and open **Design Experiment/Bounce Factors.jmp**.
5. Click the Response Surface Design red triangle and select **Load Factors**.

**Figure 11.4** Responses and Factors Outlines for Tire Tread Design

In the Responses outline, notice that the Goal for Stretch is set to Match Target.

In the Choose a Design panel, possible designs appear.

**Note:** Setting the Random Seed in step 6 reproduces the exact results shown in this example. In constructing a design on your own, this step is not necessary.
6. (Optional) Click the Response Surface Design red triangle and select **Set Random Seed**. Type 12345 and click **OK**.

7. Click **Continue** to retain the Box-Behnken design selection.

8. Click **Make Table**.

**Figure 11.5** Box-Behnken Design Table

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Silica</th>
<th>Sulfur</th>
<th>Silane</th>
<th>Stretch</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 -0+</td>
<td>0.7</td>
<td>2.3</td>
<td>60</td>
<td>•</td>
</tr>
<tr>
<td>2 0+-</td>
<td>1.2</td>
<td>2.8</td>
<td>40</td>
<td>•</td>
</tr>
<tr>
<td>3 000</td>
<td>1.2</td>
<td>2.3</td>
<td>50</td>
<td>•</td>
</tr>
<tr>
<td>4 000</td>
<td>1.2</td>
<td>2.3</td>
<td>50</td>
<td>•</td>
</tr>
<tr>
<td>5 -0-</td>
<td>1.7</td>
<td>2.3</td>
<td>40</td>
<td>•</td>
</tr>
<tr>
<td>6 -0+</td>
<td>1.7</td>
<td>2.3</td>
<td>60</td>
<td>•</td>
</tr>
<tr>
<td>7 0--</td>
<td>1.2</td>
<td>1.8</td>
<td>60</td>
<td>•</td>
</tr>
<tr>
<td>8 0--</td>
<td>1.2</td>
<td>2.8</td>
<td>60</td>
<td>•</td>
</tr>
<tr>
<td>9 -0-</td>
<td>0.7</td>
<td>2.3</td>
<td>40</td>
<td>•</td>
</tr>
<tr>
<td>10 --0</td>
<td>0.7</td>
<td>2.8</td>
<td>50</td>
<td>•</td>
</tr>
<tr>
<td>11 000</td>
<td>1.2</td>
<td>2.3</td>
<td>50</td>
<td>•</td>
</tr>
<tr>
<td>12 --0</td>
<td>0.7</td>
<td>1.8</td>
<td>50</td>
<td>•</td>
</tr>
<tr>
<td>13 0--</td>
<td>1.2</td>
<td>1.8</td>
<td>40</td>
<td>•</td>
</tr>
<tr>
<td>14 --0</td>
<td>1.7</td>
<td>1.8</td>
<td>50</td>
<td>•</td>
</tr>
<tr>
<td>15 --0</td>
<td>1.7</td>
<td>2.8</td>
<td>50</td>
<td>•</td>
</tr>
</tbody>
</table>

At this point, conduct the experiment and enter the responses into the data table.

**Analyze the Experimental Data**

1. Select **Help > Sample Data Library** and open Design Experiment/Bounce Data.jmp. The file Bounce Data.jmp contains your experiment results.

2. Run the **Model** script.

   Notice that the main effects in the Construct Model Effects list are followed by the & RS suffix. This suffix indicates that these are response surface effects, which produce a Response Surface report in the Standard Least Squares report.

3. Click **Run**.
Figure 11.6 Lack of Fit and Effect Tests Reports

There is no indication of lack of fit and the Effect Tests report indicates that all but two higher-order terms (Silica*Silane and Silane*Silane) have p-values below 0.0001. See *Fitting Linear Models* for more information about interpretation of the tables in Figure 11.6.

4. Click the disclosure icon next to Response Surface to open the report.

5. Click the disclosure icon next to Canonical Curvature.

Figure 11.7 Response Surface Report

The Coef table shown as the first part of the report gives a concise summary of the estimated model parameters. The first three columns give the coefficients of the second-order terms. The last column gives the coefficients of the linear terms. To see the prediction expression in its entirely, select *Estimates > Show Prediction Expression* from the Response Stretch red triangle.
The Solution report gives the coordinates of the point where the single critical value occurs. In this instance, that point is a saddle point (a point where neither a maximum nor a minimum occurs) and falls outside the range of the design space.

The Canonical Curvature report shows eigenvalues and eigenvectors of the effects. These give information about the nature and direction of the surface’s curvature. The large positive eigenvalue of 62.9095 indicates positive curvature and the eigenvector values indicate that the curvature is primarily in the Silica direction. The large negative eigenvalue of -74.9584 indicates negative curvature and the eigenvector values indicate that the curvature is primarily in the Sulfur direction.

See *Fitting Linear Models* for more information about the response surface analysis tables in Figure 11.7.

Next, use the prediction profiler and the contour profiler to find optimal settings.

**Explore Optimal Settings**

1. Click the Prediction Profiler red triangle and select **Optimization and Desirability > Maximize Desirability**.

![Figure 11.8 Prediction Profiler for Bounce Data.jmp with Desirability Maximized](image)

**Note:** Your optimal settings might differ. This is because there are many points for which the predicted Stretch is 450.

When you specified the response, the goal was set to match a target of 450, with lower and upper limits of 350 and 550. This goal was carried over to the design table and these limits were put in a Response Limits column property for Stretch. A desirability function is constructed from these response limits (top right cell in Figure 11.8). See “Response Limits”.
When you maximize the desirability function, JMP identifies one combination of factor level settings (usually out of many possible combinations) that results in a predicted Stretch of 450. Figure 11.8 shows these settings as Silica = 1.069, Sulfur = 1.972, and Silane = 40.000. Next, you use the Contour Profiler to identify other points that maximize the desirability function.

For more information about the Prediction Profiler, see Profilers.

2. Click the Response Stretch red triangle and select Factor Profiling > Contour Profiler. Suppose that you want to achieve your target while setting Sulfur to the value 2.0. Also, you want to make sure that the settings that you choose for Silane and Silica maintain predicted Stretch within 5 units of 450.

3. On the vertical axis, click the red triangle next to Sulfur and select Silane.

Figure 11.9 Contour Profiler for Bounce Data.jmp

The plot shows the contour of values of Silane and Silica for Stretch at 425 and Sulfur at 2.3.

4. Set the Current X for Sulfur to 2.

5. Set the Contour for Stretch to 450.

6. Set the Lo Limit and Hi Limit for Stretch to 445 and 455, respectively. Press Enter.
The unshaded band of Silica and Silane values gives predicted Stretch between 445 and 455 when Sulfur is set at 2.0. The values on the solid red curve give predicted Stretch of 450.

7. Drag the crosshairs that appear in the plot to the unshaded band to find settings for Silica and Silane that are best for your process from a practical perspective.

Suppose that your process is known to be more robust at low levels of Silane than at high levels. Then you might consider the settings in Figure 11.11.
For Sulfur = 2.0, the factor settings identified by the crosshairs are Silica = 1.045 and Silane = 41.71. These settings are shown under Current X. At these settings, the predicted Stretch is 449.62071, shown next to Current Y.

For further information about the Contour Profiler, see Profilers.

Response Surface Design Window

The Response Surface Design window walks you through the steps to construct a design for modeling a quadratic surface. You can select a central composite design, a Box-Behnken design, or a blocked version of one of these design types. If you select a central composite design, you can adjust the axial points.

The Response Surface Design window updates as you work through the design steps. The outlines, separated by buttons that update the outlines, follow the flow in Figure 11.12.

Figure 11.12 Response Surface Design Flow
Responses

Use the Responses outline to specify one or more responses.

**Tip:** When you have completed the Responses outline, consider selecting **Save Responses** from the red triangle menu. This option saves the response names, goals, limits, and importance values in a data table that you can later reload in DOE platforms.

**Figure 11.13** Responses Outline

<table>
<thead>
<tr>
<th>Responses</th>
<th>Add Response</th>
<th>Remove</th>
<th>Number of Responses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Response Name</td>
<td>Goal</td>
<td>Lower Limit</td>
<td>Upper Limit</td>
</tr>
<tr>
<td>Y</td>
<td>Maximize</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Add Response**  Enters a single response with a goal type of Maximize, Match Target, Minimize, None, or Functional. If you select Match Target, enter limits for your target value. If you select Maximize or Minimize, entering limits is not required but can be useful if you intend to use desirability functions.

**Functional**  (Available only in JMP Pro.) Adds multiple Y columns with FDE column properties to the design data table. These columns can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.

**Remove**  Removes the selected responses.

**Number of Responses**  Enters additional responses so that the number that you enter is the total number of responses. If you have entered a response other than the default Y, the Goal for each of the additional responses is the Goal associated with the last response entered. Otherwise, the Goal defaults to Match Target. Click the Goal type in the table to change it.

The Responses outline contains the following columns:

**Response Name**  The name of the response. When added, a response is given a default name of Y, Y2, and so on. To change this name, double-click it and enter the desired name.

**Goal, Lower Limit, Upper Limit**  The Goal tells JMP that you want to maximize or minimize your response, match a target, or that you have no goal for your response. JMP assigns a Response Limits column property, based on these specifications, to each response column in the design table. It uses this information to define a desirability function for each response. The Profiler and Contour Profiler use these desirability functions to find optimal factor settings. For further details, see the Profiler chapter in *Profilers* and “Response Limits”.
- A Goal of Maximize indicates that the best value is the largest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

- A Goal of Minimize indicates that the best value is the smallest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

- A Goal of Match Target indicates that the best value is a specific target value. The default target value is assumed to be midway between the Lower Limit and Upper Limit.

- A Goal of None indicates that there is no goal in terms of optimization. No desirability function is constructed.

**Note:** If your target response is not midway between the Lower Limit and the Upper Limit, you can change the target after you generate your design table. In the data table, open the Column Info window for the response column (Cols > Column Info) and enter the desired target value.

**Importance** When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for the responses. If there is only one response, then specifying the Importance is unnecessary because it is set to 1 by default.

**Detection Limits** The lower and upper detection limits are bounds beyond which the response cannot be measured. The detection limits are saved as a column property. You can use these limits to specify a censored response in the Generalized Regression platform. See the Generalized Regression chapter in *Fitting Linear Models*.

**Editing the Responses Outline**

In the Responses outline, note the following:

- Double-click a response to edit the response name.
- Click the goal to change it.
- Click on a limit or importance weight to change it.
- For multiple responses, you might want to enter values for the importance weights.
**Response Limits Column Property**

The Goal, Lower Limit, Upper Limit, and Importance that you specify when you enter a response are used in finding optimal factor settings. For each response, the information is saved in the generated design data table as a Response Limits column property. JMP uses this information to define the desirability function. The desirability function is used in the Prediction Profiler to find optimal factor settings. For further details about the Response Limits column property and examples of its use, see “Response Limits”.

If you do not specify a Lower Limit and Upper Limit, JMP uses the range of the observed data for the response to define the limits for the desirability function. Specifying the Lower Limit and Upper Limit gives you control over the specification of the desirability function. For more details about the construction of the desirability function, see the Profiler chapter in *Profilers*.

**Factors**

Factors in a response surface design can only be continuous.

**Tip:** Use **DOE > Custom Design** to create response surface designs that involve categorical factors.

The initial Factors panel for a response surface design appears with two continuous factors.

**Figure 11.14** Factors Outline

![Factors Outline](image)

The factors outline contains the following buttons.

- **Add**: Enters the number of continuous factors specified.
- **Remove Selected**: Removes the selected factors.

**Tip:** When you have completed your Factors panel, select Save Factors from the red triangle menu. This saves the factor names and values in a data table that you can later reload. See “Response Surface Design Options”.
The Factors outline contains the following columns:

**Name**  The name of the factor. When added, a factor is given a default name of X1, X2, and so on. To change this name, double-click it and enter the desired name.

**Role**  Specifies the Design Role of the factor as Continuous. The Design Role column property for the factor is saved to the data table. This property ensures that the factor type is modeled appropriately.

**Values**  The experimental settings for the factors. To insert Values, click the default values and enter the desired values.

### Factor Column Properties

For each factor, various column properties are saved to the data table for the completed design.

**Design Role**  Each factor is assigned the Design Role column property. The Role that you specify in defining the factor determines the value of its Design Role column property. When you select a design with a block, that factor is assigned the Blocking value. The Design Role property reflects how the factor is intended to be used in modeling the experimental data. Design Role values are used in the Augment Design platform.

**Factor Changes**  Each factor is assigned the Factor Changes column property with a setting of Easy. In the Response Surface Design platform, it is assumed that factor levels can be changed for each experimental run. Factor Changes values are used in the Evaluate Design and Augment Design platforms.

**Coding**  If the Design Role is Continuous, the Coding column property for the factor is saved. This property transforms the factor values so that the low and high values correspond to –1 and +1, respectively. The estimates and tests in the Fit Least Squares report are based on the transformed values.

**RunsPerBlock**  Indicates the number of runs in each block. When you select a design with a block and then click Make Table, a factor with the default name Block is added to the Factors list. The RunsPerBlock column property is saved for that factor.

### Choose a Design

After you enter your responses and factors and click **Continue**, you select from a list of designs. The designs include two types:

- "Box-Behnken Designs"
- "Central Composite Designs"

Select the design that you want to use and click **Continue**.
Box-Behnken Designs

Box-Behnken designs have only three levels for each factor and have no design points at the vertices of the cube defined by the ranges of the factors. These designs can be useful when it is desirable to avoid extreme settings for engineering considerations. However, these designs result in higher prediction variance near the vertices than do central composite designs.

Central Composite Designs

Central composite designs have center points and axial points. An axial point is a point where one factor is set to a high or low value (an axial value) and all other factors are set to the midrange, or center, value.

A central composite design can have axial points that fall beyond the faces of the hypercube defined by the specified factor ranges. This means that each factor might require five distinct settings, including two that fall beyond the range of values specified in the Factors outline. However, JMP enables you to place design points on the face.

The following types of central composite designs are available:

Central Composite Design  The usual central composite design for the specified number of factors.

CCD-Uniform Precision  The number of center points is chosen so that the prediction variance near the center of the design space is very flat.

CCD-Orthogonal  The number of center points and the axial values are chosen so that the second-order parameter estimates are minimally correlated with the other parameter estimates.

CCD-Orthogonal Blocks  The second-order parameter estimates and block effects are minimally correlated with the other parameter estimates.

Figure 11.15  Choose a Design Panel for Four Factors
Axial Value

When you select a central composite design and then click **Continue**, you have the option to provide axial scaling information. In placing axial values, the values shown are used to multiply half of the specified range of a factor. If you specify a value of 1.0 next to Axial Value, then axial points in the resulting design are placed on the faces of the cube defined by the factors. You can set the axial value according to the following options:

**Figure 11.16** Axial Value Panel

- **Rotatable**  The prediction variance depends only on the scaled distance from the center of the design. The axial points are more extreme than the factor ranges. If this factor range cannot be practically achieved, select **On Face** or specify your own value.

- **Orthogonal**  The effects are orthogonal. The axial points are more extreme than the factor ranges. If this factor range cannot be practically achieved, select **On Face** or specify your own value.

- **On Face**  Places the axial points at the extremes of the specified factor ranges.

- **User Specified**  Places the axial points at a distance specified by the value that you enter in the Axial Value text box.

- **Inscribe**  Rescales the design so that the axial points are at the low and high ends of the factor range. The factorial design points are shrunken based on that scaling.

Specify Output Options

You can specify details for the output data table in the Output Options panel. When you finish, click **Make Table** to construct the data table for the design.

Run Order

The **Run Order** options determine the order of the runs in the design table. Choices include the following:

- **Keep the Same**  Rows in the design table are in the same order as in the Design and Anticipated Coefficients outline.

- **Sort Left to Right**  Columns in the design table are sorted from left to right.
Randomize  Rows in the design table are in random order.

Sort Right to Left  Columns in the design table are sorted from right to left.

Randomize within Blocks  Rows in the design table are in random order within the blocks.

Center Points and Replicates

Number of Center Points  The number of center points that appear in the design. A center point is a run where every continuous factor is set at the center of the factor’s range. The initial value shown is the number of center points in the design that you selected.

Number of Replicates  The number of times to replicate the entire design, including center points. One replicate doubles the number of runs.

Make Table

Click Make Table to create a design table that contains the runs for your experiment.

Figure 11.17  Orthogonal Central Composite Design for Bounce Factors and Response

![Design Table]

The Design note in the Table panel at the upper left gives the design type that generated the table (Central Composite Design). This information can be helpful if you are comparing multiple designs.

Pattern Column

A Pattern column gives a symbolic description of the run in each row in terms of the factor values.

Tip: Pattern can be a useful label variable in plots.
Table 11.1 Pattern Column Description

- Low value  
+ High value  
0 Midrange (center) value  
a Low axial value  
A High axial value

Design Table Scripts

The design table includes the following scripts:

**Model**  Runs the Analyze > Fit Model platform.

**Evaluate Design**  Runs the DOE > Design Diagnostics > Evaluate Design platform.

**DOE Dialog**  Re-creates the Response Surface Design window that you used to generate the design table. The script also contains the random seed used to generate your design.

Response Surface Design Options

The red triangle menu in the Response Surface Design platform contains these options:

**Save Responses**  Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.

**Load Responses**  Loads responses that you saved using the Save Responses option.

**Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

**Note:** It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting Column Properties > Design Role. In the Design Role area, select the appropriate role.

**Load Factors**  Loads factors that you saved using the Save Factors option.
Save Constraints  (Unavailable for some platforms) Saves factor constraints that you defined in the Define Factor Constraints or Linear Constraints outline into a data table, with a column for each constraint. You can then quickly load the constraints into most DOE windows.

In the constraint table, the first rows contain the coefficients for each factor. The last row contains the inequality bound. Each constraint’s column contains a column property called ConstraintState that identifies the constraint as a “less than” or a “greater than” constraint. See “ConstraintState”.

Load Constraints  (Unavailable for some platforms) Loads factor constraints that you saved using the Save Constraints option.

Set Random Seed  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:

- initializing search algorithms for design generation
- randomizing Run Order for design construction
- selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking Make Design.

Note: The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

Simulate Responses  Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

- A set of simulated response values is added to each response column.
- For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
- A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

Note: Not all distributions are available for all design types.

- A script called DOE Simulate is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a
new column called \(<Y> \text{ Simulated}\), where \(Y\) is the name of the response. Clicking Apply again updates the formula and values in \(<Y> \text{ Simulated}\).

For additional details, see “Simulate Responses”.

**Note:** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in *Basic Analysis*.

**Save X Matrix** Saves the Moments Matrix and Model Matrix to table scripts in the design data table. These scripts contain the moments and design matrices. See “Save X Matrix”.

**Caution:** For a design with nominal factors, the Model Matrix saved by the Save X Matrix option is *not* the coding matrix used in fitting the linear model. You can obtain the coding matrix used for fitting the model by selecting the option Save Columns > Save Coding Table in the Fit Model report that you obtain when you run the Model script.

**Save Script to Script Window** Creates the script for the design that you specified in the Response Surface Design window and saves it in an open script window.
A full factorial design defines an experiment where trials are run at all possible combinations of factor settings. A full factorial design allows the estimation of all possible interactions. Full factorial designs are large compared to screening designs, and since high-level interactions are often not active, they can be inefficient. They are typically used when you have a small number of factors and levels and want information about all possible interactions. For example, full factorial designs often form the basis for a measurement systems analysis (MSA).

**Figure 12.1** Full Factorial Design for Three Two-Level Factors
Contents

Overview of Full Factorial Design ................................................................. 379
Example of a Full Factorial Design ............................................................... 379
  Construct the Design .................................................................................. 379
  Analyze the Experimental Data ................................................................. 381
Build a Full Factorial Design .................................................................... 385
  Responses .................................................................................................. 385
  Factors ...................................................................................................... 387
Select Output Options ................................................................................. 389
Make Table .................................................................................................. 391
Full Factorial Design Options ..................................................................... 392
Overview of Full Factorial Design

In a full factorial design, you perform an experimental run at every combination of the factor levels. The sample size is the product of the numbers of levels of the factors. For example, a factorial experiment with a two-level factor, a three-level factor, and a four-level factor has $2 \times 3 \times 4 = 24$ runs.

The Full Factorial Design platform supports both continuous factors and categorical factors with arbitrary numbers of levels. It is assumed that you can run the trials in a completely random fashion.

Full factorial designs are the most conservative of all design types. Unfortunately, because the sample size grows exponentially with the number of factors, full factorial designs are often too expensive to run. Custom designs, definitive screening designs, and screening designs are less conservative but more efficient and cost-effective.

Example of a Full Factorial Design

In this example, you construct a full factorial design to study the effects of five two-level factors (Feed Rate, Catalyst, Stir Rate, Temperature, and Concentration) on the yield of a reactor. Because there are five factors, each at two levels, the full factorial design includes at least $2^5 = 32$ runs. For smaller screening designs involving this experimental situation, see “Additional Examples of Screening Designs”.

In this example, you load the responses and factors from existing tables. When designing a new experiment on your own, enter the responses and factors manually. See “Responses” and “Factors”.

Construct the Design

1. Select DOE > Classical > Full Factorial Design.
2. Select Help > Sample Data Library and open Design Experiment/Reactor Response.jmp.
3. Click the Full Factorial Design red triangle and select Load Responses.
4. Select Help > Sample Data Library and open Design Experiment/Reactor Factors.jmp.
5. Click the Full Factorial Design red triangle and select Load Factors.
6. Click Continue.
Note: Setting the Random Seed in step 7 ensures that the runs in your design table appear in the same order as in this example. In constructing a design on your own, this step is not necessary.

7. (Optional) Click the Full Factorial Design red triangle and select Set Random Seed. Type 12345 and click OK.

The Run Order in the Output Options panel is set to Randomize. The order of runs in the design table will be random, as determined by the random seed.

The Number of Runs is set to 32. This is the number of all possible factor level combinations.

8. Click Make Table.

The first column in the design data table shows the factor level combination for each run in terms of + and - signs, indicating high and low factor settings. The table also has an empty Y column named Percent Reacted for entering response values as you conduct the experiment.
Analyze the Experimental Data

Next, proceed to analyze the data from the completed experiment. You will use two methods to analyze the results: Screening and Stepwise Regression. Then you will find optimal settings using the Prediction Profiler.

Analysis Using Screening Platform

1. Select Help > Sample Data Library and open Design Experiment/Reactor 32 Runs.jmp.
2. Run the Screening script.

The Screening report shows a Contrasts report and a Half Normal Plot. The Contrasts report shows estimates for all 31 potential effects, up to the five-way interaction.
Figure 12.4 Contrasts Report for Reactor 32 Runs.jmp

<table>
<thead>
<tr>
<th>Term</th>
<th>Contrast</th>
<th>Lenth t-Ratio</th>
<th>Individual p-Value</th>
<th>Simultaneous p-Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catalyst</td>
<td>3.9500</td>
<td>1.415</td>
<td>0.001</td>
<td>0.001</td>
</tr>
<tr>
<td>Temperature</td>
<td>-5.37500</td>
<td>8.19</td>
<td>&lt; 0.001</td>
<td>0.000</td>
</tr>
<tr>
<td>Concentration</td>
<td>3.12500</td>
<td>-1.76</td>
<td>0.081</td>
<td>0.998</td>
</tr>
<tr>
<td>Stir Rate</td>
<td>-01.250</td>
<td>-1.25</td>
<td>0.008</td>
<td>0.008</td>
</tr>
<tr>
<td>Catalyst*Temperature</td>
<td>-6.62500</td>
<td>10.10</td>
<td>&lt; 0.001</td>
<td>&lt; 0.001</td>
</tr>
<tr>
<td>Catalyst*Concentration</td>
<td>-2.2500</td>
<td>0.52</td>
<td>0.52</td>
<td>0.52</td>
</tr>
<tr>
<td>Temperature*Stir Rate</td>
<td>1.062500</td>
<td>1.62</td>
<td>0.113</td>
<td>0.920</td>
</tr>
<tr>
<td>Concentration*Stir Rate</td>
<td>0.43750</td>
<td>0.67</td>
<td>0.52</td>
<td>1.000</td>
</tr>
<tr>
<td>Stir Rate*Stir Rate</td>
<td>0.7500</td>
<td>0.57</td>
<td>0.57</td>
<td>1.000</td>
</tr>
<tr>
<td>Catalyst<em>Temperature</em>Concentration</td>
<td>-0.12500</td>
<td>-0.19</td>
<td>0.8537</td>
<td>1.000</td>
</tr>
<tr>
<td>Catalyst<em>Temperature</em>Feed Rate</td>
<td>0.062500</td>
<td>0.19</td>
<td>0.8537</td>
<td>1.000</td>
</tr>
<tr>
<td>Catalyst<em>Concentration</em>Feed Rate</td>
<td>-0.93750</td>
<td>-1.43</td>
<td>0.157</td>
<td>0.9784</td>
</tr>
<tr>
<td>Temperature<em>Concentration</em>Feed Rate</td>
<td>0.312500</td>
<td>0.48</td>
<td>0.6494</td>
<td>1.000</td>
</tr>
<tr>
<td>Catalyst<em>Temperature</em>Stir Rate</td>
<td>0.562500</td>
<td>0.86</td>
<td>0.3772</td>
<td>1.000</td>
</tr>
<tr>
<td>Catalyst<em>Concentration</em>Stir Rate</td>
<td>0.062500</td>
<td>0.10</td>
<td>0.9266</td>
<td>1.000</td>
</tr>
<tr>
<td>Temperature<em>Concentration</em>Stir Rate</td>
<td>0.062500</td>
<td>0.10</td>
<td>0.9266</td>
<td>1.000</td>
</tr>
<tr>
<td>Catalyst<em>Feed Rate</em>Stir Rate</td>
<td>0.7500</td>
<td>1.14</td>
<td>0.2478</td>
<td>0.9869</td>
</tr>
<tr>
<td>Temperature<em>Feed Rate</em>Stir Rate</td>
<td>0.075000</td>
<td>0.8775</td>
<td>0.5539</td>
<td>1.000</td>
</tr>
</tbody>
</table>

**Note:** Because the \( p \)-values in the Contrasts report are obtained using a Monte Carlo simulation, you might not obtain the same values as shown in Figure 12.4. See “Lenth’s Pseudo-Standard Error”.

The six highlighted effects in the Contrasts outline are labeled in the Half Normal Plot.
The Half Normal Plot provides strong evidence that at least five of the labeled effects are larger than would be expected if they were the result of random variation. This suggests that these effects are active. The plot does not provide a clear indication that the three-way Concentration*Feed Rate*Stir Rate interaction is active.

In the Contrasts outline in Figure 12.4, the Individual p-Value for the three-way Concentration*Feed Rate*Stir Rate interaction is 0.0705 and its Simultaneous p-Value is 0.7592. Because the effect does not stand out on the Half Normal Plot and because its p-values are large, you decide not to include this effect in your model.

3. In the Half Normal Plot, drag a rectangle to select all labeled effects except for Concentration*Feed Rate*Stir Rate.

4. Click **Make Model** to open a Fit Model window containing the five effects.

5. Click **Run**.

   The Actual by Predicted plot shows no evidence of lack of fit and the Effect Summary outline shows that all five effects are significant.

### Analysis Using Stepwise Regression

1. Return to the Reactor 32 Runs.jmp data table, or reopen it by selecting **Help > Sample Data Library** and opening Design Experiment/Reactor 32 Runs.jmp.

2. Run the **Model** script.

   The Construct Model Effects list contains only up to two-way interactions. You want to consider all interactions.
3. From the Select Columns list, select Feed Rate through Concentration.

4. Click Macros > Full Factorial.
   All possible effects are added in the Construct Model Effects list.

5. Change the Personality to Stepwise.

6. Click Run.

7. Change the Stopping Rule to Minimum AICc.
   For designed experiments, AICc is preferred to BIC. This is because BIC is typically a more lenient stopping rule than AICc as it tends to allow inactive effects into the model.

8. Click Go.
   The Stepwise procedure selects six effects as potentially active.

9. Click Run Model.
   This fits a model using the six effects. The Effect Summary outline indicates that Catalyst*Concentration is not significant at the 0.05 significance level as the p-value is 0.0896.

10. Select Catalyst*Concentration in the Effect Summary outline and click Remove.
    The five remaining effects are all highly significant. These are the same five effects that you identified using the Screening platform (“Analysis Using Screening Platform”).

**Optimal Settings Using the Prediction Profiler**

Now, find optimal settings for the three active factors involved in the five significant effects that you retained in your model.

1. In the Reactor 32 Runs.jmp data table, run the Reduced Model script.
   The Reduced Model script opens a Fit Model window for the five-effect model that you identified in “Analysis Using Screening Platform” and “Analysis Using Stepwise Regression”.

2. Click Run.
   The Prediction Profiler report displays Desirability because in the Full Factorial window, you specified a Goal of Maximize when you defined your response. The desirability function shown in the rightmost cell in the top row of the profiler shows that a value of 100 is most desirable and a value of 90 or below is least desirable.

3. Click the Prediction Profiler red triangle and select Optimization and Desirability > Maximize Desirability.
Figure 12.6 Prediction Profiler Showing Settings That Optimize Desirability

The predicted mean Percent Reacted at the settings that are shown is 95.875, with a confidence interval of 92.91 to 98.84. Note that, for all three factors, the settings that are identified are at the extremes of the ranges used in the experiment. In a future experiment, you should explore the process behavior beyond these settings.

Build a Full Factorial Design

Build a Full Factorial design by selecting DOE > Classical > Full Factorial Design. First define your responses and factors. Next, continue to the output options. The design process follows the flow in Figure 12.7. For more information on workflow see “The DOE Workflow: Describe, Specify, Design”.

Figure 12.7 Full Factorial Design Flow

Responses

Use the Responses outline to specify one or more responses.

Tip: When you have completed the Responses outline, consider selecting Save Responses from the red triangle menu. This option saves the response names, goals, limits, and importance values in a data table that you can later reload in DOE platforms.
Add Response  Enters a single response with a goal type of Maximize, Match Target, Minimize, None, or Functional. If you select Match Target, enter limits for your target value. If you select Maximize or Minimize, entering limits is not required but can be useful if you intend to use desirability functions.

Functional  (Available only in JMP Pro.) Adds multiple Y columns with FDE column properties to the design data table. These columns can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.

Remove  Removes the selected responses.

Number of Responses  Enters additional responses so that the number that you enter is the total number of responses. If you have entered a response other than the default Y, the Goal for each of the additional responses is the Goal associated with the last response entered. Otherwise, the Goal defaults to Match Target. Click the Goal type in the table to change it.

The Responses outline contains the following columns:

Response Name  The name of the response. When added, a response is given a default name of Y, Y2, and so on. To change this name, double-click it and enter the desired name.

Goal, Lower Limit, Upper Limit  The Goal tells JMP that you want to maximize or minimize your response, match a target, or that you have no goal for your response. JMP assigns a Response Limits column property, based on these specifications, to each response column in the design table. It uses this information to define a desirability function for each response. The Profiler and Contour Profiler use these desirability functions to find optimal factor settings. For further details, see the Profiler chapter in Profilers and “Response Limits”.

– A Goal of Maximize indicates that the best value is the largest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

– A Goal of Minimize indicates that the best value is the smallest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

– A Goal of Match Target indicates that the best value is a specific target value. The default target value is assumed to be midway between the Lower Limit and Upper Limit.
A Goal of None indicates that there is no goal in terms of optimization. No desirability function is constructed.

**Note:** If your target response is not midway between the Lower Limit and the Upper Limit, you can change the target after you generate your design table. In the data table, open the Column Info window for the response column (Cols > Column Info) and enter the desired target value.

**Importance** When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for the responses. If there is only one response, then specifying the Importance is unnecessary because it is set to 1 by default.

**Detection Limits** The lower and upper detection limits are bounds beyond which the response cannot be measured. The detection limits are saved as a column property. You can use these limits to specify a censored response in the Generalized Regression platform. See the Generalized Regression chapter in *Fitting Linear Models*.

**Editing the Responses Outline**

In the Responses outline, note the following:

- Double-click a response to edit the response name.
- Click the goal to change it.
- Click on a limit or importance weight to change it.
- For multiple responses, you might want to enter values for the importance weights.

**Response Limits Column Property**

The Goal, Lower Limit, Upper Limit, and Importance that you specify when you enter a response are used in finding optimal factor settings. For each response, the information is saved in the generated design data table as a Response Limits column property. JMP uses this information to define the desirability function. The desirability function is used in the Prediction Profiler to find optimal factor settings. For further details about the Response Limits column property and examples of its use, see “Response Limits”.

If you do not specify a Lower Limit and Upper Limit, JMP uses the range of the observed data for the response to define the limits for the desirability function. Specifying the Lower Limit and Upper Limit gives you control over the specification of the desirability function. For more details about the construction of the desirability function, see the Profiler chapter in *Profilers*.

**Factors**

Factors in a full factorial design can be continuous or categorical.
Tip: When you have completed the Factors outline, consider selecting Save Factors from the red triangle menu. This option saves the factor names, roles, changes, and values in a data table that you can later reload in DOE platforms.

Figure 12.9 Factors Outline

Continuous Adds a Continuous factor. The data type in the resulting data table is Numeric. A continuous factor is a factor that you can conceptually set to any value between the lower and upper limits you supply, given the limitations of your process and measurement system.

Categorical Adds a Categorical factor. Click to select or specify the number of levels. The data type in the resulting data table is Character. The value ordering of the levels is the order of the values, as entered from left to right. This ordering is saved in the Value Order column property after the design data table is created.

The default values for a categorical factor are L1, L2,..., Lk, where k is the number of levels that you specify. Replace the default values with level names that are relevant for your experiment.

Remove Removes the selected factors.

Add N Factors Adds multiple factors. Enter the number of factors to add, click Add Factor, and then select the factor type. Repeat Add N Factors to add multiple factors of different types.

Factors Outline

The Factors outline contains the following columns:

Name The name of the factor. When added, a factor is given a default name of X1, X2, and so on. To change this name, double-click it and enter the desired name.

Role The Design Role of the factor. The Design Role column property for the factor is saved to the data table. This property ensures that the factor type is modeled appropriately. The
Role of the factor determines other factor properties that are saved to the data table. See “Factor Column Properties”.

Values  The experimental settings for the factors.

Editing the Factors Outline

In the Factors outline, note the following:

- To edit a factor name, double-click the factor name.
- To edit a value, click the value in the Values column.

Factor Column Properties

For each factor, various column properties are saved to the design table after you create the design by selecting Make Table in the Screening Design window. These properties are also saved automatically to the data table that is created when you select the Save Factors option. You can find more information about these column properties and related examples in “Column Properties”.

Coding  If the Role is Continuous, the Coding column property for the factor is saved. This property transforms the factor values so that the low and high values correspond to –1 and +1, respectively. See “Coding”.

Value Order  If the Role is Categorical or if a Block variable is constructed, the Value Order column property for the factor is saved. This property determines the order in which levels of the factor appear. See “Value Order”.

Design Role  Each factor is given the Design Role column property. The Role that you specify in defining the factor determines the value of its Design Role column property. The Design Role property reflects how the factor is intended to be used in modeling the experimental data. Design Role values are used in the Augment Design platform. See “Design Role”.

Factor Changes  Each factor is assigned the Factor Changes column property with the value of Easy. The Factor Changes property reflects how the factor is used in modeling the experimental data. Factor Changes values are used in the Augment Design and Evaluate Design platforms. See “Factor Changes”.

Select Output Options

After you enter your responses and factors and click Continue, you can make selections for your design table in the Output Options outline. The structure of the full factorial design appears at the top of the outline.
Run Order

The Run Order options determine the order of the runs in the design table.

Keep the Same  Rows in the design table are sorted from left to right.

Sort Left to Right  Columns in the design table are sorted from left to right.

Randomize  Rows in the design table are in random order.

Sort Right to Left  Columns in the design table are sorted from right to left.

Center Points and Replicates

Number of Runs  Shows the number of runs in the design before you add center points or replicates.

Number of Center Points  Specifies how many additional runs to add as center points to the design. A center point is a run where every continuous factor is set at the center of the factor’s range.

Suppose that your design includes both continuous and categorical factors. If you request center points in the Output Options panel, the center points are distributed as follows:

1. The settings for the categorical factors are ordered using the value ordering specified in the Factors outline.
2. One center point is assigned to each combination of the settings of the categorical factors in order, and this is repeated until all center points are assigned.

Number of Replicates  The number of times to replicate the entire design, including center points. One replicate doubles the number of runs.
Make Table

Clicking Make Table creates a data table that contains the runs for your experiment. The example in Figure 12.11 shows a full factorial design with five center points for three factors: X1 (a two-level continuous factor), X2 (a three-level continuous factor), and X3 (a two-level categorical factor). The design uses the default values for the factor levels. The center points are in rows 7, 8, 12, 14, and 17. See “Pattern Column”.

Figure 12.11  Design Data Table

The name of the table, shown in the upper left corner, is the design type that generated it.

Design Table Scripts

The design table includes the following scripts:

- **Model**  Runs the Analyze > Fit Model platform.
- **Evaluate Design**  Runs the DOE > Design Diagnostics > Evaluate Design platform.
- **DOE Dialog**  Re-creates the Full Factorial Design window that you used to generate the design table. The script also contains the random seed used to generate your design.

Run the **Screening** or **Model** scripts to analyze the data.

Pattern Column

The Pattern column contains entries that summarize the run in the given row. You can use Pattern as a label variable in plots.

- For a two-level continuous factor, the low setting is denoted by “−”, the high setting by “+”, and a center point by “0”. 
• For a continuous factor with more than two levels:
  – For a non-center point, the factor setting is denoted by an integer that corresponds to
    the value level for the run.
  – For a center point, the factor setting is denoted by a “0”.
• For a categorical factor, the factor setting is denoted by an integer that corresponds to the
  value level for the run.

Full Factorial Design Options

The red triangle menu in the Full Factorial Design platform contains these options:

**Save Responses**  Saves the information in the Responses panel to a new data table. You can
then quickly load the responses and their associated information into most DOE windows.
This option is helpful if you anticipate reusing the responses.

**Load Responses**  Loads responses that you saved using the Save Responses option.

**Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s
column contains its levels. Other information is stored as column properties. You can then
quickly load the factors and their associated information into most DOE windows.

**Note:** It is possible to create a factors table by entering data into an empty table, but
remember to assign each column an appropriate Design Role. Do this by right-clicking on
the column name in the data grid and selecting **Column Properties > Design Role**. In the
Design Role area, select the appropriate role.

**Load Factors**  Loads factors that you saved using the Save Factors option.

**Save Constraints**  (Unavailable for some platforms) Saves factor constraints that you defined
in the Define Factor Constraints or Linear Constraints outline into a data table, with a
column for each constraint. You can then quickly load the constraints into most DOE
windows.

In the constraint table, the first rows contain the coefficients for each factor. The last row
contains the inequality bound. Each constraint’s column contains a column property called
ConstraintState that identifies the constraint as a “less than” or a “greater than” constraint.
See “ConstraintState”.

**Load Constraints**  (Unavailable for some platforms) Loads factor constraints that you saved
using the Save Constraints option.

**Set Random Seed**  Sets the random seed that JMP uses to control actions that have a random
component. These actions include one or more of the following:
- initializing search algorithms for design generation
- randomizing Run Order for design construction
- selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking Make Design.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

**Simulate Responses** Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

- A set of simulated response values is added to each response column.
- For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
- A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

**Note:** Not all distributions are available for all design types.

- A script called **DOE Simulate** is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a new column called <Y> Simulated, where Y is the name of the response. Clicking Apply again updates the formula and values in <Y> Simulated.

For additional details, see “Simulate Responses”.

**Note:** **JMP Pro** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in *Basic Analysis*.

**Advanced Options** None available.

**Save Script to Script Window** Creates the script for the design that you specified in the Full Factorial Design window and saves it in an open script window.
Use the Mixture Design platform to build experiments with factors that are components in a mixture. Choose from several classical mixture design approaches, such as simplex, extreme vertices, and lattice. For the extreme vertices approach, you can supply a set of linear inequality constraints limiting the geometry of the mixture factor space.

In mixture experiments, a factor’s value is its proportion of the mixture, which falls between zero and one. Mixture experiments have three or more factors with the sum of the factor proportions equal to one (100%). Mixture experiments differ from other experimental types in that you cannot vary factors independently of one another. When you change the proportion of one factor, the proportion of one or more other factors must also change. This simple fact has a profound effect on every aspect of experimentation with mixtures: the factor space, the design properties, and the interpretation of the results.

Because the mixture components are proportions that sum to one, the feasible region of a mixture design takes the form of a simplex. For example, three factor designs can be visualized with a triangular 2-D graph and four factor designs can be visualized with a 3-D tetrahedron.

**Figure 13.1** Ternary Plot
Contents

Overview of Mixture Designs ................................................................. 397
Mixture Design Window ......................................................................... 397
  Responses .......................................................................................... 398
  Factors .............................................................................................. 400
  Ternary Plot Overview ....................................................................... 401
Examples of Mixture Design Types ..................................................... 402
  Optimal Mixture Design ................................................................... 402
  Simplex Centroid Design ................................................................. 404
  Simplex Lattice Design ................................................................... 406
  Extreme Vertices Design ................................................................ 407
  ABCD Design ................................................................................... 411
  Space Filling Design ........................................................................ 412
Fitting Mixture Designs ....................................................................... 414
  Whole Model Tests and Analysis of Variance Reports ...................... 415
  Understanding Response Surface Reports ....................................... 415
A Chemical Mixture Example .............................................................. 416
  Create the Design ............................................................................ 416
  Analyze the Mixture Model ............................................................. 418
  The Prediction Profiler ..................................................................... 419
  The Mixture Profiler ........................................................................ 420
Overview of Mixture Designs

You can choose from the following types of mixture designs:

**Optimal**  Generates an optimal mixture design using the custom designer. See “Optimal Mixture Design”.

**Simplex Centroid**  (Available for unconstrained factors or factors with lower bound constraints.) Generates a design of pure mixtures and blends of factors up to a specified degree. In a pure mixture, one component is at 100% and all other components are at 0%. See “Simplex Centroid Design”.

**Simplex Lattice**  (Available for unconstrained factors or factors with lower bound constraints.) Generates a design of pure mixtures and blends in a space filling triangular grid of runs. You can specify the number of grid levels. See “Simplex Lattice Design”.

**Extreme Vertices**  (Available when you have linear constraints or restricted upper or lower bounds on one or more of your factors.) Generates a design based on the vertices and combinations of the vertices of a constrained factor space. See “Extreme Vertices Design”.

**ABCD Design**  Generates a screening design for mixtures devised by Snee (1975). See “ABCD Design”.

**Space Filling**  Generates a space filling design that accommodates linear constraints. See “Space Filling Design”.

**Note:** The optimal, extreme vertices, and space filling designs can incorporate linear constraints and restrictions on components.

Mixture Design Window

The mixture design window updates as you work through the design steps. See “The DOE Workflow: Describe, Specify, Design”. The workflow and outlines vary depending on design type.

**Figure 13.2** Mixture Design Workflow
Responses

Use the Responses outline to specify one or more responses.

Tip: When you have completed the Responses outline, consider selecting **Save Responses** from the red triangle menu. This option saves the response names, goals, limits, and importance values in a data table that you can later reload in DOE platforms.

**Figure 13.3** Responses Outline

| Add Response | Enters a single response with a goal type of Maximize, Match Target, Minimize, None, or Functional. If you select Match Target, enter limits for your target value. If you select Maximize or Minimize, entering limits is not required but can be useful if you intend to use desirability functions.
| Functional   | (Available only in JMP Pro.) Adds multiple Y columns with FDE column properties to the design data table. These columns can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.
| Remove       | Removes the selected responses.
| Number of Responses | Enters additional responses so that the number that you enter is the total number of responses. If you have entered a response other than the default Y, the Goal for each of the additional responses is the Goal associated with the last response entered. Otherwise, the Goal defaults to Match Target. Click the Goal type in the table to change it.

The Responses outline contains the following columns:

**Response Name**  The name of the response. When added, a response is given a default name of Y, Y2, and so on. To change this name, double-click it and enter the desired name.

**Goal, Lower Limit, Upper Limit**  The Goal tells JMP that you want to maximize or minimize your response, match a target, or that you have no goal for your response. JMP assigns a Response Limits column property, based on these specifications, to each response column in the design table. It uses this information to define a desirability function for each response. The Profiler and Contour Profiler use these desirability functions to find optimal factor settings. For further details, see the Profiler chapter in Profilers and “Response Limits”.

The Responses outline contains the following columns:
A Goal of Maximize indicates that the best value is the largest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

A Goal of Minimize indicates that the best value is the smallest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

A Goal of Match Target indicates that the best value is a specific target value. The default target value is assumed to be midway between the Lower Limit and Upper Limit.

A Goal of None indicates that there is no goal in terms of optimization. No desirability function is constructed.

Note: If your target response is not midway between the Lower Limit and the Upper Limit, you can change the target after you generate your design table. In the data table, open the Column Info window for the response column (Cols > Column Info) and enter the desired target value.

Importance When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for the responses. If there is only one response, then specifying the Importance is unnecessary because it is set to 1 by default.

Detection Limits The lower and upper detection limits are bounds beyond which the response cannot be measured. The detection limits are saved as a column property. You can use these limits to specify a censored response in the Generalized Regression platform. See the Generalized Regression chapter in Fitting Linear Models.

Editing the Responses Outline

In the Responses outline, note the following:

- Double-click a response to edit the response name.
- Click the goal to change it.
- Click on a limit or importance weight to change it.
- For multiple responses, you might want to enter values for the importance weights.
Response Limits Column Property

The Goal, Lower Limit, Upper Limit, and Importance that you specify when you enter a response are used in finding optimal factor settings. For each response, the information is saved in the generated design data table as a Response Limits column property. JMP uses this information to define the desirability function. The desirability function is used in the Prediction Profiler to find optimal factor settings. For further details about the Response Limits column property and examples of its use, see “Response Limits”.

If you do not specify a Lower Limit and Upper Limit, JMP uses the range of the observed data for the response to define the limits for the desirability function. Specifying the Lower Limit and Upper Limit gives you control over the specification of the desirability function. For more details about the construction of the desirability function, see the Profiler chapter in Profilers.

Factors

Add factors in the Factors outline.

Tip: When you have completed the Factors outline, consider selecting Save Factors from the red triangle menu. This saves the factor names, roles, changes, and values in a data table that you can later reload.

Figure 13.4  Factors Outline

Add  Enter the number of factors to add and click Add.

Remove Selected  Removes the selected factors.

Factors List

The Factors list contains the following columns:

Name  The name of the factor. When added, a factor is given a default name of X1, X2, and so on. To change this name, double-click it and enter the desired name.
**Role**  Specifies the Design Role of the factor. The Design Role column property for the factor is saved to the data table. This property ensures that the factor type is modeled appropriately.

**Values**  The experimental settings for the factors. To insert Values, click the default values and enter the desired values.

**Editing the Factors List**

In the Factors list, do the following:

- To edit a factor name, double-click the factor name.
- To edit a value, click the value in the **Values** column.

**Linear Constraints**

Click the **Linear Constraint** button to enter one or more linear inequality constraints. A template appears for a linear expression involving all the continuous factors in your design. Enter coefficient values for the factors and select the direction of the inequality to reflect your linear constraint. Specify the constraining value in the box to the right of the inequality. To add more constraints, click **Linear Constraint** again.

**Note:** When you save a script for a design that involves a linear constraint, the script expresses the linear constraint as a *less than or equal to* inequality (≤).

**Ternary Plot Overview**

A ternary plot is a two-dimensional representation of three mixture components that sum to a constant. The plot is an equilateral triangle with an edge for each component. When unconstrained, each vertex of the triangle corresponds to a pure blend where one component is 1 (100%) and all other components are 0. When components are constrained, the feasible mixtures are represented by a portion of the ternary plot. Shading is used to exclude infeasible portions of the plot.

**Figure 13.5** displays three components P1, P2, and P3. The three components are unconstrained with the range of each proportion ranging from 0 to 1 (100%). Three points are labeled with their coordinates (P1, P2, P3). One point (0.2, 0.2, 0.6) includes blue lines along the axis grid lines for each mixture component to guide you in reading the axes.
**Examples of Mixture Design Types**

- “Optimal Mixture Design”
- “Simplex Centroid Design”
- “Simplex Lattice Design”
- “Extreme Vertices Design”
- “ABCD Design”
- “Space Filling Design”

**Optimal Mixture Design**

Optimal mixture designs can be generated using either the Mixture Design Platform or the Custom Design platform.

Here you use the Mixture Platform to create an example optimal mixture design with three factors:

1. Select **DOE > Classical > Mixture Design**.
2. Use three factors for this example. No changes need to be made to the Factors section.
3. Click **Continue**.

4. Click **Optimal** on the Choose Mixture Design Type panel.

5. (Optional) To match the output of this example, click the Mixture Design red triangle and select Set Random Seed, and then enter 1409.

6. (Optional) To match the output of this example, click the Mixture Design red triangle and select Number of Starts, and then enter 2.

7. In the **Define Factor Constraints** panel, click **Specify Linear Constraints**, and then click **Add**.

8. Enter a 1 in the X1 and X2 boxes and enter 0.8 in the constraint box. This constrains X1+X2 to less than 80% of the mixture.

9. In the **Model** panel, click **Interactions > 2nd**. This adds interaction effects to the model.

10. In the **Design Generation** panel, enter 2 for the **Number of Center Points**.

11. Click **Make Design**.

**Figure 13.6 12-Run Optimal Design Runs**

<table>
<thead>
<tr>
<th>Design Run</th>
<th>X1</th>
<th>X2</th>
<th>X3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.8</td>
<td>0</td>
<td>0.2</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>0.8</td>
<td>0.2</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>0.4</td>
<td>0.6</td>
</tr>
<tr>
<td>6</td>
<td>0.4</td>
<td>0</td>
<td>0.6</td>
</tr>
<tr>
<td>7</td>
<td>0</td>
<td>0.8</td>
<td>0.2</td>
</tr>
<tr>
<td>8</td>
<td>0.4</td>
<td>0</td>
<td>0.6</td>
</tr>
<tr>
<td>9</td>
<td>0.4</td>
<td>0.4</td>
<td>0.2</td>
</tr>
<tr>
<td>10</td>
<td>0.8</td>
<td>0</td>
<td>0.2</td>
</tr>
<tr>
<td>11</td>
<td>0.264183</td>
<td>0.26087</td>
<td>0.46613</td>
</tr>
<tr>
<td>12</td>
<td>0.264183</td>
<td>0.26087</td>
<td>0.46613</td>
</tr>
</tbody>
</table>

12. Click **Make Table**.

**Note:** In practice, you would round the mixtures amounts to the appropriate level of precision.

**Visualize the Design**

1. From the design table, select **Graph > Ternary Plot**.

2. Select X1, X2, and X3 and click **X, Plotting**, and then click **OK**.
Figure 13.7 Ternary Plot for Optimal Design

The ternary plot shows the 7 unique mixtures that make up the design. The shading indicates the constrained region. For more information about ternary plots, see “Ternary Plot Overview”.

Simplex Centroid Design

A simplex centroid design of degree $k$ with $n$ factors consists of mixtures with the following characteristics:

- all one factor mixtures or pure blends
- all blends of two factors at equal levels
- additional blends, up to $k$ factors at a time blended at $k$ equal levels

A center point run with equal amounts of all the ingredients is included when $k$ is equal to the number of factors.

Note: This design can be used with lower bounds on one or more factors.

Creating the Design

To create an example simplex centroid design:

1. Select DOE > Classical > Mixture Design.
2. Use three factors for this example. No changes need to be made to the Factors section.
3. Click Continue.
4. Click **Simplex Centroid** to generate the design

**Note:** The default setting of $k = 2$ was used. There is a text box that enables you to adjust the value of $k$.

**Figure 13.8** Three Factor Simplex Centroid Design of Degree 2.

<table>
<thead>
<tr>
<th>Run</th>
<th>X1</th>
<th>X2</th>
<th>X3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>2</td>
<td>0.0000</td>
<td>1.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>3</td>
<td>0.0000</td>
<td>0.0000</td>
<td>1.0000</td>
</tr>
<tr>
<td>4</td>
<td>0.5000</td>
<td>0.5000</td>
<td>0.0000</td>
</tr>
<tr>
<td>5</td>
<td>0.5000</td>
<td>0.0000</td>
<td>0.5000</td>
</tr>
<tr>
<td>6</td>
<td>0.0000</td>
<td>0.5000</td>
<td>0.5000</td>
</tr>
<tr>
<td>7</td>
<td>0.3333</td>
<td>0.3333</td>
<td>0.3333</td>
</tr>
</tbody>
</table>

5. Click **Make Table**.

**Visualize the Design**

6. From design table, select **Graph>Ternary Plot**.
7. Select $X_1$, $X_2$, and $X_3$ and click **X, Plotting**, and then click **OK**.

**Figure 13.9** Ternary Plot for Simplex Centroid Design

For more information about ternary plots, see “Ternary Plot Overview”.
Simplex Lattice Design

The simplex lattice design is a space filling design that creates a triangular grid of runs. The design is the set of blends where the factors’ values are \( \frac{i}{m} \), where \( i \) varies from 0 to \( m \) and the sum of the factors is 1. For a three-level design, a factor can be set at 0, 0.33, 0.66, or 1.

**Note:** This design can be used with lower bounds on one or more factors.

To create an example simplex lattice design:

1. Select **DOE > Classical > Mixture Design.**
2. Use three factors for this example. No changes need to be made to the Factors section.
3. Click **Continue.**
4. Click **Simplex Lattice** to generate the design.

**Note:** The default setting of 5 levels was used. There is a text box that enables you to adjust the number of levels

**Figure 13.10** Three Factor Five-Level Simplex Lattice Design

5. Click **Make Table.**

**Visualize the Design**

6. From the design table, select **Graph > Ternary Plot.**
7. Select \( X_1, X_2, \) and \( X_3 \) and click **X, Plotting,** and then click **OK.**

\[ \text{Design} \]

\[ \begin{array}{llll}
\text{Run} & X_1 & X_2 & X_3 \\
1 & 0.0000 & 0.0000 & 1.0000 \\
2 & 0.0000 & 0.2000 & 0.8000 \\
3 & 0.0000 & 0.4000 & 0.6000 \\
4 & 0.0000 & 0.6000 & 0.4000 \\
5 & 0.0000 & 0.8000 & 0.2000 \\
6 & 1.0000 & 0.0000 & 0.0000 \\
7 & 0.2000 & 0.0000 & 0.8000 \\
8 & 0.2000 & 0.2000 & 0.6000 \\
9 & 0.2000 & 0.4000 & 0.4000 \\
10 & 0.2000 & 0.6000 & 0.2000 \\
11 & 0.4000 & 0.0000 & 0.6000 \\
12 & 0.4000 & 0.2000 & 0.4000 \\
13 & 0.4000 & 0.4000 & 0.2000 \\
14 & 0.4000 & 0.6000 & 0.2000 \\
15 & 0.6000 & 0.0000 & 0.4000 \\
16 & 0.6000 & 0.2000 & 0.2000 \\
17 & 0.6000 & 0.4000 & 0.0000 \\
18 & 0.6000 & 0.6000 & 0.0000 \\
19 & 0.8000 & 0.0000 & 0.2000 \\
20 & 0.8000 & 0.2000 & 0.0000 \\
21 & 1.0000 & 0.0000 & 0.0000 \\
\end{array} \]
For more information about ternary plots, see “Ternary Plot Overview”.

As the number of levels increases, the number of design points increases, decreasing the space between design points. In contrast to the simplex centroid design, the simplex lattice design does not necessarily include the centroid.

**Extreme Vertices Design**

An extreme vertices design requires restricted ranges on one or more of the factors, as defined by limits in the Factors panel or by linear constraints. An extreme vertices design consists of mixtures at the vertices of the factor space and at the averages of vertices up to a specified degree. The centroid point for two neighboring vertices joined by a line is a second-degree centroid. The centroid point for vertices sharing a plane is a third-degree centroid.

**An Extreme Vertices Example with Range Constraints**

To create an example extreme vertices design:

1. Select **DOE > Classical > Mixture Design**.
2. Under Factors, enter 2 for the number of additional factors to add and click **Add**.
3. Set the ranges for the five factors as shown in **Figure 13.12** and click **Continue**.
4. Enter 4 in the Degree text box and click Extreme Vertices.

Figure 13.13 Display and Modify Panel for Extreme Vertices Example

The default number of runs for this five-factor, degree 4 extreme vertices design is 116. This is the number of extreme vertices and averages up to degree 4 for these five factors given the constraints on their ranges. JMP uses the default set of mixtures as a candidate set to generate a smaller D Optimal design.

5. (Optional) To match the output of this example, click the Mixture Design red triangle and select Set Random Seed, and then enter 1409.

6. Enter 10 in the Choose desired sample size box and click Find Subset to generate the design.

Note: The Find Subset option uses the row exchange method (not coordinate exchange) to find the optimal subset of rows.

Figure 13.14 Ten Run D-optimal Extreme Vertices Design

7. Click Make Table.

Visualize the Design

8. From the design table, select Graph > Ternary Plot.
9. Select $X_1$, $X_2$, $X_3$, $X_4$, and $X_5$ and click **X, Plotting**, and then click **OK**.

**Figure 13.15** Partial Output of Ternary Plot for Five-Factor Design

When you have more than three mixture components, the ternary plot shows a series of plots. Each plot has two component axes and the third axis is the sum of all other components. The plots are shaded if you have a constrained region. The unshaded portion represents the feasible region. For more information about ternary plots, see “Ternary Plot Overview”.

### An Extreme Vertices Example with Linear Constraints

Consider the classic example presented by Snee (1979) and Piepel (1988). This example has three factors, $X_1$, $X_2$, and $X_3$, with factor bounds and three linear constraints.

To create an extreme vertices design for this example:

1. Select **DOE > Classical > Mixture Design**.
2. Enter the values from **Figure 13.16** for $X_1$, $X_2$, and $X_3$ and click **Continue**.

**Figure 13.16** Values and Linear Constraints for the Snee and Piepel Example

<table>
<thead>
<tr>
<th>Factors</th>
<th>Values</th>
<th>Linear Constraints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Role</td>
<td>Values</td>
</tr>
<tr>
<td>$X_1$</td>
<td>Mixture</td>
<td>0.1</td>
</tr>
<tr>
<td>$X_2$</td>
<td>Mixture</td>
<td>0.1</td>
</tr>
<tr>
<td>$X_3$</td>
<td>Mixture</td>
<td>0.7</td>
</tr>
</tbody>
</table>
3. Click **Linear Constraint** three times. Enter the constraints as shown in Figure 13.16.
4. Click the **Extreme Vertices** button.
5. Click **Make Table**.

**Visualize the Design**

6. From the design table, select **Graph > Ternary Plot**.
7. Select X1, X2, and X3 and click **X, Plotting**, and then click **OK**.

**Figure 13.17** Ternary Plot Showing Piepel Example with Constraints

The ternary plot shows the feasible region as defined by the factor limits and the linear constraints. The design points are at the six vertices of the feasible region, at the six edge mid-points, and the overall centroid. For more information about ternary plots, see “Ternary Plot Overview”.

**Statistical Details for Extreme Vertices Method**

If there are linear constraints, JMP uses the CONSIM algorithm developed by R.E. Wheeler, described in Snee (1979) and presented by Piepel (1988) as CONVRT. The method is also described in Cornell (1990, Appendix 10a). The method combines constraints and checks to see whether vertices violate them. If so, it drops the vertices and calculates new ones. The method named CONAEV for doing centroid points is by Piepel (1988).
If there are no linear constraints (only range constraints), the extreme vertices design is constructed using the XVERT method developed by Snee and Marquardt (1974) and Snee (1975). After the vertices are found, a simplex centroid method generates combinations of vertices up to a specified order.

The XVERT method first creates a full $2^{n_f-1}$ design using the given low and high values of the $n_f-1$ factors with smallest range. Then, it computes the value of the one factor left out based on the restriction that the factors’ values must sum to one. It keeps points that are not in factor’s range. If not, it increments or decrements the value to bring it within range, and decrements or increments each of the other factors in turn by the same amount. This method keeps the points that still satisfy the initial restrictions.

The above algorithm creates the vertices of the feasible region in the simplex defined by the factor constraints. However, Snee (1975) has shown that it can also be useful to have the centroids of the edges and faces of the feasible region. A generalized $n$-dimensional face of the feasible region is defined by $n_f-n$ of the boundaries and the centroid of a face defined to be the average of the vertices lying on it. The algorithm generates all possible combinations of the boundary conditions and then averages over the vertices generated on the first step.

**ABCD Design**

The ABCD Design is a screening design for mixtures. See Snee (1975).

To create an example ABCD design:

1. Select **DOE > Classical > Mixture Design**.
2. Under Factors, enter 3 for the number of additional factors to add and click **Add**.
3. Click **Continue**.
4. Click **ABCD Design**.
5. Click **Make Table**.
Space Filling Design

The Space Filling mixture designs spread design points throughout the design region. It
accommodates linear constraints. The design is generated in a fashion similar to the Fast
Flexible Filling design method found under DOE > Special Purpose > Space Filling Design
(“Fast Flexible Filling Designs”).

Two Mixture Design red triangle options relate specifically to Space Filling Designs:

**FFF Optimality Criterion** For the Fast Flexible Filling mixture design type, enables you to
select between the MaxPro criterion (the default) and the Centroid criterion. See “FFF
Optimality Criterion”.

**Advanced Options > Set Average Cluster Size** For the Fast Flexible Filling mixture design
type, enables you to specify the average number of randomly generated points used to
define each cluster or, equivalently, each design point. See “Set Average Cluster Size”.

Space Filling Example

To create an example space filling design:

1. Select **DOE > Classical > Mixture Design**.
2. (Optional) To match the output of this example click the Mixture Design red triangle and
   select Set Random Seed and enter 1409.
3. Use three factors for this example. No changes need to be made to the Factors section.
4. Click **Continue**.
5. Click **Linear Constraints**
6. Enter 0.7 in the X1 box, 1 in the X3 box, change the direction of the inequality to ≥ and enter
   0.4 in the constraint box.
   This constrains 0.7X1+X3 to at least 40% of the mixture.
7. Enter 30 in the **Runs** box.
8. Click **Space Filling**.
9. Click **Make Table**.

**Visualize the Design**

10. From the design table, select **Graph > Ternary Plot**.
11. Select X1, X2, and X3 and click **X, Plotting**, and then click **OK**.
Figure 13.19 Space Filling Design with One Linear Constraint

This design is constructed using the Centroid FFF Optimality Criterion. Note that the points fall in the constrained design region and are fairly well spread throughout this region. For more information about ternary plots, see “Ternary Plot Overview”.

Statistical Details for Mixture Space Filling Designs

FFF Optimality Criterion

The algorithms for Fast Flexible Filling designs begin by generating a large number of random points within the specified design region. These points are then clustered using a Fast Ward algorithm into a number of clusters that equals the Number of Runs that you specified.

The final design points can be obtained by using the default MaxPro (maximum projection) optimality criterion or by selecting the Centroid criterion. You can find these options under FFF Optimality Criterion in the report’s red triangle menu.

MaxPro For $p$ factors and $n$ equal to the specified Number of Runs, the MaxPro criterion strives to find points in the clusters that minimize the following criterion:

$$C_{MaxPro} = \sum_{i}^{n} \sum_{j = i + 1}^{n} \left[ \frac{1}{p} \prod_{k=1}^{p} (x_{ik} - x_{jk})^2 \right]$$

The MaxPro criterion maximizes the product of the distances between potential design points in a way that involves all factors. This supports the goal of providing good space-filling properties on projections of factors. See Joseph et al. (2015). The Max Pro option is the default.
Centroid  This method places a design point at the centroid of each cluster. It has the property that the average distance from an arbitrary point in the design space to its closest neighboring design point is smaller than for other designs.

**Note:** You can set a preference to always use a given optimality criterion. Select File > Preferences > Platforms > DOE. Select FFF Optimality Criterion and select your preferred criterion.

### Set Average Cluster Size

The **Set Average Cluster Size** option is found under Advanced Options in the Mixture Design red triangle menu. This option enables you to specify the average number of uniformly generated points used to define each cluster or, equivalently, each design point.

By default, if the number of Runs for the Space Filling design type is 200 or smaller, a total of 10,000 random uniformly generated points are used as the basis for the clustering algorithm. When the number of Runs exceeds 200, the default value is 50. Increasing this value can be particularly useful in designs with a large number of factors.

**Note:** Depending on the number of factors and the specified value for Runs, you might want to increase the average number of initial points per design point by selecting Advanced Options > Set Average Cluster Size.

### Linear Constraints

The design region can be restricted by selecting the **Linear Constraint** option in the Linear Constraints outline.

When you specify linear constraints, the random points that form the basis for the clustering algorithm are randomly distributed within the constrained design region. The clustering algorithm uses these points.

### Fitting Mixture Designs

When fitting a model for mixture designs, one must take into account that the factors sum to a constant. A traditional full linear model is not fully estimable.

An appropriate response surface model for mixture responses is the Scheffé polynomial (Scheffé 1958). See the discussion of Cox Mixtures and the Scheffé cubic macro in Fitting Linear Models. The Scheffé polynomial model does the following:

- suppresses the intercept
• includes all the linear main-effect terms
• excludes all the square terms (such as X1*X1)
• includes all the cross terms (such as X1*X2)

In this model, the parameters are easy to interpret (Cornell 1990). The coefficients on the linear terms are the fitted response at the extreme points where the mixture consists of a single factor. The coefficients on the cross terms indicate the curvature across each edge of the factor space.

For a mixture model with third-degree polynomial terms, the Scheffé cubic model can be used. The Scheffé cubic model includes terms of the form X1*X2*(X1-X2).

• To fit a Scheffé polynomial model use the Mixture Response Surface macro in the Fit Model platform.
• To fit the Scheffé cubic model use the Scheffe Cubic macro in the Fit Model platform.
• If you chose to fit a different mixture model the Fit Model platform includes options for a No Intercept model and Mixture Effects as an effect attribute.

**Tip:** The custom design model outline has an option for adding the Scheffé cubic model terms. The generated design table will include a script for the Scheffé cubic model.

### Whole Model Tests and Analysis of Variance Reports

In a whole-model Analysis of Variance table, JMP traditionally tests that all the parameters are zero except for the intercept. In a mixture model without an intercept, JMP looks for a hidden intercept, in the sense that a linear combination of effects is a constant. If it finds a hidden intercept, it does the whole model test with respect to the intercept model rather than a zero-intercept model. This test is equivalent to testing that all the parameters are zero except the linear parameters, and testing that they are equal.

The hidden-intercept property also causes the $R^2$ to be reported with respect to the intercept model rather than reported as missing.

### Understanding Response Surface Reports

When there are effects marked as response surface effects “&RS,” JMP creates additional reports that analyze the fitted response surface. These reports were originally designed for full response surfaces, not mixture models. However, JMP might encounter a no-intercept model and find a hidden intercept with linear response surface terms, but no square terms. Then it **folds** its calculations, collapsing on the last response surface term to calculate critical values for the optimum. This can be done for any combination that yields a constant and involves the last response surface term.
A Chemical Mixture Example

Three plasticizers (p1, p2, and p3) comprise 79.5% of the vinyl used for automobile seat covers (Cornell, 1990). Within this 79.5%, the individual plasticizers are restricted by the following constraints: $0.409 \leq x_1 \leq 0.849$, $0 \leq x_2 \leq 0.252$, and $0.151 \leq x_3 \leq 0.274$. Cornell uses a 14-run design to fit a quadratic mixture model to the collected responses. The design is a 3-degree extreme vertices design with replicate measurements taken at the four vertices and the overall centroid.

- “Create the Design”
- “Analyze the Mixture Model”
- “The Prediction Profiler”
- “The Mixture Profiler”

Create the Design

To create Cornell’s mixture design in JMP

1. Select Help > Sample Data Library and open Plastifactors.jmp.
2. Select DOE > Classical > Mixture Design.
3. Click the Mixture Design red triangle and select Load Factors.

Figure 13.20 Factors and Factor Constraints for the Plasticizer Experiment

4. Click Continue.
5. Enter 3 in the Degree box.
6. Click Extreme Vertices.
7. Click Make Table. JMP uses the 9 factor settings to generate a JMP table.
Figure 13.21 Extreme Vertices Mixture Design

<table>
<thead>
<tr>
<th></th>
<th>p1</th>
<th>p2</th>
<th>p3</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.397</td>
<td>0.232</td>
<td>0.151</td>
<td>*</td>
</tr>
<tr>
<td>2</td>
<td>0.256</td>
<td>0.292</td>
<td>0.375</td>
<td>*</td>
</tr>
<tr>
<td>3</td>
<td>0.6615</td>
<td>0.126</td>
<td>0.2125</td>
<td>*</td>
</tr>
<tr>
<td>4</td>
<td>0.6</td>
<td>0.126</td>
<td>0.274</td>
<td>*</td>
</tr>
<tr>
<td>5</td>
<td>0.7875</td>
<td>0</td>
<td>0.2125</td>
<td>*</td>
</tr>
<tr>
<td>6</td>
<td>0.849</td>
<td>0</td>
<td>0.151</td>
<td>*</td>
</tr>
<tr>
<td>7</td>
<td>0.5355</td>
<td>0.232</td>
<td>0.2125</td>
<td>*</td>
</tr>
<tr>
<td>8</td>
<td>0.474</td>
<td>0.232</td>
<td>0.274</td>
<td>*</td>
</tr>
<tr>
<td>9</td>
<td>0.723</td>
<td>0.126</td>
<td>0.151</td>
<td>*</td>
</tr>
</tbody>
</table>

Note: Your table might differ due to the random seed used to generate the design.

Next, you add an extra five design runs by duplicating the vertex points and overall centroid, to generate the 14 run design.

8. To identify the vertex points and the centroid use a ternary plot. From the design table, select Graph > Ternary Plot.

9. Select p1, p2, and p3 and click X, Plotting, and then click OK.

Figure 13.22 Ternary Plot for Design

10. Highlight the vertices and centroid points.
11. Select **Edit > Copy**, to copy the selected rows to the clipboard.

12. Click in the first cell of row 10 and select **Edit > Paste** to add the duplicate rows to the table.

**Note:** A similar design can be obtained using the custom designer with the quadratic model, 2 center points, 4 replicate designs, and 14 runs.

The Plasticizer design with the results (Y values) that Cornell obtained are available in the sample data file **Plasticizer.jmp**.

### Analyze the Mixture Model

To analyze the Plasticizer experiment use the sample data table **Plasticizer.jmp**.

1. Select **Help > Sample Data Library** and open **Plasticizer.jmp**.
2. Click the green triangle next to the **Model** script in the upper left corner of the data table.

   A completed Fit Model launch window appears.

**Note:** The model script is saved to the design table when you create a design.

3. Click **Run** to see the response surface analysis.
4. **Plasticizer.jmp** contains a column called **Pred Formula Y**. This column was added after the analysis by selecting **Save Columns > Prediction Formula** from the Response Y red triangle.
5. To see the prediction formula, click the plus symbol in the column list:


**Note:** These results correct the coefficients reported in Cornell (1990).
The Response Surface Solution report shows that a maximum predicted value of 19.570299 occurs at point (0.63505, 0.15568, 0.20927).

**Figure 13.24** Mixture Response Surface Analysis

![Response Surface](image)

![Solution](image)

**The Prediction Profiler**

The report contains a prediction profiler.

1. From the prediction profiler you can see how the crossed effects show as curvature in the prediction traces. As you change values of one component (drag the red lines) the values of the other two components move in the opposite direction to maintain their ratio and the overall mixture constraint (components must sum to 100%).

   **Note:** The axes of prediction profiler traces range from the defined upper and lower bounds of the factors, p1, p2, and p3. When you explore the effect of a component and the limit of a second component is reached, it cannot move further and only the third variable changes to maintain the mixture constraint.

2. To the visible profile curves to bounds that take into account the levels of all three components, click the Prediction Profiler red triangle and select **Profile at Boundary > Stop at Boundaries**.

3. To optimize the mixture components click the Prediction Profiler red triangle and select **Optimization and Desirability > Desirability Functions**.

4. Click the Prediction Profiler red triangle and select **Optimization and Desirability > Maximize Desirability** to obtain the optimal factor settings for maximum Y.

The profiler displays optimal settings (rounded) of 0.6350 for p1, 0.1557 for p2, and 0.2093 for p3, which give an estimated response of 19.5703.
The Mixture Profiler

The Fit Model report also has a **Mixture Profiler** that is useful for visualizing and optimizing response surfaces from mixture experiments. Many of the features are the same as those of the Contour Profiler. However, some are unique to the Mixture Profiler:

- A ternary plot is used instead of a Cartesian plot, which enables you to view three mixture factors at a time.
- If you have more than three factors, radio buttons let you choose which factors to plot.
- If the factors have constraints, you can enter their low and high limits in the Lo Limit and Hi Limit columns. This setting shades non-feasible regions in the profiler.

Click the Response Y red triangle and select **Factor Profiling > Mixture Profiler** to see the mixture profiler for the plasticizer data.
Figure 13.26 Mixture Profiler for Plasticizer Example
A Taguchi design uses crossed array to explore factors in the presence of noise. A Taguchi design has two parts: the inner array is a design for control factors, and the outer array is a design for the noise factors. The full design is the cross product of the two arrays.

Note that noise factors in production that are not easy or cost effective to control must be controlled during an experiment. Alternatives to Taguchi designs include combined arrays and mixed resolution designs (Borror and Montgomery, 2000). For an example of a design with noise factors using the custom designer see “Experiments for Robust Process and Product Design”.

**Figure 14.1** Taguchi Design with Three Control Factors and Two Noise Factors
Contents

Overview of Taguchi Designs ................................................................. 425
Example of a Taguchi Design ............................................................... 425
Build a Taguchi Design ........................................................................ 429
  Responses ........................................................................................... 430
  Factors ............................................................................................... 430
Choose Taguchi Inner and Outer Array Designs .................................... 431
Display Coded Design .......................................................................... 431
Make the Design Table ......................................................................... 432
Taguchi Design Options ........................................................................ 432
Overview of Taguchi Designs

A Taguchi Design uses two types of factors: control factors and noise factors.

- An inner design is constructed for the control factors.
- An outer design is constructed for the noise factors.

The experiment is performed on all combinations of the inner and outer design runs. The noise factors have to be controlled during the experiment. The mean and standard deviation for each setting in the inner array across the noise settings are combined into a signal-to-noise measure for analysis. Table 14.1 lists the signal-to-noise performance statistics.

### Table 14.1 Recommended Performance Statistics

<table>
<thead>
<tr>
<th>Goal</th>
<th>S/N Ratio Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>nominal is best</td>
<td>$\frac{S}{N} = 10\log\left(\frac{\sum Y^2}{\sum s^2}\right)$</td>
</tr>
<tr>
<td>larger-is-better (maximize)</td>
<td>$\frac{S}{N} = -10\log\left(\frac{1}{n} \sum \frac{1}{Y_i^2}\right)$</td>
</tr>
<tr>
<td>smaller-is-better (minimize)</td>
<td>$\frac{S}{N} = -10\log\left(\frac{1}{n} \sum Y_i^2\right)$</td>
</tr>
</tbody>
</table>

Example of a Taguchi Design

Use a Taguchi design to study four control factors evaluated across three noise factors. This example is an experiment described by Byrne and Taguchi (1986). The objective of the experiment is to find settings of control factors to maximize the adhesiveness (pull-off force) of nylon tubing.

The design has four signal factors:

- **Interfer**  Tubing and connector interference. Signal factor with 3 levels.
- **Wall**     Wall thickness of the connector. Signal factor with 3 levels.
- **Depth**    Insertion depth of the tubing into the connector. Signal factor with 3 levels.
Adhesive  Percent of adhesive. Signal factor with 3 levels.

The design has three noise factors:

Time   Conditioning time. Noise factor with 2 levels.

Temperature  Temperature. Noise factor with 2 levels.

Humidity  Relative humidity. Noise factor with 2 levels.

Create the Design

1. Select DOE > Classical > Taguchi Arrays.
2. Select Help > Sample Data Library and open Design Experiment/Byrne Taguchi Factors.jmp.
3. In the Taguchi Arrays window, click the Taguchi Design red triangle and select Load Factors.

The Factors panel shows the four three-level control (signal) factors and three noise factors.

Note: The Goal selected for the response determines the SN Ratio formula that is added to your design data table.

4. Ensure that L9-Taguchi is selected for the inner array.
5. Click L8 for the outer array design.

Figure 14.2  Completed Taguchi Design Window

6. Click Continue.
7. Click Make Table to create the design table shown in Figure 14.3.
The inner array has nine runs for the four signal factors, each at three levels. The settings for the signal factors are provided in the first four columns of the table.

The outer design is a full factorial design for the three two-level noise factors. The outer array is provided in eight columns of the data table. The column names are the pattern of the outer array runs. For example, the column named “---” is for the results collected when all of the noise levels are at their low levels. Each of the nine trials are conducted at each of the eight combination of noise factors for a total of 72 experimental trials.

**Figure 14.3** Taguchi Design before Data Entry

![Taguchi Design before Data Entry](image)

The design table allows for entry of the 72 experimental results.

8. Select **Help > Sample Data Library** and open Design Experiment/Byrne Taguchi Data.jmp.

**Figure 14.4** Complete Taguchi Design Table (Byrne Taguchi Data.jmp)

![Complete Taguchi Design Table](image)

The SN Ratio Y column is the performance statistic (larger is better) to maximize the response. It is computed as –10 times the common logarithm of the average of the squared reciprocals of the responses:

\[
-10\log_{10} \left[ \frac{1}{(Y- - -)^2} + \frac{1}{(Y- - +)^2} + \frac{1}{(Y- + -)^2} + \frac{1}{(Y- + +)^2} + \frac{1}{(Y+ - -)^2} + \frac{1}{(Y+ - +)^2} + \frac{1}{(Y+ + -)^2} + \frac{1}{(Y+ + +)^2} \right]
\]

This expression is large when all of the individual \(y\) response values are large. That is, you are trying to find the signal settings that result in the largest response across the noise settings.
Analyze the Data

The data are now ready to analyze. The goal of the analysis is to find factor settings that maximize both the mean and the signal-to-noise ratio.

1. In the Byrne Taguchi Data.jmp data table, click the green arrow to run the Model script.

**Figure 14.5** Fit Model Launch Window for Taguchi Data

The script launches the Fit Model window. The model includes the main effects of the four signal factors to model the mean (Mean Y) and signal-to-noise ratio (SN Ratio Y) responses.

2. Click *Run*.

The Prediction Profiler at the bottom of the report is a quick way to find settings that give the highest signal-to-noise ratio for this experiment and the mean value at that maximum.

**Figure 14.6** The Prediction Profiler
3. Click the Prediction Profiler red triangle and select **Optimization and Desirability > Desirability Functions**.

This adds a row of traces and a column of function settings to the profiler, as shown in Figure 14.7. The default desirability functions are set to larger-is-better, which is what you want in this experiment. See Profilers for more information about desirability functions in the prediction profiler.

4. Click the Prediction Profiler red triangle and select **Optimization and Desirability > Maximize Desirability**.

**Figure 14.7** Best Factor Settings for Byrne Taguchi Data

In this example, the optimal settings for Interfer and Wall are 2, Depth is 3, and Adhesive is 1. These settings result in a predicted Mean value of 22.8 and an SN Ratio of 26.9.

**Build a Taguchi Design**

Build a Taguchi Design by selecting **DOE > Classical > Taguchi Arrays**. First define your responses and factors. Next, continue to the design options, generation, and evaluation. The design process follows the flow in Figure 14.8. See “The DOE Workflow: Describe, Specify, Design”.

**Figure 14.8** Taguchi Design Flow
Responses

Use the Response outline to specify a response for a Taguchi design.

**Figure 14.9  Response Outline**

<table>
<thead>
<tr>
<th>Response Name</th>
<th>Goal</th>
<th>Lower Limit</th>
<th>Upper Limit</th>
<th>Importance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y</td>
<td>Larger is Better</td>
<td></td>
<td></td>
<td>1</td>
</tr>
</tbody>
</table>

The Response outline contains the following columns:

**Response Name**  The name of the response (the default is Y). To change this name, double-click it and enter a different name.

**Goal, Lower Limit, Upper Limit**  The Goal determines the form of the signal-to-noise function (Table 14.1). Select one of the following Goals: Larger Is Better, Nominal is Best, Smaller is Better, or None. When you create your design, JMP saves a formula for the SN Ratio to the data table that reflects your selected goal. To change a goal, click it and enter a different goal. Use the Lower and Upper Limits if you have limits on your response.

**Importance**  When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for the responses. In a Taguchi Design there is only one response, the Importance is set to 1 by default. No value is needed for the Importance.

Factors

Use the Factors outline to specify factors for a Taguchi Design.

**Signal**  Specify two or more 2- or 3-level signal factors. Signal factors are system control inputs. These are factors that you can control in production.

**Noise**  Specify one or more noise factors. Noise factors are variables that are difficult or expensive to control in production. However, you must be able to control noise factors during the experiment. Click Noise to add a noise factor.

**Remove**  Removes the selected factors.

**Name**  The name of the factor. When added, a factor is given a default name of X1, X2, and so on. To change this name, double-click it and enter a different name.

**Role**  Specifies the Design Role (Signal or Noise) of the factor. This is set when you add the factor.

**Values**  The experimental settings for the factors. To insert Values, click the default values and enter the desired values.
Figure 14.10  Factors Outline

<table>
<thead>
<tr>
<th>Name</th>
<th>Role</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>X1</td>
<td>Signal</td>
<td>1, 2</td>
</tr>
<tr>
<td>X2</td>
<td>Signal</td>
<td>1, 2</td>
</tr>
</tbody>
</table>

Choose Taguchi Inner and Outer Array Designs

The Choose Inner and Outer Array Design options appear after you click Continue in the Specify Factors panel. Based on your signal factors, you get one or more choices for orthogonal designs for the inner array. The outer array choices for orthogonal “L” designs depend on the number and type of factors in your design.

Display Coded Design

After you select a design type for the inner and outer arrays, the Coded Design is shown when your inner array has two-level factors.

Figure 14.11  Coding for Eight Factor L12 Design

The Coded Design shows the pattern of high and low values for the factors in each run.
Make the Design Table

When you click **Make Table**, a Taguchi Design table similar to the one in Figure 14.12 appears. In the data table, each row represents an inner array run. In the values for the Pattern variable, plus signs designate high levels, and minus signs represent low levels. The table also contains a column for each factor and a column for each pattern that appears in the Pattern column. The columns for the patterns contain the responses to the experiment. If you selected Simulate Responses from the Taguchi Design red triangle menu, the pattern columns are filled with simulated response values.

![Figure 14.12 Taguchi Design Table for an Eight Factor L12 Design](image)

Taguchi Design Options

The Taguchi Design red triangle menu contains options for design setup and generation.

**Save Responses**  Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.

**Load Responses**  Loads responses that you saved using the Save Responses option.

**Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

**Note:** It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting **Column Properties > Design Role**. In the Design Role area, select the appropriate role.

**Load Factors**  Loads factors that you saved using the Save Factors option.

**Save Constraints**  (Unavailable for some platforms) Saves factor constraints that you defined in the Define Factor Constraints or Linear Constraints outline into a data table, with a
column for each constraint. You can then quickly load the constraints into most DOE windows.

In the constraint table, the first rows contain the coefficients for each factor. The last row contains the inequality bound. Each constraint’s column contains a column property called `ConstraintState` that identifies the constraint as a “less than” or a “greater than” constraint. See “`ConstraintState`”.

**Load Constraints** (Unavailable for some platforms) Loads factor constraints that you saved using the Save Constraints option.

**Set Random Seed** Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:

- initializing search algorithms for design generation
- randomizing Run Order for design construction
- selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking **Make Design**.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

**Simulate Responses** Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

- A set of simulated response values is added to each response column.
- For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
- A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

**Note:** Not all distributions are available for all design types.

- A script called **DOE Simulate** is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a
new column called <Y> Simulated, where Y is the name of the response. Clicking Apply again updates the formula and values in <Y> Simulated.

For additional details, see “Simulate Responses”.

**Note:** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in *Basic Analysis*. 
Using the Evaluate Design platform, you can:

- See the strengths and limitations of your existing experimental design.
- Determine your design’s ability to detect effects associated with meaningful changes in the response.
- Address prediction variance and the precision of your estimates.
- Gain insight on aliasing.
- Obtain efficiency measures.

The Evaluate Design platform generates the results that appear in the Design Evaluation outlines provided by several DOE platforms. Diagnostics provided by both Evaluate Design and the Design Evaluation outlines include the following:

- power analysis
- a prediction variance profiler and surface plot
- a fraction of design space plot, showing how much of the design space has prediction variance above a given value
- estimation efficiency measures for parameter estimates
- the alias matrix, showing the bias structure for model effects
- a color map showing absolute correlations among effects
- design efficiency values

**Figure 15.1** Comparison of Two Fraction of Design Space Plots
Contents

Overview of the Evaluate Design Platform ......................................................... 437
Example of Evaluate Design .............................................................. 438
  Assessing the Impact of Lost Runs ......................................................... 438
  Evaluating Power Relative to a Specified Model ...................................... 445
Evaluate Design Launch Window ............................................................. 447
Evaluate Design Window .............................................................. 447
  Factors .............................................................. 449
  Model .............................................................. 449
  Alias Terms .............................................................. 450
  Design .............................................................. 451
  Design Evaluation .............................................................. 451
  Power Analysis .............................................................. 451
  Prediction Variance Profile .............................................................. 458
  Fraction of Design Space Plot .............................................................. 459
  Prediction Variance Surface .............................................................. 460
  Estimation Efficiency .............................................................. 462
 Alias Matrix .............................................................. 464
  Color Map on Correlations .............................................................. 465
  Design Diagnostics .............................................................. 467
Evaluate Design Options .............................................................. 469
Overview of the Evaluate Design Platform

The Evaluate Design platform provides powerful tools that enable you to assess the properties of your design, whether it is created by JMP or another tool. You can use the platform before conducting an experiment to choose from several designs. You can also assess the impact of incorrect settings or lost runs in a design that you have conducted. You can modify the terms in your assumed model to see the impact of estimating a modified model. You can also modify the terms that appear in the Alias Terms outline to see the impact on the Alias Matrix.

You start by entering information about the design in the launch window. Then you can modify the assumed model and specify which effects not included in the model are of potential interest. Based on your specifications, the Design Evaluation platform then provides a number of ways to evaluate the properties of the generated design:

**Power Analysis**  Enables you to explore your ability to detect effects of given sizes.

**Prediction Variance Profile**  Shows the prediction variance over the range of factor settings.

**Fraction of Design Space Plot**  Shows how much of the model prediction variance lies below or above a given value.

**Prediction Variance Surface**  Shows a surface plot of the prediction variance for any two continuous factors.

**Estimation Efficiency**  For each parameter, gives the fractional increase in the length of a confidence interval compared to that of an ideal (orthogonal) design, which might not exist. Also gives the relative standard error of the parameters.

**Alias Matrix**  Gives coefficients that indicate the degree to which the model parameters are biased by effects that are potentially active, but not in the model.

**Color Map on Correlations**  Shows the absolute correlations between effects on a plot using an intensity scale.

**Note:** The default intensity scale is a gray scale. To change the color scale, click the Color Map on Correlations red triangle and select **Blue to Gray to Red**. For a custom color scale, right-click in the plot and select **Color Theme**.

**Design Diagnostics**  Gives efficiency measures for your design.

**Note:** In several DOE platforms, when you construct a design, a Design Evaluation outline appears. This outline shows results provided by the Evaluate Design platform. The platforms that provide a Design Evaluation outline are: Custom Design, Definitive Screening Design, Screening Design, Response Surface Design, and Mixture Design with Optimal design type.
Example of Evaluate Design

- “Assessing the Impact of Lost Runs”
- “Evaluating Power Relative to a Specified Model”

Assessing the Impact of Lost Runs

An experiment was conducted to explore the effect of three factors (Silica, Sulfur, and Silane) on tennis ball bounciness (Stretch). The goal of the experiment is to develop a predictive model for Stretch. A 15-run Box-Behnken design was selected using the Response Surface Design platform. After the experiment, the researcher learned that the two runs where Silica = 0.7 and Silane = 50 were not processed correctly. These runs could not be included in the analysis of the data.

Use the Evaluate Design platform to assess the impact of not including those two runs. Obtain diagnostics for the intended 15-run design and compare these to the actual 13-run design that is missing the two runs.

Construct the Intended and Actual Designs

Intended Design

1. Select Help > Sample Data Library and open Design Experiment/Bounce Data.jmp.
2. Select DOE > Design Diagnostics > Evaluate Design.
   You can add Stretch as Y, Response if you wish. But specifying the response has no effect on the properties of the design.
4. Click OK.

Leave your Evaluate Design window for the intended design open.

Tip: Place the Evaluate Design window for the intended design in the left area of your screen. After the next steps, you will place the corresponding window for the actual design to its right.
Actual Design with Missing Runs

In this section, you will exclude the two runs where Silica = 0.7 and Silane = 50. These are rows 3 and 7 in the data table.

1. In Bounce Data.jmp, select rows 3 and 7, right-click in the highlighted area, and select Hide and Exclude.
2. Select DOE > Design Diagnostics > Evaluate Design.
3. Click Recall.
4. Click OK.

Leave your Evaluate Design window for the actual design open.

Tip: Place the Evaluate Design window for the actual design to the right of the Evaluate Design window for the intended design to facilitate comparing the two designs.

Comparison of Intended and Actual Designs

You can now compare the two designs using these methods:

- “Power Analysis”
- “Prediction Variance Profile”
- “Fraction of Design Space Plot”
- “Estimation Efficiency”
- “Color Map on Correlations”
- “Design Diagnostics”

Power Analysis

In each window, do the following:

1. Open the Power Analysis outline.
   The outline shows default values of 1 for all Anticipated Coefficients. These values correspond to detecting a change in the anticipated response of 2 units across the levels of main effect terms, assuming that the interaction and quadratic terms are not active.
   The power calculations assume an error term (Anticipated RMSE) of 1. From previous studies, you believe that the RMSE is approximately 2.
2. Type 2 next to Anticipated RMSE.
   When you click outside the text box, the power values are updated.
   You are interested in detecting differences in the anticipated response that are on the order of 6 units across the levels of main effects, assuming that interaction and quadratic terms are not active. To set these uniformly, use a red triangle option.
3. Click the Power Analysis red triangle and select **Set Delta for Power**
4. Type 6 as your value for delta.
5. Click **OK**.

**Figure 15.2** shows both outlines, with the Design and Anticipated Responses outline closed.

**Figure 15.2** Power Analysis Outlines, Intended Design (Left) and Actual Design (Right)

The power values for the actual design are uniformly smaller than for the intended design. For Silica and Sulfur, the power of the tests in the intended design is almost twice the power in the actual design. For the Silica*Sulfur interaction, the power of the test in the actual design is 0.231, compared to 0.672 in the intended design. The actual design results in substantial loss of power in comparison with the intended design.

**Prediction Variance Profile**

1. In each window, open the Prediction Variance Profile outline.
2. In the window for the actual design, right-click on the vertical axis and from the menu select **Edit > Copy Axis Settings**.
   
   This action creates a script containing the axis settings. Next, apply these axis settings to the Prediction Variance Profile plot for the intended design.
3. In the Evaluate Design window for the intended design, locate the Prediction Variance Profile outline. Right-click on the vertical axis and from the menu select **Edit > Paste Axis Settings**.
   
   The plots are shown in **Figure 15.5**, with the plot for the intended design at the top and for the actual design at the bottom.
The Prediction Variance Profile plots are profiler views of the relative prediction variance. You can explore the relative prediction variance in various regions of design space. Both plots show the same relative prediction variance in the center of the design space. However, the variance for points near the edges of the design space appears greater than for the same points in the intended design. Explore this phenomenon by moving all three vertical lines to points near the edges of the factor settings.

4. In both windows, click the Prediction Variance Profile red triangle and select Maximize Variance.

Figure 15.4 shows the maximum relative prediction variance for the intended and actual designs.
**Figure 15.4** Prediction Variance Profile Maximized, Intended Design (Top) and Actual Design (Bottom)

For both designs, theprofilers identify the same point as one of the design points where the maximum prediction variance occurs: Silica=0.7, Sulfur=1.8, and Silane=40. The maximum prediction variance is 1.396 for the intended design, and 3.021 for the actual design. Note that there are other points where the prediction variance is maximized. The larger maximum prediction variance for the actual design means that predictions in parts of the design space are less accurate than they would have been had the intended design been conducted.

**Fraction of Design Space Plot**

1. In each window, open the Fraction of Design Space Plot outline.
2. In the window for the intended design, right-click in the plot and select **Edit > Copy Frame Contents**.
3. In the window for the actual design, locate the Fraction of Design Space Plot outline.
4. Right-click in the plot and select **Edit > Paste Frame Contents**.

**Figure 15.5** shows the plot with annotations. Each Fraction of Design Space Plot shows the proportion of the design space for which the relative prediction variance falls below a specific value.
Chapter 15
Evaluate Designs

Figure 15.5  Fraction of Design Space Plots

The relative prediction variance for the actual design is greater than that of the intended design over the entire design space. The discrepancy increases with larger design space coverage.

Estimation Efficiency

In each window, open the Estimation Efficiency outline.

Figure 15.6  Estimation Efficiency Outlines, Intended Design (Left) and Actual Design (Right)

In the actual design (right), the relative standard errors for all parameters either exceed or equal the standard errors for the intended design (left). For all except three of the non-intercept parameters, the relative standard errors in the actual design exceed those in the intended design.
The Fractional Increase in CI Length compares the length of a parameter’s confidence interval as given by the current design to the length of such an interval given by an ideal design of the same run size. The length of the confidence interval, and consequently the Fractional Increase in CI Length, is affected by the number of runs. See “Fractional Increase in CI Length”.

Despite the reduction in run size, for the actual design, the terms Silane, Silica*Silane, and Sulfur*Silane have a smaller increase than for the intended design. This is because the two runs that were removed to define the actual design had Silane set to its center point. By removing these runs, the widths of the confidence intervals for these parameters more closely resemble those of an ideal orthogonal design, which has no center points.

**Color Map on Correlations**

In each report, do the following:

1. Open the **Color Map On Correlations** outline.

   The two color maps show the effects in the Model outline. Each plot shows the absolute correlations between effects colored using the JMP default white to black intensity scale. Ideally, you would like zero or very small correlations between effects.

---

**Figure 15.7 Color Map on Correlations, Intended Design (Left) and Actual Design (Right)**

The absolute values of the correlations range from 0 (white) to 1 (black). Hover over a cell to see the value of the absolute correlation. The color map for the actual design shows more absolute correlations that are large than does the color map for the intended design. For example, the correlation between Sulfur and Silica*Sulfur is < .0001 for the intended design, and 0.5774 for the actual design.
Design Diagnostics

In each report, open the Design Diagnostics outline.

**Figure 15.8** Design Diagnostics, Intended Design (Left) and Actual Design (Right)

The intended design (left) has higher efficiency values and a lower average prediction variance than the actual design (right). The results of the Design Evaluation analysis indicate that the two lost runs have had a negative impact on the design.

Note that both the number of runs and the model matrix factor into the calculation of efficiency measures. In particular, the $D$-, $G$-, and $A$- efficiencies are calculated relative to the ideal design for the run size of the given design. It is not necessarily true that larger designs are more efficient than smaller designs. However, for a given number of factors, larger designs tend to have smaller Average Variance of Prediction values than do smaller designs. For more information on how efficiency measures are defined, see “Design Diagnostics”.

Evaluating Power Relative to a Specified Model

For this example, you have constructed a definitive screening design to determine which of six factors have an effect on the yield of an extraction process. The data are given in the Extraction Data.jmp sample data table, located in the Design Experiment folder. Because the design is a definitive screening design, each factor has three levels. See “Definitive Screening Designs”.

You are interested in the power of tests to detect a strong quadratic effect. You consider a strong effect to be one whose magnitude is at least three times as large as the error variation.

Although the experiment studies six factors, effect sparsity suggests that only a small subset of factors is active. Consequently, you feel comfortable investigating power in a model based on a smaller number of factors. Also, past studies on a related process provide strong evidence to suggest that three of the factors, Propanol, Butanol, and pH, have negligible main effects, do not interact with other factors, and do not have quadratic effects. This leads you to believe that the likely model contains main, interaction, and quadratic effects only for Methanol, Ethanol, and Time. You decide to investigate power in the context of a three-factor response surface model.

Use the Evaluate Design platform to determine the power of your design to detect strong quadratic effects for Methanol, Ethanol, or Time.

1. Select **Help > Sample Data Library** and open Design Experiment/Extraction Data.jmp.
2. Select **DOE > Design Diagnostics > Evaluate Design**.

3. Select Methanol, Ethanol, and Time and click **X, Factor**.
   
   You can add Yield as **Y, Response** if you wish. But specifying the response has no effect on the properties of the design.

4. Click **OK**.

5. In the Model outline, click **RSM**.
   
   This adds the interaction and quadratic terms for the three factors.

6. Open the Power Analysis outline.
   
   Note that the Anticipated RMSE is set to 1 by default. Although you have an estimate of the RMSE from past studies, you need not enter it. This is because the magnitude of the effect of interest is three times the error variation.


8. Click **Apply Changes to Anticipated Coefficients**.

**Figure 15.9** Power Analysis Outline after Applying Changes to Coefficients

The power of detecting a quadratic effect whose magnitude is three times the error variation is 0.737. This assumes a final model that is a response surface in three factors. It also assumes a 0.05 significance level for the test.
Evaluate Design Launch Window

To launch the Evaluate Design platform, open the data table of interest and select DOE > Design Diagnostics > Evaluate Design. The example in Figure 15.10 uses the Bounce Data.jmp sample data table, located in the Design Experiment folder.

Figure 15.10 Evaluate Design Launch Window

The launch window contains the following buttons:

**Y, Response**  Enter the response column or columns. Entering a response is optional. Response values are not used in evaluating the design. Responses must be numeric.

**X, Factor**  Enter the factor columns. Factors can be of any Data Type or Modeling Type.

Evaluate Design Window

The Evaluate Design window consists of two parts. See Figure 15.11, where all outline nodes are closed.

- The Factors, Model, Alias Terms, and Design outlines define the model and design.
- The Design Evaluation outline provides results that describe the properties of your design.
The Factors, Model, Alias Terms, and Design outlines contain information that you enter about the factors, assumed model, potentially aliased effects of interest, and the actual design. JMP populates these outlines using your selections in the launch window and the design table. However, you can modify the effects in the Model and Alias Terms outlines. Once you have made your specifications, the Design Evaluation outlines are updated. You can open these outlines to see reports or control windows that provide information about your design.

- “Factors”
- “Model”
- “Alias Terms”
- “Design”
- “Design Evaluation”
- “Power Analysis”
- “Prediction Variance Profile”
- “Fraction of Design Space Plot”
- “Prediction Variance Surface”
- “Estimation Efficiency”
- “Alias Matrix”
- “Color Map on Correlations”
- “Design Diagnostics”
Factors

The factors outline lists the factors entered in the launch window. You can select factors to construct effects in the Model outline.

Figure 15.12 Factors Outline

![Factors Outline](image)

Model

What appears in the Model outline depends upon whether the associated data table contains a Model or Fit Model script:

- If there is a script, the Model outline contains the estimable effects specified in the script. Effects are entered into the model in the order specified in the script. If the model script contains more effects than are estimable, those that are not estimable are not included in the model for evaluation.
- If there is no script, the Model outline contains only main effects.

Figure 15.13 shows the Model outline for the Bounce Data.jmp data table, found in the Design Experiment folder. The Model script in the data table contains response surface effects for the three factors Silica, Silane, and Sulfur. Consequently, the Model outline contains the main effects, two-way interactions, and quadratic effects for these three factors.

![Model Outline](image)

You can add effects to the Model outline using the following buttons:

- **Main Effects**  Adds main effects for all factors in the model.
Interactions  Adds interaction effects. If no factors are selected in the Factors outline, select 2nd, 3rd, 4th, or 5th to add all appropriate interactions up to that order. Add interactions up to a given order for specific factors by selecting the factor names in the Factors outline, selecting Interactions, and then specifying the appropriate order. Interactions between non-mixture and mixture factors, and interactions with blocking and constant factors, are not added.

RSM  Adds interaction and quadratic terms up to the second order (response surface model terms) for continuous factors. Categorical factors are not included in RSM terms. Main effects for non-mixture factors that interact with all the mixture factors are removed.

Cross  Adds specific interaction terms. Select factor names in the Factors outline and effect names in the Model outline. Click Cross to add the crossed terms to the Model outline.

Powers  Adds polynomial terms. If no factor names are selected in the Factors outline, adds polynomial terms for all continuous factors. If factor names are selected in the Factors outline, adds polynomial terms for only those factors. Select 2nd, 3rd, 4th, or 5th to add polynomial terms of that order.

Scheffé Cubic  Adds Scheffé cubic terms for all mixture factors. These terms are used to specify a mixture model with third-degree polynomial terms.

Remove Term  Removes selected effects.

Alias Terms

It is possible that effects not included in your assumed model are active. In the Alias Terms outline, list potentially active effects that are not in your assumed model but might bias the estimates of model terms. The Alias Matrix entries represent the degree of bias imparted to model parameters by the effects that you specified in the Alias Terms outline. See “The Alias Matrix”.

By default, the Alias Terms outline includes all two-way interaction effects that are not in your Model outline (with the exception of terms involving blocking factors). Add or remove terms using the buttons. For a description of how to use these buttons to add effects to the Alias Terms table, see “Model”.

In the Evaluate Design platform, the Alias Matrix outline is immediately updated to reflect changes to Alias Matrix effects. In the Custom Design platform, you must click Make Design after modifying the effects in the Alias Terms outline. Within other DOE platforms that construct designs, there is no Alias Terms outline. However, the Alias Matrix outline, containing appropriate effects, appears under Design Evaluation after you construct the design.
Design

The Design outline shows the design runs for the factors that you have specified in the launch window. You can easily view the design as you explore its properties in the Design Evaluation outline.

Design Evaluation

Design Evaluation within the Evaluate Design platform is based on your design and the specifications that you make in the Model and Alias Terms outlines. Several DOE Design platforms provide a Design Evaluation outline: Custom, Definitive Screening, Screening, Response Surface, and Mixture with Optimal design type. Design Evaluation within these platforms is based on the design that you construct.

Power Analysis

The Power Analysis outline calculates the power of tests for the parameters in your model. Power is the probability of detecting an active effect of a given size. The Power Analysis outline helps you evaluate the ability of your design to detect effects of practical importance. The higher your power, the more likely you are to detect significant effects assuming your coefficient and RMSE assumptions are correct. Power depends on the number of runs, the significance level, and the estimated error variation. In particular, you can determine if additional runs are necessary.

This section covers the following topics:

- “Power Analysis Overview”
- “Power Analysis Details”
- “Tests for Individual Parameters”
- “Tests for Categorical Effects with More Than Two Levels”
- “Design and Anticipated Responses Outline”
- “Power Analysis for Coffee Experiment”

Power Analysis Overview

Power is calculated for the effects listed in the Model outline. These include continuous, discrete numeric, categorical, blocking, mixture, and covariate factors. The tests are for individual model parameters and for whole effects. For more information on how power is calculated, see “Power Calculations”.
Power is the probability of rejecting the null hypothesis of no effect at specified values of the model parameters. In practice, your interest is not in the values of the model parameters, but in detecting differences in the mean response of practical importance. In the Power Analysis outline, you can compute Anticipated Responses for specified values of the Anticipated Coefficients. This helps you to determine the coefficient values associated with the differences you want to detect in the mean response.

Figure 15.14 shows the Power Analysis outline for the design in the Coffee Data.jmp sample data table, found in the Design Experiment folder. The model specified in the Model script is a main effects only model.

In the Power Analysis outline, you can:

- Specify coefficient values that reflect differences that you want to detect. You enter these as Anticipated Coefficients in the top part of the outline.
- Specify anticipated response values and apply these to determine the corresponding Anticipated Coefficients. You specify Anticipated Responses in the Design and Anticipated Responses panel.

From the Power Analysis red triangle menu, you can:
• Specify a power to determine anticipated coefficients to achieve that power. If coefficients do not exist to satisfy the specified power, then the coefficients are set to zero.

• Specify a value for delta, where anticipated coefficients will be half of the specified delta. The power is then updated based on the anticipated coefficients.

**Power Analysis Details**

Specify values for the Significance Level and Anticipated RMSE. These are used to calculate the power of the tests for the model parameters.

**Significance Level**  The probability of rejecting the hypothesis of no effect, if it is true. The power calculations update immediately when you enter a value.

**Anticipated RMSE**  An estimate of the square root of the error variation. The power calculations update immediately when you enter a value.

The top portion of the Power Analysis report opens with default values for the Anticipated Coefficients (Figure 15.14). The default values are based on Delta. See “Advanced Options > Set Delta for Power”.

**Note:** If the design is supersaturated, meaning that the number of parameters to be estimated exceeds the number of runs, the anticipated coefficients are set to 0.

Figure 15.15 shows the top portion of the Power Analysis report where values have been specified for the Anticipated Coefficients. These values reflect the differences you want to detect.

**Figure 15.15** Possible Specification of Anticipated Coefficients for Coffee Data.jmp
Tests for Individual Parameters

The Term column contains a list of model terms. For each term, the Anticipated Coefficient column contains a value for that term. The value in the Power column is the power of a test that the coefficient for the term is 0 if the true value of the coefficient is given by the Anticipated Coefficient.

**Term**  The model term associated with the coefficient being tested.

**Note:** The order in which model terms appear in the Power Analysis report may not be identical to their order in the Parameter Estimates report obtained using Standard Least Squares. This difference can only occur when the model contains an interaction with more than one degree of freedom.

**Anticipated Coefficient**  A value for the coefficient associated with the model term. This value is used in the calculations for Power. These values are also used to calculate the Anticipated Response column in the Design and Anticipated Responses outline. When you set a new value in the Anticipated Coefficient column, click **Apply Changes to Anticipated Coefficients** to update the Power and Anticipated Response columns.

**Note:** The anticipated coefficients have default values of 1 for continuous effects. They have alternating values of 1 and –1 for categorical effects. You can specify a value for Delta be selecting **Advanced Options > Set Delta for Power** from the red triangle menu. If you change the value of Delta, the values of the anticipated coefficients are updated so that their absolute values are one-half of Delta. See “**Advanced Options > Set Delta for Power**”.

**Power**  Probability of rejecting the null hypothesis of no effect when the true coefficient value is given by the specified Anticipated Coefficient. For a coefficient associated with a numeric factor, the change in the mean response (based on the model) is twice the coefficient value. For a coefficient associated with a categorical factor, the change in the mean response (based on the model) across the levels of the factor equals twice the absolute value of the anticipated coefficient.

Calculations use the specified Significance Level and Anticipated RMSE. For more information about the power calculation, see “**Power for a Single Parameter**”.

**Apply Changes to Anticipated Coefficients**  When you set a new value in the Anticipated Coefficient column, click **Apply Changes to Anticipated Coefficients** to update the Power and Anticipated Response columns.
Tests for Categorical Effects with More Than Two Levels

If your model contains a categorical effect with more than two levels, then the following columns appear below the Apply Changes to Anticipated Coefficients button:

**Effect**  The categorical effect.

**Power**  The power calculation for a test of no effect. The null hypothesis for the test is that all model parameters corresponding to the effect are zero. The difference to be detected is defined by the values in the Anticipated Coefficient column that correspond to the model terms for the effect. The power calculation reflects the differences in response means determined by the anticipated coefficients.

Calculations use the specified Significance Level and Anticipated RMSE. For more information about the power calculation, see “Power for a Categorical Effect”.

Design and Anticipated Responses Outline

The Design and Anticipated Responses outline shows the design preceded by an Anticipated Response column. Each entry in the first column is the Anticipated Response corresponding to the design settings. The Anticipated Response is calculated using the Anticipated Coefficients.

Figure 15.16 shows the Design and Anticipated Responses outline corresponding to the specification of Anticipated Coefficients given in Figure 15.15.

Figure 15.16  Anticipated Responses for Coffee Data.jmp

In the Anticipated Response column, you can specify a value for each setting of the factors. These values reflect the differences you want to detect.
Click **Apply Changes to Anticipate Responses** to update both the Anticipated Coefficient and Power columns.

**Anticipated Response**  The response value obtained using the Anticipated Coefficient values as coefficients in the model. When the outline first appears, the calculation of Anticipated Response values is based on the default values in the Anticipated Coefficient column. When you set new values in the Anticipated Response column, click **Apply Changes to Anticipated Responses** to update the Anticipated Coefficient and Power columns.

**Design**  The columns to the right of the Anticipated Response column show the factor settings for all runs in your design.

**Apply Changes to Anticipated Responses**  When you set new values in the Anticipated Response column, click **Apply Changes to Anticipated Responses** to update the Anticipated Coefficient and Power columns.

### Power Analysis for Coffee Experiment

Consider the design in the Coffee Data.jmp data table. Suppose that you are interested in the power of your design to detect effects of various magnitudes on Strength. Recall that Grind is a two-level categorical factor, Temperature, Time, and Charge are continuous factors, and Station is a three-level categorical (blocking) factor.

In this example, ignore the role of Station as a blocking factor. You are interested in the effect of Station on Strength. Since Station is a three-level categorical factor, it is represented by two terms in the Parameters list: Station 1 and Station 2.

Specifically, you are interested the probability of detecting the following changes in the mean Strength:

- A change of 0.10 units as you vary Grind from Coarse to Medium.
- A change of 0.10 units or more as you vary Temperature, Time, and Charge from their low to high levels.
- An increase due to each of Stations 1 and 2 of 0.10 units beyond the overall anticipated mean. This corresponds to a decrease due to Station 3 of 0.20 units from the overall anticipated mean.

You set 0.05 as your Significance Level. Your estimate of the standard deviation of Strength for fixed design settings is 0.1 and you enter this as the Anticipated RMSE.

**Figure 15.17** shows the Power Analysis node with these values entered. Specifically, you specify the Significance Level, Anticipated RMSE, and the value of each Anticipated Coefficient.

When you click Apply Changes to Anticipated Coefficients, the Anticipated Response values are updated to reflect the model you have specified.
Recall that Temperature is a continuous factor with coded levels of -1 and 1. Consider the test whose null hypothesis is that Temperature has no effect on Strength. Figure 15.17 shows that the power of this test to detect a difference of 0.10 (=2*0.05) units across the levels of Temperature is only 0.291.

Now consider the test for the whole Station effect, where Station is a three-level categorical factor. Consider the test whose null hypothesis is that Station has no effect on Strength. This is the usual $F$ test for a categorical factor provided in the Effect Tests report when you run Analyze > Fit Model. See Fitting Linear Models.

The Power of this test is shown directly beneath the Apply Changes to Anticipated Coefficients button. The entries under Anticipated Coefficients for the model terms Station 1 and Station 2 are both 0.10. These settings imply that the effect of both stations is to increase Strength by 0.10 units above the overall anticipated mean. For these settings of the Station 1 and Station 2 coefficients, the effect of Station 3 on Strength is to decrease it by 0.20 units from the overall anticipated mean. Figure 15.17 shows that the power of the test to detect a difference of at least this magnitude is 0.888.
**Prediction Variance Profile**

The Prediction Variance Profile helps you to understand where in the design space your predictions have more or less variability. Low prediction variance is desired. Use the **Maximize Variance** option to find the maximum variance. See “Maximize Variance”.

The Prediction Variance Profile plots the relative variance of prediction as a function of each factor at fixed values of the other factors. **Figure 15.18** shows the Prediction Variance Profile for the Bounce Data.jmp data table, located in the Design Experiment folder.

**Figure 15.18** Prediction Variance Profiler

---

**Relative Prediction Variance**

For given settings of the factors, the prediction variance is the product of the error variance and a quantity that depends on the design and the factor settings. Before you run your experiment, the error variance is unknown, so the prediction variance is also unknown. However, the ratio of the prediction variance to the error variance is not a function of the error variance. This ratio, called the **relative prediction variance**, depends only on the design and the factor settings. Consequently, the relative variance of prediction can be calculated before acquiring the data. See “Relative Prediction Variance”.

After you run your experiment and fit a least squares model, you can estimate the error variance using the mean squared error (MSE) of the model fit. You can estimate the actual variance of prediction at any setting by multiplying the relative variance of prediction at that setting.

It is ideal for the prediction variance to be small throughout the design space. Generally, the error variance drops as the sample size increases. In comparing designs, you may want to place the prediction variance profilers for two designs side-by-side. A design with lower prediction variance on average is preferred.
Maximize Variance

You can evaluate a design or compare designs in terms of the maximum relative prediction variance. Select the **Maximize Variance** option from the Prediction Variance Profile red triangle menu. JMP uses a desirability function that maximizes the relative prediction variance. The value of the maximum variance in the Prediction Variance Profile is the worst (least desirable from a design point of view) value of the relative prediction variance. The maximum variance can occur at more than one combination of factor settings.

**Figure 15.19** shows the Prediction Variance Profile with Maximize Variance selected. The plot is for the Bounce Data.jmp sample data table, located in the Design Experiment folder. The maximum value of the relative prediction variance is 1.3958 when Silica = 0.7, Sulfur = 1.8, and Silane = 40. However, keep in mind that several factor settings can have this same relative variance. The design point with Silica = 1.7, Sulfur = 2.8, and Silane = 60 also has relative prediction variance of 1.3958. To evaluate the prediction variance using a surface, see “Prediction Variance Surface”.

**Fraction of Design Space Plot**

The Fraction of Design Space Plot shows the proportion of the design space over which the relative prediction variance lies below a given value. It is desirable to have a large proportion of the design space with low prediction variance values. **Figure 15.20** shows the Fraction of Design Space plot for the Bounce Data.jmp sample data table, located in the Design Experiment folder.
Figure 15.20 Fraction of Design Space Plot

The X axis in the plot represents the proportion of the design space, ranging from 0 to 100%. The Y axis represents relative prediction variance values. For a point \((x, y)\) that falls on the blue curve, the value \(x\) is the proportion of design space with variance less than or equal to \(y\). Red dotted crosshairs mark the value that bounds the relative prediction variance for 50% of design space.

Figure 15.20 shows that the minimum relative prediction variance is slightly less than 0.3, while the maximum is below 1.4. (The actual maximum is 1.395833, as shown in Figure 15.19.) The red dotted crosshairs indicate that the relative prediction variance is less than 0.34 over about 50% of the design space. You can use the crosshairs tool to find the maximum relative prediction variance that corresponds to any Fraction of Space value. Use the crosshairs tool in Figure 15.20 to see that 90% of the prediction variance values are below approximately 0.55.

Note: Monte Carlo sampling of the design space is used in constructing the Fraction of Design Space Plot. Therefore, plots for the same design may vary slightly.

Prediction Variance Surface

The Prediction Variance Surface report plots the relative prediction variance surface as a function of any two design factors. Figure 15.21 shows the Prediction Variance Surface outline for the Bounce Data.jmp sample data table, located in the Design Experiment folder. Show or hide the controls by selecting Control Panel on the red triangle menu. See “Control Panel”.
Figure 15.21 Prediction Variance Surface

When there are two or more factors, the Prediction Variance Surface outline shows a plot of the relative prediction variance for any two variables. The Prediction Variance Surface outline plots the relative prediction variance formula. Drag on the plot to rotate and change the perspective.

Control Panel

The Control Panel contains options for adjusting the plot:

Response Grid Slider  The Grid check box superimposes a grid that shows constant values of Variance. The value of the Variance is shown in the text box. The slider enables you to adjust the placement of the grid. Alternatively, you can enter a Variance value in the text box. Click outside the box to update the plot.

Independent Variables  This panel enables you to select which two factors are used as axes for the plot and to specify the settings for factors not used as axes. Select a factor for each of the X and Y axes by clicking in the appropriate column. Use the sliders and text boxes to specify values for each factor not selected for an axis. The plot shows the three-dimensional slice of the surface at the specified values of the factors that are not used as axes in the plot. Move the sliders to see different slices.

Each grid check box activates a grid for the corresponding factor. Use the sliders to adjust the placement of each grid.

Lock Z Scale locks the z-axis to its current values. This is useful when moving the sliders that are not on an axis.

Appearance  The Resolution slider affects how many points are evaluated for a formula. Too coarse a resolution means that a function with a sharp change might not be represented
very well. But setting the resolution high can make evaluating and displaying the surface slower.

The **Orthographic projection** check box shows a projection of the plot in two dimensions.

The **Contour** menu controls the placement of contour curves. A contour curve is a set of points whose Response values are constant. You can select to turn the contours Off (the default) or place them contours Below, Above, or On Surface.

### Estimation Efficiency

This report gives the Fractional Increase in CI (Confidence Interval) Length and Relative Std (Standard) Error of Estimate for each parameter estimate in the model. Smaller is better for both of these values. Figure 15.22 shows the Estimation Efficiency outline for the Bounce Data.jmp sample data table, located in the Design Experiment folder.

**Figure 15.22** Estimation Efficiency Outline

<table>
<thead>
<tr>
<th>Term</th>
<th>Fractional Increase in CI Length</th>
<th>Relative Std of Estimate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intercept</td>
<td>1.236</td>
<td>0.577</td>
</tr>
<tr>
<td>Silica</td>
<td>0.369</td>
<td>0.354</td>
</tr>
<tr>
<td>Silane</td>
<td>0.369</td>
<td>0.354</td>
</tr>
<tr>
<td>Sulfur</td>
<td>0.369</td>
<td>0.354</td>
</tr>
<tr>
<td>Silica*Silane</td>
<td>0.936</td>
<td>0.5</td>
</tr>
<tr>
<td>Silica*Sulfur</td>
<td>0.936</td>
<td>0.5</td>
</tr>
<tr>
<td>Sulfur*Silane</td>
<td>0.936</td>
<td>0.5</td>
</tr>
<tr>
<td>Silica*Silica</td>
<td>1.016</td>
<td>0.52</td>
</tr>
<tr>
<td>Silane*Silane</td>
<td>1.016</td>
<td>0.52</td>
</tr>
<tr>
<td>Sulfur*Sulfur</td>
<td>1.016</td>
<td>0.52</td>
</tr>
</tbody>
</table>

### Fractional Increase in CI Length

The Fractional Increase in CI Length compares the length of a parameter’s confidence interval as given by the current design to the length of such an interval given an ideal design:

- The length of the ideal confidence interval for the parameter is subtracted from the length of its actual confidence interval.
- This difference is then divided by the length of the ideal confidence interval.

For an orthogonal D-optimal design, the fractional increase is zero. In selecting a design, you would like the fractional increase in confidence interval length to be as small as possible.
The Ideal Design

The covariance matrix for the ordinary least squares estimator is $\sigma^2(X'X)^{-1}$. The diagonal elements of $(X'X)^{-1}$ are the relative variances (the variances divided by $\sigma^2$) of the parameter estimates. For two-level designs and using the effects coding convention (see “Coding”), the minimum value of the relative variance for any parameter estimate is $1/n$, where $n$ is the number of runs. This occurs when all the effects for the design are orthogonal and the design is D-optimal.

Let $\hat{\beta}$ denote the vector of parameter estimates. The ideal design, which may not exist, is a design whose covariance matrix is given as follows:

$$\text{Var}(\hat{\beta}) = (\sigma^2 / n)I_n$$

where $I_n$ is the $n$ by $n$ identity matrix and $\sigma$ is the standard deviation of the response.

If an orthogonal D-optimal design exists, it is the ideal design. However, the definition above extends the idea of an ideal design to situations where a design that is both orthogonal and D-optimal does not exist.

The definition is also appropriate for designs with multi-level categorical factors. The orthogonal coding used for categorical factors allows such designs to have the ideal covariance matrix. For a Custom Design, you can view the coding matrix by selecting Save X Matrix from the options in the Custom Design window, making the design table, and looking at the script Model Matrix that is saved to the design table.

Fractional Increase in Length of Confidence Interval

Note that, in the ideal design, the standard error for the parameter estimates would be given as follows:

$$SE_{Ideal}(\hat{\beta}) = (\sigma / \sqrt{n})I_n$$

The length of a confidence interval is determined by the standard error. The Fractional Increase in Confidence Interval Length is the difference between the standard error of the given design and the standard error of the ideal design, divided by the standard error of the ideal design.

Specifically, for the $i$th parameter estimate, the Fractional Increase in Confidence Interval Length is defined as follows:

$$FI = \frac{\sqrt{n}(XX_{ii})^{-1} - (\sigma / \sqrt{n})}{(\sigma / \sqrt{n})} = \sqrt{n(XX_{ii})^{-1}} - 1$$
where

\[ \sigma^2 \text{ is the unknown response variance,} \]
\[ X \text{ is the model matrix for the given design, defined in "The Alias Matrix"}, \]
\[ (X'X)^{-1} \text{ is the } i^{th} \text{ diagonal entry of } (X'X)^{-1}, \text{ and} \]
\[ n \text{ is the number of runs.} \]

Relative Std Error of Estimate

The Relative Std Error of Estimate gives the ratio of the standard deviation of a parameter’s estimate to the error standard deviation. These values indicate how large the standard errors of the model’s parameter estimates are, relative to the error standard deviation. For the \( i^{th} \) parameter estimate, the Relative Std Error of Estimate is defined as follows:

\[ SE = \frac{1}{\sqrt{(X'X)^{-1}_{ii}}} \]

where

\[ X \text{ is the model matrix defined in "The Alias Matrix"}, \text{ and} \]
\[ (X'X)^{-1}_{ii} \text{ is the } i^{th} \text{ diagonal entry of } (X'X)^{-1}. \]

Alias Matrix

The Alias Matrix addresses the issue of how terms that are not included in the model affect the estimation of the model terms, if they are indeed active. In the Alias Terms outline, you list potentially active effects that are not in your assumed model but that might bias the estimates of model terms. The Alias Matrix entries represent the degree of bias imparted to model parameters by the Alias Terms effects. See “Alias Terms”.

The rows of the Alias Matrix are the terms corresponding to the model effects listed in the Model outline. The columns are terms corresponding to effects listed in the Alias Terms outline. The entry in a given row and column indicates the degree to which the alias term affects the parameter estimate corresponding to the model term.

In evaluating your design, you ideally want one of two situations to occur relative to any entry in the Alias Matrix. Either the entry is small or, if it is not small, the effect of the alias term is small so that the bias will be small. If you suspect that the alias term may have a substantial effect, then that term should be included in the model or you should consider an alias optimal design.

For more information about the computation of the Alias Matrix, see “The Alias Matrix”. See also Lekivetz, R. (2014).
Note the following:

- If the design is orthogonal for the assumed model, then the correlations in the Alias Matrix correspond to the absolute correlations in the Color Map on Correlations.
- Depending on the complexity of the design, it is possible to have alias matrix entries greater than 1 or less than -1.

**Alias Matrix Example**

Consider the Coffee Data.jmp sample data table, located in the Design Experiment folder. The design assumes a main effects model. You can see this by running the Model script in the data table. Consequently, in the Evaluate Design window’s Model outline, only the Intercept and five main effects appear. The Alias Terms outline contains the two-way interactions.

**Figure 15.23** Alias Matrix for Coffee Data.jmp

The Alias Matrix shows the Model terms in the first column defining the rows. The two-way interactions in the Alias Terms are listed across the top, defining the columns. Consider the model effect Temperature for example. If the Grind*Time interaction is the only active two-way interaction, the estimate for the coefficient of Temperature is biased by 0.333 times the true value of the Grind*Time effect. If other interactions are active, then the value in the Alias Matrix indicates the additional amount of bias incurred by the Temperature coefficient estimate.

**Color Map on Correlations**

The Color Map on Correlations shows the absolute value of the correlation between any two effects that appear in either the Model or the Alias Terms outline. The cells of the color map are identified above the map. There is a cell for each effect in the Model outline and a cell for each effect in the Alias Terms outline. Smaller values are desired.

By default, the absolute magnitudes of the correlations are represented by a white to gray to black intensity color theme. In general terms, the color map for a good design shows a lot of white off the diagonal, indicating orthogonality or small correlations between distinct terms. Large absolute correlations among effects inflate the standard errors of estimates.
To see the absolute value of the correlation between two effects, hover over the corresponding cell. To change the color scale, click the Color Map on Correlations red triangle and select **Blue to Gray to Red**. For a custom color scale, right-click in the plot and select **Color Theme**. To save a table of the correlations, right-click to the right of the plot below the legend and select **Table of Correlations**.

**Color Map Example**

**Figure 15.24** shows the Color Map on Correlations for the Bounce Data.jmp sample data table, found in the Design Experiment folder. The black coloring indicates absolute correlations of one. Note that there are black cells on the diagonal, showing correlations of model terms with themselves.

All other cells are either white or gray. The gray squares correspond to correlations between quadratic terms. To see this, hover over each of the gray squares. The absolute correlations of quadratic terms with each other are small, 0.0714.

From the perspective of correlation, this is a good design. When effects are highly correlated, it is more difficult to determine which is responsible for an effect on the response.

**Figure 15.24** Color Map on Correlations

**Tip:** To save a table of the correlations, right-click to the right of the plot below the legend and select **Table of Correlations**.
Design Diagnostics

The Design Diagnostics outline shows $D$-, $G$-, and $A$-efficiencies and the average variance of prediction. These diagnostics are not shown for designs that include factors with Changes set to Hard or Very Hard or effects with Estimability designated as If Possible.

When Design Diagnostics is accessed from a DOE platform other than Evaluate Design, the Design Creation Time gives the amount of time required to create the design. When Design Diagnostics is accessed from the Evaluate Design platform, Design Creation Time gives the amount of time required for the Evaluate Design platform to calculate results.

Figure 15.25 shows the Design Diagnostics outline for the Bounce Data.jmp sample data table, found in the Design Experiment folder.

Caution: The efficiency measures should not be interpreted on their own. But they can be used to compare designs. Given two designs, the one with the higher efficiency measure is better. While the maximum efficiency is 100 for any criterion, an efficiency of 100% is impossible for many design problems.

Notation

The descriptions of the efficiency measures given below use the following notation:

- $X$ is the model matrix
- $n$ is the number of runs in the design
- $p$ is the number of terms, including the intercept, in the model
- $Var(\hat{y}|x)$ is the relative prediction variance at the point $x$. See “Relative Prediction Variance”.
- $Var(\hat{y}|X)_{\text{max}}$ is the maximum relative prediction variance over the design region
D Efficiency

The efficiency of the design to that of an ideal orthogonal design in terms of the D-optimality criterion. A design is D-optimal if it minimizes the volume of the joint confidence region for the vector of regression coefficients:

\[
D\text{-efficiency} = 100 \left( \frac{1}{n} |X'X|^{1/p} \right)
\]

G Efficiency

The efficiency of the design to that of an ideal orthogonal design in terms of the G-optimality criterion. A design is G-optimal if it minimizes the maximum prediction variance over the design region:

\[
G\text{-efficiency} = 100p/(n \text{Var}(\hat{y}|\mathbf{x})_{\text{max}})
\]

Letting \(D\) denote the design region,

\[
\text{Var}(\hat{y}|\mathbf{x})_{\text{max}} = \text{maximum}[\mathbf{x}'(\mathbf{X}'\mathbf{X})^{-1}\mathbf{x}]_{\mathbf{x}\text{ in }D}
\]

**Note:** G-Efficiency is calculated using Monte Carlo sampling of the design space. Therefore, calculations for the same design may vary slightly.

A Efficiency

The efficiency of the design to that of an ideal orthogonal design in terms of the A-optimality criterion. A design is A-optimal if it minimizes the sum of the variances of the regression coefficients:

\[
A\text{-efficiency} = 100p/(n \text{Trace}(\mathbf{X}'\mathbf{X})^{-1})
\]

Average Variance of Prediction

At a point  \(\mathbf{x}\) in the design space, the relative prediction variance is defined as:

\[
\text{Var}(\hat{y}|\mathbf{x}) = \mathbf{x}'(\mathbf{X}'\mathbf{X})^{-1}\mathbf{x}
\]

where this is the prediction variance divided by the error variance. For more information about the calculation, see Section 4.3.5 in Goos and Jones (2011).
Evaluate Design Options

The Evaluate Design red triangle menu contains the following options:

**Advanced Options > Split Plot Variance Ratio**  Specify the ratio of the variance of the random whole plot and the subplot variance (if present) to the error variance. Before setting this value, you must define a hard-to-change factor for your split-plot design, or hard and very-hard-to-change factors for your split-split-plot design. Then you can enter one or two positive numbers for the variance ratios, depending on whether you have specified a split-plot or a split-split-plot design.

**Advanced Options > Set Delta for Power**  Specify a value for the difference you want to detect that is applied to Anticipated Coefficients in the Power Analysis report. The Anticipated Coefficient values are set to Delta/2 for continuous effects. For categorical effects, they are alternating values of Delta/2 and –Delta/2. For more information about power analysis, see “Power Analysis”.

By default, Delta is set to two. Consequently, the Anticipated Coefficient default values are 1 for continuous effects and alternating values of 1 and –1 for categorical effects. The default values that are entered as Anticipated Coefficients when Delta is 2 ensure these properties:

- The power calculation for a numeric effect assumes a change of Delta in the response mean due to linear main effects as the factor changes from the lowest setting to the highest setting in the design region.
- The power calculation for the parameter associated with a two-level categorical factor assumes a change of Delta in the response mean across the levels of the factor.
- The power calculation for a categorical effect with more than two levels is based on the multiple degree of freedom $F$ test for the null hypothesis that all levels have the same response mean. Power is calculated at the values of the response means that are determined by the Anticipated Coefficients. Various configurations of the Anticipated Coefficients can define a difference in levels as large as Delta. However, the power
values for such configurations will differ based on the Anticipated Coefficients for the other levels.

**Save Script to Script Window**  Creates a script that reproduces the Evaluate Design window and places it in an open script window.
The Compare Designs platform compares up to four designs to a reference design. Use to explore, evaluate, and compare design performance. Diagnostics show how the designs perform relative to each other and how they perform in an absolute sense. To compare designs relative to your specific needs, you can change the terms in the assumed model and in the alias terms list.

**Figure 16.1** Comparing Three Designs with Different Run Sizes
Contents

Overview of the Compare Designs Platform .......................................................... 473
Examples of Comparing Designs ......................................................................... 473
  Designs of Same Run Size ................................................................................. 473
  Designs of Different Run Sizes .......................................................................... 478
  Split Plot Designs with Different Numbers of Whole Plots .............................. 482
Launch the Compare Designs Platform ................................................................. 486
Compare Designs Window: Specify Model and Alias Terms. .............................. 488
  Reference Design ............................................................................................... 488
  Factors ............................................................................................................... 488
  Model .................................................................................................................. 488
  Alias Terms ....................................................................................................... 489
Compare Designs Window: Design Evaluation ...................................................... 489
  Power Analysis ................................................................................................. 490
  Prediction Variance Profile .............................................................................. 493
  Fraction of Design Space Plot ......................................................................... 495
  Relative Estimation Efficiency ......................................................................... 496
  Alias Matrix Summary ...................................................................................... 498
  Absolute Correlations ....................................................................................... 500
  Design Diagnostics ........................................................................................... 502
Compare Designs Options ..................................................................................... 504
Overview of the Compare Designs Platform

The Compare Designs platform, which is an extension of the Evaluate Design platform, enables you to easily compare up to four designs to a reference design. To compare the performance of one or two designs relative to another, you select a reference design that is treated as the base design. You can specify effects in the Model outline, and effects of interest in the Alias Terms outline.

The Design Evaluation report shows diagnostic results and plots covering these areas:
- Power analysis
- Prediction variance
- Fraction of design space
- Relative estimation efficiency
- Alias matrix diagnostics
- Correlations among effects (including confounding)
- Relative efficiency measures for the overall designs

Examples of Comparing Designs

- “Designs of Same Run Size”
- “Designs of Different Run Sizes”
- “Split Plot Designs with Different Numbers of Whole Plots”

Designs of Same Run Size

In this example, you compare two designs for six factors each with 13 runs. One is a 12-run Plackett-Burman (PB) design augmented with a single center point. The other is a Definitive Screening Design (DSD).

Comparison in Terms of Main Effects Only

First, compare the two designs assuming that the model to be estimated contains only the main effects.

1. Select Help > Sample Data, click Open the Sample Scripts Directory, and select Compare Same Run Size.jsl.
2. Right-click in the script window and select Run Script.
Two 13-run design tables are constructed: Definitive Screening Design and Plackett-Burman. You want to compare these two designs. Because the Plackett-Burman table is active, it is the reference design to which you compare the DSD.

3. In the Plackett-Burman data table, select **DOE > Design Diagnostics > Compare Designs**.
4. Select Definitive Screening Design from the **Compare ‘Plackett-Burman’ with** list.
5. Select X1 through X6 in the Plackett-Burman panel and in the Definitive Screening Design panel.
6. Open the Match Columns outline and click **Match**.

**Figure 16.2** Launch Window with Matched Columns

This defines the correspondence between the factors in your two designs.

7. Click **OK**.

The reference design is the Plackett-Burman design. In the Design Evaluation outline, comparison metrics compare the PB to the DSD. The designs are compared relative to power, prediction variance, estimation efficiency, aliasing, and design efficiency measures.
In terms of power, prediction variance, and estimation efficiency, the PB design outperforms the DSD. Figure 16.3 shows the Power Analysis report with the default settings for the significance level, Anticipated RMSE, and coefficients. For tests for the main effects, the PB design has higher power than does the DSD.
Figure 16.4  Fraction of Design Space Plot for PB and DSD Comparison

The Fraction of Design Space plot indicates that the PB design has smaller prediction variance than the DSD over the entire design space.

You conclude that, if you suspect that only main effects are active, the PB design is preferable.

Comparison in Terms of Two-Way Interactions

Now suppose you suspect that some two-way interactions might be active. The analysis below shows that if those two-way interactions are actually active, then the PB design might be less desirable than the DSD.

1. In the Absolute Correlations report, open the Color Map on Correlations report and the color map reports under it.

Figure 16.5  Color Maps for PB and DSD Comparison

The Color Map on Correlations plots show that the PB design aliases main effects with two-way interactions. In contrast, the DSD does not alias main effects with two-way interactions.
To gain more insight on how the designs compare if some two-way interactions are active, add two-way interactions in the Model outline.

2. In the Factors outline, select X1 through X3.
3. In the Model outline, select **Interactions > 2nd**.

**Figure 16.6** Power Analysis for PB and DSD Comparison with Interactions

The Term list shows the three two-way interactions. If these two-way interactions are active, then the DSD has better performance in terms of power across all effects than the PB.
The DSD also outperforms the PB design in terms of prediction variance with the three interactions in the model. You can explore the other reports to see that the DSD is preferred when there are potentially active interactions.

**Designs of Different Run Sizes**

In this example, compare three designs with run sizes 16, 20, and 24. The designs are constructed for main effect models. Use the Compare Designs platform to determine whether the potential benefits of using a larger run size are worth the additional cost in resources.

1. Select Help > Sample Data, click Open the Sample Scripts Directory, and select Compare Three Run Sizes.jsl.

2. Right-click in the script window and select Run Script.

Three design tables are constructed using Custom Design, with only main effects as entries in the Model outline:

- 16-Run Design
- 20-Run Design
- 24-Run Design

You want to compare these three designs. Notice that the 16-Run Design table is active.

3. In the 16-Run Design table, select DOE > Design Diagnostics > Compare Designs.

4. From the Compare ‘16-Run Design’ with list, select 20-Run Design and 24-Run Design.

Panels for each of these designs are added to the launch window. JMP automatically matches the columns in the order in which they appear in the three design tables.

5. Click OK.
All three designs have high power for detecting main effects if the coefficients are on the order of the Anticipated RMSE.
As expected, the 24-run design is superior to the other two designs in terms of prediction variance over the entire design space. The 20-run design is superior to the 16-run design.

6. In the Absolute Correlations report, open the Color Map on Correlations report and the three color map reports under it.

For the 16-run design, the Color Map on Correlations indicates that there is confounding of some main effects with some two-factor interactions, and confounding of two-factor interactions.

For the 20-run design, the Color Map on Correlations indicates that there are some large correlations between some main effects and some two-factor interactions, and between some two-factor interactions.

The 24-run design shows only moderate correlations between main effects and two-factor interactions, and between two-factor interactions.
**Figure 16.11  Absolute Correlations Comparison**

<table>
<thead>
<tr>
<th>Model x Model</th>
<th>Average Correlation</th>
<th>Number of Confoundings</th>
<th>Number of Pairs</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-Run Design</td>
<td>0.000</td>
<td>0</td>
<td>28</td>
</tr>
<tr>
<td>20-Run Design</td>
<td>0.000</td>
<td>0</td>
<td>28</td>
</tr>
<tr>
<td>24-Run Design</td>
<td>0.000</td>
<td>0</td>
<td>28</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Model x Alias</th>
<th>Average Correlation</th>
<th>Number of Confoundings</th>
<th>Number of Pairs</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-Run Design</td>
<td>0.094</td>
<td>21</td>
<td>224</td>
</tr>
<tr>
<td>20-Run Design</td>
<td>0.166</td>
<td>0</td>
<td>224</td>
</tr>
<tr>
<td>24-Run Design</td>
<td>0.098</td>
<td>0</td>
<td>224</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Alias x Alias</th>
<th>Average Correlation</th>
<th>Number of Confoundings</th>
<th>Number of Pairs</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-Run Design</td>
<td>0.056</td>
<td>21</td>
<td>378</td>
</tr>
<tr>
<td>20-Run Design</td>
<td>0.121</td>
<td>0</td>
<td>378</td>
</tr>
<tr>
<td>24-Run Design</td>
<td>0.085</td>
<td>0</td>
<td>378</td>
</tr>
</tbody>
</table>

The Absolute Correlations table summarizes the information shown in the Color Maps on Correlations. Recall that the model for all three designs consists of only main effects and the Alias Matrix contains two-factor interactions.

For the 16-run design, the Model x Alias portion of the table indicates that there are nine confoundings of main effects with two-factor interactions. The Alias x Alias portion indicates that six two-factor interactions are confounded.

**Figure 16.12  Design Diagnostics Comparison**

<table>
<thead>
<tr>
<th>Efficiency of 16-Run Design</th>
<th>Efficiency of 16-Run Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative to 20-Run Design</td>
<td>Relative to 24-Run Design</td>
</tr>
<tr>
<td>D-efficiency</td>
<td>0.800</td>
</tr>
<tr>
<td>G-efficiency</td>
<td>0.600</td>
</tr>
<tr>
<td>A-efficiency</td>
<td>0.800</td>
</tr>
<tr>
<td>H-efficiency</td>
<td>0.800</td>
</tr>
<tr>
<td>Additional Run Size</td>
<td>-4</td>
</tr>
</tbody>
</table>

The Design Diagnostics report compares the efficiency of the 16-run design to both the 20-run and 24-run designs in terms of several efficiency measures. Relative efficiency values that exceed 1 indicate that the reference design is preferable for the given measure. Values less than 1 indicate that the design being compared to the reference design is preferable. The 16-run design has lower efficiency than the other two designs across all metrics, indicating that the larger designs are preferable.
Split Plot Designs with Different Numbers of Whole Plots

In this example, compare two split-plot designs with different numbers of whole plots. The designs are for three factors:

- A continuous hard-to-change factor
- A continuous easy-to-change factor
- A three-level categorical easy-to-change factor

The designs include all two-factor interactions in the assumed model. You can afford 20 runs and want to compare using 4 or 8 whole plots.

Launch Compare Designs

1. Select Help > Sample Data, click Open the Sample Scripts Directory, and select Compare Split Plots.jsl.
2. Right-click in the script window and select Run Script.
   Two design tables are constructed using Custom Design:
   - 4 Whole Plots
   - 8 Whole Plots
   You want to compare these two designs. Notice that the 4 Whole Plots table is active.
3. In the 4 Whole Plots table, select DOE > Design Diagnostics > Compare Designs.
4. From the Compare ‘4 Whole Plots’ with list, select 8 Whole Plots.
   A panel for this design is added to the launch window. JMP automatically matches the columns in the order in which they appear in the two design tables.

Figure 16.13 Completed Launch Window
5. Click **OK**.
6. Open the **Matching Specification** outline under Reference Design: 20 run ‘4 Whole Plots’.

**Figure 16.14** Matching Specification for Split-Plot Designs

Notice that the Whole Plots column is entered as part of the design. This is necessary because Compare Designs needs to know the whole plot structure.

**Examine the Report**

The Design Evaluation report provides various diagnostics that compare the two designs.
The Power Analysis report shows that the power for the whole-plot factor, \( X_1 \), is much smaller for the four whole-plot design (0.19) than for the eight whole-plot design (0.497). However, the four whole-plot design has higher power to detect split-plot effects, especially the interaction of the two split-plot factors, \( X_2 \times X_3 \) (0.797 compared to 0.523). Notice that the power for the combined effect \( X_2 \times X_3 \) is given under the color bar and legend.
The Relative Estimation Efficiency report shows the relative estimation efficiency for $X_1$ to be 0.778. This indicates that the standard error for $X_1$ is notably larger for the four whole-plot design than for the eight whole-plot design.

Open the Relative Std Error of Estimates report. You can see that the relative standard error for $X_1$ in the four whole-plot design is 0.553, compared to the eight whole-plot error of 0.43.

In the Relative Estimation Efficiency report, the relative estimation efficiency for $X_2 \times X_3^2$ is 1.449, indicating that the standard error for the parameter associated with $X_2 \times X_3^2$ is notably larger for the eight whole-plot design than for the four whole-plot design.

The Power Analysis and the Relative Estimation Efficiency reports indicate that the choice of designs revolves around the importance of detecting the whole plot effect $X_1$. The eight whole-plots design gives you a better chance of detecting a whole plot effect. The four whole-plots design is somewhat better for detecting split-plot effects involving the categorical variable.
Launch the Compare Designs Platform

Launch the Compare Designs platform by selecting **DOE > Design Diagnostics > Compare Designs**. All open data tables appear in the list at the left. The active data table and its columns appear in a Source Columns panel. The design in the initial Source Columns panel is the *reference design*, namely, the design to which other designs are compared. When you add designs to compare to the reference design, their columns appear in panels under the reference design panel.

**Figure 16.17** shows the launch window for the three designs in “Designs of Different Run Sizes”.

**Figure 16.17** Compare Designs Launch Window

Design Table Selection

Select up to four design tables from the list on the left.

- To compare multiple designs to the reference design, you must select their design tables simultaneously from the list on the left.
- To replace a design (or designs) in the Source Columns list, select the desired table (or tables) from the list at the left. The design table (or tables) under the reference design table are replaced.

**Note:** The reference design table can be compared to itself, which can be useful when exploring the assignment of design columns to factors.
**Match Columns**

Specify which columns in each of the design tables correspond to each other in the Match Columns panel. To match columns, select the columns to match in each of the design table Source Columns lists, and then click Match.

**Figure 16.18 Selection of Columns for Matching**

- To match single columns in each list, select the single column in each list, and then click Match.
- To match several columns that appear in the correct matching order in each list, select them in each list. Click the Match button. They are matched in their list order (Figure 16.18). In this example, Feed Rate is matched with X1, and Catalyst is matched with X3.
- If the lists contain the same numbers of columns and your desired match order is their order of appearance in the lists, you do not have to click Match. When you click OK to run the launch window, JMP matches the columns automatically in their order of appearance. You can review the matching in the report’s Matching Specification outline.
Compare Designs Window: Specify Model and Alias Terms

The Compare Designs window consists of two sets of outlines:

- Specify which effects are in the model and which effects are potentially active using the Factors, Model, and Alias Terms outlines.
- Compare the designs using the diagnostics in the Design Evaluation outlines. Changes that you make in the Model and Alias Terms outlines are updated in the Design Evaluation report.

The Compare Designs report uses the column names from the reference design.


Reference Design

The name of the window for the reference design appears in the outline title. The Matching Specification outline lists the specifications that you entered in the launch window.

Factors

Use the Factors outline to add effects to the Model and Alias Terms lists.

The Factors outline lists the factors, using the column names from the reference design, and coded values. Because they are not factors, whole plot and subplot columns do not appear in the Factors outline. However, they are required for the analysis.

Model

Add or remove effects to compare your designs for the effects that you believe should be in the model. The Model outline initially lists effects that are in the Model script of the reference design table and that are estimated by all designs being compared. If there is no Model script in the reference design table, the Model outline shows only the main effects that can be estimated by all designs being compared. For more information about how to add and remove effects, see “Model”.
Note: If any of the designs are supersaturated, meaning that the number of parameters to be estimated exceeds the number of runs, the Model outline lists only a set of effects that can be estimated.

Alias Terms

Add or remove effects to compare your designs for effects that might be active. The Alias Terms outline initially contains all two-factor interactions that are not in the Model outline. The effects in this outline impact the calculations in the Alias Matrix Summary and Absolute Correlations outline. See “Alias Matrix Summary” and “Absolute Correlations”.

For more information about how to add and remove effects, see “Alias Terms”.

Compare Designs Window: Design Evaluation

- “Power Analysis”
- “Prediction Variance Profile”
- “Fraction of Design Space Plot”
- “Relative Estimation Efficiency”
- “Alias Matrix Summary”
- “Absolute Correlations”
- “Design Diagnostics”

Color Dashboard

Several of the Design Evaluation outlines show values colored according to a color bar. The colors are applied to diagnostic measures and they help you see which values (and designs) reflect good or bad behavior. You can edit the legend values to apply colors that reflect your definitions of good and bad behavior.

Figure 16.19 Color Dashboard

You can modify the color bar by selecting these two options in the red triangle menu for the outline or by right-clicking the color bar:

Show Legend Values  Shows or hides the values that appear under the color bar.

Edit Legend Values  Specify the values that define the colors.
Power Analysis

Power is the probability of detecting an active effect of a given size. The Power Analysis report helps you evaluate and compare the ability of your designs to detect effects of practical importance. For each of your designs, the Power Analysis report calculates the power of tests for the effects in the Model outline.

The Power Analysis report gives the power of tests for individual model parameters and for whole effects. It also provides a Power Plot and a Power versus Sample Size plot.

Power depends on the number of runs, the significance level, and the estimated error variation. For more information about how power is calculated, see “Power Calculations”.

Figure 16.20 Power Analysis Outline for Three Designs

Figure 16.20 shows the Power Analysis outline for the three designs constructed in “Designs of Different Run Sizes”. Two two-way interactions have been added to the Model outline.

Power Analysis Report

When you specify values for the Significance Level and Anticipated RMSE, they are used to calculate the power of the tests for the model parameters. Enter coefficient values that reflect differences that you want to detect as Anticipated Coefficients. To update the results for all designs, click Apply Changes to Anticipated Coefficients.

Significance Level The probability of rejecting the hypothesis of no effect, if it is true. The power calculations update immediately when you enter a value.

Anticipated RMSE An estimate of the square root of the error variation. The power calculations update immediately when you enter a value.
The power values are colored according to a color gradient that appears under the Apply Changes to Anticipated Coefficients button. You can control the color legend using the options in the Power Analysis red triangle menu. See “Color Dashboard”.

For more information about the Power Plots, see “Power Plot”.

**Note:** If the design is supersaturated, meaning that the number of parameters to be estimated exceeds the number of runs, the Power Analysis outline lists only a set of effects that can be estimated.

**Tests for Individual Parameters**

The Term column contains a list of model terms. For each term, the Anticipated Coefficient column contains a value for that term. The Power value is the power of a test that the coefficient for the term is zero if the true value of the coefficient is given by the Anticipated Coefficient, given the design, and the terms in the Model outline.

**Term**  The model term associated with the coefficient being tested.

**Anticipated Coefficient**  A value for the coefficient associated with the model term. This value is used in the calculations for Power. When you set a new value in the Anticipated Coefficient column, click **Apply Changes to Anticipated Coefficients** to update the Power calculations.

**Note:** The anticipated coefficients have default values of 1 for continuous effects. They have alternating values of 1 and –1 for categorical effects.

**Power**  The probability of rejecting the null hypothesis of no effect when the true coefficient value is given by the specified Anticipated Coefficient.

- For a coefficient associated with a numeric factor, the change in the mean response from the high to low setting (based on the model) is twice the coefficient value.
- For a coefficient associated with a categorical factor, the change in the mean response (based on the model) across the levels of the factor equals twice the absolute value of the anticipated coefficient. For more information on power for categorical factors, see “Tests for Categorical Effects with More Than Two Levels”

Calculations use the specified Significance Level and Anticipated RMSE. For more information about the power calculation, see “Power for a Single Parameter”.

**Apply Changes to Anticipated Coefficients**  When you set a new value in the Anticipated Coefficient column, click **Apply Changes to Anticipated Coefficients** to update the Power values.
Tests for Categorical Effects with More Than Two Levels

If your model contains a categorical effect with more than two levels, then the following columns appear below the Apply Changes to Anticipated Coefficients button:

**Effect**  
The categorical effect.

**Power**  
The power calculation for a test of no effect. The null hypothesis for the test is that all model parameters corresponding to the effect are zero. The difference to be detected is defined by the values in the Anticipated Coefficient column that correspond to the model terms for the effect. The power calculation reflects the differences in response means determined by the anticipated coefficients.

Calculations use the specified Significance Level and Anticipated RMSE. For more information about the power calculation, see “Power for a Categorical Effect”.

**Power Plot**

The Power Plot shows the power values from the Power Analysis in graphical form. The plot shows the power for each effect and for each design in a side-by-side bar chart.

Figure 16.21  Power Plot for Three Designs

The Power Plot in Figure 16.21 is for the main effects of the three designs constructed in “Designs of Different Run Sizes”.

Power versus Sample Size

The Power versus Sample Size plots appears only when the designs that you are comparing differ in run size. The plots enables you to see how sample size affects power for each effect in the model. It conveys the same information as is in the Power Plots graph, but in a different format. The power values at integer sample sizes are connected with line segments.

Figure 16.22  Power versus Sample Size Profiler for Three Designs

Prediction Variance Profile

The Prediction Variance Profile outline shows profilers of the relative variance of prediction for each design being compared. Each plot shows the relative variance of prediction as a function of each factor at fixed values of the other factors.

To find the maximum value of the relative prediction variance over the design space for the reference design, select the Maximize Variance option from the red triangle next to Prediction Variance Profile. See “Maximize Variance”.

Figure 16.23  Prediction Variance Profile for Three Designs
The Prediction Variance Profile plot in Figure 16.23 is for the three designs constructed in “Designs of Different Run Sizes”. Two two-way interactions, $X_1X_3$ and $X_2X_3$, have been added to the Model outline. The initial value for each continuous factor in the plot is the midpoint of its design settings. The Variance values to the left indicate that, as the number of runs increases, the variance decreases at the center point.

**Relative Prediction Variance**

For given settings of the factors, the prediction variance is the product of the error variance and a quantity that depends on the design and the factor settings. Before you run your experiment, the error variance is unknown, so the prediction variance is also unknown. However, the ratio of the prediction variance to the error variance is not a function of the error variance. This ratio, called the *relative prediction variance*, depends only on the design and the factor settings. Consequently, the relative variance of prediction can be calculated before acquiring the data. See “Relative Prediction Variance”.

After you run your experiment and fit a least squares model, you can estimate the error variance using the mean squared error (MSE) of the model fit. You can estimate the actual variance of prediction at any setting by multiplying the relative variance of prediction at that setting.

Ideally, the prediction variance is small throughout the design space. Generally, the error variance drops as the sample size increases. In comparing designs, a design with lower prediction variance on average is preferable.

**Maximize Variance**

You can also evaluate a design or compare designs in terms of the maximum relative prediction variance. Select the *Maximize Variance* option from the red triangle next to Prediction Variance Profile. JMP uses a desirability function that maximizes the relative prediction variance. The value of the Variance in the Prediction Variance Profile is the worst (least desirable from a design point of view) value of the relative prediction variance.
Figure 16.24 Prediction Variance Profile Showing Maximum Variance for Three Designs

Figure 16.24 shows the Prediction Variance Profile after Maximize Variance was selected for the three designs constructed in “Designs of Different Run Sizes”. As expected, the maximum relative prediction variance decreases as the run size increases. The plot also shows values of the factors that give this worst-case relative variance. However, keep in mind that many settings can lead to this same maximum relative variance.

Fraction of Design Space Plot

The Fraction of Design Space Plot shows the proportion of the design space over which the relative prediction variance lies below a given value.

Figure 16.25 Fraction of Design Space Plot for Three Designs
Figure 16.25 shows the Fraction of Design Space plot for the three designs constructed in “Designs of Different Run Sizes”. Note the following:

- The X axis in the plot represents the proportion of the design space, ranging from 0 to 100%.
- The Y axis represents relative prediction variance values.
- For a point \((x, y)\) that falls on a given curve, the value \(x\) is the proportion of design space with variance less than or equal to \(y\).
- Red dotted crosshairs mark the value that bounds the relative prediction variance for 50% of design space for the reference design.

Figure 16.25 shows that the relative prediction variance for the 24-run design is uniformly smaller than for the other two designs. The 20-run design has uniformly smaller prediction variance than the 16-run design. The red dotted crosshairs indicate that the relative prediction variance for the 20-run design is less than about 0.23 over about 50% of the design space.

You can use the crosshairs tool to find the maximum relative prediction variance that corresponds to any Fraction of Space value. For example, use the crosshairs tool to see that for the 24-run design, 90% of the prediction variance values are below approximately 0.20.

Note: Plots for the same design might vary slightly, since Monte Carlo sampling of the design space is used in constructing the Fraction of Design Space Plot.

Relative Estimation Efficiency

The Relative Estimation Efficiency report compares designs in terms of the standard errors of parameter estimates for parameters in the assumed model. The standard errors control the length of confidence intervals for the parameter estimates. This report provides an efficiency ratio and the relative standard errors.

The relative estimation efficiency values are colored according to a color gradient shown under the table of relative estimation efficiency values. You can control the color legend using the options in the Relative Estimation Efficiency red triangle menu. See “Color Dashboard”.
Figure 16.26 shows the Relative Estimation Efficiency outline for the split-plot designs compared in “Split Plot Designs with Different Numbers of Whole Plots”.

Relative Estimation Efficiency

For a given term, the estimation efficiency of the reference design relative to a comparison design is the relative standard error of the term for the comparison design divided by the relative standard error of the term for the reference design. A value less than one indicates that the reference design is not as efficient as the comparison design. A value greater than one indicates that it is more efficient.

Relative Standard Error of Estimates

The Relative Std Error of Estimates report gives the ratio of the standard deviation of a parameter’s estimate to the error standard deviation. These values indicate how large the standard errors of the model’s parameter estimates are, relative to the error standard deviation. For the $i^{th}$ parameter estimate, the Relative Std Error of Estimate is defined as follows:

$$SE = \sqrt{(XX)^{-1}_{ii}}$$

where:

- $X$ is the model matrix defined in “The Alias Matrix”, and
\[(X'X)_{ii}^{-1}\] is the \(i^{th}\) diagonal entry of \((X'X)^{-1}\).

**Alias Matrix Summary**

The alias matrix addresses the issue of how terms that are not included in the model affect the estimation of the model terms, if they are indeed active. In the Alias Terms outline, you list potentially active effects that are not in your assumed model but that might bias the estimates of model terms. The alias matrix entries represent the degree of bias imparted to model parameters by the Alias Terms effects. See “Alias Terms” and “Alias Matrix”.

The Alias Matrix Summary table lists the terms in the assumed model. These are the terms that correspond to effects listed in the Model outline. Given a design, for each entry in the Term column, the square root of the sum of the squared alias matrix entries for the terms corresponding to effects in the Alias Terms outline is computed. This value is reported in the Root Mean Squared Values column for the given design. For an example, see “Example of Calculation of Alias Matrix Summary Values”.

**Note:** The Alias Matrix Summary report appears only if there are effects in the Alias Terms list.

**Figure 16.27** Alias Matrix Summary for Two Designs

![Alias Matrix Summary](image)

**Figure 16.27** shows the Alias Matrix Summary report for the Plackett-Burman and Definitive Screening designs constructed in “Designs of Same Run Size”, with only main effects in the Model outline. All two-factor interactions are in the Alias Terms list. The table shows that, for the Definitive Screening Design, main effects are uncorrelated with two-factor interactions.

The Root Mean Squares Values are colored according to a color gradient shown under the Alias Matrix Summary table. You can control the color legend using the options in the Alias Matrix Summary red triangle menu. See “Color Dashboard”.
**Alias Matrix**

The rows of the Alias Matrix are the terms corresponding to the model effects listed in the Model outline. The columns are terms corresponding to effects listed in the Alias Terms outline. The entry in a given row and column indicates the degree to which the alias term affects the parameter estimate corresponding to the model term.

In evaluating your design, you ideally want one of two situations to occur relative to any entry in the Alias Matrix. Either the entry is small or, if it is not small, the effect of the alias term is small so that the bias is small. If you suspect that the alias term might have a substantial effect, then that term should be included in the model or you should consider an alias-optimal design. In fact, alias-optimality is driven by the squared values of the alias matrix.

For additional background on the Alias Matrix, see “The Alias Matrix”. See also Lekivetz, R. (2014).

**Example of Calculation of Alias Matrix Summary Values**

This example illustrates the calculation of the values that appear in the Alias Matrix Summary outline. In this example, you compare the two designs assuming that only main effects are active.

1. Select Help > Sample Data, click Open the Sample Scripts Directory, and select Compare Same Run Size.jsl.
2. Right-click in the script window and select Run Script.
   
   Two 13-run design tables are constructed:
   
   – Definitive Screening Design
   – Plackett-Burman
   
   You are interested only in the Plackett-Burman design. This is the active table.
3. From the Plackett-Burman table, select DOE > Design Diagnostics > Evaluate Design.
4. Select X1 through X6 and click X, Factor.
5. Click OK.
6. Open the Alias Terms outline to confirm that all two-factor interactions are in the Alias Terms list.
7. Open the Alias Matrix outline.

   For each model term listed in the Effect column, the entry in that row for a given column indicates the degree to which the alias term affects the parameter estimate corresponding to the model term.

For example, to obtain the Alias Matrix Summary entry in Figure 16.27 corresponding to X1, square the terms in the row for X1 in the Alias Matrix, average these, and take the square root. You obtain 0.2722.
Absolute Correlations

The Absolute Correlations report summarizes information about correlations between model terms and alias terms.

Figure 16.28 Absolute Correlations Report for Three Designs

Figure 16.28 shows the Absolute Correlations report for the three designs constructed in “Designs of Different Run Sizes”, with only main effects in the Model outline.

Absolute Correlations Table

The table in the Absolute Correlations report is divided into three sections:

- Model x Model considers correlations between terms corresponding to effects in the Model list.
- Model x Alias considers correlations between terms corresponding to effects in the Model list and terms corresponding to effects in the Alias list.
• Alias x Alias considers correlations between terms corresponding to effects in the Alias list.

**Note:** If there are no alias terms, only the Model x Model section appears.

For each section of the report, the following are given:

**Average Correlation**   The average of the correlations for all pairs of terms considered in this section of the report.

**Number of Confoundings**   The number of pairs of terms consisting of confounded terms.

**Number of Terms**   The total number of pairs of terms considered in this section of the report.

The values in the Absolute Correlations table are colored according to a color gradient shown under the table. You can control the color legend using the options in the Absolute Correlations red triangle menu. See “Color Dashboard”.

### Color Map on Correlations

The Color Map on Correlations outline shows plots for each of the designs. The cells of the color map are identified above the map. There are cells for all terms that correspond to effects that appear in either the Model outline or the Alias Terms outline. Each cell is colored according to the absolute value of the correlation between the two terms.

By default, the absolute magnitudes of the correlations are represented by a white to gray to black intensity color theme. In general terms, the color map for a good design shows a lot of white off the diagonal, indicating orthogonality or small correlations between distinct terms. Large absolute correlations among effects inflate the standard errors of estimates.

To see the absolute value of the correlation between two effects, hover over the corresponding cell. To change the color scale, click the Color Map on Correlations red triangle and select **Blue to Gray to Red**. For a custom color scale, right-click in the plot and select **Color Theme**. To save a table of the correlations, right-click to the right of the plot below the legend and select **Table of Correlations**.

### Absolute Correlations and Color Map on Correlations Example

**Figure 16.28** shows the Absolute Correlations report for the Plackett-Burman and Definitive Screening designs constructed in “Designs of Different Run Sizes”. The Model outline contains only main effects, so the Alias Terms outline contains all two-factor interactions. All main effects and two-way interactions are shown in the color maps.
In the Color Map on Correlations for the 16-run design, the black cells off the main diagonal indicate that the corresponding terms have correlation one and therefore are completely confounded. There are nine instances where model terms (main effects) are confounded with alias terms (two factor interactions), and six instances where alias terms are confounded with each other. This is shown in the report under Pairwise Confoundings.

The color maps for the 20- and 24-run designs have no off-diagonal cells that are solid black. It follows that these designs show no instances of confounding between any pair of main or two-way interaction effects. However, it is interesting to note that the 20- and 24-run designs both have a higher Average Correlation for Model x Alias terms than does the 16-run design. Although the 16-run design shows confounding, the average amount of correlation is less than for the 20- and 24-run designs.

**Design Diagnostics**

The Design Diagnostics outline shows $D$-, $G$-, $A$-, and $I$-efficiencies for the reference design relative to the comparison designs. It also shows the Additional Run Size. Given two designs, the one with the higher relative efficiency measure is better.

**Figure 16.29** Design Diagnostics for Three Designs

![Design Diagnostics](image)

Figure 16.29 shows the Design Diagnostics report for the three designs constructed in “Designs of Different Run Sizes”, with only main effects in the Model outline.

The values in the Design Diagnostics table are colored according to a color gradient shown under the table. You can control the color legend using the options in the Design Diagnostics red triangle menu. See “Color Dashboard”.

**Efficiency and Additional Run Size**

Relative efficiencies for each of $D$-, $G$-, $A$-, and $I$-efficiency are shown in the Design Diagnostics report. These are obtained by computing each design’s efficiency value and then taking the appropriate ratio. The descriptions of the relative efficiency measures are given in “Relative Efficiency Measures”.
Additional Run Size is the number of runs in the reference design minus the number of runs in the comparison design. If your reference design has more runs than your comparison design, then the Additional Run Size tells you how many additional runs you need to achieve the efficiency of the reference design.

Relative Efficiency Measures

Notation

- $X$ is the model matrix
- $p$ is the number of terms, including the intercept, in the model
- $\text{Var}(\hat{y}|x)$ is the relative prediction variance at the point $x$. See “Relative Prediction Variance”.

Relative Efficiencies

The relative efficiency of the reference design ($\text{Ref}$) to the comparison design ($\text{Comp}$) is given by the following expressions:

**D Efficiency**  
$\frac{\text{Eff}_{\text{Ref}}}{\text{Eff}_{\text{Comp}}}$ where Eff for each design is given as follows:

$Eff = |X'X|^{1/p}$

**G Efficiency**  
$\frac{\text{Eff}_{\text{Comp}}}{\text{Eff}_{\text{Ref}}}$ where Eff for each design is given as follows:

$Eff = \text{Var}(\hat{y}|x)_{\text{max}} = \text{maximum}[x'(X'X)^{-1}x]$  

$\text{max}_{x \in D}[x'(X'X)^{-1}x]$

Here, D denotes the design region.

**Note:** G-Efficiency is calculated using Monte Carlo sampling of the design space. The reported value is based on the larger of $\text{Var}(\hat{y}|x)_{\text{max}}$ or the prediction variance from the Monte Carlo sampling. Therefore, calculations for the same design might vary slightly.

**A Efficiency**  
$\frac{\text{Eff}_{\text{Comp}}}{\text{Eff}_{\text{Ref}}}$ where Eff for each design is given as follows:

$Eff = \text{Trace}[(X'X)^{-1}]$

**I Efficiency**  
$\frac{\text{Eff}_{\text{Comp}}}{\text{Eff}_{\text{Ref}}}$ where Eff for each design is given as follows:
Compare Designs Options

Advanced Options > Split Plot Variance Ratio  Specify the ratio of the variance of the random whole plot and the subplot variance (if present) to the error variance. Before setting this value, you must define a hard-to-change factor for your split-plot design, or hard and very-hard-to-change factors for your split-split-plot design. Then you can enter one or two positive numbers for the variance ratios, depending on whether you have specified a split-plot or a split-split-plot design.

\[ Eff = \frac{\int x'(X'X)^{-1} x \, dx}{\int dx} \]

For more information about the calculation, see Section 4.3.5 in Goos and Jones (2011).
Use the Sample Size and Power platform to investigate the impact of sample size on your ability to answer specific questions when planning experiments or studies.

- How many units should I test?
- Will I be able to detect a difference in my treatment means?
- How many units must I test to estimate failure time?

The Sample Size and Power platform is a collection of calculators. The calculators have fields for data entry and calculated values. You can select values to specify and those to calculate. For example, you might specify power and the effect size that you want to detect and then calculate the necessary sample size. Alternatively, you might specify a sample size and power to calculate the effect size that you can detect.

Sample size calculations for hypothesis tests are based on the trade off between Type I and Type II errors. The Type I error, or $\alpha$, is the probability of rejecting the null hypothesis when it is true. The Type II error, or $\beta$, is the probability of not rejecting the null hypothesis when it is false. Generally you would like $\alpha$ and $\beta$ to be small. Power, or $1 - \beta$, is the probability of rejecting the null hypothesis when it is false.

For more information about power and sample size in JMP, see Barker (2011).

**Figure 17.1** Power Animation for One Sample Mean
Example of the Reliability Demonstration Calculator ........................................542
Reliability Demonstration Calculator Fields .................................................544
Statistical Details for the Reliability Demonstration Calculator .......................545
Launch the Sample Size and Power Platform

The Sample Size and Power platform is a collection of calculators for planning experiments or studies. Launch the Sample Size and Power platform by selecting **DOE > Design Diagnostics > Sample Size and Power.**

**Figure 17.2** Sample Size and Power Launch Window

Choose from the following calculators:

- “One Sample Mean Calculator”
- “Two Sample Means Calculator”
- “k Sample Means Calculator”
- “One Sample Standard Deviation Calculator”
- “One Sample Proportion Calculator”
- “Two Sample Proportions Calculator”
- “Counts per Unit Calculator”
- “Sigma Quality Level Calculator”
- “Reliability Test Plan Calculator”
- “Reliability Demonstration Calculator”
One Sample Mean Calculator

Use the One Sample Mean calculator to evaluate sample size for a hypothesis test about one mean. Study the trade offs between sample size, power, significance, and the hypothesized difference to detect. Sample size and power are associated with the following hypothesis test:

\[ H_0: \mu = \mu_0 \]

versus the two-sided alternative:

\[ H_a: \mu \neq \mu_0 \]

where \( \mu \) is the true mean and \( \mu_0 \) is the null mean or reference value. The difference to detect is an amount, \( \delta \), away from \( \mu_0 \) that one considers as important to detect based on a set of samples. For the same significance level and power, a larger sample size is needed to detect a small difference than to detect a large difference. It is assumed that the population of interest is normally distributed with mean \( \mu \) and standard deviation \( \sigma \).

**Figure 17.3** Initial Sample Size and Power Calculator for One Mean
Examples of the One Sample Mean Calculator

In the following examples, suppose you are interested in demonstrating that the flammability of a new fabric being developed by your company has improved performance over current materials. Previous testing indicates that the standard deviation for time to burn of this fabric is 2 seconds.

Example of Sample Size Calculation

In this initial example, you would like to design an experiment that has 90% power to detect a difference of 1.5 seconds at a significance level of $\alpha = 0.05$. Use the One Sample Mean calculator to calculate the number of fabric samples you need to test.

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click the **One Sample Mean** button.
3. Leave **Alpha** set to 0.05.
4. Enter 2 for **Std Dev**.
5. Leave **Extra Parameters** set to 0.
6. Enter 1.5 for **Difference to detect**.
7. Leave **Sample Size** blank.
8. Enter 0.9 for **Power**.
9. Click **Continue**.

![One-Sample Mean Calculator](image)

At a significance level of 0.05, 21 fabric samples are needed to have a 90% chance of detecting a significant difference of 1.5 seconds in the burn time.
Example of Power versus Sample Size Plot

To explore trade offs between sample size and power in your fabric experiment, use the plot of power versus sample size.

2. Click One Sample Mean.
3. Leave Alpha set to 0.05.
4. Enter 2 for Std Dev.
5. Leave Extra Parameters set to 0.
6. Enter 1.5 for the Difference to detect.
7. Leave Sample Size blank.
8. Leave Power blank.
9. Click Continue to launch the power by sample size plot.

Figure 17.5 Power by Sample Size

The plot shows a range of sample sizes for which the power varies from about 0.1 to about 0.95. You could reduce the number of tests in your experiment to about 15 and maintain power above 75%. However, if you ran only 10 tests, the power to detect a significant difference of 1.5 would drop to about 50%.

Tip: Use the crosshair tool to obtain sample size and power combinations from the plot.
Example of Power versus Difference Plot

To explore trade offs between power and the magnitude of the difference that you can detect with 21 observations in your fabric experiment, use the plot of power versus difference.

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **One Sample Mean**.
3. Leave **Alpha** set to 0.05.
4. Enter 2 for **Std Dev**.
5. Leave **Extra Parameters** set to 0.
6. Leave **Difference to detect** blank.
7. Enter 21 for **Sample Size**.
8. Leave **Power** blank.
9. Click **Continue**.

**Figure 17.6** Plot of Power by Difference to Detect for a Sample Size of 21

At a significance level of 0.05 and 21 observations, you can detect a difference of 1.5 seconds with 90% power. If the difference is only one second smaller, then with 21 fabric samples, you have about 50% power of detecting the difference.

Example of an Animation Script

Use an animation script to explore how changing the sample size affects power.

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **One Sample Mean**.
3. Leave **Alpha** set to 0.05.

**Tip:** You can change the Alpha level after the animation is launched by clicking the Alpha value in the animation window.

4. Enter 2 for **Std Dev**.
5. Leave **Extra Parameters** set to 0.
6. Enter 1.5 as **Difference to detect**.
7. Leave **Sample Size** blank.

**Tip:** When you leave the sample size blank, the default sample size is set to 20. You will see the default of 20 after the animation script is launched. You can change the sample size before or after the animation is launched. To change it after the animation is launched, click the Sample Size value in the animation window.

8. Leave **Power** blank.
9. Click **Animation Script**.

**Figure 17.7** Initial Animation Script to Illustrate Power

The initial animation plot shows two $t$-density curves:

- The red curve shows the $t$-distribution when the true mean is zero.
- The blue curve shows the $t$-distribution when the true mean is 1.5, which is the difference to be detected.
— The blue shading indicates the probability of committing a type II error. A type II error is the probability of not detecting a difference when there is a difference. The probability of a type II error is often denoted by $\beta$.

— The red shading indicates the probability of committing a type I error. A type I error is the probability of concluding that the difference in means is significant when there is no difference. The probability of a type I error is often denoted by $\alpha$.

Select and drag the square handles to see the changes in statistics based on the positions of the curves. To change the values of Sample Size and Alpha, click their values beneath the plot.

By default, the animation shows a two sided test. Use the **Two Sided, Low Side, and High Side** buttons to toggle between not equal, less than, or greater than alternative hypotheses.

### One Sample Mean Calculator Fields

Specify the following quantities:

**Alpha**  The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Tip:** For a one-sided test, use $\alpha = \alpha \cdot 2$. For a one sided test with $\alpha = 0.05$, use the two-sided calculator with $\alpha = 0.10$. The resulting values are those needed for a one-sided test with $\alpha = 0.05$.

**Std Dev**  The assumed standard deviation. An estimate of the error standard deviation could be the root mean square error (RMSE) from a previous model fit.

**Tip:** Use a standard deviation of 1 to estimate the sample size needed to detect differences measured in standard deviation units.

**Extra Parameters**  The number of parameters other than $\mu$ in the hypothesis test. This option can be used for multi-factor designs. Leave the default zero in this field for simple cases.

In a multi-factor design where effects are orthogonal, you can specify the number of additional model parameters here. For example, in a three-factor, two-level design with all three two-factor interactions, the number of additional parameters is five: two parameters for the other main effects, and three parameters for the interactions.

Specify two of the following values to calculate the third value, or specify one value to obtain a plot of the relationship between the other two:

**Difference to Detect**  The smallest difference between the true mean and the hypothesized or reference mean you want to be able to declare statistically significant.
Sample Size  The total number of observations (runs, experimental units, or samples) in your experiment.

Power  The probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

Calculator Buttons

Continue  Evaluates the missing value when two parameters are specified, or launches a plot comparing two missing parameters if only one parameter is specified.

Back  Returns to the previous Sample Size and Power launch window.

Animation Script  Launches an interactive plot to illustrate and explore the relationship between power and the difference to detect. See “Example of an Animation Script”.

Statistical Details for the One Sample Mean Calculator

The one sample mean calculations are based on the traditional full versus reduced $F$ test for the following hypothesis test:

$$H_0: \mu = \mu_0 \text{ vs } H_a: \mu \neq \mu_0$$

JMP calculates power as follows:

$$\Pr(\text{reject } H_0 | \mu = \mu_0 + \delta) = 1 - F\left(f_{1-\alpha}, 1, n-p-1, \frac{n\delta^2}{\sigma^2}\right)$$

where:

$\alpha$ is the significance level.

$n$ is the sample size.

$p$ is the number of extra parameters.

$\delta$ is the difference to detect.

$f_{1-\alpha}$ is the $(1 - \alpha)^{th}$ quantile of the $F(1, n-p-1)$ distribution.

$F(x, df_1, df_2, nc)$ is the cumulative distribution function of the non-central $F$ distribution with degrees of freedom $df_1$ and $df_2$ and non-centrality parameter $nc$ evaluated at $x$.

Because analytical solutions for $\delta$ and $n$ do not exist, numerical solutions are used to solve for them.

For more information about calculations in JMP, see Barker (2011, Section 2.1).
Two Sample Means Calculator

Use the Two Sample Means calculator to evaluate sample size for a hypothesis test about two means. Explore questions such as how large a treatment effect is detectable for a given sample size, significance level, desired power, and assumed variability in the data. Sample size and power are associated with the following hypothesis test:

\[ H_0: \mu_1 - \mu_2 = 0 \]

versus the two-sided alternative:

\[ H_a: \mu_1 - \mu_2 \neq 0 \]

where \( \mu_1 \) and \( \mu_2 \) are the true means of the two populations. It is assumed that the populations of interest are normally distributed and that you want to detect a difference of \( \delta \) between the means.

Example of the Two Sample Means Calculator

Suppose you are comparing two groups and want to detect a 1 standard deviation difference between the group means at a 0.05 significance level with 80% power.

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **Two Sample Means**.
3. Leave **Alpha** as 0.05.
4. Enter 1 for **Std Dev**.
5. Leave **Extra Parameters** as 0.
6. Enter 1 as **Difference to detect**.
7. Leave **Sample Size** blank.
8. Enter 0.8 for **Power**.
9. Click **Continue**.
The sample size is calculated as 34. With 17 samples in each group, you have an 80% chance of detecting a 1 standard deviation difference between the two sample means at a significance level of $\alpha = 0.05$.

**Two Sample Means Calculator Fields**

Specify the following quantities:

**Alpha**  The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Std Dev**  The assumed standard deviation where both groups are assumed to have equal standard deviation.

**Extra Parameters**  The number of parameters other than $\mu_1$ and $\mu_2$ in the hypothesis test. This option can be used for multi-factor designs. Leave the default zero in this field for simple cases.

In a multi-factor balanced design, the number of additional model parameters can be specified here. For example, in a three-factor two-level design with all three two-factor interactions, the number of additional parameters is four: one parameter for the other main effects, and three parameters for the interactions.

Specify two of the following parameters to calculate the third value, or specify one value to obtain a plot of the relationship between the other two parameters:

**Difference to Detect**  The smallest difference between the two means that you want to be able to declare statistically significant.
Sample Size  The total number of observations (runs, experimental units, or samples) in your experiment. Use half of this sample size in each group.

Power  The probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

Calculator Buttons

Continue  Evaluates the missing value when two parameters are specified, or launches a plot comparing two missing parameters if only one parameter is specified.

Back  Returns to the previous Sample Size and Power launch window.

Statistical Details for the Two Sample Means Calculator

The two sample mean calculations are based on the traditional full versus reduced $F$ test for the following hypothesis test:

\[ H_0: \mu_1 - \mu_2 = 0 \text{ vs } H_a: \mu_1 - \mu_2 \neq 0 \]

JMP calculates power as follows:

\[
\text{power} = \Pr(\text{reject } H_0 \mid (\mu_1 - \mu_2 = \delta)) = 1 - F\left( f_{1-\alpha}, 1, 2n-p-2, \frac{n\delta^2}{2\sigma^2} \right)
\]

where:

- $\alpha$ is the significance level.
- $n$ is the sample size per group.
- $p$ is the number of extra parameters.
- $\delta$ is the difference to detect.
- $f_{1-\alpha}$ is the $(1 - \alpha)^{th}$ quantile of the $F(1, 2n - p - 2)$ distribution.
- $F(x, df_1, df_2, nc)$ is the cumulative distribution function of the non-central $F$ distribution with degrees of freedom $df_1$ and $df_2$ and non-centrality parameter $nc$ evaluated at $x$.

Because analytical solutions for $\delta$ and $n$ do not exist, numerical solutions are used to solve for them.

For more information about calculations in JMP, see Barker (2011, Section 2.2).
**k Sample Means Calculator**

Use the k Sample Means calculator to determine an appropriate sample size for a hypothesis test about two to ten means. Sample size and power are associated with the following hypothesis test:

\[ H_0: \mu_1 = \mu_2 = \ldots = \mu_k \]

versus the two-sided alternative:

\[ H_a: \text{not all means equal} \]

where:

\[ X_{ij} \sim N(\mu_j, \sigma^2) \text{ for } i = 1, \ldots, n, \ j = 1, \ldots, k \]

**Example of the k Sample Means Calculator**

Suppose you have 4 observations from each of 4 groups and you want to test to see whether all of the group means are equal. You expect the group means to be 10, 11, 12, and 13 with a standard deviation of 0.9. Calculate the power of detecting a difference in one or more means at a 0.05 significance level.

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **k Sample Means**.
3. Leave **Alpha** as 0.05.
4. Enter 0.9 for **Std Dev**.
5. Leave **Extra Parameters** as 0.
6. Enter 10, 11, 12, and 13 as the four levels of prospective means.
7. Enter 16 for **Sample Size**.
8. Leave **Power** blank.
9. Click **Continue**.
The Power is calculated as approximately 0.95. This means that there is a 95% chance of detecting that at least one of the means is different at a 0.05 significance level, assuming that the population means are 10, 11, 12, and 13, with a standard deviation of 0.9 and a total sample size of 16.

10. Click the 16 for Sample Size and delete it.

11. Click the 0.95 for Power and delete it.

12. Click **Continue** to launch a plot of power versus sample size.
From the plot of power versus sample size, you can confirm that a sample size of 16 is acceptable. Hover over the Sample Size axis and drag to extend the axis beyond 16. You can see that the increase in power for sample sizes above 16 is slight.

The plot also reports the difference in means, which is calculated as the square root of the sum of squared deviations from the grand mean. In this case, it is the square root of $(-1.5)^2 + (-0.5)^2 + (0.5)^2 + (1.5)^2$, which is the square root of 5. Therefore, the difference in means in this example is approximately 2.236.

**k Sample Means Calculator Fields**

Specify the following quantities:

**Alpha**  The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Std Dev**  The assumed standard deviation where all groups are assumed to have equal standard deviation.

**Extra Parameters**  The number of parameters other than the $\mu$ in the hypothesis test. This option can be used for multi-factor designs. Leave the default 0 in this field in simple cases.

**Prospective Means**  The assumed values for the means. At least two means must be specified.
Specify one of the following values to calculate the second, or leave both values blank to obtain a plot of the relationship between the two:

**Sample Size**  The total number of observations (runs, experimental units, or samples) in your experiment. Use a sample size of $n/k$ in each group, where $n$ is the total number of observations.

**Power**  The probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

### Calculator Buttons

**Continue**  Evaluates the missing value when one parameter is specified, or launches a plot comparing two parameters if no parameters are specified.

**Back**  Returns to the previous Sample Size and Power launch window.

### Statistical Details for the $k$ Sample Means Calculator

The $k$ sample mean calculations are based on the following:

$$\text{power} = 1 - F\left(f_{1 - \alpha, 1k - 1, 2kn - p - 2k, \frac{1}{\sigma^2} \sum_{j=1}^{k} (\mu_j - \bar{\mu})^2}\right)$$

where:

- $\alpha$ is the significance level
- $\sigma$ is the common standard deviation among the $k$ groups.
- $n$ is the sample size per group.
- $p$ is the number of extra parameters.
- $\bar{\mu}$ is the mean of the $k$ group prospective means
- $f_{1 - \alpha}$ is the $(1 - \alpha)^{th}$ quantile of the $F(k - 1, kn - p - k)$ distribution.
- $F(x, df_1, df_2, nc)$ is the cumulative distribution function of the non-central $F$ distribution with degrees of freedom $df_1$ and $df_2$ and non-centrality parameter $nc$ evaluated at $x$.

Numerical solutions are used to solve for $n$. 
**Difference in Means**

The difference in means is calculated as follows:

\[
\sqrt{\frac{k}{\sum_{j=1}^{k} (\mu_j - \bar{\mu})^2}}
\]

For more information about calculations in JMP, see Barker (2011, Section 2.3).

---

**One Sample Standard Deviation Calculator**

Use the One Sample Standard Deviation calculator to evaluate sample size for a hypothesis test about one standard deviation. Sample size and power are associated with the following hypothesis test:

\[
H_0: \sigma = \sigma_0
\]

versus the one-sided alternative:

\[
H_{a_1}: \sigma > \sigma_0 \text{ or } H_{a_2}: \sigma < \sigma_0
\]

where \(\sigma\) is the population standard deviation and \(\sigma_0\) is the hypothesized value. The difference to detect is an amount, \(\delta\), away from \(\sigma_0\) that one considers as important to detect based on a set of samples.

---

**Example of the One Sample Standard Deviation Calculator**

**Note:** This example is from the online manual of The National Institute of Standards and Technology (NIST). You can access the NIST manual examples at [https://www.itl.nist.gov/div898/handbook/prc/section2/prc232.htm](https://www.itl.nist.gov/div898/handbook/prc/section2/prc232.htm).

The variance for resistivity measurements on a lot of silicon wafers is claimed to be 100 ohm-cm squared. The buyer is unwilling to accept a lot if the variance is greater than 155 ohm-cm squared. How many wafers must you test to estimate the lot variance with precision to detect an increase in 55 ohm-cm squared from the target of 100 ohm-cm squared? In terms of standard deviation, the hypothesized standard deviation, \(\sigma_0\), is 10 (the square root of 100) and \(\sigma\) is 12.4499 (the square root of 100 + 55 = 155). The difference to detect is 12.4499 – 10 = 2.4499. The desired power is 0.99 and the significance level is 0.05.

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **One Sample Standard Deviation**.
3. Leave **Alpha** as 0.05.
4. Enter 10 for **Hypothesized Standard Deviation**.
5. Select Larger for **Alternative Standard Deviation**.
6. Enter 2.4499 for **Difference to Detect**.
7. Leave **Sample Size** blank.
8. Enter 0.99 for **Power**.
9. Click **Continue**.

**Figure 17.11** One-Sample Standard Deviation Calculator

You must test 171 wafers in order to have a 99% chance of detecting an increase in the standard deviation of 2.4499 from a standard deviation of 10, with an alpha of 0.05.

**One Sample Standard Deviation Calculator Fields**

Specify the following:

**Alpha**  The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Hypothesized Standard Deviation**  The hypothesized or baseline standard deviation to which the sample standard deviation is compared.

**Alternative Standard Deviation**  The direction of the change that you want to detect, either Larger or Smaller.

**Note:** If you select Smaller from the Alternative Standard Deviation menu, enter a negative Difference to Detect.
Specify two of the following values to calculate the third value:

**Difference to Detect**  The smallest detectable difference (how small a difference you want to be able to declare statistically significant). This is the difference between the hypothesized value and the true value.

**Sample Size**  The total number of observations (runs, experimental units, or samples) in your experiment.

**Power**  The probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

### Calculator Buttons

**Continue**  Evaluates the missing value.

**Back**  Returns to the previous Sample Size and Power launch window.

### Statistical Details for the One Sample Standard Deviation Calculator

The formula that JMP uses to calculate power depends on the setting of the Alternative Standard Deviation option.

For cases where the alternative standard deviation is larger, JMP calculates power as follows:

$$
\text{power} = 1 - F\left(\frac{\sigma_0^2 \cdot \chi_{1 - \alpha}}{(\sigma_0 + \delta)^2}, n - 1\right)
$$

$$
\delta = \sigma_0 \sqrt{\frac{\chi_{1 - \alpha}}{\chi_{\beta/2}}} - \sigma_0
$$

where:

- $\sigma_0$ is the hypothesized standard deviation.
- $\sigma$ is the true standard deviation
- $\chi_{\alpha}$ is the $(1 - p)^{th}$ quantile of the $X_{n-1}^2$ distribution.
- $F(x, n-1)$ is the cumulative distribution function of the $X_{n-1}^2$ distribution evaluated at $x$.

For cases where the alternative standard deviation is smaller, JMP calculates power as follows:

$$
\text{power} = 1 - F\left(\frac{\sigma_0^2 \cdot \chi_{\alpha}}{(\sigma_0 + \delta)^2}, n - 1\right)
$$
Prospective Sample Size and Power

Chapter 17

One Sample Proportion Calculator

Design of Experiments Guide

\[
\delta = \sigma_0 \sqrt{\frac{X_p}{X_{1-\beta}}} - \sigma_0
\]

where:

- \(\sigma_0\) is the hypothesized standard deviation.
- \(\sigma\) is the true standard deviation
- \(X_p\) is the \((1 - p)\)th quantile of the \(X_{n-1}^2\) distribution.
- \(F(x, n-1)\) is the cumulative distribution function of the \(X_{n-1}^2\) distribution evaluated at \(x\).

Numerical solutions are used to solve for \(n\).

For more information about calculations in JMP, see Barker (2011, Section 2.4).

---

One Sample Proportion Calculator

Use the One Sample Proportion calculator to evaluate sample size for a hypothesis test about one proportion. Sample size and power are associated with the following hypothesis test:

- \(H_0: p = p_0\)
- versus the two-sided alternative:
  - \(H_a: p \neq p_0\)
- or versus a one-sided alternative:
  - \(H_a: p < p_0\) or \(H_a: p > p_0\)

where \(p\) is the population proportion and \(p_0\) is the null proportion.

The One Proportion Calculator also provides the actual test size. This is the actual Type I error rate for the specified assumptions. Since the binomial distribution is discrete, the actual test size can differ significantly from the stated Alpha level for small samples or proportions near 0 or 1. To guarantee an alpha level equal to or greater than your stated level, use the Exact Clopper-Pearson method.
Example of the One Sample Proportion Calculator

Suppose that an assembly line has a historical proportion of defects equal to 0.1. Given a sample size of 100 and an alpha level of 0.05, you want to calculate the power to detect a defect rate that differs by 0.1 or more from the historical rate.

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **One Sample Proportion**.
3. Leave **Alpha** as 0.05.
4. Leave 0.1 as the value for **Proportion**.
5. Leave the **Method** as Exact Agresti-Coull.
6. Leave the test type as **Two-Sided**.
7. Leave 0.2 as the value for **Null Proportion**.
8. Enter 100 as the **Sample Size**.
9. Click **Continue**.

**Figure 17.12** One Sample Proportion Calculator

For a sample size of 100, the power is approximately 70%. The Actual Test Size is approximately 0.0467, which is slightly less than the desired 0.05. With a sample size of 100, if the defect rate is 0.2, the probability of a Type I error of rejecting the null hypothesis is 5%. Alternatively, the probability of a Type II error of not rejecting the null hypothesis is 30% (1 - power).
One Sample Proportion Calculator Fields

Specify the following quantities and test settings:

**Alpha**  The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Proportion**  The true proportion, which could be known or hypothesized. The default value is 0.1.

**Tip:** For all other parameters fixed, the largest sample size occurs when the proportion is 0.5.

**Method**  Select a method. Choices are Exact Agresti-Coull or Exact Clopper-Pearson. The Clopper-Pearson method tends to be more conservative (larger sample size) than the Agresti-Coull method.

**One-Sided or Two-Sided**  Select either a one-sided or a two-sided test.

Specify two of the following parameters to calculate the third value, or specify one value to obtain a plot of the relationship between the other two parameters.

**Note:** The plot uses the normal approximation method rather than an exact method.

**Null Proportion**  The proportion to test against ($p_0$). The default value is 0.2.

**Sample Size**  The total number of observations (runs, experimental units, or samples) in the experiment.

**Power**  The probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

**Calculator Buttons**

**Continue**  Evaluates the missing value when two parameters are specified, or launches a plot comparing two missing parameters if only one parameter is specified.

**Back**  Returns to the previous Sample Size and Power launch window.
Statistical Details for the One Proportion Calculator

The one proportion sample size computations use exact methods based on the binomial distribution. Exact calculations guarantee that the stated power level is obtained.

Agresti-Coull Method

The exact Agresti-Coull method uses the adjusted Wald-based test statistic. JMP calculates power under the two-sided null hypothesis as follows:

\[
\text{Power} = \sum_{y = 0}^{n} \Pr(Y = y | Y \sim \text{binomial}(n, p)) I(T(y) \geq \chi_{1 - \alpha}^2)
\]

where:

\[
T(y) = \frac{(\hat{p} - p_0)^2}{p(1-p)} \frac{n+4}{n+4}
\]

\[
\hat{p} = \frac{y + 2}{n + 4}
\]

\[
I(T(y_1, y_2) \geq \chi_{1 - \alpha}^2) = 1 \text{ if } (T(y_1, y_2) \geq \chi_{1 - \alpha}^2) \text{ and 0 otherwise, and }
\]

\[
\chi_{1 - \alpha}^2 \text{ is the } (1 - \alpha)^{th} \text{ quantile of the } \chi_1^2 \text{ distribution.}
\]

Because there is not a closed-form expression for \( n \) or \( p_0 \), numerical techniques are used to solve for \( n \) or \( p_0 \).

For more information about the adjusted Wald test statistic, see Agresti and Coull (1998). For more information about calculations in JMP, see Barker (2011, Section 3.3).

Clopper-Pearson Method

The exact Clopper-Pearson method is based on the binomial distribution. This method results in an alpha level equal to or greater than the stated level. The Clopper-Pearson method is more conservative (larger sample size) than the Agresti-Coull method.

The exact Clopper-Pearson method uses the binomial distribution directly. Numerical techniques are used to solve for the unknown parameter.

For more information about the Clopper-Pearson exact method, see Clopper and Pearson (1934) or Agresti and Coull (1998, Section 1).
Two Sample Proportions Calculator

Use the Two Sample Proportions calculator to evaluate sample size for a hypothesis test about two proportions. Sample size and power are associated with the following hypothesis test:

\[ H_0: p_1 - p_2 = D_0 \]

versus the two-sided alternative:

\[ H_a: p_1 - p_2 \neq D_0 \]

or versus either of the following one-sided alternatives:

\[ H_a: (p_1 - p_2) < D_0 \] or \[ H_a: (p_1 - p_2) > D_0 \]

where \( p_1 \) and \( p_2 \) are the population proportions from two populations, and \( D_0 \) is the hypothesized difference in proportions.

The Two Proportions Calculator also provides the actual test size. This is the actual Type I error rate for the specified assumptions. Since the binomial distribution is discrete, the actual test size can differ significantly from the stated Alpha level for small samples or proportions near 0 or 1.

Example of the Two Sample Proportions Calculator

Suppose you are responsible for two silicon wafer assembly lines. Based on the knowledge from many runs, one of the assembly lines has a defect rate of 8% and the other line has a defect rate of 6%. You want to know the sample size necessary to have 80% power to conclude there is a difference in defect rates.

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **Two Sample Proportions**.
3. Leave **Alpha** set at 0.05.
4. Enter 0.08 for **Proportion 1**.
5. Enter 0.06 for **Proportion 2**.
6. Select a **Two-Sided** test.
7. Enter 0 for **Null Difference in Proportion**.
8. Leave **Sample Size 1** and **Sample Size 2** blank.
9. Enter 0.8 for **Power**.
10. Click **Continue**.
The calculator shows that you should test a sample size of 2,554 wafers from each production line in order to detect a difference in defect rates.

**Two Sample Proportions Calculator Fields**

Specify the following quantities and test settings:

**Alpha**  The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Proportion 1**  The proportion for population 1, which could be known or hypothesized. The default value is 0.5.

**Proportion 2**  The proportion for population 2, which could be known or hypothesized. The default value is 0.1.

**One-Sided or Two-Sided**  Select either a one-sided or a two-sided test.

Specify two of the following parameters to calculate the third where the sample sizes are considered as one parameter. The sample sizes must both be entered or both be left blank for calculation.

**Null Difference in Proportion**  The difference in proportions under the null hypothesis. The default value is 0.2.

**Sample Size 1**  The total number of observations (runs, experimental units, or samples) in the experiment to estimate Proportion 1.
Sample Size 2  The total number of observations (runs, experimental units, or samples) in the experiment to estimate Proportion 2.

Note: When sample size is calculated, Sample Size 1 = Sample Size 2. If you enter sample sizes, they do not have to be equal.

Power  The probability of rejecting the null hypothesis when it is false. High power is desired. With all other parameters fixed, power increases with sample size.

Calculator Buttons

Continue  Evaluates the missing value.

Back  Returns to the previous Sample Size and Power launch window.

Statistical Details for the Two Proportions Calculator

Two proportions calculations are based on exact methods similar to those used for the one proportion calculator. For the two-sided hypothesis

\[ H_0: p_1 - p_2 = D_0 \text{ vs } H_a: p_1 - p_2 \not= D_0 \]

JMP calculates power under the null hypothesis as follows:

\[
\text{Power} = \sum_{y_1 = 0}^{n_1} \sum_{y_2 = 0}^{n_2} \Pr(Y_1 = y_1)\Pr(Y_2 = y_2)I\{T(y_1,y_2) \geq \chi^2_{1-\alpha}\}
\]

where the adjusted Wald statistic is defined as follows:

\[
T(y_1,y_2) = \frac{(\hat{p}_1 - \hat{p}_2 - \delta_0)^2}{\hat{p}_1(1-\hat{p}_1) + \hat{p}_2(1-\hat{p}_2)} \quad \text{where } \hat{p}_j = \frac{y_j + 1}{n_j + 2} \text{ for } j = 1, 2
\]

and:

\[
I\{T(y_1,y_2) \geq \chi^2_{1-\alpha}\} = 1 \text{ if } (T(y_1,y_2) \geq \chi^2_{1-\alpha}) \text{ and } 0 \text{ otherwise}
\]

and \(\chi^2_{1-\alpha}\) is the \((1 - \alpha)\text{th}\) quantile of the \(\chi^2\) distribution.

Because there are no closed-form expressions for the \(n_i\) or \(\delta_0\), numerical techniques are used to solve for the \(n_i\) and \(\delta_0\).
For more information about the adjusted Wald test statistic, see Agresti and Coull (1998). For more information about calculations in JMP, see Barker (2011, Section 3.3).

Counts per Unit Calculator

Use the Counts per Unit Calculator to evaluate sample size for a one-sided hypothesis test about the defects (counts) per unit. Sample size and power are associated with the following hypothesis test:

\[ H_0: \lambda \leq \lambda_0 \]

versus a one-sided alternative:

\[ H_a: \lambda > \lambda_0 \]

where \( \lambda \) is the rate of a Poisson distribution.

Example of the Counts per Unit Calculator

Consider a wafer manufacturing process with a target of 4 or fewer defects per wafer. You want to verify that a new process meets that target. How many wafers should you test to detect a difference of 1 that the count of defects per wafer is on target with 90% power at the significance level of 0.05?

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **Counts per Unit**.
1. Leave **Alpha** as 0.05 (the chance of failing the test if the new process is as good as the target).
2. Enter 4 as the **Baseline Counts per Unit**, indicating the target of 4 defects per wafer.
3. Enter 1 as the **Difference to detect**.
4. Enter a power of 0.9.
   - This is the chance of detecting a change larger than 1, which is equivalent to 5 or more defects per wafer. In this type of situation, the significance level (alpha) is sometimes called the *producer’s risk* and the power (beta) is called the *consumer’s risk*.
5. Click **Continue**.
You must test 38 wafers. The process meets the target if there are fewer than 173 defects.

**Note:** The 173 defects are the maximum number of defects that can occur in 38 wafers without rejecting the null hypothesis.

### Counts per Unit Calculator Fields

Specify the following quantities:

- **Alpha**  The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

- **Baseline Count per Unit**  The number of targeted defects per unit. The default value is 0.1.

Specify two of the following quantities to calculate the third quantity:

- **Difference to detect**  The smallest detectable difference to test against specified in defects per unit.

- **Sample Size**  The number of units.

- **Power**  The probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

### Calculator Buttons

- **Continue**  Evaluates the missing value.

- **Back**  Returns to the previous Sample Size and Power launch window.
Statistical Details for the Counts per Unit Calculator

Calculations for the counts per unit calculator are based on applying a normal approximation to the Poisson distribution. The test uses the following hypothesis:

\[ H_0: \lambda \leq \lambda_0 \text{ vs } H_a: (\lambda > \lambda_0) \]

The above hypothesis uses the following test statistic:

\[ T = \frac{\bar{d} - \lambda_0}{\sqrt{\lambda_0/n}} \]

where \( n \) is the sample size and \( \bar{d} \) is the mean number of defects per unit in the sample. We assume \( T \) to be approximately normally distributed. The power calculation is based on the distribution of \( T \) under the null and alternative hypotheses.

\[
\text{power} = \Pr(\text{reject } H_0| \lambda = \lambda_0 + \delta) = \Pr[T > Z_{1 - \alpha} | (\lambda = \lambda_0 + \delta)] = 1 - \Phi \left( \frac{Z_{1 - \alpha} - \delta \sqrt{n/\lambda_0}}{\sqrt{(\lambda_0 - \delta)/\lambda_0}} \right)
\]

where \( \Phi() \) is the standard normal cumulative distribution function and \( Z_{1-p} \) is the \((1 - p)\)th quantile of the standard normal distribution.

Using \( 1 - \beta \) to denote the desired power to reject the null hypothesis, the sample size is calculated as follows:

\[
n = \frac{\lambda_0}{\delta^2 \left( Z_{1 - \alpha} - Z_\beta \sqrt{\frac{\lambda_0 + \delta}{\lambda_0}} \right)^2}
\]

Because an analytical solution for \( \delta \) does not exist, numerical methods are used to solve for \( \delta \) given power and \( n \).

For more information about calculations in JMP, see Barker (2011, Section 2.5).
Sigma Quality Level Calculator

Use the Sigma Quality Level Calculator to explore relationships between the number of defects, number of opportunities for defects, and the Sigma Quality Level. The Sigma Quality Level is a statistic that relates a given defect rate to a six-sigma scale. For example, a defect rate of 3.4 per one million opportunities results in a six-sigma process.

Example of the Sigma Quality Level Calculator

Suppose you want to estimate the Sigma Quality Level for 50 defects in 1,000,000 opportunities at your plant. An opportunity is the unit for the defect count. It could be a single item or you might have multiple defects on a single item where each potential defect is an opportunity.

2. Click the Sigma Quality Level.
3. Enter 50 for the Number of Defects.
4. Enter 1000000 as the Number of Opportunities.
5. Click Continue.

Figure 17.15 Sigma Quality Level Calculator

The Sigma Quality level is approximately 5.4.

Example Computing the Number of Defects

To calculate the maximum number of defects you can have out of a million opportunities and still have a six-sigma quality level process, follow these steps:

2. Click the Sigma Quality Level button.
3. Leave **Number of Defects** blank.
4. Enter 1000000 as the **Number of Opportunities**.
5. Enter 6 as **Sigma Quality Level**.
6. Click **Continue**.

**Figure 17.16** Six-Sigma Quality Level for 1,000,000 Opportunities

The computation shows that the **Number of Defects** cannot be more than 3 in 1,000,000 opportunities to achieve a six-sigma quality level process.

**Sigma Quality Level Calculator Fields**

Specify two of the following quantities to calculate the third quantity:

**Number of Defects** The number of defects.

**Number of Opportunities** The number of opportunities for a defect.

**Sigma Quality Level** The defect rate in standard deviation units.

**Calculator Buttons**

**Continue** Evaluates the missing value.

**Back** Returns to the previous Sample Size and Power launch window.

**Statistical Details for the Sigma Quality Calculator**

Calculations for the sigma quality calculator are based on the definition of sigma quality level \( \sigma_q \) for \( d \) defects in \( n \) opportunities:

\[
\sigma_q = \frac{Z}{1 - \frac{d}{n}} + 1.5
\]
From this definition, \( d \) and \( n \) can be calculated as follows:

\[
\begin{align*}
d &= n[1 - \Phi(\sqrt{q} - 1.5)] \\
n &= d[1 - \Phi(\sqrt{q} - 1.5)]^{-1}
\end{align*}
\]

where \( \Phi() \) is the standard normal cumulative distribution function and \( Z_{1-d/n} \) is the \((1 - d/n)\)th quantile from the standard normal distribution.

## Reliability Test Plan Calculator

Use the Reliability Test Plan Calculator to determine the sample size, study length, or precision needed for a reliability study. Reliability studies are used to estimate failure times and failure probabilities of a product. The test plan calculator uses expected confidence intervals to define the precision of the estimates. These estimates are based on a fitted failure distribution. To fit a failure distribution, a minimal number of failures must be observed.

### Example of the Reliability Test Plan Calculator

A company has developed a new product and wants to calculate how many units to test to estimate the time until 20% of units fail, using a 95% confidence interval with two-sided absolute precision of 200 hours. In other words, when a confidence interval is created for the estimated time, the difference between the upper and lower limits should be approximately 200 hours. The company can run the test for 2,500 hours. In addition, from studies of similar products, they believe the approximate failure distribution to be a Weibull distribution with location parameter \( \alpha = 2000 \) and scale parameter \( \beta = 3 \).

To compute the required sample size:

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **Reliability Test Plan**.
3. Leave Alpha set at 0.05.
4. Select **Weibull** from the Distribution list.
5. Enter 2000 for the **Weibull** \( \alpha \) parameter.
6. Enter 3 for the **Weibull** \( \beta \) parameter.
7. Select **Two-sided Interval Absolute Width** from the Precision Measure list.
8. Select **Estimate time associated with specified failure probability** and enter 0.2 for \( p \).
Note: The cumulative distribution function plot is labeled according to the study objective. Here, Time = 1213 is the time estimate for 20% of unit failures.

10. Enter 2500 for Censor Time.
11. Enter 200 for Precision.
12. Click Continue.

Figure 17.17 Reliability Test Plan Calculator

To estimate the time until 20% of units fail with a precision of 200 hours requires 217 units on test for 2,500 hours. The expected number of failures in this test is approximately 186, much larger than the minimum of 3 needed to estimate the failure distribution.
Reliability Test Plan Calculator Fields

Specify the following quantities and test settings:

**Alpha**  The significance level of the confidence interval used to define the precision measure.

**Distribution**  The assumed failure distribution. Distributions available are: Weibull, Lognormal, Frechet, Loglogistic, SEV, Normal, LEV, and logistic. For more information about these distributions, see *Reliability and Survival Methods*.

**Location**  The location parameter for the failure distribution.

*Note:* The Location field is denoted Weibull $\alpha$ when the Distribution is set to Weibull.

**Scale**  The scale parameter for the failure distribution.

*Note:* The Scale field is denoted Weibull $\beta$ when the Distribution is set to Weibull.

**Precision Measure**  The definition of the precision measure. Definitions are based on the expected confidence interval of the quantity being estimated (failure time or probability). The choices for the precision measure are as follows:

- **Interval Ratio**  Defines precision as the square root of the ratio of the upper limit to the lower limit. This ratio is always greater than one since the upper limit is greater than or equal to the lower limit. The interval ratio decreases as the precision in the estimate increases.

- **Two-sided Interval Absolute Width**  Defines precision as the width of the confidence interval or the difference between the upper and lower limits.

- **Lower One-sided Interval Absolute Width**  Defines precision as the width of the lower side of the interval or the difference between the estimate and the lower limit of the confidence interval for the estimate.

- **Two-sided Interval Relative Width**  Defines precision as the width of the confidence interval relative to the estimate. This is the difference between the upper and lower limits divided by the estimate.

- **Lower One-sided Interval Relative Width**  Defines precision as the width of the lower side of the interval relative to the estimate. This is the difference between the estimate and the lower limit divided by the estimate.

**Objective**  The objective of the study. Select one of the following objectives and enter the corresponding value:

- Estimate time associated with specified failure probability $p$.
- Estimate failure probability at time $t$. 
Note: The plot is the cumulative distribution function of the failure distribution. The plot is labeled with the estimate of time or probability based on the study objective.

Specify two of the following quantities to calculate the third quantity:

**Sample Size**  The number of units to include in the reliability test.

**Censor Time**  The amount of time available to run the reliability test.

**Precision**  The level of precision. The definition of the units on this value corresponds to the chosen Precision Measure.

**Calculator Buttons**

- **Continue**  Evaluates the missing value.
- **Back**  Returns to the previous Sample Size and Power launch window.

**Additional Reliability Test Plan Calculations**

In addition to calculating the sample size, censor time, or precision, the following quantities are also calculated:

**Expected number of failures**  The expected number of failures for the specified reliability test.

**Probability of fewer than 3 failures**  The probability that the specified reliability test results in fewer than three failures. This is important because a minimum of three failures is required to obtain stable estimates for the location and scale parameters of the failure distribution. With only one or two failures, the estimates are unstable. If this probability is large, you risk not observing enough failures to reliably estimate the distribution parameters. Increasing the sample size or censor time are both ways to lower the probability of fewer than three failures.

**Large-sample approximate covariance matrix**  Provides the approximate variances and covariance for the location and scale parameters of the failure distribution.

**Statistical Details for the Reliability Test Plan Calculator**

The reliability test plan is designed to estimate either a quantile:

\[ q(p) = \exp[\sigma \Phi^{-1}(p) + \mu] \]
or a failure probability:

$$p(t) = \Phi \left[ \frac{\log(t) - \mu}{\sigma} \right]$$

at a specified level of significance with an assumed failure time distribution and precision measure. $\Phi()$ is the standard cumulative distribution function of the assumed failure time distribution with location parameter $\mu$ and scale parameter $\sigma$. Wald confidence intervals and the precision measure define precision as a function of $t$ (time) and $n$ (sample size). Numerical methods are used to solve for the desired quantity.

For more information about calculations in JMP, see Barker (2011, Section 6).

## Reliability Demonstration Calculator

Use the Reliability Demonstration calculator to test a specified number of units for a specified period of time. If fewer than $k$ units fail, the demonstration passes, and you can conclude that the product reliability meets or exceeds a reliability standard. We pose the reliability demonstration as a hypothesis test:

$$H_0: p < p^* \text{ vs } H_a: p \geq p^*$$

where $p$ is the probability of survival time at $t^*$ for the new product and $p^*$ is the standard probability of survival at time $t^*$.

### Example of the Reliability Demonstration Calculator

A company wants to estimate the sample size needed for assessing the reliability of a new product against a historical reliability standard of 90% survival after 1,000 hours. From prior studies on similar products, it is believed that the failure time distribution is Weibull, with a $\beta$ parameter of 3. The company can afford to run the demonstration for 800 hours, and wants the experiment to result in no more than 2 failures.

To compute the required sample size:

1. Select **DOE > Design Diagnostics > Sample Size and Power**.
2. Click **Reliability Demonstration**.
3. Leave Alpha set at 0.05.
4. Select **Weibull** from the Distribution list.
5. Enter 3 for the **Weibull $\beta$**.
6. Enter 2 for **Max Failures Tolerated**.
7. Enter 1000 for **Time**.
8. Enter 0.9 for **Probability of Surviving**.
9. Enter 800 for **Time of Demonstration**.
10. Leave **Number of Units Tested** blank.
11. Click **Continue**.

**Figure 17.18** Reliability Demonstration Calculator

The company needs to run 118 units in the demonstration. Furthermore, if they observe 2 or fewer failures by 800 hours, they can conclude that the new product reliability is at least as reliable as the standard.
The plot shows that as the true probability of a unit surviving to the time in the reliability standard increases, the probability of passing the demonstration increases. In this example, if a unit has only a 92% chance of surviving to the standard time, then the chance of the new product passing the demonstration is only about 12.5%.

**Reliability Demonstration Calculator Fields**

Specify the following quantities and test settings:

**Alpha**  The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Distribution**  The assumed failure time distribution. Distributions available are: Weibull, Lognormal, Frechet, Loglogistic, SEV, Normal, LEV, and logistic. For more information about these distributions, see *Reliability and Survival Methods*.

**Scale**  The scale parameter for the failure time distribution.

---

**Note:** The Scale field is denoted Weibull $\beta$ when the specified Distribution is Weibull.

**Max Failures Tolerated**  The maximum number of failures allowed for a successful test demonstration.

**Reliability Standard**  The definition of the standard that you are testing. This standard is based on a length of time and the probability of an item's survival to that time.

**Time**  The minimum length of time that an item under test should survive.

**Probability of Surviving**  The probability that the item under test survives until the defined Time of the reliability standard.

Enter one of the following two values to calculate the other:

**Time of Demonstration**  The length of the demonstration in time.

**Number of Units Tested**  The number of units needed for the demonstration.

**Calculator Buttons**

**Continue**  Evaluates the missing value.

**Back**  Returns to the previous Sample Size and Power launch window.
Statistical Details for the Reliability Demonstration Calculator

The reliability demonstration depends on the assumed failure time distribution with scale parameter \( \sigma \). The reliability standard, or probability of survival at time \( t \) and location \( \mu \) is stated as follows:

\[
p = 1 - \Phi \left[ \frac{\log(t - \mu)}{\sigma} \right]
\]

where \( \mu \) is solved for using the following:

\[
\mu = \log(t) - \sigma \Phi^{-1}(1 - p) .
\]

To calculate sample size and the size of the test, the probability of survival at time \( t \) is posed as a hypothesis test:

\[
H_0 : p < p^* \text{ vs } H_a : p \geq p^*
\]

where \( p^* \) is the standard probability of survival at time \( t^* \).

We want to test the hypothesis at the \( \alpha \) level or as follows:

\[
\alpha = \text{Pr}(k \text{ or few failures } | H_0 \text{ true}).
\]

Since the test is of \( n \) independent units, the number of failures has a binomial \((n, p)\) distribution where \( p \) is the probability of a unit failing before time \( t \). Therefore, we can express \( \alpha \) as a function of \( t \) and \( n \):

\[
\alpha = \text{Pr} \left( x \leq k | x \sim \text{Bin}(n, \Phi \left[ \frac{\log(t - \mu^*)}{\sigma^*} \right]) \right)
\]

where \( \mu^* \) and \( \sigma^* \) are from the assumed reliability standard.

Properties of the binomial and beta distributions result in being able to solve for \( t \) using:

\[
t = \frac{t^* \exp \left( \sigma^* \Phi^{-1}[1 - B^{-1}(\alpha; n - k, k + 1)] \right)}{\exp[\sigma^* \Phi^{-1}(1 - p^*)]}
\]

For \( n \), Brent’s method is used to find the root of:

\[
B^{-1}(\alpha; n - k, k + 1) - 1 + \Phi \left[ \frac{\log t - (\log t^*) + \sigma^* \Phi^{-1}(1 - p^*)}{\sigma^*} \right] = 0
\]
where:

\[ B^{-1}(\alpha; n - k, k + 1) \]

is the \( \alpha \) quantile of the Beta\((n - k; k + 1) \) distribution and \( \Phi() \) is the cumulative distribution function of the assumed failure time distribution.

For more information about calculations in JMP, see Barker (2011, Section 5).
A choice (or discrete choice) experiment provides data for modeling discrete preferences. Study participants are presented with sets of potential products (or product profiles) with varying attributes. From each set of profiles, a participant selects a preferred profile. For example, in designing a high-end laptop, a computer company might be interested in the relative importance of key features such as: processor speed, hard disk size, screen size, battery life, and price. A choice experiment addresses the relative values of these features to a customer and indicates an optimal set of trade-offs among product features.

The results of a choice experiment are analyzed using conjoint analysis methods. See Consumer Research.

**Figure 18.1 A Survey with Eight Choice Sets**

<table>
<thead>
<tr>
<th>Choice Set</th>
<th>Choice ID</th>
<th>Disk Size</th>
<th>Speed</th>
<th>Battery Life</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>40 GB</td>
<td>2.0 GHz</td>
<td>6 Hrs</td>
<td>$1000</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>80 GB</td>
<td>1.5 GHz</td>
<td>4 Hrs</td>
<td>$1500</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>80 GB</td>
<td>1.5 GHz</td>
<td>4 Hrs</td>
<td>$1200</td>
</tr>
<tr>
<td>4</td>
<td>2</td>
<td>40 GB</td>
<td>1.5 GHz</td>
<td>6 Hrs</td>
<td>$1500</td>
</tr>
<tr>
<td>5</td>
<td>3</td>
<td>40 GB</td>
<td>1.5 GHz</td>
<td>4 Hrs</td>
<td>$1200</td>
</tr>
<tr>
<td>6</td>
<td>3</td>
<td>80 GB</td>
<td>2.0 GHz</td>
<td>6 Hrs</td>
<td>$1500</td>
</tr>
<tr>
<td>7</td>
<td>4</td>
<td>40 GB</td>
<td>2.0 GHz</td>
<td>4 Hrs</td>
<td>$1000</td>
</tr>
<tr>
<td>8</td>
<td>4</td>
<td>80 GB</td>
<td>1.5 GHz</td>
<td>6 Hrs</td>
<td>$1500</td>
</tr>
<tr>
<td>9</td>
<td>5</td>
<td>80 GB</td>
<td>2.0 GHz</td>
<td>6 Hrs</td>
<td>$1200</td>
</tr>
<tr>
<td>10</td>
<td>5</td>
<td>40 GB</td>
<td>1.5 GHz</td>
<td>6 Hrs</td>
<td>$1000</td>
</tr>
<tr>
<td>11</td>
<td>6</td>
<td>40 GB</td>
<td>1.5 GHz</td>
<td>4 Hrs</td>
<td>$1500</td>
</tr>
<tr>
<td>12</td>
<td>6</td>
<td>80 GB</td>
<td>1.5 GHz</td>
<td>6 Hrs</td>
<td>$1000</td>
</tr>
<tr>
<td>13</td>
<td>7</td>
<td>80 GB</td>
<td>1.5 GHz</td>
<td>4 Hrs</td>
<td>$1000</td>
</tr>
<tr>
<td>14</td>
<td>7</td>
<td>40 GB</td>
<td>2.0 GHz</td>
<td>6 Hrs</td>
<td>$1200</td>
</tr>
<tr>
<td>15</td>
<td>8</td>
<td>80 GB</td>
<td>1.5 GHz</td>
<td>6 Hrs</td>
<td>$1200</td>
</tr>
<tr>
<td>16</td>
<td>8</td>
<td>80 GB</td>
<td>2.0 GHz</td>
<td>4 Hrs</td>
<td>$1500</td>
</tr>
</tbody>
</table>
Contents

Overview of Choice Designs ................................................................. 549
Choice Design Terminology ............................................................... 549
Bayesian D-Optimality ...................................................................... 550
Example of a Choice Design ................................................................. 550
Example of a Choice Design with Analysis ........................................... 553
  Create a Choice Design for a Pilot Study .......................................... 553
  Analyze the Pilot Study Data ............................................................ 555
  Design the Final Choice Experiment Using Prior Information ............. 556
  Run the Design and Analyze the Results .......................................... 558
Choice Design Window ...................................................................... 561
  Attributes .......................................................................................... 561
  Model ................................................................................................. 562
  Design Generation ............................................................................ 563
  Design ................................................................................................. 564
  Make Table ......................................................................................... 566
Choice Design Options ...................................................................... 566
Technical Details ................................................................................. 567
  Bayesian D-Optimality and Design Construction .............................. 567
  Utility-Neutral and Local D-Optimal Designs ................................. 568
Overview of Choice Designs

Discrete choice experiments support the process of designing a product. They help prioritize product features for a company’s market so that the company can design a product that people want to buy. The Choice Design platform creates experiments using factors that are attributes of a product. Selecting the attributes to be studied and their values is of critical importance. You must include all attributes that are likely to influence a consumer’s decision to buy the product. For more information and guidelines for designing a choice experiment, see Sall (2008).

Choice Design Terminology

The following terminology is associated with choice designs:

- **An attribute** is a feature of a product.
- **A profile** is a specification of product attributes.
- **A choice set** is a collection of profiles.
- **A survey** is a collection of choice sets.
- **A partial profile** is a profile in a choice design where only a specified number of attributes are varied within each choice set. The remaining attributes are not varied.

In a discrete choice experiment, respondents are presented with a survey containing several choice sets. Choice sets usually contain only a small number of profiles to facilitate the decision process. Within each choice set, each respondent specifies which of the profiles he or she prefers. For example, attributes for a laptop experiment might include speed, storage, screen size, battery life, and price. Different combinations of these attributes comprise product profiles. A choice set might consist of two profiles. From each choice set, a respondent chooses the profile that he or she prefers.

In cases where many attributes are involved, you can construct surveys where each choice set contains *partial profiles*. In a choice set with partial profiles, only a specified number of attributes are varied and the remaining attributes are held constant. This reduces the complexity of the choice task.
Bayesian D-Optimality

Because discrete choice models are nonlinear in their parameters, the efficiency of a choice design depends on the unknown parameters. The Choice Design platform uses a Bayesian approach, optimizing the design over a prior distribution of likely parameter values that you specify. The Bayesian D-optimality criterion is the expected logarithm of the determinant of the information matrix, taken with respect to the prior distribution. The Choice Design platform maximizes this expectation with respect to the prior probability distribution. See “Bayesian D-Optimality and Design Construction” and Kessels et al. (2011).

You can also generate the following types of designs:

- Utility-neutral designs - In a utility-neutral design, all choices within a choice set are equally probable. The prior mean is set to 0.
- Local D-optimal designs - A local D-optimal design takes into account the prior on the mean, but does not include any information from a prior covariance matrix.

For more information about utility neutral and local D-optimal designs, see “Utility-Neutral and Local D-Optimal Designs”.

Example of a Choice Design

About the Experiment

In this example, a coffee shop is interested in making an ideal cup of coffee to satisfy the majority of its customers. The manager has asked you to determine which factors affect customer preferences. Specifically, you need to determine which settings of the following factors (attributes) result in an ideal cup of coffee:

- Grind size (medium or coarse)
- Temperature (195°, 200°, 205°)
- Brewing time (3 minutes, 3.5 minutes, or 4 minutes)
- Charge (1.6 grams/ounce, 2 grams/ounce, or 2.4 grams/ounce)

Each combination of factor levels is a profile. Trying to obtain information about preferences by having every respondent sample every possible profile is not practical. However, you can ask a respondent to select a preferred profile from a choice set consisting of a small number of profiles.

In this example, you design an experiment where each respondent indicates his or her preference in several choice sets. Your design will have the following structure:

- ten respondents
• twelve choice sets
• two profiles per choice set
• one survey per respondent containing all 12 choice sets

The experiment results in 12 responses per respondent. Analysis of these preferences can be used to draw conclusions about how to make a cup of coffee that pleases most customers.

Create the Design

You can enter factors either manually or automatically using a preexisting table that contains the factors and settings. In this example, for convenience, you use a preexisting table. But, if you are designing a new experiment, you must first enter the factors manually. For more information about entering factors manually, see “Attributes”.

1. Select DOE > Consumer Studies > Choice Design.
2. Select Help > Sample Data Library and open Design Experiment/Coffee Choice Factors.jmp.
3. Click the Choice Design red triangle and select Load Factors.

Figure 18.2 Choice Design Window with Attributes Defined

4. Click Continue.
5. (Optional) Open the DOE Model Controls outline.

   Notice that there only main effects. In this example, you are only interested in a model that contains the main effects of your four factors. However, if you wanted your design to be capable of estimating additional effects, you add them in this outline.

6. In the Design Generation panel:
   - Keep the Number of attributes that can change within a choice set at 4.
   - Keep the Number of profiles per choice set at 2.
   - Type 12 for the Number of choice sets per survey.

   In this example, the respondents evaluate 12 choice sets.
– Keep the **Number of surveys** at 1.
– Type 10 for the **Expected number of respondents per survey**.

In this example, there are ten respondents.

**Figure 18.3 Completed Design Generation Panel**

Note: Setting the Random Seed in step 7 reproduces the exact results shown in this example. In constructing a design on your own, this step is not necessary.

7. (Optional) Click the Choice Design red triangle and select **Set Random Seed**. Type 12345 and click **OK**.
8. Click **Make Design**.

There are 12 choice sets, each consisting of two coffee profiles.
9. Select **Output separate tables for profiles and responses**.

This places the descriptions of the choice sets in a data table called Choice Profiles. A second data table (called Choice Runs) is constructed to facilitate entry of the response information.
10. Click **Make Table**.

The Choice Profiles table shows the 12 choice sets, each consisting of two profiles. The Choice Runs table enables you to record the preferred profile in the column `Response` using the profile ID. Enter 1 if Choice1 is the preferred profile or 2 if Choice 2 is the preferred profile. Alternatively, if the respondent has no preference, leave the response missing.

The **Choice** script in the Choice Profiles table facilitates analysis of experimental results. It opens a completed launch window for a Choice Model. For information about Choice Models, see **Consumer Research**.

The **DOE Dialog** script in the Choice Profiles table relaunches the design dialog.
Example of a Choice Design with Analysis

In this example, a computer manufacturer is interested in manufacturing a new laptop and wants information about customer preferences before beginning an expensive development process. The manufacturer decides to construct a design consisting of two sets of profiles that will be administered to ten respondents. The goal of the choice design is to understand how potential laptop purchasers view the advantages of a collection of four attributes:

- size of hard drive disk (40 GB or 80 GB)
- speed of processor (1.5 GHz or 2.0 GHz)
- battery life (4 Hrs or 6 Hrs)
- cost of computer ($1000, $1200 or $1500)

To construct the design for the ten respondents, you first conduct a small pilot study using only one respondent. Then you analyze the results and use the parameter estimates as prior information in designing the final study for the ten respondents.

Create a Choice Design for a Pilot Study

In this section, you construct a choice design for a one-respondent study.

Define Factors and Levels

In this example, you load the factors from an existing table. When designing a new experiment on your own, enter the factors manually.

1. Select DOE > Consumer Studies > Choice Design.
2. Select Help > Sample Data Library and open Design Experiment/Laptop Factors.jmp.
3. Click the Choice Design red triangle and select Load Factors.

Figure 18.4 Choice Design Window with Attributes Defined
Create the Design

1. Click Continue.

2. This pilot survey will be given to a single respondent. The default values in the DOE Model Controls, Prior Specification, and Design Generation panels are appropriate as is.

3. (Optional) Click the Choice Design red triangle and select Set Random Seed. Type 12345 and click OK.

4. Click Make Design.

   Note: Setting the Random Seed in step 3 reproduces the exact results shown in this example. In constructing a design on your own, this step is not necessary.

Figure 18.5 Pilot Design

The single survey contains eight choice sets, each consisting of two laptop profiles.

5. Verify that the Combine profiles and responses in one table option is selected.

   This places the choice sets and the survey results in the same table.

6. Click Make Table.

This survey was designed assuming no prior information. For this reason, some choice sets might not elicit useful information. The plan is to obtain survey results from the single respondent, analyze the results, and then use the results from the pilot survey as prior information in designing the final survey.
Analyze the Pilot Study Data

Now that the pilot survey design is complete, it is administered to single respondent. The respondent chooses one profile from each set, entering 1 for the chosen profile and 0 for the rejected profile. You will analyze the results using the Choice platform.

**Note:** For more information about the Choice platform, see *Consumer Research*.

1. Select Help > Sample Data Library and open Design Experiment/Laptop Design.jmp.
2. Run the **Choice** script.

**Figure 18.6** Choice Model Launch Window

![Choice Model Launch Window](image)

The only grouping variable is **Choice Set** because there is a single survey and a single respondent.

3. Click **Run Model**.
To construct the final choice design that you will give to ten respondents, you need prior means and variances for the parameter estimates. The analysis in Figure 18.7 gives estimates of the parameter means (Estimate) and estimates of their standard errors (Std Error). You will treat the standard errors as prior estimates of the standard deviations. Next, to calculate estimates of the variances of the attributes, construct a JMP table and square the standard errors.

4. Right-click in the Parameter Estimates report and select Make into Data Table.

5. In the new data table, right-click in the Std Error column header and select New Formula Column > Transform > Square.

A column called Std Error^2 is added to the data table. Its values will serve as your estimates of the prior variance for the choice model parameters.

**Note:** Do not close the Untitled data table at this point.

---

**Design the Final Choice Experiment Using Prior Information**

In this section, you use the prior information obtained from the pilot laptop study to construct a final design. The final design will be administered to a set of ten participants.

1. Select Help > Sample Data Library and open Design Experiment/Laptop Factors.jmp.
2. Select DOE > Consumer Studies > Choice Design.
3. Click the Choice Design red triangle and select Load Factors.
4. Click **Continue**.

5. From the Untitled table, enter the values in the Estimate column into the Prior Mean outline in the Choice Design window (Figure 18.9).

   You can copy and paste the entire column from the Untitled table, then click in the Disk Size text box under **Prior Mean** in the Prior Mean outline, right-click, and select Paste.

6. From the Untitled table, enter the values in the Std Error^2 column into the diagonal entries in the Prior Variance Matrix outline in the Choice Design window (Figure 18.9). Enter these one-by-one, rounded to three decimal places.

**Figure 18.9** Prior Mean and Variance Information from Pilot Study

7. In the Design Generation panel, enter 2 for the **Number of surveys** and five for the **Expected number of respondents per survey**.

   This gives instruments for a total of 10 respondents and allows for two different sets of profiles.

8. Click **Make Design**.

9. Click **Make Table**.

   The design table has 160 rows. There are 16 rows for each of the ten study respondents. Each respondent has 8 choice sets, each with 2 profiles. There are two surveys, each given to 5 respondents. The 160 rows result from the following calculation: 2 profiles * 8 choice sets * 2 surveys * 5 respondents = 160 rows.

   The final design is now ready to be administered to the 10 respondents.
Run the Design and Analyze the Results

In this section, you analyze the results obtained when you obtain results from the final design. In particular, you want to know how changing the price or other characteristics of a laptop affects its desirability as perceived by potential buyers. This desirability is called the utility value of the laptop attributes.

Determine Significant Attributes

1. Select Help > Sample Data Library and open Design Experiment/Laptop Results.jmp.
2. Run the Choice script.

Figure 18.10 Choice Model Launch Window

There are three grouping variables, Respondent, Survey, and Choice Set, because there are multiple surveys and respondents.

3. Click Run Model.
The Effect Summary and Likelihood Ratio Tests outlines indicate that Disk Size, Speed, and Price are significant at the 0.05 level, and that Battery Life is marginally significant.

**Find Unit Cost and Trade Off Costs**

Next, use the Profiler to see the utility value and how it changes as the laptop attributes change.

1. Click the Choice Model red triangle and select **Utility Profiler**.

**Figure 18.12** Utility Profiler at Price = $1000

When each attribute value is set to its lowest value, the Utility value is –0.3406. The first thing that you want to do is determine the unit utility cost.

2. Move the slider for Price to $1,500.
When Price changes from $1,000 to $1,500, the Utility changes from –0.3406 to –2.3303. That is, raising the price of a laptop by $500.00 lowers the utility (or desirability) approximately 2 units. Therefore, you can estimate the unit utility cost to be approximately $250.00.

With this unit utility cost estimate, you can now vary the other attributes, note the change in utility, and find an approximate monetary value associated with attribute changes. For example, the most significant attribute is Speed (Figure 18.11).

3. In the Utility Profiler, set Price back to $1,000, its lowest value, and change Speed to 2.0 GHz, its higher value.

The Utility value changes from the original value shown in Figure 18.12 of –0.3406 to 0.9886, for a total change of 1.3292 units. Using the utility cost estimate or $250.00, the increase in price for a 2.0 GHz laptop over a 1.5 GHz laptop can be computed to be 1.3292*$250.00 = $332.30. This is the dollar value that the Choice study indicates that the manufacturer can use as a basis for pricing this laptop attribute. You can make similar calculations for the other attributes.
Choice Design Window

The Choice Design window walks you through the steps to construct a choice design for modeling attribute preferences. You can specify an assumed model and prior information. The Choice Design window updates as you work through the design steps. The outlines, separated by buttons that update the outlines, follow the flow in Figure 18.15.

Figure 18.15 Choice Design Flow

Attributes

Attributes in a choice design can only be categorical.

Tip: When you have completed the Attributes outline, consider selecting Save Factors from the red triangle menu. This saves the attribute names, roles, and levels in a data table that you can later reload and reuse.

Figure 18.16 Attributes Outline

The Attributes outline contains the following buttons:

Add Factor  Adds an attribute with the selected number of levels.

Remove  Removes the selected attributes.

Add N Factors  Adds multiple attributes. Enter the number of attributes to add, click Add Factor, and then select the number of levels. Repeat Add N Factors to add multiple attributes with different numbers of levels.
The Attributes outline contains the following columns:

**Name**  The name of the attribute. Attributes are given default names of X1, X2, and so on. To change a name, double-click it and type the desired name.

**Role**  Specifies the Design Role of the attribute as Categorical.

**Attribute Levels**  The attribute name or description. To insert Attribute Levels, click the default levels and type the desired names.

**Editing the Attributes Outline**
- To edit the Name of an attribute, double-click the attribute name.
- To edit an Attribute Level, click the level.

**Attribute Column Properties**
For each attribute, JMP saves the Value Order column property to the data tables constructed by the Choice platform. The Value Order column property specifies that levels appear in reports using the ordering specified in the Attributes outline. See “Value Order”.

**Model**
The model outline consists of two parts:
- You can specify your assumed model, which contains all the effects that you want to estimate. See “DOE Model Controls”.
- You can specify prior knowledge about the attribute levels, which can result in a better design. See “Prior Specification”.

**DOE Model Controls**
Specify your assumed model in the DOE Model Controls outline. All main effects are included by default. Click the Interactions button to add all two-way interactions.

**Figure 18.17  DOE Model Controls Outline**
When you construct your design table, JMP saves a Choice script to the data table. The Choice script launches the Choice Platform with the model selected in the DOE Model Controls outline.

The DOE Model Controls outline contains the following buttons:

**Main Effects**  Adds main effects for all attributes in the model.

**Interactions**  Adds all second-order interactions. If you do not want to include all of the interactions, select the interactions that you want to remove and click **Remove Term**.

**Remove Term**  Removes selected effects.

### Prior Specification

Enter specifications for a multivariate normal prior distribution on the model parameters. Enter the prior distribution’s mean in the Prior Mean outline and its covariance matrix in the Prior Variance outline.

![Prior Specification Outline](image)

You can ignore the prior specifications using these options:

**Ignore prior specifications. Generate the Utility Neutral design.** Sets the prior means to 0 and generates a locally D-optimal design. This design is called a utility-neutral design. See Huber and Zwerina (1996).

**Ignore prior variance. Generate the local design for the prior mean.** Generates a locally D-optimal design. The local design takes into account the prior on the mean but ignores the covariance matrix. See Huber and Zwerina (1996).

### Design Generation

Enter specifications that define the structure for your design in the Design Generation panel.
Enter a number for each of the following items:

**Number of attributes that can change within a choice set**  Enter a number less than or equal to the total number of attributes. This is often set to the total number of attributes. However, if you are comparing many attributes and want to simplify the selection process for respondents, set this to a number that is smaller than the total number of attributes.

**Number of profiles per choice set**  Enter the number of profiles that a respondent must choose from in stating a preference.

**Number of choice sets per survey**  Enter the number of preferences that you want to obtain from each respondent.

**Number of surveys**  Enter the number of distinct collections of choice sets. This is useful if you want to administer surveys to multiple respondents.

**Expected number of respondents per survey**  Enter the total number of respondents divided by the number of surveys.

**Make Design**

Once you have completed the Design Generation outline, click **Make Design** to generate the design. The design appears in the Design outline.

**Design**

The Design outline shows the runs for a design that is optimal, given your selections. Review the design to ensure that it meets your needs.
Figure 18.20 Design Outline for Coffee Example

<table>
<thead>
<tr>
<th>Design</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Choice Set</td>
<td>Grind</td>
<td>Temperature</td>
<td>Time</td>
</tr>
<tr>
<td>1</td>
<td>Coarse</td>
<td>195</td>
<td>3</td>
</tr>
<tr>
<td>1</td>
<td>Medium</td>
<td>200</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>Medium</td>
<td>205</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>Coarse</td>
<td>200</td>
<td>3.5</td>
</tr>
<tr>
<td>3</td>
<td>Coarse</td>
<td>195</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>Medium</td>
<td>200</td>
<td>3.5</td>
</tr>
<tr>
<td>4</td>
<td>Coarse</td>
<td>200</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>Medium</td>
<td>205</td>
<td>3.5</td>
</tr>
<tr>
<td>5</td>
<td>Coarse</td>
<td>195</td>
<td>3.5</td>
</tr>
<tr>
<td>5</td>
<td>Coarse</td>
<td>200</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>Medium</td>
<td>195</td>
<td>3.5</td>
</tr>
<tr>
<td>6</td>
<td>Medium</td>
<td>205</td>
<td>4</td>
</tr>
<tr>
<td>7</td>
<td>Coarse</td>
<td>195</td>
<td>3.5</td>
</tr>
<tr>
<td>7</td>
<td>Medium</td>
<td>200</td>
<td>3</td>
</tr>
<tr>
<td>8</td>
<td>Medium</td>
<td>195</td>
<td>4</td>
</tr>
<tr>
<td>8</td>
<td>Coarse</td>
<td>205</td>
<td>3</td>
</tr>
<tr>
<td>9</td>
<td>Coarse</td>
<td>200</td>
<td>3.5</td>
</tr>
<tr>
<td>9</td>
<td>Medium</td>
<td>200</td>
<td>3</td>
</tr>
<tr>
<td>10</td>
<td>Medium</td>
<td>200</td>
<td>3</td>
</tr>
<tr>
<td>10</td>
<td>Coarse</td>
<td>205</td>
<td>4</td>
</tr>
<tr>
<td>11</td>
<td>Coarse</td>
<td>200</td>
<td>3.5</td>
</tr>
<tr>
<td>11</td>
<td>Medium</td>
<td>195</td>
<td>4</td>
</tr>
<tr>
<td>12</td>
<td>Coarse</td>
<td>200</td>
<td>4</td>
</tr>
<tr>
<td>12</td>
<td>Medium</td>
<td>205</td>
<td>4</td>
</tr>
</tbody>
</table>

Note: Figure 18.20 is taken from the coffee example. See “Example of a Choice Design”.

Note: The algorithm for finding an optimal design is based on a random starting design. Because of this, the design you obtain is not unique. The design algorithm will generate different designs when you click the Back and Make Design buttons repeatedly.

Output Options

Select one of the following output options:

Output separate tables for profiles and responses  Displays two data tables:
- The Choice Profiles table lists the profiles in each row, identified by Survey and Choice Set columns. Within a choice set, the profiles are identified by Choice ID. This table is useful for constructing the survey instruments.
- The Choice Runs table provides an empty Response column where you can enter respondent preferences. Each row corresponds to a single choice set. The rows are sorted by Respondent, Survey, and Choice Set. The choice set IDs are given in the next columns, followed by the Response column. Enter the choice set ID for the respondent’s preference in the Response column.

Combine profiles and responses in one table  Provides a single Choice Profiles table with an empty Response Indicator column where you can enter respondent preferences. Each row corresponds to a single profile. The table is sorted by Respondent, Survey, and
Choice Set. Enter the value 1 (or another nonzero numerical indicator) for the respondent’s preferred profile and a 0 indicator for the other profiles in that choice set.

**Note:** The values you enter in the Response Indicator column must be numerical.

**Make Table**

Click **Make Table** to construct the table or tables that you selected in “Output Options”. In the table panel of the Choice Profiles table, there is a **Choice** script. Run the script and then click **Run Model** to analyze your experimental results.

For information about the Choice Model report, see *Consumer Research*.

**Choice Design Options**

**Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

**Note:** It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting **Column Properties > Design Role**. In the Design Role area, select the appropriate role.

**Load Factors**  Loads factors that you saved using the Save Factors option.

**Set Random Seed**  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:

- initializing search algorithms for design generation
- randomizing Run Order for design construction
- selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking **Make Design**.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

**Simulate Responses**  Adds response probabilities and a column containing a choice simulation formula to the design table. Select this option before you click Make Table.
When you click Make Table, the following occur:

- A new column that contains a simulated choice response formula is added to the design table. The formula and values are based on the model that is specified in the design window.
- A Model window appears where you can set the values of the marginal utilities for model effects.
- A script called **Choice Simulate** is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the marginal utilities.

When you click Apply, the formula for the simulated choice response values is updated in the Choice Simulated column. If you click Apply again, the formula and values in this column are updated.

See “Simulate Responses”.

**Note:** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see *Basic Analysis*.

### Number of Starts

Enables you to specify the number of random starts used in constructing the design. See “Bayesian D-Optimality and Design Construction”.

### Advanced Options

Not available for Choice Designs.

### Save Script to Script Window

Creates the script for the design that you specified in the Choice Design window and saves it in an open script window.

## Technical Details

### Bayesian D-Optimality and Design Construction

The Bayesian D-optimality criterion is the expected logarithm of the determinant of the information matrix of the maximum likelihood of the parameter estimators in the multinomial logit model, taken with respect to the prior distribution. The Choice Design platform maximizes this expectation with respect to a sample of parameter vectors that represents the prior probability distribution. See Kessels et al. (2011).

For partial profile designs, JMP uses a two-stage design algorithm:

1. The constant attributes in each choice set are determined using an *attribute balance* approach.
2. The levels of the non-constant attributes are determined using Bayesian D-optimality.
Attribute balance means that the algorithm attempts to balance the number of times each attribute is held constant in the entire design. If two or more attributes are held constant, the algorithm attempts to balance the occurrence of pairs of attributes held constant in the design.

The levels of the non-constant attributes are determined to optimize the Bayesian D-optimal criterion. A random starting design is found. Then levels of the non-constant attributes are generated using a coordinate-exchange algorithm and evaluated until the Bayesian D-optimality criterion is optimized. The calculations, which involve integration with respect to a multivariate normal prior, use the quadrature method described in Gotwalt et al. (2009).

**Note:** The Bayesian D-optimality criterion can result in choice sets where some non-constant attributes have identical levels. This situation occurs when varying the non-constant levels within a profile would result in uninformative choice sets where all profiles have very high or very low probabilities.

### Utility-Neutral and Local D-Optimal Designs

You can use the Choice Design platform to generate a utility-neutral design by setting prior means to 0. In a utility-neutral design, all choices within a choice set are equally probable. See Huber and Zwerina (1996).

You can also generate a local D-optimal design. The local design takes into account the prior of the mean, but does not include any information from a prior covariance matrix. See Huber and Zwerina (1996).
MaxDiff (maximum difference scaling) studies are an alternative to studies that use standard preference scales to determine the relative importance of items being rated. In a MaxDiff study, a respondent reports only the most and least preferred options from among a small set of choices. This forces respondents to rank options in terms of preference, which often results in rankings that are more definitive than rankings obtained using standard preference scales.

Use the MaxDiff platform when you need to construct a design consisting of choice sets for one factor that can be presented to respondents as part of a MaxDiff study. Conduct your study and then analyze your data use the MaxDiff analysis platform.

**Figure 19.1  A MaxDiff Design Table**

<table>
<thead>
<tr>
<th>Subject</th>
<th>Choice Set</th>
<th>Candy</th>
<th>Choice</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Reese’s Cups</td>
<td>•</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>Hershey Bar</td>
<td>•</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>Snickers</td>
<td>•</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>Butterfinger</td>
<td>•</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>Butterfinger</td>
<td>•</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
<td>Heath Bars</td>
<td>•</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>Plain M&amp;M’s</td>
<td>•</td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>Snickers</td>
<td>•</td>
</tr>
<tr>
<td>9</td>
<td>3</td>
<td>Plain M&amp;M’s</td>
<td>•</td>
</tr>
<tr>
<td>10</td>
<td>3</td>
<td>Snickers</td>
<td>•</td>
</tr>
<tr>
<td>11</td>
<td>3</td>
<td>Peanut M&amp;M’s</td>
<td>•</td>
</tr>
<tr>
<td>12</td>
<td>3</td>
<td>Hershey Bar</td>
<td>•</td>
</tr>
<tr>
<td>13</td>
<td>4</td>
<td>Snickers</td>
<td>•</td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>Peanut M&amp;M’s</td>
<td>•</td>
</tr>
<tr>
<td>15</td>
<td>4</td>
<td>Reese’s Cups</td>
<td>•</td>
</tr>
<tr>
<td>16</td>
<td>4</td>
<td>Heath Bars</td>
<td>•</td>
</tr>
</tbody>
</table>
Contents

Overview of the MaxDiff Design Platform .......................................................... 571
Example of a MaxDiff Design ................................................................. 571
MaxDiff Design Launch Window .............................................................. 575
MaxDiff Window ................................................................. 575
   Design Options Outline ................................................. 575
   Design Outline ................................................. 576
   Pairwise Incidence Matrix ............................................. 576
   Make Table ......................................................... 576
MaxDiff Options ................................................................. 576
Overview of the MaxDiff Design Platform

A choice set is a collection of items from which a respondent must select an item that is most preferred (best item) and one that is least preferred (worst item). Use the MaxDiff platform to specify the number of items that appear in a choice set and the number of choice sets to be presented to a respondent.

The MaxDiff platform provides you with a single survey. If you have several respondents, you can administer the same survey to all respondents or construct a survey for each respondent.

The MaxDiff design is constructed to match the incidence matrix of a balanced incomplete block design as closely as possible. This implies that each pair of items occurs equally often in the design. If the number of choice sets allows a balanced incomplete block to be constructed for the specified number of items in a choice set, the design that is constructed is a balanced incomplete block design.

The items or profiles are considered to be the levels of the treatment factor. The choice sets are considered to be blocks. In a MaxDiff study, the block size is smaller than the number of treatments.

Example of a MaxDiff Design

You are the purchaser for your company’s office supplies and you need to buy candy for a holiday party. First, you want to determine which candy types people prefer. To figure this out, you conduct a MaxDiff study.

You ask five randomly chosen associates to rate seven types of candies. Based on your experience with previous studies, you realize that it is difficult for raters to rank seven types of items in order of preference. Instead, you create a design that consists of choice sets of size four. To keep the study manageable, you structure the survey as a MaxDiff study: you ask each associate to specify his or her most preferred and least preferred candy in each of the seven choice sets. (These selections result in a balanced incomplete block design. See Cochran and Cox (1957).) You administer the same survey to each associate.

Create the Design

Construct a table that lists the items or profiles for your choice sets. In this example, your table of items, Candy Profiles.jmp, is already constructed.

1. Select Help > Sample Data Library and open Design Experiment/Candy Profiles.jmp.
   The table lists the seven candy types of interest.
2. Select DOE > Consumer Studies > MaxDiff Design.
3. From the Select Columns list, select Candy and click **X, Factor**.
4. Click **OK**.
5. In the Design Options outline, do the following:
   - Set the **Number of Profiles per Choice Set** to 4.
   - Set the **Number of Choice Sets** to 7.

**Note:** Setting the Random Seed in step 6 reproduces the exact results shown in this example. In constructing a design on your own, this step is not necessary.

6. (Optional) Click the MaxDiff Study red triangle and select **Set Random Seed**. Type 12345 and click **OK**.
7. Click **Make Design**.

   The Design outline shows 7 choice sets, each consisting of 4 candy types. The Pairwise Incidence Matrix provides a matrix of the number of choice sets in which each pair of candy types appear together. The diagonal of the matrix is the number of choice sets each candy type appears in. For this example, each candy appears in 4 choice sets and appears with each other candy types in two of the four choice sets.

8. Click **Make Table**.

**Figure 19.2** Partial Design Table for Candy Preference Survey

<table>
<thead>
<tr>
<th>Subject</th>
<th>Choice Set</th>
<th>Candy</th>
<th>Choice</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Reese’s Cups</td>
<td>•</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>Hershey Bar</td>
<td>•</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>Snickers</td>
<td>•</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>Butterfinger</td>
<td>•</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>Butterfinger</td>
<td>•</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>Heath Bars</td>
<td>•</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>Plain M&amp;Ms</td>
<td>•</td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>Snickers</td>
<td>•</td>
</tr>
<tr>
<td>9</td>
<td>1</td>
<td>Plain M&amp;Ms</td>
<td>•</td>
</tr>
<tr>
<td>10</td>
<td>1</td>
<td>Snickers</td>
<td>•</td>
</tr>
<tr>
<td>11</td>
<td>1</td>
<td>Peanut M&amp;Ms</td>
<td>•</td>
</tr>
<tr>
<td>12</td>
<td>1</td>
<td>Hershey Bar</td>
<td>•</td>
</tr>
<tr>
<td>13</td>
<td>1</td>
<td>Snickers</td>
<td>•</td>
</tr>
<tr>
<td>14</td>
<td>1</td>
<td>Peanut M&amp;Ms</td>
<td>•</td>
</tr>
<tr>
<td>15</td>
<td>1</td>
<td>Reese’s Cups</td>
<td>•</td>
</tr>
<tr>
<td>16</td>
<td>1</td>
<td>Heath Bars</td>
<td>•</td>
</tr>
</tbody>
</table>

The design table contains a **Choice** column for recording preferences. For each choice set, record a 1 for the most preferred candy, a -1 for the least preferred, and a 0 for the other two candies.
Analyze the Study Results

You conduct the study and record your data in Candy Survey.jmp.

1. Select Help > Sample Data Library and open Design Experiment/Candy Survey.jmp.
   The table shows the results of presenting the survey to each of five respondents, listed in the Subject column.
2. Select Analyze > Consumer Research > MaxDiff.
3. Click Select Data Table, select Candy Survey, and click OK.
4. Assign column roles:
   – Select Choice and click Response Indicator.
   – Select Subject and click Subject ID.
   – Select Choice Set and click Choice Set ID.
   – Select Candy and click Add in the Construct Profile Effects panel.

Because you designated the Best choice as 1 and the Worst choice as -1, you make no change to the Best and Worst choice indicators at the bottom left of the launch window.

5. Click Run Model.
The report indicates that Candy is significant. The three candy types with the highest utilities are Plain M&Ms, Reese’s Cups, and Peanut M&Ms.

6. Click the MaxDiff Model red triangle and select All Levels Comparison Report.

The comparison report indicates which pairs of candy types differ significantly in terms of utility. The third entry in each cell is the $p$-value for the difference defined by the row item’s utility minus the column item’s utility. The intensity of the color for the $p$-value indicates how significant a difference is. The shading, blue or red, indicates whether the difference (row - column) is negative or positive. The $p$-values are not adjusted to control the multiple comparison error rate and should be used only as a guide. For more information about the All Level Comparisons Report, see Consumer Research.
MaxDiff Design Launch Window

To use the MaxDiff Design platform, you need a starting data table. Your starting data table must contain a column of character data that lists the items to be presented to respondents for rating.

With your starting data table active in JMP, select **DOE > Consumer Studies > MaxDiff Design**. If you have no active data tables, you are prompted to navigate to your starting data table.

**Figure 19.6** MaxDiff Launch Window using Candy Profiles.jmp

*X, Factor*  The character column that contains the items that respondents will rate.

MaxDiff Window

The MaxDiff Study window updates as you work through the design steps. The outlines, separated by buttons that update the outlines, follow the flow in **Figure 19.7**

**Figure 19.7** MaxDiff Design Flow

The MaxDiff Study window opens showing the Design Options outline. Once you click Make Design, the Design outline appears. To construct the design table, click Make Table.

Design Options Outline

Specify the following:

**Number of Profiles per Choice Set**  The number of items to be included in each choice set.
**Number of Choice Sets**  The total number of sets of items to be presented to and rated by respondents.

**Design Outline**

The Design outline identifies the choice sets using consecutive positive integers. The items that comprise each choice set are listed.

**Pairwise Incidence Matrix**

The Pairwise Incidence Matrix outline provides a matrix of the number of choice sets in which each pair of factor levels appear together. The diagonal of the matrix is the number of choice sets each factor level appears in.

**Make Table**

The Make Table button creates the design table. The design table consists of four columns:

- **Subject**  Initially populated by ones. Replace with appropriate identifiers for respondents.

  **Tip:** To easily add respondent identifiers, see *Using JMP*. Use Columns > Recode to change the identifiers to names.

- **Choice Set**  A designator for each choice set.

- **Factor**  The levels of the factor that you specified. These are the items in the choice set.

- **Choice**  A column where you can enter results. Use a numeric value to indicate the best choice, the worst choice, and choices in between. The values 1, -1, and 0 are typically used and are required for analysis by the MaxDiff analysis platform (located at Analyze > Consumer Research > MaxDiff).

**MaxDiff Options**

- **Set Random Seed**  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:
  - initializing search algorithms for design generation
  - randomizing Run Order for design construction
selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking Make Design.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

**Simulate Responses** Select this option to simulate response values. When you click Make Table, a Simulate Choice window opens along with the design table, and Probability and Choice Simulated columns are added to the design table. The Choice Simulated formula column contains random responses and the Probability formula column contains their probabilities.

**Caution:** To change the model used in simulating the responses, enter values in the Marginal Utility column in the Simulate Choice window for all factor levels but the last. Because the marginal utilities must sum to zero, you are not permitted to edit the Marginal Utility for the last level. Once you have specified the remaining Marginal Utility values, the last level of the factor is adjusted accordingly.

**Number of Starts** The number of random starts used in constructing the design. This value is set to 10 by default.

**Advanced Options** Not applicable for MaxDiff Designs.

**Save Script to Script Window** Creates the script for the design that you specified and places in an open script window.
Covering arrays are used in testing deterministic systems where failures occur as a result of interactions among components or subsystems. The design goal is to reveal if any interaction induces a failure in the system. Application areas include software, circuit, and network design.

Since the tests are deterministic, the emphasis driving the design is the need to cover all required interactions. The Covering Arrays platform constructs highly efficient covering arrays. You can also exclude factor level combinations that are not feasible for your testing protocol.

**Figure 20.1**  Strength 3 Covering Array
# Contents

- Overview of Covering Arrays ..................................................... 581
- Example of a Covering Array with No Factor Level Restrictions ...................... 583
  - Create the Design ............................................................. 583
  - Analyze the Experimental Data .............................................. 585
- Example of a Covering Array with Factor Level Restrictions .......................... 587
  - Create the Design ............................................................. 588
  - Analyze the Experimental Data .............................................. 592
- Covering Array Window ............................................................. 593
  - Factors ........................................................................... 594
  - Restrict Factor Level Combinations ...................................... 595
  - Design ............................................................................ 597
  - Metrics ............................................................................ 600
  - Output Options ................................................................... 600
  - The Covering Array Data Table ............................................. 601
- Covering Array Options ............................................................... 602
- Technical Details for Covering Arrays ............................................. 603
  - Algorithm for Optimize ....................................................... 604
  - Formulas for Metrics ............................................................ 604
Overview of Covering Arrays

You can use covering arrays to test systems where failures occur as a result of interactions among components or subsystems. Covering arrays are often used in areas such as software, circuit, and network design, where the following conditions are likely to be true:

- The cost of testing is usually high.
- Testing focuses on revealing interactions for which failures occur.
- A test run is typically deterministic and results in either success or failure.
- Replicate runs are wasteful because they yield identical results.
- The efficiency of a design is based on how many of the possible conditions are covered without including redundant runs.

Because systems testing is expensive, reducing the amount of testing is critical. Testing all possible interactions is usually prohibitive and often unnecessary. Experience shows that most failures result from the interaction of a small number of components. The size of the largest combination of components likely to drive a failure, called the strength, drives the size of the design.

In the Covering Array platform, you specify the required strength of your design. If appropriate, you define factor level combinations that are not permitted. The Covering Array platform constructs a highly efficient design that meets your requirements. It provides metrics that you can use to assess the quality of the design in terms of its coverage. It also provides a script in the data table for the design that enables you to analyze your results.

Covering arrays are often used in situations where certain combinations of factor level settings are not feasible. The Covering Array platform is able to find very efficient covering arrays even when restrictions are placed on factor level combinations.

For background on the structure of covering arrays and algorithms for computing them, see Colbourn (2004), Colbourn et al. (2011), Hartman and Raskin (2004), and Martirosyan (2003). For more information about covering arrays with restrictions on factor levels, see Cohen et al. (2007) and Morgan (2009).

Covering Arrays and Strength

A covering array of strength \( t \) is a design that tests all combinations of \( t \) factor level settings. Consider an interaction defined by specific settings for \( k \) factors. If failures occur for all tests involving that interaction, then that interaction detects a failure. Using this terminology, a strength \( t \) design enables you to detect failures associated with any interaction of up to \( t \) factors.
In the literature, covering arrays are also referred to as *factor covering designs*. For background and more information, see Yilmaz et al. (2014), Cohen et al. (2003), and Dalal and Mallows (1998).

To illustrate the nature of covering arrays, consider a situation involving seven categorical factors each with two levels. You want to test all pairwise combinations of factor levels.

A design that might be used in this situation is the 8-run resolution III main effects design:

**Figure 20.2** A Resolution III Design with Strength 2

Note that this factorial design is a strength 2 covering array because all pairwise combinations of levels of any two factors appear. For example, for $X_1$ and $X_2$, the following combinations each appear twice:

- L2 and L1
- L2 and L2
- L1 and L1
- L1 and L2

However, a strength 2 covering array needs only 6 runs:

**Figure 20.3** Strength 2 Covering Array

All pairwise combinations of levels of any two factors appear at least once in the six runs. The Covering Array design is more efficient than the Resolution III design because it achieves strength 2 coverage with fewer runs.

The efficiency of a covering array is measured by the number of runs required to achieve the required coverage. The smaller the number of runs, the more efficient the design.
Example of a Covering Array with No Factor Level Restrictions

The data in this example pertain to interoperability in the area of software testing. There are four factors of interest:

- Web Browser (Safari, IE, Firefox, Chrome, Other)
- Operating System (Windows or macOS)
- RAM (4, 8, or 16 MB)
- Connection Speed at three settings (0-1, 1-5, or greater than 5 Mbps)

You are interested in finding out which combinations of these factors are likely to cause failures.

The response is whether the system functions properly for each combination of factor settings. Testing each combination of settings would require 90 (5x2x3x3) trials. To keep the run size manageable, you decide to require Strength 3 coverage, indicating that all combinations of any three factors are tested.

Create the Design

Create the Strength 3 covering array by following these steps.

2. Select DOE > Special Purpose > Covering Array.
3. From the menu next to Strength: t = , select 3.
4. Click the Covering Array red triangle, select Load Factors.

The Factors outline is populated with the four factors and their levels.
5. Click **Continue**.

   The Restrict Factor Level Combinations outline opens, where you can enter restrictions on the design settings. Because there are no restrictions for this design, do not change the default selection of **None**.

6. Click **Make Design**.

   The Design outline opens to show a 45-run design.

**Figure 20.5** Design and Metrics Outlines for Software Factors

In the Metrics outline, consider the row that corresponds to $t = 3$. The Coverage is 100%, indicating that the design covers 100% of the three-factor interactions. This is what you want, because you requested a Strength 3 design. For $t = 3$, the Diversity column indicates that 68.33% of the three-factor interactions that appear are distinct. There is some minor repetition of three-factor combinations.
For $t = 4$, the Coverage is 50%, indicating that the design covers half of the four-factor interactions. There are 90 possible distinct combinations of the four factor settings. The 45 runs in the design comprise one-half of these distinct combinations. The Diversity value of 100% reinforces the fact that none of the four-way interactions are repeated.

7. Click **Make Table**.

**Figure 20.6** Partial Design Table for Software Factors

The design is presented in a data table. Notice the following in the Table panel at the top left:
- The Design note indicates that this is a strength 3 covering array.
- The DOE Dialog script reproduces the Covering Array window settings.
- The Analysis script analyzes the experimental data.

**Analyze the Experimental Data**

Now that you have your design table, you can conduct your experiment and record your data in the *Response* column of the design table (**Figure 20.6**). Your experimental results are in the *Software Data.jmp* sample data table.

1. Select **Help > Sample Data Library** and open Design Experiment/Software Data.jmp.
2. In the Table panel, click the green triangle next to the **Analysis** script.
The Summary outline indicates that three tests failed and four tests did not result in a pass or fail outcome.

The Failure Analysis Details outline gives a breakdown of failures in terms of the associated three-way interactions. The outline lists only combinations of factor levels where all tests resulted in failure. If any test that involves a given three-way combination of settings results in success, then that three-way combination of settings cannot be responsible for system failure.

Two failures were associated with Web Browser set to Firefox, Operating System set to macOS, and RAM set to 8 MB. Notice that this combination led to failure regardless of the setting of Connection Speed.

3. Select the first line in the 3 Factor Interactions report.

This action selects the corresponding rows and columns in the data table.
Three failures were associated with combinations of Web Browser, RAM, and Connection Speed. Note that two of these failures, Firefox, 8 MB, 1-5 Mbps and Firefox, 8 MB, >5 Mbps, are among the two failures for the Web Browser, Operating System, and RAM interaction. Selecting any of these rows in the report selects the corresponding rows and columns in the data table.

Example of a Covering Array with Factor Level Restrictions

This example is patterned after an example described in Dalal and Mallows (1998). An originating phone (Near Phone) calls a receiving phone (Far Phone). Each phone call goes through an interface of type A or B. Five factors are of interest:

- Market: USA, UK, Canada, France, Mexico
- Near Phone: ISDN, Bus (Business), Coin, Res (Residential)
- Near Interface: A or B
- Far Phone: ISDN, Bus (Business), Coin, Res (Residential)
- Far Interface: A or B

You are interested in which combinations of pairs of these factors are likely to cause failures. However, certain combinations are not possible:

- An ISDN line on either phone (Near or Far) cannot use interface A.
• Business and Residential lines on the originating phone (Near) cannot use interface B.

Create the Design

The factors and their settings are given in the data table Phone Factors.jmp. Create a Strength 2 covering array by following these steps.

Load Factors

1. Select Help > Sample Data Library and open Design Experiment/Phone Factors.jmp. The Phone Factors.jmp data table contains the factors and their settings.
2. Select DOE > Special Purpose > Covering Array.
   Notice that the menu next to Strength: t = , is set to 2 by default.
3. Click the Covering Array red triangle and select Load Factors.
   The Factors outline is populated with the five factors and their levels.

   Figure 20.10 Factors Outline for Phone Factors

4. Click Continue.
   The Restrict Factor Level Combinations outline opens.

Restrict Factor Level Combinations

You can specify disallowed combinations in two ways:

• Use Disallowed Combinations Filter
• Use Disallowed Combinations Script
The filter gives an intuitive way to specify disallowed combinations. The script provides a quick and easy way to specify disallowed combinations, but requires that you have written or saved a script. In this example, if you do not want to specify combinations using the filter, skip to “Specify Disallowed Combinations Using a Script”.

Recall that the restrictions are the following:
- An ISDN line on either phone (Near or Far) cannot use interface A.
- Business and Residential phones on the originating phone (Near) cannot use interface B.

Specify Disallowed Combinations Using the Filter

Use this approach to enter disallowed combinations using the filter interface. Alternatively, you can paste a script as shown in “Specify Disallowed Combinations Using a Script”.

1. Select Use Disallowed Combinations Filter.
2. From the Add Filter Factors list, select Near Phone and Near Interface and click the Add button.
3. Press Ctrl and click ISDN under Near Phone and A under Near Interface.

Both blocks should turn dark. You have added the constraint that an ISDN line on the originating phone (Near) cannot use interface A.

4. Click OR.
5. From the Add Filter Factors list, select Far Phone and Far Interface and click the Add button.
6. Press Ctrl and click ISDN under Far Phone and A under Far Interface.

You have added the constraint that an ISDN line on the receiving phone (Far) cannot use interface A.

7. Click OR.
8. From the Add Filter Factors list, select Near Phone and Near Interface and click the Add button.
9. Press Ctrl and click Bus and Res under Near Phone and B under Near Interface.
   You have added the restriction that Business and Residential lines on the originating
   phone (Near) cannot use interface B.

**Figure 20.12** Completed Disallowed Combinations Filter

Specify Disallowed Combinations Using a Script

Alternatively, you can specify disallowed combinations by constructing a script. After loading
your factors ("Load Factors"), do the following:

1. Click **Continue**.
2. Select **Use Disallowed Combinations Script**.
3. Copy the following script and paste it in the Disallowed Combinations Expression script
   box:

   (Near Phone == "ISDN" & Near Interface == "A") | 
   (Far Phone == "ISDN" & Far Interface == "A") | 
   (Near Phone == "Bus" & Near Interface == "B") | 
   (Near Phone == "Res" & Near Interface == "B")
Chapter 20  
Design of Experiments Guide  
Example of a Covering Array with Factor Level Restrictions

Figure 20.13  Completed Disallowed Combinations Script Window

Construct the Design Table

Note: Setting the Random Seed in the next two steps reproduces the exact results shown in this example. When constructing a design on your own, these steps are not necessary.

1. Click the Covering Array red triangle and select Set Random Seed.
2. Enter 632 and click OK.
3. Click Make Design.
   The Design outline opens to show a 20-run design. A Metrics outline is added to the window.

Figure 20.14  Metrics Outline for Phone Design

The Metrics outline indicates that Strength 2 coverage is 100%. This means that all permissible two-factor combinations are represented in the design. The design also covers 65% of all three-factor combinations.

4. Click Make Table.
   The design is placed in a design table. A column for the response is provided, as well as various scripts.
Analyze the Experimental Data

Now that you have your design table, you can conduct your experiment and record your data in the Response column of the design table. Your experimental results are in the Phone Data.jmp sample data table.

1. Select Help > Sample Data Library and open Design Experiment/Phone Data.jmp.
2. In the Table panel, click the green triangle next to the Analysis script.
The Summary outline indicates that three tests failed.

The Failure Analysis Details outline contains a 2 Factor Interactions report, because a two-way interaction is the lowest level interaction that detects a failure.

The 2 Factor Interactions report shows the combinations that might have caused the three failures. It is possible that one combination, Near Interface set to A and Far Phone set to Coin, is responsible for all three failures. Or it is possible that two or three other combinations caused the three failures.

3. Select the first line in the 2 Factor Interactions report.

In the data table, rows 4, 16, and 19 are selected. Failures occur for these combinations, regardless of the settings for Market, Near Phone, and Far Interface. But note that other combinations of factor settings could account for these failures as well.
Factors

Add factors in the Factors outline.

Figure 20.18 Factors Outline

Add Factor  Enters the number of factors specified in Add N Factors. All factors are categorical. Select or specify the number of levels.

Remove  Removes the selected factors.

Add N Factors  Adds multiple factors with a specific number of levels. Enter the number of factors to add, click Add Factor, and select or specify the number of levels. Repeat Add N Factors to add multiple factors with different numbers of levels.

Strength t  Select a value to specify the strength of the array.

Tip: When you have completed your Factors panel, select Save Factors from the red triangle menu. This saves the factor names and values in a data table that you can later reload. See “Covering Array Options”.

Factors Table

The Factors table contains the following columns:

Name  The name of the factor. When a factor is added, it is given a default name of X1, X2, and so on. To change this name, double-click it and enter the desired name.

Role  Specifies the Design Role of the factor. The Design Role for all covering array factors is Categorical. The Design Role column property for the factor is saved to the data table. This property ensures that the factor is modeled appropriately.

Values  The settings for the factors. To insert Values, click the default values and enter the desired values. The value ordering in the design table is the order of the values as entered from left to right.
**Editing the Factors Table**

In the Factors outline, notice the following:

- To edit a factor name, double-click the factor name.
- Categorical factors have a down arrow to the left of the factor name. Click the arrow to add a level.
- To remove a factor level, click the value, click **Delete**, and click outside the text box.
- To edit a value, click the value in the Values column.

**Factor Column Properties**

For each factor, the Value Labels column property is saved to the design table. The Value Labels column property represents values in a column with specified labels. These labels are shown in the data table and are used in plots and reports. See “Value Labels”.

**Restrict Factor Level Combinations**

When you complete the Factors outline and click Continue, the Restrict Factor Level Combinations outline appears. This outline enables you to specify factor level combinations that are prohibited. Unless you have loaded a constraint or included one as part of a script, the **None** option is selected. To specify constraints, select one of the other options:

**Use Disallowed Combinations Filter** Defines sets of constraints based on restricting values of individual factors. You can define both AND and OR constraints. See “Use Disallowed Combinations Filter”.

**Use Disallowed Combinations Script** Defines disallowed combinations and other constraints as Boolean JSL expressions in a script editor box. See “Use Disallowed Combinations Script”.

**Use Disallowed Combinations Filter**

This option uses an adaptation of the Data Filter to facilitate specifying disallowed combinations. For detailed information about using the Data Filter, see *Using JMP*.

To add disallowed combinations:

1. Select factors from the Add Filter Factors list and click **Add**.
2. Specify the disallowed combinations by selecting levels.
Note: The red triangle options in the Add Filter Factors menu are the same as those found in the Select Columns panel of many platform launch windows. See Using JMP.

When you click Add, the initial panel is updated. The Disallowed Combinations control panel shows the selected factors and provides options for further control.

The Covering Array platform allows only categorical factors. For categorical factors, the possible levels are shown either as labeled blocks or, when the number of levels is large, as list entries. Select a level to disallow it. To select multiple levels, press Ctrl. The block or list entries are highlighted to indicate the levels that have been disallowed. When you add a factor to the Disallowed Combinations panel, the number of levels of the categorical factor is given in parentheses following the factor name.

Disallowed Combinations Options

Clear    Clears all disallowed factor level settings that you have specified. This does not clear the selected factors.

AND    Opens the Add Filter Factors list. Selected factors become an AND group. Any combination of factor levels specified within an AND group is disallowed.

To add a factor to an AND group later on, click the group’s outline to see a highlighted rectangle. Select AND and add the factor.

To remove a single factor, select **Delete** from its red triangle menu.

OR    Opens the Add Filter Factors list. Selected factors become a separate AND group. For AND groups separated by OR, a combination is disallowed if it is specified in at least one AND group.

Red Triangle Options for Factors

A factor can appear in several OR groups. An occurrence of the factor in a specific OR group is referred to as an **instance** of the factor.

Delete    Removes the selected instance of the factor from the Disallowed Combinations panel.

Clear Selection    Clears any selection for that instance of the factor.

Invert Selection    Deselects the selected values and selects the values not previously selected for that instance of the factor.

Display Options    Changes the appearance of the display.

Blocks Display    Shows each level as a block.

List Display    Shows each level as a member of a list.
**Single Category Display**  Shows each level.

**Check Box Display**  Adds a check box next to each value.

**Radio Box Display**  Adds a radio selection next to each value for a single selection.

**Find**  (Available for categorical factors.) Provides a text box beneath the factor name where you can enter a search string for levels of the factor. Press Enter or click outside the text box to perform the search. Once **Find** is selected, Find options appear in the search panel black triangle menu. Options include Contain Terms, Contain Phrase, Starts with Phrase or Ends with Phrase, and Invert Result.

**Use Disallowed Combinations Script**

This option opens a script window where you insert a script that identifies the combinations that you want to disallow. The script must evaluate as a Boolean expression. When the expression evaluates as true, the specified combination is disallowed.

When creating the expression, use the name of the level in quotation marks. Do not use the ordinal value of the level. For example, **Figure 20.19** shows the script that you entered in the phone interface example, “Specify Disallowed Combinations Using a Script”.

**Figure 20.19**  Script Window Showing Names of Levels in Quotes

![Script Window](image)

**Design**

When you click Make Design, the Design and Metrics outlines appear. For designs that require extensive computation, a progress bar appears.

The Design outline shows the design that you have constructed. The first column lists a Run order. You might need to use the scroll bar to view all the runs. The remaining columns show factor settings for each run.
Optimize

Select Optimize to reduce the size of a design that was constructed by the Covering Array platform or that you have loaded using the Load Design red triangle option. Optimize is not available for designs constructed by the Covering Array platform that are known to be optimal. In particular, all unconstrained strength 2 designs for two-level factors constructed by the platform are optimal. Also, any unconstrained strength $t$ design for $t+1$ factors is optimal for any $t$.

For more information about the algorithm, see “Algorithm for Optimize”.

**Note:** Optimize is time intensive, but can be run repeatedly to yield incrementally better designs.

Use the **Maximum iterations** option to specify a maximum number of iterations to be used in optimizing the design.

**Unsatisfiable Constraints**

If a set of constraints prohibits the construction of a covering array where all required factor levels are represented, it is said to be *unsatisfiable*.

**Example of Unsatisfiable Constraints**

Consider a strength 2 design for three factors, each at three levels.

1. Select **DOE > Special Purpose > Covering Array**.
2. Next to **Add N Factors**, type 3.
3. From the **Add Factor** menu, select **3 Level**.
4. Click **Continue**.
5. Select **Use Disallowed Combinations Filter**.
6. From the **Add Filter Factors** list, select all three factors and click the **Add** button.
7. Press Ctrl and select the following levels:
   - For X1, select L1.
   - For X2, select L1, L2, and L3.
   - For X3, select L3.
Figure 20.20  Completed Restrict Factor Level Combinations Panel

Note: Setting the Random Seed in the next two steps reproduces the exact results shown in this example. When constructing a design on your own, these steps are not necessary.

8. Click the Covering Array red triangle and select **Set Random Seed**.
9. Enter 12345 and click **OK**.
10. Click **Make Design**.

Figure 20.21  Design and Metrics Outlines

A note beneath the Design outline indicates that one run has a missing setting due to the constraints. That run is run 9. To ensure that the covering array has strength 2, the
combination of $X_1$ set to $L_1$ and $X_3$ set to $L_3$ is required. But for these settings, the constraints prohibit all settings for $X_2$.

**Metrics**

The Metrics outline gives you information about how well the design meets the strength requirements. See Dalal and Mallows (1998) for background on these metrics for unconstrained designs.

- **$t$** The number of factors.

**Coverage** The ratio of the number of distinct $t$-factor settings that appear in the design to the total possible number of $t$-factor settings, expressed as a percentage. A $t$-coverage of 100% indicates that all possible $t$-factor settings are covered by the design. Note that each $t$-factor setting can appear multiple times.

For constrained and unsatisfiable designs, the definition of Coverage is adjusted for the number of $t$-factor settings that are possible once the constraints have been applied to all $t$-factor combinations. See “Formulas for Metrics”.

**Diversity** The ratio of the number of distinct $t$-factor settings in the design to the total number of occurrences of $t$-factor settings in the design, expressed as a percentage. The $t$-diversity measures how well the design avoids replication. A $t$-diversity of 100% indicates that no $t$-factor settings are repeated. A $t$-diversity of 50% indicates that the average number of times that distinct $t$-factor settings appear is two.

For constrained and unsatisfiable designs, the definition of Diversity is adjusted for the number of runs with missing settings. See “Formulas for Metrics”.

**Output Options**

- **Make Table** Constructs the Covering Array data table.

- **Back** Takes you back to the Factors outline. You can make changes to the previous outlines and regenerate the design.

**Note:** If you have defined Disallowed Combinations in the Restrict Factor Level Combinations outline, these are retained as a script. The script is shown in the Use Disallowed Combinations Script panel when you click Continue.
The Covering Array Data Table

The Covering Array data table contains a first column where you can enter the response. The remaining columns give the factor settings.

The Table panel in the upper left contains a Design note indicating that the design is a Covering Array and giving the Strength of the design. The Table panel also contains the following scripts.

**DOE Dialog**  Re-creates the Covering Array window that you used to generate the design table.

**Disallowed Combinations**  Shows factor level restrictions that you entered in the Restrict Factor Level Combinations outline.

**Analysis**  Provides an analysis of your experimental data. For more information about the script, see “Analysis Script”. For background, see Zhang and Zhang (2011).

**Tip:** To run a script, click the green triangle next to the script name.

---

**Figure 20.22** Partial View of Covering Array Table for Software Data.jmp Showing Scripts

---

**Analysis Script**

The Analysis script assumes the following about the Response column:

- The responses are recorded as 0 for failure and 1 for success.
- Missing values are permitted.
- The Response column is continuous.
- You can rename or move the Response column.
The Analysis script produces a report with two outlines:

- The Summary outline gives the number of runs resulting in Success, Failure, and the number of runs for which the response is Missing.

- The Failure Analysis Details report contains a \(<k>\) Factor Interactions report. The value of \(k\) is the smallest number of interactions that detect a failure. (For a definition of detect, see “Covering Arrays and Strength”.) The three columns contain the following:
  - The **Factors** column lists all \(k\)-factor combinations that detect failures.
  - The **Failure Levels** column lists the values of the \(k\) factors in the **Factors** column that detect failures.
  - The **Failure Count** column gives the number of failures corresponding to the \(k\)-factor combination of **Failure Levels**.

**Note:** A failure observation can appear in more than one of the \(k\)-factor combinations listed in the **Failure Levels** column.

The rows in the \(<k>\) Factor Interactions report are dynamically linked to the data table. If you select one or more rows in the report, the corresponding rows are selected in the data table.

---

**Covering Array Options**

The red triangle menu in the Covering Array platform contains these options:

**Save Factors**  Creates a data table containing a column for each factor that contains its factor levels. Each factor’s column contains these column properties: Design Role, Value Order, and Factor Changes. Saving factors enables you to quickly load them into a DOE window.

**Note:** You can create a factors table for a Covering Array by entering data into an empty table, but remember to assign each column an appropriate Design Role of Categorical. Right-click the column name in the data grid and select **Column Properties > Design Role**. In the Design Role area, select Categorical.

**Load Factors**  Loads factors that you have saved using the Save Factors option into the Factors outline.

**Load Design**  Loads a design from the active data table. If no data table is active, you are prompted to open one. When you select Load Design, a menu appears that enables you to select the columns that you want to specify as factors in the design. All columns are imported as categorical. Columns and their values are listed in the Factors outline. The
Design outline shows a Run for each row in the data table and gives the values of the factors for each run.

The Load Design options enables you to obtain metrics, modify, or construct an Analysis script for an existing design:

- The Metrics outline shows $t$-Coverage and $t$-Diversity for the specified design.
- You can click Back to impose factor level restrictions and then construct a new design.
- Clicking Make Table constructs a design table where you can enter responses. The table contains an Analysis script for the design.

**Set Random Seed**  Sets the random seed that JMP uses to control certain actions that have a random component. For Covering Arrays, the seed selects a starting design and an iteration count. For most designs, the random seed guarantees reproducibility of the design, but not of the run order.

**Note:** Upper limits on time as well as iteration count are used to limit design construction time. For some large and high strength designs, depending on the machine, the time limit might override the iteration limit. For such designs, the random seed does not guarantee reproducibility.

To reproduce a design, enter the random seed used to generate it before clicking Make Design.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

**Advanced Options**  Not available for Covering Arrays.

**Save Script to Script Window**  Creates the script for the design that you specified in the Covering Array window and places it in an open script window.

---

**Technical Details for Covering Arrays**

- “Algorithm for Optimize”
- “Formulas for Metrics”
Algorithm for Optimize

The Optimize button invokes an algorithm that is conceptually similar to a class of covering array optimizers sometimes referred to as *post-construction randomized optimizers* (Nayeri et al., 2013). However, the algorithm in JMP differs from most in that it also addresses designs with constraints. In particular, it optimizes constrained covering arrays as well as unsatisfiable, constrained covering arrays.

The algorithm assumes that the design to be optimized is a covering array of the specified strength. For a $K$ factor design of strength $t$, the algorithm iteratively examines all $\binom{K}{t}$ factor projections to determine whether runs can be eliminated or merged. Consequently, as $K$ or $t$ increases, the run time of the algorithm quickly escalates. To improve performance, the JMP implementation is threaded to use as many CPU cores as are available on your workstation.

Formulas for Metrics

The formulas for Coverage and Diversity depend on whether there are constraints. The following notation is used:

- $\binom{u}{v}$ is the number of combinations of $u$ things taken $v$ at a time
- $t$ is the strength of the design
- $K$ is the number of factors
- $M = \binom{K}{t}$
- $i = 1, 2, ..., M$ is an index that orders all combinations, or *projections*, of $t$ factors
- $v_{ik}$ is the number of levels for the $k^{th}$ factor
- $n_i$ is the number of distinct $t$ tuples in the design for the $i^{th}$ projection
- $p_i$ is the product of the $v_{ik}$ for the factors in the $i^{th}$ projection
- $r$ is the number of runs in the design

Unconstrained Design

Coverage and Diversity are given by the following:

- Coverage: $\frac{1}{M} \sum_{i=1}^{M} \frac{n_i}{p_i}$
- Diversity: $\frac{1}{M} \sum_{i=1}^{M} \frac{n_i}{r}$
Constrained Design

In a constrained design, certain *t* tuples are not allowed. This can result in missing values for some *t* tuples. For some combinations of *t* factors, there might be no valid *t* tuples whatsoever. Coverage and diversity must be defined in terms of the possible valid combinations. For this reason, the formulas for constrained designs require additional notation:

- \( a_i \) is the number of invalid *t* tuples arising from factors in the *i*\(^{th}\) projection
- \( m \) is the number of projections where there are no valid *t* tuples
- \( q_i \) is the number of runs in the design with missing values for any factor in the *i*\(^{th}\) projection
- \( r_i = r - q_i \)
- \( M' = M - m \)

Coverage and Diversity are given by the following:

\[
\text{Coverage} = \frac{1}{M'} \sum_{i=1}^{M'} \frac{n_i/(p_i - a_i)}
\]

\[
\text{Diversity} = \frac{1}{M'} \sum_{i=1}^{M'} \frac{n_i/r_i}
\]

If there are no invalid *t* tuples (\( M' = M \)) and if there are no missing values (\( r_i = r \), for all *i*), then the definitions for coverage and diversity for constrained designs reduce to the definitions for unconstrained designs. See Morgan (2014).
Space-filling designs are useful in situations where run-to-run variability is of far less concern than the form of the model. Consider a sensitivity study of a computer simulation model. In this situation, and for any mechanistic or deterministic modeling problem, any variability is small enough to be ignored. For systems with no variability, replication, randomization, and blocking are irrelevant.

The Space Filling platform provides designs for situations with both continuous and categorical factors. For continuous factors, space-filling designs have two objectives:

- maximize the distance between any two design points
- space the points uniformly

**Figure 21.1** Space-Filling Design
# Contents

Overview of Space-Filling Designs ................................................. 609
Build a Space Filling Design ..................................................... 610
  Responses ............................................................................. 610
  Factors ................................................................................. 612
  Define Factor Constraints ...................................................... 614
  Space Filling Design Methods ............................................... 618
  Design .................................................................................. 618
  Design Diagnostics ............................................................... 618
  Design Table ......................................................................... 619

Space Filling Design Options ..................................................... 619
Sphere-Packing Designs ............................................................ 621
  Creating a Sphere-Packing Design ........................................ 621
  Visualizing the Sphere-Packing Design ................................... 623
Latin Hypercube Designs .......................................................... 624
  Creating a Latin Hypercube Design ....................................... 624
  Visualizing the Latin Hypercube Design ................................. 626
Uniform Designs ................................................................. 628
Comparing Sphere-Packing, Latin Hypercube, and Uniform Methods ... 630
Minimum Potential Designs ....................................................... 632
Maximum Entropy Designs ......................................................... 634
Gaussian Process IMSE Optimal Designs ..................................... 636
Fast Flexible Filling Designs ....................................................... 637
  FFF Optimality Criterion .................................................... 637
  Set Average Cluster Size for FFF Designs ............................... 639
  Constraints ........................................................................... 639
  Creating and Viewing a Constrained Fast Flexible Filling Design 640
  Creating a Space-Filling Design for a Map Shape ..................... 641
Example of a Sphere-Packing Design ........................................ 646
  Create the Sphere-Packing Design for the Borehole Data .......... 646
  Guidelines for the Analysis of Deterministic Data ................. 647
Overview of Space-Filling Designs

Space-filling designs are useful for modeling systems that are deterministic or near-deterministic. One example of a deterministic system is a computer simulation. Such simulations can be very complex involving many variables with complicated interrelationships. A goal of designed experiments on these systems is to find a simpler empirical model that adequately predicts the behavior of the system over limited ranges of the factors.

In experiments on systems where there is substantial random noise, the goal is to minimize the variance of prediction. In experiments on deterministic systems, there is no variance but there is bias. Bias is the difference between the approximation model and the true mathematical function. The goal of space-filling designs is to bound the bias.

One approach to bound the bias is to spread the design points out as far from each other as possible while staying inside the experimental boundaries. The other approach is to space the points out evenly over the region of interest.

The Space Filling designer supports the following design methods:

**Sphere Packing**  Maximizes the minimum distance between pairs of design points. See “Sphere-Packing Designs” and “Create the Sphere-Packing Design for the Borehole Data”.

**Latin Hypercube**  Maximizes the minimum distance between design points but requires even spacing of the levels of each factor. This method produces designs that mimic the uniform distribution. The Latin Hypercube method is a compromise between the Sphere-Packing method and the Uniform design method. See “Latin Hypercube Designs”.

**Uniform**  Minimizes the discrepancy between the design points (which have an empirical uniform distribution) and a theoretical uniform distribution. See “Uniform Designs”.

**Minimum Potential**  Spreads points out inside a sphere around the center. See “Minimum Potential Designs”.

**Maximum Entropy**  Measures the amount of information contained in the distribution of a set of data. See “Maximum Entropy Designs”.

**Gaussian Process IMSE Optimal**  Creates a design that minimizes the integrated mean squared error of the Gaussian process over the experimental region. See “Gaussian Process IMSE Optimal Designs”.

**Fast Flexible Filling**  The Fast Flexible Filling method forms clusters from random points in the design space. These clusters are used to choose design points according to an optimization criterion. This is the only method that can accommodate categorical factors and constraints on the design space. You can specify linear constraints and disallowed
combinations. See “Fast Flexible Filling Designs” and “Creating and Viewing a Constrained Fast Flexible Filling Design”.

**Note:** If the number of runs is 500 or less, a Gaussian Process model is saved to the data table. If the number of runs exceeds 500, a Neural model is saved to the data table.

## Build a Space Filling Design

Build a Space Filling Design by selecting **DOE > Special Purpose > Space Filling Design**. First define your responses and factors. Next, continue to the design options, generation, and evaluation. The design process follows the flow in **Figure 21.2**.

**Figure 21.2** Space Filling Design Flow

### Responses

Use the Responses outline to specify one or more responses.

**Tip:** When you have completed the Responses outline, consider selecting **Save Responses** from the red triangle menu. This option saves the response names, goals, limits, and importance values in a data table that you can later reload in DOE platforms.

**Figure 21.3** Responses Outline

<table>
<thead>
<tr>
<th>Response Name</th>
<th>Goal</th>
<th>Lower Limit</th>
<th>Upper Limit</th>
<th>Importance</th>
<th>Lower Detection Limit</th>
<th>Upper Detection Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y</td>
<td>Maximize</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Add Response**  Enters a single response with a goal type of Maximize, Match Target, Minimize, None, or Functional. If you select Match Target, enter limits for your target value. If you select Maximize or Minimize, entering limits is not required but can be useful if you intend to use desirability functions.
**Functional**  (Available only in JMP Pro.) Adds multiple Y columns with FDE column properties to the design data table. These columns can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.

**Remove**  Removes the selected responses.

**Number of Responses**  Enters additional responses so that the number that you enter is the total number of responses. If you have entered a response other than the default Y, the Goal for each of the additional responses is the Goal associated with the last response entered. Otherwise, the Goal defaults to Match Target. Click the Goal type in the table to change it.

The Responses outline contains the following columns:

- **Response Name**  The name of the response. When added, a response is given a default name of Y, Y2, and so on. To change this name, double-click it and enter the desired name.

- **Goal, Lower Limit, Upper Limit**  The Goal tells JMP that you want to maximize or minimize your response, match a target, or that you have no goal for your response. JMP assigns a Response Limits column property, based on these specifications, to each response column in the design table. It uses this information to define a desirability function for each response. The Profiler and Contour Profiler use these desirability functions to find optimal factor settings. For further details, see the Profiler chapter in *Profilers* and “Response Limits”.

  - A Goal of Maximize indicates that the best value is the largest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

  - A Goal of Minimize indicates that the best value is the smallest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

  - A Goal of Match Target indicates that the best value is a specific target value. The default target value is assumed to be midway between the Lower Limit and Upper Limit.

  - A Goal of None indicates that there is no goal in terms of optimization. No desirability function is constructed.

**Note:**  If your target response is not midway between the Lower Limit and the Upper Limit, you can change the target after you generate your design table. In the data table, open the Column Info window for the response column (*Cols > Column Info*) and enter the desired target value.

- **Importance**  When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for
the responses. If there is only one response, then specifying the Importance is unnecessary because it is set to 1 by default.

**Detection Limits** The lower and upper detection limits are bounds beyond which the response cannot be measured. The detection limits are saved as a column property. You can use these limits to specify a censored response in the Generalized Regression platform. See the Generalized Regression chapter in *Fitting Linear Models*.

**Editing the Responses Outline**

In the Responses outline, note the following:

- Double-click a response to edit the response name.
- Click the goal to change it.
- Click on a limit or importance weight to change it.
- For multiple responses, you might want to enter values for the importance weights.

**Response Limits Column Property**

The Goal, Lower Limit, Upper Limit, and Importance that you specify when you enter a response are used in finding optimal factor settings. For each response, the information is saved in the generated design data table as a Response Limits column property. JMP uses this information to define the desirability function. The desirability function is used in the Prediction Profiler to find optimal factor settings. For further details about the Response Limits column property and examples of its use, see “Response Limits”.

If you do not specify a Lower Limit and Upper Limit, JMP uses the range of the observed data for the response to define the limits for the desirability function. Specifying the Lower Limit and Upper Limit gives you control over the specification of the desirability function. For more details about the construction of the desirability function, see the Profiler chapter in *profilers*.

**Factors**

Add factors for a space filling design in the Factors outline.
Figure 21.4 Factors Outline

The Factors outline contains these options:

**Continuous**  Enters the number of continuous factors specified in **Add N Factors**.

**Categorical**  Enters the number of nominal factors specified in **Add N Factors**.

**Remove**  Removes the selected factors.

**Add N Factors**  Adds multiple factors of a given type. Enter the number of factors to add and click Continuous or Categorical. Repeat **Add N Factors** to add multiple factors of different types.

**Tip:** When you have completed your Factors panel, select **Save Factors** from the red triangle menu. This saves the factor names and values in a data table that you can later reload. See “Space Filling Design Options”.

Factors Outline

The Factors outline contains the following columns:

**Name**  The name of the factor. When added, a factor is given a default name of X1, X2, and so on. To change this name, double-click it and enter the desired name.

**Role**  Specifies the Design Role of the factor. The Design Role column property for the factor is saved to the data table. This property ensures that the factor type is modeled appropriately.

**Values**  The experimental settings for the factors. To insert Values, click the default values and enter the desired values.

Editing the Factors Outline

In the Factors outline, note the following:

- To edit a factor name, double-click the factor name.
• Categorical factors have a down arrow to the left of the factor name. Click the arrow to add a level.
• To remove a factor level, click the value, click **Delete**, and click outside the text box.
• To edit a value, click the value in the **Values** column.

**Factor Types**

**Continuous**  Numeric data types only. A continuous factor is a factor that you can conceptually set to any value between the lower and upper limits you supply, given the limitations of your process and measurement system.

**Categorical**  Either numeric or character data types. For a categorical factor, the value ordering is the order of the values as entered from left to right. This ordering is saved in a **Value Order** column property after the design data table is created.

**Factor Column Properties**

For each factor, various column properties are saved to the data table.

**Design Role**  Each factor is assigned the Design Role column property. The Role that you specify in defining the factor determines the value of its Design Role column property. The Design Role property reflects how the factor is intended to be used in modeling the experimental data. Design Role values are used in the Augment Design platform.

**Factor Changes**  Each factor is assigned the Factor Changes column property with a setting of Easy. In space-filling designs, it is assumed that factor levels can be changed for each experimental run. Factor Changes values are used in the Evaluate Design and Augment Design platforms.

**Coding**  If the Role is Continuous, the Coding column property for the factor is saved. This property transforms the factor values so that the low and high values correspond to –1 and +1, respectively. The estimates and tests in the Fit Least Squares report are based on the transformed values.

**Value Order**  If the Role is Categorical or Blocking, the Value Order column property for the factor is saved. This property determines the order in which levels of the factor appear.

**Define Factor Constraints**

Factor constraints can be specified only for space filling designs constructed using the Fast Flexible Filling method.
Use Define Factor Constraints to restrict the design space. Unless you have loaded a constraint or included one as part of a script, the None option is selected. To specify constraints, select one of the other options:

**Specify Linear Constraints**  Specifies inequality constraints on linear combinations of factors. Available only for factors with a Role of Continuous or Mixture. See “Specify Linear Constraints”.

**Note:** When you save a script for a design that involves a linear constraint, the script expresses the linear constraint as a less than or equal to inequality (\( \leq \)).

**Use Disallowed Combinations Filter**  Defines sets of constraints based on restricting values of individual factors. You can define both AND and OR constraints. See “Use Disallowed Combinations Filter”.

**Use Disallowed Combinations Script**  Defines disallowed combinations and other constraints as Boolean JSL expressions in a script editor box. See “Use Disallowed Combinations Script”.

**Note:** When you analyze a design that has factor constraints, the model profiler honors the constraints.

---

### Specify Linear Constraints

In cases where it is impossible to vary continuous factors independently over the design space, you can specify linear inequality constraints. Linear inequalities describe factor level settings that are allowed. For an example, see “Mixture of Mixtures Design”.

Click **Add** to enter one or more linear inequality constraints.

**Add**  Adds a template for a linear expression involving all the continuous factors in your design. Enter coefficient values for the factors and select the direction of the inequality to reflect your linear constraint. Specify the constraining value in the box to the right of the inequality. To add more constraints, click **Add** again.

**Note:** The Add option is disabled if you have already constrained the design region by specifying a Sphere Radius.

**Remove Last Constraint**  Removes the last constraint.

**Check Constraints**  Checks the constraints for consistency. This option removes redundant constraints and conducts feasibility checks. A JMP alert appears if there is a problem. If constraints are equivalent to bounds on the factors, a JMP alert indicates that the bounds in the Factors outline have been updated.
Use Disallowed Combinations Filter

This option uses an adaptation of the Data Filter to facilitate specifying disallowed combinations. For detailed information, see Using JMP.

Select factors from the Add Filter Factors list and click Add. Then specify the disallowed combinations by using the slider (for continuous factors) or by selecting levels (for categorical factors). For an example, see “Response Surface Design With Constraints and Categorical Factor”.

The red triangle options for the Add Filter Factors menu are those found in the Select Columns panel of many platform launch windows. See Using JMP.

When you click Add, the Disallowed Combinations control panel shows the selected factors and provides options for further control. Factors are represented as follows, based on their modeling types:

**Continuous Factors**  For a continuous factor, a double-ended slider that spans the range of factor settings appears. You can specify disallowed settings by dragging the slider ends or by setting the endpoints by clicking on the text value under the slider. In the slider, a solid blue highlight represents the disallowed values.

**Categorical Factor**  For a categorical factor, the possible levels are displayed either as labeled blocks or, when the number of levels is large, as list entries. Select a level to disallow it. To select multiple levels, hold the Control key. The block or list entries are highlighted to indicate the levels that have been disallowed. When you add a categorical factor to the Disallowed Combinations panel, the number of levels of the categorical factor is given in parentheses following the factor name.

**Disallowed Combinations Options**

The control panel has the following controls:

**Clear**  Clears all disallowed factor level settings that you have specified. This does not clear the selected factors.

**Start Over**  Removes all selected factors and returns you to the initial list of factors.

**AND**  Opens the Add Filter Factors list. Selected factors become an AND group. Any combination of factor levels specified within an AND group is disallowed.

To add a factor to an AND group later on, click the group’s outline to see a highlighted rectangle. Select AND and add the factor.

To remove a single factor, select Delete from its red triangle menu.

**OR**  Opens the Add Filter Factors list. Selected factors become a separate AND group. For AND groups separated by OR, a combination is disallowed if it is specified in at least one AND group.
Red Triangle Options for Factors

A factor can appear in several OR groups. An occurrence of the factor in a specific OR group is referred to as an instance of the factor.

Delete  Removes the selected instance of the factor from the Disallowed Combinations panel.

Clear Selection  Clears any selection for that instance of the factor.

Invert Selection  Deselects the selected values and selects the values not previously selected for that instance of the factor.

Display Options  Available only for categorical factors. Changes the appearance of the display. Options include showing each level as a block, list, or single category, or adding a check box next to each value.

Find  Available only for categorical factors. Provides a text box beneath the factor name where you can enter a search string for levels of the factor. Press the Enter key or click outside the text box to perform the search. Once Find is selected, Find options appear in the red triangle menu, such as Does not contain, Match Case, Starts with or Ends with, or Clear Find.

Use Disallowed Combinations Script

Use this option to disallow particular combinations of factor levels using a JSL script. This option can be used with continuous factors or mixed continuous and categorical factors.

This option opens a script window where you insert a script that identifies the combinations that you want to disallow. The script must evaluate as a Boolean expression. When the expression evaluates as true, the specified combination is disallowed.

When forming the expression for a categorical factor, use the ordinal value of the level or the name of the level. If a factor’s levels are high, medium, and low, specified in that order in the Factors outline, their associated ordinal values are 1, 2, and 3. For example, suppose that you have two continuous factors, X1 and X2, and a categorical factor X3 with three levels: L1, L2, and L3, in order. You want to disallow levels where the following is true:

\[ e^{X_1} + 2X_2 < 0 \text{ and } X_3 = L2 \]

Enter the expression \((\text{Exp}(X1) + 2 \times X2 < 0) \& (X3 == 2)\) into the script window.
Figure 21.5 Expression in Script Editor

(In the figure, unnecessary parentheses were removed by parsing.) Notice that functions can be entered as part of the Boolean expression. The expression \((\text{Exp}(X_1) + 2 \times X_2 < 0) \& (X_3 == \text{"L2"})\) is also valid.

**Space Filling Design Methods**

The following methods for constructing space-filling designs are available:

- “Sphere-Packing Designs”
- “Latin Hypercube Designs”
- “Uniform Designs”
- “Minimum Potential Designs”
- “Maximum Entropy Designs”
- “Gaussian Process IMSE Optimal Designs”
- “Fast Flexible Filling Designs”

**Design**

The Design outline shows the runs for the space-filling design.

**Design Diagnostics**

The Design Diagnostics outline shows the values for the space filling design factors scaled from zero to one. The Minimum Distance is based on these scaled values and is the minimum distance from each point to its nearest neighbor. The row number for the nearest neighbor is given in the Nearest Point column. The discrepancy value shown below the table is the integrated difference between the design points based and a uniform distribution.

The MaxPro (maximum projection) criterion is provided for the full design as well as for each level of categorical variables when used. Smaller values are better. For more information about the MaxPro criteria see “MaxPro”.
Note: If for any dimension, two points can have the same value (that is, $x_{ik} = x_{jk}$), the MaxPro criterion is undefined. In this case, the Design Diagnostics shows a missing value for MaxPro.

**Design Table**

Use the Design Table buttons to finish your Space Filling Design construction.

**Make Table** Constructs the Space Filling Design data table.

**Back** Takes you back to where you were before clicking **Make Design**. You can make changes to the previous outlines and regenerate the design.

**Space Filling Design Options**

The red triangle menu in the Space Filling Design platform contains these options:

**Save Responses** Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.

**Load Responses** Loads responses that you saved using the Save Responses option.

**Save Factors** Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

**Load Factors** Loads factors that you saved using the Save Factors option.

**Save Constraints** (Unavailable for some platforms) Saves factor constraints that you defined in the Define Factor Constraints or Linear Constraints outline into a data table, with a column for each constraint. You can then quickly load the constraints into most DOE windows.

In the constraint table, the first rows contain the coefficients for each factor. The last row contains the inequality bound. Each constraint’s column contains a column property called `ConstraintState` that identifies the constraint as a “less than” or a “greater than” constraint. See “`ConstraintState`”.

Note: It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting **Column Properties > Design Role**. In the Design Role area, select the appropriate role.
Load Constraints  (Unavailable for some platforms) Loads factor constraints that you saved using the Save Constraints option.

Set Random Seed  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:
- initializing search algorithms for design generation
- randomizing Run Order for design construction
- selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking Make Design.

Note: The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

Simulate Responses  Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:
- A set of simulated response values is added to each response column.
- For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
- A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

Note: Not all distributions are available for all design types.

- A script called DOE Simulate is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a new column called <Y> Simulated, where Y is the name of the response. Clicking Apply again updates the formula and values in <Y> Simulated.

For additional details, see “Simulate Responses”.

Note: You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in Basic Analysis.
**FFF Optimality Criterion** For the Fast Flexible Filling design method, enables you to select between the MaxPro criterion (the default) and the Centroid criterion. See “**FFF Optimality Criterion**”.

**Number of Starts** Specifies the number of times that the algorithm for the chosen design type initiates to construct a new design. The best design, based on the criterion for the given design type, is returned. Set to 1 by default for all design types. Not used for Fast Flexible Filling Designs.

**Advanced Options > Set Average Cluster Size** For the Fast Flexible Filling design method, enables you to specify the average number of randomly generated points used to define each cluster or, equivalently, each design point.

**Advanced Options > MaxPro Categorical Weight** For the Fast Flexible Filling design method, enables you to specify the weight used for categorical factors in the MaxPro calculation. Points that have the same categorical level are multiplied by the weight. This provides better space-filling properties at the sub-design for each level of a categorical factor.

**Save Script to Script Window** Creates the script for the design that you specified in the Space Filling Design platform and saves it in an open script window.

---

**Sphere-Packing Designs**

The Sphere-Packing design method maximizes the minimum distance between pairs of design points. The effect of this maximization is to spread the points out as much as possible inside the design region.

- “Creating a Sphere-Packing Design”
- “Visualizing the Sphere-Packing Design”

**Creating a Sphere-Packing Design**

To create a sphere-packing design follow these steps:

1. Select **DOE > Special Purpose > Space Filling Design**.
2. Enter responses and factors.
   
   See “**Responses**”.
3. Alter the factor level values, if necessary. For example, Figure 21.6 shows the two existing factors, X1 and X2, with values that range from 0 to 1 (instead of the default –1 to 1).
4. Click **Continue**.

5. In the design specification dialog, specify a sample size (**Number of Runs**). Figure 21.7 shows a sample size of eight.

6. Click **Sphere Packing**.

   JMP creates the design and displays the design runs and the design diagnostics. Figure 21.8 shows the Design Diagnostics panel with 0.518 as the **Minimum Distance**. Your results might differ slightly from the ones below, but the minimum distance is the same. The MaxPro statistic is undefined for Sphere Packing as points can have identical values for one dimension.
Chapter 21
Design of Experiments Guide

Figure 21.8 Sphere-Packing Design Diagnostics

7. Click Make Table. Use this table to complete the visualization example, described next.

Visualizing the Sphere-Packing Design

To visualize the sphere-packing design use the sphere-packing design table to create a plot with Graph Builder:

1. Select Graph > Graph Builder.
2. Specify X1 as X and X2 as Y.
3. Click the smoother icon to remove the smoother (blue line) from your graph.
4. Adjust the frame size so that the frame is square by right-clicking the plot and selecting Graph > Size/Scale > Size to Isometric.
5. Right-click the plot and select Customize. When the Customize panel appears, click the plus sign to see a text edit area and enter the following script:
   For Each Row(Circle({:X1, :X2}, 0.518/2))
where 0.518 is the minimum distance number that you noted in the Design Diagnostics panel. This script draws a circle centered at each design point with radius 0.259 (half the diameter, 0.518), as shown on the left in Figure 21.9. This plot shows the efficient way JMP packs the design points.
6. Now repeat the procedure exactly as described in the previous section, but with a sample size of 10 instead of eight.
   Remember to change 0.518 in the graphics script to the minimum distance produced by 10 runs. When the plot appears, again set the frame size and create a graphics script using the minimum distance from the diagnostic report as the diameter for the circle. You should see a graph similar to the one on the right in Figure 21.9. Note the irregular nature of the sphere packing. In fact, you can repeat the process a third time to get a slightly different picture because the arrangement is dependent on the random starting point.
Latin Hypercube Designs

In a Latin Hypercube, each factor has as many levels as there are runs in the design. The levels are spaced evenly from the lower bound to the upper bound of the factor. Like the sphere-packing method, the Latin Hypercube method chooses points to maximize the minimum distance between design points, but with a constraint. The constraint maintains the even spacing between factor levels.

- “Creating a Latin Hypercube Design”
- “Visualizing the Latin Hypercube Design”

Creating a Latin Hypercube Design

To create a Latin hypercube design follow these steps:

1. Select DOE > Special Purpose > Space Filling Design.
2. Enter responses, if necessary, and factors.
   See “Responses”.
3. Alter the factor level values, if necessary. Figure 21.10 shows adding four factors and changing their values to 1 and 8 instead of the default –1 and 1.
Figure 21.10 Space-Filling Dialog for Four Factors

4. Click **Continue**.

5. In the design specification dialog, specify a sample size (**Number of Runs**). This example uses a sample size of eight.

6. Click **Latin Hypercube** (Figure 21.7). Factor settings and design diagnostics results appear similar to those in Figure 21.11, which shows the Latin Hypercube design with four factors and eight runs.

**Note:** The purpose of this example is to show that each column (factor) is assigned each level only once, and each column is a different permutation of the levels.
Visualizing the Latin Hypercube Design

To visualize the nature of the Latin Hypercube technique, create a plot with Graph Builder:

1. Create another Latin Hypercube design using two factors.
2. Select DOE > Special Purpose > Space Filling Design.
3. Enter two factors and be sure to change the factor values so that they are 0 and 1 instead of the default –1 and 1.
4. Click Continue.
5. Specify a sample size of eight (Number of Runs).
6. Click Latin Hypercube.
Figure 21.12  Latin Hypercube Design with Two Factors and Eight Runs

7. Click **Make Table**.

8. Select **Graph > Graph Builder**.

9. Specify X1 as X and X2 as Y.

10. Click the smoother icon to remove the smoother (blue line) from your graph.

11. Right-click the plot and select **Graph > Size/Scale > Size to Isometric** to adjust the frame size so that the frame is square.

12. Right-click the plot, select **Customize** from the menu. In the Customize panel, click the large plus sign to see a text edit area, and enter the following script:

   ```
   For Each Row(Circle({:X1, :X2}, 0.404/2))
   ```

   where 0.404 is the minimum distance number that you noted in the Design Diagnostics panel (Figure 21.12). This script draws a circle centered at each design point with radius 0.202 (half the diameter, 0.404), as shown on the left in Figure 21.13. This plot shows the efficient way JMP packs the design points.

13. Repeat the above procedure exactly, but with 10 runs instead of eight (step 5). Remember to change 0.404 in the graphics script to the minimum distance produced by 10 runs.

You should see a graph similar to the one on the right in Figure 21.13. Note the irregular nature of the sphere packing. In fact, you can repeat the process to get a slightly different picture because the arrangement is dependent on the random starting point.
Figure 21.13 Comparison of Latin Hypercube Designs with Eight Runs (left) and 10 Runs (right)

Note that the minimum distance between each pair of points in the Latin Hypercube design is smaller than that for the Sphere-Packing design. This is because the Latin Hypercube design constrains the levels of each factor to be evenly spaced. The Sphere-Packing design maximizes the minimum distance without any constraints.

Uniform Designs

The Uniform design minimizes the discrepancy between the design points (empirical uniform distribution) and a theoretical uniform distribution.

Note: These designs are most useful for getting a simple and precise estimate of the integral of an unknown function. The estimate is the average of the observed responses from the experiment.

1. Select **DOE > Special Purpose > Space Filling Design**.
2. Enter responses, if necessary, and factors.
   See “Responses”.
3. Alter the factor level values to 0 and 1.
4. Click **Continue**.
5. In the design specification dialog, specify a sample size. This example uses a sample size of eight (**Number of Runs**).
6. Click the **Uniform** button. JMP creates this design and displays the design runs and the design diagnostics as shown in **Figure 21.14**.

**Note:** The emphasis of the Uniform design method is not to spread out the points. The minimum distances in **Figure 21.14** vary substantially.

**Figure 21.14** Factor Settings and Diagnostics for Uniform Space-Filling Designs with Eight Runs

7. Click **Make Table**.

A Uniform design does not guarantee even spacing of the factor levels. However, increasing the number of runs and running a distribution on each factor (use **Analyze > Distribution**) shows flat histograms.
To compare space-filling design methods, create the **Sphere Packing**, **Latin Hypercube**, and **Uniform** designs, as shown in the previous examples. The Design Diagnostics tables show the values for the factors scaled from zero to one. The minimum distance is based on these scaled values and is the minimum distance from each point to its closest neighbor. The discrepancy value is the integrated difference between the design points and the uniform distribution.

**Figure 21.16** shows a comparison of the design diagnostics for three eight-run space-filling designs. Note that the discrepancy for the Uniform design is the smallest (best). The discrepancy for the Sphere-Packing design is the largest (worst). The discrepancy for the Latin Hypercube takes an intermediate value that is closer to the optimal value. The MaxPro criteria is smaller for the Latin Hypercube design as compared to the Uniform Design.

Also note that the minimum distance between pairs of points is largest (best) for the Sphere-Packing method. The Uniform design has pairs of points that are only about half as far apart. The Latin Hypercube design behaves more like the Sphere-Packing design in spreading the points out.

For both spread and discrepancy, the Latin Hypercube design represents a healthy compromise solution.
Another point of comparison is the time it takes to compute a design. The Uniform design method requires the most time to compute. Also, the time to compute the design increases rapidly with the number of runs. For comparable problems, all the space-filling design methods take longer to compute than the $D$-optimal designs in the Custom Designer.
Minimum Potential Designs

The Minimum Potential design spreads points out inside a sphere. To understand how this design is created, imagine the points as electrons with springs attached to every other point, as illustrated in Figure 21.17. The coulomb force pushes the points apart, but the springs pull them together. The design is the spacing of points that minimizes the potential energy of the system.

Minimum Potential designs:

- have spherical symmetry
- are nearly orthogonal
- have uniform spacing

To construct a Minimum Potential example design:

1. Select **DOE > Special Purpose > Space Filling Design**.
2. Add 3 continuous factor. See “Factors”.
3. Alter the factor level values to 0 and 1.
4. Click **Continue**.
5. In the design specification dialog (shown on the left in Figure 21.18), enter a sample size (Number of Runs). This example uses a sample size of 12.
6. Click the **Minimum Potential** button. JMP creates this design and displays the design runs and the design diagnostics (shown on the right in Figure 21.18).
Figure 21.18  Space-Filling Methods and Design Diagnostics for Minimum Potential Design

7. Click **Make Table**.

You can see the spherical symmetry of the Minimum Potential design using the Scatterplot 3D graphics platform.

1. After you make the JMP design table, choose the **Graph > Scatterplot 3D** command.

2. In the Scatterplot 3D launch dialog, select X1, X2, and X3 as **Y, Columns** and click **OK** to see the initial three-dimensional scatterplot of the design points.

3. To see the results similar to those in Figure 21.19:
   - Click the Scatterplot 3D red triangle and select the **Normal Contour Ellipsoids**.
   - Right-click the plot and select **Settings**, and then increase the marker size using the **Marker Size** slider.

Now the even spread of the points on the surface of the ellipsoid can be visualized.
Figure 21.19 Minimum Potential Design Points on Sphere

Maximum Entropy Designs

The Maximum Entropy design is an alternative to the Latin Hypercube design for computer experiments. The Latin Hypercube design is a popular design to use along with a Gaussian-Process model. Computer simulation experts like to use the Latin Hypercube design because all projections onto the coordinate axes are uniform.

However, as the example in Figure 21.20 shows, the Latin Hypercube design might not provide you with optimal space filling properties. This example is a two-factor 16 run Latin Hypercube with factor level settings set between -1 and 1. The plot of the two factors shows that this design has regions that are missing coverage. In particular, there is poor coverage for X1 near 0 and X2 near -1.
The Maximum Entropy design optimizes a measure of the amount of information contained in an experiment. See the technical note below. With the factor levels set between -1 and 1, the two-factor Maximum Entropy design shown in Figure 21.21 covers the region better than the Latin hypercube design in Figure 21.20. The space-filling property of the design improves as the number of runs increases.

**Figure 21.20** Two-factor Latin Hypercube Design

**Figure 21.21** Two-Factor Maximum Entropy Design
**Technical** Maximum Entropy designs maximize the Shannon information (Shewry and Wynn (1987)) of an experiment, assuming that the data come from a normal \((m, s^2 R)\) distribution, where

\[
R_{ij} = \exp\left( -\sum_k \theta_k (x_{ik} - x_{jk})^2 \right)
\]

is the correlation of response values at two different design points, \(x_i\) and \(x_j\). Computationally, these designs maximize \(|R|\), the determinant of the correlation matrix of the sample. If \(x_i\) and \(x_j\) are far apart, then \(R_{ij}\) approaches zero. If \(x_i\) and \(x_j\) are close together, then \(R_{ij}\) is near one.

---

**Gaussian Process IMSE Optimal Designs**

The Gaussian process IMSE optimal design method constructs designs that are suitable for Gaussian process models. Gaussian process models fit a wide variety of surfaces. Gaussian process IMSE optimal designs minimize the integrated mean squared error of the Gaussian process model over the experimental region. The Gaussian process IMSE optimal design method uses a correlation structure similar to that of the kriging model. See Jones and Johnson (2009).

**Covariance Parameter Vector**

In a Gaussian Process IMSE Optimal Design formulation of the Gaussian process model, the covariance parameter vector determines the correlation structure. There is a Theta for each factor. A theta equal to 0 corresponds to a correlation of 1, causing the fitted surface to be flat in the corresponding factor’s direction. As theta increases, the correlation decreases, allowing the surface to be flexible in the factor’s direction.

In the Covariance Parameter Vector outline, in the list of values under Thetas, you can enter values that reflect your prior knowledge of the surface.

**Comparison of Gaussian Process IMSE Optional Design with Latin Hypercube Design**

Gaussian process IMSE optimal designs are alternatives to the Latin Hypercube design. You can compare the IMSE optimal design to the Latin Hypercube (shown previously in Figure 21.20). The table and overlay plot in Figure 21.22 show a Gaussian IMSE optimal design. You can see that the design provides uniform coverage of the factor region.
Figure 21.22 Comparison of Two-factor Latin Hypercube and Gaussian IMSE Optimal Designs

Note: Both the Maximum Entropy design and the Gaussian Process IMSE Optimal design were created using 100 random starts.

Fast Flexible Filling Designs

The algorithms for Fast Flexible Filling designs begin by generating a large number of random points within the specified design region. These points are then clustered using a Fast Ward algorithm into a number of clusters that equals the Number of Runs that you specified.

The final design points can be obtained by using the default MaxPro (maximum projection) optimality criterion or by selecting the Centroid criterion.

Note: If you have Categorical factors or factor constraints, then Fast Flexible Filling is the only space filling design Method available.

FFF Optimality Criterion

The Space Filling Design red triangle menu contains optimality criteria under FFF Optimality Criterion.

MaxPro For p factors and n equal to the specified Number of Runs, the MaxPro criterion strives to find points in the clusters that minimize the following criterion:
The MaxPro criterion maximizes the product of the distances between potential design points in a way that involves all factors. This supports the goal of providing good space-filling properties on projections of factors. See Joseph et al. (2015). The Max Pro option is the default.

Centroid
This method places a design point at the centroid of each cluster. It has the property that the average distance from an arbitrary point in the design space to its closest neighboring design point is smaller than for other designs.

Note: You can set a preference to always use a given optimality criterion. Select File > Preferences > Platforms > DOE. Select FFF Optimality Criterion and select your preferred criterion.

Categorical Factors
When you have categorical factors, the algorithm proceeds as follows:

- The total number of design points is balanced across the total number of combinations of levels of the categorical factors. Suppose that there are \( m \) combinations of levels and that \( k \) design points are allocated to each of these.
- A large number of points within the design space defined by the continuous variables is generated. These are grouped into \( k \) primary clusters.
- Each of the \( k \) primary clusters of points is further clustered into \( m \) sub-clusters.
- Within each primary cluster, a design point is calculated for each of the \( m \) sub-clusters using the specified FFF optimality criterion.
- For each of the \( k \) primary clusters, one of the \( m \) combinations of levels is randomly assigned to each of the \( m \) sub-cluster design points. This yields a total of \( km \) design points.
- For each of the \( k \) primary clusters, a design point is chosen for each of the \( m \) combinations of levels according to the MaxPro criterion, where points having the same level of a categorical factor are multiplied by the MaxPro Categorical Weight. (For a description of MaxPro Categorical Weight, see “Space Filling Design Options”.) This process continues through all \( k \) primary clusters 10 times, or until no improvement is found by changing the given design points.

\[
C_{MaxPro} = \sum_{i}^{n-1} \sum_{j=i+1}^{n} \left[ \frac{1}{p} \prod_{k=1}^{p} (x_{ik} - x_{jk})^{2} \right]
\]
Set Average Cluster Size for FFF Designs

The Set Average Cluster Size option enables you to specify the average number of randomly-generated points used to define each cluster or, equivalently, each design point. The option is found under Advanced Options in the Space Filling Design red triangle menu.

By default, if the Number of Runs is set to 200 or less, a total of 10,000 randomly generated points are used as the basis for the clustering algorithm. When the number of Runs exceeds 200, a default value of 50 is used. Increasing this value can be particularly useful in designs with a large number of factors or where disallowed combinations restrict the distribution of points used in the clustering algorithm.

Note: Depending on the number of factors and the specified value for Number of Runs, you might want to increase the average number of initial points per design point by selecting Advanced Options > Set Average Cluster Size.

Constraints

Once you complete the Factors outline, click Continue. The Define Factor Constraints outline appears. Use this outline to restrict the design region. For more information about the outline, see “Define Factor Constraints”.

You can use the Use Disallowed Combinations Filter and Use Disallowed Combinations Script options to specify disallowed factor level combinations. Or, you can use the Specify Linear Constraints option to specify bounds in terms of linear inequalities. However, the design is generated differently for these two methods.

Use Disallowed Combinations Filter and Use Disallowed Combinations Script

When disallowed combinations are specified, the random points that form the basis for the clustering algorithm are randomly distributed within the unconstrained design region. Then disallowed points are removed and clustering proceeds with the remaining points.

Note: Depending on the nature of the constraints and the specified Number of Runs, the default coverage of the unconstrained design space by the initial randomly generated points might not be sufficient to produce the required Number of Runs. In this case, you might obtain a JMP Alert indicating that the algorithm “Could not find sufficient number of points.” To increase the initial number of points that form the basis for the clustering algorithm, specify a larger average number of initial points per design point by selecting Advanced Options > Set Average Cluster Size. (See “Set Average Cluster Size for FFF Designs”).
Specify Linear Constraints

When you use the Specify Linear Constraints option, the random points that form the basis for the clustering algorithm are randomly distributed within the constrained design region. The clustering algorithm uses these points.

Creating and Viewing a Constrained Fast Flexible Filling Design

This example creates and views a constrained fast flexible filling design.

Constructing the Design

1. Select DOE > Special Purpose > Space Filling Design.
2. Add 2 continuous factors.
3. Alter the factor level values to 0 and 1 and click Continue.
4. In the Define Factor Constraints outline, select Specify Linear Constraints.
   Notice that Fast Flexible Filling is the only available Space Filling Design Method.
5. Select Add.
6. Enter the following coefficients and bound:
   1 for X1
   1 for X2
   0.8 for the bound

   Figure 21.23 Linear Constraint

7. Type 200 next to Number of Runs.
   JMP creates a design that satisfies the constraints. Open the Design outline to view the design.
9. Select Make Table to construct the data table.
Constructing the Plot

1. With the data table active, select **Graph > Graph Builder**.
2. Drag X1 to the drop zone labeled X.
3. Drag X2 to the drop zone labeled Y.
4. Remove the **Smoother** by clicking the smoother icon.
5. Click the Graph Builder red triangle and click **Show Control Panel** to deselect it.

You should see a graph similar to the one in **Figure 21.24**. Note that the points satisfy the linear constraint \( X_1 + X_2 \leq 0.8 \).

**Figure 21.24** Fast Flexible Filling Design with One Linear Constraint

Creating a Space-Filling Design for a Map Shape

A fast flexible filling (FFF) design can be used to design an experiment to be executed across a region such as a map shape. For example, if you had two sample collection methods (perhaps for air or soil samples) that you wanted to compare at locations spread throughout a US state, consider a FFF design.

Supposed the US state of interest is Georgia. You want 40 samples, 20 for each sampling method, spread throughout the state. To create a FFF design for a map shape, you need a file with the latitude and longitude of the map boundaries (see “Background Maps”).
In the following example, you determine the longitude and latitude for the US state of Georgia, define the shape of the state, then create the design. The design will provide the location and the sampling method for each of your 40 samples.

**Find Longitude and Latitude for Georgia**

1. Navigate to the Maps directory, usually found here:
   - Windows: C:/Program Files/SAS/JMP/<Version>/Maps
   - macOS: /Library/Application Support/JMP/<Version>/Maps
   - Notice that in US-State-Name.jmp, Shape ID 11 corresponds to the US state of Georgia. In this example, that is the state of interest.
3. In US-State-XY.jmp, select Rows > Row Selection > Select Where...
4. Select Shape ID and enter 11 in the text box, then click OK.
   - This selects all rows with a Shape ID of 11, representing Georgia.
5. Select Tables > Subset and click OK to obtain a subset of the US-State-XY.jmp table of the latitudes and longitudes data for the state of Georgia (the selected rows).

**Get the Range of Values**

To define the space for the space filling design, you need to know the range of values for the latitude and longitudes in Georgia. Then, you can create design factors with these values.

1. Select File > New > Script. In the script window, right-click and select Show Embedded Log.
2. Copy the following and paste it into the new script:
   ```
   dt = current data table();
   mymap = dt << get as matrix({X,Y});
   xx = mymap[0,1];
   yy = mymap[0,2];
   show(min(xx), max(xx));
   show(min(yy), max(yy));
   show(xx,yy);
   ```
3. With the subset of the US-State-XY.jmp table active, run the script.
   - The range of values for the latitudes and longitudes in Georgia and the xx and yy matrices appear in the log.
Add Factors

1. Select **DOE > Special Purpose > Space Filling Design.**
2. Add two continuous factors to the design. Enter 2 in the **Add N Factors** text box and click **Continuous.**
3. Rename the factors longitude and latitude and enter their min and max values in the Factor outline:
   - For longitude, enter -85.6 and -80.9 as the values. These are the min and max longitude values from the log for $x$.
   - For latitude, enter 30.4 and 35.0 as the values. These are the min and max latitude values from the log for $y$.
4. Add a categorical factor. Click **Categorical > 2 Level.** Rename the factor Method.

Figure 21.26 Factors

<table>
<thead>
<tr>
<th></th>
<th>Role</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Longitude</strong></td>
<td>Continuous</td>
<td>-85.6</td>
</tr>
<tr>
<td><strong>Latitude</strong></td>
<td>Continuous</td>
<td>30.3</td>
</tr>
<tr>
<td><strong>Method</strong></td>
<td>Categorical</td>
<td>1</td>
</tr>
</tbody>
</table>
Define the Shape

To further define the space for the space filling design, you need to define the shape of the state using a polygon.

1. Select **Use Disallowed Combinations Script** to open the Disallowed Combinations Expression text box.

   The ranges of longitude and latitude define a square. The state of Georgia is a polygon, not a square. You want to disallow points that fall outside of the state of Georgia polygon.

2. Go to your script window and copy the xx and yy matrices from your script log. Paste this into the Disallowed Combinations Expression text box.

3. At the end, add the following line:

   ```
   !In Polygon(longitude, latitude , xx, yy);
   ```

   This excludes points that are not in the polygon defined by the xx and yy coordinates.

**Figure 21.27** Disallowed Combinations Expression

---

Make the Design

1. Change the **Number of Runs** to 40 and click **Fast Flexible Filling**.

2. Click **Make Table**.

3. From your design table, select **Graph > Graph Builder**.

4. Drag these columns into these zones:
   - longitude to the X zone
   - latitude to the Y zone
   - Method to the Color zone
5. Above the graph, click the Smoother element icon to turn it off.
6. To add the state shape, right-click the graph and select **Graph > Background Map**. 
7. Under **Boundaries**, select **US States** and click **OK**.

**Figure 21.28** Example of FFF Design for the US State of Georgia

**Note**: The exact location of the points on your map may differ from the one shown due to the random starting point for the FFF algorithm.

The map identifies the 40 locations where you should collect your samples. The sampling method (L1 or L2) is indicated by the color of the points.

The **Graph > Background Map** window has these additional options:

- To determine the counties for your testing, under **Boundaries**, select **US Counties**.
- To map your testing locations at the street level, under **Images**, select **Street Map Service**.
Example of a Sphere-Packing Design

Worley (1987) presented a model of the flow of water through a borehole that is drilled from the ground surface through two aquifers. The response variable $y$ is the flow rate through the borehole in m$^3$/year and is determined by the following equation:

$$y = \frac{2\pi T_u (H_u - H_l)}{\ln(r/r_w)} \left[ 1 + \frac{2LT_u}{\ln(r/r_w) r_w^2 K_w} + \frac{T_u}{T_l} \right]$$

There are eight factors in this model:

$r_w =$ radius of borehole, 0.05 to 0.15 m
$r =$ radius of influence, 100 to 50,000 m
$T_u =$ transmissivity of upper aquifer, 63,070 to 115,600 m$^2$/year
$H_u =$ potentiometric head of upper aquifer, 990 to 1100 m
$T_l =$ transmissivity of lower aquifer, 63.1 to 116 m$^2$/year
$H_l =$ potentiometric head of lower aquifer, 700 to 820 m
$L =$ length of borehole, 1120 to 1680 m
$K_w =$ hydraulic conductivity of borehole, 9855 to 12,045 m/year

You can use a sphere-packing design to obtain a set of conditions for which to calculate the response $y$. Then you can build a model to estimate the true model over the range of inputs used in your design. Evaluation of your estimated model can help you understand the impact of each of the eight factors on the response.

Create the Sphere-Packing Design for the Borehole Data

To create a sphere-packing design for the borehole model, you can use a data table of saved factor settings.

1. Select Help > Sample Data Library and open Design Experiment/Borehole Factors.jmp
2. Select DOE > Special Purpose > Space Filling Design
3. Click the Space Filling Design red triangle and select Load Factors.
Figure 21.29  Factors Panel with Factor Values Loaded for Borehole Example

<table>
<thead>
<tr>
<th>Name</th>
<th>Role</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>log10 Rw</td>
<td>Continuous</td>
<td>-1.3</td>
</tr>
<tr>
<td>log10 R</td>
<td>Continuous</td>
<td>2</td>
</tr>
<tr>
<td>Tu</td>
<td>Continuous</td>
<td>63070</td>
</tr>
<tr>
<td>H1</td>
<td>Continuous</td>
<td>63.1</td>
</tr>
<tr>
<td>Hu</td>
<td>Continuous</td>
<td>990</td>
</tr>
<tr>
<td>Hl</td>
<td>Continuous</td>
<td>700</td>
</tr>
<tr>
<td>C</td>
<td>Continuous</td>
<td>1120</td>
</tr>
<tr>
<td>Kw</td>
<td>Continuous</td>
<td>9855</td>
</tr>
</tbody>
</table>

**Note:** The logarithm of $r$ and $r_{wo}$ are used as factors.

4. Click **Continue**.
5. Set the Number of Runs to 32 and press Enter.
6. Click **Sphere Packing** to produce the design.
7. Click **Make Table** to make a table showing the design settings for the experiment.

**Note:** The design table includes a Model table script. This script runs a Gaussian Process model for the response $y$.

8. (Optional) To see a completed data table for this example, select **Help > Sample Data Library** and open Design Experiment/ Borehole Sphere Packing.jmp.

Because the designs are generated from a random seed, the settings that you obtain can differ from those shown in the completed table.

**Guidelines for the Analysis of Deterministic Data**

It is important to remember that deterministic data have no random component. The same input values generate the same output. As a result, $p$-values from fitted statistical models do not have their usual meanings. A large $F$ statistic (low $p$-value) is an indication of an effect due to a model term. However, you cannot construct valid confidence intervals for effects or model predictions.

Residuals from a model fit to deterministic data are not a measure of noise. Instead, residuals are a measure of the model bias. Bias is the difference between the true value and the predicted value. Distinct patterns in the residuals indicate that additional terms should be considered for the model in order to reduce bias.
Analysis of the Borehole Sphere-Packing Design

Often, the true model is not available in a simple analytical form. As a result, the prediction bias is known only at observed data points. However, in this example, the functional form of the true model is known. In the Borehole Sphere Packing.jmp data table, the true model column contains the formula of the known function. This formula enables you to profile the prediction bias over the factor input region.

1. Select Help > Sample Data Library and open Design Experiment/Borehole Sphere Packing.jmp.
2. Click the green triangle next to the Model (GP from DOE) script.
   Use the Gaussian Process Model report to explore the relationships between the factors and the outcome Y.
3. Click the red triangle next to Gaussian Process Model of Y and select Save Prediction Formula.
4. Go back to the Borehole Sphere Packing.jmp data table.
5. In the data grid, select the column headings for true model and Y Prediction Formula.
6. Right-click and select New Formula Column > Combine > Difference.
   This creates a new column containing the bias.
7. From the Borehole Sphere Packing.jmp data table, select Graph > Profiler.
8. Select true model-Y Prediction Formula and click Y, Prediction Formula
   This option shows the bias as a function of the eight design factors.

Figure 21.30  Profiler Dialog for Borehole Sphere-Packing Data

10. Click OK.
The profiler defaults to the center of the design region. If there were no bias, all profile traces would be constant between the value ranges of each factor. In this example, the variables $\log R_w$, $K_w$, and $L$ show the largest effects on the bias.

**Figure 21.31** Profiler for Bias of the Borehole GP Model with Y Axis Set at -40 to 20

You can use the profiler to explore the range of the prediction bias over the entire domain. To find points of minimum and maximum bias, select **Optimization and Desirability > Desirability Functions** from the Prediction Profiler red triangle menu. See **Profilers**. To evaluate the prediction bias over the design points, select **Analyze > Distribution** to see a distribution analysis.
Keep in mind that, in this example, the true model is known. In many applications, the response at any factor setting is unknown. The prediction bias over the experimental data can underestimate the bias throughout the design domain.
Use the Accelerated Life Test (ALT) Design platform to design plans for accelerated life testing experiments. Product reliability at normal use conditions is often so high that the time required to test the product until it fails is prohibitive. Rather than test the product at normal use conditions, you can test the product under conditions that are more severe than normal use conditions. These severe conditions can cause the product to degrade faster and fail more quickly. You can then use this accelerated failure data to predict product reliability at normal use conditions. You can design initial experiments or augment existing experiments.

**Figure 22.1** Profiler Showing Failure Probabilities for ALT Experiment
Contents

Overview of Accelerated Life Test Designs ................................................................. 653
Example of an Accelerated Life Test Design ............................................................ 653
Example of Augmenting an Accelerated Life Test Design ........................................ 660
Build an Accelerated Life Test Design ..................................................................... 665
  Specify the Design Structure .................................................................................. 666
  Specify Acceleration Factors .................................................................................. 666
  Specify Design Details ......................................................................................... 667
Review and Update Specifications for ALT Plans .................................................... 669
Create and Assess the Optimal ................................................................................ 671
Create Design Tables ............................................................................................... 673
Accelerated Life Test Options .................................................................................. 673
Statistical Details for the ALT Design Platform ....................................................... 674
  Failure Distributions for ALT Designs .................................................................... 674
  R Precision Factor (for a 95% CI) ....................................................................... 676
  Optimality Criterion for Accelerated Life Tests .................................................... 677
Overview of Accelerated Life Test Designs

Use accelerated life testing when product reliability at normal use conditions is high. You test the product under conditions that are more severe than normal to accelerate the time until failures occur. You use this accelerated failure data to predict product reliability at normal use conditions.

Such a test is called an accelerated life test (ALT). The factors that are set to levels that accelerate the time to failure are called acceleration factors. The models for accelerated life tests are typically nonlinear models. For more information about nonlinear models, see “Nonlinear Models”.

The ALT Design platform creates and evaluates designs for situations involving one or two acceleration factors. You can optimize your design using D-optimality, quantile estimation, or failure probabilities.

Creating an ALT design requires initial estimates of the acceleration model parameters. Use subject matter knowledge to define starting estimates. If you do not have information to inform your starting estimates, you can specify a multivariate normal prior distribution to describe their uncertainty.

You can also use the Accelerated Life Test (ALT) Design platform to augment a current experiment. You might want to augment a current design to decrease the variance of estimates.

Example of an Accelerated Life Test Design

Use the ALT designer to construct a failure probability optimal ALT test design. In this example, suppose that you need to design an accelerated life test for a mechanical component. The single acceleration factor is torque, and the normal use stress is 35 Nm (newton meters). You want to estimate the time at which 10% of the units fail at the normal use stress. You construct a failure probability optimal ALT test.

Your test plan has the following characteristics:

- A total of 100 units are available for testing.
- The life distribution is assumed to be Weibull.
- The life-stress relationship is given by the logarithmic transformation.
- You plan to test torque at three stress levels: 50, 75, and 100 Nm.
- You have prior knowledge to predict initial failure times at the test levels. See “Obtain Prior Estimates”.
- The test runs for 5,000 cycles.
You will monitor the process for failures on a continuous basis.

Obtain Prior Estimates

To create an accelerated life test design, you must provide prior estimates of the parameters. Here is an approach to obtaining prior estimates:

1. Use your process knowledge to create a table of hypothetical, but likely, failure times at a small number of stress levels.
2. Use the Fit Life by X platform to fit a model and obtain estimates of the model parameters.
3. Use these estimates as your prior values for creating a design using the ALT Design platform.

Following the approach outlined above, you create a data table containing estimates of the number of failure cycles for a balanced design. Your table consists of five units at each of the three stress levels to be used in your design. Your data table is Torque Prior.jmp, found in the Sample Data Library.

1. Select Help > Sample Data Library and open Design Experiment/Torque Prior.jmp.
2. Select Analyze > Reliability and Survival > Fit Life by X.
3. Select Cycles and click Y, Time to Event.
4. Select Torque and click X.
5. From the Relationship list, select Log.
6. Enter 35 for the Use Condition. Recall that 35 Nm is the normal use condition.
7. From the Distribution list, select Weibull.

Figure 22.2  Fit Life by X Launch Window
8. Click **OK**.

9. Scroll down to the Weibull Results outline and open the Correlation Matrix outline.

**Figure 22.3** Fit Life by X Model for Prior Data

![Weibull Results and Correlation Matrix](image.jpg)

The model for the mean is given in the Estimates outline. The Estimate column contains the parameter estimates for the intercept (\( \beta_0 \)), the linear coefficient (\( \beta_1 \)), and the scale (\( \sigma \)). The standard errors column contains the standard errors for the estimates. The estimated correlations for the parameter estimates are given in the Correlation Matrix outline. Use these parameter estimates, standard errors, and correlations as your prior values to construct your ALT design.

**Enter Basic Specifications**

To create an accelerated life test design define accelerating factors, use conditions, and test conditions.

1. Select **DOE > Special Purpose > Accelerated Life Test Design**.
   
   Notice that **One accelerating factor** and **Continuous Monitoring** are selected by default.

2. Click **Continue**.

3. Under **Factor Name**, click X1 and type Torque.

   Notice that the **Number of Levels** is set to 3 by default.

4. Select **Log** under Factor Transformation.

5. Enter 35 for both the **Low Usage Condition** and the **High Usage Condition**.

   Setting both the low and high usage conditions to 35 indicates that 35 is the normal usage condition.
6. Enter 50 for the **Low Test Condition** and 100 for the **High Test Condition**.

**Figure 22.4** Completed ALT Specification Window

7. Click **Continue**.

8. Notice the **Torque Level Values** are set to 50, 75, and 100.

   **Note:** JMP sets the values of the levels evenly spaced between the low and high test conditions. You can change the levels.

9. Ensure that **Weibull** is selected as the **Distribution Choice**.

### Enter Prior Information and Remaining Specifications

Continue the construction of the example ALT design by entering prior information.

1. Under **Prior Mean**, select **Specify Intercept** and enter the prior acceleration model parameter estimates that you obtained using the Fit Life by X platform with your hypothetical data:
   - Enter 15.88 for **Intercept**.
   - Enter -1.87 for **Power (Torque)**.
   - Enter 0.05 for \(1/\beta\) (scale parameter for a Weibull model).

2. Select **Specify prior uncertainty**.

3. Enter the estimated standard errors and correlations from the prior acceleration model. **Figure 22.3** shows the completed Prior Uncertainty outline:
Design of Experiments Guide

Example of an Accelerated Life Test Design

Chapter 22

Accelerated Life Test Designs

Figure 22.5  Completed Prior Specification Outline

![Completed Prior Specification Outline]

Click the Accelerated Life Test Plan red triangle and select **ALT Optimality Criterion > Make Failure Probability Optimal**.

You plan to conduct the test over 5,000 cycles. You are interested in predictions for as many as 10,000 cycles.

4. In the Diagnostic Choices outline, enter 10,000 for both boxes for **Time range of interest**.
5. In the Design Choices outline. Enter 5,000 for **Length of test** and 100 for **Number of units under test**.

Figure 22.6  Completed Diagnostic and Design Choices Outline

![Completed Diagnostic and Design Choices Outline]

Make the Design

Continue the ALT example by generating the design.

1. Click **Continue**.
The number of runs in a balanced design appears in the Candidate Runs outline. The Parameter Variance for Balanced Design outline shows the covariance matrix for the parameters for this design. The Distribution Profiler also appears. When you obtain the optimal design, you can compare the Parameter Variance and Distribution Profiler results to those for the balanced design to see the reduction in uncertainty.

2. Click **Make Design**.

The optimal experimental design appears, along with other results.

The optimal design is computed based on the levels of the test runs, the total number of units to be tested, and the prior information that you specified. The optimal design consists of testing the specified number of units at each torque level:

- 81 units at 50 Nm
- 0 units at 75 Nm
- 19 units at 100 Nm
Run Simulations

Evaluate the example ALT design with the simulator. Use the simulator to simulate the results of your test plan based on the assumptions used to build the design. This is a way to evaluate if the test plan is sufficient before running the test plan.

1. Enter 100 for the **Number of Simulations**.
2. Enter 0.1 for the **Simulation Probability of Interest**.
3. Enter 35 for the **Simulation Usage for Torque**.
4. Click **Run Simulations** to run 100 simulations of the experiment. This is to check to see whether the 100 units that you plan to test will be sufficient given your prior assumptions for the design.

**Figure 22.9 Simulation Results**

The simulated model fits shows that the 100 simulations of the model are all similar as they all fall close to the average shown by the red curve. The Y axis is on a log scale.

5. Double-click the Y axis and select **Linear** from the Type menu and click **OK**.

The variability in the simulated fits around the 35 normal usage condition is now easier to view. You expect variability in your estimated of the normal usage condition. The simulation helps you evaluate if your ALT plan is acceptable. If there is too much
variability, you might need to increase the number of units on test or adjust the test conditions.

Save Design

Finally, complete the Example ATL design by making a test plan and saving it to a data table.

1. Click Make Test Plan to save the design to a data table. This table is a summary of the design.
2. Click Make Table to save the design to a data table. This table has 100 rows, one for each test run.

Example of Augmenting an Accelerated Life Test Design

This example shows how to use the Accelerated Life Test Design platform to augment an existing design. In this example, 150 capacitor units were tested across three temperatures (85°, 105°, and 125° Celsius) for 1500 hours. The results are recorded in the Capacitor ALT.jmp sample data table. The resulting model is used to predict the fraction of the population that is failing at 100,000 hours at a normal usage temperature of 25° Celsius.

Review Current Predictions

1. Select Help > Sample Data Library and open Design Experiment/Capacitor ALT.jmp.
2. Click the green triangle to run the Fit Life by X table script.
3. In the Distribution Profiler, found in the Comparisons outline on the Distribution tab, change the factor settings:
   - Click 105 above Temp and change it to 25.
   - Click 750.5 above Hours and change it to 100,000.
Based on your current study, the predicted fraction of the capacitor population that fails at 25° at 100,000 hours is 0.003575, with a 95% confidence interval of 0.00056 to 0.02268. You want to estimate the fraction of failures more precisely. To decrease the width of the confidence interval, a measure of the precision of your estimate, you can augment your study with additional tests.

**Augment the Design**

You want to augment your design to obtain a more precise estimate of the predicted fraction of failures. Your original design used temperature settings of 85, 105, and 125. In your augmented design, you want to test at temperature values of 90, 110, and 125. Note that two of these settings are new. Augment the design with optimally selected runs:

1. Select **DOE > Special Purpose > Accelerated Life Test Design**.
2. Select **One accelerating factor**, select **Continuous Monitoring**, and click **Continue**.
3. Enter **Temp** for **Factor Name**.
4. Enter 5 for **Number of Levels**.
   
   Even though your augmented runs span only three levels (90, 110, and 125), you must also specify the levels used in the original experiment for a total of five levels. The Factor Transformation is set to Arrhenius Celsius by default.
5. Enter 25 for both **Low Usage Condition** and **High Usage Condition**.
6. Enter 85 for the **Low Test Condition** and 125 for the **High Test Condition**.
7. Click **Continue**.
8. Enter 85, 90, 105, 110, and 125 for the **Temp Level Values**.
   
   There are three levels from the original experiment (85, 105, and 125). The augmented design has two new levels (90 and 110) and one of the levels from the first experiment (125).
   
**Note:** All levels must be listed.
9. Ensure that **Weibull** is selected as the **Distribution Choice**.

10. Under **Prior Mean**, select **Specify Intercept**. Enter your current acceleration model parameter estimates from the Fit Life by X Estimates outline, found in the Weibull Results outline on the Statistics tab.

**Figure 22.11 Parameter Estimates and Fitted Model from Weibull Results Outline**

<table>
<thead>
<tr>
<th>Estimates</th>
<th>Estimate</th>
<th>Std Error</th>
<th>Lower 95%</th>
<th>Upper 95%</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \beta_0 )</td>
<td>-35.19978</td>
<td>4.912666</td>
<td>-44.39451</td>
<td>-26.00508</td>
</tr>
<tr>
<td>( \beta_1 )</td>
<td>1.38896</td>
<td>0.1566352</td>
<td>1.08196</td>
<td>1.69597</td>
</tr>
<tr>
<td>( \sigma )</td>
<td>1.30471</td>
<td>0.1119728</td>
<td>1.08536</td>
<td>1.52405</td>
</tr>
</tbody>
</table>

- Enter -35.200 for **Intercept**.
- Enter 1.389 for **Activation Energy (Temp)**.
  This is an estimate of the activation energy and is the coefficient of the inverse temperature, measured in degrees Kelvin, multiplied by Boltzmann’s constant.
- Enter 1.305 for **1/\( \beta \)**.
  For the Weibull distribution, JMP uses a parameterization that depends on a location parameter \( \mu \) and scale parameter \( \sigma \). In terms of the usual \( \alpha \) and \( \beta \) parameterization, the scale parameter is \( \sigma = 1/\beta \). See “**Weibull**”.

In the Accelerated Life Test Plan window, you can specify uncertainty about your prior means by selecting the **Specify prior uncertainty** option. In this example, you do not specify prior uncertainty. Your design is created assuming that the values specified in the Prior Means outline are the true parameter values.

11. Under Design Choices, enter 1500 for **Length of test**.

The test is conducted over 1500 hours, which was the length of the original design.

12. Enter 250 for **Number of units under test**.

The previous experiment tested 150 units, and the augmented experiment tests an additional 100 units, for a total of 250 units.
13. Click **Continue**.

14. Under **Candidate Runs** enter 50 as the minimum number of units for the temperatures of 85, 105, and 125. These represent the runs already completed.

15. Click the Accelerated Life Test Plan red triangle and select **ALT Optimality Criterion > Make Failure Probability Optimal**.

   For more information about this criterion, see “Make Failure Probability Optimal”.

16. Click **Make Design**.

   The optimal experimental design appears along with other results.

**Figure 22.13  Optimal Design**
The optimal design is computed based on the levels of the test runs, the minimum number of units under test, the total number of units to be tested (this is the information in the Candidate Runs outline), and other information that you specified. The optimal design consists of testing the specified number of units at each temperature level:

- 50 units at 85°C. Since the previous experiment already tested 50 units at 85°C, no additional units are needed.
- 58 units at 90°C.
- 50 units at 105°C. Since the previous experiment tested 50 units at 105°C, no additional units are needed.
- 0 units at 110°C. This level is not needed.
- 92 units at 125°C. Since the previous experiment tested 50 units at 125°C, 42 additional units are needed.

**Compare the Augmented Design to the Original Study**

1. In the Distribution Profiler, enter the normal use condition of 25 for Temperature and 100,000 for Time. The estimate of the fraction of the population that is failing is 0.00357, with a 95% confidence interval of 0.00089 to 0.014525. This interval is narrower than the interval from the initial experiment, which was from 0.00056 to 0.02268 (Figure 22.10).

**Figure 22.14** Distribution Profiler for Temp = 25 and Time = 100000
Build an Accelerated Life Test Design

Build an accelerated lift test (ALT) design by selecting **DOE > Special Purpose > Accelerated Life Test Design**. The Accelerated Life Test Plan is updated as you work through the design. The steps for building an accelerated life test design follow the flow in **Figure 22.15**.

**Figure 22.15** Accelerated Life Test Plan Flow

This section describes the outlines in the Accelerated Life Test Plan flow.
Specify the Design Structure

Use the Accelerated Life Test Plan outline to define the model structure and the type of inspection for your design.

**Figure 22.16** Initial ALT Design Window

Number of accelerating Factors

- **One accelerating factor** Select for a design with one factor.
- **Two accelerating factors - main effects model** Select for a two factor design for a main effects model
- **Two accelerating factors - interaction model** Select for a two factor design for a model that contains main effects and an interaction term.

Monitoring Type

- **Continuous Monitoring** Select for a design with exact failure times recorded. Failure times beyond the length of the test are right censored.
- **Monitoring at Intervals** Select for a design with units inspected for failures at intervals. Failure times are interval censored. Enter the number of inspections, the time of the first inspection, and the time between inspections. For inspection intervals that are irregular, you can change the inspection times later in the Design Choices outline.

**Accelerated Life Test Plan** Specify details about the acceleration factor or factors.

Specify Acceleration Factors

Specify details about the acceleration factor or factors.
Figure 22.17  ALT Specification Window

<table>
<thead>
<tr>
<th>Factor Name</th>
<th>Number of Levels</th>
<th>Factor Transformation</th>
<th>Low Usage Condition</th>
<th>High Usage Condition</th>
<th>Low Test Condition</th>
<th>High Test Condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>X1</td>
<td>3</td>
<td>Arrhenius Celsius</td>
<td>20</td>
<td>30</td>
<td>90</td>
<td>110</td>
</tr>
</tbody>
</table>

**Factor Name**  Enter a name for each acceleration factor.

**Number of Levels**  For each acceleration factor, enter the number of proposed levels that you want to include in the experiment.

**Factor Transformation**  For each acceleration factor, select a transformation function. This transformation describes the life-stress relationship, which is the manner in which the life distribution changes across stress levels. The transformations available are Arrhenius Celsius, Reciprocal, Log, Square Root, and Linear.

**Low Usage Condition**  For each acceleration factor, enter a lower bound for its value in typical usage conditions.

**High Usage Condition**  For each acceleration factor, enter an upper bound for its value in typical usage conditions.

**Note:** The Low Usage Condition and High Usage Condition values can be equal. Use equal values when the usage condition is a single value.

**Low Test Condition**  For each acceleration factor, enter the low test condition.

**High Test Condition**  For each acceleration factor, enter the high test condition.

**Note:** The low and high test conditions define the endpoints of the acceleration factors in the design. The initial candidate uses equally spaced levels between the low and high test conditions. You can adjust the levels before constructing the design.

**Specify Design Details**

Specify the factor levels, details of the prior distribution, the time range and probability of interest, the length of the test, and the number of units to be tested.
Figure 22.18 Distribution Details

**Factors** Enter the levels for the acceleration factors. By default, the levels are evenly spaced between the low and high test conditions.

**Distribution Choice** Select a life distribution (LogNormal or Weibull) for each acceleration factor. See “Statistical Details for the ALT Design Platform”.

**Prior Mean** Enter prior estimates of the acceleration model parameters. The prior estimates are hyperparameters in a Bayesian prior distribution. The Prior Mean values can be a best guess based on subject matter knowledge or they can be based on a previous study.

When there is only one acceleration factor, there is a choice to specify the intercept or the quantile.

- **Specify Intercept** Enter the priors for the model parameters including the intercept.
- **Specify Quantile** Enter the priors for the acceleration factor, the expected failure proportion at a given time, and value for the acceleration factor. This information is used to calculate the intercept.
- **Specify prior uncertainty** Select to enter values for the standard error and correlations of the prior distribution for the acceleration model parameters. The standard errors reflect uncertainty relative to the prior estimates of the acceleration model parameters.
Note: When prior uncertainty measures are not specified, the design is created by treating the values entered under Prior Mean as the true parameter values. This design is close to optimal if the prior mean parameters are close to the true values. However, this design is not robust to misspecification of the parameter estimates. If you are unsure about your prior estimates, use the Prior Uncertainty specifications to reflect your uncertainty.

Diagnostic Choices  The choices available depend on the design optimality criteria. The design optimality criteria is found under the Accelerated Lift Test Plan red triangle menu. For a D-optimal design there are no diagnostic choices.

Time range of interest  (Available only for a failure probability optimal design.) Specify the time interval over which you want to estimate the fraction of the population that is failing. Enter the lower value in the left box and the upper value in the right box. If you are interested in a specific time point, enter that value in both boxes.

Probability of interest  (Available only for a quantile estimate optimal design.) Specify the failure fraction for which you want an estimate of time. For example, if you want to estimate the time at which 10% of the units fail, then enter 0.10.

Design Choices  Specify values relating to the length of the test, inspection intervals, and the number of units being tested.

Length of test  (Available only for Continuous Monitoring.) Specify the length of time during which units are on test. When you make the design table, record each unit’s failure time or whether it was right censored.

Inspection Times  (Available only for Monitoring at Intervals.) Specify the times at which inspections are conducted. When you make the design table, these times are used to construct Start Time and End Time columns. The number of units failing in each interval is recorded.

Number of units under test  The number of units in the experiment.

- If you are designing an initial experiment, enter the number of units that you plan to test.
- If you are augmenting a previous experiment, enter the number of units tested in the previous experiment plus the number of units for the next experiment.

Review and Update Specifications for ALT Plans

After you specify the accelerated life test plan design details and click Continue, three new outlines are added to the window.
**Candidate Runs**  Enter the minimum and maximum number of units allowed at each level of the acceleration factors. If you are augmenting a previous experiment, for each setting, include the number of units already run at each level in the Minimum Units column.

**Parameter Variance for Balanced Design**  Provides a matrix proportional to the covariance matrix for the estimates of the acceleration model parameters for the balanced design.

Denote the matrix of first partial derivatives of the model with respect to the parameters, \( \theta \), by \( X \). Denote the error variance by \( \sigma^2 \). Under general conditions, the least squares estimator of \( \theta \) is asymptotically unbiased with asymptotic covariance matrix as follows:

\[
\text{Cov}(\hat{\theta}) = \sigma^2 (X'X)^{-1}
\]

The Parameter Variance for Balanced Design outline gives \( (X'X)^{-1} \), where derivatives are calculated numerically. The calculation assumes that the values specified in the Prior Mean outline are the true parameter values.

See “Nonlinear Models”.

**Distribution Profiler**  Enables you to explore failure probabilities, based on the balanced design, as you vary the acceleration factors and time. The probabilities are based on the assumption that the values specified in the Prior Mean are the true parameter values.

**Tip:** Click **Update Profiler** to update the profiler if changes are made to Distribution Choice, Prior Mean, or Design Choices.
Create and Assess the Optimal

Click **Make Design** to create the optimal ALT design and see results that address the quality of the design.

**Note:** By default, the optimal design is D-optimal. To change the optimality criterion click the Accelerated Life Test Plan red triangle and select **ALT Optimality Criterion**.

**Figure 22.20** Design Outlines

**Design**

<table>
<thead>
<tr>
<th>X1</th>
<th>N Units</th>
<th>Expected Failures</th>
<th>All Censored Probability</th>
<th>Failure Probability</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>90</td>
<td>61</td>
<td>27.5</td>
<td>0.0</td>
<td>0.45</td>
</tr>
<tr>
<td>100</td>
<td>0</td>
<td>0</td>
<td>0.0</td>
<td>0.68</td>
</tr>
<tr>
<td>110</td>
<td>89</td>
<td>78.0</td>
<td>0.0</td>
<td>0.88</td>
</tr>
</tbody>
</table>

**Parameter Variance for Optimal Design**

<table>
<thead>
<tr>
<th>Effect</th>
<th>Intercept</th>
<th>X1</th>
<th>1/β</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intercept</td>
<td>73.7305</td>
<td>-2.3992</td>
<td>-3.2634</td>
</tr>
<tr>
<td>X1</td>
<td>0.07811</td>
<td>0.10646</td>
<td></td>
</tr>
<tr>
<td>1/β</td>
<td>1.53453</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Optimality Criteria**

- D Optimal Design
- D Criterion: -5.493
- Quantile Criterion: 5.516
- Probability Criterion: 0.005

**R Precision Factor (for a 95% CI)**

**Design** Shows the number of units to be tested at each combination of acceleration levels. For a single factor, the first column gives the levels of the factor. For two factors, the first two columns give the levels of the factors.

**N Units** The number of units to be tested at each combination of acceleration levels.

**Expected Failures** Expected number of failures for the design setting. The expected number is computed using the prior model specification.
All Censored Probability  Probability that none of the units tested at the combination of acceleration levels fail. The probability is computed using the prior model specification.

Failure Probability  The expected probability of failure for the design settings. The failure probability is calculated as the expected failures divided by the number of units on test.

Note: The expected failures and censoring probabilities enable you to judge whether your prior specifications are reasonable.

Parameter Variance for Optimal Design  Shows a matrix proportional to the covariance matrix for the estimates of the acceleration model parameters for the optimal design. The calculation assumes that the values specified in the Prior Mean outline are the true parameter values. See “Parameter Variance for Balanced Design”.

Note: Compare the values in the Parameter Variance for Optimal Design matrix to those in the Parameter Variance for Balanced Design matrix to determine the extent to which the optimal design reduces the variance of estimates.

Optimality Criteria  Values for three optimality criteria are provided:

D Criterion  D-optimality of the design. See “Make D-Optimal Design”.

Quantile Criterion  Time I-optimality of the design. See “Make Quantile Estimate Optimal”.

Probability Criterion  Probability I-optimality of the design. See “Make Failure Probability Optimal”.

R Precision Factor (for a 95% CI)  A profiler to evaluate the impact of sample size, level of the factor(s), and the quantile of interest on the R Precision Factor. The R Precision Factor (for a 95% CI) is a measure of the precision of the 95% confidence interval for the quantile of interest.

Simulator  Use the simulator to explore your accelerated model before collecting data.

Number of Simulations  The number of simulation trials to run.

Simulation Probability of Interest  The failure probability of interest.

Simulation Usage  Values for the usage conditions of the acceleration factors.

After clicking Run Simulations, a table of summary statistics and a plot of model fits appear.
Create Design Tables

Use the buttons to make the accelerated lift test design, test plan, and table.

**Make Design**  Updates the optimal design if any changes are made to the Distribution Choice, Prior Mean, Prior Variance Matrix, Design Choices, or Candidate Runs.

**Make Test Plan**  Creates a data table where each row corresponds to a distinct design setting. The table shows the acceleration factor design settings and the number of units to test at those design settings.

**Make Table**  Creates a table that you can use for recording your failure time data.

- For Continuous Monitoring, the table contains a row for each unit to be tested and the design settings for that unit. If a unit fails during the experiment, record the unit’s failure time in the Failure Time column and a 0 in the Censored column. If a unit does not fail during the experiment, record the final inspection time in the Failure Time column and a 1 in the Censored column.

- For Monitoring at Intervals, the table contains a row for each design setting and time interval combination. The time intervals are defined by the Start Time and End Time columns, which are based on the Inspection Times entered in the Design Choices outline. For each setting and time interval, record the number of units that failed in the Number Failing column.

Accelerated Life Test Options

The Accelerated Life Test Plan red triangle menu contains the following options:

**Simulate Responses**  Adds simulated responses to the table when you click Make Table. The simulated responses are created by taking random draws from the chosen distribution at the parameter values specified in the Prior Mean outline. If a simulated response exceeds the specified test length, the observation is censored at the test length value.

**ALT Optimality Criterion**

**Make D-Optimal Design**  Creates a Bayesian D-optimal design if the number of Monte Carlo spheres is greater than 0. The optimality criterion is the expectation of the logarithm of the determinant of the information matrix with respect to the prior distribution. If the number of Monte Carlo spheres is 0, then the design is a locally D-optimal design. It follows that D-optimality focuses on precise estimates of the coefficients.

**Make Quantile Estimate Optimal**  Default optimality criteria. Creates a design that minimizes the variance of a specified percentile at the specified usage conditions.
**Make Failure Probability Optimal**  Creates a design that minimizes the variance of the estimate of failure probability over the time range of interest at the specified usage conditions.

**Advanced Options**

**N Monte Carlo Spheres**  Enables you to set the number of nonzero radius values used in the integration. To find a nonlinear design that optimizes a given optimality criterion, JMP minimizes the integral of the log of the determinant of the Fisher information matrix with respect to the prior distribution of the parameters. Such an integral is calculated numerically. For more information about how the integration is performed, see “Nonlinear Design Options”.

**Tip:** By default N Monte Carlo Spheres is set to four. Higher values result in better numerical accuracy but with more computation time.

**Save Script to Script Window**  Creates the script for the design that you specified in the Accelerated Life Test Plan window and places it in an open script window.

## Statistical Details for the ALT Design Platform

### Failure Distributions for ALT Designs

In the accelerated life test design platform, you can select either a lognormal or Weibull failure distribution.

This section contains the parameterizations for the probability density function (pdf) and cumulative distribution function (cdf) for each distribution. For more information about the Weibull distribution, see *Reliability and Survival Methods*.

### Lognormal

Lognormal distributions are used commonly for failure times when the range of the data is several powers of 10. This distribution is often conceptualized as the multiplicative product of many small positive independently and identically distributed random variables. This distribution is appropriate when the logarithms of the data values appear normally distributed. The probability distribution function is usually characterized by strong right-skewness.
The lognormal family is parameterized by a location parameter, \( \mu \), and a shape parameter, \( \sigma \). The lognormal pdf and cdf are given as follows, where the logarithm is to the base \( e \):

\[
f(x;\mu, \sigma) = \frac{1}{x\sigma} \phi_{\text{nor}}\left[\frac{\log(x) - \mu}{\sigma}\right], \quad x > 0
\]

\[
F(x;\mu, \sigma) = \Phi_{\text{nor}}\left[\frac{\log(x) - \mu}{\sigma}\right],
\]

The functions

\[
\phi_{\text{nor}}(z) = \frac{1}{\sqrt{2\pi}} \exp\left(-\frac{z^2}{2}\right)
\]

and

\[
\Phi_{\text{nor}}(z) = \int_{-\infty}^{z} \phi_{\text{nor}}(w) \, dw
\]

are the pdf and cdf, respectively, for the standard normal distribution (N(0,1)).

**Weibull**

The Weibull distribution can be used to model failure time data with either an increasing or a decreasing hazard rate. It is used frequently in reliability analysis because of its tremendous flexibility in modeling many different types of data, based on the values of the shape parameter.

The Weibull pdf and cdf are commonly represented as follows:

\[
f(x;\alpha, \beta) = \frac{\beta}{\alpha} x^{(\beta-1)} \exp\left[-\left(\frac{x}{\alpha}\right)^\beta\right]; \quad x > 0, \alpha > 0, \beta > 0
\]

\[
F(x;\alpha, \beta) = 1 - \exp\left[-\left(\frac{x}{\alpha}\right)^\beta\right]
\]

where \( \alpha \) is a scale parameter, and \( \beta \) is a shape parameter. The Weibull distribution reduces to an exponential distribution when \( \beta = 1 \).

**Weibull Parameterization**

In JMP, the Weibull parameterization defines \( \sigma \) as the scale parameter and \( \mu \) as the location parameter. These are related to the \( \alpha \) and \( \beta \) Weibull parameterization as follows:

\[
\alpha = \exp(\mu)
\]
\[ \beta = \frac{1}{\sigma} \]

With these parameters, the pdf and the cdf of the Weibull distribution are expressed as a log-transformed smallest extreme value distribution (SEV) using a location-scale parameterization with \( \mu = \log(\alpha) \) and \( \sigma = 1/\beta \):

\[
f(x; \mu, \sigma) = \frac{1}{x \sigma} \phi_{\text{sev}} \left[ \frac{\log(x) - \mu}{\sigma} \right], \quad x > 0, \sigma > 0
\]

\[
F(x; \mu, \sigma) = \Phi_{\text{sev}} \left[ \frac{\log(x) - \mu}{\sigma} \right]
\]

where

\[
\phi_{\text{sev}}(z) = \exp[z - \exp(z)]
\]

and

\[
\Phi_{\text{sev}}(z) = 1 - \exp[-\exp(z)]
\]

are the pdf and cdf, respectively, for the standardized smallest extreme value (\( \mu = 0, \sigma = 1 \)) distribution.

**R Precision Factor (for a 95% CI)**

The R precision factor is a measure of the precision of the estimate of \( t_p \), the \( p^{th} \) quantile of the failure time distribution. An approximate 95% confidence interval for \( \log(t_p) \) is:

\[
\log(t_p) \pm z_{0.975} \sqrt{\text{Var}[\log(t_p)]} = \log(t_p) \pm \log(R)
\]

resulting in a confidence interval for \( t_p \):

\[
[t_p/R, t_pR]
\]

where

\[
R = \exp\left[ z_{0.975} \sqrt{\text{Var}[\log(t_p)]} \right]
\]

To obtain R, use the large sample approximation of the variance of the log(\( t_p \)): 
Optimality Criterion for Accelerated Life Tests

Consider an accelerated life test (ALT) to be conducted across at most two acceleration factors $x_1$ and $x_2$ with $J_1$ and $J_2$ levels, respectively. The goal of test planning is to determine the number of samples to allocate to each combination of the factor levels.

The computation of the optimality criterion depends on the overall Fisher information matrix from the individual level-specific information matrices

$$I(\theta) = \sum_{i,j} n_{ij} I_{ij}(\theta)$$

as well as the inclusion of prior uncertainty $S$ where appropriate.

**D-optimality**

The D-optimal design $D_d$ is the design that minimizes the following expression across all possible values of $n_{jj}$

$$\log \left| \int_{\theta} \left[ S^{-1} + I(\theta) \right]^{-1} \pi(\theta) d\theta \right|$$

where $|.|$ is the determinant operation and $\pi(\theta)$ is the prior distribution over the parameters. This distribution is usually a multivariate normal distribution. The log of the determinant is used for numerical stability.

**Quantile Optimality**

The quantile optimal design $D_q$ is the design that minimizes the expression:

$$\int_{\theta} \left[ \mathbf{c}' I(\theta) \mathbf{c} \right] \pi(\theta) d\theta$$

where the vector $\mathbf{c}$ depends on the use condition.

For the single use condition

$$\mathbf{c}' = \{1, 0, 0, z_p\}$$

where $z_p$ is the $p^{th}$ quantile of the failure distribution.

For the range of use condition let

$$R = \exp z_{0.975} \sqrt{\text{Var}[\log(t_p)]}$$
\[ \varepsilon_i = \frac{G(x_{iULh}) - G(x_{iULl})}{g(x_{iULh}) - g(x_{iULl})} \]

where \( G(\cdot) \) is the antiderivative of \( g(\cdot) \), \( x_{iULh} \) is the highest use level considered for the \( i^{th} \) factor, \( x_{iULl} \) is the lowest use level considered for the same factor. Then

\[ c' = \{1, \varepsilon_1, \varepsilon_2, \varepsilon_1, \varepsilon_2, z_p\} \]

where \( z_p \) is the \( p^{th} \) quantile of the failure distribution.

**Failure Probability Optimality**

The failure probability optimal design \( D_f \) is the design that minimizes the expression:

\[
\int_{\theta} \left\{ \frac{1}{\sigma^2} \left[ \frac{\phi(z_U(\theta))}{\Phi(z_U(\theta))} \right]^2 c'_f p I(\theta) c_{fp} \right\} \left( \pi(\theta)d\theta \right)
\]

where \( z_U(\theta) \) is the standardized log-time at use conditions as defined in "Quantile Optimality". \( c_{fp} \) is similar to \( c \) as defined in "Quantile Optimality" except that the last entry is \( z_U(\theta) \). The quantity in the numerator is based on the asymptotic variance of \( \log \Phi(z_U(\theta)) \), where the log-transformation is used for numerical stability. The asymptotic variance is then standardized in terms of the original \( \log \Phi(z_U(\theta)) \) for consistency and smaller is better. For a range of use conditions, the integral is taken inside of \( \log \Phi(\cdot) \) rather than over the asymptotic variance for ease of computation. It is still appropriate as an optimality metric by the property that the variance of a sum bounds the sum of variances and both the logarithmic function and cdf are monotone functions. As such, minimizing the above expression minimizes the true asymptotic variance of the failure probability by bounding it from above.
When the goal of your experiment is to fit a model that is nonlinear in the unknown parameters, use a nonlinear design to place design points in areas that are key to fitting the nonlinear model. Although you could use an orthogonal design that is optimal for a linear model, such designs, in general, do not place design points in locations that minimize the uncertainty (or maximize the precision) of the estimates of the fitted parameters.

The efficiency of a nonlinear design depends on the values of the unknown parameters. This creates a circular problem in that to find the best design, you need to know the parameters in advance. JMP uses a Bayesian approach to construct a nonlinear design that maximizes the average efficiency over specified ranges of the values of the parameter. To properly specify these ranges, you must have some insight about the system of interest.

Nonlinear designs offer these advantages compared to designs for linear models:

- Predictions using a well-chosen model are likely to be good over a wider range of factor settings.
- It is possible to model response surfaces with complex curvature and with asymptotic behavior.

**Figure 23.1** Design Points for a Nonlinear Model
Contents

Overview of Nonlinear Designs ................................................................. 681
Examples of Nonlinear Designs ............................................................... 682
  Create a Nonlinear Design with No Prior Data ................................. 682
  Augment a Design Using Prior Data .................................................... 687
  Create a Design for a Binomial Response ............................................ 691

Nonlinear Design Launch Window ......................................................... 694

Nonlinear Design Window ..................................................................... 695
  Factors ................................................................................................. 695
  Parameters ........................................................................................... 696
  Design Generation .............................................................................. 696
  Design .................................................................................................. 696
  Make Table or Augment Table ............................................................ 697

Nonlinear Design Options ..................................................................... 697

Statistical Details for Nonlinear Designs ................................................ 698
  Nonlinear Models ................................................................................ 698
  Radial-Spherical Integration of the Optimality Criterion ...................... 699
  Finding the Optimal Design ............................................................... 699
Overview of Nonlinear Designs

Construct designs to fit models that are nonlinear in their parameters using the Nonlinear Design platform. You can construct optimal designs or optimally augment existing data for nonlinear models. Nonlinear designs based on information that is descriptive of the underlying process can yield more accurate estimates of model parameters and prediction of process behavior than is possible with standard designs for polynomial models. For background on nonlinear models, see “Nonlinear Models”.

The efficiency of a design for a nonlinear model depends on the unknown values of the parameters that the design is intended to estimate. For this reason, JMP uses a Bayesian approach to construct designs that are efficient over a wide range of likely parameter values. You can specify a range of values for the unknown parameters and a distribution for the prior. The prior distribution choices include Uniform, Normal, Lognormal, and Exponential.

The Nonlinear Design platform uses a Bayesian approach, optimizing the design over a prior distribution of likely parameter values that you specify. The Bayesian D-optimality criterion is the expectation of the logarithm of the determinant of the information matrix with respect to a sample of parameter vectors that represents this prior probability distribution. The information matrix entries depend on the prediction variances at the design points. Little information is contributed by observations with low variance, where the response is almost certain. It follows that an optimal design places some design settings at high-variance points. See Gotwalt et al. (2009).

A principal of optimal design is that, over the feasible region of experimentation, the optimal design places points in locations with the highest variance of prediction. Though this may seem counter-intuitive, if an alternative design put points at other locations, the prediction variance at the design points of the optimal design would be even higher. For models that are linear in the parameters, the high-variance points tend to be at the vertices of the experimental region. But this is not necessarily true for models that are nonlinear in the parameters.

Note: Nonlinear designs are computed using a random starting design. For this reason, nonlinear designs that you obtain for identical specifications usually differ.

To use the Nonlinear Design platform, you must have an existing data table. That data table must contain the following:

- A column for the response.
- A column for each factor.
- A column that contains a formula showing the relationship between the factors and the response. This formula must include the unknown parameters.
**Note:** This is the same format as is required for a data table used in the Nonlinear platform for modeling.

Your table can come in one of two forms:

- It might be a template, containing only column information and no rows. See “Create a Nonlinear Design with No Prior Data”.
- It might contain rows with predictor information. In this case, the predictor values are included in the nonlinear design. See “Augment a Design Using Prior Data”.

---

**Examples of Nonlinear Designs**

- “Create a Nonlinear Design with No Prior Data”
- “Augment a Design Using Prior Data”
- “Create a Design for a Binomial Response”

**Create a Nonlinear Design with No Prior Data**

This example shows how to create a design when you have not yet collected data, but have a guess for the unknown parameters. In this example, you model the fractional yield (Observed Yield) of an intermediate product in a chemical reaction. The fractional yield is a function of reaction time and temperature. See Box and Draper (1987).

**Create the Design**

1. Select Help > Sample Data Library and open Design Experiment/Reaction Kinetics Start.jmp. Notice the following:
   - The data table contains no rows because no data have been collected.
   - The columns for the predictors, Reaction Temperature and Reaction Time, have the Coding, Design Role, and Factor Changes properties. To see these properties, click \*\*\* in the Columns panel. They tell JMP how to treat these predictors when constructing a design. For information about how to save these column properties, see “Column Properties”.
   - The Observed Yield column will contain response data obtained by running the experiment.
   - The Yield Model column contains the formula that relates the predictors to the response, Observed Yield. Click \+\+\+ in the Columns panel to see the formula. The formula is nonlinear in the parameters t1 and t3.
2. Select **DOE > Special Purpose > Nonlinear Design**.

3. Select Observed Yield and click **Y, Response**.

4. Select Yield Model and click **X, Predictor Formula**.

5. Click **OK**.

   In this example, the values 510 and 540 for Reaction Temperature and 0.1 and 0.3 for Reaction Time were specified using the Coding column property. Alternatively, you can specify a reasonable range of values directly in the Factors outline.

6. Change the values of the parameter t1 to 25 and 50, and t3 to 30 and 35.

   These new values represent a reasonable range of parameter values for the experimental situation. The default values were constructed based on the initial parameter values that were specified in the definition of the prediction formula. For information about constructing formulas, see *Using JMP*.

   Notice that the prior distribution, shown under Distribution, for each of t1 and t3 is set to Normal by default.

7. Change the number of runs to 12 in the Design Generation panel.

**Figure 23.2** Completed Outlines for Reaction Kinetics Experiment

8. Click **Make Design**.

9. Click **Make Table**.
Your design should be similar to the one shown in Figure 23.3. The runs might be in a different order, and the values for Reaction Temperature and Reaction Time, and consequently those computed for Yield Model, can be slightly different. Notice that values appear in the Yield Model column because the column contains the formula for the model. Also notice that the table contains a Model script that you can use to fit a nonlinear model to your observations.

Now that you have created your design table, run your experiment, and record the responses in the Observed Yield column. The data table Reaction Kinetics.jmp, found in the Design Experiment folder contains observed results for the design.

**Explore the Design**

Before analyzing your results, construct a plot to see the design settings.

1. Select Help > Sample Data Library and open Design Experiment/Reaction Kinetics.jmp.
1. Select Graph > Graph Builder.
2. Drag and drop Reaction Temperature into the Y zone.
3. Drag and drop Reaction Time into the X zone.
4. Click the second icon above the graph to deselect the Smoother.
Notice that the points are located in three areas. There are no points at low temperature and high time (the lower right corner of the graph). Unlike orthogonal designs, nonlinear designs do not necessarily place design points at the corners of the design region. In this example, design points at low temperature and high time would be inefficient.

To see the density of design points in the remaining three corners, use the Contour tool.

5. Click to turn on the Contour tool.
6. Click Done.
Notice that there are comparatively few points at low time and high temperature. From the design table, you can see that there are only two such points. Because of the model and the parameter specifications, the optimal design places more design points at high time and high temperature.

**Analyze the Results**

Now that you visually explored your design, analyze your results.

**Note:** Rather than conduct step 1 through step 4, you can run the Model script.

1. Select **Analyze > Specialized Modeling > Nonlinear**.
2. Select Observed Yield and click **Y, Response**.
3. Select Yield Model and click **X, Predictor Formula**.
   Notice that the model appears in the Options for fitting custom formulas panel.
4. Click **OK**.
5. Click **Go** in the Control Panel.
   The iterative search for a solution proceeds until one of the Stop Limit values is reached. Then, the Solution and Correlation of Estimates reports appear.
6. Click the Nonlinear Fit red triangle and select **Profilers > Profiler**.
7. To maximize the yield, click the Prediction Profiler red triangle and select Optimization and Desirability > Maximize Desirability.

**Figure 23.6  Time and Temperature Settings for Maximum Yield**

The estimated maximum yield is approximately 63.5% at a reaction temperature of 540 degrees Kelvin and a reaction time of 0.1945 minutes.
Augment a Design Using Prior Data

This example shows how to create a nonlinear design when you have prior data. In this example, the data pertain to a chemical reaction. You want to model the rate of uptake (velocity) of available organic substrate as a function of the concentration of that substrate. See Meyers (1986). You have already run an experiment, but you want to leverage your results to obtain more precise estimates of the parameters.

Obtain Prior Parameter Estimates

Use your existing experimental data to obtain better estimates of the parameter values.

2. Click the plus sign next to Model (x) in the Columns panel. The formula editor opens.
3. The Parameters outline in the middle bottom of the formula editor shows the current values of the model parameters. The values (b1 = 1 and b2 = 1) are your initial estimates. They are used to compute the Model (x) values in the data table. For your next experiment, you want to replace these with better estimates.
4. Click Cancel to close the formula editor window.
5. Select Analyze > Specialized Modeling > Nonlinear.
6. Select Velocity (y) and click Y, Response.
7. Select Model (x) and click X, Predictor Formula.

Notice that the formula given by Model (x) appears in the Options for fitting custom formulas panel.
8. Click **OK**.

9. In the Control Panel, click **Go**.

   The iterative search for a solution proceeds until one of the Stop Limit values is reached. Then, the Solution and Correlation of Estimates reports appear. Also, an option appears in the Control Panel enabling you to add confidence limits to the Solution report.

10. In the Control Panel, click **Confidence Limits**.

    Confidence intervals for the parameters b1 and b2 appear in the Solution report.
Figure 23.8 Nonlinear Fit Results

The Lower CL and Upper CL values for $b_1$ and $b_2$ define ranges of values for these parameters. Next, use these intervals to define a range for the prior values in your augmented nonlinear design.

**Note:** Do not close the Nonlinear Fit report because these results are needed in the next steps.

**Augment the Design**

Now, create a design to estimate the nonlinear parameters more precisely.

1. With the Chemical Kinetics.jmp data table active, select **DOE > Special Purpose > Nonlinear Design**.
2. Select Velocity (y) and click **Y, Response**.
3. Select Model (x) and click **X, Predictor Formula**.
4. Click **OK**.
In the Chemical Kinetics.jmp data, the values for Concentration range from 0.417 to 6.25. Therefore, these values initially appear as the low and high values in the Factors outline. You want to change these values to encompass a broader interval.

5. Click 0.417 and type 0.1. Click 6.25 and type 7.

6. Leave the prior Distribution for each parameter set to Normal.

   The range of Values for the parameters reflects the uncertainty of your knowledge about them. You could specify a range that you think covers 95% of possible parameter values. The confidence limits from the Nonlinear Fit report shown in Figure 23.8 provide such a range. Replace the Values for the parameters in the Parameters outline with the confidence limits, rounding to three decimal places.

7. In the DOE Nonlinear Design window, enter these values into the Parameters for b1 and b2:
   - b1: 0.568 and 3.158
   - bb2: 6.858 and 45.830
Chapter 23  Nonlinear Designs

8. Enter 40 for the **Number of Runs** in the Design Generation panel.

9. Click **Make Design**.

The Design outline opens, showing the Concentration and Velocity (y) values for the original 13 runs and new Concentration settings for the additional 27 runs.

10. Click **Make Table**.

This creates a new JMP design table that contains the settings and results for the original 13-run design and settings for 27 new runs. Instead of creating a new data table, you can add the new runs to your existing data table by clicking Augment Table instead of Make Table.

The new runs reflect the broader interval of Concentration values and the range of values for b1 and b2 obtained from the original experiment, which are used to define the prior distribution. Both should lead to more precise estimates of b1 and b2.

**Create a Design for a Binomial Response**

In some applications, the measurement of interest is a pass/fail (binomial) measurement. In this example, you will construct a nonlinear design for a binomial response with one design factor. For more information on designs in nonlinear settings and the binomial case in particular, see Gotwalt et al. (2009).

You plan to model the probability of success for your binomial response as a function of a single factor x. using a generalized linear model with a logistic link function

\[
Y(x) = \frac{1}{1 + e^{-(\beta_0 + \beta_1 x)}}
\]
and the variance of $Y$ as the weight.

This model is nonlinear in the unknown parameters $\beta_0$ and $\beta_1$. Use the nonlinear designer to plan an experimental design. Your goal is to model the effect of $x$ on your binomial response $Y$.

To generated the desired non-linear design you must have a data table containing columns for the predictor, a column containing a formula for the nonlinear response model that you are fitting, and a column with a formula for your weights.

Data Table for Design Construction

The One Factor Logistic Design.jmp data table, found in the Design Experiment folder, contains the following:

- Column $x$ for the predictor. The Coding property defined for this column sets the low value to 0 and the high value to 1.
- Column $Y$, for the response. This is the column for collected responses (0/1) from your testing.
- Column Linear Pred that contains a formula for the linear portion of the link function. To view the formula, click the plus sign to the right of Linear Pred in the Columns panel. The model formula includes the initial estimates for the parameters $b_0$ and $b_1$. Initial parameter values are set when you define a formula. These values are shown in the formula element panel in the lower center of the formula editor window.
- Column Var $Y$ that contains the formula for the variance of the response based on the assumed logistic model. This is $p(1-p)$ where $p$ is the logistic function. This column is used as the weight column.
- Column Pred $P$ that contains the logistic link function.
Create the Design

1. Select Help > Sample Data Library and open Design Experiment/One Factor Logistic Design.jmp.
2. Select DOE > Special Purpose > Nonlinear Design.
4. Select Linear Pred and click X, Predictor Formula.
5. Select Var Y and click Weight.
6. Click OK.

Figure 23.12 Nonlinear Design Window

<table>
<thead>
<tr>
<th>Factors</th>
<th>Name</th>
<th>Role</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td></td>
<td></td>
<td>0</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Name</th>
<th>Distribution</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>b0</td>
<td>Normal</td>
<td>-1</td>
<td></td>
</tr>
<tr>
<td>b1</td>
<td>Normal</td>
<td>2</td>
<td></td>
</tr>
</tbody>
</table>

The Factors outline shows the factor x with the specified values of 0 and 1. The Parameters outline shows the two model parameters with each prior distribution set to a normal distribution. JMP computes default Values based on your initial settings for the parameter values. You can change the assumed distribution and ranges for the parameters in this outline. Leave all settings as they appear. The default number of runs is 10.

7. Click the Nonlinear Design red triangle and select Advanced Options > N Monte Carlo Spheres. Set the number of spheres to 0 to obtain a locally optimal design. Click OK.
8. Click Make Design.
9. Click Augment Table.

This adds the 10 run design to One Factor Logistic Design.jmp (Figure 23.13). Your design table will be different because the optimization algorithm has a random component.
The model saved to the data table is a nonlinear model to fit the “Linear Pred” used in the creation of the design. After you collect your data, use a generalized linear model (GLM) with a logit link function to model the effect of x on Y.

Nonlinear Design Launch Window

To use the Nonlinear Design platform, you must have an existing data table that contains the following:

- A column for the response.
- A column for each factor.
- A column that contains a formula showing the relationship between the factors and the response. This formula must include the unknown parameters.

For information about formulas, see Using JMP.

The table can contain values for the predictors and response. If it does, the design that you construct augments the design that is implicit in the table. There can be no row containing missing predictor values.

With your starting data table active, select **DOE > Special Purpose > Nonlinear Design**.


Y, Response The numeric column for response values.

X, Predictor Formula The numeric column that contains the formula for the nonlinear model. This formula must contain parameters.

Weight (Optional) A numeric column that assigns weights to the observations.

Nonlinear Design Window

The Nonlinear Design window updates as you work through the design steps. The outlines, separated by buttons that update the outlines, follow the flow in Figure 23.15.

Figure 23.15 Nonlinear Design Flow

The initial design window shows the Factors, Parameters, and Design Generation outlines.

Figure 23.16 Initial Design Window

Factors

The column names used in the model formula are automatically inserted in the Name column of the Factors outline. Each factor’s role is set to Continuous.

For each factor, the Values are initially set to -1 and 1. Or, if you have defined a value using the Coding column property, those values are used instead. You can change these values in the factors outline.
Parameters

The parameter names used in the model formula are automatically inserted in the Name column of the Parameters outline.

For each parameter, the Values are initially set to a symmetric interval around the initial value specified in the parameter definition. This interval is obtained by taking the initial value’s distance to 0, and constructing an interval of this width around the initial value. These values are used in defining prior distributions for the model parameters.

**Note:** Adjust the Values for the parameters in conjunction with your choice of distribution to reflect your uncertainty about the model parameters.

Four families of prior distributions are listed under Distribution. The Values that you specify for the parameters determine which member of the family of prior distributions that is used. Denote the low value by low and the high value by high. Then the distributions are determined as follows:

- Uniform: The distribution is uniform on the interval (low, high).
- Normal, Lognormal, Exponential: The distribution is the one where low is the 0.025 quantile and where high is the 0.975 quantile.

Design Generation

JMP provides a suggested number of runs, determined as follows:

- If you are not augmenting a data table, the number of runs is four times the number of parameters plus two.
- If you are augmenting a data table, the number of runs is the number of runs in the data table plus two times the number of parameters.

**Note:** If you are augmenting a design, the number of runs that JMP suggests or that you specify includes those runs corresponding to observations in your data table. Adjust the number of runs appropriately.

Design

When you click Make Design, JMP constructs the design and adds a Design outline to the Nonlinear Design window. In the Design outline, you can review the factor level settings.
**Make Table or Augment Table**

The Make Table button creates a new design table. If your original table included existing runs, the new table also includes the existing runs. The **Augment Table** button adds the new runs to your existing table.

**Nonlinear Design Options**

The red triangle menu in the Nonlinear Design platform contains these options:

**Save Responses**  Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.

**Load Responses**  Not available.

**Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

**Load Factors**  Not available.

**Save Constraints**  Not available.

**Load Constraints**  Not available.

**Simulate Responses**  Adds response values to the design table. Select this option before you click Make Table. Then, in the resulting design table, the response columns contain simulated values.

*Note:* To set a preference to always simulate responses, select **File > Preferences > Platforms > DOE** and select **Simulate Responses**.

**Number of Starts**  Sets the number of times that a nonlinear design is created using the quadrature method. Among the designs created, the platform selects the design that maximizes the optimality criterion.

**Advanced Options > Number of Monte Carlo Samples**  Sets the number of octahedra per sphere used in computing the optimality criterion. The default value is one octahedron. See “Radial-Spherical Integration of the Optimality Criterion”.

**Advanced Options > N Monte Carlo Spheres**  Sets the number of nonzero radius values used in computing the optimality criterion. The default is two. See “Radial-Spherical Integration of the Optimality Criterion”.

Statistical Details for Nonlinear Designs

- “Nonlinear Models”
- “Radial-Spherical Integration of the Optimality Criterion”
- “Finding the Optimal Design”

Nonlinear Models

Denote the vector of \( n \) responses by \( \mathbf{Y} = (Y_1, Y_2, ..., Y_n)' \). A nonlinear model is defined by the following properties:

- The \( Y_i \) are independent and identically distributed with an exponential family distribution.
- The expected value of each \( Y_i \) given a vector of predictor values \( \mathbf{x}_i \) is a nonlinear function of parameters, \( \theta \). Denote this function as follows:
  \[
  E(Y_i(\mathbf{x})) = f(\theta, \mathbf{x}_i)
  \]
- Each \( Y_i \) is expressed as follows:
  \[
  Y_i = f(\theta, \mathbf{x}_i) + \varepsilon_i
  \]
- The vector of errors, \( \varepsilon = (\varepsilon_1, \varepsilon_2, ..., \varepsilon_n)' \) has mean 0 and covariance matrix \( \sigma^2 \mathbf{I} \), where \( \mathbf{I} \) is the \( n \times n \) identity matrix.

Denote the matrix of first partial derivatives of the function \( f \) with respect to the parameters \( \theta \) by \( \mathbf{X} \). Under general conditions, the least squares estimator of \( \theta \) is asymptotically unbiased, with asymptotic covariance matrix given as follows:

\[
\text{Cov}(\hat{\theta}) = \sigma^2 (\mathbf{X}'\mathbf{X})^{-1}
\]

For the proof of this result, see Wu (1981) and Jennrich (1969).
Radial-Spherical Integration of the Optimality Criterion

The optimality criterion is the expectation of the logarithm of the determinant of the information matrix with respect to the prior distribution. Consequently, finding an optimal nonlinear design requires maximizing the integral of the log of the determinant of the Fisher information matrix with respect to the prior distribution of the parameters. This integral must be calculated numerically. The approach used in the Nonlinear Design platform is based on Gotwalt et al. (2009).

For normal distribution priors, the integral is reparameterized into a radial direction and a number of angular directions equal to the number of parameters minus one. The radial part of the integral is computed using Radau-Gauss-Laguerre quadrature with an evaluation at radius = 0. This is done by constructing a certain number of hyperoctahedra and randomly rotating each of them.

If the prior distribution is not normal, then the integral is reparameterized so that the new parameters have a normal distribution. Then the radial-spherical integration method is applied.

Note: If the prior distribution for the parameters does not lend itself to a solution and the process fails, a message is added to the window that the Fisher information matrix is singular in a region of the parameter space. When this occurs, consider changing the prior distribution or the ranges of the parameters.

Finding the Optimal Design

The method used to find an optimal design is similar to the coordinate exchange algorithm described in Meyer and Nachtsheim (1995). For more information about how the nonlinear optimal design is obtained, see Gotwalt et al. (2009). The general approach proceeds as follows:

- Random designs are tested until a nonsingular starting design is found.
- Iterations are conducted, where each iteration consists of a pass through all the runs.
- For each run, factors are optimized one at a time.
- The objective function is the Bayesian D-optimality criterion. This is the expectation of the logarithm of the determinant of the information matrix with respect to the prior distribution.
- Iterations terminate once the change in the objective function is small.
A Balanced Incomplete Block Design (BIBD) can be used when it is not possible to include all treatments or factor combinations in every block. Use BIBDs for testing $a$ treatments in $b$ blocks when only $k$ treatments can be run in any one block (and $k < a$). For example, you might have a situation where there are limitations on the number of treatments that can be tested at the same time. The BIBD design is constructed such that each treatment and each pair of treatments occurs together in blocks an equal number of times. This makes the design balanced. Not including all treatments in every block makes the design incomplete.

Use the Balanced Incomplete Block Platform to construct BIBDs. In addition, you can use the platform to construct complete block designs where each treatment occurs in every block.

**Figure 24.1** BIBD for 4 Treatments in 4 Blocks of Size 3

<table>
<thead>
<tr>
<th>Design</th>
<th>Block</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>L2</td>
</tr>
<tr>
<td>2</td>
<td>L3</td>
</tr>
<tr>
<td>3</td>
<td>L4</td>
</tr>
<tr>
<td>4</td>
<td>L1</td>
</tr>
<tr>
<td>1</td>
<td>L3</td>
</tr>
<tr>
<td>2</td>
<td>L4</td>
</tr>
<tr>
<td>3</td>
<td>L1</td>
</tr>
<tr>
<td>4</td>
<td>L2</td>
</tr>
<tr>
<td>1</td>
<td>L2</td>
</tr>
<tr>
<td>2</td>
<td>L1</td>
</tr>
<tr>
<td>3</td>
<td>L3</td>
</tr>
<tr>
<td>4</td>
<td>L4</td>
</tr>
</tbody>
</table>
Contents

Example of Balanced Incomplete Block Designs .......................................................... 703
Build a Balanced Incomplete Block Design ............................................................... 705
  Specify Treatments, Blocks, and Make Design ....................................................... 705
  Verify Design and Make Table ................................................................................ 706
Balanced Incomplete Block Design Options ............................................................... 707
Statistical Details for Balanced Incomplete Block Designs ........................................ 708
Example of Balanced Incomplete Block Designs

In this example, you want to test three new product formulations in your plant, and you want to block by day. There is a limit of two formulations that can be run per day. In addition, you need to finish your experiment in one work week. You need a design with at most five blocks.

1. Select **DOE > Special Purpose > Balanced Incomplete Block Design**.
2. Set the Treatment Size to 3.

   **Tip:** Treatment size can refer to the number of levels of a single factor or combinations of levels of two or more factors.

3. Select 2 for the **Block Size**.
4. Select 3 for **Allowable Blocks**.

   You can select 3 or 6 blocks. In this example, each block is a day and you can have no more than 5 days or 5 blocks. The number of runs is 6 because you have 3 blocks of size 2.

**Note:** You can enter a Treatment Name, Block Name, and Treatment Labels to customize your design table.

5. Click **Make Design**.

**Figure 24.2** BIBD for 3 Treatments in 3 Blocks of Size 2
The design has six runs in three blocks with two treatments in each block as seen in the Block Design outline. For additional design details open the Design and Incidence Matrix outlines. See “Verify Design and Make Table”.

Initially, you had to select a design with 3 or 6 blocks. You selected 3 blocks because of time constraints in your plant. However, suppose you were allowed to run your experiment for 6 days. You could then update the design to use 6 blocks.

6. Select 6 in the **Allowable Blocks** menu.
7. Click **Make Design** to update the design.
8. Open the **Incidence Matrix** outline.

**Figure 24.3** BIBD Design Details for 3 Treatments in 6 Blocks of Size 2

Now the design has 6 blocks. The incidence matrix shows the treatments that are in each block. The Pairwise Treatment Frequencies shows that each treatment appears four times (diagonal entries) and that each treatment pair occurs twice in the design (off diagonal entries). The blocks each have two positions. The Positional Frequencies show that treatment L1 always occurs in position 1, L2 is split between the two positions, and L3 occurs in position 2.
Build a Balanced Incomplete Block Design

Build a Balanced Incomplete Block Design by selecting **DOE > Special Purpose > Balanced Incomplete Block Design**.

**Figure 24.4** Balanced Incomplete Block Design Window

For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

The Balanced Incomplete Block Design window updates as you work through the design. The steps to build a BIBD follow the flow in **Figure 24.5**.

**Figure 24.5** Balanced Incomplete Block Design Flow

**Specify Treatments, Blocks, and Make Design**

The following options are in the Design Options outline:

**Treatment Name**  The name of the treatment factor.

**Treatment Size**  The number of treatments.

*Tip:* Treatments can be factor-level combinations.

**Treatment Labels**  Labels for the treatments. The default labeling is L1 to La where a is the total number of treatments.

**Block Name**  The name of the blocking factor.

**Block Size**  The number of treatments that can be run in any one block.
Note: Values for Block Size are determined by the number of treatments. If a value is not in the list, it is because the BIBD platform cannot create a design with that block size for the given number of treatments.

Allowable Blocks  Allowable number of blocks in the design based on the number of treatments and the block size.

Include Block Multiples  Allows for the selection of a design with the number of blocks equal to a multiple (that you specify) of the initial allowable block sizes. The additional (multiple) blocks are cyclic permutations of the original design.

Specify Multiplier  (Available when Include Block Multiples is selected.) Multiplier that you want to apply to the initial allowable block sizes.

Make Design  Generates the design.

Verify Design and Make Table

Block Design  Shows the BIBD in a traditional design layout.

Make Table  Creates the BIBD data table.

Include order column  Includes a column in the design table for the order of runs within each block.

Design  Shows the BIBD in a block layout where each row represents a block and the treatments in that block.

Incidence Matrix  Shows the treatments that occur in each block. Each row of the matrix corresponds to a block in the design with a 1 if the treatment is in the block and 0 otherwise.

Pairwise Treatment Frequencies  Shows the number of times each treatment occurs in the same block with every other treatment on the off-diagonal entries. The diagonal entries are the total number of times each treatment occurs.

Positional Frequencies  Shows the number of times each treatment occurs in each block position.
Balanced Incomplete Block Design Options

The red triangle menu in the Balanced Incomplete Block Design platform contains these options:

**Simulate Responses**  Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

- A set of simulated response values is added to each response column.
- For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
- A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

**Note:** Not all distributions are available for all design types.

- A script called **DOE Simulate** is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a new column called `<Y> Simulated`, where `Y` is the name of the response. Clicking Apply again updates the formula and values in `<Y> Simulated`.

For additional details, see “Simulate Responses”.

**Note:** You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in *Basic Analysis*.

**Save Script to Script Window**  Creates the script for the design that you specified in the Balanced Incomplete Block window and places it in an open script window.
Statistical Details for Balanced Incomplete Block Designs

The total number of observations in a BIBD is determined by the following equation:

\[ N = ar = bk \]

where

- \( a \) is the number of treatments
- \( r \) is the number of times each treatment occurs in the design
- \( b \) is the number of blocks
- \( k \) is the number of treatments in each block

The number of blocks in which each pair of treatments occurs is given by the following:

\[ \lambda = \frac{r(k-1)}{a-1} \]

where \( \lambda \) must be an integer.

These conditions are necessary for a BIBD to exist, but not sufficient. The BIBD platform presents values for which it can generate a BIBD.

When the Include Block Multiples is selected, the original BIBD is copied the number of times specified. The additional (multiple) blocks are cyclic permutations of the original design. The positions of treatments in the copies differs from the original.

For more information about BIBDs, see SAS Institute Inc. (2013).
Chapter 25

MSA Designs

Create a Design for a Measurement Systems Analysis Experiment

Measurement systems analysis experiments, also known as gage R&R studies, are based on full factorial designs. The MSA platform generates a full factorial design for a measurement systems analysis (MSA) experiment and provides design diagnostic measures. For analysis of MSA experiments, see Quality and Process Methods.

Figure 25.1 MSA Factor Settings

<table>
<thead>
<tr>
<th>Name</th>
<th>MSA Role</th>
<th># of Levels</th>
<th>Variance</th>
<th>Randomize</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part</td>
<td>Part</td>
<td>5</td>
<td>1</td>
<td>Yes</td>
</tr>
<tr>
<td>Operator</td>
<td>Operator</td>
<td>4</td>
<td>1</td>
<td>Yes</td>
</tr>
<tr>
<td>Gauge</td>
<td>Gauge</td>
<td>2</td>
<td>1</td>
<td>Yes</td>
</tr>
</tbody>
</table>
## Contents

- Overview of MSA Designs ................................................................. 711
- Example of MSA Design ................................................................. 711
- Build an MSA Design ................................................................. 714
  - Responses .................................................................................. 714
  - Factors ....................................................................................... 717
- MSA Design .................................................................................. 718
- MSA Design Diagnostics ................................................................. 718
- MSA Design Table .......................................................................... 719
- MSA Design Options ....................................................................... 719
- Statistical Details for the MSA Design Platform ................................. 720
Overview of MSA Designs

A measurement systems analysis (MSA) design is a full factorial design where the factors are random effects. The focus of the study is to estimate the variation in the response due to each factor. The MSA Design platform generates a full factorial design with diagnostic measures specific to an MSA study.

Example of MSA Design

In this example, you want to study the variability in your measurement systems due to instruments and operators. You have two scales in your lab and four operators who have time to participate in the study. You have a set of five standard parts to weigh and each operator makes six measurements per part per instrument. You do not have previous estimates of variability, so you design an experiment based on a variance of one, which results in diagnostics that are scaled to the true variability.

1. Select DOE > Special Purpose > MSA Design.
2. Click on the Match Target Goal for the response Y, and select Match Target.
3. Set the # of Levels for Part to 5.
4. Set Add N Factors to 2 and click Add Factor.
5. Rename X2 to Operator, click on None to set the MSA Role to Operator, and type 4 in the # of Levels column.
6. Rename X3 to Gauge, click on None to set the MSA Role to Gauge, and type 2 in the # of Levels column.
7. In the Number of Replicates box, type 5.
   Specifying 5 replicates indicates that each run of the design contains 6 measurements.
8. Leave the Replicate Runs set to Fast Repeat to run the replicates sequentially.

Figure 25.2 Factor Settings
9. Select **Show Levels** (check box in the Factors outline).

10. Edit the factor Values as shown in Figure 25.3.

**Figure 25.3** Factor Values

![Factor Values Table](image)

**Note:** Setting the Random Seed in step 11 reproduces the design and diagnostics shown in this example.

11. (Optional) Click the MSA red triangle, select **Set Random Seed**, and type 123.

12. Click **Make Design**.

**Note:** Click **Make Table** to generate a table for data collection. See “MSA Design Table” for analysis scripts that are included in the design table.

13. Scroll down to the Design Diagnostics outline and click the gray disclosure icon to open.

   The Design Diagnostics report contains settings for assumed variances that are then used to estimate confidence intervals, variance proportions, and EMP Monitoring Classifications. These estimates are used to evaluate the strength of your MSA study design. Explore different variance assumptions, or use the **Back** button to make adjustments to your design.

14. Adjust the expected Variance of your factors to explore the impact on your design diagnostics.
   - Set Operator Variance to 0.5.
   - Set Part Variance to 10.
   - Set Gauge Variance to 0.25.
All diagnostics are based on simulations that are computed from the sampling distributions of the appropriate mean squares. Based on the variance estimate assumptions, the study results in a 74% probability of a first class process. Note that the diagnostics are based on a completely randomized design. In this example, you selected the Fast Repeat to run the replicates sequentially. Often logistics of running the MSA requires the replicates to be run sequentially.
Build an MSA Design

Build an MSA design by selecting **DOE > Special Purpose > MSA Design.**

**Figure 25.5** MSA Design Window

For more information about the options in the Select Columns red triangle menu, see *Using JMP.*

The MSA design window updates as you work through the design steps. The steps to build an MSA design follow the flow in **Figure 25.6.**

**Figure 25.6** MSA Design Flow

---

**Responses**

Use the Responses outline to specify one or more responses.

**Tip:** When you have completed the Responses outline, consider selecting **Save Responses** from the red triangle menu. This option saves the response names, goals, limits, and importance values in a data table that you can later reload in DOE platforms.
Add Response  Enters a single response with a goal type of Maximize, Match Target, Minimize, None, or Functional. If you select Match Target, enter limits for your target value. If you select Maximize or Minimize, entering limits is not required but can be useful if you intend to use desirability functions.

Functional (Available only in JMP Pro.) Adds multiple Y columns with FDE column properties to the design data table. These columns can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.

Remove  Removes the selected responses.

Number of Responses  Enters additional responses so that the number that you enter is the total number of responses. If you have entered a response other than the default Y, the Goal for each of the additional responses is the Goal associated with the last response entered. Otherwise, the Goal defaults to Match Target. Click the Goal type in the table to change it.

The Responses outline contains the following columns:

Response Name  The name of the response. When added, a response is given a default name of Y, Y2, and so on. To change this name, double-click it and enter the desired name.

Goal, Lower Limit, Upper Limit  The Goal tells JMP that you want to maximize or minimize your response, match a target, or that you have no goal for your response. JMP assigns a Response Limits column property, based on these specifications, to each response column in the design table. It uses this information to define a desirability function for each response. The Profiler and Contour Profiler use these desirability functions to find optimal factor settings. For further details, see the Profiler chapter in Profilers and “Response Limits”.

– A Goal of Maximize indicates that the best value is the largest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

– A Goal of Minimize indicates that the best value is the smallest possible. If there are natural lower or upper bounds, you can specify these as the Lower Limit or Upper Limit.

– A Goal of Match Target indicates that the best value is a specific target value. The default target value is assumed to be midway between the Lower Limit and Upper Limit.
A Goal of None indicates that there is no goal in terms of optimization. No desirability function is constructed.

**Note:** If your target response is not midway between the Lower Limit and the Upper Limit, you can change the target after you generate your design table. In the data table, open the Column Info window for the response column (Cols > Column Info) and enter the desired target value.

**Importance**  When you have several responses, the Importance values that you specify are used to compute an overall desirability function. These values are treated as weights for the responses. If there is only one response, then specifying the Importance is unnecessary because it is set to 1 by default.

**Detection Limits**  The lower and upper detection limits are bounds beyond which the response cannot be measured. The detection limits are saved as a column property. You can use these limits to specify a censored response in the Generalized Regression platform. See the Generalized Regression chapter in *Fitting Linear Models*.

**Editing the Responses Outline**
In the Responses outline, note the following:
- Double-click a response to edit the response name.
- Click the goal to change it.
- Click on a limit or importance weight to change it.
- For multiple responses, you might want to enter values for the importance weights.

**Response Limits Column Property**
The Goal, Lower Limit, Upper Limit, and Importance that you specify when you enter a response are used in finding optimal factor settings. For each response, the information is saved in the generated design data table as a Response Limits column property. JMP uses this information to define the desirability function. The desirability function is used in the Prediction Profiler to find optimal factor settings. For further details about the Response Limits column property and examples of its use, see “Response Limits”.

If you do not specify a Lower Limit and Upper Limit, JMP uses the range of the observed data for the response to define the limits for the desirability function. Specifying the Lower Limit and Upper Limit gives you control over the specification of the desirability function. For more details about the construction of the desirability function, see the Profiler chapter in *Profilers*.

**Note:** Detection limits are not available for MSA designs, however, they can be added via JSL.
Factors

The MSA Factors outline defaults to a 3-part study.

**Note:** The MSA designer requires at least one factor with a part role.

**Add Factor**  Click to add one or more factors.

**Remove**  Removes the selected factors.

**Add N Factors**  Adds multiple factors. Enter the number of factors to add and click **Add Factor**.

**Show Levels**  Select to show factor levels. When selected, the following options are available.

- **Name**  Factor name with a menu to add a level.
- **Role**  Fixed to a categorical factor. MSA factors are categorical by default.
- **Values**  Specifies the factor levels, which you can click to edit.

**Name**  Specifies the name of the factor, which you can click to edit. Initially, three factors are in the factor list; Operator, Part, and Gauge. You can add or remove factors from this list.

**MSA Role**  Specifies the MSA Role of the factor. Click to select from Operator, Part, Gauge, or None.

**# of Levels**  Specifies the number of levels for a factor.

**Variance**  Specifies a prior variance due to the factor. The default is one, which results in diagnostics that are scaled to the true variability.

**Randomize**  Specifies to randomize the factor in the design table.

**Number of Replicates**  Specifies the number of replicates between 0 and 10 to include in your design. The number of replicates is the number of measurements in addition to an initial measurement. The default is two replicates, which results in three measurements for each run. To specify a single measurement per run, set the number of replicates to zero.

**Replicate Runs**  Specifies the run order for replicate runs in the experiment.

- **Fast Repeat**  replicates are run sequentially.
- **Batch Repeat**  The factor combinations are run in batches. Each replicate set makes up a new batch of runs. The order of runs is the same from batch to batch.
- **Completely Randomized**  the factor combinations are run in batches. Each replicate set makes up a new batch of runs. The order of runs is randomized within each batch.
Note: A Replicates column is included in the final design table. For the completely randomized run option, the Replicates column is hidden.

MSA Design

The Design outline shows the runs for the MSA design.

MSA Design Diagnostics

All diagnostics in the Design Diagnostics report are based on simulations that are computed from the sampling distributions of the appropriate mean squares. You can make changes to the variance estimate for each model factor. The design diagnostics update with changes to the variance estimates. This enables you to explore the ability of your design to measure your systems under different assumed models.

MSA Design Variance Estimates

The Variance Estimates report enables you to specify a variance estimate for each MSA model factor. Diagnostics are based on your variance estimates and include simulated confidence interval (CI) bounds. Simulated estimates and CI bounds are also provided for the probability of a response falling out of specifications. The specifications are defined by the lower and upper limits set for the response.

MSA Design Variance Proportions

The Variance Proportions report contains diagnostics for the estimated variance proportions based on the assumed variances. The report also includes simulated approximate CI bounds and measurement systems EMP classification probability. For more information about EMP classification see Quality and Process Methods.

MSA Design Simulation Results and Options

The Simulation report contains box plots of the distribution of the simulated variance proportions used to estimate the variance proportions CI bounds. The simulations are based on a large number of trials.

The Simulation Results red triangle menu contains the following options:

Show Statistics Opens summary statistics for each model factor.

Show Points Shows or hides the points in the box plots that fall beyond the whiskers.

Make Data Table Opens a data table of the simulation results.
MSA Design Table

Use the buttons to finish your MSA design construction.

**Make Table**  Constructs the MSA design data table. In addition to the design, the table includes a run order column, a replicates column, and the following scripts for analysis:

- **EMP Measurement Systems Analysis**  Launches the MSA analysis platform. See “Measurement Systems Analysis”.
- **Variability Chart**  Launches the Variability Gauge Chart platform. See “Variability Gauge Charts”.
- **DOE Dialog**  Launches the MSA Design platform with the specifications used to generate the current design table.
- **Operator Worksheets**  Opens a data table for each operator to use as a worksheet for data collection.
- **Back**  Takes you back to make adjustments to the design specifications.

MSA Design Options

The MSA Design red triangle menu contains the following options:

- **Save Responses**  Saves the information in the Responses panel to a new data table. You can then quickly load the responses and their associated information into most DOE windows. This option is helpful if you anticipate reusing the responses.
- **Load Responses**  Loads responses that you saved using the Save Responses option.
- **Save Factors**  Saves the information in the Factors panel to a new data table. Each factor’s column contains its levels. Other information is stored as column properties. You can then quickly load the factors and their associated information into most DOE windows.

**Note:** It is possible to create a factors table by entering data into an empty table, but remember to assign each column an appropriate Design Role. Do this by right-clicking on the column name in the data grid and selecting **Column Properties > Design Role**. In the Design Role area, select the appropriate role.

- **Load Factors**  Loads factors that you saved using the Save Factors option.
- **Save Constraints**  (Unavailable for some platforms) Saves factor constraints that you defined in the Define Factor Constraints or Linear Constraints outline into a data table, with a
column for each constraint. You can then quickly load the constraints into most DOE windows.

In the constraint table, the first rows contain the coefficients for each factor. The last row contains the inequality bound. Each constraint’s column contains a column property called `ConstraintState` that identifies the constraint as a “less than” or a “greater than” constraint. See “`ConstraintState`”.

**Load Constraints**  (Unavailable for some platforms) Loads factor constraints that you saved using the Save Constraints option.

**Set Random Seed**  Sets the random seed that JMP uses to control actions that have a random component. These actions include one or more of the following:

- initializing search algorithms for design generation
- randomizing Run Order for design construction
- selecting a starting design for designs based on random starts

To reproduce a design, enter the random seed that generated the design before clicking Make Design.

**Note:** The random seed associated with a design is included in the DOE Dialog script that is saved to the design data table.

---

**Statistical Details for the MSA Design Platform**

The variance and variance proportion simulations are computed using simulated mean square terms. The mean square terms are simulated from chi-square distributions scaled by the associated expected mean square. The simulated variances are computed using method of moments estimators and are then used in computing the confidence bounds for the variance proportions.

For example, consider the variance for Part. The simulation computations follow these steps:

1. Simulate the mean square for Part, the mean squares for each two-way interaction involving Part, as well as any mean squares for higher order interactions involving Part.
2. Compute the variance using inclusion-exclusion:
   
   variance of Part = mean square of Part – mean square of two-way interactions + mean square of three-way interactions -...+/-mean square of highest order interaction

3. The simulated variance proportion for Part is then computed as Variance of Part/Total Variance.
Note: Only the distributions of the mean square terms are known directly. Specifically, Mean Square = Chi-Squared Distribution(df)*Expected Mean Square. The distributions of the variance and variance proportions are approximated by the simulated values. Because of this, the confidence bounds can differ each time a variance term is updated or each time the platform is run.
Group orthogonal supersaturated designs are a special case of screening designs. They are appropriate in early stage work when the number of factors to be investigated is larger than the number of feasible runs. A supersaturated design is a design with fewer observations than model parameters. That is, the design cannot estimate all main effects simultaneously. This makes detection of significant effects difficult. A group orthogonal supersaturated design is a special class of two-level supersaturated designs with properties that are desirable for model selection.
Contents

Overview of Group Orthogonal Supersaturated Designs ........................................ 725
Example of Group Orthogonal Supersaturated Designs ........................................ 725
Build a Group Orthogonal Supersaturated Design ........................................... 727
   Specify Factors, Structure, and Make Design .............................................. 727
   Verify Design and Make Table ........................................................................ 728
Group Orthogonal Supersaturated Design Options ........................................... 729
Statistical Details for Group Orthogonal Supersaturated Designs ...................... 730
Overview of Group Orthogonal Supersaturated Designs

Group orthogonal supersaturated designs (GOSSD) are constructed to have a specific structure to facilitate model selection. The design factors are partitioned into groups such that factors within a group are correlated with other factors within the same group yet factors are orthogonal to factors in other groups. One group consists of three or more “fake” factors. These fake factors are not assigned to design factors. They are used only in the analysis of the design. The fake factors provide an unbiased estimate of the variance assuming that second-order and higher-order effects are negligible.

Practical considerations for setting up a GOSSD include:

- More groups are better than fewer groups.
- Factors that are thought to be active should be placed in separate groups.
- Choose the levels of factors so that anticipated coefficients are positive.

Example of Group Orthogonal Supersaturated Designs

In this example, you want to design an experiment to study 12 factors in at most 12 runs. You want a design with at least 16 parameters. One parameter is needed for the intercept and at least three fake factors are desired.

1. Select **DOE > Special Purpose > Group Orthogonal Supersaturated > Group Orthogonal Supersaturated Design**.
2. Select **Number of Runs**.
3. Enter 12 for the **Number of Runs** and click away from the text box.
4. Select the second option in the Structure window with 16 parameters in 4 groups of size 4.
5. Click on the X1 factor name and change the name to *Fake 1*.
6. Repeat for X2 and X3 to name them as *Fake 2* and *Fake 3*, respectively.
7. Click **Make Design**.
The structure of the design is evident in the color map. Factors within a group are correlated. Factors in different groups are not correlated, which indicates that they are orthogonal.
Build a Group Orthogonal Supersaturated Design

Build a Group Orthogonal Supersaturated Design by selecting DOE > Special Purpose > Group Orthogonal Supersaturated > Group Orthogonal Supersaturated Design.

Figure 26.2 Group Orthogonal Supersaturated Design Window

For more information about the options in the Select Columns red triangle menu, see Using JMP.

The GOSSD window updates as you work through the design. The steps to build a GOSSD follow the flow in Figure 26.3

Figure 26.3 Group Orthogonal Supersaturated Design Flow

Specify Factors, Structure, and Make Design

The following options are available in the Design Options outline.

Tip: Provide either the number of runs or the number of factors to define possible design structures.

Number of Runs Defines the number of design runs. The number needs to be a multiple of 2 and preferably a multiple of 4.
Number of Factors  Defines the number of factors. Include a factor for the intercept and three to five fake factors. The number of factors must be a multiple of 8.

Structure  Provides a list of possible structures for your design. The columns in this list are dependent on whether you set the number of runs or the number of factors.

Number of Groups  The number of groups in the design. The minimum is 2.

Group Size  The number of factors in each group.

Number of Runs  (Available if you set the number of factors) The number of runs in the design.

Number of Parameters  (Available if you set the number of runs.) The number of parameters in the design. The parameters include one intercept, your design factors, and the remaining parameters are assigned to fake factors.

Factors

Factor Name  The name for the intercept is fixed. The remaining factors can be renamed.

Role  Enables you to define a factor as continuous or categorical.

Lower  Enables you to set the lower limit of each factor.

Upper  Enables you to set the upper limit of each factor.

Group Structure  Shows factors that appear in each group.

Swap  Enables you to swap factors between groups.

Make Design  Generates the design.

Verify Design and Make Table

Design  Displays the design matrix.

Make Table  Creates the GOSSD data table. The design table includes the following scripts:

Model  (Executes only if the Response column is populated.) Runs the DOE > Special Purpose > Group Orthogonal Supersaturated > Fit Group Orthogonal Supersaturated platform.

Doe Dialog  Re-creates the GOSSD Design window that you used to generate the design table.

GOSSD Structure  Shows the structure of the design (number of runs, number of parameters, number of groups, group size).

Multivariate  Runs the Analyze > Multivariate platform for the design factors.
Model Matrix  Contains the design matrix.

DOE Simulate  (Available when you simulate responses.) Launches the simulate window.

Design Evaluation

Correlation Matrix  Shows the matrix of correlations between effects.

Color Map on Correlations  Shows the absolute correlations between effects on a plot using an intensity scale. Includes a red triangle menu that contains an option to save the correlations to a data table.

Group Orthogonal Supersaturated Design Options

The red triangle menu in the Group Orthogonal Supersaturated Design platform contains the following options:

Simulate Responses  Adds response values and a column containing a simulation formula to the design table. Select this option before you click Make Table.

When you click Make Table, the following occur:

– A set of simulated response values is added to each response column.
– For each response, a new column that contains a simulation model formula is added to the design table. The formula and values are based on the model that is specified in the design window.
– A Model window appears where you can set the values of coefficients for model effects and specify one of three distributions: Normal, Binomial, or Poisson.

Note: Not all distributions are available for all design types.

– A script called DOE Simulate is saved to the design table. This script reopens the Model window, enabling you to re-simulate values or to make changes to the simulated response distribution.

Make selections in the Model window to control the distribution of simulated response values. When you click Apply, a formula for the simulated response values is saved in a new column called <Y> Simulated, where Y is the name of the response. Clicking Apply again updates the formula and values in <Y> Simulated.

For additional details, see “Simulate Responses”.

Note: You can use Simulate Responses to conduct simulation analyses using the JMP Pro Simulate feature. For more information and DOE examples, see the Simulate chapter in Basic Analysis.
Statistical Details for Group Orthogonal Supersaturated Designs

For statistical details of design construction see Jones, et.al. (2019).
Use the Fit Group Orthogonal Supersaturated platform to analyze group orthogonal supersaturated designs. This analysis technique takes advantage of the group orthogonal structure of group orthogonal supersaturated designs.

**Figure 27.1** Fit Group Orthogonal Supersaturated Results
Contents

Overview of the Fit Group Orthogonal Supersaturated Platform .................... 733
Example of Fit Group Orthogonal Supersaturated ............................................. 733
Launch the Fit Group Orthogonal Supersaturated Platform ............................ 736
The Fit Group Orthogonal Supersaturated Report ............................................. 737
Fit Group Orthogonal Supersaturated Platform Options ................................. 738
Overview of the Fit Group Orthogonal Supersaturated Platform

A group orthogonal supersaturated design (GOSSD) is constructed to facilitate the identification of active effects. These designs group factors such that within a group, factors are correlated but between groups, factors are orthogonal. This structure leads to two analysis features:

- Fake, or dummy, factors assigned to the first group are used to estimate variance, assuming that the second- or higher-order effects are negligible.
- Between-group orthogonality enables a two-step model selection procedure.

The Fit Group Orthogonal Supersaturated Platform performs a two-step model selection procedure, enables you to view a regression plot of all factors, and then provides a model for the active effects with the option to examine this model with the Fit Model platform.

Example of Fit Group Orthogonal Supersaturated

In this example, you want to design an experiment to study 12 factors in at most 12 runs. For a GOSSD, you need a design with at least 16 parameters. One parameter is needed for the intercept, at least three parameters are needed for the fake factors, and 12 parameters are needed for the design factors. Use simulated responses to fit a model.

**Tip:** You are not limited to three fake factors. More can be used.

**Generate the Design**

1. Select **DOE > Special Purpose > Group Orthogonal Supersaturated > Group Orthogonal Supersaturated Design**.
2. Select **Number of Runs**.
3. Enter 12 for the **Number of Runs** and click away from the text box.
4. Select the second option in the Structure section with 16 parameters in 4 groups of size 4.
5. Click on the X1 factor name and change the name to Fake 1.
6. Repeat for X2 and X3 to name them as Fake 2 and Fake 3, respectively.
7. Click the Group Orthogonal Supersaturated Design red triangle and select **Simulate Responses**.
8. Click **Make Design**.
9. Click **Make Table**.
The Simulate Responses window shows the settings that were used to generate the design table. Note that the outline box for Group 1 is closed. Group 1 contains the “fake” factors. These are all set to 0 as they are assumed to have no impact on the model. Your values might differ from those shown in Figure 27.2. This simulation has one active effect per group.

Tip: Use the Simulate Responses Window to enter new values for a different simulation.

Analyze the Simulated Response

1. Select **DOE > Special Purpose > Group Orthogonal Supersaturated > Fit Group Orthogonal Supersaturated**.
2. Select Response and click **Y**.
3. Select Fake 1 through X15 and click **X**.
4. Click **OK**.

Tip: The design table generated using the Group Orthogonal Supersaturated platform contains a script called Model. Run this script to run this analysis directly.
Your simulation set $X_7$, $X_{10}$, and $X_{13}$ as factors with effects. The Fit GOSSD procedure identified those three factors as significant. In addition, case $X_{14}$ was also identified. In practice, you would need to determine whether the size and significance of the effect warrants further attention.

**Note:** Your simulation results might differ from those shown in Figure 27.3 due to the generation of random results. You might see an alert that a group has one or more additional effects that might be active. This is a limitation of a supersaturated design; your findings might not be conclusive.

5. Click **Run Model** to run the identified model.
Launch the Fit Group Orthogonal Supersaturated Platform

Launch the Fit Group Orthogonal Supersaturated Design platform by selecting **DOE > Special Purpose > Group Orthogonal Supersaturated > Fit Group Orthogonal Supersaturated**.

**Note:** If you created your design in JMP using the Group Orthogonal Supersaturated platform, the design table contains a script called Model. Run this script to run the analysis directly.

**Figure 27.4 Fit Group Orthogonal Supersaturated Launch Window**

**Y** One or more numeric response variables.

**X** Two-level continuous or categorical factors. Because the platform uses the unique structure of a GOSSD in performing the analysis, these factors must define a GOSSD.

For more information about the options in the Select Columns red triangle menu, see *Using JMP*. 
The Fit Group Orthogonal Supersaturated Report

The Fit Group Orthogonal Supersaturated Report has two sections. The first section reports the estimates of active effects within each group, fitting one group at a time. Only active groups are shown. This is Stage 1 of the analysis. In Stage 2 a combined model is constructed.

Figure 27.5  Stage 1 Findings

<table>
<thead>
<tr>
<th>Term</th>
<th>Main effects that are identified as active.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Estimate</td>
<td>Parameter estimate for a regression fit of Y on the main effect.</td>
</tr>
<tr>
<td>Std Error</td>
<td>The standard error of the estimate, computed using the fake factors in Group 1.</td>
</tr>
<tr>
<td>t Ratio</td>
<td>The Estimate divided by its Std Error.</td>
</tr>
<tr>
<td>Prob&gt;</td>
<td>t</td>
</tr>
</tbody>
</table>

The second section of the report contains the results of Stage 2 of the analysis. Stage 2 constructs the model used to evaluate the design results.

Figure 27.6  Stage 2 Results

<table>
<thead>
<tr>
<th>Term</th>
<th>Main effects that are identified as active.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Estimate</td>
<td>Parameter estimate for a regression fit of Y on the main effect.</td>
</tr>
</tbody>
</table>
**Std Error**  The standard error of the estimates obtained by fitting the specified model and intercept using the full data set.

**t Ratio**  The Estimate divided by its Std Error.

**Prob>|t|**  The $p$-value computed using the t Ratio and the degrees of freedom for error (DF).

**RMSE**  The square root of the mean square error.

**DF**  The degrees of freedom associated with the error estimate used to construct the RMSE.

---

**Fit Group Orthogonal Supersaturated Platform Options**

The red triangle menu in the Fit Group Orthogonal Supersaturated Design platform contains the following options:

See *Using JMP* for more information about the following options:

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

**Statistical Details for the Fit Group Orthogonal Supersaturated Platform**

A two-stage strategy is used to fit group orthogonal supersaturated designs. The first stage identifies which groups contain active effects.

- Obtain an estimate of $\sigma$ from the fake factors and then discard the fake factors from further analyses.
- Test for significance of each group of factors.

The second stage considers significance of individual factors in active groups. This stage uses a guided subsets procedure. See Jones and Nachtsheim (2016). For complete statistical details, see Jones, et al. (2019).
When planning experiments or studies, use the Sample Size Explorers to answer questions like these:

- How many units should I test?
- Will I be able to detect a difference in my treatment means?
- How many samples are needed to construct an interval with a specified width?
- How many units must I test to estimate failure time?

The Sample Size Explorers are a collection of interactive utilities that enable you to adjust study parameters and assumptions to explore different study designs. The tools are grouped by use:

- Power for hypothesis testing.
- Confidence intervals for interval estimation.
- Reliability demonstrations.

Figure 28.1  Sample Size Explorer for One Sample Mean
Contents

Overview of the Sample Size Explorers Platform .................................................. 741
Example of Sample Size Explorers ........................................................................ 741
Launch Sample Size Explorers ................................................................................ 742
Power Explorers for Hypothesis Tests .................................................................... 743
  Power for One Sample Mean .................................................................................. 743
  Power for One Sample Proportion ......................................................................... 746
  Power for One Sample Variance ........................................................................... 748
  Power for One Sample Equivalence ....................................................................... 750
  Power for Two Independent Sample Means .......................................................... 752
  Power for Two Independent Sample Proportions .................................................. 756
  Power for Two Independent Sample Variances ...................................................... 758
  Power for Two Independent Sample Equivalence ................................................ 760
  Power for ANOVA ................................................................................................ 763
Confidence Interval Calculators .............................................................................. 765
  Margin of Error for One Sample Mean ................................................................. 765
  Margin of Error for One Sample Proportion ......................................................... 768
  Margin of Error for One Sample Variance ............................................................ 770
  Margin of Error for Two Independent Sample Means .......................................... 771
  Margin of Error for Two Independent Sample Proportions .................................. 773
  Margin of Error for Two Independent Sample Variances ..................................... 776
Reliability Demonstration Calculators .................................................................... 777
  Parametric Reliability Demonstration .................................................................. 777
  Nonparametric Reliability Demonstration ............................................................. 779
Saved Settings in the Sample Size Explorers .......................................................... 780
Overview of the Sample Size Explorers Platform

The Sample Size Explorers are used for sample size and power calculations. The Sample Size Explorers enable you to evaluate and compare the implications of your study assumptions on the number of observations (runs, experimental units, or samples) needed for your study. There are explorers for hypothesis testing, interval estimation, and reliability demonstrations. For more information about power and sample size, see Barker (2011).

Example of Sample Size Explorers

You can use the Sample Size Explorers to help determine the number of units to test in a study of a new material. Suppose you are interested in demonstrating that the flammability of a new fabric being developed by your company has improved performance over current materials. Previous testing indicates that the standard deviation for time to burn of this fabric is 2 seconds.

Use the Power Explorer for One Sample Mean to calculate the number of fabric samples you need to test. You would like to design an experiment that has 90% power to detect a difference of 1.5 seconds at a significance level of $\alpha = 0.05$.

1. Select **DOE > Sample Size Explorers > Power > Power for One Sample Mean**.
2. Leave **Alpha** set to 0.05.
3. Enter 2 for **Std Dev**.
4. Enter 1.5 for **Difference to detect**.
5. Enter 0.9 for **Power**.
6. Click Save Settings to save these settings.
7. Use the sliders and or text boxes to explore other sample size and power possibilities for your study.
At a significance level of 0.05, 21 fabric samples are needed to have a 90.4% chance of detecting a significant difference of 1.5 seconds in the burn time.

**Launch Sample Size Explorers**

Launch Sample Size Explorers by selecting **DOE > Sample Size Explorers**. There are multiple calculators to select from.

For hypothesis testing, select **DOE > Sample Size Explorers > Power**:  
- “Power for One Sample Mean”  
- “Power for One Sample Proportion”  
- “Power for One Sample Variance”  
- “Power for One Sample Equivalence”  
- “Power for Two Independent Sample Means”  
- “Power for Two Independent Sample Means”  
- “Power for Two Independent Sample Variances”  
- “Power for Two Independent Sample Equivalence”  
- “Power for ANOVA”

For interval estimation, select **DOE > Sample Size Explorers > Confidence Intervals**:  
- “Margin of Error for One Sample Mean”  
- “Margin of Error for One Sample Proportion”  
- “Margin of Error for One Sample Variance”
• “Margin of Error for Two Independent Sample Means”
• “Margin of Error for Two Independent Sample Proportions”
• “Margin of Error for Two Independent Sample Variances”

For reliability demonstrations, select **DOE > Sample Size Explorers > Reliability:**
• “Parametric Reliability Demonstration”
• “Nonparametric Reliability Demonstration”

### Power Explorers for Hypothesis Tests

Use the power explorers to calculate sample size for hypothesis tests. Explore the impact of sample size on the power of a hypothesis test to detect a specified difference where the difference could be from a constant (one-sample case) or between two groups (two-sample case). For the one-sample case, the hypothesis is about the single parameter (mean, proportion, or variance). For the two-sample case, the hypothesis is about comparing two groups. For more than two groups, you can use the Power Explorer for ANOVA, see “Power for ANOVA”.

For hypothesis testing, select **DOE > Sample Size Explorers > Power:**
• “Power for One Sample Mean”
• “Power for One Sample Proportion”
• “Power for One Sample Variance”
• “Power for One Sample Equivalence”
• “Power for Two Independent Sample Means”
• “Power for Two Independent Sample Means”
• “Power for Two Independent Sample Variances”
• “Power for Two Independent Sample Equivalence”
• “Power for ANOVA”

### Power for One Sample Mean

Use the Power Explorer for One Sample Mean to determine a sample size for a hypothesis test about one mean. Select **DOE > Sample Size Explorers > Power > Power for One Sample Mean.** Explore the trade-offs between variability assumptions, sample size, power, significance, and the hypothesized difference to detect. Sample size and power are associated with the following hypothesis test:
versus the two-sided alternative:

\[ H_0: \mu = \mu_0 \]

or versus a one-sided alternative:

\[ H_a: \mu < \mu_0 \quad \text{or} \quad H_a: \mu > \mu_0 \]

where \( \mu \) is the true mean and \( \mu_0 \) is the null mean or reference value. The difference to detect is an amount, \( \Delta \), away from \( \mu_0 \) that one considers important to detect. For the same significance level and power, a larger sample size is needed to detect a small difference than to detect a large difference. It is assumed that the population of interest is normally distributed with mean \( \mu \) and standard deviation \( \sigma \).

**Power Explorer for One Sample Mean Options**

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Test Type**  Specifies a one or two-sided hypothesis test.

**Fixed Parameters**

**Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the *significance level* of the test. The default alpha level is 0.05.

**Std Dev (\( \sigma \))**  Specifies the assumed population standard deviation.

**Tip:** Use a standard deviation of 1 to estimate the sample size needed to detect differences measured in standard deviation units.

**Population standard deviation known**  Specifies use of calculations based on a known, rather than assumed, population standard deviation.

**Test Parameters**  Parameters that are inter-related and update as you make changes.

**Difference to detect (\( \Delta \))**  Specifies smallest difference between the true mean and the hypothesized or reference mean that you want to be able to declare statistically significant.

**Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment.
Power  Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

Save Settings  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

Make Data Collection Table  Creates a new data table that you can use for data collection.

Statistical Details for One Sample Power

The one sample mean calculations are based on the traditional $t$ test when $\sigma$ is unknown. For the case when $\sigma$ is known, the calculations use the $z$ test. For the case when $\sigma$ is unknown, the power is calculated according to the alternative hypothesis.

For a one-sided, higher alternative:

$$\Pr(\mu > \mu_0 \mid \mu = \mu_0 + \delta) = 1 - T\left(t_{1-\alpha, n-1}; \frac{\delta}{\sigma / \sqrt{n}}\right)$$

For a one-sided, lower alternative:

$$\Pr(\mu < \mu_0 \mid \mu = \mu_0 - \delta) = \left(1 - t_{1-\alpha, n-1}; \frac{\delta}{\sigma / \sqrt{n}}\right)$$

For a two-sided alternative:

$$\Pr(\mu \neq \mu_0 \mid \mu = \mu_0  \pm \delta) = 1 - T\left(t_{1-\alpha/2, n-1}; \frac{\delta}{\sigma / \sqrt{n}}\right) + \left(1 - t_{1-\alpha/2, n-1}; \frac{\delta}{\sigma / \sqrt{n}}\right)$$

where:

- $\alpha$ is the significance level
- $n$ is the sample size
- $\sigma$ is the assumed population standard deviation
- $\delta$ is the difference to detect
- $t_{1-\alpha, n}$ is the $(1 - \alpha)^{th}$ quantile of the central $t$-distribution with $\nu$ degrees of freedom
- $T(t; \nu, \lambda)$ is the cumulative distribution function of the non-central $t$ distribution with $\nu$ degrees of freedom and non-centrality parameter $\lambda$.

When $\sigma$ is known the $z$ distribution is used in the above equations for the power calculations. Because closed-form solutions for $\delta$ and $n$ do not exist, numerical routines are used to solve for them.
Power for One Sample Proportion

Use the Power Explorer for One Sample Proportion to determine a sample size for a hypothesis test about one proportion. Select **DOE > Sample Size Explorers > Power > Power for One Sample Proportion**. Explore the trade offs between sample size, power, significance, and the hypothesized difference to detect. Sample size and power are associated with the following hypothesis test:

\[ H_0: p = p_0 \]

versus the two-sided alternative:

\[ H_a: p \neq p_0 \]

or versus a one-sided alternative:

\[ H_a: p < p_0 \quad \text{or} \quad H_a: p > p_0 \]

where \( p \) is the population proportion and \( p_0 \) is the null proportion.

**Power Explorer for One Sample Proportion Options**

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Test Type**  Specifies a one or two-sided hypothesis test.

**Model Type**

- **Exact Test**  Specifies calculations based on the Clopper-Pearson methodology.
- **Normal Approximation**  Specifies calculations based on the normal approximation methodology.

**Tip:** Since the binomial distribution is discrete, the actual test size can differ significantly from the stated Alpha level for small samples or proportions near 0 or 1. To guarantee an alpha level equal to or greater than your stated level, use the Exact test.

**Fixed Parameters**

- **Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Test Parameters**  Parameters that are inter-related and update as you make changes.
Assumed proportion (p0)  Specifies the proportion that you anticipate or assume for your study, the null hypothesis value.

Alternative proportion (pA)  Specifies the proportion that you test against, the alternative hypothesis value.

Sample Size  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment.

Power  Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

Save Settings  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

Make Data Collection Table  Creates a new data table that you can use for data collection.

Statistical Details for the One Sample Proportion Explorer

For the exact test, the power is computed based on the form of the alternative hypothesis.

For one-sided, higher alternative:

$$\Pr(p > p_0 | p = p_a) = \sum_{x = x_1 - a, n, p_0}^{n} \binom{n}{x} p_a^x (1 - p_a)^{n-x}$$

for a one-sided, lower alternative:

$$\Pr(p < p_0 | p = p_a) = \sum_{x = x_0}^{x = x_1 - a, n, p_0 - 1} \binom{n}{x} p_a^x (1 - p_a)^{n-x}$$

for a two-sided alternative:

$$\Pr(p \neq p_0 | p = p_a) = \sum_{x = x_1 - a/2, n, p_0}^{n} \binom{n}{x} p_a^x (1 - p_a)^{n-x} + \sum_{x = x_0}^{x = x_1 - a/2, n, p_0 - 1} \binom{n}{x} p_a^x (1 - p_a)^{n-x}$$

where $x_{q,n,p}$ is the $q^{th}$ quantile of a binomial distribution with $n$ trials and probability $p$.

For the normal approximation, the power is computed based on the form of the alternative hypothesis.

For a one-sided, higher alternative:
Pr(\(p > p_0 \mid p = p_a\)) = 1 - \Phi\left(z_{1 - \alpha} \sqrt{\frac{p_0(1 - p_0)}{p_a(1 - p_a)}} - \frac{(p_a - p_0)}{p_a(1 - p_a)} \right)

For a one-sided, lower alternative:

\[
Pr(p < p_0 \mid p = p_a) = \Phi\left(-z_{1 - \alpha} \sqrt{\frac{p_0(1 - p_0)}{p_a(1 - p_a)}} - \frac{(p_a - p_0)}{p_a(1 - p_a)} \right)
\]

For a two-sided alternative:

\[
Pr(p \neq p_0 \mid p = p_a) = 1 - \Phi\left(z_{1 - \alpha/2} \sqrt{\frac{p_0(1 - p_0)}{p_a(1 - p_a)}} - \frac{(p_a - p_0)}{p_a(1 - p_a)} \right) + \Phi\left(-z_{1 - \alpha/2} \sqrt{\frac{p_0(1 - p_0)}{p_a(1 - p_a)}} - \frac{(p_a - p_0)}{p_a(1 - p_a)} \right)
\]

**Power for One Sample Variance**

Use the Power Explorer for One Sample Variance to determine a sample size for a hypothesis test about one variance. Select **DOE > Sample Size Explorers > Power > Power for One Sample Variance**. Explore the tradeoffs between sample size, power, significance, and the hypothesized difference to detect (defined as a ratio between the null and alternative hypothesis values). Sample size and power are associated with the following hypothesis test:

\(H_0: \sigma = \sigma_0\)

versus the two-sided alternative:

\(H_a: \sigma \neq \sigma_0\)

or versus a one-sided alternative:

\(H_a: \sigma < \sigma_0\) or \(H_a: \sigma > \sigma_0\)
where $\sigma$ is the true variance and $\sigma_0$ is the null variance or reference value. The difference to detect is an amount away from $\sigma_0$ that one considers as important to detect based on a set of samples. This difference is expressed as the ratio of $\sigma_0/\sigma_\alpha$ or the ratio of your null variance and your assumed variance under the alternative hypothesis. For the same significance level and power, a larger sample size is needed to detect a small difference in variances than to detect a large difference. It is assumed that the population of interest is normally distributed with mean $\mu$ and standard deviation $\sigma$.

### Power Explorer for One Sample Variance Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Test Type**  Specifies a one or two-sided hypothesis test.

**Fixed Parameters**

- **Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Test Parameters**  Parameters that are inter-related and update as you make changes.

- **Ratio of variances (Null/Alternative)**  Specifies the ratio of the variance under the null hypothesis (reference variance) to the variance under the alternative hypothesis (expected variance).

- **Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment.

- **Power**  Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

- **Save Settings**  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

- **Make Data Collection Table**  Creates a new data table that you can use for data collection.

### Statistical Details for the One Sample Variance Explorer

The power calculations for testing the variance of one sample group is based on the $\chi^2$ test. Calculations are based on the form of the alternative hypothesis.

For a one-sided, higher alternative:
Pr(σ > σ₀ | σ = σ₀/ρ) = 1 − χ²(ρx₁−α, n−1; n−1)
for a one-sided, lower alternative:
Pr(σ < σ₀ | σ = σ₀/ρ) = χ²(ρx, n−1; n−1)
for a two-sided alternative:
Pr(σ ≠ σ₀ | σ = σ₀/ρ) = 1 − χ²(ρx₁−α/n, n−1; n−1) + χ²(ρx/2, n−1; n−1)
where:
α is the significance level
n is the sample size
ρ=σ₀/σ₀
x₁−α,n is the (1 - α)th quantile of a central χ² distribution with ν degrees of freedom
χ²(x, ν) is the cumulative distribution function of a central χ² distribution with ν degrees of freedom.

Power for One Sample Equivalence

Use the Power Explorer for One Sample Equivalence to determine a sample size for an equivalence test about one mean. Select DOE > Sample Size Explorers > Power > Power for One Sample Equivalence. Explore the trade offs between variability assumptions, sample size, power, significance, and the equivalence range. Sample size and power are associated with the following hypothesis test:

H₀: μ − μ₀ ≥ δₘ or H₀: μ − μ₀ ≤ δₘ

versus the alternative:

Hₐ: δₘ < μ − μ₀ < δₘ

where μ is the true mean, μ₀ is the reference value, and (δₘ, δₘ) is the equivalence range. For the same significance level and power, a larger sample size is needed to detect a small difference than to detect a large difference. It is assumed that the population of interest is normally distributed with mean μ and standard deviation σ.
Power Explorer for One Sample Equivalence Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

Equivalence Range

- **Maximum difference**: Specifies the maximum value, above which the mean is considered different from the reference mean.
- **Minimum difference**: Specifies the minimum value, below which the mean is considered different from the reference mean.

*Note*: Typically, the equivalence range is symmetric.

Fixed Parameters

- **Alpha**: The probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.
- **Std Dev (σ)**: The assumed population standard deviation.
- **Population standard deviation known**: Specifies calculations based on a known, rather than assumed, population standard deviation.

Test Parameters: Parameters that are inter-related and update as you make changes.

- **Difference in Means**: Specifies the difference between the true mean and the hypothesized or reference mean such that the two means are considered equivalent.
- **Sample Size**: Specifies the total number of observations (runs, experimental units, or samples) needed your experiment.
- **Power**: Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.
- **Save Settings**: Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.
- **Make Data Collection Table**: Creates a new data table that you can use for data collection.

Statistical Details for the One Sample Equivalence Explorer

The power calculations for testing equivalence in one sample group is based on methods described in Chow et al. (2008).

If σ is unknown, the power (1-β) is computed as follows:
where:

- \( \alpha \) is the significance level
- \( n \) is the sample size
- \( \sigma \) is the assumed standard deviation
- \( \delta \) is the difference to detect
- \( (\delta_m, \delta_M) \) is the equivalence range
- \( t_{1-\alpha, n} \) is the \( (1 - \alpha) \)th quantile of the central \( t \)-distribution with \( v \) degrees of freedom
- \( T(t; v, \lambda) \) is the cumulative distribution function of the non-central \( t \) distribution with \( v \) degrees of freedom and non-centrality parameter \( \lambda \).

If \( \sigma \) is known, then power \( (1-\beta) \) is computed as follows:

\[
1 - \beta = \Phi\left(\frac{\delta - \delta_M}{\sigma/\sqrt{n}} - z_{1-\alpha}\right) + \Phi\left(\frac{\delta - \delta_m}{\sigma/\sqrt{n}} - z_{1-\alpha}\right) - 1
\]

### Power for Two Independent Sample Means

Use the Power Explorer for Two Independent Sample Means to determine a sample size for a hypothesis test about the means from two groups. Select **DOE > Sample Size Explorers > Power > Power for Two Independent Sample Means**. Explore the trade-offs between sample size, power, significance, and the hypothesized difference to detect. Sample size and power are associated with the following hypothesis test:

\[
H_0: \mu_1 - \mu_2 = 0
\]

versus the two-sided alternative:

\[
H_a: \mu_1 - \mu_2 \neq 0
\]

or versus a one-sided alternative:

\[
H_a: \mu_1 - \mu_2 < 0 \quad \text{or} \quad H_a: \mu_1 - \mu_2 > 0
\]

where \( \mu_1 \) and \( \mu_2 \) are the true means of the two populations. It is assumed that the populations of interest are normally distributed and that you want to detect a difference of \( \delta \) between the means.
Power Explorer for Two Independent Sample Means Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Test Type**  Specifies a one or two-sided hypothesis test.

**Fixed Parameters**

**Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Group 1 StdDev (σ₁)**  Specifies the assumed standard deviation for one of your groups, Group 1. An estimate of the error standard deviation could be the root mean square error (RMSE) from a previous model fit.

**Group 2 StdDev (σ₂)**  Specifies the assumed standard deviation for the second group, Group 2. An estimate of the error standard deviation could be the root mean square error (RMSE) from a previous model fit.

**Population standard deviations known**  Specifies calculations based on a known, rather than assumed, population standard deviations.

**Test Parameters**

**Difference to detect (Δ)**  Specifies the smallest difference between the group means that you want to be able to declare statistically significant.

**Group 1 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 1 in your experiment. Select Lock to lock the Group 1 sample size.

**Group 2 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 2 in your experiment. Select Lock to lock the Group 2 sample size.

**Total Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment. The power curve is based on total sample size. Set Lock to lock the total sample size.

**Note:** Adjusting the sample size for one group adjusts the total sample size unless the total sample size is locked. In that case, adjusting the sample size for one group adjust the sample size for the second group. Adjusting the total sample size adjusts the two groups proportionally, unless one group is locked. Use only one lock at a time.

**Power**  Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.
Save Settings  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

Make Data Collection Table  Creates a new data table that you can use for data collection.

Statistical Details for Two Independent Means

The power calculations for testing the difference in means of two sample groups are based on the traditional $t$ test, or if $\sigma_1$ and $\sigma_2$ are known, the $z$ test.

For the case when $\sigma$ is unknown and it is assumed that $\sigma_1=\sigma_2=\sigma$, the power is calculated based on the form of the alternative hypothesis. For a one-sided, higher alternative:

$$Pr(\mu_1 > \mu_2 \mid \mu_1 = \mu_2 + \delta) = 1 - T\left(t_{1-\alpha, n_1+n_2-2; n_1+n_2-2, \frac{\delta}{\sigma \sqrt{n_1+n_2}}}\right)$$

For a one-sided, lower alternative:

$$Pr(\mu_1 < \mu_2 \mid \mu_1 = \mu_2 - \delta) = T\left(-t_{1-\alpha, n_1+n_2-2; n_1+n_2-2, \frac{\delta}{\sigma \sqrt{n_1+n_2}}}\right)$$

For a two-sided alternative:

$$Pr(\mu_1 \neq \mu_2 \mid \mu_1 = \mu_2 \pm \delta) =$$

$$1 - T\left(t_{1-\frac{\alpha}{2}, n_1+n_2-2; n_1+n_2-2, \frac{\delta}{\sigma \sqrt{n_1+n_2}}}\right) + T\left(-t_{1-\frac{\alpha}{2}, n_1+n_2-2; n_1+n_2-2, \frac{\delta}{\sigma \sqrt{n_1+n_2}}}\right)$$

where:

$\alpha$ is the significance level

$n_1$ and $n_2$ are the group sample sizes

$\sigma$ is the pooled standard deviation

$\delta$ is the difference to detect

$t_{1-\alpha,n_i}$ is the $(1 - \alpha)^{th}$ quantile of the central $t$-distribution with $\nu$ degrees of freedom
$T(t; \nu, \lambda)$ is the cumulative distribution function of the non-central $t$ distribution with $\nu$ degrees of freedom and non-centrality parameter $\lambda$.

When $\sigma_1$ and $\sigma_2$ are not assumed to be equal then the degrees of freedom, $n_1 + n_2 - 2$ in the above equations, is computed as follows:

$$df = \frac{\left(\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}\right)^2}{\frac{1}{n_1-1}\left(\frac{\sigma_1^2}{n_1}\right) + \frac{1}{n_2-1}\left(\frac{\sigma_2^2}{n_2}\right)}$$

When $\sigma_1$ and $\sigma_2$ are known the $z$ distribution is used for the power calculation. The power is calculated based on the form of the alternative hypothesis. For a one-sided, higher alternative:

$$Pr(\mu_1 > \mu_2 \mid \mu_1 = \mu_2 + \delta) = 1 - \Phi\left(z_1 - \alpha - \frac{\delta}{\sqrt{\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}}}\right)$$

For a one-sided, lower alternative:

$$Pr(\mu_1 < \mu_2 \mid \mu_1 = \mu_2 - \delta) = \Phi\left(-z_1 - \alpha - \frac{\delta}{\sqrt{\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}}}\right)$$

For a two-sided alternative:

$$Pr(\mu_1 \neq \mu_2 \mid \mu_1 = \mu_2 \pm \delta) = 1 - \Phi\left(z - \frac{\alpha}{2} - \frac{\delta}{\sqrt{\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}}}\right) + \Phi\left(-z - \frac{\alpha}{2} - \frac{\delta}{\sqrt{\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}}}\right)$$

where:

$\alpha$ is the significance level

$n_1$ and $n_2$ are the group sample sizes

$\sigma_1$ and $\sigma_2$ are known group standard deviations

$\delta$ is the difference to detect
$z_{1-\alpha}$ is the $(1 - \alpha)^{th}$ quantile of the $z$-distribution

$\Phi(x)$ is the cumulative distribution function of the normal distribution.

### Power for Two Independent Sample Proportions

Use the Power Explorer for Two Independent Sample Proportions to determine a sample size for a hypothesis test for proportions from two groups. Select **DOE > Sample Size Explorers > Power > Power for Two Independent Sample Proportions**. Explore the trade offs between sample size, power, significance, and the hypothesized difference to detect. Sample size and power are associated with the following hypothesis test:

$$H_0: p_1 - p_2 = D_0$$

versus the two-sided alternative:

$$H_a: p_1 - p_2 \neq D_0$$

or versus either of the following one-sided alternatives:

$$H_a: (p_1 - p_2) < D_0 \quad \text{or} \quad H_a: (p_1 - p_2) > D_0$$

where $p_1$ and $p_2$ are the population proportions from two populations, and $D_0$ is the hypothesized difference in proportions.

### Power Explorer for Two Independent Sample Proportions Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Test Type**  Specifies a one or two-sided hypothesis test.

**Fixed Parameters**

**Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Test Parameters**  Parameters that are inter-related and update as you make changes.

**Group 1 proportion (p1)**  Specifies the proportion that you anticipate or assume for Group 1.

**Group 2 proportion (p2)**  Specifies the proportion that you anticipate or assume for Group 2.
**Group 1 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 1 in your experiment. Select Lock to lock the Group 1 sample size.

**Group 2 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 2 in your experiment. Select Lock to lock the Group 2 sample size.

**Total Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment. The power curve is based on total sample size. Select Lock to lock the total sample size.

**Note:** Adjusting the sample size for one group adjusts the total sample size unless the total sample size is locked. In that case, adjusting the sample size for one group adjust the sample size for the second group. Adjusting the total sample size adjusts the two groups proportionally, unless one group is locked. Use only one lock at a time.

**Power**  Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

**Save Settings**  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

**Make Data Collection Table**  Creates a new data table that you can use for data collection.

### Statistical Details for Two Independent Sample Proportions

The power calculations for testing the difference in proportions from two sample groups are based on the normal approximation. The calculations depend on the form of the alternative hypothesis. For a one-sided, higher alternative:

\[
Pr(p_1 > p_2 \mid p_1 = p_2 + \delta) = 1 - \Phi \left( z_1 - \alpha - \frac{\delta}{\sqrt{\frac{p_1(1-p_1)}{n_1} + \frac{p_2(1-p_2)}{n_2}}} \right)
\]

For a one-sided, lower alternative:

\[
Pr(p_1 > p_2 \mid p_1 = p_2 - \delta) = \Phi \left( -z_1 - \alpha - \frac{\delta}{\sqrt{\frac{p_1(1-p_1)}{n_1} + \frac{p_2(1-p_2)}{n_2}}} \right)
\]

For a two-sided alternative:
Pr(p_1 \neq p_2 \mid p_1 = p_2 \pm \delta) =

1 - \Phi \left( z_{1-\alpha} - \frac{\delta}{\sqrt{\frac{n_1(1-p_1)}{n_1} + \frac{n_2(1-p_2)}{n_2}}} \right) + \Phi \left( -z_{1-\alpha} - \frac{\delta}{\sqrt{\frac{n_1(1-p_1)}{n_1} + \frac{n_2(1-p_2)}{n_2}}} \right)

where:

- $\alpha$ is the significance level
- $n_1$ and $n_2$ are the group sample sizes
- $p_1$ and $p_2$ are the group proportions
- $\delta$ is the difference to detect
- $z_{1-\alpha}$ is the $(1-\alpha)^{th}$ quantile of the z-distribution
- $\Phi(x)$ is the cumulative distribution function of the normal distribution.

**Power for Two Independent Sample Variances**

Use the Power Explorer for Two Independent Sample Variances to determine a sample size for a hypothesis test for variances from two groups. Select **DOE > Sample Size Explorers > Power > Power for Two Independent Sample Variances**. Explore the trade offs between sample size, power, significance, and the hypothesized difference to detect. Sample size and power are associated with the following hypothesis test:

$H_0: \sigma_1 = \sigma_2$

versus the two-sided alternative:

$H_a: \sigma_1 \neq \sigma_2$

or versus a one-sided alternative:

$H_a: \sigma_1 < \sigma_2$ or $H_a: \sigma_1 > \sigma_2$

where $\sigma_1$ is the variance for Group 1 and $\sigma_2$ is the variance for Group 2. The difference to detect is an amount away from $\sigma_2$ that one considers as important to detect based on a set of samples. This difference is expressed as the ratio of $\sigma_2/\sigma_1$, or the ratio of your variances. For the same significance level and power, a larger sample size is needed to detect a small difference in variances than to detect a large difference. It is assumed that the populations of interest are normally distributed.
Power Explorer for Two Independent Sample Variances Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Test Type**  Specifies a one or two-sided hypothesis test.

**Fixed Parameters**

- **Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Test Parameters**  Parameters that are inter-related and update as you make changes.

- **Ratio of variances (Group 2/Group 1)**  Specifies the ratio of the variances.

- **Group 1 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 1 in your experiment. Select Lock to lock the Group 1 sample size.

- **Group 2 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 2 in your experiment. Select Lock to lock the Group 2 sample size.

- **Total Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment. The power curve is based on total sample size. Select Lock to lock the total sample size.

**Note:** Adjusting the sample size for one group adjusts the total sample size unless the total sample size is locked. In that case, adjusting the sample size for one group adjust the sample size for the second group. Adjusting the total sample size adjusts the two groups proportionally, unless one group is locked. Use only one lock at a time.

- **Power**  Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

**Statistical Details for the Two Independent Sample Variances Explorer**

The power calculations for testing the ratio of variances from two sample groups is based on the standard F test. The calculations depend on the form of the alternative hypothesis. For a one-sided, higher alternative:

\[
Pr(\sigma_1 > \sigma_2 | \sigma_1 = \sigma_2 \rho) = 1 - F(\rho f_1 - \alpha, n_1 - 1, n_2 - 1; n_1 - 1, n_2 - 1)
\]
For a one-sided, lower alternative:

\[
\Pr(\sigma_1 < \sigma_2 | \sigma_1 = \sigma_2 \rho) = F(\rho f_{\alpha, n_1 - 1, n_2 - 1}; n_1 - 1, n_2 - 1)
\]

For a two-sided alternative:

\[
\Pr(\sigma_1 \neq \sigma_2 | \sigma_1 = \sigma_2 \rho) = \\
1 - F\left(\rho f_{\alpha/2, n_1 - 1, n_2 - 1}; n_1 - 1, n_2 - 1\right) + F\left(\rho f_{\alpha/2, n_1 - 1, n_2 - 1}; n_1 - 1, n_2 - 1\right)
\]

where:
- \(\alpha\) is the significance level
- \(n_1\) and \(n_2\) are the group sample sizes
- \(\rho = \sigma_2 / \sigma_1\)
- \(f_{1-\alpha, v_1,v_2}\) is the \((1 - \alpha)\)th quantile of an \(F\) distribution with \(v_1\) and \(v_2\) degrees of freedom
- \(F(x, v)\) is the cumulative distribution function of an \(F\) distribution with \(v\) degrees of freedom.

**Power for Two Independent Sample Equivalence**

Use the Power Explorer for Two Sample Equivalence to determine a sample size for an equivalence test of two groups. Select **DOE > Sample Size Explorers > Power > Power for Two independent Sample Equivalence**. Explore the trade-offs between variability assumptions, sample size, power, significance, and the equivalence range. Sample size and power are associated with the following hypothesis test:

\[
H_0: \mu_1 - \mu_2 \geq \delta_M \quad \text{or} \quad H_0: \mu_1 - \mu_2 \leq \delta_m
\]

versus the alternative:

\[
H_a: \delta_m < \mu_1 - \mu_2 < \delta_M
\]

where \(\mu_1\) and \(\mu_2\) the true group means and \((\delta_m, \delta_M)\) is the equivalence range. For the same significance level and power, a larger sample size is needed to detect a small difference than to detect a large difference. It is assumed that the populations of interest are normally distributed.
**Power Explorer for Two Independent Sample Equivalence Options**

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Equivalence Range**

- **Maximum difference**  Specifies the margin above which the mean is considered different from the reference mean.
- **Minimum difference**  Specifies the margin below which the mean is considered different from the reference mean.

**Note:** Typically, the equivalence margin is symmetric. However, it does not have to be symmetric.

**Fixed Parameters**

- **Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.
- **Group 1 StdDev (σ₁)**  Specifies the assumed population standard deviation for one of your groups, Group 1.
- **Group 2 StdDev (σ₂)**  Specifies the assumed population standard deviation for the second group, Group 2.
- **Population standard deviations known**  Specifies calculations based on a known, rather than assumed, population standard deviations.

**Test Parameters**  Parameters that are inter-related and update as you make changes.

- **Difference in Means**  Specifies the difference between group means that defines the equivalence range.
- **Group 1 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 1 in your experiment. Select Lock to lock the Group 1 sample size.
- **Group 2 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 2 in your experiment. Select Lock to lock the Group 2 sample size.
- **Total Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment. The power curve is based on total sample size. Select Lock to lock the total sample size.
Note: Adjusting the sample size for one group adjusts the total sample size unless the total sample size is locked. In that case, adjusting the sample size for one group adjusts the sample size for the second group. Adjusting the total sample size adjusts the two groups proportionally, unless one group is locked. Use only one lock at a time.

**Power** Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

**Save Settings** Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

**Make Data Collection Table** Creates a new data table that you can use for data collection.

### Statistical Details for the Two Independent Sample Equivalence Explorer

The power calculations for testing equivalence of two group means is based on methods described in Chow et al. (2008).

If \( \sigma_1 \) and \( \sigma_2 \) are unknown, the power \((1-\beta)\) is computed as follows:

\[
1 - \beta = T\left(-t_{1-\alpha, df}, \frac{\delta - \delta_M}{\sigma_1^2 / n_1 + \sigma_2^2 / n_2}\right) - T\left(t_{1-\alpha, df}, \frac{\delta - \delta_M}{\sigma_1^2 / n_1 + \sigma_2^2 / n_2}\right)
\]

where:

\[
df = \begin{cases} 
  n_1 + n_2 - 2 & \text{if } \sigma_1 = \sigma_2 \\
  \frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2} & \text{if } \sigma_1 \neq \sigma_2 \\
  \frac{1}{n_1 - 1} \left(\frac{\sigma_1^2}{n_1}\right) + \frac{1}{n_2 - 1} \left(\frac{\sigma_2^2}{n_2}\right) 
\end{cases}
\]

\(\alpha\) is the significance level
\(n_1\) and \(n_2\) are the group sample sizes
\(\sigma_1\) and \(\sigma_2\) are the assumed group standard deviations
\(\delta\) is the difference to detect
(δ_m, δ_M) is the equivalence range

\[ t_{1-\alpha, \nu} \] is the \((1 - \alpha)\)th quantile of the central \(t\)-distribution with \(\nu\) degrees of freedom

\( T(t; \nu, \lambda) \) is the cumulative distribution function of the non-central \(t\) distribution with \(\nu\) degrees of freedom and non-centrality parameter \(\lambda\).

If \(\sigma\) is known, then power \((1-\beta)\) is computed as follows:

\[
1 - \beta = \Phi \left( \frac{\delta - \delta_M}{\sqrt{\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}}} - z_{1-\alpha} \right) + \Phi \left( \frac{\delta - \delta_m}{\sqrt{\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}}} - z_{1-\alpha} \right) - 1
\]

**Power for ANOVA**

Use the Power Explorer for ANOVA to determine a sample size for a study of \(k\) groups or treatments to be analyzed using ANOVA. Select **DOE > Sample Size Explorers > Power > Power for ANOVA**. Explore the trade offs between variability assumptions, sample size, power and significance. Sample size and power are associated with the following hypothesis test:

\[
H_0: \mu_1 = \mu_2 = \ldots = \mu_k
\]

versus the two-sided alternative:

\[
H_a: \text{not all means equal}
\]

where:

\[
X_{ij} \sim N(\mu_j, \sigma^2) \text{ for } i = 1, \ldots, n, \; j = 1, \ldots, k
\]

**Power Explorer for ANOVA Options**

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Fixed Parameters**

- **Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

- **Number of groups**  Specifies the number of groups or treatments in your experiment.
**Within-group variance** ($\sigma^2$)  Specifies the assumed population variance for each group where the standard deviation is assumed to be equal across groups.

**Test Parameters**  Parameters that are inter-related and update as you make changes.

**Between-group variance**  Specifies the variance of the individual group means around the grand mean.

**Sample size (per group)**  Specifies the number of observations (runs, experimental units, or treatments) needed for each group in your experiment.

**Power**  Specifies the probability of rejecting the null hypothesis when it is false. With all other parameters fixed, power increases as sample size increases.

**Save Settings**  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

**Make Data Collection Table**  Creates a new data table that you can use for data collection.

**Statistical Details for the ANOVA Explorer**

The power calculations for testing differences among means from multiple groups assuming equal standard deviations for each group is based on the standard F test. The power (1-$\beta$) is computed as follows:

$$1 - \beta = F\left( f_q, K - 1, N - K, \frac{\sigma^2_{BG}}{\sigma^2} \right)$$

where

- $F(q, df_1, df_2, \lambda)$ is a non-central F-distribution with noncentrality parameter $\lambda$.
- $K$ is the number of groups
- $n$ is the number of samples within each group (assumed equal for all groups)
- $N = nK$
- $\sigma^2_{BG}$ is the variation of the group means around the grand mean
- $\sigma^2$ is the within group variance (assumed equal for all groups)
Confidence Interval Calculators

Use the confidence interval calculators to select a study sample size to obtain an interval estimate with pre-specified characteristics. Explore the impact of sample size on the margin of error of an interval estimate. Explore sample size for a confidence, prediction, or tolerance interval for one mean. Explore sample size for a confidence interval for two means, or one or two proportions or variances.

For interval estimation, select DOE > Sample Size Explorers > Confidence Intervals:

- “Margin of Error for One Sample Mean”
- “Margin of Error for One Sample Proportion”
- “Margin of Error for One Sample Variance”
- “Margin of Error for Two Independent Sample Means”
- “Margin of Error for Two Independent Sample Proportions”
- “Margin of Error for Two Independent Sample Variances”

Margin of Error for One Sample Mean

Use the Interval Explorer for one sample mean to determine a sample size for a confidence, prediction, or tolerance interval. Select DOE > Sample Size Explorers > Confidence Intervals > Margin of Error for One Sample Mean. Explore the trade offs between variability assumptions, sample size, significance, and the margin of error.

Interval Explorer for One Sample Mean Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

Interval Purpose

- **Confidence** Specifies a confidence interval for a mean.
- **Prediction** Specifies a prediction interval for one future observation.
- **Tolerance** Specifies a tolerance interval to cover a proportion of the population.

Interval Type

- **Bound** Specifies a one-sided interval (upper or lower bound)
- **Interval** Specifies a two-sided interval.
Fixed Parameters

**Alpha**  Specifies the confidence level is 1 - alpha. The default alpha level is 0.05 for a 95% confidence interval.

**Std Dev (σ)**  Specifies the assumed population standard deviation.

**Proportion**  (Available only when Tolerance is selected for Interval Purpose.) Specifies the proportion of the population for the tolerance interval to cover.

**Population standard deviation known**  Specifies calculations based on a known, rather than assumed, population standard deviation.

Interval Parameters  Parameters that are inter-related and update as you make changes.

**Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed to construct your interval.

**Margin of Error**  (Available only when Interval is selected for Interval Type.) Specifies the half-width of the interval. With all other parameters fixed, margin of error decreases as sample size increases.

**Bound Size**  (Available only when Bound is selected for Interval Type.) Specifies the distance from the bound to the estimate. With all other parameters fixed, the bound decreases as sample size increases.

**Save Settings**  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

**Make Data Collection Table**  Creates a new data table that you can use for data collection.

Statistical Details for the One Sample Interval Explorer

The calculation for each interval type uses the standard normal-based procedures if σ is known and t distribution procedures or approximations otherwise.

**Confidence Intervals**

The margin of error (MOE) for confidence intervals is calculated as follows:

\[
MOE = \begin{cases} 
  z_{1 - \alpha/2} \frac{\sigma}{\sqrt{n}} & \text{if } \sigma \text{ known} \\
  t_{1 - \alpha/2, n - 1} \frac{\sigma}{\sqrt{n}} & \text{if } \sigma \text{ unknown}
\end{cases}
\]

The bound is calculated as follows:
Design of Experiments Guide

Confidence Interval Calculators

Prediction Intervals

The margin of error (MOE) for prediction intervals is calculated as follows:

\[
\text{MOE} = \begin{cases} 
  z_{1 - \alpha/2} \sigma \sqrt{\frac{1 + \frac{1}{n}}{n}}, & \text{if } \sigma \text{ known} \\
  t_{1 - \alpha/2, n-1} \sigma \sqrt{\frac{1 + \frac{1}{n}}{n}}, & \text{if } \sigma \text{ unknown}
\end{cases}
\]

The bound is calculated as follows:

\[
\text{bound} = \begin{cases} 
  \pm z_{1 - \alpha} \frac{\sigma}{\sqrt{n}} & \text{if } \sigma \text{ known} \\
  \pm t_{1 - \alpha, n-1} \frac{\sigma}{\sqrt{n}} & \text{if } \sigma \text{ unknown}
\end{cases}
\]

Tolerance Intervals

For the tolerance interval on a proportion \( q \) of the population, the margin of error or bound is computed based on approximate procedures described in Krishnamoorthy and Mathew (2009).

The margin of error (MOE) for tolerance intervals is calculated as follows:
Sample Size Explorers
Confidence Interval Calculators
Design of Experiments Guide

The bound is calculated as follows:

\[
MOE = \begin{cases}
  \frac{\sqrt{N \chi^2_{q, 1, \frac{1}{n}}} \sigma}{\chi_{\alpha, N}} & \text{if } \sigma \text{ known} \\
  \frac{(n-1) \chi^2_{q, 1, \frac{1}{n}}} {\chi_{\alpha, n-1} \sigma} & \text{if } \sigma \text{ unknown}
\end{cases}
\]

The bound is calculated as follows:

\[
bound = \begin{cases}
  \pm \frac{t_{1-\alpha, N, z_q \sqrt{n}}}{\sqrt{n}} & \text{if } \sigma \text{ known} \\
  \pm \frac{t_{1-\alpha, n-1, z_q \sqrt{n}}}{\sqrt{n}} & \text{if } \sigma \text{ unknown}
\end{cases}
\]

where \( N \) is a suitably large integer value to represent asymptotic behavior. JMP sets the value of \( N \) to 2000.

Margin of Error for One Sample Proportion

Use the Interval Explorer for One Sample Proportion to determine a sample size for a confidence interval. Select DOE > Sample Size Explorers > Confidence Intervals > Margin of Error for One Sample Proportion. Explore the trade offs between the assumed proportion, sample size, significance, and the margin of error for your interval. Calculations use the Normal approximation.

Interval Explorer for One Sample Proportion Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

Interval Type

**Bound** Specifies a one-side of the interval (upper or lower bound)
**Interval**  Specifies a two-sided interval.

**Fixed Parameters**

**Alpha**  Specifies the confidence level, 1 - Alpha. The default alpha level is 0.05 for a 95% confidence interval.

**Interval Parameters**  Parameters that are inter-related and update as you make changes.

**Proportion**  Specifies the assumed proportion for the interval.

**Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed to construct your interval.

**Margin of Error**  Specifies the half-width of the interval. With all other parameters fixed, margin of error decreases as sample size increases.

**Save Settings**  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

**Make Data Collection Table**  Creates a new data table that you can use for data collection.

### Statistical Details for the One Sample Proportion Interval Explorer

The interval calculations for capturing a population proportion is based on the Agresti-Coull method, see Agresti and Coull(1998).

The margin of error (MOE) for confidence intervals is calculated as follows:

$$ MOE = z_{1 - \alpha/2} \sqrt{\frac{p(1-p)}{\hat{n}}} $$

The bound is calculated as follows:

$$ \text{bound} = \pm z_{1 - \alpha} \sqrt{\frac{\hat{p}(1-\hat{p})}{\tilde{n}}} $$

where

$$ \tilde{n} = n + \frac{z^2}{q} $$

and

$$ \hat{p} = \frac{np + \frac{z^2}{q}/2}{\hat{n}} $$

and $q = 1 - \alpha/2$ for an interval or $q = 1 - \alpha$ for a bound.
Margin of Error for One Sample Variance

Use the Interval Explorer for One Sample Variance to determine a sample size for a confidence interval. Select **DOE > Sample Size Explorers > Confidence Intervals > Margin of Error for One Sample Variance.** Explore the trade offs between sample size, significance, and the margin of error for your interval.

Interval Explorer for One Sample Variance Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Interval Type**

- **Lower Bound** Specifies a one-sided lower interval.
- **Upper Bound** Specifies a one-sided upper interval.
- **Interval** Specifies a two-sided interval.

**Fixed Parameters**

- **Alpha** Specifies the confidence level, 1 - Alpha. The default alpha level is 0.05 for a 95% confidence interval.

**Interval Parameters** Parameters that are inter-related and update as you make changes.

- **Sample Size** Specifies the total number of observations (runs, experimental units, or samples) needed to construct your interval.
- **Interval Width** Specifies the full width of the interval. With all other parameters fixed, interval width decreases as sample size increases.

**Save Settings** Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

**Make Data Collection Table** Creates a new data table that you can use for data collection.

**Statistical Details for the One Sample Variance Interval Explorer**

The interval calculations for capturing a population variance is based on the $X^2$ distribution. Note that the interval bounds are not symmetric around the sample estimate.

The interval width is computed as follows:
width = \left( n - 1 \right) \left( \frac{1}{2 \chi_{\alpha/2, n-1}} - \frac{1}{2 \chi_{1-\alpha/2, n-1}} \right)

The lower bound is computed as follows:

\text{lower bound} = \frac{n - 1}{2 \chi_{1-\alpha, n-1}}

The upper bound is computed as follows:

\text{upper bound} = \frac{n - 1}{2 \chi_{\alpha, n-1}}

**Margin of Error for Two Independent Sample Means**

Use the Interval Explorer for Two Independent Sample Means to determine a sample size for a confidence interval. Select **DOE > Sample Size Explorers > Confidence Intervals > Margin of Error for Two Independent Sample Means**. Explore the trade offs between variability assumptions, sample size, significance, and the margin of error for your interval.

**Interval Explorer for Two Independent Sample Mean Options**

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Interval Type**

- **Bound** Specifies a one-sided interval (upper or lower bound)
- **Interval** Specifies a two-sided interval

**Fixed Parameters**

- **Alpha** Specifies the confidence level, 1 - \( \alpha \). The default alpha level is 0.05 for a 95% confidence interval.
- **Group 1 StdDev** (\( \sigma_1 \)) Specifies the assumed standard deviation for one of your groups, Group 1.
- **Group 2 StdDev** (\( \sigma_2 \)) Specifies the assumed standard deviation for the second group, Group 2.
Population standard deviations known  Specifies calculations based on known population standard deviations.

Interval Parameters  Parameters that are inter-related and update as you make changes.

Group 1 Sample Size  Specifies the number of observations (runs, experimental units, or samples) needed for Group 1 in your experiment. Select Lock to lock the Group 1 sample size.

Group 2 Sample Size  Specifies the number of observations (runs, experimental units, or samples) needed for Group 2 in your experiment. Select Lock to lock the Group 2 sample size.

Total Sample Size  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment. The margin of error curve is based on total sample size. Select Lock to lock the total sample size.

Note: Adjusting the sample size for one group adjusts the total sample size unless the total sample size is locked. In that case, adjusting the sample size for one group adjust the sample size for the second group. Adjusting the total sample size adjusts the two groups proportionally, unless one group is locked. Use only one lock at a time.

Margin of Error  Specifies the half-width of the interval. With all other parameters fixed, margin of error decreases as sample size increases.

Save Settings  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

Make Data Collection Table  Creates a new data table that you can use for data collection.

Statistical Details for the Two Independent Sample Interval Explorer

The interval calculations for capturing the difference in population means is based on the standard normal or $t$ distributions based on whether $\sigma_1$ and $\sigma_2$ are known or unknown.

The margin of error (MOE) is calculated as follows:

\[
MOE = \begin{cases} 
  z_{1 - \alpha/2} \sqrt{\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}} & \text{if } \sigma_1 \text{ and } \sigma_2 \text{ known} \\
  t_{1 - \alpha/2, n-1} \sqrt{\frac{\sigma_1^2}{n_1} + \frac{\sigma_2^2}{n_2}} & \text{if } \sigma_1 \text{ and } \sigma_2 \text{ unknown}
\end{cases}
\]
When \( \sigma_1 \) and \( \sigma_2 \) are unknown, the bounds are calculated as follows:

\[
\text{bound} = \pm t_{1-\alpha, \, df} \sqrt{\frac{s_1^2}{n_1} + \frac{s_2^2}{n_2}}
\]

where

\[
df = \left\{ \begin{array}{ll}
\frac{n_1 + n_2 - 2}{\left( \frac{s_1^2}{n_1} + \frac{s_2^2}{n_2} \right)^{\frac{1}{2}}} & \text{if } \sigma_1 = \sigma_2 \\
\frac{1}{n_1 - 1} \left( \frac{s_1^2}{n_1} \right) + \frac{1}{n_2 - 1} \left( \frac{s_2^2}{n_2} \right) & \text{if } \sigma_1 \neq \sigma_2
\end{array} \right.
\]

When \( \sigma \) is known, the bounds are calculated as follows:

\[
\text{bound} = \pm z_{1-\alpha} \sqrt{\frac{s_1^2}{n_1} + \frac{s_2^2}{n_2}}
\]

**Margin of Error for Two Independent Sample Proportions**

Use the Interval Explorer for Two Independent Sample Proportions to determine a sample size for a confidence interval for the difference in two proportions, for log relative risk, or for log odds. Select **DOE > Sample Size Explorers > Confidence Intervals > Margin of Error for Two Independent Sample Proportions**. Explore the trade offs between variability assumptions, sample size, significance, and the margin of error for your interval.

**Interval Explorer for Two Independent Sample Proportions Options**

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

**Interval Type**

- **Bound**  
  Specifies one side of the interval (upper or lower bound)

- **Interval**  
  Specifies a two-sided interval.

**Comparison Method**
Difference in Proportions  Specifies a confidence interval for the difference in two proportions \((p_1 - p_2)\).

Log Relative Risk  Specifies a confidence interval for the relative risk \((p_1/p_2)\) on a log scale.

Log Odds  Specifies a confidence interval for the odds \((p_1/(1-p_2))\) on a log scale.

Fixed Parameters

Alpha  Specifies the confidence level, 1 - Alpha. The default alpha level is 0.05 for a 95% confidence interval.

Interval Parameters  Parameters that are inter-related and update as you make changes.

Group 1 Proportion  Specifies the assumed proportion for Group 1.

Group 2 Proportion  Specifies the assumed proportion for Group 2.

Group 1 Sample Size  Specifies the number of observations (runs, experimental units, or samples) needed for Group 1 in your experiment. Select Lock to lock the Group 1 sample size.

Group 2 Sample Size  Specifies the number of observations (runs, experimental units, or samples) needed for Group 2 in your experiment. Select Lock to lock the Group 2 sample size.

Total Sample Size  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment. The margin of error curve is based on total sample size. Select Lock to lock the total sample size.

Note: Adjusting the sample size for one group adjusts the total sample size unless the total sample size is locked. In that case, adjusting the sample size for one group adjust the sample size for the second group. Adjusting the total sample size adjusts the two groups proportionally, unless one group is locked. Use only one lock at a time.

Margin of Error  Specifies the half-width of the interval. With all other parameters fixed, margin of error decreases as sample size increases.

Bound Size  Specifies the bound of the interval. With all other parameters fixed, margin of error decreases as sample size increases.

Save Settings  Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

Make Data Collection Table  Creates a new data table that you can use for data collection.
Statistical Details for the Two Independent Proportions Interval Explorer

The calculations for each interval type are based on normal approximations.

**Difference in Proportions**

For intervals about the difference in proportions the margin of error (MOE) is calculated as follows:

\[
\text{MOE} = z_{1 - \alpha/2} \sqrt{\frac{p_1(1 - p_1)}{n_1} + \frac{p_2(1 - p_2)}{n_2}}
\]

The bounds are calculated as follows:

\[
\text{bound} = \pm z_{1 - \alpha} \sqrt{\frac{p_1(1 - p_1)}{n_1} + \frac{p_2(1 - p_2)}{n_2}}
\]

**Log Relative Risk**

For the logarithm of the relative risk the margin of error (MOE) is calculated as follows:

\[
\text{MOE} = z_{1 - \alpha/2} \sqrt{\frac{(1-p_1)}{n_1 p_1} + \frac{(1-p_2)}{n_2 p_2}}
\]

The bounds are calculated as follows:

\[
\text{bound} = \pm z_{1 - \alpha} \sqrt{\frac{(1-p_1)}{n_1 p_1} + \frac{(1-p_2)}{n_2 p_2}}
\]

**Log Odds**

For the logarithm of the odds ratio, the margin of error is calculated as follows:

\[
\text{MOE} = z_{1 - \alpha/2} \sqrt{\frac{1}{n_1 p_1} + \frac{1}{n_1 (1-p_1)} + \frac{1}{n_2 p_2} + \frac{1}{n_2 (1-p_2)}}
\]

The bounds are calculated as follows:

\[
\text{bound} = \pm z_{1 - \alpha} \sqrt{\frac{1}{n_1 p_1} + \frac{1}{n_1 (1-p_1)} + \frac{1}{n_2 p_2} + \frac{1}{n_2 (1-p_2)}}
\]
Margin of Error for Two Independent Sample Variances

Use the Interval Explorer for Two Independent Sample Variance to determine a sample size for a confidence interval. Select DOE > Sample Size Explorers > Confidence Intervals > Margin of Error for Two Independent Sample Variances. Explore the trade offs between sample size, significance, and the margin of error for your interval.

Interval Explorer for Two Independent Sample Variances Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

Interval Type

- **Lower Bound**  Specifies a one-sided lower interval.
- **Upper Bound**  Specifies a one-sided upper interval.
- **Interval**     Specifies a two-sided interval.

Fixed Parameters

- **Alpha**  Specifies the confidence level, 1 - Alpha. The default alpha level is 0.05 for a 95% confidence interval.

Interval Parameters

- **Group 1 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 1 in your experiment. Select Lock to lock the Group 1 sample size.
- **Group 2 Sample Size**  Specifies the number of observations (runs, experimental units, or samples) needed for Group 2 in your experiment. Select Lock to lock the Group 2 sample size.
- **Total Sample Size**  Specifies the total number of observations (runs, experimental units, or samples) needed for your experiment. The margin of error curve is based on total sample size. Select Lock to lock the total sample size.

**Note:** Adjusting the sample size for one group adjusts the total sample size unless the total sample size is locked. In that case, adjusting the sample size for one group adjusts the sample size for the second group. Adjusting the total sample size adjusts the two groups proportionally, unless one group is locked. Use only one lock at a time.

- **Interval Width**  Specifies the full width of the interval. With all other parameters fixed, interval width decreases as sample size increases.
Statistical Details for the Ratio Two Independent Variances Interval Explorer

The interval calculations for capturing the ratio of two population variances is based on the F-distribution. The margin of error (MOE) is calculated as follows:

\[
MOE = F_{1-\alpha/2, n_1 - 1, n_2 - 1} - F_{\alpha/2, n_1 - 1, n_2 - 1}
\]

The lower bound is calculated as follows:

\[
\text{lower bound} = F_{\alpha, n_1 - 1, n_2 - 1}
\]

The upper bound is calculated as follows:

\[
\text{upper bound} = F_{1-\alpha, n_1 - 1, n_2 - 1}
\]

Reliability Demonstration Calculators

Use the Reliability Demonstration calculators to test a specified number of units for a specified period of time. If fewer than \( k \) units fail, the demonstration passes, and you can conclude that the product reliability meets or exceeds a reliability standard.

For reliability demonstrations, select **DOE > Sample Size Explorers > Reliability**:

- “Parametric Reliability Demonstration”
- “Nonparametric Reliability Demonstration”

Parametric Reliability Demonstration

Use the Demonstration Explorer for Parametric Reliability to determine the number of units to put on test for a reliability demonstration. Select **DOE > Sample Size Explorers > Reliability > Parametric Reliability Demonstration**. Explore the trade offs between time, significance, number of failures, and the number of units to test.
Demonstration Explorer for Parametric Reliability Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

Fixed Parameters

- **Alpha** Specifications the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

- **Distribution** Specifies the assumed failure time distribution. Distributions available are: Weibull and Lognormal. For more information about these distributions, see Reliability and Survival Methods.

- **Demonstration Time** Specifies the minimum length of time that an item under test should survive with the intended reliability.

- **Demonstration Reliability** Specifies the probability that an item under test survives until the defined Demonstration Time of the reliability standard.

- **Scale parameter** Specifies the scale parameter for the failure time distribution.

**Note:** The Scale field is denoted Weibull $\beta$ when the specified Distribution is Weibull.

Demonstration Parameters Parameters that are inter-related and update as you make changes.

- **Maximum failures allowed** Specifies the maximum number of failures allowed for a successful test demonstration.

- **Sample Size** Specifies the total number of units on test needed for your demonstration.

- **Test Time** Specifies the length of the demonstration test in time.

- **Save Settings** Saves the current settings to the Saved Settings table. This enables you to save a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

- **Make Data Collection Table** Creates a new data table that you can use for data collection.

Statistical Details for the Parametric Reliability Demonstration Explorer

For a parametric reliability demonstration test, the test time needed to demonstrate that the product achieves a demonstration time $T_d$ with reliability $R_d$ is computed using a Binomial distribution with probability of success computed using the assumed lifetime distribution.

The test time for the Weibull distribution is computed as follows:
test time \( = T_d \left( \frac{-\log(P)}{\log(R_d)} \right)^{1/\beta} \)

The test time for the lognormal distribution is computed as follows:

\[
\text{test time} = \exp \left( \frac{z \left( 1 - e^{-\log P - z_1 - R_d} \right)}{\sigma} \right)
\]

where

\[
\log P = -\log \left( \frac{S_f}{S_f + 1} \right)
\]

\[
S_f = \frac{n - c}{c + 1} \alpha, 2(n - c), 2(c + 1)
\]

and \( c \) is the maximum number of failures allowed during the demonstration.

### Nonparametric Reliability Demonstration

Use the Demonstration Explorer for Nonparametric Reliability to determine the number of units to put on test for a reliability demonstration when there is not an assumed failure rate distribution. Select **DOE > Sample Size Explorers > Reliability > Nonparametric Reliability Demonstration**. Explore the trade offs between time, significance, number of failures, and the number of units to test.

#### Demonstration Explorer for Nonparametric Reliability Options

Set study assumptions and explore sample sizes using the radio buttons, text boxes, and sliders. The curve updates as you make changes to the settings. Alternatively, change settings by dragging the cross hairs on the curve or adjusting the values in the axis text boxes.

#### Fixed Parameters

**Alpha**  Specifies the probability of a type I error, which is the probability of rejecting the null hypothesis when it is true. It is commonly referred to as the significance level of the test. The default alpha level is 0.05.

**Demonstration Parameters**  Parameters that are inter-related and update as you make changes.

**Maximum failures allowed**  Specifies the maximum number of failures allowed for a successful test demonstration.
Sample Size Explorers
Saved Settings in the Sample Size Explorers

Sample Size  Specifies the total number of units on test needed for your demonstration.

Demonstration Reliability  Specifies the probability that the item under test survives until
the defined Demonstration Time of the reliability standard.

Save Settings  Saves the current settings to the Saved Settings table. This enables you to save
a set of alternative study plans. See “Saved Settings in the Sample Size Explorers”.

Make Data Collection Table  Creates a new data table that you can use for data collection.

Statistical Details for the Nonparametric Reliability Demonstration Explorer

For a nonparametric reliability demonstration test, the demonstrated reliability is computed
based on the Binomial distribution. The \( \alpha \) quantile of the Binomial cdf can be computed by a
transformation to an \( \alpha \) quantile from the \( F \)-distribution, see Jowett, (1963).

The reliability is calculated as follows:

\[
R = \frac{S_f}{S_f + 1}
\]

where

\[
S_f = \frac{n - c}{c + 1} \alpha, 2(n - c), 2(c + 1)
\]

and \( c \) is the maximum number of failures allowed during the demonstration.

Saved Settings in the Sample Size Explorers

The Saved Settings report provides a table of saved settings enabling you to compare study
scenarios. Each time you click the Save Settings button, a new row is added to the table. Click
on a row in the table to reset the explorer to those settings. Right-click in the table and select
Columns to display additional parameter values in the table.

The Saved Settings red triangle contains the following options:

Clear Selected Rows  Removes the selected rows from the Saved Settings table.

Clear All  Clears all rows from the Saved Setting table.

Make Table  Creates a new a data table that contains all Saved Settings table columns
including those that are hidden.
Appendix A

Column Properties

Understanding Column Properties Assigned by DOE

When you construct a design using the DOE platforms, column properties are saved to the data table that contains the resulting design. This appendix provides detail about only those column properties that are saved to designs that the DOE platform constructs. Examples illustrate how each column property is assigned and used by the DOE platforms. Descriptions of column properties not assigned by the DOE platforms are provided in *Using JMP*.

Some of the column properties described in this appendix are useful in general modeling situations. To use the properties more generally, you can specify them yourself. This ability is particularly useful when your design has not been created by a DOE platform. Some of the examples in this appendix illustrate situations where you add a column property on your own.

**Figure A.1** Column Property Asterisks and Column Info Window
Contents

Adding and Viewing Column Properties .......................................................... 785
Response Limits .................................................................................................. 786
  Response Limits Example ................................................................................ 788
  Editing Response Limits ................................................................................. 791
Detection Limits ................................................................................................ 794
Functional Response ......................................................................................... 794
  Design Role Example ...................................................................................... 795
Coding, .................................................................................................................. 797
  Low and High Values ....................................................................................... 797
  Coding Column Property and Center Polynomials ........................................... 798
  Coding Example ............................................................................................. 798
  Assigning Coding ............................................................................................ 802
Mixture .................................................................................................................. 805
  Mixture Example ............................................................................................. 807
Factor Changes .................................................................................................... 810
  Factor Changes Example ............................................................................... 811
Value Order .......................................................................................................... 813
  Value Order Example ..................................................................................... 815
  Assigning Value Order .................................................................................... 816
Value Labels ......................................................................................................... 817
  Value Labels Example ..................................................................................... 817
RunsPerBlock ........................................................................................................ 819
  RunsPerBlock Example .................................................................................... 819
ConstraintState ................................................................................................. 820
  ConstraintState Example ................................................................................ 821
Adding and Viewing Column Properties

The DOE platforms automatically save certain column properties to the design tables that they construct. However, some of the column properties associated with designed experiments are useful in general modeling situations. To use these column properties with data tables that have not been created using DOE platforms, you can add them yourself.

Adding a Column Property

To assign a column property to one or more columns, do the following:

1. Select the column or columns to which you want to assign a property.
2. Do one of the following:
   - Right-click the header area, select Column Properties, and select the property.
   - Right-click the header area, select Column Info, and select the property from the Column Properties menu.
   - Select Cols > Column Info and select the property from the Column Properties menu.
3. In the column property panel that appears, specify values and select options as appropriate.
4. Click Apply to add the column property or click OK to add the column property and close the column properties window.

Tip: A column might already contain a property that you want to apply to other columns. Use the Standardize Attributes command to apply that property to other columns. See Using JMP.

Viewing a Column Property

To view the properties assigned to a specific column, in the columns panel, click the column property asterisk icon *. Click a property to see its settings or to edit it. Figure A.2 shows the column properties assigned to Stretch in the Bounce Data.jmp sample data table, located in the Design Experiment folder.
You can also view column properties by accessing the Column Properties list in the Column Info menu. Select the column or columns whose column properties you want to view and do one of the following:

- Right-click the header area, select Column Info, and select the property from the Column Properties list.
- Select Cols > Column Info and select the property from the Column Properties list.

**Response Limits**

Using the Response Limits column property, you can specify the following:

- bounds on the range of variation for a response
- a desirability goal
- a measure of the importance of the response
- desirability values

The Response Limits column property defines a desirability function for the response. The Profiler and Contour Profiler use desirability functions to find optimal factor settings. See Profilers.

*Figure A.3* shows the Response Limits panel in the Column Info window for the response Stretch in the Bounce Data.jmp sample data table, found in the Design Experiment folder.
Figure A.3  Example of the ResponseLimits Panel

The Response Limits panel consists of the following areas:

**Goal**  Select your response goal from the menu. Available goals are Maximize, Match Target, Minimize, and None. JMP defines a desirability function for the response to match the selected goal. If you specify limits, the desirability function is defined using these limits. If you do not specify limits, JMP bases the desirability function on conservative limit values derived from the distribution of the response. If None is selected as the goal, then all response values are considered equally desirable. See also “Responses”.

**Importance**  Enter a relative weighting for each of several responses in computing the overall desirability function. The Importance value can be any positive number. When no Importance value is specified, JMP treats all responses in a given analysis as having equal Importance values. If there is only one response, it receives Importance 1.

**Value**  Specify Lower and Upper limits and a Middle value for your response. JMP uses these values to construct a desirability function for the response. If you do not specify limits, JMP bases the desirability function on conservative limit values. If your goal is Match Target and no Middle value is specified, then the target is defined to be the midpoint of the Lower and Upper limits.

**Desirability**  Specify values that reflect the desirability of your Lower, Middle, and Upper values. Desirability values should be between 0 and 1. If you do not specify Desirability values, JMP assigns values in accordance with the selected Goal.

**Show as Graph Reference Lines**  Shows horizontal reference lines for the Lower, Middle, and Upper values in the Actual by Predicted Plot and the Prediction Profiler. This option applies only if limits are specified.
Response Limits Example

The Coffee Data.jmp sample data table (located in the Design Experiment folder) contains the results of an experiment that was performed to optimize the Strength of coffee. For a complete description of the experimental design and analysis, see “The Coffee Strength Experiment”.

Your goal is to find factor settings that enable you to brew coffee with a target strength of 1.3, which is considered to be the most desirable value. Values less than 1.2 and greater than 1.4 are completely undesirable. The desirability of values between 1.2 and 1.4 decreases as their distance from 1.3 increases.

1. Select Help > Sample Data Library and open Design Experiment/Coffee Data.jmp.
2. In the Table panel, click the green triangle next to the DOE Dialog script.
   The DOE Dialog script re-creates the Custom Design dialog that was used to create the experimental design in Coffee Data.jmp.
3. Open the Responses outline.

Figure A.4 Responses Outline in Custom Design Window

When you designed this experiment, you specified a response Goal of Match Target with a Lower Limit of 1.2 and an Upper Limit of 1.4. Since there is only one response, you did not specify a value for Importance, because it is 1 by default. When you constructed the design table, JMP assigned the Response Limits column property to Strength.

4. Close the Custom Design window.
5. In the Coffee Data.jmp sample data table, select the Strength column and select Cols > Column Info.
6. Select Response Limits in the Column Properties list.
Figure A.5 Response Limits Column Property for Strength

Notice the following:

- The Goal is set to **Match Target**.
- Importance is missing. When Importance is missing, JMP treats all responses in a given analysis as having equal Importance values. So JMP assigns Strength an Importance value of one.
- The Lower limit is 1.2.
- The Upper limit is 1.4.
- No Middle value is specified.
  Because no Middle value is specified, the target is defined to be the midpoint of the Lower and Upper limits, which is 1.3.
- No Desirability values are specified.

7. Select the **Show as Graph Reference Lines** option.
   
   This option shows horizontal reference lines for the Lower, Middle, and Upper values in the Actual by Predicted Plot and the Prediction Profiler.

8. Click **OK**.

9. In the **Coffee Data.jmp** data table, click the green triangle next to the **Reduced Model** script.

10. Click **Run**.
     
    The Prediction Profiler appears at the bottom of the report.
The desirability function for Strength appears in the plot at the right above Desirability. This plot appears because the data table contains a Response Limits column property for Strength. The Prediction Profiler also shows reference lines for the Lower and Upper limits for Strength.

11. Press Ctrl and click the Strength plot for Desirability.

Figure A.7  Response Goal Window for Strength

Notice the following:

- JMP determines the Middle value to be the midpoint of the High and Low limits that you specified in the Response Limits column property.
- Because the Goal is set to Match Target, JMP sets the Desirability for the Middle value to 1.
- JMP sets the Desirability for the High and Low values to very small numbers, 0.0183.
- The Desirability plot in Figure A.6 shows how JMP uses the Desirability values shown in Figure A.7. The Desirability function for Strength is essentially 0 beyond the Low and High values and it increases to 1 gradually as Strength approaches the target of 1.3. The Importance value is set to 1 since there is only one response in the model.

12. Click Cancel to exit the window.
13. Click the Prediction Profiler red triangle and select **Optimization and Desirability > Maximize Desirability.**

The settings for Time and Charge are updated to show settings for the factors that maximize the desirability function for Strength. However, many other settings also maximize the desirability function. See *Profilers* for information about how to identify other settings that maximize the desirability function.

**Editing Response Limits**

In the Vinyl Data.jmp sample data table, a Response Limits column property is already assigned to the response thickness. The property has a goal of maximizing thickness. Suppose that instead of maximizing thickness, you want the sheets of vinyl to have a thickness between 6 and 10, with a target thickness of 8.5.

1. Select **Help > Sample Data Library** and open Design Experiment/Vinyl Data.jmp.
2. Select the thickness column and select **Cols > Column Info.**

   The Response Limits property appears in the Column Properties list as the only property assigned to thickness. The Response Limits panel appears to the right of the list.
3. Click **Maximize** and select **Match Target.**
4. Type 1 for the **Importance** value.
5. Under Value, type 6 for the Lower value, 8.5 for the Middle value, and 10 for the Upper value.

   This is an example of asymmetric response limits. Values of thickness as small as 6 or as large as 10 are acceptable. However, the target for thickness is 8.5.
6. Select **Show as Graph Reference Lines.**

   This option shows horizontal reference lines for the Lower, Middle, and Upper values in the Actual by Predicted Plot and the Prediction Profiler.
7. Click **OK**.

8. In the Vinyl Data.jmp data table, click the green triangle next to the **Model** script.

   Note that m1, m2, and m3 are mixture factors. Also, the design involves a random Whole Plots factor. Because of this, the default Method is REML (Recommended).

9. Click **Run**.

10. Click the Response thickness red triangle and select **Row Diagnostics > Plot Actual by Predicted**.

    The reference lines for the Lower, Middle, and Upper limits appear on the Actual by Predicted Plot.

11. Click the Response thickness red triangle and select **Factor Profiling > Profiler**.
The plot at the right above Desirability shows the desirability function that JMP has constructed for thickness. The desirability is 1 at the Middle limit of 8.5. The desirability is essentially 0 for thickness values below 6 and above 10.

12. Press Ctrl and click the thickness plot for Desirability.

Figure A.10  Response Goal Window for Thickness

This window shows your settings for the High, Middle, and Low Values. It also shows the Desirability values that JMP assigns, based on your goal of Match Target. The Desirability function shown in Figure A.9 is a continuous curve that matches the Desirability settings in Figure A.10 at the High, Middle, and Low Values. At other values, the Desirability function assigns desirabilities that are consistent with the selected goal.

13. Click Cancel.

14. Click the Prediction Profiler red triangle and select Optimization and Desirability > Maximize Desirability.

The settings for the factors are updated to show values that maximize the desirability function for thickness. Keep in mind that many other settings also maximize the desirability function. The predicted response at these optimal settings is 8.5. Recall that you set 8.5 as the target setting, with limits of 6 and 10.

15. Close the Vinyl Data.jmp sample data table without saving the changes.
Detection Limits

The Detection Limits column property defines bounds beyond which the response cannot be measured. You can use these limits to specify a censored response in the Generalized Regression platform.

Functional Response

The FDE X column property specifies a column as a functional response. Multiple Y columns with the FDE column property can be used in the Functional Data Explorer platform with the DOE factors as supplementary factors.

Design Role

Factors in designed experiments, as well as in more general models, can behave in various ways. JMP uses the design role column property to describe these behaviors. These are the possible design roles:

- Continuous
- Discrete Numeric
- Categorical
- Blocking
- Covariate
- Mixture
- Constant
- Uncontrolled
- Random Block
- Signal
- Noise
In many of the JMP DOE platforms, you can specify factors with different design roles. In some platforms, your design requirements cause JMP to define factors. For example, Whole Plots and Subplots are factors that JMP creates when you specify very-hard-to-change and hard-to-change factors. In platforms where various design roles can occur, when JMP creates the design table for your design, each factor is assigned the Design Role column property.

- For descriptions of the design roles other than Random Block, Signal, and Noise, see “Factor Types”.
- For a description of the Random Block design role, see “Changes and Random Blocks”.
- For descriptions of the Signal and Noise design roles, see “Factors”.

**Design Role Example**

The experiment in the Odor Control Original.jmp sample data table studies the effect of three factors on odor. You designed the 15-run experiment and it was conducted. However, when the results were reported to you, you learned that the experiment was conducted over three days. The first 5 runs were conducted on Day 1, the second 5 runs on Day 2, and the remaining 5 runs on Day 3.

Since variations in temperature and humidity might have an effect on the response, you want to include Day as a random blocking factor. It is easy to add a column for Day to the design table. But you want to use the Evaluate Design platform to compare the design with the unexpected block to your original design. You also want the ability to use the Augment Design platform in case you need to augment the design. To use the Evaluate Design and Augment Design platforms, you need to add the Design Role column property to your new Day column.

1. Select Help > Sample Data Library and open Odor Control Original.jmp.
2. Select the first column, Run.
4. Next to Column Name, type Day.
5. From the Initialize Data list, select Sequence Data.
6. Enter the following:
   - 1 for From
   - 3 for To
   - 1 for Step
   - 5 for Repeat each value N times
7. Next to Number of columns to add, type 1.
8. Click **OK**.

   The Day column is added as the second column in the data table.

9. Select the Day column.

10. Select **Cols > Column Info**.

11. From the Column Properties list, select **Design Role**.

12. In the Design Role panel, click **Continuous** and select **Random Block**.

13. Click **OK**.

   In the columns panel, an asterisk appears next to Day.

14. Click the asterisk next to Day to verify that the Design Role column property has been assigned.

15. Close the Odor Control Original.jmp sample data table without saving the changes.
Coding

The Coding column property applies only to columns with a numeric data type. It applies a linear transformation to the data in the column. In the Coding column property window, you specify a Low Value and a High Value. The Low Value and High Value in your original data are transformed to –1 and +1. JMP uses the transformed data values whenever the column is entered as a model effect in the Fit Model platform.

The coding property is useful for the following reasons:

- Coded predictors lead to parameter estimates that are more easily interpreted and compared.
- Coded predictors help reduce multicollinearity in models with interaction and higher-order terms.

When any DOE platform other than Accelerated Life Test Design creates a design, JMP defines a Coding column property for each non-mixture factor with a numeric data type. Figure A.12 shows the Coding column property panel for the column Feed Rate in the Reactor 20 Custom.jmp sample data table, found in the Design Experiment folder.

Figure A.12  Coding Property Panel for Feed Rate

Low and High Values

When the Coding property is applied as part of design construction in a DOE platform, the Low Value is initially set to the minimum setting of the factor and the High Value is initially set to the maximum setting.
When you apply the Coding property to a column that does not contain that property, JMP inserts the minimum value as the Low Value and the maximum value as the High Value. You can change these values as needed.

**Caution:** After the Coding column property is assigned to a column, JMP does not automatically update it when you make changes to the values in the column. If you change the values in a column that has a Coding column property, review the High Value and Low Value to ensure that they are still appropriate.

The Coding column property centers each value in a column by subtracting the midpoint of the High Value and Low Value. It then divides by half the range. Suppose that \( H \) is the High Value and \( L \) is the Low Value. Then every \( X \) in the column is transformed to the following:

\[
\frac{X - (H + L)/2}{(H - L)/2}
\]

For each factor, the transformed values have a midpoint equal to 0 and range from -1 to +1.

**Coding Column Property and Center Polynomials**

The Center Polynomials option is located in the Fit Model launch window, within the Model Specification red triangle menu. Center Polynomials centers a continuous column involved in a polynomial term by subtracting the mean of each value in the column. See *Fitting Linear Models*.

If the Coding column property is assigned to a column, then the Center Polynomials option has no effect on that column. In a polynomial term involving that column, the values are centered and scaled as specified by their Coding property. Suppose that another column in the model does not have the Coding property and that you select Center Polynomials. Then that column is centered by its mean in any polynomial term where it appears.

**Coding Example**

The Reactor 20 Custom.jmp sample data table contains data from a 20-run design that was constructed using the Custom Design platform. The experiment investigates the effects of five factors on a yield response (Percent Reacted) for a chemical process.

1. Select **Help > Sample Data Library** and open Design Experiment/Reactor 20 Custom.jmp.
2. In the Table panel, click the green triangle next to the **DOE Dialog** script.
3. Open the **Factors** outline.
Notice that the settings for Temperature range from 140 to 180. When the design was generated, the Coding column property was assigned to Temperature. The Low Value is set to 140 and the High Value is set to 180.

4. Close the Custom Design window.

5. In the Reactor 20 Custom.jmp sample data table, click the asterisk next to Temperature in the columns panel and select Coding.

The Column Info window appears and shows the Coding column property panel. You can see that JMP added the column property, specifying the Low Value and High Value, when it constructed the design table. In fact, by repeating this step, you can verify that JMP added the Coding property for all five factors.

Figure A.14 Coding Panel for Temperature

6. Click Cancel to close the Column Info window.

7. In the Reactor 20 Custom.jmp sample data table, click the green triangle next to the Reduced Model script.

This script fits a model that contains only the five effects determined to be significant based on an analysis of the full model.
8. Click **Run**.

**Figure A.15** Effect Summary Report for Reduced Model

In the Source list, the High and Low values used in the Coding column property appear in parentheses to the right of the main effects, Catalyst, Temperature, and Concentration. The ranges imposed by the Coding property are not shown for the interaction effects.

**Tip:** Notice the “^” symbols to the right of the PValues for Temperature and Concentration. These symbols indicate that these main effects are components of interaction effects with smaller p-values. If an interaction effect is included in the model, then the principle of effect heredity requires that all component effects are also in the model. See “Effect Heredity”.

9. Click the Response Percent Reacted red triangle and select **Estimates > Show Prediction Expression**.

Look at the Prediction Expression outline to see how coding affects the prediction formula.
Each factor is transformed as specified by the Coding column property. For example, for Temperature, notice the following:

- The Low Value in the Coding property was set to 140. The Temperature value of 140 is transformed to -1.
- The High Value in the Coding property was set to 180. The Temperature value of 180 is transformed to +1.
- The midpoint of the Low and High values is 160. The Temperature value of 160 is transformed to 0.

The transformed values help you compare the effects. The estimated coefficient for Catalyst is 9.942 and the estimated coefficient for Concentration is -3.077. It follows that the predicted effect of Catalyst on Percent Reacted is more than three times as large as the effect of Concentration on Percent Reacted. Also, the coefficients indicate that predicted Percent Reacted increases as Catalyst increases and decreases as Concentration increases.

The transformed values help you interpret the coefficients:

- When all factors are at their midpoints, their transformed values are 0. The predicted Percent Reacted is the intercept, which is 65.465.
- When Catalyst and Concentration are at their midpoints, a 20 unit increase in Temperature increases the Percent Reacted by 5.558 units.
- Suppose that Concentration is at its midpoint, so that its transformed value is 0:
– When Catalyst is at its midpoint, a 20 unit increase in Temperature increases the Percent Reacted by 5.558 units.
– When Catalyst is at its high setting, a 20 unit increase in Temperature increases the Percent Reacted by 5.558 + 6.035 = 11.593 units.

It follows that the coefficient of the interaction term, 6.035, is the increase in the slope of the model for predicted Percent Reacted for a 0.5 unit change in Catalyst.

Assigning Coding

The experimental data in the Tiretread.jmp sample data table results from an experiment to study the effects of SILICA, SILANE, and SULFUR on four measures of tire tread performance. In this example, you will consider only one of the responses, ABRASION.

You will first fit a model using the uncoded factors. Then you will assign the coding property to the factors and rerun the model to obtain meaningful parameter estimates.

1. Select Help > Sample Data Library and open Tiretread.jmp.
2. Select Analyze > Fit Model.
3. Select ABRASION and click Y.
4. Select SILICA, SILANE, and SULFUR and click Macros > Response Surface.
5. Check Keep dialog open.
6. Click Run.
7. Click the Response ABRASION red triangle and select Estimates > Show Prediction Expression.
Appendix A
Column Properties
Design of Experiments Guide

Figure A.17 Prediction Expression for Model with Uncoded Factors

\[
\begin{align*}
\text{Prediction Expression} &= -40.0394111 + 32.987289493 \cdot \text{SILICA} \\
&\quad + 1.7880765099 \cdot \text{SILANE} \\
&\quad + 21.813076926 \cdot \text{SULFUR} \\
&\quad + \left( \frac{\text{SILICA} - 1.2}{1.2} \right) \cdot \left( \frac{\text{SILICA} - 1.2}{1.2} - 16.03840362 \right) \\
&\quad + \left( \frac{\text{SILANE} - 1.2}{1.2} \right) \cdot \left( \frac{\text{SILANE} - 50}{50} + 1.025 \right) \\
&\quad + \left( \frac{\text{SILANE} - 50}{50} \right) \cdot \left( \frac{\text{SULFUR} - 2.3}{2.3} - 0.034471056 \right) \\
&\quad + \left( \frac{\text{SILICA} - 1.2}{1.2} \right) \cdot \left( \frac{\text{SULFUR} - 2.3}{2.3} \cdot 28.5 \right) \\
&\quad + \left( \frac{\text{SILANE} - 50}{50} \right) \cdot \left( \frac{\text{SULFUR} - 2.3}{2.3} \cdot 1.575 \right) \\
&\quad + \left( \frac{\text{SULFUR} - 2.3}{2.3} \right) \cdot \left( \frac{\text{SULFUR} - 2.3}{2.3} \cdot -6.288485272 \right)
\end{align*}
\]

The coefficients do not help you compare effect sizes. The sizes of the coefficients do not reflect the impact of the effects on ABRASION over the range of their settings. Also, the coefficients are not easily interpreted. For example, the coefficients do not facilitate your understanding of the predicted response when SILICA is at the midpoint of its range.

Apply the Coding column property to the three factors to see how coding makes the coefficients more meaningful.

8. In the Tiretread.jmp data table, select SILICA, SILANE, and SULFUR in the Columns panel. Click the Columns red triangle and select Standardize Attributes.


10. Click OK.

An asterisk appears in the Columns panel next to SILICA, SILANE, and SULFUR indicating that these have been assigned a column property.

11. In the Fit Model window, click Run.

12. Click the Response ABRASTION red triangle and select Estimates > Show Prediction Expression.
The coefficients for the coded factors enable you to compare effect sizes. SILANE has the largest effect on ABRASION over the range of design settings. The effects of SILICA and the SILANE*SULFUR interaction are large as well.

The coefficients for the coded factors are also more easily interpreted. For example, when all factors are at the center of their ranges, the predicted value of ABRASION is the intercept, 139.12.

13. Close the Tiretread.jmp sample data table without saving the changes.
### Mixture

The Mixture column property is useful when a column in a data table represents a component of a mixture. The components of a mixture are constrained to sum to a constant. Because of this, they differ from non-mixture factors. The Mixture column property serves two purposes:

- **It identifies a column as a mixture component.**
  - If you add a column with the Mixture column property as a model effect in the Analyze > Fit Model window, JMP automatically generates a no-intercept model.
- **It defines the coding for a mixture component.**
  - Coding for mixture components differs from that for non-mixture factors. However, as with non-mixture factors, a benefit of coding for mixture factors is that it helps you interpret parameter estimates. See “PseudoComponent Coding”.

**Figure A.19** shows the Mixture column property panel for the factor m1 in the Vinyl Data.jmp sample data table, found in the Design Experiment folder.

**Figure A.19  Mixture Column Property Panel**

In the Mixture column property panel, you can specify the following:

**Lower Limit**  Specifies the low value used in PseudoComponent Coding. When the Mixture property is applied as part of design construction in a DOE platform, the Lower Limit is set to the minimum setting of the factor. When you apply the Mixture property to a column that does not contain that property, JMP inserts the minimum value as the Lower Limit. You can change this value as needed.
**Upper Limit**  Specifies the high value used in PseudoComponent Coding. When the Mixture property is applied as part of design construction in a DOE platform, the Upper Limit is set to the maximum setting of the factor. When you apply the Mixture property to a column that does not contain that property, JMP inserts the maximum value as the Upper Limit. You can change this value as needed.

**Sum of Terms**  Specifies the sum of the mixture components. When you apply the Mixture property to a column that does not contain that property, JMP inserts a default value of 1 for the Sum of Terms.

**L PseudoComponent Coding**  Transforms data values so that the Lower Limit corresponds to 0.

**U PseudoComponent Coding**  Transforms data values so that the Upper Limit corresponds to 0.

**PseudoComponent Coding**

A pseudo-component is a linear transformation. Let $S$ denote the sum of the mixture components. Suppose that $q$ columns $X_1, X_2, \ldots, X_q$ have been assigned the Mixture column property. Suppose that the columns and effects constructed from these columns are entered as effects in the Fit Model window.

Define the following:

$$L = \sum_{i=1}^{q} L_i$$

where $L_i$ is the Lower Limit for $X_i$.

$$U = \sum_{i=1}^{q} U_i$$

where $U_i$ is the Upper Limit for $X_i$.

Let $x_i$ denote a value of the column $X_i$. The L PseudoComponent at $x_i$ is defined as follows:

$$x_i^L = (X_i - L_i)/(S - L)$$

The U PseudoComponent at $x_i$ is defined as follows:

$$x_i^U = (U_i - X_i)/(U - S)$$

If you select both **L PseudoComponent Coding** and **U PseudoComponent Coding**, the Fit Model platform uses the $L$ coding if $(S - L) < (U - S)$. Otherwise, the $U$ coding is used.
In Fit Model, mixture factors are transformed using pseudo-components before computing parameter estimates. This helps make parameter estimates more meaningful. In reports dealing with parameter estimates, the mixture main effects are given by the coding transformation. Other reports, such as the profilers, are based on the uncoded values.

**Mixture Example**

The data in the Donev Mixture Data.jmp sample data table, found in the Design Experiment folder, are based on an example from Atkinson and Donev (1992). The design includes three mixture factors and one non-mixture factor:

- The response is the electromagnetic Damping of an acrylonitrile powder.
- The three mixture ingredients are copper sulphate (CuSO4), sodium thiosulphate (Na2S2O3), and Glyoxal.
- The non-mixture environmental factor of interest is the Wavelength of light.

Though Wavelength is theoretically continuous, the researchers were interested only in predictions at three discrete wavelengths. As a result, Wavelength is treated as a categorical factor with three levels.

For more information about using Custom Design to construct a design for this situation, see “Mixture Experiments”.

1. Select Help > Sample Data Library and open Design Experiment/Donev Mixture Data.jmp.
2. Click the asterisk next to CuSO4 in the columns panel and select Mixture.

**Figure A.20** Mixture Column Property Panel for CuSO4
Notice the following:

- The Lower Limit is 0.2, the minimum design setting for CuSO4.
- The Upper Limit is 0.8, the maximum design setting for CuSO4.
- The Sum of Terms is set to 1. This is the sum of the three mixture factors.
- The **L PseudoComponent Coding** option is selected. See “PseudoComponent Coding”.

3. Click **Cancel**.

4. Click the asterisk next to Glyoxal in the columns panel and select **Mixture**.

   For this factor, note the following:
   
   - The Lower Limit is 0, the minimum design setting for Glyoxal.
   - The Upper Limit is 0.6, the maximum design setting for Glyoxal.

5. Click **Cancel**.

6. In the Donev Mixture Data.jmp data table, click the green triangle next to the **Model** script.

   The model contains the main effects of the mixture factors and two-way interactions for all four factors.

7. Click **Run**.

   In the Parameter Estimates report, the mixture factors appear in their pseudo-component coded form. When the mixture factors appear in interactions, they are not denoted in coded form. Nevertheless, the model fitting is based on the pseudo-components. The first three terms in the Parameter Estimates report (Figure A.21), show the coded form for the mixture factors.

**Figure A.21** Parameter Estimates Report

| Term                        | Estimate | Std Error | t Ratio | Prob>|t| |
|-----------------------------|----------|-----------|---------|-----|---|
| (CuSO4-0.2)/06              | 6.1910821| 0.918605  | 6.74    | 0.0005* |
| (Na2S2O3-0.2)/06            | 4.0898179| 0.918065  | 4.36    | 0.0048* |
| Glyoxal/0.6                 | 8.1656667| 0.921638  | 8.86    | 0.0001* |
| CuSO4+Na2S2O3               | 11.293949| 4.728932  | 2.39    | 0.0542  |
| CuSO4+Glyoxal               | 4.3511592| 4.512775  | 0.96    | 0.3722  |
| CuSO4+Wavelength[L1]       | -3.647534| 1.113399  | -3.14   | 0.00135* |
| CuSO4+Wavelength[L2]       | 1.8781509| 1.079113  | 1.74    | 0.1324  |
| Na2S2O3+Glyoxal             | 18.4845  | 4.512775  | -4.10   | 0.00064* |
| Na2S2O3+Wavelength[L1]     | -0.275689| 1.064006  | -0.26   | 0.8042  |
| Na2S2O3+Wavelength[L2]     | 0.4452853| 1.103581  | 0.40    | 0.7006  |
| Glyoxal+Wavelength[L1]     | 0.198283 | 1.090627  | 0.18    | 0.8617  |
| Glyoxal+Wavelength[L2]     | 0.1905384| 1.090647  | 0.17    | 0.8571  |

8. Click the Response Damping red triangle and select **Estimates > Show Prediction Expression**.

   The Prediction Expression report shows the model that was fit. Note that the mixture factors are transformed using the L PseudoComponent coding.
**Figure A.22** Prediction Expression for Damping Model

<table>
<thead>
<tr>
<th>Prediction Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.1910820765 [ \left( \frac{\text{CuSO}_4 - 0.2}{0.6} \right) ]</td>
</tr>
<tr>
<td>+ 4.0089179235 [ \left( \frac{\text{Na}_2\text{S}_2\text{O}_3 - 0.2}{0.6} \right) ]</td>
</tr>
<tr>
<td>+ 8.1666666667 [ \left( \frac{\text{Glyoxal}}{0.6} \right) ]</td>
</tr>
<tr>
<td>+ \left( \frac{\text{CuSO}_4 - 0.2}{0.6} \right) \cdot \left( \frac{\text{Na}_2\text{S}_2\text{O}_3 - 0.2}{0.6} \right) \cdot 11.293949004</td>
</tr>
<tr>
<td>+ \left( \frac{\text{CuSO}_4 - 0.2}{0.6} \right) \cdot \left( \frac{\text{Glyoxal}}{0.6} \right) \cdot 4.3511691804</td>
</tr>
<tr>
<td>+ \left( \frac{\text{CuSO}_4 - 0.2}{0.6} \right) \cdot \text{Match(Wavelength)} \left{ \begin{array}{l} &quot;L1&quot; = -3.847342876 \ &quot;L2&quot; = 1.8781509412 \ &quot;L3&quot; = 1.9691919345 \ \text{else} \Rightarrow . \end{array} \right.</td>
</tr>
<tr>
<td>+ \left( \frac{\text{Na}_2\text{S}_2\text{O}_3 - 0.2}{0.6} \right) \cdot \left( \frac{\text{Glyoxal}}{0.6} \right) \cdot -18.48450251</td>
</tr>
<tr>
<td>+ \left( \frac{\text{Na}_2\text{S}_2\text{O}_3 - 0.2}{0.6} \right) \cdot \text{Match(Wavelength)} \left{ \begin{array}{l} &quot;L1&quot; = -0.275688526 \ &quot;L2&quot; = 0.44528528 \ &quot;L3&quot; = -0.169596754 \ \text{else} \Rightarrow . \end{array} \right.</td>
</tr>
<tr>
<td>+ \left( \frac{\text{Glyoxal}}{0.6} \right) \cdot \text{Match(Wavelength)} \left{ \begin{array}{l} &quot;L1&quot; = 0.1982830114 \ &quot;L2&quot; = 0.1905384076 \ &quot;L3&quot; = -0.388821419 \ \text{else} \Rightarrow . \end{array} \right.</td>
</tr>
</tbody>
</table>

Suppose that you are interested in predictions at Wavelength L2. Suppose also that Na2S2O3 and Glyoxal are set to their low values, 0.2 and 0 respectively, and that CuSO4 is set to its high value, 0.8. In this case, the predicted Damping equals the parameter estimate for CuSO4 (6.191) plus the parameter estimate for CuSO4\*Wavelength[L2] (1.878). You can verify this in the Prediction Profiler.

9. Click the Response Damping red triangle and select **Save Columns > Save Coding Table**.
For this particular design, the L Pseudo Component coding transforms the mixture factors to range between 0 and 1. Note that this does not happen in general.

**Factor Changes**

The Factor Changes column property indicates how difficult it is to change factor settings in a designed experiment. The possible specifications for Factor Changes are Easy, Hard, and Very Hard. For example, Figure A.24 shows the Factor Changes column property panel for the factor A1 in the Battery Data.jmp sample data table, located in the Design Experiment folder.

**Figure A.24** Factor Changes Column Property Panel
• When a design contains factors that are hard-to-change and very-hard-to-change, it must also include a subplot and a whole plot factor:
  – The levels of the whole plot factor define the groups of runs for which the levels of the very-hard-to-change factors are held constant.
  – The levels of the subplot factor define the groups of runs for which the levels of the hard-to-change factors are held constant.

• When a design contains only factors that are hard-to-change, but no factors that are very-hard-to-change, it should include a whole plot factor. The levels of the whole plot factor define the groups of runs for which the levels of the hard-to-change factors are held constant. See “Changes and Random Blocks”.

**Augment and Evaluate Design**

For the Evaluate Design and Augment Design platforms, the Factor Changes column property identifies factors with Changes specified as Hard or Very Hard. However, these platforms also require that the whole plot and subplot factors be entered as model effects in the launch windows. This is because the whole plot and subplot factors are part of the design structure.

**Custom Design**

The Custom Design platform enables you to create designs where all factor changes are Easy. You can also construct split-plot, split-split plot, or two-way split-plot (strip-plot) designs. When constructing these designs, you need to identify the factors whose values are hard-to-change or very-hard-to-change. In the Factors outline, you can identify factors as having Changes that are Easy, Hard, or Very Hard. When the Custom Design platform constructs the design table, the Factor Changes property is assigned to every factor that appears in the Factors outline.

The Custom Design platform is the only platform that constructs designs for factors with Changes that are Hard or Very Hard. Other DOE platforms also assign the Factor Changes column property to factors that they construct, but the value of the column property is set to Easy for their factors.

If you Load Factors in the Custom Design window using a table of factors, you can assign the Factor Changes column property to columns in that table. When you Load Factors using that table, your Factor Changes specifications appear in the Factors outline.

**Factor Changes Example**

The Battery Data jmp sample data table, found in the Design Experiment folder, contains data from an experiment that studies the open current voltage of batteries (OCV). The design is a two-way split-plot design. For further background, see “Two-Way Split-Plot Experiment”.

1. Select Help > Sample Data Library and open Design Experiment/Battery Data jmp.
2. Click the asterisk to the right of the factor C1 in the columns panel.
3. Select **Factor Changes**.

**Figure A.25** Factor Changes Panel for C1

![Factor Changes Panel](image)

The value of Factor Changes for C1 is Hard. **Figure A.24** shows that the value of Factor Changes for A1 is Very Hard.

4. Click **OK**.
5. In the data table, click the green triangle next to the **DOE Dialog** script.
6. Open the **Factors** outline.

**Figure A.26** Factors Outline for Battery Experiment

![Factors Outline](image)

The factors A1, A2, A3, and A4 have Changes set to Very Hard, and the factors C1 and C2 have Changes set to Hard. When the Custom Design platform constructs the design table, it saves these specifications to the appropriate columns as Factor Changes column properties.

In the Design outline, notice the Whole Plots and Subplots factors.
To account for the factor changes that are Hard and Very Hard, two factors are created by the Custom Design platform. The Whole Plots factor groups the runs where the Very Hard factor levels are constant and the Subplots factor groups the runs where the Hard factors levels are constant. These factors need to be included as model effects when you enter columns with the Factor Changes column property in the Evaluate Design and Augment Design platforms.

### Value Order

The Value Order column property assigns an order to the values in a column. That order is then used in plots and analyses. You can specify the order in which you want values to appear in reports.

**Note:** For certain values that have a natural ordering, such as days of the week, JMP automatically orders these in the appropriate way in reports. See *Using JMP*.

Figure A.28 shows the Value Order panel for the Type column in the *Car Physical Data.jmp* sample data table. Reports that involve the values of Type place these levels in the order Sporty, Small, Compact, Medium, and Large. Use the buttons to the right of the Value Order list to specify your desired ordering for the values.
In designs created using most DOE platforms, categorical factors, including the constructed factors Whole Plots and Subplots, and blocking factors are assigned the Value Order property. This property orders the levels according to the order in which they appear in the Factors outline. The levels of constructed factors are consecutive integers and the Value Order property specifies this natural ordering. You can modify the Value Order specification for any factor to meet your needs.

The Value Order property is not assigned by the Covering Array or Taguchi Arrays platforms. The Covering Array platform assigns the Value Labels column property. See “Value Labels”.
Value Order Example

Suppose that you want the values for a factor to appear in a different order in the Prediction Profiler. Consider an example of a wine tasting experiment, constructed using Custom Design. Wine is rated by five experts, each listed as a Rater in the Wine Data.jmp sample data table. Rater is a fixed blocking factor. Nine factors are studied. Rating is the response.

1. Select Help > Sample Data Library and open Design Experiment/Wine Data.jmp.
2. In the Table panel, click the green triangle next to the Reduced Model script.
3. Click Run.
   
   The Prediction Profiler appears at the bottom of the report.

Figure A.29  Profiler with Original Value Order

Notice that the values for De-Stem and Filtering appear in the order No followed by Yes. You want to reverse these, so that the Yes level appears first.

Tip: To arrange the profiler click the Prediction Profiler red triangle and select Appearance > Arrange in rows. For this example enter 7 and click OK.

5. In the data table, click the asterisk next to De-Stem in the columns panel and select Value Order.
6. Click Reverse.
7. Click OK.
8. Click the asterisk next to Filtering in the columns panel and select Value Order.
9. Click Reverse.
10. Click OK.
11. Again, click the green triangle next to the Reduced Model script.
12. Click **Run**.

**Figure A.30** Profiler with New Value Orders

![Profiler with New Value Orders](image)

The levels for De-Stem and Filtering now appear in the order Yes followed by No.

13. Close the Wine Data.jmp sample data table without saving the changes.

**Assigning Value Order**

Consider the Candy Bars.jmp sample data table. Of the 18 brands lists under Brand, Hershey and M&M/Mars have the largest numbers of types of candy as listed in the Name column. You want these two brands to appear first in reports.

1. Select **Help > Sample Data Library** and open Candy Bars.jmp.
2. Select the Brand column.
3. Select **Cols > Column Info.**
4. Under Column Properties, select Value Order.
5. In the Value Order list, select Hershey.
6. Click the **up arrow** five times.
   Hershey is now first in the Value Order list.
7. In the Value Order list, select M&M/Mars.
8. Click the **up arrow** seven times.
   M&M/Mars is now second in the Value Order list.
9. Click **OK**.
   An asterisk indicating the Value Order column property appears next to Brand in the columns panel. JMP now lists Hershey and M&M/Mars first in reports involving Brand.
10. Select **Analyze > Distribution.**
11. Select Calories and click **Y, Columns**.
12. Select Brand and click **By**.
13. Click **OK**.
14. Press Ctrl, click the Calories red triangle, and select **Display Options > Horizontal Layout**.
   Note that the Distribution reports for Hershey and M&M/Mars appear first among the 18 brands.
15. Close the Candy Bars.jmp sample data table without saving the changes.

---

**Value Labels**

The Value Labels column property represents values in a column with specified labels. These labels are displayed in the data table and are used in plots and reports. In the data table, you can view the original values by double-clicking within a cell. For more information about how to assign and work with the Value Labels column property, see *Using JMP*.

The Covering Arrays platform is the only DOE platform that assigns the Value Labels column property. The Covering Arrays platform saves factors to the data table with a Nominal modeling type. The underlying values are consecutive integers ranging from 1 to the number of levels that you specify in the Covering Array Factors outline. The Values that you specify in the Factors outline are the Value Labels that are assigned to the underlying integers.

**Value Labels Example**

You want to test an internet-based software application to detect issues arising from components in the operating environment. The four components of interest consist of a browser, the operating system, the computer’s RAM, and the connection speed. To minimize testing time, you restrict yourself to testing two-way interactions.

Construct a Strength 2 covering array to test the required combinations of factor levels.

1. Select **DOE > Special Purpose > Covering Array**.
2. Select **Help > Sample Data Library** and open Design Experiment/Software Factors.jmp.
3. Click the Covering Array red triangle and select **Load Factors**.
   The factors and their levels appear in the Factors outline.
Notice that the Role of the four factors is described as Categorical.

4. Click **Continue**.

The Restrict Factor Level Combinations outline opens. Since all combinations of settings are possible, leave this set to **None**.

5. Click **Make Design**.

6. Click **Make Table**.

7. In the columns panel, click the asterisk next to **Web Browser** and select **Value Labels**.

**Figure A.32 Column Info Window for Factor A**

Notice that **Web Browser** has a Numeric data type and a Nominal modeling type. The underlying values of **Web Browser** are the integers 1, 2, 3, 4, and 5. These values are assigned value labels corresponding to the values that you entered when you constructed the design.
Change the value label for 2 from IE to Internet Explorer.

8. Select $2 = \text{IE}$ in the Value Labels list.

![Value Labels Panel with Selection](image)

9. Type **Internet Explorer** next to Label.
10. Click **Change**.

    The change appears in the data table.

**Note:** To use the numeric values and not the labels, deselect **Use Value Labels**.

---

**RunsPerBlock**

When you use the DOE platforms to construct a design containing a blocking factor, the factor is assigned the Design Role column property with the value Blocking. JMP also assigns the RunsPerBlock column property to each Blocking factor. The RunsPerBlock property indicates the maximum allowable number of runs in each block. This property is used by the Evaluate Design and Augment Design platforms to indicate the blocking structure for the factor. See “Blocking”.

**Note:** The RunsPerBlock column property is assigned by JMP as part of design construction. You cannot directly assign this column property.

---

**RunsPerBlock Example**

Consider the wine tasting experiment described in “Example of a Custom Design”. Wine samples are tasted by five raters (**Rater**) and each rater tastes eight samples.

1. Select **Help > Sample Data Library** and open Design Experiment/Wine Data.jmp.
2. Click the asterisk next to Rater in the columns panel and select **Design Role**. Notice that the Design Role is set to Blocking.

3. Click **Cancel**.

4. Click the asterisk next to Rater in the columns panel and select **RunsPerBlock**.

**Figure A.34** RunsPerBlock Column Property Panel for Rater

Notice that the value of RunsPerBlock is 8. The design constructed by the DOE Dialog script has 40 runs. Since there are five raters, JMP constructs a design with 40/5 = 8 runs for each rater.

---

**ConstraintState**

In the Custom and Mixture Design platforms, you can Save Constraints that you specify for a design. When you select Save Constraints, the coefficients of each linear constraint appear in a column in a data table. The value that bounds the inequality is given in the last row of the table.

Each constraint column is assigned the ConstraintState column property. This property specifies the direction of the inequality that defines the constraint. When you select Load Constraints from a design platform, the ConstraintState column property tells JMP the direction of the inequality.

**Note:** The ConstraintState column property is assigned by JMP as part of design construction. You cannot directly assign this column property.
Appendix A
Design of Experiments Guide

ConstraintState Example

The sample data table Piepel.jmp, located in the Design Experiment folder, contains a mixture design with three continuous factors. The design is based on an experiment presented in Snee (1979) and Piepel (1988), where there are boundary constraints on each factor and three additional linear constraints. In this example, you do the following:

1. Change one of the three additional constraints
2. Save the constraints to a table
3. Observe how the ConstraintState column property describes the direction of the inequality in the constraint

For further development of this example, see “An Extreme Vertices Example with Linear Constraints”.

1. Select Help > Sample Data Library and open Design Experiment/Piepel.jmp.
2. In the Table panel, click the green triangle next to the DOE Dialog script.
   Notice the three linear constraints below the Factors outline. To make the constraints more interpretable, you want to reformulate the first constraint in terms of a “greater than or equal to” inequality.

![Figure A.35 Linear Constraints beneath Factors Outline](image)

3. In the first constraint, do the following:
   - Type 85 next to X1.
   - Type 90 next to X2.
   - Type 100 next to X3.
   - Select ≥ from the inequality menu.
   - Type 90 to the right of the inequality sign.
4. Click the Mixture Design red triangle and select Save Constraints.
   A table containing information about the constraints appears.
Each column contains the coefficients of the factors $X_1$, $X_2$, and $X_3$ in rows 1 through 3. Row 4 contains the value that appeared to the right of the inequality sign.

5. Click the asterisk next to Constraint 1.

6. Click **ConstraintState**.

**Figure A.36** Constraint Table

```
<table>
<thead>
<tr>
<th></th>
<th>Constraint 1</th>
<th>Constraint 2</th>
<th>Constraint 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>-85</td>
<td>85</td>
<td>-0.7</td>
</tr>
<tr>
<td>2</td>
<td>-90</td>
<td>90</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>-100</td>
<td>100</td>
<td>-1</td>
</tr>
<tr>
<td>4</td>
<td>-90</td>
<td>95</td>
<td>-0.4</td>
</tr>
</tbody>
</table>
```

7. Click **Cancel**.

**Figure A.37** ConstraintState Column Property Panel

The ConstraintState panel for $X_1$ indicates that the direction of the inequality is “greater than” indicating greater than or equal to $\geq$.

7. Click **Cancel**.
This appendix contains information on the Alias Matrix, power calculations and the Relative Prediction Variance.

- “The Alias Matrix”
- “Power Calculations”
- “Relative Prediction Variance”
## Contents

- The Alias Matrix ................................................................. 825
- Designs with Hard or Very Hard Factor Changes ................................ 825
- Designs with If Possible Effects .................................................. 826
- Power Calculations .................................................................. 826
- Power for a Single Parameter ....................................................... 826
- Power for a Categorical Effect ....................................................... 828
- Relative Prediction Variance ......................................................... 829
The Alias Matrix

The Alias Matrix entries represent the degree of bias imparted to model parameters by the effects that you specified in the Alias Terms outline. The Alias Matrix is also used in defining alias optimality. See “Alias Optimality”.

Calculations for the Alias Matrix are based on the model matrix. See “Model Matrix”.

Let \( X_1 \) be the model matrix corresponding to the terms in the Model outline. Denote the matrix of model terms for the effects specified in the Alias Terms outline by \( X_2 \).

The assumed model is given as follows:

\[
Y = X_1 \beta_1 + \varepsilon
\]

Suppose that some of the alias terms are active and that the true model is given as follows:

\[
Y = X_1 \beta_1 + X_2 \beta_2 + \varepsilon
\]

The least squares estimator of \( \beta_1 \) is given by:

\[
\hat{\beta}_1 = (X_1'X_1)^{-1}X_1'Y
\]

Under the usual regression assumptions, the expected value of \( \hat{\beta}_1 \) is given by:

\[
E[\hat{\beta}_1] = \beta_1 + A\beta_2
\]

where \( A = (X_1'X_1)^{-1}X_1'X_2 \).

The matrix \( A \) is called the alias matrix.

Designs with Hard or Very Hard Factor Changes

For designs with hard-to-change or very-hard-to-change factors, the alias matrix is given as follows:

\[
A = (X_1'V^{-1}X_1)^{-1}X_1'(V^{-1}X_2)
\]

where \( V \) is the block diagonal covariance matrix of the responses.
**Designs with If Possible Effects**

For designs with If Possible effects (Bayesian D- and I-optimal designs), the alias matrix is given as follows:

\[
A = (X_1'X_1 + K^2)^{-1}X_1'X_2
\]

where \(K\) is a diagonal matrix with these values:

- \(k = 0\) for Necessary terms
- \(k = 1\) for If Possible main effects, powers, and interactions involving a categorical factor with more than two levels
- \(k = 4\) for all other If Possible terms

In the Bayesian case, the alias matrix gives the aliasing of effects corresponding to a ridge regression with a prior variance of \(K^{-1}\). For additional detail on Bayesian designs, see “Bayesian D-Optimality” and “Bayesian I-Optimality”.

In the Custom Design platform, you can control the weights used for If Possible terms by selecting **Advanced Options > Prior Parameter Variance** from the red triangle menu. There you can set prior variances for all model terms by specifying the diagonal elements of \(K\). The option updates to show the default weights when you click Make Design.

---

**Power Calculations**

The Power Analysis report gives power calculations for single parameter values and, when the design includes a categorical factor with three or more levels, for whole effects. This section describes the calculations in the two cases:

- “Power for a Single Parameter”
- “Power for a Categorical Effect”

**Power for a Single Parameter**

This section describes how power for the test of a single parameter is computed. Use the following notation:

\(X\) The model matrix. See *Fitting Linear Models* for information on the coding for nominal effects. Also, See “Model Matrix”.

**Note:** You can view the model matrix by running Fit Model. Then select **Save Columns > Save Coding Table** from the red triangle menu for the main report.
\( \beta_i \)  The parameter corresponding to the term of interest.

\( \hat{\beta}_i \)  The least squares estimator of \( \beta_i \)

\( \beta_i^A \)  The Anticipated Coefficient value. The difference you want to detect is \( 2\beta_i^A \).

The variance of \( \hat{\beta}_i \) is given by the \( i \)th diagonal entry of \( \sigma^2(X'X)^{-1} \), where \( \sigma^2 \) is the error variance. Denote the \( i \)th diagonal entry of \( (X'X)^{-1} \) by \( (X'X)_{ii}^{-1} \).

The error variance, \( \sigma^2 \), is estimated by the MSE, and has \( n - p - 1 \) degrees of freedom, where \( n \) is the number of observations and \( p \) is the number of terms other than the intercept in the model. If \( n - p - 1 = 0 \), then JMP sets the degrees of freedom for the error to 1. This allows the power to be estimated for parameters in a saturated design.

The test of \( H_0: \beta_i = 0 \) is given by:

\[
\frac{\hat{\beta}_i}{\sqrt{\text{MSE}(X'X)_{ii}^{-1}}}
\]

or equivalently by:

\[
F_0 = \frac{\hat{\beta}_i^2}{\text{MSE}(X'X)_{ii}^{-1}}
\]

Under the null hypothesis, the test statistic \( F_0 \) has an \( F \) distribution on 1 and \( n - p - 1 \) degrees of freedom.

If the true value of \( \beta_i \) is \( \beta_i^A \), then \( F_0 \) has a noncentral \( F \) distribution with noncentrality parameter given by:

\[
\lambda = \frac{(\beta_i^A)^2}{\sigma^2(X'X)_{ii}^{-1}}
\]

To compute the power of the test, first solve for the \( \alpha \)-level critical value \( F_c \):

\[
\alpha = 1 - FDist(F_c, 1, n - p - 1)
\]

Then calculate the power as follows:

\[
\text{Power} = 1 - FDist(F_c, 1, n - p - 1, \lambda)
\]
Power for a Categorical Effect

This section describes how power for the test for a whole categorical effect is computed. Use the following notation:

\( X \) Model matrix. See “The Alias Matrix”.

\( \beta \) Vector of parameters.

\( \hat{\beta} \) Least squares estimate of \( \beta \).

\( \beta^A \) Vector of Anticipated Coefficient values.

\( L \) Matrix that defines the test for the categorical effect. The matrix \( L \) identifies the values of the parameters in \( \beta \) corresponding to the categorical effect and sets them equal to 0. The null hypothesis for the test of the categorical effect is given by:

\[ H_0: L\beta = 0 \]

\( r \) Rank of \( L \). Alternatively, \( r \) is the number of levels of the categorical effect minus one.

**Note:** You can view the design matrix by running Fit Model. Then select **Save Columns > Save Coding Table** from the red triangle menu for the main report.

The covariance matrix of \( \hat{\beta} \) is given by \( \sigma^2 (X'X)^{-1} \), where \( \sigma^2 \) is the error variance.

The error variance, \( \sigma^2 \), is estimated by the MSE, and has \( n - p - 1 \) degrees of freedom, where \( n \) is the number of observations and \( p \) is the number of terms other than the intercept in the model. If \( n - p - 1 = 0 \), then JMP sets the degrees of freedom for the error to 1. This allows the power to be estimated for parameters in a saturated design.

The test of \( H_0: L\beta = 0 \) is given by:

\[ F_0 = \left( (L\hat{\beta})'[L(X'X)^{-1}L']^{-1}(L\hat{\beta}) \right) / (rMSE) \]

Under the null hypothesis, the test statistic \( F_0 \) has an \( F \) distribution on \( r \) and \( n - p - 1 \) degrees of freedom.

If the true value of \( \beta \) is \( \beta^A \), then \( F_0 \) has a noncentral \( F \) distribution with noncentrality parameter given by:

\[ \lambda = \left( (L\beta^A)'[L(X'X)^{-1}L']^{-1}(L\beta^A) \right) / \sigma^2 \]
To compute the power of the test, first solve for the $\alpha$-level critical value $F_c$:

$$\alpha = 1 - FDist(F_c, r, n - p - 1)$$

Then calculate the power as follows:

$$Power = 1 - FDist(F_c, r, n - p - 1, \lambda)$$

---

**Relative Prediction Variance**

Consider the following notation:

- $X$ Model matrix. See “Model Matrix”. Custom designs provide a script that shows the model matrix. See “Save X Matrix”.
- $\sigma^2$ Error variance.
- $\hat{\beta}$ Vector of least squares estimates of the parameters.
- $x_i'$ The $i^{th}$ row of $X$.

Using this notation, the predicted response for the $i^{th}$ row of $X$ is given by:

$$\hat{Y} = x_i'\hat{\beta}$$

The relative prediction variance at the settings defined by $x_i$ is given by:

$$\frac{x_i'var(\hat{Y})x_i}{\sigma^2} = \frac{x_i'var(x_i'\hat{\beta})x_i}{\sigma^2} = x_i'(X'X)^{-1}x_i$$


References


Models.” Technometrics 16:391–408.

Spaces.” Technometrics 17:149–159.


Journal of Quality Technology 17:222–236.

and Robustness.” Quality Engineering 16:495–500.

Ridge National Laboratory.


Assess the Prediction Capability of Response Surface Designs.” Journal of Quality Technology 
35:377–386.

Adaptive Testing.” In Proceedings of the 2011 International Symposium on Software Testing and 
Analysis, 331–341.
Appendix D

Technology License Notices

- Scintilla is Copyright © 1998–2017 by Neil Hodgson <neilh@scintilla.org>. All Rights Reserved.

  Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation.

  NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

- Progress® Telerik® UI for WPF: Copyright © 2008-2019 Progress Software Corporation. All rights reserved. Usage of the included Progress® Telerik® UI for WPF outside of JMP is not permitted.

- ZLIB Compression Library is Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.

- Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.

- Packages is Copyright © 2009–2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
Technology License Notices

Appendix D

Design of Experiments Guide

(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

• iODBC software is Copyright © 1995–2006, OpenLink Software Inc and Ke Jin
  (www.iodbc.org). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

– Redistributions of source code must retain the above copyright notice, this list of
  conditions and the following disclaimer.

– Redistributions in binary form must reproduce the above copyright notice, this list of
  conditions and the following disclaimer in the documentation and/or other materials
  provided with the distribution.

– Neither the name of OpenLink Software Inc. nor the names of its contributors may be
  used to endorse or promote products derived from this software without specific prior
  written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.

• This program, “bzip2”, the associated library “libbzip2”, and all documentation, are
  Copyright © 1996–2019 Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
   conditions and the following disclaimer.

2. The origin of this software must not be misrepresented; you must not claim that you
   wrote the original software. If you use this software in a product, an acknowledgment in
   the product documentation would be appreciated but is not required.

3. Altered source versions must be plainly marked as such, and must not be
   misrepresented as being the original software.
4. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Julian Seward, jseward@acm.org

bzip2/libbzip2 version 1.0.8 of 13 July 2019

- MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.
- libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and / or other materials provided with the distribution.
- Neither the name of Florian Reuter nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar license but with different Copyright notices) all the files are:


Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

- Regarding the decompression algorithm used for UNIX files:


The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

- Snowball is Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS \"AS IS\" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- Pako is Copyright © 2014–2017 by Vitaly Puzrin and Andrei Tuputcyn.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the \“Software\”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

- HDF5 (Hierarchical Data Format 5) Software Library and Utilities are Copyright 2006–2015 by The HDF Group. NCSA HDF5 (Hierarchical Data Format 5) Software Library and Utilities Copyright 1998-2006 by the Board of Trustees of the University of Illinois. All rights reserved. DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF GROUP AND THE CONTRIBUTORS “AS IS” WITH NO WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED. In no event shall The HDF Group or the Contributors be liable for any damages suffered by the users arising out of the use of this software, even if advised of the possibility of such damage.


Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

- Neither the name of Adobe Systems Incorporated nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
• dmlc/xgboost is Copyright © 2019 SAS Institute.
Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

• libzip is Copyright © 1999–2019 Dieter Baron and Thomas Klausner.
This file is part of libzip, a library to manipulate ZIP archives. The authors can be contacted at <libzip@nih.at>.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. The names of the authors may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHORS \"AS IS\" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• OpenNLP 1.5.3, the pre-trained model (version 1.5 of en-parser-chunking.bin), and dmlc/xgboost Version .90 are licensed under the Apache License 2.0 are Copyright © January 2004 by Apache.org.

You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:
You must give any other recipients of the Work or Derivative Works a copy of this License; and

You must cause any modified files to carry prominent notices stating that You changed the files; and

You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

If the Work includes a “NOTICE” text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.

LLVM is Copyright © 2003–2019 by the University of Illinois at Urbana-Champaign. Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at:
http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

clang is Copyright © 2007–2019 by the University of Illinois at Urbana-Champaign. Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at:
http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF
ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

- lld is Copyright © 2011–2019 by the University of Illinois at Urbana-Champaign. Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

- libcurl is Copyright © 1996–2021, Daniel Stenberg, daniel@haxx.se, and many contributors, see the THANKS file. All rights reserved. Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, provided that the above copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.