imp

Statistical Discovery™ From SAS.

Version 16

Predictive and Specialized
Modeling

“The real voyage of discovery consists not in seeking new landscapes,
but in having new eyes.”

Marcel Proust

JMP, A Business Unit of SAS
SAS Campus Drive
Cary, NC 27513 16.1



The correct bibliographic citation for this manual is as follows: SAS Institute Inc. 2020-2021.
JMP® 16 Predictive and Specialized Modeling. Cary, NC: SAS Institute Inc.

JMP® 16 Predictive and Specialized Modeling
Copyright © 2020-2021, SAS Institute Inc., Cary, NC, USA
All rights reserved. Produced in the United States of America.

U.S. Government License Rights; Restricted Rights: The Software and its documentation is
commercial computer software developed at private expense and is provided with
RESTRICTED RIGHTS to the United States Government. Use, duplication or disclosure of the
Software by the United States Government is subject to the license terms of this Agreement
pursuant to, as applicable, FAR 12.212, DFAR 227.7202-1(a), DFAR 227.7202-3(a) and DFAR
227.7202-4 and, to the extent required under U.S. federal law, the minimum restricted rights as
set out in FAR 52.227-19 (DEC 2007). If FAR 52.227-19 is applicable, this provision serves as
notice under clause (c) thereof and no other notice is required to be affixed to the Software or
documentation. The Government'’s rights in Software and documentation shall be only those
set forth in this Agreement.

SAS Institute Inc., SAS Campus Drive, Cary, North Carolina 27513-2414.
March 2021
August 2021

SAS® and all other SAS Institute Inc. product or service names are registered trademarks or
trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.

SAS software may be provided with certain third-party software, including but not limited to
open-source software, which is licensed under its applicable third-party software license
agreement. For license information about third-party software distributed with SAS software,
refer to http://support.sas.com/thirdpartylicenses.


http://support.sas.com/thirdpartylicenses

Get the Most from JMP

Whether you are a first-time or a long-time user, there is always something to learn about
JMP.

Visit JMP.com to find the following:

live and recorded webcasts about how to get started with JMP

video demos and webcasts of new features and advanced techniques
details on registering for JMP training

schedules for seminars being held in your area

success stories showing how others use JMP

the JMP user community, resources for users including examples of add-ins and scripts,
a forum, blogs, conference information, and so on

https://www.jmp.com/getstarted



https://www.jmp.com/getstarted




Contents
Predictive and Specialized Modeling

1 LearnaboutJMP.... ... 17
Documentation and Additional Resources
Formatting Conventions in JMP Documentation ..................... ... .. ... .. ..... 19
JIMP Help oo 20
JMP Documentation Library .............. . i 20
Additional Resources for Learning JMP ...... ... ... ... i 26
JMP Tutorials .. ... 26
Sample Data Tables ........ ... i 26
Learn about Statistical and JSL Terms ..........c.ooiiiiiiiiir ittt en.. 27
Learn JMP Tips and Tricks ......... ..o 27
JMP TOOIPS ..o 27
JMP User Community ......... ... 28
Free Online Statistical Thinking Course ............ ... ... o i ... 28
JMP New User Welcome Kit . ... .. . i i 28
Statistics Knowledge Portal ......... ... . .. 28
JMP Training .. ... 28
JMP Books by USers . ... 29
The JMP Starter Window . ... i e e e 29
JMP Technical SUPPOTt . ... 29
2 Introduction to Predictive and Specialized Modeling ...................... 31
Overview of Modeling Techniques
3 Neural Networks ... 33
Fit Nonlinear Models Using Nodes and Layers
Overview of the Neural Platform ......... ... . e 35
Launch the Neural Platform . .......... oo e 35
The Neural Launch Window ... ... e 36
The Model Launch Control Panel ...........c.coo et 37
Validation Methods for Neural ......... ..o 38
Hidden Layer Structure .......... ... ... .. . . 39
Boosting ... 40

Fitting Options . ... .. 41



6 Contents Predictive and Specialized Modeling

Model Reports ... ... 43
Training and Validation Measuresof Fit .............. ... ... .. ... .. ... ..., 43
Confusion Statistics . ......... ... 44

Neural Platform Options ....... ... ... e 44
Neural Model Options ............ i 45

Example of a Neural Network ........ .. ... .. . 46

4 PartitionModels ... 49

Use Decision Trees to Explore and Model Your Data

Overview of the Partition Platform .......... ... ... ... ... .. .. . .. 51

Example of the Partition Platform ......... ... ... ... ... . 51

Launch the Partition Platform ........... ... ... ... . . 54

The Partition Report ........ ... 55
Control Buttons ........ ... 55
Report for Categorical Responses ............ ... ... . .. .. ... i 56
Report for Continuous Responses ........... .. ... . i 58

Partition Platform Options ......... ... .. 61
Show Fit Details ........ ... i 64
Specify Profit Matrix ........ ... 65
Decision Matrix Report ........ ... 67
Informative Missing ............ ... .. . 68
Actual by Predicted Plot ... ... .. 69
ROC CUIVe .. 70
Lift CUTVe ... 71
Node Options . ... 72

Validation in Partition .......... . ... 73

Additional Examples of Partitioning ............ .. ... ... ... ... 74
Example of a Continuous Response .......... ... ... ... i 74
Example of Informative Missing ........... ... . ... i 77
Example of Profit Matrix and Decision Matrix Report .............................. 80

Statistical Details for the Partition Platform .............. ... ... .. ... o i 83
Responses and Factors ............. ... i 83
Splitting Criterion ......... ... . .. 84
Predicted Probabilities in Decision Tree and Bootstrap Forest ....................... 84

5 BootstrapForest........................ 87

Fit a Model By Averaging Many Trees

Overview of the Bootstrap Forest Platform ........... ... ... .. ... ... ... ... ... 89

Example of Bootstrap Forest with a Categorical Response ............................. 90
Bootstrap Forest Model ....... ... ... 90

Missing Values ...... ... .. 92



Predictive and Specialized Modeling Contents 7

Example of Bootstrap Forest with a Continuous Response ............................. 93
Launch the Bootstrap Forest Platform .......... ... ... ... . .. i i 95
Launch Window . ... ... 95
Specification Window ....... ... .. 97
The Bootstrap Forest Report ............ .. i 99
Model Validation-Set Summaries ............. ... ... . i 100
SPeCifications ... ... ...ttt 100
Overall Statistics ....... ... 100
Cumulative Validation ............ .. . . . 102
Per-Tree SUMMATIies . ..........oiiiuiiii i i 103
Bootstrap Forest Platform Options .......... ... ... . i i 104
6 BoostedTree ... 107
Fit Many Layers of Trees, Each Based on the Previous Layer
Overview of the Boosted Tree Platform .......... ... ... ... ... ... . o ... 109
Example of Boosted Tree with a Categorical Response ............................... 109
Example of Boosted Tree with a Continuous Response ............................... 111
Launch the Boosted Tree Platform ........... ... ... ... ... . i i 113
Specification Window ....... ... . . 115
The Boosted Tree Report ....... ... ... 117
Model Validation - Set Summaries ............ ... ... i i 118
Specifications . ............ . i 119
Overall Statistics ....... ... 119
Cumulative Validation ............ ... 120
Boosted Tree Platform Options ........... ... i, 121
Statistical Details for the Boosted Tree Platform .............. ... ... ... ... ... ... ... 123
Overfit Penalty . ... . 123
7 KNearestNeighbors ... 125
Predict Response Values Using Nearby Observations
Overview of the K Nearest Neighbors Platform ........... ... ... ... ... ... .. ... 127
Example of K Nearest Neighbors with Categorical Response .......................... 128
Example of K Nearest Neighbors with Continuous Response ......................... 130
Launch the K Nearest Neighbors Platform ........... ... ... ... ... ... ... .. ... 132
The K Nearest Neighbors Report .......... ... .. i, 134
Continuous Responses ............ .. .. 134
Categorical ReSponses . ....... ... ..ot 135
K Nearest Neighbors Platform Options .......... ... ... . i i ... 136

Model Fit Options ...... ... ... 136



8 Contents Predictive and Specialized Modeling

8 Naive Bayes. ..., 139
Classify Observations Using Probabilistic Assumptions
Overview of the Naive Bayes Platform ........... ... ... ... .. i .. 141
Example of Naive Bayes .......... ... 142
Launch the Naive Bayes Platform ........... ... ... ... . i, 144
The Naive Bayes Report ........... . 145
Fit Details Report ...... ... 146
Response Column Report ...... ... .. 146
Confusion Matrix Report ........ ... i 146
ROC CUIVES ... 146
Naive Bayes Platform Options ............ .. ... i, 147
Additional Example of Naive Bayes ........... .. ... i 148
Statistical Details for the Naive Bayes Platform .............. ... ... ... .. ... .. ... 149
Algorithm .. ... 149
Saved Probability Formulas ............ .. ... . 151
9 Support VectorMachines.......................................... 153
Predict Response Categories Using Support Vectors
Overview of Support Vector Machines ........... ... ... . ... . il 155
Example of Support Vector Machines .......... ... .. ... ... ... ... 155
Launch the Support Vector Machines Platform ........... ... ... ... ... ... ... ... 157
The Support Vector Machines Launch Window ............... ... .. ... ... . .. 158
Model Launch Control Panel ............ ... ... . i 159
The Support Vector Machine Report ......... ... ... ... . . 162
Model Comparison Report .......... ... . 162
Support Vector Machine Model Report .............. .. .. .. ... ... ... 163
Support Vector Machines Platform Options .......... ... ... ... ..o o ... 165
Support Vector Machine Model Report Options ............. ... .. ... oi.s. 166
Additional Example of the SVM Platform .............. .. .. .. .. ... ... ... ... 168
Example of Support Vector Regression for Continuous Response .................... 168
10 Model Screening.................................. 171
Fit and Compare Multiple Prediction Models
Example of Model Screening for Continuous Response .............................. 173
Launch the Model Screening Platform .......... ... ... ... ... .. .. .. .. ... ..., 175
The Model Screening Report ........ ... 178
Summary Across the Folds Report ....... ... ... ... . . 179
Training, Validation, and Test Measures of Fit ............. ... ... ... ... ... ... 180
Model Screening Platform Options ............ .. ... i 181

Decision Thresholds Report ......... ... e 184



Predictive and Specialized Modeling Contents

11 Model Comparison ...................

Compare the Predictive Ability of Fitted Models

Example of Model Comparison ................iiuuiiiiiiiiiiiiiiiiii .
Launch the Model Comparison Platform ............ ... ... .. ... . . i,
The Model Comparison Report ......... ... ... i
Model Comparison Platform Options ............ ... ... i,
Continuous and Categorical Responses ............. ... ... .. ... . i i
Continuous Responses . ...... ...
Categorical ReSpONnSes .. ... ...t
Additional Example of Model Comparison .............. ..o oo,

12 Make Validation Column ......................... ..

Divide Data into Training, Validation, and Test Sets

Overview of the Make Validation Column Platform ............... ... ... ... ... ...
Example of Make Validation Column ........... ... ... ... .. . i i
Launch the Make Validation Column Platform .............. ... ... ... ... ... ...,
Make Validation Column Report ......... ... .. ... ... ... . .. .. . i
Specify Rates or Relative Rates ........... ... ... . .. . . i
Set CUtpoints . ... ... ..
OPtONS ..

Make Validation Column Platform Options ................ .. ... . .o ..
Additional Example of the Make Validation Column Platform ........................

13 FormulaDepot ...

Manage Models and Generate Scoring Code

Overview of the Formula Depot Platform ........ ... ... ... ... ... ... ... ... ...
Example of Formula Depot ... ... .
Launch the Formula Depot Platform ......... .. ... ... ... .. ... ... ... ...,
Platforms That Publish Prediction Formulas to the Formula Depot ..................
Formula Depot Platform Options .............. .o i,
Formula Depot Model Options ............ .. .. .. .. ... i
Generating Scoring Code from the Formula Depot Platform ..........................

14 Fit CUINVe

Fit Built-In Nonlinear Models to Your Data

Overview of the Fit Curve Platform ........ ... .. i e,
Example Using the Fit Curve Platform ............ ... ... . ... . i,
Launch the Fit Curve Platform ........ ... . i e
The Fit Curve Report ... ... .
Fit Curve Options . ... i



10 Contents Predictive and Specialized Modeling

Model Comparison Report .......... .. i 229
Model Fit Report ... 231
Model Fit Options . ... 231

Test Parallelism . ....... .. 233

Compare Parameter Estimates ............ ... ... . . . i 236

Equivalence Test ... ... ... 237
Statistical Details for the Fit Curve Platform .......... ... ... ... ... ... .. o ... 238

Model Formulas ...... ... 238

15 Nonlinear Regression................................................. 245
Fit Custom Nonlinear Models to Your Data
Example of Fitting a Custom Model ........ ... .. .. ... ... ... 247
Launch the Nonlinear Platform ......... ... ... ... . . . 250
The Nonlinear Fit Report ......... ... 251
Nonlinear Platform Options ............ ... .. .. . . 255
Create a Formula Using the Model Library ........... ... ... ... ... ... .o ... 259

Customize the Nonlinear Model Library ............ ... ... . .o ... 261
Additional Examples ...... ... .. 262

Example of Maximum Likelihood: Logistic Regression ............................ 263

Example of a Probit Model with Binomial Errors: Numerical Derivatives ........... 264

Example of a Poisson Loss Function .............. ... ... ... ... . o 265

Example of Setting Parameter Limits ............. ... ... ... ... . ... 267
Statistical Details for the Nonlinear Platform ............ ... ... .. ... .. ... .. ..., 270

Profile Likelihood Confidence Limits ............. ... ... ... ... . oo, 271

How Custom Loss Functions Work ......... ... ... ... . . .. 272

Notes Concerning Derivatives ............. ... . .. i 273

Notes on Effective Nonlinear Modeling ............... ... ... ... ... .. ... 274

16 Functional DataExplorer................................ ... 277
Perform Functional Data Analysis
Overview of the Functional Data Explorer Platform .................................. 279
Example of Functional Data Explorer .......... .. ... . .. i i 280
Launch the Functional Data Explorer Platform ............... .. .. .. ... ... . ..., 283
The Functional Data Explorer Report ........ ... ... ... ... ... i .. 286

Model Reports .. ... 287
Functional Data Explorer Platform Options .................. .. .. .. .. ... .. ... 292

Functional Data Explorer Group Options ............. ... ... ... o ... 293

Data Processing Report Options ............ ... i, 294

Model Report Options ........ ... ... i 297
Additional Examples of the Functional Data Explorer Platform ....................... 298

Example for Multiple Functional Processes ........... ... ..., 299



Predictive and Specialized Modeling Contents 11

Example of Functional DOE . ... .. ... . . 303
Statistical Details for the Functional Data Explorer Platform .......................... 305
Functional Model Fits ....... ... .. 306
Function Summaries Details ............ .. .. .. 307
17 Gaussian Process..................................... 309
Fit Data Using Smoothing Models
Example of Gaussian Process ............ ... 311
Launch the Gaussian Process Platform ........... ... ... ... ... ... oo i 313
The Gaussian Process Report ......... .. .. 314
Actual by Predicted Plot ........ ... ... 314
Model Report ... ... 314
Marginal Model Plots ........ ... .. 315
Gaussian Process Platform Options .......... ... ... .. i i 315
Additional Examples of the Gaussian Process Platform ............................... 316
Example of a Gaussian Process Model ........ ... ... ... ... .. il 317
Example of Gaussian Process Model with Categorical Predictors ................... 318
Statistical Details for the Gaussian Process Platform .................. ... ... ... ... 320
Models with Continuous Predictors .......... ... ... ... ... . i i, 320
Models with Categorical Predictors ............. ... ... ... . it 321
Variance Formula Parameterization ............ ... ... . ... . ... i, 322
Model Fit Details ......... ..o 322
18 Time Series Analysis............................... ... 323
Fit Time Series Models and Transfer Functions
Overview of the Time Series Platform ........ ... ... ... ... . . i ... 325
Example of the Time Series Platform ........... .. ... ... ... .. .. .. .. .. ... 326
Launch the Time Series Platform .......... .. ... ... . .. . . i i 328
The Time Series Analysis Report .......... ... . . i i 330
Time Series Graph ....... ... ... .. . 330
Time Series Basic Diagnostics Chart .......... ... ... ... ... ... . oL 331
Time Series Platform Options .............. i 333
Time Series Diagnostics ............. ... ... . 333
Differencing and Decomposition ............. ... ... i 334
ARIMA and Seasonal ARIMA Models ............ ... ... i i, 337
Smoothing Models ........ ... ... . . . . 338
State Space Smoothing Models ......... .. ... ... . . 339
Transfer Function Models ....... .. .. 340
Smoothing Model Specification Windows .......................... .. .. L 343
RepOTts ..o 345

Difference Report ........ ..o i 345



12 Contents Predictive and Specialized Modeling

Decomposition Reports ....... ... 346
Model Comparison Report ........ ... . 348
ARIMA and Seasonal ARIMA Model Report .......... ... ... ... ... ... ... 351
State Space Smoothing Report .......... ... .. . . i 355
Transfer Function Report ...... ... .. .. 357
Spectral Density Report ... ... ... 359
Additional Examples of the Time Series Platform ......... ... ... ... ... ... ....... 360
Example of Creating Time ID Column .............. ... ... . ... ... 360
Example Using Box-Cox Transformation ............. ... ... ... ... . .o... 365
Example Using a Holdback Set ........ .. ... ... . i 367
Statistical Details for the Time Series Platform ............ ... ... ... ... ... ... ... 369
Statistical Details for Spectral Density ............ ... ... ... . il 369
Statistical Details for X-11 Decomposition ............. ... ..., 370
Statistical Details for Exponential Smoothing Models ............................. 370
Statistical Details for ARIMA Models ......... ... ... ... . i ... 374
Statistical Details for Transfer Functions ................... .. .. ... ..o ... 376
19 Time SeriesForecast ... 377
Forecast Multiple Time Series
Example of Time Series Forecast ........... ... ... . i 379
Launch the Time Series Forecast Platform ............ ... ... ... ... ... ... .. ... 381
DataFormat ........ . 381
The Time Series Forecast Report .......... ... .. . i i 383
Analysis of Time Pattern .......... ... .. .. .. ... ... 383
Group Summary of Time ........ .. 383
Group Summary of Y ... . 384
Modeling Specifications ............ ... .. .. 384
Time Series Forecast Platform Options ........... ... ... .. 387
Model RePorts .. ... 389
20 Matched Pairs Analysis.................................... 391
Compare Measurements on the Same Subject
Overview of the Matched Pairs Platform ............. ... ... ... ... ... ... .. ... 393
Example of Comparing Matched Pairs .......... ... ... ... ... .. .. L. 393
Launch the Matched Pairs Platform ........... ... ... ... .. ... o i 395
Multiple Y Columns ... ... . 395
The Matched Pairs Report ........... .. 396
Difference Plot and Report ....... ... .. i 397
ACTOSS GIOUPS .ottt 397
Matched Pairs Platform Options .......... .. ... . .. i 398

Example Comparing Matched Pairs across Groups ............... ..., 399



Predictive and Specialized Modeling Contents

Statistical Details for the Matched Pairs Platform ............ ... ... ... ... .. ...
Graphics for Matched Pairs .......... ... ... i
Correlation of Responses ......... ... ..

21 Modeling Utilities............................... ..

Exploring Data for Outliers, Missing Values, and Patterns

Explore Outliers Utility ........ ... ..
Example of the Explore Outliers Utility ............... .. ... . ... ... o ..
Launch the Explore Outliers Utility ........... ... .. ... ... ... ... ...,
Quantile Range Outliers ........... .. ...
Robust Fit Outliers ......... ... .
Robust PCA Outliers .......... .. i e
K Nearest Neighbor Outliers ......... ... ... . .. . .
Explore Outliers Utility Options ............ .. . . i
Additional Examples of the Explore Outliers Utility ..............................

Explore Missing Values Utility ......... ... ... .. i
Example of the Explore Missing Values Utility ...................................
The Missing Value Report .......... ... .. .. .. ... ... .. i
Explore Missing Values Utility Options ........... ... ... ... o ...

Explore Patterns Utility .......... ...
Example of the Explore Patterns Utility ............... ... ... .. .. .. .......
Launch the Explore Patterns Utility .......... ... ... ... ... . ...
Explore Patterns Report ............ ..
Explore Patterns Utility Options ........ ... .. ... .. ... ... ... o ..
Additional Example of the Explore Patterns Utility ...............................
Statistical Details for the Explore Patterns Utility .............. ... .. ... ... ... ...

22 Response SCreening.......................coooiiiii

Test Many Responses in Large-Scale Data

Overview of the Response Screening Platform ................ .. .. .. .. ... ... ...
Example of Response Screening .............. .. .. i
Launch the Response Screening Platform ........ ... ... ... ... ... .. ...
The Response Screening Report .......... ... .. .. ... .. ... ... i
Result Table ........ ..
FDRPValue Plot ... ... .
FDR LogWorth by Effect Size .......... .. .. .. .. .. ... ... ... L
FDR LogWorth by RSquare .......... ... . .. i,
The PValues DataTable ......... ... ...
PValues Data Table Scripts .......... .. .. .. .. ..
Response Screening Platform Options ........... ... ... ... i i i
Means Data Table .......... ... .

13



14 Contents Predictive and Specialized Modeling

Compare Means DataTable .......... ... ... . . i i i 464
The Response Screening Personality in Fit Model ............ ... ... ... .. ... .. ... 466
Launch Response Screening in Fit Model ......... ... ... ... ... ... ... ... ... 467
The Fit Response Screening Report ........... ... ... . i i 468
Fit Response Screening Options ............ ... 469
PValues Data Table ......... ... . . 470
YFitsDataTable .......... . . 471
Additional Examples of Response Screening ................ ..., 472
Example of Tests of Practical Significance and Equivalence ........................ 472
Example of the MaxLogWorth Option ........ ... ... ... ... . ... 474
Example of Robust Fit ........ .. . 475
Response Screening Personality .......... ... ... ... i 478
Statistical Details for the Response Screening Platform ............................... 479
The False Discovery Rate .......... ... .. i 479
23 Process SCreening....................coooi i 481
Screen Many Processes for Stability and Capability
Overview of the Process Screening Platform ................. .. .. .. ... ... . ..., 483
Example of Process Screening ........... ... ... i 483
Launch the Process Screening Platform ............ ... ... ... ... . i i 486
Launch Window Roles ........ ... . . 486
Launch Window Options .......... ... i e 487
Limits Table . ....... o 489
The Process Screening Report ........... ... .. ... . 491
Process Screening Platform Options ......... ... ... ... . i i 497
Process Performance Graph ......... ... ... i 502
Additional Example of Process Screening .................. .. .. .. . oL 504
Statistical Details for the Process Screening Platform .......... ... ... ... ... ....... 506
Scaling Factors for Using Medians to Estimate Sigma .............................. 506
24 PredictorScreening.......................... 509
Screen Many Predictors for Significant Effects
Overview of the Predictor Screening Platform ................ .. .. .. .. .. ... ..., 511
Example of Predictor Screening ............ ... . .. i 511
Launch the Predictor Screening Platform ........ ... ... ... ... ... .. .. 513
The Predictor Screening Report ......... ... .. ... ... ... 514
Predictor Screening Platform Options ........... ... ... . .. i i i 514
25 Association Analysis ... 515

Perform Market Basket Analysis

Overview of the Association Analysis Platform ........... ... ... ... ... ... ... ... 517



Predictive and Specialized Modeling Contents 15

Example of the Association Analysis Platform ............ ... ... ... ... ... ... ... 518
Launch the Association Analysis Platform .............. ... .. ... . .o i 520
DataFormat ... 521
The Association Analysis Report .......... ... .. .. i i i 522
Frequent Item Sets ......... ... . 522
Rules ..o 522
Association Analysis Platform Options .......... ... ... .. i i 523
Singular Value Decomposition ................. i 524
SVD Report ... 525
SVD Report Options ....... ...t 526
Topic Analysis ...... ... i 527
Topic Analysis Report ......... .. 527
Topic Analysis Report Options ........ ... 528
Additional Example: SVD Analysis .............oiiiiiiiiii 529
Statistical Details for the Association Analysis Platform .............................. 531
Frequent Item Set Generation ............... .. . i i 531
Association Analysis Performance Measures .................. ..., 532
26 Process History Explorer ... ... 535
Identify Problem Components in Complex Process Histories
Example of Process History Explorer ............. ... ... ... ... . .. .. .. .. ... 537
Launch the Process History Explorer Platform ............ ... ... ... ... ... ... .... 539
DataFormat .......... . 540
The Process History Explorer Report ........ ... ... ... ... . .. .. .. ... ... ....... 540
Process History Explorer Platform Options ........... ... ... ... .. iiiiiiii... 541
A StatisticalDetails.................................... 545
Predictive and Specialized Modeling
Measures of Fit ... ... . . 547
Entropy RSquare ... ... 547
Validation in JMP Modeling .......... ... .. 547
Validation Column Role ........ ... ..o i 548
K-Fold and Holdback Validation ............. ... ... ... ... .. i, 550
B References......................... 553

C Technology LicenseNotices ..................................................... 557



16 Contents Predictive and Specialized Modeling



Chapter 1

Learn about JMP

Documentation and Additional Resources

Learn about JMP documentation, such as book conventions, descriptions of each JMP
document, the Help system, and where to find additional support.
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Predictive and Specialized Modeling Formatting Conventions in JMP Documentation

Formatting Conventions in JMP Documentation

These conventions help you relate written material to information that you see on your screen:

Sample data table names, column names, pathnames, filenames, file extensions, and
folders appear in Helvetica (or sans-serif online) font.

Code appears in Lucida Sans Typewriter (or monospace online) font.

Code output appears in Lucida Sans Typewriter italic (or monospace italic online) font
and is indented farther than the preceding code.

Helvetica bold formatting (or bold sans-serif online) indicates items that you select to
complete a task:

— buttons

— check boxes

— commands

— list names that are selectable

- menus

— options

— tab names

— text boxes

The following items appear in italics:
— words or phrases that are important or have definitions specific to JMP
— book titles

— variables

Features that are for JMP Pro only are noted with the JMP Pro icon i’NII!PO . For an overview
of JMP Pro features, visit https://www.jmp.com/software/pro.

Note: Special information and limitations appear within a Note.

Tip: Helpful information appears within a Tip.


https://www.jmp.com/software/pro
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JMP Help

JMP Help in the Help menu enables you to search for information about JMP features,
statistical methods, and the JMP Scripting Language (or JSL). You can open JMP Help in
several ways:

e Search and view JMP Help on Windows by selecting Help > JMP Help.
* On Windows, press the F1 key to open the Help system in the default browser.

* Get help on a specific part of a data table or report window. Select the Help tool % from
the Tools menu and then click anywhere in a data table or report window to see the Help
for that area.

¢ Within a JMP window, click the Help button.

Note: The J]MP Help is available for users with Internet connections. Users without an Internet
connection can search all books in a PDF file by selecting Help > JMP Documentation Library.
See “JMP Documentation Library” for more information.

JMP Documentation Library

The Help system content is also available in one PDF file called JMP Documentation Library.
Select Help > JMP Documentation Library to open the file. You can also download the
Documentation PDF Files add-in if you prefer searching individual PDF files of each
document in the JMP library. Download the available add-ins from
https://community.jmp.com.

The following table describes the purpose and content of each document in the JMP library.

Document Title Document Purpose Document Content

Discovering JMP If you are not familiar ~ Introduces you to JMP and gets you
with JMP, start here. started creating and analyzing data. Also

learn how to share your results.

Using IMP Learn about JMP data  Covers general JMP concepts and
tables and how to features that span across all of JMP,
perform basic including importing data, modifying
operations. columns properties, sorting data, and

connecting to SAS.


https://jmp.com/doc-addin
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Predictive and Specialized Modeling JMP Documentation Library
Document Title Document Purpose Document Content
Basic Analysis Perform basic analysis ~ Describes these Analyze menu platforms:

using this document. e Distribution

e FitYbyX

¢ Tabulate

* Text Explorer

Covers how to perform bivariate,
one-way ANOVA, and contingency
analyses through Analyze > Fit Y by X.
How to approximate sampling
distributions using bootstrapping and
how to perform parametric resampling

with the Simulate platform are also
included.

Essential Graphing Find the ideal graph Describes these Graph menu platforms:
for your data. e Graph Builder
¢ Scatterplot 3D
¢ Contour Plot
¢ Bubble Plot
¢ Parallel Plot
¢ Cell Plot
® Scatterplot Matrix
¢ Ternary Plot
¢ Treemap
¢ Chart
e Overlay Plot

The book also covers how to create
background and custom maps.

Profilers Learn how to use Covers all profilers listed in the Graph
interactive profiling menu. Analyzing noise factors is
tools, which enableyou included along with running simulations
to view cross-sections using random inputs.
of any response
surface.
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JMP Documentation Library Predictive and Specialized Modeling
Document Title Document Purpose Document Content
Design of Learn how to design Covers all topics in the DOE menu.
Experiments Guide experiments and

determine appropriate
sample sizes.

Fitting Linear Models Learn about Fit Model =~ Describes these personalities, all
platform and many of  available within the Analyze menu Fit
its personalities. Model platform:

e Standard Least Squares
* Stepwise

* Generalized Regression
* Mixed Model

¢ MANOVA

¢ Loglinear Variance

¢ Nominal Logistic

* Ordinal Logistic

e Generalized Linear Model
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Document Title

Predictive and

Document Purpose

Learn about additional
Specialized Modeling ~ modeling techniques.

Learn about JMP
JMP Documentation Library

Document Content

Describes these Analyze > Predictive
Modeling menu platforms:

Neural

Partition

Bootstrap Forest

Boosted Tree

K Nearest Neighbors
Naive Bayes

Support Vector Machines
Model Comparison
Model Screening

Make Validation Column

Formula Depot

Describes these Analyze > Specialized
Modeling menu platforms:

Fit Curve

Nonlinear

Functional Data Explorer
Gaussian Process

Time Series

Matched Pairs

Describes these Analyze > Screening
menu platforms:

Modeling Utilities
Response Screening
Process Screening
Predictor Screening
Association Analysis

Process History Explorer

23
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Document Title Document Purpose

Multivariate Read about techniques

Methods for analyzing several
variables
simultaneously.

Quality and Process ~ Read about tools for
Methods evaluating and
improving processes.

Chapter 1
Predictive and Specialized Modeling

Document Content

Describes these Analyze > Multivariate
Methods menu platforms:

Multivariate

Principal Components
Discriminant

Partial Least Squares

Multiple Correspondence Analysis
Structural Equation Models

Factor Analysis

Multidimensional Scaling

Item Analysis

Describes these Analyze > Clustering
menu platforms:

Hierarchical Cluster
K Means Cluster
Normal Mixtures
Latent Class Analysis

Cluster Variables

Describes these Analyze > Quality and
Process menu platforms:

Control Chart Builder and individual
control charts

Measurement Systems Analysis
Variability / Attribute Gauge Charts
Process Capability

Model Driven Multivariate Control
Chart

Legacy Control Charts
Pareto Plot

Diagram

Manage Spec Limits
OC Curves
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Document Title

Reliability and
Survival Methods

Consumer Research

Scripting Guide

JSL Syntax Reference

Document Purpose

Learn to evaluate and
improve reliability in a
product or system and
analyze survival data
for people and
products.

Learn about methods
for studying consumer
preferences and using
that insight to create
better products and
services.

Learn about taking
advantage of the
powerful JMP
Scripting Language
(JSL).

Read about many JSL
functions on functions
and their arguments,
and messages that you
send to objects and
display boxes.

Learn about JMP 25
JMP Documentation Library

Document Content

Describes these Analyze > Reliability and
Survival menu platforms:

Life Distribution
e FitLifeby X
¢ Cumulative Damage
® Recurrence Analysis
* Degradation
® Destructive Degradation
* Reliability Forecast
* Reliability Growth
* Reliability Block Diagram
* Repairable Systems Simulation
* Survival
e Fit Parametric Survival

¢ Fit Proportional Hazards

Describes these Analyze > Consumer
Research menu platforms:

e Categorical

e Choice
e  MaxDiff
e Uplift

* Multiple Factor Analysis

Covers a variety of topics, such as writing
and debugging scripts, manipulating
data tables, constructing display boxes,
and creating JMP applications.

Includes syntax, examples, and notes for
JSL commands.
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Additional Resources for Learning JMP

In addition to reading JMP help, you can also learn about JMP using the following resources:

e “JMP Tutorials”

e “Sample Data Tables”

e “Learn about Statistical and JSL Terms”
e “Learn JMP Tips and Tricks”

e “JMP Tooltips”

e “JMP User Community”

* “Free Online Statistical Thinking Course”
e  “JMP New User Welcome Kit”

* “Statistics Knowledge Portal”

e “JMP Training”

e “JMP Books by Users”

e “The JMP Starter Window”

JMP Tutorials

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu
is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, start with the Beginners Tutorial. It steps you through the
JMP interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment
and comparing a sample mean to a constant.

Sample Data Tables

All of the examples in the JMP documentation suite use sample data. Select Help > Sample
Data Library to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories,
select Help > Sample Data.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\UMP\16\Samples\Data
On macQOS: \Library\Application Support\dJMP\16\Samples\Data
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In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

To view examples using sample data, select Help > Sample Data and navigate to the Teaching
Resources section. To learn more about the teaching resources, visit https://jmp.com/tools.

Learn about Statistical and JSL Terms

For help with statistical terms, select Help > Statistics Index. For help with JSL scripting and
examples, select Help > Scripting Index.

Statistics Index Provides definitions of statistical terms.

Scripting Index Lets you search for information about JSL functions, objects, and display
boxes. You can also edit and run sample scripts from the Scripting Index and get help on
the commands.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for
using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select
Help > Tip of the Day. Or, you can turn it off using the Preferences window.

JMP Tooltips

JMP provides descriptive tooltips (or hover labels) when you hover over items, such as the
following:

® Menu or toolbar options

* Labels in graphs

* Text results in the report window (move your cursor in a circle to reveal)
¢ Files or windows in the Home Window

* Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences >
General and then deselect Show menu tips. This option is not available on macOS.


https://jmp.com/tools
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JMP User Community

The JMP User Community provides a range of options to help you learn more about J]MP and
connect with other JMP users. The learning library of one-page guides, tutorials, and demos is
a good place to start. And you can continue your education by registering for a variety of JMP
training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts,
and social networking groups.

To access JMP resources on the website, select Help > JMP User Community or visit
https://community.jmp.com.

Free Online Statistical Thinking Course

Learn practical statistical skills in this free online course on topics such as exploratory data
analysis, quality methods, and correlation and regression. The course consists of short videos,
demonstrations, exercises, and more. Visit https://www jmp.com/statisticalthinking.

JMP New User Welcome Kit

The JMP New User Welcome Kit is designed to help you quickly get comfortable with the
basics of JMP. You'll complete its thirty short demo videos and activities, build your
confidence in using the software, and connect with the largest online community of JMP users
in the world. Visit https://www.jmp.com/welcome.

Statistics Knowledge Portal

The Statistics Knowledge Portal combines concise statistical explanations with illuminating
examples and graphics to help visitors establish a firm foundation upon which to build
statistical skills. Visit https://www.jmp.com/skp.

JMP Training

SAS offers training on a variety of topics led by a seasoned team of JMP experts. Public
courses, live web courses, and on-site courses are available. You might also choose the online
e-learning subscription to learn at your convenience. Visit https://www.jmp.com/training.


https://community.jmp.com
https://www.jmp.com/statisticalthinking
https://www.jmp.com/welcome
https://www.jmp.com/skp
https://www.jmp.com/training

Chapter 1 Learn about JMP 29
Predictive and Specialized Modeling JMP Technical Support

JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP
website. Visit https://www.jmp.com/books.

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data
analysis. Options are categorized and described, and you launch them by clicking a button.
The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and
File menus. The window also lists JMP Pro features and platforms.

* To open the JMP Starter window, select View (Window on macOS) > JMP Starter.

e To display the JMP Starter automatically when you open JMP on Windows, select File >
Preferences > General, and then select JMP Starter from the Initial JMP Window list. On
macQOS, select JMP > Preferences > Initial JMP Starter Window.

JMP Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP,
many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at https://www.jmp.com/support, including the
technical support phone number.


https://www.jmp.com/books
https://www.jmp.com/support
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Predictive and Specialized Modeling

Introduction to Predictive and Specialized Modeling

Overview of Modeling Techniques

Predictive and Specialized Modeling provides details about more technical modeling techniques,
such as Response Screening, Partitioning, and Neural Networks.

The Neural platform implements a fully connected multi-layer perceptron with one or two
layers. Use neural networks to predict one or more response variables using a flexible
function of the input variables. See “Neural Networks”.

The Partition platform recursively partitions data according to a relationship between the
X and Y values, creating a decision tree of partitions. See “Partition Models”.

JMP
PRO The Bootstrap Forest platform enables you to fit an ensemble model by averaging
many decision trees each of which is fit to a random subset of the training data. See
“Bootstrap Forest”.

f’“ﬂ’o The Boosted Tree platform produces an additive decision tree model that consists of
many smaller decision trees that are constructed in layers. The tree in each layer consists of
a small number of splits, typically five or fewer. Each layer is fit using the recursive fitting
methodology. See “Boosted Tree”.

‘II’NFI{PO The K Nearest Neighbors platform predicts a response value for a given observation
using the responses of the observations in that observation’s local neighborhood. It can be
used with a categorical response for classification and with a continuous response for
prediction. See “K Nearest Neighbors”.

JMP
PRO The Naive Bayes platform classifies observations into groups that are defined by the
levels of a categorical response variable. The variables (or factors) that are used for
classification are often called features in the data mining literature. See “Naive Bayes”.

JMP
PRO The Support Vector Machines platform classifies observations into groups that are
defined by levels of a categorical response variable. The model classifies data by
optimizing a hyperplane that separates the classes. See “Support Vector Machines”.

JMP

PRO The Model Screening platform enables you to quickly run multiple predictive models
and compare the results. Measures of fit are provided for each model along with overlaid
diagnostic plots. See “Model Screening”.

P
f’RO The Model Comparison platform enables you to compare the predictive ability of
different models. Measures of fit are provided for each model along with overlaid
diagnostic plots. See “Model Comparison”.

JMP
PRO The Make Validation Column platform lets you partition the data into two or three
sets, using one of five different methods to create these partitions. See “Make Validation
Column”.
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JMP

PRO The Formula Depot platform enables you to organize, compare, profile, and score
models for deployment. For model exploration work, you can use the Formula Depot to
store candidate models outside of your JMP data table. See “Formula Depot”.

The Fit Curve platform provides predefined models, such as polynomial, logistic,
Gompertz, exponential, peak, and pharmacokinetic models. Compare different groups or
subjects using a variety of analytical and graphical techniques. See “Fit Curve”.

The Nonlinear platform lets you fit custom nonlinear models, which include a model
formula and parameters to be estimated. See “Nonlinear Regression”.

The Gaussian Process platform models the relationship between a continuous response
and one or more continuous predictors. These models are common in areas like computer
simulation experiments, such as the output of finite element codes, and they often
perfectly interpolate the data. See “Gaussian Process”.

JMP
PRO The Functional Data Explorer platform enables you to convert functional data into a
form that can be analyzed in another JMP platform. See “Functional Data Explorer”.

The Time Series platform lets you explore, analyze, and forecast univariate time series. See
“Time Series Analysis”.

The Time Series Forecast platform lets you model and forecast multiple time series. The
best fitting model is automatically selected from a set of up to 30 exponential smoothing
models. See “Time Series Forecast”.

The Matched Pairs platform compares the means between two or more correlated
variables and assesses the differences. See “Matched Pairs Analysis”.

The Modeling Utilities assist in the data cleaning and pre-processing stages of data
analysis. Each utility has exploratory tools to give you a more thorough understanding of
your data. See “Modeling Utilities”.

The Response Screening platform automates the process of conducting tests across a large
number of responses. Your test results and summary statistics are presented in data tables,
rather than reports, to enable data exploration. See “Response Screening”.

The Process Screening platform enables you to explore a large number of processes across
time. The platform calculates control chart, process stability, and process capability
metrics, and detects large process shifts. See “Process Screening”.

The Predictor Screening platform enables you to screen a data set for significant
predictors. See “Predictor Screening”.

‘II’NFI{PO The Association Analysis platform enables you to identify items that have an affinity
for each other. It is frequently used to analyze transactional data (also called market
baskets) to identify items that often appear together in transactions. See “Association
Analysis”.

The Process History Explorer platform enables you to identify problem components in
complex process histories. See “Process History Explorer”.
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JVIP
PRO Most features in this platform are available only in JMP Pro and noted with this icon.

The Neural platform implements a fully connected multi-layer perceptron with one or two
layers. Use neural networks to predict one or more response variables using a flexible function
of the input variables. Neural networks can be very good predictors when it is not necessary
to describe the functional form of the response surface, or to describe the relationship between
the inputs and the response.

Figure 3.1 Example of a Neural Network

4 =/ Neural
Validation: Random Holdback
[> Model Launch

£~ Model NTanH(3)

4 Training 4 Validation
4 mvalue 4 mvalue
Measures Value Measures Value
RSquare 0.7736955 RSquare 0.7141834
RASE 4,609027 RASE 4.2406200
Mean Abs Dev  2.9801616 Mean Abs Dev  2.5179460
-Loglikelihood 993.12394 -Loglikelihood 483.93653
SSE 71589348 SSE 3039.1044
Sum Freq 337 Sum Freq 169

< Diagram
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Overview of the Neural Platform

Think of a neural network as a function of a set of derived inputs, called hidden nodes. The
hidden nodes are nonlinear functions of the original inputs. You can specify up to two layers
of hidden nodes, where each layer can contain as many hidden nodes as you want.

Figure 3.2 shows a two-layer neural network with three X variables and one Y variable. In this
example, the first layer has two nodes, and each node is a function of all three nodes in the
second layer. The second layer has three nodes, and all nodes are a function of the three X
variables. The predicted Y variable is a function of both nodes in the first layer.

Figure 3.2 Neural Network Diagram

The functions applied at the nodes of the hidden layers are called activation functions. The
activation function is a transformation of a linear combination of the X variables. For more
information about the activation functions, see “Hidden Layer Structure”. The function
applied at the response is a linear combination (for continuous responses), or a logistic
transformation (for nominal or ordinal responses).

The main advantage of a neural network model is that it can efficiently model different
response surfaces. Given enough hidden nodes and layers, any surface can be approximated
to any accuracy. The main disadvantage of a neural network model is that the results are not
easily interpretable. This is because there are intermediate layers rather than a direct path
from the X variables to the Y variables, as in the case of regular regression.

Launch the Neural Platform

To launch the Neural platform, select Analyze > Predictive Modeling > Neural.

Launching the Neural platform is a two-step process. First, enter your variables on the Neural
launch window. Second, specify your options in the Model Launch control panel.
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pio The Neural Launch Window

Use the Neural launch window to specify X and Y variables, a validation column, and to
enable Informative Missing value coding.

Figure 3.3 The Neural Launch Window

Predicts cne or more response variables using a flexible function of the input variables.

Select Columns Cast Selected Columns into Roles Action

= 14 Columns required

dll indus

 ches required
nox

dll rooms T

A 55

dl distance

all tax optional numeric

d pt

pl _—

all Istat

all mvalue

[] Informative Missing

Set Random Seed l:l

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Y, Response The response variable or variables that you want to analyze. When multiple
responses are specified, the models for the responses share all parameters in the hidden
layers (those parameters not connected to the responses). The responses are conditionally
independent given the predictor variables, but are marginally correlated through those
variables to create one overall neural model.

X, Factor The predictor variables.

Freq A column whose numeric values assign a frequency to each row in the analysis.

‘I]’NHO Validation A numeric column that defines the validation sets. See “Validation Methods

for Neural”. If you click the Validation button with no columns selected in the Select
Columns list, you can add a validation column to your data table. For more information
about the Make Validation Column utility, see “Make Validation Column”.

By A column or columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.
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‘#‘"{0 Informative Missing Check this box to enable informative coding of missing values.
This coding allows estimation of a predictive model despite the presence of missing
values. It is useful in situations where missing data are informative. If this option is not

checked, rows with missing values are ignored.

For a continuous variable, missing values are replaced by the mean of the variable. Also, a
missing value indicator, named <colname> Is Missing, is created and included in the
model. If a variable is transformed using the Transform Covariates fitting option on the
Model Launch control panel, missing values are replaced by the mean of the transformed
variable.

For a categorical variable, missing values are treated as a separate level of that variable.

Set Random Seed Sets the seed for the starting values used in the fitting procedure. Set
Random Seed is useful if you want to reproduce an analysis. If you set a random seed and
save the script, the seed is automatically saved in the script.

The Model Launch Control Panel

Use the Model Launch control panel to specify the validation method, the structure of the
hidden layer, whether to use gradient boosting, and other fitting options.

Figure 3.4 The Model Launch Control Panel

JMP Pro JMP
4 [*|Neural 4 =|Neural
4 Model Launch 4 Model Launch
Walidation Method Walidation Method
[Holdback v| To make repreducible: [Holdback v| To make reproducible:
Holdback Proportion | 0.3333|  RandomSeed[ 0] Holdback Proportion|  0.3333|  RandomSeed[ 0]
Hidden Layer Structure Hidden Nodes

MNumber of nodes of each activation type Bm |

Activaticn Sigmoid Identity Radial

Layer TanH  Linear Gaussian
First 3 0 0
Second 0 0 0

Second layer is closer to X's in two layer models.

Boosting

Fit an additive sequence of models scaled by the leaming rate.
MNumber of Models 0

Learning Rate 01

Fitting Options
Transform Covariates
Robust Fit

MNumber of Tours

o)
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Validation Method Select the method that you want to use for model validation. See
“Validation Methods for Neural”.

Random Seed Specify a nonzero numeric random seed if you want to reproduce the
validation assignment for future launches of the Neural platform. By default, the
Random Seed is set to zero, which does not produce reproducible results. When you
save the analysis to a script, the random seed that you enter is saved to the script.

Hidden Layer Structure or Hidden Nodes Specify the number of hidden nodes of each type
in each layer. See “Hidden Layer Structure”.

Note: The standard edition of JMP uses only the TanH activation function, and can fit only
neural networks with one hidden layer.

-I',"ﬂ’o Boosting Specify options for gradient boosting. See “Boosting”.

-I','Vlg’ Fitting Options Specify options for variable transformation and model fitting. See
“Fitting Options”.

Go Fits the neural network model and shows the model reports.

After you click Go to fit a model, you can reopen the Model Launch Control Panel and change
the settings to fit another model.

Validation Methods for Neural

Neural utilizes a validation method in its fitting routine. Choices of validation method include
holdback, K-fold, or (in JMP Pro) the use of a validation column. To fit a model, the Neural
platform does the following:

* applies a penalty on the model parameters

¢ uses the validation set to tune the penalties on the parameters.

Select one of the following validation methods:

Excluded Rows Holdback Uses row states to subset the data. Rows that are unexcluded are
used as the training set, and excluded rows are used as the validation set.

For more information about using row states and how to exclude rows, see Using [MP.

Holdback Randomly divides the original data into the training and validation sets. You
specify the proportion of the original data to use as the validation set (holdback). The
random selection is based on stratified sampling across the model factors to attempt to
create training and validation sets that are more balanced than ones based on simple
random sampling.
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KFold Divides the data into K subsets, or folds. In turn, each of the K folds is used to validate
the model fit on the rest of the data, fitting a total of K models. The final model is for the
fold that resulted in the model with the best validation statistic.

This method is useful for small data sets, because it makes efficient use of limited amounts
of data.

f,"’"’ Validation Column Uses a numeric column that defines the validation sets. The column’s
values determine how the data is split:

— If the validation column has two levels, the smaller value defines the training set and
the larger value defines the validation set.

— If the validation column has three levels, the values, in order of increasing size, define
the training, validation, and test sets.

— If the validation column has more than three unique values, then K-Fold validation is
performed. The number of folds is determined by the number of values in the
validation column.

The Neural platform uses the validation column to train and tune the model or to train,
tune, and evaluate the model. For more information about validation, see “Validation in
JMP Modeling”.

Hidden Layer Structure

Note: The standard edition of JMP uses only the TanH activation function, and can fit only
neural networks with one hidden layer.

The Neural platform can fit one or two-layer neural networks. Increasing the number of nodes
in the first layer, or adding a second layer, makes the neural network more flexible. You can
add an unlimited number of nodes to either layer. The second layer nodes are functions of the
X variables. The first layer nodes are functions of the second layer nodes. The Y variables are
functions of the first layer nodes.

Caution: You cannot use boosting with a two-layer neural network. If you specify any
non-zero values in the second layer and also specify boosting, the second layer is ignored.

The functions applied at the nodes of the hidden layers are called activation functions. An
activation function is a transformation of a linear combination of the X variables. The
following activation functions are available:

TanH The hyperbolic tangent function is a sigmoid function. TanH transforms values to be
between -1 and 1, and is the centered and scaled version of the logistic function. The
hyperbolic tangent function is:
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e 1
e2% + 1
where x is a linear combination of the X variables.
Linear The identity function. The linear combination of the X variables is not transformed.
The Linear activation function is most often used in conjunction with one of the non-linear
activation functions. In this case, the Linear activation function is placed in the second
layer, and the non-linear activation functions are placed in the first layer. This is useful if
you want to first reduce the dimensionality of the X variables, and then have a nonlinear
model for the Y variables.
For a continuous Y variable, if only Linear activation functions are used, the model for the
Y variable reduces to a linear combination of the X variables. For a nominal or ordinal Y
variable, the model reduces to a logistic regression.
Gaussian The Gaussian function. Use this option for radial basis function behavior, or when
the response surface is Gaussian (normal) in shape. The Gaussian function is:
e
where x is a linear combination of the X variables.
Boosting

-l',"ﬂ’o Boosting is the process of building a large additive neural network model by fitting a
sequence of smaller models. Each of the smaller models is fit on the scaled residuals of the
previous model. The models are combined to form the larger final model. The process uses
validation to assess how many component models to fit, not exceeding the specified number

of models.

Boosting is often faster than fitting a single large model. However, the base model should be a
1 to 2 node single-layer model. The benefit of faster fitting can be lost if a large number of
models is specified.

Use the Boosting panel in the Model Launch control panel to specify the number of
component models and the learning rate. Use the Hidden Layer Structure panel in the Model
Launch control panel to specify the structure of the base model.

The learning rate must be 0 < r < 1. Learning rates close to 1 result in faster convergence on a
final model, but also have a higher tendency to overfit data. Use learning rates close to 1 when
a small Number of Models is specified.
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As an example of how boosting works, suppose you specify a base model consisting of one
layer and two nodes, with the number of models equal to eight. The first step is to fit a
one-layer, two-node model. The predicted values from that model are scaled by the learning
rate, then subtracted from the actual values to form a scaled residual. The next step is to fit a
different one-layer, two-node model, where the response values are the scaled residuals of the
previous model. This process continues until eight models are fit, or until the addition of
another model fails to improve the validation statistic. The component models are combined
to form the final, large model. In this example, if six models are fit before stopping, the final
model consists of one layer and 2 x 6 =12 nodes.

Caution: You cannot use boosting with a two-layer neural network. If you specify any
non-zero values in the second layer and also specify boosting, the second layer is ignored.

Fitting Options

‘I]’NII{O The following model fitting options are available:

Transform Covariates Transforms all continuous variables to near normality using either the
Johnson Su or Johnson Sb distribution. Transforming the continuous variables helps
mitigate the negative effects of outliers or heavily skewed distributions. See the Save
Transformed Covariates option in “Neural Model Options”.

Robust Fit Trains the model using least absolute deviations instead of least squares. This
option is useful if you want to minimize the impact of response outliers. This option is
available only for continuous responses.

Penalty Method Choose the penalty method. To mitigate the tendency neural networks have

to overfit data, the fitting process incorporates a penalty on the likelihood. See “Penalty
Method”.

Number of Tours Specify the number of times to restart the fitting process, with each
iteration using different random starting points for the parameter estimates. The iteration
with the best validation statistic is chosen as the final model.
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The penalty is Ap(p;), where A is the penalty parameter, and p( ) is a function of the parameter
estimates, called the penalty function. Validation is used to find the optimal value of the

penalty parameter.

Table 3.1 Descriptions of Penalty Methods

Method

Squared

Absolute

Weight Decay

NoPenalty

Penalty Function

>

2B

none

B}
1+ p2
Bi

Description

Use this method if you think that most of your X
variables are contributing to the predictive ability of
the model.

Use either of these methods if you have a large
number of X variables, and you think that a few of
them contribute more than others to the predictive
ability of the model.

Does not use a penalty. You can use this option if
you have a large amount of data and you want the
fitting process to go quickly. However, this option
can lead to models with lower predictive
performance than models that use a penalty.
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Model Reports

A model report is created for every neural network model. Measures of fit appear for the
training and validation sets. In addition, confusion statistics appear when the response is

nominal or ordinal.

Figure 3.5 Example of a Neural Model Report

4 =/Model NTanH(3)

Training and Validation Measures of Fit

Measures of fit appear for the training and validation sets (Figure 3.5).

Generalized RSquare A measure that can be applied to general regression models. It is

Entropy RSquare

< Training
4 chas
Measures Value
Generalized RSquare  0.5326372
Entropy RSquare 0.4705979
RASE 0.2006679
Mean Abs Dev 0.0860496
Misclassification Rate 0.0534125
-Loglikelihood 44.43917
Sum Freq 337
Confusion Matrix
Predicted

Actual Count
chas 0 1
0 n 3
1 15 8

Confusion Rates

Predicted

Actual Rate
chas 0 1
0 0.990 0.010
1 0.652 0.348

4 Validation
4 chas
Measures Value
Generalized RSquare  0.1796731
Entropy RSquare 0.1450083
RASE 0.2498265
Mean Abs Dev 0.0920273
Misclassification Rate 0.0828402
-Loglikelihood 36.985080
Sum Freq 169
Confusion Matrix
Predicted

Actual Count
chas 0 1
0 155 2
1 12 0

Confusion Rates

Predicted

Actual Rate
chas 0 1
0 0.987 0.013
1 1.000 0.000

based on the likelihood function L and is scaled to have a maximum value of 1. The value
is 1 for a perfect model, and 0 for a model no better than a constant model. The
Generalized RSquare measure simplifies to the traditional RSquare for continuous normal
responses in the standard least squares setting. Generalized RSquare is also known as the

Nagelkerke or Craig and Uhler R?, which is a normalized version of Cox and Snell’s

pseudo R See Nagelkerke (1991).

See “Entropy RSquare”.

RSquare Gives the RSquare for the model.

(Appears only when the response is nominal or ordinal.) A measure of fit
that compares the log-likelihoods from the fitted model and the constant probability
model. Entropy RSquare ranges from 0 to 1, where values closer to 1 indicate a better fit.
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RASE Gives the root average squared error. When the response is nominal or ordinal, the
differences are between 1 and p (the fitted probability for the response level that actually
occurred).

Mean Abs Dev The average of the absolute values of the differences between the response
and the predicted response. When the response is nominal or ordinal, the differences are
between 1 and p (the fitted probability for the response level that actually occurred).

Misclassification Rate The rate for which the response category with the highest fitted
probability is not the observed category. Appears only when the response is nominal or
ordinal.

-LogLikelihood Gives the negative of the log-likelihood. See Fitting Linear Models.
SSE Gives the error sums of squares. Available only when the response is continuous.

Sum Freq Gives the number of observations that are used. If you specified a Freq variable in
the Neural launch window, Sum Freq gives the sum of the frequency column.

If there are multiple responses, fit statistics are given for each response, and an overall
Generalized RSquare and negative Log-Likelihood is given.

Confusion Statistics

For nominal or ordinal responses, a Confusion Matrix report and Confusion Rates report is
given (Figure 3.5). The Confusion Matrix report shows a two-way classification of the actual
response levels and the predicted response levels. For a categorical response, the predicted
level is the one with the highest predicted probability. The Confusion Rates report is equal to
the Confusion Matrix report, with the numbers divided by the row totals.

Neural Platform Options

The Neural red triangle menu contains the following options:

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.
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Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Neural Model Options

Each model report has a red triangle menu that contains options for producing additional
output or saving results. The model report red triangle menu contains the following options:

Diagram Shows a diagram representing the hidden layer structure.
Show Estimates Shows the parameter estimates in a report.

Profiler Launches the Prediction Profiler. For nominal or ordinal responses, each response
level is represented by a separate row in the Prediction Profiler. For more information
about the options in the red triangle menu, see Profilers.

Categorical Profiler Launches the Prediction Profiler. Similar to the Profiler option, except
that all categorical probabilities are combined into a single profiler row. Available only for
nominal or ordinal responses. For more information about the options in the red triangle
menu, see Profilers.

Contour Profiler Launches the Contour Profiler. This is available only when the model
contains more than one continuous factor. For more information about the options in the
red triangle menu, see Profilers.

Surface Profiler Launches the Surface Profiler. This is available only when the model
contains more than one continuous factor. For more information about the options in the
red triangle menu, see Profilers.

ROC Curve Creates an ROC curve. Available only for nominal or ordinal responses. For
more information about ROC Curves, see “ROC Curve”.

Lift Curve Creates a lift curve. Available only for nominal or ordinal responses. For more
information about Lift Curves, see “Lift Curve”.

Plot Actual by Predicted Plots the actual versus the predicted response. Available only for
continuous responses.

Plot Residual by Predicted Plots the residuals versus the predicted responses. Available
only for continuous responses.

Save Formulas Creates new columns in the data table containing formulas for the predicted
response and the hidden layer nodes.

Save Profile Formulas Creates new columns in the data table containing formulas for the
predicted response. Formulas for the hidden layer nodes are embedded in this formula.
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This option produces formulas that can be used by the Interactive HTML version of the
Profiler.

Save Fast Formulas Creates new columns in the data table containing formulas for the
predicted response. Formulas for the hidden layer nodes are embedded in this formula.
This option produces formulas that evaluate faster than the other options, but cannot be
used in the Interactive version of the Profiler.

‘II’NFI{PO Publish Prediction Formula Creates prediction formulas and saves them as formula
column scripts in the Formula Depot platform. If a Formula Depot report is not open, this
option creates a Formula Depot report. See “Formula Depot”.

Make SAS Data Step Creates SAS code that you can use to score a new data set.

Save Validation Creates a new column in the data table that identifies which rows were used
in the training and validation sets. This option is not available when a Validation column is
specified on the Neural launch window. See “The Neural Launch Window”.

-I','V'P Save Transformed Covariates Creates new columns in the data table showing the
transformed covariates. The columns contain formulas that show the transformations.
This option is available only when the Transform Covariates option is checked on the
Model Launch control panel. See “Fitting Options”.

Remove Fit Removes the entire model report.

Example of a Neural Network

This example uses the Boston Housing.jmp data table. Suppose you want to create a model to
predict the median home value as a function of several demographic characteristics. Follow
the steps below to build the neural network model:

1. Select Help > Sample Data Library and Boston Housing.jmp.

Launch the Neural platform by selecting Analyze > Predictive Modeling > Neural.
Assign mvalue to the Y, Response role.

Assign the other columns (crim through Istat) to the X, Factor role.

Click OK.

Enter 0.2 for the Holdback Proportion.

Enter 1234 for the Random Seed.

N o ok N

Note: In general, results vary due to the random nature of choosing a validation set. Entering
the seed above enable you to reproduce the results shown in this example.
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8. Enter 3 for the number of TanH nodes in the first layer.

9. Check the Transform Covariates option.

10. Click Go.

Figure 3.6 Neural Report

4 =/Model NTanH(3)

< Training

4 mvalue
Measures Value
RSquare 0.9074839
RASE 2.8561453

Mean Abs Dev  2.1278654
-Loglikelihood 997.23823
SSE 3295.6567
Sum Freq 404

4 Validation
4 mvalue
Measures Value
RSquare 0.912591
RASE 2.4304519

Mean Abs Dev  1.8284954
-Loglikelihood 235.31561
SSE 602.52384
Sum Freq 102
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Results are provided for both the training and validation sets. Use the results of the validation
set as a representation of the model’s predictive power on future observations.

The R-Square statistic for the Validation set is 0.913, signifying that the model is predicting
well on data not used to train the model. As an additional assessment of model fit, click the
red triangle next to Model NTanH(3) and select Plot Actual by Predicted.

Figure 3.7 Actual by Predicted Plot

£ Actual by Predicted Plot
Training Validation

50
40

30

mvalue
mvalue

0 10 20 30 40 50 0 10 20 30 40 50

mvalue Predicted mvalue Predicted

The points fall along the line, signifying that the predicted values are similar to the actual
values.

To get a general understanding of how the X variables are impacting the predicted values,
click the red triangle next to Model NTanH(3) and select Profiler.
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Figure 3.8 Profiler

4 = |Prediction Profiler
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Some of the variables have profiles with positive slopes, and some negative. For example, the
variable rooms has a positive slope. This indicates that the more rooms a home has, the higher
the predicted median value. The variable pt is the pupil teacher ratio by town. This variable
has a negative slope, indicating that the higher the pupil to teacher ratio, the lower the median
value.



Chapter 4

Partition Models
Use Decision Trees to Explore and Model Your Data

The Partition platform recursively partitions data according to a relationship between the
predictors and response values, creating a decision tree. The partition algorithm searches all
possible splits of predictors to best predict the response. These splits (or partitions) of the data
are done recursively to form a tree of decision rules. The splits continue until the desired fit is
reached. The partition algorithm chooses optimum splits from a large number of possible
splits, making it a powerful modeling, and data discovery tool.

Figure 4.1 Example of a Decision Tree

|
= |All Rows
|
Count G*2 LogWorth
300 427.81787 10.087875

* HDL<49 ~ HDL>=49
I | |
Count G*2 LogWorth Count G*2 LogWorth
152 193.95912 2.6731558 157 191.84163 2.7096215
| | [ |
> BP>=88 ~BP<88 ~BP-=88 ~BP< 88
I ] | I | |
Count G2 Count G*2 LogWorth Count G*2 LogWorth Count G"2
108 12361263 44 60906011 24101151 B8 11828397 3.2130148 69 63.761094
[ Candidates [» Candidates
T BMI<299 T BMI>=299 *ILTG<3.9703 *ILTG>=3.9703
I | | (e e
Count G2 Count Gh2 Count G2 Count G2
34 46.06962 10 6.5016393 6 0 82 106.54786
|* Candidates | Candidates |* Candidates | Candidates
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Overview of the Partition Platform

The Partition platform recursively partitions data according to a relationship between the
predictors and response values, creating a decision tree. Variations of partitioning go by many
names and brand names: decision trees, CART™ CHAID™, C4.5, C5, and others. The
technique is often considered as a data mining technique for the following reasons:

e it is useful for exploring relationships without having a good prior model
¢ it handles large problems easily

e the results are interpretable

A classic application of partitioning is to create a diagnostic heuristic for a disease. Given
symptoms and outcomes for a number of subjects, partitioning can be used to generate a
hierarchy of questions to help diagnose new patients.

Predictors can be either continuous or categorical (nominal or ordinal). If a predictor is
continuous, then the splits are created by a cutting value. The sample is divided into values
below and above this cutting value. If a predictor is categorical, then the sample is divided
into two groups of levels.

The response can also be either continuous or categorical (nominal or ordinal). If the response
is continuous, then the platform fits the means of the response values and the split is chosen to
minimize the sum of squared errors. If the response is categorical, then the fitted value is a
probability for the levels of the response and the split is chosen to minimize the residual
log-likelihood chi-square.

For more information about split criteria, see “Statistical Details for the Partition Platform”.

For more information about recursive partitioning, see Hawkins and Kass (1982) and Kass
(1980).

Example of the Partition Platform

In this example, you use the Partition platform to construct a decision tree that predicts the
one-year disease progression (low or high) of patients with diabetes.

1. Select Help > Sample Data Library and Diabetes.jmp.
2. Select Analyze > Predictive Modeling > Partition.

3. Select Y Binary and click Y, Response.

4. Select Age through Glucose and click X, Factor.

5. Enter 0.33 for the Validation Portion.
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Note: In JMP Pro, a validation column can be used for validation. Select Validation and
click Validation. Set the Validation Portion to 0.

6. Click OK.

7. On the platform report window, click Go to perform automatic splitting.

Note: Because you are using a random Validation Portion, your results differ from those in
Figure 4.2.

Figure 4.2 Partition Report for Diabetes

[ Split H Prune H Go |[COI0rP0ints| Number
RSquare N of Splits
Training 0.428 209 4
Validation 0154 143
|
~ All Rows
|
Count G*2 LogWorth
200 33682461 1833404

> LTG>=4.6052 *LTG<4.6052

Count G*2 LogWorth Count G*2 LogWorth
140 193.82300 8.0682805 150 £3.421961 3.4514003

[ | | !—‘—\

> BMI==327 > BMI<32.7 > BMI==273 > BMI<273
|| ——
Count G"2 Count G*2 LogWorth Count G"2 Count G"2
20 0 120 160.67707 5.1050931 30 30.024145 129 20.635492
[ Candidates [ Candidates [ Candidates

> LTG>=5.1299 *ILTG<«5.1299
1 1 |
Count G2 Count G2
38 47.397760 82 03.305403
[ Candidates [ Candidates

Automatic splitting resulted in four splits. The final RSquare for the Validation set is 0.154.
The decision tree shows the four splits and the counts of observations in each split.

8. Click the red triangle next to Partition for Y Binary and select Column Contributions.
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Figure 4.3 Column Contributions Report
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450092475 T ]
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Age
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TCH
Glucose
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The Column Contributions report shows that LTG and BMI are the only predictors in the
decision tree model. Each column is used in two splits. Your results can differ. When the
Validation Portion is used, the validation set is selected at random from the data table. If
you redo your analysis, a new random validation set is selected and your results can differ

from your first run.

9. Click the red triangle next to Partition for Y Binary and select Save Columns > Profiler.

Figure 4.4 Profiler for Partition Model

4 = |Prediction Profiler
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g ! !
£ i i
o H H
)_Low 0.744 i i
cooooooo Ll ~ oW o wm o coooooo oo oo oo oo o o oo O
- - — o~ - — o
180.14
48,518 1 26.376 94.647 Total 11544
Age Gender BMI BP Cholestercl LDL
High p.256 i
g !
£ i
5] H
)_Low 0.744 i
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The profiler enables you to change the values of BMI and LTG to obtain the predicted Y
Binary outcome. No other factors had a split in the partition model. Their profiles are flat

lines.

10. Click the red triangle next to Partition for Y Binary and select Save Columns > Save

Prediction Formula.

In the Diabetes.jmp data table, columns called Prob(Y Binary==Low), Prob(Y Binary==High),
and Most Likely Y Binary are added. To see how these response probabilities are calculated,
in the Columns panel, next to each column, double-click the Formula icon =r .
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Launch the Partition Platform

Launch the Partition platform by selecting Analyze > Predictive Modeling > Partition.

Figure 4.5 Partition Launch Window

Builds a decision tree to predict a response.

Select Columns Cast Selected Columns into Roles Action
= 14 Columns required
Ay optiona
aptional C 1
[ Y Binary
<l Y Crdinal
o hee, required
ender
4l BMI B -
4
dll Total Cholesterol
40 optional numeric
4 HDL optional numeric
4 TCH
i
dll Glucose optiona
A Validation
Options

Methed | pecision Tree v

Validation Porticn
Informative Missing
Ordinal Restricts Order

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Y, Response The response variable or variables that you want to analyze.

X, Factor The predictor variables.

Weight A column whose numeric values assign a weight to each row in the analysis.
Freq A column whose numeric values assign a frequency to each row in the analysis.

‘I]’“H’O Validation A numeric column that defines the validation sets. See “Validation in
Partition”. If you click the Validation button with no columns selected in the Select
Columns list, you can add a validation column to your data table. For more information

about the Make Validation Column utility, see “Make Validation Column”.

By A column or columns whose levels define separate analyses. For each level of the column,
the corresponding rows are analyzed using the other variables that you specify. The
results appear in separate reports. If more than one By variable is assigned, a separate
report is produced for each possible combination of the levels of the By variables.
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JMP

PRO Method Enables you to select the partition method (Bootstrap Forest, Boosted Tree, K
Nearest Neighbors, or Naive Bayes).

For more information about these methods, see “Bootstrap Forest”, “Boosted Tree”, “K
Nearest Neighbors”, and “Naive Bayes”.

Validation Portion The portion of the data to be used as the validation set. See “Validation in
Partition”.

Informative Missing If selected, enables missing value categorization for categorical

predictors and informative treatment of missing values for continuous predictors. See
“Informative Missing”.

Ordinal Restricts Order If selected, restricts consideration of splits to those that preserve the
ordering.

The Partition Report

The initial Partition report shows a partition plot, control buttons, a summary panel, and a
decision tree. The partition plot and decision tree are initialized without any splits. The
reports details are different for categorical and continuous responses.

e “Control Buttons”
e “Report for Categorical Responses”

e “Report for Continuous Responses”

Control Buttons

Use the control buttons to interact with the decision tree.

Split Creates a partition of the data using the optimal split. To specify multiple splits, hold
the Shift key as you click Split.

Prune Removes the worst split.

Go (Available when you are using validation.) Automatically adds splits to the decision tree
until the validation statistic is optimized. See “Validation in Partition”. Without validation,
you simply decide the number of splits to use in the partition model.

Color Points For categorical responses, colors observations according to response level.
These colors are added to the data table.
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Report for Categorical Responses

The sample data table Diabetes.jmp was used to create a report for the categorical response Y
Binary.

Figure 4.6 Partition Report for a Categorical Response
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Partition Plot

Each point in the Partition Plot represents an observation in the data table. If validation is
used, the plot is only for the training data. The initial partition plot does not show splits.

Notice the following:

The left vertical axis is the proportion of each response outcome.
The right vertical axis shows the order in which the response levels are plotted.

Horizontal lines divide each split by the response variable. The initial horizontal line
shows the overall proportion of the first plotted response in the data set.

Splits are shown below the X axis with a text description and a vertical line that splits the
observations in the plot. The vertical lines extend into the plot and indicate the boundaries
for each node. The most recent split appears directly below the horizontal axis and on top
of existing splits. The plot is updated with each split or prune of the decision tree.
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Summary Report

Figure 4.7 Summary Report for a Categorical Response

| Number
RSquare N of Splits
Training 0.428 209 4

Validation 0.154 1432

The Summary Report provides fit statistics for the training data and validation and test data
(if used). The fit statistics in the Summary Panel update as you add splits or prune the decision
tree.

RSquare The current value of R2.
N The number of observations.

Number of Splits The current number of splits in the decision tree.

Node Reports

Each node in the tree has a report and a red triangle menu with additional options. Terminal
nodes also have a Candidates report.

Figure 4.8 Terminal Node Report for a Categorical Response

~ All Rows
.

Count G2
442 518.87142

4 Candidates

Candidate

Term G2 LogWorth Cut Point
Age 10.5000264 1.71376465 51
Gender 1.8302510 0.75424581 2
BMI 92.8760803 31.25572705 273
BP 64.8300680 18.98680929 100
Total Cholesterol 20.3048623 4,01316712 194
LDL 12.5858490 0.82750128 1222
HDL 44,2535587 11.48909721 46
TCH 64.3516093 17.86426783 4
LTG 102.8078418 * 35.971309920 4.8203
Glucose 43.2683018 11.05800993 99

Count Number of training observations that are characterized by the node.

G2 A fit statistic used for categorical responses (instead of sum of squares that is used for
continuous responses). Lower values indicate a better fit. See “Statistical Details for the
Partition Platform”.

Candidates For each column, the Candidates report provides details about the optimal split
for that column. The optimal split over all terms is marked with an asterisk.

Term Shows the candidate columns.
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Candidate G*"2 Likelihood ratio chi-square for the best split. Splitting on the predictor
with the largest G2 maximizes the reduction in the model G"2.

LogWorth The LogWorth statistic, defined as -logyg(p-value). The optimal split is the one
that maximizes the LogWorth. See “Statistical Details for the Partition Platform”.

Cut Point The value of the predictor that determines the split. For a categorical term, the
levels in the left-most split are listed.

The optimal split is noted by an asterisk. However, there are cases where the Candidate G is
higher for one variable, but the Logworth is higher for a different variable. In this case > and <
are used to point in the best direction for each variable. The asterisk corresponds to the
condition where they agree. See “Statistical Details for the Partition Platform”.

Report for Continuous Responses

The sample data table Diabetes.jmp was used to create a report for the continuous response Y.

Figure 4.9 Partition Report for a Continuous Response
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Partition Plot

The partition plot is initialized without any splits. Each point represents an observation in the
data table. If validation is used, the plot is only for the training data.
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Notice the following:

e The vertical axis represents the response value of the observations.

* Horizontal lines show the mean response value for each node of the decision tree. The
initial horizontal line is at the overall mean of the response.

® Vertical axis divisions represent splits in the decision tree. A text description of the most
recent split appears below the horizontal axis. Observations are reorganized into their
respective nodes as splits are created or removed.

Tip: To see tooltips for narrow partitions, hover over the labels on the horizontal axis of the
partition plot.

Summary Report

Figure 410 Summary Report for a Continuous Response

Number
RSquare RASE N of Splits AlCc
Training 0420 54600663 200 4 325383

Validation 0.366 61.16064 143

The Summary Report provides fit statistics for the training data and validation and test data
(if used). The fit statistics in the Summary Panel update as you add splits or prune the decision
tree.

RSquare The current value of R2.

RASE The root average square error. See Fitting Linear Models.

N The number of observations.

Number of Splits The current number of splits in the decision tree.

AICc The corrected Akaike’s Information Criterion. See Fitting Linear Models.
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Node Reports

Each node in the tree has a report and a red triangle menu with additional options. Terminal
nodes also have a Candidates report.

Figure 4.11 Terminal Node Report for a Continuous Response

Number
RSquare RASE N of Splits AlCc
0.000 .44z 0
> All Rows
Count 442
Mean  152.13348
Std Dev  77.093005
4 Candidates
Term Candidate 55 LogWorth Cut Point
Age 101593.5830 3.61765555 51
Gender 4860.2308 0.40460420 1
EMI 7206182987 46.76510648 27.3
BP 4467086091 23.80250262 102
Total Cholesterol  157877.7151 6.30470855 194
LDL 1200145872 449760240 1266
HDL 3005146338 20.07867675 46
TCH 4702047338 2555525084 3.73
LTG 7641333264 * 50.04935713 4.6052
Glucose 3412443856 16.90517792 100

Count The number of observations (rows) in the branch.
Mean The average response for all observations in that branch.
Std Dev The standard deviation of the response for all observations in that branch.

Candidates For each column, the Candidates report provides details about the optimal split
for that column. The optimal split over all columns is marked with an asterisk.

Term Shows the candidate columns.
Candidate SS Sum of squares for the best split.

LogWorth The LogWorth statistic, defined as -logg(p-value). The optimal split is the one
that maximizes the LogWorth. See “Statistical Details for the Partition Platform”.

Cut Point The value of the predictor that determines the split. For a categorical term, the
levels in the left-most split are listed.

The optimum split is noted by an asterisk. However, there are cases where the Candidate SS is
higher for one variable, but the Logworth is higher for a different variable. In this case > and <
are used to point in the best direction for each variable. The asterisk corresponds to the
condition where they agree. See “Statistical Details for the Partition Platform”.
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Partition Platform Options

The Partition red triangle menu options give you the ability to customize reports according to
your needs. The available options are determined by the type of data that you use for your
analysis.

Display Options Contains options that show or hide report elements.

Show Points Shows the points. For categorical responses, this option shows the points or
colored panels.

Show Tree Shows the large tree of partitions.
Show Graph Shows the partition graph.

Show Split Bar (Available only for categorical responses.) Shows the colored bars that
indicate the split proportions in each leaf.

Show Split Stats Shows the split statistics. For more information about the categorical
split statistic G2, see “Statistical Details for the Partition Platform”.

Show Split Prob (Available only for categorical responses.) Shows the Rate and Prob
statistics in the node reports.

JMP automatically shows the Rate and Prob statistics when you select Show Split
Count. For more information about Rate and Prob, see “Statistical Details for the
Partition Platform”.

Show Split Count (Available only for categorical responses.) Shows frequency counts in
the node reports. When you select this option, JMP automatically selects Show Split
Prob. And when you deselect Show Split Prob, the counts do not appear.

Show Split Candidates Shows the Candidates report.

Sort Split Candidates Sorts the Candidates reports by the statistic or the log(worth),
whichever is appropriate.

Split Best Splits the tree at the optimal split point. This is equivalent to clicking the Split
button.

Prune Worst Removes the terminal split that has the least discrimination ability. This is
equivalent to clicking the Prune button.

Minimum Size Split Define the minimum size split allowed by entering a number or a
fractional portion of the total sample size. To specify a number, enter a value greater than
or equal to 1. To specify a fraction of the sample size, enter a value less than 1. The default
value is set to the maximum of 5, or the floor of the number of rows divided by 10,000.
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Lock Columns Interactively lock columns so that they are not considered for splitting. You
can turn the display off or back on without affecting the individual locks.

Plot Actual by Predicted (Available only for continuous responses.) Shows a plot of actual
values by predicted values. See “Actual by Predicted Plot”.

Small Tree View Shows a small version of the partition tree to the right of the partition plot.

Tree 3D Shows a 3-D plot of the tree structure. To access this option, press Shift and click the
red triangle menu.

Leaf Report Shows the mean and count or rates for the bottom-level leaves of the report.

Column Contributions Shows a report indicating each input column’s contribution to the fit.
The report also shows how many times it defined a split and the total G> or Sum of
Squares attributed to that column.

Split History Shows a plot of RSquare versus the number of splits. If you use excluded row
validation, holdback validation, or a validation column, separate curves are drawn for
training and validation RSquare values. The RSquare curve is blue for the training set and
red for the validation set. If you select K Fold Crossvalidation, the RSquare curve for all of
the data is blue, and the curve for the cross validation RSquare is green.

ROC Curve (Available only for categorical responses.) Receiver Operating Characteristic
(ROC) curves display the efficiency of a model’s fitted probabilities to sort the response
levels. See “ROC Curve”.

Lift Curve (Available only for categorical responses.) Lift curves display the predictive
ability of a partition model. See “Lift Curve”.

Show Fit Details (Appears only for categorical responses.) The Fit Details report shows
several measures of fit and provides a Confusion Matrix report. See “Show Fit Details”.

Save Columns Contains options for saving model and tree results, and creating SAS code.
Save Residuals Saves the residual values from the model to the data table.
Save Predicteds Saves the predicted values from the model to the data table.
Save Leaf Numbers Saves the leaf numbers of the tree to a column in the data table.

Save Leaf Labels Saves leaf labels of the tree to the data table. The labels document each
branch that the row would trace along the tree. Each branch is separated by “&”. An
example label might be: “size(Small,Medium)&size(Small)”. However, JMP does not
include redundant information in the form of category labels that are repeated. A
category label for a leaf might refer to an inclusive list of categories in a higher tree
node. A caret (‘") appears where the tree node with redundant labels occurs.
Therefore, “size(Small, Medium)&size(Small)” is presented as "&size(Small).
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Save Prediction Formula Saves prediction formulas to a column or multiple columns in
the data table. The formulas consist of nested conditional clauses that describe the tree
structure. If the response is continuous, one column that contains a Predicting property
is added. If the response is categorical, columns that contain a Response Probability
property are added for each level of the response. In addition, a Most Likely column
that contains the response level with the highest probability of occurrence for each
observation is added.

Save Tolerant Prediction Formula Saves a formula that predicts even when there are
missing values and when Informative Missing has not been checked. The prediction
formula tolerates missing values by randomly allocating response values for missing
predictors to a split. If the response is continuous, the column contains a Predicting
property. If the response is categorical, the column contains a Response Probability
property. If you have checked Informative Missing, you can save the Tolerant
Prediction Formula by holding the Shift key as you click the report’s red triangle.

Save Leaf Number Formula Saves a column containing a formula in the data table that
computes the leaf number.

Save Leaf Label Formula Saves a column containing a formula in the data table that
computes the leaf label.

Make SAS DATA Step Creates SAS code for scoring a new data set.

PRo Publish Prediction Formula  Creates a prediction formula and saves it as a formula

column script in the Formula Depot platform. If a Formula Depot report is not open,
this option creates a Formula Depot report. See “Formula Depot”.

‘II’NFI{O Publish Tolerant Prediction Formula Creates a tolerant prediction formula and

saves it as a formula column script in the Formula Depot platform. If a Formula Depot
report is not open, this option creates a Formula Depot report. See “Formula Depot”. If
you have checked Informative Missing, you can use this option by holding the Shift
key as you click the report’s red triangle.

Specify Profit Matrix (Available only for categorical responses.) Enables you to specify
profits or costs associated with correct or incorrect classification decisions. For a nominal

response, you can specify the profit matrix entries using a probability threshold. See
“Show Fit Details”.

Profiler Shows an interactive profiler report. Changes in the factor values are reflected in the
estimated classification probabilities. See Profilers.

Color Points (Available only for categorical responses.) Colors points based on their
response level. This is equivalent to clicking the Color Points button. See “Report for
Categorical Responses”.

See Using [MP for more information about the following options:
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Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Show Fit Details

Figure 4.12 Fit Details for Categorical Response (Y Binary from Diabetes.jmp)

4 Fit Details
Measure Training Validation Definition
Entropy RSquare 0.4276 0.1543 1-Loglike(model)/Loglike(0)
Generalized RSquare 0.5656 0.2464 (1-(L(0)/Limedel))*(2/n))/(1-LIO) 2/m))
Mean -Log p 0.3224 0.5312 3 -Legip[li/n
RASE 0.3201 0.4080 v (yljl-plln
Mean Abs Dev 0.2083 0.2017 3 [y[jl-el[jll/n
Misclassification Rate 0.1371 0.2238 3 (pljlzpMax)/n
N 200 143 n

< Confusion Matrix

Training Validation
Predicted Predicted
Actual Count Actual Count
YBinary Low High YBinary Low High
Low 212 12 Low 84 13
High 29 46 High 19 27
Predicted Predicted
Actual Rate Actual Rate
YBinary Low High YBinary Low High
Low 0.046 0.034 Low 0.866 0.134
High 0.387 0.613 High 0.413 0.587

Entropy RSquare A measure of fit that compares the log-likelihoods from the fitted model
and the constant probability model. Entropy RSquare ranges from 0 to 1, where values
closer to 1 indicate a better fit. See “Entropy RSquare”.

Generalized RSquare A measure that can be applied to general regression models. It is
based on the likelihood function L and is scaled to have a maximum value of 1. The
Generalized RSquare measure simplifies to the traditional RSquare for continuous normal
responses in the standard least squares setting. Generalized RSquare is also known as the
Nagelkerke or Craig and Uhler R?, which is a normalized version of Cox and Snell’s
pseudo R? See Nagelkerke (1991). Values closer to 1 indicate a better fit.
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Mean -Log p The average of -log(p), where p is the fitted probability associated with the
event that occurred. Smaller values indicate a better fit.

RASE The root average square error, where the differences are between the response and p
(the fitted probability for the event that actually occurred). Smaller values indicate a better
fit.

Mean Abs Dev The average of the absolute values of the differences between the response
and p (the fitted probability for the event that actually occurred). Smaller values indicate a
better fit.

Misclassification Rate The rate for which the response category with the highest fitted
probability is not the observed category. Smaller values indicate a better fit.

The Confusion Matrix report shows matrices for the training set and for the validation and
test sets (if defined). The Confusion Matrix Report contains confusion matrices and confusion
rates matrices. A confusion matrix is a two-way classification of actual and predicted
responses. A confusion rates matrix is equal to the confusion matrix, with the numbers
divided by the row totals.

If the response has a Profit Matrix column property, or if you specify costs using the Specify
Profit Matrix option, then a Decision Matrix report appears. See “Decision Matrix Report”.

Specify Profit Matrix

A profit matrix can be used with categorical responses. A profit matrix is used to assign costs
to undesirable outcomes and profits to desirable outcomes.
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Figure 4.13 Specify Profit Matrix Window

Specify Profit Matrix

Each matrix entry is the profit if you predict the response in the column when the response in the row is the
actual response,

Enter values that reflect profits for correct decisions on the diagenal.
Enter values {usually negative) that reflect profits for incorrect decisions elsewhere,
Use the Undecided column to reflect profits for an alternative decision.

When you save prediction formulas, these values will be used to create best decisicn columns.
The best decision is the one with greatest expected profit.

Decision or Prediction
[High  [Low |[Undecided
High [ 1)[ 1] |
tw [ 1] 1] i

Actual

To create a profit matrix for a binary response, enter a Target and Probability Threshold.
If the predicted probability exceeds the threshold, the best decision will be the target.

Target: M =vrrr v|
Probability Threshold: E'

[T Sawe to colurnn as property.

Cancel |

You can assign profit and cost values to each combination of actual and predicted response
categories. To specify the costs of classifying into an alternative category, enter values in the
Undecided column. To save your assignments to the response column as a property, check
Save to column as property. Leaving this option unchecked applies the Profit Matrix only to
the current Partition report.

Probability Threshold Specification for Profit Matrix

When the response is binary, instead of entering weights into the profit matrix, you can
specify a probability threshold in the Profit Matrix window. For more information about how
values are calculated for the profit matrix, see Using JMP.

Target The level whose probability is modeled.

Probability Threshold A threshold for the probability of the target level. If the probability
that an observation falls into the target level exceeds the probability threshold, the
observation is classified into that level.

When you define costs using the Specify Profit Matrix option and then select Show Fit Details,
a Decision Matrix report appears. See “Decision Matrix Report”.

When you specify a profit matrix and save the model prediction formula, the formula
columns saved to the data table include the following;:

— Profit for <level>: For each level of the response, a column gives the expected profit for
classifying each observation into that level.
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— Most Profitable Prediction for <column name>: For each observation, gives the level of
the response with the highest expected profit.
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— Expected Profit for <column name>: For each observation, gives the expected profit for
the classification defined by the Most Profitable Prediction column.

— Actual Profit for <column name>: For each observation, gives the actual profit for
classifying that observation into the level specified by the Most Profitable Prediction

column.

Decision Matrix Report

Figure 4.14 Fit Details Report with Decision Matrix Report

4 Fit Details
Measure Training Validation Definition
Entropy RSquare 0.3788 0.0367 1-Loglike(model)/Loglike(0)
Generalized RSquare 0.5382 0.0647 (1-(LI0)/Limedel))*(2/n))/(1-LIO) 2/m))
Mean -Log p 0.4124 0.6402 ¥ -Legip[jli/n
RASE 0.3649 0.4684 V F(y[jl-p[)*/n
Mean Abs Dev 0.2854 0.3861 3 [y[jl-eljll/n
Misclassification Rate 0.1915 0.3810 3 (pljlzpMax)/n
N 94 42 n
4 Confusion Matrix
Training Validation
Predicted Predicted
Actual Count Actual Count
Severity High Low Severity High Low
High 46 12 High 15 11
Low 6 30 Low 5 N
4 Decision Matrix
Training Validation Specified Profit Matrix
Decision Decision Decision
Actual Count Actual Count Actual  High Low
Severity High Low Severity High Low High 1 -5
High 51 7 High 20 6 Low -3 1
Low 12 24 Low 6 10
Actual Decision Rate Actual Decision Rate
Severity High Low || Severity High Low
High 0.879 0.121 || High 0.769 0.231
Low 0.333 0.667 || Low 0.375 0.625
Misclassification Misclassification
Rate Rate
0.2021 0.2857

Note: This report is available only if the response has a Profit Matrix column property or if
you specify costs using the Specify Profit Matrix option. The report is part of the Fit Details

report.

When a profit matrix is defined, the partition algorithm uses the values in the matrix to
calculate the profit for each decision. When you select Show Fit Details, a Decision Matrix

report appears.
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In the Decision Matrix report, the decision counts reflect the most profitable prediction
decisions based on the weighting in the profit matrix. The report gives Decision Count and
Decision Rate matrices for the training set and for validation and test sets (if defined). For
reference, the profit matrix is also shown.

Note: If you change the weights in your Profit Matrix using the Specify Profit Matrix option,
the Decision Matrix report automatically updates to reflect your changes.

Decision Count Matrix Shows a two-way classification with actual responses in rows and
classification counts in columns.

Specified Profit Matrix Gives the weights that define the Profit Matrix.

Decision Rate Matrix Shows rate values corresponding to the proportion of a given row’s
observations that are classified into each category. If all observations are correctly
classified, the rates on the diagonal are all equal to one.

Tip: You can obtain a decision rate matrices for a response using the default profit matrix
with costs of 1 and -1. Select Specify Profit Matrix from the red triangle menu, make no
changes to the default values, and click OK.

The matrices are arranged in two rows:

e The Decision Count matrices are in the first row.
e The Specified Profit Matrix is to the right in the first row.

e The Decision Rate matrices are in the second row.

Informative Missing

The Informative Missing option enables informative treatment of missing values on the
predictors. The model that is fit is deterministic. The Informative Missing option is found on
the launch window and is selected by default. When the Informative Missing option is
selected, categorical and continuous predictors are handled differently:

* Rows containing missing values for a categorical predictor are entered into the analysis as
a separate level of the variable.

* Rows containing missing values for a continuous predictor are assigned to a split as
follows: The values of the continuous predictor are sorted. Missing rows are first
considered to be on the low end of the sorted values. All splits are constructed. The
missing rows are then considered to be on the high end of the sorted values. Again, all
splits are constructed. The optimal split is determined using the LogWorth criterion. For
further splits on the given predictor, the algorithm commits the missing rows to high or
low values, as determined by the first split induced by that predictor.
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If the Informative Missing option is not selected, the missing values are handled as follows:

*  When a predictor with missing values is used as a splitting variable, each row with a
missing value on that predictor is randomly assigned to one of the two sides of the split.

* The first time a predictor with missing values is used as a splitting variable an Imputes
column is added to the Summary Report showing the number of imputations. As
additional imputations are made, the Imputes column updates (Figure 4.15), where five
imputations were performed.

Note: The number of Imputes can be greater than the number of rows that contain missing
values. The imputation occurs at each split. A row with missing values can be randomly
assigned multiple times. Each time a row is randomly assigned it increments the
imputation count.

Figure 4.15 Impute Message in Summary Report

Number
RSquare RASE N of Splits AlCc
0445 6.8246278 501 1 33522

Actual by Predicted Plot

For continuous responses, the Actual by Predicted plot is the typical plot of the actual
response versus the predicted response. When you fit a Decision Tree, all observations in a leaf
have the same predicted value. If there are n leaves, then the Actual by Predicted plot shows at
most n distinct predicted values. The actual values form a scatter of points around each leaf
mean on n vertical lines.

The diagonal line is the Y = X line. For a perfect fit, all the points would be on this diagonal.
When validation is used, plots are shown for both the training and the validation sets
(Figure 4.16).

Figure 4.16 Actual by Predicted Plots for a Continuous Response
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Curve

The ROC Curve option is available only for categorical responses. Receiver Operating
Characteristic (ROC) curves display the efficiency of a model’s fitted probabilities in sorting
the response levels. An introduction to ROC curves is found in Basic Analysis.

The predicted response for each observation in a partition model is a value between 0 and 1.
To use the predicted response to classify observations as positive or negative, a cut point is
used. For example, if the cut point is 0.5, an observation with a predicted response at or above
0.5 would be classified as positive, and an observation below 0.5 as negative. There are trade
offs in classification as the cut point is varied.

To generate a ROC curve, each predicted response level is considered as a possible cut point
and the following values are computed for each possible cut point:

* The sensitivity is the proportion of true positives or the percent of positive observations
with a predicted response greater than the cut point.

* The specificity is the proportion of true negatives or the proportion of negative
observations with a predicted response less than the cut point.

The ROC curve plots sensitivity against 1 - specificity. A partition model with n splits has n+1
predicted values. The ROC curve for the partition model has n+1 line segments.

If your response has more than two levels, the Partition report contains a separate ROC curve
for each response level versus the other levels. Each curve is the representation of a level as the
positive response level. If there are only two levels, one curve is the reflection of the other.

Figure 4.17 ROC Curves for a Three Level Response

< Receiver Operating Characteristic
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If the model perfectly rank-orders the response values, then the sorted data contains all of the
positive values first, followed by all of the other values. In this situation, the curve moves all
the way to the top before it moves at all to the right. If the model does not predict well, the
curve follows the diagonal line from the bottom left to top right of the plot.

In practice, the ROC curve lies above the diagonal. The area under the curve is the indicator of
the goodness of fit for the model. A value of 1 indicates a perfect fit and a value near 0.5
indicates that the model cannot discriminate among groups.

When your response has more than two levels, the ROC curve plot enables you to see which
response categories have the largest area under the curve.

Lift Curve

The Lift Curve option provides another plot to display the predictive ability of a partition
model. The lift curve plots the lift versus the portion of the observations. There is a point for
each unique predicted probability value. Each predicted probability of a response level
defines a portion of the observations that have a predicted probability greater than or equal to
the unique predicted probability value. For a particular level of the response, the lift value is
the ratio of the proportion of observed responses in that portion to the overall proportion of
observed responses.

Note: For smaller models, it is possible that a large portion of the points have the same
predicted probability value. If this probability is the highest predicted probability for the
response level, the lift curve does not start at Portion = 0. For example, this is shown in the
Low lift curve in Figure 4.18.

Figure 4.18 Lift Curve

£ Lift Curve

a5 Y Binary
— Low
— High
30

& 25

20

15

1.0
0.00 0.10 0.20 0.30 0.40 0.50 0.60 0.70 0.80 0.90 1.00
Porticn



72

Partition Models Chapter 4
Partition Platform Options Predictive and Specialized Modeling

Figure 4.19 Lift Table for Lift Curve

N> N High Lift = portion high/

Prob High Prob High Portion in Portion Portion High  overall high of .27
0.97 20 0.06 20 1.00 372

0.77 44 0.14 30 0.89 330

0.33 68 0.22 47 0.69 257

031 168 0.54 78 0.46 173

0.04 309 1.00 a3 0.27 1.00

Figure 4.19 provides a table of values to demonstrate the calculation of Lift and Portion used
for the High lift curve shown in Figure 4.18. A partition model with five splits was built to
predict the response, Y Binary. Y Binary has two levels: Low and High. The lift curve is based
on 309 observations. There are 83 observed High responses for an overall rate of 0.27.

* Prob High: The five unique predicted probability values from the partition model for the
High response level.

* N> Prob High: The number of observations that have a predicted probability value equal to
or greater than the value in Prob High.

* Portion: N > Prob High divided by 309, the total number of observations.

¢ N High in Portion: The number of observations in each portion that have an observed High
response.

* Portion High: N High in Portion divided by N > Prob High.

¢ Lift: Portion High divided by 0.27, the overall rate of the observed High response.

Lift measures how many High responses fall in each portion as compared to the expected
number of High responses for that portion. For the first 6% of the data set the lift is 3.72. Using

the model to select the 6% of the observations with the highest predicted values results in 3.72
more High responses than if that 6% were selected at random.

Node Options

This section describes the options on the red triangle menu for each node.
Split Best Finds and executes the best split at or below this node.
Split Here Splits at the selected node on the best column to split by.

Split Specific Lets you specify where a split takes place. This is useful in showing what the
criterion is as a function of the cut point, as well as in determining custom cut points.
When specifying a splitting column, you can choose the following options for how the
split is performed:

Optimal Value Splits at the optimal value of the selected variable.

Specified Value Enables you to specify the level where the split takes place.
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Output Split Table Produces a data table showing all possible splits and their associated
split value.

Prune Below Eliminates the splits below the selected node.
Prune Worst Finds and removes the worst split below the selected node.

Select Rows Selects the data table rows corresponding to this leaf. You can extend the
selection by holding down the Shift key and choosing this command from another node.

Show Details Produces a data table that shows the split criterion for a selected variable. The
data table, composed of split intervals and their associated criterion values, has an
attached script that produces a graph for the criterion.

Lock Prevents a node or its subnodes from being chosen for a split. When checked, a lock
icon appears in the node title.

Validation in Partition

The use of validation with partition models is important given that partition models are easily
overfit. When this happens, the model predicts the data used to build the model very well, but
predicts future observations poorly. Validation is the process of using part of a data set to
estimate model parameters, and using the other part to assess the predictive ability of the
model. For more information about validation, see “Validation in JMP Modeling”.

In Partition, when a validation method is used, the Go button appears. The Go button
provides for repeated splitting without having to repeatedly click the Split button. When you
click the Go button, splitting occurs until the validation RSquare is better than what the next
10 splits would obtain. This rule can result in complex trees that are not very interpretable, but
have good predictive power.

Using the Go button turns on the Split History command. If using the Go button results in a
tree with more than 40 nodes, the Show Tree command is turned off.

Select one of the following validation methods:

Excluded Rows Uses row states to subset the data. Rows that are unexcluded are used as the
training set, and excluded rows are used as the validation set.

For more information about using row states and how to exclude rows, see Using JMP.

Holdback Randomly divides the original data into the training and validation data sets. The
Validation Portion on the platform launch window is used to specify the proportion of the
original data to use as the validation data set (holdback). See “Launch the Partition
Platform” for more information about the Validation Portion.
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‘IJ’I\F{PO Validation Column Uses a numeric column that defines the validation sets. This column
should contain at most three distinct values:

— If the validation column has two levels, the smaller value defines the training set and
the larger value defines the validation set.

— If the validation column has three levels, the values, in order of increasing size, define
the training, validation, and test sets.

— If the validation column has more than three levels, the rows that contain the smallest
three values define the validation sets. All other rows are excluded from the analysis.

If you click the Validation button with no columns selected in the Select Columns list, you
can add a validation column to your data table. For more information about the Make
Validation Column utility, see “Make Validation Column”.

Tip: To use K Fold or Nested K Fold crossvalidation, fit a partition model through the Model
Screening platform. See “Model Screening”.

Additional Examples of Partitioning

¢ “Example of a Continuous Response”
e “Example of Informative Missing”

e “Example of Profit Matrix and Decision Matrix Report”

Example of a Continuous Response

In this example, you use the Partition platform to construct a decision tree that predicts the
one-year disease progression measured on a quantitative scale for patients with diabetes.

Select Help > Sample Data Library and Diabetes.jmp.
Select Analyze > Predictive Modeling > Partition.
Select Y and click Y, Response.

Select Age through Glucose and click X, Factor.

S

Select a validation procedure based on your JMP installation:
— For JMP Pro, select Validation and click Validation.
— For JMP, enter 0.3 as the Validation Portion.

Note: Results using the validation proportion can differ from those shown here due to the
random selection of validation rows.
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Figure 4.20 Completed Launch Window with Validation Portion = 0.3

Builds a decision tree to predict a response.

Select Columns Cast Selected Columns into Roles Action
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6. Click OK.

7. On the platform report window, click Split once to perform a split.
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Figure 4.21 Report after First Split with Decision Tree Hidden
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LTG<4.6444 LTG>=4.6444
All Rows
Split || Prune || Go Number
RSquare RASE N of Splits AlCc
Training 0.289 64.936287 300 1 346215
Validation 0.286 65.018633 133
> All Rows
Count 309 LogWorth Difference
Mean  152.15838 23.842052 83.0524
Std Dev  77.152004
> ILTG<4.6444 ILTG>=4.6444
Count 165 Count 144
Mean  113.45435 Mean  106.50604
Std Dev 57.539112 Std Dev  72.90208
4 Candidates 4 Candidates
Term Candidate 55 LogWorth Cut Point Term Candidate 55 LogWorth Cut Point
Age 84715313 0.194473313 55 Age 18672.7382 0.34630856 40
Gender 11883.5806 1.199803004 2 Gender 0765.1800 0.71825513 2
EMI 1070364015 *  9.638041473 27.3 EMI 1844602628 *  11.16722518 31.6
BP 49452 8063 3.255385840 102 BP 110594.1012 531343981 112
Total Cholesterol  18405.3341 0.743625408 227 Total Cholesterol  14034.4383 0.20662942 171
LDL 46015.1196 2.038400787 1268 LDL 26277.3712 0.61835279 11238
HDL 43884.0040 2.740574144 55 HDL 20670.2079 0.75604004 46
TCH 308585790 1.786470402 4.08 TCH 16782.5089 0.29608360 4
LTG 50273.0167 3.331583548 4.20905 LTG 771581270 3.18049143 5.3423
Glucose 278905035 1420442935 24 Glucose 85802.2760 3.71377476 100

The original 309 values in the training data set are now split into two parts:

— The left leaf, corresponding to LTG < 4.6444, has 165 observations.

— The right leaf, corresponding to LTG >= 4.6444 has 144 observations.

For both the right and left leaf the next split would be on BMI. The Candidate SS for BMI
on the right leaf is higher than the Candidate SS for BMI on the left leaf. Thus, the next
split is on the right leaf.

Click Go to use automatic splitting.
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Figure 4.22 Report after Automatic Splitting with Validation

£ = |Partition for Y

BMI<2 BEMI>=244
4

BMI<27.3 MI>=27] BMI<31.6 BMI>=
3 316

LTG<4.6444 LTG=>=4.6444

All Rows
Split || Prune || Go Number

RSquare RASE N of Splits AlCc
Training 04091 54952824 300 4 336518

Validation 0.396 59.824841 133

< Split History
1.00

0.75

R-Square

0.50 o

0.25

Number of Splits

Validation Data in Red

The solution found has four splits. The Split History plot shows that there is no further
improvement in the validation data set after four splits. The RSquare value of 0.39 on the
validation data does not support this model as a strong predictor of disease progression. The
scatter across partitions in the partition plot further indicate that this model does not separate

the Y levels well.

Example of Informative Missing

In this example, you construct a decision tree model to predict if a customer is a credit risk.
Since your data set contains missing values, you also explore the effectiveness of the

Informative Missing option.
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Launch the Partition Platform

AN

Select Help > Sample Data Library and open Equity.jmp.
Select Analyze > Predictive Modeling > Partition.

Select BAD and click Y, Response.

Select LOAN through DEBTINC and click X, Factor.
Click OK.

Create the Decision Tree and ROC Curve with Informative Missing

1
2
3.
4

Press Shift and click Split.
Enter 5 for the number of splits and click OK.
Click the red triangle next to Partition for BAD and select ROC Curve.

Click the red triangle next to Partition for BAD and select Save Columns > Save
Prediction Formula.

The columns Prob(BAD==Good Risk) and Prob(BAD==Bad Risk) contain the formulas that
Informative Missing utility uses to classify the credit risk of future loan applicants. You are
interested in how this model performs in comparison to a model that does not use
informative missing.

Create the Decision Tree and ROC Curve without Informative Missing

1. Click the red triangle next to Partition for BAD and select Redo > Relaunch Analysis

2. De-select Informative Missing.

3. Click OK and repeat the steps in “Create the Decision Tree and ROC Curve with
Informative Missing”.
The columns Prob(BAD==Good Risk) 2 and Prob(BAD==Bad Risk) 2 contain the formulas
that do not use the informative missing utility.

Compare the ROC Curves

Visually compare the ROC curves from the two models. The model at left is with Informative
Missing, and the model at right is without Informative Missing.
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Figure 4.23 ROC Curves for Models with (Left) and without (Right) Informative Missing

4 Receiver Operating Characteristic 4 Receiver Operating Characteristic
X 1.00
T BAD Area BAD Area
0.90 — Good Risk 0.8695 0.90 — Good Risk 0.7283
— Bad Risk  0.8685 — BadRisk 07283
0.80 0.80
0.70 0.70
2300 »2 08
=k =%
S & 050 % & 050
5 e 5o
2 0.40 Y E 040
0.30 0.30
0.20 0.20
0.10 0.10
0.00 0.00
0.00 0.10 0.20 0.20 0.40 0.50 0.60 0.70 0.80 0.90 1.00 0.00 0.10 0.20 0.20 0.40 0.50 0.60 0.70 0.80 0.90 1.00

1-Specificity 1-Specificity
False Positive False Positive

The area under the curve (AUC) for the model with informative missing (0.8695) is higher
than the AUC for the model without informative missing (0.7283). Because there are only

two levels for the response, the ROC curves for each model are reflections of one another

and the AUCs are equal.

Note: Your AUC can differ from that shown for the model without informative missing.
When informative missing is not used, the assignment of missing rows to sides of a split is
random. Rerunning the analysis can result in slight differences in results.

Use the Model Comparison Platform

Next, compare the models using the Model Comparison platform to compare the two sets of
formulas that you created in step 4 and step 3.

1.
2.

Select Analyze > Predictive Modeling > Model Comparison.

Select Prob(BAD==Good Risk), Prob(BAD==Bad Risk), Prob(BAD==Good Risk) 2, and
Prob(BAD==Bad Risk) 2 and click Y, Predictors.

The first pair of formula columns contains the formulas from the model with informative
missing. The second pair of formula columns contains the formulas from the model
without informative missing.

Click OK.

Figure 4.24 Measures of Fit from Model Comparison

4 Measures of Fit for BAD
Entropy Generalized Mean Misclassification
Creator .2.4.6.8 RSquare RSquare Mean-Logp RMSE Abs Dev Rate N
Partition | | | | 03812 0.5015 03002 03012  0.1817 0.1158 5960
Partition [ § i i 0.1232 0.1834 0.4381 03687 0.2737 01765 5960
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The Measures of Fit report shows that the first model, which was fit with informative
missing, performs better than the second model, which was not fit with informative
missing. The first model has higher RSquare values as well as a lower RMSE value and a
lower Misclassification Rate. These findings align the ROC curves comparison.

Note: Again, your results can differ due to the random differences when Informative
Missing is not used.

Example of Profit Matrix and Decision Matrix Report

For this example, consider a study of patients who have liver cancer. Based on various
measurements and markers, you want to classify patients according to their disease severity
(high or low). There are two errors that one can make in classification of patients: classifying a
subject who has high severity into the low group, or classifying a patient with low severity
into the high group. Clinically, the misclassification of a high patient as low is a costly error, as
that patient might not receive the aggressive treatment needed. Classifying a patient with low
severity into the high severity group is a less costly error. That patient might receive the more
aggressive treatment than needed, but this is not a major concern.

In this example, you define a profit matrix in the context of a liver cancer study and obtain a
Decision Matrix report. The Decision Matrix report helps you assess your classification rates
relative to the costs in your profit matrix.

Select Help > Sample Data Library and open Liver Cancer.jmp.
Select Analyze > Predictive Modeling > Partition.

Select Severity and click Y, Response.

Select BMI through Jaundice and click X, Factor.

S

Select a validation procedure based on your JMP installation:
— For JMP Pro, select Validation and click Validation.
— For JMP, enter 0.3 as the Validation Proportion.

Note: Results using the validation proportion can differ from those shown here, due to the
random selection of validation rows.
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Figure 4.25 Completed Launch Window with Validation Portion = 0.3

Builds a decision tree to predict a response.

Select Columns Cast Selected Columns into Roles Action
™ 9 Columns h severity
dll Mode Count ontiona
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6. Click OK.
7. DPress Shift and click Split.
8. Enter 10 for the number of splits and click OK.
Check that the Number of Splits is 10 in the panel beneath the plot.
9. Click the red triangle next to Partition for Severity and select Specify Profit Matrix.
10. Change the entries to the following values:
— Enter 1 in the High, High box.
— Enter -5 in the High, Low box.
— Enter -3 in the Low, High box.

— Enter 1 in the Low, Low box.

Figure 4.26 Completed Profit Matrix

Decisionor Predidion

|High ||LD\‘." ||Undecided|
ign [ T][ 5] ]
e oy —

Actual

Tip: You can save this profit matrix as a column property for use in later analyses. Select
the check box “Save to column as property” at the bottom of the profit matrix window.
Note the following:

— Each value of 1 reflects your profit when you make a correct decision.

— The -3 value indicates that if you classify a Low severity patient as High severity, your
loss is 3 times as much as the profit of a correct decision.
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— The -5 value indicates that if you classify a High severity patient as Low severity, your
loss is 5 times as much as the profit of a correct decision.

11. Click OK.
12. Click the red triangle next to Partition for Severity and select Show Fit Details.

Figure 4.27 Confusion Matrix and Decision Matrix Reports

4 Fit Details
Measure Training Validation Definition
Entropy RSquare 0.3788 0.0367 1-Loglike(model)/Loglike(0)
Generalized RSquare 0.5382 0.0647 (1-(LI0)/Limedel))*(2/n))/(1-LIO) 2/m))
Mean -Log p 0.4124 0.6402 ¥ -Legip[jli/n
RASE 0.3649 0.4694 v 3(yljl-p[l)n
Mean Abs Dev 0.2854 0.3861 3 [y[jl-eljll/n
Misclassification Rate 0.1915 0.3810 3 (pljlzpMax)/n
N 94 42 n

< Confusion Matrix

Training Validation
Predicted Predicted
Actual Count Actual Count
Severity High Low Severity High Low
High 46 12 High 15 11
Low 6 30 Low 5 N

< Decision Matrix

Training Validation Specified Profit Matrix
Decision Decision Decision
Actual Count Actual Count Actual  High Low
Severity High Low Severity High Low High 1 -5
High 51 7 High 20 6 Low =5 1
Low 12 24 Low 6 10

Actual Decision Rate Actual Decision Rate
Severity High Low || Severity High Low

High 0.879 0.121 || High 0.769 0.231
Low 0.333 0.667 || Low 0.375 0.625
Misclassification Misclassification
Rate Rate
0.2021 0.2857

The Confusion Matrix and Decision Matrix reports follow the list of Measures in the Fit
Details report. Notice that the Confusion Matrix report and the confusion matrices in the
Decision Matrix report show different counts. This is because the weighting in the profit
matrix results in different decisions than do the predicted probabilities without weighting.

The Confusion Matrix for the validation set shows classifications based on predicted
probabilities alone. Based on these, 11 High severity patients would be classified as Low
severity and 5 Low severity patients would be classified as High severity.

The Decision Matrix report incorporates the profit matrix weights. Using those weights,
only 6 High severity patients are classified as Low severity. However, this comes at the
expense of misclassifying 6 Low severity patients into the High severity group (1
additional patient).
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13. Click the red triangle next to Partition for Severity and select Save Columns > Save
Prediction Formula.

Eight columns are added to the data table.

Tip: To quickly return to the data table, click the View Associated Data icon & in the
bottom right corner of the report window (Windows) or the Show Data Table icon on the
tool bar menu (macOS).

— The first three columns involve only the predicted probabilities. The confusion matrix
counts are based on the Most Likely Severity column, which classifies a patient into the
level with the highest predicted probability. These probabilities are given in the
Prob(Severity == High) and Prob(Severity == Low) columns.

— The last five columns involve the profit matrix weighting. The column called
Most Profitable Prediction for Severity contains the decision based on the profit matrix.
The decision for a patient is the level that results in the largest profit. The profits are
given in the Profit for High and Profit for Low columns.

Statistical Details for the Partition Platform

® “Responses and Factors”
e “Splitting Criterion”

e “Predicted Probabilities in Decision Tree and Bootstrap Forest”

Responses and Factors

The response can be either continuous or categorical (nominal or ordinal):

e [f the response is categorical, then it is fitting the probabilities estimated for the response
levels, minimizing the residual log-likelihood chi-square [2*entropy].

¢ If the response is continuous, then the platform fits means, minimizing the sum of squared
errors.

The factors can be either continuous or categorical (nominal or ordinal):

e If the factor is continuous, then the partition is done according to a splitting “cut” value for
the factor.

e If the factor is categorical, then it divides the X categories into two groups of levels and
considers all possible groupings into two levels.
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Splitting Criterion
Node splitting is based on the LogWorth statistic, which is reported in Candidate reports for
nodes. LogWorth is calculated as follows:
-logyg(p-value)

where the adjusted p-value is calculated in a complex manner that takes into account the
number of different ways splits can occur. This calculation is very fair compared to the
unadjusted p-value, which favors Xs with many levels, and the Bonferroni p-value, which
favors Xs with small numbers of levels. Details about the method are discussed in Sall (2002).

For continuous responses, the Sum of Squares (5S) is reported in node reports. This is the
change in the error sum-of-squares due to the split.

A candidate SS that has been chosen is:

SStest = SSparent = (SSright + SSieft) Where SS in a node is just s2(n - 1).

Also reported for continuous responses is the Difference statistic. This is the difference
between the predicted values for the two child nodes of a parent node.

For categorical responses, the G (likelihood ratio chi-square) appears in the report. This is
actually twice the [natural log] entropy or twice the change in the entropy. Entropy is X -log(p)
for each observation, where p is the probability attributed to the response that occurred.

A candidate G2 that has been chosen is:
2 _ 2 2 2
G est=G parent ~ (G et + G right)'

Partition actually has two rates; one used for training that is the usual ratio of count to total,
and another that is slightly biased away from zero. By never having attributed probabilities of
zero, this allows logs of probabilities to be calculated on validation or excluded sets of data,
used in Entropy R-Square.

Predicted Probabilities in Decision Tree and Bootstrap Forest

The predicted probabilities for the Decision Tree and Bootstrap Forest methods are calculated
as described below by the Prob statistic.

For categorical responses in Decision Tree, the Show Split Prob command shows the following
statistics:

Rate The proportion of observations at the node for each response level.

Prob The predicted probability for that node of the tree. The method for calculating Prob for
the it response level at a given node is defined as follows:
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n. + prior,
Prob, = -1 -
Z(ni + prior;)

where the summation is across all response levels; n;is the number of observations at the
node for the i response level; and prior; is the prior probability for the i response level,
calculated as follows:

prior; = Ap;t (1-1)P;

where p; is the prior; from the parent node, P; is the Prob; from the parent node, and A is a
weighting factor currently set at 0.9.

The method for calculating Prob assures that the predicted probabilities are always
nonzero.
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rio Bootstrap Forest
Fit a Model By Averaging Many Trees

The Bootstrap Forest platform is available only in JMP Pro.

The Bootstrap Forest platform fits an ensemble model by averaging many decision trees each
of which is fit to a bootstrap sample of the training data. Each split in each tree considers a
random subset of the predictors. In this way, many weak models are combined to produce a
more powerful model. The final prediction for an observation is the average of the predicted
values for that observation over all the decision trees.

Figure 5.1 Example of a Cumulative Validation Report

4 Cumulative Validation
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w Overview of the Bootstrap Forest Platform

The Bootstrap Forest platform predicts a response value by averaging the predicted response
values across many decision trees. Each tree is grown on a bootstrap sample of the training data.
A bootstrap sample is a random sample of observations, drawn with replacement. In addition,
the predictors are sampled at each split in the decision tree. The decision tree is fit using the
recursive partitioning methodology described in “Partition Models”.

This is the fitting process for the training set:

1. For each tree, select a bootstrap sample of observations.
2. Fit the individual decision tree, using recursive partitioning.
— Select a random set of predictors for each split.

— Continue splitting until a stopping rule that is specified in the Bootstrap Forest
Specification window is met.

3. Repeat step 1 and step 2 until the number of trees specified in the Bootstrap Forest
Specification window is reached or until Early Stopping occurs.

For an individual tree, the bootstrap sample of observations that is used to fit the tree is drawn
with replacement. You can specify the proportion of observations to be sampled. If you specify
that 100% of the observations are to be sampled, because they are drawn with replacement,
the expected proportion of unused observations is 1/e, or approximately 36.8%. For each
individual tree, these unused observations are called the out-of-bag observations. The
observations used in fitting the tree are called in-bag observations. For a continuous response,
the Bootstrap Forest platform provides measures for the error rate for out-of-bag observations,
called out-of-bag error.

For a continuous response, the predicted value for an observation is the average of its
predicted values over the collection of individual trees. For a categorical response, the
predicted probability for an observation is the average of its predicted probabilities over the
collection of individual trees. The observation is classified into the level for which its predicted
probability is the highest.

For more information about bootstrap forests, see Hastie et al. (2009).
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w Example of Bootstrap Forest with a Categorical
Response

In this example, you construct a bootstrap forest model to predict whether a customer is a bad
credit risk. But you are aware that your data set contains missing values, so you also explore
the degree to which values are missing.

o Bootstrap Forest Model

Select Help > Sample Data Library and open Equity.jmp.
Select Analyze > Predictive Modeling > Bootstrap Forest.
Select BAD and click Y, Response.

Select LOAN through DEBTINC and click X, Factor.

Select Validation and click Validation.

Click OK.

Enter 4 next to Number of Terms per Split.

Enter 30 next to Maximum Splits per Tree.

O X N ol W=

Select Multiple Fits over Number of Terms and enter 10 next to Max Number of Terms.

—_
o

. (Optional) Select Suppress Multithreading and enter 123 next to Random Seed.

Because the bootstrap forest method involves random sampling, these actions ensure that
your results are exactly the same as the results shown below.

11. Click OK.
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Figure 5.2 Overall Statistics Report

4 |~ |Bootstrap Forest for BAD
|> Specifications
4 Overall Statistics

Measure Training Validation  Test Definition

Entropy RSquare 0.5124 0.4828 0.4824 1-Loglike(model)/Loglike(0)
Generalized RSquare 0.6302 0.6153 0.6068 (1-(L(0)/L{model)™(2/n))/(1-LIO)"2Z/Mm))
Mean -Log p 0.2354 0.2793 0.2618 ¥ -Leg(p[jli/n

RASE 0.2596 0.2886 0.2771 ¥ ¥(y[jl-p(D)¥n

Mean Abs Dev 0.1580 01779 0.1688 3 y(1-elll/n

Misclassification Rate  0.0898 0.1133 0.0990 3 (p[lzpMax)/n

N 3576 1192 1192 n

4 Confusion Matrix

Training Validation Test

Actual Predicted Count Actual Predicted Count Actual Predicted Count
BAD Good Risk Bad Risk BAD Good Risk Bad Risk BAD Good Risk Bad Risk
Good Risk 2819 86 Good Risk 884 33 Good Risk 921 28
Bad Risk 233 436 Bad Risk 102 173 Bad Risk 90 153

Actual Predicted Rate Actual Predicted Rate Actual Predicted Rate
BAD Good Risk  Bad Risk BAD Good Risk  Bad Risk BAD Good Risk  Bad Risk
Good Risk 0.970 0.030 Good Risk 0.964 0.036 Good Risk 0.970 0.030
Bad Risk 0.350 0.650 Bad Risk 0.371 0.629 Bad Risk 0.370 0.630

Because the Multiple Fits over Number of Terms option was specified, models were
created using 4, 5, 6, 8, and 10 as the number of predictors in each split. The Model
Validation-Set Summaries report shows that the model whose Validation set has the
highest Entropy RSquare is the five-term model. This is also the model with the smallest
misclassification rate. This model is determined to be the best model, and the results in the
Overall report are for this model.

The Overall report shows that the misclassification rates for the Validation and Test sets
are about 11.3% and 9.9%, respectively. The confusion matrices suggest that the largest
source of misclassification is the classification of bad risk customers as good risks.

The results for the Test set give you an indication of how well your model extends to
independent observations. The Validation set was used in selecting the Bootstrap Forest
model. For this reason, the results for the Validation set give a biased indication of how the
model generalizes to independent data.

You are interested in determining which predictors contributed the most to your model.

12. Click the red triangle next to Bootstrap Forest for BAD and select Column Contributions.
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Figure 5.3 Column Contributions Report

£ Column Contributions

Number
Term of Splits
DEBTINC 96
VALUE 20
DELINQ 83
DEROG 77
CLAGE 63
CLNO 55
JCB 50
NING. 51
LOAN 41
MORTDUE 42
A{e]] 40
REASON 13

G"2

Portion

567.182771

] 05456

104.83095 I
102.545002 [0
73.3253058 [ |
54,1092672 [
30.2200294 1
26.1866120 [
24,5238480 [
19.7652555 [1
17.0533251 1
16.3836362 |
3.45680616 |

0.1008
0.0986
0.0705
0.0520
0.0291
0.0252
0.0236
0.0190
0.0164
0.0158
0.0033
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The Column Contributions report suggests that the strongest predictor of a customer’s
credit risk is DEBTINC, which is the debt to income ratio. The next highest contributors to
the model are DELINQ, the number of delinquent credit lines, and VALUE, the assessed
value of the customer.

pio Missing Values

Next, you explore the extent to which predictor values are missing.

1.
2.
3.

Select Analyze > Screening > Explore Missing Values.
Select Bad through DEBTINC and click Y, Columns.
Click OK in the Alert that appears.

The columns REASON and JOB are not added to the Y, Columns list because they have a
Character data type. You can see how many values are missing for these two columns

using Distribution (not illustrated in this example).

Click OK.
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Figure 5.4 Missing Values Report

< |=|Explore Missing Values

4 Commands

Missing Value Report MNumber of missing values for each column
Missing Value Clustering Hierarchical clustering of rows and columns missingness
Missing Value Snapshot Patterns of missing values with graphical map

Multivariate Normal Imputation| Least squares prediction from the nonmissing variables in each row

Multivariate SVD Imputation Imputation for wide problems using a singular value decomposition
with the power-method adapted for missing values

Automated Data Imputation Automatically selects best dimension for low-rank approximation
based on the data and has streaming imputation capabilities

[ Automated Data Imputation Controls

4 Missing Columns

Number

[] Show only columns with missing | Column Missing
LOAN 0
Select columns and choose an action. | pORTDUE 518
Color Cells VALUE 112
Exclude Rows| |Color Rows| e I
DEROG 708
DELINQ 580
CLAGE 308
NINQ 510
CLNO 222
DEBTINC 1267

The DEBTINC column contains 1267 missing values, which amounts to about 21% of the
observations. Most other columns involved in the Bootstrap Forest analysis also contain
missing values. The Informative Missing option in the launch window ensures that the
missing values are treated in a way that acknowledges any information that they carry. See
“Informative Missing”.

x Example of Bootstrap Forest with a Continuous
Response

In this example, you construct a bootstrap forest model to predict the percent body fat for
male subjects.

A A L o R

Select Help > Sample Data Library and open Body Fat.jmp.

Select Analyze > Predictive Modeling > Bootstrap Forest.

Select Percent body fat and click Y, Response.

Select Age (years) through Wrist circumference (cm) and click X, Factor.

Select Validation and click Validation.

Click OK.

(Optional) Select Suppress Multithreading and enter 123 next to Random Seed.

Because the bootstrap forest method involves random sampling, these actions ensure that
your results are exactly the same as the results shown below.
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8. Click OK.

Figure 5.5 Overall Statistics

£ |~ Bootstrap Forest for Percent body fat

< Specifications

Target
Validation Column:

Number of Trees in the Forest:

Number of Terms Sampled per Split:

< Owverall Statistics

Individual

Trees RASE

In Bag 2.025251

OutofBag 5.995064
RSquare RASE

Training 0.802 2.6941446

Validation 0.675 4.9577438

Percent body fat
Validation

100
10

180
72

Training Rows: 180
Validation Rows: 72
Test Rows: 0
Number of Terms: 13
Bootstrap Samples: 180
Minimum Splits per Tree: 10
Minimum Size Split: 5

Chapter 5
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The Overall Statistics report shows that the Validation RSquare is 0.675.

You are interested in obtaining a model-independent indication of the most important

predictors.

9. Click the red triangle next to Bootstrap Forest for Percent body fat and select Column

Contributions.

Figure 5.6 Column Contributions

£ Column Contributions

Term

Abdomen circumference (cm)
Chest circumference (cm)
Age [years)

Knee circumference (cm)
Height {inches)

Wrist circumference (cm)
Thigh circumference (cm)
Weight (lbs)

Hip circumference (cm)
Ankle circumference (cm)
Meck circumference (cm)

Biceps (extended) circumference (cm)

Forearm circumference (cm)

Number
of Splits

55

106 4349.56265

35 700.64626 |
46 287.666673 ||
36 269.801386 ]
44 189,408502 ]
48 171.226028 []
33 164.742015[]
24 147.372437[]
34 114631003 ||
29 101095245 ||
32 94,1033567 ||
27 83.2687719
28 66.0446242 |

Portion
0.6453
0.1039
0.0427
0.0400
0.0281
0.0254
0.0244
0.0219
0.0170
0.0150
0.0140
0.0124
0.0099

The Column Contributions report suggests that Abdomen circumference (cm), Chest
circumference (cm), and Age (years) are the strongest predictors for Percent body fat.
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w Launch the Bootstrap Forest Platform

Launch the Bootstrap Forest platform by selecting Analyze > Predictive Modeling > Bootstrap
Forest.

pro Launch Window

Figure 5.7 Bootstrap Forest Launch Window

Builds a collection of decision trees using random sampling and averages the results
to predict a response.

Select Columns Cast Selected Columns into Roles Action
*114 Columns required
‘BAD opliohac

4o
4 MORTDUE

& fesson s
i JOB optianat
4 o)
4 DEROG

4 DELING optional numeric

4l CLAGE optional mumeric

4 NINg —

4 oo optional numeric

4 DEBTING optiona

ik Validation

Options

Methed | Bagtstrap Forest v

Validation Porticn
Informative Missing
Ordinal Restricts Order

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Bootstrap Forest platform launch provides the following options:

Y, Response The response variable or variables that you want to analyze.

X, Factor The predictor variables.

Weight A column whose numeric values assign a weight to each row in the analysis.
Freq A column whose numeric values assign a frequency to each row in the analysis.

Validation A numeric column that defines the validation sets. This column should contain at
most three distinct values:.

— If the validation column has two levels, the smaller value defines the training set and
the larger value defines the validation set.
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By

— If the validation column has three levels, the values, in order of increasing size, define

the training, validation, and test sets.

— If the validation column has more than three levels, the rows that contain the smallest
three values define the validation sets. All other rows are excluded from the analysis.

The Bootstrap Forest platform uses the validation column to train and tune the model or to
train, tune, and evaluate the model. For more information about validation, see
“Validation in JMP Modeling”.

If you click the Validation button with no columns selected in the Select Columns list, you
can add a validation column to your data table. For more information about the Make
Validation Column utility, see “Make Validation Column”.

A column or columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

Method Enables you to select the partition method (Decision Tree, Bootstrap Forest, Boosted

Tree, K Nearest Neighbors, or Naive Bayes). These alternative methods, except for
Decision Tree, are available in JMP Pro.

For more information about these methods, see “Partition Models”, “Boosted Tree”, “K
Nearest Neighbors”, and “Naive Bayes”.

Validation Portion The portion of the data to be used as the validation set.

Informative Missing If selected, enables missing value categorization for categorical

predictors and informative treatment of missing values for continuous predictors. See
“Informative Missing”.

Ordinal Restricts Order If selected, restricts consideration of splits to those that preserve the

ordering.
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pio Specification Window
After you select OK in the launch window, the Bootstrap Forest Specification window appears.

Figure 5.8 Bootstrap Forest Specification Window

Bootstrap Forest Specification

MNumber of Rows: 252 Multiple Fits
Mumber of Terms: 13 [] Multiple Fits over Mumnber of Terms
Forest Max Mumber of Terms
MNumber of Trees in the Forest L] Use Tuning Design Table
Number of Terms Sampled per Split: Reproducibility
Bootstrap Sample Rate [ Suppress Multithreading
Minimum Splits per Tree: Random Seed
Maximum Splits per Tree
Minimum Size Split:

Early Stopping

JMP .
PRO Specification Panel
Number of Rows The number of rows in the data table.

Number of Terms The number of columns that are specified as predictors.

i’wll{o Forest Panel

Number of Trees in the Forest The number of trees to grow and then average.

Number of Terms Sampled per Split The number of predictors to consider as splitting
candidates at each split. For each split, a new random sample of predictors is taken as the
candidate set.

Bootstrap Sample Rate The proportion of observations to sample (with replacement) for
growing each tree. A new random sample is generated for each tree.

Minimum Splits Per Tree The minimum number of splits for each tree.
Maximum Splits Per Tree The maximum number of splits for each tree.
Minimum Size Split The minimum number of observations needed on a candidate split.

Early Stopping (Available only if validation is used.) If selected, the process stops growing
additional trees if the additional trees do not improve the validation statistic. The
validation statistic is the validation set’s Entropy RSquare value for a categorical response
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and its RSquare value for a continuous response. If not selected, the process continues
until the specified number of trees is reached.

i’wll{o Multiple Fits Panel

Multiple Fits over Number of Terms If selected, creates a bootstrap forest for several values

of number of terms sampled per split. The model for which results are displayed is the
model whose Validation Set’s Entropy RSquare value (for a categorical response) or
RSquare (for a continuous response) is the largest.

The lower bound is the Number of Terms Sampled per Split specification. The upper
bound is specified by the following option:

Max Number of Terms The maximum number of terms to consider for a split.

Use Tuning Table Design Opens a window where you can select a data table containing

values for the Forest panel tuning parameters, called a tuning design table. A tuning design
table has a column for each option that you want to specify and has one or multiple rows
that each represent a single Bootstrap Forest model design. If an option is not specified in
the tuning design table, the default value is used.

For each row in the table, JMP creates a Bootstrap Forest model using the tuning
parameters specified. If more than one model is specified in the tuning design table, the
Model Validation-Set Summaries report lists the RSquare value for each model. The
Bootstrap Forest report shows the fit statistics for the model with the largest RSquare
value.

You can create a tuning design table using the Design of Experiments facilities. A
bootstrap forest tuning design table can contain the following case-insensitive columns in
any order:

— Number Trees

— Number Terms

— Portion Bootstrap

— Minimum Splits per Tree
— Maximum Splits per Tree

— Minimum Size Split

f’wllipo Reproducibility Panel

Suppress Multithreading If selected, all calculations are performed on a single thread.

Random Seed Specify a nonzero numeric random seed to reproduce the results for future

launches of the platform. By default, the Random Seed is set to zero, which does not
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produce reproducible results. When you save the analysis to a script, the random seed that
you enter is saved to the script.

w The Bootstrap Forest Report

After you click OK in the Bootstrap Forest Specification window, a window appears that
informs you of approximately how long it will take JMP to fit the model. If the approximated
time is too long, you have the option to view the current model by selecting Accept Current
Model. The Bootstrap Forest report appears after the complete model is fit or after the current
model is accepted.

Figure 5.9 Accept Current Model Dialog

IMP Progress @

Bootstrap Forest
Bootstrap Forest. 7 seconds left

00:04

Accept Current Model |

Figure 5.10 Bootstrap Forest Report for a Categorical Response

£ |~ Bootstrap Forest for BAD
| Specifications
4 Overall Statistics

Measure Training Validation Test Definition

Entropy RSquare 0.5124 0.4828 0.4824 1-Loglike{model)/Loglike(0)
Generalized RSquare 0.6302 0.6153 0.6068 (1-(L{0)/L(madel))"(2/n))/(1-LIO)"2/r)
Mean -Log p 0.2334 0.2793 0.2618 ¥ -Logip[ili/n

RASE 0.2596 0.2886 0.2771  Zly[jl-pl)¥/n

Mean Abs Dev 0.1580 0.1779 0.1688 3 [y[jl-e[ll/n

Misclassification Rate 0.0898 0.1133 0.0990 ¥ (p[jlzpMax)/n

N 3576 1192 1192 n

< Confusion Matrix

Training Validation Test

Actual Predicted Count Actual Predicted Count Actual Predicted Count
BAD Good Risk Bad Risk BAD Good Risk Bad Risk BAD Good Risk Bad Risk
Good Risk 2819 86 Good Risk 854 33 Good Risk 921 28
Bad Risk 235 436 Bad Risk 102 173 Bad Risk a0 153

Actual Predicted Rate Actual Predicted Rate Actual Predicted Rate
BAD Good Risk Bad Risk BAD Good Risk Bad Risk BAD Good Risk Bad Risk
Good Risk 0.970 0.030 Good Risk 0.964 0.036 Good Risk 0.970 0.030

Bad Risk 0.350 0.650 Bad Risk 0.371 0.629 Bad Risk 0.370 0.630
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Figure 5.11 Bootstrap Forest Report for a Continuous Response

£ |~ Bootstrap Forest for Percent body fat
< Specifications

Target Percent body fat Training Rows: 180
Validation Column: Validation Validation Rows: 72
Test Rows: 0
Number of Trees in the Forest: 100 Number of Terms: 13
Number of Terms Sampled per Split: 10 Bootstrap Samples: 180
Minimum Splits per Tree: 10
Minimum Size Split: 5

< Owverall Statistics

Individual
Trees RASE
In Bag 2.025251
OutofBag 5.995064
RSquare RASE N
Training 0.802 26941446 180

Validation 0.675 4.9577438 72

The following reports are provided, depending on whether the response is categorical or
continuous:

“Model Validation-Set Summaries”
® “Specifications”

e “Overall Statistics”

e “Cumulative Validation”

e  “Per-Tree Summaries”

po Model Validation-Set Summaries
(Available when you select the Multiple Fits over Number of Terms option in Bootstrap Forest

Specification window.) Provides fit statistics for all the models fit. See Figure 5.10 and
“Multiple Fits Panel”.

pio Specifications

Shows the settings used in fitting the model.

po Overall Statistics

Provides fit statistics for the training set, and for the validation and test sets if they are
specified. The specific form of the report depends on the modeling type of the response.
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Suppose that multiple models are fit using the Multiple Fits over Multiple Terms option in the
Bootstrap Forest Specification window. Then the model for which results are displayed in the
Overall Statistics and Cumulative Validation reports is the model for which the validation set’s
Entropy RSquare value (for a categorical response) or RSquare (for a continuous response) is
the largest.

Pro Categorical Response

Measures Report

Gives the following statistics for the training set, and for the validation and test sets if they are
specified.

Note: For Entropy RSquare and Generalized RSquare, values closer to 1 indicate a better fit.
For Mean -Log p, RASE, Mean Abs Dev, and Misclassification Rate, smaller values indicate a
better fit.

Entropy RSquare A measure of fit that compares the log-likelihoods from the fitted model
and the constant probability model. It ranges from 0 to 1. See “Entropy RSquare”.

Generalized RSquare A measure that can be applied to general regression models. It is
based on the likelihood function L and is scaled to have a maximum value of 1. The value
is 1 for a perfect model, and 0 for a model no better than a constant model. The
Generalized RSquare measure simplifies to the traditional RSquare for continuous normal
responses in the standard least squares setting. Generalized RSquare is also known as the
Nagelkerke or Craig and Uhler R2, which is a normalized version of Cox and Snell’s
pseudo R2.

Mean -Log P The average of negative log(p), where p is the fitted probability associated with
the event that occurred.

RASE The root average squared prediction error. The differences are between 1 and p, the
fitted probability for the response level that actually occurred.

Mean Abs Dev The average of the absolute values of the differences between the response
and the predicted response. The differences are between 1 and p, the fitted probability for
the response level that actually occurred.

Misclassification Rate The rate for which the response category with the highest fitted
probability is not the observed category.

N The number of observations.
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Confusion Matrix Report

(Available only for categorical responses.) Shows classification statistics for the training set,
and for the validation and test sets if they are specified. The Confusion Matrix Report contains
confusion matrices and confusion rates matrices. A confusion matrix is a two-way
classification of actual and predicted responses. A confusion rates matrix is equal to the
confusion matrix, with the numbers divided by the row totals.

Decision Matrix

(Available only for categorical responses and if the response has a Profit Matrix column
property or if you specify costs using the Specify Profit Matrix option.) Gives Decision Count
and Decision Rate matrices for the training set, and for the validation and test sets if they are
specified. See “Additional Examples of Partitioning”.

Continuous Response

Individual Trees Report

Gives RASE values, which are averaged over all trees, for In Bag and Out of Bag observations.
Training set observations that are used to construct a tree are called in-bag observations.
Training observations that are not used to construct a tree are called out-of-bag (OOB)
observations.

For each tree, the Out of Bag RASE is computed as the square root of the sum of squared
errors divided by the number of OOB observations. The squared Out of Bag RASE for each
tree is given in the Per-Tree Summaries report as OOB SSE/N.

RSquare and RASE Report

Gives Rsquare, root average squared prediction error, and the number of observations for the
training set, and for the validation and test sets, if they are defined.

Cumulative Validation

(Available only if validation is used.) Shows a plot of the fit statistics for the Validation set
versus the number of trees.

For a continuous response, the single fit statistic is R-Square. For a categorical response, the fit
statistics are listed below and are described in “Measures Report”.

® RSquare (Entropy RSquare)
e Avg-Logp (Mean-Logp)
* Root Average Squared Prediction Error (RASE)
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® Avg Abs Error (Mean Abs Dev)
¢ MR (Misclassification Rate)

The Cumulative Details report below the Cumulative Validation plot gives the values used in
the plot.

bo Per-Tree Summaries

The Per-Tree Summaries report involves the concepts of in-bag and out-of-bag observations.
For an individual tree, the bootstrap sample of observations used in fitting the tree is drawn
with replacement. Even if you specify that 100% of the observations are to be sampled,
because they are drawn with replacement, the expected proportion of unused observations is
1/e. For each individual tree, the unused observations are called the out-of-bag observations.
The observations used in fitting the tree are called in-bag observations.

The Per-Tree Summaries report shows the following summary statistics for each tree:
Splits The number of splits in the decision tree.

Rank The rank of the tree’s OOB Loss in ascending order. The tree with the smallest OOB
loss has Rank 1.

OOB Loss A measure of the total predictive inaccuracy of the tree when applied to the Out
Of Bag rows. Lower values indicate a higher predictive accuracy.

0O0B Loss/N The OOB Loss divided by the number of OOB rows, OOB N.
RSquare (Available only for continuous responses.) The RSquare value for the tree.
IB SSE (Available only for continuous responses.) Sum of squared errors for the In Bag rows.

IB SSE/N (Available only for continuous responses.) Sum of squared errors for the In Bag
rows divided by the number of In Bag observations. The number of In Bag observations is
equal to the number of observations in the training set multiplied by the bootstrap
sampling rate that you specify in the Bootstrap Forest Specification window.

OOB N (Available only for continuous responses.) The number of Out Of Bag rows.

OOB SSE (Available only for continuous responses.) Sum of squared errors when the tree is
applied to the Out Of Bag rows.

OOB SSE/N (Available only for continuous responses.) The OOB SSE divided by the number
of OOB rows, OOB N.
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w Bootstrap Forest Platform Options

The Bootstrap Forest red triangle menu contains the following options:

Plot Actual by Predicted (Available only for continuous responses.) Provides a plot of actual
versus predicted values.

Column Contributions Displays a report that shows each input column’s contribution to the
fit. The report also shows:

— The total number of instances over all of the trees when the specified column is used to
split the data.

— The total G? (for a categorical response) or SS, sum of squares (for a continuous
response), attributed to the column.

—  Abar chart of G or SS.
— The proportion of G2 or SS attributed to the column.

Show Trees Provides various options for displaying trees in the Tree Views report. The
report gives a picture of the tree that is fit at each layer of the boosting process. For a
description of the Prob column shown by the Show names categories estimates option, see
“Predicted Probabilities in Decision Tree and Bootstrap Forest”.

ROC Curve (Available only for categorical responses.) See “ROC Curve”.

Lift Curve (Available only for categorical responses.) See “Lift Curve”.

Save Columns Contains options for saving model and tree results, and creating SAS code.
Save Predicteds Saves the predicted values from the model to the data table.

Save Prediction Formula Saves the prediction formula to a column in the data table. The
formula consists of nested conditional clauses that describe the tree structure. If the
response is continuous, the column contains a Predicting property. If the response is
categorical, the column contains a Response Probability property.

Save Tolerant Prediction Formula (The Save Prediction Formula option should be used
instead of this option. Use this option only when Save Prediction Formula is not
available.) Saves a formula that predicts even when there are missing values and when
Informative Missing has not been selected. The prediction formula tolerates missing
values by randomly allocating response values for missing predictors to a split. If the
response is continuous, the column contains a Predicting property. If the response is
categorical, the column contains a Response Probability property. If you have selected
Informative Missing, you can save the Tolerant Prediction Formula by holding the Shift
key as you click the report’s red triangle.
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Save Residuals (Available only for continuous responses.) Saves the residuals to the data
table.

Save Cumulative Details (Available only if validation is used.) Creates a data table
containing the fit statistics for each tree.

Publish Prediction Formula Creates a prediction formula and saves it as a formula
column script in the Formula Depot platform. If a Formula Depot report is not open,
this option creates a Formula Depot report. See “Formula Depot”.

Publish Tolerant Prediction Formula (The Publish Prediction Formula option should be
used instead of this option. Use this option only when Publish Prediction Formula is
not available.) Creates a tolerant prediction formula and saves it as a formula column
script in the Formula Depot platform. If a Formula Depot report is not open, this option
creates a Formula Depot report. See “Formula Depot”. If you have selected Informative
Missing, you can use this option by holding the Shift key as you click the report’s red
triangle.

Make SAS DATA Step Creates SAS code for scoring a new data set.

Specify Profit Matrix (Available only for categorical responses.) Enables you to specify profit
or costs associated with correct or incorrect classification decisions. See “Show Fit Details”.

Profiler Shows a Prediction Profiler. See Profilers.

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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Chapter 6

to Boosted Tree
Fit Many Layers of Trees, Each Based on the Previous Layer

The Boosted Tree platform is available only in JMP Pro.

Boosting is the process of building a large, additive decision tree by fitting a sequence of
smaller decision trees, called layers. The tree at each layer consists of a small number of splits.
The tree is fit based on the residuals of the previous layers, which allows each layer to correct
the fit for bad fitting data from the previous layers. The final prediction for an observation is
the sum of the predictions for that observation over all of the layers.

Figure 6.1 Example of Boosted Tree Layers

4 Layer2

All Rows
Count LogWorth
431 10499219

solvent pct<50 not Missing solvent pct>=50 or Missing
Count Estimate Count LogWorth
382 0027177 49 8.2092846

chrome content<100 or Missing ||chrome content>=100 not Missing
Count Estimate Count Estimate
8 -0.582872 41 -0.58569
4Layer3
All Rows
Count LogWorth
431 54954427
ESA Amperage<0 or Missing ESA Amperage>=0 not Missing
Count Estimate Count LogWorth
46 -0.551098 385 57251324

[ |
press type(Albert70, WoodHoe70) ||press type(Motter70, Motter94)
Count Estimate Count Estimate
178 -0.028508 207 0.0742558
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o, Overview of the Boosted Tree Platform

The Boosted Tree platform produces an additive decision tree model that is based on many
smaller decision trees that are constructed in layers. The tree in each layer consists of a small
number of splits, typically five or fewer. Each layer is fit using the recursive fitting
methodology described in “Partition Models”. The only difference is that fitting stops at a
specified number of splits. For a given tree, the predicted value for an observation in a leaf is
the mean of all observations in that leaf.

This is the fitting process:

1. Fit an initial layer.

2. Compute residuals. These are obtained by subtracting the predicted mean for observations
within a leaf from their actual value.

Fit a layer to the residuals.

4. Construct the additive tree. For a given observation, sum its predicted values over the
layers.

5. Repeat step 2 to step 4 until the specified number of layers is reached, or, if validation is
used, until fitting an additional layer no longer improves the validation statistic.

The final prediction is the sum of the predictions for an observation over all the layers.
By fitting successive layers on residuals from previous layers, each layer can improve the fit.

For categorical responses, only those with two response levels are supported. For a categorical
response, the residuals fit at each layer are offsets of linear logits. The final prediction is a
logistic transformation of the sum of the linear logits over all the layers.

For more information about boosted trees, see Hastie et al. (2009).

o Example of Boosted Tree with a Categorical
Response

In this example, you construct a boosted tree model to predict which printing jobs are affected
by a defect called banding.

1. Select Help > Sample Data and open Bands Data.jmp.
2. Select Analyze > Predictive Modeling > Boosted Tree.
3. Select Banding? and click Y, Response.

4. Select the Predictors column group and click X, Factor.
5. Enter 0.2 for Validation Portion.
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6. Click OK.

The Boosted Tree Specification window appears.

7. (Optional) In the Reproducibility panel, select Suppress Multithreading and enter 123 for
Random Seed.

Because the boosted tree fit involves a random component, these actions ensure that you
obtain the exact results shown below.

8. Click OK.

Figure 6.2 Overall Statistics for Nominal Response

< Owverall Statistics

Measure Training Validation Definition

Entropy RSquare 0.7103 0.3299 1-Loglike(model)/Loglike(0)
Generalized RSquare 0.8340 0.4803 (1-(LI0)/Limedel))*(2/n))/(1-LIO) 2/m))
Mean -Log p 0.1985 0.4383 7 -Legip[jli/n

RASE 0.2196 0.3801 v (yljl-p[l)¥n

Mean Abs Dev 0.1650 0.2828 3 [y[jl-e[jll/n

Misclassification Rate 0.0232 0.1832 3 (pljlzpMax)/n

N 43 108 n

< Confusion Matrix

Training Validation

Actual  Predicted Count Actual  Predicted Count
Banding? band band Banding? band band
band 179 9 band 22 17
noband 1 242 noband 3 66

Actual Predicted Rate Actual Predicted Rate
Banding? band band Banding? band band
band 0.952 0.048 band 0.564 0.436

noband 0.004 0.996 noband 0.043 0.957

Because the response, Banding?, is categorical, the Boosted Tree analysis provides a
Misclassification Rate under Measure and a Confusion Matrix report. The
Misclassification Rate for the validation set is 0.1852, or about 19%.

9. Click the red triangle next to Boosted Tree for Banding? and select Show Trees > Show

names categories estimates.

A Tree Views report appears, with outlines for the layers. You can examine the layers to
see the trees that are fit and the predicted values.
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Example of Boosted Tree with a Continuous Response

Figure 6.3 Layer 1 of the Boosted Tree

4 Layer1

All Rows
Count LogWorth
431 21.603031

I
[ 1
solvent pct<50 not Missing solvent pct>=50 or Missing
Count LogWorth Count LogWorth
382 65001711 49 16.793498
I I
I | [ |
press type(Albert70, WoodHoe70) press type(Motter70, Motter94) wax<2.4 or Missing wax>=2.4 not Missing
Count Estimate Count LogWorth Count Estimate Count LogWorth
177 0015145 205 11056017 19 -0.44004 30 9.7830619

I
[ 1
grain screened(YES,) | grain screened(NO) wax>=2.6 not Missing

Count Estimate Count  Estimate Count Estimate
81 -0.002277 124 0.1123969 8 -0.438711

wax<2.6 or Missing
Count LogWorth
22 69616173

!—k—\

proof cut<45 not Missing || proof cut>=45 or Missing
Count Estimate Count Estimate
6 -0.437952 16 -0.439858

10. Click the red triangle next to Boosted Tree for Banding? and select Save Columns > Save
Prediction Formula.

Columns called Prob(Banding?==noband), Prob(Banding?==band), and Most Likely
Banding? are added to the data table. Examine the Prob(Banding?==noband) column to see
how model predictions are calculated from the layers.

JVP
PRO

Response

Example of Boosted Tree with a Continuous

In this example, you construct a boosted tree model to predict the percent body fat given a
combination of nominal and continuous factors.

N o gl L=

Select Help > Sample Data and open the Body Fat.jmp sample data table.

Select Analyze > Predictive Modeling > Boosted Tree.

Select Percent body fat and click Y, Response.

Select Age (years) through Wrist circumference (cm) and click X, Factor.

Select Validation and click Validation.

Click OK.
Click OK.
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Figure 6.4 Overall Statistics for Continuous Response

< Owverall Statistics

RSquare RASE N
Training 0.843 32012478 180
Validation 0.611 54301412 72

The Overall Statistics report provides the R-square and RASE for the boosted tree model.
The R-square for the validation set is 0.611. The RASE for the validation set is about 5.43.

You are interested in obtaining a model-independent indication of the important
predictors for Percent body fat.

8. Click the red triangle next to Boosted Tree for Percent body fat and select Profiler.

9. Click the red triangle next to Prediction Profiler and select Assess Variable Importance >
Independent Uniform Inputs.

Note: Because Assess Variable Importance uses randomization, your results might not
exactly match those in Figure 6.5.

Figure 6.5 Summary Report for Variable Importance

< Summary Report

Column Main Effect Total Effect .2 4 6 8
Abdomen circumference (cm) 0.865 0.854
Age (years) 0.085 0.084 ]
Wrist circumference (cm) 0.005 0.01 |
Hip circumference (cm) 0.004 0.007
Biceps (extended) circumference (cm) 0.003 0.005
Chest circumference (cm) 0.002 0.004
Ankle circumference (cm) 0.002 0.003
Height {inches) 0.001 0.002
Weight (lbs) 0.001 0.002
Thigh circumference (cm) 0.001 0.002
Knee circumference (cm) 0.001 0.001
Meck circumference (cm) Oe-18 2e-17
Forearm circumference (cm) Oe-18 2e-17

The Summary Report shows that Abdomen circumference (cm) is the most important
predictor of Percent body fat.



Chapter 6 Boosted Tree 113
Predictive and Specialized Modeling Launch the Boosted Tree Platform

w Launch the Boosted Tree Platform

Launch the Boosted Tree platform by selecting Analyze > Predictive Modeling > Boosted Tree.

Figure 6.6 Boosted Tree Launch Window Using Body Fat.jmp

Builds a decision tree that is a sequence of smaller trees to predict a response,

Select Columns Cast Selected Columns into Roles Action
Z26/60K o requied
Enter column name Pl optional

A Percent body fat
A Age (years)

A Weight (Ibs) required

dl Height (inches)

.l Meck circumference (cm)
A Chest circumference (cm)
d Abdomen circumference {cm) =

A Hip circumference (cm) c

V'l Thigh circumference (cm)

A Knee circumference (cm)

A Ankde circumference (cm)

V'l Biceps (extended) circumference (cm)
A Forearm circumference (cm)

M Wrist circumference (cm)

[> Prediction Fermulas (11/0)

th Validation

Options

Methed | Boosted Tree <

Validation Portion
Informative Missing
Ordinal Restricts Order

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Boosted Tree platform launch window has the following options:

Y, Response The response variable or variables that you want to analyze.

X, Factor The predictor variables.

Weight A column whose numeric values assign a weight to each row in the analysis.
Freq A column whose numeric values assign a frequency to each row in the analysis.

Validation A numeric column that defines the validation sets. This column should contain at
most three distinct values:

— If the validation column has two levels, the smaller value defines the training set and
the larger value defines the validation set.
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By

— If the validation column has three levels, the values, in order of increasing size, define
the training, validation, and test sets.

— If the validation column has more than three levels, the rows that contain the smallest
three values define the validation sets. All other rows are excluded from the analysis.

The Boosted Tree platform uses the validation column to train and tune the model or to
train, tune, and evaluate the model. For more information about validation, see
“Validation in JMP Modeling”.

If you click the Validation button with no columns selected in the Select Columns list, you
can add a validation column to your data table. For more information about the Make
Validation Column utility, see “Make Validation Column”.

A column or columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

Method Enables you to select the partition method (Decision Tree, Bootstrap Forest, Boosted

Tree, K Nearest Neighbors, or Naive Bayes). These alternative methods, except for
Decision Tree, are available in JMP Pro.

For more information about these methods, see “Partition Models”, “Bootstrap Forest”, “K
Nearest Neighbors”, and “Naive Bayes”.

Validation Portion The portion of the data to be used as the validation set.

Informative Missing If selected, enables missing value categorization for categorical

predictors and informative treatment of missing values for continuous predictors. See
“Informative Missing”.

Ordinal Restricts Order If selected, restricts consideration of splits to those that preserve the

ordering.
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pio Specification Window

After you select OK in the launch window, the Gradient-Boosted Trees Specification window
appears.

Figure 6.7 Boosted Tree Specification Window
Gradient-Boosted Trees Specification

Boosting

Multiple Fits
Mumber of Layers: [] Multiple Fits over Splits and Learning Rate
Splits per Tree: Max Splits Per Tree
Learning Rate: Max Learning Rate
Minimur Size Solt [ Use Tuning Design Table

Stochastic Boosting Reproducibility

Row Sampling Rate 1.0000 Suppress Multithreading
Column Sampling Rate [1.0000 Random SEEdljl

Early Stopping

i’wll{o Boosting Panel

Number of Layers The maximum number of layers to include in the final tree.
Splits per Tree The number of splits for each layer.

Learning Rate A number such that 0 <r < 1. Learning rates close to 1 result in faster
convergence on a final tree, but also have a higher tendency to overfit data. Use learning
rates closer to 1 when a small Number of Layers is specified. The learning rate is a small
fraction typically between 0.01 and 0.1 that slows the convergence of the model. This
preserves opportunities for later layers to use different splits than the earlier layers.

Overfit Penalty (Available only for categorical responses.) A biasing parameter that helps
protect against fitting probabilities equal to zero.See “Overfit Penalty”.

Minimum Size Split The minimum number of observations needed on a candidate split.

f’“‘l{o Multiple Fits Panel

Multiple Fits over Splits and Learning Rate If selected, creates a boosted tree for every
combination of Splits per Tree (in integer increments) and Learning Rate (in 0.1
increments).

The lower bounds for the combinations are specified by the Splits per Tree and Learning

Rate options. The upper bounds for the combinations are specified by the following
options:
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Max Splits per Tree Upper bound for Splits per Tree.
Max Learning Rate Lower bound for Learning Rate.

Use Tuning Design Table Opens a window where you can select a data table containing
values for some tuning parameters, called a tuning design table. A tuning design table has a
column for each option that you want to specify and has one or multiple rows that each
represent a single Boosted Tree model design. If an option is not specified in the tuning
design table, the default value is used.

For each row in the table, JMP creates a Boosted Tree model using the tuning parameters
specified. If more than one model is specified in the tuning design table, the Model
Validation-Set Summaries report lists the R-Square value for each model. The Boosted Tree
report shows the fit statistics for the model with the largest R-Square value.

You can create a tuning design table using the Design of Experiments facilities. A boosted
tree tuning design table can contain the following case-insensitive columns in any order:

— Number of Layers
— Splits per Tree

— Learning Rate

— Minimum Size Split
— Row Sampling Rate

— Column Sampling Rate

f’“ﬁpo Stochastic Boosting Panel

Row Sampling Rate Proportion of training rows to sample for each layer.

Note: When the response is categorical, the training rows are sampled using stratified
random sampling.

Column Sampling Rate Proportion of predictor columns to sample for each layer.

JmPp o s
PRO Reproducibility Panel
Suppress Multithreading If selected, all calculations are performed on a single thread.

Random Seed Specify a nonzero numeric random seed to reproduce the results for future
launches of the platform. By default, the Random Seed is set to zero, which does not
produce reproducible results. When you save the analysis to a script, the random seed that
you enter is saved to the script.
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f’wlg,o Early Stopping

Early Stopping If selected, the boosting process stops fitting additional layers when the
additional layers do not improve the validation statistic. If not selected, the boosting
process continues until the specified number of layers is reached. This option appears only
if validation is used.

o The Boosted Tree Report

After you click OK in the Gradient-Boosted Trees Specification window, the Boosted Tree
report opens.

Figure 6.8 Boosted Tree Report for a Continuous Response

4 = Boosted Tree for Percent body fat

4Model Validation-Set Summaries
The fitbelow was the best of these models fit.

Learning Row Column Minimum
N Splits Rate Sampling Rate Sampling Rate N Layers Size Split RSquare RMSE
3 0.1 1 1 30 5 0.6034 5.4804
4 01 1 1 31 5 0.6160 5.3920
5 0.1 1 1 26 5 0.6215 5.3533
3 0.2 1 1 35 5 0.6074 54522
4 0.2 1 1 20 5 0.6146 54023
5 0.2 1 1 20 5 0.5931 5.5508
4 Specifications
Target Column: Percent body fat Number of training rows: 180
Validation Column: Validation Number of validation rows: 72
Number of Layers: 26
Splits per Tree: 5
Learning Rate: 01

4 Overall Statistics

RSquare RMSE N
Training 0.864 3.0203083 180
Validation 0622 53533415 72

4 Cumulative Validation
1.00

0.75

050

RSquare Validation

0.25

0.00
0 5 10 15 20 25
Number of Layers
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Figure 6.9 Boosted Tree Report for a Categorical Response

< |=|Boosted Tree for Banding?

< Specifications

Target Banding? Number of training rows: 431

Number of Layers: 50 Number of validation rows: 108

Splits per Tree: 3

Leaming Rate: 01

Overfit Penalty: 0.0001

< Overall Statistics

Measure Training Validation Definition
Entropy RSquare 0.5032 0.2871 1-Loglike{model)/Loglike{C)
Generalized RSquare 0.6678 0.4291 (1-(L{0)/L{model)) *(2/n))/(1-LO)2/r])
Mean -Log p 0.3403 0.4663 3 -Log(p[jl)/n
RASE 0.3202 0.3910  Ziy[j1-ell)¥/n
Mean Abs Dev 0.2604 0.3248 3 |y[il-p[ll/n
Misclassification Rate 0.1230 0.2222 3 (p[jlzpMax)/n
N 431 108 n

< Confusion Matrix

Training

Actual  Predicted Count
Banding? band noband
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235

band 143
noband 8

Actual  Predicted Rate
Banding? band noband

band 0.761
noband 0.033

0.239
0.967

4 Cumulative Validation

1.00

RSquare Validation

20
Number of Layers

Validation
Actual  Predicted Count

Banding? band noband
band 22 17
noband 7 62

Actual  Predicted Rate
Banding? band noband
band 0.564 0.436
noband 0.101 0.899

30 40
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Rsqu
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The following reports are provided, depending on whether the response is categorical or

continuous:

e  “Model Validation - Set Summaries”

® “Specifications”

e “Qverall Statistics”

e “Cumulative Validation”

Model Validation - Set Summaries

Shows fit statistics for all the models fit if you selected the Multiple Fits over Splits and
Learning Rate option in the Specification window. See Figure 6.8 and “Multiple Fits Panel”.
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pio Specifications

Shows the settings used in fitting the model.

Pho Overall Statistics

Shows fit statistics for the training set, and for the validation and test sets if they are specified.

Suppose that you fit multiple models using the Multiple Fits over Splits and Learning Rate
option in the Boosted Tree Specification window. Then the model for which results are
displayed in the Overall Statistics and Cumulative Validation reports is the model for which
the validation set’s Entropy R-square value (for a categorical response) or R-square (for a
continuous response) is the largest.

#’NII{PO Measures Report

(Available only for categorical responses.) Gives the following statistics for the training set,
and for the validation and test sets if they are specified.

Note: For Entropy R-Square and Generalized R-Square, values closer to 1 indicate a better fit.
For Mean -Log p, RASE, Mean Abs Dev, and Misclassification Rate, smaller values indicate a
better fit.

Entropy RSquare A measure of fit that compares the log-likelihoods from the fitted model
and the constant probability model. It ranges from 0 to 1. See “Entropy RSquare”.

Generalized RSquare A measure that can be applied to general regression models. It is
based on the likelihood function L and is scaled to have a maximum value of 1. The value
is 1 for a perfect model, and 0 for a model no better than a constant model. The
Generalized R-Square measure simplifies to the traditional R-Square for continuous
normal responses in the standard least squares setting. Generalized R-Square is also
known as the Nagelkerke or Craig and Uhler R?, which is a normalized version of Cox and
Snell’s pseudo R,

Mean -Log P The average of negative log(p), where p is the fitted probability associated with
the event that occurred.

RASE The root average squared prediction error. The differences are between 1 and p, the
fitted probability for the response level that actually occurred.

Mean Abs Dev The average of the absolute values of the differences between the response
and the predicted response. The differences are between 1 and p, the fitted probability for
the response level that actually occurred.
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Misclassification Rate The rate for which the response category with the highest fitted
probability is not the observed category.

N The number of observations.

f"ﬂ’o Confusion Matrix Report

(Available only for categorical responses.) Shows classification statistics for the training set,
and for the validation and test sets if they are specified. The Confusion Matrix Report contains
confusion matrices and confusion rates matrices. A confusion matrix is a two-way
classification of actual and predicted responses. A confusion rates matrix is equal to the
confusion matrix, with the numbers divided by the row totals.

JMP .. .
PRO Decision Matrix

(Available only for categorical responses and if the response has a Profit Matrix column
property or if you specify costs using the Specify Profit Matrix option.) Gives Decision Count
and Decision Rate matrices for the training set, and for the validation and test sets if they are
specified. See “Additional Examples of Partitioning”.

pro Cumulative Validation

(Available only if validation is used.) Shows a plot of the fit statistics for the Validation set
versus the number of layers.

For a continuous response, the single fit statistic is R-Square. For a categorical response, the fit
statistics are listed below and are described in “Measures Report”.

¢ R-Square (Entropy R-Square)

e Avg-Logp (Mean - Log p)

* Root Average Squared Prediction Error (RASE)
® Avg Abs Error (Mean Abs Dev)

¢ MR (Misclassification Rate)

The Cumulative Details report below the Cumulative Validation plot gives the values used in
the plot.



Chapter 6

Boosted Tree 121

Predictive and Specialized Modeling Boosted Tree Platform Options

i, Boosted Tree Platform Options

The Boosted Tree red triangle menu contains the following options:

Show Trees Provides options for displaying trees in the Tree Views report. The report gives
a picture of the tree that is fit at each layer of the boosting process.

Plot Actual by Predicted (Available only for continuous responses.) Provides a plot of actual
versus predicted values.

Column Contributions Displays a report showing each input column’s contribution to the fit.
The report also shows:

The total number of instances over all of the trees when the specified column is used to
split the data.

The total G (for a categorical response) or SS, sum of squares (for a continuous
response) attributed to the column.

A bar chart of G or SS.
The proportion of G2 or SS attributed to the column.

ROC Curve (Available only for categorical responses.) See “ROC Curve”.

Lift Curve (Available only for categorical responses.) See “Lift Curve”.

Save Columns Contains options for saving model and tree results, and creating SAS code.

Save Predicteds Saves the predicted values from the model to the data table.

Save Prediction Formula Saves the prediction formula to a column in the data table. The

formula consists of nested conditional clauses that describe the tree structure. If the
response is continuous, the column contains a Predicting column property. If the
response is categorical, the column contains a Response Probability column property.

Save Tolerant Prediction Formula (The Save Prediction Formula option should be used

instead of this option. Use this option only when Save Prediction Formula is not
available.) Saves a formula that predicts even when there are missing values and when
Informative Missing has not been selected. The prediction formula tolerates missing
values by randomly allocating response values for missing predictors to a split. If the
response is continuous, the column contains a Predicting column property. If the
response is categorical, the column contains a Response Probability column property. If
you have selected Informative Missing, you can save the Tolerant Prediction Formula
by holding the Shift key as you click the report’s red triangle.

Save Residuals (Available only for continuous responses.) Saves the residuals to the data

table.
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Save Offset Estimates (Available only for categorical responses.) Saves the sums of the
linear components. These are the logits of the fitted probabilities.

Save Tree Details Creates a data table containing split details and estimates for each
layer.

Save Cumulative Details (Available only if validation is used.) Creates a data table
containing the fit statistics for each layer.

Publish Prediction Formula Creates a prediction formula and saves it as a formula
column script in the Formula Depot platform. If a Formula Depot report is not open,
this option creates a Formula Depot report. See “Formula Depot”.

Publish Tolerant Prediction Formula (The Publish Prediction Formula option should be
used instead of this option. Use this option only when Publish Prediction Formula is
not available.) Creates a tolerant prediction formula and saves it as a formula column
script in the Formula Depot platform. If a Formula Depot report is not open, this option
creates a Formula Depot report. See “Formula Depot”. If you have selected Informative
Missing, you can use this option by holding the Shift key as you click the report’s red
triangle.

Make SAS DATA Step Creates SAS code for scoring a new data set.

Specify Profit Matrix (Available only for categorical responses.) Enables you to specify profit
or costs associated with correct or incorrect classification decisions. See “Show Fit Details”.

Profiler Shows a Prediction Profiler. See Profilers.
See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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o, Statistical Details for the Boosted Tree Platform

This section describes details specific to the Boosted Tree Platform. For statistical details about
recursive decision trees, see “Statistical Details for the Partition Platform”.

pro Overfit Penalty

When the response is categorical, a parametric penalty is imposed. For each layer, the
estimates minimize the negative log-likelihood plus the penalty value multiplied by the sum
of squares of the estimates for each observation. This penalty encourages each new layer not
to overfit the training data.
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o K Nearest Neighbors
Predict Response Values Using Nearby Observations

The K Nearest Neighbors platform is available only in JMP Pro.

The K Nearest Neighbors platform predicts a response value for a given observation using the
responses of the observations in that observation’s local neighborhood. It can be used for
classification of a categorical response as well as for prediction of a continuous response.

K Nearest Neighbors is a nonparametric method that is based on the distance to neighboring
observations. Because of this fact, K Nearest Neighbors is able to classify observations using
irregular predictor value boundaries. However, because the algorithm is sensitive to irrelevant
predictors, the selection of predictors can impact your results.

K Nearest Neighbors has been used successfully in many applications, such as classifying

satellite imagery and electrocardiogram (EKG) patterns.

Figure 7.1 Example of the K Nearest Neighbors Platform

4 =K Nearest Neighbors

4 ~|BAD
4 Model Selection
ClT Legend
— Validation
0.16 ——Training
2
5 014
=
o
Son
3
% 0.10
=
0.08
0.06
0 2 4 6 8 10
K
4 Training 4 Validation A Test
Misclassification Misclassification Misclassification
K Count RSquare Rate Misclassifications K Count RSquare Rate Misclassifications K Count RSquare Rate Misclassifications
1 2576 040794 0.06432 230 * 1 1192 045576 0.07131 85 * 11192 045615 0.05789 69 *
2 3576 0.45873 0.08865 317 2 1192 0.48262 0.10319 123 2 1192 0.48144 0.08725 104
B 3576 044273 0.10263 367 3 1192 0.46421 0.12248 146 3 1192 0.45726 0.10738 128
4 3576 0.42115 0.11270 403 4 1192 0.42626 0.13674 163 4 1192 0.43075 0.11997 142
5 3576 038727 0.12724 435 3 1192 0.40776 0.14597 174 3 1192 0.40738 0.13003 133
13 3576 0.25814 0.13758 492 6 1192 0.38201 0.15352 183 [ 1192 0.28816 0.14178 169
7 3576 0.33587 0.13870 496 7 1192 0.3576 0.16527 197 7 1192 0.35063 0.14597 174
8 3576 031932 0.13982 500 8 1192 032988 0.17030 203 8 1192 033321 0.14849 177
9 3576 0.29532 0.14178 507 9 1192 0.32025 0.16946 202 9 1192 0.21376 0.15017 179
10 3576 0.27695 0.14290 511 10 1192 0.30289 0.17534 209 10 1192 0.30543 0.15436 184
4 Confusion Matrix for Best K=1
4 Training 4 Validation ATest
Actual Predicted Count Actual Predicted Count Actual Predicted Count
BAD GoodRisk BadRisk | | BAD GoodRisk BadRisk | | BAD Good Risk Bad Risk
Good Risk 2894 i Good Risk 917 0 Good Risk 949 0
Bad Risk 219 452 | | Bad Risk 85 190| | Bad Risk 69 174
Actual Predicted Rate Actual Predicted Rate Actual Predicted Rate
BAD Good Risk Bad Risk BAD Good Risk Bad Risk BAD Good Risk Bad Risk
Good Risk 0.9% 0.004 Good Risk 1.000 0.000 Good Risk 1.000 0.000

Bad Risk 0.326 0.674 Bad Risk 0.309 0.691 Bad Risk 0.284 0.716
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Overview of the K Nearest Neighbors Platform

The K Nearest Neighbors platform predicts a response value based on the responses of the k
nearest neighbors. The k nearest neighbors to a given observation are determined by
identifying the k smallest Euclidean distances between the predictor values for that
observation and the predictor values for each of the other observations. The K Nearest
Neighbors platform models both continuous and categorical responses.

A potential drawback of the k nearest neighbors method is that for large scale problems, the
prediction formula is often complex and hard to interpret, limiting its usefulness. In addition,
K Nearest Neighbors does not calculate probabilities for categorical responses. For more
information about the k nearest neighbors method, see Hastie et al. (2009), Hand et al. (2001),
and Shmueli et al. (2017).

Continuous Responses

For a continuous response, the predicted value is the average of the responses for the k nearest
neighbors. Each continuous predictor is scaled by its standard deviation. With this scaling, a
single predictor with a large range does not excessively influence the distance calculation.
Missing values for a continuous predictor are replaced by the mean of that predictor. See
“Example of K Nearest Neighbors with Continuous Response”.

Categorical Responses

For a categorical response, the predicted value is the most frequent response level for the k
nearest neighbors. If two or more levels are tied as the most frequent levels, the predicted
response is assigned by selecting one of these levels at random.

Note: Because ties for most frequent levels in the case of a categorical response are broken at
random, results from independent runs of the platform might differ. To obtain reproducible
results, use the Set Random Seed option in the launch window or include the Set Random
Seed() function in a JSL script.

In the categorical prediction models, each categorical predictor is expressed in terms of
indicator variables, with one indicator variable representing each level. A row with a missing
value for a categorical predictor is represented by values of zero on all indicator variables for
that predictor.
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w Example of K Nearest Neighbors with Categorical
Response

You have historical financial data for 5,960 customers who applied for home equity loans.
Each customer was classified as being a Good Risk or Bad Risk. There are missing values for
many of the predictors. You want to construct a model to use in classifying the credit risk of
future customers.

1
2
3.
4

Select Help > Sample Data Library and open Equity.jmp.
Select Analyze > Predictive Modeling > K Nearest Neighbors.
Select BAD and click Y, Response.

Select LOAN through CLNO and click X, Factor.

Because one of the potential predictors, DEBTINC, has many missing values, you do not
include it in your model. Missing values for continuous predictors are replaced by the
average of the predictor. This procedure sometimes works well for values that are missing
at random. Although the high missing rate of the DEBINC indicates that the missing
might be informative, we do not investigate that in this example.

Select Validation and click Validation.
Click OK.
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Example of K Nearest Neighbors with Categorical Response

Figure 7.2 K Nearest Neighbors Report
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For each value of K, JMP constructs a model using only the training set observations. Each
of these models is used to classify the validation set observations. The validation set results
are used to select a best model. In this example, the model based on the single nearest
neighbor (K = 1) has the smallest misclassification rate. The test set verifies that the single
nearest neighbor model is the best performer for independent data.

7. Click the BAD red triangle and select Publish Prediction Formula.
Next to Number of Neighbors, K, leave the default value of 1.
9. Click OK.

The prediction equation is saved in the Formula Depot. You can compare the performance
of alternative models published to the Formula Depot with that of the K =1 nearest
neighbor model using the Model Comparison option in the Formula Depot. See “Formula
Depot”.
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w Example of K Nearest Neighbors with Continuous
Response

In this example, you want to predict the percent body fat for males using 13 predictors. The
Body Fat.jmp sample data table contains percent body fat estimates that are based on
underwater weighing and on various body circumference measurements.

Select Help > Sample Data Library and open Body Fat.jmp.

Select Analyze > Predictive Modeling > K Nearest Neighbors.

Select Percent body fat and click Y, Response.

Select Age (years) through Wrist circumference (cm) and click X, Factor.
Select Validation and click Validation.

Click OK.

Click the Percent body fat red triangle and select Plot Actual by Predicted.

N o ok =
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Figure 7.3 K Nearest Neighbors Report

4 =K Nearest Neighbors

<4 =|Percent body fat
4 Model Selection

80

]

70

RASE

65
60
5.5

5.0
0

4 Training
K Count
1 180
180
180
180
180
180
180
180
9 180
10 180

@ - o W

RSquare
035772
053615
0.54629
0.56861

0.5824
0.60348
0.59602
0.60651
058352

05847

4 Actual by Predicted Plot

4 Training
50

40

30

20

Percent body fat

The K = 8 model had the lowest RASE for the validation set. Among k nearest neighbor

10

SSE
Trvzn
5612.94
5400.23
5220.16
5053.22

47982
487747
476153

40187
490448

20

*

4 Validation

K
1

2
3
4
5
]
T
8
a9
0

1

30

Count
72
72
72
72
72
72
72
72
72
72

Percent body fat Predicted

K Nearest Neighbors

Example of K Nearest Neighbors with Continuous Response

RSquare
0.18717
0.42182
0.53234
0.57693
0.57138
0.57974
0.58002

0.5938
0.57761
0.57982

40

Legend

= Validation

—Training

RASE
7.8433
6.6167
5.9508
5.6600
5.6957
5.6412
5.6392
5.5460
5.6555
5.6406

< Validation

50

SSE

443150
315224
254060
230650
233573
220128
228968

221461 *

230280
229081

Percent bady fat

50

40

30

20

30 40 50

Percent body fat Predicted

131

models, the model based on 8 nearest neighbors seems to perform the best. The Actual by
Predicted plot for the training set shows that the points fall along the line, signifying that
the predicted values are similar to the actual values. Most of the points on the plot for the
validation set fall along the line, with a few observations on the upper end that are a bit

farther away.
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a Launch the K Nearest Neighbors Platform

Launch the K Nearest Neighbors platform by selecting Analyze > Predictive Modeling >
K Nearest Neighbors.

Figure 7.4 K Nearest Neighbors Launch Window
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For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The K Nearest Neighbors launch window provides the following options:

Y, Response The response variable or variables that you want to analyze.

Note: The K Nearest Neighbors platform can be used as a utility to determine the
distances between neighboring observations, even without the presence of a response
variable. If you do not specify a response variable, a blank report appears. However, the
red triangle menu options Save Near Neighbor Rows and Save Near Neighbor Distances
are available.

X, Factor The predictor variables.

Validation A numeric column that defines the validation sets. This column should contain at
most three distinct values:

— If the validation column has two levels, the smaller value defines the training set and
the larger value defines the validation set.
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By

— If the validation column has three levels, the values, in order of increasing size, define
the training, validation, and test sets.

— If the validation column has more than three levels, the rows that contain the smallest
three values define the validation sets. All other rows are excluded from the analysis.

The K Nearest Neighbors platform uses the validation column to train and tune the model
or to train, tune, and evaluate the model. For more information about validation, see
“Validation in JMP Modeling”.

If you click the Validation button with no columns selected in the Select Columns list, you
can add a validation column to your data table. For more information about the Make
Validation Column utility, see “Make Validation Column”.

A column or columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

Validation Portion The portion of the data to be used as the validation set.

Number of Neighbors, K Maximum number of nearest neighbors to analyze. Models are fit

for one nearest neighbor up to the value that you specify for K.

Note: The maximum number of neighbors, K, must be no larger than one less than the
number of rows in the training data table. If you specify a K that is larger than the
maximum allowable K, a warning appears.

Category Bias Specifies a tuning parameter that ensures that the fitted probabilities for

categorical responses are always positive. By default, the Category Bias is 0.5.

Set Random Seed Sets the seed for the randomization process used in tie-breaking for

nominal and ordinal responses. If you specify a Validation Portion, this option also sets the
seed for the rows used for validation. Set Random Seed is useful if you want to reproduce
an analysis. If you set a random seed and save the script, the seed is automatically saved in
the script.
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u The K Nearest Neighbors Report

The K Nearest Neighbors report contains a separate report for each response variable. Each
response variable report contains information about the fitted model for that response. This
information includes a Model Selection report and summary information for each of the k
models that were fit. The report shows tables for the training set and for the validation and
test sets if you defined these using validation.

The Model Selection report displays a solution path plot across K based on the
Misclassification Rate for categorical responses or the RASE for continuous responses. By
default, the slider is placed on the value of K that corresponds to the best performing model.
You can drag the slider to change the value of K in the report.

The statistics reported depend on the modeling type of the response. Each row in the
summary tables corresponds to a model defined by k nearest neighbors, where K ranges from
one to the value that you specified as Number of Neighbors, K in the launch window.

pio Continuous Responses

By default, in addition to the Model Selection graph, the report for a continuous response
contains the Summary Table report.

Summary Table

An asterisk marks the model for the value of K that has the smallest RASE. The report for a
continuous response contains the following columns:

K Number of nearest neighbors used in the model. K ranges from 1 to the Number of
Neighbors, K that you specified in the launch window.

Count Number of observations.
RSquare The RSquare value for the model.

RASE Root mean average squared prediction error for the model. The model with the
smallest RASE is marked with an asterisk. If there are tied RASE values, the model with
the smallest K is marked with the asterisk.

SSE Sum of squared errors for the model.
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Categorical Responses

By default, in addition to the Model Selection graph, the report for a categorical response
contains the Summary Table, Confusion Matrix, and Mosaic Plot reports.

Summary Table

An asterisk marks the model for the value of K that has the smallest misclassification rate. The
report for a categorical response contains the following columns:

K Number of nearest neighbors used in the model. K ranges from 1 to the Number of
Neighbors, K that you specified in the launch window.

Count Number of observations.

Misclassification Rate Proportion of observations misclassified by the model. This is
calculated as Misclassifications divided by Count. The model with the smallest
misclassification rate is marked with an asterisk. If there are tied misclassification rates,
the model with the smallest K is marked with the asterisk.

Misclassifications Number of observations that are incorrectly predicted by the model.

Confusion Matrix

By default, a Confusion Matrix Report is shown for the model with the smallest
Misclassification Rate. If there are ties for the smallest misclassification rate, a report is shown
for the model with the smallest K. The Confusion Matrix Report contains confusion matrices
and confusion rates matrices. A confusion matrix is a two-way classification of actual and
predicted responses. A confusion rates matrix is equal to the confusion matrix, with the
numbers divided by the row totals. If you use validation, confusion matrices and confusion
rates matrices for the validation and test sets appear. Use the Confusion Matrix Report and the
misclassification rates to evaluate your model.

Tip: If you change the position of the slider in the solution path plot, an additional Confusion
Matrix Report is displayed for the chosen value of K. Use the additional report to compare an
alternative model to the default best model.

Mosaic Plot

By default, a mosaic plot is shown for the model with the smallest Misclassification Rate. If
there are ties for the smallest misclassification rate, a mosaic plot is shown for the model with
the smallest K. A mosaic plot is a stacked bar chart where each segment is proportional to its
group’s frequency count. For more information about mosaic plots, see Basic Analysis. If you
use validation, mosaic plots for the validation and test sets are shown.
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Tip: If you change the position of the slider in the solution path plot, the mosaic plot updates
to display the results for the chosen value of K.

w K Nearest Neighbors Platform Options

The K Nearest Neighbors red triangle menu contains the following options:

Save Near Neighbor Rows Saves K columns to the data table. The columns are named
RowNear <k>. For a given row, the k' column contains the row number of its k' nearest
neighbor.

Caution: The row numbers in the columns RowNear <k> do not update when you reorder
the rows in your data table. If you reorder the rows, the values in those columns are
incorrect.

Save Near Neighbor Distances Saves K columns to the data table. The columns are named
Distance <k>. For a given row, the k! column contains the distance to that row’s k' nearest
neighbor.

See Using J[MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Model Fit Options

Mosaic Plot (Available only for nominal or ordinal responses.) Shows or hides the mosaic
plot. See “Mosaic Plot”.

Plot Actual by Predicted (Available only for continuous responses.) Plots the actual versus
the predicted responses for the model with the smallest RASE. If there are ties for the
smallest RASE, the plot is based on the model with the smallest K.



Chapter 7 K Nearest Neighbors 137
Predictive and Specialized Modeling K Nearest Neighbors Platform Options

Tip: If you change the position of the slider on the solution path plot to a different K, the
Actual by Predicted plot is updated to reflect the model for the chosen value of K.

Plot Residual by Predicted (Available only for continuous responses.) Plots the residuals
versus the predicted responses for the model with the smallest RASE. If there are ties for
the smallest RASE, the plot is based on the model with the smallest K.

Tip: If you change the position of the slider on the solution path plot to a different K, the
Residual by Predicted plot is updated to reflect the model for the chosen value of K.

Save Predicteds Saves K predicted value columns to the data table. The columns are named
Predicted <Response> <k>. The k' column contains predictions for the model based on the
k nearest neighbors, where Response is the name of the response column.

Save Prediction Formula Saves a column that contains a prediction formula for a specific k
nearest neighbor model. Enter a value for K when prompted. The prediction formula
contains all the training data, so this option might not be practical for large data tables.

Caution: The values obtained from Save Prediction Formula and Save Predicteds do not
necessarily match. The values obtained from the Save Prediction Formula option use all of
the rows in the training set, including the row for the predicted value. The values from the
Save Predicteds option do not use the row for the predicted value in the training set, only
all other rows.

Publish Prediction Formula Creates a prediction formula for the specified k nearest neighbor
model and saves it as a formula column script in the Formula Depot platform. If a Formula
Depot report is not open, this option creates a Formula Depot report. See “Formula
Depot”.
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Chapter 8

sio Naive Bayes

Classify Observations Using Probabilistic Assumptions

The Naive Bayes platform is available only in JMP Pro.

The Naive Bayes platform fits a model to predict the value of a categorical variable. Naive
Bayes is a fast and computationally simple method. It is especially suitable for situations
where there are a large number of predictors.

Figure 8.1 Example of Naive Bayes Analysis
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w Overview of the Naive Bayes Platform

The Naive Bayes platform classifies observations into classes that are defined by the levels of a
categorical response variable. The variables (or factors) that are used for classification are
often called features in the data mining literature.

For each class, the naive Bayes algorithm computes the conditional probability of each feature
value occurring. If a feature is continuous, its conditional marginal density is estimated. The
naive Bayes technique assumes that, within a class, the features are independent. (This is the
reason that the technique is referred to as “naive”.) Classification is based on the idea that an
observation whose feature values have high conditional probabilities within a certain class has
a high probability of belonging to that class. See Hastie et al. (2009).

Because the algorithm estimates only one-dimensional densities or distributions, the
algorithm is extremely fast. This makes it suitable for large data sets, and in particular, data
sets with large numbers of features. All nonmissing feature values for an observation are used
in calculating the conditional probabilities.

Each observation is assigned a naive score for each class. An observation’s naive score for a
given class is the proportion of training observations that belong to that class multiplied by
the product of the observation’s conditional probabilities. The naive probability that an
observation belongs to a class is its naive score for that class divided by the sum of its naive
scores across all classes. The observation is assigned to the class for which it has the highest
naive probability.

Caution: Because the conditional probabilities of class membership are assumed
independent, the naive Bayes estimated probabilities are inefficient.

Naive Bayes requires a large number of training observations to ensure representation for all
predictor values and classes. If an observation in the Validation set is being classified and it
has a categorical predictor value that was missing in the Training set, then the platform uses
the non-missing features to predict. If an observation is missing all predictor values, the
predicted response is the most frequent response. The prediction formulas handle missing
values by having them contribute nothing to the observation’s score.

For more information about the naive Bayes technique, see Hand et al. (2001), and Shmueli et
al. (2010).
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w Example of Naive Bayes

You want to construct a classification model to be used in predicting the disease progression
for future patients as High or Low. You have baseline medical data for 442 diabetic patients.
You also have a binary measure of diabetes disease progression obtained one year after each
patient’s initial visit. This measure quantifies disease progression as being either Low or High.

AN

Select Help > Sample Data Library and open Diabetes.jmp.
Select Analyze > Predictive Modeling > Naive Bayes.
Select Y Binary and click Y, Response.

Select Age through Glucose and click X, Factor.

Select Validation and click Validation.

Click OK.

Figure 8.2 Naive Bayes Report
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The Training Set has about a 21% misclassification rate and the Validation Set has about a
24% misclassification rate. The Confusion matrix suggests that, for both the Training and
Validation sets, the larger source of misclassification comes from classifying patients with
Low disease progression as having High disease progression. The Validation set results
indicate how your model extends to independent observations.

You are interested in which individual predictors have the greatest impact on the naive
Bayes classification.

Click the Naive Bayes red triangle and select Profiler.
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Figure 8.3 Prediction Profiler for Disease Progression
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Click the Prediction Profiler red triangle and select Assess Variable Importance >
Independent Uniform Inputs.

Figure 8.4 Variable Importance
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The Summary Report indicates that HDL, BMI, and LTG have the greatest impact on the
estimated probabilities.

Figure 8.5 Marginal Model Plots Report
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The second row of plots in the Marginal Model Plots report shows that higher values of
HDL are associated with a lower probability of classifying a patient as High. Also, higher
BMI and LTG values are associated with a higher probability of classifying a patient as
High.
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a Launch the Naive Bayes Platform

Launch the Naive Bayes platform by selecting Analyze > Predictive Modeling > Naive Bayes.

Figure 8.6 Naive Bayes Launch Window
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For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Naive Bayes launch window provides the following options:

Y, Response The categorical response column whose values are the classes of interest.
X, Factor Categorical or continuous predictor columns.

Weight A column whose numeric values assign a weight to each row in the analysis.
Freq A column whose numeric values assign a frequency to each row in the analysis.

Validation A numeric column that defines the validation sets. This column should contain at
most three distinct values:

— If the column has three unique values, then:
rows with the smallest value are used for the Training set.
rows with the middle value are used for the Validation set.
rows with the largest value are used for the Test set.
— If the column has two unique values, then only Training and Validation sets are used.

— If the validation column has more than three levels, the rows that contain the smallest
three values define the validation sets. All other rows are excluded from the analysis.
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The Naive Bayes platform uses the validation column to train and evaluate the model. For

more information about validation, see “Validation in JMP Modeling”.

If you click the Validation button with no columns selected in the Select Columns list, you

can add a validation column to your data table. For more information about the Make
Validation Column utility, see “Make Validation Column”.

By A column or columns whose levels define separate analyses. For each level of the

specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate analysis is produced for each possible combination of the levels of

the By variables.

Validation Portion The portion of the data to be used as the Validation set.

Note: If neither a Validation column or a Validation Portion is specified in the launch window
and if there are excluded rows, these rows are treated as a Validation set. For more

information about validation see “Validation in JMP Modeling”.

u The Naive Bayes Report

After you click OK in the launch window, the Naive Bayes report appears. By default, the

Naive Bayes report contains reports for fit details, the response column, the Confusion Matrix

Report, and the ROC and Lift curves.

Figure 8.7 Naive Bayes Report
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ptio Fit Details Report

The Fit Details report shows various measures of fit for the model for the Training set, and for
the Validation and Test sets if they are specified. The Measure column lists the different fit
statistics and the Definition column shows the formulas for the corresponding fit statistics. See
“Measures of Fit for Categorical Responses”. By default, the Fit Details report in the Naive
Bayes report window is closed.

ptio Response Column Report

The response column report shows performance statistics for the naive Bayes classification in
a summary table for the Training set, and the Validation and Test sets if they are specified. The
summary tables contain the following columns:

Count The number of observations in the set corresponding to the table (Training,
Validation, or Test set).

Misclassification Rate Proportion of observations in the corresponding set that are
misclassified by the model. This is calculated as Misclassifications divided by Count.

Misclassifications The number of observations in the corresponding set that are classified
incorrectly.

piio Confusion Matrix Report

The Confusion Matrix Report shows a confusion matrix and a confusion rates matrix for the
Training set, and for the Validation and Test sets if they are specified. A confusion matrix is a
two-way classification of actual and predicted responses. A confusion rates matrix is equal to
the confusion matrix, with the numbers divided by the row totals.

ptio ROC Curves

The report displays the Receiver Operating Characteristic (ROC) curve for the Training set,
and for the Validation and Test sets if they are specified. The ROC curve measures the ability
of the fitted probabilities to classify response levels correctly. The further the curve from the
diagonal, the better the fit. An introduction to ROC curves is found in Basic Analysis.

See “ROC Curve” for more information about ROC curves.
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w Naive Bayes Platform Options

The Naive Bayes red triangle menu contains the following options:

ROC Curve Shows or hides the ROC plot. The ROC plot is shown by default. See “ROC
Curves”.

Lift Curve Shows or hides the lift curve for the model. If you used validation, Lift curve is
shown for each of the Training, Validation, and Test sets, if specified.

A lift curve shows how effectively response levels are classified as their fitted probabilities
decrease. The fitted probabilities are plotted along the horizontal axis in descending order.
The vertical coordinate for a fitted probability is the proportion of correct classifications
for that probability or higher, divided by the overall correct classification rate. Use the lift
curve to see whether you can correctly classify a large proportion of observations if you
select only those with a fitted probability that exceeds a threshold value.

If the response has two levels, the Lift curve plot displays a lift curve for the first level of
the response only. If the response has more than two levels, the Lift curve plot displays a
sub-outline of the curves for each response level. See “Lift Curve” for more information
about lift curves.

Save Predicteds Saves the predicted classifications to the data table in a column called
Naive Predicted <Y, Response>.

Save Prediction Formula Saves a column called Naive Predicted Formula <Y, Response> to
the data table. This column contains the prediction formula for the classifications.

Save Probability Formula Saves columns to the data table that contain formulas used for
classifying each observation. Three groups of columns are saved:

Naive Score <Class>, Sum For each column that represents a class, this column gives a
score formula that measures strength of membership in the given class. In the Naive
Score Sum column., these scores are summed across classes. See “Saved Probability
Formulas”.

Naive Prob <Class> For each class, this column gives a formula for the conditional
probability that an observation is in that class. See “Saved Probability Formulas”.

Naive Predicted Formula <Y, Response> Gives the formula for the predicted class.

Publish Probability Formula Creates probability formulas and saves them as formula
column scripts in the Formula Depot platform. If a Formula Depot report is not open, this
option opens the Formula Depot window. See “Formula Depot”.

Profiler Shows or hides an interactive profiler report. Changes in the factor values are
reflected in the estimated classification probabilities. See Profilers.
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See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

JMP

PRO

Additional Example of Naive Bayes

You have historical financial data for 5,960 customers who applied for home equity loans.
Each customer was classified as being a Good Risk or Bad Risk. There is missing data on most
of the predictors. You want to construct a model to use in classifying the credit risk of future
customers.

1. Select Help > Sample Data Library and open Equity.jmp.

2. Select Analyze > Predictive Modeling > Naive Bayes.

3. Select BAD and click Y, Response.

One of the potential predictors, DEBTINC, has many missing values that might be
informative. However, naive Bayes is not prepared to handle large number of missing
values well, so you do not include DEBTINC in your model.

4. Select LOAN through CLNO and click X, Factor.
Select Validation and click Validation.
6. Click OK.
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Figure 8.8 Naive Bayes Report for BAD

4 BAD
4 Training 4 Validation 4 Test
Misclassification Misclassification Misclassification
Count Rate Misclassifications Count Rate Misclassifications Count Rate Misclassifications

3576 0.18009 644 1192 0.19128 228 1192 0.18960 226
<4 Confusion Matrix

4 Training 4 Validation 4ATest

Actual  Predicted Count Actual  Predicted Count Actual  Predicted Count
BAD Good Risk Bad Risk | | BAD Good Risk BadRisk | | BAD Good Risk  Bad Risk
Good Risk 2691 214 Good Risk 859 58 Good Risk 885 64
Bad Risk 430 241 Bad Risk 170 105| | Bad Risk 162 81

Actual Predicted Rate Actual Predicted Rate Actual Predicted Rate
BAD Good Risk Bad Risk | | BAD Good Risk BadRisk | | BAD Good Risk  Bad Risk
Good Risk 0.926 0.074 Good Risk 0.937 0.063 Good Risk 0.932 0.067
Bad Risk 0.641 0.359| | Bad Risk 0.618 0.382 | |BadRisk 0.667 0.333

The Training, Validation, and Test sets show misclassification rates between 18% and 19%.
The confusion matrices for all of the sets suggest that the largest source of misclassification
is the classification of Bad Risk customers as Good Risk customers.

You are interested in the probabilities that customers with certain financial background
values are classified as High Risk.

7. Click the Naive Bayes red triangle and select Save Probability Formulas.
Three sets of columns are added to the data table.

— The three Naive Score columns contain naive score formulas for Good Risk, Bad Risk,
and the sum of both.

— The two Naive Prob columns contain probability formulas for Good Risk and Bad Risk.

— The Naive Predicted Formula Bad column contains a formula that assigns an
observation to the class for which the observation has the highest naive probability.

Use these formulas to score new customers. For more information about the formula
columns, see “Saved Probability Formulas”.

we Statistical Details for the Naive Bayes Platform

e “Algorithm”

e “Saved Probability Formulas”
ptio Algorithm
The naive Bayes method classifies an observation into the class for which its probability of

membership, given the values of its features, is highest. The method assumes that the features
are conditionally independent within each class.
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Denote the possible classifications by Cy, ..., Cx. Denote the features, or predictors, by X;, X,

v Xpe

The conditional probability that an observation with predictor values xy, xy, ..., x, belongs in
the class Cj is computed as follows:

p
P(CY TT [P(xj| €1/ (R)

- j=1
) = — -

> | P(Cp| TT [Px;|Cp1|/R
k=1 i=1

P(Ck‘(xl’ e X

where R is a regularization constant. In the formula above, the conditional probability that an
observation with X; = x;belongs to the class Cy, P(x;| Cy), is determined as follows:

* IfX;is categorical:

# of observations in x i C K

P(x]- | Ck) N # of observations in C k

o If X]» is continuous:
1
P(x. = —m. .
(5[Co) = 50005 =m0/ 530
Here, ¢ is the standard normal density function, and m and s are the mean and standard

deviation, respectively, of the predictor values within the class C;.

The unconditional probability that an observation belongs in class C, P(Cy), is computed as
follows:

# of observations in Ck +(0.5/K)

Total # of observations + 0.5

P(Cy) =
An observation is classified into the class for which its conditional probability is the largest.
Note: In the formula for P(Cy), 0.5 is the prior bias factor. This value is the default value. To

change the prior default factor, go to File > Preferences > Platforms > Naive Bayes, select the
Prior Bias check box and change the value.
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pto Saved Probability Formulas

This section describes the formulas saved using the Save Probability Formula option. The
conditional probability that an observation with predictor values xy, x, ..., x,, belongs in the
class Cy differs slightly from that given by P(Cyl(xy,..., xp)), shown in the section “Algorithm”.
This is done for computational efficiency.

Naive Score Formulas

The Naive Score formula for a given class Cy, S(Cy), is a variation of the numerator in the
expression for P(Cyl(xy,..., xp)) and is computed as follows:

S5(Cy) = exp[In{P(Cy)} + Continuous + Categorical + In(R)]

The Naive Score formula is a combination of scores from continuous and categorical
predictors. Recall that R is a regularization constant. The continuous portion of the formula is
computed as follows:

P1
X — M,
Continuous = > {Normal Log Density[—LS—Lk] + ln(l/sjk)}
. ik
j=1

where
j=1,..., p; continuous predictors.

The categorical portion of the formula is computed as follows:

P2 Lr
Categorical = DR 1rlln(P(xrl|Ck))
r=1(1=1

where
r=1,...,p, categorical variables
I=1,.., L, levels of the r" categorical variable

1,;is an indicator variable that equals 1 when x,; is the 1M level of the i categorical
predictor and 0 otherwise
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Naive Score Sum Formulas

The Naive Score Sum formula, S, sums the Naive Score formulas over all classes. This is a
variation of the denominator in the expression for P(Cil(xy,..., Xp))-

K
5= 3> 5(CY
k=1
Naive Prob Formulas
The Naive Prob formula for a given class C; equals P(Cyl (x1,..., xp))- In the JMP formulas,
S(Cp)

P(Cy|(xys X)) = =

Naive Predicted Formula

The Naive Predicted Formula for an observation classifies that observation into the class for
which P(Cyl (xy,..., xp)) is the largest. This is equivalent to classifying an observation into the
class for which its Naive Score formula is the largest.
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The Support Vector Machines platform is available only in JMP Pro.

In JMP Pro, the Support Vector Machines (SVM) platform provides a machine learning tool for
both nonlinear regression and classification. The SVM algorithm is a supervised learning
algorithm that uses the training data to build a model to predict or classify new observations.

If you have a categorical response, you can visualize the model classification in the Response
Profile Plot. The SVM platform also provides misclassification rates, confusion matrices, and
ROC and Lift curves to help you determine how well your model fits the data. If you have a
continuous response, fit statistics and actual by predicted plots are used to determine how
well the model fits the data.

Figure 9.1 Response Profile Plot

£ ~|Response Profile Plot

Factor Current X
Sepal length ¢ ( ) 5.8433
Petal length ¢ ( ) 3.758
Sepal width ¢ $: ) 3.0573
Petal width ¢ ( ) 1.1993

Legend
Species = setosa
5 Species = versicolor
Species = virginica

Petal length |4

5 6 7
Sepal length ™
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w Overview of Support Vector Machines

A support vector machine (SVM) model is a supervised learning algorithm that is used to
predict or classify new observations. A model is fit on a set of training data where the
responses are known. Then, the model is used to predict the responses of new observations.

When the response is categorical, SVM models classify data by optimizing a hyperplane that
separates the classes. This can also be viewed as finding the hyperplane that maximizes the
margin between the classes. In simple problems, this hyperplane is linear. However, more
complicated data often cannot be separated linearly. For these scenarios, the SVM platform
provides the option to use a radial basis function kernel to map the points to a nonlinear
dimension that can make the classes easier to separate.

When the response is continuous, the models that are fit are known as support vector
regression (SVR) models. In a typical regression problem, the goal is to fit a model that
minimizes the error between a predicted response and the actual response. In an SVR
problem, the goal is to fit a model such that the error between a predicted response and the
actual response falls within a range of -¢ to €. This provides a more flexible fit. In JMP Pro, € is
equal to 0.1. The SVR algorithm doubles the data by creating two classes, Y + e and Y - &. Then
the same algorithm that is used for the classification problem is also used for the prediction
(SVR) problem.

The maximization in SVM algorithms is performed by solving a quadratic programming
problem. In JMP Pro, the algorithm used by the SVM platform is based on the Sequential
Minimal Optimization (SMO) algorithm introduced by John Platt in 1998. Typically, the SVM
quadratic programming problem is very large. The SMO algorithm splits the overall quadratic
programming problem into a series of smaller quadratic programming problems. Smaller
quadratic programming problems are solved analytically instead of numerically, meaning
they produce closed-form solutions. Therefore, the SMO algorithm is more efficient than
solving the overall quadratic programming problem (Platt 1998).

w Example of Support Vector Machines

You have baseline medical data for 442 diabetic patients. You also have a binary measure of
diabetes disease progression obtained one year after each patient’s initial visit. This measure
quantifies disease progression as either Low or High. You want to construct a classification
model to predict the disease progression for future patients as High or Low. You explore both
kernel function options.

1. Select Help > Sample Data Library and open Diabetes.jmp.

2. Select Analyze > Predictive Modeling > Support Vector Machines.
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3. Select Y Binary and click Y, Response.

4. Select Age through Glucose and click X, Factor.

5. Select Validation and click Validation.

6. Click OK.

7. In the Model Launch control panel, check that the kernel function is a Radial Basis

Function and select Tuning Design.

*®

Enter 10 next to Number of Runs.

9. Click Go.

10. Click the gray triangle next to Model Launch to open the Model Launch control panel.
11. Change the kernel function to a Linear function and select Tuning Design.

12. Enter 10 next to Number of Runs.

13. Click Go.

Figure 9.2 Model Comparison Report

< Medel Comparison

Training Validation Validation Probability Threshold Validation

Show Method Kernel Function Cost Gamma #5V  Misclassification Rate  Misclassification Rate ~ Generalized RSquare Threshold  Misclassification Rate  Best
O Medel 1 Radial Basis Function 2.57061  0.43877 251 0.00324 0.23564 0.00838 0.39079 0.23364
O Medel 2 Radial Basis Function 3.04271  0.31899 218 0.01294 0.28571 -0.4206 0.23223 0.28571
O Medel 3 Radial Basis Function 3.93906  0.46899 255 0.00324 0.28571 -0.0081 053372 0.28571
O Model 4 Radial Basis Function ~ 1.073  0.27968 208 0.0712 0.21805 0.22138 0.17372 0.21805
O Model 5 Radial Basis Function 0.41677 0.0281 156 0.15534 0.18797 0.50483 0.36015 0.18797
O Model 6  Radial Basis Function 0.23269  0.39898 246 0.26861 0.28571 0.22323 6ie-8 0.28571
O Model 7 Radial Basis Function  4.8013  0.15144 167 0.05178 0.2782 -04245 0.26219 0.2782
O Meodel & Radial Basis Function 3.31202  0.20293 181 0.04207 0.28571 -0.454 0.22753 0.28571
O Medel 9 Radial Basis Function  4.2693  0.06093 140 0.11974 0.19549 0.42841 032812 0.19549
O Model 10 Radial Basis Function 1.87641 0.0919 150 0.13269 0.21053 042499 0.30598 0.21033
O Model 11 Linear 4.42735 5 122 0.17476 0.17293 0.51943 047722 0.17263
O Model 12 Linear 4.99046 . 123 0.16828 0.17292 0.52037 0.47551 0.17293
O Model 13 Linear 3.8272 . 123 0.17476 0.17292 0.51923 0.47763 0.17293
O Model 14 Linear 2.74788 5 124 0.17132 0.17293 0.51724 0.48019 0.17293
O Medel 15 Linear 3.22207 5 123 0.17476 0.17293 0.51851 0.47842 0.17233
O Medel 16 Linear 129304 5 124 0.17132 0.17293 0.51518 04813 0.17293
O Model 17  Linear 1.74671 5 124 0.16828 0.17293 0.51557 048143 0.17233
O Model 18  Linear 0.83575 5 123 0.16305 0.15789 0.51498 0.48207 0.15789
O Model 19  Linear 2.22 . 125 0.17152 0.17292 0.51579 0.48255 0.17293
Medel 20 Linear 0.04975 . 138 01554 0.14286 0.52302 0.41946 0.14286 Smallest...

The Model Comparison report shows that the best model in terms of misclassification rate
and RSquare is Model 20. This model has a linear kernel function with cost parameter
0.04975. This is the model to further analyze.
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Figure 9.3 Model Report for Best Fitting Model

£ =/ Support Vector Machine Model 20

< Model Summary

Response Y Binary
Validation Methed Validaticn Celumn
Kernel Functicn Linear

Measure

Number of rows

Sum of Frequencies
Misclassificaticn Rate

< Estimation Details
Cost 0.05

Training Validation

309 133
309 133
0.1553398 0.1428571
133 133

Number of Support Vectors

4 Fit Details
Measure
Entropy RSquare
Generalized RSquare
Mean -Log p
RASE
Mean Abs Dev
Misclassificaticn Rate
N

< Confusion Matrix
[ Set Probability Threshold

0.3855
0.5257
0.3576
0.3405
0.2311
0.1715
309

Training Validation Definition

0.3795 1-Loglike(model)/Loglike(0)

0.5230 (1-(L{0)/L{model)}*(2/n))/(1-LIO)*2/n)
0.3712 3 -Log(p[jl)/n

03404 ¥ Tly{jl-pD¥n

02453 3 ly(il-p[l/n

0.1579 3 (pljlzpMax)/n

133 n

< Training £ Validation
Predicted Misclassification Predicted Misclassification
Actual Rate Rate Actual Rate Rate
YBinary Low High 01553 | ¥Binary Low High 0.1429
Low 0.960 0.040 Low 0.926 0.074
High 0470 0.530 High 0316 0.684
Predicted Predicted
Actual Count Actual Count
YBinary Low High YBinary Low High
Low 217 ] Low 38 7
High 30 44 High 12 26

The Model Summary report shows that the misclassification rates for the training and

157

validation sets are very similar. This is a good indication that the model did not overfit the

data. The confusion matrices provide more information about the types of observations

that are misclassified by the model. In the confusion matrices, the upper left corner shows
that the model correctly categorizes the Low responses most of the time (96% in training

and 92.6% in validation). However, fewer of the High responses are correctly categorized
(53% in training and 68.4% in validation). Therefore, most of the misclassifications are the
High responses being misclassified as Low.

w Launch the Support Vector Machines Platform

Launch the Support Vector Machines (SVM) platform by selecting Analyze > Predictive

Modeling > Support Vector Machines.

Launching the SVM platform is a two-step process. First, enter your variables on the SVM

launch window. Second, specify your options in the Model Launch control panel.
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po The Support Vector Machines Launch Window

Use the SVM launch window to specify your response and model factors. If used, validation
and by columns are also specified in the launch windows.

Figure 9.4 Support Vector Machines Launch Window

Predicts a response based on the support vecters in the space of the X variables.
Select Columns Cast Selected Columns into Roles Action

*114 Columns
f : Binary X, Factor || required Cancel
ol ¥ Ordinal oplona
A Age
th Gender
4 BMI Freq gptional numeric Recall
8P Validation || optional numeric L
dll Total Cholesterol
4 1oL By optional
4 HDL

4 TCH

4L

dll Glucose

A Validation

Response|| required 0K

Rermove

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Support Vector Machines launch window provides the following options:

Y, Response The response variable that you want to analyze.

X, Factor The predictor variables.

Freq A column whose numeric values assign a frequency to each row in the analysis.

Validation A numeric column that defines the validation sets. See “Validation Method”. If
you click the Validation button with no columns selected in the Select Columns list, you
can add a validation column to your data table. For more information about the Make
Validation Column utility, see “Make Validation Column”.

By A column or columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.
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pio Model

Launch Control Panel

When you click OK in the launch window, the Support Vector Machine report window
appears, showing a Model Launch control panel for fitting models. Use the Model Launch
control panel to specify the kernel function and associated parameter values, as well as the
validation method.

Figure 9.5 The Model Launch Control Panel

£ =/ Support Vector Machine
< Model Launch

Kernel Function

Radial Basis Function *

[] Tuning Design

Cost

Gamma 0.1

1

Validation Method

MNeone =

The Model Launch control panel contains the following options:

Kernel Function Specifies the kernel function used in the model. Choose from the following
kernel functions:

Radial Basis Function Selects the radial basis function kernel to create a nonlinear

hyperplane to separate the classes.

The Cost parameter is the penalty associated with misclassifying an observation in the
training set. A higher cost parameter implements an algorithm that is less likely to
misclassify a point in the training set, whereas a lower cost parameter produces a wider
margin. The Cost parameter must be greater than 0, and the default value is 1.

The Gamma parameter is the parameter in the kernel function. This parameter
determines the amount of curvature there is to the decision line; a higher Gamma value
indicates more curvature. A nonlinear decision line provides a more flexible fit, but too
much curvature can lead to overfitting. The Gamma parameter must be greater than 0,
and the default value is 1/(# of predictors).

Linear Selects the linear kernel function to create a linear hyperplane to separate the

classes.

The Cost parameter is the penalty associated with misclassifying an observation in the
training set. A higher cost parameter implements an algorithm that is less likely to
misclassify a point in the training set, whereas a lower cost parameter produces a wider
margin. The Cost parameter must be greater than 0, and the default value is 1.
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Note: If you specify parameter values that are out of range, the default values are used.

Tip: To find the best fitting model, fit a range of kernel functions and parameter values and
use the Model Comparison report.

Tuning Design Enables you to fit a range of parameter values for the specified kernel.
The models with the largest RSquare and the smallest Misclassification Rate or RASE
are identified in the Model Comparison report. After you select Tuning Design, you
must specify minimum and maximum values for the parameters. Default values are
provided based on the data and the minimum must be greater than zero. You must also
specify a value for the Number of Runs. The SVM platform fits that many models over
a grid of parameter values determined by the minimum and maximum values.

Validation Method Specifies the model validation method. When you click the Go button for
the first time, the first SVM model is fit using the specified validation method. This
Validation Method is then used for all SVM models fit from within the SVM window. This
ensures that all models in the report window are fit using the same validation method and
validation set.

Holdback Randomly divides the original data into training and validation sets. You can
specify the proportion of the original data to use as the validation set (holdback).

KFold (Available only when Y is continuous or nominal.) Randomly divides the original
data into K subsets. In turn, each of the K sets is used to validate the model fit on the
rest of the data, fitting a total of K models. If Y is continuous, the model that has the
best validation RASE statistic is chosen as the final model. If Y is nominal, the model
that has the best validation misclassification rate is chosen as the final model.

Validation Column (Available only if you specified a Validation column in the launch
window.) Uses the values in the specified Validation column to divide the data into
parts. The column’s values determine how the data are split, and what method is used
for validation:

— If there are two values, the smaller value defines the training set and the larger value
defines the validation set.

— If there are three values, these values define the training, validation, and test sets in
order of increasing size.

— If the validation column has more than three levels, then Validation Column K Fold is
used.

The SVM platforms uses the validation column to train and evaluate the model, unless
a Tuning Design is used. If the Tuning Design option is selected, the SVM platform uses
the validation column to train and tune the model or to train, tune, and evaluate the
model. For more information about validation, see “Validation in JMP Modeling”.
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Note: If the validation column does not lead to a valid partition of the data, the
Holdback validation method is used instead.

Validation Column K Fold (Available only when the Y, Response column has exactly two
levels and a Validation column is specified in the launch window.) Uses the values in
the specified Validation column to divide the data into K sets, where K is the number of
unique values in the column. Then, K-Fold validation is performed.

None No validation used.

Go Fits the specified SVM model and shows the model report.

Note: If you have a large data table, a progress bar is shown for each model that is fit to
the data. The total number of models fit is k!/2(k-2)!, where k is the number of levels of the
response variable. Each progress bar has an Accept Current Estimates button. Click this
button if you want to stop the fitting algorithm early and accept the current estimates.
Because prediction calculations are performed after you click this button, it may take some
time for the report to appear.

Missing Values

Rows that contain any missing predictor values are not included in the SVM modeling
procedure. Therefore, any columns saved to the data table will contain missing values in those
rows. If you want to include data with missing values in an SVM model, some form of
preprocessing is required. See “Explore Missing Values Utility”.
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w The Support Vector Machine Report

When you click Go in the Model Launch control panel, a Model Comparison report appears
above the control panel and a model report appears below the control panel. The model
reports are numbered sequentially. Each time a new model is fit, it is added to the Model
Comparison report and a new model report is added to the window. See “Model Comparison
Report” and “Support Vector Machine Model Report”. Click on the column headings to sort
the models by any of the columns in the Model Comparison report. The first click sorts in
ascending order; click the column heading a second time to sort in descending order.

po Model Comparison Report

The Model Comparison Report contains the following information:

Show A check box that indicates whether the Support Vector Machine Model report for the
corresponding fit should appear in the report window.

Method The model number.
Kernel Function The kernel function for the corresponding model.
Cost The value of the cost parameter for the corresponding model.

Gamma The value of the gamma parameter for the corresponding model. If the model uses a
linear kernel, this value is missing.

# SV The number of support vectors used in the corresponding model.

Training Misclassification Rate (Appears only if the response is categorical.) The
misclassification rate for the observations in the training set. This rate is based on the
classification decision rule that is calculated by the platform.

Validation Misclassification Rate (Appears only if the response is categorical and validation
is used.) The misclassification rate for the observations in the validation set. This rate is
based on the classification decision rule that is calculated by the platform.

Test Misclassification Rate (Appears only if the response is categorical and a test set is
specified using a validation column.) The misclassification rate for the observations in the
test set. This rate is based on the classification decision rule that is calculated by the
platform.

Training RASE (Appears only if the response is continuous.) The square root of the mean
squared prediction error (Root Average Square Error) for the observations in the training
set. See “RASE”.
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Validation RASE (Appears only if the response is continuous and validation is used.) The
square root of the mean squared prediction error (Root Average Square Error) for the
observations in the validation set. See “RASE”.

Test RASE (Appears only if the response is continuous and a test set is specified using a
validation column.) The square root of the mean squared prediction error (Root Average
Square Error) for the observations in the test set. See “RASE”.

Validation Generalized RSquare (Appears only if validation is used.) The Generalized
RSquare value for observations in the validation set. See “Fit Details”.

Probability Threshold (Appears only if the response is binary and validation is used.) The
cutoff probability determined by the classification decision rule that is calculated by the
platform. An observation is classified into the target level when its predicted probability
exceeds this value.

Tip: You can change this value by using the Set Probability Threshold option in the
Confusion Matrix report. See “Confusion Matrix”.

Conditional Validation Misclassification Rate (Appears only if the response is binary and
validation is used.) The misclassification rate for the observations in the validation set,
conditioned on the probability threshold value.

Best Indicates which model fit has the smallest misclassification rate. If validation is used
without a test set, this is the model with the smallest validation misclassification rate. If
validation is used with a test set, this is the model with the smallest test misclassification
rate.

Model Comparison Plot

Shows a contour plot of the model performance of the validation set over the grid of
parameter values. This report is available only if Tuning Design is specified in the Model
Launch Control Panel.

pio Support Vector Machine Model Report

Response Profile Plot (Available only when the response is categorical.) Gives a visual
representation of the classification model. The points on the plot are the actual data
observations and are on by default only when there are exactly two continuous variables.
For the two variables plotted, the shaded contours represent a plane of the prediction
space determined by fixed values of the remaining model factors. The predictions are
based on the classification decision rule that is calculated by the platform. Controls for the
fixed values are located above the plot. When you change the fixed values of the factors,
using either the slider or number box, the prediction space for the plotted variables is
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automatically updated. You can also change the axes of the plot to display any continuous
factor using the red triangles on each axis.

The Response Profile Plot red triangle menu contains the following options:

Grid Density Determines the fineness of the prediction grid underlying the shaded
contours. A higher grid density provides a smoother decision line.

Show Points Shows or hides the points on the plot. On by default when there are only
two variables.

Model Summary Gives the name of the response column, the validation method, and the
type of kernel function used in the model fit. The Model Summary table also contains
information about the model fit for the training, validation, and test sets. The number of
observations and the number of support vectors are reported for each set. If the response is
categorical, the misclassification rate is reported for each set. The misclassification rate is
the proportion of observations misclassified by the model. This is calculated as the number
of misclassifications divided by the total number of observations. If the response is
continuous, the RASE and R Square values are reported for each set.

Estimation Details Gives the values of the parameters used in the model.

Fit Details (Available only if the response is categorical.) Gives the following statistics for the
training set, and for the validation and test sets if they are specified:

Entropy RSquare A measure of fit that compares the log-likelihoods from the fitted
model and the constant probability model. Entropy RSquare ranges from 0 to 1, where
values closer to 1 indicate a better fit. See “Entropy RSquare”.

Generalized RSquare A measure that can be applied to general regression models. It is
based on the likelihood function L and is scaled to have a maximum value of 1. The
Generalized RSquare measure simplifies to the traditional RSquare for continuous
normal responses in the standard least squares setting. Generalized RSquare is also
known as the Nagelkerke or Craig and Uhler R?, which is a normalized version of Cox
and Snell’s pseudo R%. See Nagelkerke (1991). Values closer to 1 indicate a better fit.

Mean -Log p The average of -log(p), where p is the fitted probability associated with the
event that occurred. Smaller values indicate a better fit.

RASE The square root of the mean squared prediction error (Root Average Square Error).
RASE is computed as follows, where Source indicates the Training, Validation, or Test

set.
SSE
_ Source
RASESource Y n
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Mean Abs Dev The average of the absolute values of the differences between the
response and the predicted response. The differences are between 1 and p, the fitted
probability for the response level that actually occurred. Smaller values indicate a
better fit.

Misclassification Rate The rate for which the response category with the highest fitted
probability is not the observed category.

Note: The misclassification rates in the Fit Details report might not match the
misclassification rates in the Confusion Matrix report. When the response is binary, the
rates in the Fit Details report use a probability cutoff of 0.5, but the rates in the
Confusion Matrix report use the probability threshold value as the cutoff.

N The number of observations.

Confusion Matrix (Available only if the response is categorical.) A confusion matrix is shown
for each set (training, validation, and test) specified in the model. A confusion matrix is a
two-way classification of actual and predicted responses. Use the confusion matrices and
the misclassification rates to evaluate your model.

The confusion matrices and the misclassification rates use the value in the probability
threshold box as the cutoff value. By default, this value is based on the classification
decision rule that is calculated by the platform. You can change the cutoff value by
dragging the slider or entering a new value in the box next to Probability Threshold. If you
change the probability threshold, the confusion matrices and misclassification rates
automatically update. The probability threshold and conditional validation
misclassification rate columns in the Model Comparison report are also updated.

Actual by Predicted Plot (Available only if the response is continuous.) Plots the actual
response versus the predicted response. The diagonal line is the Y = X line. The closer the
points are to this line, the better the model fits the data. When validation is used, plots are
shown for the training, validation, and, if specified, test sets.

w Support Vector Machines Platform Options

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.
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Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Support Vector Machine Model Report Options

Each Support Vector Machine Model report contains the following options:

Response Profile Plot (Available only if the response is categorical.) Shows or hides the
Response Profile Plot.

Support Vector Coefficients Shows or hides the table of support vector coefficients. Select
rows in the table to highlight the support vectors in the original data table and the
Response Profile Plot.

Confusion Matrix (Available only if the response is categorical.) Shows or hides the
confusion matrix. See “Confusion Matrix”.

ROC Curve (Available only if the response is categorical.) Shows or hides the ROC Curve. If
you use validation, ROC Curves for the validation and, if specified, test sets appear in
addition to the curve for the training set. For more information, see “ROC Curve”.

Lift Curve (Available only if the response is categorical.) Shows or hides the Lift Curve. If
you use validation, Lift Curves for the validation and, if specified, test sets appear in
addition to the curve for the training set. For more information, see “Lift Curve”.

Plot Actual by Predicted (Available only if the response is continuous.) Shows or hides a
plot of the actual values versus the predicted values.

Plot Residual by Predicted (Available only if the response is continuous.) Show or hides a
plot of the residuals versus the predicted values.

Profiler Shows or hides the Prediction Profiler. Each response level is represented by a
separate row in the Prediction Profiler. For more information about the options in the red
triangle menu, see Profilers.

Contour Profiler (Available only when the model contains more than one continuous factor.)
Shows or hides the Contour Profiler. For more information about the options in the red
triangle menu, see Profilers.

Surface Profiler (Available only when the model contains at least one continuous factor.)
Shows or hides a surface profiler. For more information about the options in the red
triangle menu, see Profilers.
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Save Predicteds Saves the predicted classifications based on the threshold probability cutoff
value to the data table in a column called Predicted <Y, Response>.

Save Prediction Formula Saves the prediction formulas based on the threshold probability
cutoff value to the data table. If the response is binary, a single prediction formula column
is added to the data table. If the response has more than two levels, a prediction formula
column is added to the data table for each pairwise model, in addition to a formula
column for the final prediction.

Publish Prediction Formula Creates probability formulas based on the threshold probability
cutoff value and saves them as formula column scripts in the Formula Depot platform. If a
Formula Depot report is not open, this option opens the Formula Depot window. See
“Formula Depot”.

Save Probabilities Saves the probability of each response level as a separate column in the
data table, as well as a column called Most Likely <Y, Response>.

Save Probability Formula (Available only if the response is binary.) Saves the following
formula columns to the data table:

Decision Value A hidden column that contains the formula for the decision value.
Probability Two probability formula columns, one for each level of the binary response.
Most Likely The predicted classification based on which probability value is higher.

Threshold Predicted The predicted classification based on the threshold probability
cutoff value obtained from the confusion matrix. By default, this value is based on the
classification decision rule that is calculated by the platform. If the threshold value is
changed to 0.5, the Threshold Predicted column is not saved to the data table because it
would be equivalent to the Most Likely column.

Publish Probability Formula (Available only if the response is binary.) Creates probability
formulas and saves them as formula column scripts in the Formula Depot platform. If a
Formula Depot report is not open, this option opens the Formula Depot window. See
“Formula Depot”.

Save Validation (Available only when the Holdback or KFold validation methods are used.)
Creates a new column in the data table that identifies which rows were used in the
training and validation sets.

Remove Fit Removes the entire model report.
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Additional Example of the SVM Platform

Example of Support Vector Regression for Continuous Response

Support vector regression (SVR) models use the SVM algorithm to predict continuous
response data. This example uses the same medical data on diabetic patients that was used in
“Example of Support Vector Machines”. Instead of a binary measure of diabetes disease
progression, you now have a continuous measure. Higher values correspond to more disease
progression. Vary the cost parameter of the radial basis function to find the best fitting model.

Select Help > Sample Data Library and open Diabetes.jmp.

Select Analyze > Predictive Modeling > Support Vector Machines.
Select Y and click Y, Response.

Select Age through Glucose and click X, Factor.

Select Validation and click Validation.

Click OK.

NS ol L=

In the Model Launch control panel, check that the kernel function is a Radial Basis
Function with Cost parameter 1 and Gamma parameter 0.1.

Click Go.

*®

9. Click the gray triangle next to Model Launch to open the Model Launch control panel.
10. Change the cost parameter to 0.1.

11. Click Go.

12. Click the gray triangle next to Model Launch to open the Model Launch control panel.
13. Change the cost parameter to 2.

14. Click Go.

Figure 9.6 Model Comparison Report

< Model Comparison

Training  Validation Validation
Show Method Kernel Function Cost Gamma #5Y RASE RASE Generalized RSquare Best
Wi Model 1 Radial Basis Function 1 0.1 266 43.8147 58.3285 0.42552
Model 2 Radial Basis Function 0.1 0.1 280 52,5804 57.5025 0.44167 Smallest RASE
Model 3 Radial Basis Function 2 0.1 265 40.553 60,7501 0.37621

Validation Column: Validation

The Model Comparison report contains the results of the models using different cost
parameters. Recall that a higher cost parameter implements an algorithm that is less likely
to misclassify a point, whereas a lower cost parameter implements a more flexible



Chapter 9 Support Vector Machines 169
Predictive and Specialized Modeling Additional Example of the SVM Platform

algorithm. In this scenario, the more flexible model (cost parameter equal to 0.1) produces
the best model fit.

15. In the Show column of the Model Comparison report, deselect Model 1 and Model 3.

Figure 9.7 Model Report for Continuous Response

4 |=|Support Vector Machine Medel 2

4 Model Summary 4 Estimation Details
Response ¥ Cost 01
Validation Method Validation Column Gamma 0.1
Kernel Function  Radial Basis Function
Measure Training Validation
Number of rows 309 133
Sum of Frequencies 309 133
RASE 5258037 57.502401
R-Square 0.5340282 0.4416728
Mumber of Support Vectors 280 280

4 Actual by Predicted Plot
Training Validation

300

100

¥ Predicted ¥ Predicted

The model report for a continuous response contains the Model Summary, Estimation
Details, and Actual by Predicted Plot. In the Model Summary report, the RASE is 52.58 for
the training set and 57.50 for the validation set.
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rio Model Screening
Fit and Compare Multiple Prediction Models

The Model Screening platform is available only in JMP Pro.

The Model Screening platform in JMP Pro enables you to run multiple predictive modeling
platforms from one launch window and assemble summaries from the different methods.
This helps you pick the best performing model without launching each individual model
platform. You can also easily launch an individual platform report for any of the models from
the Model Screening report window for further refinement.

Figure 10.1 Model Screening Report

4 ROC Curve
Training Validation Method
100 100 Decision Tree

ootstrap Forest

0.90 0.90

0.80 0.80

0.70 0.70

0.60 Generalized Regression Lasso

0.60

I AuC

Training Validation
09160 0.8080
09918 08083
0073 08863
09211 02391
09171 08736
0877 09197
0.8869 0.9164
0880 09184

0.30 0.50

Method Fol
Decision Tree
Bootstrap Forest

Sensitivity
True Positive
Sensitivity
True Positive

0.40 - 0.40

0.30 0.30 Boosted Tree
Neural Boosted

Support Vector Machines
Fit Stepwise

MNominal Logistic

Generalized Regression Lasse

0 0.20 0.40 0.60 0.80 1.00 0 0.20 0.40 0.60 0.80 Decision Tree 0.8114 0.8119
1-Specificity 1-Specificity Bootstrap Forest 0.9836 0.9063
False Positive False Positive

Neural Boosted 08953 0.9135
09178 0.8921
0.8866 0.9214
0.8881 0.9139
0.8843 0.9175
0.8560 0.8773
0.9837 0.9512
0.9798 0.9311
0.9065 0.9632

Id
1
1
1
1
1
1
1
1
2
2
Boosted Tree 2| 0o o0se:
2
Support Vector Machines 2
Fit Stepwise 2
Norminal Legistic 2
Generalized Regression Lasso 2
Decision Tree 3
Bootstrap Forest 3
Boosted Tree 3
Neural Boosted 3
Deselect All

Unsupported methods: K Nearest Neighbors



172 Model Screening Chapter 10
Predictive and Specialized Modeling

Contents
Example of Model Screening for Continuous Response. ..................cooiiiunn. 173
Launch the Model Screening Platform. .............. ... ... .. ... ... . ... 175
The Model Screening Report. ... ... ... i 178
Summary Across the Folds Report....... ... ... . 179
Training, Validation, and Test Measuresof Fit............ ... ... ... ... ... ... .... 180
Model Screening Platform Options ............ ... i 181

Decision Thresholds Report. ............ .. 184



Chapter 10 Model Screening 173
Predictive and Specialized Modeling Example of Model Screening for Continuous Response

w Example of Model Screening for Continuous
Response

You have baseline medical data for 442 diabetic patients. You also have a continuous measure
of diabetes disease progression obtained one year after each patient’s initial visit. Higher
values correspond to more disease progression. You want to assess various models for their
ability to predict diabetes disease progression.

Select Help > Sample Data Library and open Diabetes.jmp.
Select Analyze > Predictive Modeling > Model Screening.
Select Y and click Y, Response.

Select Age through Glucose and click X, Factor.

In the Folded Crossvalidation section, select the box next to K Fold Crossvalidation.

AN S

(Optional) In the Options section, type 42920 next to Set Random Seed.
Use the random seed in order to match the example output.
Click OK.

8. Click the red triangle next to Model Screening for Y and select Optional Reports > Elapsed
Time.

N
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Figure 10.2 Model Report for Continuous Response

£ ~|Model Screening for Y
Table: Dizbetes Response: Y

I’ Details
4 Summary Across the Folds
N Trials Validation 5et Folds

Method Folds Sum Freq RSquare © Mean RASE StdDev RASE
Neural Boosted 5 88.400 0.5503 51.194 27313
Fit Stepwise 5 88.400 0.4743 55.180 3.5662
Fit Least Squares 5 88.400 0.4716 55.324 34460
Generalized Regressicn Lasso 5 58.400 0.4636 53.674 4,1850
Bootstrap Forest 5 58.400 0.4578 55.997 45840
Support Vector Machines 5 58.400 0.4429 56.945 3.9816
Boosted Tree 5 88.400 0.4204 57.488 3.6976
K Mearest Neighbors 5 88.400 0.4276 57.5809 24818
Decision Tree 5 88.400 0.3917 50.302 3.9977

Select Dominant Run Selected Save Script Selected

[ Training
[ Validation

Sum Freq and Sum Weight are suppressed when they are the same as N,

< Elapsed Time

Method Details Milliseconds ~ Elapsed Time

K Mearest Neighbors 26 0:00:00.026

Fit Stepwise 42 0:00:00042 |

Fit Least Squares ag 0:00:00085 ||

Decisicn Tree 129 0:00:00.129 ||

Boosted Tree 267 0:00:00.267 [1] :
Generalized Regression Lasso 1186 0:00:01.186 ] :
Support Vector Machines 1303 0:00:01303 ]
Bootstrap Forest 2427 0:00:02427 [
MNeural Boosted 5830 0:00:05.830

The best performing model based on the Validation RSquare averaged across the folds, is
Neural Boosted. The average Validation RSquare for Neural Boosted is 0.5503. The Elapsed
Time report shows that the Neural Boosted models also took the longest to fit. In this case, the
elapsed time was only 5 seconds, but this information could be important for larger data sets

or more complex models.

Tip: To see performance metrics for the individual models, click the gray disclosure icon next

to Validation.
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w Launch the Model Screening Platform

To launch the Model Screening platform, select Analyze > Predictive Modeling > Model
Screening.

Figure 10.3 The Model Screening Launch Window

Fits many different predictive models and provides summaries of measures of fit.

Select Columns Cast Selected Columns into Roles Action
= 14 Columns Ay
Y sptiona

aptional C I
[ Y Binary
<l Y Crdinal
4o 4 Age

ender

th Gender
4l BMI PEY
45 i
dll Total Cholesterol

4 Ho :
4 TCH
A LG
dll Glucose op
A Validation
Method Options
ecision Tree emove Live Reports
Decision Tr IR Live Rep
Bootstrap Forest [ Log Methods
Boosted Tree Time Limit Each
K Mearest Neighbors Set Random Seed
[] Maive Bayes
Meural Folded Crossvalidation
upport Vector Machines it repeatedly with sequenced folds.
[+] Support Ve Machi Fit repeatedly with seq d fold
Discriminant K Fold Crossvalidation K

| wn

Fit Least Squares
Fit Stepwise
Logistic Regression Repeated K Fold ljl
Generalized Regression
[] Partial Least Squares
[] %GBoost

[] Mested Crossvalidation K L| 5 |

Meodeling Options

[] Add Two Way Interactions
[[] Add Quadratics

[] Informative Missing

[[] Additional Methods

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Y, Response The response variable or variables that you want to analyze.
X, Factor The predictor variables.

Weight (Not applicable to the K Nearest Neighbors, Support Vector Machines, or Neural
modeling platforms.) A column whose numeric values assign a weight to each row in the
analysis.
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Freq (Not applicable to the K Nearest Neighbors modeling platform.) A column whose

numeric values assign a frequency to each row in the analysis.

Validation (Not applicable if any of the Crossvalidation options are selected in the launch

By

window.) A numeric column that defines the validation sets. If you click the Validation
button with no columns selected in the Select Columns list, you can add a validation
column to your data table. For more information about the Make Validation Column
utility, see “Make Validation Column”.

Note: If you specify a validation column with more than three levels, this column is used
to perform K Fold crossvalidation.

A column or columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

Methods Enables you to select the desired modeling platforms. By default, the modeling

platforms that are fit are Decision Tree (Partition), Bootstrap Forest, Boosted Tree, K
Nearest Neighbors, Neural, Support Vector Machines, Discriminant, Fit Least Squares, Fit
Stepwise, Logistic Regression, and Generalized Regression. Naive Bayes, Partial Least
Squares, and XGBoost are also available.

Notes:

— XGBoost is not supported by JMP and is available only if the XGBoost add-in is
installed. For more information about XGBoost, see https://community.jmp.com.

— Decision Tree (Partition), Discriminant, and Partial Least Squares all require some type
of validation set in order to fit a model.

— If there are fewer than 20 observations in a validation set, a Decision Tree (Partition)
model cannot be fit.

— The modeling platforms use default options and tuning parameters in model fitting.
You can try to improve the fit past what the default yields by calling platforms directly
and choosing different options.

Options

Provides additional options.

Remove Live Reports Does not include the individual model platform reports in the Model

Screening report window.


https://community.jmp.com/t5/JMP-Add-Ins/XGBoost-Add-In-for-JMP-Pro/ta-p/319383?attachment-id=11848
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Tip: Select this option to free up memory when you have a large problem with many
methods and fits.

Log Methods Writes out a progress message to the log each time a fitting platform is called.

Time Limit Each Specifies a time limit, in seconds, for each fit. For platforms that support
early stopping, the best estimates up to that point are provided. For platforms that do not
support early stopping, no result is provided.

Set Random Seed Sets a random seed that is used for any random components of the model
fit routines. This enables you to rerun the platform and obtain the same model fits.

Folded Crossvalidation

Provides options for various types of crossvalidation.

K Fold Crossvalidation Divides the data randomly into K parts or folds. Each model is fit to
the data K times, each time with a different fold held out as a crossvalidation set. A total of
K models are fit. The default value of K is 5.

— K specifies the number of folds for K Fold Crossvalidation. The default is 5 and K must
be greater than 1.

Nested Crossvalidation Divides the data into nested folds for crossvalidation. First, the data
are divided into k=1, ..., K equals parts, or folds. For each fold, the k' fold is used as a test
set and the remaining data are divided further into L equal parts. These L subdivisions are
called inner folds. Then, a model is fit to the data L times with a different inner fold held out
each time as a crossvalidation set. The L models then use the k' fold as a common test data
set. In all, a total of K*L models are fit. The default value of K is 4 and the default value of L
is 5.

For example, set K=2 and L = 3. The data are initially divided into two folds. The first fold
is held out as a test set and the second fold is divided into 3 inner folds. Three models are

fit to the data, each time with a different inner fold held out as a crossvalidation set. Then,
all three models are tested on the first fold.

The second fold is then held out as a test set and the first fold is divided into 3 inner folds.
Three models are fit to the data, each time with a different inner fold held out as a
crossvalidation set. Then, all three models are tested on the second fold.

— K specifies the number of folds for Nested Crossvalidation. The default is 4 and K must
be greater than 1.

— L specifies the number of inner folds for Nested Crossvalidation. The defaultis 5 and L
must be greater than 1.
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Note: If both K Fold Crossvalidation and Nested Crossvalidation are selected, Nested
Crossvalidation is performed.
Repeated K Fold Specifies the number of times the K Fold Crossvalidation or Nested
Crossvalidation process is repeated.
Modeling Options
Provides additional options for the modeling platforms.
Add Two Way Interactions Adds all two way interaction effects to linear models.
Add Quadratics Adds effects for the squares of continuous variables to linear models.
Informative Missing Enables informative missing for all platforms.
Additional Methods Calls several additional methods, such as Ridge, Elastic Net and Lasso,
in the Generalized Regression platform. See Fitting Linear Models.
Caution: This results in additional model fits.
When you click OK, the specified models are fit and a set of progress bars are shown. The
upper progress bar reports the progress across all fits. The lower progress bar reports the
progress for the current individual model fit. You can stop the lower progress bar to employ
early stopping and the upper progress bar will continue to run.
JVP

PRO

The Model Screening Report

The content of the Model Screening report depends on both the type of crossvalidation
implemented and the modeling type of the response variable. At the top of the Model
Screening report, the name of the data table and column name of the response variable are
shown. If a validation column is specified, the name of that column is also shown.

By default, the Details report appears next. This report contains the individual model reports
for all of the models for each fold and trial. These reports are the actual output from each
platform and contain all reports and command features. For example, if you decide on a
model that is best, you can go to the corresponding platform report in the Details report and
save the desired prediction formula column. You can hide the Details report by selecting the
Remove Live Reports option in the launch window.

If either the K Fold Crossvalidation option or the Nested Crossvalidation option is specified in
the launch window, the Summary Across the Folds report appears. This report is a summary
of the measures of fit averaged across the test folds.
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Measures of fit are shown for each individual model fit, for the training, validation, and test
sets if applicable. If crossvalidation is used by specifying a validation column in the launch
window, only the individual model fit measures of fit are shown in the report.

Summary Across the Folds Report

The Summary Across the Folds report contains a summary of the measures of fit across the
folds, as well as across the trials if Repeated K Fold is specified. If the K Fold Crossvalidation
option is specified, the measures of fit are summarized across the validation sets. If the Nested
K Fold Crossvalidation option is specified, the measures of fit are summarized across the test
sets. The report contains a table with the following columns:

Method The name of the method used to fit the model.

N Trials Folds The total number of models that were fit across all folds and trials, if
applicable.

Sum Freq The average number of observations in the validation or test sets. The test sets are
used to estimate model performance.

RSquare The mean RSquare across all validation or test set folds. This column contains the
Entropy RSquare when the response is categorical.

Mean RASE The mean RASE (Root Average Square Error) across all validation or test set
folds.

StdDev RASE The standard deviation of the RASE across all validation or test sets.

Mean AUC (Available only for categorical responses.) The mean area under the ROC curve
(AUC) across all validation or test sets.

Mean MR (Available only for categorical responses.) The mean misclassification rate (MR)
across all validation or test sets.

The following options are available below the table:

Select Dominant Selects each model that is better than or equal to all of the other models in
terms of a combination of model fitting criteria. This is also referred to as selecting the
Pareto Frontier. For continuous responses, RSquare and Sum Freq are considered when
determining the dominant model. For categorical responses, Entropy RSquare,
Misclassification Rate, AUC, and Sum Freq are considered when determining the dominant
model.

Run Selected Runs the individual model for each selected row. If any type of folded
crossvalidation is specified in the launch window, the model run uses the fold, inner fold,
and trial combination that corresponds to the final model. The final model is the model
that produces the highest weighted average RSquare. The weight average RSquare is the
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average, weighted by number of observations, of the training RSquare, validation
RSquare, and when a test set is used, the test RSquare. A validation column is created in
the data table for any fold, inner fold, and trial combination that is required by clicking
Run Selected.

Save Script Selected Saves a model script to the script window for each selected row. If any
type of folded crossvalidation is specified in the launch window, the validation set
specified in the script uses the fold, inner fold, and trial combination that corresponds to
the final model. The final model is the model that produces the highest weighted average
RSquare. The weight average RSquare is the average, weighted by number of
observations, of the training RSquare, validation RSquare, and when a test set is used, the
test RSquare. A validation column is created in the data table for any fold, inner fold, and
trial combination that is requested by clicking Save Script Selected.

Training, Validation, and Test Measures of Fit

There is a measures of fit report for each model data set that is specified. These could be
Training, Training and Validation, or Training, Validation, and Test sets. Each report contains a
table with the following columns:

Method The name of the method used to fit the model.

N The number of observations in the set.

Sum Wgt The sum of the weights.

RSquare (Available only for continuous responses.) The RSquare value of the fitted model.

Entropy RSquare (Available only for categorical responses.) A measure of fit that compares
the log-likelihoods from the fitted model and the constant probability model. Entropy
RSquare ranges from 0 to 1, where values closer to 1 indicate a better fit. See “Entropy
RSquare”.

Misclassification Rate (Available only for categorical responses.) The proportion of
observations misclassified by the model. Smaller values indicate a better fit.

Note: In these tables, the misclassification rate is always calculated using a probability
threshold of 0.5.

AUC (Available only for categorical responses.) The area under the ROC curve. Values closer
to 1 indicate a better fit.
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RASE The square root of the mean squared prediction error (Root Average Square Error).
RASE is computed as follows, where Source indicates the Training, Validation, or Test set.

SSE
_ Source
RASESource - A/ n

Generalized RSquare (Available only for categorical responses.) A measure that can be
applied to general regression models. It is based on the likelihood function L and is scaled
to have a maximum value of 1. The value is 1 for a perfect model, and 0 for a model no
better than a constant model. The Generalized RSquare measure simplifies to the
traditional RSquare for continuous normal responses in the standard least squares setting.
Generalized RSquare is also known as the Nagelkerke or Craig and Uhler R?, which is a
normalized version of Cox and Snell’s pseudo R See Nagelkerke (1991).

Fold (Available only if the K Fold Crossvalidation option or the Nested Crossvalidation
option is specified in the launch window.) Identifies the fold that is held out for the model
fit in that row.

Inner Fold (Available only if the Nested Crossvalidation option is specified in the launch
window.) Identifies the inner fold that is held out for the model fit in that row.

Trial (Available only if the Repeated K Fold option is specified in the launch window.)
Identifies the trial number for the model fit in that row.

The following options are available below each table:

Select Dominant Selects each model that is better than or equal to all of the other models in
terms of a combination of model fitting criteria. For continuous responses, RSquare and
Sum Freq are considered when determining the dominant model. For categorical
responses, Entropy RSquare, Misclassification Rate, AUC, and Sum Freq are considered
when determining the dominant model.

Run Selected Runs the individual models specified in each selected row.

Save Script Selected Saves a model script to the script window for each selected row.

w Model Screening Platform Options

Plot Actual by Predicted (Available only for continuous responses.) Shows or hides a report
of plots that overlay the actual by predicted points from all of the model fits. There are
separate plots for the Training, Validation, and Test sets. The report contains a Methods
legend with check boxes that enable you to specify which fits appear on the plots based on
the method, fold, inner fold, and trial combination. Click the Deselect All button at the
bottom of the legend to remove all model fits from the plots.
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Notes:

— If you select a subset of models from the Training, Validation, or Test reports and then
select Plot Actual by Predicted, only the plots for the selected models are shown.

— The actual by predicted plots are not supported by all of the modeling platforms. A list
of unsupported platforms is shown below the plots.

Profiler (Available only for continuous responses.) Shows or hides prediction profilers for
each type of model fit. See Profilers. If any type of folded crossvalidation is specified in the
launch window, the selected model in the prediction profiler uses the fold, inner fold, and
trial combination that corresponds to the final model. The final model is the model that
produces the highest weighted average RSquare. The weight average RSquare is the
average, weighted by number of observations, of the training RSquare, validation
RSquare, and when a test set is used, the test RSquare.

Notes:

— Confidence intervals are shown in prediction profilers for Standard Least Squares
models and Generalized Regression models.

— DPrediction profilers are not available for K Nearest Neighbors models.

ROC Curve (Available only for categorical responses.) Shows or hides a report of plots that
overlay the ROC curves for all of the model fits. There are separate plots for the Training,
Validation, and Test sets. The report contains two legends with check boxes that enable
you to specify which fits appear on the plots. Click the Deselect All button at the bottom of
the legend to remove all model fits from the plots. For more information about ROC
Curves, see “ROC Curve”.

Notes:

— If you select a subset of models from the Training, Validation, or Test reports and then
select ROC Curves, only the plots for the selected models are shown.

— The ROC plots are not supported by all of the modeling platforms. A list of
unsupported platforms is shown below the plots.

Show Profit (Available only for binary categorical responses that have a Profit Matrix
column property.) Shows or hides the expected profit for each model.

Decision Threshold (Available only for binary categorical responses.) Shows or hides
Decision Thresholds reports for the training, validation, and test sets, if specified. Each
report contains a graph of the distribution of fitted probabilities for each model, confusion
matrices for each model, and classification graphs to adjust thresholds and compare the
model fits. See “Decision Thresholds Report”.

Note: If you select a subset of models from the Training, Validation, or Test reports and
then select Decision Threshold, only the information for the selected models is shown.
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Save Results Table Saves the information in the Validation report to a new data table titled
Model Screening Statistics Validation Set. If there is a test set, such as when the Nested
Crossvalidation option is specified, the information in the Test report is also saved to a
new data table titled Model Screening Statistics Test Set.

Save KFold Results Table (Available only if a Crossvalidation option is specified in the
launch window.) Saves the information in the Summary Across the Folds report to a new
data table titled KFold Results.

Save Prediction Formulas (Available only if the live reports are included in the model
report.) Saves the prediction formulas for the selected models to the data table. If you
select a model in the Summary Across the Folds report and any type of fold
crossvalidation is specified in the launch window, the prediction formula is for the fold,
inner fold, and trial combination that corresponds to the final model. The final model is
the model that produces the highest weighted average RSquare. The weight average
RSquare is the average, weighted by number of observations, of the training RSquare,
validation RSquare, and when a test set is used, the test RSquare.

Notes:
— A prediction formula is not saved for Stepwise models.
— A prediction formula is not saved for SVM models when the response is ordinal.

Optional Reports Shows a submenu of additional report options.

Elapsed Time Shows or hides a report that contains the total elapsed time that was spent
fitting each type of model.

Cardinality of Predictors Shows or hides a report of the number of levels and how many
parameters are used in the linear model fit for each categorical predictor.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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Decision Thresholds Report

The Decision Thresholds report enables you to explore thresholds for binary classification
models. There is a Decision Thresholds report for each model data set that is specified by the
validation method. These could be Training, Training and Validation, or Training, Validation,
and Test sets. Each Decision Thresholds report contains a graph of the distribution of fitted
probabilities, a bar chart of classifications, and confusion matrices. All are organized by model
fit, fold, trial, and class level. The report also contains a tabbed section on classification
accuracy measures and an option to set the profit matrix. The report updates as you adjust the
probability threshold.

Distribution of Fitted Probabilities

The distribution of fitted probabilities, or model scores, enables you to see how each
individual model fit differentiates between the two classes. A vertical line on the graph
represents the probability threshold, which determines the classification of each observation.
By default, the probability threshold is 0.5. You can change the probability threshold by
dragging the vertical line or by clicking the Probability Threshold value and entering a new
value. This changes the probability threshold value across the whole Decision Thresholds
report. The value of the probability threshold must be between 0 and 1.

Classification Counts

The bar chart of classifications shows the classification counts for each level of the response
variable at the current threshold. Green bars represent correctly classified observations; red
bars represent incorrectly classified observations.

Confusion Matrices

The confusion matrices, also known as contingency tables, show the two-way classification of
actual and predicted responses for each individual model fit. Confusion rates matrices are
shown as well. The rates are equal to the values in the confusion matrices divided by the row
totals.

Classification Accuracy Measures

False Classification by Threshold Shows a plot of the misclassification count by probability
threshold and a plot of the misclassification rate by probability threshold. Each plot
contains two curves for each individual model fit. The curves for the low response
category are solid and the curves for the high response category are dashed. The curves
intersect at the threshold that yields equal misclassification, counts or rates, of each
response level. There is also a vertical line on each graph that represents the current
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probability threshold value. You can change the probability threshold value by dragging
the vertical line. This changes the probability threshold value across the whole report.

False Classification by Portion Shows a plot of the misclassification count or rate by the
portion of the rank ordered scores. Each plot contains two curves for each individual
model fit. The curves for the low response category are solid and the curves for the high
response category are dashed.

True Classification by Threshold Shows a plot of the true count by the probability threshold
and a plot of the true rate by the probability threshold. Each plot contains two curves for
each individual model fit. The curves for the low response category are dashed and those
for the high response level are solid. The curves intersect at the threshold that yields equal
correct classifications, counts or rates, for each response. There is also a vertical line on
each graph that represents the current probability threshold value. You can change the
probability threshold value by dragging the vertical line. This changes the probability
threshold value across the whole report.

True Classification by Portion Shows a plot of the true count or rate by the portion of the
rank ordered scores. Each plot contains two curves for each individual model fit. The
curves for the low response category are dashed and the curves for the high response
category are solid.

Profit by Threshold (Available only if a profit matrix is specified.)Shows a plot of the average
profit by the probability threshold. There is a curve for each individual model fit and a
vertical line that represents the current probability threshold value. The specified profit
matrix is also shown next to the plot.

Metrics Shows a table of classification accuracy metrics for each model. A legend is
provided to describe how the metric in each column is calculated.

Set Profit Matrix

Enables you to assign costs to undesirable outcomes and profits to desirable outcomes. See
“Specify Profit Matrix”. If you change the probability threshold in the profit matrix window
and click OK, the Decision Thresholds report is updated using that value as the probability
threshold.
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Compare the Predictive Ability of Fitted Models

The Model Comparison platform is available only in JMP Pro.

The Model Comparison platform in JMP Pro lets you compare the predictive ability of
different models. Measures of fit are provided for each model along with overlaid diagnostic
plots.

Figure 11.1 Example of Comparing Models

4 *|Model Comparison
4 Predictors
Target Column Predictors
mvalue mvalue Predictor Bootstrap Forest
Pred Formula mvalue Fit Least Squares

4 Measures of Fit for mvalue

validation Predictor Creator 2.4.6.8 RSquare RASE AAE Freq
0 mvalue Predictor Bootstrap Forest 0.3630 3.2880 2.1299 405
0 Pred Formula mvalue Fit Least Squares 07295 4.6206 3.1577 405
1 mvalue Predictor Bootstrap Forest 0.8715 36625 2.7638 101
1 Pred Formula mvalue Fit Least Squares 07624 49796 3.7880 101
4 Actual by Predicted Plot
4 Actual by Predicted Plot for mvalue validation=0 4 Actual by Predicted Plot for mvalue validation=1
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w Example of Model Comparison

This section provides an example of using the Model Comparison platform. The example uses
demographic data to build a model for median home price. A regression model and a
bootstrap forest model are compared.

Begin by selecting Help > Sample Data Library and opening Boston Housing.jmp.

Create a Validation Column

1.

ISR LI

Select Analyze > Predictive Modeling > Make Validation Column.

Do not select any columns in the launch window.

This indicates that the platform will create a simple random validation column
Click OK.

In the box next to New Column Name, type Create Validation.

In the box next to Random Seed, enter 1234.

Click Go.

A new Validation column is created. The rows assigned a 0 are the training set. The rows
assigned a 1 are the validation set.

Create the Regression Model and Save the Prediction Formula to a Column

¥ X N wh =

Select Analyze > Fit Model.

Select mvalue and click Y.

Select crim through Istat and click Add.

Select Create Validation and click Validation.

Select Stepwise in the Personality list.

Click the Run button.

Select P-value Threshold from the Stopping Rule list.
Click the Go button.

Click the Run Model button.
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Figure 11.2 Fit Model Report

£ ~|Response mvalue
Validation: Create Validation

[ Effect Summary

< Summary of Fit
RSquare 0.753084
RSquare Adj 0.74663
Root Mean Square Error 4787344
Mean of Response 23.02868
Observations (or Sum Wagts) 380
< Analysis of Variance
Sum of
Source DF Squares Mean Square
Medel 11 25848508
Error 368 8434080

C. Total 379 34282577

<4 Parameter Estimates
Std Error tRatio Prob:|t|

Term Estimate
Intercept  38.300819
crim -0.128236
zn 0.0434609
chas[0] -1.215423
nox -15.38054
rocms 3.8274522
distance -1.501159
radial 0.3364500
tax -0.012471
pt -0.994523
b 0.0088057
Istat -0.59358

5.676983

0.03545
0.013555
0.490413
4180064
0.445164
0.218407
0.073112
0.003826
0.146259
0.003206
0.054166

F Ratio

234986 102.5306

2292 Prob>F

6.78
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10. To save the prediction formula to a column, click the Response red triangle and select Save
Columns > Prediction Formula.

Create the Bootstrap Forest Model and Save the Prediction Formula to a Column

O X NN o W N =

Select Analyze > Predictive Modeling > Bootstrap Forest.
Select mvalue and click Y, Response.
Select crim through Istat and click X, Factor.

Select Create Validation and click Validation.

Click OK.

Select the Early Stopping check box.
Select the Multiple Fits over number of terms check box.
Enter 617 in the box next to Random Seed.

Click OK.
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Figure 11.3 Bootstrap Forest Model

£ |~ Bootstrap Forest for mvalue

< Specifications

Model Comparison
Example of Model Comparison

Target mvalue Training Rows: 380

Validation Column: Create Validation Validation Rows: 126
Test Rows: 0

Number of Trees in the Forest: 100 Number of Terms: 13

Number of Terms Sampled per Split: 10 Bootstrap Samples: 380
Minimum Splits per Tree: 10
Minimum Size Split: 5

4 Qverall Statistics

Individual

Trees RASE

In Bag 1.997080

OutofBag 5.217378

RSquare RASE N
Training 0938 23691145 380
Validation 0.842 31747064 126

10. To save the prediction formula to a column, click the Bootstrap Forest red triangle and
select Save Columns > Save Prediction Formula.

Compare the Models

1. Select Analyze > Predictive Modeling > Model Comparison.
2. Select the two prediction formula columns and click Y, Predictors.
3. Select Create Validation and click Group.
Tip: If a Group column is not specified, JMP automatically recognizes when the same

validation column has been used for all predictors and prompts you to add it as a
grouping variable.

4. Click OK.

Figure 11.4 Model Comparison Report

£~/ Model Comparison

P Predictors

<4 Measures of Fit for mvalue
Create
Validation Predictor Creator .2.4.6.8 RSquare RASE AAE Freq
Training Pred Formula mvalue 2 Fit Least Squares 0.7540 47111 3.3770 380
Training mvalue Predictor 2 Bootstrap Forest 0.9378 2.3691 1.4382 380
Validation Pred Formula mvalue 2 Fit Least Squares 0.6530 4.6972 3.3155 126
Validation mwvalue Predictor 2 Bootstrap Forest 0.8424 31747 1.8776 126

The rows in the training set were used to build the models, so the RSquare statistics for
Create Validation = Training might be artificially inflated. In this case, the statistics are not
representative of the models’ future predictive ability. This is especially true for the
bootstrap forest model.
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Compare the models using the statistics for Create Validation = Validation. In this case, the
bootstrap forest model predicts better than the regression model.

5. Click the Model Comparison red triangle and select Profiler.

Figure 11.5 Prediction Profiler for All Models

4|~ |Prediction Profiler

The prediction profiler enables you to compare the impact of each factor in the different
models. The profiler is especially interesting when comparing different types of models
such as here where you have a regression model and a partition model.

Related Information

e Fitting Linear Models

e “Partition Models”

JMP

PRO

Launch the Model Comparison Platform

To launch the Model Comparison platform, select Analyze > Predictive Modeling > Model
Comparison.

Figure 11.6 The Model Comparison Launch Window

Compares performance across medels using prediction formula celumns.

Select Columns Cast Selected Columns into Roles Action

=117 Columns all mvalue Predictor

ﬁ;:m f:iri:l.Formula mvalue

dll indus

;chas 4 validation
nox

dll rooms T

e

dl distance

A radial

A tax optional numeric

d pt

i optional

all Istat ’ -

A mvalue If you choose no Predictor columns, it will find and

- analyze all predictors.
dll validation o P

all mvalue Predictor
dll Pred Formula mvalue
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For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Y, Predictors The columns that contain the predictions for the models that you want to
compare. They can be either formula columns or just data columns. Prediction formula
columns created by JMP platforms have either the Predicting or Response Probability
column property. If you specify a column that does not contain one of these properties, the
platform prompts you to specify which column is being predicted by the specified Y
column.

For a categorical response with k levels, most model fitting platforms save k columns to the
data table, each predicting the probability for a level. All k columns need to be specified as
Y, Predictors. For platforms that do not save k columns of probabilities, the column
containing the predicted response level can be specified as a Y, Predictors column.

If you do not specify any Y, Predictors columns, JMP uses the prediction formula columns
in the data table that have either the Predicting or Response Probability column property.

Group The column that separates the data into groups, which are evaluated separately. If a
Group column is not specified, JMP automatically recognizes when the same validation
column has been used for all predictors and prompts you to add it as a grouping variable.

The other role buttons are common among JMP platforms. See Using JMP.

w The Model Comparison Report

Figure 11.7 shows an example of the initial Model Comparison report for a continuous
response.

Figure 11.7 Initial Model Comparison Report

£~/ Model Comparison
I Predictors

< Measures of Fit for mvalue

Create

Validation Predictor Creator .2.4.6.8 RSquare RASE AAE Freq
Training Pred Formula mvalue 2 Fit Least Squares 0.7540 47111 3.3770 380
Training mvalue Predictor 2 Bootstrap Forest 0.9378 2.3691 1.4382 380
Validation Pred Formula mvalue 2 Fit Least Squares 0.6530 4.6972 3.3155 126
Validation mwvalue Predictor 2 Bootstrap Forest 0.8424 31747 1.8776 126

The Predictors report shows all responses and all models being compared for each response.
The fitting platform that created the predictor column is also listed.

The Measures of Fit report shows measures of fit for each model. The columns are different for
continuous and categorical responses.



194

Model Comparison Chapter 11
The Model Comparison Report Predictive and Specialized Modeling

Measures of Fit for Continuous Responses

RSquare The r-squared statistic. In data tables that contain no missing values, the r-squared
statistics in the Model Comparison report and original models match. However, if there
are any missing values, the r-squared statistics differ.

RASE The square root of the mean squared prediction error. This is computed as follows:

— Square and sum the prediction errors (differences between the actual responses and the
predicted responses) to obtain the SSE.

— Denote the number of observations by n.
- RASEis:

RASE= [35E
n

AAE The average absolute error.

Freq The column that contains frequency counts for each row.

Measures of Fit for Categorical Responses

Entropy RSquare One minus the ratio of the negative log-likelihoods from the fitted model
and the constant probability model. It ranges from 0 to 1.

Generalized RSquare A measure that can be applied to general regression models. It is
based on the likelihood function L and is scaled to have a maximum value of 1. The value
is 1 for a perfect model, and 0 for a model no better than a constant model. The
Generalized RSquare measure simplifies to the traditional RSquare for continuous normal
responses in the standard least squares setting. Generalized RSquare is also known as the
Nagelkerke or Craig and Uhler R?, which is a normalized version of Cox and Snell’s
pseudo R? See Nagelkerke (1991).

Mean -Log p The average of -log(p), where p is the fitted probability associated with the
event that occurred.

RASE The root average squared prediction error. For categorical responses, the differences
are between 1 and p, the fitted probability for the response level that actually occurred.

Mean Abs Dev The average of the absolute values of the differences between the response
and the predicted response. For categorical responses, the differences are between 1 and p
(the fitted probability for the response level that actually occurred).

Misclassification Rate The rate for which the response category with the highest fitted
probability is not the observed category.

N The number of observations.
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Related Information

“Training and Validation Measures of Fit” provides more information about measures of fit
for categorical responses.

w Model Comparison Platform Options

po Continuous and Categorical Responses

Model Averaging Makes a new column of the arithmetic mean of the predicted values (for
continuous responses) or the predicted.probabilities (for categorical responses).

P Continuous Responses

Plot Actual by Predicted Shows a scatterplot of the actual versus the predicted values. The
plots for the different models are overlaid.

Plot Residual by Row Shows a plot of the residuals by row number. The plots for the
different models are overlaid.

Profiler Shows a profiler for each response based on prediction formula columns in your
data. The profilers have a row for each model being compared.

pio Categorical Responses

ROC Curve Shows ROC curves for each level of the response variable. The curves for the
different models are overlaid.

AUC Comparison Provides a comparison of the area under the ROC curve (AUC) from each
model. The area under the curve is the indicator of the goodness of fit, where 1 is a perfect
fit.

The report includes the following information:

— standard errors and confidence intervals for each AUC

— standard errors, confidence intervals, and hypothesis tests for the difference between
each pair of AUCs

— an overall hypothesis test for testing whether all AUCs are equal

Lift Curve Shows lift curves for each level of the response variable. The curves for the
different models are overlaid.
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Cum Gains Curve Shows cumulative gains curves for each level of the response variable. A
cumulative gains curve is a plot of the proportion of a response level that is identified by
the model against the proportion of all responses. A cumulative gains curve for a perfect
model would reach 1.0 at the overall proportion of the response level. The curves for the
different models are overlaid.

Confusion Matrix Shows confusion matrices for each model. A confusion matrix is a
two-way classification of actual and predicted responses. Count and rate confusion
matrices are shown. Separate confusion matrices are produced for each level of the Group
variable.

If the response has a Profit Matrix column property, then Actual by Decision Count and
Actual by Decision Rate matrices are shown to the right of the confusion matrices. For
more information about these matrices, see “Additional Examples of Partitioning”.

Profiler Shows a profiler for each response based on prediction formula columns in your
data. The profilers have a row for each model being compared.

Decision Threshold (Available only for binary categorical responses.) Shows or hides
Decision Thresholds reports for the training, validation, and test sets, if specified. Each
report contains a graph of the distribution of fitted probabilities for each model, confusion
matrices for each model, and classification graphs to compare the model fits. See “Decision
Thresholds Report”.

Related Information

e “ROC Curve”

e “Lift Curve”

JUP
PRO

Additional Example of Model Comparison

This example uses automobile data to build a model to predict the size of the purchased car. A
logistic regression model and a decision tree model are compared.

Begin by selecting Help > Sample Data Library and opening Car Physical Data.jmp.

Create the Logistic Regression Model

1. Select Analyze > Fit Model.
2. Select Type and click Y.

3. Select the following columns and click Add: Country, Weight, Turning Cycle, Displacement,
and Horsepower.

4. Click Run.
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The Nominal Logistic Fit report appears.
5. To save the prediction formulas to columns, click the Nominal Logistic red triangle and

select Save Probability Formula.

Create the Decision Tree Model and Save the Prediction Formula to a Column

1. Select Analyze > Predictive Modeling > Partition.

2. Select Type and click Y, Response.

3. Select the Country, Weight, Turning Cycle, Displacement, and Horsepower columns and click
X, Factor.

4. Make sure that Decision Tree is selected in the Method list.
Click OK.
The Partition report appears.

6. Click Split 10 times.

7. To save the prediction formulas to columns, click the Partition red triangle and select Save
Columns > Save Prediction Formula.

Compare the Models

1. Select Analyze > Predictive Modeling > Model Comparison.

2. Select all columns that begin with Prob and click Y, Predictors.

3. Click OK.

Figure 11.8 Initial Model Comparison Report

4 = Model Comparison

Predictors
4 Measures of Fit for Type
Entropy Generalized Mean Misclassification
Creator .2.4.6.8 RSquare RSquare Mean-Logp RASE AbsDev Rate N
Fit Nominal Logistic 0.5821 0.8798 0.6656 0.4780  0.3900 0.3103 116
Partiticn 0.6243 0.9006 0.5976 0.4575 0.3986 0.2759 116

The report shows that the Partition model has slightly higher values for Entropy RSquare
and Generalized RSquare and a slightly lower value for Misclassification Rate.

Click the Model Comparison red triangle and select ROC Curve.

ROC curves appear for each Type, one of which is shown in Figure 11.9.
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Figure 11.9 ROC Curve for Medium
£ ROC Curve for Type=Medium

1.00 Predictor Creator AUC
— Prob[Medium] Fit Neminal Logistic 0.9314

20 — Prob{Type==Medium) Partition 0.9085

0.80
0.70
0.60
0.50

Sensitivity
True Positive

0.40
0.30
0.20
0.10

0
0 0.20 0.40 0.60 0.80 1.00
1-Specificity
False Positive

Examining all the ROC curves, you see that the two models are similar in their predictive
ability.
Click the Model Comparison red triangle and select AUC Comparison.

AUC Comparison reports appear for each Type, one of which is shown in Figure 11.10.

Figure 11.10 AUC Comparison for Medium

< AUC Comparison for Type=Medium

Predictor AUC StdError Lower95% Upper95%
Prob[Medium] 0.9314 0.0218 0.8742 0.9637
Prob(Type==Medium) 0.2085 0.0255 0.5448 0.9477
AucC
Predictor vs. Predictor Difference Std Error Lower 95% Upper 95% ChiSquare Prob>ChiSq
Prob[Medium] Prob{Type==Medium) 0.0229 0.0234 -0.023 0.0687 0.9553 0.3284
Test ChiSquare DF Prob=ChiSq
All AUCs equal 0.95534 1 0.3284

The report shows results for a hypothesis test for the difference between the AUC values (area
under the ROC curve). Examining the results, you see there is no statistical difference between
the values for any level of Type.

You conclude that there is no large difference between the predictive abilities of the two
models for the following reasons:

The R Square values and the ROC curves are similar.

There is no statistically significant difference between AUC values.



Chapter 12

rio Make Validation Column
Divide Data into Training, Validation, and Test Sets

The Make Validation Column platform is available only in JMP Pro.

Validation is the process of using part of a data set to estimate model parameters and using
another part to assess the predictive ability of a model. You can partition the data into two or
three sets. The Make Validation Column platform provides five different methods to create
these partitions.
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w Overview of the Make Validation Column Platform

Validation is the process of using part of a data set to estimate model parameters and using
another part to assess the predictive ability of a model. With complex data, this can reduce the
risk of model overfitting.

A validation column partitions the data into two or three parts.

¢ The training set is used to estimate the model parameters.

e The validation set is used to help choose a model with good predictive ability.

* The testing set checks the model’s predictive ability after a model has been chosen.

A validation column can be used as a validation method in many JMP platforms. See
“Validation in JMP Modeling”.

The Make Validation Column platform enables you to create training, validation, and test sets
using a variety of methods. You can specify stratification, grouping, or cutpoint columns to
determine the method used to create the validation column.

w Example of Make Validation Column

The Lipid Data.jmp data table contains blood measurements, physical measurements, and
questionnaire data from 95 subjects at a California hospital. You are interested in creating a
validation column to use during future analyses.

1. Select Help > Sample Data Library and open Lipid Data.jmp.
2. Select Analyze > Distribution.

3. Select Gender and click Y, Columns.

4. Click OK.
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Figure 12.1 Distribution of Gender in Lipid Data.jmp

4 = |Distributions
4 =|Gender

male

female

4 Frequencies

Level Count Prob
female 24 0.25263
male 71 074737
Total 95 1.00000
N Missing 0

2 Levels

Figure 12.1 illustrates the distribution of Gender in the data set. Notice that there is not an
equal proportion of males and females represented. Because there are fewer females
within the data, you want to be sure to balance the genders across the validation and
training sets.

5. Select Analyze > Predictive Modeling > Make Validation Column.
6. Select Gender and click Stratification Columns.
7. Click OK.

The Make Validation Column report appears with a description of the validation method
you selected. There are also options to change the rates, column types, or set a seed.

8. (Optional) Type 1234 next to Random Seed in the Options section of the report.
9. C(lick Go.

A Validation column is added to the data table. You can explore the distribution of the
validation and training sets by creating a Mosaic Plot.

10. Select Analyze > Fit Y by X.
11. Assign Validation to Y, Response, and Gender to X, Factor.
12. Click OK.
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Figure 12.2 Distribution of Gender across Validation and Training Sets

4 Mosaic Plot
1.00

Validation

0.75

0.50

Validation

Training

0.25

0.00

male

Gender

Figure 12.2 illustrates the distribution of Gender across each of the validation and training sets.
Note that about 75% of both females and males are in the training set and about 25% of both
females and males are in the validation set.

s Launch the Make Validation Column Platform

Launch the Make Validation Column platform by selecting Analyze > Predictive Modeling >
Make Validation Column.

Figure 12.3 Make Validation Column Launch Window

Makes a column used to divide the data into training, validation, and test sets.

-Select Columns ——— - Cast Selected Columns into Roles ————— - Action

[*15 Columns Stratification Columns|| opfiona! oK
rjy
th sex
: \::Z:tt Grouping Columns || optional Remove

-Selected Method ——————————
Make Validation Column ~ ~ Cutpoint Column || optional numeric

Random Validation Column

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Make Validation Column launch window provides the following options:
Stratification Columns Assigns one or more stratification columns.

Grouping Columns Assigns one or more grouping columns.
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Cutpoint Column Assigns a numeric cutpoint column.

Cutpoint Batch ID When a cutpoint column is assigned, you can also assign a column for
cutpoint batch IDs. This enables you to determine cutpoint values within each level of
the Cutpoint Batch ID column.

Selected Method

Provides two methods for validation.

Make Validation Column creates a validation column based on the specified stratification,
grouping, and cutpoint columns. The validation column method determined by the
specified stratification, grouping, and cutpoint columns is described below the box. After
a method is selected and you click OK, you specify the allocations for each set in the Make
Validation Column report. See “Specify Rates or Relative Rates” and “Set Cutpoints”.
There are five methods for constructing the holdback sets.

Random Validation Column The default method if there are no column assignments in
the launch window. This method partitions the data into sets based on the allocations
entered in the Make Validation Column report.

Stratified Validation Column The selected method if one or more stratification columns
are assigned. This method partitions the data into balanced sets based on the levels of
the specified stratification columns. As in the Random Validation Column method,
rows are randomly assigned to the holdback sets based on the allocations entered in
the Make Validation Column report. However, this is done at each level or combination
of levels of the stratifying columns. Use this method when you want a balanced
representation of the levels of a column in each of the training, validation, and test sets.

Grouped Validation Column The selected method if one or more grouping columns are
specified. This method partitions the data into sets in such a way that entire levels of a
specified column or combinations of levels of two or more columns are placed in the
same set. Because of this, the sizes of the resulting sets vary slightly from the sizes that
you specified. Use this option when splitting levels across holdback sets is not
desirable.

Stratify by Group Validation Column The selected method if both stratification and
grouping columns are specified. This method partitions the data to balance the levels
across the stratification column while requiring that the specified groups stay together
in the same holdback sets. As in Grouped Validation Column, groups can be created as
levels of a specified column or combination of levels of two or more columns. The sizes
of the resulting sets vary slightly from the sizes you specified.
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Cutpoint Validation Column The selected method if a cutpoint column is specified. This
method partitions the data into sets based on the time series cutpoints. Use this option
when you want to assign your data to holdback sets based on time periods. The
training set consists of rows between the first cutpoint and the second cutpoint. The
validation set consists of rows between the second and third cutpoints. The test set
consists of the remaining rows. These sets are chosen based on options in the Set
Cutpoints report.

Make Autovalidation Table Creates a new data table that contains a duplication of the rows
in the original data table concatenated to the rows in the original data table. The new data
table, which can be used for crossvalidation, has four additional columns:

Valid Set Assigns a value of 0 to the original data and a value of 1 to the duplicated data.
The values in this column designate the training and validation sets. Use this column in
the Validation role in the launch window of an analysis.

Valid ID Assigns the row number of the original observation. This allows matching of
training and validation set rows for each original observation.

Valid Weight Assigns the autovalidation weight, to be used in the Freq role in the launch
window of an analysis. For each value of Valid ID, the same uniform random number is
generated for the training observation and the validation observation. For the training
set, Valid Weight is calculated as follows:

Valid Weight = -log(1 - Valid Uniform)
For the validation set, Valid Weight is calculated as follows:
Valid Weight = -log(Valid Uniform)

The Valid Weight column is constructed so that the training data weights are negatively
correlated with the validation data weights. This ensures that the difference in the fit of
the validation data yields an effective crossvalidation of the fitting method.

Null Factor Assigns the same normal random number for each value of Valid ID.

Tip: Use Make Autovalidation Table for small data tables, where using a subset as the
training data could cause estimation problems.
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u Make Validation Column Report

When you click OK in the launch window, the Make Validation Column report window
appears. The report contains a description of the validation method you selected and relevant
options for rates, cutpoints, column type, and setting a random seed.

pio Specify Rates or Relative Rates

This report enables you to specify the allocations for the training, validation, and test sets. In
the boxes next to Training Set, Validation Set, and Test Set, enter values that represent the
proportions or numbers of rows that you would like to include in each of these sets. The
default values construct a training set that contains about 75% of the rows and a validation set
that contains about 25% of the rows.

Depending on the number of rows in the data table and the selected validation method, the
actual sizes of the resulting sets might vary slightly from the sizes that you specified. The
Adjusted Rates, Row Counts, and Group Count columns provide the actual sizes of the sets.

pio Set Cutpoints

This report is shown only when a cutpoint column is specified in the launch window. The
cutpoints are determined by one of the following four methods:

Proportions Determines the cutpoints based on the proportions of rows specified for each
set. In the boxes next to Training Set, Validation Set, and Test Set, enter values that
represent the proportions that you would like to include in each of these sets. Depending
on the number of rows and the proportions, the actual sizes of the resulting sets might
vary slightly from the sizes you specified.

Number of Rows Determines the cutpoints based on the number of rows specified for each
set. In the boxes next to Training Set, Validation Set, and Test Set, enter values that
represent the number of rows that you would like to include in each of these sets. This
option enables you to specify the sets exactly.

Fixed Time or Date Determines the cutpoints based on fixed data points in the specified
cutpoint column. If you select this option, the minimum and maximum values for the
cutpoint column are shown for reference. In the boxes next to Training Set, Validation Set,
and Test Set, enter the value that represents the minimum value that you would like to
include in each of these sets.

Elapsed Time Determines the cutpoints based on the amount of time that has elapsed since
the first timestamp in the cutpoint column. If you select this option, the total elapsed time
from the first value to the last value is shown for reference. In the boxes next to Training
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Set, Validation Set, and Test Set, enter the values that represent the amounts of elapsed
time that you would like to include in each of these sets.

b0 Options
You can also specify the following additional options:

New Column Name Enables you to specify the name of the validation column.

Validation Column Type (Not available for the Cutpoint Validation Column method.)
Enables you to specify the validation column type as fixed or formula.

— The fixed column type produces a column with fixed values.

— The formula column type produces a formula column as the validation column.

Random Seed (Not available for the Cutpoint Validation Column method or if a formula

column type is specified.) Enables you to set a random seed to reproduce the same
validation column in the future.

Click Go in the Make Validation Column report to add the validation column to the data table.
The validation column has a Notes property that gives the stratifying, grouping, or cutpoint
variables.

» Make Validation Column Platform Options

The Make Validation Column Utility has the following red triangle menu options:

See Using [MP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.
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w Additional Example of the Make Validation
Column Platform

This example uses weekly weather data collected over one year from 16 weather stations
across the United States. Run the Weather Station Locations script in the data table to view a
map of the locations. Not every weather station has a weekly temperature measurement for
every week of the year. You are interested in creating a validation column for this data table
based on the dates of data collection. For each weather station, you want to use the first 60% of
observations for training, the next 25% of observations for validation, and the final 15% of
observations for testing. This example shows the importance of using a Batch ID column in
this type of scenario.

Create Validation Column with Cutpoints

N

9.

AL

Select Help > Sample Data Library and open Functional Data/Weekly Weather Data.jmp.
Select Analyze > Predictive Modeling > Make Validation Column.

Select Week of Year and click Cutpoint Column.

Click OK.

In the list next to Determine cutpoints using, select Proportions.

In the boxes next to Training Set, Validation Set, and Test Set, enter 0.60, 0.25, and 0.15,
respectively.

In the box next to New Column Name, type Cutpoint Validation.
Click Go.
A validation column called Cutpoint Validation is added to the data table.

Select Analyze > Tabulate.

10. Click ID and drag it to the Drop zone for rows.

11. Click Cutpoint Validation and drag it on top of N.
12. Click Row% and drag it on top of the cells.
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Figure 12.4 Cutpoint Validation Column Proportions

Cutpoint Validation

Training | Validation Test|
1D Row % Row %| Row %
Bristol, TN 62.70% 20.03%| 16.28%
Corpus Christi, TX 70.27% 18.92%| 10.81%
Denver, CO 58.14% 23.26%| 18.60%
Goodwell, OK 64.71% 17.65%| 17.65%
Grand Canycn Mational Park, AZ | 53.66% 26.83%| 19.31%
Greenville, ME 60.47% 20.93%| 18.60%
Harrisburg, PA 60.53% 26.32%| 13.16%
Helena, MT 60.00% 25.00%| 15.00%
Lynchburg, VA 71.79% 17.05%| 10.26%
Madera, CA 67.50% 22.50%| 10.00%
Miami Beach, FL 63.16% 26.32%| 10.53%
Minneapolis/St. Paul, MN 57.50% 27.50%| 15.00%
M. Myrtle Beach, SC 60.05% 16.67%| 14.20%
Peason Ridge Range, LA 57.80% 28.95%| 13.16%
Philip, SD 50.52% 23.81%| 16.67%
Terra Haute, IN 47.22% 33.33%| 19.44%

Figure 12.4 shows that not all of the weather stations have the correct proportions for the
training, validation, and test sets. Use a Batch ID column to obtain the correct percentages.

Create Validation Column with Cutpoints and Batch ID

Select Analyze > Predictive Modeling > Make Validation Column.
Select Week of Year and click Cutpoint Column.

Select ID and click Cutpoint Batch ID.

Click OK.

In the list next to Determine cutpoints using, select Proportions.

AU

In the boxes next to Training Set, Validation Set, and Test Set, enter 0.60, 0.25, and 0.15,
respectively.

N

In the box next to New Column Name, type Cutpoint Batch Validation.

Click Go.

A validation column called Cutpoint Batch Validation is added to the data table.
9. Select Analyze > Tabulate.

10. Click ID and drag it to the Drop zone for rows.

11. Click Cutpoint Batch Validation and drag it on top of N.

12. Click Row% and drag it on top of the cells.



210

Make Validation Column

Additional Example of the Make Validation Column Platform

Chapter 12
Predictive and Specialized Modeling

Figure 12.5 Cutpoint Validation Column with Batch ID Proportions

Cutpoint Batch Validation

Training | Validation Test|
1D Row % Row %| Row %
Bristol, TN 60.47% 13.95%
Corpus Christi, TX 50.46% 16.22%
Denver, CO 60.47% 13.95%
Goodwell, OK 58.82% 14.71%
Grand Canycn Mational Park, AZ | 60.98% 14.63%
Greenville, ME 60.47% 13.95%
Harriskburg, PA 60.53% 13.16%
Helena, MT 60.00% 15.00%
Lynchburg, VA 58.97% 15.38%
Madera, CA 60.00% 15.00%
Miami Beach, FL 60.53% 13.16%
Minneapolis/St. Paul, MN 60.00% 15.00%
M. Myrtle Beach, SC 50.52% 14.20%
Peason Ridge Range, LA 60.53% 13.16%
Philip, SD 50.52% 14.20%
Terra Haute, [N 61.11% 13.80%

Figure 12.5 shows that using a Cutpoint Batch ID column ensures that each weather
station has proportions for the training, validation, and test sets that are much closer to the

specified values.
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sio Formula Depot
Manage Models and Generate Scoring Code

The Formula Depot Platform is available only in JMP Pro.

The Formula Depot is a repository to organize, compare, and profile models. Scoring code for
deployment within or outside of JMP can be generated for models published to the Formula
Depot. For model exploration work, you can use the Formula Depot to store candidate models
outside of your JMP data table. The model profiler and model compare platforms are
accessible from the Formula Depot. A model that is selected for further use can be saved to
your JMP table or saved to a JMP table with new data for scoring. For use in an environment
outside of JMP, you can generate scoring code in C, Python, JavaScript, SAS, or SQL.

Figure 13.1 Example of the Formula Depot

£ ~|Formula Depot

Manage Models and Generate Scoring Code
< Formula Scripts

4 [=|Fit Generalized
Formulas
Table Liver Cancer
Creator  Fit Generalized
Target
Created Mode Count Prediction Formula
Factors Age BMI, Hepatitis, Jaundice, Markers, Time
£ = |Partition - Severity
Publish Prediction Fermula
Table Liver Cancer
Creator  Partition
Target  Severity
Created Most Likely Severity
Factors Age BMI, Jaundice, Markers, Time
Others  Prob(Severity==High), Prob{Severity==Low)
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w Overview of the Formula Depot Platform

The Formula Depot is a repository to organize, compare, profile, and score models for
deployment. Models are prediction formulas. Prediction formulas are saved to the Formula
Depot as column scripts. You can add prediction formulas to JMP tables to score data. You can
also use the Formula Depot to generate scoring code for prediction formulas to facilitate the
deployment of models in environments outside of JMP.

The Formula Depot enables you to perform the following tasks:

* save prediction formulas outside of data tables

¢ save prediction formulas from multiple data tables in a common location

* save intermediate cleaning formulas within a prediction formula

e compare models

e profile models

* add prediction formulas to a data table for scoring of new data within J]MP

* generate scoring code (C, Python, JavaScript, SAS, or SQL) for deploying models outside
of JMP

® The Formula Depot includes intermediate formulas in the generated scoring code. A
model constructed from inputs with column formulas includes the corresponding
formulas in the scoring code. For example, if your model includes a recoded variable the
recode formula is included in the scoring code. This enables you to apply your prediction
formula to raw data that has not been processed.

Note: Informative missing is not a supported intermediate formula.

w Example of Formula Depot

The Liver Cancer.jmp sample data table contains data on the severity of liver cancer in patients
when they entered a study. The file also contains a number of table scripts for models. This
example uses these scripts to generate models to demonstrate the Formula Depot.

1. Select Help > Sample Data Library and open Liver Cancer.jmp.
2. Click the green triangle next to the Lasso Poisson, Validation Column script.

3. Click the red triangle next to Poisson Adaptive Lasso with Validation Column and select
Save Columns > Publish Prediction Formula.

This option opens a Formula Depot that contains the prediction formula for the Fit
Generalized model.
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4. To add the prediction formula to the data table, select Run Script from the Fit Generalized
- Node Count red triangle in the Formula Depot.

Note: The result of step 3 and step 4 can be obtained using the Save Columns > Save
Prediction Formula at step 3. However, then the prediction formula is not part of the
Formula Depot

5. To generate scoring code for use outside of JMP select a code type from the Fit Generalized
- Node Count red triangle. A script window appears containing the code. See “Generating
Scoring Code from the Formula Depot Platform”.

6. To save the Formula Depot, select File > Save.

Note: The Formula Depot is saved as a JMP Report File (*.jrp).

Figure 13.2 Formula Depot with a Generalized Model

£ ~|Formula Depot
Manage Models and Generate Scoring Code
4 Formula Scripts
4 [=|Fit Generalized
Formulas
Table Liver Cancer
Creator  Fit Generalized
Target
Created Mode Count Prediction Formula
Factors Age BMI, Hepatitis, Jaundice, Markers, Time

JMP

PRO

Launch the Formula Depot Platform

Launch the Formula Depot by selecting Analyze > Predictive Modeling > Formula Depot.

Figure 13.3 Empty Formula Depot from Launch

£ =|Formula Depot

Fo_rmula Scripts

Alternatively, if there is not an open Formula Depot then a Formula Depot opens when you
select a Publish command.
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vio Platforms That Publish Prediction Formulas to the Formula
Depot

The platforms that publish prediction formulas and generate scoring code include:

¢ Discriminant

* Least Squares Regression
* Logistic Regression

® Partition

e Uplift

e K Nearest Neighbors

¢ Naive Bayes

¢ Neural

¢ Latent Class Analysis

® Principal Components
* Generalized Regression
e PLS

e Gaussian Process

In platforms that do not publish prediction formulas to the Formula Depot, you can save the
prediction formula to the data table. From the data table, add it to the Formula Depot by
selecting Add Formula from Column. However, the scoring code might not be fully functional
for such models. For more information about scoring code see “Generating Scoring Code from
the Formula Depot Platform”.

In addition, you can publish a formula directly from the formula editor. Select the formula,
right-click, and select Publish expression to formula depot.

w Formula Depot Platform Options

Add Formula From Column Enables you to add existing prediction formulas from data table
columns to the current formula depot. If your table has only one formula, that formula is
added to the depot. If you have multiple column formulas, a dialog box enables you to
select the formulas of interest. If your formula columns are selected in your data table,
they will be pre-selected in the dialog box.

Show Scripts Opens a new Formula Window (or appends to an open Formula Window)
that contains scripts for all of the formulas that are in the current formula depot.
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Copy Scripts Copies all scripts from the current formula depot to the clipboard.

Copy Formulas as Functions Enables you to select models from the current formula depot
to be copied as functions for use in JSL. Selected models are copied onto the clipboard. The
functions act on scalar variables rather than columns. One Namespace is generated for
each selected model. Each Namespace has one function, called predict, that takes the
model inputs as parameters and returns the model predictor.

Copy Formulas as Transforms Enables you to select models from the current formula depot
to be copied. Selected models are copied onto the clipboard within a Transform
Columns () statement.

Run Scripts Enables you to save models from the current formula depot to new columns in
your JMP data table. Formulas with intermediate column formulas will add the
intermediate columns to your JMP data table.

Note: If you have more than one data table open, a Choose Table window appears that
enables you to specify which data table to use for Run Scripts.

Generate C Code, Generate Python Code, Generate JavaScript Code, Generate SAS Code,

and Generate SQL Code Enables you to select models from the current formula depot for
code generation. A new script window appears that contains scoring code for the selected
models in C, Python, JavaScript, SAS DS2, or SQL, respectively. You can use this code to
facilitate the deployment of the model in the environment or framework of your choice.
See “Generating Scoring Code from the Formula Depot Platform”.

Model Comparison Enables you to select models from the current formula depot to be
compared using the model comparison utility. If models from multiple tables are stored in
the depot, first select the table of interest and then the models of interest. Hold the shift
key when selecting the Model Comparison option to launch the Model Comparison in a
new window. See “Model Comparison”.

Note: If you have more than one data table open, a Choose Table window appears that
enables you to specify which data table to use for the Model Comparison.

Remove Model Comparison Removes all Model Comparison reports from the current
formula depot.

Profiler Enables you to select models from the current formula depot to be profiled using the
profiler. If models from multiple tables are stored in the depot you first select the table of
interest and then the models of interest. Hold the shift key when selecting the profiler
option to launch the profiler in a new window. See Profilers.
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Note: If you have more than one data table open, a Choose Table window appears that
enables you to specify which data table to use for the Profiler.
Remove Profiler Removes all Profilers from the current formula depot.

See Using [MP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

pio Formula Depot Model Options

Each prediction formula that is saved in the Formula Depot has an individual options menu.
In addition to Show, Copy, Run, and Code Generation options that correspond to the main
menu options, the individual menus include the following options:

Rename New Column Enables you to rename the model. This new name is applied as the
column name if you run the script to add the prediction formula to a JMP data table. In
addition, this name is included in generated code.

Remove Removes the model from the Formula Depot. This command cannot be undone.

w Generating Scoring Code from the Formula Depot
Platform

Scoring code generation is intended to facilitate using models built in JMP in a production
environment or other framework of your choice. Many platforms publish prediction formulas
to the Formula Depot, however; not all prediction formulas generate complete code. Code can
be complete, it can be a code fragment, or the code can include unsupported functions that
require additional programming for implementation. Error messages often indicate an
unsupported function call that requires additional programming in the targeted language.
Target language specific libraries might be required for the implementation of more complex
functions. These libraries are discussed in the language specific sections below. For example,
you can perform the following tasks:

* Deploy your model to SAS Model Manager using the generated SAS code.

* Augment your ETL process with in-database scoring using the generated SQL code.
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¢ Create a node for a data transformation pipeline with an application built with the
generated C code.

e Create a Jupyter notebook to show live scoring results using the generated Python code.

* Enable customers to score their own data with a web application that includes the
generated JavaScript.

For the C, Python, and JavaScript languages, you must include supporting code such as .h files
and utility libraries when deploying or compiling the generated code. These files are available
in your JMP installation folder inside the Scoring folder.

Tip: To find the location of installation folder on your machine, use the JSL command Get
Path Variable("$ALL_HOME/Scoring");.

C Code The Cscoring code that is generated must be compiled into a library and then linked
into an application. You might use either a static or a dynamic link approach. The files
jmp_lib.h, jmp_parms.h, and jmp_score.h needed for compiling and linking can be found in
the Scoring/C folder in your JMP installation folder.

Python Code The file jmp_score.py that is needed to run your Python scoring application
can be found in the Scoring/Python folder in your JMP installation folder. When deploying
your models, copy jmp_score.py to the same location as your executable scoring code.

When calling the generated code to score your data, it is important that the input data is
passed in a data structure compatible with the code generated by JMP. The Python scoring
code expects the input and output arguments to be of a dictionary-like type. Values can be
accessed and written by key, such as DataFrame row objects from the Spark, Dask and
Pandas frameworks, or the standard Python “dict” class.

Use of linear algebra operators or advanced operators such as Vec Quadratic and Design
Norm require the NumPy Python library.

JavaScript Code The file jmp_score.js that is needed to run your JavaScript scoring
application can be found in Scoring/JavaScript folder.

SAS Code The generated code fragment that once wrapped by PROC DS2 statements can be
used in SAS applications including the SAS In-Database Code Accelerator. The code is
added to a SAS Window and includes a variable name mapping section in the comment
block that precedes the code. Any temporary variable names associated with intermediate
columns are deleted at the end of the DATA Step by the drop command.

Tip: For models with an ifmax call, such as logistic or neural models for a categorical
response, move temporary variable declarations before the method run() statement.

SQL Code The SQL code fragment that once wrapped in a select statement can be used in
SQL queries against most major database servers.
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Note: Code that contains “placeholder” or “ERROR” indicates an unsupported function call.
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Fit Curve

Fit Built-In Nonlinear Models to Your Data

In many situations, especially in the physical and biological sciences, well-known nonlinear
equations describe the relationship between variables. For example, pharmacological bioassay
experiments can demonstrate how the strength of the response to a drug changes as a function
of drug concentration. Sigmoid curves often accurately model response strength as a function
of drug concentration. Another example is exponential growth curves, which can model the
size of a population over time.

The Fit Curve platform does not require you to specify starting values for parameter estimates
or create model formulas. To specify your own starting values and create model formulas, use
the more powerful custom Nonlinear platform, which can also fit any nonlinear model. See
“Nonlinear Regression”.

Figure 14.1 Example of Nonlinear Fit in the Fit Curve Platform
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Overview of the Fit Curve Platform

Some models are [inear in the parameters (for example, a quadratic or other polynomial);
others can be transformed to be such (for example, when you use a log transformation of x).
The Fit Model or Fit Y by X platforms are more appropriate in these situations. An example in
Fitting Linear Models shows a significant linear relationship between oxygen uptake and time
spent running. For more information about Fit Model, see Fitting Linear Models. For more
information about Fit Y by X, see Basic Analysis.

The Fit Curve platform enables you to fit models that are nonlinear in the parameters. The
initial example in this chapter shows the analysis of a nonlinear relationship: drug toxicity as a
function of concentration. The effect of concentration on toxicity changes from low to high
doses, so this relationship is nonlinear.

The following are examples of equations for linear and nonlinear functions.

Linear function: Y = Byt ﬁlex

Nonlinear function: y = Bo+ Bleﬁzx

The Fit Curve platform provides predefined models, such as polynomial, logistic, probit,
Gompertz, exponential, peak, and pharmacokinetic models. Specifying a grouping variable
lets you estimate separate model parameters for each level of the grouping variable. The fitted
models and estimated parameters can be compared across the levels of the grouping variable.

Fit Curve also enables you to build a model to create the prediction formula. Then you set
upper and lower parameter limits in Nonlinear. See “Example of Setting Parameter Limits”. In
JMP Pro, you can also specify a set of supplementary variables and fit a generalized regression
model within the Fit Curve platform to determine how these variables affect the response.
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Example Using the Fit Curve Platform

This example shows how to build a model for toxicity as a function of the concentration of a
drug. You have a standard formulation of the drug and want to compare it to three new
formulations.

You are interested in a toxicity ratio of non-surviving to surviving cells at a specific
concentration of each drug. From prior research, you know the toxicity ratios for 16 different
concentrations of each drug formulation. A higher ratio indicates more toxicity, which could
be detrimental to development of the drug. Log concentration was calculated to decrease the
range of concentration values and make it easier to detect differences in the curves.

Follow these steps to build the model:

Select Help > Sample Data Library and open Nonlinear Examples/Bioassay.jmp.
Select Analyze > Specialized Modeling > Fit Curve.

Assign Toxicity to the Y, Response role.

Assign log Conc to the X, Regressor role.

Assign Formulation to the Group role.

Click OK.

The Fit Curve Report appears. The Plot report contains an overlaid plot of the fitted model
of each formulation.

AL

Figure 14.2 Initial Fit Curve Report
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7. To see a legend identifying each drug formulation, right-click one of the graphs and select
Row Legend. Select Formulation for the column and click OK.

Figure 14.3 Fit Curve Report with Plot Legend
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The curves appear S-shaped, so a sigmoid curve would be an appropriate fit. Table 14.1
shows formulas and graphical depictions of the different types of models that the Fit
Curve platform offers.

8. Click the Fit Curve red triangle and select Sigmoid Curves > Logistic Curves > Fit Logistic
4pP.
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Figure 14.4 Logistic 4P Report
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The Logistic 4P report appears. There is also a separate plot for each drug formulation. The
plot of the fitted curves suggests that formulation B might be different, because the test B
curve starts to rise sooner than the others. Inflection point parameters cause this rise.

9. Click the Logistic 4P red triangle and select Compare Parameter Estimates.

Figure 14.5 Parameter Comparison Report
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Notice that the Inflection Point parameter for the test B formulation is significantly lower than
the average inflection point. This agrees with the plots shown in Figure 14.4. Drug
formulation B has a higher toxicity ratio than the other formulations.
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Launch the Fit Curve Platform

To launch the Fit Curve platform, select Analyze > Specialized Modeling > Fit Curve. The
launch window is shown in Figure 14.6.

Figure 14.6 Fit Curve Platform Launch Window

Fits a variety of built-in nonlinear models.
Select Columns Cast Selected Columns into Roles Action
;“ Columns required numeric
Cencentraticn

required numeric
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opti
opt

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Fit Curve platform launch window has the following features:
Y, Response Specify the Y variable.
X, Regressor Specify the X variable.

Group Specify a grouping variable. The fitted model has separate parameters for each level
of the grouping variable. This enables you to compare fitted models and estimated
parameters across the levels of the grouping variable.

Z, Supplementary Specify one or more supplementary variables. Supplementary variables
are not used in any of the calculations in the Fit Curve platform and including them does
not affect the results. Supplementary variables are variables you might want to use in
future analyses of the results from Fit Curve. When you specify supplementary variables,
they are included in the table that is created by the Make Parameter Table option. In JMP
Pro, if you specify one or more supplementary variables and a grouping variable, a Curve
DOE Analysis option is made available for the fitted models. See “Curve DOE Analysis”.

Weight Specify a variable that contains the weights of the observations.
Freq Specify a variable that contains the frequencies of the observations.

By Specify a variable to perform a separate analysis for every level of the variable.
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The Fit Curve Report

The Fit Curve report initially contains only a plot of Y versus X. If you specify a Group
variable, the report includes overlaid and individual plots for each group of the fitted model.

Figure 14.7 Fit Curve Reports: No Grouping Variable (left) and with Group Variable (right)
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After fitting a model, the fitted model appears on the plot (when no grouping variable is
specified on the platform launch window). A Model Comparison report appears above the
plots and a Model Report appears below the plot. Each time a new model is fit, it appears in
the Model Comparison report and a new model report appears in the report window. See
“Model Comparison Report” and “Model Fit Report”.

Note: Any rows that are excluded in the data table are also hidden in the Fit Curve plot.

Fit Curve Options

Select any of the following built-in models from the Fit Curve red triangle menu. See “Model
Formulas”.

Polynomials Fits first degree to fifth degree polynomials.

Sigmoid Curves Fits Logistic, Probit, Gompertz, and Weibull models. These models are
S-shaped and have both upper and lower asymptotes. The Logistic 2P, 3P, and 4P and
Probit 2P and 4P models are symmetric. The Logistic 5P and both Gompertz models are
not symmetric. The Logistic 2P is available only when the response is between 0 and 1. The
Weibull Growth is available only when both the response values and regressor values are
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non-negative. Examples of Sigmoid curves include learning curves and modeling tumor
growth, both of which increase initially and then taper off.

Exponential Growth and Decay Fits Exponential, Biexponential, Mechanistic Growth, and
Cell Growth models. The Exponential 2P and 3P are similar, but the 3P model has an
asymptote. The Biexponential models assume there are two separate growth or decay
processes. The Mechanistic Growth and Exponential 3P models always increase (or
decrease), but the rate of growth (or decay) slows so that the model has an asymptote.
Examples of exponential growth and decay functions are virus spread and drug half-life,
respectively.

Peak Models Fits Gaussian Peak and Lorentzian Peak models. These models increase up to a
peak and then decrease. The Gaussian Peak model is a scaled version of the Gaussian
probability density function (PDF). The Lorentzian Peak model is a scaled version of the
Cauchy distribution, a continuous probability distribution. These models can be used for
some chemical concentration assays and artificial neural networks.

Pharmacokinetic Models Fits the One Compartment Oral Dose model, the Two
Compartment IV Bolus Dose model, and the Biexponential 4P model. This option is used
to model the concentration of drugs in the body.

Fit Michaelis-Menten Fits the Michaelis-Menten biochemical kinetics model, which relates
the rate of enzymatic reactions to substrate concentration.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Model Comparison Report

To create the report shown in Figure 14.8, select Sigmoid Curves > Logistic Curves > Fit
Logistic 4P and Sigmoid Curves > Fit Gompertz 4P from the Fit Curve red triangle menu.
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Figure 14.8 Model Comparison Report
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The Model Comparison report shows fit statistics used for comparing multiple models. The
statistics are AICc, AICc Weight, BIC, SSE, MSE, RMSE, and R-Square, and are defined below.

AICc Gives a measure of the goodness of fit of an estimated statistical model that can be used
to compare two or more models. AICc is a modification of the AIC adjusted for small
samples. AICc can be computed only when the number of data points is at least two
greater than the number of parameters. The model with the lowest AICc value is the best,
which is the Logistic 4P in our example. See Fitting Linear Models.

AICc Weight Gives normalized AICc values that sum to one. The AICc weight can be
interpreted as the probability that a particular model is the true model given that one of
the fitted models is the truth. Therefore, the model with the AICc weight closest to one is
the best fit. In our example, the Logistic 4P model is clearly the better fit. The AICc weights
are calculated using only nonmissing AICc values:

AICcWeight = exp[-0.5(AICc-min(AICc))] / sum(exp[-0.5(AICc-min(AICc))])

where min(AICc) is the smallest AICc value among the fitted models. The AICc Weight
column is then sorted in decreasing order.

BIC Gives a measure based on the likelihood function of model fit that is helpful when
comparing different models. The model with the lower BIC value is the better fit. See
Fitting Linear Models.

SSE The sum of the squared differences between each observation and its predicted value.
MSE Gives the average of the squares of the errors of each value.
RMSE The square root of the MSE that estimates the standard deviation of the random error.

R-Square Estimates the proportion of variation in the response that can be attributed to the
model rather than to random error. The model with the R-Square value closest to one is the
better fit.

The Model Comparison platform provides additional options, such as plotting residual and
actual values. See “Model Comparison”.
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Model Fit Report

A report is created for each fitted model. The red triangle menu for each model report
contains the following options.

Prediction Model Gives the algebraic form of the prediction formula and the parameters.
Summary of Fit Gives the same fit statistics as the Model Comparison report.

Parameter Estimates Gives the estimates of the parameters, standard errors, Chi-squared
statistics, p-values, and confidence intervals. The correlations and covariances of the
estimates are given also.

Tip: You can sort the Parameter Estimates report table by clicking on the column that you
want to sort by.

Plot Gives plots of the data with the fitted model (Figure 14.7). The plots are shown only
when you select a Grouping variable on the platform launch window.

Model Fit Options

Each model report contains a red triangle menu with some or all of the following options:

Test Parallelism Helps determine whether the curves are similar in shape when they are
shifted along the X axis. In certain situations, it is important to establish parallelism before
making further comparisons between groups. This option is available only when a Group
variable is specified on the platform launch window. This option is available for the
Sigmoid models (Logistic and Gompertz), as well as the Linear Regression model, with the
exception of higher-order polynomials. See “Test Parallelism”.

Area Under Curve Gives the area under the fitted curve. This option is available for the
following models: One Compartment, Two Compartment, Gaussian Peak, and Lorentzian
Peak. This option is also available for Bi-Exponential 4P Models, but only when all
parameters are positive. The range of integration depends on the type of model and is
specified in the report.

If a Grouping variable is specified on the platform launch window, an Analysis of Means is
performed for comparing the estimates across groups. If the result for a group exceeds a
decision limit, the result is considered different from the overall mean of AUC.

Time to Peak Response Displays the estimate of the regressor, X, at the peak of the fitted
curve. The standard error of the estimate is also shown. This option is available for Cell
Growth 4P and One Compartment models.
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Peak Response Displays the estimate of the response, Y, at the peak of the fitted curve. The
standard error of the estimate is also shown. This option is available for Cell Growth 4P
and One Compartment models.

Compare Parameter Estimates Gives an analysis for testing the equality of parameters
across levels of the grouping variable. This option is available only when a Group variable
is specified on the platform launch window. See “Compare Parameter Estimates”.

Equivalence Test Gives an analysis for testing the equivalence of models across levels of the
grouping variable. This option is available only when a Group variable is specified on the
platform launch window. See “Equivalence Test”.

‘lj,w['{o Curve DOE Analysis (Available only if a grouping variable and at least one

supplementary variable are specified in the launch window.) Launches a Generalized
Regression report within the Fit Curve platform. A generalized regression model is fit to
each parameter of the nonlinear model using the supplementary variables as model
effects. By default, a two degree factorial model is fit and the Estimation Method is
Forward Selection. These models are then combined to create a profiler of the response as
a function of the regressor variable and the supplementary variables. You can then use the
CDOE Profiler to explore how the supplementary variables affect the response.

The Curve DOE Analysis report contains the following red triangle menu options:

Generalized Regression for Model Parameters Shows or hides the Generalized
Regression reports for each model parameter. For more information on Generalized
Regression model reports, see Fitting Linear Models.

Diagnostic Plots Shows or hides actual by predicted and residual plots for the response
variable.

CDOE Profiler Shows or hides the CDOE Profiler, which enables you to explore how the
response changes based on the supplementary variables. For more information about
the CDOE Profiler red triangle menu options, see Profilers.

Save Prediction Formula Saves the prediction formula for the response to a new column
in the data table.

Make Parameter Table Saves the parameter estimates, standard errors, and t-ratios in a data
table. This option is available only when a Group variable is specified on the platform
launch window.

Plot Actual by Predicted Plots actual Y values on the vertical axis and predicted Y values on
the horizontal axis.

Plot Residual by Predicted Plots the residuals on the vertical axis and the predicted Y values
on the horizontal axis.
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Profiler Shows or hides a profiler of the fitted prediction function. The derivatives are
derivatives of the prediction function with respect to the X variable. For more information
about profilers, see Profilers.

Save Formulas Contains options for saving a variety of formula columns in the data table.
Save Prediction Formula Saves the prediction equation.
Save Std Error of Predicted Saves the standard error of the predicted values.

Save Parametric Prediction Formula Saves the prediction equation in parametric form.
This is helpful if you want to use the fitted model in the custom Nonlinear platform.

Save Residual Formula Saves the residuals.

Save Studentized Residual Formula Saves the studentized residual formula, a standard
residual that is divided by its estimated standard deviation.

Save First Derivative Saves the derivative of the prediction function with respect to the X
variable.

Save Std Error of First Derivative Saves the equation of the standard error of the first
derivative.

Save Inverse Prediction Formula Saves the equation for predicting X from Y.

Custom Inverse Prediction Predicts an X value for a specific Y value. For more information
about inverse prediction, see Fitting Linear Models.

Remove Fit Removes the model report, the entry from the Model Comparison report, and
the fitted line from the plot.

Test Parallelism

The Test Parallelism option provides an analysis for testing if the fitted models between
groups have the same shape, but are shifted along the X axis (Figure 14.9). In the Bioassay
example, the curve for drug formulation B is shifted to the left of the other three curves.
However, you do not know whether the curves still have the same shape (are parallel), or if
formulation B is different. The Parallelism Test tells us if the shapes for the different drug
formulations have similar shapes and are shifted along the horizontal axis. Select Test
Parallelism from the fitted model’s red triangle menu to add the report.
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Figure 14.9 Parallelism Test
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The report gives the following results:

Test Results Gives the results of an F Test and a Chi-Square Test for parallelism. The tests

compare the error sums-of-squares for a full model (Full SSE) and a reduced model (Fit
SSE). The full model gives each group different parameters. The reduced model forces the
groups to share every parameter except for the inflection point. A small p-value indicates
that the group models are significantly different from one another. Therefore, the reduced
model with shared parameters is insufficient and the full model should be used. In
Figure 14.9, the p-value is greater than 0.05, indicating that there is not enough evidence to
conclude that differences exist between the curves. In this case, the reduced model with
shared parameters is appropriate.

The fit statistics are calculated as follows:
F Ratio [(Fit SSE - Full SSE) / NDF] / [Full SSE / DDF]
ChiSquare Fit SSE - Full SSE
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Parallel Fit Parameter Estimates Gives the parameter estimates under the reduced model

(same parameters, except for inflection point). A plot of the fitted curves under the
reduced model is provided. The inflection point for drug formulation B is much lower
than that of the other three drug formulations.

Relative Potencies Gives the potency and relative potency for each level of the grouping

variable. The potency is 10"(EC5p), where ECsj is the concentration at which the response
half way between baseline and maximum is obtained. For the Logistic 2P, 3P, and 4P, the
potency is 10"(inflection point parameter). The relative potency is the potency of one level
of the grouping variable divided by the potency of another level. For example, in

Figure 14.10, the relative potency of test A to standard is Potency . o/Potencygiandard-

Figure 14.10 Relative Potencies by Group

4 Relative Potencies

4 Relative Potency versus standard

Relative
Group Potency  Potency Std Error
standard 2.0461329 1 0

test A 1.9445466 1.0522416 0.0246535
test B 1.2328161 1.6597227 0.0388878

test C 1977115 1.0349084 0.0242474
4 Relative Potency versus test A
Relative
Group Potency  Potency Std Error
standard 20461320  0.950352 0.0222663
test A 1.9445466 1 0
test B 12328161 15773209 0.036957
test C 1977115 0.9835273 0.0230435
4 Relative Potency versus test B
Relative
Group Potency  Potency Std Error

standard 2.0461329 0.6025103 0.014117
test A 1.9445466 0.6339864 0.0148545

test B 1.2328161 1 0
test C 1977115 0.6235429 0.0146008
4 Relative Potency versus test C
Relative
Group Potency  Potency Std Error

standard 2.0461329 0.9662691 0.0226392
test A 1.9445466 1.0167486 0.0238219
test B 1.2328161 1.6037388 0.037576
test C 1.877115 1 0

In the Relative Potency versus standard panel from Figure 14.10, note that the relative
potencies for drug formulations A and C are nearly one. This indicates that their potencies
are similar to that of the standard formulation. The potency for drug formulation B is
lower than that of the standard. This means that drug formulation B increases in toxicity as
a function of concentration faster than the standard.

In the parallelism test, the curves are parallel, which enables you to calculate relative
potencies. Based on the relative potencies, you conclude that formulation B is more potent
than the other drug formulations. Taken with the prior findings, drug formulation B appears
to be more toxic.
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Compare Parameter Estimates

The Compare Parameter Estimates report gives results for testing the equality of parameters
across the levels of the grouping variable. There is an Analysis of Means (ANOM) report for
each parameter, which tests whether the parameters are equal to an overall mean. If the result
for a parameter exceeds the decision limits, then the parameter is different from the overall
mean. Figure 14.11 shows the ANOM report for growth rate estimates. Select Compare
Parameter Estimates from the fitted model’s red triangle menu to add the report.

Figure 14.11 Parameter Comparison for Growth Rate Estimates
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The Analysis of Means red triangle menu contains the following options:

Set Alpha Level Sets the alpha level for the test.

Show Summary Report Shows or hides a report containing the parameter estimates, the
decision limits, and whether the parameter exceeded the limits.

Display Options Contains options for showing or hiding decision limits, shading, and the
center line. Also contains options for changing the appearance of the points.

For more information about the Analysis of Means report, see Basic Analysis.

Equivalence Test

The Equivalence Test report gives an analysis for testing the equivalence of models across
levels of the grouping variable (Figure 14.12). After selecting the option, you specify the level
of the grouping variable that you want to test against every other level. There is a report for
every level versus the chosen level. Select Equivalence Test from the fitted model’s red

triangle menu to add the report.
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The equality of the parameters is tested by analyzing the ratio of the parameters. The default
decision lines are placed at ratio values of 0.8 and 1.25, representing a 25% difference.

If all of the confidence intervals are inside the decision lines, then the two groups are
practically equal. If a single interval falls outside the lines (Figure 14.12), then you cannot
conclude that the groups are equal. The inflection point for drug formulation B is lower than
the standard, which agrees with the previous findings.

Figure 14.12 Equivalence Test
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The Equivalence red triangle menu contains the following options:
Set Alpha Level Sets the alpha level for the test. The default value is 0.05.

Set Decision Lines Changes the decision limits for the ratio. The default values are set at 0.8
and 1.25, representing a 25% difference.

Show Summary Report Shows or hides a report containing the parameter estimates, the
decision limits, and whether the parameter exceeded the limits.

Display Options Contains options for showing or hiding decision limits, shading, and the
center line. Also contains options for changing the appearance of the points. For additional
formatting options, right-click the graph and select Customize.
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Statistical Details for the Fit Curve Platform

Model Formulas

Table 14.1 provides the formulas for the models on the Fit Curve red triangle menu.

Table 14.1 Fit Curve Model Formulas
Model Formula

Polynomials

k
/ Bo+ 2 B
i=1

where k is the order of the polynomial. These models
can also be fit using the Fit Model and Fit Y by X
platforms.

Logistic 2P 1
1+ Exp(—a(x-b))

a = Growth Rate
b = Inflection Point

Available only when all response values are between
zero and one.

Logistic 3P c
1+ Exp(—a(x—-b))

a = Growth Rate
b = Inflection Point

¢ = Asymptote
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Table 14.1 Fit Curve Model Formulas (Continued)

Model

Logistic 4P

N

Logistic 4P Rodbard

i

Logistic 4P Hill

N

Logistic 5P

i

Formula

c+ d-c
1+ Exp(-a(x b))

a = Growth Rate

b = Inflection Point

¢ = Lower Asymptote

d = Upper Asymptote
c+ d-c

1+x/b)"

a = Growth Rate

b = Inflection Point

¢ =Lower Asymptote

d = Upper Asymptote

Available only when the regressor values are positive.

d-c

AN EE)

a = Growth Rate
b = Inflection Point
¢ = Lower Asymptote
d = Upper Asymptote
d—c
(1+Exp(-a(x —b)))f
a = Growth Rate

c+

b = Inflection Point
¢ =Asymptote 1
d = Asymptote 2

f=Power
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Table 14.1 Fit Curve Model Formulas (Continued)

Model Formula

Probit 2P © (J%b)

a = Growth Rate
b = Inflection Point
® = Normal Distribution CDF

Available only when all response values are between
zero and one.

c+(d—c)-q>(x‘b)

a

Probit 4P

a = Growth Rate

f b = Inflection Point

¢ =Asymptote 1

d = Asymptote 2

® = Normal Distribution CDF
Gompertz 3P aExp(—Exp(-b(x —¢)))

a=Asymptote

b = Growth Rate
¢ = Inflection Point

Gompertz 4P a+ (b—a)Exp(-Exp(—c(x —d)))

a = Lower Asymptote

b =Upper Asymptote
¢ = Growth Rate
d = Inflection Point
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Table 14.1 Fit Curve Model Formulas (Continued)

Model

Weibull Growth

D)

Exponential 2P

-

Exponential 3P

i\

Biexponential 4P

Formula

a(l- Exp(—(x/c)b))
a=Upper Asymptote
b = Growth Rate
¢ = Inflection Point

Available only when both the response values and
regressor values are non-negative.

aExp(bx)
a = Scale

b = Growth Rate

a+ bExp(cx)
a = Asymptote
b =Scale

¢ = Growth Rate

aExp(-bx) + cExp(—dx)
a=Scale 1
b =Decay Rate 1
¢ = Scale 2
d = Decay Rate 2

Available only when the response values are positive.
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Table 14.1 Fit Curve Model Formulas (Continued)

Model

Biexponential 5P

\
/Q

Mechanistic Growth

-

Cell Growth 4P

/>

Gaussian Peak

Formula
a+ bExp(—cx) + dExp(—fx)

a=Asymptote

b=Scale 1

¢ =Decay Rate 1

d =Scale 2

f=Decay Rate 2
a(1—bExp(—cx))

a = Asymptote

b =Scale

¢ = Growth Rate

ab
(a—b)Exp(—cx) + bExp(dx)

a = Peak value if mortality rate, d, is zero
b =Response at time zero

¢ = Cell Division Rate

d = Cell Mortality Rate

Available only when the response values are positive
and the regressor values are non-negative.

(57
a = Peak Value

b = Critical Point

¢ = Growth Rate
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Table 14.1 Fit Curve Model Formulas (Continued)

Model

Lorentzian Peak

One Compartment Oral Dose

process in

pill —p kidneys

b
——pp elimination

Two Compartment IV Bolus

Dose

shot —p

blood

b
o
c

¢d

tissue

Formula
ab?
(x— c)2 + b2
a =Peak Value
b = Growth Rate

¢ = Critical Point

CLI_LCb(Exp(—bx) — Exp(—cx))

a = Area Under Curve
b = Elimination Rate
¢ = Absorption Rate

Available only when the response values and the
regressor values are all positive.

(4~ DExp(-0x) = (B~ D)Exp(-Bx))

o= %(b+c+d+J(b+c+d)274bd)

p= %(b+c+de(b+c+d)274bd)

a = Initial Concentration
b = Transfer Rate In

¢ = Transfer Rate Out

d = Elimination Rate

Available only when the response values and the
regressor values are all positive.
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Table 14.1 Fit Curve Model Formulas (Continued)

Model Formula
Michaelis-Menten ax
b+x

a = Max Reaction Rate
b = Inverse Affinity

Available only when the response values and the
regressor values are all positive.
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Nonlinear Regression
Fit Custom Nonlinear Models to Your Data

The Nonlinear platform is a good choice for models that are nonlinear in the parameters. This
chapter focuses on custom nonlinear models, which include a model formula and parameters
to be estimated. Use the default least squares loss function or a custom loss function to fit
models. The platform minimizes the sum of the loss function across the observations.

Figure 15.1 Example of a Custom Nonlinear Fit

< Solution
SSE  DFE MSE RMSE
2245.5741473 20 112.27871 10.596165
Parameter Estimate ApproxStdErr
BO 15.052907621 1453256085
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Solved By: Analytic Gauss-Mewton
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The Nonlinear platform also provides predefined models, such as polynomial, logistic,
Gompertz, exponential, peak, and pharmacokinetic models. See “Fit Curve”.

Note: Some models are linear in the parameters (for example, a quadratic or other polynomial)
or can be transformed to be such (for example, when you use a log transformation of x). The
Fit Model or Fit Y by X platforms are more appropriate in these situations. For more
information about these platforms, see Fitting Linear Models and Basic Analysis.
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Example of Fitting a Custom Model

This example fits a custom model by creating a formula column for the model and then fitting
the model using the Nonlinear platform. This method requires a few more steps than fitting a
built-in model, but it allows any nonlinear model to be fit. You can also provide a custom loss
function, and specify several other options for the fitting process.

Tip: If the custom model is one that you use often for several data tables, you can add the
model to the Model Library instead. See “Customize the Nonlinear Model Library”.

The data are in the US Population.jmp data table. The response variable is the population (in
millions) of the Unites States and the predictor is the year.

Create a Formula Column
To fit a custom model, you must first create a model column with initial parameter estimates.
1. Select Help > Sample Data Library and open Nonlinear Examples/US Population.jmp.
2. Create a new column called Model.
3. Right-click the Model column and select Column Properties > Formula.
The Formula Editor appears.

4. Select Parameters from the list below the list of columns.

Figure 15.2 Select Parameters

"“CD'“F”"S T [ =] ] =[allo]s]8]X
year

A pop

A X-formula

no formula

Table Variables v

Constants
Table Variables
Local Variables

Parameters p, I Preview

OK || Cancel || Apply || Help

5. Select New Parameter.

6. Type BO for Name.
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7. Type 3.9 for Value. This is the initial estimate of the parameter.

Click OK.
9. Select New Parameter.
10. Type B1 for Name and enter 0.022 for Value.
11. Click OK.

12. Enter the model formula using the Formula Editor functions, the column year, and the
parameters.

Figure 15.3 Completed Model Formula

BD-Exp(Bl-(year—l?B[}))

Tip: Click the gray triangle next to Transcendental to find the Exp command.

13. Click OK.

Fit a Nonlinear Model

Select Analyze > Specialized Modeling > Nonlinear.
Assign Model to the X, Predictor Formula role.
Assign pop to the Y, Response role.

Click OK.

Click Go on the Control Panel to fit the model.

S
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Figure 15.4 Plot and Solution Report

4 Solution
SSE  DFE MSE RMSE

22455741473 20 112.27871 10.596165
Parameter Estimate ApproxStdErr
BO 15.052907631 1.45325605
Bl 0.014188513 0.0005273
Solved By: Analytic Gauss-Newten
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The final parameter estimates are shown in the Solution report, along with other fit
statistics. The fitted model is shown on the plot.

Parameters for Models with a Grouping Variable

In the formula editor, when you add a parameter, note the check box for Expand Into
Categories, selecting column. This option is used to add several parameters (one for each
level of a categorical variable for example) at once. When you select this option, a dialog
appears that enables you to select a column. After selection, a new parameter appears in the
Parameters list with the name D_column, where D is the name that you gave the parameter.
When you use this parameter in the formula, a Match expression is inserted, containing a
separate parameter for each level of the grouping variable.
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Launch the Nonlinear Platform

To launch the Nonlinear platform, select Analyze > Specialized Modeling > Nonlinear.

Figure 15.5 Nonlinear Platform Launch Window

Fits nonlinear models using least squares or a custom loss function,

Select Colurmns
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-Log( 1/ (1 + Exp( -Madel ¥ )} ),

-log{1-1/(1+Exp( -:Model ¥)) )
)

[ Mumeric Derivatives Only
O Expand Intermediate Formulas

Action
Q

Cancel

Remove

Recall

Help

For more information about the options in the Select Columns red triangle menu, see Using

JMP.

The Nonlinear platform launch window has the following features:

Y, Response Select the Y variable.

X, Predictor Formula Select either the X variable or a column containing the model formula

with parameters.

Note: If you select a column that does not contain a model formula with parameters and
you also do not specify a custom formula, the Fit Curve platform is launched instead.

Note: If you select a formula column that contains a parameter list item that does not have
an assignment, JMP automatically sets that parameter to zero and displays a message in

the log.

Group Specify a grouping variable. The fitted model has separate parameters for each level
of the grouping variable. This enables you to compare fitted models and estimated

parameters across the levels of the grouping variable.
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Note: If the formula does not have separate parameters for each group level, the Group
variable is ignored by JMP.

Weight Specify a variable containing the weights of observations.

Freq Specify a variable representing the frequency of an observation.

Loss Specify a formula column giving a loss function.

By Specify a variable to perform a separate analysis for every level of the variable.

Model Library Launches the Model Library tool, which helps you choose initial values to
create a formula column. See “Create a Formula Using the Model Library”.

Options for fitting custom formulas If you specify a column in the X, Predictor Formula role
that does not contain a model formula with parameters, you can use this option to create a
custom formula. In the Predictor field, specify parameters, parameter values, and a custom
formula that uses the selected X variable. Then, click the Reset button and launch the
platform.

Numeric Derivatives Only Uses numeric derivatives only. This option is useful when you
have a model for which it is too messy to take analytic derivatives. It can also be valuable
in obtaining convergence in tough cases. This option is used only when a formula column
is provided in the X, Predictor Formula role.

Expand Intermediate Formulas Tells JMP that if an ingredient column to the model is a
column that itself has a formula, to substitute the inner formula, as long as it refers to other
columns. To prevent an ingredient column from expanding, use the Other column
property with a name of “Expand Formula” and a value of 0. This option is used only
when a formula column is provided in the X, Predictor Formula role.

The Nonlinear Fit Report

The initial Nonlinear Fit report includes the following items, shown in Figure 15.6.
Control Panel Provides options for controlling the fitting process.

Go Starts the fitting process.

Stop Stops the fitting process.

Step Proceeds through the fitting process one iteration at a time.

Reset Resets the editable values into the formula, resets the iteration values, and
calculates the SSE at these new values.
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Criterion Shows iteration measures from the fitting process.
Current Shows the current value of each Criterion.
Stop Limit Sets limits on the measures listed under Criterion.

Plot Shows a plot of the X and Y variables for models with only one X variable. The model
based on the current values is shown on the plot. To change the current values of the
parameters, use the sliders or edit boxes beneath the plot.

Figure 15.6 Initial Nonlinear Fit Report

4 [=|Nonlinear Fit
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4 Control Panel

Click Go to start.

E| Criterion Current  Stop Limit
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After you click Go to fit a model, the report includes the following additional items, shown in
Figure 15.7.

Save Estimates Saves the current parameter values to the parameters in the formula
column.
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Confidence Limits Computes confidence intervals for all parameters. The intervals are

profile likelihood confidence intervals, and are shown in the Solution report. The
confidence limit computations involve a new set of iterations for each limit of each
parameter, and the iterations often do not find the limits successfully. The Edit Alpha and
Convergence Criterion options are for the confidence interval computations. For more
information about the Goal SSE for CL, see “Profile Likelihood Confidence Limits”.

Solution Shows the parameters estimates and other statistics.

SSE Shows the residual sum of squared errors. SSE is the objective that is to be
minimized. If a custom loss function is specified, this is the sum of the loss function.

DFE Shows the degrees of freedom for error, which is the number of observations used
minus the number of parameters fitted.

MSE Shows the mean squared error. It is the estimate of the variance of the residual
error, which is the SSE divided by the DFE.

RMSE Estimates the standard deviation of the residual error, which is square root of the
MSE.

RSquare (Available only if the model has an intercept and the sum of the residuals is
close to zero.) Shows the RSquare value.

Parameter Lists the names that you gave the parameters in the fitting formula.

Estimate Lists the parameter estimates produced. Keep in mind that with nonlinear
regression, there might be problems with this estimate even if everything seems to
work.

ApproxStdErr Lists the approximate standard error, which is computed analogously to
linear regression. It is formed by the product of the RMSE and the square root of the
diagonals of the derivative cross-products matrix inverse.

Note: If the number of observations is less than or equal to the number of parameters
in the fitted model, ApproxStdErr is not reported.

Lower CL and Upper CL  Shows the confidence limits for the parameters. They are
missing until you click the Confidence Limits on the Control Panel. For more
information about the confidence intervals, see “Profile Likelihood Confidence Limits”.

Excluded Data Shows a report showing fit statistics for excluded rows. This is useful for
validating the model on observations not used to fit the model. You can use this feature
in conjunction with the Remember Solution option to change the exclusions, and get a
new report reflecting the different exclusions

Correlation of Estimates Displays the correlations between the parameter estimates.



254 Nonlinear Regression Chapter 15
The Nonlinear Fit Report Predictive and Specialized Modeling

Covariance of Estimates Displays the covariances between the parameter estimates.

Figure 15.7 Fitted Model Report
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Nonlinear Platform Options

The Nonlinear Fit red triangle menu contains the following options:

Parameter Bounds Sets bounds on the parameters. When the option is selected, editable
boxes appear in the Control Panel. Unbounded parameters are signified by leaving the
field blank.

Plot Shows or hides a plot of the X and Y variables for models with only one X variable. The
model shown on the plot is based on the current values of the parameters. To change the
current values of the parameters, use the sliders or edit boxes beneath the plot. If you
specify a Group variable at launch, then a curve shows for each group.

Iteration Options Specifies options for the fitting algorithm.
Iteration Log Records each step of the fitting process in a new window.

Numeric Derivatives Only Useful when you have a model that is too messy to take
analytic derivatives for. It can also be valuable in obtaining convergence in tough cases.

Expand Intermediate Formulas Tells JMP that if an ingredient column to the formula is a
column that itself has a formula, to substitute the inner formula, as long as it refers to
other columns. To prevent an ingredient column from expanding, use the Other
column property with a name of “Expand Formula” and a value of 0.

Newton Specifies whether Gauss-Newton (for regular least squares) or Newton-Raphson
(for models with loss functions) is the optimization method.

QuasiNewton SR1 Specifies QuasiNewton SR1 as the optimization method.
QuasiNewton BFGS Specifies QuasiNewton BFGS as the optimization method.

Accept Current Estimates Tells JMP to produce the solution report with the current
estimates, even if the estimates did not converge.

Show Derivatives Shows the derivatives of the nonlinear formula in the JMP log. See
“Notes Concerning Derivatives”, for technical information about derivatives.

Unthreaded Runs the iterations in the main computational thread. In most cases, JMP
does the computations in a separate computational thread. This improves the
responsiveness of JMP while doing other things during the nonlinear calculations.
However, there are some isolated cases (models that have side effects that call display
routines, for example) that should be run in the main thread, so this option should be
turned on.

Profilers Provides various profilers for viewing response surfaces.
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Profiler Shows the Prediction Profiler. The Profiler lets you view vertical slices of the
surface across each x-variable in turn, as well as find optimal values of the factors.

Contour Profiler Shows the Contour Profiler. The Contour profiler lets you see
two-dimensional contours as well as three dimensional mesh plots.

Surface Profiler Creates a three-dimensional surface plot. This option is available only
for models with two or more X variables.

Parameter Profiler Shows the Prediction Profiler and profiles the SSE or loss as a
function of the parameters.

Parameter Contour Profiler Shows the Contour Profiler and contours the SSE or loss as a
function of the parameters.

Parameter Surface Profiler Creates a three-dimensional surface plot and profiles the SSE
or loss as a function of the parameters. This option is available only for models with
two or more parameters.

SSE Grid Create a grid of values around the solution estimates and compute the error sum of
squares for each value. The solution estimates should have the minimum SSE. When the
option is selected, the Specify Grid for Output report is shown with these features:

Parameter Lists the parameters in the model.

Min Displays the minimum parameter values used in the grid calculations. By default,
Min is the solution estimate minus 2.5 times the ApproxStdErr.

Max Displays the maximum parameter value used in the grid calculations. By default,
Max is the solution estimate plus 2.5 times the ApproxStdErr.

Number of Points Gives the number of points to create for each parameter. To calculate
the total number of points in the new grid table, multiply all the Number of Points
values. Initially Number of Points is 11 for the first two parameters and 3 for the rest. If
you specify new values, use odd values to ensure that the grid table includes the
solution estimates. Setting Number of Points to 0 for any parameter records only the
solution estimate in the grid table.

When you click Go, JMP creates the grid of points in a new table. A highlighted row marks
the solution estimate row if the solution is in the table.

Revert to Original Parameters Resets the platform to the original parameter values (the
values given in the formula column parameters).

Remember Solution Creates a report called Remembered Models, which contains the
current parameter estimates and summary statistics. Results of multiple models can be
remembered and compared. This is useful if you want to compare models based on
different parameter restrictions, or models fit using different options. Click the radio
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button for a particular model to display that model in the Plot and the parameter estimates
in the Control Panel.

Custom Estimate Gives an estimate of a function of the parameters. You provide an
expression involving only parameters. JMP calculates the expression using the current
parameter estimates, and also calculates a standard error of the expression using a
first-order Taylor series approximation.

Custom Inverse Prediction Estimates the X value for a given Y value. It also calculates a
standard error for the estimated X. JMP must be able to invert the model. The standard
error is based on the first-order Taylor series approximation using the inverted expression.
The confidence interval uses a t-quantile with the standard error, and is a Wald interval.

Show Prediction Expression Shows the prediction model or the loss function at the top of
the report.

Save Pred Confid Limits Saves asymptotic confidence limits for the model prediction. This
is the confidence interval for the average Y at a given X value.

Save Indiv Confid Limits Saves asymptotic confidence limits for an individual prediction.
This is the confidence interval for an individual Y value at a given X value.

Save Formulas Gives options for saving model results to data table columns:

Save Prediction Formula Saves the prediction formula with the current parameter
estimates.

Save Std Error of Predicted Saves the standard error for a model prediction. This is the
standard error for predicting the average Y for a given X. The formula is of the form
Sqrt(VecQuadratic(matrixl,vectorl)). matrixl is the covariance matrix
associated with the parameter estimates, and vectorl is a composition of the partial
derivatives of the model with respect to each parameter.

Save Std Error of Individual Saves the standard error for an individual prediction. This is
the standard error for predicting an individual Y value for a given X value. The
formula is of the form Sqrt(VecQuadratic(matrixl,vectorl)+mse). matrixlis the
covariance matrix associated with the parameter estimates, vectorlis a composition
of the partial derivatives of the model with respect to each parameter, and mse is the
estimate of error variance.

Save Residual Formula Saves the formula for computing the residuals.

Save Pred Confid Limit Formula Saves the formula to calculate the confidence interval
for a model prediction. This is a confidence interval for the average Y for a given X.

Save Indiv Confid Limit Formula Saves the formula to calculate the confidence interval
for an individual prediction. This is a confidence interval for an individual Y for a
given X.
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Save Inverse Prediction Formula Saves formulas for the inverse of the model, the
standard error of an inverse prediction, and the standard error of an individual inverse
prediction.

Save Specific Solving Formula Equivalent to Save Inverse Prediction Formula in simple
cases. However, this command allows the formula to be a function of several variables
and allows expressions to be substituted. This feature works only for solving easily
invertible operators and functions that occur just once in the formula.

After selecting this command, a dialog appears that enables you to select the variable to
solve for. You can also edit the names of the columns in the resulting table. You can also
substitute values for the names in the dialog. In these cases, the formula is solved for
those values.

Note: The standard errors, confidence intervals, and hypothesis tests are correct only if
least squares estimation is done, or if maximum likelihood estimation is used with a
proper negative log-likelihood.

Save Estimates to Table Saves the parameter estimates to a new data table.
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Create a Formula Using the Model Library

The Model Library can assist you in creating the formula column with parameters and initial
values. Click the Model Library button on the Nonlinear launch window to open the library.
Select a model in the list to see its formula in the Formula box.

Figure 15.8 Nonlinear Model Library Dialog
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Click Show Graph to show a 2-D theoretical curve for one-parameter models and a 3-D
surface plot for two-parameter models. No graph is available for models with more than two
explanatory (X) variables. On the graph window, change the default initial values of
parameters using the slider, or clicking and entering values in directly.
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Figure 15.9 Example Graph in Model Library
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The Reset button sets the initial values of parameters back to their default values.

Click Show Points to overlay the actual data points to the plot. The dialog in Figure 15.10
opens, asking you to assign columns into X and Y roles, and an optional Group role. The
Group role allows for fitting the model to every level of a categorical variable. If you specify a
Group role here, also specify the Group column on the platform launch window.

Figure 15.10 Select Roles
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[ Remove |
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For most models, the starting values are constants. Showing points enables you to adjust the
parameter values to see how well the model fits for different values of the parameters. For the

US population example, the points are shown in Figure 15.11.
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Figure 15.11 Show Points
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Clicking Make Formula at this point (after using Show Points) creates a new data table
column named after the model that you chose from the Model Library. This column has the
formula as a function of the latest parameter starting values.

Note: If you click Make Formula before using the Show Graph or Show Points buttons, you
are asked to provide the X and Y roles, and an optional Group role (Figure 15.10). After that,
you are brought back to the plot so that you have the opportunity to adjust the parameters
starting values if desired. At that point click Make Formula again to create the new column.

Once the formula is created in the data table, continue the analysis by assigning the new
column as the X, Predictor Formula in the Nonlinear launch dialog.

Customize the Nonlinear Model Library

The Model Library is created by a built-in script named NonlinLib.jsl, located in the
Resources/Builtins folder in the folder that contains JMP (Windows) or in the Application
Package (macOS). You can customize the nonlinear library script by modifying this script.

Note: You might not be able to directly edit the file. If this is the case, open the script, make the
desired edits, and save to a different location on your computer. Use the same filename. Then,
delete the old NonlinLib.jsl script in the Resources/Builtins folder and move the new
NonlinLib.jsl file into the Resources/Builtins folder.
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To add a model, you must add three lines to the list named Listofmodel11ist#. These three
lines are actually a list themselves, which consists of the following three parts.

* Model name, a quoted string
* Model formula, an expression

e Model scale

For example, suppose you want to add a model called “Simple Exponential Growth” that has
the form

y = blekx

Add the following lines to the NonlinLib.jsl script

{//Simple Exponential Growth
"Simple Exponential Growth",
Expr(Parameter({bl=2, k=0.5}, bl*exp(k * :X))),
Jowx = -1; highx = 2; Towy = 0; highy = 2},

Some things to note:

e The first line is simply an open bracket (starting the list) and an optional comment. The
second line is the string that is displayed in the model library window.

e The values of Towx, highx, Togy, and highy specify the initial window for the theoretical
graph.

e There is a comma as the last character in the example above. If this is the final entry in the
Listofmodel1ist# list, the comma can be omitted.

e If the model uses more than two parameters, replace the last line (containing the graph
limits) with the quoted string “String Not Available”.

To delete a model, delete the corresponding three-lined list from the Listofmodel11ist# list.

Additional Examples

e “Example of Maximum Likelihood: Logistic Regression”
e “Example of a Probit Model with Binomial Errors: Numerical Derivatives”
¢ “Example of a Poisson Loss Function”

e “Example of Setting Parameter Limits”
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Example of Maximum Likelihood: Logistic Regression

This example shows how to use the Nonlinear platform to minimize a loss function. The loss
function is the negative of a log-likelihood function, thus producing maximum likelihood

e

stimates.

The Logistic w Loss.jmp data table in the Nonlinear Examples sample data folder has an
example for fitting a logistic regression using a loss function. The Y column contains ones for
events and zeros for non-events. The Model Y column has the linear model, and the Loss
column has the loss function. In this example, the loss function is the negative log-likelihood
for each observation, or the negative log of the probability of getting the observed response.

Run the model by following the steps below:

1
2
3.
4

Select Analyze > Specialized Modeling > Nonlinear.
Assign Model Y to the X, Predictor Formula role.

Assign Loss to the Loss role.

Figure 15.12 Nonlinear Launch Window
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The Nonlinear Fit Control Panel appears.

Select Help > Sample Data Library and open Nonlinear Examples/Logistic w Loss.jmp.

Action
Q

Cancel

Remove

Recall

Help
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Figure 15.13 Nonlinear Fit Control Panel
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6. Click Go.

The parameter estimates are shown in the Solution report.
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Figure 15.14 Solution Report

4 Solution

Sqrt

Loss DFE Avgloss Avgloss
7.8070527905 15 0.4337252 0.6585751
Parameter Estimate ApproxStdErr
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The Loss value in the Solution report is the negative log-likelihood evaluated at the parameter

estimates.

Example of a Probit Model with Binomial Errors: Numerical
Derivatives

The Ingots2.jmp sample data table includes the numbers of ingots tested for readiness after
different treatments of heating and soaking times. The response variable, NReady, is binomial,
depending on the number of ingots tested (Ntotal) and the heating and soaking times.
Maximum likelihood estimates for parameters from a probit model with binomial errors are

obtained using:

e numerical derivatives

* the negative log-likelihood as a loss function

* the Newton-Raphson method.
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The average number of ingots ready is the product of the number tested and the probability
that an ingot is ready for use given the amount of time it was heated and soaked. Using a
probit model, the P column contains the model formula:

Normal Distribution(b0+b1l*Heat+b2*Soak)
The argument to the Normal Distribution function is a linear model of the treatments.
To specify binomial errors, the loss function, Loss, has the formula

-(Nready*Log(p) + (Ntotal - Nready)*Log(l - p))
Follow these steps to fit the model:

1. Select Help > Sample Data Library and open Ingots2.jmp.
2. Select Analyze > Specialized Modeling > Nonlinear.

3. Assign P to the X, Predictor Formula role,

4. Assign Loss to the Loss role.

5. Select the Numeric Derivatives Only option.

6. Click OK.

7. Click Go.

The platform used the Numerical SR1 method to obtain the parameter estimates shown in
Figure 15.15.

Figure 15.15 Solution for the Ingots2 Data

4 Solution

Sqrt
Loss DFE Avgloss Avgloss
47.479945327 Li 20674966 17226423
Parameter Estimate ApproxStdErr
b0 -2.3934153 0.51256572
bl 0.0399554554 0.01202329
b2 0.0362537934 0.15017139

Solved By: Mumerical SRL

Example of a Poisson Loss Function
A Poisson distribution is often used to model count data.

.
P(Y=n) = E——'L"-,n =0,1,2,...
n:
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where p can be a single parameter, or a linear model with many parameters. Many texts and
papers show how the model can be transformed and fit with iteratively reweighted least
squares (Nelder and Wedderburn 1972). However, in JMP it is more straightforward to fit the
model directly. For example, McCullagh and Nelder (1989) show how to analyze the number
of reported damage incidents caused by waves to cargo-carrying vessels.

The data are in the Ship Damage.jmp sample data table. The model formula is in the model
column, and the loss function (or negative log-likelihood) is in the Poisson column. To fit the
model, follow the steps below:

Select Help > Sample Data Library and open Ship Damage.jmp.
Select Analyze > Specialized Modeling > Nonlinear.

Assign model to the X, Predictor Formula role.

Assign Poisson to the Loss role.

Click OK.

Set the Current Value (initial value) for b0 to 1, and the other parameters to 0.

AL N O

Figure 15.16 Enter New Parameters

4 Control Panel

Click Go to start.

Go | Criterion Current  Stop Limit
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Treration

Stop | Ohbj Change 1340732 +154 le-15

Step | Relative Gradient 1.34078e+154 0.000001
1.34075e+154 0.00000L

Cheat | i
Reset
= | Loss is Neg LogLikelihood

Current
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¥r 65 [1]
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7. Click Go.

8. (lick the Confidence Limits button.

The Solution report appears. The results include the parameter estimates and confidence
intervals, and other summary statistics.
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Figure 15.17 Solution Table for the Poisson Loss Example
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Note: The standard errors, confidence intervals, and hypothesis tests are correct only if least

squares estimation is done, or if maximum likelihood estimation is used with a proper

negative log-likelihood.

Example of Setting Parameter Limits

The Fit Curve personality enables you to fit a model and then use the prediction equation in

the full personality of the Nonlinear platform. This method requires more steps and user
input but allows any nonlinear model to be fit.

Complete “Example Using the Fit Curve Platform” to fit the model. This example shows how

to save the prediction formula from Fit Curve and then set parameter limits in Nonlinear.

1.

SANERC LI N O

Click the Logistic 4P red triangle and select Save Formulas > Save Parametric Prediction

Formula.

A new column named Toxicity Predictor appears in the data table.

Select Analyze > Specialized Modeling > Nonlinear.
Assign Toxicity to the Y, Response role.
Assign Toxicity Predictor to the X, Predictor Formula role.

Assign Formulation to the Group role.

Click OK.

The Nonlinear Fit window appears. In the Control Panel, parameter values and locking
options are shown. The letters listed before each parameter correspond to variables from

the Prediction Model in the Fit Curve function.
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Figure 15.18 Nonlinear Fit Control Panel
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Tip: You can lock parameters if you know the values from prior information.

7.

Click the Nonlinear Fit red triangle and select Parameter Bounds.

Options for setting the lower and upper parameters appear next to the parameters.

Set the lower bounds for the parameters as shown in Figure 15.19. You know from prior

experience that the maximum toxicity of the drug is at least 1.1.
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Figure 15.19 Setting Parameter Bounds
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Figure 15.20 Nonlinear Fit Plot and Parameter Estimates
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Options below the plot allow for adjusting parameter limits and estimates.

Statistical Details for the Nonlinear Platform

e “Profile Likelihood Confidence Limits”
e  “How Custom Loss Functions Work”
¢ “Notes Concerning Derivatives”

* “Notes on Effective Nonlinear Modeling”
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Profile Likelihood Confidence Limits

The upper and lower confidence limits for the parameters are based on a search for the value
of each parameter after minimizing with respect to the other parameters. The search looks for
values that produce an SSE greater by a certain amount than the solution’s minimum SSE. The
goal of this difference is based on the F-distribution. The intervals are sometimes called

likelihood confidence intervals or profile likelihood confidence intervals (Bates and Watts 1988;
Ratkowsky 1990).

Profile confidence limits all start with a goal SSE. This is a sum of squared errors (or sum of
loss function) that an F test considers significantly different from the solution SSE at the given
alpha level. If the loss function is specified to be a negative log-likelihood, then a Chi-square
quantile is used instead of an F quantile. For each parameter’s upper confidence limit, the
parameter value is increased until the SSE reaches the goal SSE. As the parameter value is
moved up, all the other parameters are adjusted to be least squares estimates subject to the
change in the profiled parameter. Conceptually, this is a compounded set of nested iterations.
Internally there is a way to do this with one set of iterations developed by Johnston and
DeLong. See the SAS/ETS User’s Guide (SAS Institute Inc. 2020).

Figure 15.21 shows the contour of the goal SSE or negative likelihood, with the least squares
(or least loss) solution inside the shaded region:

® The asymptotic standard errors produce confidence intervals that approximate the region
with an ellipsoid and take the parameter values at the extremes (at the horizontal and
vertical tangents).

* Profile confidence limits find the parameter values at the extremes of the true region,

rather than the approximating ellipsoid.

Figure 15.21 Diagram of Confidence Limits for Parameters

approximate 95% confidence ellipse

likelihood 95%

confidence
interval for b1
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Likelihood confidence intervals are more trustworthy than confidence intervals calculated
from approximate standard errors. If a particular limit cannot be found, computations begin
for the next limit. When you have difficulty obtaining convergence, try the following:

* use a larger alpha, resulting in a shorter interval, more likely to be better behaved
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¢ relax the confidence limit criteria.

How Custom Loss Functions Work

The nonlinear facility can minimize or maximize functions other than the default sum of
squares residual. This section shows the mathematics of how it is done.

Suppose that f(B) is the model. Then the Nonlinear platform attempts to minimize the sum of
the loss functions defined as follows:

n

L= S p(f(B)
i=1

The loss function p(®) for each row can be a function of other variables in the data table. It
must have nonzero first- and second-order derivatives. The default p(®) function,
squared-residuals, is

p(f(B) = (vy—f(B))

To specify a model with a custom loss function, construct a variable in the data table and build
the loss function. After launching the Nonlinear platform, select the column containing the
loss function as the loss variable.

The nonlinear minimization formula works by taking the first two derivatives of p(®) with
respect to the model, and forming the gradient and an approximate Hessian as follows:

n

L= Y p(f(B)
i=1

aL _ Z Sp(F(B)) o

P DT B

n

2
oL 5 Oolf (BN o o p(F(BNE f
oB;oBy of)> BBy of PP,

If f(®) is linear in the parameters, the second term in the last equation is zero. If not, you can
still hope that its sum is small relative to the first term, and use

2 n
0L B o O
0P 0By iZ1 (of)? 9By By

The second term is probably small if p is the squared residual because the sum of residuals is
small. The term is zero if there is an intercept term. For least squares, this is the term that
distinguishes Gauss-Newton from Newton-Raphson.
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Note: The standard errors, confidence intervals, and hypothesis tests are correct only if least
squares estimation is done, or if maximum likelihood estimation is used with a proper
negative log-likelihood.

Notes Concerning Derivatives

The nonlinear platform takes symbolic derivatives for formulas with most common
operations. This section shows what type of derivative expressions result.

If you open the Negative Exponential.jmp nonlinear sample data example, the actual formula
for the Nonlinear column looks something like this:

Parameter({b0=0.5, b1=0.5}, bO*(1-Exp(-b1*X)))

The Parameter block in the formula is hidden if you use the formula editor. That is how it is
stored in the column and how it appears in the Nonlinear Launch dialog. Two parameters
named b0 and b1 are given initial values and used in the formula to be fit.

The Nonlinear platform makes a separate copy of the formula, and edits it to extract the
parameters from the expression. Then it maps the references to them to the place where they
are estimated. Nonlinear takes the analytic derivatives of the prediction formula with respect
to the parameters. If you use the Show Derivatives command, you get the resulting formulas
listed in the log, like this:

Prediction Model:
b0 * First(T#1=1-(T#2=Exp(-b1*X)), T#3=-(-1*T#2*X))
The Derivative of Model with respect to the parameters is:
{T#1, T#3*b0}
The derivative facility works like this:

¢ In order to avoid calculating subexpressions repeatedly, the prediction model is threaded
with assignments to store the values of subexpressions that it needs for derivative
calculations. The assignments are made to names like T#1, T#2, and so on.

¢ When the prediction model needs additional subexpressions evaluated, it uses the First
function, which returns the value of the first argument expression, and also evaluates the
other arguments. In this case additional assignments are needed for derivatives.

® The derivative table itself is a list of expressions, one expression for each parameter to be
fit. For example, the derivative of the model with respect to b0 is T#1; its thread in the
prediction model is 1-(Exp(-b1*X)). The derivative with respect to b1 is T#3*b0, which
is = (-1*Exp (-b1*X)*X) *b0 if you substitute in the assignments above. Although many
optimizations are made, it does not always combine the operations optimally. You can see
this by the expression for T#3, which does not remove a double negation.
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If you specify a loss function, then the formula editor takes derivatives with respect to
parameters, if it has any. And it takes first and second derivatives with respect to the model, if
there is one.

If the derivative mechanism does not know how to take the analytic derivative of a function,
then it takes numerical derivatives, using the NumDeriv function. If this occurs, the platform
shows the delta that it used to evaluate the change in the function with respect to a delta
change in the arguments. You might need to experiment with different delta settings to obtain
good numerical derivatives.

Tips
There are always many ways to represent a given model, and some ways behave much better

than other forms. Ratkowsky (1990) covers alternative forms in his text.

If you have repeated subexpressions that occur several places in a formula, then it is better to
make an assignment to a temporary variable. Then refer to it later in the formula. For example,
one of the model formulas above was this:

If(Y==0, Log(1/(1+Exp(model))), Log(l - 1/(1 + Exp(model))));
This could be simplified by factoring out an expression and assigning it to a local variable:

temp=1/(1+Exp(model));
If(Y==0, Log(temp), Log(1l-temp));

The derivative facility can track derivatives across assignments and conditionals.

Notes on Effective Nonlinear Modeling

We strongly encourage you to center polynomials.

Anywhere you have a complete polynomial term that is linear in the parameters, it is always
good to center the polynomials. This improves the condition of the numerical surface for
optimization. For example, if you have an expression like the following:

a;+byx+ clx2
you should transform it to
b _ _\2
Ay +by(Xx —X) +cp(x —%)

The two models are equivalent, apart from a transformation of the parameters, but the second
model is far easier to fit if the model is nonlinear.
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The transformation of the parameters is easy to solve.

_ _2
a; = dy— bzx +oyX

b1 = b2 —2c,%

If the number of iterations still goes to the maximum, increase the maximum number of
iterations or relax one of the convergence criteria.

There is really no one omnibus optimization method that works well on all problems. JMP has
options like Newton, QuasiNewton BFGS, QuasiNewton SR1, and Numeric Derivatives Only
to expand the range of problems that are solvable by the Nonlinear Platform.

If the default settings are unable to converge to the solution for a particular problem, using
various combinations of these settings to increase the odds of obtaining convergence.

Some models are very sensitive to starting values of the parameters. Working on new starting
values is often effective. Edit the starting values and click Reset to see the effect. The plot often
helps. Use the sliders to visually modify the curve to fit better. The parameter profilers can
help, but might be too slow for anything but small data sets.
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Perform Functional Data Analysis

The Functional Data Explorer platform is available only in JMP Pro.

The Functional Data Explorer (FDE) platform is designed for data that are functions, signals,
or series. It can be used as an exploratory data analysis tool or as a dimension-reduction
technique. In the case of dimension reduction, the FDE platform converts functional data into
a form that can be analyzed in another JMP platform.

Data preprocessing tools are available in the FDE platform, including several types of
transformations for output data and alignments for input data. A functional model is created
by fitting a B-spline, P-spline, or Fourier basis model to the data. When a model is fit,
functional principal components analysis (functional PCA) is automatically performed on the
functional model. Results from the functional PCA, such as the functional principal
component scores, are saved to a separate data table for feature extraction or dimension
reduction.

Figure 16.1 B-Spline Model Selection in FDE
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w Overview of the Functional Data Explorer Platform

Functional data can be defined as data that are recorded over a continuous domain, where a
set of measurements form a curve or image. Often, the domain is time and the sets of
measurements are defined by an ID variable. A functional data observation for ID level i at a
specific point f on the domain is written as f;(f). The Functional Data Explorer platform enables
you to explore and analyze functional data.

The form of functional data can be dense or sparse. Dense functional data occur when
observations are on the same equally spaced grid of points for all levels of the ID variable.
Sparse functional data occur when ID levels have different numbers of observations that are
unequally spaced across the domain. The Functional Data Explorer platform can handle both
forms of functional data.

Although functional data can be expressed in many ways, it can generally be classified into
the following two cases:

* The response of interest, f(f), has a functional form.

* There are one or more covariates, f(t)’s, that have functional forms. These are sometimes
referred to as functional or signal processes.

The Functional Data Explorer platform is useful as an exploratory tool for any type of
functional data. However, the strength of the platform is taking many functional processes
(that might be associated with a scalar response) and extracting key features to use in further
modeling. This can be done by first fitting a functional model to the data using a B-spline,
P-spline, or Fourier basis model. Then, a functional principal components analysis (functional
PCA) is performed on the functional model. Results from the functional PCA, such as the
functional principal component (FPC) scores, are saved and used for feature extraction and
analysis in another modeling platform, such as the Generalized Regression personality of the
Fit Model platform. Alternatively, you can specify a set of supplementary variables and fit a
generalized regression model within the FDE platform to determine how these variables affect
the response.

For more information about functional data analysis, see Ramsay and Silverman (2005).
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JMP

PRO

Example of Functional Data Explorer

This example analyzes weekly weather data collected from 16 weather stations across the
United States. Run the Weather Station Locations script in the data table to view a map of the
locations. Daily temperatures are summarized as weekly averages. Not every weather station
has a weekly temperature measurement for every week of the year. This is an example of

sparse functional data.

Select TMAX and click Y, Output.
Select Week of Year and click X, Input.
Select ID and click ID, Function.

Click OK.

AL N

Figure 16.2 Initial Functional Data Explorer Report
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Select Help > Sample Data Library and open Functional Data/Weekly Weather Data.jmp.

Select Analyze > Specialized Modeling > Functional Data Explorer.
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A4 Target Functions

The initial Functional Data Explorer report contains plots of the raw data, summary
statistics, and summary plots for the functional mean and functional standard deviation of
the data. There are also buttons for data processing options. Data processing options are
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also accessible from the Data Processing red triangle menu. Prior to modeling, it is often a
good idea to standardize your output data.

7. Click the Standardize button under the Transform menu.

The data plots and summary statistics are updated based on the specified transformation.
Standardized is added to the Steps list.

8. Click the Functional Data Explorer red triangle and select Models > Fourier Basis.

Figure 16.3 Fourier Basis Model Report

4 = |Fourier Basis on Standardize
[ Model Controls
4 Model Selection

3 Legend

+ Legend
2 — Prediction 500 | —Pericd 53
£ |
g
5 0 550 |
3
3 I
5 - BIC
£ 1
g 2 500
|
3
|
4 450
-10 0 10 20 30 40 50 60 |
Week of Year
—— = 0 5 10 15 20
Trining | (116 - |[&][3] Number of Fourier Pairs
1010 20 50 -10 10 20 50 -10 10 30 50 -10 10 30 50 -10 10 30 50 AFit Statistics
5 Pairs 3
. . -2 Log Likelihood 355.54285
0 /\ /’\ f‘h\x j‘/\\ /f"\ Alce 384.22137
2 Eictol TN Forpus Christi I Denver 0 | Goodwell 0F lanvon Nations BIC 44587154
PR [ Y N Gov 0.0713964

Transformed TMAX Std Dev  0.276974
| Diagnostic Plots
[ = Function Summaries
I Basis Function Coefficients
> Random Coefficients by Function

The Fourier Basis report includes several reports that contain information about the
selected model. In the Model Selection report, the displayed model is the best fitting
model according to the BIC fit criterion. For the weather data, the Fourier Basis model that
is chosen has a period of 53 and three basis function pairs. Fit statistics and coefficients are
also available for the model. Scroll down to view the Functional PCA report.
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Figure 16.4 Functional PCA Report
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The Functional PCA report shows that the first two eigenvalues explain nearly 97% of the
variation in the data. In the Model Selection graph, click and drag the red dashed line to 3
FPCs to see that the first three eigenvalues explain 99% of the variation in the data.
However, the first eigenvalue alone explains 92%. You can use the Score Plot to detect
individual functions that are outliers from the other functions. In the Score Plot, most of
the locations are clustered together except for the Miami Beach, FL and Greenville, ME
locations. Scroll up to the individual function plots. The function for the Miami Beach
location is flatter, indicating less temperature variability than the rest of the locations. The
function for the Greenville location has a lower maximum, indicating consistently colder
temperatures than the rest of the locations.

Tip: Deselect the Label variables option in the Score Plot report to better identify outliers.

w Launch the Functional Data Explorer Platform

Launch the Functional Data Explorer platform by selecting Analyze > Specialized Modeling >
Functional Data Explorer.

Figure 16.5 Functional Data Explorer Launch Window
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For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Functional Data Explorer launch window includes tabs for different types of data
formats. Select the tab based on your data format.

Stacked Data Format Select for data tables where each row corresponds to a single
observation. There are separate columns for the output, input, and ID variables.
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Note: The Stacked Data Format is the only data format that enables you to specify
multiple functional processes. If you assign more than one column to Y, Output in the
Stacked Data Format tab, each Y variable is analyzed separately. A Fit Group report
contains the individual reports for the Y variables.

Rows as Functions Select for data tables where each row corresponds to the full output

function for one level of the ID variable. Each column is a level of the input variable.

Caution: The Rows as Functions format assumes that your observations are equally
spaced in the input domain unless the FDE X column property is used. The FDE X column
property enables this data format to use input variables specified in the column names.

Columns as Functions Select for data tables where each column corresponds to the entire

output function for one level of the ID variable. Each row corresponds to a level of the
input variable.

Launch Window Options

Y, Output Assigns the functional process, f(t). There must be at least two observed output

values for each level of the ID variable.

Note: Functions with fewer than two observed output values are removed from the
analysis.

X, Input  (Available for Stacked Data Format and Columns as Functions.) Assigns the input

variable ¢t. If no variable is specified for X, Input, the row number is used. Using the row
number assumes that the observations are equally spaced in the input domain.

ID, Function (Available for Stacked Data Format and Rows as Functions.) Assigns the ID

variable to each function. For Stacked Data, if no ID variable is assigned all observations
are assumed to come from one function.

Z, Supplementary (Available for Stacked Data Format and Rows as Functions.) Assigns one

or more supplementary variables. Supplementary variables are not used in any of the
calculations in the Functional Data Explorer platform and including them does not affect
the results. Supplementary variables are variables you might want to use in future
analyses of the results from Functional Data Explorer. When you specify supplementary
variables, they are included in a Supplementary column group in the tables that are created
by the Save Data and Save Summaries options. These columns retain any column
properties that were specified in the original data table. A Functional DOE Analysis option
is also made available for the fitted models. See “Functional DOE Analysis”.
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Freq (Available only for Stacked Data Format.) Assigns a column whose numeric values

represent a frequency for each row in the analysis. The effect of a frequency column is to
expand the data table, so that any row with integer frequency k is expanded to k identical
TOWS.

Validation Assigns an optional numeric column that defines the validation sets. This column

By

should contain only two distinct values. The smaller value defines the training set and the
larger value defines the validation set. If there are more than two values, the smallest value
defines the training set and all other values define the validation set. The FDE platform
uses the validation column to train and evaluate the model. For more information about
validation, see “Validation in JMP Modeling”.

Note: The Validation option enables you to hold out complete functions, not a sample of
observations from each function. Therefore, all observations that have the same ID value
must be classified as either test or validation. You cannot have observations with the same
ID value in both sets. For more information about this type of validation column, see
“Grouped Validation Column”.

Caution: If you click the Validation button with no columns selected in the Select Columns
list, and add a validation column to your data table it will not be a grouped validation
column. Instead, use the Make Validation Column Platform, see “Grouped Validation
Column”.

Assigns a column that creates a report consisting of separate analyses for each level of the
variable. If more than one By variable is assigned, a separate analysis is produced for each
possible combination of the levels of the By variables.
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u The Functional Data Explorer Report

The initial Functional Data Explorer report contains a Data Processing report and a

Summaries report.

Figure 16.6 Initial Functional Data Explorer Report
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The Data Processing Report includes an initial data plot of all observations, as well as a grid of
individual data plots that correspond to levels of the ID variable. The maximum number of
individual plots shown in the grid is twenty. There are drop-down menus and arrows above
the grid to interactively select which individual plots are shown. If you specified a validation
set, the first drop-down menu enables you to select if the individual plots shown are from the
training set or the validation set. If there are more than twenty functions, the second
drop-down menu and the arrows enable you to view different groups of plots. All graphs plot
the functional response data over the values of the input variable. The Data Processing Report

also contains data processing buttons.

The Summaries report contains a table of overall summary statistics, including the number of
observations, number of functions, and the overall mean, standard deviation, minimum, and
maximum values. There are also plots of the functional mean and functional standard
deviation. The functional summary statistics displayed in the plots are computed at each
unique value of the input variable.
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The Data Processing and Summaries reports are useful for preprocessing your data prior to
fitting a model or performing direct functional principal components analysis. There are data
cleaning, transformation, and alignment buttons available in the Data Processing Report that
correspond to the options in the Data Processing red triangle menu. See “Data Processing
Report Options”. Each time you perform a preprocessing step, the graphs and summary
results are automatically updated. You can perform multiple preprocessing steps in sequence.
Each step is added to the Steps list of the Data Processing report. To remove the most recent
step, click the Remove Last Step button below the Steps outline.

pio Model Reports

Use the options in the Models submenu in the Functional Data Explorer red triangle menu to
fit models to your data. See “Models” for the available models. Each time you fit a different
type of model to the data, a model report appears. Each model report contains the following
reports:

e “Model Controls”

e “Model Selection”

e “Diagnostic Plots”

e “Function Summaries”

e “Basis Function Coefficients”

e “Random Coefficients by Function”
e “Functional PCA”

Pro Model Controls

The Model Controls report enables you to define parameters of models to compare in the
Model Selection report. The appearance of the Model Controls report depends on the type of
model that is fit.

B-Spline and P-Spline Model Controls

When a B-Spline or P-Spline model is fit, you can specify the following parameters:

Number of Knots Add, remove, or specify a range for the number of knots in each spline.
The knots must be non-zero integers.
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Note: The maximum number of knots allowed for B-Spline models is one less than the
maximum number of observations per function or the number of unique inputs. The
maximum number of knots allowed for P-Spline models is two less than the number of
unique inputs. If you specify a number larger than the maximum, a warning message
appears.

Spline Degree Add or remove spline degree fits from the Model Selection report.

Fourier Basis Model Controls

When a Fourier Basis model is fit, you can specify the following parameters:

Number of Fourier Pairs Add, remove, or specify a range for the number of Fourier pairs to
compare.

Period Change the period of the function.

After you specify the model controls, click Go to view the updated models in the Model
Selection report.

Tip: To specify the Model Controls prior to fitting a model, press Shift, click the Functional
Data Explorer red triangle, and select the desired model. See “Models”.

Pro Model Selection

The Model Selection report contains an overall prediction plot, a grid of individual prediction
plots, a solution path plot, and a table of fit statistics. The grid of individual prediction plots
has the same layout and controls as the grid of individual plots in the Data Processing report.
At most, there are twenty plots shown at a time. There are drop-down menus and arrows that
enable you to view different groups of individual prediction plots. The solution path plot
shows a model selection criterion plotted over values of a model parameter. The Bayesian
Information Criterion (BIC) is the default fitting criterion. See “Model Report Options”. For
B-Spline and P-Spline models, there is a separate solution path for each spline degree plotted
across the defined number of knots. For Fourier Basis models, the solution path is plotted
across the number of Fourier pairs for a defined period. Use the Model Selection option to
change the solution path plot parameters.

The current solution is designated by the dotted vertical line in the solution path plot. By
default, the slider is placed at the number of knots or Fourier pairs that corresponds to the
model that has the smallest model selection criterion value. You can drag the slider at the top
of the dotted vertical line to change the number of knots or Fourier pairs in the current model.
Dragging the slider automatically updates the prediction plots in the Model Selection report,
as well as the information in all other reports.
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The Fit Statistics table contains a description of the current solution model. It also displays the
-2 Log Likelihood, the values for the AICc, BIC, and GCV model fitting criterion, and a value
for the response standard deviation, denoted as <Y, Output> Std Dev. The response standard
deviation is defined as the residual sigma from the fitted model. When a P-Spline model is
selected, the penalty parameter A (Lambda) is also displayed.

The prediction plots show the raw data and prediction curves that correspond to the current
model. If there is a validation set, the predicted curves are not shown for functions that are in
the validation set. For spline models, the default model selected is the degree of spline with
the best fit. Click a specific spline in the solution path plot or the legend to change the current
model selection. The curve in the overall prediction plot is a prediction of the mean curve. The
curves in the individual prediction plots are prediction curves for each specific function. For
B-Spline models, the overall prediction plot also displays the location of the knots. You can
change the location of the knots by dragging the blue slider bars to different locations. To
update the model reports according to the new knot locations, click the Update Models
button. To reset the knots to their default locations, click the Reset Knots button.

pro Diagnostic Plots
The Diagnostic Plots report contains the Actual by Predicted plot and the Residual by
Predicted plot. These plots help assess how well the current model fits the data. The
Diagnostic Plots report is closed by default.

pro Function Summaries
Displays summaries from the Functional PCA for each level of the ID variable. The functional
principal components associated with eigenvalues that explain more than 1% variation in the
data are displayed by default. The mean, standard deviation, median, minimum, maximum,
integrated difference, root integrated square error (RISE), and root integrated function square
(RIES) are also shown. The integrated difference and RISE summary values are used to
determine how much the ID specific function differs from the overall mean function. The RIFS
summary value is used for optimal curve fitting. See “Function Summaries Details”. The
Function Summaries red triangle menu contains the following options:

Customize Function Summaries Displays a window that enables you to select the number
of FPCs and the summary statistics that are shown in the Function Summaries report. If
the number of FPCs to be shown is specified, the Functional PCA report is also updated.
There is also a checkbox, Save Graphs, that determines whether a graph for each function
is included in the data table produced by the Save Summaries option.

Tip: If you have multiple functional processes, you can customize all Function Summaries
reports to show the same summary values by clicking Ctrl and selecting Customize
Function Summaries.
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Save Summaries Saves the summary statistics specified in the Function Summaries report to
a new data table. The name of the new data table describes the model fit. This data table
contains formula columns for the eigenfunctions, mean function, prediction function, and
conditional prediction function. There is also a column that contains the image of a graph
of the raw data and the specified model fit for each function. In the data table, there is a
profiler script that launches the prediction profilers for the prediction and conditional
prediction formulas. These formulas are functions of the input variable, the ID variable,
and the eigenfunctions.

Pro Basis Function Coefficients

Displays the estimated basis function coefficients and their standard deviations. These are
common across all levels of the ID variable and are fixed estimates in the mixed model
framework. To view standard errors and confidence intervals for the coefficients, right-click in
the table and select Columns.

Pro Random Coefficients by Function

Displays the estimated random coefficients for each basis function and functional process
combination. These are unique to each level of the ID variable and are random effects
estimates in the mixed model framework.

pro Functional PCA

Functional principal components analysis (functional PCA) is performed on the fitted
functional model. The Functional PCA report lists the eigenvalues that correspond to each
functional principal component (FPC) in order from largest to smallest. The percent of
variation accounted for by each FPC and the cumulative percent is listed and shown in a bar
chart. There is a graph of the mean function as well as a graph for each component. The
component graphs show the values of the eigenfunction.

You can perform model selection in the Functional PCA report to refine the selected number
of functional principal components. There is a solution path plot that shows the Bayesian
Information Criterion (BIC) plotted versus the number of FPCs. The current number of FPCs
is designated by the dotted vertical line in the solution path plot. It is possible that models
with different numbers of FPCs might have similar fits. Therefore, the solution path plot
provides zones, which are intervals of values of the BIC statistic. There is a green zone and a
yellow zone. The green zone contains values in the interval of the minimum BIC to the
minimum BIC plus four and the yellow zone contains values in the interval of the minimum
BIC plus four to the minimum BIC plus 10. By default, the model with the smallest number of
FPCs within the green zone is selected. You can drag the slider at the top of the vertical line to
change the number of FPCs. Dragging the slider automatically updates the other information
in the Functional PCA report.
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Note: The zones may appear small on your plot. Zoom in on the y-axis to better visualize the
zones.

When Direct Functional PCA is performed, there is also an overall prediction plot and a grid
of individual prediction plots. The grid of individual prediction plots has the same layout and
controls as the grid of individual plots in the Data Processing report. At most, there are twenty
plots shown at a time and there are drop-down menus and arrows that enable you to view
different groups of individual prediction plots. Updating the number of FPCs automatically
updates the prediction plots as well.

The prediction plots show the raw data and prediction curves that correspond to the current
model. If there is a validation set, the predicted curves are not shown for functions that are in
the validation set. The curve in the overall prediction plot is a prediction of the mean curve,
given the specified number of FPCs. The curves in the individual prediction plots are
prediction curves for each specific function, given the specified number of FPCs.

Note: The Functional PCA report is not shown if only a single function is modeled.
Otherwise, if JMP is unable to perform Functional PCA, an error message appears in the
Functional PCA report.

The following options are available in the Functional PCA red triangle menu:

Diagnostic Plots Shows or hides the Actual by Predicted and the Residual by Predicted
plots. Use these plots help assess how well the model fits the data, given the selected
number of functional principal components.

Score Plot Shows or hides a score plot of the FPC scores. Use the lists under Select
Component to specify which FPCs are plotted on each axis of the Score Plot. If there is
only one FPC, the FPC scores are plotted on the line y = x and the lists to change the
components are not shown. Score plots are useful for detecting outliers. In the case of FPC
scores, the Score Plot is useful for detecting levels of the ID variable that have outlier
functions. If you select a point in the score plot, the FPC Profiler is set to the scores for that
function.

Tip: Hover over a point in the score plot to view a prediction plot of the fitted curve for
that level of the ID variable.

FPC Profiler Shows or hides a profiler of the FPC scores. The FPC Profiler includes a column
for the input variable and a column for each FPC score. For each target function that is
specified, there are two additional profilers. One measures the difference from the target
function, and the other measures the integrated error from the target function. For more
information about FPC Profiler red triangle menu options, see Profilers.
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Tip: Use the Reset button to reset all of the FPC scores to 0 in the profiler.

Customize Number of FPC’s Specifies the number of FPC scores to show in the Functional
PCA. Specifying the number of FPC scores in this option also updates the Function
Summaries report. To view the mean model, set the number of FPC’s to 0.

s Functional Data Explorer Platform Options

The Functional Data Explorer red triangle menu contains the following options:
Summaries A submenu of the following options for functional summary statistics:

Plot Mean Shows or hides a plot of the functional mean in the Summaries report. On by
default.

Plot Standard Deviation Shows or hides a plot of the functional standard deviation in the
Summaries report. On by default.

Plot Median Shows or hides a plot of the functional median in the Summaries report.

Models A submenu of the following model options:

B-Splines Fits a basis spline (B-Spline) model to the data. Use the B-Spline model for
non-periodic data.

P-Splines Fits a penalized basis spline (P-Spline) model to the data.

Fourier Basis Fits a Fourier Basis model to the data. Use the Fourier Basis model for

periodic data. A periodic model assumes that the function finishes where it starts. See
“Fourier Basis Model”.

Note: If there are fewer than three unique input values, neither a Fourier basis model or a
P-Spline model can be fit to the data, and a warning message appears.

Model Controls Shows a submenu that enables you to open the Model Controls panel prior
to fitting a model. See “Model Controls”.

Direct Functional PCA (Not available if there is only a single function.) Performs functional
principal components analysis directly on the data, without fitting a basis function model

tirst. This reduces computation time, particularly for large data sets. The implementation
of Direct Functional PCA is as follows:

1. Align the input data to be between 0 and 1 and interpolate the observations to a
common grid of input values.



Chapter 16 Functional Data Explorer 293
Predictive and Specialized Modeling Functional Data Explorer Platform Options

2. Perform functional principal components analysis on the data.

3. Smooth the first eigenfunction using a P-Spline model with a knot at each grid point.

4. Remove the first smoothed eigenfunction from the data and repeat step 2 to step 4 until
a large amount of the variation in the data is explained.

Once you perform a Direct Functional PCA, a Functional PCA report is shown. See
“Functional PCA”.

Save Data Saves the processed data to a new data table. The processed data are saved in the
stacked data format.

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

bt Functional Data Explorer Group Options

Functional Data Explorer Group options are available only when there are multiple functional
processes specified in the Stacked Data Format tab in the launch window.

Summaries A submenu of options to show or hide plots of functional summary statistics for
all functional processes. See “Summaries”.

Data Processing A submenu of data processing options that can be applied to all functional
processes. See “Data Processing Report Options”.

Models A submenu of model options that can be fit to all functional processes. See
“Models”.

Save Data Saves the processed data for all functional processes to a new data table. The
processed data are saved in the stacked data format.

Save Summaries Saves the summary statistics specified in each Function Summaries report
to a new data table. The name of the new data table describes the model fit. This data table
contains formula columns for the eigenfunctions, mean function, prediction function, and
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conditional prediction function for each of the Y variables. In the data table, there is a
profiler script for each Y variable that launches the prediction profilers for the prediction
and conditional prediction formulas. These formulas are functions of the input variable,
the ID variable, and the eigenfunctions.

Arrange in Rows Specifies how many reports are displayed across the window.
See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Data Processing Report Options

The Data Processing red triangle menu contains the following options:
Cleanup A submenu of the following data cleanup options:

Remove Zeros Removes observations with zero values. If there are no zeros in the data,
an alert appears, indicating that no zero values were found.

Remove Value Displays a specifications window that enables you to specify a value to
remove from the data.

Remove Selected Removes observations that correspond to rows that are selected in the
data table.

Remove Unselected Removes observations that correspond to rows that are not
selected in the data table.

Caution: Remove Selected and Remove Unselected remove the row numbers. When Auto
Recalc is enabled, you must add or delete rows before using these options.

Filter X Removes X values that fall outside of a specified interval. When you select the
Filter X option, you must specify Below and Above values. The X values that fall
outside of the specified interval are not used for the analysis.
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Filter Y Removes Y values that fall outside of a specified interval. When you select the

Filter Y option, you must specify Below and Above values. The Y values that fall
outside of the specified interval are not used for the analysis.

Reduce Reduces the data over the X values using one of the following techniques:

Use the Grid tab to interpolate observations to a common grid of values. You can
specify the grid size. By default, the grid size is half the number of unique input values
and therefore reduces the number of total observations. If you are not interested in
reducing the number of total observations, but simply want your observations to be on
the same grid, specify the grid size to be the number of unique input values.

Use the Bin tab to create a specified number of bins that are evenly spaced over the
unique X values. For each function (or level of the ID, Function variable), the
observations within a bin are averaged to produce a Y value for the corresponding bin
level.

Use the Thin tab to remove every N observation over the X values, where N is
determined by the specified thinning rate. This is done for each function (or level of the
ID, Function variable). By default, the thinning rate is 2, which removes half of the
observations in each function.

Note: The Remove options exclude the specified observations from the analysis and
modeling reports, but the observations remain unchanged in the data table.

Transform A submenu of the following options to transform the data:

Center Centers the output.

Standardize Standardizes the output by centering and scaling the data to have mean 0

and variance 1.

Range 0 to 1 Scales the output to lie within the range of 0 and 1.

Square Root Transforms the data by computing the square root of the output. The

output values must be nonnegative.

Square Transforms the data by computing the square of the output.

Log Transforms the data by computing the natural logarithm of the output.

Exp Transforms the data by computing the exponential function of the output.

Negation Transforms the data by negating the output.

Logit Transforms the data by computing the logit function of the output. The output

values must be between 0 and 1.

Log X Transforms the data by computing the natural logarithm of the input.
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Align A submenu of the following options to align the input data:
Row Alignment Replaces the input values with the row number.

Align Maximum Aligns the functions using the observed maximum output value for each
ID level. The input value associated with the observed maximum output value is set to
zero for each ID level and the other input values are shifted up or down based on the
difference between the observed maximum and zero.

Align Minimum  Aligns the functions using the observed minimum output value for each
ID level. The input value associated with the observed minimum output value is set to
zero for each ID level and the other input values are shifted up or down based on the
difference between the observed minimum and zero.

Align 0to 1 Aligns the output functions such that the range of the input values is 0 to 1.
Tip: Align 0 to 1 is particularly useful when you fit a P-Spline model.

Align by Function Aligns the output functions such that each function starts at the
overall minimum of the input values and ends at the overall maximum of the input
values.

Dynamic Time Warping (Available only when there is more than one function.) Aligns
the output functions using dynamic time warping (DTW). DTW is a function alignment
technique that finds an optimal warping to align two or more functions together. When
you select the DTW option, a Select Reference Function window appears. Use this to
select the reference function. The reference function is the function that the remaining
functions are aligned to.

Once you select a reference function and click OK, a warping function plot is shown
along with a list for the remaining query functions. On the warping function plot, the
reference function is on the y-axis and the selected query function is on the x-axis.
Deviations from the red diagonal line (y = x) indicate that the inputs of the query
function have been warped for better alignment.

Target Functions (Available only when there is more than one function.) A submenu that
enables you to load target functions.

Load Targets Shows a window that enables you to specify a target function. A target
function is used for curve matching, where it is desirable for all of the functions to look
like the target function. You can also specify two target functions to compare the
remaining curves to the “best” and “worse” case functions.

If you specify one or more target functions, the data from the functions are not used in
model fitting. For each specified target function, two rows are added to the FPC
Profiler. See “FPC Profiler”.
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Note: Target functions must be loaded before any other preprocessing steps are
performed.

Dynamic Time Warping Options
Plot Warping Functions Shows or hides the warping function plot. On by default.

Save Distance Matrix Saves the distance matrix to a separate data table. The distance matrix
can be useful for clustering the functions. The distance matrix data table contains a
hierarchical clustering script.

Save Warping Functions Saves the warping functions to a separate data table. Each row of
the data table contains the DTW adjusted input variable, the original input variable, and
the ID variable.

po Model Report Options

Model Selection Displays a submenu of choices to use as the model selection criteria. The
choices are AICc, BIC, and GCV. See Fitting Linear Models.

Plot Basis Shows or hides a plot of all the basis functions on one graph.
Diagnostic Plots Shows or hides the Diagnostics Plots report. See “Diagnostic Plots”

Function Summaries Shows or hides the Function Summaries report. See “Function
Summaries”.

Basis Function Coefficients Shows or hides the Basis Function Coefficients report. See
“Basis Function Coefficients”.

Random Coefficients by Function Shows or hides the Random Coefficients by Function
report. See “Random Coefficients by Function”.

Functional PCA Shows or hides the Functional PCA report. See “Functional PCA”.

Functional DOE Analysis (Available only if at least one supplementary variable is specified
in the launch window.) Launches a Generalized Regression report within the FDE
platform. A generalized regression model is fit to each of the FPC score functions using the
supplementary variables as model effects. By default, a two degree factorial model is fit
and the Estimation Method is Best Subset. Note that categorical quadratic effects are not
included. If the number of terms in the model is greater than 21 or the number of functions
is greater than 1000, the Estimation Method automatically switches to Pruned Forward.
Alternatively, you can specify a model script in the original data table that defines the
desired model fit. Modeling the FPC scores using the supplementary variables enables you
to use the model fit to determine how the response changes based on the supplementary
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variables. Use the FDOE Profiler to explore how the supplementary variables affect the
response.

The Functional DOE Analysis report contains the following red triangle menu options:

Generalized Regression for FPC Scores Shows or hides the Generalized Regression
reports for each FPC score. For more information on Generalized Regression model
reports, see Fitting Linear Models.

Diagnostic Plots Shows or hides actual by predicted and residual plots for the response
variable.

FDOE Profiler Shows or hides the FDOE Profiler, which enables you to explore how the
response changes based on the supplementary variables. For more information about
the FPC Profiler red triangle menu options, see Profilers.

Save Columns Shows a list with the options Save Prediction Formula and Save Residual

Formula. These options save the corresponding formula to a new column in the data
table.

Save Data Saves the modeled data to a new data table. The modeled data are saved in the
stacked data format.

Remove Fit Removes the model report for the specified fit.

w Additional Examples of the Functional Data
Explorer Platform

¢ “Example for Multiple Functional Processes”

e “Example of Functional DOE”

pio Example for Multiple Functional Processes

This example uses the Fermentation Process.jmp and Fermentation Process Batch Yield
Results.jmp sample data tables to analyze enzyme production. Yield is the amount of an
enzyme produced by genetically modified yeast. There are 100 process measurements per
batch that were taken at equally spaced times over a 12-hour period.
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Use the Functional Data Explorer platform to fit models to the data and save functional
principal components to a new data table. The functional principal components are then
analyzed in the Generalized Regression personality of the Fit Model platform.

Fit Functional Models

Select Help > Sample Data Library and open Functional Data/Fermentation Process.jmp.
Select Analyze > Specialized Modeling > Functional Data Explorer.

In the Stacked Data Format tab, select Ethanol through pH and click Y, Output.

Select Time and click X, Input.

Select BatchlID and click ID, Function.

Click OK.

NS ol L=

Click the Functional Data Explorer Group red triangle and select Data Processing > Align
> Align 0 to 1. This aligns the input variable to be between 0 and 1 in each Functional Data
Explorer report.

8. Click the Functional Data Explorer Group red triangle and select Models > B-Splines. This
tits a B-spline model to each of the functional processes.

Figure 16.7 Functional Data Explorer Report for Ethanol
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Figure 16.8 Model Summary Report for Ethanol
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Figure 16.7 and Figure 16.8 show the model reports for one of the functional process
variables, Ethanol. Scroll through the full report to view the models fit for each of the
process variables. Next, use the FPCs in the Function Summaries report in an analysis.

Save FPCs and Link Yield Results

1. Press Ctrl, click any Function Summaries red triangle, and select Customize Function
Summaries.

In the box next to Enter number of FPCs to show, type 3.
Click the Deselect All Summaries box.
Click OK.

Click the Functional Data Explorer Group red triangle and select Save Summaries.

SRR N

Select Help > Sample Data Library and open Functional Data/Fermentation Process Batch
Yield Results.jmp.

7. In the Functional Data Explorer Model Summaries.jmp data table, right-click BatchID and
deselect Link ID.

8. In the Functional Data Explorer Model Summaries.jmp data table, right-click BatchID and
select Link Reference > Fermentation Process Batch Yield Results.jmp.

This virtually joins the yield data table and the summaries data table.
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Fit a Generalized Regression Model

Use the Generalized Regression personality of the Fit Model platform to determine how Yield
is affected by the functional process variables.

1. In the Functional Data Explorer Model Summaries.jmp data table, select Analyze > Fit Model.

N>

Click the triangle next to referenced by BatchlD to Fermentation Process Batch Yield
Results.

Select Yield[BatchlID] and click Y.

Select the remaining columns, except Time and BatchlD, and click Add.
Change the Personality to Generalized Regression.

Click Run.

Select the Adaptive box.

Click Go.

® N S g W

Figure 16.9 Generalized Regression Report for Batch Yield
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The Generalized Regression report shows that Yield is significantly affected by certain
components of Ethanol, Molasses Feed, NH3 Feed, and Air. The RSquare for the model is
0.73225. By using FDE to perform dimension reduction on the functional processes first, you
greatly reduce the number of variables, while still retaining the ability to build a reasonable
prediction models.

Example of Functional DOE

This example uses the Formulation For Homogeneity DOE.jmp data table to explore how
combinations of ingredients effect the homogeneity grade of a compound across different
temperatures. The three ingredients that form the compound are the primary ingredient
labeled Active, Water, and Solvent. There are 32 combinations of ingredients; these
combinations are denoted by the values in the Formulation column. For each formulation, the
Homogeneity Grade is measured from 20 to 70 degrees Celsius at 5 degree intervals. By
plotting these measurements across the different temperatures, you can form a curve for each
formulation. Use the Functional Data Explorer platform to determine how the curves change
depending on the values of Active, Water, and Solvent.

1. Select Help > Sample Data Library and open
Functional Data/Formulation For Homogeneity DOE.jmp.

Select Analyze > Specialized Modeling > Functional Data Explorer.
In the Stacked Data Format tab, select Homogeneity Grade and click Y, Output.
Select T and click X, Input.

Select Formulation and click ID, Function.

AL

Select Solvent, Active, and Water and click Z, Supplementary.

These variables are not used in the initial functional data analysis. However, by specifying
them here as supplementary variables, you can use them later when fitting models.

7. Click OK.
Click the Functional Data Explorer red triangle and select Models > B-Splines.

The best fitting model is a linear spline model with one knot.
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Figure 16.10 Functional PCA for Homogeneity Grade
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The Functional PCA report shows that two functional principal components are needed to

explain the variability in the data. The FPC Profiler shows how Homogeneity Grade is

affected by the FPCs across the different temperatures. However, there is no way to tell
how the actual ingredients affect the Homogeneity Grade.

9. Click the red triangle next to B-Spline on Initial data and select Functional DOE Analysis.
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The Functional DOE Analysis option fits a generalized regression model to each principal
component score using the three supplementary variables as predictors. Because the data
table contains a Model script, the models that are fit are based on the model defined in the
script.

Note: If your data table does not contain a Model script, a two degree factorial model is fit.

Figure 16.11 FDOE Profiler for Homogeneity Grade
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The FDOE Profiler enables you to explore how Homogeneity Grade changes based on the
predictors you are actually interested in. In general, Homogeneity Grade seems to decrease
as the amount of Active increases.

Note: In this example, the values of Active, Solvent, and Water are constrained to sum to 1.
This constraint is reflected in the profiler.

we Statistical Details for the Functional Data Explorer
Platform

e “Functional Model Fits”

e “Function Summaries Details”
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Functional Model Fits

All of the model fits in the Functional Data Explorer platform rely on basis function
expansion. Basis functions are a set of independent functions. Any function, f{t), can be
approximated by taking a linear combination of K basis functions, denoted as ¢;. In general, a
function is approximated as follows:

K
ft) = Z (1)
k=1
where the ¢, parameters are the basis coefficients. The amount of smoothing is determined by

the number of basis functions, K. For more information about basis function expansion, see
Ramsay and Silverman (2005).

pro Fourier Basis Model

The k=1,..., K functions that define the Fourier basis are defined such that ¢y =1,
$o.1 = sin(rot), and ¢y = cos(rmt). Then, the approximated function is defined as follows:

fi(t) = cio+cilsino)t+cizcosmt+ci3sin2mt+ci4C032(Dt+

This approximates a periodic function with period A defined as A = 2n/w. The coefficients are
a combination of fixed basis function coefficients and random coefficients by function. Each ¢
is defined as follows:

Cik = Bt oy

where f; is the fixed coefficient for basis function k and o is the random coefficient for basis
function k for a specific functional process i. For the Fourier Basis model, the estimates for the
Br and o parameters are found in the Basis Function Coefficients table and Random
Coefficients by Function table, respectively.

Fourier basis models have an intercept term and an equal number of sine and cosine terms,
which are referred to as Fourier pairs. Therefore, K is always odd. For example, if K=7, there
is an intercept term and three Fourier pairs.
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Function Summaries Details

The Function Summaries report includes the following summary statistics: integrated
difference, root integrated square error (RISE), and root integrated function squared (RIFS).
These summary statistics are defined in this section. For all equations in this section, it is
assumed that the input values have been aligned between 0 and 1. The following notation is
used for all functions:

fi(x) is the estimated function for curve i at input value x
m(x) is the estimated mean function at input value x

Integrated Difference

The integrated difference is the average difference between points on the ID specific curve and
the overall mean curve. It can be used to determine if the ID specific curve falls above or below
the mean curve, on average. The integrated difference for curve i is defined as follows:

1
ID; = [(f;(x)—m(x))dx
0

RISE

Root integrated square error (RISE) is the average distance between the ID specific curve and
the overall mean curve. It can be used to determine which ID specific curves are most similar
or most different from the overall mean curve. The RISE summary value for curve i is defined
as follows:

1
RISE;= [ (f(x) - () dx
0

RIFS

Root integrated function squared (RIFS) is a summary value for analyzing optimal curve
scenarios. If you pre-subtract off an optimal curve, you can use the smallest values of RIFS to
determine which functions are closest to the optimal curve. The RIFS summary value for curve
i is defined as follows:
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Gaussian Process
Fit Data Using Smoothing Models

Use the Gaussian Process platform to model the relationship between a continuous response
and one or more predictors. These types of models are common in computer simulation
experiments, such as the output of finite element codes, and they often perfectly interpolate
the data. Gaussian processes can deal with these no-error-term models, in which the same
input values always results in the same output value.

The Gaussian Process platform fits a spatial correlation model to the data. The correlation of
the response between two observations decreases as the values of the independent variables
become more distant.

One purpose for using this platform is to obtain a prediction formula that can be used for
further analysis and optimization.

Figure 17.1 Gaussian Process Prediction Surface Example
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Example of Gaussian Process

This example uses data from a space filling design in two variables with a deterministic
equation for Y (the response). You can use the Gaussian Process platform to find the
explanatory power of X1 and X2 on Y. You can view the equation for Y in the column formula.

Select Help > Sample Data Library and open 2D Gaussian Process Example.jmp.
Select Analyze > Specialized Modeling > Gaussian Process.

Select X1 and X2 and click X.

Select Y and click Y

Select Correlation Type > Cubic.

PRo Deselect Fast GASP.

Click OK.

N o gl L=

Figure 17.2 Gaussian Process Report
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Fit using the Cubic correlation function.

[* Marginal Model Plots

Note: The estimated parameters can be different due to different starting points in the
minimization routine, the choice of correlation type, and the inclusion of a nugget
parameter.
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Now, visualize the fitted surface compared to the original surface.

8. Click the red triangle next to Gaussian Process Model of Y and select Save Prediction
Formula.

9. Select Graph > Surface Plot.
10. Select X1 through Y Prediction Formula and click Columns.
11. Click OK.

12. In the Surface column, select Both sides for the Y Prediction Formula.

Figure 17.3 3D Surface Plot of the Actual and Predicted Ys

The two surfaces are similar. The impact of X1 and X2 on the response Y can be visualized.
You can rotate the plot to view it from different angles. Marginal plots are another tool to
use to understand the impact of the factors on the response.
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Launch the Gaussian Process Platform

Launch the Gaussian Process platform by selecting Analyze > Specialized Modeling >

Gaussian Process.

Figure 17.4 Gaussian Process Launch Window
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For more information about the options in the Select Columns red triangle menu, see Using

JMP.

Y Assigns the continuous columns to analyze.

X Assigns the columns to use as explanatory variables. Categorical variables are allowed in
JMP Pro when the Fast GASP option is specified.

Estimate Nugget Parameter Introduces a ridge parameter into the estimation procedure. A
ridge parameter is useful if there is noise or randomness in the response, and you want the
prediction model to smooth over the noise instead of perfectly interpolating.

JMP

PRo Fast GASP Option to use the Fast GASP algorithm. Fast GASP breaks the Gaussian

process model into small pieces (called blocks) to speed computation time. Blocks allow
for the use of multiple CPUs and parallel processing.

Note: When there are more than 2,500 observations, the Fast GASP algorithm is required.

For more information about Fast GASP, see Parker (2015).

Correlation Type Choose the correlation structure for the model. The platform fits a spatial
correlation model to the data, where the correlation of the response between two

observations decreases as the values of the independent variables become more distant.

Gaussian Restricts the correlation between two points to always be nonzero, no matter

the distance between the points.



314 Gaussian Process Chapter 17
The Gaussian Process Report Predictive and Specialized Modeling

Cubic Allows the correlation between two points to be zero for points that are far
enough apart. This method is a generalization of a cubic spline.

‘['3"'['{0 The Fast GASP algorithm does not support the cubic correlation function.
Minimum Theta Value Sets the minimum theta value to use in the fitted model. The default
is 0. The theta values are analogous to a slope parameter in regular regression models.
Small theta values indicate that a variable has little influence on the predicted values.

ﬂ'{o Block Size The number of observations in each computational block used by the Fast

GASP algorithm. There must be at least 25 observations per block and a maximum of the
number of rows in the data set up to a maximum of 2,500.

The Gaussian Process Report

* “Actual by Predicted Plot”
e “Model Report”
e “Marginal Model Plots”

Actual by Predicted Plot

The Actual by Predicted plot shows the actual Y values on the Y axis and the jackknife
predicted values on the X axis. One measure of goodness-of-fit is how well the points lie along
the diagonal (Y = X) of the plot.

The jackknife values are not true jackknife values in that the model is not re-fit with the
associated row for each Y excluded. Rather, the row is excluded from the prediction model for
each associated Y but the correlation parameters retain the contribution of the row in them.
For Gaussian processes that perfectly interpolate the data this jackknife procedure provides
predictions that are not equal to the input.

Model Report

The Model Report shows a functional ANOVA table for the model parameter estimates.
Specifically, it is an analysis of variance table where the variation is computed using a
function-driven method.

Theta Gaussian Process model parameter estimates. See “Statistical Details for the Gaussian
Process Platform”.
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Total Sensitivity Sum of the main effect and all interaction terms for each factor. It is a
measure of the amount of influence a factor and all its two-way interactions have on the
response variable.

Total variation is the integrated variability over the entire experimental space.

Main Effect The functional main effect of each factor is the integrated total variation due to
that factor alone. The main effect is the ratio of the functional effect and the total variation
for each factor in the model.

Interactions Functional interaction effects are computed in a similar way to main effects.

‘lj;wﬂ’o Categorical Input When the model includes categorical factors, a correlation matrix for

each categorical factor is provided. The off-diagonal entries correspond to Gaussian
Process model parameter estimates. See “Models with Categorical Predictors”.

2

Mu and Sigma“ The mean and variance model parameters.

Nugget The estimated nugget value. A nugget value is reported if you selected estimate
nugget parameter in the Gaussian Process launch window. A nugget value is also
reported if JMP has added a nugget parameter in order to avoid a singular covariance
matrix.

-2LogLikelihood The estimated value of twice the negative log-likelihood function. See
Fitting Linear Models.

Marginal Model Plots

A marginal plot appears for each factor in the model. For each plot, all factors except one are
integrated out using a distribution that is uniform over the ranges of the other factors in the
data. The marginal prediction of the response for the remaining factor of interest is drawn in
blue. The data points for the observed response values are included to show how well the
marginal model fits the data. For models with a small number of factors, these plots can be
used as diagnostic plots.

Gaussian Process Platform Options

The Gaussian Process red triangle menu contains the following options:
Profiler Opens the standard Profiler. See Profilers.
Contour Profiler Opens the Contour Profiler. See Profilers.

Surface Profiler Opens the Surface Profiler. See Profilers.
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Save Prediction Formula Creates a new prediction formula column in the active data table.

Save Variance Formula Creates a new variance formula column in the active data table.

‘II’NHO Publish Prediction Formula Creates a prediction formula and saves it as a formula

column script in the Formula Depot platform. If a Formula Depot report is not open, this
option creates a Formula Depot report. See “Formula Depot”.

#"\gﬂ Publish Variance Formula Creates a variance formula and saves it as a formula column
script in the Formula Depot platform. If a Formula Depot report is not open, this option
creates a Formula Depot report. See “Formula Depot”.

Save Jackknife Predicted Values Saves the jackknife predicted values to the active data
table. These are the X-axis values for the Actual by Predicted Plot.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Additional Examples of the Gaussian Process
Platform

e “Example of a Gaussian Process Model”

* “Example of Gaussian Process Model with Categorical Predictors”
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Example of a Gaussian Process Model

This example uses data that demonstrates the flow of water through a Borehole that is drilled
from the ground surface through two aquifers. Given a specified engineering model the
Gaussian process lets us understand the impact of factors included in the model on the
response, Y.

1. Select Help > Sample Data Library and open Design Experiment/Borehole Latin
Hypercube.jmp.

Select Analyze > Specialized Modeling > Gaussian Process.

Select log10 Rw through Kw and click X.

Select Y and click Y.

f,"ﬁpo In JMP Pro, to run the analysis faster, leave the Fast GASP checked.

Click OK.

SANERC LI N T

Figure 17.5 Borehole Latin Hypercube Report

4 [~|Gaussian Process Model of Y

4 Actual by Predicted Plot
150

-
.
L
125 .
.
100
.
¥ 75 »
.
-~
50 -
'..
..
25 ol
o
0
0 25 50 75 100 125 150
¥ Jackknife Predicted
4 Model Report
Total log10 Rw log10R Tu Tl Hu HI Kw
Column Theta Sensitivity Main Effect Interaction Interaction Interaction Interaction Interaction Interaction LInteraction Interaction
log10 Rw 3.1176666 0.9056500  0.8780948 5 0 0 823845  0.009361 0.0098402 0.0069199  0.0013434
loglOR  2.3588=8 0 0 0 5 0 0 0 0 0 0
Tu 6.236e17 5.9483e8  5.9305e8 0 0 5 0 1.38e-10 0 0 3.96e-11
il 262116 0.0004260 9.9057=5 8.2584e5 0 0 . 3.5637e5 1.6787e5 0.0001811  1.1754e5
Hu 1.8619e6 0.0406251 0.0309698  0.009361 0 138e-10  3.5637e5 . 211145 0.0001643  0.0000733
HI 147626 0.0417349 0.03168 0.0098492 0 0 167875 2.1114e5 5 00001829  2.4958=5
L 1.1809e7 0.0325842  0.0250417 0.0069199 0 0 0.0001811 00001643 0.0001929 . 8.4321e5
Kw 1.6608e0 00072782  0.0057404 0.0013424 0 3.96e-11  1.1734e5 00000733 2.4958e5 8.4321e5
n a Nugget

113.66359 19535458 3.0931e6
-2*Loglikelihood
205.91976
Fit using the Gaussian correlation function,
Nugget parameter set to aveid singular variance matrix,
‘Warning: Likelihood estimation algorithm did not converge.

> Marginal Model Plots
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The data on the actual by predicted plot fall along the Y = X line, indicating that the
Gaussian process prediction model is a good approximation of the true function. In the
Model Report, you see that the first factor, log10 Rw, has the highest total sensitivity. The
estimated total sensitivity for logl0 Rw explains more than 90% of the variation in the
response. Factors with small theta values have little (or no) impact on the prediction
formula. Use the profiler to visualize the sensitivities.

7. Click the Gaussian Process Model of Y red triangle and select Profiler.

The desirability functions automatically appear because the response, Y, has a Response
Limits column property.

8. Click the Prediction Profiler red triangle and select Optimize and Desirability > Maximize
Desirability.

Figure 17.6 Gaussian Process Model Profiler
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The desirability function is set to maximize the response Y because Y has goal set to
Maximize in the Response Limits column property. Maximizing the desirability functions
identifies the values of the factors that maximize the response. The shaded bands
represent the 95% confidence intervals.

Note: Your estimates can differ from those shown in Figure 17.5, which were found using
the Fast GASP algorithm.

pio Example of Gaussian Process Model with Categorical Predictors

This example uses the Algorithm Data.jmp sample data table. These data are simulated

CPU times from a 50 run space filling designed experiment. The Algorithm Factors.jmp sample
data table provides the factors and settings for the design. The design has three continuous
and two categorical factors. The goal is to predict CPU Time using a Gaussian Process model
that contains both continuous and categorical factors.

1. Select Help > Sample Data Library and open Design Experiment/Algorithm Data.jmp.
2. Select Analyze > Specialized Modeling > Gaussian Process.
3. Select Alpha through Compiler and click X.
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4. Select CPU Time and click Y.
f,wﬁpo To run the analysis, leave the Fast GASP checked. Click OK.

Note: The Fast GASP option must be used for models that contain categorical factors. See
“Models with Categorical Predictors”.

Figure 17.7 Algorithm Data Report
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Gamma 0.0018767 0.0898853 0.0898593 1.1373e6  2.4865e5

Categorical input Algorithm

Dynamic  Greedy Transform
Dynamic 1.0000 0.9900  0.9993
Greedy 0.9909 1.0000 1.0000
Transform  0.9998 1.0000 1.0000

Categorical input Compiler
A B
A 1.0000 1.0000
B 1.0000 1.0000
n o
336.14857 37115284
-2*Loglikelihood
240.06589
Fit using the Gaussian correlaticn functicn.
Warning: Likelihood estimation algorithm did not converge,

[* Marginal Model Plots

The actual by predicted plot shows a strong correlation between the actual and predicted
CPU times. This in an indication that the Gaussian process prediction model is a good
approximation of the true function. In the Model Report, the Beta predictor has the highest
total sensitivity. This indicates that of the continuous predictors, Beta explains the most
variation in the response. There is a separate Categorical Input matrix for each of the
categorical predictors, Algorithm and Compiler. These matrices are correlation matrices and
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show the correlation between levels for each categorical predictor. The off-diagonals of the
matrices are the t parameters.

Statistical Details for the Gaussian Process Platform

e “Models with Continuous Predictors”
* “Models with Categorical Predictors”
e “Variance Formula Parameterization”
e “Model Fit Details”

Models with Continuous Predictors

If the Gaussian Process model contains only continuous predictors, the Gaussian Process
platform implements two possible correlation structures, the Gaussian and the Cubic.

The Gaussian correlation structure uses the product exponential correlation function with a
power of 2 as the estimated model. This model assumes that Y is normally distributed with
mean p and covariance matrix o”R. The elements of the R matrix are defined as follows:

K

2

rij = exp[ > ek(xik*xjk) ]
k=1

where
K = # of continuous predictors

0y = theta parameter for the k™ predictor
X = the value of the k' predictor for subject i
xj,. = the value of the k™ predictor for subject j

The Cubic correlation structure also assumes that Y is normally distributed with mean p and
covariance matrix 6°R. The R matrix consists of the following elements:

T = Hp(déek)
k
where

d = xp =%
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Statistical Details for the Gaussian Process Platform

1-6(d0)2+6(]d|0)3, |d| < L

20
p(d:0) = | 2(1-|d|6)? L jg<d
’ ’ 20 -0

0. %< \d]

See Santer (2003). The theta parameter used in the Cubic correlation structure is the reciprocal
of the parameter often used in the literature. The reciprocal is used so that when theta has no
effect on the model, then rho has a value of zero, rather than infinity.

JMP

pio Models with Categorical Predictors

If the Gaussian Process model includes categorical predictors, the Gaussian correlation

structure is used for the correlation structure. The elements of the R matrix are defined as
follows:

P K

2

rl.]. = [ IT rpi]_]exp[— > ek(xik_xjk)J
p=1 k=1

where

K = # of continuous predictors

P = # of categorical predictors
0 = theta parameter for the k™ continuous predictor
x; = the value of the k™' continuous predictor for subject i

xj = the value of the k™ continuous predictor for subject j

Tpij = the correlation between the observed level of predictor p for subject i and the

observed level of predictor p for subject j

There is a T parameter for each combination of levels of a categorical variable, where t;;
corresponds to the unique combination formed by the observed levels of subject i and subject
j- Thus, the covariance element Tij depends on the combination of levels of the categorical
predictors obtained from the it and j ' observations. See Qian et al. (2012).
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Variance Formula Parameterization

The saved variance formula uses the previously defined parameterization of R, except when
the model includes categorical predictors. When the Gaussian Process model includes
categorical predictors, the saved variance formula uses the following parameterization of R:

K P
2
rij = P\~ X XX - X 0
k=1 p=1
where (I)Pij - _ln(TPij) and all other variables are as previously defined.

Model Fit Details

The model parameters are fit via maximum likelihood. The fitted parameters are provided in
the platform report. These are the parameters:

e pis the Gaussian Process mean,

e &2 is the Gaussian Process variance,

e Theta corresponds to the values of 6, in the definition of R.

* The off-diagonals of the categorical input correlation matrices correspond to the values of
Tpijin the definition of R.

Note: If your report contains the note Nugget parameters set to avoid singular variance
matrix, JMP has added a ridge parameter to the variance matrix so that it is invertible.
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The Time Series platform enables you to explore, analyze, and forecast univariate time series.
A time series is a set of observations taken over a series of equally spaced time periods.
Observations that are close together in time are typically correlated. Time series methodology
takes advantage of this dependence between observations to better predict what the series will
look like in the future.

Characteristics that are common in time series data include seasonality, trend, and
autocorrelation. The Time Series platform provides options to handle these characteristics.
Graphs such as variograms, autocorrelation plots, partial autocorrelation plots, and spectral
density plots can be used to identify the type of model appropriate for describing and
predicting (forecasting) the time series. There are also several decomposition methods in the
platform that enable you to remove seasonal or general trends in the data to simplify the
analysis. Alternatively, the platform can fit more sophisticated ARIMA models and State
Space Smoothing models that have the ability to incorporate seasonality and long term trends
all in one model. You can also perform a Box-Cox transformation and analyze and model the
transformed series.

There are several methods to assess the forecasting performance of models. The Forecast on
Holdback feature partitions the time series into a training portion to build models and a and
holdback portion to assess forecasting performance.

Figure 18.1 Forecast Plot
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Overview of the Time Series Platform

A time series is a set vy, iy, ... .y Of observations that are observed over a series of equally
spaced time periods. Some examples of time series data include quarterly sales reports,
monthly average temperatures, and counts of sunspots. The Time Series platform enables you
to explore patterns and trends found in these types of data. You can then use these patterns
and trends to forecast, or predict, into the future.

Characteristics that are common in time series data include seasonality, trend, and
autocorrelation. Seasonality refers to patterns that occur over a known period of time. For
example, data that are collected monthly might look similar in summer months across all
years of data collection. Trend refers to long term movements of a series, such as gradual
increases or decreases of values across time. Autocorrelation is the degree to which each point
in a series is correlated with earlier values in the series.

There are many different models and forecasting methods available in the Time Series
platform. However, not all methods can handle trend or seasonality. In order to choose an
appropriate model, it is essential to determine which characteristics are present in the series.
The Time Series platform provides graphs such as variograms, autocorrelation plots, partial
autocorrelation plots, and spectral density plots that can be used to identify the type of model
appropriate for describing and forecasting the evolution of the time series. There are also
several differencing and decomposition methods in the platform that enable you to remove
seasonal or general trends in the data to explore and simplify the analysis. You can also view
and apply a Box-Cox transformation to your data.

Alternatively, the platform can fit more sophisticated models that can incorporate seasonality
and long term trends. One such model in the platform that has this ability is Winter’s Additive
Method, which is an advanced exponential smoothing model. In addition, the platform can fit
AutoRegressive Integrated Moving Average (ARIMA) models and State Space Smoothing
models. Both of these types of models are the most statistically complex, but also provide the
most flexibility. Advanced exponential smoothing, ARIMA, and State Space Smoothing
models are harder to interpret, but they are excellent tools for forecasting.

The Time Series platform can also fit transfer function models when supplied with an input
series.
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Example of the Time Series Platform

This example uses the Raleigh Temps.jmp sample data table, which contains maximum
monthly temperatures measured in degrees Fahrenheit from 1980 to 1990. Use the Time Series
platform to examine the series and predict the maximum monthly temperatures for the next
two years.

1. Select Help > Sample Data Library and open Time Series/Raleigh Temps.jmp.

Select Analyze > Specialized Modeling > Time Series.

2
3
4.
5

Select Temperature and click Y, Time Series.
Select Month/Year and click X, Time ID.

In the box next to Forecast Periods, type 24.

This is the number of future periods that are forecast by the models fit to the data. You
want to predict the monthly temperature for the next two years, which is 24 months.

Click OK.

Figure 18.2 Time Series Analysis Report for Raleigh Temps.jmp
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Example of the Time Series Platform

The Time Series graph shows that the series is cyclic. This cyclic component is also
apparent in the autocorrelation chart. Points that are 1 lag apart are positively correlated,
with an AutoCorr value of 0.8007. As points become farther apart, they become negatively
correlated, then positively correlated again, and then the pattern repeats. The Time Series
graph and the autocorrelation chart provide evidence of seasonality in the time series.

Click the Time Series red triangle and select ARIMA.

Set p, the autoregressive order, to 1 because the series showed evidence of autocorrelation.
Click Estimate.

Click the Time Series red triangle and select Seasonal ARIMA.

In the ARIMA box, set p, the autoregressive order, to 1 because the series showed evidence
of autocorrelation.

In the Seasonal ARIMA box, set D, the seasonal differencing order, to 1 because the series
showed evidence of seasonality.

Click Estimate.
In the Model Comparison table, check the box under Graph for both models.

Figure 18.3 Model Comparison Table for Raleigh Temps.jmp
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The Model Comparison table is sorted by the AIC statistic, in decreasing order. This means
that the best fitting model appears at the top of the report. The AIC value for the seasonal
ARIMA model (693.4) is much smaller than the value for the regular ARIMA model
(924.5). The graph shows that while the ARIMA model predicts the observed points
relatively well, the residuals are larger than those from the Seasonal ARIMA model. Also,
the Seasonal ARIMA model has more realistic predictions for future observations with
narrower prediction intervals. These results make sense since the series showed evidence
of a seasonal component.
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Launch the Time Series Platform

Launch the Time Series platform by selecting Analyze > Specialized Modeling > Time Series.
The Time Series launch window for the Seriesg.jmp sample data table is shown in Figure 18.4.

Figure 18.4 The Time Series Launch Window
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Data must be sorted by time, evenly spaced.

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Time Series platform launch window contains the following options:

Y, Time Series Assigns one or more columns as time series variables. Displayed on the Y
axis.

Input List Assigns one or more columns as input series variables. Displayed in the Input
Time Series Panel and used in transfer function models. The input series variable must be
numeric, either as a time series or an indicator.

X, Time ID Assigns one variable for labeling the time axis (X axis). If no variable is specified
for Time ID, the row number is used instead.

Note: If you use an X, Time ID variable, you can specify the time frequency by using the
Time Frequency column property. You can choose Annual, Quarterly, Monthly, Weekly,
Daily, Hourly, By Minute, and By Second. This helps JMP determine the spacing of the
data when plotting the forecast values. If no frequency is specified, the data is treated as
equally spaced numeric data.

Caution: It is assumed that the observations of the variable assigned to X, Time ID are
equally spaced. However, the Time Series platform checks only whether the time stamps
are increasing. The platform does not check if the observations are equally spaced.
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By Assigns a column that creates a report consisting of separate analyses for each level of the
variable. If more than one By variable is assigned, a separate analysis is produced for each
possible combination of the levels of the By variables.

Note: If you use a By variable, you might have to change the number of autocorrelation
lags depending on how many observations there are for each level of the By variable. The
number of lags must be greater than one but less than the number of observations per
level.

Autocorrelation Lags Specifies the number of lags to use in computing the autocorrelations
and partial correlations. This is the maximum number of periods between points used in
the computation of these correlations. It must be greater than one but less than the number
of rows. The default number of lags is 25.

Tip: A commonly used rule for the maximum number of lags is n/4, where n is the number
of observations.

Forecast Periods Specifies the number of observations that are forecast using each model
fitted to the data. The default number of forecasts is 25.

— If you select the Forecast on Holdback option, the Forecast Periods value specifies the
number of observations at the end of the series that are not included in the model
fitting. These values are then forecast using the fitted model.

— If you do not select the Forecast on Holdback option, the Forecast Periods value
specifies the number of future observations that are forecast after the end of the series.

Forecast on Holdback Determines whether forecasts are made on future observations or on
the holdback observations. If the Forecast on Holdback option is selected, the forecasts are
made on the holdback set that is determined by the number specified in the Forecast
Periods option.

Use Box-Cox Transformation Transforms the original data using a Box-Cox transformation
with the lambda that is specified in the Lambda for Box-Cox option. When this option is
selected, all analyses in the Time Series report are performed on the transformed data.
However, all forecasts are transformed back and reported on the original scale.

Lambda for Box-Cox (Available only when Use Box-Cox Transformation is selected.)
Specifies the lambda parameter used for the Box-Cox transformation of the original
data.

Note: In order to preserve the order and spacing of a time series, the Time Series platform
treats excluded rows in the data table as missing values.
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The Time Series Analysis Report

The initial Time Series report displays the time series graph, summary statistics and tests for
the time series variable, and a basic diagnostics report. If a column is specified for Input List in
the launch window, the Transfer Function Analysis and Input Time Series Panel reports are
shown. Both the Transfer Function Analysis report and the Input Time Series Panel report
contain the same initial information as the Time Series report.

* “Time Series Graph”

* “Time Series Basic Diagnostics Chart”

Time Series Graph

The Time Series graph plots each times series by the time ID. If no time ID is specified, the row
number is used instead. If a holdback set is specified, there is a vertical reference line on the
graph that separates the training data from the holdback data.

The platform also performs several tests for stationarity using Augmented Dickey-Fuller (ADF)
tests. The following tests and summary statistics are displayed next to the time series graph:

Lambda for Box-Cox (Appears only if a Box-Cox Transformation is specified.) The value of
lambda used in the Box-Cox transformation.

Mean The sample mean.

SD The sample standard deviation.

N The series length.

Zero Mean ADF A test against a random walk with zero mean, which is defined as follows:
X = dxp_qtey

Single Mean ADF A test against a random walk with a non-zero mean, which is defined as
follows:

Xp—H = ¢(Xt717u)+€t

Trend ADF A test against a random walk with a non-zero mean and a linear trend, which is
defined as follows:

xt*H*Bf = ¢[xt,1fufl3(t*1)]+et
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Time Series Basic Diagnostics Chart

The information that is shown in the Time Series Basic Diagnostics chart depends on the Time
Series Report red triangle menu options. The red triangle menu options that show or hide
information from the diagnostics chart are Autocorrelation, Partial Autocorrelation,
Variogram, and AR Coefficients. By default, Autocorrelation and Partial Autocorrelation are
shown.

Autocorrelation Chart

The Autocorrelation option shows or hides the following columns in the Time Series Basic
Diagnostics chart:

Lag The number of periods between points.
Note: The number of lags begins with 0 as the default. To compute correlations beginning

with lag 1, modify the JMP preferences before generating the graph. Select File >
Preferences > Platforms > Time Series, and then select Suppress Lag 0 in ACF and PACF.

AutoCorr The autocorrelation for the kth lag, which is computed as follows:

N

‘k 1 - -

e = % where ¢ =5 ¥ - -Y)
t=k+1

and y is the mean of the N non-missing points in the time series. By definition, the first
autocorrelation (lag 0) always has length 1.

The bars graphically depict the autocorrelations. The blue curves represent twice the
large-lag standard error (+ 2 standard errors), which is computed as follows:

Ljung-Box Q Used to test whether a group of autocorrelations is significantly different from
zero, or to test that the residuals from a model can be distinguished from white noise.
Q is the test statistic.

p-Value The p-value from the Ljung-Box test.
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Partial Autocorrelation Chart

The Partial Autocorrelation option shows or hides the following columns in the Time Series
Basic Diagnostics chart:

Lag The number of periods between points.

Partial The partial autocorrelation for the kth lag.

The bars graphically depict the partial autocorrelations. The blue lines represent + 2
standard errors for approximate 95% prediction limits, where the standard error is
computed as follows:

1
SE, = — forallk

Variogram Chart

The Variogram option shows or hides the following columns in the Time Series Basic
Diagnostics chart:

Lag The number of periods between points.

Variogram The variogram measures the variance of the differences of points k lags apart and
compares it to that for points one lag apart. The variogram is computed from the
autocorrelations as follows:

voo ke
ko

where ry is the autocorrelation at lag k.

AR Coefficients Chart

The AR Coefficients option shows or hides the following columns in the Time Series Basic
Diagnostics chart:

Lag The number of periods between points.

AR Coef The coefficients approximate those that you would obtain from fitting a high-order,
purely autoregressive model.
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Time Series Platform Options

® “Time Series Diagnostics”

¢ “Differencing and Decomposition”

e “ARIMA and Seasonal ARIMA Models”
*  “Smoothing Models”

* “State Space Smoothing Models”

e “Transfer Function Models”

*  “Smoothing Model Specification Windows”

Time Series Diagnostics

Graph Shows a submenu of options to control the time series plot appearance.
Time Series Graph Shows or hides the time series graph.
Show Points Shows or hides the points in the time series graph.

Connecting Lines Shows or hides the lines connecting the points in the time series
graph.

Mean Line Shows or hides a horizontal line in the time series graph that depicts the
mean of the time series.

Autocorrelation Shows or hides the Autocorrelation plot in the Time Series Basic
Diagnostics Chart. The autocorrelation graph describes the correlation between all pairs of
points in the time series for a given separation in time (lag). See “Autocorrelation Chart”.

Tip: The autocorrelation graph of the sample is often called the sample autocorrelation
function.

Partial Autocorrelation Shows or hides the Partial Autocorrelation plot in the Time Series
Basic Diagnostics Chart. The partial autocorrelation graph describes the partial correlation
between all the pairs of points in the time series for a given separation in time (lag). See
“Partial Autocorrelation Chart”.

Tip: The Autocorrelation and Partial Autocorrelation graphs can help you determine
whether the time series is stationary (meaning it has a fixed mean and standard deviation
over time) and what model might be appropriate to fit the time series.

Variogram Shows or hides the graph of the variogram in the Time Series Basic Diagnostics
Chart. See “Variogram Chart”.
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AR Coefficients Shows or hides the graph of the least squares estimates of the

autoregressive (AR) coefficients in the Time Series Basic Diagnostics Chart. See “AR
Coefficients Chart”.

Spectral Density Shows or hides graphs of the spectral density as a function of period and

frequency. The spectral density option also displays the White Noise test report, which
gives results from two tests on the data. See “Spectral Density Report” and “Statistical
Details for Spectral Density”.

Differencing and Decomposition

Difference Shows the Differencing Specification window (Figure 18.5). The window enables

you to specify the differencing operation that you want to apply to the time series.
Differencing the values in a time series can transform a nonstationary series into a
stationary series. The differenced series is given by the following equation:

D
w, = (1- B)'(1-B%) v,
where ¢ is the time index and B is the backshift operator defined by By, =y, ;.

Note: Many time series do not exhibit a fixed mean, such as time series with trend or
seasonality. Such nonstationary series are not suitable for description by time series
models that assume a stationary time series such as ARMA models. Removing the trend
and/or seasonality creates a differenced series that is stationary and enables you to
describe the series using the models that assume stationarity.

Figure 18.5 Differencing Specification Window

Specify Differencing

MNonseasonal Seasonal

Differencing Order g » | Differencing Crder 0 - |
Observations Per Period

[Estimate” Cancel H Help |

The Differencing Specification window enables you to specify the Nonseasonal
Differencing Order, d, the Seasonal Differencing Order, D, and the number of
Observations per Period, s. Selecting zero for the value of the differencing order is
equivalent to no differencing of that kind. Each time you specify a differencing operation
and click Estimate, a new Difference Report is displayed in the report window. See
“Additional Examples of the Time Series Platform”.

Decomposition (Not available when either Forecast on Holdback or Use Box-Cox

Transformation are selected in the launch window.) Shows a submenu of decomposition
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methods. Decomposition of time series data isolates and removes linear trends and
seasonal cycles from a time series. This can help with better model estimation. Three
Decomposition options are provided.

Remove Linear Trend Estimates the linear trend of the time series using a linear
regression model and removes the linear trend from the data. A Time Series report for
the detrended series is added to the report window, along with the linear trend
information. See “The Time Series Analysis Report” and “Linear Trend Report”.

Remove Cycle Estimates the cyclic component of a time series using a single cosine wave
and then removes the cyclic component from the data. When you select the Remove
Cycle option, the Define Cycle dialog appears. This dialog window enables you to
specify the number of units per cycle and indicate whether a constant should be
subtracted from the data. A Time Series report for the decycled series is added to the
report window, along with the cycle information. See “The Time Series Analysis
Report” and “Cycle Report”.

X11 Removes trend and seasonal effects using the X-11 method developed by the US
Bureau of the Census (Shiskin et. al. 1967). For more information about the X-11
method, see “Statistical Details for X-11 Decomposition”. When selected, the Select
Decomposition Type dialog appears. This dialog window enables you to specify a
multiplicative or additive X-11 adjustment. Once you click OK, an X11 report is added
to the report window. See “X11 Report”.

The X11 option is available only for monthly or quarterly data. The X, Time ID column
must contain numeric values equally spaced by month or quarter without any gaps or
missing values. JMP returns an error if you request X11 for a time column that does not
satisfy these requirements. For an example of an appropriate time column for an X11
analysis, see “Create Appropriate Time ID Column”.

Note: When you select the Remove Linear Trend or the Remove Cycle options, JMP adds
a column to the data table that contains the detrended or decycled data. If this column is
already present in the data table when you select the option, JMP overwrites the existing
column.

Tip: Typically, you would begin decomposition by removing any linear trend, and then
removing long cycles, such as a 12-month cycle. Then you could start removing short
cycles, such as 6-month cycles.

Show Lag Plot Shows or hides a plot with observations at time f on the Y axis and
observations at time t +/- p on the X axis. The +/- p is known as the lag. This plot is useful in
determining how an observation at time ¢ is related to another observation at time ¢ +/- p. If
there is not an identifiable structure to the plot, the observations are not related. However,
if there is a structure to the plot, this indicates that there is some relationship between
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observations across time. Identifying the structure helps when building a time series
model.

Show Box-Cox Transformation Plot (Not available if you specified Use Box-Cox
Transformation in the launch window.) Shows or hides the Box-Cox Transformation plot.
The Box-Cox transformation is a power transformation based on the Lambda parameter
() and uses the following formula:

g1
Y, = T ifA=0
In(y) if & = 0

The Box-Cox Transformation Plot shows a graph of the transformed time series and
options for setting the Lambda parameter (1). The Lambda box shows the current value of
the parameter. You can also use the Lambda slider to change the value of the parameter,
which then automatically updates the plot. The Low and High boxes set the range of the
slider.

Tip: Use the Box-Cox Transformation plot to see the transformed time series for different
values of Lambda. Once you decide on a value, relaunch the analysis and select Use
Box-Cox Transformation and enter the desired Lambda next to Lambda for Box-Cox. This
runs the Time Series platform on the transformed series.

Cross Correlation (Available only in the Transfer Function Analysis red triangle menu.)
Shows or hides a cross-correlation plot to the report. The length of the plot is twice that of
an autocorrelation plot, or 2 x ACF length + 1. The plot includes plots of the output series
versus all input series, in both numerical and graphical forms. The blue lines indicate two
standard errors.

Note: For the cross correlation plot, the standard errors are calculated under the null
hypothesis as 1/sqrt(# - k), where n is the number of nonmissing data values and k is the
number of autocorrelation lags.

Prewhitening (Available only in the Input Series red triangle menu.) Shows the
Prewhitening Specification window that enables you to set the prewhitening order.
Prewhitening is a technique used to help identify the transfer function model. This
technique involves fitting an ARIMA model to the input series such that the residuals are
equivalent to white noise. The same model is then used to estimate the output series. You
can use the cross correlation between the filtered input and filtered output series to
determine an appropriate lag for the transfer function model. For information about
prewhitening, see Box et al. (1994).
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ARIMA and Seasonal ARIMA Models

ARIMA Shows the ARIMA Specification window, which enables you to specify the ARIMA
model that you want to fit. An ARIMA model predicts future values of a time series by a
linear combination of its past values and a series of errors (also known as random shocks or
innovations). The ARIMA model performs a maximum likelihood fit of the specified
ARIMA model to the time series. See “ARIMA Model”.

Note: An ARIMA model is commonly denoted ARIMA(p,d,q). If any of p, d, or q are zero,
the corresponding letters are often dropped. For example, if p and d are zero, then the
model would simply be a moving average model, denoted as MA(g).

Figure 18.6 ARIMA Specification Window

Specify ARIMA Model
ARIMA

p. Autoregressive Crder | 0
d, Differencing Crder 0
q. Moving Average Crder | 0

Prediction Interval @|

| Intercept
| Constrain fit

[Estimate” Cancel H Help |

p, Autoregressive Order The order p of the polynomial ¢(B) operator.
d, Differencing Order The order 4 of the differencing operator.
g, Moving Average Order The order g of the differencing operator 6(B).

Prediction Interval Enables you to set the prediction level between 0 and 1 for the
forecast prediction intervals.

Intercept Determines whether the intercept term p is a part of the model.

Constrain fit If checked, the fitting procedure constrains the autoregressive parameters
to always remain within the stable region and the moving average parameters within
the invertible region.

Tip: Deselect the Constrain fit option if the fitter is having difficulty finding the true
optimum or if you want to speed up the fit. You can use the Model Summary table to see
whether the resulting fitted model is stable and invertible.

Once you specify the model and click Estimate, a Model Report is added to the report
window. See “Reports”.
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Seasonal ARIMA Shows the Seasonal ARIMA Specification window, which enables you to
specify the Seasonal ARIMA model that you want to fit. This window has the same
elements as the ARIMA specification window, but it also contains the seasonal element
specifications. The additional Observations per Period option enables you to specify the
number of observations per period, denoted as s. For more information about the Seasonal
ARIMA model, see “Seasonal ARIMA Model”.

Note: Seasonal ARIMA models are denoted as Seasonal ARIMA(p,d,q)(P,D,Q)s.

Once you specify the model and click Estimate, a Model Report is added to the report
window. See “Reports”.

Smoothing Models

Shows a submenu of smoothing models. Once you select a smoothing model, a specification
window appears. See “Smoothing Model Windows”. For each model that is specified, a
Smoothing Model Report appears in the report window. See “ARIMA and Seasonal ARIMA
Model Report”. Smoothing models represent the evolution of a time series by the model:

Yy = Byt Byt ts(t) tay,
where

L is the time-varying mean term
B;is the time-varying slope term
s(t) is one of the s time-varying seasonal terms

a; are the random shocks

For more information about the general smoothing model equation, see “Statistical Details for
Exponential Smoothing Models”. The following smoothing models are available:

Simple Moving Average (Not available when either Forecast on Holdback or Use Box-Cox
Transformation are selected in the launch window.) A model that estimates values by
using an average of several adjacent points, defined by the smoothing window. The
Simple Smoothing Average Specification window enables you to specify aspects of the
smoothing window. Once the smoothing window options are specified, a Simple Moving
Average report is shown. By default, this report produces plotted values that are equal to
the average of consecutive observations in a time window. Multiple Simple Moving
Average models can be added and shown on the same plot. See “Simple Smoothing
Average Specification Window”.

Simple Exponential Smoothing A model with a level component. See “Simple Exponential
Smoothing”.
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Double Exponential Smoothing A model with a level component and a trend component.
This is a special case of Linear Exponential Smoothing. See “Double (Brown) Exponential
Smoothing”.

Linear Exponential Smoothing A model with a level component and a trend component.
See “Linear (Holt) Exponential Smoothing”.

Damped-Trend Linear Exponential Smoothing A model with a level component and a
damped trend component. This model is appropriate for a series that exhibits a trend more
complicated than a linear trend. See “Damped-Trend Linear Exponential Smoothing”.

Seasonal Exponential Smoothing A model with a level component and a seasonal
component. See “Seasonal Exponential Smoothing”.

Winters Method A model with a level component, a trend component, and a seasonal
component. See “Winters Method (Additive)”.

Note: Each smoothing model, except for the Simple Moving Average model, is a traditional
exponential smoothing model and has an ARIMA model equivalent. You might not be able to
specify the equivalent ARIMA model using the ARIMA option because some smoothing
models intrinsically constrain the ARIMA model parameters in ways that the ARIMA option
does not allow.

State Space Smoothing Models

Shows the Specify State Space Smoothing Models window, which enables you to fit a variety
of state space smoothing models as defined by Hyndman et al. (2008). A state space
smoothing model is defined based on its error, trend component, and seasonal component.

® The errors can be additive (A) or multiplicative (M).

® The trend component can be none (N), additive (A), additive damped (Ag), multiplicative
(M), or multiplicative damped (My).

* The seasonal component can be none (N), additive (A), or multiplicative (M).

A specific model can be represented by its ETS (Error, Trend, Seasonal). Use the check boxes in
the Specify State Space Smoothing Models window to select the error, trend, and seasonality
for the desired models. Click Select Recommended to select the check boxes that correspond
to the models recommended by the platform. The window opens with the recommended
models selected. Click Select All to select all check boxes or Deselect All to deselect all check
boxes. The window also contains the following options:

Period Specifies seasonality values to be considered in the model fitting process.

Constrain Parameters Constrains the parameters in such a way that the further an
observation is from the present, the less effect it has on the present state of the model. In
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State Space Smoothing models, a forecast at time £, given all previous observations, is the
same as the weighted sum of all observations up to time ¢. The weights are a function of
the parameters. Therefore, constraining the parameters ensures that the weights for past
observations go to zero and that the further an observation is from the present, the faster
the weight goes to zero.

When you click OK, the specified set of models is fit. Summary values for each state space
smoothing model are added to the Model Comparison table. Individual fit reports are added
to the report window.

Transfer Function Models

Transfer Function (Available only in the Transfer Function Analysis red triangle menu.)
Shows the Transfer Function Model Specification window. Building a transfer function
model is similar to building an ARIMA model; it is an iterative process of exploring,
fitting, and comparing models. Before building a model and during the data exploration
process, it is sometimes useful to prewhiten the data. See “Prewhitening”. For more
information about transfer functions, see “Statistical Details for Transfer Functions”.

Note: Currently, the Transfer Function option has limited support of missing values.
Because the Time Series platform also treats excluded rows as missing values, transfer
function models cannot be fit on a data table with excluded rows.

Figure 18.7 Transfer Function Model Specification Window

Specify Transfer Function Model

MNoise Series Orders Choose Inputs Inputs Series Orders
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g, Moving AverageQrder | 0 rl, Order of Denominator Operator 2

P, Autoregressive Crder 0 s2, Order of Seasonal Mumerator Operator 0

[, Differencing Crder 0 d2, Order of Seasonal Differencing Operator | 0

Q. Moving Average Order | 0 r2, Order of Seasonal Denominater Operator | 0

S, Observations Per Period |12 5, Observations Per Period 12

L, Input Lag 3
| Intercept
Alternative Parameterization
| Constrain fit
Forecast Periods
Prediction Interval @|
[ Estimate | [ Cancel | [ Help |

The Transfer Function Model Specification window contains the following sections:

Noise Series Orders Contains specifications for the noise series. Lowercase letters are
coefficients for non-seasonal polynomials, and uppercase letters are coefficients for
seasonal polynomials.
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Choose Inputs Enables you select the input series for the model.

Input Series Orders Contains specifications for the input series. The first three orders
relate to non-seasonal polynomials. The next four orders relate to seasonal
polynomials. The final option is for an input lag.

There are three additional options that control model fitting:

Intercept Specifies whether the model has an intercept. If unchecked, it is assumed that p
is zero.

Alternative Parameterization Specifies whether the general regression coefficient is
factored out of the numerator polynomials.

Constrain Fit Toggles the constraining of the AR and MA coefficients.

Forecast Periods Specifies the number of forecasting periods that are used for
forecasting. If there are rows at the end of the data table that contain missing values for
the Y variable and nonmissing values for the input variables, these rows are used in the
initial forecasting settings. The values for the input variables are treated as future
values of the input variables.

Prediction Interval Specifies the confidence level for the prediction interval.

ARIMA Model Group Shows the ARIMA Model Group window, which enables you to fit a
range of ARIMA or Seasonal ARIMA models by specifying the range of orders. As you
enter ranges into the window, the Total Number of Models updates accordingly.

Figure 18.8 ARIMA Model Group Specification Window

Specify ARIMA Model
ARIMA Seasonal ARIMA
p. Autoregressive Order | 0| 0 P, Autoregressive Crder oo
d, Differencing Crder oo [, Differencing Crder oo
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Prediction Interval g g5 v|
| Intercept
| Constrain fit
Total Number of Models 0
[ Estimate H Cancel H Help |

Once you specify the models and click Estimate, a Model Report for each specified model
is added to the report window. See “Reports”.

Combine and Save Forecasts from Models Creates a new data table with the combined
results from all model fits in the report.
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Save Spectral Density Creates a new data table containing the spectral density and
periodogram where the (i+1)th row corresponds to the frequency f;=7/ N (that is, the ith
harmonic of 1 / N). The new data table has the following columns:

Period The period of the ith harmonic, 1/ f;

Frequency The frequency of the harmonic, f;.

Angular Frequency The angular frequency of the harmonic, 2xf;

Sine The Fourier sine coefficients, a;.

Cosine The Fourier cosine coefficients, b;.

Periodogram The periodogram, I(f;).

Spectral Density The spectral density, a smoothed version of the periodogram.

Number of Forecast Periods Shows a window that enables you to set the number of future
periods that are forecast for the fitted models. The initial value is set in the Time Series
launch window. All existing and future forecast results will use the new number of
periods once it is changed.

Maximum Iterations Shows a window that enables you to reset the maximum number of
iterations for future optimizations used in fitting ARIMA models.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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Smoothing Model Specification Windows

Simple Smoothing Average Specification Window

The Simple Smoothing Average Specification window appears when you select Simple
Moving Average as the smoothing model. Let w be the smoothing window width in a simple
moving average (SMA) model. Let fi=(y .14V o+ - (w-2)Yi-(u-1))/w be the average of w
consecutive observations for some time point f.

Figure 18.9 Simple Smoothing Average Specification Window
Enter smoothing window width,

@ Mo Centering
Centered
Centered and Double Smoothed for Even Mumber of Terms

. Cancel |

Enter smoothing window width The smoothing window width, w, that defines the number
of consecutive points to average. The larger the window width, the more the series is
smoothed.

No Centering The smoothing window is constructed from the points leading up to and
including the time point, ¢, the point at which the series is being estimated. In other words,
fis the plotted value for time t.

Centered The smoothing window is centered around the time point at which the series is
being estimated.
— For odd w, f; is the plotted value for time f-(w-1)/2.
— For even w, f; is the plotted value for time t-(w-1)/2. When saved to a data table, f; is at
t-(w-2)/2.

Centered and Double Smoothed for Even Number of Terms For even w, the smoothing
window cannot be centered around the time point at which the series is being estimated.
This option creates two smoothing windows that are almost centered, and averages them
together. The smoothing estimates are calculated as follows:

w-—1

Vet2 2 VeoitVy g
¢ i=1

2w

T
SE
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Smoothing Model Windows

The Smoothing Model specification windows appear when you select one of the smoothing
model options other than Simple Moving Average. The title of the window and the available
options depend on the smoothing model option that you select.

Figure 18.10 Smoothing Model Specification Window

Prediction Interval 045 - |
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[Estimate” Cancel H Help |

Prediction Interval Enables you to set the prediction level for the forecast prediction
intervals.

Observations per Period (Available only for seasonal smoothing models.) Enables you to set
the number of observations per period in a seasonal smoothing model.

Constraints Enables you to specify what type of constraint you want to enforce on the
smoothing weights during the fit. The following constraint options are available:

Zero To One Constrains the values of the smoothing weights to the range zero to one.
Unconstrained Allows the parameters to range freely.

Stable Invertible Constrains the parameters such that the equivalent ARIMA model is
stable and invertible.

Custom Expands the dialog to enable you to set constraints on individual smoothing
weights. Each smoothing weight can be Bounded, Fixed, or Unconstrained as
determined by the setting of the popup menu next to the weight’s name. When
entering values for fixed or bounded weights, the values can be positive or negative
real numbers.
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Figure 18.11 Custom Smoothing Weights
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The example shown in Figure 18.11 has the Level weight (a) fixed at a value of 0.3 and
the Trend weight (y) bounded by 0.1 and 0.8. In this case, the value of the Trend weight
is allowed to move within the range 0.1 to 0.8 while the Level weight is held constant at
0.3. Note that you can specify all the smoothing weights in advance by using these
custom constraints. In that case, none of the weights would be estimated from the data
although forecasts and residuals would still be computed.

Reports

¢ “Difference Report”

* “Decomposition Reports”

e “Model Comparison Report”

e “ARIMA and Seasonal ARIMA Model Report”
* “State Space Smoothing Report”

e “Transfer Function Report”

* “Spectral Density Report”

Difference Report

The Difference Report contains graphs of the autocorrelations and partial autocorrelations of
the differenced series. These graphs can be used to determine whether the differenced series is
stationary.

The ARIMA and Seasonal ARIMA models that are available in the Time Series platform
accommodate a differencing operation. In a two step process, these models first difference the
time series according to the differencing operation, and then fit the differenced series. The
Difference option is a useful preprocessing tool for determining the order of differencing to
specify for the ARIMA model.
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The Difference red triangle menu contains the following options:

Graph Shows a submenu of options to control the appearance of the differenced series plot.
See “Time Series Platform Options”.

Autocorrelation Shows or hides the autocorrelation of the differenced series.
Partial Autocorrelation Shows or hides the partial autocorrelations of the differenced series.
Variogram Shows or hides the variogram of the differenced series.

Save Saves a new column that contains the values in the differenced series to the original
data table. Some of the leading elements are lost in the differencing process. They are
represented as missing values in the saved Difference column.

Remove Fit Removes the Difference report from the report window.

Decomposition Reports

This section provides details about the reports obtained from the three decomposition
options:

e “Linear Trend Report”
e “Cycle Report”
e “X11 Report”

Linear Trend Report
Contains the values of By and B, from the linear regression model that is fit to the data:
Trend, = Byt Bytime
The detrended series is equal to D, = O, - Trend;, where O, is the original time series.

Cycle Report

Contains the values of the cyclical component that is fit to the data:

Cycle, = C+A- COS(Z T ((é) : t+P))

The parameter values are defined as follows:
e (s the (optional) Constant
* Ais the Amplitude of the cosine wave

¢ U is the number of Units per Cycle
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e Pis the Phase of the cosine wave

* tis one less than the row number of a given observation

The decycled series is equal to D; = O, - Cycle;, where O is the original time series.

X11 Report

Depending on your selection of Decomposition Type, the X11 option adds an X11 -
Multiplicative report or an X11 - Additive report. The reports contain the same four plots:

Original and Adjusted Overlays the X11-adjusted time series on the original time series, O,.
The X11-adjusted values are O,/S; for the multiplicative adjustment and O; - S, for the
additive adjustment.

D10 - Final Seasonal Factors Plots the seasonal factor components, S;, over time.
D12 - Final Trend Cycle Plots the trend cycle components, C;, over time.

D13 - Final Irregular Series Plots the irregular components, I, over time.

X11 Report Options
The X11 reports have the following red triangle options:

Show Tables Shows or hides the X11 summary tables, as described in Shiskin et. al. (1967).
The tables are grouped into five categories (labeled B through F), described in Table 18.1.

Save Columns Saves four columns to the data table: the seasonally adjusted time series, the
seasonal components (S;), the trend cycle components (C;), and the irregular series
components (Iy).

Save All Columns Saves columns to the data table for all of the tables produced in the report
by the Show Tables option.

Remove Fit Removes the X11 report from the report window.

Table 18.1 Descriptions of the Categories of X11 Output Tables

Letter Prefix Category Description

B preliminary estimates of seasonal, trend cycle, and irregular
components

C intermediate estimates of seasonal, trend cycle, and irregular
components

D final estimates of seasonal, trend cycle, and irregular components
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Table 18.1 Descriptions of the Categories of X11 Output Tables (Continued)

Letter Prefix Category Description
E analytical tables
F summary measures

For more information about the contents of the X11 output tables, see Shisken et. al. (1967) or
SAS/ETS 15.2 User’s Guide (search for “The output from PROC X11”).

Model Comparison Report

Once a model is fit, the Model Comparison Report is displayed in the report window. This
report contains the Model Comparison table and plots for the models. Each time a new model
is fit, a new row is added to the Model Comparison table, with a unique color-coding. The
Model Comparison table summarizes the fit statistics for each model and is used to compare
several models fitted to the same time series. By default, the models are sorted by the AIC
statistic, in increasing order. To sort the model by a different statistic, right-click any column in
the Model Comparison Table and select Sort by Column. Alternatively, you can also click on
the column header to sort. For definitions of the fit statistics, see “Model Summary Table”. The
only fit statistic that is unique to the Model Comparison Table is Weights. This fit statistic is
the normalized AIC Weight. The AIC Weight for a model is calculated as follows:

K
AICWeight = exp[-0.5(AIC - BestAIC)]/ Z (exp[—O.S(AICk —BestAIC)])
k=1

K is the total number of models, AIC; is the AIC value for model k, and BestAIC is the AIC
value for the model with the minimum AIC value.

If you specify a holdback set, the fit statistics that are computed on the training data are not
shown in the Model Comparison table. Instead, the following metrics to determine the
forecasting performance of the individual models on the holdback set are computed: Root
Mean Square Error (RMSE), Mean Square Error (MSE), Mean Absolute Percentage Error
(MAPE), and Mean Absolute Error (MAE). By default, the models are sorted by the RMSE
statistic, in increasing order. To sort the model by a different statistic, right-click any column in
the Model Comparison Table and select Sort by Column. Alternatively, you can also click on
the column header to sort. For definitions of the fit statistics, see “Model Summary Table”.
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Caution: If you do not specify a holdback set and fit a combination of state space smoothing
models and ARIMA models, a caution message is shown at the top of the Model Comparison
table. In this case, the state space smoothing models are not comparable to the ARIMA models
because likelihood values and likelihood-based information criteria, such as the AIC statistic,
are not comparable between the two different model classes. However, if you specify a
holdback set, the models can be compared because the RMSE statistic is used.

Figure 18.12 Model Comparison Table

Model Comparison

Report Graph Model DF  Variance AIC SBC RSquare -2loglH Weights 2.4 6.8 MAPE MAE
[+ o ~ Seasonal ARIMA(0, 1, 1)(0,1,1)12 128 138.49122 1020.9047 1029.5302 0.990 1014.9047  1.000000 3.197010  8.990978
il L} — ARIMA(L, 1,1) 140 9789437 1394.1215 1403.0101 0.932 13881215 00000000 | | | | 8.687058 24.364166
-[¥l ] — ARMAI(L, 1) 141 989.13835 1407.7483 1416.6577 0919 1401.7483 00000000 | | | ! 9.704486 25.348507
=[¥] | — AR[1) 142 1134.3871 1426.17%4 1432.1190 0.909 14221794  0.000000 @ : | : 0.873726 26.556219
=¥ ] = MA(1) 142 42646121 1616.8626 1622.8022 0.603 1612.8626 0000000 | | | | | 23.865796 53.716974

You can select which full model reports are shown in the report window using the Report
check box. Two model plots appear to the right of the Model Comparison table. The top plot is
a time series plot of the data, forecasts, and prediction limits. Below that are plots of the
autocorrelation and partial autocorrelation functions. You can select which models are
displayed on the model plots using the Graph check box.

Figure 18.13 Model Plots
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Model Comparison Report Options
Each model in the Model Comparison report has the following red triangle menu options:

Fit New Opens a specification window for the model. You can change the settings to fit a
different model.
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Simulate Once (Not available if a holdback set is specified.) Provides one simulation of the
model to the upper end of the time axis. The simulation is shown on the Model
Comparison time series plot.

Simulate More (Not available if a holdback set is specified.) Provides the specified number
of simulations of the model to the upper end of the time axis. The simulations are shown
on the Model Comparison time series plot.

Remove Model Simulation (Not available if a holdback set is specified.) Removes the
simulations for the model.

Remove All Simulation (Not available if a holdback set is specified.) Removes the
simulations for all models.

Generate Simulation (Not available if a holdback set is specified.) Generates simulations for
the model, and stores the results in a data table. You can specify the random seed, number
of simulations, and the number of forecast periods.

Set Seed (Not available if a holdback set is specified.) Specifies the seed for generating the
simulated trajectories.

Remove Fit Removes the corresponding model from the report window.

Remove All Models Removes all models that are listed in the Model Comparison table from
the report window.

Remove Unselected Removes all models that do not have the Report check box selected
from the report window.

Remove Selected Removes all models that have the Report check box selected from the
report window.

Hide All Reports Hides all of the models that are listed in the Model Comparison table from
the report window. This is equivalent to deselecting all of the Report check boxes.

Hide All Graphs Hides all of the models that are listed in the Model Comparison table from
the Model Plots. This is equivalent to deselecting all of the Graph check boxes.

Note: The Time Series platform treats excluded rows as missing values. If the last several
observations in the data table are excluded or missing, the simulation options in the Model
Comparison Report will not work properly. The simulation procedure uses the last several
observations of the time series. If the last several observations are missing, the simulation
produces all missing values into the future.
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ARIMA and Seasonal ARIMA Model Report

The time series modeling options are used to fit theoretical models to the series and use the
fitted model to predict (forecast) future values of the series. These options also produce
statistics and residuals that enable you to determine the adequacy of the model that you have
chosen to use. You can select the modeling options multiple times. Each time you select a
model, that model is added to the Model Comparison table. When the Report check box next
to a model in the Model Comparison table is selected, a report is produced for that model. The
report specifies the model in its title.

The following reports are shown by default:

¢ Model Summary Table

e Parameter Estimates Table
e Forecast Plot

e Residuals

e [teration History

Model Summary Table Contains fit statistics for the model. In the formulas below, 7 is the
length of the series and k is the number of fitted parameters in the model.

DF The number of degrees of freedom in the fit, n — k.
Sum of Squared Innovations The sum of the squared innovations.
Sum of Squared Residuals The sum of the squared residuals.

Variance Estimate The sum of squared innovations divided by the number of degrees of
freedom (n — k). This is the sample estimate of the variance of the random shocks a;,
described in the section “ARIMA Model”.

Standard Deviation The square root of the variance estimate. This is a sample estimate of
the standard deviation of the random shocks a;.

Akaike’s ‘A’ Information Criterion The AIC value, computed as —2loglikelihood + 2k.
Smaller AIC values indicate better fit.

Schwarz’s Bayesian Criterion The SBC value, computed as —2loglikelihood + k*In(n).
Smaller SBC values indicate better fit. Schwarz’s Bayesian Criterion is equivalent to the
Bayesian Information Criterion (BIC).

RSquare The R-Square value, computed as follows:

2 _ ., SSE
R ’1_SST

where
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n
-2
SST = > (y;-vy)
i=1

n
A2
SSE = 3% (y;-y))
i=1

Y; are the one-step-ahead forecasts

y is the mean

If the model does not fit the series well, the model error sum of squares, SSE, might be
larger than the total sum of squares, SST. As a result, R? can be negative.

RSquare Adj The adjusted R? value, computed as follows:

[0 -F)

MAPE The Mean Absolute Percentage Error value, computed as follows:

n
100
)

i=1

yi‘ﬁi

Yi

MAE The Mean Absolute Error value, computed as follows:

n
1 .
=2 iy
i=1
-2LogLikelihood Twice the negative log-likelihood function evaluated at the best-fit
parameter estimates. Smaller values are better fits. See Fitting Linear Models.

Stable Indicates whether the autoregressive operator is stable. That is, whether all the
roots of ¢(z) = 0 lie outside the unit circle.

Invertible Indicates whether the moving average operator is invertible. That is, whether
all the roots of 6(z) = 0 lie outside the unit circle.

Note: The ¢ and 6 operators are defined in the section “ARIMA Model”.

Parameter Estimates Table Shows the estimates for the time series model parameters. Each
type of model has its own set of parameters, which are described in the sections on specific
time series models. Each Parameter Estimates table contains the following columns:
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Term The name of the parameter, which are described in the sections for each model
type. Some models contain an intercept or mean term. In those models, the related
constant estimate is also shown. The definition of the constant estimate is given under
the description of ARIMA models.

Factor (Shown only for multiplicative Seasonal ARIMA models.) The factor of the model
that contains the parameter. In the multiplicative seasonal models, Factor 1 is
nonseasonal and Factor 2 is seasonal.

Lag (Shown only for ARIMA and Seasonal ARIMA models.) The degree of the lag or
backshift operator that is applied to the term to which the parameter is multiplied.

Estimate The parameter estimates of the time series model.

Std Error The estimates of the standard errors of the parameter estimates. These
estimates are used to calculate tests and prediction intervals.

tRatio The test statistics for the hypotheses that each parameter is zero. The test statistic
for a parameter is the ratio of the parameter estimate to its standard error. If the
hypothesis is true, then this statistic has an approximate Student’s ¢ distribution.
Looking for a t-ratio greater than 2 in absolute value is a common rule for judging
significance because it approximates the 0.05 significance level.

Prob>|t| The observed p-value calculated for each parameter. The p-value is the
probability of getting a t-ratio greater (in absolute value) than the computed value,
given a true hypothesis.

Constant Estimate (Shown only for models that contain an intercept or mean term.) The
definition of the constant estimate is given under ARIMA model.

Mu (Shown only for ARIMA and Seasonal ARIMA models.) The estimate for the
intercept value of an ARIMA or seasonal ARIMA model.

Forecast A plot that shows both the observed and predicted values for the time series. The
plot is divided by a vertical line into two regions.

If you specified a holdback set, a vertical line separates the training data from the holdback
data. To the left of the vertical line, the one-step-ahead forecasts are overlaid with the
training data points. To the right of the vertical line, the values forecast by the model are
overlaid with the holdback data points. The prediction intervals for the forecast are also
shown. You can control the number of forecast values using the Forecast Periods option in
the platform launch window.

If you did not specify a holdback set, the vertical line separates the observed data from the
future forecasts. To the left of the vertical line, the one-step-ahead forecasts are overlaid
with the observed data points. To the right of the vertical line, the future values forecast by
the model and the prediction intervals for the forecast are shown. You can control the
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number of future forecast values using the Forecast Periods option in the platform launch
window or by selecting Number of Forecast Periods from the Time Series red triangle
menu.

Residuals A graph that shows the values of the residuals based on the fitted model. These
values are the observed values of the time series minus the one-step-ahead predicted
values. The autocorrelation and partial autocorrelation reports for these residuals are also
shown. These reports can be used to determine whether the fitted model is adequate to
describe the data. If the fitted model is adequate, the points in the residual plot should be
normally distributed about zero and the autocorrelation and partial autocorrelation of the
residuals should not have any significant components for lags greater than zero.

Forecasting Errors on Holdback Series (Available only if a holdback set is specified.) A plot
of the forecasting errors on the observations in the holdback set. The autocorrelation and
partial autocorrelation reports for these errors are also shown.

Iteration History Contains the value of the objective function at each iteration. This can be
useful for diagnosing problems with the fitting procedure. Attempting to fit a model that
is poorly suited to the data can result in a failure to converge on an optimum value for the
likelihood. The Iteration History table contains the following quantities:

lter The iteration number.
Iteration History The objective function value for each step.
Step The type of iteration step.

Obj-Criterion The norm of the gradient of the objective function.

ARIMA and Seasonal ARIMA Model Report Options

Each ARIMA and Seasonal ARIMA model report has a red triangle menu that contains the
following options:

Show Points Shows or hides the data points in the forecast graph.
Show Prediction Interval Shows or hides the prediction intervals in the forecast graph.

Save Columns Creates a new data table that contains columns that represent the results of
the model.

Save Prediction Formula (Not available if a holdback set is specified.) Saves the data and
prediction formula to a new data table.

Create SAS Job Creates SAS code that duplicates the model analysis in SAS.

Submit to SAS Submits SAS code to SAS that duplicates the model analysis. If you are not
connected to a SAS server, this option guides you through the connection process.
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Residual Statistics Controls the displays of residual statistics are shown for the model.
These displays are described in the section “Time Series Platform Options”. However, they
are applied to the series of residuals.

Remove Fit Removes the individual model fit from the report.

State Space Smoothing Report

Each State Space Smoothing model is added to the Model Comparison table. If the Report
check box for a state space smoothing model in the Model Comparison table is selected, a
State Space Smoothing report appears. Each State Space Smoothing report has a unique
outline name that identifies the model. The following reports are included:

Model Type Describes the best fitting model for the series in terms of error, trend, and
seasonality.

Model Summary Contains fit statistics for the model. In the formulas below, # is the length of
the series and k is the number of fitted parameters in the model.

-2LoglLikelihood Twice the negative log-likelihood function evaluated at the best-fit
parameter estimates. Smaller values are better fits. See Fitting Linear Models.

AIC The Akaike’s Information Criterion (AIC) value, computed as —2loglikelihood + 2k.
Smaller AIC values indicate better fit.

BIC The Schwarz’s Bayesian Criterion (SBC) value, computed as
—2loglikelihood + k*In(n). Smaller SBC values indicate better fit. Schwarz’s Bayesian
Criterion is equivalent to the Bayesian Information Criterion (BIC).

Nparm The number of parameters in the calculation of the information criteria. This

number is one more than the number of free parameters in the likelihood function.

Note: Nparm is not the number of parameters in the parameter estimates table.

Sigma The estimate of the one-step-ahead forecast standard deviation.
RSquare The R-Square value, computed as follows:

2 _,_SSE
R ’1_SST

where

n

-2

SST = > (y;-vy)
i=1
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n
.2
SSE = % (y;—vy)
i=1

Y; are the one-step-ahead forecasts

y is the mean

If the model does not fit the series well, the model error sum of squares, SSE, might be
larger than the total sum of squares, SST. As a result, R? can be negative.

RSquare Adj The adjusted RZ value, computed as follows:

[0

MAPE The Mean Absolute Percentage Error value, computed as follows:

yz‘*?j

Yi

n
100
"’l Z

i=1

where

Y; are the one-step-ahead forecasts

MAE The Mean Absolute Error value, computed as follows:

1 n
=2 iy
i=1

where

Y; are the one-step-ahead forecasts

Parameter Estimates A table that shows the estimate, standard error, and 95% confidence
interval for each parameter in the model.

Forecast A plot that shows both the observed and predicted values for the time series. See
“Forecast”.

One-Step-Ahead Forecasting Errors A plot of the one-step-ahead forecasting errors over
time. For each time point £, the error is calculated as the observed value of the time series
at f minus the one-step-ahead predicted value at t. If a holdback set is specified, the errors
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are computed only for the training data. The autocorrelation and partial autocorrelation
reports for these errors are also shown.

Forecasting Errors on Holdback Series (Available only if a holdback set is specified.) A plot
of the forecasting errors on the observations in the holdback set. The autocorrelation and
partial autocorrelation reports for these errors are also shown.

Component States A report that contains a plot for each state of the model and the
corresponding formula for the model. Each plot includes the state estimates of the series
and the state forecasts. If a holdback set is specified, the state estimates are for the training
portion and the state forecasts are for the holdback portion. If a holdback set is not
specified, the state estimates are for the portion up to the last observation of the time series
and the state forecasts are for after the last observation of the time series. A model can
have up to three states: Level, Trend, and Seasonal.

The Component States red triangle menu has a Save States option. Select this option to
save the component states at each time point to a separate data table.

One-Step-Ahead Relative Forecasting Errors for Multiplicative Error Model (Available only
for multiplicative error models.) A plot of the one-step-ahead relative forecasting errors
over time. For each time point ¢, the error is calculated as the one-step-ahead-forecasting
error at t divided by the one-step-ahead predicted value at t.

State Space Smoothing Report Options
Each state space smoothing report has a red triangle menu that contains the following options:
Show Points Shows or hides the data points in the forecast graph.

Show Prediction Interval Shows or hides the prediction intervals in the forecast graph.

Save Columns Creates a new data table that contains columns that represent the results of
the model.

Remove Fit Removes the individual model fit from the report.

Transfer Function Report

Each transfer function model is added to the Model Comparison table. If the Report check box
for a transfer function model in the Model Comparison table is selected, a Transfer Function
Model report is produced. If a holdback set is specified, a model plot is also available in the
Model Comparison report.

Each Transfer Function Model report contains the following reports:

* Model Summary

e Parameter Estimates
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® Residuals

¢ Forecasting Errors on Holdback Series

¢ Interactive Forecasting

¢ Iteration History

The information in the Model Summary, Parameter Estimates, Residuals, Forecasting Errors
on Holdback Series, and Iteration History reports is the same as in the ARIMA and Seasonal
ARIMA model report. For more information about these reports, see “ARIMA and Seasonal

ARIMA Model Report”. The Parameter Estimates table is followed by the formula of the
model, where B is the backshift operator.

Interactive Forecasting

The Interactive Forecasting report provides a forecasting graph based on a prediction interval
specified in the Transfer Function Specification window. The prediction interval around the
prediction is shown in blue. Change the confidence level for this prediction interval by
entering a number in the Prediction Interval box above the graph.

You can drag the plus sign in the graph to change the number of forecast periods in the graph.
In the forecast periods, you can change the input values using the Import Inputs from Table
button or by dragging points in the input graph to different values. The results of your
changes are reflected in the forecast periods of the output graph.

Figure 18.14 Interactive Forecasting Graph
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Spectral Density Report

Figure 18.15 Spectral Density Plots and White Noise Test Report
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< White Noise test

Fisher's Kappa 38.360497
Prob > Kappa 1.648e-22
Bartlett's Kolmogorov-Smirnov  0.7914586

The White Noise Test report contains the following statistics:

Fisher’s Kappa Tests the null hypothesis that the values in the series are drawn from a
normal distribution with variance 1 against the alternative hypothesis that the series has a
periodic component. Kappa is the ratio of the maximum value of the periodogram, I(f;),
and its average value.

Prob > Kappa The probability of observing a value larger than Kappa if the null hypothesis
is true, given by the following equation:

q
. . g-1
Pr(k>x) = 1- -1y| 9 11k
r(k > K) pY )[j][max( q,oﬂ
j=0

where

g=N/2if Niseven, g=(N-1)/2if Nis odd

Kk is the observed value of Kappa

The null hypothesis is rejected if this probability is less than the significance level a.
Bartlett’s Kolmogorov-Smirnov Compares the normalized cumulative periodogram to the

cumulative distribution function of the uniform distribution on the interval (0, 1). The test

statistic equals the maximum absolute difference of the cumulative periodogram and the

uniform CDF. If it exceeds 4/(./g) , then one typically rejects the hypothesis that the

series comes from a normal distribution. The values a = 1.36 and a = 1.63 correspond to
significance levels 5% and 1% respectively.
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Additional Examples of the Time Series Platform

“Example of Creating Time ID Column”
“Example Using Box-Cox Transformation”
“Example Using a Holdback Set”

Example of Creating Time ID Column

This example uses the SeriesP.jmp sample data table to show how to perform a time series
analysis. You first create a new column that is appropriate for the Time ID.

Create Appropriate Time ID Column

1.

¥ X N DN

—_ e
N = O

Select Help > Sample Data Library and open Time Series/SeriesP.jmp.

The SeriesP.jmp data table contains a Year column and a Quarter column to identify the
time period during which the responses were observed. However, the Time Series
platform requires one column with unique, equally spaced time points to label the X axis.
If no Time ID is specified, then the row number is used to identify the time periods. To
avoid this and make the report easier to interpret, you construct a Time ID column from
Year and Quarter.

Select Cols > New Columns. In the Column Name box, type Year.Quarter.
Select Best > Date > yyyyQq next to Format.

Select Column Properties > Formula.

Click the gray triangle next to Date Time and click Informat.

Click the gray triangle next to Character.

Select Year, click Char, and then click Concat.

Type “Q” in the box (including quotation marks) and press Enter.

Click Concat.

. Select Quarter and click Char.
. Click the <formatName> box, type yyyyQq, and press Enter.
. Click OK.

The completed New Column window should appear as in Figure 18.16.



Chapter 18 Time Series Analysis 361
Predictive and Specialized Modeling Additional Examples of the Time Series Platform

Figure 18.16 New Column
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13. Click OK.

Note: This time column also works for X11 analyses.

Time Series Analysis

Now that the data table contains an appropriate Time ID column, proceed with the analysis.
1. Select Analyze > Specialized Modeling > Time Series.

2. Select GDP and click Y, Time Series.

3. Select Year.Quarter and click X, Time ID.

4. Click OK.
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Figure 18.17 Time Series Report for SeriesP.jmp
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Mean 98.489
Std 12.232008
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The series shows an increasing trend over time that is fairly linear. In addition, the
autocorrelation chart shows that there is strong correlation between points that are close
together. The AutoCorr values for points with lags of 1, 2, and 3 are 0.9551, 0.9112, 0.8666,

respectively.

5. Click the Time Series GDP red triangle and select Difference.

6. Select 1 for the Nonseasonal Differencing Order and click Estimate.
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Figure 18.18 Difference Report for SeriesP.jmp

£ |~ Difference: (1-B) "1

4 Mean 0.6479661
3 Std 0.8564260
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g 1 Single Mean ADF  -7.430542
a8 0 Trend ADF -7.564809
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18 0.0660 1] 23,3780 0.1765 18 -0.0291 I
19 01905 I :II 266430 0.1132 19 -0.0610 i
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The Difference report helps determine an appropriate model to be fit to the original time
series. The plot of differences shows that the differenced series no longer has the trend that
was observed in the original data. This indicates that lag-1 differencing is an appropriate
choice. Also, even after removing the trend, the series shows no sign of seasonality. For
these reasons, models to fit the original series should be able to handle linear trends, but
do not necessarily need to handle seasonality. Linear exponential smoothing and ARIMA
models would be appropriate.

Click the Time Series GDP red triangle and select Smoothing Model >
Linear Exponential Smoothing.

Click Estimate.

Click the Time Series GDP red triangle and select ARIMA Model Group. This enables you
to fit multiple ARIMA models for a range of values of (p,d,q)(P,D,Q).

10. In the ARIMA box, set the following ranges:
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— Fix d, the differencing order, at 1 by setting the range from 1 to 1 because the
differencing report showed lag-1 differencing was appropriate.

— Set p, the autoregressive order, to range from 0 to 1 because the original series showed
evidence of autocorrelation.

— Set g, the moving average order, to range from O to 1.
Note: In most cases, it is sufficient to keep p and g small.

— Leave P, D, and Q set at 0, since the series showed no evidence of seasonality.

These settings lead to the fitting of four total models.

Figure 18.19 ARIMA Model Group Specification

Specify ARIMA Model
ARIMA Seasonal ARIMA
p. Autoregressive Order | 0 1 P, Autoregressive Crder oo
d, Differencing Crder 11 [, Differencing Crder oo
q. Moving AverageCrder | 0| 1 Q, Moving Average Order | 0| 0
Observations per Period (12|12
Prediction Interval g g5 v|
[#] Intercept
Constrain fit
Total Number of Models 4
[Estimate” Cancel H Help
11. Click Estimate.
Figure 18.20 Model Comparison Table
< Model Comparison
Report Graph Model DF  Variance AIC SBC RSquare -2loglH Weights .2 4.6 .8 MAPE MAE
& = —1I(1) 58 0.746113 151.14636 153.22390 0.995 149.14636 0.477865[ i 0.675816 0.649664
¥ [ = ARI(1, 1) 57 07391006 153.13024 15720432 0.995 149.13824 0176424 O] ¢ H 0.676216  0.649960
& = — IMA(L, 1) 57 0.7591199 153.14002 157.29510 0.995 148.14002 U.176355:|§ 0.676179 0.649933
~ ¥ ] —— ARIMA(L, 1,1) 56 0.748633 153.01882 160.15143 0995 147.91882 0.119474]: 0.668180 0.641981
=[] = = Linear (Holt) Expenential Smocothing 56 0.7878954 155.66571 159.78660 0.994 151.66571 0.049882] | | i 0.716452 0.686737

The Model Comparison Table is sorted such that the best fitting model, according to the AIC
criterion, is at the top of the list. In this case, the ARIMA(0,1,0) model (denoted I(1) in the
report) best fits the original time series. It should also be noted that although the I(1) model is
“best,” all of the models have extremely similar values for the fit statistics. They could all be
considered appropriate.
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Figure 18.21 Model Report for ARIMA(0,1,0)

A = Model: I(1)
< Model Summary

DF 58 Stable Yes
Sum of Squared Innovaticns 43.2745559 Invertible Yes
Sum of Squared Residuals 43.2745559
Variance Estimate 0.74611303
Standard Deviaticn 0.86377835

Akaike's ‘A’ Information Criterion 151.146363
Schwarz's Bayesian Critericn 153.223901

RSquare 0.99501481
RSquare Adj 0.99501481
MAPE 0.67581386
MAE 0.64966380
-2Loglikelihood 149.146363
4 Parameter Estimates
Constant
Term Lag  Estimate StdError tRatio Prob:|t] Estimate Mu
Intercept 0 0.64796610 0.1114962 5.81 <0001* 0.6479661 0.6479661
4 Forecast

150

140
3130
= b
T 120
@
G 110
B
£ 100 /

a0 ,.A'D/'

80

1955Q1 196001 196501 197001 197501
Year.Quarter

The model report for I(1) shows the forecast graph. The blue lines indicate the prediction
intervals. GDP is predicted to continue increasing at a linear rate.

Example Using Box-Cox Transformation

In this example, you use a Box-Cox transformation to analyze the Passengers column in the
Seriesg.jmp data table. The Lambda value is set to zero, which makes the Box-Cox
transformation an approximate log transformation. The script in the Seriesg.jmp data table
runs a time series analysis on the Log Passengers column. By using the Box-Cox
transformation for the analysis, the results are easier to interpret since all forecasts are
transformed back and reported on the original scale.

1. Select Help > Sample Data Library and open Time Series/Seriesg.jmp.

2. Select Analyze > Specialized Modeling > Time Series.

3. Select Passengers and click Y, Time Series.

4. Select Time and click X, Time ID.

5. Select Use Box-Cox Transformation.

Use the default value of 0 for Lambda.
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Click OK.

7. Click the red triangle next to Time Series Box-Cox Transformed Passengers and select
Seasonal ARIMA.

8. In the ARIMA section of the Seasonal ARIMA Specification window, set the following
parameters.

— Set p, Autoregressive Order to 0.
— Set d, Differencing Order to 1
— Set g, Moving Average Order to 1

9. In the Seasonal ARIMA section of the Seasonal ARIMA Specification window, set the
following parameters.

— Set P, Autoregressive Order to 0
— Set D, Differencing Order to 1
— Set Q, Moving Average Order to 1
10. Deselect Intercept to run a model without an intercept.

Your window should now match the window shown in Figure 18.22.

Figure 18.22 Seasonal ARIMA Specifications

Specify ARIMA Model
ARIMA, Seasonal ARIMA
p, Autoregressive Order | 0 P, Autoregressive Order 0
d, Differencing Order 1 D, Differencing Order 1
g, Moving Average Order | 1 Q, Moving Average Order | 1

Observations per Pericd |12

Prediction Interval | o

[ Irtercept
Constrain fit

|Estimate|| Cancel || Help

11. Click Estimate.
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Figure 18.23 Seasonal ARIMA Model for Box-Cox Transformed Passengers Data

£~/ Model: Seasonal ARIMA(O, 1, 1)(0, 1, 1)12 No Intercept
< Model Summary

DF 129 Stable Yes
Sum of Squared Innovaticns 0.17660091 Invertible Yes
Sum of Squared Residuals 0.18475178
Variance Estimate 0.001369
Standard Deviaticn 0.03699999
Akaike's ‘A’ Information Criterion  -485.39302
Schwarz's Bayesian Critericn -479.64263
RSquare 0.99097293
RSquare Adj 0.99000295
MAPE 0.53058847
MAE 0.02923608
-2Leglikelihood -480,30302

4 Parameter Estimates
Term  Factor lag  Estimate StdError tRatio Prob:|t|

MAT1,1 1 1 0.40182267 0.0896415  4.48 <.0001*
MA2,12 2 12 055694079 0.0731098  7.62
< Forecast
1000
o 800
3
5
T 600
g
T 400
oo P 3
r
200
0 29 58 87 116 145

Time

The parameter estimates are equivalent to those obtained from running the same model on
the Log Passengers column. However, the forecasts and prediction intervals in
Figure 18.23 are on the original scale.

Example Using a Holdback Set

This example uses a holdback set to evaluate predictions made on monthly data on lead
production. Since a holdback set is used, both State Space Smoothing and ARIMA models can
be fit and compared to find the best fitting model for the data.

1. Select Help > Sample Data Library and open Time Series/Lead Production.jmp.
2. Select Analyze > Specialized Modeling > Time Series.

3. Select LEADPROD and click Y, Time Series.

4. Select DATE and click X, Time ID.

5. Select Forecast on Holdback.

Selecting this options means that forecasts are made on the holdback set instead of on
future observations.

6. Enter 12 next to Forecast Periods.
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This assigns the last 12 observations in the data to the holdback set. Since this is monthly
data, this is equivalent to the last year.

7. Click OK.

8. Click the Time Series LEADPROD red triangle and select State Space Smoothing.
9. Type 12 next to Period.

10. Select Constrain Parameters.

11. Click OK.

12. Click the Time Series LEADPROD red triangle and select ARIMA Model Group.

13. Set the range for all parameters from 0 to 1. The Specify ARIMA Model window looks like
the one in Figure 18.24.

Figure 18.24 ARIMA Model Group Specifications

Specify ARIMA Model
ARIMA Seasonal ARIMA

p, Autoregressive Order | 0] 1 P, Autoregressive Order 0 1
d, Differencing Order 0 1 D, Differencing Order 0 1
g, Moving Average Order | 0| 1 Q, Moving Average Order | 0] 1

Observations per Period (12|12

Prediction Interval | pg5

Intercept
Constrain fit

Total Number of Mcdels 64

Estimate” Cancel || Help

14. Click Estimate.

Figure 18.25 Model Comparison

< Model Comparison

Holdback Evaluation
Report Graph Model Class Model RMSE ~ MSE MAPE MAE
~[] O —— ARIMA Seasonal ARIMA(D, 1, 1)(1,0,0)12 | 32194131 10364621 8.000164 24163319
~[] O — ARIMA Seasonal ARIMA(D, 1,1)(0,0,1)12 | 33168746 11001657 9.148390 2456.0873
-] [} — State Space Smoocthing AAA12 Constrained 33509303 11228734 8.623519 22455657
~[] O —— ARIMA Seasonal ARIMA(1,1,0)(1,0,0)12 | 3397,0855 11540190 9.082427 23025823
~[] O —— ARIMA Seasonal ARIMA(D, 1, 1)(1,1,0)12 | 34486372 11893090 0.320450 26408142
~[] O ARIMA Seasonal ARIMA(1,1,0)(1,1,0)12 | 34843764 12140870 0.708056 2604.6290
~[] O —— ARIMA Seasonal ARIMA(1,1,0)(0,0,1)12 | 34912648 12188930 9.302681 2435744
-] [} — State Space Smoocthing MAM12 Constrained 35121513 12335206 10.552196 28134655
~[] O —— ARIMA Seasonal ARIMA(D, 1, 0)(1,0,0)12 | 35250858 12426230 9.374006 2440.6802
~[] O —— ARIMA Seasonal ARIMA(D, 1, 0)(1,1,0)12 | 35513973 12612423 0.367%47 24803210
~[] O = ARIMA Seasonal ARIMA(D, 1, 1)(1,0,1)12 | 35700242 12809414 10.520274 2739.0632
~[] O ARIMA Seasonal ARIMA(D, 1, 0)(0,1,0)12 | 35973008 12940638 11.622868 3219.0476
~[] O —— ARIMA Seasonal ARIMA(D, 1, 0)(0,0,1)12 | 36318176 13190090 0.792052 25444260
~[] O —— ARIMA Seasonal ARIMA(1,1,0)(0,1,0)12 | 36618395 13409068 12.030672 3366.0035
~[] O — ARIMA Seasonal ARIMA(D, 1,1)(0,1,0)12 | 36736360 13495608 12.063523 33704644
~[] O ARIMA Seasonal ARIMA(1,1,0)(1,0,1)12 | 37006621 13694900 11.077791 2890.6426
~[] O = ARIMA Seasonal ARIMA(D, 1, 0)(1,0,1)12 | 37237664 13866437 11.222827 2035.8075
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The fit statistics are comparable between the State Space Smoothing models and the
ARIMA models because they are evaluated on the holdback set.

15. Select the Graph check box next to the first three models in the Model Comparison report.

Figure 18.26 Model Comparison Graph
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The evaluation statistics and the forecasting plots show that there is no substantial

differences in forecasting performance among the top models. Based on the report, either
an ARIMA model or a State Space Smoothing model is appropriate for this data.

Statistical Details for the Time Series Platform

e “Statistical Details for Spectral Density”

* “Statistical Details for X-11 Decomposition”

e “Statistical Details for Exponential Smoothing Models”
* “Statistical Details for ARIMA Models”

e “Statistical Details for Transfer Functions”

Statistical Details for Spectral Density

The least squares estimates of the coefficients of the Fourier series are computed as follows:

N

2
%=y > ycos(2nf;t)
i=1
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N
2 .
b, = N > ysin(2nf;t)
i=1
Then the f;=i/N are combined to form the periodogram I(f;) = (N/2)(ai2 + biz), which represents
the intensity at frequency f;.

The periodogram is then smoothed and scaled by 1/(4r) to form the spectral density.

Statistical Details for X-11 Decomposition

This method adjusts the original time series using either a multiplicative or an additive
decomposition. The model is fit using an iterative process to estimate the three X-11
components: trend cycle, seasonal, and irregular. The trend cycle component contains both the
long-term trend and the long-term cyclical effects. The irregular component contains the
effects of variation unexplained by the trend and seasonal components. For a historical
overview of the development of the X-11 method, see SAS/ETS 15.2 User’s Guide (search for
“Historical Development of X-11").

The multiplicative adjustment fits the following model:
Op = G- Sy
where
O; is the original time series
C;is the trend cycle component
S;is the seasonal component
I; is the irregular component
The adjusted multiplicative trend is O,/S;.
The additive adjustment fits the following model:
Op = G5+

The adjusted additive trend is O; - S;.

Statistical Details for Exponential Smoothing Models

Smoothing models are defined as follows:

Yy = Byt +s(t) +a,
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where
1, is the time-varying mean term
B; is the time-varying slope term
s(t) is one of the s time-varying seasonal terms

a; are the random shocks

Models without a trend have ;= 0 and nonseasonal models have s(t) = 0. The estimators for
these time-varying terms are defined as follows:

L;is a smoothed level that estimates 1,
T,is a smoothed trend that estimates f3;

St_]- forj=0,1,.., s - 1 are the estimates of the s(¢)

Each smoothing model defines a set of recursive smoothing equations that describe the
evolution of these estimators. The smoothing equations are written in terms of model
parameters called smoothing weights:

o is the level smoothing weight

v is the trend smoothing weight

¢ is the trend damping weight

d is the seasonal smoothing weight

While these parameters enter each model in a different way (or not at all), they have the
common property that larger weights give more influence to recent data while smaller
weights give less influence to recent data. For more information on smoothing weights, see
SAS/ETS 15.2 User’s Guide (the Forecasting Process Details chapter).

Simple Exponential Smoothing

The model for simple exponential smoothing is y; = p; + a;.

The smoothing equation, L; = ay; + (1 — a)L.4, is defined in terms of a single smoothing weight
o.. This model is equivalent to an ARIMA(0, 1, 1) model where the following is true:

(1-B)y, = (1-0B)a;, where 6 =1-a

The moving average form of the model is defined as follows:

o0
Yyp=at Yoy
i-1
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Double (Brown) Exponential Smoothing

The model for double exponential smoothing is y; = p; + Byt + a;.

The smoothing equations, defined in terms of a single smoothing weight a, are defined as
follows:

L

P = ocyt+(1—0c)Lt71

T, = a(l,~L, )+(1-o0)T,

This model is equivalent to an ARIMA(Q, 1, 1)(0, 1, 1); model where the following is true:
(1 _B)Zyt =(1- eB)Qat where 071 =0, with 6=1-«

The moving average form of the model is defined as follows:

o0
. 2
yp=a,+ Y Qat(-Da )ﬂt—j
j=1

Linear (Holt) Exponential Smoothing
The model for linear exponential smoothing is y; = p; + Bt + a;.
The smoothing equations, in terms of smoothing weights o and v, are defined as follows:

L

p= oy, T (l—a)L,_+T, 1)
Ty =v(@Ly-L_p+A-1T;_4

This model is equivalent to an ARIMA(0, 2, 2) model where the following is true:
(1—B)2yt = (1—9B—92B2)at with 6 =2-a-ay and 6, =a-1

The moving average form of the model is defined as follows:

©
yp=at Y (0‘+]‘0“/)”t,]'
j=1

Damped-Trend Linear Exponential Smoothing

The model for damped-trend linear exponential smoothing is y; = p; + ;¢ + a;.
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The smoothing equations, in terms of smoothing weights o, y, and ¢, are defined as follows:
Ly=oay,+(1-o)L;_1+¢T,_q)
Tt = 'Y(LtiLt—l) + (1 7Y)(PTt_]

This model is equivalent to an ARIMA(1, 1, 2) model where the following is true:

(1-¢B)(1-B)y, = (1-6,B~ eZBz)at

where
0, =1+¢-a-aye
92 = (a-1)¢

The moving average form of the model is defined as follows:

@ j
_ ataye(e’ —1)
Yp= oyt Z[ o—1 %

j=1

Seasonal Exponential Smoothing

The model for seasonal exponential smoothing is y; = p; + s(f) + a;.
The smoothing equations in terms of smoothing weights o and 5 are defined as follows:
L, =aly,~S; J+(1-aL, ,

S, = 8(y,-L,_)+(1-8)S

t t—s

This model is equivalent to a seasonal ARIMA(0, 1, s+1)(0, 1, 0); model:

s+1

(1-B)(1-B%)y, - (1—elB—esz—e3B )a,
where

0, =1-a

0, = (1-8)(1-0a)

0= (1-a)(3-1)
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The moving average form of the model is defined as follows:

o o for j mod s #0
yp=a+ Yy ity where vy =
j=1 oa+d8(l—a)forjmods =0

Winters Method (Additive)

The model for the additive version of the Winters method is y; = p; + Bt + s(t) + a;.

The smoothing equations in terms of weights o, y, and & are defined as follows:
L, =oa(y,~S;_)+Q-a)Ll,_{+T,_ 1)

p = VL -L T A-NT

= 8(y,~L)+(1-8)S, |

This model is equivalent to a seasonal ARIMA(0, 1, s+1)(0, 1, 0)s model defined as follows:

s+1
(17B)(17B2)yt - {1 3 el.Bl]at
i=1

The moving average form of the model is defined as follows:

o0

ye=at 2 ey

j=1
where
_ Jatjay, jmods # 0
atjoy+d(l-a),jmods = 0

Statistical Details for ARIMA Models

ARIMA Model
For a response series {y;}, the general form for the ARIMA model is defined as follows:
¢(B)(w;—p) = 6(B)a,

where

t is the time index
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B is the backshift operator defined as By;=y;_4

wy=(1- B)“ y; is the response series after differencing
L is the intercept or mean term

¢(B) and 6(B) are the autoregressive operator and the moving average operator,
respectively, and are defined as follows:

o(B) = 1—¢1B—¢2B2— —4’po

0(B) = 1-0,B-0,B"— ... ~0,B’
where

a; are the sequence of random shocks

The 4, are assumed to be independent and normally distributed with mean zero and
constant variance.

The model can be rewritten as follows:
d(B)w, = 5+0(B)a,
The constant estimate 3 is given by the relation:

8= 0B = n-djp—dou—...— ¢,

Seasonal ARIMA Model

In the case of Seasonal ARIMA modeling, the differencing, autoregressive, and moving
average operators are the product of seasonal and nonseasonal polynomials:

D
w, = 1-BY(1-B% v,

2 2 P
o(B) = (1-9; 1B-9; ,B —...—(pLPBp)(l—(plsBs—(pzst Ty pB)

0(B) = (1—91’13—91’232 B% Qs)

q S
.=, B(1-0, B -0 ~..=0, o,B

2,2s

where s is the number of observations per period. The first index on the coefficients is the

factor number (1 indicates nonseasonal, 2 indicates seasonal) and the second is the lag of the
term.
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Statistical Details for Transfer Functions

A typical transfer function model with m inputs can be represented as follows:

_0(B) ®,,(B) 0(B)
“u= =Xyttt Cam T ey
! 8,(B) 8,,(B) m.m=—dm ¢(B)
where

Y; denotes the output series
X; to X,,, denote m input series
e; represents the noise series
X1, 11 indicates the series X; is indexed by t with a d1-step lag

u represents the mean level of the model

¢(B) and 0(B) represent autoregressive and moving average polynomials from an ARIMA
model

oy(B) and 8y(B) represent numerator and denominator factors (or polynomials) for
individual transfer functions, with k representing an index for the 1 to m individual inputs.

Each polynomial in the above model can contain two parts, either nonseasonal, seasonal, or a
product of the two as in seasonal ARIMA. When specifying a model, leave the default 0 for
any part that you do not want to include in the model.
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Forecast Multiple Time Series

The Time Series Forecast platform enables you to forecast multiple time series, where the
number of series could be very large. The platform provides compact summaries of the
multiple time series and provides options for efficiently fitting up to 30 different forecasting
models in the exponential smoothing family. The best fitting model is automatically selected.

The Time Series Forecast platform is designed to select a best fitting model automatically from
a set of exponential smoothing models. This is in contrast to the Time Series platform which
requires manual selection of a best fitting model and uses ARIMA models.

Figure 19.1 Original Series and Forecasts

4 Fitted Model Using Entire Series
< Original Series and Forecasts

7000 ® Criginal Series
6500 i — Forecasts
6000 _ Forecasting Intervals
5500 ..r"’“!"."'m'ioi'..r..
0y
5000 ot
¥ 4500
4000 P
3500 ."m“_._.-.-i-ao

3000

2500

198301 1985Q1 19870Q1 198901 199101 1993Q1 1995Q1
Time
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Example of Time Series Forecast

AL A

Click OK.

Select Time and click Time.

Select Series and click Grouping.

Select Help > Sample Data Library and open Time Series/M3C Quarterly.jmp.
Select Analyze > Specialized Modeling > Time Series Forecast.
Select Y and click Y.

The initial Time Series Forecast report appears. It contains summaries of the Time and Y
variables. There is also a Modeling Specifications report that provides options for fitting

forecast models.

Figure 19.2 Initial Report for Time Series Forecast

£ =/ Time Series Forecast
£ Analysis of Time Pattern

Suggested Seascnality 4
£ Group Summary of Time

Missing
Seriess N Rows Value
M 846 44 Mo
M 847 44 Mo
M 848 46 Mo
M 649 44 Mo
M &850 44 Mo
N 651 44 Mo
M 652 43 Mo
M 653 43 Mo
M 654 45 Mo
M 6855 44 Mo

£ Group Summary of Y

Series Min Max
M 846 312438 61766
M 847 1522 43208
M 848 154972 5970
M 649 21367 50232
M &850 875.51 6908
N 651 75124 85262
M 652 486163 991357
M 653 2797 7202

M 654 237274 67351
M 655 244906 890428

Date Rescluticn Quarterly data.

Unique
Timestamps

Length
44
44
48
44
44
44
43
43
45
44

Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes

Start
198401
198401
198303
198401
198401
198401
198401
198401
198304
198401

NObs N Missing

44
44
46
44
44
44
43
43
45
44

[=T =T = i = = Y = Y )

End
199404
199404
199404
199404
199404
199404
199403
199403
199404
199404

All Positive
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes

Missing

Record
No
No
No
No
No
No
No
No
No
No

Comment

7. In the Model Specifications report, click the Complete Specifications tab.

8. Click the menu below Model Selection Strategy and select Forecasting Performance.

9. Click Run.

This fits a set of recommended models to the data. The best model for each level of the
grouping variable is chosen and reported in the Model Reports. See “Model Reports”.
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Figure 19.3 Model Reports
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< Model Summary
-2Loglikelihood  635.4059

AlC 645.4030
BIC 654.3268
Nparm 5
Sigma 216.1735

RMSE(Holdback) 182.0081
<4 Parameter Estimates

Parameter Estimate  Std Error Lower 95% Upper953%
alpha 0.413 0.00008039 0.413 0.414
beta -0.185 0.00001975 -0.185 -0.185
10 3143564 0.00300895 3143558 3143570
b0 14.815 0.00020227 14.814 14.815
< One-Step-Ahead Forecasting Errors
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The model report for one series, Series N646, is shown. This corresponds to the series
name that is selected in the Select Series list. You can use the down arrow key to scan
through the model reports for each series. Alternatively, you can click a different name in
the list to display the model report for the selected series.
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Launch the Time Series Forecast Platform

Data

Launch the Time Series Forecast platform by selection Analyze > Specialized Modeling > Time
Series Forecast.

Figure 19.4 The Time Series Forecast Launch Window

Select Columns Cast Selected Columns into Roles Action
* 13 Columns v
th Series optional numeric
ds
all Time . -
G th Series
A Time
optiona

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

The Time Series Forecast platform launch window contains the following options:

Y Assigns one or more columns as time series variables. Multiple time series can be
organized as individual columns in a table or they can be stacked in a single column with
one or more grouping variables.

Grouping Assigns one or more columns as grouping variables. Grouping variables are used
to identify individual time series when they are in stacked format.

Time Assigns a column for the time variable. If the individual time series are organized as
individual columns, the timestamps in the Time column must not contain any duplicates.

By Assignsa column that creates a report consisting of separate analyses for each level of the
variable. If more than one By variable is assigned, a separate analysis is produced for each
possible combination of the levels of the By variables.

Format

Multiple time series can be organized as individual columns in a table or they can be stacked
in a single column with one or more grouping columns to identify the individual series. You
can also have a combination of multiple Y columns and multiple grouping columns.

The platform makes the following assumptions about the data:

e All of the time series are recorded at the same time resolution.



382

Time Series Forecast Chapter 19
Launch the Time Series Forecast Platform Predictive and Specialized Modeling

e All of the time series are collected up to the same final observed time point. This final
observed time point is defined as the latest time point that occurs in any of the individual
time series. A series without data up to the final observed time point is assumed to have
missing values. For example, in Figure 19.5, the final observed time point is 5, represented
by the solid black line. It is assumed that Series 2 has missing observations at time points 4
and 5 and that Series 4 has a missing observation at time point 5.

* All of the forecasts start at the same time point. This starting time point is the next time
point following the final observed time point. For example, in Figure 19.5, the final
observed time point is 5, represented by the solid black line. Therefore, all of the forecasts
start at time point 6, represented by the dashed black line.

Figure 19.5 Demonstration of Assumptions

Y vs. Time
10
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—_2
—_3
—4
—35
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Time
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The Time Series Forecast Report

The Time Series Forecast report contains summary tables based on the variables specified in
the launch window. A summary table of the time series by group is always provided. If a Time
column is specified, the report also contains a summary of the time pattern and a summary
table of the time by group. The report also contains a Modeling Specifications report that
enables you to fit models to each time series.

® “Analysis of Time Pattern”
¢ “Group Summary of Time”
e “Group Summary of Y”

* “Modeling Specifications”

Analysis of Time Pattern

If a time column is specified, the Time Series Forecast platform analyzes the entries of the
column to determine a pattern. The platform is designed to recognize a variety of time
patterns, including daily, business daily, monthly, bi-weekly, quarterly, and so on. The pattern
is reported as the Date Resolution. A Suggested Seasonality is also provided based on the time
pattern.

Group Summary of Time

If a time column is specified, the report contains summaries of the individual time series. The
summaries contain the following information for each time series:

<Grouping Column Name> (Available only if a Grouping variable is specified.) The level of
the grouping variable that defines the individual series when data is provided in the
stacked format.

N Rows The number of observations in the series.

Missing Value Indicates whether any of the time values are missing values.
Unique Timestamps Indicates whether the time stamps are unique.

Start The starting time stamp.

End The ending time stamp.

Missing Record Indicates whether there are observations missing from the data table, based
on the starting and ending time stamps and the data resolution/pattern.
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Group Summary of Y

The report contains a summary table for each Y variable. The summaries contain the following
information for each time series:

Variable (Available only if there are multiple Y columns and at least one grouping column.)
The column name of the time series variables.

Time Series (Available only if there are multiple series.) The name of the individual time
series. When the data are provided in the stacked format, this is the level of the grouping
variable. When the data are provided in the wide format, with multiple columns, this is
the column name of the individual series.

Note: When the data are provided in the stacked format, the column heading in the table
is the name of the Grouping column.

Min The minimum value of Y for the individual series.

Max The maximum value of Y for the individual series.

Length The duration of the series. This is determined based on the starting and ending time
stamps and the result of the Analysis of Time Pattern.

N Obs The number of observations. If there are no missing records, this number is the same
as the Length.

N Missing The number of missing Y values.
All Positive Indicates whether all of the Y values are positive.

Comment Indicates if there is a problem with the series, such as non-unique time stamps.

Modeling Specifications

The Modeling Specifications report enables you to fit models to the individual time series. A
variety of models are considered. Hyndman et al. (2008) defines state space smoothing models
based on their error, trend component, and seasonal component:

® The errors can be additive (A) or multiplicative (M).

® The trend component can be none (N), additive (A), additive damped (Ay4), multiplicative
(M), or multiplicative damped (My).

* The seasonal component can be none (N), additive (A), or multiplicative (M).

A specific model can be represented by its ETS (Error, Trend, Seasonal). These are the models
used in Time Series Forecasting.



Chapter 19 Time Series Forecast 385
Predictive and Specialized Modeling The Time Series Forecast Report

There are two tabs in the Modeling Specifications report. Use the Recommended
Specifications tab to fit a set of state space smoothing models that is chosen by the platform.
Use the Complete Specifications tab to select the specific state space smoothing models that
you want to fit. For each individual time series, the best fitting model from the given set is
then used for forecasting.

Select Models

Available only in the Complete Specifications tab, shown in “Complete Specifications Tab”.
The Select Models report enables you to specify the state space smoothing models to fit to the
individual time series. Use the check boxes to select the error, trend, and seasonality for the
models. Click Select Recommended to select the check boxes that correspond to the models
recommended by the platform. Click Select All to select all check boxes or Deselect All to
deselect all check boxes. Click Constrain Parameters to constrain the parameters in such a
way that the further an observation is from the present, the less effect it has on the present
state of the model. In State Space Smoothing models, a forecast at time £, given all previous
observations, is the same as the weighted sum of all observations up to time t. The weights are
a function of the parameters. Therefore, constraining the parameters ensures that the weights
for past observations go to zero and that the further an observation is from the present, the
faster the weight goes to zero.

Figure 19.6 Complete Specifications Tab

Recommended Specifications | Complete Specifications

4 Select Models
State Space Smoothing Models
Additive Error Models Multiplicative Error Models
Seasonal Seasonal
Trend None Additive Multiplicative Trend None Additive Multiplicative
Nene O None
Additive O Additive
Additive with Damping O Additive with Damping
Multiplicative ] O O Multiplicative O
Multiplicative with Damping [ O O Multiplicative with Damping O
|Select Recommended| | Select All | |Deselect AII| Select Recommended| | Select All | |Deselect AII|
[] Constrain Parameters
4 Forecasting Settings
Name Value Description
MNAhead 4| NAhead>=0, Opticnal. Forecast n-ahead future chservations.
Pericd |4 Pericd>0, Opticnal. Integer or comma delimited integers.

< Model Selection Strategy
Forecasting Performance ~ |Metric| RMSE ~ NHoIdback

< Other Options
Preserve Model Selection Criterion [
Forecast Interval Level 0.95

Imputation for Applicable Models | pgne .
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Forecast Settings
Enables you to specify the following optional settings:

NAhead Specifies the number of steps ahead to forecast. The number of steps must be
nonnegative.

Period Specifies seasonality values to be considered in the model fitting process. By default,
the period is set to the suggested seasonality from the Analysis of Time Pattern report. If
you want to consider models with different seasonality, specify the additional periods here
and separate them with a comma. The period must be greater than zero.

Model Selection Strategy
Enables you to specify how the best model is chosen.

Information Criteria Determines the best model based on the specified information criteria.
The available information criteria are AIC and BIC.

Tip: Use BIC if the time series is long.

Forecasting Performance Determines the best model based on a performance selection
algorithm that involves a holdback set. First, the time series is partitioned into a training
set and a holdback set. The value of NHoldback specifies the number of observations in
the holdback set. Then, the algorithm fits all recommended or user-specified models on
the data in the training set. Forecasts are made on the holdback set using the individual
fitted models. These forecasts are compared to the actual holdback observations and the
models are evaluated using the specified metric. The model with the best metric is selected
for the final model. Last, the selected final model is fit to the entire time series (training set
and holdback set) and the refitted model is used to forecast beyond the last observation of
the time series.

Metric Specifies the metric to evaluate the forecasts made by the individual model fits.
The available metrics are Root Mean Square Error (RMSE), Mean Square Error (MSE),
and Mean Absolute Error (MAE).

NHoldback Specifies the number of observations used in the holdback set.

Other Options
Enables you to specify the following options:

Preserve Model Selection Criterion Saves the model selection criterion for the set of models
that is fit to the data. After model fitting, this information is shown in the Information
Criterion of All Models for All Series report.
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Forecast Interval Level The prediction interval level for the forecasts. This changes the
width of the shaded area in the forecasting plots.

Imputation for Applicable Models Specifies the imputation method used during the model
fitting process.

Note: These options change only the data that are used for model fitting. The raw data are
not changed.

None Does not impute missing values.

Last Value Imputes missing values by using the last value that is available before a
sequence of missing observations.

Middle Value Imputes missing values by averaging the last value that is available before
a sequence of missing observations and the first value that is available after a sequence
of missing observations.

Linear Interpolation Imputes missing values by creating a linear interpolation between
the last value that is available before a sequence of missing observations and the first
value that is available after a sequence of missing observations.

When you click Run, the specified set of models is fit. A progress bar appears that reports the
number of active threads, the number of finished and total tasks, and the percentage of
finished tasks. Note that a task is defined as the fitting of all specified models for one series
and response variable combination. When the fitting process is complete, the Model Reports
report is shown. See “Model Reports”. If you make any changes to the options in the Model
Specifications report and click Run again, the Model Reports report is replaced with a new
report.

Time Series Forecast Platform Options

The Time Series Forecast red triangle menu contains the following options:
Report Options (Effective only after fitting a model.) Contains the following report options:

Set Forecast Interval Level Enables you to change the forecast interval level. The
individual model reports update automatically.

Set NAhead Enables you to change the number of steps ahead to forecast. The individual
model reports update automatically.

Set NHoldout Enables you to change the duration of the holdout set. The individual
model reports update automatically.
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Save Results (Effective only after fitting a model.) Saves the forecasts to a separate data table
named Forecasts. The Forecasts data table has the same layout and format as the original
data table. If a holdout set is specified by NHoldout, an additional data table that saves the
actual values from the holdout data and the forecasts is produced. You can use this table to
calculate different types of error estimates.

The following additional save options are shown in the Request Outputs window:

Save Forecast Intervals Saves the lower and upper prediction intervals as columns in
the Forecasts data table.

Save One-Step-Ahead Predictions Stacks the one-step-ahead predictions and the
forecasts and saves them to a separate data table.

Save Original Series Stacks the original series and the forecasts and saves them to a
separate data table.

Save Forecast Results to Original Data Table Saves the results to new columns in the
original data table.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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Model Reports

The Model Reports report contains a Select Series list and one or more individual series
modeling reports. The individual reports that are displayed are determined by the Select
Series list. Click on the name of a series in this list to show the report for the selected series. If
you select more than one series name by using either Ctrl or Shift, an individual model fit
report for each of the selected series is shown. If you deselect one or more series from the
Select Series list, the reports for the corresponding series are removed.

The Select Series list is linked to the data table. When you select a series in the Select Series list,
the observations for the series and response variable combination are also selected in the data
table. The Select Series list is also linked to the Group Summary of Y table. If a Time variable is
specified, the Select Series list is also linked to the Group Summary of Time table. When you

select a series in the Select Series list, the corresponding entries are also selected in the tables.

Each individual model report contains the following information:

Model Type Describes the best fitting model for the series in terms of error, trend, and
seasonality.

Model Report A group of reports based on the model that is fit to the series.

Series and Forecasts (Available only when Information Criteria is specified as the
model selection strategy.) A plot of the original series and forecasts. During the time
period of the original series, the one-step-ahead predictions are shown. Beyond the
time period of the original series, the forecasts are shown. The shaded region
represents the forecasting interval.

Note: All of the forecasts start at the time point that immediately follows the last time
point across all individual series. See “Data Format”.

Training, Holdback, and Forecasts (Available only when Forecast Performance is
specified as the model selection strategy.) A plot of the training series, holdback series,
and the forecasted series. A shaded vertical region represents the holdback series. Since
this is the model refit on the entire time series, the one-step-ahead predictions are
shown during the time period of the entire original series. During the time period past
the last observation, the forecasts are shown. The shaded region represents the
forecasting interval.

Model Summary Provides the -2Loglikelihood, the AIC, the number of parameters, and
the sigma value. The sigma value is the estimate of the one-step-ahead forecast
standard deviation. If Forecast Performance is specified as the model selection strategy,
the root mean square error (RMSE) for the holdback set is also shown. See Fitting Linear
Models.
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Parameter Estimates Provides the parameter estimates for the model. The parameters
correspond to the parameters in the best fitting model, which is described in the Model
Type report.

One-Step-Ahead Forecasting Errors A plot of the one-step-ahead forecasting errors
over time. For each time point ¢, the error is calculated as e(t) = y(t) - u(f).

One-Step-Ahead Relative Forecasting Errors for Multiplicative Error Model (Available
only for multiplicative error models.) A plot of the one-step-ahead relative forecasting
errors over time. For each time point ¢, the error is calculated as e(t) = [y(t) - u(t))/u(t).
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Matched Pairs Analysis

Compare Measurements on the Same Subject

The Matched Pairs platform compares the means between two or more correlated variables
and assesses the differences. For example, you might compare a blood pressure measurement
taken on the same subject before a treatment and again after the treatment. A statistical
method called the paired t test takes the correlated responses into account.

The platform produces a graph of the paired differences by the paired means, and the paired ¢
test results for all three alternative hypotheses. Additional features provide for more than two
matched responses and for a grouping column to test across samples, in a simple version of
repeated measures analysis.

Figure 20.1 Example of Matched Pairs Analysis

4> Matched Pairs
4 Difference: Tympanic-Oral

Difference: Tympanic-Oral
(=}

97 a8 99 100 101 102 103
Mean: (Tympanic+Oral)/2

Tympanic 99,63 t-Ratic  8.030246
Oral 93.51 DF 19
Mean Difference 1.12 Prob = |t|

Std Error 013947 Prob > t

Upper 95% 141192 Prob <t  1.0000
Lower 95% 082808

N 20

Correlation 0.87389
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Overview of the Matched Pairs Platform

The Matched Pairs platform compares row-by-row differences between two response
columns using a paired f test. Often, the two columns represent measurements on the same
subject before and after some treatment. Alternatively, the measurements could represent data
taken on the same subject with two different instruments.

If you have paired data arranged in two data table columns, then you are ready to use the
Matched Pairs platform. However, if all of your measurements are in a single column, then
perform one of the following tasks:

* Use the Split option in the Tables menu to split the column of measurements into two
columns. Then you can use the Matched Pairs platform.

* For two response columns, create a third column that calculates the difference between the
two responses. Then test that the mean of the difference column is zero with the
Distribution platform.

e For the two responses stored in a single column, you can do a two-way analysis of
variance. One factor (the ID variable) identifies the two responses and the other factor
identifies the subject. Use the Fit Y by X Oneway platform with a blocking variable (the
subject column), or use the Fit Model platform to do a two-way ANOVA. The test on the
ID factor is equivalent to the paired f test.

Note: If the data are paired, do not do a regular independent ¢ test. Do not stack the data into
one column and use the Fit Y by X One-way ANOVA on the ID without specifying a block
variable. To do this has the effect of ignoring the correlation between the responses. This
causes the test to overestimate the effect if responses are negatively correlated, or to
underestimate the effect if responses are positively correlated.

Example of Comparing Matched Pairs

This example uses the Therm.jmp sample data table. The data contains temperature
measurements on 20 people. Temperature is measured using two types of thermometers: oral
and tympanic (ear). You want to determine whether the two types of thermometers produce
equal temperature readings. Note that the differences in temperature between the different
people are not important. The matched pairs analysis is testing the differences between the
thermometers.

1. Select Help > Sample Data Library and open Therm.jmp.
2. Select Analyze > Specialized Modeling > Matched Pairs.

3. Select Oral and Tympanic and click Y, Paired Response.
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4. Click OK.

The report window appears.

Figure 20.2 The Matched Pairs Report Window

4> Matched Pairs
4 Difference: Tympanic-Oral

Difference: Tympanic-Oral
(=}

97 a8 99 100 101 102 103
Mean: (Tympanic+Oral)/2

Tympanic 99,63 t-Ratic  8.030246
Oral 93.51 DF 19
Mean Difference 1.12 Prob = |t|

Std Error 013947 Prob > t

Upper 95% 141192 Prob <t  1.0000
Lower 95% 082808

N 20

Correlation 0.87389

The results show that, on average, the tympanic thermometer measures 1.12 degrees higher
than the oral thermometer. The small p-value (Prob > |tl) indicates that this difference is
statistically significant, and not due to chance.

Note that this matched pairs analysis does not indicate which thermometer is correct (if
either), but indicates only that there is a difference between the thermometers.
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Launch the Matched Pairs Platform

Launch the Matched Pairs platform by selecting Analyze > Specialized Modeling > Matched
Pairs.

Figure 20.3 The Matched Pairs Launch Window

Provides a paired t test for matched variables.

Select Columns Cast Selected Columns into Roles Action

~ /4 Columns required numeric

o reguied rumeric

A Tympanic

dl difference ontional
opti

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Y, Paired Response Provide the two response columns. For information about analyzing
more than two responses, see “Multiple Y Columns”.

X, Grouping Provide a grouping variable to compare the differences across groups. See
“Across Groups”.

Weight Identifies one column whose numeric values assign a weight to each row in the
analysis.

Freq Identifies one column whose numeric values assign a frequency to each row in the
analysis.

By Performs a separate matched pairs analysis for each level of the By variable.

After you click OK, the Matched Pairs report window appears. See “The Matched Pairs
Report”.

Multiple Y Columns

You can have more than two responses. If the number of responses is odd, all possible pairs
are analyzed. The following table shows an example for three responses.

Y1 by Y2 Y1by Y3
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Y2 by Y3

If the number of responses is even, the Matched Pairs platform asks whether you want to do
all possible pairs. If you do not do all possible pairs, adjacent responses are analyzed as a pair.
The following table shows the arrangement of analyses for four responses.

Y1 by Y2 Y3 by Y4

The Matched Pairs Report

Follow the instructions in “Example of Comparing Matched Pairs” to produce the report
window shown in Figure 20.4.

The Matched Pairs report shows a Tukey mean-difference plot, summary statistics, and the
results of the paired ¢ test. See “Difference Plot and Report”. If you specified an X, Grouping
variable, the report also includes the Across Groups report. See “Across Groups”.

Figure 20.4 Example of Matched Pairs Report

4> Matched Pairs
4 Difference: Tympanic-Oral

Difference: Tympanic-Oral
(=}

97 a8 99 100 101 102 103
Mean: (Tympanic+Oral)/2

Tympanic 99,63 t-Ratic  8.030246
Oral 93.51 DF 19
Mean Difference 1.12 Prob = |t|

Std Error 013947 Prob > t

Upper 95% 141192 Prob <t  1.0000
Lower 95% 082808

N 20

Correlation 0.87389
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Note: The red triangle menu provides additional options that can add reports to the initial
report window. See “Matched Pairs Platform Options”.

Difference Plot and Report

The Difference plot shows differences by means. In the Difference plot, note the following:

¢ The mean difference is shown as the horizontal line, with the 95% confidence interval
above and below shown as dotted lines. If the confidence region includes zero, then the
means are not significantly different at the 0.05 level. In this example, the difference is
significant.

e If you add a reference frame, the mean of pairs is shown by the vertical line. For more
information about a reference frame, see “Matched Pairs Platform Options”.

The Difference report shows the mean of each response, the difference of the means, and a
confidence interval for the difference. The Difference report also shows the results of the
paired ¢ test.

Across Groups

Note: The Across Groups report appears only if you have specified an X, Grouping variable.

The Across Groups analysis corresponds to a simple repeated measures analysis. (You can get
the same test results using the Manova personality of the Fit Model platform.)

Mean Difference Shows the mean of the difference across rows in each group between the
two paired columns. In other words, this is the within-subject by across-subject
interaction, or split-plot by whole-plot interaction.

Mean Mean Shows the mean of the mean across rows in each group across the two paired
columns. In other words, this is the across-subject or whole-plot effect.

Test Across Groups Two F tests determine whether the across-groups values are different:

Mean Difference Tests that the change across the pair of responses is different in
different groups.

Mean Mean Tests that the average response for a subject is different in different groups

Related Information

¢ “Example Comparing Matched Pairs across Groups”
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Matched Pairs Platform Options

The Matched Pairs red triangle menu contains the following options:

Plot Dif by Mean Shows or hides the plot of the paired differences by paired means. For a
detailed description of this plot, see “Difference Plot and Report”.

Plot Dif by Row Shows or hides the plot of paired differences by row number.

Reference Frame Shows or hides the reference frame on the Plot Dif by Mean plot. A
rectangle showing where a plot of Y2 by Y1 would be located inside the plot, tilted and
possibly squished. A vertical red line is shown representing the mean of means. The
reference frame is shown initially when the range of the differences is greater than half the
range of the data.

Wilcoxon Signed Rank Shows or hides the Wilcoxon signed rank test. The Wilcoxon signed
rank test is applied to the paired differences. It is a nonparametric test that compares the
sizes of the positive differences to the sizes of the negative differences. The test uses the
Pratt method to address zero differences. The test also assumes that the distribution of
differences is symmetric. See Basic Analysis. See also Lehman (2006), Conover (1999,

p- 350), and Cureton (1967).

Sign Test Shows or hides the sign test. This is a nonparametric version of the paired ¢ test
that uses only the sign (positive or negative) of the difference for the test.

Set o Level Changes the alpha level used in the analyses. Affects the confidence intervals in
the report and on the plot.

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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Example Comparing Matched Pairs across Groups

This example uses the Dogs.jmp sample data table. This example shows you how to produce
both a Matched Pairs Across Groups report and the corresponding MANOVA report using Fit
Model.

Select Help > Sample Data Library and open Dogs.jmp.
Select Analyze > Specialized Modeling > Matched Pairs.

1
2
3. Select LogHist0 and LogHist1 and click Y, Paired Response.
4. Select drug and click X, Grouping.

5

Click OK.
The report on the left in Figure 20.5 appears.
Now produce the Fit Model report using the same data table.

Select Analyze > Fit Model.

Select LogHist0 and LogHist1 and click Y.
Select drug and click Add.

Select the Manova personality.

Click Run Model.

In the Response Specification report, select Repeated Measures from the Choose
Response menu.

7. Click OK.

AL
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Figure 20.5 Examples of Matched Pairs across Groups and Fit Model MANOVA with
Repeated Measures

4 Across Groups 4(=Manova Fit
Mean b S
drug Count Difference Mean Mean Response Specification
merphine g 0.8822 -2.264 M 16
trimeth 8 1.5217 -1.959 DFE 14
P Parameter Estimates
Test Across
Groups FRatio  Prob>F I Least Squares Means

0.3991 Within Pairs Y Axis
(4222 Among Pairs X Axis

Mean Difference
Mean Mean

I Partial Correlation
I’ Overall E&H Matrices
4 =|Between Subjects
' M Matrix
I M-transformed Parameter Estimates
¢ = All Between

4i=drug
Test Value  Exact F NumDF DenDF Prob=F
FTest 0.048824 0.6835 1 14 04222

Within Subjects

I M-transformed Parameter Estimates

I =1 All Withjn Interactions

P = Time

4= Time*drug
Test Value Exact F NumDF DenDF Prob>F

FTest 0.0540433 0.7566 1 14 03891

The F Ratio for the Mean Difference in the Across Groups report corresponds to the F Ratio for
Time*drug under the Within Subjects report. The F Ratio for the Mean Mean in the Across
Groups report corresponds to the F Ratio for drug under Between Subjects in the Manova Fit
report.

Statistical Details for the Matched Pairs Platform

® “Graphics for Matched Pairs”

* “Correlation of Responses”
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Graphics for Matched Pairs

The primary graph in the platform is a Tukey mean-difference (Cleveland 1994, p. 130). This
graph plots the difference of the two responses on the vertical axis against the mean of the two
responses on the horizontal axis. This graph is the same as a scatterplot of the two original
variables, but turned 45 degrees. A 45 degree rotation and rescaling turns the original
coordinates into a difference and a mean.

Figure 20.6 Example of Transforming to Difference by Mean, Rotated by 45 Degrees
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Correlation of Responses

In most cases where the pair of measurements is taken from the same individual at different
times, they are positively correlated. However, if they represent competing responses, the
correlation can be negative.

Figure 20.7 shows how the positive correlation of the two responses becomes the small
variance on the difference (the vertical axis). If the correlation is negative, the ellipse is
oriented in the other direction and the variance of the rotated graph is large on the vertical
axis.

Figure 20.7 Examples of Positive Correlation Before and After Rotation
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Modeling Utilities

Exploring Data for Outliers, Missing Values, and Patterns

Modeling Utilities is a collection of utilities that are designed to assist in the data cleaning and
pre-processing stages of data analysis. Each utility has exploratory tools to give you a more
thorough understanding of your data. With Modeling Ultilities, you can do the following:

¢ Explore outliers in both the univariate and multivariate cases.
¢ Explore and impute missing values in your data.

¢ Explore and find unusual features or patterns in your data.

Figure 21.1 Multivariate k-Nearest Neighbor Outlier Example

4 K Nearest Neighbors

||Exc|udeSeIected Rows||ScatterpIotMatrix||Save|\|l\| Distances” Close ||

5000 rows analyzed.
20 20

1
2

in

Distance to
Neighbor k
-
.
Distance to
Neighbor k

0 1000 2000 3000 4000 5000 0 1000 2000 3000 4000 5000
Row Mumber Row Mumber

3
5

Distance to
Neighbor k

Distance to
Neighbor k

0 1000 2000 3000 4000 5000 0 1000 2000 3000 4000 5000
Row Mumber Row Mumber

-8

Distance to
Neighbor k

0 1000 2000 3000 4000 5000
Row Mumber



404 Modeling Utilities Chapter 21
Predictive and Specialized Modeling

Contents
Explore Outliers Utility ............. ... 405
Example of the Explore Outliers Utility. ......... ... ... .. i, 405
Launch the Explore Outliers Utility............. .. ... o oo oo 409
Quantile Range Outliers. . ......... ... .. . 410
Robust FitOutliers ....... ... i 413
Robust PCAQutliers ............ i i 415
K Nearest Neighbor Outliers. .. ......... ... e 418
Explore Outliers Utility Options. . ...........o i i 420
Additional Examples of the Explore Outliers Utility............... ... ... ... ... 421
Explore Missing Values Utility ............... e 423
Example of the Explore Missing Values Utility .............. ... 424
The Missing Value Report .......... . i 426
Explore Missing Values Utility Options .......... ... ... i, 432
Explore Patterns Utility ............ 433
Example of the Explore Patterns Utility ............... ... ... o i .. 433
Launch the Explore Patterns Utility........... ... ... ... oo o o i i 436
Explore Patterns Report . ...... ... 437
Explore Patterns Utility Options. ....... ... i 438
Additional Example of the Explore Patterns Utility ............................... 442

Statistical Details for the Explore Patterns Utility ................................. 444



Chapter 21 Modeling Utilities 405
Predictive and Specialized Modeling Explore Ouitliers Utility

Explore Outliers Utility

The Explore Outliers tool provides four different options to identify, explore, and manage
outliers. Exploring and understanding outliers in your data is an important part of analysis.
Outliers in data can be due to mistakes in data collection or reporting, measurement systems
failure, the inclusion of error or missing value codes in the data set, or simply an unusual
value. The presence of outliers can distort estimates and bias results toward those outliers.

Outliers also inflate the sample variance. Sometimes retaining outliers in data is necessary,
however, and removing them could underestimate the sample variance and bias the data in
the opposite direction.

Whether you remove or retain outliers, it is a good practice to locate them. There are many
ways to visually inspect for outliers. For example, box plots, histograms, and scatter plots can
easily display these extreme values. See Discovering [MP.

The Explore Outliers tool provides the following options:
Univariate There are two options for exploring outliers in your univariate data.

Quantile Range Outliers Uses the quantile distribution of each column to identify
outliers as extreme values. This tool is useful for discovering missing value or error
codes within the data. This is the recommended method to begin exploring outliers in
your data. See “Quantile Range Outliers”.

Robust Fit Outliers Finds robust estimates of the center and spread of each column and
identifies outliers as those data points that are far from those values. See “Robust Fit
Outliers”.

Multivariate There are two options for exploring outliers in your multivariate data.

Robust PCA Outliers Decomposes data into a low-rank matrix and residuals and uses
the residuals to detect outliers. See “Robust PCA Outliers”.

K Nearest Neighbor Outliers Identifies outliers as values that are far from their k-nearest
neighbors. See “K Nearest Neighbor Outliers”.

Example of the Explore Outliers Utility

Use the Explore Outliers utility to identify outliers that can then be examined using the
Distribution platform. The Probe.jmp sample data table contains 387 characteristics (the
Responses column group) measured on 5800 semiconductor wafers. The Lot ID and Wafer
Number columns uniquely identify the wafer. You are interested in identifying outliers within
a select group of columns of the data set.

1. Select Help > Sample Data Library and open the Probe.jmp sample data table.
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2. Select Analyze > Screening > Explore Outliers.
Click the triangle next to Responses(387/0) to show all of the columns in the group.

4. Select columns VDP_M1 through VDP_SICR and click Y, Columns. There should be 14
columns selected.

Figure 21.2 Explore Outliers Launch Window

Identifies, explores, and manages outliers in univariate or multivariate data.

Select Columns Cast Selected Columns into Roles Action
*|394 Columns 4 vor mn
Enter column name 2o A vop_mz
ith Lot 1D Al vDP_MNBASE
th Wafer Number Al VDP_NEMIT
th Process ﬁ\«"DP_NENBNI -m

Die X VDP_MSINK
: DieV Al VDP_PBASE
ih site 4 vop_peL
Al Start Time 4 vop_pcoLL
A Responses (387/0) A vDP_PEMIT

4l DELL_RPMER 4l VDP_PINNBASE

4l DELL_RPPBR 4l VDP_PINPBASE

a4 DELW_M1 4 vDP_PSINK

4l DELW M2 4 VDP_SICR

4l DELW_NBASE optional numeric

Al DELW_NEMIT optional mameric

4l DELW_NEMBNI

4l DELW_NSINK optionat

ol DELW_PBASE optional

4 DELW_PCOLL

5. Click OK.
6. Click Quantile Range Outliers.

The Quantile Range Outliers report shows each column and lists the number and identity
of the outliers found.

7. In the Quantile Range Outliers report, select Show only columns with outliers. This limits
the list of columns to only those that contain outliers.

Note that several columns contain outlier values of 9999. Many industries use nines as a
missing value code.

8. In the Nines report, select each column.
9. Click Add Highest Nines to Missing Value Codes.

A JMP Alert indicates that you should use the Save As command to preserve your original
data.

10. Click OK.
11. In the Quantile Range Outliers report, click Rescan.

12. Select Restrict search to integers.
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In continuous data, integer values are often error codes or other coded data values. Notice
that no additional error codes are included in this set of columns.

13. Deselect Restrict search to integers.

Examine the Data

1
2
3.
4

Select all of the remaining columns in the Quantile Range Outliers report.

Click Select Rows.

Select Analyze > Distribution.

Assign the selected columns to the Y, Columns role. Because you selected these column
names in the Quantile Range Outliers report, they are already selected in the Distribution

launch window.
Click OK.

Figure 21.3 Distribution of Columns with Outliers Selected
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In columns VDP_M1 and VDP_PEMIT, notice that some of the selected outliers are
somewhat close to the majority of data. For the rest of the columns, the selected outliers
appear distant from the majority of data. Investigate the data points and exclude them

from your analyses.
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Refine Excluded Outliers

1. In the Quantile Range Outliers report, hold Ctrl and deselect columns VDP_M1 and
VDP_PEMIT.

With the remaining columns selected in the report, click Exclude Rows.
Change Q to 20.

Click Rescan.

Select columns VDP_M1 and VDP_PEMIT in the report.

Click Select Rows.

SN L T

Reexamine the Data

1. Examine the Distributions report again. Notice the selected outliers are now separate
enough from the majority of the data to select and exclude them from your analyses.

2. In the Quantile Range Outliers report, click Exclude Rows.

3. In the Distributions report, click the Distributions red triangle and select Redo > Redo
Analysis.

Figure 21.4 Distributions of Columns with Outliers Excluded
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The displays of the distributions of the data are now more informative without the
outliers.
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Launch the Explore Outliers Utility
To launch Explore Outliers, select Analyze > Screening > Explore Outliers.

Note: The Explore Outliers commands analyze only columns with a Continuous modeling
type. Other columns can be entered in the launch window but are ignored.

Figure 21.5 Explore Outliers Utility Launch Window

Identifies, explores, and manages cutliers in univariate or multivariate data.

Select Columns Cast Selected Columns into Roles Action
Enter column name P - optional numeric
ik Banding?

A timestamp

th cylinder number optional numeric
th press

ik job number optional

[> Predictors (32/0)

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Y, Columns Specifies the columns that you want to analyze.
Validation Specifies a validation column that is used for Robust PCA Outliers.

Label Specifies a column that replaces row numbers in multivariate analysis reports with
labels.

By A column or columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

After you click OK, the Explore Outliers report appears. You are presented with the following
four outlier analysis commands:

*  “Quantile Range Outliers”

* “Robust Fit Outliers”

* “Robust PCA Outliers”

e “K Nearest Neighbor Outliers”
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Tip: To run an outlier analysis across all levels of a By variable, press Ctrl and click the desired
outlier analysis command button.

Quantile Range Outliers

The Quantile Range Outliers method of outlier detection uses the quantile distribution of the
values in a column to locate extreme values. Quantiles are useful for detecting outliers because
there is no distributional assumption associated with them. Data are simply sorted from
smallest to largest. For example, the 20th quantile is the value at which 20% of values are
smaller. Extreme values are found using a multiplier of the interquantile range, the distance
between two specified quantiles. For more information about how quantiles are computed,
see Basic Analysis.

The Quantile Range Outliers utility is also useful for identifying missing value codes stored
within the data. As noted earlier, in some industries, missing values are entered as nines (such
as 999 or 9999). This utility finds any nines greater than the upper quartile as suspected
missing value codes. The utility then enables you to add those missing value codes as a
column property in the data table.

Quantile Range Outliers Options

The Quantile Range Outliers panel enables you to specify how outliers are to be identified and
how you want to manage them.

Figure 21.6 Quantile Range Outliers Window

4 Quantile Range Outliers

Qutliers are values Q times the interquantile range past the lower and upper quantiles.

Tail Quantile 0.1 Select columns and choose an acticn.
Q 3 Identify Qutliers in Table

[] Restrict search to integers Select Rows | | Color Cells

[] Show only columns with outliers Exclude Rows

Clear Outliers in Table

|Add to Missing Value Codes| |F0rmu|a Columns|

| Change to Missing | | Formula Script |

An outlier is considered any value more than Q times the interquantile range from the lower
and upper quantiles. You can adjust the value of Q and the size of the interquantile range.

Tail Quantile The probability for the lower quantile that is used to calculate the interquantile
range. The probability of the upper quantile is considered 1 - Tail Quantile. For example, a
Tail Quantile value of 0.1 means that the interquantile range is between the 0.1 and 0.9
quantiles of the data. The default value is 0.1.
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Q The multiplier that determines the outlier threshold. Values that fall beyond Q times the
interquantile range past the Tail Quantile or 1 - Tail Quantile values are identified as
outliers. Large values of Q provide a more conservative set of outliers than small values.
The default is 3.

Restrict search to integers Restricts outlier values to only integer values. This setting limits
the search for outliers in order to find industry-specific missing value codes and error
codes.

Show only columns with outliers Limits the list of columns in the report to those that
contain outliers.

After the report is displayed using your specifications, there are many ways to act on these
extreme values. You can select the outliers in a column by selecting the specified column in the
Quantile Range Outliers report.

Tip: If no columns are selected in the report and you click one of the following buttons, a JMP
Alert appears that enables you to select all of the columns.

Select Rows Selects the rows of outliers in the selected columns in the data table.

Exclude Rows Turns on the exclude row state for outliers in the selected columns in the
Quantile Range Outliers Report. Click Rescan to update the Quantile Range Outliers
report.

Color Cells Colors the cells of the selected outliers in the data table.
Color Rows Colors the rows containing outliers for the selected columns in the data table

Add to Missing Value Codes Adds the selected outliers to the missing value codes column
property. Use this option to identify known missing value or error codes within the data.
Missing value and error codes are often integers and are sometimes a series of nines. Click
Rescan to update the Quantile Range Outliers report.

Note: Add to Missing Value Codes is not available with Quantile Range Outliers if a By
variable is specified in the launch window.

Change to Missing Changes the outlier value to a missing value in the data table. Use
caution when changing values to missing. Change values to missing only if the data are
known to be invalid or inaccurate. Click Rescan to update the Quantile Range Outliers
report.

Note: If the selected outlier has been added to the missing value codes, the outlier is not
changed to a missing value.
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Formula Columns Creates a new formula column for each column that is specified in the
launch window. Each new column contains the original column’s value if the value is
within the outlier limits and is set to missing otherwise. The new columns are prefixed or
suffixed by a user specified name to distinguish them from the original columns. By
default, the suffix is set to “Culled”.

Formula Script Creates a script that is added to the data table. When the script is run, it
creates a new formula column for each column that is specified in the launch window.
Each new column contains the original column’s value if the value is within the outlier
limits and is set to missing otherwise. The new columns are prefixed or suffixed by a user
specified name to distinguish them from the original columns. By default, the suffix is set
to “Culled”.

Rescan Rescans the data after outlier actions have been taken.
Note: Press Ctrl and click Rescan to rescan across all command groups.
Close Closes the Quantile Range Outliers panel.

Note: Press Ctrl and click Close to close all command windows.

Quantile Range Outliers Report

The Quantile Range Outliers report lists all columns with the outliers found using the
specified options. The report shows values for the upper and lower quantiles along with their
low and high thresholds. Values outside of these threshold limits are considered outliers. The
number of outliers in each column is indicated. The values of each outlier are listed in the last
column of the report. Outliers that occur more than once in a column are listed with their
count in parentheses. To remove columns without outliers from the report, select Show only
columns with outliers.

There are several things to look for when reading this report.

e Error codes. For some continuous data, suspiciously high integer values are likely to be
error codes. For example, if your upper and lower quantile values are all less than 0.5,
outliers such as 1049 or -777 are likely to be error codes.

e Zeros. Sometimes zeros can indicate missing values. If the majority of your data is
reasonably large and you notice zeros as outliers, they are likely to be due to missing data.
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Nines Report

The Nines report within the Quantile Range Outliers window shows a list of columns that
contain probable missing value codes. These missing value codes are a series of nines (usually
9999) and are the highest number that is all nines and also higher than the upper quantile. If
the count is high, it is likely that these outliers are actually missing value codes. If the count is
very low, you should explore further to determine whether the value is an outlier or a missing
value code. The Nines Report includes the upper quantile value.

This report is displayed only when probable missing value codes are identified.

Add Highest Nines to Missing Value Codes Adds the selected outlier values to the missing
value codes column property. You must click Rescan to update the Quantile Range
Outliers report.

Note: Add Highest Nines to Missing Value Codes is not available with Quantile Range
Outliers if a By variable is specified in the launch window.

Change Highest Nines to Missing Replaces the selected outlier values with missing values
in the data table.

Note: The first time you use choose an action (such as Change to Missing or Exclude Rows) to
change your data, the alert window warns you to use the Save As command to save your data
table as a new file to preserve a copy of your original data. When this window appears, click
OK. If you decide to save your new data file, you will automatically be prompted to save the
file with a new name.

Robust Fit Outliers

Robust estimates of parameters are less sensitive to outliers than non-robust estimates. Robust
Fit Outliers provides several types of robust estimates of the center and spread of your data to
determine thresholds for identifying outliers.

Figure 21.7 Robust Fit Outliers Window

4 Robust Fit Outliers
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Cauchy Identify Outliers in Table
rtil
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Robust Fit Outliers Options

Given a robust estimate of the center and spread, outliers are defined as those values that are
K times the robust spread from the robust center. The Robust Fit Outliers window provides
several options for calculating the robust estimates and multiplier K as well as provides tools
to manage the outliers found.

Huber Uses Huber M-Estimation to estimate center and spread. This option is the default.
See Huber and Ronchetti (2009).

Cauchy Assumes a Cauchy distribution to calculate estimates for the center and spread.
Cauchy estimates have a high breakdown point and are typically more robust than Huber
estimates. However, if your data are separated into clusters, the Cauchy distribution tends
to consider only the half of the data that makes closer clusters, ignoring the rest.

Quartile Uses the interquartile range (IQR) to estimate the spread. The estimate for the center
is the median. The estimate for spread is the IQR divided by 1.34898. Dividing the IQR by
this factor makes the spread correspond to one standard deviation if the data are normally
distributed.

K The multiplier that determines outliers as K times the spread away from the center. Large
values of K provide a more conservative set of outliers than small values. The default is 4.

Show only columns with outliers Limits the list of columns in the report to those that
contain outliers.

Once the report is displayed using your specifications, there are many ways to explore these
extreme values. You can select the outliers in a row by selecting the specified row in the
Robust Estimates and Outliers report.

Tip: If no columns are selected in the report and you click one of the following buttons, a JMP
Alert appears that enables you to select all of the columns.
Select Rows Selects the rows containing outliers for the selected columns in the data table.

Exclude Rows Sets the Exclude Row state for outliers in the selected columns in the data
table. Click Rescan to update the Robust Estimates and Outliers report.

Color Cells Colors the cells of the selected outliers in the data table.
Color Rows Colors the rows containing outliers for the selected columns in the data table.

Add to Missing Value Codes Adds the selected outliers to the missing value codes column
property for the selected columns. Use this option to identify known missing value or
error codes within the data. Click Rescan to update the Robust Estimates and Outliers
report.
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Note: Add to Missing Value Codes is not available with Robust Fit Outliers if a By variable
is specified in the launch window.

Change to Missing Changes the outlier value to a missing value in the data table. Click
Rescan to update the Robust Estimates and Outliers report.

Formula Columns Creates a new formula column for each column that is specified in the
launch window. Each new column contains the original column’s value if the value is
within the outlier limits and is set to missing otherwise. The new columns are prefixed or
suffixed by a user specified name to distinguish them from the original columns. By
default, the suffix is set to “Culled”.

Formula Script Creates a script that is added to the data table. When the script is run, it
creates a new formula column for each column that is specified in the launch window.
Each new column contains the original column’s value if the value is within the outlier
limits and is set to missing otherwise. The new columns are prefixed or suffixed by a user
specified name to distinguish them from the original columns. By default, the suffix is set
to “Culled”.

Rescan Rescans the data after outlier actions have been taken.

Note: Press Ctrl and click Rescan to rescan across all command groups.

Close Closes the Robust Fit Outliers panel.

Note: Press Ctrl and click Close to close all command windows.

Robust PCA Outliers

You can use the Robust PCA Outliers utility to quickly identify outlier cells in correlated
multivariate data. This method is useful because many other multivariate approaches identify
only the outlier rows. Before the method is applied to the data, the columns are first centered
(optional) and scaled. The scaling factor is defined as follows:

max [Q(.75) - Q(.50), Q(.50) - Q(.25)] / [normalQuantile(0.75)]

where

Q(p) is the p' quantile

Note: If Q(75) or Q(25) are equal to the median, then more extreme quantiles are used until
there is a non-zero range.
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After the data are centered and scaled, the Robust PCA Outliers utility performs a sequence of
singular value decompositions and thresholding steps to decompose the data matrix. The data
are decomposed into a low-rank matrix and a sparse matrix of residuals. The thresholding is
done so that the residuals are either very large or outliers or very close to zero for non-outliers.
The algorithm determines a matrix rank appropriate to capture the systematic variation
without the outliers or small noise. Outliers that are not in the low-rank space are detected
based on their residuals. See Candes et al (2009) and Lin et al (2013). If there are missing
values, they are initially replaced with zeros after the centering and scaling steps. Then, after
each singular value decomposition (SVD) iteration, the missing values are updated by their
predicted values from the SVD.

Robust PCA Outliers Report

When you select Robust PCA Outliers from the list of commands, you must specify a value for
Lambda and select if the data should be centered. If you Shift+Click the Robust PCA Outliers
button, the following options are also available:

Lambda Specifies a value that determines the sparsity of the matrix of residuals. For larger
values of Lambda, the matrix of residuals is more sparse. For a data table with 7 training
rows and p columns, the default value of Lambda is defined as follows:

2
~/max(n, p)

Max Iterations Specifies the maximum number of SVD iterations.

A=

Converge Criterion Determines when to stop the algorithm.

Outlier Threshold Specifies the outlier threshold that determines which outliers are shown
in the Cell Large Residuals table. An observation is shown if the scaled residuals is larger
than the following:

min[0.99 x max{abs(residuals)}, Outlier Threshold]
By default, the Outlier Threshold is 2.

Center Determines if the data are centered before the Robust PCA Outlier algorithm is
performed.

Note: If the number of rows is less than or equal to 10, the data are not centered.

Scale Determines if the data are scaled before the Robust PCA Outlier algorithm is
performed.

Note: If the number of rows is less than or equal to 10, the data are not scaled.
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The Robust PCA Outliers report contains a table with information about the method. This
table includes the rank of the low-rank matrix, the number of SVD iterations, the convergence
criterion, the value of Lambda, and the number of imputed missing values. The report also
contains the following tables and reports:

Cell Large Residuals A table that shows the largest outlier cells. The number of cells shown
is determined by the Outlier Threshold. The table contains the column name and row
number of the cell, the residual value, and the scaled residual value.

Tip: To color specific outlier cells in the data table, select rows in the Cell Large Residuals
table and click Colorize.

Row Root Mean Square A table that shows the root mean square value for each row in the
data table. The root mean square is calculated using the scaled residuals.

Tip: If you select a row in the Row Root Mean Square table, the corresponding row is
selected in the data table.

Column Root Mean Square A table that shows the root mean square value for each column
specified in the launch window. The root mean square is calculated using the scaled
residuals.

Tip: If you select a row in the Column Root Mean Square table and click Select Columns,
the corresponding column is selected in the data table.

Snapshot A graphical representation of the outlier cells in the data table. The outlier cells are
colored in red.

Residuals The matrix of residuals from the matrix decomposition. A cell is colored if the
absolute value of the scaled residual is greater than the following:

min[0.99 x max{abs(residuals)}, Outlier Threshold]
Low Rank Approximation The matrix of scaled residuals from the matrix decomposition.

Singular Values The vector of singular values from the SVD.

Robust PCA Outliers Options

There are buttons at the bottom of the Robust PCA Outliers report that provide options to
save different parts of the report.

Close Closes the Robust PCA Outliers report.

Save Large Outliers Saves the information in the Cell Large Residuals table to a new data
table.
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Save Cleaned Opens a window that provides several techniques to clean the outliers based
on thresholds and save new columns to the data table.

Trim Trims outlier cells if the corresponding absolute scaled residual is greater than the
specified threshold. By default, the threshold is 10. Select Color ™ to color the outlier
cells red. The trimmed cells are set to the value of the unscaled threshold.

Impute Sets outlier cells to the value of the low rank approximation if the corresponding
absolute scaled residual is greater than the specified threshold. By default, the
threshold is 100. Select Color M to color these cells green.

Make Missing Sets outlier cells to missing if the corresponding absolute scaled residual
is greater than the specified threshold. By default, the threshold is 1000. Select Color
to color these cells blue.

Color imputed from missing If selected, colors cells that originally had missing values
and were imputed.

Save Residuals Saves the residuals to new columns in the original data table.
Save Scaled Residuals Saves the scaled residuals to new columns in the original data table.

Save Low Rank Approx Saves the low-rank approximation to new columns in the original
data table.

K Nearest Neighbor Outliers

Use K Nearest Neighbor Outliers to identify an outlier based on distance to its nearest
neighbor. For each value of k, the K Nearest Neighbor Outliers utility displays a plot of the
Euclidean distance from each point to its kth nearest neighbor. You specify the largest value of
k, denoted as K. Plots are provided for k=1,2,3,5,... K, using the Fibonacci sequence to avoid
displaying too many plots.

Before the nearest neighbors are calculated, the columns are centered and scaled. The scaling
factor is as follows:

max [Q(.75) - Q(.50), Q(.50) - Q(.25)] / [normalQuantile(0.75)]

where

Q(p) is the pth quantile

Note: If Q(75) or Q(25) are equal to the median, then more extreme quantiles are used until
there is a non-zero range.
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This approach is sensitive to the specified value of k. A small value of k can miss identifying
points as outliers and a large value of k can falsely classify points as outliers:

® Suppose that the specified K is small, so that you are studying only a few neighbors. If
there is a cluster of more than K points that is far from the rest of the points, then the
points within the cluster have small distances to their nearest neighbors. You might be
unable to detect the cluster of outliers.

* Suppose that the specified K is large, so that you are studying a large number of neighbors.
If there are clusters with fewer than K data points, then the points within these clusters can
appear to be outliers. You might overlook the fact that the points form a cluster,
interpreting the individual cluster members as outliers instead.

K Nearest Neighbor Outliers Report

When you select K Nearest Neighbor Outliers from the list of commands, you must specify
the value of K to use as an upper bound for the farthest neighbor to be considered. You must
also specify whether missing values should be imputed. Notice that K is set to 8 and Impute
Missing is selected by default.

The report shows plots for select values of k up to the value K. The value of k for each plot is
displayed in its vertical axis label. It is of the form Distance to Neighbor k = <a>, where a is an
integer denoting the ath closest neighbor. Each plot shows the distance from the point in the ith
row to its a™ nearest neighbor. The points that have large distances from their neighbors,
across multiple values of k, are likely to be outliers.

The buttons above the plots do the following;:

Exclude Selected Rows Excludes rows corresponding to selected points from further
analysis. The rows are assigned the Excluded row state in the data table. You are asked if
you want to rerun or close the K Nearest Neighbors report. Rerunning the analysis
identifies new nearest neighbors. The plots are updated and the excluded points are not
shown.

Scatterplot Matrix Opens a separate window containing a scatterplot matrix for all columns
in the analysis. You can explore potential outliers by selecting them in the K Nearest
Neighbors plots and viewing them in the scatterplot matrix.

Save NN Distances Saves the distances from each row to its n" nearest neighbor as new
columns in the data table.

Close Closes the K Nearest Neighbors report.
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Largest Outliers

The report also includes a Largest Outliers table. This table contains the 20 observations with
the largest distances from their K" nearest neighbor. The table has the following columns:

Row The row number of the observation.

Distance The distance from the observation in the specified row and its K™ nearest neighbor.
The table is sorted by this column in descending order.

Nearest Neighbors Lists the row numbers for the k nearest neighbors. The first row number
is the closest nearest neighbor. The last row number is the K™ nearest neighbor and the
distance between this observation and the specified row is found in the Distance column.

Col<n> Specifies the column name for the corresponding RMS value.

RMS<n> Calculates the root mean squared differences across the k nearest neighbors for
each column. The five largest RMS values are displayed in order, where RMSI1 is the
maximum RMS value. The pth RMS value is calculated as follows:

K
2
2 BpiPp.i)
_ k=1
RMSP

K

where

D, is the p™ column

D, is the value of the p'™ column for row i

D, i is the value of the pth column for the k™ nearest neighbor of row i

Note: The number of Col and RMS columns shown in the Largest Outliers table is the
minimum of the number of columns specified in the launch and the number five.

Explore Outliers Utility Options

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.
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Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Additional Examples of the Explore Outliers Utility

Robust PCA Outliers Example

The Water Treatment.jmp data set contains daily measurement values of 38 sensors in an urban
waste water treatment plant. You are interested in exploring these data for potential outliers.
Potential outliers could include sensor failures, storms, and other situations.

Select Help > Sample Data Library and open Water Treatment.jmp.
Select Analyze > Screening > Explore Outliers.

Select the Sensor Measurements column group and click Y, Columns.
Click OK.

Shift+Click Robust PCA Outliers.

Enter 10 next to Outlier Threshold.

AL o

Use the default values for the other options.
7. Click OK.
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Figure 21.8 Robust PCA Outliers Report
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10.

The Cell Large Residuals table shows the cells that have a scaled residual greater than 10
or less than -10. There are several cells with large scaled residuals from the SED-S column.
If you look at the Column Root Mean Square table, it shows that the SED-S column does in
fact have the largest scaled Root Mean Square value. The row with the largest scaled Root
Mean Square value is row 60.

Click Save Cleaned at the bottom of the report.

This option enables you to adjust cells with large outliers by trimming the values,
imputing new values, or setting the cells to missing. The Save Cleaned Columns report
provides these options.

Select Impute. Trim is already selected by default.
Click OK.

There are 38 new Cleaned columns added to the Water Treatment.jmp data table. Since you
know row 60 had the largest scaled Root Mean Square value, scroll to this row to view
some of the cells that were trimmed and imputed. You can now use the cleaned columns in
any type of analysis.
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Figure 21.9 Cleaned Columns from Robust PCA Outliers
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Explore Missing Values Utility

The presence of missing values in a data set can affect the conclusions made using the data. If,
for example, several healthy participants dropped out of a longitudinal study and their data

continued on as missing, the results of the study can be biased toward those unhealthy

individuals who remained. Missing data values must not only be identified, they must also be

understood before further analysis can be conducted.

The Explore Missing Values utility provides several ways to identify and understand the
missing values in your data. It also provides methods for conducting multivariate normal
imputation for missing values. These imputation methods assume that data are missing at

random, which means that any differences between missing and non-missing data cannot be
explained by the values of the other variables in the study. If you suspect that missing values
are not missing at random, then consider using the Informative Missing procedure, which is
available in a number of platforms. See Fitting Linear Models.

Caution: Be careful when analyzing data after imputing missing values, as the results have

the potential to be biased.
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Example of the Explore Missing Values Utility

The Arrhythmia.jmp sample data table contains information from 452 patient
electrocardiograms (ECGs). The data was originally collected to classify different patterns of
ECGs as cardiac arrhythmia. However, there are missing values in this data table. You are
primarily interested in exploring these missing values and imputing them when necessary.
Since you can conduct missing value imputation only for columns that have a continuous
modeling type, you conduct your analysis in two stages.

Examine Missing Values

1. Select Help > Sample Data Library and open Arrhythmia.jmp.
2. Select Analyze > Screening > Explore Missing Values.

3. Select all columns (280 in all) and click Y, Columns.
4

Click OK. Select the Show only columns with missing check box.

Figure 21.10 Missing Value Report

£ |~|Explore Missing Values
< Commands

| Missing Value Report |Number of missing values for each column
| Missing Value Clustering |Hierarchica| clustering of rows and columns missingness
| Missing Value Snapshot |Patterns of missing values with graphical map

|Multivariate MNormal Imputation| Least squares predicticn from the nonmissing variables in each row

| Multivariate SVD Imputation | Imputation for wide problems using a singular value decompositicn
with the power-method adapted for missing values

| Automated Data Imputation | Automatically selects best dimensicn for low-rank approximaticn
based on the data and has streaming imputation capabilities

[* Automated Data Imputation Controls

£ Missing Columns

Number

Show only columns with missing | Column Missing
T ’
P 22

Select columns and choose an action. | gRsT 1
Coler Cells J 376
Exclude Rows| Heartrate 1

The Missing Columns report shown in Figure 21.10 indicates that only five columns have
missing data. Out of a total of 452 rows, Column J has 376 missing values. Because it is
largely missing, imputed values might not result in a meaningful analysis. For such data,
you could explore a model using the Informative Missing option for Column J in a
platform that supports the Informative Missing option.

Note that the two Imputation options, Multivariate Imputation and Multivariate SVD

Imputation, are not shown. A message indicates that imputation is disabled because some
columns included in the analysis were categorical. The data table contains several columns
that are numeric, but have a nominal modeling type. These cannot be used for imputation.
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Impute Missing Values

The five columns that have missing values are continuous. You proceed to impute values for
the four columns other than Column J using multivariate imputation for the continuous
columns in your data table. By doing so, you tacitly assume that the probabilities that values
are missing depend only on the values of the continuous variables and not on the values of
excluded nominal variables. To conduct this new analysis, you need to launch the Explore
Missing Values utility again.

1.
2.

Select Analyze > Screening > Explore Missing Values.
In the launch window, click the red triangle next to 280 Columns.

Use the columns filter menu to view only the columns with a Continuous modeling type
in the Select Columns list.

Select Modeling Type > Uncheck All.

This removes all columns from the Select Columns list.

Select Modeling Type > Continuous.

The Select Columns list now contains only the 207 columns that are Continuous.

Select all 207 columns. Then Ctrl-click the J column (to deselect it) and click Y, Columns.
Click OK.

Click Multivariate Normal Imputation.

A window appears and asks whether you want to use a Shrinkage estimator for
covariances.

Click Yes Shrinkage.

A JMP Alert appears, informing you that you should use the Save As command to
preserve your original data.

Click OK.

Figure 21.11 Imputation Report

£ Imputation Report

Undo |

32 missing values were replaced by least squares imputation A shrinkage
estimate was used, with off-diagonals scaled by a factor of 0.82034. 32 rows
and 4 columns were affected. There were 4 missing value pattems agoss
columns, Imputed values colored light blue,

The Imputation Report indicates how many missing values were imputed and the specific
imputation details. No missing data remain in the four columns that had missing values.
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Launch the Explore Missing Values Utility

Launch the Explore Missing Values modeling utility by selecting Analyze > Screening >
Explore Missing Values. Enter the columns of interest into the Y, Columns list. You can also
specify a By variable.

Note: You can enter only columns with a Numeric modeling type in the Explore Missing
Values utility.

The Missing Value Report

Figure 21.12 Missing Value Report for Continuous Variables in Arrhythmia.jmp.

£ |~|Explore Missing Values
< Commands

| Missing Value Report |Number of missing values for each celumn
| Missing Value Clustering |Hierarchica| clustering of rows and celumns missingness
| Missing Value Snapshot |Patterns of missing values with graphical map

|Multivariate MNormal Imputation| Least squares predicticn from the nonmissing variables in each row

| Multivariate SVD Imputation | Imputation for wide problems using a singular value decompositicn
with the power-method adapted for missing values

| Automated Data Imputation | Automatically selects best dimensicn for low-rank approximaticn
based on the data and has streaming imputation capabilities

[* Automated Data Imputation Controls

After you click OK in the launch window, the report opens to show a Commands outline and
a Missing Columns report. The commands are the following:

* “Missing Value Report”
* “Missing Value Clustering”
e “Missing Value Snapshot”

e “Multivariate Normal Imputation” (Not available if you entered a Numeric column with a
Nominal or Ordinal modeling type in the launch window.)

e “Multivariate SVD Imputation” (Not available if you entered a Numeric column with a
Nominal or Ordinal modeling type in the launch window.)

. ‘#ﬂ’o “Automated Data Imputation” (Not available if you entered a Numeric column with

a Nominal or Ordinal modeling type in the launch window.)

Tip: To run a missing value command across all levels of a By variable, press Ctrl and click the
desired command button.
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Missing Value Report

The Missing Value Report opens the Missing Columns report, which lists the name of each
column and the number of missing values in that column.

Show only columns with missing Removes columns from the list that do not have missing
values.

Close Closes the Missing Columns report.

Select Rows Selects the rows in the data table that contain missing values for the column(s)
that you select in the Missing Columns report.

Exclude Rows Applies the excluded row state for rows in the data table that contain missing
values for the column(s) that you select in the Missing Columns report.

Color Cells Colors the cells in the data table that contain missing values for the column(s)
that you select in the Missing Columns report.

Color Rows Colors the rows in the data table that contain missing values for the column(s)
that you select in the Missing Columns report.

Missing Value Clustering

Missing Value Clustering provides a hierarchical clustering analysis of the missing data.

* The dendrogram to the right of the plot shows clusters of missing data pattern rows. These
are the rows that you would obtain by using Tables > Missing Data Pattern.

¢ The dendrogram beneath the plot shows clusters of variables.

Use this report to determine whether certain groups of columns tend to have similar patterns
of missing values.

The rows of the plot are defined by the missing data patterns; there is a row for each pattern.
The columns correspond to the variables. Each red cell indicates a group of missing values for
the column listed beneath the plot. Hover over a cell to see the list of values represented. Click
in the plot to select missing data pattern rows. Vertical bars are displayed to indicate the
selected patterns.

Missing Value Snapshot

The Missing Value Snapshot shows a cell plot for the missing values. The columns represent
the variables. Black cells indicate a missing value. This plot is especially useful in
understanding missingness for longitudinal data, where subjects can withdraw from a study
before the end of the data collection period.
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Multivariate Normal Imputation

The Multivariate Normal Imputation utility imputes missing values based on the multivariate
normal distribution. The procedure requires that all variables have a Continuous modeling
type. The algorithm uses least squares imputation. The covariance matrix is constructed using
pairwise covariances. The diagonal entries (variances) are computed using all nonmissing
values for each variable. The off-diagonal entries for any two variables are computed using all
observations that are nonmissing for both variables. In cases where the covariance matrix is
singular, the algorithm uses minimum norm least squares imputation based on the
Moore-Penrose pseudo-inverse.

Multivariate Normal Imputation allows the option to use a shrinkage estimator for the
covariances. The use of shrinkage estimators is a way of improving the estimation of the
covariance matrix. For more information about shrinkage estimators, see Schéfer and
Strimmer (2005).

Note: If a validation column is specified, the covariance matrices are computed using
observations from the Training set.

Multivariate Normal Imputation Report

The imputation report explains the results of the multivariate imputation process. Results
include the following:

® Method of imputation (either least squares or minimum-norm least squares)
* How many values were replaced

* Shrinkage estimator on/off

* Factor by which the off-diagonals were scaled

¢ How many rows and columns were affected

¢ How many different missing value patterns there were

Once the imputation is complete, the cells corresponding to imputed values in the data table
are colored in light blue. If the Missing Columns report is open, it is updated to show no
missing values.

Click Undo to undo the imputation and replace the imputed data with missing values.

Multivariate SVD Imputation

The Multivariate SVD Imputation utility imputes missing values using the singular value
decomposition (SVD). This utility is useful for data with hundreds or thousands of variables.
Because SVD calculations do not require calculation of a covariance matrix, the SVD method is
recommended for wide problems that contain large numbers of variables. The procedure
requires that all variables have a Continuous modeling type.
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The singular value decomposition represents a matrix of observations X as X = UDV’, where U
and V are orthogonal matrices and D is a diagonal matrix.

The SVD algorithm used by default in the Multivariate SVD Imputation utility is the sparse
Lanczos method, also known as the implicitly restarted Lanczos bidiagonalization method
(IRLBA). See Baglama and Reichel (2005). The algorithm does the following;:

1. Each missing value is replaced with its column’s mean.
2. An SVD decomposition is performed on the matrix of observations, X.

3. Each cell that had a missing value is replaced by the corresponding element of the UDV’
matrix obtained from the SVD decomposition.

4. Steps 2 and 3 are repeated until the SVD converges to the matrix X.

Imputation Method Window

When you click Multivariate SVD Imputation, the Imputation Method window shows the
recommended settings.

Number of Singular Vectors Number of singular vectors that are computed and used in the
imputation.

Note: It is important not to specify too many singular vectors, otherwise the SVD and the
imputations do not change from iteration to iteration.

Maximum Iterations The number of iterations used in imputing the missing values.

Show lteration Log Opens a Details report that shows the number of iterations and gives
details about the criteria.

For large problems, a progress bar shows how many dimensions the SVD has completed. You
can stop the imputation and use that number of dimensions at any time.

Multivariate SVD Imputation Report
The imputation report explains the results of the multiple imputation process.

* Method of imputation
¢ How many values were replaced

e How many rows and columns were affected

Once the imputation is complete, the Missing Columns report is automatically shown
indicating no missing values in the columns that were imputed. Imputed values are displayed
in light blue.

Click Undo to undo the imputation and replace the imputed data with missing values.
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PRo Automated Data Imputation

The Automated Data Imputation (ADI) utility imputes missing values using a low-rank
matrix approximation method, also known as matrix completion. Once trained, the ADI
model is capable of performing missing data imputations for streaming data through scoring
formulas. Streaming data are added rows of observations that become available over time and
were not used for tuning or validating the imputed model. This utility is flexible, robust, and
automated to select the best dimension for the low-rank approximation. These features enable
ADI to work well for many different types of data sets.

A low-rank approximation of a matrix is of the form X =UDV' and can be viewed as an
extension of singular value decomposition (SVD). ADI uses the Soft-Impute method as the
imputation model and is designed such that the data determines the rank of the low-rank
approximation.

The ADI algorithm performs the following steps:

1. The data are partitioned into training and validation sets.
Each set is centered and scaled using the observed values from the training set.

For each partitioned data set, additional missing values are added within each column and
are referred to as induced missing (IM) values.

4. The imputation model is fit on the training data set along a solution path of tuning
parameters. The IM values are used to determine the best value for the tuning parameter.

5. Additional rank reduction is performed using the training data set by de-biasing the
results from the chosen imputation model in step 4.

6. Final rank reduction is performed to calibrate the model for streaming data and to prevent
overfitting. This is done by fitting the imputation model on the validation set, using the
rank determined in step 5 as an upper bound.
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Automated Data Imputation Controls

The ADI utility contains options for saving the imputed values and advanced controls.

Figure 21.13 ADI Controls

<4 Automated Data Imputation Controls

Options for Saving Imputed Values

() Create New Data Table
(®) Save Scoring Formula to Current Data Table
) Impute Values in Place

Advanced Controls With Recommended Settings:

Dimensicn Upper Bound:
Maximum lterations:
Proportion of Observations to Induce as Missing:
Proportion of Rows to Use for Validation:
Set Random Seed: Ijl

Options for Saving Imputed Values The following three options for saving the imputed
values for the ADI method are available:

Create New Data Table Creates a new data table that has the same dimensions as the
original data table. In the new data table, the columns selected in the launch window
contain the imputed values.

Save Scoring Formula to Current Data Table Saves a column group, named Imputed_, to
the current data table that contains the imputed columns specified in the launch
window. A hidden column, ADI Impute Column, is also added to the current data table
that contains the imputed vectors and the scoring formula used in the data imputation.
The column formulas automatically update if any additional rows are added to the
data table, enabling missing data imputation for streaming data. This is the default
option.

Impute Values in Place Imputes the missing values in the current data table. The
imputed values are displayed in light blue.

Advanced Controls Contains the following advanced controls, which default to
recommended settings based on the data:

Dimension Upper Bound Determines the maximum rank allowed in the low-rank
approximation. This is determined by the dimension of the matrix formed by the
chosen columns.

Maximum lterations Determines the number of values that are iterated over to
determine the tuning parameter for the imputation model. The default is 10.
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Proportion of Observations to Induce as Missing Determines the proportion of IM
values that are added to the training and validation sets. The default proportion for
each set is 0.2.

Proportion of Rows to Use for Validation Determines the proportion of rows to use in
the training and validation sets. The default proportion for the validation set is 0.3.

Set Random Seed Determines the random seed for ADI. Use this option to obtain
reproducible results.

Explore Missing Values Utility Options

ADI Loading Matrix (Available only for the ADI utility.) Shows or hides a report that contains
the columns that correspond to the factor loading for each component.

See Using [MP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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Explore Patterns Utility

Data can be messy, so it is sometimes hard to determine the validity of your data by visual
inspection alone. The Explore Patterns utility is a tool for detecting unusual or unexpected
patterns in your data. Although some patterns occur by chance or some innocent mechanism,
they might indicate data that has been falsified or tampered with. This utility is most useful
when the values are precise so that matches and patterns are less likely to happen by
coincidence. The Explore Patterns utility is also designed to handle large data tables
efficiently.

The Explore Patterns utility looks for duplicate values and duplicate sequences of values.
These types of patterns can indicate data tampering strategies such as pasting the same value
many times, pasting the same value across a range of cells, or copying a range of data and
pasting it somewhere else. The utility also analyzes properties of the formatted values to
determine whether the data are actual measurements or might have been generated by a
random number generator. There are also options to examine distribution properties and
detect linear relationships between columns across groups of rows.

Note: The Explore Patterns utility ignores excluded rows, but the results are not necessarily
equivalent to if you had deleted the row. For runs of rows, such as the Longest Runs and
Longest Duplicated Sequences options, an excluded row stops the run.

Example of the Explore Patterns Utility

The Nicardipine Lab Patterns.jmp sample data table is adapted from a study of the drug
Nicardipine. The data table contains 27 columns of numeric laboratory results. Use the
Explore Patterns Utility to determine whether there are any unexpected patterns in the
laboratory results.

1. Select Help > Sample Data Library and open the Nicardipine Lab Patterns.jmp sample data
table.

Select Analyze > Screening > Explore Patterns.

Select the Laboratory Results column group and click Y, Columns.
Click OK.

AR

Click the gray disclosure icon next to Univariate Summary to open the Univariate
Summary report.
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Figure 21.14 Explore Patterns Univariate Summary Report

£ Univariate Summary

Longest Runs Longest Duplicate Sequences
Starting Starting Starting

Column Row Count Value Rarity Column Row | Row J Count Rarity
Creatinine 2265 7 003336 189 Activated PTT 2816 3034 4 182
Hematocrit 3048 4 28999009 131 Prothrombin Time 2942 2966 6 149
Prothrombin Time 2931 6 12 1041 Hematocrit 3051 3057 3 146
BUN 2267 5 2,142 85 Leukocytes 547 1275 3 1141
LDH 3456 3 602 7.1 Creatinine 1464 1681 & 1.0
Activated PTT 1460 3 30.290990 6.2 Leukocytes 975 1485 3 108
Platelet 521 3 150 5.8 ALT 240 24325 3 105
Platelet 1002 3 336 5.1 Sodium 2339 2076 6 03
Creatine Kinase 3456 3 63 49 Leukocytes 456 2805 3 9.8
Activated PTT 3435 3 205 46 Activated PTT 1050 1055 4 04
ALT 3457 3 66 44 Potassium 1046 1067 6 04
co2 13090 4 82.612 40 Hemeglobin 1247 3273 3 92

The Univariate Summary report summarizes the longest runs and longest duplicate
sequences found across all of the columns. Each table is sorted by Rarity, a calculation of
how likely the run or sequence is to occur by chance. The column with the highest rarity
score for longest runs is Creatinine, whereas the column with the highest rarity score for
longest duplicate sequences is Activated PTT. You will further examine these columns in
the Univariate Patterns Report.

6. In the Univariate Patterns report, the report for the first column, Activated PTT, is shown
initially. Press Ctrl and select Creatinine from the Select Columns list.
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Figure 21.15 Explore Patterns Univariate Patterns Report

< Univariate Patterns
Select Columns A
ALT
ALP
AST
Bilirubin
BUN
Calcium
coz
Chloride
Creatine Kinase
Creatinine
Erythrocytes
Glucese
Hematocrit
Hemeglobin

4

~|Activated PTT

Number MNumber
of rows

Number of
Missing Unique Values

3463 1333 222
Most Duplicated Values Lengest Runs
Value Count Starting
23 a5 Row Count
24 a0 1460 3
25 83 3435 3
27 82 1032 3
22 74 1400 3
26 66 1456 3
28 65 469 3
20 57 1051 3
21 50 1056 3
30 47 758 3
960 3
933 3
~|Creatinine
Number Numb Berof
of rows Missing Unigue Values
3463 504 124
Most Duplicated Values Longest Runs
Value Count Starting
0.06188 462 Row Count
0.07072 455 2265 7
0.05304 380
0.07956 33
0.0884 214
0.0442 195
0.09724 119
0.03536 100
0.10608 &7
0.11492 50

Value
30.299999

Value
0.03536

Rarity
6.2
48

Rarity
189
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Explore Patterns Utility

Longest Duplicate Sequences

Starting Starting First few
Row | Row ] Count Rarity values
2816 3034 4 182 25729.8269
1050 1055 4 94 202222
1528 2386 4 91 273124
773 2587 4 84 262726

Longest Duplicate Sequences
Starting Starting
Row | Row ) Count Rarity First few values
1464 1681 & 11.0 0.079560.07072006188

As you select column names from the Select Columns list, the corresponding column
reports are shown. The Activated PTT report shows that this column contains several three
count runs and four count sequences. The Creatinine report shows that although it is the
column with the highest rarity score for Longest Runs, there is only one run in the column.
This column also has one eight count sequence.
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Launch the Explore Patterns Utility
Launch the Explore Patterns utility by selecting Analyze > Screening > Explore Patterns.

Figure 21.16 Explore Patterns Utility Launch Window

Detects unusual patterns in the data.

Select Columns Cast Selected Columns into Roles Action

~/37 Columns required numeric

Enter column name P - ntional mumeric -
aptiona: = -Cancel

ik STUDYID

th SITEID

th USUBID

A AGE

th SEX [ Recall |

W Race

ik Description of Planned Arm
ik Vasoconsription Flag

ik Patient Died

th Measurement

[» Laboratory Results (27/0)

Minimum Run Size 2
Minimum Longest Duplicate Size 2
Minimum Cress Column Duplicate Run Size 2
Minimum Rows for Linear Relationship 10

[] Include Missing

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Y, Columns Assigns the columns to analyze. The variables must be numeric and continuous.

By Assigns one or more columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

Minimum Run Size Specifies the minimum number of values in a row for a sequence to be
reported as a run.

Minimum Longest Duplicate Size Specifies the minimum length of a sequence for it to be
reported as a duplicate sequence within a column.

Minimum Cross Column Duplicate Run Size Specifies the minimum length of a sequence
for it to be reported as a duplicate sequence across columns.

Minimum Rows for Linear Relationship Specifies the minimum number of rows used for
detecting linear relationships between columns across groups of rows.

Note: The minimum number of rows must be greater than or equal to three.
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Include Missing Specifies that missing values be included in pattern detection.

Explore Patterns Report

The initial Explore Patterns report contains a Control Panel, Univariate Summary report, and
Univariate Patterns report. Many of the tables in these reports contain rows that can be
selected. If a row is selected and you right-click the first column, a menu appears that enables
you to select or colorize the related rows and columns in the data table.

Control Panel

The control panel contains options that enable you to select which reports appear in the report
window. These are the same options that are in the Explore Patterns red triangle menu. See
“Explore Patterns Utility Options”. There is also a section of the control panel to specify report
settings. These are the same settings that are found in the launch window. See “Launch the
Explore Patterns Utility”. If you change the settings in the control panel, the reports are
automatically updated.

Univariate Summary

The Univariate Summary report combines results from several patterns reports across
columns. By default, there are summary tables for Longest Runs and Longest Duplicate
Sequences. Longest Runs and Longest Duplicate Sequences with rarity > 2 are shown in the
tables.

If the Fraction Length option is selected a Fraction Length summary table is also shown. This
table shows the proportion of values in each column that have a fraction length greater than or
equal to 15. Columns that do not contain any values that have fraction lengths greater than or
equal to 15 are not shown in the Fraction Length summary table.

If at least one of the Y columns has a Spec Limit column property and the Distribution wrt
Spec Limits option is selected, a Spec Limits Distrib summary table is also shown. This table
shows the columns that have a statistically significant number of observations outside of the
specification limits.

For more information about the Univariate Summary report contents, see “Explore Patterns
Utility Options”.
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Univariate Patterns

The Univariate Patterns report contains a Select Columns list and one or more column-specific
patterns reports. The column-specific reports that are displayed are determined by the Select
Columns list. To examine each column’s report, select the first column and then successively
use the down arrow key to advance to the next column. Alternatively, you can click a column
name in this list to display the patterns report for the selected column. If you select more than
one column name by using either Ctrl or Shift, a patterns report for each of the selected
columns is displayed. If you deselect one or more columns from the Select Columns list, the
reports for the corresponding columns are removed.

Each individual patterns report displays a summary table that contains the number of rows,
number of missing observations, and number of unique values for the given column. By
default, there are also tables for Most Duplicated Values, Longest Runs, and Longest
Duplicate Sequences. If the Formatted Widths, Fraction Lengths, or Leading and Trailing
Digits options are selected from either the control panel or the Explore Patterns red triangle
menu, a corresponding table is added to each individual patterns report.

If you right-click on a row in any of the tables in the Univariate Patterns report, a menu of
right-click options appears.

Select Rows and Column Selects the column and rows in the original data table that
correspond to the selected row in a specific table in the Univariate Patterns report. For
example, if you right-click the second row of the Leading Digits table for a specific
column, the rows in that column that have a leading digit of 2 are selected in the original
data table.

Colorize Cells Colors the cells in the original data table that correspond to the selected row
in a specific table in the Univariate Patterns report. The rows of the colored cells are also
selected.

There are red triangle options for the column-specific patterns report. See “Univariate Patterns
Report Options”.

Explore Patterns Utility Options

The control panel and Explore Patterns red triangle menu contain options for summary and
pattern tables.

Most Duplicated Values Shows or hides a table of the values that appear most frequently in
the data. Shows up to ten numbers for each column.

Longest Runs Shows or hides a table of the longest run of the same value. The table contains
the following information:

Starting Row The row number that corresponds to the start of the run.
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Count The length of the run.
Value The value of the entries in the run.

Rarity A measurement of how rare it would be for the run to occur by chance. A high
rarity indicates that it is not likely that the run occurred by chance. See “Rarity in
Longest Runs”.

Longest Duplicated Sequences Shows or hides a table of the longest sequence of values that
appears more than once in the same column. Sequences of repeated values are also
considered. If a sequence is duplicated more than once, each instance appears in the table.
The table contains the following information:

Starting Row | The row number that corresponds to the start of the first sequence.
Starting Row J The row number that corresponds to the start of the duplicate sequence.
Count The length of the sequence.

Rarity A measurement of how rare it would be for the duplicate sequence to occur by
chance. A high rarity indicates that it is not likely that the duplicate sequence occurred
by chance. See “Rarity in Longest Sequences”.

First few values The first few values of the duplicate sequence. Shows up to three values
for each sequence.

Formatted Widths Shows or hides a table of overall widths and decimal widths of the
formatted values. The table contains the following information:

Width The width size.

Overall Count The number of observations in the column whose overall width equals the
specified width.

Decimal Count The number of observations in the column whose decimal width equals
the specified width.

Fraction Length Shows or hides a table of the continued fraction lengths for the values. A
continued fraction is a representation of a number as a sequence of continually divided
terms. The fraction length can indicate how rational a number is. Lengths of 15 or more
indicate that the number is an irrational number, such as from a root function, a function
involving an irrational number, or from a random number generator (Benford, 1938).

Note: In Explore Patterns, the maximum fraction length is 15. Numbers with fraction
lengths of 15 or more are all reported as 15.

Length The length of the continued fraction.
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Count The number of observations in the column whose continued fraction length
equals the specified continued fraction length.

Leading and Trailing Digits Shows or hides a table of counts for each leading and trailing
digit, 1 through 9. For the leading digits, there are also columns for the expected rate and
the minimum and maximum values that contain the corresponding leading digit. The
expected rate is based on Benford’s Law, which states that the frequency that a number has
a first digit that is equal to a is F, = logyo(a+1/a). This law applies to data that have a large
range of numbers that all have four or more digits.

Spec Limit Matches (Available when at least one of the columns has a Spec Limit column
property.) Shows or hides a table of values that are exactly the lower specification limit,
upper specification limit, or target value. If there are no exact matches, the report is not
shown.

Distribution wrt Spec Limits (Available only when at least one of the columns has a Spec
Limit column property.) Shows or hides a table of observed versus expected observations
that are outside of the specification limits. The Chi-Square and PValue columns appear
only if the number of observed observations is significantly higher than the number of
expected observations.

Duplicates Across Columns Shows or hides the Duplicates Across Columns report. The
report contains a table of sequences of values that appear in the same rows across more
than one column. There is a note at the top of the report that states the minimum length of
a sequence for it to be considered a duplicate. This number is specified in the launch
window or control panel as Minimum Cross Column Duplicate Run Size. There is also a
Colorize option at the top of the report. See “Colorize Duplicates Across Columns”.

Colorize Duplicates Across Columns (Available only after Duplicates Across Columns has
been selected.) Colors cells in the data table to correspond to the duplicate matches found
in the Duplicates Across Columns report. The rows that contain the duplicates are also
selected.

Linear Relationships Shows or hides the Linear relationships between variables report. The
report contains a table of exact linear relationships across columns over a specified
number of sequential rows. An exact linear relationship is defined as a linear relationship
that has an R? value greater than or equal to 0.999999. There is a note at the top of the
report that states the minimum number of rows considered. This number is specified in
the launch window or control panel as Minimum Rows for Linear Relationships. There is
also a Colorize option at the top of the report. See “Colorize Linear Relationships”.

Colorize Linear Relationships (Available only after Linear Relationships has been selected.)
Colors cells in the data table to correspond to the linear relationships found in the Linear
relationships between variables table. The rows that contain the linear relationships are
also selected.
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Save Columns Contains the following save options:

Save Table of Runs Saves the longest runs for all columns to a new data table. The data
table contains the same columns as the Longest Runs table in the Univariate Patterns
report and is sorted by Starting Row.

Save Table of Duplicate Sequences Saves the longest duplicate sequences for all
columns to a new data table. The data table contains the same columns as the Longest
Duplicate Sequences table in the Univariate Patterns report and is sorted by Starting
Row L.

Save Duplicates Across Columns Saves the Duplicates Across Columns table to a new
data table.

Save Linear Relationships Saves the Linear relationships between values table to a new
data table.

Ordering Columns Contains options for ordering. When you change the ordering, the
column list in the Univariate Patterns report is reordered. The top column is automatically
selected and the report for only that column is displayed.

Order by Runs Rarity Orders the column list by the rarity values of the longest runs.
Higher rarity values are at the top.

Order by Sequence Rarity Orders the column list by the rarity values of the long
duplicate sequences. Higher rarity values are at the top.

Order by Column Name Orders the column list in alphabetical order by column name.

Original Order Orders the column list in the original order in which the columns were
specified in the launch window.

Clear Cell Colors Clears the cell colors for columns selected in the data table or for all
columns if no columns are selected in the data table.

See Using JMP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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Univariate Patterns Report Options
Each Univariate Patterns red triangle menu contains the following options:

Select Most Duplicated Selects the observations in the data table that correspond to the
values in the Most Duplicated Values table.

Select Longest Runs Selects the observations in the data table that correspond to the values
in the Longest Runs table.

Select Longest Duplicate Sequences Selects the observations in the data table that
correspond to the values in the Longest Duplicate Sequences table.

Select by Formatted Width Selects the observations in the data table that correspond to the
values in the Formatted Widths table that have the user-specified overall width.

Select by Decimal Width Selects the observations in the data table that correspond to the
values in the Formatted Widths that have the user-specified decimal width.

Select by Fraction Length Selects the observations in the data table that correspond to the
values in the Fraction Length table that have the user-specified fraction length.

Select by Leading Digit Selects the observations in the data table that correspond to the
values in the Leading and Trailing Digits table that have the user-specified leading digit.

Additional Example of the Explore Patterns Utility

The Water Treatment.jmp data table contains data from an urban waste water treatment plant.
The columns are daily measurements of different sensors in the plant. Use the Explore
Patterns Utility to determine whether there are any unexpected patterns in the sensor
measurements.

Select Help > Sample Data Library and open the Water Treatment.jmp sample data table.
Select Analyze > Screening > Explore Patterns.

Select the Sensor Measurements column group and click Y, Columns.

Click OK.

S

In the Control Panel, under Across Columns, click the box next to Duplicates Across
Columns.
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Figure 21.17 Duplicates Across Columns Report

< Duplicates Across Columns
With runs atleast2  Colorize

Number
from Row toRow MNumber Rows Equal Duplicate Sets

219 230 12 12 PH-P,PH-D

207 217 11 11 PH-E PH-P

214 217 4 8 PH-E PH-P,PH-D
330 333 4 8 PH-E PH-P,PH-D
1908 204 7 7 PH-P,PH-D

91 96 6 6 PH-P,PH-D

94 96 3 6 PH-E PH-P,PH-D
208 210 3 6 PH-E PH-P,PH-D
216 217 2 6 PH-E PH-P,PH-D,PH-S
228 229 2 6 PH-E PH-P,PH-D,PH-S
247 252 6 6 PH-E PH-P

200 205 6 6 PH-E PH-P

203 205 3 6 PH-E PH-P,PH-D
427 429 3 6 PH-E PH-P,PH-D
472 AT7 6 6 PH-E PH-P

26 30 5 5 PH-E PH-P

63 67 5 5 PH-P,PH-D

141 145 5 5 PH-E PH-D

200 303 5 5 PH-E PH-P

352 356 5 5 PH-P,PH-D

The Duplicates Across Columns report shows a long list of duplicate columns. However,
the minimum run size is 2 and there are many small runs in the list. You want to focus on
the larger runs of at least 10.

6. In the Control Panel, under Settings, enter 10 in the box next to Minimum Cross Column

Duplicate Run Size.

Tip: Click anywhere outside of the box to automatically update the report.

Figure 21.18 Duplicates Across Columns Report With Runs at Least 10

< Duplicates Across Columns
With runs at least 10 Colorize

Number  Duplicate

from Row toRow MNumber Rows Equal Sets
219 230 12 12 PH-P,PH-D
207 217 11 11 PH-E PH-P

The updated Duplicates Across Columns report shows that there are two duplicate sets
with runs of at least 10. Both sets include the PH-P column.

7. Click Colorize in the Duplicates Across Columns Report.
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Figure 21.19 Colorized Water Treatments.jmp Data Table

| -
- PH-E DBO-E DQO-E | S5-E | 55V-E | SED-E | COND-E  PH-P | DBO-P S55-P  SS5V-P | SED-P | COND-P | PH-D
. 206 707 12400 2340 1200 61.7 1.8 15500 79 1230 2200 59.0 40 16510 78
. 207 76 1720 3940 2260 51.3 55 13240 76 1970 3020 470 40 13060 77
. 208 76 2680 3240 2260 53.1 40 13900 76 2650 2360 53.4 45 13890 76
209 76 1760 2000 1760 50.0 30 8590 76 1490 1720 51.2 20 8600 76
b 210 76 1460 2430 1640 57.3 32 10950 76 1930 2080 55.8 30 10890 76
b 21 78 1390 3800 2560 53.1 5.5 20400 78 2010 3400 476 85 20000 79
b 212 79 2050 5290 2640 614 65 27500 79 2200 3240 60.5 6.0 28500 78
b 213 78 1170 3660 5000 272 4.2 32300 78 1350 6200 323 70 31700 77
. 214 76 1480 4000 5640 316 70 15540 76 2350 7980 286 1.0 15150 76
b 215 78 1580 2560 1940 474 30 18310 78 2180 2400 467 40 18600 78
216 d7 1230 2460 1860 398 25 12880 I8 2410 3000 253 45 13280 77
b 217 a7 1330 4100 2040 62.7 45 14900 7 1610 2560 57.8 45 14210 77
. 218 75 2370 3880 1780 57.3 40 16200 76 3000 2400 53.3 45 15710 77
b 219 77 2030 3570 2220 58.6 30 18280 76 2150 2080 731 50 18170 76
. 220 78 1990 3800 2440 55.7 50 14530 78 1100 1960 60.2 35 14300 78
. 221 78 2140 9410 3040 53.3 65 14540 78 3960 3200 57.5 70 15280 78
222 77 2080 2980 2600 377 40 12360 78 2450 2840 4635 50 12850 78
. 223 79 2060 3050 1880 56.4 40 12000 79 2208 2720 50.0 60 12280 79
b 224 77 2470 3610 2860 51.0 45 11800 7 1460 2120 56.4 25 12510 I8
. 225 75 4380 6810 3700 56.8 60 13960 76 2120 3480 644 60 14460 76
b 226 78 2550 2820 1660 67.5 20 9500 78 2840 1720 65.1 20 9650 78
. 227 77 2830 3100 1700 61.2 25 10650 78 2350 2700 511 55 11000 78
. 228 79 3130 3410 5120 336 6.0 9150 79 2050 5200 338 75 9760 79
. 229 77 3000 6100 4520 451 80 13130 I8 3750 5560 439 100 13120 I8
b 230 78 1770 4120 1960 694 45 21900 78 3300 4760 52.1 75 23300 78

The Colorize feature colors the cells in the original data table that correspond to the
duplicate sets in the report.

Statistical Details for the Explore Patterns Utility

Rarity in Longest Runs
To calculate the rarity for longest runs, first define the following variables:

n = the number of rows in the column

k = the number of times a specific value occurs in the column

p = k/n = the probability of observing the specific value in the column
m = the length of the run

N = the number of unique runs

Then, the rarity for longest runs is calculated as follows:

Rarity = -logy(1 — (1 - "~ HN)
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Rarity in Longest Sequences
To calculate the rarity for longest sequences, first define the following variables:

p = the probability of observing the specific sequence one time in the column

k = the number of times the starting value of the sequence occurs in the column

Then, the rarity for longest sequences is calculated as follows:

Rarity = -logy(1 — (1 - p)b)

445
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Chapter 22

Response Screening
Test Many Responses in Large-Scale Data

The analysis of large-scale data sets, where hundreds or thousands of measurements are taken
on a part or an organism, requires innovative approaches. But testing many responses for the
effects of factors can be challenging, if not misleading, without appropriate methodology.

Response Screening automates the process of conducting tests across a large number of
responses. Your test results and summary statistics are presented in data tables, rather than
reports, to enable data exploration. A False-Discovery Rate approach guards against incorrect
declarations of significance. Plots of p-values are scaled using the LogWorth, making them
easily interpretable.

Because large scale data sets are often messy, Response Screening presents methods that
address irregularly distributed and missing data. A robust estimate method allows outliers to
remain in the data, but reduces the sensitivity of tests to these outliers. Missing data options
allow missing values to be included in the analysis. These features enable you to analyze your
data without first conducting an extensive analysis of data quality.

When you have many observations, even differences that are of no practical interest can be
statistically significant. Response Screening presents tests of practical difference, where you
specify the difference that you are interested in detecting. On the other hand, you might want
to know whether differences do not exceed a given magnitude, that is, if the means are
equivalent. For this purpose, Response Screening presents equivalence tests.

Figure 22.1 Example of a Response Screening Plot
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Overview of the Response Screening Platform

Response Screening automates the process of conducting tests across a large number of
responses. It tests each response that you specify against each factor that you specify.
Response screening addresses two main issues connected with large-scale data. These are the
need to conduct many tests, and the requirement to deal effectively with outliers and missing
values.

Response screening is available as a platform and as a Fit Model personality. In both cases, it
performs tests analogous to those found in the Fit Y by X platform, as shown in Table 22.1. As
a personality, it performs tests of the response against the individual model effects.

To facilitate and support the multiple inferences that are required, Response Screening
provides these features:

Data Tables Results are shown in data tables, as well as in a report, to enable you to explore,
sort, search, and plot your results. Statistics that facilitate plot interpretation are provided,
such as the LogWorth of p-values.

False Discovery Rates Because you are conducting a large number of tests, you need to
control the overall rate of declaring tests significant. Response screening controls the false
discovery rate. The False Discovery Rate (FDR) is the expected proportion of significant
tests that are incorrectly declared significant (Benjamini and Hochberg 1995; Westfall et al.
2011).

Tests of Practical Significance When you have many observations, even small effects that
are of no practical consequence can result in statistical significance. To address this issue,
you can define an effect size that you consider to be of practical significance. You then
conduct tests of practical significance, thereby only detecting effects large enough to be of
pragmatic interest.

Equivalence Tests When you are studying many factors, you are often interested in those
that have essentially equivalent effects on the response. In this case, you can specify an
effect size that defines practical equivalence and then conduct equivalence tests.

To address issues that arise when dealing with messy data, Response Screening provides
features to deal with outliers and missing data. These features enable you to analyze your data
directly, without expending effort to address data quality issues:

Robust Estimation Outliers in your data increase estimates of standard error, causing tests
to be insensitive to real effects. Select the Robust option to conduct Huber M-estimation.
Outliers remain in the data, but the sensitivity of tests to these outliers is reduced.

Missing Value Options The platform contains an option to treat missing values on
categorical predictors in an informative fashion.
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Table 22.1 Analyses Performed by Response Screening

Response Factor

Continuous Categorical
Continuous Continuous
Categorical Categorical
Categorical Continuous

Fit Y by X Analysis
Oneway
Bivariate
Contingency

Logistic

Chapter 22
Predictive and Specialized Modeling

Description

Analysis of Variance
Simple Linear Regression
Chi-Square

Simple Logistic Regression

The Response Screening platform generates a report and a data table: the Response Screening
report and the PValues table. The Response Screening personality generates a report and two
data tables: the Fit Response Screening report, the PValues table, and the Y Fits table.

The JSL command Summarize Y by X performs the same function as the Response Screening
platform but without creating a platform window. See the JSL Syntax Reference.

Example of Response Screening

The Probe.jmp sample data table contains 387 characteristics (the Responses column group)
measured on 5800 wafers. The Lot ID and Wafer Number columns uniquely identify the wafer.
You are interested in which of the characteristics show different values across a process

change (Process).

Select Process and click X.

A A

Select Help > Sample Data Library and open Probe.jmp.

Select Analyze > Screening > Response Screening.

Enter 100 in the MaxLogWorth box.

Select the Responses column group and click Y, Response.

A logworth (-logyg(p-value)) of 100 or larger corresponds to an extremely small p-value.
Setting a value for the MaxLogWorth helps control the scale of plots as it limits the

reported logworth value.
6. Click OK.

The report shows a table of p-value results and the FDR PValue Plot, and also contains two

other plot reports.
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The FDR PValue Plot shows two types of p-values, FDR PValue and PValue, for each of the 387
tests. These are plotted against Rank Fraction. PValue is the usual p-value for the testof a Y
against Process. The FDR PValue is a p-value that is adjusted to guarantee a given false
discover rate (FDR), here 0.05. The FDR PValues are plotted in blue and the PValues are
plotted in red. The Rank Fraction ranks the FDR p-values from smallest to largest, in order of
decreasing significance.

Both the horizontal blue line and the sloped red line on the plot are thresholds for FDR
significance. Tests with FDR p-values that fall below the blue line are significant at the 0.05
level when adjusted for the false discovery rate. Tests with ordinary p-values that fall below
the red line are significant at the 0.05 level. In this way, the plot enables you to read FDR
significance from either set of p-values.

Figure 22.2 Response Screening Report for 387 Tests against Process
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The FDR PValue Plot shows that more than 60% of the tests are significant. A handful of tests
are significant using the unadjusted p-value, but not significant using the FDR p-value. These
tests correspond to the red points that are above the red line, but below the blue line.

To identify the characteristics that are significantly different across Process, you can drag a
rectangle around the appropriate points in the plot. This selects the rows corresponding to
these points in the Result table, where the names of the characteristics are given in the first
column.

The Result table contains 387 rows, one for each response measure in the Responses group.
The response is given in the first column, called Y. Each response is tested against the effect in
the X column, namely, Process.

The remaining columns give information about the test of Y against X. Here the test is a
Oneway Analysis of Variance. In addition to other information, the table gives the test’s
p-value, LogWorth, FDR (False Discovery Rate) p-value, and FDR LogWorth. Use this table to
sort by the various statistics, select rows, or plot quantities of interest.

Notice that LogWorth and FDR LogWorth values that correspond to p-values of 1e-100 or less
are reported as 100, because you set MaxLogWorth to 100 in the launch window. Also, cells
corresponding to FDR LogWorth values greater than two are colored with an intensity
gradient.

See “The Response Screening Report” for more information about the report and PValues
table.
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Launch the Response Screening Platform

Launch the Response Screening platform by selecting Analyze > Screening > Response
Screening.

Figure 22.3 Response Screening Launch Window

Fits a large number of Y by X combinations while centrolling the False-Discovery Rate.
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For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Launch Window Roles
Y, Response Identifies the response columns containing the measurements to be analyzed.
X Identifies the columns against which you want to test the responses.

Grouping Analyzes the rows assigned to each level of the specified column separately. All
results are presented in a single table and report.

Weight Identifies a column whose values assign a weight to each row. These values are used
as weights in the analysis. See Fitting Linear Models.
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Freq Identifies a column whose values assign a frequency to each row. These values enable
you to account for pre-summarized data. See Fitting Linear Models.

By For each level of the specified column, analyzes the corresponding Ys and Xs and
presents the results in separate tables and reports.

Launch Window Options

PValues Table on Launch Creates a data table for the p-values and individual model fit
statistics. This data table is linked to the Result Table in the Response Screening report.

Robust (Available only for continuous responses.) Fits regression and ANOVA models using
the Huber M-estimation method (Huber and Ronchetti 2009). This method estimates
parameters by minimizing the Huber loss function. The Huber loss function penalizes
outliers, which reduces the influence of the outliers on tests. If there are no outliers, the
estimates are close to the least squares estimates. When you select the Robust option,
several Robust measures and model fit statistics columns are added to the Result Table.
See Basic Analysis for more information about Huber M-estimation. For an example, see
“Example of Robust Fit”.

Caution: The Robust option can increase processing time.

Cauchy (Available only for continuous responses.) Estimates parameters using maximum
likelihood and a Cauchy link function. This estimation method assumes that the errors
have a Cauchy distribution, which has fatter tails than the normal distribution, resulting in
a reduced emphasis on outliers. This option can be useful if you have a large proportion of
outliers in your data. However, if your data are close to normal with only a few outliers,
this option can lead to incorrect inferences. When you select the Cauchy option, several
Cauchy measures and model fit statistics columns are added to the Result Table.

Poisson Y Fits each Y response as a count having a Poisson distribution. The test is
performed only for categorical X. This option is appropriate when your responses are
counts.

Missing is category For any categorical X variable, treats missing values on X as a category.

Paired Xand Y Performs tests only for Y columns paired with X columns according to their
order in the Y, Response and X lists. The first Y is paired with the first X, the second Y
with the second X, and so on.

Practical Difference Portion The fraction of the specification range, or of an estimated six
standard deviation range, that represents a difference that you consider pragmatically
meaningful. If Spec Limits is not set as a column property, a range of six standard
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deviations is estimated for the response. The standard deviation estimate is computed
from the interquartile range (IQR), as & = (IQR)/(1.3489795) .

If no Practical Difference Proportion is specified, its value defaults to 0.10. Tests of
practical significance and equivalence tests use this difference to determine the practical
difference. See “Compare Means Data Table”.

MaxLogWorth Controls the scale of plots involving LogWorth values (-log of p-values).
LogWorth values that exceed MaxLogWorth are plotted as MaxLogWorth to prevent
extreme scales in LogWorth plots. See “Example of the MaxLogWorth Option” for an
example.

Advanced Options Contains the following options:

Kappa Addsanew column called Kappa to the data table. If Y and X are both categorical
and have the same levels, kappa is provided. This is a measure of agreement between Y
and X.

Corr The Corr option computes the Pearson product-moment correlation in terms of the
indices defined by the value ordering.

If X and Y are both binary, the Pearson product-moment calculation gives Spearman’s
rho and Kendall's Tau-b. Otherwise, a value of Corr that is large in magnitude indicates
an association; a Corr value that is small in magnitude does not preclude an
association.

Force X Categorical Ignores the modeling type and treats all X columns as categorical.
Force X Continuous Ignores the modeling type and treats all X columns as continuous.
Force Y Categorical Ignores the modeling type and treats all Y columns as categorical.
Force Y Continuous Ignores the modeling type and treats all Y columns as continuous.

Unthreaded Suppresses multithreading used for computational speed.

The Response Screening Report

The Response Screening report consists of a results table and several plots. These plots focus
on False Discovery Rate (FDR) statistics. See “The False Discovery Rate”.

The default plots are the FDR PValue Plot, the FDR LogWorth by Effect Size, and the FDR
LogWorth by RSquare. If you select the Robust option on the launch window, Robust versions
of each of these reports are also presented. In addition, a Robust LogWorth by FDR LogWorth
plot is presented to help assess the impact of using the robust fit.
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Result Table

The Response Screening Result table contains a row for each pair of Y and X variables. The
columns of the table contain measures and model fit statistics that are specific to the selected
fit and Y and X modeling types.

Group (Appears only if there is a grouping variable.) The level of the grouping column.
Y The specified response columns.
X The specified factor columns.

Count The number of rows used for testing, or the corresponding sum of the Freq or Weight
variable.

PValue The p-value for the significance test corresponding to the pair of Y and X variables.
For more information about Fit Y by X statistics, see Basic Analysis.

LogWorth The quantity -logg(p-value). This transformation adjusts p-values to provide an
appropriate scale for graphing. A value that exceeds 2 is significant at the 0.01 level
(-log1p(0.01) =2).

FDR PValue The False Discovery Rate p-value calculated using the Benjamini-Hochberg
technique. This technique adjusts the p-values to control the false discovery rate for
multiple tests. If there is no Group variable, the set of multiple tests includes all tests
displayed in the table. If there is a Group variable, the set of multiple tests consists of all
tests conducted for each level of the Group variable. For more information about the FDR
correction, see Benjamini and Hochberg (1995). For more information about the false
discovery rate, see “The False Discovery Rate”.

FDR LogWorth The quantity -log;o(FDR PValue). This is the statistic to use for plotting and
assessing significance. Note that small p-values result in high FDR LogWorth values. Cells
corresponding to FDR LogWorth values greater than two (p-values less than 0.01) are
colored with an intensity gradient.

Effect Size Indicates the extent to which response values differ across the levels or values of
X. Effect sizes are scale invariant.

— When Y is continuous, the effect size is the square root of the average sum of squares
from the hypothesis test divided by a robust estimate of the response standard
deviation. If the interquartile range (IQR) is nonzero and IQR > range/20, the standard
deviation estimate is IQR/1.3489795. Otherwise the sample standard deviation is used.

— When Y is categorical and X is continuous, the effect size is the square root of the
average ChiSquare value for the whole model test.

— When Y and X are both categorical, the effect size is the square root of the average
Pearson ChiSquare.
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Rank Fraction The rank of the FDR LogWorth expressed as a fraction of the number of tests.
If the number of tests is m, the largest FDR LogWorth value has Rank Fraction 1/m, and the
smallest has Rank Fraction 1. The Rank Fraction is used in plotting the PValues and FDR
PValues in rank order of decreasing significance.

RSquare (Appears only when Y is continuous.) The coefficient of determination, which
measures the proportion of total variation explained by the model.

Kappa (Appears only when Y and X are both categorical and have the same number of
levels.) A measure of agreement between Y and X.

Corr (Appears only when Y and X are both categorical.) The Pearson product-moment
correlation in terms of the indices defined by the value ordering.

The following columns are added to the Result table when the Robust option is selected in the
launch window. The Robust option applies only when Y is continuous, so Robust column cells
are empty when Y is categorical.

Robust PValue The p-value for the significance test corresponding to the pair of Y and X
variables using a robust fit.

Robust LogWorth The quantity -log;g(Robust PValue).

Robust FDR PValue The False Discovery Rate calculated for the Robust PValues using the
Benjamini-Hochberg technique. If there is no Group variable, the multiple test adjustment
applies to all tests displayed in the table. If there is a Group variable, the multiple test
adjustment applies to all tests conducted for each level of the Group variable.

Robust FDR LogWorth The quantity -log;p(Robust FDR PValue).

Robust Rank Fraction The rank of the Robust FDR LogWorth expressed as a fraction of the
number of tests.

Robust Chisq The chi-square value associated with the robust test.
Robust Sigma The robust estimate of the error standard deviation.

Robust Outlier Portion The portion of the values whose distance from the robust mean
exceeds three times the Robust Sigma.

The following columns are added to the Result table when the Cauchy option is selected in the
launch window. The Cauchy option applies only when Y is continuous, so Cauchy column
cells are empty when Y is categorical.

Cauchy PValue The p-value for the significance test corresponding to the pair of Y and X
variables using a Cauchy fit.

Cauchy LogWorth The quantity -log;y(Cauchy PValue).
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Cauchy FDR PValue The False Discovery Rate calculated for the Cauchy PValues using the
Benjamini-Hochberg technique. If there is no Group variable, the multiple test adjustment
applies to all tests displayed in the table. If there is a Group variable, the multiple test
adjustment applies to all tests conducted for each level of the Group variable.

Cauchy FDR LogWorth The quantity -log;o(Cauchy FDR PValue).

Cauchy Rank Fraction The rank of the Cauchy FDR LogWorth expressed as a fraction of the
number of tests.

Cauchy ChiSquare The chi-square value associated with the test from the Cauchy fit.
Cauchy Sigma The estimate of the error standard deviation from the Cauchy fit.

Cauchy Outlier Portion The portion of the values whose distance from the mean of the
Cauchy fit exceeds three times the Cauchy Sigma.

FDR PValue Plot

The FDR PValue Plot report shows a plot of FDR PValues and PValues against the Rank
Fraction. The Rank Fraction ranks the PValues in order of decreasing significance. FDR
PValues are plotted in blue and PValues in red.

A blue horizontal line shows the 0.05 significance level. Note that you can change this level by
double-clicking the vertical axis, removing the current reference line, and adding a new
reference line.

A red increasing line provides an FDR threshold for unadjusted p-values. A p-value falls
below the red line precisely when the FDR-adjusted p-value falls below the blue line. This
enables you to read significance relative to the FDR from either the adjusted or unadjusted
p-values.

Figure 22.4 shows the FDR PValue Plot for the Probe.jmp sample data table. Note that some
tests are significant according to the usual p-value but not according to the FDR p-value.
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Figure 22.4 FDR PValue Plot

< FDR PValue Plot
1.0

09
08
07
06
05

04

FDR PValue & PValue

03

02

0.1

Response Screening
The Response Screening Report

* FDR PValue

* PValue
— FDR PValue 0.05 Thresheld
— PValue 0.05 Thresheld

4

-*

I d

H
;
M
J
>

h)

0 o

0 0.1 02 03 04 05 06

Rank Fracticn

FDR LogWorth by Effect Size

459

When you have large effects, the associated p-values are often very small. Visualizing these
small values graphically can be challenging. When transformed to the LogWorth
(-logqo(p-value)) scale, highly significant p-values have large LogWorths and nonsignificant

p-values have low LogWorths. A LogWorth of zero corresponds to a nonsignificant p-value of
1. Any LogWorth above 2 corresponds to a p-value below 0.01.

In the FDR LogWorth by Effect Size plot, the vertical axis is the FDR LogWorth and the

horizontal axis is the Effect Size. Generally, larger effects lead to more significant p-values and
larger LogWorths. However, this relationship is not necessarily strong because significance

also depends on the error variance. In fact, large LogWorths can be associated with small

effects, and small LogWorths can be associated with large effects, because of the size of the
error variance. The FDR LogWorth by Effect Size plot enables you to explore this relationship.

Figure 22.5 shows the FDR LogWorth by Effect size plot for the Probe.jmp sample data table
with MaxLogWorth set to 100. Most FDR LogWorth values exceed 2, which indicates that most

effects are significant at the 0.01 level. The FDR LogWorth values of 100 correspond to

extremely small p-values.
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Figure 22.5 FDR LogWorth by Effect Size
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FDR LogWorth by RSquare

The FDR LogWorth by RSquare plot shows the FDR LogWorth on the vertical axis and
RSquare values on the horizontal axis. Larger LogWorth values tend to be associated with
larger RSquare values, but this relationship also depends on the number of observations.

The PValues Data Table

If the PValues Tables on Launch option is selected in the launch window, a PValues data table
is created when the Response Screening platform is launched. This data table contains the
same information as the Result table that is in the Response Screening report. The PValues
data table also contains the additional, model specific columns:

YMean The meanofY.

SSE Appears when Y is continuous. The sum of squares for error.
DFE Appears when Y is continuous. The degrees of freedom for error.
MSE Appears when Y is continuous. The mean squared error.

F Ratio Appears when Y is continuous. The F Ratio for the analysis of variance or regression
test.

Intercept Appears when Y and X are both continuous. The intercept of the regression model
relating the corresponding pair of Y and X variables.



Chapter 22 Response Screening 461
Predictive and Specialized Modeling Response Screening Platform Options

Slope Appears when Y and X are both continuous. The slope of the regression model
relating the corresponding pair of Y and X variables.

DF Appears when Y and X are both categorical. The degrees of freedom for the ChiSquare
test.

LR Chisq Appears when Y and X are both categorical. The value of the Likelihood Ratio
ChiSquare statistic.

Robust Elapsed Time (Appears only when Robust is specified in the launch window.)
Computing time, in seconds, required to create the Robust report.

PValues Data Table Scripts

Relevant scripts are saved to the PValues data table. All but one of these reproduce plots
provided in the report. When you select rows in the PValues table, the Fit Selected script
produces the appropriate Fit Y by X analyses.

Response Screening Platform Options

The Response Screening red triangle menu contains options to customize the display and to
compute and save calculated data.

Results Table Shows or hides the table of results.

Fit Selected Items For selected relationships, adds the appropriate Fit Y by X reports to the
Response Screening report. You can select relationships by selecting points in the plots,
rows in the Result Table, or if opened, rows in the PValue data table.

Select Columns Selects the columns in the original data table that correspond to rows that
you select in the Result Table, to points that you select in plots in the Response Screening
report window, or if opened, rows in the PValues table. Select the rows or points first, then
select Select Columns. The corresponding columns in the data table are selected. You can
select columns corresponding to additional rows in the PValues table or points in plots by
first selecting them and then selecting Select Columns again. To select columns
corresponding to different rows or points, first clear the current column selection in the
original data table.

Select Where Opens the Select Where window. You can select specific responses in the
Result table that correspond to a particular condition by using the Comparison menu and
Value text box. For example, you can select all responses such that Effect Size > 0.80. After
you click OK, the responses are selected in the Result table.
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Tip: You can also access the Select Where window by right-clicking anywhere in the Result
table.

Save PValues Creates the PValues data table. See “The PValues Data Table”.

Save Means For continuous Ys and categorical Xs, creates a data table with the counts,
means, and standard deviations for each level of the categorical variable. If the Robust
option is selected, the robust mean is included.

Save Compare Means For continuous Ys and categorical Xs, tests all pairwise comparisons
across the levels of the categorical variable. For each comparison, the data table gives the
usual ¢ test, a test of practical significance, an equivalence test, and a column that uses
color coding to summarize the results. The data table also contains a script that plots
Practical LogWorth by Relative Practical Difference. See “Compare Means Data Table”.
For an example, see “Example of Tests of Practical Significance and Equivalence”.

Save Std Residuals Saves a new group of columns to the original data table and places these
in a column group call Residual Group. For each continuous Y and categorical X, a column
is constructed containing the residuals divided by their estimated standard deviation. In
other words, the column contains standardized residuals. The column is defined by a
formula.

If the Robust option is selected, standardized residual columns are constructed using
robust fits and robust estimates.

Save Outlier Indicator Saves a new group of columns to the original data table and places
these in a column group call Outlier Group. Save Outlier Indicator is most effective when
you have selected the Robust option.

For each continuous Y and categorical X, a column that indicates outliers is constructed.
An outlier is a point whose distance to the predicted value exceeds three times an estimate
of sigma. In other words, an outlier is a point whose standardized residual exceeds three.
The column is defined by a formula.

If the Robust option is selected, robust fits and robust estimates are used. An outlier is a
point whose distance to the predicted value exceeds three times the robust estimate of
sigma.

The Cluster Outliers script is added to the original data table. The script shows outliers on
a hierarchical cluster plot of the data.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.
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Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that

support the feature, the Automatic Recalc option immediately reflects the changes that

you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Means Data Table

The Means data table contains a row for each combination of response and X level. For the

Probe.jmp sample data table, there are 387 response variables, each tested against Process at

two levels. The Means table contains 387x2 = 774 rows.

Figure 22.6 Means Data Table

«|Save Means

 |Columns (6/0)
Q
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kX2
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All rows 774

Selected
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Hidden
Labeled

The Means data table includes the following columns:

o oo

-

L= B« Y R A

o

10
11
12
13
14
15
16
17
18

Y
DELL_RPNBR
DELL_RPNBR
DELL_RPPBR
DELL_RPPBR
DELW_M1
DELW_M1
DELW_M2
DELW_M2
DELW_NBASE
DELW_NBASE
DELW_NEMIT
DELW_NEMIT
DELW_NEMNBNI
DELW_NENBNI
DELW_NSINK
DELW_NSINK
DELW_PBASE
DELW_PBASE

X
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process
Process

Y The continuous response variables.

X The categorical variables.

Level

New
Old
New
Old
New
Old
New
Old
New
Old
New
Old
New
Old
New
Old
New
Old

Level The level of the categorical X variable.

Count
3044
2750
3044
2750
3039
2750
3039
2689
3028
2750
3038
2750
3043
2749
3032
2750
3036
2750

Mean

0.2035840106
0.2346329436
-0.068072506
-0.043321135

-0.04387197
-0.071400861
0.8014275806
0.7274958056
0.1957655669
14765185729
0.3411755212
0.3813085954
37172025841
4.6556238745
9.2876152816
7.8902297629
11651478779
1.2087969753

Count The count of values in the corresponding Level.

Mean The mean of the Y variable for the specified Level.

StdDev
0.1916031302
0.1278299414
0.1784161107
19165048167
1.0774346893
0.0389764703
0.0698264259
0.0649383327
77801881218
0.1326787074
0.0940762694
0.0976561441
1.1419433505
0.1893626325
1.2840573691
0.3781489659
0.1351193171
0.1486923744
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StdDev The standard deviation of the Y variable for the specified Level.

Robust Mean The robust M-estimate of the mean. Appears when you select the Robust
option on the launch window.

Compare Means Data Table

When your data table consists of a large number of rows (large ), the standard error used in
testing can be very small. As a result, tests might be statistically significant, when in fact, the
observed difference is too small to be of practical consequence. Tests of practical significance
enable you to specify the size of the difference that you consider worth detecting. This
difference is called the practical difference. Instead of testing that the difference is zero, you test
whether the difference exceeds the practical difference. As a result, the tests are more
meaningful, and fewer tests need to be scrutinized.

Equivalence tests enable you to determine whether two levels have essentially the same effect,
from a practical perspective, on the response. In other words, an equivalence test tests
whether the difference is smaller than the practical difference.

The Compare Means data table provides results for both tests of practical difference and tests
of practical equivalence. Each row compares a response across two levels of a categorical
factor. Results of the pairwise comparisons are color-coded to facilitate interpretation. See
“Practical Difference” for a description of how the practical difference is specified. See
“Example of Tests of Practical Significance and Equivalence” for an example.

Figure 22.7 Compare Means Data Table

~)Untitled 23 4 B 02
P Practical Log...cal Difference | o Y Leveli Levelj X Difference  Std Err Dif | Plain Dif PValue  Practical Difference  Practical Dif PValue | Practical Equiv PValue | Practical Result
1 DELLRPNBR New Old  Process -0031048933 0004326425 | 8044596e-13 0.0990979657 1 6.407405€-55 Equivalent
2 DELLRPPBR New Old  Process -0024751371 00349025251 04782555718 0.7959556871 1 307185e-104 Equivalent
3 DELW.M1 New Old  Process 00275288913 00205582035  0.1806001982 0.4687012219 1 1.160101e-98 Equivalent
¥ Columns (11/0) 4 DELW_M2 New Old  Process 00739317751 0.0017890895 0 0.0469881911 1.350706e-50 1 Different
2 5 DELW_NBASE New Old  Process -1280753006 14836374126 0388034756 33.792861061 1 128251e-102 Equivalent
FN7=) 6 DELW_NEMIT New Old  Process -0040133074 0002521398 | 7.306034e-56 0.0565587625 1 3.954083¢-11 Equivalent
W Lovell @ 7 DELWNENBNI  New Old  Process -0.93842129 00220490008 0 05760161527 1.142115e-59 1 Different
:f:;”ﬂ 8 DELW_NSINK New Old  Process 13973855188 0.0254310074 0 07148732981 6.27067e-150 1 Different
A Difference 9 DELW_PBASE New Old  Process -0043649097 00037311377 | 2908704631 0.0864253619 1 209453330 Equivalent
A 5td Err Dif 10 DELW_PCOLL New Old  Process 18169399617 0.0085444762 0 078359742 [ 1 Different
A Plain Dif PValue 11 DELW_PEMIT New Old  Process -0022697392 0.0534170363 06709186367 12176717085 1 1.10189e-106 Equivalent
A Practical Difference 12 DELW_PSINK New Old Process 0911093371 0.0678503246 1.666427e-40 15705731641 1 1.83559e-22 Equivalent
:i::g:::g:y;{flue 13 DELW_RPNBR New Old Process -0101421251 0.0100452789 | 9008231e-24 02309922348 1 7.505304e-38 Equivalent
e Practical Result 14 DELW_RPPBR New Old  Process 03015474189 00280757905 | 1.169725e-26 0.6465385194 1 1402789-34 Equivalent
15 DELW_SICR New Old  Process 00275370732 0.0176173979  0.1180928699 0.4016073762 1 1042102296 Equivalent
16 M1COMBVGAT.. New Old  Process -0532453055 06037284633 03778451214 1377484916 1 8.16456e-103 Equivalent
17 M1TRENCHVG.. New Old  Process -061657228 0.1695447206 |1 010002786205 3872532637 1 4896901e-80 Equivalent
18 M2/M1CAPVG. New Old  Process -0047230999 00978790012 06294372314 2.2331316201 1 2.36705¢-106 Equivalent
~Rows 19 M2.COMBBBY.. New Old  Process 00001788376 0.1270241159 09988767052 2.8980258306 1 1.08197e-110 Equivalent
All rows 287 20 M2.COMBVGAT.. New Old  Process 02971147541 02860872543 02990592705 6527621621 1 191844e-101 Equivalent
Selected 0 21 NISOTUB-TREN.. New Old  Process 70118092399 02482751793 [ 1587846 164 6.0414047752 00000469484 0.9999530516 |Different
Excluded 0 22 NISOTUB-TUBV.. New Old  Process -0074789866 0.1081535234 04892691678 24675993783 1 170833e-104 Equivalent
'l*;ggferl‘j g 23 PS_RPNBR New Old  Process -6469026527 152942887 | 00000237641 35351614685 1 1545634277 Equivalent

The Compare Means data table contains a script that plots Practical LogWorth by Relative
Practical Difference. Relative Practical Difference is defined as the actual difference divided by
the practical difference.

Y The continuous response variables.
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X The categorical variables.

Leveli The level of the categorical X variable.

Levelj The level of the categorical X variable being compared to Leveli.

Difference The estimated difference in means across the two levels. If the Robust option is

selected, robust estimates of the means are used.

Std Err Diff The standard error of the difference in means. This is a robust estimate if the

Robust option is selected.

Plain Dif PValue The p-value for the usual Student's t test for a pairwise comparison. This is

the robust version of the f test when the Robust option is selected. Tests that are significant
at the 0.05 level are highlighted.

Practical Difference The difference in means that is considered to be of practical interest. If

you assign a Spec Limit property to the Y variable, the practical difference is computed as
the difference between the specification limits multiplied by the Practical Difference
Proportion. If no Practical Difference Proportion has been specified, the Practical
Difference is the difference between the specification limits multiplied by 0.10.

If you do not assign a Spec Limit property to the Y variable, an estimate of its standard
deviation is computed from its interquartile range (IQR). This estimate is

6 = (IQR)/(1.3489795) . The Practical Difference is computed as 6o multiplied by
the Practical Difference Proportion. If no Practical Difference Proportion has been

specified, the Practical Difference is computed as 66 multiplied by 0.10.

Practical Dif PValue The p-value for a test of whether the absolute value of the mean

difference in Y between Leveli and Levelj is less than or equal to the Practical Difference. A
small p-value indicates that the absolute difference exceeds the Practical Difference. This
indicates that Leveli and Levelj account for a difference that is of practical consequence.

Practical Equiv PValue Uses the Two One-Sided Tests (TOST) method to test for a practical

difference between the means (Schuirmann 1987). The Practical Difference specifies a
threshold difference for which smaller differences are considered practically equivalent.
One-sided t tests are constructed for two null hypotheses: the true difference exceeds the
Practical Difference; the true difference is less than the negative of the Practical Difference.
If both tests reject, this indicates that the absolute difference in the means falls within the
Practical Difference. Therefore, the groups are considered practically equivalent.

The Practical Equivalence PValue is the largest p-value obtained on the one-sided ¢ tests. A
small Practical Equiv PValue indicates that the mean response for Leveli is equivalent, in a
practical sense, to the mean for Levelj.
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Practical Result A description of the results of the tests for practical difference and
equivalence. Values are color-coded to help identify significant results.

— Different (Pink): Indicates that the absolute difference is significantly greater than the
practical difference.

— Equivalent (Green): Indicates that the absolute difference is significantly within the
practical difference.

— Inconclusive (Gray): Indicates that neither the test for practical difference nor the test
for practical equivalence is significant.

The Response Screening Personality in Fit Model

If you are interested in univariate tests against linear model effects, you can fit the Response

Screening personality in Fit Model. The report and tables produced test all responses against
all model effects.

¢ “Launch Response Screening in Fit Model”
®  “The Fit Response Screening Report”

e “Fit Response Screening Options”

e “PValues Data Table”

* “Y Fits Data Table”
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Launch Response Screening in Fit Model

Select Analyze > Fit Model. Enter your Ys and model effects. Select Response Screening from
the Personality list.

Figure 22.8 Response Screening from the Fit Model Window
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Degree
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Transform (=
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For more information about the options in the Select Columns red triangle menu, see Using
JMP.

There are two options for robust estimation:

Robust Fit (Huber) Specifies robust (Huber) estimation to down weight outliers for
continuous responses. If there are no outliers, these estimates are close to the least squares
estimates. Note that this option increases processing time.

Very Robust Fit (Cauchy) Specifies very robust (Cauchy) estimation to down weight outliers
for continuous responses. Assumes that the errors have a Cauchy distribution. A Cauchy
distribution has fatter tails than the normal distribution, resulting in a reduced emphasis
on outliers. This option can be useful if you have a large proportion of outliers in your
data. However, if your data are close to normal with only a few outliers, this option can
lead to incorrect inferences. The Cauchy option estimates parameters using maximum
likelihood and a Cauchy link function.

Tip: If both robust options are selected, the platform uses only Cauchy estimation.
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The Informative Missing option provides a coding system for missing values. The Informative
Missing coding allows estimation of a predictive model despite the presence of missing
values. It is useful in situations where missing data are informative. Select this option from the
Model Specification red triangle menu.

Figure 22.9 Informative Missing Option
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For more information about the Fit Model window, see Fitting Linear Models.

The Fit Response Screening Report

The Fit Response Screening report shows two plots:
¢ The FDR PValue Plot
¢ The FDR LogWorth by Rank Fraction Plot

The FDR PValue Plot is interpreted in the same way as for the platform itself. See “The
Response Screening Report”.
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The FDR LogWorth by Rank Fraction plot shows FDR LogWorth values plotted against the
ranks of the p-values. The plotted points decrease or remain constant as rank fraction
increases. The plot gives an indication of what proportion of tests are significant. An example
using the Response Screening personality is given in “Response Screening Personality”.

Fit Response Screening Options

The Fit Response Screening red triangle menu contains options to save the calculated data.

Model Dialog Opens a window containing the model dialog that you have run to obtain the
given report.

Save Estimates Opens a data table in which each row corresponds to a response and the
columns correspond to the model terms. The entries are the parameter estimates obtained
by fitting the specified model. This data table also contains a table variable called Original
Data that gives the name of the data table that was used for the analysis. If you specified a
By variable, JMP creates an estimates table for each level of the By variable, and the
Original Data variable gives the By variable and its level.

Save Prediction Formula Adds columns to the original data table containing prediction
equations for all responses.

Save Least Squares Means Opens a data table where each row corresponds to a response
and a combination of effect settings. The row contains the least squares mean and
standard error for that combination of settings.

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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PValues Data Table

The PValues data table contains a row for each pair consisting of a Y variable and a model
Effect. The columns in the table include the following. If you select the Robust Fit option on
the launch window, the models are fit using Huber M-estimation.

Y The specified response columns.
Effect The specified model effects.

FRatio The test statistic for a test of the Effect. This is the value found in the Effect Tests
report in Least Squares Fit.

PValue The p-value for the significance test corresponding to the FRatio. See Fitting Linear
Models for more information about Effect Tests.

LogWorth The quantity -logg(p-value). This transformation adjusts p-values to provide an
appropriate scale for graphing. A value that exceeds 2 is significant at the 0.01 level
(because -logy(0.01) = 2).

FDR PValue The False Discovery Rate p-value calculated using the Benjamini-Hochberg
technique. This technique adjusts the p-values to control the false discovery rate for
multiple tests. For more information about the FDR correction, see Benjamini and
Hochberg (1995). For more information about the false discovery rate, see “The False
Discovery Rate” or Westfall et al. (2011).

FDR LogWorth The quantity -logo(FDR PValue). This is the best statistic for plotting and
assessing significance. Note that small p-values result in high FDR LogWorth values.

Rank Fraction The rank of the FDR LogWorth expressed as a fraction of the number of tests.
If the number of tests is m, the largest FDR LogWorth value has Rank Fraction 1/m, and the
smallest has Rank Fraction 1. Equivalently, the Rank Fraction ranks the p-values in
increasing order, as a fraction of the number of tests. The Rank Fraction is used in plotting
the PValues and FDR PValues in rank order of decreasing significance.

Test DF The degrees of freedom for the effect test.

The PValues data table also contains a table variable called Original Data that gives the name
of the data table that was used for the analysis. If you specified a By variable, JMP creates a
PValues table for each level of the By variable, and the Original Data variable gives the By
variable and its level.
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Y Fits Data Table

The Y Fits data table contains a row for Y variable. For each Y, the columns in the table
summarize information about the model fit. If you select the Robust Fit option on the launch
window, the models are fit using Huber M-estimation.

Y The specified response columns.

RSquare The multiple correlation coefficient.

RMSE The Root Mean Square Error.

Count The number of observations (or sum of the Weight variable).

Overall FRatio The test statistic for model fit from the Analysis of Variance report in Least
Squares Fit.

Overall PValue The p-value for the overall test of model significance.
Overall LogWorth The LogWorth of the p-value for the overall test of model significance.

Overall FDR PValue The overall p-value adjusted for the false discovery rate. (See “The
Response Screening Report”.)

Overall FDR LogWorth The LogWorth of the Overall FDR PValue.

Overall Rank Fraction The rank of the Overall FDR LogWorth expressed as a fraction of the
number of tests. If the number of tests is m, the largest Overall FDR LogWorth value has
Rank Fraction 1/m, and the smallest has Rank Fraction 1.

<Effect> PValue These columns contain p-values for tests of each model effect. These
columns are arranged in a group called PValue in the columns panel.

<Effect> LogWorth These columns contain LogWorths for the p-values for tests of each
model effect. These columns are arranged in a group called LogWorth in the columns
panel.

<Effect> FDR LogWorth These columns contain FDR LogWorths for tests of each model
effect. These columns are arranged in a group called FDR LogWorth in the columns panel.

The Y Fits data table also contains a table variable called Original Data that gives the name
of the data table that was used for the analysis. If you specified a By variable, JMP creates a
Y Fits table for each level of the By variable, and the Original Data variable gives the By
variable and its level.
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“Example of Tests of Practical Significance and Equivalence”
“Example of the MaxLogWorth Option”
“Example of Robust Fit”

“Response Screening Personality”

Example of Tests of Practical Significance and Equivalence

This example tests for practical differences using the Probe.jmp sample data table.

1.
2.

N o ok W

Select Help > Sample Data Library and open Probe.jmp.
Select Analyze > Screening > Response Screening.

The Response Screening Launch window appears.

Select the Responses column group and click Y, Response.
Select Process and click X.

Type 0.15 in the Practical Difference Portion box.

Click OK.

Click the Response Screening red triangle and select Save Compare Means.

Figure 22.10 shows a portion of the data table. For each response in Y, the corresponding

row gives information about tests of the New and the Old levels of Process.

Figure 22.10 Compare Means Table, Partial View

-

o~ o v s =

16

18
19
20
21
2
2

W

Practical Practical Dif
Y Leveli Levelj X Difference Std Err Diff | Plain Dif PValue  Difference PValue Practical Equiv PValue  Practical Result

DELL_RPNBR New Old Process -0.031048933 0.004326425 8.044596e-13 0.1486469486 1 1.57079e-153 Equivalent
DELL_RPPBR New Old Process  -0.024751371 0.0349025251 04782555718 1.1939335307 1 2.40983e-225 Equivalent
DELW_M1 New Old Process  0.0275288913 0.0205582035 0.1806001982 0.7030518329 1 1.40119e-217 Equivalent
DELW_M2 New Old Process  0.0739317751 0.0017890895 0 00704822866 0.0269479498 09730520502 Different

DELW_NBASE New Old Process  -1.280753006 14836374126 0.388034756  50.689291592 1 6.62236e-223 Equivalent
DELW_NEMIT New Oid Process -0.040133074 0.002521398 7.306034e-56 0.0848381437 1 7.74847e-69 Equivalent
DELW_NENBNI New Oid Process  -0.93842129 0.0220490008 0 0.864024229 0.0003726256 09996273744 Different

DELW_NSINK New Old Process 13973855188 0.0254310074 0 1.0723100972 3.228438e-37 1 Different

DELW_PBASE New Old Process  -0.043649097 0.0037311377 2.908704e-31 0.1296380428 8.21675e-113 Equivalent
DELW_PCOLL New Old Process 1.8169399617 0.0085444762 0 1.17539613 1 Different

DELW_PEMIT New Old Process -0.022697392 0.0534170363 06709186367 1.8265075627 1.2499e-228 Equivalent
DELW_PSINK New Old Process  0.911093371 0.0678503246 1.666427e-40 23558597461 3.147655e-97 Equivalent
DELW_RPNBR New Old Process -0.101421251 0.0100452789 9.008231e-24 0.3464883523 1.6441e-125 Equivalent
DELW_RPPBR New Old Process  0.3015474189 0.0280757905 1.169725e-26 0.9698077792 7.48088e-120 Equivalent
DELW_SICR New Old Process  0.0275370732 0.0176173979 0.1180928699 0.6024110643 7.77189e-215 Equivalent

M1_COMB_VGAT... New Old Process -0.532453055 0.6037284633 03778451214 20.662273741
M1_TRENCH_VG... New Old Process  -0.61657228 0.1695447206 0.0002786205 5.8087989555
M2/M1_CAP_VG.. New Old Process  -0.047230999 0.0978790012 06294372314 3.3496974301
M2 COMB BB V.. New Old Process 0.0001788376 0.1270241159 09988767052 43470387459
M2_COMB_VGAT... New Old Process 0.2971147541 0.2860872543 02990592705 9.7914324315
NISO_TUB-TREN... New Old Process 7.0118092399 0.2482751793 1.58784e-164 9.0621071628
NISO_TUB-TUB_V... New Old Process -0.074789866 0.1081535234 04892691678 3.7013990674
PS_RPNBR New Old Process = -64.69026527 15.2943887 0.0000237641 | 530.27422027

clalalalalalala|alalala - =

1.83138e-223 Equivalent
2.39165e-191 Equivalent
2.54456e-228 Equivalent
3.07472e-234 Equivalent
1.42412e-221 Equivalent
9.077234e-17 Equivalent
897914e-226 Equivalent
3.12381e-189 Equivalent
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10.

Because specification limits are not saved as column properties in Probe.jmp, JMP
calculates a value of the practical difference for each response. The practical difference of
0.15 that you specified is multiplied by an estimate of the 6 range of the response. This
value is used in testing for practical difference and equivalence. It is shown in the Practical
Difference column.

The Plain Difference column shows responses whose p-values indicate significance. The
Practical Diff PValue and Practical Equiv PValue columns give the p-values for tests of
practical difference and practical equivalence. Note that many columns show statistically
significant differences, but do not show practically significant differences.

Display the Compare Means data table and select Analyze > Distribution.
Select Practical Result and click Y, Columns.
Click OK.

Figure 22.11 shows the distribution of results for practical significance. Only 37 tests are
different, as determined by testing for the specified practical difference. For 5 of the
responses, the tests were inconclusive. You cannot tell whether the responses result in a
practical difference across Process.

Figure 22.11 Distribution of Practical Significance Results

£ |=|Practical Result

Incenclusive

Equivalent

Different

4 Frequencies

Level Count Prob
Different 37 0.09561
Equivalent 345 0.89147
Incenclusive 5 0.01292
Total 387 1.00000
N Missing 0

3 Levels

The 37 responses can be selected for further study by clicking on the corresponding bar in the
plot.
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Example of the MaxLogWorth Option

Use the Response Screening MaxLogWorth option to control the LogWorth scale from being
distorted by very large values. When data sets have a large number of observations, p-values
can be very small. LogWorth values provide a useful way to study p-values graphically in
these cases. In some data sets the p-values are so small that the LogWorth scale is distorted by
very large values.

1.
2.
3.

Select Help > Sample Data Library and open Probe.jmp.
Select Analyze > Screening > Response Screening.

In the Response Screening Launch window, select the Responses column group and click
Y, Response.

Select Process and click X.

Select the Robust check box.

Click OK.

The analysis is numerically intensive and might take some time to complete.

In the Response Screening report, open the Robust FDR LogWorth by Effect Size report.

The detail in the plot is difficult to see, because of the huge Robust FDR LogWorth value of
about 58,000. To ensure that your graphs show sufficient detail, you can set a maximum
value of the LogWorth.

Figure 22.12 Robust FDR LogWorth vs. Effect Size, MaxLogWorth Not Set
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8. Repeat step 1 through step 5.
9. Type 1000 in the MaxLogWorth box at the bottom of the launch window.
10. Click OK.
The analysis might take some time to complete.
11. In the Response Screening report, open the Robust FDR LogWorth by Effect Size report.
Now the detail in the plot is apparent.

Figure 22.13 Robust FDR LogWorth vs. Effect Size, MaxLogWorth = 1000
£ FDR LogWorth By Effect Size
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Example of Robust Fit

Select Help > Sample Data Library and open Drosophila Aging.jmp.
Select Analyze > Screening > Response Screening.

Select all of the continuous columns and click Y, Response.

Select line and click X.

Check Robust.

Click OK.

AL A
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Figure 22.14 Robust FDR PValue Plot for Drosophila Data
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Note that a number of tests are significant using the unadjusted robust p-values, as
indicated by the red points that are less than 0.05. However, only two tests are significant
according to the robust FDR p-values. These two points are more easily identified in a plot
that shows FDR LogWorths.

Click the Robust FDR LogWorth by Effect Size disclosure icon.
Drag a rectangle around the point with a Robust FDR LogWorth value that exceeds 1.5.
In the graph, right click and select Row Label.

Figure 22.15 Robust LogWorth by Effect Size for Drosophila Data
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Points above the red line at 2 have significance levels below 0.01 (-log(0.01) =2). A
horizontal line at about 1.3 corresponds to a 0.05 significance level.

10. Click the Robust LogWorth by LogWorth disclosure icon.

Figure 22.16 Robust LogWorth by LogWorth for Drosophila Data
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If the robust test for a response were identical to the usual test, its corresponding point
would fall on the diagonal line in Figure 22.16. The circled point in the plot does not fall
near the line, because it has a Robust LogWorth value that exceeds its LogWorth value.

11. Drag a rectangle around this point in the plot.
12. Find the row for this point in the Result table.

Note that the response, log2in_CG8237 has PValue 0.9568 and Robust PValue 0.0176.
13. Click the Response Screening red triangle and select Fit Selected Items.

A Fit Selected Items report is displayed containing a Oneway Analysis for the response
log2in_CG8237. The plot shows two outliers for the ORE line (Figure 22.17). These outliers
indicate why the robust test and the usual test give disparate results. The outliers inflate
the error variance for the non-robust test, which makes it more difficult to see a significant
effect. In contrast, the robust fit down-weights these outliers, thereby reducing their
contribution to the error variance.



478 Response Screening Chapter 22
Additional Examples of Response Screening Predictive and Specialized Modeling

Figure 22.17 Oneway Analysis for log2in_CG8237
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Response Screening Personality

The Response Screening personality in Fit Model enables you to study tests of multiple
responses against linear model effects.

Select Help > Sample Data Library and open Drosophila Aging.jmp.
Select Analyze > Fit Model.

Select all the continuous columns and click Y.

Select channel and click Add.

Select sex, line, and age and select Macros > Full Factorial.

Select Response Screening from the Personality list.

Click Run.

NS o L=

The Fit Response Screening report appears. Two data tables are also presented: Y Fits
summarizes the overall model tests, and PValues tests the individual effects in the model
for each Y.

To get a general idea of which effects are important, do the following:
8. Run the FDR LogWorth by Rank Fraction script in the PValues data table.
9. Select Rows > Data Filter.
10. In the Data Filter window, select Effect and click Add.

11. In the Data Filter, click through the list of the model effects while you view the selected
points in the FDR LogWorth by Rank Fraction plot.
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Keep in mind that values of LogWorth that exceed 2 are significant at the 0.01 level. The
Data Filter helps you see that, with the exception of sex and channel, the model effects are
rarely significant at the 0.01 level. Figure 22.18 shows a reference line at 2. The points for
tests of the line*age interaction effect are selected. None of these are significant at the 0.01
level.

Figure 22.18 FDR LogWorth vs Rank Fraction Plot with line*age Tests Selected
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Statistical Details for the Response Screening
Platform

The False Discovery Rate

All of the Response Screening plots involve p-values for tests conducted using the FDR
technique described in Benjamini and Hochberg (1995). See also Westfall et al. (2011). This
method assumes that the p-values are independent and uniformly distributed.

JMP uses the following procedure to control the false discovery rate at level o

1. Conduct the m hypothesis tests of interest to obtain p-values py, py,..., Py-

2. Rank the p-values from smallest to largest. Denote these by py<po) < ... <p)-
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3. Find the largest p-value for which p(; < (i/m)a.. Suppose this first p-value is the kth largest,
P)-
4. Reject the k hypotheses associated with p-values less than or equal to py.

This procedure ensures that the false discovery rate does not exceed o

The p-values adjusted for the false discovery rate, denoted p(; pg, are computed as follows:

Pm) fori=m
P(iy), FDR ~ . i |
mzn[P(iJr 1), FDR’ (7)19(,')} fori=m-1,...,1

If a hypothesis has an FDR-adjusted p-value that falls below o, then it is rejected by the
procedure.
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Process Screening
Screen Many Processes for Stability and Capability

Use the Process Screening platform for exploring a large number of processes across time. The
platform calculates process stability and process capability metrics. The platform creates
control charts and detects large process shifts. The platform is intended to expedite the
evaluation of a very large number of processes by enabling you to quickly focus on the

processes that are unstable, not capable of meeting specification limits, or subject to shifts in
the mean.

Based on your initial results, you can choose to explore specific processes graphically or in
greater analytical depth. You can easily access the Control Chart Builder and Process

Capability platforms. You can save detailed results for all of your processes or for specific
processes.

Figure 23.1 Example of a Process Performance Graph
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Overview of the Process Screening Platform

The Process Screening platform facilitates the task of assessing data from a large number of
processes for stability and capability. The results are largely based on control chart
calculations to determine when a process is out of control. The Process Screening platform
enables you to do the following;:

® Specify a constant subgroup size or use a variable containing subgroup identifiers for
control chart calculations using subgroups.

* Use grouping variables. For each combination of values of the group variables, an analysis
is provided for each process variable.

* Use medians to make your centerline and sigma calculations robust to outliers.

* Obtain information about the location of large shifts in the mean of your processes.

You can customize the Summary report to show specific control chart tests, including tests for
changes in process mean and spread. The report also provides capability information when
you supply specification limits. The Process Performance Graph gives you a visual
representation of the performance of your processes in terms of stability and capability. The
Shift Graph shows locations of upshifts and downshifts.

Tip: For information about adding specification limits, see Using [MP.

Process Screening makes it easy to select specific processes for further analysis. The platform
provides small run charts for these processes - the size of the plots makes it easy for you to
view a substantial number at a time. You can also link to Control Chart Builder and the
Process Capability platform for analyses of select processes.

You can save data tables containing results in various forms, either for your entire set of
processes or only for select processes.

Example of Process Screening

The Semiconductor Capability.jmp sample data table contains 128 columns of process
measurements. Each column contains 1,455 measurements. You are interested in identifying
unstable processes. Also, each column contains a Spec Limits column property. If a process is
stable, it is appropriate to calculate its process capability. You proceed to assess both stability
and capability for this data table.

1. Select Help > Sample Data Library and open Semiconductor Capability.jmp.
2. Select Analyze > Screening > Process Screening.

3. Select the Processes column group and click Process Variables.
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Notice that the Control Chart Type is set to Indiv and MR.
4. Click OK.

Figure 23.2 Partial View of Initial Report
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The Process Screening window appears, showing a table of results for each process. The
table is sorted by Stability Index. This is a measure of the stability of a process, where a
stable process has a stability index near 1. Higher values of the stability index indicate a
less stable process. (The sorting is indicated by the caret beside Stability Index in the
report.) You want to take a closer look at processes with a stability index value greater than
or equal to 1.03.

5. In the report window, select processes PMS1 through IVP9.
Each of these first 11 processes has a value of 1.03 or larger in the Stability Index column.

6. Right-click the selected processes and select Quick Graph for Selected Items.

Figure 23.3 Quick Graphs for Highest Alarm Rate Processes
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You decide to take a closer look at IVP8 (row 3, column 1 in the Graphs of Selected Items).
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7. Select the second process in the Summary table, which corresponds to IVP8.

8. Right-click the selected process and select Control Charts for Selected Items.

Figure 23.4 Control Chart Builder Report for IVP8
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A Control Chart Builder report appears. Because IVP8 has a Spec Limits column property,
the report also includes a capability analysis.
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Launch the Process Screening Platform

Launch the Process Screening platform by selecting Analyze > Screening > Process
Screening.

Figure 23.5 Process Screening Launch Window

Uses control chart metrics to quickly screen a large number of processes for stability.
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For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Launch Window Roles

Process Variables The columns of process data containing the measurements to be
analyzed. The columns must have a Numeric data type. If a process variable has a Control

Limits column property, the Process Screening platform uses those limits to calculate the
Specified Sigma.

Note: The platform does not support control limits that are specified in a Control Limits
column property for dispersion (R) charts.
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Grouping Columns assigned as grouping variables. Each process variable is analyzed at each
combination of levels of the grouping variables. The results are presented in a single
report.

Subgroup Assigns one or more subgroup variables. If more than one subgroup variable is
assigned, the subgroup levels are defined as a combination of the multiple columns.

Note: The Subgroup role is ignored for Indiv and MR charts.

Time A numeric column whose values are used for the time order for the data. Use the Time
role for data that are time-stamped. The time stamp is used for the time axis in quick
graphs and shift graphs. The process data are sorted by the Time variable before
calculations are performed.

By A column whose levels define separate analyses. For each level of the specified column,
the corresponding rows are analyzed using the other variables that you have specified.
The results are presented in separate tables and reports. If more than one By variable is
assigned, a separate analysis is produced for each possible combination of the levels of the
By variables.

Launch Window Options

Control Chart Type Select one of five control chart types: Indiv and MR (Individual
Measurement and Moving Range); XBar and R; XBar and S; XBar, MR, and R; or XBar, MR,
and S. The XBar, MR, and R control chart and the XBar, MR, and S control chart are also
referred to as three way control charts. For more information about statistical details, see
Quality and Process Methods.

Note: If the subgroup size for a process is 1, the chart automatically switches to an Indiv
and MR chart.

Subgroup Sample Size Specifies a constant sample size for subgroups. The minimum
subgroup size is 2. A subgroup size of 5 is the default. The Subgroup Sample Size
specification is ignored for Indiv and MR charts or when a subgroup variable is specified.

KSigma Specifies the sigma multiplier. KSigma is the value that is multiplied by sigma in the
calculation of control limits. By default, KSigma is 3.

Use Limits Table Enables you to import historical control limits and specification limits from
a data table. When you select this option and click OK in the launch window, a Choose
limits table window appears. Once you choose a limits tables and click OK, a Limits
Specification window appears. Assign columns in your limits table to appropriate roles
and click OK. See “Limits Table”.
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Note: If you do not select this option, limits are obtained from the Control Limit and
Specification Limit column properties for the Process Variables. If you do not select this
option and the Process Variables do not have control limit column properties, the control
limits are calculated from the data.

Use Medians instead of Means Estimates the center line using the median of the
observations. Sigma is estimated using scaling factors obtained using Monte Carlo
simulation. The table of factors is given in “Statistical Details for the Process Screening
Platform”. The calculation depends on the type of chart selected:

— For XBar and R chart or Indiv and MR chart calculations, sigma is estimated using the
scaled median of the ranges.

— For XBar and S chart calculations, sigma is estimated using the scaled median of the
standard deviations.

— For unequal subgroup sizes, the scaling factor corresponds to the average subgroup
size rounded to the nearest integer.

When one or more outliers influence the location of the center line, many subgroups can
appear out of control. Using the median alleviates this problem.

Note: When Use Medians instead of Means is selected, the results obtained from the
Control Charts for Selected Items or the Process Capability for Selected Items red triangle
menu options do not match the Process Screening results.

Sort by Subgroup Sorts the process data by the subgroup variable, or combination of nested
subgroup variables, before calculations are performed.

Advanced Options Contains the following options:

Shift Threshold Specify a value that controls the sensitivity of the Shift Graph. Shift
Threshold is set to three by default. After outlier removal, the Shift Graph shows a plot
of the time occurrence of all process shifts that exceed the number of within-sigma
units specified by the Shift Threshold. See “Shift Graph”.

Outlier Threshold Specify a value that controls the sensitivity of outlier removal for
detection of large recent shifts and for the Shift Graph. Outlier Threshold is set to five
by default. If the number of within sigma units from an observation to both of its
neighboring observations exceeds the specified Outlier Threshold, that observation is
replaced with a value that is one within-sigma unit away from its closest neighboring
observation. See “Shift Magnitudes and Positions”.

Shift Lambda Enables you to change the exponentially weighted moving average
(EWMA) weight used in the Shift Graph. See “Shift Magnitudes and Positions”.
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Drift Beta The weight used in the exponentially weighted moving average (EWMA) for
drift detection. Drift Beta is set to 0.05 by default.

Minimum Process Length The minimum number of data values that a process must
have in order to be included in the analysis. By default, this value is set to 3.

Limits Table

A Limits Table contains a row for each process defined by the Process Variables and Grouping
variables in your table of process data. When you use a Limits Table, the Limits Specifications
window enables you to specify variables with the roles listed below. You do not need to
specify variables for all of these roles. All of these roles are optional.

Figure 23.6 Limits Specifications Window
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Columns in the Limits Table that have appropriate names or names that match the role
buttons are auto-filled. For example, any column called “Process”, “Column”, or “Parameter”
is auto-filled into the Process Variables list.
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If you have control limits but do not have columns for Center or Sigma, then you can use the
Derived Sigma options.

Process Variables A column that contains values corresponding to the column names in
your table of process data.

Grouping One or more columns that contain the values of the grouping variables for your
table of process data.

Center A column containing values for the center line for each process. This is usually the
historical process mean.

Sigma A column containing values for the within standard deviation for each process. This
is usually the historical standard deviation. This is labeled as Specified Sigma in the
Process Screening report.

Derived Sigma Calculates sigma based on the given control limits and subgroup size. This is
labeled as Specified Sigma in the Process Screening report.

Note: If there is a specified sigma, the within-sigma, stability index, and stability ratio
values do not match between the Process Screening and Control Chart Builder platforms.
The Process Screening platform uses the specified sigma to calculate the control limits, but
still calculates the within-sigma using the data. The Control Chart Builder platform uses
the specified sigma as the historical sigma and in control charts, the historical sigma is
used as the within-sigma.

The derived sigma is calculated as follows:
Sigma = d*(UCL - LCL)/6

where d is the square root of the subgroup size.

LCL A column containing the lower control limits for each process.

UCL A column containing the upper control limits for each process.

Subgroup Size A column containing the subgroup size for each process.
LSL A column containing lower specification limits for each process.
USL A column containing upper specification limits for each process.
Target A column containing a target value for each process.

Importance A column containing an importance value for each process. The Importance
column provides a mechanism to sort processes in the order that you prefer.
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The Process Screening Report

The Process Screening report opens with a Summary table that contains results about process
stability. There is a label above the summary table that shows the type of control chart on
which the results are based. The sample size or subgroup variable is also shown above the
summary table for every chart type except for Indiv and MR. The summary table also contains
capability results if you have provided specification limits. The processes and groups are
initially sorted in decreasing order by Stability Index. If Importance values are specified by the
user, the processes and groups are sorted in decreasing order by Stability Index within
Importance. The columns for Stability Index, Ppk, Cpk, Cp, and Target Index are colored as
green, yellow, and red to indicate adequate, marginal, and poor stability or capability,
respectively. This color coding scheme matches the Process Performance graph color coding
scheme.

Tip: To sort the report by a column, click the column name. A caret appears to the right of the
column name. The direction of the caret indicates whether the sorting is descending or
ascending. To change the order of the sorting, click the column name again.

The control chart calculations in the Summary table include Nelson tests and a Range Limit
Exceeded test. These tests assume the following about the control chart limits:

® The center line for the XBar or X control charts is given by the mean of all measurements. If
you use the Medians instead of Means option, the center line is given by the median of the
observations.

* Control limits are placed at K sigma units from the center line. Use the KSigma option in
the launch window to specify K. By default, KSigma is 3.

* Sigma is estimated using the conventions that correspond to the control chart type that
you specified or, if you use Medians instead of Means, as described in “Use Medians
instead of Means”.

Tip: The eight Nelson tests in the Process Screening platform follow the test settings in the
Control Chart Builder platform preferences. You can customize the tests at File > Preferences >
Platforms > Control Chart Builder.

The Summary table can contain the following information:

Column The columns that you entered as Process. There is a row for each distinct
combination of Process and Grouping columns. This column is suppressed if there is only
one process column.

Tip: To access options that operate on selected items, right-click the Column column.
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Grouping Columns There is a report column for each column in the data table that you
entered as Grouping. The levels of the Grouping columns are listed so that there is a
unique row in the report table for each distinct combination of Process name and
Grouping columns values.

Importance (Appears only when there are importance values specified by the user, as inputs
from a limits table.) The user-specified importance value for the processes.

Variability Contains the following columns:

Stability Index A measure of stability of the process. A stable process has a stability index
near one. Higher values indicate less stability. The stability index is defined as follows:

(Overall Sigma / Within Sigma)
If a three way control chart is selected in the launch, the stability index is defined as
follows:

(Overall Sigma / Between-and-Within Sigma)

Stability Ratio A measure of stability of the process. A stable process has a stability ratio
near one. Higher values indicate less stability. The stability ratio is defined as follows:

(Overall Sigma / Within Sigma)?

If a three way control chart is selected in the launch, the stability ratio is defined as
follows:

(Overall Sigma / Between-and-Within Sigma)?

Within Sigma An estimate of the standard deviation based on within subgroup variation.
The estimate is based on the control chart type that you specified, and is a short-term
measure of variation. See Quality and Process Methods for statistical details. If you select
Medians instead of Means, Within Sigma is computed as described in “Use Medians
instead of Means”.

Overall Sigma The usual estimate of standard deviation based on all observations.

Between Sigma (Appears only when three way control chart is selected in the launch
window.) An estimate of the standard deviation based on the variation between
subgroups. See Quality and Process Methods for statistical details.

Between-and-Within Sigma (Appears only when three way control chart is selected in
the launch window.) An estimate of the standard deviation based on the variation
between subgroups and the variation within subgroups. The Between-and-Within
Sigma estimate is defined as follows:

Between-and-Within Sigma = «/ Within Sigma2 + Between Sigma2
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Specified Sigma The standard deviation specified by a sigma control limit in the Limits
Specification dialog or an estimate of the standard deviation derived from the control
limits and subgroup size. See “Derived Sigma”. The control limits and subgroup size
can be specified using a limits table or a Control Limits column property.

Summary Contains the following columns:

Centerline (Appears if you do one of the following: select Use Medians instead of Means
in the launch window, import a Center value using a limits table, or import control
limits to derive sigma.) The value listed under Centerline is used in control chart
calculations as the center line.

— If you select Use Medians instead of Means in the launch window, the overall median
of the observations is displayed.

— If you import a Center value from a limits table, that value is displayed.

— If you import control limits, the value displayed is calculated as (UCL + LCL)/2.
Mean The average of all observations.
Count The number of observations.

N Subgroups The number of subgroups.

Control Chart Alarms Contains information about the subgroups that result in alarms for a

variety of tests, including each of the 8 Western Electric rules. The standard deviation
estimate is the Within Sigma value. By default, only the Alarm Rate, Test 1, and Latest
Alarm columns are shown in the Summary table.

Alarm Rate The number of subgroups that resulted in alarms for any of the tests selected
under the Choose Test option (Any Alarm) divided by the number of non-missing
subgroups (Subgroups).

Any Alarm (Appears only when more than one Test column is shown.) The number of
subgroups that trigger alarms for any of the tests selected under the Choose Test
option. These are the eight Nelson tests and the test for Range Limit Exceeded.

Tip: The eight Nelson tests in the Process Screening platform follow the test settings in the
Control Chart Builder platform preferences. You can customize the tests at File >
Preferences > Platforms > Control Chart Builder.

Test1 One point is more than three standard deviations from the center line. The
subgroup associated with that point triggers the alarm.

Test2 Nine or more consecutive points are on the same side of the center line. The
subgroup associated with the ninth point triggers the alarm.
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Test 3 Six or more consecutive points are continually increasing or decreasing. The
subgroup associated with the sixth point triggers the alarm.

Test4 Fourteen consecutive points alternate in direction: increasing and then decreasing
or decreasing and then increasing. The subgroup associated with the 14th point
triggers the alarm.

Test5 Two out of three consecutive points on the same side of the center line are more
than two standard deviations from the center line. The subgroup associated with the
second point that exceeds two standard deviations triggers the alarm.

Test6 Four out of five consecutive points on the same side of the center line are more
than one standard deviation from the center line. The subgroup associated with the
fourth point that exceeds one standard deviation triggers the alarm.

Test 7 Fifteen consecutive points, on either side of the center line, are all within one
standard deviation of the center line. The subgroup associated with the 15th point
triggers the alarm.

Test8 Eight consecutive points, on either side of the center line, all fall beyond one
standard deviation of the center line. The subgroup associated with the eighth point
triggers the alarm.

Range Limit Exceeded The number of subgroups that exceed the upper control limit on
the R, S, or MR chart calculation.

Moving Range Limit Exceeded The number of subgroups that exceed the moving range
limit on the three way control chart calculation.

Latest Alarm The position of the subgroup, counting from the last subgroup, that
signaled the most recent alarm for any of the Nelson or Range Limit Exceeded tests.

Capability (Appears only when there are Spec Limits specified for some processes.) Contains
the following options:

Ppk Capability index based on Overall Sigma and assuming a normal distribution. See
Quality and Process Methods for statistical details. On by default.

Cpk Capability index based on Within Sigma or Between-and-Within Sigma and
assuming a normal distribution. See Quality and Process Methods for statistical details.
On by default.

Cp The potential capability if target and drift issues are resolved. See Quality and Process
Methods for details.
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Target Index The number of short-term standard deviations that the process average
differs from the target value. This measures the ability of the process to hit the target
value. The Target Index is calculated as 3(Cp - Cpk). A target index is considered poor
if above 1, marginal if between 0.5 and 1, and adequate if less than 0.5. See White et al.
(2018).

Out of Spec Count The number of observations that fall outside the specification limits.
On by default.

Out of Spec Rate The proportion of observations that fall outside the specification
limits. On by default.

Expected Out of Spec Rate The expected proportion of observations that fall outside of
the specification limits. The Expected Out of Spec Rate assumes a stable and normally
distributed process and uses overall sigma.

Latest Out of Spec The number of observations, counting from the last observation to
the most recent observation that falls outside the specification limits. On by default.

(Mean-Tgt)/SpecRange The spec centered mean. This is the same as the Mean Shift
Standardized to Spec in Process Capability. See Quality and Process Methods for
statistical details.

StdDev/SpecRange The spec scaled standard deviation. This is the same as the Std
Deviation Standardized to Spec in Process Capability. See Quality and Process Methods
for statistical details.

LSL The lower specification limits.
USL The upper specification limits.

Target The target value.

Shift Magnitudes and Positions (Shown only if you have selected a Shift Detection option

from the Process Screening red triangle menu.) Shift detection is performed to identify
shifts that exceed one within-sigma unit. The algorithm uses outlier-correction and an
EWMA smoothing approach for the individual observations. This is the algorithm:

— Outliers are removed so that single outliers do not indicate shifts. The value specified
as Outlier Threshold (five by default) on the launch window controls the sensitivity of
outlier removal. If the number of within-sigma units from an observation to both of its
neighboring observations exceeds the specified Outlier Threshold, that observation is
replaced with a value that is one within-sigma unit away from its closest neighboring
observation.

— An EWMA fit is constructed for the subgroup means in forward time order and
another EWMA fit is constructed for the subgroup means in reverse time order. The
EWMA fits have lambda equal to 0.3.
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— The largest positive and negative differences between successive EWMA values that
exceed one within-sigma unit are identified.

— The absolute values of these differences, divided by the within estimate of sigma, are
the values reported as Largest Upshift and Largest Downshift.

— The locations of the first subgroups involved in these largest shifts define the Upshift
Position and Downshift Position.

Largest Upshift The magnitude of the largest upward shift that exceeds one
within-sigma unit, reported in within-sigma units.

Upshift Position or Upshift <Time Variable> The position of the subgroup having the
largest Upshift. If you specify a Time variable, the column in the Summary table is
named Upshift <Time Variable> and the position of the shift is given in terms of the
Time variable.

Largest Downshift The magnitude of the largest downward shift that exceeds one
within-sigma unit, reported in within-sigma units.

Downshift Position or Downshift <Time Variable> The position of the subgroup having
the largest Downshift. If you specify a Time variable, the column in the Summary table
is named Downshift <Time Variable> and the position of the shift is given in terms of
the Time variable.

Drift Magnitudes and Positions (Shown only if you have selected the Drift Summaries

option from the Process Screening red triangle menu.) Drift detection is performed to
detect smaller, more gradual changes in processes. The algorithm is identical to the one
used in shift detection, except that drift detection uses a Holt Double-Exponential
Smoother instead of an EWMA. This is the algorithm:

— Outliers are removed through the same process that is used in shift detection. See
“Shift Magnitudes and Positions”.

— The drift detection algorithm fits a Holt Double-Exponential Smoothing model for the
subgroup means in forward time order and fits another Holt Double-Exponential
Smoothing model for the subgroup means in reverse time order. The two smoothing
model fits each have two smoothing constants: a for the level and B for the slope. The 8
smoothing constant is set at 0.05 and the o smoothing constant is estimated to
minimize the error.

— The means of the positive drift values, negative drift values, and absolute drift values
are reported as Mean Up Drift, Mean Down Drift, and Mean Abs Drift, respectively.

Mean Up Drift The sum of the positive drift values divided by the count.
Mean Down Drift The sum of the negative drift values divided by the count.

Mean Abs Drift The sum of the absolute value of all drift values divided by the count.
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Note: Process Screening does not utilize the Distribution or Process Capability Distribution
column properties and always performs capability analyses assuming a normal distribution. If
the distribution type for one of these column properties is non-normal, a Warnings outline is
shown below the Summary table.

Process Screening Platform Options

The Process Screening red triangle menu contains options to customize the display and to
save calculated statistics. The options that operate on selected items are also accessible by
right-clicking the Column column in the Summary table.

Summary Shows or hides the Summary table. See “The Process Screening Report”.

Find and Select Enter search strings for columns that you entered as Process Variables or
Grouping in the launch window. A panel appears for each column. The corresponding
processes are selected in the Summary table.

Select Where Opens the Select Where window. You can select specific processes in the
Summary table that correspond to a particular condition by using the Comparison menu
and Value text box. For example, you can select all processes such that Ppk < 1.33. After
you click OK, the processes are selected in the Summary table.

Tip: You can also access the Select Where window by right-clicking anywhere in the
Summary table.

Show Summary Columns Enables you to choose some of the summary columns that are
shown in the Summary table.

Quick Graph for Selected Items Plots small graphs of the processes that you select in the
Summary table in a Graphs of Selected Items report. The report makes it possible to view
and compare many processes at once. The plots are ordered according to their order of
entry on the launch window. Each quick graph also has lines for the spec limits. There is a
solid blue line for the target value and dotted blue lines for the LSL and USL values. To
remove the quick graphs, click the Graphs of Selected Items red triangle and select
Remove.

Tip: To change the layout of the quick graphs, click the Graphs of Selected Items red
triangle and select Number of Plots Across.

Control Charts for Selected ltems Opens a Control Chart Builder report window for the
processes that you selected in the Summary table. The control chart corresponds to your
selections in the Process Screening launch window.
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Notes:

Only the tests selected in Process Screening are sent to Control Chart Builder. Tests that
have been turned off are not sent.

If you have multiple subgroup variables where the inner subgroup variable is not
sorted within the outer subgroup variable, a new subgroup variable column is created
and used when Control Charts for Selected Items is launched. This does not apply if
Sort by Subgroup is selected in the Process Screening launch window.

Process Capability for Selected ltems Opens a Process Capability report window showing

Individual Detail Reports for the processes that you select in the Summary table. If you
select a process for which specification limits are not specified, a Spec Limits window
appears. In this window, you can specify specification limits by selecting a data table or

entering values directly.

The Process Capability analysis assumes normal distributions and uses within sigma
values that correspond to your Control Chart Type selection in the Process Screening
launch window:

— Moving range for Indiv and MR

— Average of ranges for XBar and R

— Average of unbiased standard deviations for XBar and S

Notes:

— If you specify sigma using a sigma control limit or the Derived Sigma option in the

Limits Specifications window, this value is not used in Process Capability. This is
because the Process Screening and Process Capability platforms use these control limits
differently.

If you have multiple subgroup variables where the inner subgroup variable is not
sorted within the outer subgroup variable, a new subgroup variable column is created
and used when Process Capability for Selected Items is launched. This does not apply
if Sort by Subgroup is selected in the Process Screening launch window.

Color Selected Iltems Applies a color of your choosing to the values in the selected rows of
the Summary table.

Remove Selected ltems Removes the rows selected in the Summary table and reruns the
analysis without those processes.

Show Tests Shows or hides test results for Nelson tests that are selected under the Choose
Tests option in the Process Screening report’s summary table.

Choose Tests Enables you to choose the tests that you want to include in the calculation of
Alarm Rate and Any Alarm.
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Tip: To select multiple tests, press Alt and click the Process Screening red triangle to open
a menu of all platform options.

Shift Detection Provides options for detecting shifts after outlier removal. See “Shift
Magnitudes and Positions”.

Largest Upshift Adds columns for Largest Upshift and Upshift Position to the Summary
table. The largest upward shift in the series that exceeds one within-sigma unit is
identified. See “Shift Magnitudes and Positions”.

Largest Downshift Adds columns for Largest Downshift and Downshift Position to the
Summary table. The largest downward shift in the series that exceeds one within-sigma
unit is identified. See “Shift Magnitudes and Positions”.

Shift Graph (Available only when some processes have shifts that exceed the Shift
Threshold.) Shows a plot of the time occurrence of all process shifts that exceed the
number of within-sigma units specified by the Shift Threshold (three by default). You
can also change the Shift Threshold by using the slider bar on the Shift Graph. Hover
over the diamond to see the value. Green markers indicate upshifts and red markers
indicate downshifts. The markers are located at the local peaks of the shifts.

To identify the processes that correspond to one or more shift occurrences, select the
points and click Select Process. The corresponding processes are selected in the
Summary table. Processes that have no shifts exceeding the Shift Threshold number of
within-sigma units are not plotted.

Note: The Shift Graph does not show the positions of Largest Upshift and Largest
Downshift values that appear in the Summary table if the shifts are less than the specified
Shift Threshold number of within-sigma units in magnitude. See “Additional Example of
Process Screening”.

Show Shifts in Quick Graphs (Available only when a Quick Graph has been added to the
report window.) Shows the location of the shifts in the Quick Graphs using green and
red vertical lines.

Drift Summaries Adds columns for Mean Up Drift, Mean Down Drift, and Mean Abs
Drift to the Summary Table. See “Drift Magnitudes and Positions”.

Drift Graph Selected Displays a drift graph for each process that you select in the
Summary Table. Drift graphs enable you to detect smaller, more gradual changes in the
selected processes. The values plotted are the slope estimates from a Holt
Double-Exponential Smoothing model. See “Drift Magnitudes and Positions”. Each
drift graph displays the within-sigma value and the estimates for the two smoothing
parameters in the Holt Double-Exponential Smoothing model.
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Process Performance Graph (Available only when specification limits are defined for at
least one process variable.) Shows a four-quadrant graph that assesses the performance of
processes in terms of stability and capability. See “Process Performance Graph”.

Process Performance Graph Boundaries (Available only once the Process Performance
Graph is in the report window.) Opens a window where you can set values for the Process
Performance Graph's stability index and Ppk capability boundaries.

Tip: You can set preferences for your desired boundaries for Stability Index and Ppk
Capability in File > Preferences > Platforms > Process Screening.

Goal Plot (Available only when specification limits are defined for at least one process
variable.) The Goal Plot shows, for each variable, the spec-normalized mean shift on the X
axis, and the spec-normalized standard deviation on the Y axis. If you define importance
values for the processes, the goal plot points are sized by importance. It is useful for
getting a quick, summary view of how the variables are conforming to specification limits.
See Quality and Process Methods for more information about goal plots and their features.

Tip: Hover over a point in the Goal Plot to view the Quick Graph for that process. Click the
Quick Graph to add it to the report window.

The Goal Plot red triangle menu contains the following options:

Show Within Sigma Points Shows or hides the points calculated using the within sigma
estimate.

Show Within or Between-and-Within Sigma Points (Available only when three way
control chart is selected in the launch window.) Shows or hides the points calculated
using the between-and-within sigma estimate.

Show Overall Sigma Points Shows or hides the points calculated using the overall sigma
estimate.

Shade Levels Shows or hides the Ppk level shading. This is turned on by default. The
shaded areas depend on the relationship between p and Ppk, with p representing the
value shown in the box beneath Ppk. By default, p = 1.33.

— Points in the red area have Ppk <p.
— Points in the yellow area have p < Ppk < 2p.

— Points in the green area have 2p < Ppk.

Label Within Sigma Points Shows or hides labels for points calculated using the within
sigma estimate.
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Label Within or Between-and-Within Sigma Points (Available only when a three way
control chart is selected in the launch window.) Shows or hides labels for points
calculated using the between-and-within sigma estimate.

Label Overall Sigma Points Shows or hides labels for points calculated using the overall
sigma estimate.

Defect Rate Contour Shows or hides a contour representing a specified defect rate.

Show Capability (Available only when specification limits are defined for at least one
process variable.) Displays a submenu that enables you to show or hide the Capabilities in
the Summary table.

Note: Spec Centered Mean and Spec Scaled Std Dev are displayed in the Summary table
as (Mean-Tgt)/SpecRange and StdDev/SpecRange. The Spec Limits option displays the
LSL, USL, and Target columns in the Summary table.

The following option is also available in the submenu:

Color Out of Spec Values Colors the cells in the data table that correspond to values that
are out of spec. The cell is colored blue if the value is above the USL and red if the value
is below the LSL.

Tip: To remove colors in specific cells, select all cells of interest. Right-click in one of the
cells and select Clear Color.

Save Summary Table Saves all of the information that can appear in the Summary table to a
Process Summary data table. The Process Summary data table also contains specification
limit details, if these are specified for at least one process. As in the summary table, the
columns for Stability Index, Ppk, Cpk, Cp, and Target Index are colored as green, yellow,
and red to indicate adequate, marginal, and poor stability or capability, respectively.

Save Summary Table with Graphs Creates the Process Summary data table with an
additional column titled Graph. The Graph column contains a quick graph for each process
in the Process Summary table.

Save Details Table Saves detailed information about control chart calculations to a Process
Details data table. For each combination of process and grouping variables, the table
contains a row for each subgroup showing:

— The value of the subgroup variable
— The values of the subgroup sample statistics.
— The control limits.

— The subgroup size.
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— Alist of indicators for which, if any, alarms were triggered. Alarms for the Nelson tests
are indicated with the numbers for the tests. An alarm for the Range Limit Exceeded
test is indicated with an R.

— The Drift

Save Selected Details For the selected rows in the Summary table, saves a Process Details
table with the information that is saved when you select Save Details Table.

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.

Process Performance Graph

The Process Performance Graph is a four-quadrant plot of capability versus stability. Each
process for which specification limits are provided is represented by a marker. The marker
type depends on if the process violates guidelines for the Target Index and Cp values. A
left-pointing triangle indicates the process is below target, a circle indicates the process is on
target, and a right-pointing triangle indicates the process is above target. An open marker
indicates that the variation of the process is adequate and a filled marker indicates that the
variation of the process could be reduced. A complete description of the marker combinations
is provided in Table 23.1. Additionally, if you define importance values for the processes, the
markers on the Process Performance Graph are sized by importance.
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Table 23.1 Process Performance Graph Markers

Graph Marker Target Index Cp

@) On Target Adequate Variation

® On Target Reduce Variation

D Above Target Adequate Variation

> Above Target Reduce Variation

q Below Target Adequate Variation

< Below Target Reduce Variation

On the graph, the horizontal coordinates represent the stability index of the process and
the vertical coordinates represent the capability of the process, given as Ppk. The graph is
divided into four quadrants based on the following default boundaries:

— A stability index that exceeds 1.25 indicates that the process is unstable.
— A Ppk that is smaller than 1.33 indicates that the process is not capable.

Additionally, there is a red line on the graph at 1.33 divided by Stability Index that
indicates where the Cpk value is 1.33. This line categorizes the processes in the unstable
and incapable quadrants in terms of how they might be fixed. Processes below the red line
are fixable by special causes; processes above the red line are fixable by reducing
variability. Selecting points in the graph selects the corresponding processes in the
Summary table.

Tip: Hover over a point in the Process Performance Graph to view the Quick Graph for
that process. Click the Quick Graph to add it to the report window.
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Additional Example of Process Screening

This example illustrates the use of a Grouping column and the construction of a Shift Graph
using Consumer Prices.jmp.

The consumer price index data table contains monthly data on 17 products. The time periods
vary by product. The data are arranged so that all 17 products are listed in a single column
called Series. To separate the products, you must treat Series as a Grouping column.

1.

2
3.
4

o1

10.
11.

Select Help > Sample Data Library and open Consumer Prices.jmp.
Select Analyze > Screening > Process Screening.

Select Price and click Process Variables.

Select Series and click Grouping.

This ensures that each level of Series is treated as a separate process.
Select Date and click Time.

Set the Control Chart Type to XBar and R.

Set the Subgroup Sample Size to 3.

Because the data are given monthly, subgroups of size three represent quarters.
Click OK.

Press Alt and click the red triangle next to Process Screening.

This opens a window showing the available red triangle options. You can select multiple
options at once in this window.

Check the following: Largest Upshift, Largest Downshift, and Shift Graph.
Click OK.

The columns Largest Upshift, Upshift Date, Largest Downshift, and Downshift Date are
added to the Summary table. The shifts are the largest shifts exceeding one within-sigma
unit. The position of each shift is given in terms of the Time variable, Date. See “Shift
Magnitudes and Positions”.

A Shift Graph also appears. The Shift Graph shows all shifts that exceed the number of
Shift Threshold within-sigma units, which is set to three by default. See “Shift Graph”.
Green points correspond to upshifts and red points correspond to downshifts.

Notice that Gasoline, All has values for both Largest Upshift and Largest Downshift in the
Summary table. The Largest Downshift value, 1.8296, is less than three. Because the Shift
Graph shows shifts of only three or more within-sigma units, the Largest Downshift value
for Gasoline, All is not plotted on the Shift Graph.

Also notice that Tomatoes is not included on the Shift Graph. For Tomatoes, no shifts of
three or more within-sigma units were found.
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12. Double-click the horizontal axis of the Shift Graph to open the X Axis Settings window.

13. In the Tick/Bin Increment panel, set # Minor Ticks to 1.
14. Set Label Row Nesting to 2.
15. Click OK.

Figure 23.7 Shift Graph

4 =| Process Screening
< Shift Graph

Price Oranges
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Price Bread
Price Bananas
Price Apples
19Jan 22Mar 22May 23Jul 225ep 23Nov 24Jan 26Mar 27May 27Jul
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Time

Select Process

®  Upshift
® Downshift
Shift Threshold

Most series show primarily upshifts. Price Coffee, however, has several alternating
downshifts and upshifts. To better understand this series, obtain a control chart.

16. Select any point to the right of Price Coffee in the Shift Graph and click Select Process.

This action selects the row of the Summary table corresponding to Coffee.

17. Right-click the selected process in the Summary table and select Control Charts for

Selected Items.
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Figure 23.8 Control Chart for Coffee
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XBar & R chart of Price
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The control chart shows the upshifts and downshifts that are identified in the Shift Graph.

The Summary table indicates that the largest upshift (25.399 within-sigma units) occurs for
the subgroup that includes September 1994. In the control chart in Figure 23.8, this is the
subgroup in position 59. The Summary table also indicates that the largest downshift
(9.1674 within-sigma units) occurs for the subgroup that includes March 1981. This is the
subgroup in position 5 in the control chart.

Because shifts are calculated using EWMA-smoothed series and an outlier-correction
algorithm, the shift positions might not precisely correspond to the subgroups that seem
to start the shifts on a Shewhart control chart.

Statistical Details for the Process Screening
Platform

Scaling Factors for Using Medians to Estimate Sigma

When you select Use Medians instead of Means, sigma is estimated using a scaled median
range or median standard deviation. The table below gives the scaling factors, which were
obtained using Monte Carlo simulation.
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For subgroups of size n drawn from a normal distribution, the following are true:

The theoretical median of the ranges is approximately d2_Median*c, where d2_Median is
the value corresponding to .

The theoretical median of the standard deviations is approximately c4_Median*c, where
c4_Median is the value corresponding to n.

Table 23.2 Scaling Constants for Median Range and Median Standard Deviation

d2_Median

0.953
1.588
1.978
2.257
2471
2.646
2.792
2915
3.024
3.118
3.208
3.286
3.357
3.422
3.483
3.539
3.590
3.640
3.685
3.731
3.770

c4_Median
0.675
0.833
0.888
0.917
0.933
0.944
0.952
0.959
0.963
0.967
0.969
0.972
0.975
0.976
0.978
0.979
0.980
0.981
0.982
0.983
0.984
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Table 23.2 Scaling Constants for Median Range and Median Standard Deviation (Continued)

n d2_Median c4_Median
23 3.811 0.984
24 3.846 0.985

25 3.883 0.986
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Predictor Screening
Screen Many Predictors for Significant Effects

The analysis of large data sets, where hundreds to thousands of measurements on a part,
process, or sample are taken requires innovative approaches. The Predictor Screening
platform provides a method of screening many predictors for their ability to predict an
outcome. For example, predictor screening can be used to help identify biomarkers from
thousands tested in samples from patients with and without a condition to predict the
condition.

Predictor screening differs from response screening. Response screening tests factors one at a
time as a predictor of the response. Predictor screening uses bootstrap forest partitioning to
evaluate the contribution of predictors on the response. The partition models are built on
multiple predictors. Predictor screening can identify predictors that might be weak alone but
strong when used in combination with other predictors. See “Response Screening”.

Figure 24.1 Example of a Predictor Screening Report

£ | Predictor Screening

Banding? Copy Selected
Predictor Contribution Portion Rank
ink pct 27.3767 0.1609 1
solvent pct 14,5981 0.0838 2
press 14,0203 0.0824 B
varnish pct 13.6577  0.0803 4
roller durometer 11.8470  0.0696 5
press speed 11.0130  0.0847 ]
ESA Voltage 71478 0.0420 0] 7
viscasity 60070 0.0411 0] 8
press type 65136 0.0382 ) 9
ESA Amperage 64143 0.0377 ] 10
grain screened 4.6011  0.0270 :l 11
unit number 4.3955  0.0238 :| 12
humidity 41744 00245 [l 13
blade pressure 40893  0.0240 [l 14
paper mill location 3.7328  0.0219 [ 15
ink type 16758 0.0216 [0 16
ink temperature 34103  0.0200 :| 17
type on cylinder 28272 0.0166 1 18
proof cut 2.8073 0.0165 :| 19
hardener 27884 0.0164 [ 20
anode space ratio 22320 0.0131[0 21
current density 1.8053 0.0106 ] 22
caliper 1.6249  0.0005 (] 23
cylinder size 13343  0.0078 :| 24
blade mfg 12237 o.0072]] 25
roughness 11170 0.0066 ] 26
proef on ctd ink 1.1017  0.0065 ] 27
paper type 1.0461  0.0061] 28
plating tank 0.9256 0.0054 29
wax 0.8162 0.0048 30
solvent type 0.7797  0.0046 | 31
direct steam 0.0556 0.0003 32
chrome content 0.0000 0.0000 33
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Overview of the Predictor Screening Platform

Predictor screening is useful for the identification of significant predictors from a large
number of candidates. Suppose you had hundreds of Xs and needed to determine which of
those were most significant as predictors of an outcome.

The predictor screening platform uses a bootstrap forest to identify potential predictors of
your response. For each response, a bootstrap forest model using 100 decision trees is built.
The column contributions to the bootstrap forest model for each predictor are ranked. Because
the bootstrap forest method involves a random component, column contributions can differ
when you rerun the report. For more information about decision trees, see “Partition Models”.

Example of Predictor Screening

The Bands Data.jmp data table contains measurements from machinery in the rotogravure
printing business. The data set contains 539 records and 38 variables. The response Y is the
column Banding? and its values are “BAND” and “NOBAND”. You are interested in
understanding what properties are most likely to contribute to the response.

Select Help > Sample Data Library and open Bands Data.jmp.

Select Analyze > Screening > Predictor Screening.

Select Banding? as Y, Response.

Select the grouped columns grain screened to chrome content and click X.
Click OK.

S
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Figure 24.2 Ranked Column Contributions

£ = |Predictor Screening

Banding? Copy Selected
Predictor Contribution Portion Rank
ink pct 27.3767  0.1600 1
solvent pct 145981 0.0838 2
press 140203 0.0824 3
varnish pct 13.6577 0.0803 4
roller durometer 11.8470  0.0696 5
press speed 11.0130  0.0647 6
ESA Voltage 71478 0.0420 ] 7
viscosity 69979 0.0411 ] 8
press type 65136 0.0383 | 9
ESA Amperage 64143 0.0377 ] 10
grain screened 46011 0.0270 [ 11
unit number 43055 0.0258 :| 12
humidity 41744 0.0245 1 13
blade pressure 40803 0.0240 ] 14
paper mill location 37328 0.0219] 15
ink type 3.6759  0.0216 [0 16
ink temperature 3.4103 0.0200 7] 17
type on cylinder 2.8272 0.0166 ] 18
proof cut 28073 0.0165 ] 19
hardener 2784 0.0164 ] 20
ancde space ratic 22320 0.0131] 21
current density 1.8052  0.0106[] 22
caliper 1.6249  0.0095 [1 25
cylinder size 13343 0.0078 ] 24
blade mfg 1.2237  0.0072 ] 25
roughness 11170 0.0066 ] 26
proof on ctd ink 11017 0.0065]] 27
paper type 1.0461  0.0061]] 28
plating tank 0.9256  0.0054 29
wax 0.8162  0.0048 | 30
solvent type 0.7797  0.0046 31
direct steamn 0.0356  0.0003 32
chrome content 0.0000  0.0000 33

Note: Because this analysis is based on the Bootstrap Forest method that has a random
selection component, your results can differ slightly from those in Figure 24.2. See “Bootstrap
Forest”.

The columns are sorted and ranked in order of contribution in the bootstrap forest model.
Predictors with the highest contributions are strong candidate predictors for the response of
interest.

Tip: Click on a column heading to change how the columns are sorted in the table.
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Launch the Predictor Screening Platform

Launch the Predictor Screening platform by selecting Analyze > Screening > Predictor
Screening.

Figure 24.3 Predictor Screening Launch Window

Screens many predictors for their ability to predict an cutcome,

Select Columns Cast Selected Columns into Roles Action
Enter column name P - optiona
ik Banding?

A timestamp

th cylinder number required
th press otiong

th customer
[' N job number

Predictors (32/0

[» Predictors (32/0) ontiona
MNumber Trees 100

Set Random Seed

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Y, Response The response columns.
X Predictor columns.

By A column or columns whose levels define separate analyses. For each level of the
specified column, the corresponding rows are analyzed using the other variables that you
have specified. The results are presented in separate reports. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

Number of Trees The number of decision trees in the bootstrap forest model.

Set Random Seed Sets the seed for the starting values used in the fitting procedures. Set
Random Seed is useful if you want to reproduce an analysis. If you set a random seed and
save the script, the seed is automatically saved in the script.
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The Predictor Screening Report

The report (Figure 24.2) shows the list of predictors with their respective contributions and
rank. Predictors with the highest contributions are likely to be important in predicting Y.

The Contribution column shows the contribution of each predictor to the bootstrap forest
model. The Portion column in the report shows the percent contribution of each variable.

You can select the important predictors in the Predictor Screening report. Selecting the
important predictors selects the corresponding columns in the data table, enabling you to
easily enter these columns into the launch windows for modeling platforms. The Copy
Selected button enables you to copy the selected columns to the clipboard so that you can
paste them into a model as well. In this way, the Predictor Screening enhances the modeling
process.

Predictor Screening Platform Options

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.

Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
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rio Association Analysis
Perform Market Basket Analysis

‘;)“ﬂ’o The Association Analysis platform is available only in JMP Pro.

Association analysis enables you to identify items that have an affinity for each other. It is
frequently used to analyze transactional data (also called market baskets) to identify items that
often appear together in transactions. For example, grocery stores and online merchants use
association analysis to strategically organize and recommend products that tend to be
purchased together.

Association analysis is also used for identifying dependent or associated events. For example,
you can identify car parts that seem to fail around the same time. In this application, car
inspections are treated as the market baskets and you analyze the associations among groups
of faulty parts found in each inspection.

Figure 25.1 Example of Singular Value Decomposition Plots

4 SVD Plots
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JMP

PRO

Overview of the Association Analysis Platform

The Association Analysis platform identifies connections among groups of items in an
independent event or transaction. In association analysis, an ifem is the basic object of interest.
For example, an item could be a product, a web page, or a service. An item set is a list of one or
more items.

The relationship between two item sets is defined by an association rule. An association rule
consists of a condition item set and a consequent item set. Antecedents are the individual items in
the condition item set. Association analysis identifies association rules, which predict that a
consequent item set will be in a transaction, given that the condition item set is already in the
transaction. Some association rules are stronger, and therefore more useful, than others. The
following three performance measures describe the strength of an association rule:

* Support is the proportion of transactions in which an item set appears. A high value for
support indicates that the item set occurs frequently.

* Confidence is the proportion of transactions that contain the consequent item set, given that
the condition item set is in the transaction. Confidence measures the strength of
implication, or the predictive power, of an association rule. Note that confidence in
association analysis is not related to the concept of confidence intervals.

* Liftis the ratio of an association rule’s confidence to its expected confidence, assuming that
the condition and consequent item sets appear in transactions independently. Lift
measures how much the consequent item set depends on the presence of the condition
item set. The minimum value for lift is 0.

— Alift ratio less than 1 indicates that the condition and consequent repel each other,
because they occur together less frequently than one would expect by chance alone.

— Alift ratio close to 1 indicates that the consequent occurs at the same rate in
transactions that contain the condition as one would expect from chance alone.

— Alift ratio greater than 1 indicates that the consequent item set has an affinity for the
condition item set. The consequent item set occurs more often with the condition item
set than one would expect by chance alone.

For more information about these performance measures, see “Association Analysis
Performance Measures”.

The Association Analysis platform also enables you to perform singular value decomposition.
Singular value decomposition (SVD) groups similar transactions and also groups similar
items using a matrix reducing methodology that is different from what is used in association
analysis. Use the SVD methodology to gain insights that complement what you learn from
association analysis.

For more information about association analysis, see Hastie et al. (2009) and Shmueli et al.
(2010). For more information about singular value decomposition, see Jolliffe (2002).
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w Example of the Association Analysis Platform

This example uses the Grocery Purchases.jmp sample data table, which contains transactional
data reported by a grocery store. The data table lists the items purchased by 1001 customers,
each assigned a unique customer ID. You want to explore the associations among items in
order to identify patterns in consumer behavior.

1.

2
3
4.
5

Select Help > Sample Data Library and open Grocery Purchases.jmp.
Select Analyze > Screening > Association Analysis.

Select Product and click Item.

Select Customer ID and click ID.

Click OK.

By default, the Rules report is sorted in decreasing order by Confidence. However,
association rules with extremely high confidence also tend to have a higher number of
items in the condition set. Since you want to view association rules with smaller condition
sets, sort the report by Confidence, but in increasing order.

Right-click in the Rules report and select Sort By Column.
The Select Columns window appears.

Select Confidence and then check the Ascending option.
Click OK.

Figure 25.2 Association Analysis Report

4

Rules
Rule A

Condition Consequent Confidence  Lift
apples sardines 40% 1.357
Coke turkey 40% 1422
sardines chicken, Heineken 40% 2.002
herring, clives ham, turkey 40%  3.006
ice cream turkey 40% 1424
artichoke baguette, Heineken 40% 1.547
ham corned beef, herring 40% 1.648
ham corned beef, olives 40% 1.703
peppers sardines 41% 137
sardines peppers 41% 137
Coke Heineken, sardines 4% 2.23
sardines Coke, Heineken 41% 2332
avocado, Heineken crackers, ham A% 2707
scda baguette, herring 41% 1.631
corned beef ham 41% 1.343
Heineken, soda bourbon, crackers, olives 41% 3152
artichocke, Heineken avocado, baguette 41% 1.921
Heineken, herring avocado, baguette 41% 1.924

9. Scroll down the report to where the Confidence values are 58%.
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10.

There is an entry in the Rules report table that indicates that 58% of customers who bought
an avocado also bought an artichoke. The value of Lift is 1.908, indicating that there is a
likely dependency. You want to verify that avocados and artichokes occur in a significant
portion of transactions.

Click the disclosure icon next to Frequent Item Sets.

Figure 25.3 Frequent Item Sets Report

< Frequent ltem Sets

Item Set Support ~ N ltems

{Heineken} 60% 1
{crackers) 40% 1
{herring} 40% 1
{olives} 47% 1
{bourbon} 40% 1
{baguette} 30% 1
{cormned beef} 30% 1
{crackers, Heineken} 3T7% 2
{avocado} 36% 1
{soda} 32% 1
{chicken} 3% 1
{apples} 31% 1
{ice cream} 3% 1
{artichoke} 30% 1
{ham} 30% 1
{Coke} 30% 1
{peppers} 30% 1
{sardines} 30% 1
{Heineken, herring} 20% 2
{turkey} 28% 1
{baguette, Heineken} 26% 2
{Heineken, soda} 26% 2
{herring, olives} 26% 2
{artichoke, Heineken} 25% 2

11.

12.

13.

14.
15.

The Frequent Item Sets report shows that 36% of customers purchased avocados. The
Rules report in Figure 25.2 shows that 58% of these customers also bought artichokes.
Because of the large proportion of customers who follow this behavior, the grocery store
management might use this information to strategically locate avocados and artichokes.

You also decide to look at the association rules with the highest lift.
Right-click in the Rules report table and select Sort By Column.
The Select Columns window appears.

Select Lift and click OK.

The Rules table is sorted by decreasing values of lift. Notice that the second association
rule has a lift of 5.642 and 83% confidence. You want to verify that both the condition set,
{chicken, ice cream}, and the consequent item set, {Coke, sardines}, have adequate support.

Right-click in the Frequent Item Sets report and select Sort By Column.
The Select Columns window appears.

Select Item Set and then check the Ascending option.

Click OK.
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The Frequent Item Sets table is sorted alphabetically by item set. Scroll through the list to
see that the condition item set, {chicken, ice cream}, has 14% support. The consequent item
set, {Coke, sardines}, has 15% support. This association rule has high lift, but represents
fewer transactions than the first association rule that you examined.

w Launch the Association Analysis Platform

Launch the Association Analysis platform by selecting Analyze > Screening > Association
Analysis.

Figure 25.4 Association Analysis Launch Window

Explores data for items that occcur together.,

Select Columns Cast Selected Columns into Roles Action
*|2 Columns required
dll Customer ID ontiona
aptional C 1

th Product R
Mini S rt 0.1

IO optional mumeric
Minimum Cenfidence 04
Minimum Lift 1.2 aplionac
Maximum Antecedents 3 =L
Maximum Rule Size 4

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

ltem The categorical column or columns that contain the item data to be analyzed. If the

column has the Multiple Response modeling type, each of the multiple responses in each
row is treated as an item. If multiple columns are specified, each column in each row is
treated as an item.

The column that identifies the transaction to which an item belongs. The ID role is
required, unless the Item role is filled by a column with the Multiple Response modeling
type or the Item role is filled by multiple columns.

Note: If an ID role is specified, all rows with the same ID are combined into one
transaction.

Freq The column that identifies a frequency for the transactions in the Item column. For

example, if a transaction has a frequency of 3, that is treated as three identical transactions
that contain the items in the Item column.

Note: The Freq role is ignored if the Item role is filled by a column that does not have the
Multiple Response modeling type.
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By Produces a separate report for each level of the By variable. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

Minimum Support Specifies a minimum value for the proportion of occurrences of an item
set. This value must be between 0 and 1. Only item sets with support equal to or exceeding
this value are considered in the analysis.

Minimum Confidence Specifies a minimum value for the proportion of occurrences that a
consequent item set occurs within transactions that contain the conditional item set. This
value must be between 0 and 1. Only association rules with confidence equal to or
exceeding this value appear in the report.

Minimum Lift Specifies a minimum dependency ratio. Lift values must be 0 or greater. Only
association rules with lift equal to or exceeding this value appear in the report.

Maximum Antecedents Specifies the maximum number of items in the condition item set.
Association rules with more than this number of items in the condition set are not
considered in the analysis.

Maximum Rule Size Specifies the maximum number of items that appear in the union of the
condition and consequent item sets. Association rules with more than this combined
number of items are not considered in the analysis. The default value is 4.

Note: You can use the minimum support, maximum antecedent, and maximum rule size
options in the launch window to reduce computational time for large data sets. For more
information about these measures, see “Statistical Details for the Association Analysis
Platform”.

Data Format

There are three data formats that are accepted in the Association Analysis platform:

* You can specify a single item response in each row in the Item role and identify which
items are included in each transaction using the ID role. In this format, the Item and ID
roles are required and the Freq role is ignored.

* You can specify a Multiple Response modeling type column for the Item role. In this
format, the Item role is required, the ID and Freq roles are optional. If an ID role is
specified, all rows with the same ID are combined into one transaction. If a Freq role is
specified, the frequency applies to the transaction, not the specific items in the transaction.

* You can specify multiple item response columns in the Item role. In this format, the ID and
Freq roles are optional. If an ID role is specified, all rows with the same ID are combined
into one transaction. If a Freq role is specified, the frequency applies to the transaction, not
the specific items in the transaction.
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w The Association Analysis Report

By default, the Association Analysis report contains the following reports:

* “Frequent Item Sets”

e  “Rules”

Tip: To order the contents of a table in a report by any of its columns, right-click in the table
and select Sort by Column.

oo Frequent ltem Sets

The Frequent Item Sets report lists item sets in decreasing order of support. The listed item
sets meet the Minimum Support value that you specified in the launch window. Each item set
is considered as a conditional and as a consequent item set to form association rules. The table
contains the following columns:

Iltem Set The item sets that are considered as conditional or consequent sets for the
association rules.

Support The proportion of transactions in which all of the items in the Item Set occur.

N ltems The number of items in the Item Set.

pro Rules

The Rules report shows a table of association rules that are sorted in decreasing order of
confidences. Only association rules that meet the Minimum Support, Minimum Confidence,
Minimum Lift, Maximum Antecedents, and Maximum Rule Size requirements that you
specified in the launch window appear in this report.

The Rules report table contains the following columns:
Rule The association rules formed by combining Condition and Consequent item sets.

Condition The item set that is thought to influence the presence of a Consequent item set
within transactions.

Consequent The item set whose presence is thought to be influenced by the presence of
a Condition item set.

Confidence The proportion of transactions that contain the Consequent item set, given that
the condition item set is in the transaction. Confidence measures the strength of
implication, or the predictive power, of an association rule.
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Lift The ratio of an association rule’s confidence to its expected confidence, assuming that the
condition and consequent item sets appear in transactions independently. Lift measures
how much the Consequent item set depends on the presence of the Condition item set. The
minimum value for lift is 0.

— Alift ratio less than 1 indicates that the Condition and Consequent item sets repel each
other, because they occur together less frequently than one would expect by chance
alone.

— Alift ratio close to 1 indicates that the Consequent item set occurs at the same rate in
transactions that contain the Condition item set as one would expect from chance
alone.

— Alift ratio greater than 1 indicates that the Consequent item set has an affinity for the
Condition item set. The Consequent item set occurs more often with the Condition item
set than one would expect by chance alone.

w Association Analysis Platform Options

The Association Analysis red triangle menu contains the following options:

Transaction Listing Shows or hides a table listing each Transaction ID value and the items
included in that transaction. The table is sorted by the Transaction ID column.

Frequent ltem Sets Shows or hides a list of item sets whose support exceeds the Minimum
Support value specified in the launch window. See “Frequent Item Sets”.

Rules Shows or hides a table of association rules that meet the Minimum Support, Minimum
Confidence, Minimum Lift, Maximum Antecedents, and Maximum Rule Size
requirements specified in the launch window. See “Rules”.

SVD Shows or hides a report of a partial singular value decomposition (SVD) of the
incidence matrix for the items. This decomposition reduces the incidence matrix into a
user-specified number of dimensions for analysis. The SVD report also contains options to
visualize the singular vectors, cluster transactions and items, save out singular vectors,
and perform a rotated SVD analysis. See “Singular Value Decomposition”.

See Using [MP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used
in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that
support the feature, the Automatic Recalc option immediately reflects the changes that
you make to the data table in the corresponding report window.
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Save Script Contains options that enable you to save a script that reproduces the report to
several destinations.
Save By-Group Script Contains options that enable you to save a script that reproduces the
platform report for all levels of a By variable to several destinations. Available only when a
By variable is specified in the launch window.
we Singular Value Decomposition

Singular value decomposition (SVD) complements association analysis by providing another
method to identify items that have an affinity for each other. Singular value decomposition of
the transaction item matrix reduces the matrix to a manageable number of dimensions,
thereby enabling you to group similar transactions and similar items. The SVD analysis is
equivalent to performing principal components analysis (PCA) on a correlation matrix.

The transaction item matrix is a matrix for which each row corresponds to a transaction and
each column corresponds to an item. The entries of the matrix are zeros and ones. If an item
occurs in a transaction, the corresponding row and column entry is one. Otherwise, the row
and column entry is zero. Because the transaction item matrix usually contains more values of
zero than one, it is called a sparse matrix.

The partial singular value decomposition approximates the column-standardized transaction
item matrix using three matrices: U, S, and V'. The relationship between these matrices is
defined as follows:

Transaction Item Matrix=U*S* V'

Define nTran as the number of transactions (rows) in the transaction item matrix, nltem as the
number of items (columns) in the transaction item matrix, and nVec as the specified number of
singular vectors. Note that nVec must be less than or equal to min(nTran, nltem). It follows that
U is an nTran by nVec matrix that contains the left singular vectors of the transaction item
matrix. S is a diagonal matrix of dimension nVec. The diagonal entries in S are the singular
values in the transaction item matrix. V' is an nVec by nltem matrix. The rows in V' (or columns
in V) are the right singular vectors.

The right singular vectors capture connections among different items with similar functions or
topic areas. If three items tend to appear in the same transactions, the SVD is likely to produce
a singular vector in V' with large values for those three items. The U singular vectors
represent the transactions projected into this new item space.

The SVD also captures indirect connections. If two items never appear together in the same
transaction, but they generally appear in transactions with another third item, the SVD is able
to capture some of that connection. If two transactions have no items in common but contain
items that are connected in the dimension-reduced space, they map to similar vectors in the
SVD plots.
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The SVD transforms transaction data into a fixed-dimensional vector space, making it
amenable to clustering, classification, and regression techniques. The Save options enable you
to export this vector space to be analyzed in other JMP platforms.

The transaction item matrix is centered, scaled, and divided by nTran minus 1 before the
singular value decomposition is carried out. This analysis is equivalent to a PCA of the
correlation matrix of the transaction item matrix. The SVD implementation takes advantage of
the sparsity of the transaction item matrix.

pio SVD Report

The SVD option produces two SVD plots and a table of the singular values from the singular
value decomposition.

PRo SVD Plots

The first plot contains a point for each transaction. For a given transaction, the point that is
plotted is defined by the transaction’s values in the first two singular vectors (the first two
columns of the U matrix) multiplied by the diagonal singular values matrix (S). This plot is
equivalent to the Score Plot in the Principal Components platform. Each point in this plot
represents a transaction. In the Transaction SVD plot, points that are visibly grouped together
indicate transactions with a similar composition.

The second plot contains a point for each item. For a given item, the point that is plotted is
defined by the item’s values in the first two singular vectors (the first two rows of the V'
matrix) multiplied by the diagonal singular values matrix (S). This plot is equivalent to the
Loadings Plot in the Principal Components platform. Each point in this plot represents an
item. In the Item SVD plot, items that are visibly grouped together indicate items that have
similar functions or topic areas.

PRo Singular Values
Below the transaction and item SVD plots, a table of the singular values appears. These are the
diagonal entries of the S matrix in the singular value decomposition of the transaction item
matrix. The Singular Values table also contains a column of corresponding eigenvalues for the
equivalent principal components analysis. Like in the Principal Components platform, there
are columns for the percent and cumulative percent of variation explained by each eigenvalue
(or singular value). You can use the Cum Percent column to decide what percent of variance
from the transaction item matrix you want to preserve, and then use the corresponding
number of singular vectors.
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pto SVD Report Options

The SVD red triangle menu contains the following options:

SVD Scatterplot Matrix Shows or hides a scatterplot matrix of the item and transaction
singular value decomposition vectors. You must select the size of the scatterplot matrix
when you select this option. This scatterplot matrix enables you to visualize more than the
first two dimensions of the singular value decomposition.

Topic Analysis, Rotated SVD Performs a varimax rotated partial singular value
decomposition of the item transaction matrix to produce groups of items called topics. You
can select this option multiple times to find different numbers of topics. See “Topic
Analysis”.

Cluster ltems Shows or hides a hierarchical clustering analysis of the items in the data. The
following options are available to the right of the dendrogram:

Set Clusters Specifies the number of clusters that are colored in the dendrogram and
used in the Save Clusters option. Points in the Item SVD plot are also colored by cluster.

Save Clusters Saves a data table that contains the items and their cluster assignments.
You must set the number of clusters before clicking Save Clusters.

For more information about clustering and dendrograms, see Multivariate Methods.

Cluster Transactions Shows or hides a hierarchical clustering analysis of the transactions in
the data. The following options are available to the right of the dendrogram:

Set Clusters Specifies the number of clusters that are colored in the dendrogram and
used in the Save Clusters option. Points in the Transaction SVD plot are also colored by
cluster.

Save Clusters Saves a data table that contains the transactions and their cluster
assignments. You must set the number of clusters before clicking Save Clusters.

For more information about clustering and dendrograms, see Multivariate Methods.

Save Transaction Singular Vectors Saves a user-specified number of singular vectors from
the transaction singular value decomposition as columns to a new data table where each
row corresponds to a transaction. The first two saved columns represent the points plotted
in the transaction SVD plot. See “Singular Value Decomposition”.

Save Item Singular Vectors Saves a user-specified number of singular vectors from the
items singular value decomposition as columns to a new data table where each row
corresponds to an item. The first two saved columns represent the points plotted in the
item SVD plot. See “Singular Value Decomposition”.
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Topic Analysis

The Topic Analysis, Rotated SVD option performs a varimax rotation on the partial singular
value decomposition (SVD) of the transaction item matrix. See “Singular Value
Decomposition”. You must specify a number of rotated singular vectors, which corresponds
to the number topics that you want to retain from the transaction item matrix. After you
specify a number of topics, the Topic Analysis report appears.

Topic analysis is equivalent to a rotated principal component analysis (rotated PCA). The
varimax rotation takes a set of singular vectors and rotates them to make them point more
directly in the coordinate directions (toward the items). This rotation makes the vectors help
explain the composition of the transactions as each rotated vector orients toward a set of
items. Negative values indicate a repulsion force. The items with negative values occur in a
topic less frequently compared to the items with positive values.

Topic Analysis Report

The Topic Analysis report shows the items that have the largest loadings in each topic after
rotation. There are additional reports that show the components of the rotated singular value
decomposition.

The Top Loadings by Topic report shows a table for each topic. The items in each table are the
ones that have the largest loadings in absolute value for each topic. Each table is sorted in
descending order by the absolute value of the loading. These tables can be used to determine
conceptual themes that correspond to each topic.

The Topic Analysis report also contains the following reports:

Topic Loadings Contains a matrix of the loadings across topics for each item. This matrix is
equivalent to the factor loading matrix in a rotated PCA.

Word Clouds by Topic Contains a matrix of word clouds, one for each topic.

Topic Scores Contains a matrix of transaction scores for each topic. Transactions with
higher scores in a topic are more likely to be associated with that topic.

Topic Scores Plots Shows the topic scores for all transactions in one-dimensional
scatterplots. Negative values indicate transactions that are negatively associated with a
topic. Use these plots to explore the distribution of transactions within each topic.

Variance Explained by Each Topic Contains a table of the variance explained by each topic.
The table also contains columns for the percent and cumulative percent of the variation
explained by each topic.

Rotation Matrix Contains the rotation matrix for the varimax rotation.
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pro Topic Analysis Report Options

The Topic Analysis red triangle menu contains the following options:

Topic Scatterplot Matrix Shows or hides a scatterplot matrix of the rotated singular value
decomposition vectors.

Display Options Contains options to show or hide content that appears in the Topic Analysis
report. See “Topic Analysis Report”.

Rename Topics Shows a dialog that enables you to add descriptive names for one or more
of the topics.

Save Transaction Topic Vectors Saves a user-specified number of singular vectors from the
rotated singular value decomposition as columns to the data table.

Save Item Topic Vectors Saves the topic vectors as columns to a new Item Topic Scores data
table.

Remove Removes the Topic Analysis report from the SVD report.

JMP

PRO

Additional Example: SVD Analysis

In this example, you use singular value decomposition of the transaction item matrix to gain
further insight into the Grocery Purchases.jmp sample data.

Select Help > Sample Data Library and open Grocery Purchases.jmp.
Select Analyze > Screening > Association Analysis.

Select Product and click Item.

Select Customer ID and click ID.

Click OK.

Click the Association Analysis red triangle and select SVD.

Click OK.

N o gl L=
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Figure 25.5 SVD Plots

4 SVD Plots

Transaction Singular Vector 2

Item Singular Vector 2

Transaction Singular Vector 1

06

04

02

-0.2

-04

-06

Association Analysis 529
Additional Example: SVD Analysis

ice cream

]

Coke

-06 -04 -0.2 00 02
Item Singular Vector 1

04

06

The transaction SVD plot suggests that there might be two or three groups of transactions.
In the upper right corner of the item SVD plot, notice that the points that represent Coke
and ice cream overlap. The proximity of these two items indicates that there is a strong
affinity between them.

8. Click the SVD red triangle and select Topic Analysis, Rotated SVD.

9. Type 3 next to Number of topics (rotated singular vectors) and click OK.

The Topic Items and Topic Scores reports appear.

Figure 25.6 Topic Items Report

£ Top Loadings by Topic

Topic 1
Item Loading
avocado -0.7191
colives 0.7142
baguette -0.6089
turkey 0.5697
artichoke -0.4889
bourbon 0.4860

Heineken -0.4329
corned beef  0.3836
Coke 0.3096

Topic 2
Item Loading
Coke 0.7017
ice cream 0.6945
herring -0.6550
sardines 0.6122
chicken 0.5138
corned beef  -0.4257
steak -0.3395
colives -0.3035
ham -0.3022

Topic 3
Item Loading
crackers 0.7030
apples -0.6437
scda 0.6411
Heineken 0.6409
sardines -0.3618
steak -0.3468
corned beef  -0.3400
bourbon 0.3340

Three groups, or topics, are created and shown in the Topic Items report. The first items
listed in the Topic Item tables represent the primary items for that group. For example,
Topic 1is a group that is identified primarily by transactions that do not contain avocados,
but do contain olives.
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Figure 25.7 Topic Scores

< Topic Scores Plots
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Topic 1

Topic 2

Topic 3

The topic scores that are assigned to each of the 1001 transactions are plotted in the Topic
Scores report. Select groups of points for a topic to see how those transactions relate to

other topics. For example, transactions with very high values on Topic 1 tend to have low
values on Topics 2 and 3.

10. Open the Singular Values report.

Figure 25.8 Singular Values Table

< Singular Values

Singular
Number Value
1 17399
2 1.6494
3 15093
4 14077
5 1.2565
6 1133
7 1.0333
8 09927
9 09265
10 0.7888
1 0.7247
12 0.6647
13 0.6465
14  0.6379
15 0.6266
16 0.6140
17 0.6077
18 05817
19 05590
20 01213

Eigenvalue Percent

3.0272
2.7204
2.2780
1.9816
1.5788
1.2839
1.0676
0.9854
0.8583
0.6223
0.5253
0.4419
0.4179
0.4069
0.3927
0.3770
0.3693
0.3383
0.3125
0.0147

15.1362
13.6021
11.3901

Cum Percent
15.1362
28.7383
40,1284
50.0363
57.9301
64,3497
69.6877
74.6148
75.9063
82.0177
84,6440
86.8534
85,0431
90.9777
92.9411
94,8259
96.6724
93.3641
99,9264
100.000

As seen in Figure 25.8, the first two singular values explain only about 30% of the
variability in the grocery store data. Additional dimensions might be required to explain a
sufficient amount of variability.
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we Statistical Details for the Association Analysis
Platform

¢ “Frequent Item Set Generation”

* “Association Analysis Performance Measures”

pio Frequent ltem Set Generation

The Association Analysis platform uses the Apriori algorithm to reduce computational time
when generating frequent item sets. The Apriori algorithm leverages the fact that an item set’s
support is never larger than the support of its subsets. The platform generates larger item sets
from combinations of smaller item sets that meet the minimum support level. In addition, the
platform does not generate item sets that exceed either the specified maximum number of
antecedents or the maximum rule size. These options are useful when working with large data
sets, because the total possible number of rules increases exponentially with the number of
items. For more information about the Apriori algorithm, see Agrawal and Srikant (1994).

pio Association Analysis Performance Measures

This section defines the performance measures used in the Association Analysis platform.
Denote an association rule with condition item set X and consequent item set Y by X = Y.
Habhsler (2015) contains a collection of performance measures used in association analysis,
including support, confidence, and lift.

PRo Support

Support is the proportion of transactions in which an item set occurs. Support can also be
viewed as the probability that a transaction contains an item set.

The support S of a condition item set X is defined as follows:

N
supp(X) = 'N’X - Pr(X)

where:
Ny is the number of transactions that contain the item set X
N is the total number of transactions.

Support for an association rule is defined as follows:

supp(X=Y) = supp(XVY) = Pr(XnY)
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In this case, support is equivalent to the probability that a transaction contains both item sets
XandY.

For both the item set and association rule cases, support ranges from 0% to 100%.

Confidence

Confidence is the proportion of transactions that contain the consequent item set, given that
the transaction contains the condition item set. Confidence can also be viewed as the
conditional probability that a transaction contains the consequent item set, given that the
transaction contains the condition item set.

supp(XVY) _ Pr(XnY) _
supp(X) Pr(X)

conf(X=Y) = Pr(Y|X)

Confidence ranges from 0% to 100%. An association rule with a confidence of 0% has a
consequent item set that does not appear in any transaction with the condition item set. A
confidence of 100% indicates that every transaction that contains the condition item set also
contains the consequent item set.

Note: Confidence in association analysis is not related to the concept of confidence intervals.

Lift

Lift measures dependency between X and Y.

supp(XUY) _ PriXnY)
supp(X) xsupp(Y)  Pr(X)Pr(Y)

lif(X = Y) =

The numerator for lift is the proportion of transactions where X and Y occur jointly. The
denominator is an estimate of the expected joint occurrence of X and Y, assuming that they
occur independently.

Lift ranges from 0 to co. A lift value of 1 indicates that X and Y jointly occur in transactions
with the frequency that would be expected by chance alone. Increasing lift values suggest that
Y occurs more often than expected when X is present.

Note: The lift for association rule X = Y is equal to the lift for association rule Y = X.
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Note: The Process History Explorer platform is new and experimental. It is subject to change
in future releases.

In complex manufacturing situations, such as in semiconductor factories, a defective tool or
route combination might lead to poor yield or reduced quality. However, there might be
hundreds of steps that a unit passes through that involve many different tools. It can be
difficult to determine the exact combination of factors that leads to the poor yield.

The Process History Explorer platform organizes all of the production tracking data and
enables you to identity factors that seem to be associated with poor yield. You can then
perform stepwise regression. You can analyze the time that a unit spends waiting between
steps or tools in the process and see how that waiting time is related to yield. You can also
analyze the effect on yield of transitions from one tool to another.

Figure 26.1 Process History Explorer Report

4 [=|Process History Explorer
1250 Units, using ID columns: Lot, Wafer
125 Steps, using columns: Layer, Operaticn
136250 Operations, using time cclumns: Timeln, TimeCut
185 levels in X columns: Tool, Route
1 response: Yield

< Response Yield
£ Levels with Lowest Yields

Term Level Count Mean ~ StdError Std Dev

Tool PlanarTool008 1000 0.75299 0.00188  0.03932
Tool DepTool003 1375 0.75577 0.00168  0.06245
Tool EtchTool019 750 0.76192 0.0021 0.05749
Tool EtchTool012 500 0.76203 0.0026  0.05807
Tool EtchTool034 850 0.76279 0.00199 0.0381

Tool PlanarTool021 1050 0.7637 0.00186  0.06028
Tool PlanarTool030 1025 0.76339 0.00184  0.05894

Tool EtchTool016 900 0.76566 0.00191  0.05734
Tool EtchTool009 925 0.76598 0.00197  0.05994
Tool Dep2Tool018 1525 0.76766 0.00156  0.06088
Tool Dep2Tool014 1825 0.76813 0.00138  0.05893
Tool DepTool019 1650 0.76839 0.00143  0.05794
Tool EtchTool020 1000 0.76909 0.00177  0.03586
Tool Dep2Tool015 1475 0.76948 0.0015  0.05775
Tool PhotoTool010 3525 0.76996 0.00008  0.03822
Tool Dep2Tool013 1825 0.7705 0.00141  0.06025
Tool DepTool012 1750 0.77063 0.00145  0.06051
Tool Dep2Tool006 1400 0.77063 0.00158  0.03905
Tool PlanarTool028 900 0.77103 0.00202  0.06071
Tool Dep2Tool011 1600 0.77124 0.00145  0.05797

Tool EtchTool010 850 0.77125 0.00213  0.06208
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Example of Process History Explorer

This example uses two data tables. The first data table contains step-by-step history of 25
wafers in 50 lots that went through a complex manufacturing process. The second data table
contains the yield for each wafer in each lot.

1. Select Help > Sample Data Library and open Quality Control > Lot Wafer History.jmp and
Quality Control > Lot Wafer Yield.jmp.

2. From the Lot Wafer History.jmp data table, select Analyze > Screening > Process History
Explorer.

Select Lot and Wafer and click ID.
Select Tool and Route and click X, Process.
Select Layer and Operation and click Step.
Select Timeln and TimeOut and click Timestamp.
Click OK.
A window appears that enables you to select the corresponding yield table.
8. Select Lot Wafer Yield and click OK.
A window appears that enables you to select the yield column.
9. Select Yield and click OK.
10. Click the Process History Explorer red triangle and select Levels with Lowest Yield.

N o ok W
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£ |~ Process History Explorer
1250 Units, using ID columns: Lot, Wafer

125 Steps, using columns: Layer, Operaticn
136250 Operations, using time cclumns: Timeln, TimeCut
185 levels in X columns: Tool, Route

1 response: Yield
< Response Yield

£ Levels with Lowest Yields

Term Level

Teol PlanarTcol008

Teol DepTool003
Teol EtchTeol019
Teol EtchTeol012
Teol EtchTeool034
Teol PlanarTeol021

Teol PlanarTool030

Teol EtchTeol016
Teol EtchTeol009
Teol Dep2Tool018
Teol Dep2Tool014
Teol DepTool019
Teol EtchTeol020
Teol Dep2Tool015
Teol PhotoTecl010
Teol Dep2Tool013
Teol DepTool012
Teol Dep2Tocl006

Teol PlanarTool028

Teol Dep2Tool011
Teol EtchTeol010

Count
1000
1375

750
500
850
1050
1025
900
925
1525
1825
1650
1000
1475
3525
1825
1750
1400
900
1600
850

Mean ~ Std Error

0.75299 0.00188
0.75577 0.00168
0.76192 0.0021
0.76203 0.0026
0.76279 0.00199
0.7637 0.00186
0.76539 0.00184
0.76566 0.00191
0.76598 0.00197
0.76766 0.00156
0.76813 0.00138
0.76839 0.00143
0.76909 0.00177
0.76048 0.0015
0.76996 0.00098
0.7705 0.00141
0.77063 0.00145
0.77063 0.00158
0.77103 0.00202
0.77124 0.00145
0.77125 0.00213

Figure 26.2 Process History Explorer Report

Std Dev
0.05952
0.06245
0.05749
0.03807

0.0381
0.06028
0.03894
0.05734
0.03994
0.06088
0.03893
0.05794
0.03586
0.05773
0.03822
0.06023
0.06051
0.03905
0.06071
0.05797
0.06208
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The report contains information about the process, including the number of units, steps,
operations, and levels in the X columns. The Levels with Lowest Yields table contains counts
and yield information for the 195 levels in the X columns. Notice that the PlanarTool008 tool
had the lowest yield and 1,000 units went through that tool.
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Launch the Process History Explorer Platform

Launch the Process History Explorer platform by selecting Analyze > Screening > Process
History Explorer.

Figure 26.3 Process History Explorer Launch

Identifies process steps associated with poor yield.

Select Columns Cast Selected Columns into Roles Action
th Lot th Wafer
. |
ik Layer
& Operation i Tool
ool

th Route
e & Rou
A Timeln apitono
all TimeOut
th Affected th Layer
A vield ik Operation
[[] Geal is te Minimize ¥

all TimeOut

optional

For more information about the options in the Select Columns red triangle menu, see Using
JMP.

Launch Window Roles

ID Specifies one or more columns that identify a unit in the process.

Note: The ID columns must have corresponding columns in the yield table.

X, Process Specifies one or more columns that identify the components or specific details
that make up the steps of the process.

Step Optional columns that specify the steps and sub-steps that a unit goes through. For
example, the layer and the type of operation within the layer.

Timestamp Specifies the time of the operation. The time can be specified as a single time
point or as a pair of time points that indicate the times that the operation started and
ended.

Order Optional column that specifies the order that a batch of units went through the
components specified in the X, Process role.
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By Produces a separate report for each level of the By variable. If more than one By variable
is assigned, a separate report is produced for each possible combination of the levels of the
By variables.

Launch Window Options

Goal is to Minimize Y Specifies that the goal of the analysis is to minimize the response. By
default, the analysis seeks to maximize the response.

Note: The response is specified in a second data table, not in the data table used to launch
the platform.

Format

The data for Process History Explorer must be specified in two data tables. The first table is
used to launch the platform and contains the steps and details of the process. The second table
contains the response, or yield, for each level of the ID columns.

The sample data tables Quality Control > Lot Wafer History and Quality Control > Lot Wafer Yield
provide an example of how the data are specified in two data tables.

The Process History Explorer Report

The initial Process History Explorer Report provides a summary of the information in the data
table(s).

* The number of Units, determined by the ID columns. If there is more than one ID column,
this is the number of unique combinations.

® The number of Steps, determined by the Step columns. If there is more than one Step
column, this is the number of unique combinations.

® The number of Operations, determined by the Timestamp columns. This is the same as the
number of rows in your data table.

® The number of levels, determined by the X, Process columns. If there is more than one
X, Process column, this is the sum of the number of levels in each column.

e The number of responses, determined by the Yield columns.

Select options from the Process History Explorer red triangle menu to continue your analysis.
See “Process History Explorer Platform Options”.
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Process History Explorer Platform Options

The Process History Explorer red triangle menu contains the following options:

Levels with Lowest Yield Displays a table of summary statistics for the yield for each level of
each X, Process variable. The summary statistics provided for each level are the number of
operations, and the mean, standard error, and standard deviation of the yield. By default,
the table is sorted in ascending order by mean yield.

Levels with Lowest Yield with Time Filter Displays a table of summary statistics for the time
intervals of the top 50 levels with the lowest yields. The routine searches for a time interval
for each of the top 50 levels in the Levels with Lowest Yield table that minimizes the mean
yield within the interval. The interval must contain at least 25% of the operations in that
level. The summary statistics provided for each level are the number of operations in the
identified interval, the mean yield in the identified interval, the timestamps for the first
and last operations in the level (First Time and Last Time), and the timestamps for the first
and last operations in the identified interval (RunStart Time and RunEnd Time).

Stepwise Regression Displays a Stepwise Regression window that enables you to specify
options for a stepwise regression analysis. You can use stepwise regression to find
problems in the process, where a problem is something that causes your yield to decrease.
At each step in the regression, a term enters according to which term has the largest
negative yield. This helps you identify process steps that most impact the yield. Stepwise
Regression provides a table that shows the order in which terms entered the model at each
step of the regression.

Note: If the Goal is to Minimize Y option is selected in the launch window, Stepwise
Regression adjusts to detect terms that cause the yield to increase.

Goal Specifies the criterion used in the stepwise regression model. The Biggest
individual difference option identifies the terms that individually cause the yield to
change the most. The Biggest total difference option identifies the terms that cause the
biggest total difference, which is the difference multiplied by the number of units
affected. The Most predictive option produces a traditional stepwise regression model.

Time Filtering Enables you to use the starting time of a component in the stepwise
regression model. If you choose the None option, the times are averaged over the entire
time period. If you choose the Starting Time option, the component is allowed to fail at
a particular starting time. The starting time is the time that maximizes the negative
yield affect. If you choose the Starting Time option, the Stepwise Regression report
table contains a Start Time column.
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X Transform Enables you to use the regular count data or the Log(Count + 1) data for the
X, Process variables in the stepwise regression. The Log(Count + 1) option transforms
the variables in the regression such that high frequency counts have less of a linear
influence in the regression. If you choose the None option, high frequency counts have
a linear influence in the regression.

Number of Regression Steps The number of steps in the Stepwise Regression analysis.
The default is ten.

Figure 26.4 Stepwise Regression Window

Specify Stepwise Opticns

Goal

(®) Biggest individual difference
() Biggest total difference
() Most predictive

Time Filtering

(® None
() Starting Time

X Transform

(® None
) Leg(Count+1)

MNumber of Regression Steps

Waiting Time Analysis (Available only when two Timestamp variables are specified.) Each
unique ID can go through only one level of a step at a time. In addition, each step can
process only one ID at a time. Waiting Time Analysis provides a table of waiting time
summary statistics for each ID. In this table, waiting time is the amount of time between
when an ID is done with one step and when it starts another step. Additional Waiting
Time Analysis tables are also provided. These tables contain waiting time summary
statistics for each ID within the levels of each Step variable. In these tables, waiting time is
the amount of time between when an ID is done with a particular level of a Step variable
and when it goes through that same level again. The tables provide the following statistics:

Waiting Sum The sum of the waiting times for the given combination of ID and Step
variable levels.

Waiting Count The number of waiting times for the given combination of ID and Step
variable levels.

Waiting Mean The mean of the waiting times for the given combination of ID and Step
variable levels.



Chapter 26 Process History Explorer 543
Predictive and Specialized Modeling Process History Explorer Platform Options

Waiting Max The maximum waiting time for the given combination of ID and Step
variable levels.

Transition Analysis Displays a report that helps you identify transitions from one
component to another that are problematic for the resulting yield. This report can help you
identify alignment and registration issues in the process. For example, some levels of the
process column might be out of alignment with respect to other levels of the process
column. If there is a transition problem, you would expect that items that repeat a specific
level to have better yields than items that go through different levels of the process
column.

When you select this option, you must choose one or more X, Process columns and one or
more levels in each of those columns to include in the analysis. For each column that you
specify for the analysis, a report appears that contains four tables. The first shows yields
and counts for transitions from a specific level of the column to another specific level of the
column. The second shows yields and counts for transitions away from specific levels of
the column. The third shows yields and counts for transitions to specific levels of the
column. The fourth shows yields and counts for transitions where the unit repeats a
specific level of the column.

Order Interaction (Available only if an Order variable is specified in the launch window.)
Displays a report of a one-way analysis of the yield on the Order column. The report
contains a table for each X, Process column. In each table, the levels of the process column
are listed in descending order of LogWorth of the corresponding analysis of variance
model. The tables also contain the p-values and a heat map for each level of the process
column.

Save Count Table Creates a new data table that contains counts of how many units went
through each level of the X, Process variables. The count table has a row for each unique
unit, determined by the ID values.

Save Log Count Table Creates a new data table that is the same format as the Count table,
except with entries of Log(Count + 1).

Save Waiting Time (Available only when two Timestamp variables are specified.) Saves each
table in the Waiting Time Analysis report to a separate data table.
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Appendix A

Statistical Details
Predictive and Specialized Modeling

This appendix discusses measures of fit and the types of cross validation available in each
platform.
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Measures of Fit

Entropy RSquare

The Entropy RSquare is computed for the training set and for the validation and test sets if
validation is used. For the training set, Entropy RSquare is computed as follows:

* The specified model is fit using the training set.
¢ Predicted probabilities for each level of the response are obtained, based on the model.

e Using these predicted probabilities, the likelihood is computed for observations in the
training set. Call this Likelihood_Full 1yyjpjpg-

¢ The reduced model (no predictors) is fit using the training set.

® The predicted probabilities for the levels of the response from the reduced model are used
to compute the likelihood for observations in the training set. Call this quantity
Likelihood_Reduced rygpjng-

e The Entropy RSquare for the training set is:

B log(Likelihood_Fullel-ning)
log(Likelihood_Reduced

Entropy RSquarer, . . ¢ = 1
Training)

The Entropy RSquare for the validation and test sets are computed in a manner analogous to
the Entropy RSquare for the training set.

Validation in JMP Modeling

Data can be partitioned into sets before modeling to avoid overfitting and to select a good
predictive model. This process uses part of the original data to estimate parameters and uses
the rest of the data to tune or evaluate the parameters, or do both. In JMP Pro, you can
partition the data into two or three sets in the following ways:

Train and Evaluate Partitions the data into two sets, called Training and Validation. The
training set is used to estimate the model parameters. The validation set is used to
independently evaluate the performance of the fitted model.

Train and Tune Partitions the data into two sets, called Training and Validation. The training
set is used to estimate the model parameters. The validation set is used in the model fitting
algorithm to tune the model parameters and ultimately choose a model with good
predictive ability. There is no independent model evaluation done in this case.
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Train, Tune, and Evaluate Partitions the data into three sets, called Training, Validation, and
Test. The training set is used to estimate the model parameters. The validation set is used
in the model fitting algorithm to tune the model parameters and ultimately choose a
model with good predictive ability. The test set is then used to independently evaluate the
performance of the fitted model.

po Validation Column Role

The Validation Column role is available only in JMP Pro. For JMP, see “Excluded Rows as
Validation Holdback”.

One way to create data partitions is to use the Validation Column role. The Validation Column
role uses the column’s values to divide the data into parts. The column is assigned using the
Validation role in the platform’s launch window. For information about how to create a
validation column, see “Make Validation Column”.

Caution: The use of a validation column is platform specific. Different platforms use the levels
of the validation column differently. See notes in Table A.1.

Table A.1 Validation Column by Platform

Platform Train & Train & Train,Tune, Notes
Evaluate Tune & Evaluate
Fit Model
Fit Least Squares ~ Yes No No If there are more than three levels,

the validation column is ignored.

Stepwise No Yes Yes If there are more than three levels,
Regression K-Fold Cross-Validation is used.
Logistic Yes No No If there are more than three levels,
Regression the validation column is ignored.
Generalized No Yes Yes If there are more than three levels,
Regression K-Fold Cross-Validation is used.
Partial Least No Yes Yes If there are more than three levels,
Squares K-Fold Cross-Validation is used.
Predictive Models

Neural No Yes Yes If there are more than three levels,

K-Fold Cross-Validation is used.
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Platform

Partition

Bootstrap Forest

Boosted Tree

K Nearest
Neighbors

Naive Bayes

Support Vector
Machines

Specialized Models

Functional Data
Explorer

Multivariate
Models

Discriminant

Partial Least
Squares

Train &
Evaluate

No

Yes

Yes

Yes

Train &
Tune

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Train,Tune,
& Evaluate

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Statistical Details
Validation in JMP Modeling

Notes

If there are more than three levels,
the platform only uses rows with
the three smallest values.

If there are more than three levels,
the platform only uses rows with
the three smallest values.

If there are more than three levels,
the platform only uses rows with
the three smallest values.

If there are more than three levels,
the platform only uses rows with
the three smallest values.

If there are more than three levels,
the platform only uses rows with
the three smallest values.

If there are more than three levels,
K-Fold Cross-Validation is used.

Must be created as a Grouped
Random validation column.

If there are more than two levels,
the smallest value defines the
training set and all other values
define the validation set.

If there are more than three levels,
the platform only uses rows with
the three smallest values.

If there are more than three levels,
K-Fold Cross-Validation is used.
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Platform Train & Train & Train,Tune, Notes
Evaluate Tune & Evaluate
Uplift No Yes Yes If there are more than three levels,

the platform only uses rows with
the three smallest values.

K-Fold and Holdback Validation

The Validation Column role provides a framework for partitioning data into cross validation

sets. In addition, some JMP platforms also support K-Fold and various types of Holdback
validation.

K-Fold Cross-Validation Divides the original data into K subsets. In turn, each of the K sets
is used to validate the model fit on the rest of the data, fitting a total of K models. The
model that produces the best validation statistic is chosen as the final model, and the fold
that is not used in the building of that model provides the test set performance statistics.

Note: For some platforms, you must specify K-Fold Cross-Validation in the model control
panel. For other platforms, you must specify K-Fold Cross-Validation in the platform
launch window. For still other platforms, you must specify K-Fold Cross-Validation
through a validation column that contains more than three levels.

Random Validation Holdback (Available as a launch option for specific platforms.)
Randomly divides the original data into the training and validation sets. A test set can also
be included. You can specify the proportions of the original data to use in each set.

Leave-One-Out Validation Holdback (Available as an option for specific platforms.)
Repeatedly fits the model leaving out one observation at a time. Leave-one-out validation
is also known as the jackknife procedure.

Excluded Rows as Validation Holdback Uses the excluded rows in the data table as a
validation holdback set. For JMP Pro, this option is available by selecting in the platform
preferences.

Note: For platforms that support using excluded rows as a validation holdback set, the
excluded rows are used only when there is no validation column or validation proportion
specified in the launch window.
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Table A.2 K-Fold and Holdback Validation by Platform

Platform

Fit Model
Fit Least Squares

Stepwise Regression

Logistic Regression

JVP
PRO Generalized
Regression

JMP
PRO Partial Least
Squares

Predictive Model

Neural

Partition

JVIP
PRO Bootstrap Forest
JMP

PRO Boosted Tree

JMP
PRO K Nearest
Neighbors

JVP
PRO Naive Bayes

JMP
PRO Support Vector
Machines

Specialized Models

Excluded Rows
as Validation
Holdback

Yes

Yes

Yes
Yes
Yes

Yes

Random
Validation
Holdback

Yes

Yes

Yes

Yes

Yes
Yes
Yes

Yes
Yes

Leave-One-Out
Holdback

Yes

Yes

K-Fold
Cross-Validation

No

Yes (for
continuous
response
models only)

No

Yes (though the
model controls)

Yes (through
the model
controls)

Yes (through
model launch
or validation
column)

Yes (select the
option in the
platform
preferences)

Yes (through
model launch)
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Platform Excluded Rows Random Leave-One-Out K-Fold
as Validation Validation Holdback Cross-Validation
Holdback Holdback

JVP

PRO Functional Data No No No No

Explorer

Multivariate Models

Discriminant Optional No No No

Partial Least Squares  No Yes Yes Yes (through

model launch
or validation
column)

JMP
PRO Uplift No Yes No
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Technology License Notices

Scintilla is Copyright © 1998-2017 by Neil Hodgson <neilh@scintilla.org>.
All Rights Reserved.

Permission to use, copy, modify, and distribute this software and its documentation for
any purpose and without fee is hereby granted, provided that the above copyright notice
appear in all copies and that both that copyright notice and this permission notice appear
in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING
ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL
HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Progressé® Telerik® UI for WPF: Copyright © 2008-2019 Progress Software Corporation.
All rights reserved. Usage of the included Progress® Telerik® UI for WPF outside of JMP is
not permitted.

ZLIB Compression Library is Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.
Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.
Packages is Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

Neither the name of the WhiteBox nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
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(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

¢ iODBC software ia Copyright © 1995-2006, OpenLink Software Inc and Ke Jin
(www.iodbc.org). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

— Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

— Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

— Neither the name of OpenLink Software Inc. nor the names of its contributors may be
used to endorse or promote products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.

e This program, “bzip2”, the associated library “libbzip2”, and all documentation, are
Copyright © 1996-2019 Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. The origin of this software must not be misrepresented; you must not claim that you
wrote the original software. If you use this software in a product, an acknowledgment in
the product documentation would be appreciated but is not required.

3. Altered source versions must be plainly marked as such, and must not be
misrepresented as being the original software.
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4. The name of the author may not be used to endorse or promote products derived from
this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

Julian Seward, jseward@acm.org
bzip2/libbzip2 version 1.0.8 of 13 July 2019
R software is Copyright © 1999-2012, R Foundation for Statistical Computing.

MATLARB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and
international patents. See www.mathworks.com/patents. MATLAB and Simulink are
registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a
list of additional trademarks. Other product or brand names may be trademarks or
registered trademarks of their respective holders.

libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

— Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

— Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and / or other materials
provided with the distribution.

— Neither the name of Florian Reuter nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
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USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

¢ libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and
the trio files, which are covered by a similar license but with different Copyright notices)
all the files are:

Copyright © 1998-2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS 1S”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in
advertising or otherwise to promote the sale, use or other dealings in this Software
without prior written authorization from him.

¢ Regarding the decompression algorithm used for UNIX files:
Copyright © 1985, 1986, 1992, 1993
The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.
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2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to
endorse or promote products derived from this software without specific prior written
permission.

* Snowball is Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton.
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used
to endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS \”AS IS\” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

® Pako is Copyright © 2014-2017 by Vitaly Puzrin and Andrei Tuputcyn.

Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.
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THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.

HDF5 (Hierarchical Data Format 5) Software Library and Utilities are Copyright 2006—
2015 by The HDF Group. NCSA HDF5 (Hierarchical Data Format 5) Software Library and
Utilities Copyright 1998-2006 by the Board of Trustees of the University of Illinois. All
rights reserved. DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF GROUP
AND THE CONTRIBUTORS “AS IS” WITH NO WARRANTY OF ANY KIND, EITHER
EXPRESSED OR IMPLIED. In no event shall The HDF Group or the Contributors be liable
for any damages suffered by the users arising out of the use of this software, even if
advised of the possibility of such damage.

agl-aglfn technology is Copyright © 2002, 2010, 2015 by Adobe Systems Incorporated. All
Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

— Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

— Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

— Neither the name of Adobe Systems Incorporated nor the names of its contributors
may be used to endorse or promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
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e dmlc/xgboost is Copyright © 2019 SAS Institute.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file
except in compliance with the License. You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the
License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS
OF ANY KIND, either express or implied. See the License for the specific language
governing permissions and limitations under the License.

e libzip is Copyright © 1999-2019 Dieter Baron and Thomas Klausner.

This file is part of libzip, a library to manipulate ZIP archives. The authors can be
contacted at <libzip@nih.at>.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.

3. The names of the authors may not be used to endorse or promote products derived from
this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHORS "AS IS" AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

¢ OpenNLP 1.5.3, the pre-trained model (version 1.5 of en-parser-chunking.bin), and
dmlc/xgboost Version .90 are licensed under the Apache License 2.0 are Copyright ©
January 2004 by Apache.org.

You may reproduce and distribute copies of the Work or Derivative Works thereof in any
medium, with or without modifications, and in Source or Object form, provided that You
meet the following conditions:
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— You must give any other recipients of the Work or Derivative Works a copy of this
License; and

— You must cause any modified files to carry prominent notices stating that You changed
the files; and

— You must retain, in the Source form of any Derivative Works that You distribute, all
copyright, patent, trademark, and attribution notices from the Source form of the
Work, excluding those notices that do not pertain to any part of the Derivative Works;
and

— If the Work includes a “NOTICE” text file as part of its distribution, then any
Derivative Works that You distribute must include a readable copy of the attribution
notices contained within such NOTICE file, excluding those notices that do not pertain
to any part of the Derivative Works, in at least one of the following places: within a
NOTICE text file distributed as part of the Derivative Works; within the Source form or
documentation, if provided along with the Derivative Works; or, within a display
generated by the Derivative Works, if and wherever such third-party notices normally
appear. The contents of the NOTICE file are for informational purposes only and do
not modify the License. You may add Your own attribution notices within Derivative
Works that You distribute, alongside or as an addendum to the NOTICE text from the
Work, provided that such additional attribution notices cannot be construed as
modifying the License.

— You may add Your own copyright statement to Your modifications and may provide
additional or different license terms and conditions for use, reproduction, or
distribution of Your modifications, or for any such Derivative Works as a whole,
provided Your use, reproduction, and distribution of the Work otherwise complies
with the conditions stated in this License.

¢ LLVM is Copyright © 2003-2019 by the University of Illinois at Urbana-Champaign.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file
except in compliance with the License. You may obtain a copy of the License at:

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the
License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS
OF ANY KIND, either express or implied. See the License for the specific language
governing permissions and limitations under the License.

¢ clang is Copyright © 2007-2019 by the University of Illinois at Urbana-Champaign.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file
except in compliance with the License. You may obtain a copy of the License at:

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the
License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF
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ANY KIND, either express or implied. See the License for the specific language governing
permissions and limitations under the License.

e lId is Copyright © 2011-2019 by the University of Illinois at Urbana-Champaign.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file
except in compliance with the License. You may obtain a copy of the License at:

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the
License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF
ANY KIND, either express or implied. See the License for the specific language governing
permissions and limitations under the License.

e libcurl is Copyright © 1996-2021, Daniel Stenberg, daniel@haxx.se, and many
contributors, see the THANKS file. All rights reserved.

Permission to use, copy, modify, and distribute this software for any purpose with or
without fee is hereby granted, provided that the above copyright notice and this
permission notice appear in all copies.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE
OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in
advertising or otherwise to promote the sale, use or other dealings in this Software
without prior written authorization of the copyright holder.
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