Quality and Process Methods

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust
The correct bibliographic citation for this manual is as follows: JMP Statistical Discovery LLC 2022. JMP® 17 Quality and Process Methods. Cary, NC: JMP Statistical Discovery LLC

JMP® 17 Quality and Process Methods
Copyright © 2022, JMP Statistical Discovery LLC, Cary, NC, USA
All rights reserved. Produced in the United States of America.
JMP Statistical Discovery LLC, SAS Campus Drive, Cary, North Carolina 27513-2414.
October 2022
JMP® and all other JMP Statistical Discovery LLC product or service names are registered trademarks or trademarks of JMP Statistical Discovery LLC in the USA and other countries. ® indicates USA registration.
Other brand and product names are trademarks of their respective companies.
JMP software may be provided with certain third-party software, including but not limited to open-source software, which is licensed under its applicable third-party software license agreement. For license information about third-party software distributed with JMP software, refer to http://support.sas.com/thirdpartylicenses.

Get the Most from JMP

Whether you are a first-time or a long-time user, there is always something to learn about JMP.
Visit JMP.com to find the following:

• live and recorded webcasts about how to get started with JMP
• video demos and webcasts of new features and advanced techniques
• details on registering for JMP training
• schedules for seminars being held in your area
• success stories showing how others use JMP
• the JMP user community, resources for users including examples of add-ins and scripts, a forum, blogs, conference information, and so on

jmp.com/getstarted
Contents

Quality and Process Methods

1 Learn about JMP
   Documentation and Additional Resources
   Formatting Conventions in JMP Documentation ......................................................... 17
   JMP Help .............................................................................................................. 18
   JMP Documentation Library ...................................................................................... 18
   Additional Resources for Learning JMP ................................................................. 25
      Search JMP ........................................................................................................ 25
      JMP Tutorials ................................................................................................... 25
      Sample Data Tables ............................................................................................. 26
      Learn about Statistical and JSL Terms ............................................................. 26
      Learn JMP Tips and Tricks .................................................................................. 26
      JMP Tooltips ....................................................................................................... 26
      JMP User Community ......................................................................................... 27
      Free Online Statistical Thinking Course ......................................................... 27
      JMP New User Welcome Kit ............................................................................. 27
      Statistics Knowledge Portal .............................................................................. 27
      JMP Training ....................................................................................................... 28
      JMP Books by Users ........................................................................................... 28
      The JMP Starter Window ..................................................................................... 28
      JMP Technical Support ...................................................................................... 28

2 Introduction to Quality and Process Methods
   Tools for Process and Product Improvement ......................................................... 29

3 Control Chart Builder
   Create Control Charts Interactively
   Overview of Control Chart Builder ....................................................................... 34
   Example of Control Chart Builder .......................................................................... 35
   Control Chart Types ............................................................................................... 37
      Shewhart Control Charts for Variables ............................................................. 37
      Shewhart Control Charts for Attributes ........................................................... 38
      Rare Event Control Charts ............................................................................... 40
      Summary of Control Chart Types ....................................................................... 41
**Contents**

**Quality and Process Methods**

Launch Control Chart Builder .................................................. 43

- Control Chart Builder Interactive Workspace .......................... 44
- Launch Windows for Specific Control Charts ......................... 47

Control Chart Builder Window .................................................. 50

- Control Chart Builder Options .............................................. 51
  - Control Chart Builder Red Triangle Menu Options ............... 52
  - Options Panel and Right-Click Chart Options ..................... 56
  - Control Chart Builder Right-Click Axis Options ................. 66

Control Limits in Control Chart Builder ..................................... 67

Excluded and Hidden Samples in Control Chart Builder ................ 67

Additional Examples of Control Chart Builder .............................. 68

- Example of Control Limits .................................................. 68
- Example of Individual Measurement and Moving Range Charts .... 77
- Example of an XBar and R Chart .......................................... 78
- Example of XBar and R Charts with Varying Subgroup Sizes ....... 81
- Example of a Run Chart ..................................................... 83
- Example of a P Chart ........................................................ 84
- Example of a Laney P’ Chart .............................................. 85
- Example of an NP Chart .................................................... 87
- Example of a C Chart ....................................................... 89
- Example of a U Chart ....................................................... 91
- Example of a G Chart ....................................................... 92
- Example of a T Chart ....................................................... 93
- Example of a Three Way Control Chart ................................ 95
- Example of Multiple Control Charts ................................... 97

Statistical Details for Control Chart Builder ............................... 98

- Statistical Details for XBar and R Charts ............................... 98
- Statistical Details for XBar and S Charts ............................... 99
- Statistical Details for Individual Measurement and Moving Range Charts .................................................. 100
- Statistical Details for P, NP, and Laney P’ Charts ................. 101
- Statistical Details for U, C, and Laney U’ Charts ................. 102
- Statistical Details for Levey-Jennings Charts ....................... 103
- Statistical Details for G Charts .......................................... 103
- Statistical Details for T Charts .......................................... 104
- Statistical Details for Three Way Control Charts ................. 105

**4 Measurement Systems Analysis**

Evaluate a Continuous Measurement Process Using the EMP Method

Overview of Measurement Systems Analysis .............................. 111

Example of Measurement Systems Analysis ............................... 111
Contents

5 Type 1 Gauge Analysis

Evaluate a Continuous Measurement Process Using the Type 1 Method

Example of Type 1 Gauge Analysis ................................................................. 143
Launch the Type 1 Gauge Platform ............................................................... 145
  Data Format ................................................................................................. 146
The Type 1 Gauge Study Report ................................................................. 147
  Run Chart .................................................................................................. 147
  Summary and Capability Statistics Table .................................................... 147
Type 1 Gauge Study Options ...................................................................... 149
  Type 1 Gauge Analysis Report Options ................................................... 149

6 Variability Gauge Charts

Evaluate a Continuous Measurement Process Using Gauge R&R

Overview of Variability Charts .................................................................... 153
Example of a Variability Chart ..................................................................... 154
Launch the Variability Gauge Chart Platform .............................................. 155
  Data Format ................................................................................................. 157
The Variability Gauge Report ....................................................................... 157
Variability Gauge Platform Options ............................................................ 159
Variability Gauge Analysis Report Options ............................................... 159
  Heterogeneity of Variance Tests ............................................................... 162
  Variance Components ................................................................................ 163
  About the Gauge R&R Method .................................................................. 165
  Gauge R&R Report ..................................................................................... 166
  Misclassification Probabilities ................................................................. 168
  Bias Report ................................................................................................. 169
Contents

Quality and Process Methods

Linearity Study .................................................................................................................. 170
Additional Examples of Variability Charts ........................................................................ 171
  Example of the Heterogeneity of Variance Test .............................................................. 171
  Example of the Bias Report and Linearity Study ............................................................. 173
Statistical Details for Variability Charts ............................................................................ 176
  Statistical Details for Variance Components ................................................................ 176
  Statistical Details for the Discrimination Ratio ............................................................... 177
  Statistical Details for the Misclassification Probabilities ................................................ 178

7 Attribute Gauge Charts .................................................................................................. 179
  Evaluate a Categorical Measurement Process Using Agreement Measures ................. 181
  Overview of Attribute Gauge Charts ............................................................................ 181
  Example of an Attribute Gauge Chart .......................................................................... 181
  Launch the Attribute Gauge Chart Platform .................................................................. 183
  The Attribute Gauge Report .......................................................................................... 184
    Gauge Attribute Chart .................................................................................................. 184
    Agreement Reports ........................................................................................................ 185
    Effectiveness Report ..................................................................................................... 187
  Attribute Gauge Platform Options .................................................................................. 188
  Statistical Details for Attribute Gauge Charts ................................................................ 190
    Statistical Details for the Gauge Attribute Chart ......................................................... 190
    Statistical Details for the Agreement Report ............................................................... 191

8 Process Screening ........................................................................................................... 195
  Screen Many Processes for Stability and Capability ....................................................... 197
  Overview of the Process Screening Platform .................................................................. 197
  Example of Process Screening ....................................................................................... 197
  Launch the Process Screening Platform ......................................................................... 200
    Limits Table .................................................................................................................. 203
  The Process Screening Report ....................................................................................... 205
  Process Screening Platform Options .............................................................................. 211
    Process Performance Graph ......................................................................................... 218
  Additional Example of Process Screening ...................................................................... 219
  Statistical Details for the Process Screening Platform .................................................... 221

9 Process Capability ............................................................................................................ 225
  Measure the Variability of a Process over Time ............................................................. 227
  Overview of the Process Capability Platform .................................................................. 227
  Example of the Process Capability Platform with Normal Variables ............................ 229
  Example of the Process Capability Platform with Nonnormal Variables ...................... 231
  Launch the Process Capability Platform ......................................................................... 237
CUSUM Control Chart Platform Options .................................................. 310
  Average Run Length (ARL) Report ..................................................... 313
Additional Examples of CUSUM Control Charts ....................................... 314
  Example of the Data Units Option in a CUSUM Control Chart .................. 314
  Example of a CUSUM Chart with Subgroups ....................................... 315
Statistical Details for the CUSUM Control Chart Platform .......................... 316
  Statistical Details for CUSUM Control Chart Construction .................... 317
  Statistical Details for Shift Detection ................................................ 318
  Statistical Details for Average Run Length ........................................ 318

11 EWMA Control Charts ........................................................................ 321
  Create Exponentially Weighted Control Charts
  Overview of the EWMA Control Chart Platform .................................... 323
  Example of the EWMA Control Chart Platform .................................... 323
  Launch the EWMA Control Chart Platform .......................................... 325
  The EWMA Control Chart Platform Report ......................................... 326
  Control Panel for EWMA Control Chart ............................................. 326
  EWMA Chart Report ........................................................................... 327
The EWMA Control Chart Platform Options .......................................... 329
  Average Run Length (ARL) Report ..................................................... 332
  Additional Example of the EWMA Control Chart Platform .................... 333
Statistical Details for the EWMA Control Chart Platform .......................... 336

12 Multivariate Control Charts .................................................................. 339
  Monitor Multiple Process Characteristics Simultaneously
  Overview of Multivariate Control Charts ............................................. 341
  Launch the Multivariate Control Chart Platform .................................... 341
  The Multivariate Control Chart Report ................................................. 343
  Multivariate Control Chart Platform Options ....................................... 344
    T Square Partitioned ................................................................. 345
    Change Point Detection ............................................................. 346
    Principal Components .................................................................. 347
Statistical Details for Multivariate Control Charts .................................... 347
  Statistical Details for Individual Observations ...................................... 348
  Statistical Details for Observations in Rational Subgroups ..................... 350
  Statistical Details for Change Point Detection ...................................... 352

13 Model Driven Multivariate Control Charts .......................................... 357
  Monitor and Diagnosis a Complex Process
  Overview of Model Driven Multivariate Control Charts ......................... 359
  Example of Model Driven Multivariate Control Charts ......................... 359
### Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example of a UWMA Chart</td>
<td>413</td>
</tr>
<tr>
<td>Statistical Details for Legacy Control Charts</td>
<td>414</td>
</tr>
<tr>
<td>Statistical Details for Median Moving Range Charts</td>
<td>414</td>
</tr>
<tr>
<td>Statistical Details for Capability Analysis</td>
<td>414</td>
</tr>
<tr>
<td>Statistical Details for V-Mask CUSUM Control Charts</td>
<td>421</td>
</tr>
<tr>
<td>Statistical Details for Weighted Moving Average Charts</td>
<td>424</td>
</tr>
<tr>
<td>15 Pareto Plots</td>
<td>427</td>
</tr>
<tr>
<td>Focus Improvement Efforts on the Vital Few</td>
<td>429</td>
</tr>
<tr>
<td>Overview of the Pareto Plot Platform</td>
<td>429</td>
</tr>
<tr>
<td>Example of the Pareto Plot Platform</td>
<td>429</td>
</tr>
<tr>
<td>Launch the Pareto Plot Platform</td>
<td>432</td>
</tr>
<tr>
<td>The Pareto Plot Report</td>
<td>433</td>
</tr>
<tr>
<td>Pareto Plot Platform Options</td>
<td>434</td>
</tr>
<tr>
<td>Plots Options</td>
<td>435</td>
</tr>
<tr>
<td>Additional Examples of the Pareto Plot Platform</td>
<td>438</td>
</tr>
<tr>
<td>Example of a Threshold for Combined Causes</td>
<td>438</td>
</tr>
<tr>
<td>Example of a Constant Sample Size across Groups</td>
<td>439</td>
</tr>
<tr>
<td>Example of a Non-Constant Sample Size across Groups</td>
<td>441</td>
</tr>
<tr>
<td>Example of a One-Way Comparative Pareto Plot</td>
<td>442</td>
</tr>
<tr>
<td>Example of a Two-Way Comparative Pareto Plot</td>
<td>444</td>
</tr>
<tr>
<td>Example of Subcategories</td>
<td>445</td>
</tr>
<tr>
<td>Statistical Details for the Pareto Plot Platform</td>
<td>446</td>
</tr>
<tr>
<td>16 Cause-and-Effect Diagrams</td>
<td>449</td>
</tr>
<tr>
<td>Identify Root Causes</td>
<td>451</td>
</tr>
<tr>
<td>Example of a Cause-and-Effect Diagram</td>
<td>451</td>
</tr>
<tr>
<td>Prepare the Data</td>
<td>452</td>
</tr>
<tr>
<td>Launch the Diagram Platform</td>
<td>452</td>
</tr>
<tr>
<td>The Cause-and-Effect Diagram Report</td>
<td>453</td>
</tr>
<tr>
<td>Right-Click Menus</td>
<td>453</td>
</tr>
<tr>
<td>Cause and Effect Diagram Menu Options</td>
<td>456</td>
</tr>
<tr>
<td>How to Save the Diagram</td>
<td>457</td>
</tr>
<tr>
<td>Save the Diagram as a Data Table</td>
<td>457</td>
</tr>
<tr>
<td>Save the Diagram as a Journal</td>
<td>457</td>
</tr>
<tr>
<td>Save the Diagram as a Script</td>
<td>458</td>
</tr>
<tr>
<td>17 Manage Limits</td>
<td>459</td>
</tr>
<tr>
<td>Manage Limits for Many Columns</td>
<td>461</td>
</tr>
<tr>
<td>Example of Manage Limits</td>
<td>461</td>
</tr>
<tr>
<td>Launch the Manage Limits Platform</td>
<td>464</td>
</tr>
</tbody>
</table>
The Manage Limits Report ................................................................. 464
Spec Limits .................................................................................... 465
Process Screening .......................................................................... 465
MSA ................................................................................................. 465
Detection Limits ............................................................................ 465
Buttons .......................................................................................... 466
Manage Limits Options ................................................................. 466

18 Operating Characteristic Curves .................................................. 469
Visualizing the Probability of Detecting Process Shifts
Example of Operating Characteristic Curves .................................... 471
Launch the Operating Characteristic Curves Platform ...................... 472
The Operating Characteristic Curve Report .................................... 472
OC Curves for Control Charts Report .............................................. 472
OC Curves for Acceptance Sampling Options ................................. 473

A References ................................................................................... 475
B Technology License Notices ........................................................ 479
Learn about JMP documentation, such as book conventions, descriptions of each JMP document, the Help system, and where to find additional support.
# Contents

- Formatting Conventions in JMP Documentation .................................................. 17
- JMP Help .................................................................................................................. 18
- JMP Documentation Library ..................................................................................... 18
- Additional Resources for Learning JMP ................................................................. 25
  - Search JMP ........................................................................................................... 25
  - JMP Tutorials ....................................................................................................... 25
  - Sample Data Tables .............................................................................................. 26
  - Learn about Statistical and JSL Terms ................................................................. 26
  - Learn JMP Tips and Tricks. ................................................................................... 26
  - JMP Tooltips ........................................................................................................ 26
- JMP User Community .............................................................................................. 26
- Free Online Statistical Thinking Course ................................................................. 27
- JMP New User Welcome Kit .................................................................................... 27
- Statistics Knowledge Portal ..................................................................................... 27
- JMP Training .......................................................................................................... 28
- JMP Books by Users ............................................................................................... 28
- The JMP Starter Window ......................................................................................... 28
- JMP Technical Support ............................................................................................ 28
Formatting Conventions in JMP Documentation

These conventions help you relate written material to information that you see on your screen:

- Sample data table names, column names, pathnames, filenames, file extensions, and folders appear in *Helvetica* (or sans-serif online) font.
- Code appears in *Lucida Sans Typewriter* (or monospace online) font.
- Code output appears in *Lucida Sans Typewriter italic* (or monospace italic online) font and is indented farther than the preceding code.
- **Helvetica bold** formatting (or bold sans-serif online) indicates items that you select to complete a task:
  - buttons
  - check boxes
  - commands
  - list names that are selectable
  - menus
  - options
  - tab names
  - text boxes
- The following items appear in italics:
  - words or phrases that are important or have definitions specific to JMP
  - book titles
  - variables
- Features that are for JMP Pro only are noted with the JMP Pro icon. For an overview of JMP Pro features, visit jmp.com/software/pro.

**Note:** Special information and limitations appear within a Note.

**Tip:** Helpful information appears within a Tip.
JMP Help

JMP Help in the Help menu enables you to search for information about JMP features, statistical methods, and the JMP Scripting Language (or JSL). You can open JMP Help in several ways:

- Search and view JMP Help on Windows by selecting Help > JMP Help.
- On Windows, press the F1 key to open the Help system in the default browser.
- Get help on a specific part of a data table or report window. Select the Help tool $\text{??}$ from the Tools menu and then click anywhere in a data table or report window to see the Help for that area.
- Within a JMP window, click the Help button.

**Note:** The JMP Help is available for users with Internet connections. Users without an Internet connection can search all books in a PDF file by selecting Help > JMP Documentation Library. See “JMP Documentation Library” for more information.

JMP Documentation Library

The Help system content is also available in one PDF file called JMP Documentation Library. Select Help > JMP Documentation Library to open the file. You can also download the Documentation PDF Files add-in if you prefer searching individual PDF files of each document in the JMP library. Download the available add-ins from https://community.jmp.com.

The following table describes the purpose and content of each document in the JMP library.

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discovering JMP</td>
<td>If you are not familiar with JMP, start here.</td>
<td>Introduces you to JMP and gets you started creating and analyzing data. Also learn how to share your results.</td>
</tr>
<tr>
<td>Using JMP</td>
<td>Learn about JMP data tables and how to perform basic operations.</td>
<td>Covers general JMP concepts and features that span across all of JMP, including importing data, modifying columns properties, sorting data, and connecting to SAS.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Basic Analysis</td>
<td>Perform basic analysis using this document.</td>
<td>Describes these Analyze menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Distribution</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Y by X</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Tabulate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Text Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Covers how to perform bivariate, one-way ANOVA, and contingency analyses through Analyze &gt; Fit Y by X. How to approximate sampling distributions using bootstrapping and how to perform parametric resampling with the Simulate platform are also included.</td>
</tr>
<tr>
<td>Essential Graphing</td>
<td>Find the ideal graph for your data.</td>
<td>Describes these Graph menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Graph Builder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scatterplot 3D</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Contour Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Bubble Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Parallel Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cell Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scatterplot Matrix</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ternary Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Treemap</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Chart</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Overlay Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The book also covers how to create background and custom maps.</td>
</tr>
<tr>
<td>Profilers</td>
<td>Learn how to use interactive profiling tools, which enable you to view cross-sections of any response surface.</td>
<td>Covers all profilers listed in the Graph menu. Analyzing noise factors is included along with running simulations using random inputs.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><em>Design of Experiments Guide</em></td>
<td>Learn how to design experiments and determine appropriate sample sizes.</td>
<td>Covers all topics in the DOE menu.</td>
</tr>
<tr>
<td><em>Fitting Linear Models</em></td>
<td>Learn about Fit Model platform and many of its personalities.</td>
<td>Describes these personalities, all available within the Analyze menu Fit Model platform:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Standard Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Stepwise</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Regression</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Mixed Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Linear Mixed Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MANOVA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Loglinear Variance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nominal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ordinal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Linear Model</td>
</tr>
<tr>
<td><strong>Document Title</strong></td>
<td><strong>Document Purpose</strong></td>
<td><strong>Document Content</strong></td>
</tr>
<tr>
<td>------------------</td>
<td>----------------------</td>
<td>----------------------</td>
</tr>
</tbody>
</table>
| *Predictive and Specialized Modeling* | Learn about additional modeling techniques. | Describes these Analyze > Predictive Modeling menu platforms:  
  - Neural  
  - Partition  
  - Bootstrap Forest  
  - Boosted Tree  
  - K Nearest Neighbors  
  - Naive Bayes  
  - Support Vector Machines  
  - Model Comparison  
  - Model Screening  
  - Make Validation Column  
  - Formula Depot  

Describes these Analyze > Specialized Modeling menu platforms:  
  - Fit Curve  
  - Nonlinear  
  - Functional Data Explorer  
  - Gaussian Process  
  - Time Series  
  - Matched Pairs  

Describes these Analyze > Screening menu platforms:  
  - Explore Outliers  
  - Explore Missing Values  
  - Explore Patterns  
  - Response Screening  
  - Predictor Screening  
  - Association Analysis  
  - Process History Explorer |
<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multivariate Methods</td>
<td>Read about techniques for analyzing several variables simultaneously.</td>
<td>Describes these Analyze &gt; Multivariate Methods menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multivariate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Principal Components</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Discriminant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partial Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multiple Correspondence Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Structural Equation Models</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Factor Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multidimensional Scaling</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multivariate Embedding</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Item Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Clustering menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Hierarchical Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• K Means Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Normal Mixtures</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latent Class Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cluster Variables</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>----------------------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Quality and Process Methods</strong></td>
<td>Read about tools for evaluating and improving processes.</td>
<td>Describes these Analyze &gt; Quality and Process menu platforms:&lt;br&gt;  • Control Chart Builder and individual control charts  &lt;br&gt;  • Measurement Systems Analysis (EMP and Type 1 Gauge)  &lt;br&gt;  • Variability / Attribute Gauge Charts  &lt;br&gt;  • Process Screening  &lt;br&gt;  • Process Capability  &lt;br&gt;  • Model Driven Multivariate Control Chart  &lt;br&gt;  • Legacy Control Charts  &lt;br&gt;  • Pareto Plot  &lt;br&gt;  • Diagram  &lt;br&gt;  • Manage Spec Limits  &lt;br&gt;  • OC Curves</td>
</tr>
<tr>
<td><strong>Reliability and Survival Methods</strong></td>
<td>Learn to evaluate and improve reliability in a product or system and analyze survival data for people and products.</td>
<td>Describes these Analyze &gt; Reliability and Survival menu platforms:&lt;br&gt;  • Life Distribution  &lt;br&gt;  • Fit Life by X  &lt;br&gt;  • Cumulative Damage  &lt;br&gt;  • Recurrence Analysis  &lt;br&gt;  • Degradation  &lt;br&gt;  • Repeated Measures Degradation  &lt;br&gt;  • Destructive Degradation  &lt;br&gt;  • Reliability Forecast  &lt;br&gt;  • Reliability Growth  &lt;br&gt;  • Reliability Block Diagram  &lt;br&gt;  • Repairable Systems Simulation  &lt;br&gt;  • Survival  &lt;br&gt;  • Fit Parametric Survival  &lt;br&gt;  • Fit Proportional Hazards</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| **Consumer Research** | Learn about methods for studying consumer preferences and using that insight to create better products and services. | Describes these Analyze > Consumer Research menu platforms:  
  - Categorical  
  - Choice  
  - MaxDiff  
  - Uplift  
  - Multiple Factor Analysis |
| **Genetics**        | Learn about methods that are available in JMP to help you analyze your genetic data and use that data to simulate a breeding program to predict the optimum genetic crosses to make. | Describes these Analyze > Genetics menu platforms:  
  - Marker Statistics  
  - Marker Simulation |
| **Scripting Guide** | Learn about taking advantage of the powerful JMP Scripting Language (JSL). | Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications. |
| **JSL Syntax Reference** | Read about many JSL functions on functions and their arguments, and messages that you send to objects and display boxes. | Includes syntax, examples, and notes for JSL commands. |
Additional Resources for Learning JMP

In addition to reading JMP help, you can also learn about JMP using the following resources:

- “Search JMP”
- “JMP Tutorials”
- “Sample Data Tables”
- “Learn about Statistical and JSL Terms”
- “Learn JMP Tips and Tricks”
- “JMP Tooltips”
- “JMP User Community”
- “Free Online Statistical Thinking Course”
- “JMP New User Welcome Kit”
- “Statistics Knowledge Portal”
- “JMP Training”
- “JMP Books by Users”
- “The JMP Starter Window”

Search JMP

If you are not sure where to find a statistical procedure, do a search across JMP. Results are tailored to the window that you launch the search from, such as a data table or report.

1. Click Help > Search JMP. Or, press Ctrl+comma.
2. Enter your search text.
3. Click the result that contains the procedure that you want.
   On the right, you can see a description and the location of the procedure.
4. Click the corresponding button to open or go to a result.

JMP Tutorials

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, start with the Beginners Tutorial. It steps you through the JMP interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment and comparing a sample mean to a constant.
Sample Data Tables

All of the examples in the JMP documentation suite use sample data. Select Help > Sample Data Folder to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories, select Help > Sample Index.

Sample data tables are installed in the following directory:
- On Windows: C:\Program Files\SAS\JMP\17\Samples\Data
- On macOS: \Library\Application Support\JMP\17\Samples\Data

In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

To view examples using sample data, select Help > Sample Index and navigate to the Teaching Resources section. To learn more about the teaching resources, visit jmp.com/tools.

Learn about Statistical and JSL Terms

For help with statistical terms, select Help > Statistics Index. For help with JSL scripting and examples, select Help > Scripting Index.

Statistics Index  Provides definitions of statistical terms.

Scripting Index  Lets you search for information about JSL functions, objects, and display boxes. You can also edit and run sample scripts from the Scripting Index and get help on the commands.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select Help > Tip of the Day. Or, you can turn it off using the Preferences window.

JMP Tooltips

JMP provides descriptive tooltips (or hover labels) when you hover over items, such as the following:
- Menu or toolbar options
- Labels in graphs
- Text results in the report window (move your cursor in a circle to reveal)
• Files or windows in the Home Window
• Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences > General and then deselect Show menu tips. This option is not available on macOS.

JMP User Community

The JMP User Community provides a range of options to help you learn more about JMP and connect with other JMP users. The learning library of one-page guides, tutorials, and demos is a good place to start. And you can continue your education by registering for a variety of JMP training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, and social networking groups.

To access JMP resources on the website, select Help > JMP on the Web > JMP User Community or visit https://community.jmp.com.

Free Online Statistical Thinking Course

Learn practical statistical skills in this free online course on topics such as exploratory data analysis, quality methods, and correlation and regression. The course consists of short videos, demonstrations, exercises, and more. Visit jmp.com/statisticalthinking.

JMP New User Welcome Kit

The JMP New User Welcome Kit is designed to help you quickly get comfortable with the basics of JMP. You'll complete its thirty short demo videos and activities, build your confidence in using the software, and connect with the largest online community of JMP users in the world. Visit jmp.com/welcome.

Statistics Knowledge Portal

The Statistics Knowledge Portal combines concise statistical explanations with illuminating examples and graphics to help visitors establish a firm foundation upon which to build statistical skills. Visit jmp.com/skp.
JMP Training

SAS offers training on a variety of topics led by a seasoned team of JMP experts. Public courses, live web courses, and on-site courses are available. You might also choose the online e-learning subscription to learn at your convenience. Visit jmp.com/training.

JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP website. Visit jmp.com/books.

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus. The window also lists JMP Pro features and platforms.

- To open the JMP Starter window, select View (Window on macOS) > JMP Starter.
- To display the JMP Starter automatically when you open JMP on Windows, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list. On macOS, select JMP > Preferences > Initial JMP Starter Window.

JMP Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP, many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at jmp.com/support, including the technical support phone number.
Introduction to Quality and Process Methods

Tools for Process and Product Improvement

*Quality and Process Methods* describes a number of methods and tools that are available in JMP to help you evaluate and improve quality and process performance:

- Control charts provide feedback on key variables and show when a process is in, or out of, statistical control. “Control Chart Builder” describes the JMP approach to creating control charts using an interactive control chart platform called Control Chart Builder.

- The Measurement Systems Analysis platform assesses the precision, consistency, and bias of a system. Before you can study a process, you need to make sure that you can accurately and precisely measure the process. If variation comes from the measurement itself, then you are not reliably learning about the process. Use this analysis to find out how your system is performing. See “Measurement Systems Analysis”.

- The Type 1 Gauge platform assesses whether a measurement system, or gauge, is repeatable. Specifically, the analysis determines if a measurement system can repeatedly measure a part and obtain measurements that are close to a known reference standard. See “Type 1 Gauge Analysis”.

- The Variability/Attribute Gauge Chart platform creates variability or attribute gauge charts. Variability charts analyze continuous measurements and reveal how your system is performing. Attribute charts analyze categorical measurements and show you measures of agreement across responses. You can also perform a gauge study to see measures of variation in your data. See “Variability Gauge Charts” and “Attribute Gauge Charts”.

- The Process Screening platform enables you to explore a large number of processes across time. The platform calculates control chart, process stability, and process capability metrics, and detects large process shifts. See “Process Screening”.

- The Process Capability platform measures the ability of a process to meet specification limits. You can compare process performance, summarized by process centering and variability, to specification limits. The platform calculates capability indices based on both long-term and short-term variation. The analysis helps identify the variation relative to the specifications; this enables you to achieve increasingly higher conformance values. See “Process Capability”.

- CUSUM charts enable you to make decisions based on the cumulative sum. These charts can detect small shifts in a process. See “CUSUM Control Charts”.

- Exponentially weighted moving average (EWMA) charts can also be used to detect small shifts in a process. See “EWMA Control Charts”.
• When you need to monitor multiple process characteristics simultaneously, see “Multivariate Control Charts”.
• The Model Driven Multivariate Control Chart (MDMVCC) platform enables you to build a control chart based on principal components or partial least squares models. See “Model Driven Multivariate Control Charts”.
• “Legacy Control Charts” describes the older control chart platforms in JMP. Instead of using these platforms, you are encouraged to use the Control Chart Builder platform, as well as the new CUSUM and EWMA Control Chart platforms.
• The Pareto Plot platform shows the frequency of problems in a quality related process or operation. Pareto plots help you decide which problems to solve first by highlighting the frequency and severity of problems. See “Pareto Plots”.
• The Diagram platform constructs cause-and-effect diagrams, which organize the sources of a problem for brainstorming or as a preliminary analysis to identify variables for further experimentation. Once complete, further analysis can be done to identify the root cause of the problem. See “Cause-and-Effect Diagrams”.
• The Manage Spec Limits utility enables you to quickly add or edit many specification limits for several columns at once. See “Manage Limits”.
• The Operating Characteristic (OC) Curves utility enables you to construct OC curves for control charts and attribute acceptance sampling plans. See “Operating Characteristic Curves”.
Use Control Chart Builder to create control charts of your process data. Control Chart Builder can be launched as an interactive workspace or from specific control chart menu options. In the interactive workspace, you select the variables that you want to chart and drag them into zones. JMP automatically chooses an appropriate chart type based on the data. You can quickly create another type of chart, or change the current settings for an existing chart.

A control chart is a graphical and analytic tool for monitoring process variation. The natural variation in a process can be quantified using a set of control limits. Control limits help distinguish common-cause variation from special-cause variation. Typically, action is taken to identify and eliminate special-cause variation. It is also important to quantify the common-cause variation in a process, as this determines the capability of a process.

**Figure 3.1 Control Chart Builder Example**
# Contents

Overview of Control Chart Builder ............................................................... 34  
Example of Control Chart Builder ............................................................... 35  
Control Chart Types .................................................................................... 37  
  - Shewhart Control Charts for Variables .................................................. 37  
  - Shewhart Control Charts for Attributes ................................................ 38  
  - Rare Event Control Charts ................................................................. 40  
  - Summary of Control Chart Types ....................................................... 41  
Launch Control Chart Builder ................................................................. 43  
  - Control Chart Builder Interactive Workspace ..................................... 44  
  - Launch Windows for Specific Control Charts ..................................... 47  
Control Chart Builder Window ................................................................. 50  
Control Chart Builder Options ................................................................. 51  
  - Control Chart Builder Red Triangle Menu Options ............................ 52  
  - Options Panel and Right-Click Chart Options .................................... 56  
  - Control Chart Builder Right-Click Axis Options ............................... 66  
Control Limits in Control Chart Builder ................................................... 67  
Excluded and Hidden Samples in Control Chart Builder .......................... 67  
Additional Examples of Control Chart Builder ......................................... 68  
  - Example of Control Limits ............................................................... 68  
  - Example of Individual Measurement and Moving Range Charts ............ 77  
  - Example of an XBar and R Chart ....................................................... 78  
  - Example of XBar and R Charts with Varying Subgroup Sizes ............... 81  
  - Example of a Run Chart ................................................................. 83  
  - Example of a P Chart ..................................................................... 84  
  - Example of a Laney P’ Chart ............................................................ 85  
  - Example of an NP Chart ................................................................. 87  
  - Example of a C Chart .................................................................... 89  
  - Example of a U Chart .................................................................... 91  
  - Example of a G Chart .................................................................... 92  
  - Example of a T Chart .................................................................... 93  
  - Example of a Three Way Control Chart ........................................... 95  
  - Example of Multiple Control Charts .............................................. 97  
Statistical Details for Control Chart Builder ............................................. 98  
  - Statistical Details for XBar and R Charts ......................................... 98  
  - Statistical Details for XBar and S Charts ......................................... 99  
  - Statistical Details for Individual Measurement and Moving Range Charts. 100  
  - Statistical Details for P, NP, and Laney P’ Charts ................................ 101  
  - Statistical Details for U, C, and Laney U’ Charts ............................... 102  
  - Statistical Details for Levey-Jennings Charts ..................................... 103
Chapter 3
Quality and Process Methods

Statistical Details for G Charts ................................................................. 103
Statistical Details for T Charts ................................................................. 104
Statistical Details for Three Way Control Charts ................................. 105
Overview of Control Chart Builder

A control chart is a graphical and analytic tool for monitoring process variation and identifying special-cause variation in a process. Establishing control limits to filter out routine variation helps determine whether a process is stable and predictable. If the variation in a process is more than desired, the process can be adjusted to create higher quality output with potential cost savings.

All processes exhibit measurement variation as the process is monitored over time. There are two types of variation in process measurements:

- **Routine or common-cause** variation. Measurements from a stable process still exhibit random variation. When process measurements exhibit only common-cause variation, the measurements stay within expected limits.

- **Abnormal or special-cause** variation. Special-cause variation is indicated by patterns observed on the control chart. Examples include a shift in the process mean, points above or below the control limits, or measurements that trend up or down. These shifts in the process measurements can be caused by factors such as a broken tool or machine, equipment degradation, or changes to raw materials. A change or defect in the process is often identifiable by abnormal variation in the process measurements.

Control Chart Builder enables you to create several types of control charts including Shewhart and Rare Event control charts. Shewhart control charts are broadly classified into control charts for variables and control charts for attributes. Rare event charts are designed for events that occur infrequently. JMP provides a flexible, user-defined approach to building control charts. You can construct control charts in the following ways:

- Use the interactive Control Chart Builder workspace. When you drag a data column to the workspace, Control Chart Builder creates an appropriate chart based on the data type and sample size.

- Use the control chart menu options to build a specific control chart using a launch window.

Once an initial chart is created through either method above, use the menus and other options to change the type of chart, change the statistic on the chart, reformat the chart, or add additional charts.
Example of Control Chart Builder

In this example, use Control Chart Builder interactively and through the launch window to investigate an increase in the number of defects in a production process. The launch window approach is convenient if you know which type of control chart you want to build.

Control Chart Builder Interactive Method

Use the interactive Control Chart Builder workspace to investigate the variability in the process data.

1. Select Help > Sample Data Folder and open Quality Control/Socket Thickness.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Thickness to the Y zone.
4. Drag Hour to the Subgroup zone (at bottom).

Figure 3.2 Control Charts for Socket Thickness

Looking at the Average chart, you can see that there are several points below the lower control limit of 7.788772. You want to see whether another variable might be contributing to the problem.

5. Drag Cavity into the Phase zone.
6. Click Done.
Figure 3.3  Control Charts for Each Cavity

From the Average chart, you can conclude the following:

- There are differences between the cavities, indicating the need for separate control limits for each cavity.
- Cavity 1 is producing sockets with an average thickness above that of the other cavities. This indicates that further investigation of the differences between cavities is warranted.
- All of the cavities have points that are outside the control limits. Therefore, you should investigate the lack of control in the process for each cavity.

The Range chart for each cavity shows that the within-subgroup measurements are in control and are similar across cavities.

Control Chart Builder Launch Window Method

Use the XBar Control Chart launch window to obtain the same chart as Figure 3.3.

1. Select Help > Sample Data Folder and open Quality Control/Socket Thickness.jmp.
2. Select Analyze > Quality and Process > Control Chart > XBar Control Chart.
3. Select Thickness and click Y.
4. Select Hour and click Subgroup.
5. Select Cavity and click Phase.
6. Click OK.

You should see the same control chart that appears in Figure 3.3.
Control Chart Types

Control Chart Builder enables you to create several types of control charts, including Shewhart Variable, Shewhart Attribute, and Rare Event charts.

- “Shewhart Control Charts for Variables”
- “Shewhart Control Charts for Attributes”
- “Rare Event Control Charts”
- “Summary of Control Chart Types”

Shewhart Control Charts for Variables

In Control Chart Builder, control charts for variables are classified according to the subgroup summary statistic plotted on the chart.

- XBar charts are a type of location chart that display subgroup means (averages).
- R charts are a type of dispersion chart that display subgroup ranges (maximum – minimum).
- S charts are a type of dispersion chart that display subgroup standard deviations.
- Individual Measurement charts are a type of location chart that display individual measurements.
- Run charts are a type of location chart that display individual measurements as a connected series of points.
- Presummarize charts display both subgroup means and standard deviations.
- Moving Range charts are a type of dispersion chart that display moving ranges of two successive measurements.

Note: If you remove a dispersion chart or turn off the preference Show Two Shewhart Charts in File > Preferences > Platforms > Control Chart Builder, you will see only the location chart. Any associated scripts will contain the JSL option Show Two Shewhart Charts set to off (0).

XBar, R, and S Charts

For quality characteristics measured on a continuous scale, a typical analysis shows both the process mean and its variability with a mean chart aligned above its corresponding R or S chart.
Individual Measurement Charts

Individual Measurement charts display individual measurements. Individual Measurement charts are appropriate when only one measurement is available for each sampling time point. If you are charting individual measurements, the individual measurement chart shows above its corresponding moving range chart. Moving Range charts display moving ranges of two successive measurements.

Presummarize Charts

If your data consist of repeated measurements of the same process unit, you can combine these into one measurement for the unit. Pre-summarizing is not recommended unless the data contain repeated measurements on each process or measurement unit.

Presummarize summarizes the process column into sample means and/or standard deviations, based either on the sample size or sample label chosen. Then it charts the summarized data based on the options chosen in the window.

Levey-Jennings Charts

Levey-Jennings charts show a process mean with control limits based on a long-term sigma. The control limits are placed at 3σ distance from the center line. The standard deviation, σ, for the Levey-Jennings chart is calculated the same way standard deviation is in the Distribution platform.

Shewhart Control Charts for Attributes

In Control Chart Builder, you can create attribute charts, which are applicable for count data. Attribute charts are based on binomial and Poisson models. Because the counts are measured per subgroup, it is important when comparing multiple charts to determine whether you have a similar number of items in the subgroups between the charts. Attribute charts, like variables charts, are classified according to the subgroup sample statistic plotted on the chart.

Table 3.1  Attribute Chart Determination

<table>
<thead>
<tr>
<th>Distribution Used to Calculate Sigma</th>
<th>Statistic Type: Proportion</th>
<th>Statistic Type: Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binomial</td>
<td>P chart, Laney P’ chart</td>
<td>NP chart</td>
</tr>
<tr>
<td>Poisson</td>
<td>U chart, Laney U’ chart</td>
<td>C chart</td>
</tr>
</tbody>
</table>
Control Chart Builder makes some decisions for you based on the variable selected. Once the basic chart is created, you can use the menus and other options to change the type, the statistic, and the format of the chart.

- **P** charts display the proportion of nonconforming (defective) items in subgroup samples, which can vary in size. Because each subgroup for a P chart consists of $N_i$ items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in a subgroup is $N_i$.

- Laney $P'$ charts display the same information as a standard P chart, but the control limits are calculated using a moving range adjusted sigma. In a standard P chart, the control limits are computed using the binomial distribution. However, this distribution often underestimates the variance in the actual data and causes false alarms to be reported in the chart. Laney $P'$ charts address these issues. The Laney $P'$ chart is particularly useful when the subgroup size is very large.

- **NP** charts display the number of nonconforming (defective) items in subgroup samples. Because each subgroup for an NP chart consists of $N_i$ items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in subgroup $i$ is $N_i$.

- **C** charts display the number of nonconformities (defects) in a subgroup sample that usually, but does not necessarily, consists of one inspection unit.

- **U** charts display the number of nonconformities (defects) per unit in subgroup samples that can have a varying number of inspection units.

- Laney $U'$ charts display the same information as a standard U chart, but the control limits are calculated using a moving range adjusted sigma. In a standard U chart, the control limits are computed using the Poisson distribution. However, this distribution often underestimates the variance in the actual data and causes false alarms to be reported in the chart. Laney $U'$ charts address these issues. The Laney $U'$ chart is particularly useful when the subgroup size is very large.

**Note:** Generally there is no harm in using a Laney chart over standard P and U charts. If there is no overdispersion, the moving range sigma adjustment is close to 1, resulting in a chart that is equivalent to a standard chart. However, if there is overdispersion then the Laney charts are better for process control. Overdispersion occurs when there is greater variability in the data than is assumed by the distribution.
Rare Event Control Charts

In Control Chart Builder, you can create a Rare Event chart, which is a control chart that provides information about a process where the data comes from rarely occurring events. Tracking processes that occur infrequently on a traditional control chart tend to be ineffective. Rare event charts were developed in response to the limitations of control charts in rare event scenarios. Control Chart Builder provides two types of rare event charts (G charts and T charts). The difference between a G chart and a T chart is the quantity used to measure distance between rare events. The G chart measures counts of events between incidents, whereas the T chart measures time intervals between incidents.

Table 3.2  Rare Event Chart Determination Based on Sigma

<table>
<thead>
<tr>
<th>Distribution Used to Calculate Sigma</th>
<th>Chart Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Negative Binomial</td>
<td>G chart</td>
</tr>
<tr>
<td>Weibull</td>
<td>T chart</td>
</tr>
</tbody>
</table>

G charts

A G chart measures the number of events between rarely occurring errors or nonconforming incidents, and creates a chart of a process over time. Each point on the chart represents the number of units between occurrences of a relatively rare event. For example, in a production setting, where an item is produced daily, an unexpected line shutdown can occur. You can use a G chart to look at the number of units produced between line shutdowns.

When reading a G chart, the points above the upper control limit indicate that the number of events between errors has increased. If the number of events between rarely occurring errors or nonconforming incidents has increased, that is good. Therefore, a point flagged as out of control above the limits is generally considered a desirable effect when working with G charts.

T charts

A T chart measures the time intervals elapsed since the last event. Each point on the chart represents a number of time intervals that have passed since a prior occurrence of a rare event. A T chart can be used for numeric, nonnegative data, date/time data, and time-between data. Since a traditional plot of these data might contain many points at zero and an occasional point at one, using a T chart avoids flagging numerous points as out of control. The data points for a T chart in Control Chart Builder are restricted to integer values.
When reading a T chart, the points above the upper control limit indicate that the amount of time between events has increased. This means that the rate of adverse events has decreased. Therefore, a point flagged as out of control above the limits is generally considered a desirable effect when working with T charts.

**Summary of Control Chart Types**

The most common control charts are available in Control Chart Builder and in the platforms in the Analyze > Quality and Process > Control Chart menu. Use Control Chart Builder as your first choice to easily and quickly generate charts. JMP automatically chooses the appropriate chart type based on the data. Table 3.3 through Table 3.7 summarize the different control chart types.

### Table 3.3 Variable Charts Without Grouping (X) Variable or Nonsummarized Data

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Points &gt; Statistic</td>
</tr>
<tr>
<td>Individual</td>
<td>Individual</td>
</tr>
<tr>
<td>Moving Range on Individual</td>
<td>Moving Range</td>
</tr>
<tr>
<td>Individual (limits computed on median moving range)</td>
<td>Individual</td>
</tr>
<tr>
<td>Median Moving Range on Individual</td>
<td>Moving Range</td>
</tr>
<tr>
<td>Run Chart</td>
<td>Individual</td>
</tr>
<tr>
<td>Levey Jennings</td>
<td>Individual</td>
</tr>
</tbody>
</table>

### Table 3.4 Variable Charts with Grouping (X) Variables or Summarized Data

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Points &gt; Statistic</td>
</tr>
<tr>
<td>XBar (limits computed on range)</td>
<td>Average</td>
</tr>
<tr>
<td>XBar (limits computed on standard deviation)</td>
<td>Average</td>
</tr>
</tbody>
</table>
Table 3.4  Variable Charts with Grouping (X) Variables or Summarized Data  (Continued)

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Points &gt; Statistic</td>
</tr>
<tr>
<td>R</td>
<td>Range</td>
</tr>
<tr>
<td>S</td>
<td>Standard Deviation</td>
</tr>
<tr>
<td>Levey Jennings</td>
<td>Average</td>
</tr>
</tbody>
</table>

Table 3.5  Presummarize Charts

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Points &gt; Statistic</td>
</tr>
<tr>
<td>Individual on Group Means</td>
<td>Average</td>
</tr>
<tr>
<td>Individual on Group Means</td>
<td>Average</td>
</tr>
<tr>
<td>(limits computed on median moving range)</td>
<td></td>
</tr>
<tr>
<td>Individual on Group Std Devs</td>
<td>Standard Deviation</td>
</tr>
<tr>
<td>Individual on Group Std Devs</td>
<td>Standard Deviation</td>
</tr>
<tr>
<td>(limits computed on median moving range)</td>
<td></td>
</tr>
<tr>
<td>Moving Range on Group Means</td>
<td>Moving Range on Means</td>
</tr>
<tr>
<td>Median Moving Range on Group Means</td>
<td>Moving Range on Mean</td>
</tr>
<tr>
<td>Moving Range on Group Std Devs</td>
<td>Moving Range on Std Dev</td>
</tr>
<tr>
<td>Median Moving Range on Group Std Devs</td>
<td>Moving Range on Std Dev</td>
</tr>
</tbody>
</table>
Table 3.6  Attribute Charts

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
<th>Points &gt; Statistic</th>
<th>Limits &gt; Sigma</th>
</tr>
</thead>
<tbody>
<tr>
<td>P chart</td>
<td></td>
<td>Proportion</td>
<td>Binomial</td>
</tr>
<tr>
<td>NP chart</td>
<td></td>
<td>Count</td>
<td>Binomial</td>
</tr>
<tr>
<td>C chart</td>
<td></td>
<td>Count</td>
<td>Poisson</td>
</tr>
<tr>
<td>U chart</td>
<td></td>
<td>Proportion</td>
<td>Poisson</td>
</tr>
<tr>
<td>Laney P’ chart</td>
<td></td>
<td>Proportion</td>
<td>Binomial adjusted by a moving range sigma value</td>
</tr>
<tr>
<td>Laney U’ chart</td>
<td></td>
<td>Proportion</td>
<td>Poisson adjusted by a moving range sigma value</td>
</tr>
</tbody>
</table>

Table 3.7  Rare Event Charts

<table>
<thead>
<tr>
<th>Chart Types</th>
<th>Control Chart Builder Options</th>
<th>Points &gt; Statistic</th>
<th>Limits &gt; Sigma</th>
</tr>
</thead>
<tbody>
<tr>
<td>G chart</td>
<td></td>
<td>Count</td>
<td>Negative Binomial</td>
</tr>
<tr>
<td>T chart</td>
<td></td>
<td>Count</td>
<td>Weibull</td>
</tr>
</tbody>
</table>

Launch Control Chart Builder

You can launch Control Chart Builder in the following two ways:

- If you are not sure what type of control chart is appropriate for your data, select **Analyze > Quality and Process > Control Chart Builder**. This method enables you to drag data columns to the workspace and Control Chart Builder creates an appropriate chart based on the data type and sample size. See “Control Chart Builder Interactive Workspace”.

- If you know which type of control chart is appropriate for your data, select the appropriate chart from the **Analyze > Quality and Process > Control Chart** submenu. This displays a control chart launch window. See “Launch Windows for Specific Control Charts”. There are control chart builder launch windows for the following control charts:
  - IMR Control Chart
Control Chart Builder Interactive Workspace

To begin creating a control chart interactively, drag variables from the Select Columns box into the zones. If you drop variables in the center, Control Chart Builder guesses where to put them based on whether the variables are continuous or categorical.
Figure 3.4 Interactive Control Chart Builder Window

The Control Chart Builder workspace contains the following zones:

**Y** Assigns the process variable.

**Label** Assigns a sample label variable to uniquely label individual measurements. The labels are not sorted and appear on the horizontal axis in the same order they appear in the data table.

**Subgroup** Assigns subgroup variables. To define subgroup levels as a combination of multiple columns, add multiple variables to the **Subgroup** zone. When a subgroup variable is assigned, each point on the control chart corresponds to a summary statistic for all of the points in the subgroup.

**Phase** (Not available for Rare Event control charts.) Assigns phase variables. When a Phase variable is assigned, separate control limits are computed for each phase. See also “Example of an XBar and R Chart”.

The initial Control Chart Builder window contains the following buttons:

**Undo** Reverses the last change made to the window.

**Start Over** Returns the window to the default condition, removing all data, and clearing all zones.

For more information about the options in the Select Columns red triangle menu, see *Using JMP*.
Control Chart Builder
Launch Control Chart Builder

Done  Hides the buttons and the Select Columns box and removes all drop zone outlines. In this presentation-friendly format, you can copy the graph to other programs. To restore the window to the interactive mode, click the Control Chart Builder red triangle and select Show Control Panel.

By  Identifies the variable and produces a separate analysis for each value that appears in the column.

Shewhart Variables/Shewhart Attribute/Rare Event  Enables you to select Shewhart Variables, Shewhart Attribute, or Rare Event control chart types. If you select an Attribute chart type, an n Trials box and zone appear on the chart.

n Trials  (Available for Attribute charts.) Assigns a lot size for an attribute control chart.

New Y Chart  Produces a copy of the current chart for every column selected in the Select Columns box. The new charts use the selected columns in the Y role.

Once you drag variables to the chart, other buttons and options appear at left that enable you to show, hide or switch items on the chart (Figure 3.7). Many of these functions (Points, Limits, Warnings, etc.) are the same as the functions available when you right-click the chart. See “Options Panel and Right-Click Chart Options”. For information about warnings and rules, see “Tests” and “Westgard Rules”.

Three Way Control Chart  Enables you to produce a three way control chart for variable chart types. The subgroup size must be greater than one. The plotting statistic is based on subgroup averages, within-subgroup variation, or between-subgroup variation. The default set of three includes a presummarized chart of the averages using Moving Range limits, a Moving Range chart and a Range chart.

Event Chooser  Allows the chart to respond in real time to selection changes. There are several standard groups of responses that are recognized and pre-scored (for example, pass/fail, yes/no, Likert Scales, conforming/non-conforming, and defective/non-defective). If you are analyzing results from a survey and want to focus solely on a specific sector of the results for one or more questions, you can make the selection on the screen. When you make the selection, the chart is scored again and replotted immediately. The levels selected in the Event Chooser are counted as events, and all other levels are counted as non-events.

The Event Chooser is available for attribute charts with response columns that have a modeling type of nominal or ordinal. If you want the Event Chooser to work on a numeric integer-valued nominal or ordinal response column, you must select the Use Event Chooser option from the Control Chart Builder red triangle menu. The Event Chooser does not appear for response columns with a modeling type of continuous.
Launch Windows for Specific Control Charts

The options that appear in the launch windows for specific control charts vary depending on whether you are launching variable control charts or attribute control charts. You can access these launch windows through the Analyze > Quality and Process > Control Chart menu. These launch windows enable you to specify variables for a control chart in Control Chart Builder.

Launch Windows for Variable Control Charts

This section contains information about the launch windows for IMR, XBar, Run, Levey Jennings, IMR on Means, and Three Way Control Charts.

Figure 3.5 Launch Window for Variable Control Charts

For more information about the options in the Select Columns red triangle menu, see Using JMP.

Y Assigns the process variables.

Subgroup (Not available for Run charts.) Assigns the subgroup variables. When a subgroup variable is assigned, each point on the control chart corresponds to a summary statistic for all of the points in the subgroup.

Label (Available only for IMR charts.) Assigns a sample label variable to uniquely label individual measurements. The labels are not sorted and appear on the horizontal axis in the same order they appear in the data table.

Note: If a subgroup size greater than one is specified by a Subgroup variable, a constant subgroup size, or the Set Subgroup Size command in a script, the Label variable is ignored.
**Phase**  (Not available for Run charts.) Assigns the phase variable. When a Phase variable is assigned, separate control limits are computed for each phase.

**By**  Identifies a variable to produce a separate analysis for each value that appears in the column.

**Sort by Subgroup**  (Available only for IMR charts.) Sorts all variables by the Subgroup variable.

**Constant Subgroup Size**  (Available only for XBar and Three Way charts.) Specifies a number of observations that make up each subgroup. If the number of observations per subgroup is not constant, you should specify a column in the Subgroup role.

**Note:** If you specify a Subgroup variable, the platform ignores the setting for the Constant Subgroup Size option.

**Dispersion Chart**  (Available only for XBar charts.) Specifies the type of dispersion chart that appears below the XBar chart. You can choose between no dispersion chart, a range chart (XBar & R), or a standard deviation chart (XBar & S).

**Grouping Method**  (Available only for Three Way charts.) Specifies the statistic represented by the points on the first chart. The options are Mean and Standard Deviation. See “Statistic”.

**Between Chart**  (Available only for Three Way Charts.) Specifies the method for computing the between sigma estimate. The options are Moving Range and Median Moving Range. See “Sigma” and “Statistical Details for Three Way Control Charts”.

**Within Chart**  (Available only for Three Way Charts.) Specifies the method for computing the within sigma estimate. The options are Range and Standard Deviation. See “Sigma” and “Statistical Details for Three Way Control Charts”.
### Launch Windows for Attribute Control Charts

This section contains information about the launch windows for P, NP, C, U, Laney P’, and Laney U’ Control Charts.

#### Figure 3.6  Launch Window for Attribute Control Charts

For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

- **Y, n Defective**  (Available only for P, NP, and Laney P’ control charts.) Assigns the process variables.

- **Y, n Defects**  (Available only for C, U, and Laney U’ control charts.) Assigns the process variables.

- **Subgroup**  Assigns the subgroup variables. When a subgroup variable is assigned, each point on the control chart corresponds to a summary statistic for all of the points in the subgroup.

- **n Trials**  Assigns the subgroup sample size.

- **Phase**  Assigns the phase variable. When a Phase variable is assigned, separate control limits are computed for each phase.

- **By**  Identifies a variable to produce a separate analysis for each value that appears in the column.
Control Chart Builder Window

Use Control Chart Builder to construct control charts for process data. The analysis produces a chart that can be used to evaluate whether a process is in a state of statistical control. The report varies depending on which type of chart you select. Control charts update dynamically as data is added or changed in the data table. Figure 3.7 displays the Control Chart Builder window for the Bottle Tops.jmp sample data table.

To create the chart:

1. Select Help > Sample Data Folder and open Quality Control/Bottle Tops.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Status to the Y zone.
4. Drag Sample to the Subgroup zone (at bottom).

You can drag other variables into the various zones to augment the analysis and use the “Control Chart Builder Options” to further examine the data. Some of the right-click chart options (for example, show or hide points, limits, warnings, and zones; select statistic and sigma options) also appear on the left hand side of the chart for easy access.

Control charts have the following characteristics:

- Each point plotted on the chart represents an individual process measurement or summary statistic. Subgroups should be chosen rationally, that is, they should be chosen to maximize the probability of seeing a true process signal between subgroups. Often, this
requires knowledge of the process to determine the most effective grouping strategy. See Wheeler (2004); Woodall and Adams (1998).

- The vertical axis of a control chart is scaled in the same units as the summary statistic.
- The horizontal axis of a control chart identifies the subgroup samples and is time ordered. Observing the process over time is important in assessing if the process is changing.

The green line is the center line, or the average of the data. The center line indicates the average (expected) value of the summary statistic when the process is in statistical control. Measurements should appear equally on both sides of the center line. If not, this is possible evidence that the process average is changing.

- The two red lines are the upper and lower control limits, labeled UCL and LCL. These limits give the range of variation to be expected in the summary statistic when the process is in statistical control. If the process is exhibiting only routine variation, then all the points should fall randomly in that range.

Note: To hide the lower control limits on dispersion, attribute, and rare event charts, deselect the Show Lower Limit option in the options panel. To change the default to always hide the lower control limits, deselect the Show Lower Control Limit preference in File > Preferences > Platforms > Control Chart Builder.

- A point outside the control limits signals the presence of a special cause of variation.

Options in the Control Chart Builder window create control charts that can be updated dynamically as samples are received and recorded or added to the data table. When a control chart signals abnormal variation, action should be taken to return the process to a state of statistical control if the process degraded. If the abnormal variation indicates an improvement in the process, the causes of the variation should be studied and implemented.

When you double-click the axes, the appropriate Axis Specification window appears for you to specify the format, axis values, number of ticks, gridline, reference lines, and other options to display.

Control Chart Builder Options

Control Chart Builder options appear in the red triangle menu or by right-clicking on a chart or axis. Some of the right-click chart options also appear on the bottom left hand side of the chart for easy access. You can also set preferences for many of the options in Control Chart Builder at File > Preferences > Platforms > Control Chart Builder.

- “Control Chart Builder Red Triangle Menu Options”
- “Options Panel and Right-Click Chart Options”
- “Control Chart Builder Right-Click Axis Options”
Control Chart Builder Red Triangle Menu Options

The Control Chart Builder red triangle menu contains the following options:

**Show Control Panel**  Shows or hides the following elements:

- buttons
- the Select Columns box
- the drop zone borders
- check boxes and drop-down menus

**Show Limit Summaries**  Shows or hides the Limit Summaries report. This report shows the control limits (LCL and UCL), the center line (Avg), the Points and Limits plotted, and the Sample Size for the chart. Sample size is not shown for rare event charts.

**Show Capability**  (Available only for Shewhart Variables charts that have specification limits.) Shows or hides the Process Capability Analysis report. Since the report is part of the Limit Summaries report, the Process Capability report appears only when the Show Limit Summaries option is selected. For more information, see “The Process Capability Report”. You can set preferences for many of the options in the Process Capability report in Control Chart Builder at File > Preferences > Platforms > Process Capability.

**Note:** Show Capability is not available if the response variable has no variation.

**Show Alarm Report**  Shows or hides a report that contains information about out of control samples. The report reflects failures for currently enabled tests in each chart and updates automatically as different tests are enabled and disabled and as data and row states change. A second table lists the currently enabled tests for each chart. The first table contains the following columns:

- **Position**  Indicates the numerical position of the chart, starting from the top of the report.
- **Total Samples Out of Control**  Counts the number of samples that failed at least one of the selected tests.
- **Alarm Rate**  The total number of samples out of control divided by the total number of nonmissing samples. This is also known as the Proportion Out of Control.

**Note:** The counts that contribute to the calculation of the alarm rate include excluded samples only if the Test Excluded Subgroups and the Show Excluded Region options are both selected.

**Show Limit Labels**  Shows or hides labels for the limits in each chart. The limits are shown inside the right frame of the chart.
Show Sigma Report  (Available only for Shewhart Variables charts.) Shows or hides the Process Sigma Report, which is a table of sigma values. The Process Sigma Report contains the overall sample size, number of subgroups, sample mean, overall sigma, within sigma, and stability index. For three way control charts, the between-sigma and between-and-within sigma values are also shown. If a phase variable is specified, a set of values is given for each phase.

Note: The Process Sigma Report appears only if the Limit Summaries report is turned on.

Show Excluded Region  Shows (on) or removes (off) the regions of the chart where samples have been excluded. When entirely excluded subgroups are shown on the location chart, they appear as dimmed points to indicate that they are excluded.

Caution: The Show Excluded Region option impacts the chart. Excluded samples are removed from the calculation of control limits, whether this option is on or off. Excluded samples are included in alarm rate calculations only if the Test Excluded Subgroups and the Show Excluded Region options are both selected.

Connect Thru Missing  Connects points, as well as the lines for averages and limits, when some samples have missing values or excluded rows.

Set Subgroup Size  (Not available if a subgroup variable is specified.) Sets a subgroup size. Missing values are taken into account when computing limits and sigma.

Note: If the Set Subgroup Size option is used, the Show Excluded Region option is turned on automatically.

Get Limits  Retrieves the control limits that are stored in an open or saved data table.

Save Limits  Saves the control limits in one of the following ways:

in Column  Saves the control limits that appear on the chart as a column property in the existing data table for the response variable. If the limits are constant, LCL, Avg, and UCL values for each chart type in the report are saved. This option is not available with phase charts. In addition, the option has no effect if the sample sizes are not constant for each chart.

in New Table  Saves the standard deviation and mean for each chart into a new data table. If the limits are constant, the LCL, Avg, UCL, Sample Size, and number of subgroups (N Subgroups) for each chart are saved as well. If there are phases, a new set of values is saved for each phase. There is a row for each statistic and a column for each Y variable. If there is a By variable, a table is created for each level of the By variable. Each table then contains a note that indicates the level that is associated with each table.
in New Tall Table  (Not available for Rare Event, Attribute, or Phase charts.) Saves the standard deviation, mean, and Sigma for each chart into a new data table. If the limits are constant, the LCL, Avg, UCL, Sample Size, and number of subgroups (N Subgroups) for each chart are saved as well. There is a row for each Y variable and a column for each statistic. A column for Sigma that can be used in the Process Screening platform is also saved. If there is a By variable, a table is created for each level of the By variable. Each table then contains a note that indicates the level that is associated with each table.

Save Summaries  Creates a new data table containing such information as the sample label, sample sizes, statistic being plotted, center line, control limits, and any tests, warnings and failures. The specific statistics included in the table depend on the type of chart.

Graph Spacing  Sets the amount of space between graph panels.

Graph Spacing Color  Sets the color of the space between the graph panels.

Graph Spacing Transparency  Sets the transparency level of the spacing between the graph panels. Must be between 0 and 1.

Graph Spacing Borders  Sets the presence of the internal graph panel borders.

Include Missing Categories  (Not available for attribute charts.) Enables the graph to collect rows with missing values in a categorical column, and displays the missing values on the graph as a separate category. If this option is disabled, all rows with a missing X value are removed from the calculations, in addition to being hidden from the graph.

This option is not available for continuous X variables or categorical Y variables because there is no compelling way to display the collected missing values on the relevant axes. By default, this option is enabled.

Note: If Include Missing Categories is enabled, capability analysis results in Control Chart Builder do not match those in the Process Capability platform if a categorical X variable has missing values.

Use Event Chooser  (Available only for attribute charts with numeric non-continuous Y variables.) Categorizes ordinal numeric data and offers individual numeric-level modeling selections.

Alarm Script  Enables you to write and run a script that indicates when the data fail special causes tests. See “Tests”. Results can be written to a file, written to the log or sent in an email. There is an option to include an explanation of why the test failed.

As an Alarm Script is invoked, the following variables are available, both in the issued script and in subsequent JSL scripts:

\[ \text{qc_col} \] is the name of the column
qc_test is the test that failed
qc_sample is the sample number
qc_phase is the label of the phase during which the failure occurred

See the Scripting Guide for more information about writing custom Alarm Scripts.

**Note:** Alarm scripts are not available in reports that use the Local Data Filter.

**Sort by Row Order**  Sorts all subgroup and phase variables in the order in which the levels appear in the data table. This applies to all combinations of nested subgroup and phase variables.

**K Sigma**  Sets the $K$ value to be multiplied by sigma to form the control limit about the average. By default, K Sigma is set to 3.

**Test Excluded Subgroups**  (Available only if the Show Excluded Region option is selected.) Includes (on) or excludes (off) entirely excluded subgroups in the computation of tests. When excluded subgroups are shown and the Text Excluded Subgroups option is not selected, the excluded subgroups are treated as missing values.

**Note:** For any test that relies on consecutive points (runs tests), an entirely excluded subgroup is treated as missing and counts of consecutive points are restarted.

**Control Chart Dialog**  (Available only if the control chart is launched through a Control Chart launch window.) Opens the Control Chart launch window with the original settings that were used to create the control chart.

**Fit to Window**  Specifies whether the graph is resized as you resize the JMP window. The default setting is Off, which prevents the graph from resizing. To always fit the graph inside the window, keep the setting at On. The Auto setting turns on stretching if there is only one report in the window and only one Y. Otherwise stretching is Off. There is also an option to maintain the aspect ratio.

See Using JMP for more information about the following options:

**Local Data Filter**  Shows or hides the local data filter that enables you to filter the data used in a specific report.

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Platform Preferences**  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.
Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

- Column Switcher is available only for a single Y variable having two or fewer associated charts. Based on the selected chart type, only columns that are appropriate for the Y role are included in the Column Switcher column list.
- In Control Chart Builder, the Automatic Recalc option is turned on by default and cannot be turned off.
- When using the local data filter, you can deselect the Show Excluded Region option for more focused exploration.

Options Panel and Right-Click Chart Options

In the Control Chart Builder report, the following options appear on the left hand side or when you right-click a chart. Some options appear in both locations.

Event Chooser  (Available only for attribute charts with response columns that have a modeling type of nominal or ordinal.) Allows the chart to respond in real time to selection changes. See “Event Chooser”.

Points  Provides the following options:

  Statistic  Changes the statistic plotted on the chart. See “Statistic”.

  Individual Points  Show or hides individual observations in a subgroup. Available only with a subgroup variable or Set Sample Size. This option is not available for Attribute chart types or Rare Event charts.

  Box Plots  (Available only for Shewhart Variables charts.) Shows or hides box plots on the chart.

  Show Connect Line  Shows connecting lines between the points.

  Show Points  Shows or hides the points on the chart.

Limits  Provides the following options:

  Sigma  Specifies the method of computing sigma. See “Sigma”.

  Zones  (Available only for Variables and Attribute chart types.) Shows or hides the zones on the chart. There are three equal-width zones on either side of the mean. Zones are not drawn below the LCL or above the UCL. If the limits for a Variables chart are not centered around the mean, \( \min(Avg-LCL, UCL-Avg)/3 \) is used as the width of each zone. The zones for an Attributes chart use a width of \( (UCL-Avg)/3 \).
Shade Zones  Shows or hides shading zones by ranges. Zone C is shaded green, zones A and B are shaded yellow, and beyond zone A is shaded red.

Spec Limits  (Available only if the data table has a Spec Limits column property or if you specify Spec Limits using the Add Spec Limits option.) Shows or hides the specification limits on the chart. By default, the spec limits are shown if the Spec Limits column property has the Show as Graph Reference Lines option selected. See Using JMP for information about adding a Spec Limits column property.

Add Spec Limits  (Available in the right-click menu.) Enables you to enter specification limits.

Set Control Limits  (Available in the right-click menu.) Enables you to enter control limits for tests. After you click OK in the Set Control Limits window, the specified control limits are set uniformly across groups. Select this option again to remove the specified control limits.

Note: If you set limits using the Set Control Limits option and then perform an action that changes the chart type, the previously set limits are removed and the limits are recalculated using the methods associated with the new chart type. A chart type change could be caused by adding or removing variables or by making changes to the point statistic or sigma statistic.

Add Limits  (Available in the right-click menu.) Specifies additional control limits to be plotted on the chart. These limits are not used in tests.

Show Upper Limit  Shows or hides the upper control limit on the chart. If you hide the upper control limit on a chart, the Test Beyond Limits and Test 1 options do not flag points associated with the hidden upper control limit.

Show Lower Limit  Shows or hides the lower control limit on the chart. If you hide the lower control limit on a chart, the Test Beyond Limits and Test 1 options do not flag points associated with the hidden lower control limit.

Show Center Line  Shows or hides the center line on the chart.

Add Dispersion Chart  (Available in the right-click menu.) Adds a dispersion chart to the chart area. Change the chart type with the Points options. A dispersion chart illustrates the variation in the data by plotting one of many forms of dispersion, including the range, standard deviation, or moving range. Available only for Variables chart types.

Note: You can customize the default dispersion chart type using the Dispersion Chart and Summarized Dispersion Chart preferences in File > Preferences > Platforms > Control Chart Builder.
**Set Subgroup Size**  (Available only if a subgroup variable is not already specified.) Sets a subgroup size. Missing values are taken into account when computing limits and sigma.

**Warnings** Provides the following options:

- **Customize Tests**  (Available in the right-click menu. Available only for Variables and Attribute chart types that are not Laney P’ or Laney U’ charts.) Enables you to design custom tests and select or deselect multiple tests at once. After the option is selected, the Customize Tests window appears for designing the tests. Select a test description, and enter the desired number (n) and label. You can save the settings to preferences and also restore the default settings.

- **Tests**  (Available only for Variables and Attribute chart types that are not Laney P’ or Laney U’ charts.) Enables you to select which statistical control tests to enable. For more information about tests, see “Tests”.

  **Note:** Hover over a flagged point on the chart to see a description of the test that failed.

- **Westgard Rules**  (Available only for Variables and Attribute chart types that are not Laney P’ or Laney U’ charts.) Specifies the set of Westgard statistical control tests that are enabled. Because Westgard rules are based on sigma and not the zones, they can be computed without regard to constant sample size. For more information about tests, see “Westgard Rules”.

- **Test Beyond Limits**  (Called Test 15 in JMP.) Enables the test for any points beyond the control limits. These points are identified on the chart. This test works on all charts with limits, regardless of the sample size being equal.

  **Note:** If you hide the upper or lower control limits, the Test Beyond Limits option does not flag points that are beyond limits that are not shown on the control chart.

- **Remove Graph**  (Available in the right-click menu.) Removes the control chart.

- **Remove Location Chart**  (Available only if you right-click a location chart.) Removes the location chart from the report.

- **Remove Dispersion Chart**  (Available only if you right-click a dispersion chart.) Removes the dispersion chart from the report.

  **Note:** For a description of the Rows, Graph, Customize, and Edit menus, see *Using JMP*.

- **Row Legend**  (Available only when there is one observation per marker.) Colors the rows according to a specified data column and inserts a legend next to the graph. This option is not available if there is a phase variable.
Three Way Control Chart  Enables you to produce a three way control chart for variable chart types. See “Three Way Control Chart”.

Switch to IMR Chart  Moves the subgroup variable to the Label role to create an Individual and Moving Range chart. This option is available if there is only one specified subgroup variable, the chart is summarized, and the chart has a Shewhart Variables chart type.

Caution: The Undo command is not available for this option.

Statistic

You can change the statistic represented by the points on the chart. The options available depend on the chart type selected.

For Variables chart types, you can change the statistic represented by the points on the chart using the following options:

Individual  Creates a chart where each point represents an individual value in the data table.

Average  Creates a chart where each point represents the average of the values in a subgroup.

Range  Creates a chart where each point represents the range of the values in a subgroup.

Standard Deviation  Creates a chart where each point represents the standard deviation of the values in a subgroup.

Moving Range on Means  Computes the difference in the range between two consecutive subgroup means.

Moving Range on Std Dev  Computes the difference in the range between two consecutive subgroup standard deviations.

Moving Range  Creates a chart where each point is the difference between two consecutive observations.

Note: The Average, Range, Standard Deviation, Moving Range on Means, and Moving Range on Std Dev methods appear only if a subgroup variable with a sample size greater than one is specified or a sample size is set.

For Attribute chart types, you can change the statistic represented by the points on the chart using the following options:

Proportion  Creates a chart where each point represents the proportion of items in subgroup samples.
**Control Chart Builder Options**

**Quality and Process Methods**

**Count**  Creates a chart where each point represents the number of items in subgroup samples.

For Rare Event chart types, the statistic represented by the points on the chart uses the Count option.

**Sigma**

You can change the method for computing sigma for the chart. The options available depend on the chart type selected.

For Variables chart types, you can use the following options:

- **Range** Estimates sigma using the range of the data in a subgroup.
- **Standard Deviation** Estimates sigma using the standard deviation of the data in a subgroup.
- **Moving Range** Estimates sigma using the moving ranges. The moving range is the difference between two consecutive points.
- **Median Moving Range** Estimates sigma using the median moving range, rather than the average moving range.
- **Levey-Jennings** Estimates sigma using the standard deviation of all the observations. If your chart has phases, sigma is calculated for each phase separately.

For Attribute chart types, you can use the following options:

- **Binomial (P, NP)** Estimates sigma using the binomial distribution model. The model indicates the number of successes in a sequence of experiments, where each experiment yields success with some probability. Selecting Binomial yields either a P or NP chart.
- **Poisson (C, U)** Estimates sigma using the Poisson distribution model. The model indicates the number of events and the time at which these events occur in a given time interval. Selecting Poisson yields either a C or U chart.
- **Laney (P’)** Estimates sigma using the binomial distribution model, adjusted by a moving range sigma value.
- **Laney (U’)** Estimates sigma using the Poisson distribution model, adjusted by a moving range sigma value.

For Rare Event chart types, you can use the following options:

- **Negative Binomial** Uses the negative binomial distribution model to estimate sigma. The model indicates the number of successes in a sequence of trials before a specified number of failures occur. Selecting Negative Binomial yields a G chart.
- **Weibull** Uses the Weibull distribution model to estimate sigma. The model indicates the mean time between failures. Selecting Weibull yields a T chart.
Tests

The Warnings option in the pop-up menu or on the left hand side of the window displays a submenu for Tests selection. You can select one or more tests for special causes (Western Electric rules) from the menu. Nelson (1984) developed the numbering notation used to identify special tests on control charts. The tests work with both equal and unequal sample sizes.

If a selected test is positive for a particular sample, that point is labeled with the test number. When you select several tests for display and more than one test signals at a particular point, the label of the numerically lowest test specified appears beside the point. You can hover over a flagged point on the chart to see a description of the test that failed.

**Tip:** To add or remove several tests at once, select or deselect the tests in the Control Panel under **Warnings > Tests**.

Table 3.8 lists and interprets the eight tests, and Figure 3.9 illustrates the tests. The following rules apply to each test:

- The area between the upper and lower limits is divided into six zones, each with a width of one standard deviation.
- The zones are labeled A, B, C, C, B, A with zones C nearest the center line.
- A point lies in Zone B or beyond if it lies beyond the line separating zones C and B. That is, if it is more than one standard deviation from the center line.
- Any point lying on a line separating two zones lines is considered belonging to the innermost zone. So, if a point lies on the line between Zone A and Zone B, the point is considered to be in Zone B.
- When a Phase variable is specified, the counts for each test are reset at the start of each phase.

**Notes:**

- Tests 1 through 8 apply to all Shewhart Variables chart types.
- Tests 1, 2, 5, and 6 apply to the upper and lower halves of the chart separately.
- Tests 3, 4, 7, and 8 apply to the whole chart.
- Once a runs test (one that is based on consecutive observations) is triggered, the counts do not reset to 0 when moving to the next sample.
- Runs tests handle excluded rows based on the setting of the Show Excluded Region and Test Excluded Subgroups options.
  - By default, both options are selected, and the excluded rows are included in the runs tests calculations.
– If the Show Excluded Region option is selected and the Test Excluded Subgroups option is not selected, the excluded rows are treated as missing and the counts for the runs tests reset to 0 when moving to the next sample.
– If the Show Excluded Region option is not selected, the excluded rows are treated as if they are deleted.

- Tests 5 through 8 are not available for attribute charts.

See Nelson (1984, 1985) for further recommendations on how to use these tests.

**Figure 3.8 Zones for Western Electric Rules**

![Zones for Western Electric Rules](image)

**Table 3.8 Description and Interpretation of Tests for Special Causes$^a$**

<table>
<thead>
<tr>
<th>Test 1</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>One point beyond Zone A (upper or lower)</td>
<td>Detects a shift in the mean, an increase in the standard deviation, or a single aberration in the process. For interpreting Test 1, any dispersion chart (R, S, or MR) can be used to rule out increases in variation. Note that if you hide the upper or lower control limits, the Test 1 option does not flag points that are associated with limits that are not shown on the control chart.</td>
</tr>
</tbody>
</table>
### Table 3.8 Description and Interpretation of Tests for Special Causes

<table>
<thead>
<tr>
<th>Test</th>
<th>Description</th>
<th>Interpretation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Test 2</strong></td>
<td>Nine points in a row in a single (upper or lower) side of Zone C or beyond</td>
<td>Detects a shift in the process mean.</td>
</tr>
<tr>
<td><strong>Test 3</strong></td>
<td>Six points in a row steadily increasing or decreasing (anywhere on the chart)</td>
<td>Detects a trend or drift in the process mean.</td>
</tr>
<tr>
<td><strong>Test 4</strong></td>
<td>Fourteen points in a row alternating up and down (anywhere on the chart)</td>
<td>Detects systematic effects such as two alternately used machines, vendors, or operators.</td>
</tr>
<tr>
<td><strong>Test 5</strong></td>
<td>Two out of three points in a row in or beyond Zone A and the point itself is in or beyond Zone A; the two points must be on the same side (upper or lower)</td>
<td>Detects a shift in the process average or increase in the standard deviation. Any two out of three points provide a positive test.</td>
</tr>
<tr>
<td><strong>Test 6</strong></td>
<td>Four out of five points in a row in or beyond Zone B and the point itself is in or beyond Zone B; the four points must be on the same side (upper or lower)</td>
<td>Detects a shift in the process mean. Any four out of five points provide a positive test.</td>
</tr>
<tr>
<td><strong>Test 7</strong></td>
<td>Fifteen points in a row in Zone C, above and below the center line</td>
<td>Detects stratification of subgroups when the observations in a single subgroup come from various sources with different means. Also detects a reduction in variation.</td>
</tr>
<tr>
<td><strong>Test 8</strong></td>
<td>Eight points in a row on both sides of the center line with none in Zones C</td>
<td>Detects stratification of subgroups when the observations in one subgroup come from a single source, but subgroups come from different sources with different means.</td>
</tr>
</tbody>
</table>

---

Figure 3.9 Illustration of Special Causes Tests

Test 1: One point beyond Zone A

Test 2: Nine points in a row in a single (upper or lower) side of Zone C or beyond

Test 3: Six points in a row steadily increasing or decreasing

Test 4: Fourteen points in a row alternating up and down

Test 5: Two out of three points in a row in Zone A or beyond

Test 6: Four out of five points in a row in Zone B or beyond

Test 7: Fifteen points in a row in Zone C (above and below the center line)

Test 8: Eight points in a row on both sides of the center line with none in Zone C

Westgard Rules

Westgard rules are implemented under the Westgard Rules submenu of the Warnings option when you right-click a chart or on the left hand side of the window. The different tests are abbreviated with the decision rule for the particular test. For example, 1 2s refers to a test where one point is two standard deviations away from the mean.

Notes:

- Once a runs test (one that is based on consecutive observations) is triggered, the counts do not reset to 0 when moving to the next sample.
- Runs tests handle excluded rows based on the setting of the Show Excluded Region and Test Excluded Subgroups options.
  - By default, both options are selected, and the excluded rows are included in the runs tests calculations.
  - If the Show Excluded Region option is selected and the Test Excluded Subgroups option is not selected, the excluded rows are treated as missing and the counts for the runs tests reset to 0 when moving to the next sample.
  - If the Show Excluded Region option is not selected, the excluded rows are treated as if they are deleted.

Rule 1 2S (called Test 9 in JMP) is commonly used with Levey-Jennings charts, where control limits are set 2 standard deviations away from the mean. The rule is triggered when any one point goes beyond these limits.

Rule 1 3S (called Test 10 in JMP) refers to a rule common to Levey-Jennings charts where the control limits are set 3 standard deviations away from the mean. The rule is triggered when any one point goes beyond these limits.

Rule 2 2S (called Test 11 in JMP) is triggered when two consecutive control measurements are farther than two standard deviations from the mean.
Rule R 4S (called Test 12 in JMP) is triggered when one measurement is greater than two standard deviations from the mean and the previous measurement is greater than two standard deviations from the mean in the opposite direction such that the difference is greater than 4 standard deviations.

Rule 4 1S (called Test 13 in JMP) is triggered when four consecutive measurements are more than one standard deviation from the mean.

Rule 10 X (called Test 14 in JMP) is triggered when ten consecutive points are on one side of the mean.

**Control Chart Builder Right-Click Axis Options**

The following options are available when you right-click the vertical axis of a control chart.

**Remove Graph**  Removes the entire graph.

**Remove**  Removes a variable.

**Note:** If there is more than one chart type on the graph, a submenu listing the different charts is displayed. You can select which chart to remove.

For more information about the Axis Settings, Revert Axis, Add or Remove Axis Label, Save to Column Property, and Edit options, see *Using JMP*. 
Control Limits in Control Chart Builder

Control limits are based on the performance of your process and tell you about the variability in your process. Upper control limits (UCLs), center lines, and lower control limits (LCLs) are calculated from the data when a control chart is created. You can use these calculated control limits to indicate when your process has changed.

It is important to note that control limits are different from specification limits, which are often used in capability analysis.

Table 3.9  Control Limits versus Specification Limits

<table>
<thead>
<tr>
<th>Control Limits</th>
<th>Specification Limits</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculated from data</td>
<td>Defined by the customer or design</td>
</tr>
<tr>
<td>Based on variability</td>
<td>Based on system requirements</td>
</tr>
<tr>
<td>The voice of the process</td>
<td>The voice of the customer</td>
</tr>
</tbody>
</table>

Excluded and Hidden Samples in Control Chart Builder

The following points summarize the use of excluded and hidden samples in Control Chart Builder:

- Excluded subgroups are not used in the calculations of control limits, and appear on the chart as dimmed points by default. If the Show Excluded Region option is not selected, the points for the excluded subgroups do not appear in the chart, are treated as missing in Tests for Special Causes, and are not included in the count of points for Tests for Special Causes.

- Hidden observations are used in the calculations of control limits, but do not appear in the chart.

- Rows that are both hidden and excluded are included in the count of points for Tests for Special Causes when the Test Excluded Subgroups option is selected. An excluded row can be labeled with a special cause flag. A hidden point cannot be labeled. If the flag for a Tests for Special Causes test is on a hidden point, it will not appear in the chart.

- For partially excluded subgroups, if one or more observations within a subgroup is excluded, and at least one observation within the subgroup is included, the excluded observation is not included in the calculations of either the point statistic or the limits.
• Checks for negative and non-integer data happen on the entire data (even excluded values).
• Tests apply to all excluded subgroups only when the Test Excluded Subgroups option is selected.

Additional Examples of Control Chart Builder

This section contains examples using Control Chart Builder.

Note: In this section, some examples show the Control Panel while others do not. To show or hide the Control Panel, select Show Control Panel from the Control Chart Builder red triangle menu.

• “Example of Control Limits”
• “Example of Individual Measurement and Moving Range Charts”
• “Example of an XBar and R Chart”
• “Example of XBar and R Charts with Varying Subgroup Sizes”
• “Example of a Run Chart”
• “Example of a P Chart”
• “Example of a Laney P’ Chart”
• “Example of an NP Chart”
• “Example of a C Chart”
• “Example of a U Chart”
• “Example of a G Chart”
• “Example of a T Chart”
• “Example of a Three Way Control Chart”
• “Example of Multiple Control Charts”

Example of Control Limits

This example uses Control Chart Builder in three stages. In most cases, you would start with “Create the Baseline Control Chart”, where you let JMP calculate the control limits for you. Then, to apply these control limits to new data, you would either “Specify Control Limits” or “Specify Multiple Sets of Control Limits” (for phase data).
In this example, consider a company’s printing process. Variations can cause distortion in the line, including skew, thickness, and length problems. In this example, we will consider the length of the line. A line is considered good if it has a printed length of 16 cm +/- 0.2 cm. Any longer and the sentence might run off of the page. Any shorter and there would be a lot of wasted space on the page. For every print run, the first and last books are taken for measurement. The line lengths are measured on a specified page in the middle of each book.

You want to know: Is this process in control (stable)? Are we getting consistent print quality? What happens when we make improvements to the printing process? Does quality improve? To answer these questions, we need to create control charts and use control limits.

Create the Baseline Control Chart

First, examine whether the existing process is in control. If it is, we can use the control limits created by JMP as our baseline or historical limits.

1. Select Help > Sample Data Folder and open Quality Control/Line Length.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Length to the Y zone.

   An Individual and Moving Range chart of Length appears. This chart is appropriate if you have no natural subgrouping in your data. However, in this example, there is a natural subgrouping, which is each print run.

4. Drag Run to the Subgroup zone (at bottom).

Figure 3.10 XBar and R Chart of Line Length by Print Run
Three lines are drawn horizontally across the XBar and R charts. These are the calculated LCL (lower control limit), Avg (average) and UCL (upper control limit).

Ideally, we would like for all of our points to fall within the control limits, and we would like for the points to fall randomly within these limits. Looking at the graph, we see that no points fall outside of the control limits, and there does not appear to be a pattern to the points. To investigate further, perform Western Electric tests to check for patterns and trends that would cause these tests to fail. (The Western Electric tests are also referred to as Nelson tests.)

5. In the XBar chart, right-click and select **Warnings > Tests > All Tests**.

Notice that no points were circled or flagged. This means that our process is in control or stable.

If we had determined that our process was not in control, we would investigate out of control points or work to alter our process so that it is in control. For this example, since the process is already in control or stable, we can skip that step. Now, you can use these control limits with new data. Proceed to “Specify Control Limits”, or “Specify Multiple Sets of Control Limits” (to see an example with phase data).

**Specify Control Limits**

Since we established that the process is in control, we can use these historical limits with new data to see how the new data compares to the existing process. To use historical limits, we need to specify control limits instead of having JMP calculate them.

There are several ways to specify control limits in JMP:

- “Set Control Limits Option”
- “Add a Column Property”
- “Use the Get Limits Option”
- “Exclude Rows”

**Set Control Limits Option**

One simple way to specify control limits is to use the Set Control Limits option in Control Chart Builder.

1. Select **Help > Sample Data Folder** and open Quality Control/New Length Data.jmp.
   This is the table that contains your new data.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag Length to the Y zone.
4. Drag Run to the **Subgroup** zone (at bottom).
5. Right-click in the Average (XBar) chart and select **Limits > Set Control Limits**.
6. Enter these limits:
   - LCL - 15.90519
   - Avg - 15.99825
   - UCL - 16.09131
   These are the historical limits from the Average (XBar) chart in Figure 3.10.

7. Click **OK**.

8. Right-click in the Range (R) chart and select **Limits > Set Control Limits**.

9. Enter these limits:
   - LCL - 0
   - Avg - 0.0495
   - UCL - 0.161693
   These are the historical limits from the Range (R) chart in Figure 3.10.

10. Click **OK**.

**Figure 3.11** XBar and R Chart of Line Length with Historical Limits

Rather than calculating limits from the data, JMP used the historical control limits that you defined. In the Length Limit Summaries table, notice that the Limits Sigma now says User Defined. Many points now fall outside of the limits. Also, the averages are higher than those of the baseline process. This process appears different from the original process that we used to calculate the baseline control limits.
Add a Column Property

Another way to specify control limits is to add the Control Limits column property to a column in your new data table.

1. Select Help > Sample Data Folder and open Quality Control/New Length Data.jmp.
   This is the table that contains your new data.
2. Select the Length column and click Cols > Column Info.
3. Click Column Properties > Control Limits.
4. XBar is selected, so enter these fixed limits for the Average (XBar) chart:
   - Avg - 15.99825
   - LCL - 15.90519
   - UCL - 16.09131
   These are the historical limits from the Average (XBar) chart in Figure 3.10.
   Leave the value for Subgroup Size as missing. This value is not used in the Control Chart Builder platform.
5. Click XBar > R. Enter these fixed limits for the Range (R) chart:
   - Avg - 0.0495
   - LCL - 0
   - UCL - 0.161693
   These are the historical limits from the Range (R) chart in Figure 3.10.
   Leave the value for Subgroup Size as missing. This value is not used in the Control Chart Builder platform.
6. Click OK.
   You have entered control limits for XBar and R charts for the Length column. Now you can create a control chart.
7. Select Analyze > Quality and Process > Control Chart Builder.
8. Drag Length to the Y zone.
9. Drag Run to the Subgroup zone (at bottom).
The control chart is identical to Figure 3.11.

Use the Get Limits Option

The Get Limits method of specifying control limits is the most flexible. You should use this method in the following cases:

- If you have control limits for many different processes
• If you have different control limits for each phase (see “Specify Multiple Sets of Control Limits”)

To use the Get Limits method, you need a data table that defines your historical limits. For more information about how to create a limits table, see “Saving and Retrieving Limits”.

**Note:** When no subgroup variable is specified, the Get Limits option uses the subgroup size (_Sample Size) from the limits table. Also, when the limits are missing in the file, JMP also looks for the sigma (_Std Dev). When no LCL or UCL are specified in the limits file (if both the average and sigma are found, and the subgroup size is constant), the option sets the limits based on the average, subgroup size, and sigma.

In this example, a limits data table has already been created.

1. Select **Help > Sample Data Folder** and open Quality Control/New Length Data.jmp.
   This is the table that contains your new data.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag **Length** to the **Y** zone.
4. Drag **Run** to the **Subgroup** zone (at bottom).
5. Click the Control Chart Builder red triangle and select **Get Limits**.
6. Select **Other** and click **OK**.
7. Navigate and open the limits data table for this example, called Length Limits.jmp. By default, the file is located here:
   - On Windows: C:\Program Files\SAS\JMP\17\Samples\Data\Quality Control
   - On macOS: \Library\Application Support\JMP\17\Samples\Data\Quality Control

The control chart is identical to **Figure 3.11**.

**Exclude Rows**

Another way to specify control limits is to exclude rows in a data table. One advantage to this method is that you can see both the historical data and new data in the same graph. This can help to visualize and investigate differences when they occur between the data collection periods.

To use this method, you must meet the following criteria:

• New and old data must reside in the same data table.
• Historical data and new data must all have equal subgroup sizes.
• All new data must be excluded in the data table (using Rows > Exclude/Unexclude).

In this example, new data have already been excluded.

1. Select **Help > Sample Data Folder** and open Quality Control/Combined.jmp.
This table contains old and new data, and the rows corresponding to the new data are excluded.

2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag **Length** to the **Y** zone.
4. Drag **Run** to the **Subgroup** zone (at bottom).
5. In the **XBar** chart, right-click and select **Warnings > Tests > All Tests**.

**Figure 3.12** XBar and R Chart of Line Length with Excluded Data

JMP uses only the unexcluded rows (historical data) to create the control limits. The new data (excluded data) are plotted on the graph (dimmed), but these data were not used in any of the calculations. However, when you turn on the tests, all of the data is tested. The new data has many points that fall outside of the control limits and are flagged as failing Test 1 (point is more than 3σ from the average).

**Specify Multiple Sets of Control Limits**

In this example, you want to set different control limits for different phases of a process. The column property, set control limits, and excluded row state methods will not work in this situation because these methods are limited to only one set of control limits for the entire chart. For a control chart with phases, you need to use the get limits method.
In the printing company, the goal is to reduce the variability of the force needed to break the bond between paper and the book spine for three different sites. Each site has different machines, different operators, and is also located in different countries; therefore, each site has a unique set of historical limits. For all three sites, the company does the following:

1. Creates a baseline control chart based on the existing process data.
2. Changes the process, based on a designed experiment.
3. Gathers data from the new process.
4. Creates a new control chart based on the new process data.

The goal is to plot the new data on a control chart using historical limits from the old process. In this way, the printing company can compare the new process to the old process limits.

**Create a Control Chart Based on Existing Process**

1. Select **Help > Sample Data Folder** and open Quality Control/Phase Historical Data.jmp. This table contains the existing process data for all three sites.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag **Force** to the **Y** zone.
4. Drag **Run** to the **Subgroup** zone (at bottom).
5. Drag **Site** to the **Phase** zone.

**Figure 3.13  Baseline Control Chart for Existing Data**
Create a Control Chart Based on Updated Process

1. From the report in Figure 3.13, click the Control Chart Builder red triangle and select **Save Limits > in New Table**.
   
   This creates a limits table.
2. Save this new limits table to any location, so you can access it later.
3. Select **Help > Sample Data Folder** and open Quality Control/Phase New Data.jmp.
   
   This data was collected from all three sites after the change was made to the process.
4. Select **Analyze > Quality and Process > Control Chart Builder**.
5. Drag Force to the Y zone.
6. Drag Run to the Subgroup zone (at bottom).
7. Drag Site to the Phase zone.
8. Click the Control Chart Builder red triangle and select **Get Limits**. Open the limits table that you saved in step 2.
   
   This applies the historical limits to the new data in the Control Chart Builder report.

**Figure 3.14** Control Chart for New Data Based on Historical Limits

Now you can see how the new data (after the process change) compare with the historical process limits (before the process change). None of the points fall outside of the control limits for either the location or dispersion chart. The goal was to reduce variability. Looking at the moving range chart, you can see that most points fall below the average line. For sites 1 and 2, it is clear that the variability of force needed to break the bond between pages and the book spine has been decreased. The decrease at Site 3 is not as strong as at sites 1 and 2. The improvements to the printing process appear to have succeeded in reducing the variability.
Example of Individual Measurement and Moving Range Charts

In this example, you use the interactive workspace in Control Chart Builder to create control charts on the acidity levels of pickles. The acidity in four vats is measured each day at 1, 2, and 3 PM. The data table records day, time, and acidity measurements.

1. Select Help > Sample Data Folder and open Quality Control/Pickles.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Acid to the Y role.
4. Click the Control Chart Builder red triangle and select Show Limit Labels.
   This option labels the control limits and averages in both charts.

Figure 3.15 Individual Measurement and Moving Range Charts for Acid

The individual measurement and moving range charts monitor the acidity in each vat produced (subgroup of size 1). Vat 13 has an acidity above the upper control limit of 14.05.

You can also view a Median Moving Range chart. Continue with the following steps to change the charts to use median moving ranges.

5. In the Limits[1] outline, change the Sigma setting to Median Moving Range.
The limits in the individual measurement and median moving range charts use the median moving range as the sigma, rather than the average moving range. This results in slightly narrower control limits for Acid.

**Example of an XBar and R Chart**

In this example, you use the interactive workspace in Control Chart Builder to create an XBar and R Chart with a phase variable. Data on the diameter of medical tubing for a new prototype were collected over 40 days. After the first 20 days (phase 1), some adjustments were made to the manufacturing equipment. Analyze the data to determine whether the past 20 days (phase 2) of production are in a state of control.

1. Select Help > Sample Data Folder and open Quality Control/Diameter.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag DIAMETER to the Y role.
4. Drag DAY to the Subgroup role (at bottom).
The first 20 days appear to have high variability, and in the Average chart, there are three observations that are outside of the control limits. An adjustment was made to the manufacturing equipment and new control limits were incorporated.

To compute separate control limits for each phase:

5. Drag Phase to the **Phase** role.

6. In the Average chart, right-click and select **Warnings > Test Beyond Limits**.

7. In the Limits[1] outline, select **Shade Zones**.
Including the Phase variable means that the control limits for phase 2 are based only on the data for phase 2. None of the phase 2 observations are outside the control limits. This is highlighted by including the zone shading on the chart. Therefore, you can conclude that the process is in control after the adjustments were made.

**Filter the Control Chart by Another Variable**

This data table, Diameter.jmp, contains a column for the operator of the machine for each sample. You can use the Local Data Filter with Control Chart Builder to show the data for a subset of operators.

8. Click the **Control Chart Builder** red triangle and deselect **Show Excluded Region**.

   Turning off the Show Excluded Region option indicates that the subgroups that are excluded by settings in the Local Data Filter no longer appear on the horizontal axis of the control chart as you make selections in the Local Data Filter. As a result, you see only the portion of the data that are of interest.

9. Click the **Control Chart Builder** red triangle and select **Local Data Filter**.

10. In the Local Data Filter, click on OPERATOR and click the + button.

11. In the Local Data Filter, select the bar labeled RMM.
Figure 3.19 XBar and R Chart of Diameter for Operator RMM

The XBar and R charts now show only the points for the RMM operator, as denoted by the Where() statement below the charts. The limits for both phases have been adjusted to reflect that the observations for the other three operators have been excluded.

Example of XBar and R Charts with Varying Subgroup Sizes

In this example, you use the interactive workspace in Control Chart Builder to create XBar and R charts using data that have varying subgroup sizes.

1. Select Help > Sample Data Folder and open Quality Control/Coating.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Weight 2 to the Y role.
4. Drag Sample to the Subgroup role (at bottom).
Weight 2 has several missing values in the data, so the chart has uneven limits. Although each sample has the same number of observations, samples 1, 3, 5, and 7 each have a missing value.

Instead of viewing a line connecting the averages of each sample, you can switch to viewing box plots at each sample.

5. In the Points[1] outline, deselect the Show Connect Line option.
6. In the Points[1] outline, select the Box Plots option.
Example of a Run Chart

In this example, you use the Run Chart launch window to launch Control Chart Builder. Run charts display a column of data as a connected series of points.

1. Select **Help > Sample Data Folder** and open Stock Averages.jmp.
2. Select **Analyze > Quality and Process > Control Chart > Run Chart**.
3. Select Close and click **Y**.
4. Click **OK**.
Example of a P Chart

In this example, you use the P Control Chart launch window to launch Control Chart Builder. You want to create a P chart to analyze defect data on galvanized washers for two different lot sizes. The washers were inspected for finish defects such as rough galvanization and exposed steel. If a washer contained a finish defect, it was deemed nonconforming or defective. Thus, the defect count represents how many washers were defective for each lot of size 400.

1. Select Help > Sample Data Folder and open Quality Control/Washers.jmp.
2. Select Analyze > Quality and Process > Control Chart > P Control Chart.
3. Select # defective and click Y, n Defective.
4. Select Lot Size and click n Trials.
5. Click OK.
6. Right-click the graph and select Limits > Show Lower Limit to deselect the Show Lower Limit option.

This hides the lower limit, which is not of interest in this situation.
To view the differences between constant and variable sample sizes, you can compare charts for Lot Size and Lot Size 2 by simply dragging the variables to the nTrials zone.

**Example of a Laney P’ Chart**

In this example, you compare a P control chart and a Laney P’ control chart using the Control Chart Builder. Laney P’ charts are useful when the variance in the data is greater than the variance that is assumed by the binomial distribution. The data are counts in milliliters of plastics measured from samples of ocean water that were taken over the course of 10 weeks in 3 different locations.

**Create a Standard P Chart**

1. Select **Help > Sample Data Folder** and open **Quality Control/Water Plastics.jmp**.
2. Select **Analyze > Quality and Process > Control Chart > P Control Chart**.
3. Select Total Plastic and click **Y, n Defective**.
4. Select Week and click **Subgroup**.
5. Select Total Volume and click **n Trials**.
6. Select Location and click **Phase**.
7. Click OK.

**Figure 3.24 Standard P Chart for Water Plastics**

There are several points on the standard P chart that are labeled as out of control. Due to how control limits are calculated in the standard P chart, there is a strong possibility that the out of control points are actually false alarms. Compare these results to the results from the Laney $P'$ chart.

**Create Laney $P'$ Chart**

8. Select **Analyze > Quality and Process > Control Chart > Laney $P'$ Control Chart**.
9. Select Total Plastic and click **Y, n Defective**.
10. Select Week and click **Subgroup**.
11. Select Total Volume and click **n Trials**.
12. Select Location and click **Phase**.
13. Click **OK**.
Unlike the standard P chart, the Laney P’ chart displays all of the points as in control for this data set.

**Example of an NP Chart**

In this example, you use the interactive workspace in Control Chart Builder to create an NP chart with a phase variable. The two phases represent the time before and after an adjustment to the process. The data are simulated from a bottle top manufacturing process.

1. Select **Help > Sample Data Folder** and open Quality Control/Bottle Tops.jmp.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag **Sample** to the **Subgroup** role.
   This variable is the sample ID for each bottle.
4. Drag **Status** to the **Y** role.
   This variable indicates whether the bottle top conformed to the design standards.
The original observations appear to have high variability and there are five observations (Samples 13, 15, 21, 22 and 23) that are outside of the upper control limit. Samples 15 and 23 note that new material and a new operator were introduced into the process, respectively. At the end of the phase, an adjustment was made to the manufacturing equipment. Therefore, the control limits for the entire series should not be used to assess the control during phase 2.

To compute separate control limits for each phase:

5. Drag Phase to the Phase zone.
Including the Phase variable means that the control limits for phase 2 are based only on the data for phase 2. None of the phase 2 observations are outside the control limits. Therefore, you can conclude that the process is in control after the adjustment.

**Example of a C Chart**

In this example, you use the C Control Chart launch window to launch Control Chart Builder. You want to explore data concerning the various defects discovered while manufacturing cabinets over two time periods.

1. Select **Help > Sample Data Folder** and open Quality Control/Cabinet Defects.jmp.
2. Select **Analyze > Quality and Process > Control Chart > C Control Chart**.
3. Select **Type of Defect** and click **Y, n Defects**.
4. Select **Lot Number** and click **Subgroup**.
5. Select **Date** and click **Phase**.
6. Click **OK**.
You can now view the results on the two different days. Both appear to be within limits. You can also examine other defect type behavior using the Event Chooser.

7. Click the Control Chart Builder red triangle and select **Show Control Panel**.

8. Under Event Chooser, click the gray triangle next to Type of Defect.

   The control chart is showing events that correspond to the Bruised veneer defect type.

9. Under Event Chooser > Type of Defect, click the box next to Bruised veneer.

10. Under Event Chooser > Type of Defect, click the box next to Defective Sanding.
Figure 3.29 C Chart of Defective Sanding Defect Type

This chart shows that all of the events corresponding to the Defective sanding defect type occurred on the first day, 01Jan1956.

Example of a U Chart

In this example, you use the U Control Chart launch window to launch Control Chart Builder. You want to create a U chart to monitor the number of defects per subgroup sample size. The data are defect counts in boxes of automobile support braces. A box of braces constitutes one inspection unit. The number of boxes inspected (per day) is the subgroup sample size, which can vary.

1. Select Help > Sample Data Folder and open Quality Control/Braces.jmp.
2. Select Analyze > Quality and Process > Control Chart > U Control Chart.
3. Select # defects and click Y, n Defects.
4. Select Unit size and click n Trials.
5. Click OK.
Because the sample sizes are not equal across subgroups, the limits are uneven. Two of the last five samples are not within the control limits.

**Example of a G Chart**

In this example, you use the interactive workspace in Control Chart Builder to create a G chart to monitor data about adverse drug events (ADEs) reported by a group of hospital patients. An ADE is any type of injury or reaction the patient suffered after taking the drug. The date of the reaction and the number of days since the last reaction were recorded.

A G chart is an effective way to understand whether rare events are occurring more frequently than expected and warrant an intervention. See “Rare Event Control Charts”.

1. Select Help > Sample Data Folder and open Quality Control/Adverse Reactions.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Doses since Last ADE to the Y role.
4. Drag Date of ADE to the Subgroup role.
   
   An Individual & Moving Range chart of Doses since Last ADE appears.
5. In the drop-down list, select Rare Event instead of Shewhart Variables.
A G chart of Doses since Last ADE appears, showing that the number of doses given since the last event.

**Figure 3.31** G chart of Doses since Last ADE

---

**Example of a T Chart**

In this example, you use the interactive workspace in Control Chart Builder to create a T chart to explore data from a fan manufacturing process. The first column identifies each fan that burned out. The second column identifies the number of hours between each burnout.

T charts are used to measure the time that has elapsed since the last event. See “Rare Event Control Charts”.

1. Select **Help > Sample Data Folder** and open Quality Control/Fan Burnout.jmp.
2. Select **Analyze > Quality and Process > Control Chart Builder**.
3. Drag **Hours between Burnouts** to the **Y** role.
4. Drag **Burnout** to the **Subgroup** role.
Figure 3.32 Individual and Moving Range Chart of Hours Between Burnouts

5. In the drop-down list, select Rare Event instead of Shewhart Variables.
6. Under Limits, change the Sigma from Negative Binomial to Weibull.
In the T chart, all points appear to be within the control limits. It is clear that the Individual & Moving Range chart was inappropriate for the analysis, as the limits were too narrow.

Example of a Three Way Control Chart

In this example, you use the Three Way Control Chart launch window to launch Control Chart Builder. Three way control charts are useful when there is variation between batches and variation within batches.

1. Select Help > Sample Data Folder and open Quality Control/Vial Fill Weights.jmp.
3. Select Fill Weight and click Y.
4. Select Sample and click Subgroup.
5. Click OK.
Figure 3.34 Three Way Control Chart for Fill Weight

Three Way Control Chart of Individual on Means, Moving Range on Means & R chart of Fill Weight

<table>
<thead>
<tr>
<th>Points plotted</th>
<th>LCL</th>
<th>Avg</th>
<th>UCL</th>
<th>Limits Sigma</th>
<th>Subgroup Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average</td>
<td>5.055722</td>
<td>6.114611</td>
<td>6.333501</td>
<td>Moving Range</td>
<td>6</td>
</tr>
<tr>
<td>Moving Range on Means</td>
<td>0.044710</td>
<td>0.140071</td>
<td>Moving Range</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>Range</td>
<td>0.1792</td>
<td>0.280494</td>
<td>Range</td>
<td>6</td>
<td></td>
</tr>
</tbody>
</table>

### Process Capability Analysis

#### Histogram

Fill Weight Limit Summaries

<table>
<thead>
<tr>
<th>LSL</th>
<th>Target</th>
<th>USL</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.8</td>
<td>6.1</td>
<td>6.4</td>
</tr>
</tbody>
</table>

### Process Summary

- **LCL**: 5.8
- **Target**: 6.1
- **USL**: 6.4
- **N Subgroups**: 60
- **Sample Mean**: 6.114611
- **Between Sigma**: 0.033745
- **Within Sigma**: 0.040099
- **Between-and-Within Sigma**: 0.061069
- **Overall Sigma**: 0.069929
- **Stability Index**: 1.145077

Within sigma estimated by average of ranges.
Between sigma estimated by average moving range of subgroup means.

### Between-and-Within Sigma Capability

<table>
<thead>
<tr>
<th>Index</th>
<th>Estimate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cpk</td>
<td>1.7717</td>
</tr>
<tr>
<td>Cpl</td>
<td>1.558</td>
</tr>
<tr>
<td>Cpu</td>
<td>1.637</td>
</tr>
<tr>
<td>C</td>
<td>1.595</td>
</tr>
</tbody>
</table>

### Overall Sigma Capability

<table>
<thead>
<tr>
<th>Index</th>
<th>Estimate</th>
<th>Lower 95%</th>
<th>Upper 95%</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ppk</td>
<td>1.300</td>
<td>1.225</td>
<td>1.400</td>
</tr>
<tr>
<td>Ppl</td>
<td>1.300</td>
<td>1.345</td>
<td>1.614</td>
</tr>
<tr>
<td>Ppu</td>
<td>1.360</td>
<td>1.325</td>
<td>1.465</td>
</tr>
<tr>
<td>Po</td>
<td>1.430</td>
<td>1.335</td>
<td>1.535</td>
</tr>
<tr>
<td>Cpm</td>
<td>1.400</td>
<td>1.299</td>
<td>1.504</td>
</tr>
</tbody>
</table>

### Nonconformance

<table>
<thead>
<tr>
<th>Portion</th>
<th>Observed %</th>
<th>Expected Between-and-Within %</th>
<th>Expected Overall %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Below LSL</td>
<td>0.00000</td>
<td>0.00000</td>
<td>0.00000</td>
</tr>
<tr>
<td>Above USL</td>
<td>0.00000</td>
<td>0.00001</td>
<td>0.00022</td>
</tr>
<tr>
<td>Total Outside</td>
<td>0.00000</td>
<td>0.00002</td>
<td>0.00026</td>
</tr>
</tbody>
</table>
A Moving Range chart appears between the Range and Average charts. The limits on the Average (XBar) chart are now calculated using the moving range between each sample.

**Example of Multiple Control Charts**

In Control Chart Builder, you can create multiple control charts in the same window using the New Y Chart option in the interactive workspace or by specifying multiple processes in a specific control chart launch window. In this example, use the IMR control chart launch window and then save the control limits to a new data table.

1. Select **Help > Sample Data Folder** and open Semiconductor Capability.jmp.
2. Select **Analyze > Quality and Process > Control Chart > IMR Control Chart**.
3. Click the triangle next to Processes to show all of the processes.
4. Select the first five processes and click **Y**.
5. Click **OK**.

If you scroll through the report window, there are Individual and Moving Range control charts for all five selected processes. Since the processes have a Spec Limits column property, there are also Process Capability Analysis reports for each process.

6. Click the Control Chart Builder red triangle and select **Save Limits > in New Tall Table**.

**Figure 3.35  New Tall Table**

<table>
<thead>
<tr>
<th>Process</th>
<th>Std Dev</th>
<th>Sample Size</th>
<th>Sigma</th>
<th>N Subgroups</th>
<th>Mean</th>
<th>LCL</th>
<th>UCL</th>
<th>AvgR</th>
<th>LCLR</th>
<th>UCLR</th>
</tr>
</thead>
<tbody>
<tr>
<td>NPN1</td>
<td>2.6330722541</td>
<td>1</td>
<td>2.6330722541</td>
<td>1455</td>
<td>114.79276556</td>
<td>106.86775458</td>
<td>122.69792832</td>
<td>2.8733506553</td>
<td>0</td>
<td>9.7123774226</td>
</tr>
<tr>
<td>PNP1</td>
<td>59.430128559</td>
<td>1</td>
<td>59.430128559</td>
<td>1455</td>
<td>313.05971647</td>
<td>134.77933079</td>
<td>513.36010214</td>
<td>67.05971866</td>
<td>0</td>
<td>219.05271249</td>
</tr>
<tr>
<td>PNP2</td>
<td>79.27035928</td>
<td>1</td>
<td>79.27035928</td>
<td>1455</td>
<td>456.61569285</td>
<td>218.00401501</td>
<td>694.42677069</td>
<td>69.44702198</td>
<td>0</td>
<td>292.18155238</td>
</tr>
<tr>
<td>NPN2</td>
<td>2.1316521676</td>
<td>1</td>
<td>2.1316521676</td>
<td>1455</td>
<td>115.74213862</td>
<td>109.34718152</td>
<td>122.13709452</td>
<td>2.403311974</td>
<td>0</td>
<td>7.8570260866</td>
</tr>
<tr>
<td>PNP3</td>
<td>6.1609122855</td>
<td>1</td>
<td>6.1609122855</td>
<td>1455</td>
<td>137.61457411</td>
<td>119.13163725</td>
<td>156.09731096</td>
<td>6.951645073</td>
<td>0</td>
<td>22.708423829</td>
</tr>
</tbody>
</table>

The control limits are saved to a new data table, with a row for each Y variable and a column for each statistic.
Statistical Details for Control Chart Builder

This section contains statistical details for Control Chart Builder.

- “Statistical Details for XBar and R Charts”
- “Statistical Details for XBar and S Charts”
- “Statistical Details for Individual Measurement and Moving Range Charts”
- “Statistical Details for P, NP, and Laney P’ Charts”
- “Statistical Details for U, C, and Laney U’ Charts”
- “Statistical Details for Levey-Jennings Charts”
- “Statistical Details for G Charts”
- “Statistical Details for T Charts”
- “Statistical Details for Three Way Control Charts”

Notes:

- Control limits are calculated using a sigma multiplier, $K$, which is set to 3 by default. To change the default value of $K$, use the K Sigma option in the red triangle menu or the K Sigma preference in File > Preferences > Platforms > Control Chart Builder.
- For sample sizes up to $n = 50$, JMP uses control chart constants $d_2(n)$ and $d_3(n)$ that are defined in Table 2 of Harter (1960). For samples with a sample size greater than 50, JMP uses the control chart constant values for sample size 50 in both the sigma and control limit calculations.

Statistical Details for XBar and R Charts

In Control Chart Builder, control limits for XBar and R charts are generated using the following formulas:

LCL for XBar chart = $\overline{X}_w - \frac{K\hat{\sigma}}{\sqrt{n_i}}$

UCL for XBar chart = $\overline{X}_w + \frac{K\hat{\sigma}}{\sqrt{n_i}}$

LCL for R chart = $\max\left(d_2(n_i)\hat{\sigma} - Kd_3(n_i)\hat{\sigma}, 0\right)$

UCL for R chart = $d_2(n_i)\hat{\sigma} + Kd_3(n_i)\hat{\sigma}$

Center line for R chart: By default, the center line for the $i^{th}$ subgroup indicates an estimate
of the expected value of \( R_i \). This value is computed as \( d_2(n_i)\hat{\sigma} \), where \( \hat{\sigma} \) is an estimate of \( \sigma \).

The standard deviation for XBar and R charts is estimated using the following formula:

\[
\hat{\sigma} = \frac{R_1}{d_2(n_1)} + \ldots + \frac{R_N}{d_2(n_N)}
\]

where:

- \( \bar{X}_{w} \) = weighted average of subgroup means
- \( K \) = the sigma multiplier and is set to 3 by default
- \( \sigma \) = process standard deviation
- \( n_i \) = sample size of \( i^{th} \) subgroup
- \( d_2(n) \) is the expected value of the range of \( n \) independent normally distributed variables with unit standard deviation
- \( d_3(n) \) is the standard deviation of the range of \( n \) independent normally distributed variables with unit standard deviation
- \( R_i \) is the range of \( i^{th} \) subgroup
- \( N \) is the number of subgroups for which \( n_i \geq 2 \).

**Statistical Details for XBar and S Charts**

In Control Chart Builder, control limits for XBar and S charts are generated using the following formulas:

LCL for XBar chart = \( \bar{X}_{w} - \frac{K\hat{\sigma}}{\sqrt{n_i}} \)

UCL for XBar chart = \( \bar{X}_{w} + \frac{K\hat{\sigma}}{\sqrt{n_i}} \)

LCL for S chart = \( \max\left(c_4(n_i)\hat{\sigma} - Kc_5(n_i)\hat{\sigma}, 0\right) \)

UCL for S chart = \( c_4(n_i)\hat{\sigma} + Kc_5(n_i)\hat{\sigma} \)

Center line for S chart: By default, the center line for the \( i^{th} \) subgroup indicates an estimate of the expected value of \( s_i \). This value is computed as \( c_4(n_i)\hat{\sigma} \), where \( \hat{\sigma} \) is an estimate of \( \sigma \).
The estimate for the standard deviation for XBar and S charts is:

\[ \hat{\sigma} = \frac{s_1}{c_4(n_1)} + \ldots + \frac{s_N}{c_4(n_N)} \]

where:

- \( \bar{X}_w \) = weighted average of subgroup means
- \( K \) = the sigma multiplier and is set to 3 by default
- \( \sigma \) = process standard deviation
- \( n_i \) = sample size of \( i^{th} \) subgroup
- \( c_4(n) \) is the expected value of the standard deviation of \( n \) independent normally distributed variables with unit standard deviation
- \( c_5(n) \) is the standard error of the standard deviation of \( n \) independent normally distributed variables with unit standard deviation
- \( N \) is the number of subgroups for which \( n_i \geq 2 \)
- \( s_i \) is the sample standard deviation of the \( i^{th} \) subgroup

### Statistical Details for Individual Measurement and Moving Range Charts

This section describes how control limits for Individual Measurement and Moving Range charts are calculated in Control Chart Builder.

Control limits for Individual Measurement charts are computed as follows:

- LCL for Individual Measurement Chart = \( \bar{X} - K\hat{\sigma} \)
- UCL for Individual Measurement Chart = \( \bar{X} + K\hat{\sigma} \)

Control limits for Individual Measurement charts with sigma estimated by the median moving range are computed as follows:

- LCL for Individual Measurement Chart = \( \bar{X} - K\hat{\sigma}_{MMR} \)
- UCL for Individual Measurement Chart = \( \bar{X} + K\hat{\sigma}_{MMR} \)

Control limits for Moving Range charts are computed as follows:

- LCL for Moving Range Chart = \( \text{max}\{d_2(n)\hat{\sigma} - Kd_3(n)\hat{\sigma}, 0\} \)
UCL for Moving Range Chart = \( d_2(n) \hat{\sigma} + Kd_3(n)\hat{\sigma} \)

Control limits for Median Moving Range charts are computed as follows:

\[
\text{LCL}_{\text{MMR}} = \max(0, \text{MMR} - Kd_3(n)\hat{\sigma}_{\text{MMR}})
\]

\[
\text{UCL}_{\text{MMR}} = \text{MMR} + Kd_3(n)\hat{\sigma}_{\text{MMR}}
\]

The standard deviation for Individual Measurement and Moving Range charts is estimated as follows:

\[
\hat{\sigma} = \frac{\overline{MR}}{d_2(n)}
\]

The standard deviation for Individual Measurement and Moving Range charts when using the median is estimated as follows:

\[
\hat{\sigma}_{\text{MMR}} = \text{MMR}/0.954
\]

where:

\( \overline{X} \) = the mean of the individual measurements

\( K \) = the sigma multiplier and is set to 3 by default

\( \overline{MR} \) = the mean of the nonmissing moving ranges computed as \( (MR_2+MR_3+...+MR_n)/(N-1) \) where \( MR_i = |x_i - x_{i-1}| \).

\( \text{MMR} \) = the median of the nonmissing moving ranges

\( \sigma \) = the process standard deviation

\( d_2(n) \) = expected value of the range of \( n \) independent normally distributed variables with unit standard deviation.

\( d_3(n) \) = standard deviation of the range of \( n \) independent normally distributed variables with unit standard deviation

**Note:** Moving Range charts in Control Chart Builder use a range span of \( n = 2 \).

### Statistical Details for P, NP, and Laney P’ Charts

In Control Chart Builder, the lower and upper control limits, LCL, and UCL, respectively, are computed using the following formulas:

\[
P \text{ chart LCL} = \max(\bar{p} - K\sqrt{\bar{p}(1-\bar{p})/n}, 0)
\]
P chart UCL = \min(p + K\sqrt{p(1-p)/n_i}, 1)

NP chart LCL = \max(n_i\bar{p} - K\sqrt{n_i\bar{p}(1-\bar{p})}, 0)

NP chart UCL = \min(n_i\bar{p} + K\sqrt{n_i\bar{p}(1-\bar{p})}, n_i)

Laney P’ chart LCL = \max(\bar{p} - K\sigma_z\sqrt{\bar{p}(1-\bar{p})}/n_i, 0)

Laney P’ chart UCL = \min(\bar{p} + K\sigma_z\sqrt{\bar{p}(1-\bar{p})}/n_i, 1)

where:

\bar{p} is the average proportion of nonconforming items taken across subgroups

\bar{p} = \frac{n_1p_1 + \ldots + n_Np_N}{n_1 + \ldots + n_N} = \frac{X_1 + \ldots + X_N}{n_1 + \ldots + n_N}

n_i is the number of items in the \(i^{th}\) subgroup

K is the sigma multiplier and is set to 3 by default

\sigma_z is a moving range sigma calculated from the standardized values

**Statistical Details for U, C, and Laney U’ Charts**

In Control Chart Builder, the lower and upper control limits, LCL, and UCL, are computed using the following formulas:

U chart LCL = \max(\bar{u} - K\sqrt{\bar{u}/n_i}, 0)

U chart UCL = \bar{u} + K\sqrt{\bar{u}/n_i}

C chart LCL = \max(n_i\bar{u} - K\sqrt{n_i\bar{u}}, 0)

C chart UCL = n_i\bar{u} + K\sqrt{n_i\bar{u}}

Laney U’ chart LCL = \max(\bar{u} - K\sigma_{z\bar{u}}\sqrt{\bar{u}/n_i}, 0)

Laney U’ chart UCL = \bar{u} + K\sigma_{z\bar{u}}\sqrt{\bar{u}/n_i}

The limits vary with \(n_i\).

\(u_i\) is the number of nonconformities per unit in the \(i^{th}\) subgroup. In general, \(u_i = c/n_i\).
Quality and Process Methods

Statistical Details for Control Chart Builder

- **K** is the sigma multiplier and is set to 3 by default
- \( \sigma_z \) is a moving range sigma calculated from the standardized values
- \( c_i \) is the total number of nonconformities in the \( i^{th} \) subgroup
- \( n_i \) is the number of inspection units in the \( i^{th} \) subgroup
- \( \bar{c} \) is the average number of nonconformities per unit taken across subgroups. The quantity \( \bar{c} \) is computed as a weighted average

\[
\bar{u} = \frac{n_1 c_1 + \ldots + n_N c_N}{n_1 + \ldots + n_N} = \frac{c_1 + \ldots + c_N}{n_1 + \ldots + n_N}
\]

- \( N \) is the number of subgroups

Statistical Details for Levey-Jennings Charts

Levey-Jennings charts are available in Control Chart Builder and show a process mean with control limits based on a long-term sigma. The control limits are placed at \( K^* \)’s distance from the center line, where \( K = 3 \) by default.

The standard deviation, \( s \), for the Levey-Jennings chart is calculated the same way standard deviation is in the Distribution platform.

\[
s = \sqrt{\frac{\sum_{i=1}^{N} (y_i - \bar{y})^2}{N-1}}
\]

See Levey and Jennings (1950); Westgard (2002).

Statistical Details for G Charts

In Control Chart Builder, the negative binomial distribution is used to calculate the sigma value for a G chart. The negative binomial distribution is an extension of the geometric (Poisson) distribution and allows for overdispersion relative to the Poisson. The negative binomial distribution can be used to construct both exact and approximate control limits for count data. Approximate control limits can be obtained based on a chi-square approximation to the negative binomial. All data is used as individual observations regardless of subgroup size.

Let \( X \) have a negative binomial distribution with parameters \((\mu, k)\). Then:

\[
P(X \leq r) \sim P\left( \chi^2_{\mu} \leq \frac{2r + 1}{1 + \mu k} \right)
\]
where:

\( \chi^2_v \) is a chi-square variate with \( v = 2\mu/(1+\mu k) \) degrees of freedom.

Based on this approximation, approximate upper and lower control limits can be determined. For a nominal level \( \alpha \) Type 1 error probability in one direction, an approximate upper control limit is a limit UCL such that the following equation is true:

\[
P(X > UCL) = 1 - P\left(\chi^2_v \leq \frac{2UCL + 1}{1 + \mu k}\right) = \alpha
\]

Likewise, an approximate lower control limit, LCL, is a limit such that the following equation is true:

\[
P(X < LCL) = 1 - P\left(\chi^2_v \geq \frac{2LCL + 1}{1 + \mu k}\right) = \alpha
\]

Thus, an approximate level lower and upper control limits, LCL and UCL, respectively, are computed using the following formulas:

\[
UCL = \frac{\chi^2_{v, 1-\alpha}(1 + \mu k) - 1}{2}
\]

\[
LCL = \max\left\{0, \frac{\chi^2_{v, \alpha}(1 + \mu k) - 1}{2}\right\}
\]

where:

\( \chi^2_{v, 1-\alpha}(\chi^2_{v, \alpha}) \) is the upper (lower) percentile of the chi-square distribution with
\( v = 2\mu/(1+\mu k) \) degrees of freedom. Negative lower control limits can be set to zero.

For more information about the negative binomial control limits, see Hoffman (2003).

**Statistical Details for T Charts**

In Control Chart Builder, the Weibull distribution is used to calculate the sigma value for a T chart. The estimates of the shape and scale parameters are calculated from the data and used to obtain the percentiles of the Weibull distribution.

**Note:** Subgroups with a response value of zero are given a weight of zero when estimating the Weibull distribution parameters.

Define the following quantities:
\[ p_1 = \text{normalDist}(-K) \text{ for Normal } (0,1) \]
\[ p_2 = \text{normalDist}(0) \text{ for Normal } (0,1) \]
\[ p_3 = \text{normalDist}(K) \text{ for Normal } (0,1) \]

Then the limits are calculated using the following formulas:

\[
\begin{align*}
\text{LCL} &= \text{Weibull Quantile} (p_1, \beta, \alpha) \\
\text{CL} &= \text{Weibull Quantile} (p_2, \beta, \alpha) \\
\text{UCL} &= \text{Weibull Quantile} (p_3, \beta, \alpha)
\end{align*}
\]

where:

- \( \beta \) is the shape parameter and \( \alpha \) is the scale parameter for the Weibull Quantile function
- \( K \) is the sigma multiplier and is set to 3 by default

For more information about the Weibull Quantile function, see Help > Scripting Index.

**Statistical Details for Three Way Control Charts**

This section describes how the sigma values are calculated for Three Way control charts in Control Chart Builder.

**Within Sigma Based on Average of Ranges**

The within sigma estimate for three way control charts that is estimated using the average of ranges can be used for the Individual on Means, Moving Range on Means and R chart.

\[
\hat{\sigma}_{\text{within}} = \frac{R_1}{d_2(n_1)} + \ldots + \frac{R_N}{d_2(n_N)}
\]

The formula uses the following notation:

- \( R_i \) = range of \( i^{th} \) subgroup
- \( n_i \) = sample size of \( i^{th} \) subgroup
- \( d_2(n_i) \) = expected value of the range of \( n_i \) independent normally distributed variables with unit standard deviation
- \( N \) = number of subgroups for which \( n_i \geq 2 \)
**Within Sigma Based on Average of Unbiased Standard Deviations**

The within sigma estimate for three way control charts that is estimated using the average of unbiased standard deviations can be used for the Individual on Means, Moving Range on Means, and S chart.

\[
\hat{\sigma}_{\text{within}} = \frac{s_1}{c_4(n_1)} + \ldots + \frac{s_N}{c_4(n_N)}
\]

The formula uses the following notation:

- \( s_i \) = sample standard deviation of the \( i^{th} \) subgroup
- \( n_i \) = sample size of \( i^{th} \) subgroup
- \( c_4(n_i) \) = expected value of the standard deviation of \( n_i \) independent normally distributed variables with unit standard deviation
- \( N \) = number of subgroups for which \( n_i \geq 2 \)

**Between Sigma**

The between sigma estimate for three way control charts is estimated using the moving range of subgroup means.

\[
\hat{\sigma}_{\text{between}} = \sqrt{\frac{(\bar{MR})^2}{d_2(2)}} - \frac{\hat{\sigma}_{\text{within}}^2}{H}
\]

The formula uses the following notation:

- \( \bar{MR} \) = the mean of the nonmissing moving ranges computed as \( (MR_2+MR_3+\ldots+MR_N)/(N-1) \)
- \( MR_i = |y_i - y_{i-1}| \).
- \( d_2(2) \) = expected value of the range of two independent normally distributed variables with unit standard deviation.
- \( H = \frac{1}{n_1} + \frac{1}{n_2} + \ldots + \frac{1}{n_N} \), the harmonic mean of subgroup sample sizes.

**Note:** If between Sigma is estimated as a negative value, it is set to 0.
Between-and-Within Sigma

The between-and-within sigma estimate for three way control charts is estimated using a combination of the within sigma and between sigma estimates.

\[ \hat{\sigma}_{\text{between-and-within}} = \sqrt{\frac{\hat{\sigma}_{\text{within}}^2 + \hat{\sigma}_{\text{between}}^2}{N}} \]
Measurement Systems Analysis
Evaluate a Continuous Measurement Process Using the EMP Method

The Measurement Systems Analysis (MSA) platform uses the Evaluating the Measurement Process (EMP) method to assess the precision, consistency, and bias of a measurement system. Use MSA to evaluate your measurement system performance. Before you study the process itself, you should make sure that you can accurately and precisely measure the process.

Note: This chapter covers the EMP method. The Gauge R&R method is described in “Variability Gauge Charts”.

Figure 4.1 Example of a Measurement System Analysis
## Contents

- Overview of Measurement Systems Analysis .................................................. 111
- Example of Measurement Systems Analysis .................................................. 111
- Launch the Measurement Systems Analysis Platform ................................... 115
  - Data Format ......................................................................................... 117
- Measurement Systems Analysis Report ......................................................... 118
  - Average Chart ..................................................................................... 118
  - Dispersion Chart ................................................................................ 119
- Measurement Systems Analysis Platform Options ....................................... 119
- Measurement Systems Analysis Report Options ......................................... 120
  - EMP Results Report ........................................................................... 123
  - Shift Detection Profiler ....................................................................... 125
  - Bias Comparison Report ..................................................................... 130
  - Linearity and Bias Results Report .......................................................... 131
- Additional Example of Measurement Systems Analysis .............................. 132
- Statistical Details for Measurement Systems Analysis .............................. 138
  - Statistical Details for Intraclass Correlation and Probable Error ............... 138
Overview of Measurement Systems Analysis

The Evaluating the Measurement Process (EMP) method in the Measurement Systems Analysis platform is largely based on the methods presented in Donald J. Wheeler’s book *EMP III Using Imperfect Data* (2006). The EMP method provides visual information and results that are easy to interpret and helps you improve your measurement system to its full potential.

The Gauge R&R method analyzes how much of the variability is due to operator variation (reproducibility) and measurement variation (repeatability). Gauge R&R is available for many combinations of crossed and nested models, regardless of whether the model is balanced. See “Variability Gauge Charts”.

Within the Six Sigma DMAIC methodology, Measurement System Analysis (MSA) addresses the Measure phase and process behavior charts (or control charts) address the Control phase. MSA helps you predict and characterize future outcomes. You can use the information gleaned from MSA to help you interpret and configure your process behavior charts.

For more information about Control Charts, see “Control Chart Builder”.

Example of Measurement Systems Analysis

Use the Measurement Systems Analysis platform to study the variability of a measurement system. The study had three operators who each measured the same five parts.

1. Select Help > Sample Data Folder and open Variability Data/Gasket.jmp.
3. Assign Y to the Y, Response role.
4. Assign Part to the Part, Sample ID role.
5. Assign Operator to the X, Grouping role.
   Notice that the MSA Method is set to EMP, the Chart Dispersion Type is set to Range, and the Model Type is set to Crossed.
6. Click OK.
Figure 4.2 MSA Initial Report

The Average Chart shows the average measurements for each operator and part combination. In this example, the means of the part measurements are generally beyond the control limits. This is a desirable outcome, because it indicates that you can detect part-to-part variation.

The Range Chart shows the variability for each operator and part combination. In this example, the ranges are within the control limits. This is a desirable outcome, because it indicates that the operators are measuring parts in the same way and with similar variation.

The color coding for each part is shown in the legend below the charts.

7. Click the red triangle next to Measurement Systems Analysis for Y and select **Parallelism Plots**.
Figure 4.3 Parallelism Plot for Operator and Part

The Parallelism Plots chart shows the average measurements for each part by operator. Because the lines are generally parallel and there is no major crossing, you conclude that there is no interaction between operators and parts.

**Tip:** Interactions indicate a serious issue that requires further investigation.

8. Click the red triangle next to Measurement Systems Analysis for Y and select EMP Results.

Figure 4.4 EMP Results Report
The EMP Results report computes several statistics to help you assess and classify your measurement system. The Intraclass Correlation indicates the proportion of the total variation that you can attribute to the part.

From the EMP Results report, you can conclude the following:

- The Intraclass Correlation values are close to 1, indicating that most of the variation is coming from the part instead of the measurement system.
- The classification is First Class, meaning that the strength of the process signal is weakened by less than 11%.
- There is at least a 99% chance of detecting a warning using Test 1 only.
- There is 100% chance of detecting a warning using Tests 1-4.

**Note:** For more information about tests and detecting process shifts, see “Shift Detection Profiler”.

There is no interaction between operators and parts, and there is very little variation in your measurements (the classification is First Class). Therefore, you conclude that the measurement system is performing quite well.
Launch the Measurement Systems Analysis Platform

Launch the Measurement Systems Analysis platform by selecting **Analyze > Quality and Process > Measurement Systems Analysis**.

**Figure 4.5** The Measurement Systems Analysis Window

- **Select Columns**
- **MSA Method**
- **Chart Dispersion Type**
- **Model Type**
- **Options**
- **Show EMP Metadata Entry Dialog**

For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

The Measurement Systems Analysis window contains the following features:

**Select Columns** Lists all of the variables in your current data table. Move a selected column into a role.

**MSA Method** Select the method to use: EMP (Evaluating the Measurement Process), Gauge R&R, or Type 1 Gauge. This chapter covers the EMP method. For more information about the Gauge R&R method, see “Variability Gauge Charts”. For more information about the Type 1 Gauge method, see “Type 1 Gauge Analysis”.

**Chart Dispersion Type** Designates the type of chart for showing variation. Select the **Range** option or the **Standard Deviation** option.
Note: For the EMP method, the chart dispersion type determines how the statistics in the EMP Results report are calculated. If the Range option is selected, and you have a one factor or a two factor, balanced, crossed model, the statistics in this report are based on ranges. Otherwise, the statistics in this report are based on standard deviations.

Model Type  Designates the model type:

Main  Variables with nominal or ordinal modeling types are treated as main effects.

Crossed  The model is crossed when every level of every factor occurs with every level of every other factor.

Crossed with Two Factor Interactions  The model is crossed when each level of two factors occurs with every level of the other factor.

Nested  The model is nested when all levels of a factor appear within only a single level of any other factor.

Crossed then Nested (3 Factors Only)  The factors are crossed and then nested for 3 factors.

Nested then Crossed (3 Factors Only)  The factors are nested and then crossed for 3 factors.

Options  Contains the following options:

Sigma Multiplier  Specifies the sigma multiplier used in the analyses.

Specify Alpha Level  Specifies the 1-alpha confidence level used in the analyses.

Set Random Seed  Enables you to set a specific random seed.

Analysis Settings  Opens a window that enables you to set the REML maximum iterations and convergence limit.

Show EMP Metadata Entry Dialog  Specifies if the MSA Metadata dialog is shown after you click OK. This dialog enables you to load the metadata from a data table or enter the metadata for each column manually. Use the following options to enter the metadata manually:

Choose Tolerance Entry Type  Choose to enter the tolerance range directly or specify the lower and upper tolerance values. If you choose to enter lower and upper tolerance values, the tolerance range is calculated as the difference between the upper and lower tolerance values. If only one tolerance value is entered, the tolerance range cannot be calculated and any statistics in the report that rely on the tolerance range are not shown.
**Tolerance Range**  Specifies the tolerance for the process, which is the difference between the upper specification limits and the lower specification limits.

**Lower Tolerance**  Specifies the lower tolerance limit. This is used to calculate the tolerance range if it is not specified directly.

**Upper Tolerance**  Specifies the upper tolerance limit. This is used to calculate the tolerance range if it is not specified directly.

**Historical Mean**  Specifies a historical mean. The historical mean is used to compute tolerance ranges for one-sided specification limits (either USL-Historical Mean or Historical Mean-LSL). If you do not enter a historical mean, the grand mean is used.

**Historical Process Sigma**  Specifies a historical process sigma. This value is used to calculate the process variation in the Linearity and Bias Results option and some of the statistics in the Gauge R&R report.

**Tip:** This data can also be specified prior to launching using the MSA column property. You can set MSA column properties to several measurement columns at once using Manage Limits. See “Manage Limits”.

**Use Spec Limits for Tolerance if Needed**  If a tolerance range is not specified for a column, but the column has a Spec Limits column property, this option uses the specification limits to calculate the tolerance range.

**Y, Response**  The column(s) of measurements.

**Standard**  Specifies a standard or reference column that contains the “true” or known values for the measured part. Including this column enables the Bias and Linearity Study options. These options perform analysis on the differences between the observed measurement and the reference or standard value. See “Linearity and Bias Results”.

**Part, Sample, ID**  The column designating the part or unit.

**X, Grouping**  The column(s) representing grouping variables.

**By**  Identifies a column that creates a report consisting of separate analyses for each level of the variable.

## Data Format

To use the Measurement Systems Analysis platform, all response measurements must be in a single response column. Sometimes, responses are recorded in multiple columns, where each row is a level of a design factor and each column is a level of a different design factor. Data in this format must be stacked before running the Measurement Systems Analysis platform. See *Using JMP*. 
Measurement Systems Analysis Report

The EMP Measurement Systems Analysis Study report contains a Measurement Systems Analysis report for each response column that was specified in the launch window. By default, each Measurement Systems Analysis report includes sections for the Average Chart and a dispersion chart. The dispersion chart type is specified in the launch window and is either a Range chart or a Standard Deviation chart.

- “Average Chart”
- “Dispersion Chart”

Average Chart

The Average Chart in the Measurement Systems Analysis platform plots the average measurement values for each combination of the part and X variables. This chart helps detect product variation despite measurement variation. In an Average Chart, out of control data is desirable because it indicates the ability of the measurement system to detect part-to-part variation.

The Average Chart red triangle menu contains the following options:

Show Grand Mean  Shows or hides the overall mean of the Y variable on the chart.

Show Connected Means  Shows or hides lines connecting the average measurement values.

Show Control Limits  Shows or hides lines representing the Upper Control Limit (UCL) and the Lower Control Limit (LCL) and labels those values. The control limits for the Average Chart use the same calculations as an XBar control chart. See “Statistical Details for XBar and R Charts”.

Show Control Limits Shading  Shows or hides shading between the UCL and LCL.

Show Separators  Shows or hides vertical lines to delineate the X variables.

Show Data  Shows or hides the data points on the chart. The y-axis rescales as needed to show all data points.

Tip: You can replace variables in the Average Chart in one of two ways: swap existing variables by dragging and dropping a variable from one axis to the other axis; or, click a variable in the Columns panel of the associated data table and drag it onto an axis.
Dispersion Chart

The dispersion chart shown in the Measurement Systems Analysis platform is either a Range chart or a Standard Deviation chart. The Range chart plots the variability statistic for each combination of the part and $X$ variables. The Standard Deviation chart plots the standard deviation statistic for each combination of the part and $X$ variables. Both of these charts help you check for consistency within subgroups. In a Range or Standard Deviation chart, data within limits is desirable, indicating homogeneity in your error.

The Range Chart or Standard Deviation Chart red triangle menu contains the following options:

- **Show Average Dispersion**  Shows or hides the average range or standard deviation on the chart.
- **Show Connected Points**  Shows or hides lines connecting all of the ranges or standard deviations.
- **Show Control Limits**  Shows or hides lines representing the Upper Control Limit (UCL) and the Lower Control Limit (LCL) and labels those values. For more information about the calculations of the limits used in the Range Chart, see “Statistical Details for XBar and R Charts”. For more information about the calculations of the limits used in the Standard Deviation Chart, see “Statistical Details for XBar and S Charts”.
- **Show Control Limits Shading**  Shows or hides shading between the UCL and LCL.
- **Show Separators**  Shows or hides vertical lines to delineate between the $X$ variables.

**Tip:** You can replace variables in the Range or Standard Deviation Charts in one of two ways: swap existing variables by dragging and dropping a variable from one axis to the other axis; or, click a variable in the Columns panel of the associated data table and drag it onto an axis.

---

Measurement Systems Analysis Platform Options

The EMP Measurement Systems Analysis Study red triangle menu contains the following options:

- **Save**  Shows a submenu of the following options:
  - **Save Metadata as Column Properties**  Saves the MSA metadata as column properties in the original data table. This includes the measurement sigma, which is saved in the Process Screening column property. The measurement sigma is the square root of the total of all variance components subtracted by the part variance.
Save All Metadata to Table  Saves a new data table that contains the MSA metadata for each column. This includes the measurement sigma, which is used in the Process Screening platform. The measurement sigma is the square root of the total of all variance components subtracted by the part variance.

See Using JMP for more information about the following options:

Local Data Filter  Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Platform Preferences  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Measurement Systems Analysis Report Options

Each Measurement Systems Analysis report red triangle menu contains the following options:

Average Chart  Shows or hides a plot of the average measurement values for each combination of the part and X variables. See “Average Chart”.

Range Chart  (Available only when Range is the Chart Dispersion Type selected in the launch window.) Shows or hides a plot of the variability statistic for each combination of the part and X variables. See “Dispersion Chart”.

Std Dev Chart  (Available only when Standard Deviation is the Chart Dispersion Type selected in the launch window.) Shows or hides a plot of the standard deviation statistic for each combination of the part and X variables. See “Dispersion Chart”.

Parallelism Plots  Shows or hides an overlay plot that reflects the average measurement values for each part. If the lines are relatively not parallel or crossing, there might be an interaction between the part and X variables.
Tip: Interactions indicate a serious issue that requires further investigation. For example, interactions between parts and operators mean that operators are measuring different parts differently, on average. Therefore, measurement variability is not predictable. This issue requires further investigation to find out why the operators do not have the same pattern or profile over the parts.

EMP Results  Shows or hides a report that computes several statistics to help you assess and classify your measurement system. See “EMP Results Report”.

Effective Resolution  Shows or hides a table containing results for the resolution of a measurement system, which helps you determine how well your measurement increments are working. In the table, the Current Measurement Increment reflects how many digits you are currently rounding to. This is taken from the data as the nearest power of ten. This number is compared to the Smallest Effective Increment, Lower Bound Increment, and Largest Effective Increment. Based on that comparison, a recommendation is made as to whether your current increments are effective as is or if any adjustments should be made.

Note: Large measurement increments have less uncertainty in the last digit, but large median errors. Small measurement increments have small median errors, but more uncertainty in the last digit.

Bias Comparison  Shows or hides an Analysis of Means chart for testing if the X variables have different averages. See “Bias Comparison Report”.

Test-Retest Error Comparison  Shows or hides an Analysis of Means for Variances or Analysis of Means Ranges chart for testing if any of the groups have different test-retest error levels. This chart shows if there are differences in the test-retest error between operators. The Analysis of Mean Ranges chart is displayed when ranges are used for variance components.

- For information about the options in the red triangle menu next to Operator Variance Test, see “Bias Comparison Report”.
- For more information about Analysis of Means for Variances charts, see “Variance Components”.

Shift Detection Profiler  Shows or hides an interactive set of charts that you can adjust to see the probabilities of getting warnings on your process behavior chart. See “Shift Detection Profiler”.

Variance Components  Shows or hides a report containing the estimates of the variance components for the given model. The calculations in this report are based on variances, not ranges. Balanced data uses the EMS method. Unbalanced data uses the REML method.
**Note:** This report is similar to the Variance Components report in the Variability Chart platform, except that it does not compute Bayesian variance component estimates. See “Variance Components”.

**EMP Gauge R&R Results**  
Shows or hides a report that partitions the variability in the measurements into part variation and measurement system variation. The calculations in this report are based on variances, not ranges. Because negative variance components are set to zero, values of zero could indicate outliers in your results.

**Note:** This report is similar to the Gauge R&R report in the Variability Chart platform. However, by default, the calculation for Reproducibility does not include interactions. To specify that interactions be included in the Reproducibility calculation, select the Include Interactions in Reproducibility platform preference. This preference is located in File > Preferences > Platforms > EMP Measurement Systems Analysis. For more information about Gauge R&R studies, see “About the Gauge R&R Method”.

**AIAG Gauge R&R Results**  
Shows or hides a report that partitions the variability in the measurements into part variation and measurement system variation. The calculation for Reproducibility includes interactions. This report is the same as the Gauge R&R report in the Variability Chart platform. See “Gauge R&R Report”. The AIAG Gauge R&R Results red triangle menu contains the following options:

- **AIAG Labels**  
  Shows or hides the column of labels in the AIAG Gauge R&R Results report defined by the Automotive Industry Action Group (AIAG).

- **Discrimination Ratio**  
  Adds the Discrimination Ratio to the Summary and Gauge R&R Statistics section of the AIAG Gauge R&R Results report. The discrimination ratio compares the total variance of the measurement with the variance of the measurement error and characterizes the relative usefulness of a given measurement for a specific product. Generally, when the discrimination ratio is less than 2, the measurement cannot detect product variation, implying that the measurement process needs improvement. A discrimination ratio greater than 4 adequately detects unacceptable product variation, implying that the production process needs improvement. See “Statistical Details for the Discrimination Ratio”.

- **Misclassification Probabilities**  
  (Available only if lower and upper tolerance values are specified for the response in the MSA Metadata.) Shows or hides a report of probabilities for rejecting good parts and accepting bad parts. See “Misclassification Probabilities”.

- **Linearity and Bias Results**  
  (Available only if a Standard column is specified in the launch window.) Shows or hides a graph and summary from a regression analysis using the standard column as the X variable and the bias as the Y variable. This analysis examines the relationship between bias and the size of the part. A nonzero slope indicates that your
gauge performs differently with different sized parts. See “Linearity and Bias Results Report”.

**Edit MSA Metadata** Opens a window that enables you to add or edit the tolerance range, tolerance limits, historical mean, and historical process sigma. See “Show EMP Metadata Entry Dialog”.

**EMP Results Report**

In the Measurement Systems Analysis platform, the EMP Results report computes several statistics to help you assess and classify your measurement system. Using this report, you can determine the following:

- How your process chart is affected.
- Which tests to set.
- How much the process signal is attenuated.
- How much the bias factors are affecting your system and reducing your potential intraclass correlation coefficient.

**Note:** The statistics in this report are based on ranges in the following instances: if you selected **EMP** as the **MSA Method** and **Range** as the **Chart Dispersion Type**, and you have a one factor or a two factor, balanced, crossed model. Otherwise, the statistics in this report are based on variances.

The EMP Results report contains the following calculations:

**Test-Retest Error** Indicates measurement variation or repeatability (also known as within error or pure error).

**Degrees of Freedom** Indicates the amount of information used to estimate the within error.

**Probable Error** The median error for a single measurement. Indicates the resolution quality of your measurement and helps you decide how many digits to use when recording measurements. See “Shift Detection Profiler”.

**Intraclass Correlation** Indicates the proportion of the total variation that you can attribute to the part. If you have very little measurement variation, this number is closer to 1.

**Intraclass Correlation (no bias)** Does not take bias or interaction factors into account when calculating the results.

**Intraclass Correlation (with bias)** Takes the bias factors (such as operator, instrument, and so on) into account when calculating the results.
**Intraclass Correlation (with bias and interaction)** Takes the bias and interaction factors into account when calculating the results. This calculation appears only if the model is crossed and uses standard deviation instead of range.

**Bias Impact** The amount by which the bias factors reduce the Intraclass Correlation.

**Bias and Interaction Impact** The amount by which the bias and interaction factors reduce the Intraclass Correlation. This calculation appears only if the model is crossed and uses standard deviation instead of range.

**Monitor Classification Legend**

The EMP Results report contains a Monitor Classification Legend, which describes the system and classification parameters in the Measurement Systems Analysis platform.

**Figure 4.6 Monitor Classification Legend**

<table>
<thead>
<tr>
<th>Classification</th>
<th>Intraclass Correlation</th>
<th>Attenuation of Process Signal</th>
<th>Probability of Warning, Test 1 Only*</th>
<th>Probability of Warning, Tests 1-4*</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Class</td>
<td>0.80 - 1.00</td>
<td>Less than 11%</td>
<td>0.99 - 1.00</td>
<td>1.00</td>
</tr>
<tr>
<td>Second Class</td>
<td>0.50 - 0.80</td>
<td>11% - 29%</td>
<td>0.88 - 0.99</td>
<td>1.00</td>
</tr>
<tr>
<td>Third Class</td>
<td>0.20 - 0.50</td>
<td>29% - 55%</td>
<td>0.40 - 0.88</td>
<td>0.92 - 1.00</td>
</tr>
<tr>
<td>Fourth Class</td>
<td>0.00 - 0.20</td>
<td>More than 55%</td>
<td>0.03 - 0.40</td>
<td>0.08 - 0.92</td>
</tr>
</tbody>
</table>

* Probability of warning for a 3 standard error shift within 10 subgroups using Wheeler’s tests, which correspond to Nelson’s tests 1, 2, 5, and 6.

This legend describes the following classifications: First, Second, Third, and Fourth Class. Each classification indicates the following:

- the corresponding Intraclass Correlation values
- the amount of process signal attenuation (decrease)
- the chance of detecting a 3 standard error shift within 10 subgroups, using Wheeler’s tests one or all four tests

Wheeler (2006) identifies four detection tests known as the Western Electric Zone Tests. Within the Shift Detection Profiler, there are eight tests that you can select from. The tests that correspond to the Wheeler tests are the first, second, fifth, and sixth tests.

**Tip:** To prevent the legend from appearing, deselect **Show Monitor Classification Legend** in the EMP Measurement Systems Analysis platform preferences.
Shift Detection Profiler

Use the Shift Detection Profiler in the Measurement Systems Analysis platform to assess the sensitivity of the control chart that you use to monitor your process. The Shift Detection Profiler estimates the probability of detecting shifts in the product mean or product standard deviation. The control chart limits include sources of measurement error variation. Based on these limits, the Shift Detection Profiler estimates the Probability of Warning. This is the probability that a control chart monitoring the process mean signals a warning over the next \( k \) subgroups.

You can set the subgroup size that you want to use for your control chart. Note the following:

- If the Subgroup Size equals one, the control chart is an Individual Measurement chart.
- If the Subgroup Size exceeds one, the control chart is an XBar-chart.

You can explore the effect of Subgroup Size on the control chart’s sensitivity. You can also explore the benefits of reducing bias and test-retest error.

Figure 4.7 shows the Shift Detection Profiler report for the Gasket.jmp sample data table, found in the Variability Data folder.
Probability of Warning

The Probability of Warning is the probability of detecting a change in the process. A change is defined by the Part Mean Shift and the Part Std Dev settings in the Shift Detection Profiler. The probability calculation assumes that the tests selected in the Customize and Select Tests outline are applied to the Number of Subgroups specified in the Profiler.

The control limits for the Individual Measurement chart (Subgroup Size = 1) and the XBar-chart (Subgroup Size > 1) are based on the In-Control Chart Sigma. The In-Control Sigma takes into account the bias factor (reproducibility) variation and the test-retest (repeatability) variation. These are initially set to the values obtained from your MSA study. The In-Control Chart Sigma also incorporates the In-Control Part Std Dev. Both of these values appear beneath the profiler, along with the False Alarm Probability, which is based on the In-Control Chart Sigma.
**In-Control Part Std Dev**  
The standard deviation for the true part values, exclusive of measurement errors, for the stable process. The default value for In-Control Part Std Dev is the standard deviation of the part component estimated by the MSA analysis and found in the Variance Components report.

Often, parts for an MSA study are chosen to have specific properties and do not necessarily reflect the part-to-part variation seen in production. For this reason, you can specify the in-control part standard deviation by selecting **Change In-Control Part Std Dev** from the Shift Detection Profiler red triangle menu.

**In-Control Chart Sigma**  
The value of sigma used to compute control limits. This value is computed using the In-Control Part Std Dev, the Bias Factors Std Dev, and Test-Retest Std Dev specified in the Shift Detection Profiler, and the Subgroup Size. The reproducibility factors are assumed to be constant within a subgroup.

For a subgroup of size $n$, control limits are set at the following values:

$$±3\left(\frac{\text{In-Control Chart Sigma}}{\sqrt{n}}\right)$$

It follows that the In-Control Chart Sigma is the square root of the sum of the squares of the following terms:

- In-Control Part Std Dev
- Bias Factors Std Dev, as specified in the Shift Detection Profiler, multiplied by $\sqrt{n}$
- Test-Retest Std Dev, as specified in the Shift Detection Profiler

The Bias Factors Std Dev is multiplied by $\sqrt{n}$ to account for the assumption that the reproducibility factors are constant within a subgroup.

JMP updates the In-Control Chart Sigma when you change the In-Control Part Std Dev, the Bias Factors Std Dev, the Test-Retest Std Dev, or the Subgroup Size.

**False Alarm Probability**  
The probability that the control chart tests signal a warning when no change in the part mean or standard deviation has occurred. JMP updates the False Alarm Probability when you change the Number of Subgroups or the tests in Customize and Select Tests.

For more information about the Variance Components report, see “Variance Components”.

**Shift Detection Profiler Settings**

**Number of Subgroups**  
The number of subgroups over which the probability of a warning is computed. If the number of subgroups is set to $k$, the profiler gives the probability that the control chart signals at least one warning based on these $k$ subgroups. The Number of Subgroups is set to 10 by default. Drag the vertical line in the plot to change the Number of Subgroups.
**Part Mean Shift**  The shift in the part mean. By default, the profiler is set to detect a 1 sigma shift. The initial value is the standard deviation of the part component estimated by the MSA analysis and found in the Variance Components report. Drag the vertical line in the plot or click the value beneath the plot to change the Part Mean Shift.

**Part Std Dev**  The standard deviation for the true part values, exclusive of measurement errors. The initial value for Part Std Dev is the standard deviation of the part component estimated by the MSA analysis and is found in the Variance Components report. Drag the vertical line in the plot or click the value beneath the plot to change the Part Std Dev.

**Bias Factors Std Dev**  The standard deviation of factors related to reproducibility. Bias factors include operator and instrument. The bias factor variation does not include part and repeatability (within) variation. The initial value is derived using the reproducibility and interaction variance components estimated by the MSA analysis and is found in the Variance Components report. Drag the vertical line in the plot or click the value beneath the plot to change the Bias Factors Std Dev.

**Test-Retest Std Dev**  The standard deviation of the test-retest, or repeatability, variation in the model. The initial value is the standard deviation of the Within component estimated by the MSA analysis and is found in the Variance Components report. Drag the vertical line in the plot or click the value beneath the plot to change the Test-Retest Std Dev.

**Subgroup Size**  The sample size used for each subgroup. This is set to 1 by default. You can increase the sample size to investigate improvement in control chart performance. Increasing the sample size from 1 demonstrates what happens when you move from an Individual Measurement chart to an XBar-chart. Drag the vertical line in the plot to change the Subgroup Size.

**Shift Detection Profiler Options**

The red triangle menu for the Shift Detection Profiler provides several options.

**Change In-Control Part Std Dev**  Specify a value for the part standard deviation for the stable process. The in-control part standard deviation should reflect the variation of the true part values, exclusive of measurement errors. Enter a new value and click OK.

The In-Control Part Std Dev is originally set to the standard deviation of the part component estimated by the MSA analysis, found in the Variance Components report.

This option is useful if the parts chosen for the EMP study were not a random sample from the process.

**Reset Factor Grid**  Displays a window for each factor allowing you to enter a specific value for the factor’s current setting, to lock that setting, and to control aspects of the grid. See *Profilers.*
**Factor Settings**  Submenu that consists of the following options:

**Remember Settings**  Adds an outline node to the report that accumulates the values of the current settings each time the Remember Settings command is invoked. Each remembered setting is preceded by a radio button that is used to reset to those settings. There are options to remove selected settings or all settings in the Remember Settings red triangle menu.

**Copy Settings Script**  Copies the current Profiler’s settings to the clipboard.

**Paste Settings Script**  Pastes the Profiler settings from the clipboard to a Profiler in another report.

**Set Script**  Sets a script that is called each time a factor changes. The set script receives a list of arguments of the form:

\{factor1 = n1, factor2 = n2, \ldots\}

For example, to write this list to the log, first define a function:

```
ProfileCallbackLog = Function({arg}, show(arg));
```

Then enter `ProfileCallbackLog` in the Set Script dialog.

Similar functions convert the factor values to global values:

```
ProfileCallbackAssign = Function({arg}, evalList(arg));
```

Or access the values one at a time:

```
ProfileCallbackAccess = Function({arg}, f1=arg["factor1"]; f2=arg["factor2"]);
```

**Shift Detection Profiler Legend**

This panel gives a brief description of four of the Shift Detection Profiler settings. See “Shift Detection Profiler Settings”.

**Tip:** To prevent the legend from appearing, deselect **Show Shift Detection Profiler Legend** in the EMP Measurement Systems Analysis platform preferences.

**Customize and Select Tests**

In the Customize and Select Tests panel, select and customize the tests that you want to apply to the $k$ subgroups in your control chart. The eight tests are based on Nelson (1984). For more information about the tests, see “Tests”.

The Shift Detection Profiler calculations take these tests into account. The Probability of Warning and False Alarm Probability values increase as you add more tests. Because the calculations are based on a quasi-random simulation, there might be a slight delay as the profiler is updated.

The Customize and Select Tests panel has the following options:

**Restore Default Settings**  If no settings have been saved to preferences, this option resets the selected tests to the first test only. The values of \( n \) are also reset to the values described in “Tests”. If settings have been saved to preferences, this option resets the selected tests and the values of \( n \) to those specified in the preferences.

**Note:** You can access preferences for control chart tests by selecting *File > Preferences > Platforms > Control Chart Builder*. Custom Tests 1 through 8 correspond to the eight tests shown in Customize and Select Tests.

**Save Settings to Preferences**  Saves the selected tests and the values of \( n \) for use in future analyses. These preferences are added to the Control Chart Builder platform preferences.

**Bias Comparison Report**

In the Measurement Systems Analysis platform, the Bias Comparison option creates an Analysis of Means chart. This chart shows the mean values for each level of the grouping variables and compares them with the overall mean. You can use this chart to see whether an operator is measuring parts too high or too low, on average.

The red triangle menu next to Analysis of Means contains the following options:

**Set Alpha Level**  Select an option from the most common alpha levels or specify any level using the Other selection. Changing the alpha level modifies the upper and lower decision limits.

**Show Summary Report**  Shows a report containing group means and decision limits, and reports if the group mean is above the upper decision limit or below the lower decision limit.

**Display Options**  Include the following options:

**Show Decision Limits**  Draws lines representing the Upper Decision Limit (UDL) and the Lower Decision Limit (LDL) and defines those values.

**Show Decision Limit Shading**  Adds shading between the UDL and the LDL.

**Show Center Line**  Draws the center line statistic that represents the average.

**Point Options**  Changes the chart display to needles, connected points, or points.
Linearity and Bias Results Report

In the Measurement Systems Analysis platform, the Linearity and Bias Results report contains a plot and a table for each of the following:

- Bias summary statistics and $t$ test results for each standard value and the overall value.
- Results from an ANOVA test that tests if the slope of the line is equal to zero.
- The parameter estimates and tests for the intercept and the slope. The intercept tests the bias and the slope tests the linearity. The test for the intercept is useful only if the test on the slope fails to reject the hypothesis that the slope is equal to 0.
- Linearity and Bias summary statistics. This table is shown only if you specify values for the sigma multiplier and the historical process sigma. The sigma multiplier is specified in the launch window. There are several ways to specify the historical process sigma:
  - Prior to analysis, you can assign the MSA column property to the response and specify the historical process sigma in the column property.
  - In the launch window, you can specify the historical process sigma by selecting the Show EMP Metadata Entry Dialog.
  - In the report window, you can click the Measurement Systems Analysis red triangle and select Edit MSA Metadata.
  - You can directly specify the historical process sigma in a script.

The Linearity and Bias Results red triangle menu contains the following options:

**Show Bias Points**  Shows or hides the bias points on the graph.

**Show Line of Fit**  Shows or hides the line of fit on the graph.

**Show Fit Confidence Curves**  Shows or hides the line of fit confidence curves on the graph.

**Show Overall Avg Bias Line**  Shows or hides the overall average bias line on the graph.

**Show Avg Bias Points**  Shows or hides the average bias points on the graph.
Additional Example of Measurement Systems Analysis

In this example, three operators have measured a single characteristic twice on each of six wafers. Use the Measurement Systems Analysis platform to conduct a detailed analysis to determine how well a measurement system is performing.

Perform the Initial Analysis

1. Select Help > Sample Data Folder and open Variability Data/Wafer.jmp.
3. Assign Y to the Y, Response role.
4. Assign Wafer to the Part, Sample ID role.
5. Assign Operator to the X, Grouping role.
   Notice that the MSA Method is set to EMP, the Chart Dispersion Type is set to Range, and the Model Type is set to Crossed.
6. Click OK.
Figure 4.8 Average and Range Charts

The Average Chart shows that some of the average part measurements fall beyond the control limits. This is desirable, indicating measurable part-to-part variation.

The Range Chart shows no points that fall beyond the control limits. This is desirable, indicating that the operator measurements are consistent within part.

Examine Interactions

Take a closer look for interactions between operators and parts. Click the red triangle next to Measurement Systems Analysis for Y and select Parallelism Plots.
Looking at the parallelism plot by operator, you can see that the lines are relatively parallel and that there is only some minor crossing.

**Examine Operator Consistency**

Take a closer look at the variance between operators. Click the red triangle next to Measurement Systems Analysis for Y and select **Test-Retest Error Comparison**.

Looking at the Test-Retest Error Comparison, you can see that none of the operators have a test-retest error that is significantly different from the overall test-retest error. The operators appear to be measuring consistently.
Just to be sure, you decide to look at the Bias Comparison chart, which indicates whether an operator is measuring parts too high or too low. Click the red triangle next to Measurement Systems Analysis for Y and select **Bias Comparison**.

**Figure 4.11** Bias Comparison

Looking at the Bias Comparison chart, you make the following observations:

- Operator A and Operator B have detectable measurement bias, as they are significantly different from the overall average.
- Operator A is significantly biased low.
- Operator B is significantly biased high.
- Operator C is not significantly different from the overall average.

**Classify Your Measurement System**

Examine the EMP Results report to classify your measurement system and look for opportunities for improvement. Click the red triangle next to Measurement Systems Analysis for Y and select **EMP Results**.
The classification is Second Class, which means that there is a better than 88% chance of detecting a three standard error shift within ten subgroups, using Test one only. You notice that the bias factors have an 11% impact on the Intraclass Correlation. In other words, if you could eliminate the bias factors, your Intraclass Correlation coefficient would improve by 11%.

**Explore the Ability of a Control Chart to Detect Process Changes**

Use the Shift Detection Profiler to explore the probability that a control chart will be able to detect a change in your process. Click the red triangle next to Measurement Systems Analysis for Y and select **Shift Detection Profiler**.
By default, the only test selected is for a point beyond the 3 sigma limits. Also note that the default Subgroup Size is 1, indicating that you are using an Individual Measurement chart.

Explore your ability to detect a shift in the mean of two part standard deviations in the 10 subgroups following the shift. Click the **Part Mean Shift** value of 2.1701 and change it to 4.34 (2.17 multiplied by 2). The probability of detecting a shift of twice the part standard deviation is 56.9%.

Next, see how eliminating bias affects your ability to detect the shift of two part standard deviations. Change the **Bias Factors Std Dev** value from 1.1256 to 0. The probability of detecting the shift increases to 67.8%.

Finally, add more tests to see how your ability to detect the two part standard deviation shift changes. In addition to the first test, select the second, fifth, and sixth tests (Wheeler’s Rules 4, 2, and 3). With these four tests and no bias variation, your probability of detecting the shift is 99.9%.

You can also explore the effect of using a control chart based on larger subgroup sizes. For subgroup sizes of two or more, the control chart is an XBar-chart. Change the **Bias Factors Std Dev** value back to 1.1256 and deselect all but the first test. Set the **Subgroup Size** in the profiler to 4. The probability of detecting the two part standard deviation shift is 98.5%.
Examine Measurement Increments

Finally, see how well your measurement increments are working. Click the red triangle next to Measurement Systems Analysis for Y and select Effective Resolution.

**Figure 4.14 Effective Resolution**

<table>
<thead>
<tr>
<th>Source</th>
<th>Value Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Probable Error</td>
<td>0.9029 Median error for a single measurement</td>
</tr>
<tr>
<td>Current Measurement Increment</td>
<td>0.01 Measurement increment estimated from data (in tenths)</td>
</tr>
<tr>
<td>Lower Bound Increment</td>
<td>0.0903 Measurement increment should not be below this value</td>
</tr>
<tr>
<td>Smallest Effective Increment</td>
<td>0.1986 Measurement increment is more effective above this value</td>
</tr>
<tr>
<td>Largest Effective Increment</td>
<td>1.9865 Measurement increment is more effective below this value</td>
</tr>
</tbody>
</table>

**Action:** Drop a digit
**Reason:** The measurement increment of 0.01 is below the lowest measurement increment bound and should be adjusted to record fewer digits.

The Current Measurement Increment of 0.01 is below the Lower Bound Increment of 0.09, indicating that you should adjust your future measurements to record one less digit.

---

**Statistical Details for Measurement Systems Analysis**

For more information about the calculations of the limits used in the Range Chart, see “Statistical Details for XBar and R Charts”. For more information about the calculations of the limits used in the Standard Deviation Chart, see “Statistical Details for XBar and S Charts”.

**Statistical Details for Intraclass Correlation and Probable Error**

This section contains computational details for statistics in the Measurement Systems Analysis platform.

Intraclass Correlation without bias is computed as follows:

\[ r_{pe} = \frac{\hat{\sigma}_p^2}{\hat{\sigma}_p^2 + \hat{\sigma}_{pe}^2} \]

Intraclass Correlation with bias is computed as follows:

\[ r_b = \frac{\hat{\sigma}_p^2}{\hat{\sigma}_p^2 + \hat{\sigma}_b^2 + \hat{\sigma}_{pe}^2} \]
Intraclass Correlation with bias and interaction factors is computed as follows:

\[
r_{int} = \frac{\hat{\sigma}_p^2}{\hat{\sigma}_p^2 + \hat{\sigma}_b^2 + \hat{\sigma}_{int}^2 + \hat{\sigma}_{pe}^2}
\]

Probable Error is computed as follows:

\[
Z_{0.75} \times \hat{\sigma}_{pe}
\]

Note the following:

\[
\hat{\sigma}_{pe}^2 = \text{variance estimate for pure error}
\]

\[
\hat{\sigma}_p^2 = \text{variance estimate for product}
\]

\[
\hat{\sigma}_b^2 = \text{variance estimate for bias factors}
\]

\[
\hat{\sigma}_{int}^2 = \text{variance estimate for interaction factors}
\]

\[
Z_{0.75} = \text{the 75\% quantile of standard normal distribution}
\]
Type 1 Gauge Analysis
Evaluate a Continuous Measurement Process Using the Type 1 Method

A Type 1 Gauge analysis is a measurement systems analysis that determines whether a measurement system, or gauge, is repeatable. Specifically, the analysis determines if a measurement system can repeatedly measure a part and obtain measurements that are close to a known reference standard.

The Type 1 Gauge platform produces a run chart, histogram, and metrics such as Cg and CgK that are useful in assessing gauge repeatability.

Figure 5.1 Example of a Type 1 Gauge Analysis
Contents

Example of Type 1 Gauge Analysis ................................................................. 143
Launch the Type 1 Gauge Platform ................................................................. 145
  Data Format .................................................................................................. 146
The Type 1 Gauge Study Report ................................................................. 147
  Run Chart .................................................................................................... 147
  Summary and Capability Statistics Table ..................................................... 147
Type 1 Gauge Study Options ................................................................. 149
  Type 1 Gauge Analysis Report Options ..................................................... 149
Example of Type 1 Gauge Analysis

Perform a Type 1 Gauge analysis to evaluate the repeatability of a measurement system.

1. Select Help > Sample Data Folder and open Variability Data/Type 1 Gauge MSA.jmp.
2. In the Columns section of the data table, click the asterisk next to Y1 and select MSA.

Figure 5.2 MSA Column Property

The Y1 column has an MSA column property, which contains metadata that is used in the Type 1 Gauge Analysis. The metadata includes tolerance specifications, the measurement resolution, and the reference value or the known value of the process quality variable. In this example, the reference value is 50.014.

3. Click Cancel to close the Column Info window.
5. Ensure that the MSA Method is set to Type 1 Gauge.
6. In the Show Type 1 Gauge Metadata Entry Dialog, select If Needed.
7. Select Y1 and click Y, Response.
8. Click **OK**.

9. Click the Run Chart red triangle and select **Show Mean**.

**Figure 5.3** Type 1 Gauge Analysis for Y1 Report

The Run Chart shows that the mean of the observed measurements is close to the reference standard and all of the measurements are within the percent of tolerance*tolerance range. The run chart also shows the variability of the measurements. To understand the measurement variability, review the Summary and Capability Statistics table. The values for Cg and CgK are 1.399 and 1.323, respectively. These values are close to the ideal Cg and CgK values of 1.33 or greater. Therefore, this measurement system is considered to be repeatable.
Launch the Type 1 Gauge Platform

Launch the Type 1 Gauge platform by selecting **Analyze > Quality and Process > Measurement Systems Analysis.** Set the MSA Method to **Type 1 Gauge.**

**Figure 5.4** The Type 1 Gauge Launch Window

For more information about the options in the Select Columns red triangle menu, see *Using JMP.*

The Type 1 Gauge window contains the following features:

**Y, Response**  Specifies one or more columns of measurements. Specifying more than one Y column produces a separate analysis report for each response.

**Freq**  Identifies a data table column whose values assign a frequency to each row. Can be useful when you have summarized data.

**By**  Identifies a column that creates a report consisting of separate analyses for each level of the variable.

**MSA Method**  Selects one of the following methods: EMP (Evaluating the Measurement Process), Gauge R&R, or Type 1 Gauge. This chapter covers the Type 1 Gauge method. For more information about the EMP method, see “Measurement Systems Analysis”. For more information about the Gauge R&R method, see “Variability Gauge Charts”.

**Percent of Tolerance**  Specifies the percent of part tolerance used to compare against the measurement variation. The default value is 20%. The percent of tolerance value is used to
calculate the portion of tolerance lines plotted on the Run Chart and certain statistics in the Summary and Capability Statistics table.

**Sigma Multiplier**  Specifies a constant value that is multiplied by sigma. The default value is 6, which means you are looking at $6\sigma$ or a 6 sigma process.

**Specify Alpha Level**  Specifies the alpha level for the Bias Test. The default value is 0.05.

**Show Type 1 Gauge Metadata Entry Dialog**  Specifies when the Type 1 Gauge Metadata dialog is shown after you click OK. This dialog enables you to load the metadata from a data table or enter the metadata for each column manually. When you enter the metadata manually, you can specify a tolerance range directly or specify lower and upper tolerance values. If you choose to enter lower and upper tolerance values, the tolerance range is calculated as the difference between the upper and lower tolerance values. If only one tolerance value is entered, the tolerance range cannot be calculated and any statistics in the report that rely on the tolerance range are not shown. The dialog also contains fields for the reference value and the gauge resolution. Specifying a value for the gauge resolution is optional, but the reference value is required. If a reference value is not entered for a response column, no Type 1 Gauge report is shown for that response column.

**Note:** This data can also be specified prior to launching by applying the MSA column property. You can apply the MSA column property to several measurement columns at once using Manage Limits. See “Manage Limits”.

**If Needed**  Opens the Type 1 Gauge Metadata window if at least one of the response columns is missing the tolerance range (or upper and lower tolerance values) or reference value in the MSA column property.

**Yes**  Opens the Type 1 Gauge Metadata window.

**No**  Does not open the Type 1 Gauge Metadata window. Columns that do not contain a reference value in the MSA metadata column property are not included in the analysis report.

**Use Spec Limits for Tolerance if Needed**  If a tolerance range is not specified for a column, but the column has a Spec Limits column property, this option uses the specification limits to calculate the tolerance range.

**Data Format**

The data for a Type 1 Gauge analysis should consist of measurements from the same part taken by the same operator. A known reference standard value must be defined in the MSA metadata. Enter metadata in the MSA column property or through the Type 1 Gage Metadata Entry Dialog accessible through the Type 1 launch window.
The Type 1 Gauge Study Report

The Type 1 Gauge Study report contains a Type 1 Gauge Analysis report for each measurement column that was specified in the launch window. The column name is included in the title of each analysis report. By default, each Type 1 Gauge Analysis report contains a run chart of measurements and a table of summary and capability statistics.

- “Run Chart”
- “Summary and Capability Statistics Table”

Run Chart

In the Type 1 Gauge Analysis report, the run chart of measurements includes horizontal lines at the reference value and upper and lower tolerances. The tolerances are based on the reference standard value (Ref), percent of tolerance value ($p$), and the tolerance range (Tol) and are calculated as follows:

$$\text{Portion of Tolerance} = \text{Ref} \pm 0.5p\times \text{Tol}$$

The Run Chart red triangle menu contains the following options:

- **Show Portion of Tolerance** Shows or hides the portion of tolerance lines on the run chart. If a tolerance range is given or calculated, the portion of tolerance is shown by default.
- **Show Reference** Shows or hides the reference value on the run chart. The reference value is shown by default.
- **Show Mean** Shows or hides the mean on the run chart.

Summary and Capability Statistics Table

In the Type 1 Gauge Analysis report, the Summary and Capability Statistics table contains statistics to determine the repeatability of the measurement system.

**Note:** Statistics that involve the tolerance range (Tol) are included only if a tolerance range is specified in the MSA metadata prior to the analysis.

- **Reference (Ref)** The reference standard value defined in the MSA metadata.
- **Mean** The mean of the observed measurements.
- **Std Dev** The standard deviation, $\sigma$, of the observed measurements.
- **k*Std Dev** The sigma multiplier, defined in the launch, multiplied by Std Dev.
N  The number of observed measurements.

**Tolerance Range (Tol)**  The tolerance range.

**Ref - (p/2)*Tol**  The lower portion of tolerance value that is shown on the Run Chart.

**Ref + (p/2)*Tol**  The upper portion of tolerance value that is shown on the Run Chart.

**Cg**  A measure of how well the variation of the measurements fits into the specified tolerance range. A common threshold for a good measurement system is a Cg value of 1.33 or greater. Cg is calculated as follows:

\[
C_g = \frac{p \cdot Tol}{k \cdot \sigma}
\]

**Cgk**  A measurement that is similar to the Cg value calculation, but also takes the bias into account. A common threshold for a good measurement system is a Cgk value of 1.33 or greater. Cgk is calculated as follows:

\[
C_{gk} = \frac{(p/2) \cdot Tol - |Mean - Ref|}{(k/2) \cdot \sigma}
\]

**% Var for Repeatability**  The percent of the tolerance range that is consumed by \( k \sigma \). Higher values indicate more measurement variability in the system. The % Var for Repeatability is calculated as follows:

\[
% \text{Var for Repeatability} = \left(\frac{k \sigma}{Tol}\right) \times 100
\]

**% Var for Repeatability and Bias**  A measurement that is similar to the % Var for Repeatability, but also takes the bias into account.

**Bias**  The difference between the mean and the reference standard value.

**Bias/Tol %**  The percent bias value, which is calculated as follows:

\[
\left(\frac{Bias}{Tol}\right) \times 100
\]

**Resolution (Res)**  The smallest resolution that your measurement device is capable of reporting.

**Res/Tol %**  The percent resolution value, which is calculated as follows:

\[
\left(\frac{|Res|}{Tol}\right) \times 100
\]
Type 1 Gauge Study Options

The Type 1 Gauge Study red triangle menu contains the following options:

**Save**  Shows a submenu of the following options:

- **Save Type 1 Gauge Metadata as Column Properties**  Saves the Type 1 Gauge metadata as MSA column properties in the data table.
- **Save Type 1 Gauge Metadata to Table**  Saves a new data table that contains the Type 1 Gauge metadata for each column.

See *Using JMP* for more information about the following options:

- **Local Data Filter**  Shows or hides the local data filter that enables you to filter the data used in a specific report.
- **Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.
- **Platform Preferences**  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.
- **Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.
- **Save By-Group Script**  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Type 1 Gauge Analysis Report Options

Each Type 1 Gauge Analysis report red triangle menu contains the following options:

- **Summary and Capability Statistics**  Shows or hides the Type 1 Gauge Summary and Capability Statistics table for the corresponding response. See “Summary and Capability Statistics Table”.
- **Run Chart**  Shows or hides the run chart of the measurement data for the corresponding response. See “Run Chart”.
- **Bias Test**  Shows or hides the results from the bias test. This is a two-sided *t* test that tests the mean of the observed measurements against the reference standard.
Histogram  Shows or hides a histogram of the measurement data. This is useful for checking the normality of the measurements. The Histogram red triangle menu contains the following options:

Show Reference  Shows or hides a reference line of the reference standard value on the histogram. There reference line is shown by default.

Show Count Axis  Shows or hides a count axis to the right of the histogram frame.
Variability gauge charts analyze continuous measurements and can reveal how your measurement system is performing. You can also perform a gauge study to see measures of variation in your data.

**Tip:** This chapter covers only variability charts. For more information about attribute charts, see “Attribute Gauge Charts”.

**Figure 6.1** Example of a Variability Chart
# Contents

- Overview of Variability Charts ................................................................. 153
- Example of a Variability Chart ................................................................. 154
- Launch the Variability Gauge Chart Platform ........................................... 155
  - Data Format ......................................................................................... 157
- The Variability Gauge Report ................................................................. 157
- Variability Gauge Platform Options ......................................................... 159
- Variability Gauge Analysis Report Options ............................................. 159
  - Heterogeneity of Variance Tests ......................................................... 162
  - Variance Components ........................................................................ 163
  - About the Gauge R&R Method ......................................................... 165
  - Gauge R&R Report ........................................................................... 166
  - Misclassification Probabilities ......................................................... 168
  - Bias Report ....................................................................................... 169
  - Linearity Study .................................................................................. 170
- Additional Examples of Variability Charts ............................................. 171
  - Example of the Heterogeneity of Variance Test ................................. 171
  - Example of the Bias Report and Linearity Study ............................... 173
- Statistical Details for Variability Charts ............................................... 176
  - Statistical Details for Variance Components ..................................... 176
  - Statistical Details for the Discrimination Ratio ................................... 177
  - Statistical Details for the Misclassification Probabilities .................... 178
Overview of Variability Charts

Just as a control chart shows variation across time in a process, a variability chart shows the same type of variation across categories such as parts, operators, repetitions, and instruments. A variability chart plots the data and means for each level of grouping factors, with all plots side by side. Along with the data, you can view the mean, range, and standard deviation of the data in each category, seeing how they change across the categories. The report options are based on the assumption that the primary interest is how the mean and variance change across the categories.

Variability charts are commonly used for measurement systems analysis such as Gauge R&R. This analysis examines how much of the variability is due to operator variation (reproducibility) and measurement variation (repeatability). Gauge R&R is available for many combinations of crossed and nested models, regardless of whether the model is balanced.

**Tip:** The traditional name for a variability chart is a *multi vari* chart, but because that name is not well known, the more generic term variability chart is used instead.
Example of a Variability Chart

In this example, you want to identify the variation between three operators that each took three measurements of ten parts.

1. Select Help > Sample Data Folder and open Variability Data/2 Factors Crossed.jmp.
2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.
3. For Chart Type, select Variability.
5. Select Operator and click X, Grouping.
6. Select part# and click Part, Sample ID.
7. Click OK.
8. Click the Variability Gauge Analysis for Measurement red triangle and select Show Group Means and Connect Cell Means.

Figure 6.2 Example of a Variability Chart
Chapter 6
Variability Gauge Charts

Looking at the Std Dev chart, you can see that Cindy and George have more variation in their measurements than Tom, who appears to be measuring parts the most consistently. George seems to have the most variation in his measurements, so he might be measuring parts the most inconsistently.

Launch the Variability Gauge Chart Platform

Launch the Variability Chart platform by selecting Analyze > Quality and Process > Variability/Attribute Gauge Chart. Set the Chart Type to Variability.

Figure 6.3 The Variability Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using JMP.

Chart Type Choose between a variability gauge analysis (for a continuous response) or an attribute gauge analysis (for a categorical response, usually “pass” or “fail”).

Note: The content in this chapter covers only the Variability chart type. For more information about the Attribute chart type, see “Attribute Gauge Charts”.

Model Type Choose the model type (Main Effect, Crossed, Nested, Crossed then Nested or Nested then Crossed). See “Statistical Details for Variance Components”.

Launch the Variability Gauge Chart Platform

Looking at the Std Dev chart, you can see that Cindy and George have more variation in their measurements than Tom, who appears to be measuring parts the most consistently. George seems to have the most variation in his measurements, so he might be measuring parts the most inconsistently.
Options  Contains the following options:

 Sigma Multiplier  Specifies the sigma multiplier used in the analyses. The default value is 6.

 Specify Alpha Level  Specifies the significance level used in the analyses.

 Set Random Seed  Enables you to set a specific random seed.

 Analysis Settings  Enables you to specify the method for computing variance components. See “Analysis Settings”.

 Show MSA Metadata Entry Dialog  Specifies if the MSA Metadata dialog is shown after you click OK. This dialog enables you to load the metadata from a data table or enter the metadata for each column manually. Use the following options to enter the metadata manually:

 Choose Tolerance Entry Type  Choose to enter the tolerance range directly or specify the lower and upper tolerance values. If you choose to enter lower and upper tolerance values, the tolerance range is calculated as the difference between the upper and lower tolerance values. If only one tolerance value is entered, the tolerance range cannot be calculated and any statistics in the report that rely on the tolerance range are not shown.

 Tolerance Range  Specifies the tolerance for the process, which is the difference between the upper specification limits and the lower specification limits.

 Lower Tolerance  Specifies the lower tolerance limit. This is used to calculate the tolerance range if it is not specified directly.

 Upper Tolerance  Specifies the upper tolerance limit. This is used to calculate the tolerance range if it is not specified directly.

 Historical Mean  Specifies a historical mean. The historical mean is used to compute tolerance ranges for one-sided specification limits, either USL-Historical Mean or Historical Mean-LSL. If you do not enter a historical mean, the grand mean is used.

 Historical Process Sigma  Specifies a historical process sigma. This value is used for calculations in the Gauge R&R Report and the Linearity Study.

 Tip: This data can also be specified prior to launching by applying the MSA column property. You can apply the MSA column property to several measurement columns at once using Manage Limits. See “Manage Limits”.

 Use spec limits for lower and upper tolerance  If a tolerance range is not specified for a column, but the column has a Spec Limits column property, this option uses the specification limits to calculate the tolerance range.
Y, Response  Specifies the measurement column. Specifying more than one Y column produces a separate variability chart for each response.

Standard  Specifies a standard or reference column that contains the “true” or known values for the measured part. Including this column enables the Bias and Linearity Study options. These options perform analysis on the differences between the observed measurement and the reference or standard value. See “Bias Report” and “Linearity Study”.

X, Grouping  Specify the classification columns that group the measurements. If the factors form a nested hierarchy, specify the higher terms first. If you are doing a gauge study, specify the operator first and then the part.

Freq  Identifies the data table column whose values assign a frequency to each row. Can be useful when you have summarized data.

Part, Sample ID  Identifies the part or sample that is being measured.

By  Identifies a column that creates a report consisting of separate analyses for each level of the variable.

Data Format

To use the Variability Chart platform, all response measurements must be in a single response column. Sometimes, responses are recorded in multiple columns, where each row is a level of a design factor and each column is a level of a different design factor. Data that are in this format must be stacked before running the Variability Chart platform. See Using JMP.

The Variability Gauge Report

The Variability Gauge report contains a Variability Gauge Analysis report for each response column that was specified in the launch window. By default, there are two charts in each Variability Gauge Analysis report. The measurement variability chart and the standard deviation chart show patterns of variation. You can use these charts to identify possible groups of variation (within subgroups, between subgroups, over time). If you notice that any of these sources of variation are large, you can then work to reduce the variation for that source.
The charts show the response on the $y$-axis and a multilevel, categorized $x$-axis.

In Figure 6.4, the Measurement chart shows the range of measurements for each operator by part. Each measurement appears on the chart. Maximum and minimum bars indicate the range of values for each cell, and a cell means bar indicates the median value for each combination of values. The Std Dev chart plots the standard deviation of the measurements taken on each part by operator.

You can add features to the charts, as illustrated in Figure 6.4. See “Variability Gauge Platform Options”.

To replace variables in charts, do one of the following:

- Swap existing variables by dragging a variable from one axis label to the other axis label. When you drag a variable over a chart or click an axis label, the axis labels are highlighted. This indicates where to drop the variable.
- Click a variable in the Columns panel of the associated data table and drag it onto an axis label.

In other platforms, rows that are excluded in the associated data table still appear on the charts or plots. However, in variability charts, excluded rows do not appear on the charts.
Variability Gauge Platform Options

The Variability Gauge red triangle menu contains the following options:

**Save**  Shows a submenu of the following options:

- **Save Metadata as Column Properties**  (Not available if a By variable is specified in the launch window.) Saves the metadata as column properties in the original data table. This includes the measurement sigma, which is saved in the Process Screening column property. The measurement sigma is the square root of the total of all variance components subtracted by the part variance.

- **Save All Metadata to Table**  Saves a new data table that contains the metadata for each column. This includes the measurement sigma, which is used in the Process Screening platform. The measurement sigma is the square root of the total of all variance components subtracted by the part variance. If there is a By variable, a table is saved for each level of the By variable and the table name includes the level.

See *Using JMP* for more information about the following options:

- **Local Data Filter**  Shows or hides the local data filter that enables you to filter the data used in a specific report.

- **Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

- **Platform Preferences**  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

- **Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

- **Save By-Group Script**  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Variability Gauge Analysis Report Options

Each Variability Gauge Analysis report red triangle menu contains options to modify the appearance of the chart, perform Gauge R&R analysis, and compute variance components.

- **Vertical Charts**  Changes the layout to horizontal or vertical.
Variability Gauge Charts

Chapter 6
Variability Gauge Analysis Report Options

Quality and Process Methods

**Variability Chart**  Shows or hides the variability chart.

**Show Points**  Shows or hides the points for individual rows.

**Show Range Bars**  Shows or hides the bars indicating the minimum and the maximum value of each cell.

**Show Cell Means**  Shows or hides the mean mark for each cell.

**Connect Cell Means**  Connects or disconnects cell means within a group of cells.

**Show Separators**  Shows or hides the separator lines between levels of the X, Grouping variables.

**Show Group Means**  (Available only if you have two or more X, Grouping variables or one X, Grouping variable and one Part, Sample ID variable.) Shows or hides the mean for groups of cells, represented by a horizontal solid line. A window appears, prompting you to select one of the grouping variables.

**Show Grand Mean**  Shows or hides the overall mean, represented by a gray dotted line across the entire graph.

**Show Grand Median**  Shows or hides the overall median, represented by a blue dotted line across the entire graph.

**Show Box Plots**  Shows or hides box plots.

**Mean Diamonds**  Shows or hides mean diamonds. The confidence intervals use the within-group standard deviation for each cell.

**XBar Control Limits**  Shows or hides lines at the UCL and LCL on the variability chart. For more information about the calculations of these limits, see “Statistical Details for Control Chart Builder”.

**Points Jittered**  Adds some random noise to the plotted points so that coincident points do not plot on top of one another.

**Show Standard Mean**  (Available only if you have specified a Standard variable.) Shows or hides the mean of the standard column.

**Variability Summary Report**  Shows or hides a report that gives the mean, standard deviation, coefficient of variation (CV), standard error of the mean, lower and upper confidence intervals, and the minimum, maximum, and number of observations.

**Std Dev Chart**  Shows or hides a separate graph that shows cell standard deviations across category cells.

**Mean of Std Dev**  Shows or hides a line at the mean standard deviation on the Std Dev chart.
**S Control Limits**  Shows or hides lines showing the LCL and UCL in the Std Dev chart. For more information about the calculations of these limits, see “Statistical Details for Control Chart Builder”.

**Group Means of Std Dev**  Shows or hides the mean lines on the Std Dev chart.

**Heterogeneity of Variance Tests**  Performs a test for comparing variances across groups. See “Heterogeneity of Variance Tests”.

**Variance Components**  Estimates the variance components for a specific model. Variance components are computed for these models: main effects, crossed, nested, crossed then nested (three factors only), and nested then crossed (three factors only). See “Variance Components”.

**Gauge Studies**  Contains the following options:

- **Gauge R&R**  Interprets the first factors as grouping columns and the last factor as Part, and creates a gauge R&R report using the estimated variance components. (Note that there is also a Part field in the launch window). See “Gauge R&R Report”.

  If you select the Gauge R&R option and you have not already selected a model type or entered MSA metadata, you are prompted to do so. If you want to modify your metadata specifications, click the Variability Gauge Analysis red triangle and select **Gauge Studies > Edit MSA Metadata**. See “Show MSA Metadata Entry Dialog”.

  **Note:** The Platform preferences for Variability include the Gauge R&R Specification Dialog option. The preference is selected by default. Deselect the preference to use the spec limits that are defined in the data table.

- **Discrimination Ratio**  Shows or hides the Discrimination Ratio report. The discrimination ratio compares the total variance of the measurement with the variance of the measurement error and characterizes the relative usefulness of a given measurement for a specific product. Generally, when the discrimination ratio is less than 2, the measurement cannot detect product variation, implying that the measurement process needs improvement. A discrimination ratio greater than 4 adequately detects unacceptable product variation, implying that the production process needs improvement. See “Statistical Details for the Discrimination Ratio”.

- **Misclassification Probabilities**  (Available only if lower and upper tolerance values are specified for the response in the MSA Metadata.) Shows or hides a report of probabilities for rejecting good parts and accepting bad parts. See “Misclassification Probabilities”.

- **Bias Report**  (Available only if a Standard column is specified in the launch window.) Shows the average difference between the observed values and the standard. A graph of the average biases and a summary table appears. See “Bias Report”.
**Linearity Study**  (Available only if a Standard column is specified in the launch window.) Performs a regression using the standard values as the X variable and the bias as the Y variable. This analysis examines the relationship between bias and the size of the part. A nonzero slope indicates that your gauge performs differently with different sized parts. See “Linearity Study”.

**Gauge R&R Plots**  Shows or hides Mean Plots (the mean response by each main effect in the model) and Std Dev plots. If the model is purely nested, the graphs appear with a nesting structure. If the model is purely crossed, interaction graphs appear. Otherwise, the graphs plot independently at each effect. For the standard deviation plots, the red lines connect $\sqrt{\text{mean weighted variance}}$ for each effect.

**Edit MSA Metadata**  Opens a window that enables you to add or edit the tolerance range, tolerance limits, historical mean, and historical process sigma. See “Show MSA Metadata Entry Dialog”.

**AIAG Labels**  Enables you to specify that quality statistics should be labeled in accordance with the AIAG standard, which is used extensively in automotive analyses.

### Heterogeneity of Variance Tests

In the Variability Chart platform, the Heterogeneity of Variance Tests option performs a test for comparing variances across groups. The test is an Analysis of Means for Variances (ANOMV) based method. This method indicates whether any of the group standard deviations are different from the square root of the average group variance. For an example, see “Example of the Heterogeneity of Variance Test”.

To be robust against non-normal data, the method uses a permutation simulation to compute decision limits. For more information about this method, see Wludyka and Sa (2004). Because the method uses simulations, the decision limits can be slightly different each time. To obtain the same results each time, assign a random seed in the launch window.

The red triangle menus for the test reports contain the following options:

**Set Alpha Level**  Sets the alpha level for the test.

**Show Summary Report**  Shows or hides a summary report for the test. The values in the report are the same values that are shown in the plot.

**Display Options**  Enables you to show or hide the decision limits, decision limit shading, and center line. There are also points options that you can use to show needles, show connected points, or show only points.
Variance Components

In the Variability Chart platform, the Variance Components option models the variation from measurement to measurement. The response is assumed to be a constant mean plus random effects associated with various levels of the classification.

Note: Once you select the Variance Components option, if you did not select the Model Type in the launch window (if you selected Decide Later), you are prompted to select the model type. For more information about model types, see “Launch the Variability Gauge Chart Platform”.

Figure 6.5 Example of the Variance Components Report

The Analysis of Variance report appears only if the EMS method of variance component estimation is used. This report shows the significance of each effect in the model.

The Variance Components report shows the estimates themselves. See “Statistical Details for Variance Components”.

Analysis Settings

From the launch window, click Analysis Settings to choose the method for computing variance components.
Choose best analysis (EMS, REML, or Bayesian)  Chooses the best analysis from EMS, REML, or Bayesian, using the following logic:

- If the data are balanced, and if no variance components are negative, the EMS (expected mean squares) method is used to estimate the variance components.
- If the data are unbalanced, the REML (restricted maximum likelihood) method is used, unless a variance component is estimated to be negative, then the Bayesian method is used.
- If any variance component is estimated to be negative using the EMS method, the Bayesian method is used.
- If there is confounding in the variance components, then the bounded REML method is used, and any negative variance component estimates are set to zero.

Choose best analysis (EMS or REML)  Chooses the best analysis from EMS or REML, using the same logic as the Choose best analysis (EMS, REML, or Bayesian) option. However, this option never uses the Bayesian method, even for negative variance components. The bounded REML method is used and any negative variance component is forced to be 0.

Use REML analysis  Uses the bounded REML method, even if the data are balanced. The bounded REML method can handle unbalanced data and forces any negative variance component to be 0.

Use Bayesian analysis  Uses the Bayesian method. The Bayesian method can handle unbalanced data and forces all variances components to be positive and nonzero. If there is confounding in the variance components, then the bounded REML method is used, and any negative variance component estimates are set to zero. The method implemented in JMP computes the posterior means using a modified version of Jeffreys’ prior. See Portnoy (1971) and Sahai (1974).

Maximum Iterations  (Applicable only for the REML method.) For difficult problems, you might want to increase the number of iterations. Increasing this value means that JMP will try more times to find a solution in the optimization phase.

Convergence Limit  (Applicable only for the REML method.) For problems where you want greater precision, you might want to change the convergence limit to be smaller.
Decreasing this value means that JMP will find the solution to a higher level of accuracy in the optimization phase. However, this can increase the time taken to find a solution. Providing a larger convergence value returns quicker results, but is less precise.

**Number of Iteration Abscissas**  (Applicable only for the Bayesian method.) For greater accuracy, you might want to increase the number of iteration abscissas. However, this can increase the time taken to find a solution. Providing a smaller number returns quicker results, but is less precise.

**Maximum Number of Function Evaluations**  (Applicable only for the Bayesian method.) For greater accuracy, you might want to increase the maximum number of function evaluations. However, this can increase the time taken to find a solution. Providing a smaller number returns quicker results, but is less precise.

### About the Gauge R&R Method

The Gauge R&R method analyzes how much of the variability in your measurement system is due to operator variation (reproducibility) and measurement variation (repeatability). Gauge R&R studies are available for many combinations of crossed and nested models, regardless of whether the model is balanced.

**Tip:** Alternatively, you can use the EMP method to assess your measurement system. See “Measurement Systems Analysis”.

Before performing a Gauge R&R study, you collect a random sample of parts over the entire range of part sizes from your process. Select several operators at random to measure each part several times. The variation is then attributed to the following sources:

- The process variation, from one part to another. This is the ultimate variation that you want to be studying if your measurements are reliable.
- The variability inherent in making multiple measurements, that is, repeatability. In Table 6.1, this is called the within variation.
- The variability due to having different operators measure parts—that is, reproducibility.

A Gauge R&R analysis then reports the variation in terms of repeatability and reproducibility.

### Table 6.1  Definition of Terms and Sums in Gauge R&R Analysis

<table>
<thead>
<tr>
<th>Variance/Sum</th>
<th>Term and Abbreviation</th>
<th>Alternate Term</th>
</tr>
</thead>
<tbody>
<tr>
<td>V(Within)</td>
<td>Repeatability (EV)</td>
<td>Equipment Variation</td>
</tr>
</tbody>
</table>
Variability Gauge Charts
Variability Gauge Analysis Report Options

A Shewhart control chart can identify processes that are going out of control over time. A variability chart can also help identify operators, instruments, or part sources that are systematically different in mean or variance.

### Gauge R&R Report

In the Variability Chart platform, the Gauge R&R report shows measures of variation interpreted for a gauge study of operators and parts. There is a full version of the Gauge R&R report and a reduced version. To generate the reduced Gauge R&R report, select **File > Preferences > Platforms > Variability Chart > Reduced Gauge R&R Report.**

---

### Table 6.1 Definition of Terms and Sums in Gauge R&R Analysis (Continued)

<table>
<thead>
<tr>
<th>Variances Sums</th>
<th>Term and Abbreviation</th>
<th>Alternate Term</th>
</tr>
</thead>
<tbody>
<tr>
<td>V(Operator)+V(Operator*Part)</td>
<td>Reproducibility</td>
<td>Appraiser Variation</td>
</tr>
<tr>
<td></td>
<td>(AV)</td>
<td></td>
</tr>
<tr>
<td>V(Operator*Part)</td>
<td>Interaction (IV)</td>
<td>Interaction Variation</td>
</tr>
<tr>
<td>V(Within)+V(Operator)+V(Operator*Part)</td>
<td>Gauge R&amp;R (RR)</td>
<td>Measurement Variation</td>
</tr>
<tr>
<td>V(Within)+V(Operator)+V(Operator*Part)+V(Part)</td>
<td>Total Variation (TV)</td>
<td>Total Variation</td>
</tr>
<tr>
<td>V(Part)</td>
<td>Part Variation (PV)</td>
<td>Part Variation</td>
</tr>
<tr>
<td>V(Within)+V(Operator)+V(Operator*Part)+V(Part)</td>
<td>Total Variation (TV)</td>
<td>Total Variation</td>
</tr>
</tbody>
</table>
Figure 6.7 Example of the Full Gauge R&R Report

<table>
<thead>
<tr>
<th>Measurement Source</th>
<th>Variation (k*StdDev)</th>
<th>% of Tolerance</th>
<th>% Process</th>
<th>which is 6*sqrt of</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repeatability (EV)</td>
<td>0.3860052</td>
<td>77.20</td>
<td>33.23</td>
<td>V(Within)</td>
</tr>
<tr>
<td>Reproducibility (AV)</td>
<td>0.4568005</td>
<td>91.36</td>
<td>39.47</td>
<td>V(Operator) + V(Operator*part#)</td>
</tr>
<tr>
<td>Operator</td>
<td>0.0680194</td>
<td>17.76</td>
<td>7.67</td>
<td>V(Operator)</td>
</tr>
<tr>
<td>Operator*part#</td>
<td>0.4406823</td>
<td>89.62</td>
<td>38.71</td>
<td>V(Operator*part#)</td>
</tr>
<tr>
<td>Gauge R&amp;R</td>
<td>0.5983054</td>
<td>119.61</td>
<td>51.67</td>
<td>V(Within) + V(Operator) + V(Operator*part#)</td>
</tr>
<tr>
<td>Part Variation (PV)</td>
<td>1.0423929</td>
<td>208.02</td>
<td>90.08</td>
<td>V(part#)</td>
</tr>
<tr>
<td>Total Variation</td>
<td>1.2019429</td>
<td>240.39</td>
<td>103.85</td>
<td>Total Variation</td>
</tr>
</tbody>
</table>

Summary and Gauge R&R Statistics:

6 * k
49.7571 % Gauge R&R = 100*(RR/TV)
0.57362 Precision to Part Variation = RR/PV
2 Number of Distinct Categories = Floor(sqrt(2)*(PV/RR))
0.5 Lower Tolerance (LT)
1 Upper Tolerance (UT)
0.5 Tolerance = UT-LT
1.1961 Precision/Tolerance Ratio = RR/(UT-LT)
0.1929 Historical Process Sigma

Using last column ‘part#’ for Part.

Figure 6.8 Example of the Reduced Gauge R&R Report

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Variation (k*StdDev)</th>
<th>% of Tolerance</th>
<th>% Process</th>
<th>which is 6*sqrt of</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operator*part#</td>
<td>0.4480823</td>
<td>89.82</td>
<td>36.71</td>
<td>V(Operator*part#)</td>
</tr>
<tr>
<td>Repeatability (EV)</td>
<td>0.3860052</td>
<td>77.20</td>
<td>33.35</td>
<td>V(Within)</td>
</tr>
<tr>
<td>Reproducibility (AV)</td>
<td>0.4568005</td>
<td>91.36</td>
<td>39.47</td>
<td>V(Operator) + V(Operator*part#)</td>
</tr>
<tr>
<td>Gauge R&amp;R</td>
<td>0.5983054</td>
<td>119.61</td>
<td>51.67</td>
<td>V(Within) + V(Operator) + V(Operator*part#)</td>
</tr>
<tr>
<td>Part Variation (PV)</td>
<td>1.0423929</td>
<td>208.02</td>
<td>90.08</td>
<td>V(part#)</td>
</tr>
<tr>
<td>Total Variation</td>
<td>1.2019429</td>
<td>240.39</td>
<td>103.85</td>
<td>Total Variation</td>
</tr>
</tbody>
</table>

Summary and Gauge R&R Statistics:

6 * k
49.7571 % Gauge R&R = 100*(RR/TV)
0.57362 Precision to Part Variation = RR/PV
2 Number of Distinct Categories = Floor(sqrt(2)*(PV/RR))
0.5 Lower Tolerance (LT)
1 Upper Tolerance (UT)
0.5 Tolerance = UT-LT
1.1961 Precision/Tolerance Ratio = RR/(UT-LT)
0.1929 Historical Process Sigma

The table in the Gauge R&R report contains the following information:

Measurement Source  Defines the source of measurement for the variation.

Variation (k*StdDev)  The square roots of sums of variance components scaled by the value of the sigma multiplier, k.

% of Tolerance  (Available only if you specified a tolerance range or lower and upper tolerance values.) Provides the % of tolerance computed as 100*(Variation/Tolerance).
% Process  (Available only if you specified a historical process sigma.) Provides the % of process computed as 100*(Variation/(K*Historical Sigma)).

which is k*sqrt of  The descriptions of how the variance component sums are calculated.

Note:  To add columns to the Gauge R&R report, right-click on the column heading and select Columns.

The Gauge R&R report also contains a Summary and Gauge R&R statistics section. This includes specified values, summaries, and other statistics. If you specified a tolerance range or lower and upper tolerance values, a Precision-to-Tolerance ratio is included in this section. This ratio represents the proportion of the tolerance or capability interval that is lost due to gauge variability. The % Gauge R&R value is also shown in this section, which is the percentage of the total variation that is made up by the measurement variation. Table 6.2 shows guidelines for the percent measurement variation, as suggested by Barrentine (1991).

Table 6.2  Acceptable Percent Measurement Variation

<table>
<thead>
<tr>
<th>&lt; 10%</th>
<th>excellent</th>
</tr>
</thead>
<tbody>
<tr>
<td>11% to 20%</td>
<td>adequate</td>
</tr>
<tr>
<td>21% to 30%</td>
<td>marginally acceptable</td>
</tr>
<tr>
<td>&gt; 30%</td>
<td>unacceptable</td>
</tr>
</tbody>
</table>

Variance Components for Gauge R&R

The Variance Components for Gauge R&R table in the Gauge R%R report contains the difference variance components from the model. These are the variance components used to compute that variation in the initial table of the Gauge R&R report.

Misclassification Probabilities

In the Variability Chart platform, you can analyze observations that have been misclassified based on the lower and upper tolerance limits. When you select the Misclassification Probabilities option, you are prompted to select the model type if you have not already done so.
Figure 6.9 Example of the Misclassification Probabilities Report

The misclassification probabilities are based on the joint probability function of $Y$, the measured value of the part, and $X$, the true value of the part. The joint probability density function used is a bivariate normal distribution. To understand the descriptions, define the following probabilities:

$$
\delta = P[(LSL \leq X \leq USL) \text{ and } (Y < LSL \text{ or } Y > USL)]
$$

$$
\beta = P[(X < LSL \text{ or } X > USL) \text{ and } (LSL \leq Y \leq USL)]
$$

$$
\pi = P(LSL \leq X \leq USL)
$$

**Descriptions**

- **$P$(Good part is falsely rejected)**
  The conditional probability that a part is rejected given that it is a good part, or $\delta/\pi$.

- **$P$(Bad part is falsely accepted)**
  The conditional probability that a part is accepted given that it is a bad part, or $\beta/(1-\pi)$.

- **$P$(Part is good and is rejected)**
  The joint probability that a part is good and that it is rejected, or $\delta$.

- **$P$(Part is bad and is accepted)**
  The joint probability that a part is bad and that it is accepted, or $\beta$.

- **$P$(Part is good)**
  The probability that a part is good, or $\pi$.

For more information, see “Statistical Details for the Misclassification Probabilities” as well as Burdick et al. (2005).

**Bias Report**

In the Variability Chart platform, the Bias Report option shows a graph for Overall Measurement Bias with a summary table and a graph for Measurement Bias by Standard with a summary table. The average bias, or the differences between the observed values and the standard values, appears for each level of the $X$ variable. A $t$ test for the bias is also given.

The Bias Report option is available only when a Standard variable is provided in the launch window.
The Measurement Bias Report red triangle menu contains the following options:

**Confidence Intervals**  Calculates confidence intervals for the average bias for each part and places marks on the Measurement Bias Report by Standard plot.

**Measurement Error Graphs**  Produces a graph of Measurement Error versus all grouping columns together. There are also graphs of Measurement Error by each grouping column separately.

### Linearity Study

In the Variability Chart platform, the Linearity Study option performs a regression analysis using the standard variable as the X variable and the bias as the Y variable. This analysis examines the relationship between bias and the size of the part. If the slope is significantly different from zero, you can conclude that there is a significant relationship between the size of the part or variable measured as a standard and the ability to measure.

The Linearity Study option is available only when a Standard variable is provided in the launch window. To obtain a complete results report, you also need to specify values for the sigma multiplier and the historical process sigma. These values are multiplied to calculate the Process Variation. The sigma multiplier is specified in the launch window. There are several ways to specify the historical process sigma.

- Prior to analysis, you can assign the MSA column property to the response and specify the historical process sigma in the column property.
- In the launch window, you can specify the historical process sigma by selecting the Show MSA Metadata Entry Dialog.
- In the report window, you can click the Variability Gauge Analysis red triangle and select Gauge Studies > Edit MSA Metadata.
- You can directly specify the historical process sigma in a script.

The Linearity Study report shows the following information:

- Bias summary statistics for each standard.
- An ANOVA table that tests if the slope of the line is equal to zero.
- The line parameters, including tests for the slope (linearity) and intercept (bias). The test for the intercept is useful only if the test on the slope fails to reject the hypothesis of slope = 0.
- A table that contains the values for Process Variation, Linearity, % Linearity, Overall Avg Bias, % Bias, and Alpha.
- The equation of the line appears directly beneath the graph, along with the R Squared value.

The Linearity Study red triangle menu contains the following options:
Set Alpha Level  Changes the alpha level that is used in the bias confidence intervals.

Linearity by Groups  Produces separate linearity plots for each level of the X, Grouping variables that you specified in the launch window.

Show Bias Points  Shows or hides the bias points on the graph.

Show Line of Fit  Shows or hides the line of fit on the graph.

Show Fit Confidence Curves  Shows or hides the line of fit confidence curves on the graph.

Show Overall Avg Bias Line  Shows or hides the overall average bias line on the graph.

Show Avg Bias Points  Shows or hides the average bias points on the graph.

Additional Examples of Variability Charts

This section contains examples using the Variability Chart platform.

- “Example of the Heterogeneity of Variance Test”
- “Example of the Bias Report and Linearity Study”

Example of the Heterogeneity of Variance Test

Use the Variability Chart platform to test if the variances of different groups are statistically different. In this example, three operators each took three measurements of ten parts, for a total of 90 observations. You want to examine the following:

- whether the variance of measurements for each operator are the same or different
- whether the variance for each part is the same or different
- whether the variance for each Operator*part combination is the same or different

1. Select Help > Sample Data Folder and open Variability Data/2 Factors Crossed.jmp.
2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.
4. Select Operator and click X, Grouping.
5. Select part# and click Part, Sample ID.
6. (Optional) Enter 1234 next to Set Random Seed.
7. Click OK.
8. Click the Variability Gauge Analysis for Measurement red triangle and select Heterogeneity of Variance Tests.
9. Select **Crossed**.

10. Click **OK**.

**Figure 6.10** Heterogeneity of Variances Tests Report
In the Operator Variance test, all three levels exceed the upper and lower decision limits. From this, you conclude that each operator has a different variability from the square root of the average group variance. You might want to examine why the variation between each operator is different.

For the part# Variance test and the interaction (Operator*part#) Variance test, none of the levels exceed the decision limits. From this, you conclude that the variances are not statistically different from the square root of the average group variance. Each part has a similar variance to the other parts, and each Operator*part# combination has similar variance to the other Operator*part# combinations.

**Example of the Bias Report and Linearity Study**

Use the Variability Chart platform to evaluate the bias and linearity of a new measurement system. Five parts were chosen throughout the operating range of the measurement system, based on documented process variation. Each part was measured by layout inspection to determine its reference value. Each part was then measured twelve times by the lead operator. The parts were selected at random during the day.

**Bias Report**

Use the Bias Report option to examine the overall and individual measurement bias.

1. Select Help > Sample Data Folder and open Variability Data/MSALinearity.jmp.
2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.
3. For Chart Type, select Variability.
4. Check that the value for the Sigma Multiplier is 6.
5. Select Response and click Y, Response.
7. Select Part and click X, Grouping.
8. Click OK.
9. Click the Variability Gauge Analysis for Response red triangle and select Gauge Studies > Bias Report.
The bias (Response minus Standard) is calculated for every measurement. The Overall Measurement Bias Report shows a histogram of the bias and a t test to see whether the average bias is equal to 0. You can see that the Average Bias is not zero, it is -0.0533. However, zero is contained within the confidence interval (-0.1152, 0.0085), which means that the Average Bias is not significantly different from 0. Using a significance level of 0.05, you can see that the p-value is greater than 0.05, which also shows that the Average Bias is not significantly different from 0.

The Measurement Bias Report by Standard shows average bias values for each part. The bias averages are plotted on the graph along with the actual bias values for every part, so that you can see the spread. In this example, part number 1 (with a standard value of 2) is biased high and parts 4 and 5 (with standard values of 8 and 10) are biased low.

**Tip:** To see confidence intervals for the bias, right-click in the table and select **Columns > Lower 95%** and **Columns > Upper 95%**.
Linearity Study

Use the Linearity Study option to determine whether there is a significant relationship between the size of the parts and the operator’s ability to measure them. First, you must specify a historical process sigma.

1. Click the Variability Gauge Analysis for Response red triangle and select **Gauge Studies > Edit MSA Metadata**.
2. In the Edit MSA Metadata window, enter 2.488105 as the value for the Historical Process Sigma. This is the standard deviation of the response. The Historical Process Sigma is used to calculate the Process Variation.
3. Click **OK**.
4. Click the Variability Gauge Analysis for Response red triangle and select **Gauge Studies > Linearity Study**.

**Figure 6.12** Linearity Study

![Linearity Study graph](image)

Note the following:

- The slope is -0.131667. This value appears as part of the equation below the graph, and also in the third table.
- The p-value associated with the test on the slope is quite small, <.0001. The t test for the slope is testing whether the bias changes with the standard value.

Because the p-value is small, you can conclude that there is a significant linear relationship between the size of the parts and the operator’s ability to measure them. You can also see this in the graph. If the part or standard value is small, the bias is high, and vice versa.
Statistical Details for Variability Charts

This section contains statistical details for the Variability Chart platform.

- “Statistical Details for Variance Components”
- “Statistical Details for the Discrimination Ratio”
- “Statistical Details for the Misclassification Probabilities”

Statistical Details for Variance Components

The exact model type that you choose in the Variability Chart platform depends on how the data were collected. For example, if the operators are measuring the same parts, you have a crossed design. If they measuring different parts, you have a nested design. To illustrate, in a model where $B$ is nested within $A$, multiple measurements are nested within both $B$ and $A$, and there are $na \times nb \times nw$ measurements, the following statements hold:

- $na$ random effects are due to $A$
- $na \times nb$ random effects due to each $nb$ $B$ levels within $A$
- $na \times nb \times nw$ random effects due to each $nw$ levels within $B$ within $A$:

$$y_{ijk} = u + Za_i + Zb_{ij} + Zw_{ijk}.$$ 

The $Z$s are the random effects for each level of the classification. Each $Z$ is assumed to have a mean of zero and to be independent from all other random terms. The variance of the response $y$ is the sum of the variances due to each $z$ component:

$$\text{Var}(y_{ijk}) = \text{Var}(Za_i) + \text{Var}(Zb_{ij}) + \text{Var}(Zw_{ijk}).$$

Table 6.3 shows the supported models and what the effects in the model would be.

<table>
<thead>
<tr>
<th>Model</th>
<th>Factors</th>
<th>Effects in the Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main Effects</td>
<td>1</td>
<td>A</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>A, B</td>
</tr>
<tr>
<td></td>
<td>unlimited</td>
<td>and so on, for more factors</td>
</tr>
</tbody>
</table>
Statistical Details for the Discrimination Ratio

In the Variability Chart platform, the discrimination ratio compares the total variance of the measurement, $M$, with the variance of the measurement error, $E$. The discrimination ratio is computed for all main effects, including nested main effects. The discrimination ratio, $D$, is computed as follows:

$$D = \sqrt[N]{2\left(\frac{P}{T-P}\right) + 1}$$

where:

$P$ = estimated variance for a factor

$T$ = estimated total variance

**Table 6.3** Models Supported by the Variability Charts Platform

(Continued)

<table>
<thead>
<tr>
<th>Model</th>
<th>Factors</th>
<th>Effects in the Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crossed 1</td>
<td>1</td>
<td>A</td>
</tr>
<tr>
<td>Crossed 2</td>
<td>2</td>
<td>A, B, A*B</td>
</tr>
<tr>
<td>Nested 1</td>
<td>1</td>
<td>A</td>
</tr>
<tr>
<td>Nested 2</td>
<td>2</td>
<td>A, B(A)</td>
</tr>
<tr>
<td>Nested 3</td>
<td>3</td>
<td>A, B(A), C(A,B)</td>
</tr>
<tr>
<td>Nested 4</td>
<td>4</td>
<td>A, B(A), C(A,B), D(A,B,C)</td>
</tr>
<tr>
<td>Nested then Crossed</td>
<td>3</td>
<td>A, B, A*B, C(A,B)</td>
</tr>
<tr>
<td>Crossed then Nested</td>
<td>3</td>
<td>A, B, A<em>C, C</em>B(A)</td>
</tr>
</tbody>
</table>
Statistical Details for the Misclassification Probabilities

This section describes the computations for the probabilities in the Misclassification Probabilities report in the Variability Chart platform. The misclassification probabilities are based on the joint probability function of $Y$, the measured value of the part, and $X$, the true value of the part. The joint probability distribution function $F_{YX}(y, x)$ uses a bivariate normal distribution with mean vector $[\mu, \mu]$ and the following covariance matrix:

$$
\begin{bmatrix}
\gamma_P + \gamma_M & \gamma_P \\
\gamma_P & \gamma_P
\end{bmatrix}
$$

where $\gamma_P$ is the part-to-part variation, $\gamma_M$ is the measurement variation, and $\mu$ is the grand mean. These quantities can be found or derived from quantities in the report window. Specifically, $\gamma_P + \gamma_M$ is equal to the square of Total Variation (TV) divided by 6: $(TV/6)^2$ and $\gamma_P$ is equal to the square of Part Variation (PV) divided by 6: $(PV/6)^2$. The correlation $\rho_{YX}$ between $Y$ and $X$ is defined as the square root of $\gamma_P/(\gamma_P + \gamma_M)$.

Next, define the following probabilities:

$$
\delta = P[(LSL \leq X \leq USL) \text{ and } (Y < LSL \text{ or } Y > USL)]
$$
$$
\beta = P[(X < LSL \text{ or } X > USL) \text{ and } (LSL \leq Y \leq USL)]
$$
$$
\pi = P(LSL \leq X \leq USL)
$$

These probabilities can be expressed in terms of the joint probability distribution function $F_{YX}(y, x)$ and the marginal probability distribution functions for $Y$: $F_Y(y)$ and $F_X(x)$:

$$
\delta = F_{YX}(LSL, USL) - F_{YX}(LSL, LSL) - F_{YX}(USL, USL) + F_{YX}(USL, LSL) + F_X(USL) - F_X(LSL)
$$
$$
\beta = F_{YX}(USL, LSL) - F_{YX}(LSL, LSL) - F_{YX}(USL, USL) + F_{YX}(LSL, USL) + F_Y(USL) - F_Y(LSL)
$$
$$
\pi = F_X(USL) - F_X(LSL)
$$

$P$(Good part is falsely rejected) $= \delta/\pi$

$P$(Bad part is falsely accepted) $= \beta/(1-\pi)$

$P$(Part is good and is rejected) $= \delta$

$P$(Part is bad and is accepted) $= \beta$

$P$(Part is good) $= \pi$
Attribute charts analyze categorical measurements and can help show you measures of agreement across responses, such as raters. In attribute data, the variable of interest has a finite number of categories. Typically, data has only two possible results, such as pass or fail. You can examine aspects such as how effective raters were at classifying a part, how much they agreed with each other, and how much they agreed with themselves over the course of several ratings.

**Tip:** This chapter covers only attribute charts. For more information about variability charts, see “Variability Gauge Charts”.

**Figure 7.1** Example of an Attribute Chart
Contents

Overview of Attribute Gauge Charts ............................................................. 181
Example of an Attribute Gauge Chart ......................................................... 181
Launch the Attribute Gauge Chart Platform .............................................. 183
The Attribute Gauge Report ................................................................. 184
  Gauge Attribute Chart ............................................................................. 184
  Agreement Reports .................................................................................. 185
  Effectiveness Report ................................................................................ 187
Attribute Gauge Platform Options .......................................................... 188
Statistical Details for Attribute Gauge Charts ........................................ 190
  Statistical Details for the Gauge Attribute Chart .................................. 190
  Statistical Details for the Agreement Report ......................................... 191
Overview of Attribute Gauge Charts

Before you create an attribute gauge chart, your data should be formatted using the following guidelines:

- In order to compare agreement among raters, each rater in the data table must be in a separate column. These columns are then assigned to the Y, Response role in the launch window. In Figure 7.2, each rater (A, B, and C) is in a separate column.
- Responses in the different columns can be character (pass or fail) or numeric (0 or 1). In Figure 7.2, rater responses are numeric (0 for pass, 1 for fail). All response columns must have the same data type.
- Any other variables of interest that you might want to use as X, Grouping variables should appear stacked in one column each (see the Part column in Figure 7.2). You can also define a Standard column, which produces reports that compare raters with the standard. The Standard column and response columns must have the same data type.

Figure 7.2 Attribute Gauge Data

Example of an Attribute Gauge Chart

You want to examine how effective raters are in correctly classifying parts, and how well raters agree with each other and with themselves over the course of the ratings. In this example, three raters are indicating if a part passed (0) or failed (1) for 50 parts, three times each.

1. Select Help > Sample Data Folder and open Attribute Gauge.jmp.
2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.
3. For Chart Type, select Attribute.
4. Select A, B, and C and click **Y, Response**.
5. Select Standard and click **Standard**.
6. Select Part and click **X, Grouping**.
7. Click **OK**.

**Figure 7.3 Example of an Attribute Chart**

The first chart (Part) shows how well the raters agreed with each other for each part. For example, here you can see that the percent agreement dropped for part 6, 12, 14, 21, 22, and so on. These parts might have been more difficult to categorize.

The second chart (Rater) shows each rater’s agreement with him or herself and the other raters for a given part, summed up over all of the parts. In this example, it looks like the performance of the raters is relatively similar. Rater C had the lowest agreement, but the difference is not major (about 89% instead of 91%).

8. Open the Effectiveness Report and scroll down to the Conformance Report.

   You can see that 0 = non-conform (fail) and a 1 = conform (pass). However in this data, it is exactly the opposite: 0 is a pass and 1 is a fail. Reverse this setting.

9. Click the Conformance Report red triangle and select **Change Conforming Category**.
Launch the Attribute Gauge Chart Platform

Launch the Attribute Gauge Chart platform by selecting **Analyze > Quality and Process > Variability/Attribute Gauge Chart**. Set the **Chart Type** to **Attribute**.

For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

**Chart Type**  Choose between a variability gauge analysis (for a continuous response) or an attribute gauge analysis (for a categorical response, usually “pass” or “fail”).

**Note:** The content in this chapter covers only the Attribute chart type. For more information about the Variability chart type, see “Variability Gauge Charts”.

**Specify Alpha**  Specify the alpha level used by the platform.

**Y, Response**  Specify the columns of ratings given by each rater. You must specify more than one rating column.

**Standard**  Specify a standard or reference column that contains the “true” or known values for the part. In the report window, an Effectiveness Report and an additional section in the Agreement Comparisons report appear, which compare the raters with the standard.
**X, Grouping** Specify the classification columns that group the measurements. If the factors form a nested hierarchy, specify the higher terms first.

**Freq** Identifies the data table column whose values assign a frequency to each row. Can be useful when you have summarized data.

**By** Identifies a column that creates a report consisting of separate analyses for each level of the variable.

---

**The Attribute Gauge Report**

The Attribute Gauge report contains the Gauge Attribute Chart and several other reports.

- “Gauge Attribute Chart”
- “Agreement Reports”
- “Effectiveness Report”

**Gauge Attribute Chart**

The Gauge Attribute Chart plots the percent Agreement, which is a measurement of rater agreement for every part in the study. The agreement for each part is calculated by comparing the ratings for every pair of raters for all ratings of that part. See “Statistical Details for Attribute Gauge Charts”.
Figure 7.6 Gauge Attribute Chart

The first chart in Figure 7.6 uses all X grouping variables (in this case, the Part) on the horizontal axis. The second chart uses all Y variables on the horizontal axis (typically, and in this case, the Rater).

- In the first graph, you can look for parts with a low percent Agreement value, and investigate to determine why raters do not agree about the measurement of that particular part.
- In the second graph, you can look for raters with a low percent Agreement value, and investigate to determine why they do not agree with the other raters or with themselves.

For information about additional options, see “Attribute Gauge Platform Options”.

Agreement Reports

There are different types of Agreement reports in the Attribute Gauge Report. These include the Agreement Report, the Agreement Comparisons report, the Agreement within Raters report, the Agreement across Categories report, and the Effectiveness Report.

Note: The Kappa value is a statistic that expresses agreement. The closer the Kappa value is to 1, the more agreement there is. A Kappa value closer to 0 indicates less agreement.
The Agreement Report shows agreement summarized for each rater and overall agreement. This report is a numeric form of the data presented in the second chart in the Attribute Gauge Chart report (Figure 7.6).

The Agreement Comparisons report shows each rater compared with all other raters, using Kappa statistics. The rater is compared with the standard only if you have specified a Standard variable in the launch window.

The Agreement within Raters report shows the number of items that were inspected. The confidence intervals are score confidence intervals, as suggested by Agresti and Coull (1998). The Number Matched is the sum of the number of items inspected, where the rater agreed with him or herself on each inspection of an individual item. The Rater Score is the Number Matched divided by the Number Inspected.

The Agreement across Categories report shows the agreement in classification over that which would be expected by chance. It assesses the agreement between a fixed number of raters when classifying items.

Figure 7.7 Agreement Reports
Effectiveness Report

In the Attribute Gauge report, the Effectiveness Report compares every rater with the standard. This report appears only if you have specified a Standard variable in the launch window. For a description of a Standard variable, see “Launch the Attribute Gauge Chart Platform”.

Figure 7.8 Effectiveness Report

The Agreement Counts table shows cell counts on the number correct and incorrect for every level of the standard. In Figure 7.8, the standard variable has two levels, 0 and 1. Rater A had 45 correct responses and 3 incorrect responses for level 0, and 97 correct responses and 5 incorrect responses for level 1.

Effectiveness is defined as the number of correct decisions divided by the total number of opportunities for a decision. For example, say that rater A sampled every part three times. On the sixth part, one of the decisions did not agree (for example, pass, pass, fail). The other two decisions would still be counted as correct decisions. This definition of effectiveness is different from the MSA 3rd edition. According to MSA, all three opportunities for rater A on part six would be counted as incorrect. Including all of the inspections separately gives you more information about the overall inspection process.
In the Effectiveness table, 95% confidence intervals are given about the effectiveness. These are score confidence intervals. It has been demonstrated that score confidence intervals provide increased coverage probability, particularly where observations lie near the boundaries. See Agresti and Coull (1998).

The Misclassifications table shows the incorrect labeling. The rows represent the levels of the standard or accepted reference value. The columns contain the levels given by the raters.

**Conformance Report**

The Conformance Report shows the probability of false alarms and the probability of misses. This report appears only when the rating has two levels (such as pass or fail, or 0 or 1).

The following descriptions apply:

- **False Alarm**  The part is determined to be non-conforming, when it actually is conforming.
- **Miss**  The part is determined to be conforming, when it actually is not conforming.
- **P(False Alarms)**  The number of parts that have been incorrectly judged to be nonconforming divided by the total number of parts that are judged to be conforming.
- **P(Miss)**  The number of parts that have been incorrectly judged to be conforming divided by the total number of parts that are actually nonconforming.

The Conformance Report red triangle menu contains the following options:

- **Change Conforming Category**  Reverses the response category that is considered conforming.
- **Calculate Escape Rate**  Calculates the Escape Rate, which is the probability that a non-conforming part is produced and not detected. The Escape Rate is calculated as the probability that the process will produce a non-conforming part times the probability of a miss. You specify the probability that the process will produce a non-conforming part, also called the Probability of Nonconformance.

**Note:** Missing values are treated as a separate category in this platform. To avoid this separate category, exclude rows of missing values in the data table.

**Attribute Gauge Platform Options**

The Attribute Gauge red triangle menu contains the following options:

- **Attribute Gauge Charts**  Shows or hides the gauge attribute chart and the efficiency chart.
- **Show Agreement Points**  Shows or hides the agreement points on the charts.
**Connect Agreement Points**  Connects the agreement points in the charts.

**Agreement by Rater Confid Intervals**  Shows or hides the agreement by rater confidence intervals on the efficiency chart.

**Show Agreement Group Means**  Shows or hides the agreement group means on the gauge attribute chart. This option is available when you specify more than one X, Grouping variable.

**Show Agreement Grand Mean**  Shows or hides the overall agreement mean on the gauge attribute chart.

**Show Effectiveness Points**  Shows or hides the effectiveness points on the charts.

**Connect Effectiveness Points**  Draws lines between the effectiveness points in the charts.

**Effectiveness by Rater Confid Intervals**  Shows or hides confidence intervals on the second chart in the Attribute Gauge Chart report (Figure 7.6).

**Effectiveness Report**  Shows or hides the Effectiveness report. This report compares every rater with the standard, using the Kappa statistic.

See *Using JMP* for more information about the following options:

**Local Data Filter**  Shows or hides the local data filter that enables you to filter the data used in a specific report.

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Platform Preferences**  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

**Save By-Group Script**  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.
Statistical Details for Attribute Gauge Charts

This section contains statistical details for Attribute Gauge charts.

- “Statistical Details for the Gauge Attribute Chart”
- “Statistical Details for the Agreement Report”

Statistical Details for the Gauge Attribute Chart

In the Gauge Attribute chart that plots all X, Grouping variables on the horizontal axis, the percent Agreement is calculated as follows:

\[
\text{\% Agreement for part } i = \frac{\sum_{l=1}^{k} \left( \frac{\text{number of responses for level } l}{2} \right)}{\binom{N_i}{2}}
\]

In the Gauge Attribute chart that plots all Y, Response variables on the horizontal axis, the percent Agreement is calculated as follows:

\[
\text{\% Agreement for rater } k = \frac{\sum_{i=1}^{n} \left( \frac{\sum_{j=1}^{r_i} \text{number of uncounted matching levels for this rater } k \text{ within part } i \text{ for rep } j}{2} \right)}{\sum_{i=1}^{n} \left( \sum_{j=1}^{r_i} N_i - j \right)}
\]

Note the following:

- \( n \) = number of parts (grouping variables)
- \( r_i \) = number of reps for part \( i \) (\( i = 1, ..., n \))
- \( m \) = number of raters
- \( k \) = number of levels
- \( N_i = m \times r_i \). Number of ratings on part \( i \) (\( i = 1, ..., n \)). This includes responses for all raters, and repeat ratings on a part. For example, if part \( i \) is measured 3 times by each of 3 raters, then \( N_i \) is 3 x 3 = 9.

For example, consider the following table of data for three raters, each having three replicates for one part.
Table 7.1 Three Replicates for Raters A, B, and C

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Using this table, you can make these calculations:

\[
% \text{ Agreement} = \frac{\binom{4}{2} + \binom{5}{2}}{\binom{9}{2}} = \frac{16}{36} = 0.444
\]

% Agreement [rater A] = percent Agreement [rater B] = \(\frac{4 + 3 + 3}{8 + 7 + 6} = \frac{10}{21} = 0.476\) and

% Agreement [rater C] = \(\frac{4 + 3 + 2}{8 + 7 + 6} = \frac{9}{21} = 0.4286\)

**Statistical Details for the Agreement Report**

In the Attribute Gauge Chart platform, the simple Kappa coefficient is reported. The simple Kappa coefficient is a measure of inter-rater agreement.

\[
\hat{\kappa} = \frac{p_0 - p_e}{1 - p_e}
\]

where:

\[
p_0 = \sum_i p_{ii}
\]

and:

\[
p_e = \sum_i p_i p_i
\]
If you view the two response variables as two independent ratings of the \( n \) parts, the Kappa coefficient equals +1 when there is complete agreement of the raters. When the observed agreement exceeds chance agreement, the Kappa coefficient is positive, and its magnitude reflects the strength of agreement. Although unusual in practice, Kappa is negative when the observed agreement is less than the chance agreement. The minimum value of Kappa is between -1 and 0, depending on the marginal proportions.

Estimate the asymptotic variance of the simple Kappa coefficient with the following equation:

\[
\text{var} = \frac{A + B - C}{(1 - P_e)^2 n}
\]

where:

\[
A = \sum_i p_{ii} \left[ 1 - (p_{i.i} + p_{.i})(1 - \hat{\kappa}) \right]
\]

\[
B = (1 - \hat{\kappa})^2 \sum_{i \neq j} \sum_p p_{ij} (p_{i.i} + p_{.j})^2
\]

and:

\[
C = \left[ \hat{\kappa} - P_e (1 - \hat{\kappa}) \right]^2
\]

The Kappas are plotted and the standard errors are also given.

**Note:** The Kappa statistics in the Attribute Chart platform are shown even when the levels of the variables are unbalanced.

Categorical Kappa statistics (Fleiss 1981) are found in the Agreement Across Categories report.

Given the following assumptions:

- \( n \) = number of parts (grouping variables)
- \( m \) = number of raters
- \( k \) = number of levels
- \( r_i \) = number of reps for part \( i \) \( (i = 1, ..., n) \)
- \( N_i = m \times r_i \). Number of ratings on part \( i \) \( (i = 1, 2, ..., n) \). This includes responses for all raters, and repeat ratings on a part. For example, if part \( i \) is measured 3 times by each of 2 raters, then \( N_i \) is \( 3 \times 2 = 6 \).
- \( x_{ij} \) = number of ratings on part \( i \) \( (i = 1, 2, ..., n) \) into level \( j \) \( (j = 1, 2, ..., k) \)
The individual category Kappa is defined as follows:

\[
\hat{\kappa}_j = 1 - \frac{\sum_{i=1}^{n} x_{ij}(N_i - x_{ij})}{(\hat{p}_j \hat{q}_j) \sum_{i=1}^{n} N_i(N_i - 1)}
\]

where \( \hat{p}_j = \frac{\sum_{i=1}^{n} x_{ij}}{n} \) \( \hat{q}_j = 1 - \hat{p}_j \)

The overall Kappa is defined as follows:

\[
\hat{\kappa} = \frac{\sum_{j=1}^{k} \hat{q}_j \hat{p}_j \hat{\kappa}_j}{\sum_{j=1}^{k} \hat{p}_j \hat{q}_j}
\]

The variance of \( \hat{\kappa}_j \) and \( \hat{\kappa} \) are calculated as follows:

\[
\text{var}(\hat{\kappa}_j) = \frac{2}{nN(N-1)}
\]

\[
\text{var}(\hat{\kappa}) = \frac{\left( \sum_{j=1}^{k} \hat{p}_j \hat{q}_j \right)^2}{\sum_{j=1}^{k} \hat{p}_j \hat{q}_j} \times \left[ \frac{k}{nN(N-1)} - \sum_{j=1}^{k} \hat{p}_j \hat{q}_j (\hat{q}_j - \hat{p}_j) \right]
\]

The standard errors of \( \hat{\kappa}_j \) and \( \hat{\kappa} \) are shown only when there are an equal number of ratings per part (for example, \( N_i = N \) for all \( i = 1, \ldots, n \)).
Use the Process Screening platform to explore a large number of processes across time. The platform calculates process stability and process capability metrics. The platform creates control charts and detects large process shifts. The platform is intended to expedite the evaluation of a very large number of processes by enabling you to quickly focus on the processes that are unstable, not capable of meeting specification limits, or subject to shifts in the mean.

Based on your initial results, you can choose to explore specific processes graphically or in greater analytical depth. You can easily access the Control Chart Builder and Process Capability platforms. You can save detailed results for all of your processes or for specific processes.

**Figure 8.1** Example of a Process Performance Graph
Contents

Overview of the Process Screening Platform ...................................................... 197
Example of Process Screening ................................................................. 197
Launch the Process Screening Platform ....................................................... 200
  Limits Table ......................................................................................... 203
The Process Screening Report ...................................................................... 205
Process Screening Platform Options ........................................................... 211
  Process Performance Graph .................................................................... 218
Additional Example of Process Screening .................................................... 219
Statistical Details for the Process Screening Platform ............................... 221
Overview of the Process Screening Platform

The Process Screening platform facilitates the task of assessing data from a large number of processes for stability and capability. The results are largely based on control chart calculations to determine when a process is out of control. The Process Screening platform enables you to do the following:

- Specify a constant subgroup size or use a variable containing subgroup identifiers for control chart calculations using subgroups.
- Use grouping variables. For each combination of values of the group variables, an analysis is provided for each process variable.
- Use medians to make your centerline and sigma calculations robust to outliers.
- Obtain information about the location of large shifts in the mean of your processes.

You can customize the Summary report to show specific control chart tests, including tests for changes in process mean and spread. The report also provides capability information when you supply specification limits. The Process Performance Graph gives you a visual representation of the performance of your processes in terms of stability and capability. The Shift Graph shows locations of upshifts and downshifts.

**Tip:** For information about adding specification limits, see *Using JMP*.

Process Screening makes it easy to select specific processes for further analysis. The platform provides small run charts for these processes - the size of the plots makes it easy for you to view a substantial number at a time. You can also link to Control Chart Builder and the Process Capability platform for analyses of select processes.

You can save data tables containing results in various forms, either for your entire set of processes or only for select processes.

Example of Process Screening

You are interested in identifying unstable processes in a data table that contains 128 columns of process measurements. Each column contains a Spec Limits column property. If a process is stable, it is appropriate to calculate its process capability.

1. Select Help > Sample Data Folder and open Semiconductor Capability.jmp.
2. Select Cols > Column Viewer.
3. Select the Processes column group and click Show Summary.
This enables you to quickly see summary statistics for all of the process columns. If you scroll through the Summary Statistics table, some of the columns have the same value for their minimum and maximum, indicating that the column has constant entries. You do not want to include these columns in the analysis.

4. In the Summary Statistics table, deselect VPM1, VPM2, PMS1, SNM1, PNP6, VPM4, VPM6, VPM9, P1, and M1. The columns selected in the Summary Statistics table correspond to the columns selected in the data table.

Tip: To deselect the columns, press Ctrl and click the column name in the table.

5. In the data table, select Analyze > Quality and Process > Process Screening.

6. Click Process Variables. This assigns the columns that are already selected in the data table as the process variables.

Notice that the Control Chart Type is set to Indiv and MR.

7. Click OK.

Figure 8.2 Partial View of Initial Report

The Process Screening window appears, showing a table of results for each process. The table is sorted by Stability Index. This is a measure of the stability of a process, where a stable process has a stability index near 1. Higher values of the stability index indicate a less stable process. (The sorting is indicated by the caret beside Stability Index in the report.) You want to take a closer look at processes with a stability index value greater than or equal to 1.03.

8. In the report window, select processes IVP8 through IVP9.

Each of these first 10 processes has a value of 1.03 or larger in the Stability Index column.
9. Right-click the selected processes and select **Show Charts for Selected**.

**Figure 8.3** Charts for Highest Alarm Rate Processes

You decide to take a closer look at IVP8 (row 1, column 1 in the Charts for Selected).

10. Select the first process in the Summary table, which corresponds to IVP8.

11. Right-click the selected process and select **Control Charts for Selected Items**.

**Figure 8.4** Control Chart Builder Report for IVP8

A Control Chart Builder report appears. Because IVP8 has a Spec Limits column property, the report also includes a capability analysis.
Launch the Process Screening Platform

Launch the Process Screening platform by selecting **Analyze > Quality and Process > Process Screening**.

**Figure 8.5** Process Screening Launch Window

For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

**Launch Window Roles**

**Process Variables**  The columns of process data containing the measurements to be analyzed. The columns must have a Numeric data type. If a process variable has a Control Limits column property, the Process Screening platform uses those limits to calculate the Specified Sigma.

**Note:** The platform does not support control limits that are specified in a Control Limits column property for dispersion (R) charts.

**Grouping**  Columns assigned as grouping variables. Each process variable is analyzed at each combination of levels of the grouping variables. The results are presented in a single report.
**Subgroup**  Assigns one or more subgroup variables. If more than one subgroup variable is assigned, the subgroup levels are defined as a combination of the multiple columns.

**Note:** The Subgroup role is ignored for Indiv and MR charts.

**Time**  A numeric column whose values are used for the time order for the data. Use the Time role for data that are time-stamped. The time stamp is used for the time axis in quick graphs and shift graphs. The process data are sorted by the Time variable before calculations are performed.

**By**  A column whose levels define separate analyses. For each level of the specified column, the corresponding rows are analyzed using the other variables that you have specified. The results are presented in separate tables and reports. If more than one By variable is assigned, a separate analysis is produced for each possible combination of the levels of the By variables.

**Launch Window Options**

**Control Chart Type**  Select one of five control chart types: Indiv and MR (Individual Measurement and Moving Range); XBar and R; XBar and S; XBar, MR, and R; or XBar, MR, and S. The XBar, MR, and R control chart and the XBar, MR, and S control chart are also referred to as three way control charts. For more information about statistical details, see “Statistical Details for Control Chart Builder”.

**Note:** If the subgroup size for a process is 1, the chart automatically switches to an Indiv and MR chart.

**Subgroup Sample Size**  Specifies a constant sample size for subgroups. The minimum subgroup size is 2. A subgroup size of 5 is the default. The Subgroup Sample Size specification is ignored for Indiv and MR charts or when a subgroup variable is specified.

**K Sigma**  Specifies the sigma multiplier. K Sigma is the value that is multiplied by sigma in the calculation of control limits. By default, K Sigma is 3.

**Use Limits Table**  Enables you to import historical control limits and specification limits from a data table. When you select this option and click OK in the launch window, a Choose limits table window appears. Once you choose a limits tables and click OK, a Limits Specification window appears. Assign columns in your limits table to appropriate roles and click OK. See “Limits Table”.

**Note:** If you do not select this option, limits and sigma values are obtained from the Control Limit, Spec Limit, or Process Screening column properties for the Process Variables. If you do not select this option and the Process Variables do not have control limit column properties, the control limits are calculated from the data.
**Tip:** To add columns properties to several columns at once, see “Manage Limits”

**Use Medians instead of Means**  Estimates the center line using the median of the observations. Sigma is estimated using scaling factors obtained using Monte Carlo simulation. The table of factors is given in “Statistical Details for the Process Screening Platform”. The calculation depends on the type of chart selected:

- For XBar and R chart or Indiv and MR chart calculations, sigma is estimated using the scaled median of the ranges.
- For XBar and S chart calculations, sigma is estimated using the scaled median of the standard deviations.
- For unequal subgroup sizes, the scaling factor corresponds to the average subgroup size rounded to the nearest integer.

When one or more outliers influence the location of the center line, many subgroups can appear out of control. Using the median alleviates this problem.

**Note:** When Use Medians instead of Means is selected, the results obtained from the Control Charts for Selected Items or the Process Capability for Selected Items red triangle menu options do not match the Process Screening results.

**Sort by Subgroup**  Sorts the process data by the subgroup variable, or combination of nested subgroup variables, before calculations are performed.

**Advanced Options**  Contains the following options:

- **Shift Threshold**  Specify a value that controls the sensitivity of the Shift Graph. Shift Threshold is set to three by default. After outlier removal, the Shift Graph shows a plot of the time occurrence of all process shifts that exceed the number of within-sigma units specified by the Shift Threshold. See “Shift Graph”.

- **Outlier Threshold**  Specify a value that controls the sensitivity of outlier removal for detection of large recent shifts and for the Shift Graph. Outlier Threshold is set to five by default. If the number of within sigma units from an observation to both of its neighboring observations exceeds the specified Outlier Threshold, that observation is replaced with a value that is one within-sigma unit away from its closest neighboring observation. See “Shift Magnitudes and Positions”.

- **Shift Lambda**  Enables you to change the exponentially weighted moving average (EWMA) weight used in the Shift Graph. See “Shift Magnitudes and Positions”.

- **Drift Beta**  The weight used in the exponentially weighted moving average (EWMA) for drift detection. Drift Beta is set to 0.05 by default.
Minimum Process Length  The minimum number of data values that a process must have in order to be included in the analysis. By default, this value is set to 3.

Limits Table

A Limits Table contains a row for each process defined by the Process Variables and Grouping variables in your table of process data. When you use a Limits Table in the Process Screening platform, the Limits Specifications window enables you to specify variables with the roles listed below. You do not need to specify variables for all of these roles. All of these roles are optional.

Figure 8.6  Limits Specifications Window

Columns in the Limits Table that have appropriate names or names that match the role buttons are auto-filled. For example, any column called “Process”, “Column”, or “Parameter” is auto-filled into the Process Variables list.

If you have control limits but do not have columns for Center or Sigma, then you can use the Derived Sigma options.

Process Variables  A column that contains values corresponding to the column names in your table of process data.
Grouping  One or more columns that contain the values of the grouping variables for your table of process data.

Center  A column containing values for the center line for each process. This is usually the historical process mean.

Sigma  A column containing values for the within standard deviation for each process. This is usually the historical standard deviation. This is labeled as Specified Sigma in the Process Screening report.

Derived Sigma  Calculates sigma based on the given control limits and subgroup size. This is labeled as Specified Sigma in the Process Screening report.

**Note:** If there is a specified sigma, the within-sigma, stability index, and stability ratio values do not match between the Process Screening and Control Chart Builder platforms. The Process Screening platform uses the specified sigma to calculate the control limits, but still calculates the within-sigma using the data. The Control Chart Builder platform uses the specified sigma as the historical sigma and in control charts, the historical sigma is used as the within-sigma.

The derived sigma is calculated as follows:

\[
\text{Sigma} = d \times \frac{(UCL - LCL)}{6}
\]

where \(d\) is the square root of the subgroup size.

LCL  A column containing the lower control limits for each process.

UCL  A column containing the upper control limits for each process.

Subgroup Size  A column containing the subgroup size for each process.

LSL  A column containing lower specification limits for each process.

USL  A column containing upper specification limits for each process.

Target  A column containing a target value for each process.

Importance  A column containing an importance value for each process. The Importance column provides a mechanism to sort processes in the order that you prefer.
The Process Screening Report

The Process Screening report opens with a Summary table that contains results about process stability. There is a label above the summary table that shows the type of control chart on which the results are based. The sample size or subgroup variable is also shown above the summary table for every chart type except for Indiv and MR. The summary table also contains capability results if you have provided specification limits. The processes and groups are initially sorted in decreasing order by Stability Index. If Importance values are specified by the user, the processes and groups are sorted in decreasing order by Stability Index within Importance. The columns for Stability Index, Ppk, Cpk, Cp, and Target Index are colored as green, yellow, and red to indicate adequate, marginal, and poor stability or capability, respectively. This color coding scheme matches the Process Performance graph color coding scheme.

**Tip:** To sort the report by a column, click the column name. A caret appears to the right of the column name. The direction of the caret indicates whether the sorting is descending or ascending. To change the order of the sorting, click the column name again. If you change the sorting, the graphs produced by the Show Chart as Selected, Show Chart for Selected, Drift Graph, and Control Charts for Selected Items options use the same sort as the Summary table.

The control chart calculations in the Summary table include Nelson tests and a Range Limit Exceeded test. These tests assume the following about the control chart limits:

- The center line for the XBar or X control charts is given by the mean of all measurements. If you use the Medians instead of Means option, the center line is given by the median of the observations.
- Control limits are placed at $K$ sigma units from the center line. Use the KSigma option in the launch window to specify $K$. By default, KSigma is 3.
- Sigma is estimated using the conventions that correspond to the control chart type that you specified or, if you use Medians instead of Means, as described in “Use Medians instead of Means”.

**Tip:** The eight Nelson tests in the Process Screening platform follow the test settings in the Control Chart Builder platform preferences. You can customize the tests at File > Preferences > Platforms > Control Chart Builder.

The Summary table can contain the following information:

**Column** The columns that you entered as Process Variables. There is a row for each distinct combination of Process and Grouping columns. This column is suppressed if there is only one process column.
**Tip:** To access options that operate on selected items, right-click the **Column** column. The right click menu also contains a Table option that provides a list of Table Box messages. See the *JSL Syntax Reference*.

**Grouping Columns** There is a report column for each column in the data table that you entered as Grouping. The levels of the Grouping columns are listed so that there is a unique row in the report table for each distinct combination of Process name and Grouping columns values.

**Importance** (Appears only when there are importance values specified by the user, as inputs from a limits table.) The user-specified importance value for the processes.

**Variability** Contains the following columns:

**Stability Index** A measure of stability of the process. A stable process has a stability index near one. Higher values indicate less stability. The stability index is defined as follows:

\[ \frac{\text{Overall Sigma}}{\text{Within Sigma}} \]

If a three way control chart is selected in the launch, the stability index is defined as follows:

\[ \frac{\text{Overall Sigma}}{\text{Between-and-Within Sigma}} \]

**Stability Ratio** A measure of stability of the process. A stable process has a stability ratio near one. Higher values indicate less stability. The stability ratio is defined as follows:

\[ \left( \frac{\text{Overall Sigma}}{\text{Within Sigma}} \right)^2 \]

If a three way control chart is selected in the launch, the stability ratio is defined as follows:

\[ \left( \frac{\text{Overall Sigma}}{\text{Between-and-Within Sigma}} \right)^2 \]

**Within Sigma** An estimate of the standard deviation based on within subgroup variation. The estimate is based on the control chart type that you specified, and is a short-term measure of variation. See “Statistical Details for the Process Capability Platform” for statistical details. If you select Medians instead of Means, Within Sigma is computed as described in “Use Medians instead of Means”.

**Overall Sigma** The usual estimate of standard deviation based on all observations.

**Between Sigma** (Appears only when three way control chart is selected in the launch window.) An estimate of the standard deviation based on the variation between subgroups. See “Statistical Details for the Process Capability Platform” for statistical details.
**Between-and-Within Sigma**  (Appears only when three way control chart is selected in the launch window.) An estimate of the standard deviation based on the variation between subgroups and the variation within subgroups. The Between-and-Within Sigma estimate is defined as follows:

\[
\text{Between-and-Within Sigma} = \sqrt{\text{Within Sigma}^2 + \text{Between Sigma}^2}
\]

**Specified Sigma**  The standard deviation specified by a sigma control limit in the Limits Specification dialog or an estimate of the standard deviation derived from the control limits and subgroup size. See “Derived Sigma”. The control limits and subgroup size can be specified using a limits table or a Control Limits column property.

**Summary**  Contains the following columns:

- **Centerline**  (Appears if you do one of the following: select Use Medians instead of Means in the launch window, import a Center value using a limits table, or import control limits to derive sigma.) The value listed under Centerline is used in control chart calculations as the center line.
  - If you select Use Medians instead of Means in the launch window, the overall median of the observations is displayed.
  - If you import a Center value from a limits table, that value is displayed.
  - If you import control limits, the value displayed is calculated as (UCL + LCL)/2.

- **Mean**  The average of all observations.

- **Count**  The number of observations.

- **N Subgroups**  The number of subgroups.

**Control Chart Alarms**  Contains information about the subgroups that result in alarms for a variety of tests, including each of the 8 Western Electric rules. The standard deviation estimate is the Within Sigma value. By default, only the Alarm Rate, Test 1, and Latest Alarm columns are shown in the Summary table.

- **Alarm Rate**  The number of subgroups that resulted in alarms for any of the tests selected under the Choose Test option (Any Alarm) divided by the number of non-missing subgroups (Subgroups).

- **Any Alarm**  (Appears only when more than one Test column is shown.) The number of subgroups that trigger alarms for any of the tests selected under the Choose Test option. These are the eight Nelson tests and the test for Range Limit Exceeded.
Tip: The eight Nelson tests in the Process Screening platform follow the test settings in the Control Chart Builder platform preferences. You can customize the tests at File > Preferences > Platforms > Control Chart Builder.

Test 1 One point is more than three standard deviations from the center line. The subgroup associated with that point triggers the alarm.

Test 2 Nine or more consecutive points are on the same side of the center line. The subgroup associated with the ninth point triggers the alarm.

Test 3 Six or more consecutive points are continually increasing or decreasing. The subgroup associated with the sixth point triggers the alarm.

Test 4 Fourteen consecutive points alternate in direction: increasing and then decreasing or decreasing and then increasing. The subgroup associated with the 14th point triggers the alarm.

Test 5 Two out of three consecutive points on the same side of the center line are more than two standard deviations from the center line. The subgroup associated with the second point that exceeds two standard deviations triggers the alarm.

Test 6 Four out of five consecutive points on the same side of the center line are more than one standard deviation from the center line. The subgroup associated with the fourth point that exceeds one standard deviation triggers the alarm.

Test 7 Fifteen consecutive points, on either side of the center line, are all within one standard deviation of the center line. The subgroup associated with the 15th point triggers the alarm.

Test 8 Eight consecutive points, on either side of the center line, all fall beyond one standard deviation of the center line. The subgroup associated with the eighth point triggers the alarm.

Range Limit Exceeded The number of subgroups that exceed the upper control limit on the R, S, or MR chart calculation.

Moving Range Limit Exceeded The number of subgroups that exceed the moving range limit on the three way control chart calculation.

Latest Alarm The position of the subgroup, counting from the last subgroup, that signaled the most recent alarm for any of the Nelson or Range Limit Exceeded tests that are enabled in the report.

Capability (Appears only when there are Spec Limits specified for some processes.) Contains the following options:
**Ppk**  Capability index based on Overall Sigma and assuming a normal distribution. See “Statistical Details for the Process Capability Platform” for statistical details. On by default.

**Cpk**  Capability index based on Within Sigma or Between-and-Within Sigma and assuming a normal distribution. See “Statistical Details for the Process Capability Platform” for statistical details. On by default.

**Cp**  The potential capability if target and drift issues are resolved. See “Statistical Details for Capability Indices for Normal Distributions” for details.

**Target Index**  The number of short-term standard deviations that the process average differs from the target value. This measures the ability of the process to hit the target value. The Target Index is calculated as 3(Cp - Cpk). A target index is considered poor if above 1, marginal if between 0.5 and 1, and adequate if less than 0.5. See White et al. (2018).

**Out of Spec Count**  The number of observations that fall outside the specification limits. On by default.

**Out of Spec Rate**  The proportion of observations that fall outside the specification limits. On by default.

**Expected Out of Spec Rate**  The expected proportion of observations that fall outside of the specification limits. The Expected Out of Spec Rate assumes a stable and normally distributed process and uses overall sigma.

**Latest Out of Spec**  The number of observations, counting from the last observation to the most recent observation that falls outside the specification limits. On by default.

**\((\text{Mean-Tgt)}/\text{SpecRange})**  The spec centered mean. This is the same as the Mean Shift Standardized to Spec in Process Capability. See “Statistical Details for the Goal Plot” for statistical details.

**StdDev/SpecRange**  The spec scaled standard deviation. This is the same as the Std Deviation Standardized to Spec in Process Capability. See “Statistical Details for the Goal Plot” for statistical details.

**LSL**  The lower specification limits.

**USL**  The upper specification limits.

**Target**  The target value.
Shift Magnitudes and Positions  (Shown only if you have selected a Shift Detection option from the Process Screening red triangle menu.) Shift detection is performed to identify shifts that exceed one within-sigma unit. The algorithm uses outlier-correction and an EWMA smoothing approach for the individual observations. This is the algorithm:

– Outliers are removed so that single outliers do not indicate shifts. The value specified as Outlier Threshold (five by default) on the launch window controls the sensitivity of outlier removal. If the number of within-sigma units from an observation to both of its neighboring observations exceeds the specified Outlier Threshold, that observation is replaced with a value that is one within-sigma unit away from its closest neighboring observation.

– An EWMA fit is constructed for the subgroup means in forward time order and another EWMA fit is constructed for the subgroup means in reverse time order. The EWMA fits have lambda equal to 0.3.

– The largest positive and negative differences between successive EWMA values that exceed one within-sigma unit are identified.

– The absolute values of these differences, divided by the within estimate of sigma, are the values reported as Largest Upshift and Largest Downshift.

– The locations of the first subgroups involved in these largest shifts define the Upshift Position and Downshift Position.

Largest Upshift  The magnitude of the largest upward shift that exceeds one within-sigma unit, reported in within-sigma units.

Upshift Position or Upshift <Time Variable>  The position of the subgroup having the largest Upshift. If you specify a Time variable, the column in the Summary table is named Upshift <Time Variable> and the position of the shift is given in terms of the Time variable.

Largest Downshift  The magnitude of the largest downward shift that exceeds one within-sigma unit, reported in within-sigma units.

Downshift Position or Downshift <Time Variable>  The position of the subgroup having the largest Downshift. If you specify a Time variable, the column in the Summary table is named Downshift <Time Variable> and the position of the shift is given in terms of the Time variable.

Drift Magnitudes and Positions  (Shown only if you have selected the Drift Summaries option from the Process Screening red triangle menu.) Drift detection is performed to detect smaller, more gradual changes in processes. The algorithm is identical to the one used in shift detection, except that drift detection uses a Holt Double-Exponential Smoother instead of an EWMA. This is the algorithm:

– Outliers are removed through the same process that is used in shift detection. See “Shift Magnitudes and Positions”. 
The drift detection algorithm fits a Holt Double-Exponential Smoothing model for the subgroup means in forward time order and fits another Holt Double-Exponential Smoothing model for the subgroup means in reverse time order. The two smoothing model fits each have two smoothing constants: \( \alpha \) for the level and \( \beta \) for the slope. The \( \beta \) smoothing constant is set at 0.05 and the \( \alpha \) smoothing constant is estimated to minimize the error.

The means of the positive drift values, negative drift values, and absolute drift values are reported as Mean Up Drift, Mean Down Drift, and Mean Abs Drift, respectively.

- **Mean Up Drift**: The sum of the positive drift values divided by the count.
- **Mean Down Drift**: The sum of the negative drift values divided by the count.
- **Mean Abs Drift**: The sum of the absolute value of all drift values divided by the count.

**Note:** Process Screening does not utilize the Distribution or Process Capability Distribution column properties and always performs capability analyses assuming a normal distribution. If the distribution type for one of these column properties is non-normal, a Warnings outline is shown below the Summary table.

## Process Screening Platform Options

The Process Screening red triangle menu contains options to customize the display and to save calculated statistics. The options that operate on selected items are also accessible by right-clicking the **Column** column in the Summary table.

- **Summary**: Shows or hides the Summary table. See “The Process Screening Report”.
- **Find and Select**: Enter search strings for columns that you entered as Process Variables or Grouping in the launch window. A panel appears for each column. The corresponding processes are selected in the Summary table.
- **Select Where**: Opens the Select Where window. You can select specific processes in the Summary table that correspond to a particular condition by using the Comparison menu and Value text box. For example, you can select all processes such that Ppk < 1.33. After you click OK, the processes are selected in the Summary table.

**Tip:** You can also access the Select Where window by right-clicking anywhere in the Summary table.

- **Filter Where**: Opens the Filter Where window. Enables you to filter the processes shown in the Summary table. Select a column and use the Comparison menu and Value text box to
define a filter. After you click OK, only the processes that meet the specified condition are shown in the Summary table.

**Tip:** You can also access the Filter Where window by right-clicking anywhere in the Summary table.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Reset Filter</strong></td>
<td>(Available only after a filter is applied to the Summary table using the Filter Where option.) Removes any filter that is currently applied to the Summary table.</td>
</tr>
<tr>
<td><strong>Show Summary Columns</strong></td>
<td>Enables you to choose some of the summary columns that are shown in the Summary table.</td>
</tr>
<tr>
<td><strong>Show Charts as Selected</strong></td>
<td>Plots small graphs of the processes that are selected in the Summary table in a Charts as Selected report. This report automatically updates as you select and deselect processes in the Summary table. These charts have the same information and options as the charts in the Charts for Selected report. See “Show Charts for Selected”.</td>
</tr>
<tr>
<td><strong>Show Charts for Selected</strong></td>
<td>Plots small graphs of the processes that are selected in the Summary table in a Charts for Selected report. The report makes it possible to view and compare many processes at once. By default, each chart has red lines for the control limits. The Chart for Selected red triangle menu contains additional options to change the appearance of the graphs. See “Chart Settings”. To remove the graphs, click the Charts for Selected red triangle and select Remove.</td>
</tr>
</tbody>
</table>
Show Spec Limits  Shows or hides the upper and lower specification limits as dotted blue lines.

Number of Plots Across  Specifies the layout for the charts.

Frame Size  Enables you to specify a frame size that is used for all of the charts.

Launch for Selected  Enables you to launch either Control Chart Builder or Process Capability for the items selected in the Summary table.

Control Chart Builder  Opens a Control Chart Builder report window for the processes that you selected in the Summary table. The control chart corresponds to your selections in the Process Screening launch window.

Notes:
- Only the tests selected in Process Screening are sent to Control Chart Builder. Tests that have been turned off are not sent.
- If you have multiple subgroup variables where the inner subgroup variable is not sorted within the outer subgroup variable, a new subgroup variable column is created and used when Control Charts for Selected Items is launched. This does not apply if Sort by Subgroup is selected in the Process Screening launch window.

Process Capability  Opens a Process Capability report window showing Individual Detail Reports for the processes that you select in the Summary table. If you select a process for which specification limits are not specified, a Spec Limits window appears. In this window, you can specify specification limits by selecting a data table or entering values directly.

The Process Capability analysis assumes normal distributions and uses within sigma values that correspond to your Control Chart Type selection in the Process Screening launch window:
- Moving range for Indiv and MR
- Average of ranges for XBar and R
- Average of unbiased standard deviations for XBar and S

Notes:
- If you specify sigma using a sigma control limit or the Derived Sigma option in the Limits Specifications window, this value is not used in Process Capability. This is because the Process Screening and Process Capability platforms use these control limits differently.
- If you have multiple subgroup variables where the inner subgroup variable is not sorted within the outer subgroup variable, a new subgroup variable column is created and used when Process Capability for Selected Items is launched. This does not apply if Sort by Subgroup is selected in the Process Screening launch window.
Color Selected Items  Applies a color of your choosing to the values in the selected rows of the Summary table.

Remove Selected Items  Removes the rows selected in the Summary table and reruns the analysis without those processes.

Show Tests  Shows or hides test results for Nelson tests that are selected under the Choose Tests option in the Process Screening report’s summary table.

Choose Tests  Enables you to choose the tests that you want to include in the calculation of Alarm Rate and Any Alarm.

Tip: To select multiple tests, press Alt and click the Process Screening red triangle to open a menu of all platform options.

Shift Detection  Provides options for detecting shifts after outlier removal. See “Shift Magnitudes and Positions”.

Largest Upshift  Adds columns for Largest Upshift and Upshift Position to the Summary table. The largest upward shift in the series that exceeds one within-sigma unit is identified. See “Shift Magnitudes and Positions”.

Largest Downshift  Adds columns for Largest Downshift and Downshift Position to the Summary table. The largest downward shift in the series that exceeds one within-sigma unit is identified. See “Shift Magnitudes and Positions”.

Shift Graph  (Available only when some processes have shifts that exceed the Shift Threshold.) Shows a plot of the time occurrence of all process shifts that exceed the number of within-sigma units specified by the Shift Threshold (three by default). You can also change the Shift Threshold by using the slider bar on the Shift Graph. Hover over the diamond to see the value. Green markers indicate upshifts and red markers indicate downshifts. The markers are located at the local peaks of the shifts.

To identify the processes that correspond to one or more shift occurrences, select the points and click Select Process. The corresponding processes are selected in the Summary table. Processes that have no shifts exceeding the Shift Threshold number of within-sigma units are not plotted.

Note: The Shift Graph does not show the positions of Largest Upshift and Largest Downshift values that appear in the Summary table if the shifts are less than the specified Shift Threshold number of within-sigma units in magnitude. See “Additional Example of Process Screening”.

Show Shifts in Quick Graphs  (Available only when a Quick Graph has been added to the report window.) Shows the location of the shifts in the Quick Graphs using green and red vertical lines.
**Drift Summaries**  Adds columns for Mean Up Drift, Mean Down Drift, and Mean Abs Drift to the Summary Table. See “Drift Magnitudes and Positions”.

**Drift Graph Selected**  Displays a drift graph for each process that you select in the Summary Table. Drift graphs enable you to detect smaller, more gradual changes in the selected processes. The values plotted are the slope estimates from a Holt Double-Exponential Smoothing model. See “Drift Magnitudes and Positions”. Each drift graph displays the within-sigma value and the estimates for the two smoothing parameters in the Holt Double-Exponential Smoothing model. The Drift Graphs red triangle menu contains additional options to change the appearance of the graphs. See “Chart Settings”. To remove the graphs, click the Drift Graphs red triangle and select Remove.

**Process Performance Graph**  (Available only when specification limits are defined for at least one process variable.) Shows a four-quadrant graph that assesses the performance of processes in terms of stability and capability. See “Process Performance Graph”.

**Process Performance Graph Boundaries**  (Available only once the Process Performance Graph is in the report window.) Opens a window where you can set values for the Process Performance Graph’s stability index and Ppk capability boundaries.

**Tip:** You can set preferences for your desired boundaries for Stability Index and Ppk Capability in File > Preferences > Platforms > Process Screening.

**Goal Plot**  (Available only when specification limits are defined for at least one process variable.) The Goal Plot shows, for each variable, the spec-normalized mean shift on the X axis, and the spec-normalized standard deviation on the Y axis. If you define importance values for the processes, the goal plot points are sized by importance. It is useful for getting a quick, summary view of how the variables are conforming to specification limits. See “Goal Plot” for more information about goal plots and their features.

**Tip:** Hover over a point in the Goal Plot to view the a graphlet of the control chart for that process. Click the Quick Graph to add it to the report window. To change the settings of the graphlets, see “Chart Settings”.

The Goal Plot red triangle menu contains the following options:

**Show Within Sigma Points**  Shows or hides the points calculated using the within sigma estimate.

**Show Within or Between-and-Within Sigma Points**  (Available only when three way control chart is selected in the launch window.) Shows or hides the points calculated using the between-and-within sigma estimate.
**Show Overall Sigma Points**  Shows or hides the points calculated using the overall sigma estimate.

**Shade Levels**  Shows or hides the Ppk level shading. This is turned on by default. The shaded areas depend on the relationship between $p$ and Ppk, with $p$ representing the value shown in the box beneath Ppk. By default, $p = 1.33$.

- Points in the red area have Ppk $< p$.
- Points in the yellow area have $p < $Ppk$ < 2p$.
- Points in the green area have $2p < $Ppk$.

**Label Within Sigma Points**  Shows or hides labels for points calculated using the within sigma estimate.

**Label Within or Between-and-Within Sigma Points**  (Available only when a three way control chart is selected in the launch window.) Shows or hides labels for points calculated using the between-and-within sigma estimate.

**Label Overall Sigma Points**  Shows or hides labels for points calculated using the overall sigma estimate.

**Defect Rate Contour**  Shows or hides a contour representing a specified defect rate.

**Show Capability**  (Available only when specification limits are defined for at least one process variable.) Displays a submenu that enables you to show or hide the Capabilities in the Summary table.

---

**Note:** Spec Centered Mean and Spec Scaled Std Dev are displayed in the Summary table as (Mean-Tgt)/SpecRange and StdDev/SpecRange. The Spec Limits option displays the LSL, USL, and Target columns in the Summary table.

The following option is also available in the submenu:

**Color Out of Spec Values**  Colors the cells in the data table that correspond to values that are out of spec. The cell is colored red if the value is above the USL and blue if the value is below the LSL.

**Tip:** To remove colors in specific cells, select all cells of interest. Right-click in one of the cells and select Clear Color.

**Save Summary Table**  Saves all of the information that can appear in the Summary table to a Process Summary data table. The Process Summary data table also contains specification limit details, if these are specified for at least one process. As in the summary table, the columns for Stability Index, Ppk, Cpk, Cp, and Target Index are colored as green, yellow, and red to indicate adequate, marginal, and poor stability or capability, respectively.
Save Summary Table with Graphs  Creates the Process Summary data table with an additional column titled Graph. The Graph column contains a quick graph for each process in the Process Summary table.

Save Details Table  Saves detailed information about control chart calculations to a Process Details data table. For each combination of process and grouping variables, the table contains a row for each subgroup showing:
  - The value of the subgroup variable
  - The values of the subgroup sample statistics.
  - The control limits.
  - The subgroup size.
  - A list of indicators for which, if any, alarms were triggered. Alarms for the Nelson tests are indicated with the numbers for the tests. An alarm for the Range Limit Exceeded test is indicated with an R.
  - The Drift

Save Selected Details  For the selected rows in the Summary table, saves a Process Details table with the information that is saved when you select Save Details Table.

See Using JMP for more information about the following options:

Local Data Filter  Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Platform Preferences  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.
Process Performance Graph

The Process Performance Graph in the Process Screening platform is a four-quadrant plot of capability versus stability. Each process for which specification limits are provided is represented by a marker. The marker type depends on if the process violates guidelines for the Target Index and Cp values. A left-pointing triangle indicates the process is below target, a circle indicates the process is on target, and a right-pointing triangle indicates the process is above target. An open marker indicates that the variation of the process is adequate and a filled marker indicates that the variation of the process could be reduced. A complete description of the marker combinations is provided in Table 8.1. Additionally, if you define importance values for the processes, the markers on the Process Performance Graph are sized by importance.

Table 8.1 Process Performance Graph Markers

<table>
<thead>
<tr>
<th>Graph Marker</th>
<th>Target Index</th>
<th>Cp</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>On Target</td>
<td>Adequate Variation</td>
</tr>
<tr>
<td></td>
<td>On Target</td>
<td>Reduce Variation</td>
</tr>
<tr>
<td></td>
<td>Above Target</td>
<td>Adequate Variation</td>
</tr>
<tr>
<td></td>
<td>Above Target</td>
<td>Reduce Variation</td>
</tr>
<tr>
<td></td>
<td>Below Target</td>
<td>Adequate Variation</td>
</tr>
<tr>
<td></td>
<td>Below Target</td>
<td>Reduce Variation</td>
</tr>
</tbody>
</table>

On the graph, the horizontal coordinates represent the stability index of the process and the vertical coordinates represent the capability of the process, given as Ppk. The graph is divided into four quadrants based on the following default boundaries:

- A stability index that exceeds 1.25 indicates that the process is unstable.
- A Ppk that is smaller than 1.33 indicates that the process is not capable.

Additionally, there is a red line on the graph at 1.33 divided by Stability Index that indicates where the Cpk value is 1.33. This line categorizes the processes in the unstable and incapable quadrants in terms of how they might be fixed. Processes below the red line are fixable by special causes; processes above the red line are fixable by reducing variability. Selecting points in the graph selects the corresponding processes in the Summary table.
Tip: Hover over a point in the Process Performance Graph to view a graphlet of the control chart for that process. Click the Quick Graph to add it to the report window. To change the settings of the graphlets, see “Chart Settings”.

Additional Example of Process Screening

This example illustrates the use of a Grouping column and the construction of a Shift Graph using data from a consumer price index. The data table contains monthly data on 17 products, and the time periods vary by product. The data are arranged so that all 17 products are listed in a single column called Series. To separate the products, you must treat Series as a Grouping column.

1. Select Help > Sample Data Folder and open Consumer Prices.jmp.
4. Select Series and click Grouping.
   This ensures that each level of Series is treated as a separate process.
5. Select Date and click Time.
6. Set the Control Chart Type to XBar and R.
7. Set the Subgroup Sample Size to 3.
   Because the data are given monthly, subgroups of size three represent quarters.
8. Click OK.
9. Press Alt and click the red triangle next to Process Screening.
   This opens a window showing the available red triangle options. You can select multiple options at once in this window.
10. Check the following: Largest Upshift, Largest Downshift, and Shift Graph.
11. Click OK.

The columns Largest Upshift, Upshift Date, Largest Downshift, and Downshift Date are added to the Summary table. The shifts are the largest shifts exceeding one within-sigma unit. The position of each shift is given in terms of the Time variable, Date. See “Shift Magnitudes and Positions”.

A Shift Graph also appears. The Shift Graph shows all shifts that exceed the number of Shift Threshold within-sigma units, which is set to three by default. See “Shift Graph”. Green points correspond to upshifts and red points correspond to downshifts.

Notice that Gasoline, All has values for both Largest Upshift and Largest Downshift in the Summary table. The Largest Downshift value, 1.8296, is less than three. Because the Shift
Graph shows shifts of only three or more within-sigma units, the Largest Downshift value for Gasoline, All is not plotted on the Shift Graph.

Also notice that Tomatoes is not included on the Shift Graph. For Tomatoes, no shifts of three or more within-sigma units were found.

12. Double-click the horizontal axis of the Shift Graph to open the X Axis Settings window.
13. In the Tick/Bin Increment panel, set # Minor Ticks to 1.
15. Click OK.

**Figure 8.7** Shift Graph

Most series show primarily upshifts. Price Coffee, however, has several alternating downshifts and upshifts. To better understand this series, obtain a control chart.

16. Select any point to the right of Price Coffee in the Shift Graph and click Select Process.

This action selects the row of the Summary table corresponding to Coffee.

17. Right-click the selected process in the Summary table and select Control Charts for Selected Items.
The control chart shows the upshifts and downshifts that are identified in the Shift Graph. The Summary table indicates that the largest upshift (25.399 within-sigma units) occurs for the subgroup that includes September 1994. In the control chart in Figure 8.8, this is the subgroup in position 59. The Summary table also indicates that the largest downshift (9.1674 within-sigma units) occurs for the subgroup that includes March 1981. This is the subgroup in position 5 in the control chart.

Because shifts are calculated using EWMA-smoothed series and an outlier-correction algorithm, the shift positions might not precisely correspond to the subgroups that seem to start the shifts on a Shewhart control chart.

**Statistical Details for the Process Screening Platform**

This section describes how scaling factors are calculated when you use medians to estimate sigma. When you select Use Medians instead of Means, sigma is estimated using a scaled median range or median standard deviation. The table below gives the scaling factors, which were obtained using Monte Carlo simulation.
For subgroups of size $n$ drawn from a normal distribution, the following are true:

- The theoretical median of the ranges is approximately $d_{2\_Median} \sigma$, where $d_{2\_Median}$ is the value corresponding to $n$.
- The theoretical median of the standard deviations is approximately $c_{4\_Median} \sigma$, where $c_{4\_Median}$ is the value corresponding to $n$.

**Table 8.2 Scaling Constants for Median Range and Median Standard Deviation**

<table>
<thead>
<tr>
<th>$n$</th>
<th>$d_{2_Median}$</th>
<th>$c_{4_Median}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>0.953</td>
<td>0.675</td>
</tr>
<tr>
<td>3</td>
<td>1.588</td>
<td>0.833</td>
</tr>
<tr>
<td>4</td>
<td>1.978</td>
<td>0.888</td>
</tr>
<tr>
<td>5</td>
<td>2.257</td>
<td>0.917</td>
</tr>
<tr>
<td>6</td>
<td>2.471</td>
<td>0.933</td>
</tr>
<tr>
<td>7</td>
<td>2.646</td>
<td>0.944</td>
</tr>
<tr>
<td>8</td>
<td>2.792</td>
<td>0.952</td>
</tr>
<tr>
<td>9</td>
<td>2.915</td>
<td>0.959</td>
</tr>
<tr>
<td>10</td>
<td>3.024</td>
<td>0.963</td>
</tr>
<tr>
<td>11</td>
<td>3.118</td>
<td>0.967</td>
</tr>
<tr>
<td>12</td>
<td>3.208</td>
<td>0.969</td>
</tr>
<tr>
<td>13</td>
<td>3.286</td>
<td>0.972</td>
</tr>
<tr>
<td>14</td>
<td>3.357</td>
<td>0.975</td>
</tr>
<tr>
<td>15</td>
<td>3.422</td>
<td>0.976</td>
</tr>
<tr>
<td>16</td>
<td>3.483</td>
<td>0.978</td>
</tr>
<tr>
<td>17</td>
<td>3.539</td>
<td>0.979</td>
</tr>
<tr>
<td>18</td>
<td>3.590</td>
<td>0.980</td>
</tr>
<tr>
<td>19</td>
<td>3.640</td>
<td>0.981</td>
</tr>
<tr>
<td>20</td>
<td>3.685</td>
<td>0.982</td>
</tr>
<tr>
<td>21</td>
<td>3.731</td>
<td>0.983</td>
</tr>
<tr>
<td>22</td>
<td>3.770</td>
<td>0.984</td>
</tr>
</tbody>
</table>
Table 8.2 Scaling Constants for Median Range and Median Standard Deviation (Continued)

<table>
<thead>
<tr>
<th>n</th>
<th>d2_Median</th>
<th>c4_Median</th>
</tr>
</thead>
<tbody>
<tr>
<td>23</td>
<td>3.811</td>
<td>0.984</td>
</tr>
<tr>
<td>24</td>
<td>3.846</td>
<td>0.985</td>
</tr>
<tr>
<td>25</td>
<td>3.883</td>
<td>0.986</td>
</tr>
</tbody>
</table>
Process capability analysis, used in process control, measures how well a process is performing compared to given specification limits. A good process is one that is stable and consistently produces product that is well within specification limits. A capability index is a measure that relates process performance, summarized by process centering and variability, to specification limits.

Graphical tools such as a goal plot and box plots give you quick visual ways of identifying which process or product characteristics are within specifications. Individual detail reports display a capability report for each variable in the analysis. The analysis enables you to identify variation relative to the specifications or requirements; this enables you to achieve increasingly higher conformance values.

You can specify subgroups to compare the overall variation of the process to the within subgroup variation. You can compute capability indices for processes that produce measurements that follow various distributions. For data that follow none of the specified distributions, you can compute nonparametric capability indices.

Figure 9.1  Example of the Process Capability Platform
Contents

Overview of the Process Capability Platform ........................................... 227
Example of the Process Capability Platform with Normal Variables ............ 229
Example of the Process Capability Platform with Nonnormal Variables ....... 231
Launch the Process Capability Platform .................................................. 237
  Process Selection ................................................................. 238
  Process Subgrouping ............................................................ 238
  Moving Range Options .......................................................... 239
  Historical Information .......................................................... 240
  Distribution Options ............................................................. 240
  Other Specifications .............................................................. 241
Enter Specification Limits for a Process ............................................... 242
  Spec Limits Window ............................................................. 242
  Spec Limits Column Property .................................................. 245
The Process Capability Report ............................................................ 245
  Goal Plot ................................................................. 246
  Capability Box Plots .......................................................... 249
  Capability Index Plot .......................................................... 251
Process Capability Platform Options .................................................... 253
  Individual Detail Reports ....................................................... 256
  Normalized Box Plots ......................................................... 265
  Process Performance Plot ...................................................... 266
  Summary Reports ............................................................... 267
  Make Goal Plot Summary Table ................................................. 269
Additional Examples of the Process Capability Platform ......................... 270
  Example of Process Capability for a Stable Process ........................ 270
  Example of Process Capability for an Unstable Process ..................... 274
  Example of the Simulation of Confidence Limits for a Nonnormal Process Ppk 278
Statistical Details for the Process Capability Platform ............................ 285
  Statistical Details for Variation Statistics ...................................... 285
  Statistical Details on Notation .................................................. 289
  Statistical Details for the Goal Plot ........................................... 289
  Statistical Details for Capability Box Plots ................................... 291
  Statistical Details for Capability Indices for Normal Distributions ....... 292
  Statistical Details for Capability Indices for Nonnormal Distributions .... 297
  Statistical Details for the Parameterizations of Distributions .............. 299
Overview of the Process Capability Platform

The Process Capability platform provides the tools needed to measure the compliance of a process to given specifications. By default, JMP shows a Goal Plot, Capability Box Plots, and a Capability Index Plot for the variables that you fit with normal distributions. Capability indices for nonnormal variables are plotted on the Capability Index Plot. You can add normalized box plots, summary reports, and individual detail reports for the variables in your analysis.

You can supply specification limits in several ways:

- in the data table, using a column property
- by requesting the Spec Limits Dialog in the launch window
- by loading the limits from a specification limits data table
- using the Manage Spec Limits utility (Analyze > Quality and Process > Manage Spec Limits)

You can specify two-sided, one-sided, or asymmetric specification limits.

**Note:** The Process Capability platform expands significantly on the Capability analyses that are available through Analyze > Distribution and through Analyze > Quality and Process > Control Chart.

**Capability Indices**

A capability index is a ratio that relates the ability of a process to produce product that meets specification limits. The index relates estimates of the mean and standard deviation of the quality characteristic to the specification limits. Within estimates of capability are based on an estimate of the standard deviation constructed from within-subgroup variation. Overall estimates of capability use an estimate of standard deviation constructed from all of the process data. See “Statistical Details for Capability Indices for Normal Distributions” and “Statistical Details for Variation Statistics”.

Estimates of the mean or standard deviation are well-defined only if the processes related to centering or spread are *stable*. Therefore, interpretation of within capability indices requires that process spread is stable. Interpretation of overall capability indices requires that both process centering and spread are stable.

Capability indices constructed from small samples can be highly variable. The Process Capability platform provides confidence intervals for most capability indices. Use these to determine the range of potential values for your quality characteristic’s actual capability.
When confidence intervals are not provided (for example, for nonnormal distributions) you can use the Simulate feature to construct confidence intervals. For an example, see “Example of the Simulation of Confidence Limits for a Nonnormal Process Ppk”.

Guidelines for values of capability indices can be found in Montgomery (2013). The minimum recommended value is 1.33. Six Sigma initiatives aim for much higher capability levels that correspond to extremely low rates of defective parts per million.

**Capability Indices for Nonnormal Processes**

The Process Capability platform constructs capability indices for process measurements with the following distributions: Normal, Beta, Exponential, Gamma, Johnson, Lognormal, Mixture of 2 Normals, Mixture of 3 Normals, SHASH, and Weibull. A Best Fit option determines the best fit among these distributions and provides capability indices for this fit. The platform also provides a Nonparametric fit option that gives nonparametric estimates of capability.

For the nonnormal methods, estimates are constructed using two approaches: the ISO/Quantile method (Percentiles) and the Bothe/Z-scores method (Z-Score). For more information about these methods, see “Statistical Details for Capability Indices for Nonnormal Distributions”.

**Overall and Within Estimates of Sigma**

Most capability indices in the Process Capability platform can be computed based on estimates of the overall (long-term) variation and the within-subgroup (short-term) variation. If the process is stable, these two measures of variation should yield similar results since the overall and within subgroup variation should be similar. The normalized box plots and summary tables can be calculated using either the overall or the within-subgroup variation. See “Additional Examples of the Process Capability Platform” for examples of capability indices computed for stable and unstable processes.

You can specify subgroups for estimating within-subgroup variation in the launch window. You can specify a column that defines subgroups or you can select a constant subgroup size. For each of these methods, you can choose to estimate the process variation using the average of the unbiased standard deviations or using the average of the ranges. If you do not specify subgroups, the Process Capability platform constructs a within-subgroup estimate of the process variation using a moving range of subgroups of size two. Finally, you can specify a historical sigma to be used as an estimate of the process standard deviation.
Capability Index Notation

The Process Capability platform provides two sets of capability indices. See “Statistical Details for Capability Indices for Normal Distributions” for more information about the calculation of the capability indices.

- Cpk, Cpl, Cpu, Cp, and Cpm. These indices are based on a within-subgroup (short-term) estimate of the process standard deviation.
- Ppk, Ppl, Ppu, Pp, and Cpm. These indices are based on an overall (long-term) estimate of the process standard deviation. Note that the process standard deviation does not exist if the process is not stable. See Montgomery (2013).

The Process Capability platform uses the appropriate AIAG notation for capability indices: Ppk labeling denotes an index constructed from an overall variation estimate and Cpk denotes an index constructed from a within-subgroup variation estimate.

Note: The AIAG (Ppk) Labeling platform preference is selected by default. You can change the reporting to use Cp notation only by deselecting this preference under Process Capability.

For more information about process capability analysis, see Montgomery (2013) and Wheeler (2004).

Example of the Process Capability Platform with Normal Variables

In this example, you use the Process Capability platform to analyze standard measurements that a semiconductor manufacturer might make on a wafer as it is being processed. Specification limits for the variables have been entered in the data table through the Column Properties > Spec Limits property.

1. Select Help > Sample Data Folder and open Semiconductor Capability.jmp.
3. Click the white triangle next to Processes to view all of the continuous variables.
4. Select PNP1, PNP2, NPN2, PNP3, IVP1, PNP4, NPN3, and IVP2, and click Y, Process.
5. Click OK.
6. Click the Goal Plot red triangle and select Label Overall Sigma Points.
7. Click the Capability Index Plot red triangle and select Label Overall Sigma Points.
Figure 9.2  Example Results for Semiconductor Capability.jmp

The Goal Plot shows the spec-normalized mean shift on the x-axis and the spec-normalized standard deviation on the y-axis for each variable. The triangular region defined by the red lines in the bottom center of the plot is the goal triangle. It defines a region of capability index values. You can adjust the goal triangle using the Ppk slider to the right of the plot. When the slider is set to 1, note that PNP1, PNP3, IVP1, and IVP2 are outside of the goal triangle and possibly out of specification.

The Capability Box Plots report shows a box plot for each variable in the analysis. The values for each column are centered by their target value and scaled by the specification range. In this example, all process variables have both upper and lower specification limits, and these are symmetric about the target value. It follows that the solid green line shows where the target should be and the dashed lines represent the specification limits.
It appears that the majority of points for IVP1 are above its upper specification limit (USL), and the majority of points for IVP2 are less than its target. PNP2 seems to be on target with all data values inside the specification limits.

The Capability Index Plot plots the Ppk values for each variable. Four variables come from very capable processes, with Ppk values of 2 or more. Four variables have Ppk values below 1.

Example of the Process Capability Platform with Nonnormal Variables

In this example, you use the nonnormal capability features of the Process Capability platform to compute capability indices.

View the Distributions

2. Select Analyze > Distribution.
3. Select all seven columns from the Select Columns list and click Y, Columns.
4. Check the box next to Histograms Only.
5. Click OK.

For most processes, the histograms show evidence that the theoretical distribution of measurements is skewed and does not follow a normal distribution. Therefore, for each process, you find the best fitting distributions among all of the available parametric distributions.

Perform a Capability Analysis

2. Select all seven columns from the Columns list and click Y, Process.
3. Select all seven columns in the Y, Process list.
4. Open the Distribution Options panel and select Best Fit from the Distribution list.
5. Click Set Process Distribution.

The suffix &Dist(Best Fit) is added to each variable name in the Y, Process list. The Best Fit option specifies that the best-fitting parametric distribution should be fit to each variable. The available parametric distributions are Normal, Beta, Exponential, Gamma, Johnson, Lognormal, Mixture of 2 Normals, Mixture of 3 Normals, SHASH, and Weibull (Figure 9.3).
6. Open the **Nonnormal Distribution Options** outline. Note that the Nonnormal Capability Indices Method is set to **Percentiles**, the Johnson Distribution Fitting Method is set to **Quantile Matching**, and the Distribution Comparison Criterion is set to **AICc**.

**Figure 9.3** Completed Launch Window

![Completed Launch Window](image)

The Quantile Matching method is the default method used for fitting Johnson distributions because of its stability and speed as compared to Maximum Likelihood. Note that Maximum Likelihood is used in the Distribution platform.

7. Click **OK**.

8. Click the Goal Plot red triangle and select **Label Overall Sigma Points**.

9. Click the Capability Index Plot red triangle and select **Label Overall Sigma Points**.
The Goal Plot shows only one point and it corresponds to Process 7. The Capability Box Plots report shows a single box plot for Process 7. This is because the best fit for Process 7 is a normal distribution.

10. To the right of the Capability Index Plot, set the Ppk value to 2.
The Capability Index Plot shows Ppk values for all seven processes. Only two processes, Process 2 and Process 7, have capability values that exceed 2. Note that the best fitting nonnormal distributions are shown in parentheses to the right of the variable names in the Capability Index Plot. The best fitting distribution for Process 7 is not shown because it is a normal distribution.

11. Click the Process Capability red triangle and select Individual Detail Reports. Because you requested Best Fit in the launch window, the Compare Distributions option has been selected from each distribution’s red triangle menu.

The title of the report for Process 4 indicates that the capability calculations are based on a lognormal fit. All of the check boxes in the Compare Distributions report, except the boxes
for Nonparametric and Beta, are checked, indicating that these nine distributions are fit. (This is because you requested a Best Fit in the launch window.) The button that is selected in the Selected column indicates that the Lognormal distribution is the distribution that is used in the remainder of the Process 4 (Lognormal) Capability report to estimate capability and nonconformance.

The Compare Distributions report enables you to compare the nine distributional fits. The Histogram - Compare Distributions report gives a visual assessment of the fit and the Comparison Details report shows fit statistics for the selected distributions. Both the plot and the fit statistics indicate that the lognormal distribution gives the best fit among the selected distributions.

The Individual Detail Report information that is shown by default includes a histogram showing the estimated best-fit distribution, a summary of the process information, capability indices based on an overall estimate of sigma, parameter estimates for the fitted lognormal distribution, and observed and expected nonconformance levels.
Launch the Process Capability Platform

Launch the Process Capability Platform by selecting Analyze > Quality and Process > Process Capability. In Figure 9.6, all sections and panels have been opened.

Figure 9.6 Process Capability Launch Window

For more information about the options in the Select Columns red triangle menu, see Using JMP.
The Process Capability launch window contains the following outlines and options:

- “Process Selection”
- “Process Subgrouping”
- “Moving Range Options”
- “Historical Information”
- “Distribution Options”
- “Other Specifications”

After you click OK in the launch window, the Spec Limits window appears unless one of the following occurs:

- All of the columns contain specification limits.
- You selected No (skip columns with no spec limits) on the launch window.

The Spec Limits window also appears if you select Yes on the launch window. Otherwise, the Process Capability report window appears.

**Process Selection**

In the Process Capability launch window, select the process variables to include in the analysis.

**Y, Process** Assigns the variables that you want to analyze.

**Notes:**

- The Transform menu is not available for the Select Column list in the Process Capability launch window. Right-click a column heading in the data table and select New Formula Column to create a transform column for use in Process Capability. See Using JMP for more information about creating new formula columns.
- Reference columns for virtually joined tables are not available in the Process Capability platform.

**Process Subgrouping**

In the Process Capability launch window, the options in this section enable you to assign each variable in the Y, Process list a subgroup ID column or a constant subgroup size.

**Create Subgroups Using an ID Column**

1. Select a variable or variables in the Y, Process list.
2. Select Subgroup ID Column from the Subgroup with options.
3. Select a subgroup ID column in the Select Columns list.
4. Click Nest Subgroup ID Column.

The subgroup ID column appears in brackets to the right of the variable names in the Y, Process list.

Create Subgroups Using a Constant Subgroup Size
1. Select a variable or variables in the Y, Process list.
2. Select Constant Subgroup Size from the Subgroup with options.
3. Enter the subgroup size next to Set Constant Subgroup Size.
4. Click Subgroup by Size.

The subgroup size appears in brackets to the right of the variable names in the Y, Process list.

Nest Subgroup ID Column  (Available when you select Subgroup ID Column.) Assigns a column that you select from the Select Columns list to define the subgroups for the selected Y, Process columns.

Subgroup by Size  (Available when you select Constant Subgroup Size.) Assigns the subgroup size that you specify in the Set Constant Subgroup Size box to define the subgroups for the selected Y, Process columns.

Set Constant Subgroup Size  (Available when you select Constant Subgroup Size.) Specify the constant subgroup size for the selected Y, Process columns. You need to assign this value using Subgroup by Size.

Within-Subgroup Variation Statistic  (Available when Process Subgrouping is used.) Specifies if the within-subgroup estimate of standard deviation is calculated using standard deviations or ranges.

Calculate Between-and-Within Capability  (Available when Process Subgrouping is used.) Specifies that the between-and-within subgroup estimate of the standard deviation should be used in the capability analysis.

Moving Range Options

In the Process Capability launch window, the options in this section enable you to specify which moving range statistic is used in the within sigma estimate when subgrouping is not used.

Note: When you specify subgrouping and click Calculate Between-and-Within Capability, use the Moving Range Options outline to specify which moving range statistic is used in the between sigma estimate.
**Average of Moving Range**  Uses the mean of the moving ranges to estimate sigma. The moving range is the difference between two consecutive points.

**Median of Moving Range**  Uses the median of the moving ranges to estimate sigma.

### Historical Information

In the Process Capability launch window, the options in this section enable you to assign historically accepted values of the standard deviation to variables in the Y, Process list.

1. Select a variable or variables in the Y, Process list.
2. Enter a value next to Set Historical Sigma.
3. Select Use Historical Sigma to assign that value to the selected variables.

The specified value appears in parentheses in the expression “&Sigma()” to the right of the variable names in the Y, Process list.

**Note:** If you set a historical sigma, then subgroup assignments for the selected process variable are no longer relevant and are removed.

### Distribution Options

In the Process Capability launch window, the options in this section enable you to assign other distributions or calculation methods to variables in the Y, Process list and to specify options related to nonnormal calculations. Unless otherwise specified, all Y, Process variables are analyzed using the assumption that they follow a normal distribution.

- The available distributions are the Normal, Beta, Exponential, Gamma, Johnson, Lognormal, Mixture of 2 Normals, Mixture of 3 Normals, SHASH, and Weibull distributions. Except for Johnson distributions, maximum likelihood estimation is used to fit distributions. See “Johnson Distribution Fit Method”.
- The Best Fit option determines the best fit among the available distributions and applies this fit.
- The Nonparametric option fits a distribution using kernel density estimation.

For more options related to nonnormal fits, see “Nonnormal Distribution Options”.

### Specify a Distribution

1. Select a variable or variables in the Y, Process list.
2. Select a distribution from the Distribution list.
3. Select Set Process Distribution to assign that distribution to the selected variables.
The specified distribution appears in parentheses in the expression “&Dist()” to the right of the variable names in the Y, Process list.

**Note:** If you select a distribution other than Normal, you cannot assign a Subgroup ID column or a Historical Sigma. These selections are not supported by the methods used to calculate nonnormal capability indices. See “Statistical Details for Capability Indices for Nonnormal Distributions”.

### Nonnormal Distribution Options

**Nonnormal Capability Indices Method**  Specifies the method used to compute capability indices for nonnormal distributions. See “Statistical Details for Capability Indices for Nonnormal Distributions”.

**Johnson Distribution Fit Method**  Specifies the method used to find the best-fitting Johnson distribution. Before estimating the parameters, the best-fitting family of distributions is determined from among the Johnson Su, Sb, and Sl families. The procedure described in Slifker and Shapiro (1980) is used to find the best-fitting family.

**Quantile Matching**  The default method. It is more stable and faster than Maximum Likelihood. Quantile Matching Parameter estimates, assuming the best-fitting family, are obtained using a quantile-matching approach. See Slifker and Shapiro (1980).

**Maximum Likelihood**  Parameters for the best-fitting family are determined using maximum likelihood.

**Distribution Comparison Criterion**  (Available when a Best Fit Distribution is selected.) Specify the criterion that you want to use in determining a Best Fit. This criterion also determines the ordering of distributions in the Comparison Details report. See “Order by Comparison Criterion”.

### Other Specifications

The Process Capability launch window also contains the following options and specifications:

**By**  Produces a separate report for each level of the By variable. If more than one By variable is assigned, a separate report is produced for each possible combination of the levels of the By variables.

**Specify Alpha Level**  Specifies the significance level for confidence limits.

**Show Spec Limits Dialog**  Specifies how to handle columns that do not have specification limits.
Note: It is good practice to ensure that specification limits for all process variables are specified as Spec Limits column properties or to load specification limits from a Limits Data table (see “Limits Data Table”). Otherwise, you can specify limits interactively in the Spec Limits window that appears after you click OK in the launch window (unless you select No (skip columns with no spec limits) on the launch window).

Enter Specification Limits for a Process

The lower specification limit (LSL), upper specification limit (USL), and target define the lower bound, upper bound, and target value for a quality process. There are several ways to enter specification limits to use in a process capability analysis:

- Enter limits in the Spec Limits window after selecting columns in the launch window. See “Spec Limits Window”.
- Import limits from a JMP data table (known as a Limits Table). See “Limits Data Table”.
- Enter limits as Spec Limits column properties in the data table. See “Spec Limits Column Property”.
- If you are creating a Process Capability report by running a JSL script, enter limits in the script. See “The Process Capability Report”.

Only one specification limit is required for a selected column. If only the USL is specified, the box plots and Goal Plot point are colored blue. If only the LSL is specified, the box plots and Goal Plot point are colored red.

Spec Limits Window

You can enter known specification limits for a process in the Spec Limits window. This window appears if you selected If Needed or Yes for the Show Spec Limits Dialog options in the Process Capability launch window. Figure 9.7 shows the Spec Limits window for the Cities.jmp sample data table after selecting OZONE, CO, SO2, and NO as process variables in the launch window. Enter the known specification limits and click OK to view the Process Capability report.

You can specify process importance values for each column. Process importance values provide a mechanism to sort processes in the order that you prefer. Process importance values are used to size markers in many of the graphs in the Process Capability report.
If you select the Show Limits option for a process and then save the specification limits to a column property, the Show as Graph Reference Lines option is selected in the saved Spec Limits column property. If you select the Show Limits option for a process and then save the specification limits to a new table, the Show Limits column in the new table contains a 1 for the process. The Select All Show Limits button selects the Show Limits option for all processes.

Figure 9.7 Spec Limits Window for Cities.jmp

Limits Data Table

You can also specify limits in a process capability analysis using a limits data table. Click the Select Data Table button and then select the appropriate data table that contains the specification limits for the analysis. After you select the appropriate limits table, the values populate the window. Click OK to view the Process Capability report.

A limits data table can be in two different formats: tall or wide. A tall limits data table has one column for the responses and the limits key words are the other columns. A wide limits data table has a column for each response with one column to label the limits keys. Either of these formats can be read using the Load spec limits from data table option.

- A tall table contains four or five columns and has one row for each process. The first column has a character data type and contains the names of the columns analyzed in the Process Capability platform. The next three columns need to be named LSL, Target, and USL. These column names can also be preceded by an underscore character. The optional final column named Show Limits specifies if the specification limits are shown as reference lines in select analysis plots.
**Figure 9.8** Example of a Tall Specification Limits Table

<table>
<thead>
<tr>
<th>Process</th>
<th>_LSL</th>
<th>_Target</th>
<th>_USL</th>
</tr>
</thead>
<tbody>
<tr>
<td>OZONE</td>
<td>0.075</td>
<td>0.15</td>
<td>0.25</td>
</tr>
<tr>
<td>CO</td>
<td>5</td>
<td>7</td>
<td>12</td>
</tr>
<tr>
<td>SO2</td>
<td>0.01</td>
<td>0.04</td>
<td>0.09</td>
</tr>
<tr>
<td>NO</td>
<td>0.01</td>
<td>0.025</td>
<td>0.04</td>
</tr>
</tbody>
</table>

- A wide table contains three rows and one column for each column analyzed in the Process Capability platform plus a _LimitsKey column. In the _LimitsKey column, the three rows need to contain the identifiers _LSL, _Target, and _USL.

**Figure 9.9** Example of a Wide Specification Limits Table

<table>
<thead>
<tr>
<th>_LimitsKey</th>
<th>OZONE</th>
<th>CO</th>
<th>SO2</th>
<th>NO</th>
</tr>
</thead>
<tbody>
<tr>
<td>_LSL</td>
<td>0</td>
<td>5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>_Target</td>
<td>0.05</td>
<td>10</td>
<td>0.03</td>
<td>0.025</td>
</tr>
<tr>
<td>_USL</td>
<td>0.1</td>
<td>20</td>
<td>0.08</td>
<td>0.6</td>
</tr>
</tbody>
</table>

The easiest way to create a limits data table is to save results computed by the Process Capability platform. The Save options in the Process Capability red triangle menu enable you to save limits from the sample values. After entering or loading the specification limits, you can do the following:

- Select **Save > Save Spec Limits as Column Properties** to save the limits as Spec Limits column properties to the columns in the data table.
- Select **Save > Save Distributions as Column Properties** to save the distributions used in calculating capability as Process Capability Distribution column properties to the columns in the data table.
- Select **Save > Save Spec Limits to New Table** to save the limits to a new tall specification limits data table. If you have selected at least one nonnormal distribution, a column called Distribution that contains the specified distributions is also added to the limits data table.

See “Process Capability Platform Options”.
Spec Limits Column Property

In the Process Capability platform, you can use columns that have a spec limits column property. When you perform a capability analysis, you can use Column Properties > Spec Limits to save specification limits as a column property. The Spec Limits property applies only to numeric columns.

Some processes have one-sided specifications. Some have no target. You can enter any of these that apply: a lower specification limit, an upper specification limit, a target value, or a process importance value.

Figure 9.10 displays the Spec Limits section of the Column Properties window for OZONE in the sample data table Cities.jmp.

Figure 9.10 Spec Limits Section of the Column Properties Window

Tip: Saving specification limits as a column property ensures consistency when you repeat an analysis.

The Process Capability Report

By default, the Process Capability report contains the following plots:

- “Goal Plot” (provided only if at least one variable is fit with a normal distribution and shows only points for variables fit with normal distributions)
• “Capability Box Plots” (provided only if at least one variable is fit with a normal distribution and shows only box plots for variables fit with normal distributions)

• “Capability Index Plot”

Using the Process Capability red triangle menu, you can add individual detail reports, normalized box plots, and summary reports. The red triangle menu also has options for identifying out-of-spec values in your data table, creating a summary data table, changing the display order of analyzed columns, and saving out spec limits. These options are described in “Process Capability Platform Options”.

You can change the default report at File > Preferences > Platforms > Process Capability. You can also make changes to the appearance of reports produced by options by selecting the relevant Process Capability topic at File > Preferences > Platforms.

Goal Plot

In the Process Capability report, the Goal Plot shows the following for each variable:

• the spec-normalized mean shift on the horizontal axis
• the spec-normalized standard deviation on the vertical axis

The Goal Plot is useful for getting a quick, summary view of how the variables are conforming to specification limits. By default, the Goal Plot shows only those points for each column that are calculated using the overall sigma. Hover over each point to view the variable name and the sigma method used to calculate the point. See “Statistical Details for the Goal Plot” for more information about the calculation of the coordinates for the Goal Plot.

**Note:** Process variables with distributions other than Normal are not plotted on the Goal Plot.

Goal Plot Points

Points on the Goal Plot correspond to columns, not rows. Selecting a point in the Goal Plot selects the corresponding column in the data table. If process importance values are specified, the goal plot points are sized by importance.

Hover over a point in the Goal Plot to view a control chart for that process. Click the control chart to launch Control Chart Builder with the corresponding control chart and capability report.

**Note:** A control chart is not available for a process if the unbiased pooled standard deviation is chosen as the within-group variation statistic for that process.
The points on the Goal Plot are also linked to the rows of the Goal Plot Summary Table, where each row corresponds to a column. You can select a point in the Goal Plot, right-click, and apply row states. These row states are applied to the rows of the Goal Plot Summary Table. Row states that you apply in the Goal Plot Summary Table are reflected in the Goal Plot. To see this table, select Make Goal Plot Summary Table from the Process Capability red triangle menu. See “Make Goal Plot Summary Table”.

Tip: If you hide a point in the Goal Plot, you can show the point again by changing the corresponding row state in the Goal Plot Summary Table.

Goal Plot Triangle

The goal plot triangle appears in the center of the bottom of the Goal Plot. The slider to the right of the plot enables you to adjust the size of goal triangle in the plot.

By default, the Ppk slider and the value beneath it are set to Ppk = 1. This approximates a non-conformance rate of 0.0027, if the distribution is normal. The goal triangle represents the Ppk shown in the box. To change the Ppk value, move the slider or enter a number in the box.

JMP gives the Goal Plot in terms of Ppk values by default. You can change this preference at File > Preferences > Platforms > Process Capability. When the AIAG (Ppk) Labeling preference is unchecked, all of the Ppk labeling is changed to Cpk labeling, including the label of the slider to the right of the goal plot.

Goal Plot Options

The Goal Plot red triangle menu has the following options:

Show Within Sigma Points  Shows or hides the points calculated using the within sigma estimate.

Show Within or Between-and-Within Sigma Points  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides the points calculated using the within sigma estimate or, if specified, the between-and-within sigma estimate.

Show Overall Sigma Points  Shows or hides the points calculated using the overall sigma estimate.

Shade Levels  Shows or hides the Ppk level shading (Figure 9.11). When you select Shade Levels, shaded areas appear in the plot. The shaded areas depend on the relationship between \( p \) and Ppk, with \( p \) representing the value shown in the box beneath Ppk:

- Points in the red area have Ppk < \( p \).
- Points in the yellow area have \( p < \text{Ppk} < 2p \).
Points in the green area have $2p < Ppk$.

**Label Within Sigma Points** Shows or hides labels for points calculated using the within sigma estimate.

**Label Within or Between-and-Within Sigma Points** (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides labels for points calculated using the within sigma estimate or, if specified, the between-and-within sigma estimate.

**Label Overall Sigma Points** Shows or hides labels for points calculated using the overall sigma estimate.

**Defect Rate Contour** Shows or hides a contour representing a specified defect rate.

*Figure 9.11* shows the Goal Plot for the entire data set for the *Semiconductor Capability.jmp* sample data table after selecting Shade Levels and Show Within Sigma Points from the Goal Plot red triangle menu.

*Figure 9.11* Goal Plot

---

**One-Sided or Missing Specification Limits**

When there is only one specification limit for a column, markers and colors are used in the following ways:

- If only the upper specification limit (USL) is specified, the point on the Goal Plot is represented by a right-pointing triangle and is colored blue.
• If only the lower specification limit (LSL) is specified, the point on the Goal Plot is represented by a left-pointing triangle and is colored red.
• If at least one process has only an upper specification limit, the right half of the goal triangle is blue.
• If at least one process has only a lower specification limit, the left half of the goal triangle is red.

Processes with only an upper specification limit are represented by blue and should be compared to the blue (right) side of the goal triangle. Processes with only a lower specification limit are represented by red and should be compared to the red (left) side of the goal triangle. For more information about how the coordinates of points are calculated, see “Statistical Details for the Goal Plot”.

**Capability Box Plots**

In the Process Capability report, the Capability Box Plots show a box plot for each variable selected in the analysis. The values for each column are centered by their target value and scaled by the difference between the specification limits. If the target is not centered between the specification limits, the values are scaled by twice the minimum difference between the target and specification limits. For each process column $Y_j$ (see “Statistical Details on Notation” for a description of the notation):

$$Z_{ij} = \frac{Y_{ij} - T_j}{2 \times \min(T_j - LSL_j, USL_j - T_j)}$$

For a process with a one-sided specification, see “One-Sided or Missing Specification Limits”. For the situation where no target is specified, see “Statistical Details for Capability Box Plots”.

**Note:** Process variables with distributions other than Normal are not plotted on the Capability Box Plot.

Figure 9.12 shows a Capability Box Plots report for eight variables in the Semiconductor Capability.jmp sample data table.
The plot displays dotted green lines drawn at ±0.5.

- For a process with a target that is centered between its specification limits, the dotted green lines represent the standardized specification limits.
- For a process with a target that is not centered between its specification limits, one of the dotted green lines represents the standardized specification limit for the limit closer to the target. The other dotted green line represents the same distance in the opposite direction.

This plot is useful for comparing variables with respect to their specification limits. For example, in Figure 9.12, the majority of points for IVP1 are above its USL, and the majority of its points for IVP2 are less than its target. PNP2 seems to be on target with all data points in the specification limits.

**One-Sided or Missing Specification Limits**

When there is only one specification limit for a column, colors are used in the following ways:

- If only the upper specification limit (USL) is specified, the box plot is colored blue.
- If only the lower specification limit (LSL) is specified, the box plot is colored red.
- If at least one process has only an upper specification limit, the dotted line at 0.5 is blue.
- If at least one process has only a lower specification limit, the dotted line at -0.5 is red.
Suppose that only the lower specification limit is specified and that the process target is specified. The capability box plot is based on the following values for the transformed observations. See “Statistical Details on Notation” for a description of the notation:

\[
Z_{ij} = \frac{Y_{ij} - T_j}{2(T_j - \text{LSL}_j)}
\]

Suppose that only the upper specification limit is specified and that the process target is specified. The capability box plot is based on the following values for the transformed observations:

\[
Z_{ij} = \frac{Y_{ij} - T_j}{2(\text{USL}_j - T_j)}
\]

For more information about how missing targets are handled with one-sided specification limits, see “Single Specification Limit and No Target”.

**Capability Index Plot**

In the Process Capability report, the Capability Index Plot shows Ppk values for all variables that you entered as Y, Process in the launch window. Each variable name appears on the horizontal axis and the Ppk values appear on the vertical axis. If you fit a nonnormal distribution, the fitted distribution name appears in the plot as a parenthetical suffix to the variable name. If process importance values are specified, the points on the capability index plot are sized by importance. A horizontal line is placed at the Ppk value that is specified by the slider to the right of the plot.

Hover over a point in the Capability Index Plot to view a control chart for that process. Click the control chart to launch Control Chart Builder with the corresponding control chart and capability report.

**Note:** A control chart is not available for a process if the unbiased pooled standard deviation is chosen as the within-group variation statistic for that process.

*Figure 9.13* shows a Capability Index Plot report for the Process Measurements.jmp sample data table. Six of the variables are fit with nonnormal distributions. Process 7 is fit with a normal distribution. Points have been labeled using the Label Overall Sigma Points option that is available in the Capability Index Plot red triangle menu.
Figure 9.13 Capability Index Plot with Nonnormal Distributions

Capability Index Plot Options

The Capability Index Plot red triangle menu has the following options:

Show Within Sigma Points  Shows or hides the points calculated using the within sigma estimate.

Show Within or Between-and-Within Sigma Points  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.)  Shows or hides the points calculated using the within sigma estimate or, if specified, the between-and-within sigma estimate.

Show Overall Sigma Points  Shows or hides the points calculated using the overall sigma estimate.

Shade Levels  Shows or hides the Ppk level shading. When you select Shade Levels, shaded areas appear in the plot. The shaded areas depend on the relationship between \( p \) and Ppk, with \( p \) representing the value shown in the box beneath Ppk:

- Points in the red area have Ppk < \( p \).
- Points in the yellow area have \( p < \text{Ppk} < 2p \).
- Points in the green area have \( 2p < \text{Ppk} \).
Chapter 9
Quality and Process Methods

Process Capability Platform Options

The Process Capability red triangle menu contains the following options:

**Individual Detail Reports**  Shows or hides individual detail reports for each variable in the analysis. See “Individual Detail Reports”.

**Goal Plot**  Shows or hides a goal plot for the data. The Goal Plot shows the spec-normalized mean shift on the x-axis and the spec-normalized standard deviation on the y-axis for each variable. See “Goal Plot”. (Only variables for which you specify normal distributions are shown on the plot.)

**Capability Box Plots**  Shows or hides a capability box plot for each variable in the analysis. The values for each column are centered by their target value and scaled by twice the minimum difference between the target value and the specification limits. See “Capability Box Plots”. (Box plots are shown only for variables for which you specify normal distributions.)

**Normalized Box Plots**  Provides two options for plots that show normalized box plots for each process variable. Each column is standardized by subtracting its mean and dividing by an estimate of the column’s standard deviation. The box plot is constructed using quantiles for the standardized values. See “Normalized Box Plots”. (Normalized box plots are shown only for variables for which you specify normal distributions.)

**Within Sigma Normalized Box Plots**  Shows or hides a plot called Within Sigma Normalized Box Plots. The box plots are constructed using the within-subgroup estimate of standard deviation.

**Within or Between-and-Within Sigma Normalized Box Plots**  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides a plot called Within or Between-and-Within Normalized Box Plots. The box plots are constructed using the within group estimate of the standard deviation or, if specified, the between-and-within estimate.

**Label Within Sigma Points**  Shows or hides labels for points calculated using the within sigma estimate.

**Label Within or Between-and-Within Sigma Points**  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides labels for points calculated using the within sigma estimate or, if specified, the between-and-within sigma estimate.

**Label Overall Sigma Points**  Shows or hides labels for points calculated using the overall sigma estimate.
Overall Sigma Normalized Box Plots  Shows or hides a plot called Overall Sigma Normalized Box Plots. The box plots are constructed using the overall estimate of standard deviation.

Capability Index Plot  Shows overall Ppk values for all variables that you entered as Y, Process. See “Capability Index Plot”.

Process Performance Plot  Shows or hides a four-quadrant plot of capability versus stability. Each process that has at least one specification limit is represented by a point. See “Process Performance Plot”.

Summary Reports  Provides two options for summary reports of capability indices. See “Summary Reports”.

Within Sigma Summary Report  Shows or hides a summary report of capability indices calculated using the within-subgroup estimate of standard deviation. (Results are available only for variables with specified normal distributions.)

Within or Between-and-Within Sigma Summary Report  (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides a summary report of capability indices calculated using the within group estimate of the standard deviation or, if specified, the between-and-within group estimate.

Overall Sigma Summary Report  Shows or hides a summary report of capability indices calculated using the overall estimate of standard deviation.

Action Options

The following red triangle menu options perform actions:

Out of Spec Values  Provides options for the cells in the data table containing values that are out of spec.

Select Out of Spec Values  Selects all rows and columns in the data table that contain at least one value that does not fall within the specification limits.

Color Out of Spec Values  Colors the cells in the data table that correspond to values that are out of spec. The cell is colored blue if the value is above the USL and red if the value is below the LSL.

Tip: To remove colors in specific cells, select all cells of interest. Right-click in one of the cells and select Clear Color. To remove colors in all cells, deselect Color Out of Spec Values.

Make Goal Plot Summary Table  Creates a summary table for the points plotted in the Goal Plot. This table includes the variable’s name, its spec-normalized mean shift, and its
spec-normalized standard deviation. Each variable has two rows in this table: one for each sigma type (within and overall). See “Make Goal Plot Summary Table”.

**Order By**  Reorders the box plots, summary reports, and individual detail reports. You can reorder by Initial Order, Reverse Initial Order, Within Sigma Cpk Ascending, Within or Between-and-Within Sigma Cpk Ascending, Within Sigma Cpk Descending, Within or Between-and-Within Sigma Cpk Descending, Overall Sigma Ppk Ascending, or Overall Sigma Ppk Descending. The options that order by Within Sigma reorder plot elements only for variables with specified normal distributions.

**Note:** The options to order by Within or Between-and-Within Sigma are available only if Calculate Between-and-Within Capability is selected for at least one process in the launch window.

**Save**  Provides options for saving specification limits and distributions.

**Save Spec Limits as Column Properties**  Saves the specification limits to a column property for each variable in the analysis. If no Spec Limits column property is present, the column property is created. If a Spec Limits column property is present, the values in the column property are overwritten. See “Spec Limits Column Property”.

**Save Distributions as Column Properties**  Saves the distribution used in calculating capability as a Process Capability Distribution column property. See *Using JMP*.

If a column contains the Distribution property specifying a nonnormal distribution and no Process Capability Distribution property, then the Process Capability platform applies a nonnormal fit. The Process Capability platform uses the distribution specified in the Distribution column property, or a Johnson fit if that distribution is not supported in Process Capability. If a column contains the Process Capability Distribution property, then the Process Capability platform uses the distribution specified in the Process Capability Distribution column property.

**Note:** If you want to use a specific distribution in the Process Capability platform, save it as a Process Capability Distribution column property.

**Save Spec Limits to New Table**  Saves the specification limits and the setting for Show Limits for each process to a limits data table in tall format. See “Limits Data Table”.

**Relaunch Dialog**  Opens the platform launch window and recalls the settings used to create the report.

See *Using JMP* for more information about the following options:

**Local Data Filter**  Shows or hides the local data filter that enables you to filter the data used in a specific report.
**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Platform Preferences**  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

**Save By-Group Script**  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

**Individual Detail Reports**

In the Process Capability red triangle menu, the Individual Detail Reports option displays a capability report for each variable in the analysis.

**Normal Distributions**

*Figure 9.14* shows the Individual Detail Report for PNP1 from the Semiconductor Capability.jmp sample data table as described in “Example of the Process Capability Platform with Normal Variables”.
The Individual Details report for a variable with a normal distribution shows a histogram, process summary details, and capability and nonconformance statistics. The histogram shows the distribution of the values, the lower and upper specification limits and the process target (if they are specified), and one or two curves showing the assumed distribution. The histogram in Figure 9.14 shows two normal curves, one based on the overall estimate of standard deviation and the other based on the within-subgroup estimate.

When you fit your process with a normal distribution, the Process Summary includes the Stability Index, which is a measure of stability of the process. The stability index is defined as follows:

\[
\text{Stability Index} = \frac{\text{Overall Sigma}}{\text{Within Sigma}}
\]

If Calculate Between-and-Within Capability is specified for a process in the launch window, the stability index for that process is defined as follows:

\[
\text{Stability Index} = \frac{\text{Overall Sigma}}{\text{Between-and-Within Sigma}}
\]

A stable process has stability index near one. Higher values indicate less stability.
Note: You can change the preferences for stability assessment type in File > Preferences > Platforms > Process Capability. This changes the stability assessment type used through the Process Capability platform.

Nonnormal Distributions

Note: Capability indices based on within-subgroup variation and stability indices are not available for processes for which you have specified nonnormal distributions.

Figure 9.15 shows the Individual Detail Report for Process 1 from the Process Measurements.jmp sample data table as described in “Example of the Process Capability Platform with Nonnormal Variables”.

Figure 9.15 Individual Detail Report for Process 1

The report opens with a note summarizing the Nonnormal Distribution Options that you selected in the launch window.
The Individual Details report for a variable with a nonnormal distribution shows a histogram, process summary details, and capability and nonconformance statistics. The histogram shows the distribution of the values, the lower and upper specification limits and the process target (if they are specified). A curve showing the fitted distribution is superimposed on the histogram. If you selected a Nonparametric distribution, the curve shown in the histogram is the nonparametric density.

The report also shows a Parameter Estimates report if you selected a nonnormal parametric distribution or a Nonparametric Density report if you selected a Nonparametric fit. See “Parameter Estimates” and “Nonparametric Density”.

**Individual Detail Report Options**

The outline title for each variable in the Individual Detail Reports section is of the form <Variable Name> Capability. However, if you request nonnormal capability, the relevant distribution name is shown parenthetically in the outline title.

Each Capability report has a red triangle menu with the following options:

**Compare Distributions**  Shows or hides the control panel for comparing distributions for the process. See “Compare Distributions”.

**Process Summary**  Shows or hides the summary statistics for the variable, including the overall sigma estimate, and, if you have specified a normal distribution, the within sigma estimate and the stability index. If you have specified Calculate Between-and-Within Capability for at least one process in the launch window, estimates for the between sigma and the between-and-within sigma are also included.

**Histogram**  Shows or hides the histogram of the values of the variable. The histogram report includes a red triangle menu that controls the following features of the histogram:

**Show Spec Limits**  Shows or hides vertical red lines on the histogram at the specification limits for the process.

**Show Target**  Shows or hides a vertical green line on the histogram at the process target.

**Show Within Sigma Density**  Shows or hides an approximating normal density function on the histogram with mean given by the sample mean and standard deviation given by the within estimate of sigma.

**Show Between-and-Within Sigma Density** (Available only when Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides an approximating normal density function on the histogram with mean given by the sample mean and standard deviation given by the between-and-within estimate of sigma.
Show Overall Sigma Density  Shows or hides an approximating normal density function on the histogram with mean given by the sample mean and standard deviation given by the overall estimate of sigma.

Show Count Axis  Shows or hides an additional axis to the right of the histogram plot showing the count of observations.

Show Density Axis  Shows or hides an additional axis to the right of the histogram plot showing the density.

Capability Indices  Controls display of the following capability index reports:

**Within Sigma Capability**  (Available when distribution is Normal.) Shows or hides capability indices (and confidence intervals) based on the within (short-term) sigma.

**Between-and-Within Sigma Capability**  (Available only when distribution is Normal and Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides capability indices based on the between-and-within sigma.

**Within Sigma Z Benchmark**  (Available when distribution is Normal.) Shows or hides Z benchmark indices based on the within (short-term) sigma.

**Between-and-Within Sigma Z Benchmark**  (Available only when distribution is Normal and Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides Z benchmark indices based on the between-and-within sigma.

**Within Sigma Target Index**  (Available when distribution is Normal.) Shows or hides an estimate of the target index that is based on the within (short-term) sigma.

**Between-and-Within Sigma Target Index**  (Available only when distribution is Normal and Calculate Between-and-Within Capability is selected for at least one process in the launch window.) Shows or hides an estimate of the target index that is based on the between-and-within sigma.

**Overall Sigma Capability**  Shows or hides capability indices (and confidence intervals) based on the overall (long-term) sigma.

**Overall Sigma Z Benchmark**  (Available when distribution is Normal.) Shows or hides Z benchmark indices based on the overall (long-term) sigma.

**Note:** By default, the confidence intervals for the capability indices are constructed based on $\alpha = 0.05$. To change the default confidence level, select File > Preferences > Platforms > Process Capability.
**Nonconformance**  Shows or hides the observed and expected percentages of observations below the LSL, above the USL, and outside of the specification limits. The Nonconformance table contains hidden columns for observed and expected PPM and counts.

**Interactive Capability Plot**  Shows or hides the Interactive Capability Plot. The Interactive Capability Plot enables you to change the value of one or more summary statistics and see how the changes affect the capability analysis. There are Original and New reports that show the original and new summary statistics, capability indices, and expected PPM. Use the slider controls or text boxes to change the spec limits, mean, and overall sigma from the original values. You can also use the Mean Shift box to shift the mean by a factor of the original sigma. The Interactive Capability Plot report has the following red triangle menu options:

- **Capability**  Shows or hides the capability indices in the Original and New reports.

- **Expected PPM**  Shows or hides the expected PPM values in the Original and New reports.

- **Revert to Original Values**  Reverts the interactive capability plot and the summary values in the New report back to the original values.

- **Save New Spec Limits as a Column Property**  Saves the new specification limits as a Spec Limits column property to the column in the original data table.

**Note:** The analysis is not rerun with the new specification limits unless the Auto Recalc option is turned on.

**Parameter Estimates**  (Available when a distribution other than Normal or Nonparametric is selected.) Shows or hides the Parameter Estimates report, which gives estimates for the parameters of the selected distribution.

The estimates for all except the Johnson family distributions are obtained using maximum likelihood. For more information about Johnson family fits, see “Johnson Distribution Fit Method”.

The parameters and probability density functions for the normal, beta, exponential, gamma, Johnson, lognormal, and Weibull distributions are described in “Statistical Details for Capability Indices for Nonnormal Distributions”. These are the same parameterizations used in the Distribution platform, with the exception that Process Capability does not support threshold parameters. See Basic Analysis.

**Fix Parameters**  (Available when a distribution other than Normal or Nonparametric is selected.) Displays a window that enables you to fix one or more parameter values in a nonnormal distribution. Enter a value in the User-defined Value column for the parameters that you would like to fix. Once you click OK, the omitted parameter values
are re-estimated given the fixed parameter values. The re-estimated parameter values appear in the Parameter Estimates report, along with a column indicating which parameters are fixed.

**Nonparametric Density**  (Available when Nonparametric is selected as the distribution.)
Shows or hides the Nonparametric Density report, which gives the *kernel bandwidth* used in fitting the nonparametric distribution. The kernel bandwidth is given by the following, where \( n \) is the number of observations and \( S \) is the uncorrected sample standard deviation:

\[
\text{bandwidth} = \frac{0.95}{n^{1/5}}
\]

**Compare Distributions**

In the Process Capability platform, the Compare Distributions report enables you to compare and apply various distributional fits. Note the following:

- Your selected distribution is indicated in the Selected column.
- The report initially shows fit statistics for your Selected distribution and other fitted distributions in the Comparison Details report. If you selected Best Fit, the Comparison Details report initially shows statistics for all parametric fits.
- Check the distributions in the Distribution list that you want to compare.
  - The probability density function for the best fitting distribution in each family that you select is superimposed on the histogram in the Histogram - Compare Distributions report.
  - If the distribution is parametric, a row for that family containing fit results is added to the Comparison Details report.
  - If Nonparametric is checked in the Distribution list, the Nonparametric Density report, showing the automatically selected kernel bandwidth, is added to the Compare Distributions report. See “Nonparametric Density”.
  - You can change your selected distribution by selecting its radio button under Selected. The capability report is updated to show results for the selected distribution.

*Figure 9.16* shows the Compare Distributions report for Process 1 in the Process Measurements.jmp sample data table. The Selected distribution, which is Lognormal, is being compared to a Normal distribution. The Comparison Details report shows fit statistics for both distributions.

To obtain probability plots, click the Compare Distributions red triangle and select Probability Plots. The points in the probability plot for the normal distribution in *Figure 9.16* do not follow the line closely. This indicates a poor fit.
Figure 9.16  Compare Distributions with Probability Plot for Normal

Compare Distributions Options

The Compare Distributions red triangle menu contains the following options:

**Comparison Details**  For each distribution, gives AICc, BIC, and -2Loglikelihood values. See *Fitting Linear Models*. (Not available for a Nonparametric fit.)

**Comparison Histogram**  Shows or hides the Histogram report.

**Probability Plots**  Shows or hides a report that displays probability plots for each parametric distribution that you fit (Figure 9.16). An observation’s horizontal coordinate is its observed data value. An observation’s vertical coordinate is the value of the quantile of the
fitted distribution for the observation’s rank. For the normal distribution, the overall estimate of sigma is used in determining the fitted distribution.

The red triangle menus associated with each Probability Plot contain the following options.

**Simultaneous Empirical Confidence Limits**  Shows or hides confidence limits that have a simultaneous 95% confidence level of containing the true probability function, given that the data come from the selected parametric family. These limits have the same estimated precision at all points. Use them to determine whether the selected parametric distribution fits the data well. See Nair (1984) and Meeker and Escobar (1998).

**Simultaneous Empirical Confidence Limits Shading**  Shows or hides shading of the region between the Simultaneous Empirical Confidence Limits.

**Parametric Fit Line**  Shows or hides the line that shows the predicted probabilities for the observations based on the fitted distribution.

**Parametric Fit Confidence Limits Shading**  Shows or hides shading of the region between parametric fit confidence intervals. The parametric fit confidence limits have confidence level (1 - Alpha), where Alpha is the value that you specify in the launch window. (Available only when the parametric fit confidence limits are meaningful and when it is possible to calculate them.)

When possible, the intervals are computed by expressing the parametric distribution $F$ as a location-scale family, so that $F(y) = G(z)$, where $z = (y - \mu)/\sigma$. The approximate standard error of the fitted location-scale component at a point is computed using the delta method. Using the standard error estimate, a Wald confidence interval for $z$ is computed for each point. The confidence interval for the cumulative distribution function $F$ is obtained by transforming the Wald interval using $G$. Note that, in some cases, special accommodations are required to provide appropriate intervals near the endpoints of the interval of process measurements.

**Order by Comparison Criterion**  Orders the distributions in the Comparison Details report according to the criterion that you select. The default ordering is by AICc, unless you selected another criterion in the Distribution Comparison Criterion panel in the launch window.
Normalized Box Plots

In the Process Capability red triangle menu, the Normalized Box Plots options show or hide box plots that have been normalized using the specified sigma in the title. When drawing normalized box plots, JMP standardizes each column by subtracting the mean and dividing by the standard deviation. The box plots are formed for each column using these standardized values.

Figure 9.17  Within Sigma Normalized Box Plot

Figure 9.17 shows the Within Sigma Normalized Box Plot for a selection of the process variables in the Semiconductor Capability.jmp sample data table using wafer as a subgroup variable.

The green vertical lines represent the specification limits for each variable normalized by the mean and standard deviation of each variable. The gray dotted vertical lines are drawn at ±0.5, since the data is standardized to a standard deviation of 1.
Process Performance Plot

In the Process Capability red triangle menu, the Process Performance Plot option shows or hides a four-quadrant plot of capability versus stability. Each process that has specification limits is represented by a point. If process importance values are specified, the points are sized by importance. The horizontal coordinate of each point equals the stability index of the process and the vertical coordinate of each point equals the overall Ppk capability of the process. The plot is divided into four shaded quadrants based on the following default boundaries:

- A stability index that exceeds 1.25 indicates that the process is unstable.
- A Ppk that is smaller than 1.0 indicates that the process is not capable.

Additionally, there is a red line on the graph that indicates where the Cpk value is 1. The boundaries that define the four quadrants can be adjusted using the Ppk and Stability Index slider controls to the right of the plot. You can also set preferences for your desired Capability and Stability boundaries, as well as stability assessment type in File > Preferences > Platforms > Process Capability Performance Plot and File > Preferences > Platforms > Process Capability.

The legend contains descriptions of the shaded regions. If any of the processes are missing a lower or upper specification limit, the legend also shows the markers used for those processes. If the markers do not appear in the legend, then all of the processes in the plot contain both lower and upper specification limits. See “One-Sided or Missing Specification Limits”.

Hover over a point in the Process Performance Plot to view a control chart for that process. Click the control chart to launch Control Chart Builder with the corresponding control chart and capability report.

**Note:** A control chart is not available for a process if the unbiased pooled standard deviation is selected as the within-group variation statistic for that process.

The Process Performance Plot red triangle menu contains the following option:

**Label Points** Shows or hides labels for each point in the Process Performance Plot.

**Show Within Cpk Curve** Shows or hides the within Cpk curve in the Process Performance Plot.
Figure 9.18 shows the Process Performance Plot for a selection of the process variables in the Semiconductor Capability.jmp sample data table using wafer as a subgroup variable.

Summary Reports

In the Process Capability red triangle menu, the Summary Report options show or hide a table that contains the following statistics for each variable: LSL, Target, USL, Sample Mean, various Sigma estimates, Stability Index, Cpk, Cpl, Cpu, Cp, Cpm, and Nonconformance statistics. If there is at least one nonmissing process importance value, an Importance column is also included in the Summary Report. These statistics are calculated using the sigma estimate specified in the report title. The columns for Stability Index, Cpk, Cpl, Cpu, and Cp are colored as green, yellow, and red to indicate adequate, marginal, and poor stability or capability. This color coding scheme matches what you would see in the Process Performance graph.

Note: You can change the preferences for stability assessment type in File > Preferences > Platforms > Process Capability. This changes the stability assessment type used through the Process Capability platform.
Figure 9.19 shows a subset of columns for both summary reports as described in “Example of the Process Capability Platform with Normal Variables”. The following optional columns are available for this report:

- Confidence intervals for Cpk, Cpl, Cpu, CP, and Cpm
- Expected and observed PPM statistics (outside, below LSL, above USL)

**Note:** The expected PPM statistics are the percentages you would expect to see based on the distribution chosen. By default, the distribution is normal. The observed PPM statistics are the percentages based on the actual data.

- Sample standard deviation
- The sample size (N), the minimum, and the maximum.
- Target Index

**Note:** Target Index is only available in the Within Sigma Capability Summary report.

To reveal these optional columns, right-click the report and select the column names from the Columns submenu.

Note that the report (based on overall sigma) shows the overall capability indices Ppk, Ppl, Ppu, and Pp instead of the within capability indices Cpk, Cpl, Cpu, and Cp. The labeling of the overall capability indices depends on the setting of the AIAG (Ppk) Labeling preference.

**Figure 9.19** Within Sigma and Overall Sigma Capability Summary Reports
Make Goal Plot Summary Table

In the Process Capability red triangle menu, the Make Goal Plot Summary Table option produces a summary data table that includes each variable’s name, its spec-normalized mean shift (Spec-Standardized Mean), and its spec-normalized standard deviation (Spec-Standardized Std Dev). For each variable, there is a row for each of the sigma types.

**Note:** If a variable is fit with a distribution other than normal, the name of the fitted distribution is appended parenthetically to the variable name. The Spec-Standardized Mean and Spec-Standardized Std Dev values are not provided for nonnormal variables.

The points in the Goal Plot are linked to the rows in the Goal Plot Summary Table. If you apply row states to a point in the Goal Plot, you can change the corresponding row states in the Goal Plot Summary Table. Conversely, if you apply row states in the Goal Plot Summary Table, they are reflected on the Goal Plot.

**Figure 9.20** shows the Goal Plot Summary Table for the Semiconductor Capability.jmp sample data table as described in “Example of the Process Capability Platform with Normal Variables”.

**Figure 9.20** Summary Table

<table>
<thead>
<tr>
<th>Process</th>
<th>Sigma Type</th>
<th>Spec-Standardized Mean</th>
<th>Spec-Standardized Std Dev</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 PNP1</td>
<td>Within</td>
<td>0.0605056038</td>
<td>0.2240448185</td>
</tr>
<tr>
<td>2 PNP2</td>
<td>Within</td>
<td>-0.00733452</td>
<td>0.0658873257</td>
</tr>
<tr>
<td>3 NPN2</td>
<td>Within</td>
<td>0.0580798256</td>
<td>0.0621472935</td>
</tr>
<tr>
<td>4 PNP3</td>
<td>Within</td>
<td>0.3154424678</td>
<td>0.2653278331</td>
</tr>
<tr>
<td>5 IVP1</td>
<td>Within</td>
<td>1.3681693325</td>
<td>0.5591421926</td>
</tr>
<tr>
<td>6 PNP4</td>
<td>Within</td>
<td>0.0300774244</td>
<td>0.0566663241</td>
</tr>
<tr>
<td>7 NPN3</td>
<td>Within</td>
<td>-0.05674621</td>
<td>0.0503161575</td>
</tr>
<tr>
<td>8 IVP2</td>
<td>Within</td>
<td>-0.65593547</td>
<td>1.1945993146</td>
</tr>
<tr>
<td>9 PNP1</td>
<td>Overall</td>
<td>0.0605056038</td>
<td>0.2199861461</td>
</tr>
<tr>
<td>10 PNP2</td>
<td>Overall</td>
<td>-0.00733452</td>
<td>0.0663490674</td>
</tr>
<tr>
<td>11 NPN2</td>
<td>Overall</td>
<td>0.0580798256</td>
<td>0.0612473972</td>
</tr>
<tr>
<td>12 PNP3</td>
<td>Overall</td>
<td>0.3154424678</td>
<td>0.2610147096</td>
</tr>
<tr>
<td>13 IVP1</td>
<td>Overall</td>
<td>1.3681693325</td>
<td>0.5536059447</td>
</tr>
<tr>
<td>14 PNP4</td>
<td>Overall</td>
<td>0.0300774244</td>
<td>0.0556117297</td>
</tr>
</tbody>
</table>
Additional Examples of the Process Capability Platform

This section contains examples using the Process Capability platform.

- “Example of Process Capability for a Stable Process”
- “Example of Process Capability for an Unstable Process”
- “Example of the Simulation of Confidence Limits for a Nonnormal Process Ppk”

Example of Process Capability for a Stable Process

In this example, you verify the assumptions that enable you to estimate PPM defective rates based on a capability analysis. You access Process Capability through Control Chart Builder and then directly. The data consist of 22 subgroups of size five. There are six missing readings, with three in each of two consecutive subgroups.

Process Capability through Control Chart Builder

You can use Control Chart Builder to check process stability and the normality assumption for your process characteristic. You can also obtain Process Capability information directly within Control Chart Builder.

1. Select Help > Sample Data Folder and open Quality Control/Clips2.jmp.
2. Select Analyze > Quality and Process > Control Chart Builder.
3. Drag Date to the Subgroup zone.
4. Drag Gap to the Y zone.
The control chart indicates that Gap is stable over time. Because Gap has the Spec Limits column property, a Process Capability Analysis report appears to the right of the control chart.

The histogram and fitted normal blue curve suggest that the distribution of Gap is approximately normal. Although the process is stable, the distribution of Gap is shifted to the right of the specification range.

The Process Summary report shows the specification limits that are saved to the Spec Limits column property. It also shows that the estimate of sigma calculated from within-subgroup variation (Within Sigma) does not differ greatly from the overall estimate.
given by the sample standard deviation (Overall Sigma). Consequently, the Stability Index is near one (0.979268). This is expected because the process is stable.

5. Right-click in the body of the Nonconformance report and select **Expected Within PPM** from the Columns submenu.

**Figure 9.23** Capability Indices and Nonconformance Report

The Cpk value calculated using subgroup variation is 0.966, indicating that the process is not very capable. The Cpl value suggests good performance, but this is because the process is shifted away from the lower specification limit. Defective parts generally result from large values of \( \text{Gap} \).

Note that the confidence interval for Cpk is wide; it ranges from 0.805 to 1.128. This occurs even though there are 104 observations. Capability indices are surprisingly variable, due to the fact that they are ratios. It is easy to reach incorrect conclusions based on the point estimate of a capability index.

The estimates of out-of-specification product given in the Nonconformance report provide a direct measure of process performance. The PPM values in the Nonconformance report indicate that \( \text{Gap} \) hardly ever falls below the lower specification limit (1.4 parts per million). However, the number of parts for which \( \text{Gap} \) falls above the upper specification limit is 1869.0 parts per million.

For an uncentered process, the Cp value indicates potential capability if the process were adjusted to be centered. If this process were adjusted to be centered at the target value of 14.8, then its capability would be 1.264, with a confidence interval from 1.071 to 1.457.

**Process Capability Platform**

Now that you have verified stability and normality for \( \text{Gap} \), you can obtain additional information in the Process Capability platform.

1. Select **Analyze > Quality and Process > Process Capability**.
2. Select Gap and click **Y, Process**.
3. Open the **Process Subgrouping** outline.
4. Select Date in the Select Columns list and Gap in the Y, Process list.

5. Click **Nest Subgroup ID Column**.

   By default, the Within-Subgroup Variation Statistic selection is set to Average of Unbiased Standard Deviations. In the Control Chart Builder example ("Process Capability through Control Chart Builder"), subgroup ranges were used.

6. Click **OK**.

**Figure 9.24** Goal Plot and Box Plot for Gap

The Goal Plot shows the Ppk index for Gap as being essentially equal to 1. The box plot shows that most values fall within specifications, but the preponderance of data values are shifted to the right within the specification range.

7. Click the Process Capability red triangle and select Individual Detail Reports.

   The report is the one obtained using Control Chart Builder, except that the Within Sigma is based on average standard deviations rather than average ranges. See "Histogram in Process Capability Analysis for Gap" and "Capability Indices and Nonconformance Report".
Example of Process Capability for an Unstable Process

This example shows a case where the overall variation differs from the within variation because the process is not stable.

1. Select Help > Sample Data Folder and open Quality Control/Coating.jmp.
4. Open the Process Subgrouping outline.
5. Select Sample in the Select Columns list on the left.
7. Click Nest Subgroup ID Column.
8. Click OK.
9. Enter 16 for LSL, 20 for Target, and 24 for USL in the Spec Limits window.
10. Click OK.
11. Click the Goal Plot red triangle and select Show Within Sigma Points.
12. Click the Process Capability red triangle and select Individual Detail Reports.
Figure 9.25  Process Capability Report for Coating.jmp Data
Additional Examples of the Process Capability Platform

Quality and Process Methods
**Figure 9.25** shows the resulting Process Capability report. The Goal Plot shows two points that represent the mean shift and standard deviation standardized to the specification limits. There is a legend next to the Goal Plot that identifies the two points. The Overall Sigma point is calculated using the overall sample standard deviation. The Within Sigma point is calculated using a within-subgroup estimate of the standard deviation.

The point calculated using Overall Sigma is outside the goal triangle corresponding to a Ppk of 1. This indicates that the variable Weight results in non-conforming product.

However, the point calculated using Within Sigma is inside the goal triangle. This indicates that, if the process were stable, Weight values would have a high probability of falling within the specification limits.

13. Hover cursor over one of the points in the Goal Plot.
14. Click the control chart.

**Figure 9.26** XBar and S Chart for Weight

![XBar and S Chart for Weight](image)

The control chart indicates that the Weight measurements are unstable. The process is affected by special causes and is unpredictable. This makes the interpretation of capability indices and nonconformance estimates highly questionable. Even estimates based on Overall Sigma are questionable, because the process is not predictable.
The histogram in Figure 9.25 shows the distribution of the Weight values with normal density curves using both sigma estimates superimposed over the histogram. The normal curve that uses the Overall Sigma estimate is flatter and wider than the normal curve that uses the Within Sigma estimate. This normal curve is more dispersed because the estimate of Overall Sigma is inflated by the special causes that make the process unstable. If the process were stable, the narrower normal curve would reflect process behavior.

You can also compare the Cpk estimate (1.142) to the Ppk estimate (0.814). The fact that Ppk is much smaller than Cpk is additional evidence that this is an unpredictable process. The Cpk estimate is a forecast of the capability that you would achieve by bringing the process to a stable state.

**Note:** The Individual Detail Reports Cutoff preference determines whether the Individual Reports appear by default. If the preference is enabled, the Individual Reports appear by default if the number of process variables is less than or equal to the number specified in the preference. You can change this preference in Preferences > Platforms > Process Capability.

### Example of the Simulation of Confidence Limits for a Nonnormal Process Ppk

In this example, you first perform a capability analysis for three nonnormal variables. You then use simulation to find confidence limits for the nonconformance percentage for a specific variable.

**Nonnormal Capability Analysis**

If you prefer not to follow the steps below, you can obtain the results in this section by running the Process Capability table script in Tablet Measurements.jmp.

1. Select Help > Sample Data Folder and open Tablet Measurements.jmp.
4. Select Weight, Thickness, and Purity in the Y, Process list on the right.
5. Open the Distribution Options outline.
6. From the Distribution list, select Best Fit.
7. Click Set Process Distribution.
   The &Dist(Best Fit) suffix is added to each column name in the list on the right.
8. Click OK.

   A Capability Index Plot appears, showing the Ppk values. Note that only the Thickness variable appears above the line that denotes Ppk = 1. Purity is nearly on the line. Although
the number of measurements, 250, seems large, the estimated Ppk value is still quite variable. For this reason, you construct a confidence interval for the true Purity Ppk value.

**Note**: Because a Goal Plot is not shown, you can conclude that a normal distribution fit was not the best fit for any of the three variables.

9. Click the Process Capability red triangle and select **Individual Detail Reports**.

   The best fits are different for each process.
   - Weight: Lognormal
   - Thickness: SHASH
   - Purity: Weibull

**Construct the Simulation Column**

To use the Simulate utility to estimate Ppk confidence limits, you need to construct a simulation formula that reflects the fitted Weibull distribution. If you prefer not to follow the steps below, you can obtain the results in this section by running the **Add Simulation Column** table script.


   **Figure 9.27** Weibull Parameter Estimates for Purity

   These are the parameter estimates for the best fitting distribution, which is Weibull.

2. In the Tablet Measurements.jmp sample data table, select **Cols > New Columns**.

3. Next to **Column Name**, enter Simulated Purity.

4. From the **Column Properties** list, select **Formula**.

5. In the formula editor, select **Random > Random Weibull**.

6. The placeholder for **beta** is selected. Click the insertion element (^).
In the Process Capability report, under Purity (Weibull) Capability, right-click in the Parameter Estimates report table and select **Make into Data Table**.

8. Copy the entry in Row 2 in the **Estimate** column (1589.7167836).

9. In the formula editor window, select the placeholder for **beta** in the **Random Weibull** formula and paste 1589.7167836 into the placeholder for **beta**.

10. In the data table that you created from the Parameter Estimates report, copy the entry in Row 1 in the **Estimate** column (99.918708989).

11. In the formula editor window, select the placeholder for **alpha** in the **Random Weibull** formula and paste 99.918708989 into the placeholder for **alpha**.

12. Click **OK** in the formula editor window.

13. In the Tablet Measurements.jmp data table, right-click the Simulated Purity column and select **Column Properties > Spec Limits**.


15. Click **OK** in the New Column window.
The Simulated Purity column contains a formula that simulates values from the best-fitting distribution.

**Simulate Confidence Intervals for Purity Ppk and Expected Percent Nonconforming**

When you use Simulate, the entire analysis is run the number of times that you specify. To shorten the computing time, you can minimize the computational burden by running only the required analysis. In this example, because you are interested only in Purity with a fitted Weibull distribution, you perform only this analysis before running Simulate.

**Note:** If you do not care about computing time, you can use the same report you created in the previous section and start with step 7.

1. In the Process Capability report, click the Process Capability red triangle and select Relaunch Dialog.
2. (Optional) Close the Process Capability report.
3. In the launch window, from the Cast Selected Columns into Roles list, select Weight&Dist(Lognormal) and Thickness&Dist(SHASH).
4. Click Remove.
5. Click OK.
6. Click the Process Capability red triangle and select Individual Detail Reports.
   Both Ppk and Ppl values are provided, but they are identical because Purity has only a lower specification limit.
7. In the Overall Sigma Capability report, right-click the Estimate column and select Simulate.
   In the Column to Switch Out list, make sure Purity is selected. In the Column to Switch In list, make sure Simulated Purity is selected.
8. Next to Number of Samples, type 500.
   **Note:** The next step is not required. However, it ensures that you obtain exactly the simulated values shown in this example.
9. (Optional) Next to Random Seed, type 12345.
10. Click OK.
    The calculation might take several seconds. A data table entitled Process Capability Simulate Results (Estimate) appears. The Ppk and Ppl columns in this table each contain 500 values calculated based on the Simulated Purity formula. The first row, which is excluded, contains the values for Purity obtained in your original analysis. Because Purity has only a lower specification limit, the Ppk values are identical to the Ppl values.
11. In the Process Capability Simulate Results (Estimate) data table, click the green triangle next to the **Distribution** script.

**Figure 9.30** Distribution of Simulated Ppk Values for Purity
Two Distribution reports are shown, one for Ppk and one for Ppl. But Purity has only a lower specification limit, so that the Ppk and Ppl values are identical. For this reason, the Distribution reports are identical.

The Simulation Results report shows that a 95% confidence interval for Ppk is 0.909 to 1.145. This indicates that the true Ppk value could be above 1.0, which would place Purity above the Ppk = 1 line in the Capability Index Plot you constructed in “Nonnormal Capability Analysis”.

12. In the Process Capability report, right-click the Expected Overall % column in the Nonconformance report and select Simulate.

   In the Column to Switch Out list, make sure Purity is selected. In the Column to Switch In list, make sure Simulated Purity is selected.

13. Next to Number of Samples, enter 500.

14. (Optional) Next to Random Seed, enter 12345.

15. Click OK.

   The calculation might take several seconds. A data table entitled Process Capability Simulate Results (Expected Overall %) appears. Because Purity has only a lower specification limit, the Below LSL values are identical to the Total Outside values.

16. In the Process Capability Simulate Results (Expected Overall %) data table, click the green triangle next to the Distribution script.
Figure 9.31 Distribution of Simulated Total Outside Values for Purity

<table>
<thead>
<tr>
<th>Quantiles</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>100.0% max</td>
<td>0.3143922404</td>
</tr>
<tr>
<td>99.5%</td>
<td>0.2840953878</td>
</tr>
<tr>
<td>97.5%</td>
<td>0.2380942499</td>
</tr>
<tr>
<td>90.0%</td>
<td>0.1843938492</td>
</tr>
<tr>
<td>75.0% quartile</td>
<td>0.1520061781</td>
</tr>
<tr>
<td>50.0% median</td>
<td>0.1187664242</td>
</tr>
<tr>
<td>25.0% quartile</td>
<td>0.0965591681</td>
</tr>
<tr>
<td>10.0%</td>
<td>0.0746454951</td>
</tr>
<tr>
<td>2.5%</td>
<td>0.0546638349</td>
</tr>
<tr>
<td>0.5%</td>
<td>0.036622146</td>
</tr>
<tr>
<td>0.0%</td>
<td>0.0336704993</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Summary Statistics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mean</td>
</tr>
<tr>
<td>Std Dev</td>
</tr>
<tr>
<td>Std Err Mean</td>
</tr>
<tr>
<td>Upper 95% Mean</td>
</tr>
<tr>
<td>Lower 95% Mean</td>
</tr>
<tr>
<td>N</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Simulation Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>$Y_0 = 0.12604$ (Original Estimate)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Confidence Intervals</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alpha</td>
</tr>
<tr>
<td>-------</td>
</tr>
<tr>
<td>0.05</td>
</tr>
<tr>
<td>0.10</td>
</tr>
<tr>
<td>0.20</td>
</tr>
<tr>
<td>0.50</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Empirical p-Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test</td>
</tr>
<tr>
<td>----------</td>
</tr>
<tr>
<td>$Y \geq</td>
</tr>
<tr>
<td>$Y \leq Y_0$</td>
</tr>
<tr>
<td>$Y \geq Y_0$</td>
</tr>
</tbody>
</table>
Statistical Details for the Process Capability Platform

This section contains statistical details for the Process Capability platform.

- “Statistical Details for Variation Statistics”
- “Statistical Details on Notation”
- “Statistical Details for the Goal Plot”
- “Statistical Details for Capability Box Plots”
- “Statistical Details for Capability Indices for Normal Distributions”
- “Statistical Details for Capability Indices for Nonnormal Distributions”
- “Statistical Details for the Parameterizations of Distributions”

Statistical Details for Variation Statistics

The Process Capability platform provides two types of capability indices. The Ppk indices are based on an estimate of \( \sigma \), the standard deviation of a process, that uses all of the data in a way that does not depend on subgroups. This overall estimate can reflect special cause as well as common cause variation. The Cpk indices are based on an estimate that attempts to capture only common cause variation. The Cpk indices are constructed using within-subgroup or between-and-within-subgroup estimates of \( \sigma \). In this way, they attempt to reflect the true process standard deviation. When a process is not stable, the different estimates of \( \sigma \) can differ markedly.

Overall Sigma

The overall sigma does not depend on subgroups. The overall estimate of \( \sigma \) is calculated as follows:

\[
\hat{\sigma} = \sqrt{\frac{1}{N-1} \sum_{i=1}^{N} (y_i - \bar{y})^2}
\]
The formula uses the following notation:

\[ N = \text{number of nonmissing values in the entire data set} \]
\[ y_i = \text{value of the } i^{th} \text{ observation} \]
\[ \bar{y} = \text{mean of nonmissing values in the entire data set} \]

Caution: When the process is stable, the Overall Sigma estimates the process standard deviation. If the process is not stable, the overall estimate of \( \sigma \) is of questionable value, since the process standard deviation is unknown.

Estimates of Sigma Based on Within-Subgroup Variation

An estimate of \( \sigma \) that is based on within-subgroup variation can be constructed in one of the following ways:

- Within sigma estimated by average of ranges
- Within sigma estimated by average of unbiased standard deviations
- Within sigma estimated by moving range
- Within sigma estimated by unbiased pooled standard deviation

If you specify a subgroup ID column or a constant subgroup size on the launch window, you can specify your preferred within-subgroup variation statistic. See “Launch the Process Capability Platform”. If you do not specify a subgroup ID column, a constant subgroup size, or a historical sigma, JMP estimates the within sigma using the third method (moving range of subgroups of size two).

Within Sigma Based on Average of Ranges

Within sigma estimated by the average of ranges is the same as the estimate of the standard deviation of an XBar and R chart:

\[ \sigma = \frac{R_1}{d_2(n_1)} + \cdots + \frac{R_N}{d_2(n_N)} \]

The formula uses the following notation:

\[ R_i = \text{range of } i^{th} \text{ subgroup} \]
\[ n_i = \text{sample size of } i^{th} \text{ subgroup} \]
\[ d_2(n_i) = \text{expected value of the range of } n_i \text{ independent normally distributed variables with unit standard deviation} \]
\[ N = \text{number of subgroups for which } n_i \geq 2 \]
Within Sigma Based on Average of Unbiased Standard Deviations

Within sigma estimated by the average of unbiased standard deviations is the same as the estimate for the standard deviation in an XBar and S chart:

\[ \hat{\sigma} = \frac{s_1}{c_4(n_1)} + \cdots + \frac{s_N}{c_4(n_N)} \]

The formula uses the following notation:

- \(n_i\) = sample size of \(i^{th}\) subgroup
- \(c_4(n_i)\) = expected value of the standard deviation of \(n_i\) independent normally distributed variables with unit standard deviation
- \(N\) = number of subgroups for which \(n_i \geq 2\)
- \(s_i\) = sample standard deviation of the \(i^{th}\) subgroup

Within Sigma Based on Average Moving Range

Within sigma estimated by average moving range is the same as the estimate for the standard deviation for Individual Measurement and Moving Range charts:

\[ \hat{\sigma} = \frac{\overline{MR}}{d_2(2)} \]

The formula uses the following notation:

- \(\overline{MR}\) = the mean of the nonmissing moving ranges computed as \((MR_2 + MR_3 + \cdots + MR_N)/(N-1)\)
  
  where \(MR_i = |y_i - y_{i-1}|\).

- \(d_2(2)\) = expected value of the range of two independent normally distributed variables with unit standard deviation.

Within Sigma Based on Median Moving Range

Within sigma estimated by median moving range:

\[ \hat{\sigma} = \frac{MMR}{0.954} \]

The formula uses the following notation:

- \(MMR\) = the median of the nonmissing moving ranges computed as Median\((MR_2, MR_3, \ldots, MR_N)\) where \(MR_i = |y_i - y_{i-1}|\).
Within Sigma Based on Unbiased Pooled Standard Deviation

Within sigma estimated by the unbiased pooled standard deviation:

\[
\hat{\sigma} = \sqrt{\frac{n_1(n_1 - 1)s_1^2 + \ldots + n_N(n_N - 1)s_N^2}{c_4(n - N + 1)\sqrt{n_1 + \ldots + n_N - N}}}
\]

The formula uses the following notation:

- \(n_i\) = sample size of \(i^{th}\) subgroup
- \(n = n_1 + \ldots + n_N\), the total sample size
- \(c_4(\cdot)\) = expected value of the standard deviation of \((\cdot)\) independent normally distributed variables with unit standard deviation
- \(N\) = number of subgroups for which \(n_i \geq 2\)
- \(s_i\) = sample standard deviation of the \(i^{th}\) subgroup

Estimate of Sigma Based on Between Group Variation

Between Sigma Based on Moving Range

The estimate of \(\sigma\) that is based on between-subgroup variation is estimated by the moving range of subgroup means:

\[
\hat{\sigma} = \sqrt{\frac{MR^2}{d_2(2)(\frac{\hat{\sigma}^2\text{Within}}{H})}}
\]

The formula uses the following notation:

- \(\overline{MR}\) = the mean of the nonmissing moving ranges computed as \((MR_2+MR_3+\ldots+MR_N)/(N-1)\)
  where \(MR_i = |y_i - y_{i-1}|\).
- \(d_2(2)\) = expected value of the range of two independent normally distributed variables with unit standard deviation.
- \(\sigma^2\text{within}\) = the specified within sigma estimate.
- \(H = \frac{N}{\frac{1}{n_1} + \frac{1}{n_2} + \ldots + \frac{1}{n_N}}\), the harmonic mean of subgroup sample sizes.
Chapter 9  
Quality and Process Methods  

Estimate of Sigma Based on Between and Within Group Variation

Between-and-Within Sigma

The estimate of sigma that is based on the combined between and within group variation is defined as follows:

$$\hat{\sigma} = \sqrt{\frac{\sigma^2_{\text{within}} + \sigma^2_{\text{between}}}{2}}$$

Statistical Details on Notation

In the Process Capability platform, the formulas for the Goal Plot and Capability Box Plots use the following notation:

- $Y_{ij}$ = $i^{th}$ observation for process $j$
- $\bar{Y}_j$ = mean of the observations on process $j$
- $\text{SD}(Y_j)$ = standard deviation of the observations on process $j$
- $T_j$ = target value for process $j$
- $\text{LSL}_j$ = lower specification limit for process $j$
- $\text{USL}_j$ = upper specification limit for process $j$

Statistical Details for the Goal Plot

This section provides details about the calculation of the mean shift and standard deviation standardized to specification quantities plotted in the Goal Plot in the Process Capability platform. This section uses the notation defined in “Statistical Details on Notation”.

The mean shift and the standard deviation standardized to the specification limits for the $j^{th}$ column are defined as follows:

- Spec-Standardized Mean = $\frac{\bar{Y}_j - T_j}{2 \times \min(T_j - \text{LSL}_j, \text{USL}_j - T_j)}$
- Spec-Standardized Std Dev = $\frac{\text{SD}(Y_j)}{2 \times \min(T_j - \text{LSL}_j, \text{USL}_j - T_j)}$

**Note:** If either LSL$_j$ or USL$_j$ is missing, twice the distance from the target to the nonmissing specification limit is used in the denominators of the Goal Plot coordinates.
Goal Plot Points for Processes with Missing Targets

Suppose that the process has both a lower and an upper specification limit but no target. Then the formulas given in “Statistical Details for the Goal Plot” are used, replacing $T_j$ with the midpoint of the two specification limits.

Suppose that the process has only one specification limit and no target. To obtain $(x,y)$ coordinates for a point on the Goal Plot, the capability indices of the process are used. (See “Statistical Details for Capability Indices for Normal Distributions” for definitions in terms of the theoretical mean and standard deviation.) For sample observations, the following relationships hold:

\[
C_{pu} = \frac{USL_j - \bar{Y}_j}{3SD(Y_j)}
\]

\[
C_{pl} = \frac{\bar{Y}_j - LSL_j}{3SD(Y_j)}
\]

If a process has two specification limits and a target at the midpoint of the limits, then the $(x,y)$ coordinates for the point on the Goal Plot satisfy these relationships:

\[
C_{pu} = (0.5 - x)/3y
\]

\[
C_{pl} = (0.5 + x)/3y
\]

To obtain coordinates when there is only one specification limit and no target, these relationships are used. To identify a unique point requires an assumption about the slope of the line from the origin on which the points fall. A slope of 0.5 is assumed for the case of an upper specification limit and of -0.5 for a lower specification limit. When capability values are equal to one and the Ppk slider for the goal plot triangle is set to 1, these slopes place the points on the goal plot triangle lines.

Consider the case of only an upper specification limit and no target. Using the assumption that the $(x,y)$ coordinates fall on a line from the origin with slope 0.5, solving for $x$ and $y$ gives the following coordinates:

\[
x = 1/(3C_{pu} + 2)
\]

\[
y = 1/(6C_{pu} + 4)
\]
Consider the case of only a lower specification limit and no target. Using the assumption that the \((x,y)\) coordinates fall on a line from the origin with slope -0.5, solving for \(x\) and \(y\) gives the following coordinates:

\[
\begin{align*}
x &= -1/(3C_{pl} + 2) \\
y &= 1/(6C_{pl} + 4)
\end{align*}
\]

**Note:** If either \(C_{pu}\) or \(C_{pl}\) is less than -0.6, then it is set to -0.6 in the formulas above. At the value -2/3, the denominator for \(x\) assumes the value 0. Bounding the capability values at -0.6 prevents the denominator from assuming the value 0 or switching signs.

### Statistical Details for Capability Box Plots

This section describes how the Process Capability platform handles processes with missing targets. A column with no target can have both upper and lower specification limits, or only a single specification limit. The calculations used to create the Capability Box plots depend on what specification limits are defined. The notation used in this section is defined in “Statistical Details on Notation”.

#### Two Specification Limits and No Target

When no target is specified for the \(j\)th column, the capability box plot is based on the following values for the transformed observations:

\[
Z_{ij} = \frac{Y_{ij} - (LSL_j + USL_j)/2}{USL_j - LSL_j}
\]

#### Single Specification Limit and No Target

Suppose that only the lower specification limit is specified. (The case where only the upper specification limit is specified in a similar way.)

When no target is specified for the \(j\)th column, the capability box plot is based on the following values for the transformed observations:

\[
Z_{ij} = \frac{Y_{ij} - \bar{Y}_j}{2(\bar{Y}_j - LSL_j)}
\]

**Note:** When a column has only one specification limit and no target value, and the sample mean falls outside the specification interval, no capability box plot for that column is plotted.
Statistical Details for Capability Indices for Normal Distributions

This section provides details about the calculation of capability indices for normal data in the Process Capability platform.

For a process characteristic with mean $\mu$ and standard deviation $\sigma$, the population-based capability indices are defined as follows. For sample observations, the parameters are replaced by their estimates:

\[
C_p = \frac{USL - LSL}{6\sigma}
\]

\[
C_{pl} = \frac{\mu - LSL}{3\sigma}
\]

\[
C_{pu} = \frac{USL - \mu}{3\sigma}
\]

\[
C_{pk} = \min(C_{pl}, C_{pu})
\]

\[
C_{pm} = \frac{\min(T - LSL, USL - T)}{3\sigma \left[1 + \left(\frac{T - \mu}{\sigma}\right)^2\right]}
\]

Target Index = $3(C_p - C_{pk})$

The formulas use the following notation:

- $LSL$ = Lower specification limit
- $USL$ = Upper specification limit
- $T$ = Target value

For estimates of Within Sigma capability, $\sigma$ is estimated using the subgrouping method that you specified. For estimates of Overall Sigma capability, $\sigma$ is estimated using the sample standard deviation. If either of the specification limits is missing, the capability indices containing the missing specification limit are reported as missing.

**Note:** With the default AIAG (Ppk) Labeling, the indices based on Overall Sigma are denoted by Pp, Ppl, Ppu, and Ppk. The labeling for the index Cpm does not change when Overall Sigma is used. The formulas in this section are defined using Cp labels.

**Confidence Intervals for Capability Indices**

Confidence intervals for capability indices are available only for processes with normal distributions. Confidence intervals are calculated for both Within and Overall Sigma capability and are shown in the Individual Detail Reports.
\section*{Cp}

The 100(1 - \(\alpha\))% confidence interval for Cp is calculated as follows:

\[
\left( \hat{C}_p_{\alpha/2}, \hat{C}_p_{1-\alpha/2} \right) \frac{\chi^2_{\alpha/2, df}}{G_{\alpha/2}}, \left( \hat{C}_p_{\alpha/2}, \hat{C}_p_{1-\alpha/2} \right) \frac{\chi^2_{1-\alpha/2, df}}{G_{\alpha/2}},
\]

where

- \(\hat{C}_p\) is the estimated value for Cp
- \(\chi^2_{\alpha/2, df}\) is the \((\alpha/2)\)th quantile of a chi-square distribution with \(df\) degrees of freedom
- \(df\) is the degrees of freedom
- \(N\) is the number of observations
- \(m\) is the number of subgroups

For Overall Sigma capability, the degrees of freedom is equal to \(N - 1\).

For Within Sigma capability, the degrees of freedom depends on the subgrouping and the within sigma estimation method.

- For Within Sigma capability with unbalanced subgroups, the degrees of freedom calculation is the same regardless of the within sigma estimation method. The degrees of freedom is equal to \(N - m\).
- For Within Sigma capability with balanced subgroups of size \(n = N/m\), the degrees of freedom calculation depends on the within sigma estimation method.
  - When Within Sigma is estimated by the average of the unbiased standard deviations, the degrees of freedom is equal to \(f^*(N - m)\). The scale factor \(f\), which varies between 0.875 and 1, is defined as follows:
    \[
    f = \frac{1}{2(n - 1) \left( \frac{(n - 1)}{2} \left( \frac{\Gamma\left(\frac{n - 1}{2}\right)}{\Gamma\left(\frac{n}{2}\right)} \right)^2 - 1 \right)}
    \]
    where \(\Gamma(n)\) is the gamma function evaluated at \(n\).
    For more information, see Bissell (1990).
  - When Within Sigma is estimated by the average of ranges, the degrees of freedom is calculated as \(df = \frac{1}{A - (3/16) * A + (3/64) * A^2 + 0.25}\). A is defined as follows:
\[ A = \frac{2d_3(n)^2}{m \cdot d_2(n)^2} \]

\( d_2(n) \) is the expected value of the range of \( n \) independent normally distributed variables with unit standard deviation

\( d_3(n) \) is the standard deviation of the range of \( n \) independent normally distributed variables with unit standard deviation

For more information, see David (1951).

- When Within Sigma is estimated by the unbiased pooled standard deviations, the degrees of freedom is equal to \( N - m \).

- For Within Sigma capability with no subgroups, the degrees of freedom calculation depends on the within sigma estimation method.

  - When Within Sigma is estimated by the average moving ranges, the degrees of freedom is calculated as \( 0.62 \times (N - 1) \).

  - When Within Sigma is estimated by the median moving ranges, the degrees of freedom is calculated as \( 0.32 \times (N - 1) \).

For more information, see Wheeler (2004, p. 82).

**Cpk**

The 100(1 - \( \alpha \))% confidence interval for Cpk is calculated as follows:

\[
\left( \hat{C}_{pk} \left[ 1 - \Phi^{-1} \left( 1 - \frac{\alpha}{2} \right) \frac{1}{\sqrt{9N\hat{C}_{pk}^2}} + \frac{1}{2df} \right] , \hat{C}_{pk} \left[ 1 + \Phi^{-1} \left( 1 - \frac{\alpha}{2} \right) \frac{1}{\sqrt{9N\hat{C}_{pk}^2}} + \frac{1}{2df} \right] \right)
\]

where

\( \hat{C}_{pk} \) is the estimated value for Cpk

\( \Phi^{-1} \left( 1 - \frac{\alpha}{2} \right) \) is the \((1 - \alpha/2)^{th}\) quantile of a standard normal distribution

\( df \) is the degrees of freedom

\( N \) is the number of observations

\( m \) is the number of subgroups

For Overall Sigma capability, the degrees of freedom is equal to \( N - 1 \).

For Within Sigma capability, the degrees of freedom depends on the subgrouping and the within sigma estimation method.
• For Within Sigma capability with unbalanced subgroups, the degrees of freedom calculation is the same regardless of the within sigma estimation method. The degrees of freedom is equal to \( N - m \).

• For Within Sigma capability with balanced subgroups of size \( n = N/m \), the degrees of freedom calculation depends on the within sigma estimation method.
  – When Within Sigma is estimated by the average of the unbiased standard deviations, the degrees of freedom is equal to \( f^* (N - m) \). The scale factor \( f \), which varies between 0.875 and 1, is defined as follows:

\[
 f = \frac{1}{2(n-1) \left( \frac{(n-1)}{2} \left( \frac{\Gamma\left(\frac{n-1}{2}\right)}{\Gamma\left(\frac{n}{2}\right)} \right)^2 - 1 \right)}
\]

where \( \Gamma(n) \) is the gamma function evaluated at \( n \).

For more information, see Bissell (1990).

  – When Within Sigma is estimated by the average of ranges, the degrees of freedom is calculated as \( df = 1/A - (3/16) * A + (3/64) * A^2 + 0.25 \). \( A \) is defined as follows:

\[
 A = \frac{2 d_3(n)^2}{m \cdot d_2(n)^2}
\]

\( d_2(n) \) is the expected value of the range of \( n \) independent normally distributed variables with unit standard deviation

\( d_3(n) \) is the standard deviation of the range of \( n \) independent normally distributed variables with unit standard deviation

For more information, see David (1951).

  – When Within Sigma is estimated by the unbiased pooled standard deviations, the degrees of freedom is equal to \( N - m \).

• For Within Sigma capability with no subgroups, the degrees of freedom calculation depends on the within sigma estimation method.
  – When Within Sigma is estimated by the average moving ranges, the degrees of freedom is calculated as \( 0.62 * (N - 1) \).
  – When Within Sigma is estimated by the median moving ranges, the degrees of freedom is calculated as \( 0.32 * (N - 1) \).

For more information, see Wheeler (2004, p. 82).
Cpm

**Note:** The confidence interval for Cpm is computed only when the target value is centered between the lower and upper specification limits.

The 100(1 - α)% confidence interval for Cpm is calculated as follows:

\[
\left[ \hat{C}_{pm} \pm \frac{\chi_{\alpha/2, \gamma}^2}{\gamma}, \hat{C}_{pm} \pm \frac{\chi_{1-\alpha/2, \gamma}^2}{\gamma} \right]
\]

where

- \( \hat{C}_{pm} \) is the estimated value for Cpm
- \( \chi_{\alpha/2, \gamma}^2 \) is the \((\alpha/2)\)th quantile of a chi-square distribution with \( \gamma \) degrees of freedom

\[
\gamma = \frac{N \left( 1 + \left( \frac{\bar{x} - T}{s} \right)^2 \right)^2}{1 + 2 \left( \frac{\bar{x} - T}{s} \right)^2}
\]

- \( N \) is the number of observations
- \( \bar{x} \) is the mean of the observations
- \( T \) is the target value
- \( s \) is the sigma estimate

For Overall Sigma capability, \( s \) is the Overall Sigma estimate. For Within Sigma capability, \( s \) is replaced by the Within Sigma estimate.

**Tip:** For more information on confidence intervals for Cp, Cpk, and Cpm, see Pearn and Kotz (2006).

Cpl and Cpu

Lower and upper confidence limits for Cpl and Cpu are computed using the method of Chou et al. (1990).

The 100(1 - α)% confidence limits for Cpl (denoted by CPL_L and CPL_U) satisfy the following equations:

\[
Pr[t_{n-1}(\delta_L) \geq 3\hat{C}_{pl}/\sqrt{n}] = 1 - \alpha/2 \quad \text{where} \quad \delta_L = 3CPL_L\sqrt{n}
\]
Statistical Details for Capability Indices for Nonnormal Distributions

This section describes the two methods used to calculate capability indices for nonnormal distributions in the Process Capability platform. The two methods are the Percentile (also known as ISO/Quantile) method and the Z-Score (also known as Bothe/Z-scores) method. When you select a distribution for a nonnormal process variable, you can fit a parametric distribution or a nonparametric distribution. You can use either the Percentile or the Z-Score methods to calculate capability indices for the process variable of interest. However, unless you have a very large amount of data, a nonparametric fit might not accurately reflect behavior in the tails of the distribution.

Note: For both the Percentile and the Z-Score methods, if the data are normally distributed, the capability formulas reduce to the formulas for normality-based capability indices.

The descriptions of the two methods use the following notation:

- LSL = Lower specification limit
- USL = Upper specification limit
- T = Target value
Percentile (ISO/Quantile) Method

The percentile method replaces the mean in the standard capability formulas with the median of the fitted distribution and the 6σ range of values with the corresponding percentile range. The method is described in AIAG (2005).

Denote the $\alpha^{*100}$th percentile of the fitted distribution by $P_\alpha$. Then Percentile method capability indices are defined as follows:

$$P_{pk} = \min\left(\frac{P_{0.5} - LSL}{P_{0.5} - P_{0.00135}}, \frac{USL - P_{0.5}}{P_{0.99865} - P_{0.5}}\right)$$

$$P_{pl} = \frac{P_{0.5} - LSL}{P_{0.5} - P_{0.00135}}$$

$$P_{pu} = \frac{USL - P_{0.5}}{P_{0.99865} - P_{0.5}}$$

$$P_p = \frac{USL - LSL}{P_{0.99865} - P_{0.00135}}$$

$$C_{pm} = \frac{\min\left(\frac{T - LSL}{P_{0.5} - P_{0.00135}}, \frac{USL - T}{P_{0.99865} - P_{0.5}}\right)}{\sqrt{1 + \left(\frac{\mu - T}{\sigma}\right)^2}}$$

Z-Score (Bothe/Z-Scores) Method

The Z-Score method transforms the specification limits to values that have the same probabilities on a standard normal scale. It computes capability measures that correspond to a normal distribution with the same risk levels as the fitted nonnormal distribution.

Let $F$ denote the fitted distribution for a process variable with lower and upper specification limits given by LSL and USL. Equivalent standard normal specification limits are defined as follows:

$$\begin{bmatrix}
LSL_F = \Phi^{-1}(F(LSL)) \\
USL_F = \Phi^{-1}(F(USL))
\end{bmatrix}$$
Then the Z-Score method capability indices are defined as follows:

\[ P_{pk} = \min(-\frac{LSL_F}{3}, \frac{USL_F}{3}) \]

\[ P_{pl} = -\frac{LSL_F}{3} \]

\[ P_{pu} = \frac{USL_F}{3} \]

\[ P_p = \frac{(USL_F - LSL_F)}{6} \]

**Note:** Because Cpm is a target-based measure, it cannot be calculated using the Z-Scores method.

**Note:** For very capable data, \( F(LSL) \) or \( F(USL) \) can be so close to zero or one, respectively, that \( LSL_F \) or \( USL_F \) cannot be computed. In these cases, JMP automatically switches from the Z-Score method to the Percentile method by default. This gives more meaningful capability indices. To turn off this default setting, select File > Preferences > Platforms > Process Capability.

## Statistical Details for the Parameterizations of Distributions

This section gives the density functions \( f \) for the distributions used in the Process Capability platform. It also gives expected values and variances for all but the Johnson and SHASH distributions.

### Normal

\[ f(x|\mu, \sigma) = \frac{1}{\sigma \sqrt{2\pi}} \exp\left[-\frac{1}{2\sigma^2}(x - \mu)^2\right], \quad -\infty < x < \infty, \quad -\infty < \mu < \infty, \quad \sigma > 0 \]

\[ E(X) = \mu \]

\[ \text{Var}(X) = \sigma^2 \]

### Beta

\[ f(x|\alpha, \beta) = \frac{1}{B(\alpha, \beta)} x^{\alpha - 1} (1 - x)^{\beta - 1}, \quad 0 \leq x \leq 1, \quad \alpha > 0, \quad \beta > 0 \]

\[ E(X) = \frac{\alpha}{\alpha + \beta} \]
\[ \text{Var}(X) = \frac{\alpha \beta}{(\alpha + \beta)^2(\alpha + \beta + 1)} \]

where \( B(\cdot) \) is the Beta function.

**Exponential**

\[ f(x|\sigma) = \frac{1}{\sigma} \exp\left(-\frac{x}{\sigma}\right), \quad x > 0, \quad \sigma > 0 \]

\[ \text{E}(X) = \sigma \]
\[ \text{Var}(X) = \sigma^2 \]

**Gamma**

\[ f(x|\alpha, \sigma) = \frac{1}{\Gamma(\alpha)\sigma^\alpha} x^{\alpha-1} \exp\left(-\frac{x}{\sigma}\right), \quad x > 0, \quad \alpha > 0, \quad \sigma > 0 \]

\[ \text{E}(X) = \alpha\sigma \]
\[ \text{Var}(X) = \alpha\sigma^2 \]

where \( \Gamma(\cdot) \) is the gamma function.

**Johnson**

**Johnson Su**

\[ f(x|\gamma, \delta, \sigma, \theta) = \frac{\delta}{\sigma} \left[1 + \left(\frac{x - \theta}{\sigma}\right)^2\right]^{-1/2} \phi\left[\gamma + \delta \sinh^{-1}\left(\frac{x - \theta}{\sigma}\right)\right], \quad -\infty < x, \theta, \gamma < \infty, \quad \theta > 0, \quad \delta > 0 \]

**Johnson Sb**

\[ f(x|\gamma, \delta, \sigma, \theta) = \phi\left[\gamma + \delta \ln\left(\frac{x - \theta}{\sigma - (x - \theta)}\right)\right] \frac{\delta\sigma}{(x - \theta)(\sigma - (x - \theta))}, \quad 0 < x < \theta + \sigma, \quad \sigma > 0 \]

**Johnson Sl**

\[ f(x|\gamma, \delta, \sigma, \theta) = \frac{\delta}{|x - \theta|} \phi\left[\gamma + \delta \ln\left(\frac{x - \theta}{\sigma}\right)\right], \quad x > 0 \text{ if } \sigma = 1, \quad x < 0 \text{ if } \sigma = -1 \]

where \( \phi(\cdot) \) is the standard normal probability density function.
Lognormal

$$f(x|\mu, \sigma) = \frac{1}{\sqrt{2\pi}\sigma} \exp\left[\frac{-(\log(x) - \mu)^2}{2\sigma^2}\right], \quad x > 0, \quad -\infty < \mu < \infty, \quad \sigma > 0$$

$$E(X) = \exp(\mu + \sigma^2/2)$$

$$\text{Var}(X) = \exp(2(\mu + \sigma^2)) - \exp(2\mu + \sigma^2)$$

Mixture of Normals

The Mixture of 2 Normals and Mixture of 3 Normals options for Distribution share the following parameterization:

$$f(x|\mu_i, \sigma_i, \pi_i) = \sum_{i=1}^{k} \pi_i \phi\left(\frac{x - \mu_i}{\sigma_i}\right)$$

$$E(X) = \sum_{i=1}^{k} \pi_i \mu_i$$

$$\text{Var}(X) = \sum_{i=1}^{k} \pi_i (\mu_i^2 + \sigma_i^2) - \left(\sum_{i=1}^{k} \pi_i \mu_i\right)^2$$

where $\mu_i$, $\sigma_i$, and $\pi_i$ are the respective mean, standard deviation, and proportion for the $i^{th}$ group, and $\phi(\cdot)$ is the standard normal probability density function. For the Mixture of 2 Normals, $k$ is equal to 2. For the Mixture of 3 Normals distribution, $k$ is equal to 3. A separate mean, standard deviation, and proportion of the whole is estimated for each group in the mixture.

SHASH

$$f(x|\gamma, \delta, \sigma, \theta) = \frac{\delta \cosh(w)}{\sqrt{\sigma^2 + (x - \theta)^2}} \phi[\sinh(w)], \quad -\infty < x, \theta < \infty, \quad 0 < \delta, \quad 0 < \sigma$$

where

$\phi(\cdot)$ is the standard normal pdf

$$w = \gamma + \delta \sinh^{-1}\left(\frac{x - \theta}{\sigma}\right)$$
Note: When $\gamma = 0$ and $\delta = 1$, the SHASH distribution is equivalent to the normal distribution with location $\theta$ and scale $\sigma$.

Weibull

$$f(x|\alpha, \beta) = \frac{\beta}{\alpha^\beta} x^{\beta-1} \exp\left[ -\left(\frac{x}{\alpha}\right)^\beta \right], \quad \alpha > 0, \quad \beta > 0$$

$$E(X) = \alpha \Gamma\left(1 + \frac{1}{\beta}\right)$$

$$\text{Var}(X) = \alpha^2 \left\{ \Gamma\left(1 + \frac{2}{\beta}\right) - \Gamma^2\left(1 + \frac{1}{\beta}\right) \right\}$$

where $\Gamma(\cdot)$ is the gamma function.
CUSUM Control Charts

Create Tabular CUSUM Control Charts with Decision Limits

Cumulative Sum (CUSUM) control charts enable you to detect small shifts in a process. They are useful in detecting shifts that occur over time, such as a gradual drift, and that are not necessarily accompanied by a sudden shift. The CUSUM Control Chart platform creates a CUSUM chart with decision limits, similar to a Shewhart chart. This chart is also called a *tabular CUSUM chart*. To create a V-mask cumulative sum control chart, see “V-Mask CUSUM Control Charts”.

The CUSUM Control Chart platform also provides information about average run length (ARL). The *average run length* is the average number of samples or observations that can be expected to occur before an out-of-control signal occurs. You can use the average run length to assess the performance of a CUSUM chart, given specific parameters and assuming constant variance.

**Figure 10.1** CUSUM Control Chart
Contents

Overview of the CUSUM Control Chart Platform .................................................. 305
Example of a CUSUM Control Chart ................................................................. 305
Launch the CUSUM Control Chart Platform ...................................................... 307
The CUSUM Control Chart Platform Report ..................................................... 308
  Control Panel for CUSUM Control Chart ...................................................... 309
  CUSUM Chart Report. ............................................................................... 310
CUSUM Control Chart Platform Options ......................................................... 310
  Average Run Length (ARL) Report .............................................................. 313
Additional Examples of CUSUM Control Charts .............................................. 314
  Example of the Data Units Option in a CUSUM Control Chart .................... 314
  Example of a CUSUM Chart with Subgroups .............................................. 315
Statistical Details for the CUSUM Control Chart Platform ............................... 316
  Statistical Details for CUSUM Control Chart Construction ....................... 317
  Statistical Details for Shift Detection ......................................................... 318
  Statistical Details for Average Run Length ................................................. 318
Overview of the CUSUM Control Chart Platform

A tabular CUSUM chart consists of two one-sided decision limits charts superimposed on one chart. The chart contains decision limits that signal when the process is out of control and places a shift line on the chart where the shift is suspected to have occurred. To use the CUSUM Control Chart platform, you must determine the smallest change in the mean that you consider important. You can view the CUSUM control chart in standard deviation units or in data units. For more information about tabular CUSUM charts, see Woodall and Adams (1998) and Montgomery (2013).

Another form of a cumulative sum control chart is the V-mask chart. To create a V-mask CUSUM chart, see “V-Mask CUSUM Control Charts”.

Note: The summary results in the CUSUM Control Chart platform do not always match the summary results in the V-mask CUSUM platform. Specifically, the summary results for a two-sided V-mask CUSUM chart do not match those from a CUSUM Control Chart with both Upper Side and Lower Side options selected. However, the one-sided summary reports from the CUSUM Control Chart platform and the V-mask CUSUM platform do match.

Example of a CUSUM Control Chart

In this example, you want to detect small shifts in the temperature of an engine. The data table contains temperature measurements from the engine thermostat.

1. Select Help > Sample Data Folder and open Quality Control/Engine Temperature Sensor.jmp.
2. Select Analyze > Quality and Process > Control Chart > CUSUM Control Chart.
3. Select Y and click Y.
4. Click OK.
5. In the Target box, type 100.
6. In the Sigma box, type 10.
The vertical line on the CUSUM Chart indicates that a shift in the temperature measurements started around sample 26.

**Note:** You can compare this result to the Individual Moving Range control chart by running the IMR Chart table script in Engine Temperature Sensor.jmp. The IMR chart does not trigger any of the Nelson tests.

**Example of a One-Sided CUSUM Control Chart**

Continuing the previous example, suppose that you care only about increasing temperature changes. To change the CUSUM control chart in Figure 10.2 to a one-sided chart, deselect the Lower Side check box. When you do that, the points for the negative cumulative sums are removed from the chart. You are left with a CUSUM control chart that contains only the positive cumulative sum points.
Launch the CUSUM Control Chart Platform

Launch the CUSUM Control Chart platform by selecting **Analyze > Quality and Process > Control Chart > CUSUM Control Chart**.

*Figure 10.4* The CUSUM Control Chart Launch Window

Charts cumulative sums of deviations of subgroup means from a target.

Y Identifies the variables that you want to chart.

**Note:** The rows of the data table must be sorted in the order in which the observations were collected.
X  Identifies a subgroup variable. The horizontal axis of the CUSUM chart is labeled by the subgroup variable. If a value of this column is present more than once, the average response at each X value is plotted on the CUSUM chart.

By  Produces a separate report for each level of the By variable. If more than one By variable is assigned, a separate report is produced for each possible combination of the levels of the By variables.

Show Excluded Region  (Applicable only when an X variable is specified.) Specifies that subgroups that are entirely excluded are shown on the horizontal axis in the CUSUM control chart.

Data Units  Specifies that data units be used in the report rather than standard deviation units. By default, the chart and parameters are shown in standard deviation units. However, if you select the Data Units option in the launch window, the chart and parameters are shown in the units of the data column that is being analyzed.

When you use standard deviation units, values for the $h$ and $k$ parameters do not depend on the process standard deviation. This can be an advantage.

The CUSUM Control Chart Platform Report

By default, the CUSUM Control Chart platform produces a report that contains a parameter control panel and a CUSUM chart.

- “Control Panel for CUSUM Control Chart”
- “CUSUM Chart Report”

Figure 10.5  CUSUM Control Chart Report

Note: A $k$ of 0.5, together with a Sigma of 10, indicates a minimum detectable change of $2 \times k \times \text{Sigma} = 10 \times (0.5) = 5$, centered around the Target.
Control Panel for CUSUM Control Chart

The Control Panel contains the current values for the chart parameters. The current values are in boxes that enable you to update the parameter values. There are also boxes for Upper Side and Lower Side. If you have specified the Data Units option in the launch window, this setting is denoted in the Control Panel below the check boxes.

The Control Panel contains the following options:

**Target**  The known value of the mean. This is the value of the center line in the chart. By default, this parameter is set to the Target value in the Spec Limits column property for the Y column. If the Y column does not have a Target value in the Spec Limits column property, this parameter is set to the overall average of the Y column.

**Note:** To use the overall average of the Y column as the value of the center line even if the Y column has a Target value in the Spec Limits column property, select the Use Process Mean for Center Line platform preference. This preference is located in File > Preferences > Platforms > CUSUM Control Chart.

**Sigma**  The known value of the standard deviation. By default, this parameter is set to the average moving range of the Y column. If there is an X variable, the Sigma parameter is set to the average moving range of the summary data.

**Head Start**  The value of the cumulative sums before the first sample. Starting the cumulative sums at a nonzero value increases the sensitivity of the CUSUM chart near the beginning of the samples. This parameter is also known as the fast initial response (FIR) value. By default, this parameter is set to 0.

**h or H**  The value of the parameter that defines the limits. If the Data Units option was not selected in the launch window, this is the h parameter. If the Data Units option was selected in the launch window, this is the H parameter. Note that H is equal to h times Sigma. By default, h is equal to 5 and H is equal to 5 times Sigma.

**k or K**  The value of the parameter that defines the smallest change in the mean that is valuable to detect. If the Data Units option was not selected in the launch window, this is the k parameter. If the Data Units option was selected in the launch window, this is the K parameter. Note that K is equal to k times Sigma. By default, k is equal to 0.5 and K is equal to one half of Sigma.

**Upper Side**  Shows or hides the positive values for the cumulative sum on the chart. These values are the $C^+$ values.

**Lower Side**  Shows or hides the negative values for the cumulative sum on the chart. These values are the $C^-$ values.
CUSUM Control Charts

CUSUM Control Chart Platform Options

Using Data Units  The presence of this text indicates that the Data Units option was selected in the launch window and that the values in the CUSUM chart are centered but not standardized.

CUSUM Chart Report

The CUSUM Chart report contains the cumulative sum control chart with decision limits that are determined by the current values of the chart parameters. The samples (or subgroups if you specified an X variable) are denoted on the horizontal axis. The vertical axis denotes centered values of the positive and negative values for the cumulative sum. If the Data Units option was not selected in the launch window, the vertical axis denotes cumulative sums for standardized response values. If the Data Units option was selected in the launch window, the vertical axis denotes cumulative sums for unstandardized response values.

CUSUM Control Chart Platform Options

The CUSUM Control Chart red triangle menu contains the following options:

Show Limits  Shows or hides the upper and lower decision limits in the CUSUM Chart.

Show Center Line  Shows or hides the center line in the CUSUM Chart.

Show Shift Lines  (Available only when there is a shift detected in the data.) Shows or hides the vertical lines in the CUSUM Chart that designate shifts. Shift lines are drawn at the start of a shift.

- A positive shift occurs when the value of $C^+$ exceeds the upper limit on the chart. The start of the shift is defined as the first point after the most recent zero value for $C^+$.
- A negative shift occurs when the value of $C^-$ falls below the lower limit on the chart. The start of the shift is defined as the first point after the most recent zero value for $C^-.$

Show ARL  Shows or hides the Average Run Length (ARL) report. See “Average Run Length (ARL) Report”.

ARL Profiler  Shows or hides a profiler of average run length versus the parameters h and k. If you have specified the Data Units option in the launch window, the profiler plots average run length versus the parameters H and K.

The average run length (ARL) for a specified shift is the average number of runs expected before an out-of-control signal occurs. For example, the ARL at 0 represents the average
number of runs expected before a false-alarm signal occurs when the process is in control. When the process is in control, the shift size is 0.

The ARL Profiler enables you to explore how various settings of the parameters affect the performance of the corresponding CUSUM chart. As the parameters in the Control Panel are updated, the ARL Profiler is updated as well. An ideal CUSUM chart has a high ARL(0) value and a low ARL(Δ) value, where Δ is the size shift that is of interest.

The ARL Profiler depends on the settings of the Upper Side and Lower Side options in the Control Panel:

- If both the Upper Side and Lower Side options are selected, the profiler represents the average run length for crossing either the upper or lower decision limits on the CUSUM chart.
- If only the Upper Side option is selected, the profiler represents the average run length for the upper decision limit on the CUSUM chart.
- If only the Lower Side option is selected, the profiler represents the average run length for the lower decision limit on the CUSUM chart.

For more information about the options in the red triangle menu next to ARL Profiler, see Profilers.

**Control Panel**  Shows or hides a report of the current values of the parameters. This report enables you to change the parameter values as well as the sidedness of the CUSUM chart.

**Parameters Report**  Shows or hides a report of the current values of the parameters.

**Test Beyond Limits**  Shows or hides a red circle around any point that is above the upper limit or below the lower limit in the CUSUM chart.

**Save Summaries**  Creates a new data table that contains statistics for each subgroup in the CUSUM chart. The following statistics are saved to the new data table: the subgroup number and size, the subgroup sample mean, the value of the Sigma parameter, an indicator of shift starts, a value that indicates each interval between shift starts, an indicator of test failures, the upper and lower cumulative sums and corresponding consecutive run counts, and the LCL and UCL values.

**Get Limits**  Retrieves the control limits that are stored in an open or saved data table.

**Save Limits**  Saves the control limits in one of the following ways:

- **in Column**  Saves a Control Limits column property in the existing data table for the Y variable. The column property contains the value of the target used in the CUSUM chart.

- **in New Table**  Saves the values of H, K, the standard deviation, mean, and head start into a new data table.
CUSUM Control Charts
CUSUM Control Chart Platform Options

**Save Sigma**  Saves the value of the Sigma parameter to a Sigma column property in the Y variable column in the data table.

**Tune Chart**  Shows or hides a control that enables you to set an acceptable range for the Y variable. Adjust the minimum and maximum values of the acceptable range and click **Done**. At this point, the CUSUM chart updates based on a new value of the k parameter.

- If you specified the Data Units option in the launch window, the imputed k parameter is the average of the minimum and maximum values.
- If the Data Units option is not specified, the imputed K parameter is the average of the minimum and maximum values divided by the Sigma parameter.

Setting the acceptable range for the Y variable enables you to set the practical significance of the CUSUM chart. This is particularly helpful when the testing interval is more frequent, which can result in a much shorter practical average run length.

**Reset to Defaults**  Resets all parameters back to their default values.

**Alarm Script**  Enables you to write and run a script that indicates when the data fail special causes tests. Results can be written to a file, written to the log or sent in an email. There is an option to include an explanation of why the test failed.

As an Alarm Script is invoked, the following variables are available, both in the issued script and in subsequent JSL scripts:

- `qc_col` is the name of the column
- `qc_test` is the test that failed
- `qc_sample` is the sample number

**Tip:** After an alarm script is specified, the alarm script is invoked when the Test Beyond Limits option is turned on.

See the *Scripting Guide* for more information about writing custom Alarm Scripts.

See *Using JMP* for more information about the following options:

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Platform Preferences**  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.
Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Average Run Length (ARL) Report

In the CUSUM Control Chart platform, the Average Run Length (ARL) report contains a table and a graph of ARL values. The average run length (ARL) for a specified shift is the average number of runs expected before an out-of-control signal occurs. For example, the ARL at 0 represents the average number of runs expected before seeing a false-alarm signal when the process is in control. When the process is in control, the shift size is 0.

The table and graph in the ARL report enable you to explore how various settings of the parameters affect the performance of the corresponding CUSUM chart. As the \( h \) and \( k \) parameters in the Control Panel are updated, the ARL report is updated as well. An ideal CUSUM chart has a high ARL(0) value and a low ARL(\( \Delta \)) value, where \( \Delta \) is the size shift that is of interest.

The Average Run Length (ARL) report depends on the settings of the Upper Side and Lower Side options in the Control Panel. If only one option is selected, the ARL report uses calculations for the corresponding one-sided CUSUM chart. If both options are selected, the ARL report uses calculations for the two-sided CUSUM chart. Note that the two-sided ARL values are related to the positive and negative one-sided ARL values by the following equation:

\[
\frac{1}{\text{ARL}} = \frac{1}{\text{Positive ARL}} + \frac{1}{\text{Negative ARL}}
\]

ARL Table

The ARL Table shows the average run length for shifts (\( \Delta \)) between zero and three at 0.25 increments. If the Data Units option is specified, the shift is represented by \( 2^*K/\Sigma^2 \). If the Data Units option is not specified, the shift is represented by \( 2^*k/\Sigma \).

ARL Graph

The ARL Graph shows the average run length for shifts (\( \Delta \)) between 0 and 3. This graph contains the same data points as the ARL Table to the left of the ARL Graph.
Additional Examples of CUSUM Control Charts

This section contains examples using the CUSUM Control Chart platform.

- “Example of the Data Units Option in a CUSUM Control Chart”
- “Example of a CUSUM Chart with Subgroups”

Example of the Data Units Option in a CUSUM Control Chart

This example uses the Data Units option to detect small shifts in the temperature of an engine. The data table contains temperature measurements from the engine thermostat.

Note: This example reproduces the analysis in “Example of a CUSUM Control Chart” using the data units option.

1. Select Help > Sample Data Folder and open Quality Control/Engine Temperature Sensor.jmp.
2. Select Analyze > Quality and Process > Control Chart > CUSUM Control Chart.
3. Select Y and click Y.
4. Select the box next to Data Units.
5. Click OK.
6. In the Target box, type 100.
7. In the Sigma box, type 10.

Note that the options below Head Start are H and K, instead of h and k. These parameters are now specified in units of the data column, rather than in standard deviation units.
Like in the example using sigma units, the vertical line on the CUSUM Chart indicates that a shift in the temperature measurements started around sample 26.

**Example of a CUSUM Chart with Subgroups**

In this example, you want to be able to detect a $2\sigma$ shift in a process. A machine fills 8-ounce cans of two-cycle engine oil additive. The filling process is believed to be in statistical control. The process is set so that the average weight of a filled can ($\mu_0$) is 8.10 ounces. Previous analysis shows that the standard deviation of fill weights ($\sigma_0$) is 0.05 ounces.

Subgroup samples of four cans are selected and weighed every hour for twelve hours. Each observation in the data table contains one value of weight and its associated value of hour. The observations are sorted so that the values of hour are in increasing order.

1. Select **Help > Sample Data Folder** and open Quality Control/Oil1 Cusum.jmp.
2. Select **Analyze > Quality and Process > Control Chart > CUSUM Control Chart**.
3. Select **weight** and click **Y**.
4. Select **hour** and click **X**.
5. Click **OK**.
6. In the Target box, type 8.1.
   This is the target mean for the process.
7. In the Sigma box, type 0.05.
   This is the known standard deviation for the process.
8. In the h box, type 2.
This defines the decision limits to be 2 standard deviations in each direction.

**Figure 10.7** CUSUM Control Chart with Subgroups

The CUSUM Chart does not show any points outside of the upper or lower decision limits. There is no evidence that a shift in the process has occurred.

**Note:** Montgomery (2013) states that “only if there is some significant economy of scale or some other valid reason for taking samples of size greater than one should subgroups of size greater than one be used with the CUSUM.” The use of rational subgroups in the tabular CUSUM chart does not always improve the performance of the chart.

---

**Statistical Details for the CUSUM Control Chart Platform**

This section contains statistical details for the CUSUM Control Chart platform.

- “Statistical Details for CUSUM Control Chart Construction”
- “Statistical Details for Shift Detection”
- “Statistical Details for Average Run Length”
Statistical Details for CUSUM Control Chart Construction

This section defines the statistics that are used in the construction of the CUSUM Chart. Some of these statistics are also saved in the data table that is created by the Save Summaries command.

One-Sided Upper and Lower Cumulative Sums

The definitions of $C^+$ and $C^-$ depend on the setting of the Data Units option.

**Note:** In the Save Summaries data table, $C^+$ and $C^-$ are labeled Upper Cumulative Sum and Lower Cumulative Sum, respectively.

Cumulative Sums in Standardized Units

If the Data Units option is not selected, $C^+$ and $C^-$ for each step are defined as follows:

$$ C_i^+ = \max \left(0, \frac{x_i - T}{\sigma} - k + C_{i-1}^+ \right) $$

$$ C_i^- = \min \left(0, \frac{x_i - T}{\sigma} + k + C_{i-1}^- \right) $$

where:

$x_i$ is the value of the response at the $i^{th}$ step

$T$ is the target of the process

$\sigma$ is the standard deviation of the process

$k$ is the reference value, in units of standard deviations

If a value is specified for Head Start, that value is used as the initial $C^+$ value and the negative of that value is used as the initial $C^-$ value. Otherwise, the initial values of $C^+$ and $C^-$ are zero.

Cumulative Sums in Data Units

If the Data Units option is selected, $C^+$ and $C^-$ for each step are defined as follows:

$$ C_i^+ = \max(0, (x_i - T) - K + C_{i-1}^+ ) $$

$$ C_i^- = \min(0, (x_i - T) + K + C_{i-1}^- ) $$
where:

\[ x_i \] is the value of the response at the \( i^{th} \) step

\( T \) is the target of the process

\( \sigma \) is the standard deviation of the process

\( K \) is the reference value, in units of the data

If a value is specified for Head Start, that value is used as the initial \( C^+ \) value and the negative of that value is used as the initial \( C^- \) value. Otherwise, the initial values of \( C^+ \) and \( C^- \) are zero.

### Counters for Positive and Negative Runs

\( N^+ \) at each step is the number of steps since the most recent zero value for \( C^+ \). \( N^- \) at each step is the number of steps since the most recent zero value for \( C^- \).

**Note:** In the Save Summaries data table, \( N^+ \) and \( N^- \) are labeled Positive Runs and Negative Runs, respectively.

### Statistical Details for Shift Detection

This section defines positive and negative shift detection for the CUSUM Chart.

A positive shift occurs when the value of \( C^+ \) exceeds the upper limit on the chart. The start of the shift is defined as the first point after the most recent zero value for \( C^+ \).

A negative shift occurs when the value of \( C^- \) exceeds the lower limit on the chart. The start of the shift is defined as the first point after the most recent zero value for \( C^- \).

### Statistical Details for Average Run Length

This section defines how one-sided and two-sided average run length (ARL) values are calculated in a CUSUM Control Chart.

The one-sided ARL values are calculated using the integral equation method (with 24 Gaussian points) described by Goel and Wu (1971). If the Head Start value is greater than 0, the values are calculated according to the method in Appendix A.1 of Lucas and Crosier (1982).

Note that the two-sided ARL values are related to the positive and negative one-sided ARL values by the following equation:

\[
\frac{1}{\text{ARL}} = \frac{1}{\text{Positive ARL}} + \frac{1}{\text{Negative ARL}}
\]
Lucas and Crosier (1982) describe the properties of a Head Start value for CUSUM charts in which the initial CUSUM $S_0$ is set to a nonzero value. This is sometimes referred to as a fast initial response (FIR) feature. Average run length calculations given by them show that the FIR feature has little effect when the process is in control and that it leads to a faster response to an initial out-of-control condition than a standard CUSUM chart.
Exponentially weighted moving average (EWMA) charts can be used to detect small shifts in a process. Each point on an EWMA chart is the weighted average of all the previous subgroup means, including the mean of the present subgroup sample. The weights decrease exponentially going backward in time.

**Figure 11.1** EWMA Control Chart Report
Contents

Overview of the EWMA Control Chart Platform .................................................. 323
Example of the EWMA Control Chart Platform .................................................. 323
Launch the EWMA Control Chart Platform ....................................................... 325
The EWMA Control Chart Platform Report ...................................................... 326
  Control Panel for EWMA Control Chart ......................................................... 326
  EWMA Chart Report ....................................................................................... 327
The EWMA Control Chart Platform Options .................................................... 329
  Average Run Length (ARL) Report ................................................................. 332
Additional Example of the EWMA Control Chart Platform .............................. 333
Statistical Details for the EWMA Control Chart Platform ................................. 336
Overview of the EWMA Control Chart Platform

Exponentially weighted moving average (EWMA) charts can be used to detect small shifts in a process. Each point on an EWMA chart is the weighted average of all the previous subgroup means, including the mean of the present subgroup sample. The weights decrease exponentially going backward in time. For more information about exponentially weighted moving average charts, see Box et al. (2009) and Montgomery (2013).

The EWMA Control Chart platform pairs an EWMA chart with an X chart and a residual chart. If you do not specify a Subgroup variable, the X chart is an individual measurements chart. If you specify a Subgroup variable and at least one subgroup size is greater than 1, the X chart is an XBar chart.

Example of the EWMA Control Chart Platform

In this example, you are interested in detecting a shift in the gap between the ends of manufactured metal clips. To monitor the process for a change in the average gap, subgroup samples of five clips have been measured daily.

1. Select Help > Sample Data Folder and open Quality Control/Clips1.jmp.
2. Select Analyze > Quality and Process > Control Chart > EWMA Control Chart.
3. Select Gap and click Y.
4. Select Sample and click Subgroup.
5. Click OK.
Purple vertical lines in the EWMA chart denote shifts. Shift starts are detected at samples 4 and 17.
Launch the EWMA Control Chart Platform

Launch the EWMA Control Chart platform by selecting Analyze > Quality and Process > Control Chart > EWMA Control Chart.

Figure 11.3 EWMA Control Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using JMP.

The EWMA Control Chart platform launch window contains the following options:

- **Y** Identifies the variables that you want to chart.
  
  **Note:** If you do not specify a Subgroup variable, the rows of the data table must be sorted in the order in which the observations were collected.

- **Subgroup** Identifies a subgroup variable. The horizontal axis of the EWMA chart is labeled by the subgroup variable.

- **By** Produces a separate report for each level of the By variable. If more than one By variable is assigned, a separate report is produced for each possible combination of the levels of the By variables.

- **Center Data** Specifies that the data are centered by subtracting the target from each observation.

- **Show Excluded Region** (Applicable only when a Subgroup variable is specified.) Specifies that subgroups that are entirely excluded in the data table are shown in the EWMA control chart.
By default, the EWMA Control Chart platform produces a report that contains a parameter control panel, an EWMA chart, an X chart, and a residuals chart.

- “Control Panel for EWMA Control Chart”
- “EWMA Chart Report”

**Figure 11.4  EWMA Control Chart Report**

**Control Panel for EWMA Control Chart**

The Control Panel contains the current values for the chart parameters. The current values are in boxes that enable you to update the parameter values.
The Control Panel contains the following options:

**Target** The known value of the mean. This is the value of the center line in the chart. By default, this parameter is set to the Target value in the Spec Limits column property for the Y column. If the Y column does not have a Target value in the Spec Limits column property, this parameter is set to the overall average of the Y column.

The Target value cannot be edited in these situations:

– If you specified the Center Data option in the launch window.
– If the Y variable has a Spec Limits column property that contains a value for Target. However, you can select the Use Overall Mean for Target option in the red triangle menu to switch between the Target value in the Spec Limits column property and the overall mean of the Y variable.

**Sigma** The known value of the standard deviation. By default, this parameter is set to the average moving range of the Y column. If there is a Subgroup variable, the Sigma parameter is set to the average of the moving ranges of the subgroup means.

*Note:* The default Sigma value calculation does not include excluded rows.

**Lambda** The value of the smoothing constant for weighting prior samples. By default, this parameter is set to 0.2.

*Using Centered Data* The presence of this text indicates that the Centered Data option was selected in the launch window and that the values in the EWMA chart and X chart are centered around the Target value.

**EWMA Chart Report**

The EWMA Chart report contains three charts: an EWMA chart, an X chart, and a residuals chart. For more information about the interpretation of these charts, see Box et al. (2009).

**EWMA Chart**

The EWMA chart is an exponentially weighted moving average (EWMA) chart with decision limits that are determined by the current values of the chart parameters:

- If you specified a Subgroup variable and at least one subgroup size is greater than 1, the horizontal axis denotes the subgroups.
- Otherwise, the horizontal axis denotes the samples.
In both cases, the vertical axis denotes the exponentially weighted moving average. If you specified the Center Data option in the launch window, the vertical axis denotes the exponentially weighted moving average with the target value subtracted from it. Each sample or subgroup has a single point on the chart. There is one additional point that is a forecast point, which is shown in blue.

**Note:** If the last sample (or subgroup) is both hidden and excluded, the line connecting the last sample (or subgroup) to the forecast point is not drawn.

### X Chart

The X chart is a Shewhart control chart of the observations:

- If you specified a Subgroup variable and at least one subgroup size is greater than 1, the X chart is an XBar chart of the mean values. The horizontal axis denotes the subgroups. The vertical axis denotes the subgroup means. If you selected the Center Data option in the launch window, the vertical axis denotes the subgroup means with the target value subtracted from them. Each subgroup has a single point on the chart.

- Otherwise, the X chart is an individual measurements chart of the values. The horizontal axis denotes the samples. The vertical axis denotes the measurements. If you selected the Center Data option in the launch window, the vertical axis denotes the measurements with the target value subtracted from them. Each sample has a single point on the chart.

For more information about the limits on the X chart, see “Statistical Details for Control Chart Builder”.

### Residuals Chart

The residuals chart enables you to visually check for autocorrelation:

- If you specified a Subgroup variable and at least one subgroup size is greater than 1, the residuals chart is a chart of the differences between each subgroup mean and the EWMA value for the previous subgroup. The $i^{th}$ residual is calculated as $r_i = X_i - EWMA_{i-1}$ where $X_i$ denotes the $i^{th}$ subgroup mean and $EWMA_{i-1}$ denotes the $(i-1)^{th}$ EWMA value.

- Otherwise, the residuals chart is a chart of the differences between each sample value and the EWMA value for the previous sample. The $i^{th}$ residual is calculated as $r_i = X_i - EWMA_{i-1}$ where $X_i$ denotes the $i^{th}$ sample value and $EWMA_{i-1}$ denotes the $(i-1)^{th}$ EWMA value.

The limits on the residuals chart are $\pm 3*ResidSigma$, where $ResidSigma$ is the standard deviation of the residuals.
The EWMA Control Chart Platform Options

The EWMA Control Chart red triangle menu contains the following options:

**Show Limits**  Shows or hides the upper and lower decision limits in the EWMA chart, X chart, and residuals chart.

**Show Center Line**  Shows or hides the center line in the EWMA chart, X chart, and residuals chart.

**Show Shift Lines**  Shows or hides the vertical lines in the EWMA chart that designate shifts. Shift lines are drawn at the start of a shift. A shift start is defined as the first point after the EWMA value crosses the center line in a particular direction.

- A positive shift occurs when the EWMA value exceeds the upper limit on the chart. The start of the shift is defined as the first point after the most recent EWMA value below the Target line.
- A negative shift occurs when the EWMA value falls below the lower limit on the chart. The start of the shift is defined as the first point after the most recent EWMA value above the Target line.

**Figure 11.5 Shift Lines Example**

![Shift Lines Example](image)

In this example, the point for sample 7 is above the upper limit. Looking back from sample 7, the most recent point below the Target line is sample 3. Therefore, sample 4 is the first point above the Target line since the most recent point below the Target line and is denoted as the start of the positive shift.

Similarly, the point for sample 20 is below the lower limit and the most recent point above the Target line is sample 16. Therefore, sample 17 is denoted as the start of the negative shift.

**Test Beyond Limits**  Shows or hides a red circle around any point that is above the upper limit or below the lower limit in the EWMA and X charts.
Show ARL  Shows or hides the Average Run Length (ARL) report. See “Average Run Length (ARL) Report”.

Control Panel  Shows or hides a report of the current values of the parameters. This report enables you to change the parameter values in the EWMA chart.

Parameters Report  Shows or hides a report of the current values of the parameters.

Constant Limits  Specifies that the EWMA chart limits are calculated using an asymptotic expression so that the limits on the EWMA chart are constant.

**Caution:** The Constant Limits option has no effect when the sample sizes are not equal across subgroups.

Save Summaries  Creates a new data table that contains statistics for each subgroup in the EWMA chart. The following statistics are saved to the new data table: the subgroup number, the subgroup label, the subgroup size, the subgroup mean, an indicator of shift starts, a value that indicates each interval between shift starts, the exponentially weighted moving average of each subgroup, the number of positive and negative consecutive run counts, the LCL and UCL values, and test failure indicators. The table also contains columns for the center, LCL, and UCL values for the X chart, as well as columns for the point, average, LCL, and UCL values for the Residuals chart. The forecast value is saved in the last row of the summary table.

Reset to Defaults  Resets all parameters to their default values. If a Lambda value has been specified in the Lambda platform preference, the Lambda value is reset to the value that is specified in the platform preference.

**Note:** When the Y variable has a Spec Limits column property that contains a value for Target, the Reset to Defaults option sets the Target to the Target value in the Spec Limits column property.

Restart EWMA After Empty Subgroup  Specifies how calculations for the moving average and limits are handled when there are empty subgroups. A subgroup can be empty if all the observations for the subgroup are missing values or are in excluded rows. If this option is selected, the calculations restart in the first nonmissing subgroup that follows an empty subgroup. The restart of the calculations resets the moving average to the overall mean. If this option is not selected, the EWMA calculations continue with the most recent nonmissing subgroup moving average.

Connect Thru Missing  Connects points when some samples have missing values or excluded rows.

Use Overall Mean for Target  (Available only when the Y variable has a Spec Limits column property that contains a value for Target.) Sets the Target in the EWMA chart to the overall
mean of the \( Y \) variable. If this option is not selected, the Target in the EWMA chart is set to the Target value in the Spec Limits column property.

**Overlay Charts** Specifies whether the individual location values are overlaid on the EWMA chart. When this option is selected, the Location chart is no longer shown. Instead, the points from the Location chart appear on the EWMA chart as unconnected gray Xs. The limits from the Location chart do not appear on the EWMA chart, unless the Show X Limits on Overlay Charts option is selected.

**Note:** When the Overlay Charts option is selected, the Show X Chart option is also selected.

**Show X Limits on Overlay Charts** (Available only when the Overlay Charts option is selected.) Shows or hides the limits from the Location chart on the EWMA chart when the Overlay Charts option is selected. When the Location chart limits are shown on the EWMA chart, they appear as dashed lines.

**Note:** The Test Beyond Limits option is applied to the Location chart values in the Overlay Chart only when the Show X Limits on Overlay Charts option is selected.

**Lambda Slider** Shows or hides a slider control that enables you to change the value of the Lambda parameter interactively.

**Show X Chart** Shows or hides the Location chart below the EWMA chart.

**Note:** When the Overlay Charts option is selected, the Show X Chart option is also selected and cannot be turned off.

**Show Residuals Chart** Shows or hides a chart of residuals.

**K Sigma** Sets the \( K \) value to be multiplied by sigma to form the control limit about the average. By default, \( K \) Sigma is set to 3.

**Get Limits** Retrieves the control limits that are stored in an open or saved data table.

**Save Limits** Saves the chart parameters in one of the following ways:

- **in Column** Saves a Control Limits column property in the existing data table for the response variable. The column property contains the value of the target used in the EWMA chart.

- **in New Table** Saves the values of Lambda, the standard deviation, and the target for the EWMA chart into a new data table.

**Save Sigma** Saves the value of the Sigma parameter to a Sigma column property in the \( Y \) variable column in the data table.
**Alarm Script**  Enables you to write and run a script that indicates when the data fail special causes tests. Results can be written to a file, written to the log or sent in an email. There is an option to include an explanation of why the test failed.

As an Alarm Script is invoked, the following variables are available, both in the issued script and in subsequent JSL scripts:

- `qc_col` is the name of the column
- `qc_test` is the test that failed
- `qc_sample` is the sample number

**Tip:** After an alarm script is specified, the alarm script is invoked when the Test Beyond Limits option is turned on.

See the *Scripting Guide* for more information about writing custom Alarm Scripts.

See *Using JMP* for more information about the following options:

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Platform Preferences**  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

**Save By-Group Script**  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

**Average Run Length (ARL) Report**

In the EWMA Control Chart platform, the Average Run Length (ARL) report contains a table and a graph of ARL values. The average run length (ARL) for a specified shift is the average number of runs expected before an out-of-control signal occurs. For example, the ARL at 0 represents the average number of runs expected before seeing a false-alarm signal when the process is in control. When the process is in control, the shift size is 0.

The table and graph in the ARL report enable you to explore how various settings of the Lambda parameter affect the performance of the corresponding EWMA chart. The table and graph also enable you to compare the performance of the EWMA chart with a Shewhart chart, such as the X chart in the EWMA Chart report. The Shewhart ARL column is equivalent to the EWMA ARL column when Lambda is set to 1.
The value of EWMA ARL at 0 depends on the setting of the Constant Limits option:

- If the Constant Limits option is selected, the process is assumed to have been in control long enough that the effect of the starting value is negligible. In this case, also referred to as a steady state of the EWMA chart, the value of EWMA ARL(0) is calculated using the method described in Crowder (1987).
- If the Constant Limits option is not selected, the value of EWMA ARL(0) is calculated using the method described in Knoth (2004). This situation is also referred to as a zero state of the EWMA chart.

**ARL Report**

The ARL Report shows the average run length for standardized shifts ($\Delta$) between 0 and 3 at 0.25 increments. The shift is represented by $\sqrt{n} \times \text{RawShift}/\Sigma$, where $n$ is the constant sample size in each subgroup. The multiplier used in calculating control limits is the current value of $K \Sigma$. By default, $K \Sigma$ is set to 3. This table contains ARL values for the EWMA chart as well as a Shewhart chart.

**ARL Graph**

The ARL Graph shows the average run length for standardized shifts ($\Delta$) between 0 and 3. This graph contains the same data points as the ARL Table to the left of the ARL Graph. The solid line corresponds to the EWMA ARL values, and the dashed line corresponds to the Shewhart ARL values.

**Additional Example of the EWMA Control Chart Platform**

In this example, you create a chart that overlays the subgroup points and limits on the EWMA control chart. This enables you to see the EWMA points in the context of the subgroup points. The data table used in this example contains simulated observations of temperature at the time of magnet quench. Magnet quench occurs when part of the superconducting coil enters a resistive state and increases in temperature. When this happens, containment of the fusion reactor is at risk. Immediately shutting down power to the magnet is required to prevent a breach.

1. Select **Help > Sample Data Folder** and open **Quality Control/Quench.jmp**.
2. Select **Analyze > Quality and Process > Control Chart > EWMA Control Chart**.
3. Select **Temp** and click **Y**.
4. Select **Time stamp** and click **Subgroup**.
5. Click **OK**.
6. Click the EWMA Control Chart red triangle and select **Test Beyond Limits**.

**Figure 11.6** EWMA Chart with Points Beyond Limits Highlighted

![EWMA Control Chart]

Note that three observations are outside the limits in the EWMA chart and one observation is outside the limits in the X chart. The observations outside of the limits are indicated by a red circle. The purple vertical line in the EWMA chart denotes a shift upward around 1:16 AM.

7. Click the EWMA Control Chart red triangle and select **Overlay Charts**.

The X chart limits are not shown on the overlay chart by default, so the observation outside the X limits is not circled until you turn on the X limits for the overlay chart.

8. Click the EWMA Control Chart red triangle and select **Show X Limits on Overlay Charts**.
The solid lines and circles in the top chart represent the limits and points for the EWMA chart. The dashed lines and x markers represent the limits and points for the X chart. Note that the observations outside the EWMA limits and the X limits are still circled.

9. Click the EWMA Control Chart red triangle and select **Constant Limits**.
Because the time span of the data is so long, the asymptotic limits differ from the original EWMA limits only for the first few subgroups. In this case, you might decide that you can use constant (asymptotic) limits instead of the EWMA limits.

**Statistical Details for the EWMA Control Chart Platform**

This section defines the statistics that are used in the construction of the EWMA chart. Some of these statistics are also saved in the data table that is created by the Save Summaries command.

The $i^{th}$ point on the EWMA chart is calculated as follows:

$$EWMA_i = \lambda X_i + (1 - \lambda)EWMA_{i-1}$$

where:

- $\lambda$ = Lambda parameter
- $X_i = i^{th}$ sample value (or subgroup mean)
Chapter 11
EWMA Control Charts

Quality and Process Methods
Statistical Details for the EWMA Control Chart Platform

\[ \text{EWMA}_{i-1} = (i-1)^{\text{th}} \text{ EWMA value} \]

When \( i = 1 \), define \( \text{EWMA}_0 \) as the Target value.

**Note:** When the Restart EWMA after Empty Subgroup option is selected, the \( \text{EWMA}_{i-1} \) value following an empty subgroup is the Target value. When the Restart EWMA after Empty Subgroups option is not selected, the \( \text{EWMA}_{i-1} \) value following an empty subgroup is the \( \text{EWMA} \) value for the most recent non-empty subgroup.

The computation of the control limits on the EWMA chart is determined by the setting of the Constant Limits option.

**EWMA Limits**

When the Constant Limits option is not selected and the subgroup sizes are not equal, the EWMA control limits are computed as follows:

\[
\begin{align*}
\text{LCL} &= T - K \sigma \lambda \sqrt{\sum_{j=1}^{i} \frac{(1-\lambda)^{2(i-j)}}{n_j}} \\
\text{UCL} &= T + K \sigma \lambda \sqrt{\sum_{j=1}^{i} \frac{(1-\lambda)^{2(i-j)}}{n_j}}
\end{align*}
\]

where:

- \( T \) = Target value
- \( K \) = the sigma multiplier and is set to 3 by default
- \( \sigma \) = Sigma value
- \( i \) = the number of the sample (or subgroup)
- \( n_i \) = the size of subgroup \( i \)

When the Constant Limits option is not selected and the subgroup sizes are equal, the formulas for the EWMA control limits simplify as follows:

\[
\begin{align*}
\text{LCL} &= T - K \sigma \frac{\lambda}{\sqrt{n(2-\lambda)}} \left[ 1 - (1-\lambda)^{2i} \right] \\
\text{UCL} &= T + K \sigma \frac{\lambda}{\sqrt{n(2-\lambda)}} \left[ 1 - (1-\lambda)^{2i} \right]
\end{align*}
\]

where:

- \( T \) = Target value
$K =$ the sigma multiplier and is set to 3 by default

$\sigma =$ Sigma value

$i =$ the number of the sample (or subgroup)

$n =$ the size of each subgroup (or 1 if no subgroup is specified)

**Constant Limits**

When the Constant Limits option is selected, the EWMA control limits are computed as follows:

$$LCL = T - K\sigma \sqrt{\frac{\lambda}{n(2 - \lambda)}}$$  

$$UCL = T + K\sigma \sqrt{\frac{\lambda}{n(2 - \lambda)}}$$

where:

$T =$ Target value

$K =$ the sigma multiplier and is set to 3 by default

$\sigma =$ Sigma value

$n =$ the subgroup size (or 1 if no subgroup is specified)

For more information about constructing exponentially weighted moving average charts, see Montgomery (2013).
Chapter 12

Multivariate Control Charts
Monitor Multiple Process Characteristics Simultaneously

The Multivariate Control Charts platform is deprecated, meaning it is an older platform that contains features that can be accessed in a newer platform. This legacy platform might not be available in future releases of JMP.

For monitoring and diagnosing complex processes, see “Model Driven Multivariate Control Charts”.
Contents

Overview of Multivariate Control Charts .................................................. 341
Launch the Multivariate Control Chart Platform ........................................ 341
The Multivariate Control Chart Report ..................................................... 343
Multivariate Control Chart Platform Options ........................................... 344
   T Square Partitioned ............................................................................ 345
   Change Point Detection ....................................................................... 346
   Principal Components .......................................................................... 347
Statistical Details for Multivariate Control Charts ...................................... 347
   Statistical Details for Individual Observations ....................................... 348
   Statistical Details for Observations in Rational Subgroups ...................... 350
   Statistical Details for Change Point Detection ....................................... 352
Overview of Multivariate Control Charts

Multivariate control charts are used to monitor two or more interrelated process variables. Where univariate control charts are used to monitor a single independent process characteristic, multivariate control charts are necessary when process variables are correlated. A Hotelling $T^2$ chart, or just $T^2$ chart for short, is one type of multivariate control chart. A $T^2$ chart can detect shifts in the mean or the relationship between several interrelated variables. The observations can either be individual observations of the process variables or they can be grouped into rational subgroups.

Tip: For an updated multivariate control chart platform, see “Model Driven Multivariate Control Charts”.

Launch the Multivariate Control Chart Platform

Launch the Multivariate Control Chart platform by selecting Analyze > Quality And Process > Control Chart > Multivariate Control Chart.

Figure 12.1 The Multivariate Control Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using JMP.

Tip: Consider using the newer Model Driven Multivariate Control Chart platform. To launch the Model Driven Multivariate Control Chart platform, select Analyze > Quality and Process > Model Driven Multivariate Control Chart.

The Multivariate Control Chart platform launch window contains the following options:

Y, Columns Specify the columns to be analyzed.
**Subgroup**  Enter a column with sub-grouped data. Hierarchically, this group is nested within Group.

**Group**  Enter a column that specifies group membership at the highest hierarchical level.

**Weight**  Identifies the data table column whose variables assign weight (such as importance or influence) to the data.

**Freq**  Identifies the data table column whose values assign a frequency to each row. Can be useful when your data table contains summarized data.

**By**  Identifies a column that creates a report consisting of separate analyses for each level of the variable.

**Get Targets**  Click to select a JMP table that contains historical targets for the process.
The Multivariate Control Chart Report

Use a multivariate control chart to quickly identify shifts in your process and to monitor your process for special cause indications.

Figure 12.2  Multivariate Control Chart
The multivariate control chart plots Hotelling’s $T^2$ statistic. The calculation for the control limit differs based on whether targets have been specified. To understand how the $T^2$ statistic and the UCL (Upper Control Limit) are calculated, see “Statistical Details for Multivariate Control Charts”. For more information about control limits, see Tracy et al. (1992).

In this example, the Principal Components reports for both data sets indicate that the first eigenvalue, corresponding to the first principal component, explains about 95% of the total variation in the variables. The values in both Eigenvectors tables indicate that the first principal component is driven primarily by the variables Fuel and Steam Flow. You can use this information to construct a potentially more sensitive control chart based only on this first component. For more information about the Principal Components reports, see “Principal Components”.

---

Multivariate Control Chart Platform Options

The Multivariate Control Chart red triangle menu contains the following options:

- **T Square Chart**  Shows the $T^2$ chart. Hotelling’s $T^2$ chart is a multivariate extension of the XBar chart that takes correlation into account.

- **T Square Partitioned**  Constructs multivariate control charts based on the principal components of Y. Specify the number of major principal components for $T^2$. See “T Square Partitioned”.

- **Set Alpha Level**  Set the $\alpha$ level used to calculate the control limit. The default is $\alpha=0.05$.

- **Show Covariance**  Shows the Covariance report. Covariance is a measure of the linear relationship between two variables. When a subgroup variable is specified, the Pooled Covariance report is shown.

- **Show Correlation**  Shows the Correlation report. When a subgroup variable is specified, the Pooled Correlation report is shown.

- **Show Inverse Covariance**  Shows the Inverse Covariance report. If the inverse covariance is singular, a generalized inverse of the covariance matrix is reported. When a subgroup variable is specified, the Pooled Inverse Covariance report is shown.

- **Show Inverse Correlation**  Shows the Inverse Correlation report. If the inverse correlation is singular, a generalized inverse of the correlation matrix is reported. When a subgroup variable is specified, the Pooled Inverse Correlation report is shown.

- **Show Means**  Shows the Group Means report, which contains the means for each group.

- **Save T Square**  Creates a new column in the data table containing $T^2$ values.
**Save T Square Formula**  Creates a new column in the data table. Stores a formula in the column that calculates the $T^2$ values.

**Save Target Statistics**  Creates a new data table containing target statistics for the process. Target statistics include: sample size, the number of samples, mean, standard deviation, and any correlations.

**Change Point Detection**  (Not available for sub-grouped data.) Shows a Change Point Detection plot of test statistics by row number and indicates the row number where the change point appears. See “Change Point Detection”.

**Principal Components**  Shows reports showing eigenvalues and their corresponding eigenvectors. Principal components help you understand which of the many variables you might be monitoring are primarily responsible for the variation in your process. See “Principal Components”.

**Save Principal Components**  Creates new columns in the data table that contain the scaled principal components.

---

**T Square Partitioned**

In the Multivariate Control Chart red triangle menu, you can use the T Square Partitioned option to construct a control chart based on principal components. This is useful if you are monitoring a large number of correlated process characteristics. If a small number of principal components explains a large portion of the variation in your measurements, then a multivariate control chart based on these big components might be more sensitive than a chart based on your original, higher-dimensional data.

**Tip:** Consider using the Model Driven Multivariate Control Chart platform for decomposition of the $T^2$ statistic. See “Model Driven Multivariate Control Charts”.

The T Square Partitioned option is also useful when your covariance matrix is ill-conditioned. When this is the case, components with small eigenvalues, explaining very little variation, can have a large, and misleading, impact on $T^2$. It is useful to separate out these less important components when studying process behavior.

Once you select the T Square Partitioned option, you need to decide how many major principal components to use.
The option creates two multivariate control charts: T Square with Big Principal Components and T Square with Small Principal Components. Suppose that you enter \( r \) as the number of major components when you first select the option. The chart with Big Principal Components is based on the \( r \) principal components corresponding to the \( r \) largest eigenvalues. These are the \( r \) components that explain the largest amount of variation, as shown in the Percent and Cum Percent columns in the Principal Components: on Covariances reports. The chart with Small Principal Components is based on the remaining principal components.

For a given subgroup, its \( T^2 \) value in the Big Principal Components chart and its \( T^2 \) value in the Small Principal Components chart sum to its overall \( T^2 \) statistic presented in the \( T^2 \) with All Principal Components report. For more information about how the partitioned \( T^2 \) values are calculated, see Kourti and MacGregor (1996).

**Change Point Detection**

When the data set consists of multivariate individual observations, a multivariate control chart can be developed to detect a shift in the mean vector, the covariance matrix, or both. This method partitions the data and calculates likelihood ratio test statistics for a shift. The statistic that is plotted on the control chart is an observation’s likelihood ratio test statistic divided by the product of the following:

- Its approximate expected value assuming no shift.
- An approximate value for an upper control limit.

Division by the approximate upper control limit allows the points to be plotted against an effective upper control limit of 1. A Change Point Detection plot readily shows the change point for a shift occurring at the maximized value of the control chart statistic. The Change Point Detection implementation in JMP is based on Sullivan and Woodall (2000) and is described in “Statistical Details for Change Point Detection”.

**Note:** The Change Point Detection method is designed to show a single shift in the data. Detect multiple shifts by recursive application of this method.

Note the following about the Change Point Detection plot:

- Values above 1.0 indicate a possible shift in the data.
- Control chart statistics for the Change Point Detection plot are obtained by dividing the likelihood ratio statistic of interest (either a mean vector or a covariance matrix) by a normalizing factor.
- The change point of the data occurs for the observation having the maximum test statistic value for the Change Point Detection plot.

Note the following about the scatterplot matrix:

- This plot shows the shift in the sample mean vector.
**Principal Components**

In the Multivariate Control Chart platform, the Principal Components report contains the following information:

- **Eigenvalue**  
  Eigenvalues for the covariance matrix.

- **Percent**  
  Percent variation explained by the corresponding eigenvector. Also shows an accompanying bar chart.

- **Cum Percent**  
  Cumulative percent variation explained by eigenvectors corresponding to the eigenvalues.

- **ChiSquare**  
  Provides a test of whether the correlation remaining in the data is of a random nature. This is a Bartlett test of sphericity. When this test rejects the null hypothesis, this implies that there is structure remaining in the data that is associated with this eigenvalue.

- **DF**  
  Degrees of freedom associated with the Chi-square test.

- **Prob > ChiSq**  
  $p$-value for the test.

- **Eigenvectors**  
  Table of eigenvectors corresponding to the eigenvalues. Note that each eigenvector is divided by the square root of its corresponding eigenvalue.

For more information about principal components, see *Multivariate Methods*.

---

**Statistical Details for Multivariate Control Charts**

This section contains statistical details for the Multivariate Control Chart platform.

- “Statistical Details for Individual Observations”
- “Statistical Details for Observations in Rational Subgroups”
- “Statistical Details for Change Point Detection”
Statistical Details for Individual Observations

You can use the Multivariate Control Chart platform to analyze individual observations, or measurements that are not sub-grouped. For these types of measurements, the natural subgroup size is \( n = 1 \). Denote the number of observations by \( m \) and the number of variables measured by \( p \). A \( T^2 \) statistic is calculated and plotted for each observation. The calculation of the \( T^2 \) statistic and upper control limit (UCL) depends on the source of the target statistics. In a Phase I chart, the limits are based on the same data that is being plotted on the control chart. In a Phase II chart, the limits are based on target statistics that were calculated from a historical data set. For more information about \( T^2 \) statistic and control limit calculations for Hotelling \( T^2 \) control charts, see Montgomery (2013).

Calculations for Phase I Control Charts

In Phase I control charts, the \( T^2 \) statistic for the \( i^{\text{th}} \) observation is defined as follows:

\[
T_i^2 = (Y_i - \bar{Y})S^{-1}(Y_i - \bar{Y})
\]

where:
- \( Y_i \) is the column vector of \( p \) measurements for the \( i^{\text{th}} \) observation
- \( \bar{Y} \) is the column vector of sample means of the \( p \) variables
- \( S^{-1} \) is the inverse of the sample covariance matrix

The \( T_i^2 \) value for each of the \( i \) observations are the points plotted on the multivariate control chart.

When computing Phase I control limits, the UCL is based on the beta distribution. Specifically, the upper control limit (UCL) is defined as follows:

\[
UCL = \left( \frac{m - 1}{m} \right)^2 \beta \left[ 1 - \alpha, \frac{p}{2}, \frac{m - p - 1}{2} \right]
\]

where:
- \( p \) = number of variables
- \( m \) = number of observations

\( \beta \left[ 1 - \alpha, \frac{p}{2}, \frac{m - p - 1}{2} \right] = (1-\alpha)^{\text{th}} \) quantile of a Beta \( \left( \frac{p}{2}, \frac{m - p - 1}{2} \right) \) distribution
Calculations for Phase II Control Charts

In Phase II control charts, define the historical data set as $X$. Then the $T^2$ statistic for the $i^{th}$ observation is defined as follows:

$$T_i^2 = (Y_i - \bar{X})' S_X^{-1} (Y_i - \bar{X})$$

where:
- $Y_i$ is the column vector of $p$ measurements for the $i^{th}$ observation
- $\bar{X}$ is the column vector of sample means of the $p$ variables, calculated from the historical data set
- $S_X^{-1}$ is the inverse of the sample covariance matrix, calculated from the historical data set

The $T_i^2$ value for each of the $i$ observations are the points plotted on the multivariate control chart.

When computing Phase II control limits, new observations are independent of the historical data set. In this case, the upper control limit (UCL) is a function of the $F$ distribution and partially depends on the number of observations in the historical data set from which the targets are calculated. The UCL is defined as follows:

$$UCL = \begin{cases} \frac{p(m+1)(m-1)}{m(m-p)} F_{1-\alpha, p, m-p} & \text{if } m \leq 100 \\ \frac{p(m-1)}{m-p} F_{1-\alpha, p, m-p} & \text{if } m > 100 \end{cases}$$

where:
- $p = \text{number of variables}$
- $m = \text{number of observations in the historical data set}$
- $F_{1-\alpha, p, m-p} = (1-\alpha)^{th} \text{ quantile of an } F(p, m-p) \text{ distribution}$
Statistical Details for Observations in Rational Subgroups

You can use the Multivariate Control Chart platform to analyze observations that are sub-grouped. Consider the case where $p$ variables are monitored and $m$ subgroups of size $n > 1$ are obtained. A $T^2$ statistic is calculated and plotted for each subgroup. The calculation of the $T^2$ statistic and upper control limit (UCL) depends on the source of the target statistics. In a Phase I chart, the limits are based on the same data that is being plotted on the control chart. In a Phase II chart, the limits are based on target statistics that were calculated from a historical data set. For more information about $T^2$ statistic and control limit calculations for Hotelling $T^2$ control charts, see Montgomery (2013).

Calculations for Phase I Control Charts

For Phase I control charts, the $T^2$ statistic for the $j^{th}$ subgroup is defined as follows:

$$T_j^2 = (\bar{Y}_j - \bar{Y})' S_p^{-1} (\bar{Y}_j - \bar{Y})$$

where:

- $\bar{Y}_j$ is the mean of the $n$ column vectors of $p$ measurements for the $j^{th}$ subgroup
- $\bar{Y} = \frac{1}{m} \sum_{j=1}^{m} \bar{Y}_j$ is the mean of the subgroup means
- $S_j$ is the sample covariance matrix for the $n$ observations in the $j^{th}$ subgroup
- $S_p = \frac{1}{m} \sum_{j=1}^{m} S_j$ is the pooled covariance matrix, calculated as the mean of the within-subgroup covariance matrices

The Phase I upper control limit (UCL) is defined as follows:

$$UCL = \frac{p(m-1)(n-1)}{mn-m-p+1} F_{1-p, mn-m-p+1}$$

where:

- $p =$ number of variables
- $n =$ sample size for each subgroup
- $m =$ number of subgroups
- $F_{1-p, mn-m-p+1} = (1-\alpha)^{th}$ quantile of an $F_{p, mn-m-p+1}$ distribution
Calculations for Phase II Control Charts

In Phase II control charts, define the historical data set from which the target statistics are calculated as $X$. Then the $T^2$ statistic for the $j^{th}$ subgroup is defined as follows:

$$T_j^2 = (\bar{Y}_j - \bar{X})'S_p^{-1}(\bar{Y}_j - \bar{X})$$

where:

- $\bar{Y}_j$ is the mean of the $n$ column vectors of $p$ measurements for the $j^{th}$ subgroup
- $\bar{X}_k$ is the mean of the $n$ column vectors of $p$ measurements for the $k^{th}$ subgroup from the historical data set
- $\bar{X} = \frac{1}{m} \sum_{k=1}^{m} \bar{X}_k$ is the overall mean of the observations
- $S_k$ is the sample covariance matrix for the $n$ observations in the $k^{th}$ subgroup from the historical data set
- $S_p = \frac{1}{m} \sum_{k=1}^{m} S_k$ is the pooled covariance matrix, calculated as the mean of the within-subgroup covariance matrices

The Phase II upper control limit (UCL) is defined as follows:

$$UCL = \frac{p(m + 1)(n - 1)}{mn - m - p + 1} F_{[1 - \alpha, p, mn - m - p + 1]}$$

where:

- $p$ = number of variables
- $n$ = subgroup sample size
- $m$ = number of subgroups in the historical data set
- $F_{[1 - \alpha, p, mn - m - p + 1]} = (1-\alpha)^{th}$ quantile of an $F(p, mn - m - p + 1)$ distribution
Additivity of Test Statistics for Observations in Rational Subgroups

When a sample of $mn$ independent normal observations is grouped into $m$ rational subgroups each of size $n$, define $T^2_M$ as the distance between the mean $\bar{Y}_j$ of the $j$th subgroup and the target value. ($T^2_M$ is equivalent to $T^2$ in the previous sections for observations in rational subgroups.) You can also calculate $T^2$ statistics related to the internal variability in each subgroup and the overall variability around the target value. The components of the $T^2$ statistic are additive, much like sums of squares. Specifically, the following relationship is true for each of the $m$ subgroups:

$$T^2_{A_j} = T^2_{M_j} + T^2_{D_j}$$

In all of the following definitions, $S_p$ is defined as it is in the previous sections, depending on whether the control chart is a Phase I or a Phase II control chart. Also, define $\mu$ as $\bar{Y}$ for Phase I control charts and as $\bar{X}$ for Phase II control charts.

The distance from the target value for the $j$th subgroup is defined as follows:

$$T^2_{M_j} = n(\bar{Y}_j - \mu)S_p^{-1}(\bar{Y}_j - \mu)$$

The internal variability for the $j$th subgroup is defined as follows:

$$T^2_{D_j} = \sum_{i=1}^{n}(Y_{ji} - \bar{Y}_j)S_p^{-1}(Y_{ji} - \bar{Y}_j)$$

where $Y_{ji}$ is the $i$th column vector of $p$ measurements for the $j$th subgroup.

The overall variability for the $j$th subgroup is defined as follows:

$$T^2_{A_j} = \sum_{i=1}^{n}(Y_{ji} - \mu)S_p^{-1}(Y_{ji} - \mu)$$

where $Y_{ji}$ is the $i$th column vector of $p$ measurements for the $j$th subgroup.

**Note:** When you select the **Save T Square** or **Save T Square Formula** options from the Multivariate Control Chart red triangle menu, the three values saved in each row correspond to one value of $i$ in the three definitions above.

### Statistical Details for Change Point Detection

This section contains details for the Change Point Detection option in the Multivariate Control Chart platform. This discussion follows the development in Sullivan and Woodall (2000).
Assumptions

Denote a multivariate distribution of dimension $p$ with mean vector $\mu_i$ and covariance matrix $\Sigma_i$ by $N_p(\mu_i, \Sigma_i)$. Suppose that the $x_i$ are $m$ (where $m > p$) independent observations from such a distribution:

$$x_i \sim N_p(\mu_i, \Sigma_i), \quad i = 1, \ldots, m$$

If the process is stable, the means $\mu_i$ and the covariance matrices $\Sigma_i$ equal a common value so that the $x_i$ have a $N_p(\mu, \Sigma)$ distribution.

Suppose that a single change occurs in either the mean vector or the covariance matrix, or both, between the $m_1$ and $m_1+1$ observations. Then the following conditions hold:

- Observations 1 through $m_1$ have the same mean vector and the same covariance matrix ($\mu_a, \Sigma_a$).
- Observations $m_1 + 1$ to $m$ have the same mean vector and covariance matrix ($\mu_b, \Sigma_b$).
- One of the following occurs:
  - If the change affects the mean, $\mu_a \neq \mu_b$.
  - If the change affects the covariance matrix, $\Sigma_a \neq \Sigma_b$.
  - If the change affects both the mean and the covariance matrix, $\mu_a \neq \mu_b$ and $\Sigma_a \neq \Sigma_b$.

Overview

A likelihood ratio test approach is used to identify changes in one or both of the mean vector and covariance matrix. The likelihood ratio test statistic is used to compute a control chart statistic that has an approximate upper control limit of 1. The control chart statistic is plotted for all possible $m_1$ values. If any observation’s control chart statistic exceeds the upper control limit of 1, this is an indication that a shift occurred. Assuming that exactly one shift occurs, that shift is considered to begin immediately after the observation with the maximum control chart statistic value.

Likelihood Ratio Test Statistic

The maximum value of twice the log-likelihood function for the first $m_1$ observations is defined as follows:

$$l_1 = -m_1 k_1 \log(2\pi) - m_1 \log \left|[S_1]_{k_1}\right| - m_1 k_1$$

The equation for $l_1$ uses the following notation:

- $S_1$ is the maximum likelihood estimate of the covariance matrix for the first $m_1$ observations.
• $k_1 = \text{Min}[p,m_1-1]$ is the rank of the $p \times p$ matrix $S_1$.

• The notation $\left|S_1\right|_{k_1}$ denotes the generalized determinant of the matrix $S_1$, which is defined as the product of its $k_1$ positive eigenvalues $\lambda_j$:

$$\left|S_1\right|_{k_1} = \prod_{j=1}^{k_1} \lambda_j$$

The generalized determinant is equal to the ordinary determinant when $S_1$ has full rank.

Denote the maximum of twice the log-likelihood function for the subsequent $m_2 = m - m_1$ observations by $l_2$ and the maximum of twice the log-likelihood function for all $m$ observations by $l_0$. Both $l_2$ and $l_0$ are given by expressions similar to that given for $l_1$.

The likelihood ratio test statistic compares the sum $l_1 + l_2$ to $l_0$. The sum $l_1 + l_2$ is twice the log-likelihood that assumes a possible shift at $m_1$. The value $l_0$ is twice the log-likelihood that assumes no shift. If $l_0$ is substantially smaller than $l_1 + l_2$, the process is assumed to be unstable.

The likelihood ratio test statistic for a test of whether a change begins at observation $m_1 + 1$ is defined as follows:

$$\text{lrt}[m_1] = (l_1 + l_2 - l_0)$$

$$= (m_1(p - k_1) + m_2(p - k_2))(1 + \log(2\pi))$$

$$+ m \log(|S|) - m_1 \log\left[\left|S_1\right|_{k_1}\right] - m_2 \log\left[\left|S_2\right|_{k_2}\right]$$

The distribution of the likelihood ratio test statistic is asymptotically chi-square distributed with $p(p + 3)/2$ degrees of freedom. Large log-likelihood ratio values indicate that the process is unstable.

### The Control Chart Statistic

Simulations indicate that the expected value of lrt$[m_1]$ varies based on the observation’s location in the series, and, in particular, depends on $p$ and $m$. See Sullivan and Woodall (2000).

Approximating formulas for the expected value of lrt$[m_1]$ are derived by simulation. To reduce the dependence of the expected value on $p$, lrt$[m_1]$ is divided by its asymptotic expected value, $p(p + 3)/2$. 


The formulas for the approximated expected value of $\text{lrt}[m_1]$ divided by $p(p+3)/2$ are defined as follows:

$$
\text{ev}[m,p,m_1] = \begin{cases} 
  a_p + m_1 b_p & \text{if } m_1 < p + 1 \\
  a_p + (m - m_1) b_p & \text{if } m - m_1 < p + 1 \\
  1 + \frac{m - 2p - 1}{(m_1 - p)(m - p - m_1)} & \text{otherwise}
\end{cases}
$$

where

$$
a_p = \frac{0.08684(p - 14.69)(p - 2.036)}{(p - 2)}
$$

and

$$
b_p = \frac{0.1228(p - 1.839)}{(p - 2)}
$$

For $p = 2$, the value of $\text{ev}[m,p,m_1]$ when $m_1$ or $m_2 = 2$ is 1.3505.

**Note:** The formulas above are not accurate for $p > 12$ or $m < (2p + 4)$. In such cases, simulation should be used to obtain approximate expected values.

An approximate upper control limit that yields a false out-of-control signal with probability approximately 0.05, assuming that the process is stable, is calculated as follows:

$$
\text{UCL}[m,p] \equiv (3.338 - 2.115 \log[p] + 0.8819(\log[p])^2 - 0.1382(\log[p])^3) 
+ (0.6389 - 0.3518 \log[p] + 0.01784(\log[p])^3) \log[m].
$$

Note that this formula depends on $m$ and $p$.

The control chart statistic is defined to be twice the log of the likelihood ratio test statistic divided by $p(p + 3)$, divided by its approximate expected value, and also divided by the approximate value of the control limit. Because of the division by the approximate value of the UCL, the control chart statistic can be plotted against an upper control limit of 1. The approximate control chart statistic is calculated as follows:

$$
\hat{y}[m_1] = \frac{2\text{lrt}[m_1]}{p(p + 3)(\text{ev}[m,p,m_1]UCL[m,p])}
$$
Model-driven multivariate control charts are used to monitor parameters for multiple processes in a single control chart. The Model Driven Multivariate Control Chart (MDMVCC) platform enables you to build a control chart based on principal components or partial least squares models. For a set of continuous variables, the MDMVCC platform uses principal components to build the control chart. For saved principal components or partial least squares score functions, the MDMVCC platform builds a control chart based on the provided models. Use the MDMVCC platform to interactively explore and understand the underlying components that lead to out-of-control signals.

**Figure 13.1** Model-driven Multiple Control Chart
Contents

Overview of Model Driven Multivariate Control Charts .................................................. 359
Example of Model Driven Multivariate Control Charts .................................................. 359
Launch the Model Driven Multivariate Control Chart Platform ...................................... 362
  Data Format .................................................................................................................. 363
The Model Driven Multivariate Control Chart Report .................................................... 364
Model Driven Multivariate Control Chart Platform Options ........................................... 364
  Plot Options ............................................................................................................... 366
  Score Plot .................................................................................................................. 367
Additional Examples of the Model Driven Multivariate Control Chart Platform .............. 368
  Example of a Model Driven Multivariate Control Chart with Historical Data ............. 368
  Example of a Model Driven Multivariate Control Chart with a PLS Model ............... 369
Statistical Details for the Model Driven Multivariate Control Chart Platform ................. 371
  Statistical Details for Monitoring Statistics ............................................................... 372
  Statistical Details for Limits ....................................................................................... 373
  Statistical Details for Contributions ........................................................................... 376
  Statistical Details for Score Plot Group Comparisons ............................................... 378
  Statistical Details for Score Plot Loadings ............................................................... 379
Overview of Model Driven Multivariate Control Charts

The Model Driven Multivariate Control Chart (MDMVCC) platform has two primary functions: monitoring and diagnosing.

- Use multivariate control charts to monitor a multivariate process.
- You can interactively drill down to investigate the contributions of individual variables to the overall signal to diagnosis the process.

For more information about multivariate control charts, see Kourti and MacGregor (1996).

You can construct a model driven multivariate control chart using current or historical data. A control chart is considered to be a Phase I chart if it is constructed using current data; a control chart is considered to be a Phase II chart if it is constructed using target statistics from a historical data set. In a Phase I chart, you check that the process is stable and establish a historical data set from which to calculate target statistics for the process. In a Phase II chart, the control chart uses the target statistics from Phase I in order to monitor new process observations.

To construct a Phase II model driven multivariate control chart, first identify a period of time during which the process is stable and capable. Then, perform the following steps:

1. Develop a Phase I control chart to verify that the process is stable over this period. The data used in Phase I provides a historical data set.
2. Save the target statistics for this historical data set.
3. Monitor the on-going process using the Phase II control chart.

See “Example of a Model Driven Multivariate Control Chart with Historical Data”.

Example of Model Driven Multivariate Control Charts

In this example, you build a multivariate control chart for the historical values of six process variables in a steam turbine system.

1. Select Help > Sample Data Folder and open Quality Control/Steam Turbine Historical.jmp.
2. Select Analyze > Quality and Process > Model Driven Multivariate Control Chart.
3. Select all six columns, click Process, and click OK.
Note that the process shifts after sample 16.

4. Select the sample 17 data point. Right-click and select **Rows > Row Label**.
5. Hover over the sample 17 data point to view the $T^2$ contribution proportion plot for that point. Click on the plot to open the plot in the report window.
Note that Cool Temp contributes 40% of the $T^2$ value. The Cool Temp bar is green indicating that sample 17 is within the univariate control limits for Cool Temp. Steam Flow and MW each contribute about 20% of the $T^2$ value. They are both red, which indicates that sample 17 is outside of the univariate control limits for each variable. Steam Temp has a zero contribution to the $T^2$ value. In this example, you found variables where the multivariate out-of-control sample could be traced to an out-of-control univariate variable. However, that is not always the case. In multivariate process control you may observe an out-of-control point on the $T^2$ chart but find that the sample is in-control at the univariate level for all variables.

6. Hover over the Steam Flow bar in the contribution proportion plot to see a univariate control chart for Steam Flow. Click on the chart to open in a new report window.

**Figure 13.4** Individual Chart for Steam Flow

The individual chart indicates that the steam flow might have experienced an upset around sample 17. When control limits are specified in the Controls Limits column property, the individual chart respects those limits.

7. In the PCA Model Driven Multivariate Control Chart report window, Click the $T^2$ for 3 Principal Components red triangle and select **Contribution Proportion Heat Map**.
Figure 13.5 Contribution Proportion Heat Map

The contribution proportion heat map shows that there is a shift in the contribution proportions for rows 16, 17, and 18 and again at row 23 as compared to other rows. Generally, Steam Temp, Cool Temp, and Pressure contribute the most to the $T^2$ value for each row.

Launch the Model Driven Multivariate Control Chart Platform

Launch the Model Driven Multivariate Control Chart (MDMVCC) platform by selecting Analyze > Quality and Process > Model Driven Multivariate Control Chart.

Figure 13.6 The Model Driven Multivariate Control Chart Launch Window
For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

The MDMVCC platform launch window contains the following options:

**Process**  Assigns the process columns. See “Data Format”.

**Time ID**  Assigns a column that is used to identify samples. If no Time ID is assigned, the row number identifies the observations. If the Time ID column is a time, the time identifies each sample. Otherwise, the numeric value of the Time ID identifies each sample.

**By**  Produces a separate report for each level of the By variable. If more than one By variable is assigned, a separate report is produced for each possible combination of the By variables.

**Historical Data End at Row**  Specifies a row number to indicate where historical data end. This enables you to calculate chart limits based on historical data. Both historical and current data are plotted on the charts. Historical data are also known as Phase I data, and current data are also known as Phase II data.

**Data Format**

The Model Driven Multivariate Control Chart (MDMVCC) platform accepts data in the following three allowable data formats:

**Raw Data**  Use continuous process data to build a control chart that is based on the principal components of the data. The default dimension of the control chart is based on the number of principal components that account for 85% of the process variation. This number is based on the cumulative percent of the principal component eigenvalues.

**Principal Components**  Use principal component columns that were previously saved from a principal component analysis (PCA). The default dimension of the control chart is the number of components specified as process variables.

**Partial Least Squares Score Data**  Use score columns that were previously saved from a partial least squares (PLS) analysis to build a control chart that is based on the score columns. The default dimension of the control chart is the number of scores specified as process variables.

**Notes:**

- PCA or PLS models built with a frequency or weight column are not supported.
- PCA or PLS models built with historical data must use the same number of historical data rows as specified in the MDMVCC launch window.
- PCA models built from within the Multivariate platform are not supported.
The Model Driven Multivariate Control Chart Report

The initial Model Driven Multivariate Control Chart (MDMVCC) Report shows a $T^2$ control chart. The hover labels on the chart are themselves charts. Click the hover label charts to open larger versions of the charts. Depending on the chart, they open in a separate report window or in the Diagnosis the Process section of the MDMVCC report. You can use the graphlets to interactively drill down into the data.

Figure 13.7 MDMVCC Report with a Hover Graphlet

Model Driven Multivariate Control Chart Platform Options

The PCA Model Driven Multivariate Control Chart red triangle menu contains the following options:

**Show History Summary Statistics**  Shows or hides summary statistics for rows designated as historical data or all rows if historical data rows are not specified. Summary statistics include univariate means and standard deviations for process variables. For PCA-based charts, the eigenvalues and eigenvectors are displayed. For charts based on PLS scores, the standard deviation of scores and the score loadings are displayed.

**Monitor the Process**  Contains the following options for monitoring the process.

**Show Monitoring Plots**  Shows or hides the selected process monitoring plots.
Set Component  Enables you to set the number of components for the $T^2$, DModX, or SPE plots. The number of components can range from one up to the number of valid eigenvectors for PCA driven analysis or from one up to the number of PLS model factors for PLS driven analysis.

Set $\alpha$ Level  Enables you to adjust the alpha level that is used for all control chart limits.

$T^2$ Plot  Shows or hides a $T^2$ plot. The $T^2$ statistic is a summary of multivariate variation that measures how far away an observation is from the center of a PCA or PLS model.

**Note:** When using local data filters with historical data, $T^2$ charts are only available for groups with historical data.

Normalized DModX Plot  Shows or hides a plot of the normalized DModX values. DModX measures the distance of each observation to the PCA or PLS model. A high DModX value indicates an observation that deviates from the underlying correlation structure of the data.

Squared Prediction Error Plot  Shows or hides the squared prediction error (SPE) plot. SPE measures the sum of squared of the residuals from the PCA or PLS model. A high SPE value indicates an observation that deviates from the underlying correlation structure of the data.

Score Plot  Shows or hides a score plot of principal components or partial least squares factors. See “Score Plot”.

Diagnose the Process  (Available when at least one diagnostic plot is active.) Shows or hides diagnostic plots.

Show Excluded Rows  Shows or hides excluded rows on plots (excluded rows shown by default). When this option is selected, excluded rows are displayed and included in the count of out of control points. However, excluded rows are excluded from numerical calculations. Rows that are both hidden and excluded in the data table remain hidden on MDMVCC plots regardless of the Show Excluded Rows setting.

**Note:** Control charts launched from MDMVCC show or hide excluded rows based on the Show Excluded Rows setting.

See *Using JMP* for more information about the following options:

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.
Platform Preferences  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Plot Options

In the Model Driven Multivariate Control Chart platform, the following options apply to the $T^2$, Normalized DModX, Squared Prediction Error, and Score Plots. The plots, when selected, appear in the Diagnosis the Process section of the report window.

Show Limit Summaries  (Not available for the Score Plot.) Shows or hides control chart limits and summary data in a report table below the chart.

Contribution Heat Map  Shows or hides a heat map that is colored by the variable contributions of each observation.

Contribution Proportion Heat Map  Shows or hides a heat map that is colored by the variable contributions expressed as proportions of the overall value of each observation.

Contribution Plot for Selected Samples  (Available only when one or more points are selected.) Shows or hides a bar chart of the individual component contributions to the overall value for each selected sample.

Contribution Proportion Plot for Selected Samples  (Available only when one or more points are selected.) Shows or hides a bar chart of the individual component contributions expressed as proportions of contribution of the overall value for each selected sample.

Mean Contribution Proportion Plot for Selected Samples  (Available only when two or more points are selected.) Shows or hides a bar chart of the average of the individual component contributions to the overall value for each selected sample.

**Note:** Bars are green if the value or mean value is within 3 sigma of the mean. Bars are red if the value or mean value is beyond 3 sigma of the mean. When control limits are specified in the Controls Limits column property, the bar coloring respects those limits.

The following options are available for contribution plots:

Sort Bars  Enables you to sort the bars from largest to smallest contribution or from largest to smallest average contribution for multiple plots.
Label Bars  Enables you to label the bars by the value, the column name, or to remove labels (No Label).

Control Charts for Selected Items  Shows a control chart for the selected columns. When control limits are specified in the Controls Limits column property, the individual chart respects those limits.

Scatterplot Matrix  (Available when two or more bars are selected.) Shows a scatterplot matrix for the selected variables.

Remove Plot  Removes the plot from the report window.

Normalized Score Plot for Selected Samples  (Available only for a Score Plot when one or more points are selected.) Shows or hides a bar chart of normalized scores for each sample selected.

Score Ellipse Coverage  (Available only for Score Plots with two components.) Adds an ellipse with the specified coverage to the score plot. The ellipse is based on historical data. When both Phase I and Phase II data are present, there is an ellipse for each phase and the Phase II ellipse is dashed.

Connect Points  (Available only for Score Plots.) Connects data points in the score plot.

Show Loadings  (Available only for Score Plots.) Shows the PCA loadings on the score plot using biplot arrows.

Save Columns  For each plot there are three options to save values to the data table:

   Save Values  Saves values ($T^2$, Normalized DModX, SPE, or scores) to a new data table column.

   Save Contributions  Saves contributions to new data table columns.

   Save Contribution Proportions  Saves contribution proportions to new data table columns.

Score Plot

In the Model Driven Multivariate Control Chart platform, the Score Plot displays a plot of principal components or partial least squares factors. Use the controls below the plot to change the components shown in the Score Plot.

Use the buttons to the right of the plot to assign and compare the relative contributions between two groups of points. Relative contributions show how two or more samples differ from each other. Relative contributions show what changes in the underlying process variables contribute to differences in groups of samples. One use is to investigate the differences between an in-control sample and an out-of-control sample.
Group A is the reference group and Group B the comparator group. Each group can consist of one or more points. To assign the reference group, select one or more points and then click Group A. To assign the comparator group, select one or more points and then click Group B. To display the Relative Score Contribution Plot, click Compare.

Figure 13.8  Score Plot with Relative Contribution Plot for Row 17 Relative to Row 24

Additional Examples of the Model Driven Multivariate Control Chart Platform

This section contains examples of the Model Driven Multivariate Control Chart platform.

- “Example of a Model Driven Multivariate Control Chart with Historical Data”
- “Example of a Model Driven Multivariate Control Chart with a PLS Model”

Example of a Model Driven Multivariate Control Chart with Historical Data

This example demonstrates the use of historical data to set the monitoring limits for current data.

1. Select Help > Sample Data Folder and open Quality Control/Flight Delays.jmp.
2. Select Analyze > Quality and Process > Model Driven Multivariate Control Chart.
3. Select the AA through WN and click Process.
4. Select Flight Date and click Time ID.
5. Enter 16 for Historical Data End at Row.
6. Click OK.
Figure 13.9 $T^2$ Chart for Historical and Current Data

Note that there are two sets of limits. One set applies to the historical data. A second set of limits applies to the current data. For more information about how the historical data is used to calculate the two sets of limits, see “Statistical Details for Limits”.

Tip: Turn on Automatic Recalc to enable the chart to automatically update as you add additional observations to the data table. The Automatic Recalc option is under redo when you click the PCA Model Driven Multivariate Control Chart red triangle.

Example of a Model Driven Multivariate Control Chart with a PLS Model

This example demonstrates the use of a PLS model for monitoring a multivariate process. Consider a process with 14 inputs and 5 quality variables. You have a PLS model that explains the process and you want to use this model to monitor the process for deviations.

1. Select Help > Sample Data Folder and open Polyethylene Process.jmp.

   This data table contains 14 process variables and 5 quality or output variables. The first 100 rows are historical data used to build a PLS model to describe the process. These rows are colored blue. The remaining 239 rows are data collected since the model was built.

   The partial least squares model finds 4 score functions that describe the process. These functions are saved to the data table in columns X Score 1 Formula to X Score 4 Formula. To build the PLS model, use the table script Set current data as excluded to exclude the 239 rows
of data collected after the historical data. Then use the *Fit Partial Least Squares* table script to build the PLS model to relate the quality variable to the process variables.

2. Select **Analyze > Quality and Process > Model Driven Multivariate Control Chart**.

3. Select the **X Score 1 Formula** through **X Score 4 Formula** and click **Process**.

4. Set the **Historical Data End at Row** to 100.

5. Click **OK**.

**Figure 13.10** $T^2$ Chart

The blue data points represent the historical data. The black data points are data points collected after the control chart was established. The process experienced an upset that begins around sample number 326.

6. Hover over the sample data points that are above the upper control limit to view contribution plots.

7. Select the first cluster of data points above the upper control limit. Click the $T^2$ for 4 Factors red triangle and select **Mean Contribution Proportion Plot for Selected Samples**.

8. Click the red triangle next to T2 Mean Contribution Proportion Plot for Selected Samples and select **Sort Bars**.
Figure 13.11 Mean Contribution Proportion Plot

Notice that the contributions plot is in terms of the PLS model input variables. It appears that \( z_2 \) and \( T_{max2} \) are causing the process upset. \( T_{max2} \) and \( z_2 \) are related. \( T_{max2} \) is a reactor temperature and \( z_2 \) is the location of the \( T_{max2} \) temperature.

**Note:** The descriptions of the factors are recorded in the Notes column property.

---

**Statistical Details for the Model Driven Multivariate Control Chart Platform**

This section contains statistical details for the Model Driven Multivariate Control Chart platform.

- “Statistical Details for Monitoring Statistics”
- “Statistical Details for Limits”
- “Statistical Details for Contributions”
- “Statistical Details for Score Plot Group Comparisons”
- “Statistical Details for Score Plot Loadings”
Statistical Details for Monitoring Statistics

This section contains computations for the monitoring statistics in the Model Driven Multivariate Control Chart platform.

$T^2$

The $T_i^2$ value for each of the $i$ observations is plotted on the $T^2$ control chart. For historical and current data, the $T^2$ values for a PCA or PLS model with $k$ components are defined as:

$$T_i^2 = t_i^T S_k^{-1} t_i$$

where:

- $t_i$ = the vector of $k$ scores for the $i^{th}$ observation
- $S_k$ = the diagonal sample covariance matrix of the $k$ scores for historical observations

For PCA models, $S_k$ is the diagonal eigenvalue matrix.

The mean of each of the $k$ historical score vectors is 0 when the data is centered during the data preprocessing step. This step occurs in PCA on correlations or covariances and in PLS with centering. For preprocessing options where $X$ is not centered, the data is assumed to have been centered by the user, so the mean of each of the $k$ score vectors is 0. For more information about Hotelling’s $T^2$, see Montgomery (2013).

$SPE$

For both PCA and PLS models, the preprocessed $X$ matrix can be decomposed as:

$$X = T_k P_k^T + E$$

where $T_k = (t_1, ..., t_k)$ is the $k$ dimensional score matrix and $P_k = (p_1, ..., p_k)$ is a matrix with the first $k$ eigenvectors for PCA models or the loading matrix for PLS models. The squared prediction error of this PCA or PLS model is used for the SPE control chart.

The $SPE_i$ value for each of the $i$ observations is plotted on the SPE control chart. The squared prediction error is defined as:

$$SPE_i = e_i^T e_i = \sum_{j=1}^{p} e_{ij}^2$$

where

- $e_i$ = the residual vector for observation $i$
- $p$ = number of variables
DModX

The $DModX_i$ value for each of the $i$ observations is plotted on the DModX control chart. The normalized distance to model (DModX) is defined as:

$$DModX_i = \frac{SPE_i / (df_1)}{\left(\sum_{i=1}^{n} SPE_i \right) / (df_2)} = \frac{1}{n} \sum_{i=1}^{p} e_{ij}^2 / (df_1)$$

where

- $e_{ij} = \text{the residual for observation } i \text{ and variable } j$
- $df_1 = p - k$
- $df_2 = (n - k - 1)(p - k)$ if the data is centered and $(n - k)(p - k)$ if the data is not centered
- $n = \text{number of historical data observations}$
- $k = \text{number of PCA/PLS components}$
- $p = \text{number of variables}$

**Note:** $DModX_i$ is equal to $SPE_i$ scaled by $1/d$.

**Statistical Details for Limits**

In the Model Driven Multivariate Control Chart platform, all data are treated as historical data when the number of historical rows is not specified in the launch window. See “Launch the Model Driven Multivariate Control Chart Platform”.

**$T^2$**

The upper control limit (UCL) for historical data is based on the Beta distribution and defined as:

$$UCL = \frac{(n-1)^2}{n} \beta \left[ 1 - \alpha; \frac{k}{2}; \frac{n - k - 1}{2} \right]$$

where:

- $n = \text{number of historical data observations}$
- $k = \text{number of PCA or PLS components}$
\[
\beta \left[ 1 - \alpha; \frac{k}{2}, \frac{n-k-1}{2} \right] = (1-\alpha)^{th} \text{ quantile of a Beta} \left[ \frac{k}{2}, \frac{n-k-1}{2} \right] \text{ distribution.}
\]

The UCL for current data is based on the \( F \) distribution and defined as:
\[
UCL = \frac{k(n+1)(n-1)}{n(n-k)} F[1 - \alpha; k; (n-k)]
\]

where:
- \( n \) = number of historical data observations
- \( k \) = number of PCA or PLS components
- \( F(1-\alpha; k; n-k) = (1-\alpha)^{th} \text{ quantile of an} \ F(k; n-k) \text{ distribution.} \)

**DModX**

For PCA and PLS models, the UCL is based on the \( F \) distribution. The DModX UCL for PCA models is defined as:
\[
UCL = F[1 - \alpha; df_1; df_2]
\]

where:
- \( df_1 = p-k \)
- \( df_2 = (n-k-1)(p-k) \) if the data is centered and \( (n-k)(p-k) \) if the data is not centered
- \( n \) = number of historical data observations
- \( k \) = number of PCA components
- \( p \) = number of variables
- \( F(1-\alpha; n-p-1; p-k) = (1-\alpha)^{th} \text{ quantile of a} \ F(n-p-1; p-k) \text{ distribution.} \)

The DModX UCL for PLS models is defined as:
\[
UCL = F[1 - \alpha; h; nh]
\]

where:
- \( h = (2\hat{\mu}_{SPE}^2)/(\hat{\sigma}_{SPE}^2) \)
- \( \hat{\mu}_{SPE} \) = historical sample mean of SPE
- \( \hat{\sigma}_{SPE}^2 \) = historical sample variance of SPE
- \( n \) = number of historical data observations
- \( F(1-\alpha; h; nh) = (1-\alpha)^{th} \text{ quantile of an} \ F(h; nh) \text{ distribution.} \)
**SPE**

The SPE UCL for PCA models is defined as:

\[
UCL = \theta_1 \left[ 1 - \frac{\theta_2 h_0 (1 - h_0)}{\theta_1^2} + \frac{z_{1-\alpha}(2\theta_2 h_0)^{1/2}}{\theta_1} \right]^{1/h_0}
\]

where:

\[ h_0 = 1 - 2 \theta_1 \theta_3 / (3 \theta_2) \]

\[ \theta_1 = \sum_{a=1}^{k} \lambda_a \]

\[ \theta_2 = \sum_{a=1}^{k} \lambda_a^2 \]

\[ \theta_3 = \sum_{a=1}^{k} \lambda_a^3 \]

\( \lambda_a \) = the \( a \)th eigenvalue

\( k \) = number of PCA components

\( z_{1-\alpha} = (1-\alpha) \) th quantile of the standard normal distribution

For more information about SPE control limits for PCA models, see Jackson and Mudholkar (1979).

For PLS models, the UCL is based on the chi-square distribution and defined as:

\[
UCL = g \chi^2_{[1 - \alpha; h]}
\]

where

\[ g = (\hat{\sigma}_{SPE}^2) / (2\hat{\mu}_{SPE}) \]

\[ h = (2\hat{\mu}_{SPE}^2) / (\hat{\sigma}_{SPE}^2) \]

\( \hat{\mu}_{SPE} \) = historical sample mean of SPE

\( \hat{\sigma}_{SPE}^2 \) = historical sample variance of SPE

\( \chi^2(1-\alpha; h) = (1-\alpha) \) th quantile of an \( \chi^2(h) \) distribution
The \(g\) and \(h\) parameters are estimated by the method of moments. For more information about SPE control limits for PLS models, see Nomikos (1995).

### Statistical Details for Contributions

This section contains computations for the contribution statistics in the Model Driven Multivariate Control Chart platform.

#### \(T^2\)

The \(T^2\) contributions for a PCA or PLS model with \(p\) variables and \(k\) components are calculated as:

\[
T_i = t_i \cdot S_k \cdot t_i^T = \sum_{a=1}^{k} \frac{t_{ia}^2}{s_a} = \sum_{a=1}^{k} \frac{t_{ia}}{s_a} \sum_{j=1}^{p} r_{ja} x_{ij} = \sum_{j=1}^{p} \left( \sum_{a=1}^{k} \frac{t_{ia} r_{ja} x_{ij}}{s_a} \right) = \sum_{j=1}^{p} \text{Cont}(T^2_i)_j
\]

where:

- \(t_i\) = the vector of \(k\) scores for the \(i^{th}\) observation
- \(S_k\) = the diagonal sample covariance matrix of the \(k\) scores for historical observations. For PCA models, \(S_k\) is the diagonal eigenvalue matrix.
- \(s_a\) = the \(a^{th}\) diagonal element of \(S_k\)
- \(r_{ja}\) = the \(j^{th}\) element of the \(a^{th}\) eigenvector for PCA models and the \(a^{th}\) column of the \(R_k\) loading matrix for PLS models. \(R_k\) is the matrix used to relate the score matrix, \(T_k\) to the \(X\) matrix, such that \(T_k = XR_k\).
- \(x_{ij}\) = the value of the \(j^{th}\) variable for the \(i^{th}\) observation.

**Note:** The \(p\) terms in the last sum are the variable contributions.
The contribution of each variable is the sum of its contribution to each score, weighted by the normalized score value. A variable is considered to have a large contribution to $T_i^2$ if there is a large normalized score value, and the variable contribution is large.

$$\sum_{j=1}^{p} Cont(T_i^2)_j = T_i^2$$

the contribution proportion of variable $j$ is defined as:

$$ContProp(T_i^2)_j = \frac{Cont(T_i^2)_j}{\sum_{j=1}^{p} Cont(T_i^2)_j}$$

**Note:** When computing $T_i^2$ contribution proportions, JMP zeros out negative contributions. Negative contributions are possible due to the interaction of variables during the projection of $X$ in PCA and PLS models. The negative contributions are zeroed in order to identify the variable contributions that represent a large proportion of the total positive contributions.

For more information about PCA contributions and negative contributions, see Kourti and MacGregor (1996). For more information about PLS contributions, see Li et al. (2009).

**DModX**

For PCA and PLS models, the contribution of variable $j$ to $DModX_i$ is defined as:

$$Cont(DModX_i)_j = \frac{e_{ij}}{\sqrt{d}}$$

Note that since

$$DModX_i = \sum_{j=1}^{p} \frac{e_{ij}^2}{d}$$

the contribution proportion of variable $j$ is defined as:

$$ContProp(DModX_i)_j = \frac{e_{ij}^2/d}{DModX_i}$$

**SPE**

For PCA and PLS models, the contribution of variable $j$ to $SPE_i$ is defined as:
Note that since the contribution proportion of variable $j$ is defined as:

$$\text{ContProp}(SPE_i)_j = \frac{e_{ij}^2}{SPE_i}$$

The score contribution computation is the same as $T^2$ contributions but are computed only for the dimensions selected in the score plot.

**Statistical Details for Score Plot Group Comparisons**

For the score plot group comparisons in the Model Driven Multivariate Control Chart platform, the relative score contribution for variable $j$ is the difference between the average contribution in group B and the average contribution in group A:

$$\sum_{i \in B} \frac{\text{Cont}(T^*_i)_j}{n_b} - \sum_{i \in A} \frac{\text{Cont}(T^*_i)_j}{n_a}$$

where

- $T^*_i$ = the $i^{th}$ row of the score matrix with columns corresponding to the dimensions shown in the score plot.
- $A$ = the set of observations in group A
- $B$ = the set of observations in group B
- $n_a$ = the number of observations in group A
- $n_b$ = the number of observations in group B.
Statistical Details for Score Plot Loadings

In the Model Driven Multivariate Control Chart platform, the loadings shown on the score plot are based on PCA eigenvectors or PLS X score loadings (R matrix). These loadings are scaled by the maximum absolute value of scores. The scaling is performed in order to graph the loadings on the score plot. The loadings illustrate each variable’s approximate influence on each score.
The legacy control chart platforms in JMP provide a variety of control charts, as well as runs charts, V-Mask CUSUM charts, and weighted moving average charts. To support process improvement initiatives, most of the control chart options display separate control charts for different phases of a project on the same chart.

A control chart is a graphical and analytic tool for monitoring process variation. The natural variation in a process can be quantified using a set of control limits. Control limits help distinguish common-cause variation from special-cause variation. Typically, action is taken to identify and eliminate special-cause variation. It is also important to quantify the common-cause variation in a process, as this determines the capability of a process.

**Figure 14.1  Control Chart Example**
Contents

Overview of Legacy Control Charts ......................................................... 383
Legacy Control Charts for Variables ....................................................... 383
Legacy Control Charts for Attributes ....................................................... 386
Example of a Legacy Control Chart ........................................................ 387
Launch a Legacy Control Chart Platform ................................................. 388
  Process Information ............................................................................. 389
  Limits Specifications .......................................................................... 392
  Specified Statistics ............................................................................ 393
Legacy Control Chart Reports ................................................................. 394
V-Mask CUSUM Chart Reports ................................................................. 396
  Interpret a Two-Sided V-Mask CUSUM Chart ..................................... 396
  Interpret a Legacy One-Sided CUSUM Chart ...................................... 397
Legacy Control Chart Platform Options .................................................. 398
  Window Options for Legacy Control Charts ....................................... 398
  Chart Options for Legacy Control Charts .......................................... 400
  Chart Options for V-Mask CUSUM Control Charts ............................ 403
Saving and Retrieving Limits ................................................................. 403
Excluded, Hidden, and Deleted Samples .................................................. 407
Additional Examples of Legacy Control Charts ....................................... 408
  Example of Presummarized Charts ..................................................... 408
  Example of a V-Mask CUSUM Chart ................................................. 410
  Example of a One-Sided CUSUM Chart ............................................ 412
  Example of a UWMA Chart ................................................................ 413
Statistical Details for Legacy Control Charts .......................................... 414
  Statistical Details for Median Moving Range Charts .......................... 414
  Statistical Details for Capability Analysis ......................................... 414
  Statistical Details for V-Mask CUSUM Control Charts ...................... 421
  Statistical Details for Weighted Moving Average Charts .................... 424
Overview of Legacy Control Charts

Legacy control charts are broadly classified into two categories:

- **“Legacy Control Charts for Variables”** — IR, XBar, Runs Chart, Levey-Jennings, Presummarize, CUSUM, UWMA, and EWMA.
- **“Legacy Control Charts for Attributes”** — P, NP, C, and U.

Legacy Control Charts for Variables

Control charts for variables are classified according to the subgroup summary statistic plotted on the chart:

- **The IR selection provides additional chart types:**
  - Individual Measurement charts display individual measurements. These charts are appropriate when only one measurement is available for each subgroup sample.
  - Moving Range charts display moving ranges of two or more successive measurements. See **“Moving Range (Average) Charts”**.
- **XBar charts display subgroup means (averages)**. This selection provides additional chart types:
  - R charts display subgroup ranges (maximum – minimum).
  - S charts display subgroup standard deviations.

For quality characteristics measured on a continuous scale, a typical analysis shows both the process mean and its variability with a mean chart aligned above its corresponding R or S chart.

- **Runs Chart displays data as a connected series of points**. Runs charts can also plot the group means when the Sample Label role is used, either on the window or through a script.

- **Levey-Jennings charts show a process mean with control limits based on a long-term sigma**. The control limits are placed at 3s distance from the center line. The standard deviation, s, for the Levey-Jennings chart is calculated the same way standard deviation is in the Distribution platform.

- **Presummarize charts display subgroup means and standard deviations**. See **“Presummarize Charts”**.

- **CUSUM charts show cumulative sums of subgroup or individual measurements from a target value**. See **“V-Mask CUSUM Control Charts”**.

- **UWMA charts show a uniformly weighted moving average of a specified number of measurements**. See **“Uniformly Weighted Moving Average Charts”**.
• EWMA charts show an exponentially weighted moving average of all measurements with a specified weight. See “Exponentially Weighted Moving Average Charts”.

Moving Range (Average) Charts

In a Moving Average chart, the quantities that are averaged can be individual observations instead of subgroup means. However, a Moving Average chart for individual measurements is not the same as a control chart for individual measurements or moving ranges with individual measurements plotted.

Moving Range (Average) charts display moving ranges of two or more successive measurements. Moving ranges are computed for the number of consecutive measurements that you enter in the Range Span box. The default range span is 2. Because moving ranges are correlated, these charts should be interpreted with care.

A Median Moving Range chart is also available. If you choose a Median Moving Range chart and an Individual Measurement chart, the limits on the Individual Measurement chart use the Median Moving Range as the sigma, rather than the Average Moving Range.

Presummarize Charts

If your data consist of repeated measurements of the same process unit, you can combine these into one measurement for the unit. Pre-summarizing is not recommended unless the data have repeated measurements on each process or measurement unit.

Presummarize summarizes the process column into sample means or standard deviations, based either on the sample size or sample label chosen. Then it charts the summarized data based on the options chosen in the launch window. You can also append a capability analysis by checking the appropriate box in the launch window.

The Presummarize launch window has the following options for chart types:

• Individual on Group Means
• Individual on Group Std Devs
• Moving Range on Group Means
• Moving Range on Group Std Devs
• Median Moving Range on Group Means
• Median Moving Range on Group Std Devs

There is also an option for setting the range span that is used for the moving range chart types.
V-Mask CUSUM Control Charts

V-Mask Cumulative Sum (CUSUM) control charts show cumulative sums of subgroup or individual measurements from a target value. V-Mask CUSUM charts can help you decide whether a process is in a state of statistical control by detecting small, sustained shifts in the process mean. In comparison, standard Shewhart control charts can detect sudden and large changes in measurement, such as a two or three sigma shift, but they are less effective at spotting smaller changes, such as a one sigma shift.

The CUSUM menu selection has options for V-mask cumulative sum charts. In addition to KSigma, you also specify:

- The vertical distance $h$ between the origin for the V-mask and the upper or lower arm of the V-mask for a two-sided chart. For a one-sided chart, $H$ is the decision interval. Choose $H$ as a multiple of the standard error.
- The reference value $k$, where $k$ is greater than zero.

Another form of a cumulative sum control chart is the tabular CUSUM chart. To create a tabular CUSUM chart, see “CUSUM Control Charts”. The tabular CUSUM chart is recommended over the V-mask chart for a variety of reasons, including the following:

- The V-mask must be moved with each observation, not simply placed on the last observation.
- The cumulative sums in the V-mask procedure can end up a long way from the center of the graph, even for an on-target process.

Caution: Montgomery (2013) strongly “advises against using the V-mask procedure.”

Uniformly Weighted Moving Average Charts

Each point on a Uniformly Weighted Moving Average (UWMA) chart is the average of the $w$ most recent subgroup means, including the present subgroup mean. When you obtain a new subgroup sample, the next moving average is computed by dropping the oldest of the previous $w$ subgroup means and including the newest subgroup mean. The constant, $w$, is called the span of the moving average.

In addition to KSigma and Alpha, in the UWMA launch window you also specify:

- The Moving Average Span, or $w$, which indicates how many subgroups to include to form the moving average. The larger the Moving Average Span ($w$), the smoother the UWMA line, and the less it reflects the magnitude of shifts. This means that larger values of $w$ guard against smaller shifts. See “Control Limits for UWMA Charts”.

Exponentially Weighted Moving Average Charts

Each point on an Exponentially Weighted Moving Average (EWMA) chart is the weighted average of all the previous subgroup means, including the mean of the present subgroup sample. The weights decrease exponentially going backward in time.

**Note:** An Exponentially Weighted Moving Average (EWMA) chart can also be called a Geometric Moving Average (GMA) chart.

In addition to KSigma and Alpha, in the EWMA launch window you also specify:

- A Weight parameter, which is the weight \(0 < \text{weight} \leq 1\) assigned to the present subgroup sample mean. Small values of Weight are used to guard against small shifts. See “Control Limits for EWMA Charts”.

**Tip:** See “EWMA Control Charts” for the newer EWMA Control Charts platform.

Legacy Control Charts for Attributes

Attribute charts are used for discrete count data because they are based on binomial and Poisson models. Count data occur when the variable of interest is a discrete count of something, such as the number of defects or blemishes per subgroup. This is in contrast with the previous types of charts, where measurement data consist of a process variable that is often continuous.

Because the counts are measured per subgroup, it is important when comparing charts to determine whether you have a similar number of items in the subgroups between the charts. Attribute charts, like variables charts, are classified according to the subgroup sample statistic plotted on the chart.

**Determining Which Attribute Chart to Use**

Each item is judged as either conforming or non-conforming:

- **p-chart** Shows the proportion of defective items.
- **np-chart** Shows the number of defective items.

The number of defects is counted for each item:

- **c-chart** Shows the number of defects.
- **u-chart** Shows the proportion of defects.
For attribute charts, specify the column containing the defect count or defective proportion as the Process variable. The data are interpreted as counts, unless the column contains non-integer values between 0 and 1.

- **P** charts display the proportion of nonconforming (defective) items in subgroup samples, which can vary in size. Since each subgroup for a P chart consists of \( N_i \) items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in a subgroup is \( N_i \).

- **NP** charts display the number of nonconforming (defective) items in subgroup samples. Because each subgroup for an NP chart consists of \( N_i \) items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in subgroup \( i \) is \( N_i \).

**Note:** To use the Sigma column property for P or NP charts, the value needs to be equal to the proportion. JMP calculates the sigma as a function of the proportion and the sample sizes.

- **C** charts display the number of nonconformities (defects) in a subgroup sample that usually, but does not necessarily, consists of one inspection unit.

**Caution:** For a C chart, if you do not specify a Sample Size or Constant Size, then the Sample Label is used as the sample size.

- **U** charts display the proportion of nonconformities (defects) in each subgroup sample that can have a varying number of inspection units.

**Caution:** For a U chart, if you do not specify a Unit Size or Constant Size, then the Sample Label is used as the unit size.

### Example of a Legacy Control Chart

In this example, create XBar and R charts that have a subgroup sample size of four.

1. Select **Help > Sample Data Folder** and open Quality Control/Coating.jmp.
2. Select **Analyze > Quality And Process > Legacy Control Charts > XBar**.
   
   Note the selected chart types of XBar and R.
3. Select Weight and click **Process**.
4. Select Sample and click **Sample Label**.
5. Click **OK**.
Figure 14.2 Variables Charts for Coating Data

An XBar chart and an R chart for the process are shown in Figure 14.2. Sample six indicates that the process is not in statistical control. To check the sample values, click the sample six summary point on either control chart. The corresponding rows highlight in the data table.

Note: If an S chart is chosen with the XBar chart, then the limits for the XBar chart are based on the standard deviation. Otherwise, the limits for the XBar chart are based on the range.

Launch a Legacy Control Chart Platform

When you launch a legacy control chart platform by selecting Analyze > Quality And Process > Legacy Control Charts, a launch window similar to Figure 14.3 appears. The specific controls vary depending on which type of chart you select. Initially, the window shows the following types of information:

- **“Process Information”** for measurement variable selection
- Chart type information (for more information, see “Overview of Legacy Control Charts”)
• “Limits Specifications”
• “Specified Statistics”

Figure 14.3 XBar Control Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using JMP.

Process Information

The launch window for a legacy control chart displays a list of columns in the current data table. Here, you specify the variables to be analyzed and the subgroup sample size.

Process

The Process role selects variables for charting:

• For variables charts, specify measurements as the process.
• For attribute charts, specify the defect count or defective proportion as the process. The data are interpreted as counts, unless it contains non-integer values between 0 and 1.

Note: The rows of the data table must be sorted in the order in which the observations were collected. Even if there is a Sample Label variable specified, you still must sort the observations accordingly.
**Sample Label**

The **Sample Label** role enables you to specify a variable whose values label the horizontal axis and can also identify unequal subgroup sizes. If you do not specify a sample label variable, the samples are identified by their subgroup sample number.

- If the sample subgroups are the same size, select the **Sample Size Constant** option and enter the size in the text box. If you entered a Sample Label variable, its values are used to label the horizontal axis. The sample size is used in the calculation of the limits regardless of whether the samples have missing values.

- If the sample subgroups have an unequal number of rows or have missing values and you have a column identifying each sample, select the **Sample Grouped by Sample Label** option and enter the sample identifying column as the sample label.

For attribute charts (P, NP, C, and U charts), this variable is the subgroup sample size. Additional options appear on the launch window, including **Sample Size**, **Constant Size**, or **Unit Size**, depending on your selection. In variables charts, it identifies the sample. When the chart type is IR, a **Range Span** text box appears. The range span specifies the number of consecutive measurements from which the moving ranges are computed.

**Notes:**

- The rows of the data table must be sorted in the order in which the observations were collected. Even if there is a **Sample Label** variable specified, you still must sort the observations accordingly.

- The non-integer part of the value for **Constant Size** is truncated. If you have a constant non-integer subgroup sample size, you must specify a column of constant values.
The illustration in Figure 14.4 shows an XBar chart for a process with unequal subgroup sample sizes, using the Coating.jmp sample data from the Quality Control sample data folder.

**Figure 14.4** Variables Charts with Unequal Subgroup Sample Sizes

**Phase**

The Phase role enables you to specify a column identifying different phases, or sections. A phase is a group of consecutive observations in the data table. For example, phases might correspond to time periods during which a new process is brought into production and then put through successive changes. Phases generate, for each level of the specified Phase variable, a new sigma, set of limits, zones, and resulting tests.

On the window for XBar, R, S, IR, P, NP, C, U, Presummarize, and Levey-Jennings charts, a Phase variable button appears. If a phase variable is specified, the phase variable is examined, row by row, to identify to which phase each row belongs. Saving to a limits file reveals the sigma and specific limits calculated for each phase.

**By**

The By role identifies a variable to produce a separate analysis for each value that appears in the column.
Limits Specifications

There are several ways to set limits specifications for legacy control charts. You can specify computations for control limits by entering a value for $k$ (K Sigma), or by entering a probability for $\alpha$ (Alpha), or by retrieving a limits value from the process columns’ properties or a previously created Limits Table. Limits Tables and the Get Limits button are discussed in the section “Saving and Retrieving Limits”. There must be a specification of either K Sigma or Alpha. The window default for K Sigma is 3.

K Sigma

The K Sigma parameter option enables specification of control limits in terms of a multiple of the sample standard error. K Sigma specifies control limits at $k$ sample standard errors above and below the expected value, which shows as the center line. To specify $k$, the number of sigmas, click the radio button for K Sigma and enter a positive $k$ value into the text box. The usual choice for $k$ is 3, which is three standard deviations. The examples shown in Figure 14.5 compare the XBar chart for the Coating.jmp data with control lines drawn with K Sigma = 3 and K Sigma = 4.

Figure 14.5  K Sigma =3 (left) and K Sigma=4 (right) Control Limits

Alpha

The Alpha parameter option specifies control limits (also called probability limits) in terms of the probability $\alpha$ that a single subgroup statistic exceeds its control limits, assuming that the process is in control. To specify alpha, click the Alpha radio button and enter the desired probability. Reasonable choices for $\alpha$ are 0.01 or 0.001. For XBar charts under the assumption of normality and known in-control parameters, the Alpha value equivalent to a K Sigma of 3 is 0.0027.
Specified Statistics

After specifying a process variable, if you click the Specify Stats (when available) button on a legacy control chart launch window, a tab with editable fields is appended to the bottom of the window. This lets you enter historical statistics (that is, statistics obtained from historical data) for the process variable. The Control Chart platform uses those entries to construct control charts. The example here shows 1 as the standard deviation of the process variable and 20 as the mean measurement.

Figure 14.6 Example of Specify Stats

Note: When the mean is user-specified, it is labeled in the plot as \( \mu_0 \).

If you check the Capability option on a Control Chart launch window (Figure 14.3), a window appears as the platform is launched asking for specification limits. The standard deviation for the control chart selected is sent to the window and appears as a Specified Sigma value, which is the default option. After entering the specification limits and clicking OK, capability output appears in the same window next to the control chart. For information about how the capability indices are computed, see “Statistical Details for Capability Indices for Normal Distributions”.
Legacy Control Chart Reports

The legacy control chart analysis produces a chart that can be used to determine whether a process is in a state of statistical control. The report varies depending on the type of chart that you select. Figure 14.7 displays the parts of a simple control chart. Control charts update dynamically as data is added or changed in the data table.

**Figure 14.7** Example of a Control Chart

![Control Chart Diagram]

**Note:** Any rows that are excluded in the data table prior to the creation of a Runs chart are hidden in the Runs chart.

Control charts have the following characteristics:

- Each point plotted on the chart represents an individual process measurement or summary statistic. In Figure 14.7, the points represent the average for a sample of measurements.
  
  Subgroups should be chosen *rationally*, that is, they should be chosen to maximize the probability of seeing a true process change *between* subgroups. Often, this requires knowledge of the process to determine the most effective grouping strategy. See Wheeler (2004); Woodall and Adams (1998).

- The vertical axis of a control chart is scaled in the same units as the summary statistic.

- The horizontal axis of a control chart identifies the subgroup samples and is time ordered. Observing the process over time is important in assessing if the process is changing.

- The green line is the center line, or the average of the data. The center line indicates the average (expected) value of the summary statistic when the process is in statistical control. Measurements should appear equally on both sides of the center line. If not, this is possible evidence that the process average is changing.

- The two red lines are the upper and lower control limits, labeled UCL and LCL. These limits give the range of variation to be expected in the summary statistic when the process is in statistical control. If the process is exhibiting only routine variation, then all the points...
should fall randomly in that range. In Figure 14.7, one measurement is above the upper control limit. This is evidence that the measurement could have been influenced by a special cause, or is possibly a defect.

- A point outside the control limits (or the V-mask of a CUSUM chart) signals the presence of a special cause of variation.

Options within each platform create control charts that can be updated dynamically as samples are received and recorded or added to the data table.

When a control chart signals abnormal variation, action should be taken to return the process to a state of statistical control if the process degraded. If the abnormal variation indicates an improvement in the process, the causes of the variation should be studied and implemented.

When you double-click the horizontal or vertical axis, the appropriate Axis Specification window appears for you to specify the format, axis values, number of ticks, gridline, reference lines, and other options to display on the axis.

For example, the Pickles.jmp data lists measurements taken each day for three days. In Figure 14.8, by default, the horizontal axis is labeled at every other tick. Sometimes this gives redundant labels, as shown to the left in Figure 14.8. If you specify a label at an increment of eight, the horizontal axis is labeled once for each day, as shown in the chart on the right.

**Figure 14.8** Example of Labeled x Axis Tick Marks

**Tip:** For information about warnings and rules, see “Tests” and “Westgard Rules”.
V-Mask CUSUM Chart Reports

This section describes how to interpret V-Mask CUSUM charts and legacy one-sided CUSUM charts.

- “Interpret a Two-Sided V-Mask CUSUM Chart”
- “Interpret a Legacy One-Sided CUSUM Chart”

Interpret a Two-Sided V-Mask CUSUM Chart

To interpret a two-sided CUSUM chart, compare the points with limits that compose a V-mask. A V-mask is a shape in the form of a V on its side that is superimposed on the graph of the cumulative sums. The V-mask is formed by plotting V-shaped limits. The origin of a V-mask is the most recently plotted point, and the arms extended backward on the horizontal axis, as in Figure 14.9. As data are collected, the cumulative sum sequence is updated and the origin is relocated at the newest point.

Note: See also “Example of a V-Mask CUSUM Chart”.

Figure 14.9 V-Mask for a Two-Sided CUSUM Chart
Shifts in the process mean are visually easy to detect on a CUSUM chart because they produce a change in the slope of the plotted points. The point where the slope changes is the point where the shift occurs. A condition is out-of-control if one or more of the points previously plotted crosses the upper or lower arm of the V-mask. Points crossing the lower arm signal an increasing process mean, and points crossing the upper arm signal a downward shift.

There are important differences between CUSUM charts and Shewhart charts:

- A Shewhart control chart plots points based on information from a single subgroup sample. In CUSUM charts, each point is based on information from all samples taken up to and including the current subgroup.
- On a Shewhart control chart, horizontal control limits define whether a point signals an out-of-control condition. On a CUSUM chart, the limits can be either in the form of a V-mask or a horizontal decision interval.
- The control limits on a Shewhart control chart are commonly specified as $3\sigma$ limits. On a CUSUM chart, the limits are determined from average run length.

A CUSUM chart is more efficient for detecting small shifts in the process mean. Lucas (1976) states that a V-mask detects a $1\sigma$ shift about four times as fast as a Shewhart control chart.

**Interpret a Legacy One-Sided CUSUM Chart**

Use a one-sided CUSUM chart to identify data approaching or exceeding the side of interest.

**Figure 14.10** Example of a One-Sided CUSUM Chart

The decision interval or horizontal line is set at the H value that you entered in the launch window. In this example, it is 0.25. Any values exceeding the decision interval of 0.25 indicate a shift or out-of-control condition. In this example, observation 4 appears to be where a shift occurred. Also note that no V-mask appears for one-sided CUSUM charts.
Legacy Control Chart Platform Options

Legacy control charts have red triangle menus that affect various parts of the platform:

- The menu on the top-most title bar affects the whole platform window. Its items vary with the type of chart that you select. See “Window Options for Legacy Control Charts”.
- There is a menu of items on the chart type title bar with options that affect each chart individually. See “Chart Options for Legacy Control Charts”.

Window Options for Legacy Control Charts

The red triangle menu on the window title bar lists options that affect the report window. If you request $XBar$ and $R$ at the same time, you can check each chart type to show or hide it. The specific options that are available depend on the type of control chart you request. Unavailable options show as grayed menu items.

**Show Limits Legend** Shows or hides the Avg, UCL, and LCL values to the right of the chart.

**Connect Through Missing** Connects points when some samples have missing values. In Figure 14.11, the left chart has no missing points. The middle chart has samples 2, 11, 19, and 27 missing with the points not connected. The right chart appears if you select the Connect Through Missing option, which is the default.

**Figure 14.11 Example of Connected through Missing Option**

<table>
<thead>
<tr>
<th>No missing points</th>
<th>Missing points are not connected</th>
<th>Missing points are connected</th>
</tr>
</thead>
</table>

**Use Median** For Runs Charts, when you select the Show Center Line option in the individual Runs Chart red triangle menu, a line is drawn through the center value of the column. The center line is determined by the Use Median setting of the main Runs Chart red triangle menu. When Use Median is selected, the median is used as the center line. Otherwise, the mean is used. When saving limits to a file, both the overall mean and median are saved.
**Capability** (Not available when a Phase variable is specified.) Performs a Capability Analysis for your data. A pop-up window is first shown, where you can enter the Lower Spec Limit, Target, and Upper Spec Limit values for the process variable.

![Figure 14.12 Capability Analysis Window](image)

An example of a capability analysis report is shown in Figure 14.13 for Coating.jmp when the Lower Spec Limit is set as 16.5, the Target is set to 21.5, and the Upper Spec Limit is set to 23.

![Figure 14.13 Capability Analysis Report for Coating.jmp](image)

For additional information, see “Statistical Details for Capability Analysis”.

**Save Sigma** Saves the computed value of sigma as a column property in the process variable column in the JMP data table.

**Save Limits** Saves the control limits in one of the following ways:
in **Column**  Saves control limits as a column property in the existing data table for the response variable. If the limits are constant, LCL, Avg, and UCL values for each chart type in the report are saved. This option is not available with phase charts. In addition, the option has no effect if the sample sizes are not constant for each chart.

in **New Table**  Saves the standard deviation and mean for each chart into a new data table. If the limits are constant, the LCL, Avg, and UCL for each chart are saved as well. If there are phases, a new set of values is saved for each phase. You can use this data table to use the limits later. In the Control Chart launch window, click **Get Limits** and then select the saved data table. See the section “**Saving and Retrieving Limits**”.

**Save Summaries**  Creates a new data table that contains the sample label, sample sizes, the statistic being plotted, the center line, and the control limits. The specific statistics included in the table depend on the type of chart.

**Alarm Script**  Enables you to write and run a script that indicates when the data fail special causes tests. Results can be written to the log or spoken. See “**Tests**” of this guide. See the **Scripting Guide** for more information about writing custom Alarm Scripts.

See **Using JMP** for more information about the following options:

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Platform Preferences**  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.

**Save By-Group Script**  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

## Chart Options for Legacy Control Charts

The red triangle menu of chart options appears when you click the icon next to the chart name. Some options are also available under **Chart Options** when you right-click the chart. Not all of the options below are available for all control chart types.

**Box Plots**  Superimposes box plots on the subgroup means plotted in a Mean chart. The box plot shows the subgroup maximum, minimum, 75th percentile, 25th percentile, and median. Markers for subgroup means show unless you deselect the **Show Points** option. The control limits displayed apply only to the subgroup mean. The **Box Plots** option is
available only for $\bar{X}$ charts. It is most appropriate for larger subgroup sample sizes (more than 10 samples in a subgroup).

**Needle**  Connects plotted points to the center line with a vertical line segment.

**Connect Points**  Shows or hides the line that connects the data points.

**Show Points**  Shows or hides the points representing summary statistics. Initially, the points show. You can use this option to suppress the markers denoting subgroup means when the **Box Plots** option is in effect.

**Connect Color**  Displays the JMP color palette for you to choose the color of the line segments used to connect points.

**Center Line Color**  Displays the JMP color palette for you to choose the color of the line segments used to draw the center line.

**Limits Color**  Displays the JMP color palette for you to choose the color of the line segments used in the upper and lower limits lines.

**Line Width**  Enables you to select the width of the control lines. Options are **Thin**, **Medium**, or **Thick**.

**Point Marker**  Enables you to select the marker used on the chart.

**Show Center Line**  Shows or hides the center line in the control chart.

**Show Control Limits**  Shows or hides the chart control limits and their legends.

**Limits Precision**  Sets the decimal limit for labels.

**Tests**  Shows a submenu that enables you to choose which tests to mark on the chart when the test is positive. Tests apply only for charts whose limits are $3\sigma$ limits. Tests 1 to 4 apply to Mean, Individual, and attribute charts. Tests 5 to 8 apply to Mean charts, Presummarize, and Individual Measurement charts only. If tests do not apply to a chart, the Tests option is dimmed. When sample sizes are unequal, the Test options are grayed out. If the samples change while the chart is open and they become equally sized, and the zone or test option is selected, the zones or tests are applied immediately and appear on the chart. These special tests are also referred to as the **Western Electric Rules**. For more information about special causes tests, see “Tests”.

**Westgard Rules**  Westgard rules are control rules that help you decide whether a process is in or out of control. The different tests are abbreviated with the decision rule for the particular test. See the text and chart in “Westgard Rules”.

**Test Beyond Limits**  Flags as a “$\star$” any point that is beyond the limits. This test works on all charts with limits, regardless of the sample size being constant, and regardless of the size
of $k$ or the width of the limits. For example, if you had unequal sample sizes, and wanted to flag any points beyond the limits of an R chart, you could use this command.

**Show Zones** Shows or hides the zone lines. The zones are labeled A, B, and C as shown here in the Mean plot for weight in the Coating.jmp sample data. Control Chart tests use the zone lines as boundaries. The seven zone lines are set one sigma apart, centered on the center line.

**Figure 14.14** Show Zones

![Show Zones](image)

**Shade Zones** Shows or hides the default green, yellow, and red colors for the three zone areas and the area outside the zones. Green represents the area one sigma from the center line, yellow represents the area two and three sigmas from the center line, and red represents the area beyond three sigmas. Shades can be shown with or without the zone lines.

**Tip:** To change the colors used to shade the zones, right-click in the control chart and select Customize. In the Customize Graph window, you can specify colors for each of the three zones.

**Figure 14.15** Shade Zones

![Shade Zones](image)
**OC Curve**  (Available when subgroup sizes are equal.) Opens a new window that contains the operating characteristic (OC) curve, using all the calculated values directly from the active control chart. See “Operating Characteristic Curves”.

**Chart Options for V-Mask CUSUM Control Charts**

The following options are specific to the legacy CUSUM control chart red triangle menu.

**Mask Color**  (Available only when the Show V Mask option is selected.) Enables you to select a line color for the V-mask.

**Show Shift**  Shows or hides the shift that you entered in the launch window.

**Show V Mask**  Shows or hides the V-mask based on the statistics that you specified in the CUSUM Control Charts launch window.

**Show Parameters**  Shows or hides a report that summarizes the CUSUM charting parameters.

**Show ARL**  Shows or hides the average run length (ARL) information. The average run length is the expected number of samples taken before an out-of-control condition is signaled:

- ARL (Delta), sometimes denoted ARL1, is the average run length for detecting a shift in the size of the specified Delta.
- ARL(0), sometimes denoted ARL0, is the in-control average run length for the specified parameters (Montgomery 2013).

**Saving and Retrieving Limits**

You can use the following previously established control limits for legacy control charts:

- upper and lower control limits and a center line value
- parameters for computing limits, such as a mean and standard deviation

The control limits or limit parameter values must be either in a JMP data table, referred to as the Limits Table, or stored as a column property in the process column. When you specify the Control Chart command, you can retrieve the Limits Table with the Get Limits button on the Control Chart launch window.

**Tip:** To add specification limits to several columns at once, see “Manage Limits”.
The easiest way to create a Limits Table is to save results computed by the Control Chart platform. The **Save Limits** command in the red triangle menu for each control chart automatically saves limits from the sample values. The type of data saved in the table varies according to the type of control chart in the analysis window. You can also use values from any source and create your own Limits Table.

All Limits Tables must have:

- A column of special keywords that identify each row.
- A column for each of the variables whose values are the known standard parameters or limits. This column name must be the same as the corresponding process variable name in the data table to be analyzed by the Control Chart platform.

The following table describes the limit keywords and their associated control chart for both legacy control charts and charts created with Control Chart Builder.

**Table 14.1** Limits Table Keys with Appropriate Charts and Meanings

<table>
<thead>
<tr>
<th>Keywords</th>
<th>For Charts</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>_KSigma</td>
<td>All except Control Chart Builder and V-Mask CUSUM</td>
<td>multiples of the standard deviation of the statistics to calculate the control limits; set to missing if the limits are in terms of the alpha level</td>
</tr>
<tr>
<td>_Alpha</td>
<td>All except Control Chart Builder</td>
<td>Type I error probability used to calculate the control limits</td>
</tr>
<tr>
<td>_Range Span</td>
<td>IM, MR, MMR</td>
<td>number of consecutive measurements for which moving ranges are computed. Not applicable in the Control Chart Builder platform, where the range span is always equal to 2.</td>
</tr>
<tr>
<td>_Sample Size</td>
<td>All except Levey-Jennings and Presummarize</td>
<td>subgroup size</td>
</tr>
<tr>
<td>_Std Dev</td>
<td>XBar, R, S, IM, MR, G, T, V-Mask CUSUM, and Levey-Jennings</td>
<td>known process standard deviation</td>
</tr>
<tr>
<td>_U</td>
<td>C, U</td>
<td>known average number of nonconformities per unit</td>
</tr>
</tbody>
</table>
Table 14.1 Limits Table Keys with Appropriate Charts and Meanings (Continued)

<table>
<thead>
<tr>
<th>Keywords</th>
<th>For Charts</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>_P</td>
<td>NP, P</td>
<td>known value of average proportion nonconforming</td>
</tr>
<tr>
<td>_LCL, _UCL</td>
<td>XBar, IM, P, NP, C, U, G, T, and Levey-Jennings</td>
<td>lower and upper control limit for Mean Chart, Individual Measurement chart, or any attribute or rare event chart</td>
</tr>
<tr>
<td>_AvgR</td>
<td>R, MR</td>
<td>average range or average moving range</td>
</tr>
<tr>
<td>_LCLR, _UCLR</td>
<td>R, MR</td>
<td>lower control limit for R or MR chart</td>
</tr>
<tr>
<td></td>
<td></td>
<td>upper control limit for R or MR chart</td>
</tr>
<tr>
<td>_AvgS, _LCLS, _UCLS</td>
<td>S Chart</td>
<td>average standard deviation, upper and lower control limits for S chart</td>
</tr>
<tr>
<td>_AvgR_PreMeans</td>
<td>IM, MR</td>
<td>Mean, upper, and lower control limits based on pre-summarized group means or standard deviations.</td>
</tr>
<tr>
<td>_AvgR_PreStdDev</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_LCLR_PreMeans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_LCLR_PreStdDev</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_UCLR_PreMeans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_UCLR_PreStdDev</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_Avg_PreMeans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_Avg_PreStdDev</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_LCL_PreMeans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_LCL_PreStdDev</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_UCL_PreMeans</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_UCL_PreStdDev</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_Data Units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_Two Sided</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_Headstart</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_Beta</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_Delta</td>
<td></td>
<td></td>
</tr>
<tr>
<td>_V-Mask CUSUM</td>
<td></td>
<td>specifications for V-Mask CUSUM chart</td>
</tr>
</tbody>
</table>
You can save limits in a new data table or as properties of the response column. When you save control limits using the in New Table command, the limit keywords written to the table depend on the current chart types displayed.

Figure 14.16 shows examples of control limits saved to a data table using Coating.jmp. The rows with values _Mean, _LCL, and _UCL are for the Individual Measurement chart. The values with the R suffix (_AvgR, _LCLR, and _UCLR) are for the Moving Range chart. If you create these charts again using this Limits Table, the Control Chart platform identifies the appropriate limits from keywords in the _LimitsKey column.

Figure 14.16  Example of Saving Limits in a Data Table

Note that values for _KSigma, _Alpha, and _Range Span can be specified in the Control Chart Launch window. JMP always looks at the values from the window first. Values specified in the window take precedence over those in an active Limits Table.

Rows with unknown keywords and rows marked with the excluded row state are ignored. Except for _Range Span, _KSigma, _Alpha, and _Sample Size, any needed values not specified are estimated from the data.
Excluded, Hidden, and Deleted Samples

The following table summarizes the effects of various conditions on samples and subgroups in legacy control charts:

**Table 14.2 Excluded, Hidden, and Deleted Samples**

<table>
<thead>
<tr>
<th>Condition 1</th>
<th>Condition 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>All rows of the sample are excluded before creating the chart.</td>
<td>Sample is not included in the calculation of the limits, but it appears on the graph.</td>
</tr>
<tr>
<td>Sample is excluded after creating the chart.</td>
<td>Sample is included in the calculation of the limits, and it appears in the graph. Nothing changes on the output by excluding a sample with the graph open.</td>
</tr>
<tr>
<td>Sample is hidden before creating the chart.</td>
<td>Sample is included in the calculation of the limits, but does not appear on the graph.</td>
</tr>
<tr>
<td>Sample is hidden after creating the chart.</td>
<td>Sample is included in the calculation of the limits, but does not appear on the graph. The sample marker disappears from the graph, the sample label still appears on the axis, but limits remain the same.</td>
</tr>
<tr>
<td>All rows of the sample are both excluded and hidden before creating the chart.</td>
<td>Sample is not included in the calculation of the limits, and it does not appear on the graph.</td>
</tr>
<tr>
<td>All rows of the sample are both excluded and hidden after creating the chart.</td>
<td>Sample is included in the calculation of the limits, but does not appear on the graph. The sample marker disappears from the graph, the sample label still appears on the axis, but limits remain the same.</td>
</tr>
<tr>
<td>Data set is subsetted with Sample deleted before creating chart.</td>
<td>Sample is not included in the calculation of the limits, the axis does not include a value for the sample, and the sample marker does not appear on the graph.</td>
</tr>
<tr>
<td>Data set is subsetted with Sample deleted after creating chart.</td>
<td>Sample is not included in the calculation of the limits, and does not appear on the graph. The sample marker disappears from the graph, the sample label is removed from the axis, the graph shifts, and the limits change.</td>
</tr>
</tbody>
</table>
Some additional notes:

- Hide and Exclude operate only on the row state of the first observation in the sample. For example, if the second observation in the sample is hidden, but the first observation is not hidden, the sample still appears on the chart.

  **Note:** Excluded rows in Presummarize charts are excluded from calculations, regardless of which position they are within a sample.

- An exception to the exclude/hide rule: Both hidden and excluded rows are included in the count of points for Tests for Special Causes. An excluded row can be labeled with a special cause flag. A hidden point cannot be labeled. If the flag for a Tests for Special Causes is on a hidden point, it will not appear in the chart.

- Because of the specific rules in place (Table 14.2), the control charts do not support the Automatic Recalc script.

---

**Additional Examples of Legacy Control Charts**

This section contains examples using legacy control charts.

- “Example of Presummarized Charts”
- “Example of a V-Mask CUSUM Chart”
- “Example of a One-Sided CUSUM Chart”
- “Example of a UWMA Chart”

**Example of Presummarized Charts**

This examples creates presummarized charts in two different ways using legacy control charts.

**Direct Presummarized Charts**

You can create presummarized charts directly by using the legacy Presummarize launch window.

1. Select **Help > Sample Data Folder** and open Quality Control/Coating.jmp.
2. Select **Analyze > Quality and Process > Legacy Control Charts > Presummarize**.
3. Select Weight and click **Process**.
4. Select Sample and click **Sample Label**.
5. Select both Individual on Group Means and Moving Range on Group Means. The Sample Grouped by Sample Label button is automatically selected when you choose a Sample Label variable.

When using Presummarize charts, you can select either the On Group Means option or the On Group Std Devs option or both. Each option creates two charts (an Individual Measurement, also known as an X chart, and a Moving Range chart) if both IR chart types are selected.

The On Group Means option computes each sample mean and then plots the means and creates an Individual Measurement and a Moving Range chart on the means.

The On Group Std Devs option computes each sample standard deviation and plots the standard deviations as individual points. Individual Measurement and Moving Range charts for the standard deviations then appear.

6. Click OK.

Figure 14.17 Example of Charting Presummarized Data

Although the points for XBar and S charts are the same as the Individual on Group Means and Individual on Group Std Devs charts, the limits are different because they are computed as Individual charts.
Indirect Presummarized Charts

You can also create presummarized charts indirectly by manually creating a summary table and then launching a legacy IR chart.

1. Choose **Tables > Summary**.
2. Select **Sample** and click **Group**.
3. Select **Weight**, and then click **Statistics > Mean** and **Statistics > Std Dev**.
4. Click **OK**.
5. Select **Analyze > Quality and Process > Legacy Control Charts > IR**.
6. Select **Mean(Weight)** and **Std Dev(Weight)** and click **Process**.
7. Click **OK**.

The resulting charts match the presummarized charts.

Example of a V-Mask CUSUM Chart

Use the legacy CUSUM option to create a V-Mask CUSUM control chart to analyze the filling process of 8-ounce cans of two-cycle engine oil additive by a machine. The filling process is believed to be in statistical control. The process is set so that the average weight of a filled can (\(\mu_0\)) is 8.10 ounces. Previous analysis shows that the standard deviation of fill weights (\(\sigma_0\)) is 0.05 ounces.

Subgroup samples of four cans are selected and weighed every hour for twelve hours. Each observation contains one value of weight and its associated value of hour. The observations are sorted so that the values of hour are in increasing order.

1. Select **Help > Sample Data Folder** and open Quality Control/Oil1 Cusum.jmp.
2. Select **Analyze > Quality And Process > Legacy Control Charts > CUSUM**.
3. Select **weight** and click **Process**.
4. Select **hour** and click **Sample Label**.
5. Select the **Two Sided** check box if it is not already checked.
6. In the Parameters area, click the **H** button and type 2.
7. Click **Specify Stats**.
8. Type 8.1 next to **Target**.
   
   8.1 is the average weight in ounces of a filled can. This is the target mean.
9. Type 1 next to **Delta**.
   
   1 is the absolute value of the smallest shift to be detected as a multiple of the process standard deviation or of the standard error.
10. Type 0.05 next to **Sigma**.

0.05 is the known standard deviation of fill weights ($\sigma_0$) in ounces.

**Figure 14.18** Completed Launch Window

---

11. Click **OK**.

**Figure 14.19** Two-Sided CUSUM Chart for Oil1 Cusum.jmp Data

You can interpret the chart by comparing the points with the V-mask. The right edge of the V-mask is centered at the most recent point (the 12th hour). Because none of the points cross the arms of the V-mask, there is no evidence that a shift in the process has occurred. See “V-Mask CUSUM Chart Reports”.
Example of a One-Sided CUSUM Chart

Use the legacy CUSUM option to create a one-sided CUSUM control chart to identify any instances of over-filling in a process where a machine fills 8-ounce cans of engine oil. Anything that is 0.25 ounces beyond the mean of 8.1 is considered a problem. In order to cut costs, the manufacturer is primarily concerned about significant over-filling and not so concerned about under-filling.

1. Select Help > Sample Data Folder and open Quality Control/Oil1 Cusum.jmp.
2. Select Analyze > Quality And Process > Legacy Control Charts > CUSUM.
3. Deselect Two Sided.
4. Select weight and click Process.
5. Select hour and click Sample Label.
6. Click H and type 0.25.
7. Click Specify Stats.
8. Type 8.1 next to Target.
   8.1 is the average weight in ounces of a filled can. This is the target mean.
9. Type 1 next to Delta.
   1 is the absolute value of the smallest shift to be detected as a multiple of the process standard deviation or of the standard error.
10. Type 0.05 next to Sigma.
   0.05 is the known standard deviation of fill weights (σ₀) in ounces.
11. Click OK.

Figure 14.20 One-Sided CUSUM Chart for Oil1 Cusum.jmp Data
The decision interval is set at the H value that you entered (0.25). You can see that at the fourth hour, some significant over-filling occurred.

**Example of a UWMA Chart**

In this example, a legacy UWMA control chart with a moving average span of three is examined. The measure of interest is the gap between the ends of manufactured metal clips. To monitor the process for a change in the average gap, subgroup samples of five clips are selected daily.

1. Select Help > Sample Data Folder and open Quality Control/Clips1.jmp.
2. Select Analyze > Quality and Process > Legacy Control Charts > UWMA.
4. Select Sample and click Sample Label.
5. Change the Moving Average Span to 3.
6. Click OK.

**Figure 14.21** UWMA Charts for the Clips1 data

The point for the first day is the mean of the five subgroup sample values for that day. The plotted point for the second day is the average of subgroup sample means for the first and second days. The points for the remaining days are the average of subsample means for each day and the two previous days.

The average clip gap appears to be decreasing, but no sample point falls outside the 3σ limits.
Statistical Details for Legacy Control Charts

This section contains statistical details for legacy control charts.

- “Statistical Details for Median Moving Range Charts”
- “Statistical Details for Capability Analysis”
- “Statistical Details for V-Mask CUSUM Control Charts”
- “Statistical Details for Weighted Moving Average Charts”

Note: For more information about other types of charts (such as XBar and R charts, P and NP charts, and more) see the “Statistical Details for Control Chart Builder”.

Statistical Details for Median Moving Range Charts

Control limits for legacy Median Moving Range charts are computed as follows:

\[ \text{LCL}_{MMR} = \max(0, \text{MMR} - k\sigma) \]
\[ \text{UCL}_{MMR} = \text{MMR} + k\sigma \]

where:

- MMR is the median of the nonmissing moving ranges.
- \( \hat{\sigma} = \text{MMR}/0.954 \)
- \( d_3(n) \) is the standard deviation of the range of \( n \) independent normally distributed variables with unit standard deviation.

Statistical Details for Capability Analysis

This section contains details about the computation of the statistics in the Capability Analysis report in legacy control charts.

Variation Statistics

All capability analyses use the same formulas. Options differ in how sigma (\( \sigma \)) is computed:

Long Term Sigma Uses the overall sigma. This option is used for \( P_{pk} \) statistics, and computes sigma as follows:
Chapter 14
Quality and Process Methods

Legacy Control Charts

Statistical Details for Legacy Control Charts

Note: By default, the capability indices in the Long Term Sigma report use the Cp labeling that is used in the other sigma reports. To use Ppk labeling in the Long Term Sigma report, select the File > Preferences > Platforms > Distribution > PpK Capability Labeling preference.

Control Chart Sigma

Uses a sigma that is determined by the control chart settings.

- If you specify a value for Sigma using the Specify Stats button in the control launch window, the specified value is used for computing capability indices.

- In an IR chart that uses the Moving Range (Average) option, the value for sigma is computed as follows:

\[ \hat{\sigma} = \frac{R}{d_2(n)} \]

where:

- \( R \) is the average of the moving ranges.
- \( d_2(n) \) is the expected value of the range of \( n \) independent normally distributed variables with unit standard deviation, where \( n \) is the value of the Range Span option.

- In an IR chart that uses the Median Moving Range option, the value for sigma is computed as follows:

\[ \hat{\sigma} = \frac{MMR}{d_4(n)} \]

where:

- MMR is the median of the nonmissing moving ranges.
- \( d_4(n) \) is the median of the range of \( n \) independent normally distributed variables with unit standard deviation, where \( n \) is the value of the Range Span option.

- In an XBar chart that uses the R option, the value for sigma is computed as follows:

\[ \hat{\sigma} = \frac{R_1/d_2(n_1) + \cdots + R_N/d_2(n_N)}{N} \]

where:

- \( R_i \) = range of \( i^{th} \) subgroup
\[ n_i = \text{sample size of } i^{th} \text{ subgroup} \]
\[ d_2(n_i) = \text{expected value of the range of } n_i \text{ independent normally distributed variables with unit standard deviation} \]
\[ N = \text{number of subgroups for which } n_i \geq 2 \]

- In an XBar chart that uses the S option, the value for \( \sigma \) is computed as follows:

\[
\sigma = \frac{s_1}{c_4(n_1)} + \cdots + \frac{s_N}{c_4(n_N)} \quad \frac{N}{c_4(n_N)}
\]

where:
\[ n_i = \text{sample size of } i^{th} \text{ subgroup} \]
\[ c_4(n_i) = \text{expected value of the standard deviation of } n_i \text{ independent normally distributed variables with unit standard deviation} \]
\[ N = \text{number of subgroups for which } n_i \geq 2 \]
\[ s_i = \text{sample standard deviation of the } i^{th} \text{ subgroup} \]

**Capability Indices for Normal Distributions**

This section provides details about the calculation of capability indices for normal data.

For a process characteristic with mean \( \mu \) and standard deviation \( \sigma \), the population-based capability indices are defined as follows:

\[
C_p = \frac{USL - LSL}{6\sigma}
\]
\[
C_pl = \frac{\mu - LSL}{3\sigma}
\]
\[
Cpu = \frac{USL - \mu}{3\sigma}
\]
\[
Cpk = \min(C_pl, Cpu)
\]
\[
Cpm = \frac{\min(T - LSL, USL - T)}{3\sigma \sqrt{1 + \left(\frac{T - \mu}{\sigma}\right)^2}}
\]

where:

- \( LSL \) is the lower specification limit.
- \( USL \) is the upper specification limit.
Chapter 14
Legacy Control Charts

Quality and Process Methods
Statistical Details for Legacy Control Charts

$T$ is the target value.

For sample-based capability indices, the parameters are replaced by their estimates. The estimate for $\sigma$ uses the method that you specified in the Capability Analysis window. See “Variation Statistics”.

If either of the specification limits is missing, the capability indices containing the missing specification limit are reported as missing.

**Tip:** A capability index of 1.33 is often considered to be the minimum value that is acceptable. For a normal distribution, a capability index of 1.33 corresponds to an expected number of nonconforming units of about 6 per 100,000.

**Confidence Intervals for Capability Indices**

**Note:** Confidence intervals for capability indices appear only in the Long Term Sigma report.

The 100(1 - $\alpha$)% confidence interval for $C_p$ is calculated as follows:

$$
\left[ \hat{C}_p \left( \frac{2}{\chi_{\alpha/2, n-1}^2} \right), \hat{C}_p \left( \frac{2}{\chi_{1-\alpha/2, n-1}^2} \right) \right]
$$

where:

$\hat{C}_p$ is the estimated value for $C_p$.

$\chi_{\alpha/2, n-1}^2$ is the $(\alpha/2)^{th}$ quantile of a chi-square distribution with $n - 1$ degrees of freedom.

$n$ is the number of observations.

The 100(1 - $\alpha$)% confidence interval for $C_{pk}$ is calculated as follows:

$$
\left( \hat{C}_{pk} \left[ 1 - \Phi^{-1} \left( 1 - \alpha/2 \right) \left( \frac{1}{9n \hat{C}_{pk}^2} + \frac{1}{2(n-1)} \right) \right], \hat{C}_{pk} \left[ 1 + \Phi^{-1} \left( 1 - \alpha/2 \right) \left( \frac{1}{9n \hat{C}_{pk}^2} + \frac{1}{2(n-1)} \right) \right] \right)
$$

where:

$\hat{C}_{pk}$ is the estimated value for $C_{pk}$.

$\Phi^{-1}(1 - \alpha/2)$ is the $(1 - \alpha/2)^{th}$ quantile of a standard normal distribution.

$n$ is the number of observations.
The 100(1 - \(\alpha\))% confidence interval for CPM is calculated as follows:

\[
\left( \hat{CPM} \frac{\chi_{\alpha/2, \gamma}^2}{\gamma}, \hat{CPM} \frac{\chi_{1 - \alpha/2, \gamma}^2}{\gamma} \right)
\]

where:

\(\hat{CPM}\) is the estimated value for CPM.

\(\chi_{\alpha/2, \gamma}^2\) is the \((\alpha/2)\)th quantile of a chi-square distribution with \(\gamma\) degrees of freedom.

\[
\gamma = \frac{n \left(1 + \left(\frac{\bar{x} - T}{s}\right)^2\right)}{1 + 2 \left(\frac{\bar{x} - T}{s}\right)^2}
\]

\(n\) is the number of observations.
\(\bar{x}\) is the mean of the observations.
\(T\) is the target value.
\(s\) is the long-term sigma estimate.

**Note:** The confidence interval for CPM is computed only when the target value is centered between the lower and upper specification limits.

Lower and upper confidence limits for CPL and CPU are computed using the method of Chou et al. (1990).

The 100(1 - \(\alpha\))% confidence limits for CPL (denoted by CPL\(_L\) and CPL\(_U\)) satisfy the following equations:

\[
\Pr[t_{n-1}(\delta_L) \geq 3 \hat{C}_{\text{pl}} \sqrt{n}] = \alpha/2 \quad \text{where} \quad \delta_L = 3\text{CPL}_L \sqrt{n}
\]

\[
\Pr[t_{n-1}(\delta_U) \leq 3 \hat{C}_{\text{pl}} \sqrt{n}] = \alpha/2 \quad \text{where} \quad \delta_U = 3\text{CPL}_U \sqrt{n}
\]

where:

\(t_{n-1}(\delta)\) has a non-central \(t\)-distribution with \(n - 1\) degrees of freedom and noncentrality parameter \(\delta\).

\(\hat{C}_{\text{pl}}\) is the estimated value for Cpl.
The 100(1 - \( \alpha \))% confidence limits for CPU (denoted by CPU\(_L\) and CPU\(_U\)) satisfy the following equations:

\[
\text{Pr}\left[t_{n-1}(\delta_L) \geq 3\hat{C}_p \sqrt{n}\right] = \frac{\alpha}{2} \quad \text{where} \quad \delta_L = 3\text{CPU}_L \sqrt{n}
\]

\[
\text{Pr}\left[t_{n-1}(\delta_U) \leq 3\hat{C}_p \sqrt{n}\right] = \frac{\alpha}{2} \quad \text{where} \quad \delta_U = 3\text{CPU}_U \sqrt{n}
\]

where:

\( t_{n-1}(\delta) \) has a non-central \( t \)-distribution with \( n - 1 \) degrees of freedom and noncentrality parameter \( \delta \).

\( \hat{C}_p \) is the estimated value for \( \text{Cpu} \).

### Capability Indices for Nonnormal Distributions

This section describes how capability indices are calculated for nonnormal distributions. These generalized capability indices are defined as follows:

\[
\text{Cp} = \frac{\text{USL} - \text{LSL}}{P_{0.99865} - P_{0.00135}}
\]

\[
\text{Cpk} = \min(C_{pl}, C_{pu})
\]

\[
\text{Cpm} = \frac{\min\left(\frac{T - \text{LSL}}{P_{0.5} - P_{0.00135}}, \frac{\text{USL} - T}{P_{0.99865} - P_{0.5}}\right)}{\sqrt{1 + \left(\frac{\mu - T}{\sigma}\right)^2}}
\]

\[
\text{Cpl} = \frac{P_{0.5} - \text{LSL}}{P_{0.5} - P_{0.00135}}
\]

\[
\text{Cpu} = \frac{\text{USL} - P_{0.5}}{P_{0.99865} - P_{0.5}}
\]

where:

\( \text{LSL} \) is the lower specification limit.
\( \text{USL} \) is the upper specification limit.
\( T \) is the target value.
\( P_{\alpha} \) is the \( \alpha \times 100^{\text{th}} \) percentile of the fitted distribution.
For the calculation of Cpm, μ and σ are estimated using the expected value and square root of the variance of the fitted distribution. For more information about the relationship between the parameters in the Parameter Estimates report and the expected value and variance of the fitted distributions, see Basic Analysis.

Sigma Quality Statistics

The Sigma Quality statistics for each Portion (Below LSL, Above USL, and Total Outside) are calculated as follows:

\[
\text{Sigma Quality} = \Phi^{-1}_{1 - \text{Pct}/100} + 1.5
\]

where:

- Pct is the value in the Percent column of the report.
- \(\Phi^{-1}_{1 - \text{Pct}/100}\) is the \((1 - \text{Pct}/100)^{\text{th}}\) quantile of a standard normal distribution.

**Note:** Even though the Percent Below LSL and Percent Above USL sum to the Percent Total Outside value, the Sigma Quality Below LSL and Sigma Quality Above USL values do not sum to the Sigma Quality Total Outside value. This is because calculating Sigma Quality involves finding normal distribution quantiles, and is therefore not additive.

Benchmark Z Statistics

Benchmark Z statistics are available only for capability analyses based on the normal distribution. The Benchmark Z statistics are calculated as follows:

\[
Z_{\text{Bench}} = \Phi^{-1}_{1 - P(LSL) - P(USL)}
\]

\[
Z_{\text{LSL}} = \frac{\bar{X} - LSL}{\sigma} = 3 \times Cpl
\]

\[
Z_{\text{USL}} = \frac{USL - \bar{X}}{\sigma} = 3 \times Cpu
\]

where:

- LSL is the lower specification limit.
- USL is the upper specification limit.
- \(\bar{X}\) is the sample mean.
- \(\sigma\) is the sample standard deviation.
- \(\Phi^{-1}_{1 - P(LSL) - P(USL)}\) is the \((1 - P(LSL) - P(USL))^{\text{th}}\) quantile of a standard normal distribution.
- \(P(LSL) = \text{Prob}(X < LSL) = 1 - \Phi(Z_{\text{LSL}})\).
\[ P(USL) = \text{Prob}(X > USL) = 1 - \Phi(Z_{USL}). \]
\[ \Phi \] is the standard normal cumulative distribution function.

**Statistical Details for V-Mask CUSUM Control Charts**

The following notation is used in these formulas:

- \( \mu \) denotes the mean of the population, also referred to as the process mean or the process level.
- \( \mu_0 \) denotes the target mean (or goal) for the population. Sometimes, the symbol \( \bar{X}_0 \) is used for \( \mu_0 \). See the American Society for Quality Statistics Division (2004). You can provide \( \mu_0 \) as the Target in the Known Statistics for CUSUM Chart area on the launch window.
- \( \sigma \) denotes the population standard deviation. \( \hat{\sigma} \) denotes an estimate of \( \sigma \).
- \( \sigma_0 \) denotes a known standard deviation. You can provide \( \sigma_0 \) as the Sigma in the Known Statistics for CUSUM Chart area on the launch window.
- \( n \) denotes the nominal sample size for the CUSUM chart.
- \( \delta \) denotes the shift in \( \mu \) to be detected, expressed as a multiple of the standard deviation. You can provide \( \delta \) as the Delta in the Known Statistics for CUSUM Chart area on the launch window.
- \( \Delta \) denotes the shift in \( \mu \) to be detected, expressed in data units. If the sample size \( n \) is constant across subgroups, then the following computation applies:

\[
\Delta = \delta \sigma \bar{X} = (\delta \sigma) / \sqrt{n}
\]

You can provide \( \Delta \) as the Shift in the Known Statistics for CUSUM Chart area on the launch window.

**Note:** Some authors use the symbol D instead of \( \Delta \).

**One-Sided CUSUM Charts**

**Positive Shifts**

If the shift \( \delta \) to be detected is positive, the CUSUM for the \( t^{th} \) subgroup is computed as follows:

\[ S_t = \max(0, S_{t-1} + (z_t - k)) \]
\( t = 1, 2, \ldots, n \), where \( S_0 = 0 \), \( z_t \) is defined as for two-sided charts, and the parameter \( k \), termed the reference value, is positive. If the parameter \( k \) is not specified in the launch window, \( k \) is set to \( \delta/2 \). The CUSUM \( S_t \) is referred to as an upper cumulative sum. \( S_t \) can be computed as follows:

\[
\text{max} \left\{ 0, S_{t-1} + \frac{\bar{X}_t - (\mu_0 + k\sigma_{\bar{X}_t})}{\sigma_{\bar{X}_t}} \right\}
\]

The sequence \( S_t \) cumulates deviations in the subgroup means greater than \( k \) standard errors from \( \mu_0 \). If \( S_t \) exceeds a positive value \( h \) (referred to as the decision interval), a shift or out-of-control condition is signaled.

### Negative Shifts

If the shift to be detected is negative, the CUSUM for the \( t \)th subgroup is computed as follows:

\[
S_t = \text{max}(0, S_{t-1} - (z_t + k))
\]

\( t = 1, 2, \ldots, n \), where \( S_0 = 0 \), \( z_t \) is defined as for two-sided charts, and the parameter \( k \), termed the reference value, is positive. If the parameter \( k \) is not specified in the launch window, \( k \) is set to \( \delta/2 \). The CUSUM \( S_t \) is referred to as a lower cumulative sum. \( S_t \) can be computed as follows:

\[
\text{max} \left\{ 0, S_{t-1} - \frac{\bar{X}_t - (\mu_0 - k\sigma_{\bar{X}_t})}{\sigma_{\bar{X}_t}} \right\}
\]

The sequence \( S_t \) cumulates the absolute value of deviations in the subgroup means less than \( k \) standard errors from \( \mu_0 \). If \( S_t \) exceeds a positive value \( h \) (referred to as the decision interval), a shift or out-of-control condition is signaled.

Note that \( S_t \) is always positive and \( h \) is always positive, regardless of whether \( \delta \) is positive or negative. For charts designed to detect a negative shift, some authors define a reflected version of \( S_t \) for which a shift is signaled when \( S_t \) is less than a negative limit.

Lucas and Crosier (1982) describe the properties of a fast initial response (FIR) feature for CUSUM charts in which the initial CUSUM \( S_0 \) is set to a “head start” value. Average run length calculations given by them show that the FIR feature has little effect when the process is in control and that it leads to a faster response to an initial out-of-control condition than a standard CUSUM chart. You can provide a Head Start value in the Known Statistics for CUSUM Chart area on the launch window.
Constant Sample Sizes

When the subgroup sample sizes are constant (= n), it might be preferable to compute CUSUMs that are scaled in the same units as the data. CUSUMs are then computed as follows:

\[ S_t = \max(0, S_{t-1} + (\bar{X}_t - (\mu_0 + k \sigma / \sqrt{n})) \]

where \( \delta > 0 \)

\[ S_t = \max(0, S_{t-1} - (\bar{X}_t - (\mu_0 - k \sigma / \sqrt{n}))) \]

where \( \delta < 0 \). In either case, the parameter \( k \) is rescaled to \( k' = k \sigma / \sqrt{n} \). If the parameter \( k \) is not specified in the launch window, \( k' \) is set to \( \delta/2 \). A shift is signaled if \( S_t \) exceeds \( h' = h \sigma / \sqrt{n} \). Some authors use the symbol \( H \) for \( h' \).

Two-Sided CUSUM Charts

If the CUSUM chart is two-sided, the cumulative sum \( S_t \) plotted for the \( t^{\text{th}} \) subgroup is defined as follows:

\[ S_t = S_{t-1} + z_t \]

\( t = 1, 2, ..., n \). Here \( S_0=0 \), and the term \( z_t \) is calculated as follows:

\[ z_t = (\bar{X}_t - \mu_0) / (\sigma / \sqrt{n_t}) \]

where \( \bar{X}_t \) is the \( t^{\text{th}} \) subgroup average, and \( n_t \) is the \( t^{\text{th}} \) subgroup sample size. If the subgroup samples consist of individual measurements \( x_t \), the term \( z_t \) simplifies to the following computation:

\[ z_t = (x_t - \mu_0) / \sigma \]

The first equation can be rewritten as follows:

\[ S_t = \sum_{i=1}^{t} z_i = \sum_{i=1}^{t} (\bar{X}_i - \mu_0) / \sigma \bar{X}_i \]

where the sequence \( S_t \) cumulates standardized deviations of the subgroup averages from the target mean \( \mu_0 \).

In many applications, the subgroup sample sizes \( n_t \) are constant (\( n_t = n \)), and the equation for \( S_t \) can be simplified:

\[ S_t = (1 / \sigma \bar{X}) \sum_{i=1}^{t} (\bar{X}_i - \mu_0) = (\sqrt{n} / \sigma) \sum_{i=1}^{t} (\bar{X}_i - \mu_0) \]
In some applications, it might be preferable to compute $S_i$ as follows:

$$S_i = \sum_{i=1}^{t} (X_i - \mu_0)$$

which is scaled in the same units as the data. In this case, the procedure rescales the V-mask parameters $h$ and $k$ to $h' = h\sigma/\sqrt{n_i}$ and $k' = k\sigma/\sqrt{n_i}$, respectively. Some authors use the symbols $F$ for $k'$ and $H$ for $h'$.

If the process is in control and the mean $\mu$ is at or near the target $\mu_0$, the random walk model applies. Therefore, the points might wander away from zero, but they will not exhibit a large trend since positive and negative displacements from $\mu_0$ tend to cancel each other. If $\mu$ shifts in the positive direction, the points exhibit an upward trend, and if $\mu$ shifts in the negative direction, the points exhibit a downward trend.

**Statistical Details for Weighted Moving Average Charts**

This section describes how control limits are calculated in legacy weighted moving average charts.

**Control Limits for UWMA Charts**

Control limits for UWMA charts are computed for each subgroup $i$ as follows:

$$LCL_i = \mu_0 - k\frac{\hat{\sigma}}{\text{min}(i, w)} \sqrt{\frac{1}{n_i} + \frac{1}{n_{i-1}} + \ldots + \frac{1}{n_{1+\text{max}(i-w, 0)}}}$$

$$UCL_i = \mu_0 + k\frac{\hat{\sigma}}{\text{min}(i, w)} \sqrt{\frac{1}{n_i} + \frac{1}{n_{i-1}} + \ldots + \frac{1}{n_{1+\text{max}(i-w, 0)}}}$$

where:

- $w$ is the span parameter (number of terms in moving average)
- $n_i$ is the sample size of the $i^{th}$ subgroup
- $k$ is the number of standard deviations
- $\mu_0$ is the weighted average of the subgroup means
- $\hat{\sigma}$ is the estimated process standard deviation
Control Limits for EWMA Charts

Control limits for EWMA charts are computed as follows:

\[
LCL = \mu_0 - k\hat{\sigma}r \left( \frac{i-1}{n_i} \right) \sum_{j=0}^{j} \frac{(1-r)^2j}{n_i-j}
\]

\[
UCL = \mu_0 + k\hat{\sigma}r \left( \frac{i-1}{n_i} \right) \sum_{j=0}^{j} \frac{(1-r)^2j}{n_i-j}
\]

where:

- \( r \) is the EWMA weight parameter (0 < \( r \) < 1)
- \( x_{ij} \) is the \( j \)th measurement in the \( i \)th subgroup, with \( j = 1, 2, 3, ..., n_i \)
- \( n_i \) is the sample size of the \( i \)th subgroup
- \( k \) is the number of standard deviations
- \( \mu_0 \) is the weighted average of the subgroup means
- \( \hat{\sigma} \) is the estimated process standard deviation
A Pareto plot is a chart that shows the severity (measured by frequency) of problems in a quality-related process or operation. Pareto plots help you decide which problems to solve first by highlighting the frequency and severity of problems. This can help improve the statistical quality of your process or operation.

**Figure 15.1** Pareto Plot Examples
Contents

Overview of the Pareto Plot Platform ................................................................. 429
Example of the Pareto Plot Platform ................................................................. 429
Launch the Pareto Plot Platform ..................................................................... 432
The Pareto Plot Report .................................................................................... 433
Pareto Plot Platform Options .......................................................................... 434
  Plots Options ................................................................................................. 435
Additional Examples of the Pareto Plot Platform ........................................ 438
  Example of a Threshold for Combined Causes ............................................. 438
  Example of a Constant Sample Size across Groups .................................... 439
  Example of a Non-Constant Sample Size across Groups ............................ 441
  Example of a One-Way Comparative Pareto Plot ........................................ 442
  Example of a Two-Way Comparative Pareto Plot ........................................ 444
  Example of Subcategories ........................................................................... 445
Statistical Details for the Pareto Plot Platform ............................................. 446
Overview of the Pareto Plot Platform

The Pareto Plot platform produces charts to display the relative frequency or severity of problems in a quality-related process or operation. The Pareto plot is displayed initially as a bar chart that shows the classification of problems arranged in decreasing order. The column whose values are the cause of a problem is assigned the Y role and is called the *process variable*. You can also generate a comparative Pareto plot, which combines two or more Pareto plots for the same process variable. The single display shows plots for each value in a column assigned the X role, or combination of levels from two X variables. Columns assigned the X role are called *classification variables*.

The Pareto plot can chart a single Y (process) variable with no X classification variables, with a single X, or with two X variables. The Pareto function does not distinguish between numeric and character variables or between modeling types. You can switch between a bar chart and a pie chart. All values are treated as discrete, and bars or wedges represent either counts or percentages.

Example of the Pareto Plot Platform

In this example, you determine which factors contribute most toward process failure during the fabrication of integrated circuits. The data contain the types of failure defects and the number of times each type of defect occurred.

1. Select Help > Sample Data Folder and open Quality Control/Failure.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
3. Select failure and click Y, Cause. This column lists the causes of failure. It is the variable that you want to inspect.
4. Select N and click Freq. This column list the number of times that each type of failure occurred.
5. Click OK.
The left axis represents the count of failures, and the right axis represents the percent of failures in each category. The bars are in decreasing order with the most frequently occurring failure to the left. The curve indicates the cumulative failures from left to right.

6. Click the Pareto Plot red triangle and select **Label Cum Percent Points**.

   Note that Contamination accounts for approximately 45% of the failures. The point above the Oxide Defect bar shows that Contamination and Oxide Defect together account for approximately 71% of the failures.

7. Click the Pareto Plot red triangle and deselect **Label Cum Percent Points** and **Show Cum Percent Curve**.

8. Click the label for the y-axis labeled **N** and rename it **Count**.

9. Double-click the y-axis to display the **Y Axis Settings** window.
   - In the **Maximum** field, type 15.
   - In the **Increment** field, type 2.
   - In the **Axis Label Row** panel, select **Grid Lines** for the **Major** grid line.
   - Click **OK**.

10. Click the Pareto Plot red triangle and select **Category Legend**.
Figure 15.3 Pareto Plot with Display Options

Figure 15.3 shows the counts of different types of failures and has a category legend. The vertical count axis is rescaled and has grid lines at the major tick marks.

11. To view the data as a pie chart, click the Pareto Plot red triangle and select Pie Chart.

Contamination and Oxide Defect clearly represent the majority of the failures.
Launch the Pareto Plot Platform

Launch the Pareto Plot platform by selecting Analyze > Quality and Process > Pareto Plot.

Figure 15.5 The Pareto Plot Launch Window

For more information about the options in the Select Columns red triangle menu, see Using JMP.

The Pareto Plot launch window contains the following options:

**Y, Cause** Identifies the column whose values are the cause of a problem. It is called the process variable and is the variable that you want to inspect.

**X, Grouping** Identifies the grouping factor. The grouping variable produces one Pareto plot window with side-by-side plots for each value. You can have no grouping variable, one grouping variable (see “Example of a One-Way Comparative Pareto Plot”), or two grouping variables (see “Example of a Two-Way Comparative Pareto Plot”).

**Subcategory** Assigns a variable that splits the causes into subcategories. The subcategories for each cause are shown as different colored bars on the Pareto plot.

**Weight** Assigns a variable to give the observations different weights.

**Freq** Identifies the column whose values hold the frequencies.

**By** Identifies a variable to produce a separate analysis for each value that appears in the column.

**Threshold of Combined Causes** Enables you to specify a threshold for combining causes by specifying a minimum rate or count. Select the option and then select Tail % or Count and enter the threshold value. The Tail percent option combines smaller count groups against the percentage specified of the total (combined small groups count/total group count). The Count option enables you to specify a specific count threshold. For an example, see “Example of a Threshold for Combined Causes”.


**Per Unit Analysis**  Enables you to compare defect rates across groups. JMP calculates the defect rate as well as 95% confidence intervals of the defect rate. Select the option and then select **Constant** or **Value in Freq Column** and enter the sample size value or cause code, respectively. The Constant option enables you to specify a constant sample size on the launch window. The Value In Freq Column option enables you to specify a unique sample size for a group through a special cause code to designate the rows as cause rows.

Although causes are allowed to be combined in Pareto plots, the calculations for these analyses do not change correspondingly.

For examples, see “Example of a Constant Sample Size across Groups” and “Example of a Non-Constant Sample Size across Groups”.

---

**The Pareto Plot Report**

The Pareto plot combines a bar chart displaying percentages of variables in the data with a line graph showing cumulative percentages of the variables.

**Figure 15.6** Pareto Plot Example
The Pareto plot can chart a single $Y$ (process) variable with no $X$ classification variables, with a single $X$, or with two $X$ variables. The Pareto plot does not distinguish between numeric and character variables or between modeling types. All values are treated as discrete, and bars represent either counts or percentages. The following list describes the arrangement of the Pareto plot:

- A $Y$ variable with no $X$ classification variables produces a single chart with a bar for each value of the $Y$ variable. For an example, see “Example of the Pareto Plot Platform”.

- A $Y$ variable with one $X$ classification variable produces a row of Pareto plots. There is a plot for each level of the $X$ variable with bars for each $Y$ level. These plots are referred to as the *cells* of a comparative Pareto plot. There is a cell for each level of the $X$ (classification) variable. Because there is only one $X$ variable, this is called a *one-way comparative Pareto plot*. For an example, see “Example of a One-Way Comparative Pareto Plot”.

- A $Y$ variable with two $X$ variables produces rows and columns of Pareto plots. There is a row for each level of the first $X$ variable and a column for each level of the second $X$ variable. Because there are two $X$ variables, this is called a *two-way comparative Pareto plot*. The rows have a Pareto plot for each value of the first $X$ variable, as described previously. The upper left cell is called the *key cell*. Its bars are arranged in descending order. The bars in the other cells are in the same order as the key cell. You can reorder the rows and columns of cells. The cell that moves to the upper left corner becomes the new key cell and the bars in all other cells rearrange accordingly. For an example, see “Example of a Two-Way Comparative Pareto Plot”.

- Each bar is the color for which the rows for that $Y$ level are assigned in the associated data table. Otherwise, a single color is used for all of the bars whose $Y$ levels do not have rows with an assigned color. If the rows for a $Y$ level have different colors, the bar for that $Y$ level is the color of the first row for that $Y$ level in the data table.

You can change the type of scale and arrangement of bars and convert the bars into a pie chart using the options in the Pareto Plot red triangle menu. See “Pareto Plot Platform Options”.

### Pareto Plot Platform Options

The Pareto Plot red triangle menu contains options to customize the appearance of the individual bars in the plot and to perform different types of count analyses.

**Configure Causes**  Shows a window that contains options to customize one or more of the individual bars in the Pareto plot. You can change the label, color, and marker of individual causes and specify if the bar value is shown. You can also combine, separate, or reorder the causes.
Per Unit Rates  Shows or hides a table that compares defect rates across groups. If a sample size is specified in the launch window, Defects Per Unit (DPU) and Parts Per Million (PPM) columns are included in the Per Unit Rates table.

Test Rate Within Groups  Shows or hides a table of the results of a likelihood ratio chi-square test to determine whether the rates across causes are the same within a group. See “Statistical Details for the Pareto Plot Platform”.

Test Rates Across Groups  (Available only when a Grouping variable is specified in the launch window.) Shows or hides a table of the results of a likelihood ratio chi-square test to determine whether the rate for each cause is the same across groups. See “Statistical Details for the Pareto Plot Platform”.

Note: By default, the statistics shown in the tables are calculated based on the raw counts of causes and do not take into account causes that have been combined or ordered in the Pareto plot. To calculate the statistics in a table based on the counts of causes as shown in the Pareto plot, select the Match Plot option from the corresponding table’s red triangle menu. If you press Ctrl and select the Match Plot option, the option is applied to all of the tables in the report.

See Using JMP for more information about the following options:

Local Data Filter  Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Platform Preferences  Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

Save By-Group Script  Contains options that enable you to save a script that reproduces the platform report for all levels of a By variable to several destinations. Available only when a By variable is specified in the launch window.

Plots Options

In the Pareto Plot platform, the Plot red triangle menu contains options to customize the appearance of the plots.

Pareto  Shows a submenu of options to change the appearance of the Pareto plot.
**Show Pareto Bars**  Shows or hides the bars that correspond to the value for each cause.

**Subcategory Bar Style**  (Available only when a subcategory is specified in the launch window.) Sets the style of the Pareto bars to Side by Side, Stacked, Bullet, Nested, Single, Needle, or Float.

**Bar Style**  (Not available when a subcategory is specified in the launch window.) Sets the style of the Pareto bars to Bar or Float.

**Bar Label Format**  Opens a window that enables you to edit the format of the bar label.

**Show Pareto Line**  Shows or hides a line that connects the values for each cause.

**Pareto Line Connect Style**  (Available only when the Pareto Line is shown in the plot.) Sets the line style of the Pareto line to Line, Curve, or Step.

**Show Pareto Markers**  Shows or hides markers at the value for each cause.

**Show Error Bars**  Shows or hides error bars on the Pareto bars.

**Pie Chart**  Shows the bars as a pie chart.

**Cumulative Percent**  Shows a submenu of options that affect the appearance of the cumulative percent curve and labels on the Pareto plot.

**Show Cum Percent Curve**  Shows or hides the cumulative percent curve above the bars and the cumulative percent axis on the vertical right axis.

**Cum Line Connect Style**  Sets the line style of the cumulative percent curve to Line, Curve, or Step.

**Cum Percent Curve Color**  Changes the color of the cumulative percent curve.

**Show Cum Percent Points**  Shows or hides the points on the cumulative percent curve.

**Label Cum Percent Points**  Shows or hides the labels for the points on the cumulative curve.

**Cum Percent Label Format**  Shows a window that enables you to edit the format of the cumulative percent label.

**Orientation**  Sets the orientation of the plot to be vertical or horizontal. The default orientation is vertical.

**Note:** When the orientation is horizontal, the scale of the X axis is always percent. The Percent Scale option that enables you to toggle between a percent scale and a count scale is disabled.

**Legend Position**  Changes the position of the legend around the Pareto plot.
Legend Settings  Shows a window with options to edit legend settings such as the color, title position, and font of the legend text.

Show Cum Percent Axis  Shows or hides the cumulative percent axis on the vertical right axis.

Synchronize Y Axes  (Available only when the orientation is vertical.) Locks and unlocks the two Y axes. When this option is selected, zooming and panning of one axis is synchronized with the other axis.

Percent Scale  Sets the scale of the left Y axis to count or percent. A percent scale is shown by default.

N Legend  Shows or hides the total sample size in the plot area.

Reorder Horizontal  (Available only when a grouping variable is specified.) Reorders horizontally grouped Pareto plots.

Reorder Vertical  (Available only when a grouping variable is specified.) Reorders vertically grouped Pareto plots.

Swap Group Orientation  (Available only when a grouping variable is specified.) Swaps the horizontal and vertical groups in the Pareto plot. If only one group is specified, the orientation of the plot is changed.

Ungroup Plots  Separates grouped Pareto plots when there are two or more groups.

Selected Causes  Shows a submenu of options to change the bars in the Pareto plot. These options are also available with a right-click anywhere in the plot area.

Combine Causes  (Available only if at least two bars are selected in the Pareto plot.) Combines selected bars into a single cause bar.

Separate Causes  Separates selected bars into their original component bars.

Move to First  Moves one or more highlighted bars to the left (first) position.

Move to Last  Moves one or more highlighted bars to the right (last) position.

Colors  Shows the colors palette for coloring one or more highlighted bars.

Markers  Shows the markers palette for assigning a marker to the points on the cumulative percent curve, when the Show Cum Percent Points command is in effect.

Label  Displays the bar value at the top of all highlighted bars.

Subset  Creates a subset data table from the selections in the Pareto Plot. If nothing is selected in the Pareto plot, all of the data from the plot is included in the data table.
Additional Examples of the Pareto Plot Platform

This section contains examples of the Pareto Plot platform.

- “Example of a Threshold for Combined Causes”
- “Example of a Constant Sample Size across Groups”
- “Example of a Non-Constant Sample Size across Groups”
- “Example of a One-Way Comparative Pareto Plot”
- “Example of a Two-Way Comparative Pareto Plot”
- “Example of Subcategories”

**Example of a Threshold for Combined Causes**

This example uses a threshold value to combine causes with counts of 2 or fewer into one combined cause. The data table in this example lists causes of failure during the fabrication of integrated circuits and the number of times each type of defect occurred.

1. Select Help > Sample Data Folder and open Quality Control/Failure.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
3. Select failure and click Y, Cause.
4. Select N and click Freq.
5. Select Threshold of Combined Causes and then select Count.
6. Enter 2 as the threshold value.
7. Click OK.

**Figure 15.7** Pareto Plot with a Threshold Count of 2
Figure 15.7 displays the plot after specifying a count of 2. All causes with counts 2 or fewer are combined into the bar labeled 4 Others.

8. To separate the combined bars into original categories as shown in Figure 15.8, select the bar labeled 4 Others.

9. Click the Plots red triangle and select Selected Causes > Separate Causes.

Tip: Alternatively, you can right-click the bar labeled 4 Others and select Selected Causes > Separate Causes.

---

Example of a Constant Sample Size across Groups

This example uses Pareto plots to compare the causes of failure during the fabrication of integrated circuits for two different processes. Each process has a constant sample size of 1000. The data table in this example lists the causes of failure and the number of times each type of defect occurred.

1. Select Help > Sample Data Folder and open Quality Control/Failures.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
4. Select Process and click X, Grouping.
5. Select Count and click Freq.
6. Select Per Unit Analysis and then select Constant.
7. Enter 1000 in Sample Size.
8. Click **OK**.

**Figure 15.9** Pareto Plot Report Window

![Pareto Plot Report Window](image)

Process A indicates Contamination as the top failure while Process B indicates Oxide Defect as the leading failure.

9. Click the Pareto Plot red triangle and select **Test Rates Across Groups**.

**Figure 15.10** Test Rates across Groups Results

![Test Rates across Groups](image)

Note that the DPU for Contamination across groups (Process A and B) is around 0.06.
Example of a Non-Constant Sample Size across Groups

This example uses Pareto plots to compare the causes of failure during the fabrication of integrated circuits for two different processes. A unique sample size for each group is used by specifying size as the cause code, which designates the rows as size rows. The data table in this example lists the causes of failure the number of times each type of defect occurred.

1. Select Help > Sample Data Folder and open Quality Control/Failures/size.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
4. Select Process and click X, Grouping.
5. Select Count and click Freq.
6. Select Per Unit Analysis and then select Value in Freq Column.
7. Enter size in Cause Code.
8. Click OK.

Figure 15.11 Pareto Plot Report Window

9. Click the Pareto Plot red triangle and select Per Unit Rates.
10. Click the Pareto Plot red triangle and select Test Rates Across Groups.
Note that the sample size of 101 is used to calculate the DPU for the causes in group A. However, the sample size of 145 is used to calculate the DPU for the causes in group B.

If there are two group variables, Per Unit Rates lists DPU or rates for every combination of the grouping variables for each cause. However, Test Rate Across Groups only tests overall differences between groups.

**Example of a One-Way Comparative Pareto Plot**

This example compares failures in samples of capacitors manufactured before and after cleaning a tube in the diffusion furnace.

1. Select Help > Sample Data Folder and open Quality Control/Failure2.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
3. Select failure and click Y, Cause.
4. Select clean and click X, Grouping.
   - The clean variable identifies samples as before and after cleaning.
5. Select N and click Freq.
6. Click OK.
Figure 15.13 One-way Comparative Pareto Plot

There is a plot for each value of the variable clean. The horizontal and vertical axes are scaled identically for both plots. The bars in the first plot are in descending order of the Y axis values and determine the order for all cells.

7. Click the Plots red triangle and select **Reorder Horizontal**.
8. Click the down arrow once and then click **OK**.

This rearranges the order of the plots.
Figure 15.14 One-way Comparative Pareto Plot with Reordered Cells

The plots are easier to interpret when presented as the before-and-after plot shown in Figure 15.14. Note that the order of the causes changes to reflect the order based on the first cell. A comparison of these two plots shows a reduction in oxide defects after cleaning.

Example of a Two-Way Comparative Pareto Plot

This example compares failures in production samples in a capacitor manufacturing process before and after a furnace cleaning on each of three consecutive days.

1. Select Help > Sample Data Folder and open Quality Control/Failure3.jmp.
2. Select Analyze > Quality and Process > Pareto Plot.
3. Select failure and click Y, Cause.
4. Select clean and date and click X, Grouping.
5. Select N and click Freq.
6. Click OK.
7. Click the Pareto Plot red triangle and select Configure Causes.
8. Select contamination, click the bar next to Color, and change the color to black.
9. Select metallization, click the bar next to Color, and change the color to black.
10. Click OK.
The two-way layout of Pareto plots shows each level of both X variables. The bars in the upper left cell are arranged in descending order and the bars in the other cells match that order. In each cell of the two-way comparative plot, the bars representing the two most frequently occurring problems are colored black. Contamination and metallization are the two vital categories in all cells. After furnace cleaning, contamination is less of a problem.

**Example of Subcategories**

This example uses a Pareto plot to compare the causes of failure during the fabrication of integrated circuits for two different processes. To see both processes on the same plot, a subcategory is defined.

1. Select **Help > Sample Data Folder** and open Quality Control/Failures.jmp.
2. Select **Analyze > Quality and Process > Pareto Plot**.
3. Select Causes and click **Y, Cause**.
4. Select Process and click **Subcategory**.
5. Select Count and click **Freq**.
6. Click **OK**.
The number of failures for each process and cause combination appears on the same Pareto plot. To change the bar style of the subcategories, click the Plots red triangle and select **Pareto > Subcategory Bar Style**.

**Statistical Details for the Pareto Plot Platform**

The likelihood ratio Chi-square test statistic computed in the Pareto Plot platform uses the following notation:

- $n_{ij}$ is the count for Cause $i$ in Group $j$.
- $E_j$ is the expected count for Group $j$. This is the mean count of each group, across causes.
- $E_i$ is the expected count for Cause $i$. This is the mean count of each cause, across groups.

**Likelihood Ratio Chi-Square Test Statistic within Groups**

$$ G_j^2 = 2 \sum_{i=1}^{K} n_{ij} \ln \left( \frac{n_{ij}}{E_j} \right) $$
Likelihood Ratio Chi-Square Test Statistic across Groups

\[ G_i^2 = 2 \sum_{j=1}^{I} n_{ij} \ln \left( \frac{n_{ij}}{E_i} \right) \]
Use the Diagram platform to construct cause-and-effect diagrams, also known as *Ishikawa charts* or *fishbone charts*. Use these diagrams to:

- Organize the causes of an effect (sources of a problem)
- Brainstorm
- Identify variables in preparation for further experimentation

**Figure 16.1** Example of a Cause-and-Effect Diagram
Contents

Example of a Cause-and-Effect Diagram .................................................. 451
Prepare the Data ...................................................................................... 452
Launch the Diagram Platform ................................................................. 452
The Cause-and-Effect Diagram Report ..................................................... 453
  Right-Click Menus ............................................................................... 453
  Cause and Effect Diagram Menu Options ............................................. 456
How to Save the Diagram ....................................................................... 457
  Save the Diagram as a Data Table .......................................................... 457
  Save the Diagram as a Journal ................................................................. 457
  Save the Diagram as a Script ................................................................. 458
Example of a Cause-and-Effect Diagram

Use a diagram to examine the major factors and possible causes of the defects in a circuit board.

1. Select Help > Sample Data Folder and open Ishikawa.jmp.
2. Select Analyze > Quality and Process > Diagram.
5. Click OK.

Figure 16.2 Ishikawa.jmp Diagram

The major factors are Inspection, Solder process, Raw card, Components, and Component insertion. From each major factor, possible causes branch off, such as Inspection, Measurement, and Test coverage for the Inspection factor.

You can focus on one area at a time to further examine the possible causes or sources of variation for each major factor.
Prepare the Data

Before you launch the Diagram platform, your data should be in two columns of a data table.

Figure 16.3  Example of the Ishikawa.jmp Data Table

<table>
<thead>
<tr>
<th>Parent</th>
<th>Child</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Defects in circuit board</td>
<td>Inspection</td>
</tr>
<tr>
<td>2 Defects in circuit board</td>
<td>Solder process</td>
</tr>
<tr>
<td>3 Defects in circuit board</td>
<td>Raw card</td>
</tr>
<tr>
<td>4 Defects in circuit board</td>
<td>Components</td>
</tr>
<tr>
<td>5 Defects in circuit board</td>
<td>Component insertion</td>
</tr>
<tr>
<td>6 Inspection</td>
<td>Measurement</td>
</tr>
<tr>
<td>7 Inspection</td>
<td>Test coverage</td>
</tr>
<tr>
<td>8 Inspection</td>
<td>Inspector</td>
</tr>
<tr>
<td>9 Solder process</td>
<td>Splatter</td>
</tr>
<tr>
<td>10 Solder process</td>
<td>Flux</td>
</tr>
<tr>
<td>11 Solder process</td>
<td>Chain speed</td>
</tr>
<tr>
<td>12 Solder process</td>
<td>Temperature</td>
</tr>
<tr>
<td>13 Solder process</td>
<td>Wave pump</td>
</tr>
<tr>
<td>14 Temperature</td>
<td>Setup</td>
</tr>
</tbody>
</table>

Notice that the Parent value Defects in circuit board (the effect) has five major factors, listed in the Child column. One of these major factors is Inspection, which has its own causes listed in the Child column. Parent values have children, and children can have their own children (and therefore be listed in both the Parent and Child columns.)

Launch the Diagram Platform

Launch the Diagram platform by selecting Analyze > Quality And Process > Diagram.

Figure 16.4  The Diagram Launch Window
For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

**Tip:** To create a basic diagram that is not based on a data table, leave the **Y, Child**, and **X, Parent** fields empty and click **OK**. Then edit the nodes using the options in the right-click menu. See “Right-Click Menus”.

**Y, Child** Represents the child factors contributing to the parent factors.

**X, Parent** Represents the parent factors (including the effect) that have child factors.

**Label** Includes the text from the Label columns in the nodes of the diagram.

**By** Produces separate diagrams for each value of the By variable.

## The Cause-and-Effect Diagram Report

In Figure 16.5, the effect or problem, Defects in circuit board, appears on the right as the center line. The major contributing factors appear at the end of the branches (Inspection, Solder process, Raw Card, and so on.) Possible causes branch off each major factor.

**Figure 16.5** Cause-and-Effect Diagram

![Cause and Effect Diagram](image)

**Right-Click Menus**

In the Cause and Effect Diagram, right-click a highlighted node to modify text, insert new nodes, change the diagram type, and more. Note the following:

- Right-click a title to change the font and color, positioning, visibility, or formatting.
- Click and highlight a node to rename it.
- Click and drag a node to move it.
**Text Menu**

The Text menu contains the following options:

- **Font**: Select the font of the text or numeric characters.
- **Color**: Select the color of the text or numeric characters.
- **Rotate Left, Rotate Right, Horizontal**: Rotates the text or numbers to be horizontal, 90 degrees left, or 90 degrees right.

**Insert Menu**

Use the Insert menu to insert items onto existing nodes. The Insert menu contains the following options:

- **Before**: Inserts a new node to the right of the highlighted node. For example, Figure 16.6 inserts Child 1.5 before Child 2.

**Figure 16.6  Insert Before**

![Cause and Effect Diagram with Child 1.5 before Child 2]

- **After**: Inserts a new node to the left of the highlighted node. For example, Figure 16.7 inserts Child 3 after Child 2.

**Figure 16.7  Insert After**

![Cause and Effect Diagram with Child 3 after Child 2]

- **Above**: Inserts a new node at a level above the current node. For example, Figure 16.8 inserts Grandparent at a level above Parent.

**Figure 16.8  Insert Above**

![Cause and Effect Diagram with Grandparent above Parent]
Below  Inserts a new node at a level below the current node. For example, Figure 16.9 inserts Grandchild at a level below Child 2.

**Figure 16.9** Insert Below

![Cause and Effect Diagram]

**Move Menu**

Use the Move menu to move nodes or branches. The Move menu contains the following options:

- **First**  Moves the highlighted node to the first position under its parent.
- **Last**  Moves the highlighted node to the last position under its parent.
- **Other Side**  Moves the highlighted node to the opposite side of its parent line.
- **Force Left**  Makes all horizontally drawn elements appear to the left of their parent.
- **Force Right**  Makes all horizontally drawn elements appear to the right of their parent.
- **Force Up**  Makes all vertically drawn elements appear above their parent.
- **Force Down**  Makes all vertically drawn elements appear below their parent.
- **Force Alternate**  Draws children on alternate sides of the parent line.
Other Menu Options

The right-click menu for a highlighted node also contains these options:

**Change Type**  Changes the entire chart type to Fishbone, Hierarchy, or Nested.

**Uneditable**  Disables all other commands except Move and Change Type.

**Text Wrap Width**  Specifies the width of labels where text wrapping occurs.

**Make Into Data Table**  Converts the currently highlighted node into a data table. Convert the all nodes by highlighting the whole diagram (effect).

**Close**  Shows the highlighted node.

**Delete**  Deletes the highlighted node and all of its children.

**Cause and Effect Diagram Menu Options**

The Cause and Effect Diagram red triangle menu contains options to redo the analysis and save scripts.

See *Using JMP* for more information about the following options:

**Redo**  Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.
How to Save the Diagram

There are several different ways to save your Cause and Effect Diagram. Choose from one of the following options:

- “Save the Diagram as a Data Table”
- “Save the Diagram as a Journal”
- “Save the Diagram as a Script”

Save the Diagram as a Data Table

Saving the Cause and Effect Diagram as a data table is a good approach if you have other processes that need to update the data table. However, very little customization of the diagram is available because the data table cannot represent the customization.

To save the diagram as a data table, perform the following steps:

1. Highlight the entire diagram in the Cause and Effect Diagram report.
2. Right-click and select Make Into Data Table.
3. Save the new data table.

Save the Diagram as a Journal

Saving the Cause and Effect Diagram as a journal is a good choice for impromptu work. You can manually build the diagram, save it as a journal, then reopen the journal later and continue building and editing the diagram. However, since the journal is not connected to the data table, any customization of the diagram exists only in the journal.

To save the diagram as a journal, perform the following steps:

1. Highlight the entire diagram in the Cause and Effect Diagram report.
2. Right-click and select **Edit > Journal**.
3. Save the new journal.

### Save the Diagram as a Script

Saving the Cause and Effect Diagram as a script is a good approach if you have other processes that need to update the data table. If you created the diagram from a data table, a simple script appears that relaunches against the data table with no customization. If you created the diagram without using a data table (or from a journal), a more complex script appears that contains all the commands needed to add and customize each area of the diagram.

To save the diagram as a script, perform the following steps:

1. Click the Cause and Effect Diagram red triangle and select **Save Script > To Script Window**.
2. Save the new script.
The Manage Limits platform enables you to quickly add or edit many limits or column property metadata for several columns at once. The limits and metadata are then used in future analyses. You can also specify importance values for each process and indicate whether limits should appear in graphs as reference lines.

The following types of limits and metadata can be specified in Manage Limits:

- Specification limits
- Importance values
- Process Screening metadata, such as centerline, control chart sigma, and measurement sigma
- Measurement Systems Analysis metadata, such as tolerance range, lower tolerance, upper tolerance
- Measurement Systems Analysis metadata specific to Type 1 Gauge analysis, such as reference and resolution
- Detection limits
Contents

Example of Manage Limits .......................................................... 461
Launch the Manage Limits Platform ................................................. 464
The Manage Limits Report ............................................................ 464
  Spec Limits ............................................................................... 465
  Process Screening ................................................................... 465
  MSA ....................................................................................... 465
  Detection Limits ...................................................................... 465
  Buttons ................................................................................... 466
Manage Limits Options ................................................................. 466
Example of Manage Limits

Use Manage Limits to add specification limits to columns in a data table and then analyze those columns in the Distribution platform.

1. Select Help > Sample Data Folder and open Cities.jmp.
2. Select Analyze > Quality and Process > Manage Limits.
3. Specify the columns that you want to set specification limits on. For this example, select OZONE, CO, SO2, and NO, and click Process Variables.
4. Click OK.
5. Add your specification limits. You can do this by loading existing limits from a JMP data table (Load from Limits Table) or by entering limits manually. For this example, enter the following limits manually:
   - OZONE: LSL 0.12, USL 0.2
   - CO: LSL 6, USL 12
   - SO2: LSL 0.015, USL 0.06
   - NO: LSL 0.02, USL 0.04
6. Click the red triangle next to Manage Limits and select Show Limits All.

Specification limits for all columns will appear in graphs as reference lines for future analyses. If you want to show the specification limits as reference lines only for individual columns, check the Show Limits box next to those columns.

Figure 17.1 Set Specification Limits
7. Choose how you want to save the specification limits. For this example, click **Save to Column Properties**. This saves them as column properties in the corresponding data table. You could also save them to a new data table (tall or wide format).

In the Cities.jmp data table Columns panel, notice that asterisks indicating the Spec Limits column property appear next to `OZONE`, `CO`, `SO2`, and `NO`.

8. To see values that are outside the limits in the data table, click the red triangle next to Manage Limits and select **Color Out of Spec Values**. Go to the Cities.jmp data table, and you can see that values below the lower specification limit are colored red and values above the upper specification limit are colored blue.

9. Now, you can run any analysis. For this example, select **Analyze > Distribution**.

10. Select `OZONE`, `CO`, `SO2`, and `NO`, and click **Y, Columns**.

11. Click **OK**.
The specification limits that you added to the OZONE column appear as reference lines in the histogram. When a column contains a Spec Limits column property, the Create Process Capability option is selected in the Distribution launch window. This adds the Process Capability report to the Distribution report.
Launch the Manage Limits Platform

Launch the Manage Limits platform by selecting **Analyze > Quality and Process > Manage Limits**.

**Figure 17.3** Manage Limits Launch Window

For more information about the options in the Select Columns red triangle menu, see *Using JMP*.

**Process Variables**  The columns of process data containing the measurements. The columns must have a Numeric data type.

**The Manage Limits Report**

The Manage Limits report contains several tables that enable you to enter specification limits or other column property metadata for each process column that was specified in the Manage Limits launch window. The report also contains buttons to load and save specification limits and save the information to column properties.

- “Spec Limits”
- “Process Screening”
- “MSA”
- “Detection Limits”
- “Buttons”
Spec Limits

The table in the Spec Limits section contains a row for each process column that was specified in the Manage Limits launch window. For each column, you can add specification limits as well as use the following options:

**Show Limits**  Specifies that the Show as Graph Reference Lines option is selected in the Spec Limits column property for the specified column.

**Process Importance**  Specifies the process importance value for each column. Process importance values provide a mechanism to sort processes in a preferred order. Process importance values are used to size markers in many platform graphs.

**Units**  Specifies the units for each column.

Process Screening

The table in the Process Screening section contains a row for each process column that was specified in the Manage Limits launch window. For each column, you can specify the centerline, specified sigma, and measurement sigma. Once you save your specifications, you can use them when you launch the Process Screening platform. See “Limits Table”.

MSA

The table in the MSA section contains a row for each process column that was specified in the Manage Limits launch window. For each column, you can specify the lower and upper tolerance or tolerance range, reference, resolution, and historical process sigma. Once you save your specifications, you can use them in the Measurement Systems Analysis (MSA), Type 1 Gauge, and Variability Chart platforms. See “Measurement Systems Analysis”, “Type 1 Gauge Analysis”, and “Variability Gauge Charts”.

Detection Limits

The table in the Detection Limits section contains a row for each process column that was specified in the Manage Limits launch window. For each column, you can add lower and upper detection limits.
Buttons

There are several buttons at the bottom of the Manage Limits report that provide the following options:

**Load from Limits Table** Loads specification limits and metadata from a JMP data table.

**Save to Column Properties** Saves the specification limits and metadata as column properties in the associated data table.

**Save to Tall Limits Table** Saves the specification limits and metadata to a new data table in tall format.

**Save to Wide Limits Table** Saves the specification limits and metadata to a new data table in wide format.

Manage Limits Options

The Manage Limits red triangle menu contains the following options:

**Show Limits All** Selects all of the boxes under Show Limits in the Spec Limits table. If Show Limits is selected for a column, the Show as Graph Reference Lines option is selected in the Spec Limits column property. The Show as Graph Reference Lines option displays the specification limits and target that you specify as reference lines in select analysis plots.

**Note:** If all boxes under Show Limits are selected, the Show Limits All option deselects all of the boxes under Show Limits.

**Round Decimals** Sets the number of decimal places to round the limits or metadata values to.

**Color Out of Spec Values** Colors any values in the data table that are outside the specification limits for the columns. Values that are below the lower specification limit are colored red and values that are above the upper specification limit are colored blue.

See *Using JMP* for more information about the following options:

**Redo** Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

**Platform Preferences** Contains options that enable you to view the current platform preferences or update the platform preferences to match the settings in the current JMP report.
**Save Script**  Contains options that enable you to save a script that reproduces the report to several destinations.
Operating Characteristic Curves
Visualizing the Probability of Detecting Process Shifts

The Operating Characteristic (OC) Curves utility enables you to construct OC curves for control charts and attribute acceptance sampling plans. OC curves are available for XBar, P, NP, C, and U charts. For specified control charts, the OC curve shows the probability of failing to detect a shift of a particular size. In addition, there are OC curves for single and double attribute acceptance sampling plans. For a specified acceptance sampling plan, the OC curve shows how the probability of accepting a lot changes with the lot quality.

Note: The OC curves for control charts are two-sided curves. They are drawn for negative and positive shifts. Often OC curves display only one curve for the absolute shift.
Contents

Example of Operating Characteristic Curves ......................................................... 471
Launch the Operating Characteristic Curves Platform ........................................... 472
The Operating Characteristic Curve Report .......................................................... 472
  OC Curves for Control Charts Report ................................................................. 472
  OC Curves for Acceptance Sampling Options .................................................... 473
Example of Operating Characteristic Curves

Use the OC Curve platform to estimate the probability of identifying a process shift with the first sample collected after the shift.

2. Select XBar Shewhart Chart.
3. Click OK.
4. Set the control limits to -1.34 and 1.34. These are 3 sigma limits for \( s = 1 \) and \( n = 5 \) (3 times 1 divided by the square root of 5).
5. Leave Sigma set to 1 and the sample size at 5.

**Figure 18.1** OC Curve Example

The Y axis is the Beta risk, or the probability of not detecting a shift. The probability of detecting a shift of size 2s with a sample of size 5 is 1 - 0.07 = 0.93.
Launch the Operating Characteristic Curves Platform

Launch the Operating Characteristic (OC) Curves by selecting Analyze > Quality and Process > OC Curves. Select the OC curve of interest and click OK to launch.

Figure 18.2 OC Curves Launch Window

The Operating Characteristic Curve Report

The Operating Characteristic Curve report if different depending on what you selected in the launch window.

- “OC Curves for Control Charts Report”
- “OC Curves for Acceptance Sampling Options”

OC Curves for Control Charts Report

For control charts, use OC curves to explore how chart parameter settings impact $\beta$, the probability of failing to detect a specified shift of interest. Use the text boxes, sliders, or the LCL, Shift, and UCL handles on the OC curve to set and adjust chart parameters. The chart parameters are as follows:

**Lower Control Limit** Specifies the lower control limit from your control chart.

**Upper Control Limit** Specifies the upper control limit from your control chart.

**Sigma** (Available only for XBar charts.) Specifies your control chart sigma.

**Sample Size** (Not available for C charts.) Specifies the sample size used for your control chart measure.

**Shift** Specifies the shift to detect.
Beta  Specifies the probability of failing to detect the specified shift given the control chart specifications. Beta updates as the specifications are changed.

**OC Curves for Acceptance Sampling Options**

For attributes acceptance sampling, you can use OC curves to explore how sampling plans and assumed product quality impact the probability of accepting a lot. Use the text boxes, sliders, or fraction defective handle on the OC curve to set and adjust your sampling plan.

**Single Sampling OC Curve Options**

The following options are available for single sampling OC curves:

- **Sampling Type**  Enables you to select Lot Sampling or Binomial Sampling.
  - **Lot Sampling**  Enables you to specify and explore an acceptance plan based on a fixed lot size.
  - **Binomial Sampling**  Enables you to specify and explore an acceptance plan for a continuous process or other situation where the binomial distribution is appropriate.

- **Lot size (N)**  (Available only for Lot Sampling.) Specifies the size of the lot that you are sampling from.
- **Sample Size (n)**  Specifies the number of units for inspection.
- **Acceptable failures (c1)**  specifies the number of allowable failures. If the number of observed defects is greater than c1, then the lot is rejected.
- **Acceptable Quality Limit (AQL)**  Specifies the poorest quality limit that is acceptable. Enter the highest proportion of defects that is acceptable.
- **Rejectable Quality Limit (RQL)**  Specifies the poorest quality for an individual lot. Enter the highest proportion of defects that is acceptable for an individual lot. RQL must be less than or equal to AQL.
- **Fraction Defective**  Specifies the expected fraction defective in the lot.
- **Probability of Acceptance**  Specifies the probability of accepting the lot given the sampling plan as defined. The Probability of Acceptance updates as the specifications are changed, but you can also adjust this value directly. When you adjust the Probability of Acceptance directly, the Fraction Defective value is updated.
- **Alpha**  Specifies the Type I error. This is the probability of rejecting a lot that has a defect level equal to the AQL
Beta  Specifies the Type II error. This is the probability of accepting a lot that has a defect level equal to the RQL.

Double Sampling OC Curve Options

The following options are available for double sampling OC curves:

First Sample  Contains the following settings for the first sample:

Number inspected (n1)  Specifies the number of units inspected in the first sample.

Acceptable failures (c1)  specifies the number of allowable failures in the first sample.

Second Sample  Contains the following settings for the second sample:

Number inspected (n2)  Specifies the number of units inspected in the second sample.

Acceptable failures (c1+c2)  specifies the total number of allowable failures.

Acceptable Quality Limit (AQL)  Specifies the poorest quality limit that is acceptable. Enter the highest proportion of defects that is acceptable.

Rejectable Quality Limit (RQL)  Specifies the poorest quality for an individual lot. Enter the highest proportion of defects that is acceptable for an individual lot. RQL must be less than or equal to AQL.

Fraction Defective  Specifies the expected fraction defective in the lot.

Probability of Acceptance  Specifies the probability of accepting the lot given the sampling plan as defined. The Probability of Acceptance updates as the specifications are changed, but you can also adjust this value directly. When you adjust the Probability of Acceptance directly, the Fraction Defective value is updated.

Alpha  Specifies the Type I error. This is the probability of rejecting a lot that has a defect level equal to the AQL.

Beta  Specifies the Type II error. This is the probability of accepting a lot that has a defect level equal to the RQL.
The following sources are referenced in Quality and Process Methods.


Appendix B

Technology License Notices

• Scintilla is Copyright © 1998–2017 by Neil Hodgson <neilh@scintilla.org>. All Rights Reserved.

Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

• Progress® Telerik® UI for WPF: Copyright © 2008-2019 Progress Software Corporation. All rights reserved. Usage of the included Progress® Telerik® UI for WPF outside of JMP is not permitted.

• ZLIB Compression Library is Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.

• Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.

• Packages is Copyright © 2009–2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

• iODBC software is Copyright © 1995–2006, OpenLink Software Inc and Ke Jin
(www.iodbc.org). All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:
– Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.
– Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.
– Neither the name of OpenLink Software Inc. nor the names of its contributors may be
used to endorse or promote products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.

• This program, “bzip2”, the associated library “libbzip2”, and all documentation, are
Copyright © 1996–2019 Julian R Seward. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.
2. The origin of this software must not be misrepresented; you must not claim that you
wrote the original software. If you use this software in a product, an acknowledgment in
the product documentation would be appreciated but is not required.
3. Altered source versions must be plainly marked as such, and must not be
misrepresented as being the original software.
4. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Julian Seward, jseward@acm.org

bzip2/libbzip2 version 1.0.8 of 13 July 2019

- MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.
- libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and / or other materials provided with the distribution.
- Neither the name of Florian Reuter nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

• libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and
the trio files, which are covered by a similar license but with different Copyright notices)
all the files are:


Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the “Software”), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in
advertising or otherwise to promote the sale, use or other dealings in this Software
without prior written authorization from him.

• Regarding the decompression algorithm used for UNIX files:


The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

• Snowball is Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS \"AS IS\" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• Pako is Copyright © 2014–2017 by Vitaly Puzrin and Andrei Tuputcyn.
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

- HDF5 (Hierarchical Data Format 5) Software Library and Utilities are Copyright 2006–2015 by The HDF Group. NCSA HDF5 (Hierarchical Data Format 5) Software Library and Utilities Copyright 1998-2006 by the Board of Trustees of the University of Illinois. All rights reserved. DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF GROUP AND THE CONTRIBUTORS “AS IS” WITH NO WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED. In no event shall The HDF Group or the Contributors be liable for any damages suffered by the users arising out of the use of this software, even if advised of the possibility of such damage.


Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

- Neither the name of Adobe Systems Incorporated nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
• dmlc/xgboost is Copyright © 2019 SAS Institute.
Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

• libzip is Copyright © 1999–2019 Dieter Baron and Thomas Klausner.
This file is part of libzip, a library to manipulate ZIP archives. The authors can be contacted at <libzip@nih.at>.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. The names of the authors may not be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE AUTHORS `AS IS` AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• OpenNLP 1.5.3, the pre-trained model (version 1.5 of en-parser-chunking.bin), and dmlc/xgboost Version .90 are licensed under the Apache License 2.0 are Copyright © January 2004 by Apache.org.
You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:
– You must give any other recipients of the Work or Derivative Works a copy of this License; and
– You must cause any modified files to carry prominent notices stating that You changed the files; and
– You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and
– If the Work includes a “NOTICE” text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License.
– You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.

• LLVM is Copyright © 2003–2019 by the University of Illinois at Urbana-Champaign. Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at:
   http://www.apache.org/licenses/LICENSE-2.0

   Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

• clang is Copyright © 2007–2019 by the University of Illinois at Urbana-Champaign. Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at:
   http://www.apache.org/licenses/LICENSE-2.0

   Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF
Appendix B
Quality and Process Methods

Technology License Notices

ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

- lld is Copyright © 2011–2019 by the University of Illinois at Urbana-Champaign.
  Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0
  Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

- libcurl is Copyright © 1996–2021, Daniel Stenberg, daniel@haxx.se, and many contributors, see the THANKS file. All rights reserved.
  Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, provided that the above copyright notice and this permission notice appear in all copies.
  THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
  Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without specific prior written authorization of the copyright holder.

- On the Windows operating system, JMP utilizes the OpenBLAS library. OpenBLAS is licensed under the 3-clause BSD license. Full license text follows: Copyright © 2011-2015, The OpenBLAS Project
  All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of the OpenBLAS project nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OPENBLAS PROJECT OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.