Using JMP

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust
Get the Most from JMP

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:

- live and recorded webcasts about how to get started with JMP
- video demos and webcasts of new features and advanced techniques
- details on registering for JMP training
- schedules for seminars being held in your area
- success stories showing how others use JMP
- the JMP user community, resources for users including examples of add-ins and scripts, a forum, blogs, conference information, and so on

jmp.com/getstarted
Contents
Using JMP

1 Learn about JMP
   Documentation and Additional Resources
   Formatting Conventions in JMP Documentation ............................................ 21
   JMP Help .................................................................................................... 22
   JMP Documentation Library ........................................................................ 22
   Additional Resources for Learning JMP ..................................................... 29
      Search JMP ............................................................................................ 29
      JMP Tutorials ....................................................................................... 29
      Sample Data Tables .............................................................................. 30
      Learn about Statistical and JSL Terms ................................................ 30
      Learn JMP Tips and Tricks .................................................................... 30
      JMP Tooltips ......................................................................................... 30
      JMP User Community ........................................................................... 31
      Free Online Statistical Thinking Course .............................................. 31
      JMP New User Welcome Kit ............................................................... 31
      Statistics Knowledge Portal ................................................................. 31
      JMP Training ........................................................................................ 32
      JMP Books by Users ............................................................................ 32
      The JMP Starter Window ..................................................................... 32
      JMP Technical Support ........................................................................ 32

2 Get Started with JMP
   Introduction to Basic Features
   Anatomy of a JMP Session ......................................................................... 35
   Data Table Features .................................................................................. 36
      Data Table Panels ................................................................................. 37
      Data Grid in Data Tables ....................................................................... 45
      Open Different Types of Data Files ...................................................... 50
   Platforms and Reports in JMP ................................................................. 51
      Launch Windows in JMP Platforms .................................................... 52
      Analysis Results in JMP Reports ......................................................... 55
   Manage Files and Open Windows ............................................................. 55
      JMP Home Window on Windows ......................................................... 55
## Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Home Window on macOS</td>
<td>59</td>
</tr>
<tr>
<td>Search for Recently Opened Files on Windows</td>
<td>61</td>
</tr>
<tr>
<td>Close Multiple Files</td>
<td>61</td>
</tr>
<tr>
<td>Display and Arrange Open Windows</td>
<td>61</td>
</tr>
<tr>
<td>Preview JMP Files</td>
<td>63</td>
</tr>
<tr>
<td>Use the Windows Reveal Feature</td>
<td>64</td>
</tr>
<tr>
<td>JMP Starter Window</td>
<td>64</td>
</tr>
</tbody>
</table>

### 3 Import Your Data

#### Create Data Tables

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Importing Data</td>
<td>70</td>
</tr>
<tr>
<td>Import Microsoft Excel Files</td>
<td>71</td>
</tr>
<tr>
<td>Preview and Import Microsoft Excel Data</td>
<td>71</td>
</tr>
<tr>
<td>Import a Microsoft Excel File Directly</td>
<td>82</td>
</tr>
<tr>
<td>Import Text Files</td>
<td>83</td>
</tr>
<tr>
<td>Find Missing Characters in Imported Data</td>
<td>85</td>
</tr>
<tr>
<td>Options in the JMP Text Import Wizard</td>
<td>86</td>
</tr>
<tr>
<td>Edit Text Before Importing into JMP</td>
<td>90</td>
</tr>
<tr>
<td>Import Text from the Script Editor</td>
<td>92</td>
</tr>
<tr>
<td>Import Multiple Files</td>
<td>93</td>
</tr>
<tr>
<td>Import PDF Files</td>
<td>98</td>
</tr>
<tr>
<td>Concatenate Tables into One Data Table</td>
<td>99</td>
</tr>
<tr>
<td>Concatenate Tables by Column Headers</td>
<td>101</td>
</tr>
<tr>
<td>Import Tables that JMP Does Not Auto-Detect</td>
<td>101</td>
</tr>
<tr>
<td>PDF Preview Red Triangle Options</td>
<td>104</td>
</tr>
<tr>
<td>Data Table Preview Options</td>
<td>104</td>
</tr>
<tr>
<td>PDF Preview Right-Click Options</td>
<td>105</td>
</tr>
<tr>
<td>Import XML and JSON Files</td>
<td>105</td>
</tr>
<tr>
<td>Preview and Import XML and JSON Data</td>
<td>105</td>
</tr>
<tr>
<td>Import XML Files Directly</td>
<td>113</td>
</tr>
<tr>
<td>Import JSON Files Directly</td>
<td>113</td>
</tr>
<tr>
<td>Build SQL Queries in Query Builder</td>
<td>114</td>
</tr>
<tr>
<td>Connect to a SQL Database</td>
<td>115</td>
</tr>
<tr>
<td>Select Tables from a SQL Database</td>
<td>115</td>
</tr>
<tr>
<td>Build a SQL Query</td>
<td>120</td>
</tr>
<tr>
<td>Save and Run a JMP Query</td>
<td>134</td>
</tr>
<tr>
<td>Open the Selected Data</td>
<td>135</td>
</tr>
<tr>
<td>Query Builder Red Triangle Options</td>
<td>136</td>
</tr>
<tr>
<td>Write SQL Statements in Query Builder</td>
<td>137</td>
</tr>
<tr>
<td>Import Data from SAS</td>
<td>137</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Java Runtime Environment (JRE) Requirements</td>
<td>137</td>
</tr>
<tr>
<td>SAS Menu Options</td>
<td>138</td>
</tr>
<tr>
<td>Import SAS Data Sets</td>
<td>138</td>
</tr>
<tr>
<td>Create SAS Transport Files in SAS from JMP</td>
<td>140</td>
</tr>
<tr>
<td>Connect to SAS from JMP</td>
<td>141</td>
</tr>
<tr>
<td>Open SAS Data Sets with SAS Query Builder</td>
<td>147</td>
</tr>
<tr>
<td>Open SAS Data Sets through a SAS Server</td>
<td>148</td>
</tr>
<tr>
<td>Using SAS Extended Attributes to Import Metadata</td>
<td>155</td>
</tr>
<tr>
<td>Run Stored Processes</td>
<td>157</td>
</tr>
<tr>
<td>Submit SAS Code</td>
<td>157</td>
</tr>
<tr>
<td>Generate ODS Results</td>
<td>159</td>
</tr>
<tr>
<td>Import Generated SAS Data Sets</td>
<td>160</td>
</tr>
<tr>
<td>Import Data from a Database</td>
<td>162</td>
</tr>
<tr>
<td>Connect to a Database</td>
<td>163</td>
</tr>
<tr>
<td>Open Data from a Database</td>
<td>164</td>
</tr>
<tr>
<td>Write SQL Statements to Query a Database</td>
<td>166</td>
</tr>
<tr>
<td>Structured Query Language (SQL): A Reference</td>
<td>168</td>
</tr>
<tr>
<td>Import Data from Google Sheets</td>
<td>174</td>
</tr>
<tr>
<td>About Importing Google Sheets</td>
<td>175</td>
</tr>
<tr>
<td>Google Sheet Settings</td>
<td>175</td>
</tr>
<tr>
<td>Import SPSS Files</td>
<td>176</td>
</tr>
<tr>
<td>Import Triple-S Survey Data</td>
<td>177</td>
</tr>
<tr>
<td>Import HDF5 Data</td>
<td>178</td>
</tr>
<tr>
<td>Import Data from MATLAB</td>
<td>179</td>
</tr>
<tr>
<td>Import Data from R</td>
<td>179</td>
</tr>
<tr>
<td>Import Data Using the Excel Add-In</td>
<td>179</td>
</tr>
<tr>
<td>Transfer Excel Data to a Data Table</td>
<td>179</td>
</tr>
<tr>
<td>About the JMP Add-In for Excel</td>
<td>181</td>
</tr>
<tr>
<td>Uninstall the JMP Excel Add-In</td>
<td>182</td>
</tr>
<tr>
<td>Import Data from the Internet or a Remote Computer</td>
<td>182</td>
</tr>
<tr>
<td>Create New Data Tables</td>
<td>183</td>
</tr>
<tr>
<td>Import Data from an OSIsoft PI Server</td>
<td>184</td>
</tr>
<tr>
<td>Connect to a PI Server</td>
<td>185</td>
</tr>
<tr>
<td>Common Options in the Import from OSIsoft PI Server Wizard</td>
<td>187</td>
</tr>
<tr>
<td>Import Raw Data from an OSIsoft PI Server</td>
<td>188</td>
</tr>
<tr>
<td>Import Plot Data from an OSIsoft PI Server</td>
<td>188</td>
</tr>
<tr>
<td>Import Interpolated Data from an OSIsoft PI Server</td>
<td>189</td>
</tr>
</tbody>
</table>
4 Enter and Edit Your Data
Perform Basic Data Table Tasks

Enter Data in Data Tables ................................................................. 194
  Copy and Paste Data into Data Tables ........................................... 194
  Add Rows to Data Tables ........................................................... 195
  Add Columns to Data Tables ....................................................... 195
  Fill Data Table Columns with Sequential Data ............................... 197
  Replace Missing Values with Previous Values in Data Table Columns 198
  Enter Cell Formulas into Data Table Columns ................................ 199

Select Rows in Data Tables .......................................................... 200
  Find Matching Cells in Rows ...................................................... 202
  Select Rows That Contain Specific Values .................................... 203
  Locate the Next Selected Row ..................................................... 204

Select Columns in Data Tables ...................................................... 205
  How to Select Columns ............................................................ 205
  Select Columns in the JMP Columns Viewer .................................. 206
  Locate Next and Previously Selected Columns in Data Tables .......... 212

Resize Rows and Columns ............................................................. 212

Organize Data in Data Tables ........................................................ 213
  Delete Rows in Data Tables ....................................................... 213
  Delete Columns in Data Tables .................................................. 214
  Rearrange Columns in Data Tables ............................................. 214
  Group Columns in Data Tables .................................................... 215
  Move Values in Data Tables ...................................................... 215
  Color Cells in Data Tables ........................................................ 216
  Edit or Delete Cells in Data Tables ............................................. 216
  Edit Column Names in Data Tables ............................................. 216
  Hide and Exclude Rows in Data Tables ....................................... 217
  Exclude Rows in Data Tables ..................................................... 218
  Hide Rows in Data Tables ........................................................ 219
  Exclude Columns in Data Tables ................................................ 220
  Hide Columns in Data Tables ...................................................... 220
  View Patterns of Missing Data in Data Tables ............................... 221
  Find and Replace Cell Values in Data Tables ................................ 223
  Edit Cells in Data Tables ........................................................ 225
  Right-Click Menus for Rows and Columns .................................... 227
  Compare Data Tables ............................................................... 227

Assign Characteristics to Rows and Columns .................................. 234
  How to Find Options for Rows and Columns ................................ 234
  Label Rows and Columns ........................................................... 234
Assign Colors or Markers to Rows .............................................. 235
Create Color Themes in Graphs ................................................. 237
Delete Custom Color Themes in Graphs ................................. 243
Select Matching Row State Cells ............................................. 243
Delete Row Characteristics .................................................. 244
Lock Columns ................................................................. 244
Restructure Data ............................................................... 244
Split a Data Table Column into Multiple Columns ................. 245
Create a New Column by Text Matching ............................... 245
Make Indicator Columns ..................................................... 247
Combine Columns in Data Tables .......................................... 248
Compress Selected Columns in Data Tables ......................... 249
Make a Binning Formula in a Data Table Column ................ 250
Convert Labels to Codes and Codes to Labels ....................... 255
Make a New Formula Column .............................................. 256
Transform Columns in a JMP Platform ................................. 256
Recode Data in a Column .................................................... 266
Edit Data Tables ............................................................... 283
Rename Data Tables ............................................................ 283
Lock Data Tables ............................................................... 283
Compress Data Tables ........................................................ 284
Copy Table Scripts ............................................................. 284
Use Data Table Variables .................................................... 285
Create and Save Scripts in Data Tables ................................. 286

5 Set JMP Column Properties ............................................. 291

The Column Info Window ...................................................... 293
About the Column Info Window ............................................. 293
About Modeling Types ........................................................ 296
The Short-Integer Format ..................................................... 296
Numeric Formats ................................................................. 297
Store Information in Row State Columns ....................... 302
Initialize Data in a Column .................................................. 304

Column Properties in JMP ................................................... 306
Basic Column Properties ..................................................... 307
Properties That Validate Column Values ......................... 308
Properties That Attach Information to Column Values .......... 309
Properties That Control the Display of Columns ................. 315
Properties Used in Modeling and DOE ............................... 315
Properties Associated with Control Charts and Capability ...... 317
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties That Control How Columns Are Used in Platforms</td>
<td>318</td>
</tr>
<tr>
<td>SAS Properties</td>
<td>327</td>
</tr>
<tr>
<td>Link Data Tables with Virtual Join Properties</td>
<td>327</td>
</tr>
<tr>
<td>Additional Column Properties</td>
<td>329</td>
</tr>
<tr>
<td>Properties Assigned and Controlled by JMP</td>
<td>332</td>
</tr>
<tr>
<td>Standardize Attributes and Properties Across Columns</td>
<td>334</td>
</tr>
<tr>
<td>Recode Column Values</td>
<td>335</td>
</tr>
<tr>
<td>Standardize Column Attributes</td>
<td>335</td>
</tr>
<tr>
<td>Standardize Column Properties</td>
<td>336</td>
</tr>
<tr>
<td>Delete Column Properties</td>
<td>336</td>
</tr>
<tr>
<td>Example of Standardizing a Formula</td>
<td>336</td>
</tr>
<tr>
<td>Assign a Preselected Analysis Role to a Column</td>
<td>338</td>
</tr>
<tr>
<td>6 Reshape Your Data</td>
<td>339</td>
</tr>
<tr>
<td>Create Subsets, Sort Data, and More</td>
<td>341</td>
</tr>
<tr>
<td>Create a Subset Data Table</td>
<td>341</td>
</tr>
<tr>
<td>Create a Subset Data Table from a JMP Report</td>
<td>343</td>
</tr>
<tr>
<td>Sort Data Tables</td>
<td>344</td>
</tr>
<tr>
<td>Stack Columns in Data Tables</td>
<td>347</td>
</tr>
<tr>
<td>Example of Stacking Columns into a Single Column</td>
<td>349</td>
</tr>
<tr>
<td>Example of Stacking Columns into More Than One Column</td>
<td>350</td>
</tr>
<tr>
<td>Split Columns in Data Tables</td>
<td>351</td>
</tr>
<tr>
<td>Examples of Splitting Columns</td>
<td>353</td>
</tr>
<tr>
<td>Transpose Rows and Columns in a Data Table</td>
<td>355</td>
</tr>
<tr>
<td>Examples of Transposing Rows and Columns in a Data Table</td>
<td>358</td>
</tr>
<tr>
<td>Concatenate Data Tables</td>
<td>359</td>
</tr>
<tr>
<td>Example of Concatenating Data Tables</td>
<td>361</td>
</tr>
<tr>
<td>Example of Concatenating Data Tables and Table Variables</td>
<td>362</td>
</tr>
<tr>
<td>Join Data Tables</td>
<td>363</td>
</tr>
<tr>
<td>Examples of Joining Data Tables</td>
<td>366</td>
</tr>
<tr>
<td>Query and Join Data Tables with JMP Query Builder</td>
<td>373</td>
</tr>
<tr>
<td>About Links to Data Tables in JMP Queries</td>
<td>376</td>
</tr>
<tr>
<td>Virtually Join Data Tables</td>
<td>377</td>
</tr>
<tr>
<td>Example of Virtually Joining Columns</td>
<td>378</td>
</tr>
<tr>
<td>Example of Virtually Joining Columns and Showing Row States</td>
<td>381</td>
</tr>
<tr>
<td>Example of Merging Referenced Data in Virtually Joined Data Tables</td>
<td>383</td>
</tr>
<tr>
<td>Example of a Link ID and a Link Reference on a Single Column</td>
<td>386</td>
</tr>
<tr>
<td>Update Data Tables</td>
<td>389</td>
</tr>
<tr>
<td>Example of Updating a JMP Data Table</td>
<td>392</td>
</tr>
<tr>
<td>Anonymize Data</td>
<td>393</td>
</tr>
</tbody>
</table>
# Create Formulas in JMP

## Formula Editor

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview of Formulas in JMP</td>
<td>397</td>
</tr>
<tr>
<td>Create Formulas in JMP</td>
<td>397</td>
</tr>
<tr>
<td>Refer to Data Table Values in Formulas</td>
<td>399</td>
</tr>
<tr>
<td>Use Local Variables in Formulas</td>
<td>402</td>
</tr>
<tr>
<td>Incorporate Parameters in Formulas</td>
<td>403</td>
</tr>
<tr>
<td>Insert Constants in Formulas</td>
<td>404</td>
</tr>
<tr>
<td>Add Operators to JMP Formulas</td>
<td>406</td>
</tr>
<tr>
<td>Keypad Reference for the Formula Editor</td>
<td>406</td>
</tr>
<tr>
<td>Use Functions in Formulas</td>
<td>408</td>
</tr>
<tr>
<td>Find Frequently Used Functions in the Formula Editor</td>
<td>410</td>
</tr>
<tr>
<td>Copy and Replicate Formulas</td>
<td>412</td>
</tr>
<tr>
<td>Order Expressions in Formulas</td>
<td>414</td>
</tr>
<tr>
<td>Build a Formula in Order of Precedence</td>
<td>415</td>
</tr>
<tr>
<td>JMP Formula Editor Options</td>
<td>416</td>
</tr>
<tr>
<td>Calculate Derivatives of JMP Functions</td>
<td>416</td>
</tr>
<tr>
<td>Simplify Complex Formulas</td>
<td>417</td>
</tr>
<tr>
<td>Evaluate Formulas</td>
<td>418</td>
</tr>
<tr>
<td>Ignore Errors in Formulas</td>
<td>418</td>
</tr>
<tr>
<td>View Formulas in JSL</td>
<td>419</td>
</tr>
<tr>
<td>Edit Formulas</td>
<td>419</td>
</tr>
<tr>
<td>Correct Mistakes in Formulas</td>
<td>419</td>
</tr>
<tr>
<td>Select Expressions in Formulas</td>
<td>420</td>
</tr>
<tr>
<td>Delete Functions from Formulas</td>
<td>420</td>
</tr>
<tr>
<td>Cut, Copy, and Paste Formulas</td>
<td>421</td>
</tr>
<tr>
<td>Click and Drag Formulas</td>
<td>421</td>
</tr>
<tr>
<td>Customize Formulas in the JMP Formula Editor</td>
<td>422</td>
</tr>
<tr>
<td>Hide and Show Outlines in Formulas</td>
<td>422</td>
</tr>
<tr>
<td>Change the Font Size in Formulas</td>
<td>422</td>
</tr>
<tr>
<td>Specify the Matrix Size in Formulas</td>
<td>422</td>
</tr>
<tr>
<td>Change the Orientation of a Formula</td>
<td>423</td>
</tr>
<tr>
<td>Open and Close Arguments in Formulas</td>
<td>423</td>
</tr>
<tr>
<td>Examples of Building Formulas in the JMP Formula Editor</td>
<td>423</td>
</tr>
<tr>
<td>Use Basic Features in the JMP Formula Editor</td>
<td>424</td>
</tr>
<tr>
<td>Use Local Variables in Formulas</td>
<td>425</td>
</tr>
<tr>
<td>Use the Munger Function in Formulas</td>
<td>426</td>
</tr>
<tr>
<td>Use the Match Conditional Function in Formulas</td>
<td>427</td>
</tr>
<tr>
<td>Use the Delete Expression Button in Formulas</td>
<td>428</td>
</tr>
<tr>
<td>Keyboard Shortcuts for the JMP Formula Editor</td>
<td>429</td>
</tr>
</tbody>
</table>
8 **Summarize Your Data** .......................................................... 433
   **The Table Summary Command** ........................................... 435
   Summarize Columns .......................................................... 435
      Summary Launch Window .................................................. 435
   Create a Summary Table .................................................... 435
   Add a Statistics Column to an Existing Summary Table ........ 439
   Explanation of Summary Statistics .................................... 440
   Example of Creating a Summary Table with Groups .............. 442

9 **JMP Reports** ............................................................... 445
   **Navigate and Customize Report Windows** .......................... 449
   Navigate JMP Reports ...................................................... 449
   Use the Hand Tool .......................................................... 450
   Display Options for JMP Reports ...................................... 450
   Show and Hide Parts of a JMP Report ................................ 452
   Combine Several JMP Reports .......................................... 453
   Rename Report Titles ...................................................... 453
   Increase Font Sizes in Reports ........................................ 453
   Resize a Report Window .................................................. 453
   Red Triangle Options in JMP Reports .................................. 454
      Local Data Filters in JMP Reports .................................. 454
      Redo Menus in JMP Reports ............................................ 457
      Save Script Menus in JMP Reports .................................. 458
   The Data Filter ............................................................. 461
      Types of Data Filter Columns ........................................ 462
      Filtering Modes .......................................................... 462
      The Data Filter Panel ................................................... 463
      Red Triangle Options for the Data Filter ......................... 466
      Animation in Data Filters .............................................. 470
      Red Triangle Options for Variables in Data Filters ........... 473
   Reformat Tables in JMP Reports ....................................... 476
      Change Display Box Properties in a JMP Report ................ 477
      Change a Table in a JMP Report Into a Matrix ................. 478
      Use Conditional Formatting in JMP Reports ...................... 478
   Select Points in JMP Graphs ............................................ 484
   Select Rows in JMP Graphs .............................................. 485
   Select a Rectangular Area of Points in a JMP Graph ............. 485
   Select an Irregularly Shaped Area of Points in a JMP Graph .... 486
   Use Markers in JMP Graphs .............................................. 487
Change the Shape of Markers ................................................................. 487
Change the Color of Markers ................................................................. 488
Change the Size of Markers ................................................................. 488
Work with Crowded Markers ............................................................... 488
Add Outlines Around Markers ............................................................. 489
Change the Selection Mode of Markers ................................................. 490
Specify the Transparency of Markers ................................................ 491
Exclude and Hide Markers ................................................................. 491
Use Images as Markers ................................................................. 492
Change the Shape or Color of Markers Based On Values ...................... 493

Change the Appearance of JMP Graphs ................................................. 495
Resize Graphs .................................................................................... 495
Zoom In on Graphs ............................................................................. 497
Change Line Widths in Graphs ............................................................ 497
Change the Background Color in Graphs ............................................. 497
Change the Color of Histogram Bars ................................................. 498
Display Coordinates and Temporary Reference Lines in Graphs .......... 498
Scroll and Scale Axes in Graphs ......................................................... 498
Customize Axes and Axis Labels in Graphs ....................................... 499
Change the Order of Values in Reports ............................................. 510
Change the Pattern and Format of Selected Objects in Graphs .......... 511
Add a Graph to a Data Table .............................................................. 511
Customize Markers, Lines, Text, and More in Graphs ....................... 512

Add Images to a JMP Graph or Report ............................................... 518
Paste a Background Image into a JMP Graph .................................... 518
Paste an Image at the End of a JMP Report ....................................... 519
Drag and Drop an Image into a JMP Graph ....................................... 519
Add Geographical Images and Boundaries to JMP Graphs ................ 521
Extract Data from an Image .............................................................. 522

Add Annotations and Shapes to JMP Reports and Graphs ................ 523
Add Annotations to JMP Reports or Graphs ....................................... 523
Add Shapes to JMP Reports ............................................................. 524

Customize Hover Labels in JMP Graphs ........................................... 527
Add Graphs or Images to Hover Labels ............................................. 528
Add Text to Hover Labels in JMP Graphs .......................................... 543
Update Names and Values in Hover Labels ..................................... 546
Edit Hover Labels in JMP Graphs ..................................................... 556
Add Images from JMP Data Tables to Hover Labels ....................... 561
Pin Hover Labels in JMP Graphs ....................................................... 562
Right-Click Options for Hover Labels ............................................... 563
## Contents

Using JMP

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customize Common Orderings</td>
<td>564</td>
</tr>
<tr>
<td>Load Common Orderings from a Data Table</td>
<td>564</td>
</tr>
<tr>
<td>Edit Common Orderings</td>
<td>565</td>
</tr>
<tr>
<td>Edit Items</td>
<td>565</td>
</tr>
<tr>
<td>Save Platform Preferences</td>
<td>565</td>
</tr>
<tr>
<td>Semantic Formatting</td>
<td>566</td>
</tr>
<tr>
<td>Format a Row in a Report Table</td>
<td>566</td>
</tr>
<tr>
<td>Format a Column in a Report Table</td>
<td>568</td>
</tr>
<tr>
<td>10 Save and Share Your Data</td>
<td>569</td>
</tr>
<tr>
<td>Get Your Data Out of JMP</td>
<td>572</td>
</tr>
<tr>
<td>Save Data Tables</td>
<td>572</td>
</tr>
<tr>
<td>Save Data Tables as Microsoft Excel Files</td>
<td>573</td>
</tr>
<tr>
<td>Save JMP Data as a CSV File</td>
<td>574</td>
</tr>
<tr>
<td>Save JMP Data as a Text File</td>
<td>575</td>
</tr>
<tr>
<td>Save JMP Data as a JSON File</td>
<td>576</td>
</tr>
<tr>
<td>Save JMP Data as a SAS Transport File</td>
<td>576</td>
</tr>
<tr>
<td>Save JMP Data as a Google Sheet</td>
<td>578</td>
</tr>
<tr>
<td>Save JMP Data as a SAS Data Set</td>
<td>579</td>
</tr>
<tr>
<td>Save Data Tables to a Database</td>
<td>580</td>
</tr>
<tr>
<td>Replace a Database with a Data Table</td>
<td>581</td>
</tr>
<tr>
<td>Save Reports</td>
<td>582</td>
</tr>
<tr>
<td>Save Reports as PDF Files</td>
<td>584</td>
</tr>
<tr>
<td>Save Reports as PowerPoint Presentations</td>
<td>585</td>
</tr>
<tr>
<td>Set the Graphic DPI for Exported Graphics</td>
<td>586</td>
</tr>
<tr>
<td>Save a JMP Analysis as a Script</td>
<td>587</td>
</tr>
<tr>
<td>Save Parts of a Report in a Graphic Format</td>
<td>587</td>
</tr>
<tr>
<td>Share Interactive Reports and Data</td>
<td>588</td>
</tr>
<tr>
<td>Share Reports as Interactive HTML</td>
<td>589</td>
</tr>
<tr>
<td>Share Reports to JMP Live or JMP Public</td>
<td>592</td>
</tr>
<tr>
<td>Share Data to JMP Live</td>
<td>603</td>
</tr>
<tr>
<td>Print Reports</td>
<td>608</td>
</tr>
<tr>
<td>Copy and Paste Reports</td>
<td>609</td>
</tr>
<tr>
<td>Work with Projects</td>
<td>610</td>
</tr>
<tr>
<td>Create a New Project</td>
<td>611</td>
</tr>
<tr>
<td>Open Files in a Project</td>
<td>611</td>
</tr>
<tr>
<td>Rearrange Files in Projects</td>
<td>612</td>
</tr>
<tr>
<td>Save a Project</td>
<td>613</td>
</tr>
<tr>
<td>Project Workspace</td>
<td>614</td>
</tr>
<tr>
<td>Project Bookmarks</td>
<td>615</td>
</tr>
</tbody>
</table>
11 Combine and Present Reports Using Dashboards

12 Workflow Builder
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example of Workflow Builder</td>
<td>657</td>
</tr>
<tr>
<td>Launch the Workflow Builder</td>
<td>661</td>
</tr>
<tr>
<td>The Workflow Builder Window</td>
<td>662</td>
</tr>
<tr>
<td>Workflow Steps</td>
<td>662</td>
</tr>
<tr>
<td>Step Settings</td>
<td>664</td>
</tr>
<tr>
<td>JMP Log History</td>
<td>665</td>
</tr>
<tr>
<td>Workflow Builder Options</td>
<td>665</td>
</tr>
<tr>
<td>Additional Examples of the Workflow Builder</td>
<td>666</td>
</tr>
<tr>
<td>Example of Creating a Workflow from the Log History</td>
<td>666</td>
</tr>
<tr>
<td>Example of Creating a Workflow with a Step Setting</td>
<td>667</td>
</tr>
<tr>
<td>Example of Adding to a Workflow from the Enhanced Log</td>
<td>668</td>
</tr>
<tr>
<td>Technical Details for the Workflow Builder</td>
<td>668</td>
</tr>
<tr>
<td>13 Customize Menus and Toolbars</td>
<td>671</td>
</tr>
<tr>
<td>Personalize JMP</td>
<td></td>
</tr>
<tr>
<td>Customize JMP Toolbars and Menus on Windows</td>
<td>673</td>
</tr>
<tr>
<td>Customize Toolbars</td>
<td>674</td>
</tr>
<tr>
<td>Customize the Main Menu Bar</td>
<td>677</td>
</tr>
<tr>
<td>Create Menu Items and Toolbar Buttons</td>
<td>678</td>
</tr>
<tr>
<td>Set User Permissions for Customized Toolbars and Buttons</td>
<td>682</td>
</tr>
<tr>
<td>Rearrange Toolbars</td>
<td>683</td>
</tr>
<tr>
<td>Copy and Paste Menus, Menu Items, Toolbars, and Buttons</td>
<td>683</td>
</tr>
<tr>
<td>Rearrange Custom Menus, Menu Items, and Buttons</td>
<td>685</td>
</tr>
<tr>
<td>Delete Custom Items</td>
<td>686</td>
</tr>
<tr>
<td>Show or Hide Custom Items</td>
<td>687</td>
</tr>
<tr>
<td>Import Customizations</td>
<td>688</td>
</tr>
<tr>
<td>Remove Customizations from JMP</td>
<td>688</td>
</tr>
<tr>
<td>Customize Toolbars on macOS</td>
<td>689</td>
</tr>
<tr>
<td>Customize Menus on macOS</td>
<td>691</td>
</tr>
<tr>
<td>Customize Menus and Toolbars for Add-Ins</td>
<td>692</td>
</tr>
<tr>
<td>14 JMP Preferences</td>
<td>693</td>
</tr>
<tr>
<td>The Preferences Window</td>
<td></td>
</tr>
<tr>
<td>Overview of JMP Preferences</td>
<td>695</td>
</tr>
<tr>
<td>General JMP Preferences</td>
<td>695</td>
</tr>
<tr>
<td>Preferences for JMP Reports</td>
<td>699</td>
</tr>
<tr>
<td>Preferences for JMP Graphs</td>
<td>702</td>
</tr>
<tr>
<td>Style Preferences for JMP Graphs and Reports</td>
<td>706</td>
</tr>
<tr>
<td>Fonts Preferences</td>
<td>708</td>
</tr>
<tr>
<td>Menu Preferences</td>
<td>711</td>
</tr>
<tr>
<td>Preferences for JMP Projects</td>
<td>712</td>
</tr>
</tbody>
</table>
B  **JMP Technical Details** ................................................................. 815

  JMP Features That Support Multithreading ........................................ 817
  Conventions for Mapping JMP Attributes to SAS Extended Attributes ..... 818

C  **References** .................................................................................. 829

D  **Technology License Notices** .......................................................... 831
Learn about JMP documentation, such as book conventions, descriptions of each JMP document, the Help system, and where to find additional support.
Contents

Formatting Conventions in JMP Documentation .................................................. 21
JMP Help ........................................................................................................... 22
JMP Documentation Library .................................................................................. 22
Additional Resources for Learning JMP ............................................................... 29
  Search JMP ....................................................................................................... 29
  JMP Tutorials .................................................................................................... 29
  Sample Data Tables ........................................................................................... 30
  Learn about Statistical and JSL Terms .............................................................. 30
  Learn JMP Tips and Tricks ................................................................................ 30
  JMP Tooltips ...................................................................................................... 30
  JMP User Community ....................................................................................... 30
  Free Online Statistical Thinking Course ........................................................ 31
  JMP New User Welcome Kit .............................................................................. 31
  Statistics Knowledge Portal ............................................................................. 31
  JMP Training ..................................................................................................... 32
  JMP Books by Users ......................................................................................... 32
  The JMP Starter Window .................................................................................. 32
  JMP Technical Support ..................................................................................... 32
Chapter 1
Using JMP

Formatting Conventions in JMP Documentation

These conventions help you relate written material to information that you see on your screen:

- Sample data table names, column names, pathnames, filenames, file extensions, and folders appear in Helvetica (or sans-serif online) font.
- Code appears in Lucida Sans Typewriter (or monospace online) font.
- Code output appears in Lucida Sans Typewriter italic (or monospace italic online) font and is indented farther than the preceding code.
- **Helvetica bold** formatting (or bold sans-serif online) indicates items that you select to complete a task:
  - buttons
  - check boxes
  - commands
  - list names that are selectable
  - menus
  - options
  - tab names
  - text boxes
- The following items appear in italics:
  - words or phrases that are important or have definitions specific to JMP
  - book titles
  - variables
- Features that are for JMP Pro only are noted with the JMP Pro icon. For an overview of JMP Pro features, visit jmp.com/software/pro.

**Note:** Special information and limitations appear within a Note.

**Tip:** Helpful information appears within a Tip.
JMP Help

JMP Help in the Help menu enables you to search for information about JMP features, statistical methods, and the JMP Scripting Language (or JSL). You can open JMP Help in several ways:

- Search and view JMP Help on Windows by selecting Help > JMP Help.
- On Windows, press the F1 key to open the Help system in the default browser.
- Get help on a specific part of a data table or report window. Select the Help tool from the Tools menu and then click anywhere in a data table or report window to see the Help for that area.
- Within a JMP window, click the Help button.

Note: The JMP Help is available for users with Internet connections. Users without an Internet connection can search all books in a PDF file by selecting Help > JMP Documentation Library. See “JMP Documentation Library” for more information.

JMP Documentation Library

The Help system content is also available in one PDF file called JMP Documentation Library. Select Help > JMP Documentation Library to open the file. You can also download the Documentation PDF Files add-in if you prefer searching individual PDF files of each document in the JMP library. Download the available add-ins from https://community.jmp.com.

The following table describes the purpose and content of each document in the JMP library.

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discovering JMP</td>
<td>If you are not familiar with JMP, start here.</td>
<td>Introduces you to JMP and gets you started creating and analyzing data. Also learn how to share your results.</td>
</tr>
<tr>
<td>Using JMP</td>
<td>Learn about JMP data tables and how to perform basic operations.</td>
<td>Covers general JMP concepts and features that span across all of JMP, including importing data, modifying columns properties, sorting data, and connecting to SAS.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Basic Analysis      | Perform basic analysis using this document.                                      | Describes these Analyze menu platforms:  
• Distribution  
• Fit Y by X  
• Tabulate  
• Text Explorer  
Covers how to perform bivariate, one-way ANOVA, and contingency analyses through Analyze > Fit Y by X. How to approximate sampling distributions using bootstrapping and how to perform parametric resampling with the Simulate platform are also included. |
| Essential Graphing  | Find the ideal graph for your data.                                              | Describes these Graph menu platforms:  
• Graph Builder  
• Scatterplot 3D  
• Contour Plot  
• Bubble Plot  
• Parallel Plot  
• Cell Plot  
• Scatterplot Matrix  
• Ternary Plot  
• Treemap  
• Chart  
• Overlay Plot  
The book also covers how to create background and custom maps. |
<p>| Profilers           | Learn how to use interactive profiling tools, which enable you to view cross-sections of any response surface. | Covers all profilers listed in the Graph menu. Analyzing noise factors is included along with running simulations using random inputs. |</p>
<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Design of Experiments Guide</em></td>
<td>Learn how to design experiments and determine appropriate sample sizes.</td>
<td>Covers all topics in the DOE menu.</td>
</tr>
<tr>
<td><em>Fitting Linear Models</em></td>
<td>Learn about Fit Model platform and many of its personalities.</td>
<td>Describes these personalities, all available within the Analyze menu Fit Model platform:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Standard Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Stepwise</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Regression</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Mixed Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Linear Mixed Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MANOVA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Loglinear Variance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nominal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ordinal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Linear Model</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><em>Predictive and Specialized Modeling</em></td>
<td>Learn about additional modeling techniques.</td>
<td>Describes these Analyze &gt; Predictive Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Neural</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Bootstrap Forest</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Boosted Tree</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- K Nearest Neighbors</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Naive Bayes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Support Vector Machines</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Model Comparison</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Model Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Make Validation Column</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Formula Depot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Specialized Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Fit Curve</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Nonlinear</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Functional Data Explorer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Gaussian Process</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Time Series</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Matched Pairs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describes these Analyze &gt; Screening menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Explore Outliers</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Explore Missing Values</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Explore Patterns</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Response Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Predictor Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Association Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Process History Explorer</td>
</tr>
</tbody>
</table>
### Document Title

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
</table>
| **Multivariate Methods** | Read about techniques for analyzing several variables simultaneously. | Describes these Analyze > Multivariate Methods menu platforms:  
- Multivariate  
- Principal Components  
- Discriminant  
- Partial Least Squares  
- Multiple Correspondence Analysis  
- Structural Equation Models  
- Factor Analysis  
- Multidimensional Scaling  
- Multivariate Embedding  
- Item Analysis  
Describes these Analyze > Clustering menu platforms:  
- Hierarchical Cluster  
- K Means Cluster  
- Normal Mixtures  
- Latent Class Analysis  
- Cluster Variables |
<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quality and Process Methods</td>
<td>Read about tools for evaluating and improving processes.</td>
<td>Describes these Analyze &gt; Quality and Process menu platforms:&lt;br&gt;• Control Chart Builder and individual control charts&lt;br&gt;• Measurement Systems Analysis (EMP and Type 1 Gauge)&lt;br&gt;• Variability / Attribute Gauge Charts&lt;br&gt;• Process Screening&lt;br&gt;• Process Capability&lt;br&gt;• Model Driven Multivariate Control Chart&lt;br&gt;• Legacy Control Charts&lt;br&gt;• Pareto Plot&lt;br&gt;• Diagram&lt;br&gt;• Manage Spec Limits&lt;br&gt;• OC Curves</td>
</tr>
<tr>
<td>Reliability and Survival Methods</td>
<td>Learn to evaluate and improve reliability in a product or system and analyze survival data for people and products.</td>
<td>Describes these Analyze &gt; Reliability and Survival menu platforms:&lt;br&gt;• Life Distribution&lt;br&gt;• Fit Life by X&lt;br&gt;• Cumulative Damage&lt;br&gt;• Recurrence Analysis&lt;br&gt;• Degradation&lt;br&gt;• Repeated Measures Degradation&lt;br&gt;• Destructive Degradation&lt;br&gt;• Reliability Forecast&lt;br&gt;• Reliability Growth&lt;br&gt;• Reliability Block Diagram&lt;br&gt;• Repairable Systems Simulation&lt;br&gt;• Survival&lt;br&gt;• Fit Parametric Survival&lt;br&gt;• Fit Proportional Hazards</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Consumer Research</td>
<td>Learn about methods for studying consumer preferences and using that insight to create better products and services.</td>
<td>Describes these Analyze &gt; Consumer Research menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Categorical</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Choice</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MaxDiff</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Uplift</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multiple Factor Analysis</td>
</tr>
<tr>
<td>Genetics</td>
<td>Learn about methods that are available in JMP to help you analyze your genetic data and use that data to simulate a breeding program to predict the optimum genetic crosses to make.</td>
<td>Describes these Analyze &gt; Genetics menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Marker Statistics</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Marker Simulation</td>
</tr>
<tr>
<td>Scripting Guide</td>
<td>Learn about taking advantage of the powerful JMP Scripting Language (JSL).</td>
<td>Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications.</td>
</tr>
<tr>
<td>JSL Syntax Reference</td>
<td>Read about many JSL functions on functions and their arguments, and messages that you send to objects and display boxes.</td>
<td>Includes syntax, examples, and notes for JSL commands.</td>
</tr>
</tbody>
</table>
Additional Resources for Learning JMP

In addition to reading JMP help, you can also learn about JMP using the following resources:

- “Search JMP”
- “JMP Tutorials”
- “Sample Data Tables”
- “Learn about Statistical and JSL Terms”
- “Learn JMP Tips and Tricks”
- “JMP Tooltips”
- “JMP User Community”
- “Free Online Statistical Thinking Course”
- “JMP New User Welcome Kit”
- “Statistics Knowledge Portal”
- “JMP Training”
- “JMP Books by Users”
- “The JMP Starter Window”

Search JMP

If you are not sure where to find a statistical procedure, do a search across JMP. Results are tailored to the window that you launch the search from, such as a data table or report.

1. Click Help > Search JMP. Or, press Ctrl+comma.
2. Enter your search text.
3. Click the result that contains the procedure that you want.
   On the right, you can see a description and the location of the procedure.
4. Click the corresponding button to open or go to a result.

JMP Tutorials

You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu is Tutorials Directory. This opens a new window with all the tutorials grouped by category.

If you are not familiar with JMP, start with the Beginners Tutorial. It steps you through the JMP interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment and comparing a sample mean to a constant.
Sample Data Tables

All of the examples in the JMP documentation suite use sample data. Select Help > Sample Data Folder to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories, select Help > Sample Index.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\JMP\17\Samples\Data
On macOS: \Library\Application Support\JMP\17\Samples\Data

In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

To view examples using sample data, select Help > Sample Index and navigate to the Teaching Resources section. To learn more about the teaching resources, visit jmp.com/tools.

Learn about Statistical and JSL Terms

For help with statistical terms, select Help > Statistics Index. For help with JSL scripting and examples, select Help > Scripting Index.

Statistics Index Provides definitions of statistical terms.

Scripting Index Lets you search for information about JSL functions, objects, and display boxes. You can also edit and run sample scripts from the Scripting Index and get help on the commands.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select Help > Tip of the Day. Or, you can turn it off using the Preferences window.

JMP Tooltips

JMP provides descriptive tooltips (or hover labels) when you hover over items, such as the following:

- Menu or toolbar options
- Labels in graphs
- Text results in the report window (move your cursor in a circle to reveal)
Files or windows in the Home Window
Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences > General and then deselect Show menu tips. This option is not available on macOS.

JMP User Community

The JMP User Community provides a range of options to help you learn more about JMP and connect with other JMP users. The learning library of one-page guides, tutorials, and demos is a good place to start. And you can continue your education by registering for a variety of JMP training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, and social networking groups.

To access JMP resources on the website, select Help > JMP on the Web > JMP User Community or visit https://community.jmp.com.

Free Online Statistical Thinking Course

Learn practical statistical skills in this free online course on topics such as exploratory data analysis, quality methods, and correlation and regression. The course consists of short videos, demonstrations, exercises, and more. Visit jmp.com/statisticalthinking.

JMP New User Welcome Kit

The JMP New User Welcome Kit is designed to help you quickly get comfortable with the basics of JMP. You'll complete its thirty short demo videos and activities, build your confidence in using the software, and connect with the largest online community of JMP users in the world. Visit jmp.com/welcome.

Statistics Knowledge Portal

The Statistics Knowledge Portal combines concise statistical explanations with illuminating examples and graphics to help visitors establish a firm foundation upon which to build statistical skills. Visit jmp.com/skp.
JMP Training

SAS offers training on a variety of topics led by a seasoned team of JMP experts. Public courses, live web courses, and on-site courses are available. You might also choose the online e-learning subscription to learn at your convenience. Visit jmp.com/training.

JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP website. Visit jmp.com/books.

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus. The window also lists JMP Pro features and platforms.

- To open the JMP Starter window, select View (Window on macOS) > JMP Starter.
- To display the JMP Starter automatically when you open JMP on Windows, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list. On macOS, select JMP > Preferences > Initial JMP Starter Window.

JMP Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP, many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at jmp.com/support, including the technical support phone number.
To get you started with JMP, this chapter covers the following topics:

- learn about the initial windows that appear when you start JMP
- understand data tables
- open data files
- manage open windows
- learn about the anatomy of a typical JMP user session

**Figure 2.1 The JMP Home Window on Windows**
Contents

Anatomy of a JMP Session ................................................................. 35
Data Table Features ......................................................................... 36
  Data Table Panels ..................................................................... 37
  Data Grid in Data Tables ............................................................. 45
  Open Different Types of Data Files .............................................. 50
Platforms and Reports in JMP ...................................................... 51
  Launch Windows in JMP Platforms .............................................. 52
  Analysis Results in JMP Reports .................................................. 55
Manage Files and Open Windows .................................................. 55
  JMP Home Window on Windows ................................................ 55
  JMP Home Window on macOS ................................................... 59
Search for Recently Opened Files on Windows .............................. 61
Close Multiple Files ...................................................................... 61
Display and Arrange Open Windows ............................................. 61
Preview JMP Files ......................................................................... 63
Use the Windows Reveal Feature ................................................... 64
JMP Starter Window ...................................................................... 64
Anatomy of a JMP Session

JMP consists of platforms that are organized by the type of statistical analysis. For example, the Distribution platform produces a univariate analysis using histograms, additional graphs, and reports. You might analyze data in the Distribution platform and then choose another platform to examine the data more thoroughly. As a result, several windows are open at once: at a minimum, the data table, platform launch windows, and the results of the analyses.

Figure 2.2 shows a typical JMP session. Note that the windows are not maximized so that you can quickly switch from one window to another.

Figure 2.2 Anatomy of a Typical JMP Session on Windows

The following sections describe the windows that you typically work with.
Data Table Features

In JMP, data points are organized into rows and columns referred to as the data table. A data table has two parts: the data table panels on the left and the data grid on the right.

You can enter, view, edit, and manipulate data using data tables. In a data table, each variable is a column, and each observation is a row.

**Figure 2.3** Data Table Features
The data table has the following characteristics:

- Column names can contain any keyboard character, including spaces, and can be up to 255 characters long.
- The maximum length of the data table’s name depends on your computer’s operating system.
- Consider setting the *Autosave timeout value* in the General preferences to automatically save data tables at the specified number of minutes. This autosave value also applies to journals, scripts, projects, and reports.
- Change the default size and font for names and values selecting **File > Preferences > Fonts**. (On macOS, select **JMP > Preferences > Fonts**.)
- Column names automatically wrap in the column name area to accommodate the column width that you specify.
- Move column boundaries and enlarge the column to view long values. Adjust widths of all selected columns at once by pressing Alt as you drag the double arrow cursor on any of the selected column boundaries.
- The number of rows and columns in a data table is limited only by your computer’s memory.
- Resize rows by dragging one of the row borders. All rows are resized to the same height. Graphics that display inside each cell shrink based on the row height.
  
  To resize columns to the same width, select the columns and press Alt (Windows) or Option (macOS); drag one of the column borders. All columns are resized to the same width.

**Tip:** To close a report thumbnail in the data table on Windows, press the middle-click button on your mouse.

### Data Table Panels

In JMP data tables, the Table, Columns, and Rows panels contain information about the data table and its contents. These interactive panels are located on the left of the data grid.
Figure 2.4 Interacting with the Data Table Panels

Table Panel in Data Tables

The Table panel contains the following elements:

- Name of the data table
- Icons indicating the table state
- Red triangle menus containing table options
- (Optional) Table variables
- (Optional) Green triangles for table scripts

Table Options

Clicking on the red triangle menu next to the data table name shows these options:
Tables  Contains the same options as the Tables menu. See “Reshape Your Data”.

New Table Variable  Creates a new table variable, which can be text or any other constant character value that you always want to be available in the data table. Table variables are normally used to document tables. See “Use Data Table Variables”.

**Note:** To rename a table variable, double-click it and enter a new name in the Name field.

New Script  Creates a JSL script to save with the data table. After selecting this command, name the script and type in the value (the JSL commands). After you click OK, the new script is listed in the Table panel and you can click its green triangle to run, edit, or delete it. See “Create and Save Scripts in Data Tables”.

Group Scripts  Moves the selected scripts into a group. Click the group name to rename it. Helpful when you want to organize scripts or minimize a long list of scripts.

Ungroup Scripts  Ungroups scripts in the selected group to return them to the top level.

Suppress Formula Eval  Turns off the feature that automatically evaluates formulas. You can turn off evaluation and build sections of a formula. To then test the formula, deselect Suppress Formula Eval.

Lock Data Table  Locks the data table so that data and column properties cannot be edited or added. You can still run analyses and assign characteristics. See “Lock Data Tables”.

Compress file when saved  Compresses the data table when it is saved. After the data table is saved, a compressed file icon 📁 appears next to the data table name in the table panel. See “Compress Data Tables”.

The Compress file when saved option only decreases the file size. This command does not affect the memory required to analyze the data. To reduce both the file size and memory required for analyzing, use Cols > Utilities > Compress Selected Columns. See “Compress Selected Columns in Data Tables”.

**Tip:** You can also configure JMP to always use GZ compression when saving tables by selecting Preferences > General > Save Data Table Columns GZ Compressed.

Disable Undo  Removes all actions from the undo history and does not record future actions. Undos are disabled only while the data table is open; the setting is not saved with the data table. This option saves memory, especially when you delete many rows or perform other tasks on the data table that require a large amount of memory to record the data.

Copy Table Script  Copies the script that re-creates the table. To re-create the table, put the copied script in a new script and run it. Note that referenced columns in virtually joined tables are not included in the script.

Copy Table Script (No Data)  Copies the script that re-creates the table but omits the data.
Rerun Formulas  Re-evaluates all columns containing formulas within the data table.

Script Options
To run a script from the data table panel, click the green triangle next to the script name. Right-clicking the script name or green triangle shows these options:

Run Script  Runs the script.

Tip: Run multiple table scripts at once by pressing Ctrl while selecting the table scripts you want to run. Then, right-click inside the empty area under the list of table scripts, and select Run Script.

Edit  Opens most scripts in the script editor so that you can edit it. Opens a JMP application script in Application Builder.

Edit with Recode  Opens a recode script (which you created by recoding a column and saving the script) in the script editor.

Delete  Deletes the script.

Group Scripts  Moves the selected scripts into a group. Click the group name to rename it. Helpful when you want to organize scripts or minimize a long list of scripts.

Ungroup Scripts  Ungroups scripts in the selected group to return them to the top level.

Copy  Copies the script. You can then paste it into the Table panel of another data table.

Debug Script  Opens the script in the JSL Debugger. See the Scripting Guide.

Paste  Pastes the script from another data table.

Additional Options
In the Table panel, you can also perform the following tasks:

• Double-click a table variable or script name to edit the name and content.
• Drag a table variable or script to rearrange it.

Columns Panel in Data Tables
The Columns panel provides a way to view and move columns. The panel contains the following information:

• Column options (contains some of the same options as the Cols menu)
• Total number of columns and number of columns selected in the data table
• A filter box to help you quickly find columns (click the magnifying glass icon to set search filter options and parameters)
• A list of columns found in the data table
• Icons indicating each column’s modeling type (see “About Modeling Types”)
• Icons representing characteristics and properties assigned to the columns (not shown, see Figure 2.7)

Figure 2.6 Example of a Columns Panel

Icons Representing Column Characteristics and Properties
Icons to the right of each column name indicate characteristics and properties the columns contain.

Figure 2.7 Icons Indicating Column Characteristics and Properties

Note: Italics indicate that the column is locked into place. When you scroll horizontally, the column remains visible.
Here are the icons that can appear in the Columns panel:

- Indicates that points on plots corresponding to the column are labeled by the value instead of the row number. See “Label Rows and Columns”.

- Indicates that the column is excluded from the calculations. See “Exclude Rows in Data Tables”.

- Indicates that the column is not included in graphs. See “Hide Rows in Data Tables”.

- Can be X or Y. Indicates that the column has been assigned the preselected role of $x$ or $y$. See “Assign a Preselected Analysis Role to a Column”.

- Indicates that the column has been assigned the preselected role of validation. See “Assign a Preselected Analysis Role to a Column”.

- Indicates that the column contains one or more properties. Click to reveal a list of properties the column contains.

- Indicates that the values in the column result from a formula. When formula evaluation is suppressed, the icon appears gray. Double-click to view and edit the formula. See “JMP Formula Editor Options”.

- Indicates that the range check or the list check option is turned on. Click to view and edit the range or list. See “Range Check” and “List Check”.

- Indicates that the column has been assigned the preselected role of weight. See “Assign a Preselected Analysis Role to a Column”.

- Indicates that the column has been assigned the preselected role of frequency. See “Assign a Preselected Analysis Role to a Column”.

- Indicates that the column values cannot be edited. See “About the Column Info Window”.

- Indicates that the expression column contains images that can be used as markers. See “Use Images as Markers”.

Virtual Join Icons

- Indicates that the column has a Link Reference column property. This property links a column in the current data table to the ID column in the referenced data table. Blue indicates that the referenced data table is linked.

- Indicates that the column has a Link Reference column property. Gray indicates that the referenced data table is not open or not linked properly.

- Indicates that the column has a Link ID column property, which marks a column in the data table as the ID column. That is, the rows of the data table are uniquely identified by the values of the ID column.

- Indicates that the column is linked from the referenced data table.

For more information about virtual join, see “Virtually Join Data Tables”.

Search Filter Options

To show search filter options in the columns list, select Show Filter from the columns list’s red triangle menu. This enables you to customize your search for columns, which is particularly helpful with long lists of columns.

Click the down arrow button next to the search box to refine your search.

- **Contains Terms**   Returns items that contain a part of the search criteria. A search for “ease oom” returns messages such as “Release Zoom”.

- **Contains Phrase**   Returns items that contain the exact search criteria. A search for “text box” returns entries that contain “text” followed directly by “box” (for example, “Context Box” and “Text Box”).

- **Starts With Phrase**   Returns items that start with the search criteria.

- **Ends With Phrase**   Returns items that end with the search criteria.

- **Whole Phrase**   Returns items that consist of the entire string. A search for “text box” returns entries that contain only “text box”.

- **Regular Expression**   Enables you to use the wildcard (*) and period (.) in the search box. Searching for “get.*name” looks for items that contain “get” followed by one or more words. It returns “Get Color Theme Names”, “Get Name Info”, and “Get Effect Names”, and so on.

- **Invert Result**   Returns items that do not match the search criteria.

- **Match All Terms**   Returns items that contain both strings. A search for “t test” returns elements that contain either or both of the search strings: “Pat Test”, “Shortest Edit Script” and “Paired t test”.
Ignore Case  Ignores the case in the search criteria.

Match Whole Words  Returns items that contain each word in the string based on the Match All Terms setting. If you search for “data filter”, and Match All Terms is selected, entries that contain both “data” and “filter” are returned.

Rows Panel in Data Tables

The Rows panel contains the following information:

- Row options (same options as the Rows menu)
- Total number of rows
- Number of selected (highlighted), excluded, hidden, and labeled rows

![Figure 2.8 Example of a Rows Panel](image)

Right-click the categories in the Rows panel to select rows, clear the selection, or to create a data view.

A data view creates a linked subset of the main data table. For example, if several rows are marked hidden, you might want to open a window that shows you only the hidden rows. Right-click Hidden in the Rows panel and select Data View.
When using a data view, continue to do most of your editing in the main data table. When you make changes in either the main data table or in the data view, the changes are reflected in both. You can make minor changes (such as changing some data or adding a column) in the data view. However, if you want to make major changes (like adding a formula) you must make those changes in the main data table.

**Data Grid in Data Tables**

In JMP data tables, the data grid is the main part of the data table that contains your data. Figure 2.10 illustrates how to interact with the data grid. See also “Select Rows in Data Tables”.
### Figure 2.10 Interacting with the Data Grid

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>To hide the data table panels at left, click the disclosure icon.</td>
</tr>
</tbody>
</table>
| 2      | • To deselect any selected columns, click the space above the diagonal line.  
        • To select all columns, press Shift and click the space above the diagonal line.  
        • To add multiple columns, double-click the space above the diagonal line. |
| 3      | To access the Cols menu options, click the red triangle. |
| 4      | To show histograms in the column header, click the histogram. |
| 5      | • To select a column, click a column title.  
        • To edit a column, double-click a column title. See “About the Column Info Window”.  
        • To access column options, right-click a column title. See “Right-Click Options for Columns”. |
| 6      | To edit a column name, click the name and press Enter. |
| 7      | • To change a column width, click and drag a line between columns.  
        • To change several column widths at once, select the columns, press Alt, then click and drag a line between the highlighted columns. |
| 8      | • To change row widths, click and drag a line between rows. |
| 9      | • To select a row, click the row number.  
        • To edit a row, double-click a row number. See “Edit Cells in Data Tables”.  
        • To access row options, right-click a row number. See “Right-Click Options for Rows”. |
| 10     | To access the Rows menu options, click the red triangle. |
Right-Click Options for Columns

Right-clicking in a column heading shows these options:

**Column Info**  Opens the Column Info window. See “About the Column Info Window”.

**Standardize Attributes**  Copies attributes (data types, modeling types, numeric formats, and so on) or properties (formulas, notes, list and range checks, and so on) from one column to other columns. Also deletes selected attributes or properties from columns. See “Standardize Attributes and Properties Across Columns”.

**Column Properties**  Contains a list of column properties. Select one to open the Column Info window and apply it to the column. This list is also available from the Column Info window. See “Column Properties in JMP”.

**Formula**  Opens the Formula Editor. See “Create Formulas in JMP”.

**Recode**  Enables you to change all of the values in a column at once. See “Rcode Data in a Column”.

**New Formula Column**  Creates a formula column. See “Make a New Formula Column”.

**Insert Columns**  Inserts one or more columns before the selected column or columns.

**Delete Columns**  Deletes all selected columns.

**Label/Unlabel**  Labels or unlabels selected columns in all plots. See “Label Rows and Columns”.

**Link ID**  Used in virtually joined data tables to mark a column in the auxiliary data table as the ID column. That is, the rows of the data table are uniquely identified by the values of the ID column. The Link ID column property checkbox is selected if the column is the ID column for the data table. See “Link Data Tables with Virtual Join Properties”.

**Link Reference**  Used in virtually joined data tables to map a column in the main data table to the ID column in the auxiliary data table. The Link Reference column property specifies the path name of the auxiliary data table. See “Link Data Tables with Virtual Join Properties”.

**Sort**  Sorts all of the rows in the table by the values in the selected column. You can choose to sort the rows in ascending or descending order. See “Sort Data Tables”.

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
</table>
| 11     | • To deselect any selected rows, click the space below the diagonal line.  
        | • To select all rows, press Shift and click the space below the diagonal line.  
        | • To add rows, double-click the space below the diagonal line. |
Copy Column Properties  Copies the column properties.
Paste Column Properties  Pastes the column properties.
Copy Columns  Copies the script to recreate the columns. It copies all of the attributes and properties but no data.
Paste Columns  Creates new columns from the script generated by Copy Columns. The column will be placed after the selected column. If no column is selected, the new columns are placed at the end of the data table. The new columns populate (in the destination table) as many rows as there are data in the script.

Right-Click Options for Rows

Right-clicking in a row heading shows these options:

Hide and Exclude  Hides the selected rows in all plots and graphs and excludes them from analyses. See “Hide and Exclude Rows in Data Tables”.
Exclude/Unexclude  Excludes or includes selected rows from analyses. See “Exclude Rows in Data Tables”.
Hide/Unhide  Hides or shows selected rows in all plots and graphs. See “Hide Rows in Data Tables”.
Label/Unlabel  Labels or unlabels selected rows in all plots. See “Label Rows and Columns”.
Colors  Provides a color palette. Select a color to apply it to the selected rows. The color is used in plots and graphs. See “Assign a Color to Rows”.
Markers  Provides a palette of markers or symbols. Select a marker to apply it to the selected rows. The marker is used in plots and graphs instead of points. See “Add Markers to Rows”.
Color Rows by Row State  Colors the row the same as the current row state color. See “Assign Colors or Markers to Rows Based on Column Values”.
Select Matching Cells  Selects rows in the active data table with values that match the selected row(s). See “Resize Rows and Columns”.
Invert Selection  Selects all previously deselected rows, and deselects all currently selected rows.
Clear Row States  Clears all active row states in the data table. All rows become included, visible, unlabeled, and show in plots as black dots. It does not affect row states saved in row state columns. See “Delete Row Characteristics”.
Add Rows  Adds the specified number of rows to the data table. See “Add Rows to Data Tables”.
Delete Rows
Removes all selected rows from the data table. Use the Undo command on the Edit menu to undo an accidental deletion. See “Delete Rows in Data Tables”.

Cursor Forms

The cursor takes different forms, depending on its location in the data grid.

Arrow Cursor
The standard arrow cursor appears in the following locations:
- In the panels area to the left of the data table
- In the triangular rows and columns area, located in the upper left corner of the data grid

You can perform the following actions with the arrow cursor:
- To select a column using the arrow cursor, click its name in the Columns panel.
- Double-click a column name in the Columns panel to edit it.
- Click the triangular areas in the upper left corner of the data grid to deselect rows and columns.

Selection (Large Plus) Cursor
When the cursor is at the top of a column heading, or in a row number area, it becomes a large plus, indicating that you can select rows or columns. When you click, that row or column is selected and highlighted. Click and drag to select multiple rows or columns, and press Ctrl and click to select discontiguous rows or columns.
- Double-click a column heading area to see the Column Info window for that column.
- Select a column to change the column name. The column highlights. Begin typing (if it is not in a locked column or locked data table).
- Double-click the row number area to edit the rows using the Row Editor.

I-beam Cursor
When you select editable text, the cursor becomes a standard I-beam. To edit text, position the I-beam within highlighted text. Click to mark an insertion point, or drag to select text for replacement.

Double Arrow Cursor
The cursor changes to a double arrow when it is on a column or a panel boundary. Drag this cursor left or right to change the width of a column or panel. Changing the width of a column does not affect the column field width specified in the Column Info window (accessed by double-clicking a column name).

Tip: You can adjust widths of all selected columns at once by pressing Alt as you drag the double arrow cursor on any of the selected column boundaries.

List Check Cursor
The cursor changes form when you move the mouse over values in columns that have data validation in effect. It becomes a small, downward-pointing arrow
on a column with list checking. When you click, the value is highlighted and the cursor becomes the I-beam. Enter or edit data as usual with any values defined as valid text or valid numbers. See “List Check”.

**Pointer Cursor** 🖱️  The cursor changes to a pointer over these objects:
- Red triangle menus for options
- Triangular disclosure icons 📦 that open or close panels
- Modeling type icons for changing

### Open Different Types of Data Files

To open a data set, select **File > Open** and select the file type. Some file types have additional features and options that appear in the Open Data File window (Table 2.1).

**Tips:**

- (Windows only) To open the same file type every time, select the **Select this filter the next time this window is invoked** check box.
- Open a file by dragging it onto the JMP Home Window.
- To change which directory the **File > Open** command looks in, see “Preferences for File Locations”.
- For more information about opening files, see “Import Your Data”.

**Table 2.1** File > Open Options by File Type

<table>
<thead>
<tr>
<th>File Type</th>
<th>Additional Features and Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Data Tables</td>
<td>Table notes, the number of columns (Cols), and the number of rows appear. Use the <strong>Select Columns</strong> option to select which columns are imported into the data table. On Windows, click the arrow next to <strong>Open</strong> and then use the Select Columns option to specify which columns are imported into the data table. On macOS, you can select which columns to import after you click <strong>Open</strong>.</td>
</tr>
<tr>
<td>Excel Files</td>
<td>• Import the file in the Excel Import Wizard by default to customize the layout and preview the data before you import it. • Click the arrow next to <strong>Open</strong> and then select one of the options. Convert the first spreadsheet row into column headings.</td>
</tr>
</tbody>
</table>
Platforms and Reports in JMP

JMP consists of platforms that are organized by the type of statistical analysis. For example, the Distribution platform produces a univariate analysis (the distribution of a single variable) using histograms, additional graphs, and reports. You might analyze data in the Distribution platform and then choose another platform to examine the data more thoroughly.

Table 2.1 File > Open Options by File Type (Continued)

<table>
<thead>
<tr>
<th>File Type</th>
<th>Additional Features and Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Files</td>
<td>• To automatically determine data arrangement, select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>– Data (Using Preferences)</td>
</tr>
<tr>
<td></td>
<td>– Data (Best Guess)</td>
</tr>
<tr>
<td></td>
<td>– Text in the Script Editor</td>
</tr>
<tr>
<td></td>
<td>• To manually specify data arrangement, select the Data (Using Preview) option. See “Options in the JMP Text Import Wizard”.</td>
</tr>
<tr>
<td>SAS Data Sets</td>
<td>• Use SAS variables for column names</td>
</tr>
<tr>
<td></td>
<td>• (Windows only) Enter a password when you open a password-protected data set.</td>
</tr>
<tr>
<td></td>
<td>• (SAS Transport files only) Select columns before opening</td>
</tr>
<tr>
<td>SPSS Data Files</td>
<td>Use SPSS variable or label names for column names.</td>
</tr>
<tr>
<td>XML Data Files</td>
<td>See “Text Files” for more information about the options.</td>
</tr>
<tr>
<td>JSON Data Files</td>
<td>See “Text Files” for more information about the options.</td>
</tr>
<tr>
<td>All Files</td>
<td>• To automatically determine data arrangement, select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>– Open as data using preferences</td>
</tr>
<tr>
<td></td>
<td>– Open as data using a best guess</td>
</tr>
<tr>
<td></td>
<td>– Open as plain text into a script window</td>
</tr>
<tr>
<td></td>
<td>• To manually specify data arrangement, select the Data (Using Preview) option.</td>
</tr>
<tr>
<td></td>
<td>• (Windows only) To open text files using your computer’s default text editor, select Use default program to open.</td>
</tr>
</tbody>
</table>
Platforms and reports work together in these ways:

1. The data table is the input for a platform. See “Data Table Features”.
2. The platform analysis starts in a launch window. See “Launch Windows in JMP Platforms”.
3. The platform results appear in a report window. See “Analysis Results in JMP Reports”.

“Anatomy of a Typical JMP Session on Windows” shows how a platform interacts with the data table and then displays the results in a report window. Information about using platforms is available in the JMP documentation library.

Launch Windows in JMP Platforms

The launch window is your point of entry into a platform, where you specify the columns to analyze. Figure 2.11 shows the Distribution launch window.

Figure 2.11 Launch Window Features

All launch windows have in common provide the following options:

Select Columns  Lists all of the variables in your current data table. Note the following:

- Right-click the modeling type icon next to a column name to change the modeling type.
- Right-click the column name to create a transform column. See “Transform Columns in a JMP Platform”.
Filter and sort the columns using the options in the red triangle menu. See “Column Filter Menu”.

**Cast Selected Columns into Roles** Moves selected columns into roles (such as Y, X, and so on.) You cast a column into the role of a variable (like an actor is cast into a role). See “Cast Selected Columns into Roles Buttons”.

In the Graph Builder window, click the **Dialog** button on the left or select **Redo > Relaunch Analysis** to show this panel.

**Action** The following options are available:

- **OK** Performs the analysis.
- **Cancel** Stops the analysis and quits the launch window.
- **Remove** Deletes any selected variables from a role.
- **Recall** Populates the launch window with the last analysis that you performed.
- **Help** Takes you to the Help for the launch window.

**Tip:** To reopen the platform launch window that was last opened, select **View > Recall Last Platform** (Windows) or **Window > Recall Last Platform** (macOS).

**Cast Selected Columns into Roles Buttons**

The following buttons frequently appear throughout launch windows. Buttons that are specific to certain platforms are described in the chapter for the specific platform.

- **Y** Identifies a column as a response or dependent variable whose distribution is to be studied.
- **X** Identifies a column as an independent, classification, or explanatory variable that predicts the distribution of the Y variable.
- **Weight** Identifies the data table column whose variables assign weight (such as importance or influence) to the data.
- **Freq** Identifies the data table column whose values assign a frequency to each row. This option is useful when a frequency is assigned to each row in summarized data. If the value is 0 or a positive integer, then the value represents the frequencies or counts of observations for each row when there are multiple units recorded.

**Validation** Identifies the data table column whose values assign rows to training, validation, and test sets for cross validation in fitting models.

**Notes:**
For some platforms, KFold validation is available if you specify more than three levels in the Validation column.

If you click the Validation button with no columns selected in the Select Columns list, you have the option to create a Validation column. For more information about the Make Validation Column utility, see *Predictive and Specialized Modeling*.

**By** Identifies a column that creates a report consisting of separate analyses for each level of the variable.

**Column Filter Menu**

A Column Filter menu appears in most of the launch windows. The Column Filter menu is found by clicking the red triangle in the Select Columns panel. Use these options to sort columns, show or hide columns, or search columns.

**Figure 2.12** The Column Filter Menu

- **Reset** Resets the columns to its original list.
- **Show Filter** Opens a box in which you type the column name that you want to find. Click the arrow next to the box and select options to customize the filter.
- **Sort by Name** Sorts the columns in alphabetical order by name in ascending, descending, or original order.
- **Modeling Type** Provides options for showing or hiding columns with specific modeling types.
- **Numeric** Shows or hides columns whose data type is Numeric.
- **Character** Shows or hides columns whose data type is Character.
Expression  Shows or hides columns whose data type is Expression.

Exclude Formats  Excludes columns with specific formats from the column selection list.

Column Groups  Shows or hides groups of columns. See “Group Columns in Data Tables”.

Ungrouped Columns  Shows or hides columns that have not been grouped.

Analysis Results in JMP Reports

After you launch your analysis, the JMP report window appears. The report window shows the output of your analysis using interactive graphs and text reports. See “JMP Reports”.

Figure 2.13  Report Window Features

Manage Files and Open Windows

The JMP Home Window provides instant access to open window and files. Opening recently opened files, closing windows, and pinning frequently used files are a few of the options.

JMP Home Window on Windows

On Windows, the JMP Home Window appears when you open JMP.

- Open recent files in the Recent Files list or pin a frequently used file.
- Right-click files in the Recent Files list to perform common tasks.
- Open or close active JMP windows in the Window List.
• Set an open data table as the current data table by selecting it from the data table list at the top.

**Figure 2.14 JMP Home Window Actions**

- Right-click a window to access options such as closing and hiding the window.
- Hover over a window to see a thumbnail.
- View recent files.
- View open windows (such as launch windows and reports).

**JMP Home Window Buttons**

On Windows, the JMP Home Window panels can contain the following buttons:

- The **Open Selected** button opens the selected files in the Recent Files list.
- The **Sort By Name** button sorts recent files alphabetically.
- The **Filter** button filters the types of files that appear in the Recent Files and Window List panels.
- **Enlarges the font size and icon size of items in the Recent Files list.**
- The **Close** button closes the panel.
Recent Files

On Windows, the Recent Files list provides quick access to files that you recently opened. Keep your favorite files at the top of the list for quick access. Hover over the filename and click the pin icon . To unpin a file, click the pin icon .

You can drag files from the Recent Files list into these locations:

- the JMP Window List to open the file
- a Windows folder or on to your desktop to create a copy of the file
- applications such as Microsoft Notepad or Microsoft Word to edit the file

Right-click files to access the following options:

- Open a file
- Copy the location path to a file
- Open a file within the folder that contains it
- Sort files alphabetically by name or by most recent
- Remove a selected file or files from the list
- Remove a file or files that are no longer in the same location (Alternatively, you can select the files and press Delete.)
- (JSL scripts) Edit, run, or debug a script
- (Text files) Change the import method or open as plain text
- (SQL queries) Run an SQL query that you saved in Query Builder. You can also create a new query using an existing query as a template.
- Run or edit a JMP application

When you open a non JMP file from the Recent Files list, JMP applies your import preferences to arrange the data. You can right-click a text file to change the import method or to open the file in a text editing window. Your import preference is bolded in the pop-up menu.

Tip: To prevent files that were opened by a script from appearing in the Recent Files window, select File > Preferences > General and de-select Add files opened by scripts to the Recent Files list.

Search the Recent Files List for JMP Files

To find a recently opened file in a long list of files, enter part of the file name in the Recent Files Filter box.

The following options are provided:
Get Started with JMP
Chapter 2
Manage Files and Open Windows

• Enter part of the file name in the Filter box above the list of files.
• Hover over the Filter box to view search tips.
• As the files are filtered, the Up and Down arrow keys change the selected file. Press Enter to open the selected file, or select the file with your cursor.
• If a file is selected in the Recent Files list, press Ctrl+F to activate the Filter box.
• Press Esc or click the X button to exit the filtering mode after you typed a search term.

Window List

On Windows, the Window List shows open JMP windows, such as data tables, reports, and scripts. You can open, close, rearrange, and hide JMP windows.

• If you hover over a file in the Window List, a thumbnail appears.
• To open the Window List in its own window, select View > Window List.
• To display windows side-by-side, right-click the selected windows and select Arrange.
• To always automatically display the Window List inside maximized windows, select File > Preferences > Windows Specific and select Dock the Window List in maximized windows.

Right-click files to access the following options:

• View a window
• Close a window (Alternatively, you can select files and press Delete.)
• Close all windows except the currently selected window (if the selected window is a report window, the dependent data table also remains open)
• Move a window to the back
• Hide a window from the Windows taskbar or unhide a window
• Select all windows, or clear all selections

Note: The active file is formatted with bold text.

Rearrange Panels in the Home Window

To rearrange the panels in the Home Window on Windows, click and drag the title bar of the panel. Drop the title bar onto a top, bottom, left, or right arrow to position the panel. A blue box indicates where the panel will be placed. To turn the panels into tabs, drag and drop any panel into the middle of the Home Window.

Tips:

• To put the Home Window back into its original order, select View > Home Window Panes > Revert to Factory Layout.
• If you close a panel and want to reopen it, select **View > Home Window Panes** and select the panel that you want to open.

• Open the JMP Home Window by selecting **View > Home Window** or clicking the **JMP Home Window** button in the lower right corner of most JMP windows. If you cannot see the **JMP Home Window** button, select **View > Status Bars**.

• If you prefer to see the JMP Starter or the Window List upon start-up, you can specify that in the Preferences (Windows only). Select **File > Preferences > General** and select an option from the Initial JMP Window list.

### JMP Home Window on macOS

Use the JMP Home window on the macOS to quickly access JMP files and open windows.

• Open recent files in the Recent Files list.
• Press Control and select a file in the Recent Files list to perform common tasks, such as adding or removing a favorite.
• Open or close active JMP windows in the Windows list.
• Set an open data table as the current data table by selecting it from the Active Table list. Press Option while selecting the data table from the list to activate the data table without bringing it to the front.
• Open the log.
• Find a file in the Recent Files list or an open window in the Windows list by entering a search term in the Search box.
• Click **Toggle Layout** to display the Recent Files and Windows lists horizontally instead of vertically.

Open the JMP Home window on macOS by selecting **Window > JMP Home** (Figure 2.15). To view the window each time you open JMP, select **JMP > Preferences > General > Home Window**.
Figure 2.15  Example of the JMP Home Window (macOS)

Tips:

• The Status bar area shows the path for the currently selected file. You can click a folder to open the folder to view its contents.

• To be able to quickly view the JMP Home window from any JMP window, press Ctrl and click the window, select **Customize Toolbar**, and drag the JMP Home icon to the toolbar.

• To copy a file from Recent Files to another document or into the Finder, select the file and then select **Edit > Copy**.

Recent Files

On macOS, the Recent Files list provides quick access to files that you recently opened.

You can also click the star that appears when you hover over the file name to add it to your favorites.

Press Ctrl and select a file to access other options. For example, you can run or debug a JSL script by pressing Ctrl and selecting Run Script or Debug Script.

**Tip:** To prevent files that were opened by scripts from appearing in the Recent Files window, select **JMP > Preferences > General** and de-select **Add files opened by scripts to the Recent Files list**.
Windows List

On macOS, the Windows list shows open JMP windows, such as data tables, reports, and scripts.

To close a window, click the x button that appears when you hover over the window in the Windows list.

If the window that you are closing is a parent to one or more children, you are prompted to Hide Data Table, Cancel, or Close All windows. Select Close All to close the parent and all its children windows.

Search for Recently Opened Files on Windows

On Windows, recently opened files appear in the Home Window. You can also search for recently opened files from any JMP window.

Select File > Quick Open or press Alt+Shift+O to open the Filter box and enter your search term. This option also lets you view the path of the file. Press Esc or click the X button to close the window after you type a search term.

Close Multiple Files

On Windows, close several files at once from the JMP Home Window. Select the files in the Window List, right-click, and select Close. To leave a single file opened and close the rest, select the single file and then select Close All But This.

On macOS, select File > Close Multiple and then select the files that you want to close.

Display and Arrange Open Windows

In JMP, typically you have several windows open at once (for example, data tables, reports, and the JMP Home Window). JMP provides several ways to arrange and display these open windows.

On Windows:

- Press Ctrl+Tab to switch between windows.
- Use the Reveal feature (F9 or Window > Reveal). See “Use the Windows Reveal Feature”.
- Use the options in the Window menu. Note that Arrange options are also available using the Arrange Menu option in the bottom right corner of most windows. If you cannot see Arrange Menu, JMP Home Window, and View Associated Data buttons, select View > Status Bars.
Tip: From the Arrange Menu option on Windows, you can merge open windows by selecting Combine Windows. See “Example of Combining Windows to Create a Dashboard”.

- To display the JMP Home Window, click the JMP Home Window button in the lower right corner of most windows, or press Ctrl+1.
- To show the data table for a report, click View Associated Data button in the bottom right corner of the report.
- To open an associated report when you are viewing a data table, double-click the thumbnail preview of the report in the bottom pane. To enlarge the preview, hover over the thumbnail (Figure 2.16).
- Middle-click the thumbnail preview to close the associated report.

Figure 2.16 Thumbnail Previews of Open Reports

On the macOS:
- Use the options in the Window menu.
- Use the Expose feature (F9 or F3).
Preview JMP Files

For some JMP file types, you can use Windows Explorer or macOS Finder to view a portion of the selected file. Windows supports a preview of JMP data tables, journals, and scripts. macOS supports a preview of data tables and scripts.

To preview a JMP file

1. In Windows Explorer or the macOS Finder, select the file that you want to preview.
2. In Windows Explorer, select the **Show the preview pane** button in the upper right corner. Support in e-mail programs varies.

   In the macOS Finder, select the file and press the spacebar, or select the **Quick Look** option on the pop-up menu or File menu. In Mail, select the **Quick Look Attachment** option on the pop-up menu or File menu.

   The preview pane shows a portion of the selected file.

**Figure 2.17  Data Table Preview Pane (Windows)**
Use the Windows Reveal Feature

The Reveal feature shows a top-level window with thumbnails of all open JMP windows. On Windows, press F9 to use the Reveal feature.

- Click a window to activate it.
- Press the spacebar to turn on Preview mode, where a full-sized view of the thumbnail under the cursor appears in the center of the screen.
- By default, the windows are ordered to match the original ordering on the screen in a top-down, left-to-right order. Press S to sort the thumbnails by name.
  To exit the Reveal feature, press F9, Esc, or Alt+Tab and then select another application.

JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus.

- To open the JMP Starter window, select View (Window on macOS) > JMP Starter.
- To display the JMP Starter automatically when you open JMP on Windows, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list. On the macOS, select this option on the JMP > Preferences > General page.

Figure 2.18 shows the JMP Starter window for Windows. The macOS JMP Starter window is identical.
Figure 2.18 The JMP Starter Window (Windows)
This chapter covers the following topics:

- How to import data, such as text files, PDF files, SPSS files, and SAS data
- How to transfer Excel data
- How to read in real-time data
- How to create a new data table

Figure 3.1 Importing a Text File
Contents

About Importing Data .......................................................... 70
Import Microsoft Excel Files .............................................. 71
  Preview and Import Microsoft Excel Data .......................... 71
  Import a Microsoft Excel File Directly ............................. 82
Import Text Files ..................................................................... 83
  Find Missing Characters in Imported Data ......................... 85
  Options in the JMP Text Import Wizard ............................. 86
  Edit Text Before Importing into JMP ................................. 90
  Import Text from the Script Editor .................................... 92
Import Multiple Files ............................................................. 93
Import PDF Files ..................................................................... 98
  Concatenate Tables into One Data Table ......................... 99
  Concatenate Tables by Column Headers ............................. 101
  Import Tables that JMP Does Not Auto-Detect .................. 101
  PDF Preview Red Triangle Options .................................. 104
  Data Table Preview Options ............................................ 104
  PDF Preview Right-Click Options .................................... 105
Import XML and JSON Files .................................................. 105
  Preview and Import XML and JSON Data ......................... 105
  Import XML Files Directly .............................................. 113
  Import JSON Files Directly ............................................. 113
Build SQL Queries in Query Builder ..................................... 114
  Connect to a SQL Database ........................................... 115
  Select Tables from a SQL Database ................................. 115
  Build a SQL Query ........................................................ 120
  Save and Run a JMP Query ............................................. 134
  Open the Selected Data .................................................. 135
  Query Builder Red Triangle Options ................................. 136
  Write SQL Statements in Query Builder ........................... 137
Import Data from SAS .......................................................... 137
  Java Runtime Environment (JRE) Requirements ................ 137
  SAS Menu Options ......................................................... 138
  Import SAS Data Sets ...................................................... 138
  Create SAS Transport Files in SAS from JMP ................... 140
  Connect to SAS from JMP .............................................. 141
  Open SAS Data Sets with SAS Query Builder .................... 147
  Open SAS Data Sets through a SAS Server ....................... 148
  Using SAS Extended Attributes to Import Metadata .......... 155
  Run Stored Processes ...................................................... 157
Chapter 3
Using JMP

Import Your Data

Submit SAS Code ................................................................. 157
Generate ODS Results ......................................................... 159
Import Generated SAS Data Sets ......................................... 160
Import Data from a Database ................................................ 162
Connect to a Database ......................................................... 163
Open Data from a Database .................................................. 164
Write SQL Statements to Query a Database ......................... 166
Structured Query Language (SQL): A Reference ..................... 168
Import Data from Google Sheets .......................................... 174
About Importing Google Sheets .......................................... 175
Google Sheet Settings .......................................................... 175
Import SPSS Files ............................................................... 176
Import Triple-S Survey Data .................................................. 177
Import HDF5 Data ............................................................... 178
Import Data from MATLAB .................................................. 179
Import Data from R .............................................................. 179
Import Data Using the Excel Add-In ....................................... 179
Transfer Excel Data to a Data Table ....................................... 179
About the JMP Add-In for Excel .......................................... 181
Uninstall the JMP Excel Add-In ............................................. 182
Import Data from the Internet or a Remote Computer ............... 182
Create New Data Tables ....................................................... 183
Import Data from an OSIsoft PI Server ................................. 184
Connect to a PI Server ......................................................... 185
Common Options in the Import from OSIsoft PI Server Wizard 187
Import Raw Data from an OSIsoft PI Server ......................... 188
Import Plot Data from an OSIsoft PI Server ........................... 188
Import Interpolated Data from an OSIsoft PI Server ............... 189
About Importing Data

You can import many file formats into JMP and save them as data tables. JMP opens many files by default. The file formats which JMP does not support by default require specific Open Database Connectivity (ODBC) drivers.

The Following File Formats Are Supported by Default:

- Comma-separated (.csv)
- .dat files that consist of text
- ESRI shapefiles (.shp)
- Flow Cytometry versions 2.0 and 3.0 (.fcs)
- Hierarchical Data Format, Version 5 (.h5)
- HTML (.htm, .html)
- JSON (.json)
- MATLAB (.m, .M)
- Microsoft Excel 1997 through 2019 on macOS (.xls, .xlsx)
- Microsoft Excel 2010 through 2019 on Windows (*.xlsx, *.xlsm)
- Minitab Portable Worksheet (.mtp)
- Plain text (.txt)
- R (.r)
- SAS transport (.xpt, .stx)
- SAS versions 7 through 9 on macOS (.sas7bdat)
- SAS versions 7 through 9 on Windows (.sas7bdat, .sas7bxat)
- SPSS (.sav)
- SQLite 3.0 or higher (.sqlite, .db, .sqlite3, .db3)
- Tab-separated (.tsv)
- Teradata database (.trd)
- Triple-S (.sss, .xml)
- xBase data files (.dbf)
- XML data files (.xml)

Notes on SAS Support:

On both Windows and macOS, you can open SAS data sets directly through the File > Open command. See “Import SAS Data Sets”. 
Another option is connecting to a SAS server by selecting **File > SAS > Browse Data**. See “Open SAS Data Sets through a SAS Server”.

**The Following Files Require ODBC Drivers:**

- Database (dBASE) (.ndx, .mdx) is supported with a V3+ compliant ODBC driver. .dbf files do not require an ODBC driver.
- Microsoft Access Database (.mdb) is supported with a V3+ compliant ODBC driver.

See “Import Data from a Database” for more information for working with databases.

Your computer’s available memory affects data import. Very large files might load slowly or not at all. Consider splitting up large files before importing them. You can then join or concatenate the tables. See “Concatenate Data Tables” and “Join Data Tables”.

**Note:** You can open R code (.R) and SAS program files (.sas) in JMP, but the text opens in a Script window, not in a data table.

---

**Import Microsoft Excel Files**

Microsoft Excel files open in the Excel Import Wizard by default. The wizard shows a preview of the data. You can then modify the settings before importing the data. For example, you might indicate which row the data begin on and whether the worksheet contains column headers or hidden rows or columns. Microsoft Excel .xls, .xlsm, and .xlsx file formats are supported.

For information about opening a Microsoft Excel file outside the wizard, see “Import a Microsoft Excel File Directly”.

**Notes:**

- Between Windows and macOS, the number of digits after a decimal point might differ.
- Consider setting the *Autosave timeout* value in the General preferences to automatically save open data tables. This autosave value also applies to other JMP document types.

---

**Preview and Import Microsoft Excel Data**

Before you import a worksheet, open the spreadsheet in Excel and decide how you want the data to be structured in the final data table. For example, you need to know whether the worksheet includes hidden or merged cells. In the wizard, you can then exclude hidden columns or rows.
To import a Microsoft Excel file that contains several worksheets, follow these steps:

1. Open the worksheet in Microsoft Excel.
   
   For the figures in this example, we used the Team Results.xlsx file located in the JMP Samples/Import Data folder. The file has the following characteristics:
   
   – the data begin on row 4, column 2 and end on row 9, column 5
   – two worksheets
   – the second worksheet has two sets of merged cells
   – no hidden rows or columns

   **Figure 3.2 Team Results.xlsx Worksheet**

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Here are the team results for this year’s game.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Team</td>
<td>Member Name</td>
<td>Age</td>
<td>Winnings</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>Joe</td>
<td>21</td>
<td>$56.22</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>Mary</td>
<td>22</td>
<td>$34.34</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>Cindy</td>
<td>23</td>
<td>$25.54</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>Mark</td>
<td>22</td>
<td>$52.11</td>
</tr>
<tr>
<td>8</td>
<td>2</td>
<td>Bill</td>
<td>23</td>
<td>$43.32</td>
</tr>
<tr>
<td>9</td>
<td>2</td>
<td>Jennifer</td>
<td>24</td>
<td>$11.23</td>
</tr>
</tbody>
</table>

2. To open an Excel file, select **File > Open**.
   
   The Open Data File window appears.

3. Select **Excel Files** next to File name.

4. Select the Excel file and click **Open**.
   
   The worksheet opens in the Excel Import Wizard, where a preview of the data appears along with import options.
Figure 3.3 Example Initial Data Preview

Note the following characteristics in the Data Preview:

- Both worksheets are selected for import in the upper right corner.
- The first column has been automatically been removed.
- Text from the first row of the worksheet appears as the column headings. However, you want the text in row 3 of the worksheet to be used as the column headings.
- The first data row is empty.

**Note:** JMP remembers your previous changes each time you import a worksheet, even after closing and reopening JMP. This feature is helpful when you want to reimport the same worksheet several times and experiment with options. To clear those changes when you import a different worksheet, click Restore Default Settings.

5. For **Column headers start on row**, type 3.
6. For **Data starts on row**, type 4.
7. For **Number of rows with column headers**, type 1.
8. **Data starts on row** should be set to 4.
9. **Data start on columns** should be set to 1.
10. Select **Ungrouped Team Results** in the Worksheets pane. Only this worksheet will be imported.

11. Deselect **Use for all worksheets**. These settings apply only to Ungrouped Team Results.

**Figure 3.4** Selecting the Column Header Row

Tip: Right-click a numeric column header in the Data Preview pane to change the format.

See “**Individual Worksheet Settings**” for more information about all options.

12. Click **Next** to configure other import settings. The window displays additional import settings.

13. For **Data ends with row**, type 9.

14. For **Data ends with column**, type 5.
Figure 3.5 Specifying the Last Column

![Excel Import Wizard Screenshot]

See “Additional Individual Worksheet Settings” for more information about all options.

15. Click **Import** to convert the worksheet as you specified.

Figure 3.6 Final Data Table

![Final Data Table Screenshot]

The following sections describe options in the Excel Import Wizard.

**Individual Worksheet Settings**

**Worksheet contains column headers** Select if the worksheet contains rows with column headers.

**Column headers start on row** Indicates which row the column headers begin on in the worksheet. Click the up arrow until the headers begin on the correct row, or enter the row number and press Enter.
Import Microsoft Excel Files Using JMP

**Number of rows with column headers** Indicates whether the worksheet has multiple rows as column headers. Click the up arrow until the header rows appear correctly, or enter the number of rows and press Enter.

**Data starts on row** Indicates which row the data start on in the worksheet.

**Data starts on column** Indicates which column the data start on in the worksheet.

**Concatenate worksheets and try to match columns** Merges all worksheets into one data table. JMP matches columns that have the same header.

**Create column with worksheet name when concatenating** Adds a new Source Table column that lists the worksheet name for each imported table. This option is available after you select the preceding concatenate option.

**Use for all worksheets** Applies the current import settings to all worksheets that are selected in the upper right corner.

### Additional Individual Worksheet Settings

**Treat multiple column header lines as hierarchies** Indicates that the worksheet contains multiple rows as column headers and you want these headers to be hierarchies. This option is only for stackable data.

**Replicate data in spanned rows** Indicates cells are merged in the worksheet across rows. JMP unspan the cells and copy the cell contents into all of the resulting cells. The option is selected by default.

If you deselect **Replicate data in spanned rows**, JMP unspans the cells and copies the cell contents into the topmost cell. The remaining unspanned cells are left empty.

**Suppress hidden rows** Prevents hidden rows from appearing in the data table.

**Suppress hidden columns** Prevents hidden columns from appearing in the data table.

**Suppress empty columns** Indicates whether an empty column that has a column header is imported. Deselect the option to import the column.

**Data ends with row** Indicates the last row in the worksheet that contains data.

**Data ends with column** Indicates the last column in the worksheet that contains data.

### Advanced Options

**Column Name Separator String** Indicates the separator between each word in a column heading if the headings were originally in different rows. Specify the number of rows with column headers on the first Excel Import Wizard window. Then enter a character or space...
in the Column Name Separator String box. The default string, a hyphen, results in a column heading such as “First-Second-Third”.

**Multiple Series Stack**  Divides subcategories into separate columns in a worksheet with hierarchical headings. You must also select **Treat multiple column header lines as hierarchies**. The main category is imported as the Label column.

**Replicate headers in spanned rows**  Repeats the header text in each cell for rows that are spanned in the worksheet. For example, the State column heading shown in Figure 3.7 was in a merged cell in the worksheet. On the left, the heading is replicated. Deselect the option to avoid repeating the heading as shown on the right.

**Figure 3.7** Replicated Headers in a Microsoft Excel File

![Replicated Headers](image)

**Import cell colors**  Applies the cell coloring from the worksheet to the data table. On macOS, only primary and secondary colors can be reliably imported.

**Limit column type detection**  Scans a maximum of 100 rows to determine the column type. Select this option to speed up the import of large worksheets.

**Tips:**

- JMP remembers your previous changes each time you import a worksheet, even after closing and reopening JMP. This feature is very helpful when you want to reimport the same worksheet several times and experiment with options. To clear those changes when you import a different worksheet, click **Restore Default Settings**.
- Your import settings are saved in a data table script named Source. To reimport the worksheet using the same settings, run the script. The script includes the path to the worksheet, so make sure that other users have access to that location.
- To speed up the data preview in large worksheets, deselect **Update settings on any change** on the first wizard window. Modify the settings and then click **Update now** to refresh the data preview.
- To view all rows in the Data Preview pane, select **Show all rows**. The preview might be slightly delayed depending on the size of the spreadsheet.
- You can combine two worksheets from the same workbook into one data table. The column names are matched on import, so the order of the columns is irrelevant.
Import a Microsoft Excel File with Hierarchical Headings

In an Excel worksheet, multiple header rows can have an implied hierarchy; the second header row contains data that are categories of the first header row. Figure 3.8 shows an example. In the worksheet at the top, the seasons “Winter” and “Spring” are in spanned cells above the months within those seasons. In the JMP data table, you want the seasons in one column and their corresponding months in another column.

Figure 3.8 The Original Data in Excel and Final Data in JMP for 2009
To import the worksheets and maintain multiple column hierarchies, follow these steps.

1. In JMP, select **File > Open**.

2. In the Open Data File window, select Texas Precipitation.xlsx, located in the JMP Samples/Import Data folder, and then click **Open**.

   The worksheet opens in the Excel Import Wizard, where a preview of the data appears along with import options.

**Figure 3.9** Excel Import Wizard Preview

![Excel Import Wizard Preview](image)

**Figure 3.9** shows the default settings for this worksheet:

1. All worksheets are selected for import. Press Ctrl and click a worksheet to exclude it from the import.

2. Each season is split over several columns.
3. Under Preview Pane Refresh, make sure that **Update settings on any change** is selected. This means that the Data Preview automatically refreshes when you make changes.

4. Next to **Number of rows with column headers**, click the up arrow once. Notice that **Data starts on row** automatically updates to 3.

**Figure 3.10** Updated Settings on Page One

5. Click **Next**.

6. Next to **Data ends with row**, type 6 and press Enter. After the first three empty rows are removed from the worksheet, the data end with row 6.

**Tip:** Instead of you typing the end row number, JMP can calculate the row for you. In the Data Preview pane, select row 4. Click the plus sign next to **Data ends with row**.
Notice that **Replicate data in spanned rows** is selected by default. JMP unmerges data that were merged in the worksheet and copies the cell contents as separate categories. “TX” was originally in a merged cell. In JMP, it will be copied into separate cells.

7. Select **Treat multiple column header lines as hierarchies**.
   Each season and month in the header rows of the worksheet will become categories in the data table.

8. Click **Import**.
   The four worksheets open as separate data tables. The data tables contain a Source script, which you can run to import the data into new data tables using the same import settings (Figure 3.12). Your import settings are also saved the next time you open the worksheet in the Excel Wizard in any JMP session.
**Import Your Data**

**Chapter 3**

**Import Microsoft Excel Files**

**Figure 3.12** The Final Data

### Import a Microsoft Excel File Directly

Microsoft Excel files open in the Excel Import Wizard by default. This option is helpful when the structure of data in the worksheet is irregular. For example, you might want to exclude hidden columns or convert text in the third row to column headings.

Instead of opening spreadsheets in the Excel Import Wizard, you can select **File > Open** to open the file. JMP detects whether the first row contains labels and converts them to column headings. You can change this setting in the General preferences. The Excel Open Method preferences are in File > Preferences > General (Windows) and JMP > Preferences > General (macOS). From the Use Excel Labels for Headings list, select **Always** or **Never**.

**To set the Excel Open Method preference**

To always open Microsoft Excel files outside the wizard, change the Excel Open Method preference. Choose to open all worksheets at once or select them from a list.

**To open a Microsoft Excel file (Windows)**

1. After you set the Excel Open Method as described above, select **File > Open**.
2. To convert text in the first row to column headings, select **Always** next to **Always enforce Excel Row 1 as labels**.
3. Select the Excel Files file type, select the file, or enter the URL.
4. To import all worksheets, click Open.

   or

   To select the worksheets that you want to open, click the Open button arrow, and then select Open Selected Worksheets. Select one or more worksheets and click OK.

To open a Microsoft Excel file (macOS)
1. Select File > Open and select the file.
2. (.xls only) To convert text in the first row to column headings, select Use Excel Labels as Headings.
3. (.xls only) To open specific worksheets, select Select Individual Excel Worksheets.
4. Click Open.

   If you chose to open specific worksheets, select those worksheets from the list, and then click OK. You can also click Select All if you change your mind and want to import all worksheets.

If you selected an .xlsx file, a preview of the data appears in the Excel Wizard. See “Preview and Import Microsoft Excel Data”.

Import Text Files

You can open text files in JMP with the extensions .txt, .csv, and .tsv, and the text is converted to a data table. Files with the .dat extension that consist of text are also supported. Text files can be delimited using almost any character, or they can be fixed-width files.

Trailing whitespace is removed when you import text files into JMP.

When JMP finds an integer in the text file that is greater than 9,007,199,254,740,991, the column is considered character data. You can set the column to numeric using the Text Import Wizard window or an import script.

**Tip:** You can import more than one text file at a time using the Multiple File Import option. See “Import Multiple Files”.

To adjust import settings, choose from one of the following options

- Select File > Preferences > Text Data Files to change the import settings so that JMP determines the best way to structure and format the data table.
- Manually select the import settings as you open the file (described in this section).
• Open the file in the Script Editor, edit the content, and then import the content. This option is helpful when you need to add text delimiters or modify the text.

To import a text file

1. Select File > Open.
2. On Windows, you can set the file type to Text Files.
3. Select the text file that you want to open.
   
   For information about the options, see Table 3.1 and Table 3.2.

Table 3.1 Opening Text Files on Windows

<table>
<thead>
<tr>
<th>Automatically Determining Data Arrangement</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select File &gt; Open.</td>
<td>1. Select File &gt; Open.</td>
</tr>
<tr>
<td>2. From the list next to File name, select Text Files.</td>
<td>2. From the list next to File name, select Text Files.</td>
</tr>
<tr>
<td>3. To use the import rules from the preferences, select Data, (Using Preferences). (See “Preferences for Importing and Exporting Text Files”.)</td>
<td>3. Select Data (Using Preview) next to Open as at the bottom of the window.</td>
</tr>
<tr>
<td>To have text import use its best guess to arrange the data, select the Data (Best Guess) option.</td>
<td>4. Select the file that you want to open.</td>
</tr>
<tr>
<td>(Optional) Select the Select this filter the next time this window is invoked option to apply the filter that you chose by default.</td>
<td>5. Click Open.</td>
</tr>
<tr>
<td>4. Select the file that you want to open.</td>
<td>6. Complete the Text Import window. See “Options in the JMP Text Import Wizard”.</td>
</tr>
<tr>
<td>5. Click Open.</td>
<td>7. Click Import.</td>
</tr>
</tbody>
</table>

Tip: The JMP Home window provides a shortcut to the above steps if you recently opened the file. Right-click the file in the Recent Files list and select Import (Preferences) or Import (Best Guess). (Your import preference is bolded in the right-click menu.)
### Chapter 3
Using JMP

#### Import Your Data

### Import Text Files

#### Notes:
- On Windows, JMP can open text files in your computer’s default text editor. Select **File > Open**, and then select **All Files (*.*)** from the **File name** list. Select the text file, and then select **Use default program to open. Uncheck to open as text.**

- If you cancel the import while JMP is scanning the data, data is imported based on what JMP detected. The data might not appear as you expect. For example, you might see missing values in a column that was incorrectly detected as numeric. If you cancel the import *after* the data is scanned, only the data read up to that point is imported.

For more information about importing text from a Script window, see “Import Text from the Script Editor”.

#### Find Missing Characters in Imported Data

JMP attempts to detect the character encoding in your document. Sometimes the document might use an encoding that JMP does not recognize, or JMP might have chosen the wrong encoding.

Text that JMP does not recognize is replaced with a Unicode character 🟢. Find the text by searching for `\xFfFd`.

1. In the data table, select **Edit > Search > Find**.
2. Type `\xFfFd` next to **Find what**.
3. Make sure that **Use regular expressions** is selected.
4. Make sure that **Search data** is selected.
5. Click **Find** to find the first instance.

### Table 3.2 Opening Text Files on macOS

<table>
<thead>
<tr>
<th>Automatically Determining Data Arrangement</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select <strong>File &gt; Open.</strong></td>
<td>1. Select <strong>File &gt; Open.</strong></td>
</tr>
<tr>
<td>2. Select the file that you want to open.</td>
<td>2. Select the file that you want to open. In the <strong>Open As</strong> field, select <strong>Data (Using Preview).</strong></td>
</tr>
<tr>
<td>3. In the <strong>Open As</strong> field, select <strong>Data (Best Guess)</strong> or <strong>Data (Using Preferences).</strong></td>
<td>3. Click <strong>Open.</strong></td>
</tr>
</tbody>
</table>
| 4. Click **Open.**                       | 4. Complete the Text Import Wizard window. See “Options in the JMP Text Import Wizard”.
|                                         | 5. Click **Import.**                |
6. Replace all instances with another string.

**Figure 3.13 Searching for the Unicode Character**

![Unicode Character Search Options](image)

### Options in the JMP Text Import Wizard

When you open a text file that JMP supports, JMP can show a preview of the text before opening the file as a data table. This option lets you manually arrange and format the data. For example, you can specify the end-of-line character or strip quotation marks.

JMP detects the file’s structure and shows options for importing text with either delimiters or fixed width fields. If JMP chooses the wrong file structure, click the **Delimited fields** or **Fixed width fields** radio button to import the data as the correct format. (For example, the fixed width window might appear when your file is actually delimited.)

The text import wizard options are shown in **Figure 3.14** and **Figure 3.15**.
**Figure 3.14** Text Import Wizard for Fixed Width Files

Fixed data format: click to create additional column dividers. Drag the dividers to the proper position. Drag a divider on top of another divider to delete it. The numbers at the top are the column positions and the column widths. The next step sets the column names and types.

- Delimited fields
- Fixed width fields

Charset:
- Best Guess

- File contains column names on line: [ ]
- Data starts on line: [ ]

**Subset**
- All
- Lines from start of file
- Lines from end of file
- Random lines in file
- Probability per line (0.0 to 1.0)

**Compatibility**
- Strip enclosing quotation marks
- Two-digit year rule: [2000-2099]
- Recognize apostrophe as quotation mark (not recommended)
- Use Regional Settings

Back  Next  Import  Cancel  Help
**Charset**  Select the character set used in the imported file, or let JMP detect the character set. If incorrect characters are displayed in the imported file, open the file again and select another character set.

**End of Field**  (Available only in the Delimited Import window.) Select the check boxes beside the character that marks the end of a field. Alternatively, select the check box beside Other and enter a character if the appropriate character is not listed.

**End of Line**  (Available only in the Delimited Import window.) Select the check boxes beside the character that marks the end of a line (row). Alternatively, select the check box beside Other and enter a character if the appropriate character is not listed. Note that when JMP finds double quotation marks, the delimiter rules change to look for an end double quotation mark. Other text delimiters, including spaces embedded within the quotes, are ignored and treated as part of the text string.

**File contains column names on line**  Tell JMP where to find data to use as column names. For example, if the column names in your text file are on line (row) 3, select this option and type 3 in the check box. Otherwise, JMP uses the data in the first line of the imported file as the column name in the JMP data table or takes the first line as data.

**Data starts on line**  Specify the number of the first line that contains data.
Number of Lines Specify the number of lines (rows) that you want to import.

Strip enclosing quotation marks (Available only on fixed-width imports.) Select this check box when you want JMP to remove quotation marks that enclose data in the text file.

Two-digit year rule Specify how to display dates that have two-digit years. Select the 100-year range in which your dates fall. For example, if the earliest date is 2/2/79, and the year is 1979, select 1970-2069. If the earliest date is 2/2/12, and the year is 2012, select 2000-2099. If dates span centuries, you must recode the dates with four-digit years before importing the data.

Recognize apostrophe as quotation mark (not recommended) (Available only in the Delimited Import window). Use this option only if your data comes from a nonstandard source that places apostrophes around data fields rather than quotation marks.

Use Regional Settings Specifies whether the operating system’s regional settings are used when importing a text file. If the option is deselected (the default setting), files that use a period for a decimal point and a comma for the value separator import correctly. You must specify the value separator in the Text Data Files import preferences.

If the file uses a comma for a decimal point, you must also set the following options: the OS regional settings must use a comma for a decimal point (Windows and macOS), or the Windows Specific Display Language preference must be set to a language that uses commas for decimal points.

When you are finished selecting the settings, click Next. The next window shows each column’s modeling type. To change the default modeling types, do one of the following:

• Click the data type icon to change the data type from numeric (integer) to character (character). Clicking the icon cycles between the modeling type and exclude (exclude). Exclude means that the column is not imported.

• To change a numeric column’s data format, select the format from the red triangle menu.

• Click the column heading to modify the text.

The top of the text import window shows a preview of the text file as it appears when imported into a JMP data file. Click the Import button to import the data.
Import Your Data

Chapter 3

Import Text Files

Figure 3.16 Text Import Wizard Window with Column Options

Note: To specify the format of dates, select the red triangle next to the column name, select Date, and then select the date format. To specify how the dates appear after you’ve imported the data, right-click the date column in the data table, select Column Info, and change the date next to Format.

7. When you are finished setting up the data, click Import to complete the text import.

Note: Both the Text Import Wizard and Multiple File Import import columns of numbers as numbers by default. If you have something like part numbers with leading zeros that you want to keep, or part numbers with more than 15 digits, you can force the column to be character. In the Text Import Wizard, you can do this column-by-column (on the second wizard pane, top of the column). In Multiple File Import, you can select the check box that causes all columns to be imported as character. (Otherwise leading zeros are not preserved, and digits beyond 15 are lost.) See “Import Multiple Files” for more information about Multiple File Import.

Edit Text Before Importing into JMP

You can open a text file in a Script window, where you edit the text. Then you can import the text as a data table. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.

Another option is opening a JMP add-in definition (.def) file as text and then editing it in a Script window.
To open a text file in a text editing window (Windows)

Files that you recently opened are listed in the JMP Home window. For most files, right-click the text file and select **Open as Plain Text** to open the file in a text editing window. JMP add-in definition files cannot be opened as plain text from the JMP Home window.

When you are opening the file for the first time, follow these steps:

1. Select **File > Open**.
2. Select **Text Files** from the list next to **File name**.

![Figure 3.17 Select Text Files](image)

3. (Optional) To set the default option file type to **Text Files**, select the check box beside **Select this filter the next time this window is invoked**.
4. Select the file.
5. Select **Plain text into Script window** next to **Open as**.
6. Click **Open**.
   
   The text appears in a Script window.

To open a text file in a text editing window (macOS)

1. Select **File > Open**.
2. Select the file.
3. Click **Options**.
4. Select **Text in the Script Editor** from the **Open As** list.
5. Click **Open**.
   The text appears in a Script window.

For more information about converting the text to a data table, follow step 3 in “Import Text from the Script Editor”.

**Import Text from the Script Editor**

You can import text from the Script Editor as a data table. The text can be in a table format (for example, from a Microsoft Word document or Web page) or in plain text format. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.
JMP uses the import settings in the preferences to determine how to structure and format the text. Some options include removing quotation marks around text and specifying the rows that contain column headings and data. See “Preferences for Importing and Exporting Text Files”.

**Note:** You can also import an entire web page as a data table. See “Import Data from the Internet or a Remote Computer”.

This section describes how to import text that you paste into the Script Editor. For more information about opening a text file in the Script Editor, see “Edit Text Before Importing into JMP”.

**To import text from the Script window**

1. Open a new Script window by selecting File > New > Script (Windows) or File > New > New Script (macOS).
2. Copy and paste the text into the Script Editor.
3. Do one of the following:
   - To import all text from the Script Editor, select Edit > Import as Data.
   - To import specific text, select the text, and then select Edit > Import as Data.

The text is imported into a JMP data table.

**Note:** To preview text that you import from the Script Editor, press Shift before you select File > Import as Data.

---

**Import Multiple Files**

Multiple File Import (MFI) imports CSV data and unstructured text files from one directory and stack them in a data table (or to import them in separate data tables). You can save the import settings as a script and then run the script when the data is updated in the future.

Multiple File Import supports the following file types:

- XLSX
- CSV
- TSV
- DAT
- TXT
- SAS7BDAT
Multiple File Import can also import only one file. Table 3.3 can help you decide whether to use the standard Text Import, Multiple File Import, or JSL.

**Table 3.3** Choosing Between the Text Import Wizard and MFI

<table>
<thead>
<tr>
<th>Import Characteristics</th>
<th>One File</th>
<th>Multiple Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSV, TSV, DAT</td>
<td>Text Import has a preview wizard to help name the columns, pick date formats, and subset the data.</td>
<td>MFI can stack similar files automatically. You can change formatting later.</td>
</tr>
<tr>
<td>Unstructured text</td>
<td>MFI, possibly in JSL with <strong>Load Text File()</strong>.</td>
<td>MFI</td>
</tr>
<tr>
<td>Large files over 100MB</td>
<td>You can use the Source script from a previous Text Import to speed up the next import.</td>
<td>MFI imports in parallel and might be much faster than Text Import.</td>
</tr>
<tr>
<td>Unsure about format</td>
<td>Text Import might be able to guess. The preview wizard lets you see the results before the text is imported.</td>
<td>MFI does not guess. You specify the tab delimiters. There is no preview, but select <strong>Keep dialog open</strong>, and it is easy to try different import settings.</td>
</tr>
<tr>
<td>Pictures</td>
<td>Try the JSL <strong>Open()</strong> function.</td>
<td>MFI understands PNG, JPG, and GIF files. You’ll get a table with a picture column.</td>
</tr>
</tbody>
</table>
To import multiple files, follow these steps:

1. Place the files that you want to import in the same directory.
   This example uses import data found in the JMP Samples/Import Data folder.
2. Select **File > Import Multiple Files** (Windows) or **File > Open Multiple** (macOS).
3. Browse to select the JMP Samples/Import Data folder.
4. In the **Select Files by name or extension** box, type UN*.csv and press Enter.
   In this example, the files have the UN prefix and are CSV files.
   The Files list updates to show which files have been selected.
   Specify multiple file names and extensions by separating them with semicolons, or click **Add Extension** and select an extension.

---

**Table 3.3 Choosing Between the Text Import Wizard and MFI** *(Continued)*

<table>
<thead>
<tr>
<th>Import Characteristics</th>
<th>One File</th>
<th>Multiple Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP, XLSX, and JSON</td>
<td>Try the JSL <code>Open()</code> function.</td>
<td>MFI opens JMP, XLSX, and JSON files using JSL <code>Open()</code> and will stack them if requested. MFI does not keep the table and column scripts when it opens JMP tables, so you might need to use <code>Files In Directory()</code> and <code>Open()</code> if you need all of those scripts.</td>
</tr>
</tbody>
</table>
Figure 3.19 Selected CSV Files

Notice that the Refresh button flashes if the files have changed in the directory since the last refresh.

5. Specify the columns that you want added to the data table.

By default, no extra columns are added. You might like a File Name column to show the names of the imported files. Select Add file name column.

Note: The Text Data Files preferences do not determine which options are selected in the CSV settings, although the settings are similar.

6. Keep Stack Similar Files selected because these CSV files have the same columns.

7. Click Import.

JMP applies the file name, file size, and file date and time filters to stack the files. Data with columns that contain the same column headings are imported in the same data table.
If the columns do not match, the mismatched columns are imported into a separate data table.

Figure 3.20 Imported CSV Data

Notes:

- To import hidden files, select Include hidden files.
- To import files that are in subdirectories, select Include subfolders.
- To import files in a certain size range, in the Select files by size box, type the lower and upper file size limits.
  Consider specifying the limits if you don't want to import large files over a certain limit. Specify file sizes in KB (kilobytes). One KB equals 1,000 bytes.
- To import files that were modified during a certain date and time range, in the Select files by date and time box, click the calendar button to specify the range.
- (Unstructured text files) Select Text, Whole File on One Row or Text, One Line Per Row based on how the file is structured.

Notes:

- These two options are not supported for XLSX, JSON, and JMP files.
- When you select Text, Whole File on One Row, the import includes the whole file and does not skip lines before the first data line.
- JMP creates a data table that lists the files that could not be imported (for example, SAS datasets).

Import Structured Data with Different Quoting

Sometimes export filters place something other than quotation marks around fields. You specify the delimiter in the CSV settings.
Import Your Data
Chapter 3
Import PDF Files

Text in a CSV file might contain escape sequences such as a backslash instead of doubling the quotation mark. You also specify the delimiter in the CSV settings.

Tips:

- **Keep dialog open** is off by default, but you might turn it on while testing. This enables you to import files to see what the data looks like, edit the source files if necessary, and reimport them with the same settings.

- When you import files that are not supported, a data table called “@ Unused Files” is created. The file names are listed in the Files table script. Right-click the script and select Edit. To output the file names of unsupported files in this data table, select **Add file name column** on the Multiple File Import window.

- Right-click the Files list and select Sort by Column to change the way the Files list is sorted.

- The Import button is unavailable if no files match the filters that you selected.

- JMP automatically changes the CSV settings when you select either of the two options for Text Explorer-style data (the bottom center radio buttons). A delimiter is not specified, which loads all data in one column. JMP also changes the CSV settings to not use an end-of-line character, which loads the entire file in one row. You can also change the CSV settings. If you try the manual approach, be sure to set No Headers and First Data Line to 1.

Import PDF Files

The PDF Import Wizard enables you to preview a PDF file, adjust the import settings, and view the results in the data table preview before you import the data. JMP attempts to auto-detect the data structure in the PDF file, or you can customize the structure.

**Note:** A PDF file consists of tables that contain data. In the PDF preview, the tables are outlined and selected on each page.

- “Concatenate Tables into One Data Table”
- “Concatenate Tables by Column Headers”
- “Import Tables that JMP Does Not Auto-Detect”
- “PDF Preview Red Triangle Options”
- “Data Table Preview Options”
- “PDF Preview Right-Click Options”
Chapter 3
Using JMP

Import Your Data

Import PDF Files

Concatenate Tables into One Data Table

1. Select **File > Open** and select **PDF Files** from the list next to File name.
2. Navigate to the JMP Samples/Import Data folder and double-click Food Distribution.pdf.
3. In the Import PDF Wizard, a preview of the PDF file is shown on the left. A preview of the data in a data table is shown on the right.
   The PDF file consists of one table on each page.

Figure 3.21 Initial PDF File and Data Table Preview

Note the following:
- There are seven rows at the top of the PDF that you don’t want to import.
- You also don’t want the footnotes in the last row of the PDF file.
4. In the corner of the first table, click the red triangle and select **Number of rows to use as header > Specify rows**.
5. Type 7 and click **OK**.
   In the PDF file preview, the first seven rows are selected.
   In the data table preview, the data begin on row 1.
6. In the PDF file preview, scroll down to page 2.

7. Drag the bottom of the PDF table upward until the footnotes are no longer selected (Figure 3.22).

Note: You can also simply delete the row from the final data table.

Figure 3.22 Dragging the Table to Remove Data

8. In the Table report on the right, select **Concatenate all tables into one**.

When you concatenate data tables, you combine rows from two or more data tables into one data table.

9. At the bottom, click **OK**.

The data is imported into a data table.

Figure 3.23 Final Data Table (Partial View)
Concatenate Tables by Column Headers

When a PDF file contains tabular data with the same column headers on each page, you can concatenate the tables based on the column headers.

1. Select File > Open and select PDF Files from the list next to File name.
2. Navigate to the JMP Samples/Import Data folder and double-click Iris.pdf.
   Scroll through the PDF preview and notice that the column headers are the same on each page.
3. In the Table report on the right, make sure that Concatenate tables with matching column names is selected.
4. At the bottom, click OK.

Figure 3.24  Final Data Table (Partial View)

Import Tables that JMP Does Not Auto-Detect

Sometimes tables in PDF files cannot be auto-detected. In these cases, you can drag boxes around the columns to group and divide tables.
Notice that rows in the first column were auto-detected as three tables. Drag the top edge of the third table up until it surrounds the two columns.

In the first table shown in Figure 3.27, drag the far right border to the left until only columns one and two are in the same table, and columns 3 and 4 are outside the table (Figure 3.27).
Drag a box around the remaining two columns to put them in a table (Figure 3.28).

Figure 3.28 Final Tables on Page One
PDF Preview Red Triangle Options

The section describes the red triangle options on the PDF preview pane.

Global Red Triangle

The red triangle in the upper left corner of the PDF preview window contains two options:

- **Auto-detect tables on this page**  If you previously divided or combined tables, this option reverts the changes you made so that the tables are auto-detected again.

- **Ignore tables on this page**  Removes the tables from the page. That data is not imported.

Red Triangle on Each Table

- **Ignore this table**  Removes the table. The data is not imported.

- **Number of rows to use as header**  Specifies the number of header rows in the PDF file that will not be imported as data.

- **Auto-detect tables on this page**  If you previously divided or combined tables, this option reverts the changes you made so that the tables are auto-detected again.

- **Ignore tables on this page**  Removes the tables from the page. That data is not imported.

Data Table Preview Options

This section describes options that are on the data table preview pane.

- **Auto-detect tables**  If you previously divided or combined tables, this option reverts the changes you made so that the tables are auto-detected again.

- **Ignore all tables**  Removes the tables from the PDF file. The data is not imported.

- **Minimum column count**  Avoids importing tables that have fewer columns than specified.

- **Minimum row count**  Avoids importing tables that have fewer rows than specified.

- **Concatenate all tables into one**  Combines rows from two or more data tables into one data table.

- **Individual tables**  Imports the data into multiple tables.
**Concatenate tables with matching column names** Combines rows from two or more data tables that have matching column names into one data table.

**PDF Preview Right-Click Options**

See “Red Triangle on Each Table” for descriptions of most PDF preview right-click options. The following options are also available:

- **Add column divider** Creates a column divider at the selected point. Choose this option to create a new column in the data table (for example, if the columns weren’t auto-detected).
- **Remove column divider** Deletes the column border at the selected point.
- **Add row divider** Creates a row border at the selected point. Choose this option to create a new row in the data table.
- **Remove row divider** Deletes the column border at the selected point (for example, if the rows weren’t auto-detected).

**Import XML and JSON Files**

**Preview and Import XML and JSON Data**

The XML Import Wizard imports two types of nested text data: XML and JSON files. Both kinds of files contain structured text that can be nested to represent hierarchical relationships. This wizard helps you pick out the elements of the hierarchy that hold values and elements that determine rows to build a data table.

A useful way to imagine a nested text file: the document is a book of short stories. Some of the short stories might have chapters, others only have paragraphs. Chapters have paragraphs. Paragraphs have sentences. Here’s an example of the full tree for such a book.

```xml
<book>
  <story name="car poll">
    <wheels>4</wheels>
    <para><name>chev</name></para>
    <para><name>ford</name></para>
    <para><name>volk</name></para>
  </story>
  <story name="big class">
    <para><name>ralph</name><height>6</height></para>
    <para><name>billy</name><height>5</height></para>
  </story>
  <story name="cheese" location="NC">
  </story>
</book>
```
This XML document (the book) contains three short stories; each short story is a different data table. In the following example, you choose to import only one of them at a time. This particular XML file uses paragraphs to represent rows in a table in all of the tables. Arranging content by paragraph is not required. If you wanted to import the cheese table, which is slightly more complicated than the other two, you’d probably want a variety column, containing “american” or “swiss” for each row. You would also want price and quantity columns. And you might want a column that doesn’t have a clearly defined name for the 1, 2, 3, 1, 2 values of <para>. You’d expect five rows. Finally, you might want a table variable or a column for the location NC value.

A JSON file consists of name and value pairs that are imported as column headings and data. In the following example, the first name in each string is appended to “Grocery Store Purchases” and turned into column headings, as in “Grocery Store Purchases.Item”. “avocado” is the value in the first cell of the table. The next column is named “Grocery Store Purchases.Category”, and “Produce” is the value in the first cell of the second column.

```json
{"Grocery Store Purchases": [
{"Item":"avocado", "Category":"Produce"},
{"Item":"bread", "Category":"Bakery"},
{"Item":"chocolate", "Category":"candy"}
]}
```

*To import an XML or JSON file in the XML Import Wizard*

1. Select **File > Open**.
2. Browse to JMP’s Samples/Import Data folder.
3. On Windows, set the file type to **XML Data Files**.
4. Select Book.xml and click **Open**.
   The file opens in the XML Import Wizard.
Note: “Data (Using Preview)” is selected on the Open Data File window so that the XML file opens in the wizard automatically. You can also import XML and JSON files directly. See “Import XML Files Directly”.

Determine How the Data is Imported

1. In the Row column, select the element that should create a new row in the data table. In this example, the row is created when </para> is processed, and the columns are written for that row with their current values.

Figure 3.29 Row Element Selected in the Row Column

2. In the Col column, select the data type for that column next to the Col circle.
   - location: **Character**
   - name: **Character** (both instances)
   - price: **Numeric**
   - quantity: **Numeric**

   **Tip:** The values in the Sampler column give an idea of what the data type should be.
3. In the Fill column, specify which values fill the cells.

For location and the both instances of name, click the Fill circle and select `+book/story`. This setting fills cells with the values until the node `<book>/<story>` begins again.
Figure 3.31 Fill Values Selected in the Fill Column

When adding each row to the data table, JMP decides what to do on the next row if no new value is found for a column. For example, the chapter name is not specified for each type of cheese, Missing values follow “american” and “swiss”.

- The Use Once option means use the value once and forget it; the second, third, and fifth rows would be missing if the data is not given again.
- The Fill Forever option means never forget the value but replace it with new values when found.
- You select the +book/story option in this example. This option indicates that, when the opening <book>/<story> elements are found, JMP fills in the cells until the <book>/<story> node begins again. The -<element> option refers to the closing tag of the element, which will be the point at which the node ends.

4. In the Format column, click Best next to price, select Fixed Dec, type “2” for the decimal place, then click OK.
5. In the Column Name column, rename columns as shown in Figure 3.33.
6. At the bottom of the window, click **OK**.

The data is imported in a data table as you specified.

**Figure 3.34** Final Data Table

**View the Statistics in the XML Import Wizard**

Click **Stat Cols** at the top of the XML Import Wizard to show statistics for the elements.
Occurs  The number of times the element occurs. The root element occurs once and is usually not the element to make rows from. You’ll get as many rows from the element as occur.

If you pick multiple rows, then the actual number might be less than the total of the “occurs”; elements that end right after another element ends don’t generate an extra row. For example, if you select both `<para>` and `<chapter>` as row makers, then you don’t get an extra row when the chapter ends right after the last paragraph. But you could get an extra row if there were a `<footnote>` for `<chapter>` after the last paragraph and before the end of the chapter. You’d have to select the footnote column to make that happen.

 Writes  The number of times the source has a value that could be written. If it is zero, you probably don’t want to make a column from this element, because the values would be all missing.

Unique  The number of unique values (less than or equal to the Writes value).

Repeats  The maximum number of times this element repeats within its parent element. Bigger repeat values are likely candidates to make rows. If this element repeats and is used as a column, a character column will make a list; an expression column might be even better because it uses `{lists}` (within curly brackets) to indicate where the values stop and start. A numeric column will get only one of the repeating values.

Sampler  The values for the element.

**XML Import Wizard Options**

Guess  JMP selects the settings based on the size of data table that you select. Tall guess selects an element that will make as many rows as possible (the default setting). Wide guess selects an element to make rows that will make as many columns as possible. Huge guess selects as many elements to make rows as it needs to get all of the data into the table; it might be bigger than you expect.

Undo  Reverses the last change made to the window.

Redo  Recalls the last change made to the window.

Name Col  Shows or hides the Column Name column.

Stat Cols  Shows or hides statistics for the elements in the tree.

Stack  Applies to nodes that repeat within a parent node that is creating rows. By default, extra values are stored in a single table cell separated by commas. If this option is selected, repeating values are stacked in extra rows.

Import Preview  Shows a preview of the imported data according to the options that you select.
Chapter 3
Using JMP

Import Your Data

Import XML and JSON Files

Source View  Shows the source XML document.

Script View  Shows a JSL script of the settings that you select.

Import XML Files Directly

JMP can detect the structure of an XML or JSON file and import it directly into a data table. If you don’t want to see a preview of the data in the XML Import Wizard, use this method.

1. On Windows:
   - Select File > Open.
   - Set the file type to Data Files.
   - Select the file.
   - Next to Open as, select Data (Best Guess).
2. On macOS:
   - Select File > Open and select the file.
   - Click Options on the lower left corner of the window.
   - Select Data (Best Guess).
3. Click Open.

The file opens as a data table.

If you are not satisfied with the results, consider using the XML Import Wizard to customize the import. See “Preview and Import XML and JSON Data”.

Note: You can import XML or JSON text from a script editor window by selecting Edit > Import as Data. If nothing is selected in the file, then the import is based on the file extension. If text is selected, then JMP attempts to parse the text as JSON or XML. Otherwise, the text is imported into a CSV file.

Import JSON Files Directly

A JSON file consists of name and value pairs that are imported as column headings and data. You can import a JSON files with the XML Import Wizard (“Preview and Import XML and JSON Data”) or directly.

To open a JSON file directly, follow these steps:

1. On Windows:
   - Select File > Open.
   - Set the file type to JSON Data Files.
Import Your Data

Chapter 3

Build SQL Queries in Query Builder

1. Select the file.
2. Select Data (Best Guess) next to Open as.
3. On macOS:
   a. Select File > Open and select the file.
   b. Click Options on the lower left corner of the window.
   c. Select Data (Best Guess).
4. Click Open.

The file opens as a data table.

Notes:
- The imported JSON file does not contain date, time, currency, geographic, percent, and scientific information to determine the column format. If you want to use any of these formats, right-click the numeric column, select Column Info, and change the format in the Data Type list.
- Member names in name-value pairs are case insensitive.
- The JSON import code does not use the JSON file’s numeric, Boolean, or string distinction. Instead, it determines the entire column can be numeric or not. You can explicitly specify the column as character if the guess is not what you want.
- The file cannot have an empty array element. The name must be quoted before the colon in the name-value pair.
- The JSON standard accepts decimal numbers with decimal points.

Build SQL Queries in Query Builder

Query Builder is the preferred method for selecting and importing data from a SQL database without writing SQL statements. You can preview the data before importing it into a data table. Share your queries so that other users can customize and run the queries.

Query Builder provides an alternative to writing your own queries using the File > Database > Open Table feature. However, you can also start building a query in Query Builder and then add your own SQL statements.

SAS Query Builder is also available for querying SAS data sets on SAS servers. See “Open SAS Data Sets with SAS Query Builder”.

Notes:
- Database table names that contain the characters $# -+/%&|;? are not supported.
• The Value Order column property is not supported. Consider writing a script in the Post-Query Script window to sort the rows.

Connect to a SQL Database

Set up the ODBC connection through the Windows Control Panel or inside JMP.

1. Select **File > Database > Query Builder** to display the Select Database Connection window. The Connections box lists data sources that you connected to in the current JMP session.

2. If the desired data source is *not* listed in the Connections box, click **New Connection** to choose a data source. The method of choosing a data source depends on your operating system and the ODBC driver. See “Connect to a Database”.

3. Select a table or schema from the Schemas - Tables box and click **Next**.

Query Builder examples are based on a table named SQBTest, which contains movie rental data.

Figure 3.35  Select the Database Schema

**Tip:** To find the table in a long list, enter the name in the search box above the schemas. You can also search for tables above the list of tables. The red triangle menu provides options for matching case and searching with regular expressions.

Select Tables from a SQL Database

After connecting to the SQL database, select the tables that you want to query. Either select a primary table or join several tables to query them all.
By default, JMP attempts to join tables based on key relationships that are assigned in the tables.

- A primary key identifies a column that uniquely describes the data (for example, a customer ID number). All rows from the primary table are included in your query.
- A foreign key in a secondary table matches the primary key in one of the joined tables. Only matching rows from the secondary table are included in your query.

If there are no keys, data are matched by column name, which joins the two tables. By default, only matching rows from the secondary tables are included in the query.

This example shows how to join multiple tables. However, you can also build a query using a single table. In this case, joining is not necessary.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. See “Connect to a Database”.
2. Select the schema from the Schemas - Tables list.
   If you also select a table, that table will be the primary table after you click Next.
3. In the Select Tables for Query window, select **g6_Customers** from the Available Tables list, and then click **Primary**.
   The Columns tab shows that CustID is the primary key. The data is indexed, which speeds up the query.
4. Select **g6_Movies** and **g6_Rentals** from the Available Tables list, and then click **Secondary**.
   The Left Join icon indicates that the tables were automatically joined (Figure 3.36). CustID is the primary key in g6_Customers and matches a foreign key in one of the other tables.

**Tip:** After you add a primary or secondary table, click **Add Related Tables** to add tables that have matching columns. The button is unavailable when no related tables are found or when a primary or secondary table is not selected.
Figure 3.36 shows the completed window.

**Figure 3.36  Selecting Primary and Secondary Tables**

Tip: To find the schema in a long list, enter the name in the search box above the schemas. You can also search for tables above the list of tables. The red triangle menu provides options for matching case and searching with regular expressions.

5. Click the Table Snapshot tab for each table to preview the data.
6. Below the primary and secondary tables, click **Preview Join** to see a preview of the table that was created from the specified joins.

**Tips:**

- The icon next to a secondary table indicates that the table is not joined in the query. Click the **Edit Join** button to specify the columns to join. If you cannot find columns to join, click the **Remove** button to remove the table. See “Edit the Conditions for Joining Tables”.

- On the Columns tab, the Key column might show multiple keys; some columns can be both primary and foreign keys. A unique key icon does not appear next to primary keys, because all primary keys are unique.

- On the Columns tab, the Reference is specified for foreign keys that match primary keys in another schema. The reference is the name of the schema and column.

- Click **Change Data Source** to query a different schema or database.

- To join data from different sources (for example, a database and Microsoft Excel), use Query Builder to import the database data into a data table; import the Excel data into a data table; use JMP Query Builder in the Tables menu to query and join the tables.

- When you import a table that contains a primary key, the Link ID column property is added to the column in the data table. The column property enables you to virtually join data tables. See “Virtually Join Data Tables”.

---

**Figure 3.37 Table Snapshot Tab**

![Table Snapshot Tab](image)
Edit the Conditions for Joining Tables

In the Select Tables for Query red triangle menu, Auto join Database Tables is initially selected. JMP automatically joins database tables based on key relationships or matching column names.

If there are no keys, or when column names do not match, click **Edit Join** to specify the columns to join.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

To edit the conditions for joining tables

1. Select File > New > Database Query, connect to the database, and select the SQLTest schema. See “Connect to a Database”.
2. In the Select Tables for Query window, select *g1_books* as the Primary table and *g1_charges* as the Secondary table.
   - The icon next to the secondary table indicates that the table is not joined in the query.
3. Select *g1_charges* in the Secondary table pane and click **Edit Join**.
   - The Add Condition window appears.
4. In the Left Column list, select *g1_books*.
5. Select *Book ID* from the Left Column box.
6. Select *ID* from the Right Column box.
7. Make sure that the equal sign is selected between the two boxes.

**Figure 3.38** The Add Condition Window

8. Click **Next**.

   The Edit Join window shows that non-matching rows from *g1_books* will be included in the data table. Rows that are only in *g1_charges* will be omitted.

   To do a full join and import all rows, you would select **Include non-matching rows from g1_charges**. If only one of the non-matching options is available, the database does not support full joins.

9. Click **OK**.

**Note:** The **OK** button is unavailable until all of the secondary tables are joined.
To prevent tables from joining automatically

- Deselect **Auto join Database Tables** from the Select Tables for Query red triangle menu above the primary table.
- If you frequently query large databases, deselect **Automatically join tables added to a query** in **Preferences > Query Builder** to prevent memory issues.

**Build a SQL Query**

After selecting database tables, you either import the data or build a query. Query Builder enables you to interactively create the database query rather than write SQL expressions.

After selecting database tables (and joining them if necessary), click **Build Query** to open the Query Builder window. You can continue to refine the query by selecting which columns to include and specifying criteria for sampling and filtering. You can also save the query to edit and run again later.

The columns from all database tables appear in the Available Columns list. Prefixes such as t1 and t2 (also called *aliases*) associate each column with the corresponding database table.

To skip the Query Builder step and import all data, click **Import Now** instead.

**Note:** The JMP Query Builder in the Tables menu provides many of the same options but lets you query and join JMP data tables. See “*Query and Join Data Tables with JMP Query Builder*”.

**Select Columns from the Database Table**

Suppose that you want to view movie rentals by movie genre, rating, and demographic data such as marital status and age.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. See “*Connect to a Database*”.
2. In the Select Tables for Query window, select **g6_Customers** and click **Primary**.
3. Select **g6_Movies** and **g6_Rentals** and click **Secondary**.
4. Click **Build Query** to show the Query Builder window.
6. Click **Add** on the Included Columns tab.
Chapter 3
Using JMP

Import Your Data

Using JMP
Build SQL Queries in Query Builder

Figure 3.39 Selected Columns

Select the Tables red triangle menu or click Change to choose other tables and to remove tables.

Notes:

- When a query contains eight tables or more, a search box appears above the table names near the upper left corner. To find a column in a long list, enter the name in the search box below Available Columns. The red triangle menu provides options for matching case and searching with regular expressions. To hide the search box, deselect Show Search Box from the Available Columns red triangle menu.

- Reference columns no longer appear in the Available Columns list because they are not supported in queries.

- You can change the width of the column by selecting an option from the Format list in the Included Columns list.

7. Select the SQL tab below the columns to view the SQL statements for your query. This code is saved as a data table property after you run the query.

8. Click Save in the lower right corner.
   Your work is saved as g6_Customers.jmpquery, which you can open later to return to this point or to run the query.

9. Click Run Query to import the data.
   The data table includes the following scripts:
   
   - Run the Source script to reconnect to the database and import the data. 

Figure 3.39 Selected Columns
– Run the Modify Query script to open the query in Query Builder.
– Run the Update From Database script to re-import and refresh the data.

**Tips:**

- To rename a column, double-click the JMP Name in the Included Columns tab and enter a new name.
- To rename an alias, right-click the table in the Select Tables for Query window and select **Change Alias**. Aliases are not case sensitive.
- The query runs in the background unless you deselect **Run queries in the background when possible** from the Query Builder ODBC preferences. You can also check the progress of all ODBC queries by selecting **View > Running Queries**.

**Note:** For SAS Query Builder, all queries run in the foreground.

- Deselect **Update preview automatically** if the preview loads too slowly. Click **Update** below the Query Preview tab to update the data view. Consider changing the Preview options in the JMP Query Builder preferences if you frequently work with large databases. Consider limiting the maximum number of rows that can be previewed. In the JMP Query Builder preferences, change the value of **Maximum number of rows for previews**.
- To omit duplicate rows from the database, select **Distinct rows only** on the Included Columns tab.

**Maintain Compatibility with JMP 12**

If you add a JMP 17 feature to a query, that query will no longer load in JMP 12. If you are using JMP 13, but you need to create queries that will still run in JMP 12, select **Keep this query compatible with JMP 12** in the Query Builder Preferences. After you select the option, features that create compatibility problems are hidden in Query Builder.

When you are ready to move JMP 12 queries to a later version, deselect this preference.

**Create a Computed Column**

You can create a new column from existing columns. You might calculate the mean for two columns and store the mean in a new column. Date-time values might be in the wrong format. Click the Available Columns red triangle, select **Add Computed Column**, and create the new column in the formula editor.

Suppose that you want to calculate the maximum number of times you can watch a movie during the rental period. You are querying a database that contains the length of each movie and number of days the movie was checked out. This example shows how to create a new computed column from these data.
1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. See “Connect to a Database”.

2. In the Select Tables for Query window, select **g6_Rentals** as the Primary table and **g6_Movies** as the Secondary table.

3. Click **Build Query** to show the Query Builder window.

4. Click the Available Columns red triangle and select **Add Computed Column**.
   
   The Computed Column window appears. The window contains the JMP Formula Editor.

---

**Figure 3.40** Computed Column Window with Formula Editor

---

**Notes:**

- Operators and functions are provided in the list on the left side of the Formula Editor (**Figure 3.40**). In some instances, you might need to change the server type based on your database.

- The Operators list does not provide a Concatenate (||) operator. You must type the formula in the Formula Editor box.

5. From the g6_Rentals list on the left, select **Days Out** and click the multiplication button.
6. Select the blank box, type (24 * 60, and press Enter. This formula multiplies the number of minutes in an hour by the number of minutes in day. Notice that when you type the first parenthesis, then second one is automatically inserted.

7. Click the outer box to select the entire equation and click the division button.
8. Select g6_Movies from the list on the left and then select LengthMins.

9. Click OK.
   A new column named Calc1 is created.
10. Right-click the column and select Rename Column.
11. Type MaximumTimesWatched and click OK.
12. In the Available Columns list, select MaximumTimesWatched and click Add.
13. Select t2.Name and click Add.
   On the Query Preview tab, notice that Nanny McPhee can be watched 160 times while the movie is rented.

**Group the Common Values**

You can combine (or group) common values in a column before importing the data into JMP. To group common values, select an Aggregation function to determine how the common values are calculated.

**Note:** Aggregation support is based on your database. See the database documentation.

Suppose that you are interested in the number of times a specific movie was rented. In this example, the count for each item number is calculated, and common movie values are grouped into single rows.
Note: The Query Builder examples are based on a database that is not installed with JMP.

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. See “Connect to a Database” for.

2. In the Select Tables for Query window, select **g6_Movies** as the Primary table and **g6_Rentals** as the Secondary table.

3. Click **Build Query** to show the Query Builder window.

4. In the Available Columns box, select **t1.Name** and **t2.ItemNo** and click **Add**.

5. Select **t2.ItemNo** and select **Count** from the Aggregation list.

   The Group By check box is selected for **t1.Name**. All instances of a specific movie name will be grouped into one row.

6. Click **Run Query** to import the data.

7. In the data table, right-click the Count-ItemNo column and select **Sort > Descending**.

   Scarface was rented most frequently.
Figure 3.45 Partial View of the Sorted Count-ItemNo Column

<table>
<thead>
<tr>
<th>Name</th>
<th>Count-ItemNo</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scarface</td>
<td>15991</td>
</tr>
<tr>
<td>Rambo</td>
<td>15643</td>
</tr>
<tr>
<td>Nanny McPhee</td>
<td>15289</td>
</tr>
<tr>
<td>Marmaduke</td>
<td>15255</td>
</tr>
<tr>
<td>A Bug’s Life</td>
<td>15128</td>
</tr>
<tr>
<td>Diary of a Wimpy...</td>
<td>14989</td>
</tr>
<tr>
<td>Cars</td>
<td>14905</td>
</tr>
</tbody>
</table>

Tips:
- To clear the grouped rows, select **None** from the column’s Aggregation list.
- The DISTINCT Aggregation functions show only rows that contain distinct values. Rows with duplicate values are omitted. These functions are useful when a database contains many duplicate values.

**Import a Sample of the Data**

With large databases, consider sampling the data. Sampling returns a subset of rows and decreases the query time. The database query runs, and a smaller portion of data are imported based on options that you select on the Sample tab.

Sampling methods differ based on the database vendor.
- SQL Server supports block sampling by default. A block sample takes an entire page of rows (such as all rows on pages 1 and 5). If you select 1,000 rows, approximately 1,000 rows are imported.
- Oracle and other databases support row sampling. If you select 5,000 rows, between 4,800 and 5,200 rows per sample are typically imported, based on how Oracle cycles through the data.

For major database vendors, JMP detects the capabilities and provides vendor-specific options when possible. Features that are unsupported by the vendor are unavailable on the Sample tab.

Suppose that you want to import a sample of the data. In this example, you select 5,000 random rows.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. See “Connect to a Database” for.
2. In the Select Tables for Query window, select **g6_Rentals** as the Primary table and **g6_Movies** as the Secondary table.

3. Click **Build Query** to show the Query Builder window.

4. Click the **Add All** button on the Included Columns tab.

5. Click the **Sample** tab and select **Sample this result set**.

6. Select **Random N Rows** and type 5,000.

   In the Sample By area, Blocks or Pages is the only option based on which type of sampling the database supports.

7. Click **Run Query** to import the data.

   The new data table consists of approximately 5,000 rows. With block or page sampling, you might get a sample of 4,900 rows one time and 5,600 rows the next time.

**Tips:**

- To re-create the same sample set each time you run a query, set the Seed value to any positive integer up to 64,000. Suppose that you want to query movie rentals by gender. Type 1 as the Seed value and run the query. The distribution of male customers in the results is low. Type 2 as the Seed value and run the query again. Repeat this process to find the Seed value that results in a similar distribution of males and females.

- To add individual columns to the Included Columns tab, right-click the column and select **Include Column** or click the **Add** button.

**Select Filters to Import a Subset of the Data**

Add filters to import a subset of values from the selected filters into the data table. Some filters are not available if the query is compatible with JMP 12. See “Maintain Compatibility with JMP 12”.

**Filters for Both Continuous and Categorical Columns**

**Simple Comparison**  Matches values using the specified operator.

   - Age > 14 matches ages that are greater than 14.

**Range**  Matches a range of values using the specified operator.

   - 12 ≤ Age ≤ 17 matches ages that are between 12 and 17.

**Is NULL or Is Not NULL**  Matches missing values.

   - Either NULL or not NULL matches missing values and non-missing values.

**Custom Expression**  Enables you to write your own SQL expression.
( ( ( t2.Gender IN ( 'F' ) ) AND ( t2.Age >= 20 ) AND ( t2.Age <= 50 ) ) )

matches the F Gender. It also matches Age between 20 and 50.

Filters that are Only for Categorical Columns

List Box  Displays a list box from which you select one or more values. List Box is the default filter for categorical columns based on the Query Builder preferences.

Manual List  Enables you to enter the column values.

Check Box List  Displays a check box list.

Note: List Box, Manual List, and Check Box List include a Not in list option that enables you to retrieve rows that do not match the selected values.

Contains  Matches a string that contains or does not contain the specified value. Contains Comedy OR Romance matches Comedy and Romance.

For most categorical columns, the filter is a List Box by default. For columns that contain over 1,000 levels, the Contains filter is automatically selected. You can change the number of levels in the Query Builder preferences.

Like or Not Like  Matches a string that is similar to or not similar to the specified value. Supports the % wildcard (zero or more characters) and _ wildcard (exactly one character).

Genre Like %com matches any number of characters before “com”, as in “RomCom”. To also match “Comedy”, use %com% or Contains com.

Match Column Values  Matches the specified column value. Select the table and then select the columns. The Select non-matching option enables you to filter all rows except for the selected rows. See “Import Matching Data from an Existing Data Table” for an example.

This example shows how to import data for age 30 and over customers, and movies in the RomCom and Comedy genres.

Note: The Query Builder examples are based on a database that is not installed with JMP.

1. Select File > New > Database Query, connect to the database, and select the SQBTest schema. See “Connect to a Database”.
2. In the Select Tables for Query window, select g6_Rentals from the Available Tables list, and then click Primary.
3. Select g6_Customers and g6_Movies and then click Secondary.
4. Click Build Query to show the Query Builder window.
5. In the Available Columns box, select t2.Gender, t2.Age, and t3.Genre, and then click Add on the Included Columns tab.

6. Select all columns on the Included Columns tab and click Add Selected Items to Filters.

   Filters for the columns appear in the Filters outline.

7. Set the t2.Age filter to $\geq 30$.

8. Click the t3.Genre red triangle and select Like, type %com%, and press Enter.

   The % wildcards match any number of characters before and after “com”. On the Query Preview tab, notice that movies in both the RomCom and Comedy genres are shown.

**Figure 3.46** Selecting Filters

9. Click the Filters red triangle and select All Prompt on Run.

   Users who run the query can customize the filters.

10. Click Run Query.

11. In the Query Prompts window, click OK to apply the preselected filters and import the data.

**Notes:**

- For most categorical columns, the filter is a list box by default. For columns that contain over 1,000 levels, the Contains filter is automatically selected. You can change the number of levels in the Query Builder preferences.

- The Conditional option in a filter’s red triangle menu enables you to filter data within hierarchical categories. For example, suppose that you have a State filter and a City filter.
To select a state and then display only cities that are in that state, click the City red triangle and select Conditional.

- The Inverse option at the top of the Filters list enables you to select all but the specified rows for all filters. The option is unavailable for filters that select all rows.
- “<Blank>” in the filter list indicates that the database contains a missing value for that column.
- To create a filter for large columns of categorical data, JMP attempts to determine the number of rows in the table.
  - The Query Builder preference called **Retrieve category levels for tables whose size cannot be determined** is selected by default so that JMP automatically retrieves the levels. If you deselect the preference, the Contains fallback filter type in the Query Builder preferences is selected.
  - If the categorical column has more than 1 million rows, JMP does not automatically retrieve the unique category levels for the filtered column. The Query Builder preference called **Maximum rows in table for which category levels will be automatically retrieved** supports a minimum of -1 (no limit) and a maximum value of 1 billion rows.
- The default filter for categorical columns is a list box unless the **Keep this query compatible with JMP 12** Query Builder preference is selected.

**Import Matching Data from an Existing Data Table**

You can also select rows from an open data table that match a column in your query. Consider a database of airline data. The database includes data such as flight duration and tail number. You also have a data table that includes tail number data. Use the Match Column Values filter to import only data for matching tail numbers.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select **Help > Sample Data Folder** and open **Air Traffic.jmp**.
2. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. See “Connect to a Database”.
3. In the Select Tables for Query window, select **g5_AIRLINE_ONTIMEPERF** from the Available Tables list, and then click **Primary**.
4. Click **Build Query** to show the Query Builder window.
5. Click **Add All** on the Included Columns tab.
6. Select **t1.TailNum** on the Included Columns tab and click **Add Selected Items to Filters**.
7. Click the t1.TailNum red triangle in the Filters column, select **Filter Type**, and then select **Match Column Values**.

8. Select **Air Traffic** below **Match values from table**.

9. Select the Tail Number column and then select **All rows (38,118)** from the list. The data view on the Query Preview tab updates to show the filtered values.

10. Click **Run Query** to import the data.

   The data table includes only data for rows that are in the Tail Number column.

**Write a Custom Expression to Import a Subset of the Data**

In addition to selecting filters to subset the data, you can write custom SQL expressions if you do not want to use the filters that are provided.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select the columns that you want to filter (described in “Select Filters to Import a Subset of the Data”).

2. Click the Filters red triangle and select **Add Custom Expression**.

3. Type the following text in the Custom Expression box:

   
   \[
   ( ( ( t2.Gender \: \text{IN} \: \{ 'F' \} ) \: \text{AND} \: ( t2.Age \: \geq \: 20 ) \: \text{AND} \: ( t2.Age \: \leq \: 50 ) ) )
   \]

4. Click outside the Custom Expression box to update the Query Preview tab.

   This expression matches the F Gender. It also matches Age between 20 and 50.

**Figure 3.47 Writing a Custom Filter Expression**
Sort the Selected Data

You can sort the rows in specific columns by values to control how the data appear in the data table. In this example, you sort the Married column in descending order and sort the data by age and then height.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. See “Connect to a Database”.
2. In the Select Tables for Query window, select **g4_bigclass** as the Primary table.
3. Click **Build Query** to show the Query Builder window.
4. On the Included Columns tab, click **Add All**.
5. Select **t1.age** and **t1.height** and click **Order by the Selected Items**.

   The columns appear in the Order By outline in the right column.

   The columns are sorted by **age** first (youngest to oldest) and then **height** (shortest to tallest).
6. In the Order By outline, select t1.height and then click **Sort the values in descending order**  below the columns.

   The height column is sorted from tallest to shortest.

7. Select t1.height and click **Move the Selected Items Up in the List**  .

   The height column is sorted first. Values in the age column are sorted within each level of height. For a height of 68, age is sorted from 14 to 17.
View the Query Status

On the Query Status tab, view the status of a query as it runs in the background. The query name, SQL statements, and number of processed records appear. You can stop a query at any time and view only the processed records. To view background queries from other JMP windows, select View > Running Queries. The status details are unavailable if you deselect Run queries in the background when possible from the Query Builder preferences.

Note: For SAS connections in Query Builder, all queries and query previews run in the foreground.

Write a Post-Query Script

On the Post-Query Script tab, write a JSL script that runs after you run the query. For example, you might want to import the data and then create a distribution.

```
Distribution( Column( :age, :gender ) );
```

This script is part of the Source script in the final data table.

Save and Run a JMP Query

Save your SQL query as a .jmpquery file to modify or run the query later. You are prompted to enter the password if the server connection string does not specify it. The .jmpquery file can also be opened and run by a JSL script.
After you build a query, click **Save** in the lower right corner to save the settings as a .jmpquery file. Clicking **Save** again overwrites the file with your latest changes. Clicking **Save As** saves the query in a new .jmpquery file.

**Run a JMP Query**

A query file opens in Query Builder by default, where you modify the query and then run it as needed to import the data. After you are satisfied with the query, you can configure it to run when opened instead of opening in Query Builder.

When you are building the query, select **Run on Open** from the red triangle menu next to the Query Name box in the upper left corner.

To override the Run on Open setting, press Ctrl (Windows) or Command (macOS) before opening the file from the file system. On Windows, you can also right-click the query in the JMP Home Window and select **Edit Query**.

**Use a Saved Query as a Template**

You can also use the .jmpquery file as a starting point for a new query. This option prevents you from overwriting your original query if you accidentally click **Save**. It works the same as clicking **Save As** after you modify the query.

1. Right-click the .jmpquery file in the JMP Home Window’s Recent Files list.
2. Select **Open as Template**.
3. Modify the query and click **Save** to create a new .jmpquery file.

**Note:** The .jmpquery file contains database login information. You must have set up the database connection before running the query. See “Connect to a Database”.

**Open the Selected Data**

After you specify the columns and data to import from the SQL database, click **Run Query** to open the data in a data table. The SQL statements are saved as a table variable. The following scripts are available:

- **Source**  Runs the query.

- **Modify Query**  Opens the query in Query Builder, where you can change which columns and data are imported and further customize the query.
**Update From Database**  Connects to the database to refresh the data and then run the query. If the data table and database table contain the same number of columns, values in the existing data table are updated when the database is refreshed. The existing data table is also updated when only formula columns follow the last column that is refreshed. Otherwise, the updated data appears in a new data table.

**Query Builder Red Triangle Options**

The Query Builder red triangle menu provides scripting and custom SQL options. The modify and run scripts are always automatically saved in the final data table.

- **Copy Modify Script**  Copies a script to the computer’s clipboard that lets you modify the query.

- **Copy Run Script**  Copies a script to the computer’s clipboard that lets you refresh the data and run the query.

- **Save Modify Script to Script Window**  Saves the Modify Query script to the script window.

- **Save Run Script to Script Window**  Saves the Update From Database script to the script window.

- **Run on Open**  Runs the query when you open the query file.

- **Convert to Custom SQL**  Shows the query statements in a new script editor window. You must remove prompting filters before selecting this option.

When you save the query from the Custom SQL window, the custom SQL is saved. Interactive components that were present before you customized the query are not saved. Revert to Interactive is also unavailable on the red triangle menu.

- **Keep this query compatible with JMP 12**  Makes subsequent changes to the query compatible with JMP 12. Features that cause compatibility issues with JMP 12 are hidden while you edit the query. After you deselect this option and make a change that is supported only in JMP 13 and later, this option is no longer available.

The JMP Query Builder preferences include the same option, which is deselected by default. When you open a query in JMP 17 that is marked as JMP 12 compatible, features that create compatibility problems are hidden regardless of how the preference is set.

- **Revert to Interactive**  Displays the interactive query in the Query Builder window. Changes that you made on the Custom SQL tab are not saved when you revert.
Write SQL Statements in Query Builder

Query Builder enables you to interactively create SQL queries without writing SQL statements. You can also build a query in Query Builder and then add custom statements to the query.

**Note:** The Query Builder examples are based on a database that is not installed with JMP.

1. Select **File > New > Database Query**, connect to the database, and select the **SQBTest** schema. See “Connect to a Database”.
2. In the Select Tables for Query window, select **g6_Rentals** as the Primary table.
3. Select **g6_Movies** and **g6_Customers** as the Secondary tables.
4. Click **Build Query** to show the Query Builder window.
5. Click the **Add All** button on the Included Columns tab.
6. Click the Query Builder red triangle and select **Convert to Custom SQL** and click **OK**.

   The SQL that Query Builder generated appears on the Custom SQL tab.

7. Click before the semicolon and type the following SQL statement:

   ```sql
   WHERE ( ( t2.Gender IN ( 'F' ) ) AND ( t2.Age >= 20 ) AND ( t2.Age <= 50 ) )
   ```

8. Click **Run Query** to import the data into JMP.

   The data table scripts include the custom query.

**Note:** If you select **Revert to Interactive** from the red triangle menu, the changes that you made on the Custom SQL tab are not saved. If you save the custom query and reopen it, Revert to Interactive is not available.

See “Structured Query Language (SQL): A Reference” for a brief primer of SQL statements.

Import Data from SAS

You can connect to a SAS server and work directly with SAS data sets.

Java Runtime Environment (JRE) Requirements

- On Windows, Java Runtime Environment (JRE) 7 or later must be installed on your computer to access SAS. However, JRE 7 does not need to be specified as the current version.
- On macOS, JRE 7 or later must be installed for SAS integration.
Note: On Windows, the bitness of the JRE must match that of JMP. For example, 64-bit JMP communicates with both 32-bit and 64-bit SAS if the 64-bit JRE is installed.

SAS Menu Options

The following options are in the File > SAS menu.

**Browse Data**  Browse and import data residing on a SAS Server.

**SAS Query Builder**  Select and import data on a SAS server without writing SQL statements.  See “Build SQL Queries in Query Builder”.

**Export Data to SAS**  Export JMP data tables to a SAS Server.

**Browse SAS Folders**  Browse and run SAS stored processes or open Metadata-defined data tables.

**New SAS Program**  Opens a script window for writing and submitting SAS code.

**Submit to SAS**  Sends SAS code directly from JMP to the currently active SAS server.

**Open SAS Log Window**  Opens a SAS log window for the active SAS server.

**Open SAS Output Window**  Opens a SAS output window for the active SAS server. This window shows recent SAS output.

**Server Connections**  Administer connections to SAS servers.

You can also find shortcuts for SAS options on the SAS page of the JMP Starter, and there is a SAS toolbar. You can save certain settings pertaining to SAS Integration on the SAS Integration page of the Preferences window (**File > Preferences**). For more information about setting your SAS Integration preferences, see “Preferences for Updating JMP”.

Import SAS Data Sets

SAS data sets are saved in one of many SAS formats:

- Windows supported formats are `.sas7bdat` and `.sas7bxat`.
- macOS supports reading and writing `.sas7bdat` files.
- Windows and macOS support reading and writing `.xpt` files.

When you open a data set in JMP, the file opens as a data table. JMP uses SAS variable names as column names by default. To use variable labels in a specific file on Windows, select the option when you open the file (see step 5 below).
Chapter 3
Import Your Data

Using JMP Import Data from SAS

The following ISO date formats are supported for .sas7bdat files: B8601DA, B8601DN, B8601DT, B8601DZ, B8601LZ, B8601TM, B8601TZ, E8601DA, E8601DN, E8601DT, E8601DZ, E8601LZ, E8601TM, E8601TZ, and IS8601DA. If the date format is not supported, the data is imported with the Scientific Notation format.

The following date formats are supported for .xpt files: BEST, DATE, DATETIME, DAY, MMDDYY, DOWNAME, HHMM, HOUR, TIME, YYMMDD, DDMMYY, MMSS, DTDATA, IS8601DA, E8601DA, PERCENT, and DOLLAR.

To open a SAS data set from JMP:

1. Select **File > Open**.
2. (Windows only) Select **SAS Data Sets** from the list next to **File name** as shown in **Figure 3.50**.

   **Note:** SAS variable names and formats are preserved and can be saved after changes are made to the SAS data set. See “Save JMP Data as a SAS Data Set”.

3. Select the file.

**Figure 3.50** Open SAS Data Set

Note: To select the columns to import, click the arrow on the Open button and select **Select columns**.
4. (Optional) Select any of the following options:

   **SAS variable labels**  Uses the SAS variable labels (instead of variable names) as the column names in the JMP data table.

   **SAS variable names**  Uses the SAS variable names (instead of the labels) as the column names in the JMP data table.

5. (Optional on Windows) Select any of the following options:

   **Apply table and column properties from SAS 9.4 extended attributes**  If the SAS server supports extended attributes (SAS 9.4), includes the extended attributes when storing JMP metadata. This setting overrides the SAS 9.4 Extended Attributes preference on the SAS Integration page.

   **Select this filter the next time this window is invoked**  Sets the default file type choice to the option that you select next to the File name list. If selected, the default file type will be **SAS Data Sets** the next time you reach this window.

6. (Optional) Select any of the following for a SAS Transport (.xpt) file:

   **Select member**  Lets you enter the name of a specific member, or table, for JMP to open. On macOS, select **Member Tables > Specified** and then enter the name.

   **Open all members**  Opens all members, or tables, in the transport file. On macOS, select **Member Tables > All**.

   **Save all members**  Saves the file as a JMP file as soon as you open it. The file is saved to the same directory where the SAS transport file was opened. On macOS, the option is **Save all**.

   **Select columns**  Tells JMP to open only certain columns from the transport file. Select the columns that you want to import from the list that appears. On macOS, the option is **Select columns before opening**.

7. Click **Open**.

   **Note:** If you are importing date variables from a SAS file, JMP looks for a SAS date format and translates it to a JMP date column.

---

**Create SAS Transport Files in SAS from JMP**

JMP can open SAS transport files that were saved using the SAS XPORT engine. For example, below is sample SAS code that creates a transport file called **test**.

   **Note:** **misc** and **work** are SAS libref names.
Connect to SAS from JMP

You can either connect to a SAS Metadata Server or directly to a SAS Workspace Server. Once connected to a SAS Metadata Server, you can browse through SAS servers, libraries, and data sets.

Note: SAS Server version 9.4 is the default setting in the JMP SAS Integration preferences.

To begin, select File > SAS > Server Connections. The SAS Server Connections window shown in Figure 3.51 appears. All connections are made in this window.

The following sections describe how to connect to a SAS server.
Chapter 3
Import Data from SAS Using JMP

- “Connect to a SAS Metadata Server from JMP”
- “Connect to a Remote SAS Workspace Server from JMP”
- “Connect to a SAS Environment from JMP (Windows Only)”
- “Connect to SAS on Your Local Machine from JMP (Windows Only)”

**Connect to a SAS Metadata Server from JMP**

**Note:** You can be connected to only one Metadata Server at a time. If you make a second connection, your first one is disconnected.

*To connect to a Metadata Server*

1. Select **File > SAS > Server Connections**. The SAS Server Connections window shown in Figure 3.51 appears.
2. Select the version for the SAS Server. Your SAS Metadata Server administrator should have this information.
   
   SAS Server version 9.4 is selected by default based on the JMP SAS Integration preferences.
3. Select the profile that you want to use.
   
   If you do not have a profile set up, see “To create or modify a SAS Metadata Server profile”.
4. Click **Connect**.
   
   If JMP is unable to establish a connection, an error message appears. Common reasons are invalid user names or passwords. If you need to update the information for the profile, see “To create or modify a SAS Metadata Server profile”.
5. Click **Close**.

Once you are connected to a SAS Metadata Server, you can connect to any SAS Workspace Servers that the Metadata Server offers.

*To connect to a SAS Workspace Server (Windows only)*

1. Select **File > SAS > Server Connections**. The SAS Server Connections window shown in Figure 3.51 appears.
2. Select the Workspace Server to connect to.
Figure 3.52 Open a Connection to a Workspace Server

3. Click **Connect**.

   Under Open Workspace Server Connections, the Workspace Server is shown as the current active connection.

Figure 3.53 Current Active Connection

4. Click **Close**.

To change the active connection

**Note:** The active connection is what is used to submit SAS code or handle SAS script commands.

To change the active connection, you first need to be connected to more than one server. Follow the instructions in “To connect to a SAS Workspace Server (Windows only)” to add two or more server connections.

1. In the Open Workspace Server Connections section, click the drop-down menu and select the desired server.
2. Click **Set as Active**.
3. Click **Close**.

**Tip:** You can change the active server at any time.

To disconnect from a SAS Workspace Server

1. In the SAS Server Connections window, select the Workspace Server to disconnect under Open Workspace Server Connections.
2. Click **Disconnect**.

*To disconnect from a SAS Metadata Server*

1. In the SAS Server Connections window, select the Metadata Server to disconnect.
2. Click **Disconnect**.

*To create or modify a SAS Metadata Server profile*

1. In the SAS Server Connections window, select the **SAS Server Version**.
2. Click **Manage Profiles**.
3. Click **Add** to add a new profile, or click **Modify** to change a profile’s settings.
   
   The Create Profile or Modify Profile window appears. If you are adding a new profile, all fields are empty except the Authentication domain field, which contains DefaultAuth, and the Port field. If you are modifying a profile, the fields contain the current information.

![Figure 3.54 Create or Modify a Metadata Server Profile](image)

4. Fill in the information needed to connect to a SAS Metadata Server. Your SAS Metadata Server administrator should have this information.

   **Profile name** Select a name for this profile. This name is shown in the list of profiles.

   **Description** (Optional) You can enter a short description of this profile.

   **Machine** The name of the machine that hosts the Metadata Server. (Example: myserver.mycompany.com)

   **Port** The port through which you should connect to the machine. (Example: 8561)

   **Use Integrated Windows Authentication** Select this option to use your Windows log in ID and password to access the server. When enabled, the User name and password fields are disabled. This option is disabled by default.

   **User name** Your user name for the Metadata Server.

   **Password** Your password. This is always displayed as asterisks.
**Authentication domain**  The domain you, as a user, belong to.

5. Click **Save**.

**Connect to a Remote SAS Workspace Server from JMP**

You can also connect directly to a SAS Workspace Server, instead of going through a Metadata Server.

To **connect to a Remote SAS Workspace Server**

1. Select **File > SAS > Server Connections**. The SAS Server Connections window shown in **Figure 3.51** appears.
2. Under Establish New Workspace Server Connection, select **Connect to remote SAS server on**.

**Figure 3.55**  Open a Connection to a Remote SAS Server

3. Enter the machine name and the port number. Your SAS server administrator has this information.
4. Click **Connect**.
5. Enter your user name and password in the window that appears.
6. Click **OK**.
7. Click **Close** in the SAS Server Connections window.

To **disconnect from a Remote SAS Workspace Server**

1. In the SAS Server Connections window, select the server to disconnect under Open Workspace Server Connections.
2. Click **Disconnect**.
Connect to a SAS Environment from JMP (Windows Only)

On Windows, you can connect to a SAS mid-tier (or SAS environment) if SAS Server version 9.4 is selected in JMP’s preferences and your computer or JMP has been configured correctly. (SAS Server version 9.4 is the default setting in the JMP SAS Integration preferences.)

The SAS installer should have set up your computer to find the SAS environment definition file. If not, you can enter the path to the file in the JMP preferences.

To configure your JMP preferences
1. Select File > Preferences > SAS Integration.
2. Select I want to connect to a SAS Environment and then click Configure.
3. To connect to an environment that JMP has already detected, click Automatic discovery, and then select the URL from the list if necessary.
4. To enter the path to the SAS environment definition file, click Manual configuration and enter the URL.
5. Click OK.

To connect to a SAS Environment
1. Select File > SAS > Server Connections to open the SAS Server Connections window.
2. In the Metadata Server Connection area, select Connect to a SAS Environment.
   If this option is not available, either your computer or JMP is not configured to find the environment. See “To configure your JMP preferences”.
3. Select the name of the environment from the Environment list if necessary.
4. Click Connect.
5. Enter your user name and password if prompted.

Connect to SAS on Your Local Machine from JMP (Windows Only)

You can also connect directly to SAS on your local machine.

To connect to SAS on your computer
1. Select File > SAS > Server Connections to open the SAS Server Connections window.
2. Under Establish New Connection, select Connect to SAS on this machine.
   This option is disabled if SAS is not installed on the computer.
3. Click Connect.
4. Click Close in the SAS Server Connections window.
To disconnect from SAS on your computer

1. In the SAS Server Connections window, select **Local** under Open Connections.
2. Click **Disconnect**.

Open SAS Data Sets with SAS Query Builder

SAS Query Builder is the preferred method for selecting and importing data from a SAS server. You can preview the data before importing it into a data table. You can also save the queries to modify and run later or to reference in a JSL script.

SAS Query Builder provides an alternative to opening SAS data sets with the **File > SAS > Browse Data** feature.

To open a SAS data set with SAS Query Builder, follow these steps:

1. Select **File > SAS > SAS Query Builder**.
2. In the Connect to SAS Server window, select a Metadata server or a remote server.
   - To connect to a Metadata server that you have already set up in JMP, select the server from the **Connect to metadata-defined SAS server** list.
     
     **Connect to all available libraries** is selected by default based on the SAS Integration preferences. This option connects metadata-defined SAS libraries automatically across all JMP sessions. When the Workspace Server contains a large number of metadata-defined SAS libraries, consider deselecting this option to speed up your connection to the server.
   
   - To add or configure a Metadata server, click **Manage Profiles** and follow steps in “To create or modify a SAS Metadata Server profile”.
   
   - To connect to a remote server, enter the machine name and the port number. Your SAS Metadata Server administrator should have this information.
3. Click **OK**.

The SAS Query Builder window appears.

For more information about using Query Builder, see “Build SQL Queries in Query Builder”.

Notes:

- All Query Builder queries run in the foreground.
- Extended attributes are not imported by default. To import them, modify the JMP SAS Integration preferences. Select **File > Preferences** (Windows) or **JMP > Preferences** (macOS). Select **SAS Integration** and then select **On import, apply table and column properties from extended attributes**.
- SAS Query Builder does not support local server connections.
Open SAS Data Sets through a SAS Server

Once you connect to a SAS Workspace Server, you can browse through the SAS libraries on that server and import data into JMP.

To browse the data sets on the SAS server, select File > SAS > Browse Data. The Browse SAS Data window appears.

The window is initially populated with a list of servers the SAS Metadata Server provides (if connected). Any physical and local connections are also shown (as listed in Figure 3.55).

- Select a server to see a list of libraries that server contains.
- Select a library to see a list of data sets within that library.
- Select a data set to see a list of columns within that data set.

When you close and reopen the Browse SAS Data window, the previously viewed library and data set appear in the window. However, at any time, you can select a different server from the SAS Server list and then select a library and data set.

Tip: If a server is unavailable, or if the connections failed, the server’s name is shown in light, italic text. Click it to try to re-establish the connection.

Browse SAS Data Information

You can select a SAS data set and see information about its contents before opening it using the Get Details, Column Details, and Data Preview options.
Data Preview

When you select a data set, the Data Preview outline shows you the first ten rows and columns in the data set.

**Figure 3.57 Data Preview**

![Data Preview](image)

Data Set Details

Click **Get Details** in the Browse SAS Data window to see the size and last modification date for each data set in the library. This option helps you estimate whether your computer can process the entire data set.

Column Details

To see information about a particular column in the data set, select it. The Column Details outline shows you some basic information about the data column.
### Figure 3.58 Column Details

**SAS Server:** SASApp

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product_ID</td>
<td>Name</td>
</tr>
<tr>
<td>Product_Name</td>
<td>Label</td>
</tr>
<tr>
<td>Category</td>
<td>Type (Character)</td>
</tr>
<tr>
<td>SubCategory</td>
<td>Length</td>
</tr>
<tr>
<td>Unit_Weight_Oz</td>
<td>Sort Order (Unsorted)</td>
</tr>
<tr>
<td>Case_Quantity</td>
<td>Format (DOLLAR)</td>
</tr>
<tr>
<td>Case_Price</td>
<td>Data Preview (10 of 40 rows, 8 columns.)</td>
</tr>
</tbody>
</table>

**Name**  
Column name from the SAS data set.

**Label**  
Descriptive column label. The label can be longer than the name, and is often helpful to determine what the column name means.

**Type**  
Specifies whether the column has a character or numeric data type.

**Length**  
The length in bytes of data in the column.

**Sort Order**  
How the column is sorted in SAS.

**Format**  
The format for the SAS column, such as DOLLAR. This format field also contains information about the width of formatted values and the number of decimal places.

---

### Open a SAS Data Set

You can import SAS data sets directly into JMP.

1. From the Browse SAS Data window, select a data set.
   
   By default, JMP specifies **All rows** for import.

2. Click **Import**.

The entire SAS data set is imported into a JMP data table. When SAS data is imported, JMP attempts to make the best match to the SAS format.
Import a Sample of a SAS Data Set

You can import a sample of a SAS data set directly into JMP.

1. From the Browse SAS Data window, select a data set.
2. Open the Import Options outline.

Figure 3.59  Import Options

3. If you want to import only a portion of a data set, you can do any of the following:
   – Select the first $x$ number of rows only. See “To import the first $x$ number of rows only”.
   – Select to auto-sample a specified file size. See “To import an auto-sample file of a specified size”.
   – Select a subset of the columns. See “To select a subset of columns”.
   – Construct a WHERE clause to filter the data. See “To import using a WHERE clause”.
   – Take a custom sample of the data. See “Importing a Random Sample of the Data”.

The following options are also available:

**Use labels for imported column names**  Converts SAS labels to column names.

**Add SQL table variable to imported table**  Saves the SQL table variable as a data table variable.

**Restore JMP metadata from SAS extended attributes**  Includes JMP metadata (table and column properties) that were saved in the SAS data set as extended attributes.

**To import the first $x$ number of rows only**

1. In the Import Options section, select **First $x$ rows only** and specify the number of rows to import.
2. In the Browse SAS Data window, click **Import**.
JMP imports the specified number of rows.

_To import an auto-sample file of a specified size_

1. In the Import Options section, select **Auto-sample** and specify the number of MB to import.
2. In the Browse SAS Data window, click **Import**.
   JMP imports the specified number of MB.

_To select a subset of columns_

1. In the Import Options section, click **Select Columns**.
   The Select Columns window appears.

2. Select the columns that you want to import.
   To select more than one column at a time, press Ctrl and click each column.
3. Click **Add**.
4. When you have added all the columns that you want, click **OK**.
5. In the Browse SAS Data window, click **Import**.
   Only the columns that you selected from the SAS data set are imported into a JMP data table.

_To import using a WHERE clause_

1. Click **Where**.
2. Use the WHERE clause editor to construct your WHERE clause.
3. Click **OK** to return to the Browse SAS Data window.
4. Click **Import**.
   Only the data that matches your WHERE clause are imported into a JMP data table.

For information about constructing WHERE clauses and using the WHERE clause editor, see “Use the WHERE Clause Editor”.
**Note:** If you import data using both a WHERE clause and sampling, the WHERE clause is applied first, and then a sample of the filtered data is taken.

You can also write your own SQL statements.

*To import using a custom SQL statement*

You can also open a SAS data set using a custom SQL statement.
1. Open the Custom SQL outline under the Import Options outline.

**Figure 3.61  Custom SQL**

2. Enter your SQL statement in the window.
3. Click **Execute Custom SQL**.

**Note:** Your SQL is run on the selected server but is not restricted to any selected library or data set.

**Importing a Random Sample of the Data**

You can also import a random sample of the rows of the SAS data set.

**Note:** The sampling feature requires that the SAS server has the SAS/STAT product licensed and installed. If SAS/STAT is not present, sampling is disabled.

In the Sample Imported Data area of the Import Options outline, select the **Custom random sample** check box. By default, 5% of the rows are imported. To change the random sample import settings, click the **Settings** button.
In this window, you specify any of the following:

**Sample Size**  You can set the sample size be percentage or by number of rows. To ensure that each row is sampled only once, de-select the With replacement option. To ensure that any row can be sampled and appear more than once in the imported data, select the option.

**Selecting by Column**  You can select strata by moving columns into the Strata list.

**Handling Multiple Row Sampling**  If With replacement is selected, you can specify to either add each duplicated row as a separate row or combine all duplicated rows into one row. If the second option is selected, a column is added to the table that contains a count of how many times each row was sampled.

**Setting minimum and maximum numbers of items selected**  Select the option and enter a number.

**Setting the random number seed**  Select the option and enter a seed. Specifying the seed lets you reproduce the exact same sample multiple times.

**Note:** If you import data using both a WHERE clause and sampling, the WHERE clause is applied first, and then a sample of the filtered data is taken.

**Import Options**

There are additional options that you can use to specify how SAS data is imported into JMP.

**Use labels for imported column names**  When selected, this option switches the column name, which has a limited length and might be difficult to decipher, with the column label. This option is turned off by default. To use the SAS data column names as column names in JMP, deselect this box.
Add SQL table variable to imported table When selected, this option adds SQL queries to the data table panel as a variable. This option is turned on by default. If you turn off this option, only two variables are added when you import the data table: the SAS server and the data set.

Restore JMP metadata from SAS extended attributes

Tip: If your data is password-protected, you might want to turn this option off, because your password might be shown in the SQL.

Table Variables

After you import the JMP data table, table variables appear in the upper left panel of the data table. These variables show the SAS server, data set, and the SQL query and sampling settings if applicable. There is also a source script added that lets you re-do the import at any time.

Open Password-Protected Data Sets

JMP can open SAS version 7 or higher data sets that are password protected. The passwords are not case sensitive.

To open password-protected data sets

1. Select File > Open.
2. Select SAS Data Sets from the Files of type list.
3. Select the file.
4. Click Open.
5. Enter the password and then click OK.

When the password is incorrect, you are prompted to enter it again until you get it right.

Using SAS Extended Attributes to Import Metadata

SAS extended attributes are metadata that you define in SAS code to import information such as table scripts, labels, length, and type. You associate the extended attributes with a data set or variable and define them in name-value pairs, such as _JMP_TABLESCRIPTNAME_2="OnOpen". See the SAS documentation on extended attributes at https://www.sas.com.

On export from JMP to SAS, items such as column properties and table scripts are preserved automatically. You map SAS extended attributes to JMP attributes only when importing SAS code into JMP.
Here is an example of defining extended attributes in SAS code. The attributes define a table script name and the table script itself.

```sas
/* specify two table scripts. */
%LET _DS_ATTRIBUTES=_JMP_TABLESCRIPTCOUNT=2
/* define the table script names */
_JMP_TABLESCRIPTNAME_1="Favorite Movie By State"
_JMP_TABLESCRIPTNAME_2="OnOpen"
_JMP_TABLESCRIPTVALUE_2="CurrentDataTable() << RunScript(""Favorite Movie By State"");"
/* define the OnOpen table script */
_JMP_TABLESCRIPTVALUE_1=""
/* a portion of the OnOpen table script */
Current Data Table();
New Column("max_name", Character, Width(128));
```

The following example shows how to combine PROC DATASETS with extended attributes:

```sas
%LET _DS_ATTRIBUTES = attr-name=attr-value...attr-name=attr-value;
%LET _VAR_ATTRIBUTES= var-name (attr-name=attr-value...)...var-name (attr-name=attr-value...);

PROC DATASETS NOLIST LIB=WORK;
    MODIFY AttributeReferenceTable;
    XATTR OPTIONS MAXCHUNK=100;
    XATTR SET DS &_DS_ATTRIBUTES;
    XATTR SET VAR &_VAR_ATTRIBUTES;
RUN;
QUIT;
```

See “Conventions for Mapping JMP Attributes to SAS Extended Attributes” for more information about SAS extended attributes and their corresponding JMP attributes.

Two SAS Integration preferences determine whether extended attributes are imported or exported. Select **On export, store table and column properties in extended attributes to export extended attributes**. Select **On import, apply table and column properties from extended attributes**. The options are deselected by default.

To see an example of exporting extended attributes, run the following script:

```sas
dt = Open("$SAMPLE_DATA/Big Class.jmp");
sd = dt << Make SAS Data Step Window( SaveJMPMetadata( 1 ) );
```
Run Stored Processes

Stored processes are SAS DATA step code saved on the SAS server that you are connected to. You can run them from JMP and see the results of the script.

**Note:** Depending on the preferences that you have set for SAS, error messages are sent either to the JMP log or to a separate SAS log window.

You must be connected to a Metadata Server to view and run stored processes. If you select **File > SAS > Browse SAS Folders** without such a connection, you are prompted to either make a connection or cancel your action.

To select and run a stored process

1. Select **File > SAS > Browse SAS Folders**.
   
   The Browse SAS Folders window appears.
2. Browse through the stored processes to find the one that you want to run.
3. Select it and click **Run**.
   
   The data opens as a JMP data table.

On Windows, you can also right-click a stored process and select **Copy Metadata Path**. This option copies the path to the clipboard. You can then paste it into a script window to include it as a parameter for the JSL operator `Meta Get Stored Process()`. See the **JSL Syntax Reference**.

**Note:** Static graphs might not appear in the results returned from a SAS stored process when streaming output is selected.

Stored processes send reports to HTML by default, but you can select RTF or PDF instead on the SAS Integration page of the JMP preferences. Select **File > Preferences** (Windows) or **JMP > Preferences** (macOS) to view the JMP preferences.

Submit SAS Code

You can submit SAS code directly from JMP to the currently active SAS server. If the submitted SAS code generates SAS Listing output, that output is automatically retrieved from the SAS server and displayed in JMP. Also, the generated SAS Log is retrieved, and, if there are any errors in the submitted code, the SAS Log is automatically displayed in the SAS Log window.
All analyses in JMP are run natively within JMP without any dependency on the SAS System. The SAS code that JMP generates is intended to enable you to perform a separate but similar analysis in the SAS System after the initial JMP analysis, or to score new observations in the SAS System using a model that was fit within JMP.

**Figure 3.63** SAS Code Submission Example

<table>
<thead>
<tr>
<th>SAS Code</th>
<th>JMP Code to Submit SAS Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>data a; x=1;</td>
<td>SAS Connect(&quot;sasmain&quot;); SAS Submit(&quot;data a; x=1; proc print; run;&quot;);</td>
</tr>
<tr>
<td>proc print; run;</td>
<td></td>
</tr>
</tbody>
</table>

The following JMP platforms generate SAS code:

- Standard Least Squares - PROC GLM
- REML - PROC MIXED
- Stepwise - PROC GLM
- Nominal and Ordinal Logistic - PROC LOGISTIC
- GLM - PROC GENMOD
- Time Series (ARIMA and TFM) - PROC ARIMA
- Neural - SAS Data Step scoring code
- Partition (Decision Tree, Bootstrap Forest, Boosted Tree) - SAS Data Step scoring code

**Note:** Use the JSL function *As SAS Expr(formula);* to turn any prediction formula into an expression that can be used in a SAS Data Step. See the *JSL Syntax Reference.*

**To run SAS code directly from JMP**

1. Either open an existing SAS program using *File > Open,* or create a new SAS program. (Create a new SAS program by selecting *File > SAS > New SAS Program* and typing in the SAS code.)

2. Click the *Submit to SAS* icon.
   You can also right-click in the Program Editor window and select *Submit to SAS.* The menu item also includes the name of the active SAS server that the SAS code will be submitted to.
   You can also press F8 (press Command+Shift+R on macOS).
To run SAS code using a JSL script

Write and run a JSL script that uses either the SAS Submit or SAS Submit File JSL functions. For more information about writing JSL scripts that submit SAS code, see the Scripting Guide.

To view the SAS Listing output

If the submitted SAS code generates SAS Listing (textual) output, that output is automatically be displayed in a SAS Output window when the job is completed. If you need to view the SAS Listing output again later in the JMP session, select File > SAS > Open SAS Output Window. The SAS Output Window retains the listing output from the previous 25 submits to the active SAS server.

To view the SAS log

If the submitted SAS code contained errors, the SAS Log window for the active SAS server is automatically opened, displaying the SAS Log for the job. However, you can view the SAS Log for the most recent 25 submits to the active server at any time by selecting File > SAS > Open SAS Log Window.

If you prefer that SAS Log information is appended to the JMP log after a submit completes:

1. Select File > Preferences (Windows) or JMP > Preferences (macOS).
2. Open the SAS Integration category.
3. In the Show SAS Log section, select JMP Log rather than Separate Window.

Also, in the Show SAS Log section, you can set whether the SAS Log should be displayed Always, Never, or On Error (the default).

Generate ODS Results

The SAS Output Delivery System (ODS) is a powerful mechanism for generating reports in HTML, RTF, PDF, and other formats. ODS output is generally much more attractive and customizable than plain-text SAS Listing output. You can set your submitted SAS code generate ODS results rather than SAS Listing output using Preferences.

To generate ODS results from your submitted SAS code

1. Select File > Preferences (Windows) or JMP > Preferences (macOS).
2. Open the SAS Integration category and find the large SAS Submit Options group.
Import Your Data

Chapter 3
Import Data from SAS

Figure 3.64 SAS Submit Options in Preferences

3. Select the **Automatically generate ODS results** option.
4. From the **ODS Result Format** list, select the format in which to generate the ODS results: HTML, PDF, RTF, or a JMP report.
5. (Optional) You can use other options to specify a style or style sheet to format the results or set the format for generated graphics. See “Preferences for Updating JMP”.

Performing the previous steps causes JMP to generate additional SAS code, including an ODS statement, that is wrapped around the SAS code that you submit. The SAS code that you submit then automatically generates ODS results in the specified format. Those results are downloaded to your computer and displayed either within JMP, when possible, or in an appropriate external application.

**Import Generated SAS Data Sets**

SAS code that you submit might generate SAS data sets. You can have them automatically imported into JMP for further analysis.

1. Select **File > Preferences** (Windows) or **JMP > Preferences** (macOS).
2. Open the SAS Integration category.
3. Select the **Import generated SAS data sets into JMP** option.

**Export JMP Data Tables to SAS**

You can export JMP data tables to a SAS Workspace Server.

1. Connect to the SAS Workspace Server.
2. Open the file that you want to export.
3. Select **File > SAS > Export Data to SAS**.

If necessary, you are connected automatically using your profile’s user name and password.
4. Select the data table that you want to export to SAS from the list of open data tables under Select Data to Export.

Figure 3.65 Export Data to SAS

5. (Optional) To export only some of the columns in the data table, click Select Columns. See “To select columns to export”.

6. Select the Destination Server.

7. Select the Library.

Tip: If your libraries do not appear, see “Show Libraries in the Export Data to SAS Window”.

A list of the data sets in the library appears.

8. Enter the name as you want it to appear in the SAS library.

9. (Optional) Set the export options that you want to use. See “Export Options”.

10. Click Export.

To select columns to export

1. To export only some of the columns in the data table, click Select Columns.

2. In the window that appears, select the columns to export and click Add.

3. When all the columns have been added to the Selected Columns list, click OK.
Export Options

**Ignore 'excluded' row state (export all rows)**  Select this option to export all rows in the data table. Deselect this option to export only those rows that are not excluded. This option is on by default.

**Preserve SAS variable names**  This option is useful for data tables that were imported originally from SAS. When importing a SAS data set, the original SAS variable name is saved in a column property for each column. Select this option to use the SAS variable name for each column when exporting to SAS. Deselect this option to export the JMP variable names. This option is off by default.

**Preserve SAS formats**  This option is useful for data tables that were imported originally from SAS. When importing a SAS data set, the original SAS format and informat is saved in a column property for each column. Select this option to use the SAS format and informat for each column when exporting to SAS. Deselect this option to export the JMP formats instead. This option is on by default.

Show Libraries in the Export Data to SAS Window

If your libraries do not appear in the Export Data to SAS window, define the library in one of the following ways:

- Using JSL, submit code to the SAS server. The code defines a library using a `libname` command.
- Define an `autoexec.sas` file that runs a snippet of SAS code every time SAS is invoked. This creates the same `librefs` every time you connect to SAS. For more information about `autoexec.sas` files, see the SAS documentation.

Libraries that are defined in metadata (such as libraries defined in the SAS Management Console under the Data Library Manager) cannot be accessed from the Export Data to SAS window.

Import Data from a Database

You can import data from a database if you have an ODBC (Open Database Connectivity) driver for the database and then save the data back to the database.

You can use Structured Query Language (SQL) statements to control what you import from an external database. When you open a database file in JMP, you are actually sending a SQL statement to the database. By default, this statement gets all columns and records in the database table. See “Build SQL Queries in Query Builder” for more information about interactively building queries. See “Write SQL Statements to Query a Database” for more information about writing queries yourself.
This section describes how to connect to a database and import the data.

**Notes:**
- Database table names that contain the characters $#-+/%&|;? are not supported.
- Multiple connections to a datasource are not permitted.
- Use a 64-bit version of the ODBC driver to match the bitness of JMP.
- SQL Native 11 and ODBC for SQL Server 17 don’t return the column length. When a driver does not return a column length, the limit is 4MB.

**Connect to a Database**

JMP can communicate with databases using ODBC data sources using an ODBC manager. The ODBC manager and associated drivers depend on your operating system. After you create the data source in the operating system software, follow these steps to connect to the database in JMP.

1. Select **File > Database > Open Table**. The Connections box lists data sources that you have connected to in the current JMP session.

2. Click **New Connection**.

3. (Windows) In the Select Data Source window (**Figure 3.66**), click the Machine Data Source tab, select the data source, click **OK**, enter the user name and password, and then click **OK**.
   
   (macOS) In the Choose DSN window, select the data source, enter the user name and password, and then click **Choose DSN**.

**Figure 3.66** Select a Data Source (Windows)

<table>
<thead>
<tr>
<th>Data Source Name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>dBASE Files</td>
<td>User</td>
<td></td>
</tr>
<tr>
<td>Excel Files</td>
<td>User</td>
<td></td>
</tr>
<tr>
<td>Movie Database</td>
<td>User</td>
<td></td>
</tr>
<tr>
<td>MS Access Database</td>
<td>User</td>
<td></td>
</tr>
<tr>
<td>SQL Databases</td>
<td>User</td>
<td></td>
</tr>
</tbody>
</table>

A Machine Data Source is specific to this machine, and cannot be shared. "User" data sources are specific to a user on this machine. "System" data sources can be used by all users on this machine, or by a system-wide service.

The new connection is shown in the Database Open Table window.
Open Data from a Database

After you connect to the ODBC database and select a table to import, the data is opened in a data table. Several table scripts are included in the data table.

- Run the Source script to reconnect to the database.
- Run the Update from DB script to re-import and refresh the data. If the database table has the same number of columns as the original JMP table, the values in that existing JMP table are updated in place. However, if the number of columns is not the same, then a new data table opens where the updated data is stored.
- Run the Save to DB script to save the data table to the database. The existing data in the database is replaced. This script might contain the user name and password. The preference called ODBC Hide Connection String can be set to prevent including this possibly sensitive information. Select File > Preferences > Tables (Windows) to find the preference (or JMP > Preferences > Tables on macOS).

To import data from a database

1. Select File > Database > Open Table.
   The Database Open Table window appears (Figure 3.67).
2. If you are already connected to the database, select it in the Connections box. Follow the steps in “Connect to a Database”.
   The Connections box lists data sources to which JMP is connected. The Schemas - Tables box lists schemas for those databases that support them.
Chapter 3
Using JMP


Import Your Data

Figure 3.67 Database Open Table Window

When one or more database connections are made, the list of connections shows in the Connections list.

Note: The Fetch Procedures check box is disabled if the ODBC driver does not support fetching procedures.

3. If the desired data source is not listed in the Connections box, click New Connection to choose a data source. The method of choosing a data source depends on your operating system.

4. Select the desired data source in the Connections box. The tables list in the Tables box updates accordingly. The update might take a several seconds, depending on the number of tables and the speed of the connection to the database. If your database supports schemas, tables are loaded for the first schema in the list, and on other schemas as you click them.

5. Control which tables are listed by choosing the options in the Include in Table List group of check boxes.

Note: Different drivers interpret these labels differently.

User Tables When clicked, displays all available user tables in the Tables list. User tables are specific to which user is logged on to the computer.
Views  When clicked, displays “views” in the Tables list along with all other file types that can be opened. “Views” are virtual tables that are query result sets updated each time you open them. They are used to extract and combine information from one or more tables.

System Tables  When clicked, displays all available system tables in the Tables list. System tables are tables that can be used by all users or by a system-wide service.

Synonyms  When clicked, displays all available ORACLE synonyms in the Tables list.

Sampling  Enter the percentage of rows that you want to appear in the list of tables. Selecting this option speeds up queries in large databases. JMP uses the sampling method supported by the database. The check box is unavailable when the database does not support sampling.

6. Select the desired table from the Tables list.

Note: If you are connected to a dBase database, select the database folder to which you would like to connect. Individual files are grayed out and cannot be selected.

7. Click Open Table to import all the data in the selected table, or click Advanced to specify a subset of the table to be imported. Some databases require that you enter the user ID and password to access the data.

   You might see a short delay when opening large tables. To see the status of all active ODBC queries, select View > Running Queries.

Note: If the data were previously exported to a database in JMP and contained an Expression column, the column will be imported as a Character column. Select Cols > Column Info and change the Data Type to Expression.

Write SQL Statements to Query a Database

You can use Structured Query Language (SQL) statements to control what you import from a database. When you open a database file in JMP, you are actually sending a SQL statement to the database. By default, this statement gets all columns and records in the database table. In some cases, this is too much data. When you are interested only in a subset of the table’s data, you can customize the SQL request to only request the data that you want. After you execute a SQL query, the code for the query is stored in the data table in the SQL table variable.

This section describes how to write SQL statements to retrieve data. To interactively query data without writing SQL statements, use Query Builder. You can also start creating a query in Query Builder and then add your own SQL. See “Write SQL Statements in Query Builder”.

1. Select File > Database > Open Table.

   The Database Open Table window appears (Figure 3.67).
2. Connect to the database if necessary or select an existing database connection. Follow the steps in “Connect to a Database”.

The Connections box lists data sources to which JMP is connected. The Schemas - Tables box lists schemas for those databases that support them.

**Note:** The SQL Query that you run in this window operates only on the tables and procedures that are displayed in the left panes of the window. Running unrelated SQL here has no results.

3. From the Database Open Table window, click the Advanced button to open specific subsets of a table.

4. Either type in a valid SQL statement, or modify the default statement. Figure 3.68 shows a default SQL Select statement appropriate for the selected file. See “Structured Query Language (SQL): A Reference”, for a description of SQL statements that you can use.

   Instead, you can add expressions by clicking the Where button and using the WHERE Clause editor to create expressions. See “Use the WHERE Clause Editor”.

**Figure 3.68** Reading All Variables from the Solubility Table Stored in an Excel File

5. Click Execute SQL. A JMP data table appears with the columns that you selected. See “Use Data Table Variables”.

6. To see the status of all running queries, select View > Running Queries.
Note that you can enter any valid SQL statement and click **Execute SQL** to execute the command. Valid SQL varies with the data source and ODBC driver.

**Structured Query Language (SQL): A Reference**

The following sections are a brief introduction to SQL. They give you insight to the power of queries, and they are not meant to be a comprehensive reference.

**Use the SELECT Statement**

The fundamental SQL statement in JMP is the **SELECT** statement. It tells the database which rows to fetch from the data source. When you completed the process in “Write SQL Statements to Query a Database” with the Solubility.jmp sample data table, you were actually sending the following SQL statement to your data source:

```
SELECT * FROM "Solubility"
```

The * operator is an abbreviation for “all columns.” So, this statement sends a request to the database to return all columns from the specified data table.

Rather than returning all rows, you can replace the * with specific column names from the data table. In the case of the Solubility data table example, you could select the ETHER, OCTANOL, and CHLOROFORM columns only by submitting this statement:

```
SELECT ETHER, OCTANOL, CHLOROFORM FROM "Solubility"
```

**Note:** JMP does not require you to end SQL statements with a semicolon.

JMP provides a graphical way of constructing simple **SELECT** statements without typing actual SQL. To select certain columns from a data source, highlight them in the list of columns.

**To highlight several rows**

- Press Shift and then click to select a range of column names
- Press Ctrl and then click (Windows) or press Command and then click (macOS) to select individual column names.

Note that the SQL statement changes appropriately with your selections.

Sometimes, you are interested in fetching only unique records from the data source. That is, you want to eliminate duplicate records. To enable this, use the **DISTINCT** keyword.

```
SELECT DISTINCT ETHER, OCTANOL, CHLOROFORM FROM "Solubility"
```
Sort Results

You can have the results sorted by one or more fields of the database. Specify the variables to sort by using the ORDER BY command.

```sql
SELECT * FROM "Solubility" ORDER BY LABELS
```

selects all fields, with the resulting data table sorted by the LABELS variable. If you want to specify further variables to sort by, add them in a comma-separated list.

```sql
SELECT * FROM "Solubility" ORDER BY LABELS, ETHER, OCTANOL
```

Use the WHERE Statement

With the WHERE statement, you can fetch certain rows of a data table based on conditions. For example, you might want to select all rows where the column ETHER has values greater than 1.

```sql
SELECT * FROM "Solubility" WHERE ETHER > 1
```

The WHERE statement is placed after the FROM statement and can use any of the following logical operators.

Table 3.4  WHERE Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>!= or &lt;&gt;</td>
<td>Not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less Than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>NOT</td>
<td>Logical NOT</td>
</tr>
<tr>
<td>AND</td>
<td>Logical AND</td>
</tr>
<tr>
<td>OR</td>
<td>Logical OR</td>
</tr>
</tbody>
</table>

When evaluating conditions, NOT statements are processed for the entire statement first, followed by AND statements, and then OR statements. Therefore

```sql
SELECT * FROM "Solubility" WHERE ETHER > -2 OR OCTANOL < 1 AND CHLOROFORM > 0
```
Import Your Data

Chapter 3
Import Data from a Database

is equivalent to

SELECT * FROM "Solubility" WHERE ETHER > -2 OR (OCTANOL < 1 AND CHLOROFORM > 0)

Use the IN and BETWEEN Statements

To specify a range of values to fetch, use the IN and BETWEEN statements in conjunction with WHERE. IN statements specify a list of values and BETWEEN lets you specify a range of values. For example,

SELECT * FROM "Solubility" WHERE LABELS IN ('Methanol', 'Ethanol', 'Propanol')
fetches all rows that have values of the LABELS column Methanol, Ethanol, or Propanol.

SELECT * FROM "Solubility" WHERE ETHER BETWEEN 0 AND 2
fetches all rows that have ETHER values between 0 and 2.

Use the LIKE Statement

With the LIKE statement, you can select values similar to a given string. Use % to represent a string of characters that can take on any value. For example, you might want to select chemicals out of the Solubility data that are alcohols, that is, have the OL ending. The following SQL statement accomplishes this task.

SELECT * FROM "Solubility" WHERE LABELS LIKE '%OL'

The % operator can be placed anywhere in the LIKE statement. The following example extracts all rows that have labels starting with M and ending in OL:

SELECT * FROM "Solubility" WHERE LABELS LIKE 'M%OL'

Use Aggregate Functions

Aggregate functions are used to fetch summaries of data rather than the data itself. Use any of the following aggregate functions in a SELECT statement.

<table>
<thead>
<tr>
<th>Function</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM( )</td>
<td>Sum of the column</td>
</tr>
<tr>
<td>AVG( )</td>
<td>Average of the column</td>
</tr>
<tr>
<td>MAX( )</td>
<td>Maximum of the column</td>
</tr>
<tr>
<td>MIN( )</td>
<td>Minimum of the column</td>
</tr>
</tbody>
</table>
Table 3.5 SELECT Statement Functions (Continued)

<table>
<thead>
<tr>
<th>Function</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>COUNT( )</td>
<td>Number of rows in the column</td>
</tr>
</tbody>
</table>

Some examples include:

- The following statement requests the sum of the ETHER and OCTANOL columns:
  SELECT SUM(ETHER), SUM(OCTANOL) FROM "Solubility"

- This statement returns the number of rows that have ETHER values greater than one:
  SELECT COUNT(*) FROM "Solubility" WHERE ETHER > 1

- The following statement lets you know the average OCTANOL value for the data that are alcohols:
  SELECT AVG(OCTANOL) FROM "Solubility" WHERE LABELS LIKE '%OL'

**Note:** When using aggregate functions, the column names in the resulting JMP data table are Expr1000, Expr1001, and so on. You probably want to rename them after the fetch is completed.

The **GROUP BY** and **HAVING** Commands

The **GROUP BY** and **HAVING** commands are especially useful with the aggregate functions. They enable you to execute the aggregate function multiple times based on the value of a field in the data set.

For example, you might want to count the number of records in the data table that have ETHER=0, ETHER=1, and so on, for each value of ETHER.

- SELECT COUNT(ETHER) FROM "Solubility" GROUP BY (ETHER) returns a single column of data, with each entry corresponding to one level of ETHER.

- SELECT COUNT(ETHER) FROM "Solubility" WHERE OCTANOL > 0 GROUP BY (ETHER) does the same thing as the above statement, but only for rows where OCTANOL > 0.

When using **GROUP BY** with an aggregate function of a column, include the column itself in the **SELECT** statement. For example,

```
SELECT ETHER, COUNT(ETHER) FROM "Solubility" GROUP BY (ETHER)
```

returns a column containing the levels of ETHER in addition to the counts.
Use Subqueries

Aggregate functions are also useful for computing values to use in a WHERE statement. For example, you might want to fetch all values that have greater-than-average values of ETHER. In other words, you want to find the average value of ETHER, and then select only those records that have values greater than this average. Remember that SELECT AVG(ETHER) FROM "Solubility" fetches the average that you are interested in. So, the appropriate SQL command uses this statement in the WHERE conditional:

\[
\text{SELECT } * \text{ FROM "Solubility" WHERE ETHER > (SELECT AVG(ETHER) FROM "Solubility")}
\]

Save and Load SQL Queries

After constructing a query, you might want to repeat the query at a later time. You do not have to hand-type the query each time you want to use it. Instead, you can export the query to an external file. To do this, click the Export SQL button in the window shown in Figure 3.68. This brings up a window that lets you save your SQL query as a text file.

To load a saved query, click the Import SQL button in the window shown in Figure 3.68. This brings up a window that lets you navigate to your saved query. When you open the query, it is loaded into the window.

Use the WHERE Clause Editor

JMP provides help building WHERE clauses for SQL queries during ODBC import. It provides a WHERE clause editor that helps you build basic expressions using common SQL features, allowing vendor-specific functions. For example, you do not need to know whether SQL uses ‘=’ or ‘==’ for comparison, or avg() or average() for averaging.

In addition, string literals should be enclosed by single quotes (‘string’) rather than double quotes ("string").

To open the WHERE clause editor

1. Connect to a database by following the steps in “Connect to a Database”.
2. From the Database Open Table window, click the Advanced button.
3. Click the Where button.

USE the WHERE Clause Editor to add any of the following from the work panel: expressions, functions, and terms. They are applied to the highlighted blue box.

1. Click the Table Name Browser to select a table. The columns in that table appear in the list.
2. Click the SQL Vendor Name Browser to select the type of SQL that you want to use: GenericSQL, Access, DB2, MySQL, Oracle, SQL Server, or all of the above. Perform an
action by clicking a function or operator in the list and selecting an operator from the list that appears.

**Note:** The following SQL Server data types are not supported: Binary, Geography, and Geometry.

3. Select an empty formula element in the formula editing area by clicking it. It is selected when there is a red outline around it. All terms within the smallest nesting box relative to the place that you clicked become selected. The subsequent actions apply to those combined elements.

4. Add operators to an expression by clicking buttons on the keypad.

5. (Optional) To customize your WHERE clause, select one of the options from the red triangle menu in the formula editor:

   - **Show Boxing**  Show or hide boxes around the WHERE clause terms.
   - **Larger Font**  Increase the font size of the formula.
   - **Smaller Font**  Decrease the font size of the formula.
   - **Simplify**  Simply the WHERE clause statement as much as possible.
   - **Reset panel layout**  Display the panels as shown in Figure 3.69.

The WHERE clause editor works similarly to the Formula Editor, which is described in “Create Formulas in JMP”.
A Google Sheet is a spreadsheet that is saved in your Google account. This enables you to continue to edit the spreadsheet and to share it with others.

Import data from a Google spreadsheet by logging into your Google account, copying the URL for the spreadsheet, and specifying how the data is structured. For example, you must know which row the data begin on if there are column headers.

To import data from a Google spreadsheet, follow these steps:

1. Log in to https://sheets.google.com and open the spreadsheet.
2. Copy the URL in the browser’s address bar.
3. In JMP, select File > Internet Open > Google Sheets.
4. Type your Google account name. (@gmail.com is unnecessary.)
5. Paste the URL in the spreadsheet URL or ID field.
6. Click Import.

   The data are imported into a JMP data table.

   If you are importing data using the specified Google account for the first time, you are prompted to give JMP access to your Google account.
a. Click **Allow**.

The data are imported into a JMP data table.

### About Importing Google Sheets

- Information that Google uses to authenticate your account is stored in `C:/Users/<username>/AppData/Roaming/SAS/JMP/OAuthTokens.jmp` on Windows. On Mac, `OAuthTokens.jmp` is stored in `~/Library/Application Support/JMP`. (Passwords are not stored on the computer, and access tokens are encrypted.) Storing tokens in a data table enables you to import and export data using the same Google account without providing the authentication information again. Note that a user with access to your computer’s user account has access to all of your Google spreadsheets. If the spreadsheets contain confidential information, reconsider sharing your user account.

- `<username>@gmail.com` is not required for your account name. However, if you do use it, `<username>@gmail.com` and `<user name>` are treated as separate accounts. You must enter the authentication code for both accounts when importing or exporting.

- If other users have access to your computer’s user account, they can copy `OAuthTokens.jmp` to their computer and import your spreadsheets.

- **If Display intranet sites in Compatibility View** in Internet Explorer on Windows is selected, the Google Sheet cannot be imported. To avoid this issue, follow these steps:
  1. In Internet Explorer, select the Tools button and then select **Compatibility View settings**.
  2. Deselect **Display intranet sites in Compatibility View**.

**Note:** In Google Sheets, you can select **File > Publish to the web** to publish the sheet for an audience to view. In this case, the link to the published sheet includes the `pubhtml` suffix. Use **File > Internet Open** to open these sheets. See “Import Data from the Internet or a Remote Computer”.

### Google Sheet Settings

Change the following settings, if necessary, and then click **Import** to import the sheet data.

**Sheet contains column headers**  Select if the worksheet contains rows with column headers.

**Column headers start on row**  Indicates which row the column headers begin on in the worksheet. Click the up arrow until the headers begin on the correct row, or enter the row number and press Enter.

**Data starts on row**  Indicates which row the data start on in the worksheet.
Select Sheets to Open  Deselect any sheets you don’t want to import by pressing Ctrl and clicking a sheet.

Advanced Options

Cell Range  Imports cells within the specified range (for example, G5:G17).

Import cell colors  Applies the cell coloring from the worksheet to the data table.

Suppress empty columns  Prevents empty columns from appearing in the data table.

Import SPSS Files

JMP opens SPSS files as data tables and maintains several SPSS features:

- General numeric and character data with minimal formatting are supported.
- SPSS date, datetime, and time formats are supported.
- By default, labels are converted to column headings. When you select this option, and the data contains no labels, the columns are named Column 1, Column 2, and so on.

You also have the option of selecting the conversion method for column headings when opening an SPSS file. The method that you select then overrides the preferences.

To change the default conversion method, select File > Preferences (or JMP > Preferences on macOS). On the General page, deselect Use SPSS labels for column names during import. Variable names are then imported automatically as column headings.

- The value labels that you defined in the SPSS file are saved as Value Labels column properties. The value label then appears in each data table cell instead of the original value. For more information about Value Label properties, see “Value Labels”.

- SPSS can assign certain values in a variable to be treated as missing for analyses. For example, the value 64 could be regarded as missing for a Height variable. Then, the calculation of the distribution of height would ignore values of 64. When you import SPSS, these values are included in the Missing Value Codes column property for the appropriate variable.

  Missing value ranges of up to 20 numbers are supported. If the range begins with a negative number, the numbers count down to the maximum value (for example, -10 through -5). If the range begins with a positive number, the numbers count up from the minimum value (for example, 1 through 12).

Custom currency formats selected in an SPSS file are not maintained on import. In addition, JMP does not read SPSS data that contains double-byte characters, such as non-Unicode Japanese characters.
To open an SPSS file (Windows)

1. Select File > Open.
2. From the list next to File name, select SPSS Data Files (* .sav).
3. Select the SPSS file.
4. (Optional) To specify the column headings, select one of the following Set JMP column names from options:
   - SPSS Labels creates column headings from SPSS labels.
   - SPSS Variable Names creates column headings from variable names.
5. Click Open.
   JMP opens the file as a data table.

To open an SPSS file (macOS)

1. Select File > Open.
2. Select the SPSS file.
3. (Optional) To specify the column headings, do one of the following
   - Deselect Use SPSS Labels as Headings to convert variable names to column headings.
   - Select Use SPSS Labels as Headings to convert labels to column headings.
4. Click Open.
   JMP opens the file as a data table.

Notes:

- As with importing other files, you might experience a delay when opening and saving large SPSS files.
- A pipe (|) now separates words within a multiple response in the .sav file’s SPSS label (as in “detergent|liquid”). To change the delimiter, run the following JSL script: Preference(SPSSMultiResponseDelimiter(":") ), where the colon is the new delimiter.

Import Triple-S Survey Data

Triple-S (SSS) is a specification for survey data. The survey data is stored in a pair of files: .xml or .sss, and a .csv, .dat, or .asc file. The .xml or .sss file defines the variables and describes the survey. The accompanying .csv, .dat, or .asc file contains the data gathered from each respondent.
Import Your Data

Variable labels are converted to column headings by default. To convert variable names to column headings, deselect **Use Triple-S Labels as Headings** in the JMP General preferences.

To import a Triple-S file, follow these steps:

1. Place the pair of Triple-S files in the same folder and use the same root name for both files.
2. Select **File > Open**.
3. On Windows, select **Triple-S Survey Files** from the File name list.
4. Select the SPSS file.
5. (Optional on Windows) To override the Triple-S column heading preference, select **Variable Labels or Variable Names** next to **Set JMP column names from:**.
6. Click **Open**.

   JMP opens the file as a data table.

**Note:** The default encoding is UTF-8. Triple-S files that are encoded as Windows-1252 will be imported as ISO-8859-1.

---

**Import HDF5 Data**

Hierarchical Data Format, Version 5 (HDF5) is a portable file format for storing data. An HDF5 file consists of groups and datasets. When you import the file, JMP opens a group to present the names of the inner datasets. For example, if the file contains data for a group of musical recordings with songs and artists tables, JMP prompts you to open either “songs” or “artists”. If the file does not contain a group, JMP prompts you to open a single table.

JMP handles only tables with numeric (integer, float, double) and string types, and compound files with three or fewer dimensions that contain only simple types. If a data set does not appear in the import window, the file is most likely unsupported.

You can import up to 1,000,000 columns and an unbounded number of rows.

**Note:** Only ASCII characters are supported in HDF5 files. Non-ASCII characters such as French and Chinese characters are not supported.

To import an HDF5 file, follow these steps:

1. Select **File > Open**.
2. On Windows, make sure that **All JMP Files** or **HDF5 Data File** is selected from the File name list.
3. Select the HDF5 file.

   A list of groups or datasets in the file appears.
4. In the **Filter** field, specify the criteria (as a regular expression) by which you want to filter the list of tables.

5. Select the data set that you want to import and click **Import**.

   The data are opened as data tables.

---

### Import Data from MATLAB

JMP provides a scripting interface to MATLAB. See the *Scripting Guide* and the *JSL Syntax Reference*.

### Import Data from R

JMP provides a scripting interface to R. See the *Scripting Guide* and the *JSL Syntax Reference*.

### Import Data Using the Excel Add-In

The add-in for Excel provides new capabilities to JMP and Excel users on Windows:

- Transfer selected cells in Excel to JMP data tables. See “Transfer Excel Data to a Data Table”.

- Use the JMP Profiler with calculation models in Excel workbooks. The profiler tool is designed to bring the power of the JMP profiler to models residing in Excel worksheets. You do not have to recreate your Excel models in JMP, verify that they are correct, and maintain the model in both JMP and Excel. See *Profiler*.

**Note:** During the JMP installation, select the Excel Add-In. This installs the add-in for your version of Microsoft Excel.

- Microsoft Excel 2010, Microsoft Excel 2013, Microsoft Excel 2016, Microsoft Excel 2019, and Office 365 Desktop Excel are supported.

### Transfer Excel Data to a Data Table

You can use the JMP Add In for Excel to transfer a worksheet from Excel to the following JMP destinations:

- a data table
You can also create models for profiling in JMP. See Profilers.

To transfer data from Excel to a JMP data table and platform

1. In your Excel worksheet, show the JMP add-in on the ribbon.
2. Click the Preferences button.
3. Accept the default Data Table Name (File name_Worksheet name) or type a name.
4. Select Use the first rows as column names if the first row in the worksheet contains column headers.
5. If you selected to use the first rows a column headers, type the number of rows used.
6. Select Transfer Hidden Rows if the worksheet contains hidden rows to be included in the JMP data table.
7. Select Transfer Hidden Columns if the worksheet contains hidden columns to be included in the JMP data table.
8. Click OK to save your preferences.
9. Select the cells to transfer into JMP, including any cells that you want to use as column names.
   If you are using cells as column names, they need to be the first rows in your selection.
   If only one cell (or no cell) is selected, the entire Excel worksheet is transferred to JMP.
10. Select the JMP destination from the toolbar:
    – Data Table
    – Graph Builder
    – Distribution platform
    – Fit Y by X platform
    – Fit Model platform
    – Time Series platform
    – Control Chart platform

JMP opens, and the selected data is placed in a new JMP data table and the selected launch window appears.
Notes:

- Empty cells are imported as missing data, and dates, numbers, and strings are recognized correctly.
- Your JMP windows might be hidden behind your Excel window, especially if you maximize Excel.

For more information about using the various JMP platforms, refer to the proper JMP documentation.

About the JMP Add-In for Excel

The JMP add-in commands are in two groups:

Transfer to JMP

Preferences   Set preferences for transferring data from Excel to JMP.

Data Table   Transfer the selected data in your Excel file to a JMP data table.

Graph Builder   Transfer the selected data in your Excel file to a JMP data table and launch the Graph Builder platform.

Distribution   Transfer the selected data in your Excel file to a JMP data table and launch the Distribution platform.

Fit Y By X   Transfer the selected data in your Excel file to a JMP data table and launch the Fit Y by X platform.

Fit Model   Transfer the selected data in your Excel file to a JMP data table and launch the Fit Model platform.

Time Series   Transfer the selected data in your Excel file to a JMP data table and launch the Time Series platform.

Control Chart   Transfer the selected data in your Excel file to a JMP data table and launch the Control Chart platform.

Profile in JMP

Create/Edit Model   Set up preferences for using the JMP profiler with Excel data.

Run Model   Run the JMP profiler.
Uninstall the JMP Excel Add-In

To uninstall the Excel Add-in, double-click the JMP installer, click Modify, and deselect Excel Add-In.

Import Data from the Internet or a Remote Computer

Import data from the Internet, FTP sites, or other computers by selecting File > Internet Open. A file path can start with http, ftp, or file; a drive letter; or, the path to a network drive (relative or absolute).

Using Internet Open, you can import data and images from the Internet or a remote computer and save it as a data table, web page, or text. You can also open a SAS stored process report using this option. See “Import Data from Google Sheets” for more information about using Internet Open to import a Google spreadsheet.

Suppose that you want to import data (with images) from a table on a web page and save it as a data table. The specific web page lists countries by population.

1. Select File > Internet Open > Web Page.
2. Enter the following URL:
3. Keep Open As set to Data, and click OK.
   JMP finds several tables on the specified page.
4. Click Rank country (or dependent territory)... and click OK.
   JMP opens a data table that contains the information from the web page table.
5. (Optional) To add the images to the data table, run the Load pictures script.

Notes:

- You can open a remote file as one of the following formats:
  - Data  Opens the file as a data table.
  - Web page  Opens the web page in the JMP browser (Windows) or the default browser (macOS).
    From the File menu on Windows, you can then choose to save the file or import the data as a data table. Select this option to import data that is generated by web page scripts and server-side requests.
  - Text  Opens the file in the script editor. If you imported an HTML file, the HTML tags of a web page are displayed.
• When you open a file from an FTP server, an FTP login window appears. For an anonymous account, click OK. For an authenticated login, enter your user ID and password. The file then opens as you specified.

**Note:** Some anonymous FTP servers require a user ID. If the data table does not open, try typing either “ftp” or “anonymous” in the User ID text box. Leave the Password text box empty and click **OK**.

• JMP waits 60 seconds before stopping the import due to an error. You can change the Internet Time Out setting on the General preferences page.

• If the table that you are importing contains images, the images are first imported as text. To display the images in your data table, run the automatically generated table script named **Load pictures**. A new expression column that contains the images is added to the data table.

• Running the Source script in a data table enables you to re-import and refresh the data.

*To open a SAS stored process report as a data table (Windows only)*

1. Select **File > Internet Open** and select the file.
   The file opens in the JMP browser.
2. In the JMP browser, select **File > Import Table as Data Table**.
   A window appears that lists the tables found in the web page.
3. Select the table or tables that you want to import.
4. Click **OK**.
   Each table is opened as a new data table.

See “**Run Stored Processes**” for more information about stored process reports.

---

**Create New Data Tables**

To create a new data table by entering data manually, follow these steps:

1. Select **File > New > Data Table**. This shows an empty data table with no rows and one numeric column, labeled **Column 1**.
2. Move the cursor onto a cell.
3. Click in the cell. The cursor appears as a line in the cell.
Figure 3.70  A New Data Table

4. Enter a value.

There are several ways to fill a table with values:

- Create new rows and columns and type or paste data into the data grid. (See “Enter Data in Data Tables”.)
- Construct a formula to calculate column values. (See “Create Formulas in JMP”.)
- Import data from another application. (See “About Importing Data”.)
- Copy values from another application and paste them into the table.
- Use a measuring instrument to read external measures. See in the Scripting Guide for more information about data feeds.
- Drag columns from one table to another.

See “Enter and Edit Your Data” for more information about how to format, edit, and work with data tables.

Import Data from an OSIsoft PI Server

This import functionality is built on the Web API, and requires the PI Web Server to be deployed and running. In addition, the PI Asset Framework must be installed and configured.
PI Server data is typically machine generated and collected at defined intervals. The interval time can be short, leading to large amounts of data. For example, you have a process that is being monitored. Every 15 minutes, data is collected from various sensors and this data is sent to the PI Server. In another application, sensor readings can be collected more frequently, for example, every millisecond. The table below illustrates how this can lead to a large amount of data.

Table 3.6 Example of Collected Data

<table>
<thead>
<tr>
<th></th>
<th>10</th>
<th>10</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Number of sensors</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Data Collected Every Unit of Time</strong></td>
<td>15</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td><strong>Units of Time</strong></td>
<td>Minutes</td>
<td>Seconds</td>
<td>Millisecond</td>
</tr>
<tr>
<td><strong>Units of Time per Day</strong></td>
<td>96</td>
<td>86,400</td>
<td>86,400,000</td>
</tr>
<tr>
<td><strong>Data Points per Day</strong></td>
<td>960</td>
<td>864,000</td>
<td>864,000,000</td>
</tr>
<tr>
<td><strong>Data Points per Month</strong></td>
<td>29,200</td>
<td>26,280,000</td>
<td>26,280,000,000</td>
</tr>
<tr>
<td><strong>Data Points per Year</strong></td>
<td>350,400</td>
<td>315,360,000</td>
<td>315,360,000,000</td>
</tr>
</tbody>
</table>

The PI Server can import the following types of data:

- raw data
- plot data
- interpolated data

**Connect to a PI Server**

Complete the following steps to connect to a PI Server:

1. Select **File > Database > Import from OSIsoft PI Server**. The Connect to PI Server window is displayed.
Figure 3.71 Connect to PI Server

2. Specify the URL for the PI Server.
3. Use the Authentication drop-down menu to select the authentication type from the list (None, Kerberos, or Basic).
4. If you are using Basic authentication, specify the user name and password.
5. Click **OK**.
Common Options in the Import from OSIsoft PI Server Wizard

Figure 3.72 Import from OSIsoft PI Server

Select and specify the following information, in the order in which it is listed.

**Asset server**  Select an asset server from the list of deployed servers.

**Asset database**  Select a database from the list of configured databases.
**Elements**  Select an element. The elements are displayed in a tree view that you can use to navigate to the data that you want to import.

**Attributes**  Select an attribute. Attributes can be top level or nested. Nested attributes contain a vertical bar.

**Start time**  (Optional) Specify the start of the time period during which you want to import data. This is specified using the OSIsoft PI syntax. The default start time is “*-1d”, which means one day ago.

**End time**  (Optional) Specify the end of the time period during which you want to import data. This is specified using the OSIsoft PI syntax. The default end time is “*”, which means today.

**Server timezone**  Select either the server timezone or Coordinated Universal Time (UTC). By default, this is set to server timezone.

**Series**  Select the type of series to import as Raw data, Plot data, or Interpolated data. Raw data is data collected from the sensors as it came in. This is the default value. Plot data is data that is optimized for plotting. Interpolated data is data that is optimized for aligning with defined time intervals.

### Import Raw Data from an OSIsoft PI Server

The following fields are specific to raw data:

**Max. count**  Specify the maximum number of values to retrieve from the data. This can be used as a measure to avoid unintentionally collecting a very large amount of data.

**Boundary type**  Select the behavior of data retrieval at the end points of the specified time range. The possible values are inside, outside, and interpolated. The default value is inside.

**Filter**  (Optional) Specify an expression to filter the data that is imported. Use OSIsoft’s filter expression syntax.

**Retrieve Attributes**  Select to create additional columns to indicate the good, questionable, substitution, and annotation status of each value.

Click **Import** to start importing raw data from the PI Server.

### Import Plot Data from an OSIsoft PI Server

Plot data is optimized for graphing the results. The following field is specific to plot data:

**No. of intervals**  Specify the number of intervals to fetch. You can have up to five values per interval. This value indicates how much data will be imported.
Click **Import** to start importing plot data from the PI Server.

**Import Interpolated Data from an OSIsoft PI Server**

Interpolated data is optimized for aligning data from various sources where it is important that they all have a common time stamp.

**Interval** Specify the sampling interval. The default interval is 1h (one hour). When the interval is set to one hour, data is interpolated to a value at the start of each hour.

**Sync Time** (Optional) Specify the absolute date and time from which to calculate an even set of intervals in a periodic operation.

**Sync Time Boundary Type** Select the behavior of data retrieval at the end points of the specified time range. The possible values are inside and outside. The default value is inside.

**Filter** (Optional) Specify an expression to filter the data that is imported. Use OSIsoft’s filter expression syntax.

Click **Import** to start importing interpolated data from the PI Server.

**Related Information**

- PI Web API Reference
- PI Web API Reference - Time Strings
Import Your Data

Import Data from an OSIsoft PI Server
Chapter 4

Enter and Edit Your Data

Perform Basic Data Table Tasks

After you import data into JMP or create a new data table, you can format your data to prepare it for analysis.

This chapter contains the following information:

- Change formatting for numeric values
- Add, delete, and select rows and columns
- Use the Row Editor to navigate within rows and edit rows
- Create scripts that are saved to the data table

Figure 4.1 The Rows and Cols Menus

Enter and edit data using the options in the Rows and Cols menus.
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter Data in Data Tables</td>
<td>194</td>
</tr>
<tr>
<td>Copy and Paste Data into Data Tables</td>
<td>194</td>
</tr>
<tr>
<td>Add Rows to Data Tables</td>
<td>195</td>
</tr>
<tr>
<td>Add Columns to Data Tables</td>
<td>195</td>
</tr>
<tr>
<td>Fill Data Table Columns with Sequential Data</td>
<td>197</td>
</tr>
<tr>
<td>Replace Missing Values with Previous Values in Data Table Columns</td>
<td>198</td>
</tr>
<tr>
<td>Enter Cell Formulas into Data Table Columns</td>
<td>199</td>
</tr>
<tr>
<td>Select Rows in Data Tables</td>
<td>200</td>
</tr>
<tr>
<td>Find Matching Cells in Rows</td>
<td>202</td>
</tr>
<tr>
<td>Select Rows That Contain Specific Values</td>
<td>203</td>
</tr>
<tr>
<td>Locate the Next Selected Row</td>
<td>204</td>
</tr>
<tr>
<td>Select Columns in Data Tables</td>
<td>205</td>
</tr>
<tr>
<td>How to Select Columns</td>
<td>205</td>
</tr>
<tr>
<td>Select Columns in the JMP Columns Viewer</td>
<td>206</td>
</tr>
<tr>
<td>Locate Next and Previously Selected Columns in Data Tables</td>
<td>212</td>
</tr>
<tr>
<td>Resize Rows and Columns</td>
<td>212</td>
</tr>
<tr>
<td>Organize Data in Data Tables</td>
<td>213</td>
</tr>
<tr>
<td>Delete Rows in Data Tables</td>
<td>213</td>
</tr>
<tr>
<td>Delete Columns in Data Tables</td>
<td>214</td>
</tr>
<tr>
<td>Rearrange Columns in Data Tables</td>
<td>214</td>
</tr>
<tr>
<td>Group Columns in Data Tables</td>
<td>215</td>
</tr>
<tr>
<td>Move Values in Data Tables</td>
<td>215</td>
</tr>
<tr>
<td>Color Cells in Data Tables</td>
<td>216</td>
</tr>
<tr>
<td>Edit or Delete Cells in Data Tables</td>
<td>216</td>
</tr>
<tr>
<td>Edit Column Names in Data Tables</td>
<td>216</td>
</tr>
<tr>
<td>Hide and Exclude Rows in Data Tables</td>
<td>217</td>
</tr>
<tr>
<td>Exclude Rows in Data Tables</td>
<td>218</td>
</tr>
<tr>
<td>Hide Rows in Data Tables</td>
<td>219</td>
</tr>
<tr>
<td>Exclude Columns in Data Tables</td>
<td>220</td>
</tr>
<tr>
<td>Hide Columns in Data Tables</td>
<td>220</td>
</tr>
<tr>
<td>View Patterns of Missing Data in Data Tables</td>
<td>221</td>
</tr>
<tr>
<td>Find and Replace Cell Values in Data Tables</td>
<td>223</td>
</tr>
<tr>
<td>Edit Cells in Data Tables</td>
<td>225</td>
</tr>
<tr>
<td>Right-Click Menus for Rows and Columns</td>
<td>227</td>
</tr>
<tr>
<td>Compare Data Tables</td>
<td>227</td>
</tr>
<tr>
<td>Assign Characteristics to Rows and Columns</td>
<td>234</td>
</tr>
<tr>
<td>How to Find Options for Rows and Columns</td>
<td>234</td>
</tr>
<tr>
<td>Label Rows and Columns</td>
<td>234</td>
</tr>
<tr>
<td>Assign Colors or Markers to Rows</td>
<td>235</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Create Color Themes in Graphs</td>
<td>237</td>
</tr>
<tr>
<td>Delete Custom Color Themes in Graphs</td>
<td>243</td>
</tr>
<tr>
<td>Select Matching Row State Cells</td>
<td>243</td>
</tr>
<tr>
<td>Delete Row Characteristics</td>
<td>244</td>
</tr>
<tr>
<td>Lock Columns</td>
<td>244</td>
</tr>
<tr>
<td>Restructure Data</td>
<td>244</td>
</tr>
<tr>
<td>Split a Data Table Column into Multiple Columns</td>
<td>245</td>
</tr>
<tr>
<td>Create a New Column by Text Matching</td>
<td>245</td>
</tr>
<tr>
<td>Make Indicator Columns</td>
<td>247</td>
</tr>
<tr>
<td>Combine Columns in Data Tables</td>
<td>248</td>
</tr>
<tr>
<td>Compress Selected Columns in Data Tables</td>
<td>249</td>
</tr>
<tr>
<td>Make a Binning Formula in a Data Table Column</td>
<td>250</td>
</tr>
<tr>
<td>Convert Labels to Codes and Codes to Labels</td>
<td>255</td>
</tr>
<tr>
<td>Make a New Formula Column</td>
<td>256</td>
</tr>
<tr>
<td>Transform Columns in a JMP Platform</td>
<td>256</td>
</tr>
<tr>
<td>Recode Data in a Column</td>
<td>266</td>
</tr>
<tr>
<td>Edit Data Tables</td>
<td>283</td>
</tr>
<tr>
<td>Rename Data Tables</td>
<td>283</td>
</tr>
<tr>
<td>Lock Data Tables</td>
<td>283</td>
</tr>
<tr>
<td>Compress Data Tables</td>
<td>284</td>
</tr>
<tr>
<td>Copy Table Scripts</td>
<td>284</td>
</tr>
<tr>
<td>Use Data Table Variables</td>
<td>285</td>
</tr>
<tr>
<td>Create and Save Scripts in Data Tables</td>
<td>286</td>
</tr>
</tbody>
</table>
Enter Data in Data Tables

This section describes how to add rows and columns, fill columns with sequential data, and enter cell formulas.

- “Copy and Paste Data into Data Tables”
- “Add Rows to Data Tables”
- “Add Columns to Data Tables”
- “Fill Data Table Columns with Sequential Data”
- “Replace Missing Values with Previous Values in Data Table Columns”
- “Enter Cell Formulas into Data Table Columns”

Tip: Consider setting the Autosave Timeout value in the General preferences to automatically save open data tables at the specified number of minutes. This autosave value also applies to journals, scripts, projects, and reports.

Copy and Paste Data into Data Tables

When you paste data from another document into a data table, JMP adds rows and columns as needed. Click a cell and paste the data.

Multiple Lines of Data

When you copy one data table cell and paste several lines of data, each line is pasted into its own cell.

To paste all lines into one cell, do one of the following:

- Double-click an existing cell first and then paste.
- Right-click an existing cell and select Paste into Cell. The Paste into Cell option is available only on character and expression columns.

Note: If you try to paste into a cell that does not exist, the text will paste into separate cells.

The data type of the copied content needs to match the data type of the cells that you’re pasting into. You can add new columns and paste the data, paste the data into cells of the correct data type, or change the data type of the cells if necessary.

Note: To copy the entire numeric value, select Edit > Copy With Full Precision. The option applies only to the fixed decimal format.
Add Rows to Data Tables

To add any number of rows to the data table

1. Select Rows > Add Rows.
2. Enter the number of rows to add.
3. Specify where to add the new rows (at the start or end of the data table, or after a specific row).
4. Click OK.

To add a single row to the end of the data table

- Below the last row, click anywhere in a cell and begin typing.
- Below the last row, double-click in the empty row number area.

Add Columns to Data Tables

There are several ways to add new columns to a data table:

- Double-click the empty space to the right of the last data table column to add one column. See “About the Column Info Window” for more information about changing attributes after you add the column.
- Select Cols > New Columns. Use this option to add one or more columns and change their attributes.
- Double-click the upper triangle in the data grid above the row numbers. The Add Multiple Columns window appears.

Notes:

- When you initially create a column, you can choose to fill it with initial data values. See “Initialize Data in a Column”. However, after you modify the cells, this option no longer appears.
- If any rows are selected in the data table, double-clicking to create a new column deselects the rows. Using Cols > New Columns to create a new column will not change the row selection.
- You cannot edit the data in the columns of a By group or a linked subset.

To add one or more columns using New Columns

1. (Optional) Select the column before or after which the new column or columns are added.
2. Select Cols > New Columns.
3. Change the column name.
By default, the new column names are Column 1, Column 2, and so on.

4. Select the data type, modeling type, and format for all of the columns. See “About the Column Info Window”.

5. (Optional) Select initial data values for all of the columns. See “Initialize Data in a Column”.

6. Specify where you want to put the new columns. If you do not select an option, the column is added after the last column.

7. (Optional) For multiple columns, specify whether the columns should be grouped. See “Group Columns in Data Tables”.

8. To add more columns, follow these steps:
   a. Click Apply to add the new column.
   b. Click Next, change the column properties, and then click Apply.
   c. Click Next to add another column.

9. Click OK to save your changes.

**Figure 4.2** The New Column Window

**Tip:** To change the modeling type after the columns are created, click the modeling type icon in the Columns panel and select a different type.

*To add one or more columns using Add Multiple Columns*

1. Double-click the upper triangular area in the data grid. The Add Multiple Columns window appears.
Figure 4.3 Adding Multiple Columns

2. Change the prefix for each column.
   By default, the new column names are Column 1, Column 2, and so on.
3. Enter the number of columns to add.
4. Specify whether the columns should be grouped. See “Group Columns in Data Tables”.
5. Select the data type for all of the columns. See “About the Column Info Window”.
6. Specify where you want to put the new columns.
7. (Optional) Select initial data values for all of the columns. See “Initialize Data in a Column”.
8. Click OK to save your changes.

Fill Data Table Columns with Sequential Data

To fill columns with a repeating sequence of data or with a continuation of values, follow these steps:
1. Create a sequence of data in a column.
2. Highlight the cells containing the sequenced data. The cells can be in different columns.
3. Right-click the selected cells and select an option under Fill.

Fill Options

- **Repeat sequence to end of table**: Specifies that the cells below the selection are filled with repeats of the selected cells.
- **Continue sequence to end of table**: Specifies that the cells below the selection are filled with a continuation of the pattern found in the selected cells. For example, if the selected cells contain the numbers 1 and 2, then the remaining cells are filled with 3, 4, 5, 6, and so on. If the selected cells contain the numbers 2 and 4, then the remaining cells are filled with 6, 8, 10, 12, and so on.
- **Repeat sequence to**: JMP repeats the pattern found in the selected cells to the row number that you specify.
- **Continue sequence to**: JMP continues the pattern found in the selected cells to the row number that you specify.

Replace Missing Values with Previous Values in Data Table Columns

When a column contains missing values, you can replace those values with the value in the preceding cell. For example, if “4, ., ., 6, ., 7, .” is selected, the values are changed to “4, 4, 4, 4, 6, 6, 7, 7”.

1. Select the cells that contain the missing and replacement values.
   - The first cell that you select must immediately precede a missing value. After that, you can select non-adjacent cells.
Figure 4.5 Missing Values

2. Right-click and select Fill > Replace Missing with Previous Value.

Figure 4.6 Replaced Values

Enter Cell Formulas into Data Table Columns

In numeric data table columns, you can enter cell expressions preceded by an equal sign (=). JMP evaluates the expression and stores the new number as the cell’s value. Unlike column formulas, a cell expression is not stored. Cell expressions can contain operators, constants, and global and column variables.

To enter an expression

1. Click the cell where you want to enter the expression.
2. Type an equal sign (=), and then type the expression (Table 4.1).
3. Press Enter.
Select Rows in Data Tables

To select one entire row

• Click in the empty space that contains the row number.

To select a specific row number

• Select Rows > Row Selection > Go to Row and type in the desired row number.

To select multiple rows

• For continuous selection:
  – Click and drag the cursor over the row numbers.
  – Press Shift and click the first and last rows of the desired range.
  – Press Shift and press the up or down arrow key.
• For discontiguous selection:
  – Press Ctrl and click each row.

To select or deselect all rows

• To select all rows, select Rows > Row Selection > Select All Rows.
  or
• Press Shift and click the lower triangular area in the upper left corner of the data grid to select. Click again in the same area to deselect all rows (Figure 4.7).
• To clear all highlighted areas in the data table, press Esc.

Table 4.1 Examples of Expressions in Table Cells

<table>
<thead>
<tr>
<th>Example expression</th>
<th>Cell value</th>
</tr>
</thead>
<tbody>
<tr>
<td>=sqrt(2)</td>
<td>1.41</td>
</tr>
<tr>
<td>=456+890</td>
<td>1346</td>
</tr>
<tr>
<td>=height+weight</td>
<td>Sums the values of cells in columns height and weight located in the same row as the cell that you entered the expression.</td>
</tr>
<tr>
<td>=height[1]</td>
<td>Displays the value found in row 1 of the height column</td>
</tr>
</tbody>
</table>
To select random rows

1. Select **Rows > Row Selection > Select Randomly**.
2. You can randomly select either a specific number of rows, or a proportion of the total number of rows:
   - Enter a whole number to select that number of rows.
   - Enter a value between 0 and 1 to select that proportion of rows.
   For example, enter 10 to select 10 rows. Enter 0.1 to select 10% of the rows.

To invert the row selection

- Select **Rows > Row Selection > Invert Row Selection**.

To select dominant rows

1. Select **Rows > Row Selection > Select Dominant**.
2. Choose the column(s) whose values you want to use to determine dominance.
3. Select the high or low values to dominate by for each column.
4. Click **OK**.

Note the following about dominant values and rows:

- A value is dominant over another value if it is higher or lower (based on your specification).
- The Select Dominant option selects each row that is not dominated by any other row. A row dominates another row only if all of its values are dominating the other row’s values.
- The resultant set of rows is called the Pareto Frontier.

To save the current row selection in a new column

1. Select **Rows > Row Selection > Name Selection in Column**.
2. Type a column name.
3. Label the selected and deselected rows.
4. Click OK.

**Tip:** If you repeat this process after creating the new column and indicate the same column name, the original column is overwritten. Changes that you made in the data table to Selected or Unselected values are lost. Avoid overwriting those values by clearing the corresponding box in the Name Selection in Column window. For example, to avoid overwriting the Unselected values, make sure that the Unselected box is cleared.

**To select excluded, hidden, or labeled rows**

1. Select **Rows > Row Selection**.
2. Select from the following options:
   - Select Excluded
   - Select Hidden
   - Select Labeled

**Note:** For more information about excluded, hidden, or labeled rows, see “Assign Characteristics to Rows and Columns”.

**To select rows that contain duplicate values**

1. Select **Rows > Row Selection > Select Duplicate Rows**.
   
   All duplicate rows except for the first are selected. If no columns are selected, duplicate rows are selected using all the columns.
   
   If columns are selected, duplicate values are found in the rows of those columns.
   
   The match is case sensitive.

**Find Matching Cells in Rows**

Find cells that have matching values using the Select Matching Cells option.

- Select **Rows > Row Selection > Select Matching Cells**
  or

- Right-click one of the highlighted row numbers and select **Select Matching Cells**.
Select Rows That Contain Specific Values

JMP can search for a specific value (or text string) and highlight all of the cells in the data table that contain the specific value.

1. Select **Rows > Row Selection > Select Where**.

**Figure 4.8** Specify Criteria for Selecting Rows

2. From the column list, highlight the name of the column whose rows you want to select.
3. Use the drop-down menu to select a condition from the list (equals, does not equal, and so on). See **Figure 4.8**.
4. Type the search value.
5. Click **OK**.

You can also specify the following optional features:

- To compare the values of two columns, click the **Compare column** check box. Select from the list of columns for comparison.
- To make the search case-sensitive, click the box beside **Match Case**.
- You can save a Where clause from the Select Rows window to the clipboard, data table, or script window. Select **Keep dialog open**, select rows and other options, and select one of the Save Script options from the Row Selections red triangle menu. Add JSL to the script that reruns the query:

```julia
dt = Open("$SAMPLE_DATA/Big Class.jmp");
Current Data Table() << Row Selection(
    Select where( :age == 15 ),
    Dialog( Edit( Source Column( :age ) == "" ), Keep dialog open )
);```

If rows are currently selected in the data table, you can specify the following features:

- Click an option under **Current Selection** to tell JMP how to handle that current selection:
  - **Clear** removes the highlight from currently selected rows and selects all rows that contain the specified value.
  - **Extend** keeps the currently selected rows selected and also selects the rows in which the specified value has been found.
  - **Restrict** selects the rows in the currently selected array that contain the specified values.
- Click **Add Condition** to add a condition to the list.
- To add more conditions to the search, repeat the previous steps. Click the appropriate item in the **Select Rows** area to specify if you would like JMP to select rows conditionally: if all conditions are met, or if any of the conditions are met.

## Locate the Next Selected Row

You can locate the next selected row after the current row and cause it to flash by selecting **Rows > Next Selected**.

Each time you select **Rows > Next Selected**, the next selected row is found and flashes. A beep signals when the last selected row is located.

You might want to use this feature when you have selected rows intermittently in a large data set and want to look through the selected rows in the data table.

### Example of Locating Next Selected Rows

1. Select **Help > Sample Data Folder** and open Diamonds Data.jmp.
2. Select **Analyze > Fit Y by X**.
3. Select Carat Weight and click **Y, Response**.
4. Select Price and click **X, Factor**.
5. Click **OK**.
6. Select **Tools > Lasso**.
   - If you cannot see the menu bar, hover over the blue bar below the title bar to reveal it.
7. Lasso some of the points near the 10,000 dollar price at the bottom of the plot (**Figure 4.9**).
8. In the data table, select **Rows > Next Selected** (or you can press F7).

You can easily navigate through the selected rows to see the data for each.
Select Columns in Data Tables

You can select columns in the data table, using the Columns Viewer, or by going sequentially through columns.

- “How to Select Columns”
- “Select Columns in the JMP Columns Viewer”
- “Locate Next and Previously Selected Columns in Data Tables”

How to Select Columns

Choose one of several methods for selecting columns in a data table.

To select one entire column

- In the data grid, click in the empty space around the column name.
  or
- In the Columns panel, click the column name.

To select a specific column number

1. Select **Cols > Column Selection > Go to**.
2. Enter the column number or name and click **OK**.

To select multiple columns

- For continuous selection:
Enter and Edit Your Data
Select Columns in Data Tables

- Click and drag the cursor over the column name.
- Press Shift and click the first and last columns of the desired range.
- Press Shift and press the left or right arrow key.

- For columns that are not next to each other:
  - Press Ctrl and click each column.

To select or deselect all columns

- Press Shift and click the upper triangular area in the upper left corner of the data grid to select. Click again in the same area to deselect all columns.

Figure 4.10 Upper Triangular Area

<table>
<thead>
<tr>
<th>name</th>
<th>age</th>
<th>sex</th>
<th>height</th>
<th>weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>KATIE</td>
<td>12</td>
<td>F</td>
<td>59</td>
<td>95</td>
</tr>
<tr>
<td>LOUISE</td>
<td>12</td>
<td>F</td>
<td>61</td>
<td>123</td>
</tr>
<tr>
<td>JANE</td>
<td>12</td>
<td>F</td>
<td>55</td>
<td>74</td>
</tr>
<tr>
<td>JACLYN</td>
<td>12</td>
<td>F</td>
<td>66</td>
<td>145</td>
</tr>
<tr>
<td>LILLIE</td>
<td>12</td>
<td>F</td>
<td>52</td>
<td>64</td>
</tr>
<tr>
<td>TIM</td>
<td>12</td>
<td>M</td>
<td>60</td>
<td>84</td>
</tr>
<tr>
<td>JAMES</td>
<td>12</td>
<td>M</td>
<td>61</td>
<td>128</td>
</tr>
<tr>
<td>ROBERT</td>
<td>12</td>
<td>M</td>
<td>51</td>
<td>79</td>
</tr>
<tr>
<td>BARBARA</td>
<td>13</td>
<td>F</td>
<td>60</td>
<td>112</td>
</tr>
<tr>
<td>ALICE</td>
<td>13</td>
<td>F</td>
<td>61</td>
<td>107</td>
</tr>
</tbody>
</table>

Tip: To clear all highlighted areas in the data table, press Esc.

To invert the column selection

Select Cols > Column Selection > Invert Column Selection. Selects any column that is currently deselected and deselects any column that is currently selected.

Select Columns in the JMP Columns Viewer

The Columns Viewer option in the Cols menu helps you quickly select columns by attributes, properties, and statistics, particularly in a data table that has many columns. You can view summary statistics and properties for those columns, view quartiles in the summary statistics, subset the data, and more. And columns in the Columns Viewer window are also linked to the data table columns.
Figure 4.11  Linked Columns in the Column Viewer

The Columns Viewer gives you a quick view of data table characteristics. For example, the Summary Statistics report shows which columns contain missing values. You can select those columns in the report and then exclude them in the data table.
Figure 4.12 Identify Missing Values

The Summary Statistics report shows the following information:

- the total number of rows (N)
- the number of rows with missing values (N Missing)
- the number of categories (N Categories)
- for continuous data, the Min, Max, Mean, and Std Dev

Other options include the following:

**Clear Select**  Deselects columns in the data table and in the Columns Viewer. This option ensures that no columns are selected before you begin selecting columns.

**Subset**  Creates a linked subset data table from the selected columns.

**Show Summary**  Creates a linked Summary Statistics report for the selected columns.

Right-click to select options such as sorting by column or creating a data table. Select **Show Quartiles** to include lower quartiles, upper quartiles, and interquartile ranges. To create a linked data table from all columns in the report, click the Summary Statistics red triangle and select Data Table View.

**Find Columns with Properties**  Shows a list of column properties in the Columns with Properties report. Select the properties that you want to find and then click **OK** to create a linked report from all columns. Or you can select columns first in the Select Columns list and then show the list of properties just for those columns.
Notes:

- Each time you click the **Show Summary** or **Find Columns with Properties** buttons, a new report is added to the window. To delete a report, select **Remove** from the report’s red triangle menu.

- Deleting rows from a data table view created from Columns Viewer is not undo-able.

**Example of Finding Columns with a Specific Property**

This example shows how to find columns that have a Formula property and then view all formulas at once.

1. Select **Help > Sample Data Folder** and open Consumer Preferences.jmp.
2. Select **Cols > Columns Viewer** to open the Data Table Columns Viewer window.
3. Select **Find Columns with Properties**, select **Formula**, and click **OK**.

   The Columns with Properties report appears. Several columns include the Formula property. Because the list is so long, you want to view all formula columns together.

**Figure 4.13 Select the Formula Column Property**

4. Right-click the report, select **Sort by Column, Formula**, and then click **OK**.

   Columns that have a Formula property appear at the top of the report.
Figure 4.14  Sort by Column

5. Select the Employee Tenure, Position Tenure, and Salary Group columns and select Column Info.

   Formulas for the selected columns appear in the data table’s Column Settings window.

Example of Showing Summary Statistics

This example shows how to find columns with a low standard deviation. This can be helpful if you want to delete or exclude that data from an analysis.

1. Select Help > Sample Data Folder and open Semiconductor Capability.jmp.
2. Select Cols > Columns Viewer to open the Data Table Columns Viewer window.
3. Type PNP in the box and press Enter.
   The grouped processes are shown.
4. Expand the processes group to show the PNP columns.
5. Click **Show Summary** to add the Summary Statistics report.

The rows show the minimum, maximum, mean, and standard deviation for each column.

6. Right-click in the report and select **Sort by Column**.

7. Select **Std Dev** and **Ascending**, and then click **OK**.

Notice that PNP6 has no standard deviation, because the minimum, maximum, and mean values are 0.
Chapter 4
Using JMP

Enter and Edit Your Data
Resize Rows and Columns

Figure 4.17 Sorted Std Dev Column

8. In the Summary Statistics report, select the row for PNP6 and then display the data table.

9. View the data table and press Delete to remove the selected column.

The column is instantly removed from the data table.

10. To close the Columns Viewer, click the X button in the upper right corner (Windows) or upper left corner (macOS) of the window.

Locate Next and Previously Selected Columns in Data Tables

You can find the next selected column after the current column by selecting Cols > Column Selection > Next Selected Column. Similarly, you can find the previously selected column before the current column by selecting Cols > Column Selection > Previous Selected Column.

Each time you select one of these options, the next or previously selected column appears and flashes. The options are available only when columns are selected.

You might want to use this feature to look at intermittently selected columns in a large data table.

Resize Rows and Columns

To resize rows
Resize rows by dragging one of the row borders. All rows are resized to the same height. Graphics that appear inside each cell shrink based on the row height.

To resize columns
To resize a column, drag the column border to the right or left.

To resize several columns to the same width, follow these steps:
1. Select the columns that you want to resize.
2. Press Alt (Windows) or Option (macOS) and drag one of the column borders. All columns are resized to the same width.

Organize Data in Data Tables

Choose one of many methods to rearrange data in a data table.

- “Delete Rows in Data Tables”
- “Delete Columns in Data Tables”
- “Rearrange Columns in Data Tables”
- “Group Columns in Data Tables”
- “Move Values in Data Tables”
- “Color Cells in Data Tables”
- “Edit or Delete Cells in Data Tables”
- “Edit Column Names in Data Tables”
- “Hide and Exclude Rows in Data Tables”
- “Exclude Rows in Data Tables”
- “Hide Rows in Data Tables”
- “Exclude Columns in Data Tables”
- “Hide Columns in Data Tables”
- “View Patterns of Missing Data in Data Tables”
- “Find and Replace Cell Values in Data Tables”
- “Edit Cells in Data Tables”
- “Right-Click Menus for Rows and Columns”
- “Compare Data Tables”

Delete Rows in Data Tables

To delete rows in a JMP data table, follow these steps:

1. Highlight the rows that you want to delete.
2. Press Delete, or right-click the row numbers and select **Delete Rows**.
**Caution:** When you try to delete thousands of rows, an alert might appear if your computer has insufficient memory to save data for undo. Either select fewer rows to delete or select **Disable Undo** from the Table panel red triangle menu. This option removes all actions from the undo history and does not record future actions. When the **Disable Undo** option is selected, it is in effect only while the data table is open; the setting is not saved with the data table.

### Delete Columns in Data Tables

To delete columns in a JMP data table, follow these steps:

1. Highlight the columns to delete.
2. Press Delete, or right-click and select **Delete Columns**.

### Rearrange Columns in Data Tables

You can rearrange or sort data table columns by their name, data type, or modeling type, or reverse the current order. To reorder columns, select **Cols > Reorder Columns** and select from one of the following options:

- **Move Selected Columns**  Move the selected columns to a particular place in the data table. Specify where to place the selected columns in the Move Selected Columns window:
  - **To first**  Moves the selected columns so that they are in the left-most position in the data table.
  - **To last**  Moves the selected columns so that they are in the right-most position in the data table.
  - **After**  Moves the selected columns so that they are after a column that you identify.

- **Original Order**  Returns the columns to the order they were in when data table was last saved.

- **Reorder by Name**  Arranges the columns from left to right in alphabetical order by column name.

- **Reorder By Data Type**  Arranges the columns from left to right in alphabetic order by data type (expression, row state, character, numeric).

- **Reorder By Modeling Type**  Arranges the columns from left to right in alphabetic order by modeling type (none, continuous, ordinal, nominal, multiple response, unstructured text, vector). Row state columns have no modeling type, and are shown last.

- **Reverse Order**  Reverses the order of the data table columns.
Group Columns in Data Tables

Group columns within a single heading to manage large numbers of columns and facilitate analysis role assignment. Grouped columns appear in an outline format within the Columns panel.

To group or ungroup columns
1. Within the data grid, select the columns that you want to group.
2. From the main menu, select Cols > Group Columns or Cols > Ungroup Columns.
   or
1. From the Columns panel, select the columns that you want to group.
2. Right-click the selected columns and select Group Columns or Ungroup Columns.

Note: Grouped columns are automatically retained for data tables generated from the following commands: Subset, Sort, Summary, Join, Stack, and Split. For the Stack command, if all the columns in the stack group belong to the same columns group, then the group's name is used for the column name.

Move Values in Data Tables

To move values in a data table, select the values, click and pause, and then drop the values into the new location.

Tip: Clicking and dragging on a selection without pausing extends the selection.

When dragging and dropping values, note the following:

- Cells retain all of their characteristics and column properties.
- After you move cells, missing values appear in the cells that you initially selected.
- The selected cells and the destination cells must have the same data type.
- If you drag a set of cells to an empty area of the table, new columns are automatically created.
- New columns have the original columns' display format and modeling types.

To specify where to move rows
1. Highlight the rows that you want to move.
2. Select Rows > Move Rows.
3. Specify where you would like to move the rows in the Move Rows window:
Move Content into Another JMP Window

On Windows, you can drag selected content over a minimized window. The minimized window moves to the front and you can paste your content into it. You can do the same thing in JMP. For example, you can drag selected content over the Home Window button (located in the bottom right corner of most windows). Then in the Window List, drag the content over the window that you want to move the content into. That window moves to the front and you can drop in the content.

Tip: If you cannot see the JMP Home Window button, select View > Status Bars.

For example, you can drag a selected column, row, or cell from one data table into another; drag selected text from one script window into another; or drag selected content from a report into a journal.

Color Cells in Data Tables

You can select one or more data table cells and change the color to highlight a specific value. Right-click the cell or cells, select Color Cells, and select a color. To remove color from cells, select the cells, right-click, and select Cols > Clear Color.

Edit or Delete Cells in Data Tables

To edit or delete the contents of a cell, follow these steps:

1. Click the cell containing the value that you want to edit or delete.
2. Press Delete.
3. To edit the value, click the cell a second time, and then edit the cell’s value.

Edit Column Names in Data Tables

To edit a single column name, select the column and begin typing. You can also edit the column name in the Column Info window, or select the header and press Enter.

To edit all of the column names at once, click Cols > Column Names and select one of the following options:

Move up  Moves the first row of data up to replace the column names.
**Move up and append**  Moves the first row of data up and appends the entries to the existing column names.

**Move down**  Moves the columns names down to become a row of data. The columns are then named Column 1, Column 2, and so on.

**Recode Column Names**  Opens the Recode window to recode the column names. See “Recode Data in a Column”.

## Hide and Exclude Rows in Data Tables

Apply Hidden and Excluded row states to rows that you do not want to include in analysis or plot calculations and that you do not want to display in plots. These rows are not included in subsequent analyses.

**Notes:**

- Plots found under the Graph menu, with the exception of Profilers, are immediately recalculated to reflect hidden and excluded rows.

- For many platforms, reports and plots are not updated immediately to reflect excluded and hidden observations. You need to rerun the analysis to recalculate analysis results and the related plots. For exceptions, see “Platforms that Update Immediately for Hide and Exclude”.

- When you Exclude and Hide rows, they are excluded and hidden in all open reports and plots that update automatically.

- When you Exclude and Hide rows, a circle with a strikethrough (🚫, for Exclude) and a mask icon (保守, for Hide) appear beside the row number.

- Rows remain hidden and excluded until you highlight the rows and select **Hide and Exclude** again.

**To hide and exclude one or more rows**

1. Select the rows that you want to hide and exclude.

2. Do one of the following:
   - Right-click the highlighted area next to the row numbers and select **Hide and Exclude**.
   - From the **Rows** menu, select **Hide and Exclude**.
Platforms that Update Immediately for Hide and Exclude

When you apply Hide and Exclude to rows, for most platforms under the Analyze menu, points or plot elements that correspond directly to rows are usually hidden immediately in plots. However, calculations shown in accompanying reports usually are not updated. For the following platforms, applying Hide and Exclude results in immediate updates to plots and calculations:

- Tabulate
- Control Chart Builder

Exclude Rows in Data Tables

Apply the Excluded row state to rows that you do not want to include in subsequent calculations. Statistics are recalculated without the excluded rows.

To exclude one or more rows, follow these steps:

1. Select rows that you want to exclude.
2. Do one of the following:
   - Right-click the highlighted area next to the row numbers and select **Exclude/Unexclude**.
   - From the **Rows** menu, select **Exclude/Unexclude**.

Notes:

- In most cases, when a row is represented by a point or an individual plot element, excluding the row does not hide it in plots.
- In Graph Builder, when a plot element is represented by a group of rows, the plot is reconstructed using only the unexcluded rows. The plot also does not display plot elements corresponding to the excluded rows. Excluded rows are treated as if they are both hidden and excluded.
- Plots found under the Graph menu (with the exception of Profilers, Parallel Plot, and Scatterplot Matrix) are immediately recalculated to reflect excluded rows.
- For many platforms, reports and plots are not updated immediately to reflect excluded observations. You need to rerun the analysis to recalculate plots and analysis results.
- When you Exclude rows, they are excluded in all open plots and reports that are updated immediately.
- A circle with a strikethrough (○) appears beside the row number of an excluded row.
- Rows remain excluded until you highlight the rows and select **Exclude/Unexclude** again.
Hide Rows in Data Tables

Apply the Hidden row state to rows that you do not want to include in plots.

To hide one or more rows, follow these steps:

1. Select rows that you want to hide.
2. Do one of the following:
   - Right-click the selected area next to the row numbers and select Hide/Unhide.
   - From the Rows menu, select Hide/Unhide.

Notes:

• Not all plots hide the elements that correspond to hidden rows. This is often the case when the calculations used to construct the plot elements use the data from the hidden rows. As a general rule, if there is a one-to-one correspondence between rows and plot elements, the points or elements corresponding to the hidden rows are hidden.
• When you Hide rows, they are hidden in all open plots that are updated immediately.
• Hiding rows does not exclude them from calculations and analyses.
• When each hidden row corresponds to a point or an individual plot element, plots are updated immediately when you apply the Hidden row state to rows.
• Depending on the platform, plot elements are calculated using multiple observations, but they do not correspond directly to a row. In these cases, the plot elements generally are not updated to reflect hidden observations unless those rows are also excluded.
• For some plots where plot elements correspond to groups of rows, when you Hide rows, the plot is updated to hide plot elements corresponding to hidden rows. See “JMP Plots Where Grouping Elements are Updated for Hide”.
• A mask icon (.instrument) appears beside the row number of a hidden row.
• Rows remain hidden until you select the rows and select Hide/Unhide again.

JMP Plots Where Grouping Elements are Updated for Hide

When you apply Hide to rows, in plots with a one-to-one correspondence between rows and plot elements, the points or plot elements are usually hidden immediately. However, for the following platforms and options, applying Hide results in immediate updates to plot elements that correspond to groups of rows:

• Control Chart Builder. See Quality and Process Methods.
• Graph Builder. The bar chart, heat map, and pie chart are updated to reflect hidden rows. See Essential Graphing.
• Bubble Plot. See Essential Graphing.
Exclude Columns in Data Tables

When your data table contains columns that you do not want to consider for analysis, you can exclude those columns so that they do not appear in selection lists in launch windows. Note the following:

- Excluded columns remain visible in the data grid.
- A circle with a strikethrough () appears to the right of the column name in the Columns panel.

To exclude columns from launch windows

1. Select one or more columns that you want to exclude.
2. Do one of the following:
   - Right-click the highlighted column name in the Columns panel and select Exclude/Unexclude.
   - From the Cols menu, select Exclude/Unexclude.

To unexclude columns

1. Select the columns in the Columns panel.
2. Do one of the following:
   - Right-click the highlighted column name in the Columns panel and select Exclude/Unexclude.
   - From the Cols menu, select Exclude/Unexclude.

Hide Columns in Data Tables

When your data table contains columns that you do not want to see in the data grid, you can hide those columns. Note the following:

- Hidden columns appear in launch windows and are available for analyses.
- A mask icon () appears to the right of the column name in the Columns panel.

To hide columns

1. Select one or more columns that you want to hide.
2. Do one of the following:
   - Right-click the highlighted column name in the Columns panel and select Hide/Unhide.
   - From the Cols menu, select Hide/Unhide.
To unhide columns

1. Select the columns in the Columns panel.
2. Do one of the following:
   - Right-click the highlighted column name in the Columns panel and select Hide/Unhide.
   - From the Cols menu, select Hide/Unhide.

View Patterns of Missing Data in Data Tables

If your data table contains missing data, you might want to determine whether there is a pattern to the missing data. The pattern might help you make discoveries about your data.

To view patterns of missing data, follow these steps:

1. With your data table open, select Tables > Missing Data Pattern.
2. Select the columns for which you would like to find patterns of missing data.
3. Click Add Columns.
4. Select Count Missing Value Codes to count missing value codes as missing values.
5. Select Add Value Colors Property to consistently color columns that contain 0 or 1 (missing value indicators).
   For example, nonmissing is always colored blue, missing is always colored red. This is especially helpful for data tables that might have similar values across columns.
6. Click OK.

Example of Viewing Patterns of Missing Data

1. Select Help > Sample Data Folder and open Missing Data Pattern.jmp.
2. Select Tables > Missing Data Pattern.
3. Highlight all of the columns.

   **Note:** For more information about the options in the red triangle menu, see “Column Filter Menu”.

4. Click **Add Columns**.
5. Click **OK**.

**Figure 4.19** A Missing Data Pattern Table

**Tip:** To quickly create a Treemap or Cell Plot of the data, click the green triangle next to the Treemap or Cell Plot script in the table panel.
Figure 4.19 shows the following patterns:

- Row 1 shows that there are two instances where all rows in Trial 1, Trial 2, Trial 3, and Trial 4 have no missing values.
- Row 2 shows that there are two rows in the source table whose one missing value is in the Trial 4 column.
- Row 3 shows that there are two rows in the source table whose missing values are in the Trial 3 and Trial 4 columns.
- Row 4 shows that there is one row in the source table whose three missing values are in the Trial 2, Trial 3, and Trial 4 columns.

The Count column is assigned the frequency role. If you now use the Missing Data Pattern data table to run an analysis, JMP automatically uses Count as a frequency. See “Assign a Preselected Analysis Role to a Column”.

Find and Replace Cell Values in Data Tables

You can find and replace cell values by selecting the Edit > Search > Find options.

Figure 4.20 The Find Window

The following rules apply to searching for values:

- To find values in hidden columns, unhide the column.
- Values found in locked columns cannot be modified.
- The Undo command works only with Replace. You cannot undo Replace All.
- If your data table contains value labels, using the Search commands searches for actual values, but does not search for labels. See “Value Labels”.
- If your data table contains formatted values (such as dates, times, or durations) using the Search command searches for the formatted values, not the actual values.
Find Window Options

Refine your search with the following options:

**Match Case**  Performs a case-sensitive search, which can be useful for locating proper nouns or other capitalized words.

**Match entire cell value**  Detects empty spaces, which lets you search for a series of words in a character column, or locate strings with unwanted leading or trailing empty spaces.

*Tip:* To find missing character values, leave the **Find what** box empty and check **Match entire cell value**. To find missing numeric values, insert a period into the **Find** box and check **Match entire cell value**.

**Use regular expressions**  Assumes the find string to be a regular expression instead of the literal string that you enter in the **Find what** box. The regular expressions follow standard semantics.

**Restrict to selected rows**  Restricts the search to selected rows.

**Restrict to selected columns**  Restricts the search to selected columns.

**Search data**  Searches only data cells (omitting column names).

**Search column names**  Searches only column names (omitting data cells).

**By column**  Searches the table column by column, from top to bottom, until it reaches the last cell in the rightmost column, or until you stop the search.

**By row**  Searches the data table row by row from left to right, to the rightmost cell in the last row or until you stop the search.

**Multiple lines**  Increases the Find and Replace boxes to 3 lines long instead of 1. The Enter key inserts a return into the field.

*Tip:* You can alternatively click and drag on the Find and Replace boxes to make them larger. If you copy and paste, the boxes resize to 1 line long, but all of your text is still there.

**Keep dialog open**  Keeps the Find window open during your search.

Search Actions

This section describes some common searches that you might perform.

Begin by searching for a value in the data table. The search begins with the first cell in the first column and searches every cell until it locates the value or reaches the end of the table.
To replace the currently highlighted cell value

Enter a value in the Replace with box and click Replace. Or, if the Search window is closed, select Edit > Search > Replace. If the replace value is a missing value, the currently highlighted cell content becomes a missing value.

To replace all occurrences of the specified value

Enter a value in the Replace with box and click Replace All. Or, if the Search window is closed, select Edit > Search > Replace All.

To replace the value and search for the next value

Enter a value in the Replace with box and click Replace. Or, if the Search window is closed, select Edit > Search > Replace and Find Next. Or, press Ctrl+L.

To use a selected value as the Find what value

In the data table, select a value. Select Edit > Search > Use Selection for Find. Next, select Edit > Search > Find. The value that you selected in the data table is already entered in the Find what field.

To use a selected value as the Replace with value

In the data table, select a value. Select Edit > Search > Use Selection for Replace to populate the Replace with field.

To find the next value when the Search window is closed

Select Edit > Search > Find Next. Or, press Ctrl+G, or F3, on Windows.

To find a missing value:

• To find missing character values, leave the Find what field empty and select Match entire cell value.
• To find missing numeric values, type a period into the Find what text box.

**Edit Cells in Data Tables**

Use the Row Editor to browse or edit cells one row at a time. Open the Row Editor in one of the following ways:

• Select Rows > Row Editor.
• In a data table, double-click in the row number area. The row that you use is the row that first appears in the Row Editor.
• In a report window, right-click in a plot or graph and select Row Editor.
Note the following:

- If you have a report window open, and you want edited data to be automatically reflected there, make sure that Automatic Recalc is turned on. See “Automatic Recalc”.
- If your data table contains value labels, the Row Editor displays the label, and when the cell is highlighted for editing, it shows the actual value. See “Value Labels”.

Row Editor Buttons

Click the arrow buttons to browse through selected rows or the entire data set if no rows are selected.

- Shows the previous row.
- Shows the previously selected row.
- Makes the row blink in graphs.
- Shows the next selected row.
- Shows the next row.
- Searches for a row. See “Resize Rows and Columns”.
- Creates a new row at the end of the data table.

Note: Changes made to a row using the Row Editor are written to the data table when you change fields in the Row Editor. You still need to save the changes to the data table.

Row Editor Options

The red triangle menu in the Row Editor contains the following options:

**Next Selected**   Displays information for the selected row that is located after the current one.

**Prev Selected**   Displays information for the selected row that is located before the current one.

**Next**   Displays information for the row that is located after the current one, regardless of whether the row is selected.
**Prev**  Displays information for the row that is located before the current one, regardless of whether the row is selected.

**Save**  Saves the data table and any changes that you have made to it via the Row Editor.

**New Row**  Creates a new row in the data table.

**Find**  Displays the same window as if you had selected **Rows > Row Selection > Select Where**. Select one of the options from the **Current Selection** menu, and then highlight the column whose rows you want to select. Type in the value for which you want JMP to search. See “Resize Rows and Columns”.

**Blink**  Causes the current row’s highlight to flash at a rapid rate.

**Note:** Text in a locked column or a locked data table cannot be edited. See “Lock” and “Lock Data Tables”.

---

**Right-Click Menus for Rows and Columns**

When you right-click in the row number area, or at the top of a column in the column name area, pop-up menus appear. These menus provide quick access to selected commands in the Rows and Columns menus. For more information about these options, see “Right-Click Options for Columns” and “Right-Click Options for Rows”.

**Compare Data Tables**

JMP can compare two open data tables and report the differences between data, scripts, table variables, column names, column properties, and column attributes. The numbers of columns and rows in each data table are shown at the top of the Compare Data Tables window. In this example, the sample data tables Popcorn Trials.jmp and Popcorn.jmp are compared.

**Figure 4.22  Basic Information about Data Tables**

<table>
<thead>
<tr>
<th>Compare Data Tables</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Compare:</strong> Popcorn Trials (5 columns, 8 rows)</td>
</tr>
<tr>
<td><strong>With:</strong> Popcorn (5 columns, 16 rows)</td>
</tr>
</tbody>
</table>

| `C:\Program Files\SAS\JMP16\Samples\Data\Popcorn Trials.jmp` |
| `C:\Program Files\SAS\JMP16\Samples\Data\Popcorn.jmp` |

**Specify Matching Columns**

Columns with the same name are automatically matched. Lines are drawn between each matched column. You can also manually link two columns.

1. Select **Help > Sample Data Folder** and open Popcorn.jmp and Popcorn Trials.jmp.
2. Show Popcorn Trials.jmp and select **Tables > Compare Data Tables**.

3. From the With list, select Popcorn.jmp.

   Popcorn Trials.jmp should automatically be selected from the Compare list.

4. In the Match Columns pane, select yield and yield1 and then click **Link**.

**Figure 4.23** Manually Linked Columns

Columns that have the same name are automatically linked.

**Note:** If you click the Compare Data icon , the linked columns will not be compared. The values for that pair of columns will show up in the results, but they won’t be compared.

5. Click **Compare**.

   The results are shown in the Data report.
The first eight rows are the same so they are not shown. The remaining rows (colored blue) are only in the second table, Popcorn.jmp.

6. In the Data report, deselect **Hide rows with no differences**.
The first eight rows are shown because they are the same in both data tables.

7. Deselect **Hide columns with no differences**.
Figure 4.26 Showing Columns with No Differences

Columns that are in both data tables and that match are shown. You might select this option to give more context to the matched data.

**Note:** If the data in a cell isn’t ‘completely shown, select the text and then view the data in the Cell Data box.

**Data Table Compare Options**

**Align Data Options**

**Flexible by Row**  Searches for common rows to align. Consider this option for smaller data tables if you think that the data tables are nearly the same.

**By Row**  Compares rows one by one. Consider this option if you already know that the rows should line up row by row. The comparison will run much faster. However, if the default Flexible by Row was selected, and the comparison is taking too long, you might want to select this option.

**Use ID Columns**  Uses the selected ID column to compare rows. The rows of the data table are uniquely identified by the values of the ID column. Consider this option if the data tables are large, sorted differently, or have missing rows. You can select more than one column.
Fuzzy Compare Options

**Ignore missing**  Ignores missing data.

**Allow Relative Error**  Enables you to specify the relative error rate for numeric data. The numeric values are considered equal if they are within the relative error rate that you specify. The smaller the relative error rate, the more precise the comparison.

**Ignore case**  Disregards case when comparing text.

**Ignore whitespace**  Disregards whitespace when comparing text.

Data Options

**Show fuzzy differences**  Shows differences in numeric and string data that are approximately the same. Works with the value in the Relative Error field to remove insignificant differences.

**Hide columns with no differences**  Shows or hides all matched columns.

**Hide rows with no differences**  Shows or hides rows that contain matching data.

Compare Table Properties

Click the red triangle and select **Compare Table Properties** to see differences in table scripts and variables. Figure 4.27 shows that the table variables and scripts are different. To see the full variable or script, select the line and view the selected metadata.

In this example, both notes differ, and the reference variable and scripts are only in Popcorn.jmp. The Notes variable is selected so that you can see it contents in both data tables in the Selected Metadata box. The red shading indicates that the text is only in Popcorn.jmp. The blue shading indicates that the text is only in Popcorn Trials.jmp.

**Figure 4.27** Different Table Variables

![Table Properties](image)
Deselect **Show Diff** to see the name of each data table and the complete contents of each Notes variable instead of only showing the differences.

*Shortest run* is the smallest number of consecutive characters that are required to be the same (between the two files) before you can declare the characters as a *common subsegment*. A common subsegment has no background color because it is present in both files. The shortest run is set to 3 to prevent subsegments that are too short from showing up as common, which is typically unhelpful. For example, a shortest run of 1 means that any single character that is in both files could match. This leads to many very short segments of common text and differences, which is usually not a good reading experience.

**Compare Column Attributes and Properties**

Click the red triangle and select **Compare Column Attributes and Properties** to see differences in column notes, value colors, and the like.

**Figure 4.28** shows that column notes are different in Popcorn.jmp and Popcorn Trials.jmp. The yield1/yield column is selected so that you can see the complete note and differences between the two notes in the Selected Metadata box.

**Figure 4.28** Comparing Column Attributes and Properties

```plaintext
Notes:

Stack Yield1 and yield2 with Stack command in ounces. This is the response for the settings of Tables menu to get the POPCORN data table three factors: popcorn, oil amt, and batch.
```
Assign Characteristics to Rows and Columns

This section describes how to exclude, hide, label, color, or mark rows and columns in order to customize the appearance of points in scatterplots and graphs.

- “How to Find Options for Rows and Columns”
- “Label Rows and Columns”
- “Assign Colors or Markers to Rows”
- “Create Color Themes in Graphs”
- “Delete Custom Color Themes in Graphs”
- “Select Matching Row State Cells”
- “Delete Row Characteristics”
- “Lock Columns”

How to Find Options for Rows and Columns

The menu for row actions can be accessed from the following places:

- the **Rows** menu in the main menu
- right-click a row
- the red triangle in the Rows panel
- the left red triangle in the upper left corner of the data grid

Similarly, the menu for columns actions can be accessed from the following places:

- the **Cols** menu in the main menu
- right-click a column
- the red triangle in the Columns panel
- the right red triangle in the upper left corner of the data grid

Label Rows and Columns

When you position the arrow cursor over a point in a plot, the point’s label appears. By default, row numbers are used as labels. You can customize the labels:

- You can change the label to display column values instead of the row number.
- You can enable the label to always appear, not only when you position the cursor over points.
• A label or yellow tag icon ( ) appears beside the column name in the Columns panel, indicating that points on plots are identified by the column value. If there are multiple columns that are labeled, their values appear on plots separated by a comma.

• Data remain labeled until you select Label/Unlabel again.

To change the label to display column values

1. Highlight one or more columns whose values you want to appear as the label in plots.
2. Select Cols > Label/Unlabel from the menu or right-click and select Label/Unlabel.

To enable the label to always appear (not just when you position the cursor over points)

1. Highlight one or more rows whose label you want to always appear in plots.
2. Select Rows > Label/Unlabel from the menu.

To turn off labeling for rows or columns

1. Highlight the labeled rows or columns that you no longer want labeled.
2. Select Label/Unlabel from the Rows menu or Cols menu. You can also right-click columns or rows and select Label/Unlabel.

Tip: A photo can be displayed in the label when you hover over data. For example, the SAS Offices.jmp sample data table contains an Expression column that is labeled. A photo of each office is stored in the column. When you hover over a data point on the map, the photo for that row appears. See “Expression Role”.

Assign Colors or Markers to Rows

Assign colors or markers to rows to differentiate rows in a data table.

• If you assign a color to a row, the points representing the values in that row are colored in the plot.

• If you assign a marker to a row, the point is replaced with the marker in the plot.

• You can also assign colors or markers based on column values.

Assign a Color to Rows

Assigning a color to selected rows means that the points in plots appear in the color that you select. In the data grid, the active color assigned to a row appears next to the row number.

To assign rows a color

1. Highlight one or more rows that you want to assign a color to.
2. Right-click the highlighted rows and select **Rows > Colors**.
3. Select one of the available colors.

**Tip:** To clear an assigned color from the selected rows, assign the color black.

### Add Markers to Rows

To replace the standard points in plots with a marker, use the JMP markers palette. In the data table, these markers also appear next to row numbers.

1. Highlight one or more rows that you want to apply the marker to.
2. Right-click the selected rows and select **Markers**, and then select the marker shape.
   - Select **Other** to create custom markers. You can type alphabetic characters, numerals, and other keyboard symbols.

**Tip:** To return to the default marker, select the initial dot marker. To clear an assigned color from the selected marker, select the color black.

### Assign Colors or Markers to Rows Based on Column Values

You can assign colors or markers to your data table rows based on the values found in a particular column. For example, in a column called **Sex**, you could assign all rows whose value is F a red circle marker. All rows whose value is M could have a green plus marker. These colors and markers replace the default black dot in plots and appear next to its row number in the data table.

*To assign colors or markers to rows based on column values*

1. Select **Rows > Color or Mark by Column**.
2. Select the column to color and or mark.

**Figure 4.29** Color or Mark by Column
3. Select the **Colors** and **Markers** schemes to apply.
   A preview of your selection appears under Row States.

4. (Optional) Select any additional options. See “**Color or Mark by Column Options**”.

5. Click **OK**.

6. (Optional) To shade all rows according to their row state, right-click in the row numbers area within the data grid and select **Color Rows by Row State**.
   From then on, the rows are shaded with the color that you assign to the rows.

### Color or Mark by Column Options

**Colors**  Select a color theme to assign different colors to the rows in your data table. Color assignment is based on the values of the selected column.

**Continuous Scale**  Assigns colors in a chromatic sequence based on the values in the highlighted column.

**Reverse Scale**  Assigns colors in a reversed chromatic sequence based on the values in the highlighted column.

**Markers**  Assigns a different marker to each row in your data table based on the values found in the column that you highlighted.

**Make Window with Legend**  Includes a legend with your new characteristics so that you can easily identify which colors and markers correspond with which row.

**Save To Column Property**  Saves the color and marker information as a column property.
   The rows in the selected column of the data table are colored, based on the color theme.

**Save To Table Property**  Saves the color and marker information as a table property.

**Excluded Rows**  Assigns colors or markers to rows that are excluded.

### Create Color Themes in Graphs

JMP includes several color themes that can distinguish a range of values in a graph. You can also create your own color themes based on an existing color theme or create custom themes.

When you select a default color theme, the colors are not applied to reports that are open. You need to rerun the existing reports to format them with the default color theme.

See “**Delete Custom Color Themes in Graphs**” for more information about deleting custom color themes.
To create a color theme

1. Select **File > Preferences > Graphs**.

2. To either create a new Continuous Color Theme or Categorical Color Theme, click the appropriate color theme.

   If you are creating a new continuous color theme, the Continuous Color Themes window appears.

**Figure 4.30** Continuous Color Themes Window

The sequential color “Cividis” is a form of Viridis that is designed for viewing with color limitations.

   If you selected to create a new categorical color theme, the Categorical Color Themes window appears.
3. (Optional) To base the theme on an existing theme, select a color themes from the available themes.

4. Click the Custom Color Theme disclosure icon to show the Custom Color Theme panel. Figure 4.32 shows the color theme panels for both continuous and categorical themes (respectively).

5. Click New to create a new theme.
   A new color theme is created based on the selected color theme. A temporary name is assigned to the theme.

6. Type a new name in place of the temporary label. On Windows, do not press Enter. The window closes if you do so.

7. To modify the color theme, do any of the following:
– To modify the missing color, click the missing color to open a color palette. Select the desired missing value color and click OK.
– To modify the gradient of continuous color, move the sliders left or right.
– To add more colors to the gradient, click the color bar to choose a color. A new slider is displayed under the color bar.
– To change the color of a slider, click the slider to display the Color window and choose another color.
– To reverse the order of the colors on the gradient, click Reverse.
– To distribute the colors evenly on the gradient, click Space Evenly.
– To list the custom theme in the Sequential pane, select Sequential from the list.
– To list the custom theme in the Diverging pane, select Diverging from the list.
– To list the custom theme in the Chromatic pane, select Chromatic from the list.
– To prevent a theme from appearing in lists of color themes, select Hidden.
– To remove a color from the color theme, click the color’s slider and drag the slider above or below the color bar.
– To discard your changes, click Cancel.

8. Click Save to save the custom color theme.

The new custom color theme is appended to the contents of the selected pane.

9. Click OK to close the color theme window.

To adjust color themes for color blindness

In the Continuous or Categorical Color Themes window, choose an option based on the type of color blindness from the Color vision menu.

Continuous and Categorical Color Themes

The following figure shows examples of the two types of color themes in JMP, continuous and categorical. When a color theme is selected for continuous data, the colors are graduated (as shown on the left). When the same color theme is selected for categorical data, the color consists of distinct blocks of color (as shown on the right).
Custom Color Themes

Custom color themes can be applied in the same way as built-in color themes:

- You can select custom color themes as defaults from the Continuous Color Theme and Categorical Color Theme drop-down menus in the Graphs preferences. Only continuous color themes are available for continuous data. All color themes are available for categorical data.
- You can apply the custom color themes to components such as markers and data table rows. See “Assign Colors or Markers to Rows Based on Column Values”.
- In certain reports, such as treemaps and surface plots, you can select specific custom color themes. See Essential Graphing.

Use Custom Color Themes on Multiple Computers

In Windows, the color themes that you create are defined in the JMP preferences file called JMP.PFS. If you use JMP on more than one computer (for example, at home and at work), you can copy the color theme definitions from one JMP preferences file to another. Custom colors are then available on both computers.

In the preferences file, the code for a custom color theme looks like this:

```
Add Color Theme(
    "Pink to Blue", 2051, {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}}
),
```
In this example, the name of the color theme is “Pink to Blue.” The Red/Green/Blue (RGB) values for each color slider are located in brackets. The first slider defines the RGB values 255, 168, and 255. The second and third groups of brackets define colors for the second and third sliders.

**Note:** The second value (2051) is the category of the color theme, such as Categorical or Continuous. You can omit the category, but JMP always includes the information in the preferences file or when `Show Preferences()` is run.

In a text editor (such as Microsoft Notepad) add this color theme to the preferences file on your other computer. The preferences file is located in your Users folder within the JMP or JMPPro folder.

C:/Users/<user_name>/AppData/Roaming/SAS/JMP/17
C:/Users/<user_name>/AppData/Roaming/SAS/JMPPro/17

**Note:** To see the preceding folders, you must configure Windows Explorer to show hidden files and folders. For more information, refer to the Windows help.

To transfer color themes to another Windows computer

1. On the computer that contains the customized JMP preferences, select **File > New > Script**. The Script window appears.
2. Type the following JSL function:
   ```javascript
   Show Preferences()
   ```
3. Click **Run Script**.
   Your customized preferences are written to the log.
4. Select **View > Log** (or display the open log).
   The custom color theme that you created appears, for example:
   ```javascript
   Add Color Theme("Pink to Blue", 2051, {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}})
   ```
   This definition might be in the middle of other customized preferences that appear in the log.
5. Save the log as **Log.jsl** and open the file on the computer whose preferences you are updating.
6. On the computer whose preferences you are updating, close JMP.
7. Make a backup of JMP.PFS, and then open the original JMP.PFS in a text editor.
8. Copy and paste the custom color definition from Log.jsl to JMP.PFS. The definition goes after `Preferences` as shown in the following example:
Preferences(
    Add Color Theme(
        "Pink to Blue", 2051, {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}}
    ),
);  

**Note:** Be sure to include the closing parenthesis and comma. The code does not need to be indented. You can put the code in any valid location. Pasting it after `Preferences(` helps ensure that you do not delete any necessary parentheses or commas.

9. Save the file.
   
   If you open JMP and the new color definition is not displayed in the preferences, delete the updated preferences file and add the definition to the original preferences file. Make sure that you copy and paste the definition in the correct location.

### Delete Custom Color Themes in Graphs

1. Select **File > Preferences > Graphs**.
2. To either delete a color theme, select either the Continuous or Categorical Color Theme. The relevant Color Themes window appears.
3. Click the Custom Color Theme disclosure icon to show the Custom Color Theme panel.
4. From the appropriate pane, select the custom color to delete.
   
   **Note:** You can delete only custom color themes.

5. Click **Delete**.
6. Click **OK** to save your changes and close the Color Themes window.

### Select Matching Row State Cells

You can select a cell in a row state column and then select all cells that contain the selected cell’s attributes. This option enables you to select cells with any combination of row state attributes, such as Exclude, Hide, color, or marker. For example, if a cell has a red marker and is excluded, and you select matching cells, all cells in excluded rows with red markers are selected.

1. Right-click the cell whose row state you want to select.
2. Select **Select Matching Cells**.
   
   The cells with matching row states are selected.
Delete Row Characteristics

To clear all row states in the data table, select **Rows > Clear Row States**. To clear row states only in selected rows, select **Rows > Clear Selected Row States**.

All rows become included, visible, unlabeled, and show in plots as black dots. The **Clear Row States** command does not affect row states saved in row state columns.

Lock Columns

You can lock a column in place so that when you scroll horizontally, the column remains visible. Highlight the columns and select **Cols > Scroll Lock/Unlock**. Note the following:

- Hidden columns cannot be scroll locked.
- The name of a locked column appears in italics in the Columns panel.
- Scroll locked columns are moved to the left in the data grid. Once you unlock them, they are not moved back to their original locations in the data table, but remain on the left.
- Columns remain scroll locked until you highlight the columns and select **Scroll Lock/Unlock** again.

Restructure Data

JMP provides several ways to restructure data in a data table, such as creating a column from multiple columns, creating indicator columns, and recoding data.

- “Split a Data Table Column into Multiple Columns”
- “Create a New Column by Text Matching”
- “Make Indicator Columns”
- “Combine Columns in Data Tables”
- “Compress Selected Columns in Data Tables”
- “Make a Binning Formula in a Data Table Column”
- “Convert Labels to Codes and Codes to Labels”
- “Make a New Formula Column”
- “Transform Columns in a JMP Platform”
- “Recode Data in a Column”
Split a Data Table Column into Multiple Columns

Use the Text to Columns option to make a character column with delimited fields into multiple columns. Highlight a column from a data table and select Cols > Utilities > Text to Columns. The maximum number of delimited fields across all rows determines the number of new columns created.

Note: Text to Columns is case-sensitive.

The Text to Columns window has the following options:

- **Delimiter** Specify text, such as a comma, to indicate how the data in the source column is organized into new columns. For example, if the original cell reads “NY, NJ, PA,” and the delimiter is a comma, three new columns contain “NY”, “NJ”, and “PA”.

- **TAB** Specifies tabs as delimiters.

- **NEWLINE** Specifies newline characters (\r, \n, and \r\n) as delimiters.

- **Make Indicator Columns** Makes new columns that are named after the distinct fields in the source column with cell values of either 0 or 1.

- **Include Missing** Allows any empty rows to be counted as a category. An additional column named Missing is added to the data table. A value of 1 indicates an empty row.

Create a New Column by Text Matching

The New Column by Text Matching option enables you to use regular expressions (which identify patterns in text) to match unstructured text in a column and then create a new column from the matched text. This feature is an alternative to using the Text Explorer platform to write regular expressions and then save the results to a column.

1. Select Help > Sample Data Folder and open Pet Survey.jmp.
2. Select the Survey Response column.
3. Select Cols > Utilities > New Column By Text Matching.
4. Below the Leftover box, click the Add button.
5. Select Blank from the list and click OK.
6. Next to Title, enter Cat.
7. Next to Regex, enter (cat(?:s?))([\s.]).
   This expression finds “cat”, optionally followed by “s”, with either a space or period afterward.
   
   **Note:** If the regular expression has an error, an X icon appears to the left of Cat.

8. Click the Add button again.
9. Select Blank from the list and click OK.
10. Next to Title, enter Dog.
11. Next to Regex, enter (dog(?:s?))([\s.]).
12. (Optional) To save the script so that you do not have to repopulate the Regular Expressions Editor after closing and reopening it, select one of the Save Script options from the red triangle menu.
13. Click OK.
The Use Result Specification option in the Regular Expressions Editor gives you control over which matched text appears in the new column:

- If you don’t select Use Result Specification (the default setting), the result in the new column is whatever is produced by the regular expression in the right side of the editor.
- If you select Use Result Specification, then the result in the new column is whatever is produced by the Result expression in the right side of the editor. If your regular expression is `Air(port)`, then the new column contains the word `port` when found in the original column.

For more information about the Regular Expression Editor, see Basic Analysis.

To learn more about regular expressions, visit Regular-Expressions.info.

**Make Indicator Columns**

Convert a categorical column into multiple indicator columns based on each distinct category. The columns are named after each level in the column. For example, when you make an indicator column from `sex` in Big Class.jmp, the indicator columns are named `F` and `M`.

Highlight a column in a data table and select **Cols > Utilities > Make Indicator Columns**. You can then indicate whether you want to prepend the original column name to the indicator column names (as in `sex_F` and `sex_M`) and include missing values.

Multiple columns with values of either 0 or 1 are created. A value of 1 indicates that the original column contains that specific category.

If the given column has the Multiple Response modeling type or Multiple Response column property, the categories are determined from the set of responses.
Combine Columns in Data Tables

The Combine Columns option is the opposite of Text to Columns. Instead of making multiple columns, you can combine a set of columns into one character column with delimited fields.

To combine indicator columns, follow these steps:

1. Select Help > Sample Data Folder and open Consumer Preferences.jmp.
2. Select the columns, Floss After Waking Up, Floss After Meal, and Floss Before Sleep.
4. Type “Combined Floss” for the column name, and keep the default delimiter as a comma.
5. Select Selected Columns are Indicator Columns and click OK.

Figure 4.36 Combined Floss Column

The selected columns are represented in the Combined Floss column with each field separated by a comma. Only the columns that have a value of 1 are represented in the combined column for each given row.

Note: Value labels show a label in the data table instead of a value. A label appears for each instance of the value in the combined column. You can show the original values by double-clicking a label within a cell. To avoid using value labels, select No Value Labels when you combine the columns.
Compress Selected Columns in Data Tables

JMP lets you compress columns in a data table to minimize the size of the file and reduce the amount of memory required to analyze data. This feature is helpful when numeric columns contain many small integers or when any column contains fewer than 255 unique values. For example, compressing columns in a data table with 389 columns and 85,000 rows might decrease the file size from 250MB to 33MB, depending on the type of data.

When you compress columns, JMP verifies whether the data can be stored in a more compact form based on the data type:

- In character columns with fewer than 255 unique values, the List Check property is added to the column where appropriate (Figure 4.37). When the preference Allow 16 Bit List Check Compression is selected, the List Check property is also added to character columns that have more than 255 unique values.

  The List Check property restricts the values in the selected column to valid values. The List Check property is not applied when the number of values in the selected column is too great. For example, if the number of values is almost the same as the number of rows, the data table does not add the List Check property to the column.

- For numeric columns, only those with the Best, Fixed Dec, or Data format are compressed. Data is compressed to 1-byte, 2-byte, or 4-byte integers when possible (Figure 4.38). For more information about short integers, see “The Short-Integer Format”.

  A numeric column with non-integer values can also be compressed if there are fewer than 255 unique values. In this case, the List Check property is added to the column.

Notes:

- To automatically compress a column that has less than or equal to 65,535 unique values, select the Allow 16 Bit List Check Compression preference in the General group. The List Check property is also added to the column.

- In a column with the List Check property, you can enter only a value that is in the list. Otherwise, JMP warns that the cell contains invalid data when you try to enter the new value. See “List Check”.
To compress columns, select one or more columns and select **Cols > Utilities > Compress Selected Columns**. (Select all columns if you do not know which columns can be compressed.)

The column or columns are compressed if possible. The log shows which columns were compressed and how they were compressed. (Select **View > Log** to show the log.)

**Note:** To compress a numeric column manually, set your Tables preferences to allow short numeric data and then change the column’s data type to **1-byte integer**, **2-byte integer**, or **4-byte integer**. For more information about this preference, see “Preferences for Data Tables”.

### Make a Binning Formula in a Data Table Column

You can distribute your data into bins using the Make Binning Formula option. Select the column or columns that you want to divide into bins, and select **Cols > Utilities > Make Binning Formula**. A histogram of the bins and a Value Label legend are shown, along with a red triangle menu that contains options for defining the cutpoints. There are several ways to add cutpoints, remove cutpoints, and adjust the bin sizes.

- Right-click in the histogram to add or remove cutpoints.
- Click and drag the vertical lines in the histogram to adjust the bin sizes.
• Edit the boxes next to the cutpoint value labels to edit the cutpoint values and adjust the bin sizes.
• Use the add and remove buttons above the Value Label legend to add and remove rows, which is equivalent to adding and removing cutpoints.
• Use the undo and redo buttons to undo or redo actions done on the bin settings.

There is an option to add formula columns for the cutpoints to the data table.

**Right-Click Options for Make Binning Formula**

Right-click the histogram in the Make Binning Formula window to select the following options:

**Add Cutpoint**  Adds a cutpoint line to the histogram in the location that was clicked.

**Remove Cutpoint**  Removes a cutpoint line. This option is available only if you right-click on an existing cutpoint.

**Show Counts**  Shows or hides the counts above the bars.

**Show Percents**  Shows or hides the percentages above the bars.

**Subset**  Creates a subset data table based on the current selection.

**Fill Pattern**  Specifies the fill pattern for the bars in the histogram.

**Red Triangle Options for Cutpoints**

The Cutpoints red triangle contains the following options:

**Fill using Equal Width Bins**  Specifies a start (offset) and a bin width. JMP fills in the table until it goes past the largest possible values. For example, if you enter offset=50 and width=10 and your largest data value is 95, you will get the following bins: 50, 60, 70, 80, 90, 100.

**Fill using Bin Count**  Specifies a start, end, and a bin count. JMP divides the space between the start and end equally by the bin count. If you change the bin count, the reported bin width is automatically updated in the window.

**Fill using Percentiles**  Specifies a percentage between 1 and 50. JMP divides the range of the data by that quantile. For example, if you specify a percentile of 20, you get five equal weight bins.

**Fill using Mean/StdDev**  Specifies the bin cutpoints to be set at the mean of the data plus the first, second, or third standard deviation from the mean based on your selection in the window.
**Fill using Jenks Natural Breaks**  Specifies a bin count and creates bin cutpoints so that the variance within each bin is minimized and the variance between the bins is maximized.

**Bin Label**  Specifies whether value labels are shown instead of the data values.

- **Use Value Labels**  Shows a label instead of the value shown in the new formula column defining the bins.
- **Use Range Labels**  Includes the lower and upper values for each range in the label.
- **No Labels**  Uses the lower edge value as the label.
- **Character**  Applies the Character data type. The formula produces the labels.

See “Value Labels”.

**Tip:** Value Labels are recommended in most platforms, many of which do not support range labels. In the Categorical platform, you must use value labels. On some axes, you might find that range labels more clearly identify the values, or you can try adjusting the offset and width for the axis.

**Bin Label Style**  Specifies a preset that defines what the Value Labels or Character output look like in the table.

- **Low–High**  Defines the Value Labels by the lowest and highest points of each bin. The format is Low–High.
- **Low to High**  Defines the Value Labels by the lowest and highest points of each bin. The format is Low to High.
- **Low, High**  Defines the Value Labels by the lowest and highest points of each bin. The format is Low, High.
- **Low–High-1 (integers)**  Defines the Value Labels by the lowest point and one less than the highest point of each bin. The format is Low–High-1.
- **Low to High-1 (integers)**  Defines the Value Labels by the lowest point and one less than the highest point of each bin. The format is Low to High-1.
- **[Low, High) (mathematical)**  Specifies that the lower value is included in the range and the upper value is not. For example, if your range is [50,60), then a value of 50 would be in the bin, but a value of 60 would not be.
- **Low**  Defines the Value Labels by the lowest point of each bin.
- **Midpoint**  Defines the Value Labels by the midpoint of each bin.
- **Integer Sequence**  Defines the Value Labels by a sequence of consecutive integers. Define the starting integer in the Integer Sequence Labels window.
**Uppercase Alphabetical**  Defines the Value Labels as uppercase letters in alphabetical order.

**Lowercase Alphabetical**  Defines the Value Labels as lowercase letters in alphabetical order.

**Custom**  Enables you to enter custom Value Labels.

**Column Format**  Specifies how the Value Labels are formatted. By default, the format of the column is applied. However, you might want to override the setting (for example, changing the format to Dollar). This setting is most useful if the column format is something like Best, but you really want your bins to have no decimals. Instead of cleaning up all of the value labels, you specify the format.

**Histogram**  Specifies whether counts or percentages appear above the bars.

**Show Points**  Shows or hides the observed data points below the bars.

**Rescale Axis**  Resets the axis to the original scale.

**Recall**  Populates the Make Binning Formula window with the last binning actions that you performed.

**Make All Like X**  (Appears only if multiple columns are selected.) Applies the choices made for the first column (X) to the remaining columns in the dialog.

**Make Formula Columns**  Creates the formula columns and closes the window.

**Tip:** Once you create a formula column, you can edit the formula by right-clicking on the column header and selecting **Edit Binning Formula.** This reopens the Make Binning Formula window. To update the binning formula column, edit the cutpoints and click **Update Column.**

---

**Example of Making a Binning Formula**

1. Select **Help > Sample Data Folder** and open Big Class.jmp.
2. Select the height column.
3. Select **Cols > Utilities > Make Binning Formula.**
   - You want the range of values to appear as X-X, so in the Bin Label Style, keep the range set to **Low - High.**
4. Click the Cutpoints red triangle and select **Fill using Equal Width Bins.**
5. In the window that appears, change the **offset** to -0.5.
For integer data, setting the offset to -0.5 helps disambiguate values on the edge. In this example, one of the bins covers 59.5 to 64.5, so it is clear that 59 and 65 are not included in this bin.

6. Keep the **width** set to 5.
7. Click **OK**.
8. Keep the Bin Label setting of **Use Value Labels** so that you can see the range of values for the bin.

**Figure 4.39** Completed Binning Window

9. Click **Make Formula Column**.

A column called **height Binned** is added to the **Big Class.jmp** data table.

10. To see how the formula is calculated, right-click the **height Binned** column and select **Formula**.

**Figure 4.40** Formula
Convert Labels to Codes and Codes to Labels

Suppose that you have a column of strings such as “dissatisfied”, “somewhat dissatisfied”, and “somewhat satisfied”, and “satisfied”. You can recode the values to “1”, “2”, “3”, and “4”. The original strings are placed in the Value Labels column property for that column. If the column has a List Check property, the property is removed. The column data type is changed to 1-byte Integer. Converting a column of strings to short numeric codes saves memory and can speed up processing.

You can also convert a numeric column of codes to labels. The column must have value labels. The column data type is changed to Character, and the Value Label column property is removed. This is, in effect, the opposite of converting labels to codes.

Convert Labels to Codes

1. Select the character column and select Cols > Utilities > Labels to Codes.

Figure 4.41 Converting Labels to Codes

![Default codes are assigned to the values.](image)

2. Change the codes if desired and click OK.
   The column is recoded, and value labels are added to the column.

Convert Codes to Labels

1. Select the numeric column that contains value labels and select Cols > Utilities > Codes to Labels.

2. Change the labels if desired and click OK.
   The column is recoded with the original value labels.
Make a New Formula Column

To perform further analyses on your data, use the New Formula Column menu options from your existing data table. Formula columns use formulas or calculations to define column values.

Right-click a column heading in your data table and select **New Formula Column**. Choose from Transform, Character, Combine, Pairwise, Aggregate, Distributional, Date Time, Random, Row, or Vector to calculate column values. A new formula column is added to the data table. See “Transform Columns in a JMP Platform” for a description of these options.

**Note:** The same options exist in both the New Formula Column menu, and the right-click column menu in the launch window. However, performing these tasks in a launch window results in a temporary column, and New Formula Column adds a new column to the original data table.

Right-click options depend on the selected column’s data type and the number of columns selected. If the selected column is a Character column, Character and Row options appear. See “Character Menu” and “Row Menu”.

Transform Columns in a JMP Platform

Each launch window in JMP enables you to create one or more temporary transform columns for use in performing analyses. These transform columns are not part of the source data table and only can be used within the context of the current launch window. Transform columns use formulas or calculations to define the column values. Closing the launch window deletes any transform columns.

Each column listed in the Select Columns pane of the launch window includes an icon representing the column’s modeling type (continuous, ordinal, or nominal) and the column name. Right-click a column name to create a transform column using Transform, Character, Combine, Pairwise, Aggregate, Distributional, Date Time, Random, Row, Vector, or Formula to calculate the column’s values.

Right-click options depend on the selected column’s data type and number of columns selected.
Group By  For ordinal and nominal data, specifies the column to use for grouping data. A separate analysis is computed for each level of the specified column.

Notes:

- The transform column is available only in the current launch window. To make the transform column available outside of the current launch window, right-click the transform column and select Add to Data Table. The transform column is added to the source data table.

- You can paste a transform column into a Roles box on the launch window. For example, you might copy a transform column from a script. Right-click in the appropriate launch window Cast Selected Columns into Roles box and select Paste. This is an alternative to right-clicking the column in the Select Columns list, selecting the transform, and adding the transform column to a role.

- If the transform function is invertible, the following platforms use the original scale for the prediction profiler and to save the predicted values and formulas.
Restructure Data Using JMP

- Fit Y by X
- Standard Least Squares
- Partition
- Boosted Tree
- Bootstrap Forest

- Define your own transform by writing a JSL script. See the Scripting Guide.

Transform Menu

Select a function from the Transform menu to create a transform column containing the calculations based on the selected function. See the Scripting Index in the Help menu or Fitting Linear Models.

**Note:** You can apply unary functions to multiple columns resulting in multiple transform columns.

**Table 4.2** Descriptions of the Transform Menu Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Round</td>
<td>Rounds date values. For example, in a chart of weeks, Round converts the date values into the first date of each week that they occur on.</td>
</tr>
<tr>
<td>Scale Offset</td>
<td>Enables you to specify a general linear transform. For example, you might multiply the value by 1.8 and apply an offset of 32 to convert Celsius temperatures to Fahrenheit.</td>
</tr>
<tr>
<td>Custom Binning</td>
<td>Opens the binning window which enables you to distribute the data into bins.</td>
</tr>
<tr>
<td>Square Root</td>
<td>Takes the square root of the values of the selected column.</td>
</tr>
<tr>
<td>Square</td>
<td>Calculates the square for the selected column values.</td>
</tr>
<tr>
<td>Log</td>
<td>Applies the natural logarithm transformation to the selected column.</td>
</tr>
<tr>
<td>Log x+1</td>
<td>Calculates Log(col+1).</td>
</tr>
<tr>
<td>Exp</td>
<td>Applies the exponential transformation to the selected column.</td>
</tr>
<tr>
<td>Log10</td>
<td>Applies the base-10 logarithm transformation to the selected column.</td>
</tr>
<tr>
<td>Pow10</td>
<td>Calculates 10 raised to the power of the selected column values.</td>
</tr>
</tbody>
</table>
### Table 4.2 Descriptions of the Transform Menu Options (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cube Root</strong></td>
<td>Calculates the cube root for the selected column values.</td>
</tr>
<tr>
<td><strong>Cube</strong></td>
<td>Calculates the cube for the selected column values.</td>
</tr>
<tr>
<td><strong>Reciprocal</strong></td>
<td>Calculates the reciprocal (1/column) for the selected column values.</td>
</tr>
<tr>
<td><strong>Absolute Value</strong></td>
<td>Calculates the absolute value for the selected column values.</td>
</tr>
<tr>
<td><strong>Negation</strong></td>
<td>Calculates the negative for the selected column values.</td>
</tr>
</tbody>
</table>
| **Arrhenius**  | Applies the Arrhenius transformation to the variable T (temperature in degrees Centigrade):  
                    \[
                    X = \frac{11604.5181215503}{T + 273.15}
                    \]
                    This is the component of the Arrhenius relationship that is multiplied by the activation energy. |
| **Arrhenius Inverse** | Applies the inverse of the Arrhenius transformation to the variable X:  
                    \[
                    T = \frac{11604.5181215503}{X} - 273.15
                    \]
| **Logit**      | Calculates the inverse of the logistic function for the selected column (where \( p \) is in the range of 0 to 1):  
                    \[
                    \text{Logit}(p) = \log\left(\frac{p}{1-p}\right)
                    \]
| **Logistic**   | Calculates the logistic (also known as Squish and Logist) function for the selected column (where the result is in the range of 0 to 1):  
                    \[
                    \text{Logistic}(x) = \frac{1}{1 + e^{-x}}
                    \]
Chapter 4
Restructure Data

Table 4.2 Descriptions of the Transform Menu Options  (Continued)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logit Percent</td>
<td>Calculates the logit as a percent for the selected column (where ( pct ) is a percent in the range of 0 to 100):</td>
</tr>
</tbody>
</table>
|                   | \[
| LogitPct(pct) = \log\left( \frac{\frac{pct}{100}}{1 - \frac{pct}{100}} \right) \]
| Logistic Percent  | Calculates the logistic (or logist) as a percent for the selected column (where the result is in the range of 0 to 100): |
|                   | \[
| LogisticPct(x) = \frac{100}{1 + e^{-x}} \]

**Combine Menu**

Select multiple columns to access the Combine menu. The Combine menu creates a transform column containing the calculations based on the selected function.

The following functions are included in the menu:

- **Sum**  Calculates the sum of the first and second columns (\( A + B \)).
- **Difference**  Calculates the difference between the first and second columns (\( A - B \)).
- **Difference (reverse order)**  Calculates the difference between the second and first columns (\( B - A \)).
- **Product**  Calculates the product of the first and second columns (\( A \times B \)).
- **Ratio**  Calculates the ratio of the first column to the second column (\( A / B \)).
- **Ratio (reverse order)**  Calculates the ratio of the second column to the first column (\( B / A \)).
- **Minimum**  Returns the minimum value of the selected columns.
- **Maximum**  Returns the maximum value of the selected columns.
- **Average**  Returns the average value of the selected columns.
- **Standard Deviation**  Calculates the standard deviation of the values in the selected column.
- **Median**  Calculates the median value for the selected column.
- **Quantile**  Calculates the quantile of the specified percentage for the selected column.
**Geometric Mean**  Returns the $n$th root of the product of the data.

**Pairwise Menu**

Select a function from the Pairwise menu to create pairwise results for two or more columns. This menu appears only when the number of selected columns is even and greater than or equal to four.

- **Sum**  Calculates the sum of the first and second columns ($A + B$).
- **Difference**  Calculates the difference between the first and second columns ($A - B$).
- **Difference (reverse order)**  Calculates the difference between the second and first columns ($B - A$).
- **Product**  Calculates the product of the first and second columns ($A \times B$).
- **Ratio**  Calculates the ratio of the first column to the second column ($A / B$).
- **Ratio (reverse order)**  Calculates the ratio of the second column to the first column ($B / A$).
- **Minimum**  Returns the minimum value of the selected columns.
- **Maximum**  Returns the maximum value of the selected columns.
- **Average**  Returns the average value of the selected columns.
- **Geometric Mean**  Returns the $n$th root of the product of the data.

**Aggregate Menu**

Select a function from the Aggregate menu to create a transform column containing the statistics calculated from the selected column (or part of a column if you specified a Group By column).

*Note:* The **Group By** option is useful for these functions.

The following functions are included in the menu:

- **Mean**  Returns the average value of the selected column.
- **Sum**  Calculates the sum of the values in the selected column.
- **Count**  Calculates the number of values in the selected column.
- **Median**  Calculates the median value for the selected column.
- **Quantile**  Calculates the quantile of the specified percentage for the selected column.
- **Minimum**  Returns the minimum value of the selected column.
Maximum  Returns the maximum value of the selected column.

Standard Deviation  Calculates the standard deviation of the values in the selected column.

Distributional Menu

Select a function from the Distributional menu to create a transform column containing the
statistics calculated from the selected column. See the Scripting Index in the Help menu.

The following functions are included in the menu:

Center  Subtracts the column mean from each value across all rows of the selected column.

Standardize  Calculates the column value minus the mean divided by the standard deviation
across all rows of the selected column.

Range 0 to 1  Scales the data up or down so that the minimum value is greater or equal to 0,
and the maximum value is less than or equal to 1.

Box Cox  Transforms the data using the Box-Cox equation. See Fitting Linear Models.

Node Normalizing  Transforms the data using one of the Johnson equations. The new
column name indicates either Johnson Su, Johnson Sb, or None, depending on which
equation was used to calculate the new data.

Informative Missing  Creates two columns. The Informative column replaces missing values
with the column mean. The Is Missing column indicates 1 for missing values, and 0
otherwise.

Rank  Returns the rank, ranging from 1 as the lowest, with row-order tie-breaking.

Rank (reverse order)  Returns the rank, ranging from 1 as the highest, with row-order
tie-breaking.

Cumulative Probability  Calculates the cumulative probability: Col Rank(col) / (Col
Number(col) + 1).

Normal Quantile  Calculates the quantile from a Normal distribution.

SHASH  Calculates the cumulative distribution function (cdf) evaluated at x of the
sinh-arcsinh (SHASH) distribution.

Random Menu

For numeric columns, select a function from the Random menu to create columns with
random values.
The following functions are included in the menu:

**Random Uniform**  Generates random numbers uniformly between 0 and 1.

**Random Normal**  Generates random numbers that approximate a normal distribution with a mean of 0 and standard deviation of 1 if no arguments are used, or with the mean and standard deviation entered as arguments.

**Sample without Replacement**  Shuffles the values randomly each time it’s evaluated. The result for the first value affects the result for the second value.

**Sample with Replacement**  Shuffles the values randomly each time it’s evaluated. The result for the first value does not affect the result for the second value.

**Date Time Menu**

For column values containing date or time values, select a function from the Date Time menu to create a transform column containing values calculated from the selected column.

The following functions are included in the menu:

**Day**  Returns the day of the month for the date in the selected column.

**Month**  Returns the month number for the date in the selected column.

**Month Abbr.**  Returns the abbreviated month for the date in the selected column.

**Year**  Returns the year for the date in the selected column.

**Month Year**  Returns the month number and year for the date in the selected column.

**Quarter**  Returns the year’s quarter (1, 2, 3, or 4) for the date in the selected column.

**Week**  Returns the number of the week in the year for the date in the selected column.

**Year Quarter**  Returns the year and the year’s quarter (1, 2, 3, or 4) for the date in the selected column.

**Year Week**  Returns a string representing the ISO-8601 week of year format (for example, June 12, 2013 results in “2013W24”).

**Day of Year**  Returns the day of the year for the date in the selected column.

**Day of Week**  Returns the day of the week for the date in the selected column.

**Day of Week Abbr.**  Returns the abbreviated day of the week for the date in the selected column.

**Day of Week Name**  Returns the full day of the week for the date in the selected column.

**Date**  Returns the month, day, and year for the date in the selected column.
Time of Day  Returns the time for the date in the selected column.

Hour    Returns the hour part of the date in the selected column.

Minute  Returns the minute part of the date in the selected column.

Second  Returns the seconds part of the date in the selected column.

Character Menu

Select a function from the Character menu to create a transform column containing strings formed by the selected Character function.

The following functions are included in the menu:

Length     Calculates the number of characters in each string in the selected column or columns.

Concatenate Concatenates the strings in the selected column or columns into a new string.

Concatenate with Space Concatenates the strings in the selected column or columns into a new string with each sub-string separated by a whitespace character.

Concatenate with Comma Concatenates the strings in the selected column or columns into a new string with each sub-string separated by a comma character.

Titlecase Converts the strings to title-case (for example, “Sheila Smith”).

Uppercase Converts the strings to uppercase (for example, “SHEILA SMITH”).

Lowercase Converts the strings to lowercase (for example, “sheila smith”).

First Word Extracts the first word from a character string in the selected column or columns.

Last Word Extracts the last word from a character string in the selected column or columns.

Rank       Returns the rank, ranging from 1 as the lowest, with row-order tie breaking.

Rank (reverse order) Returns the rank, ranging from 1 as the highest, with row-order tie-breaking.

Row Menu

Select a function from the Row menu to create a transform column containing calculations determined by the selected Row function.

In addition to the functions described in the appendix, the following functions are included in the menu:

Row       Returns the current row number.

Selected   Returns the selected index.
Difference  Calculates the difference of each value in the selected column using the formula:

\[
\begin{align*}
\text{Row( )} &= 1 \\
\text{else} &\Rightarrow \text{Dif (kHours, )}
\end{align*}
\]

**Note:** The Difference function also supports the Group By option.

Lag  Returns the value in the previous row for the selected column.

Lag Multiple  Returns the values from multiple previous rows for the selected column.

Cumulative Sum  Calculates the cumulative sum for each value in the selected column using the formula:

\[
\begin{align*}
\text{Row( )} &= 1 \\
\text{else} &\Rightarrow \text{kHours} + \text{Lag ( )}
\end{align*}
\]

**Note:** The Cumulative Sum function also supports the Group By option.

Moving Average  Calculates the exponentially weighted moving average, EWMA (using a smoothing parameter between 0 to 1.0) for each value in the selected column. The following example uses a smoothing parameter of 0.25:

\[
\begin{align*}
\text{Row( )} &= 1 \\
\text{else} &\Rightarrow \text{kHours} + 0.25 \times \text{Lag ( )} \times 0.75
\end{align*}
\]

Weighting  Determines how the values are weighted. Incremental weighting is a ramp or triangle. The exponential moving average is EWMA or EMA.

Items Before  Controls the size of the range (or window) by including the specified number of items before the current item in the average (in addition to the current item). -1 means all prior items.

Items After  Controls the size of the range (or window) by including the specified number of items after the current item in the average (in addition to the current item). -1 means all following items.

Report missing values for partial window  Controls how missing values are treated. By default, missing values are ignored.

**Note:** JMP evaluates the formula entered on-demand; complex formulas might require a lot of processing time.
Vector Menu

Select a transform from the Vector menu to create transform columns from vector data.

- **To Columns**: Expands the vector into individual number columns.
- **Sum**: Returns the sum of the arguments or of the values within the vector.
- **Min**: Returns the minimum value among the values within the vector.
- **Max**: Returns the maximum value among the values within the vector.
- **Loc Min**: Returns the first position of the minimum value.
- **Loc Max**: Returns the first position of the maximum value.

Transform Column Options

After creating a transform column, you can perform the following actions:

- **Rename**: Renames the transform column.
- **Add to Data Table**: Adds the transform column to the data table as a formula column.

Recode Data in a Column

Use the recoding tool to change all of the values in a column at once. For example, suppose you are interested in comparing the sales of computer and pharmaceutical companies. Your current company labels are Computer and Pharmaceutical. You want to change them to Technical and Drug. Going through all 32 rows of data and changing all the values would be tedious, inefficient, and error-prone, especially if you had many more rows of data. Recode is a better option.

**Notes:**

- To recode similar values within multiple columns, use the Recode option in **Cols > Standardize Attributes**. See “Standardize Column Attributes”.
- To recode only column headings, select **Cols > Column Names > Recode Column Names**.

To recode data, follow these steps:

1. Select **Help > Sample Data Folder** and open **Companies.jmp**.
2. Select the Type column by clicking once on the column heading.
3. Select **Cols > Recode**.

   Notice that New Column is selected by default to place the recoded values in a new column. The new column is named **Type 2**.
4. In the Recode window, enter the desired values in the **New Value** boxes. For this example, enter Technical in the Computer row, and Drug in the Pharmaceutical row. Notice that the recoded values appear in the Changes box.

**Figure 4.43** Recode Window

The asterisk indicates which values have changed.

5. Click **Recode**.

The new values appear in the data table under a new column called Type 2.

**Notes:**

- By default, the recoded data appears in a new column. To always recode the column that you selected, select **File > Preferences** (Windows) or **JMP > Preferences** (macOS), select **Recode**, and then select **In Place** from the Commit Style list.
- By default, the data in the Recode window is sorted by new value in ascending order. This applies to both Recode and Recode Column Names. To change how data is sorted, select **File > Preferences** (Windows) or **JMP > Preferences** (macOS), select **Recode** and change the Sort Style preference. Select **Old Value** to sort column names by the natural order they
appear in the data table and data by the order in the value order column property, if specified. Select Count to sort by count in descending order.

- If the data table contains value labels, the labels appear in a column in the Recode window called New Labels. Editing the labels also modifies the Value Labels column property. You can also select Replace values with value labels to modify the data in the New Values column.

- The following column properties are updated when you recode a column: Value Labels, Value Scores, Value Order, Value Colors, Supercategories, Coding, and Missing Value Codes.

- If you enter a non-numeric value in a column with a Numeric data type, you are prompted to convert the data type to Character. Click Yes to convert the column and display the new value. Click No to keep the column Numeric and display a missing value.

- Selecting rows on the Recode window also selects them in the data table for quick editing.

- The recoding tool supports expression columns.

Recode Options

The following options are available in the list next to the Recode red triangle:

New Column  Creates a new column for the changed data and retains the original column.

Formula Column  Creates a new column with the changes as a formula instead of values. Changing a value in the original column in the data table causes the formula column to update that value automatically.

In Place  Applies any change to the original data column.

The remaining options are available on the Recode window:

Filter  Searches for specific values. Click the down arrow to select search options. For more information about each option, see “Search Filter Options in Recode”. Note that you can type a regular expression to customize the filter.

View Groups  Deselect to view ungrouped values. Selected by default.

Show Only Grouped  Shows recoded values that have been grouped.

Show Only Ungrouped  Shows values that have not been grouped.

Group  Becomes active when multiple values are selected. Click Group to make highlighted values part of the same group. If you previously edited a value before grouping, the edited value becomes the group representative in the New Value column. Otherwise, the group representative is the value that occurs most often.

All  Shows all data values.
Only Modified  Shows only modified recoded values.

Only Unmodified  Shows only unmodified recoded values.

Changes  Shows a list of changes made in the Recode window.

Reverses the last change made to the window.

Recalls the last change made to the window.

Scripting

To save a script to re-create the recoded data table, select Script from the red triangle menu and then select an option.

The Recode window includes the following script options:

Script sequence of actions  Attempts to save your actions to a script and omit the data. If you convert all strings to uppercase using the red triangle option, the generated script contains code that converts input strings to uppercase without including the data.

Compress sequence  Compresses the script of sequenced actions by removing unnecessary operations. Consider this option to speed up recoding that contains multiple edits.

Multiple Response

Remove empty items  In a Multiple Response column, excludes empty items in the column when recoding the column in the data table.

Remove duplicate items  In a Multiple Response column, excludes duplicate items. For example, if the original data were a, b, b, c, and no changes to those particular items were made, the recoded column in the data table would contain a, b, c.

Sort items  In a Multiple Response column, sorts items alphabetically. For example, if the original data were b, a, c, and no changes to those particular items were made, the recoded column in the data table would contain a, b, c.

Red Triangle Options for Recode

The red triangle menu contains options for the Recode window.

Convert to Titlecase  Converts the first letter of each word to uppercase, and the remaining letters to lowercase.

Convert to Uppercase  Converts all values to uppercase.

Convert to Lowercase  Converts all values to lowercase.
**Trim Whitespace**  Removes leading and trailing whitespace characters. For example, if an extra space was imported before and after the name John, this command would delete the spaces.

**Remove Whitespace**  Removes trailing, leading, and interior whitespace characters.

**Collapse Whitespace**  Removes leading and trailing whitespace characters and removes duplicate interior whitespace characters. That is, if more than one whitespace character is present, the **Collapse Whitespace** command replaces the two spaces with one space.

**Remove Punctuation**  Removes special characters (such as quotation marks and ampersands) from the beginning, middle, and end of words.

**Replace String**  Replaces all occurrences of specified characters with a new string or with nothing. Note that you can type a regular expression to customize the replacement.

**First Word**  Groups values based on the first word of the string. For example, if “John Smith” and “John Adams” were values, this command would group them under “John.”

**Last Word**  Groups values based on the last word of the string.

**Group Similar Values**  Enables you to customize how data is grouped. Choose from the grouping options list. See “Group Similar Values Options for Recode”.

**Advanced**

- **All but First Word**  Splits values based on the remaining value after the first word is excluded.

- **All but Last Word**  Splits values based on the remaining value after the last word is excluded.

- **Apply Mapping from Table**  Enables you to use columns in a mapping data table to modify values in the target table. See “Example of Applying Values from Mapping Columns”.

- **Extract Segment**  Enables you to extract specific strings. See “Example of Splitting on a Comma”.

- **Choose Closest**  Enables you to map values in the column of a mapping data table to the column that you are recoding.

**Parse as Numbers**  Converts the data to numbers.

**Labels to Codes**  Converts labeled values to codes.

**Convert to Character**  In a numeric column, converts the column to a character column.

**Add Value Labels**  Enables you to assign value labels to each value.
Replace Values with Value Labels  Replaces the values specified in the Value Label column property with the value labels that you specify. This option is available only when the column has a Value Label property.

Recall  Recalls previous changes made in the Recode window.

Start Over  Returns the window to the default condition.

Script  View options to import, merge, or save Recode scripts.

- Import from File  imports a JSL script to recode previously recoded data. Run the same script on different data to recode data the same way.

- Import from Data Table  imports a JSL script saved to a data table.

- Import from Recode Result Column  imports data from the column that you select, usually the column in which you saved previous recode results.

- Save to File  saves Recode changes to a JSL script. After selecting Save, you are prompted to name and save the file.

- Save to Data Table  saves a Recode script to current data table.

- To modify the recoding in a saved script, right-click the script in the data table and select Edit with Recode. After making changes, select Script > Save to Data Table from the red triangle menu again to save your changes in a new script.

- Merge with Data Table Script  merges changes made in the Recode window to the current Recode script saved to the data table. If there are multiple scripts, you are prompted to choose which script to merge your recoded data with.

- Save to Script Window  appends the Recode script to the script window.

Publish to Formula Depot  Publishes the recode script to the Formula Depot, which enables you to reuse the code in other scripts.

Right-Click Options for Recode

The first six options are available for grouped values:

Group to New Value  (Available only when you select multiple values) Enables you to specify a new value for the two or more selected values.

Group to  (Available only when you select multiple values) Right-click selected values to select a different grouping value, or group representative. The list shows the first eight possible group representatives.

Swap New Values  When two values are highlighted, select Swap New Values to make the new value of the first value adopt the new value of the second value, and vice versa.

Make Representative  Right-click a single value from a group and select Make Representative to make the selected value the new value.
Remove From Group  After values are grouped, right-click one or more values to remove
them from that group.

Group Similar Values  Right-click a single string to find values that are similar. The Grouping
Options window appears. See “Group Similar Values Options for Recode”.

Open All Groups  Opens the groups so that you can see all of the values in each group.

Close All Groups  Collapses the values within each group.

The following options are available for all data:

Select Rows  Selects the selected rows in the data table. When you select a row in the Recode
window, the corresponding rows are automatically selected in the data table. However, if
you select rows in the data table, the rows are not selected in Recode. If you want to select
only the rows shown in the Recode window, right-click the row, and select this option.

Make into Data Table  Creates a data table of the results shown in the Recode window.

Copy Selected Column Rows  Copies the data only from the column that you right-clicked.
You can then paste the data into a data table.

Copy Selected Table Rows  Copies the data for all columns. You can then paste the data into
a data table.

Group Similar Values Options for Recode

Select the following Group Similar Values commands to increase the accuracy of grouping:

Ignore Case  Item case is ignored.

Ignore Non-Printable Characters  Non-printable characters are ignored. Some data can
include non-printable characters (such as file separators) that only the computer can read.

Ignore Whitespace  White space is ignored.

Ignore Punctuation  Punctuation is ignored.

Allow Character Edits  Enables characters to be replaced by the new value when similar
values are grouped.

Max Difference Ratio  Groups values according to the maximum proportional difference.
For example, type “.25” to group values that are at most 25% different.

Max Character Difference  Groups values according to a maximum number of nonadjacent
character differences. For example, type “5” to group values that differ by five characters
or less.
**Min Source String Length**  Prevents strings from being matched if they are too short. Experiment with this option and the Difference Ratio and Max Character Difference options to specify a value that works for your data.

**Search Filter Options in Recode**

Click the down arrow button next to the search box to refine your search.

**Contains Terms**  Returns items that contain a part of the search criteria. A search for “ease oom” returns messages such as “Release Zoom”.

**Contains Phrase**  Returns items that contain the exact search criteria. A search for “text box” returns entries that contain “text” followed directly by “box” (for example, “Context Box” and “Text Box”).

**Starts With Phrase**  Returns items that start with the search criteria.

**Ends With Phrase**  Returns items that end with the search criteria.

**Whole Phrase**  Returns items that consist of the entire string. A search for “text box” returns entries that contain only “text box”.

**Regular Expression**  Enables you to use the wildcard (*) and period (.) in the search box. Searching for “get.*name” looks for items that contain “get” followed by one or more words. It returns “Get Color Theme Names”, “Get Name Info”, and “Get Effect Names”, and so on.

**Invert Result**  Returns items that do not match the search criteria.

**Match All Terms**  Returns items that contain both strings. A search for “t test” returns elements that contain either or both of the search strings: “Pat Test”, “Shortest Edit Script” and “Paired t test”.

**Ignore Case**  Ignores the case in the search criteria.

**Match Whole Words**  Returns items that contain each word in the string based on the Match All Terms setting. If you search for “data filter”, and Match All Terms is selected, entries that contain both “data” and “filter” are returned.

**Example of Grouping by Similar Values**

You can group similar values according to the number of characters that differ between them.

1. Select **Help > Sample Data Folder** and open Candy Bars.jmp.
2. Select the **Name** column.
3. Select **Cols > Recode**.
4. Click the red triangle and select **Group Similar Values**.
5. Make sure that Allow Character Edits is selected.

6. Next to Max Different Ratio, type “.5”.
   
   This allows JMP to group values that differ by 50% or less. In other words, values that share at least 50%, or half, of the same characters. The Difference Ratio is determined by comparing the total number of characters of each value and the total amount of unique characters between two given values.

7. Next to Max Character Difference, type “6”.
   
   Values that have no more than six characters are grouped.

8. Click OK.

Figure 4.44 Grouping Similar Values

![Figure showing grouped values](image)

The values shown in the New Value column represents the grouped values in the recoded data table.

9. (Optional) To change the new value to represent a different old value in a group, right-click Almond Roca and select Make Representative.
10. (Optional) To replace the original data in the data table with the recoded data, select In Place from the red triangle menu, and then click Recode.

**Example of Splitting on a Comma**

The Aircraft Incidents.jmp sample data table contains a column of city and state names separated by a comma. You can split the values in that column on the comma and recode the column with only state names.

1. Select Help > Sample Data Folder and open Aircraft Incidents.jmp.
2. Select the Location column and select Cols > Recode.

**Figure 4.46  Original Data**

<table>
<thead>
<tr>
<th>Old Values (1537)</th>
<th>New Values (1537)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abilene, TX</td>
<td>Abilene, TX</td>
</tr>
<tr>
<td>Adelanto, CA</td>
<td>Adelanto, CA</td>
</tr>
<tr>
<td>Afton, VA</td>
<td>Afton, VA</td>
</tr>
<tr>
<td>Alleia, HI</td>
<td>Alleia, HI</td>
</tr>
<tr>
<td>Aiken, TX</td>
<td>Aiken, TX</td>
</tr>
<tr>
<td>Ainsworth, NE</td>
<td>Ainsworth, NE</td>
</tr>
<tr>
<td>Akachak, AK</td>
<td>Akachak, AK</td>
</tr>
<tr>
<td>Akron, CO</td>
<td>Akron, CO</td>
</tr>
<tr>
<td>Alamogordo, NM</td>
<td>Alamogordo, NM</td>
</tr>
<tr>
<td>Alamosa, CO</td>
<td>Alamosa, CO</td>
</tr>
<tr>
<td>Albion, IL</td>
<td>Albion, IL</td>
</tr>
<tr>
<td>Albuquerque, NM</td>
<td>Albuquerque, NM</td>
</tr>
<tr>
<td>Alcoa, WY</td>
<td>Alcoa, WY</td>
</tr>
<tr>
<td>Alexander City, AL</td>
<td>Alexander City, AL</td>
</tr>
<tr>
<td>ALEXANDER, AK</td>
<td>ALEXANDER, AK</td>
</tr>
<tr>
<td>Alice, ND</td>
<td>Alice, ND</td>
</tr>
<tr>
<td>Amalanchy, NJ</td>
<td>Amalanchy, NJ</td>
</tr>
<tr>
<td>Almond, WI</td>
<td>Almond, WI</td>
</tr>
<tr>
<td>Alton, IL</td>
<td>Alton, IL</td>
</tr>
<tr>
<td>Alturas, CA</td>
<td>Alturas, CA</td>
</tr>
<tr>
<td>Altus, OK</td>
<td>Altus, OK</td>
</tr>
<tr>
<td>Alvarado, TX</td>
<td>Alvarado, TX</td>
</tr>
<tr>
<td>Amargosa Valley, NV</td>
<td>Amargosa Valley, NV</td>
</tr>
<tr>
<td>Amarillo, TX</td>
<td>Amarillo, TX</td>
</tr>
<tr>
<td>AMHERST, NH</td>
<td>AMHERST, NH</td>
</tr>
</tbody>
</table>

3. Click the red triangle and select Advanced > Extract Segment.
In the Preview pane, notice that the data contain cities followed by a comma and abbreviated state names. You will extract the last two characters of each string.

4. Deselect Include Whitespace and Include Punctuation at the top of the window.
   Whitespace and punctuation will not be considered in the extraction.

5. Type a comma in the Characters box.

**Figure 4.47** Specifying a Delimiter

![Delimiter Window]

The comma is used to extract the last two characters.

6. In the Extract Segment window, type “2” above Start Anchor and End Anchor.
   The segment extraction begins and ends with the second word.

7. Make sure that From Start is selected for the Start Anchor and End Anchor options.
8. In the Preview pane shown in Figure 4.48, notice that the replacement values contain only the state abbreviations.

9. Scroll down in the Preview pane. Notice that the current value and replacement value for Atlantic Ocean are the same. The data couldn’t be split on a comma.

10. Click **OK**.

   Entries with a matching state name are grouped.
Figure 4.50 Recoded City, State Name

Example of Applying Values from Mapping Columns

A column in a mapping data table contain values that you can use to recode a column in another data table. In this example, U.S. states in State Capitals.jmp are replaced with the state abbreviations defined in State Abbreviations.jmp (the mapping data table).

1. Select Help > Sample Data Folder and open State Abbreviations.jmp and State Capitals.jmp.
2. In State Capitals.jmp, select the U.S. States column.
4. Click the red triangle and select Advanced > Apply Mapping from Table.
5. Click Choose Table, select State Abbreviations.jmp, and click OK.
6. In the Match Column box, select U.S. States.
7. In the Replace With Column box, select Abbreviations.

The Match and Replace With columns show the result of the mapping.

Figure 4.51 Matching and Replacing Columns

8. Select the Replace unmatched items with box and type “no match”.

The Preview section shows how the values are mapped. Scroll down and notice that the “no match” states are misspelled, so they don’t map to any state in the Abbreviations column.
9. Click **OK** and then click **Recode**.

A new column of abbreviated state names appears in *State Capitals.jmp* in a new column called *U.S. States 2*.

To fix the entries that weren’t matched, see “Example of Fixing Misspelled Words”.

---

**Figure 4.52** Preview of Unmatched Columns

<table>
<thead>
<tr>
<th>Current Value</th>
<th>Replacement Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kentucky</td>
<td>KY</td>
</tr>
<tr>
<td>Louisiana</td>
<td>LA</td>
</tr>
<tr>
<td>Maine</td>
<td>ME</td>
</tr>
<tr>
<td>Maryland</td>
<td>MD</td>
</tr>
<tr>
<td>Massachusetts</td>
<td>no match</td>
</tr>
<tr>
<td>Michigan</td>
<td>MI</td>
</tr>
<tr>
<td>Minnesota</td>
<td>MN</td>
</tr>
<tr>
<td>Mississippi</td>
<td>no match</td>
</tr>
</tbody>
</table>

**Figure 4.53** Abbreviated State Names

<table>
<thead>
<tr>
<th>U.S. States</th>
<th>U.S. States 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alabama</td>
<td>AL</td>
</tr>
<tr>
<td>Alaska</td>
<td>AK</td>
</tr>
<tr>
<td>Arizona</td>
<td>AZ</td>
</tr>
<tr>
<td>Arkansas</td>
<td>AR</td>
</tr>
<tr>
<td>California</td>
<td>CA</td>
</tr>
<tr>
<td>Colorado</td>
<td>CO</td>
</tr>
<tr>
<td>Connecticut</td>
<td>CT</td>
</tr>
<tr>
<td>Delaware</td>
<td>DE</td>
</tr>
<tr>
<td>Florida</td>
<td>FL</td>
</tr>
<tr>
<td>Georgia</td>
<td>GA</td>
</tr>
<tr>
<td>Hawaii</td>
<td>HI</td>
</tr>
<tr>
<td>Idaho</td>
<td>ID</td>
</tr>
<tr>
<td>Illinois</td>
<td>IL</td>
</tr>
<tr>
<td>Indiana</td>
<td>IN</td>
</tr>
<tr>
<td>Iowa</td>
<td>IA</td>
</tr>
<tr>
<td>Kansas</td>
<td>KS</td>
</tr>
<tr>
<td>Kentucky</td>
<td>KY</td>
</tr>
<tr>
<td>Louisiana</td>
<td>LA</td>
</tr>
<tr>
<td>Maine</td>
<td>ME</td>
</tr>
<tr>
<td>Maryland</td>
<td>MD</td>
</tr>
<tr>
<td>Massachusetts</td>
<td>no match</td>
</tr>
<tr>
<td>Michigan</td>
<td>MI</td>
</tr>
<tr>
<td>Minnesota</td>
<td>MN</td>
</tr>
<tr>
<td>Mississippi</td>
<td>no match</td>
</tr>
<tr>
<td>Missouri</td>
<td>MO</td>
</tr>
</tbody>
</table>
Example of Fixing Misspelled Words

You can use a data table as a dictionary to fix misspelled words. State Abbreviations.jmp contains columns of U.S. state names and abbreviations. State Capitals.jmp contains a few misspelled state names to mimic real data. This example shows how to fix the misspelled state names.

1. Select Help > Sample Data Folder and open State Abbreviations.jmp and State Capitals.jmp.
2. In State Capitals.jmp, select the U.S. States column.
4. Click the red triangle and select Advanced > Choose Closest.
5. Click Choose Table, select State Abbreviations, and click OK.
6. In the Match Column box, select U.S. States.
7. In the Preview pane, scroll down and notice that “Massachusets” will be replaced with “Massachusetts”, “Missisippi” will be replaced with “Mississippi”.

Figure 4.54 Misspelled State Replacement

8. Click OK and then click Recode.

A new column that contains the updated state names is added to the data table.

Example of Parsing as Numbers

The Parse as Numbers option turns character data into numeric data. This option is comparable to the JSL Num() character function.

Many formats are supported, such as date and times, currency, and scientific notations. If a format is unsupported, a missing value is displayed.

1. Open your data table and select a column that contains both numeric and character values.
2. Select **Cols > Recode**.

3. Select **Parse as Numbers** from the red triangle menu.
   
The old and new values are shown.

4. Click **Recode**.
   
   A new column with recoded values is added to the data table. The data type of the column is Numeric.
   
   “a” couldn’t be parsed as a number, so a missing value is displayed in the new column for that value.

**Example of Applying Recoded Values to a Different Column**

When you recode a column, you can save the recoded values in a script. When you import or run the script, the column that you originally recoded is recoded again.
Suppose that you want to recode a different column with the same values. Save the recoded values in a formula column and then edit the formula.

1. Enter the recoded values in the New Values column of the Recode window.
2. Select **Formula Column** from the list next to the red triangle menu.
3. Click **Recode**.
4. Right-click the formula column and select **Formula**.
5. In the formula, select the column that was recoded.
   In this example, the *sex* column was recoded.

**Figure 4.58** Recoded Column

6. In the Columns list, select the column that will replace *sex*.
   In this example, you want to replace the *sex* column with *gender*, so select *gender*.

**Figure 4.59** Selecting the gender Column
Edit Data Tables

JMP provides many ways to change the basic properties of a data table.

- “Rename Data Tables”
- “Lock Data Tables”
- “Compress Data Tables”
- “Copy Table Scripts”
- “Use Data Table Variables”
- “Create and Save Scripts in Data Tables”

Rename Data Tables

A data table’s name appears at the top of its window, in the table panel, and on all related analysis reports. You can change a data table’s name in any of the following ways:

- Select File > Save As and save as the new name.
- In the table panel, click table name, type the new name, and then press Enter.
- On Windows, select Window > Set Title.

Lock Data Tables

Locking a data table prevents data and column properties from being added or edited. You can still assign row states, run analyses, and so on. To lock a data table, click the red triangle next to the table name in the table panel and select Lock Data Table.

A lock icon  appears next to the data table name. To unlock the file, select Lock Data Table again.

If you make a data table read-only outside of JMP (for example, by changing its properties on Windows), the data table contains a note informing you that it is locked (Figure 4.60). This type of lock allows users to edit the data table, but not save the changes.
Compress Data Tables

Compressing a data table reduces the size of the stored file. You can still run analyses, assign characteristics, and so on. To compress a data table, click the red triangle next to the table name in the table panel and select Compress File When Saved and save the data table.

After saving the data table, a compressed icon appears next to the data table name. To decompress the file, select Compress File When Saved again.

In addition, you can configure JMP to always use GZ compression when saving by selecting Preferences > General > Save Data Table Columns GZ Compressed.

Note: The Compress File When Saved option only decreases the file size. This command does not affect the memory required to analyze the data. To reduce both the file size and memory required for analyzing, use Cols > Utilities > Compress Selected Columns. See “Compress Selected Columns in Data Tables”.

Copy Table Scripts

Copying a table script enables you to paste the script into another script to recreate the table.
Use Data Table Variables

A data table variable can contain textual information (for example, source information for the data), or a value that can be used by column formulas or JSL scripts. Data table variable names appear in the table panel at the left of the data grid.

Figure 4.61 Table Variables in the Table Panel

Uses for Table Variables

Use table variables in the following situations:

- To document tables
- In formulas
- In JSL scripts

Use Table Variables to Document Tables

Table variables are used primarily to document tables. Many sample data tables installed with JMP contain a table variable named Notes. This variable provides details about the data (for example, the source of the data). The example in Figure 4.61 shows a data table that contains Notes as one of its table variables. JMP also automatically creates table variables when you create a design table using the Design of Experiments commands in JMP. The design table has a table variable named Design with the name of the design type as its value.

Reference Table Variables in Formulas

Table variables can also be incorporated in formulas that you build using the Formula Editor. These formulas calculate values for a column by referring to a table variable. For more information about constructing a formula that uses table variables, see “Refer to Data Table Values in Formulas”.

Use Data Table Variables in JSL Scripts

You can also incorporate table variables into JSL scripts. See the Scripting Guide.

Data Table Variable Actions

To add new data table variables

1. In the Table panel, click the red triangle to the left of the data table name.
2. Select New Table Variable.
3. Give the variable a name and value in the boxes labeled Name and Value.
4. Click OK.
   The table variable appears in the Table panel.

To view or edit table variables

1. Double-click the content of an existing table variable.
2. Edit the content.

To edit a table variable name

1. Double-click the table variable name.
2. Edit the name.

To delete table variables

Select one or more table variables and press Delete, or right-click the selected variables and select Delete.

Concatenating Data Tables with Table Variables

See the “Example of Concatenating Data Tables and Table Variables”.

Create and Save Scripts in Data Tables

To automatically complete various analyses and tasks, you can create a JSL script and save it to the data table (Figure 4.62). For more information about writing data table scripts, see the Scripting Guide.
Figure 4.62 Scripts Saved With the Data Table

Save a Report Script to a Data Table

Once you have run an analysis and you are in the report window, you can add a script to the data table. This script generates the JSL that reproduces your analysis.

To save a script to the data table

From the report window, click the red triangle for the platform and select **Save Script > To Data Table**.

Example of Saving a Report Script to a Data Table

First, you create your analysis, then you save the script.

1. Select **Help > Sample Data Folder** and open Big Class.jmp.
2. Select **Analyze > Fit Y by X**.
3. Select weight and click **Y, Response**.
4. Select height and click **X, Factor**.
5. Click **OK**.
6. Click the red triangle next to Bivariate Fit of weight By height and select **Fit Line**.
7. Click the red triangle next to Bivariate Fit of weight By height and select **Save Script > To Data Table**.

8. In the Save Script As window, enter the name of the script.

9. To replace an existing script with the same name, select it from the Name list and select **Replace existing script**.

10. To save a script that has the same name as an existing script and use the same name, select **Append unique suffix**.

   A number is added to the end of the script name.

11. Click **OK**.

The script is added to the bottom of the Table panel.

**Tip:** If you want a particular script to run automatically every time the data table is opened, name the script **OnOpen**. Only one script saved in the data table can be set to run automatically. If you name the script **Model** (or **model**) in a Fit Model script, the launch window is automatically filled in based on the script when you select **Analyze > Fit Model**.

---

**Write a JSL Script for the Data Table**

*To add a script to a data table using JSL*

1. Click the red triangle to the left of the data table name in the Table panel.
2. Select **New Script**.
3. Give the script a name by typing it into the box beside **Name**.
4. Add the script by entering JSL code into the box beside **Script**.
5. Perform one of the following actions:
   - If you want to run the JSL Debugger on the script to check it for errors, click **Debug Script**.
   - If you are finished editing the script, click **OK**. The script appears in the Table panel and the window closes.
   - If you are not finished editing the script and want to save it, click **Save**. The script appears in the Table panel and the window remains open for further editing.
   - If you want to run the script, click **Run**.

### Run, Edit, Delete, or Copy Scripts

**To run, edit, delete, or copy a script that is saved to the data table**

1. In the Table panel, right-click the green triangle beside the script’s name or right-click the script name.
2. Select one of the following commands:
   – Run Script
   – Edit
   – Delete
   – Copy

Once you copy a script, you can then paste it into a script window or into the Table panel of another data table.
Use the Column Info window to set specific properties on a column in a data table. Here are some examples of the actions that you can perform on a column:

- Change data and modeling types
- Change numeric formats
- Add formulas
- Specify restrictions on values or missing values
- Order categorical values or row data
- Save specification, control, or response limits
- Enter a known value for sigma

You can also standardize attributes and properties across multiple columns, assign a preselected analysis role to columns, and compress columns in a data table.

**Figure 5.1** The Column Info Window
Contents

About the Column Info Window ................................................................. 293
  About Modeling Types ................................................................. 296
The Short-Integer Format ................................................................. 296
Numeric Formats ............................................................................. 297
Store Information in Row State Columns .............................................. 302
  Initialize Data in a Column ......................................................... 304
Column Properties in JMP ................................................................. 306
  Basic Column Properties ............................................................. 307
  Properties That Validate Column Values ........................................... 308
  Properties That Attach Information to Column Values ................. 309
Properties That Control the Display of Columns ................................. 309
  Properties Used in Modeling and DOE .......................................... 315
  Properties Associated with Control Charts and Capability ............ 317
  Properties That Control How Columns Are Used in Platforms ........ 318
  SAS Properties ........................................................................... 327
  Link Data Tables with Virtual Join Properties ............................ 327
  Additional Column Properties ....................................................... 329
  Properties Assigned and Controlled by JMP ................................. 332
Standardize Attributes and Properties Across Columns ....................... 334
  Recode Column Values ............................................................... 335
  Standardize Column Attributes ...................................................... 335
  Standardize Column Properties ..................................................... 336
Delete Column Properties .................................................................. 336
  Example of Standardizing a Formula ............................................. 336
Assign a Preselected Analysis Role to a Column ................................. 338
About the Column Info Window

Use the Column Info window to specify all of the attributes and properties of a column. You can access the Column Info window in any one of the following ways:

- Select **Cols > New Columns**.
- Click an existing column heading and select **Cols > Column Info**.
- Right-click an existing column heading and select **Column Info**.
- Double-click directly above a column name.
- In the Columns panel, right-click a column and select **Column Info**.

Figure 5.2 The Column Info Window

The Column Info window contains the following information:

**Column Name**  Type or edit the name of the column.

**Lock**  Lock the column so that none of its values can be edited. After you lock a column, the lock icon (🔒) appears next to the column name in the data table’s Columns panel. If you add a formula to a column, the column automatically locks.

**Data Type**  Select or change the data type of a column, which determines the following:
- How the column’s values are formatted in the data grid
- How the column’s values are saved internally
- Whether the column’s values can be used in calculations

See “About Modeling Types”.

Choose from the following data types:

**Numeric** The columns contain only numbers (with or without a decimal point).

**Character** The columns contain any characters, including numbers. In character columns, numbers are seen as characters and are treated as discrete values instead of continuous values. The maximum field width for character values is 32,766 bytes.

**Row State** The columns contain row state information, which indicates whether the rows are excluded, hidden, labeled, colored, or marked. See “Store Information in Row State Columns”.

**Expression** The columns contain JSL expressions that can range from simple entries to complicated statement sequences. In particular, an expression can correspond to a picture, a matrix, or an expression. You can drag-and-drop expressions, such as an image, from your desktop to cells in an expression column. See “Expression Role”.

**Notes:**
- If you change a column’s Data Type from Character to Numeric, any character values become missing data values and are not recoverable.
- If you enter non-numeric data in a column with a Numeric data type, a warning window is displayed, prompting you to change the data type to Character. Click **Try Again** to return to the data table to re-enter the value. Click **Change** to change the data type. Click **Revert** to cancel your edit and return the cell’s value.
- Short-integer formats might also be available. See “The Short-Integer Format”.

**Modeling Type** (Numeric or Character data types only) Select or change the modeling type of a column, which tells JMP how to treat the column’s values during analyses. You can change the modeling type to look at a variable in different ways. See “About Modeling Types”.

Choose from the following modeling types:

**Continuous** Only numeric data types. Continuous values are treated as continuous measurement values. JMP platforms use the numeric values directly in computations.

**Ordinal** Either numeric or character data types. JMP platforms treat ordinal values as discrete categorical values that have an order. In Graph Builder, if there are more than 50 discrete values, JMP treats the column as continuous.

- If the column has a numeric data type, the values are ordered according to their numeric magnitude.
- If the column has a character data type and a Value Order column property is saved to the column, values are ordered according to the Value Order property. Otherwise, values are ordered according to their alphanumeric data value ordering. However, in
special cases where the values have an obvious order, values are automatically ordered appropriately. See “Value Order”.

**Nominal** Either numeric or character data types. JMP platforms treat all values as discrete values with no implicit order.

**Multiple Response** Only character data types. Distinct entries in a single cell must be separated by commas. JMP platforms that support multiple response columns treat each entry in the comma-separated list as a separate data value. If your entries are separated by a character other than a comma, use the Multiple Response column property instead. See “Multiple Response”.

**Unstructured Text** Only character data types. These values are generally unique and are therefore not appropriate for categorical analysis. The Text Explorer platform is ideal for analyzing unstructured text values.

**Vector** Only expression data types. The entries in the cells are column or row vectors. JMP platforms that support the Vector modeling type recognize the vectors and treat them appropriately in calculations.

**None** Any data type. Use None as a modeling type when a column is not well represented by the other modeling types. For example, a column of pictures or ID values might be assigned the None modeling type. JMP launch windows do not allow you to assign roles to columns with the None modeling type.

**Tip:** You must use the Column Info window to change a column’s modeling type to Multiple Response, Unstructured Text, or Vector.

**Format** (Numeric data types only) Select or change the display format of a numeric column. See “Numeric Formats”.

**Initialize Data** (Appears only during new column creation) Specify the type of initial data values that you want to appear in the column. See “Initialize Data in a Column”.

**Column Properties** (Contains a list of different properties) Assign properties to columns. See “Column Properties in JMP”.

**Tip:** Click the **Next** button to continue adding columns.
About Modeling Types

A column in a JMP data table can contain different types of information. However, all information in a single column must have the same data and modeling types.

- When you import data, JMP guesses which data and modeling types to use. Therefore, you should verify that JMP has guessed correctly.
- When you manually insert data, you should assign a data type and a modeling type at that time.

Figure 5.3 illustrates the icons that identify the different modeling types.

Figure 5.3 Modeling Type Icons in the Columns Panel

Click an icon to change the modeling type to **Continuous**, **Nominal**, **Ordinal**, or **None**.

See “Modeling Type”.

**Tip:** You can select Continuous only if your data type is numeric. If the Continuous option is dimmed on the menu and you want to make the column continuous, you must first change the column’s data type in the Column Info window.

The Short-Integer Format

When you use the correct short-integer format for your data, you do not see any difference in how the numbers appear. However, the numbers occupy less disk space and use less memory. Short-integer formats must be activated in preferences to appear in the Column Info window.
To make short-integer formats available in the Column Info window

1. Select **File > Preferences** and click **Tables**.
2. Select the **Allow short numeric data format** option.
3. Click **OK** to return to the data table.

To store numeric data in short-integer format:

1. Double-click above the column name whose values you want to be short-integer.
   The Column Info window appears.
2. From the Data Type menu, select **1-byte integer**, **2-byte integer**, or **4-byte integer**.

JMP stores values as integers in the range that you selected. The following numbers are examples:

- For 1-byte integer, the range of numbers that you can enter is from -126 to 127.
- For 2-byte integer, the range of numbers that you can enter is from -32,766 to 32,767.
- For 4-byte integer, the range of numbers that you can enter is from -2,147,483,646 to 2,147,483,647.

**Numeric Formats**

For numeric columns, the Format menu appears in the Column Info window. Specify the format to tell JMP how to display numbers in the column. For all format options, you can specify the number of total characters that you want the cells in the column to accommodate. See “**Specify Width**”.

For descriptions of the format options, see “**Numeric Format Options**”.

**Tip:** To add commas to values that equal a thousand or more, select the **Use thousands separator** option. You must account a space for each comma in the Width box, or else they might not appear. This option is available for the Best, Fixed Dec, Percent, and Currency formats.

**Specify Width**

When you specify a number in the Width field, be sure to include the total number of possible characters. Characters include: numbers, decimal points, commas, and currency symbols.
### Numeric Format Options

Choose from the following numeric format options:

**Best**  Allows JMP to consider the precision of each cell value and select the best way to show it. By default, the physical width of the column is 12 characters.

**Fixed Dec**  Shows all values in the column rounded to the number of decimal places that you specify.

- To see only whole numbers, set the number of decimal places to zero.
- If the number of integers following the decimal point is smaller than the number of decimal places that you specify, zeros are added to reach the number of decimal places. For example, if the value is 1.23 and you type 5 in the Dec box, JMP shows the number with five decimal places: 1.23000.

**Percent**  Multiplies numeric values by 100 and shows the number followed by a percent sign.

**PValue**  Shows probability values. The default value of the width is 12. If a number is less than 0.0001, the number is displayed as <.0001. The format is mostly used in JSL scripts and rarely needed for a data table column.

**Scientific**  Shows a number in standard scientific notation. If you enter the number 123456, it appears as 1.23456e+5. Select Dec to show the decimal points and enter the number of points.

**Engineering**  Similar to Scientific, but the exponent is always a multiple of 3 and the Dec field represents significant digits.

**Engineering SI**  Same as Engineering, but the exponent is replaced with an SI symbol.

**Precision**  Rounds the number to a given number of significant digits. Specify the number of significant digits in the Dec field.

**Currency**  Formats values with two decimal positions, thousands separators, and the currency sign that is specified in your computer’s locale settings. The default width of the Currency format is 15. If you have a number that requires a wider field width, the format defaults to the Best format. Once assigned, the currency symbol appears in the column and in graphs that contain the column.

**Date**  Shows all values in the column as a date. See “Date Formats”.

**Time**  Shows all values in the column as a specific instance in time, such as 12/2/03 at 2:23 PM. See “Time Formats”.

**Duration**  Shows all values in the column as a duration of time, such as hours, minutes, and seconds.
Using JMP About the Column Info Window

:day:hr:m, :day:hr:m:s  Shows a duration of time, such as 52:03:01:30, or fifty-two days, three hours, one minute, and thirty seconds.

hr:m, hr:m:s, min:s  Shows a duration of time, such as 17:37, or seventeen hours and thirty-seven minutes.

Geographic  Shows latitude and longitude number formatting for geographic maps. Latitude and longitude options include the following:

DDD  Degrees

DMM  Degrees and minutes

DMS  Degrees, minutes, and seconds

In each format, the last field can have a fraction part. You can specify the direction with either a signed degree field or a direction suffix. To show a signed degree field, such as -59°00 ′00 ″, deselect Direction Indicator. To show the direction suffix, such as 59°00′00″ S, select Direction Indicator.

To use spaces as field separators, deselect Field Punctuation. To use degrees, minutes, and seconds symbols, select Field Punctuation.

Custom  Enables you to define a custom format for a numeric column, including customization of column width and number of decimal places. Select Custom, click Set Custom Format, and define the format in the Formula Editor window. For example, if you don’t want to display the percentage sign next to a number, select this option and multiply the number by 100. This is an alternative to selecting the Percent format. Or if your data is in meters and you want to show it in kilometers with the unit, add the formula `Char(:value / 1000) || " km"`. You might also want to apply a date/time format that isn’t available in the Format Date or Time lists, such as D/M/Y.

Format Pattern  Enables you to customize the date-time formatting of numeric values. See “Customize Date-Time Formats with Format Patterns” for details.

Date Formats

When you choose a Date format, you can also specify an Input Format. The Date format indicates how the date appears in the data table cells, and the Input Format indicates how you enter the date.

If you assign a date format to a numeric column that already contains data, then the numeric values are treated as the number of seconds since January 1, 1904. For example, if you have a numeric column with a cell value of 1,234,567,890 and you change the format to Date > m/d/y, the cell value appears as 02/13/1943.

The examples in Table 5.1 use the date of December 31, 2004.
Table 5.1  Date Formats

<table>
<thead>
<tr>
<th>Format</th>
<th>Appears As</th>
</tr>
</thead>
<tbody>
<tr>
<td>m/d/y</td>
<td>12/31/2004</td>
</tr>
<tr>
<td>mmddyyyy</td>
<td>12312004</td>
</tr>
<tr>
<td>m/y</td>
<td>12/2004</td>
</tr>
<tr>
<td>yyyyQq</td>
<td>2004Q4</td>
</tr>
<tr>
<td>d/m/y</td>
<td>31/12/2004</td>
</tr>
<tr>
<td>ddmmyyyy</td>
<td>31122004</td>
</tr>
<tr>
<td>ddMonyyyy</td>
<td>31Dec2004</td>
</tr>
<tr>
<td>Monddyyyy</td>
<td>Dec312004</td>
</tr>
<tr>
<td>y/m/d</td>
<td>2004/12/31</td>
</tr>
<tr>
<td>yyyyymmdd</td>
<td>20041231</td>
</tr>
<tr>
<td>yyyy-mm-dd</td>
<td>2004-12-31</td>
</tr>
<tr>
<td>Date Long</td>
<td>Friday, December 31, 2004</td>
</tr>
<tr>
<td>Date Abbrev</td>
<td>Dec 31, 2004</td>
</tr>
<tr>
<td>Locale Date</td>
<td>Varies based on local OS setting. Here is an example: in the United States, the local OS setting is mm/dd/yyyy (12/31/2004).</td>
</tr>
</tbody>
</table>

**Note:** To change how a date appears in a graph without changing how it appears in a data table, see “Change the Numeric Format of an Axis”.

**Time Formats**

When you choose a Time format, you can also specify an Input Format. The Time format indicates how the time appears in the data table cells, and the Input Format indicates how you enter the time.

- You can add the number of hours, minutes, and seconds after midnight of the prepended date for the following date formats:
  - m/d/y
  - d/m/y
– y/m/d
– ddMonyyyy
– Monddyyyy
– Locale Date

For example, December 31, 2004 has a numeric value of 3,187,296,600, which represents 12/31/2004 12:10 AM.

- :day:hr:m and :day:hr:m:s show the number of days, hours, minutes, and seconds since January 1, 1904. For example, the results for December 31, 2004 are :36890:00:10: and :36890:00:10:00.

- h:m:s and h:m show the hours, minutes, and seconds portion of the date in the date field. For example, the results for December 31, 2004 at 12:10 AM are 12:10:00 AM and 12:10 AM.

- yyyy-mm-ddThh:mm and yyyy-mm-ddThh:mm:ss show the year, month, day, and time. For example, 2004-12-31T12:10:00. T is a literal value, representing itself.

**Note:** To change how a time appears in a graph without changing how it appears in a data table, see “Change the Numeric Format of an Axis”.

---

**Customize Date-Time Formats with Format Patterns**

Format patterns are strings that define a date-time format, such as <YYYY><MM><DD><hh><mm><ss><ampm>. The parts of the pattern in angle brackets are called field descriptors. The field descriptors represent a value (such as <YYYY>, which is a four-digit year) or other date-time text (such as <>, which is a locale-specific date separator).

A format pattern enables you to build formats that aren’t provided in JMP. These formats can be used for both formatting and inputting data. You can type the pattern yourself, use a built-in format as a starting place, or select field descriptors from a list.

You can use format patterns anywhere built-in date-time formats can be selected.

**Build a Format Pattern**

1. Create a numeric column in a data table.
2. Right-click the column and select **Column Info**.
3. Select **Format Pattern** from the Format list.
4. Click **Set Format Pattern**.
5. To use a built-in format as a starting place, select **Builtins**, select a date-time format, and then edit the format.
6. To edit the format, type the field descriptors in the Format Pattern field, or select a format pattern from the Field Descriptors list.
7. Click **OK**.

**Build an Input Format Pattern**

1. In an existing numeric column, right-click and select **Column Info**.
2. Select **Format Pattern** from the Format list, and then deselect **Use Output Format**.
3. Click **Set Format Pattern**.
4. Build the pattern as described in the preceding task.

**Notes:**

- Some formats cannot be used for input. For example, when a variable-length number field descriptor is followed immediately by another number, some dates are ambiguous. The format `<YYYY><M><D>` cannot process input because `<M>` is a single digit month; dates such as 2020111 would be ambiguous. It’s unclear whether the date is Jan 11 or Nov 1.
- ISO date formats were previously parsed as non-ISO YMD formats, and the opposite was also true. Now YMD date formats are compatible with each other; you can paste one YMD date into a column that is formatted using another YMD date.

**International Formats**

If you are importing or entering data that contains formatting specific to country standards, you might need to make sure that your number formats are interpreted correctly. On Windows, access the Control Panel’s region and language option, and select the country for which the number should be formatted. On macOS, from the Apple menu, select **Language & Region > Formats**, and select the correct country. On later versions of macOS, this option may appear under System Preferences > Language and Region.

**Store Information in Row State Columns**

Similar to assigning row states to rows, you can create a column that contains only row state information. A row state column stores information about whether rows are excluded, hidden, labeled, colored, marked, or selected. To designate a column as a row state column, in the Column Info window next to Data Type, select **Row State**.
Since row state columns store the row states, you can apply them again later. Populate row state columns by copying them from the current row states or with column formulas.

To create a row state column
1. Select **Cols > New Columns.**
2. Next to Data Type, select **Row State.**
3. Click **OK.**

Populate the cells with new row state information or copy existing row state information from rows.

To populate cells with new row state information
1. To populate only certain rows in the row state column, highlight those rows. Or, to populate all rows in the column, highlight the row state column.
2. Right-click and select **Row States Cells.**
3. Select the row state that you want to apply.

To copy existing row state information
1. To populate only certain rows in the row state column, highlight those rows. Or, to populate all rows in the column, highlight the row state column.
2. Click the star icon (★) beside the column name in the Columns panel.
3. Select one of the following:
   - **Copy from Row States**  Replaces the row states in the column with the row states from the rows.
   - **Add from Row States**  Adds the row states from the rows to the row state column.
   - **Copy to Row States**  Replaces the row states in the rows with the row states from the column.
Add to Row States  Adds the row states from the row state column to the row states in the rows.

Permanently Select Cells

You can save a selection in a row state column just like you save other row state characteristics (hide, exclude, color, and so on). This places a “permanent” highlight on a cell.

To permanently select cells
1. Right-click a cell and select Row States Cells > Select/Deselect.
2. Repeat this for as many cells as you would like to select.
3. To remove the highlight, right-click the cell and select Row States Cells > Select/Deselect.

Initialize Data in a Column

When you first add a new column to a data table, the Initialize Data menu appears in the Column Info window. Specify the type of initial data values that you want to appear in the new column. Initializing data is not available for Row State data types.

Select one of the following options:

Missing/Empty  Places missing values in the column, represented by a black dot (●) for numeric data and a blank space for character data.

Constant     Places one number or character in all of the column’s rows. Enter the number or character into the box that appears. Enter any number of characters.

Today        Places today’s timestamp in the column for each row. This option is relevant only for the Date or Time formats.

Sequence Data  Inserts sequential data based on the parameters that you specify. See “Numeric or Character Sequence Data”.

Random       Inserts randomly generated data values into the column. Select a method for generating the random values:

Random Integer Enter minimum and maximum integer values. Integer values within this range are generated so that each occurs with approximately equal frequency.

Random Uniform Enter a range for continuous values. Random uniform values within this range are generated.

Random Normal Enter the mean and standard deviation for a normal distribution. Random normal values from this distribution are generated.
**Random Indicator**  Enter up to three values and corresponding desired proportions. The proportions should sum to 1. Values are generated to have a distribution that corresponds as closely as possible to the specified proportions.

**Note:** This method generates values in the exact proportions that you specify unless the number of rows multiplied by one of the proportions results in a fractional value.

Suppose that there are \( n \) rows and that the three proportions are \( p_1, p_2, \) and \( p_3 \). Here is how the values are generated:

- Each row is assigned a random uniform value between 0 and 1.
- The rows are ordered according to their random uniform values.
- The rows corresponding to the smallest \( \text{Round}(np_1) \) random uniform values are assigned the first value, the rows corresponding to the next smallest \( \text{Round}(np_2) \) random uniform values are assigned the second value, and the remaining rows are assigned the third value.

**Numeric or Character Sequence Data**

**To insert sequential data for numeric data**

1. Next to **Data Type**, make sure **Numeric** is selected.
2. Next to **Initialize Data**, select **Sequence Data**.
3. In the **From** and **To** boxes, assign a starting and ending point.
4. In the **Step** box, assign the sequence.
5. (Optional) In the **Repeat each value N times** box, enter the number of times that you want each numeric value repeated.
6. Click **OK**.

For example, if you want the column to contain even numbers from 2 to 60, type 2 in the **From** box, 60 in the **To** box, and 2 in the **Step** box.

**To insert sequential data for character data**

1. Next to **Data Type**, make sure **Character** is selected.
2. Next to **Initialize Data**, select **Sequence Data**.
3. In the box next to **Add**, enter the character data and click **Add**.
4. (Optional) In the **Repeat each value N times** box, enter the number of times that you want each character value repeated.
5. Click **OK**.
Column Properties in JMP

A column property is information that is attached to a column. Once that information is entered, it is saved as part of the data table. You can select column properties and apply them to columns. There are some column properties that JMP creates for your convenience. Often, you can modify these.

Column properties are listed in the Column Info window’s Column Properties menu. The area below the Column Properties menu shows column properties that have been saved to a column. To view or edit a property, select it from this list.

In the Columns panel of the data table, an icon appears next to the name of each column that contains a property, other than the Notes property. The Notes property is not denoted by an icon. Icons include the following:

- ✓ Indicates that the range or list check property is applied
- ✪ Indicates that the column contains a formula
- ✷ Indicates that the column contains a property other than the Note, Range Check, or List Check column property

For information about more column property icons, see “Icons Representing Column Characteristics and Properties”.

To assign a column property to one or more columns

1. Select the column or columns to which you want to assign a property.
2. Do one of the following:
   - Right-click the header area, select Column Properties, and select the property.
   - Right-click the header area, select Column Info, and select the property from the Column Properties menu.
   - Select Cols > Column Info and select the property from the Column Properties menu.
3. In the column property panel that appears, specify values and select options as appropriate.
   - Click Apply to add the column property or click OK to add the column property and close the column properties window.

A column might already contain a property that you want to apply to other columns. Use the Standardize Attributes command to apply that property to other columns. See “Standardize Attributes and Properties Across Columns”.
The following sections describe the properties that you can add to columns.

- “Basic Column Properties”
- “Properties That Validate Column Values”
- “Properties That Attach Information to Column Values”
- “Properties That Control the Display of Columns”
- “Properties Used in Modeling and DOE”
- “Properties Associated with Control Charts and Capability”
- “Properties That Control How Columns Are Used in Platforms”
- “SAS Properties”
- “Link Data Tables with Virtual Join Properties”
- “Additional Column Properties”
- “Properties Assigned and Controlled by JMP”

### Basic Column Properties

Basic column properties that apply generally include Formula and Notes.

### Formula

Insert a formula into a column to compute the values for that column. After a formula is added, the column is locked so that its data values cannot be manually edited (preventing invalidation of the formula).

- Click **Edit Formula** to create a formula. For more information about creating a formula, see “Create Formulas in JMP”.
- If you do not want JMP to evaluate the formula, click **Suppress Eval**.
- If you do not want JMP to alert you about errors in your formula, click **Ignore Errors**.
- Once you have created a formula:
  - In the Column Info window, a visual of the formula appears at right. However, if your formula is long, only a portion of it might appear. Click and drag the borders of the formula box to resize it.
  - From the data table, edit the formula by clicking (➕) next to the column name in the Columns panel.

**Tip:** To bypass the Column Info window when creating a formula, right-click the column and select **Formula**.
Notes

Adds notes to the selected column.

Properties That Validate Column Values

The following properties help validate values in a column: Range Check, List Check, and Missing Value Codes.

Range Check

Range checking validates the data in a column. Set up the column to accept only numbers that fall within a specified range.

Select which formula to use to set up the range. $x$ is the value entered into the column, $a$ is the beginning of the range, and $b$ is the end of the range.

- $a = \text{the lowest value that the column accepts}$
- $b = \text{the highest value that the column accepts}$
- For a single-sided range check, leave either $a$ or $b$ empty.
- From the data table, modify the range check by clicking $\text{next to the column name in the Columns panel.}$

List Check

List checking validates the data in a column. Set up the column to accept only the individual values that you specify. List checking is useful when you want to specify how to order the data in your graphs or plots.

- You can use up to 127 values.
- Use the buttons to add new values, change, or reverse the order of values, and remove values.
- Once a list check is set on a column, the cursor changes to $\mathbb{H}$ when positioned over the cells. If you try to enter a value not included on the validation list, a warning message appears.
- To see a menu of acceptable values, right-click a cell and select List Check Values. You can select the cell value from the menu instead of entering it into the cell.
- From the data table, modify the list check by clicking $\text{next to the column name in the Columns panel.}$
Missing Value Codes

Use missing value codes to specify column values that should be treated as missing. For example, sometimes the value 99 is used as a placeholder to represent missing values, or perhaps several values are used to represent different types of missing values.

**Note:** The Missing Value Codes column property is an extended attribute. If you plan to export to a SAS 9.4 server or Save As a SAS 9.4 file format, you should enable extended attributes in the SAS Integration Preference page. See “Preferences for Updating JMP”. Alternatively, you should select **Store table and column properties in SAS 9.4 extended attributes** in the Save As window. If extended attributes are not selected, JMP exports or saves Missing Value Codes as missing values. Extended attributes are supported only by SAS 9.4. Earlier versions of SAS disregard any extended attributes.

To remove missing value codes for a single column
1. In the Columns panel of the data table, next to the column, click **> Missing Value Codes**.
2. Missing Value Codes is highlighted in the list. Click **Remove**.
3. Click **OK**.

To remove missing value codes across multiple columns
1. Select the columns containing the missing value codes that you want to delete.
2. Select **Cols > Standardize Attributes**.
3. Under Delete Properties, click **Column Properties > Missing Value Codes**.
4. Click **OK**.

Properties That Attach Information to Column Values

The following column properties attach information that is used in reports and plots to the values in a column:

- Value Labels
- Value Scores
- Value Order
- Row Order Levels
- Value Colors
- Color Gradient
- Short Name
Value Labels

Use value labels to show a label in the data table instead of a value. A label appears for each instance of the value. You can show the original values by double-clicking a label within a cell.

- Enter the value that you want to assign a label to in the Value box.
- Enter the label that you want to appear in the Label box.
- To use ranges, click **Allow Ranges** then specify the lower and upper values. If Allow Ranges is selected, Value Labels can be non-integers. Graph Builder can use the Value Labels for the x- and y-axes.

**Tip:** To assign a label to missing values, enter a period (.) for the lower bound and leave the upper bound empty. To assign a label to all other values, enter three periods (...) for the lower bound and leave the upper bound empty.

- Add, change, or remove labels.

**Tips:**

- To turn off value labels in the data table without deleting the value labels that you have set up, in the Column Properties window, deselect **Use Value Labels**. Or, to quickly show or hide value labels in a data table, right-click a column and check or uncheck **Use Value Labels**.
- When your data table contains value labels, using the **Search** commands searches for actual values, but does not search for labels.
- When your data table contains value labels, the **Row Editor** displays the label, and when the cell is highlighted for editing, it shows the actual value.
- If you copy and paste a cell with a value label, the actual value is pasted.
- In a formula, when you reference a column using value labels, hover over the value label to see the actual data value.
Value Scores

Use value scores to indicate a value-score pair for categorical data columns. The value is a data value and the score is a number. This property associates a data value with a score (for example, the column’s data value could be “not satisfied”, “satisfied”, “very satisfied”). The user could assign a score of 0 to “not satisfied”, 50 to “satisfied”, and 100 to “very satisfied”. Those scores are then used for computation purposes like computing the mean. See Consumer Research for an example.

To use value scores

1. In the data table, right-click the column and select Column Info.
2. From the Column Properties list, select Value Scores.
3. Enter the value that you want to assign a label to in the Value box (for example, “satisfied”).
4. Enter the label that you want to appear in the Score box (for example, “50”).
5. Click Add, Change, or Remove.
6. Click OK.

Value Order

Value Order assigns an ordering to values in a column that is then used in reports and plots. The default ordering for reports and plots is alphanumeric data value ordering, except in the following cases, where values are automatically ordered appropriately:

- January, February, March, April, May, June, July, August, September, October, November, December
- Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
- Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
- Very Low, Low, Medium Low, Medium, Medium High, High, Very High
- Strongly Disagree, Disagree, Neutral, Indifferent, Agree, Strongly Agree
- Failing, Unacceptable, Very Poor, Poor, Bad, Acceptable, Average, Good, Better, Very Good, Excellent, Best

Tip: You can anonymize Value Order so that the Value Order properties are renumbered. To do this, highlight the column with the Value Order column property and select Tables > Anonymize.

When you construct a design using a DOE platform, the Value Order column property is automatically assigned to categorical factors. For examples of assigning and editing the Value Order column property, see the Design of Experiments Guide.
Note: When you’re comparing character data, select Use Locale Comparisons for Characters to consider locale information when determining the ordering.

Custom Order

By default, Custom Order is selected. This option allows you to order data values in a user-defined order. Initially, character data is ordered alphabetically and numeric data is sorted numerically. You can use the arrows to move the values and the plus sign to add values.

Sorted Order

Deselect Custom Order to move the values to the Sorted Order box. Then you indicate the rules for sorted items.

Items that are not custom ordered are affected by the sorted order. Drag items down to the Sorted Order area to remove them from the custom order and have the sorting rules applied to those items. Deselect Custom Order to apply sorting rules to all items.

The sort order rules are applied when you select or deselect the check boxes.

Row Order Levels  Sorts the column values by their occurrence in the data table, rather than sorting by value. This option does not apply to sorting data table columns.

Note: If both Row Order Levels and Common Order are selected, the row order levels apply.

Common Order  If all values have a predefined sort order (for example, the days of the week), remaining items are sorted on that basis. Common order is the typical ASCII ordering. This option is available only for character data.

Numerical Order  Sorts character column values by splitting the data into string and numeric segments.

Here are the numerical order rules:

– Strings are broken into segments of numeric (not including +/-, but including dots in the middle) and non-numeric characters.

– Segments are compared between two strings, comparing numbers by magnitude as long as the numbers don’t start with leading zeros.

Numbers with leading zeroes are sorted before any numbers without leading zeroes.

If both numbers have leading zeroes, then the numbers are compared digit-by-digit. For example, “0CH2” is sorted before “0 CH2”.

– If two strings differ by segment type, a numeric segment sorts before a string segment.
– The locale compare affects symbols; characters such as hyphens and lowercase or uppercase are ignored in locale sorting. (Note that lowercase is sorted before uppercase in ASCII ordering. The rules are different for each language. The goal is to sort the same way that the operating system sorts file names.

To use ASCII ordering, deselect **Numerical Ordering** in the Value Order column property.

– The string segments are compared using locale compare by default. This comparison is language-aware. The comparison is provided by the operating system, so there are subtle differences between behavior on Windows and macOS.

**Value Colors**

Use value colors to assign the values of a nominal or ordinal column a certain color or range of color themes. The column’s values appear with the assigned color in all applicable graphs, such as mosaic plots and plots with color-coded legends. You can also color the values in the data table column.

- To change the color of a specific value, right-click a color circle and select a color.
- To use a color theme, click **Color Theme** below the list of value colors and then select the color.
- To create a custom color theme, see “Create a Custom Color Theme”.
- To also color the cells in the data table, select **Color Cell by Value**.
- Select from the options in the Macros menu. See “Macros Options”.

**Create a Custom Color Theme**

*To create a custom color theme*

1. Click **Color Theme** below the list of value colors in the column properties.
2. Open the Custom Color Theme outline.
3. Click **New**.
4. Create the color using the sliders.
5. Name the color and click **Save**.
6. Click **OK**.

You can access the new custom color in the Color Theme menu the next time you use the Value Colors property. The color is also saved in your preferences. See “Create Color Themes in Graphs” for more information about creating color themes.
Macros Options

The Macros menu contains the following options:

**Gradient between ends**   Sets the colors of the top and bottom values. JMP applies a color gradient across the entire range of values. Use this command to make all of the colors in between for the other levels.

**Gradient between selected points**   Sets the colors of the top and bottom values so that JMP can apply a color gradient to a range of values that you have highlighted in the Value Colors list.

**Reverse colors**   Reverses the color of the values from top to bottom or bottom to top.

**Revert to old colors**   Sets the colors back to their original color values.

Color Gradient

Select a color gradient to color a continuous column in a plot. Color gradients are supported in the Graph Builder, Bubble Plot, Treemap, and Cell Plot platforms.

- To also color the cells in the data table, select **Color Cell by Value** above the list of value colors.
- Select a color gradient from the menu.
- Enter the minimum, maximum, and center values:
  - Minimum values reflect the color at the left of the gradient.
  - Maximum values reflect the color at the right of the gradient.
  - Center values reflect the color in the middle of the gradient.

**Note:** To see color gradients in Graph Builder, you must assign the column to the Color zone. To see color gradients in Bubble Plot and Treemap, you must assign the column to the Coloring role.

Short Name, SPSS Name, and SAS Name

These column properties insert the specified short name in a Categorical structured report when the Show Columns Used in Report red triangle option is selected.

SAS Name is also a column property that is added when you import SAS data. It contains the name of the variable in the SAS data set. Modifying it will affect the SAS data set if the data are exported back to SAS.
SPSS Label, Long Name, SAS Label, and Question

These column properties insert the specified long name in a Categorical structured report when the Show Columns Used in Report red triangle option is selected.

SAS Label is also a column property for imported SAS data. It contains the description of the column in the SAS data set. Modifying it will affect the SAS data set if the data are exported back to SAS.

Properties That Control the Display of Columns

The Axis and Units column properties control how column values are displayed.

Axis

Use the Axis property to change the default axis settings for a column. JMP automatically uses your settings when the column appears in an analysis. See “Customize Axes and Axis Labels in Graphs” for more information about the properties.

When you add the Axis column property, you can save all column properties or only the properties that you changed. For example, you might want the axis to start at 0 and are not concerned about the upper bounds of the axis. Set the minimum axis value and select Changed Properties Only from the Save to column list.

To set default axis properties for a column from within a graph
1. Create the graph.
2. Change the axis to your preferred specifications.
3. Right-click the axis and select Save to Column Property.

Units

Use the Units property to specify the measurement units that were used to collect the data for the column. The units appear in parentheses after the column name in the data table and when the column appears in plots. For example, you might want a column to indicate that age values are measured in months, or that a monetary value is in thousands of dollars.

Properties Used in Modeling and DOE

When you construct a design using the DOE platforms, column properties are saved to the resulting design table. However, some of these column properties are useful in general modeling situations. To use the properties more generally, you can specify them yourself.
Set JMP Column Properties

Chapter 5

Column Properties in JMP

Note: the Design of Experiments Guide describes the properties associated with DOE in detail and presents examples. Only a brief description of these properties is provided here.

The following column properties are used in modeling and DOE:

- Response Limits
- Detection Limits
- Design Role
- Coding
- Mixture
- Factor Changes

Response Limits

The Response Limits column property defines a desirability function for the response. The Prediction and Contour Profilers use desirability functions to find optimal settings. See the Design of Experiments Guide.

Detection Limits

The Detection Limits column property defines bounds beyond which the response cannot be measured. You can use these limits to specify a censored response in either the Distribution or Generalized Regression platform. See Fitting Linear Models.

Design Role

The Design Role column property indicates how a column is used in both a designed experiment and in the model used to fit the data. For example, a column could represent a continuous factor, a categorical factor, a blocking factor, and so on. See the Design of Experiments Guide.

Coding

The Coding column property applies a linear transformation to the data in a numeric column. The data are transformed to –1 and +1 based on bounds that you specify. JMP then uses the transformed data values whenever the column is entered as a model effect in the Fit Model platform. See the Design of Experiments Guide.
Chapter 5
Using JMP

Set JMP Column Properties
Column Properties in JMP

317

Mixture

The Mixture column property is useful when a column in a data table represents a component of a mixture. The components of a mixture are constrained to sum to a constant. The Mixture column property identifies a column as a mixture component and defines a coding for that column. See the Design of Experiments Guide.

Factor Changes

The Factor Changes column property indicates how difficult it is to change factor settings in a designed experiment. It is used to create and analyze split-plot, split-split-plot, and two-way split-plot designs. See the Design of Experiments Guide.

Properties Associated with Control Charts and Capability

The Specification Limits, Control Limits, Sigma, and Process Capability Distribution properties are associated with control charts and capability.

Spec Limits

Specification limits are used when you perform a capability analysis using the Distribution and Capability platforms. Note that in old data tables, the column property might be named Capability Analysis.

You can specify any combination of a Lower Spec Limit, an Upper Spec Limit, or a Target. The Show as Graph Reference Lines option displays the specification limits and target that you specify as reference lines on appropriate plots.

Tip: To add specification limits to several columns at once, see Quality and Process Methods.

Control Limits

The Control Limits column property enables you to specify control limits for a column, rather than having JMP calculate control limits from the values in the column. This is useful when you are comparing process data to historical control limits.

The Control Limits column property can be assigned only to a numeric column. To assign the Control Limits column property, select the control chart type and then enter the requested values. If any of these entries are missing, JMP replaces it with a calculated value in the control chart.
**Sigma**

Use the Sigma property to enter a known sigma value. This value is used by applications such as control charts or any application that requires a sigma value to complete computations. If no sigma value is supplied, sigma is calculated from the sample.

**Process Capability Distribution**

The Process Capability Distribution column property specifies a process distribution for the column. The Process Capability Distribution column property is used only in the Process Capability platform. See also “Process Capability Distribution”.

**QC Alarm Script**

You can generate automatic alarms by writing a script and storing it as a column property or data table property named QC Alarm Script.

The following QC Alarm Script automatically writes a message to the log whenever a test fails:

```julia
Write("Out of Control for test ",
     qc_test,
     " in column ",
     qc_col,
     " in sample ",
     qc_sample
)
```

**Properties That Control How Columns Are Used in Platforms**

The following properties control how columns are used in platforms:

- Distribution
- Time Frequency
- Map Role
- Supercategories
- Multiple Response
- Target Level
- Control Level
- Profit Matrix
- Informative Missing
Distribution

For a column that contains continuous numeric data, use the Distribution property to select a distribution type to fit to the column. This distribution is used in the Distribution platform and is used in the Process Capability platform under certain conditions. See “Distribution and Process Capability Distribution”.

When you obtain a Distribution report (by selecting Analyze > Distribution) for the column, JMP automatically estimates a fit using the specified distribution. A curve representing the fitted distribution is superimposed on the histogram.

If you set both the Distribution property and the Spec Limits property, then the Distribution platform produces a Capability Analysis report that is based on the distribution specified in the Distribution column property.

**Note:** In older data tables, the Capability Analysis column property might have been assigned to a column to specify spec limits. We recommend that you use the Spec Limits property instead.

Distribution and Process Capability Distribution

If you are using the Process Capability platform to analyze a column that does not contain a Process Capability Distribution property, the distribution specified in the Distribution column property results in a nonnormal fit in the Process Capability platform. If this distribution is supported in the Process Capability platform, then it is used. However, if this distribution is not supported, the platform uses a Johnson fit.

If both the Distribution and Process Capability Distribution column properties are saved for a given column, then the distribution specified in the Distribution column property is used in the Distribution platform, and the distribution specified in the Process Capability Distribution column property is used in the Process Capability platform.

Time Frequency

When using the Time Series platform, you can assign the Time Frequency property to data. The Time Frequency property specifies the frequency with which the data is reported (such as annually, quarterly, monthly, and so on). Specifying a time frequency allows JMP to take things like leap years and leap days into account. If no frequency is specified, the data is treated as equally spaced numeric data.

Map Role

If you have created a data table that contains boundary data (such as countries, states, provinces, or counties), to see a corresponding map in Graph Builder, use the Map Role property.
Note the following:

- If the custom boundary files reside in the default custom maps directory, then you need to specify only the Map Role property in the -Name file.
- If the custom boundary files reside in an alternate location, then you must specify the Map Role property in the -Name file and in the data table that you are analyzing.
- The columns that contain the Map Role property must contain the same boundary names, but the column names can be different.

For an example using the Map Role property, see Essential Graphing.

**To add the Map Role property into the -Name data table**

1. Right-click the column containing the boundaries and select **Column Properties > Map Role**.
2. Select **Shape Name Definition**.
3. Click **OK**.
4. Save the data table.

**To add the Map Role property into the data table that you are analyzing**

**Note:** Perform these steps only if your custom boundary files do not reside in the default custom maps directory.

1. Right-click the column containing the boundaries and select **Column Properties > Map Role**.
2. Select **Shape Name Use**.
3. Next to **Map name data table**, click \(\text{\[Icon\]}\) to browse to a -Name map data table. You can enter the relative or absolute path.
   - If the map data table is in the same folder, enter only the filename. Quotation marks are not required when the path contains spaces.
4. Next to **Shape definition column**, enter the name of the column in the map data table whose values match those in the selected column.
5. Click **OK**.
6. Save the data table.

When you generate a graph in Graph Builder and assign the modified column to the Shape zone, your boundaries appear on the graph.
Supercategories

When a data set contains ratings (for example, on a five-point scale), you might want to know the percent of the responses in a subset of those ratings. Add a Supercategories column property to group specific categories into one category.

Supercategories are supported only in the Categorical platform.

To add the Supercategory property to a data column
1. Right-click the column that contains categories that you want to group.
2. Select Column Properties > Supercategories.
   The column properties window shows the Supercategories options (Figure 5.5).
3. Select the categories in the Column’s Categories list that you want to group.
4. Enter a descriptive name next to Supercategory Name.
   Leave the name blank, and JMP names the supercategory after the categories that you selected.
5. Click Add to create the supercategory.
6. Click the Supercategories red triangle and select from the following options:
   Options > Hide Hides data in the selected supercategory from reports and graphs.
   Add All Creates a supercategory from all of the categories in the column.
   Add Mean and Add Std Dev Calculate statistics for value scores. See Consumer Research.
7. Click OK to add the property to the column.

Figure 5.5 Example of a Supercategories Configuration

Multiple Response

The term multiple response refers to the situation where the cells in a column contain more than one response value. For example, many cells in the Brush Delimited column in the Consumer Preferences.jmp sample data table contain multiple values. For example, row 6 contains “Wake, After Meal, Before Sleep”.
Add the Multiple Response column property if you want to specify a delimiter other than the comma. Otherwise, change the column’s modeling type to Multiple Response in the Column Info window. See “About Modeling Types” for more information about the Multiple Response modeling type.

JMP automatically assigns the Multiple Response modeling type to data tables saved in JMP 12 or lower. The column must contain the Multiple Response column property, and the delimiter must be a comma for the automatic assignment to take place. JMP does not remove the Multiple Response column property, though you might choose to do so.

**Figure 5.6** Multiple Response Configuration Window

![Multiple Response Configuration Window](Image)

**Note:** You can use the Multiple Response property in the Categorical platform. See *Consumer Research*. You can also use this property in the Data Filter. See “The Data Filter”. If the delimiter is a comma, consider using the Multiple Response modeling type instead.

**Target Level**

Use the Target Level column property to specify the level of interest of a response column for logistic regression platforms. This level is used as the positive response level in logistic regression models, and it impacts the statistics, probability curves, and other measures of fit. This column property is designed for binary responses, but it can be used for any categorical column.

**Note:** The Target Level column property is used by the following platforms when a binary response column is specified: Fit Y by X (Logistic) and the Nominal Logistic personality of Fit Model.

**Control Level**

Use the Control Level column property to specify the level of a factor column that should be used as a control level to compare with all other levels of the factor column. This column property is useful for methods that perform multiple comparisons to a control group.

**Note:** The Control Level column property is used by the following platforms when a categorical factor column is specified: Fit Y by X (Oneway), Response Screening, and the Standard Least Squares and Generalized Regression personalities of Fit Model.
Profit Matrix

Use the Profit Matrix column property to assign weights to the levels of a nominal or ordinal response variable for a predictive model. For a nominal response, you can specify the profit matrix entries using a probability threshold.

**Note:** The Profit Matrix column property is used by the following platforms: Model Comparison, Partition, PLS, and Fit Model. The personalities in Fit Model that use the Profit Matrix column property are Generalized Regression, Nominal Logistic, and Ordinal Logistic.

Profit Matrix

When you select **Column Properties > Profit Matrix**, a matrix template appears, with a row and column for each value in the selected column. The Actual levels are shown as rows and the predicted levels are shown as columns. Correct decisions are those on the diagonal, where the predicted level equals the actual level.

- For diagonal entries, enter values that reflect profits or weights for correct decisions.
- For non-diagonal entries, enter values that reflect profits (or losses) or weights for incorrect decisions.
- For situations where no prediction is made, use the Undecided column to indicate associated profits or losses.

Probability Threshold Specification for Profit Matrix

When the response is binary, additional options appear beneath the profit matrix template. These options enable you to specify a probability threshold instead of entering weights directly into the profit matrix.

Specify the Target Level and Probability Threshold. Then click Set to update the profit matrix.

**Target Level**  The level whose probability is modeled.

**Probability Threshold**  A threshold for the probability of the target level. If the probability that an observation falls into the target level exceeds the probability threshold, the observation is classified into that level.

**Set**  Enters values into the profit matrix template that reflect your specifications for Target and Probability Threshold. See “Probability Threshold Calculations”.

Probability Threshold Calculations

Denote the threshold probability by \( t \). When you click Set, the entries in the profit matrix are assigned as follows:

- 0 for each diagonal entry, reflecting no loss from correct decisions
• -1 for a prediction of the target level when the actual value is the non-target level
• \(-\frac{t}{1-t}\) for a prediction of the non-target level when the actual value is the target level

This implies that the profits for classifying into the two levels are given as follows:

\[
\text{Profit for Target Level} = \left(\frac{-t}{1-t}\right)\text{Prob[Non-Target Level]}
\]

\[
\text{Profit for Non-Target Level} = -\text{Prob[Target Level]}
\]

The Most Profitable Prediction is the level whose profit is the larger of these two values. It follows from the two Profit equations above that an observation is assigned to the target level whenever \(\text{Prob[Target Level]} \geq t\).

**Profit Matrix and Predictive Models**

For a nominal or ordinal column with the Profit Matrix column property, most modeling platforms enable you to save formula columns that reflect profit matrix entries. Fit your model and then select the Save Prediction Formula or Save Probability Formula option. In addition to saving the usual prediction formulas to the data table, JMP saves the following analogs of the usual formula columns:

• **Profit for <level>:** For each level of the response, a column gives the expected profit for classifying each observation into that level.

• **Most Profitable Prediction for <column name>:** For each observation, gives the level of the response with the highest expected profit.

• **Expected Profit for <column name>:** For each observation, gives the expected profit for the classification defined by the Most Profitable Prediction column.

• **Actual Profit for <column name>:** For each observation, gives the actual profit for classifying that observation into the level specified by the Most Profitable Prediction column.

See “Example of a Profit Matrix for More Than Two Levels”. For an example of using a profit matrix in modeling, see *Predictive and Specialized Modeling*.

**Example of a Profit Matrix for More Than Two Levels**

The example below shows a profit matrix for the *Airline* column in the *Travel Costs.jmp* sample data table.
To see how the values in this profit matrix were assigned, consider a travel agency that uses four airlines, Carrier 1 to Carrier 4, to service its customers. For each ticket sold, the agency realizes a profit that depends on the carrier selected by the customer. When the agency recommends, or predicts, a carrier, it reserves a ticket for a small fee. If the customer decides to use the predicted carrier, the agency profits by a certain amount less the reservation fee. However, if the customer decides to take a different carrier, the agency loses the reservation fee and must pay another reservation fee. The agency’s profit is lower due to the incorrect prediction.

Suppose that the reservation fees for Carriers 1 through Carrier 4 are $15, $20, $30, and $50, respectively, and that the profits from ticket sales are $40, $40, $100, and $110, respectively.

If the agency recommends Carrier 1 to a customer who then decides to purchase the ticket, the agency reserves a ticket for $15 and then receives $40 for a net profit of $25. If the agency predicts that a customer will choose Carrier 4 but the customer chooses Carrier 1, the agency loses $50 for the Carrier 4 reservation and must also pay $15 for the reservation on Carrier 1. This gives the agency a net loss of $40 - $50 - $15 = -$25.

Example of Using Probability Threshold to Define the Profit Matrix

The sample data table Liver Cancer.jmp gives disease Severity ratings for 136 patients. You are interested in modeling Severity using the predictors given in the columns from BMI to Jaundice. The usual prediction formulas for a model classify a patient into the Severity level that is most probable. However, classifying a patient as having Low severity when in actuality the patient’s severity is High is a more costly error than classifying a patient as having High severity when in actuality the patient’s severity is Low. As a result, you want to assign a higher cost to misclassifying a patient as Low, when the patient’s severity is actually high.
You can assign this higher cost by setting a probability threshold. With input from experts, you determine that the following is a good strategy: Classify into the High level of Severity any patient whose predicted probability of being in the High level exceeds 0.4.

1. Select **Help > Sample Data Folder** and open Liver Cancer.jmp.
2. Select the Severity column and select **Cols > Column Info**.
3. Select the Profit Matrix column property.
4. Change the Target to **High**.
5. Enter 0.4 as the **Probability Threshold**.
6. Click **Set**.

   The profit matrix updates to show the corresponding weights.

**Figure 5.8** Profit Matrix Showing Weights Corresponding to Probability Threshold

The profit matrix shows that the loss for misclassifying a patient with High severity as having Low severity is -1, while the loss for misclassifying a patient with Low severity as having High severity is smaller, -0.6667.
Informative Missing

The Informative Missing column property directs most fitting platforms to use a coding system for columns that contain missing values. For continuous columns, the coding system consists of two columns. The first column is a column of the original values with missing values replaced by the mean of the nonmissing values; the second column is an indicator column to denote which rows are missing. For categorical columns, missing values are treated as a distinct level of the column.

SAS Properties

SAS Label, SAS Name, SAS Format, and SAS Informat are assigned to columns when you import a SAS data set. You can change the value in the column property to control the label, name, format, or informat of the column that gets created in the SAS data set if the data is exported back to SAS.

Link Data Tables with Virtual Join Properties

Virtual Join links a main data table to one or more auxiliary data tables. The feature enables the main data table to access data from the auxiliary data tables without physically joining the tables. See “Virtually Join Data Tables”.

The Link ID and Link Reference column properties make the linking possible.

Notes:

• The data types of the Link ID and Link Reference columns must match.
• Link ID and Link Reference do not work for Row State and Expression data types.
• Consider adding the Link ID column property before adding the Link Reference column property so that the referencing column in the main table has a column to link to.

Link ID

The Link ID column property marks a column in the auxiliary data table as the ID column. That is, the rows of the data table are uniquely identified by the values of the ID column. The data table that has a Link ID column property is referred to as the referenced data table.

To add the Link ID column property, select the column, select Cols > Column Info and then select Link ID from the Column Properties list. Make sure that the Link ID checkbox is selected and click OK. The selected checkbox indicates that the column is the ID column for the data table.
Link Reference

The Link Reference column property maps a column in the main data table to the ID column in the referenced data table. The column that has a link reference is referred to as the referencing column. The referencing column can look up the data of the auxiliary data tables through the ID column.

To add the Link Reference column property, select the column, select Cols > Column Info, and then select Link Reference from the Column Properties list. Enter the path to the main table and click OK. If you enter the path correctly, the referenced columns show up in the Columns panel of the main table after you click OK.

Notes:

- The path is case sensitive.
- Consider putting the data tables in the same folder. Then you can omit the directory name from the Link Reference property and include only the data table name. Otherwise, include the full path to the data table (such as c:/users/marie/My Data.jmp).
- You can also increase portability by using a JMP path variable in the Link Reference path. Figure 5.9 shows an example. Enter a forward slash in the path to share the data tables with both Windows and macOS users. See the Scripting Guide for more information about path variables.
- You can avoid entering the path by right-clicking a column to add the Link Reference property. See “Example of Virtually Joining Columns”.
- Select Row State Synchronization options to synchronize row states in data tables that contain virtually joined columns. See “Example of Virtually Joining Columns and Showing Row States”.
- Select Auto Open to open the linked table automatically when the main data table is opened. See “Update Data Tables”.
- You can specify that the linked column name be used in virtually joined columns. This option lets you specify a shorter column name (for example, Cheese instead of Cheese[Choice]). In the Link Reference column property, select Use Linked Column Name.
Additional Column Properties

There are three additional properties: Expression Role, Event Handler, and Other.

Expression Role

When you import a column of data that contains image data, the data type is set to Expression to show the data as pictures. Or you can assign the Expression data type in the Column Info window.

To customize how the image looks in the data table cell, or to display matrices and expressions as images, add the Expression Role column property. The default is set to Picture. If the Expression Role is set to Picture and the expression is a picture, then the expression evaluates to a picture and the picture appears in the data table. Otherwise, the expression shows as a JSL expression. Change this setting to alter how expressions are used.

**Note:** Expression columns that contain images greater than 32KB in size are truncated when saved to Microsoft Excel. Those expression columns are not restored when imported back into JMP.
Select from the following options:

**Picture**  If the expression contains picture data, the column evaluates and the picture is displayed.

**Matrix**  If the expression contains a matrix, the column evaluates and the matrix is displayed. Otherwise, the data is displayed as an expression.

**Expression**  If the expression is simply an expression, use this option to display it in the column.

  Use Expression when you want to work with an expression that might contain picture data, but you want to prevent JMP from displaying the image.

**Picture expressions**  To customize how images appear in a data table cell, select one of the following options after selecting Picture from the list.

- **maximum width and height**  Specifies the maximum width and height of the image in the data table cell.

- **Stretch**  Enlarges a small image to fill the data table cell.

- **Preserve aspect ratio**  Maintains the image’s ratio of width to height in the data table cell. Selected by default.

- **Add a decorative frame to small images in a data table**  Displays a beveled edge around small images in the data table cell.

**To drag images into an expression column**

1. Create a new column in a data table.
2. Right-click the column, select **Column Info**, and then select the **Expression** data type.
3. Right-click the column, select **Column Properties**, and then select **Expression Role**.
4. Select options as described above.
5. Navigate to the website that contains the image that you want in your data table. You can also use an image that is on your computer.
6. Select the image, and drag it into an empty cell in the expression column.
   - Resize the cell to make the image larger.

   The SAS Offices.jmp and Big Class Families.jmp sample data tables show an example of an expression column.

**Tips:**

- You can also import data that contains a column of images to create an expression column.
- For more information about what you can do with images in an expression column, see “Use Images as Markers” and “Add Images from JMP Data Tables to Hover Labels”.


To add an expression column using Summary

1. Select Help > Sample Data Folder and open CrimeData.jmp.
2. Select Tables > Summary.
3. Select State, and click Group.
4. Select Total Rate, and click Statistics > Histogram.
5. Click OK.

A new data table appears that contains a new expression column with images of histograms. Resize the row to make images larger.

For more information about Summary, see Chapter 8, “Summarize Your Data”.

6. Right-click the Histogram(Total Rate) column, and select Column Info.

Notice the column’s data type is set to Expression.

7. Select Expression Role from the Column Properties menu.

The Expression Role is automatically set to Picture. In the rare case that a picture needs to be displayed as an Expression, change the setting to Expression.

8. Click OK.

Expression Role is assigned to the Expression column.

Event Handler

Use the Event Handler column property to define hyperlinks in a text column. The hyperlinks can be used to open web pages and other documents.

Add the Event Handler to a column of URLs to open the URLs in a browser. You can also modify the placeholder scripts on the column property to open different kinds of resources. For example, in a data table of geographical data, you might edit the Click script to display a Google map when the user clicks the hyperlink in the data table. The SAS Offices.jmp sample data table provides examples.

See the Scripting Guide for more information about editing the scripts.

Other

Use the Other column property to create your own column property and assign it any name that you choose. This property is then available for JSL programming.

1. Right-click the column and select Column Properties > Other.
2. Enter a name for the new property.
3. Enter a value for the property.
Properties Assigned and Controlled by JMP

To control how information flows between platforms, JMP assigns some properties that you cannot control. These properties do not appear on the Column Properties menu.

Response Probability

In Profiler reports, the Response Probability property makes all levels of the categorical response variable appear in a single row. JMP automatically assigns the Response Probability property when certain probability formulas are saved to the data table.

Follow these steps to save the property:
1. Fit a logistic regression model using the Fit Model platform.
2. Click the report red triangle and select **Save Probability Formula**.

   JMP automatically assigns the Response Probability property to the new probability columns.

For more information about the prediction profiler, see **Profiler**.

Expand Formula

In the Profiler and Nonlinear platforms, if an input column to the model has a formula, JMP substitutes the inner formula, as long as it refers to other columns. To prevent an input column from expanding, assign a value of 0 to the Expand Formula property.

See **Profiler**.

Expand Intermediates

The Expand Intermediates property is assigned to saved formula columns that refer to intermediate formula columns. This is done in several JMP platforms to avoid repeating some calculations. When formula columns with the Expand Intermediates column property are specified in the Profiler, JMP automatically profiles them using the original factor columns.

**Note:** The Expand Intermediates column property overrides the Expand Intermediate Formula option in the profiler launch.

See **Profiler**.

Intermediate

The Intermediate property is assigned to intermediate formula columns that are used to calculate final saved output columns.
Predicting

JMP automatically assigns the Predicting column property when you fit a model to a continuous response and save the prediction formula or prediction values. The Predicting column property identifies the platform used to create the prediction formula. That platform is listed as the Creator in the Model Comparison platform. In many cases, the Predicting column property also includes an estimate of the standard deviation from the platform used to create the prediction formula. This standard deviation estimate is used in the Prediction Profiler platform.

For platforms that also assign a Std Error column property to a saved standard error formula column, the Predicting column property contains an ID clause. The ID number in the Predicting column property matches the ID number in the Std Error column property of the corresponding standard error formula column. These ID numbers are used by the Prediction Profiler platform and are especially useful when there are multiple prediction formula columns and standard error formula columns.

Std Error

JMP automatically assigns the Std Error column property when you fit a model to a continuous response and save a formula column that calculates the standard error of the predicted values. The Std Error column property contains an ID clause and a DF clause. The ID number matches the ID number in the corresponding prediction formula column. These ID numbers are used by the Prediction Profiler platform and are especially useful when there are multiple prediction formula columns and standard error formula columns. The DF value of this column property is used by the Prediction Profiler to draw confidence intervals when both a prediction formula column and a standard error formula column are provided.

Caution: Removing or changing this property is not recommended. Doing so could adversely affect the confidence intervals in the Prediction Profiler.

Informative Missing Terms

Missing levels of a categorical variable are treated as informative missing in certain JMP platforms, either by default or if you request an informative missing fit. In these cases, JMP automatically assigns the Informative Missing Terms column property to a prediction formula column that includes the categorical variable. This column property ensures that the missing value category is treated as a distinct level of the categorical variable in plots and analyses that involve the prediction formula. In particular, profiler plots show the missing values as a level.
Set JMP Column Properties
Chapter 5
Standardize Attributes and Properties Across Columns

**Column ID**

JMP automatically assigns the Column ID column property to the column that is used to split the initial Bootstrap results data table. This column property assists the split operation and ensures that the column names in the split Bootstrap results table are meaningful.

**ConstraintState**

When you select Save Constraints, the coefficients of each linear constraint appear in a column in a data table. Each constraint column is assigned the ConstraintState column property. This property specifies the direction of the inequality that defines the constraint. When you select Load Constraints from a design platform, the ConstraintState column property tells JMP the direction of the inequality.

**RunsPerBlock**

The RunsPerBlock property indicates the maximum allowable number of runs in each block. This property is used by the Evaluate Design and Augment Design platforms to indicate the blocking structure for the factor.

---

**Standardize Attributes and Properties Across Columns**

A column might contain attributes (data types, modeling types, numeric formats, and so on) or properties (formulas, notes, list and range checks, and so on) that you want other columns to have. You can use the existing column to standardize the attributes and properties across columns. This includes both adding and deleting attributes and properties.

*To apply an existing column’s attributes and properties to multiple columns*

1. Select the column or columns containing the desired attributes or properties.
2. Select Cols > Standardize Attributes.
Recode Column Values

Use the Recode option if you need to recode similar values within multiple columns in the same way. After you click **Recode**, the values that appear are generated from the union of all of the selected columns. For example, suppose that you have two columns with user responses. One column contains the values Agree and Disagree. The other column contains the values Agree, Disagree, Unsure, and Strongly Disagree. You want to simplify all of the values in both columns to be A, D, U, and SD.

**Note:** If you want to recode values only in a single column, you can also use the Cols > Recode option. See “Recode Data in a Column”.

Standardize Column Attributes

By default, the items within the Standardize Attributes panel are dimmed. To access an item, click the **Attributes** button and select the items to be duplicated across columns.

**Note:** The Input Format item is applicable only for the Date, Time, and Duration formats.

To change the values of any of the attributes, use the menus in the Standardize Attributes panel.
Standardize Column Properties

To standardize properties across columns

1. Select the columns that you want to standardize. One of those columns must contain the property that you want to add to the other columns.
2. Select Cols > Standardize Attributes.
4. Select the property that you want to standardize. Modify the property settings if necessary.
5. Click Apply to standardize the property across selected columns. Changes are shown in the data table, open reports, and open graphs.
   Or click OK to standardize the property across selected columns and close the column properties window.

Delete Column Properties

To delete the same properties across multiple columns

1. Select the columns containing the attributes or properties that you want to delete.
2. Select Cols > Standardize Attributes.
3. Under Delete Properties, click Column Properties and select the properties that you want to delete.
4. Click OK.

Note: Make sure you click OK and not Remove. Clicking Remove simply removes the property from the list but does not delete it.

Example of Standardizing a Formula

If you have applied a formula to a column, and you want to apply that same formula to additional columns in the data table, use the Substitute Column Reference option.

Note: This option is dependent upon the location of the column that is referenced in the original formula. For example, if your original formula is based on the previous column, then any other formulas applied to additional columns are based on their previous columns.

For example, the Blood Pressure.jmp sample data table contains blood pressure measurements taken on five subjects three times each day, over a period of three days. You want to find the log of each blood pressure (BP) column.
1. Select **Help > Sample Data Folder** and open Blood Pressure.jmp.

Create nine new columns, one for each existing BP column.

2. Select **Cols > New Columns**.

3. Add nine columns.

4. Click **OK**.

Apply your original formula:

5. Right-click Column 12 1 and select **Formula**.

6. Select **BP 8M**.

7. Select **Transcendental > Log**.

8. Click **OK**.

Column 12 1 now contains the log of the BP 8M column. You want the rest of the empty columns to contain the log of the remainder of the BP columns.

9. In the data table, select all of the new columns that you created, including the one with the original formula (columns 12 1 through 12 9).

10. Select **Cols > Standardize Attributes**.

11. In the Standardize Properties panel, click **Column Properties** and select **Formula**.

12. Select the check box next to **Substitute Column Reference**.

13. Leave **BP 8M** selected.

You want that column reference to be substituted in the subsequent column formulas.

14. Click **OK**.

Now all of the new columns are populated with the log of the BP columns, in the order in which they appear. Column 12 1 contains the log for BP 8M, Column 12 2 contains the log for BP 12M, and so on.

See “Copy and Replicate Formulas”.

---

**Assign a Preselected Analysis Role to a Column**

You can assign an analysis role, such as x, y, weight, or frequency, to a selected column and save the role with the data table. When you do this and then run an analysis, JMP uses the preselected role to automatically fill in the role boxes in windows. Then you do not have to specify these roles each time you run an analysis. For example, you might want a column named height to take the x role in every analysis of that data table. To enforce the x role, you assign the preselected role of x to the column.
When you select Freq, the values in that column are what JMP uses as the frequency of the observation. If $n$ is the value of the Freq variable for a given row, then that row is used in computations $n$ times. If it is less than 1 or is missing, then JMP does not use it to calculate any analyses.

When you select Weight, the values in that column provide weights for each observation in the data table. The variable does not have to be an integer, but it is included only in analyses when its value is greater than zero.

When you select Validation, that column is specified as a Validation column in platforms that support a Validation column role.

To assign a preselected role to a column

1. Highlight the column.
2. Select **Cols > Preselect Role.**
3. Select a role: **No Role, X, Y, Weight, Freq, or Validation.**

After you select the appropriate roles, icons in the Columns panel signify what roles have been assigned. Click the icon to access a list of roles and select a different one. See “Icons Representing Column Characteristics and Properties”.
This chapter covers the following tasks that you can perform on JMP data:

- create a new data table from a subset of rows and columns
- sort by any number of columns
- stack multiple columns into a single column
- split a column into two or more columns
- transpose rows and columns
- concatenate multiple tables end to end
- join two tables side by side
- virtually join tables without physically joining them
- update columns in a table with values from another table
- anonymize the data

**Figure 6.1** Creating a Subset Data Table from a Report
Contents

Create a Subset Data Table ................................................................. 341
Create a Subset Data Table from a JMP Report ................................. 343
Sort Data Tables ....................................................................... 344
Stack Columns in Data Tables ........................................................... 347
   Example of Stacking Columns into a Single Column ......................... 349
   Example of Stacking Columns into More Than One Column ............... 350
Split Columns in Data Tables ............................................................ 351
   Examples of Splitting Columns ....................................................... 353
Transpose Rows and Columns in a Data Table ..................................... 355
   Examples of Transposing Rows and Columns in a Data Table ............ 358
Concatenate Data Tables .................................................................. 359
   Example of Concatenating Data Tables .......................................... 361
   Example of Concatenating Data Tables and Table Variables ............ 362
Join Data Tables .......................................................................... 363
   Examples of Joining Data Tables .................................................... 366
Query and Join Data Tables with JMP Query Builder ......................... 373
   About Links to Data Tables in JMP Queries ................................... 376
Virtually Join Data Tables ................................................................ 377
   Example of Virtually Joining Columns ............................................ 378
   Example of Virtually Joining Columns and Showing Row States ......... 381
   Example of Merging Referenced Data in Virtually Joined Data Tables . 383
   Example of a Link ID and a Link Reference on a Single Column ........ 386
Update Data Tables ...................................................................... 389
   Example of Updating a JMP Data Table ....................................... 392
Anonymize Data ........................................................................... 393
Create a Subset Data Table

You can produce a new JMP data table that is a subset of all rows and columns, only highlighted rows and columns, or randomly selected rows from the active JMP data table.

To create a subset

1. Select **Tables > Subset**.

Figure 6.2 The Subset Window

2. Specify the content that you want to subset. Select any combination of the following:
   - Subset by (the levels within selected columns)
   - Rows (all, selected, or random)
   - Columns (all or selected)

   In Figure 6.2, the **sex** column will be subset.

3. Customize your subset table further using the additional options.

4. Click **OK** to create the subset table.
Subset Options

Subset by  Subsets by the levels of a column. Select Subset by and then select the columns that you want to categorize for the subset.

Consider the fact that many new data tables might be created. A new data table appears for each level of the column that you specified in the Subset window.

All Rows  Creates a subset table that contains all rows from the active table.

Selected Rows  Creates a subset table that contains only the selected rows from the active table. Selected by default.

Random - sampling rate  Creates a subset table whose data is a random proportion of the active data table. Enter the proportion of the sample that you want in the text box. For example, if you want a random 50% of the data to be included in the new table, enter 0.5 in the text box.

Random - sample size  Creates a subset table whose data is a random sample of the active data table. Enter the size of the sample that you want in the text box. For example, if you want 16 random rows to be included in the new table, enter 16 into the text box.

If you select a random sample that is the entire source table, the result is a random shuffle of the rows of the data table. If you specify columns to stratify, the result is a random shuffle of each of the rows for each group. See “Select this option for very large tables that can cause delays as the Preview pane is refreshed. Deselected by default.Stratified Subsets”.

All columns  Creates a subset table that contains all columns from the active table. Selected by default.

Selected columns  Creates a subset table that contains only the selected columns from the active table.

Keep by columns  Retains the column that you subsetted by in the output data tables.

Output table name  Specifies the name of the subset table.

Link to original data table  Links the subset table to the original table. When you change values in one table, the other table is updated.

Copy formula  Includes formulas from the original table in the output columns. Include all columns needed for the calculation of the formula. Selected by default.

Suppress formula evaluation  Prevents JMP from evaluating columns’ formulas when the new table is created. Selected by default.

Save Default Options  Saves your current settings.
**Note:** Save Default Options only saves the settings for Selected Rows, Selected Columns, Linked to original data table, Copy formula, and Suppress formula evaluation.

**Keep dialog open**  Keeps the Subset window open after you click OK.

**Save Script to Source Table**  Saves a script to the original data table that enables you to subset the data again using the same settings.

**Auto Refresh**  Automatically refreshes the table Preview. If the Preview takes too much time to complete, you can deselect this option and click the Refresh button . Selected by default.

**Preview with Random Subset**  Select this option for very large tables that can cause delays as the Preview pane is refreshed. Deselected by default.

Stratified Subsets

In the JMP Subset window, if you specify a sample size and add stratification columns, the sample size represents the size per stratum, rather than the size of the whole subset.

**Figure 6.3** Stratified Subsets

For stratified random samples with a specified sample size, two columns can be saved: Selection Probability and Sampling Weight. Check the corresponding check box to save these columns.

**Create a Subset Data Table from a JMP Report**

Histograms and Pareto plots produce linked subsets of a data table.

**Use a Histogram**

Once you have produced output that contains a histogram (by selecting Analyze > Distribution), you can use the histogram to create a new data table. The new data table contains the data in the histogram’s highlighted bars.
To create a subset, double-click a highlighted bar. Or, right-click anywhere in the histogram and select **Subset** from the menu. The subset table appears.

**Figure 6.4** Subset Created from a Histogram

---

**Note:** The subset data table contains a view of the data, not the actual data. You must explicitly save the table if you want a copy. Note that the saved copy of the data table is no longer linked to the source table.

**Using a Pareto Plot**

Once you have produced output that contains a Pareto plot (by selecting **Analyze > Quality and Process > Pareto Plot**), you can use the Pareto plot to create a new data table. The new data table contains the data in the Pareto plot’s highlighted bars. To create a subset, double-click a highlighted bar.

**Sort Data Tables**

You can sort a JMP data table by columns in either ascending or descending order. By default, columns sort in ascending order. You can either create a new table that contains the sorted values, or you can replace the original table with the sorted table.

If columns contain value labels, sorting is based on the actual data values, not the value labels. (See “**Value Labels**.”) However, the value labels are displayed in the sorted data table.
If your sorted column uses either the Value Order property or the List Check property, the column is sorted according to that order.

**Example of Sorting Data Tables**

1. Select **Help > Sample Data Folder** and open Popcorn.jmp.
2. Select **Tables > Sort**.

**Figure 6.5 The Sort Window**

3. Highlight the names of the columns that you want to sort by. For this example, select popcorn and yield.
4. Click **By** to add the columns to the sort list.

   The columns that you add to the list establish the order of precedence for sorting. The first column in the list is the major sort field. Each variable thereafter is sorted within the previous variable in the sort list. You can drag and drop within the By list to change the sort order.

5. Customize your sort further using the additional options. For this example, highlight yield and click the descending button.

6. Enter a name for the new sorted table in the box beside **Output table name**. For this example, enter **sorted popcorn**.
Figure 6.6 Completed Sort Window

7. Click **OK**.

**Sort Options**

**Select Columns Filter Menu**  Contains options to search and filter through columns. See “Column Filter Menu”.

**Replace Table**  Replaces the original data table with the sorted table instead of creating a new table with the sorted values. This option is not available if there are any open report windows generated from the original table.

**Output table name**  (Optional) Specifies the name of the sorted table.

**Keep dialog open**  Keeps the Sort window open after you click **OK**.

**Save Script to Source Table**  Saves a script to the original data table that enables you to sort the data again using the same settings.

**By**  Adds the columns that you want to sort by. The columns that you add to the list establish the order of precedence for sorting. The first column in the list is the major sort field. Each variable thereafter is sorted within the previous variable in the sort list.

**Remove**  Removes any highlighted columns.

**Ascending and descending buttons**  You can change the ascending or descending list order of the values for the grouping variables. In the By variable list, select a variable
and click the appropriate ascending or descending button. The icon beside the variable changes to indicate the sorting order.

**Save Default Options**  Saves the current settings as the new default options.

**Auto Refresh**  Automatically refreshes the table Preview. If the Preview takes too much time to complete, you can deselect this option and click the Refresh button. Selected by default.

**Preview with Random Subset**  Select this option for very large tables that can cause delays as the Preview pane is refreshed. Deselected by default.

---

## Stack Columns in Data Tables

You can rearrange your JMP data table by stacking two or more columns into a single new column, preserving the values from the other columns. Or, you can stack a set of columns into multiple groups. The various ways that you can stack columns are explained in “Stack Options”.

To stack columns, follow these steps:

1. Select **Tables > Stack**.

   **Figure 6.7** Stack Window

2. Highlight the names of the columns that you want to stack and click **Stack Columns**.

3. Customize your stacking further using the additional options.

4. Click **OK**.
Stack Options

**Select Columns Filter Menu** Contains options to search and filter through columns. See “Column Filter Menu”.

**Multiple series stack** Stacks selected columns into two or more columns. Specify the number of columns into which you want the selected columns to be stacked by entering the number into the Number of Series box. This box appears when you check the box beside **Multiple series stack**.

Select the **Contiguous** option if the series consists of adjacent columns.

See “Example of Stacking Columns into More Than One Column”.

**Note:** The order in which you add columns to the box on the right determines the group to which they belong.

**Stack by Row** Stacks columns by rows. Deselect the option to stack one column underneath another. Selected by default.

**Eliminate missing rows** Eliminates missing data from the new table. If Stack by Rows is checked also, only rows with all data missing are eliminated.

**Non-stacked columns** Includes or drops non-stacked columns from the new data table.

Select one of these options:

- **Keep All** Includes all of the non-stacked columns from the original table in the new table. Selected by default.

- **Drop All** Omits the non-stacked columns from the new table.

- **Select** Select the non-stacked columns that you want to include or drop in the new table.

**Keep dialog open** Keeps the Stack window open after you click **OK**.

**Save Script to Source Table** Saves a script to the original data table that enables you to stack the data again using the same settings.

**Stack Columns** Adds the columns that you want to stack.

**Remove** Removes any highlighted columns.

**Output table name** (Optional) Specifies the name of the new table.

**Stacked Data Column** Assigns a name to the column that will contain the data for the stacked columns. The default name is **Data**. Leave the box empty if you do not want this column to appear in the new table.
Source Label Column  Assigns a name to the column that will contain the original table’s column names. The default name is Label. Leave the box empty if you do not want this column to appear in the new table.

Copy formula  Includes formulas from the original table in the output columns. Selected by default.

Suppress formula evaluation  Prevents JMP from evaluating columns’ formulas when the new table is created. Selected by default.

Move Columns  Specifies where the stacked columns are moved to. To Last is the default value.

Auto Refresh  Automatically refreshes the table Preview. If the Preview takes too much time to complete, you can deselect this option and click the Refresh button . Selected by default.

Preview with Random Subset  Select this option for very large tables that can cause delays as the Preview pane is refreshed. Deselected by default.

Example of Stacking Columns into a Single Column

A researcher has two columns in their JMP data table representing yield, and they want to stack the two columns into a single column. (This new single column is called Data by default.)

1. Select Help > Sample Data Folder and open Popcorn Trials.jmp.
2. Select Tables > Stack.
3. Select yield1 and yield2 and click Stack Columns.
4. Click OK.

In the Preview pane, the Label column represents the Source Label Column that identifies the source of the data. Its values are the column names in the original table from which the stacked values originated.

**Example of Stacking Columns into More Than One Column**

Suppose that a researcher has data on blood pressure readings. The readings were taken over three days: Monday, Wednesday, and Friday. Three readings were taken each day, at 8am, 12pm, and 6pm.

1. Select Help > Sample Data Folder and open Blood Pressure.jmp.

   Each BP (blood pressure) column is delineated according to the date and time. The BP 8M column corresponds to readings that were taken at 8am on Monday. The BP 12W column corresponds to readings that were taken on 12pm on Wednesday, and so on. The researcher wants to stack all of the blood pressure columns into three columns that correspond to each day: Monday, Wednesday, and Friday.

2. Select Tables > Stack.

3. Select all of the BP readings and click Stack Columns.

   The order of the columns reflects how the columns in the series should be grouped.

4. Select Multiple series stack.
5. Next to Number of Series, type 3.
6. Because you want to stack the columns vertically, select **Contiguous**.
7. Rename the Stacked Data Column from Data to BP (for blood pressure).
8. Rename the Source Label Column from Label to Day.

**Figure 6.9** Completed Stack Window

9. Click **OK**.

In the stacked data table, note the following:
- The first Day column represents Monday.
- The Day 2 column represents Wednesday.
- The Day 3 column represents Friday.

---

**Split Columns in Data Tables**

You can create a new JMP data table from the active JMP data table by splitting one column into several new columns. This column is split according to the values found in another column, referred to as the **Split By** column. You can also split columns according to the values of one or more grouping variables.

**Note:** If the split is on a categorical column that contains a missing value, the column name for the missing category is “.” for a numeric column.
To split columns, follow these steps:

1. Select **Tables > Split**.

**Figure 6.10** Split Window

2. Highlight the names of the column or columns that you want to split and click **Split Columns**.

3. Highlight a column whose values you want to use as the basis for splitting the column.

4. Click **Split By**.

5. Customize your splitting further using the additional options.

6. Click **OK**.

**Split Options**

**Select Columns Filter Menu**  Contains options to search and filter through columns. See “**Column Filter Menu**”.

- **Keep All**  Includes all columns in the new table.
- **Drop All**  Includes only columns used in the split in the new table. Selected by default.
- **Select**  Selects which columns to keep in the new table.

**Keep dialog open**  Keeps the Split window open after you click **OK**.

**Save Script to Source Table**  Saves a script to the original data table that enables you to split the data again using the same settings.
Split By  Adds the column whose values you want to use as the new column names, and as the basis for splitting the column.

Split Columns  Adds the column or columns that you want to split.

Group  Specifies a Group variable when you want your data to be split within each group of the selected variable. Each group results in a row in the output table. You must also specify the required variables, Split By, and Split Columns.

Note: If the variable that you want to group by contains unequal groups or is in a random order, specifying it as the Group variable ensures that your data is restructured properly, and any missing values are assigned in the appropriate places.

Sort by Column Property  Sorts the order of the output columns by the Value Order column property. If the column does not have a Value Order property, and the data has an implied order (such as days or months), the implied order is applied.

Output table name  (Optional) Specifies the name of the new table.

Copy formula  (Appears if there is a formula in the data table.) Includes formulas from the original table in the output columns.

Suppress formula evaluation  (Appears if there is a formula in the data table.) Prevents JMP from evaluating columns’ formulas when the new table is created.

Auto Refresh  Automatically refreshes the table Preview. If the Preview takes too much time to complete, you can deselect this option and click the Refresh button . Selected by default.

Preview with Random Subset  Select this option for very large tables that can cause delays as the Preview pane is refreshed. Deselected by default.

Examples of Splitting Columns

This section contains two examples using the Split command in JMP:

• In the first example, one column is split by a second column. See “Example of Splitting a Column by a Second Column”.

• The second example uses a Group variable. See “Example of Splitting a Column Using a Group Variable”.

Example of Splitting a Column by a Second Column

In the Popcorn.jmp data table, the data in the trial column shows that there are two trials, 1 and 2. In this example, split the yield column into two new columns: one for trial 1 and one for trial 2.
1. Select Help > Sample Data Folder and open Popcorn.jmp.
2. Select Tables > Split.
3. Select the yield column and click Split Columns.
4. Select the trial column and click Split By.
5. Under Remaining columns, select Keep All.
   The default is Drop All, which omits any columns that are not in the Split By, Split Columns, or Group fields. Selecting Keep All includes these columns in the new table.
6. (Optional) Type Yield column split by Trial column in the Output table name field.
7. Click OK.
A new data table is created (Figure 6.11). Notice the following:
   – The yield and trial columns are gone.
   – The data table has two new columns, named after the unique values (1 and 2) from the original trial column.
   – The values from the original yield column are now split into the new columns named 1 and 2.
   – The columns other than trial and yield are exactly the same as they were in the original table.
8. (Optional) Rename the new columns to give them meaningful names. For example, rename 1 to yield (trial 1) and rename 2 to yield (trial 2).

Figure 6.11  New Table Created By Splitting yield Column by trial Column

Example of Splitting a Column Using a Group Variable

The Drug Measurements.jmp sample data table contains measurements of three different drugs (a, b, and c) administered to 12 different subjects. You want to split the measurement into different columns, one for each drug type. You also want to group the measurements by subject.

1. Select Help > Sample Data Folder and open Drug Measurements.jmp.
2. Select Tables > Split.
3. Select Drug Type and click Split By.
4. Select Measurement and click Split Columns.

Notice that the Subject variable contains unequal groups. Most of the subjects were given all three drugs, but subject 2 was given only one drug, and subjects 7 and 12 were given only two drugs. In this situation, to ensure that the correct measurements are associated with the correct subject, specify Subject as the Group variable.

5. Select Subject and click Group.
6. Click OK.

Figure 6.12 Drug Measurements.jmp Split by a Grouping Variable

<table>
<thead>
<tr>
<th>Subject</th>
<th>a</th>
<th>b</th>
<th>c</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>91</td>
<td>99</td>
<td>91</td>
</tr>
<tr>
<td>2</td>
<td>•</td>
<td>96</td>
<td>•</td>
</tr>
<tr>
<td>3</td>
<td>95</td>
<td>99</td>
<td>93</td>
</tr>
<tr>
<td>4</td>
<td>97</td>
<td>93</td>
<td>96</td>
</tr>
<tr>
<td>5</td>
<td>95</td>
<td>100</td>
<td>94</td>
</tr>
<tr>
<td>6</td>
<td>92</td>
<td>96</td>
<td>95</td>
</tr>
<tr>
<td>7</td>
<td>93</td>
<td>96</td>
<td>•</td>
</tr>
<tr>
<td>8</td>
<td>100</td>
<td>94</td>
<td>92</td>
</tr>
<tr>
<td>9</td>
<td>98</td>
<td>99</td>
<td>97</td>
</tr>
<tr>
<td>10</td>
<td>96</td>
<td>•</td>
<td>99</td>
</tr>
<tr>
<td>11</td>
<td>98</td>
<td>100</td>
<td>93</td>
</tr>
<tr>
<td>12</td>
<td>•</td>
<td>95</td>
<td>95</td>
</tr>
</tbody>
</table>

You can see that the appropriate missing values appear for subjects 2, 7, and 12.

Transpose Rows and Columns in a Data Table

You can create a new JMP data table that is a transposed version of the active data table. The columns of the active table are the rows of the new table, and its rows are the new table’s columns.

When you transpose columns, you do the following:

- Select the columns to be transposed.
- Specify a “label” column, from which the new columns get their names (optional).
- Specify “by” columns, which tells JMP to transpose data within groups (optional).
Note: Columns that you want to transpose must have the same data type. Also, if columns contain value labels, transposing uses the actual data values, not the value labels. (See “Value Labels”.)

To transpose rows and columns, follow these steps:
1. Open a data table that contains the rows and columns that you want to transpose.
2. Select Tables > Transpose.

Figure 6.13 Transpose Window

3. Highlight the column name(s) you want to transpose in the Select Columns box on the left.
4. Click Transpose Columns.
5. (Optional) Customize your transposed table further using the additional options.
6. Click OK.

Transpose Options

Select Columns Filter Menu  Contains options to search and filter through columns. See “Column Filter Menu”.

Transpose selected rows only  Transposes only rows that are currently highlighted in the active table.

Output table name  (Optional) Specifies the name of the subset table.
Label column name  (Applicable only if you have specified a Label column.) Specifies an alternative name for the Label column. Otherwise, the default column name is Label.

Keep dialog open  Keeps the Transpose window open after you click OK.

Save Script to Source Table  Saves a script to the original data table that enables you to transpose the data again using the same settings.

Transpose Columns  Adds the columns that you want to transpose.

Label  Uses the data from a column in the original table as the column names in the new table. Follow these steps:

1. Highlight a column from the Select Columns box on the left.
2. Click Label. The column name appears in the Label box.

The default column name is Label. You can specify an alternative name for the column using the Label column name option. Only one column is created for each distinct value in the label column. Therefore, if there are duplicate values in the label column, JMP creates only one column for the duplicated value using the value from the last duplicated row.

By  Organizes the transposed columns into groups based on the columns that you put into the By box. Follow these steps:

1. Highlight the column name(s) in the Select Columns box whose values you want to see as a group.
2. Click By.

Auto Refresh  Automatically refreshes the table Preview. If the Preview takes too much time to complete, you can deselect this option and click the Refresh button. Selected by default.

Preview with Random Subset  Select this option for very large tables that can cause delays as the Preview pane is refreshed. Deselected by default. Table 6.1 describes the rules that apply to transposing.

Table 6.1  Rules for Transposing

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>The original table has columns but no rows</td>
<td>The new table contains one column that lists those column names.</td>
</tr>
<tr>
<td>The original table has one column and it is assigned to Label</td>
<td>Its values become the column names in the transposed table.</td>
</tr>
</tbody>
</table>
Chapter 6

Reshape Your Data
Transpose Rows and Columns in a Data Table

This section contains three examples: a simple example of transposing, an example using the Label option, and an example using a By group.

Simple Example of Transposing
1. Select Help > Sample Data Folder and open Materials1.jmp.
2. Select Tables > Transpose.
3. Select plastic, tin, and gold and click Transpose Columns.
4. Click OK.

Figure 6.14 Simple Transposed Table

The original table in Figure 6.14 has two rows and three continuous columns called plastic, tin, and gold. The transposed table has a row for each of the three columns in the original table, and columns named Row 1 and Row 2 for the original table’s rows. The additional column called Label has the column names (plastic, tin, and gold) from the original table as values.

Example Using the Label Option
1. Select Help > Sample Data Folder and open Materials2.jmp.
2. Select Tables > Transpose.
3. Select plastic, tin, and gold and click Transpose Columns.
4. Select item and click Label.
5. Click OK.
Chapter 6
Reshape Your Data

Using JMP Concatenate Data Tables

Figure 6.15  Transpose with a Label

<table>
<thead>
<tr>
<th>Label</th>
<th>nails</th>
<th>hooks</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>plastic</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>tin</td>
<td>5</td>
</tr>
<tr>
<td>3</td>
<td>gold</td>
<td>6</td>
</tr>
</tbody>
</table>

The values from the item column in the original table are used as column labels in the transposed table.

Example Using a By Group

1. Select Help > Sample Data Folder and open Animals Subset.jmp.
2. Select Tables > Transpose.
3. Select subject and miles and click Transpose Columns.
4. Select season and click Label.
5. Select species and click By.
6. Click OK.

Figure 6.16  Transpose Using a By Group

<table>
<thead>
<tr>
<th>species</th>
<th>Label</th>
<th>fall</th>
<th>winter</th>
<th>spring</th>
<th>summer</th>
</tr>
</thead>
<tbody>
<tr>
<td>COYOTE</td>
<td>subject</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>COYOTE</td>
<td>miles</td>
<td>4</td>
<td>2</td>
<td>7</td>
<td>8</td>
</tr>
<tr>
<td>FOX</td>
<td>subject</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>FOX</td>
<td>miles</td>
<td>4</td>
<td>3</td>
<td>6</td>
<td>2</td>
</tr>
</tbody>
</table>

The transposed table contains values that have been transposed in groups.

Concatenate Data Tables

When you concatenate data tables in JMP, you combine rows from two or more data tables. You can create a new data table or you can append rows to the first data table. A column name might be the same in the data tables that you want to concatenate. If so, then the column in the new data table lists the values from all of the data tables in the order of concatenation. If the two original data tables have columns with different names, those columns are included in the new data table showing missing values.

To concatenate two data tables with the same column names, follow these steps:
1. Select Tables > Concatenate.
2. Highlight the names of the data tables that you would like to combine, and click **Add**.
   You can concatenate as many data tables as you choose, and you can also add the same data tables multiple times. The number of rows in the new data tables is the sum of the number of rows in all the data tables.

3. (Optional) Click the **Save and evaluate formulas** choice to request that JMP include all formulas.
   If you do not select this option, no formulas are included in the new data table.

   **Note:** Columns with the same name can have different formulas. The formula from the first data table that contains a formula for that column is saved in the concatenated data table. This situation can occur when more than two tables are being concatenated and the second or third on has a formula for the column in question.

4. (Optional) Click the **Create source column** choice to add a column called **Source Table** to the new data table.
   This column identifies the name of the source data table in the corresponding rows.

5. (Optional) Select the **Append to first table** choice to append rows to the data table listed first in the **Data Tables to be Concatenated** field. This option is an alternative to creating a new data table.

6. (Optional) Enter a name for the new data table in the **Output table name** field.
If you do not enter a name, JMP names the data table Untitled# (for example, Untitled1). The **Output table name** field is not available if you selected the **Append to first table** choice.

7. Click OK.

**Example of Concatenating Data Tables**

Suppose that you want to concatenate two JMP data tables (Trial1.jmp and Trial2.jmp) into a new data table.

To concatenate data tables, follow these steps:

1. Select **Help > Sample Data Folder** and open Trial1.jmp and Trial2.jmp.
2. From the Trial1.jmp table, select **Tables > Concatenate**.
3. In the **Opened Data Table** list, select Trial2 and click **Add**.
4. Click **OK**.

The data tables combine into a new concatenated table with all of the rows from the first data table followed by all of the rows from the second data table.

**Figure 6.18** Result of Concatenating Two Data Tables

<table>
<thead>
<tr>
<th>popcorn</th>
<th>oil amt</th>
<th>batch</th>
<th>yield</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 plain</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
</tr>
<tr>
<td>2 gourmet</td>
<td>little</td>
<td>large</td>
<td>8.6</td>
</tr>
<tr>
<td>3 plain</td>
<td>lots</td>
<td>large</td>
<td>10.4</td>
</tr>
<tr>
<td>4 gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.2</td>
</tr>
<tr>
<td>5 plain</td>
<td>little</td>
<td>small</td>
<td>9.9</td>
</tr>
<tr>
<td>6 gourmet</td>
<td>little</td>
<td>small</td>
<td>12.1</td>
</tr>
<tr>
<td>7 plain</td>
<td>lots</td>
<td>small</td>
<td>10.6</td>
</tr>
<tr>
<td>8 gourmet</td>
<td>lots</td>
<td>small</td>
<td>18.0</td>
</tr>
<tr>
<td>9 plain</td>
<td>little</td>
<td>large</td>
<td>8.8</td>
</tr>
<tr>
<td>10 gourmet</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
</tr>
<tr>
<td>11 plain</td>
<td>lots</td>
<td>large</td>
<td>8.8</td>
</tr>
<tr>
<td>12 gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.8</td>
</tr>
<tr>
<td>13 plain</td>
<td>little</td>
<td>small</td>
<td>10.1</td>
</tr>
<tr>
<td>14 gourmet</td>
<td>little</td>
<td>small</td>
<td>15.9</td>
</tr>
<tr>
<td>15 plain</td>
<td>lots</td>
<td>small</td>
<td>7.4</td>
</tr>
<tr>
<td>16 gourmet</td>
<td>lots</td>
<td>small</td>
<td>16.0</td>
</tr>
</tbody>
</table>

Concatenated data tables always contain a column for every column name found in the original data tables. However, if the column names do not match exactly, they are not merged. For example, if the **yield** column was instead named **yield1** and **yield2**, a separate column would be created for each in the concatenated data table.
When you concatenate two or more data tables containing table variables, separate columns are created for each table variable. This ensures that important distinctions are not lost when concatenating data tables.

**Note:** Columns are not created for table variables that begin with the name Notes.

### Example of Concatenating Data Tables and Table Variables

Suppose that two cancer trials were conducted at two different hospitals. One of the trials’ data is in the Cancer1.jmp data table, and the other trial’s data is in the Cancer2.jmp data table.

To consolidate the data and the variables into one JMP data table, follow these steps:

1. Select **Help > Sample Data Folder** and open Cancer1.jmp and Cancer2.jmp.
   
   Notice that there are two distinct table variables: Dosage Amount and Location. In the concatenated table, columns are created for these two table variables.

2. From the Cancer1.jmp data table, select **Tables > Concatenate**.
3. Select Cancer2 and click **Add**.
4. Click **OK**.

![Figure 6.19 Data and Variables Concatenated](image)

The data and the variables are concatenated. The variables appear as columns in the concatenated table. The notes from each data table are added to the new data table as table variables.
Join Data Tables

You can combine two JMP data tables into one new table by selecting **Tables > Join**. For an overall description of how to join two data tables, see “To join two data tables into a new data table, follow these steps:”. Tables can be joined in three different ways:

- By combining them according to row number. See “Example of Joining by Row Number”.
- In a Cartesian fashion, where you form a new table consisting of all possible combinations of the rows from two original tables. See “Examples of a Cartesian Join”.
- By matching the values in one or more columns that exist in both data tables, or in a single data table. See “Examples of Joining By Matching Columns”.

**Note:** The JMP Query Builder option in the Tables menu provides an option to query data before performing a simple join. See “Query and Join Data Tables with JMP Query Builder”.

To join two data tables into a new data table, follow these steps:

1. Open the two data tables that you want to join.
2. Select **Tables > Join**.
   In the window that appears, the names of all open tables appear below **Join...with**.

**Figure 6.20** The Join Window

3. In the **Join...with** box, select the table to join with the active table.
4. From the Matching Specification area, select the option that specifies how to join the tables.

5. Enter the name of the new table in the text box beside **Output table name**.

6. (Optional) Customize the join procedure further using the additional options.

7. Click **OK** to create the joined data table.

**Note:** Joining on matching columns that have value labels correctly joins with the column’s data values, not the value labels.

### Join Options

**Keep dialog open**  Keeps the Join window open after you click OK.

**Save Script to Source Table**  Saves a script to the original data table that enables you to join the data again using the same settings.

**Preserve main table order**  Maintains the order of the original data table in the joined table, instead of sorting by the matching columns. Selected by default.

**Update main table with data from second table**  Data in the original table are updated with data in columns that have the same names. The results are displayed in a new data table.

Note the following:

- JMP does not replace data with missing values.
- The output table uses the same columns as the original table. Thus, when you use **Update main table with data from second table**, **Select Columns for joined table** is not applicable.
- The **Update main table with data from second table** option is available only when joining by row number or by matching columns.

**Merge same name columns**  Data from the second table replaces the data of the same name columns in the original table. Note that missing values in the first table are replaced by nonmissing values in the second.

If you are matching by column, Match Flag is selected when you select **Merge same name columns**. The new joined table contains a nominal column named **Match Flag**:

- If Main appears in this column, the data originated from the first (active) table.
- If With appears in this column, the data originated from the second table.
- If Both appears in this column, the data was found in both the first and second tables.

**Match flag**  Determines whether the **Match Flag** column is created when you are matching by column. Selected automatically when you select **Merge same name columns**.
Copy formula (Main Table and Second Table)  Includes formulas from the main table and/or the second table in the output columns. Selected by default.

Suppress formula evaluation (Main Table and Second Table)  Prevents JMP from evaluating columns’ formulas during the creation of the new table. Selected by default.

By Matching Columns  To join rows, select columns in both tables whose values and data types match. Follow these steps:

1. Highlight a column name from each list in the Source Columns area. The first highlighted column in the top list pairs with the first highlighted column in the bottom list, the second columns are paired, and so on. Rows join only if values and data types match for all the column pairs.

2. Click Match. The selected pair of columns appears in the Match columns box. Matching columns do not have to have the same names and do not have to be in the same relative column position in both tables.

3. (Optional) To include only the first match found, check the boxes associated with Drop multiples in both tables. Only the first match found is written to the new table. If you specify this option for one table, the first match value is joined with all matches in the other table. If you do not check the boxes associated with Drop multiples in either table, a Cartesian join is performed within each group of matching column values.

4. (Optional) To include all rows from the data table, even when there is no matching value, check the boxes associated with Include non-matches. You can specify this option for either or both data tables being joined.

By Row Number  Joins the two tables side by side.

Cartesian Join  Joins two tables using a Cartesian fashion, where it forms a new table consisting of all possible combinations of the rows from two original tables. JMP crosses the data in the first table with the data in the second to display all combinations of the values in each set.

Select Columns for joined table  Selects a subset of columns from either table for inclusion in the output table. Follow these steps:

1. In the Source Columns area, highlight the columns from each table that you want to include in the new table.

2. Click Select in the Output Columns area.

Output table name  Specifies the name of the joined table.

Auto Refresh  Automatically refreshes the table Preview. If the Preview takes too much time to complete, you can deselect this option and click the Refresh button . Selected by default.
**Preview with Random Subset**  Select this option for very large tables that can cause delays as the Preview pane is refreshed. Deselected by default.

**Examples of Joining Data Tables**

The following sections provide examples using the Join command in JMP.

**Example of Joining by Row Number**

Joining tables by row number joins the two tables side by side. The new table has all of the columns from both tables, unless you specify to include only certain columns.

*To join tables with an unequal number of rows*

If the two tables that you want to join have an unequal number of rows, the new table contains values for the rows found in both tables.

1. Select **Help > Sample Data Folder** and open Species1.jmp and Species2.jmp.
   Notice that the Species1.jmp table has two rows, and the Species2.jmp table has four rows.
2. From the Species1.jmp table, select **Tables > Join**.
3. In the **Join...with** box, select Species2.
4. From the Matching Specification area, select **By Row Number**.
5. Click **OK**.

**Figure 6.21**  Joined Tables by Row Number

<table>
<thead>
<tr>
<th>species</th>
<th>season</th>
</tr>
</thead>
<tbody>
<tr>
<td>FOX</td>
<td>spring</td>
</tr>
<tr>
<td>COYOTE</td>
<td>summer</td>
</tr>
<tr>
<td>fall</td>
<td></td>
</tr>
<tr>
<td>winter</td>
<td></td>
</tr>
</tbody>
</table>

If one table with two rows is joined with a table with four rows, then the new table contains four rows.

*To join columns with the same name*

If the two tables have column names that are the same, the names of these columns in the new table appear as “column name of table name.” For example, suppose that you want to combine the eight rows from the Trial1.jmp and Trial2.jmp data tables shown in **Figure 6.22** into a single table. You want to combine them so that the new table contains all of the columns from both tables.
1. Select **Help > Sample Data Folder** and open Trial1.jmp and Trial2.jmp.
2. From the Trial1.jmp data table, select **Tables > Join**.
3. In the **Join...with** box, select Trial2.
4. From the Matching Specification menu, select **By Row Number**.
5. Click **OK**.

**Figure 6.22** Original Tables and the Joined Table

<table>
<thead>
<tr>
<th></th>
<th>popcorn of Trial1</th>
<th>oil amt of Trial1</th>
<th>batch of Trial1</th>
<th>yield of Trial1</th>
<th>popcorn of Trial2</th>
<th>oil amt of Trial2</th>
<th>batch of Trial2</th>
<th>yield of Trial2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>8.8</td>
</tr>
<tr>
<td>2</td>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.6</td>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
</tr>
<tr>
<td>3</td>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>10.4</td>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>8.8</td>
</tr>
<tr>
<td>4</td>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.2</td>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.8</td>
</tr>
<tr>
<td>5</td>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>9.9</td>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>10.1</td>
</tr>
<tr>
<td>6</td>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>12.1</td>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>15.9</td>
</tr>
<tr>
<td>7</td>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>10.5</td>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>7.4</td>
</tr>
<tr>
<td>8</td>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>18.0</td>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>16.0</td>
</tr>
</tbody>
</table>

A column name can be the same in the two original tables. The output column name is then qualified by the source table name. For example, the column names in the new table appear as `<variable name> of table name`.

**To join only specified columns**

Suppose that you do not want all of the columns from the original data tables to be in the joined table:

1. Select **Help > Sample Data Folder** and open Trial1.jmp and Trial2.jmp.
2. From the Trial1.jmp data table, select **Tables > Join**.
3. In the **Join...with** box, select Trial2.
4. From the Matching Specification menu, select **By Row Number**.
5. Click **Select columns for joined table** to specify the subset of columns that you want to include.
6. In the Source Columns list, select popcorn and yield from the Trial1 list and select yield from the Trial2 list.

   Because identical data exists in the popcorn column of both tables, you need to select only one column.
7. Click **Select**.
8. Click **OK**.
Examples of a Cartesian Join

When doing a Cartesian join, JMP joins two tables in a Cartesian fashion: the new table consists of all possible combinations of the rows from two original tables. This creates cases in the output table where there are one case for each combination of column values.

Simple Example of a Cartesian Join

1. Select Help > Sample Data Folder and open Species1.jmp and Species2.jmp.
2. From the Species1.jmp table, select Tables > Join.
3. In the Join...with box, select Species2.
4. From the Matching Specification menu, select Cartesian Join.
5. Click OK.

Complex Example of a Cartesian Join

In this example, use the Tables > Join command twice:
The first join combines the Oil Amount.jmp table with the Batch.jmp table using the Cartesian option.

The second join combines the resulting table (Cartesian oil amount + batch) with the Popcorn Type.jmp table and produces a final table with all tables joined.

1. Select Help > Sample Data Folder and open Oil Amount.jmp, Batch.jmp, and Popcorn Type.jmp.
2. From the Oil Amount.jmp table, select Tables > Join.
3. In the Join...with box, select Batch.
4. From the Matching Specification menu, select Cartesian Join.
5. Under Output table name, type Oil Amount and Batch.
6. Click OK.

**Figure 6.25** Oil Amount and Batch Joined Table

<table>
<thead>
<tr>
<th>oil amount</th>
<th>batch</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>small</td>
</tr>
<tr>
<td>2</td>
<td>large</td>
</tr>
<tr>
<td>3</td>
<td>small</td>
</tr>
<tr>
<td>4</td>
<td>large</td>
</tr>
</tbody>
</table>

The joined table contains all of the columns from the Oil Amount.jmp and Batch.jmp tables. Add the Popcorn Type.jmp columns:

7. From the Oil Amount and Batch table that you just created, select Tables > Join.
8. In the Join...with box, select Popcorn Type.
10. Click OK.

**Figure 6.26** Oil Amount and Batch Joined with Popcorn Type

<table>
<thead>
<tr>
<th>oil amount</th>
<th>batch</th>
<th>popcorn</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>small</td>
<td>gourmet</td>
</tr>
<tr>
<td>2</td>
<td>small</td>
<td>plain</td>
</tr>
<tr>
<td>3</td>
<td>large</td>
<td>gourmet</td>
</tr>
<tr>
<td>4</td>
<td>large</td>
<td>plain</td>
</tr>
<tr>
<td>5</td>
<td>small</td>
<td>gourmet</td>
</tr>
<tr>
<td>6</td>
<td>small</td>
<td>plain</td>
</tr>
<tr>
<td>7</td>
<td>large</td>
<td>gourmet</td>
</tr>
<tr>
<td>8</td>
<td>large</td>
<td>plain</td>
</tr>
</tbody>
</table>
The final table contains all of the columns from all three original tables. Keep in mind that the number of rows produced by a Cartesian join is the product of the number of rows in the original tables.

**Examples of Joining By Matching Columns**

When you join data tables by matching columns, JMP aligns the rows in the two tables by matching column values.

**Caution:** If the matched columns do not result in unique rows, proceed carefully.

**Notes:**
- The columns used for matching must have the same data type (numeric, character, or row state).
- You can join a data table to itself, in order to remove duplicate values or rows from the data table.
- You can use a virtual join as an alternative to creating a new data table. See “Virtually Join Data Tables”.

*To join tables with a unique identifier*

You have two files of information about hot dogs. The second file contains one column, Size, that is missing from the first file. Use Join with a matching column to combine the data tables.

1. Select **Help > Sample Data Folder** and open Hot Dogs.jmp and Hot Dogs2.jmp.
   The Product Name column is a unique identifier for the rows in your data tables. Each table has 54 unique product names.
2. From the Hot Dogs data table, select **Tables > Join**.
3. In the Join ‘Hot Dogs’ with list, select Hot Dogs2.
4. Select **By Matching Columns** in the Matching Specification area.
5. From the Hot Dogs and Hot Dogs2 lists, select Product Name.
6. Click **Match**.
7. In the Options, select **Merge same column names**. When the merge columns is used the Match Flag is automatically selected.
8. Select **Keep dialog open** in the lower left corner of the window so that you can easily return to the Join window in the case that the joined data table is not as you expected.
9. Click **Apply**.
Chapter 6  
Reshape Your Data  
Using JMP

Figure 6.27  Joined Table by Matching Columns

<table>
<thead>
<tr>
<th>Match Flag</th>
<th>Product Name</th>
<th>Type</th>
<th>Taste</th>
<th>$/oz</th>
<th>$/lb Protein</th>
<th>Calories</th>
<th>Sodium</th>
<th>Protein/Fat</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Both</td>
<td>Happy Hill Supers</td>
<td>Beef</td>
<td>Bland</td>
<td>0.11</td>
<td>14.23</td>
<td>186</td>
<td>495</td>
<td>1</td>
<td>Jumbo</td>
</tr>
<tr>
<td>2 Both</td>
<td>Georgies Skinless...</td>
<td>Beef</td>
<td>Bland</td>
<td>0.17</td>
<td>21.70</td>
<td>181</td>
<td>477</td>
<td>2</td>
<td>Jumbo</td>
</tr>
<tr>
<td>3 Both</td>
<td>Special Market's...</td>
<td>Beef</td>
<td>Bland</td>
<td>0.11</td>
<td>14.49</td>
<td>176</td>
<td>425</td>
<td>1</td>
<td>Jumbo</td>
</tr>
<tr>
<td>4 Both</td>
<td>Spike's Beef</td>
<td>Beef</td>
<td>Medium</td>
<td>0.15</td>
<td>20.49</td>
<td>149</td>
<td>322</td>
<td>1</td>
<td>Regular</td>
</tr>
<tr>
<td>5 Both</td>
<td>Hungry Hugh's...</td>
<td>Beef</td>
<td>Medium</td>
<td>0.10</td>
<td>14.47</td>
<td>184</td>
<td>482</td>
<td>1</td>
<td>Regular</td>
</tr>
<tr>
<td>6 Both</td>
<td>Great Dinner Beef</td>
<td>Beef</td>
<td>Medium</td>
<td>0.11</td>
<td>15.45</td>
<td>190</td>
<td>587</td>
<td>2</td>
<td>Regular</td>
</tr>
<tr>
<td>7 Both</td>
<td>RUB Kosher Beef</td>
<td>Beef</td>
<td>Medium</td>
<td>0.21</td>
<td>25.25</td>
<td>158</td>
<td>370</td>
<td>2</td>
<td>Regular</td>
</tr>
<tr>
<td>8 Both</td>
<td>Wonder Kosher S...</td>
<td>Beef</td>
<td>Medium</td>
<td>0.20</td>
<td>24.02</td>
<td>139</td>
<td>322</td>
<td>2</td>
<td>Regular</td>
</tr>
<tr>
<td>9 Both</td>
<td>Happy Fats Jumbo...</td>
<td>Beef</td>
<td>Medium</td>
<td>0.14</td>
<td>18.86</td>
<td>175</td>
<td>479</td>
<td>1</td>
<td>Regular</td>
</tr>
<tr>
<td>10 Both</td>
<td>Midwest Beef</td>
<td>Beef</td>
<td>Medium</td>
<td>0.14</td>
<td>18.86</td>
<td>148</td>
<td>375</td>
<td>1</td>
<td>Regular</td>
</tr>
<tr>
<td>11 Both</td>
<td>General Kosher B...</td>
<td>Beef</td>
<td>Medium</td>
<td>0.23</td>
<td>30.65</td>
<td>152</td>
<td>330</td>
<td>1</td>
<td>Regular</td>
</tr>
</tbody>
</table>

The resulting table now includes the Size column that was in the Hot Dogs2 table. The Match Flag column indicates that the data originated from both tables for all rows.

To join tables with different numbers of rows and different column names

Suppose that Sarah and Joe are performing a popcorn experiment. They are popping different types of popcorn (gourmet and plain) in different amounts of oil. They are recording the amount (yield) of popcorn that is produced. Sarah gave you the first trial data in a file named Trial1.jmp. Joe gave you the second trial data in a file named Little.jmp. You want to combine the two tables into one table.

1. Select Help > Sample Data Folder and open Trial1.jmp and Little.jmp.
2. From the Trial1.jmp table, select Tables > Join.
3. In the Join...with box, select Little.
   You can see that three of the columns (popcorn, oil amt/oil, and batch) contain the same values in both tables. Identify these columns as matches. Also, because Sarah and Joe gave the oil and oil amt columns different names, you can tell JMP that oil amt and oil match.
4. Deselect Preserve main table order.
   The joined table is sorted by matching columns, not by the order of data in Trial1.jmp,
5. Select By Matching Columns in the Matching Specification area.
6. From the Trial1 list, select popcorn, oil amt, and batch.
7. From the Little list, select popcorn, oil, and batch.
8. Click Match.
   Looking at the two data tables, you can see that they have different numbers of rows. Trial1.jmp has values for eight experimental conditions, and Little.jmp has values for only four of those conditions. Sarah completed her experiment, but Joe only partially completed his experiment. You want the joined table to contain all of the rows in Trial1.jmp, even if that row in the Little.jmp table contains a missing value.
9. Select the Include non-matches boxes for both tables.
In the joined table, you want only one column for popcorn, one column for oil, and one column for batch. However, you want two columns for yield: one representing the yield from Trial1.jmp, and another representing the yield from Little.jmp.

10. Select the box beside **Select columns for joined table**.

11. From the Trial1 list, select all of the columns.

12. Click **Select**.

13. From the Little list, select yield.

14. Click **Select**.

**Figure 6.28** Completed Join Window

15. Click **OK**.

The joined table is sorted by the matching columns. Note that the yield column from the Little.jmp table (Yield of Little) has missing values indicating no matching values with the Trial1.jmp table.

*To join a table to itself (to remove duplicate entries)*

1. Select **Help > Sample Data Folder** and open Coffee Shop Purchases.jmp.
You can see that some of the customers had the same drink on the same date. You want to consolidate these duplicate rows using **Join**.

2. Select **Tables > Join**.
3. In the **Join...with** box, select Coffee Shop Purchases.
4. Select **By Matching Columns** in the Matching Specification area.
5. From both Coffee Shop Purchases lists, select all three columns: Date, Customer, and Beverage.
6. Click **Match**.
7. Select the **Drop multiples** boxes for both tables (the Main Table and the With Table).
8. Type **Coffee Shop Purchases Final** for the **Output table name**.
9. Click **OK**.

**Figure 6.29** Original and Joined Coffee Shop Purchases Data Tables

---

**Query and Join Data Tables with JMP Query Builder**

The JMP Query Builder option in the Tables menu enables you to query data tables and save selected data into a new data table. This feature is similar to using the Join command but lets you perform queries before saving the data. For example, you can query SAT data and save only data for 2004 test scores in a data table. You can also include a prompt that lets the user run the query and choose a subset of the 2004 test scores.

1. Select **Help > Sample Data Folder** and open SAT.jmp and SATByYear.jmp.
2. Display SATByYear.jmp.
3. Select **Tables > JMP Query Builder**.
   - The current data table, SATByYear.jmp, is selected as the Primary table.
4. Select SAT.jmp in the Available Tables list and click **Secondary**.
5. Select SAT.jmp next to the Secondary button and view the Columns tab. The Join column shows that two columns have the same name and were joined.

**Figure 6.30** Joined Columns

![Figure 6.30 Joined Columns](image)

6. Click **Build Query**.

**Add Columns**


2. Click **Add**.

   The columns are added to the Included Columns tab.

3. Select **Distinct rows only** to avoid saving duplicate rows.

4. On the Query Preview tab, make sure that **Update preview automatically** is selected so that you can see the selected columns.

**Add Filters**

1. In the Included Columns list, select t2.2004 Verbal and t2.2004 Math, and then click **Add Selected Items to Filter**.

   The columns are added to the Filters list.
2. Click the red triangle next to each filter and select **Prompt on Run**. Accept the default prompt message.

**Run the Query**

1. Click **Run Query**.

You are prompted to indicate which math and verbal scores to save in the data table. To save all data, do not change the values in the prompt window.

2. Click **OK** to create the data table.

**Figure 6.32 Queried Data**

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Alabama</td>
<td>0.1</td>
<td>560</td>
<td>553</td>
</tr>
<tr>
<td>Alaska</td>
<td>0.53</td>
<td>518</td>
<td>514</td>
</tr>
<tr>
<td>Arizona</td>
<td>0.32</td>
<td>523</td>
<td>524</td>
</tr>
<tr>
<td>Arkansas</td>
<td>0.06</td>
<td>569</td>
<td>555</td>
</tr>
<tr>
<td>California</td>
<td>0.49</td>
<td>501</td>
<td>519</td>
</tr>
<tr>
<td>Colorado</td>
<td>0.27</td>
<td>554</td>
<td>553</td>
</tr>
<tr>
<td>Connecticut</td>
<td>0.85</td>
<td>515</td>
<td>515</td>
</tr>
<tr>
<td>District of Colum...</td>
<td>0.77</td>
<td>489</td>
<td>476</td>
</tr>
<tr>
<td>Delaware</td>
<td>0.73</td>
<td>500</td>
<td>499</td>
</tr>
<tr>
<td>Florida</td>
<td>0.67</td>
<td>499</td>
<td>499</td>
</tr>
<tr>
<td>Georgia</td>
<td>0.73</td>
<td>494</td>
<td>493</td>
</tr>
</tbody>
</table>

See “**Build SQL Queries in Query Builder**” for more information about features that also appear in Query Builder for databases.

**Tips:**

- To join data from different sources (for example, a database and Microsoft Excel), use Query Builder to import the database data into a data table; import the Excel data into a data table; and use JMP Query Builder in the Tables menu to query and join the tables.
• When you open a query, data tables in the query open as hidden files that you can open from the JMP Home Window. You can also open the hidden files from the Table panel when you build the query.

• If you try to query a Microsoft Excel file that has more than 255 columns, only 255 columns are imported. Instead, select File > Open to open the Excel file in the Excel Import Wizard, and save the file as a data table.

About Links to Data Tables in JMP Queries

When you query JMP data tables, the resulting data table contains scripts for rerunning the query, updating the data, and editing the query. Data tables in these scripts have *absolute paths*. For example, the following portion of these scripts defines where two JMP sample data tables are stored.

```julia
JMP Tables(
    ["SAT" => "C:\Program Files\SAS\JMPPRO\17\Samples\Data\SAT.jmp",
    "SATByYear" => "C:\Program Files\SAS\JMPPRO\17\Samples\Data\SATByYear.jmp"]
),
```

However, when you save a query as a .jmpquery file, the file contains *relative paths* to the original data tables if it is possible to create them. The following example shows data tables that are stored in the FuelData subfolder that is relative to the .jmpquery file.

```julia
JMP Tables( ["Cars" => "FuelData\Cars.jmp",
    "Trains" => "FuelData\Trains.jmp"] )
```

In the .jmpquery file, if a relative path cannot be created, an absolute path is used with path variable substitutions if possible. When you run the query, you are prompted to select the data table if the table cannot be found. JMP then detects whether other missing data tables in the query are in the selected folder.

You can also use path variables to locate the data tables. For example, you might write a script that selects a data table in the $DOCUMENTS folder. Or you can define a path variable in a JSL script and then run a query from the script. See the *Scripting Guide* for more information about path variables.
Virtually Join Data Tables

The Virtual Join option in JMP links a main data table to one or more auxiliary data tables. This feature enables the main data table to access data from the auxiliary data tables without physically joining the tables. Virtually joining tables saves memory, because the same data are not replicated in every table that references them. And updating linked data is simpler; linked data can be independently updated in the source table without being updated in the referencing table.

The Link ID and Link Reference column properties make the linking possible.

- The Link ID column property marks a column in the auxiliary data table as the ID column. That is, the rows of the data table are uniquely identified by the values of the ID column. The data table that has a Link ID column property is referred to as the referenced data table.
- The Link Reference column property links a column in the main data table to the Link ID column in the referenced data table. The column property specifies the path name of the referenced data table. The column that has a link reference is referred to as the referencing column. The referencing column can look up the data of the auxiliary data tables through the Link ID column.

Figure 6.33 shows an example of virtually joined data tables. Pizza Profiles.jmp is the referenced data table because the ID column contains a Link ID column property. The ID column contains unique values that correspond to data in the referencing data table, Pizza Responses.jmp.
Reshape Your Data
Chapter 6
Virtually Join Data Tables

Figure 6.33 Virtually Joined Data Tables

Note: A column can have a Link Reference column property, but it does not necessarily have to link columns from the referenced data table. The virtual join icon next to the column in the Columns list is gray . This can happen if the referenced data table is not opened or the referencing column is excluded. See “Virtual Join Icons” for more information about the other virtual join icons.

With the link column properties setup, all columns from the referenced data tables become part of your main data table. Therefore, if the main data table has a referencing column, the columns of the referenced table automatically appear in the Select Columns list of the launch window.

Example of Virtually Joining Columns

Suppose that respondents in a pizza experiment chose their favorite crust, topping, and cheese. To see which cheese the respondents preferred, follow these steps:

1. Select Help > Sample Data Folder and open Pizza Profiles.jmp and Pizza Responses.jmp.
2. First, right-click the ID column in Pizza Profiles.jmp and select Link ID.
This column contains unique values that correspond to values in Pizza Responses.jmp. For example, row one in Pizza Profiles.jmp indicates that pizza with thick crust, mozzarella cheese, and pepperoni toppings is nicknamed ThickOni. When all responses in Pizza Responses.jmp are “ThickOni”, the subject chose pizza with these attributes.

3. In Pizza Responses.jmp, select the three columns that begin with “Choice”.

4. Right-click and select **Link Reference** > Pizza Profiles.jmp.

The selected columns are linked to the ID column in Pizza Profiles.jmp and appear in the main data table’s Columns list (Figure 6.33).

**Note:** Look at one of the column’s Link Reference properties again and notice that the Pizza Profiles.jmp data table is selected. See “Link Data Tables with Virtual Join Properties” for information about changing the link.

5. In Pizza Responses.jmp, select **Analyze > Distribution**.

6. Scroll down to select the three Cheese columns in the referenced column groups, click **Y, Columns**, and click **OK**.

**Figure 6.34** Distribution Launch Window

More respondents chose Mozzarella in the Choice column. In Choice1 and Choice2, the proportion of Mozzarella to Jack is nearly even.
Notes:

- See the Movie Rentals.jmp sample data table for another example of virtually joined columns. The data are already joined with Movie Customers.jmp and Movie Inventory.jmp, so you do not need to specify the Link Reference.
- A data table can have only one Link ID column property. The Link ID column cannot have duplicate values.
- A data table can have multiple referencing columns. The columns can reference different or the same data tables.
- A referenced data table can also have a referencing column (a column that references another data table).
- If the Link Reference column property is removed from the column, or the referenced data table is closed, the corresponding referenced columns are removed from the main data table.
- The data types of the linked columns must match.
- The Expression and Row State data types do not support the Link Reference or Link ID column properties.
- When the main data table is saved, the Link Reference column property is saved, but referenced columns are not saved. The data tables are relinked when you open them.
- When a referenced data table is renamed, the corresponding Link Reference column property is automatically updated.
• Referenced columns are not included when you select Copy Table Script from the Table panel red triangle menu.

• Select Row State Synchronization options to synchronize row states in data tables that contain virtually joined columns. See “Example of Virtually Joining Columns and Showing Row States”.

• A column can have both Link ID and Link Reference column properties.

Tips:

• In addition to right-clicking a column to add the Link ID and Link Reference column properties, you can add the properties through the Column Info window. See “Link Data Tables with Virtual Join Properties”.

• You can specify that the linked column name be used in virtually joined columns that are shown in the Columns list. This option lets you specify a shorter column name (for example, Cheese instead of Cheese[Choice]). In the Link Reference column property, select Use Linked Column Name. You can also manually rename the column as usual. The Table preference is called Virtual Join Use Linked Column Name. It is deselected by default.

• To share the data with another user, you might want to merge the data so that the data tables are permanently joined. This option is helpful because you provide one data table, not the main and auxiliary data tables. To merge the joined columns into the table that has a link reference, select Merge Referenced Data from the red triangle menu in the data table’s left pane. The data are replicated from the auxiliary data table to the main data table. When you save the main data table, the actual data are also saved. The Link Reference column property is removed from the referencing column in the main data table. See “Example of Merging Referenced Data in Virtually Joined Data Tables”.

Example of Virtually Joining Columns and Showing Row States

When row states change in one JMP data table that has a virtually joined column, those row states can automatically show up in virtually joined columns in other linked data tables. Suppose that the main and auxiliary data tables have a subject ID column. The row states are changed in the data table that contains a Link ID property on the subject ID column. Then the row states are updated in the data table that contains virtually joined Link Reference columns. You can specify whether the Link Reference columns send (dispatch) row states to the other data tables or receive (accept) row states.

1. Select Help > Sample Data Folder and open Nic Demographics.jmp, Nic Labs.jmp, and Nic Adverse Events.jmp.

2. View Nic Labs.jmp.

Notice that, in the Columns list, the blue Virtual Join icon appears next to Unique Subject Identifier. The blue color indicates that the column has a Link Reference column property and the referenced data table (Nic Demographics.jmp) is open. The Link Reference
column property links the Unique Subject Identifier column in the current data table to the Unique Subject Identifier column in the referenced data table. If the icon is gray, the referenced data table is not open, or the columns could be linked incorrectly.

Nic Adverse Events.jmp is set up the same way.

**Figure 6.36** Link Reference Column Property on Unique Subject Identifier

3. In Nic Labs.jmp, select the Unique Subject Identifier column and select **Cols > Column Info**.

4. Select the **Link Reference** column property.
   - Notice that Accept is selected. This means that when rows in the referenced data table (Nic Demographics.jmp) contain a row state, the row state automatically appears in the current data table.
   - Also notice that the Select, Exclude, and Hide row states are selected. When these row states are selected in Nic Demographics.jmp, the row states appear in Nic Lib.jmp and Nic Adverse Events.jmp.

5. In Nic Demographics.jmp, right-click the first row and select **Hide and Exclude**.
   - The first row contains data for Unique Subject Identifier 101001.

6. View Nic Labs.jmp to see the hidden and excluded rows for Unique Subject Identifier 101001.
Cautions:

- Dispatching row states in multiple tables with multiple columns can be complex and should be done with caution.
- Dispatching row states is best used when no multiple row states are assigned to the same ID value. If a Link Reference column dispatches the color row state, ambiguity quickly develops when there are multiple rows with the same ID value but different color row states. For example, the data table has two rows with an ID value of 001. You color one row red and the other row green, There is no way for JMP to know how to set the row state in the linked data table.

Notes:

- Multiple columns in table A can link to table B. And Table B can itself have multiple columns that link to table C. The row states of all of the rows appear in the data tables that contain linked columns. For example, if row 1 is excluded in table A and row 1 is hidden in table B, the main data table shows that the row as excluded and hidden.
- If a data table is accepting a specific row state, avoid manually applying that row state in the data table. Let the dispatching column control that row state.

Example of Merging Referenced Data in Virtually Joined Data Tables

To share the data from virtually joined JMP data tables with another user, you might want to merge the data so that the data tables are permanently joined. This option is helpful because you provide one data table, not the main and auxiliary data tables.

When you merge referenced data, the data are replicated from the auxiliary data table to the main data table. When you save the main data table, the actual data are also saved.

1. Select Help > Sample Data Folder and open Pizza Profiles.jmp and Pizza Responses.jmp.
2. Right-click the ID column in Pizza Profiles.jmp and select Link ID.
3. Select the Choice1, Choice2, and Choice columns in Pizza Responses.jmp, right-click, and then select Link Reference > Pizza Profiles.jmp.

The selected columns are linked to the ID column in Pizza Profiles.jmp.
4. In Pizza Responses.jmp, select the Choice1 column if it is not already selected.

**Note:** If you do not select the columns, then all columns will be in the merged data.

5. Click the red triangle next to the name of the data table and select **Merge Referenced Data**.
A message confirms that the selected column was merged. Notice that the blue virtual join icon for Choice1 no longer appears in the Column list. The Link Reference column property was removed.

**Figure 6.38** Merging Referenced Data

**Figure 6.39** Merged Data
If you hover over one of the linked columns in the Columns panel, a tooltip indicates which data table it is linked to.

Figure 6.40  Data Table that Contains the Linked Column

Example of a Link ID and a Link Reference on a Single Column

Suppose that employee data is available in multiple JMP data tables and can be linked together by a single column that has both a Link ID and a Link Reference property. To see an example of how the data tables are set up, follow these steps:

1. Select Help > Sample Data Folder and open Employee Master.jmp.

   Note: In the Employee Id column’s Link Reference column property, the Auto Open option is selected to automatically open two other tables, Education History.jmp and Predicted Termination.jmp. They appear in the Home Window’s Window List.

   - Employee Master.jmp has information about each employee.
   - Education History.jmp has the information about the education of each employee.
   - Predicted Termination.jmp has job performance information about each employee.

2. Open Predicted Termination.jmp from the Home Window’s Window List.
   Notice that the Employee Id column has a Link ID column property.

Figure 6.41  Link ID Column Property
3. In Employee Master.jmp, select the Employee Id column and select **Columns > Column Info**.

**Figure 6.42** Link ID and Link Reference Column Properties in Employee Master.jmp

![Link ID and Link Reference Column Properties](image)

Notice that the column has a Link ID column property and a Link Reference to Education History.jmp.

In the data table’s Columns list, the Link Reference icon and Link ID icon appear next to the Employee Id column.

4. Open Education History.jmp from the Home Window’s Window List.
5. Select the Employee Id column and select **Columns > Column Info**.
Figure 6.43  Link ID and Link Reference Column Properties in Education History.jmp

As shown in Figure 6.43, Employee Id has a Link ID column property and a Link Reference to Predicted Termination.jmp.
Figure 6.44  Linked Data Tables

The Employee Id column of Employee Master.jmp references Education History.jmp, which then references Predicted Termination.jmp. All data are available through virtual join from the main data table, Employee Master.jmp.

Notes:

• Auto Open in a column’s Link Reference property specifies whether the linked table is automatically opened when the main data table is opened.
• If referenced columns are unhidden when the data table is saved, those referenced columns are automatically linked and unhidden when the table is opened.
• When you close the data tables, it is a best practice to close the main table first (Employee Master.jmp), because there is a link between that table and all the others. Closing them in a different order might display a prompt indicating that the table that you are closing has other windows open. You might want to cancel and consider saving and closing your tables in a different order.

Update Data Tables

If you have two JMP data tables and would like to update your original table with data from a new table, select **Tables > Update**. The Update command is a special case of Join in place. It is a Join with the Update option checked, and it does not result in a new table.
Before you update a table, make sure that the name of the column containing the values that you want to replace is the same as the name of the column containing the data that you want to replace it with.

To replace values in the active table with those found in another open table

1. Click the original table that you want to update (this is the table whose values you want to replace) to make it the active table.

2. Select Tables > Update.

Figure 6.45 Updating a Table

3. Highlight the new table containing the data that you want to transfer to the original table.

4. (Optional) If you do not want JMP to replace the values in the original table with any missing values found in the new table, select the box next to Ignore missing. The original table retains its original values if they correspond to missing values in the new table.

5. If the two tables have one or more columns whose values uniquely describe each row, JMP uses those columns as the match column values. That is, JMP updates the rows whose match column values coincide. JMP uses these columns to preserve the sorted order of the data. If your tables do not have matching column values, you can incorporate the updated values according to their row order by continuing here. To proceed with tables containing matching column values, see “To update a table using matching columns”.

6. From the Add Columns from Update Table area, select an option. Using these options, you can add columns (that do not exist) from the new table into the original table.
   – Choose All to add all columns from the new table into the original table.
   – Choose Selected to add only columns that you have selected from the new table into the original table.
– Choose **None** if you do not want to add any non-existent columns from the new table into the original table.

7. (Optional) From the Replace Columns in Main Table area, select an option, Using these options, you can replace the values in columns that have the same names.
   – Choose **All** to add all columns with the same names from the new table into the original table.
   – Choose **Selected** to replace only columns with the same names that you have selected from the new table into the original table.
   – Choose **None** if you do not want to add any non-existent columns that have the same names from the new table into the original table.

8. Click **OK**.

**To update a table using matching columns**

1. Follow the first three steps outlined in the previous section, “To replace values in the active table with those found in another open table”.

2. Select **Match columns**.

3. Highlight the two column names (in the respective tables) that you want to match.

4. Click **Match**.

**Figure 6.46** Updating a Table with Matching Columns

5. (Optional) Repeat to match more columns.
6. Click **OK**.

**Note:** Columns that have different names from the columns in the table that you are updating (and that have not been assigned matches) are appended as separate columns. To avoid this problem, select the None option in the Add Columns from Update table area.

---

**Example of Updating a JMP Data Table**

Suppose a researcher has a data table containing height measurements for students. The researcher receives an updated table that contains more recent measurements of the students’ heights. The researcher wants to avoid scrolling through the JMP data tables to find the students whose height has changed, and copying and pasting the new values. Using the **Update** command, the researcher can quickly update the original data table with the new height values.

1. Select **Help > Sample Data Folder** and open **Big Class.jmp** and **New Heights.jmp**.
   The **Big Class.jmp** table contains the original data, and the **New Heights.jmp** table contains the updated data.
2. From the **Big Class.jmp** table, select **Tables > Update**.
3. In the **Update...with data from** box, select **New Heights**.
4. Select **Match columns**.
5. In the **Big Class** and **New Heights** lists, select **name**.
6. Click **Match**.
   This tells JMP to use **name** as the match column value, since it is the column whose values uniquely describe each row.
7. Click **OK**.
Figure 6.47 The Updated Big Class.jmp Table

<table>
<thead>
<tr>
<th>name</th>
<th>age</th>
<th>sex</th>
<th>height</th>
<th>weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>KATIE</td>
<td>12</td>
<td>F</td>
<td>62</td>
<td>95</td>
</tr>
<tr>
<td>LOUISE</td>
<td>12</td>
<td>F</td>
<td>61</td>
<td>123</td>
</tr>
<tr>
<td>JANE</td>
<td>12</td>
<td>F</td>
<td>58</td>
<td>74</td>
</tr>
<tr>
<td>JACKLYN</td>
<td>12</td>
<td>F</td>
<td>68</td>
<td>145</td>
</tr>
<tr>
<td>LILLIE</td>
<td>12</td>
<td>F</td>
<td>52</td>
<td>64</td>
</tr>
<tr>
<td>TIM</td>
<td>12</td>
<td>M</td>
<td>64</td>
<td>84</td>
</tr>
<tr>
<td>JAMES</td>
<td>12</td>
<td>M</td>
<td>63</td>
<td>128</td>
</tr>
<tr>
<td>ROBERT</td>
<td>12</td>
<td>M</td>
<td>70</td>
<td>79</td>
</tr>
<tr>
<td>BARBARA</td>
<td>13</td>
<td>F</td>
<td>62</td>
<td>112</td>
</tr>
<tr>
<td>ALICE</td>
<td>13</td>
<td>F</td>
<td>61</td>
<td>107</td>
</tr>
<tr>
<td>SUSAN</td>
<td>13</td>
<td>F</td>
<td>58</td>
<td>67</td>
</tr>
<tr>
<td>JOHN</td>
<td>13</td>
<td>M</td>
<td>68</td>
<td>98</td>
</tr>
<tr>
<td>JOE</td>
<td>13</td>
<td>M</td>
<td>64</td>
<td>105</td>
</tr>
<tr>
<td>MICHAEL</td>
<td>13</td>
<td>M</td>
<td>60</td>
<td>95</td>
</tr>
</tbody>
</table>

You can see that the height values in the updated table no longer match the values in the original table. The values have been updated to use the newer values from the New Heights.jmp table.

Anonymize Data

The Anonymize Data feature in JMP enables you to create a new data table in which certain unique identifiers have been removed:

- Column headings, character data, and value labels are modified.
- Data in nominal columns are modified.
- Modified data in ordinal columns appear in the same order as in the original data table.
- Data in continuous columns are not modified.
- Column names in column properties are modified.

**Note:** Table scripts and some table variables cannot be anonymized. If your data table contains content that cannot be anonymized, a warning message appears in the log.

“Notes” column properties are removed. Other column properties are modified based on changes in the data table. For example, Value Order properties are renamed. Formulas except for prediction formulas are updated. Some column properties might no longer have the desired effect on the column.
To rename data, do one of the following:

- To rename data in specific columns, select the columns and then select **Tables > Anonymize**.
- To rename data in the entire data table, select **Tables > Anonymize**.

The data appear in a new data table.

DISCLAIMER: The Anonymize Data utility is provided merely to assist Users in removing certain unique identifiers from a data table as described above. The Anonymize Data utility might not remove all sensitive or personally identifiable information from a data table. Users should not rely exclusively on the Anonymize Data utility to remove such information where complete anonymization, pseudo-anonymization, or de-identification of data is desired or required by law or policy (such as where data are or might be disclosed to other parties). SAS does not represent, and specifically disclaims, that use of the Anonymize Data utility will by itself result in the User’s compliance with any national, state, local or international laws, regulations, or policies that pertain to the privacy, de-identification, or anonymization of sensitive or personally identifiable information.
Use the JMP Formula Editor to create a column whose values are computed by a formula and store that formula as part of a column’s information. Formulas can be simple assignments of numeric, character, or row state constants, or they can contain complex evaluations based on conditional clauses. The Formula Editor window operates like a calculator with buttons, displays, and a list of functions.

For more information about the functions that are available in the Formula Editor, see “Reference for JMP Functions in Formulas”.

**Figure 7.1** The Formula Editor
Contents

Overview of Formulas in JMP .............................................................. 397
Create Formulas in JMP ..................................................................... 397
Refer to Data Table Values in Formulas .......................................... 399
Use Local Variables in Formulas ...................................................... 402
  Incorporate Parameters in Formulas .............................................. 403
Insert Constants in Formulas ............................................................. 404
Add Operators to JMP Formulas ...................................................... 406
  Keypad Reference for the Formula Editor ...................................... 406
Use Functions in Formulas ............................................................... 408
  Find Frequently Used Functions in the Formula Editor .................. 410
Copy and Replicate Formulas ........................................................... 412
Order Expressions in Formulas ......................................................... 414
  Build a Formula in Order of Precedence ...................................... 415
JMP Formula Editor Options ............................................................. 416
  Calculate Derivatives of JMP Functions ....................................... 416
  Simplify Complex Formulas .......................................................... 417
Evaluate Formulas .......................................................................... 418
  Ignore Errors in Formulas ............................................................. 418
  View Formulas in JSL .................................................................. 419
Edit Formulas .................................................................................. 419
  Correct Mistakes in Formulas ....................................................... 419
Select Expressions in Formulas ....................................................... 420
Delete Functions from Formulas ...................................................... 420
Cut, Copy, and Paste Formulas ........................................................ 421
Click and Drag Formulas .................................................................. 421
Customize Formulas in the JMP Formula Editor ............................. 422
  Hide and Show Outlines in Formulas ............................................ 422
  Change the Font Size in Formulas ................................................. 422
  Specify the Matrix Size in Formulas ............................................. 422
  Change the Orientation of a Formula ............................................ 423
  Open and Close Arguments in Formulas ..................................... 423
Examples of Building Formulas in the JMP Formula Editor .......... 423
  Use Basic Features in the JMP Formula Editor ......................... 424
  Use Local Variables in Formulas ................................................. 425
  Use the Munger Function in Formulas ....................................... 426
  Use the Match Conditional Function in Formulas ...................... 427
  Use the Delete Expression Button in Formulas ......................... 428
Keyboard Shortcuts for the JMP Formula Editor ............................. 429
Glossary of Terms for the JMP Formula Editor ................................. 430
Overview of Formulas in JMP

Formulas are an integral part of a data table for the following reasons:

- They are stored as part of a column’s information when you save the data table.
- You can examine or change them at any time by opening the Formula Editor.
- Their values can be linked to, or dependent on, the values in other columns. Their values are automatically recomputed whenever you edit the values in the columns to which the formula is linked.
- Their values are locked in the data table so that they cannot be manually edited.

This chapter describes the Formula Editor and shows how to build formulas. For more information about each function, see “Reference for JMP Functions in Formulas”.

Create Formulas in JMP

A formula is an expression stored in a column that performs operations in order to insert values into that column. Formulas can perform mathematical operations, such as addition and multiplication, or they can compare column values or join values by referring to other areas in the same data table. Formulas can consist of any JMP Scripting Language (JSL) command. Once you insert a formula into a column, the column is locked: its values can be edited only by changing or removing the formula.

There are three basic steps to building a formula:

1. Open the Formula Editor by right-clicking the column name to which you want to apply the formula and selecting Formula.

   or

   Double-click the column name to which you want to apply the formula, select Formula from the Column Properties menu, and then click Edit Formula.

In the Formula Editor, the empty formula is selected (highlighted in blue). You can start typing or select a column or function.

- When you type, a small text editor window appears, which enables you to edit the formula. You can click the Maximize editor button if you need more room. Long formulas open in the maximized editor by default.

- When you select a column or function, that item is added to the selected blue box.

- You can also drag a column from the Columns list into the selected box.
Note: An element is selected when there is a blue outline around it. All terms within the smallest nesting box relative to the place that you clicked become selected. The subsequent actions apply to those combined elements.

2. Add expressions, functions, and terms. Then they appear in the highlighted blue box. The following sections in this chapter provide detailed instructions on how to add constants, elements, operators, and functions.

Figure 7.2 Building a Formula

See “Use Basic Features in the JMP Formula Editor”, for an example of how to use the Formula Editor.

Notes:
- In a formula, when you reference a column using value labels, hover over the value label to see the actual data value.
- The Formula Editor recognizes the Excluded state and removes those rows from calculations. Here’s an example using the Col Maximum() function:
  \[
  \text{Col Maximum( :height, :sex, Excluded( Row State() ) )}
  \]
- JMP automatically removes trailing spaces in formulas.
- You can also use the Formula Editor to define a custom format. For example, you might want to convert a number from inches to centimeters using the calculation \[
  \text{Char( :height}
  \]
Using JMP Refer to Data Table Values in Formulas

* 2.54 \text{ cm}$. Realize that the underlying data, which you see when double-clicking a data table cell, would still be the value of :height.

- To move the cursor from one field to another in a formula, select the field and press an arrow key.
- For aggregated functions such as Col Mean, the formula might evaluate faster if you separate the formula into two columns. One column should contain an expression that represents the target for the aggregated function. The second column should contain the aggregated function itself referencing the new target column. Here’s an example of the original formula:

\[
:Y - \text{Col Mean( If( :Status == "nonsmoker", :Y, . ), :Cycle )}
\]

In a new :Y2 column, create this formula:

\[
\text{If( :Status == "nonsmoker",}
\]

\[
:Y,
\]

\[
.
\]

\[
\text{)}
\]

In another column, create this formula:

\[
:Y - \text{Col Mean( :Y2, :Cycle )}
\]

Refer to Data Table Values in Formulas

You can create a formula that refers to values found in other parts of the JMP data table, such as other columns and table variables.

When a formula uses values in other columns, the values in the column with that formula are dependent on the values in those other columns. Whenever a column that the formula refers to changes, the dependent column also changes. If you delete the referenced column, empty terms appear in the column containing the formula.

If you create a formula that refers to values found in table variables, those table variables must already exist in the data table. Table variables are character strings that are available to the entire table. Their names are displayed in the table panel at the left of the data table. See “Use Data Table Variables”.

**Tip:** To create a table variable from a value in the Formula Editor, right-click the value and select Create Table Variable from Value.

The following example shows how to re-create a formula column in the Companies.jmp sample data table.

1. Select Help > Sample Data Folder and open Companies.jmp.
2. Right-click the last empty column and select New Columns.
The Column Info window appears.

3. Type “Profit by Sales” next to Column Name.
   You are re-creating the formula found in the existing %profit/sales column.

4. In the Column Properties list, select Formula.
   The Formula Editor opens. The blue outline around the box in the editing window indicates that the box is selected.

5. With the box selected, select **Profits ($M)** from the Columns list.

**Figure 7.3** Adding the Profits ($M) Column

6. With the box selected, click the Divide button \( \div \).

**Figure 7.4** Adding the Division Symbol

7. With the box selected as shown, select **Sales ($M)** from the Columns list.

**Figure 7.5** Adding the Sales ($M) Column
8. Select the outer box in the formula editing area by clicking it.

**Figure 7.6** Selecting the Formula

![Formula Image](image)

9. Click the Multiply button \( \times \).

**Figure 7.7** Adding the Multiplication Symbol

![Formula Image](image)

10. With the new box selected, type “100” and press Enter.

**Figure 7.8** Multiplying the Formula by 100

![Formula Image](image)

11. Click **OK**.

The column is filled with the calculated numbers.

12. Right-click the last column and select Column Info.

13. In the Column Info window, select **Fixed Dec** from the Format list, type “10” next to Width, and type “2” next to Dec.

The column width and number of decimal places are specified.

14. Click **OK**.

The new formula column matches the \%profit/sales formula column.

**Tips:**

- Pressing Alt (Option on macOS) and clicking a column replaces both empty and non-empty selected fields with that column.

- The right-click menu for the Columns list has two replacement options: **Replace all occurrences of selected subexpression** replaces all occurrences of the selected expression with the currently selected column. **Replace the selected subexpression with columns** replaces the selected expression with multiple columns for functions that support it (for example, Sum or Plus).

- Define your own functions and transform columns by writing a JSL script. See the **Scripting Guide**.
Use Local Variables in Formulas

You can create and use temporary numeric variables in expressions. You can use ordinary local variables or you can use parameters, which are special types of local variables. Local variables exist only for the evaluation of the formula in which they are defined. They appear in formulas as bold italic terms.

Local variables are most often used with Assignment functions, which can assign expressions to local variables that are used in a complex equation. See “Assignment Functions”. This technique can sometimes simplify building an equation and improve the efficiency of its evaluation.

To build a formula that references values found in local variables, follow these steps:

**Step 1: Create the Local Variable**

1. Open the Formula Editor by right-clicking a column name in the data table and selecting **Formula**.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a blue outline around it.)
3. In the middle pane of the Formula Editor, select **Local Variables** from the list.
4. Click **New Local**.
5. Enter a name for the local variable. By default, local variables have the names $t_0$, $t_1$, and so on, and have missing values.
6. Assign a starting value, and click **OK**.
7. (Optional) To copy, edit, or delete a local variable, right-click (Ctrl-click on the macOS) its name and select **Copy**, **Edit**, or **Delete**.

**Step 2: Insert a Local Variable into a Formula**

1. Select a term in the formula editing area by clicking it. (It is selected when there is a blue outline around it.)
2. Click the local variable name in the Local Variables list. It appears in the formula as a bold italic term.

**Notes:**

- Double-clicking or pressing Alt and clicking the local variable replaces the portion of the formula that is selected.
- Another way to create local variables is to use the Make Temporary Variable button on the Formula Editor keypad. The button automatically creates and displays local variables and places a semicolon after it. See “Add Operators to JMP Formulas”.

• You can also create a local variable from an expression. Right-click the expression in the Formula Editor and select **Create Local Variable from Expression**.

• Pressing Alt+Shift and then clicking enables you to edit the selected variable in place instead of in a new window.

See “Use Local Variables in Formulas” for an example of referencing local variables in a formula.

---

### Incorporate Parameters in Formulas

Parameters are special types of local variables that are recognized as model parameters in some JMP platforms, such as Nonlinear fitting. They can be used in formulas just as ordinary local variables can.

*To view examples of parameters*

1. In the sample data folder that was installed when you installed JMP, open the Nonlinear Examples folder and then US Population.jmp.
2. Right-click the column name x-formula and select **Formula**.
3. In the middle pane of the Formula Editor, select **Parameters** from the list.

**Notes:**

• After completing a nonlinear fit or after clicking the Reset button in the nonlinear control panel, the parameter’s value is the most recent value computed by the nonlinear platform.

• Each time the fitting algorithm takes a step, the updated parameter values are shown in the Nonlinear report.

• When you paste a formula with parameters into a column, the parameters are automatically created for that column unless it has existing parameters with the same names.

• Double-clicking or pressing Alt and clicking the parameter replaces the portion of the formula that is selected.

• Pressing Alt+Shift and clicking enables you to edit the selected parameter in place instead of in a new window.

*To build a formula that references values found in parameters*

**Step 1: Create the Parameter**

1. Open the Formula Editor by right-clicking a column name in the data table and selecting **Formula**.
2. Make sure the formula is selected in the formula editing area. (It is selected when there is a blue outline around it.)

3. In the middle pane of the Formula Editor, select **Parameters** from the list.

4. Click **New Parameter**.

5. Enter a name for the parameter. By default, parameters have the names \(b_0\), \(b_1\), and so on, and have missing values.

6. Assign a starting value. It is important to enter this value when using a parameter in a model for the nonlinear platform. After completing a nonlinear fit, the parameter’s value is the most recent value computed by the nonlinear platform.

7. (Optional) To add several parameters (one for each level of a categorical variable, for example) at once, select **Expand into categories, selecting column**. Then select the column for which you want to expand the parameter.

8. Click **OK**.

9. (Optional) To copy, edit, or delete a parameter, right-click (Ctrl-click on the macOS) its name and select **Copy**, **Edit**, or **Delete**.

**Step 2: Insert a Parameter into a Formula**

1. Select a term in the formula editing area by clicking it. (It is selected when there is a blue outline around it.)

2. Click the parameter name in the Parameters box. The parameter appears in the formula as bold type.

**Tip:** Pressing Alt+Shift and clicking enables you to edit the selected parameter.

---

**Insert Constants in Formulas**

Formulas in JMP can be simple assignments of numeric, character, or row state constants, or they can contain complex evaluations based on conditional clauses. Constants include commonly used numeric terms, such as \(e\), \(\pi\), \(-1\), \(0\), \(1\), and \(2\). There are two ways to add a constant value to a formula:

- Enter them manually using the keyboard
- Select them from the list in the middle pane, as shown in Figure 7.9.
To add constants to a formula, follow these steps:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting **Formula**.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a blue outline around it.)
3. Either type in a number or select **Constants** in the middle pane, as shown in Figure 7.9. Then click a value in the list that appears: 0, 1, 2, -1, pi, e. The value appears in the outlined box.
4. Complete the remainder of the formula using the keypad and functions. (See “Refer to Data Table Values in Formulas”, “Add Operators to JMP Formulas”, and “Use Functions in Formulas”.)

**Note:** Double-clicking or pressing Alt and clicking the constant replaces the portion of the formula that is selected.
Add Operators to JMP Formulas

You can add operators to a formula using the keypad, which contains buttons that help build formulas. It includes common operators (also referred to as functions).

To build a formula using keypad operators at the top of the window, follow these steps:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a blue outline around it.) The operator performs its action on the area that is highlighted.
3. Select the column or variable that you want to use in your formula.
4. Click the keypad button(s).

Keypad Reference for the Formula Editor

Table 7.1 describes the keypad buttons.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arithmetic buttons</td>
<td>Work as they normally do on a pocket calculator, providing addition, multiplication, subtraction, and division operators.</td>
</tr>
<tr>
<td>Exponent</td>
<td>Raises a given value to a specified power. It has an exponent of two by default.</td>
</tr>
<tr>
<td>Root</td>
<td>Calculates the specified root of the radicand. It has an implied index of two (a square root), which is not displayed.</td>
</tr>
<tr>
<td>Unary sign function</td>
<td>Inverts the sign of the argument. Apply the unary sign function to variable expressions or use it to enter negative constants.</td>
</tr>
</tbody>
</table>
### Table 7.1 Keypad Buttons in the Formula Editor (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Local variable (Make Temporary Variable)" /></td>
<td>Creates and displays a local variable and assigns it the value of the selected expression. The local variable has the default name $t0$ in an expression and a semicolon after it. See “Use Local Variables in Formulas”, for more information about creating and inserting local variables. See “Use Local Variables in Formulas” for an example.</td>
</tr>
<tr>
<td><img src="image" alt="Insert" /></td>
<td>Inserts a new clause or function argument. First select the existing clause or argument that you want the new element to follow, and then click this button. The new clause appears and is selected. You can also insert a new clause or argument by typing a comma. Pressing ALT and the Insert icon inserts a new field before the selected field.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Deletes an element’s value, or deletes a clause. The Delete button functions the same as the Delete key on the keyboard.</td>
</tr>
<tr>
<td><img src="image" alt="Switch terms" /></td>
<td>Looks at the operator that is central to the selected expression and switches the expressions on either side of that operator.</td>
</tr>
<tr>
<td>![Delete expression (Peel)]</td>
<td>Removes the outermost expression with the first argument. You can repeat this process to delete a formula term by term. See “Use the Delete Expression Button in Formulas”, for an example.</td>
</tr>
<tr>
<td><img src="image" alt="Clear" /></td>
<td>Clear the entire formula.</td>
</tr>
<tr>
<td><img src="image" alt="Help" /></td>
<td>Opens the Scripting Index to the entry for the JSL function in the selected part of the formula. This button is applicable only when the selected box in the visual area of the formula is a known function.</td>
</tr>
<tr>
<td><img src="image" alt="Undo" /></td>
<td>Reverts the last change.</td>
</tr>
<tr>
<td><img src="image" alt="Redo" /></td>
<td>Redoes the last reverted change.</td>
</tr>
</tbody>
</table>
Create Formulas in JMP

Use Functions in Formulas

You can add many types of functions to a formula in JMP. All of these functions are organized in the Functions list. The browser groups collections of functions in lists organized by topic. The list contains functions that are commonly used in formulas. Use the Functions list to specify the type of calculation that you want to perform on the elements in a formula.

To create a formula that contains a function, follow these steps:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a blue outline around it.) The function performs its action on the area that is highlighted.
3. In the Functions list, select a group of functions to view. See Table 7.2.
   The functions that belong to that group are then displayed in the list below the menu. The function groups are briefly described in the following list.
4. Click any function in the Functions list to apply it to the selected item. When you click some items, you reveal a submenu from which you should make a selection.
5. Continue to build the formula by highlighting terms and clicking items in the formula element browser, keypad, or Functions list.

Tips:

- Hover over a function to learn more about the function.
- Pressing Alt and selecting the function replaces the selected function in a formula with the function that you select from the Functions list or the button that you select from the keypad.
- Pressing Alt (Option on macOS) and clicking a column or other element replaces the item even if it is non-empty.
- Most functions give hints about appropriate arguments through gray words inserted in the boxes in the formula editing area. Functions also show a small caret in the argument area if additional arguments can be added.
- To find out what a function does, right-click the function in the Functions list or in the formula and select Show in Scripting Index.
- Define your own functions by writing a JSL script. See the Scripting Guide.
## Table 7.2 Groups of Functions

<table>
<thead>
<tr>
<th>Group</th>
<th>Functions Included</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row</td>
<td>Displays a list of functions that contains miscellaneous functions such as Lag, Dif, Subscript, Row, and NRow. See “Row Functions”.</td>
</tr>
<tr>
<td>Numeric</td>
<td>Displays a list of functions that are terms commonly used in formulas. See “Numeric Functions”.</td>
</tr>
<tr>
<td>Transcendental</td>
<td>Displays a list of functions that are functions such as natural log, common log, exponential, root, factorial, combinatorial, beta, and gamma. See “Transcendental Functions”.</td>
</tr>
<tr>
<td>Trigonometric</td>
<td>Displays a list of functions that are the standard trigonometric functions: sine, cosine, tangent, inverse functions, and hyperbolic functions. See “Trigonometric Functions”.</td>
</tr>
<tr>
<td>Character</td>
<td>Displays a list of functions that operate on character arguments such as trimming, finding the length of a string, converting between numbers and characters. See “Character Functions”.</td>
</tr>
<tr>
<td>Comparison</td>
<td>Displays a list of functions that are the standard logical comparisons such as less than, less than or equal to, not equal to, and so on. See “Comparison Functions”.</td>
</tr>
<tr>
<td>Conditional</td>
<td>Displays a list of functions that are programming-like functions, such as If, Match, and Choose. See “Conditional Functions”.</td>
</tr>
<tr>
<td>Probability</td>
<td>Displays a list of functions that compute probabilities and quantiles for standard statistical distributions, such as normal, Student’s t, Chi-squared, and F-distributions. See “Probability Functions”.</td>
</tr>
<tr>
<td>Discrete Probability</td>
<td>Displays a list of functions that compute discrete probabilities, such as Poisson, Gamma Poisson, and Hyper geometric. See “Discrete Probability Functions”.</td>
</tr>
<tr>
<td>Statistical</td>
<td>Displays a list of functions that calculate standard statistical quantities such as the mean or standard deviation. See “Statistical Functions”.</td>
</tr>
<tr>
<td>Random</td>
<td>Displays a list of functions that generate random numbers based on predefined distributions such as the uniform, normal, Cauchy, and so on. There is also a function to randomize the order of table rows. See “Random Functions”.</td>
</tr>
</tbody>
</table>
### Table 7.2 Groups of Functions (Continued)

<table>
<thead>
<tr>
<th>Group</th>
<th>Functions Included</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date Time</td>
<td>Displays a list of functions that require arguments with the date data type, which is interpreted as the number of seconds since January 1, 1904. Date Time functions return values such as day, week, or month of the year. They can also compute dates and can find data intervals. See “Date Time Functions”.</td>
</tr>
<tr>
<td>Row State</td>
<td>Displays a list of functions that assign or detect row state status of color, marker, label, hidden, excluded, or selected. See “Row State Functions”.</td>
</tr>
<tr>
<td>Assignment</td>
<td>Displays a list of functions that place the value on the right side of the assignment operator into the variable on the left side of the operator. See “Assignment Functions”.</td>
</tr>
<tr>
<td>Parametric Model</td>
<td>Lets you construct a Linear, Interactions, or Full Quadratic model for columns that you choose. After choosing the type of model, a window appears that lets you select the variables from which to construct the model. Press Ctrl and click to select more than one. See “Parametric Model Functions”.</td>
</tr>
<tr>
<td>Finance</td>
<td>Lets you create formulas to calculate principal payments, interest rate, rate of return, and so on. See “Finance Functions”.</td>
</tr>
</tbody>
</table>

### Find Frequently Used Functions in the Formula Editor

You can customize the Functions list to make it easier to find the functions that you typically work with. The functions appear at the top of the list. Show frequently used functions at the top of the list, create your own function categories, delete functions, delete categories, and move functions up and down in the list.
Chapter 7
Create Formulas in JMP

Figure 7.10  Customizing the Functions List

To quickly bookmark a favorite function
1. Right-click the function in the Functions list.
2. Select **Add as favorite**.

To bookmark a favorite and specify the location
1. Select **Customize Functions List** from the red triangle menu above the formula editor area.
2. Select the function in the Available Functions list.
3. Click the right arrow button to place it in the Functions list.
4. Click the up or down button to rearrange the favorite.

To rearrange or delete favorites
1. Select **Customize Functions List** from the red triangle menu above the formula editor area.
2. Select **Favorite Functions** in the Categories list.
3. Select the favorite function that you want to rearrange and click the up or down button.
4. Select the favorite function that you want to delete and click the X button.

To add functions to a category
If a function is in a formula but the function is not in the Functions list, you can add it to your list by adding it to a category.
1. Select the function that you want to add to a category in the Functions list.
2. Right-click the function and select **Add to Category**.
3. Select the category.
4. Click **OK**.

*To rearrange, add, or delete categories*

1. Select **Customize Functions List** from the red triangle menu above the formula editor area.
2. In the Categories list, select a category and rearrange, add, or delete the category.

*To rearrange or delete functions*

1. Select **Customize Functions List** from the red triangle menu above the formula editor area.
2. In the Categories list, select the category that contains the function you want to rearrange or delete.
3. Click the up, down, or X buttons to rearrange or delete the selected function.

**Note:** Deleting a function only deletes it from the Functions list. You can still type the function in a formula.

---

**Copy and Replicate Formulas**

The Standardize Attributes option in the Cols menu provides a way to replicate a column formula while incrementing each column reference in the formula. This option is an alternative to manually creating new column formulas whose columns increment by one in each of the subsequent columns. For example, if column B contains the formula $A \times 2$, then the standardized column C would contain the formula $B \times 2$, and the standardized column D would contain the formula $C \times 2$.

1. Select **Help > Sample Data Folder** and open Semiconductor Capability.jmp.
2. Select **Cols > New Columns**.
3. Type 3 next to **Number of columns to add** and click **OK**.
4. Select the first new column, select **Cols**, and then select **Formula**.
5. Create the formula $NPN1/PNP1$ and click **OK**.
6. Select the three new columns and then select **Cols > Standardize Attributes**.

7. In the Standardize Properties section, select **Formula** from the list.

8. Select **Substitute Column Reference** and leave NPN1 and PNP1 selected.

**Figure 7.12 Standardize Properties Options**

**Note:** In this example, we want to change both NPN1 and PNP1. You can deselect the column that you do not want to change in the subsequent formulas.

9. Click **OK**.

A formula that is relative to the formula in the first new column is copied to the second and third selected columns.
The formulas in the second and third selected columns increment by one column.

- Original formula in the first column: NPN1/PNP1
- Relative formula in the second column: PNP1/PNP2
  In the data table, PNP2 comes after PNP1.
- Relative formula in the third column: PNP2/NPN2
  In the data table, NPN2 comes after PNP2.

Figure 7.13 Resulting Data Table

<table>
<thead>
<tr>
<th>NPN1</th>
<th>PNP1</th>
<th>PNP2</th>
<th>NPN2</th>
<th>X</th>
<th>Y</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1435576</td>
<td>322.516752</td>
<td>469.39029</td>
<td>1.159558473</td>
<td>0.3550831117</td>
<td>0.88731038</td>
<td>4.0479171331</td>
</tr>
<tr>
<td>120.043699</td>
<td>333.12808</td>
<td>437.78113</td>
<td>120.074127</td>
<td>0.3603529704</td>
<td>0.760946694</td>
<td>3.61879212</td>
</tr>
<tr>
<td>14.920651</td>
<td>348.978727</td>
<td>552.128147</td>
<td>117.7531124</td>
<td>0.3293233673</td>
<td>0.6558172554</td>
<td>4.5390151087</td>
</tr>
<tr>
<td>11.756446</td>
<td>268.548804</td>
<td>373.058629</td>
<td>114.092608</td>
<td>0.4161150511</td>
<td>0.7198549341</td>
<td>3.2697879024</td>
</tr>
<tr>
<td>111.545085</td>
<td>295.073166</td>
<td>338.900737</td>
<td>113.778098</td>
<td>0.3780251749</td>
<td>0.870672615</td>
<td>2.9785113754</td>
</tr>
<tr>
<td>115.523596</td>
<td>323.833209</td>
<td>469.992077</td>
<td>115.481049</td>
<td>0.3503518387</td>
<td>0.8590184949</td>
<td>4.0345614413</td>
</tr>
</tbody>
</table>

Note: Some columns in Semiconductor Capability.jmp were deleted to show the new columns X, Y, and Z in Figure 7.13.

See “Example of Standardizing a Formula” for another example.

Order Expressions in Formulas

As you create a formula in JMP, keep in mind that all functions have an order of precedence shown in the following table, where level one is the highest order of precedence. Expressions with a high order of precedence are evaluated before those at lower levels. When an expression has operators of equal precedence, it is evaluated from left to right. You can use parentheses to override other precedence rules when necessary because any expression within parentheses is always evaluated first. Terms have no order of precedence because they cannot be evaluated further. Table 7.3 shows the first six levels of the order of precedence.

Table 7.3 Order of Precedence of Operators in Formulas

<table>
<thead>
<tr>
<th>Level</th>
<th>Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level 1</td>
<td>Parentheses</td>
</tr>
<tr>
<td>Level 2</td>
<td>Functions in the Functions lists, And, Or, Not</td>
</tr>
<tr>
<td>Level 3</td>
<td>*, ÷, Modulo</td>
</tr>
<tr>
<td>Level 4</td>
<td>+, −</td>
</tr>
<tr>
<td>Level 5</td>
<td>Comparisons: &lt;, ≤, ≠, ≥, &gt;, ≤ x ≤, &lt; x ≤, &lt; x &lt;</td>
</tr>
</tbody>
</table>
Build a Formula in Order of Precedence

It is best to build a formula starting with any expression that serves as an argument. This is because functions have a high order of precedence and are always grouped with their corresponding arguments. It is also a good idea to create expressions working from highest to lowest order of precedence when possible. If you need parentheses, be sure to enter the open parenthesis before entering the expression to be enclosed.

For example, given a data table with the columns A, B, and C, use the following steps to compose the expression \( A(B + C) \). Note that this expression is not the same as \( A \times B + C \), which evaluates as \( (A \times B) + C \).

To enter the expression, follow these steps:

1. Click column A in the Columns list.
2. Click the multiplication button \( \times \) in the Formula Editor keypad.
3. Enter an open parenthesis.
4. Click column B in the Columns list.
5. Click the addition button \( + \) in the Formula Editor keypad.
6. Click column C in the Columns list.

Because the order of precedence determines which arguments are affected by each functions, it also affects the grouping of expressions. Select functions in the formula to verify how the order-of-precedence rules have been applied.

Structure Formulas for Efficient Evaluation

Usually, it is not necessary to structure formulas with efficient evaluation in mind. Most formulas evaluate almost instantaneously regardless of their structure. This is because statistical functions and constant expressions are evaluated only once when a column's values are calculated.

However, when you are creating conditional expressions, keep in mind that Match evaluates faster and uses less memory than an equivalent Condition function, If. (Note that Match ignores trailing spaces and If does not.)
For example, using Big Class.jmp, you can predict a child’s height from his age as shown in Figure 7.14. There is a base height of 58.125 inches to which a quantity is added depending on the value of the age variable.

Figure 7.14  The Match Conditional Evaluates Faster Than the If Function

The Match conditional evaluates faster than the If function because the age variable is evaluated only once for each row in the data table. The If condition must evaluate the age variable at each If clause for each row until a clause evaluates as true.

JMP Formula Editor Options

The Formula Editor provides robust options for creating and managing formulas.

- “Calculate Derivatives of JMP Functions”
- “Simplify Complex Formulas”
- “Evaluate Formulas”
- “Ignore Errors in Formulas”
- “View Formulas in JSL”

Calculate Derivatives of JMP Functions

The JMP Formula Editor can find and display the derivative of a function. The derivative is found with respect to the function argument (a single variable name) you highlight. Therefore, in order to differentiate with respect to x, x must be one of the arguments in the expression. The red triangle menu next to the keypad contains the Derivative command.

To calculate a derivative, follow these steps:
1. Enter a function.
2. Highlight a variable.
3. Select Derivative from the menu.
Simplify Complex Formulas

When the Formula Editor contains a complex formula, JMP can simplify it using various algebraic rules. It can find constant expressions, distribute multiplication over addition, combine terms, and more.

To simplify complex formulas, follow these steps:

1. Select a portion or all of the formula.
2. Click the red triangle next to the keypad.
3. Select Simplify from the list as shown in Figure 7.16.

Figure 7.16 Selecting Simplify (Left) Produces a Simplified Formula (Right)
Evaluate Formulas

By default, JMP evaluates each formula that you create. You can turn this evaluation off, or you can use it before you have finished creating a formula.

Suppress Evaluation

Turning off evaluation is a useful formula development mode for building complex formulas. You can turn off evaluation and build sections of a formula, and evaluate only to test it. In particular, you can close the Formula Editor and reopen it at a later time to continue building a formula without JMP evaluating it.

To suppress formula evaluation, click the red triangle next to the keypad and select **Suppress Eval**. When evaluation is suppressed, the formula icon appears dimmed.

Note the following:

- If the icon appears to the right of the red triangle in the Formula Editor, it indicates that formula evaluation is suppressed for that formula.
- If the icon appears beside the column name in the Columns panel, it indicates that the values in the column result from a formula. When formula evaluation is suppressed, this formula icon appears dimmed. See “Icons Representing Column Characteristics and Properties”.
- To turn off formula evaluation for all formulas, click the red triangle next to the data table name and select **Suppress Formula Eval**. To re-evaluate formulas, click the red triangle next to the data table name and select **Rerun Formulas**. You can also click the **Apply** button in the Formula Editor for each column that contains a pending formula.
- When you turn off formula evaluation, edit a formula, and click **Apply**, you are prompted for whether to evaluate the formula. To allow formula evaluation once, click **Evaluate formula this time**.

Ignore Errors in Formulas

Once you construct a formula and click **OK**, JMP checks behind the formula for error and alerts you of any errors that it finds. An error message appears for each error and asks whether you want to ignore further errors.

Sometimes you might want to suppress error messages while a formula is under development. For example, you might want the evaluated values for some rows without seeing an error message for each row that causes errors.

To ignore errors, follow these steps:

1. Create a formula.
2. Click the red triangle next to the keypad and select **Ignore Errors**.

**View Formulas in JSL**

You have the option of entering or changing any part of a formula in *text mode*. Text mode displays the formula in the JMP Scripting Language (JSL). The entire formula (or any of its terms) appears in the Script Editor when you double-click the formula. If the formula is long, it opens in a maximized Script Editor window. Otherwise, you can click the **Maximize editor** button to maximize the window.

Any element of a formula can be displayed in the Script Editor and then edited. After editing formula scripting commands, click outside the formula (or click **OK** below the maximized window) to see its formatted form and to save the change. To enter an If statement in text form, add pairs of arguments for each If/Then clause in the statement, and a single last argument for the else clause if needed. In text form, the If statement in Figure 7.17 looks like this: If(:total! = 0, (:count/:total)*100, 0).

![Figure 7.17 An If Statement in Formula Mode](image)

**Edit Formulas**

Edit formulas in JMP by using the keypad; using arrows to select expressions; cutting, copying, and pasting; deleting functions, and dragging expressions.

- “Correct Mistakes in Formulas”
- “Select Expressions in Formulas”
- “Delete Functions from Formulas”
- “Cut, Copy, and Paste Formulas”
- “Click and Drag Formulas”

**Correct Mistakes in Formulas**

If you make a mistake while entering a formula in the JMP Formula Editor, press Ctrl+Z. This reverses the effect of the last (undo-able) command.
Other commands to help modify formulas include the following:

- Click the delete button ( ) on the Formula Editor keypad to remove the selected expression.
- Use the cut, copy, and paste keyboard shortcut commands or right-click a highlighted part of the formula and select Cut, Copy, or Paste from the menu.
- Drag portions of the formula to rearrange them.

**Select Expressions in Formulas**

Use the keyboard arrow keys to select expressions for editing in the JMP Formula Editor. You can also use the arrow keys to view the formula’s order of precedence when either parentheses or the boxing option are not present. (See “Hide and Show Outlines in Formulas”.)

Clicking an operator (+, −, *, ÷) in an expression selects the operator and its operands. A blue box appears around the items. Once an operator is selected:

- The left and right arrow keys move the selection across other associative operators having equal precedence within the expression.
- The up arrow extends the current selection by adding the operand and operator of higher precedence to the selection.
- The down arrow reduces the current selection by removing an operand and operator from the selection.

**Delete Functions from Formulas**

Deleting a function also deletes its arguments; deleting a required argument or missing term from a function sometimes deletes the function as well. In the JMP Formula Editor, you can peel a function to delete it from its argument.

To peel a function from a single argument, follow these steps:

1. Select the function.
2. Click the peel button in the Formula Editor keypad. Or use the hand tool to drag the argument on top of its function.

**Figure 7.18** Peeling an Argument

3. Complete formula changes.
4. Click **Apply**, and the new values fill the data table column automatically.

5. Once you have created a formula, you can change values in columns that are referenced by your formula. JMP automatically recalculates all affected values in the formula’s column.

### Cut, Copy, and Paste Formulas

You can cut or copy any expression or an entire formula and paste it into another formula in the JMP Formula Editor. Use the cut, copy, and paste shortcut commands or right-click a highlighted part of the formula and select **Cut**, **Copy**, or **Paste** from the menu. The following aspects apply when you cut, copy, and paste a formula:

- When you paste it into another formula display, the formula appears in formatted form.
- The formula is saved on the clipboard as a JSL statement. Thus, if you copy it into other applications, it appears as a JMP Scripting Language (JSL) statement.

**Note:** Press Shift and click the red triangle to reveal a command called **Copy As SAS Formula**.

### Click and Drag Formulas

In the JMP Formula Editor, you can drag any part of a formula that can be selected to any other location that can be selected.

To click and drag in a formula, follow these steps:

1. Place the arrow cursor inside an expression.
2. Click the expression.
3. Drag across the formula. Destination expressions have a dotted outline.

**Figure 7.19** Dragging an Expression

4. Drag the selected expression to the new desired location. The selected expression is moved to the new location, where it replaces the existing expression.
Customize Formulas in the JMP Formula Editor

There are several ways that you can customize formulas in the JMP Formula Editor.

- “Hide and Show Outlines in Formulas”
- “Change the Font Size in Formulas”
- “Specify the Matrix Size in Formulas”
- “Change the Orientation of a Formula”
- “Open and Close Arguments in Formulas”

Hide and Show Outlines in Formulas

By default, JMP outlines specific terms within the formula. This is called boxing. Boxing is useful when you want to select and modify a specific portion of a formula, or need to determine the order of evaluation that takes place.

To turn boxing on or off, follow these steps:

1. Build a formula.
2. Click the red triangle next to the keypad and select Show Boxing. When a check appears on the menu beside Show Boxing, the outline appears in the formula. When it does not, the outline does not appear.

Change the Font Size in Formulas

To incrementally increase or decrease the font used to display the formatted formula, follow these steps:

1. Click the red triangle next to the keypad.
2. Select Larger Font or Smaller Font.
3. Repeat this process to further increase or decrease the font size.

Specify the Matrix Size in Formulas

You can set the maximum width and height of matrices by selecting Max matrix size to show from the red triangle menu. If the width or height is greater than the specified size, the matrix dimensions show instead of the data. You can still see the data by editing the formula in the text editor window.
Change the Orientation of a Formula

By default, JMP determines the size of a formula and displays it in the Formula Editor in the best orientation (horizontally or vertically). However, if you create a long formula, you might want to display it in a different layout.

To change a formula’s orientation, follow these steps:
1. Build a formula.
2. Highlight an argument or formula.
3. Right-click what you have highlighted.
4. Select Orientation.
5. Select from the Orientation options: Best, Horizontal, or Vertical.

Open and Close Arguments in Formulas

When a formula is too large to fit on the screen, you can close formulas and arguments.

To close an argument, follow these steps:
1. Build a formula.
2. Highlight an argument or formula.
3. Right-click what you have highlighted.
4. Select Close or Close Arguments from the menu that appears.

Examples of Building Formulas in the JMP Formula Editor

To learn more about building formulas, see the following examples and tutorials:

- “Use Basic Features in the JMP Formula Editor”
- “Use Local Variables in Formulas”
- “Use the Munger Function in Formulas”
- “Use the Match Conditional Function in Formulas”
- “Use the Delete Expression Button in Formulas”
Use Basic Features in the JMP Formula Editor

The following example uses the Big Class.jmp sample data table to walk you through using the basic features of the Formula Editor. You can find Big Class.jmp in the sample data folder, which was installed when you installed JMP.

Big Class.jmp has a column called weight. Suppose you want a new column that computes standardized weight values.

To create this column using a formula to obtain its values, follow these steps:

1. Select Help > Sample Data Folder and open Big Class.jmp.
2. Select Cols > New Columns.
3. Type the new name, standard weight, in the box beside Column Name.
4. Select Formula from the Column Properties menu.
5. Click the empty formula element in the formula editing area to select it.

   When you create a formula and Show Boxing is checked, the selected portion of the formula is outlined with a thin blue line. See “Hide and Show Outlines in Formulas”. All terms within the smallest nesting box relative to the place that you clicked become selected, and the subsequent action applies to those combined elements.

Next, enter the formula that standardizes the weight values.

1. While the initial missing term is selected, click weight in the Columns list.
2. Click the minus button in the Formula Editor keypad.
   
   A new missing term appears after the minus sign as shown in Figure 7.20.
3. Click weight again.
4. Click the Functions list, and select Statistical.
5. Select Col Mean from the Statistical list.
6. Select the entire expression.

   The blue box should now enclose the whole formula.
7. Click the division button in the keypad.

   The result gives a selected missing denominator for the whole expression.
8. Click weight again from the column selector list.

   It becomes selected in the denominator.
9. Select Col Std Dev from the Statistical list.
10. Close the Formula Editor by clicking **OK**.

11. Close the Column Info window by clicking **OK**.

In the data table, the new **Standard Weight** column fills with values. When a weight value changes, the calculated **Standard Weight** value automatically recalculates.

**Use Local Variables in Formulas**

Suppose you want to compute the slope in a simple linear regression of $y$ on $x$ using the standard formula shown in **Figure 7.21**. One way to do this is to create two local variables, and name them **XY** and **Xsqrd**. (See “**Use Local Variables in Formulas**”.) Then assign them to the numerator and the denominator calculations of the slope formula. Delimit each assignment with a semicolon, as shown in **Figure 7.21**. (Statements in the Formula Editor are actually JSL programming statements. Multiple statements in a formula must be separated by a semicolons.) The slope computation is simplified to **XY** divided by **Xsqrd**.
Create Formulas in JMP
Examples of Building Formulas in the JMP Formula Editor

Chapter 7
Using JMP

Figure 7.21 Local Variables in a Standard Slope Formula

\[
\sum \frac{(x - \bar{x})(y - \bar{y})}{\sum (x - \bar{x})^2}
\]

\[
XY = \sum_{i=1}^{NRow(\)} \left( (X_i - \text{ColMean}(X)) \times (Y_i - \text{ColMean}(Y)) \right);
\]

\[
X_{sqrd} = \sum_{i=1}^{NRow(\)} (X_i - \text{ColMean}(X))^2;
\]

\[
\frac{XY}{X_{sqrd}}
\]

Note: You can also create local variables using the \[ \text{Local} \] button on the on-screen keypad. Clicking this button creates a local variable with a default name in an expression and places a semicolon after it. The default name is \[ t1 \], and additional local variables are named \[ t2, t3, \] and so on. You can change these default names by double-clicking and editing the name. However, you must be careful to rename each instance of the variable to avoid errors.

Use the Munger Function in Formulas

The following examples show uses of the Munger function. In these examples, assume that there is a character column of names with “Veronica Layman” as one of its values. To simplify the examples, the literal name “Veronica Layman” is the search string instead of a column name.

For instructions on how to incorporate Character functions, such as Munger, into a formula, see “Character Functions”.

Insert Characters

This Munger example finds the blank between the first and last name, and inserts the middle initial “J.” The formula Munger("Veronica Layman", 1, " ", " J. ") inserts the middle initial J., and evaluates as Veronica J. Layman.

Double quotation marks are required by the Munger function for literal strings, including strings that consist of a blank or when leading or trailing blanks are part of a string.

Delete Characters

To delete one or more characters from a string, follow these steps:

1. Designate the characters to delete as the Find string in the Munger function.
2. Enter an empty Replace string: two quotation marks with nothing between them.

For example, the function, `Munger("Veronica Layman", 1, "onic", ")` removes the “onic” from Veronica and evaluates as Vera Layman.

**Note:** A Replace field with a null (no value) string enclosed in quotation marks is different from a Replace field with no value. If you delete the Replace string altogether, Munger shows the argument name (“Replace”) in the Formula Editor window and behaves as if that optional argument does not exist. The resulting data type can also change from character to numeric, depending on the value of the Find/Length argument.

Find the Position (Index) of a Value

When the Find/Length field contains characters, Munger behaves like an index function and returns the numeric position of the first instance of the search string if it exists. For example, `Munger("Veronica Layman", 1, ")` searches for a single blank and finds it in position nine. If the search string is not found, Munger returns a zero. This use of Munger produces the same result as the Contains function, as shown in “Character Functions”.

Find a Substring

Munger can extract substrings. For example, to extract only the first name, `Munger("Veronica Layman", 1, 8, ")` starts at position one and reads through position eight. The remaining characters are ignored because the replace argument is not defined. This yields “Veronica” and produces the same result as the Substring, as shown in “Character Functions”.

An alternative way to find a substring is with a start value, any negative find value, and a no replace argument. `Munger("Veronica Layman", 9, ",")` returns “Layman”.

Use the Match Conditional Function in Formulas

This example walks you through using a conditional statement to match arguments.

Suppose that you want a Match conditional for the nominal variable Type from the Hot Dogs.jmp sample data table.

1. In the Formula Editor, select Type from the Columns list.
2. Select **Conditional** from the Functions list.
3. Select **Match**.
4. Select **Add Match Arguments from Data**.
   
   The values are automatically filled in.
Create Formulas in JMP
Examples of Building Formulas in the JMP Formula Editor

**Note:** Rather than complete step 2 through step 4, press Shift, select **Conditional** from the Functions list, and then select **Match**.

**Figure 7.22** Automatically Filling a Match Conditional Statement

If you do not want the values filled in for you, select **Do Not Add** from the Match list instead of **Add Arguments from Data**.

**Use the Delete Expression Button in Formulas**

The following steps illustrate the results of repeatedly clicking the delete expression (or peel) button:

1. Start with a formula.

2. Select a formula element.

3. Click the delete expression button.

4. Click the delete expression again.

5. Click the delete expression again.
6. Click the delete expression again.

7. Click the delete expression again.

8. Click the delete expression again.

9. Click the delete expression again.

---

**Keyboard Shortcuts for the JMP Formula Editor**

Table 7.4 describes the keyboard shortcuts that you can use in the JMP Formula Editor.

**Table 7.4 Keyboard Shortcuts in the Formula Editor**

<table>
<thead>
<tr>
<th>Insert This Item</th>
<th>Using This Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>A missing element (•)</td>
<td>Delete</td>
</tr>
<tr>
<td>Subscript</td>
<td>[</td>
</tr>
<tr>
<td>Exponent</td>
<td>^ (Press Shift and type 6.)</td>
</tr>
<tr>
<td>Set of parentheses ()</td>
<td>(</td>
</tr>
<tr>
<td>Set of quotation marks &quot; &quot;</td>
<td>&quot;</td>
</tr>
<tr>
<td>New argument before the selected field</td>
<td>Alt + ⬆</td>
</tr>
<tr>
<td>* (multiplication symbol)</td>
<td>* on keypad or keyboard</td>
</tr>
<tr>
<td>+</td>
<td>+ on keypad or keyboard</td>
</tr>
<tr>
<td>–</td>
<td>– on keypad or keyboard</td>
</tr>
<tr>
<td>÷</td>
<td>/ on keypad or keyboard</td>
</tr>
</tbody>
</table>
Glossary of Terms for the JMP Formula Editor

The following terms are used in the Formula Editor:

**Element**  The name of a constant, table variable, local variable, or parameter that appears in the element browser list.

**Argument** Any element or an entire expression (including mathematical operands) that is operated on by a function. Arguments are always grouped with functions. To find which expressions serve as a function’s arguments, select that function in the formula.

**Term**  Indivisible parts of an expression, such as constants and variables.

**Expression** Any part of a formula that can be selected as a single unit, including terms, missing terms, and functions grouped with their arguments, as well as the entire formula.

---

Table 7.4  Keyboard Shortcuts in the Formula Editor (Continued)

<table>
<thead>
<tr>
<th>Insert This Item</th>
<th>Using This Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>+/-</td>
<td>Press Shift+- (Minus)</td>
</tr>
<tr>
<td>And</td>
<td>&amp;</td>
</tr>
<tr>
<td>Not</td>
<td>!</td>
</tr>
<tr>
<td>Or</td>
<td></td>
</tr>
<tr>
<td>Power</td>
<td>^</td>
</tr>
<tr>
<td>New argument</td>
<td>,</td>
</tr>
<tr>
<td>x&lt;y</td>
<td>&lt;</td>
</tr>
<tr>
<td>x==y</td>
<td>=</td>
</tr>
<tr>
<td>x&gt;y</td>
<td>&gt;</td>
</tr>
</tbody>
</table>
Clause  A complete segment in a conditional function.

Function  A mathematical or logical operation that performs a specific action on one or more arguments. Functions include most items in the Functions list and all keypad operators. Functions always operate upon selected expressions, and arguments are always grouped with functions. To find which expressions serve as a function’s arguments, select that function in the formula.

The boxed groupings also show how order-of-precedence rules apply and show which arguments are deleted when you delete a function. See “Order Expressions in Formulas”.

Missing term  Any empty place holder for an expression, represented by an empty box.

Missing value  Excluded or null data consisting of the missing value mark (•) for numeric data or null character strings for character data.
This chapter describes how to create a summary data table, which includes summary statistics such as the mean and median, standard deviation, and minimum and maximum values.

**Figure 8.1** Summary Table for Companies.jmp
Contents

Summarize Columns ................................................................. 435
Summary Launch Window ......................................................... 435
Create a Summary Table .......................................................... 435
Add a Statistics Column to an Existing Summary Table ................. 439
Explanation of Summary Statistics ............................................. 440
Example of Creating a Summary Table with Groups ..................... 442
Summarize Your Data

Chapter 8

Summarize Columns

The Tables > Summary command calculates various summary statistics, including the mean and median, standard deviation, minimum and maximum value, and so on.

Summary tables have the following characteristics:

- A single row exists for each level of a grouping variable that you specify. If no grouping variable is specified, a single row exists for the full data table.
- When there are several grouping variables, the table contains rows for each combination of levels of all the grouping variables.
- In addition to one column for each grouping variable, the table contains frequency counts in a column named N Rows with counts for each grouping level.
- The summary table can be linked to its source table. When you select rows in the summary table, the corresponding rows are highlighted in its source table.
- If the source table’s column(s) contain value labels, the value labels are displayed in the new table.
- A summary table is not saved when you close it unless you select File > Save As to give it a name and location.

Summary Launch Window

Statistics   Defines the summary statistics (such as mean, standard deviation, and median) for a numeric column in the source table. See “Add Summary Statistics”.

Group       Summarizes the statistics by group. See “Use One or More Grouping Columns”.

Subgroup    Summarizes the statistics by subgroup. See “Create a Two-Way Table of Summary Statistics by Adding a Subgroup Variable”.

Freq        Identifies a column whose values assign a frequency to each row.

Weight      Identifies a column whose values assign a weight to each row.

Create a Summary Table

To create a summary table, follow these steps:

1. Open a data table.
2. Select Tables > Summary.
3. Highlight the columns that you want to summarize.
Note: For more information about the options in the red triangle menu, see “Column Filter Menu”.

4. Add summary statistics, groups, subgroups, frequency variable, weight variable, and select any options needed:
   - “Add Summary Statistics”
   - “Use One or More Grouping Columns”
   - “Use Quantile Statistics”
   - “Change the Format of the Statistics Column Name”
   - “Link to the Original Data Table”
   - “Prompt to Save When Closing Linked Summary Tables”
   - “Keep the Summary Window Open”
   - “Create a Two-Way Table of Summary Statistics by Adding a Subgroup Variable”

5. Name the summary table by typing a name in the box beside Output table name.

6. Click OK.

Notes:

• When the summary table is linked to the original data table, you cannot edit the data in the summary table, because that would modify and compromise the original data. To edit the data, create a subset of the summary table or save the table, close the table, and reopen it.

• When you select a column that has a Units column property, that value is included in the column header.

Add Summary Statistics

You can add columns that display summary statistics (such as mean, standard deviation, median, and so on) for any numeric column in the source table.

1. In the Summary window, highlight the column that you want to use in calculating the statistics.

2. Click the Statistics button.

3. Select one of the standard univariate descriptive statistics from the Statistics list. The statistics are described in “Explanation of Summary Statistics”.
Use One or More Grouping Columns

If you want the statistics summarized by group, highlight the column(s) that you want to be your grouping variables and click Group to move the variable into the grouping variables list. See “Example of Creating a Summary Table with Groups” for an example. If you add only grouping variables, the summary table shows a count for each group.

To change the order of the grouping variables

To change the order of the grouping variables (ascending or descending order), select a variable in the grouping variable list and click the ascending or descending button ( ). The icon beside the variable changes to indicate the sorting order.

You can also change the order of the grouping variables using the Value Order column property. See “Value Order”.

To include marginal statistics

To add marginal statistics (for the grouping variables) to the output columns, click the box beside Include marginal statistics. In addition to adding marginal statistics for each grouping variable, JMP adds rows at the end of the table that summarize each level of the first grouping variable.

1. Select Help > Sample Data Folder and open Companies.jmp.
2. Select Tables > Summary.
3. Select Profits ($M) and click Statistics.
4. Select Mean.
5. Select Type and Size Co and click Group.
6. Select Include marginal statistics.
7. Click OK. See Figure 8.2 at left.

Figure 8.2 Summary Table with and without Marginal Statistics
Compare the summary table with marginal statistics (at left) to the summary table without marginal statistics (at right). You can see that the marginal statistics are added, and a row showing that there are 32 total Computer and Pharmaceutical companies.

**Use Quantile Statistics**

To add specific quantile statistics, follow these steps:

1. In the box under **For quantile statistics, enter value (%)** type the desired quantile value (%) for the first quantile (for example, 25).
2. Select the applicable column and click **Statistics**.
3. Select **Quantiles**.
4. (Optional) Repeat this process for any additional quantiles.

**Change the Format of the Statistics Column Name**

To change the format of the statistics column name in the summary table, select from one of the formats in the **statistics column name format** menu. Table 8.1 illustrates the available options. Assume that you are creating a summary table of the mean profits for a company. Your original column name is **Profits ($M)**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>stat (column)</td>
<td>Mean (Profits ($M))</td>
</tr>
<tr>
<td>column</td>
<td>Profits ($M)</td>
</tr>
<tr>
<td>stat of column</td>
<td>Mean of Profits ($M)</td>
</tr>
<tr>
<td>column stat</td>
<td>Profits ($M) Mean</td>
</tr>
<tr>
<td>stat</td>
<td>Mean</td>
</tr>
</tbody>
</table>

**Link to the Original Data Table**

You can select whether to link the summary table to the original data table. By default, the **Link to original data table** option is selected. If you want to edit the data in the summary table, deselect the **Link to original data table** option. When the summary table is linked to the original data table, you cannot edit the data in the summary table, because that would modify and compromise the original data. To edit the data, create a subset of the summary table or save the table, close the table, and reopen it.
Within linked tables, if you drag columns from the summary table into the column heading of a new column in the original data table, the values are expanded as if they were matched by grouping columns.

**Prompt to Save When Closing Linked Summary Tables**

To be prompted to save an unsaved linked summary table when you close it, select *Prompt to save when closing summary tables*. When you select this option in the Summary window, it is selected in the Tables preferences. If you do not want to be prompted to save linked summary tables in the future, deselect the preference.

**Keep the Summary Window Open**

If you select the *Keep dialog open* option, the Summary window remains open after you click *Apply*. Notice that once you select this option, the OK button is replaced by a Create button.

**Create a Two-Way Table of Summary Statistics by Adding a Subgroup Variable**

1. Highlight the column(s) that you want to be the nested variable(s). These are your “subgroup variable(s).”
2. Click *Subgroup* to move the variable(s) into the subgroup list.
3. Highlight the column for which you want statistics summarized by subgroup.
4. In the Statistics list, select the specific statistic that you want.
5. Click *OK*.

For more information about the types of statistics, see “Explanation of Summary Statistics”.

**Add a Statistics Column to an Existing Summary Table**

After you have created a summary table, you can add columns of descriptive summary statistics for any numeric column in the source table. To do so, from an existing summary table, click the upper red triangle in the data grid and select *Add Statistics Column*.

**Example of Adding a Statistics Column to an Existing Table**

Suppose that you have already created a summary table, and you want to add more statistics to the existing summary table.

1. Select *Help > Sample Data Folder* and open Companies.jmp.
2. Select *Tables > Summary*.
3. Select Type and Size Co and click *Group*.
4. Click *OK*. 
5. Click the red triangle in the Columns panel, select **Add Statistics Column**.

**Figure 8.3** Creating a Summary Statistics Column from Within a Data Table

A modified version of the Summary window appears.

6. Select the column that you want, click **Statistics**, and select the specific statistic that you want. For this example, select *profit/emp* and click **Statistics**, and then select **Mean**.

7. Click **OK**.

**Figure 8.4** Example of a Summary Table with a Summary Statistics Column

The Mean(profit/emp) column is added to the existing summary table.

### Explanation of Summary Statistics

You can add columns of descriptive summary statistics for any numeric column in the source table by clicking the Statistics button and making a selection from the menu.

The Statistics menu gives these summary statistics for numeric columns:

- **N**  The number of nonmissing values.

- **Mean**  The arithmetic mean of a column’s values. It is the sum of nonmissing values (and if defined, multiplied by the weight variable) divided by the Sum Wgt.
**Std Dev**  The sample standard deviation, computed for the nonmissing values and calculated with the specified weight variable. It is the square root of the sample variance. The formula follows:

\[
s = \sqrt{\frac{1}{N-1} \sum_{i=1}^{N} w_i (y_i - \bar{y}_w)^2}
\]

where \(\bar{y}_w = \text{weighted mean}\)

**Min**  The smallest nonmissing value in a column.

**Max**  The largest nonmissing value in a column.

**Range**  The difference between Max and Min.

**% of Total**  The percent of the total count for each group. Or, if you have so specified, the percent of nonmissing values of the column to the total count for each group.

**N Missing**  The number of missing values.

**N Categories**  The number of distinct categories.

**Sum**  The sum of all values in a column.

**Sum Wgt**  The sum of all weight values in a column. (See “Column Properties in JMP”.) Or, if no column is assigned the weight role, **Sum Wgt** is the total number of nonmissing values.

**Variance**  The sample variance, computed for the nonmissing values. It is the sum of squared deviations from the mean, divided by the number of nonmissing values minus one.

**Std Err**  The standard error of the mean. It is the standard deviation divided by the square root of N. If a column is assigned the role of weight, then the denominator is the square root of the sum of the weights.

**CV (Coefficient of Variation)**  The measure of dispersion, which is the standard deviation divided by the mean multiplied by one hundred.

**Median**  The 50th percentile, which is the value where half the data are below and half are above or equal to the 50th quantile (median).

**Median Absolute Deviation**  The median of the absolute deviation from the data’s median.

**Geometric Mean**  The nth root of the product of the data. For example, geometric means are often used to calculate interest rates. The statistic is also helpful when the data contains a large value in a skewed distribution.
Note: Negative values result in missing numbers, and zero values (with no negative values) result in zero.

**Interquartile Range**  The difference between the third and first quartiles.

**Quantiles**  the value at which the specific percentage of the argument is less than or equal to.
For example, 75% of the data is less than the 75th quantile. The summary window has an edit box for entering the quantile percentage that you want.

**Histogram**  Generates histograms for different groups. Images of the histograms are saved in data table Expression columns.

## Example of Creating a Summary Table with Groups

Suppose a researcher is working with Companies.jmp, which groups companies by Type and Size. Follow along with this next example by opening Companies.jmp from the sample data folder that was installed when you installed JMP.

Suppose that the researcher wants to perform the following tasks:

- Create a table that shows the average profit per employee for small, medium, and big computer and pharmaceutical companies. In other words, create a table that contains a row for each size company and a column for the mean profit per employee of each type of company.
- Create it so the cells hold the mean for the subgroup (defined by the intersection of the row and column).

1. Select **Help > Sample Data Folder** and open Companies.jmp.
2. Select **Tables > Summary**.
3. Select **Size Co** and click **Group**.
   - The researcher selects Size Co as the grouping variable because he wants the values in that column to become rows in the new table.
4. Select **profit/emp** and click **Statistics**.
5. Select **Mean**.
6. Select **Type** and click **Subgroup**.
   - This tells JMP to create a column for the average profit per employee (Mean(profit/emp)) for each level (computer, pharmaceutical) of subgroup variable (type).
Figure 8.5 Summary Statistics for a Subgroup

Note: The summary table is named after the Group column name. If the column name contains characters that are not allowed in file names, a hyphen is substituted for the special character.
Most JMP platforms present the results of your analyses in a report window. The report window consists of graphs and statistical reports that are often linked to the data table. When you select data in the graph or report, the data is highlighted in the data table. Figure 9.1 shows an example of selected data in a report window and in a data table.

This chapter describes how to customize the colors, lines, data points, and other graphical elements in a report window.

Figure 9.1 Example of a JMP Report Window and Data Table
Contents

Navigate JMP Reports ................................................................. 449
Use the Hand Tool ................................................................. 450
Display Options for JMP Reports ............................................. 450
Show and Hide Parts of a JMP Report ........................................ 452
Combine Several JMP Reports ................................................. 453
Rename Report Titles ............................................................... 453
Increase Font Sizes in Reports ................................................. 453
Resize a Report Window ........................................................... 453
Red Triangle Options in JMP Reports ......................................... 454
Local Data Filters in JMP Reports ............................................. 454
Redo Menus in JMP Reports ..................................................... 457
Save Script Menus in JMP Reports ............................................ 458
The Data Filter ........................................................................... 461
Types of Data Filter Columns ................................................... 462
Filtering Modes ........................................................................ 462
The Data Filter Panel ............................................................... 463
Red Triangle Options for the Data Filter ..................................... 466
Animation in Data Filters .......................................................... 470
Red Triangle Options for Variables in Data Filters ..................... 473
Reformat Tables in JMP Reports ................................................. 476
Change Display Box Properties in a JMP Report ....................... 477
Change a Table in a JMP Report Into a Matrix ......................... 478
Use Conditional Formatting in JMP Reports ............................... 478
Select Points in JMP Graphs ...................................................... 484
Select Rows in JMP Graphs ...................................................... 485
Select a Rectangular Area of Points in a JMP Graph .................. 485
Select an Irregularly Shaped Area of Points in a JMP Graph ........ 486
Use Markers in JMP Graphs ...................................................... 487
Change the Shape of Markers .................................................... 487
Change the Color of Markers .................................................... 488
Change the Size of Markers ...................................................... 488
Work with Crowded Markers .................................................... 488
Add Outlines Around Markers .................................................. 489
Change the Selection Mode of Markers ...................................... 490
Specify the Transparency of Markers ........................................ 491
Exclude and Hide Markers ........................................................ 491
Use Images as Markers ............................................................ 492
Change the Shape or Color of Markers Based On Values ............. 493
Change the Appearance of JMP Graphs ..................................... 495
Chapter 9
Using JMP

Resizing Graphs ......................................................... 495
Zoom In on Graphs .................................................... 497
Change Line Widths in Graphs ................................. 497
Change the Background Color in Graphs ................. 497
Change the Color of Histogram Bars ...................... 498
Display Coordinates and Temporary Reference Lines in Graphs ................................. 498
Scroll and Scale Axes in Graphs ............................. 498
Customize Axes and Axis Labels in Graphs ............... 499
Change the Order of Values in Reports .................... 510
Change the Pattern and Format of Selected Objects in Graphs ....................................... 511
Add a Graph to a Data Table .................................... 511
Customize Markers, Lines, Text, and More in Graphs . 512
Add Images to a JMP Graph or Report .................... 518
Paste a Background Image into a JMP Graph .......... 518
Paste an Image at the End of a JMP Report ............... 519
Drag and Drop an Image into a JMP Graph .......... 519
Add Geographical Images and Boundaries to JMP Graphs .............................................. 521
Extract Data from an Image ...................................... 522
Add Annotations and Shapes to JMP Reports and Graphs .............................................. 523
Add Annotations to JMP Reports or Graphs ............... 523
Add Shapes to JMP Reports ..................................... 524
Customize Hover Labels in JMP Graphs ................. 527
Add Graphs or Images to Hover Labels ..................... 528
Add Text to Hover Labels in JMP Graphs ................ 543
Update Names and Values in Hover Labels .............. 546
Edit Hover Labels in JMP Graphs ............................ 556
Add Images from JMP Data Tables to Hover Labels .. 561
Pin Hover Labels in JMP Graphs ............................. 562
Right-Click Options for Hover Labels ..................... 563
Customize Common Orderings ................................. 564
Load Common Orderings from a Data Table ............... 564
Edit Common Orderings .......................................... 565
Edit Items ................................................................ 565
Save Platform Preferences ...................................... 565
Semantic Formatting .................................................. 566
Format a Row in a Report Table .............................. 566
Format a Column in a Report Table ....................... 568
Navigate JMP Reports

JMP reports appear in standard windows with scroll bars and options to resize. They also have other special buttons and menus like those illustrated in Figure 9.2 and those discussed in the following sections.

Figure 9.2 Basics of the Report Window

Table 9.1 Report Window Actions

<table>
<thead>
<tr>
<th>Number</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Click the disclosure icons to hide or show sections of the report.</td>
</tr>
<tr>
<td>2</td>
<td>Click the red triangle to access report options.</td>
</tr>
<tr>
<td>3</td>
<td>Right-click in the table to access formatting options.</td>
</tr>
<tr>
<td>4</td>
<td>Click and drag on the borders to resize graphs.</td>
</tr>
<tr>
<td>5</td>
<td>Right-click anywhere in the graph to access formatting options.</td>
</tr>
<tr>
<td>6</td>
<td>Right-click within the axis to access formatting options.</td>
</tr>
<tr>
<td>7</td>
<td>The cursor turns into a hand when you position it over an axis. Click and drag the cursor to scroll along the axis or to rescale the axis. See “Scroll and Scale Axes in Graphs”.</td>
</tr>
</tbody>
</table>
**Tip:** Consider setting the *Autosave timeout* value in the General preferences to automatically save open reports at the specified number of minutes. This autosave value also applies to data tables, journals, scripts, projects, and reports.

**Use the Hand Tool**

Select the hand tool using the Tools > Grabber option. There are many functions that you can use with the hand tool (also known as the grabber tool) in a report. Here are some examples of how the hand behaves in graphs and plots:

- On histograms, for continuous variables, use the hand tool to change the number of bars or to shift the boundaries of the bars.
- In all report tables, use the hand tool to click and drag columns for rearranging.
- Use the hand tool to change the displayed range of axis values. See “Scroll and Scale Axes in Graphs”.

**Display Options for JMP Reports**

Right-click a disclosure icon to see options for rearranging reports and outline levels.

- **Close** Closes (hides) that section of the report. This can also be accomplished by clicking the disclosure icon.
- **Horizontal** If available, the option switches the outline of the report between a vertical and horizontal layout.
- **Open All Below** Opens all outline levels beneath the level where this command is selected, including that level.
- **Close All Below** Closes all outline levels beneath the level where this command is selected, including that level.
- **Open All Like This** Opens all of the same type of reports as the one that is present in the analysis window. If you analyze several variables at a time, you often want to open many of the same type of report tables all at once. You might also want to open all of the same type of report tables at once when you select multiple options on a single analysis.
- **Close All Like This** Closes all of the same type of reports as the one that is present in the analysis window.
- **Close Where No Outlines** Closes all parts of the report that do not have sublevels. This command is usually used at the top level of the report outline. It is a quick way to see a nesting structure overview of a report.
Outline Close Orientation  Specifies the orientation of the outline box when the disclosure icon is clicked closed. Available options are Auto, Horizontal, or Vertical. Default orientation is Auto.

Append Item  Displays a submenu, which lists ways that you can add structural items to the report. Items include text, outline title bars, references to other JMP files and windows, a list of all open JMP files, URLs, and scripts.

Add Text Item  Opens a window that enables you to add up to six text items. You can select whether the text items appear with a bullet or initially appear hidden. Note: You must click exactly on a hidden text box for the text item to become visible.

Add Outline Item  Open a window that enables you to add a titled outline box. Note: The appended outline box contains a red triangle menu listing the append menu items.

Add Window Reference  Opens a window that enables you to select an open JMP window for adding as a link to the selected outline box.

Add File Reference  Displays the Open Data File window that enables you to select a file for adding as a link to the selected outline box.

Add Directory of Files  Displays the Choose directory window that enables you to select a directory for adding as a link to the selected outline box. Note: Links to each file in the selected directory are appended to the outline box.

Add All Open Files  For each file open in JMP, a new outline box is added. It contains a link to the file.

Add URL Reference  Opens the Create Link to URL window that enables you to add a Link Name and URL. The URL reference link is added to the selected outline box.

Add Script Button  Opens the Add Script Button window that enables you to add a named link to the selected outline box. Clicking the added link runs the specified script.

Size to Fit  Resizes the outline to fit the width of the inside graph or report.

Show Properties  Enables you to change the formatting of display boxes in the report. Properties include graph axis elements such as tick lines,

Tip: You can change some properties directly in the report by selecting one or more display boxes with the Selection tool and hovering over the display box until a popup property editor appears.

Edit  Displays a submenu that contains the following options, which affect all reports at the outline level where they are used:

Select  Highlights all reports for that outline level.
Deselect  Deselects all selected reports for that outline level.

Journal  Duplicates the report in a separate window titled Journal so that you can edit it or append other reports to it. See “Create Journals”.

Copy Picture  Copies the report to the clipboard. You can then open another application and paste it.

Page Break  Inserts a page break for printing purposes.

Show Tree Structure  Opens a window that shows the display boxes that make up the report. This is mainly used by JSL programmers who are manipulating or reading parts of the report. See the Scripting Guide.

Restore Window Size  (Appears only if the window size has been modified from its original size.) Returns the selected window to its original size.

An alternative way to access these options is to press Alt and right-click the disclosure icon △. This displays a window, as shown in Figure 9.3, with check boxes for commands and options so that you can select multiple actions at the same time. You can also do the same for the menu under a red triangle menu.

Figure 9.3  Outline Box Menu Items Window

Show and Hide Parts of a JMP Report

JMP reports are organized in a hierarchical outline. Each level of the outline has a triangle-shaped disclosure icon △ that you can click to open and close report sections.
You can also change which columns appear in a report. Right-click the report and select the column from the Columns list. To select more than one column at once, press Alt before right-clicking.

**Combine Several JMP Reports**

Suppose that you perform multiple analyses and want to show all of the results (and the data table) in one window. You can select and combine the reports and the data table in several ways. See “Example of Combining Windows to Create a Dashboard”.

**Rename Report Titles**

To rename a title in a JMP report, double-click any of the following titles:

- a title next to a red triangle menu
- a title next to a disclosure icon
- a column title

**Increase Font Sizes in Reports**

On Windows, change the font size that JMP uses in reports and data tables by selecting Window > Font Sizes. Then choose from one of the submenu items:

- **Increase Font Size**  Increases the font size. Select again to increase the font size again.
- **Decrease Font Size**  Decreases the font size. Select again to decrease the font size again.

On macOS, select View > Make Text Bigger or View > Make Text Smaller.

**Resize a Report Window**

In JMP, report windows are automatically sized to fit the contents of the window. On Windows, you can automatically resize a window after manually resizing it. Press Ctrl and click the lower right corner of the window.
Red Triangle Options in JMP Reports

Click the red triangle menu in a report to access a list of options that apply for that particular report. In addition to clicking the red triangle menu, you can also:

- Select multiple actions at the same time. Press Alt and click the red triangle menu. A panel of all commands and options appears with check boxes.
- Apply a command to all similar reports in the report window. Press Ctrl and click the red triangle menu. For example, in a One-way analysis, if you press Ctrl, click the icon, and select Means/Anova/Pooled t Test, an analysis of variance is performed for all One-way analyses in the active report window.

The red triangle options applicable to each platform in the Analyze and Graph menus are described in the following JMP documentation:

- Basic Analysis
- Consumer Research
- Essential Graphing
- Fitting Linear Models
- Multivariate Methods
- Profilers
- Quality and Process Methods
- Reliability and Survival Methods
- Predictive and Specialized Modeling

Local Data Filters in JMP Reports

Local Data Filters limit the scope of the filter to the output of the platform that you are in. For example, suppose that you have data on the profits of 30 different computer and pharmaceutical companies. You want to examine profits by company type. You can run a distribution and then use the Local Data Filter to narrow the results in the Distribution platform to the type of company.

1. Select Help > Sample Data Folder and open Companies.jmp.
2. Select Analyze > Distribution.
3. Select Profits ($M) and click Y, Columns.
4. Click OK.
5. Click the Distributions red triangle and select Local Data Filter.
6. Click Type and click Add.
7. In the Type box, click **Pharmaceutical** to see only their profits and then click **Computer** to see only their profits.

**Figure 9.4** Local Data Filter Showing Pharmaceutical Profits

---

**Note:** The red triangle menu next to a variable contains options such as inverting the selection and displaying the values in a list of check boxes. See “Red Triangle Options for Variables in Data Filters” for more information.

**Local Filtering**

When you use a Local Data Filter, it only filters in the platform, not in the data table (as the Data Filter does). For example, if you exclude rows in a Local Data Filter, these rows are not excluded in the data table. And, if you have row states in your data table, they are not impacted by the Local Data Filter.
Saving a Filter

You can script and therefore save a Local Data Filter, so that you can access your filter settings again quickly. To save a filter, click the red triangle next to Local Data Filter and select one of the Save Script options.

Counting Excluded Rows

The counts for each level of a variable (including excluded rows) are shown in the Local Data Filter by default. To omit the excluded rows from the count, click the Local Data Filter red triangle and deselect Count Excluded Rows.

Figure 9.5 shows the difference between counting and omitting excluded rows. When the excluded rows are counted, the Local Data Filter shows 20 rows that contain the value “Computer”. Also, there are nine “big” values. When the excluded rows are omitted, only 16 rows contain “Computer”.

Figure 9.5 Counting (Left) and Omitting (Right) Excluded Rows

Note: The counts are not shown when Display Options is set to Blocks Display (Figure 9.4).
For more information about advanced scripting with Local Data Filters, see the *Scripting Guide*.

**Using By-Groups and Subset Reports**

If your analysis uses by-groups or combines together reports using linked subsets of the same table, a local data filter on the parent table can be shared between all the different by-groups and subset reports.

**Using Local Data Filters in Dashboards and Applications**

You can incorporate Local Data Filters into dashboards or applications:

- For an example using dashboards, see “Example of Creating a JMP Query Dashboard and Add-In”.
- For an example using applications, see the *Scripting Guide*.

**Zoom In on Time Series Data**

After you filter time series data, you can zoom in closer on the Local Data Filter histogram to see smaller time increments. Suppose that one year of data are selected on the histogram. To view smaller increments of time within that year, select **Zoom to Selection** from the red triangle menu next to the variable. Select **Reset Zoom** from the Local Data Filter red triangle menu to reset the histogram.

**Redo Menus in JMP Reports**

After performing an analysis, you might want to run the analysis again using different options or variables. You might also want to perform the analysis again if data in the data table have changed. The Redo red triangle menus contain the following options:

- **Column Switcher**  Lets you interactively exchange one column for another on a graph. See “Column Switcher”.
- **Redo Analysis**  Duplicates the analysis based on the previous launch window settings. The analysis appears in a new report window. This option is helpful if the data have changed.
- **Relaunch Analysis**  Opens the launch window and recalls the settings used to create the report.
- **Automatic Recalc**  Automatically updates analyses and graphics when data table values change. See “Automatic Recalc”.
Save Script Menus in JMP Reports

After completing an analysis and receiving a report, you might want to save the process that you used to create the report as a JSL script. You do this by selecting an option from the Script red triangle menu. Most of the Save Script options are the same throughout JMP. A few platforms add extra options that are described in the specific platform chapters. The following Save Script menu options are common to all platforms.

**To Clipboard**  Saves the script to your computer’s clipboard. You can then copy the script to a script or another document.

**To Data Table**  Saves the script to the data table that was used to produce the report. This enables you to run the script again from the data table to re-create the results. Select this option to save a script to the data table.

**To Journal**  Saves a link in a journal window that runs the script for the analysis. If a journal window is already open, the script is added to that journal window. The script contains the path to the data table. Note that if the data table cannot be found, the script does not run.

**To Script Window**  Opens a script editor window and adds the script to it. If a script window is already open, the script is added to the bottom of that open window.

**To Report**  Adds the script to the top of the report window.

**Script All By-Groups**

If you specified a By variable in the launch window, the Save By-Group Script menu enables you to save a script for all levels of the By variable to the data table or script window.

In the Save Script menu, **To Data Table (All Objects)** and **To Script Window (All Objects)** save a script for all levels of the By variable.

**Automatic Recalc**

The Automatic Recalc feature immediately reflects changes that you make to the data table in the corresponding report window. You can make any of the following data table changes:

- exclude or unexclude data table rows
- delete or add data table rows

This powerful feature immediately reflects these changes to the corresponding analyses, statistics, and graphs that are located in a report window.

To turn on Automatic Recalc for a report window, click the platform red triangle and select **Redo > Automatic Recalc**. To turn it off, deselect the same option. You can also turn on Automatic Recalc using JSL.
Platforms that support Automatic Recalc include a preference in the Platforms preferences.

**Note:** For some platforms, the Automatic Recalc feature is not appropriate and therefore is not supported. These platforms include the following: DOE, Profilers, Choice, Partition, Nonlinear, Neural, Neural Net, Partial Least Squares, Fit Model (REML, GLM, Log Variance), Gaussian Process, Item Analysis, Cox Proportional Hazard, Response Screening, and Control Charts (except Run Chart).

### Column Switcher

Within a report, use the Column Switcher to quickly analyze different variables without having to re-create your analysis. To activate the Column Switcher, from a report window, click the red triangle and select **Redo > Column Switcher**.

If you have multiple columns, use the buttons to animate the column switching or step through each column manually. Move the slider control to change the speed of the animation.

**Note:** You cannot copy or move the column switcher within a report. Also, a column switcher cannot be saved to a JMP journal.

### Example of the Column Switcher

You have data about nutrition information for candy bars. You want to examine different factors, to see which factors best predict calorie levels.

1. Select **Help > Sample Data Folder** and open Candy Bars.jmp.
2. Select **Graph > Graph Builder**.
3. Click Total fat g and drag to the X zone.
4. Click Calories and drag to the Y zone.
5. Click Cholesterol g and drag to the Wrap zone.
6. Click the Graph Builder red triangle and select **Show Control Panel**.
7. Click the Graph Builder red triangle and select **Redo > Column Switcher**.
8. Select Cholesterol g.  
   This chooses the initial column to switch.
9. Select Saturated fat g, Cholesterol g, Sodium mg, Carbohydrate g, Dietary fiber g, and Sugars g.  
   This chooses the replacement columns.
10. Click **OK**.
11. Click the Play button to cycle between the different factors. Use the slider to control the speed of the animation. Alternatively, you can step through each factor individually. Click the Looping button to specify the behavior of the animation when it reaches the last column in the Columns list.

You can see that the relationship between calories and fat is relatively strong for each level of carbohydrate. Therefore, Carbohydrate g appears to be the best predictor of calorie levels.

Notes:

- To keep axis settings constant when switching columns, select Retain Axis Settings from the Column Switcher red triangle menu. This is useful when you have customized an axis, for example, by adding a reference line.
- If a report has multiple column switchers, you can adjust the layout of the column switchers using the Layout options in the Column Switcher red triangle menu.
- To add new columns, do one of these options:
  - In the Column Switcher, click the plus button, choose columns, and click OK.
  - In Graph Builder, drag columns from the Columns list into the Column Switcher list.
  - From a data table, drag columns from the Columns panel into the Column Switcher list.
- To remove columns, click the minus button, choose the columns to remove, and click OK. Or, you can select the column and press the Delete key.
- To revert changes, select Reset from the Columns red triangle menu.
- The Record and Save buttons in the Column Switcher record the animation and then save it as an animated GIF. This feature is available only on Windows.
The Data Filter

The Data Filter in JMP provides a variety of ways to identify subsets of data. You can interactively select complex subsets of data, hide these subsets in plots, or exclude them from analyses.

1. Select **Rows > Data Filter**.

**Tip:** In addition to the main Data Filter, you can also launch a local Data Filter within a platform report. Click the Local Data Filter icon from the Report toolbar, or select **Local Data Filter** from the red triangle menu in a report. See “Local Data Filters in JMP Reports” for more information.

2. Select the columns that you want to use as filters, and then click **Add**.

**Notes:**

- To restore your current row states when the Data Filter window is closed, select the **Save and restore current row states** option.
- If you have a long list of columns, you can sort, show, hide, or search for columns in the list. Use the options in the Add Filter Columns red triangle menu.
- By default, the Data Filter window is attached to the data table. You can detach it temporarily or permanently:
  - Detach it temporarily by deselecting the **Use Floating Window** option from the Data Filter red triangle menu.
  - Detach it permanently by selecting **File > Preferences > Data Filter** and deselecting **Use Floating Window**.
Types of Data Filter Columns

In the JMP Data Filter, there are four types of filter columns:

**Continuous columns**  Filters numeric columns whose modeling type is set to continuous. A continuous filter column is represented by a histogram that spans the data range. You can adjust vertical lines on the histogram that represent the minimum and maximum filtered values. For options, see “Options for All Types of Variables” and “Options for Continuous Variables”.

**Categorical columns**  Filters nominal and ordinal columns. For each categorical column, the Data Filter generates a set of distinct categories. These categories can be displayed in different forms. For options, see “Options for All Types of Variables” and “Options for Nominal or Ordinal Variables”.

*Note:* For categorical columns with value labels, if you want to include responses that are not present in the data, select the Include Responses Not in Data option from File > Preferences > Platforms > Categorical.

**Multiple Response columns**  Filters character columns that have the Multiple Response column property or Multiple Response modeling type assigned. Each data cell of the column generally consists of multiple categories, separated by some common separator, like a comma. Since each data cell can contain more than one category, multiple response columns have a richer set of filtering options. For options, see “Options for All Types of Variables” and “Options for Variables with the Multiple Response Modeling Type or Column Property”.

**Unstructured Text**  Filters text columns whose modeling type is set to Unstructured Text. Type words or phrases into the filter text edit box to add them to the filter text list. You can then filter the rows based on these words and phrases. For options, see “Options for All Types of Variables” and “Options for Unstructured Text”.

Filtering Modes

In the JMP Data Filter, there are three modes of filtering: Select, Show, and Include. You can set and clear these modes using the corresponding check boxes.

**Select**  (Not available for the Local Data Filter.) Shows the selected rows in the data table in a highlighted state.

You can turn off the automatic selection of this option using the Data Filter Select Check preference. See also “Changing the Row State in the Data Table After Making Data Filter Selections”.
Show  Shows the unselected rows with the Hide icon 📜.

You can turn on the automatic selection of this option using the Data Filter Show Check preference. For more information about row states, see the “Store Information in Row State Columns”.

Include  Shows the unselected rows with the Exclude icon 🗑.

You can turn on the automatic selection of this option using the Data Filter Include Check preference. For more information about row states, see the “Store Information in Row State Columns”.

There are two additional options when filtering: Auto clear and Conditional. These options are available from the red triangle menu for the Data Filter. See “Red Triangle Options for the Data Filter”.

The Data Filter Panel

Once you have added columns in the initial window, the Data Filter panel appears.

Figure 9.8  Data Filter Panel

The main controls in the Data Filter panel include the following:

Clear  Clears all selections that you have made on variables in the Data Filter panel.

Favorites  Saves your current data filter criteria as a favorite. Once you have created a favorite, selecting it resets the current conditions to the criteria in the favorite. You can also
remove the favorite. To retain favorites once the current session ends, save the data filter script by selecting one of the Save Script options from the Data Filter red triangle menu.

Select, Show, and Include  See “Filtering Modes”.

Inverse  Inverts the current selection state of the rows in the data table.

**Note:** Only the rows in the data table are inverted, not the selection in the Data Filter. To invert the selection in the Data Filter, from the column’s red triangle menu, select **Invert Selection**.

AND  The AND button opens the **Add to Selected Group** list. The *and* operator restricts the selection. You can add variables to the filter process at any time.

OR  The OR button opens the **Add new OR Group list**. The *or* operator extends the selection. You can add variables to the filter process at any time.

**Changing the Row State in the Data Table After Making Data Filter Selections**

If you have made selections in the Data Filter and subsequently alter row states in the data table, or select points in a graph or plot, the selections in the Data Filter might not match the selections in the data table. The Data Filter contains a warning message that says: “Your selection was changed in another window”. The **Reset Selection** button appears. Clicking the **Reset Selection** button changes the data table selections back to reflect the selections in the Data Filter.

**Example of Changing Selections**

1. Select **Help > Sample Data Folder** and open Big Class.jmp.
2. Select **Analyze > Distribution**.
3. Select age and sex and click **Y, Columns**.
4. Click **OK**.
5. Select **Rows > Data Filter.**
6. Select sex and click **Add**.
7. In the Data Filter control panel, select all of the males by clicking on the M block.
You can see that all of the rows containing males are highlighted in the data table and in the histograms. Now you decide that you want to see only the students who are age 12.

8. In the age histogram, select the bar representing age 12.

Now the selection does not match the Data Filter selection. A warning message and a **Reset selection** button appear in the Data Filter window.

**Figure 9.10** Data Filter Warning Message and Reset Button
Red Triangle Options for the Data Filter

The Data Filter red triangle menu contains the following options:

**Auto clear**  If you have more than one nominal or ordinal column selected in the Data Filter, this option clears any other selections before making a new selection. For example, using Big Class.jmp, suppose that you have the columns sex (nominal) and age (ordinal) in your Data Filter. If you have males (M) selected for sex, and you click an age group, say age 12, your selection of males will be automatically cleared. This means that selecting age 12 is not conditional on selecting males. Conversely, if you turn off Auto clear, you can then select both males and age 12 at the same time. Auto clear is off by default.

**Conditional**  Limits the categories displayed for the selected filter column. See “Conditional Data Filters”.

**Grouped by AND**  Enables you to control the AND and OR behavior of multiple groups of column filters. See “Grouped by AND in Data Filters”.

**Show Histograms and Bars**  Shows or hides the histogram and bars in the data filter.

**Show Counts**  Shows or hides the counts in the categorical column data filters.

**Use Floating Window**  Keeps the Data Filter window on top of its associated data table. If you do not want the Data Filter window to remain on top, deselect this option.

**Start Over**  Closes the current Data Filter session and shows the original Data Filter window.

**Show Controls**  Shows or hides all buttons and checkboxes in the Data Filter window except Clear and Inverse.

**Show Modes**  Shows or hides the filtering mode checkboxes in the Data Filter window.

**Animation**  Sequentially highlights the values of a single variable in the data table. See “Animation in Data Filters”.

**Subset**  Creates a new data table that contains only the following:

- The rows identified by the Data Filter.
- The columns selected in the active data table. If no columns are selected, then all columns are included.

This option is similar to the Tables > Subset command, only without subsetting options.

**Save Where Clause**  Builds a Where clause based on the value selections that you make.

**Tip:** Selecting To Formula Column creates an indicator column. You can use the indicator column in many platforms as a By role, Group or ID in Graph Builder, and so on.
Save Script  Provides options for saving scripts. See “Save Script Menus in JMP Reports”.

Copy Local Data Filter  (Available only for the Local Data Filter.) Copies the script for the local data filter to the clipboard. You can then apply this local data filter to a new report by using the Paste Local Data Filter option in the report’s red triangle menu.

Remove Local Data Filter  (Available only for the Local Data Filter.) Removes the Local Data Filter from the report.

Conditional Data Filters

For filter columns with hierarchy, you can use the Conditional option to filter what appears in the column lists. For example, you could filter by region so that only the states in the selected region appear in the list.

Note: If there is more than one OR group, the conditional filter is not available.

The following example illustrates how the Conditional option helps show the subcategories clearly, without the extra categories that do not belong.

1. Select Help > Sample Data Folder and open Cities.jmp.
2. Select Rows > Data Filter.
3. In the Data Filter window, select city, State, and Region, and then click Add.
   The Data Filter window appears, showing a list for each variable.
4. Click the Data Filter red triangle and select Conditional.
5. Select MW in the Region list.
6. Select OH from the State list.
   The cities that are in Ohio and in the Midwest region are selected in the data table. In the Data Filter window, only Midwestern states appear in the State list, and only cities in Ohio appear in the cities list.
The circled number in front of the column name indicates the order in which the column values were selected. In Figure 9.11, Region was selected first, so it has a circled “1” in front of the column name. State was selected second, so it has a circled “2” in front of the column name.

When you rearrange hierarchical filters that are in ascending order, the filter number changes to match the ascending position in the hierarchy.

To clear the selections and reset the order of the hierarchy, click Clear.

**Grouped by AND in Data Filters**

When you add a filter column, click AND, and add another filter column, you create a filter group. Within that group, columns that meet all criteria are selected in the data table.
When you then click OR and add one or more filters, you create a second filter group. With Grouped by AND deselected, this is the default behavior.

If you select Grouped by AND, you reverse the behavior.

The following example shows what happens when Grouped by AND is selected.

1. Select Help > Sample Data Folder and open Big Class.jmp.
2. Select Rows > Data Filter.
3. Click the Data Filter red triangle and select Grouped By AND.
4. In the Data Filter window, select the age column and click Add.
5. Click OR and add the sex column.
   sex is added to the same group as age.
6. Select 14 from the age filter, and select M from the sex filter.
   age and sex are in the same group. In the data table, rows that meet either the age OR sex conditions are selected. That is, all 14-year-olds and all males are selected in the data table.
7. Click AND and add the weight column.
   A new group is added.
8. Move the left weight slider to approximately 112.
   Another filter group has been added. The second filter group limits the selection to those rows where weight is greater than 112.
   The two filter groups together select rows that satisfy the condition in the first group AND the condition in the second group, that is, a student who is 14 or any male but must weigh more than 112.
Animation in Data Filters

The animation feature sequentially highlights the values of a single variable. The variable’s values are highlighted in the data table. However, patterns are more interesting if you first create a plot and then animate a variable using the Data Filter to see how it behaves on the plot.

To use the animation feature, click the Data Filter red triangle and select Animation. Then select the variable that you want to animate. The highlighted frame around the variable indicates which variable is selected for animation.
The Animation Control panel contains the following controls:

- The middle button ( ) starts and pauses the animation. After you start the animation cycles, the button changes to a pause button ( ). By default the animation begins with the first value of the topmost variable.
- The backward arrow ( ) moves the animation backward one cycle. Click more than once to go backward more than one cycle.
- The forward arrow ( ) moves the animation forward one cycle. Click more than once to go forward more than one cycle.
- The square button ( ) hides the Animation Control section on the Data Filter window. Select Animation from the menu on the Data Filter title bar again to see the Animation Control.
- The looping button ( ) enables looping and is on by default. If you turn the looping button off, the animation will cycle through the sequence of values one time and then stop.
- The record button ( ) starts recording the animation. After you start the recording, the button changes to a stop recording button ( ).
- The save button ( ) saves the recorded animation.

Use the slider to adjust the speed of the animation (slower to faster).

The Animate drop-down menu contains the following options:

- **Forward**  Highlights values from first to last.
- **Backward**  Highlights values from last to first.
- **Bounce**  Highlights forward and then backward repeatedly.
Save Where Clause in Data Filters

Once you have filtered variable values in the Data Filter, that information can be expressed as a JMP Where clause. The Where clause is used in JSL (JMP Scripting Language) programs to identify specific rows of data for processing or analysis. The Data Filter builds a Where clause based on the value selections that you make.

The options in the Save Where Clause menu include the following:

**To Clipboard**  Creates a Where clause from the filter criteria and puts it on the clipboard.

**To Row State Column**  Creates a row state column in the data table that has a formula equivalent to the filter criteria.

**To Formula Column**  Creates a formula column in the data table that has a formula equivalent to the filter criteria.

**To Data Table**  Creates a Where clause from the filter criteria and saves it as a JSL command with the current data table in a table property called Filter.

**To Script Window**  Creates a Where clause from the filter criteria and appends it to the current script text window, or creates a new script if one does not exist already.

**To Journal**  Creates the Where clause from the filter criteria and appends it to the current journal, or creates a new journal if one does not already exist.

### Example of Saving a Where Clause

1. Select **Help > Sample Data Folder** and open **Big Class.jmp**.
2. Select **Rows > Data Filter**.
3. Select **age**, **sex**, and **height** and click **Add**.

Select all females who are twelve and fourteen years old and whose height is between 56 and 60 inches:

4. Click the 12 and 14 blocks and the F block.
5. Click 51 and type 56.
6. Click 70 and type 60.
7. Click the Data Filter red triangle and select **Save Where Clause > To Script Window**.

The Where clause that is created from this example appears in a script window:

```verbatim
Select Where(  
   (:age == 12 | :age == 14) & :sex == "F" & (:height >= 56 & :height <= 60)  
);```
Red Triangle Options for Variables in Data Filters

After you add a column to the data filter, a red triangle menu appears. Some of the red triangle options for a variable can vary, depending on the type of variable.

Options for All Types of Variables

The red triangle menu next to any type of variable contains the following generic options:

- **Clear Selection**  Clears any selection in effect for that variable only.
- **Invert Selection**  Deselects any selected values, and selects all values previously not selected, for that variable only.
- **Modeling Type**  Shows a submenu of modeling types for the column filter. By default, the column filter type is set to the column’s modeling type. You can change the filter type by selecting a different modeling type in the submenu.

Options for Continuous Variables

For continuous variables, values appear in a histogram with vertical lines at the minimum and maximum values. You can adjust the selected range by clicking on the vertical lines and dragging. The updated range is highlighted in blue.

The following options are available for continuous variables only:

- **Select Missing**  Selects rows that contain missing values.
- **Include Minimum Value**  Includes or excludes the minimum value in the selected range. When the minimum value is excluded, the solid vertical line in the histogram becomes a dashed vertical line.
- **Include Maximum Value**  Includes or excludes the maximum value in the selected range. When the maximum value is excluded, the solid vertical line in the histogram becomes a dashed vertical line.
- **Set Number of Bins**  Sets the number of bins for the histogram.
- **Zoom to Selection**  Shows only the selected range in the histogram. The menu item changes to **Reset Zoom** after you select it. **Reset Zoom** resets the display.

Options for Nominal or Ordinal Variables

For nominal and ordinal variables, values appear in blocks, in a list, or in a menu. If the variable contains only a small number of categories, the values appear in blocks. If the variable contains a large number of categories, the values appear in a list or in a menu. However, you can change these default settings.
The following options are available for nominal or ordinal variables only:

**Display Options**  Changes the appearance of the display. Options can include the following:

- **Blocks Display**  Shows each level as a block.
- **List Display**  Shows each level as a member of a list, followed by its frequency.
- **Single Category Display**  Shows each level, followed by its frequency, in a menu.
- **Check Box Display**  Adds a check box next to each value. To make this the default setting, select the **Check Box Display** option in File > Preferences > Data Filter.
- **Radio Box Display**  Adds a radio button next to each value.

**Order by Count**  Orders the values in decreasing sort order by count.

**Find**  Provides a text box where you can enter a search string for the selected column. Press Enter to perform the search.

### Options for Variables with the Multiple Response Modeling Type or Column Property

The following options are available for variables with the Multiple Response modeling type or column property:

**Display Options**  Changes the appearance of the display. Options can include the following:

- **List Display**  Shows each level as a member of a list, followed by its frequency.
- **Single Category Display**  Shows each level, followed by its frequency, in a menu.
- **Check Box Display**  Adds a check box next to each value. To make this the default setting, select the **Check Box Display** option in File > Preferences > Data Filter.
- **Radio Box Display**  Adds a radio button next to each value.

**Match None**  Selects only rows containing values that do not match any of the selections.

**Match Any**  Selects all rows that contain values that match any of the selected values. By default, this option is selected.

**Match All**  Selects only rows with values that include all of the selected values.

**Match Exactly**  Selects only those rows with values that exactly match the checked values.

**Match Only**  Selects only those rows with contents exactly matching the checked values.

**Match At Least**  Selects at least \( n \) of the selected values.

**Match At Most**  Selects a maximum of \( n \) of the selected values.
**Match Between**  Selects between \( n \) and \( m \) of the selected values.

**Find**  Provides a text box where you can enter a search string for the selected column. Press Enter to perform the search.

**Note:** For more information about the Multiple Response property, see the “Multiple Response”.

## Options for Unstructured Text

The following options are available for variables with the Unstructured Text modeling type:

**Case Sensitive**  If this box is checked, the filter based on the word or phrase typed in the filter text edit box is case sensitive.

**Regular Expression**  Assumes the string typed into the filter text edit box is a regular expression instead of a literal string.

**Display Options**  Changes the appearance of the display. Options can include the following:

- **List Display**  Shows each word or phrase as a member of a list, followed by its frequency.
- **Single Category Display**  Shows each word or phrase, followed by its frequency, in a menu.
- **Check Box Display**  Adds a check box next to each word or phrase. To make this the default setting, select the **Check Box Display** option in File > Preferences > Data Filter.
- **Radio Box Display**  Adds a radio button next to each word or phrase.

**Add Missing**  Adds a filter for entries that do not contain any text.

**Clear Filter Texts List**  Removes any words or phrases that had been added to the filter text list.

**Show Filter Text Edit Box**  Shows or hides the filter text edit box.

**Order by Count**  Orders the words or phrases in decreasing sort order by count.

**Match None**  Selects only rows containing text that does not match any of the selected words or phrases.

**Match Any**  Selects all rows that contain text that matches any of the selected words or phrases. By default, this option is selected.

**Match All**  Selects only rows with text that includes all of the selected words or phrases.
Reformat Tables in JMP Reports

There are many ways to change the formatting of a JMP report table. Right-click a report table to access the following formatting options:

**Table Style**   Adds borders, shading, and dividing lines to the table. Select from the following options:

- **Underline Headings**   Shows the preference setting for Underline Table Headings.
- **Shade Headings**   Shows the preference setting for Shade Table Headings.
- **Heading Column Borders**   Shows divider lines between columns in headings.
- **Column Borders**   Contains borders outside columns and divider lines between columns.
- **Row Borders**   Contains borders outside rows and divider lines between columns.
- **Shade Alternate Rows**   Shades alternate rows.
- **Shade Cells**   Shades the body of the table. When used with Shade Alternate Rows, a darker shade is used on alternate rows.

**Note:** Change the format of all report tables by selecting the preceding options in the JMP preferences. On Windows, the Report Tables options are in File > Preferences > Styles. On macOS, select the Report Tables options in JMP > Preferences > Styles.

**Columns**   Shows or hides columns in the table.

**Note:** Columns whose names begin with a tilde (~), such as ~Bias, are not applicable to the analysis that you ran and do not appear in the table, even if you place checks next to their names.

**Sort by Column**   Sorts the columns in descending or ascending order by the selected column. You can also select Numerical Order to sort a sorted string column numerically. After you do that, the Numerical Order option is available when you right-click the column. For more information about the sorting rules used by the Numerical Order option, see “Numerical Order”.

**Make into Data Table**   Creates a JMP data table from the report table. The data table script recreates the report and the data table generated by Make into Data Table.

**Make Combined Data Table**   Searches the report for other tables like the one you selected and combines them into a single data table. The data table contains a column that identifies the original data table. The data table script recreates the report and the data table generated by Make Combined Data Table.
Make Into Matrix  Creates a JMP matrix from a report table. See “Change a Table in a JMP Report Into a Matrix”.

Select Where  (Available only for categorical columns) Creates a Where clause using the selected columns or a complex expression.

Show Properties  Enables you to change the formatting of display boxes in the report.

Format Columns  Changes the numeric formatting of one or more columns in the table.

Copy Column  Copies the contents of the right-click column to the clipboard for pasting into another window or application.

Copy Table  Copies the right-click table to the clipboard for pasting into another window or application.

Simulate  Provides simulated results for the selected column of statistics in a report.

Bootstrap  Approximates the sampling distribution of a statistic. See Basic Analysis.

Change Display Box Properties in a JMP Report

For each display box in a JMP report, you can change properties such as the font, text color, padding, and alignment. Your changes are included when you save the report as a script, a graphic, or a journal.

To change display box properties, follow these steps:

1. Right-click the disclosure icon next to the report and select Show Properties.
   The Properties pane appears.
2. Modify the report properties.
3. Click the report to view your changes.

Tips:

- In the Properties pane, use the arrow buttons to navigate among display boxes in the display tree.
- After you open the Properties pane, select a specific report and change its properties.

Change the Format of Numeric Columns

In the Show Properties pane, you can change the appearance of a JMP report, including changing the format of selected numeric columns. For example, you might want to specify two decimal places for all numeric columns. Your changes are included when you save the report as a script, a graphic, or a journal.
To change the numeric formats, follow these steps:

1. Right-click the disclosure icon next to the report and select **Show Properties**. The Properties pane appears.
2. Press Shift and select the columns whose format you want to change.
3. From the Format list in the Properties pane, select the Format properties.

**Tips:**
- To select all display boxes of a specific type (for example, all NumberColBoxes), select one of the boxes in the report. From the Select list in the Properties pane, select **Boxes of type ‘NumberColBox’**.
- To select all columns that have a specific format, select one of the boxes in the report. From the Select list in the Properties pane, select **Columns with matching format**.

**Change a Table in a JMP Report Into a Matrix**

You can create a JMP matrix from a report table. For example, when working with JMP Scripting Language (JSL), you might want to access a report’s table that has been stored into a JSL variable. Or, you might want to store a report table’s values into a table property as either a table property or as a JSL assignment, which is stored within the data table and is accessible via a script or the Formula Editor.

To store a table in matrix form into a global variable, into a table property, or into a table property as an assignment:

1. Right-click anywhere in a report table.
2. Select **Make into Matrix**.
3. In the window that appears, tell JMP how you want to store the table.
4. (Optional) Rename the variable or property by entering a new name into the box beside Name.

**Use Conditional Formatting in JMP Reports**

To configure reports to use conditional formatting, you must first set your report preferences to enable showing conditional formatting. See “Preferences for Data Tables”.

**Note:** You must enable **Show conditional formatting** in the Reports preferences for your conditional formatting to appear in JMP reports.

To configure conditional formatting, follow these steps:

1. Open the JMP Preferences window.
2. Select the Reports preference group.
3. Click **Manage Rules**.

   The Conditional Format Rule window appears.

**Figure 9.14** Conditional Format Rule Window

All rules are enabled by default. The PValue rule is applied to columns that contain probability values.

From this window you can add, edit or delete a rule.

**Disable or Enable a Rule**

To disable or enable a rule, follow these steps:

1. Open the JMP Preferences window.
2. Select the Reports preference group.
3. Click **Manage Rules**.

   The Conditional Format Rule window appears.
4. Select the rule from the list.
5. If **Rule enabled** is selected, select to disable.
6. If **Rule enabled** is not selected, select to enable.

**Add a Rule**

To add a rule, follow these steps:

1. Open the JMP Preferences window.
2. Select the Reports preference group.

3. Click **Manage Rules**.

The Conditional Format Rule window appears.

4. Click **Add**.

The Conditional Format Rule window appears. A placeholder rule appears on the left.

**Figure 9.15** Adding a Conditional Format Rule

5. Add and format conditions as described in “Add a Condition”.

6. Click **OK** to save the new rule and return to the previous Conditional Format Rule window.

7. Select **Rule enabled** to enable the rule.

**Edit a Rule**

To change the conditional formatting of a rule, follow these steps:

1. In the Conditional Format Rule window, select the rule from the list.

2. Click **Edit**.

The Conditional Format Rule window appears, showing the selected rule’s current conditions.
The default rule for PValue includes two conditions. The order of the list indicates the order that the rules are applied. For example, a p-value of 0.04 would not invoke the first rule (x < 0.01) but would invoke the second rule (x < 0.05).

**Note:** You cannot edit an existing condition within a rule. To edit an existing condition, you must delete the condition and then add it. See “Edit an Existing Condition”.

### Add a Condition

To add a condition to a rule, follow these steps:

1. Open the rule to view the Conditional Format Rule window.
2. In the Condition area, select a relation from the list and enter a value in the text box.  
   Or  
   If you want the condition to include a value range:  
   – Select > or ≥ from the relation drop list and enter the value in the text box.  
   – Select the check box, select the < or ≤ relation, and enter the value.
3. Format the condition using the procedure described in “Format a Condition”.

**Tip:** When you click **Add new condition**, the condition and its format settings are immediately added to the bottom of the condition list and the Condition and Format areas return to their default settings. Verify your settings before you click **Add new condition**.

4. After verifying your settings, click **Add new condition** to add the condition to the rule.
5. Use the ▲ and ▼ buttons to position the condition within the list.
Figure 9.17  Example of Adding a Condition with Formatting Rules

6. Click **OK** to save your changes and return to the previous Conditional Format Rule window.

**Delete a Condition**

To delete a condition from a rule, follow these steps:

1. In the Conditional Format Rule window, select the condition and click **Delete**.
2. Click **OK** to save your changes and return to the previous Conditional Format Rule window.
3. Click **OK** to return to the Preferences window.

**Format a Condition**

To format values that fall within a condition, follow these steps:

1. With a Condition entered, select a Text Color from the drop list:
   - **Default**: The value appears without color.
   - **Solid**: The value appears in the specified color.
   - **Dimmed**: The value appears dimmed by the specified transparency.
   - **Color Range**: For ranged conditions, the values appear in color gradients within the specified color range.
   - **Dimmed Range**: For ranged conditions, values appear in dimmed gradients by the specified transparency range.
2. To specify a text color, click the color swatch and select a color.
3. To specify a transparency, enter the percent value (for example, ‘60%’). The Sample area displays a preview of the appearance of the text column.

4. Select a Background Color from the drop list:
   - **Default**  The value appears without a color background.
   - **Solid**  The value appears with the specified color background.
   - **Color Range**  For ranged conditions, the values appear with background color gradients within the specified color range.

5. To specify a background color, click the color swatch and select a color. The Sample area displays a preview of the appearance of the text column.

6. To have condition values noted, select an Annotation from the drop list:
   - **None**  No notation is used on the value.
   - **Box**  The value appears in the table with a box around it.
   - **Circle**  The value appears in the table with an ellipse around it.
   - ***(asterisk)***  An asterisk (*) appears to the right of values in the table.

7. To style the value text, select the **Font Style** from the drop list:
   - **None**  No style is used to format the value.
   - **Plain**  No style is used to format the value.
   - **Bold**  The value appears bolded in the table.
   - **Italic**  The value appears italicized in the table.
   - **BoldItalic**  The value appears bolded and italicized in the table.

See Figure 9.17 for an example of condition formatting.

**Note:** After configuring the formatting, remember to click **Add new condition** to add the new condition to the rule.

**Edit an Existing Condition**

To change the formatting for an existing condition, follow these steps:

1. In the Conditional Format Rule window, select the condition and click **Delete**.
2. Re-create the condition by using the procedure described in “Add a Condition”.
3. Format the conditional using the procedure described in “Format a Condition”.
Tip: When you click Add new condition, the condition and its format settings are
immediately added to the bottom of the condition list and the Condition and Format areas
return to their default settings. Verify your settings before you click Add new condition.

4. After verifying your settings, click Add new condition to add the condition to the rule.
5. Use the Up and Down buttons to position the condition within the list.
6. Click OK to save your changes and return to the previous Conditional Format Rule
window.

Select Points in JMP Graphs

To select a point in a JMP graph, click the point. This selects the point as well as the
 corresponding row in the current data table. To select multiple points, press Shift while you
 select points. A point’s label appears when you place the cursor over the point with or without
clicking.

Figure 9.18 Label for a Data Point

Tips:
• You can paste the contents of a label into another document. Right-click the label and
 select Copy. Paste the text into the other document.
• A photo can be displayed in the label if you store the image in an Expression role column.
 See “Expression Role”.

Select Rows in JMP Graphs

All graphs and plots that represent the same data table are linked to each other and to the corresponding JMP data table. When you click points in plots or bars of a graph, the corresponding rows highlight in the data table. The example in Figure 9.19 shows a histogram with the SPEEDYTYPE bar highlighted, and the corresponding rows highlighted in the table. You can also extend the selection of bars in a histogram by pressing Shift and then making your selection.

**Figure 9.19** Highlighting Rows in a Histogram

Select a Rectangular Area of Points in a JMP Graph

You can select all points that fall in a rectangular area using the cursor. Click and drag the arrow to highlight points. Alternatively, you can use the brush tool. As you move the brush over the graph, points that fall within the rectangle are selected. Any points marked in the data table as hidden are not selected. See “Hide Rows in Data Tables”.

To select points using the brush tool, follow these steps:
1. Click the brush tool in the toolbar.
2. Click and hold the brush tool in a plot. A rectangle appears.
3. Move the rectangle over points. As it passes over them, they appear highlighted both in the plot and in the active data table.

To keep all points selected as you move the brush tool over points, press Shift before you click a point in the plot. The selected points are also selected in the data table.

Figure 9.20 Using the Brush Tool

![Bivariate Fit of weight By height](image)

4. Release the mouse. The points within the rectangle and the data table remain selected.

   - To change the size of the selection rectangle, press Alt before you click in the plot. Drag the cursor to resize the selection box. This shape acts like a slicing tool that can traverse and highlight slices of points across either axis. **Note:** The size of the selection box is remembered for the next time you use the brush tool.

   - If you press Ctrl and click the brush tool on selected points, the points within the selection rectangle are deselected. Points outside the selection rectangle remain selected.

**Select an Irregularly Shaped Area of Points in a JMP Graph**

You can use the lasso tool to select points that fall in an irregularly shaped area. Any points marked in the data table as hidden are not selected. See “Hide Rows in Data Tables”.

To select points within an irregularly shaped area, follow these steps:

1. Click the lasso tool in the toolbar.
2. Click and hold the lasso tool in a plot.

   **Note:** To keep all points selected as you drag the lasso around several sets of points, press Shift before you click in the plot.

3. Drag the lasso around any set of points.
Using JMP Use Markers in JMP Graphs

4. Release the mouse. JMP automatically closes the lasso and highlights the points within the enclosed area.

Use Markers in JMP Graphs

Markers are points on a graph that represent data. Once they are changed from their default setting, they also appear next to rows in the data table.

- “Change the Shape of Markers”
- “Change the Color of Markers”
- “Change the Size of Markers”
- “Work with Crowded Markers”
- “Add Outlines Around Markers”
- “Change the Selection Mode of Markers”
- “Specify the Transparency of Markers”
- “Exclude and Hide Markers”
- “Use Images as Markers”
- “Change the Shape or Color of Markers Based On Values”

Change the Shape of Markers

You can assign a character from the JMP markers palette to replace the standard points in scatterplots. These markers also appear next to row numbers in the data table.

1. Highlight one or more markers whose shape you would like to change.
2. Right-click anywhere in the graph. In a histogram, right-click the box plot area on the right.

3. Select **Row Markers**.

4. Select a marker shape from the options that appear, or click **Other** to enter a character to use as a marker.

### Change the Color of Markers

You can assign any color to highlighted markers on a JMP graph. In the associated data table, the color appears next to the row number in the data grid.

To change the color of markers (or points) on a graph:

1. Highlight one or more markers whose color you would like to change.
2. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
3. Select **Row Colors**.
4. Select one of the colors, or click **Custom** to apply a custom color.

### Change the Size of Markers

To increase or decrease the size of markers on a JMP graph, follow these steps:

1. Right-click anywhere in a graph. Press Ctrl and right-click to broadcast the command and apply it to all plots of the same type located in the same window. In a histogram, right-click the box plot area on the right.
2. Select **Marker Size**.
3. Select one of the marker sizes listed.
   
   The default value, Preferred Size, is selected on the Graphs page in the JMP preferences.

   **Note:** When the drawing speed is set to Fast, the smallest marker size (Dot) is applied. See “Work with Crowded Markers”.

### Work with Crowded Markers

A large number of markers on a JMP graph can appear crowded. You might need to alter the transparency to gain a better view. Altering the transparency might also affect the marker drawing mode, which is the mode JMP uses when it refreshes a report window. As markers are drawn on a plot, JMP uses one of two speeds: normal or fast.
To change the marker drawing speed

1. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
2. Select Marker Drawing Mode, and then select either Normal or Fast.

   **Normal**  If JMP is in normal drawing mode and the number of markers on a graph are more than the specified threshold number, JMP automatically switches to fast mode. See “Preferences for Data Tables” for more information about setting the marker threshold.

   **Fast**  Graphs that display a large number of markers appear faster if you set the marker drawing speed to Fast. Note that when the drawing speed is set to Fast, the smallest marker size (Dot) is applied, and marker transparency settings revert to the default opaqueness.

   **Outlined**  See “Add Outlines Around Markers”.

To fill hollow markers

In the JMP preferences, select Graphs and then select Fill Hollow Markers. Hollow markers on all graphs are filled with an opaque background.

**Add Outlines Around Markers**

You can add a black outline, or frame, to markers in a JMP plot or graph. Outlined markers are available at the medium, larger, XL, XXL, and XXXL marker size. See “Change the Size of Markers”.

To add outlines

1. Right-click a plot or graph.
2. Select Marker Drawing Mode.
3. Select Outlined.

To use an outline effectively, it is best if your marker is a color other than black.

To change marker colors

1. Highlight the markers whose color you want to change.
2. Right-click anywhere in the graph.
3. Select Row Colors.
4. Select a marker color from the options that appear.
Change the Selection Mode of Markers

When you select markers on a JMP graph, only the selected markers are highlighted. You can change how markers are highlighted on the current graph. The options are applied to the top two triangles in the following figure.

**Figure 9.22 Examples of Highlighted Triangular Markers**

![Figure showing examples of highlighted triangular markers.]

To change the marker highlighting on the current graph, follow these steps:

1. Right-click anywhere in a graph and select **Marker Selection Mode**.
2. Select one of the following options:
   - **Preferred Mode**: The Marker Selection Mode that is selected on the Graphs page in the JMP preferences. The default value is Unselected Faded.
   - **Unselected Faded**: Only the selected markers are highlighted. Everything else is dimmed by the percent specified by **Faded amount for unselected markers** in Preferences > Graphs.
   - **Selected Larger**: The selected markers are larger than the deselected markers.
   - **Selected Haloed**: The edges of the selected markers are outlined in blue.
   - **Selected Outlined**: The selected markers are outlined in black.
   - **Selected Same Color**: The selected markers are shaded with the Marker Selection Color that is selected in the Graphs preferences.
Specify the Transparency of Markers

You can change the transparency of markers (points) on a JMP graph. For example, this enables you to control the visibility of overlapping points.

**Note:** When the drawing speed is set to Fast, the default marker transparency is applied. See “Work with Crowded Markers”.

1. In a graph, right-click anywhere and select **Transparency**. In a histogram, right-click the box plot area on the right and select **Transparency**.
2. Enter the level of transparency that you want the markers (points) to have on the graph, and click **OK**.
   
   A value of 1 indicates total opaqueness and 0 indicates invisibility. Values between 1 and 0 are semi-transparent.

Exclude and Hide Markers

In a JMP graph, use the Rows > Hide and Exclude command to suppress the appearance and exclude from statistical analyses the highlighted rows. Data remains hidden and excluded until you select Rows > Hide and Exclude again.

Using the Exclude/Unexclude command, you can exclude highlighted rows from statistical analyses. Data remains excluded until you select Rows > Exclude/Unexclude for those highlighted rows.

**Note:** Excluded data are not automatically hidden in plots even though they are excluded from calculations in text reports and graphs.

Using the Hide/Unhide command, you can suppress (hide) the appearance of highlighted points in scatterplots. For example, you can exclude points from analysis and then hide those same points in scatterplots. The data remain hidden until you select Rows > Hide/Unhide for highlighted hidden rows.

**Note:** Hidden points are not automatically excluded from statistical computations that affect text reports and graphs, even though they are not displayed in the plots. To exclude hidden observations from analyses, you must highlight them and select Rows > Exclude/Unexclude characteristic.

To exclude or hide markers (points) from analyses, follow these steps:
1. Highlight the marker(s) that you would like to exclude or hide.
2. Right-click anywhere in a graph.
3. Select **Row Exclude** or **Row Hide**.

**Use Images as Markers**

Place images in an expression column to use those images as markers on JMP graphs. Then you indicate which column to use for markers. This feature prevents the need to look at a marker color and refer to the legend for its meaning, which is particularly helpful with data that contain many levels.

If you use a character or numeric column as the marker, the data value is used for the marker.

1. Create a new column in your data table.
2. Right-click the column, select **Column Info**, and select the **Expression** data type.
3. Click **OK**.
4. Drag graphics from your computer into each cell of the column. You can also import data that contains a column of images.
5. Select the column, select the **Cols** menu, and then select **Use for Marker**.
6. Create a graph that uses markers. *Figure 9.23* was created in Graph Builder.
7. (Optional) To resize the markers, right-click the graph, and select **Graph > Marker Size** (or right-click and select **Marker Size** in some platforms). Medium markers are selected in this example.
8. Click the Graph Builder red triangle and deselect **Show Legend**.
Notes:

- In the Big Class Families.jmp sample data table, the picture column used for markers on graphs.
- This feature is not supported in Bubble Plot.

Change the Shape or Color of Markers Based On Values

In some JMP plots, you can change marker shapes or colors based on the values of points by adding a row legend. It is called a row legend because JMP automatically inserts a legend using row color or row marker settings. When you assign markers or colors in this way, it assigns the characteristic(s) to all points in a graph, regardless of what points you have selected. All previous marker and color settings are overwritten.

To add shapes or colors based on column values, follow these steps:

1. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
2. Select Row Legend.
3. In the window that appears, highlight the column whose values you want to color or mark. A preview of the legend is shown on the right.
4. Refine your row legend using the following options:

**Colors**  Lets you choose among several pre-defined color schemes.

**Tip:** If you already applied a color scheme in the data table, select None to maintain it. Colors should be consistently applied and uniquely grouped.

**Continuous Scale**  Assigns colors on a spectrum that corresponds to the ascending or descending order of the values. Use this option when the highlighted column contains continuous values.

**Reverse Scale**  Reverses the scale of colors.

**Markers**  Lets you choose among several marker schemes.

**Tip:** If you already applied a marker scheme in the data table, select None to maintain it. Markers should be consistently applied and uniquely grouped.

**Make Window with Legend**  Creates a separate legend window that tells you what colors and shapes correspond to which value.

**Save to Column Property**  Adds a column property that stores the selected color theme.

**Save to Table Property**  Adds a table property that preserves the selected color and marker configuration.

**Excluded Rows**  Assigns colors or markers to rows that are excluded.

Most legends have one column. However, the following platforms have multi-column legends when there are more than 20 levels:

- Recurrence
- Oneway (for CDF Plot and all three Densities red triangle commands)
- Fit Model (for the Regression Plot in Standard Least Squares)
Chapter 9
Using JMP

JMP Reports
Change the Appearance of JMP Graphs

• Survival

Remove the Row Legend

Delete a row legend by right-clicking it and selecting Remove.

Change the Appearance of JMP Graphs

There are many ways that you can format your JMP report to meet your needs. The sections that follow detail how to make changes to the graphical portions of your output reports.

Tip: If you have a touchscreen, you can pan and zoom most graphs and axes in JMP. Graphs and axes change scale and zoom out if pinched, and zoom in if stretched.

• “Resize Graphs”
• “Zoom In on Graphs”
• “Change Line Widths in Graphs”
• “Change the Background Color in Graphs”
• “Change the Color of Histogram Bars”
• “Display Coordinates and Temporary Reference Lines in Graphs”
• “Scroll and Scale Axes in Graphs”
• “Customize Axes and Axis Labels in Graphs”
• “Change the Order of Values in Reports”
• “Change the Pattern and Format of Selected Objects in Graphs”
• “Add a Graph to a Data Table”
• “Customize Markers, Lines, Text, and More in Graphs”

Resize Graphs

There are two main ways to resize graphs in JMP: using the click and drag method or resizing it according to pixel size.

Note: You can also change the default size of a graph using the Graph Height option in File > Preferences > Graphs.
Use Click and Drag

To resize a plot or graph using the click and drag method:

1. Place the cursor on the right edge, bottom edge, or lower right corner of the plot frame. The cursor changes to a small double-arrow.
2. Click and drag to change the size of the plot. When you resize, the height and width of all plots in that frame adjust independently of other frames in the same report window. Table 9.2 describes how to adjust the plot.

Table 9.2 Resizing Actions

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the plot frame but preserve the proportions (aspect ratio)</td>
<td>Press Shift and click and drag the corner of the frame.</td>
</tr>
<tr>
<td>Adjust a plot in 8-pixel increments</td>
<td>Press Alt and click and drag the corner of the frame.</td>
</tr>
<tr>
<td>Adjust all plots of the same type simultaneously</td>
<td>Press Ctrl and click and drag the corner of one of the plots. If you do this for one scatterplot, the action is broadcast to all scatterplots in the window, and they resize together. Any other types of plots remain unchanged.</td>
</tr>
</tbody>
</table>

Specify Graph Size in Pixels

To resize a plot or graph to a specific pixel size, follow these steps:

1. Right-click the plot or graph.
2. Select **Size/Scale > Frame Size**.
3. Enter the number of pixels for the frame’s height and width.

**Note:** For more information about the other options in the Size/Scale menu, see “Scroll and Scale Axes in Graphs”.
Zoom In on Graphs

The magnifier lets you automatically zoom in on any area of a JMP plot or graph. When you click the magnifier, the point or area where you click becomes the center of a new view of the data. The scale of the new view enlarges, giving you a closer look at interesting points or patterns. You can perform any of the following actions:

- Click and drag the magnifier to focus in on a particular region of the plot.
- On a ternary plot, drag the magnifier to zoom the triangular axes.
- Zoom repeatedly to look closer at the data.
- Press Ctrl and click the magnifier to return to your previous state before the last zoom.
- Double-click or press Alt and click the magnifier to restore the original plot.

On Windows, you can also zoom by pressing Ctrl and using the mouse wheel.

On macOS, zoom by pressing Option and clicking the area.

Note: You can zoom in and still see a center point by dragging from the axis to inside the graph. For a vertical axis, click a position and drag right into the graph. This zooms in on the scale, adjusting both endpoints of the scale but keeping the clicked value in about the same position. Dragging left zooms out.

Change Line Widths in Graphs

After fitting a line to a JMP graph, or producing a graph with a line already present, you can adjust the width of the line:

1. Right-click anywhere in a graph.
2. Select Customize.
3. Select Smoother (for example, if the graph contains a smoother).
4. Change the line width. The value is in pixels.
5. Click OK.

Change the Background Color in Graphs

To change the background color in a JMP graph, follow these steps:

1. Right-click anywhere in a graph. (To change only the color of a box plot, right-click the box plot area.)
2. Select Background Color.
3. Select one of the predefined colors, or create your own color.
4. Click **OK**.

### Change the Color of Histogram Bars

To change the color of histogram bars in a JMP graph, follow these steps:

1. Right-click anywhere in a histogram and select **Histogram Color**.
2. Click a color, or click **Other** and create your own color.

See your operating system documentation for more information about creating your own colors.

### Display Coordinates and Temporary Reference Lines in Graphs

You can measure points and distances in JMP graphs, or easily find the exact value, or coordinates, of points and distances on plots and graphs. To do this, click the crosshairs tool and click and hold anywhere on a graph. The coordinate values appear where the crosshairs intersect the vertical and horizontal axis as you drag the crosshairs within a plot.

![Figure 9.25 Using the Crosshairs Tool](image)

On a fitted line or curve, the crosshairs identify the response value for any predicted value. On a ternary plot, this tool displays triangular crosshair lines.

### Scroll and Scale Axes in Graphs

The hand tool (also known as the grabber tool) provides a way to change the axes and view of a JMP plot:

- On a **y-axis**, dragging scrolls the **y-axis**; dragging or scales the **y-axis**.
• On an x-axis, dragging scrolls the x-axis; or scales the x-axis.

Tip: When you drag an axis to change its scale, JMP automatically updates the major and minor tick increments based on the new axis width. To prevent this (retaining your original increments), press Shift while dragging.

You can also right-click in a plot or graph, and select Size/Scale (or Graph > Size/Scale). Choose one of the following options:

• To adjust the scale of the X axis, select X Axis. To adjust the scale of the Y axis, select Y Axis or Right Y Axis. For more information about this window, see “Customize Axes and Axis Labels in Graphs”.

• For more information about the Frame Size option, see “Specify Graph Size in Pixels”.

• Select Size to Isometric when the x- and y-axes are measured in the same units and you want distances on the graph to be represented accurately regardless of direction.

Customize Axes and Axis Labels in Graphs

Double-click a numeric axis in a JMP graph to customize it using the Axis Settings window. Or, right-click the axis area and select Axis Settings to access the window.

Note: In the Graph Builder and Distribution platforms, you can also customize nominal axes using the Axis Settings window.

Customization features in the window depend on the data type of the axis and the specific platform JMP uses to create the plot or chart. Figure 9.26 shows a typical Axis Settings window for numeric (continuous) axes.
Figure 9.26 Axis Settings Window for a Numeric (Continuous) Axis

The Axis Settings window contains the following panels:

- “Scale”
- “Tick/Bin Increment”
- “Axis Label Row”
- “Reference Lines”
- The Preview panel shows how your current selections will appear on the axis.

Scale

In the Scale panel, you can do the following:

- “Change the Axis Scale Type”
- “Change the Numeric Format of an Axis”
- “Establish Minimum and Maximum Axis Values”

Change the Axis Scale Type

When viewing a graph with a numeric axis, you can change the axis scale to one of the following types:

- Linear
• Log
• Power
• Geodesic
• Geodesic US
• Probability Scales (Normal, Weibull, Fréchet, Logistic, Exponential, Gamma, Beta, and Mixtures)

Notes:
• Specific platforms might use other scale types that are fixed and cannot be changed. For example, Destructive Degradation, Degradation, and the X axis in Fit Y by X scatterplots use custom scales. Do not change the scale in these graphs through the Axis Settings window.
• If you selected a scale type of Log, enter the Base to use.
• If you selected a scale type of Power, enter the Power to use.
• Power works similarly to log scale, but instead of the scale conversion being \log(x), it is \(x^p\), where \(p\) is a customizable axis option. For example, \(\text{Power} = 2\) creates an \(x^2\) axis.

To set a default scale type for a variable, which avoids making this change every time you run an analysis, see “Axis”.

Change the Numeric Format of an Axis

For plots and charts that contain a numeric axis area, you can change the format of the axis. For more information about numeric formats, see “Numeric Formats”.

Notes:
• If you selected Date, Time, or Duration, you need to specify the format of the increments. See “Add and Remove Axis Labels”. You can also specify label row nesting. See “Label Row Nesting”.
• If you selected Fixed Dec, enter the number of decimal places that you want JMP to display in the Dec box.
• If you selected Precision, select whether you want to keep trailing zeros and all whole digits.
• To add commas to values that equal a thousand or more, select the Use thousands separator option. You must account a space for each comma in the Width box, or else they might not appear. This option is available for the Best, Fixed Dec, Percent, and Currency formats.
• For a numeric axis, you can adjust the width of the tick mark labels using the Width box.
**Note:** When you change the numeric format of an axis, you do not change the numeric format of the way the values appear in the corresponding data table. To change how a date or time appears in a data table, see “**Numeric Formats**”.

Selecting a date interval from the date increment drop-down menu divides the JMP date (number of seconds) into the appropriate units. This gives the plot scale that you want for your data. The date axis must be a column with a JMP date value and appear in the Axis Settings window in the date format found in the Column Info window. However, you can use the Axis Settings window to format the date’s appearance in the plot.

**Establish Minimum and Maximum Axis Values**

For plots and charts that contain a numeric axis area, you can change the minimum and maximum values that you want the graph to display.

Note the following:

- To restore the default minimum, maximum axis settings, and tick increments of an axis, right-click on the axis labels and select **Revert Scale**. To restore all default axis settings, right-click the axis labels and select **Revert Axis**.
- Select **Reverse Order** to reverse the axes by reversing the minimum and maximum values. Note that this option is not supported for ternary plots.

**Tip:** To set a default minimum and maximum axis value for a variable, which avoids making this change every time you run an analysis, see “**Axis**”.

The example on the right in **Figure 9.27** is an enlargement of the point cluster that shows between 80 and 140 in the plot to the left. The enlarged plot is obtained by reassigning the maximum and minimum axis values.

**Figure 9.27** Rescale Axis to Enlarge a Plot Section
Tick/Bin Increment

In the Tick/Bin Increment panel, you can do the following:

- “Change Axis Increments”
- “Add Minor Tick Marks”
- “Change the Tick Offset”
- “Label Row Nesting”

Change Axis Increments

While viewing a graph, you can change the axis increments.

If the axis Format is set to Date, Time, or Duration, a format menu appears beside Increment (Figure 9.28). Select the format for the increments.

Figure 9.28 Selecting the Format for Date and Time Increments

Tip: To set a default axis increment for a variable, which avoids making this change every time you run an analysis, see “Axis”.
Add Minor Tick Marks

You can add tick marks to a numeric axis, or change the number of minor tick marks that appear on a numeric axis. In the Axis Label Row panel, be sure to select the **Minor** Tick Marks box so that the tick marks appear on the axis.

**Tip:** To set default minor tick marks for a variable, which avoids making this change every time you run an analysis, see “Axis”.

---

Change the Tick Offset

To change the starting point of the tick marks, enter a number in the Tick Offset box. For example, if the Tick Offset is currently set to 0, setting it to 1 will move all the values on the axes up by 1.

---

Label Row Nesting

This option appears only if you have selected Date, Time, or Duration as the axis Format. Label row nesting enables you to split a date axis into multiple rows based on the format. For example, you might put the year on the outermost row, then the month, then the day:

1. Select **Help > Sample Data Folder** and open Stock Prices.jmp.
2. Select **Graph > Graph Builder**.
3. Drag Date into the X zone.
4. Drag Open into the Y zone.
5. Double-click the X axis.
6. For **Format**, select **Date > ddMonyyy**.
7. Increase the value for **Label Row Nesting** to 3.
8. Click **OK**.
9. Click **Done** to see the finished graph.
Figure 9.29 Example of Label Row Nesting

Axis Label Row

In the Axis Label Row panel, you can do the following:

- “Change the Axis Label Font”
- “Add Tick Marks, Grid Lines, or Labels”
- “Change the Orientation for Tick Labels”

Note: In Graph Builder, if you have nested labels in an axis, tabs appear in the Axis Label Row panel. You can change each row of labels separately in its own tab.

Change the Axis Label Font

You can change the axis label font on any axis type. Your changes only apply to the active graph. To set the default axis label font, see “Preferences for File Locations”.

To change the current font type and size, double-click an axis, select Axis Settings, and then click Font.

Notes:

- Select Automatic Font Size to have JMP attempt to decrease the font size (down to a certain minimum) if all of the labels cannot fit at the default size.
To change the axis label font color, right-click the axis and select **Show Properties**. In the Edit options on the right, change the text color.

**Add Tick Marks, Grid Lines, or Labels**

These options can vary depending on whether your axis is continuous or categorical. **Figure 9.30** shows axis settings for a categorical axis. **Figure 9.26** shows axis settings for a continuous axis.

**Figure 9.30  Axis Label Row for a Categorical Axis**

Options for continuous axes:

- Select **Automatic Tick Marks** to turn on tick marks only if one or more labels are hidden due to insufficient space.
- Add major or minor tick marks, grid lines, or labels, by selecting the corresponding check boxes.
- Click the color box to change the color of grid lines.
- Select **Tick Marks Inside Graph Frame** to move the tick marks inside the graph.
Options for categorical axes:

- The default is to not show tick marks if all of the labels are visible. To add tick marks, select **Automatic Tick Marks**. Change the tick mark style by selecting one of the options.
- Select **Automatic Tick Marks** to turn on tick marks only if one or more labels is hidden (due to insufficient space).
- Add grid lines by selecting **Show Grid**.
- Click the color box to change the color of grid lines.
- Select **Tick Marks Inside Graph Frame** to move the tick marks inside the graph.
- Select **Lower Frame** to add a frame around the labels.
- Change the number of lines that text wraps.
- Change the labels by entering different values in the Label boxes.

**Tips:**

- To set default tick marks for a variable, which avoids making this change every time you run an analysis, see “Properties That Control the Display of Columns”.
- For additional axis customizations, select **Show Properties** from the axis right-click menu.

**Change the Orientation for Tick Labels**

To change the orientation for tick labels, select an option from the Label Orientation list.

- **Automatic**: Tick labels are oriented automatically to be readable, depending on the tick increment and length of the labels.
- **Horizontal**: Baseline at the bottom.
- **Vertical**: Vertical with the baseline on the right.
- **Perpendicular**: Horizontal for vertical axes and vertical for horizontal axes.

**Note:** Parallel and Perpendicular are useful with paired axes, like in Multivariate plots.

- **Parallel**: Vertical for vertical axes and horizontal for horizontal axes.
- **Angled**: Angled at about 45 degrees.

**Reference Lines**

Add reference lines to graphs:

1. Double-click a numeric axis. Or, right-click a numeric axis and select **Axis Settings**.
2. In the Value text box, enter the value to which you want the reference line to correspond. This is the position on the graph at which the line is placed.
3. Enter a Label for the line.
4. You can further customize the reference line by choosing either of these options:

   **Allow Ranges**  Enables you to enter a minimum and a maximum value, which define the beginning and the end of the reference line. The reference line appears over a range of data.

   **Line Color**  Changes the line color. You can also specify the opacity.

   **Line Style**  Specifies the line style (when Allow Ranges is not selected). You can also specify the line width.

   **Font**  Enables you to adjust the font for the reference line label.

   **Label Position**  Enables you to select a position for the reference line label. Options are outside or inside the graph frame.

   **Label Axis Side**  Enables you to select the side of the graph for the reference line label.

5. Click **Add**. The value moves into the box to the right of the Add button, indicating that it will be placed on the graph. Your changes appear in the Preview window.

6. To add more lines, repeat the above steps.
7. To change an existing reference line, make your changes, and then click **Update**.

**Tip:** To set a default reference line for a variable, which avoids making this change every time you run an analysis, see “Properties That Control the Display of Columns”.

### Extend Divider Lines and Frames for Categorical Axes

Extending the vertical divider line(s) between tick labels is useful when there are many levels of a nominal or ordinal (categorical) variable.

To extend the divider line to the x-axis labels, follow these steps:

1. Double-click a nominal or ordinal axis to show the axis settings.
2. Select **Show Tick Marks > Short Divider of Show Tick Marks > Long Divider** to add the divider lines, or **Lower Frame** to add a frame around the axis area.
Add and Remove Axis Labels

You can add or remove labels in a numeric axis. To add an axis label:

1. Right-click a numeric axis and select **Add Axis Label**.
2. Enter a name for the axis label. The axis area enlarges to hold the number of label lines that you enter.

This command can be used multiple times to add multiple labels. To edit the label after it has been added to the axis, click it and it will turn into an edit box.

To remove an axis label, right-click a numeric axis and select **Remove Axis Label**. The last label added is removed.

Rotate Axis Labels and Tick Marks

You can change the axis label on any axis type.

To rotate an axis label, follow these steps:

1. Double-click an axis to show the axis settings.
2. From the Label Orientation list, select which direction to rotate the text.

**Tip:** To set a default axis label position for a variable, which avoids making this change every time you run an analysis, see “Properties That Control the Display of Columns”.

You can rotate tick marks on a nominal axis by right-clicking the tick label and selecting **Rotated Tick Labels**.
Copy and Paste Graph Contents

After customizing a graph by adding elements such as a fitted line, you can copy and paste the contents from one graph to another compatible graph:

1. Right-click the graph that you have customized.
2. Select Edit > Copy Frame Contents.
3. Right-click the graph to which you would like to copy the settings.
4. Select Edit > Paste Frame Contents.

Tip: If you are having difficulty pasting histogram bars, see the JSL workaround the Scripting Guide.

Copy and Paste Axis Settings

After customizing an axis (as described in “Customize Axes and Axis Labels in Graphs”), you can copy and paste your new settings to another axis:

1. Right-click the axis that you have customized.
2. Select Edit > Copy Axis Settings.
3. Right-click the axis to which you would like to copy the settings.

Tip: To broadcast the axis settings to multiple graphs, press Ctrl when you right-click the axis and select Edit > Paste Axis Settings.

Change the Order of Values in Reports

Data in a JMP report might not appear in the order that you prefer. To give data a specific order so that it appears that way in a report, assign the column the Value Order property before running the analysis, as described in “Value Order”.

If your values include any of the following, they automatically appear in the appropriate order in reports:

- January, February, March, April, May, June, July, August, September, October, November, December
- Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
- Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
- Very Low, Low, Medium Low, Medium, Medium High, High, Very High
- Strongly Disagree, Disagree, Neutral, Indifferent, Agree, Strongly Agree
• Failing, Unacceptable, Very Poor, Poor, Bad, Acceptable, Average, Good, Better, Very Good, Excellent, Best

**Change the Pattern and Format of Selected Objects in Graphs**

In JMP graphs, patterns appear on some objects such as bars and maps when you select them. You can change the pattern for a specific object in the legend.

Right-click the item in the legend and select **Fill Pattern** to select a new pattern.

To remove the pattern, right-click the item again and select **Revert**.

**Change the Format of Selected Objects in All Graphs**

Select **File > Preferences > Graphs** (Windows) or **JMP > Preferences > Graphs** (macOS) to change the Filled Areas preferences.

• To change the highlight on selected objects, select one of the following Filled Selection Mode preferences:

  - **Selected Patterned**  Striped pattern (the default setting)
  - **Selected Darker**  Solid darker color
  - **Selected Outlined**  Outline
  - **Selected Same Color**  The Fill Selection Color in the preferences formats the selected object.

• To change the color of selected rows in graphic objects when the Fill Selection Mode is “Selected Same Color”, click the Fill Selection Color bar. The default color is red.

**Add a Graph to a Data Table**

You can add a JMP graph to a new JMP data table. Right-click a graph and select **Edit > Make table of graphs like this**. The graph and the variables appear in a new data table. You then resize the row and column to enlarge the graph.
Customize Markers, Lines, Text, and More in Graphs

JMP graphs consist of markers, lines, text, and other graphical elements that you can customize. For example, in a Scatterplot Matrix graph, you might want to highlight data points in one of the bivariate graphs with a pink solid marker. In a Contour Plot graph, you can increase the width or transparency of the contour lines.

Example of Customizing a Contour Plot

1. Select Help > Sample Data Folder and open Little Pond.jmp.
2. In the Table panel, click the green triangle next to the Contour Plot script.
3. Click the red triangle next to Contour Plot for Z and deselect Fill Areas.

Figure 9.33 Contour Plot before Customization
4. Right-click the plot and select **Customize**.
   The Customize Graph window appears.

5. Click **Shape**.

6. Change the **Line Width** to 2.0.

7. Click the color next to **Line Color** and select a shade of green.

8. Click **OK**.

**Figure 9.34** Customized Contour Plot

The graphical elements that you can customize differ on each graph. For example, in a Control Chart graph, there are three line elements (Lower Limit, Upper Limit, and Connect Line). In other graphs, the line element might be named Line or Custom.

To customize graphical elements in the current graph, follow these steps:

1. Right-click the graph and select **Customize**.

2. Select the element that you want to change, and then update the properties.
   Your changes are immediately shown on the graph.

3. Click **OK** to save your changes to the current graph.

**Note:** The Customize settings do not override those shown in the legend. For example, if you set the fill area in a bar chart to red, and the legend is blue, the legend will remain blue.

Each element can include properties for line color, marker style and size, text style, and so on. Here are some common properties:

**Line Color**  Changes the color of the line. Click to select any color in the window. Right-click to choose from more colors.
Line Style  Changes the style of the line. Click to select one of five different styles.

Line Width  Changes the width of the line. Click in the box and enter the desired line width in points.

Marker  Changes the marker shape. For more information about markers, see “Use Markers in JMP Graphs”.

Marker Size  Changes the size of the marker.

Arrow  Adds an arrowhead to a line at either None, Start, End, or Both ends of the line.

Line of Fit  Changes the color, width, or style of the line.

Text Color  Changes the color of the text.

Font  Changes the font, style, and point size of the text.

Text Style  Changes the text alignment to centered, left-aligned, or right-justified. The Fill option applies the selected color to the background.

Fill Color  Changes the color of objects such as box plots and Fit Confidence regions.

Fill Pattern  Changes the pattern of filled objects.

Transparency  Changes the marker or label transparency. Enter the level of transparency to draw markers (points) on the graph. The degrees of opacity ranges from 0 (clear) to 1 (opaque). For more information about changing the transparency of markers, see “Specify the Transparency of Markers”.

Clip Shape  Crops the object (such as contours) around the boundary according to the selected Clip Shape. The display segs that make up the object then conform to the boundaries of the map. Select a sub-boundary to display the objects only over a portion of the boundary. For example, you might want to display the objects only over New York.

About Clip Shape Options

Graphical elements (display segs such as reference, grid lines, and contours) can be clipped to conform to the boundaries of a geographical map. The Customize Graph window provides Clip Shape options, where you can select a boundary around which to clip the shape. Figure 9.35 shows reference lines clipped around a map of the United States.
Figure 9.35 Unclipped (Left) and Clipped (Right) Reference Lines

Tips:

• See Essential Graphing for an example of creating the maps shown in Figure 9.35.
• The Clip Shape option in the Customize window was also set to clip the contours to the boundaries of the map. See “Clip Shape”.
• Scripting provides additional options such as specifying the clipping path in a matrix or string. See the Scripting Guide.

Create Scripts for Graphical Elements

In addition to customizing graphical elements, you can write JSL scripts that add elements. These scripts run when you display the graph. You can write the scripts from scratch, or you can select from the following lists of commands and scripts, accessed by clicking on the Add a new script button:

• Use the Templates list to insert a single JSL command. For example, the Polygon option inserts the Polygon command. The text enclosed in underscores are placeholders for point values, which you replace with your own values.

```
Polygon([_x0_, _x1_, ...], [_y0_, _y1_, ...]);
```

• Use the Samples list to insert a script that creates elements such as bubble plots and sine waves. In this list, the Polygon sample script shows examples of the Transparency, Fill Color, and Polygon values, which you replace with your own values.
In some graphs, you can view the JSL that creates graphical elements. Figure 9.37 shows the Group Label script for a Discriminant Analysis graph. The script defines markers and text for group labels. The commands included in these built-in scripts cannot be modified or deleted. You can insert commands from the Templates or Samples list, but you cannot click in the window and type new commands.

Figure 9.37 Example of JSL That Creates Group Labels

For information about JSL, see the Scripting Guide and the JSL Syntax Reference.

To create a graphics script, follow these steps:

1. Right-click the graph and select Customize.
2. Click the Add a new script button (.addButton) to create a new script.
   The default name, Script, is highlighted.
3. With the default name highlighted, type a more descriptive name, and then press Enter. (If you already moved the cursor and the name is no longer highlighted, double-click Script, and then enter the new name.)
4. Do one or more of the following:
   - Enter JSL in the Properties window.
– Select one or more JSL commands from the Templates list, and change the placeholder text. For example, change the Pen Color option from “blue” to “red.”
– Select one or more sample scripts from the Samples list and update, if necessary.

5. (Optional) Click **Apply** to update the graph with your changes without closing the window. Unlike other property changes, script changes to not take effect until you click **Apply** or **OK**.

6. Click **OK** to save your changes.

One of the following occurs:
– The element that you created appears on the graph.
– An error message appears if the script contains an error. Select **View > Log** to read about the error, and then correct the script.

To delete a script that you created, select the script and then select the **Delete selected object** button ( ).

**Change the Drawing Order of Graphical Elements**

The graphical elements are drawn in the order in which they are listed. The first element on the list is drawn first, so it appears **behind** all other graphical elements. If one element hides another, you can rearrange the order of the elements.

*To rearrange graphical elements*

1. Right-click the graph and select **Customize**.
2. Select the element that you want to move.
3. Click the **Move up in drawing order** button ( ) or **Move down in drawing order** ( ) button one or more times until the elements are in the order in which you want them drawn.
4. Click **OK**.

**Save Your Customizations**

The graph customizations apply to the current graph and are also used when you redo an analysis. To re-create your graph at a later time with its customizations, select **Save Script** from the red triangle menu, and then select one of the Save options. For example, you can save the script to the data table, which applies your customized properties each time you run the script. See “Save a JMP Analysis as a Script”.
Copy Your Customizations

You can copy your customizations from one graph to another. All objects that you created or modified, such as colored text or lines, are pasted to the other graph.

To copy lines from one graph to another, see “Copy and Paste Graph Contents”.

To copy other objects

1. Right-click in the graph with custom elements and select Edit > Copy Customizations.
2. Right-click in the destination graph and select Edit > Paste Customizations.

The objects appear on the current graph and are added to the list of customized elements.

Notes:

• The customizations are pasted into all similar graphs when you press Ctrl, click, and then paste.
• The copy customizations feature copies only the elements that you added or modified. It does not copy the other contents of the graph.

Add Images to a JMP Graph or Report

To enhance your analyses with logos and other types of graphics, paste or drag and drop graphics into the graph or report. .bmp, .emf, .jpeg, .png, and .rtf graphic formats are supported.

• “Paste a Background Image into a JMP Graph”
• “Paste an Image at the End of a JMP Report”
• “Drag and Drop an Image into a JMP Graph”
• “Add Geographical Images and Boundaries to JMP Graphs”
• “Extract Data from an Image”

Paste a Background Image into a JMP Graph

1. Open the graphic file in a graphics program and select the graphic. Copy it to the computer’s clipboard.
2. Right-click inside a graph.
3. Select Edit > Paste Background Image. The graphic is inserted at the point in the graph that you right-clicked.
Paste an Image at the End of a JMP Report

You can add a graphic to the end of a JMP report window. Copy the graphic from a graphics program onto your computer’s clipboard, display the report window, and select Edit > Paste.

Drag and Drop an Image into a JMP Graph

To add an image that you created, generate your report and then drag and drop the image from your computer’s file system onto the graph in the report. After you add the image, JMP provides several options such as resizing, formatting, and rotating an image. Right-click the image and select Image to see these options.

The following example shows a bivariate plot of wind speeds in the Chicago area. The plot on the left includes arrows to illustrate the wind direction and speed. A map image was dropped onto the plot and resized to line up the markers with the stations that provided the wind data (each dot representing a station).

**Figure 9.38** Example of a Custom Map Image

Image Processing

JMP includes a variety of image processing options. Image processing includes filters that can sharpen, blur, resize, and enhance. JMP also allows flipping, rotating, and locking images. This section describes the processing options.

Notes:

- Repeated changes to images can degrade the image quality. If you are not happy with the results of sizing, scaling, or applying filters to the image, remove the image and start again.
- All JMP image filters are supported at the operating system level; images might be processed differently on Windows and macOS.
Lock

Locks the image in place so that it cannot be moved.

Size/Scale

- **Fill Graph**: Resizes the image proportionately to fit the graph.
- **Specify Size**: Resizes the image according to the values that you enter. (The units for these values are the same as your graph axes.)
- **Crop**: Crops the image according to the values that you enter. (The units for these values are the same as your graph axes.) For example, the left edge might be positioned at 50. You enter 60 next to Left, and the portion of the image between 50 and 60 is removed from the image.

Flip

- **Flip vertical**: Flips the image top to bottom.
- **Flip horizontal**: Flips the image left to right.
- **Flip both**: Flips the image both horizontally and vertically.

Rotate

Rotates the image the specified number of degrees. Enter a negative value to rotate the image counterclockwise.

Transparency

Changes the image transparency level. Enter a value between 0 and 1 (where 1 is completely opaque).

Filter

Provides filters found in many graphic editing programs to change the appearance of the image. Select a filter repeatedly to increase its effects on the image.

- **Contrast**: Optimizes the light and dark colors. Larger values lighten the image.
- **Despeckle**: Removes pixels that do not blend with surrounding pixels. For example, a black pixel surrounded by white pixels is converted to a white pixel.
- **Edge**: Darkens everything but the outlines of objects.
- **Enhance**: Reduces the contrast between pixels in a noisy image.
- **Gamma**: Balances the brightness of an image and the red, green, and blue (RGB) ratios. Larger values create a lighter image.
• **Gaussian Blur**: Blurs pixels by the specified radius. Larger radii create a smoother image. (In JSL, you can also specify the sigma value. Larger sigma values create a smoother image.)

• **Median**: Replaces each pixel color value with the median value of the surrounding pixels.

• **Negate**: Converts each pixel to its complementary color (such as pink to green and white to black).

• **Normalize**: Removes a percentage of the top and bottom color values. The color values are then stretched to fill the remaining image. This process increases the intensity of the colors.

• **Reduce Noise**: Finds the minimum and maximum color values and replaces them with values more consistent with the surrounding pixels. Larger values create a smoother image.

• **Sharpen**: Makes the edges of pixels more distinct.

**Remove**

Removes the image from the report.

### Add Geographical Images and Boundaries to JMP Graphs

Adding map images and political boundaries to graphs provides visual context to geospatial data. For example, you can add a map to the graph that displays an image of the U.S. Another option is displaying the boundaries for each state (when data includes the latitudes and longitudes for the U.S.).

The data should have latitudinal and longitudinal coordinates. Otherwise, the map has no meaning in the context of the data. The x and y axes also have range requirements based on the type of map. These requirements are described in the following sections.

Two tools are especially helpful when you are viewing a map:

• The grabber tool (_drag_ ) lets you scroll horizontally and vertically through a map.

• The magnifier tool ( _magnifying glass_ ) lets you zoom in and out.

For more information about adding maps, see *Essential Graphing*. 
Extract Data from an Image

JMP provides the ability to extract information from images into a data table and then analyze that information. Researchers at WildTrack.org analyze digital footprint photos in JMP to track endangered species. They drag and drop a footprint image into a JMP report and draw data points to capture the size and shape of the print. A JMP Scripting Language (JSL) script extracts those measurements into a data table. At that point, the researchers can analyze the data and determine whether the footprint is from a new animal. This method helps them track populations of endangered species in specific regions of the world.

Figure 9.39 Example of Extracting and Analyzing Data

Analysis shows that the footprint above is from a tiger whom WildTrack has already cataloged.

The details for implementing this feature are beyond the scope of Using JMP, because the needs of the user vary widely. For more information about writing JSL scripts, see the Scripting Guide and the JSL Syntax Reference.
Add Annotations and Shapes to JMP Reports and Graphs

You can add text notes, lines, polygons, ovals, and rectangles to a report or graph using graphics tools found in the toolbar.

Add Annotations to JMP Reports or Graphs

You can add editable text notes to a JMP report or graph using the annotate tool. To add an annotation:

1. Select the annotate tool from the Tools menu or toolbar.
2. In the report or graph, click where you want to add the annotation. Or, click and drag to size the annotation note. A white editable text box appears.
3. Enter text.
4. Click outside the annotation.
5. (Optional) To add a tag line, right-click the annotation and select Tag Line.

You can also edit any of the following options:

- **Background Color** Select the background color for the annotation.
- **Text Color** Select the text color. The color of the text also defines the color of the annotation outline.
- **Font** Change the font type, style, and size. To change the default font, see “Preferences for File Locations”.
- **Tag Line** Draws a line between the annotation and the point or text it is anchored to.
- **Filled** Removes the background color from the annotation so that it looks transparent. A transparent note is handy for putting titles and footnotes on a graph.
- **Editable** Makes the annotation editable by double-clicking on it.
- **Fixed Size** Avoids resizing the annotation box when you add text to the box.
- **Reanchor** (Available only when the annotation is moved.) Annotations are anchored to a location within the report, but can be moved around independently of the anchor location. The behavior of an annotation depends on the anchor position. For example, annotations anchored inside a graph move with the axes, and annotations anchored inside an outline show or hide when the outline is opened or closed. To reanchor an annotation, turn off the tag line, move the annotation to a new location, and right-click to reanchor it.
**Delete**  Deletes the entire annotation.

**Note:** When adding multiple annotations, press Shift when selecting the annotation tool for the first time. This causes subsequent clicks to add an annotation, and you do not have to select the annotate tool from the toolbar before the addition of each annotation.

Once you have added an annotation, you can do the following:

**Table 9.3** Using Annotations

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to or edit an annotation</td>
<td>Click inside the text box.</td>
</tr>
<tr>
<td>Move an annotation</td>
<td>Click inside the annotation box and drag it. When an annotation is moved, it becomes selected, as indicated by a double blue line with handles around the perimeter.</td>
</tr>
<tr>
<td>Resize an annotation</td>
<td>Place the cursor on the handle of a selected note (showing in the middle of the edges and in the corners). The cursor appears as a single crossed arrow; drag to resize the annotation.</td>
</tr>
<tr>
<td>Delete an annotation</td>
<td>Highlight the annotation by clicking the handle of a note and then press Delete or Backspace.</td>
</tr>
</tbody>
</table>
| Move an annotation’s tag line       | 1. Right-click the annotation and deselect **Tag Line.**  
2. Drag the annotation to where you want the tag line to start (the attachment point).  
3. Right-click the annotation and select **Tag Line.**  
   The tag line now starts at the point where you moved the annotation.  
4. Move the annotation where you want it to appear. |
| Move the tag line with the annotation | Press Ctrl and drag the annotation to move the tag line endpoint with the annotation.                                                       |

**Add Shapes to JMP Reports**

You can add editable lines, polygons, and simple shapes (ovals or rectangles) to a JMP report using the drawing tools 📝 🗝️ 🖋️. The following sections describe how each of these tools can be used.
Note: Each graphics tool remembers the most recent options chosen. This is useful if you need many annotations or other graphics with the same characteristics. For example, suppose you want many thick green lines with an arrow on one end. Create a line the way you want it, set the options, and subsequent lines appear with those options in effect. The options persist until you change them.

Add a Line

Add a line annotation to a report window, follow these steps:

1. Click the line tool in the tool palette.
2. Click and drag where you want to insert the line. The line appears selected, showing handles on both ends.
3. Click and drag the line to move it.
4. Click a handle and drag to rotate the line.
5. Right-click a line for options to customize the appearance of the line:
   - **Point to and Point from** Places arrows on either end (or both ends) of the line.
   - **Thick** Changes the width of a line to thick. Lines are thin by default.
   - **Dashed** Changes the line to dashed. Lines are solid by default.
   - **Color** Displays the JMP color palette to change the color of the shape.
   - **Reanchor** Line annotations are anchored to a location within the report but can be moved around independently of the anchor location. The behavior depends on the anchor position. For example, line annotations anchored inside a graph move with the axes, and line annotations anchored inside an outline show or hide when the outline is opened or closed. To reanchor a line annotation, move the line to a new location and right-click to reanchor it. Available only when the annotation is located outside the graph.
   - **Delete** Removes the shape from the report surface. You can also remove the shape by selecting it and then pressing Delete or Backspace.

Add a Polygon or Bezier Curve

To add a polygon (or Bezier curve) annotation to a report window, follow these steps:

1. Click the polygon tool in the tool palette.
2. Click to create the beginning point for the first side of a polygon.
3. Click again at the location where you want to complete the first side and begin an adjacent side. A square selection box with handles appears around the polygon area.
4. Click a third time to complete the second side.
5. Continue this process until the polygon is the way you want it. Each time a side is complete, the selection box adjusts to encompass the polygon sides.
6. Double-click to release the polygon tool.

Once you have added a polygon, you can perform the following actions:

<table>
<thead>
<tr>
<th>Table 9.4 Working with Polygons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Action</strong></td>
</tr>
<tr>
<td>Select or deselect the polygon</td>
</tr>
<tr>
<td>Resize the polygon</td>
</tr>
<tr>
<td>Move the polygon</td>
</tr>
<tr>
<td>Change the number of sides of</td>
</tr>
<tr>
<td>the polygon</td>
</tr>
</tbody>
</table>

Right-click a polygon for options to customize its appearance:

- **Filled** Fills or empties the area of the shape.
- **Raised** Displays thick shaded lines around the shape. If the shape is also filled, the lower edge of the figure appears raised, giving it a three-dimensional look.
- **Smooth** Smooths the vertices of a polygon to produce a Bezier curve. The smoothed figure is reshaped and resized the same way as the polygon, and can be filled and raised.
- **Closed** Opens or closes the last segment of a polygon.
- **Color** Displays the JMP color palette to change the color of the shape’s sides, and its fill color when the **Filled** option is in effect.
- **Reanchor** Polygon annotations are anchored to a location within the report, but can be moved around independently of the anchor location. The behavior depends on the anchor position. For example, polygon annotations anchored inside a graph move with the axes, and polygon annotations anchored inside an outline show or hide when the outline is opened or closed. To reanchor a polygon annotation, move the polygon to a new location and right-click to reanchor it.
- **Delete** Removes the shape from the report. You can also remove the shape by selecting it and then pressing Delete or Backspace.
Add an Oval or Rectangle

To add an oval or rectangle annotation to a report window, follow these steps:

1. Click the simple shape tool \( \bigcirc \) in the tool palette.
2. Click and drag where you want to insert the shape. An oval appears with a selection box around it.
3. (Optional) To turn the oval into a rectangle, right-click the oval and select **Shape > Rectangle**.
4. Double-click to release the simple shape tool.

Once you have added the shape, you can do the following:

- Select the shape and drag one of the selection box handles to reshape or resize.
- Click and drag an edge of the selection box (located between the handles) to move it.
- Select the shape, and then right-click it for options to customize its appearance:

  - **Filled** Fills or empties the area of the shape.
  - **Raised** Displays thick shaded lines around the shape. If the shape is also filled, the lower edge of the figure appears raised, giving it a three-dimensional look.
  - **Shape** Displays a submenu whose options transform the shape into either an oval or a rectangle when selected.
  - **Color** Displays the JMP color palette to change the color of the shape’s sides and its fill color when the Filled option is in effect.
  - **Reanchor** Shape annotations are anchored to a location within the report, but can be moved around independently of the anchor location. The behavior depends on the anchor position. For example, shape annotations anchored inside a graph move with the axes, and shape annotations anchored inside an outline show or hide when the outline is opened or closed. To reanchor a shape annotation, move the shape to a new location and right-click to reanchor it.
  - **Delete** Removes the shape from the report. You can also remove the shape by selecting it and then pressing Delete or Backspace.

Customize Hover Labels in JMP Graphs

When you hover over a visual element in a JMP graph, usually you see a basic description of the data point in a hover label. Customize what appears in the hover label in any of these ways:
Add interactive graphs or images using **graphlets**.

Add formatted text using **textlets**.

Add, remove, or update names and values using **gridlets**.

Learn more about using the Hover Label Editor.

Add images from data tables.

Pin hover labels on graphs.

Format hover labels and access additional options.

---

<table>
<thead>
<tr>
<th>Action</th>
<th>See “Add Graphs or Images to Hover Labels”.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add formatted text using textlets.</td>
<td>See “Add Text to Hover Labels in JMP Graphs”</td>
</tr>
<tr>
<td>Add, remove, or update names and values using gridlets.</td>
<td>See “Update Names and Values in Hover Labels”.</td>
</tr>
<tr>
<td>Learn more about using the Hover Label Editor.</td>
<td>See “Edit Hover Labels in JMP Graphs”.</td>
</tr>
<tr>
<td>Add images from data tables.</td>
<td>See “Add Images from JMP Data Tables to Hover Labels”.</td>
</tr>
<tr>
<td>Pin hover labels on graphs.</td>
<td>See “Pin Hover Labels in JMP Graphs”.</td>
</tr>
<tr>
<td>Format hover labels and access additional options.</td>
<td>See “Right-Click Options for Hover Labels”.</td>
</tr>
</tbody>
</table>

---

**Figure 9.40** Examples of Graphs, Text, Names, and Values in Hover Labels

Male patient, 19 years old, 25.3 BMI, has **Medium** disease progression (200).

Text created using textlets

Names and values updated using gridlets

Hover graph created using graphlets

---

**Add Graphs or Images to Hover Labels**

In JMP, you can add a thumbnail of a graph or an image to a hover label using graphlets.
Preset graphlets: Preset graphlets are predefined and editable. They are easy to add, simply right-click on a graph and select Hover Label > graph type, or you can add them from the Hover Label Editor.

**Note:** Graphs based on synthetic data (such as data used in simulations) that are not connected to a data table do not support preset graphs.

- Paste graphlet: Create a graph in Graph Builder. Copy the script by saving it to your clipboard, and then paste it as a graphlet into a baseline graph.

Once you add the hover graph, put your cursor over an element in the baseline graph. A thumbnail preview of the hover graph appears for that element. For example, for aggregate data, you can see a hover graph of the underlying data distribution.

Some JMP platforms have built-in hover label graphs, such as Principal Components, Process Screening, Model Driven Multivariate Control Charts, and Functional Data Explorer. You do not need to do anything to add these graphs to your visualizations. When you hover over them, the graph automatically appears in the hover labels.

You can also customize hover label graphs using JSL. For details, see the *Scripting Guide*.

**Hover Graph Actions**

- Click a hover graph to launch it in a new window, or click an image to open a related link.
- Press Ctrl and click on a hover label graph to replace the baseline graph with the hover label graph.
- Press Alt and click on a hover label graph to replace the contents of the last launched window, instead of opening a new one.

**Example of Adding a Preset Graph to a Hover Label**

In this example, you create a graph, add preset graphs to hover labels, and then customize the hover label graphs.

**Create the Original Graph**

1. Select Help > Sample Data Folder and open JMP Man Dozen.jmp.
2. Select Graph > Graph Builder.
3. Select X and Y and drag them to the Y zone.
4. Select Data Set and drag it to the X zone.
5. Click the Bar element .
6. For the Error Interval, select Standard Deviation.
You can see that the mean and standard deviation for these observations are the same, so this graph does not tell you much. Use preset graphs to get more insight into the data.

**Add Preset Graphs**

1. In the graph, right-click and select **Hover Label > Histogram**.
   
   This adds preset histograms to the hover labels.

2. Point to some of the bars. In this example, point to the red bars for dots and star.

   **Tip:** To make the hover label remain so that you can compare it with other hover labels, click the Pin icon in the top right corner. See “Pin Hover Labels in JMP Graphs”.

---

**Figure 9.41 Original Graph for JMP Man Dozen.jmp**
You can see that the distribution for the measurements is clearly different. But you want to see another type of graph, a scatterplot.

3. In the graph, right-click and select **Hover Label > Points**.
   
   This changes the preset graphs from histograms to scatterplots.

4. Hover over the blue bar for `down_parab` and the red bar for `down_parab`. Notice that the Y and X variables on the axes are reversed.

   You want to use the same X and Y role assignments for all graphs (assigning the X variable to the X axis, and the Y variable to the Y axis). You also want to change the smoother to a line of fit, and add a caption box with summary statistics to the scatterplot.

   You can customize a graph in Graph Builder and then copy the graph as a template and apply it to all of the hover labels in this graph.

**Customize Graphs**

1. Hover over the blue bar for `down_parab` and click the graph to open it in a new window.

   The graph opens in Graph Builder.

   **Note:** Notice that when you launch a preset graph, you see a Local Data Filter at left. You can use the Local Data Filter to expand and change the graph. For details, see “**Local Data Filters in JMP Reports**”. 
2. Click the Graph Builder red triangle and select **Show Control Panel**.
3. Click the Line of Fit element.
4. Click the Caption Box icon.
5. Under Caption Box, change the Summary Statistic to **5 Number Summary**.
6. Click **Done**.

**Figure 9.43** Customized Graph for down_parab

7. Click the Graph Builder red triangle menu and select **Save Script > To Clipboard**.
8. Close this Graph Builder window.
9. In your original graph, right-click and select **Hover Label > Paste Graphlet**.
   This applies the customized graph as a template to all hover label graphs. Hover over a few bars to see the changes.

**Tip:** To better compare original graphs and graphs launched from hover labels, use projects. See “Save and Share Your Data”.

**Example of Specifying Drill-Down Column Hierarchies in Hover Labels**

In preset graphs that use categorical columns, you can specify which columns to filter by.
Create the Original Graph

1. Select **Help > Sample Data Folder** and open San Francisco Crime.jmp. These data show crime statistics for police districts in San Francisco.
2. Select **Graph > Graph Builder**.
3. Select Police District and drag it to the X zone.
4. Click the Treemap element 
   
   You can see a treemap of the different police districts in San Francisco.
5. Right-click on the graph and select **Hover Label > Treemap**.
6. Put your cursor over Central to see the hover label graph.

**Figure 9.44** Initial Hover Label Graph for Central

The hover label graph is showing the number of incidents in each district by the day of the week. Instead, in this example, you want to see the number of incidents in each district by category.

Specify the Drill-Down Column Hierarchy

1. In the San Francisco Crime.jmp data table, right-click the Police District column heading and select **Column Properties > Next in Hierarchy**.
2. Under Next in Hierarchy, click Category.
3. Click OK.

4. Add a second level of the hierarchy that appears if the first hover label graph is launched:
   a. In the San Francisco Crime.jmp data table, right-click the Category column.
   b. Select Column Properties > Next in Hierarchy.
   c. Under Next in Hierarchy, click Incident Description.
   d. Click OK.

5. In Graph Builder, put your cursor over Central again to see the updated hover label graph.
Figure 9.46 Updated Hover Label Graph for Central

The hover label graph is now showing the number of incidents in each district by category.

6. Click the hover label graph to launch it.

7. Put your cursor over Other Offenses.
The second level of the hover label graph is showing the number of incidents in the Other Offenses category by the incident description.

**Example of Removing a Filter Column from a Hover Label Graph**

In some cases, the hover label graph might be filtering on a column that you want to remove. For example, the filter column might be too granular to be useful. You can remove it using the Hover Label Editor.

**Create the Original Graph**

1. Select Help > Sample Data Folder and open CrimeData.jmp.
   These data show crime rates for regions and states in the U.S.
2. Select Graph > Graph Builder.
3. Select Population and drag it to the Y zone.
4. Select Year and drag it to the X zone.
5. Select Region and drag it to the Overlay zone.
6. Click the Line element .
Figure 9.48 Mean Population Crime Rates by U.S. Region Per Year

This graph shows the mean population in each U.S. region that were impacted by different crime rates over different years. In the hover label graphs, you want to see a more granular view that shows the impacts by U.S state instead of region.

7. Keep this window open.

Copy and Paste a Graph

1. Click the Graph Builder red triangle and select **Redo > Redo Analysis**.
   A copy of the original graph appears.

2. In the copy of the graph, select State and drag it to the **Overlay** zone.
   This replaces Region with State.

3. Click **Done**.
4. Click the Graph Builder red triangle and select **Save Script > To Clipboard**.
5. Close this graph.
6. In the original graph, right-click and select **Hover Label > Paste Graphlet**.
7. Hover over the Pacific line and click to launch the hover label graph.
Because we are still filtering by year, this view is too granular to be useful. You want to remove the year filter, so the graph filters only by region.

8. Close the hover label graph for the Pacific region.

**Remove a Filter Column**

1. Right-click the original graph and select **Hover Label > Hover Label Editor**.
2. In the Graphlet window, click the **Filters** tab.
3. Select **Year**, the column you no longer want to filter by.
4. Click **OK**.

5. Hover over the Pacific line and click to launch the hover label graph.
You can see that the hover label graphs are no longer filtering by year, but by region only, creating a more useful visualization.

**Example of Displaying Multiple Images in a Hover Label**

For labeled columns, hover labels can contain an image from the first labeled image column and up to four values from labeled text columns. To show more labeled images or text observations, use the Label Viewer.

1. Select **Help > Sample Data Folder** and open Big Class Families.jmp.
2. Select **Graph > Graph Builder**.
3. Select weight and drag it to the **Y zone**.
4. Select height and drag it to the **X zone**.
5. Click the Bar element 🍂.
6. Hover over the bar for the height of 65 inches and click Pin 🪞.
Although five names are included in this bar, only the first image (Henry) appears in the hover label. You want to see more images in the hover label.

7. Right-click in the graph and select **Hover Label > Label Viewer**.
8. To see the additional image, in the hover label, click a thumbnail.
9. In the Label Viewer, click the Forward arrow to see the fifth image.

**Add Text to Hover Labels in JMP Graphs**

A textlet is a hover label extension that adds formatted text to a hover label in a JMP graph. You might use a textlet to describe data in an explanatory paragraph, or to call out important information by making it bold or drawing it in a different color.

**Example of Adding Text to a Hover Label**

**Create the Original Graph**

1. Select Help > Sample Data Folder and open Diabetes.jmp.
   These data show measurements for diabetes patients that track the progression of the disease.
2. Select Graph > Graph Builder.
3. Select LDL and drag it to the Y zone.
4. Select Age and drag it to the X zone.
5. Click the Line of Fit element.
6. Click Done.
7. Hover over the point in row 345.

Figure 9.55 Initial Hover Label for Content for Row 345

For the data point in row 345, you can see the row number, age of the person, and their LDL measurement. Change what appears in the hover labels:

- Add the patient’s level of disease progression in a sentence.
- Assign different colors to the levels of the disease progressions, based on severity.

Add Text
1. Put your cursor over the hover label for row 345 and click Pin.
   Pinning the hover label enables you to see your changes as you apply them.
2. Right-click in the graph and click Hover Label > Hover Label Editor.
3. On the left, click Textlet.
4. In the JSL Variables box, define the variables using JSL. Copy and paste the following JSL script:

```javascript
// gets the value for the Y Ordinal column for the underlying visual element
local:YOrdinal = As Column( "Y Ordinal" )[local:_firstRow];
// maps the value to HTML color names that are used to style the text
local:color = Match( local:YOrdinal, 
    "Low", "Medium Dark Green",
    "Medium", "Medium Dark Blue",
    "High", "Medium Dark Red" );
```

5. Under HTML Markup, write your text using HTML and the JSL variables that you just defined. Copy and paste the following code:

```
Patient has <font color='{local:color}'>{local:YOrdinal}</font> disease progression.
```

Figure 9.56 JSL Variables and HTML Markup for Textlet

6. Click **OK**.
You can see the new sentence appearing in the hover label indicating the level of disease progression. Since the disease progression for this patient is medium, it is color coded blue.

**Update Names and Values in Hover Labels**

When you hover over an element in a JMP graph (such as a point, bar, and so on), you see content in the hover label for that element. By default, the hover label contains name and value pairs that are in a grid. The value can come from the data table, or can be an arbitrary calculation or JSL expression. You can customize these names or values using gridlets. For example, here are some things that you can do:

- Remove a name and its associated value
- Add a name and its associated value
- Change a name
- Change the style of a name (for example, bold) or a value (for example, decimal places)
Tip: Another way to customize hover label grid entries is using labels. See “Add Images from JMP Data Tables to Hover Labels”.

Example of Updating Names and Values in a Hover Label

In this example, you create a graph and update content in the hover label using gridlets.

Create the Original Graph

1. Select Help > Sample Data Folder and open Movie Inventory.jmp. These data show movie rental data.
2. Select Graph > Graph Builder.
3. Select Length and drag it to the Y zone.
4. Select Year and drag it to the X zone.
5. Click Done.
6. Hover over the point in row 34 (Figure 9.58).

Figure 9.58 Initial Hover Label Content for Row 34

For the data point in row 34, you can see the row number, the year in which the movie was made, and the length of the movie (in minutes). Change what appears in the hover labels:

- Remove the row number and the length entry.
• Add the movie name and genre.
• Create a new entry that shows the length of the movie in hours and minutes.
• Make the genre name bold.

**Update Names and Values**

1. Hover over the hover label for row 34 and click Pin. Pinning the hover label enables you to see your changes as you apply them.
2. Right-click in the hover label and click **Edit**.
3. At left in the thumbnail, click **Row**.
4. In the Delete tab, click **Add**.
   “Row” appears under the entries to delete.
5. Click **Apply**.
   In the graph window, you can see that Row is removed from the hover label.

**Figure 9.59  Hover Label with Row Removed**

6. At left in the thumbnail, click **Length** (the other entry that you want to remove).
7. In the Delete tab, click **Add**.
   “Length” appears under the entries to delete.
8. Click **Apply**.

   In the graph window, you can see that *Length* is removed from the hover label, leaving only *Year*.

9. Add the movie name and genre:
   a. Click the **Append** tab. Type should be set to **Name**.
   b. Under Target, type *Name* (the name that you want to add).
   c. Under Value, copy and paste the following JSL expression: 

      ```
      :Name[[local:_firstRow]]
      ```

      *Name* is the column reference. Brackets indicate to get the corresponding column value for the given index. **local:_firstRow** is the index, which is a Hover Label Execution Context (HLEC) variable. For details, see the *Scripting Guide*.
   d. Click **Add** and then click **Apply**.

   In the thumbnail and in the graph hover label, you can see that the name of the movie is added.

**Figure 9.60** Hover Label with Name Added

e. Under Target, type **Genre** (the next name you want to add).

f. Under Value, copy and paste the following JSL expression:

   ```
   :Genre[[local:_firstRow]]
   ```

   g. Click **Add** and then click **Apply**.
In the thumbnail and in the graph hover label, you can see that the genre of the movie is added.

10. Convert the Length data from minutes to hours and minutes:
   a. On the Append tab, in the Target box, type Duration (the name of the new hover label that you want to add).
   b. Under Value, copy and paste the following JSL expression: `local:_Length * 60`
      `local:_Length` is an HLEC variable, with the value of the grid entry Length. Length is in the graph, so we have access to this value in the hover label context. For details, see the Scripting Guide.
      * 60 converts the duration from minutes to seconds. In order to apply the hours:minutes format, the duration needs to be in seconds.
   c. Click Add and then click Apply.
      In the thumbnail and in the graph hover label, you can see the Duration label is added. But the value needs to be formatted correctly.

Figure 9.61 Hover Label with Duration Added

d. Click the Reformat tab.

e. Under Target, type Duration (the name of the hover label entry that you want to reformat).

f. Click Edit.
g. Next to Format, select **Duration > hr:m** and then click **OK**.

h. Click **Add** and then click **Apply**.

On the hover label, you can see that the Duration is now in hours and minutes.

Figure 9.62 Hover Label with Duration in Hours and Minutes

11. Make the Genre values bold:

   a. Click the **Style** tab.

   b. Under Target, type **Genre** (the name of the hover label entry that you want to make bold).

      Notice that Scope is set to **Values**. This bolds the Genre values instead of the name Genre.

   c. Click **Font**.

   d. Under Font style, click **Bold** and then click **OK**.

   e. Click **Add** and then click **Apply**.

      On the hover label, you can see that the Genre value, Romance, is now bold.
Figure 9.63 Hover Label with Genre Value in Bold

Hover over the other labels to see that they are all updated.
Use Labels in Data Tables

In addition to gridlets, you can also do some basic customization of hover labels by adding Labels to columns in data tables.

- If your hover label contains a Row entry, you can replace it with values in columns by adding a Label.
- Once you add a Label, you can make it persist on the graph. You can also move the label’s location on the graph. A tag line might be added to connect the label to its point.

Example Using Labels in Data Tables

1. Select Help > Sample Data Folder and open Iris.jmp.
2. Select Graph > Graph Builder.
3. Select Sepal length and drag it to the Y zone.
4. Select Sepal width and drag it to the X zone.
5. Click Done.
6. Hover over the point in row 109.
Figure 9.65 Hover Label for Row 109

You can see that a Row entry appears in the hover label. You want to replace it with a column and its value from the data table called Species.

7. In the data table, right-click the Species column and select Label/Unlabel.

A label icon appears beside the column name in the Columns panel.

8. In Graph Builder, hover over the same data point.

Figure 9.66 Hover Label Showing Species Column

You can see that the Row entry is replaced by the Species column.

Note: If you specify multiple labeled columns, their values appear alphabetically in the hover label.

Now, you want to make some of the labels persist on the graph.
9. Click the same data point to highlight it.
10. Right-click anywhere and select **Rows > Row Label**.

**Note:** In a histogram, right-click the box plot area on the right.

**Figure 9.67** Species Label Showing on Graph

![Species Label Showing on Graph](image1)

You can see that the label containing the Species value for this data point appears on the graph.

11. Click and drag the label to move its position.

A tag line is added to connect the label to the point.

**Figure 9.68** Reposition the Species Label

![Reposition the Species Label](image2)

In the data table, a label icon 📋 appears beside the row number.
Data remains labeled until you highlight the column or row and select Label/Unlabel again.

**Edit Hover Labels in JMP Graphs**

Use the Hover Label Editor to customize and add graphs, images, formatted text, names, and values in hover labels.

*To interactively edit hover labels*

1. In a graph, hover over data to show a hover label.
2. In a hover label, right-click and select **Edit**.

In the Hover Label Editor, a thumbnail of the hover label appears at left. Click an area in the thumbnail to edit it at right. Changes that you make apply to all hover labels in the graph.

**Figure 9.69** Interactively Edit a Hover Label

![Hover Label Editor](image)

In this example, the Incident Address data is clicked and the Delete tab appears, so you could delete the Incident Address entry from all hover labels in the graph. You could also rename it, reformat it, or change the font style.

To add or edit hover labels generally, launch the Hover Label Editor. Right-click on a graph and select **Hover Label > Hover Label Editor**.
**Figure 9.70 Hover Label Editor**

On the left, you can choose **Textlet**, **Gridlet**, or **Graphlet**, depending on what you want to do in hover labels:

- **Textlet**  Add formatted text to hover labels using JSL. For an example, see “Example of Adding Text to a Hover Label”. For details about this window, see the *Scripting Guide*.

- **Gridlet**  Delete, add, rename, reformat, or choose a style for names and values that appear in hover labels. For an example, see “Example of Updating Names and Values in a Hover Label”. For details about this window, see “Gridlet Tabs”.

- **Graphlet**  Add an interactive graph or image to hover labels. For an example, see “Example of Adding a Preset Graph to a Hover Label”. For details about this window, see “Graphlet Tabs”.

**Textlet Tabs**

- **Markup**  Define HTML markup used to create rich text on the hover label.

- **Presets**  Examples of a preconfigured textlet.
  
  - The Showcase textlet is an example of how to add color and style to the textlet content based on the underlying data. “Add Text to Hover Labels in JMP Graphs” for an example.
  
  - The Tabulate textlet is an example of how to add summary statistics for the underlying data to the textlet content.

  - The Context textlet is an example of how to display the evaluation context variables in the textlet (for debugging purposes). Evaluation context variables define the environment in which your graphlet and textlet scripts are executed. See the *Scripting Guide* for details.
**JSL Variables**  (Optional) Enables you to assign the result of expressions to local JSL variables. The variables are used in the HTML Markup field to create dynamic, data-driven rich text.

**HTML Markup**  Specifies a rich text paragraph template based on a subset of HTML tags. The markup can contain JSL variable references enclosed in delimiters. The default delimiters are braces ({}). Table 9.5 describes the supported HTML tags:

### Table 9.5 Supported HTML Tags in Textlets

<table>
<thead>
<tr>
<th>HTML Tag</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;b&gt; &lt;/b&gt;</code></td>
<td><strong>bold text</strong></td>
</tr>
<tr>
<td><code>&lt;i&gt; &lt;/i&gt;</code></td>
<td><strong>italicized text</strong></td>
</tr>
<tr>
<td><code>&lt;u&gt; &lt;/u&gt;</code></td>
<td><strong>underlined text</strong></td>
</tr>
<tr>
<td><code>&lt;font&gt; &lt;/font&gt;</code></td>
<td><strong>stylized font</strong> with any of the following attributes:</td>
</tr>
<tr>
<td></td>
<td>• <code>color=color</code>: The quoted foreground color value. Can be a color name or a hexadecimal RGB color value.</td>
</tr>
<tr>
<td></td>
<td>• <code>face=family</code>: The quoted name of an installed font family.</td>
</tr>
<tr>
<td></td>
<td>• <code>size=size</code>: The quoted font size.</td>
</tr>
<tr>
<td><code>&lt;background&gt; &lt;/background&gt;</code></td>
<td><strong>background color value</strong></td>
</tr>
<tr>
<td></td>
<td>• <code>color=color</code>: The quoted color name or hexadecimal RGB color value.</td>
</tr>
</tbody>
</table>

**Other**  Specify the delimiters and width of text on the hover label.

**Delimiters**  Select the delimiter that indicates variables for replacement in the Markup area. For example, you might use square bracket delimiters for JMP variables if the script contains C++ code or other code that also uses braces.

**Width**  Specify the preferred width in pixels for the hover label.
Note: After you make changes to the textlet configuration, you can click Apply to see your changes on a pinned hover label. When you are satisfied with the updated hover label, click OK to save your changes.

Gridlet Tabs

Gridlet tabs include Delete, Append (add), Rename, Reformat, and Style. In all of these tabs, you specify the Matching Criteria, which identifies the hover label entry that you want to change.

Type and Target

Matching Criteria Specify the hover label entry that you want to change:
Choose the type of entry to select and the target entry.

Note: Not all choices appear in all tabs.

Name Enter the exact name of the entry that you want to change. For example, if the entry name is Mean(height), enter this target value: Mean(height).

Figure 9.71 Hover Label Example

| name: JEFFREY X |
|-----------------
| weight: 113 |
| Mean(height): 69.0 |

Index Enter the index of the entry in the grid that you want to change. For example, if the third entry in the hover label is Mean(height), enter 3 as the Target value.

Column Enter the column name of the entry that you want to change. For example, if the entry is Mean(height), enter this target value: height.

Regex Enter a regular expression matched against the name that you want to change. For example, if the entry is Mean(height), enter this target value: ^.*\(height\)$ (The Pat Regex, parenthesis, and quotations are automatically added.)

All Changes the style for all hover label entries.

Gridlet Buttons

Add Adds a specified Target value under Entries. Click Apply to apply your changes to the hover label.

Remove Removes a specified Target value under Entries. Click Apply to apply your changes to the hover label.
**Replace**  Replaces a selected Target value under Entries. Click an entry, enter a new target value, and click Replace. Click Apply to apply your changes to the hover label.

**Gridlet Tabs**

**Delete**  Specify entries to delete from hover labels.

*Note:* If you are using JSL, Delete is the Expunge command.

**Append**  Specify entries to add to hover labels.

**Value**  Specify the JSL to add the value to the hover label. For an example, see “Update Names and Values”.

**Click**  Add an action to the entry that will appear as a link. Specify the script to be executed when the link is clicked. For example, the script can create a visualization, open a web page, or launch a platform. Here are a few ways that you can copy and paste a script:

Create a visualization to link to: In Graph Builder, create the visualization that you want. Click the Graph Builder red triangle menu and select Save Script > To Clipboard. Paste the script under Click.

Link to a preset graph: In Graph Builder, from the underlying graph that has the preset hover label graphs, right-click > Hover Label > Hover Label Editor. Under Graphlet, in the Picture tab, copy the script. Paste the script under Click.

Click **Apply** to apply your changes to the hover label.

*Note:* If you are using JSL, Append is the Annex command.

**Rename**  Specify entries to rename in hover labels. Enter a new name to replace the current Target value.

**Reformat**  Specify a different format for entry values in hover labels. For example, you can change the date or duration format, or change the number of decimal points. Click **Edit** to choose a different format. For details about the Edit options, see “Numeric Format Options”

**Style**  Specify a background color, text color, or font details (such as bold, and so on) for entries in hover labels.

**Scope**  Specify if the style updates should be made to the names of the entries, the values, or both. For example, if you are applying a style change to all the matching criteria, you can easily align all the names to the left, or all the values to the right.
**Background color**  Specifies the background color for the Target value, name, or both in hover labels.

**Text color**  Specifies the text color for the Target value, name, or both in hover labels.

**Font**  Specifies font details, such as font, font style, and size for the Target value, name, or both in hover labels.

**Alignment**  Specifies how to align the text for the Target value, name, or both in hover labels.

### Graphlet Tabs

**Presets**  Click a preset graph to add it to hover labels. For details about preset graphs, see “Add Graphs or Images to Hover Labels”.

**Picture**  Add a JSL script to define the type of graph or image to add to hover labels.

**Click**  Add a JSL script that is executed when a user clicks on the thumbnail (or hover graph) that is defined by the Picture script. If nothing is defined here, the Picture script is reused, so that the image or graph defined under Picture is launched in a new window.

**Filters**  Remove a filter column from your hover graph. Click a column that you want to remove, or add a “1” under Skip Filters Flag. See “Example of Removing a Filter Column from a Hover Label Graph”.

**Thumbnail**  Specify the size of the graph thumbnail and whether to include axis values.

**Other**  Use JSL to specify the following information:

- **Title**  Sets the title of the new window that is created when a hover graph is launched.

- **Reapply**  Defines whether the current hover label graph customizations are applied to a new window launched when clicking on a hover graph.

### Add Images from JMP Data Tables to Hover Labels

You can add images to hover labels using graphlets, but you can also add them from a JMP data table.

**Tip:** For details about adding JMP graphs or images using graphlets in a hover label, see “Customize Hover Labels in JMP Graphs”.

1. Create a new column in your data table.
2. Right-click the column, select **Column Info**, and select the **Expression** data type.
3. Click **OK**.
4. Drag graphics from your computer into each cell of the column. You can also import data that contains a column of images.

5. Right-click the column in the data table and select Label/Unlabel to apply a label.

6. Create a graph using your data table (for example, in Graph Builder or Distribution).

7. Hover over a data point or a histogram bar.

   The image appears on the label. To see an example, run the Graph Builder script in the SAS Offices.jmp sample data table.

**Figure 9.72 Image on Hover Label**

![Image on Hover Label](image)

**Tips:**

- Images in an expression column can also be used as markers. See “Use Images as Markers”.

- You can pin the hover label so that the label always appears on the graph. See “Pin Hover Labels in JMP Graphs”.

**Pin Hover Labels in JMP Graphs**

When you hover over data on a JMP graph, a hover label that contains data values appears. You can pin the hover label so that it always appears on the graph as a label. This is helpful if you want to compare several labels, or if you want to show the label information. When you save the graph, the label is saved. When you print the graph, the label is printed.
Note: The hover label remains pinned after you redo an analysis. However, if the data changed, you might have to reposition the label.

Figure 9.73 Pinned Hover Labels

To pin a hover label, hover over the data point until the label appears. Click the pin icon in the upper right corner of the label. You can then drag the label to reposition it.

Right-Click Options for Hover Labels

- **Background Color** Applies the selected color to the label background.
- **Frame Color** Applies the selected color to the label border and tag line.
- **Text Color** Applies the selected color to the text.
- **Filled** Applies the background color and frame color to the label. Selected by default.
- **Use Gradient** Shades the background color vertically from light to dark. Selected by default.
- **Font** Applies the selected font family to the text. The default font is determined by your JMP Font preferences.
  
  If a script with a pinned label refers to a font that is not on the computer, the script does not run.
- **Add Text** Adds text to the bottom of the label.
- **Replace Text** Change the text on the tooltip. If you redo the analysis, the tooltip text remains updated.
- **Tag Line** Draws a line between the label and the data point. The Frame Color is applied to the line.
Copy  Copies the hover label contents to the clipboard.

Subset  Opens a data table with the subset data associated with the hover label.

Edit  Opens the Hover Label Editor, where you can further edit the contents of the hover label. See “Edit Hover Labels in JMP Graphs”.

Close  Removes the label. You can also remove the label by clicking the X in the upper right corner of the label.

**Note:** To return to the default label formatting, remove the label and add it again.

---

**Customize Common Orderings**

Common orderings are built-in sets of data, such as month names, days of the week, and Likert, that are automatically arranged and sorted. You can create new common orderings, and change and delete orderings that were user-created. This way, you do not have to edit a column property every time you create a new report. Instead, you can create a custom ordering once and apply it multiple times, as needed.

**Note:** The default set of orderings include a lock icon  and cannot be changed or deleted. You can, however, disable the option by deselecting the checkbox.

---

**Load Common Orderings from a Data Table**

1. Open the table from which you want to create custom orderings, making sure that the table is the current data table.
2. Select **File > Preferences > Value Order**.
3. Click **Create**.
4. Choose the column whose values you want to use to form the items list, and then click **OK**.
   
   The items list is populated with the information from the table and the new list is defined under items.
5. To change the name of the new ordering, double-click the name, specify a new name, and then press Enter.
6. To change the order of the list, use the arrows to move items up and down the list. When the list is in the correct order, click **OK**.
Edit Common Orderings

You can perform the following tasks for user-created common orderings:

- Create a new common ordering. In the field below the Common Orderings box, type a name for the ordering and click Add.
- Duplicate a common ordering. Select the ordering and clicking Duplicate. JMP provided orderings can be duplicated and then changed.
- Delete a common ordering. To delete an ordering, click Delete.
- Arrange orderings. If you have similar orderings, use the arrows to arrange them by order or importance. JMP will apply the orderings in the order in which they appear in the list.

Edit Items

You can perform the following tasks for items:

**Note:** The items associated with JMP provided common orderings cannot be changed.

- Add items to new and existing common orderings. In the field below the items box, type one item at a time and click Add.
- Change the order of the items. Use the arrows to move the items and change the order in which they appear.
- Delete an item. To delete an item, click Delete.
- Specify an exact match. Use the Exact Match option to indicate that the items must be identical. If this option is deselected, case and whitespace can be different.

Save Platform Preferences

You can customize your platform and then save the settings to your preferences. This way, your preferred settings are saved without you having to open File > Preferences and individually setting each preference.

**Note:** Not all preferences can be saved. The Save Preference Changes dialog displays which settings changed and can be saved.

Complete the following steps:

1. Configure the platform.
2. On the red triangle menu, select Platform Preferences > Save Changes to. A window similar to the following is displayed:
**Semantic Formatting**

Semantic formats provide a way to customize numeric formatting in reports. They combine a numeric format with a set of criteria specifying where the format will be used. Instead of overriding formats every time a particular report is opened, you can set the format once and new reports that match the specified criteria will automatically be formatted.

There are many scenarios in which semantic formatting can be used. For example, the default format for Rsquare in a Summary of Fit report has 6 digits of precision. You can customize the format to show 2 digits of precision. This preference can be set using semantic formatting. Every report in the future will use this preference. The preference can also be defined for a row in the table, in this case, the Rsquare row. The preference can also be defined for the entire table.

**Format a Row in a Report Table**

1. Right-click in the table that you want to reformat a row in and select **Format Column**. The Column Numeric Format window opens.
Note: You window may display different formats and values.

2. Expand the Semantic Formatting section of the window. The semantic information about the table is listed: Name, Outline Path, Platform Name, and Format.

3. Click Add. The Create Semantic Format window opens.
Figure 9.76 Create Semantic Format

![Create Semantic Format window](image_url)

4. Specify a name for the format.
5. In the Format section, make the desired changes to the format.
6. Select the criteria and options that you want to apply to the format. Wild cards can be used.
7. Click **OK** in the three windows.

The report window is updated with the custom format.

**Format a Column in a Report Table**

To format an entire column with the formats that you created in the previous section, complete the following steps:

1. Right-click in the table that you want to reformat a row in and select **Format Column**. The Column Numeric Format window opens.
2. Listed in the Matched Semantic Formats section is the format that you created in the previous section. Select it and click **Edit**. The Edit Semantic Format window opens.
3. Deselect the Row Label option and click **OK**.
4. Click **OK**.

The report window is updated with the custom format.
This chapter describes how to save data tables in different formats, save your JMP analyses as scripts, or save your JMP sessions. You also learn how to share reports interactively on the web, or as JMP journals or projects.

When choosing how to share your content, consider the following:

- If you want to interactively share your data, even with people who do not use JMP, you might choose to share it to JMP Live or JMP Public, or as an interactive HTML page.
- If you want to present your data, you might choose to create a JMP journal.
- If you want to send data tables, linked reports, and other items to another JMP user, you might choose to bundle all these files as a JMP project.
Save and Share Your Data

Chapter 10
Using JMP

Contents

Save Data Tables .......................................................... 572
  Save Data Tables as Microsoft Excel Files ....................... 573
  Save JMP Data as a CSV File ....................................... 574
  Save JMP Data as a Text File ...................................... 575
  Save JMP Data as a JSON File ..................................... 576
  Save JMP Data as a SAS Transport File ......................... 576
  Save JMP Data as a Google Sheet ................................ 578
  Save JMP Data as a SAS Data Set ................................ 579
  Save Data Tables to a Database ................................ 580
  Replace a Database with a Data Table ......................... 581

Save Reports ............................................................ 582
  Save Reports as PDF Files ......................................... 584
  Save Reports as PowerPoint Presentations ..................... 585
  Set the Graphic DPI for Exported Graphics .................... 586
  Save a JMP Analysis as a Script ................................ 587
  Save Parts of a Report in a Graphic Format ................... 587

Share Interactive Reports and Data ............................... 588
  Share Reports as Interactive HTML ............................. 589
  Share Reports to JMP Live or JMP Public ....................... 592
  Share Data to JMP Live ............................................ 603

Print Reports ............................................................ 608

Copy and Paste Reports ............................................... 609

Work with Projects ..................................................... 610
  Create a New Project ............................................... 611
  Open Files in a Project ............................................ 611
  Rearrange Files in Projects ...................................... 612
  Save a Project ....................................................... 613
  Project Workspace .................................................. 614
  Project Bookmarks .................................................. 615
  Project Contents ..................................................... 615
  Recent Files in Projects .......................................... 616
  Project Log ............................................................ 617
  Move Files into Projects .......................................... 617
  Write a Project On Open Script ................................ 618
  Example of Creating a New Project .............................. 618

Create Journals .......................................................... 621
  Example of Making a Journal for a Presentation .............. 622
  Create New Journals ............................................... 624
  Manage Links in Shared Journals ............................... 625
Add and Edit Outlines to Journals ................................................................. 626
Right-Click Options in Journals ................................................................. 627
Control the Display of Outline Levels in Journals ................................. 628
Add a Graph or Graphic to Journals ......................................................... 628
Customize Items in Journals ................................................................. 628
Prevent Modifications to Journals ......................................................... 629
Append Reports to Journals ................................................................. 629
Save Journals in Other Formats .............................................................. 629
Delete Items from Journals ................................................................. 630
Save JMP Sessions ............................................................................... 630
  Save Sessions upon Exiting JMP ....................................................... 631
  Save Sessions Manually ................................................................. 631
Save a Log Window ............................................................................. 632
Save Data Tables

Select **File > Export** or **File > Save As** to save a data table in another format such as Microsoft Excel or CSV.

Note: To save a data table as a journal, select **Edit > Journal** and then **File > Save As**.

JMP saves data tables in the formats listed in Table 10.1.

### Table 10.1  Supported File Types for Saving Data Tables

<table>
<thead>
<tr>
<th>File Type(s)</th>
<th>OS Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Data Table (.jmp)</td>
<td>All</td>
</tr>
<tr>
<td>Excel Workbook (.xls, .xlsx)</td>
<td>All</td>
</tr>
<tr>
<td>Text Export File (.txt)</td>
<td>All</td>
</tr>
<tr>
<td>Comma-delimited File (.csv)</td>
<td>Windows</td>
</tr>
<tr>
<td>Tab-delimited File (.tsv)</td>
<td>Windows</td>
</tr>
<tr>
<td>SAS Data Set (.sas7bdat)</td>
<td>All</td>
</tr>
<tr>
<td>SAS Data Set with Extended Attributes (.sas7bxat)</td>
<td>Windows</td>
</tr>
</tbody>
</table>

Note: JMP can save column properties and table properties as extended attributes in a SAS 9.4 .sas7bxat file. Select **File > Export**, select the **SAS** file type, and then select the check box for saving extended attributes. JMP names the file with the .sas7bxat extension. The SAS Integration preferences also include this option, which is off by default.

<table>
<thead>
<tr>
<th>File Type(s)</th>
<th>OS Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAS Transport File (.xpt,.stx)</td>
<td>All</td>
</tr>
<tr>
<td>JSON Data File (.json)</td>
<td>All</td>
</tr>
</tbody>
</table>

You can also save files for types that have a corresponding ODBC driver. See “**Save Data Tables to a Database**”.

Notes:

- The maximum length of the data table’s name depends on your computer’s operating system. See your operation system documentation for details.
- JMP tries to save any modified files when a crash is detected.
Save Data Tables as Microsoft Excel Files

There are two options for saving data tables as Microsoft Excel files:

- Save one data table in Microsoft Excel format (.xls or .xlsx). Data from a single table is saved in a workbook named after the data table.
- Generate a workbook in .xlsx format from multiple tables. Data from each table appear on a different worksheet in the workbook.

Saving an .xlsx file retains data table cell colors, hidden data, and excluded data. Formulas and most formatting are not included.

The maximum length of the Excel file name is determined by your computer’s operating system.

Save One Data Table as a Microsoft Excel Workbook

To save a data table as a Microsoft Excel workbook, follow these steps:

**Windows**

1. Select **File > Export**.
2. Select **Microsoft Excel** and click **Next**.
3. Perform any of these optional steps:
   - Rename the file.
   - To save the file as an .xls file, select **Use Excel 97-2003 Format (*.xls)**.
   - To avoid opening the file in the default spreadsheet program after saving, deselect **Open the file after saving** on the Export window.
4. Click **Save**.

**macOS**

1. Select **File > Export**.
2. Select **Microsoft Excel** and select the format.
3. Click **Next**.
4. Perform any of these optional steps:
   - Rename the file.
   - To avoid opening the file in the default spreadsheet program after saving, deselect **Open the file after saving**.
5. Click **Export**.
Note: On Windows, data is split among several worksheets when the number of columns or rows exceeds the number that Excel supports.

Save Multiple Data Tables as a Microsoft Excel Workbook

To save multiple data tables in a new or existing Microsoft Excel workbook, follow these steps:

1. Open the data tables.
2. (Windows) Select File > Export > Microsoft Excel, select Export Multiple Data Tables, and then click Next.
3. (macOS) Select File > Export, select Export Multiple Data Tables from the Excel list, and then click Next.
4. In the JMP Data Table column, select only the data tables that you want to save.
5. In the Worksheet Name column, specify the name of the worksheet tab if necessary.
6. Enter a name for the workbook in the Workbook Name box.
   The workbook is named after the current data table by default.
7. Click Choose and browse to select a directory to save the file in.
   You can overwrite an existing workbook. Worksheets that already exist in the workbook are replaced. Worksheets that are not in the existing workbook appear at the end of the sheets.
8. Click Save (or Export on macOS).
   The file is saved as an .xlsx file.

Save JMP Data as a CSV File

On Windows, JMP can convert data from a JMP data table to a comma-separated values (CSV) file. To save a data table as a CSV file:

1. With the specific data table open in JMP, select File > Save As.
2. Select CSV (Comma delimited) (*.csv) from the Save as type list.
3. Enter the file name.
4. Select the location for the CSV file.
5. Click Save.

Note: Exporting a data table to a CSV file uses the comma and carriage return line feed character (CRLF) as file delimiters. Use a different extension and later rename the file with the CSV extension if you need to use different delimiters.
Save JMP Data as a Text File

JMP can convert data from a JMP data table to standard text format with rows and columns.

Text Formatting Options

Export Column Names to Text File  To save column headings in the first line of text, and to save labels or header information with the data, select Export Table Headers.

Add quotation marks to all column names, Add quotation marks to all character values, Add quotation marks to all numeric values  Select an option to add quotation marks even when they are not required. Some programs that import CSV files might need the quotation marks to display the text correctly. Quotation marks are always added to fields that contain special characters such as the field delimiter (typically a comma or tab), the line separator (typically a carriage return), or quotation marks.

End of Field  Select the radio button next to the character that marks the end of a field (or cell). Select Other and enter a character if the appropriate character is not listed.

End of Line  Select the radio button next to the character that marks the end of a line (or row). Select Other and enter a character if the appropriate character is not listed.

Notes:

• If a double quotation mark is found when importing text data, the delimiter rules change, and JMP looks for an end double quotation mark. Other text delimiters, including spaces embedded within the quotation marks, are ignored and treated as part of the text string.

• When you import text data, columns that contain image data are assigned the Expression data type.

Windows

1. Select File > Export.
2. Select Text and then click Next.
3. (Optional) Rename the file.
4. Click the Options button and specify end-of-line and end-of-field characters, and choose whether to export column headings as text.
5. Click OK.
6. (Optional) To avoid opening the file in the default text editor after saving, deselect Open the file after saving.
7. Click Save.
8. Click Yes.
macOS

1. Select File > Export.
2. Select Text and then click Next.
3. (Optional) Rename the file.
4. Specify end-of-line and end-of-field characters, and choose whether to export column headings as text.
5. (Optional) To avoid opening the file in the default text editor after saving, deselect Open the file after saving.
6. Click Export.

Save JMP Data as a JSON File

You can save a data table as a JSON file, which consists of name and value pairs. JSON files are often used to exchange data between applications.

To save a data table as a JSON file, follow these steps:

Windows

1. Select File > Export.
2. Select JSON Data and click Next.
3. (Optional) Rename the file.
4. Click Save.

macOS

1. Select File > Export.
2. Select JSON Data and click Next.
3. (Optional) Rename the file.
4. Click Export.

Save JMP Data as a SAS Transport File

You can save a JMP data table in SAS transport file format. JMP replaces spaces in file names and column names with underscores, converts column headings to uppercase SAS variables, and makes other changes to follow the transport file specifications.
When you save the data table as a transport file, you can opt to append it to an existing transport file. When you reopen the transport file in JMP, the two data tables open in separate windows.

Notes:

- The maximum length for SAS transport file names is 8 characters. JMP warns that characters beyond that limit are omitted.
- Images in Expression columns cannot exceed 200 characters, otherwise they are not supported.

Windows

1. Select **File > Export**.
2. Select **SAS Transport File**.
3. Click **Next**.
4. (Optional) Rename the file.
5. Click **Save**.
6. Click **OK**.

   Alerts appear regarding other SAS format modifications.
7. Click **OK** on each alert.
8. (Optional) Append the data table to an existing SAS transport file. Select **File > Export**, select the **Append** check box, and then click **Next**. Select the file to which you want to append the data table and then click **Save**.

macOS

1. Select **File > Export**.
2. Select **SAS Transport**.
3. Click **Next**.
4. (Optional) Rename the file.
5. Click **Export**.

   Alerts appear regarding SAS format modifications.
6. Click **OK** on each alert.
7. (Optional) Append the data table to an existing SAS transport file. Select **File > Export**, select the **Append** check box, and then click **Next**. Select the file to which you want to append the data table and then click **Append**.
Save JMP Data as a Google Sheet

A Google Sheet is a spreadsheet that is saved in your Google account. Exporting a JMP data table to Google Sheets enables you to share the data with others and edit the data outside of JMP.

You can export a JMP data table to an existing Google spreadsheet or create a new one.

To export a JMP data table as a Google spreadsheet, follow these steps:

1. If you are exporting to an existing spreadsheet, perform these steps first. Otherwise, go to step 2.
   b. Open the existing spreadsheet.
   c. Copy the URL from the browser’s address bar.
2. In JMP, open the data table with the data that you want to export.
4. Under Spreadsheet Type, choose either Existing or New Spreadsheet.
5. Enter your Google account name. (@gmail.com is unnecessary.)
6. (Existing spreadsheets only) Next to Spreadsheet Name, paste the URL of the Google spreadsheet that you copied in step 1.
7. (New spreadsheets only) Enter a name for the new spreadsheet.
8. Enter the name of the sheet (the tab name).
9. Click Save.
10. If you have already exported a data table from JMP, the data appears in Google Sheets. Go to your Google spreadsheet to see the data in the specified sheet.
   or
   If you are exporting data using the specified Google account for the first time, you are prompted to give JMP access to your Google account.
   a. Click Allow.
   b. Go to your Google spreadsheet to see the data in the specified sheet.
   Depending on the size of the data table, the Save operation might take some time.

About Exporting Google Sheets

- Information that Google uses to authenticate your account is stored in C:/Users/<username>/AppData/Roaming/SAS/JMP/OAuthToken.jmp on Windows. On Mac, OAuthTokens.jmp is stored in ~/Library/Application Support/JMP. (Passwords are not stored on the computer, and access tokens are encrypted.) Storing tokens in a data table enables
you to import and export data using the same Google account without providing the authentication information again. Note that a user with access to your computer’s user account has access to all of your Google spreadsheets. If the spreadsheets contain confidential information, reconsider sharing your user account.

- JMP features such as formulas and List Check column properties are not supported in Google Sheets.
- If the spreadsheet is empty, look in the JMP log for error messages. On Windows, select View > Log. On macOS, select Window > Log.
- If a Google Sheet has only one sheet, you cannot replace the sheet with a new sheet. Add a second sheet with a unique name and then delete the original sheet. In the Export to Google Sheets window, select Existing Spreadsheet and export the data table again. The sheet name that you specified appears in the sheet.
- See “About Importing Google Sheets” for more information about security, country restrictions, and more.
- If Display intranet sites in Compatibility View in Internet Explorer on Windows is selected, the Google Sheet cannot be exported. To avoid this issue, follow these steps:
  1. In Internet Explorer, select the Tools button and then select Compatibility View settings.
  2. Deselect Display intranet sites in Compatibility View.

Save JMP Data as a SAS Data Set

You can save data tables as SAS version 7 and higher data sets. JMP writes columns as SAS variables, writes rows as SAS observations, and makes other changes to follow the SAS data set specifications.

When you export data to a SAS data set, JMP date columns become SAS date values with the appropriate SAS format.

On Windows, JMP can save column properties and table properties as extended attributes in a SAS 9.4 .sas7bcat file. The option is available in the Save JMP As window and in the SAS Integration preferences.

Windows

1. Select File > Export.
2. Select SAS Data Set and click Next.
3. (Optional) Rename the file.
4. (Optional) To save SAS variable names or SAS formats, select the Preserve SAS variable names or Preserve SAS formats check boxes.
5. (Optional) To store JMP metadata as extended attributes for SAS 9.4, select **Store table and column properties in SAS 9.4 extended attributes**. JMP automatically assigns the .sas7bxat file extension.

6. Click **Save**.

7. Click **Yes**.

8. If other alerts appear, click **OK** on each alert.

**macOS**

1. Select **File > Export**.

2. Select **SAS** and click **Next**.

3. (Optional) Rename the file.

4. Select export options.
   
   To avoid exporting rows that have the Excluded row state, select **Honor Excluded Rows**. The other options are described in the preceding section.

5. Click **Export**.

**Save Data Tables to a Database**

You can save a data table to any database on your system that has a compliant ODBC (Open Database Connectivity) driver.

When exporting a data table to a database using ODBC, JMP exports the data as either character (CHAR or NCHAR) or numeric (FLOAT or DOUBLE PRECISION) data types. If a column is defined as a JMP date or time, the column exports as character data. The receiving database handles changing the data type to a proper date format.

1. First, connect to the database. See “To add a new database connection”.

2. Select **File > Database > Save Table**.
Figure 10.1 The Database Save Table Window

3. In the Connections box, highlight the name of the database to which you want to save the file (Figure 10.1). The Connections box contains a list of databases to which your system is connected.

4. From the **JMP data table to be saved menu**, select the open JMP data table that you want to save to the database.

5. In the **Save to database table** box, enter the name that you want the table to have when you save it in the database.

6. Click **Save Table**.

**To add a new database connection**

1. Click **Connect**.

2. Select the data source that you want and click **OK**. Or, to create a new source, click the **New** button (Windows) or **Choose DSN** button (macOS).

   Depending on which data source you select (and which database drivers you have installed on your computer), you might be presented with a variety of windows. Use them to create the database source.

3. Select the database to which you want to save the file.

**Replace a Database with a Data Table**

To replace a database with a data table, follow these steps:

1. First, connect to the database. See “To add a new database connection”.

2. Select **File > Database > Save Table**.
Save and Share Your Data

Chapter 10
Using JMP

Save Reports

To save a report, select **File > Export**.

- On Windows, you can save the report as any of the file types listed in **Table 10.2**.
- On macOS, the report is saved as a JMP report (.jrp). Note the following:
  - You can save the report as a journal by selecting **Edit > Journal** and then **File > Save**.
  - If you want to save the report as a text, image, HTML, PowerPoint, or RTF file, select **File > Export**. Supported image files include .png, .emf, .jpg, .gif, .tiff, .svg, and .eps.

**Table 10.2** Windows Supported Report File Types

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Word (.doc)</td>
<td>Word processing format; mixture of pictures, text, and tables.</td>
</tr>
<tr>
<td>Enhanced Metafile (.emf)</td>
<td>Can contain both vector and bitmap components.</td>
</tr>
<tr>
<td>Encapsulated PostScript File (.eps)</td>
<td>Line drawing (or vector image) that can show a bitmap preview of the image.</td>
</tr>
</tbody>
</table>

3. In the Connections box, select the name of the database to which you want to replace the file. The Connections box contains a list of databases to which your system is connected.

4. In the Schemas - Tables box, select the database table that you want to replace.

   **Note:** Remember the name for the database table. You use this same name for the replacement database table.

5. Click **Drop Table**.

   The database table is deleted from the database.

6. From the **JMP data table to be saved** list, select the JMP data table that you want to save to the database.

7. In the **Save to database table** box, enter the name for the deleted database table.

8. Click **Save Table**.

   The data table is saved to the database.

9. Click **Disconnect**.

10. Close the Database Save Table window.
Table 10.2  Windows Supported Report File Types  *(Continued)*

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CompuServe Graphics Interchange Format (.gif)</td>
<td>Compressed bitmap pictures.</td>
<td>Browser format; marked up text and references to separate picture files. Save pictures within the HTML file by selecting one of these formats: PNG, JPEG, SVG, or GIF.</td>
</tr>
<tr>
<td>Hypertext Markup Language (.htm, .html)</td>
<td>HTML or Interactive HTML with Data (.htm, .html)</td>
<td>Saves the data, reports, and graphs in an interactive web page, so non-JMP users can explore the data. See “Share Reports as Interactive HTML”.</td>
</tr>
<tr>
<td>Joint Photographics Expert Group (.jpg, .jpeg)</td>
<td>Compressed bitmap pictures; standard for photographs. See “Set the Graphic DPI for Exported Graphics”.</td>
<td></td>
</tr>
<tr>
<td>JMP Journal (.jrn)</td>
<td>Analysis report duplicated in a separate window titled Journal. You can edit it or append other reports to it. See “Create Journals”.</td>
<td>On macOS, select Edit &gt; Journal, and then File &gt; Save. On Windows, choose File &gt; Save, and then choose the journal format.</td>
</tr>
<tr>
<td>JMP Report (.jrp)</td>
<td>Analysis report originally created in JMP. It can be reopened for continued analysis. Contains the JSL and embedded data or reference to the data to reproduce a live report. Choose this format if you want to work with the report again, perhaps with new data.</td>
<td></td>
</tr>
<tr>
<td>Portable Document Format (.pdf)</td>
<td>Format for sharing documents regardless of the operating system or application in which they were created.</td>
<td></td>
</tr>
<tr>
<td>Portable Network Graphics (.png)</td>
<td>Compressed bitmap pictures; successor to GIF. See “Set the Graphic DPI for Exported Graphics”.</td>
<td></td>
</tr>
<tr>
<td>PowerPoint Presentation (.pptx)</td>
<td>Microsoft PowerPoint format; mixture of pictures, text, and tables. See “Save Reports as PowerPoint Presentations”.</td>
<td></td>
</tr>
</tbody>
</table>
Table 10.2 Windows Supported Report File Types (Continued)

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rich Text Format (.rtf)</td>
<td>Word processing format; mixture of pictures, text, and tables. Save pictures within the RTF file by selecting one of these formats: PNG, JPEG, or EMF.</td>
</tr>
<tr>
<td>Scalable Vector Graphic (.svg)</td>
<td>Pictures stored as text; best used for two-dimensional graphics.</td>
</tr>
<tr>
<td>Tagged Image File Format (.tif, .tiff)</td>
<td>Raster file format. See “Set the Graphic DPI for Exported Graphics”.</td>
</tr>
<tr>
<td>Text Format (.txt)</td>
<td>Plain text format; no pictures.</td>
</tr>
</tbody>
</table>

Save Reports as PDF Files

You save reports as PDF files by selecting File > Save As > PDF File (*.pdf) (Windows) or File > Export > Image > PDF (macOS).

Windows

- You can control pagination features such as headers, footers, and margins when you export the file.
  - Select File > Export, select PDF, and click Next.
  - Name the file, click Save, and then change settings in the Page Setup window.
- You can also control pagination by selecting File > Page Setup. Note that you can click Set as Default to apply the settings to future page setups.
- You can also control pagination by selecting File > Print Preview.

macOS

- Select File > Export > Image > PDF. The resulting PDF file contains a single PDF image with no headers or footers.
- You can also select File > Print and then select Save as PDF from the PDF window. The resulting PDF file is paginated into multiple pages as needed, with headers and footers, and using the page size, orientation, scaling, and margins that you selected in the Print and Page Setup windows.
Windows and macOS

Through JSL, you can control pagination on both Windows and macOS. See *JSL Syntax Reference* for more information about Set Page Setup, Set Print Headers, Set Print Footers, and Save PDF.

Save Reports as PowerPoint Presentations

Create a presentation by saving JMP results as a Microsoft PowerPoint presentation (.pptx). Rearrange JMP content and edit text in PowerPoint after saving as a .pptx file. Sections of a JMP report are imported into PowerPoint differently. Report headings are imported as editable text boxes, and graphs are imported as images. Certain graphical elements, such as legends, can be imported as separate images. Images resize once opened in PowerPoint to fit the slide. Typically, each outline in the JMP report appears on separate PowerPoint slides. If an outline in the report is closed when saving as a .pptx file, it is excluded from the PowerPoint. Larger content can spread across multiple PowerPoint slides. Delete unwanted content from the PowerPoint file.

**Note:** On Windows, PowerPoint 2007 is the minimum version required to open .pptx files created in JMP. On macOS, at least PowerPoint 2011 is required.

1. In JMP, create the report.
2. Select **File > Export > Microsoft PowerPoint** and click **Next**.
3. Select a graphic file format.
   - On Windows, EMF is the default format. On macOS, PDF is the default format.
4. (Optional) To avoid opening the file in the default presentation program after saving, deselect **Open the file after saving**.
5. Name and save the file (or export on macOS).

**Tips:**

- The native EMF graphics produced on Windows are not supported on macOS. The native PDF graphics produced on macOS are not supported on Windows. For cross-platform compatibility, change the default graphics file format by selecting **File > Preferences > Third Party Data** (Windows) or **JMP > Preferences > Third Party Data** (macOS). Then, change the **Image Format for PowerPoint** to either PNG or JPEG.
- It is sometimes necessary to auto-resize column widths using PowerPoint. PowerPoint often sizes objects differently from JMP, which can lead to abnormally sized table columns.
- Drag the column separators in PowerPoint to adjust column widths for a nicer layout. You can also double-click a column border to decrease the amount of white space in the column.
• A default PowerPoint template is installed in the JMP directory’s pptx folder. You can save a copy of this PowerPoint template and replace the default template with your own if you want to always use an alternate template when exporting. For example, you might want to create a German PowerPoint template that has German default fonts. See “Custom PowerPoint Templates”.

Custom PowerPoint Templates

PowerPoint presentations use the default JMP template. You can use a custom template by overwriting the default template file. To do this, open JMPExportTemplate.pptx located in one of the following locations:

C:/Program Files/SAS/JMP/17/pptx/
C:/Program Files/SAS/JMPPro/17/pptx/

Then, choose your own PowerPoint template, and select File > Save. The next time you save JMP content as a PowerPoint, it opens with your custom template. Alternatively, create your custom template in PowerPoint first, and save it as JMPExportTemplate.pptx.

Notes:

• The custom PowerPoint template on macOS cannot be edited.
• To use the JMP default template later, make a duplicate copy on your machine before overwriting the file.
• If you install JMP in a folder other than the default (C:/Program Files/), you can update the JMP template file.

Also, you can use a custom template with a JSL script. For more information, see the JSL Syntax Reference.

Set the Graphic DPI for Exported Graphics

On Windows, there are several ways to set the resolution (or DPI) for exported graphics:

• To change the default DPI for all graphics, set the DPI to in the Windows Specific preferences. The Default option uses the default setting of your operating system.
• The following script lets you set the default DPI to a different value. Change the number if you want a different DPI and then run the script.

```
Pref( Save Image DPI( 600 ) );
```

To verify the default DPI after you run the preceding script, run the following script:

```
Get Preferences( Save Image DPI );
```
The Windows Specific preferences and Save Report As window show Default as the DPI after you run this script. The setting applies until you change it. On the Save Report As window, select **Always use this setting** to save your choice across multiple JMP sessions.

- For a specific graphic, set the DPI in the Save Report As window.

On macOS, you cannot change the default DPI, which is 72.

### Save a JMP Analysis as a Script

After completing an analysis and receiving a report, you might want to save the process that you used to arrive at the report as a JSL script. You can save the script inside the data table, inside the report, or in a separate script window. To do this, click the red triangle in the report title and select the Save Script option that you prefer. See “Save Script Menus in JMP Reports”.

Non-English versions of JMP can save scripts in either English or your local language. See “General JMP Preferences”.

### Save Parts of a Report in a Graphic Format

You can save part of an analysis report window as a graphic. You can save the selection in .png, .jpg, .gif, .eps, .emf, .pdf, .tif, and .svg formats. On macOS, you can save the selection in .png, .jpg, .gif, .svg, .eps, .pdf, and .pptx formats.

To save a selection, follow these steps:

1. Click the selection tool ( ).
2. Highlight the area that you want to save.
3. On Windows, select **Edit > Save Selection As**. On macOS, press Control and select **File > Save Selection As**.

   The Save Selection As window appears (or the Save window on macOS).

4. Enter the file name for the graphic.

   On macOS, change the file extension to save the file in a format other than .png, the default format.

**Note:** If you use Save Selection As and create a PDF file from the selection, the PDF file has headers and footers. With JSL, you can control pagination on both Windows and macOS. See the *JSL Syntax Reference*.

5. Change options on Windows:

   - Select the graphics file format type to which you want to save the selection. See “Save Reports”.
Save and Share Your Data

– Select the Image DPI Setting. 300 or higher is best for graphics that must be stretched or printed.
– To keep your selected DPI Setting for the current session, select **Always use this setting**.
– To avoid opening the file in the default graphics program after saving, deselect **Open the file after saving**.
– Select **Select this filter the next time this window is invoked** to save your file type selection for the current session.

**Note:** If you cannot see the Select this filter option, select a folder location for saving the graphic file.

6. Click **Save**.

**Tips:**

- You can change the default DPI setting selection in the Windows Specific preferences from 96 to 300 DPI. The following script lets you set the default DPI to a different value. Change the number if you want a different DPI and then run the script.
  ```
  Pref( Save Image DPI( 600 ) );
  ```
- On macOS, you cannot change the default DPI, which is 72.
- When you export a graph or report that contains a bitmap image to an .svg file, the image is embedded in the .svg file. The exported content is then easier to reuse in other documents.

## Share Interactive Reports and Data

You can share JMP reports or data using the web, even with people who do not have JMP. They can explore your data in any of these ways:

- Create a web page of your JMP report and share it with others (for example, on a shared network drive, by email, or on a website). See “Share Reports as Interactive HTML”.
- Share your reports and data to JMP Live or JMP Public:
  - JMP Live is a secure website purchased by your company for hosting and sharing JMP reports or data privately.
  - JMP Public is a website that uses similar technology as JMP Live, where anyone can share JMP reports or data with the public.

See “Share Reports to JMP Live or JMP Public” and “Share Data to JMP Live”.
Share Reports as Interactive HTML

Interactive HTML enables you to share JMP reports that contain dynamic graphs so that even non JMP users can explore the data. JMP reports are saved as an interactive web page that you can share with others (for example, on a shared network drive, by email, or on a website). Users then explore the data as they would in JMP.

Interactive HTML Contains Data

When you export or publish a report as interactive HTML, your data are embedded in the HTML. The content is unencrypted, because web browsers cannot read encrypted data. To avoid sharing sensitive data, export your results as a non-interactive web page instead by selecting File > Export > HTML.

Which Features Are Supported Interactively

Interactive HTML provides a subset of features from JMP:

- If the features in your report are fully supported, the web page is created with no warnings.
- If your report contains unsupported features, you see a message in the export or publish window that interactive HTML is partially implemented. For details, see the JMP log (View > Log).
- Partially or unsupported features appear static in the web page. If you hover over an unsupported feature in the web page, a tooltip says that the feature is not yet interactive.

For information about exploring interactive HTML output, visit jmp.com/interactive.

Export a Single Report as Interactive HTML

To export a single JMP report as interactive HTML, use the Export as Interactive HTML with Data option to create a single web page.

1. In JMP, create the report and make it the active window.

   Note: If a report contains a Local Data Filter, it is static in the web report and users cannot change the selections. To make the Local Data Filter interactive, deselect the Include mode. (In Graph Builder, to see the Include mode, select Show Modes from the Local Data Filter red triangle menu.)

2. Select File > Export, select Interactive HTML with Data and click Next.
3. (Optional) Rename the file.
4. Keep the Open the file after saving option selected.
5. Click Save.
The output is saved in the selected folder and opens in a browser.

**Figure 10.2** Web Page for Single Interactive HTML Report

**Publish Multiple Reports as Interactive HTML**

To publish multiple JMP reports as interactive HTML, use the Publish to File option, which creates an index page that contains the reports.

**Tip:** When you publish multiple JMP reports, you specify where to save the index page and report files. You can choose a shared network folder and provide the location to others, or choose a folder on your computer and zip the files before sharing. This is particularly helpful if you are sharing with non JMP users.

1. In JMP, create the reports.

   **Note:** If a report contains a Local Data Filter, it is static in the web report and users cannot change the selections. To make the Local Data Filter interactive, deselect the **Include** mode. (In Graph Builder, to see the **Include** mode, select **Show Modes** from the Local Data Filter red triangle menu.)

2. From a report window, select **File > Publish > Publish to File**.
3. Select the reports that you want to publish.
4. (Optional) Change where the parent folder resides or change the name of the subfolder that will contain the reports.
5. Click **Next**.
6. Enter a title for the index page. You can also update the report titles.
7. (Optional) Change additional options. See “Interactive HTML Report Options”.
8. Click **Publish**.
9. In the Publish Results window, click a title.

**Figure 10.3** Index Page for Multiple Interactive HTML Reports

10. Click a thumbnail or report title to open a report.

For details about working with interactive reports, from an HTML report, click ☰ > **Help**. This opens the help at jmp.com/interactive.

**Interactive HTML Report Options**

- **Title**  
  Add a title for the index page (multiple reports only) or the reports.

- **Description**  
  (Optional) Add a description to the index page or the reports. The description will appear under the titles.
**Customize**  ( Appears for multiple reports only) Change the appearance of the web page. You can change the style, theme, font, logo, and whether the date or time appears. See “Customize Index Page Options”.

**Publish Data**  Select this for interactive reports. If you deselect this option, the reports are static.

*Note:* To avoid sharing sensitive data, save your results as a non-interactive web page. (Select File > Export > HTML.)

**Add Image**  Adds an image to the web page. You can move the image up or down using the Arrow icons.

**Close reports after running**  Closes the reports in JMP once you publish the web report.

**Delete icon**  ( Appears for multiple reports only) Deletes a report.

**Arrow icons**  ( Appears for multiple reports only) Changes the order of reports.

**Customize Index Page Options**

**Style Format**  Determines the layout of the reports.

- **Large List**  Shows the reports in a column with large thumbnail graphics.
- **Small List**  Shows the reports in a column with small thumbnail graphics.
- **Grid**  Shows the reports in rows.
- **Custom CSS**  Enables you to specify a CSS file to format the web page. The CSS file is copied into a subfolder called _css. The link to the CSS file is relative so that you can send the report and support files to another user and maintain the CSS formatting.

**Color Theme**  Specifies the color of the web page, headings, and borders. The default web page has a white background, orange headings, and blue borders.

**Change Font**  Change the font applied in the reports.

**Change Logo**  Specifies an image to display along with the reports. Click the up or down arrow next to the image to move it above or below the reports.

**Show date/time**  Shows or hides the date and time at which the web page was generated.

**Share Reports to JMP Live or JMP Public**

JMP Live is a website purchased by your company for sharing JMP content privately. JMP Live can be hosted by SAS or your company. JMP Public is a website using similar technology as JMP Live, where anyone can share JMP content with the public.
JMP Live and JMP Public are platforms for sharing JMP data, visualizations, and dashboards. Prepare your reports or data tables in JMP and publish them as posts in spaces to collaborate with your colleagues, even those who might not have JMP.

JMP Live and JMP Public offer the visual interactivity of JMP to explore your data, and let you do the following:

- Store all of your reports and data in one location
- Control sharing of reports or data
- Maintain up-to-date reports and data for your team in an easily accessible location

**Register and Sign Into a SAS Profile (JMP Public Only)**

Before you can publish posts to JMP Public, you must register and sign in using a SAS profile.

**Note:** If you are not signed in to JMP Public, you see only featured posts.

1. In a browser, go to public.jmp.com.
   Supported browsers include Chrome, Firefox, Safari, and Edge.
2. At the top right, click **Sign in**.
3. If you already have a SAS profile, log on using those credentials, then click **Submit**.
4. If you do not have a SAS profile:
   a. Click **Create profile**. Complete the form and click **Create profile**.
   b. Follow the instructions in the email to set your password and activate your profile.

**Add a JMP Live Server**

Before you can publish to JMP Live, you must add a JMP Live server.

**Note:** The first server that you add becomes the default. The default server is used for all interactive publishing and scripts that do not explicitly specify another server. If you add more servers, you can change the default server.

1. In JMP, select **File > Publish > Manage Connections**.
2. Click **Add New**.
3. Enter the JMP Live URL, formatted like this: https://jmpliveserver.com:3501 (where 3501 is the default web server port).
4. Enter an identifying name for the connection, such as JMP Live.
5. (Optional) If you want to use JSL to create JMP Live reports, enter an API key. For details, see the **Scripting Guide**.
6. Click **Next**.
7. Sign in to the JMP Live server with your user name and password.
8. Once the connection is created successfully, click **Save**.
   The server name appears under Select a connection.
9. Click **Exit**.

**Create and Publish JMP Reports**

1. Create reports in JMP.

   **Tip:** If your report contains a Local Data Filter, add columns before you publish, otherwise the Local Data Filter is static instead of active. To add columns, select them in the Local Data Filter and click the Add icon.

2. Select **File > Publish > Publish Reports to JMP Live** or **Publish to JMP Public**.
   – (JMP Live only) If you have not added a JMP Live server, add one now. See “**Add a JMP Live Server**”.
   – You might need to sign in to JMP Live or JMP Public.

   **Note:** To register for a SAS login, visit jmp.com and click **Sign In** near the search box at the top of the page.
3. Select the reports that you want to publish.

**Tip:** To choose all open reports, select the Report Title box. If you are replacing a report, you can choose only one report.

4. Choose what you want to do:
   - “Publish a New Report”
   - “Replace an Existing Report”

5. Click **Next**.
Publish a New Report

Figure 10.5 Select Where to Publish the Reports

1. Select an existing space from the list or enter text to find a space that you want to publish your report to.
   You see only spaces that you have permission to publish to.
2. (Optional) Select an existing folder from the list or enter text to find the folder where you want to publish your report.
3. Click **Next**.
4. (Optional) Update the title for each report.
5. Change additional options. See “Report Options”.
6. Click Publish.
Save and Share Your Data
Share Interactive Reports and Data

Figure 10.7 Publish Status for Creating a New Report

7. (Optional) Choose any of these options:
   - To close the JMP reports you published, select **Close reports after running**.
   - To save your process as a JSL script, select **Save publish script to script window**.
8. Click a link to open JMP Live, or click **Close Window**.
Figure 10.8  Published Reports in a JMP Live Folder

Space access determines who can see your report post. For details, see the JMP Live Help.
Replace an Existing Report

Figure 10.9 Select an Existing Post

Note: You see only posts that you have permission to update.

1. Select an existing post from the list or enter text to find a post.
2. To use the existing title (and description, if applicable) click Copy to New. Or, under New Post, enter a new title (and optional description).
3. (Optional) Change advanced options. See “Report Options”.
4. Click Next.
Figure 10.10  Choose How to Publish Data

Match Data
Configure how to use the local data tables when replacing the existing report.

<table>
<thead>
<tr>
<th>Local Data Tables</th>
<th>Data Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Big Class.jmp</td>
<td>Update JMP Live data table</td>
</tr>
<tr>
<td></td>
<td>Select from existing data</td>
</tr>
</tbody>
</table>

Updating will affect 1 other report.

5. (Publish data only) Choose whether to update the existing data table, publish new data, or use an existing data table. To use existing data or update data, select a data table.

6. Click Replace.

Figure 10.11  Publish Status for Replacing a Post

Successfully replaced "Big Class - Bivariate of weight by height".

Publish Location

Folder 1

Replaced Report

Big Class - Bivariate of weight by height

Affected Data

Big Class

Close reports after running

Save publish script to script window
7. (Optional) Choose any of these options:
   – To close the JMP reports you published, select **Close reports after running**.
   – To save your process as a JSL script, select **Save publish script to script window**.
8. Click a link to open JMP Live, or click **Close Window**.

**Figure 10.12** Published Reports in a JMP Live Folder

Space access determines who can see your report post. For details, see the **JMP Live Help**.

**Report Options**

**Description**  (Optional) Add a description of the report that appears on the post’s thumbnail.

**Advanced**  Select **Publish data** for interactive reports. If you deselect this option, the reports are static. When selected, the data behind the report and a JSL script of the report are published.

**Best interactivity**  All supported aspects of the report are fully interactive.

**Best performance**  Images and graphs are not interactive, but supported data in the rest of the report remains interactive. If your data set is large, you might choose this option to increase the responsiveness of the report.
Tip: To avoid sharing sensitive data, save your results as a non-interactive web page. (For a single report, select File > Export > HTML. For multiple reports, select File > Publish > Publish to File and deselect Publish Data.)

Warnings enabled  (Applicable for platforms that support control charts only.) Notifies interested parties when the report has control chart warnings. Interested parties can include subscribers or groups that have warnings enabled.

Add Image  Adds an image as a static, image-only report.

Data Options  Choose whether to publish new data or use existing data in the JMP Live space you are publishing to.

Allow data and scripts to be downloaded  Allows data tables and scripts associated with the reports to be downloaded. If you do not select this option, in JMP Live there is no download option next to the data table names and no JSL script to re-create the report. See “Note on Data Accessibility”.

Delete icon  Deletes a report.

Share Data to JMP Live

1. Open a data table in JMP.
2. Select File > Publish > Publish Data to JMP Live.
   - If you have not added a JMP Live server, add one now. See “Add a JMP Live Server”.
   - You might need to sign in to JMP Live.

Note: To register for a SAS login, visit jmp.com and click Sign In near the search box at the top of the page.
Tip: To choose all open data tables, select the Data Tables box.

3. Choose what you want to do:
   - “Publish a New Data Table”
   - “Update an Existing Data Table”

4. Click Next.
Publish a New Data Table

**Figure 10.14** Select Where to Publish the Data

1. Select an existing space from the list or enter text to find a space that you want to publish your data to.
   - You see only spaces that you have permission to publish to.
2. (Optional) Select an existing folder from the list or enter text to find the folder where you want to publish your data.
3. Choose whether to allow users to download the data.
4. Click **Publish**.
Figure 10.15  Publish Status for a New Data Table

5. Click a link to open JMP Live, or click **Close Window**.

Figure 10.16  Published Data File in JMP Live

Space access determines who can see your data post. For details, see the *JMP Live Help*. 
Update an Existing Data Table

**Figure 10.17** Select an Existing Data Table

1. Select an existing data table from the list or enter text to find a table.
2. Click **Replace**.

**Note:** You see only data tables that you have permission to update.

3. Click a link to open JMP Live, or click **Close Window**.

**Figure 10.18** Publish Status for Updating a Data Table

Successfully replaced "Big Class".

**Publish Location**

- Folder 1
- jmpuser01

**Replaced Data**

- Big Class
- Big Class jmp
Space access determines who can see your data post. For details, see the JMP Live Help.

**JMP Live and JMP Public Help**

For help with using JMP Live or JMP Public, click ? > Help.

**Note on Data Accessibility**

The data that is represented in your published reports will exist online in HTML5 files as well as in the JMP data table format.

Disabling the Allow data to be downloaded option prevents any user who has access to the JMP Live page from being able to download the data in the JMP data table format, but it does not prevent a user from being able to get the HTML file containing the data in XML format. Enabling the Allow data to be downloaded option allows a user who has access to the JMP Live page to get the data in either way. The JMP format is only useful to users who have access to the JMP Live page who also have a separate license of JMP software or a third-party software that knows how to read JMP files, but a user of the JMP Live page only needs a web browser to see the data in the HTML file.

**Print Reports**

To print the report in the active window, select File > Print. This command displays the standard window for printing. The appearance of the window depends on your operating system and printer driver.

To insert a page break for printing purposes, follow these steps:

1. Right-click the disclosure icon in the report window.
Copy and Paste Reports

When you need to use JMP reports or data tables in another program, you can paste or drag parts of a report or table into another program. For example, you might want to send a colleague a copy of a JMP report in a Microsoft Word file.

1. Click the selection tool.
2. Click and drag (or press Shift and click) to select items in a report window or data table. Clicking near the edge of the report window selects the entire report.
3. Click the selected items and drag them from JMP to the other program. Or, copy the selected items in JMP and paste them into the other program. When you paste an element into another application, the format used depends on the application into which you paste. If you use the applications’ Paste Special command, you can select a format to use, such as text (.rtf), unformatted text (.txt), or bitmap (.bmp).

Notes:

• To copy all text (no graphs) from the active report window as unformatted text, select **Edit > Copy As Text.** On macOS, select **Paste > Special** in Microsoft Word or **Paste and Match Style** in other macOS apps.

• To copy a graph, which includes labels and axes, right-click the graph and select **Edit > Copy Graph.**

• To copy anything other than a graph, right-click and select **Edit > Copy Picture.** For example, to copy a report, right-click the bar containing the report title and select the option.

• To copy text from a text box onto the clipboard, right-click the text and select **Copy Text.**

• To copy text from one column onto the clipboard, right-click the column and select **Copy Column.**

• To copy and entire table onto the clipboard, right-click the table and select **Copy Table.**

• The Reports preference **Transparent background in report PNG images** determines whether reports that are saved as PNG images have transparent backgrounds. The preference is deselected by default.
Work with Projects

With JMP projects, you can do the following:

- Explore your data more efficiently with a single, tabbed JMP window
- Quickly save and reopen a set of related files and reports
- Easily share your work by embedding your tables and scripts in a self-contained project file

Figure 10.20  Project File with Data Tables and Reports
This section contains the following information:

- “Create a New Project”
- “Open Files in a Project”
- “Rearrange Files in Projects”
- “Save a Project”
- “Project Workspace”
- “Project Bookmarks”
- “Project Contents”
- “Recent Files in Projects”
- “Project Log”
- “Move Files into Projects”
- “Write a Project On Open Script”
- “Example of Creating a New Project”

**Create a New Project**

To create a new, empty JMP project, select File > New > Project (Windows) or File > New > New Project (macOS).

**Open Files in a Project**

In a JMP project, you can open data tables and then run analyses on the data. Each data table and analysis report opens in a new tab.

1. From a project window, select File > Open and browse to the data tables that you want in the project.
2. From a data table, run an analysis.

If a data table is updated on your computer, any associated reports in your project update when you reopen the project.
Tip: You can use JMP keyboard shortcuts in projects, such as Ctrl+S to save a file, or Ctrl+W to close the active window pane. For a full list, select Help > Quick Reference Card.

Rearrange Files in Projects

In a JMP project, data tables and reports appear in individual tabs. You can rearrange tabs by dragging them into a dock zone.

Tip: To undo or redo a docked item, select Project > Undo Layout or Project > Redo Layout. To return all tables and reports to individual tabs, select Project > Reset Layout.

Example of Rearranging Project Files

1. Select File > New > Project (Windows) or File > New > New Project (macOS).
2. Select Help > Sample Data Folder and open Car Physical Data.jmp and Car Poll.jmp.
3. In the Car Poll.jmp data table, run the Distribution script.
4. In the Car Physical Data.jmp data table, run the Contingency script.
5. Drag the Car Poll - Distribution report tab to the right and drop it into the Dock right zone.
The Distribution report pane appears at the right of the project window. The report is docked and stays visible when you switch between tabs.

6. Drag the **Car Physical Data - Contingency** tab to the middle of the **Car Poll - Distribution** report and drop it into the **Dock tab zone**.

**Tip:** You can adjust the size of the data table window to fully show both reports.

7. Click the x to the right of Workspace, Contents, and Recent Files in the left column.

You can show these panes later by selecting the options in the Project menu.

**Figure 10.22 Reports and Data Tables Grouped into Tabs**

The Distribution and Contingency reports are now tabbed together, as are the two data tables.

**Save a Project**

If you want to share, distribute, or archive your project, create a self-contained project by saving all your data tables and scripts to the project contents. This embeds all project files and folders into a single project file that you can share with other JMP users.

1. (Optional) To save the project as a self-contained project, save each data table and script in the project by selecting **File > Save As** and then select **Project Contents**. You can click **New Folder** to create a folder in the project contents.
Save and Share Your Data

Chapter 10
Using JMP

Note: You do not need to save reports as these are automatically saved to the project.

Figure 10.23 Save a Data Table to the Project Contents

2. Select File > Save Project to save the project file.

Figure 10.24 Save a Project File

Project Workspace

In a JMP project, you can see all currently open files in the Workspace tool pane. Reports appear under the corresponding data table. The active data table appears in bold.

Tip: To hide or show the Workspace tool pane, select Project > Show Workspace. To specify which tool panes appear by default when you create a project, select File > Preferences > Projects and choose the initial tool panes.

In the Workspace tool pane, you can do the following:

• Double-click a file to make it active.
• Right-click a file to close it, hide it (removes the tab and dims the file name), bookmark it, and more.
Project Bookmarks

In a JMP project, you can create a shortcut to a file or folder in the Bookmarks tool pane. You can also organize your bookmarked files and folders by creating a bookmark group.

**Tip:** To hide or show the Bookmarks tool pane, select **Project > Show Bookmarks**. To specify which tool panes appear by default when you create a project, select **File > Preferences > Projects** and choose the initial tool panes.

**Bookmark an open file in the project**

- Right-click a tab and select **Bookmark**.
- To bookmark all open files, right-click a tab and select **Bookmark All**.

**Bookmark a file or folder on your computer**

Drag a file or folder from your computer into the Bookmarks tool pane, or click the Bookmarks red triangle menu and select **Add Files** or **Add Folder**.

**Note:** If you add or remove files from a bookmarked folder on your computer, the folder contents automatically update in the project.

**Open a bookmarked file**

In the Bookmarks tool pane, double-click a file.

**Remove a bookmark**

In the Bookmarks tool pane, right-click a file and select **Remove Bookmark**.

**Create a bookmark group**

1. Click the Bookmarks red triangle menu and select **New Group**.
2. Name the group and click **OK**.
3. Drag new or existing bookmarks into the group, or in the Bookmarks tool pane, right-click the group and select **Add Files** or **Add Folder**.

Project Contents

In a self-contained JMP project, any files you save to the project contents appear in the Contents tool pane.
**Tip:** To hide or show the Contents tool pane, select Project > Show Contents. To specify which tool panes appear by default when you create a project, select File > Preferences > Projects and choose the initial tool panes.

**Open a file from the project contents**
In the Contents tool pane, double-click a file.

**Create a folder in the project contents**
1. Click the Contents red triangle menu and select New Folder.
2. Name the folder and click OK.

**Move files into folders**
In the Contents tool pane, drag a file into a folder.

**Copy a file or folder from your computer into the project contents**
1. Click the Contents red triangle menu and select Copy Files into Project or Copy Folder into Project.
2. Navigate to the file and click Open, or navigate to the folder and click Select.

**Copy a file from your project contents to your computer**
1. In the Contents tool pane, right-click a file and select Copy File As.
2. Click Browse and navigate to where you want to save the file.
3. Click Save.

**Rename a file in the project contents**
In the Contents tool pane, right-click a file and select Rename.

**Delete a file in the project contents**
In the Contents tool pane, right-click a file and select Delete.

**Recent Files in Projects**
In a JMP Project, you can open a file from the Recent Files tool pane.
**Tip:** To hide or show the Recent Files tool pane, select *Project > Show Recent Files*. To specify which tool panes appear by default when you create a project, select *File > Preferences > Projects* and choose the initial tool panes.

**Open a file**

In the Recent Files tool pane, double-click on a file or drag it into a project.

**Note:** Open files that are saved to the project contents do not appear in the Recent Files tool pane.

**Project Log**

In a JMP Project, you can see log messages in the Log tool pane.

**Tips:**

- To hide or show the Log tool pane, select *Project > Show Log*. To specify which tool panes appear by default when you create a project, select *File > Preferences > Projects* and choose the initial tool panes.
- By default, log messages that occur in projects appear only in the project log, not in the main JMP log. To change this setting, select *File > Preferences > Projects* and update *Use Project Log Pane* to *If Open* or *Never*.

**Move Files into Projects**

In JMP, you can move files into a project, out of a project, or between projects.

1. Select *Help > Sample Data Folder* and open Big Class Families.jmp.
2. Run the Distribution, Text Explorer, and Graph Builder scripts.
3. From any window, select *Window > Move to/from Project*.
4. Leave the Source Project as *(None)* to see files that are not open in any project.
5. Leave the Destination Project as *(New Project)* to move the selected files into a newly created project.
6. Select the check box next to Big Class Families.jmp. The graphs associated with the data table are also selected.
Figure 10.25 Move Windows To/From Project

7. Click OK. A new project is created with the selected table and reports.

Write a Project On Open Script

In the Project On Open Script box, you can add a JSL script that will run each time this specific project is opened. For example, you can create a script that creates or modifies reports, prompts the user for information, or writes usage information to the log window.

1. Select Project > Project Settings.
2. Paste the JSL script and click OK.

Tips:
• See the Scripting Guide, which explains how to create a start-up script when any project is opened (instead of a specific project).
• To use an existing project as a template for new projects, specify the existing project as a new project template under File > Preferences > Projects.

Example of Creating a New Project

In this example, you create a project, import data, generate an analysis and dock the report in the project window, create a subset table, and then save, close, and reopen the project.

1. Select File > New > Project (Windows) or File > New > New Project (macOS).
2. From the project window, select File > Open.
3. Open the sandwiches.xlsx file, located here by default: C:/Program Files/SAS/JMP/17/Samples/Import Data
   Tip: At the bottom, you might need to change All JMP Files to Excel Files.
4. Click Import.
5. Select **File > Save**.
6. Make sure **Project Contents** is selected.
7. Change the file name to **Sandwiches.jmp** and click **Save**.

**Figure 10.26** Project with Sandwiches Data Imported

8. Select **Analyze > Fit Y by X**.
9. Select Calories and click **Y, Response**.
10. Select Weight and click **X, Factor**.
11. Click **OK**.
12. Drag the **Sandwiches - Fit Y by X** tab to the right and drop it into the **Dock right** zone.

**Tip:** To show the entire report, you can drag the line between the data table and the report to the left.
13. Select **Tables > Subset**.
14. Under Rows, select **Random: sampling rate 0.5**.
15. Click **OK**.

**Figure 10.28** Project with Unsaved Subset Table

16. Select **File > Save Project**.
17. Navigate to the folder where you want to save your project, name the project file, and click **Save**.
18. Close the project.
19. Select **File > Open** and open your project file.
Tip: At the bottom, you might need to change Excel Files to JMP Projects.

Notice that the subset table that you did not save has been saved automatically to the project file.

Create Journals

Create a JMP journal when you want to store results and present them. One of the benefits of journaling is that you can capture an analysis and not depend on external files. Another benefit is the ability to copy and paste specific reports or graphs into the journal. This enables you to create a custom report to present to other users.

There are two types of presentations that you can create using journals:

- A static presentation embeds the output of one or more JMP reports, fixed at a moment in time. The output is similar to what you get when you save output as a PDF file. There is no data table, points cannot be selected, colored, hidden, excluded, and so on. Only cosmetic changes (fonts, axes, sizes) can be made. The benefit is that there is no dependency on external files.

- A dynamic presentation is built from outlines containing text and buttons (or links) that help you organize, hide, or reveal a set of data tables and reports. This type of journal is dynamic because you can open reports and tables and interact with them, selecting points, subsetting data, making more graphs, or rerun an analysis.

Figure 10.29 shows some of the items that you can add to a journal.

Figure 10.29 Example of a Journal

Notes:

- When you are finished creating the journal, select Edit > Lock Journal. To unlock the journal for editing, select Edit and deselect Lock Journal.
Save and Share Your Data
Create Journals

Figure 10.30  Lock a Journal

- You can save journals to other formats, such as Microsoft Word, HTML, PDF, and so on. See “Save Journals in Other Formats”.
- Journals support GZ compression to reduce file size. See “General JMP Preferences”. This can be particularly helpful if large data tables are embedded in the journal.
- Consider setting the Autosave timeout value in the General preferences to automatically save open journals at the specified number of minutes. This autosave value also applies to data tables, scripts, projects, and reports.
- A toolbar appears at the top of the journal that enables you to insert objects in the journal, lock the journal, and change its orientation (Figure 10.30). When you select or deselect Horizontal from the red triangle menu, this setting is not saved in the journal. The setting is only for the current session.

Example of Making a Journal for a Presentation

Most people use a presentation application like PowerPoint to give presentations. With JMP journals, you can avoid using a presentation application: all your bullet points can be combined with live links and buttons to help automate the analyses that you want to show. Interactivity is also maintained in reports.

Follow this example to create a presentation using a journal.

2. Right-click in the journal. Start your outline by selecting Add Outline Item.
3. Enter the title of the presentation “My Bivariate Demo.”

Figure 10.31  Add an Outline Item

A presentation should have outline nodes. The nodes are nested, opened, and closed in sequence, as you give the presentation.

4. To add bullet points into the outline, click the red triangle in the My Bivariate Demo title bar and select Add Text Item.
5. Enter the text shown in Figure 10.32.
6. Select the **Bullet Point** check box and click **OK**.

   **Tip:** A horizontal flashing line appears at the top of the journal. Use the arrow keys to move the line to where you want to insert an object.

Now add a window reference as a link. These links lets you open a file with one click during the presentation.

7. Select **Help > Sample Data Folder** and open Big Class.jmp.

8. Click the red triangle in the My Bivariate Demo title bar and select **Add Window Reference**.

9. Select Big Class and click **OK**.

**Figure 10.33 Add a Window Reference**

10. Click the window reference to verify the link.

11. Display the window reference as a button by right-clicking the link and selecting **Style > Normal**.
Figure 10.34 Change the Link to a Button

12. Select **Edit > Lock Journal** to see the final journal.

When you lock the journal, the journal toolbar and insertion cursor no longer appear. And when you select Save Script > To Journal from a platform, the journal is not appended to the open locked journal.

Figure 10.35 Final Journal

**Tip:** You can also add objects to the journal by dragging them from the journal toolbar or putting your cursor where you want the object and double-clicking the object in the journal toolbar. The toolbar is available when you place your cursor over it.

Create New Journals

1. Close all open journals, and do one of the following:
   - To create an empty journal, select **File > New > Journal**. Or, from the JMP Starter window, select **New** in the Journal section.
   - To create a journal from an entire report or data table, select **Edit > Journal**.
   - To create a journal from a specific report or text in a report, click and drag the selection tool to select adjacent items in a report or data table. To select discontinuous items, press Shift and click the items with the selection tool. Then select **Edit > Journal**.
   - To create a journal from specific text in a data table, select the text, and then select **Edit > Journal**.
   - To create a journal from most graphs, right-click the graphic, and then select **Edit > Journal**. (Not available for surface plots and 3-D scatterplots.)
Tip: If you prefer keyboard shortcuts, press Ctrl+J (Windows) or Command+J (macOS) to create the new journal.

2. Select **File > Save** and save the journal in *.jrn* format.

**Manage Links in Shared Journals**

When you insert a link to a data table on your computer, the entire path to that data table is embedded in the journal. To share the journal or move it to another computer, store the linked files in the same directory as the journal or on a shared network drive. Because the files are in the same directory, the full pathname is unnecessary. Then the links are intact no matter where the journal is opened.

**Tips:**

- Zip the journal and supporting files so that another user can extract them to a directory. If the files remain in that directory, the links work.
- If you create a link to a sample data table, consider using the `${SAMPLE_DATA}` variable in the path. Likewise, you can use `${DESKTOP}` if the files are on your desktop or `${DOCUMENTS}` for your personal documents folder.
- You can edit several links at once within an outline. There is also an option to replace strings in the links. Right-click the disclosure icon next to the outline, and then select **Append Item > Edit Links**.

To create portable links in a journal

1. Put the data tables and other files that you want to reference in the same folder.
2. Save the journal in that folder.
3. Right-click at the bottom of the journal, select **Add File Reference**, select the file, and then click **Open**.
4. Right-click the link in the journal and select **Edit > Set Script**.
   
   Notice the full file path.
   
   `Open("C:\Users\shlori\journals\San Francisco Traffic.jmp")`
5. Delete everything in the string except for the file name.
   
   `Open("San Francisco Traffic.jmp")`
To embed a data table in a journal

To avoid linking to an external data table, copy the data table into a script and place it in the journal. The advantage is that other users always have access to your data, and you do not need to edit links. The disadvantage is that, if you want to edit the data, you must edit the script.

1. In the data table, click the red triangle next to the data table name and select **Copy Table Script**.

2. In the journal, right-click and select **Add Script Button**.

3. Enter a script name in the Name box.

4. Paste the table script into the Script box and click **OK**.

5. Right-click the link and deselect **Underline Style** display the link as a button.

Add and Edit Outlines to Journals

You can group text and links in an outline and then click the gray disclosure icon to expand and collapse the group.

- To add an outline, right-click in the journal, and then select **Append Item > Add Outline Item**. You can also add nested outline levels to outline levels that you have created. (When you click the red triangle menu of a graph that you have journaled, the **Add Outline Item** option is unavailable.) Click the outline’s red triangle and select **Add Outline Item**.
To edit the outline heading, double-click the heading, enter the new name, and press Enter.

To add text or links within an outline, click the outline’s red triangle and select an option described in “Right-Click Options in Journals”. Note that these options are not available when you click a scripted item’s red triangle.

To add text or links outside an outline, right-click the journal and then select one of the options described in “Right-Click Options in Journals”.

To edit a link, right-click the link, select Edit > Set Script, edit the path, and then click OK.

To edit the name of the link displayed in the journal, right-click the link, select Set Button Name, enter the new name, and then click OK.

**Right-Click Options in Journals**

**Add Outline Item**   Groups text and links into collapsible and expandable lists.

**Add Text Item**   Enter up to six paragraphs with the option to add a bullet or hide the text. To unhide, right-click the hidden text and deselect Hide.

*Note:* To add text outside an outline level, you can also double-click at the end of the journal and enter text in the box that appears. Click outside the box to exit the editing mode.

**Add Window Reference**   Creates a link to a window already opened in JMP.

**Add File Reference**   Creates a link to a file on your computer.

**Add Directory of Files**   Creates links to all files (including non-JMP files) in the selected directory.

**Add Open Files**   Creates outline levels and links to open files in JMP (except for the log). For example, a link to the open Big Class.jmp data table and chart is displayed below a collapsible heading named Big Class. Files such as journals, scripts, and tutorials are grouped below a collapsible heading called Other Files.

**Add URL Reference**   Creates a link to files that are delivered through an internet protocol such as HTTP, FTP, or FILE://.

**Add Script Button**   Creates a link to a JSL script. Right-click the link and deselect Underline Style to display the link as a button.

**Add Script Box**   Adds a box in which you enter a script.

**Lock**   Hides the journal toolbar and insertion cursor. If you select Save Script > To Journal from a platform, the results are not appended to a locked journal.
Edit Links  Enables you to rename file links (for example, to remove a hardcoded path). An option to test links is also provided. If the path is valid, nothing happens when you click Test Links. If it is not valid, an error message appears in the log. To update an invalid link, click Replace.

Size to Fit  Resizes the window to ensure that button names are fully displayed.

Control the Display of Outline Levels in Journals

You can instantly control which outline levels are displayed (for example, closing all sublevels below the selected level). Click the red triangle for that level, select OutlineBox, and then select one of the Open or Close commands. For more information about the Open and Close commands, see “Display Options for JMP Reports”.

Tip: On Windows, show the OutlineBox options by pressing Alt and right-clicking the outline level’s gray disclosure icon.

Add a Graph or Graphic to Journals

PNG, GIF, JPG, BMP, and TIF files are supported in journals. Do one of the following to add a graphic to a journal:

- Copy a graph from within JMP or a graphic from another application and then select Edit > Paste. JMP places the graphic at the end of the journal.
- Drag and drop the graph or graphic from another window to the journal. (See “Paste a Background Image into a JMP Graph”.) A blue line indicates where you can drop the graphic.

Tip: Consider resizing the graphic in an external program. Then you can insert the graphic at 100% resolution in the journal without dragging to resize the graphic.

Customize Items in Journals

- To click and drag journal items to different positions, select the selection tool ( ), select the item, and then drag the item to the new position. A line indicates where you can drag the item.
- To adjust text wrapping, right-click the text and select Set Wrap. Enter the number of desired pixels per line and click OK. To apply the wrap to all text items, select Set Wrap, select Extend this to other text boxes, and then click OK.
- To modify a plot axis, double-click or drag the axis. See “Customize Axes and Axis Labels in Graphs”.
• To add text or shapes anywhere in the report, use the drawing tools (Annotate, Line, Polygon, and Simple Shape). For more information about the drawing tools, see “Add Annotations and Shapes to JMP Reports and Graphs”.

• To resize plots and graphs, do one of the following:
  – Click and drag the edge.
  – Right-click the plot or graph, and then select Size/Scale > Frame Size. See “Resize Graphs”.

• To modify the format of a numeric column, you edit the Properties pane for the display box. See “Change the Format of Numeric Columns”.

### Prevent Modifications to Journals

When a journal is opened, and you then journal another report or data table, the second report or data table is added to the end of the open journal.

To prevent modifications to a journal, right-click the blank area at the bottom of the journal and select Lock. Additional reports are not added to the journal (as described in the following section). JMP instead finds an open unlocked journal or creates a new journal when you select the Edit > Journal command again.

To unlock the journal, right-click the blank area at the bottom of the journal and deselect Lock.

### Append Reports to Journals

To append other reports to a report that you already journaled, open the journal and select Edit > Journal. If an area of an analysis window is selected, Edit > Journal saves only the selected area instead of the entire window.

**Notes:**

• The journal window has the same functions as the report window: you can click icons, click and drag, and right-click to access menus.

• When a report is journaled, the journaled copy is no longer connected to the data table. To maintain that connection, save the report as JMP report and insert a link to it in the journal.

### Save Journals in Other Formats

You can save a journal in another format (such as HTML or PDF). When you save the journal as HTML, buttons and links are active when the file is viewed in a web browser.
Save and Share Your Data

Chapter 10
Using JMP

Note: The header and footer defined in your printer setup appears in the PDF file. However, you can set the left, center, and right header and footer in a JSL script. Search for the Set Print Footers message in the JMP Scripting Index. (Select Help > Scripting Index in JMP.)

Windows

1. Select File > Export.
2. Select the format. See “Save Reports”.
3. Click Next.
4. (Optional) Rename the file.
5. Save the file.

macOS

1. Select File > Export.
2. Select the format. See “Save Reports”.
3. Click Next.
4. Name and export the file.

Delete Items from Journals

1. Click the selection tool ( ).
2. Select the item that you want to delete and press Delete.

Save JMP Sessions

Each time you use JMP is called a session. A saved session is a JSL script that re-opens documents and re-runs analyses to restore JMPs state when the session script was saved. A saved session can help get you back to a previous state without having to manually re-open files and re-run analyses.

If you are an advanced user, it is important to understand what session information is preserved in a saved session. Any documents (such as data tables, scripts, and journals) that have been saved are re-opened. JMP windows that support script saving are re-run (equivalent to clicking the red triangle in a report and selecting Redo > Redo Analysis). Side effects of running scripts, such as global variable values or custom windows, are not saved. The state of highly interactive analyses is also not saved.
Save Sessions upon Exiting JMP

The most common use of saved sessions is to save the state when JMP exits so that it can be restored when JMP restarts. By default, JMP asks whether you would like to save the state of your session each time you exit the program (Figure 10.37). This enables you to quit JMP, and then return to it later without having to open the files with which you were previously working.

Figure 10.37 Saving Session uponExiting

To always save the session upon exiting, select Do not ask me again about saving the session and click Yes or No. This option also prevents JMP from saving the session upon exiting.

You can change this option later in Preferences:

1. Choose File > Preferences.
2. Select the General icon.
3. Next to the Save the session when exiting option, choose when you want JMP to save the session. Always, never, and prompt whether you want to save are the options.

Save Sessions Manually

You can also save a session to a location of your choosing and continue working, so you can restore the saved state whenever you like. Manually saving sessions is useful when you want more control of session saving and restoring. This option is especially helpful when you want to maintain multiple independent session states. Each state has a different set of files and analyses.

To create a script of a JMP session

1. Select File > Save Session Script.
2. Enter the name of your script in the window and click Save.

Another way of manually saving a session is by creating a journal of each session. A journal can be a notebook-style or project-style file. With it, you can collect references to files in a project, develop presentation launch pads, document projects, and store many scripts in one place. See “Create Journals”.

To create a journal of a JMP session

1. Open the files that you would like to include in the journal.
2. Select **File > New > Journal**. Or, to append your open files to an existing journal, open that journal.

3. Right-click in the empty journal and select **Add All Open Files**.

---

### Save a Log Window

Selecting **View > Log** displays a window that monitors JMP activities, such as JSL statements as they execute and script errors. You might also encounter instances where running a formula, matrix, or another operation writes information of interest to the log window.

To save a log, follow these steps:

1. Open the Log window.
2. Select **File > Save As**.
3. (Windows only) To open the log automatically when text is added to it, select **File > Preferences > Windows Specific**. In the **Open the JMP Log window list**, select whenever text is added.
JMP is an extensible program that lets you broaden its functionality to create your own JMP components. With Dashboard Builder, you combine reports into a dashboard, a visual tool that lets you run and present reports on a regular basis. No JSL knowledge is required. Start with a template, click report components, insert graphs and pictures, and the dashboard is done. You can also combine windows outside Dashboard Builder to create dashboards.

Figure 11.1 A Dashboard with Two Reports
## Contents

- Combine JMP Reports by Creating a Dashboard ........................................... 635
- Example of Creating a Dashboard with Two JMP Reports ............................... 635
- Using the Dashboard Builder ........................................................................... 636
- Red Triangle Options in the Dashboard Builder .............................................. 637
- Start with a Sample Dashboard ....................................................................... 638
- Edit a Dashboard ............................................................................................ 639
- View a Running Dashboard .............................................................................. 642
- Example of Combining Windows to Create a Dashboard ............................... 646
- Example of Adding Selection Filters to a Dashboard ...................................... 648
- Example of Creating a JMP Query Dashboard and Add-In ......................... 650
- Example of Creating a Dashboard from Two Data Tables .............................. 652
Combine JMP Reports by Creating a Dashboard

With Dashboard Builder, you combine reports to create your dashboards without writing JSL scripts. Similar to Application Builder, Dashboard Builder has a drag-and-drop interface but with pre-configured display boxes. In Dashboard Builder, the display boxes do not require customization as they do in Application Builder. You can put reports and graphs in tabs, embed database queries, save the dashboard as an add-in, and more.

You can also quickly create dashboards by combining several open windows using the Window > Combine Windows option. For example, you might combine two reports and a data table to arrange them on a dashboard. See “Example of Combining Windows to Create a Dashboard” for an example.

Example of Creating a Dashboard with Two JMP Reports

Suppose that you created two reports and want to run the reports again the next day against an updated set of data. This example shows how to create a dashboard from the reports.

2. To create the reports, run the table scripts named “Distribution: Profitability by Lead Studio and Genre” and “Graph Builder: World and Domestic Gross by Genre”.
3. From any window, select File > New > Dashboard.
   Templates for common layouts appear.
4. Select the 2x1 Dashboard template.
   A box with room for two reports appears on the workspace.
5. In the Reports list, double-click the report thumbnails to put them on the dashboard (Figure 11.3).
6. Click the Dashboard Builder red triangle and select Preview Mode.
   A preview of the dashboard appears (Figure 11.2). Notice that the graphs are linked to each other and the data table. They also have the same red triangle options as the Distribution and Graph Builder platforms.
7. Click Close Preview.

8. In Dashboard Builder, select File > Save, and then save the file as a .jmpapp file.
   Users who have JMP can open the data table and double-click this file to display the dashboard. Note that the .jmpapp file cannot be edited.

9. Return to the Dashboard Builder window, select File > Save As, and then save the file as a .jmpappsource file.
   The dashboard is saved in a file that you can edit in the future.

   **Note:** You might also want to save the dashboard as an add-in. Users then view the dashboard by selecting a menu item in the main Add-Ins menu instead of opening the .jmpapp file. See “Example of Creating a JMP Query Dashboard and Add-In”.

### Using the Dashboard Builder

**Figure 11.3** shows a dashboard in development. The two reports in the left pane were generated from the Hollywood Movies.jmp sample data table. Those reports were added to the right pane. “Hollywood Movies.jmp” is displayed in a text box that was added to the dashboard and centered using the toolbar buttons.
Red Triangle Options in the Dashboard Builder

The Dashboard Builder red triangle menu provides options such as running the dashboard, previewing the dashboard, and saving the dashboard as an add-in.

- **Run Dashboard**  Starts the dashboard.

- **Preview Mode**  Displays a preview of the dashboard. Click **Close Preview** on the dashboard to return to the dashboard mode.

- **Start Over**  Remove objects from the workspace and select a new template.

- **Show Grid**  Displays dotted grid lines on the workspace. Selected by default.

- **Show Properties**  Shows or hides the Objects and Properties panels for editing display boxes. See the **Scripting Guide** for more information about editing properties.

- **Auto Scroll**  Automatically scrolls horizontally or vertically as you drag an object near the edges of the workspace. Selected by default.
Dashboard Mode  Deselect to display the dashboard in Application Builder, where you can fully customize the application and write scripts. See the Scripting Guide. Select Dashboard Mode to return to the dashboard.

Source Panel  Shows or hides the Sources panel (the left column in which report components are displayed) and categorizes the icons. Show Sources is selected by default.

Save Script  Contains options that enable you to save a script that reproduces the report to several destinations.

To Data Table  Saves the script to the data table that was used to produce the report. This enables you to run the script again from the data table to recreate the results.

To Journal  Saves a link in a journal window that runs the script for the analysis. If a journal window is already open, the script is added to that journal window. The script contains the path to the data table. Note that if the data table cannot be found, the script does not run.

To Script Window  Opens a script editor window and adds the script to it. If a script window is already open, the script is added to the bottom of that open window.

To Add-In  Lets JMP users install the application and launch it from a JMP menu. See the Scripting Guide.

To Template  Saves the application as a template from which you can create new dashboards. The templates are saved in the following locations based on your operating system and JMP version:

- Windows (JMP): 
  
  "$C:/Users/<username>/AppData/Roaming/SAS/JMP/17/DashboardTemplates"

- Windows (JMP Pro): 
  
  "$C:/Users/<username>/AppData/Roaming/SAS/JMPPro/17/DashboardTemplates"

- macOS: 
  
  "~/Users/<username>/Library/Application Support/JMP/17/DashboardTemplates"

Start with a Sample Dashboard

Examples of dashboards are shown when you open Dashboard Builder. You can modify these samples instead of starting with an empty dashboard. The dashboards are also installed in the JMP Samples/Dashboards folder.

The following sample dashboards are available:

**Instant Dashboard.jmpappsource**  Combines two Multivariate reports (Principal Components/Factor Analysis and T Square with All Principal Components).
Six Quality Graphs Dashboard.jmpappsource creates three Control Charts, a Distribution report, and a Capability Analysis report.

**Edit a Dashboard**

“Example of Creating a Dashboard with Two JMP Reports” shows how to create a dashboard from two reports. This section shows how to arrange those reports and preview the final dashboard.

**Rearrange Reports in Dashboard Edit Mode**

To help you rearrange reports while editing a dashboard, the outline around a report includes drop zones. When you drag the report into a different area of the box, a portion of the box is highlighted. The highlight shows where you can drop the box.

Figure 11.4 shows how to create tabbed reports. To put the Distribution report inside a tab, drag the report over the other report until the upper right corner of the bar chart report is highlighted. The Distribution report appears in a tab on top of the other report.

To remove a tabbed report, click the middle of the report and drag it outside of the tab.

**Figure 11.4 Working with Tabbed Reports in Dashboard Edit Mode**

Figure 11.5 shows an example of placing a data table inside the bottom border of the report.

To display the data table below the report instead of inside it, drag the Data Table box onto the dashboard below the report. The box snaps inside the bottom border of the report.
Figure 11.5  Displaying a Data Table Inside a Report

Figure 11.6  shows a data filter that appears to the left of a report.

Figure 11.6  Adding a Data Filter to the Left of a Report
**Tip:** It can be hard to tell which report a filter is acting upon, or if a filter applies to all graphs. You can change the title of a data filter to indicate which graphs it impacts.

**Format Text in a Dashboard**

When you edit a dashboard, you can format text in a text box. Drag the text box to the dashboard and click the middle of the text box. Formatting options appear.

![Figure 11.7 Formatting Options for a Text Box](image)

**Preview a Dashboard**

When you edit a dashboard, you can see a preview of the final dashboard by selecting **Preview Mode** from the Dashboard Builder red triangle menu. Previewing a dashboard is particularly helpful when testing interactive elements such as column switchers, data filters, and tabbed reports.

**Note:** If you resize panes in preview mode, your changes are not saved.

**Tips:**

- The column switcher initially shows all columns in the table, but it does not actively make changes to reports in the dashboard or application.
- You should switch into preview mode to do the following:
  - Select the initial column to be switched in all reports.
– Remove any columns that you do not want to appear in the column switcher, including any other columns that are used in the reports.

• When you run the dashboard or application, the column switcher automatically connects to all platforms in the dashboard that use the same data table.

**View a Running Dashboard**

When you view a running dashboard, the same red triangle options that you find in JMP platforms are available in the reports. Dashboard Builder also provides several other options.

**View a Report Summary**

A report that contains graphs and statistics can grow fairly large. To view only the graphs while running the report, select the top red triangle in a report and then select **Report View > Summary**. The report shown in Figure 11.8 originally showed parameter estimates. In the Summary view, only the graphs are shown.
Rearrange Reports in a Running Dashboard

You rearrange reports in a running dashboard by dragging the reports into highlighted drop zones. The drop zones indicate where you can place the report. Figure 11.9 shows an example of moving a report into a tab. The Distribution report is dropped inside the “Dock tab” drop zone to place it on the first tab.
Figure 11.9 Creating Tabbed Reports in a Running Dashboard

To remove a tabbed report, click the middle of the report and drag it outside of the tab.

Maximize a Report in a Running Dashboard

To see only a specific report while running a dashboard, select the report’s Maximize Tab box.
To restore the report to its original size, select the **Restore Tab** box.

---

**Figure 11.12** shows the collapsed and expanded reports.
Combining JMP Reports by Creating a Dashboard

**Figure 11.12** Resizing Panes in a Running Dashboard

You can also drag the edge of a graph. The graph widens as far as the width of the window and the other reports allow.

**Share Reports with Users Working Outside JMP**

You can share reports with users working outside JMP by saving a dashboard as interactive HTML. First, click the Dashboard Builder red triangle and select **Run Dashboard** to run the dashboard. In the running dashboard, select **File > Save As** and then select **Interactive HTML with Data** from the list. The reports are saved in a web page that also contains the data. Email the web page to users or publish the page on a website. Users then explore the data as they would in JMP. See “Share Reports as Interactive HTML”.

**Edit a JMP Platform Script**

A dashboard consists of a JSL script, which you can edit in Dashboard Builder. For example, you might edit the script for the Multivariate platform to show the scatterplot matrix or to use different columns.

Right-click the object for a platform in the dashboard and select **Edit Platform Script**. The script opens in a script editor window.

After you edit the script and click OK, the object on the workspace is updated.

**Example of Combining Windows to Create a Dashboard**

You can quickly create dashboards by merging several open windows in JMP. Combining windows provides options to view a summary of statistics and include a selection filter.

1. Select **Help > Sample Data Folder** and open **Birth Death.jmp**.
2. Run the Distribution and Bivariate table scripts.

3. From one of the report windows, select **Window > Combine Windows**.

   The Combine Windows window appears.

   **Tip:** On Windows, you can also select Combine Windows from the Arrange Menu option in the lower right corner of JMP windows.

4. Select **Summary Report View** to display the graphs and omit the statistical reports.

5. In the Combine column, select **Birth Death - Bivariate of death by birth** and **Birth Death - Distribution**.

6. In the Filter By column, select **Birth Death - Distribution**.

   **Figure 11.13** Combine Windows Options

7. Click **OK**.

   The two reports are combined into one window. Notice the filter icon at the top of the Distribution report. When you select a bar in one of the histograms, the corresponding data in the Bivariate graph are selected.

**Notes:**

- To combine reports on Windows, you can also select Combine Windows from the Arrange Menu option in the lower right corner of JMP windows.
- To see statistics with the graphs, from the red triangle menu, select **Report View > Full**.
Example of Adding Selection Filters to a Dashboard

In a dashboard that contains several reports, you can select data in a report and then view only that data in other reports contained in the same window. This example shows how to add selection filters to the primary report when you edit a dashboard.

Open Reports and Create a Dashboard

2. To create the reports, run the table scripts named “Distribution: Profitability by Lead Studio and Genre”, “Graph Builder: World and Domestic Gross by Genre”, and “Bubble Plot: Theaters Open Week by Domestic Gross”.
3. From any window, select File > New > Dashboard.
   Templates for common layouts appear.
4. Select the 2x1 Dashboard template.
   A box with room for two reports appears on the workspace.
5. In the Reports list, double-click the Graph Builder and Distribution report thumbnails to put them on the dashboard.
Add and Use Selection Filters

1. Right-click the center of the left report (Graph Builder) and select **Use As Selection Filter**.
2. To add another report as a second selection filter, click the Bubble Plot thumbnail and drag it into the blue line around the Graph Builder graph.

**Figure 11.15** Dragging the Bubble Plot into the Graph Builder Graph

A filter icon appears on both thumbnails.

3. Click the Dashboard Builder red triangle and select **Preview Mode**.
4. Select one of the bars for the Fantasy genre in the left report.
Figure 11.16 Filtering Data

In the right report, you can see that Warner Bros and Independent studios produced the most fantasy movies. In the bottom report, you can see that Harry Potter was the most profitable fantasy movie.

Example of Creating a JMP Query Dashboard and Add-In

Suppose that you used JMP Query Builder to import portions of two data tables into JMP. A dashboard displays reports of the data. You want to create an add-in that queries the data and shows the updated reports on a dashboard.

Build the Query

2. Select Tables > JMP Query Builder.
3. Click Build Query.
4. In the Available Columns list, double-click t1.Movie Name, t1.Rotten Tomatoes Score, t1.Audience Score, and t1.Theaters Opening Wknd to add them to the Included Columns tab.
5. Click Run Query.
The queried data appears in a new data table. Note the Source table script. When you open the dashboard, JMP runs this Source script to query the data in Hollywood Movies.jmp.

6. In the new data table, run the **Graph Builder: Scores by Opening Weekend** table script to create a report.

**Create the Dashboard**

1. From the report window, select **File > New > Dashboard**.
2. Select the **Blank Dashboard** template.
3. Double-click the **Data Filter(Local)** box in the left pane to add it to the dashboard.
4. Double-click the Graph Builder report in the left pane to place it next to the local data filter.

**Figure 11.17** Dashboard for Hollywood Movies

**Create and Run the Add-In**

1. Click the Dashboard Builder red triangle and select **Save Script > To Add-In**. Add-In Builder opens.
2. Next to Add-In name, type Hollywood Movies Dashboard (the add-in filename).
3. Click the **Menu Items** tab and type Hollywood Movies Dashboard next to **Menu item name** (the name of the add-in menu item).
4. Click **Save** and save the add-in to your desktop.
   The add-in is saved and installed in your Add-Ins menu.
5. Click **Close** on the Add-In Builder window.
6. From the JMP main menu, select **Add-Ins** and select **Hollywood Movies Dashboard***.

The Hollywood Movies.jmp data table is queried, and the dashboard opens to show the local data filter and updated report.

**Figure 11.18** Hollywood Movies Add-In

![Hollywood Movies Add-In](image)

**Example of Creating a Dashboard from Two Data Tables**

The graphs or reports in a dashboard can be created from multiple data tables. The data table used for the first graph on the dashboard is considered the current data table by default. This gives the user the flexibility to use any current data table to create the graph or report. The dashboard author can also hard-code the path. Specifying the name gives the dashboard author control over which data table is used.

1. Select **Help > Sample Data Folder**, open Big Class.jmp, and run the Bivariate script.
3. From any JMP window, select **File > New > Dashboard**.
4. In Dashboard Builder, select the **2 x 1 Dashboard** template.
5. Double-click the Distribution graph to add it to the dashboard first.

   By default, this graph uses whatever data table is the current data table. In this example, Hollywood Movies.jmp stored in the Samples/Data folder is the current data table.

6. Double-click the Bivariate graph to add it to the dashboard.

   You are prompted to determine whether the first graph uses the current data table or whether you want to hard-code the path to the data table (reference the table by name) in the dashboard.
7. Select **Reference table by name** to make sure the specified data table is always used to create the graph.

8. Click **OK**.

   In this example, Hollywood Movies.jmp in the Samples/Data folder will always be used as the current data table for the first graph, despite the current data table that is open.

**Tip:** Sometimes a named data table cannot be found when the dashboard is run. This is particularly common when the dashboard is moved to a different computer. You can either open the data table before running the dashboard or run the dashboard and select the data table when prompted.

---

**To Change the Location of the Data Table**

After you assign the location of the data table (current data table or name), you can change the setting in the dashboard Objects and Properties panes.

1. Click the Dashboard Builder red triangle and select **Show Properties**.

**Figure 11.19 The Objects and Properties Panes**

2. In the Objects pane, select `DataTable1`.

3. In the Properties pane, change the Location as shown in **Figure 11.19**.
For example, if you change the Name location to Current Data Table, the selected graph on the dashboard is based on the current data table.

**Note:** The Location value of Current Data Table applies only when you are running the dashboard. When you are editing the dashboard, Dashboard Builder uses the full path to locate the data table.
The Workflow builder is a JMP utility to capture, build, manage, and share data preparation and analysis workflows. The Workflow Builder uses the Enhanced Log to capture actions as you work in JMP. Use the Workflow Builder to do any of these actions:

- automate a workflow
- share a workflow
- re-run a sequence of steps with new data
- archive or document an analysis

**Figure 12.1** Workflow Builder
Contents

Overview of the Workflow Builder ................................................................. 657
Example of Workflow Builder ................................................................. 657
Launch the Workflow Builder ................................................................. 661
The Workflow Builder Window ................................................................. 662
  Workflow Steps ..................................................................................... 662
  Step Settings ......................................................................................... 664
  JMP Log History .................................................................................. 665
Workflow Builder Options ................................................................. 665
Additional Examples of the Workflow Builder ........................................... 666
  Example of Creating a Workflow from the Log History ......................... 666
  Example of Creating a Workflow with a Step Setting .............................. 667
  Example of Adding to a Workflow from the Enhanced Log .................... 668
Technical Details for the Workflow Builder .............................................. 668
Overview of the Workflow Builder

The Workflow Builder is a utility that extends the actions recorded in the Enhanced Log to save JMP steps in a package for reuse. Interactively record steps, rearrange steps, add steps from a log, or add JSL code to build a workflow. For more information about the Enhanced Log, see

Example of Workflow Builder

This example creates a workflow that does the following:

- Opens a data table
- Prepares the data by adding a new formula column, changing a column name, and formatting values
- Builds a table showing bill amounts by server by day of the week
- Builds a graph showing tip percentages by credit card type

Start Recording and Open Data

1. Select File > New > Workflow (Windows) or File > New > New Workflow (macOS).
2. Click to start recording your actions.

   Tip: This example starts recording before performing any steps. However, you can capture steps after you have performed them. See “JMP Log History”.

3. Select Help > Sample Data Folder and open Restaurant Tips.jmp.
   Notice that a step to open the data table is recorded in the Workflow Steps.

Prepare Data

To illustrate data preparation steps, create a new Tip Percent column.

1. Highlight the Bill Amount and the Tip Amount columns, right-click on the column headings and select New Formula Column > Combine > Ratio (reverse order).
2. Format the new formula column that you added to the table:
   a. Highlight the Tip Amount/Bill Amount column and select Cols > Column Info.
   b. Change the Column Name to Tip Percent.
   c. Next to Format, click Best and choose Percent and set the Dec to 1.
   d. Click OK.
Build a Table
1. Click Analyze > Tabulate.
2. Drag Day of Week to the Drop zone for rows.
3. Drag Bill Amount into the values under N.
4. Click Done.

Figure 12.2 Table of Bill Amounts by Day

![Table of Bill Amounts by Day](image)

Notice that this step is not yet recorded in Workflow Builder. The step does not appear until you confirm that you are finished.

5. To confirm that the analysis is complete, close the Tabulate window.

Tip: If you were not actively recording your steps, use Save Script > To Workflow from the platform’s red triangle menu to add the step to the Workflow Builder.

Build a Graph
1. Click Graph > Graph Builder.
2. Drag Credit Card to the X axis.
3. Drag Tip Percent to the Y axis.
4. Hold the shift key and click the Box Plot element.
5. Click Done.

Again, the step is not yet recorded in Workflow Builder.
6. To confirm that the graph is complete, close the Graph Builder window.

**Stop Recording and Test the Workflow**

**Tip:** You can perform these steps to test your workflow anytime. You can continue to edit the workflow after testing.

1. Click 🔄 to stop recording.
2. Click the Workflow Builder red triangle and select **Presentation Mode**.
Figure 12.4 Workflow Builder in Presentation Mode

3. Click \( \text{ \textcolor{blue}{\text{Start/Stop}}} \) to reset. This closes any open windows and resets the workflow to the start.

   **Note:** The reset button closes only those windows opened by the workflow.

4. Click \( \text{ \textcolor{red}{\text{Run}}} \) to test the workflow.

**Save the Workflow**

1. Click File > Save.

   JMP Workflows have the extension .jmpflow.

   **Tip:** To add steps to a saved workflow, open the workflow in JMP and simply start recording again.

**Share the Workflow**

To share a workflow with another JMP user, create a workflow package. The package contains the workflow and associated files. The file is a *.jmpflow file.

1. Click the Workflow Builder red triangle and select **Create Workflow Package**.
2. Select Presentation Mode to have the workflow open with the Log History closed.
3. Confirm the inclusion of the data sources. To send a copy of the associated data, keep the box selected.
If you do not include a copy of the data, anyone that you share the workflow with is prompted to open a data table. The data table must be compatible with the workflow, otherwise the user could encounter errors.

**Note:** When data is on a shared drive, it might not be necessary to include the data sources in your workflow package.

4. Click **OK**.

On your computer, navigate to where you saved the workflow package. You can send this package to any JMP user.

---

**Launch the Workflow Builder**

Launch the Workflow Builder by selecting **File > New > Workflow**.

**Figure 12.5** Workflow Builder Launch Window
The Workflow Builder Window

The Workflow Builder Window has three sections. The Workflow Steps is where you view and arrange your workflow steps. The Step Settings is where you can edit and add advanced actions to your steps. The JMP Log History is a history of your JMP session.

- “Workflow Steps”
- “Step Settings”
- “JMP Log History”

Workflow Steps

The Workflow Steps section collects your JMP steps. Steps are added while you are recording, when you select **Save Script > To Workflow** from a platform red triangle menu, when you move a step from the Log History, or when you add an action from the Step Settings. Hover on a step to view the JSL code for the step.

Use the controls to start and stop workflow recording or to play the workflow.

- Start the workflow recording. Steps not recorded can be added to the workflow from the Log History, from the Enhanced Log, from the platform **Save Script > to Workflow** option, or pasted from the JSL saved to the clipboard.
- Stops the workflow recording.
- Resets the workflow. Closes all outputs created by the workflow, resets tables to their original states, and resets the workflow to the first step.
- Executes the current workflow.
- Rewinds one step. This closes windows opened on the current step and resets the cursor to the previous step
- Executes the current step and moves the execution cursor to the next step.

Use additional controls to rearrange steps in the workflow. Alternatively, select a step and drag it to a new position.

- Moves the selected step up one position.
- Moves the selected step down one position.
Each step in the workflow has one or more icons.

- Indicates a step with an error. Highlight the row and open the Step Settings to view the JSL code for the step.
- Indicates a step that executes without an error.
- Indicates a step that generates a report or new table. Click to see a thumbnail of the report or table.
- Indicates the current step.
- Indicates a breakpoint. The workflow stops at this step. Click on the gray bar to the left of a step to set a breakpoint for debugging. Click on a breakpoint once to disable and click again to remove the breakpoint.
- A check box that is enabled by the **Show Enable Checkbox** option in the Workflow Builder red triangle menu. Use to enable (check) or disable (uncheck) workflow steps.
- Indicates a note for the step. Click to read. Set notes in the Step Settings section. Use to add comments to your workflow.

Select one or more rows and use right-click options to group steps or as alternatives to using the controls.

**Cut, Copy, Paste** Use to cut, copy, or paste workflow steps.

**Group Selected** Groups selected steps in a group. Rename the group in the Step Settings.

**Tip:** Group steps in a group to further nest the steps for organizing long workflows.

**Add Empty Group** Adds an empty group to the workflow. Drag and drop steps into the group.

**Ungroup** (Available when a group is selected.) Ungroups the grouped steps.

**Step Enabled** Disables or enables the step in the workflow. Disabled steps are indicated by light italic text and are skipped when the workflow runs.

**Tip:** Use the **Show Enable Checkbox** option in the Workflow Builder red triangle menu to enable checkboxes to manage disabled steps.
**Rerecord Steps**  Runs the workflow to rerecord steps. Use to identify and remove unnecessary steps. Unnecessary steps are crossed out and removed when you click **Done** in the Rerecord Steps controls.

**Run to Step**  Runs the workflow from the current position until the selected step is reached.

**Run Selected**  Runs the selected step or group of steps.

**Set Next Step to Execute**  Moves the execution cursor to the selected step to indicate that it is the next step to execute.

**Set Breakpoint**  Sets a breakpoint in the workflow. Use for testing a portion of your workflow.

**Hide Tables from Selected**  Adds a hide tables step action to the selected steps. After the step runs, any tables created during that step are marked invisible. Use this to hide intermediate tables that do not need to be seen, but cannot be closed because reports or other tables depend on them.

### Step Settings

Use the Step Settings section to edit workflow steps or to add advanced steps to the workflow.

**Step Name**  Enables you to edit step names.

**Notes**  Add notes to a step. This adds a note icon to the step. Use to annotate your workflow.

**Add action**  Enables you to add an action to the workflow. Click away from the Step Settings to add the action to the workflow.

**Show Message**  Adds a pop-up message to the workflow.

**Subset**  Opens a Subset section to select a random subset of all tables opened in a specific step.

**Set Random Seed**  Opens a Set Random Seed section to set a random seed for a specific step. Use to generate the same results with each run of the workflow. Many modeling techniques use random starting points.

**Hide Tables**  Adds a hide tables step action. After the step runs, any tables created during that step are marked invisible. Use this to hide intermediate tables that do not need to be seen, but cannot be closed because reports or other tables depend on them.

**Custom**  Use to add a custom action to a step in your workflow. Use any valid JSL statement or function.

**Step Code**  Contains the JSL code for each step. Enables you to view and edit the JSL code.
Step Action Timeline

Use the Step Action Timeline to customize your workflow. For example, use to add wait steps.

JMP Log History

The JMP Log History contains actions recorded for the entire JMP session. Use the up arrow to add a selected step to the workflow. Actions are grouped by time. The actions recorded in the JMP Log History are the same actions recorded in the Enhanced Log (View > Log) (Windows) or Window > Log (macOS). Right-click to clear the log history.

Workflow Builder Options

The Workflow Builder red triangle menu contains the following options:

**Presentation Mode**  Sets the workflow to presentation mode where the Log History is hidden and the ability to edit the workflow is limited.

**Show History Grouped by Age**  Groups or ungroups history based on time.

**Allow Backstep**  Enables the user to back up a step in the workflow. This is a useful option to have enabled as you record and work on a workflow. Once complete, disable to increase the execution speed of the workflow.

**Name Default to Here**  Sets the names to local names

**Show Enable Checkboxes**  Shows or hides check boxes on the workflow to enable or disable steps in the workflow.

**Set Notes**  Adds a note above the workflow steps.

**Tip:** During development, disable when working with large data tables if you encounter slowness in your workflow.

**References**  As the workflow executes, it prompts the user for tables or columns that are not found in order to continue the workflow. The References menu contains the following options.

**Allow Replacement of References**  (Selected by default.) Enables the workflow to prompt for unknown tables or columns.
Additional Examples of the Workflow Builder

This section contains examples using the Workflow Builder:

- “Example of Creating a Workflow from the Log History”
- “Example of Creating a Workflow with a Step Setting”
- “Example of Adding to a Workflow from the Enhanced Log”

Example of Creating a Workflow from the Log History

A workflow can be started at any point during a JMP session. In this example, add steps from the log history to a workflow. Start with a new JMP session.
1. Select **Help > Sample Data Folder** and open Iris.jmp.
2. Select **Graph > Graph Builder**.
3. Select Sepal length and drag to the X zone.
4. Select Sepal width and drag to the Y zone.
5. Click **Done**.
6. Close Graph Builder.
7. Select **File > New > Workflow**.
   In the JMP Log History, all the steps you have performed since you opened your JMP session are captured.
8. Select the Graph Builder steps that you want to add to your workflow.

**Figure 12.6** Selecting Steps in Workflow Builder

9. Click to move the steps up.
10. Click to test the workflow.

**Example of Creating a Workflow with a Step Setting**

In this example, add steps to a workflow from the Enhanced Log.
1. Select **File > New > Workflow**.
2. Click to start recording your actions.
3. Select **Help > Sample Data Folder** and open Iris.jmp.
4. From the Workflow Builder red triangle menu select **Add Custom Action**.
5. Click the gray triangle next to Step Settings.
6. Click Custom Action in the Workflow Steps section.
7. In the Step Code section of the Step Settings panel type `Oneway(Y(:Petal width), X(:Species))` and click away from the Code window.
8. Click to stop recording.
9. Click to reset. This closes any open windows and resets the workflow to the start.
10. Click to test the workflow.

Adding a step from the Step Settings is an alternative to recording, adding from the JMP Log History, or using the platform **Save Script > to Workflow** option. It also enables you to add JSL code for complex actions not recorded by the Workflow Builder.

---

**Example of Adding to a Workflow from the Enhanced Log**

In this example, add steps to a workflow from the Enhanced Log.

1. Select **File > New > Workflow**.
2. Select **Help > Sample Data Folder** and open Iris.jmp.
3. Select **Yes** from the Record Action pop-up window.
4. Select **Graph > Graph Builder**.
5. Select **Sepal length** and drag to the X zone.
6. Select **Sepal width** and drag to the Y zone.
7. Click **Done**.
8. Open the Enhanced Log (**View > Log**) (Windows) or **Window > Log** (macOS).
9. Select the Report snapshot: Iris - Graph Builder row. Right-click and select **Save Script > Add to Workflow**.

Adding the step from the Enhanced Log is an alternative to recording, adding from the JMP Log History, or using the platform **Save Script > to Workflow** option.

---

**Technical Details for the Workflow Builder**

The following are technical notes about the Workflow Builder.
Notes:

- The Workflow builder uses actions captured in the Enhanced Log. If an action is not captured in the Enhanced Log, it is not be captured by the Workflow Builder. Use the custom option in the “Step Settings” to add JSL for such steps.

- The JMP Log History captures activity from the start of the JMP session, regardless of when the Workflow builder is opened.

- If you add an action from the Enhanced Log and there is more than one Workflow Builder open, it adds the step to the topmost builder.

- Workflow builder runs within projects.

- As the workflow executes, each step is evaluated before it is run. If a hardcoded table path is found and the table is not open, the user is prompted to open the table or one that is compatible to continue the workflow. Similarly, if an unknown column references is found, the user is prompted for a replacement. This is limited to 1-1 replacement. It will not work well for a large number of column replacements.

- When publishing to JMP Live or JMP Public, ensure that the report step is ahead of the publish step in the workflow.
This chapter describes how to customize JMP menus and toolbars to show only the commands that you need. For example, you might remove the SAS option in the File menu if you do not use SAS. Or you might assign a shortcut key to the Run Script command.

Customizing JMP also lets you set up JMP for groups with special interests. If one group does not design experiments, you could remove DOE from the JMP menu.

**Note:** When you upgrade to JMP 17 Subscription, changes to preferences are maintained.
## Contents

- **Customize JMP Toolbars and Menus on Windows** .......................................................... 673  
- **Customize Toolbars** ........................................................................................................ 674  
- **Customize the Main Menu Bar** ........................................................................................ 677  
- **Create Menu Items and Toolbar Buttons** ....................................................................... 678  
- **Set User Permissions for Customized Toolbars and Buttons** .......................................... 682  
- **Rearrange Toolbars** .......................................................................................................... 683  
- **Copy and Paste Menus, Menu Items, Toolbars, and Buttons** .......................................... 683  
- **Rearrange Custom Menus, Menu Items, and Buttons** ....................................................... 685  
- **Delete Custom Items** ......................................................................................................... 686  
- **Show or Hide Custom Items** ............................................................................................. 687  
- **Import Customizations** ....................................................................................................... 688  
- **Remove Customizations from JMP** .................................................................................. 688  
- **Customize Toolbars on macOS** ......................................................................................... 689  
- **Customize Menus on macOS** ............................................................................................ 691  
- **Customize Menus and Toolbars for Add-Ins** .................................................................... 692
Customize JMP Toolbars and Menus on Windows

*Toolbars* consist of buttons that execute commands and dividers that help you organize the buttons. In Windows, there are many ways to customize toolbars. For example, you can create, rename, hide, and modify toolbars or buttons. You can also rearrange or delete toolbars and buttons that you create.

*Menus* consist of commands, submenus, and separators. As with toolbars and buttons, you can create, rename, hide, and modify menus. You can also rearrange or delete menus and menu items that you create.

You customize toolbars and menus in the Menu Editor. The names of modified items are formatted to indicate which items were created, modified, or hidden, and which items are unsaved.

**Figure 13.1** Menu Editor Options

- **Customization set options.**
- **Item definition.**
- **Currently editing:** Customizations for current user
- **Details for:** Home > Open Database Table
- **Main Menu:**
  - **File:**
  - **Edit:**
  - **Layout:**
  - **Format:**
  - **Tables:**
  - **Rows:**
  - **Cols:**
  - **DOE:**
  - **Analyze:**
  - **Graph:**
  - **Tools:**
  - **View:**
  - **Window:**
  - **Help:**
- **Toolbars:**
  - **File, Edit:**
  - **Analyze:**
  - **Graph:**
  - **Tools:**
  - **Tables:**
  - **DOE:**
  - **SAS:**
  - **Application Builder:**
  - **Home:**
  - **New Data Table:**
  - **New Script:**
  - **Data Filter:**
  - **Open File:**
  - **Query Builder:**
  - **Open Database Table:**
  - **Browse SAS Data:**
  - **Browse Data Table:**
  - **Script Editor:**
- **Details for:**
  - **Type:** Command
  - **Source:** JMP Built-In (Customized)
  - **Internal name:** OPEN DATABASE TABLE
  - **Caption:** Open Database Table
  - **Run this JSL:**
  - **Use .jsh file:** com.shells.myaddin
  - **Location:**
  - **Hidden:**
  - **Built-in command:** FE_ADDDATABASE:OPEN_TABLE
  - **Use Add-in file:** com.shells.myaddin
  - **Use image from file:** com.shells.myaddin
  - **Use add-in folder:** com.shells.myaddin
  - **Save As:**
  - **Revert All:**
  - **Clear Selections:**
Customize Toolbars

JMP includes toolbars that you can add new buttons to, or you can create your own toolbars. By default, the JMP window type determines which bars appear. For example, the File_Edit toolbar is in all windows. In data tables, the Data Tables toolbar also appears.

**Project**  
Shows icons for projects.
Chapter 13
Using JMP

Chapter 13
Customize Menus and Toolbars

Using JMP Customize JMP Toolbars and Menus on Windows

File>Edit  Shows icons for commands found in the File and Edit menus.

Analyze  Shows icons for common commands found in the Analyze menu.

Graph  Shows icons for commands found in the Graph menu.

Tools  Shows icons of tools that you can click and use as your cursor. In some windows, the toolbar is hidden. A blue line appears instead. Hover over the blue line to show the toolbar.

Data Table List  Shows a list of open data tables. You select a data table in this list to make it the current table. Note that the current table is not necessarily the front window. To bring a table (or any window) to the front, select its name from the list in the Window menu.

Tables  Shows icons for commands in the Tables menu.

DOE  Shows icons for commands in the DOE menu.

SAS  Shows icons for accessing and browsing SAS data and folders, opening SAS Query Builder, creating a new SAS program, submitting data to SAS, opening the SAS log window and output window, and viewing server connections.

Application Builder  Shows icons for commands in Application Builder.
Customize Menus and Toolbars

Customize JMP Toolbars and Menus on Windows

Home   Shows frequently used icons from the File menu.

Data Table   Shows icons for performing common tasks in a data table, such as opening the Data Filter, Fit Model, and Recode windows.

Script Editor   Shows icons for running, debugging, and reformatting scripts.

Report   Shows icons for opening the Local Data Filter, Column Switcher, and saving a script to the data table.

Create your own toolbars for frequently used commands that are not included in the default toolbars. You assign a command to the button and can add other properties such as shortcut keys, icons, and JMP Scripting Language (JSL) scripts.

When you want to create a toolbar based on an existing toolbar, make a copy of the existing toolbar and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons”.

Step 1: Create the Toolbar

1. Select View > Customize > Menus and Toolbars.
   The Toolbars list appears on the left.
2. (Optional) Change the customization set to control which users see your customizations. See “Customization Set Options”.
3. With the Menu Editor still opened, right-click one of the toolbars, such as File_Edit.
   Select any toolbar, because all new toolbars appear at the end of the Toolbars list.
   The toolbar is inserted at the end of the list. The toolbar includes an untitled button, because all toolbars must have at least one button.
Step 2: Specify the Caption and Internal Name

Toolbars have several basic properties:

- The caption appears in the View > Toolbars list, which lets you show or hide the toolbar. Give each toolbar a unique name. JMP merges toolbars with the same name after you close and reopen the Menu Editor.
- The internal name, which is case insensitive. JMP identifies the location of an item by its internal name rather than its caption.

To specify these toolbar properties, follow these steps:

1. With the Menu Editor still opened, select the toolbar. The General properties appear on the right.
2. Enter the internal name next to Internal name.
3. Enter a unique name for the toolbar or button in the Caption box.
4. (Optional) To specify the translation for the caption, do the following:
   - Click the Localize button for the item that you want to customize.
   - Select the language.
   - Enter the translation next to Text.
   - Click OK.
5. (Optional) Click Hidden to keep the toolbar hidden after creation.
6. Customize the untitled button as described in “Create Menu Items and Toolbar Buttons”.
7. Click Save to save your changes.

Customize the Main Menu Bar

Add your own menu items to the main menu bar in JMP. These menus appear before or after menus such as File, Edit, and Tables. An untitled command is inserted automatically in the menu, because all menus must have at least one command.

When you want to create a main menu based on an existing menu, make a copy of the existing menu and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons”.

To create a main menu

1. Select View > Customize > Menus and Toolbars.
   The Main Menu list appears on the left.
2. (Optional) Change the customization set to control which users see your customizations. See “Customization Set Options”. 
3. Right-click the menu next to which you want to add a new menu.
4. Select **Insert Before** or **Insert After**.

   An untitled menu and a menu item are added to the list.
5. Complete “Step 2: Specify the Caption and Internal Name” to rename the main menu.
6. Customize the menu item as described in “Create Menu Items and Toolbar Buttons”.
7. Click **Save** to save your changes.

### Create Menu Items and Toolbar Buttons

Menus consist of commands, submenus, and separators.

- **Commands** are the items that you click to execute a command (such as Data Table and Script).
- **Submenus** are menu items that you click to reveal more menu options. An example of submenu is New inside the top-level File menu. New is also a submenu because it contains commands (such as Data Table and Script).
- **Separators** are lines that divide or group commands and submenus.

The button on a toolbar is considered a type of command, so you also complete the following steps to create new toolbar buttons.

When you want to create a menu item or button based on an existing item, make a copy of the existing item and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons”.

### Step 1: Create a New Menu Item or Button

1. Select **View > Customize > Menus and Toolbars**.

   The Menu Editor appears.
2. (Optional) Change the customization set to control which users see your customizations. See “Customization Set Options”.
3. Right-click where you want to add the menu item or button.

   A list of possible locations appears.
4. Select **Insert Before** or **Insert After**.

   The Specify Type window appears.
Chapter 13
Customize Menus and Toolbars

Using JMP Customize JMP Toolbars and Menus on Windows

Figure 13.2 Specify Type Window

5. Do one of the following:
   – To create a button, select **Command**.
   – To create a menu within a menu, select **Submenu**. (Not available for buttons.)
   – To create divider between menu items or toolbar buttons, select **Separator**.

6. Click **OK**.
   
   The new untitled button, submenu, or separator is added.

Step 2: Specify the Caption, Tooltip, and Internal Name

Buttons have several basic properties:

- The caption appears in the View > Toolbars list, which lets you show or hide the toolbar. Give each toolbar a unique name. JMP merges toolbars with the same name after you close and reopen the Menu Editor.
- The tooltip appears when you place the cursor over a menu item or button.
- The internal name, which is case insensitive. JMP identifies the location of an item by its internal name rather than its caption.

Submenu items include many of the same General properties as buttons, except that submenu items do not have tooltips.

To specify these properties, follow these steps:

1. With the Menu Editor still opened, select the menu item or button.
   
   The General properties appear on the right.

2. Enter the internal name next to **Internal name**.

3. Enter a unique name for the menu item or button in the Caption box.

4. Enter a description for button in the Tip box.

5. (Optional) To specify the translation for the caption or tip, do the following:
   – Click the **Localize** button for the item that you want to customize.
   – Select the language.
   – Enter the translation next to Text.
   – Click **OK**.

6. Customize the untitled button or menu item as described in the following procedure.
Step 3: Assign Functionality

Clicking a menu item or button either executes a predefined command or runs a JSL script. The script can be stored in a separate file, or you can enter the JSL in the Run this JSL area of the Menu Editor. If users have access to a central location, such as a network, you typically want to run the script from that location. This also simplifies giving users access to updated scripts. Otherwise, store the JSL in the menu item or button definition.

To associate a menu item or button with an add-in JSL script, you have two options:

- Select **Run JSL in this file**, and then browse to find the external file.
- Type the relative path to the JSL script, and select the add-in from the **Use add-in home folder** list. For example, the following command runs the `mds_application.jsl` script from the selected add-in:

  ```javascript
  $ADDIN_HOME(com.jmp.mdswithr)/mds_application.jsl
  ```

In addition, you can select **Use the “Here” namespace for unqualified JSL variable names** if you include namespaces in the internal or external JSL script. See the *Scripting Guide* for more information about namespaces.

To assign this functionality, follow these steps:

1. With the Menu Editor still opened, select the menu item or button that you want to modify.
   
   The Action properties appear on the right.
2. Select the action that you want to execute.
3. To run an internal JSL script, delete the placeholder text `print("Not implemented.");` in the **Run this JSL** area and enter the JSL.
4. (Optional) If your internal or external JSL script includes namespaces, select **Use the “Here” namespace for unqualified JSL variable names**.
5. Click **Save** to save your changes.

Step 4: Show an Icon on the Menu Item or Button (Optional)

New menu items have no icon next to the item. New buttons show up as blue squares on the toolbars. You can assign a descriptive icon to the menu item or button. The graphic can reside on your computer or in an add-in folder. `.ico`, `.png`, `.jpg`, and `.bmp` graphics are supported.

Assigning an icon to a button is particularly important. Otherwise, the user must view the button’s tooltip to see what the button does.

To show an icon on the menu item or button, follow these steps:

1. With the Menu Editor still opened, select the menu item or button.
   
   The Icon properties appear on the right.
2. Select one of the following options:

   None  Select this option to show a blue square instead of an icon.

   Built-in icon  Select this option to show an icon that JMP provides, and then select the
                  icon from the list.

   Use image from file  Select this option to show an image that you created. Click Browse,
                        select the graphic, and then click OK.

   Use add-in home folder  Select this option to display an icon from an add-in to the left of
                           the menu item. After you select the checkbox, select the add-in, click
                           Browse, and then select the icon. The path to the image is displayed in the
                           Use image from file field. The image can be an ICO, PNG, JPG, or BMP graphic.

3. Click Save to save your changes.

Step 5: Assign a Shortcut Key (Optional)

A shortcut key executes an action so that you do not have to select the menu item or click the
button on the toolbar. This option is also helpful when the button’s toolbar is not shown, but
you still want to execute the action.

Shortcuts begin with Ctrl, Ctrl+Shift Ctrl+Alt and end with a number, letter, or symbol that
appears on the keyboard. The Function keys (such as F1) are also supported. Many Ctrl + letter
and Function shortcuts are already assigned in JMP, but you can reassign them to your
buttons if you want.

Shortcut keys appear in menus next to each menu item.

To assign a shortcut key, follow these steps:

1. With the Menu Editor still opened, select the menu item or button.
   The Shortcuts properties appear on the right.

2. Do one of the following:

   – To assign a new shortcut, click in the New shortcut area and press the shortcut keys. If
     the keystrokes then appear in the Currently assign to box, press another combination
     of shortcut keys. (You do not have to delete the keystrokes before pressing the shortcut
     keys.)

   – To change a shortcut that you previously specified, click Remove, click in the New
     shortcut area and press the shortcut keys.

3. Click Assign.

   The shortcut appears in the Current shortcuts list.

4. Click Save to save your changes.

To remove a shortcut, select the shortcut and click Remove.
Set User Permissions for Customized Toolbars and Buttons

Use the JMP Menu Editor to specify which users can see your customized toolbars and buttons. Your changes are saved in a text file with the .jmpcust extension called a customization set. By default, your customizations are shown only to the current user; other users who log on to the computer and open JMP do not see your personal toolbars and menus.

All customization sets include the built-in JMP buttons and menus. You can also base customization sets on other customization sets. For example, you might create a new customization set that shows the JMP add-in menus and toolbars along with your modifications.

When you modify the Current user customization set, JMP creates a backup file of the set. The file is located in your Windows Users folder within the JMP or JMPPro folder.

C:/Users/<user name>/AppData/Roaming/SAS/JMP/17/

When you modify the All users customization set, JMP creates a backup file of the set. The file is located in the Windows All Users folder within the JMP or JMPPro folder.

C:/Users/All Users/SAS/JMP/17/

The All Users folder does not appear when you try to browse for it, so you must type the path into the Windows Explorer address field.

Note: To find the customization set files in Windows Explorer, show all hidden files in the Windows Explorer Folder Options. See your operating system documentation for details.

To change the customization set, follow these steps:

1. Select View > Customize > Menus and Toolbars.

The Menu Editor appears.

2. Click Change.

When you try to change the customization set, and changes to the selected set are not saved, you are prompted to save the changes. Click Save Changes.

3. Select the customization set in the Customization Set to Modify area. (By default, changes apply only to the Current user customization set.) “Customization Set Options” describes the options.

4. (Optional) To change the set on which the selected customization set is based, select the set in the Starting Set area. (Not available for the All users customization set.) “Customization Set Options” describes the options.

5. Click OK.
Rearrange Toolbars

On Windows, there are two ways to rearrange toolbars:

- To rearrange toolbars quickly for the current user, drag the toolbar above, below, to the left, or to the right of the adjacent toolbar.
- To specify the new location rather than drag the toolbar, right-click the toolbar and select a position from the Location menu. This method lets you move toolbars to the top or bottom of the window. You can also position the toolbars vertically on the left or right side of the window.

In some windows, the toolbar is hidden by default. Specifying a new location shows the toolbar in all windows of that type. On Windows, you can change the toolbar preferences to always show toolbars. See “Preferences for File Locations”.

To drag a toolbar

1. Point to the left corner of the toolbar until the Move cursor appears.
2. Drag the toolbar to the new location. When a toolbar is too wide to show completely, click the arrow to show all of the buttons, as shown in Figure 13.3.

Figure 13.3 Expanding a Toolbar

To position the toolbar

1. Right-click the toolbar that you want to move.
2. Select Location, and then select the new position.

**Note:** After you move a toolbar to the left, right, or bottom positions, you can add other toolbars to the same position. For example, you might relocate the File_Edit toolbar to the right side of the JMP window. To add other toolbars on the right side, right-click the bar and select the toolbar that you want to add.

Copy and Paste Menus, Menu Items, Toolbars, and Buttons

Copying existing items is a shortcut to creating new items in a menu or toolbar. This option lets you change only a few settings in the new item when possible.

To copy and paste menus and menu items

1. Select View > Customize > Menus and Toolbars.
The Menu Editor appears.

2. (Optional) Change the customization set to control which users see your customizations. See “Customization Set Options”.

3. Right-click the menu or menu item that you want to copy and select **Copy**.

4. Right-click the menu or menu item before, after, or into which the item will appear and select **Paste**.

One of the following occurs:

- A list of possible locations appears.
- The menu or menu item appears below the selected item. Skip to step 7.

5. Select the location of the menu by doing one of the following:

   - To paste the item **before** the selected menu, select **Paste before**.
   - To paste the menu **after** the selected menu, select **Paste after**.
   - To paste the menu **inside** the selected menu, select **Paste into**. (Available only when you select a menu as the new location.)
   - To cancel the action, select **Cancel**.

   The item appears as you indicated.

6. Modify the item.

7. Click **Save** to save your changes.

See “Customize the Main Menu Bar” and “Create Menu Items and Toolbar Buttons” for more information about modifying the items.

---

**To copy and paste toolbars and buttons**

1. Select **View > Customize > Menus and Toolbars**.

   The Menu Editor appears.

2. (Optional) Change the customization set to control which users see your customizations. See “Customization Set Options”.

3. Right-click the toolbar or button that you want to copy and select **Copy**.

4. Do one of the following:

   - To paste a toolbar, right-click **Toolbar** and select **Paste**. The toolbar appears at the end of the list of toolbars.
   - To paste a button, right-click the button before or after which you want the new button, and select **Paste**. If you selected the first button on the toolbar, select the location of the button. Otherwise, the button is pasted below the selected button.

5. Modify the item.

6. Click **Save** to save your changes.
See “Customize Toolbars” and “Create Menu Items and Toolbar Buttons” for more information about modifying the items.

Rearrange Custom Menus, Menu Items, and Buttons

On Windows, you can rearrange the order of menus, menu items, and buttons that you create. For example, under the File > New menu, you could move your custom menu before the Data Table command.

In the item’s General properties, the Source determines whether you can move the item. You can move items if the Source is Custom Item. Built-in items cannot be moved. Items that are defined in other customization sets can be moved only in that customization set. See “Customization Set Options”.

Note: The right-click menu has options for cutting and pasting items. To cut an item, you can also press Ctrl+X, or press Shift+Delete. To paste, press Ctrl+V, or press Shift+Insert.

To rearrange custom menus and menu items

1. Select View > Customize > Menus and Toolbars.
   The Main Menu list appears on the left.
2. Do the following:
   – Select the item that you want to move.
   – Verify that the Source is Custom Item.
   – If the Source is All Users or JMP Add-In, select the specified customization set and verify that the Source is Custom Item.
3. Right-click the custom menu or menu item that you want to move and select Cut.
4. Right-click the new location of the cut item and select Paste.
   One of the following occurs:
   – A list appears with the possible locations of the cut item. This occurs when you select a menu (such as File or New) or the first item in a menu (such as Data Table in the File > New menu).
   – The cut menu item appears below the selected menu item. Skip to step 6.
5. Select the location of the cut item by doing one of the following:
   – To paste the cut item before the selected item, select Paste before.
   – To paste the cut item after the selected item, select Paste after.
   – To paste the cut item inside the selected menu, select Paste into. (Available only when you select a menu as the new location.)
To rearrange custom buttons

1. Select **View > Customize > Menus and Toolbars**.
   
The Toolbars list appears on the left.

2. Do the following:
   
   – Select the custom button that you want to move.
   
   – Verify that the Source is **Custom Item**.
   
   – If the Source is *All Users* or *JMP Add-In*, select the specified customization set and verify that the Source is **Custom Item**.

3. Right-click the custom button that you want to move and select **Cut**.

4. Right-click the new location of the cut button.

   One of the following occurs:
   
   – A list appears with the possible locations of the cut button. This occurs when you select the first button on the toolbar (such as **New Data Table** in the **File_Edit** toolbar).
   
   – The button is pasted at the end of the toolbar. This occurs when you select the name of the toolbar. For example, when you select **File_Edit** and paste, the button appears after the last button, **Run Script**. Skip to step 6.
   
   – The cut button appears after the selected button. Skip to step 6.

5. Select the location of the cut button by doing one of the following:
   
   – To paste the cut button **before** the selected button, select **Paste before**.
   
   – To paste the cut button **after** the selected button, select **Paste after**.

6. Click **Save** to save your changes.

Delete Custom Items

Rather than temporarily showing or hiding toolbars, buttons, menus, and menu items, you can delete items that you created to remove them permanently from JMP. The Source determines whether you can delete the item and which customization set contains the item. **Figure 13.4** shows examples of customization Source types.
Empty menus are not supported. When you delete the only item in a menu, the entire menu is deleted, not just the selected item.

**Note:** Make sure that you really want to delete custom items. They are removed immediately without confirmation.

To delete a custom item, follow these steps:

1. Select **View > Customize > Menus and Toolbars**.
   The Menu Editor appears.
2. Select the item that you want to delete.
3. Verify whether the item can be deleted, and change the customization set, if necessary.
4. Right-click the selected item and select **Delete**.
   The item is immediately deleted.
5. Click **Save**.
   Your changes are saved.

**Show or Hide Custom Items**

In the Menu Editor, you show or hide toolbars, buttons, menus, and menu items in specific customization sets. The item’s Source determines where you show or hide the item. For example:

- When the Source is *All Users*, change the customization set to **All users** to hide the item from all users.

- When the Source is *JMP Add-In*, change the customization set to **JMP Add-In** followed by the name of the add-in. The item is shown or hidden in all sets that include the selected JMP add-in.

If you do not change the customization set, the item is shown or hidden only in the currently selected set. See “Customization Set Options” for more information about customization sets.
**Note:** To quickly hide or show toolbars for the current user, select or deselect them from the *View > Toolbars* list.

To show and hide items in a customization set, follow these steps:

1. Select *View > Customize > Menus and Toolbars.*
   
   The Menu Editor appears.
2. Select the customization set that you want to modify.
3. Select the item that you want to show or hide.
4. Select or deselect *Hidden* in the General properties. See “Step 2: Specify the Caption and Internal Name” for more information about the General properties.
5. Click **Save** to save your changes.

### Import Customizations

Changes to toolbars and menus are stored in customization sets, or plain text files. You open a customization set in JMP to import your modified toolbars and menus. The customizations are then shown in the Menu Editor. See “Customization Set Options” for more information about the menu customization files.

To import customizations, follow these steps:

1. Select **File > Open.**
2. In the File name list, select **All JMP Files** (or **JMP Menu Files**) and then select the customization set.
3. Click **Open.**
   
   A confirmation is displayed, stating that the customizations have been imported. The Menu Editor is also opened.
4. Display the Menu Editor and click **OK** to save the changes, or click **Cancel** to discard them.

### Remove Customizations from JMP

As you modify items, you discard unsaved changes by clicking the Menu Editor’s **Cancel** button and clicking **Yes** to confirm. After saving customizations, you can also remove all customizations and revert to the original menus and toolbars.

*To remove all of the current user’s customizations*

1. Select **View > Customize > Revert to Factory Defaults.**
2. Click **Yes** to remove the current user’s customizations.
When JMP finds customizations from a previous version of JMP, a confirmation appears. Do one of the following:

– Select **No** to avoid adding those customizations to the current installation of JMP.
– Select **Yes** to add those customizations to the current installation of JMP.

To remove customizations from another customization set

1. Select **View > Customize > Menus and Toolbars.**
   The Menu Editor appears.
2. Click **Change.**
3. Select the customization set, and click **OK.**
4. Click **Revert All.**
   A confirmation window appears.
5. Click **Yes** to remove your customizations.

To remove customizations from the selected item

1. Select **View > Customize > Menus and Toolbars.**
   The Menu Editor appears.
2. (Optional) Select the customization set that contains the item.
3. Select the item that you want to modify.
4. Do one of the following:
   – To restore the *previous* properties of an *unsaved* item, click **Reset.**
   – To restore the *original* properties of a *built-in* item, click **Revert All,** and then click **Yes** to confirm.
5. Click **Save** to save your changes.

**Customize Toolbars on macOS**

On macOS, you can set up toolbars to display only the icons that you need. Icons are available based on the type of window. For example, in a script window, icons for options such as reformatting, encrypting, and running the script are available. Table icons are available only for data table toolbars.

You can specify whether the icon, icon and icon name, or just the name appear on the toolbar. Displaying small icons is also an option.
To add, remove, or rearrange toolbar icons

1. Open the type of window whose toolbar you want to customize.
2. Select View > Customize Toolbar.
   A window appears that shows icons relevant to the current type of window.
3. Do any of the following:
   – To add an icon to the toolbar, drag the icon from the window onto the toolbar.
   – To move an icon on the toolbar, drag the icon to its new location onto the toolbar.
   – To remove an icon from the toolbar, drag the icon from the toolbar onto the window.
   Your changes are applied to the current window and all open windows of the same type.

![Figure 13.5 Add, Rearrange, and Remove Toolbar Buttons on macOS](image)

4. Click Done.
   When a toolbar is too wide to display completely, click the right arrows on the toolbar to show and then select other icons. Alternatively, you can click and drag the window until the entire toolbar appears.

Note: To display the original set of toolbar icons, drag the default set from the bottom of the toolbar customization window to the toolbar.

To change the appearance of toolbar icons

1. Open the type of window whose toolbar you want to customize.
2. Select View > Customize Toolbar.
   A window containing toolbar icons appears.
3. At the bottom of the window, select one of the following options from the Show list:
   – To display only an icon, select Icon Only.
   – To display an icon and its name, select Icon and Text.
Chapter 13
Using JMP

Customize Menus and Toolbars
691

Customize Menus on macOS

Customize JMP menus to quickly access files or modify existing menu items. Selecting a menu item runs a JSL script from your computer or executes the JSL commands that you specify. For example, you can create a menu item to open a frequently used script. This option is an alternative to adding the script as a favorite on the Home Window.

Features include adding and renaming menu items, hiding menu items, inserting menu item separators, and associating a menu item with JSL.

JMP customizations are stored in `<username>/Library/Application Support/JMP/17/usercust.jmpcust`.

**Note:** You cannot delete default JMP menus or delete submenus (which open to reveal other menu items). Default and custom submenus also cannot be renamed.

Example of Adding a Menu Item

In this example, create a menu item that runs a script.

1. Select **View > Customize Menus**.
2. In the JMP Menu Editor, select **File** and then **Open**.
3. Press Control and then select **Add New Menu Item after**.
4. Type **What is the Current Time?** in the Menu Label box.
5. Select **Run JSL in this file:** and select `Library/Application Support/JMP/17/Samples/Scripts/timeAnnouncer.jsl`.
6. Click **Add** and close the Menu Editor window.
7. Select **File > What is the Current Time?**.
   The Scheduler window appears, and the current time is spoken.

Example of Adding a Submenu Item

A submenu opens to reveal submenu items. In this example, create a submenu item that opens a data table.

1. Select **View > Customize Menus**.

– To display only the icon name, select **Text Only**.
4. To display small or standard icons, select or deselect **Use small size**.

Your changes are applied to the current window and all open windows of the same type.

5. Click **Done**.
2. In the JMP Menu Editor, select **File** and then **Open**.
3. Press Control and select **Add New Submenu after**.
4. Type Open My Data Tables and select **JSL Commands**.
   
   **Note:** Selecting **JSL Script** lets you select a JSL script from your computer.

5. Click **Add**.
6. Select **Open My Data Tables**, delete **Subitem placeholder** in the Menu Label box, and then type Open Napoleons March.jmp.
7. In the Run this JSL box, type `Open("$SAMPLE_DATA/Napoleons March.jmp")`.
8. Click **Save Changes**.
9. Select the **File** menu to see the new menu item.

**Tip:** If the new menu item appears in the menu but not the menu editor, close the menu editor window and reopen it.

**To delete a custom menu or submenu item**
- Delete one custom menu item by selecting the item and selecting **Delete Selection** from the options list.
- Delete all custom menu items by selecting **Revert All** from the options list.
- To delete items within a submenu, you must delete the entire submenu. Empty menus are not permitted. Select the submenu and select **Delete Selection** from the options list.

---

### Customize Menus and Toolbars for Add-Ins

To add new features to JMP, you can write the scripts and compile files to create an add-in. One way to compile the scripts is to use Add-In Builder as described in the *Scripting Guide*.

Add-In Builder provides a menu editor that enables you to create menu items in the Add-Ins menu. You can also use the JMP Menu Editor to create menu items and add toolbar buttons for an add-in.
JMP preferences enable you to specify general and specific settings and save the settings.

To change preferences
1. Select File > Preferences (Windows) or JMP > Preferences (macOS). The window in Figure 14.1 appears. The previous preferences page that you selected appears.
2. Click a category and make selections. Click Apply to see the results, and then click OK.

Notes:
- When you upgrade a subscription product, changes to preferences are maintained. In other JMP versions, you must customize the preferences after each upgrade.
- Your JMP preferences are remembered if you switch the JMP display language.

To search preferences
1. Select File > Preferences (Windows) or JMP > Preferences (macOS).
2. In the Filter box at the top, enter your text.
3. (Optional) To filter preferences by the version of JMP they were added in, click Version and choose minimum and maximum versions.
4. At left, click a category to see its results.

Matches are highlighted in blue. If you filter by version, the version number appears in a circle.

A search term can show up in these places:
- the preference itself
- a tooltip for the preference
- a list of options for a preference

To reset preferences to the default settings
1. Select File > Preferences (Windows) or JMP > Preferences (macOS).
2. Click Reset All, and then click OK.
## Contents

- Overview of JMP Preferences ................................................................. 695
- General JMP Preferences ...................................................................... 695
- Preferences for JMP Reports ................................................................. 699
- Preferences for JMP Graphs ................................................................... 702
- Style Preferences for JMP Graphs and Reports ...................................... 706
- Fonts Preferences .................................................................................. 708
- Menu Preferences .................................................................................... 711
- Preferences for JMP Projects ............................................................... 712
- Preferences for Data Tables ................................................................. 713
- Preferences for JMP Data Filters ........................................................... 718
- Preferences for the Column Switcher ...................................................... 720
- Preferences for Recoding Columns ......................................................... 720
- Value Order Preferences ........................................................................ 722
- Preferences by JMP Platform ............................................................... 723
- Preferences for Importing and Exporting Text Files .............................. 724
- Preferences for Third-Party Data ............................................................ 729
- Preferences for SAS Integration ............................................................. 731
- Preferences for the Query Builder .......................................................... 735
- Preferences for the JSL Script Editor ...................................................... 737
- Preferences for the Workflow Builder ..................................................... 740
- Preferences for the JSL Debugger .......................................................... 741
- Preferences for the Log ........................................................................... 743
- Windows Preferences ............................................................................. 744
- Mac OS Preferences ............................................................................... 748
- Communications Preferences ............................................................... 750
- Preferences for Internet Options ............................................................ 751
- Print Preferences ..................................................................................... 753
- Preferences for File Locations ............................................................... 753
- Preferences for Updating JMP ............................................................... 754
Overview of JMP Preferences

The Preferences command on the File menu (on the JMP menu on macOS) displays the Preferences window. See Figure 14.1. Each category is described in this chapter.

On Windows, changes that you make to preferences are stored in a version-specific JMP.PFS file located in one of the following folders:

C:/Users/<user name>/AppData/Roaming/SAS/JMP/17/
C:/Users/<user name>/AppData/Roaming/SAS/JMPPro/17/

On macOS, the preferences are stored in com.sas.jmp.plist, which is located in ~/Library/Preferences/.

JMP looks for this file when you open the program and considers your changes to be the factory defaults. And all subsequent changes are stored in this file.

General JMP Preferences

Most General preferences customize your JMP session at start-up. Others set preferences for file handling and the general appearance of the JMP workspace.

Figure 14.1 General Preferences

- Show the Tip of the Day at startup
- Initial Splash Window
- Initial Log Window
- Reopen the initial JMP window on last window close
- Show menu tips
- Report JSL warnings and errors interactively
- Show log warnings for JSL compatibility changes in JMP 12

Allow Unquoted Strings in JSL

- Save Journals GZ Compressed
- Save Data Table Columns GZ Compressed
- Parallel Data Table Column Decompression
- Allow 16 Bit List Check Decompression
- Save Scripts in English
- JSL save column groups with group name
- Display indexes in English
- Report Invalid Display Box Messages
- Add files opened by scripts to the Recent Files list
- Enable Advanced Linear Algebra Routines

Autosave timeout: 0
Autosave maximum data table rows: 10000
Autosave maximum data table columns: 1000
Save the session when exiting: Prompt
### Table 14.1 Preferences on the General Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show Tip of the Day at startup</strong></td>
<td>Select this option to show the Tip of the Day window at start-up. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Initial Splash Window</strong></td>
<td>Select this option to show the initial splash window at start-up. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Initial Log Window</strong></td>
<td>(Windows only) Select this option to open the log when JMP opens.</td>
</tr>
<tr>
<td><strong>Initial JMP Starter Window</strong></td>
<td>(macOS only) Select this option to show the JMP Starter window every time you start JMP. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Initial JMP Window</strong></td>
<td>(Windows only) Select one of the listed windows as the default window. When JMP starts, this window appears. The Home Window is the default window.</td>
</tr>
<tr>
<td><strong>Home Window</strong></td>
<td>(macOS only) Select this option to show the JMP Home window when you start JMP on macOS. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Reopen the initial JMP window on last window close</strong></td>
<td>(Windows only) Select this option to open whichever window you have set as the Initial JMP Window when you close the last JMP window. If this option is turned off, closing the last JMP window also quits JMP. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Show menu tips</strong></td>
<td>(Windows only) Select this option to see tooltips on main menu options and options in red triangle menus. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Report JSL warnings and errors interactively</strong></td>
<td>Shows script errors in a new window rather than only in the log. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Show log warnings for JSL compatibility changes in JMP 12</strong></td>
<td>Select this option to print warnings about JSL compatibility to the log. This option is selected by default.</td>
</tr>
</tbody>
</table>
Table 14.1 Preferences on the General Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Allow Unquoted Strings in JSL</strong></td>
<td>Select this option to print a warning to the log when a string value in a platform message is unquoted. Quoted string values are preferred over literal names.</td>
</tr>
<tr>
<td><strong>Yes (no warning)</strong></td>
<td>Allows unquoted string values and does not print a warning to the log. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Yes (warning)</strong></td>
<td>Allows unquoted string values and prints a warning to the log.</td>
</tr>
<tr>
<td><strong>No</strong></td>
<td>Ignores the unquoted string value and does not print a warning to the log.</td>
</tr>
<tr>
<td><strong>Save Journals GZ Compressed</strong></td>
<td>Select this option to save JMP journals in a compressed format to save disk space. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Save Data Table Columns GZ Compressed</strong></td>
<td>Select this option to allow JMP to save data tables using GZ compression. For backward compatibility, JMP 10 can read the compressed files but not save them. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Parallel Data Table Column Decompression</strong></td>
<td>Select this option to change the setting for decompressing columns in parallel. Deselecting this option might allow very large tables to load. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Allow 16 Bit List Check Compression</strong></td>
<td>Compresses a column that has less than or equal to 65,535 unique values. Adds the List Check property to the column. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Save Scripts in English</strong></td>
<td>Non-English versions of JMP can save scripts in either English or your local language. User-specified values (such as column names and text strings) in these scripts appear as they do in the data table. However, command words (such as Distribution and SetValue) appear in English rather than the local language in order for the script to run on JMP in English. JMP properly displays non-Roman characters (such as Japanese variable names) in JMP in English when the fonts support the necessary characters. The option is selected by default. Deselect this option to save scripts in your local language. Note that these scripts run correctly only if JMP is running in the same language.</td>
</tr>
</tbody>
</table>
Table 14.1 Preferences on the General Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>JSL save column groups with group name</td>
<td>Select this option to specify the column group name in a JSL script that you save from a platform. By default, the script contains the column names, not the column group name.</td>
</tr>
<tr>
<td>Display indexes in English</td>
<td>Shows sections of the JMP Indexes in English or the current locale’s language. The option is selected by default. When you deselect it, the following items are displayed in the current locale’s language:</td>
</tr>
<tr>
<td></td>
<td>• The message list for objects</td>
</tr>
<tr>
<td></td>
<td>• The message list for display boxes.</td>
</tr>
<tr>
<td></td>
<td>• The category list for JSL functions.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> The description of each index item is always displayed in the current locale’s language. Examples are always in English.</td>
</tr>
<tr>
<td>Report Invalid Display Box Messages</td>
<td>Sends information about invalid display box messages to the log. This option is selected by default.</td>
</tr>
<tr>
<td></td>
<td>This option can be useful during script development, but can cause unwanted log messages for existing scripts.</td>
</tr>
<tr>
<td>Add files opened by scripts to the Recent Files list</td>
<td><em>(Windows only)</em> Select this option to include files opened by the JSL Open() command in the Home Window Recent Files pane and the File &gt; Recent Files list. This option is selected by default.</td>
</tr>
<tr>
<td>Enable Advanced Linear Algebra Routines</td>
<td>Select this option to enable the use of BLAS (Basic Linear Algebra Subprograms) and LAPACK (Linear Algebra Package) routines for linear algebra calculations in various JMP platforms and JSL functions. If this preference is not enabled, linear algebra calculations are slower but more reproducible from machine to machine. The BLAS and LAPACK routines are implemented using OpenBlas on Windows and Accelerate on macOS.</td>
</tr>
<tr>
<td>Autosave timeout</td>
<td>Automatically saves the contents of opened data tables, journals, reports, projects, and scripts except for untitled files at the specified interval. The default setting is 0 minutes, which indicates no autosave.</td>
</tr>
<tr>
<td>Autosave maximum data table rows</td>
<td>Autosaves data tables if the number of rows does not exceed the specified value. 10,000 is the default setting.</td>
</tr>
</tbody>
</table>
Table 14.1 Preferences on the General Page \(\text{(Continued)}\)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autosave maximum data table columns</td>
<td>Autosaves data tables if the number of columns does not exceed the specified value. 1,000 is the default setting.</td>
</tr>
<tr>
<td>Save the session when exiting</td>
<td>This option enables you to save the state of the JMP window when exiting JMP. When opening JMP, the saved state is restored, including any open files and windows. The default setting is Prompt.</td>
</tr>
</tbody>
</table>

**Preferences for JMP Reports**

Report preferences customize the appearance of reports.

Figure 14.2  Reports Preferences

Table 14.2 Preferences on the Reports Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date Title on Output</td>
<td>Select this option to display the date and time the analysis occurred in your report windows. This option is deselected by default.</td>
</tr>
<tr>
<td>Data Table Title on Output</td>
<td>Select this option to display the name of the data table and notes, if there are any, at the top of the report. This option is deselected by default.</td>
</tr>
</tbody>
</table>
Table 14.2 Preferences on the Reports Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hover Help</td>
<td>On some numeric output, JMP provides tooltip-style help when you circle the mouse over a result. Select this option to see a tooltip where it is available. This option is selected by default. <strong>Note:</strong> If you deselect this option, hover label graphs no longer appear.</td>
</tr>
</tbody>
</table>
| Save table with report | Select one of the options from the menu to determine how a table is saved to a report:  

- **Embed** When you save a report, the table is embedded into the report. Choose this option if you want to share the report with others. The data table that is stored in the report is reopened (unchanged) each time the report is opened. If you make changes to the table, they are not saved into the report unless you re-save the report.  

- **Separate** When you save a report, the table is referenced in the report.  

- **Prompt** When you save a report, you are prompted to specify how to save the report: either to embed the table within the report, or to add a reference to the table in the report. This is the default setting. |
| Laser pointer    | JMP has a built-in laser pointer that enables you to visually emphasize parts of a report. The option is deselected by default. To turn it on, select a color for the laser pointer from the list. |
Using JMP Preferences for JMP Reports

Table 14.2 Preferences on the Reports Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show conditional formatting</strong></td>
<td>Conditionally formats the color of the text that represents the values. Available for correlation values, ( p )-values, and factor pattern values. Select one of the options from the menu:</td>
</tr>
</tbody>
</table>

  - **Always**  Conditional formatting is always applied to correlation values, \( p \)-values, and factor pattern values. This is the default setting.

  - **Screen Only**  Conditional formatting is always applied to correlation values, \( p \)-values, and factor pattern values. However, the conditional formatting does not show when the report is printed.

  - **Never**  Conditional formatting is never applied to correlation values, \( p \)-values, and factor pattern values.

  Click **Manage Rules** to change the default setting for showing conditional formatting in reports.

<table>
<thead>
<tr>
<th><strong>Manage Rules</strong></th>
<th>Creates custom conditional formatting rules that can be applied to numeric columns or matrices. See “Use Conditional Formatting in JMP Reports”.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use an Asterisk with the PValue Format</strong></td>
<td>Select this option to display an asterisk (*) next to significant ( p )-values. This option is selected by default.</td>
</tr>
</tbody>
</table>

  **Note:** Verify the **Use an Asterisk with the PValue Format** preference to ensure that the asterisk (*) is or is not used for any \( p \)-value conditions.

| **Show semantic formatting**   | Sets the default for using semantic formatting in reports. Select one of the options from the menu:                                                                                                         |

  - **Always**  Enables semantic formatting in reports.

  - **No Row Matching**  Disables row-specific semantic formatting.

  - **Never**  Disables semantic formatting in reports.

  Click **Manage Formats** to add or edit semantic formats.
Table 14.2 Preferences on the Reports Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>JMP Live Timeout</strong></td>
<td>Specifies the timeout value for publishing to JMP Live. The default time is 180 seconds.</td>
</tr>
<tr>
<td><strong>Transparent background for report PNG images</strong></td>
<td>Select this option to display a transparent background when a report is saved as a PNG file. This option is deselected by default.</td>
</tr>
</tbody>
</table>

Preferences for JMP Graphs

Graph preferences customize the appearance of graphs. See “Preferences for Data Tables” for more information about configuring the appearance of graphs.

Figure 14.3 Graphs Preferences
### Table 14.3 Preferences on the Graphs Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graph Border</strong></td>
<td>Draws a border line around the area of the graph. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Y-Axis Title Above Graph</strong></td>
<td>Shows the Title for the Y-Axis above the line rather than beside the line. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Hide Overlapping Labels</strong></td>
<td>Select this option to hide overlapping chart labels. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Graph Height</strong></td>
<td>Sets the default height (in pixels) for a graph. The default setting is 240 pixels. Some platforms take the value and multiply it by a certain amount.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> With Graph Builder windows, specifying the Graph Height enlarges the window proportionally, but the exact value is not applied.</td>
</tr>
<tr>
<td><strong>Line Width</strong></td>
<td>Sets the default width (in pixels) for lines that pertain to content. The default setting is two pixels.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This preference does not apply to grid lines.</td>
</tr>
<tr>
<td><strong>Box Plot Line Width</strong></td>
<td>Sets the default line width for box plots across platforms.</td>
</tr>
<tr>
<td><strong>Graph Marker Size</strong></td>
<td>Select a default size for the markers in graphs: Dot, Small, Medium, Large, XL, XXL, or XXXL. This preference is applied when the marker size is set to Preferred on a graph. The default setting is Large.</td>
</tr>
<tr>
<td></td>
<td>When the number of markers in a graph exceeds the Fast Marker Threshold, the graph’s Marker Drawing Mode is set to Fast. which draws dot-sized markers.</td>
</tr>
<tr>
<td><strong>Graph Marker</strong></td>
<td>Select a default marker shape for the markers in graphs. The default setting is a small dot.</td>
</tr>
<tr>
<td><strong>Graph Marker Theme</strong></td>
<td>Select a default theme for the markers in graphs when you mark by row or column. The default setting is Standard.</td>
</tr>
<tr>
<td><strong>Marker Selection Mode</strong></td>
<td>Select the default formatting for selected markers. The default setting is Unselected Faded. See “Change the Selection Mode of Markers”.</td>
</tr>
</tbody>
</table>
Table 14.3 Preferences on the Graphs Page *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Marker Selection Color</strong></td>
<td>When the Marker Selection Mode is Selected Same Color, this setting applies the specified color to selected markers. The default color is Red.</td>
</tr>
<tr>
<td><strong>Marker Selection Fade</strong></td>
<td>When the Marker Selection Mode is Unselected Faded, this setting fades the unselected markers by the specified amount (in percent). The default setting is 65%.</td>
</tr>
<tr>
<td><strong>Marker Label Color Style</strong></td>
<td>Select the color of the marker label that appears on a graph when you label a column in the data table.</td>
</tr>
<tr>
<td><strong>Marker Color</strong></td>
<td>The marker label is the same color as the marker. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Marker Color Faded</strong></td>
<td>The marker label is faded according to the Marker Selection Fade preference.</td>
</tr>
<tr>
<td><strong>Fixed Color</strong></td>
<td>The marker label color is as specified. The Marker Label Fixed Color preference determines the color.</td>
</tr>
<tr>
<td><strong>Marker Label Fixed Color</strong></td>
<td>Select the color of fixed-color marker labels, an option that you select in the Marker Label Color Style preference. The default color is gray.</td>
</tr>
<tr>
<td><strong>Fast Marker Threshold</strong></td>
<td>When JMP refreshes a report window, it can draw markers or points on a plot at two different speeds: normal and fast. If JMP is in normal drawing mode, and the number of markers on a graph are more than the specified threshold number, JMP automatically switches to fast mode. Enter the number of markers that separate normal and fast mode. When the number of markers in a graph exceeds the Fast Marker Threshold, the graph's Marker Drawing Mode is set to Fast, which draws dot-sized markers. The default setting is 50,000.</td>
</tr>
<tr>
<td><strong>Fill Hollow Markers</strong></td>
<td>Select this option to apply an opaque background to markers. This option is deselected by default.</td>
</tr>
</tbody>
</table>
Table 14.3 Preferences on the Graphs Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fill Selection Mode</td>
<td>Select the default highlight for selected rows in graphic objects:</td>
</tr>
<tr>
<td></td>
<td><strong>Selected Patterned</strong> A striped pattern (default)</td>
</tr>
<tr>
<td></td>
<td><strong>Selected Darkened</strong> A solid darker color</td>
</tr>
<tr>
<td></td>
<td><strong>Selected Outlined</strong> An outline</td>
</tr>
<tr>
<td></td>
<td><strong>Selected Same Color</strong> The Fill Selection Color in the preferences formats the selected object.</td>
</tr>
<tr>
<td></td>
<td><strong>Unselected Faded</strong> Unselected rows are faded, and selected rows are the original color.</td>
</tr>
<tr>
<td>Fill Selection Color</td>
<td>Select the default color of selected rows in graphic objects when the Fill Selection Mode is “Selected Same Color”. The default color is red.</td>
</tr>
<tr>
<td>Fill Selection Fade</td>
<td>This setting fades the unselected markers by the specified amount (in percent). The default setting is 65%.</td>
</tr>
<tr>
<td>Partial Selection Indicator</td>
<td>Select the indicator for a partial selection. The available options are None, Bar, Pie, or Waffle. The default setting is None.</td>
</tr>
<tr>
<td>Continuous Color Theme</td>
<td>Select a default color theme for continuous data. The default theme is Blue to Gray to Red. See “Create Color Themes in Graphs”.</td>
</tr>
<tr>
<td>Sequential Color Theme</td>
<td>Select the default color theme for sequential data that do not have a meaningful midpoint. The default theme is White to Black.</td>
</tr>
<tr>
<td>Bad to Good Color Theme</td>
<td>Select the default color theme for diverging data that ranges from positive to negative data. The default theme is Stoplight Bad to Good.</td>
</tr>
<tr>
<td>Categorical Color Theme</td>
<td>Select a default color theme for categorical data. The default theme is JMP Default. See “Create Color Themes in Graphs”.</td>
</tr>
</tbody>
</table>
Style Preferences for JMP Graphs and Reports

The Styles page enables you to customize colors, tick marks, grid lines, and report tables. See “Preferences for Data Tables” for more information about configuring the appearance of graphs.

Figure 14.4 Styles Preferences
### Table 14.4 Preferences on the Styles Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color Presets</strong></td>
<td>The Color Presets provides a set of predefined colors for use in customizing the appearance of reports, graphs, charts, and so on. Tints of the selected color are applied to the various elements. Note: The selected color is applied also to windows.</td>
</tr>
<tr>
<td><strong>Frame Color</strong></td>
<td>Defines the color applied to a graph frame and tick marks. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Major Grid Line Color</strong></td>
<td>Defines the major grid line color. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Minor Grid Line Color</strong></td>
<td>Defines the minor grid line color. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Graph Background Color</strong></td>
<td>Click the color box to select a background color for all graphs. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Window Background Color</strong></td>
<td>Click the color box to select a background color for all reports and data tables. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Shape Boundary Color</strong></td>
<td>Click the color box to select the color for shape files boundaries.</td>
</tr>
<tr>
<td><strong>Histogram Fill Color</strong></td>
<td>Defines the color to fill the histogram. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Histogram Line Color</strong></td>
<td>Defines the histogram line color. Click to change the default color.</td>
</tr>
<tr>
<td><strong>Original</strong></td>
<td>Click to restore default color settings.</td>
</tr>
<tr>
<td><strong>Frame Border</strong></td>
<td>Shows borders only on the axes. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Tick Marks Inside Graph Frame</strong></td>
<td>Shows axis tick marks inside the graph frame. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Major Grid Lines</strong></td>
<td>Shows major grid lines on graphs. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Minor Grid Lines</strong></td>
<td>Shows minor grid lines on graphs. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Underline Table Headings</strong></td>
<td>Shows border under table headings. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Shade Table Headings</strong></td>
<td>Shows table headings with shading. This option is selected by default.</td>
</tr>
</tbody>
</table>
### Table 14.4 Preferences on the Styles Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Table Heading Column Borders</strong></td>
<td>Shows divider lines between columns in table headings. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Table Column Borders</strong></td>
<td>Shows borders between table columns. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Table Row Borders</strong></td>
<td>Shows borders between table rows. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Shade Alternate Table Rows</strong></td>
<td>Shows alternate table rows with shading. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Shade Table Cells</strong></td>
<td>Shows table cells with shading. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Interactive HTML Themes</strong></td>
<td>Specifies the color theme for interactive HTML pages. The default theme is Light Theme.</td>
</tr>
</tbody>
</table>

### Fonts Preferences

Font preferences customize the appearance of reports, data tables, and scripts, including fonts, text size, and font style.
### Figure 14.5 Fonts Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Sets the font for the text portion of a JMP analysis report. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td>Heading</td>
<td>Sets the font for the heading of columns in an analysis report and a data table. The default setting is Segoe UI, 9 Point Bold.</td>
</tr>
<tr>
<td>Title</td>
<td>Sets the font for the title shown in all title bars. The default setting is Segoe UI, 11 Point, Bold.</td>
</tr>
<tr>
<td>Small</td>
<td>Sets the font for small text, which is used in the upper left corner of the data grid to show the number of columns and rows. The default setting is Segoe UI, 7 Point.</td>
</tr>
</tbody>
</table>
**Table 14.5 Preferences on the Fonts Page  (Continued)**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mono</strong></td>
<td>Sets the font used in the JMP Scripting Language (JSL) editor and editor boxes for script commands. The default setting is Consolas, 10 Point.</td>
</tr>
<tr>
<td><strong>Formula Editor</strong></td>
<td>Sets the font for the expressions entered into the Formula Editor. The default setting is Segoe UI, 11 Point.</td>
</tr>
<tr>
<td><strong>Annotation</strong></td>
<td>Sets the default font used in annotations. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td><strong>Axis</strong></td>
<td>Sets the font used for the axis tick labels. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td><strong>Marker</strong></td>
<td>Sets the font used for alphanumeric markers. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td><strong>Axis Title</strong></td>
<td>Sets the font for axis titles. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td><strong>Graphic Label</strong></td>
<td>Sets the font for data labels in graphs such as marker labels or bar labels. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td><strong>Legend</strong></td>
<td>Sets the font for legend titles, values, and other legend text. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td><strong>Graph Title</strong></td>
<td>Sets the font for the main graph title but not the secondary title or footnote. The default setting is Segoe UI, 11 Point, Bold.</td>
</tr>
<tr>
<td><strong>Caption</strong></td>
<td>Sets the font for the caption element and also any caption-like text (for example, line of fit statistics and the box plot 5-number summary). The default setting is Segoe UI, 8 Point.</td>
</tr>
<tr>
<td><strong>Data Table</strong></td>
<td>Sets the font for displaying data in the data table. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td><strong>Hover Label</strong></td>
<td>Sets the font for hovering over a label. The default setting is Segoe UI, 9 Point.</td>
</tr>
<tr>
<td><strong>Font Family</strong></td>
<td>Select a proportional font. The font that you select is immediately applied to all settings except for Mono, which is used for scripts.</td>
</tr>
<tr>
<td><strong>Use Greek letters</strong></td>
<td>Select this option to use Greek letters instead of spelling out Greek letters (for example, (\pi) instead of pi.) This option is selected by default.</td>
</tr>
</tbody>
</table>
**Chapter 14**  
**JMP Preferences**

### Menu Preferences

The Menu preferences show and hide menus based on how you use JMP. This gives you fewer menu items to browse through and streamlines the JMP interface. For example, if you never design experiments, deselect **Design of Experiments**. Other menus are grouped by area of interest, such as quality engineering, advanced modeling, reliability and survival, and SAS options.

**Figure 14.6** Menu Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use math symbols</strong></td>
<td>Select this option to use math symbols instead of simple text representations of math symbols (for example, ± instead of +/-) This option is selected by default.</td>
</tr>
</tbody>
</table>

**Table 14.5 Preferences on the Fonts Page (Continued)**
Preferences for JMP Projects

Projects preferences enable you to control how new empty projects are created, which tool windows appear, and more.

**Figure 14.7  Projects Preferences**

![Projects Preferences](image)

**Table 14.6  Preferences on the Projects Page**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create an empty project when starting JMP</td>
<td>Creates an empty project when you start JMP: Never, Always, or If no other project is open. Never is the default setting.</td>
</tr>
<tr>
<td>When no project window is active, open files in</td>
<td>Specifies how a new project is automatically created.</td>
</tr>
<tr>
<td></td>
<td><strong>No Project</strong>  Doesn’t put the files in a project. This is the default setting.</td>
</tr>
<tr>
<td></td>
<td><strong>Open Project or No Project</strong>  Puts the files in an open project if found or no project.</td>
</tr>
<tr>
<td></td>
<td><strong>Open Project or New Project</strong>  Puts the files in an open project if found or a new project.</td>
</tr>
<tr>
<td></td>
<td><strong>New Project</strong>  Puts the files in a new project.</td>
</tr>
</tbody>
</table>
Table 14.6 Preferences on the Projects Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial Tool Panes</td>
<td>Specifies which tool panes initially appear in a project. The Workspace, Contents, and Recent Files tools appear by default.</td>
</tr>
<tr>
<td>New Project Template</td>
<td>Specifies the project that you want to use as a template for new projects. The new project has the same window layout, linked documents, graphs, tool windows, and other project elements as the template.</td>
</tr>
<tr>
<td>Use Project Log Pane</td>
<td>Specifies when you want to view the project log rather than use the JMP log. Always is the default setting.</td>
</tr>
</tbody>
</table>

Preferences for Data Tables

Table preferences customize JMP data tables, including formula handling, appearance, and compatibility with SAS data sets.
Figure 14.8 Tables Preferences

- Evaluate OnOpen Scripts: Prompt
  - Prompt to save when closing summary tables
  - Allow short numeric data format
  - Print Data Grid as is
  - Preserve SAS variable names when exporting to SAS
  - Preserve SAS formats when exporting to SAS
  - Show Alternate Column Name
  - Use Thousands Separator
  - Show Search Box on Columns Panel
  - Row Editor Always Show All Columns

- Default Field Width: 12
  - Use Numerical Ordering
  - Numeric keypad Enter key moves down
  - Suppress Formula Eval on Open (Not recommended)

- Formula Evaluation: When Idle
  - Hide ODBC Connection Strings
  - Prefer DSN-less ODBC Connection Strings
  - ODBC Allow Table Replace
  - Warn when referenced table name has changed
  - Virtual Join Auto Open Linked Table
  - Virtual Join Use Linked Column Name

- Header Summary Graphs
  - Show summary graphs below column names
  - Show missing data bars or bins in summary graphs

- Summary Graph Colors
  - Continuous
  - Continuous Missing
  - Nominal
  - Ordinal
  - Other

- Fill and Highlight Colors

- Reset All
### Table 14.7 Preferences on the Tables Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluate OnOpen Scripts</td>
<td>If you save a script to a data table and name it <code>OnOpen</code> or <code>On Open</code>, JMP can automatically run the script whenever you open the data table. <code>On Open</code> scripts that execute other programs are never run.</td>
</tr>
<tr>
<td></td>
<td>Prompt is selected by default. Your choice is remembered each time you open the data table in the current JMP session.</td>
</tr>
<tr>
<td></td>
<td><strong>Always</strong> Allows <code>On Open</code> scripts to run without prompting.</td>
</tr>
<tr>
<td></td>
<td><strong>Never</strong> Prevents <code>On Open</code> scripts from automatically running when a data table is opened.</td>
</tr>
<tr>
<td>Prompt to save when closing summary tables</td>
<td>Prompts you to save an unsaved linked summary table when you close it. Note that, when you select this option in the Summary window, it is selected in the Tables preferences. If you do not want to be prompted to save all linked summary tables in the future, deselect the preference. This option is deselected by default.</td>
</tr>
<tr>
<td>Allow short numeric data format</td>
<td>JMP has the ability to store numeric data in as few as 8 bits (one byte). This option makes short-integer formats available to you when you select Cols &gt; Column Info and assign a column a data type. When you use the correct short-integer format for your data, the numbers are not displayed differently, but the data table uses less disk space. See “The Short-Integer Format”.</td>
</tr>
<tr>
<td>Print Data Grid as is</td>
<td>Select this option to print the JMP data table as it appears on the screen. Clear this option to resize column widths to accommodate the content width. This option is deselected by default.</td>
</tr>
<tr>
<td>Preserve SAS variable names when exporting to SAS</td>
<td>Select this option to use variable names that are compliant with SAS when you export a JMP data table to a SAS data set. This option is deselected by default.</td>
</tr>
<tr>
<td>Preserve SAS formats when exporting to SAS</td>
<td>Select this option to use formats that are compliant with SAS when you export a JMP data table to a SAS data set. This option is selected by default.</td>
</tr>
</tbody>
</table>
### Show Alternate Column Name
Select this option to show the name-label pair of the column. A column has name-label pair if the two column properties are defined and the Column Name equals one of the two properties.

JMP recognizes the following name-label pairs:
- SAS name-label pair, where the properties are “SAS Name” and “SAS Label”
- SPSS name-label pair, where the properties are “SPSS Name” and “SPSS Label”
- Short-long name-label pair, where the properties are “Short Name” and “Long Name”

If the option is selected, then both the name and label appear in the dialog.

### Use Thousands Separator
Select this option to display numbers using the locale-appropriate thousands separator. This option is deselected by default.

### Show Search Box on Columns Panel
Shows a search box on the Columns panel above the column names. This option is selected by default.

### Row Editor Always Show All Columns
Select this option to enable the Row Editor to display all columns. This option is selected by default.

### Default Field Width
Changes the number of digits that appear in numeric columns. The default setting is 12.

### Use Numerical Ordering
Specifies that text containing numbers be sorted in numerical order. This option is selected by default.

### Numeric keypad Enter key moves down
(Windows only) When a data table cell is selected and you press Enter on the keyboard, the next table cell down is selected. Pressing either Tab or Enter on the numeric keypad located to the right of the keyboard selects the next table cell to the right.

Select this option to change the behavior of the Enter key on the numeric keypad to select the next table cell down instead of to the right. This option is deselected by default.

---

**Table 14.7 Preferences on the Tables Page (Continued)**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show Alternate Column Name</strong></td>
<td>Select this option to show the name-label pair of the column. A column has name-label pair if the two column properties are defined and the Column Name equals one of the two properties.</td>
</tr>
<tr>
<td><strong>Use Thousands Separator</strong></td>
<td>Select this option to display numbers using the locale-appropriate thousands separator. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Show Search Box on Columns Panel</strong></td>
<td>Shows a search box on the Columns panel above the column names. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Row Editor Always Show All Columns</strong></td>
<td>Select this option to enable the Row Editor to display all columns. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Default Field Width</strong></td>
<td>Changes the number of digits that appear in numeric columns. The default setting is 12.</td>
</tr>
<tr>
<td><strong>Use Numerical Ordering</strong></td>
<td>Specifies that text containing numbers be sorted in numerical order. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Numeric keypad Enter key moves down</strong></td>
<td>(Windows only) When a data table cell is selected and you press Enter on the keyboard, the next table cell down is selected. Pressing either Tab or Enter on the numeric keypad located to the right of the keyboard selects the next table cell to the right. Select this option to change the behavior of the Enter key on the numeric keypad to select the next table cell down instead of to the right. This option is deselected by default.</td>
</tr>
</tbody>
</table>
Table 14.7 Preferences on the Tables Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suppress Formula Eval on Open</td>
<td>Select this option to prevent columns formulas from being evaluated when you open data tables. Deselect this option to allow formulas to be evaluated when you open data tables. This option is deselected by default. This option is not recommended because typically you want to know whether a formula evaluates.</td>
</tr>
<tr>
<td>Formula Evaluation</td>
<td>Specifies when formulas are evaluated.</td>
</tr>
<tr>
<td>When Idle</td>
<td>Evaluates the formula when JMP is not performing actions. A progress bar does not appear. This option is selected by default.</td>
</tr>
<tr>
<td>Immediate</td>
<td>Evaluates the formula immediately and shows a progress bar.</td>
</tr>
<tr>
<td>Hide ODBC Connection Strings</td>
<td>Select this option to have the Open Database command hide the ODBC connection settings (that is, user ID and password). See the Scripting Guide for additional information. This option is deselected by default.</td>
</tr>
<tr>
<td>Prefer DSN-less ODBC Connection Strings</td>
<td>Select this option to allow DSN-less ODBC connection strings. This option is deselected by default.</td>
</tr>
<tr>
<td>ODBC Allow Table Replace</td>
<td>Select this option to allow ODBC table replace. This option is selected by default.</td>
</tr>
<tr>
<td>Warn when referenced table name has changed</td>
<td>Shows a warning when a virtually linked <em>(referenced)</em> table name has changed. This option is selected by default.</td>
</tr>
<tr>
<td>Virtual Join Auto Open Linked Table</td>
<td>Automatically opens a virtually joined data table. A link to the data table is in the JMP Home window. This option is deselected by default.</td>
</tr>
<tr>
<td>Virtual Join Use Linked Column Name</td>
<td>Specifies that the linked column name be used in virtually joined columns that are shown in the Columns list. This option lets you specify a shorter column name (for example, Cheese instead of Cheese[Choice]). This option is deselected by default.</td>
</tr>
</tbody>
</table>
Table 14.7 Preferences on the Tables Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Header Summary Graphs</strong></td>
<td><strong>Show summary graphs below column names</strong>  Shows a summary graph (a distribution) in the column header. Applies when the number of rows is below a threshold such as 3 million rows. This option is deselected by default.</td>
</tr>
<tr>
<td></td>
<td><strong>Show missing data bars or bins in summary graphs</strong>  Specifies whether missing data bars or bins initially appear in summary graphs. To show missing value bars in an individual graph, right-click the graph and select <strong>Missing values bars</strong>. Missing value bars are not shown by default.</td>
</tr>
<tr>
<td></td>
<td><strong>Summary Graph Colors</strong>  Specifies the color of the fill and the highlight (the color that appears when you select a bar), including by data type.</td>
</tr>
</tbody>
</table>

**Preferences for JMP Data Filters**

Data Filter preferences customize settings for data filters.

**Figure 14.9** Data Filter Preferences
Table 14.8 Preferences on the Data Filter Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Modes</strong></td>
<td>Specifies the filtering mode.</td>
</tr>
<tr>
<td><strong>Select</strong></td>
<td>Shows the selected rows in the data table in a highlighted state. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Show</strong></td>
<td>Shows the unselected rows with the Hide icon. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Include</strong></td>
<td>Shows the unselected rows with the Exclude icon. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Options</strong></td>
<td>Specifies options for the data filter.</td>
</tr>
<tr>
<td><strong>Auto clear</strong></td>
<td>If you have more than one nominal or ordinal column selected in the Data Filter, this option clears any other selections before making a new selection. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Grouped by AND</strong></td>
<td>Enables you to control the AND and OR behavior of multiple groups of column filters. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Conditional</strong></td>
<td>Limits the categories displayed for the selected filter column. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Use Floating Window</strong></td>
<td>Keeps the Data Filter window on top of its associated data table. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Select Missing</strong></td>
<td>Highlights missing values in the data table. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Display</strong></td>
<td>Specifies display options for categorical columns.</td>
</tr>
<tr>
<td><strong>Check Box Display</strong></td>
<td>Shows a check box next to each level. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Show Histograms and Bars</strong></td>
<td>Shows the histogram and bars in the data filter. This option is selected by default.</td>
</tr>
</tbody>
</table>
Preferences for the Column Switcher

The Column Switcher preferences customize the settings for the column switcher utility.

**Figure 14.10** Column Switcher Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always include switch column in replacement list</td>
<td>If this option is selected, the current column is automatically included in the list of columns in the Column Switcher. If this option is deselected (the default setting), a warning appears if a specified Column Switcher does not include the current column.</td>
</tr>
<tr>
<td>Retain axis settings when switching</td>
<td>Specifies that the axis settings should be held constant when switching columns in the Column Switcher. This option is deselected by default.</td>
</tr>
<tr>
<td>Run animation in a loop</td>
<td>Specifies the default behavior for the end of the animation loop. If this option is selected (the default setting) the animation starts back at the beginning when it reaches the end of the loop. If this option is deselected, the animation stops at the end of the loop.</td>
</tr>
<tr>
<td>Default Outline Title</td>
<td>Specifies the title of the Column Switcher. The default setting is “Column Switcher”.</td>
</tr>
</tbody>
</table>

Preferences for Recoding Columns

The Recode preferences customize the recoding of columns.
Table 14.10 Preferences on the Recode Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sort style</strong></td>
<td>Specifies how values are sorted by default.</td>
</tr>
<tr>
<td></td>
<td><strong>New Value</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Old Value</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Count</strong></td>
</tr>
<tr>
<td><strong>Commit style</strong></td>
<td>Defines the default behavior for recoding columns.</td>
</tr>
<tr>
<td></td>
<td><strong>New Column</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Formula Column</strong></td>
</tr>
<tr>
<td></td>
<td><strong>In Place</strong></td>
</tr>
<tr>
<td><strong>Script sequence of actions</strong></td>
<td>Saves all of your actions in the script. This option is selected by default. If the option is deselected, only the original and replacement values are included in the script.</td>
</tr>
</tbody>
</table>
| **Compress sequence**         | Combines expressions to simplify the saved script. Selected by default when you select Script sequence of actions.
Table 14.10 Preferences on the Recode Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove Empty Items</td>
<td>In a Multiple Response column, excludes empty items in the column when recoding the column in the data table. This option is deselected by default.</td>
</tr>
<tr>
<td>Remove Duplicate Items</td>
<td>In a Multiple Response column, excludes duplicate items. For example, if the original data were a, b, b, c, and no changes to those particular items were made, the recoded column in the data table would contain a, b, c. This option is deselected by default.</td>
</tr>
<tr>
<td>Sort Items</td>
<td>In a Multiple Response column, sorts items alphabetically. For example, if the original data were b, a, c, and no changes to those particular items were made, the recoded column in the data table would contain a, b, c. This option is deselected by default.</td>
</tr>
</tbody>
</table>

Value Order Preferences

There is a built-in set of orderings (for example, month names, days of the week, and Likert) that automatically sort data. You can make customizations by adding new orderings, modifying previously created orderings, and disabling existing orderings.

Figure 14.12 Value Order Preferences
Each analysis report has a variety of plot and table options that are shown by default. However, there might be additional options that you want to see each time you run a particular analysis. For example, a bivariate analysis shows a scatterplot by default, but you might also always want to see a linear fit each time. By selecting the Platforms option in the left panel of the Preferences window, you can set the default options for analyses. (Analyses are run by using platforms, such as the Bivariate platform. Thus, the name of this category is Platforms.)

Highlight an analysis name in the Platforms list. Its available options appear in the Options box with the defaults selected.

Some platform preferences include a Set check box to control whether an option appears in a report.

- To prevent an option from appearing in the report, next to an option, select Set but do not select the option.
- To ensure an option appears in the report, select Set and select the option.

Click **Reset Platform to Defaults** to return the selected platform options to the default settings.

Click **Reset to Defaults** to return all platforms to their default settings.

### Table 14.11 Value Order Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exact Match</td>
<td>Specifies whether the items have to be exact matches, including case and whitespace. This option is deselected by default.</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Creates a copy of the selected ordering that you can modify.</td>
</tr>
<tr>
<td>Create</td>
<td>Select a column from the current table and create an ordering.</td>
</tr>
</tbody>
</table>
Preferences for Importing and Exporting Text Files

Text Data File preferences customize importing and exporting text files.
Figure 14.14 Text Data Files Preferences

### General
- Open Text File Charset: Best Guess
- Save Text Files as Unicode

### Import Settings
- Use best guess
- Use these settings
  - End Of Field:
    - Tab
    - Comma
    - Other
    - Spaces
    - CSV standard
  - End Of Line:
    - <CR> + <LF>
    - Semicolon
    - <CR>
    - Other
- Table contains column headers
- Column Names are on line: 1
- Column names start applying to column: 1
- Data starts on line: 2
- Two-digit year rule: 2000-2099

When determining column types:
- Scan whole file
- Scan for 5 seconds
- Treat empty columns as numeric

Try to compress (requires Scan whole file)
- Numeric columns
- Character columns
- Allow List Check

Strip enclosing quotation marks
- Recognize apostrophe as quotation mark (not recommended)
- Use Regional Settings

### Export Settings
- Export Table Header:
  - Add quotation marks to all column names
  - Add quotation marks to all character values
  - Add quotation marks to all numeric values

End Of Field:
- Tab
- Space
- Spaces
- Comma
- None
- Other

End Of Line:
- <CR> + <LF>
- <CR>
- <LF>
- Semicolon
- Other
Table 14.12  Preferences for Import Settings for Text Files

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Text File Charset</td>
<td>Select one of the options from the menu to determine what character encoding JMP uses to open files. The default setting is Best Guess. Note that Windows-1252 is considered ANSI on some systems, and UTF-8-BOM is not supported.</td>
</tr>
</tbody>
</table>
| Save Text Files as Unicode | JMP uses the Unicode character set, which supports special characters such as é and ½. It saves files without special Unicode characters as plain text automatically. This option is selected by default.  
Deselect this check box to save all your files as plain text. |
| Import Settings         | Select the strategy JMP uses to open text files. The default selection is Use these settings. In that case, you need to ensure that the settings reflect your text files.  
If you select Use best guess, JMP collects statistics in the text file on tabs, commas, blanks, and a few other characters and uses a rule-based system to decide what the file format might be. The rules try to make reasonable field widths and a reasonable number of fields per line. If your data format is too different from what the rules are designed to guess, JMP guesses incorrectly. In that case, either use the wizard or explicitly describe your data in these preference settings. |
| End Of Field            | Select one or more characters to use as the delimiter that signifies the end of a field when importing text data. Tab, comma, and CSV standard are selected by default.  
Select the Other option and enter a character to specify a delimiter that is not listed. |
### Using JMP Preferences for Importing and Exporting Text Files

#### End Of Line
Select one or more characters to use as the delimiter that signifies the end of a line (row). `<CR>+<LF>`, `<CR>`, and `<LF>` are selected by default.

Select the **Other** option and enter a character to specify a delimiter that is not listed.

Note that if double-quotes are encountered when importing text data, the delimiter rules change to look for an end double-quote. Other text delimiters, including spaces, that are embedded within the quotes are ignored and treated as part of the text string.

#### Table contains column headers
Select this option if your text file contains columns names. If you select this option, enter the line number where the column names are located in the field next to **Column Names are on line**. This option is selected by default.

#### Column Names are on line
If you select the **Table contains column headers** option, enter the line number where the column names are located in this field. Line one is the default setting.

#### Column names start applying to column
Select this option and enter the column number for data columns that do not have column names. Specifies where the column names start applying. Column one is the default setting.

#### Data starts on line
Enter the line number where the data starts in your text file. Line two is the default setting.

#### When determining column types
Set how long JMP scans a text file to determine data types for the columns. **Scan whole file** is selected by default. Note that the **Scan whole file** option can cause importing a text file to be slow for large files. Consider selecting **Scan for 5 seconds** instead.

When your text file contains columns of missing data, select **Treat empty columns as numeric** to import the columns as numeric rather than character. A period, Unicode dot, `NaN`, or a blank string are possible missing value indicators. This option is deselected by default.

#### Two-digit year rule
Select the rule that you want to use to import dates that have two-digit years instead of four. 2000-2099 is the default setting.

For more information about these rules, see “Two-digit year rule”.

---

**Table 14.12 Preferences for Import Settings for Text Files (Continued)**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>End Of Line</strong></td>
<td>Select one or more characters to use as the delimiter that signifies the end of a line (row). <code>&lt;CR&gt;+&lt;LF&gt;</code>, <code>&lt;CR&gt;</code>, and <code>&lt;LF&gt;</code> are selected by default. Select the <strong>Other</strong> option and enter a character to specify a delimiter that is not listed. Note that if double-quotes are encountered when importing text data, the delimiter rules change to look for an end double-quote. Other text delimiters, including spaces, that are embedded within the quotes are ignored and treated as part of the text string.</td>
</tr>
<tr>
<td><strong>Table contains column headers</strong></td>
<td>Select this option if your text file contains columns names. If you select this option, enter the line number where the column names are located in the field next to <strong>Column Names are on line</strong>. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Column Names are on line</strong></td>
<td>If you select the <strong>Table contains column headers</strong> option, enter the line number where the column names are located in this field. Line one is the default setting.</td>
</tr>
<tr>
<td><strong>Column names start applying to column</strong></td>
<td>Select this option and enter the column number for data columns that do not have column names. Specifies where the column names start applying. Column one is the default setting.</td>
</tr>
<tr>
<td><strong>Data starts on line</strong></td>
<td>Enter the line number where the data starts in your text file. Line two is the default setting.</td>
</tr>
<tr>
<td><strong>When determining column types</strong></td>
<td>Set how long JMP scans a text file to determine data types for the columns. <strong>Scan whole file</strong> is selected by default. Note that the <strong>Scan whole file</strong> option can cause importing a text file to be slow for large files. Consider selecting <strong>Scan for 5 seconds</strong> instead. When your text file contains columns of missing data, select <strong>Treat empty columns as numeric</strong> to import the columns as numeric rather than character. A period, Unicode dot, <code>NaN</code>, or a blank string are possible missing value indicators. This option is deselected by default.</td>
</tr>
</tbody>
</table>
| **Two-digit year rule** | Select the rule that you want to use to import dates that have two-digit years instead of four. 2000-2099 is the default setting. For more information about these rules, see “Two-digit year rule”.
Table 14.12 Preferences for Import Settings for Text Files (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Try to compress</td>
<td>Select the options used for compressing text files. The following options are available, and all are deselected by default:</td>
</tr>
<tr>
<td></td>
<td>• Numeric columns</td>
</tr>
<tr>
<td></td>
<td>• Character columns</td>
</tr>
<tr>
<td></td>
<td>• Allow List Check</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This feature requires a scan of the entire file.</td>
</tr>
<tr>
<td>Strip enclosing quotation marks</td>
<td>Select this option to remove quotation marks that enclose data in the text file. This option is selected by default.</td>
</tr>
<tr>
<td>Recognize apostrophe as quotation mark</td>
<td>Select this option to treat apostrophes as quotation marks and omit them. This option is deselected by default.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This option is not recommended unless your data comes from a nonstandard source that places apostrophes around data fields rather than quotation marks.</td>
</tr>
<tr>
<td>Use Regional Settings</td>
<td>Select this option to use the operating system’s regional settings when importing a text file.</td>
</tr>
<tr>
<td></td>
<td>• If the option is deselected (the default setting), files that use a period for a decimal point and a comma for the value separator import correctly.</td>
</tr>
<tr>
<td></td>
<td>• If the file uses a comma for a decimal point and some other value separator (and the regional settings use a comma for a decimal point), selecting this option imports the text correctly. You must specify the value separator in the Text Data Files import preferences.</td>
</tr>
</tbody>
</table>

Table 14.13 Preferences for Export Settings for Text Files

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export Table Headers</td>
<td>Select this option to include column names when you save data tables as text files. This option is selected by default.</td>
</tr>
<tr>
<td>Add quotation marks to all column names</td>
<td>Select this option to insert quotation marks around column names. Used to export data to a program that has more stringent requirements than CSV. This option is deselected by default.</td>
</tr>
</tbody>
</table>
These preferences specify settings for third-party data, such as Microsoft Excel and SPSS files.
Table 14.14 Preferences on the Third Party Data Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Excel Open Method</td>
<td>Select one of the options to determine how JMP imports Microsoft Excel worksheets.</td>
</tr>
<tr>
<td>Excel Wizard</td>
<td>Lets you preview a Microsoft Excel worksheet and modify the settings before importing the data. This is the default setting on Windows. On macOS, all .xlsx files open in the Excel Wizard.</td>
</tr>
<tr>
<td>Open All Sheets</td>
<td>Opens all worksheets in the workbook. On macOS, this preference is only for .xls files.</td>
</tr>
<tr>
<td>Select Individual Worksheets</td>
<td>Lets you select the worksheets that you want to open from a workbook. On macOS, this preference is only for .xls files. The option is also provided on macOS when you open an Excel (.xls) file.</td>
</tr>
<tr>
<td>On Windows, you can also select File &gt; Open, select the workbook, click the Open button arrow, and select Open Selected Worksheets or Use Excel Wizard.</td>
<td></td>
</tr>
<tr>
<td>Use Excel Labels as Headings</td>
<td>Select this option to allow JMP to use Excel label names as column headings when importing Excel files. Available settings include:</td>
</tr>
<tr>
<td></td>
<td>• Use best guess (default)</td>
</tr>
<tr>
<td></td>
<td>• Always</td>
</tr>
<tr>
<td></td>
<td>• Never</td>
</tr>
<tr>
<td>Image Format for PowerPoint</td>
<td>Select the default file format for images exported to Microsoft PowerPoint.</td>
</tr>
<tr>
<td></td>
<td>Windows does not support the native PDF graphics produced on macOS. macOS does not support the native EMF graphics produced on Windows. For cross-platform compatibility, specify the PNG or JPEG graphic format. Additional file formats are available through scripting. See the JSL Syntax Reference.</td>
</tr>
<tr>
<td>Use SPSS Labels for column names during import</td>
<td>Select this option to allow JMP to use SPSS label names as column headings when importing SPSS files.</td>
</tr>
<tr>
<td>Use Triple-S Labels as Headings</td>
<td>Select this option to allow JMP to use Triple-S label names as column headings.</td>
</tr>
</tbody>
</table>
Preferences for SAS Integration

SAS Integration preferences customize the default settings for working with SAS servers. For more information about using the SAS Integration capabilities, see “Import Data from SAS”.

**Note:** The SAS Environment options appear after you select SAS 9.4 from the SAS Server Version list.

**Figure 14.16  SAS Integration Preferences**

- **SAS Server Version:** 9.4
- **SAS Environment**
  - I want to connect to a SAS Environment
  - I want to connect directly to a SAS Metadata Server
  - I will manually connect to SAS workspace servers
- **Automatically connect metadata-defined SAS libraries**
- **SAS Submit Options**
  - Automatically generate ODS results
    - ODS Result Format: HTML
    - ODS Style: Statistical
    - ODS Style sheet:
    - Prompt if results are larger than 5 MB
    - Graphics Format: ActiveX Image
      - Generate ODS statistical graphics
    - Import generated SAS data sets into JMP
      - Prompt if data set has more than 100000 rows
- **SAS Data Import**
  - Use SAS variable labels for column names during data import
  - Convert SAS custom formats to JMP value labels
  - Warn before closing unsaved imported data
- **SAS 9.4 Extended Attributes**
  - On export, store table and column properties in extended attributes
  - On import, apply table and column properties from extended attributes

**Stored Process Results**
- Format
  - HTML
  - RTF
  - PDF
- Graph Format
  - ActiveX Image
  - Java Image
  - PNG
  - JPEG
  - GIF

**Show SAS Log**
- Always
- Never
- On Error

**Location**
- JMP Log
- Separate Window
### Table 14.15  Preferences on the SAS Integration Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SAS Server Version</strong></td>
<td>Select the default version for the SAS Server. This can also be changed in the Server Connections window. (See “Connect to a SAS Metadata Server from JMP”.) This option does not apply when connecting to local SAS on Windows. The default setting is 9.4.</td>
</tr>
<tr>
<td><strong>I want to connect to a SAS Environment</strong></td>
<td>Select this option to always connect to a SAS Environment and click <strong>Configure</strong> to configure the URL of the location. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>I want to connect to a SAS Metadata Server</strong></td>
<td>Select this option to always connect to a SAS Metadata Server. This option is selected by default. Clear this option if you do not have a SAS Metadata Server available, and you connect directly to SAS Workspace Servers instead.</td>
</tr>
<tr>
<td><strong>I will manually connect to SAS workspace servers</strong></td>
<td>Select this option to manually connect to a SAS workspace server. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Automatically connect metadata-defined SAS libraries</strong></td>
<td>Select this option to connect to metadata-defined SAS libraries automatically across all JMP sessions when you connect to a SAS Workspace Server. his option is selected by default. When the Workspace Server contains a large number of metadata-defined SAS libraries, deselect this option to speed up your connection to the server.</td>
</tr>
<tr>
<td><strong>Automatically generate ODS results</strong></td>
<td>Select this option to generate output delivery system (ODS) results. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>ODS Result Format</strong></td>
<td>Select the format for ODS reports. The default setting is HTML.</td>
</tr>
<tr>
<td><strong>ODS Style</strong></td>
<td>Enter the style name for ODS reports. The default setting is Statistical.</td>
</tr>
<tr>
<td><strong>ODS Style sheet</strong></td>
<td>Enter the style sheet name for ODS reports.</td>
</tr>
<tr>
<td><strong>Prompt if results are larger than __ MB</strong></td>
<td>Enter the number of MB that triggers a prompt for you to continue or cancel the operation. Five is the default setting.</td>
</tr>
<tr>
<td><strong>Graphics Format</strong></td>
<td>Select the format for graphics for ODS reports. ActiveX Image is the default setting.</td>
</tr>
</tbody>
</table>
Table 14.15 Preferences on the SAS Integration Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Generate ODS statistical graphics</strong></td>
<td>Select this option to include statistical graphics in the ODS reports.</td>
</tr>
<tr>
<td><strong>Import generated SAS data sets into JMP</strong></td>
<td>Select this option to import any generated data sets into JMP automatically.</td>
</tr>
<tr>
<td><strong>Prompt if data set has more than __ rows</strong></td>
<td>Enter the number of rows that triggers a prompt for you to continue or cancel the operation. The default setting is 100,000.</td>
</tr>
<tr>
<td><strong>Use SAS variable labels for column names during data import</strong></td>
<td>Select this option to use the column labels in the SAS data set as the JMP data table column names when importing a SAS data set into a JMP data table. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Convert SAS custom formats to JMP value labels</strong></td>
<td>Select this option to use the information in the SAS column formats to set JMP value labels when importing a SAS data set into a JMP data table. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Warn before closing unsaved imported data</strong></td>
<td>Select this option to trigger a prompt to save any SAS data sets that you imported into JMP and have not saved before closing. This option is selected by default.</td>
</tr>
<tr>
<td><strong>On export, store table and column properties in extended attributes</strong></td>
<td>Select to allow extended attribute support during SAS 9.4 data export. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>On import, apply table and column properties from extended attributes</strong></td>
<td>Select to allow extended attribute support during SAS 9.4 data import. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Stored Process Results: Format</strong></td>
<td>Select a report format: HTML (default), RTF, or PDF.</td>
</tr>
<tr>
<td><strong>Stored Process Results: Graph Format</strong></td>
<td>Select a graph format: ActiveX Image (default, available only on a SAS server that runs on Windows), Java Image, PNG, JPEG, or GIF.</td>
</tr>
<tr>
<td><strong>Show SAS Log</strong></td>
<td>Select Always, Never, or On Error (default) to set when the SAS log is displayed</td>
</tr>
<tr>
<td><strong>Location</strong></td>
<td>Select the location for SAS log information: within the JMP log window, or in a separate SAS log window. The default setting is the JMP log window.</td>
</tr>
</tbody>
</table>
Preferences for the Query Builder

The Query Builder preferences customize SQL queries that you perform in Query Builder.

Figure 14.17 Query Builder Preferences

Automatically join tables added to a query
Refresh the preview when a change occurs

Maximum number of rows for previews: 5000

Keep queries compatible with JMP 12 by default

Maximum number of levels for a Check Box List filter: 1000
Maximum rows in table for which category levels will be automatically retrieved: 100000

Retrieve category levels for tables whose size cannot be determined

Default filter type for categorical columns: List Box
Fallback filter type for categorical columns: Contains

ODBC
Run the preview update in the background
Run queries in the background when possible

Table 14.16 Preferences on the Query Builder Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatically join tables added to a query</strong></td>
<td>Automatically joins database tables in Query Builder based on keys and common column names. This option is selected by default. Deselect this option to prevent memory issues with large databases.</td>
</tr>
<tr>
<td><strong>Refresh the preview when a change occurs</strong></td>
<td>Updates the data view on the Query Preview tab when a change occurs. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Maximum number of rows for previews</strong></td>
<td>Limits the number of rows that appear on the Query Preview tab. The default number is 5000.</td>
</tr>
<tr>
<td><strong>Keep queries compatible with JMP 12 by default</strong></td>
<td>Maintains query compatibility with JMP 12. When you open a query that is marked JMP 12 compatible in JMP 13 or later, features that create compatibility problems are hidden regardless of how the preference is set.</td>
</tr>
</tbody>
</table>
Table 14.16 Preferences on the Query Builder Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Maximum number of levels for a Check Box List filter</strong></td>
<td>Determines whether the filter for a categorical variable is added as a Check Box List filter. By default, when you add a categorical variable that has more than 1,000 levels, the filter is added as a Contains filter.</td>
</tr>
<tr>
<td><strong>Maximum rows in table for which category levels will be automatically retrieved</strong></td>
<td>Specifies the maximum numbers of rows for which unique category levels in the filtered column are retrieved. The minimum value is -1 (no limit). The maximum value is 1 billion. By default, if the categorical column has more than 1 million rows, JMP does not automatically retrieve the unique category levels.</td>
</tr>
<tr>
<td><strong>Retrieve category levels for tables whose size cannot be determined</strong></td>
<td>Determines whether category levels are retrieved for a filtered column when the number of rows cannot be determined. Selected by default. If this option is deselected, the filter is added as a Contains filter.</td>
</tr>
<tr>
<td><strong>Default filter type for categorical columns</strong></td>
<td>Specifies a List Box as the default filter type for categorical columns.</td>
</tr>
<tr>
<td><strong>Fallback filter type for categorical columns</strong></td>
<td>Specifies a Contains filter as the default filter type for categorical columns when the number of rows cannot be determined or the query is canceled.</td>
</tr>
<tr>
<td><strong>Run the preview update in the background</strong></td>
<td>Updates the data view Query Preview tab without displaying the status so that you can continue to work while the queries run. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Run queries in the background when possible</strong></td>
<td>Runs database queries without displaying the status so that you that can continue to work Query Builder while the queries run. This option is selected by default.</td>
</tr>
</tbody>
</table>
Preferences for the JSL Script Editor

Script Editor preferences customize the appearance of the JSL Script Editor and script editor boxes, such as tab width, syntax coloring, and tooltips.

Figure 14.18 Script Editor Preferences

- General
  - Use tabs
  - Tab width: 4
  - Extra space at bottom of document
  - Auto-complete parentheses and braces
  - Show line numbers in script editor windows
  - Show indentation guides
  - Show line numbers in script editor boxes
  - Show operator tips
  - Show variable value tips
  - Wrap text
  - Show embedded log on script window open
  - Save and restore document state information
  - Autosave before run
  - Allow nonadjacent selection
  - Copy text using Light theme
  - Embedded log height: 30%

- Code Folding
  - Code folding
  - Code folding marker: Box Minus/Plus
  - Allow additional JSL code folding keywords

- JSL formatting
  - Spaces inside parentheses
  - Spaces in operator names
  - Color unknown object messages

- Customize Styles
  - Theme: Light
  - Language: JSL
  - Default Enabled
  - Default Disabled
  - Block Comment
  - Nested Block Comment
  - Line Comment
  - Brace
  - Date
  - Reset All Styles to Defaults
  - Style
    - Foreground: [Color]
    - Background: [Color]
    - Font: Consolas, 10 Point
    - Reset Style to Defaults
### Table 14.17 Preferences on the Script Editor Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use tabs</strong></td>
<td>Select this option to enable tabs in your scripts. This option is selected by default. Clear this option to replace any tab that you type with spaces.</td>
</tr>
<tr>
<td><strong>Tab width</strong></td>
<td>Enter how many spaces a tab should indent. If you have disabled tabs, any tab you type is replaced with the number of spaces specified. The default setting is 4.</td>
</tr>
<tr>
<td><strong>Extra space at bottom of document</strong></td>
<td>Select this option to enable scrolling up from the last blank lines of a script. This option is selected by default on Windows and deselected on macOS.</td>
</tr>
<tr>
<td><strong>Auto-complete parentheses and braces</strong></td>
<td>Select this option to enable the script editor to automatically add closing parentheses, square brackets, and curly braces when you type an opening one. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Show line numbers in script editor windows</strong></td>
<td>Select this option to show the line numbers on the left side of the script editor. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Show indentation guides</strong></td>
<td>Select this option to see faint vertical lines that mark indentation. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Show line numbers in script editor boxes</strong></td>
<td>Select this option to show the line numbers on the left side of script editor boxes (such as in the Scripting Index). This option is off by default.</td>
</tr>
<tr>
<td><strong>Show operator tips</strong></td>
<td>Select this option to see tooltips for JSL operators. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Show variable value tips</strong></td>
<td>Select this option to see tooltips for variable values. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Wrap text</strong></td>
<td>Select this option to always wrap text in the script editor. This option is off by default.</td>
</tr>
<tr>
<td><strong>Show embedded log on script window open</strong></td>
<td>Select this option to have an embedded log window appear in the scripting window when editing or running scripts. This option is off by default.</td>
</tr>
<tr>
<td><strong>Save and restore document state information</strong></td>
<td>Saves the state of collapsed and expanded code, and restores that state when the script is reopened.</td>
</tr>
</tbody>
</table>
### Table 14.17 Preferences on the Script Editor Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Autosave before run</strong></td>
<td>Automatically saves the script before you run it. This option is off by default.</td>
</tr>
<tr>
<td><strong>Allow nonadjacent selection</strong></td>
<td>Enables you to select text that is not adjacent. Press Ctrl on Windows or Command on macOS and drag your cursor over the text. Continue this action for any other text that you want to select. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Copy text using Light theme</strong></td>
<td>Determines whether the background color of the code is pasted to another document. This option is selected by default. This means that, when the Light theme is selected in the Script Editor preferences, the code will be pasted with a light background into another document.</td>
</tr>
<tr>
<td><strong>Embedded log height</strong></td>
<td>Specifies the height of the embedded log in a script window. The default setting is 30%.</td>
</tr>
<tr>
<td><strong>Code folding</strong></td>
<td>Select this option to use code folding markers in the script editor, which mark the opening and closing of user defined functions and <code>Expr()</code> blocks. You can expand and collapse these marked blocks of code. This option is off by default. You can also choose the appearance of the marker using the JSL code folding marker menu. See the <em>Scripting Guide</em>.</td>
</tr>
<tr>
<td><strong>Allow additional JSL code folding keywords</strong></td>
<td>Select this option to enable using additional keywords for folding markers in the script editor. See the <em>Scripting Guide</em>.</td>
</tr>
<tr>
<td><strong>Spaces inside parentheses</strong></td>
<td>Select this option to cause the script editor to add spaces between parentheses, brackets, and braces and their contents for automatically formatted scripts. This is on by default.</td>
</tr>
<tr>
<td><strong>Spaces in operator names</strong></td>
<td>Select this option to cause the script editor to add spaces between words within operator names. For example, turning on this option results in <code>New Window</code> instead of <code>NewWindow</code>. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Color unknown object messages</strong></td>
<td>Select this option to always show unknown object messages in color. Unknown object messages will appear in the color specified by “Message unknown color”. This option is off by default.</td>
</tr>
</tbody>
</table>
Preferences for the Workflow Builder

The Workflow builder preferences allow you to not prompt for auto record, allow for backstep, group log history by age, and prevent other windows from overlapping the Workflow builder window.

Table 14.17 Preferences on the Script Editor Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customize Styles</td>
<td>Select colors and fonts for code elements shown in JSL scripts, SAS scripts, the Text Explorer customization window, text files, and so. Reset All Styles to Defaults restores the original colors for all items in the list. Reset Style to Defaults restores the original colors and font for the selected item on the right. Note that resetting the Fonts preferences does not affect the fonts selected on this page.</td>
</tr>
</tbody>
</table>

Figure 14.19 Workflow Builder Preferences

- Don't Prompt for Auto Record
- Auto-Record if Empty
- Allow Backstep
- Group History by Age
- Show Enable Checkboxes
- Prevent Window Overlap with Workflow

Table 14.18 Preferences for the Workflow Builder

<table>
<thead>
<tr>
<th>Preferences</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Don't Prompt for Auto Record</td>
<td>Specifies whether to prompt for auto recording. This option is deselected by default. If this option is deselected, the Auto-Record if Empty option is selected.</td>
</tr>
<tr>
<td>Allow Backstep</td>
<td>Specifies whether to enable the user to back up a step in the workflow. This option is selected by default.</td>
</tr>
</tbody>
</table>
The JSL Debugger preferences let you show or hide line numbers, create breaks in scripts, and show warnings.

**Figure 14.20** JSL Debugger Preferences

- **Show Line Numbers**
- **Break On Multiple Statements Per Line**
- **Break On Throw**
- **Break On Execution Error**
- **Warn On Assignment In Condition**
- **Enter Debugger Upon Termination**
- **Break For Compatibility Warnings**

**Table 14.19** Preferences on the JSL Debugger Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show Line Numbers</strong></td>
<td>Shows or hides the line numbers for the script in the debugger. This option is selected by default.</td>
</tr>
<tr>
<td><strong>Break on Multiple Statements Per Line</strong></td>
<td>Stops executing the script between each expression in a single line. This option is deselected by default.</td>
</tr>
</tbody>
</table>
Table 14.19 Preferences on the JSL Debugger Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Break On Throw</td>
<td>Breaks when an exception error occurs in a Try() function. For example, the exception error in the Try() function is thrown by a Throw() function. The Debugger breaks on the Throw() instead of continuing through the rest of the codes. This lets you identify where the problem occurred in the script and then return to debugging. This option is deselected by default.</td>
</tr>
<tr>
<td>Break On Execution Error</td>
<td>Stops executing the script when the error occurs rather than closing the Debugger. The option is selected by default</td>
</tr>
<tr>
<td>Warn On Assignment In Condition</td>
<td>Select to show a warning when you enter an assignment expression for the breakpoint condition. For example, if you specify x = 1 instead of x == 1 in the breakpoint condition, you are prompted to verify the specification. The option is selected by default</td>
</tr>
<tr>
<td>Enter Debugger Upon Termination</td>
<td>Select to enter the Debugger when JMP terminates. The option is selected by default</td>
</tr>
<tr>
<td>Break for Compatibility Warnings</td>
<td>Stops executing the script when a JSL compatibility issue is encountered. The option is selected by default</td>
</tr>
</tbody>
</table>
Preferences for the Log

The Log preferences specify which interactive JMP actions are recorded in the log, the log mode, and customizations of the appearance and behavior of the Enhanced Log. A preview of the log appears to the right of the preference options.

Figure 14.21  Log Preferences

<table>
<thead>
<tr>
<th>Preference Group</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action Recording</td>
<td>Contains options to control what types of actions are recorded in the log. You can choose to record operations on data tables, launches of platforms, as well as a script of each report when the report is closed. The Action Recording preferences are applicable to both modes of the log. All options are selected by default.</td>
</tr>
</tbody>
</table>
### Table 14.20 Preferences on the Log Page  (Continued)

<table>
<thead>
<tr>
<th>Preference Group</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mode</strong></td>
<td>Enables you to switch between the Enhanced Log and the Text Log (the default setting).</td>
</tr>
<tr>
<td><strong>Table</strong></td>
<td>Contains options to control the appearance of the contents of the Enhanced Log. Underline Table Headings, Shade Table Headings, Table Heading Column Borders, and Table Row Borders are selected by default.</td>
</tr>
<tr>
<td><strong>Filter</strong></td>
<td>Contains options to control what types of output appear in the Enhanced Log. All options are selected by default.</td>
</tr>
<tr>
<td><strong>Columns</strong></td>
<td>Contains options to control which columns of information appear in the Enhanced Log. You can show or hide the following columns of information: the origin type of the message, the result type of the message, and the time stamp of the message. All options are selected by default.</td>
</tr>
<tr>
<td><strong>Color by Window</strong></td>
<td>Specifies whether the rows in the Enhanced Log are colored by the JMP window that created the row of the log output. This option is selected by default. “JMP Default” is the default color theme.</td>
</tr>
</tbody>
</table>

### Windows Preferences

The Windows Specific preferences customize settings for Windows computers, including auto-hiding menus and toolbars and selecting the default graphics format.
Figure 14.22 Windows Specific Preferences

- **Display Language**
  - English (English)
  - Use JMP language rather than System locale settings for number, date, and currency format

- **Locale Format Settings**
  - Decimal Separator: Default
  - Thousands Separator: Default
  - Currency Decimal Separator: Default
  - Currency Thousands Separator: Default

- **Copy/Drag Graphic Formats**
  - Enhanced metafile
  - RTF
  - JPEG
  - Windows bitmap
  - PNG
  - Resolution (DPI) for PNG and JPEG images: Default

- **Graphics Format**
  - Graphic format for RTF files: EMF
  - Graphic scale factor %: 100
  - Graphic format for HTML files: PNG

- **Enable hardware accelerated graphics**
- JSL Scripts should be run only, not opened, when selected from Recent Files or a file browser

**Show on the Windows task bar**
- All windows

**Auto-hide menu and toolbars**
- Never

- Wrap the main menu in narrow windows
- Show the thumbnail panel in data table windows
- Dock the Window List in maximized windows
- Show log activity in status bar

**Reset file associations to this application.** Reset Associations
### Table 14.21 Preferences on the Windows Specific Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
</table>
| Display Language                                 | Select the language in which you want to run JMP. The locale settings for your operating system normally determine settings for number, date, and currency formats. Select the option below the language menu to use that language to determine these formats instead. Text that appears in windows provided by the operating system (for example, File > Open), do not reflect changes in the language setting. **Notes:**  
  - After changing the display language, close and restart JMP to have the language settings fully take effect.  
  - The languages that you selected in the JMP installation program determine which languages are available. To make a language available, rerun the JMP installation program, select Modify, and then select the language. |
| Use JMP language rather than System locale settings for number, date, and currency formats | Uses the JMP display language to specify number, date, and currency formats.                                                                                                                                 |
| Locale Format Settings                           | Specify the decimal and thousands separators used for numbers and currency values. The Default setting uses the system locale and the settings in the Display Language preferences. If a non-default setting is specified, that setting overrides the Display Language preferences and the system locale. |
| Copy/Drag Graphic Formats                        | Select one or more graphic formats to use when copying and pasting (or dragging and dropping) graphics from JMP into other applications. Enhanced Metafile, Windows bitmap, RTF, and PNG are selected by default. The resolution for PNG and JPEG images is Default. |
### JMP Preferences

**Chapter 14**

**Windows Preferences Using JMP**

**Resolution (DPI) for PNG and JPEG Images**

Specify the DPI to be used when you copy a graphic format. Choose from the Default (96) or 300. 300 is better for images that must be stretched, embedded in trade publications, or printed. However, this setting uses more memory and is slower to generate for large images.

The following script lets you set the default DPI. Change the number to a different DPI if you want and then run the script.

```
Pref( Save Image DPI( 600 ) );
```

To verify the default DPI after you run the preceding script, run the following script:

```
Get Preferences( Save Image DPI );
```

For more information about specifying a higher DPI, see “Set the Graphic DPI for Exported Graphics”.

**Graphics Formats**

Select the format to use for graphics when you save a JMP report as an RTF file (EMF, PNG, or JPEG) or an HTML file (PNG, JPEG, GIF, and SVG).

In the Graphic Scale Factor % box, enter the percentage at which you want graphics to appear in other applications. This feature might not work with all versions of your chosen application. 100% is the default setting.

**Enable hardware accelerated graphics**

Takes better advantage of the computer’s graphics processing unit (GPU) for better video performance. Consider selecting this option if your computer is sluggish when drawing JMP windows. This is an experimental feature.

**JSL Scripts should be run only, not opened, when selected from Recent Files or a file browser**

Select this option to force all scripts to run when opened. If this is selected, the script window for the script is not opened. This option is deselected by default.

**Show on the Windows task bar**

Select which JMP windows you would like displayed on the Windows task bar. The default selection is All Windows. You can also choose to show the main JMP window and data table windows.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Resolution (DPI) for PNG and JPEG Images</strong></td>
<td>Specify the DPI to be used when you copy a graphic format. Choose from the Default (96) or 300. 300 is better for images that must be stretched, embedded in trade publications, or printed. However, this setting uses more memory and is slower to generate for large images. The following script lets you set the default DPI. Change the number to a different DPI if you want and then run the script.</td>
</tr>
<tr>
<td><strong>Graphics Formats</strong></td>
<td>Select the format to use for graphics when you save a JMP report as an RTF file (EMF, PNG, or JPEG) or an HTML file (PNG, JPEG, GIF, and SVG). In the Graphic Scale Factor % box, enter the percentage at which you want graphics to appear in other applications. This feature might not work with all versions of your chosen application. 100% is the default setting.</td>
</tr>
<tr>
<td><strong>Enable hardware accelerated graphics</strong></td>
<td>Takes better advantage of the computer’s graphics processing unit (GPU) for better video performance. Consider selecting this option if your computer is sluggish when drawing JMP windows. This is an experimental feature.</td>
</tr>
<tr>
<td><strong>JSL Scripts should be run only, not opened, when selected from Recent Files or a file browser</strong></td>
<td>Select this option to force all scripts to run when opened. If this is selected, the script window for the script is not opened. This option is deselected by default.</td>
</tr>
<tr>
<td><strong>Show on the Windows task bar</strong></td>
<td>Select which JMP windows you would like displayed on the Windows task bar. The default selection is All Windows. You can also choose to show the main JMP window and data table windows.</td>
</tr>
</tbody>
</table>
Mac OS Preferences

Mac OS Settings preferences customize settings for macOS machines, including the graphics formats and file associations.
Figure 14.23 Mac OS Settings Preferences

Alternate Image Formats for Clipboard and Drag & Drop:

- JPEG image
- PNG image
- GIF image
- TIFF image
- JPEG 2000 image
- com.apple.atx
- KTX textures
- ASTC textures
- DDS textures
- HEIF Image
- HEIF Image Sequence
- Windows icon image
- Windows BMP image
- Apple icon image
- Adobe Photoshop document
- TGA image
- OpenEXR image
- Portable Bitmap Format
- PVRTC Textures

These formats are in addition to PDF, which is always included.

Clipboard Image Scale Factor: 200%

Image format for RTF: PNG image
RTF Image Scale Factor: 100%

Image format for HTML: PNG image

Locale Format Settings

- Decimal Separator: Default
- Thousands Separator: Default
- Currency Decimal Separator: Default
- Currency Thousands Separator: Default
Using JMP Communications Preferences

Communications Preferences

(Windows only) Communications preferences customize settings for reading data from an external source. These settings need to be specified only if you are using an instrument to do so.

Table 14.22  Preferences on the Mac OS Settings Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alternate Image Formats for Clipboard and Drag &amp; Drop</td>
<td>Select one or more graphic formats to use when copying and pasting (or dragging and dropping) graphics from JMP into other applications. The default setting is TIFF.</td>
</tr>
<tr>
<td>Clipboard Image Scale Factor</td>
<td>Enter the percentage at which you want graphics to appear in other applications. The default setting is 200%.</td>
</tr>
<tr>
<td>Image format for RTF</td>
<td>Select the format to use for graphics when you save a JMP report as an RTF file. The default setting is PNG.</td>
</tr>
<tr>
<td>RTF Image Scale Factor</td>
<td>Enter the percentage at which you want graphics to appear in RTF documents. The default setting is 100%.</td>
</tr>
<tr>
<td>Image format for HTML</td>
<td>Select the format to use for graphics when you save a JMP report as an HTML file. The default setting is PNG.</td>
</tr>
<tr>
<td>Locale Format Settings</td>
<td>Specify the decimal and thousands separators used for numbers and currency values. The Default setting uses the system locale. If a non-default setting is specified, that setting overrides the system locale.</td>
</tr>
</tbody>
</table>

Figure 14.24  Communications Preferences
Preferences for Internet Options

Internet Options specify settings for opening files from the Internet.

Table 14.23 Preferences on the Communications Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port</td>
<td>Select the port that your data source uses.</td>
</tr>
<tr>
<td>Baud Rate</td>
<td>Set the baud rate for your data source.</td>
</tr>
<tr>
<td>Data Bits</td>
<td>Set the number of data bits (7 or 8).</td>
</tr>
<tr>
<td>Parity</td>
<td>Set the parity bit. None is the default setting.</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>Set the stop bits (1 or 2).</td>
</tr>
<tr>
<td>Flow Control</td>
<td>Set the flow control. XON/XOFF is the default setting.</td>
</tr>
</tbody>
</table>

Table 14.24 Preferences on the Internet Options Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Internet Open Timeout</strong></td>
<td>When you use Internet Open to open a web page, JMP waits the specified number of seconds before stopping the import due to an error. The default setting is 60 seconds.</td>
</tr>
<tr>
<td><strong>Proxy Server</strong></td>
<td>Specifies the proxy host. http (or https) needs to be included with the specification. http is assumed if no protocol is used.</td>
</tr>
</tbody>
</table>
Table 14.24  Preferences on the Internet Options Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Proxy Port</strong></td>
<td>Specifies the port used to connect to the proxy host. If none is specified, the port is 1080 (for http) and 443 for all others (https). The default setting is 0.</td>
</tr>
<tr>
<td><strong>Proxy User</strong></td>
<td>Specifies an optional user for the proxy. Not all proxy settings require a user.</td>
</tr>
<tr>
<td><strong>Bypass Proxy</strong></td>
<td>Specifies an optional comma-separated list of hosts to bypass (that is, not going through a proxy). A user might want to filter out hosts that are behind the corporate firewall (which don’t require a proxy).</td>
</tr>
<tr>
<td><strong>OAuth2 authentication browser type</strong></td>
<td>Specifies the type of OAuth2 authentication browser. The default setting is Default.</td>
</tr>
</tbody>
</table>
Print Preferences

The Print pages enables you to configure default print settings such as, margins, header, and footers.

**Figure 14.26** Print Preferences

![Print Preferences Interface](image)

**Table 14.25** Preferences on the Print Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Top (margin)</strong></td>
<td>Sets the print page’s top margin. The default setting is 0.75 inches.</td>
</tr>
<tr>
<td><strong>Left (margin)</strong></td>
<td>Sets the print page’s left margin. The default setting is 0.75 inches.</td>
</tr>
<tr>
<td><strong>Right (margin)</strong></td>
<td>Sets the print page’s right margin. The default setting is 0.75 inches.</td>
</tr>
<tr>
<td><strong>Bottom (margin)</strong></td>
<td>Sets the print page’s bottom margin. The default setting is 0.75 inches.</td>
</tr>
</tbody>
</table>
Table 14.25 Preferences on the Print Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left (header)</td>
<td>Sets the page’s left-side header information. The default setting is &amp;wt; (that is, the title).</td>
</tr>
<tr>
<td>Center (header)</td>
<td>Sets the page’s center header information. The default setting is blank.</td>
</tr>
<tr>
<td>Right (header)</td>
<td>Sets the page’s right-side header information. The default setting is Page &amp;pn; of &amp;pc; (that is, Page # of count).</td>
</tr>
<tr>
<td>Left (footer)</td>
<td>Sets the page’s left-side footer information. The default setting is blank.</td>
</tr>
<tr>
<td>Center (footer)</td>
<td>Sets the page’s center footer information. The default setting is blank.</td>
</tr>
<tr>
<td>Right (footer)</td>
<td>Sets the page’s right-side footer information. The default setting is blank.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Sets the page’s print orientation as either Portrait or Landscape. The default setting is Portrait.</td>
</tr>
<tr>
<td>Scale Factor</td>
<td>Sets the page’s print scaling factor (in percent). The default setting is 100%.</td>
</tr>
</tbody>
</table>

Note: The code for printing the current date in the header or footer is &d.

Preferences for File Locations

(Windows only) File Locations preferences set the default locations of JMP system files.

Figure 14.27 File Locations Preferences
Table 14.26 Preferences on the File Locations Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data Files directory</strong></td>
<td>Change the folder in which JMP looks for data files (for example, data tables).</td>
</tr>
<tr>
<td><strong>License file path</strong></td>
<td>Change the folder in which JMP looks for your JMP License file.</td>
</tr>
<tr>
<td><strong>Preferences file directory</strong></td>
<td>Change the folder in which JMP looks for preference information.</td>
</tr>
<tr>
<td><strong>Save As directory</strong></td>
<td>Change the folder in which JMP saves data files when you select File &gt; Save As.</td>
</tr>
<tr>
<td><strong>Always go to this directory when the File Open window is displayed</strong></td>
<td>Select to have JMP always use the specified path when you select File &gt; Open.</td>
</tr>
</tbody>
</table>

Preferences for Updating JMP

The JMP Update preferences show you what version of JMP you currently have, the last time it was updated, and whether and how often JMP checks automatically for updates.

Figure 14.28 JMP Updates Preferences
### Table 14.27 Preferences on the JMP Updates Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check for Updates</td>
<td>Select this option to have JMP automatically check for updates. If this option is selected, specify how often the check is performed: Daily, Weekly, or Monthly.</td>
</tr>
<tr>
<td>Current Version</td>
<td>What version of JMP you are currently running.</td>
</tr>
<tr>
<td>Last Check</td>
<td>The last time you checked for an update.</td>
</tr>
<tr>
<td>Check Now</td>
<td>Click this button to perform an update check immediately.</td>
</tr>
</tbody>
</table>
You can add functions to a formula. All of these functions are available in the Functions list of the Formula Editor. This chapter gives a description of functions in the Formula Editor.

More information about functions is available in the following resources:

- The Scripting Index describes all functions and their arguments, demonstrates how the functions work, and links to online Help. In JMP, select Help > Scripting Index to view this interactive resource.
- The JSL Syntax Reference also provides the arguments for JMP functions, not just those available in the Formula Editor. In JMP, select Help > JMP Help and find JSL Syntax Reference in the left column.

**Figure A.1 Functions in the Formula Editor**

For instructions on how to create a formula that contains a function, see “Create Formulas in JMP”.


Contents

Row Functions ................................................................. 759
Numeric Functions ............................................................ 761
Transcendental Functions .................................................. 762
Trigonometric Functions ..................................................... 766
Character Functions .......................................................... 767
Comparison Functions ...................................................... 773
Conditional Functions ...................................................... 774
Probability Functions ...................................................... 779
Discrete Probability Functions ............................................. 789
Statistical Functions .......................................................... 791
Random Functions ........................................................... 796
Date Time Functions .......................................................... 803
Row State Functions .......................................................... 806
Assignment Functions ...................................................... 812
Parametric Model Functions ............................................... 813
Finance Functions ............................................................. 813
Row Functions

In the JMP Formula Editor, adding a row function to a formula lets you reference specific rows or cells within specific rows. You can also insert values based on an arithmetic sequence. See the Scripting Guide for more information about syntax.

Col Stored Value

Returns the column value that does not have column properties applied to it. If the row is not specified, the current row is used.

Suppose that the Missing Value Codes column property is assigned to the x1 column to treat “999” as a missing value. Another column includes a formula that calculates the mean. To use the value “999” instead of a missing value to calculate the mean, use Col Stored Value in the formula:

\[
\text{Mean( Col Stored Value( :x1 ), :x2, :x3 )}
\]

Count

Creates a list of values beginning with the from value and ending with the to value. The number of steps specifies the number of values in the list between and including the from and to values. Each value determined by the first three arguments of the count function occurs consecutively the number of times that you specify with the times argument. When the to value is reached, Count starts over at the from value.

Also, you can add the times argument with the insert button on the keyboard. This argument is one by default, but repeats the count process as many times as you specify, as illustrated by the Count4 column in the data table in Figure A.2. To add any argument to the Count function, highlight the argument preceding the one that you want to enter. Either type a comma or use the insert button on the Formula Editor keypad.

The columns in the data table below result from the following formulas:

- \(\text{Count (1, 9, 2)}\) gives Count 1
- \(\text{Count (1, 9, 3)}\) gives Count 2
- \(\text{Count (1, 9, 9)}\) gives Count 3
- \(\text{Count (1, 9, 3, 3)}\) gives Count 4
The **Count** function is useful for generating a column of grid values. For example, the following formulas create a square grid of increment `NRow()`. `NRow()` is the **Row** function that gives the total number of rows in the data table. `NRow()` also creates axes that range from –5 to 5:

\[
\text{Count}(-5, 5, \text{Root}(\ NRow()\ )); \\
\text{Count}(-5, 5, \text{Root}(\ NRow()\ ), \text{Root}(\ NRow()\ ));
\]

**Dif**

Returns the difference between the value of the first argument in the current row and its value in the row defined by the current row less the second argument. The default **Dif** is one, which you can change to any number. Note that `Dif(X, n)` gives the same result as `XRow() - XRow() - n` or as `XRow() - Lag(X, n)`. 

**Dim**

Returns a row vector with the dimensions of the current data table, a specified data table, or a matrix. The dimensions are the number of rows and the number of columns and are listed in that order.

**Lag**

Returns the value of the first argument in the row defined by the current row less the second argument. The default **Lag** is one, which you can change to any number. The value returned for any lag that identifies a row number less than one is missing. Note that `Lag(X, n)` gives the same result as the subscripted notation, `XRow() - n`.

**NRow**

Returns the total number of rows in the active data table.

**Row**

Returns the current row number when an expression is evaluated for that row. You can use `Row()` in any expression, including column name subscripts. The default subscript of a column name is `Row()` unless otherwise specified.
Subscript

Enables you to use a column’s value from a row other than the current row. After choosing Subscript from the list, enter a numeric expression into the subscript argument. Subscripts that evaluate to nonexistent row numbers produce missing values. Column names with no subscript refers to the current row. To remove a subscript, select the subscript and delete it. Then delete the missing box.

The formula $\text{Count}_{\text{Row}()} - \text{Count}_{\text{Row}()-1}$, where $\text{Row}()$ is the row number as described below, uses subscripts to calculate the difference between each pair of values from the column named Count. This result is the same as that given by the Dif() function. When $\text{Row}()$ is 1, the computation produces a missing value.

The formula below calculates a column called Fib, which contains the terms of the Fibonacci series (each value is the sum of the two preceding values in the calculated column).

$$
\begin{align*}
\text{If} & \left( \text{Row}() \leq 2 \Rightarrow 1 \\
\text{else} & \Rightarrow \text{Fib}_{\text{Row}()-1} + \text{Fib}_{\text{Row}()-2} \right)
\end{align*}
$$

It shows the use of subscripts to do recursive calculations. A recursive formula includes the name of the calculated column, subscripted such that it references only previously evaluated rows (rows 1 through $(i-1)$). The calculation of the Fibonacci series shown includes a conditional expression and a comparison. See the sections “Conditional Functions” and “Comparison Functions”.

Sequence

Produces an arithmetic sequence of numbers across the rows in a data table, where the start value, ending limit, and increment are specified as arguments.

Numeric Functions

In the JMP Formula Editor, you can create a formula that contains arithmetic operators that are commonly used in formulas. See the Scripting Guide for more information about syntax.

Abs

Returns a positive number of the same magnitude as the value of its argument. For example, $|5|$ and $|-5|$ both result in 5.

Ceiling

Returns the smallest integer greater than or equal to its argument. For example, Ceiling(2.3) results in 3, while Ceiling(-2.3) results in -2.
Floor
Returns the largest integer less than or equal to its argument. For example, \texttt{Floor(2.7)} results in 2, but \texttt{Floor(-0.5)} results in -1.

Integrate
Integrates an expression with respect to a scalar value, using the adaptive quadrature method from Gander and Gautschi (2000). For example, \texttt{Integrate( Exp( -x ), x, 0, . )} results in 0.99999999986846.

Modulo
Returns the remainder when the second argument is divided into the first. For example, \texttt{Modulo(6, 5)} results in 1.

Round
Rounds the first argument to the number of decimal places given by the second argument. For example, \texttt{Round(3.554, 2)} rounds to 3.55 and \texttt{Round(3.555, 2)} rounds to 3.56.

Transcendental Functions

In the JMP Formula Editor, you can create a formula that supports transcendental functions, such as logarithmic functions for any base, functions for combinatorial calculations, the Beta function, and several gamma functions. See the Scripting Guide for more information about syntax.

Exp
Raises $e$ to the power that you specify. Thus, \texttt{Exp(1)} = e.

ExpM1
Returns a more accurate calculation of $\texttt{Exp(x)} - 1$ when $x$ is very small.

Ln
Calculates the natural logarithm of $x$. 
Log and Log10
Calculates the natural logarithm (base $e$). To change the default base, highlight the argument and type a comma or click the Insert key on the Formula Editor keypad. The base appears and is editable. The Log argument can be any numeric expressions. The expression Log($e$) evaluates as 1, and Log(32,2) is 5. The Log10 function calculates the logarithm of base 10 only.

Log1P
Returns a more accurate calculation of Log(1+x) when $x$ is very small.

Squash
Computes the function $1 / (1 + e^x)$, where $x$ is any numeric column, variable, or expression.

Logist
Also known as Squish or Logistic, is an efficient computation of the function $1 / (1+e^{-x})$, where $x$ is any numeric column, variable, or expression.

Root (Square Root)
Calculates the root of its argument as specified by the index. Root initially shows with an index of 2. To change the index, highlight the index argument and enter the value that you want.

Factorial
Returns the product of all numbers 1 through the argument that you specify. For example, Factorial(5) evaluates as 120.

NChooseK
Returns the number of $n$ things taken $k$ at a time ($n$ select $k$) and is computed in the standard way using factorials, as $n! / (k!(n-k)!$). For example, NChooseK(5,2) evaluates as 10.

Beta
Adds the two parameter Beta function and is written terms of the Gamma function as:

$$B(m, n) = \frac{\Gamma(m)\Gamma(n)}{\Gamma(m + n)}$$

Gamma
Adds the Gamma function, denoted $\Gamma(i)$, and is defined as:
\[ \Gamma(i) = \int_0^{\infty} (x^{i-1})e^{-x} \, dx \]

Gamma with a single argument is the same as \texttt{Gamma}(x, \text{infinity}). The optional second argument changes the upper integer from infinity to the value that you enter. Other interesting gamma function relationships are

- for any \( \alpha > 1 \), \( \Gamma(\alpha) = (\alpha-1) \cdot \Gamma(\alpha-1) \)
- for any positive integer, \( n \), \( \Gamma(n) = (n-1)! \)
- \( \Gamma(0.5) = \) the square root of \( \pi \)

\textbf{LGamma}

Is the natural log of the result of the gamma function evaluation. You get the same result using the \texttt{Log} (natural log) function with the \texttt{Gamma} function. However, the \texttt{LGamma} function computes more efficiently than do the \texttt{Log} (natural log) and the \texttt{Gamma} functions together. \texttt{NChooseK} is implemented using \texttt{LGamma} functions. The result is not always an exact integer. If the result is close to an integer, it is rounded up using the \texttt{Floor} function.

\textbf{Digamma}

The logarithmic derivative of the \texttt{Gamma} function.

\textbf{Trigamma}

The derivative of the \texttt{Digamma} function, or the logarithmic second derivative of the \texttt{Gamma} function.

\textbf{Arrhenius}

Calculates the non-specific component of the Arrhenius relationship that is then multiplied by the activation energy in the Arrhenius equation.

\[ \frac{11604.5181215503}{T + 273.15} \]

\textbf{Arrhenius Inv}

The inverse of the Arrhenius function:

\[ \left( \frac{11604.5181215503}{y} \right) - 273.15 \]
**Logit**

Applies the logit transformation to the argument using:

\[
\text{logit}(p) = \log\left(\frac{p}{1-p}\right)
\]

**Logit Percent**

Calculates the logit as a percent for the argument.

\[
\text{LogitPct}(pct) = \log\left(\frac{\frac{pct}{100}}{1 - \frac{pct}{100}}\right)
\]

**Logist Percent**

Calculates the logistic as a percent for the argument.

\[
\text{LogisticPct}(x) = \frac{100}{1 + e^{-x}}
\]

**Scheffe Cubic**

Is used in fitting certain models. **Scheffe Cubic** \((X_1, X_2)\) is equivalent to \(X_1\cdot X_2 \cdot (X_1 - X_2)\).

**SbInv**

Johnson Sb inverse transformation. If argument is normal, the result is Johnson Sb.

**SbTrans**

Johnson Sb transformation from a doubly bound variable to a standard normal \((0, 1)\) distribution.

**SHASHInv**

Returns a transformation of a standard normal variable into a sinh-arcsinh (SHASH) distributed variable.

**SHASHTTrans**

Returns a transformation of a sinh-arcsinh (SHASH) distributed variable into a standard normal distributed variable.
Trigonometric Functions

In the JMP Formula Editor, you can create a formula that supports trigonometric functions, such as sine and cosine. JMP’s trigonometric functions expect all angle arguments in radians. See the Scripting Guide for more information about syntax.

Sine, Cosine, Tangent

The Sine and Cosine functions calculate the sine and cosine of their respective arguments given in radians. For example, the expression Sine(0) evaluates as 0, and Cosine(0) evaluates as 1. The tangent function calculates the tangent of an argument given in radians. The expression Tan(Pi()/4) evaluates as 1.

ArcSine, ArcCosine, ArcTangent

The ArcSine and ArcCosine functions return the inverse sine and inverse cosine of their respective arguments. The returned value is measured in radians. For example, both expressions ArcSine(1) and ArcCosine(0) evaluate as 1.57080. The ArcTangent function returns the inverse tangent of its argument. The returned value is measured in radians. The expression ArcTangent(1) evaluates as 0.78540 (=3.14159/4).
**SinH, CosH, TanH**

The **SinH** and **CosH** functions return the hyperbolic sine and hyperbolic cosine of their respective arguments. The expression **SinH(1)** evaluates as 1.175201, and **CosH(0)** evaluates as 1.0. The **TanH** function returns the hyperbolic tangent of its argument. The expression **TanH(1)** evaluates as 0.761594.

**ArcSinH, ArcCosH, ArcTanH**

The **ArcSinH** and **ArcCosH** functions return the inverse hyperbolic sine and inverse hyperbolic cosine of their respective arguments. The expression **ArcSinH(1)** evaluates as 0.881374, and **ArcCosH(1)** is 0. The **ArcTanH** function returns the inverse hyperbolic tangent of its argument. The expression **ArcTanH(0.5)** evaluates as 0.549306.

---

**Character Functions**

In the JMP Formula Editor, you can create a formula that accepts character arguments or returns character strings and converts the data type of a value from numeric to character, or character to numeric. When you create these formulas, note that:

- Character functions can result in either character or numeric data. If you calculate a data type different from the one specified, the data type of the computed column is automatically changed to match the result.
- Arguments that are literal character strings must be enclosed in quotation marks.

See the *Scripting Guide* for more information about syntax.

**Char**

Produces a character string that corresponds to the digits in its numeric argument. For example, **Char(1.123)** evaluates as 1.123. See the *Scripting Guide*.

**Collapse Whitespace**

Trims leading and trailing whitespace and replaces interior whitespace with single space. That is, if more than one white space character is present, the **Collapse Whitespace** command replaces the two spaces with one space.

**Concat**

Concatenates character strings to produce a new string with the function’s second character argument appended to the first. For example, "Dr." || " " || **name** produces a new string consisting of the title **Dr.** followed by a space and the contents of the **name** string.
Contains

Returns the numeric position within the first argument of the first instance of the second argument, if it exists. The second argument can contain one or more characters. If the second argument does not exist, Contains returns a zero. For example, Contains("Veronica Layman", "ron") evaluates as 3. Contains("Lillie Layman", "L") evaluates as 1. Contains("Lillie Layman", "Veronica") evaluates as 0. The third argument, offset, is optional. Offset is a numeric value that specifies the search starting position. Contains("Lillie Layman", "L", 5) evaluates as 8 as the search starts at the 5th position, skipping the first “L”. If offset is negative, Contains searches backward from offset from the end of the string.

Munger

Computes new character strings from existing strings by inserting or deleting characters. It can also produce substrings, calculate indices, and perform other tasks depending on how you specify its arguments. The Munger function treats uppercase and lowercase letters as different characters.

Text is a character expression. Munger applies the other three arguments to this string to compute a result.

Offset is a numeric expression indicating the starting position to search in the string. If Offset is greater than the position of the first instance of the find argument, the first instance is disregarded.

Find/Length is a character or numeric expression. Use a character string as search criterion, or use a positive integer to return that number of consecutive characters starting from the Offset position. If you specify a negative integer as the Length value, Munger returns all characters from the Offset through to the end of the string.

Replace (optional argument) can be a string or unspecified. If it is a string and the Find/Offset value is numeric, Munger replaces the search criterion with the Replace string to form the result. If the Find/Offset value is numeric and no string is specified, Munger calculates a substring. If the Find/Length value is a character string, Munger always returns the numeric offset, disregarding the Replace value if it exists. To insert the Replace argument, click any argument in the Munger function and then click the insert button. Press Delete or click the Delete button ( ) on the Formula Editor keypad to remove the Replace argument.

Lowercase, Uppercase

The Lowercase function converts any uppercase character found in its argument to the equivalent lowercase character. For example, Lowercase("VERONICA LAYMAN") evaluates as veronica layman. The Uppercase function converts any lowercase character found in its argument to the equivalent uppercase character. For example, Uppercase("Veronica Layman") evaluates as VERONICA LAYMAN.
Length
Calculate the length of its argument. For example, Length("Veronica") evaluates as 8. If the argument is
- a string, length returns the number of characters;
- a list, length returns the number of items in the list;
- a blob (binary object), the number of bytes.

Num
Produces a numeric value that corresponds to its character string argument when the character string consists of numbers only. If a character string contains a non-numeric value, the result is a missing value. For example, Num("1.123") evaluates as 1.123.

Substr
Extracts the characters that are the portion of the first argument. Begins at the position given by the second argument, and ends based on the number of characters specified in the third argument. The first argument can be either a character column or a literal value. The starting argument and the length argument can be numbers of expressions that evaluate to numbers. For example, to show the first name only, Substr("Veronica Layman", 10, 6) starts at position 10 and reads through position 15, which yields Layman.

If start is negative, Substr searches backward from start from the end of the string. If length is negative or absent, Substr returns a string that begins with start and continues to the end of the text string.

Substr can also be used with lists.

Titlecase
Converts the string to title case, that is, an initial uppercase character and subsequent lowercase characters. For example, Titlecase("Veronica layman") results in Veronica Layman.

Trim
Produces a new character string from its argument, removing any leading and trailing whitespace. The second argument determines if whitespace is removed from the left, the right, or both ends of the string. If no second argument is used, whitespace is removed from both ends. For example, Trim("john ") evaluates as john. Trim(" john ", both) also evaluates as john.
Word

Extracts the \( n \)th word from a character string. One or more spaces define where each word begins and ends unless the optional delimiters argument is specified. For example, \( \text{Word}(2, \text{"Veronica Layman"}) \) returns the word Layman.

To insert the delimiters argument, click any argument in the Word function and then click the insert button \( \text{\textbullet} \) on the Formula Editor keypad. Press Delete or click the Delete button \( \text{\textbullet} \) on the Formula Editor keypad to remove the delimiters argument. If you do not specify a delimiter, space is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate word.

Most special characters act as single delimiters. You can enter any character or set of characters to act as a word delimiter. For example, to extract the last name in the following example, use a comma and blank together as the delimiting characters and ask for the first word. \( \text{Word}(1, \text{"Layman, Veronica"}, \text{", ", ", "}) \) returns the word Layman.

Words

Extracts the words from text according to the delimiters listed in the optional second argument. The default delimiter is space. For example, \( \text{Words}(\text{"the quick brown fox"}) \) returns \{"the","quick","brown","fox"\}.

If you include a second argument, any and all characters in that argument are taken to be delimiters. For example, \( \text{Words}(\text{"Doe, Jane P."},\text{", ", ", ", "}) \) returns \{"Doe","Jane","P"\}.

To insert the delimiters argument, click any argument in the Words function and then click the insert button \( \text{\textbullet} \) on the Formula Editor keypad. Press Delete or click the Delete button \( \text{\textbullet} \) on the Formula Editor keypad to remove the delimiters argument. If you do not specify a delimiter, white space is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate word.

Left, Right

Returns a substring of the left-most or right-most \( n \) characters of the string \( \text{text} \), respectively. Both functions also work with lists.

Starts With, Ends With

Returns 1 if \( \text{whole} \) begins or ends with \( \text{part} \), respectively. Returns 0 otherwise. Both functions also work with lists.
**Item**

Is different than the **Word** function because of the way it treats word delimiters. If a delimiter is found multiple times, or you enter a delimiter with multiple characters, the **Word** function treats them as a single delimiter. The **Item** function uses each delimiter to define a new word position. To compare, suppose a name is of the form lastname, firstname. The delimiter is a comma followed by a blank, such as:

```
Item(2, "Layman, Veronica", ", ", )
Word(2, "Layman, Veronica", ", ", )
```

The **Item** function returns a missing value because it treats the comma and blank separately and finds nothing between them. The **Word** function treats the comma and blank as a single delimiter and finds **Veronica** as the second word.

If you do not specify a delimiter, white space (blank space) is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate item.

**Hex and Hex to Number**

Converts between hex and hex and numbers.

**Hex** returns the hexadecimal representation of its argument. If the argument is character (in quotes), then the result is a character string twice as long containing the hexadecimal codes for the character values. For example, **Hex("A")** returns the string 41.

If the argument is numeric and “integer” is specified, the Hex function returns an 8-hexadecimal-character representation of the integer returned. For example, **Hex(12, “integer”)** returns the string 0000000C.

**Hex to Number** converts hexadecimals to numbers.

See the **Scripting Guide**.

**Repeat**

Creates a string that is the first argument repeated the number of times specified by the second argument. The first argument can be either a character literal, a character variable, or a character expression. For example, **Repeat("Katie", 3)** creates **KatieKatieKatie**.

A third argument applies when **Repeat** is used in a JSL script to repeat a matrix. When the first argument is a matrix, the second argument is the rowwise repeat and the third argument is the columnwise repeat.

**Insert**

**Insert** inserts a new item into the *list or expression* at the given position. If position is not given, it is inserted at the end.
Reverse

Reverse reverses the characters in the string.

Substitute

The first argument is a string, the second is a pattern, and the third is a replacement string. Substitute finds all matches to the pattern in the string, and replaces them with the replacement string.

Regex

The first argument is the source string that Regex searches for a match to the pattern. The second argument is the pattern, in the form of a regular expression. The Formula Editor prompts you for these two required arguments.

Tip: For more information about using regular expressions, search the Internet for regular expression tutorial.

By default, Regex performs a case-sensitive search and returns the parts of the source string that match the pattern that you specified (or returns MISSING if the match fails). There are two optional arguments that you can add. You can type a third argument—the format—that specifies the string to return. If you choose, you can use regular expressions to specify replacement text in the returned string. If you specify the third argument, you can also specify IGNORECASE so that Regex ignores capitalization when searching the source string for a match.

Table A.1 Regex Examples

<table>
<thead>
<tr>
<th>Sample Regex function</th>
<th>String that is returned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Regex( &quot;@ q3 #&quot;, &quot;([a-z])([0-9])&quot; )</td>
<td>q3</td>
</tr>
<tr>
<td></td>
<td>The function is case sensitive, so q3 matches but Q3 would not.</td>
</tr>
<tr>
<td>Regex( &quot;@ Q3 #&quot;, &quot;([a-z])([0-9])&quot;, &quot;\0&quot;,IGNORECASE)</td>
<td>Q3</td>
</tr>
<tr>
<td></td>
<td>Although \0 is the default argument, it is required in this example so that IGNORECASE can be specified.</td>
</tr>
<tr>
<td>Regex( &quot;@ Q3 #&quot;, &quot;([a-z])([0-9])&quot;, &quot;\2\1&quot;,IGNORECASE)</td>
<td>3Q</td>
</tr>
</tbody>
</table>
Comparison Functions

In the JMP Formula Editor, you can create a formula that compares the values of two arguments by using the comparison function. Each comparison relationship evaluates as true or false based on numeric magnitudes or character rankings. A true relationship evaluates as one, and false evaluates as zero.

Comparisons are useful when you include them in conditional expressions, but they can also stand alone as numeric expressions if neither term in comparison is missing. A relational symbol’s arguments can be any two expressions. However, both arguments in a comparison function must be of the same data type. Also note that:

- JMP displays an error if you use a single “=” in a conditional where “==” is expected.
- The Formula Editor uses the International Utilities package when comparing character strings. This package contains different rankings for each international character set and takes diacritical marks into consideration.
- You should not use comparison operators to specifically compare to a missing value. Instead, use the Is Missing function to detect a missing value.

See the JSL Syntax Reference for more information about syntax.

- `<` Less than
- `>` Greater than
- `<=` Less than or equal to
- `>=` Greater than or equal to
- `==` Equal to
- `!=` Not equal to
- `a<b<=c` $b$ is greater than $a$ and less than or equal to $c$
- `a<=b<c` $b$ is greater than or equal to $a$ and less than $c$

Is Missing Returns a one (1) if the value of the argument for the current row is missing, and a zero if the value is not missing.
Conditional Functions

In the JMP Formula Editor, you can include conditional expressions (called *conditionals* for short) in your formulas. These expressions let you build a sequence of clauses paired with result expressions. Constructing a sequence of clauses is the way you conditionally assign values to cells in a calculated column. Conditionals follow these rules:

- When no clause is true, the Formula Editor evaluates the result expression that accompanies the else clause.
- All result expressions in a conditional expression must evaluate to the same data type.
- A missing term matches any data type.
- By definition, expressions that evaluate as zero are false.
- If an expression evaluates as missing, no clauses are executed and missing is returned. All other numeric expressions are true.

See the *Scripting Guide* and the *JSL Syntax Reference* for more information about syntax.

Use the insert and delete clause buttons on the Formula Editor panel to expand the expression. For maximum efficiency, list the most frequently evaluated clause and result pairs first in the sequence.

**Note:** *Interpolate, Step, For,* and *While* are most often used in conjunction with other commands to build a JSL script. You can use the Formula Editor to create and execute a script in that column, but this is not recommended because of dependencies and ambiguities that can result. Most often, scripts are stored as .jsl files, and can be saved with a data table as a table property. For more information about table properties, see “Table Panel in Data Tables”. For documentation of scripting commands, see the *JSL Syntax Reference*.

**If**

Shows a single *If* condition with a missing expression and a missing *then clause*. Highlight either *expr* or *then clause* and enter a value. For example, to calculate count as a percentage of total when total is not 0, enter the conditional expression (using columns called *count* and *total*) in Figure A.3.

**Figure A.3** A Conditional Expression

![Conditional Expression Diagram](image-url)
To add a new condition to the If conditional, highlight then clause and click the insert button (\(\text{Insert}\)) on the Formula Editor keypad. Initially, this changes the existing else condition to an expr clause. Click the insert button again to add an else clause. Highlighting then or else and repetitively clicking the insert button changes the else to expr or adds a new expr clause.

To delete a clause, select the then clause above it and press Delete or click the Delete button (\(\text{Delete}\)) on the Formula Editor keypad.

By definition, expressions that evaluate as zero are false. If an expression evaluates as missing, no clauses are executed and missing is returned. All other numeric expressions are true.

**Match**

Compares an expression to a list of clauses and returns the value of the resulting expression for the first matching clause encountered. You provide the matching expression only once and then give a match value for each clause.

After you select Match in the Formula Editor, a list appears with two options:

- Select Add Match Arguments from Data, and clauses that correspond to all of the levels in your data are added automatically. Alternatively, press Shift, select Conditional, and then select Match. In Figure A.4, the example on the left shows clauses that were added automatically.
- Select Don’t Add so that you can add each clause individually. In Figure A.4, the example on the right shows an empty clause, which you fill with the missing expressions.

**Figure A.4** Examples of Using the Match Function

automatically added Match arguments

![Match automatically added examples](image)

empty Match argument

![Match empty example](image)

In an automatically filled argument, you should highlight then clause, and then enter an expression. In an empty argument, you highlight either expr, value, or then clause, and then enter an expression. (Or, if you highlight an expression and click Match, the Formula Editor creates a new Match conditional, with the original highlighted expression as expr and nothing for the value and else clause.) Also, keep in mind that:

- **Match** evaluates faster and uses less memory than an equivalent If because the variable is evaluated only once for each row in the data table. The If condition must evaluate the variable at each If clause for each row until a clause evaluates as true. See “Comparison Functions”, for a comparison of Match and If conditionals.
• With **If** and **Match**, the Formula Editor searches down from the top of the sequence for the first true clause and evaluates the corresponding result expression. Subsequent true clauses are ignored.

In the following example, each value is assigned depending on the value of the *age* variable.

**Figure A.5** An Example of Using the Match Function

![Match Function Example](image)

**Note:** **Match** ignores trailing spaces and **If** does not.

Although **Match** returns missing for any missing values, you can also specifically match missing values.

**Choose**

**Choose** is a special case of **Match** in which the arguments of the condition are a sequence of integers starting at one. The value of **clause** replaces the match condition. An example of a **Choose** condition is shown in **Figure A.6**. With **Choose**, the Formula Editor goes directly to the correct choice clause and evaluates the result expression.

**Figure A.6** Example of a **Choose** Condition

![Choose Function Example](image)

When you highlight an expression and click **Choose**, the Formula Editor creates a new conditional expression with one **clause**. Use the insert ( któ ) and delete ( δ ) buttons on the keypad to add new clauses or remove unwanted clauses, as described previously for the **If** conditional.

**Choose** evaluates the **Choose** expression and goes immediately to the corresponding result expression to generate the returned value. With **Choose**, you provide a choosing expression that yields sequential integers starting at 1 only once, and then you give a choice for each integer in the sequence.
IfMax

Evaluates the first of each pair of arguments and returns the evaluation of the result expression (the second of each pair) associated with the maximum of the expressions. If more than one expression is the maximum, the first maximum is returned. If all expressions are missing and a final result is not specified, missing is returned. If all expressions are missing and a final result is specified, that final result is returned. The test expressions must evaluate to numeric values, but the result expressions can be anything.

IfMin

Evaluates the first of each pair of arguments and returns the evaluation of the result expression (the second of each pair) associated with the minimum of the expressions. If more than one expression is the minimum, the first minimum is returned. If all expressions are missing and a final result is not specified, missing is returned. If all expressions are missing and a final result is specified, that final result is returned. The test expressions must evaluate to numeric values, but the result expressions can be anything.

And &

Evaluates as 1 when both of its arguments are true. Otherwise, it evaluates as 0 (Figure A.9.) The formula in Figure A.7 labels Group 1 as drivers only if both comparisons are true.

Figure A.7 Creating an And Function

\[
\begin{align*}
\text{If} & \quad \\text{sex == "M" & age > 13} \quad \Rightarrow \text{"Group 1"} \\
\text{else} & \quad \quad \quad \quad \Rightarrow \text{"Group 2"}
\end{align*}
\]

Or |

Evaluates as 1 when either of its arguments is true. If both of its arguments are false, then the Or expression evaluates as 0 (Figure A.9.) The formula in Figure A.8 assigns males and all participants who are more than 13 years old to Group 1.

Figure A.8 Creating an Or Function

\[
\begin{align*}
\text{If} & \quad \\text{sex == "M" & age > 13} \quad \Rightarrow \text{"Group 1"} \\
\text{else} & \quad \quad \quad \quad \Rightarrow \text{"Group 2"}
\end{align*}
\]

The truth tables on the left in Figure A.9 illustrate the results of the And (&) and Or (|) functions when both arguments have nonmissing values that evaluate to true or false. The table on the right illustrates the result when either the left or right expression (call them a and b) or both have missing values.
Figure A.9 Evaluations of And and Or Expressions

<table>
<thead>
<tr>
<th>And &amp;</th>
<th>Or</th>
</tr>
</thead>
<tbody>
<tr>
<td>True</td>
<td>True</td>
</tr>
<tr>
<td>False</td>
<td>False</td>
</tr>
</tbody>
</table>

Not !

Evaluates as 1 when its argument is false. Otherwise, Not evaluates as 0. When you apply the Not function, use parentheses where necessary to avoid ambiguity. For example, !(weight==64) can be either true or false (either 1 or 0), but (!weight)==64 is always false (0) because Not can return only 0 or 1. Expressions such as !(weight==64) can also be entered as weight != 64.

Interpolate

Linearly interpolates the $y$-value between two points, $x1$, $y1$ and $x2$, $y2$ that corresponds to the arguments that you give. You can insert additional pairs of $x$, $y$ arguments with the Insert key. Interpolate finds the pair of $x$, $y$ points that correspond to the $x$-value and completes the interpolation.

Figure A.10 Examples of Interpolate

Step

Step is like Interpolate except that it returns the $y$-value corresponding to the greatest $x$-value less than or equal to the $x$ and $y$ arguments. That is, it finds the corresponding $y$ for a given $x$ from a step function rather than a linear fit between points. Like Interpolate, you can have as many $x$ and $y$ argument pairs as you want.

Figure A.11 Examples of Step
For

Repeats the statements in the body argument as long as the while condition is true. The init and next control the iterations.

While

Repeatedly tests the expr condition and executes the body until expr is no longer true.

Break, Continue

Break stops execution of a loop completely and continues to the statement following the loop. Continue ends the current iteration of a loop and begins the loop at the next iteration.

Both are used in For, While, and For Each Row loops.

Stop

Immediately stops a script that is running.

Return

Returns an expression value from a user-defined function.

### Probability Functions

In the JMP Formula Editor, you can build formulas that calculate probabilities and quantiles for statistical distributions including the beta, Chi-square, F, gamma, normal, Student’s t, and Weibull distributions. See the JSL Syntax Reference for more information about distribution parameterizations and function arguments.

**Beta Density**

For information about the syntax for the Beta Density function, see the JSL Syntax Reference.

**Beta Distribution**

For information about the syntax for the Beta Distribution function, see the JSL Syntax Reference.

**Beta Quantile**

For information about the syntax for the Beta Quantile function, see the JSL Syntax Reference.
Cauchy Density
For information about the syntax for the Cauchy Density function, see the JSL Syntax Reference.

Cauchy Distribution
For information about the syntax for the Cauchy Distribution function, see the JSL Syntax Reference.

Cauchy Quantile
For information about the syntax for the Cauchy Quantile function, see the JSL Syntax Reference.

ChiSquare Density
For information about the syntax for the ChiSquare Density function, see the JSL Syntax Reference.

ChiSquare Distribution
For information about the syntax for the ChiSquare Distribution function, see the JSL Syntax Reference.

ChiSquare Log CDistribution
For information about the syntax for the ChiSquare Log CDistribution function, see the JSL Syntax Reference.

ChiSquare Log Density
For information about the syntax for the ChiSquare Log Density function, see the JSL Syntax Reference.

ChiSquare Log Distribution
For information about the syntax for the ChiSquare Log Distribution function, see the JSL Syntax Reference.

ChiSquare Noncentrality
For information about the syntax for the ChiSquare Noncentrality function, see the JSL Syntax Reference.
ChiSquare Quantile
For information about the syntax for the ChiSquare Quantile function, see the JSL Syntax Reference.

Dunnett P Value
For information about the syntax for the Dunnett P Value function, see the JSL Syntax Reference.

Dunnett Quantile
For information about the syntax for the Dunnett Quantile function, see the JSL Syntax Reference.

Exp Density
For information about the syntax for the Exp Density function, see the JSL Syntax Reference.

Exp Distribution
For information about the syntax for the Exp Distribution function, see the JSL Syntax Reference.

Exp Quantile
For information about the syntax for the Exp Quantile function, see the JSL Syntax Reference.

F Density
For information about the syntax for the F Density function, see the JSL Syntax Reference.

F Distribution
For information about the syntax for the F Distribution function, see the JSL Syntax Reference.

F Log CDistribution
For information about the syntax for the F Log CDistribution function, see the JSL Syntax Reference.

F Log Density
For information about the syntax for the F Log Density function, see the JSL Syntax Reference.
F Log Distribution
For information about the syntax for the F Log Distribution function, see the JSL Syntax Reference.

F Noncentrality
For information about the syntax for the F Noncentrality function, see the JSL Syntax Reference.

F Power
For information about the syntax for the F Power function, see the JSL Syntax Reference.

F Quantile
For information about the syntax for the F Quantile function, see the JSL Syntax Reference.

F Sample Size
For information about the syntax for the F Sample Size function, see the JSL Syntax Reference.

Frechet Density
For information about the syntax for the Frechet Density function, see the JSL Syntax Reference.

Frechet Distribution
For information about the syntax for the Frechet Distribution function, see the JSL Syntax Reference.

Frechet Quantile
For information about the syntax for the Frechet Quantile function, see the JSL Syntax Reference.

Gamma Density
For information about the syntax for the Gamma Density function, see the JSL Syntax Reference.

Gamma Distribution
For information about the syntax for the Gamma Distribution function, see the JSL Syntax Reference.
**Gamma Log CDistribution**
For information about the syntax for the Gamma Log CDistribution function, see the *JSL Syntax Reference*.

**Gamma Log Density**
For information about the syntax for the Gamma Log Density function, see the *JSL Syntax Reference*.

**Gamma Log Distribution**
For information about the syntax for the Gamma Log Distribution function, see the *JSL Syntax Reference*.

**Gamma Quantile**
For information about the syntax for the Gamma Quantile function, see the *JSL Syntax Reference*.

**GenGamma Density**
For information about the syntax for the GenGamma Density function, see the *JSL Syntax Reference*.

**GenGamma Distribution**
For information about the syntax for the GenGamma Distribution function, see the *JSL Syntax Reference*.

**GenGamma Quantile**
For information about the syntax for the GenGamma Quantile function, see the *JSL Syntax Reference*.

**GLog Density**
For information about the syntax for the GLog Density function, see the *JSL Syntax Reference*.

**GLog Distribution**
For information about the syntax for the GLog Distribution function, see the *JSL Syntax Reference*.

**GLog Quantile**
For information about the syntax for the GLog Quantile function, see the *JSL Syntax Reference*. 
Johnson Sb Density
For information about the syntax for the Johnson Sb Density function, see the JSL Syntax Reference.

Johnson Sb Distribution
For information about the syntax for the Johnson Sb Distribution function, see the JSL Syntax Reference.

Johnson Sb Quantile
For information about the syntax for the Johnson Sb Quantile function, see the JSL Syntax Reference.

Johnson Sl Density
For information about the syntax for the Johnson Sl Density function, see the JSL Syntax Reference.

Johnson Sl Distribution
For information about the syntax for the Johnson Sl Distribution function, see the JSL Syntax Reference.

Johnson Sl Quantile
For information about the syntax for the Johnson Sl Quantile function, see the JSL Syntax Reference.

Johnson Su Density
For information about the syntax for the Johnson Su Density function, see the JSL Syntax Reference.

Johnson Su Distribution
For information about the syntax for the Johnson Su Distribution function, see the JSL Syntax Reference.

Johnson Su Quantile
For information about the syntax for the Johnson Su Quantile function, see the JSL Syntax Reference.
**LEV Density**
For information about the syntax for the Largest Extreme Value (LEV) Density function, see the *JSL Syntax Reference*.

**LEV Distribution**
For information about the syntax for the Largest Extreme Value (LEV) Distribution function, see the *JSL Syntax Reference*.

**LEV Quantile**
For information about the syntax for the Largest Extreme Value (LEV) Quantile function, see the *JSL Syntax Reference*.

**LogGenGamma Density**
For information about the syntax for the LogGenGamma Density function, see the *JSL Syntax Reference*.

**LogGenGamma Distribution**
For information about the syntax for the LogGenGamma Distribution function, see the *JSL Syntax Reference*.

**LogGenGammaQuantile**
For information about the syntax for the LogGenGamma Quantile function, see the *JSL Syntax Reference*.

**Logistic Density**
For information about the syntax for the Logistic Density function, see the *JSL Syntax Reference*.

**Logistic Distribution**
For information about the syntax for the Logistic Distribution function, see the *JSL Syntax Reference*.

**Logistic Quantile**
For information about the syntax for the Logistic Quantile function, see the *JSL Syntax Reference*. 
Loglogistic Density
For information about the syntax for the Loglogistic Density function, see the *JSL Syntax Reference*.

Loglogistic Distribution
For information about the syntax for the Loglogistic Distribution function, see the *JSL Syntax Reference*.

Loglogistic Quantile
For information about the syntax for the Loglogistic Quantile function, see the *JSL Syntax Reference*.

Lognormal Density
For information about the syntax for the Lognormal Density function, see the *JSL Syntax Reference*.

Lognormal Distribution
For information about the syntax for the Lognormal Distribution function, see the *JSL Syntax Reference*.

Lognormal Quantile
For information about the syntax for the Lognormal Quantile function, see the *JSL Syntax Reference*.

Normal Biv Distribution
For information about the syntax for the Normal Biv Distribution function, see the *JSL Syntax Reference*.

Normal Density
For information about the syntax for the Normal Density function, see the *JSL Syntax Reference*.

Normal Distribution
For information about the syntax for the Normal Distribution function, see the *JSL Syntax Reference*. 
Normal Log CDistribution
For information about the syntax for the Normal Log CDistribution function, see the JSL Syntax Reference.

Normal Log Density
For information about the syntax for the Normal Log Density function, see the JSL Syntax Reference.

Normal Log Distribution
For information about the syntax for the Normal Log Distribution function, see the JSL Syntax Reference.

Normal Mixture Density
For information about the syntax for the Normal Mixture Density function, see the JSL Syntax Reference.

Normal Mixture Distribution
For information about the syntax for the Normal Mixture Distribution function, see the JSL Syntax Reference.

Normal Mixture Quantile
For information about the syntax for the Normal Mixture Quantile function, see the JSL Syntax Reference.

Normal Quantile
For information about the syntax for the Normal Quantile function, see the JSL Syntax Reference.

SEV Density
For information about the syntax for the Smallest Extreme Value (SEV) Density function, see the JSL Syntax Reference.

SEV Distribution
For information about the syntax for the Smallest Extreme Value (SEV) Distribution function, see the JSL Syntax Reference.
SEV Quantile
For information about the syntax for the Smallest Extreme Value (SEV) Quantile function, see the JSL Syntax Reference.

SHASH Density
For information about the syntax for the SHASH Density function, see the JSL Syntax Reference.

SHASH Distribution
For information about the syntax for the SHASH Distribution function, see the JSL Syntax Reference.

SHASH Quantile
For information about the syntax for the SHASH Quantile function, see the JSL Syntax Reference.

t Density
For information about the syntax for the t Density function, see the JSL Syntax Reference.

t Distribution
For information about the syntax for the t Distribution function, see the JSL Syntax Reference.

t Log CDistribution
For information about the syntax for the t Log CDistribution function, see the JSL Syntax Reference.

t Log Density
For information about the syntax for the t Log Density function, see the JSL Syntax Reference.

t Log Distribution
For information about the syntax for the t Log Distribution function, see the JSL Syntax Reference.

t Noncentrality
For information about the syntax for the t Noncentrality function, see the JSL Syntax Reference.


**t Quantile**

For information about the syntax for the t Quantile function, see the *JSL Syntax Reference*.

**Tukey HSD P Value**

For information about the syntax for the Tukey HSD P Value function, see the *JSL Syntax Reference*.

**Tukey HSD Quantile**

For information about the syntax for the Tukey HSD Quantile function, see the *JSL Syntax Reference*.

**Weibull Density**

For information about the syntax for the Weibull Density function, see the *JSL Syntax Reference*.

**Weibull Distribution**

For information about the syntax for the Weibull Distribution function, see the *JSL Syntax Reference*.

**Weibull Quantile**

For information about the syntax for the Weibull Quantile function, see the *JSL Syntax Reference*.

---

### Discrete Probability Functions

In the JMP Formula Editor, you can build formulas that calculate probabilities and quantiles for statistical distributions including the binomial, beta binomial, negative binomial, poisson, gamma poisson, and hypergeometric distributions. See the *JSL Syntax Reference* for more information about distribution parameterizations and function arguments.

**Beta Binomial Distribution**

For information about the syntax for the Beta Binomial Distribution function, see the *JSL Syntax Reference*.

**Beta Binomial Probability**

For information about the syntax for the Beta Binomial Probability function, see the *JSL Syntax Reference*. 
Beta Binomial Quantile
For information about the syntax for the Beta Binomial Quantile function, see the JSL Syntax Reference.

Binomial Distribution
For information about the syntax for the Binomial Distribution function, see the JSL Syntax Reference.

Binomial Probability
For information about the syntax for the Binomial Probability function, see the JSL Syntax Reference.

Binomial Quantile
For information about the syntax for the Binomial Quantile function, see the JSL Syntax Reference.

Gamma Poisson Distribution
For information about the syntax for the Gamma Poisson Distribution function, see the JSL Syntax Reference.

Gamma Poisson Probability
For information about the syntax for the Gamma Poisson Probability function, see the JSL Syntax Reference.

Gamma Poisson Quantile
For information about the syntax for the Gamma Poisson Quantile function, see the JSL Syntax Reference.

Hypergeometric Distribution
For information about the syntax for the Hypergeometric Distribution function, see the JSL Syntax Reference.

Hypergeometric Probability
For information about the syntax for the Hypergeometric Probability function, see the JSL Syntax Reference.
Neg Binomial Distribution
For information about the syntax for the Neg Binomial Distribution function, see the JSL Syntax Reference.

Neg Binomial Probability
For information about the syntax for the Neg Binomial Probability function, see the JSL Syntax Reference.

Poisson Distribution
For information about the syntax for the Poisson Distribution function, see the JSL Syntax Reference.

Poisson Probability
For information about the syntax for the Poisson Probability function, see the JSL Syntax Reference.

Poisson Quantile
For information about the syntax for the Poisson Quantile function, see the JSL Syntax Reference.

Statistical Functions
In the JMP Formula Editor, there are two types of Statistical functions that you can use in a formula:

- The functions with names that have the prefix Col. These functions compute statistics for a column of numbers or expressions involving columns.
- The Mean, Std Dev, Number, Sum, Quantile, Maximum, Minimum, and N Missing functions. These functions evaluate across columns or arguments. The statistic is computed for each row across the series of arguments. You can click the Insert key ( ) on the Formula Editor keypad, or type a comma to add arguments to the functions that accept multiple arguments. When there are multiple contiguous arguments, select the function and the first argument, and then press Shift and click the last argument in the group. These functions then automatically show with the complete list.

Note: Missing values are ignored in statistical functions.

See the JSL Syntax Reference for more information about syntax.
Col Cumulative Sum

Returns the cumulative sum for the current row. Col Cumulative Sum supports By columns, which do not need to be sorted.

Col Mean

Calculates the mean (or arithmetic average) of the numeric values identified by its argument. The formula Col Mean(age) calculates the average of all nonmissing values in the age column.

Col Moving Average

Returns the moving average over a given interval based at the current row. Missing values are ignored.

Col Std Dev

Measures the spread around the mean of the distribution identified by its argument. In the normal distribution, about 68% of the distribution is within one standard deviation of the mean. 95% of the distribution is within two standard deviations of the mean. 99% of the distribution is within three standard deviations of the mean.

Col Number

Counts the number of nonmissing values in the column that you specify. A missing numeric value occurs when a cell has no assigned value or is the result of an invalid operation (such as division by zero). Missing values show on the spreadsheet as a missing value mark (•). Missing character values are null character strings. In formulas for row state columns, an excluded row state characteristic is treated as a missing value.

Col N Missing

Counts the number of missing values in the column that you specify. A missing numeric value occurs when a cell has no assigned value or is the result of an invalid operation (such as division by zero). Missing values show in the data grid with a missing value character (•). Missing character values are null character strings.

Col Sum

Computes the sum of the values in its numeric argument. Missing values are ignored.

Col Minimum and Col Maximum

Takes the minimum of its numeric arguments. Col Minimum ignores missing values. Col Maximum takes the maximum of a numeric column argument and ignores missing values.
**Col Quantile**

Computes the value at which a specific percentage of the values is less than or equal to that value. For example, the value calculated as the 50% quantile, also called the median, is greater than or equal to 50% of the data. Half of the data values are less than the 50th quantile.

The `Col Quantile` function’s quantile argument represents the quantile percentage divided by 100. The 25% quantile, also called the lower quartile, corresponds to \( p = 0.25 \), and the 75% quantile, called the upper quartile, corresponds to \( p = 0.75 \).

The Formula Editor computes a quantile for a column of \( n \) nonmissing values by arranging the values in ascending order. The subscripts of the sorted column values, \( y_1, y_2, \ldots, y_n \), represent the ranks in ascending order.

The \( p \)th quantile value is calculated using the formula \( p(n + 1) \), where \( p \) is the percent value and \( n \) is the total number of nonmissing values. If \( p(n+1) \) is an integer, then the quantile value is \( y_{p(n+1)} \). If \( p(n + 1) \) is not an integer, then the value is interpolated by assigning the integer part of the result to \( i \), assigning the fractional part to \( f \), and applying the formula \( (1 – f) y_i + (f) y_{i+1} \).

For example, suppose a column has values 2, 4, 6, 8, 10, 12, 14, 16, 18, and 20. The 50% quantile is calculated as \( 0.5(10 + 1) = 5.5 \).

Because the result is fractional, the 50% quantile value is interpolated as

\[
(1 – 0.5) x 10 + (0.5) x 12 = (0.5)10 + (0.5)12 = 6 + 5 = 11
\]

The following are example `ColQuantile` formulas:

- `ColQuantile(age, 1)` Calculates the maximum age.
- `ColQuantile(age, 0.75)` Calculates the upper quartile age.
- `ColQuantile(age, 0.5)` Calculates the median age.
- `ColQuantile(age, 0.25)` Calculates the lower quartile age.
- `ColQuantile(age, 0)` Calculates the minimum age.

The `ColQuantile` argument can be any expression that evaluates to a value between (and including) 0 and 1. For example, the first formula in Figure A.12 calculates quantile values of age in ascending order for each row. The column then contains the interpolated values of age in ascending order in the calculated column. The second formula lists the interpolated values of age in descending order.

**Figure A.12** Examples of the Quantile Function
Col Rank

Ranks each row’s value, from 1 for the lowest value to the number of non-missing columns for the highest value. Ties can be broken by reporting the average of the possible rankings, assigning the ranks in the order that they originally appear, giving both values the lowest possible rank, or arbitrarily. (JMP 12 used arbitrary tie breaking.) Distribution’s Normal Quantile output uses average tie breaking.

Col Standardize

Performs the usual standardization on its numeric expression. For each row \( i \),
\[
\text{Col Standardize}(\text{height}) = \frac{\text{height}_{\text{Row}(i)} - \text{Col Mean}(\text{Height})}{\text{Col Std Dev}(\text{Height})}.
\]

Mean

Calculates the arithmetic average of the nonmissing values in the list of arguments that you specify. The arguments can be constants, numbers, or expressions. The \textbf{Mean} function initially shows with a single argument. You add arguments with the insert button (\(\text{ Insert }\)) on the Formula Editor keypad or by typing a comma.

Std Dev

Computes standard deviation of the nonmissing values in the list of arguments that you specify. The arguments can be constants, numbers, or expressions. The \textbf{Std Dev} function initially shows with a single argument. You add arguments by clicking the insert button (\(\text{ Insert }\)) on the Formula Editor keypad or by typing a comma.

Number

Counts the number of nonmissing values in the list of arguments that you specify.

Sum

Returns the sum of the nonmissing values in the list of arguments that you specify.

Quantile

Calculates the quantile specified by the first argument for all the nonmissing values in the remaining list of arguments that you specify.
Summation ($\Sigma$)

Evaluates for an explicit range of values in a column, as given by the summation indices. This behavior is different from all other statistical functions (except Product), which always evaluate on every row. The Summation function uses the summation notation shown in Figure A.13. To calculate a sum, replace the missing body term with an expression containing the index variable $i$, or an index variable that you assign. Summation repeatedly evaluates the expression for $i = 1$, $i = 2$, through $i = \text{NRow}()$ and then adds the nonmissing results together to determine the final result.

You can replace NRow(), the number of rows in the active spreadsheet, and the index constant, $i$, with any expression appropriate for your formula. For example, the summation formula in Figure A.13 computes the total for each row of all revenue values for rows 1 through the current row number, filling the calculated column with the cumulative totals of the revenue column.

Figure A.13  Example of the Summation function

Product ($\Pi$)

Evaluates for an explicit range of values in a column, as given by the summation indices, as opposed to all other statistical functions (except Summation), which always evaluate on every row. Product uses the notation shown in the formula in Figure A.14. To calculate a product, replace the missing body term with an expression containing the index variable $j$. Product repeatedly evaluates the expression for $i = 1$, $i = 2$, through $i = n$ and multiplies the nonmissing results together to determine the final result.

You can replace NRow(), the number of rows in the active spreadsheet and the index constant, $i$, with any expression appropriate for your formula.

For example, the product example in Figure A.14 calculates $i!$ (each row number’s factorial).

Figure A.14  Examples of the Product Function
Minimum and Maximum
Return the minimum and maximum value, respectively, from the list of nonmissing arguments that you specify.

N Missing
Counts the number of missing values in the list of arguments that you specify.

SSQ
Returns the sum of squares of all elements.

Random Functions

In the JMP Formula Editor, you can create formulas that generate random numbers by effectively “rolling the dice” within the constraints of the specified distribution. Each time you click Apply in the Formula Editor window, these functions produce a new set of random numbers.

You can use the Random Reset function to set a random seed that enables you to reproduce a set of random numbers. The random number algorithms in JMP are sometimes refined, and therefore the results might not be consistent across different versions of JMP.

Note: Random numbers are generated using the Mersenne-Twister technique. This technique has a period length of $2^{19937} - 1$. For more information about the generators, see Matsumoto and Nishimura (1998). The new generators are verified to pass all the DIEHARD tests as documented in Marsaglia (1995).

See the JSL Syntax Reference for more information about function arguments. See the JSL Syntax Reference for more information about distribution parameterizations.

Random ChiSquare
Generates a column of random numbers from a Chi-Square distribution with specified degrees of freedom. The optional noncentrality parameter must be greater than or equal to 0. The noncentrality parameter is 0 by default. For more information about the parameterization of the Chi-Square distribution, see the JSL Syntax Reference.
Random F
Generates a column of random numbers from an F distribution with specified numerator
degrees of freedom and denominator degrees of freedom. The optional noncentrality
parameter must be greater than or equal to 0. The noncentrality parameter is 0 by default. For
more information about the parameterization of the F distribution, see the JSL Syntax
Reference.

Random Index
Returns a \( k \) by 1 matrix of random integers between 1 and \( n \) with no duplicates.

Random Uniform
Generates a column of random numbers from a uniform distribution. If no arguments are
specified, the minimum of the uniform distribution is 0 and the maximum is 1. This means
that any number between 0 and 1 is as likely to be generated as any other. The result is an
approximately even distribution. You can use the optional arguments to specify different
values for the minimum and maximum numbers of the uniform distribution.

Random Normal
Generates a column of random numbers from a normal distribution with specified mean and
standard deviation. If no arguments are specified, the normal distribution has mean of 0 and
standard deviation of 1. For more information about the parameterization of the normal
distribution, see the JSL Syntax Reference.

Random Normal Mixture
Returns a random number from a normal mixture distribution with the specified arguments.
For information about the syntax for the Random Normal Mixture function, see the JSL Syntax
Reference.

Random Exp
Generates a column of random numbers from an exponential distribution with lambda=1. You
can scale the exponential function to use a different lambda. For example, \( \text{Random Exp()} \times .1 \)
generates an exponential distribution for lambda=0.1. For more information about the
parameterization of the exponential distribution, see the JSL Syntax Reference.

Random Gamma
Generates a column of random numbers from a gamma distribution with specified shape and
scale parameters. The default value of the scale parameter is 1. When the scale parameter is 1,
the gamma distribution is equivalent to an exponential distribution. For more information
about the parameterization of the gamma distribution, see the JSL Syntax Reference.
Random GenGamma
Generates a column of random numbers from an extended generalized gamma distribution with specified location, scale, and shape parameters. If no arguments are specified, the generalized gamma distribution has location of 0, scale of 1, and shape of 0. For more information about the parameterization of the generalized gamma distribution, see the JSL Syntax Reference.

Random LogGenGamma
Generates a column of random numbers from a log generalized gamma distribution with specified location, scale, and shape parameters. If no arguments are specified, the extended generalized gamma distribution has location of 0, scale of 1, and shape of 0. For more information about the parameterization of the log generalized gamma distribution, see the JSL Syntax Reference.

Random Beta
Generates a column of random numbers from a beta distribution with two specified shape parameters and optional threshold and scale parameters. The default threshold is 0, and the default scale is 1. For more information about the parameterization of the beta distribution, see the JSL Syntax Reference.

Random Cauchy
Generates a column of random numbers from a Cauchy distribution with location parameter 0 and scale parameter 1. A Cauchy variate with location parameter alpha and scale parameter beta can be generated with the formula alpha+beta*Random Cauchy(). For more information about the parameterization of the Cauchy distribution, see the JSL Syntax Reference.

Random Category
Generates a column of random category assignments based on a set of probability and result expressions (for example, Random Category(.2, "A", .3, "B", .4, "C", "D");). A random uniform number is generated and compared to the probabilities to determine which result expression is returned.

Random Johnson Su
Generates a column of random numbers from a Johnson Su distribution with two specified shape parameters, a location parameter, and a scale parameter. For more information about the parameterization of the Johnson Su distribution, see the JSL Syntax Reference.
Random Johnson Sb
Generates a column of random numbers from a Johnson Sb distribution with two specified shape parameters, a location parameter, and a scale parameter. For more information about the parameterization of the Johnson Sb distribution, see the JSL Syntax Reference.

Random Johnson Sl
Generates a column of random numbers from a Johnson Sl distribution with two specified shape parameters, a location parameter, and an optional skewness parameter. The skewness parameter can be +1 for positive skew or -1 for negative skew. The default is +1. For more information about the parameterization of the Johnson Sl distribution, see the JSL Syntax Reference.

Random Seed State
Retrieves or restores the random seed state to or from a BLOB object.

Random Triangular
Generates a column of random numbers from a triangular distribution with specified minimum, maximum, and mode parameters. If you specify only one argument, it represents the mode and the triangular distribution is between 0 and 1. If you specify two arguments, they represent the mode and the maximum, respectively, and the triangular distribution is between 0 and the maximum. If you specify three arguments, they represent the minimum, the mode, and the maximum, respectively, and the triangular distribution is between the minimum and the maximum.

Random Integer
Generates a column of random numbers from a uniform distribution of integers. If you specify one argument, the integers are between 1 and the argument. If you specify two arguments, the integers are between and include the values of the two arguments.

Random Binomial
Generates a column of random numbers from a binomial distribution with specified parameters. The first argument is \( n \), the number of trials in a binomial experiment. The second argument is \( p \), the probability that the event of interest occurs. When \( n \) is 1, the binomial function generates a distribution of Bernoulli trials. For more information about the parameterization of the binomial distribution, see the JSL Syntax Reference.
Random Negative Binomial

Generates a column of random numbers from a negative binomial distribution with specified parameters. The first argument is \( r \), the number of successes of interest. The second argument is \( p \), the probability of success. The random variable of interest is the number of failures that precede the \( r \)th success. In contrast to the binomial variate, where the number of trials is fixed and the number of successes is variable, the negative binomial variate is for a fixed number of successes and a random number of trials. For more information about the parameterization of the negative binomial distribution, see the JSL Syntax Reference.

Random Beta Binomial

Generates a column of random numbers from a beta binomial distribution with specified parameters. The first argument is \( n \), the number of trials. The second argument is \( p \), the probability of success for each trial. The third argument is optional and represents the overdispersion parameter. The default overdispersion parameter is 0. For more information about the parameterization of the beta binomial distribution, see the JSL Syntax Reference.

Random Frechet

Generates a column of random numbers from a Fréchet distribution with specified location and scale parameters. If no arguments are specified, the Fréchet distribution has location of 0 and sigma of 1. For more information about the parameterization of the Fréchet distribution, see the JSL Syntax Reference.

Random Geometric

Generates a column of random numbers from a geometric distribution with specified probability parameter. The argument is the probability that a specific event occurs at any one trial. The random variable of interest is the number of trials until a specific event occurs for the first time.

Random Poisson

Generates a column of random numbers from a Poisson distribution with specified shape parameter. For more information about the parameterization of the Poisson distribution, see the JSL Syntax Reference.

Random Gamma Poisson

Generates a column of random numbers from a gamma Poisson distribution with specified shape and overdispersion parameters. If the second argument is not specified, the gamma Poisson distribution has an overdispersion of 1. For more information about the parameterization of the gamma Poisson distribution, see the JSL Syntax Reference.
Random Weibull

Generates a column of random numbers from a Weibull distribution with specified shape and scale parameters. If the second argument is not specified, the Weibull distribution has scale of 1. For more information about the parameterization of the Weibull distribution, see the JSL Syntax Reference.

Random Logistic

Generates a column of random numbers from a logistic distribution with specified location and scale parameters. If no arguments are specified, the logistic distribution has location of 0 and scale of 1. For more information about the parameterization of the logistic distribution, see the JSL Syntax Reference.

Random Loglogistic

Generates a column of random numbers from a loglogistic distribution with specified location and scale parameters. If no arguments are specified, the loglogistic distribution has location of 0 and scale of 1. For more information about the parameterization of the loglogistic distribution, see the JSL Syntax Reference.

Random Lognormal

Generates a column of random numbers from a lognormal distribution with specified location and scale parameters. If no arguments are specified, the lognormal distribution has location of 0 and scale of 1. For more information about the parameterization of the lognormal distribution, see the JSL Syntax Reference.

Random GLog

Generates a column of random numbers from a generalized logarithmic distribution with specified location, scale, and shape parameters. When the shape parameter is 0, the generalized logarithmic distribution is equivalent to a lognormal distribution. For more information about the parameterization of the generalized logarithmic distribution, see the JSL Syntax Reference.

Random Reset

Restarts the random number sequences with a seed that you specify.

Random LEV

Generates a column of random numbers from a largest extreme value (LEV) distribution with specified location and scale parameters. If no arguments are specified, the LEV distribution has location of 0 and scale of 1. For more information about the parameterization of the LEV distribution, see the JSL Syntax Reference.
Random SEV

Generates a column of random numbers from a smallest extreme value (SEV) distribution with specified location and scale parameters. If no arguments are specified, the SEV distribution has location of 0 and scale of 1. For more information about the parameterization of the SEV distribution, see the JSL Syntax Reference.

Random SHASH

Generates a column of random numbers from a sinh-arcsinh (SHASH) distribution with two specified shape parameters, a location parameter, and a scale parameter. For more information about the parameterization of the SHASH distribution, see the JSL Syntax Reference.

Random Shuffle

Generates a randomly ordered column of numbers from the numbers in the matrix argument.

Random t

Generates a column of random numbers from a $t$ distribution with specified degrees of freedom. The optional noncentrality argument may be negative or positive. The noncentrality parameter is 0 by default. For more information about the parameterization of the $t$ distribution, see the JSL Syntax Reference.

Col Shuffle

Selects a row number at random from the current data table. Each row number is selected only once. When Col Shuffle is used as a subscript, it returns a value selected at random from the column that serves as its argument. Each value from the original column is assigned only once as Col Shuffle’s result. For more information about the syntax for the Col Shuffle function, see the JSL Syntax Reference.

Resample Freq

Generates a random selection with replacement frequency counts, suitable for use in bootstrapping. For example, it supports a second Freq Column argument, enabling it to do bootstrap samples relating to a pre-existing frequency column specified in the second argument. Resample Freq() generates a 100% resample. ResampleFreq(rate) generates a rate frequency sample. Resample(rate, column) generates a sample that is calculated by the rate multiplied by the sum of the specified column. For more information about the syntax for the Resample Freq function, see the JSL Syntax Reference.
Date Time Functions

JMP stores dates and times in numeric columns using the macOS standard of the number of seconds since January 1, 1904. When a column has date values, you can assign a date format to that column by double-clicking a column name and selecting Date or Time from the Format menu. See “Numeric Format Options”.

See the JSL Syntax Reference for more information about syntax.

In Minutes, In Hours, In Days, In Weeks, In Years

Converts from the units of the function name to the equivalent number of seconds for the argument. The argument must be a number or numeric expression. For example, In Minutes(2) yields 120, and In Years(1) yields 31,557,600 (60 seconds * 60 minutes * 24 hours * 365.25 days).

Date DMY, Date MDY

Accepts numeric expressions for day, month, and year and return the associated JMP date. For example, Date DMY (20, 3, 1991) and Date MDY(3, 20, 1991) evaluate to 2,752,272,000.

Today

Returns the number of seconds between January 1, 1904 and the current date. For example, at midnight on March 20, 1991 (a Wednesday), the Today function returns 2752272000 (2,752,272,000 seconds) and continues counting. If you evaluate the Today function later in the day, it reflects the additional seconds.

Day, Month, Year

Returns the day of the month, the month (as a number from 1 to 12), a four-digit year, respectively. The argument for these functions is interpreted as a JMP date. For example, on March 20, 1991:

- Day(2752272000) returns the number 20.
- Month(2752272000) returns the number 3.
- Year(2752272000) returns the number 1991.

Quarter

Returns the annual quarter of a datetime value as an integer 1-4.
Hour, Minute, Second

Returns the hour, the minute, and the seconds of a date-time value, respectively. The argument for these functions is interpreted as a JMP date. For example, on March 20, 1991:

- Hour(2752572649) returns the number 11.
- Minute(2752572649) returns the number 30.
- Second(2752572649) returns the number 49.

Day of Week, Day of Year, Week of Year, Time of Day

The argument for these functions is a JMP date. Day Of Week returns a number from 1 to 7, where 1 represents Sunday. Day Of Year returns the number of days from the beginning of the year. Week Of Year returns a number from 1 to 52 based on the rule specified. Rule 1 (default) has weeks start on Sunday with the first Sunday being week 2 and week 1 is a partial week or empty; rule 2 has the first Sunday begins week 1 with any previous days being week 0; rule 3 returns the ISO week number where the week starts on Monday and week 1 is the first week of the year with four days in that year. With ISO weeks, it is possible for the first or last three days of the year to belong to the neighboring year’s week number. Time Of Day returns a number from 0 to 86399 (time of day in seconds). For example, on Wednesday, March 20, 1991:

- Day Of Week(2752272000) returns the number 4.
- Day Of Year(2752272000) returns the number 79.
- Week Of Year(2752272000) returns the number 12.
- Time Of Day(2752272000) returns the number 0.

Informat

The argument for the Informat function is a date character string. For example, Informat("03/20/1991") returns the appropriate JMP date value, 2752272000. JMP can read all the date formats except for Abbrev Date and Long Date.

Abbrev Date, Long Date, Short Date

The argument for these date functions is a JMP date. They return character strings that are the formatted representation of the argument. For example:

- Abbrev Date(2752272000) returns Wed, Mar 20,1991.
- Long Date(2752272000) returns Wednesday, March 20, 1991.
- Short Date(2752272000) returns 3/20/91.
Format

The first argument in the Format function is a JMP date. This function returns the character string representation of the date by the date format that you specify in the second argument, which is a quoted string. If you apply this formula to a numeric column, JMP automatically changes the column’s data type to character.

You can also supply a column for the first argument and leave the rest blank. The result is the formatted value of the column reference. This can be used to extract value labels of a column when the value labels are turned off.

MDYHMS

The argument of MDYHMS is a JMP date. This function shows all date and time fields, appending zeros as time fields if no time information is present. This is useful if a date column is formulated such that not all date information is displayed. The MDYHMS function can be used to see all available date and time information.

Date Increment

Adds 1 or more intervals to a starting datetime value. For example, Date Increment(Today(), "Day", 3) adds three days to the current date. Date Increment(Today(), "Year", 3) adds 3 years to the current date.

Date Difference

Returns the difference of two datetime values. The interval argument can be Second, Minute, Hour, Day, Week, Month, Quarter, Year. The alignment arguments are described here:

Start Used to count the number of times an interval starts.
Actual Used to count whole intervals.
Fractional Used to count fractional intervals.

For example, the following formula returns 207.890243055556, the number of days between the dates:

```JMP
Date Difference(
  01Jan2010:00:00:00,
  27Jul2010:21:21:57,
  "Day",
  "fractional"
);
```

The following formula returns 207, the number of completed days between the dates:

```JMP
Date Difference(
  01Jan2010:00:00:00,
```
Row State Functions

There are six characteristics that rows in a JMP data table can have: selected, hidden, excluded, labeled, colored, and marked. If you give rows one or more of these characteristics and then create row state data table columns, you can then create a formula that computes and saves row state conditions. (See “Column Properties in JMP”, and “Store Information in Row State Columns”.) This formula processes row state data just as it would process character and numeric data.

See the JSL Syntax Reference for more information about syntax.

**Note:** A row can be assigned any combination of row states; a row state column can have multiple row states as a value.

Table A.2 describes the type of argument each Row State function requires and what each returns.
Table A.2  Row State Functions

| Function Name     | Argument Type Required                  | What the Function Returns (Your Column Data Type Should be This Type)          |
|-------------------|-----------------------------------------|********************************************************************************|
| Row State         | none                                    | row state of current row                                                       |
| As Row State      | numeric                                 | all row states of current row                                                  |
| Combine States    | multiple row state arguments            | multiple row state assignments                                                 |
| Excluded State    | positive integer or zero                | row state-excluded or not excluded                                            |
| Hidden State      | positive integer or zero                | row state-hidden or not hidden                                                 |
| Labeled State     | positive integer or zero                | row state-labeled or not labeled                                               |
| Color State       | integer or color name or \{red, green, blue\} | row state color                                                               |
| Marker State      | integer or character                    | row state marker                                                              |
| Selected State    | positive integer or zero                | row state-selected or not selected                                             |
| Hue State         | integer                                 | row state hue                                                                 |
| Shade State       | integer 1-5                            | row state intensity                                                           |
| Excluded          | Row State() or row state column         | integer 0 (not excluded) or 1 (excluded)                                       |
| Hidden            | Row State() or row state column         | integer 0 (not hidden) or 1 (hidden)                                          |
| Labeled           | Row State() or row state column         | integer 0 (not labeled) or 1 (labeled)                                        |
| Color Of          | Row State() or row state column         | color map integer                                                             |
| Marker Of         | Row State() or row state column         | marker map integer                                                            |
| Selected          | Row State() or row state column         | integer 0 (not selected) or 1 (selected)                                      |
Row State

Returns the active row state condition of the current row as true or false. You can use this function to conveniently write conditional clauses that depend on the status of the current row. For example, Figure A.15 assigns a 1 to rows that are currently selected and labeled and 0 otherwise.

Figure A.15  Row State

As Row State

Converts a numeric argument to a row state or set of row state conditions. Row states are stored internally in JMP as a 16-bit number, with each bit assigned to represent one of the possible row states as illustrated in Figure A.3. For example, the binary representation of 1327 is 0000010100101111. As Row State(1327) would therefore set the row state as selected, excluded, hidden, labeled, with marker 2 and color 10.

Table A.3  Row States Stored as 16-Bit Numbers: Each Bit Represents a Row State

<table>
<thead>
<tr>
<th>Bit</th>
<th>Row State</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Not selected (0) or Selected (1)</td>
</tr>
<tr>
<td>1</td>
<td>Unexcluded (0) or Excluded (1)</td>
</tr>
<tr>
<td>2</td>
<td>Unhidden (0) or Hidden (1)</td>
</tr>
<tr>
<td>3</td>
<td>Unlabeled (0) or Labeled (1)</td>
</tr>
<tr>
<td>4-7</td>
<td>Marker</td>
</tr>
<tr>
<td>8-14</td>
<td>Color</td>
</tr>
</tbody>
</table>

Combine States

Generates a row state combination with two or more arguments. Use the insert button (agog) on the Formula Editor keypad or type a comma to add arguments to the Combine States function. The currently selected expression becomes the first argument when you select Combine States. Replace each argument with an expression that evaluates to a row state. This formula:
Combine States(
    Selected State( Modulo( Row(), 2 ) ),
    Labeled State( Modulo( Row() + 1, 2 ) ) );

alternately labels or selects each row in the calculated row state column. The Selected State and Labeled State functions are defined later in this section. Use the insert (↵) and delete (💨) buttons on the Formula Editor keypad to add more arguments or remove unwanted arguments.

If you include conflicting row states in a combination, the results are unpredictable.

Excluded State

Interprets a numeric argument as true or false. When an argument evaluates as true, the Excluded State function assigns the excluded condition as the value of the column for that row. For example, Excluded State(Modulo(Row(),2)) assigns the excluded row state as the value of the row state column for each odd numbered row.

Hidden State

Assigns the hidden row state condition when its argument is greater than zero. If the argument is zero, the value in the column for that row is not hidden.

Labeled State

Gives the labeled row state condition when its argument is greater than zero. If the argument is zero the row value in the column for that row is not labeled.

Color State

Returns the color from the JMP color map that corresponds to its integer argument. JMP colors are numbered 0 through 84. Zero maps to black.

Marker State

Returns markers from the JMP marker map that correspond to its integer argument. JMP markers are numbered 0 through 16. The formula Marker State(Row()) assigns all the row state markers in a repeating sequence determined by the current row number to the calculated row state column. A row state column can have multiple row states as a value.

Selected State

Gives the selected row state condition when its argument is greater than zero. If the argument is zero, the value in the column for that row is not selected.
Hue State

Returns the color from the JMP hue map that corresponds to its integer argument. JMP hues are numbered 0 through 11 but larger integers are treated as modulo 12. The **Hue State** function does not map to black, gray, or white. A hue of zero maps to red, and a hue of 11 maps to magenta. The formula in Figure A.16 assigns row state colors in a chromatic spread based on the value of \( z \). The **Hue State** function is used with a row state data type column.

**Figure A.16** Example of Hue State Function

\[
\text{Hue State} \left( \frac{z - \text{Col Quantile}(z, 0)}{\text{Col Quantile}(z, 1) - \text{Col Quantile}(z, 0)} \right) \cdot 12
\]

Shade State

Assigns five shade levels to a color or hue. A shade of –2 is darkest and shade of +2 is lightest. A shade of zero is a pure color. The formula in **Figure A.17** assigns shade values based on the value of \( z \).

**Figure A.17** Example of Shade State Function

\[
\text{Shade State} \left( \frac{z - \text{Col Quantile}(z, 0)}{\text{Col Quantile}(z, 1) - \text{Col Quantile}(z, 0)} \right) \cdot 5
\]

To assign all shades of all the colors in the colors palette, you need to use the **Hue State** and **Shade State** assignments together. The formula in **Figure A.18** uses the **Combine States** function described at the beginning of this section. The first argument in the **Combine States** function is the **Hue State** formula shown previously, and the second argument is the **Shade State** formula. In addition, the **Marker State** function with an argument of 2 assigns the X marker to each row, and the **Selected State** function with an argument of 1 selects each row.
Figure A.18  Combine States Example For Using Both Hue State and Row State

Excluded, Hidden, Labeled, and Selected

Accepts a row state expression argument (row state column or row state constant) that evaluates as either 1 or 0 (true or false). These characteristics are inactive by default. Often, the Row() function is the argument, which detects the active row state condition of each row. For example, in Figure A.19, the formula assigns 99 whenever a row is actively selected, and 0 otherwise. Note that this formula is used in a column that has a numeric data type.

Figure A.19  Example of a Formula Using the Selected Function

The example in Figure A.20 assigns row state conditions to a row state column. The formula for the row state column (in the column called x) checks to determine whether the active row state is either Hidden or Excluded, and if so, assigns the Labeled row state.

Figure A.20  Calculate Row State Information in a Row State Column
Assignment Functions

In the JMP Formula Editor, Assignment functions work in place. That is, the result returned by the operation (on the right of the operator) is stored in the argument on the left of the operator and replaces its current value.

Assignment statements are most often used in conjunction with other commands to build a JSL script. You can use the Formula Editor to create and execute a script in that column, but this is not recommended because of dependencies and ambiguities that can result. Most often, scripts are stored as .jsl files, and can be saved with a data table. See “Create and Save Scripts in Data Tables”. For more information about syntax, see the JSL Syntax Reference.

Note: The first argument of an assignment function must be capable of being assigned. This means you cannot have an assignment such as 3+=4, because 3 is a constant value that cannot be reassigned. You must first create a variable (a table variable or local variable) whose value is 3. (For more information about table variables, see “Use Data Table Variables”. For more information about local variables, see “Refer to Data Table Values in Formulas”). Then use that variable as the left-hand argument of the assignment function.

= (assign) Puts the value of b into a. For example (a=b).

+= (add to) Adds the value of b to a and puts the result back into a. For example, a+=b.

-= (subtract to) Subtracts the value of b and puts the result back into a. For example, a-=b.

*= (multiply to) Multiplies b with a and puts the result back into a. For example, a*=b.

/= (divide to) Divides b into a and puts the result back into a. For example, a/=b.

++ (post increment) Adds one (1) to a, in place, so that a++. For example, if the initial value of a is 4, the expression a++ changes a to 5.
-- (post decrement) Subtracts one (1) from \( a \), in place, so that \( a -- \). For example, if the initial value of \( a \) is 4, the expression \( a -- \) changes \( a \) to 3.

**Parametric Model Functions**

In the JMP Formula Editor, this category is a shortcut to create three parametric models that are linear functions of a set of window-selected columns.

**Linear Model, Interactions Model, Full Quadratic Model**

Selecting each of these opens a column selection box that lets you select one or more columns to be included in the model. The function then creates and populates the chosen model.

**Finance Functions**

In the JMP Formula Editor, you can use Finance functions to create formulas for calculating principal payments, interest rates, rates of return, and so on.

**Double Declining Balance**

Returns the depreciation of an asset for a specified period of time. The function uses the double-declining balance method or some other depreciation factor.

**Future Value**

Returns the future value of an investment that is based on periodic, constant payments and a constant interest rate.

**Interest Payment**

Returns the interest payment for a given period for an investment that is based on periodic, constant payments and a constant interest rate.

**Interest Rate**

Returns the interest rate per period of an annuity.

**Internal Rate of Return**

Returns the internal rate of return for a series of cash flows in the `values` argument.
Modified Internal Rate of Return
Returns the modified internal rate of return for a series of periodic cash flows. The cost of investment and the interest received on reinvested cash is included.

Net Present Value
Returns the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values).

Number of Periods
Returns the number of periods for an investment that is based on periodic, constant payments and a constant interest rate.

Payment
Returns the payment for a loan that is based on constant payments and a constant interest rate.

Present Value
Returns the present value of an investment.

Principal Payment
Returns the payment on the principal for a given period for an investment that is based on periodic, constant payments and a constant interest rate.

Straight Line Depreciation
Returns the straight-line depreciation of an asset for one period.

Sum Of Years Digits Depreciation
Returns the sum-of-years’ digits depreciation of an asset for a specified period.
This chapter contains technical details that apply to multiple platforms in JMP and to SAS integration.
Contents

JMP Features That Support Multithreading .................................................. 817
Conventions for Mapping JMP Attributes to SAS Extended Attributes ............. 818
JMP Features That Support Multithreading

Some features in JMP are coded to take advantage of multiple central processing units (CPUs) on a machine, allowing these features to run significantly faster. This process is called multithreading.

The following features support multithreading:

- Boosted Trees
- Bootstrap Forest
- Choice
- Covering Arrays
- Capability Analysis in Distribution
- Explore Outliers
- Explore Patterns
- Factor Analysis
- Fit Life by X
- Fit Model: Parametric Survival, Mixed Model, Generalized Regression, and Response Screening
- Functional Data Explorer
- Gaussian (Fast GASP and the use of Categorical variables are only in JMP Pro.)
- K Nearest Neighbors
- Latent Class Analysis
- Life Distribution
- Multivariate
- Neural (Some features are only in JMP Pro.)
- Nominal Logistic
- Nonlinear and Nonlinear Curve
- Normal Mixtures in Cluster Analysis
- Partial Least Squares (Some features are only in JMP Pro.)
- Partition
- Predictor Screening
- Principal Components
- Process Screening
- Profiler (Does not apply to Profilers launched from within other platforms.)
Conventions for Mapping JMP Attributes to SAS Extended Attributes

SAS extended attributes are metadata that you define in SAS code to import information such as table scripts, labels, length, and type. You associate the extended attributes with a data set or variable and define them in name-value pairs, such as

```
_JMP_TABLESCRIPTNAME_2="OnOpen".
```

This section provides information about SAS extended attributes and their corresponding JMP attributes.

### Table B.1 Table Attributes

<table>
<thead>
<tr>
<th>JMP Table Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Variable Count</td>
<td>_JMP_TABLEVARCOUNT</td>
<td>Numeric, 0</td>
<td>Count of table variables</td>
</tr>
<tr>
<td>Table Variable Name 1</td>
<td>_JMP_TABLEVARNAME_1</td>
<td>String</td>
<td>Name of the first table variable</td>
</tr>
<tr>
<td>Table Variable Value 1</td>
<td>_JMP_TABLEVARVALUE_1</td>
<td>String</td>
<td>Value of the first table variable</td>
</tr>
</tbody>
</table>
### Table B.1 Table Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Table Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Variable Name 2</td>
<td>_JMP_TABLEVARNAME_2</td>
<td>String</td>
<td>Name of the second table variable</td>
</tr>
<tr>
<td>Table Variable Value 2</td>
<td>_JMP_TABLEVARVALUE_2</td>
<td>String</td>
<td>Value of the second table variable</td>
</tr>
<tr>
<td>Table Variable Name n</td>
<td>_JMP_TABLEVARNAME_n</td>
<td>String</td>
<td>Name of the nth table variable</td>
</tr>
<tr>
<td>Table Variable Value n</td>
<td>_JMP_TABLEVARVALUE_n</td>
<td>String</td>
<td>Value of the nth table variable</td>
</tr>
<tr>
<td>Table Script Count</td>
<td>_JMP_TABLESCRIPTCOUNT</td>
<td>Numeric</td>
<td>Count of table scripts</td>
</tr>
<tr>
<td>Table Script Name 1</td>
<td>_JMP_TABLESCRIPTNAME_1</td>
<td>String</td>
<td>Name of the first table scripts</td>
</tr>
<tr>
<td>Table Script Value 1</td>
<td>_JMP_TABLESCRIPTVALUE_1</td>
<td>String</td>
<td>Value of the first table scripts</td>
</tr>
<tr>
<td>Table Script Name 2</td>
<td>_JMP_TABLESCRIPTNAME_2</td>
<td>String</td>
<td>Name of the second table script</td>
</tr>
<tr>
<td>Table Script Value 2</td>
<td>_JMP_TABLESCRIPTVALUE_2</td>
<td>String</td>
<td>Value of the second table script</td>
</tr>
<tr>
<td>Table Script Name n</td>
<td>_JMP_TABLESCRIPTNAME_n</td>
<td>String</td>
<td>Name of the table script n</td>
</tr>
<tr>
<td>Table Script Value n</td>
<td>_JMP_TABLESCRIPTVALUE_n</td>
<td>String</td>
<td>Value of table script n</td>
</tr>
<tr>
<td>Lock Data Table</td>
<td>_JMP_ISLOCKED</td>
<td>Boolean, 0</td>
<td>Locked table</td>
</tr>
<tr>
<td>Suppress Formula Eval</td>
<td>_JMP_SUPPRESSEVAL</td>
<td>Boolean, 0</td>
<td>Suppressed formula evaluation</td>
</tr>
<tr>
<td>Column Group Count</td>
<td>_JMP_COLGRPCOUNT</td>
<td>Numeric, 0</td>
<td>Number of column groups</td>
</tr>
</tbody>
</table>
### Table B.1 Table Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Table Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Group Name 1</td>
<td>_JMP_COLGRPNAME_1</td>
<td>String</td>
<td>Name of column group 1</td>
</tr>
<tr>
<td>Column Group Start Col 1</td>
<td>_JMP_COLGRPSTARTCOL_1</td>
<td>String</td>
<td>Name of first column in group 1</td>
</tr>
<tr>
<td>Column Group NCols 1</td>
<td>_JMP_COLGRPNCOLS_1</td>
<td>Numeric</td>
<td>Number of columns in group 1</td>
</tr>
<tr>
<td>Column Group Name 2</td>
<td>_JMP_COLGRPNAME_2</td>
<td>String</td>
<td>Name of column group 2</td>
</tr>
<tr>
<td>Column Group Start Col 2</td>
<td>_JMP_COLGRPSTARTCOL_2</td>
<td>String</td>
<td>Name of first column in group 2</td>
</tr>
<tr>
<td>Column Group NCols 2</td>
<td>_JMP_COLGRPNCOLS_2</td>
<td>Numeric</td>
<td>Number of columns in group 2</td>
</tr>
<tr>
<td>Column Group Name n</td>
<td><em>JMP_COLGRPNAME</em>_n</td>
<td>String</td>
<td>Name of column group _n</td>
</tr>
<tr>
<td>Column Group Start Col n</td>
<td><em>JMP_COLGRPSTARTCOL</em>_n</td>
<td>String</td>
<td>Name of first column in group _n</td>
</tr>
<tr>
<td>Column Group NCols n</td>
<td><em>JMP_COLGRPNCOLS</em>_n</td>
<td>Numeric</td>
<td>Number of columns in group _n</td>
</tr>
</tbody>
</table>

### Table B.2 Column Attributes

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Name</td>
<td>_JMP_COLNAME</td>
<td>String</td>
<td>Original column name in JMP</td>
</tr>
</tbody>
</table>
### Table B.2 Column Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Length</td>
<td>_JMP_DATALENGTH</td>
<td>Numeric, 0</td>
<td>Length of the data. For numeric types, the value can be 1, 2, 4, or 8. For character types, 0 (or negative) means variable length, positive values mean fixed-length.</td>
</tr>
<tr>
<td>Row State</td>
<td>_JMP_ISROWSTATE</td>
<td>Numeric, 0</td>
<td>0 = not row state, 1 = default row state for table, 2 = row state column</td>
</tr>
<tr>
<td>Label</td>
<td>_JMP_ISLABEL</td>
<td>Boolean, 0</td>
<td>Label column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Scroll Lock</td>
<td>_JMP_ISSCROLLLOCK</td>
<td>Boolean, 0</td>
<td>Scroll locked column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Hidden</td>
<td>_JMP_ISHIDDEN</td>
<td>Boolean, 0</td>
<td>Hidden column. 1 for yes. 0 for no</td>
</tr>
<tr>
<td>Excluded</td>
<td>_JMP_ISEXCLUDED</td>
<td>Boolean, 0</td>
<td>Excluded column. 1 for yes. 0 for no</td>
</tr>
<tr>
<td>Notes</td>
<td>_SAS_NOTES</td>
<td>String</td>
<td>Notes about the column</td>
</tr>
<tr>
<td>Modeling Type</td>
<td>_SAS_LEVEL</td>
<td>String</td>
<td>Valid values are Binary, Interval, Ordinal, Nominal, Unary. JMP maps Binary and Unary to Nominal and Interval to Continuous.</td>
</tr>
</tbody>
</table>
### Table B.2 Column Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preselect Role</td>
<td>_SAS_MININGROLE</td>
<td>String</td>
<td>Valid values are Assessment, Censor, Classification, Cost, Cross ID, Decision, Frequency, ID, Input, Key, Label, Prediction, Referrer, Rejected, Residual, Segment, Sequence, Target, Text, Text Location, Time ID, Treatment, Web Address, Weight. JMP maps Y to Target, X to Input, Freq to Frequency, and Weight to Weight.</td>
</tr>
<tr>
<td>Distribution</td>
<td>_SAS_DISTRIBUTION</td>
<td>String</td>
<td>Distribution type to fit for this column</td>
</tr>
<tr>
<td>Format Name</td>
<td>_JMP_FORMATNAME</td>
<td>String</td>
<td>Format of the column (such as Fixed Dec or Percent)</td>
</tr>
<tr>
<td>Format Width</td>
<td>_JMP_FORMATWIDTH</td>
<td>Numeric</td>
<td>Width of the column</td>
</tr>
<tr>
<td>Format Decimals</td>
<td>_JMP_FORMATDECIMALS</td>
<td>Numeric</td>
<td>Number of decimal places</td>
</tr>
<tr>
<td>Format Code</td>
<td>_JMP_FORMATCODE</td>
<td>String</td>
<td>Typically the currency code for currency formats</td>
</tr>
<tr>
<td>Use Thousands Separator</td>
<td>_JMP_USETHOUSANDSSEP</td>
<td>Boolean, 0</td>
<td>Include thousands separator. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Input Format</td>
<td>_JMP_INFORMAT</td>
<td>String</td>
<td>Input format (for date, time, or duration-formatted columns)</td>
</tr>
<tr>
<td>Formula</td>
<td>_JMP_FORMULA</td>
<td>String</td>
<td>Column formula</td>
</tr>
</tbody>
</table>
### Table B.2  Column Attributes  (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suppress Formula Eval</td>
<td>_JMP_SUPPRESSEVAL</td>
<td>Boolean, 0</td>
<td>Suppressed formula evaluation. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Lock</td>
<td>_JMP_ISLOCKED</td>
<td>Boolean, 0</td>
<td>Locked column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Range Check Code</td>
<td>_JMP_RANGECHECK_CODE</td>
<td>String</td>
<td>A code that identifies the type of range check. Examples are LE, LT, LTLT, !LT, and !LELE.</td>
</tr>
<tr>
<td>Range Check Low</td>
<td>_JMP_RANGECHECK_LOW</td>
<td>Numeric</td>
<td>First argument to range check</td>
</tr>
<tr>
<td>Range Check High</td>
<td>_JMP_RANGECHECK_HIGH</td>
<td>Numeric</td>
<td>Second optional argument to range check</td>
</tr>
<tr>
<td>List Check</td>
<td>_JMP_LISTCHECK</td>
<td>String</td>
<td>List check</td>
</tr>
<tr>
<td>Missing Value Codes</td>
<td>_JMP_MISSINGCODES</td>
<td>String</td>
<td>Values to be treated as missing</td>
</tr>
<tr>
<td>Value Label Count</td>
<td>_JMP_VALUELABEL_COUNT</td>
<td>Numeric</td>
<td>Count of value labels</td>
</tr>
<tr>
<td>Value Label Code</td>
<td>_JMP_VALUELABELCODE_1</td>
<td>String</td>
<td>Code for the value label (such as EQ, LT, LE, LTLT, and LELT.). Always EQ for character variables.</td>
</tr>
<tr>
<td>Value Label Lower Bound</td>
<td>_JMP_VALUELABELELLOW_1</td>
<td>Varies</td>
<td>The lower bound of a numeric range, or the only bound if the ranges is unbounded on one side. A string for character columns. Numeric for numeric columns.</td>
</tr>
</tbody>
</table>
Table B.2 Column Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value Label Upper Bound</td>
<td>_JMP_VALUELABELHIGH_1</td>
<td>Numeric</td>
<td>The upper bound of a numeric range. Not used for character value labels.</td>
</tr>
<tr>
<td>Value Label Display</td>
<td>_JMP_VALUELABELDISPLAY_1</td>
<td>String</td>
<td>The display string for this value label</td>
</tr>
<tr>
<td>Use Value Labels</td>
<td>_JMP_USEVALUELABELS</td>
<td>Boolean, 0</td>
<td>Uses value labels when displaying this column. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Value Scores</td>
<td>_JMP_VALUESCORES</td>
<td>String</td>
<td>Associates data values with numerical scores</td>
</tr>
<tr>
<td>Value Order</td>
<td>_JMP_VALUEORDER</td>
<td>String</td>
<td>The order of values for the column</td>
</tr>
<tr>
<td>Value Colors</td>
<td>_JMP_VALUECOLORS</td>
<td>String</td>
<td>Maps values to colors.</td>
</tr>
<tr>
<td>Color Gradient</td>
<td>_JMP_COLORGRADIENT</td>
<td>String</td>
<td>Maps values to a color gradient.</td>
</tr>
<tr>
<td>Color Cells</td>
<td>_JMP_COLORCELLS</td>
<td>Boolean, 0</td>
<td>Color cells of this column using the specified value colors or color gradient. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Axis</td>
<td>_JMP_AXIS</td>
<td>String</td>
<td>Axis definition</td>
</tr>
<tr>
<td>Coding</td>
<td>_JMP_CODING</td>
<td>String</td>
<td>Code a range of values to -1, 1 for modeling purposes</td>
</tr>
<tr>
<td>Mixture</td>
<td>_JMP_MIXTURE</td>
<td>String</td>
<td>Participation in a mixture of columns adding up to a value. The Mixture column property has numeric values (limits) and string values (L Pseudo Component and U Pseudo Component).</td>
</tr>
</tbody>
</table>
Table B.2 Column Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row Order Levels</td>
<td>_JMP_ROWORDER</td>
<td>Boolean, 0</td>
<td>Sort the column by occurrence rather than value. 1 for yes. 0 for no.</td>
</tr>
<tr>
<td>Spec Limits</td>
<td>_JMP_SPECLIMITS</td>
<td>String</td>
<td>Target value and upper and lower spec limits</td>
</tr>
<tr>
<td>Control Limits</td>
<td>_JMP_CONTROLLIMITS</td>
<td>String</td>
<td>Control limits for control chart type</td>
</tr>
<tr>
<td>Response Limits</td>
<td>_JMP_RESPONSELIMITS</td>
<td>String</td>
<td>Bounds on response’s acceptable range, used by profilers</td>
</tr>
<tr>
<td>Design Role</td>
<td>_JMP_DESIGNROLE</td>
<td>String</td>
<td>Role in a designed experiment</td>
</tr>
<tr>
<td>Factor Changes</td>
<td>_JMP_FACTORCHANGES</td>
<td>String</td>
<td>Difficulty of changing a factor, for DOE. Value values: Easy, Hard, Very Hard</td>
</tr>
<tr>
<td>Sigma</td>
<td>_JMP_SIGMA</td>
<td>String</td>
<td>Sigma for Control Charts</td>
</tr>
<tr>
<td>Units</td>
<td>_JMP_UNITS</td>
<td>String</td>
<td>Units for this variable; can be any string</td>
</tr>
<tr>
<td>Time Frequency</td>
<td>_JMP_TIMEFREQ</td>
<td>String</td>
<td>Numeric, Annual, Quarterly, Monthly, Weekly, Daily, Hourly, By Minutes, By Seconds</td>
</tr>
<tr>
<td>Map Role</td>
<td>_JMP_MAPROLE</td>
<td>String</td>
<td>Role in a map data set</td>
</tr>
<tr>
<td>Multiple Response</td>
<td>_JMP_MRSEP</td>
<td>String, ”,”</td>
<td>Separator for a multiple-response column.</td>
</tr>
<tr>
<td>Label Column</td>
<td>_JMP_LABELCOLUMN</td>
<td>Boolean, 0</td>
<td>Is this column a label column? 1 for yes. 0 for no.</td>
</tr>
</tbody>
</table>
### Table B.2  Column Attributes (Continued)

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expression Column</td>
<td>_JMP_ISEXPRESSIONCOLUMN</td>
<td>Boolean, 0</td>
<td>Is this column an expression column? 1 for yes. 0 for no.</td>
</tr>
</tbody>
</table>

### Table B.3  Custom Column Properties

<table>
<thead>
<tr>
<th>JMP Column Attribute</th>
<th>SAS Attribute Name</th>
<th>SAS Attribute Type and Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom Property Count</td>
<td>_JMP_CUSTCOLPROPCOUNT</td>
<td>Numeric, 0</td>
<td>Count of custom column property</td>
</tr>
<tr>
<td>Custom Property Name 1</td>
<td>_JMP_CUSTCOLPROPNAME_1</td>
<td>String</td>
<td>Name of the custom column property 1</td>
</tr>
<tr>
<td>Custom Property Value 1</td>
<td>_JMP_CUSTCOLPROPVALUE_1</td>
<td>String</td>
<td>Value of the custom column property 1</td>
</tr>
<tr>
<td>Custom Property Name 2</td>
<td>_JMP_CUSTCOLPROPNAME_2</td>
<td>String</td>
<td>Name of the custom column property 2</td>
</tr>
<tr>
<td>Custom Property Value 2</td>
<td>_JMP_CUSTCOLPROPVALUE_2</td>
<td>String</td>
<td>Value of the custom column property 2</td>
</tr>
<tr>
<td>Custom Property Name n</td>
<td>_JMP_CUSTCOLPROPNAME_n</td>
<td>String</td>
<td>Name of the custom column property n</td>
</tr>
<tr>
<td>Custom Property Value n</td>
<td>_JMP_CUSTCOLPROPVALUE_n</td>
<td>String</td>
<td>Value of the custom column property n</td>
</tr>
</tbody>
</table>
Conventions for Mapping JMP Attributes to SAS Extended Attributes
The following sources are referenced in *Using JMP*.


Appendix D

Technology License Notices

• Scintilla is Copyright © 1998–2017 by Neil Hodgson <neilh@scintilla.org>. All Rights Reserved.

Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

• Progress® Telerik® UI for WPF: Copyright © 2008-2019 Progress Software Corporation. All rights reserved. Usage of the included Progress® Telerik® UI for WPF outside of JMP is not permitted.

• ZLIB Compression Library is Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.

• Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.

• Packages is Copyright © 2009–2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- iODBC software is Copyright © 1995–2006, OpenLink Software Inc and Ke Jin (www.iodbc.org). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

- Neither the name of OpenLink Software Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- This program, “bzip2”, the associated library “libbzip2”, and all documentation, are Copyright © 1996–2019 Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

3. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.
4. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Julian Seward, jseward@acm.org

bzip2/libbzip2 version 1.0.8 of 13 July 2019


• MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.

• libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

– Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

– Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and / or other materials provided with the distribution.

– Neither the name of Florian Reuter nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar license but with different Copyright notices) all the files are:


Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization from him.

- Regarding the decompression algorithm used for UNIX files:


The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

- Snowball is Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS \"AS IS\" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

- Pako is Copyright © 2014–2017 by Vitaly Puzrin and Andrei Tuputcyn.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

- HDF5 (Hierarchical Data Format 5) Software Library and Utilities are Copyright 2006–2015 by The HDF Group. NCSA HDF5 (Hierarchical Data Format 5) Software Library and Utilities Copyright 1998-2006 by the Board of Trustees of the University of Illinois. All rights reserved. DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF GROUP AND THE CONTRIBUTORS “AS IS” WITH NO WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED. In no event shall The HDF Group or the Contributors be liable for any damages suffered by the users arising out of the use of this software, even if advised of the possibility of such damage.


Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

- Neither the name of Adobe Systems Incorporated nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
• **dmlc/xgboost** is Copyright © 2019 SAS Institute.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

• **libzip** is Copyright © 1999–2019 Dieter Baron and Thomas Klausner.

This file is part of libzip, a library to manipulate ZIP archives. The authors can be contacted at <libzip@nih.at>.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. The names of the authors may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHORS `AS IS` AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• **OpenNLP 1.5.3**, the pre-trained model (version 1.5 of en-parser-chunking.bin), and dmlc/xgboost Version .90 are licensed under the Apache License 2.0 are Copyright © January 2004 by Apache.org.

You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:
You must give any other recipients of the Work or Derivative Works a copy of this License; and

You must cause any modified files to carry prominent notices stating that You changed the files; and

You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

If the Work includes a “NOTICE” text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.

• LLVM is Copyright © 2003–2019 by the University of Illinois at Urbana-Champaign. Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

• clang is Copyright © 2007–2019 by the University of Illinois at Urbana-Champaign. Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF
ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

- lld is Copyright © 2011–2019 by the University of Illinois at Urbana-Champaign. Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

- libcurl is Copyright © 1996–2021, Daniel Stenberg, daniel@haxx.se, and many contributors, see the THANKS file. All rights reserved.

Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, provided that the above copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.

- On the Windows operating system, JMP utilizes the OpenBLAS library. OpenBLAS is licensed under the 3-clause BSD license. Full license text follows: Copyright © 2011-2015, The OpenBLAS Project

All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the OpenBLAS project nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OPENBLAS PROJECT OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.