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Learn about JMP

Documentation and Additional Resources

Learn about JMP documentation, such as book conventions, descriptions of each JMP 

document, the Help system, and where to find additional support.
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Formatting Conventions in JMP Documentation

These conventions help you relate written material to information that you see on your screen:

• Sample data table names, column names, pathnames, filenames, file extensions, and 

folders appear in Helvetica (or sans-serif online) font.

• Code appears in Lucida Sans Typewriter (or monospace online) font.

• Code output appears in Lucida Sans Typewriter italic (or monospace italic online) font 

and is indented farther than the preceding code.

• Helvetica bold formatting (or bold sans-serif online) indicates items that you select to 

complete a task:

– buttons

– check boxes

– commands

– list names that are selectable

– menus

– options

– tab names

– text boxes

• The following items appear in italics:

– words or phrases that are important or have definitions specific to JMP

– book titles

– variables

• Features that are for JMP Pro only are noted with the JMP Pro icon . For an overview 

of JMP Pro features, visit jmp.com/software/pro.

Note: Special information and limitations appear within a Note.

Tip: Helpful information appears within a Tip.
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JMP Help

JMP Help in the Help menu enables you to search for information about JMP features, 

statistical methods, and the JMP Scripting Language (or JSL). You can open JMP Help in 

several ways:

• Search and view JMP Help on Windows by selecting Help > JMP Help.

• On Windows, press the F1 key to open the Help system in the default browser.

• Get help on a specific part of a data table or report window. Select the Help tool  from 

the Tools menu and then click anywhere in a data table or report window to see the Help 

for that area.

• Within a JMP window, click the Help button.

Note: The JMP Help is available for users with Internet connections. Users without an Internet 

connection can search all books in a PDF file by selecting Help > JMP Documentation Library. 

See “JMP Documentation Library” for more information.

JMP Documentation Library

The Help system content is also available in one PDF file called JMP Documentation Library. 

Select Help > JMP Documentation Library to open the file. You can also download the 

Documentation PDF Files add-in if you prefer searching individual PDF files of each 

document in the JMP library. Download the available add-ins from community.jmp.com.

The following table describes the purpose and content of each document in the JMP library.

Document Title Document Purpose Document Content

Discovering JMP If you are not familiar 

with JMP, start here.

Introduces you to JMP and gets you 

started creating and analyzing data. Also 

learn how to share your results.

Using JMP Learn about JMP data 

tables and how to 

perform basic 

operations.

Covers general JMP concepts and 

features that span across all of JMP, 

including importing data, modifying 

columns properties, sorting data, and 

connecting to SAS.
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Basic Analysis Perform basic analysis 

using this document.

Describes these Analyze menu platforms:

• Distribution

• Fit Y by X

• Tabulate

• Text Explorer

Covers how to perform bivariate, 

one-way ANOVA, and contingency 

analyses through Analyze > Fit Y by X. 

How to approximate sampling 

distributions using bootstrapping and 

how to perform parametric resampling 

with the Simulate platform are also 

included.

Essential Graphing Find the ideal graph 

for your data.

Describes these Graph menu platforms:

• Graph Builder

• Scatterplot 3D

• Contour Plot

• Bubble Plot

• Parallel Plot

• Cell Plot

• Scatterplot Matrix

• Ternary Plot

• Treemap

• Chart

• Overlay Plot

The book also covers how to create 

background and custom maps.

Profilers Learn how to use 

interactive profiling 

tools, which enable you 

to view cross-sections 

of any response 

surface.

Covers all profilers listed in the Graph 

menu. Analyzing noise factors is 

included along with running simulations 

using random inputs.

Document Title Document Purpose Document Content
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Design of 

Experiments Guide

Learn how to design 

experiments and 

determine appropriate 

sample sizes.

Covers all topics in the DOE menu.

Fitting Linear Models Learn about Fit Model 

platform and many of 

its personalities.

Describes these personalities, all 

available within the Analyze menu Fit 

Model platform:

• Standard Least Squares

• Stepwise

• Generalized Regression

• Mixed Model

• Generalized Linear Mixed Model

• MANOVA

• Loglinear Variance

• Nominal Logistic

• Ordinal Logistic

• Generalized Linear Model

Document Title Document Purpose Document Content
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Predictive and 

Specialized Modeling

Learn about additional 

modeling techniques.

Describes these Analyze > Predictive 

Modeling menu platforms:

• Neural

• Partition

• Bootstrap Forest

• Boosted Tree

• K Nearest Neighbors

• Naive Bayes

• Support Vector Machines

• Model Comparison

• Model Screening

• Make Validation Column

• Formula Depot

Describes these Analyze > Specialized 

Modeling menu platforms:

• Fit Curve

• Nonlinear

• Functional Data Explorer

• Gaussian Process

• Time Series

• Matched Pairs

Describes these Analyze > Screening 

menu platforms:

• Explore Outliers

• Explore Missing Values

• Explore Patterns

• Response Screening

• Predictor Screening

• Association Analysis

• Process History Explorer

Document Title Document Purpose Document Content
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Multivariate 

Methods

Read about techniques 

for analyzing several 

variables 

simultaneously.

Describes these Analyze > Multivariate 

Methods menu platforms:

• Multivariate

• Principal Components

• Discriminant

• Partial Least Squares

• Multiple Correspondence Analysis

• Structural Equation Models

• Factor Analysis

• Multidimensional Scaling

• Multivariate Embedding

• Item Analysis

Describes these Analyze > Clustering 

menu platforms:

• Hierarchical Cluster

• K Means Cluster

• Normal Mixtures

• Latent Class Analysis

• Cluster Variables

Document Title Document Purpose Document Content
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Quality and Process 

Methods

Read about tools for 

evaluating and 

improving processes.

Describes these Analyze > Quality and 

Process menu platforms:

• Control Chart Builder and individual 

control charts

• Measurement Systems Analysis 

(EMP and Type 1 Gauge)

• Variability / Attribute Gauge Charts

• Process Screening

• Process Capability

• Model Driven Multivariate Control 

Chart

• Legacy Control Charts

• Pareto Plot

• Diagram

• Manage Limits

• OC Curves

Reliability and 

Survival Methods

Learn to evaluate and 

improve reliability in a 

product or system and 

analyze survival data 

for people and 

products.

Describes these Analyze > Reliability and 

Survival menu platforms:

• Life Distribution

• Fit Life by X

• Cumulative Damage

• Recurrence Analysis

• Degradation

• Repeated Measures Degradation

• Destructive Degradation

• Reliability Forecast

• Reliability Growth

• Reliability Block Diagram

• Repairable Systems Simulation

• Survival

• Fit Parametric Survival

• Fit Proportional Hazards

Document Title Document Purpose Document Content
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Consumer Research Learn about methods 

for studying consumer 

preferences and using 

that insight to create 

better products and 

services.

Describes these Analyze > Consumer 

Research menu platforms:

• Categorical

• Choice

• MaxDiff

• Uplift

• Multiple Factor Analysis

Genetics Learn about methods 

that are available in 

JMP to help you 

analyze your genetic 

data and use that data 

to simulate a breeding 

program to predict the 

optimum genetic 

crosses to make.

Describes these Analyze > Genetics menu 

platforms:

• Marker Statistics

• Marker Simulation

Scripting Guide Learn about taking 

advantage of the 

powerful JMP 

Scripting Language 

(JSL).

Covers a variety of topics, such as writing 

and debugging scripts, manipulating 

data tables, constructing display boxes, 

and creating JMP applications.

JSL Syntax Reference Read about many JSL 

functions on functions 

and their arguments, 

and messages that you 

send to objects and 

display boxes.

Includes syntax, examples, and notes for 

JSL commands.

Document Title Document Purpose Document Content
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Additional Resources for Learning JMP

In addition to reading JMP help, you can also learn about JMP using the following resources:

• “Search JMP”

• “JMP Tutorials”

• “Sample Data Tables”

• “Learn about Statistical and JSL Terms”

• “Learn JMP Tips and Tricks”

• “JMP Tooltips”

• “JMP User Community”

• “Free Online Statistical Thinking Course”

• “JMP New User Welcome Kit”

• “Statistics Knowledge Portal”

• “JMP Training”

• “JMP Books by Users”

• “The JMP Starter Window”

Search JMP

If you are not sure where to find a statistical procedure, do a search across JMP. Results are 

tailored to the window that you launch the search from, such as a data table or report.

1. Click Help > Search JMP. Or, press Ctrl+comma.

2. Enter your search text.

3. Click the result that contains the procedure that you want.

On the right, you can see a description and the location of the procedure.

4. Click the corresponding button to open or go to a result.

JMP Tutorials

You can access JMP tutorials by selecting Help > Tutorials.

If you are not familiar with JMP, start with the Beginners Tutorial. It steps you through the 

JMP interface and explains the basics of using JMP.

The rest of the tutorials help you with specific aspects of JMP, such as designing an experiment 

and comparing a sample mean to a constant.
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Sample Data Tables

All of the examples in the JMP documentation suite use sample data. Select Help > Sample 
Data Folder to open the sample data directory.

To view an alphabetized list of sample data tables or view sample data within categories, 

select Help > Sample Index.

Sample data tables are installed in the following directory:

On Windows: C:\Program Files\SAS\JMP\17\Samples\Data

On macOS: \Library\Application Support\JMP\17\Samples\Data

In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

To view examples using sample data, select Help > Sample Index and navigate to the Teaching 

Resources section.

Learn about Statistical and JSL Terms

For help with statistical terms, select Help > Statistics Index. For help with JSL scripting and 

examples, select Help > Scripting Index.

Statistics Index Provides definitions of statistical terms.

Scripting Index Lets you search for information about JSL functions, objects, and display 

boxes. You can also edit and run sample scripts from the Scripting Index and get help on 

the commands.

Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for 

using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select 

Help > Tip of the Day. Or, you can turn it off using the Preferences window.

JMP Tooltips

JMP provides descriptive tooltips (or hover labels) when you hover over items, such as the 

following:

• Menu or toolbar options

• Labels in graphs

• Text results in the report window (move your cursor in a circle to reveal)
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• Files or windows in the Home Window

• Code in the Script Editor

Tip: On Windows, you can hide tooltips in the JMP Preferences. Select File > Preferences > 
General and then deselect Show menu tips. This option is not available on macOS.

JMP User Community

The JMP User Community provides a range of options to help you learn more about JMP and 

connect with other JMP users. The learning library of one-page guides, tutorials, and demos is 

a good place to start. And you can continue your education by registering for a variety of JMP 

training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, 

and social networking groups.

To access JMP resources on the website, select Help > JMP on the Web > JMP User 
Community or visit https://community.jmp.com.

Free Online Statistical Thinking Course

Learn practical statistical skills in this free online course on topics such as exploratory data 

analysis, quality methods, and correlation and regression. The course consists of short videos, 

demonstrations, exercises, and more. Visit jmp.com/statisticalthinking.

JMP New User Welcome Kit

The JMP New User Welcome Kit is designed to help you quickly get comfortable with the 

basics of JMP. You’ll complete its thirty short demo videos and activities, build your 

confidence in using the software, and connect with the largest online community of JMP users 

in the world. Visit jmp.com/welcome.

Statistics Knowledge Portal

The Statistics Knowledge Portal combines concise statistical explanations with illuminating 

examples and graphics to help visitors establish a firm foundation upon which to build 

statistical skills. Visit jmp.com/skp.
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JMP Training

SAS offers training on a variety of topics led by a seasoned team of JMP experts. Public 

courses, live web courses, and on-site courses are available. You might also choose the online 

e-learning subscription to learn at your convenience. Visit jmp.com/training.

JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP 

website. Visit jmp.com/books.

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data 

analysis. Options are categorized and described, and you launch them by clicking a button. 

The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and 

File menus. The window also lists JMP Pro features and platforms.

• To open the JMP Starter window, select View (Window on macOS) > JMP Starter.

• To display the JMP Starter automatically when you open JMP on Windows, select File > 
Preferences > General, and then select JMP Starter from the Initial JMP Window list. On 

macOS, select JMP > Preferences > General > Initial JMP Starter Window.

JMP Technical Support

JMP technical support is provided by statisticians and engineers educated in SAS and JMP, 

many of whom have graduate degrees in statistics or other technical disciplines.

Many technical support options are provided at jmp.com/support, including the technical 

support phone number.
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Tools for Process and Product Improvement

Quality and Process Methods describes a number of methods and tools that are available in JMP 

to help you evaluate and improve quality and process performance:

• Control charts provide feedback on key variables and show when a process is in, or out of, 

statistical control. “Control Chart Builder” describes the JMP approach to creating control 

charts using an interactive control chart platform called Control Chart Builder.

• The Measurement Systems Analysis platform assesses the precision, consistency, and bias 

of a system. Before you can study a process, you need to make sure that you can accurately 

and precisely measure the process. If variation comes from the measurement itself, then 

you are not reliably learning about the process. Use this analysis to find out how your 

system is performing. See “Measurement Systems Analysis”.

• The Type 1 Gauge platform assesses whether a measurement system, or gauge, is 

repeatable. Specifically, the analysis determines if a measurement system can repeatedly 

measure a part and obtain measurements that are close to a known reference standard. See 

“Type 1 Gauge Analysis”.

• The Variability/Attribute Gauge Chart platform creates variability or attribute gauge 

charts. Variability charts analyze continuous measurements and reveal how your system is 

performing. Attribute charts analyze categorical measurements and show you measures of 

agreement across responses. You can also perform a gauge study to see measures of 

variation in your data. See “Variability Gauge Charts” and “Attribute Gauge Charts”.

• The Process Screening platform enables you to explore a large number of processes across 

time. The platform calculates control chart, process stability, and process capability 

metrics, and detects large process shifts. See “Process Screening”.

• The Process Capability platform measures the ability of a process to meet specification 

limits. You can compare process performance, summarized by process centering and 

variability, to specification limits. The platform calculates capability indices based on both 

long-term and short-term variation. The analysis helps identify the variation relative to the 

specifications; this enables you to achieve increasingly higher conformance values. See 

“Process Capability”.

• CUSUM charts enable you to make decisions based on the cumulative sum. These charts 

can detect small shifts in a process. See “CUSUM Control Charts”.

• Exponentially weighted moving average (EWMA) charts can also be used to detect small 

shifts in a process. See “EWMA Control Charts”.
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• When you need to monitor multiple process characteristics simultaneously, see 

“Multivariate Control Charts”.

• The Model Driven Multivariate Control Chart (MDMVCC) platform enables you to build a 

control chart based on principal components or partial least squares models. See “Model 

Driven Multivariate Control Charts”.

• “Legacy Control Charts” describes the older control chart platforms in JMP. Instead of 

using these platforms, you are encouraged to use the Control Chart Builder platform, as 

well as the new CUSUM and EWMA Control Chart platforms.

• The Pareto Plot platform shows the frequency of problems in a quality related process or 

operation. Pareto plots help you decide which problems to solve first by highlighting the 

frequency and severity of problems. See “Pareto Plots”.

• The Diagram platform constructs cause-and-effect diagrams, which organize the sources 

of a problem for brainstorming or as a preliminary analysis to identify variables for further 

experimentation. Once complete, further analysis can be done to identify the root cause of 

the problem. See “Cause-and-Effect Diagrams”.

• The Manage Spec Limits utility enables you to quickly add or edit many specification 

limits for several columns at once. See “Manage Limits”.

• The Operating Characteristic (OC) Curves utility enables you to construct OC curves for 

control charts and attribute acceptance sampling plans. See “Operating Characteristic 

Curves”.
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Create Control Charts Interactively

Use Control Chart Builder to create control charts of your process data. Control Chart Builder 

can be launched as an interactive workspace or from specific control chart menu options. In 

the interactive workspace, you select the variables that you want to chart and drag them into 

zones. JMP automatically chooses an appropriate chart type based on the data. You can 

quickly create another type of chart, or change the current settings for an existing chart.

A control chart is a graphical and analytic tool for monitoring process variation. The natural 

variation in a process can be quantified using a set of control limits. Control limits help 

distinguish common-cause variation from special-cause variation. Typically, action is taken to 

identify and eliminate special-cause variation. It is also important to quantify the 

common-cause variation in a process, as this determines the capability of a process.

Figure 3.1  Control Chart Builder Example
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Overview of Control Chart Builder

A control chart is a graphical and analytic tool for monitoring process variation and 

identifying special-cause variation in a process. Establishing control limits to filter out routine 

variation helps determine whether a process is stable and predictable. If the variation in a 

process is more than desired, the process can be adjusted to create higher quality output with 

potential cost savings.

All processes exhibit measurement variation as the process is monitored over time. There are 

two types of variation in process measurements:

• Routine or common-cause variation. Measurements from a stable process still exhibit 

random variation. When process measurements exhibit only common-cause variation, the 

measurements stay within expected limits.

• Abnormal or special-cause variation. Special-cause variation is indicated by patterns 

observed on the control chart. Examples include a shift in the process mean, points above 

or below the control limits, or measurements that trend up or down. These shifts in the 

process measurements can be caused by factors such as a broken tool or machine, 

equipment degradation, or changes to raw materials. A change or defect in the process is 

often identifiable by abnormal variation in the process measurements.

Control Chart Builder enables you to create several types of control charts including Shewhart 

and Rare Event control charts. Shewhart control charts are broadly classified into control 

charts for variables and control charts for attributes. Rare event charts are designed for events 

that occur infrequently. JMP provides a flexible, user-defined approach to building control 

charts. You can construct control charts in the following ways:

• Use the interactive Control Chart Builder workspace. When you drag a data column to the 

workspace, Control Chart Builder creates an appropriate chart based on the data type and 

sample size.

• Use the control chart menu options to build a specific control chart using a launch 

window.

Once an initial chart is created through either method above, use the menus and other options 

to change the type of chart, change the statistic on the chart, reformat the chart, or add 

additional charts.
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Example of Control Chart Builder

In this example, use Control Chart Builder interactively and through the launch window to 

investigate an increase in the number of defects in a production process. The launch window 

approach is convenient if you know which type of control chart you want to build.

Control Chart Builder Interactive Method

Use the interactive Control Chart Builder workspace to investigate the variability in the 

process data.

1. Select Help > Sample Data Folder and open Quality Control/Socket Thickness.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Thickness to the Y zone.

4. Drag Hour to the Subgroup zone (at bottom).

Figure 3.2  Control Charts for Socket Thickness

Looking at the Average chart, you can see that there are several points below the lower 

control limit of 7.788772. You want to see whether another variable might be contributing 

to the problem.

5. Drag Cavity into the Phase zone.

6. Click Done.
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Figure 3.3  Control Charts for Each Cavity

From the Average chart, you can conclude the following:

• There are differences between the cavities, indicating the need for separate control limits 

for each cavity.

• Cavity 1 is producing sockets with an average thickness above that of the other cavities. 

This indicates that further investigation of the differences between cavities is warranted.

• All of the cavities have points that are outside the control limits. Therefore, you should 

investigate the lack of control in the process for each cavity.

The Range chart for each cavity shows that the within-subgroup measurements are in control 

and are similar across cavities.

Control Chart Builder Launch Window Method

Use the XBar Control Chart launch window to obtain the same chart as Figure 3.3.

1. Select Help > Sample Data Folder and open Quality Control/Socket Thickness.jmp.

2. Select Analyze > Quality and Process > Control Chart > XBar Control Chart.

3. Select Thickness and click Y.

4. Select Hour and click Subgroup.

5. Select Cavity and click Phase.

6. Click OK.

You should see the same control chart that appears in Figure 3.3.
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Control Chart Types

Control Chart Builder enables you to create several types of control charts, including 

Shewhart Variable, Shewhart Attribute, and Rare Event charts.

• “Shewhart Control Charts for Variables”

• “Shewhart Control Charts for Attributes”

• “Rare Event Control Charts”

• “Summary of Control Chart Types”

Shewhart Control Charts for Variables

In Control Chart Builder, control charts for variables are classified according to the subgroup 

summary statistic plotted on the chart.

• XBar charts are a type of location chart that display subgroup means (averages).

• R charts are a type of dispersion chart that display subgroup ranges (maximum – 

minimum).

• S charts are a type of dispersion chart that display subgroup standard deviations.

• Individual Measurement charts are a type of location chart that display individual 

measurements.

• Run charts are a type of location chart that display individual measurements as a 

connected series of points.

• Presummarize charts display both subgroup means and standard deviations.

• Moving Range charts are a type of dispersion chart that display moving ranges of two 

successive measurements.

Note: If you remove a dispersion chart or turn off the preference Show Two Shewhart Charts 

in File > Preferences > Platforms > Control Chart Builder, you will see only the location chart. 

Any associated scripts will contain the JSL option Show Two Shewhart Charts set to off (0).

XBar, R, and S Charts

For quality characteristics measured on a continuous scale, a typical analysis shows both the 

process mean and its variability with a mean chart aligned above its corresponding R or S 

chart.
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Individual Measurement Charts

Individual Measurement charts displays individual measurements. Individual Measurement 

charts are appropriate when only one measurement is available for each sampling time point. 

If you are charting individual measurements, the individual measurement chart shows above 

its corresponding moving range chart. Moving Range charts displays moving ranges of two 

successive measurements.

Presummarize Charts

If your data consist of repeated measurements of the same process unit, you can combine 

these into one measurement for the unit. Pre-summarizing is not recommended unless the 

data contain repeated measurements on each process or measurement unit.

Presummarize summarizes the process column into sample means and/or standard 

deviations, based either on the sample size or sample label chosen. Then it charts the 

summarized data based on the options chosen in the window.

Levey-Jennings Charts

Levey-Jennings charts show a process mean with control limits based on a long-term sigma. 

The control limits are placed at 3s distance from the center line. The standard deviation, s, for 

the Levey-Jennings chart is calculated the same way standard deviation is in the Distribution 

platform.

Shewhart Control Charts for Attributes

In Control Chart Builder, you can create attribute charts, which are applicable for count data. 

Attribute charts are based on binomial and Poisson models. Because the counts are measured 

per subgroup, it is important when comparing multiple charts to determine whether you have 

a similar number of items in the subgroups between the charts. Attribute charts, like variables 

charts, are classified according to the subgroup sample statistic plotted on the chart.

Table 3.1   Attribute Chart Determination

Distribution Used to 
Calculate Sigma

Statistic Type: Proportion Statistic Type: Count

Binomial P chart, Laney P chart NP chart

Poisson U chart, Laney U chart C chart
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Control Chart Builder makes some decisions for you based on the variable selected. Once the 

basic chart is created, you can use the menus and other options to change the type, the 

statistic, and the format of the chart.

• P charts display the proportion of nonconforming (defective) items in subgroup samples, 

which can vary in size. Because each subgroup for a P chart consists of Ni items, and an 

item is judged as either conforming or nonconforming, the maximum number of 

nonconforming items in a subgroup is Ni.

• Laney P charts display the same information as a standard P chart, but the control limits 

are calculated using a moving range adjusted sigma. In a standard P chart, the control 

limits are computed using the binomial distribution. However, this distribution often 

underestimates the variance in the actual data and causes false alarms to be reported in the 

chart. Laney P charts address these issues. The Laney P chart is particularly useful when 

the subgroup size is very large.

• NP charts display the number of nonconforming (defective) items in subgroup samples. 

Because each subgroup for an NP chart consists of Ni items, and an item is judged as either 

conforming or nonconforming, the maximum number of nonconforming items in 

subgroup i is Ni.

• C charts display the number of nonconformities (defects) in a subgroup sample that 

usually, but does not necessarily, consists of one inspection unit.

• U charts display the number of nonconformities (defects) per unit in subgroup samples 

that can have a varying number of inspection units.

• Laney U charts display the same information as a standard U chart, but the control limits 

are calculated using a moving range adjusted sigma. In a standard U chart, the control 

limits are computed using the Poisson distribution. However, this distribution often 

underestimates the variance in the actual data and causes false alarms to be reported in the 

chart. Laney U charts address these issues. The Laney U chart is particularly useful when 

the subgroup size is very large.

Note: Generally there is no harm in using a Laney chart over standard P and U charts. If there 

is no overdispersion, the moving range sigma adjustment is close to 1, resulting in a chart that 

is equivalent to a standard chart. However, if there is overdispersion then the Laney charts are 

better for process control. Overdispersion occurs when there is greater variability in the data 

than is assumed by the distribution.
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Rare Event Control Charts

In Control Chart Builder, you can create a Rare Event chart, which is a control chart that 

provides information about a process where the data comes from rarely occurring events. 

Tracking processes that occur infrequently on a traditional control chart tend to be ineffective. 

Rare event charts were developed in response to the limitations of control charts in rare event 

scenarios. Control Chart Builder provides two types of rare event charts (G charts and T 

charts). The difference between a G chart and a T chart is the quantity used to measure 

distance between rare events. The G chart measures counts of events between incidents, 

whereas the T chart measures time intervals between incidents.

G charts

A G chart measures the number of events between rarely occurring errors or nonconforming 

incidents, and creates a chart of a process over time. Each point on the chart represents the 

number of units between occurrences of a relatively rare event. For example, in a production 

setting, where an item is produced daily, an unexpected line shutdown can occur. You can use 

a G chart to look at the number of units produced between line shutdowns.

When reading a G chart, the points above the upper control limit indicate that the number of 

events between errors has increased. If the number of events between rarely occurring errors 

or nonconforming incidents has increased, that is good. Therefore, a point flagged as out of 

control above the limits is generally considered a desirable effect when working with G charts.

T charts

A T chart measures the time intervals elapsed since the last event. Each point on the chart 

represents a number of time intervals that have passed since a prior occurrence of a rare event. 

A T chart can be used for numeric, nonnegative data, date/time data, and time-between data. 

Since a traditional plot of these data might contain many points at zero and an occasional 

point at one, using a T chart avoids flagging numerous points as out of control. The data 

points for a T chart in Control Chart Builder are restricted to integer values.

Table 3.2   Rare Event Chart Determination Based on Sigma

Distribution Used to Calculate 
Sigma

Chart Type

Negative Binomial G chart

Weibull T chart
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When reading a T chart, the points above the upper control limit indicate that the amount of 

time between events has increased. This means that the rate of adverse events has decreased. 

Therefore, a point flagged as out of control above the limits is generally considered a desirable 

effect when working with T charts.

Summary of Control Chart Types

The most common control charts are available in Control Chart Builder and in the platforms in 

the Analyze > Quality and Process > Control Chart menu. Use Control Chart Builder as your 

first choice to easily and quickly generate charts. JMP automatically chooses the appropriate 

chart type based on the data. Table 3.3 through Table 3.7 summarize the different control chart 

types.

Table 3.3  Variable Charts Without Grouping (X) Variable or Nonsummarized Data

Chart Types Control Chart Builder Options

Points > Statistic Limits > Sigma

Individual Individual Moving Range

Moving Range on Individual Moving Range Moving Range

Individual (limits computed 

on median moving range)

Individual Median Moving Range

Median Moving Range on 

Individual

Moving Range Median Moving Range

Run Chart Individual Moving Range

Levey Jennings Individual Levey Jennings

Table 3.4  Variable Charts with Grouping (X) Variables or Summarized Data

Chart Types Control Chart Builder Options

Points > Statistic Limits > Sigma

XBar (limits computed on 

range)

Average Range

XBar (limits computed on 

standard deviation)

Average Standard Deviation



42 Control Chart Builder Chapter 3
Control Chart Types Quality and Process Methods

R Range Range

S Standard Deviation Standard Deviation

Levey Jennings Average Levey Jennings or overall 

Standard Deviation

Table 3.5  Presummarize Charts

Chart Types Control Chart Builder Options

Points > Statistic Limits > Sigma

Individual on Group Means Average Moving Range

Individual on Group Means 

(limits computed on median 

moving range)

Average Median Moving Range

Individual on Group Std 

Devs

Standard Deviation Moving Range

Individual on Group Std 

Devs (limits computed on 

median moving range)

Standard Deviation Median Moving Range

Moving Range on Group 

Means

Moving Range on Means Moving Range

Median Moving Range on 

Group Means

Moving Range on Mean Median Moving Range

Moving Range on Group 

Std Devs

Moving Range on Std Dev Moving Range

Median Moving Range on 

Group Std Devs

Moving Range on Std Dev Median Moving Range

Table 3.4  Variable Charts with Grouping (X) Variables or Summarized Data (Continued)

Chart Types Control Chart Builder Options

Points > Statistic Limits > Sigma



Chapter 3 Control Chart Builder 43
Quality and Process Methods Launch Control Chart Builder

Launch Control Chart Builder

You can launch Control Chart Builder in the following two ways:

• If you are not sure what type of control chart is appropriate for your data, select Analyze > 
Quality and Process > Control Chart Builder. This method enables you to drag data 

columns to the workspace and Control Chart Builder creates an appropriate chart based 

on the data type and sample size. See “Control Chart Builder Interactive Workspace”.

• If you know which type of control chart is appropriate for your data, select the appropriate 

chart from the Analyze > Quality and Process > Control Chart submenu. This displays a 

control chart launch window. See “Launch Windows for Specific Control Charts”. There 

are control chart builder launch windows for the following control charts:

– IMR Control Chart

Table 3.6  Attribute Charts

Chart Types Control Chart Builder Options

Points > Statistic Limits > Sigma

P chart Proportion Binomial

NP chart Count Binomial

C chart Count Poisson

U chart Proportion Poisson

Laney P chart Proportion Binomial adjusted by a 

moving range sigma value

Laney U chart Proportion Poisson adjusted by a 

moving range sigma value

Table 3.7  Rare Event Charts

Chart Types Control Chart Builder Options

Points > Statistic Limits > Sigma

G chart Count Negative Binomial

T chart Count Weibull
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– XBar Control Chart

– Run Chart

– P Control Chart

– NP Control Chart

– C Control Chart

– U Control Chart

– Laney P Control Chart

– Laney U Control Chart

– Levey Jennings Control Chart

– IMR on Means Control Chart

– Three Way Control Chart

Note: The CUSUM Control Chart, EWMA, and Multivariate Control Charts launch in 

their own platforms instead of launching in Control Chart Builder, and are documented 

separately. See “CUSUM Control Charts”, “Multivariate Control Charts”, and “EWMA 

Control Charts”.

Once you click OK in a launch window, the Control Chart Builder window appears with the 

Control Panel hidden by default. All other options and features are the same.

Control Chart Builder Interactive Workspace

To begin creating a control chart interactively, drag variables from the Select Columns box 

into the zones. If you drop variables in the center, Control Chart Builder guesses where to put 

them based on whether the variables are continuous or categorical.



Chapter 3 Control Chart Builder 45
Quality and Process Methods Launch Control Chart Builder

Figure 3.4  Interactive Control Chart Builder Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

The Control Chart Builder workspace contains the following zones:

Y Assigns the process variable.

Label Assigns a sample label variable to uniquely label individual measurements. The labels 

are not sorted and appear on the horizontal axis in the same order they appear in the data 

table.

Subgroup Assigns subgroup variables. To define subgroup levels as a combination of 

multiple columns, add multiple variables to the Subgroup zone. When a subgroup 

variable is assigned, each point on the control chart corresponds to a summary statistic for 

all of the points in the subgroup.

Phase (Not available for Rare Event control charts.) Assigns phase variables. When a Phase 

variable is assigned, separate control limits are computed for each phase. See also 

“Example of an XBar and R Chart”.

The initial Control Chart Builder window contains the following buttons:

Undo Reverses the last change made to the window.

Start Over Returns the window to the default condition, removing all data, and clearing all 

zones.
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Done Hides the buttons and the Select Columns box and removes all drop zone outlines. In 

this presentation-friendly format, you can copy the graph to other programs. To restore 

the window to the interactive mode, click the Control Chart Builder red triangle and select 

Show Control Panel.

By Identifies the variable and produces a separate analysis for each value that appears in the 

column.

Shewhart Variables/Shewhart Attribute/Rare Event Enables you to select Shewhart 

Variables, Shewhart Attribute, or Rare Event control chart types. If you select an Attribute 

chart type, an n Trials box and zone appear on the chart.

n Trials (Available for Attribute charts.) Assigns a lot size for an attribute control chart.

New Y Chart Produces a copy of the current chart for every column selected in the Select 

Columns box. The new charts use the selected columns in the Y role.

Once you drag variables to the chart, other buttons and options appear at left that enable you 

to show, hide or switch items on the chart (Figure 3.7). Many of these functions (Points, Limits, 

Warnings, etc.) are the same as the functions available when you right-click the chart. See 

“Options Panel and Right-Click Chart Options”. For information about warnings and rules, 

see “Tests” and “Westgard Rules”.

Three Way Control Chart Enables you to produce a three way control chart for variable chart 

types. The subgroup size must be greater than one. The plotting statistic is based on 

subgroup averages, within-subgroup variation, or between-subgroup variation. The 

default set of three includes a presummarized chart of the averages using Moving Range 

limits, a Moving Range chart and a Range chart.

Event Chooser Allows the chart to respond in real time to selection changes. There are 

several standard groups of responses that are recognized and pre-scored (for example, 

pass/fail, yes/no, Likert Scales, conforming/non-conforming, and defective/non-defective). 

If you are analyzing results from a survey and want to focus solely on a specific sector of 

the results for one or more questions, you can make the selection on the screen. When you 

make the selection, the chart is scored again and replotted immediately. The levels selected 

in the Event Chooser are counted as events, and all other levels are counted as non-events.

The Event Chooser is available for attribute charts with response columns that have a 

modeling type of nominal or ordinal. If you want the Event Chooser to work on a numeric 

integer-valued nominal or ordinal response column, you must select the Use Event 

Chooser option from the Control Chart Builder red triangle menu. The Event Chooser 

does not appear for response columns with a modeling type of continuous.
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Launch Windows for Specific Control Charts

The options that appear in the launch windows for specific control charts vary depending on 

whether you are launching variable control charts or attribute control charts. You can access 

these launch windows through the Analyze > Quality and Process > Control Chart menu. 

These launch windows enable you to specify variables for a control chart in Control Chart 

Builder.

Launch Windows for Variable Control Charts

This section contains information about the launch windows for IMR, XBar, Run, Levey 

Jennings, IMR on Means, and Three Way Control Charts.

Figure 3.5  Launch Window for Variable Control Charts

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Y Assigns the process variables.

Subgroup (Not available for Run charts.) Assigns the subgroup variables. When a subgroup 

variable is assigned, each point on the control chart corresponds to a summary statistic for 

all of the points in the subgroup.

Label (Available only for IMR charts.) Assigns a sample label variable to uniquely label 

individual measurements. The labels are not sorted and appear on the horizontal axis in 

the same order they appear in the data table.

Note: If a subgroup size greater than one is specified by a Subgroup variable, a constant 

subgroup size, or the Set Subgroup Size command in a script, the Label variable is 

ignored.
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Phase (Not available for Run charts.) Assigns the phase variable. When a Phase variable is 

assigned, separate control limits are computed for each phase.

By Identifies a variable to produce a separate analysis for each value that appears in the 

column.

Sort by Subgroup (Available only for IMR charts.) Sorts all variables by the Subgroup 

variable.

Constant Subgroup Size (Available only for XBar and Three Way charts.) Specifies a 

number of observations that make up each subgroup. If the number of observations per 

subgroup is not constant, you should specify a column in the Subgroup role.

Note: If you specify a Subgroup variable, the platform ignores the setting for the Constant 

Subgroup Size option.

Dispersion Chart (Available only for XBar charts.) Specifies the type of dispersion chart that 

appears below the XBar chart. You can choose between no dispersion chart, a range chart 

(XBar & R), or a standard deviation chart (XBar & S).

Grouping Method (Available only for Three Way charts.) Specifies the statistic represented 

by the points on the first chart. The options are Mean and Standard Deviation. See 

“Statistic”.

Between Chart (Available only for Three Way Charts.) Specifies the method for computing 

the between sigma estimate. The options are Moving Range and Median Moving Range. 

See “Sigma” and “Statistical Details for Three Way Control Charts”.

Within Chart (Available only for Three Way Charts.) Specifies the method for computing the 

within sigma estimate. The options are Range and Standard Deviation. See “Sigma” and 

“Statistical Details for Three Way Control Charts”.
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Launch Windows for Attribute Control Charts

This section contains information about the launch windows for P, NP, C, U, Laney P, and 

Laney U Control Charts.

Figure 3.6  Launch Window for Attribute Control Charts

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Y, n Defective (Available only for P, NP, and Laney P control charts.) Assigns the process 

variables.

Y, n Defects (Available only for C, U, and Laney U control charts.) Assigns the process 

variables.

Subgroup Assigns the subgroup variables. When a subgroup variable is assigned, each point 

on the control chart corresponds to a summary statistic for all of the points in the 

subgroup.

n Trials Assigns the subgroup sample size.

Phase Assigns the phase variable. When a Phase variable is assigned, separate control limits 

are computed for each phase.

By Identifies a variable to produce a separate analysis for each value that appears in the 

column.
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Control Chart Builder Window

Use Control Chart Builder to construct control charts for process data. The analysis produces a 

chart that can be used to evaluate whether a process is in a state of statistical control. The 

report varies depending on which type of chart you select. Control charts update dynamically 

as data is added or changed in the data table. Figure 3.7 displays the Control Chart Builder 

window for the Bottle Tops.jmp sample data table.

To create the chart:

1. Select Help > Sample Data Folder and open Quality Control/Bottle Tops.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Status to the Y zone.

4. Drag Sample to the Subgroup zone (at bottom).

Figure 3.7  Control Chart Builder Window

You can drag other variables into the various zones to augment the analysis and use the 

“Control Chart Builder Options” to further examine the data. Some of the right-click chart 

options (for example, show or hide points, limits, warnings, and zones; select statistic and 

sigma options) also appear on the left hand side of the chart for easy access.

Control charts have the following characteristics:

• Each point plotted on the chart represents an individual process measurement or 

summary statistic. Subgroups should be chosen rationally, that is, they should be chosen to 

maximize the probability of seeing a true process signal between subgroups. Often, this 

center line UCL and LCL
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requires knowledge of the process to determine the most effective grouping strategy. See 

Wheeler (2004); Woodall and Adams (1998).

• The vertical axis of a control chart is scaled in the same units as the summary statistic.

• The horizontal axis of a control chart identifies the subgroup samples and is time ordered. 

Observing the process over time is important in assessing if the process is changing.

The green line is the center line, or the average of the data. The center line indicates the 

average (expected) value of the summary statistic when the process is in statistical control. 

Measurements should appear equally on both sides of the center line. If not, this is possible 

evidence that the process average is changing.

• The two red lines are the upper and lower control limits, labeled UCL and LCL. These 

limits give the range of variation to be expected in the summary statistic when the process 

is in statistical control. If the process is exhibiting only routine variation, then all the points 

should fall randomly in that range.

Note: To hide the lower control limits on dispersion, attribute, and rare event charts, 

deselect the Show Lower Limit option in the options panel. To change the default to 

always hide the lower control limits, deselect the Show Lower Control Limit preference in 

File > Preferences > Platforms > Control Chart Builder.

• A point outside the control limits signals the presence of a special cause of variation.

Options in the Control Chart Builder window create control charts that can be updated 

dynamically as samples are received and recorded or added to the data table. When a control 

chart signals abnormal variation, action should be taken to return the process to a state of 

statistical control if the process degraded. If the abnormal variation indicates an improvement 

in the process, the causes of the variation should be studied and implemented.

When you double-click the axes, the appropriate Axis Specification window appears for you 

to specify the format, axis values, number of ticks, gridline, reference lines, and other options 

to display.

Control Chart Builder Options

Control Chart Builder options appear in the red triangle menu or by right-clicking on a chart 

or axis. Some of the right-click chart options also appear on the bottom left hand side of the 

chart for easy access. You can also set preferences for many of the options in Control Chart 

Builder at File > Preferences > Platforms > Control Chart Builder.

• “Control Chart Builder Red Triangle Menu Options”

• “Options Panel and Right-Click Chart Options”

• “Control Chart Builder Right-Click Axis Options”
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Control Chart Builder Red Triangle Menu Options

The Control Chart Builder red triangle menu contains the following options:

Show Control Panel Shows or hides the following elements:

– buttons

– the Select Columns box

– the drop zone borders

– check boxes and drop-down menus

Show Limit Summaries Shows or hides the Limit Summaries report. This report shows the 

control limits (LCL and UCL), the center line (Avg), the Points and Limits plotted, and the 

Sample Size for the chart. Sample size is not shown for rare event charts.

Show Capability (Available only for Shewhart Variables charts that have specification 

limits.) Shows or hides the Process Capability Analysis report. Since the report is part of 

the Limit Summaries report, the Process Capability report appears only when the Show 

Limit Summaries option is selected. For more information, see “The Process Capability 

Report”. You can set preferences for many of the options in the Process Capability report 

in Control Chart Builder at File > Preferences > Platforms > Process Capability.

Note: Show Capability is not available if the response variable has no variation.

Show Alarm Report Shows or hides a report that contains information about out of control 

samples. The report reflects failures for currently enabled tests in each chart and updates 

automatically as different tests are enabled and disabled and as data and row states 

change. A second table lists the currently enabled tests for each chart. The first table 

contains the following columns:

Position Indicates the numerical position of the chart, starting from the top of the report.

Total Samples Out of Control Counts the number of samples that failed at least one of 

the selected tests.

Alarm Rate The total number of samples out of control divided by the total number of 

nonmissing samples. This is also known as the Proportion Out of Control.

Note: The counts that contribute to the calculation of the alarm rate include excluded 

samples only if the Test Excluded Subgroups and the Show Excluded Region options 

are both selected.

Show Limit Labels Shows or hides labels for the limits in each chart. The limits are shown 

inside the right frame of the chart.
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Show Sigma Report (Available only for Shewhart Variables charts.) Shows or hides the 

Process Sigma Report, which is a table of sigma values. The Process Sigma Report contains 

the overall sample size, number of subgroups, sample mean, overall sigma, within sigma, 

and stability index. For three way control charts, the between-sigma and 

between-and-within sigma values are also shown. If a phase variable is specified, a set of 

values is given for each phase.

Note: The Process Sigma Report appears only if the Limit Summaries report is turned on.

Show Excluded Region Shows (on) or removes (off) the regions of the chart where samples 

have been excluded. When entirely excluded subgroups are shown on the location chart, 

they appear as dimmed points to indicate that they are excluded.

Caution: The Show Excluded Region option impacts the chart. Excluded samples are 

removed from the calculation of control limits, whether this option is on or off. Excluded 

samples are included in alarm rate calculations only if the Test Excluded Subgroups and 

the Show Excluded Region options are both selected.

Connect Thru Missing Connects points, as well as the lines for averages and limits, when 

some samples have missing values or excluded rows.

Set Subgroup Size (Not available if a subgroup variable is specified.) Sets a subgroup size. 

Missing values are taken into account when computing limits and sigma.

Note: If the Set Subgroup Size option is used, the Show Excluded Region option is turned 

on automatically.

Get Limits Retrieves the control limits that are stored in an open or saved data table.

Save Limits Saves the control limits in one of the following ways:

in Column Saves the control limits that appear on the chart as a column property in the 

existing data table for the response variable. If the limits are constant, LCL, Avg, and 

UCL values for each chart type in the report are saved. This option is not available with 

phase charts. In addition, the option has no effect if the sample sizes are not constant 

for each chart.

in New Table Saves the standard deviation and mean for each chart into a new data 

table. If the limits are constant, the LCL, Avg, UCL, Sample Size, and number of 

subgroups (N Subgroups) for each chart are saved as well. If there are phases, a new set 

of values is saved for each phase. There is a row for each statistic and a column for each 

Y variable. If there is a By variable, a table is created for each level of the By variable. 

Each table then contains a note that indicates the level that is associated with each table.
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in New Tall Table (Not available for Rare Event, Attribute, or Phase charts.) Saves the 

standard deviation, mean, and Sigma for each chart into a new data table. If the limits 

are constant, the LCL, Avg, UCL, Sample Size, and number of subgroups (N 

Subgroups) for each chart are saved as well. There is a row for each Y variable and a 

column for each statistic. A column for Sigma that can be used in the Process Screening 

platform is also saved. If there is a By variable, a table is created for each level of the By 

variable. Each table then contains a note that indicates the level that is associated with 

each table.

Save Summaries Creates a new data table containing such information as the sample label, 

sample sizes, statistic being plotted, center line, control limits, and any tests, warnings and 

failures. The specific statistics included in the table depend on the type of chart.

Graph Spacing Sets the amount of space between graph panels.

Graph Spacing Color Sets the color of the space between the graph panels.

Graph Spacing Transparency Sets the transparency level of the spacing between the graph 

panels. Must be between 0 and 1.

Graph Spacing Borders Sets the presence of the internal graph panel borders.

Include Missing Categories (Not available for attribute charts.) Enables the graph to collect 

rows with missing values in a categorical column, and displays the missing values on the 

graph as a separate category. If this option is disabled, all rows with a missing X value are 

removed from the calculations, in addition to being hidden from the graph.

This option is not available for continuous X variables or categorical Y variables because 

there is no compelling way to display the collected missing values on the relevant axes. By 

default, this option is enabled.

Note: If Include Missing Categories is enabled, capability analysis results in Control Chart 

Builder do not match those in the Process Capability platform if a categorical X variable 

has missing values.

Use Event Chooser (Available only for attribute charts with numeric non-continuous Y 

variables.) Categorizes ordinal numeric data and offers individual numeric-level modeling 

selections.

Alarm Script Enables you to write and run a script that indicates when the data fail special 

causes tests. See “Tests”. Results can be written to a file, written to the log or sent in an 

email. There is an option to include an explanation of why the test failed.

As an Alarm Script is invoked, the following variables are available, both in the issued 

script and in subsequent JSL scripts:

qc_col is the name of the column
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qc_test is the test that failed

qc_sample is the sample number

qc_phase is the label of the phase during which the failure occurred

See the Scripting Guide for more information about writing custom Alarm Scripts.

Note: Alarm scripts are not available in reports that use the Local Data Filter.

Sort by Row Order Sorts all subgroup and phase variables in the order in which the levels 

appear in the data table. This applies to all combinations of nested subgroup and phase 

variables.

K Sigma Sets the K value to be multiplied by sigma to form the control limit about the 

average. By default, K Sigma is set to 3.

Test Excluded Subgroups (Available only if the Show Excluded Region option is selected.) 

Includes (on) or excludes (off) entirely excluded subgroups in the computation of tests. 

When excluded subgroups are shown and the Text Excluded Subgroups option is not 

selected, the excluded subgroups are treated as missing values.

Note: For any test that relies on consecutive points (runs tests), an entirely excluded 

subgroup is treated as missing and counts of consecutive points are restarted.

Control Chart Dialog (Available only if the control chart is launched through a Control Chart 

launch window.) Opens the Control Chart launch window with the original settings that 

were used to create the control chart.

Fit to Window Specifies whether the graph is resized as you resize the JMP window. The 

default setting is Off, which prevents the graph from resizing. To always fit the graph 

inside the window, keep the setting at On. The Auto setting turns on stretching if there is 

only one report in the window and only one Y. Otherwise stretching is Off. There is also an 

option to maintain the aspect ratio.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.
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Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

• Column Switcher is available only for a single Y variable having two or fewer associated 

charts. Based on the selected chart type, only columns that are appropriate for the Y role 

are included in the Column Switcher column list.

• In Control Chart Builder, the Automatic Recalc option is turned on by default and cannot 

be turned off.

• When using the local data filter, you can deselect the Show Excluded Region option for 

more focused exploration.

Options Panel and Right-Click Chart Options

In the Control Chart Builder report, the following options appear on the left hand side or 

when you right-click a chart. Some options appear in both locations.

Event Chooser (Available only for attribute charts with response columns that have a 

modeling type of nominal or ordinal.) Allows the chart to respond in real time to selection 

changes. See “Event Chooser”.

Points Provides the following options:

Statistic Changes the statistic plotted on the chart. See “Statistic”.

Individual Points Show or hides individual observations in a subgroup. Available only 

with a subgroup variable or Set Sample Size. This option is not available for Attribute 

chart types or Rare Event charts.

Box Plots (Available only for Shewhart Variables charts.) Shows or hides box plots on 

the chart.

Show Connect Line Shows connecting lines between the points.

Show Points Shows or hides the points on the chart.

Limits Provides the following options:

Sigma Specifies the method of computing sigma. See “Sigma”.

Zones (Available only for Variables and Attribute chart types.) Shows or hides the zones 

on the chart. There are three equal-width zones on either side of the mean. Zones are 

not drawn below the LCL or above the UCL. If the limits for a Variables chart are not 

centered around the mean, min(Avg-LCL,UCL-Avg)/3 is used as the width of each 

zone. The zones for an Attributes chart use a width of (UCL-Avg)/3.
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Shade Zones Shows or hides shading zones by ranges. Zone C is shaded green, zones A 

and B are shaded yellow, and beyond zone A is shaded red.

Spec Limits (Available only if the data table has a Spec Limits column property or if you 

specify Spec Limits using the Add Spec Limits option.) Shows or hides the specification 

limits on the chart. By default, the spec limits are shown if the Spec Limits column 

property has the Show as Graph Reference Lines option selected. See Using JMP for 

information about adding a Spec Limits column property.

Add Spec Limits (Available in the right-click menu.) Enables you to enter specification 

limits.

Set Control Limits (Available in the right-click menu.) Enables you to enter control limits 

for tests. After you click OK in the Set Control Limits window, the specified control 

limits are set uniformly across groups. Select this option again to remove the specified 

control limits.

Note: If you set limits using the Set Control Limits option and then perform an action 

that changes the chart type, the previously set limits are removed and the limits are 

recalculated using the methods associated with the new chart type. A chart type 

change could be caused by adding or removing variables or by making changes to the 

point statistic or sigma statistic.

Add Limits (Available in the right-click menu.) Specifies additional control limits to be 

plotted on the chart. These limits are not used in tests.

Show Upper Limit Shows or hides the upper control limit on the chart. If you hide the 

upper control limit on a chart, the Test Beyond Limits and Test 1 options do not flag 

points associated with the hidden upper control limit.

Show Lower Limit Shows or hides the lower control limit on the chart. If you hide the 

lower control limit on a chart, the Test Beyond Limits and Test 1 options do not flag 

points associated with the hidden lower control limit.

Show Center Line Shows or hides the center line on the chart.

Add Dispersion Chart (Available in the right-click menu.) Adds a dispersion chart to the 

chart area. Change the chart type with the Points options. A dispersion chart illustrates the 

variation in the data by plotting one of many forms of dispersion, including the range, 

standard deviation, or moving range. Available only for Variables chart types.

Note: You can customize the default dispersion chart type using the Dispersion Chart and 

Summarized Dispersion Chart preferences in File > Preferences > Platforms > Control 

Chart Builder.
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Set Subgroup Size (Available only if a subgroup variable is not already specified.) Sets a 

subgroup size. Missing values are taken into account when computing limits and sigma.

Warnings Provides the following options:

Customize Tests (Available in the right-click menu. Available only for Variables and 

Attribute chart types that are not Laney P or Laney U charts.) Enables you to design 

custom tests and select or deselect multiple tests at once. After the option is selected, 

the Customize Tests window appears for designing the tests. Select a test description, 

and enter the desired number (n) and label. You can save the settings to preferences 

and also restore the default settings.

Tests (Available only for Variables and Attribute chart types that are not Laney P or 

Laney U charts.) Enables you to select which statistical control tests to enable. For 

more information about tests, see “Tests”.

Note: Hover over a flagged point on the chart to see a description of the test that failed.

Westgard Rules (Available only for Variables and Attribute chart types that are not 

Laney P or Laney U charts.) Specifies the set of Westgard statistical control tests that 

are enabled. Because Westgard rules are based on sigma and not the zones, they can be 

computed without regard to constant sample size. For more information about tests, 

see “Westgard Rules”.

Test Beyond Limits (Called Test 15 in JMP.) Enables the test for any points beyond the 

control limits. These points are identified on the chart. This test works on all charts 

with limits, regardless of the sample size being equal.

Note: If you hide the upper or lower control limits, the Test Beyond Limits option does 

not flag points that are beyond limits that are not shown on the control chart.

Remove Graph (Available in the right-click menu.) Removes the control chart.

Remove Location Chart (Available only if you right-click a location chart.) Removes the 

location chart from the report.

Remove Dispersion Chart (Available only if you right-click a dispersion chart.) Removes the 

dispersion chart from the report.

Note: For a description of the Rows, Graph, Customize, and Edit menus, see Using JMP.

Row Legend (Available only when there is one observation per marker.) Colors the rows 

according to a specified data column and inserts a legend next to the graph. This option is 

not available if there is a phase variable.
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Three Way Control Chart Enables you to produce a three way control chart for variable chart 

types. See “Three Way Control Chart”.

Switch to IMR Chart Moves the subgroup variable to the Label role to create an Individual 

and Moving Range chart. This option is available if there is only one specified subgroup 

variable, the chart is summarized, and the chart has a Shewhart Variables chart type.

Caution: The Undo command is not available for this option.

Statistic

You can change the statistic represented by the points on the chart. The options available 

depend on the chart type selected.

For Variables chart types, you can change the statistic represented by the points on the chart 

using the following options:

Individual Creates a chart where each point represents an individual value in the data table.

Average Creates a chart where each point represents the average of the values in a 

subgroup.

Range Creates a chart where each point represents the range of the values in a subgroup.

Standard Deviation Creates a chart where each point represents the standard deviation of 

the values in a subgroup.

Moving Range on Means Computes the difference in the range between two consecutive 

subgroup means.

Moving Range on Std Dev Computes the difference in the range between two consecutive 

subgroup standard deviations.

Moving Range Creates a chart where each point is the difference between two consecutive 

observations.

Note: The Average, Range, Standard Deviation, Moving Range on Means, and Moving Range 

on Std Dev methods appear only if a subgroup variable with a sample size greater than one is 

specified or a sample size is set.

For Attribute chart types, you can change the statistic represented by the points on the chart 

using the following options:

Proportion Creates a chart where each point represents the proportion of items in subgroup 

samples.
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Count Creates a chart where each point represents the number of items in subgroup 

samples.

For Rare Event chart types, the statistic represented by the points on the chart uses the Count 

option.

Sigma

You can change the method for computing sigma for the chart. The options available depend 

on the chart type selected.

For Variables chart types, you can use the following options:

Range Estimates sigma using the range of the data in a subgroup.

Standard Deviation Estimates sigma using the standard deviation of the data in a subgroup.

Moving Range Estimates sigma using the moving ranges. The moving range is the 

difference between two consecutive points.

Median Moving Range Estimates sigma using the median moving range, rather than the 

average moving range.

Levey-Jennings Estimates sigma using the standard deviation of all the observations. If your 

chart has phases, sigma is calculated for each phase separately.

For Attribute chart types, you can use the following options:

Binomial (P, NP) Estimates sigma using the binomial distribution model. The model 

indicates the number of successes in a sequence of experiments, where each experiment 

yields success with some probability. Selecting Binomial yields either a P or NP chart.

Poisson (C, U) Estimates sigma using the Poisson distribution model. The model indicates 

the number of events and the time at which these events occur in a given time interval. 

Selecting Poisson yields either a C or U chart.

Laney (P) Estimates sigma using the binomial distribution model, adjusted by a moving 

range sigma value.

Laney (U Estimates sigma using the Poisson distribution model, adjusted by a moving 

range sigma value.

For Rare Event chart types, you can use the following options:

Negative Binomial Uses the negative binomial distribution model to estimate sigma. The 

model indicates the number of successes in a sequence of trials before a specified number 

of failures occur. Selecting Negative Binomial yields a G chart.

Weibull Uses the Weibull distribution model to estimate sigma. The model indicates the 

mean time between failures. Selecting Weibull yields a T chart.
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Tests

The Warnings option in the pop-up menu or on the left hand side of the window displays a 

submenu for Tests selection. You can select one or more tests for special causes (Western 

Electric rules) from the menu. Nelson (1984) developed the numbering notation used to 

identify special tests on control charts. The tests work with both equal and unequal sample 

sizes.

If a selected test is positive for a particular sample, that point is labeled with the test number. 

When you select several tests for display and more than one test signals at a particular point, 

the label of the numerically lowest test specified appears beside the point. You can hover over 

a flagged point on the chart to see a description of the test that failed.

Tip: To add or remove several tests at once, select or deselect the tests in the Control Panel 

under Warnings > Tests.

Table 3.8 lists and interprets the eight tests, and Figure 3.9 illustrates the tests. The following 

rules apply to each test:

• The area between the upper and lower limits is divided into six zones, each with a width 

of one standard deviation.

• The zones are labeled A, B, C, C, B, A with zones C nearest the center line.

• A point lies in Zone B or beyond if it lies beyond the line separating zones C and B. That is, 

if it is more than one standard deviation from the center line.

• Any point lying on a line separating two zones lines is considered belonging to the 

innermost zone. So, if a point lies on the line between Zone A and Zone B, the point is 

considered to be in Zone B.

• When a Phase variable is specified, the counts for each test are reset at the start of each 

phase.

Notes:

• Tests 1 through 8 apply to all Shewhart Variables chart types.

• Tests 1, 2, 5, and 6 apply to the upper and lower halves of the chart separately.

• Tests 3, 4, 7, and 8 apply to the whole chart.

• Once a runs test (one that is based on consecutive observations) is triggered, the counts do 

not reset to 0 when moving to the next sample.

• Runs tests handle excluded rows based on the setting of the Show Excluded Region and 

Test Excluded Subgroups options.

– By default, both options are selected, and the excluded rows are included in the runs 

tests calculations.
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– If the Show Excluded Region option is selected and the Test Excluded Subgroups 

option is not selected, the excluded rows are treated as missing and the counts for the 

runs tests reset to 0 when moving to the next sample.

– If the Show Excluded Region option is not selected, the excluded rows are treated as if 

they are deleted.

• Tests 5 through 8 are not available for attribute charts.

See Nelson (1984, 1985) for further recommendations on how to use these tests.

Figure 3.8  Zones for Western Electric Rules

Table 3.8  Description and Interpretation of Tests for Special Causesa

Test 1 One point beyond Zone A 

(upper or lower)

Detects a shift in the mean, an increase in 

the standard deviation, or a single 

aberration in the process. For 

interpreting Test 1, any dispersion chart 

(R, S, or MR) can be used to rule out 

increases in variation.

Note that if you hide the upper or lower 

control limits, the Test 1 option does not 

flag points that are associated with limits 

that are not shown on the control chart.

3 limits

center line

zones
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Test 2 Nine points in a row in a 

single (upper or lower) side 

of Zone C or beyond

Detects a shift in the process mean.

Test 3 Six points in a row steadily 

increasing or decreasing 

(anywhere on the chart)

Detects a trend or drift in the process 

mean.

Test 4 Fourteen points in a row 

alternating up and down 

(anywhere on the chart)

Detects systematic effects such as two 

alternately used machines, vendors, or 

operators.

Test 5 Two out of three points in a 

row in or beyond Zone A and 

the point itself is in or beyond 

Zone A; the two points must 

be on the same side (upper or 

lower)

Detects a shift in the process average or 

increase in the standard deviation. Any 

two out of three points provide a positive 

test.

Test 6 Four out of five points in a 

row in or beyond Zone B and 

the point itself is in or beyond 

Zone B; the four points must 

be on the same side (upper or 

lower)

Detects a shift in the process mean. Any 

four out of five points provide a positive 

test.

Test 7 Fifteen points in a row in 

Zone C, above and below the 

center line

Detects stratification of subgroups when 

the observations in a single subgroup 

come from various sources with different 

means. Also detects a reduction in 

variation.

Test 8 Eight points in a row on both 

sides of the center line with 

none in Zones C

Detects stratification of subgroups when 

the observations in one subgroup come 

from a single source, but subgroups 

come from different sources with 

different means.

a. Nelson (1984, 1985)

Table 3.8  Description and Interpretation of Tests for Special Causesa (Continued)
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Figure 3.9  Illustration of Special Causes Tests1

Westgard Rules

Westgard rules are implemented under the Westgard Rules submenu of the Warnings option 

when you right-click a chart or on the left hand side of the window. The different tests are 

abbreviated with the decision rule for the particular test. For example, 1 2s refers to a test 

where one point is two standard deviations away from the mean.

1. Nelson 1984, 1985)

UCL

Avg

LCL

A
B
C
C
B
A

UCL

Avg

LCL

A
B
C
C
B
A

UCL

Avg

LCL

A
B
C
C
B
A

UCL

Avg

LCL

A
B
C
C
B
A

UCL

Avg

LCL

A
B
C
C
B
A

UCL

Avg

LCL

A
B
C
C
B
A

UCL

Avg

LCL

A
B
C
C
B
A

UCL

Avg

LCL

A
B
C
C
B
A

1

2

3

4

5

5

5 6

7

8

Test 1: One point beyond Zone A Test 2: Nine points in a row in a single (upper 
or lower) side of Zone C or beyond

Test 3: Six points in a row steadily increasing 
or decreasing

Test 4: Fourteen points in a row alternating 
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Test 8: Eight points in a row on both sides of 
the center line with none in Zone C
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Notes:

• Once a runs test (one that is based on consecutive observations) is triggered, the counts do 

not reset to 0 when moving to the next sample.

• Runs tests handle excluded rows based on the setting of the Show Excluded Region and 

Test Excluded Subgroups options.

– By default, both options are selected, and the excluded rows are included in the runs 

tests calculations.

– If the Show Excluded Region option is selected and the Test Excluded Subgroups 

option is not selected, the excluded rows are treated as missing and the counts for the 

runs tests reset to 0 when moving to the next sample.

– If the Show Excluded Region option is not selected, the excluded rows are treated as if 

they are deleted.

Rule 1 2S (called Test 9 in JMP) is commonly used with Levey-Jennings charts, where control 

limits are set 2 standard deviations away from the mean. The rule is triggered when any one 

point goes beyond these limits.

Rule 1 3S (called Test 10 in JMP) refers to a rule common to Levey-Jennings charts where the 

control limits are set 3 standard deviations away from the mean. The rule is triggered when 

any one point goes beyond these limits.

Rule 2 2S (called Test 11 in JMP) is triggered when two consecutive control measurements are 

farther than two standard deviations from the mean.
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Rule R 4S (called Test 12 in JMP) is triggered when one measurement is greater than two 

standard deviations from the mean and the previous measurement is greater than two 

standard deviations from the mean in the opposite direction such that the difference is greater 

than 4 standard deviations.

Rule 4 1S (called Test 13 in JMP) is triggered when four consecutive measurements are more 

than one standard deviation from the mean.

Rule 10 X (called Test 14 in JMP) is triggered when ten consecutive points are on one side of 

the mean.

Control Chart Builder Right-Click Axis Options

The following options are available when you right-click the vertical axis of a control chart.

Remove Graph Removes the entire graph.

Remove Removes a variable.

Note: If there is more than one chart type on the graph, a submenu listing the different 

charts is displayed. You can select which chart to remove.

For more information about the Axis Settings, Revert Axis, Add or Remove Axis Label, Save 

to Column Property, and Edit options, see Using JMP.
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Control Limits in Control Chart Builder

Control limits are based on the performance of your process and tell you about the variability 

in your process. Upper control limits (UCLs), center lines, and lower control limits (LCLs) are 

calculated from the data when a control chart is created. You can use these calculated control 

limits to indicate when your process has changed.

It is important to note that control limits are different from specification limits, which are often 

used in capability analysis.

Excluded and Hidden Samples in Control Chart 
Builder

The following points summarize the use of excluded and hidden samples in Control Chart 

Builder:

• Excluded subgroups are not used in the calculations of control limits, and appear on the 

chart as dimmed points by default. If the Show Excluded Region option is not selected, the 

points for the excluded subgroups do not appear in the chart, are treated as missing in 

Tests for Special Causes, and are not included in the count of points for Tests for Special 

Causes.

• Hidden observations are used in the calculations of control limits, but do not appear in the 

chart.

• Rows that are both hidden and excluded are included in the count of points for Tests for 

Special Causes when the Test Excluded Subgroups option is selected. An excluded row 

can be labeled with a special cause flag. A hidden point cannot be labeled. If the flag for a 

Tests for Special Causes test is on a hidden point, it will not appear in the chart.

• For partially excluded subgroups, if one or more observations within a subgroup is 

excluded, and at least one observation within the subgroup is included, the excluded 

observation is not included in the calculations of either the point statistic or the limits.

Table 3.9  Control Limits versus Specification Limits

Control Limits Specification Limits

Calculated from data Defined by the customer or design

Based on variability Based on system requirements

The voice of the process The voice of the customer
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• Checks for negative and non-integer data happen on the entire data (even excluded 

values).

• Tests apply to all excluded subgroups only when the Test Excluded Subgroups option is 

selected.

Additional Examples of Control Chart Builder

This section contains examples using Control Chart Builder.

Note: In this section, some examples show the Control Panel while others do not. To show or 

hide the Control Panel, select Show Control Panel from the Control Chart Builder red triangle 

menu.

• “Example of Control Limits”

• “Example of Individual Measurement and Moving Range Charts”

• “Example of an XBar and R Chart”

• “Example of XBar and R Charts with Varying Subgroup Sizes”

• “Example of a Run Chart”

• “Example of a P Chart”

• “Example of a Laney PChart”

• “Example of an NP Chart”

• “Example of a C Chart”

• “Example of a U Chart”

• “Example of a G Chart”

• “Example of a T Chart”

• “Example of a Three Way Control Chart”

• “Example of Multiple Control Charts”

Example of Control Limits

This example uses Control Chart Builder in three stages. In most cases, you would start with 

“Create the Baseline Control Chart”, where you let JMP calculate the control limits for you. 

Then, to apply these control limits to new data, you would either “Specify Control Limits” or 

“Specify Multiple Sets of Control Limits” (for phase data).
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In this example, consider a company’s printing process. Variations can cause distortion in the 

line, including skew, thickness, and length problems. In this example, we will consider the 

length of the line. A line is considered good if it has a printed length of 16 cm +/- 0.2 cm. Any 

longer and the sentence might run off of the page. Any shorter and there would be a lot of 

wasted space on the page. For every print run, the first and last books are taken for 

measurement. The line lengths are measured on a specified page in the middle of each book.

You want to know: Is this process in control (stable)? Are we getting consistent print quality? 

What happens when we make improvements to the printing process? Does quality improve? 

To answer these questions, we need to create control charts and use control limits.

Create the Baseline Control Chart

First, examine whether the existing process is in control. If it is, we can use the control limits 

created by JMP as our baseline or historical limits.

1. Select Help > Sample Data Folder and open Quality Control/Line Length.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Length to the Y zone.

An Individual and Moving Range chart of Length appears. This chart is appropriate if you 

have no natural subgrouping in your data. However, in this example, there is a natural 

subgrouping, which is each print run.

4. Drag Run to the Subgroup zone (at bottom).

Figure 3.10  XBar and R Chart of Line Length by Print Run
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Three lines are drawn horizontally across the XBar and R charts. These are the calculated 

LCL (lower control limit), Avg (average) and UCL (upper control limit).

Ideally, we would like for all of our points to fall within the control limits, and we would 

like for the points to fall randomly within these limits. Looking at the graph, we see that no 

points fall outside of the control limits, and there does not appear to be a pattern to the 

points. To investigate further, perform Western Electric tests to check for patterns and 

trends that would cause these tests to fail. (The Western Electric tests are also referred to as 

Nelson tests.)

5. In the XBar chart, right-click and select Warnings > Tests > All Tests.

Notice that no points were circled or flagged. This means that our process is in control or 

stable.

If we had determined that our process was not in control, we would investigate out of 

control points or work to alter our process so that it is in control. For this example, since 

the process is already in control or stable, we can skip that step. Now, you can use these 

control limits with new data. Proceed to “Specify Control Limits”, or “Specify Multiple 

Sets of Control Limits” (to see an example with phase data).

Specify Control Limits

Since we established that the process is in control, we can use these historical limits with new 

data to see how the new data compares to the existing process. To use historical limits, we 

need to specify control limits instead of having JMP calculate them.

There are several ways to specify control limits in JMP:

• “Set Control Limits Option”

• “Add a Column Property”

• “Use the Get Limits Option”

• “Exclude Rows”

Set Control Limits Option

One simple way to specify control limits is to use the Set Control Limits option in Control 

Chart Builder.

1. Select Help > Sample Data Folder and open Quality Control/New Length Data.jmp.

This is the table that contains your new data.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Length to the Y zone.

4. Drag Run to the Subgroup zone (at bottom).

5. Right-click in the Average (XBar) chart and select Limits > Set Control Limits.
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6. Enter these limits:

– LCL - 15.90519

– Avg - 15.99825

– UCL - 16.09131

These are the historical limits from the Average (XBar) chart in Figure 3.10.

7. Click OK.

8. Right-click in the Range (R) chart and select Limits > Set Control Limits.

9. Enter these limits:

– LCL - 0

– Avg - 0.0495

– UCL - 0.161693

These are the historical limits from the Range (R) chart in Figure 3.10.

10. Click OK.

Figure 3.11  XBar and R Chart of Line Length with Historical Limits

Rather than calculating limits from the data, JMP used the historical control limits that you 

defined. In the Length Limit Summaries table, notice that the Limits Sigma now says User 

Defined. Many points now fall outside of the limits. Also, the averages are higher than those 

of the baseline process. This process appears different from the original process that we used 

to calculate the baseline control limits.



72 Control Chart Builder Chapter 3
Additional Examples of Control Chart Builder Quality and Process Methods

Add a Column Property

Another way to specify control limits is to add the Control Limits column property to a 

column in your new data table.

1. Select Help > Sample Data Folder and open Quality Control/New Length Data.jmp.

This is the table that contains your new data.

2. Select the Length column and click Cols > Column Info.

3. Click Column Properties > Control Limits.

4. XBar is selected, so enter these fixed limits for the Average (XBar) chart:

– Avg - 15.99825

– LCL - 15.90519

– UCL - 16.09131

These are the historical limits from the Average (XBar) chart in Figure 3.10.

Leave the value for Subgroup Size as missing. This value is not used in the Control Chart 

Builder platform.

5. Click XBar > R. Enter these fixed limits for the Range (R) chart:

– Avg - 0.0495

– LCL - 0

– UCL - 0.161693

These are the historical limits from the Range (R) chart in Figure 3.10.

Leave the value for Subgroup Size as missing. This value is not used in the Control Chart 

Builder platform.

6. Click OK.

You have entered control limits for XBar and R charts for the Length column. Now you can 

create a control chart.

7. Select Analyze > Quality and Process > Control Chart Builder.

8. Drag Length to the Y zone.

9. Drag Run to the Subgroup zone (at bottom).

The control chart is identical to Figure 3.11.

Use the Get Limits Option

The Get Limits method of specifying control limits is the most flexible. You should use this 

method in the following cases:

• If you have control limits for many different processes
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• If you have different control limits for each phase (see “Specify Multiple Sets of Control 

Limits”)

To use the Get Limits method, you need a data table that defines your historical limits. For 

more information about how to create a limits table, see “Saving and Retrieving Limits”.

Note: When no subgroup variable is specified, the Get Limits option uses the subgroup size 

(_Sample Size) from the limits table. Also, when the limits are missing in the file, JMP also 

looks for the sigma (_Std Dev). When no LCL or UCL are specified in the limits file (if both the 

average and sigma are found, and the subgroup size is constant), the option sets the limits 

based on the average, subgroup size, and sigma.

In this example, a limits data table has already been created.

1. Select Help > Sample Data Folder and open Quality Control/New Length Data.jmp.

This is the table that contains your new data.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Length to the Y zone.

4. Drag Run to the Subgroup zone (at bottom).

5. Click the Control Chart Builder red triangle and select Get Limits.

6. Select Other and click OK.

7. Navigate and open the limits data table for this example, called Length Limits.jmp. By 

default, the file is located here:

– On Windows: C:\Program Files\SAS\JMP\17\Samples\Data\Quality Control

– On macOS: \Library\Application Support\JMP\17\Samples\Data\Quality Control

The control chart is identical to Figure 3.11.

Exclude Rows

Another way to specify control limits is to exclude rows in a data table. One advantage to this 

method is that you can see both the historical data and new data in the same graph. This can 

help to visualize and investigate differences when they occur between the data collection 

periods.

To use this method, you must meet the following criteria:

• New and old data must reside in the same data table.

• Historical data and new data must all have equal subgroup sizes.

• All new data must be excluded in the data table (using Rows > Exclude/Unexclude).

In this example, new data have already been excluded.

1. Select Help > Sample Data Folder and open Quality Control/Combined.jmp.
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This table contains old and new data, and the rows corresponding to the new data are 

excluded.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Length to the Y zone.

4. Drag Run to the Subgroup zone (at bottom).

5. In the XBar chart, right-click and select Warnings > Tests > All Tests.

Figure 3.12  XBar and R Chart of Line Length with Excluded Data

JMP uses only the unexcluded rows (historical data) to create the control limits. The new data 

(excluded data) are plotted on the graph (dimmed), but these data were not used in any of the 

calculations. However, when you turn on the tests, all of the data is tested. The new data has 

many points that fall outside of the control limits and are flagged as failing Test 1 (point is 

more than 3 from the average).

Specify Multiple Sets of Control Limits

In this example, you want to set different control limits for different phases of a process. The 

column property, set control limits, and excluded row state methods will not work in this 

situation because these methods are limited to only one set of control limits for the entire 

chart. For a control chart with phases, you need to use the get limits method.
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In the printing company, the goal is to reduce the variability of the force needed to break the 

bond between paper and the book spine for three different sites. Each site has different 

machines, different operators, and is also located in different countries; therefore, each site has 

a unique set of historical limits. For all three sites, the company does the following:

1. Creates a baseline control chart based on the existing process data.

2. Changes the process, based on a designed experiment.

3. Gathers data from the new process.

4. Creates a new control chart based on the new process data.

The goal is to plot the new data on a control chart using historical limits from the old process. 

In this way, the printing company can compare the new process to the old process limits.

Create a Control Chart Based on Existing Process

1. Select Help > Sample Data Folder and open Quality Control/Phase Historical Data.jmp.

This table contains the existing process data for all three sites.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Force to the Y zone.

4. Drag Run to the Subgroup zone (at bottom).

5. Drag Site to the Phase zone.

Figure 3.13  Baseline Control Chart for Existing Data
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Create a Control Chart Based on Updated Process

1. From the report in Figure 3.13, click the Control Chart Builder red triangle and select Save 
Limits > in New Table.

This creates a limits table.

2. Save this new limits table to any location, so you can access it later.

3. Select Help > Sample Data Folder and open Quality Control/Phase New Data.jmp.

This data was collected from all three sites after the change was made to the process.

4. Select Analyze > Quality and Process > Control Chart Builder.

5. Drag Force to the Y zone.

6. Drag Run to the Subgroup zone (at bottom).

7. Drag Site to the Phase zone.

8. Click the Control Chart Builder red triangle and select Get Limits. Open the limits table 

that you saved in step 2.

This applies the historical limits to the new data in the Control Chart Builder report.

Figure 3.14  Control Chart for New Data Based on Historical Limits

Now you can see how the new data (after the process change) compare with the historical 

process limits (before the process change). None of the points fall outside of the control limits 

for either the location or dispersion chart. The goal was to reduce variability. Looking at the 

moving range chart, you can see that most points fall below the average line. For sites 1 and 2, 

it is clear that the variability of force needed to break the bond between pages and the book 

spine has been decreased. The decrease at Site 3 is not as strong as at sites 1 and 2. The 

improvements to the printing process appear to have succeeded in reducing the variability.
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Example of Individual Measurement and Moving Range Charts

In this example, you use the interactive workspace in Control Chart Builder to create control 

charts on the acidity levels of pickles. The acidity in four vats is measured each day at 1, 2, and 

3 PM. The data table records day, time, and acidity measurements.

1. Select Help > Sample Data Folder and open Quality Control/Pickles.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Acid to the Y role.

4. Click the Control Chart Builder red triangle and select Show Limit Labels.

This option labels the control limits and averages in both charts.

Figure 3.15  Individual Measurement and Moving Range Charts for Acid

The individual measurement and moving range charts monitor the acidity in each vat 

produced (subgroup of size 1). Vat 13 has an acidity above the upper control limit of 14.05.

You can also view a Median Moving Range chart. Continue with the following steps to change 

the charts to use median moving ranges.

5. In the Limits[1] outline, change the Sigma setting to Median Moving Range.

6. In the Limits[2] outline, change the Sigma setting to Median Moving Range.
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Figure 3.16  Individual Measurement and Median Moving Range Charts for Acid

The limits in the individual measurement and median moving range charts use the median 

moving range as the sigma, rather than the average moving range. This results in slightly 

narrower control limits for Acid.

Example of an XBar and R Chart

In this example, you use the interactive workspace in Control Chart Builder to create an XBar 

and R Chart with a phase variable. Data on the diameter of medical tubing for a new 

prototype were collected over 40 days. After the first 20 days (phase 1), some adjustments 

were made to the manufacturing equipment. Analyze the data to determine whether the past 

20 days (phase 2) of production are in a state of control.

1. Select Help > Sample Data Folder and open Quality Control/Diameter.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag DIAMETER to the Y role.

4. Drag DAY to the Subgroup role (at bottom).
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Figure 3.17  Control Charts for Diameter

The first 20 days appear to have high variability, and in the Average chart, there are three 

observations that are outside of the control limits. An adjustment was made to the 

manufacturing equipment and new control limits were incorporated.

To compute separate control limits for each phase:

5. Drag Phase to the Phase role.

6. In the Average chart, right-click and select Warnings > Test Beyond Limits.

7. In the Limits[1] outline, select Shade Zones.



80 Control Chart Builder Chapter 3
Additional Examples of Control Chart Builder Quality and Process Methods

Figure 3.18  Control Charts for each Phase

Including the Phase variable means that the control limits for phase 2 are based only on the 

data for phase 2. None of the phase 2 observations are outside the control limits. This is 

highlighted by including the zone shading on the chart. Therefore, you can conclude that the 

process is in control after the adjustments were made.

Filter the Control Chart by Another Variable

This data table, Diameter.jmp, contains a column for the operator of the machine for each 

sample. You can use the Local Data Filter with Control Chart Builder to show the data for a 

subset of operators.

8. Click the Control Chart Builder red triangle and deselect Show Excluded Region.

Turning off the Show Excluded Region option indicates that the subgroups that are 

excluded by settings in the Local Data Filter no longer appear on the horizontal axis of the 

control chart as you make selections in the Local Data Filter. As a result, you see only the 

portion of the data that are of interest.

9. Click the Control Chart Builder red triangle and select Local Data Filter.

10. In the Local Data Filter, click on OPERATOR and click the + button.

11. In the Local Data Filter, select the bar labeled RMM.
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Figure 3.19  XBar and R Chart of Diameter for Operator RMM

The XBar and R charts now show only the points for the RMM operator, as denoted by the 

Where() statement below the charts. The limits for both phases have been adjusted to reflect 

that the observations for the other three operators have been excluded.

Example of XBar and R Charts with Varying Subgroup Sizes

In this example, you use the interactive workspace in Control Chart Builder to create XBar and 

R charts using data that have varying subgroup sizes.

1. Select Help > Sample Data Folder and open Quality Control/Coating.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Weight 2 to the Y role.

4. Drag Sample to the Subgroup role (at bottom).
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Figure 3.20  XBar and R Charts for Varying Subgroup Sizes

Weight 2 has several missing values in the data, so the chart has uneven limits. Although 

each sample has the same number of observations, samples 1, 3, 5, and 7 each have a 

missing value.

Instead of viewing a line connecting the averages of each sample, you can switch to viewing 

box plots at each sample.

5. In the Points[1] outline, deselect the Show Connect Line option.

6. In the Points[1] outline, select the Box Plots option.
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Figure 3.21  XBar and R Chart with Box Plots

Example of a Run Chart

In this example, you use the Run Chart launch window to launch Control Chart Builder. Run 

charts display a column of data as a connected series of points.

1. Select Help > Sample Data Folder and open Stock Averages.jmp.

2. Select Analyze > Quality and Process > Control Chart > Run Chart.

3. Select Close and click Y.

4. Click OK.
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Figure 3.22  Run Chart for Stock Averages Closing Price

Example of a P Chart

In this example, you use the P Control Chart launch window to launch Control Chart Builder. 

You want to create a P chart to analyze defect data on galvanized washers for two different lot 

sizes. The washers were inspected for finish defects such as rough galvanization and exposed 

steel. If a washer contained a finish defect, it was deemed nonconforming or defective. Thus, 

the defect count represents how many washers were defective for each lot of size 400.

1. Select Help > Sample Data Folder and open Quality Control/Washers.jmp.

2. Select Analyze > Quality and Process > Control Chart > P Control Chart.

3. Select # defective and click Y, n Defective.

4. Select Lot Size and click n Trials.

5. Click OK.

6. Right-click the graph and select Limits > Show Lower Limit to deselect the Show Lower 

Limit option.

This hides the lower limit, which is not of interest in this situation.
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Figure 3.23  P chart of # defective with sample size

To view the differences between constant and variable sample sizes, you can compare charts 

for Lot Size and Lot Size 2 by simply dragging the variables to the nTrials zone.

Example of a Laney PChart

In this example, you compare a P control chart and a Laney P control chart using the Control 

Chart Builder. Laney Pcharts are useful when the variance in the data is greater than the 

variance that is assumed by the binomial distribution. The data are counts in milliliters of 

plastics measured from samples of ocean water that were taken over the course of 10 weeks in 

3 different locations.

Create a Standard P Chart

1. Select Help > Sample Data Folder and open Quality Control/Water Plastics.jmp.

2. Select Analyze > Quality and Process > Control Chart > P Control Chart.

3. Select Total Plastic and click Y, n Defective.

4. Select Week and click Subgroup.

5. Select Total Volume and click n Trials.

6. Select Location and click Phase.
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7. Click OK.

Figure 3.24  Standard P Chart for Water Plastics

There are several points on the standard P chart that are labeled as out of control. Due to 

how control limits are calculated in the standard P chart, there is a strong possibility that 

the out of control points are actually false alarms. Compare these results to the results 

from the Laney P chart.

Create Laney P Chart

8. Select Analyze > Quality and Process > Control Chart > Laney P Control Chart.

9. Select Total Plastic and click Y, n Defective.

10. Select Week and click Subgroup.

11. Select Total Volume and click n Trials.

12. Select Location and click Phase.

13. Click OK.
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Figure 3.25  Laney P Chart for Water Plastics

Unlike the standard P chart, the Laney P chart displays all of the points as in control for 

this data set.

Example of an NP Chart

In this example, you use the interactive workspace in Control Chart Builder to create an NP 

chart with a phase variable. The two phases represent the time before and after an adjustment 

to the process. The data are simulated from a bottle top manufacturing process.

1. Select Help > Sample Data Folder and open Quality Control/Bottle Tops.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Sample to the Subgroup role.

This variable is the sample ID for each bottle.

4. Drag Status to the Y role.

This variable indicates whether the bottle top conformed to the design standards.
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Figure 3.26  NP chart of Status (Nonconforming)

The original observations appear to have high variability and there are five observations 

(Samples 13, 15, 21, 22 and 23) that are outside of the upper control limit. Samples 15 and 

23 note that new material and a new operator were introduced into the process, 

respectively. At the end of the phase, an adjustment was made to the manufacturing 

equipment. Therefore, the control limits for the entire series should not be used to assess 

the control during phase 2.

To compute separate control limits for each phase:

5. Drag Phase to the Phase zone.
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Figure 3.27  NP chart by Phase

Including the Phase variable means that the control limits for phase 2 are based only on the 

data for phase 2. None of the phase 2 observations are outside the control limits. Therefore, 

you can conclude that the process is in control after the adjustment.

Example of a C Chart

In this example, you use the C Control Chart launch window to launch Control Chart Builder. 

You want to explore data concerning the various defects discovered while manufacturing 

cabinets over two time periods.

1. Select Help > Sample Data Folder and open Quality Control/Cabinet Defects.jmp.

2. Select Analyze > Quality and Process > Control Chart > C Control Chart.

3. Select Type of Defect and click Y, n Defects.

4. Select Lot Number and click Subgroup.

5. Select Date and click Phase.

6. Click OK.
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Figure 3.28  C chart of Type of Defect with Phases

You can now view the results on the two different days. Both appear to be within limits. 

You can also examine other defect type behavior using the Event Chooser.

7. Click the Control Chart Builder red triangle and select Show Control Panel.

8. Under Event Chooser, click the gray triangle next to Type of Defect.

The control chart is showing events that correspond to the Bruised veneer defect type.

9. Under Event Chooser > Type of Defect, click the box next to Bruised veneer.

10. Under Event Chooser > Type of Defect, click the box next to Defective Sanding.
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Figure 3.29  C Chart of Defective Sanding Defect Type

This chart shows that all of the events corresponding to the Defective sanding defect type 

occurred on the first day, 01Jan1956.

Example of a U Chart

In this example, you use the U Control Chart launch window to launch Control Chart Builder. 

You want to create a U chart to monitor the number of defects per subgroup sample size. The 

data are defect counts in boxes of automobile support braces. A box of braces constitutes one 

inspection unit. The number of boxes inspected (per day) is the subgroup sample size, which 

can vary.

1. Select Help > Sample Data Folder and open Quality Control/Braces.jmp.

2. Select Analyze > Quality and Process > Control Chart > U Control Chart.

3. Select # defects and click Y, n Defects.

4. Select Unit size and click n Trials.

5. Click OK.
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Figure 3.30  U chart of # Defects

Because the sample sizes are not equal across subgroups, the limits are uneven. Two of the last 

five samples are not within the control limits.

Example of a G Chart

In this example, you use the interactive workspace in Control Chart Builder to create a G chart 

to monitor data about adverse drug events (ADEs) reported by a group of hospital patients. 

An ADE is any type of injury or reaction the patient suffered after taking the drug. The date of 

the reaction and the number of days since the last reaction were recorded.

A G chart is an effective way to understand whether rare events are occurring more frequently 

than expected and warrant an intervention. See “Rare Event Control Charts”.

1. Select Help > Sample Data Folder and open Quality Control/Adverse Reactions.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Doses since Last ADE to the Y role.

4. Drag Date of ADE to the Subgroup role.

An Individual & Moving Range chart of Doses since Last ADE appears.

5. In the drop-down list, select Rare Event instead of Shewhart Variables.
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A G chart of Doses since Last ADE appears, showing the number of doses given since the 

last event.

Figure 3.31  G chart of Doses since Last ADE

Example of a T Chart

In this example, you use the interactive workspace in Control Chart Builder to create a T chart 

to explore data from a fan manufacturing process. The first column identifies each fan that 

burned out. The second column identifies the number of hours between each burnout.

T charts are used to measure the time that has elapsed since the last event. See “Rare Event 

Control Charts”.

1. Select Help > Sample Data Folder and open Quality Control/Fan Burnout.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Hours between Burnouts to the Y role.

4. Drag Burnout to the Subgroup role.
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Figure 3.32  Individual and Moving Range Chart of Hours Between Burnouts

5. In the drop-down list, select Rare Event instead of Shewhart Variables.

6. Under Limits, change the Sigma from Negative Binomial to Weibull.
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Figure 3.33  T chart of Hours Between Burnouts

In the T chart, all points appear to be within the control limits. It is clear that the Individual & 

Moving Range chart was inappropriate for the analysis, as the limits were too narrow.

Example of a Three Way Control Chart

In this example, you use the Three Way Control Chart launch window to launch Control Chart 

Builder. Three way control charts are useful when there is variation between batches and 

variation within batches.

1. Select Help > Sample Data Folder and open Quality Control/Vial Fill Weights.jmp.

2. Select Analyze > Quality and Process > Control Chart > Three Way Control Chart.

3. Select Fill Weight and click Y.

4. Select Sample and click Subgroup.

5. Click OK.
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Figure 3.34  Three Way Control Chart for Fill Weight
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A Moving Range chart appears between the Range and Average charts. The limits on the 

Average (XBar) chart are now calculated using the moving range between each sample.

Example of Multiple Control Charts

In Control Chart Builder, you can create multiple control charts in the same window using the 

New Y Chart option in the interactive workspace or by specifying multiple processes in a 

specific control chart launch window. In this example, use the IMR control chart launch 

window and then save the control limits to a new data table.

1. Select Help > Sample Data Folder and open Semiconductor Capability.jmp.

2. Select Analyze > Quality and Process > Control Chart > IMR Control Chart.

3. Click the triangle next to Processes to show all of the processes.

4. Select the first five processes and click Y.

5. Click OK.

If you scroll through the report window, there are Individual and Moving Range control 

charts for all five selected processes. Since the processes have a Spec Limits column 

property, there are also Process Capability Analysis reports for each process.

6. Click the Control Chart Builder red triangle and select Save Limits > in New Tall Table.

Figure 3.35  New Tall Table

The control limits are saved to a new data table, with a row for each Y variable and a 

column for each statistic.
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Statistical Details for Control Chart Builder

This section contains statistical details for Control Chart Builder.

• “Statistical Details for XBar and R Charts”

• “Statistical Details for XBar and S Charts”

• “Statistical Details for Individual Measurement and Moving Range Charts”

• “Statistical Details for P, NP, and Laney P Charts”

• “Statistical Details for U, C, and Laney U Charts”

• “Statistical Details for Levey-Jennings Charts”

• “Statistical Details for G Charts”

• “Statistical Details for T Charts”

• “Statistical Details for Three Way Control Charts”

Notes:

• Control limits are calculated using a sigma multiplier, K, which is set to 3 by default. To 

change the default value of K, use the K Sigma option in the red triangle menu or the K 

Sigma preference in File > Preferences > Platforms > Control Chart Builder.

• For sample sizes up to n = 50, JMP uses control chart constants d2(n) and d3(n) that are de-
fined in Table 2 of Harter (1960). For samples with a sample size greater than 50, JMP uses 
the control chart constant values for sample size 50 in both the sigma and control limit cal-
culations.

Statistical Details for XBar and R Charts

In Control Chart Builder, control limits for XBar and R charts are generated using the 

following formulas:

LCL for XBar chart = 

UCL for XBar chart = 

LCL for R chart = 

UCL for R chart = 

Xw
K̂

ni

---------–

Xw
K̂

ni

---------+

max d2 ni 
ˆ

Kd3 ni 
ˆ

– 0 
 

d2 ni 
ˆ

Kd3 ni 
ˆ

+
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Center line for R chart: By default, the center line for the ith subgroup indicates an estimate 

of the expected value of Ri. This value is computed as , where  is an estimate of .

The standard deviation for XBar and R charts is estimated using the following formula:

where:

 = weighted average of subgroup means

K = the sigma multiplier and is set to 3 by default

 = process standard deviation

ni = sample size of ith subgroup

d2(n) is the expected value of the range of n independent normally distributed variables 

with unit standard deviation

d3(n) is the standard deviation of the range of n independent normally distributed 

variables with unit standard deviation

Ri is the range of ith subgroup

N is the number of subgroups for which ni ≥ 2.

Statistical Details for XBar and S Charts

In Control Chart Builder, control limits for XBar and S charts are generated using the 

following formulas:

LCL for XBar chart = 

UCL for XBar chart = 

LCL for S chart = 

d2 ni ̂ ̂


ˆ

R1

d2 n1 
----------------- 

RN

d2 nN 
------------------+ +

N
-------------------------------------------------------=

Xw

Xw
K̂

ni

---------–

Xw
K̂

ni

---------+

max c4 ni 
ˆ

Kc5 ni ̂– 0 
 
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UCL for S chart = 

Center line for S chart: By default, the center line for the ith subgroup indicates an estimate 

of the expected value of si. This value is computed as , where  is an estimate of .

The estimate for the standard deviation for XBar and S charts is:

where:

 = weighted average of subgroup means

K = the sigma multiplier and is set to 3 by default

 = process standard deviation

ni = sample size of ith subgroup

c4(n) is the expected value of the standard deviation of n independent normally distributed 

variables with unit standard deviation

c5(n) is the standard error of the standard deviation of n independent normally distributed 

variables with unit standard deviation

N is the number of subgroups for which ni ≥ 2

si is the sample standard deviation of the ith subgroup

Statistical Details for Individual Measurement and Moving Range 
Charts

This section describes how control limits for Individual Measurement and Moving Range 

charts are calculated in Control Chart Builder.

Control limits for Individual Measurement charts are computed as follows:

LCL for Individual Measurement Chart = 

UCL for Individual Measurement Chart = 

c4 ni 
ˆ

Kc5 ni 
ˆ

+

c4 ni ̂ ̂


ˆ

s1

c4 n1 
---------------- 

sN

c4 nN 
------------------+ +

N
------------------------------------------------------=

Xw

X K̂–

X K̂+
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Control limits for Individual Measurement charts with sigma estimated by the median 

moving range are computed as follows:

LCL for Individual Measurement Chart = 

UCL for Individual Measurement Chart = 

Control limits for Moving Range charts are computed as follows:

LCL for Moving Range Chart = 

UCL for Moving Range Chart = 

Control limits for Median Moving Range charts are computed as follows:

LCLMMR = max(0, MMR - Kd3(n) )

UCLMMR = MMR + Kd3(n)

The standard deviation for Individual Measurement and Moving Range charts is estimated as 

follows:

The standard deviation for Individual Measurement and Moving Range charts when using 

the median is estimated as follows:

 = MMR/0.954

where:

 = the mean of the individual measurements

K = the sigma multiplier and is set to 3 by default

 = the mean of the nonmissing moving ranges computed as (MR2+MR3+...+MRN)/(N-1) 

where MRi = |xi - xi-1|.

MMR = the median of the nonmissing moving ranges

 = the process standard deviation

X K̂MMR–

X K̂MMR+

max d2 n ̂ Kd3 n ̂– 0 

d2 n ̂ Kd3 n ̂+

̂MMR

̂MMR


ˆ MR

d2 n 
--------------=

̂MMR

X

MR
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d2(n) = expected value of the range of n independent normally distributed variables with 

unit standard deviation.

d3(n) = standard deviation of the range of n independent normally distributed variables 

with unit standard deviation

Note: Moving Range charts in Control Chart Builder use a range span of n = 2.

Statistical Details for P, NP, and Laney P Charts

In Control Chart Builder, the lower and upper control limits, LCL, and UCL, respectively, are 

computed using the following formulas:

P chart LCL = 

P chart UCL = 

NP chart LCL = 

NP chart UCL = 

Laney P chart LCL = 

Laney P chart UCL = 

where:

 is the average proportion of nonconforming items taken across subgroups

ni is the number of items in the ith subgroup

K is the sigma multiplier and is set to 3 by default

z is a moving range sigma calculated from the standardized values

max p K p 1 p–  ni– 0 

min p K p 1 p–  ni+ 1 

max nip K nip 1 p– – 0 

min nip K nip 1 p– + ni 

max p Kz p 1 p–  ni– 0 

min p Kz p 1 p–  ni+ 1 

p

p
n1p1  nNpN+ +

n1  nn+ +
----------------------------------------------

X1  XN+ +

n1  nN+ +
----------------------------------= =
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Statistical Details for U, C, and Laney U Charts

In Control Chart Builder, the lower and upper control limits, LCL, and UCL, are computed 

using the following formulas:

U chart LCL = 

U chart UCL = 

C chart LCL = 

C chart UCL = 

Laney U chart LCL = 

Laney U chart UCL = 

The limits vary with ni.

ui is the number of nonconformities per unit in the ith subgroup. In general, ui = ci/ni.

K is the sigma multiplier and is set to 3 by default

z is a moving range sigma calculated from the standardized values

ci is the total number of nonconformities in the ith subgroup

ni is the number of inspection units in the ith subgroup

 is the average number of nonconformities per unit taken across subgroups. The quantity 

 is computed as a weighted average

N is the number of subgroups

max u K u ni– 0 

u K u ni+

max niu K niu– 0 

niu K niu+

max u Kz u ni– 0 

u Kz u ni+

u

u

u
n1u1  nNuN+ +

n1  nN+ +
-----------------------------------------------

c1  cN+ +

n1  nN+ +
--------------------------------= =
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Statistical Details for Levey-Jennings Charts

Levey-Jennings charts are available in Control Chart Builder and show a process mean with 

control limits based on a long-term sigma. The control limits are placed at K*s distance from 

the center line, where K = 3 by default.

The standard deviation, s, for the Levey-Jennings chart is calculated the same way standard 

deviation is in the Distribution platform.

See Levey and Jennings (1950); Westgard (2002).

Statistical Details for G Charts

In Control Chart Builder, the negative binomial distribution is used to calculate the sigma 

value for a G chart. The negative binomial distribution is an extension of the geometric 

(Poisson) distribution and allows for overdispersion relative to the Poisson. The negative 

binomial distribution can be used to construct both exact and approximate control limits for 

count data. Approximate control limits can be obtained based on a chi-square approximation 

to the negative binomial. All data is used as individual observations regardless of subgroup 

size.

Let X have a negative binomial distribution with parameters (, k). Then:

where:

 is a chi-square variate with v = 2/(1+k) degrees of freedom.

Based on this approximation, approximate upper and lower control limits can be determined. 

For a nominal level  Type 1 error probability in one direction, an approximate upper control 

limit is a limit UCL such that the following equation is true:

s
yi y– 

2

N 1–
---------------------

i 1=

N

=

P X r  P v
2 2r 1+

1 k+
--------------- 

 

2
v

P X UCL  1 P v
2 2UCL 1+

1 k+
------------------------- 

 – = =
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Likewise, an approximate lower control limit, LCL, is a limit such that the following equation 

is true:

Thus, an approximate level lower and upper control limits, LCL and UCL, respectively, are 

computed using the following formulas:

where:

 is the upper (lower) percentile of the chi-square distribution with 

v = 2/(1+k) degrees of freedom. Negative lower control limits can be set to zero.

For more information about the negative binomial control limits, see Hoffman (2003).

Statistical Details for T Charts

In Control Chart Builder, the Weibull distribution is used to calculate the sigma value for a T 

chart. The estimates of the shape and scale parameters are calculated from the data and used 

to obtain the percentiles of the Weibull distribution.

Note: Subgroups with a response value of zero are given a weight of zero when estimating the 

Weibull distribution parameters.

Define the following quantities:

p1 = normalDist(-K) for Normal (0,1)

p2 = normalDist(0) for Normal (0,1)

p3 = normalDist(K) for Normal (0,1)

Then the limits are calculated using the following formulas:

LCL = Weibull Quantile (p1, , )

CL = Weibull Quantile (p2, , )

UCL = Weibull Quantile (p3, , )

P X LCL  1 P v
2 2LCL 1+

1 k+
------------------------ 

 – = =

UCL
2

v 1 – 1 k+  1–

2
-----------------------------------------------------=

LCL max 0
2

v  1 k+  1–

2
---------------------------------------------

 
 
 

=

2
v 1 – 2

v  
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where:

 is the shape parameter and  is the scale parameter for the Weibull Quantile function

K is the sigma multiplier and is set to 3 by default

For more information about the Weibull Quantile function, see Help > Scripting Index.

Statistical Details for Three Way Control Charts

This section describes how the sigma values are calculated for Three Way control charts in 

Control Chart Builder.

Within Sigma Based on Average of Ranges

The within sigma estimate for three way control charts that is estimated using the average of 

ranges can be used for the Individual on Means, Moving Range on Means and R chart.

The formula uses the following notation:

Ri = range of ith subgroup

ni = sample size of ith subgroup

d2(ni) = expected value of the range of ni independent normally distributed variables with 

unit standard deviation

N = number of subgroups for which ni ≥ 2

Within Sigma Based on Average of Unbiased Standard Deviations

The within sigma estimate for three way control charts that is estimated using the average of 

unbiased standard deviations can be used for the Individual on Means, Moving Range on 

Means, and S chart.

The formula uses the following notation:

si = sample standard deviation of the ith subgroup

ni = sample size of ith subgroup

̂within

R1

d2 n1 
----------------- 

RN

d2 nN 
------------------+ +

N
-------------------------------------------------------=

̂within

s1

c4 n1 
---------------- 

sN

c4 nN 
------------------+ +

N
------------------------------------------------------=



Chapter 3 Control Chart Builder 107
Quality and Process Methods Statistical Details for Control Chart Builder

c4(ni) = expected value of the standard deviation of ni independent normally distributed 

variables with unit standard deviation

N = number of subgroups for which ni ≥ 2

Between Sigma

The between sigma estimate for three way control charts is estimated using the moving range 

of subgroup means.

The formula uses the following notation:

 = the mean of the nonmissing moving ranges computed as (MR2+MR3+...+MRN)/(N-1) 

where MRi = |yi - yi-1|.

d2(2) = expected value of the range of two independent normally distributed variables with 

unit standard deviation.

, the harmonic mean of subgroup sample sizes.

Note: If between Sigma is estimated as a negative value, it is set to 0.

Between-and-Within Sigma

The between-and-within sigma estimate for three way control charts is estimated using a 

combination of the within sigma and between sigma estimates.

̂between
MR

d2 2 
--------------
 
 
  2 ̂

2
within

H
----------------------–=

MR

H
N

1
n1
------ 1

n2
------  1

nN
-------+ + +

----------------------------------------------=

̂between-and-within ̂within
2

̂between
2

+=
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Chapter 4
Measurement Systems Analysis

Evaluate a Continuous Measurement Process Using the EMP Method

The Measurement Systems Analysis (MSA) platform uses the Evaluating the Measurement 

Process (EMP) method to assess the precision, consistency, and bias of a measurement system. 

Use MSA to evaluate your measurement system performance. Before you study the process 

itself, you should make sure that you can accurately and precisely measure the process.

Note: This chapter covers the EMP method. The Gauge R&R method is described in 

“Variability Gauge Charts”.

Figure 4.1  Example of a Measurement System Analysis
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Overview of Measurement Systems Analysis

The Evaluating the Measurement Process (EMP) method in the Measurement Systems 

Analysis platform is largely based on the methods presented in Donald J. Wheeler’s book 

EMP III Using Imperfect Data (2006). The EMP method provides visual information and results 

that are easy to interpret and helps you improve your measurement system to its full 

potential.

The Gauge R&R method analyzes how much of the variability is due to operator variation 

(reproducibility) and measurement variation (repeatability). Gauge R&R is available for many 

combinations of crossed and nested models, regardless of whether the model is balanced. See 

“Variability Gauge Charts”.

Within the Six Sigma DMAIC methodology, Measurement System Analysis (MSA) addresses 

the Measure phase and process behavior charts (or control charts) address the Control phase. 

MSA helps you predict and characterize future outcomes. You can use the information 

gleaned from MSA to help you interpret and configure your process behavior charts.

For more information about Control Charts, see “Control Chart Builder”.

Example of Measurement Systems Analysis

Use the Measurement Systems Analysis platform to study the variability of a measurement 

system. The study had three operators who each measured the same five parts.

1. Select Help > Sample Data Folder and open Variability Data/Gasket.jmp.

2. Select Analyze > Quality and Process > Measurement Systems Analysis.

3. Assign Y to the Y, Response role.

4. Assign Part to the Part, Sample ID role.

5. Assign Operator to the X, Grouping role.

Notice that the MSA Method is set to EMP, the Chart Dispersion Type is set to Range, and 

the Model Type is set to Crossed.

6. Click OK.
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Figure 4.2  MSA Initial Report

The Average Chart shows the average measurements for each operator and part 

combination. In this example, the means of the part measurements are generally beyond 

the control limits. This is a desirable outcome, because it indicates that you can detect 

part-to-part variation.

The Range Chart shows the variability for each operator and part combination. In this 

example, the ranges are within the control limits. This is a desirable outcome, because it 

indicates that the operators are measuring parts in the same way and with similar 

variation.

The color coding for each part is shown in the legend below the charts.

7. Click the red triangle next to Measurement Systems Analysis for Y and select Parallelism 
Plots.
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Figure 4.3  Parallelism Plot for Operator and Part

The Parallelism Plots chart shows the average measurements for each part by operator. 

Because the lines are generally parallel and there is no major crossing, you conclude that 

there is no interaction between operators and parts.

Tip: Interactions indicate a serious issue that requires further investigation.

8. Click the red triangle next to Measurement Systems Analysis for Y and select EMP 
Results.

Figure 4.4  EMP Results Report
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The EMP Results report computes several statistics to help you assess and classify your 

measurement system. The Intraclass Correlation indicates the proportion of the total variation 

that you can attribute to the part.

From the EMP Results report, you can conclude the following:

• The Intraclass Correlation values are close to 1, indicating that most of the variation is 

coming from the part instead of the measurement system.

• The classification is First Class, meaning that the strength of the process signal is 

weakened by less than 11%.

• There is at least a 99% chance of detecting a warning using Test 1 only.

• There is 100% chance of detecting a warning using Tests 1-4.

Note: For more information about tests and detecting process shifts, see “Shift Detection 

Profiler”.

There is no interaction between operators and parts, and there is very little variation in your 

measurements (the classification is First Class). Therefore, you conclude that the measurement 

system is performing quite well.
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Launch the Measurement Systems Analysis Platform

Launch the Measurement Systems Analysis platform by selecting Analyze > Quality and 
Process > Measurement Systems Analysis.

Figure 4.5  The Measurement Systems Analysis Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

The Measurement Systems Analysis window contains the following features:

Select Columns Lists all of the variables in your current data table. Move a selected column 

into a role.

MSA Method Select the method to use: EMP (Evaluating the Measurement Process), Gauge 

R&R, or Type 1 Gauge. This chapter covers the EMP method. For more information about 

the Gauge R&R method, see “Variability Gauge Charts”. For more information about the 

Type 1 Gauge method, see “Type 1 Gauge Analysis”.

Chart Dispersion Type Designates the type of chart for showing variation. Select the Range 

option or the Standard Deviation option.
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Note: For the EMP method, the chart dispersion type determines how the statistics in the 

EMP Results report are calculated. If the Range option is selected, and you have a one 

factor or a two factor, balanced, crossed model, the statistics in this report are based on 

ranges. Otherwise, the statistics in this report are based on standard deviations.

Model Type Designates the model type:

Main Variables with nominal or ordinal modeling types are treated as main effects.

Crossed The model is crossed when every level of every factor occurs with every level of 

every other factor.

Crossed with Two Factor Interactions The model is crossed when each level of two 

factors occurs with every level of the other factor.

Nested The model is nested when all levels of a factor appear within only a single level 

of any other factor.

Crossed then Nested (3 Factors Only) The factors are crossed and then nested for 3 

factors.

Nested then Crossed (3 Factors Only) The factors are nested and then crossed for 3 

factors.

Options Contains the following options:

Sigma Multiplier Specifies the sigma multiplier used in the analyses.

Specify Alpha Level Specifies the 1-alpha confidence level used in the analyses.

Set Random Seed Enables you to set a specific random seed.

Analysis Settings Opens a window that enables you to set the REML maximum 

iterations and convergence limit.

Show MSA Metadata Entry Dialog Specifies if the MSA Metadata dialog is shown after you 

click OK. This dialog enables you to load the metadata from a data table or enter the 

metadata for each column manually. Use the following options to enter the metadata 

manually:

Choose Tolerance Entry Type Choose to enter the tolerance range directly or specify the 

lower and upper tolerance values. If you choose to enter lower and upper tolerance 

values, the tolerance range is calculated as the difference between the upper and lower 

tolerance values. If only one tolerance value is entered, the tolerance range cannot be 

calculated and any statistics in the report that rely on the tolerance range are not 

shown.
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Tolerance Range Specifies the tolerance for the process, which is the difference between 

the upper specification limits and the lower specification limits.

Lower Tolerance Specifies the lower tolerance limit. This is used to calculate the 

tolerance range if it is not specified directly.

Upper Tolerance Specifies the upper tolerance limit. This is used to calculate the 

tolerance range if it is not specified directly.

Historical Mean Specifies a historical mean. The historical mean is used to compute 

tolerance ranges for one-sided specification limits (either USL-Historical Mean or 

Historical Mean-LSL). If you do not enter a historical mean, the grand mean is used.

Historical Process Sigma Specifies a historical process sigma. This value is used to 

calculate the process variation in the Linearity and Bias Results option and some of the 

statistics in the Gauge R&R report.

Tip: This data can also be specified prior to launching using the MSA column property. 

You can set MSA column properties to several measurement columns at once using 

Manage Limits. See “Manage Limits”.

Use Spec Limits for Tolerance if Needed If a tolerance range is not specified for a column, 

but the column has a Spec Limits column property, this option uses the specification limits 

to calculate the tolerance range.

Y, Response The column(s) of measurements.

Standard Specifies a standard or reference column that contains the “true” or known values 

for the measured part. Including this column enables the Bias and Linearity Study options. 

These options perform analysis on the differences between the observed measurement and 

the reference or standard value. See “Linearity and Bias Results”.

Part, Sample, ID The column designating the part or unit.

X, Grouping The column(s) representing grouping variables.

By Identifies a column that creates a report consisting of separate analyses for each level of 

the variable.

Data Format

To use the Measurement Systems Analysis platform, all response measurements must be in a 

single response column. Sometimes, responses are recorded in multiple columns, where each 

row is a level of a design factor and each column is a level of a different design factor. Data in 

this format must be stacked before running the Measurement Systems Analysis platform. See 

Using JMP.
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Measurement Systems Analysis Report

The EMP Measurement Systems Analysis Study report contains a Measurement Systems 

Analysis report for each response column that was specified in the launch window. By default, 

each Measurement Systems Analysis report includes sections for the Average Chart and a 

dispersion chart. The dispersion chart type is specified in the launch window and is either a 

Range chart or a Standard Deviation chart.

• “Average Chart”

• “Dispersion Chart”

Average Chart

The Average Chart in the Measurement Systems Analysis platform plots the average 

measurement values for each combination of the part and X variables. This chart helps detect 

product variation despite measurement variation. In an Average Chart, out of control data is 

desirable because it indicates the ability of the measurement system to detect part-to-part 

variation.

The Average Chart red triangle menu contains the following options:

Show Grand Mean Shows or hides the overall mean of the Y variable on the chart.

Show Connected Means Shows or hides lines connecting the average measurement values.

Show Control Limits Shows or hides lines representing the Upper Control Limit (UCL) and 

the Lower Control Limit (LCL) and labels those values. The control limits for the Average 

Chart use the same calculations as an XBar control chart. See “Statistical Details for XBar 

and R Charts”.

Show Control Limits Shading Shows or hides shading between the UCL and LCL.

Show Separators Shows or hides vertical lines to delineate the X variables.

Show Data Shows or hides the data points on the chart. The y-axis rescales as needed to 

show all data points.

Tip: You can replace variables in the Average Chart in one of two ways: swap existing 

variables by dragging and dropping a variable from one axis to the other axis; or, click a 

variable in the Columns panel of the associated data table and drag it onto an axis.
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Dispersion Chart

The dispersion chart shown in the Measurement Systems Analysis platform is either a Range 

chart or a Standard Deviation chart. The Range chart plots the variability statistic for each 

combination of the part and X variables. The Standard Deviation chart plots the standard 

deviation statistic for each combination of the part and X variables. Both of these charts help 

you check for consistency within subgroups. In a Range or Standard Deviation chart, data 

within limits is desirable, indicating homogeneity in your error.

The Range Chart or Standard Deviation Chart red triangle menu contains the following 

options:

Show Average Dispersion Shows or hides the average range or standard deviation on the 

chart.

Show Connected Points Shows or hides lines connecting all of the ranges or standard 

deviations.

Show Control Limits Shows or hides lines representing the Upper Control Limit (UCL) and 

the Lower Control Limit (LCL) and labels those values. For more information about the 

calculations of the limits used in the Range Chart, see “Statistical Details for XBar and R 

Charts”. For more information about the calculations of the limits used in the Standard 

Deviation Chart, see “Statistical Details for XBar and S Charts”.

Show Control Limits Shading Shows or hides shading between the UCL and LCL.

Show Separators Shows or hides vertical lines to delineate between the X variables.

Tip: You can replace variables in the Range or Standard Deviation Charts in one of two ways: 

swap existing variables by dragging and dropping a variable from one axis to the other axis; 

or, click a variable in the Columns panel of the associated data table and drag it onto an axis.

Measurement Systems Analysis Platform Options

The EMP Measurement Systems Analysis Study red triangle menu contains the following 

options:

Save Shows a submenu of the following options:

Save Metadata as Column Properties (Not available if a By variable is specified in the 

launch window.) Provides the following options to save the metadata as column 

properties in the original data table.

• You can save the metadata as MSA column properties.
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• You can compute and save the measurement sigma in the Process Screening 

column property. The measurement sigma is the square root of the total of all 

variance components subtracted by the part variance.

• You can save the lower and upper tolerance values as Spec Limits column 

properties.

Save All Metadata to Table Saves a new data table that contains the MSA metadata for 

each column. This includes the measurement sigma, which is used in the Process 

Screening platform. The measurement sigma is the square root of the total of all 

variance components subtracted by the part variance. If there is a By variable, a table is 

saved for the corresponding level of the By variable and the table name includes the 

level.

Edit MSA Metadata Opens a window that enables you to add or edit the tolerance range, 

tolerance limits, historical mean, and historical process sigma for all analyses. See 

“Show MSA Metadata Entry Dialog”.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Measurement Systems Analysis Report Options

Each Measurement Systems Analysis report red triangle menu contains the following options:

Average Chart Shows or hides a plot of the average measurement values for each 

combination of the part and X variables. See “Average Chart”.
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Range Chart (Available only when Range is the Chart Dispersion Type selected in the 

launch window.) Shows or hides a plot of the variability statistic for each combination of 

the part and X variables. See “Dispersion Chart”.

Std Dev Chart (Available only when Standard Deviation is the Chart Dispersion Type 

selected in the launch window.) Shows or hides a plot of the standard deviation statistic 

for each combination of the part and X variables. See “Dispersion Chart”.

Parallelism Plots Shows or hides an overlay plot that reflects the average measurement 

values for each part. If the lines are relatively not parallel or crossing, there might be an 

interaction between the part and X variables.

Tip: Interactions indicate a serious issue that requires further investigation. For example, 

interactions between parts and operators mean that operators are measuring different 

parts differently, on average. Therefore, measurement variability is not predictable. This 

issue requires further investigation to find out why the operators do not have the same 

pattern or profile over the parts.

EMP Results Shows or hides a report that computes several statistics to help you assess and 

classify your measurement system. See “EMP Results Report”.

Effective Resolution Shows or hides a table containing results for the resolution of a 

measurement system, which helps you determine how well your measurement increments 

are working. In the table, the Current Measurement Increment reflects how many digits 

you are currently rounding to. This is taken from the data as the nearest power of ten. This 

number is compared to the Smallest Effective Increment, Lower Bound Increment, and 

Largest Effective Increment. Based on that comparison, a recommendation is made as to 

whether your current increments are effective as is or if any adjustments should be made.

Note: Large measurement increments have less uncertainty in the last digit, but large 

median errors. Small measurement increments have small median errors, but more 

uncertainty in the last digit.

Bias Comparison Shows or hides an Analysis of Means chart for testing if the X variables 

have different averages. See “Bias Comparison Report”.

Test-Retest Error Comparison Shows or hides an Analysis of Means for Variances or 

Analysis of Means Ranges chart for testing if any of the groups have different test-retest 

error levels. This chart shows if there are differences in the test-retest error between 

operators. The Analysis of Mean Ranges chart is displayed when ranges are used for 

variance components.

– For information about the options in the red triangle menu next to Operator Variance 

Test, see “Bias Comparison Report”.
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– For more information about Analysis of Means for Variances charts, see “Variance 

Components”.

Shift Detection Profiler Shows or hides an interactive set of charts that you can adjust to see 

the probabilities of getting warnings on your process behavior chart. See “Shift Detection 

Profiler”.

Variance Components Shows or hides a report containing the estimates of the variance 

components for the given model. The calculations in this report are based on variances, 

not ranges. Balanced data uses the EMS method. Unbalanced data uses the REML method.

Note: This report is similar to the Variance Components report in the Variability Chart 

platform, except that it does not compute Bayesian variance component estimates. See 

“Variance Components”.

EMP Gauge R&R Results Shows or hides a report that partitions the variability in the 

measurements into part variation and measurement system variation. The calculations in 

this report are based on variances, not ranges. Because negative variance components are 

set to zero, values of zero could indicate outliers in your results.

Note: This report is similar to the Gauge R&R report in the Variability Chart platform. 

However, by default, the calculation for Reproducibility does not include interactions. To 

specify that interactions be included in the Reproducibility calculation, select the Include 

Interactions in Reproducibility platform preference. This preference is located in File > 

Preferences > Platforms > EMP Measurement Systems Analysis. For more information 

about Gauge R&R studies, see “About the Gauge R&R Method”.

AIAG Gauge R&R Results Shows or hides a report that partitions the variability in the 

measurements into part variation and measurement system variation. The calculation for 

Reproducibility includes interactions. This report is the same as the Gauge R&R report in 

the Variability Chart platform. See “Gauge R&R Report”. The AIAG Gauge R&R Results 

red triangle menu contains the following options:

AIAG Labels Shows or hides the column of labels in the AIAG Gauge R&R Results report 

defined by the Automotive Industry Action Group (AIAG).
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Discrimination Ratio Adds the Discrimination Ratio to the Summary and Gauge R&R 

Statistics section of the AIAG Gauge R&R Results report. The discrimination ratio 

compares the total variance of the measurement with the variance of the measurement 

error and characterizes the relative usefulness of a given measurement for a specific 

product. Generally, when the discrimination ratio is less than 2, the measurement 

cannot detect product variation, implying that the measurement process needs 

improvement. A discrimination ratio greater than 4 adequately detects unacceptable 

product variation, implying that the production process needs improvement. See 

“Statistical Details for the Discrimination Ratio”.

Misclassification Probabilities (Available only if lower and upper tolerance values are 

specified for the response in the MSA Metadata.) Shows or hides a report of probabilities 

for rejecting good parts and accepting bad parts. See “Misclassification Probabilities”.

Linearity and Bias Results (Available only if a Standard column is specified in the launch 

window.) Shows or hides a graph and summary from a regression analysis using the 

standard column as the X variable and the bias as the Y variable. This analysis examines 

the relationship between bias and the size of the part. A nonzero slope indicates that your 

gauge performs differently with different sized parts. See “Linearity and Bias Results 

Report”.

Edit MSA Metadata Opens a window that enables you to add or edit the tolerance range, 

tolerance limits, historical mean, and historical process sigma. See “Show MSA Metadata 

Entry Dialog”.

EMP Results Report

In the Measurement Systems Analysis platform, the EMP Results report computes several 

statistics to help you assess and classify your measurement system. Using this report, you can 

determine the following:

• How your process chart is affected.

• Which tests to set.

• How much the process signal is attenuated.

• How much the bias factors are affecting your system and reducing your potential 

intraclass correlation coefficient.

Note: The statistics in this report are based on ranges in the following instances: if you 

selected EMP as the MSA Method and Range as the Chart Dispersion Type, and you have a 

one factor or a two factor, balanced, crossed model. Otherwise, the statistics in this report are 

based on variances.
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The EMP Results report contains the following calculations:

Test-Retest Error Indicates measurement variation or repeatability (also known as within 

error or pure error).

Degrees of Freedom Indicates the amount of information used to estimate the within error.

Probable Error The median error for a single measurement. Indicates the resolution quality 

of your measurement and helps you decide how many digits to use when recording 

measurements. See “Shift Detection Profiler”.

Intraclass Correlation Indicates the proportion of the total variation that you can attribute to 

the part. If you have very little measurement variation, this number is closer to 1.

Intraclass Correlation (no bias) Does not take bias or interaction factors into account 

when calculating the results.

Intraclass Correlation (with bias) Takes the bias factors (such as operator, instrument, 

and so on) into account when calculating the results.

Intraclass Correlation (with bias and interaction) Takes the bias and interaction factors 

into account when calculating the results. This calculation appears only if the model is 

crossed and uses standard deviation instead of range.

Bias Impact The amount by which the bias factors reduce the Intraclass Correlation.

Bias and Interaction Impact The amount by which the bias and interaction factors reduce 

the Intraclass Correlation. This calculation appears only if the model is crossed and uses 

standard deviation instead of range.

Monitor Classification Legend

The EMP Results report contains a Monitor Classification Legend, which describes the system 

and classification parameters in the Measurement Systems Analysis platform.

Figure 4.6  Monitor Classification Legend
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This legend describes the following classifications: First, Second, Third, and Fourth Class. 

Each classification indicates the following:

• the corresponding Intraclass Correlation values

• the amount of process signal attenuation (decrease)

• the chance of detecting a 3 standard error shift within 10 subgroups, using Wheeler’s test 

one or all four tests

Wheeler (2006) identifies four detection tests known as the Western Electric Zone Tests. Within 

the Shift Detection Profiler, there are eight tests that you can select from. The tests that 

correspond to the Wheeler tests are the first, second, fifth, and sixth tests.

Tip: To prevent the legend from appearing, deselect Show Monitor Classification Legend in 

the EMP Measurement Systems Analysis platform preferences.

Shift Detection Profiler

Use the Shift Detection Profiler in the Measurement Systems Analysis platform to assess the 

sensitivity of the control chart that you use to monitor your process. The Shift Detection 

Profiler estimates the probability of detecting shifts in the product mean or product standard 

deviation. The control chart limits include sources of measurement error variation. Based on 

these limits, the Shift Detection Profiler estimates the Probability of Warning. This is the 

probability that a control chart monitoring the process mean signals a warning over the next k 

subgroups.

You can set the subgroup size that you want to use for your control chart. Note the following:

• If the Subgroup Size equals one, the control chart is an Individual Measurement chart.

• If the Subgroup Size exceeds one, the control chart is an XBar-chart.

You can explore the effect of Subgroup Size on the control chart’s sensitivity. You can also 

explore the benefits of reducing bias and test-retest error.

Figure 4.7 shows the Shift Detection Profiler report for the Gasket.jmp sample data table, 

found in the Variability Data folder.
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Figure 4.7  Shift Detection Profiler for Gasket.jmp

Probability of Warning

The Probability of Warning is the probability of detecting a change in the process. A change is 

defined by the Part Mean Shift and the Part Std Dev settings in the Shift Detection Profiler. The 

probability calculation assumes that the tests selected in the Customize and Select Tests 

outline are applied to the Number of Subgroups specified in the Profiler.

The control limits for the Individual Measurement chart (Subgroup Size = 1) and the 

XBar-chart (Subgroup Size > 1) are based on the In-Control Chart Sigma. The In-Control 

Sigma takes into account the bias factor (reproducibility) variation and the test-retest 

(repeatability) variation. These are initially set to the values obtained from your MSA study. 

The In-Control Chart Sigma also incorporates the In-Control Part Std Dev. Both of these values 

appear beneath the profiler, along with the False Alarm Probability, which is based on the 

In-Control Chart Sigma.
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In-Control Part Std Dev The standard deviation for the true part values, exclusive of 

measurement errors, for the stable process. The default value for In-Control Part Std Dev is 

the standard deviation of the part component estimated by the MSA analysis and found in 

the Variance Components report.

Often, parts for an MSA study are chosen to have specific properties and do not 

necessarily reflect the part-to-part variation seen in production. For this reason, you can 

specify the in-control part standard deviation by selecting Change In-Control Part Std Dev 

from the Shift Detection Profiler red triangle menu.

In-Control Chart Sigma The value of sigma used to compute control limits. This value is 

computed using the In-Control Part Std Dev, the Bias Factors Std Dev, and Test-Retest Std 

Dev specified in the Shift Detection Profiler, and the Subgroup Size. The reproducibility 

factors are assumed to be constant within a subgroup.

For a subgroup of size n, control limits are set at the following values:

It follows that the In-Control Chart Sigma is the square root of the sum of the squares of 

the following terms:

– In-Control Part Std Dev

– Bias Factors Std Dev, as specified in the Shift Detection Profiler, multiplied by

– Test-Retest Std Dev, as specified in the Shift Detection Profiler

The Bias Factors Std Dev is multiplied by  to account for the assumption that the 

reproducibility factors are constant within a subgroup.

JMP updates the In-Control Chart Sigma when you change the In-Control Part Std Dev, 

the Bias Factors Std Dev, the Test-Retest Std Dev, or the Subgroup Size.

False Alarm Probability The probability that the control chart tests signal a warning when no 

change in the part mean or standard deviation has occurred. JMP updates the False Alarm 

Probability when you change the Number of Subgroups or the tests in Customize and 

Select Tests.

For more information about the Variance Components report, see “Variance Components”.

Shift Detection Profiler Settings

Number of Subgroups The number of subgroups over which the probability of a warning is 

computed. If the number of subgroups is set to k, the profiler gives the probability that the 

control chart signals at least one warning based on these k subgroups. The Number of 

Subgroups is set to 10 by default. Drag the vertical line in the plot to change the Number of 

Subgroups.

3 In-Control Chart Sigma  n 

n

n
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Part Mean Shift The shift in the part mean. By default, the profiler is set to detect a 1 sigma 

shift. The initial value is the standard deviation of the part component estimated by the 

MSA analysis and found in the Variance Components report. Drag the vertical line in the 

plot or click the value beneath the plot to change the Part Mean Shift.

Part Std Dev The standard deviation for the true part values, exclusive of measurement 

errors. The initial value for Part Std Dev is the standard deviation of the part component 

estimated by the MSA analysis and is found in the Variance Components report. Drag the 

vertical line in the plot or click the value beneath the plot to change the Part Std Dev.

Bias Factors Std Dev The standard deviation of factors related to reproducibility. Bias 

factors include operator and instrument. The bias factor variation does not include part 

and repeatability (within) variation. The initial value is derived using the reproducibility 

and interaction variance components estimated by the MSA analysis and is found in the 

Variance Components report. Drag the vertical line in the plot or click the value beneath 

the plot to change the Bias Factors Std Dev.

Test-Retest Std Dev The standard deviation of the test-retest, or repeatability, variation in 

the model. The initial value is the standard deviation of the Within component estimated 

by the MSA analysis and is found in the Variance Components report. Drag the vertical 

line in the plot or click the value beneath the plot to change the Test-Retest Std Dev.

Subgroup Size The sample size used for each subgroup. This is set to 1 by default. You can 

increase the sample size to investigate improvement in control chart performance. 

Increasing the sample size from 1 demonstrates what happens when you move from an 

Individual Measurement chart to an XBar-chart. Drag the vertical line in the plot to change 

the Subgroup Size.

Shift Detection Profiler Options

The red triangle menu for the Shift Detection Profiler provides several options.

Change In-Control Part Std Dev Specify a value for the part standard deviation for the 

stable process. The in-control part standard deviation should reflect the variation of the 

true part values, exclusive of measurement errors. Enter a new value and click OK.

The In-Control Part Std Dev is originally set to the standard deviation of the part 

component estimated by the MSA analysis, found in the Variance Components report.

This option is useful if the parts chosen for the EMP study were not a random sample from 

the process.

Reset Factor Grid Displays a window for each factor allowing you to enter a specific value 

for the factor’s current setting, to lock that setting, and to control aspects of the grid. See 

Profilers.
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Factor Settings Submenu that consists of the following options:

Remember Settings Adds an outline node to the report that accumulates the values of 

the current settings each time the Remember Settings command is invoked. Each 

remembered setting is preceded by a radio button that is used to reset to those settings. 

There are options to remove selected settings or all settings in the Remember Settings 

red triangle menu.

Copy Settings Script Copies the current Profiler’s settings to the clipboard.

Paste Settings Script Pastes the Profiler settings from the clipboard to a Profiler in 

another report.

Set Script Sets a script that is called each time a factor changes. The set script receives a 

list of arguments of the form:

{factor1 = n1, factor2 = n2, ...}

For example, to write this list to the log, first define a function:

ProfileCallbackLog = Function({arg},show(arg));

Then enter ProfileCallbackLog in the Set Script dialog.

Similar functions convert the factor values to global values:

ProfileCallbackAssign = Function({arg},evalList(arg));

Or access the values one at a time:

ProfileCallbackAccess = 
Function({arg},f1=arg["factor1"];f2=arg["factor2"]);

Shift Detection Profiler Legend

This panel gives a brief description of four of the Shift Detection Profiler settings. See “Shift 

Detection Profiler Settings”.

Tip: To prevent the legend from appearing, deselect Show Shift Detection Profiler Legend in 

the EMP Measurement Systems Analysis platform preferences.

Customize and Select Tests

In the Customize and Select Tests panel, select and customize the tests that you want to apply 

to the k subgroups in your control chart. The eight tests are based on Nelson (1984). For more 

information about the tests, see “Tests”.
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The Shift Detection Profiler calculations take these tests into account. The Probability of 

Warning and False Alarm Probability values increase as you add more tests. Because the 

calculations are based on a quasi-random simulation, there might be a slight delay as the 

profiler is updated.

The Customize and Select Tests panel has the following options:

Restore Default Settings If no settings have been saved to preferences, this option resets the 

selected tests to the first test only. The values of n are also reset to the values described in 

“Tests”. If settings have been saved to preferences, this option resets the selected tests and 

the values of n to those specified in the preferences.

Note: You can access preferences for control chart tests by selecting File > Preferences > 

Platforms > Control Chart Builder. Custom Tests 1 through 8 correspond to the eight tests 

shown in Customize and Select Tests.

Save Settings to Preferences Saves the selected tests and the values of n for use in future 

analyses. These preferences are added to the Control Chart Builder platform preferences.

Bias Comparison Report

In the Measurement Systems Analysis platform, the Bias Comparison option creates an 

Analysis of Means chart. This chart shows the mean values for each level of the grouping 

variables and compares them with the overall mean. You can use this chart to see whether an 

operator is measuring parts too high or too low, on average.

The red triangle menu next to Analysis of Means contains the following options:

Set Alpha Level Select an option from the most common alpha levels or specify any level 

using the Other selection. Changing the alpha level modifies the upper and lower decision 

limits.

Show Summary Report Shows a report containing group means and decision limits, and 

reports if the group mean is above the upper decision limit or below the lower decision 

limit.

Display Options Include the following options:

Show Decision Limits Draws lines representing the Upper Decision Limit (UDL) and the 

Lower Decision Limit (LDL) and defines those values.

Show Decision Limit Shading Adds shading between the UDL and the LDL.

Show Center Line Draws the center line statistic that represents the average.

Point Options Changes the chart display to needles, connected points, or points.
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Linearity and Bias Results Report

In the Measurement Systems Analysis platform, the Linearity and Bias Results report contains 

a plot and a table for each of the following:

• Bias summary statistics and t test results for each standard value and the overall value.

• Results from an ANOVA test that tests if the slope of the line is equal to zero.

• The parameter estimates and tests for the intercept and the slope. The intercept tests the 

bias and the slope tests the linearity. The test for the intercept is useful only if the test on 

the slope fails to reject the hypothesis that the slope is equal to 0.

• Linearity and Bias summary statistics. This table is shown only if you specify values for 

the sigma multiplier and the historical process sigma. The sigma multiplier is specified in 

the launch window. There are several ways to specify the historical process sigma.

– Prior to analysis, you can assign the MSA column property to the response and specify 

the historical process sigma in the column property.

– In the launch window, you can specify the historical process sigma by selecting the 

Show MSA Metadata Entry Dialog.

– In the report window, you can click the Measurement Systems Analysis red triangle 

and select Edit MSA Metadata.

– You can directly specify the historical process sigma in a script.

The Linearity and Bias Results red triangle menu contains the following options:

Show Bias Points Shows or hides the bias points on the graph.

Show Line of Fit Shows or hides the line of fit on the graph.

Show Fit Confidence Curves Shows or hides the line of fit confidence curves on the graph.

Show Overall Avg Bias Line Shows or hides the overall average bias line on the graph.

Show Avg Bias Points Shows or hides the average bias points on the graph.

Additional Examples of Measurement Systems 
Analysis

This section contains examples using the Measurement Systems Analysis platform.

• “Example of a Nested Measurement Systems Analysis”

• “Example of a Detailed Measurement Systems Analysis”
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Example of a Nested Measurement Systems Analysis

Examine the Data

1. Select Help > Sample Data Folder and open Variability Data/2 Factors Nested.jmp.

2. Select Analyze > Distribution.

3. Select Operator and Part and click Y, Columns.

4. Click OK.

Figure 4.8  Distribution of Operator and Part

If you click various bars in the histograms, you can see that each level of Part is only 

associated with one of the operators. This is how you can tell that Part is nested within 

Operator.

Perform the Analysis

1. Select Analyze > Quality and Process > Measurement Systems Analysis.

2. Select Y and click Y, Response.

3. Select Part and click Part, Sample ID.

4. Select Operator and click X, Grouping.

5. In the Chart Dispersion Type section, select Range.

6. In the Model Type section, select Nested.

7. Click OK.

8. Click the red triangle next to Measurement Systems Analysis for Y and select AIAG Gauge 
R&R Results.
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Figure 4.9  Gauge R&R Results for Nested Analysis

The portion of variation that comes from the measurement is quite high. In the Summary 

and Gauge R&R Statistics report, the % Gauge R&R is 85.516%. Since an acceptable 
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measurement system typically has a % Gauge R&R of less than 30%, this measurement 

system can be classified as unacceptable.

9. (Optional) Click the red triangle next to Average Chart and select Show Data to add the 

observations to the Average Chart. This helps to visualize the variability within part 

measurements that this analysis is highlighting.

Example of a Detailed Measurement Systems Analysis

In this example, three operators have measured a single characteristic twice on each of six 

wafers. Use the Measurement Systems Analysis platform to conduct a detailed analysis to 

determine how well a measurement system is performing.

Perform the Initial Analysis

1. Select Help > Sample Data Folder and open Variability Data/Wafer.jmp.

2. Select Analyze > Quality and Process > Measurement Systems Analysis.

3. Assign Y to the Y, Response role.

4. Assign Wafer to the Part, Sample ID role.

5. Assign Operator to the X, Grouping role.

6. Select Standard Deviation as the Chart Dispersion Type.

Notice that the MSA Method is set to EMP and confirm that the Model Type is set to 

Crossed.

7. Click OK.
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Figure 4.10  Average and Range Charts

The Average Chart shows that some of the average part measurements fall beyond the control 

limits. This is desirable, indicating measurable part-to-part variation.

The Standard Deviation Chart shows no points that fall beyond the control limits. This is 

desirable, indicating that the operator measurements are consistent within part.

Examine Interactions

Take a closer look for interactions between operators and parts. Click the red triangle next to 

Measurement Systems Analysis for Y and select Parallelism Plots.
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Figure 4.11  Parallelism Plot

Looking at the parallelism plot by operator, you can see that the lines are relatively parallel 

and that there is only some minor crossing.

Examine Operator Consistency

Take a closer look at the variance between operators. Click the red triangle next to 

Measurement Systems Analysis for Y and select Test-Retest Error Comparison.

Figure 4.12  Test-Retest Error Comparison

Looking at the Test-Retest Error Comparison, you can see that none of the operators have a 

test-retest error that is significantly different from the overall test-retest error. The operators 

appear to be measuring consistently.
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Just to be sure, you decide to look at the Bias Comparison chart, which indicates whether an 

operator is measuring parts too high or too low. Click the red triangle next to Measurement 

Systems Analysis for Y and select Bias Comparison.

Figure 4.13  Bias Comparison

Looking at the Bias Comparison chart, you make the following observations:

• Operator A and Operator B have detectable measurement bias, as they are significantly 

different from the overall average.

• Operator A is significantly biased low.

• Operator B is significantly biased high.

• Operator C is not significantly different from the overall average.

Classify Your Measurement System

Examine the EMP Results report to classify your measurement system and look for 

opportunities for improvement. Click the red triangle next to Measurement Systems Analysis 

for Y and select EMP Results.
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Figure 4.14  EMP Results

The classification is Second Class, which means that there is a better than 88% chance of 

detecting a three standard error shift within ten subgroups, using Test one only. You notice 

that the bias factors have an 13% impact on the Intraclass Correlation. In other words, if you 

could eliminate the bias factors, your Intraclass Correlation coefficient would improve by 13%.

Explore the Ability of a Control Chart to Detect Process Changes

Use the Shift Detection Profiler to explore the probability that a control chart will be able to 

detect a change in your process. Click the red triangle next to Measurement Systems Analysis 

for Y and select Shift Detection Profiler.
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Figure 4.15  Shift Detection Profiler

By default, the only test selected is for a point beyond the 3 sigma limits. Also note that the 

default Subgroup Size is 1, indicating that you are using an Individual Measurement chart.

Explore your ability to detect a shift in the mean of two part standard deviations in the 10 

subgroups following the shift. Click the Part Mean Shift value of 2.1701 and change it to 4.34 

(2.17 multiplied by 2). The probability of detecting a shift of twice the part standard deviation 

is 56.9%.

Next, see how eliminating bias affects your ability to detect the shift of two part standard 

deviations. Change the Bias Factors Std Dev value from 1.1256 to 0. The probability of 

detecting the shift increases to 67.8%.

Finally, add more tests to see how your ability to detect the two part standard deviation shift 

changes. In addition to the first test, select the second, fifth, and sixth tests (Wheeler’s Rules 4, 

2, and 3). With these four tests and no bias variation, your probability of detecting the shift is 

99.9%.

You can also explore the effect of using a control chart based on larger subgroup sizes. For 

subgroup sizes of two or more, the control chart is an XBar-chart. Change the Bias Factors 
Std Dev value back to 1.1256 and deselect all but the first test. Set the Subgroup Size in the 

profiler to 4. The probability of detecting the two part standard deviation shift is 98.5%.
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Examine Measurement Increments

Finally, see how well your measurement increments are working. Click the red triangle next to 

Measurement Systems Analysis for Y and select Effective Resolution.

Figure 4.16  Effective Resolution

The Current Measurement Increment of 0.01 is below the Lower Bound Increment of 0.08, 

indicating that you should adjust your future measurements to record one less digit.

Statistical Details for Measurement Systems 
Analysis

For more information about the calculations of the limits used in the Range Chart, see 

“Statistical Details for XBar and R Charts”. For more information about the calculations of the 

limits used in the Standard Deviation Chart, see “Statistical Details for XBar and S Charts”.

Statistical Details for Intraclass Correlation and Probable Error

This section contains computational details for statistics in the Measurement Systems Analysis 

platform.

Intraclass Correlation without bias is computed as follows:

rpe

̂p
2

̂p
2 ̂pe

2+
----------------------=



Chapter 4 Measurement Systems Analysis 141
Quality and Process Methods Statistical Details for Measurement Systems Analysis

Intraclass Correlation with bias is computed as follows:

Intraclass Correlation with bias and interaction factors is computed as follows:

Probable Error is computed as follows:

Note the following:

 = variance estimate for pure error

 = variance estimate for product

 = variance estimate for bias factors

 = variance estimate for interaction factors

Z0.75 = the 75% quantile of standard normal distribution
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Chapter 5
Type 1 Gauge Analysis

Evaluate a Continuous Measurement Process Using the Type 1 Method

A Type 1 Gauge analysis is a measurement systems analysis that determines whether a 

measurement system, or gauge, is repeatable. Specifically, the analysis determines if a 

measurement system can repeatedly measure a part and obtain measurements that are close 

to a known reference standard.

The Type 1 Gauge platform produces a run chart, histogram, and metrics such as Cg and CgK 

that are useful in assessing gauge repeatability.

Figure 5.1  Example of a Type 1 Gauge Analysis
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Example of Type 1 Gauge Analysis

Perform a Type 1 Gauge analysis to evaluate the repeatability of a measurement system.

1. Select Help > Sample Data Folder and open Variability Data/Type 1 Gauge MSA.jmp.

2. In the Columns section of the data table, click the asterisk next to Y1 and select MSA.

Figure 5.2  MSA Column Property

The Y1 column has an MSA column property, which contains metadata that is used in the 

Type 1 Gauge Analysis. The metadata includes tolerance specifications, the measurement 

resolution, and the reference value or the known value of the process quality variable. In 

this example, the reference value is 50.014.

3. Click Cancel to close the Column Info window.

4. Select Analyze > Quality and Process > Measurement Systems Analysis.

5. Ensure that the MSA Method is set to Type 1 Gauge.

6. In the Show Type 1 Gauge Metadata Entry Dialog, select If Needed.

7. Select Y1 and click Y, Response.
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8. Click OK.

9. Click the Run Chart red triangle and select Show Mean.

Figure 5.3  Type 1 Gauge Analysis for Y1 Report

The Run Chart shows that the mean of the observed measurements is close to the reference 

standard and all of the measurements are within the percent of tolerance*tolerance range. 

The run chart also shows the variability of the measurements. To understand the 

measurement variability, review the Summary and Capability Statistics table. The values 

for Cg and CgK are 1.399 and 1.323, respectively. These values are close to the ideal Cg and 

CgK values of 1.33 or greater. Therefore, this measurement system is considered to be 

repeatable.
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Launch the Type 1 Gauge Platform

Launch the Type 1 Gauge platform by selecting Analyze > Quality and Process > 
Measurement Systems Analysis. Set the MSA Method to Type 1 Gauge.

Figure 5.4  The Type 1 Gauge Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

The Type 1 Gauge window contains the following features:

Y, Response Specifies one or more columns of measurements. Specifying more than one Y 

column produces a separate analysis report for each response.

Freq Identifies a data table column whose values assign a frequency to each row. Can be 

useful when you have summarized data.

By Identifies a column that creates a report consisting of separate analyses for each level of 

the variable.

MSA Method Selects one of the following methods: EMP (Evaluating the Measurement 

Process), Gauge R&R, or Type 1 Gauge. This chapter covers the Type 1 Gauge method. For 

more information about the EMP method, see “Measurement Systems Analysis”. For more 

information about the Gauge R&R method, see “Variability Gauge Charts”.

Percent of Tolerance Specifies the percent of part tolerance used to compare against the 

measurement variation. The default value is 20%. The percent of tolerance value is used to 



148 Type 1 Gauge Analysis Chapter 5
Launch the Type 1 Gauge Platform Quality and Process Methods

calculate the portion of tolerance lines plotted on the Run Chart and certain statistics in the 

Summary and Capability Statistics table.

Sigma Multiplier Specifies a constant value that is multiplied by sigma. The default value is 

6, which means you are looking at 6*sigma or a 6 sigma process.

Specify Alpha Level Specifies the alpha level for the Bias Test. The default value is 0.05.

Show Type 1 Gauge Metadata Entry Dialog Specifies when the Type 1 Gauge Metadata 

dialog is shown after you click OK. This dialog enables you to load the metadata from a 

data table or enter the metadata for each column manually. When you enter the metadata 

manually, you can specify a tolerance range directly or specify lower and upper tolerance 

values. If you choose to enter lower and upper tolerance values, the tolerance range is 

calculated as the difference between the upper and lower tolerance values. If only one 

tolerance value is entered, the tolerance range cannot be calculated and any statistics in the 

report that rely on the tolerance range are not shown. The dialog also contains fields for 

the reference value and the gauge resolution. Specifying a value for the gauge resolution is 

optional, but the reference value is required. If a reference value is not entered for a 

response column, no Type 1 Gauge report is shown for that response column.

Note: This data can also be specified prior to launching by applying the MSA column 

property. You can apply the MSA column property to several measurement columns at 

once using Manage Limits. See “Manage Limits”.

If Needed Opens the Type 1 Gauge Metadata window if at least one of the response 

columns is missing the tolerance range (or upper and lower tolerance values) or 

reference value in the MSA column property.

Yes Opens the Type 1 Gauge Metadata window.

No Does not open the Type 1 Gauge Metadata window. Columns that do not contain a 

reference value in the MSA metadata column property are not included in the analysis 

report.

Use Spec Limits for Tolerance if Needed If a tolerance range is not specified for a column, 

but the column has a Spec Limits column property, this option uses the specification limits 

to calculate the tolerance range.

Data Format

The data for a Type 1 Gauge analysis should consist of measurements from the same part 

taken by the same operator. A known reference standard value must be defined in the MSA 

metadata. Enter metadata in the MSA column property or through the Type 1 Gage Metadata 

Entry Dialog accessible through the Type 1 launch window.
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The Type 1 Gauge Study Report

The Type 1 Gauge Study report contains a Type 1 Gauge Analysis report for each 

measurement column that was specified in the launch window. The column name is included 

in the title of each analysis report. By default, each Type 1 Gauge Analysis report contains a 

run chart of measurements and a table of summary and capability statistics.

• “Run Chart”

• “Summary and Capability Statistics Table”

Run Chart

In the Type 1 Gauge Analysis report, the run chart of measurements includes horizontal lines 

at the reference value and upper and lower tolerances. The tolerances are based on the 

reference standard value (Ref), percent of tolerance value (p), and the tolerance range (Tol) 

and are calculated as follows:

Portion of Tolerance = Ref  0.5p*Tol

The Run Chart red triangle menu contains the following options:

Show Portion of Tolerance Shows or hides the portion of tolerance lines on the run chart. If 

a tolerance range is given or calculated, the portion of tolerance is shown by default.

Show Reference Shows or hides the reference value on the run chart. The reference value is 

shown by default.

Show Mean Shows or hides the mean on the run chart.

Summary and Capability Statistics Table

In the Type 1 Gauge Analysis report, the Summary and Capability Statistics table contains 

statistics to determine the repeatability of the measurement system.

Note: Statistics that involve the tolerance range (Tol) are included only if a tolerance range is 

specified in the MSA metadata prior to the analysis.

Reference (Ref) The reference standard value defined in the MSA metatdata.

Mean The mean of the observed measurements.

Std Dev The standard deviation, , of the observed measurements.

k*Std Dev The sigma multiplier, defined in the launch, multiplied by Std Dev.
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N The number of observed measurements.

Tolerance Range (Tol) The tolerance range.

Ref - (p/2)*Tol The lower portion of tolerance value that is shown on the Run Chart.

Ref + (p/2)*Tol The upper portion of tolerance value that is shown on the Run Chart.

Cg A measure of how well the variation of the measurements fits into the specified tolerance 

range. A common threshold for a good measurement system is a Cg value of 1.33 or 

greater. Cg is calculated as follows:

Cgk A measurement that is similar to the Cg value calculation, but also takes the bias into 

account. A common threshold for a good measurement system is a Cgk value of 1.33 or 

greater. Cgk is calculated as follows:

% Var for Repeatability The percent of the tolerance range that is consumed by k. Higher 

values indicate more measurement variability in the system. The % Var for Repeatability is 

calculated as follows:

% Var for Repeatability = (pCg)  

% Var for Repeatability and Bias A measurement that is similar to the % Var for 

Repeatability, but also takes the bias into account. The % Var for Repeatability and Bias is 

calculated as follows:

% Var for Repeatability and Bias = (pCgk)  

Bias The difference between the mean and the reference standard value.

Bias/Tol % The percent bias value, which is calculated as follows:

Resolution (Res) The smallest resolution that your measurement device is capable of 

reporting.

Res/Tol % The percent resolution value, which is calculated as follows:

Cg
p Tol
k 
----------------=

Cgk
p 2  Tol Mean Ref––

k 2  
------------------------------------------------------------------=

Bias
Tol
-------------- 100
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Type 1 Gauge Study Options

The Type 1 Gauge Study red triangle menu contains the following options:

Save Shows a submenu of the following options:

Save Type 1 Gauge Metadata as Column Properties Saves the Type 1 Gauge metadata 

as MSA column properties in the data table.

Save Type 1 Gauge Metadata to Table Saves a new data table that contains the Type 1 

Gauge metadata for each column.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Type 1 Gauge Analysis Report Options

Each Type 1 Gauge Analysis report red triangle menu contains the following options:

Summary and Capability Statistics Shows or hides the Type 1 Gauge Summary and 

Capability Statistics table for the corresponding response. See “Summary and Capability 

Statistics Table”.

Res
Tol
------------ 100
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Run Chart Shows or hides the run chart of the measurement data for the corresponding 

response. See “Run Chart”.

Bias Test Shows or hides the results from the bias test. This is a two-sided t test that tests the 

mean of the observed measurements against the reference standard.

Histogram Shows or hides a histogram of the measurement data. This is useful for checking 

the normality of the measurements. The Histogram red triangle menu contains the 

following options:

Show Reference Shows or hides a reference line of the reference standard value on the 

histogram. There reference line is shown by default.

Show Count Axis Shows or hides a count axis to the right of the histogram frame.
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Variability Gauge Charts

Evaluate a Continuous Measurement Process Using Gauge R&R

Variability gauge charts analyze continuous measurements and can reveal how your 

measurement system is performing. You can also perform a gauge study to see measures of 

variation in your data.

Tip: This chapter covers only variability charts. For more information about attribute charts, 

see “Attribute Gauge Charts”.

Figure 6.1  Example of a Variability Chart
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Overview of Variability Charts

Just as a control chart shows variation across time in a process, a variability chart shows the 

same type of variation across categories such as parts, operators, repetitions, and instruments. 

A variability chart plots the data and means for each level of grouping factors, with all plots 

side by side. Along with the data, you can view the mean, range, and standard deviation of 

the data in each category, seeing how they change across the categories. The report options are 

based on the assumption that the primary interest is how the mean and variance change 

across the categories.

Variability charts are commonly used for measurement systems analysis such as Gauge R&R. 

This analysis examines how much of the variability is due to operator variation 

(reproducibility) and measurement variation (repeatability). Gauge R&R is available for many 

combinations of crossed and nested models, regardless of whether the model is balanced.

Tip: The traditional name for a variability chart is a multi vari chart, but because that name is 

not well known, the more generic term variability chart is used instead.
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Example of a Variability Chart

In this example, you want to identify the variation between three operators that each took 

three measurements of ten parts.

1. Select Help > Sample Data Folder and open Variability Data/2 Factors Crossed.jmp.

2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.

3. For Chart Type, select Variability.

4. Select Measurement and click Y, Response.

5. Select Operator and click X, Grouping.

6. Select part# and click Part, Sample ID.

7. Click OK.

8. Click the Variability Gauge Analysis for Measurement red triangle and select Show Group 
Means and Connect Cell Means.

Figure 6.2  Example of a Variability Chart
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Looking at the Std Dev chart, you can see that Cindy and George have more variation in their 

measurements than Tom, who appears to be measuring parts the most consistently. George 

seems to have the most variation in his measurements, so he might be measuring parts the 

most inconsistently.

Launch the Variability Gauge Chart Platform

Launch the Variability Chart platform by selecting Analyze > Quality and Process > 
Variability/Attribute Gauge Chart. Set the Chart Type to Variability.

Figure 6.3  The Variability Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Chart Type Choose between a variability gauge analysis (for a continuous response) or an 

attribute gauge analysis (for a categorical response, usually “pass” or “fail”).

Note: The content in this chapter covers only the Variability chart type. For more 

information about the Attribute chart type, see “Attribute Gauge Charts”.

Model Type Choose the model type (Main Effect, Crossed, Nested, Crossed then Nested or 

Nested then Crossed). See “Statistical Details for Variance Components”.
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Options Contains the following options:

Sigma Multiplier Specifies the sigma multiplier used in the analyses. The default value is 

6.

Specify Alpha Level Specifies the significance level used in the analyses.

Set Random Seed Enables you to set a specific random seed.

Analysis Settings Enables you to specify the method for computing variance 

components. See “Analysis Settings”.

Show MSA Metadata Entry Dialog Specifies if the MSA Metadata dialog is shown after you 

click OK. This dialog enables you to load the metadata from a data table or enter the 

metadata for each column manually. Use the following options to enter the metadata 

manually:

Choose Tolerance Entry Type Choose to enter the tolerance range directly or specify the 

lower and upper tolerance values. If you choose to enter lower and upper tolerance 

values, the tolerance range is calculated as the difference between the upper and lower 

tolerance values. If only one tolerance value is entered, the tolerance range cannot be 

calculated and any statistics in the report that rely on the tolerance range are not 

shown.

Tolerance Range Specifies the tolerance for the process, which is the difference between 

the upper specification limits and the lower specification limits.

Lower Tolerance Specifies the lower tolerance limit. This is used to calculate the 

tolerance range if it is not specified directly.

Upper Tolerance Specifies the upper tolerance limit. This is used to calculate the 

tolerance range if it is not specified directly.

Historical Mean Specifies a historical mean. The historical mean is used to compute 

tolerance ranges for one-sided specification limits, either USL-Historical Mean or 

Historical Mean-LSL. If you do not enter a historical mean, the grand mean is used.

Historical Process Sigma Specifies a historical process sigma. This value is used for 

calculations in the Gauge R&R Report and the Linearity Study.

Tip: This data can also be specified prior to launching by applying the MSA column 

property. You can apply the MSA column property to several measurement columns at 

once using Manage Limits. See “Manage Limits”.

Use spec limits for lower and upper tolerance If a tolerance range is not specified for a 

column, but the column has a Spec Limits column property, this option uses the 

specification limits to calculate the tolerance range.
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Y, Response Specifies the measurement column. Specifying more than one Y column 

produces a separate variability chart for each response.

Standard Specifies a standard or reference column that contains the “true” or known values 

for the measured part. Including this column enables the Bias and Linearity Study options. 

These options perform analysis on the differences between the observed measurement and 

the reference or standard value. See “Bias Report” and “Linearity Study”.

X, Grouping Specify the classification columns that group the measurements. If the factors 

form a nested hierarchy, specify the higher terms first. If you are doing a gauge study, 

specify the operator first and then the part.

Freq Identifies the data table column whose values assign a frequency to each row. Can be 

useful when you have summarized data.

Part, Sample ID Identifies the part or sample that is being measured.

By Identifies a column that creates a report consisting of separate analyses for each level of 

the variable.

Data Format

To use the Variability Chart platform, all response measurements must be in a single response 

column. Sometimes, responses are recorded in multiple columns, where each row is a level of 

a design factor and each column is a level of a different design factor. Data that are in this 

format must be stacked before running the Variability Chart platform. See Using JMP.

The Variability Gauge Report

The Variability Gauge report contains a Variability Gauge Analysis report for each response 

column that was specified in the launch window. By default, the are two charts in each 

Variability Gauge Analysis report. The measurement variability chart and the standard 

deviation chart show patterns of variation. You can use these charts to identify possible 

groups of variation (within subgroups, between subgroups, over time). If you notice that any 

of these sources of variation are large, you can then work to reduce the variation for that 

source.



160 Variability Gauge Charts Chapter 6
The Variability Gauge Report Quality and Process Methods

Figure 6.4  Variability Gauge Report

The charts show the response on the y-axis and a multilevel, categorized x-axis.

In Figure 6.4, the Measurement chart shows the range of measurements for each operator by 

part. Each measurement appears on the chart. Maximum and minimum bars indicate the 

range of values for each cell, and a cell means bar indicates the median value for each 

combination of values. The Std Dev chart plots the standard deviation of the measurements 

taken on each part by operator.

You can add features to the charts, as illustrated in Figure 6.4. See “Variability Gauge Platform 

Options”.

To replace variables in charts, do one of the following:

• Swap existing variables by dragging a variable from one axis label to the other axis label. 

When you drag a variable over a chart or click an axis label, the axis labels are highlighted. 

This indicates where to drop the variable.

• Click a variable in the Columns panel of the associated data table and drag it onto an axis 

label.

In other platforms, rows that are excluded in the associated data table still appear on the 

charts or plots. However, in variability charts, excluded rows do not appear on the charts.

points with 
range bars

group means

lines connecting 
cell means

cell means
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Variability Gauge Platform Options

The Variability Gauge red triangle menu contains the following options:

Save Shows a submenu of the following options:

Save Metadata as Column Properties (Not available if a By variable is specified in the 

launch window.) Provides the following options to save the metadata as column 

properties in the original data table.

• You can save the metadata as MSA column properties.

• You can compute and save the measurement sigma in the Process Screening 

column property. The measurement sigma is the square root of the total of all 

variance components subtracted by the part variance.

• You can save the lower and upper tolerance values as Spec Limits column 

properties.

Save All Metadata to Table Saves a new data table that contains the metadata for each 

column. This includes the measurement sigma, which is used in the Process Screening 

platform. The measurement sigma is the square root of the total of all variance 

components subtracted by the part variance. If there is a By variable, a table is saved for 

the corresponding level of the By variable and the table name includes the level.

Edit MSA Metadata Opens a window that enables you to add or edit the tolerance range, 

tolerance limits, historical mean, and historical process sigma for all analyses. See 

“Show MSA Metadata Entry Dialog”.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.
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 Variability Gauge Analysis Report Options

Each Variability Gauge Analysis report red triangle menu contains options to modify the 

appearance of the chart, perform Gauge R&R analysis, and compute variance components.

Vertical Charts Changes the layout to horizontal or vertical.

Variability Chart Shows or hides the variability chart.

Show Points Shows or hides the points for individual rows.

Show Range Bars Shows or hides the bars indicating the minimum and the maximum value 

of each cell.

Show Cell Means Shows or hides the mean mark for each cell.

Connect Cell Means Connects or disconnects cell means within a group of cells.

Show Separators Shows or hides the separator lines between levels of the X, Grouping 

variables.

Show Group Means (Available only if you have two or more X, Grouping variables or one X, 

Grouping variable and one Part, Sample ID variable.) Shows or hides the mean for groups 

of cells, represented by a horizontal solid line. A window appears, prompting you to select 

one of the grouping variables.

Show Grand Mean Shows or hides the overall mean, represented by a gray dotted line 

across the entire graph.

Show Grand Median Shows or hides the overall median, represented by a blue dotted line 

across the entire graph.

Show Box Plots Shows or hides box plots.

Mean Diamonds Shows or hides mean diamonds. The confidence intervals use the 

within-group standard deviation for each cell.

XBar Control Limits Shows or hides lines at the UCL and LCL on the variability chart. For 

more information about the calculations of these limits, see “Statistical Details for Control 

Chart Builder”.

Points Jittered Adds some random noise to the plotted points so that coincident points do 

not plot on top of one another.

Show Standard Mean (Available only if you have specified a Standard variable.) Shows or 

hides the mean of the standard column.
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Variability Summary Report Shows or hides a report that gives the mean, standard 

deviation, coefficient of variation (CV), standard error of the mean, lower and upper 

confidence intervals, and the minimum, maximum, and number of observations.

Std Dev Chart Shows or hides a separate graph that shows cell standard deviations across 

category cells.

Mean of Std Dev Shows or hides a line at the mean standard deviation on the Std Dev chart.

S Control Limits Shows or hides lines showing the LCL and UCL in the Std Dev chart. For 

more information about the calculations of these limits, see “Statistical Details for Control 

Chart Builder”.

Group Means of Std Dev Shows or hides the mean lines on the Std Dev chart.

Heterogeneity of Variance Tests Performs a test for comparing variances across groups. See 

“Heterogeneity of Variance Tests”.

Variance Components Estimates the variance components for a specific model. Variance 

components are computed for these models: main effects, crossed, nested, crossed then 

nested (three factors only), and nested then crossed (three factors only). See “Variance 

Components”.

Gauge Studies Contains the following options:

Gauge R&R Interprets the first factors as grouping columns and the last factor as Part, 

and creates a gauge R&R report using the estimated variance components. (Note that 

there is also a Part field in the launch window). See “Gauge R&R Report”.

If you select the Gauge R&R option and you have not already selected a model type or 

entered MSA metadata, you are prompted to do so. If you want to modify your 

metadata specifications, click the Variability Gauge Analysis red triangle and select 

Gauge Studies > Edit MSA Metadata. See “Show MSA Metadata Entry Dialog”.

Note: The Platform preferences for Variability include the Gauge R&R Specification 

Dialog option. The preference is selected by default. Deselect the preference to use the 

spec limits that are defined in the data table.

Discrimination Ratio Shows or hides the Discrimination Ratio report. The discrimination 

ratio compares the total variance of the measurement with the variance of the 

measurement error and characterizes the relative usefulness of a given measurement 

for a specific product. Generally, when the discrimination ratio is less than 2, the 

measurement cannot detect product variation, implying that the measurement process 

needs improvement. A discrimination ratio greater than 4 adequately detects 

unacceptable product variation, implying that the production process needs 

improvement. See “Statistical Details for the Discrimination Ratio”.
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Misclassification Probabilities (Available only if lower and upper tolerance values are 

specified for the response in the MSA Metadata.) Shows or hides a report of 

probabilities for rejecting good parts and accepting bad parts. See “Misclassification 

Probabilities”.

Bias Report (Available only if a Standard column is specified in the launch window.) 

Shows the average difference between the observed values and the standard. A graph 

of the average biases and a summary table appears. See “Bias Report”.

Linearity Study (Available only if a Standard column is specified in the launch window.) 

Performs a regression using the standard values as the X variable and the bias as the Y 

variable. This analysis examines the relationship between bias and the size of the part. 

A nonzero slope indicates that your gauge performs differently with different sized 

parts. See “Linearity Study”.

Gauge R&R Plots Shows or hides Mean Plots (the mean response by each main effect in 

the model) and Std Dev plots. If the model is purely nested, the graphs appear with a 

nesting structure. If the model is purely crossed, interaction graphs appear. Otherwise, 

the graphs plot independently at each effect. For the standard deviation plots, the red 

lines connect  for each effect.

Edit MSA Metadata Opens a window that enables you to add or edit the tolerance range, 

tolerance limits, historical mean, and historical process sigma. See “Show MSA 

Metadata Entry Dialog”.

AIAG Labels Enables you to specify that quality statistics should be labeled in 

accordance with the AIAG standard, which is used extensively in automotive analyses.

Heterogeneity of Variance Tests

In the Variability Chart platform, the Heterogeneity of Variance Tests option performs a test 

for comparing variances across groups. The test is an Analysis of Means for Variances 

(ANOMV) based method. This method indicates whether any of the group standard 

deviations are different from the square root of the average group variance. For an example, 

see “Example of the Heterogeneity of Variance Test”.

To be robust against non-normal data, the method uses a permutation simulation to compute 

decision limits. For more information about this method, see Wludyka and Sa (2004). Because 

the method uses simulations, the decision limits can be slightly different each time. To obtain 

the same results each time, assign a random seed in the launch window.

The red triangle menus for the test reports contain the following options:

Set Alpha Level Sets the alpha level for the test.

mean weighted variance
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Show Summary Report Shows or hides a summary report for the test. The values in the 

report are the same values that are shown in the plot.

Display Options Enables you to show or hide the decision limits, decision limit shading, and 

center line. There are also points options that you can use to show needles, show 

connected points, or show only points.

Variance Components

In the Variability Chart platform, the Variance Components option models the variation from 

measurement to measurement. The response is assumed to be a constant mean plus random 

effects associated with various levels of the classification.

Note: Once you select the Variance Components option, if you did not select the Model Type 

in the launch window (if you selected Decide Later), you are prompted to select the model 

type. For more information about model types, see “Launch the Variability Gauge Chart 

Platform”.

Figure 6.5  Example of the Variance Components Report

The Analysis of Variance report appears only if the EMS method of variance component 

estimation is used. This report shows the significance of each effect in the model.

The Variance Components report shows the estimates themselves. See “Statistical Details for 

Variance Components”.

Analysis Settings

From the launch window, click Analysis Settings to choose the method for computing 

variance components.
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Figure 6.6  Analysis Settings Window

Choose best analysis (EMS, REML, or Bayesian) Chooses the best analysis from EMS, 

REML, or Bayesian, using the following logic:

– If the data are balanced, and if no variance components are negative, the EMS 

(expected mean squares) method is used to estimate the variance components.

– If the data are unbalanced, the REML (restricted maximum likelihood) method is used, 

unless a variance component is estimated to be negative, then the Bayesian method is 

used.

– If any variance component is estimated to be negative using the EMS method, the 

Bayesian method is used.

– If there is confounding in the variance components, then the bounded REML method is 

used, and any negative variance component estimates are set to zero.

Choose best analysis (EMS or REML) Chooses the best analysis from EMS or REML, using 

the same logic as the Choose best analysis (EMS, REML, or Bayesian) option. However, 

this option never uses the Bayesian method, even for negative variance components. The 

bounded REML method is used and any negative variance component is forced to be 0.

Use REML analysis Uses the bounded REML method, even if the data are balanced. The 

bounded REML method can handle unbalanced data and forces any negative variance 

component to be 0.

Use Bayesian analysis Uses the Bayesian method. The Bayesian method can handle 

unbalanced data and forces all variances components to be positive and nonzero. If there 

is confounding in the variance components, then the bounded REML method is used, and 

any negative variance component estimates are set to zero. The method implemented in 

JMP computes the posterior means using a modified version of Jeffreys’ prior. See Portnoy 

(1971) and Sahai (1974).

Maximum Iterations (Applicable only for the REML method.) For difficult problems, you 

might want to increase the number of iterations. Increasing this value means that JMP will 

try more times to find a solution in the optimization phase.

Convergence Limit (Applicable only for the REML method.) For problems where you want 

greater precision, you might want to change the convergence limit to be smaller. 
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Decreasing this value means that JMP will find the solution to a higher level of accuracy in 

the optimization phase. However, this can increase the time taken to find a solution. 

Providing a larger convergence value returns quicker results, but is less precise.

Number of Iteration Abscissas (Applicable only for the Bayesian method.) For greater 

accuracy, you might want to increase the number of iteration abscissas. However, this can 

increase the time taken to find a solution. Providing a smaller number returns quicker 

results, but is less precise.

Maximum Number of Function Evaluations (Applicable only for the Bayesian method.) For 

greater accuracy, you might want to increase the maximum number of function 

evaluations. However, this can increase the time taken to find a solution. Providing a 

smaller number returns quicker results, but is less precise.

About the Gauge R&R Method

The Gauge R&R method analyzes how much of the variability in your measurement system is 

due to operator variation (reproducibility) and measurement variation (repeatability). Gauge 

R&R studies are available for many combinations of crossed and nested models, regardless of 

whether the model is balanced.

Tip: Alternatively, you can use the EMP method to assess your measurement system. See 

“Measurement Systems Analysis”.

Before performing a Gauge R&R study, you collect a random sample of parts over the entire 

range of part sizes from your process. Select several operators at random to measure each part 

several times. The variation is then attributed to the following sources:

• The process variation, from one part to another. This is the ultimate variation that you want 

to be studying if your measurements are reliable.

• The variability inherent in making multiple measurements, that is, repeatability. In 

Table 6.1, this is called the within variation.

• The variability due to having different operators measure parts—that is, reproducibility.

A Gauge R&R analysis then reports the variation in terms of repeatability and reproducibility.

Table 6.1  Definition of Terms and Sums in Gauge R&R Analysis

Variances Sums Term and 
Abbreviation

Alternate Term

V(Within) Repeatability 

(EV)

Equipment Variation
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A Shewhart control chart can identify processes that are going out of control over time. A 

variability chart can also help identify operators, instruments, or part sources that are 

systematically different in mean or variance.

Gauge R&R Report

In the Variability Chart platform, the Gauge R&R report shows measures of variation 

interpreted for a gauge study of operators and parts. There is a full version of the Gauge R&R 

report and a reduced version. To generate the reduced Gauge R&R report, select File > 
Preferences > Platforms > Variability Chart > Reduced Gauge R&R Report.

V(Operator)+V(Operator*Part) Reproducibility 

(AV)

Appraiser Variation

V(Operator*Part) Interaction (IV) Interaction Variation

V(Within)+V(Operator)+V(Operator*

Part)

Gauge R&R 

(RR)

Measurement 

Variation

V(Part) Part Variation 

(PV)

Part Variation

V(Within)+V(Operator)+ 

V(Operator*Part)+V(Part)

Total Variation 

(TV)

Total Variation

Table 6.1  Definition of Terms and Sums in Gauge R&R Analysis (Continued)

Variances Sums Term and 
Abbreviation

Alternate Term
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Figure 6.7  Example of the Full Gauge R&R Report

Figure 6.8  Example of the Reduced Gauge R&R Report

The table in the Gauge R&R report contains the following information:

Measurement Source Defines the source of measurement for the variation.

Variation (k*StdDev) The square roots of sums of variance components scaled by the value of 

the sigma multiplier, k.

% of Tolerance (Available only if you specified a tolerance range or lower and upper 

tolerance values.) Provides the % of tolerance computed as 100*(Variation/Tolerance).
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% Process (Available only if you specified a historical process sigma.) Provides the % of 

process computed as 100*(Variation/(k*Historical Sigma)).

which is k*sqrt of The descriptions of how the variance component sums are calculated.

Note: To add columns to the Gauge R&R report, right-click on the column heading and select 

Columns.

The Gauge R&R report also contains a Summary and Gauge R&R statistics section. This 

includes specified values, summaries, and other statistics. If you specified a tolerance range or 

lower and upper tolerance values, a Precision-to-Tolerance ratio is included in this section. 

This ratio represents the proportion of the tolerance or capability interval that is lost due to 

gauge variability. The % Gauge R&R value is also shown in this section, which is the 

percentage of the total variation that is made up by the measurement variation. Table 6.2 

shows guidelines for the percent measurement variation, as suggested by Barrentine (1991).

Variance Components for Gauge R&R

The Variance Components for Gauge R&R table in the Gauge R&R report contains the 

different variance components from the model. These are the variance components used to 

compute that variation in the initial table of the Gauge R&R report.

Misclassification Probabilities

In the Variability Chart platform, you can analyze observations that have been misclassified 

based on the lower and upper tolerance limits. When you select the Misclassification 

Probabilities option, you are prompted to select the model type if you have not already done 

so.

Table 6.2  Acceptable Percent Measurement Variation

< 10% excellent

11% to 20% adequate

21% to 30% marginally acceptable

> 30% unacceptable
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Figure 6.9  Example of the Misclassification Probabilities Report

The misclassification probabilities are based on the joint probability function of Y, the 

measured value of the part, and X, the true value of the part. The joint probability density 

function used is a bivariate normal distribution. To understand the descriptions, define the 

following probabilities:

 = P[(LSL  X  USL) and (Y < LSL or Y > USL)]

 = P[(X < LSL or X > USL) and (LSL  Y  USL)]

 = P(LSL  X  USL)

Descriptions

P(Good part is falsely rejected) The conditional probability that a part is rejected given that 

it is a good part, or /.

P(Bad part is falsely accepted) The conditional probability that a part is accepted given that 

it is a bad part, or /(1-).

P(Part is good and is rejected) The joint probability that a part is good and that it is rejected, 

or .

P(Part is bad and is accepted) The joint probability that a part is bad and that it is accepted, 

or .

P(Part is good) The probability that a part is good, or .

For more information, see “Statistical Details for the Misclassification Probabilities” as well as 

Burdick et al. (2005).

Bias Report

In the Variability Chart platform, the Bias Report option shows a graph for Overall 

Measurement Bias with a summary table and a graph for Measurement Bias by Standard with 

a summary table. The average bias, or the differences between the observed values and the 

standard values, appears for each level of the X variable. A t test for the bias is also given.

The Bias Report option is available only when a Standard variable is provided in the launch 

window.
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The Measurement Bias Report red triangle menu contains the following options:

Confidence Intervals Calculates confidence intervals for the average bias for each part and 

places marks on the Measurement Bias Report by Standard plot.

Measurement Error Graphs Produces a graph of Measurement Error versus all grouping 

columns together. There are also graphs of Measurement Error by each grouping column 

separately.

Linearity Study

In the Variability Chart platform, the Linearity Study option performs a regression analysis 

using the standard variable as the X variable and the bias as the Y variable. This analysis 

examines the relationship between bias and the size of the part. If the slope is significantly 

different from zero, you can conclude that there is a significant relationship between the size 

of the part or variable measured as a standard and the ability to measure.

The Linearity Study option is available only when a Standard variable is provided in the 

launch window. To obtain a complete results report, you also need to specify values for the 

sigma multiplier and the historical process sigma. These values are multiplied to calculate the 

Process Variation. The sigma multiplier is specified in the launch window. There are several 

ways to specify the historical process sigma.

• Prior to analysis, you can assign the MSA column property to the response and specify the 

historical process sigma in the column property.

• In the launch window, you can specify the historical process sigma by selecting the Show 

MSA Metadata Entry Dialog.

• In the report window, you can click the Variability Gauge Analysis red triangle and select 

Gauge Studies > Edit MSA Metadata.

• You can directly specify the historical process sigma in a script.

The Linearity Study report shows the following information:

• Bias summary statistics for each standard.

• An ANOVA table that tests if the slope of the line is equal to zero.

• The line parameters, including tests for the slope (linearity) and intercept (bias). The test 

for the intercept is useful only if the test on the slope fails to reject the hypothesis of slope = 

0.

• A table that contains the values for Process Variation, Linearity, % Linearity, Overall Avg 

Bias, % Bias, and Alpha.

• The equation of the line appears directly beneath the graph, along with the R Squared 

value.

The Linearity Study red triangle menu contains the following options:
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Set Alpha Level Changes the alpha level that is used in the bias confidence intervals.

Linearity by Groups Produces separate linearity plots for each level of the X, Grouping 

variables that you specified in the launch window.

Show Bias Points Shows or hides the bias points on the graph.

Show Line of Fit Shows or hides the line of fit on the graph.

Show Fit Confidence Curves Shows or hides the line of fit confidence curves on the graph.

Show Overall Avg Bias Line Shows or hides the overall average bias line on the graph.

Show Avg Bias Points Shows or hides the average bias points on the graph.

Additional Examples of Variability Charts

This section contains examples using the Variability Chart platform.

• “Example of the Heterogeneity of Variance Test”

• “Example of the Bias Report and Linearity Study”

Example of the Heterogeneity of Variance Test

Use the Variability Chart platform to test if the variances of different groups are statistically 

different. In this example, three operators each took three measurements of ten parts, for a 

total of 90 observations. You want to examine the following:

• whether the variance of measurements for each operator are the same or different

• whether the variance for each part is the same or different

• whether the variance for each Operator*part combination is the same or different

1. Select Help > Sample Data Folder and open Variability Data/2 Factors Crossed.jmp.

2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.

3. Select Measurement and click Y, Response.

4. Select Operator and click X, Grouping.

5. Select part# and click Part, Sample ID.

6. (Optional) Enter 1234 next to Set Random Seed.

7. Click OK.

8. Click the Variability Gauge Analysis for Measurement red triangle and select 

Heterogeneity of Variance Tests.
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9. Select Crossed.

10. Click OK.

Figure 6.10  Heterogeneity of Variances Tests Report
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In the Operator Variance test, all three levels exceed the upper and lower decision limits. From 

this, you conclude that each operator has a different variability from the square root of the 

average group variance. You might want to examine why the variation between each operator 

is different.

For the part# Variance test and the interaction (Operator*part#) Variance test, none of the 

levels exceed the decision limits. From this, you conclude that the variances are not 

statistically different from the square root of the average group variance. Each part has a 

similar variance to the other parts, and each Operator*part# combination has similar variance 

to the other Operator*part# combinations.

Example of the Bias Report and Linearity Study

Use the Variability Chart platform to evaluate the bias and linearity of a new measurement 

system. Five parts were chosen throughout the operating range of the measurement system, 

based on documented process variation. Each part was measured by layout inspection to 

determine its reference value. Each part was then measured twelve times by the lead operator. 

The parts were selected at random during the day.

Bias Report

Use the Bias Report option to examine the overall and individual measurement bias.

1. Select Help > Sample Data Folder and open Variability Data/MSALinearity.jmp.

2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.

3. For Chart Type, select Variability.

4. Check that the value for the Sigma Multiplier is 6.

5. Select Response and click Y, Response.

6. Select Standard and click Standard.

7. Select Part and click X, Grouping.

8. Click OK.

9. Click the Variability Gauge Analysis for Response red triangle and select Gauge Studies > 
Bias Report.
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Figure 6.11  Measurement Bias Report

The bias (Response minus Standard) is calculated for every measurement. The Overall 

Measurement Bias Report shows a histogram of the bias and a t test to see whether the 

average bias is equal to 0. You can see that the Average Bias is not zero, it is -0.0533. 

However, zero is contained within the confidence interval (-0.1152,0.0085), which means 

that the Average Bias is not significantly different from 0. Using a significance level of 0.05, 

you can see that the p-value is greater than 0.05, which also shows that the Average Bias is 

not significantly different from 0.

The Measurement Bias Report by Standard shows average bias values for each part. The 

bias averages are plotted on the graph along with the actual bias values for every part, so 

that you can see the spread. In this example, part number 1 (with a standard value of 2) is 

biased high and parts 4 and 5 (with standard values of 8 and 10) are biased low.

Tip: To see confidence intervals for the bias, right-click in the table and select Columns > 
Lower 95% and Columns > Upper 95%.
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Linearity Study

Use the Linearity Study option to determine whether there is a significant relationship 

between the size of the parts and the operator’s ability to measure them. First, you must 

specify a historical process sigma.

1. Click the Variability Gauge Analysis for Response red triangle and select Gauge Studies > 
Edit MSA Metadata.

2. In the Edit MSA Metadata window, enter 2.488105 as the value for the Historical Process 

Sigma. This is the standard deviation of the response. The Historical Process Sigma is used 

to calculate the Process Variation.

3. Click OK.

4. Click the Variability Gauge Analysis for Response red triangle and select Gauge Studies > 
Linearity Study.

Figure 6.12  Linearity Study

Note the following:

• The slope is -0.131667. This value appears as part of the equation below the graph, and 

also in the third table.

• The p-value associated with the test on the slope is quite small, <.0001. The t test for the 

slope is testing whether the bias changes with the standard value.

Because the p-value is small, you can conclude that there is a significant linear relationship 

between the size of the parts and the operator’s ability to measure them. You can also see this 

in the graph. If the part or standard value is small, the bias is high, and vice versa.



178 Variability Gauge Charts Chapter 6
Statistical Details for Variability Charts Quality and Process Methods

Statistical Details for Variability Charts

This section contains statistical details for the Variability Chart platform.

• “Statistical Details for Variance Components”

• “Statistical Details for the Discrimination Ratio”

• “Statistical Details for the Misclassification Probabilities”

Statistical Details for Variance Components

The exact model type that you choose in the Variability Chart platform depends on how the 

data were collected. For example, if the operators are measuring the same parts, you have a 

crossed design. If they measuring different parts, you have a nested design. To illustrate, in a 

model where B is nested within A, multiple measurements are nested within both B and A, 

and there are na•nb•nw measurements, the following statements hold:

• na random effects are due to A

• na•nb random effects due to each nb B levels within A

• na•nb•nw random effects due to each nw levels within B within A:

.

The Zs are the random effects for each level of the classification. Each Z is assumed to have a 

mean of zero and to be independent from all other random terms. The variance of the 

response y is the sum of the variances due to each z component:

.

Table 6.3 shows the supported models and what the effects in the model would be.

Table 6.3  Models Supported by the Variability Charts Platform

Model Factors Effects in the Model

Main Effects 1

2

unlimited

A

A, B

and so on, for more factors

yijk u Zai Zbij Zwijk+ + +=

Var yijk  Var Zai  Var Zbij  Var Zwijk + +=
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Statistical Details for the Discrimination Ratio

In the Variability Chart platform, the discrimination ratio compares the total variance of the 

measurement, M, with the variance of the measurement error, E. The discrimination ratio is 

computed for all main effects, including nested main effects. The discrimination ratio, D, is 

computed as follows:

where:

P = estimated variance for a factor

T = estimated total variance

Crossed 1

2

3

4

unlimited

A

A, B, A*B

A, B, A*B, C, A*C, B*C, A*B*C

A, B, A*B, C, A*C, B*C, A*B*C, D, A*D, B*D, A*B*D, 

C*D, A*C*D, B*C*D, A*B*C*D,

and so on, for more factors

Nested 1

2

3

4

unlimited

A

A, B(A)

A, B(A), C(A,B)

A, B(A), C(A,B), D(A,B,C)

and so on, for more factors

Crossed then 

Nested

3 A, B, A*B, C(A,B)

Nested then 

Crossed

3 A, B(A), C, A*C, C*B(A)

Table 6.3  Models Supported by the Variability Charts Platform (Continued)

Model Factors Effects in the Model

D 2
P

T P–
------------- 
  1+=
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Statistical Details for the Misclassification Probabilities

This section describes the computations for the probabilities in the Misclassification 

Probabilities report in the Variability Chart platform. The misclassification probabilities are 

based on the joint probability function of Y, the measured value of the part, and X, the true 

value of the part. The joint probability distribution function FYX(y, x) uses a bivariate normal 

distribution with mean vector [, ] and the following covariance matrix:

where P is the part-to-part variation, M is the measurement variation, and  is the grand 

mean. These quantities can be found or derived from quantities in the report window. 

Specifically, P + M is equal to the square of Total Variation (TV) divided by 6: (TV/6)2 and P is 

equal to the square of Part Variation (PV) divided by 6: (PV/6)2. The correlation YX between Y 

and X is defined as the square root of P/(P + M).

Next, define the following probabilities:

 = P[(LSL  X  USL) and (Y < LSL or Y > USL)]

 = P[(X < LSL or X > USL) and (LSL  Y  USL)]

 = P(LSL  X  USL)

These probabilities can be expressed in terms of the joint probability distribution function 

FYX(y, x) and the marginal probability distribution functions for Y and X: FY(y) and FX(x):

 = FYX(LSL, USL) - FYX(LSL, LSL) - FYX(USL, USL) + FYX(USL, LSL) + FX(USL) - FX(LSL)

 = FYX(USL, LSL) - FYX(LSL, LSL) - FYX(USL, USL) + FYX(LSL, USL) + FY(USL) - FY(LSL)

 = FX(USL) - FX(LSL)

P(Good part is falsely rejected) = /

P(Bad part is falsely accepted) = /(1-

P(Part is good and is rejected) = 

P(Part is bad and is accepted) = 

P(Part is good) = 

P M+ P

P P
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Evaluate a Categorical Measurement Process Using Agreement Measures

Attribute charts analyze categorical measurements and can help show you measures of 

agreement across responses, such as raters. In attribute data, the variable of interest has a finite 

number of categories. Typically, data has only two possible results, such as pass or fail. You 

can examine aspects such as how effective raters were at classifying a part, how much they 

agreed with each other, and how much they agreed with themselves over the course of several 

ratings.

Tip: This chapter covers only attribute charts. For more information about variability charts, 

see “Variability Gauge Charts”.

Figure 7.1  Example of an Attribute Chart
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Overview of Attribute Gauge Charts

Before you create an attribute gauge chart, your data should be formatted using the following 

guidelines:

• In order to compare agreement among raters, each rater in the data table must be in a 

separate column. These columns are then assigned to the Y, Response role in the launch 

window. In Figure 7.2, each rater (A, B, and C) is in a separate column.

• Responses in the different columns can be character (pass or fail) or numeric (0 or 1). In 

Figure 7.2, rater responses are numeric (0 for pass, 1 for fail). All response columns must 

have the same data type.

• Any other variables of interest that you might want to use as X, Grouping variables should 

appear stacked in one column each (see the Part column in Figure 7.2). You can also define 

a Standard column, which produces reports that compare raters with the standard. The 

Standard column and response columns must have the same data type.

Figure 7.2  Attribute Gauge Data

Example of an Attribute Gauge Chart

You want to examine how effective raters are in correctly classifying parts, and how well 

raters agree with each other and with themselves over the course of the ratings. In this 

example, three raters are indicating if a part passed (0) or failed (1) for 50 parts, three times 

each.

1. Select Help > Sample Data Folder and open Attribute Gauge.jmp.

2. Select Analyze > Quality and Process > Variability / Attribute Gauge Chart.

3. For Chart Type, select Attribute.
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4. Select A, B, and C and click Y, Response.

5. Select Standard and click Standard.

6. Select Part and click X, Grouping.

7. Click OK.

Figure 7.3  Example of an Attribute Chart

The first chart (Part) shows how well the raters agreed with each other for each part. For 

example, here you can see that the percent agreement dropped for part 6, 12, 14, 21, 22, and so 

on. These parts might have been more difficult to categorize.

The second chart (Rater) shows each rater’s agreement with him or herself and the other raters 

for a given part, summed up over all of the parts. In this example, it looks like the performance 

of the raters is relatively similar. Rater C had the lowest agreement, but the difference is not 

major (about 89% instead of 91%).

8. Open the Effectiveness Report and scroll down to the Conformance Report.

You can see that 0 = non-conform (fail) and a 1 = conform (pass). However in this data, it is 

exactly the opposite: 0 is a pass and 1 is a fail. Reverse this setting.

9. Click the Conformance Report red triangle and select Change Conforming Category.
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Figure 7.4  Conformance Report

Launch the Attribute Gauge Chart Platform

Launch the Attribute Gauge Chart platform by selecting Analyze > Quality and Process > 
Variability/Attribute Gauge Chart. Set the Chart Type to Attribute.

Figure 7.5  The Attribute Gauge Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Chart Type Choose between a variability gauge analysis (for a continuous response) or an 

attribute gauge analysis (for a categorical response, usually “pass” or “fail”).

Note: The content in this chapter covers only the Attribute chart type. For more 

information about the Variability chart type, see “Variability Gauge Charts”.

Specify Alpha Specify the alpha level used by the platform.

Y, Response Specify the columns of ratings given by each rater. You must specify more than 

one rating column.

Standard Specify a standard or reference column that contains the “true” or known values 

for the part. In the report window, an Effectiveness Report and an additional section in the 

Agreement Comparisons report appear, which compare the raters with the standard.
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X, Grouping Specify the classification columns that group the measurements. If the factors 

form a nested hierarchy, specify the higher terms first.

Freq Identifies the data table column whose values assign a frequency to each row. Can be 

useful when you have summarized data.

By Identifies a column that creates a report consisting of separate analyses for each level of 

the variable.

The Attribute Gauge Report

The Attribute Gauge report contains the Gauge Attribute Chart and several other reports.

• “Gauge Attribute Chart”

• “Agreement Reports”

• “Effectiveness Report”

Gauge Attribute Chart

The Gauge Attribute Chart plots the percent Agreement, which is a measurement of rater 

agreement for every part in the study. The agreement for each part is calculated by comparing 

the ratings for every pair of raters for all ratings of that part. See “Statistical Details for 

Attribute Gauge Charts”.
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Figure 7.6  Gauge Attribute Chart

The first chart in Figure 7.6 uses all X grouping variables (in this case, the Part) on the 

horizontal axis. The second chart uses all Y variables on the horizontal axis (typically, and in 

this case, the Rater).

• In the first graph, you can look for parts with a low percent Agreement value, and 

investigate to determine why raters do not agree about the measurement of that particular 

part.

• In the second graph, you can look for raters with a low percent Agreement value, and 

investigate to determine why they do not agree with the other raters or with themselves.

For information about additional options, see “Attribute Gauge Platform Options”.

Agreement Reports

There are different types of Agreement reports in the Attribute Gauge Report. These include 

the Agreement Report, the Agreement Comparisons report, the Agreement within Raters 

report, the Agreement across Categories report, and the Effectiveness Report.

Note: The Kappa value is a statistic that expresses agreement. The closer the Kappa value is to 

1, the more agreement there is. A Kappa value closer to 0 indicates less agreement.
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The Agreement Report shows agreement summarized for each rater and overall agreement. 

This report is a numeric form of the data presented in the second chart in the Attribute Gauge 

Chart report (Figure 7.6).

The Agreement Comparisons report shows each rater compared with all other raters, using 

Kappa statistics. The rater is compared with the standard only if you have specified a 

Standard variable in the launch window.

The Agreement within Raters report shows the number of items that were inspected. The 

confidence intervals are score confidence intervals, as suggested by Agresti and Coull (1998). 

The Number Matched is the sum of the number of items inspected, where the rater agreed 

with him or herself on each inspection of an individual item. The Rater Score is the Number 

Matched divided by the Number Inspected.

The Agreement across Categories report shows the agreement in classification over that which 

would be expected by chance. It assesses the agreement between a fixed number of raters 

when classifying items.

Figure 7.7  Agreement Reports
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Effectiveness Report

In the Attribute Gauge report, the Effectiveness Report compares every rater with the 

standard. This report appears only if you have specified a Standard variable in the launch 

window. For a description of a Standard variable, see “Launch the Attribute Gauge Chart 

Platform”.

Figure 7.8  Effectiveness Report

The Agreement Counts table shows cell counts on the number correct and incorrect for every 

level of the standard. In Figure 7.8, the standard variable has two levels, 0 and 1. Rater A had 

45 correct responses and 3 incorrect responses for level 0, and 97 correct responses and 5 

incorrect responses for level 1.

Effectiveness is defined as the number of correct decisions divided by the total number of 

opportunities for a decision. For example, say that rater A sampled every part three times. On 

the sixth part, one of the decisions did not agree (for example, pass, pass, fail). The other two 

decisions would still be counted as correct decisions. This definition of effectiveness is 

different from the MSA 3rd edition. According to MSA, all three opportunities for rater A on 

part six would be counted as incorrect. Including all of the inspections separately gives you 

more information about the overall inspection process.
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In the Effectiveness table, 95% confidence intervals are given about the effectiveness. These are 

score confidence intervals. It has been demonstrated that score confidence intervals provide 

increased coverage probability, particularly where observations lie near the boundaries. See 

Agresti and Coull (1998).

The Misclassifications table shows the incorrect labeling. The rows represent the levels of the 

standard or accepted reference value. The columns contain the levels given by the raters.

Conformance Report

The Conformance Report shows the probability of false alarms and the probability of misses. 

This report appears only when the rating has two levels (such as pass or fail, or 0 or 1).

The following descriptions apply:

False Alarm The part is determined to be non-conforming, when it actually is conforming.

Miss The part is determined to be conforming, when it actually is not conforming.

P(False Alarms) The number of parts that have been incorrectly judged to be nonconforming 

divided by the total number of parts that are judged to be conforming.

P(Miss) The number of parts that have been incorrectly judged to be conforming divided by 

the total number of parts that are actually nonconforming.

The Conformance Report red triangle menu contains the following options:

Change Conforming Category Reverses the response category that is considered 

conforming.

Calculate Escape Rate Calculates the Escape Rate, which is the probability that a 

non-conforming part is produced and not detected. The Escape Rate is calculated as the 

probability that the process will produce a non-conforming part times the probability of a 

miss. You specify the probability that the process will produce a non-conforming part, also 

called the Probability of Nonconformance.

Note: Missing values are treated as a separate category in this platform. To avoid this separate 

category, exclude rows of missing values in the data table.

Attribute Gauge Platform Options

The Attribute Gauge red triangle menu contains the following options:

Attribute Gauge Charts Shows or hides the gauge attribute chart and the efficiency chart.

Show Agreement Points Shows or hides the agreement points on the charts.
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Connect Agreement Points Connects the agreement points in the charts.

Agreement by Rater Confid Intervals Shows or hides the agreement by rater confidence 

intervals on the efficiency chart.

Show Agreement Group Means Shows or hides the agreement group means on the gauge 

attribute chart. This option is available when you specify more than one X, Grouping 

variable.

Show Agreement Grand Mean Shows or hides the overall agreement mean on the gauge 

attribute chart.

Show Effectiveness Points Shows or hides the effectiveness points on the charts.

Connect Effectiveness Points Draws lines between the effectiveness points in the charts.

Effectiveness by Rater Confid Intervals Shows or hides confidence intervals on the second 

chart in the Attribute Gauge Chart report (Figure 7.6).

Effectiveness Report Shows or hides the Effectiveness report. This report compares every 

rater with the standard, using the Kappa statistic.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.
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Statistical Details for Attribute Gauge Charts

This section contains statistical details for Attribute Gauge charts.

• “Statistical Details for the Gauge Attribute Chart”

• “Statistical Details for the Agreement Report”

Statistical Details for the Gauge Attribute Chart

In the Gauge Attribute chart that plots all X, Grouping variables on the horizontal axis, the 

percent Agreement is calculated as follows:

In the Gauge Attribute chart that plots all Y, Response variables on the horizontal axis, the 

percent Agreement is calculated as follows:

Note the following:

• n = number of parts (grouping variables)

• ri = number of reps for part i (i = 1,...,n)

• m = number of raters

• k = number of levels

• Ni = m x ri. Number of ratings on part i (i = 1,...,n). This includes responses for all raters, 

and repeat ratings on a part. For example, if part i is measured 3 times by each of 3 raters, 

then Ni is 3 x 3 = 9.

For example, consider the following table of data for three raters, each having three replicates 

for one part.

% Agreement for part i

number of responses for level l
2 

 

l 1=

k



Ni
2 

 
---------------------------------------------------------------------------------------------------=

% Agreement for rater k

number of uncounted matching levels

for this rater k within part i for rep j
j 1=

ri


 
 
 
 

i 1=

n



Ni j–

j 1=

ri


 
 
 
 

i 1=

n



---------------------------------------------------------------------------------------------------------------------------------=
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Using this table, you can make these calculations:

% Agreement =

% Agreement [rater A] = percent Agreement [rater B] =  and

% Agreement [rater C] =

Statistical Details for the Agreement Report

In the Attribute Gauge Chart platform, the simple Kappa coefficient is reported. The simple 

Kappa coefficient is a measure of inter-rater agreement.

where:

and:

Table 7.1  Three Replicates for Raters A, B, and C

A B C

1 1 1 1

2 1 1 0

3 0 0 0

4
2 
  5

2 
 +

9
2 
 

----------------------- 16
36
------ 0.444= =

4 3 3+ +
8 7 6+ +
--------------------- 10

21
------ 0.476= =

4 3 2+ +
8 7 6+ +
--------------------- 9

21
------ 0.4286= =


ˆ P0 Pe–

1 Pe–
------------------=

P0 pii
i
=

Pe pi .p.i
i
=
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If you view the two response variables as two independent ratings of the n parts, the Kappa 

coefficient equals +1 when there is complete agreement of the raters. When the observed 

agreement exceeds chance agreement, the Kappa coefficient is positive, and its magnitude 

reflects the strength of agreement. Although unusual in practice, Kappa is negative when the 

observed agreement is less than the chance agreement. The minimum value of Kappa is 

between -1 and 0, depending on the marginal proportions.

Estimate the asymptotic variance of the simple Kappa coefficient with the following equation:

where:

and:

The Kappas are plotted and the standard errors are also given.

Note: The Kappa statistics in the Attribute Chart platform are shown even when the levels of 

the variables are unbalanced.

Categorical Kappa statistics (Fleiss 1981) are found in the Agreement Across Categories 

report.

Given the following assumptions:

• n = number of parts (grouping variables)

• m = number of raters

• k = number of levels

• ri = number of reps for part i (i = 1,...,n)

• Ni = m x ri. Number of ratings on part i (i = 1, 2,...,n). This includes responses for all raters, 

and repeat ratings on a part. For example, if part i is measured 3 times by each of 2 raters, 

then Ni is 3 x 2 = 6.

• xij = number of ratings on part i (i = 1, 2,...,n) into level j (j = 1, 2,...,k)

var
A B C–+

1 Pe– 2n
--------------------------=

A pii 1 pi . p.i+  1 
ˆ

– –
i
=

B 1 
ˆ

– 
2 pij

p.i pj .+ 
2


i j
=

C 
ˆ

Pe 1 
ˆ

– –
2

=
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The individual category Kappa is defined as follows:

The overall Kappa is defined as follows:

The variance of  and  are calculated as follows:

The standard errors of  and  are shown only when there are an equal number of ratings 

per part (for example, Ni = N for all i = 1,…,n).

j
ˆ 1

xij Ni xij– 

i 1=

n



pjqj  Ni

i 1=

n

 Ni 1– 

-----------------------------------------------------–             where          pj

xij

i 1=

n



Ni

i 1=

n



-----------------         qj 1 pj–= = =


ˆ

qjpjj
ˆ

j 1=

k



pjqj

j 1=

k



--------------------------=

̂j 
ˆ

var ̂j  2
nN N 1– 
---------------------------=

var 
ˆ
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j 1=

k


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 
 
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-------------------------------------------------------- pjqj
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
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 
 
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Chapter 8
Process Screening

Screen Many Processes for Stability and Capability

Use the Process Screening platform to explore a large number of processes across time. The 

platform calculates process stability and process capability metrics. The platform creates 

control charts and detects large process shifts. The platform is intended to expedite the 

evaluation of a very large number of processes by enabling you to quickly focus on the 

processes that are unstable, not capable of meeting specification limits, or subject to shifts in 

the mean.

Based on your initial results, you can choose to explore specific processes graphically or in 

greater analytical depth. You can easily access the Control Chart Builder and Process 

Capability platforms. You can save detailed results for all of your processes or for specific 

processes.

Figure 8.1  Example of a Process Performance Graph



198 Process Screening Chapter 8
Quality and Process Methods

Contents
Overview of the Process Screening Platform  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 199

Example of Process Screening . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 199

Launch the Process Screening Platform. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 202

Limits Table  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 205

The Process Screening Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207

Process Screening Platform Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 213

Process Performance Graph. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 220

Additional Example of Process Screening. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 221

Statistical Details for the Process Screening Platform . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 223



Chapter 8 Process Screening 199
Quality and Process Methods Overview of the Process Screening Platform

Overview of the Process Screening Platform

The Process Screening platform facilitates the task of assessing data from a large number of 

processes for stability and capability. The results are largely based on control chart 

calculations to determine when a process is out of control. The Process Screening platform 

enables you to do the following:

• Specify a constant subgroup size or use a variable containing subgroup identifiers for 

control chart calculations using subgroups.

• Use grouping variables. For each combination of values of the group variables, an analysis 

is provided for each process variable.

• Use medians to make your centerline and sigma calculations robust to outliers.

• Obtain information about the location of large shifts in the mean of your processes.

You can customize the Summary report to show specific control chart tests, including tests for 

changes in process mean and spread. The report also provides capability information when 

you supply specification limits. The Process Performance Graph gives you a visual 

representation of the performance of your processes in terms of stability and capability. The 

Shift Graph shows locations of upshifts and downshifts.

Tip: For information about adding specification limits, see Using JMP.

Process Screening makes it easy to select specific processes for further analysis. The platform 

provides small run charts for these processes - the size of the plots makes it easy for you to 

view a substantial number at a time. You can also link to Control Chart Builder and the 

Process Capability platform for analyses of select processes.

You can save data tables containing results in various forms, either for your entire set of 

processes or only for select processes.

Example of Process Screening

You are interested in identifying unstable processes in a data table that contains 128 columns 

of process measurements. Each column contains a Spec Limits column property. If a process is 

stable, it is appropriate to calculate its process capability.

1. Select Help > Sample Data Folder and open Semiconductor Capability.jmp.

2. Select Cols > Column Viewer.

3. Select the Processes column group and click Show Summary.
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This enables you to quickly see summary statistics for all of the process columns. If you 

scroll through the Summary Statistics table, some of the columns have the same value for 

their minimum and maximum, indicating that the column has constant entries. You do not 

want to include these columns in the analysis.

4. In the Summary Statistics table, deselect VPM1, VPM2, PMS1, SNM1, PNP6, VPM4, VPM6, 

VPM9, P1, and M1. The columns selected in the Summary Statistics table correspond to the 

columns selected in the data table.

Tip: To deselect the columns, press Ctrl and click the column name in the table.

5. In the data table, select Analyze > Quality and Process > Process Screening.

6. Click Process Variables. This assigns the columns that are already selected in the data 

table as the process variables.

Notice that the Control Chart Type is set to Indiv and MR.

7. Click OK.

Figure 8.2  Partial View of Initial Report

The Process Screening window appears, showing a table of results for each process. The 

table is sorted by Stability Index. This is a measure of the stability of a process, where a 

stable process has a stability index near 1. Higher values of the stability index indicate a 

less stable process. (The sorting is indicated by the caret beside Stability Index in the 

report.) You want to take a closer look at processes with a stability index value greater than 

or equal to 1.03.

8. In the report window, select processes IVP8 through IVP9.

Each of these first 10 processes has a value of 1.03 or larger in the Stability Index column.
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9. Right-click the selected processes and select Show Charts for Selected.

Figure 8.3  Charts for Highest Alarm Rate Processes

You decide to take a closer look at IVP8 (row 1, column 1 in the Charts for Selected).

10. Select the first process in the Summary table, which corresponds to IVP8.

11. Right-click the selected process and select Control Charts for Selected Items.

Figure 8.4  Control Chart Builder Report for IVP8

A Control Chart Builder report appears. Because IVP8 has a Spec Limits column property, 

the report also includes a capability analysis.
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Launch the Process Screening Platform

Launch the Process Screening platform by selecting Analyze > Quality and Process > Process 
Screening.

Figure 8.5  Process Screening Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Launch Window Roles

Process Variables The columns of process data containing the measurements to be 

analyzed. The columns must have a Numeric data type. If a process variable has a Control 

Limits column property, the Process Screening platform uses those limits to calculate the 

Specified Sigma.

Note: The platform does not support control limits that are specified in a Control Limits 

column property for dispersion (R) charts.

Grouping Columns assigned as grouping variables. Each process variable is analyzed at each 

combination of levels of the grouping variables. The results are presented in a single 

report.
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Subgroup Assigns one or more subgroup variables. If more than one subgroup variable is 

assigned, the subgroup levels are defined as a combination of the multiple columns.

Note: The Subgroup role is ignored for Indiv and MR charts.

Time A numeric column whose values are used for the time order for the data. Use the Time 

role for data that are time-stamped. The time stamp is used for the time axis in quick 

graphs and shift graphs. The process data are sorted by the Time variable before 

calculations are performed.

By A column whose levels define separate analyses. For each level of the specified column, 

the corresponding rows are analyzed using the other variables that you have specified. 

The results are presented in separate tables and reports. If more than one By variable is 

assigned, a separate analysis is produced for each possible combination of the levels of the 

By variables.

Launch Window Options

Control Chart Type Select one of five control chart types: Indiv and MR (Individual 

Measurement and Moving Range); XBar and R; XBar and S; XBar, MR, and R; or XBar, MR, 

and S. The XBar, MR, and R control chart and the XBar, MR, and S control chart are also 

referred to as three way control charts. For more information about statistical details, see 

“Statistical Details for Control Chart Builder”.

Note: If the subgroup size for a process is 1, the chart automatically switches to an Indiv 

and MR chart.

Subgroup Sample Size Specifies a constant sample size for subgroups. The minimum 

subgroup size is 2. A subgroup size of 5 is the default. The Subgroup Sample Size 

specification is ignored for Indiv and MR charts or when a subgroup variable is specified.

KSigma Specifies the sigma multiplier. KSigma is the value that is multiplied by sigma in the 

calculation of control limits. By default, KSigma is 3.

Use Limits Table Enables you to import historical control limits and specification limits from 

a data table. When you select this option and click OK in the launch window, a Choose 

limits table window appears. Once you choose a limits tables and click OK, a Limits 

Specification window appears. Assign columns in your limits table to appropriate roles 

and click OK. See “Limits Table”.

Note: If you do not select this option, limits and sigma values are obtained from the 

Control Limit, Spec Limit, or Process Screening column properties for the Process 

Variables. If you do not select this option and the Process Variables do not have control 

limit column properties, the control limits are calculated from the data.
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Tip: To add columns properties to several columns at once, see “Manage Limits”

Use Medians instead of Means Estimates the center line using the median of the 

observations. Sigma is estimated using scaling factors obtained using Monte Carlo 

simulation. The table of factors is given in “Statistical Details for the Process Screening 

Platform”. The calculation depends on the type of chart selected:

– For XBar and R chart or Indiv and MR chart calculations, sigma is estimated using the 

scaled median of the ranges.

– For XBar and S chart calculations, sigma is estimated using the scaled median of the 

standard deviations.

– For unequal subgroup sizes, the scaling factor corresponds to the average subgroup 

size rounded to the nearest integer.

When one or more outliers influence the location of the center line, many subgroups can 

appear out of control. Using the median alleviates this problem.

Note: When Use Medians instead of Means is selected, the results obtained from the 

Control Charts for Selected Items or the Process Capability for Selected Items red triangle 

menu options do not match the Process Screening results.

Sort by Subgroup Sorts the process data by the subgroup variable, or combination of nested 

subgroup variables, before calculations are performed.

Advanced Options Contains the following options:

Shift Threshold Specify a value that controls the sensitivity of the Shift Graph. Shift 

Threshold is set to three by default. After outlier removal, the Shift Graph shows a plot 

of the time occurrence of all process shifts that exceed the number of within-sigma 

units specified by the Shift Threshold. See “Shift Graph”.

Outlier Threshold Specify a value that controls the sensitivity of outlier removal for 

detection of large recent shifts and for the Shift Graph. Outlier Threshold is set to five 

by default. If the number of within sigma units from an observation to both of its 

neighboring observations exceeds the specified Outlier Threshold, that observation is 

replaced with a value that is one within-sigma unit away from its closest neighboring 

observation. See “Shift Magnitudes and Positions”.

Shift Lambda Enables you to change the exponentially weighted moving average 

(EWMA) weight used in the Shift Graph. See “Shift Magnitudes and Positions”.

Drift Beta The weight used in the exponentially weighted moving average (EWMA) for 

drift detection. Drift Beta is set to 0.05 by default.
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Minimum Process Length The minimum number of data values that a process must 

have in order to be included in the analysis. By default, this value is set to 3.

Limits Table

A Limits Table contains a row for each process defined by the Process Variables and Grouping 

variables in your table of process data. When you use a Limits Table in the Process Screening 

platform, the Limits Specifications window enables you to specify variables with the roles 

listed below. You do not need to specify variables for all of these roles. All of these roles are 

optional.

Figure 8.6  Limits Specifications Window

Columns in the Limits Table that have appropriate names or names that match the role 

buttons are auto-filled. For example, any column called “Process”, “Column”, or “Parameter” 

is auto-filled into the Process Variables list.

If you have control limits but do not have columns for Center or Sigma, then you can use the 

Derived Sigma options.

Process Variables A column that contains values corresponding to the column names in 

your table of process data.
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Grouping One or more columns that contain the values of the grouping variables for your 

table of process data.

Center A column containing values for the center line for each process. This is usually the 

historical process mean.

Sigma A column containing values for the within standard deviation for each process. This 

is usually the historical standard deviation. This is labeled as Specified Sigma in the 

Process Screening report.

Derived Sigma Calculates sigma based on the given control limits and subgroup size. This is 

labeled as Specified Sigma in the Process Screening report.

Note: If there is a specified sigma, the within-sigma, stability index, and stability ratio 

values do not match between the Process Screening and Control Chart Builder platforms. 

The Process Screening platform uses the specified sigma to calculate the control limits, but 

still calculates the within-sigma using the data. The Control Chart Builder platform uses 

the specified sigma as the historical sigma and in control charts, the historical sigma is 

used as the within-sigma.

The derived sigma is calculated as follows:

Sigma = d*(UCL - LCL)/6

where d is the square root of the subgroup size.

LCL A column containing the lower control limits for each process.

UCL A column containing the upper control limits for each process.

Subgroup Size A column containing the subgroup size for each process.

LSL A column containing lower specification limits for each process.

USL A column containing upper specification limits for each process.

Target A column containing a target value for each process.

Importance A column containing an importance value for each process. The Importance 

column provides a mechanism to sort processes in the order that you prefer.
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The Process Screening Report

The Process Screening report opens with a Summary table that contains results about process 

stability. There is a label above the summary table that shows the type of control chart on 

which the results are based. The sample size or subgroup variable is also shown above the 

summary table for every chart type except for Indiv and MR. The summary table also contains 

capability results if you have provided specification limits. The processes and groups are 

initially sorted in decreasing order by Stability Index. If Importance values are specified by the 

user, the processes and groups are sorted in decreasing order by Stability Index within 

Importance. The columns for Stability Index, Ppk, Cpk, Cp, and Target Index are colored as 

green, yellow, and red to indicate adequate, marginal, and poor stability or capability, 

respectively. This color coding scheme matches the Process Performance graph color coding 

scheme.

Tip: To sort the report by a column, click the column name. A caret appears to the right of the 

column name. The direction of the caret indicates whether the sorting is descending or 

ascending. To change the order of the sorting, click the column name again. If you change the 

sorting, the graphs produced by the Show Chart as Selected, Show Chart for Selected, Drift 

Graph, and Control Charts for Selected Items options use the same sort as the Summary table.

The control chart calculations in the Summary table include Nelson tests and a Range Limit 

Exceeded test. These tests assume the following about the control chart limits:

• The center line for the XBar or X control charts is given by the mean of all measurements. If 

you use the Medians instead of Means option, the center line is given by the median of the 

observations.

• Control limits are placed at K sigma units from the center line. Use the KSigma option in 

the launch window to specify K. By default, KSigma is 3.

• Sigma is estimated using the conventions that correspond to the control chart type that 

you specified or, if you use Medians instead of Means, as described in “Use Medians 

instead of Means”.

Tip: The eight Nelson tests in the Process Screening platform follow the test settings in the 

Control Chart Builder platform preferences. You can customize the tests at File > Preferences > 

Platforms > Control Chart Builder.

The Summary table can contain the following information:

Column The columns that you entered as Process Variables. There is a row for each distinct 

combination of Process and Grouping columns. This column is suppressed if there is only 

one process column.
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Tip: To access options that operate on selected items, right-click the Column column. The 

right click menu also contains a Table option that provides a list of Table Box messages. 

See the JSL Syntax Reference.

Grouping Columns There is a report column for each column in the data table that you 

entered as Grouping. The levels of the Grouping columns are listed so that there is a 

unique row in the report table for each distinct combination of Process name and 

Grouping columns values.

Importance (Appears only when there are importance values specified by the user, as inputs 

from a limits table.) The user-specified importance value for the processes.

Variability Contains the following columns:

Stability Index A measure of stability of the process. A stable process has a stability index 

near one. Higher values indicate less stability. The stability index is defined as follows:

(Overall Sigma / Within Sigma)

If a three way control chart is selected in the launch, the stability index is defined as 

follows:

(Overall Sigma / Between-and-Within Sigma)

Stability Ratio A measure of stability of the process. A stable process has a stability ratio 

near one. Higher values indicate less stability. The stability ratio is defined as follows:

(Overall Sigma / Within Sigma)2

If a three way control chart is selected in the launch, the stability ratio is defined as 

follows:

(Overall Sigma / Between-and-Within Sigma)2

Within Sigma An estimate of the standard deviation based on within subgroup variation. 

The estimate is based on the control chart type that you specified, and is a short-term 

measure of variation. See “Statistical Details for the Process Capability Platform” for 

statistical details. If you select Medians instead of Means, Within Sigma is computed as 

described in “Use Medians instead of Means”.

Overall Sigma The usual estimate of standard deviation based on all observations.

Between Sigma (Appears only when three way control chart is selected in the launch 

window.) An estimate of the standard deviation based on the variation between 

subgroups. See “Statistical Details for the Process Capability Platform” for statistical 

details.
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Between-and-Within Sigma (Appears only when three way control chart is selected in 

the launch window.) An estimate of the standard deviation based on the variation 

between subgroups and the variation within subgroups. The Between-and-Within 

Sigma estimate is defined as follows:

Specified Sigma The standard deviation specified by a sigma control limit in the Limits 

Specification dialog or an estimate of the standard deviation derived from the control 

limits and subgroup size. See “Derived Sigma”. The control limits and subgroup size 

can be specified using a limits table or a Control Limits column property.

Summary Contains the following columns:

Centerline (Appears if you do one of the following: select Use Medians instead of Means 

in the launch window, import a Center value using a limits table, or import control 

limits to derive sigma.) The value listed under Centerline is used in control chart 

calculations as the center line.

• If you select Use Medians instead of Means in the launch window, the overall 

median of the observations is displayed.

• If you import a Center value from a limits table, that value is displayed.

• If you import control limits, the value displayed is calculated as (UCL + LCL)/2.

Mean The average of all observations.

Count The number of observations.

N Subgroups The number of subgroups.

Control Chart Alarms Contains information about the subgroups that result in alarms for a 

variety of tests, including each of the 8 Western Electric rules. The standard deviation 

estimate is the Within Sigma value. By default, only the Alarm Rate, Test 1, and Latest 

Alarm columns are shown in the Summary table.

Alarm Rate The number of subgroups that resulted in alarms for any of the tests selected 

under the Choose Test option (Any Alarm) divided by the number of non-missing 

subgroups (Subgroups).

Any Alarm (Appears only when more than one Test column is shown.) The number of 

subgroups that trigger alarms for any of the tests selected under the Choose Test 

option. These are the eight Nelson tests and the test for Range Limit Exceeded.

Between-and-Within Sigma Within Sigma
2

Between Sigma
2

+=
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Tip: The eight Nelson tests in the Process Screening platform follow the test settings in the 

Control Chart Builder platform preferences. You can customize the tests at File > 

Preferences > Platforms > Control Chart Builder.

Test 1 One point is more than three standard deviations from the center line. The 

subgroup associated with that point triggers the alarm.

Test 2 Nine or more consecutive points are on the same side of the center line. The 

subgroup associated with the ninth point triggers the alarm.

Test 3 Six or more consecutive points are continually increasing or decreasing. The 

subgroup associated with the sixth point triggers the alarm.

Test 4 Fourteen consecutive points alternate in direction: increasing and then decreasing 

or decreasing and then increasing. The subgroup associated with the 14th point 

triggers the alarm.

Test 5 Two out of three consecutive points on the same side of the center line are more 

than two standard deviations from the center line. The subgroup associated with the 

second point that exceeds two standard deviations triggers the alarm.

Test 6 Four out of five consecutive points on the same side of the center line are more 

than one standard deviation from the center line. The subgroup associated with the 

fourth point that exceeds one standard deviation triggers the alarm.

Test 7 Fifteen consecutive points, on either side of the center line, are all within one 

standard deviation of the center line. The subgroup associated with the 15th point 

triggers the alarm.

Test 8 Eight consecutive points, on either side of the center line, all fall beyond one 

standard deviation of the center line. The subgroup associated with the eighth point 

triggers the alarm.

Range Limit Exceeded The number of subgroups that exceed the upper control limit on 

the R, S, or MR chart calculation.

Moving Range Limit Exceeded The number of subgroups that exceed the moving range 

limit on the three way control chart calculation.

Latest Alarm The position of the subgroup, counting from the last subgroup, that 

signaled the most recent alarm for any of the Nelson or Range Limit Exceeded tests that 

are enabled in the report.

Capability (Appears only when there are Spec Limits specified for some processes.) Contains 

the following options:
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Ppk Capability index based on Overall Sigma and assuming a normal distribution. See 

“Statistical Details for the Process Capability Platform” for statistical details. On by 

default.

Cpk Capability index based on Within Sigma or Between-and-Within Sigma and 

assuming a normal distribution. See “Statistical Details for the Process Capability 

Platform” for statistical details. On by default.

Cp The potential capability if target and drift issues are resolved. See “Statistical Details 

for Capability Indices for Normal Distributions” for details.

Target Index The number of short-term standard deviations that the process average 

differs from the target value. This measures the ability of the process to hit the target 

value. The Target Index is calculated as 3(Cp - Cpk). A target index is considered poor 

if above 1, marginal if between 0.5 and 1, and adequate if less than 0.5. See White et al. 

(2018).

Out of Spec Count The number of observations that fall outside the specification limits. 

On by default.

Out of Spec Rate The proportion of observations that fall outside the specification 

limits. On by default.

Expected Out of Spec Rate The expected proportion of observations that fall outside of 

the specification limits. The Expected Out of Spec Rate assumes a stable and normally 

distributed process and uses overall sigma.

Latest Out of Spec The number of observations, counting from the last observation to 

the most recent observation that falls outside the specification limits. On by default.

(Mean-Tgt)/SpecRange The spec centered mean. This is the same as the Mean Shift 

Standardized to Spec in Process Capability. See “Statistical Details for the Goal Plot” for 

statistical details.

StdDev/SpecRange The spec scaled standard deviation. This is the same as the Std 

Deviation Standardized to Spec in Process Capability. See “Statistical Details for the 

Goal Plot” for statistical details.

LSL The lower specification limits.

USL The upper specification limits.

Target The target value.
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Shift Magnitudes and Positions (Shown only if you have selected a Shift Detection option 

from the Process Screening red triangle menu.) Shift detection is performed to identify 

shifts that exceed one within-sigma unit. The algorithm uses outlier-correction and an 

EWMA smoothing approach for the individual observations. This is the algorithm:

– Outliers are removed so that single outliers do not indicate shifts. The value specified 

as Outlier Threshold (five by default) on the launch window controls the sensitivity of 

outlier removal. If the number of within-sigma units from an observation to both of its 

neighboring observations exceeds the specified Outlier Threshold, that observation is 

replaced with a value that is one within-sigma unit away from its closest neighboring 

observation.

– An EWMA fit is constructed for the subgroup means in forward time order and 

another EWMA fit is constructed for the subgroup means in reverse time order. The 

EWMA fits have lambda equal to 0.3.

– The largest positive and negative differences between successive EWMA values that 

exceed one within-sigma unit are identified.

– The absolute values of these differences, divided by the within estimate of sigma, are 

the values reported as Largest Upshift and Largest Downshift.

– The locations of the first subgroups involved in these largest shifts define the Upshift 

Position and Downshift Position.

Largest Upshift The magnitude of the largest upward shift that exceeds one 

within-sigma unit, reported in within-sigma units.

Upshift Position or Upshift <Time Variable> The position of the subgroup having the 

largest Upshift. If you specify a Time variable, the column in the Summary table is 

named Upshift <Time Variable> and the position of the shift is given in terms of the 

Time variable.

Largest Downshift The magnitude of the largest downward shift that exceeds one 

within-sigma unit, reported in within-sigma units.

Downshift Position or Downshift <Time Variable> The position of the subgroup having 

the largest Downshift. If you specify a Time variable, the column in the Summary table 

is named Downshift <Time Variable> and the position of the shift is given in terms of 

the Time variable.

Drift Magnitudes and Positions (Shown only if you have selected the Drift Summaries 

option from the Process Screening red triangle menu.) Drift detection is performed to 

detect smaller, more gradual changes in processes. The algorithm is identical to the one 

used in shift detection, except that drift detection uses a Holt Double-Exponential 

Smoother instead of an EWMA. This is the algorithm:

– Outliers are removed through the same process that is used in shift detection. See 

“Shift Magnitudes and Positions”.
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– The drift detection algorithm fits a Holt Double-Exponential Smoothing model for the 

subgroup means in forward time order and fits another Holt Double-Exponential 

Smoothing model for the subgroup means in reverse time order. The two smoothing 

model fits each have two smoothing constants:  for the level and  for the slope. The  

smoothing constant is set at 0.05 and the  smoothing constant is estimated to 

minimize the error.

– The means of the positive drift values, negative drift values, and absolute drift values 

are reported as Mean Up Drift, Mean Down Drift, and Mean Abs Drift, respectively.

Mean Up Drift The sum of the positive drift values divided by the count.

Mean Down Drift The sum of the negative drift values divided by the count.

Mean Abs Drift The sum of the absolute value of all drift values divided by the count.

Note: Process Screening does not utilize the Distribution or Process Capability Distribution 

column properties and always performs capability analyses assuming a normal distribution. If 

the distribution type for one of these column properties is non-normal, a Warnings outline is 

shown below the Summary table.

Process Screening Platform Options

The Process Screening red triangle menu contains options to customize the display and to 

save calculated statistics. The options that operate on selected items are also accessible by 

right-clicking the Column column in the Summary table.

Summary Shows or hides the Summary table. See “The Process Screening Report”.

Find and Select Enter search strings for columns that you entered as Process Variables or 

Grouping in the launch window. A panel appears for each column. The corresponding 

processes are selected in the Summary table.

Select Where Opens the Select Where window. You can select specific processes in the 

Summary table that correspond to a particular condition by using the Comparison menu 

and Value text box. For example, you can select all processes such that Ppk < 1.33. After 

you click OK, the processes are selected in the Summary table.

Tip: You can also access the Select Where window by right-clicking anywhere in the 

Summary table.

Filter Where Opens the Filter Where window. Enables you to filter the processes shown in 

the Summary table. Select a column and use the Comparison menu and Value text box to 
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define a filter. After you click OK, only the processes that meet the specified condition are 

shown in the Summary table.

Tip: You can also access the Filter Where window by right-clicking anywhere in the 

Summary table.

Reset Filter (Available only after a filter is applied to the Summary table using the Filter 

Where option.) Removes any filter that is currently applied to the Summary table.

Show Summary Columns Enables you to choose some of the summary columns that are 

shown in the Summary table.

Show Charts as Selected Plots small graphs of the processes that are selected in the 

Summary table in a Charts as Selected report. This report automatically updates as you 

select and deselect processes in the Summary table. These charts have the same 

information and options as the charts in the Charts for Selected report. See “Show Charts 

for Selected”.

Show Charts for Selected Plots small graphs of the processes that are selected in the 

Summary table in a Charts for Selected report. The report makes it possible to view and 

compare many processes at once. By default, each chart has red lines for the control limits. 

The Chart for Selected red triangle menu contains additional options to change the 

appearance of the graphs. See “Chart Settings”. To remove the graphs, click the Charts for 

Selected red triangle and select Remove.

Chart Settings Opens a window that enables you to specify chart settings for the charts in 

Charts as Selected, Charts for Selected, Graphlet Charts, and Drift Charts. You can specify 

the following settings separately for each type of chart:

Dispersion Chart (Not available for Drift Charts.) Shows or hides a range, standard 

deviation, or moving range chart in addition to the control chart for each process.

Show Markers Shows or hides the individual points on the charts.

Connect Points Connects the points on the charts.

Show Control Limits Shows or hides the upper and lower control limits.

Show Centerline Shows or hides a solid green line for the average of the process.

Show Zones (Not available for Drift Charts.) Shows or hides the one and two standard 

deviation zones on the charts.

Circle Alarm Points (Not available for Drift Charts.) Shows or hides red circles around 

points that are in an alarm state. The corresponding alarm code is shown next to each 

circled point.

V Axis Label Shows or hides the vertical axis label on each chart.
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Show Spec Limits Shows or hides the upper and lower specification limits as dotted 

blue lines.

Number of Plots Across Specifies the layout for the charts.

Frame Size Enables you to specify a frame size that is used for all of the charts.

Launch for Selected Enables you to launch either Control Chart Builder or Process 

Capability for the items selected in the Summary table.

Control Chart Builder Opens a Control Chart Builder report window for the processes 

that you selected in the Summary table. The control chart corresponds to your 

selections in the Process Screening launch window.

Notes:

– If a process variable has a Spec Limits column property, the specifications limits 

defined in the column property override any specification limits that were assigned 

using a limits table.

– Only the tests selected in Process Screening are sent to Control Chart Builder. Tests that 

have been turned off are not sent.

– If you have multiple subgroup variables where the inner subgroup variable is not 

sorted within the outer subgroup variable, a new subgroup variable column is created 

and used when Control Charts for Selected Items is launched. This does not apply if 

Sort by Subgroup is selected in the Process Screening launch window.

Process Capability Opens a Process Capability report window showing Individual 

Detail Reports for the processes that you select in the Summary table. If you select a 

process for which specification limits are not specified, a Spec Limits window appears. 

In this window, you can specify specification limits by selecting a data table or entering 

values directly.

The Process Capability analysis assumes normal distributions and uses within sigma 

values that correspond to your Control Chart Type selection in the Process Screening 

launch window:

– Moving range for Indiv and MR

– Average of ranges for XBar and R

– Average of unbiased standard deviations for XBar and S

Notes:

– If you specify sigma using a sigma control limit or the Derived Sigma option in the 

Limits Specifications window, this value is not used in Process Capability. This is 

because the Process Screening and Process Capability platforms use these control limits 

differently.
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– If you have multiple subgroup variables where the inner subgroup variable is not 

sorted within the outer subgroup variable, a new subgroup variable column is created 

and used when Process Capability for Selected Items is launched. This does not apply 

if Sort by Subgroup is selected in the Process Screening launch window.

Color Selected Items Applies a color of your choosing to the values in the selected rows of 

the Summary table.

Remove Selected Items Removes the rows selected in the Summary table and reruns the 

analysis without those processes.

Show Tests Shows or hides test results for Nelson tests that are selected under the Choose 

Tests option in the Process Screening report’s summary table.

Choose Tests Enables you to choose the tests that you want to include in the calculation of 

Alarm Rate and Any Alarm.

Tip: To select multiple tests, press Alt and click the Process Screening red triangle to open 

a menu of all platform options.

Shift Detection Provides options for detecting shifts after outlier removal. See “Shift 

Magnitudes and Positions”.

Largest Upshift Adds columns for Largest Upshift and Upshift Position to the Summary 

table. The largest upward shift in the series that exceeds one within-sigma unit is 

identified. See “Shift Magnitudes and Positions”.

Largest Downshift Adds columns for Largest Downshift and Downshift Position to the 

Summary table. The largest downward shift in the series that exceeds one within-sigma 

unit is identified. See “Shift Magnitudes and Positions”.

Shift Graph (Available only when some processes have shifts that exceed the Shift 

Threshold.) Shows a plot of the time occurrence of all process shifts that exceed the 

number of within-sigma units specified by the Shift Threshold (three by default). You 

can also change the Shift Threshold by using the slider bar on the Shift Graph. Hover 

over the diamond to see the value. Green markers indicate upshifts and red markers 

indicate downshifts. The markers are located at the local peaks of the shifts.

To identify the processes that correspond to one or more shift occurrences, select the 

points and click Select Process. The corresponding processes are selected in the 

Summary table. Processes that have no shifts exceeding the Shift Threshold number of 

within-sigma units are not plotted.



Chapter 8 Process Screening 217
Quality and Process Methods Process Screening Platform Options

Note: The Shift Graph does not show the positions of Largest Upshift and Largest 

Downshift values that appear in the Summary table if the shifts are less than the specified 

Shift Threshold number of within-sigma units in magnitude. See “Additional Example of 

Process Screening”.

Show Shifts in Quick Graphs (Available only when a Quick Graph has been added to the 

report window.) Shows the location of the shifts in the Quick Graphs using green and 

red vertical lines.

Drift Summaries Adds columns for Mean Up Drift, Mean Down Drift, and Mean Abs 

Drift to the Summary Table. See “Drift Magnitudes and Positions”.

Drift Graph Selected Displays a drift graph for each process that you select in the 

Summary Table. Drift graphs enable you to detect smaller, more gradual changes in the 

selected processes. The values plotted are the slope estimates from a Holt 

Double-Exponential Smoothing model. See “Drift Magnitudes and Positions”. Each 

drift graph displays the within-sigma value and the estimates for the two smoothing 

parameters in the Holt Double-Exponential Smoothing model. The Drift Graphs red 

triangle menu contains additional options to change the appearance of the graphs. See 

“Chart Settings”. To remove the graphs, click the Drift Graphs red triangle and select 

Remove.

Process Performance Graph (Available only when specification limits are defined for at 

least one process variable.) Shows a four-quadrant graph that assesses the performance of 

processes in terms of stability and capability. See “Process Performance Graph”.

Process Performance Graph Boundaries (Available only once the Process Performance 

Graph is in the report window.) Opens a window where you can set values for the Process 

Performance Graph’s stability index and Ppk capability boundaries.

Tip: You can set preferences for your desired boundaries for Stability Index and Ppk 

Capability in File > Preferences > Platforms > Process Screening.

Goal Plot (Available only when specification limits are defined for at least one process 

variable.) The Goal Plot shows, for each variable, the spec-normalized mean shift on the X 

axis, and the spec-normalized standard deviation on the Y axis. If you define importance 

values for the processes, the goal plot points are sized by importance. It is useful for 

getting a quick, summary view of how the variables are conforming to specification limits. 

See “Goal Plot” for more information about goal plots and their features.

Tip: Hover over a point in the Goal Plot to view a graphlet of the control chart for that 

process. Click the Quick Graph to add it to the report window. To change the settings of 

the graphlets, see “Chart Settings”.
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The Goal Plot red triangle menu contains the following options:

Show Within Sigma Points Shows or hides the points calculated using the within sigma 

estimate.

Show Within or Between-and-Within Sigma Points (Available only when three way 

control chart is selected in the launch window.) Shows or hides the points calculated 

using the between-and-within sigma estimate.

Show Overall Sigma Points Shows or hides the points calculated using the overall sigma 

estimate.

Shade Levels Shows or hides the Ppk level shading. This is turned on by default. The 

shaded areas depend on the relationship between p and Ppk, with p representing the 

value shown in the box beneath Ppk. By default, p = 1.33.

– Points in the red area have Ppk < p.

– Points in the yellow area have p < Ppk < 2p.

– Points in the green area have 2p < Ppk.

Label Within Sigma Points Shows or hides labels for points calculated using the within 

sigma estimate.

Label Within or Between-and-Within Sigma Points (Available only when a three way 

control chart is selected in the launch window.) Shows or hides labels for points 

calculated using the between-and-within sigma estimate.

Label Overall Sigma Points Shows or hides labels for points calculated using the overall 

sigma estimate.

Defect Rate Contour Shows or hides a contour representing a specified defect rate.

Show Capability (Available only when specification limits are defined for at least one 

process variable.) Displays a submenu that enables you to show or hide the Capabilities in 

the Summary table.

Note: Spec Centered Mean and Spec Scaled Std Dev are displayed in the Summary table 

as (Mean-Tgt)/SpecRange and StdDev/SpecRange. The Spec Limits option displays the 

LSL, USL, and Target columns in the Summary table.

The following option is also available in the submenu:

Color Out of Spec Values Colors the cells in the data table that correspond to values that 

are out of spec. The cell is colored red if the value is above the USL and blue if the value 

is below the LSL.
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Tip: To remove colors in specific cells, select all cells of interest. Right-click in one of the 

cells and select Clear Color.

Save Summary Table Saves all of the information that can appear in the Summary table to a 

Process Summary data table. The Process Summary data table also contains specification 

limit details, if these are specified for at least one process. As in the summary table, the 

columns for Stability Index, Ppk, Cpk, Cp, and Target Index are colored as green, yellow, 

and red to indicate adequate, marginal, and poor stability or capability, respectively.

Save Summary Table with Graphs Creates the Process Summary data table with an 

additional column titled Graph. The Graph column contains a quick graph for each process 

in the Process Summary table.

Save Details Table Saves detailed information about control chart calculations to a Process 

Details data table. For each combination of process and grouping variables, the table 

contains a row for each subgroup showing:

– The value of the subgroup variable

– The values of the subgroup sample statistics.

– The control limits.

– The subgroup size.

– A list of indicators for which, if any, alarms were triggered. Alarms for the Nelson tests 

are indicated with the numbers for the tests. An alarm for the Range Limit Exceeded 

test is indicated with an R.

– The Drift

Save Selected Details For the selected rows in the Summary table, saves a Process Details 

table with the information that is saved when you select Save Details Table.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.
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Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Process Performance Graph

The Process Performance Graph in the Process Screening platform is a four-quadrant plot of 

capability versus stability. Each process for which specification limits are provided is 

represented by a marker. The marker type depends on if the process violates guidelines for the 

Target Index and Cp values. A left-pointing triangle indicates the process is below target, a 

circle indicates the process is on target, and a right-pointing triangle indicates the process is 

above target. An open marker indicates that the variation of the process is adequate and a 

filled marker indicates that the variation of the process could be reduced. A complete 

description of the marker combinations is provided in Table 8.1. Additionally, if you define 

importance values for the processes, the markers on the Process Performance Graph are sized 

by importance.

On the graph, the horizontal coordinates represent the stability index of the process and 

the vertical coordinates represent the capability of the process, given as Ppk. The graph is 

divided into four quadrants based on the following default boundaries:

– A stability index that exceeds 1.25 indicates that the process is unstable.

– A Ppk that is smaller than 1.33 indicates that the process is not capable.

Additionally, there is a red line on the graph at 1.33 divided by Stability Index that 

indicates where the Cpk value is 1.33. This line categorizes the processes in the unstable 

Table 8.1  Process Performance Graph Markers

Graph Marker Target Index Cp

On Target Adequate Variation

On Target Reduce Variation

Above Target Adequate Variation

Above Target Reduce Variation

Below Target Adequate Variation

Below Target Reduce Variation
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and incapable quadrants in terms of how they might be fixed. Processes below the red line 

are fixable by special causes; processes above the red line are fixable by reducing 

variability. Selecting points in the graph selects the corresponding processes in the 

Summary table.

Tip: Hover over a point in the Process Performance Graph to view a graphlet of the control 

chart for that process. Click the Quick Graph to add it to the report window. To change the 

settings of the graphlets, see “Chart Settings”.

Additional Example of Process Screening

This example illustrates the use of a Grouping column and the construction of a Shift Graph 

using data from a consumer price index. The data table contains monthly data on 17 products, 

and the time periods vary by product. The data are arranged so that all 17 products are listed 

in a single column called Series. To separate the products, you must treat Series as a Grouping 

column.

1. Select Help > Sample Data Folder and open Consumer Prices.jmp.

2. Select Analyze > Quality and Process > Process Screening.

3. Select Price and click Process Variables.

4. Select Series and click Grouping.

This ensures that each level of Series is treated as a separate process.

5. Select Date and click Time.

6. Set the Control Chart Type to XBar and R.

7. Set the Subgroup Sample Size to 3.

Because the data are given monthly, subgroups of size three represent quarters.

8. Click OK.

9. Press Alt and click the red triangle next to Process Screening.

This opens a window showing the available red triangle options. You can select multiple 

options at once in this window.

10. Check the following: Largest Upshift, Largest Downshift, and Shift Graph.

11. Click OK.

The columns Largest Upshift, Upshift Date, Largest Downshift, and Downshift Date are 

added to the Summary table. The shifts are the largest shifts exceeding one within-sigma 

unit. The position of each shift is given in terms of the Time variable, Date. See “Shift 

Magnitudes and Positions”.
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A Shift Graph also appears. The Shift Graph shows all shifts that exceed the number of 

Shift Threshold within-sigma units, which is set to three by default. See “Shift Graph”. 

Green points correspond to upshifts and red points correspond to downshifts.

Notice that Gasoline, All has values for both Largest Upshift and Largest Downshift in the 

Summary table. The Largest Downshift value, 1.8296, is less than three. Because the Shift 

Graph shows shifts of only three or more within-sigma units, the Largest Downshift value 

for Gasoline, All is not plotted on the Shift Graph.

Also notice that Tomatoes is not included on the Shift Graph. For Tomatoes, no shifts of 

three or more within-sigma units were found.

12. Double-click the horizontal axis of the Shift Graph to open the X Axis Settings window.

13. In the Tick/Bin Increment panel, set # Minor Ticks to 1.

14. Set Label Row Nesting to 2.

15. Click OK.

Figure 8.7  Shift Graph

Most series show primarily upshifts. Price Coffee, however, has several alternating 

downshifts and upshifts. To better understand this series, obtain a control chart.

16. Select any point to the right of Price Coffee in the Shift Graph and click Select Process.

This action selects the row of the Summary table corresponding to Coffee.

17. Right-click the selected process in the Summary table and select Control Charts for 
Selected Items.
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Figure 8.8  Control Chart for Coffee

The control chart shows the upshifts and downshifts that are identified in the Shift Graph.

The Summary table indicates that the largest upshift (25.399 within-sigma units) occurs for 

the subgroup that includes September 1994. In the control chart in Figure 8.8, this is the 

subgroup in position 59. The Summary table also indicates that the largest downshift 

(9.1674 within-sigma units) occurs for the subgroup that includes March 1981. This is the 

subgroup in position 5 in the control chart.

Because shifts are calculated using EWMA-smoothed series and an outlier-correction 

algorithm, the shift positions might not precisely correspond to the subgroups that seem 

to start the shifts on a Shewhart control chart.

Statistical Details for the Process Screening 
Platform

This section describes how scaling factors are calculated when you use medians to estimate 

sigma. When you select Use Medians instead of Means, sigma is estimated using a scaled 

median range or median standard deviation. The table below gives the scaling factors, which 

were obtained using Monte Carlo simulation.
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For subgroups of size n drawn from a normal distribution, the following are true:

• The theoretical median of the ranges is approximately d2_Median*, where d2_Median is 

the value corresponding to n.

• The theoretical median of the standard deviations is approximately c4_Median*, where 

c4_Median is the value corresponding to n.

Table 8.2  Scaling Constants for Median Range and Median Standard Deviation

n d2_Median c4_Median

2 0.953 0.675

3 1.588 0.833

4 1.978 0.888

5 2.257 0.917

6 2.471 0.933

7 2.646 0.944

8 2.792 0.952

9 2.915 0.959

10 3.024 0.963

11 3.118 0.967

12 3.208 0.969

13 3.286 0.972

14 3.357 0.975

15 3.422 0.976

16 3.483 0.978

17 3.539 0.979

18 3.590 0.980

19 3.640 0.981

20 3.685 0.982

21 3.731 0.983

22 3.770 0.984
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23 3.811 0.984

24 3.846 0.985

25 3.883 0.986

Table 8.2  Scaling Constants for Median Range and Median Standard Deviation (Continued)

n d2_Median c4_Median
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Chapter 9
Process Capability

Measure the Variability of a Process over Time

Process capability analysis, used in process control, measures how well a process is 

performing compared to given specification limits. A good process is one that is stable and 

consistently produces product that is well within specification limits. A capability index is a 

measure that relates process performance, summarized by process centering and variability, 

to specification limits.

Graphical tools such as a goal plot and box plots give you quick visual ways of identifying 

which process or product characteristics are within specifications. Individual detail reports 

display a capability report for each variable in the analysis. The analysis enables you to 

identify variation relative to the specifications or requirements; this enables you to achieve 

increasingly higher conformance values.

You can specify subgroups to compare the overall variation of the process to the within 

subgroup variation. You can compute capability indices for processes that produce 

measurements that follow various distributions. For data that follow none of the specified 

distributions, you can compute nonparametric capability indices.

Figure 9.1  Example of the Process Capability Platform
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Overview of the Process Capability Platform

The Process Capability platform provides the tools needed to measure the compliance of a 

process to given specifications. By default, JMP shows a Goal Plot, Capability Box Plots, and a 

Capability Index Plot for the variables that you fit with normal distributions. Capability 

indices for nonnormal variables are plotted on the Capability Index Plot. You can add 

normalized box plots, summary reports, and individual detail reports for the variables in your 

analysis.

You can supply specification limits in several ways:

• in the data table, using a column property

• by requesting the Spec Limits Dialog in the launch window

• by loading the limits from a specification limits data table

• using the Manage Limits utility (Analyze > Quality and Process > Manage Limits)

You can specify two-sided, one-sided, or asymmetric specification limits.

Note: The Process Capability platform expands significantly on the Capability analyses that 

are available through Analyze > Distribution and through Analyze > Quality and Process > 

Control Chart.

Capability Indices

A capability index is a ratio that relates the ability of a process to produce product that meets 

specification limits. The index relates estimates of the mean and standard deviation of the 

quality characteristic to the specification limits. Within estimates of capability are based on an 

estimate of the standard deviation constructed from within-subgroup variation. Overall 

estimates of capability use an estimate of standard deviation constructed from all of the 

process data. See “Statistical Details for Capability Indices for Normal Distributions” and 

“Statistical Details for Variation Statistics”.

Estimates of the mean or standard deviation are well-defined only if the processes related to 

centering or spread are stable. Therefore, interpretation of within capability indices requires 

that process spread is stable. Interpretation of overall capability indices requires that both 

process centering and spread are stable.

Capability indices constructed from small samples can be highly variable. The Process 

Capability platform provides confidence intervals for most capability indices. Use these to 

determine the range of potential values for your quality characteristic’s actual capability.
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Note:  When confidence intervals are not provided (for example, for nonnormal 

distributions) you can use the Simulate feature to construct confidence intervals. For an 

example, see “Example of the Simulation of Confidence Limits for a Nonnormal Process Ppk”.

Guidelines for values of capability indices can be found in Montgomery (2013). The minimum 

recommended value is 1.33. Six Sigma initiatives aim for much higher capability levels that 

correspond to extremely low rates of defective parts per million.

Capability Indices for Nonnormal Processes

The Process Capability platform constructs capability indices for process measurements with 

the following distributions: Normal, Beta, Exponential, Gamma, Johnson, Lognormal, Mixture 

of 2 Normals, Mixture of 3 Normals, SHASH, and Weibull. A Best Fit option determines the 

best fit among these distributions and provides capability indices for this fit. The platform also 

provides a Nonparametric fit option that gives nonparametric estimates of capability.

For the nonnormal methods, estimates are constructed using two approaches: the 

ISO/Quantile method (Percentiles) and the Bothe/Z-scores method (Z-Score). For more 

information about these methods, see “Statistical Details for Capability Indices for Nonnormal 

Distributions”.

Note: Process Capability analysis for individual responses is accessible through Analyze > 

Quality and Process > Control Chart Builder. However, nonnormal distributions are available 

only in the Process Capability platform.

Overall and Within Estimates of Sigma

Most capability indices in the Process Capability platform can be computed based on 

estimates of the overall (long-term) variation and the within-subgroup (short-term) variation. If 

the process is stable, these two measures of variation should yield similar results since the 

overall and within subgroup variation should be similar. The normalized box plots and 

summary tables can be calculated using either the overall or the within-subgroup variation. 

See “Additional Examples of the Process Capability Platform” for examples of capability 

indices computed for stable and unstable processes.

You can specify subgroups for estimating within-subgroup variation in the launch window. 

You can specify a column that defines subgroups or you can select a constant subgroup size. 

For each of these methods, you can choose to estimate the process variation using the average 

of the unbiased standard deviations or using the average of the ranges. If you do not specify 

subgroups, the Process Capability platform constructs a within-subgroup estimate of the 

process variation using a moving range of subgroups of size two. Finally, you can specify a 

historical sigma to be used as an estimate of the process standard deviation.



Chapter 9 Process Capability 231
Quality and Process Methods Example of the Process Capability Platform with Normal Variables

Capability Index Notation

The Process Capability platform provides two sets of capability indices. See “Statistical Details 

for Capability Indices for Normal Distributions” for more information about the calculation of 

the capability indices.

• Cpk, Cpl, Cpu, Cp, and Cpm. These indices are based on a within-subgroup (short-term) 

estimate of the process standard deviation.

• Ppk, Ppl, Ppu, Pp, and Cpm. These indices are based on an overall (long-term) estimate of 

the process standard deviation. Note that the process standard deviation does not exist if 

the process is not stable. See Montgomery (2013).

The Process Capability platform uses the appropriate AIAG notation for capability indices: 

Ppk labeling denotes an index constructed from an overall variation estimate and Cpk denotes 

an index constructed from a within-subgroup variation estimate.

Note: The AIAG (Ppk) Labeling platform preference is selected by default. You can change 

the reporting to use Cp notation only by deselecting this preference under Process Capability.

For more information about process capability analysis, see Montgomery (2013) and Wheeler 

(2004).

Example of the Process Capability Platform with 
Normal Variables

In this example, you use the Process Capability platform to analyze standard measurements 

that a semiconductor manufacturer might make on a wafer as it is being processed. 

Specification limits for the variables have been entered in the data table through the Column 

Properties > Spec Limits property.

1. Select Help > Sample Data Folder and open Semiconductor Capability.jmp.

2. Select Analyze > Quality and Process > Process Capability.

3. Click the white triangle next to Processes to view all of the continuous variables.

4. Select PNP1, PNP2, NPN2, PNP3, IVP1, PNP4, NPN3, and IVP2, and click Y, Process.

5. Click OK.

6. Click the Goal Plot red triangle and select Label Overall Sigma Points.

7. Click the Capability Index Plot red triangle and select Label Overall Sigma Points.
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Figure 9.2  Example Results for Semiconductor Capability.jmp

The Goal Plot shows the spec-normalized mean shift on the x-axis and the spec-normalized 

standard deviation on the y-axis for each variable. The triangular region defined by the red 

lines in the bottom center of the plot is the goal triangle. It defines a region of capability index 

values. You can adjust the goal triangle using the Ppk slider to the right of the plot. When the 

slider is set to 1, note that PNP1, PNP3, IVP1, and IVP2 are outside of the goal triangle and 

possibly out of specification.

The Capability Box Plots report shows a box plot for each variable in the analysis. The values 

for each column are centered by their target value and scaled by the specification range. In this 

example, all process variables have both upper and lower specification limits, and these are 

symmetric about the target value. It follows that the solid green line shows where the target 

should be and the dashed lines represent the specification limits.
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It appears that the majority of points for IVP1 are above its upper specification limit (USL), and 

the majority of points for IVP2 are less than its target. PNP2 seems to be on target with all data 

values inside the specification limits.

The Capability Index Plot plots the Ppk values for each variable. Four variables come from 

very capable processes, with Ppk values of 2 or more. Four variables have Ppk values below 1.

Example of the Process Capability Platform with 
Nonnormal Variables

In this example, you use the nonnormal capability features of the Process Capability platform 

to compute capability indices.

View the Distributions

1. Select Help > Sample Data Folder and open Process Measurements.jmp.

2. Select Analyze > Distribution.

3. Select all seven columns from the Select Columns list and click Y, Columns.

4. Check the box next to Histograms Only.

5. Click OK.

For most processes, the histograms show evidence that the theoretical distribution of 

measurements is skewed and does not follow a normal distribution. Therefore, for each 

process, you find the best fitting distributions among all of the available parametric 

distributions.

Perform a Capability Analysis

1. Select Analyze > Quality and Process > Process Capability.

2. Select all seven columns from the Columns list and click Y, Process.

3. Select all seven columns in the Y, Process list.

4. Open the Distribution Options panel and select Best Fit from the Distribution list.

5. Click Set Process Distribution.

The suffix &Dist(Best Fit) is added to each variable name in the Y, Process list. The Best Fit 

option specifies that the best-fitting parametric distribution should be fit to each variable. 

The available parametric distributions are Normal, Beta, Exponential, Gamma, Johnson, 

Lognormal, Mixture of 2 Normals, Mixture of 3 Normals, SHASH, and Weibull 

(Figure 9.3).
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6. Open the Nonnormal Distribution Options outline. Note that the Nonnormal Capability 

Indices Method is set to Percentiles, the Johnson Distribution Fitting Method is set to 

Quantile Matching, and the Distribution Comparison Criterion is set to AICc.

Figure 9.3  Completed Launch Window

The Quantile Matching method is the default method used for fitting Johnson 

distributions because of its stability and speed as compared to Maximum Likelihood. Note 

that Maximum Likelihood is used in the Distribution platform.

7. Click OK.

8. Click the Goal Plot red triangle and select Label Overall Sigma Points.

9. Click the Capability Index Plot red triangle and select Label Overall Sigma Points.
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Figure 9.4  Initial Report with Variables Labeled

Note: Click a label in the plot and drag it to make the plot more interpretable. Click the 

right side frame of the Capability Index Plot and drag it to the right to make the labels 

easier to distinguish.

The Goal Plot shows only one point and it corresponds to Process 7. The Capability Box 

Plots report shows a single box plot for Process 7. This is because the best fit for Process 7 
is a normal distribution.

10. To the right of the Capability Index Plot, set the Ppk value to 2.
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The Capability Index Plot shows Ppk values for all seven processes. Only two processes, 

Process 2 and Process 7, have capability values that exceed 2. Note that the best fitting 

nonnormal distributions are shown in parentheses to the right of the variable names in the 

Capability Index Plot. The best fitting distribution for Process 7 is not shown because it is 

a normal distribution.

11. Click the Process Capability red triangle and select Individual Detail Reports.

Because you requested Best Fit in the launch window, the Compare Distributions option 

has been selected from each distribution’s red triangle menu.

12. Scroll to the report entitled Process 4(Lognormal) Capability.
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Figure 9.5  Individual Detail Report for Process 4

The title of the report for Process 4 indicates that the capability calculations are based on a 

lognormal fit. All of the check boxes in the Compare Distributions report, except the boxes 
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for Nonparametric and Beta, are checked, indicating that these nine distributions are fit. 

(This is because you requested a Best Fit in the launch window.) The button that is selected 

in the Selected column indicates that the Lognormal distribution is the distribution that is 

used in the remainder of the Process 4(Lognormal) Capability report to estimate capability 

and nonconformance.

The Compare Distributions report enables you to compare the nine distributional fits. The 

Histogram - Compare Distributions report gives a visual assessment of the fit and the 

Comparison Details report shows fit statistics for the selected distributions. Both the plot 

and the fit statistics indicate that the lognormal distribution gives the best fit among the 

selected distributions.

The Individual Detail Report information that is shown by default includes a histogram 

showing the estimated best-fit distribution, a summary of the process information, 

capability indices based on an overall estimate of sigma, parameter estimates for the fitted 

lognormal distribution, and observed and expected nonconformance levels.
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Launch the Process Capability Platform

Launch the Process Capability Platform by selecting Analyze > Quality and Process > Process 
Capability. In Figure 9.6, all sections and panels have been opened.

Figure 9.6  Process Capability Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.
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The Process Capability launch window contains the following outlines and options:

• “Process Selection”

• “Process Subgrouping”

• “Moving Range Options”

• “Historical Information”

• “Distribution Options”

• “Other Specifications”

After you click OK in the launch window, the Spec Limits window appears unless one of the 

following occurs:

• All of the columns contain specification limits.

• You selected No (skip columns with no spec limits) on the launch window.

The Spec Limits window also appears if you select Yes on the launch window. Otherwise, the 

Process Capability report window appears.

Process Selection

In the Process Capability launch window, select the process variables to include in the 

analysis.

Y, Process Assigns the variables that you want to analyze.

Notes:

• The Transform menu is not available for the Select Column list in the Process Capability 

launch window. Right-click a column heading in the data table and select New Formula 
Column to create a transform column for use in Process Capability. See Using JMP for more 

information about creating new formula columns.

• Reference columns for virtually joined tables are not available in the Process Capability 

platform.

Process Subgrouping

In the Process Capability launch window, the options in this section enable you to assign each 

variable in the Y, Process list a subgroup ID column or a constant subgroup size.

Create Subgroups Using an ID Column

1. Select a variable or variables in the Y, Process list.

2. Select Subgroup ID Column from the Subgroup with options.
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3. Select a subgroup ID column in the Select Columns list.

4. Click Nest Subgroup ID Column.

The subgroup ID column appears in brackets to the right of the variable names in the Y, 

Process list.

Create Subgroups Using a Constant Subgroup Size

1. Select a variable or variables in the Y, Process list.

2. Select Constant Subgroup Size from the Subgroup with options.

3. Enter the subgroup size next to Set Constant Subgroup Size.

4. Click Subgroup by Size.

The subgroup size appears in brackets to the right of the variable names in the Y, Process list.

Nest Subgroup ID Column (Available when you select Subgroup ID Column.) Assigns a 

column that you select from the Select Columns list to define the subgroups for the 

selected Y, Process columns.

Subgroup by Size (Available when you select Constant Subgroup Size.) Assigns the 

subgroup size that you specify in the Set Constant Subgroup Size box to define the 

subgroups for the selected Y, Process columns.

Set Constant Subgroup Size (Available when you select Constant Subgroup Size.) Specify 

the constant subgroup size for the selected Y, Process columns. You need to assign this 

value using Subgroup by Size.

Within-Subgroup Variation Statistic (Available when Process Subgrouping is used.) 

Specifies if the within-subgroup estimate of standard deviation is calculated using 

standard deviations or ranges.

Calculate Between-and-Within Capability (Available when Process Subgrouping is used.) 

Specifies that the between-and-within subgroup estimate of the standard deviation should 

be used in the capability analysis.

Moving Range Options

In the Process Capability launch window, the options in this section enable you to specify 

which moving range statistic is used in the within sigma estimate when subgrouping is not 

used.

Note: When you specify subgrouping and click Calculate Between-and-Within Capability, 

use the Moving Range Options outline to specify which moving range statistic is used in the 

between sigma estimate.
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Average of Moving Range Uses the mean of the moving ranges to estimate sigma. The 

moving range is the difference between two consecutive points.

Median of Moving Range Uses the median of the moving ranges to estimate sigma.

Historical Information

In the Process Capability launch window, the options in this section enable you to assign 

historically accepted values of the standard deviation to variables in the Y, Process list.

1. Select a variable or variables in the Y, Process list.

2. Enter a value next to Set Historical Sigma.

3. Select Use Historical Sigma to assign that value to the selected variables.

The specified value appears in parentheses in the expression “&Sigma()” to the right of the 

variable names in the Y, Process list.

Note: If you set a historical sigma, then subgroup assignments for the selected process 

variable are no longer relevant and are removed.

Distribution Options

In the Process Capability launch window, the options in this section enable you to assign other 

distributions or calculation methods to variables in the Y, Process list and to specify options 

related to nonnormal calculations. Unless otherwise specified, all Y, Process variables are 

analyzed using the assumption that they follow a normal distribution.

• The available distributions are the Normal, Beta, Exponential, Gamma, Johnson, 

Lognormal, Mixture of 2 Normals, Mixture of 3 Normals, SHASH, and Weibull 

distributions. Except for Johnson distributions, maximum likelihood estimation is used to 

fit distributions. See “Johnson Distribution Fit Method”.

• The Best Fit option determines the best fit among the available distributions and applies 

this fit.

• The Nonparametric option fits a distribution using kernel density estimation.

For more options related to nonnormal fits, see “Nonnormal Distribution Options”.

Specify a Distribution

1. Select a variable or variables in the Y, Process list.

2. Select a distribution from the Distribution list.

3. Select Set Process Distribution to assign that distribution to the selected variables.
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The specified distribution appears in parentheses in the expression “&Dist()” to the right of 

the variable names in the Y, Process list.

Note: If you select a distribution other than Normal, you cannot assign a Subgroup ID column 

or a Historical Sigma. These selections are not supported by the methods used to calculate 

nonnormal capability indices. See “Statistical Details for Capability Indices for Nonnormal 

Distributions”.

Nonnormal Distribution Options

Nonnormal Capability Indices Method Specifies the method used to compute capability 

indices for nonnormal distributions. See “Statistical Details for Capability Indices for 

Nonnormal Distributions”.

Johnson Distribution Fit Method Specifies the method used to find the best-fitting Johnson 

distribution. Before estimating the parameters, the best-fitting family of distributions is 

determined from among the Johnson Su, Sb, and Sl families. The procedure described in 

Slifker and Shapiro (1980) is used to find the best-fitting family.

Quantile Matching The default method. It is more stable and faster than Maximum 

Likelihood. Quantile Matching Parameter estimates, assuming the best-fitting family, 

are obtained using a quantile-matching approach. See Slifker and Shapiro (1980).

Maximum Likelihood Parameters for the best-fitting family are determined using 

maximum likelihood.

Distribution Comparison Criterion (Available when a Best Fit Distribution is selected.) 

Specify the criterion that you want to use in determining a Best Fit. This criterion also 

determines the ordering of distributions in the Comparison Details report. See “Order by 

Comparison Criterion”.

Other Specifications

The Process Capability launch window also contains the following options and specifications:

By Produces a separate report for each level of the By variable. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.

Specify Alpha Level Specifies the significance level for confidence limits.

Show Spec Limits Dialog Specifies how to handle columns that do not have specification 

limits.
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Note: It is good practice to ensure that specification limits for all process variables are 

specified as Spec Limits column properties or to load specification limits from a Limits 

Data table (see “Limits Data Table”). Otherwise, you can specify limits interactively in the 

Spec Limits window that appears after you click OK in the launch window (unless you 

select No (skip columns with no spec limits) on the launch window).

Enter Specification Limits for a Process

The lower specification limit (LSL), upper specification limit (USL), and target define the 

lower bound, upper bound, and target value for a quality process. There are several ways to 

enter specification limits to use in a process capability analysis:

• Enter limits in the Spec Limits window after selecting columns in the launch window. See 

“Spec Limits Window”.

• Import limits from a JMP data table (known as a Limits Table). See “Limits Data Table”.

• Enter limits as Spec Limits column properties in the data table. See “Spec Limits Column 

Property”.

• If you are creating a Process Capability report by running a JSL script, enter limits in the 

script. See “The Process Capability Report”.

Only one specification limit is required for a selected column. If only the USL is specified, the 

box plots and Goal Plot point are colored blue. If only the LSL is specified, the box plots and 

Goal Plot point are colored red.

Spec Limits Window

You can enter known specification limits for a process in the Spec Limits window. This 

window appears if you selected If Needed or Yes for the Show Spec Limits Dialog options in 

the Process Capability launch window. Figure 9.7 shows the Spec Limits window for the 

Cities.jmp sample data table after selecting OZONE, CO, SO2, and NO as process variables in 

the launch window. Enter the known specification limits and click OK to view the Process 

Capability report.

You can specify process importance values for each column. Process importance values 

provide a mechanism to sort processes in the order that you prefer. Process importance values 

are used to size markers in many of the graphs in the Process Capability report.
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If you select the Show Limits option for a process and then save the specification limits to a 

column property, the Show as Graph Reference Lines option is selected in the saved Spec 

Limits column property. If you select the Show Limits option for a process and then save the 

specification limits to a new table, the Show Limits column in the new table contains a 1 for 

the process. The Select All Show Limits button selects the Show Limits option for all 

processes.

Figure 9.7  Spec Limits Window for Cities.jmp

Limits Data Table

You can also specify limits in a process capability analysis using a limits data table. Click the 

Select Data Table button and then select the appropriate data table that contains the 

specification limits for the analysis. After you select the appropriate limits table, the values 

populate the window. Click OK to view the Process Capability report.

A limits data table can be in two different formats: tall or wide. A tall limits data table has one 

column for the responses and the limits key words are the other columns. A wide limits data 

table has a column for each response with one column to label the limits keys. Either of these 

formats can be read using the Load spec limits from data table option.

• A tall table contains four or five columns and has one row for each process. The first 

column has a character data type and contains the names of the columns analyzed in the 

Process Capability platform. The next three columns need to be named LSL, Target, and 

USL. These column names can also be preceded by an underscore character. The optional 

final column named Show Limits specifies if the specification limits are shown as reference 

lines in select analysis plots.
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Figure 9.8  Example of a Tall Specification Limits Table

• A wide table contains three rows and one column for each column analyzed in the Process 

Capability platform plus a _LimitsKey column. In the _LimitsKey column, the three rows 

need to contain the identifiers _LSL, _Target, and _USL.

Figure 9.9  Example of a Wide Specification Limits Table

The easiest way to create a limits data table is to save results computed by the Process 

Capability platform. The Save options in the Process Capability red triangle menu enable you 

to save limits from the sample values. After entering or loading the specification limits, you 

can do the following:

• Select Save > Save Spec Limits as Column Properties to save the limits as Spec Limits 

column properties to the columns in the data table.

• Select Save > Save Distributions as Column Properties to save the distributions used in 

calculating capability as Process Capability Distribution column properties to the columns 

in the data table.

• Select Save > Save Spec Limits to New Table to save the limits to a new tall specification 

limits data table. If you have selected at least one nonnormal distribution, a column called 

Distribution that contains the specified distributions is also added to the limits data table.

See “Process Capability Platform Options”.
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Spec Limits Column Property

In the Process Capability platform, you can use columns that have a spec limits column 

property. When you perform a capability analysis, you can use Column Properties > Spec 

Limits to save specification limits as a column property. The Spec Limits property applies only 

to numeric columns.

Some processes have one-sided specifications. Some have no target. You can enter any of these 

that apply: a lower specification limit, an upper specification limit, a target value, or a process 

importance value.

Figure 9.10 displays the Spec Limits section of the Column Properties window for OZONE in 

the sample data table Cities.jmp.

Figure 9.10  Spec Limits Section of the Column Properties Window

Tip: Saving specification limits as a column property ensures consistency when you repeat an 

analysis.

The Process Capability Report

By default, the Process Capability report contains the following plots:

• “Goal Plot” (provided only if at least one variable is fit with a normal distribution and 

shows only points for variables fit with normal distributions)
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• “Capability Box Plots” (provided only if at least one variable is fit with a normal 

distribution and shows only box plots for variables fit with normal distributions)

• “Capability Index Plot”

Using the Process Capability red triangle menu, you can add individual detail reports, 

normalized box plots, and summary reports. The red triangle menu also has options for 

identifying out-of-spec values in your data table, creating a summary data table, changing the 

display order of analyzed columns, and saving out spec limits. These options are described in 

“Process Capability Platform Options”.

You can change the default report at File > Preferences > Platforms > Process Capability. You 

can also make changes to the appearance of reports produced by options by selecting the 

relevant Process Capability topic at File > Preferences > Platforms.

Goal Plot

In the Process Capability report, the Goal Plot shows the following for each variable:

• the spec-normalized mean shift on the horizontal axis

• the spec-normalized standard deviation on the vertical axis

 The Goal Plot is useful for getting a quick, summary view of how the variables are 

conforming to specification limits. By default, the Goal Plot shows only those points for each 

column that are calculated using the overall sigma. Hover over each point to view the variable 

name and the sigma method used to calculate the point. See “Statistical Details for the Goal 

Plot” for more information about the calculation of the coordinates for the Goal Plot.

Note: Process variables with distributions other than Normal are not plotted on the Goal Plot.

Goal Plot Points

Points on the Goal Plot correspond to columns, not rows. Selecting a point in the Goal Plot 

selects the corresponding column in the data table. If process importance values are specified, 

the goal plot points are sized by importance.

Hover over a point in the Goal Plot to view a control chart for that process. Click the control 

chart to launch Control Chart Builder with the corresponding control chart and capability 

report.

Note: A control chart is not available for a process if the unbiased pooled standard deviation 

is chosen as the within-group variation statistic for that process.
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The points on the Goal Plot are also linked to the rows of the Goal Plot Summary Table, where 

each row corresponds to a column. You can select a point in the Goal Plot, right-click, and 

apply row states. These row states are applied to the rows of the Goal Plot Summary Table. 

Row states that you apply in the Goal Plot Summary Table are reflected in the Goal Plot. To 

see this table, select Make Goal Plot Summary Table from the Process Capability red triangle 

menu. See “Make Goal Plot Summary Table”.

Tip: If you hide a point in the Goal Plot, you can show the point again by changing the 

corresponding row state in the Goal Plot Summary Table.

Goal Plot Triangle

The goal plot triangle appears in the center of the bottom of the Goal Plot. The slider to the 

right of the plot enables you to adjust the size of goal triangle in the plot.

By default, the Ppk slider and the value beneath it are set to Ppk = 1. This approximates a 

non-conformance rate of 0.0027, if the distribution is normal. The goal triangle represents the 

Ppk shown in the box. To change the Ppk value, move the slider or enter a number in the box.

JMP gives the Goal Plot in terms of Ppk values by default. You can change this preference at 

File > Preferences > Platforms > Process Capability. When the AIAG (Ppk) Labeling preference 

is unchecked, all of the Ppk labeling is changed to Cpk labeling, including the label of the 

slider to the right of the goal plot.

Goal Plot Options

The Goal Plot red triangle menu has the following options:

Show Within Sigma Points Shows or hides the points calculated using the within sigma 

estimate.

Show Within or Between-and-Within Sigma Points (Available only when Calculate 

Between-and-Within Capability is selected for at least one process in the launch window.) 

Shows or hides the points calculated using the within sigma estimate or, if specified, the 

between-and-within sigma estimate.

Show Overall Sigma Points Shows or hides the points calculated using the overall sigma 

estimate.

Shade Levels Shows or hides the Ppk level shading (Figure 9.11). When you select Shade 

Levels, shaded areas appear in the plot. The shaded areas depend on the relationship 

between p and Ppk, with p representing the value shown in the box beneath Ppk:

– Points in the red area have Ppk < p.

– Points in the yellow area have p < Ppk < 2p.
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– Points in the green area have 2p < Ppk.

Label Within Sigma Points Shows or hides labels for points calculated using the within 

sigma estimate.

Label Within or Between-and-Within Sigma Points (Available only when Calculate 

Between-and-Within Capability is selected for at least one process in the launch window.) 

Shows or hides labels for points calculated using the within sigma estimate or, if specified, 

the between-and-within sigma estimate.

Label Overall Sigma Points Shows or hides labels for points calculated using the overall 

sigma estimate.

Defect Rate Contour Shows or hides a contour representing a specified defect rate.

Figure 9.11 shows the Goal Plot for the entire data set for the Semiconductor Capability.jmp 

sample data table after selecting Shade Levels and Show Within Sigma Points from the Goal 

Plot red triangle menu.

Figure 9.11  Goal Plot

One-Sided or Missing Specification Limits

When there is only one specification limit for a column, markers and colors are used in the 

following ways:

• If only the upper specification limit (USL) is specified, the point on the Goal Plot is 

represented by a right-pointing triangle and is colored blue.
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• If only the lower specification limit (LSL) is specified, the point on the Goal Plot is 

represented by a left-pointing triangle and is colored red.

• If at least one process has only an upper specification limit, the right half of the goal 

triangle is blue.

• If at least one process has only a lower specification limit, the left half of the goal triangle is 

red.

Processes with only an upper specification limit are represented by blue and should be 

compared to the blue (right) side of the goal triangle. Processes with only a lower specification 

limit are represented by red and should be compared to the red (left) side of the goal triangle. 

For more information about how the coordinates of points are calculated, see “Statistical 

Details for the Goal Plot”.

Capability Box Plots

In the Process Capability report, the Capability Box Plots show a box plot for each variable 

selected in the analysis. The values for each column are centered by their target value and 

scaled by the difference between the specification limits. If the target is not centered between 

the specification limits, the values are scaled by twice the minimum difference between the 

target and specification limits. For each process column Yj (see “Statistical Details on 

Notation” for a description of the notation):

For a process with a one-sided specification, see “One-Sided or Missing Specification Limits”. 

For the situation where no target is specified, see “Statistical Details for Capability Box Plots”.

Note: Process variables with distributions other than Normal are not plotted on the Capability 

Box Plot.

Figure 9.12 shows a Capability Box Plots report for eight variables in the Semiconductor 
Capability.jmp sample data table.

Zij

Yij Tj–

2 min(Tj LSLj– USL
j

Tj)–
---------------------------------------------------------------------------=
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Figure 9.12  Capability Box Plot

The plot displays dotted green lines drawn at ±0.5.

• For a process with a target that is centered between its specification limits, the dotted 

green lines represent the standardized specification limits.

• For a process with a target that is not centered between its specification limits, one of the 

dotted green lines represents the standardized specification limit for the limit closer to the 

target. The other dotted green line represents the same distance in the opposite direction.

This plot is useful for comparing variables with respect to their specification limits. For 

example, in Figure 9.12, the majority of points for IVP1 are above its USL, and the majority of 

its points for IVP2 are less than its target. PNP2 seems to be on target with all data points in the 

specification limits.

One-Sided or Missing Specification Limits

When there is only one specification limit for a column, colors are used in the following ways:

• If only the upper specification limit (USL) is specified, the box plot is colored blue.

• If only the lower specification limit (LSL) is specified, the box plot is colored red.

• If at least one process has only an upper specification limit, the dotted line at 0.5 is blue.

• If at least one process has only a lower specification limit, the dotted line at -0.5 is red.
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Suppose that only the lower specification limit is specified and that the process target is 

specified. The capability box plot is based on the following values for the transformed 

observations. See “Statistical Details on Notation” for a description of the notation:

Suppose that only the upper specification limit is specified and that the process target is 

specified. The capability box plot is based on the following values for the transformed 

observations:

For more information about how missing targets are handled with one-sided specification 

limits, see “Single Specification Limit and No Target”.

Capability Index Plot

In the Process Capability report, the Capability Index Plot shows Ppk values for all variables 

that you entered as Y, Process in the launch window. Each variable name appears on the 

horizontal axis and the Ppk values appear on the vertical axis. If you fit a nonnormal 

distribution, the fitted distribution name appears in the plot as a parenthetical suffix to the 

variable name. If process importance values are specified, the points on the capability index 

plot are sized by importance. A horizontal line is placed at the Ppk value that is specified by 

the slider to the right of the plot.

Hover over a point in the Capability Index Plot to view a control chart for that process. Click 

the control chart to launch Control Chart Builder with the corresponding control chart and 

capability report.

Note: A control chart is not available for a process if the unbiased pooled standard deviation 

is chosen as the within-group variation statistic for that process.

Figure 9.13 shows a Capability Index Plot report for the Process Measurements.jmp sample 

data table. Six of the variables are fit with nonnormal distributions. Process 7 is fit with a 

normal distribution. Points have been labeled using the Label Overall Sigma Points option 

that is available in the Capability Index Plot red triangle menu.

Zij

Yij Tj–

2 Tj LSLj– 
-------------------------------=

Zij

Yij Tj–

2 USLj Tj– 
--------------------------------=
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Figure 9.13  Capability Index Plot with Nonnormal Distributions

Capability Index Plot Options

The Capability Index Plot red triangle menu has the following options:

Show Within Sigma Points Shows or hides the points calculated using the within sigma 

estimate.

Show Within or Between-and-Within Sigma Points (Available only when Calculate 

Between-and-Within Capability is selected for at least one process in the launch window.) 

Shows or hides the points calculated using the within sigma estimate or, if specified, the 

between-and-within sigma estimate.

Show Overall Sigma Points Shows or hides the points calculated using the overall sigma 

estimate.

Shade Levels Shows or hides the Ppk level shading. When you select Shade Levels, shaded 

areas appear in the plot. The shaded areas depend on the relationship between p and Ppk, 

with p representing the value shown in the box beneath Ppk:

– Points in the red area have Ppk < p.

– Points in the yellow area have p < Ppk < 2p.

– Points in the green area have 2p < Ppk.
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Label Within Sigma Points Shows or hides labels for points calculated using the within 

sigma estimate.

Label Within or Between-and-Within Sigma Points (Available only when Calculate 

Between-and-Within Capability is selected for at least one process in the launch window.) 

Shows or hides labels for points calculated using the within sigma estimate or, if specified, 

the between-and-within sigma estimate.

Label Overall Sigma Points Shows or hides labels for points calculated using the overall 

sigma estimate.

Process Capability Platform Options

The Process Capability red triangle menu contains the following options:

Individual Detail Reports Shows or hides individual detail reports for each variable in the 

analysis. See “Individual Detail Reports”.

Goal Plot Shows or hides a goal plot for the data. The Goal Plot shows the spec-normalized 

mean shift on the x-axis and the spec-normalized standard deviation on the y-axis for each 

variable. See “Goal Plot”. (Only variables for which you specify normal distributions are 

shown on the plot.)

Capability Box Plots Shows or hides a capability box plot for each variable in the analysis. 

The values for each column are centered by their target value and scaled by twice the 

minimum difference between the target value and the specification limits. See “Capability 

Box Plots”. (Box plots are shown only for variables for which you specify normal 

distributions.)

Normalized Box Plots Provides two options for plots that show normalized box plots for 

each process variable. Each column is standardized by subtracting its mean and dividing 

by an estimate of the column’s standard deviation. The box plot is constructed using 

quantiles for the standardized values. See “Normalized Box Plots”. (Normalized box plots 

are shown only for variables for which you specify normal distributions.)

Within Sigma Normalized Box Plots Shows or hides a plot called Within Sigma 

Normalized Box Plots. The box plots are constructed using the within-subgroup 

estimate of standard deviation.

Within or Between-and-Within Sigma Normalized Box Plots (Available only when 

Calculate Between-and-Within Capability is selected for at least one process in the 

launch window.) Shows or hides a plot called Within or Between-and-Within 

Normalized Box Plots. The box plots are constructed using the within group estimate 

of the standard deviation or, if specified, the between-and-within estimate.
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Overall Sigma Normalized Box Plots Shows or hides a plot called Overall Sigma 

Normalized Box Plots. The box plots are constructed using the overall estimate of 

standard deviation.

Capability Index Plot Shows overall Ppk values for all variables that you entered as Y, 

Process. See “Capability Index Plot”.

Process Performance Plot Shows or hides a four-quadrant plot of capability versus 

stability. Each process that has at least one specification limit is represented by a point. See 

“Process Performance Plot”.

Summary Reports Provides two options for summary reports of capability indices. See 

“Summary Reports”.

Within Sigma Summary Report Shows or hides a summary report of capability indices 

calculated using the within-subgroup estimate of standard deviation. (Results are 

available only for variables with specified normal distributions.)

Within or Between-and-Within Sigma Summary Report (Available only when Calculate 

Between-and-Within Capability is selected for at least one process in the launch 

window.) Shows or hides a summary report of capability indices calculated using the 

within group estimate of the standard deviation or, if specified, the 

between-and-within group estimate.

Overall Sigma Summary Report Shows or hides a summary report of capability indices 

calculated using the overall estimate of standard deviation.

Action Options

The following red triangle menu options perform actions:

Out of Spec Values Provides options for the cells in the data table containing values that are 

out of spec.

Select Out of Spec Values Selects all rows and columns in the data table that contain at 

least one value that does not fall within the specification limits.

Color Out of Spec Values Colors the cells in the data table that correspond to values that 

are out of spec. The cell is colored blue if the value is above the USL and red if the value 

is below the LSL.

Tip: To remove colors in specific cells, select all cells of interest. Right-click in one of the 

cells and select Clear Color. To remove colors in all cells, deselect Color Out of Spec Values.

Make Goal Plot Summary Table Creates a summary table for the points plotted in the Goal 

Plot. This table includes the variable’s name, its spec-normalized mean shift, and its 
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spec-normalized standard deviation. Each variable has two rows in this table: one for each 

sigma type (within and overall). See “Make Goal Plot Summary Table”.

Order By Reorders the box plots, summary reports, and individual detail reports. You can 

reorder by Initial Order, Reverse Initial Order, Within Sigma Cpk Ascending, Within or 

Between-and-Within Sigma Cpk Ascending, Within Sigma Cpk Descending, Within or 

Between-and-Within Sigma Cpk Descending, Overall Sigma Ppk Ascending, or Overall 

Sigma Ppk Descending. The options that order by Within Sigma reorder plot elements 

only for variables with specified normal distributions.

Note: The options to order by Within or Between-and-Within Sigma are available only if 

Calculate Between-and-Within Capability is selected for at least one process in the launch 

window.

Save Provides options for saving specification limits and distributions.

Save Spec Limits as Column Properties Saves the specification limits to a column 

property for each variable in the analysis. If no Spec Limits column property is present, 

the column property is created. If a Spec Limits column property is present, the values 

in the column property are overwritten. See “Spec Limits Column Property”.

Save Distributions as Column Properties Saves the distribution used in calculating 

capability as a Process Capability Distribution column property. See Using JMP.

If a column contains the Distribution property specifying a nonnormal distribution and 

no Process Capability Distribution property, then the Process Capability platform 

applies a nonnormal fit. The Process Capability platform uses the distribution specified 

in the Distribution column property, or a Johnson fit if that distribution is not 

supported in Process Capability. If a column contains the Process Capability 

Distribution property, then the Process Capability platform uses the distribution 

specified in the Process Capability Distribution column property.

Note: If you want to use a specific distribution in the Process Capability platform, save 

it as a Process Capability Distribution column property.

Save Spec Limits to New Table Saves the specification limits and the setting for Show 

Limits for each process to a limits data table in tall format. See “Limits Data Table”.

Relaunch Dialog Opens the platform launch window and recalls the settings used to create 

the report.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.
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Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Individual Detail Reports

In the Process Capability red triangle menu, the Individual Detail Reports option displays a 

capability report for each variable in the analysis.

Normal Distributions

Figure 9.14 shows the Individual Detail Report for PNP1 from the Semiconductor 
Capability.jmp sample data table as described in “Example of the Process Capability Platform 

with Normal Variables”.
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Figure 9.14  Individual Detail Report

The Individual Details report for a variable with a normal distribution shows a histogram, 

process summary details, and capability and nonconformance statistics. The histogram shows 

the distribution of the values, the lower and upper specification limits and the process target 

(if they are specified), and one or two curves showing the assumed distribution. The 

histogram in Figure 9.14 shows two normal curves, one based on the overall estimate of 

standard deviation and the other based on the within-subgroup estimate.

When you fit your process with a normal distribution, the Process Summary includes the 

Stability Index, which is a measure of stability of the process. The stability index is defined as 

follows:

(Overall Sigma/Within Sigma)

If Calculate Between-and-Within Capability is specified for a process in the launch window, 

the stability index for that process is defined as follows:

(Overall Sigma/Between-and-Within Sigma)

A stable process has stability index near one. Higher values indicate less stability.
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Note: You can change the preferences for stability assessment type in 

File > Preferences > Platforms > Process Capability. This changes the stability assessment type 

used through the Process Capability platform.

Nonnormal Distributions

Note: Capability indices based on within-subgroup variation and stability indices are not 

available for processes for which you have specified nonnormal distributions.

Figure 9.15 shows the Individual Detail Report for Process 1 from the 

Process Measurements.jmp sample data table as described in “Example of the Process 

Capability Platform with Nonnormal Variables”.

Figure 9.15  Individual Detail Report for Process 1

The report opens with a note summarizing the Nonnormal Distribution Options that you 

selected in the launch window.



Chapter 9 Process Capability 261
Quality and Process Methods Process Capability Platform Options

The Individual Details report for a variable with a nonnormal distribution shows a histogram, 

process summary details, and capability and nonconformance statistics. The histogram shows 

the distribution of the values, the lower and upper specification limits and the process target 

(if they are specified). A curve showing the fitted distribution is superimposed on the 

histogram. If you selected a Nonparametric distribution, the curve shown in the histogram is 

the nonparametric density.

The report also shows a Parameter Estimates report if you selected a nonnormal parametric 

distribution or a Nonparametric Density report if you selected a Nonparametric fit. See 

“Parameter Estimates” and “Nonparametric Density”.

Individual Detail Report Options

The outline title for each variable in the Individual Detail Reports section is of the form 

<Variable Name> Capability. However, if you request nonnormal capability, the relevant 

distribution name is shown parenthetically in the outline title.

Each Capability report has a red triangle menu with the following options:

Compare Distributions Shows or hides the control panel for comparing distributions for the 

process. See “Compare Distributions”.

Process Summary Shows or hides the summary statistics for the variable, including the 

overall sigma estimate, and, if you have specified a normal distribution, the within sigma 

estimate and the stability index. If you have specified Calculate Between-and-Within 

Capability for at least one process in the launch window, estimates for the between sigma 

and the between-and-within sigma are also included.

Histogram Shows or hides the histogram of the values of the variable. The histogram report 

includes a red triangle menu that controls the following features of the histogram:

Show Spec Limits Shows or hides vertical red lines on the histogram at the specification 

limits for the process.

Show Target Shows or hides a vertical green line on the histogram at the process target.

Show Within Sigma Density Shows or hides an approximating normal density function 

on the histogram with mean given by the sample mean and standard deviation given 

by the within estimate of sigma.

Show Between-and-Within Sigma Density (Available only when Calculate 

Between-and-Within Capability is selected for at least one process in the launch 

window.) Shows or hides an approximating normal density function on the histogram 

with mean given by the sample mean and standard deviation given by the 

between-and-within estimate of sigma.
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Show Overall Sigma Density Shows or hides an approximating normal density function 

on the histogram with mean given by the sample mean and standard deviation given 

by the overall estimate of sigma.

Show Count Axis Shows or hides an additional axis to the right of the histogram plot 

showing the count of observations.

Show Density Axis Shows or hides an additional axis to the right of the histogram plot 

showing the density.

Capability Indices Controls display of the following capability index reports:

Within Sigma Capability (Available when distribution is Normal.) Shows or hides 

capability indices (and confidence intervals) based on the within (short-term) sigma.

Between-and-Within Sigma Capability (Available only when distribution is Normal and 

Calculate Between-and-Within Capability is selected for at least one process in the 

launch window.) Shows or hides capability indices based on the between-and-within 

sigma.

Within Sigma Z Benchmark (Available when distribution is Normal.) Shows or hides Z 

benchmark indices based on the within (short-term) sigma.

Between-and-Within Sigma Z Benchmark (Available only when distribution is Normal 

and Calculate Between-and-Within Capability is selected for at least one process in the 

launch window.) Shows or hides Z benchmark indices based on the 

between-and-within sigma.

Within Sigma Target Index (Available when distribution is Normal.) Shows or hides an 

estimate of the target index that is based on the within (short-term) sigma.

Between-and-Within Sigma Target Index (Available only when distribution is Normal 

and Calculate Between-and-Within Capability is selected for at least one process in the 

launch window.) Shows or hides an estimate of the target index that is based on the 

between-and-within sigma.

Overall Sigma Capability Shows or hides capability indices (and confidence intervals) 

based on the overall (long-term) sigma.

Overall Sigma Z Benchmark (Available when distribution is Normal.) Shows or hides Z 

benchmark indices based on the overall (long-term) sigma.

Note: By default, the confidence intervals for the capability indices are constructed based 

on  = 0.05. To change the default confidence level, select File > Preferences > Platforms > 

Process Capability.
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Nonconformance Shows or hides the observed and expected percentages of observations 

below the LSL, above the USL, and outside of the specification limits. The 

Nonconformance table contains hidden columns for observed and expected PPM and 

counts.

Interactive Capability Plot Shows or hides the Interactive Capability Plot. The Interactive 

Capability Plot enables you to change the value of one or more summary statistics and see 

how the changes affect the capability analysis. There are Original and New reports that 

show the original and new summary statistics, capability indices, and expected PPM. Use 

the slider controls or text boxes to change the spec limits, mean, and overall sigma from 

the original values. You can also use the Mean Shift box to shift the mean by a factor of the 

original sigma. The Interactive Capability Plot report has the following red triangle menu 

options:

Capability Shows or hides the capability indices in the Original and New reports.

Expected PPM Shows or hides the expected PPM values in the Original and New 

reports.

Revert to Original Values Reverts the interactive capability plot and the summary values 

in the New report back to the original values.

Save New Spec Limits as a Column Property Saves the new specification limits as a 

Spec Limits column property to the column in the original data table.

Note: The analysis is not rerun with the new specification limits unless the Auto Recalc 

option is turned on.

Parameter Estimates (Available when a distribution other than Normal or Nonparametric is 

selected.) Shows or hides the Parameter Estimates report, which gives estimates for the 

parameters of the selected distribution.

The estimates for all except the Johnson family distributions are obtained using maximum 

likelihood. For more information about Johnson family fits, see “Johnson Distribution Fit 

Method”.

The parameters and probability density functions for the normal, beta, exponential, 

gamma, Johnson, lognormal, and Weibull distributions are described in “Statistical Details 

for Capability Indices for Nonnormal Distributions”. These are the same 

parameterizations used in the Distribution platform, with the exception that Process 

Capability does not support threshold parameters. See Basic Analysis.

Fix Parameters (Available when a distribution other than Normal or Nonparametric is 

selected.) Displays a window that enables you to fix one or more parameter values in a 

nonnormal distribution. Enter a value in the User-defined Value column for the 

parameters that you would like to fix. Once you click OK, the omitted parameter values 
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are re-estimated given the fixed parameter values. The re-estimated parameter values 

appear in the Parameter Estimates report, along with a column indicating which 

parameters are fixed.

Nonparametric Density (Available when Nonparametric is selected as the distribution.) 

Shows or hides the Nonparametric Density report, which gives the kernel bandwidth used 

in fitting the nonparametric distribution. The kernel bandwidth is given by the following, 

where n is the number of observations and S is the uncorrected sample standard deviation:

Compare Distributions

In the Process Capability platform, the Compare Distributions report enables you to compare 

and apply various distributional fits. Note the following:

• Your selected distribution is indicated in the Selected column.

• The report initially shows fit statistics for your Selected distribution and other fitted 

distributions in the Comparison Details report. If you selected Best Fit, the Comparison 

Details report initially shows statistics for all parametric fits.

• Check the distributions in the Distribution list that you want to compare.

– The probability density function for the best fitting distribution in each family that you 

select is superimposed on the histogram in the Histogram - Compare Distributions 

report.

– If the distribution is parametric, a row for that family containing fit results is added to 

the Comparison Details report.

– If Nonparametric is checked in the Distribution list, the Nonparametric Density report, 

showing the automatically selected kernel bandwidth, is added to the Compare 

Distributions report. See “Nonparametric Density”.

– You can change your selected distribution by selecting its radio button under Selected. 

The capability report is updated to show results for the selected distribution.

Figure 9.16 shows the Compare Distributions report for Process 1 in the 

Process Measurements.jmp sample data table. The Selected distribution, which is Lognormal, 

is being compared to a Normal distribution. The Comparison Details report shows fit statistics 

for both distributions.

To obtain probability plots, click the Compare Distributions red triangle and select Probability 

Plots. The points in the probability plot for the normal distribution in Figure 9.16 do not 

follow the line closely. This indicates a poor fit.

bandwidth
0.9S

n1 5/
-----------=
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Figure 9.16  Compare Distributions with Probability Plot for Normal

Compare Distributions Options

The Compare Distributions red triangle menu contains the following options:

Comparison Details For each distribution, gives AICc, BIC, and -2Loglikelihood values. See 

Fitting Linear Models. (Not available for a Nonparametric fit.)

Comparison Histogram Shows or hides the Histogram report.

Probability Plots Shows or hides a report that displays probability plots for each parametric 

distribution that you fit (Figure 9.16). An observation’s horizontal coordinate is its 

observed data value. An observation’s vertical coordinate is the value of the quantile of the 
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fitted distribution for the observation’s rank. For the normal distribution, the overall 

estimate of sigma is used in determining the fitted distribution.

The red triangle menus associated with each Probability Plot contain the following 

options.

Simultaneous Empirical Confidence Limits Shows or hides confidence limits that have a 

simultaneous 95% confidence level of containing the true probability function, given 

that the data come from the selected parametric family. These limits have the same 

estimated precision at all points. Use them to determine whether the selected 

parametric distribution fits the data well. See Nair (1984) and Meeker and Escobar 

(1998).

Simultaneous Empirical Confidence Limits Shading Shows or hides shading of the 

region between the Simultaneous Empirical Confidence Limits.

Parametric Fit Line Shows or hides the line that shows the predicted probabilities for the 

observations based on the fitted distribution.

Parametric Fit Confidence Limits Shading Shows or hides shading of the region 

between parametric fit confidence intervals. The parametric fit confidence limits have 

confidence level (1 - Alpha), where Alpha is the value that you specify in the launch 

window. (Available only when the parametric fit confidence limits are meaningful and 

when it is possible to calculate them.)

When possible, the intervals are computed by expressing the parametric distribution F 

as a location-scale family, so that F(y) = G(z), where z = (y - )/. The approximate 

standard error of the fitted location-scale component at a point is computed using the 

delta method. Using the standard error estimate, a Wald confidence interval for z is 

computed for each point. The confidence interval for the cumulative distribution 

function F is obtained by transforming the Wald interval using G. Note that, in some 

cases, special accommodations are required to provide appropriate intervals near the 

endpoints of the interval of process measurements.

Order by Comparison Criterion Orders the distributions in the Comparison Details report 

according to the criterion that you select. The default ordering is by AICc, unless you 

selected another criterion in the Distribution Comparison Criterion panel in the launch 

window.
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Normalized Box Plots

In the Process Capability red triangle menu, the Normalized Box Plots options show or hide 

box plots that have been normalized using the specified sigma in the title. When drawing 

normalized box plots, JMP standardizes each column by subtracting the mean and dividing 

by the standard deviation. The box plots are formed for each column using these standardized 

values.

Figure 9.17  Within Sigma Normalized Box Plot

Figure 9.17 shows the Within Sigma Normalized Box Plot for a selection of the process 

variables in the Semiconductor Capability.jmp sample data table using wafer as a subgroup 

variable.

The green vertical lines represent the specification limits for each variable normalized by the 

mean and standard deviation of each variable. The gray dotted vertical lines are drawn at ±0.5, 

since the data is standardized to a standard deviation of 1.
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Process Performance Plot

In the Process Capability red triangle menu, the Process Performance Plot option shows or 

hides a four-quadrant plot of capability versus stability. Each process that has specification 

limits is represented by a point. If process importance values are specified, the points are sized 

by importance. The horizontal coordinate of each point equals the stability index of the 

process and the vertical coordinate of each point equals the overall Ppk capability of the 

process. The plot is divided into four shaded quadrants based on the following default 

boundaries:

• A stability index that exceeds 1.25 indicates that the process is unstable.

• A Ppk that is smaller than 1.0 indicates that the process is not capable.

Additionally, there is a red line on the graph that indicates where the Cpk value is 1. The 

boundaries that define the four quadrants can be adjusted using the Ppk and Stability Index 

slider controls to the right of the plot. You can also set preferences for your desired Capability 

and Stability boundaries, as well as stability assessment type in 

File > Preferences > Platforms > Process Capability Performance Plot and 

File > Preferences > Platforms > Process Capability.

The legend contains descriptions of the shaded regions. If any of the processes are missing a 

lower or upper specification limit, the legend also shows the markers used for those processes. 

If the markers do not appear in the legend, then all of the processes in the plot contain both 

lower and upper specification limits. See “One-Sided or Missing Specification Limits”.

Hover over a point in the Process Performance Plot to view a control chart for that process. 

Click the control chart to launch Control Chart Builder with the corresponding control chart 

and capability report.

Note: A control chart is not available for a process if the unbiased pooled standard deviation 

is selected as the within-group variation statistic for that process.

The Process Performance Plot red triangle menu contains the following option:

Label Points Shows or hides labels for each point in the Process Performance Plot.

Show Within Cpk Curve Shows or hides the within Cpk curve in the Process Performance 

Plot.
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Figure 9.18  Process Performance Plot

Figure 9.18 shows the Process Performance Plot for a selection of the process variables in the 

Semiconductor Capability.jmp sample data table using wafer as a subgroup variable.

Summary Reports

In the Process Capability red triangle menu, the Summary Report options show or hide a table 

that contains the following statistics for each variable: LSL, Target, USL, Sample Mean, various 

Sigma estimates, Stability Index, Cpk, Cpl, Cpu, Cp, Cpm, and Nonconformance statistics. If 

there is at least one nonmissing process importance value, an Importance column is also 

included in the Summary Report. These statistics are calculated using the sigma estimate 

specified in the report title. The columns for Stability Index, Cpk, Cpl, Cpu, and Cp are 

colored as green, yellow, and red to indicate adequate, marginal, and poor stability or 

capability. This color coding scheme matches what you would see in the Process Performance 

graph.

Note: You can change the preferences for stability assessment type in 

File > Preferences > Platforms > Process Capability. This changes the stability assessment type 

used through the Process Capability platform.
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Figure 9.19 shows a subset of columns for both summary reports as described in “Example of 

the Process Capability Platform with Normal Variables”. The following optional columns are 

available for this report:

• Confidence intervals for Cpk, Cpl, Cpu, CP, and Cpm

• Expected and observed PPM statistics (outside, below LSL, above USL)

Note: The expected PPM statistics are the percentages you would expect to see based on 

the distribution chosen. By default, the distribution is normal. The observed PPM statistics 

are the percentages based on the actual data.

• Sample standard deviation

• The sample size (N), the minimum, and the maximum.

• Target Index

Note: Target Index is only available in the Within Sigma Capability Summary report.

To reveal these optional columns, right-click the report and select the column names from the 

Columns submenu.

Note that the report (based on overall sigma) shows the overall capability indices Ppk, Ppl, 

Ppu, and Pp instead of the within capability indices Cpk, Cpl, Cpu, and Cp. The labeling of 

the overall capability indices depends on the setting of the AIAG (Ppk) Labeling preference.

Figure 9.19  Within Sigma and Overall Sigma Capability Summary Reports



Chapter 9 Process Capability 271
Quality and Process Methods Process Capability Platform Options

Make Goal Plot Summary Table

In the Process Capability red triangle menu, the Make Goal Plot Summary Table option 

produces a summary data table that includes each variable’s name, its spec-normalized mean 

shift (Spec-Standardized Mean), and its spec-normalized standard deviation 

(Spec-Standardized Std Dev). For each variable, there is a row for each of the sigma types.

Note: If a variable is fit with a distribution other than normal, the name of the fitted 

distribution is appended parenthetically to the variable name. The Spec-Standardized Mean 

and Spec-Standardized Std Dev values are not provided for nonnormal variables.

The points in the Goal Plot are linked to the rows in the Goal Plot Summary Table. If you 

apply row states to a point in the Goal Plot, you can change the corresponding row states in 

the Goal Plot Summary Table. Conversely, if you apply row states in the Goal Plot Summary 

Table, they are reflected on the Goal Plot.

Figure 9.20 shows the Goal Plot Summary Table for the Semiconductor Capability.jmp sample 

data table as described in “Example of the Process Capability Platform with Normal 

Variables”.

Figure 9.20  Summary Table
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Additional Examples of the Process Capability 
Platform

This section contains examples using the Process Capability platform.

• “Example of Process Capability for a Stable Process”

• “Example of Process Capability for an Unstable Process”

• “Example of the Simulation of Confidence Limits for a Nonnormal Process Ppk”

Example of Process Capability for a Stable Process

In this example, you verify the assumptions that enable you to estimate PPM defective rates 

based on a capability analysis. You access Process Capability through Control Chart Builder 

and then directly. The data consist of 22 subgroups of size five. There are six missing readings, 

with three in each of two consecutive subgroups.

Process Capability through Control Chart Builder

You can use Control Chart Builder to check process stability and the normality assumption for 

your process characteristic. You can also obtain Process Capability information directly within 

Control Chart Builder.

1. Select Help > Sample Data Folder and open Quality Control/Clips2.jmp.

2. Select Analyze > Quality and Process > Control Chart Builder.

3. Drag Date to the Subgroup zone.

4. Drag Gap to the Y zone.
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Figure 9.21  XBar and R Control Chart for Gap

The control chart indicates that Gap is stable over time. Because Gap has the Spec Limits 

column property, a Process Capability Analysis report appears to the right of the control 

chart.

Figure 9.22  Histogram in Process Capability Analysis for Gap

The histogram and fitted normal blue curve suggest that the distribution of Gap is 

approximately normal. Although the process is stable, the distribution of Gap is shifted to 

the right of the specification range.

The Process Summary report shows the specification limits that are saved to the Spec 

Limits column property. It also shows that the estimate of sigma calculated from 

within-subgroup variation (Within Sigma) does not differ greatly from the overall estimate 
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given by the sample standard deviation (Overall Sigma). Consequently, the Stability Index 

is near one (0.979268). This is expected because the process is stable.

5. Right-click in the body of the Nonconformance report and select Expected Within PPM 

from the Columns submenu.

Figure 9.23  Capability Indices and Nonconformance Report

The Cpk value calculated using subgroup variation is 0.966, indicating that the process is 

not very capable. The Cpl value suggests good performance, but this is because the 

process is shifted away from the lower specification limit. Defective parts generally result 

from large values of Gap.

Note that the confidence interval for Cpk is wide; it ranges from 0.805 to 1.128. This occurs 

even though there are 104 observations. Capability indices are surprisingly variable, due 

to the fact that they are ratios. It is easy to reach incorrect conclusions based on the point 

estimate of a capability index.

The estimates of out-of-specification product given in the Nonconformance report provide 

a direct measure of process performance. The PPM values in the Nonconformance report 

indicate that Gap hardly ever falls below the lower specification limit (1.4 parts per 

million). However, the number of parts for which Gap falls above the upper specification 

limit is 1869.0 parts per million.

For an uncentered process, the Cp value indicates potential capability if the process were 

adjusted to be centered. If this process were adjusted to be centered at the target value of 

14.8, then its capability would be 1.264, with a confidence interval from 1.071 to 1.457.

Process Capability Platform

Now that you have verified stability and normality for Gap, you can obtain additional 

information in the Process Capability platform.

1. Select Analyze > Quality and Process > Process Capability.

2. Select Gap and click Y, Process.
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3. Open the Process Subgrouping outline.

4. Select Date in the Select Columns list and Gap in the Y, Process list.

5. Click Nest Subgroup ID Column.

By default, the Within-Subgroup Variation Statistic selection is set to Average of Unbiased 

Standard Deviations. In the Control Chart Builder example (“Process Capability through 

Control Chart Builder”), subgroup ranges were used.

6. Click OK.

Figure 9.24  Goal Plot and Box Plot for Gap

The Goal Plot shows the Ppk index for Gap as being essentially equal to 1. The box plot 

shows that most values fall within specifications, but the preponderance of data values are 

shifted to the right within the specification range.

7. Click the Process Capability red triangle and select Individual Detail Reports.

The report is the one obtained using Control Chart Builder, except that the Within Sigma is 

based on average standard deviations rather than average ranges. See “Histogram in 



276 Process Capability Chapter 9
Additional Examples of the Process Capability Platform Quality and Process Methods

Process Capability Analysis for Gap” and “Capability Indices and Nonconformance 

Report”.

Example of Process Capability for an Unstable Process

This example shows a case where the overall variation differs from the within variation 

because the process is not stable.

1. Select Help > Sample Data Folder and open Quality Control/Coating.jmp.

2. Select Analyze > Quality and Process > Process Capability.

3. Select Weight and click Y, Process.

4. Open the Process Subgrouping outline.

5. Select Sample in the Select Columns list on the left.

6. Select Weight in the Y, Process list on the right.

7. Click Nest Subgroup ID Column.

8. Click OK.

9. Enter 16 for LSL, 20 for Target, and 24 for USL in the Spec Limits window.

10. Click OK.

11. Click the Goal Plot red triangle and select Show Within Sigma Points.

12. Click the Process Capability red triangle and select Individual Detail Reports.
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Figure 9.25  Process Capability Report for Coating.jmp Data
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Figure 9.25 shows the resulting Process Capability report. The Goal Plot shows two points 

that represent the mean shift and standard deviation standardized to the specification 

limits. There is a legend next to the Goal Plot that identifies the two points. The Overall 

Sigma point is calculated using the overall sample standard deviation. The Within Sigma 

point is calculated using a within-subgroup estimate of the standard deviation.

The point calculated using Overall Sigma is outside the goal triangle corresponding to a 

Ppk of 1. This indicates that the variable Weight results in non-conforming product.

However, the point calculated using Within Sigma is inside the goal triangle. This 

indicates that, if the process were stable, Weight values would have a high probability of 

falling within the specification limits.

13. Hover cursor over one of the points in the Goal Plot.

14. Click the control chart.

Figure 9.26  XBar and S Chart for Weight

The control chart indicates that the Weight measurements are unstable. The process is affected 

by special causes and is unpredictable. This makes the interpretation of capability indices and 

nonconformance estimates highly questionable. Even estimates based on Overall Sigma are 

questionable, because the process is not predictable.
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The histogram in Figure 9.25 shows the distribution of the Weight values with normal density 

curves using both sigma estimates superimposed over the histogram. The normal curve that 

uses the Overall Sigma estimate is flatter and wider than the normal curve that uses the 

Within Sigma estimate. This normal curve is more dispersed because the estimate of Overall 

Sigma is inflated by the special causes that make the process unstable. If the process were 

stable, the narrower normal curve would reflect process behavior.

You can also compare the Cpk estimate (1.142) to the Ppk estimate (0.814). The fact that Ppk is 

much smaller than Cpk is additional evidence that this is an unpredictable process. The Cpk 

estimate is a forecast of the capability that you would achieve by bringing the process to a 

stable state.

Note: The Individual Detail Reports Cutoff preference determines whether the Individual 

Reports appear by default. If the preference is enabled, the Individual Reports appear by 

default if the number of process variables is less than or equal to the number specified in the 

preference. You can change this preference in Preferences > Platforms > Process Capability.

Example of the Simulation of Confidence Limits for a Nonnormal 
Process Ppk

In this example, you first perform a capability analysis for three nonnormal variables. You 

then use simulation to find confidence limits for the nonconformance percentage for a specific 

variable.

Nonnormal Capability Analysis

If you prefer not to follow the steps below, you can obtain the results in this section by running 

the Process Capability table script in Tablet Measurements.jmp.

1. Select Help > Sample Data Folder and open Tablet Measurements.jmp.

2. Select Analyze > Quality and Process > Process Capability.

3. Select Weight, Thickness, and Purity and click Y, Process.

4. Select Weight, Thickness, and Purity in the Y, Process list on the right.

5. Open the Distribution Options outline.

6. From the Distribution list, select Best Fit.

7. Click Set Process Distribution.

The &Dist(Best Fit) suffix is added to each column name in the list on the right.

8. Click OK.

A Capability Index Plot appears, showing the Ppk values. Note that only the Thickness 

variable appears above the line that denotes Ppk = 1. Purity is nearly on the line. Although 
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the number of measurements, 250, seems large, the estimated Ppk value is still quite 

variable. For this reason, you construct a confidence interval for the true Purity Ppk value.

Note: Because a Goal Plot is not shown, you can conclude that a normal distribution fit 

was not the best fit for any of the three variables.

9. Click the Process Capability red triangle and select Individual Detail Reports.

The best fits are different for each process.

– Weight: Lognormal

– Thickness: SHASH

– Purity: Weibull

Construct the Simulation Column

To use the Simulate utility to estimate Ppk confidence limits, you need to construct a 

simulation formula that reflects the fitted Weibull distribution. If you prefer not to follow the 

steps below, you can obtain the results in this section by running the Add Simulation Column 
table script.

1. Scroll to the Purity (Weibull) Capability report and find the Parameter Estimates report.

Figure 9.27  Weibull Parameter Estimates for Purity

These are the parameter estimates for the best fitting distribution, which is Weibull.

2. In the Tablet Measurements.jmp sample data table, select Cols > New Columns.

3. Next to Column Name, enter Simulated Purity.

4. From the Column Properties list, select Formula.

5. In the formula editor, select Random > Random Weibull.

6. The placeholder for beta is selected. Click the insertion element (^).
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Figure 9.28  Formula Editor for Simulated Purity Column

This adds a placeholder for the parameter alpha.

7. In the Process Capability report, under Purity (Weibull) Capability, right-click in the 

Parameter Estimates report table and select Make into Data Table.

8. Copy the entry in Row 2 in the Estimate column (1589.7167836).

9. In the formula editor window, select the placeholder for beta in the Random Weibull 
formula and paste 1589.7167836 into the placeholder for beta.

10. In the data table that you created from the Parameter Estimates report, copy the entry in 

Row 1 in the Estimate column (99.918708989).

11. In the formula editor window, select the placeholder for alpha in the Random Weibull 
formula and paste 99.918708989 into the placeholder for alpha.

Figure 9.29  Completed Formula Window

12. Click OK in the formula editor window.

13. In the Tablet Measurements.jmp data table, right-click the Simulated Purity column and 

select Column Properties > Spec Limits.

14. Next to Lower Spec Limit, type 99.5.

15. Click OK in the New Column window.



Chapter 9 Process Capability 283
Quality and Process Methods Additional Examples of the Process Capability Platform

The Simulated Purity column contains a formula that simulates values from the best-fitting 

distribution.

Simulate Confidence Intervals for Purity Ppk and Expected Percent Nonconforming

When you use Simulate, the entire analysis is run the number of times that you specify. To 

shorten the computing time, you can minimize the computational burden by running only the 

required analysis. In this example, because you are interested only in Purity with a fitted 

Weibull distribution, you perform only this analysis before running Simulate.

Note: If you do not care about computing time, you can use the same report you created in the 

previous section and start with step 7.

1. In the Process Capability report, click the Process Capability red triangle and select 

Relaunch Dialog.

2. (Optional) Close the Process Capability report.

3. In the launch window, from the Cast Selected Columns into Roles list, select 

Weight&Dist(Lognormal) and Thickness&Dist(SHASH).

4. Click Remove.

5. Click OK.

6. Click the Process Capability red triangle and select Individual Detail Reports.

Both Ppk and Ppl values are provided, but they are identical because Purity has only a 

lower specification limit.

7. In the Overall Sigma Capability report, right-click the Estimate column and select 

Simulate.

In the Column to Switch Out list, make sure Purity is selected. In the Column to Switch In 

list, make sure Simulated Purity is selected.

8. Next to Number of Samples, type 500.

Note: The next step is not required. However, it ensures that you obtain exactly the 

simulated values shown in this example.

9. (Optional) Next to Random Seed, type 12345.

10. Click OK.

The calculation might take several seconds. A data table entitled Process Capability 

Simulate Results (Estimate) appears. The Ppk and Ppl columns in this table each contain 

500 values calculated based on the Simulated Purity formula. The first row, which is 

excluded, contains the values for Purity obtained in your original analysis. Because Purity 

has only a lower specification limit, the Ppk values are identical to the Ppl values.
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11. In the Process Capability Simulate Results (Estimate) data table, click the green triangle 

next to the Distribution script.

Figure 9.30  Distribution of Simulated Ppk Values for Purity
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Note: Your values may vary slightly from what is shown, depending on the decimal 

precision of the parameters in the Simulated Purity column formula.

Two Distribution reports are shown, one for Ppk and one for Ppl. But Purity has only a 

lower specification limit, so that the Ppk and Ppl values are identical. For this reason, the 

Distribution reports are identical.

The Simulation Results report shows that a 95% confidence interval for Ppk is 0.909 to 

1.145. This indicates that the true Ppk value could be above 1.0, which would place Purity 

above the Ppk = 1 line in the Capability Index Plot you constructed in “Nonnormal 

Capability Analysis”.

12. In the Process Capability report, right-click the Expected Overall % column in the 

Nonconformance report and select Simulate.

In the Column to Switch Out list, make sure Purity is selected. In the Column to Switch In 

list, make sure Simulated Purity is selected.

13. Next to Number of Samples, enter 500.

14. (Optional) Next to Random Seed, enter 12345.

15. Click OK.

The calculation might take several seconds. A data table entitled Process Capability 

Simulate Results (Expected Overall %) appears. Because Purity has only a lower 

specification limit, the Below LSL values are identical to the Total Outside values.

16. In the Process Capability Simulate Results (Expected Overall %) data table, click the green 

triangle next to the Distribution script.



286 Process Capability Chapter 9
Additional Examples of the Process Capability Platform Quality and Process Methods

Figure 9.31  Distribution of Simulated Total Outside Values for Purity
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Note: Your values may vary slightly from what is shown, depending on the decimal 

precision of the parameters in the Simulated Purity column formula.

Again, two identical Distribution reports appear. The Simulation Results report shows that 

a 95% confidence interval for the Expected Overall % nonconforming is 0.055 to 0.238.

Statistical Details for the Process Capability 
Platform

This section contains statistical details for the Process Capability platform.

• “Statistical Details for Variation Statistics”

• “Statistical Details on Notation”

• “Statistical Details for the Goal Plot”

• “Statistical Details for Capability Box Plots”

• “Statistical Details for Capability Indices for Normal Distributions”

• “Statistical Details for Capability Indices for Nonnormal Distributions”

• “Statistical Details for the Parameterizations of Distributions”

Statistical Details for Variation Statistics

The Process Capability platform provides two types of capability indices. The Ppk indices are 

based on an estimate of , the standard deviation of a process, that uses all of the data in a way 

that does not depend on subgroups. This overall estimate can reflect special cause as well as 

common cause variation. The Cpk indices are based on an estimate that attempts to capture 

only common cause variation. The Cpk indices are constructed using within-subgroup or 

between-and-within-subgroup estimates of . In this way, they attempt to reflect the true 

process standard deviation. When a process is not stable, the different estimates of can differ 

markedly.

Overall Sigma

The overall sigma does not depend on subgroups. The overall estimate of  is calculated as 

follows:

̂ 1
N 1–
------------- yi y– 2

i 1=

N

=
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The formula uses the following notation:

N = number of nonmissing values in the entire data set

yi = value of the ith observation

 = mean of nonmissing values in the entire data set

Caution: When the process is stable, the Overall Sigma estimates the process standard 

deviation. If the process is not stable, the overall estimate of  is of questionable value, since 

the process standard deviation is unknown.

Estimates of Sigma Based on Within-Subgroup Variation

An estimate of  that is based on within-subgroup variation can be constructed in one of the 

following ways:

• Within sigma estimated by average of ranges

• Within sigma estimated by average of unbiased standard deviations

• Within sigma estimated by moving range

• Within sigma estimated by unbiased pooled standard deviation

If you specify a subgroup ID column or a constant subgroup size on the launch window, you 

can specify your preferred within-subgroup variation statistic. See “Launch the Process 

Capability Platform”. If you do not specify a subgroup ID column, a constant subgroup size, 

or a historical sigma, JMP estimates the within sigma using the third method (moving range of 

subgroups of size two).

Within Sigma Based on Average of Ranges

Within sigma estimated by the average of ranges is the same as the estimate of the standard 

deviation of an XBar and R chart:

The formula uses the following notation:

Ri = range of ith subgroup

ni = sample size of ith subgroup

d2(ni) = expected value of the range of ni independent normally distributed variables with 

unit standard deviation

y

̂

R1

d2 n1 
----------------- 

RN

d2 nN 
------------------+ +

N
-------------------------------------------------------=
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N = number of subgroups for which ni ≥ 2

Within Sigma Based on Average of Unbiased Standard Deviations

Within sigma estimated by the average of unbiased standard deviations is the same as the estimate 

for the standard deviation in an XBar and S chart:

The formula uses the following notation:

ni = sample size of ith subgroup

c4(ni) = expected value of the standard deviation of ni independent normally distributed 

variables with unit standard deviation

N = number of subgroups for which ni ≥ 2

si = sample standard deviation of the ith subgroup

Within Sigma Based on Average Moving Range

Within sigma estimated by average moving range is the same as the estimate for the standard 

deviation for Individual Measurement and Moving Range charts:

The formula uses the following notation:

 = the mean of the nonmissing moving ranges computed as (MR2+MR3+...+MRN)/(N-1) 

where MRi = |yi - yi-1|.

d2(2) = expected value of the range of two independent normally distributed variables with 

unit standard deviation.

Within Sigma Based on Median Moving Range

Within sigma estimated by median moving range:

The formula uses the following notation:

̂

s1

c4 n1 
---------------- 

sN

c4 nN 
------------------+ +

N
------------------------------------------------------=

̂ MR
d2 2 
--------------=

MR

̂ MMR
0.954
----------------=
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MMR = the median of the nonmissing moving ranges computed as Median(MR2, MR3,..., 

MRN) where MRi = |yi - yi-1|.

Within Sigma Based on Unbiased Pooled Standard Deviation

Within sigma estimated by the unbiased pooled standard deviation:

The formula uses the following notation:

ni = sample size of ith subgroup

n = n1 +  + nN, the total sample size

c4(·) = expected value of the standard deviation of (·) independent normally distributed 

variables with unit standard deviation

N = number of subgroups for which ni ≥ 2

si = sample standard deviation of the ith subgroup

Estimate of Sigma Based on Between Group Variation

Between Sigma Based on Moving Range

The estimate of  that is based on between-subgroup variation is estimated by the moving 

range of subgroup means:

The formula uses the following notation:

 = the mean of the nonmissing moving ranges computed as (MR2+MR3+...+MRN)/(N-1) 

where MRi = |yi - yi-1|.

d2(2) = expected value of the range of two independent normally distributed variables with 

unit standard deviation.

2
within = the specified within sigma estimate.

̂
n1 1– s1

2  nN 1– sN
2

+ +

c4 n N– 1+  n1  nN N–+ +
----------------------------------------------------------------------------------=

̂ MR
d2 2 
--------------
 
 
  2 ̂

2
Within

H
-----------------------–=

MR
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, the harmonic mean of subgroup sample sizes.

Estimate of Sigma Based on Between and Within Group Variation

Between-and-Within Sigma

The estimate of sigma that is based on the combined between and within group variation is 

defined as follows:

Statistical Details on Notation

In the Process Capability platform, the formulas for the Goal Plot and Capability Box Plots use 

the following notation:

Yij = ith observation for process j

 = mean of the observations on process j

SD(Yj) = standard deviation of the observations on process j

Tj = target value for process j

LSLj = lower specification limit for process j

USLj = upper specification limit for process j

Mj = (USLj LSLj)2

Statistical Details for the Goal Plot

This section provides details about the calculation of the mean shift and standard deviation 

standardized to specification quantities plotted in the Goal Plot in the Process Capability 

platform. This section uses the notation defined in “Statistical Details on Notation”.

H
N

1
n1

------ 1
n2

------  1
nN

-------+ + +
----------------------------------------------=

̂ ̂within
2

̂between
2

+=

Yj
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The mean shift and the standard deviation standardized to the specification limits for the jth 

column are defined as follows:

Spec-Standardized Mean = 

Spec-Standardized Std Dev = 

Note: If either LSLj or USLj is missing, twice the distance from the target to the nonmissing 

specification limit is used in the denominators of the Goal Plot coordinates.

Goal Plot Points for Processes with Missing Targets

Suppose that the process has both a lower and an upper specification limit but no target. Then 

the formulas given in “Statistical Details for the Goal Plot” are used, replacing Tj with the 

midpoint of the two specification limits.

Suppose that the process has only one specification limit and no target. To obtain (x,y) 

coordinates for a point on the Goal Plot, the capability indices of the process are used. (See 

“Statistical Details for Capability Indices for Normal Distributions” for definitions in terms of 

the theoretical mean and standard deviation.) For sample observations, the following 

relationships hold:

If a process has two specification limits and a target at the midpoint of the limits, then the (x,y) 

coordinates for the point on the Goal Plot satisfy these relationships:

Yj Mj–

USLj LSLj–
-------------------------------

SD Yj 

USLj LSLj–
-------------------------------

Cpu

USLj Yj–

3SD Yj 
------------------------=

Cpl

Yj LSLj–

3SD Yj 
-----------------------=

Cpu 0.5 x–  3y=

Cpl 0.5 x+  3y=
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To obtain coordinates when there is only one specification limit and no target, these 

relationships are used. To identify a unique point requires an assumption about the slope of 

the line from the origin on which the points fall. A slope of 0.5 is assumed for the case of an 

upper specification limit and of -0.5 for a lower specification limit. When capability values are 

equal to one and the Ppk slider for the goal plot triangle is set to 1, these slopes place the 

points on the goal plot triangle lines.

Consider the case of only an upper specification limit and no target. Using the assumption 

that the (x,y) coordinates fall on a line from the origin with slope 0.5, solving for x and y gives 

the following coordinates:

Consider the case of only a lower specification limit and no target. Using the assumption that 

the (x,y) coordinates fall on a line from the origin with slope -0.5, solving for x and y gives the 

following coordinates:

Note: If either Cpu or Cpl is less than -0.6, then it is set to -0.6 in the formulas above. At the 

value -2/3, the denominator for x assumes the value 0. Bounding the capability values at -0.6 

prevents the denominator from assuming the value 0 or switching signs.

Statistical Details for Capability Box Plots

This section describes how the Process Capability platform handles processes with missing 

targets. A column with no target can have both upper and lower specification limits, or only a 

single specification limit. The calculations used to create the Capability Box plots depend on 

what specification limits are defined. The notation used in this section is defined in “Statistical 

Details on Notation”.

x 1= 3Cpu 2+ 

y 1= 6Cpu 4+ 

x 1–= 3Cpl 2+ 

y 1= 6Cpl 4+ 
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Two Specification Limits and No Target

When no target is specified for the jth column, the capability box plot is based on the following 

values for the transformed observations:

Single Specification Limit and No Target

Suppose that only the lower specification limit is specified. (The case where only the upper 

specification limit is specified in a similar way.)

When no target is specified for the jth column, the capability box plot is based on the following 

values for the transformed observations:

Note: When a column has only one specification limit and no target value, and the sample 

mean falls outside the specification interval, no capability box plot for that column is plotted.

Statistical Details for Capability Indices for Normal Distributions

This section provides details about the calculation of capability indices for normal data in the 

Process Capability platform.

For a process characteristic with mean  and standard deviation , the population-based 

capability indices are defined as follows. For sample observations, the parameters are 

replaced by their estimates:

Cp = 

Cpl = 

Cpu = 

Cpk = 

Zij

Yij LSLj USLj+  2–

USLj LSLj–
---------------------------------------------------------=

Zij

Yij Yj–

2 Yj LSLj– 
--------------------------------=

USL LSL–
6

----------------------------

 LSL–
3

--------------------

USL –
3

---------------------

min( Cpl, Cpu )
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Cpm = 

Target Index = 

The formulas use the following notation:

LSL = Lower specification limit

USL = Upper specification limit

T = Target value

For estimates of Within Sigma capability,  is estimated using the subgrouping method that 

you specified. For estimates of Overall Sigma capability,  is estimated using the sample 

standard deviation. If either of the specification limits is missing, the capability indices 

containing the missing specification limit are reported as missing.

Note: With the default AIAG (Ppk) Labeling, the indices based on Overall Sigma are denoted 

by Pp, Ppl, Ppu, and Ppk. The labeling for the index Cpm does not change when Overall 

Sigma is used. The formulas in this section are defined using Cp labels.

Confidence Intervals for Capability Indices

Confidence intervals for capability indices are available only for processes with normal 

distributions. Confidence intervals are calculated for both Within and Overall Sigma 

capability and are shown in the Individual Detail Reports.

Cp

The 100(1 - )% confidence interval for Cp is calculated as follows:

where

 is the estimated value for Cp

 is the (/2)th quantile of a chi-square distribution with df degrees of freedom

df is the degrees of freedom

min T LSL– USL T –

3 1
T –


------------- 
  2

+

-------------------------------------------------------------

3 Cp Cpk– 

Cp̂
 2 df

2

df
-------------------- Cp̂

1  2– df
2

df
----------------------------

 
 
 
 

Cp̂

 2 df
2
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N is the number of observations

m is the number of subgroups

For Overall Sigma capability, the degrees of freedom is equal to N - 1.

For Within Sigma capability, the degrees of freedom depends on the subgrouping and the 

within sigma estimation method.

• For Within Sigma capability with unbalanced subgroups, the degrees of freedom 

calculation is the same regardless of the within sigma estimation method. The degrees of 

freedom is equal to N - m.

• For Within Sigma capability with balanced subgroups of size n = N/m, the degrees of 

freedom calculation depends on the within sigma estimation method.

– When Within Sigma is estimated by the average of the unbiased standard deviations, 

the degrees of freedom is equal to f * (N - m). The scale factor f, which varies between 

0.875 and 1, is defined as follows:

where (n) is the gamma function evaluated at n.

For more information, see Bissell (1990).

– When Within Sigma is estimated by the average of ranges, the degrees of freedom is 

calculated as df = 1/A - (3/16) * A + (3/64) * A2 + 0.25. A is defined as follows:

d2(n) is the expected value of the range of n independent normally distributed 

variables with unit standard deviation

d3(n) is the standard deviation of the range of n independent normally distributed 

variables with unit standard deviation

For more information, see David (1951).

– When Within Sigma is estimated by the unbiased pooled standard deviations, the 

degrees of freedom is equal to N - m.

• For Within Sigma capability with no subgroups, the degrees of freedom calculation 

depends on the within sigma estimation method.

f
1

2 n 1–  n 1– 
2

-----------------
 n 1–

2
------------ 
 

 n
2
--- 
 

----------------------

 
 
 
 
  2

1–

 
 
 
 
 

-----------------------------------------------------------------------------------=

A
2d3 n 2

m d 2 n 2
--------------------------=
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– When Within Sigma is estimated by the average moving ranges, the degrees of 

freedom is calculated as 0.62 * (N - 1).

– When Within Sigma is estimated by the median moving ranges, the degrees of freedom 

is calculated as 0.32 * (N - 1).

For more information, see Wheeler (2004, p. 82).

Cpk

The 100(1 - )% confidence interval for Cpk is calculated as follows:

where

 is the estimated value for Cpk

 is the (1 - /2)th quantile of a standard normal distribution

df is the degrees of freedom

N is the number of observations

m is the number of subgroups

For Overall Sigma capability, the degrees of freedom is equal to N - 1.

For Within Sigma capability, the degrees of freedom depends on the subgrouping and the 

within sigma estimation method.

• For Within Sigma capability with unbalanced subgroups, the degrees of freedom 

calculation is the same regardless of the within sigma estimation method. The degrees of 

freedom is equal to N - m.

• For Within Sigma capability with balanced subgroups of size n = N/m, the degrees of 

freedom calculation depends on the within sigma estimation method.

– When Within Sigma is estimated by the average of the unbiased standard deviations, 

the degrees of freedom is equal to f * (N - m). The scale factor f, which varies between 

0.875 and 1, is defined as follows:

Ĉpk 1  1–
1  2–

1

9NĈpk
2

------------------ 1
2df
--------+– Ĉpk 1  1–

1  2–
1

9NĈpk
2

------------------ 1
2df
--------++

 
 
 

Ĉpk

 1–
1  2–
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where (n) is the gamma function evaluated at n.

For more information, see Bissell (1990).

– When Within Sigma is estimated by the average of ranges, the degrees of freedom is 

calculated as df = 1/A - (3/16) * A + (3/64) * A2 + 0.25. A is defined as follows:

d2(n) is the expected value of the range of n independent normally distributed 

variables with unit standard deviation

d3(n) is the standard deviation of the range of n independent normally distributed 

variables with unit standard deviation

For more information, see David (1951).

– When Within Sigma is estimated by the unbiased pooled standard deviations, the 

degrees of freedom is equal to N - m.

• For Within Sigma capability with no subgroups, the degrees of freedom calculation 

depends on the within sigma estimation method.

– When Within Sigma is estimated by the average moving ranges, the degrees of 

freedom is calculated as 0.62 * (N - 1).

– When Within Sigma is estimated by the median moving ranges, the degrees of freedom 

is calculated as 0.32 * (N - 1).

For more information, see Wheeler (2004, p. 82).

Cpm

Note: The confidence interval for Cpm is computed only when the target value is centered 

between the lower and upper specification limits.

f
1

2 n 1–  n 1– 
2

-----------------
 n 1–

2
------------ 
 

 n
2
--- 
 

----------------------

 
 
 
 
  2

1–

 
 
 
 
 

-----------------------------------------------------------------------------------=

A
2d3 n 2

m d 2 n 
2

--------------------------=
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The 100(1 - )% confidence interval for Cpm is calculated as follows:

where

 is the estimated value for Cpm

 is the (/2)th quantile of a chi-square distribution with  degrees of freedom

N is the number of observations

 is the mean of the observations

T is the target value

s is the sigma estimate

For Overall Sigma capability, s is the Overall Sigma estimate. For Within Sigma capability, s is 

replaced by the Within Sigma estimate.

Tip: For more information on confidence intervals for Cp, Cpk, and Cpm, see Pearn and Kotz 

(2006).

Cpl and Cpu

Lower and upper confidence limits for Cpl and Cpu are computed using the method of Chou 

et al. (1990).

The 100(1 - )% confidence limits for Cpl (denoted by CPLL and CPLU) satisfy the following 

equations:

where

where

Cpmˆ
 2 

2


------------------ Cpmˆ

1  2– 
2


--------------------------

 
 
 
 

Cpmˆ

 2 
2


N 1

x T–
s

------------ 
 2+ 

  2

1 2
x T–

s
------------ 
  2

+

--------------------------------------------=

x

Pr tn 1– L  3Ĉpl n  1  2–= L 3CPLL n=

Pr tn 1– U  3Ĉpl n   2= U 3CPLU n=
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where

tn-1() has a non-central t-distribution with n - 1 degrees of freedom and noncentrality 

parameter 

 is the estimated value for Cpl

The 100(1 - )% confidence limits for Cpu (denoted by CPUL and CPUU) satisfy the following 

equations:

where

where

where

tn-1() has a non-central t-distribution with n - 1 degrees of freedom and noncentrality 

parameter 

 is the estimated value for Cpu

Statistical Details for Capability Indices for Nonnormal Distributions

This section describes the two methods used to calculate capability indices for nonnormal 

distributions in the Process Capability platform. The two methods are the Percentile (also 

known as ISO/Quantile) method and the Z-Score (also known as Bothe/Z-scores) method. 

When you select a distribution for a nonnormal process variable, you can fit a parametric 

distribution or a nonparametric distribution. You can use either the Percentile or the Z-Score 

methods to calculate capability indices for the process variable of interest. However, unless 

you have a very large amount of data, a nonparametric fit might not accurately reflect 

behavior in the tails of the distribution.

Note: For both the Percentile and the Z-Score methods, if the data are normally distributed, 

the capability formulas reduce to the formulas for normality-based capability indices.

The descriptions of the two methods use the following notation:

LSL = Lower specification limit

USL = Upper specification limit

T = Target value

Ĉpl

Pr tn 1– L  3Ĉpu n  1  2–= L 3CPUL n=

Pr tn 1– U  3Ĉpu n   2= U 3CPUU n=

Ĉpu
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Percentile (ISO/Quantile) Method

The percentile method replaces the mean in the standard capability formulas with the median 

of the fitted distribution and the 6 range of values with the corresponding percentile range. 

The method is described in AIAG (2005).

Denote the *100th percentile of the fitted distribution by P. Then Percentile method 

capability indices are defined as follows:

Z-Score (Bothe/Z-Scores) Method

The Z-Score method transforms the specification limits to values that have the same 

probabilities on a standard normal scale. It computes capability measures that correspond to a 

normal distribution with the same risk levels as the fitted nonnormal distribution.

Ppk min
P0.5 LSL–

P0.5 P0.00135–
--------------------------------------  

USL P0.5–

P0.99865 P0.5–
--------------------------------------,

 
 
 

=

Ppl

P0.5 LSL–

P0.5 P0.00135–
--------------------------------------=

Ppu

USL P0.5–

P0.99865 P0.5–
--------------------------------------=

Pp
USL LSL–

P0.99865 P0.00135–
------------------------------------------------=

Cpm

min
T LSL–

P0.5 P0.00135–
--------------------------------------  

USL T–
P0.99865 P0.5–
--------------------------------------, 

 

1
 T–


------------- 
  2

+

------------------------------------------------------------------------------------------------=
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Let F denote the fitted distribution for a process variable with lower and upper specification 

limits given by LSL and USL. Equivalent standard normal specification limits are defined as 

follows:

Then the Z-Score method capability indices are defined as follows:

Note: Because Cpm is a target-based measure, it cannot be calculated using the Z-Scores 

method.

Note: For very capable data, F(LSL) or F(USL) can be so close to zero or one, respectively, that 

LSLF or USLF cannot be computed. In these cases, JMP automatically switches from the 

Z-Score method to the Percentile method by default. This gives more meaningful capability 

indices. To turn off this default setting, select File > Preferences > Platforms > Process 

Capability.

Statistical Details for the Parameterizations of Distributions

This section gives the density functions f for the distributions used in the Process Capability 

platform. It also gives expected values and variances for all but the Johnson and SHASH 

distributions.

Normal

, , , 

LSLF  1–
F LSL  =

USLF  1–
F USL  =

Ppk min LSLF– 3  USLF 3, =

Ppl LSLF– 3=

Ppu USLF 3=

Pp USLF LSLF–  6=

f x    1

 2
-------------- 1

22
---------– x – 2exp= – x   –     0
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E(X) = 

Var(X) = 2

Beta

, , , 

E(X) = 

Var(X) = 

where B(·) is the Beta function.

Exponential

, , 

E(X) = 

Var(X) = 

Gamma

, , , 

E(X) = 

Var(X) = 

where (·) is the gamma function.

Johnson

Johnson Su

, , , 

f x    1
B   
------------------x

 1–
1 x– 

 1–
= 0 x 1   0  0


 +
-------------



 + 
2
  1+ + 

-------------------------------------------------

f x   1

--- x–  exp= x 0  0

f x    1

  
--------------------x 1– x–  exp= x 0  0  0

f x        

--- 1

x –

------------ 
  2

+
1– 2

   x –

------------ 
 sinh 1–+= – x       0

 0
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Johnson Sb

, 

Johnson Sl

, , 

where (·) is the standard normal probability density function.

Lognormal

, , ,

E(X) =

Var(X) =

Mixture of Normals

The Mixture of 2 Normals and Mixture of 3 Normals options for Distribution share the 

following parameterization:

E(X) =

Var(X) =

f x           x –
 x – –
-------------------------- 
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
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------------------------------------------------ 
 =  x  +   0
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x –
---------------   x –


------------ 
 ln+= x 0 if  1= x 0 if  1–=
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 2
--------------
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22
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x
-----------------------------------------------------=
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 2 2+ exp

2  2+  exp 2 2+ exp–

f x i i i  
i

i
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 
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i 1=

k

=

i
i 1=

k

 i

i
i

2 i
2+ 

i 1=

k

 i
i 1=

k

 i
 
 
 
  2

–



Chapter 9 Process Capability 305
Quality and Process Methods Statistical Details for the Process Capability Platform

where i, i, and i are the respective mean, standard deviation, and proportion for the ith 

group, and (·) is the standard normal probability density function. For the Mixture of 2 

Normals, k is equal to 2. For the Mixture of 3 Normals distribution, k is equal to 3. A separate 

mean, standard deviation, and proportion of the whole is estimated for each group in the 

mixture.

SHASH

, ,   , 0 < 

where

(·) is the standard normal pdf

Note: When  = 0 and  = 1, the SHASH distribution is equivalent to the normal distribution 

with location  and scale .

Weibull

, , 

E(X) =

Var(X) =

where (·) is the gamma function.
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Chapter 10
CUSUM Control Charts

Create Tabular CUSUM Control Charts with Decision Limits

Cumulative Sum (CUSUM) control charts enable you to detect small shifts in a process. They 

are useful in detecting shifts that occur over time, such as a gradual drift, and that are not 

necessarily accompanied by a sudden shift. The CUSUM Control Chart platform creates a 

CUSUM chart with decision limits, similar to a Shewhart chart. This chart is also called a 

tabular CUSUM chart. To create a V-mask cumulative sum control chart, see “V-Mask CUSUM 

Control Charts”.

The CUSUM Control Chart platform also provides information about average run length 

(ARL). The average run length is the average number of samples or observations that can be 

expected to occur before an out-of-control signal occurs. You can use the average run length to 

assess the performance of a CUSUM chart, given specific parameters and assuming constant 

variance.

Figure 10.1  CUSUM Control Chart
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Overview of the CUSUM Control Chart Platform

A tabular CUSUM chart consists of two one-sided decision limits charts superimposed on one 

chart. The chart contains decision limits that signal when the process is out of control and 

places a shift line on the chart where the shift is suspected to have occurred. To use the 

CUSUM Control Chart platform, you must determine the smallest change in the mean that 

you consider important. You can view the CUSUM control chart in standard deviation units or 

in data units. For more information about tabular CUSUM charts, see Woodall and Adams 

(1998) and Montgomery (2013).

Another form of a cumulative sum control chart is the V-mask chart. To create a V-mask 

CUSUM chart, see “V-Mask CUSUM Control Charts”.

Note: The summary results in the CUSUM Control Chart platform do not always match the 

summary results in the V-mask CUSUM platform. Specifically, the summary results for a 

two-sided V-mask CUSUM chart do not match those from a CUSUM Control Chart with both 

Upper Side and Lower Side options selected. However, the one-sided summary reports from 

the CUSUM Control Chart platform and the V-mask CUSUM platform do match.

Example of a CUSUM Control Chart

In this example, you want to detect small shifts in the temperature of an engine. The data table 

contains temperature measurements from the engine thermostat.

1. Select Help > Sample Data Folder and open Quality Control/Engine Temperature Sensor.jmp.

2. Select Analyze > Quality and Process > Control Chart > CUSUM Control Chart.

3. Select Y and click Y.

4. Click OK.

5. In the Target box, type 100.

6. In the Sigma box, type 10.
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Figure 10.2  CUSUM Control Chart Report

The vertical line on the CUSUM Chart indicates that a shift in the temperature measurements 

started around sample 26.

Note: You can compare this result to the Individual Moving Range control chart by running 

the IMR Chart table script in Engine Temperature Sensor.jmp. The IMR chart does not trigger 

any of the Nelson tests.

Example of a One-Sided CUSUM Control Chart

Continuing the previous example, suppose that you care only about increasing temperature 

changes. To change the CUSUM control chart in Figure 10.2 to a one-sided chart, deselect the 

Lower Side check box. When you do that, the points for the negative cumulative sums are 

removed from the chart. You are left with a CUSUM control chart that contains only the 

positive cumulative sum points.
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Figure 10.3  One-Sided CUSUM Control Chart Report

Launch the CUSUM Control Chart Platform

Launch the CUSUM Control Chart platform by selecting Analyze > Quality and Process > 
Control Chart > CUSUM Control Chart.

Figure 10.4  The CUSUM Control Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

The CUSUM Control Chart platform launch window contains the following options:

Y Identifies the variables that you want to chart.

Note: The rows of the data table must be sorted in the order in which the observations 

were collected.
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X Identifies a subgroup variable. The horizontal axis of the CUSUM chart is labeled by the 

subgroup variable. If a value of this column is present more than once, the average 

response at each X value is plotted on the CUSUM chart.

By Produces a separate report for each level of the By variable. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.

Show Excluded Region (Applicable only when an X variable is specified.) Specifies that 

subgroups that are entirely excluded are shown on the horizontal axis in the CUSUM 

control chart.

Data Units Specifies that data units be used in the report rather than standard deviation 

units. By default, the chart and parameters are shown in standard deviation units. 

However, if you select the Data Units option in the launch window, the chart and 

parameters are shown in the units of the data column that is being analyzed.

When you use standard deviation units, values for the h and k parameters do not depend 

on the process standard deviation. This can be an advantage.

The CUSUM Control Chart Platform Report

By default, the CUSUM Control Chart platform produces a report that contains a parameter 

control panel and a CUSUM chart.

• “Control Panel for CUSUM Control Chart”

• “CUSUM Chart Report”

Figure 10.5  CUSUM Control Chart Report
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Control Panel for CUSUM Control Chart

The Control Panel contains the current values for the chart parameters. The current values are 

in boxes that enable you to update the parameter values. There are also boxes for Upper Side 

and Lower Side. If you have specified the Data Units option in the launch window, this setting 

is denoted in the Control Panel below the check boxes.

The Control Panel contains the following options:

Target The known value of the mean. This is the value of the center line in the chart. By 

default, this parameter is set to the Target value in the Spec Limits column property for the 

Y column. If the Y column does not have a Target value in the Spec Limits column 

property, this parameter is set to the overall average of the Y column.

Note: To use the overall average of the Y column as the value of the center line even if the 

Y column has a Target value in the Spec Limits column property, select the Use Process 

Mean for Center Line platform preference. This preference is located in File > Preferences > 

Platforms > CUSUM Control Chart.

Sigma The known value of the standard deviation. By default, this parameter is set to the 

average moving range of the Y column. If there is an X variable, the Sigma parameter is set 

to the average moving range of the summary data.

Head Start The value of the cumulative sums before the first sample. Starting the cumulative 

sums at a nonzero value increases the sensitivity of the CUSUM chart near the beginning 

of the samples. This parameter is also known as the fast initial response (FIR) value. By 

default, this parameter is set to 0.

h or H The value of the parameter that defines the limits. If the Data Units option was not 

selected in the launch window, this is the h parameter. If the Data Units option was 

selected in the launch window, this is the H parameter. Note that H is equal to h times 

Sigma. By default, h is equal to 5 and H is equal to 5 times Sigma.

k or K The value of the parameter that defines the smallest change in the mean that is 

valuable to detect. If the Data Units option was not selected in the launch window, this is 

the k parameter. If the Data Units option was selected in the launch window, this is the K 

parameter. Note that K is equal to k times Sigma. By default, k is equal to 0.5 and K is 

equal to one half of Sigma.

Upper Side Shows or hides the positive values for the cumulative sum on the chart. These 

values are the C+ values.

Lower Side Shows or hides the negative values for the cumulative sum on the chart. These 

values are the C- values.
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Using Data Units The presence of this text indicates that the Data Units option was selected 

in the launch window and that the values in the CUSUM chart are centered but not 

standardized.

CUSUM Chart Report

The CUSUM Chart report contains the cumulative sum control chart with decision limits that 

are determined by the current values of the chart parameters. The samples (or subgroups if 

you specified an X variable) are denoted on the horizontal axis. The vertical axis denotes 

centered values of the positive and negative values for the cumulative sum. If the Data Units 

option was not selected in the launch window, the vertical axis denotes cumulative sums for 

standardized response values. If the Data Units option was selected in the launch window, the 

vertical axis denotes cumulative sums for unstandardized response values.

CUSUM Control Chart Platform Options

The CUSUM Control Chart red triangle menu contains the following options:

Show Limits Shows or hides the upper and lower decision limits in the CUSUM Chart.

Show Center Line Shows or hides the center line in the CUSUM Chart.

Show Shift Lines (Available only when there is a shift detected in the data.) Shows or hides 

the vertical lines in the CUSUM Chart that designate shifts. Shift lines are drawn at the 

start of a shift.

– A positive shift occurs when the value of C+ exceeds the upper limit on the chart. The 

start of the shift is defined as the first point after the most recent zero value for C+.

– A negative shift occurs when the value of C- falls below the lower limit on the chart. 

The start of the shift is defined as the first point after the most recent zero value for C-.

Show ARL Shows or hides the Average Run Length (ARL) report. See “Average Run Length 

(ARL) Report”.

ARL Profiler Shows or hides a profiler of average run length versus the parameters h and k. 

If you have specified the Data Units option in the launch window, the profiler plots 

average run length versus the parameters H and K.

The average run length (ARL) for a specified shift is the average number of runs expected 

before an out-of-control signal occurs. For example, the ARL at 0 represents the average 
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number of runs expected before a false-alarm signal occurs when the process is in control. 

When the process is in control, the shift size is 0.

The ARL Profiler enables you to explore how various settings of the parameters affect the 

performance of the corresponding CUSUM chart. As the parameters in the Control Panel 

are updated, the ARL Profiler is updated as well. An ideal CUSUM chart has a high 

ARL(0) value and a low ARL() value, where  is the size shift that is of interest.

The ARL Profiler depends on the settings of the Upper Side and Lower Side options in the 

Control Panel:

– If both the Upper Side and Lower Side options are selected, the profiler represents the 

average run length for crossing either the upper or lower decision limits on the 

CUSUM chart.

– If only the Upper Side option is selected, the profiler represents the average run length 

for the upper decision limit on the CUSUM chart.

– If only the Lower Side option is selected, the profiler represents the average run length 

for the lower decision limit on the CUSUM chart.

For more information about the options in the red triangle menu next to ARL Profiler, see 

Profilers.

Control Panel Shows or hides a report of the current values of the parameters. This report 

enables you to change the parameter values as well as the sidedness of the CUSUM chart.

Parameters Report Shows or hides a report of the current values of the parameters.

Test Beyond Limits Shows or hides a red circle around any point that is above the upper 

limit or below the lower limit in the CUSUM chart.

Save Summaries Creates a new data table that contains statistics for each subgroup in the 

CUSUM chart. The following statistics are saved to the new data table: the subgroup 

number and size, the subgroup sample mean, the value of the Sigma parameter, an 

indicator of shift starts, a value that indicates each interval between shift starts, an 

indicator of test failures, the upper and lower cumulative sums and corresponding 

consecutive run counts, and the LCL and UCL values.

Get Limits Retrieves the control limits that are stored in an open or saved data table.

Save Limits Saves the control limits in one of the following ways:

in Column Saves a Control Limits column property in the existing data table for the Y 

variable. The column property contains the value of the target used in the CUSUM 

chart.

in New Table Saves the values of H, K, the standard deviation, mean, and head start into 

a new data table.
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Save Sigma Saves the value of the Sigma parameter to a Sigma column property in the Y 

variable column in the data table.

Tune Chart Shows or hides a control that enables you to set an acceptable range for the Y 

variable. Adjust the minimum and maximum values of the acceptable range and click 

Done. At this point, the CUSUM chart updates based on a new value of the k parameter.

– If you specified the Data Units option in the launch window, the imputed k parameter 

is the average of the minimum and maximum values.

– If the Data Units option is not specified, the imputed K parameter is the average of the 

minimum and maximum values divided by the Sigma parameter.

Setting the acceptable range for the Y variable enables you to set the practical significance 

of the CUSUM chart. This is particularly helpful when the testing interval is more 

frequent, which can result in a much shorter practical average run length.

Reset to Defaults Resets all parameters back to their default values.

Alarm Script Enables you to write and run a script that indicates when the data fail special 

causes tests. Results can be written to a file, written to the log or sent in an email. There is 

an option to include an explanation of why the test failed.

As an Alarm Script is invoked, the following variables are available, both in the issued 

script and in subsequent JSL scripts:

qc_col is the name of the column

qc_test is the test that failed

qc_sample is the sample number

Tip: After an alarm script is specified, the alarm script is invoked when the Test Beyond 

Limits option is turned on.

See the Scripting Guide for more information about writing custom Alarm Scripts.

See Using JMP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.
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Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Average Run Length (ARL) Report

In the CUSUM Control Chart platform, the Average Run Length (ARL) report contains a table 

and a graph of ARL values. The average run length (ARL) for a specified shift is the average 

number of runs expected before an out-of-control signal occurs. For example, the ARL at 0 

represents the average number of runs expected before seeing a false-alarm signal when the 

process is in control. When the process is in control, the shift size is 0.

The table and graph in the ARL report enable you to explore how various settings of the 

parameters affect the performance of the corresponding CUSUM chart. As the h and k 

parameters in the Control Panel are updated, the ARL report is updated as well. An ideal 

CUSUM chart has a high ARL(0) value and a low ARL() value, where  is the size shift that is 

of interest.

The Average Run Length (ARL) report depends on the settings of the Upper Side and Lower 

Side options in the Control Panel. If only one option is selected, the ARL report uses 

calculations for the corresponding one-sided CUSUM chart. If both options are selected, the 

ARL report uses calculations for the two-sided CUSUM chart. Note that the two-sided ARL 

values are related to the positive and negative one-sided ARL values by the following 

equation:

ARL Table

The ARL Table shows the average run length for shifts () between zero and three at 0.25 

increments. If the Data Units option is specified, the shift is represented by 2*K/Sigma2. If the 

Data Units option is not specified, the shift is represented by 2*k/Sigma.

ARL Graph

The ARL Graph shows the average run length for shifts () between 0 and 3. This graph 

contains the same data points as the ARL Table to the left of the ARL Graph.

1
ARL
------------ 1

Positive ARL
----------------------------------- 1

Negative ARL
--------------------------------------+=
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Additional Examples of CUSUM Control Charts

This section contains examples using the CUSUM Control Chart platform.

• “Example of the Data Units Option in a CUSUM Control Chart”

• “Example of a CUSUM Chart with Subgroups”

Example of the Data Units Option in a CUSUM Control Chart

This example uses the Data Units option to detect small shifts in the temperature of an engine. 

The data table contains temperature measurements from the engine thermostat.

Note: This example reproduces the analysis in “Example of a CUSUM Control Chart” using 

the data units option.

1. Select Help > Sample Data Folder and open Quality Control/Engine Temperature Sensor.jmp.

2. Select Analyze > Quality and Process > Control Chart > CUSUM Control Chart.

3. Select Y and click Y.

4. Select the box next to Data Units.

5. Click OK.

6. In the Target box, type 100.

7. In the Sigma box, type 10.

Note that the options below Head Start are H and K, instead of h and k. These parameters 

are now specified in units of the data column, rather than in standard deviation units.
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Figure 10.6  CUSUM Control Chart Report

Like in the example using sigma units, the vertical line on the CUSUM Chart indicates that a 

shift in the temperature measurements started around sample 26.

Example of a CUSUM Chart with Subgroups

In this example, you want to be able to detect a 2 shift in a process. A machine fills 8-ounce 

cans of two-cycle engine oil additive. The filling process is believed to be in statistical control. 

The process is set so that the average weight of a filled can (0) is 8.10 ounces. Previous 

analysis shows that the standard deviation of fill weights (0) is 0.05 ounces.

Subgroup samples of four cans are selected and weighed every hour for twelve hours. Each 

observation in the data table contains one value of weight and its associated value of hour. The 

observations are sorted so that the values of hour are in increasing order.

1. Select Help > Sample Data Folder and open Quality Control/Oil1 Cusum.jmp.

2. Select Analyze > Quality and Process > Control Chart > CUSUM Control Chart.

3. Select weight and click Y.

4. Select hour and click X.

5. Click OK.

6. In the Target box, type 8.1.

This is the target mean for the process.

7. In the Sigma box, type 0.05.

This is the known standard deviation for the process.

8. In the h box, type 2.
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This defines the decision limits to be 2 standard deviations in each direction.

Figure 10.7  CUSUM Control Chart with Subgroups

The CUSUM Chart does not show any points outside of the upper or lower decision limits. 

There is no evidence that a shift in the process has occurred.

Note: Montgomery (2013) states that “only if there is some significant economy of scale or 

some other valid reason for taking samples of size greater than one should subgroups of size 

greater than one be used with the CUSUM.” The use of rational subgroups in the tabular 

CUSUM chart does not always improve the performance of the chart.

Statistical Details for the CUSUM Control Chart 
Platform

This section contains statistical details for the CUSUM Control Chart platform.

• “Statistical Details for CUSUM Control Chart Construction”

• “Statistical Details for Shift Detection”

• “Statistical Details for Average Run Length”
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Statistical Details for CUSUM Control Chart Construction

This section defines the statistics that are used in the construction of the CUSUM Chart. Some 

of these statistics are also saved in the data table that is created by the Save Summaries 

command.

One-Sided Upper and Lower Cumulative Sums

The definitions of C+ and C- depend on the setting of the Data Units option.

Note: In the Save Summaries data table, C+ and C- are labeled Upper Cumulative Sum and 

Lower Cumulative Sum, respectively.

Cumulative Sums in Standardized Units

If the Data Units option is not selected, C+ and C- for each step are defined as follows:

where:

xi is the value of the response at the ith step

T is the target of the process

 is the standard deviation of the process

k is the reference value, in units of standard deviations

If a value is specified for Head Start, that value is used as the initial C+ value and the negative 

of that value is used as the initial C- value. Otherwise, the initial values of C+ and C- are zero.

Cumulative Sums in Data Units

If the Data Units option is selected, C+ and C- for each step are defined as follows:
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where:

xi is the value of the response at the ith step

T is the target of the process

 is the standard deviation of the process

K is the reference value, in units of the data

If a value is specified for Head Start, that value is used as the initial C+ value and the negative 

of that value is used as the initial C- value. Otherwise, the initial values of C+ and C- are zero.

Counters for Positive and Negative Runs

N+ at each step is the number of steps since the most recent zero value for C+. N- at each step is 

the number of steps since the most recent zero value for C-.

Note: In the Save Summaries data table, N+ and N- are labeled Positive Runs and Negative 
Runs, respectively.

Statistical Details for Shift Detection

This section defines positive and negative shift detection for the CUSUM Chart.

A positive shift occurs when the value of C+ exceeds the upper limit on the chart. The start of 

the shift is defined as the first point after the most recent zero value for C+.

A negative shift occurs when the value of C- exceeds the lower limit on the chart. The start of 

the shift is defined as the first point after the most recent zero value for C-.

Statistical Details for Average Run Length

This section defines how one-sided and two-sided average run length (ARL) values are 

calculated in a CUSUM Control Chart.

The one-sided ARL values are calculated using the integral equation method (with 24 

Gaussian points) described by Goel and Wu (1971). If the Head Start value is greater than 0, 

the values are calculated according to the method in Appendix A.1 of Lucas and Crosier 

(1982).

Note that the two-sided ARL values are related to the positive and negative one-sided ARL 

values by the following equation:

1
ARL
------------ 1

Positive ARL
----------------------------------- 1

Negative ARL
--------------------------------------+=
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Lucas and Crosier (1982) describe the properties of a Head Start value for CUSUM charts in 

which the initial CUSUM S0 is set to a nonzero value. This is sometimes referred to as a fast 

initial response (FIR) feature. Average run length calculations given by them show that the 

FIR feature has little effect when the process is in control and that it leads to a faster response 

to an initial out-of-control condition than a standard CUSUM chart.
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Create Exponentially Weighted Control Charts

Exponentially weighted moving average (EWMA) charts can be used to detect small shifts in a 

process. Each point on an EWMA chart is the weighted average of all the previous subgroup 

means, including the mean of the present subgroup sample. The weights decrease 

exponentially going backward in time.

Figure 11.1  EWMA Control Chart Report
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Overview of the EWMA Control Chart Platform

Exponentially weighted moving average (EWMA) charts can be used to detect small shifts in a 

process. Each point on an EWMA chart is the weighted average of all the previous subgroup 

means, including the mean of the present subgroup sample. The weights decrease 

exponentially going backward in time. For more information about exponentially weighted 

moving average charts, see Box et al. (2009) and Montgomery (2013).

The EWMA Control Chart platform pairs an EWMA chart with an X chart and a residual 

chart. If you do not specify a Subgroup variable, the X chart is an individual measurements 

chart. If you specify a Subgroup variable and at least one subgroup size is greater than 1, the X 

chart is an XBar chart.

Example of the EWMA Control Chart Platform

In this example, you are interested in detecting a shift in the gap between the ends of 

manufactured metal clips. To monitor the process for a change in the average gap, subgroup 

samples of five clips have been measured daily.

1. Select Help > Sample Data Folder and open Quality Control/Clips1.jmp.

2. Select Analyze > Quality and Process > Control Chart > EWMA Control Chart.

3. Select Gap and click Y.

4. Select Sample and click Subgroup.

5. Click OK.
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Figure 11.2  EWMA Control Chart

Purple vertical lines in the EWMA chart denote shifts. Shift starts are detected at samples 4 

and 17.
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Launch the EWMA Control Chart Platform

Launch the EWMA Control Chart platform by selecting Analyze > Quality and Process > 
Control Chart > EWMA Control Chart.

Figure 11.3  EWMA Control Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

The EWMA Control Chart platform launch window contains the following options:

Y Identifies the variables that you want to chart.

Note: If you do not specify a Subgroup variable, the rows of the data table must be sorted 

in the order in which the observations were collected.

Subgroup Identifies a subgroup variable. The horizontal axis of the EWMA chart is labeled 

by the subgroup variable.

By Produces a separate report for each level of the By variable. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the levels of the 

By variables.

Center Data Specifies that the data are centered by subtracting the target from each 

observation.

Show Excluded Region (Applicable only when a Subgroup variable is specified.) Specifies 

that subgroups that are entirely excluded in the data table are shown in the EWMA control 

chart.
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The EWMA Control Chart Platform Report

By default, the EWMA Control Chart platform produces a report that contains a parameter 

control panel, an EWMA chart, an X chart, and a residuals chart.

• “Control Panel for EWMA Control Chart”

• “EWMA Chart Report”

Figure 11.4  EWMA Control Chart Report

Control Panel for EWMA Control Chart

The Control Panel contains the current values for the chart parameters. The current values are 

in boxes that enable you to update the parameter values.
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The Control Panel contains the following options:

Target The known value of the mean. This is the value of the center line in the chart. By 

default, this parameter is set to the Target value in the Spec Limits column property for the 

Y column. If the Y column does not have a Target value in the Spec Limits column 

property, this parameter is set to the overall average of the Y column.

The Target value cannot be edited in these situations:

– If you specified the Center Data option in the launch window.

– If the Y variable has a Spec Limits column property that contains a value for Target. 

However, you can select the Use Overall Mean for Target option in the red triangle 

menu to switch between the Target value in the Spec Limits column property and the 

overall mean of the Y variable.

Sigma The known value of the standard deviation. By default, this parameter is set to the 

average moving range of the Y column. If there is a Subgroup variable, the Sigma 

parameter is set to the average of the moving ranges of the subgroup means.

Note: The default Sigma value calculation does not include excluded rows.

Lambda The value of the smoothing constant for weighting prior samples. By default, this 

parameter is set to 0.2.

*Using Centered Data The presence of this text indicates that the Centered Data option was 

selected in the launch window and that the values in the EWMA chart and X chart are 

centered around the Target value.

EWMA Chart Report

The EWMA Chart report contains three charts: an EWMA chart, an X chart, and a residuals 

chart. For more information about the interpretation of these charts, see Box et al. (2009).

EWMA Chart

The EWMA chart is an exponentially weighted moving average (EWMA) chart with decision 

limits that are determined by the current values of the chart parameters:

• If you specified a Subgroup variable and at least one subgroup size is greater than 1, the 

horizontal axis denotes the subgroups.

• Otherwise, the horizontal axis denotes the samples.
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In both cases, the vertical axis denotes the exponentially weighted moving average. If you 

specified the Center Data option in the launch window, the vertical axis denotes the 

exponentially weighted moving average with the target value subtracted from it. Each sample 

or subgroup has a single point on the chart. There is one additional point that is a forecast 

point, which is shown in blue.

Note: If the last sample (or subgroup) is both hidden and excluded, the line connecting the 

last sample (or subgroup) to the forecast point is not drawn.

X Chart

The X chart is a Shewhart control chart of the observations:

• If you specified a Subgroup variable and at least one subgroup size is greater than 1, the X 

chart is an XBar chart of the mean values. The horizontal axis denotes the subgroups. The 

vertical axis denotes the subgroup means. If you selected the Center Data option in the 

launch window, the vertical axis denotes the subgroup means with the target value 

subtracted from them. Each subgroup has a single point on the chart.

• Otherwise, the X chart is an individual measurements chart of the values. The horizontal 

axis denotes the samples. The vertical axis denotes the measurements. If you selected the 

Center Data option in the launch window, the vertical axis denotes the measurements with 

the target value subtracted from them. Each sample has a single point on the chart.

For more information about the limits on the X chart, see “Statistical Details for Control Chart 

Builder”.

Residuals Chart

The residuals chart shows the differences between the exponentially weighted moving 

averages and the observed values:

• If you specified a Subgroup variable and at least one subgroup size is greater than 1, the 

residuals chart is a chart of the differences between each subgroup mean and the EWMA 

value for the previous subgroup. The ith residual is calculated as ri = Xi - EWMAi-1 where 

Xi denotes the ith subgroup mean and EWMAi-1 denotes the (i-1)th EWMA value.

• Otherwise, the residuals chart is a chart of the differences between each sample value and 

the EWMA value for the previous sample. The ith residual is calculated as ri = Xi - EWMAi-1 

where Xi denotes the ith sample value and EWMAi-1 denotes the (i-1)th EWMA value.

The limits on the residuals chart are ±3*ResidSigma, where ResidSigma is the standard 

deviation of the residuals.
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The EWMA and residuals charts can be used to identify possible seasonality and 

autocorrelation in a process. For example, in Figure 11.5, the peaks and valleys in the EWMA 

chart are evidence of seasonality in the process. The points outside limits in the residuals chart 

are evidence of autocorrelation. For this example, it would be appropriate to fit a time series 

model to the process observations and create a control chart for the residuals from the time 

series model. For more information about using the residuals chart for detecting 

autocorrelation, see Montgomery and Mastrangelo (1991).

Figure 11.5  Example of Autocorrelation and Seasonality in a Process
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The EWMA Control Chart Platform Options

The EWMA Control Chart red triangle menu contains the following options:

Show Limits Shows or hides the upper and lower decision limits in the EWMA chart, X 

chart, and residuals chart.

Show Center Line Shows or hides the center line in the EWMA chart, X chart, and residuals 

chart.

Show Shift Lines Shows or hides the vertical lines in the EWMA chart that designate shifts. 

Shift lines are drawn at the start of a shift. A shift start is defined as the first point after the 

EWMA value crosses the center line in a particular direction.

– A positive shift occurs when the EWMA value exceeds the upper limit on the chart. The 

start of the shift is defined as the first point after the most recent EWMA value below 

the Target line.

– A negative shift occurs when the EWMA value falls below the lower limit on the chart. 

The start of the shift is defined as the first point after the most recent EWMA value 

above the Target line.

Figure 11.6  Shift Lines Example

In this example, the point for sample 7 is above the upper limit. Looking back from sample 

7, the most recent point below the Target line is sample 3. Therefore, sample 4 is the first 

point above the Target line since the most recent point below the Target line and is denoted 

as the start of the positive shift.

Similarly, the point for sample 20 is below the lower limit and the most recent point above 

the Target line is sample 16. Therefore, sample 17 is denoted as the start of the negative 

shift.

Test Beyond Limits Shows or hides a red circle around any point that is above the upper 

limit or below the lower limit in the EWMA and X charts.
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Show ARL Shows or hides the Average Run Length (ARL) report. See “Average Run Length 

(ARL) Report”.

Control Panel Shows or hides a report of the current values of the parameters. This report 

enables you to change the parameter values in the EWMA chart.

Parameters Report Shows or hides a report of the current values of the parameters.

Constant Limits Specifies that the EWMA chart limits are calculated using an asymptotic 

expression so that the limits on the EWMA chart are constant.

Caution: The Constant Limits option has no effect when the sample sizes are not equal 

across subgroups.

Save Summaries Creates a new data table that contains statistics for each subgroup in the 

EWMA chart. The following statistics are saved to the new data table: the subgroup 

number, the subgroup label, the subgroup size, the subgroup mean, an indicator of shift 

starts, a value that indicates each interval between shift starts, the exponentially weighted 

moving average of each subgroup, the number of positive and negative consecutive run 

counts, the LCL and UCL values, and test failure indicators. The table also contains 

columns for the center, LCL, and UCL values for the X chart, as well as columns for the 

point, average, LCL, and UCL values for the Residuals chart. The forecast value is saved in 

the last row of the summary table.

Reset to Defaults Resets all parameters to their default values. If a Lambda value has been 

specified in the Lambda platform preference, the Lambda value is reset to the value that is 

specified in the platform preference.

Note: When the Y variable has a Spec Limits column property that contains a value for 

Target, the Reset to Defaults option sets the Target to the Target value in the Spec Limits 

column property.

Restart EWMA After Empty Subgroup Specifies how calculations for the moving average 

and limits are handled when there are empty subgroups. A subgroup can be empty if all 

the observations for the subgroup are missing values or are in excluded rows. If this 

option is selected, the calculations restart in the first nonmissing subgroup that follows an 

empty subgroup. The restart of the calculations resets the moving average to the overall 

mean. If this option is not selected, the EWMA calculations continue with the most recent 

nonmissing subgroup moving average.

Connect Thru Missing Connects points when some samples have missing values or 

excluded rows.

Use Overall Mean for Target (Available only when the Y variable has a Spec Limits column 

property that contains a value for Target.) Sets the Target in the EWMA chart to the overall 
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mean of the Y variable. If this option is not selected, the Target in the EWMA chart is set to 

the Target value in the Spec Limits column property.

Overlay Charts Specifies whether the individual location values are overlaid on the EWMA 

chart. When this option is selected, the Location chart is no longer shown. Instead, the 

points from the Location chart appear on the EWMA chart as unconnected gray Xs. The 

limits from the Location chart do not appear on the EWMA chart, unless the Show X 

Limits on Overlay Charts option is selected.

Note: When the Overlay Charts option is selected, the Show X Chart option is also 

selected.

Show X Limits on Overlay Charts (Available only when the Overlay Charts option is 

selected.) Shows or hides the limits from the Location chart on the EWMA chart when the 

Overlay Charts option is selected. When the Location chart limits are shown on the 

EWMA chart, they appear as dashed lines.

Note: The Test Beyond Limits option is applied to the Location chart values in the Overlay 

Chart only when the Show X Limits on Overlay Charts option is selected.

Lambda Slider Shows or hides a slider control that enables you to change the value of the 

Lambda parameter interactively.

Show X Chart Shows or hides the Location chart below the EWMA chart.

Note: When the Overlay Charts option is selected, the Show X Chart option is also 

selected and cannot be turned off.

Show Residuals Chart Shows or hides a chart of residuals.

K Sigma Sets the K value to be multiplied by sigma to form the control limit about the 

average. By default, K Sigma is set to 3.

Get Limits Retrieves the control limits that are stored in an open or saved data table.

Save Limits Saves the chart parameters in one of the following ways:

in Column Saves a Control Limits column property in the existing data table for the 

response variable. The column property contains the value of the target used in the 

EWMA chart.

in New Table Saves the values of Lambda, the standard deviation, and the target for the 

EWMA chart into a new data table.

Save Sigma Saves the value of the Sigma parameter to a Sigma column property in the Y 

variable column in the data table.
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Alarm Script Enables you to write and run a script that indicates when the data fail special 

causes tests. Results can be written to a file, written to the log or sent in an email. There is 

an option to include an explanation of why the test failed.

As an Alarm Script is invoked, the following variables are available, both in the issued 

script and in subsequent JSL scripts:

qc_col is the name of the column

qc_test is the test that failed

qc_sample is the sample number

Tip: After an alarm script is specified, the alarm script is invoked when the Test Beyond 

Limits option is turned on.

See the Scripting Guide for more information about writing custom Alarm Scripts.

See Using JMP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Average Run Length (ARL) Report

In the EWMA Control Chart platform, the Average Run Length (ARL) report contains a table 

and a graph of ARL values. The average run length (ARL) for a specified shift is the average 

number of runs expected before an out-of-control signal occurs. For example, the ARL at 0 

represents the average number of runs expected before seeing a false-alarm signal when the 

process is in control. When the process is in control, the shift size is 0.

The table and graph in the ARL report enable you to explore how various settings of the 

Lambda parameter affect the performance of the corresponding EWMA chart. The table and 

graph also enable you to compare the performance of the EWMA chart with a Shewhart chart, 

such as the X chart in the EWMA Chart report. The Shewhart ARL column is equivalent to the 

EWMA ARL column when Lambda is set to 1.
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The value of EWMA ARL at 0 depends on the setting of the Constant Limits option:

• If the Constant Limits option is selected, the process is assumed to have been in control 

long enough that the effect of the starting value is negligible. In this case, also referred to 

as a steady state of the EWMA chart, the value of EWMA ARL(0) is calculated using the 

method described in Crowder (1987a) and Crowder (1987b).

• If the Constant Limits option is not selected, the value of EWMA ARL(0) is calculated 

using the method described in Knoth (2004). This situation is also referred to as a zero state 

of the EWMA chart.

ARL Report

The ARL Report shows the average run length for standardized shifts () between 0 and 3 at 

0.25 increments. The shift is represented by sqrt(n)*RawShift/Sigma, where n is the constant 

sample size in each subgroup. The multiplier used in calculating control limits is the current 

value of K Sigma. By default, K Sigma is set to 3. This table contains ARL values for the 

EWMA chart as well as a Shewhart chart.

ARL Graph

The ARL Graph shows the average run length for standardized shifts () between 0 and 3. 

This graph contains the same data points as the ARL Table to the left of the ARL Graph. The 

solid line corresponds to the EWMA ARL values, and the dashed line corresponds to the 

Shewhart ARL values.

Additional Example of the EWMA Control Chart 
Platform

In this example, you create a chart that overlays the subgroup points and limits on the EWMA 

control chart. This enables you to see the EWMA points in the context of the subgroup points. 

The data table used in this example contains simulated observations of temperature at the 

time of magnet quench. Magnet quench occurs when part of the superconducting coil enters a 

resistive state and increases in temperature. When this happens, containment of the fusion 

reactor is at risk. Immediately shutting down power to the magnet is required to prevent a 

breach.

1. Select Help > Sample Data Folder and open Quality Control/Quench.jmp.

2. Select Analyze > Quality and Process > Control Chart > EWMA Control Chart.

3. Select Temp and click Y.

4. Select Time stamp and click Subgroup.

5. Click OK.
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6. Click the EWMA Control Chart red triangle and select Test Beyond Limits.

Figure 11.7  EWMA Chart with Points Beyond Limits Highlighted

Note that three observations are outside the limits in the EWMA chart and one observation 

is outside the limits in the X chart. The observations outside of the limits are indicated by a 

red circle. The purple vertical line in the EWMA chart denotes a shift upward around 1:16 

AM.

7. Click the EWMA Control Chart red triangle and select Overlay Charts.

The X chart limits are not shown on the overlay chart by default, so the observation 

outside the X limits is not circled until you turn on the X limits for the overlay chart.

8. Click the EWMA Control Chart red triangle and select Show X Limits on Overlay Charts.
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Figure 11.8  EWMA Chart with Overlaid X Chart

The solid lines and circles in the top chart represent the limits and points for the EWMA 

chart. The dashed lines and x markers represent the limits and points for the X chart. Note 

that the observations outside the EWMA limits and the X limits are still circled.

9. Click the EWMA Control Chart red triangle and select Constant Limits.
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Figure 11.9  EWMA Chart with Constant Limits

Because the time span of the data is so long, the asymptotic limits differ from the original 

EWMA limits only for the first few subgroups. In this case, you might decide that you can 

use constant (asymptotic) limits instead of the EWMA limits.

Statistical Details for the EWMA Control Chart 
Platform

This section defines the statistics that are used in the construction of the EWMA chart. Some of 

these statistics are also saved in the data table that is created by the Save Summaries 

command.

The ith point on the EWMA chart is calculated as follows:

EWMAi = Xi + (1 - )EWMAi-1

where:

 = Lambda parameter

Xi = ith sample value (or subgroup mean)
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EWMAi-1 = (i-1)th EWMA value

When i = 1, define EWMA0 as the Target value.

Note: When the Restart EWMA after Empty Subgroup option is selected, the EWMAi-1 value 

following an empty subgroup is the Target value. When the Restart EWMA after Empty 

Subgroups option is not selected, the EWMAi-1 value following an empty subgroup is the 

EWMA value for the most recent non-empty subgroup.

The computation of the control limits on the EWMA chart is determined by the setting of the 

Constant Limits option.

EWMA Limits

When the Constant Limits option is not selected and the subgroup sizes are not equal, the 

EWMA control limits are computed as follows:

LCL = 

UCL = 

where:

T = Target value

K = the sigma multiplier and is set to 3 by default

 = Sigma value

i = the number of the sample (or subgroup)

ni = the size of subgroup i

When the Constant Limits option is not selected and the subgroup sizes are equal, the 

formulas for the EWMA control limits simplify as follows:

LCL = 

UCL = 
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where:

T = Target value

K = the sigma multiplier and is set to 3 by default

 = Sigma value

i = the number of the sample (or subgroup)

n = the size of each subgroup (or 1 if no subgroup is specified)

Constant Limits

When the Constant Limits option is selected, the EWMA control limits are computed as 

follows:

LCL = 

UCL = 

where:

T = Target value

K = the sigma multiplier and is set to 3 by default

 = Sigma value

n = the subgroup size (or 1 if no subgroup is specified)

For more information about constructing exponentially weighted moving average charts, see 

Montgomery (2013).

T K 
n 2 – 
--------------------–

T K 
n 2 – 
--------------------+
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Chapter 12
Multivariate Control Charts

Monitor Multiple Process Characteristics Simultaneously

The Multivariate Control Charts platform is deprecated, meaning it is an older platform that 

contains features that can be accessed in a newer platform. This legacy platform might not be 

available in future releases of JMP.

For monitoring and diagnosing complex processes, see “Model Driven Multivariate Control 

Charts”.
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Overview of Multivariate Control Charts

Multivariate control charts are used to monitor two or more interrelated process variables. 

Where univariate control charts are used to monitor a single independent process 

characteristic, multivariate control charts are necessary when process variables are correlated. 

A Hotelling T2 chart, or just T2 chart for short, is one type of multivariate control chart. A T2 

chart can detect shifts in the mean or the relationship between several interrelated variables. 

The observations can either be individual observations of the process variables or they can be 

grouped into rational subgroups.

Tip: For an updated multivariate control chart platform, see “Model Driven Multivariate 

Control Charts”.

Launch the Multivariate Control Chart Platform

Launch the Multivariate Control Chart platform by selecting Analyze > Quality And Process > 
Control Chart > Multivariate Control Chart.

Figure 12.1  The Multivariate Control Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Tip: Consider using the newer Model Driven Multivariate Control Chart platform. To launch 

the Model Driven Multivariate Control Chart platform, select Analyze > Quality and Process 
> Model Driven Multivariate Control Chart.

The Multivariate Control Chart platform launch window contains the following options:

Y, Columns Specify the columns to be analyzed.
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Subgroup Enter a column with sub-grouped data. Hierarchically, this group is nested within 

Group.

Group Enter a column that specifies group membership at the highest hierarchical level.

Weight Identifies the data table column whose variables assign weight (such as importance 

or influence) to the data.

Freq Identifies the data table column whose values assign a frequency to each row. Can be 

useful when your data table contains summarized data.

By Identifies a column that creates a report consisting of separate analyses for each level of 

the variable.

Get Targets Click to select a JMP table that contains historical targets for the process.
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The Multivariate Control Chart Report

Use a multivariate control chart to quickly identify shifts in your process and to monitor your 

process for special cause indications.

Figure 12.2  Multivariate Control Chart
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The multivariate control chart plots Hotelling’s T2 statistic. The calculation for the control limit 

differs based on whether targets have been specified. To understand how the T2 statistic and 

the UCL (Upper Control Limit) are calculated, see “Statistical Details for Multivariate Control 

Charts”. For more information about control limits, see Tracy et al. (1992).

In this example, the Principal Components reports for both data sets indicate that the first 

eigenvalue, corresponding to the first principal component, explains about 95% of the total 

variation in the variables. The values in both Eigenvectors tables indicate that the first 

principal component is driven primarily by the variables Fuel and Steam Flow. You can use 

this information to construct a potentially more sensitive control chart based only on this first 

component. For more information about the Principal Components reports, see “Principal 

Components”.

Multivariate Control Chart Platform Options

The Multivariate Control Chart red triangle menu contains the following options:

T Square Chart Shows the T2 chart. Hotelling’s T2 chart is a multivariate extension of the 

XBar chart that takes correlation into account.

T Square Partitioned Constructs multivariate control charts based on the principal 

components of Y. Specify the number of major principal components for T2. See “T Square 

Partitioned”.

Set Alpha Level Set the  level used to calculate the control limit. The default is =0.05.

Show Covariance Shows the Covariance report. Covariance is a measure of the linear 

relationship between two variables. When a subgroup variable is specified, the Pooled 

Covariance report is shown.

Show Correlation Shows the Correlation report. When a subgroup variable is specified, the 

Pooled Correlation report is shown.

Show Inverse Covariance Shows the Inverse Covariance report. If the inverse covariance is 

singular, a generalized inverse of the covariance matrix is reported. When a subgroup 

variable is specified, the Pooled Inverse Covariance report is shown.

Show Inverse Correlation Shows the Inverse Correlation report. If the inverse correlation is 

singular, a generalized inverse of the correlation matrix is reported. When a subgroup 

variable is specified, the Pooled Inverse Correlation report is shown.

Show Means Shows the Group Means report, which contains the means for each group.

Save T Square Creates a new column in the data table containing T2 values.
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Save T Square Formula Creates a new column in the data table. Stores a formula in the 

column that calculates the T2 values.

Save Target Statistics Creates a new data table containing target statistics for the process. 

Target statistics include: sample size, the number of samples, mean, standard deviation, 

and any correlations.

Change Point Detection (Not available for sub-grouped data.) Shows a Change Point 

Detection plot of test statistics by row number and indicates the row number where the 

change point appears. See “Change Point Detection”.

Principal Components Shows reports showing eigenvalues and their corresponding 

eigenvectors. Principal components help you understand which of the many variables you 

might be monitoring are primarily responsible for the variation in your process. See 

“Principal Components”.

Save Principal Components Creates new columns in the data table that contain the scaled 

principal components.

T Square Partitioned

In the Multivariate Control Chart red triangle menu, you can use the T Square Partitioned 

option to construct a control chart based on principal components. This is useful if you are 

monitoring a large number of correlated process characteristics. If a small number of principal 

components explains a large portion of the variation in your measurements, then a 

multivariate control chart based on these big components might be more sensitive than a chart 

based on your original, higher-dimensional data.

Tip: Consider using the Model Driven Multivariate Control Chart platform for decomposition 

of the T2 statistic. See “Model Driven Multivariate Control Charts”.

The T Square Partitioned option is also useful when your covariance matrix is ill-conditioned. 

When this is the case, components with small eigenvalues, explaining very little variation, can 

have a large, and misleading, impact on T2. It is useful to separate out these less important 

components when studying process behavior.

Once you select the T Square Partitioned option, you need to decide how many major 

principal components to use.
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The option creates two multivariate control charts: T Square with Big Principal Components 

and T Square with Small Principal Components. Suppose that you enter r as the number of 

major components when you first select the option. The chart with Big Principal Components 

is based on the r principal components corresponding to the r largest eigenvalues. These are 

the r components that explain the largest amount of variation, as shown in the Percent and 

Cum Percent columns in the Principal Components: on Covariances reports. The chart with 

Small Principal Components is based on the remaining principal components.

For a given subgroup, its T2 value in the Big Principal Components chart and its T2 value in 

the Small Principal Components chart sum to its overall T2 statistic presented in the T2 with 

All Principal Components report. For more information about how the partitioned T2 values 

are calculated, see Kourti and MacGregor (1996).

Change Point Detection

When the data set consists of multivariate individual observations, a multivariate control 

chart can be developed to detect a shift in the mean vector, the covariance matrix, or both. This 

method partitions the data and calculates likelihood ratio test statistics for a shift. The statistic 

that is plotted on the control chart is an observation’s likelihood ratio test statistic divided by 

the product of the following:

• Its approximate expected value assuming no shift.

• An approximate value for an upper control limit.

Division by the approximate upper control limit allows the points to be plotted against an 

effective upper control limit of 1. A Change Point Detection plot readily shows the change 

point for a shift occurring at the maximized value of the control chart statistic. The Change 

Point Detection implementation in JMP is based on Sullivan and Woodall (2000) and is 

described in “Statistical Details for Change Point Detection”.

Note: The Change Point Detection method is designed to show a single shift in the data. 

Detect multiple shifts by recursive application of this method.

Note the following about the Change Point Detection plot:

• Values above 1.0 indicate a possible shift in the data.

• Control chart statistics for the Change Point Detection plot are obtained by dividing the 

likelihood ratio statistic of interest (either a mean vector or a covariance matrix) by a 

normalizing factor.

• The change point of the data occurs for the observation having the maximum test statistic 

value for the Change Point Detection plot.

Note the following about the scatterplot matrix:

• This plot shows the shift in the sample mean vector.
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Principal Components

In the Multivariate Control Chart platform, the Principal Components report contains the 

following information:

Eigenvalue Eigenvalues for the covariance matrix.

Percent Percent variation explained by the corresponding eigenvector. Also shows an 

accompanying bar chart.

Cum Percent Cumulative percent variation explained by eigenvectors corresponding to the 

eigenvalues.

ChiSquare Provides a test of whether the correlation remaining in the data is of a random 

nature. This is a Bartlett test of sphericity. When this test rejects the null hypothesis, this 

implies that there is structure remaining in the data that is associated with this eigenvalue.

DF Degrees of freedom associated with the Chi-square test.

Prob > ChiSq p-value for the test.

Eigenvectors Table of eigenvectors corresponding to the eigenvalues. Note that each 

eigenvector is divided by the square root of its corresponding eigenvalue.

For more information about principal components, see Multivariate Methods.

Statistical Details for Multivariate Control Charts

This section contains statistical details for the Multivariate Control Chart platform.

• “Statistical Details for Individual Observations”

• “Statistical Details for Observations in Rational Subgroups”

• “Statistical Details for Change Point Detection”



354 Multivariate Control Charts Chapter 12
Statistical Details for Multivariate Control Charts Quality and Process Methods

Statistical Details for Individual Observations

You can use the Multivariate Control Chart platform to analyze individual observations, or 

measurements that are not sub-grouped. For these types of measurements, the natural 

subgroup size is n = 1. Denote the number of observations by m and the number of variables 

measured by p. A T2 statistic is calculated and plotted for each observation. The calculation of 

the T2 statistic and upper control limit (UCL) depends on the source of the target statistics. In 

a Phase I chart, the limits are based on the same data that is being plotted on the control chart. 

In a Phase II chart, the limits are based on target statistics that were calculated from a 

historical data set. For more information about T2 statistic and control limit calculations for 

Hotelling T2 control charts, see Montgomery (2013).

Calculations for Phase I Control Charts

In Phase I control charts, the T2 statistic for the ith observation is defined as follows:

where:

Yi is the column vector of p measurements for the ith observation

 is the column vector of sample means of the p variables

S-1 is the inverse of the sample covariance matrix

The Ti
2 value for each of the i observations are the points plotted on the multivariate control 

chart.

When computing Phase I control limits, the UCL is based on the beta distribution. Specifically, 

the upper control limit (UCL) is defined as follows:

where:

p = number of variables

m = number of observations

 = (1–)th quantile of a Beta  distribution
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Calculations for Phase II Control Charts

In Phase II control charts, define the historical data set as X. Then the T2 statistic for the ith 

observation is defined as follows:

where:

Yi is the column vector of p measurements for the ith observation

 is the column vector of sample means of the p variables, calculated from the historical 

data set

SX
-1 is the inverse of the sample covariance matrix, calculated from the historical data set

The Ti
2 value for each of the i observations are the points plotted on the multivariate control 

chart.

When computing Phase II control limits, new observations are independent of the historical 

data set. In this case, the upper control limit (UCL) is a function of the F distribution and 

partially depends on the number of observations in the historical data set from which the 

targets are calculated. The UCL is defined as follows:

where:

p = number of variables

m = number of observations in the historical data set

 = (1–)th quantile of an F  distribution
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Statistical Details for Observations in Rational Subgroups

You can use the Multivariate Control Chart platform to analyze observations that are 

sub-grouped. Consider the case where p variables are monitored and m subgroups of size 

n > 1 are obtained. A T2 statistic is calculated and plotted for each subgroup. The calculation of 

the T2 statistic and upper control limit (UCL) depends on the source of the target statistics. In 

a Phase I chart, the limits are based on the same data that is being plotted on the control chart. 

In a Phase II chart, the limits are based on target statistics that were calculated from a 

historical data set. For more information about T2 statistic and control limit calculations for 

Hotelling T2 control charts, see Montgomery (2013).

Calculations for Phase I Control Charts

For Phase I control charts, the T2 statistic for the jth subgroup is defined as follows:

where:

 is the mean of the n column vectors of p measurements for the jth subgroup

 is the mean of the subgroup means

Sj is the sample covariance matrix for the n observations in the jth subgroup

 is the pooled covariance matrix, calculated as the mean of the 

within-subgroup covariance matrices

The Phase I upper control limit (UCL) is defined as follows:

where:

p = number of variables

n = sample size for each subgroup

m = number of subgroups
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 = (1–)th quantile of an F  distribution

Calculations for Phase II Control Charts

In Phase II control charts, define the historical data set from which the target statistics are 

calculated as X. Then the T2 statistic for the jth subgroup is defined as follows:

where:

 is the mean of the n column vectors of p measurements for the jth subgroup

 is the mean of the n column vectors of p measurements for the kth subgroup from the 

historical data set

 is the overall mean of the observations

Sk is the sample covariance matrix for the n observations in the kth subgroup from the 

historical data set

 is the pooled covariance matrix, calculated as the mean of the 

within-subgroup covariance matrices

The Phase II upper control limit (UCL) is defined as follows:

where:

p = number of variables

n = subgroup sample size

m = number of subgroups in the historical data set

 = (1–)th quantile of an F  distribution
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Additivity of Test Statistics for Observations in Rational Subgroups

When a sample of mn independent normal observations is grouped into m rational subgroups 

each of size n, define T2
M as the distance between the mean  of the jth subgroup and the 

target value. (T2
M is equivalent to T2 in the previous sections for observations in rational 

subgroups.) You can also calculate T2 statistics related to the internal variability in each 

subgroup and the overall variability around the target value. The components of the T2 

statistic are additive, much like sums of squares. Specifically, the following relationship is true 

for each of the m subgroups:

In all of the following definitions, Sp is defined as it is in the previous sections, depending on 

whether the control chart is a Phase I or a Phase II control chart. Also, define  as  for Phase 

I control charts and as  for Phase II control charts.

The distance from the target value for the jth subgroup is defined as follows:

The internal variability for the jth subgroup is defined as follows:

where Yji is the ith column vector of p measurements for the jth subgroup.

The overall variability for the jth subgroup is defined as follows:

where Yji is the ith column vector of p measurements for the jth subgroup.

Note: When you select the Save T Square or Save T Square Formula options from the 

Multivariate Control Chart red triangle menu, the three values saved in each row correspond 

to one value of i in the three definitions above.
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Statistical Details for Change Point Detection

This section contains details for the Change Point Detection option in the Multivariate Control 

Chart platform. This discussion follows the development in Sullivan and Woodall (2000).

Assumptions

Denote a multivariate distribution of dimension p with mean vector i and covariance matrix 

i by Np(i,i). Suppose that the xi are m (where m > p) independent observations from such a 

distribution:

If the process is stable, the means i and the covariance matrices i equal a common value so 

that the xi have a Np(, ) distribution.

Suppose that a single change occurs in either the mean vector or the covariance matrix, or 

both, between the m1 and m1+1 observations. Then the following conditions hold:

• Observations 1 through m1 have the same mean vector and the same covariance matrix 

(a,a).

• Observations m1 + 1 to m have the same mean vector and covariance matrix (b,b).

• One of the following occurs:

– If the change affects the mean, a  b.

– If the change affects the covariance matrix, a  b.

– If the change affects both the mean and the covariance matrix, a  b and a  b.

Overview

A likelihood ratio test approach is used to identify changes in one or both of the mean vector 

and covariance matrix. The likelihood ratio test statistic is used to compute a control chart 

statistic that has an approximate upper control limit of 1. The control chart statistic is plotted 

for all possible m1 values. If any observation’s control chart statistic exceeds the upper control 

limit of 1, this is an indication that a shift occurred. Assuming that exactly one shift occurs, 

that shift is considered to begin immediately after the observation with the maximum control 

chart statistic value.

xi Np i i, ,     i 1  m,=
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Likelihood Ratio Test Statistic

The maximum value of twice the log-likelihood function for the first m1 observations is 

defined as follows:

The equation for l1 uses the following notation:

• S1 is the maximum likelihood estimate of the covariance matrix for the first m1 

observations.

• k1 = Min[p,m1-1] is the rank of the p x p matrix S1.

• The notation  denotes the generalized determinant of the matrix S1, which is defined 

as the product of its k1 positive eigenvalues j:

The generalized determinant is equal to the ordinary determinant when S1 has full rank.

Denote the maximum of twice the log-likelihood function for the subsequent m2 = m - m1 

observations by l2, and the maximum of twice the log-likelihood function for all m 

observations by l0. Both l2 and l0 are given by expressions similar to that given for l1.

The likelihood ratio test statistic compares the sum l1 + l2 to l0. The sum l1 + l2 is twice the 

log-likelihood that assumes a possible shift at m1. The value l0 is twice the log-likelihood that 

assumes no shift. If l0 is substantially smaller than l1 + l2, the process is assumed to be unstable.

The likelihood ratio test statistic for a test of whether a change begins at observation m1 + 1 is 

defined as follows:

The distribution of the likelihood ratio test statistic is asymptotically chi-square distributed 

with p(p + 3)/2 degrees of freedom. Large log-likelihood ratio values indicate that the process 

is unstable.

l1 m1k1 2 log– m1 S1 k1

log m1k1––=

S1 k1

S1 k1

j

j 1=

k1

=

lrt m1  l1 l2 l0–+ =

 m1 p k1–  m2 p k2– +  1 2 log+ =

             m S  m1 S1 k1
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The Control Chart Statistic

Simulations indicate that the expected value of lrt[m1] varies based on the observation’s 

location in the series, and, in particular, depends on p and m. See Sullivan and Woodall (2000).

Approximating formulas for the expected value of lrt[m1] are derived by simulation. To 

reduce the dependence of the expected value on p, lrt[m1] is divided by its asymptotic 

expected value, p(p + 3)/2.

The formulas for the approximated expected value of lrt[m1] divided by p(p+3)/2 are defined 

as follows:

where

and

For p = 2, the value of ev[m,p,m1] when m1 or m2 = 2 is 1.3505.

Note: The formulas above are not accurate for p > 12 or m < (2p + 4). In such cases, simulation 

should be used to obtain approximate expected values.

An approximate upper control limit that yields a false out-of-control signal with probability 

approximately 0.05, assuming that the process is stable, is calculated as follows:

Note that this formula depends on m and p.
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The control chart statistic is defined to be twice the log of the likelihood ratio test statistic 

divided by p(p + 3), divided by its approximate expected value, and also divided by the 

approximate value of the control limit. Because of the division by the approximate value of the 

UCL, the control chart statistic can be plotted against an upper control limit of 1. The 

approximate control chart statistic is calculated as follows:

ŷ m1 
2lrt m1 

p p 3+  ev m p m1,, UCL m p[ , ] 
----------------------------------------------------------------------------------=
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Monitor and Diagnosis a Complex Process

Model-driven multivariate control charts are used to monitor parameters for multiple 

processes in a single control chart. The Model Driven Multivariate Control Chart (MDMVCC) 

platform enables you to build a control chart based on principal components or partial least 

squares models. For a set of continuous variables, the MDMVCC platform uses principal 

components to build the control chart. For saved principal components or partial least squares 

score functions, the MDMVCC platform builds a control chart based on the provided models. 

Use the MDMVCC platform to interactively explore and understand the underlying 

components that lead to out-of-control signals.

Figure 13.1  Model-driven Multiple Control Chart
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Overview of Model Driven Multivariate Control 
Charts

The Model Driven Multivariate Control Chart (MDMVCC) platform has two primary 

functions: monitoring and diagnosing.

• Use multivariate control charts to monitor a multivariate process.

• You can interactively drill down to investigate the contributions of individual variables to 

the overall signal to diagnosis the process.

For more information about multivariate control charts, see Kourti and MacGregor (1996).

You can construct a model driven multivariate control chart using current or historical data. A 

control chart is considered to be a Phase I chart if it is constructed using current data; a control 

chart is considered to be a Phase II chart if it is constructed using target statistics from a 

historical data set. In a Phase I chart, you check that the process is stable and establish a 

historical data set from which to calculate target statistics for the process. In a Phase II chart, 

the control chart uses the target statistics from Phase I in order to monitor new process 

observations.

To construct a Phase II model driven multivariate control chart, first identify a period of time 

during which the process is stable and capable. Then, perform the following steps:

1. Develop a Phase I control chart to verify that the process is stable over this period. The 

data used in Phase I provides a historical data set.

2. Save the target statistics for this historical data set.

3. Monitor the on-going process using the Phase II control chart.

See “Example of a Model Driven Multivariate Control Chart with Historical Data”.

Example of Model Driven Multivariate Control Charts

In this example, you build a multivariate control chart for the historical values of six process 

variables in a steam turbine system.

1. Select Help > Sample Data Folder and open Quality Control/Steam Turbine Historical.jmp.

2. Select Analyze > Quality and Process > Model Driven Multivariate Control Chart.

3. Select all six columns, click Process, and click OK.
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Figure 13.2  Steam Turbine Report

Note that the process shifts after sample 16.

4. Select the sample 17 data point. Right-click and select Rows > Row Label.

5. Hover over the sample 17 data point to view the T2 contribution proportion plot for that 

point. Click on the plot to open the plot in the report window.

Figure 13.3  Contribution Proportion Plot for Sample 17
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Note that Cool Temp contributes 40% of the T2 value. The Cool Temp bar is green indicating 

that sample 17 is within the univariate control limits for Cool Temp. Steam Flow and MW each 

contribute about 20% of the T2 value. They are both red, which indicates that sample 17 is 

outside of the univariate control limits for each variable. Steam Temp has a zero contribution 

to the T2 value. In this example, you found variables where the multivariate out-of-control 

sample could be traced to an out-of-control univariate variable. However, that is not always 

the case. In multivariate process control you may observe an out-of-control point on the T2 

chart but find that the sample is in-control at the univariate level for all variables.

6. Hover over the Steam Flow bar in the contribution proportion plot to see a univariate 

control chart for Steam Flow. Click on the chart to open in a new report window.

Figure 13.4  Individual Chart for Steam Flow

The individual chart indicates that the steam flow might have experienced an upset around 

sample 17. When control limits are specified in the Controls Limits column property, the 

individual chart respects those limits.

7. In the PCA Model Driven Multivariate Control Chart report window, Click the T2 for 3 

Principal Components red triangle and select Contribution Proportion Heat Map.
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Figure 13.5  Contribution Proportion Heat Map

The contribution proportion heat map shows that there is a shift in the contribution 

proportions for rows 16, 17, and 18 and again at row 23 as compared to other rows. Generally, 

Steam Temp, Cool Temp, and Pressure contribute the most to the T2 value for each row.

Launch the Model Driven Multivariate Control Chart 
Platform

Launch the Model Driven Multivariate Control Chart (MDMVCC) platform by selecting 

Analyze > Quality and Process > Model Driven Multivariate Control Chart.

Figure 13.6  The Model Driven Multivariate Control Chart Launch Window
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For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

The MDMVCC platform launch window contains the following options:

Process Assigns the process columns. See “Data Format”.

Time ID Assigns a column that is used to identify samples. If no Time ID is assigned, the row 

number identifies the observations. If the Time ID column is a time, the time identifies 

each sample. Otherwise, the numeric value of the Time ID identifies each sample.

By Produces a separate report for each level of the By variable. If more than one By variable 

is assigned, a separate report is produced for each possible combination of the By 

variables.

Historical Data End at Row Specifies a row number to indicate where historical data end. 

This enables you to calculate chart limits based on historical data. Both historical and 

current data are plotted on the charts. Historical data are also known as Phase I data, and 

current data are also known as Phase II data.

Data Format

The Model Driven Multivariate Control Chart (MDMVCC) platform accepts data in the 

following three allowable data formats:

Raw Data Use continuous process data to build a control chart that is based on the principal 

components of the data. The default dimension of the control chart is based on the number 

of principal components that account for 85% of the process variation. This number is 

based on the cumulative percent of the principal component eigenvalues.

Principal Components Use principal component columns that were previously saved from a 

principal component analysis (PCA). The default dimension of the control chart is the 

number of components specified as process variables.

Partial Least Squares Score Data Use score columns that were previously saved from a 

partial least squares (PLS) analysis to build a control chart that is based on the score 

columns. The default dimension of the control chart is the number of scores specified as 

process variables.

Notes:

• PCA or PLS models built with a frequency or weight column are not supported.

• PCA or PLS models built with historical data must use the same number of historical data 

rows as specified in the MDMVCC launch window.

• PCA models built from within the Multivariate platform are not supported.
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The Model Driven Multivariate Control Chart Report

The initial Model Driven Multivariate Control Chart (MDMVCC) Report shows a T2 control 

chart. The hover labels on the chart are themselves charts. Click the hover label charts to open 

larger versions of the charts. Depending on the chart, they open in a separate report window 

or in the Diagnosis the Process section of the MDMVCC report. You can use the graphlets to 

interactively drill down into the data.

Figure 13.7  MDMVCC Report with a Hover Graphlet

Model Driven Multivariate Control Chart Platform 
Options

The PCA Model Driven Multivariate Control Chart red triangle menu contains the following 

options:

Show History Summary Statistics Shows or hides summary statistics for rows designated as 

historical data or all rows if historical data rows are not specified. Summary statistics 

include univariate means and standard deviations for process variables. For PCA-based 

charts, the eigenvalues and eigenvectors are displayed. For charts based on PLS scores, the 

standard deviation of scores and the score loadings are displayed.

Monitor the Process Contains the following options for monitoring the process.

Show Monitoring Plots Shows or hides the selected process monitoring plots.
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Set Component Enables you to set the number of components for the T2, DModX, or SPE 

plots. The number of components can range from one up to the number of valid 

eigenvectors for PCA driven analysis or from one up to the number of PLS model 

factors for PLS driven analysis.

Set  Level Enables you to adjust the alpha level that is used for all control chart limits.

T2 Plot Shows or hides a T2 plot. The T2 statistic is a summary of multivariate variation 

that measures how far away an observation is from the center of a PCA or PLS model.

Note: When using local data filters with historical data, T2 charts are only available for 

groups with historical data.

Normalized DModX Plot Shows or hides a plot of the normalized DModX values. 

DModX measures the distance of each observation to the PCA or PLS model. A high 

DModX value indicates an observation that deviates from the underlying correlation 

structure of the data.

Squared Prediction Error Plot Shows or hides the squared prediction error (SPE) plot. 

SPE measures the sum of squared of the residuals from the PCA or PLS model. A high 

SPE value indicates an observation that deviates from the underlying correlation 

structure of the data.

Score Plot Shows or hides a score plot of principal components or partial least squares 

factors. See “Score Plot”.

Diagnose the Process (Available when at least one diagnostic plot is active.) Shows or hides 

diagnostic plots.

Show Excluded Rows Shows or hides excluded rows on plots (excluded rows shown by 

default). When this option is selected, excluded rows are displayed and included in the 

count of out of control points. However, excluded rows are excluded from numerical 

calculations. Rows that are both hidden and excluded in the data table remain hidden on 

MDMVCC plots regardless of the Show Excluded Rows setting.

Note: Control charts launched from MDMVCC show or hide excluded rows based on the 

Show Excluded Rows setting.

See Using JMP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.
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Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Plot Options

In the Model Driven Multivariate Control Chart platform, the following options apply to the 

T2, Normalized DModX, Squared Prediction Error, and Score Plots. The plots, when selected, 

appear in the Diagnosis the Process section of the report window.

Show Limit Summaries (Not available for the Score Plot.) Shows or hides control chart limits 

and summary data in a report table below the chart.

Contribution Heat Map Shows or hides a heat map that is colored by the variable 

contributions of each observation.

Contribution Proportion Heat Map Shows or hides a heat map that is colored by the variable 

contributions expressed as proportions of the overall value of each observation.

Contribution Plot for Selected Samples (Available only when one or more points are 

selected.) Shows or hides a bar chart of the individual component contributions to the 

overall value for each selected sample.

Contribution Proportion Plot for Selected Samples (Available only when one or more 

points are selected.) Shows or hides a bar chart of the individual component contributions 

expressed as proportions of contribution of the overall value for each selected sample.

Mean Contribution Proportion Plot for Selected Samples (Available only when two or 

more points are selected.) Shows or hides a bar chart of the average of the individual 

component contributions to the overall value for each selected sample.

Note: Bars are green if the value or mean value is within 3 sigma of the mean. Bars are red 

if the value or mean value is beyond 3 sigma of the mean. When control limits are specified 

in the Controls Limits column property, the bar coloring respects those limits.

The following options are available for contribution plots:

Sort Bars Enables you to sort the bars from largest to smallest contribution or from 

largest to smallest average contribution for multiple plots.
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Label Bars Enables you to label the bars by the value, the column name, or to remove 

labels (No Label).

Control Charts for Selected Items Shows a control chart for the selected columns. When 

control limits are specified in the Controls Limits column property, the individual chart 

respects those limits.

Scatterplot Matrix (Available when two or more bars are selected.) Shows a scatterplot 

matrix for the selected variables.

Remove Plot Removes the plot from the report window.

Normalized Score Plot for Selected Samples (Available only for a Score Plot when one or 

more points are selected.) Shows or hides a bar chart of normalized scores for each sample 

selected.

Score Ellipse Coverage (Available only for Score Plots with two components.) Adds an 

ellipse with the specified coverage to the score plot. The ellipse is based on historical data. 

When both Phase I and Phase II data are present, there is an ellipse for each phase and the 

Phase II ellipse is dashed.

Connect Points (Available only for Score Plots.) Connects data points in the score plot.

Show Loadings (Available only for Score Plots.) Shows the PCA loadings on the score plot 

using biplot arrows.

Save Columns For each plot there are three options to save values to the data table:

Save Values Saves values (T2, Normalized DModX, SPE, or scores) to a new data table 

column.

Save Contributions Saves contributions to new data table columns.

Save Contribution Proportions Saves contribution proportions to new data table 

columns.

Score Plot

In the Model Driven Multivariate Control Chart platform, the Score Plot displays a plot of 

principal components or partial least squares factors. Use the controls below the plot to 

change the components shown in the Score Plot.

Use the buttons to the right of the plot to assign and compare the relative contributions 

between two groups of points. Relative contributions show how two or more samples differ 

from each other. Relative contributions show what changes in the underlying process 

variables contribute to differences in groups of samples. One use is to investigate the 

differences between an in-control sample and an out-of-control sample.



374 Model Driven Multivariate Control Charts Chapter 13
Additional Examples of the Model Driven Multivariate Control Chart Platform Quality and Process Methods

Group A is the reference group and Group B the comparator group. Each group can consist of 

one or more points. To assign the reference group, select one or more points and then click 

Group A. To assign the comparator group, select one or more points and then click Group B. 

To display the Relative Score Contribution Plot, click Compare.

Figure 13.8  Score Plot with Relative Contribution Plot for Row 17 Relative to Row 24

Additional Examples of the Model Driven 
Multivariate Control Chart Platform

This section contains examples of the Model Driven Multivariate Control Chart platform.

• “Example of a Model Driven Multivariate Control Chart with Historical Data”

• “Example of a Model Driven Multivariate Control Chart with a PLS Model”

Example of a Model Driven Multivariate Control Chart with 
Historical Data

This example demonstrates the use of historical data to set the monitoring limits for current 

data.

1. Select Help > Sample Data Folder and open Quality Control/Flight Delays.jmp.

2. Select Analyze > Quality and Process > Model Driven Multivariate Control Chart.

3. Select the AA through WN and click Process.

4. Select Flight Date and click Time ID.

5. Enter 16 for Historical Data End at Row.

6. Click OK.
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Figure 13.9  T2 Chart for Historical and Current Data

Note that there are two sets of limits. One set applies to the historical data. A second set of 

limits applies to the current data. For more information about how the historical data is used 

to calculate the two sets of limits, see “Statistical Details for Limits”.

Tip: Turn on Automatic Recalc to enable the chart to automatically update as you add 

additional observations to the data table. The Automatic Recalc option is under redo when 

you click the PCA Model Driven Multivariate Control Chart red triangle.

Example of a Model Driven Multivariate Control Chart with a PLS 
Model

This example demonstrates the use of a PLS model for monitoring a multivariate process. 

Consider a process with 14 inputs and 5 quality variables. You have a PLS model that explains 

the process and you want to use this model to monitor the process for deviations.

1. Select Help > Sample Data Folder and open Polyethylene Process.jmp.

This data table contains 14 process variables and 5 quality or output variables. The first 100 

rows are historical data used to build a PLS model to describe the process. These rows are 

colored blue. The remaining 239 rows are data collected since the model was built.

The partial least squares model finds 4 score functions that describe the process. These 

functions are saved to the data table in columns X Score 1 Formula to X Score 4 Formula. To 

build the PLS model, use the table script Set current data as excluded to exclude the 239 rows 
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of data collected after the historical data. Then use the Fit Partial Least Squares table script 

to build the PLS model to relate the quality variable to the process variables.

2. Select Analyze > Quality and Process > Model Driven Multivariate Control Chart.

3. Select the X Score 1 Formula through X Score 4 Formula and click Process.

4. Set the Historical Data End at Row to 100.

5. Click OK.

Figure 13.10  T2 Chart

The blue data points represent the historical data. The black data points are data points 

collected after the control chart was established. The process experienced an upset that begins 

around sample number 326.

6. Hover over the sample data points that are above the upper control limit to view 

contribution plots.

7. Select the first cluster of data points above the upper control limit. Click the T2 for 4 

Factors red triangle and select Mean Contribution Proportion Plot for Selected Samples.

8. Click the red triangle next to T2 Mean Contribution Proportion Plot for Selected Samples 

and select Sort Bars.
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Figure 13.11  Mean Contribution Proportion Plot

Notice that the contributions plot is in terms of the PLS model input variables. It appears that 

z2 and Tmax2 are causing the process upset. Tmax2 and z2 are related. Tmax2 is a reactor 

temperature and z2 is the location of the Tmax2 temperature.

Note: The descriptions of the factors are recorded in the Notes column property.

Statistical Details for the Model Driven Multivariate 
Control Chart Platform

This section contains statistical details for the Model Driven Multivariate Control Chart 

platform.

• “Statistical Details for Monitoring Statistics”

• “Statistical Details for Limits”

• “Statistical Details for Contributions”

• “Statistical Details for Score Plot Group Comparisons”

• “Statistical Details for Score Plot Loadings”
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Statistical Details for Monitoring Statistics

This section contains computations for the monitoring statistics in the Model Driven 

Multivariate Control Chart platform.

T2

The value for each of the i observations is plotted on the T2 control chart. For historical and 

current data, the T2 values for a PCA or PLS model with k components are defined as:

where:

ti = the vector of k scores for the ith observation

Sk = the diagonal sample covariance matrix of the k scores for historical observations

For PCA models, Sk is the diagonal eigenvalue matrix.

The mean of each of the k historical score vectors is 0 when the data is centered during the data 

preprocessing step. This step occurs in PCA on correlations or covariances and in PLS with 

centering. For preprocessing options where X is not centered, the data is assumed to have 

been centered by the user, so the mean of each of the k score vectors is 0. For more information 

about Hotelling’s T2, see Montgomery (2013).

SPE

For both PCA and PLS models, the preprocessed X matrix can be decomposed as:

where Tk = (t1,...,tk) is the k dimensional score matrix and Pk = (p1,...,pk) is a matrix with the first 

k eigenvectors for PCA models or the loading matrix for PLS models. The squared prediction 

error of this PCA or PLS model is used for the SPE control chart.

The SPEi value for each of the i observations is plotted on the SPE control chart. The squared 

prediction error is defined as:

where
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ei = the residual vector for observation i

p = number of variables

DModX

The DModXi value for each of the i observations is plotted on the DModX control chart. The 

normalized distance to model (DModX) is defined as:

where

eij = the residual for observation i and variable j

df1 = p−k

df2 = (n−k−1)(p−k) if the data is centered and (n−k)(p−k) if the data is not centered

n = number of historical data observations

k = number of PCA/PLS components

p = number of variables

Note: DModXi is equal to SPEi scaled by 1/d.

Statistical Details for Limits

In the Model Driven Multivariate Control Chart platform, all data are treated as historical data 

when the number of historical rows is not specified in the launch window. See “Launch the 

Model Driven Multivariate Control Chart Platform”.

T2

The upper control limit (UCL) for historical data is based on the Beta distribution and defined 

as:

where:
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n = number of historical data observations

k = number of PCA or PLS components

 = (1−)th quantile of a Beta  distribution.

The UCL for current data is based on the F distribution and defined as:

where:

n = number of historical data observations

k = number of PCA or PLS components

F(1−; k; n−k) = (1−)th quantile of an F(k; n−k) distribution.

DModX

For PCA and PLS models, the UCL is based on the F distribution. The DModX UCL for PCA 

models is defined as:

where:

df1 = p−k

df2 = (n−k−1)(p−k) if the data is centered and (n−k)(p−k) if the data is not centered

n = number of historical data observations

k = number of PCA components

p = number of variables

F(1−; n−p−1; p−k) = (1−)th quantile of a F(n−p−1; p−k) distribution.

The DModX UCL for PLS models is defined as:

where:

 = historical sample mean of SPE
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 = historical sample variance of SPE

n = number of historical data observations

F(1−; h; nh) = (1−)th quantile of an F(h; nh) distribution.

SPE

The SPE UCL for PCA models is defined as:

where:

a = the ath eigenvalue

k = number of PCA components

z1− = (1−)th quantile of the standard normal distribution

For more information about SPE control limits for PCA models, see Jackson and Mudholkar 

(1979).

For PLS models, the UCL is based on the chi-square distribution and defined as:

where
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 = historical sample mean of SPE

 = historical sample variance of SPE

2(1−; h) = (1−)th quantile of an 2(h) distribution

The g and h parameters are estimated by the method of moments. For more information about 

SPE control limits for PLS models, see Nomikos (1995).

Statistical Details for Contributions

This section contains computations for the contribution statistics in the Model Driven 

Multivariate Control Chart platform.

 T2

The T2 contributions for a PCA or PLS model with p variables and k components are 

calculated as:

where:

ti = the vector of k scores for the ith observation

Sk = the diagonal sample covariance matrix of the k scores for historical observations. For 
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PCA models, Sk is the diagonal eigenvalue matrix.

sa = the ath diagonal element of Sk

rja = the jth element of the ath eigenvector for PCA models and the ath column of the Rk 

loading matrix for PLS models. Rk is the matrix used to relate the score matrix, Tk to the X 

matrix, such that Tk=XRk.

xij = the value of the jth variable for the ith observation.

Note: The p terms in the last sum are the variable contributions.

The contribution of each variable is the sum of its contribution to each score, weighted by the 

normalized score value. A variable is considered to have a large contribution to if there is a 

large normalized score value, and the variable contribution is large.

the contribution proportion of variable j is defined as:

Note: When computing T2 contribution proportions, JMP zeros out negative contributions. 

Negative contributions are possible due to the interaction of variables during the projection of 

X in PCA and PLS models. The negative contributions are zeroed in order to identify the 

variable contributions that represent a large proportion of the total positive contributions.

For more information about PCA contributions and negative contributions, see Kourti and 

MacGregor (1996). For more information about PLS contributions, see Li et al. (2009).

DModX

For PCA and PLS models, the contribution of variable j to DModXi is defined as:

Note that since
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the contribution proportion of variable j is defined as:

SPE

For PCA and PLS models, the contribution of variable j to SPEi is defined as:

Note that since

the contribution proportion of variable j is defined as:

Score Contributions

The score contribution computation is the same as T2 contributions but are computed only for 

the dimensions selected in the score plot.

Statistical Details for Score Plot Group Comparisons

For the score plot group comparisons in the Model Driven Multivariate Control Chart 

platform, the relative score contribution for variable j is the difference between the average 

contribution in group B and the average contribution in group A:
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where

T*i = the ith row of the score matrix with columns corresponding to the dimensions shown 

in the score plot.

A = the set of observations in group A

B = the set of observations in group B

na = the number of observations in group A

nb = the number of observations in group B.

Statistical Details for Score Plot Loadings

In the Model Driven Multivariate Control Chart platform, the loadings shown on the score 

plot are based on PCA eigenvectors or PLS X score loadings (R matrix). These loadings are 

scaled by the maximum absolute value of scores. The scaling is performed in order to graph 

the loadings on the score plot. The loadings illustrate each variable’s approximate influence on 

each score.
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Chapter 14
Legacy Control Charts

Create Variable and Attribute Control Charts

The legacy control chart platforms in JMP provide a variety of control charts, as well as runs 

charts, V-Mask CUSUM charts, and weighted moving average charts. To support process 

improvement initiatives, most of the control chart options display separate control charts for 

different phases of a project on the same chart.

A control chart is a graphical and analytic tool for monitoring process variation. The natural 

variation in a process can be quantified using a set of control limits. Control limits help 

distinguish common-cause variation from special-cause variation. Typically, action is taken to 

identify and eliminate special-cause variation. It is also important to quantify the 

common-cause variation in a process, as this determines the capability of a process.

Figure 14.1  Control Chart Example
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Overview of Legacy Control Charts

Legacy control charts are broadly classified into two categories:

• “Legacy Control Charts for Variables”— IR, XBar, Runs Chart, Levey-Jennings, 

Presummarize, CUSUM, UWMA, and EWMA.

• “Legacy Control Charts for Attributes”— P, NP, C, and U.

Legacy Control Charts for Variables

Control charts for variables are classified according to the subgroup summary statistic plotted 

on the chart:

• The IR selection provides additional chart types:

– Individual Measurement charts display individual measurements. These charts are 

appropriate when only one measurement is available for each subgroup sample.

– Moving Range charts display moving ranges of two or more successive measurements. 

See “Moving Range (Average) Charts”.

• XBar charts display subgroup means (averages). This selection provides additional chart 

types:

– R charts display subgroup ranges (maximum – minimum).

– S charts display subgroup standard deviations.

For quality characteristics measured on a continuous scale, a typical analysis shows both 

the process mean and its variability with a mean chart aligned above its corresponding R 

or S chart.

• Runs Chart displays data as a connected series of points. Runs charts can also plot the 

group means when the Sample Label role is used, either on the window or through a 

script.

• Levey-Jennings charts show a process mean with control limits based on a long-term 

sigma. The control limits are placed at 3s distance from the center line. The standard 

deviation, s, for the Levey-Jennings chart is calculated the same way standard deviation is 

in the Distribution platform.

• Presummarize charts display subgroup means and standard deviations. See 

“Presummarize Charts”.

• CUSUM charts show cumulative sums of subgroup or individual measurements from a 

target value. See “V-Mask CUSUM Control Charts”.

• UWMA charts show a uniformly weighted moving average of a specified number of 

measurements. See “Uniformly Weighted Moving Average Charts”.
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• EWMA charts show an exponentially weighted moving average of all measurements with 

a specified weight. See “Exponentially Weighted Moving Average Charts”.

Moving Range (Average) Charts

In a Moving Average chart, the quantities that are averaged can be individual observations 

instead of subgroup means. However, a Moving Average chart for individual measurements 

is not the same as a control chart for individual measurements or moving ranges with 

individual measurements plotted.

Moving Range (Average) charts display moving ranges of two or more successive 

measurements. Moving ranges are computed for the number of consecutive measurements 

that you enter in the Range Span box. The default range span is 2. Because moving ranges are 

correlated, these charts should be interpreted with care.

A Median Moving Range chart is also available. If you choose a Median Moving Range chart 

and an Individual Measurement chart, the limits on the Individual Measurement chart use the 

Median Moving Range as the sigma, rather than the Average Moving Range.

Presummarize Charts

If your data consist of repeated measurements of the same process unit, you can combine 

these into one measurement for the unit. Pre-summarizing is not recommended unless the 

data have repeated measurements on each process or measurement unit.

Presummarize summarizes the process column into sample means or standard deviations, 

based either on the sample size or sample label chosen. Then it charts the summarized data 

based on the options chosen in the launch window. You can also append a capability analysis 

by checking the appropriate box in the launch window.

The Presummarize launch window has the following options for chart types:

• Individual on Group Means

• Individual on Group Std Devs

• Moving Range on Group Means

• Moving Range on Group Std Devs

• Median Moving Range on Group Means

• Median Moving Range on Group Std Devs

There is also an option for setting the range span that is used for the moving range chart types.
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V-Mask CUSUM Control Charts

V-Mask Cumulative Sum (CUSUM) control charts show cumulative sums of subgroup or 

individual measurements from a target value. V-Mask CUSUM charts can help you decide 

whether a process is in a state of statistical control by detecting small, sustained shifts in the 

process mean. In comparison, standard Shewhart control charts can detect sudden and large 

changes in measurement, such as a two or three sigma shift, but they are less effective at 

spotting smaller changes, such as a one sigma shift.

The CUSUM menu selection has options for V-mask cumulative sum charts. In addition to 

KSigma, you also specify:

• The vertical distance h between the origin for the V-mask and the upper or lower arm of 

the V-mask for a two-sided chart. For a one-sided chart, H is the decision interval. Choose 

H as a multiple of the standard error.

• The reference value k, where k is greater than zero.

Another form of a cumulative sum control chart is the tabular CUSUM chart. To create a 

tabular CUSUM chart, see “CUSUM Control Charts”. The tabular CUSUM chart is 

recommended over the V-mask chart for a variety of reasons, including the following:

• The V-mask must be moved with each observation, not simply placed on the last 

observation.

• The cumulative sums in the V-mask procedure can end up a long way from the center of 

the graph, even for an on-target process.

Caution: Montgomery (2013) strongly “advises against using the V-mask procedure.”

Uniformly Weighted Moving Average Charts

Each point on a Uniformly Weighted Moving Average (UWMA) chart is the average of the w 

most recent subgroup means, including the present subgroup mean. When you obtain a new 

subgroup sample, the next moving average is computed by dropping the oldest of the 

previous w subgroup means and including the newest subgroup mean. The constant, w, is 

called the span of the moving average.

In addition to KSigma and Alpha, in the UWMA launch window you also specify:

• The Moving Average Span, or w, which indicates how many subgroups to include to form 

the moving average. The larger the Moving Average Span (w), the smoother the UWMA 

line, and the less it reflects the magnitude of shifts. This means that larger values of w 

guard against smaller shifts. See “Control Limits for UWMA Charts”.
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Exponentially Weighted Moving Average Charts

Each point on an Exponentially Weighted Moving Average (EWMA) chart is the weighted 

average of all the previous subgroup means, including the mean of the present subgroup 

sample. The weights decrease exponentially going backward in time.

Note: An Exponentially Weighted Moving Average (EWMA) chart can also be called a 

Geometric Moving Average (GMA) chart.

In addition to KSigma and Alpha, in the EWMA launch window you also specify:

• A Weight parameter, which is the weight (0 < weight ≤ 1) assigned to the present subgroup 

sample mean. Small values of Weight are used to guard against small shifts. See “Control 

Limits for EWMA Charts”.

Tip: See “EWMA Control Charts” for the newer EWMA Control Charts platform.

Legacy Control Charts for Attributes

Attribute charts are used for discrete count data because they are based on binomial and 

Poisson models. Count data occur when the variable of interest is a discrete count of 

something, such as the number of defects or blemishes per subgroup. This is in contrast with 

the previous types of charts, where measurement data consist of a process variable that is 

often continuous.

Because the counts are measured per subgroup, it is important when comparing charts to 

determine whether you have a similar number of items in the subgroups between the charts. 

Attribute charts, like variables charts, are classified according to the subgroup sample statistic 

plotted on the chart.

Determining Which Attribute Chart to Use

Each item is judged as either conforming or non-conforming:

p-chart Shows the proportion of defective items.

np-chart Shows the number of defective items.

The number of defects is counted for each item:

c-chart Shows the number of defects.

u-chart Shows the proportion of defects.
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For attribute charts, specify the column containing the defect count or defective proportion as 

the Process variable. The data are interpreted as counts, unless the column contains 

non-integer values between 0 and 1.

• P charts display the proportion of nonconforming (defective) items in subgroup samples, 

which can vary in size. Since each subgroup for a P chart consists of Ni items, and an item 

is judged as either conforming or nonconforming, the maximum number of 

nonconforming items in a subgroup is Ni.

• NP charts display the number of nonconforming (defective) items in subgroup samples. 

Because each subgroup for an NP chart consists of Ni items, and an item is judged as either 

conforming or nonconforming, the maximum number of nonconforming items in 

subgroup i is Ni.

Note: To use the Sigma column property for P or NP charts, the value needs to be equal to 

the proportion. JMP calculates the sigma as a function of the proportion and the sample 

sizes.

• C charts display the number of nonconformities (defects) in a subgroup sample that 

usually, but does not necessarily, consists of one inspection unit.

Caution: For a C chart, if you do not specify a Sample Size or Constant Size, then the 

Sample Label is used as the sample size.

• U charts display the proportion of nonconformities (defects) in each subgroup sample that 

can have a varying number of inspection units.

Caution: For a U chart, if you do not specify a Unit Size or Constant Size, then the Sample 

Label is used as the unit size.

Example of a Legacy Control Chart

In this example, create XBar and R charts that have a subgroup sample size of four.

1. Select Help > Sample Data Folder and open Quality Control/Coating.jmp.

2. Select Analyze > Quality And Process > Legacy Control Charts > XBar.

Note the selected chart types of XBar and R.

3. Select Weight and click Process.

4. Select Sample and click Sample Label.

5. Click OK.
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Figure 14.2  Variables Charts for Coating Data

An XBar chart and an R chart for the process are shown in Figure 14.2. Sample six indicates 

that the process is not in statistical control. To check the sample values, click the sample six 

summary point on either control chart. The corresponding rows highlight in the data table.

Note: If an S chart is chosen with the XBar chart, then the limits for the XBar chart are based 

on the standard deviation. Otherwise, the limits for the XBar chart are based on the range.

Launch a Legacy Control Chart Platform

When you launch a legacy control chart platform by selecting Analyze > Quality And Process 
> Legacy Control Charts, a launch window similar to Figure 14.3 appears. The specific 

controls vary depending on which type of chart you select. Initially, the window shows the 

following types of information:

• “Process Information” for measurement variable selection

• Chart type information (for more information, see “Overview of Legacy Control Charts”)

{
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• “Limits Specifications”

• “Specified Statistics”

Figure 14.3  XBar Control Chart Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Process Information

The launch window for a legacy control chart displays a list of columns in the current data 

table. Here, you specify the variables to be analyzed and the subgroup sample size.

Process

The Process role selects variables for charting:

• For variables charts, specify measurements as the process.

• For attribute charts, specify the defect count or defective proportion as the process. The 

data are interpreted as counts, unless it contains non-integer values between 0 and 1.

Note: The rows of the data table must be sorted in the order in which the observations were 

collected. Even if there is a Sample Label variable specified, you still must sort the 

observations accordingly.

limits 
specification

process information

add capability analysis 
to the report

enter or remove 
known statistics

chart type 
information
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Sample Label

The Sample Label role enables you to specify a variable whose values label the horizontal axis 

and can also identify unequal subgroup sizes. If you do not specify a sample label variable, the 

samples are identified by their subgroup sample number.

• If the sample subgroups are the same size, select the Sample Size Constant option and 

enter the size in the text box. If you entered a Sample Label variable, its values are used to 

label the horizontal axis. The sample size is used in the calculation of the limits regardless 

of whether the samples have missing values.

• If the sample subgroups have an unequal number of rows or have missing values and you 

have a column identifying each sample, select the Sample Grouped by Sample Label 
option and enter the sample identifying column as the sample label.

For attribute charts (P, NP, C, and U charts), this variable is the subgroup sample size. 

Additional options appear on the launch window, including Sample Size, Constant Size, or 

Unit Size, depending on your selection. In variables charts, it identifies the sample. When the 

chart type is IR, a Range Span text box appears. The range span specifies the number of 

consecutive measurements from which the moving ranges are computed.

Notes:

• The rows of the data table must be sorted in the order in which the observations were 

collected. Even if there is a Sample Label variable specified, you still must sort the 

observations accordingly.

• The non-integer part of the value for Constant Size is truncated. If you have a constant 

non-integer subgroup sample size, you must specify a column of constant values.
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The illustration in Figure 14.4 shows an XBar chart for a process with unequal subgroup 

sample sizes, using the Coating.jmp sample data from the Quality Control sample data folder.

Figure 14.4  Variables Charts with Unequal Subgroup Sample Sizes

Phase

The Phase role enables you to specify a column identifying different phases, or sections. A 

phase is a group of consecutive observations in the data table. For example, phases might 

correspond to time periods during which a new process is brought into production and then 

put through successive changes. Phases generate, for each level of the specified Phase 

variable, a new sigma, set of limits, zones, and resulting tests.

On the window for XBar, R, S, IR, P, NP, C, U, Presummarize, and Levey-Jennings charts, a 

Phase variable button appears. If a phase variable is specified, the phase variable is examined, 

row by row, to identify to which phase each row belongs. Saving to a limits file reveals the 

sigma and specific limits calculated for each phase.

By

The By role identifies a variable to produce a separate analysis for each value that appears in 

the column.



398 Legacy Control Charts Chapter 14
Launch a Legacy Control Chart Platform Quality and Process Methods

Limits Specifications

There are several ways to set limits specifications for legacy control charts. You can specify 

computations for control limits by entering a value for k (K Sigma), or by entering a 

probability for  (Alpha), or by retrieving a limits value from the process columnsʹ properties 

or a previously created Limits Table. Limits Tables and the Get Limits button are discussed in 

the section “Saving and Retrieving Limits”. There must be a specification of either K Sigma or 

Alpha. The window default for K Sigma is 3.

KSigma

The KSigma parameter option enables specification of control limits in terms of a multiple of 

the sample standard error. KSigma specifies control limits at k sample standard errors above 

and below the expected value, which shows as the center line. To specify k, the number of 

sigmas, click the radio button for KSigma and enter a positive k value into the text box. The 

usual choice for k is 3, which is three standard deviations. The examples shown in Figure 14.5 

compare the XBar chart for the Coating.jmp data with control lines drawn with KSigma = 3 

and KSigma = 4.

Figure 14.5  K Sigma =3 (left) and K Sigma=4 (right) Control Limits

Alpha

The Alpha parameter option specifies control limits (also called probability limits) in terms of 

the probability  that a single subgroup statistic exceeds its control limits, assuming that the 

process is in control. To specify alpha, click the Alpha radio button and enter the desired 

probability. Reasonable choices for  are 0.01 or 0.001. For XBar charts under the assumption 

of normality and known in-control parameters, the Alpha value equivalent to a KSigma of 3 is 

0.0027.
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Specified Statistics

After specifying a process variable, if you click the Specify Stats (when available) button on a 

legacy control chart launch window, a tab with editable fields is appended to the bottom of the 

window. This lets you enter historical statistics (that is, statistics obtained from historical data) 

for the process variable. The Control Chart platform uses those entries to construct control 

charts. The example here shows 1 as the standard deviation of the process variable and 20 as 

the mean measurement.

Figure 14.6  Example of Specify Stats

Note: When the mean is user-specified, it is labeled in the plot as 0.

If you check the Capability option on a Control Chart launch window (Figure 14.3), a window 

appears as the platform is launched asking for specification limits. The standard deviation for 

the control chart selected is sent to the window and appears as a Specified Sigma value, which 

is the default option. After entering the specification limits and clicking OK, capability output 

appears in the same window next to the control chart. For information about how the 

capability indices are computed, see “Statistical Details for Capability Indices for Normal 

Distributions”.
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Legacy Control Chart Reports

The legacy control chart analysis produces a chart that can be used to determine whether a 

process is in a state of statistical control. The report varies depending on the type of chart that 

you select. Figure 14.7 displays the parts of a simple control chart. Control charts update 

dynamically as data is added or changed in the data table.

Figure 14.7  Example of a Control Chart

Note: Any rows that are excluded in the data table prior to the creation of a Runs chart are 

hidden in the Runs chart.

Control charts have the following characteristics:

• Each point plotted on the chart represents an individual process measurement or 

summary statistic. In Figure 14.7, the points represent the average for a sample of 

measurements.

Subgroups should be chosen rationally, that is, they should be chosen to maximize the 

probability of seeing a true process change between subgroups. Often, this requires 

knowledge of the process to determine the most effective grouping strategy. See Wheeler 

(2004); Woodall and Adams (1998).

• The vertical axis of a control chart is scaled in the same units as the summary statistic.

• The horizontal axis of a control chart identifies the subgroup samples and is time ordered. 

Observing the process over time is important in assessing if the process is changing.

• The green line is the center line, or the average of the data. The center line indicates the 

average (expected) value of the summary statistic when the process is in statistical control. 

Measurements should appear equally on both sides of the center line. If not, this is 

possible evidence that the process average is changing.

• The two red lines are the upper and lower control limits, labeled UCL and LCL. These 

limits give the range of variation to be expected in the summary statistic when the process 

is in statistical control. If the process is exhibiting only routine variation, then all the points 

Subgroup Sample Axis

LCL

Center Line

UCL

Out of Control Point

Measurement 
Axis
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should fall randomly in that range. In Figure 14.7, one measurement is above the upper 

control limit. This is evidence that the measurement could have been influenced by a 

special cause, or is possibly a defect.

• A point outside the control limits (or the V-mask of a CUSUM chart) signals the presence 

of a special cause of variation.

Options within each platform create control charts that can be updated dynamically as 

samples are received and recorded or added to the data table.

When a control chart signals abnormal variation, action should be taken to return the process 

to a state of statistical control if the process degraded. If the abnormal variation indicates an 

improvement in the process, the causes of the variation should be studied and implemented.

When you double-click the horizontal or vertical axis, the appropriate Axis Specification 

window appears for you to specify the format, axis values, number of ticks, gridline, reference 

lines, and other options to display on the axis.

For example, the Pickles.jmp data lists measurements taken each day for three days. In 

Figure 14.8, by default, the horizontal axis is labeled at every other tick. Sometimes this gives 

redundant labels, as shown to the left in Figure 14.8. If you specify a label at an increment of 

eight, the horizontal axis is labeled once for each day, as shown in the chart on the right.

Figure 14.8  Example of Labeled x Axis Tick Marks

Tip: For information about warnings and rules, see “Tests” and “Westgard Rules”.
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V-Mask CUSUM Chart Reports

This section describes how to interpret V-Mask CUSUM charts and legacy one-sided CUSUM 

charts.

• “Interpret a Two-Sided V-Mask CUSUM Chart”

• “Interpret a Legacy One-Sided CUSUM Chart”

Interpret a Two-Sided V-Mask CUSUM Chart

To interpret a two-sided CUSUM chart, compare the points with limits that compose a 

V-mask. A V-mask is a shape in the form of a V on its side that is superimposed on the graph 

of the cumulative sums. The V-mask is formed by plotting V-shaped limits. The origin of a 

V-mask is the most recently plotted point, and the arms extended backward on the horizontal 

axis, as in Figure 14.9. As data are collected, the cumulative sum sequence is updated and the 

origin is relocated at the newest point.

Note: See also “Example of a V-Mask CUSUM Chart”.

Figure 14.9  V-Mask for a Two-Sided CUSUM Chart

d h, the rise in the arm 

corresponding to the distance (d) 
from origin to vertex

k, the rise in the arm 
corresponding to one 
sampling unit

upper arm vertex

1 unit

lower 
arm
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Shifts in the process mean are visually easy to detect on a CUSUM chart because they produce 

a change in the slope of the plotted points. The point where the slope changes is the point 

where the shift occurs. A condition is out-of-control if one or more of the points previously 

plotted crosses the upper or lower arm of the V-mask. Points crossing the lower arm signal an 

increasing process mean, and points crossing the upper arm signal a downward shift.

There are important differences between CUSUM charts and Shewhart charts:

• A Shewhart control chart plots points based on information from a single subgroup 

sample. In CUSUM charts, each point is based on information from all samples taken up to 

and including the current subgroup.

• On a Shewhart control chart, horizontal control limits define whether a point signals an 

out-of-control condition. On a CUSUM chart, the limits can be either in the form of a 

V-mask or a horizontal decision interval.

• The control limits on a Shewhart control chart are commonly specified as 3 limits. On a 

CUSUM chart, the limits are determined from average run length.

A CUSUM chart is more efficient for detecting small shifts in the process mean. Lucas (1976) 

states that a V-mask detects a 1 shift about four times as fast as a Shewhart control chart.

Interpret a Legacy One-Sided CUSUM Chart

Use a one-sided CUSUM chart to identify data approaching or exceeding the side of interest.

Figure 14.10  Example of a One-Sided CUSUM Chart

The decision interval or horizontal line is set at the H value that you entered in the launch 

window. In this example, it is 0.25. Any values exceeding the decision interval of 0.25 indicate 

a shift or out-of-control condition. In this example, observation 4 appears to be where a shift 

occurred. Also note that no V-mask appears for one-sided CUSUM charts.
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Legacy Control Chart Platform Options

Legacy control charts have red triangle menus that affect various parts of the platform:

• The menu on the top-most title bar affects the whole platform window. Its items vary with 

the type of chart that you select. See “Window Options for Legacy Control Charts”.

• There is a menu of items on the chart type title bar with options that affect each chart 

individually. See “Chart Options for Legacy Control Charts”.

Window Options for Legacy Control Charts

The red triangle menu on the window title bar lists options that affect the report window. If 

you request XBar and R at the same time, you can check each chart type to show or hide it. The 

specific options that are available depend on the type of control chart you request. 

Unavailable options show as grayed menu items.

Show Limits Legend Shows or hides the Avg, UCL, and LCL values to the right of the chart.

Connect Through Missing Connects points when some samples have missing values. In 

Figure 14.11, the left chart has no missing points. The middle chart has samples 2, 11, 19, 

and 27 missing with the points not connected. The right chart appears if you select the 

Connect Through Missing option, which is the default.

Figure 14.11  Example of Connected through Missing Option

Use Median For Runs Charts, when you select the Show Center Line option in the 

individual Runs Chart red triangle menu, a line is drawn through the center value of the 

column. The center line is determined by the Use Median setting of the main Runs Chart 

red triangle menu. When Use Median is selected, the median is used as the center line. 

Otherwise, the mean is used. When saving limits to a file, both the overall mean and 

median are saved.

No missing points Missing points are not connected Missing points are connected
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Capability (Not available when a Phase variable is specified.) Performs a Capability Analysis 

for your data. A pop-up window is first shown, where you can enter the Lower Spec Limit, 

Target, and Upper Spec Limit values for the process variable.

Figure 14.12  Capability Analysis Window

An example of a capability analysis report is shown in Figure 14.13 for Coating.jmp when the 

Lower Spec Limit is set as 16.5, the Target is set to 21.5, and the Upper Spec Limit is set to 23.

Figure 14.13  Capability Analysis Report for Coating.jmp

For additional information, see “Statistical Details for Capability Analysis”.

Save Sigma Saves the computed value of sigma as a column property in the process variable 

column in the JMP data table.

Save Limits Saves the control limits in one of the following ways:
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in Column Saves control limits as a column property in the existing data table for the 

response variable. If the limits are constant, LCL, Avg, and UCL values for each chart 

type in the report are saved. This option is not available with phase charts. In addition, 

the option has no effect if the sample sizes are not constant for each chart.

in New Table Saves the standard deviation and mean for each chart into a new data 

table. If the limits are constant, the LCL, Avg, and UCL for each chart are saved as well. 

If there are phases, a new set of values is saved for each phase. You can use this data 

table to use the limits later. In the Control Chart launch window, click Get Limits and 

then select the saved data table. See the section “Saving and Retrieving Limits”.

Save Summaries Creates a new data table that contains the sample label, sample sizes, the 

statistic being plotted, the center line, and the control limits. The specific statistics included 

in the table depend on the type of chart.

Alarm Script Enables you to write and run a script that indicates when the data fail special 

causes tests. Results can be written to the log or spoken. See “Tests” of this guide. See the 

Scripting Guide for more information about writing custom Alarm Scripts.

See Using JMP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Chart Options for Legacy Control Charts

The red triangle menu of chart options appears when you click the icon next to the chart 

name. Some options are also available under Chart Options when you right-click the chart. 

Not all of the options below are available for all control chart types.

Box Plots Superimposes box plots on the subgroup means plotted in a Mean chart. The box 

plot shows the subgroup maximum, minimum, 75th percentile, 25th percentile, and 

median. Markers for subgroup means show unless you deselect the Show Points option. 

The control limits displayed apply only to the subgroup mean. The Box Plots option is 
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available only for  charts. It is most appropriate for larger subgroup sample sizes (more 

than 10 samples in a subgroup).

Needle Connects plotted points to the center line with a vertical line segment.

Connect Points Shows or hides the line that connects the data points.

Show Points Shows or hides the points representing summary statistics. Initially, the points 

show. You can use this option to suppress the markers denoting subgroup means when 

the Box Plots option is in effect.

Connect Color Displays the JMP color palette for you to choose the color of the line 

segments used to connect points.

Center Line Color Displays the JMP color palette for you to choose the color of the line 

segments used to draw the center line.

Limits Color Displays the JMP color palette for you to choose the color of the line segments 

used in the upper and lower limits lines.

Line Width Enables you to select the width of the control lines. Options are Thin, Medium, or 

Thick.

Point Marker Enables you to select the marker used on the chart.

Show Center Line Shows or hides the center line in the control chart.

Show Control Limits Shows or hides the chart control limits and their legends.

Limits Precision Sets the decimal limit for labels.

Tests Shows a submenu that enables you to choose which tests to mark on the chart when 

the test is positive. Tests apply only for charts whose limits are 3 limits. Tests 1 to 4 apply 

to Mean, Individual, and attribute charts. Tests 5 to 8 apply to Mean charts, Presummarize, 

and Individual Measurement charts only. If tests do not apply to a chart, the Tests option is 

dimmed. When sample sizes are unequal, the Test options are grayed out. If the samples 

change while the chart is open and they become equally sized, and the zone or test option 

is selected, the zones or tests are applied immediately and appear on the chart. These 

special tests are also referred to as the Western Electric Rules. For more information about 

special causes tests, see “Tests”.

Westgard Rules Westgard rules are control rules that help you decide whether a process is 

in or out of control. The different tests are abbreviated with the decision rule for the 

particular test. See the text and chart in “Westgard Rules”.

Test Beyond Limits Flags as a “*” any point that is beyond the limits. This test works on all 

charts with limits, regardless of the sample size being constant, and regardless of the size 

X
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of k or the width of the limits. For example, if you had unequal sample sizes, and wanted 

to flag any points beyond the limits of an R chart, you could use this command.

Show Zones Shows or hides the zone lines. The zones are labeled A, B, and C as shown here 

in the Mean plot for weight in the Coating.jmp sample data. Control Chart tests use the 

zone lines as boundaries. The seven zone lines are set one sigma apart, centered on the 

center line.

Figure 14.14  Show Zones

Shade Zones Shows or hides the default green, yellow, and red colors for the three zone 

areas and the area outside the zones. Green represents the area one sigma from the center 

line, yellow represents the area two and three sigmas from the center line, and red 

represents the area beyond three sigmas. Shades can be shown with or without the zone 

lines.

Tip: To change the colors used to shade the zones, right-click in the control chart and select 

Customize. In the Customize Graph window, you can specify colors for each of the three 

zones.

Figure 14.15  Shade Zones
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OC Curve (Available when subgroup sizes are equal.) Opens a new window that contains 

the operating characteristic (OC) curve, using all the calculated values directly from the 

active control chart. See “Operating Characteristic Curves”.

Chart Options for V-Mask CUSUM Control Charts

The following options are specific to the legacy CUSUM control chart red triangle menu.

Mask Color (Available only when the Show V Mask option is selected.) Enables you to select 

a line color for the V-mask.

Show Shift Shows or hides the shift that you entered in the launch window.

Show V Mask Shows or hides the V-mask based on the statistics that you specified in the 

CUSUM Control Charts launch window.

Show Parameters Shows or hides a report that summarizes the CUSUM charting 

parameters.

Show ARL Shows or hides the average run length (ARL) information. The average run 

length is the expected number of samples taken before an out-of-control condition is 

signaled:

– ARL (Delta), sometimes denoted ARL1, is the average run length for detecting a shift in 

the size of the specified Delta.

– ARL(0), sometimes denoted ARL0, is the in-control average run length for the specified 

parameters (Montgomery 2013).

Saving and Retrieving Limits

You can use the following previously established control limits for legacy control charts:

• upper and lower control limits and a center line value

• parameters for computing limits, such as a mean and standard deviation

The control limits or limit parameter values must be either in a JMP data table, referred to as 

the Limits Table, or stored as a column property in the process column. When you specify the 

Control Chart command, you can retrieve the Limits Table with the Get Limits button on the 

Control Chart launch window.

Tip: To add specification limits to several columns at once, see “Manage Limits”.
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The easiest way to create a Limits Table is to save results computed by the Control Chart 

platform. The Save Limits command in the red triangle menu for each control chart 

automatically saves limits from the sample values. The type of data saved in the table varies 

according to the type of control chart in the analysis window. You can also use values from 

any source and create your own Limits Table.

All Limits Tables must have:

• A column of special keywords that identify each row.

• A column for each of the variables whose values are the known standard parameters or 

limits. This column name must be the same as the corresponding process variable name in 

the data table to be analyzed by the Control Chart platform.

The following table describes the limit keywords and their associated control chart for both 

legacy control charts and charts created with Control Chart Builder.

Table 14.1  Limits Table Keys with Appropriate Charts and Meanings

Keywords For Charts Meaning

_KSigma All except Control Chart 

Builder and V-Mask 

CUSUM

multiples of the standard deviation of 

the statistics to calculate the control 

limits; set to missing if the limits are 

in terms of the alpha level

_Alpha All except Control Chart 

Builder

Type I error probability used to 

calculate the control limits

_Range Span IM, MR, MMR number of consecutive measurements 

for which moving ranges are 

computed. Not applicable in the 

Control Chart Builder platform, 

where the range span is always equal 

to 2.

_Sample Size All except 

Levey-Jennings and 

Presummarize

subgroup size

_Std Dev XBar, R, S, IM, MR, G, T, 

V-Mask CUSUM, and 

Levey-Jennings

known process standard deviation

_U C, U known average number of 

nonconformities per unit
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_P NP, P known value of average proportion 

nonconforming

_LCL, _UCL XBar, IM, P, NP, C, U, G, 

T, and Levey-Jennings

lower and upper control limit for 

Mean Chart, Individual Measurement 

chart, or any attribute or rare event 

chart

_AvgR R, MR average range or average moving 

range

_LCLR, _UCLR R, MR lower control limit for R or MR chart

upper control limit for R or MR chart

_AvgS, _LCLS, _UCLS S Chart average standard deviation, upper 

and lower control limits for S chart

_AvgR_PreMeans

_AvgR_PreStdDev

_LCLR_PreMeans

_LCLR_PreStdDev

_UCLR_PreMeans

_UCLR_PreStdDev

_Avg_PreMeans

_Avg_PreStdDev

_LCL_PreMeans

_LCL_PreStdDev

_UCL_PreMeans

_UCL_PreStdDev

IM, MR Mean, upper, and lower control limits 

based on pre-summarized group 

means or standard deviations.

_Data Units

_Two Sided

_Headstart

_Beta

_Delta

V-Mask CUSUM specifications for V-Mask CUSUM 

chart

Table 14.1  Limits Table Keys with Appropriate Charts and Meanings (Continued)

Keywords For Charts Meaning
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You can save limits in a new data table or as properties of the response column. When you 

save control limits using the in New Table command, the limit keywords written to the table 

depend on the current chart types displayed.

Figure 14.16 shows examples of control limits saved to a data table using Coating.jmp. The 

rows with values _Mean, _LCL, and _UCL are for the Individual Measurement chart. The 

values with the R suffix (_AvgR, _LCLR, and _UCLR) are for the Moving Range chart. If you 

create these charts again using this Limits Table, the Control Chart platform identifies the 

appropriate limits from keywords in the _LimitsKey column.

Figure 14.16  Example of Saving Limits in a Data Table

Note that values for _KSigma,  _Alpha, and _Range Span can be specified in the Control Chart 

Launch window. JMP always looks at the values from the window first. Values specified in the 

window take precedence over those in an active Limits Table.

Rows with unknown keywords and rows marked with the excluded row state are ignored. 

Except for _Range Span, _KSigma, _Alpha, and _Sample Size, any needed values not specified 

are estimated from the data.
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Excluded, Hidden, and Deleted Samples

The following table summarizes the effects of various conditions on samples and subgroups 

in legacy control charts:

Table 14.2  Excluded, Hidden, and Deleted Samples

All rows of the sample are 

excluded before creating the chart.

Sample is not included in the calculation of the limits, 

but it appears on the graph.

Sample is excluded after creating 

the chart.

Sample is included in the calculation of the limits, 

and it appears in the graph. Nothing changes on the 

output by excluding a sample with the graph open.

Sample is hidden before creating 

the chart.

Sample is included in the calculation of the limits, but 

does not appear on the graph.

Sample is hidden after creating the 

chart.

Sample is included in the calculation of the limits, but 

does not appear on the graph. The sample marker 

disappears from the graph, the sample label still 

appears on the axis, but limits remain the same.

All rows of the sample are both 

excluded and hidden before 

creating the chart.

Sample is not included in the calculation of the limits, 

and it does not appear on the graph.

All rows of the sample are both 

excluded and hidden after creating 

the chart.

Sample is included in the calculation of the limits, but 

does not appear on the graph. The sample marker 

disappears from the graph, the sample label still 

appears on the axis, but limits remain the same.

Data set is subsetted with Sample 

deleted before creating chart.

Sample is not included in the calculation of the limits, 

the axis does not include a value for the sample, and 

the sample marker does not appear on the graph.

Data set is subsetted with Sample 

deleted after creating chart.

Sample is not included in the calculation of the limits, 

and does not appear on the graph. The sample 

marker disappears from the graph, the sample label 

is removed from the axis, the graph shifts, and the 

limits change.



414 Legacy Control Charts Chapter 14
Additional Examples of Legacy Control Charts Quality and Process Methods

Some additional notes:

• Hide and Exclude operate only on the row state of the first observation in the sample. For 

example, if the second observation in the sample is hidden, but the first observation is not 

hidden, the sample still appears on the chart.

Note: Excluded rows in Presummarize charts are excluded from calculations, regardless 

of which position they are within a sample.

• An exception to the exclude/hide rule: Both hidden and excluded rows are included in the 

count of points for Tests for Special Causes. An excluded row can be labeled with a special 

cause flag. A hidden point cannot be labeled. If the flag for a Tests for Special Causes is on 

a hidden point, it will not appear in the chart.

• Because of the specific rules in place (Table 14.2), the control charts do not support the 

Automatic Recalc script.

Additional Examples of Legacy Control Charts

This section contains examples using legacy control charts.

• “Example of Presummarized Charts”

• “Example of a V-Mask CUSUM Chart”

• “Example of a One-Sided CUSUM Chart”

• “Example of a UWMA Chart”

Example of Presummarized Charts

This examples creates presummarized charts in two different ways using legacy control 

charts.

Direct Presummarized Charts

You can create presummarized charts directly by using the legacy Presummarize launch 

window.

1. Select Help > Sample Data Folder and open Quality Control/Coating.jmp.

2. Select Analyze > Quality and Process > Legacy Control Charts > Presummarize.

3. Select Weight and click Process.

4. Select Sample and click Sample Label.
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5. Select both Individual on Group Means and Moving Range on Group Means. The Sample 
Grouped by Sample Label button is automatically selected when you choose a Sample 

Label variable.

When using Presummarize charts, you can select either the On Group Means option or the 

On Group Std Devs option or both. Each option creates two charts (an Individual 

Measurement, also known as an X chart, and a Moving Range chart) if both IR chart types 

are selected.

The On Group Means option computes each sample mean and then plots the means and 

creates an Individual Measurement and a Moving Range chart on the means.

The On Group Std Devs option computes each sample standard deviation and plots the 

standard deviations as individual points. Individual Measurement and Moving Range 

charts for the standard deviations then appear.

6. Click OK.

Figure 14.17  Example of Charting Presummarized Data

Although the points for XBar and S charts are the same as the Individual on Group Means 

and Individual on Group Std Devs charts, the limits are different because they are 

computed as Individual charts.
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Indirect Presummarized Charts

You can also create presummarized charts indirectly by manually creating a summary table 

and then launching a legacy IR chart.

1. Choose Tables > Summary.

2. Select Sample and click Group.

3. Select Weight, and then click Statistics > Mean and Statistics > Std Dev.

4. Click OK.

5. Select Analyze > Quality and Process > Legacy Control Charts > IR.

6. Select Mean(Weight) and Std Dev(Weight) and click Process.

7. Click OK.

The resulting charts match the presummarized charts.

Example of a V-Mask CUSUM Chart

Use the legacy CUSUM option to create a V-Mask CUSUM control chart to analyze the filling 

process of 8-ounce cans of two-cycle engine oil additive by a machine. The filling process is 

believed to be in statistical control. The process is set so that the average weight of a filled can 

(0) is 8.10 ounces. Previous analysis shows that the standard deviation of fill weights (0) is 

0.05 ounces.

Subgroup samples of four cans are selected and weighed every hour for twelve hours. Each 

observation contains one value of weight and its associated value of hour. The observations 

are sorted so that the values of hour are in increasing order.

1. Select Help > Sample Data Folder and open Quality Control/Oil1 Cusum.jmp.

2. Select Analyze > Quality And Process > Legacy Control Charts > CUSUM.

3. Select weight and click Process.

4. Select hour and click Sample Label.

5. Select the Two Sided check box if it is not already checked.

6. In the Parameters area, click the H button and type 2.

7. Click Specify Stats.

8. Type 8.1 next to Target.

8.1 is the average weight in ounces of a filled can. This is the target mean.

9. Type 1 next to Delta.

1 is the absolute value of the smallest shift to be detected as a multiple of the process 

standard deviation or of the standard error.
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10. Type 0.05 next to Sigma.

0.05 is the known standard deviation of fill weights (0) in ounces.

Figure 14.18  Completed Launch Window

11. Click OK.

Figure 14.19  Two-Sided CUSUM Chart for Oil1 Cusum.jmp Data

You can interpret the chart by comparing the points with the V-mask. The right edge of the 

V-mask is centered at the most recent point (the 12th hour). Because none of the points cross 

the arms of the V-mask, there is no evidence that a shift in the process has occurred. See 

“V-Mask CUSUM Chart Reports”.
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Example of a One-Sided CUSUM Chart

Use the legacy CUSUM option to create a one-sided CUSUM control chart to identify any 

instances of over-filling in a process where a machine fills 8-ounce cans of engine oil. 

Anything that is 0.25 ounces beyond the mean of 8.1 is considered a problem. In order to cut 

costs, the manufacturer is primarily concerned about significant over-filling and not so 

concerned about under-filling.

1. Select Help > Sample Data Folder and open Quality Control/Oil1 Cusum.jmp.

2. Select Analyze > Quality And Process > Legacy Control Charts > CUSUM.

3. Deselect Two Sided.

4. Select weight and click Process.

5. Select hour and click Sample Label.

6. Click H and type 0.25.

7. Click Specify Stats.

8. Type 8.1 next to Target.

8.1 is the average weight in ounces of a filled can. This is the target mean.

9. Type 1 next to Delta.

1 is the absolute value of the smallest shift to be detected as a multiple of the process 

standard deviation or of the standard error.

10. Type 0.05 next to Sigma.

0.05 is the known standard deviation of fill weights (0) in ounces.

11. Click OK.

Figure 14.20  One-Sided CUSUM Chart for Oil1 Cusum.jmp Data
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The decision interval is set at the H value that you entered (0.25). You can see that at the fourth 

hour, some significant over-filling occurred.

Example of a UWMA Chart

In this example, a legacy UWMA control chart with a moving average span of three is 

examined. The measure of interest is the gap between the ends of manufactured metal clips. 

To monitor the process for a change in the average gap, subgroup samples of five clips are 

selected daily.

1. Select Help > Sample Data Folder and open Quality Control/Clips1.jmp.

2. Select Analyze > Quality and Process > Legacy Control Charts > UWMA.

3. Select Gap and click Process.

4. Select Sample and click Sample Label.

5. Change the Moving Average Span to 3.

6. Click OK.

Figure 14.21  UWMA Charts for the Clips1 data

The point for the first day is the mean of the five subgroup sample values for that day. The 

plotted point for the second day is the average of subgroup sample means for the first and 

second days. The points for the remaining days are the average of subsample means for each 

day and the two previous days.

The average clip gap appears to be decreasing, but no sample point falls outside the 3 limits.
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Statistical Details for Legacy Control Charts

This section contains statistical details for legacy control charts.

• “Statistical Details for Median Moving Range Charts”

• “Statistical Details for Capability Analysis”

• “Statistical Details for V-Mask CUSUM Control Charts”

• “Statistical Details for Weighted Moving Average Charts”

Note: For more information about other types of charts (such as XBar and R charts, P and NP 

charts, and more) see the “Statistical Details for Control Chart Builder”.

Statistical Details for Median Moving Range Charts

Control limits for legacy Median Moving Range charts are computed as follows:

LCLMMR = max(0, MMR - kd3(n) )

UCLMMR = MMR + kd3(n)

where:

MMR is the median of the nonmissing moving ranges.

 = MMR/0.954

d3(n) is the standard deviation of the range of n independent normally distributed 

variables with unit standard deviation.

Statistical Details for Capability Analysis

This section contains details about the computation of the statistics in the Capability Analysis 

report in legacy control charts.

Variation Statistics

All capability analyses use the same formulas. Options differ in how sigma ()is computed:

Long Term Sigma Uses the overall sigma. This option is used for Ppk statistics, and computes 

sigma as follows:

̂

̂

̂
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Note: By default, the capability indices in the Long Term Sigma report use the Cp labeling 

that is used in the other sigma reports. To use Ppk labeling in the Long Term Sigma report, 

select the File > Preferences > Platforms > Distribution > PpK Capability Labeling 

preference.

Control Chart Sigma Uses a sigma that is determined by the control chart settings.

– If you specify a value for Sigma using the Specify Stats button in the control launch 

window, the specified value is used for computing capability indices.

– In an IR chart that uses the Moving Range (Average) option, the value for sigma is 

computed as follows:

where:

 is the average of the moving ranges.

d2(n) is the expected value of the range of n independent normally distributed 

variables with unit standard deviation, where n is the value of the Range Span 
option.

– In an IR chart that uses the Median Moving Range option, the value for sigma is 

computed as follows:

where:

MMR is the median of the nonmissing moving ranges.

d4(n) is the median of the range of n independent normally distributed variables 

with unit standard deviation, where n is the value of the Range Span option.

– In an XBar chart that uses the R option, the value for sigma is computed as follows:

̂
xi x– 

2

n 1–
---------------------

i 1=

n

=

̂ R
d2 n 
--------------=

R

̂ MMR
d4 n 
----------------=

̂

R1

d2 n1 
----------------- 

RN

d2 nN 
------------------+ +

N
-------------------------------------------------------=
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where:

Ri = range of ith subgroup

ni = sample size of ith subgroup

d2(ni) = expected value of the range of ni independent normally distributed variables 

with unit standard deviation

N = number of subgroups for which ni ≥ 2

– In an XBar chart that uses the S option, the value for sigma is computed as follows:

where:

ni = sample size of ith subgroup

c4(ni) = expected value of the standard deviation of ni independent normally 

distributed variables with unit standard deviation

N = number of subgroups for which ni ≥ 2

si = sample standard deviation of the ith subgroup

Capability Indices for Normal Distributions

This section provides details about the calculation of capability indices for normal data.

For a process characteristic with mean  and standard deviation , the population-based 

capability indices are defined as follows:

Cp = 

Cpl = 

Cpu = 

Cpk = 

̂

s1

c4 n1 
---------------- 

sN

c4 nN 
------------------+ +

N
------------------------------------------------------=

USL LSL–
6

----------------------------

 LSL–
3

--------------------

USL –
3

---------------------

min( Cpl, Cpu )
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Cpm = 

where:

LSL is the lower specification limit.

USL is the upper specification limit.

T is the target value.

For sample-based capability indices, the parameters are replaced by their estimates. The 

estimate for  uses the method that you specified in the Capability Analysis window. See 

“Variation Statistics”.

If either of the specification limits is missing, the capability indices containing the missing 

specification limit are reported as missing.

Tip: A capability index of 1.33 is often considered to be the minimum value that is acceptable. 

For a normal distribution, a capability index of 1.33 corresponds to an expected number of 

nonconforming units of about 6 per 100,000.

Confidence Intervals for Capability Indices

Note: Confidence intervals for capability indices appear only in the Long Term Sigma report.

The 100(1 - )% confidence interval for Cp is calculated as follows:

where:

 is the estimated value for Cp.

 is the (/2)th quantile of a chi-square distribution with n - 1 degrees of freedom.

n is the number of observations.

min T LSL– USL T –

3 1
T –


------------- 
  2

+

-------------------------------------------------------------

CP̂
 2 n 1–

2

n 1–
--------------------------- CP̂

1  2– n 1–
2

n 1–
-----------------------------------

 
 
 
 

CP̂

 2 n 1–
2
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The 100(1 - )% confidence interval for Cpk is calculated as follows:

where:

 is the estimated value for Cpk.

 is the (1 - /2)th quantile of a standard normal distribution.

n is the number of observations.

The 100(1 - )% confidence interval for CPM is calculated as follows:

where:

 is the estimated value for CPM.

 is the (/2)th quantile of a chi-square distribution with  degrees of freedom.

n is the number of observations.

 is the mean of the observations.

T is the target value.

s is the long-term sigma estimate.

Note: The confidence interval for CPM is computed only when the target value is centered 

between the lower and upper specification limits.

Lower and upper confidence limits for CPL and CPU are computed using the method of Chou 

et al. (1990).
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The 100(1 - )% confidence limits for CPL (denoted by CPLL and CPLU) satisfy the following 

equations:

where

where

where:

tn-1() has a non-central t-distribution with n - 1 degrees of freedom and noncentrality 

parameter 

 is the estimated value for Cpl.

The 100(1 - )% confidence limits for CPU (denoted by CPUL and CPUU) satisfy the following 

equations:

where

where

where:

tn-1() has a non-central t-distribution with n - 1 degrees of freedom and noncentrality 

parameter 

 is the estimated value for Cpu.

Capability Indices for Nonnormal Distributions

This section describes how capability indices are calculated for nonnormal distributions. 

These generalized capability indices are defined as follows:

Cp = 

Cpk = 

Pr tn 1– L  3Ĉpl n   2= L 3CPLL n=

Pr tn 1– U  3Ĉpl n   2= U 3CPLU n=

Ĉpl

Pr tn 1– L  3Ĉpu n   2= L 3CPUL n=

Pr tn 1– U  3Ĉpu n   2= U 3CPUU n=

Ĉpu

USL LSL–
P0.99865 P0.00135–
------------------------------------------------

min Cpl Cpu 
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Cpm = 

Cpl = 

Cpu = 

where:

LSL is the lower specification limit.

USL is the upper specification limit.

T is the target value.

P is the *100th percentile of the fitted distribution.

For the calculation of Cpm,  and  are estimated using the expected value and square root of 

the variance of the fitted distribution. For more information about the relationship between 

the parameters in the Parameter Estimates report and the expected value and variance of the 

fitted distributions, see Basic Analysis.

Sigma Quality Statistics

The Sigma Quality statistics for each Portion (Below LSL, Above USL, and Total Outside) are 

calculated as follows:

where:

Pct is the value in the Percent column of the report.

 is the (1 - Pct/100)th quantile of a standard normal distribution.

Note: Even though the Percent Below LSL and Percent Above USL sum to the Percent Total 

Outside value, the Sigma Quality Below LSL and Sigma Quality Above USL values do not 

sum to the Sigma Quality Total Outside value. This is because calculating Sigma Quality 

involves finding normal distribution quantiles, and is therefore not additive.

min
T LSL–

P0.5 P0.00135–
------------------------------------- USL T–

P0.99865 P0.5–
-------------------------------------, 

 

1
 T–


------------- 
  2

+

----------------------------------------------------------------------------------------------

P0.5 LSL–

P0.5 P0.00135–
-------------------------------------

USL P0.5–

P0.99865 P0.5–
-------------------------------------

Sigma Quality  1–
1 Pct 100– 1.5+=

 1–
1 Pct 100–
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Benchmark Z Statistics

Benchmark Z statistics are available only for capability analyses based on the normal 

distribution. The Benchmark Z statistics are calculated as follows:

Z Bench = 

Z LSL =  = 3 * Cpl

Z USL =  = 3 * Cpu

where:

LSL is the lower specification limit.

USL is the upper specification limit.

 is the sample mean.

 is the sample standard deviation.

-1
1 - P(LSL) - P(USL) is the (1 - P(LSL) -P(USL))th quantile of a standard normal distribution.

P(LSL) = Prob(X < LSL) = 1 - (Z LSL).

P(USL) = Prob(X > USL) = 1 - (Z USL).

 is the standard normal cumulative distribution function.

Statistical Details for V-Mask CUSUM Control Charts

The following notation is used in these formulas:

•  denotes the mean of the population, also referred to as the process mean or the process 

level.

• 0 denotes the target mean (or goal) for the population. Sometimes, the symbol  is used 

for 0. See the American Society for Quality Statistics Division (2004). You can provide 0 

as the Target in the Known Statistics for CUSUM Chart area on the launch window.

•  denotes the population standard deviation.  denotes an estimate of .

• 0 denotes a known standard deviation. You can provide o as the Sigma in the Known 

Statistics for CUSUM Chart area on the launch window.

• n denotes the nominal sample size for the CUSUM chart.

•  denotes the shift in  to be detected, expressed as a multiple of the standard deviation. 

You can provide  as the Delta in the Known Statistics for CUSUM Chart area on the 

launch window.

 1–
1 P LSL – P USL –

 LSL–


--------------------

USL –


---------------------

X0

̂
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•  denotes the shift in  to be detected, expressed in data units. If the sample size n is 

constant across subgroups, then the following computation applies:

You can provide  as the Shift in the Known Statistics for CUSUM Chart area on the 

launch window.

Note: Some authors use the symbol D instead of .

One-Sided CUSUM Charts

Positive Shifts

If the shift  to be detected is positive, the CUSUM for the tth subgroup is computed as follows:

St = max(0, St – 1+ (zt – k))

t = 1, 2,..., n, where S0 = 0, zt is defined as for two-sided charts, and the parameter k, termed the 

reference value, is positive. If the parameter k is not specified in the launch window, k is set to 

/2. The CUSUM St is referred to as an upper cumulative sum. St can be computed as follows:

The sequence St cumulates deviations in the subgroup means greater than k standard errors 

from 0. If St exceeds a positive value h (referred to as the decision interval), a shift or 

out-of-control condition is signaled.

Negative Shifts

If the shift to be detected is negative, the CUSUM for the tth subgroup is computed as follows:

St = max(0, St – 1 – (zt + k))

t = 1, 2,..., n, where S0 = 0, zt is defined as for two-sided charts, and the parameter k, termed the 

reference value, is positive. If the parameter k is not specified in the launch window, k is set to 

/2. The CUSUM St is referred to as a lower cumulative sum. St can be computed as follows:

 
X

  n= =

max 0 St 1–

Xi 0 k
Xt

+ –


Xt

-----------------------------------------+
 
 
 
 

max 0 St 1–

Xi 0 k
Xt

– –


Xt

-----------------------------------------–
 
 
 
 
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The sequence St cumulates the absolute value of deviations in the subgroup means less than k 

standard errors from 0. If St exceeds a positive value h (referred to as the decision interval), a 

shift or out-of-control condition is signaled.

Note that St is always positive and h is always positive, regardless of whether  is positive or 

negative. For charts designed to detect a negative shift, some authors define a reflected 

version of St for which a shift is signaled when St is less than a negative limit.

Lucas and Crosier (1982) describe the properties of a fast initial response (FIR) feature for 

CUSUM charts in which the initial CUSUM S0 is set to a “head start” value. Average run 

length calculations given by them show that the FIR feature has little effect when the process 

is in control and that it leads to a faster response to an initial out-of-control condition than a 

standard CUSUM chart. You can provide a Head Start value in the Known Statistics for 

CUSUM Chart area on the launch window.

Constant Sample Sizes

When the subgroup sample sizes are constant (= n), it might be preferable to compute 

CUSUMs that are scaled in the same units as the data. CUSUMs are then computed as follows:

 where  > 0

where  < 0. In either case, the parameter k is rescaled to . If the parameter k is not 

specified in the launch window, kʹ is set to /2. A shift is signaled if St exceeds . 

Some authors use the symbol H for hʹ.

Two-Sided CUSUM Charts

If the CUSUM chart is two-sided, the cumulative sum St plotted for the tth subgroup is defined 

as follows:

St = St - 1 +zt

t = 1, 2,..., n. Here S0=0, and the term zt is calculated as follows:

St max 0 St 1– Xt 0 k n+ – + =

St max 0 St 1– Xt 0 k n– – – =

k' k n=

h' h n=

zt Xt 0–   nt =
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where  is the tth subgroup average, and nt is the tth subgroup sample size. If the subgroup 

samples consist of individual measurements xt, the term zt simplifies to the following 

computation:

zt = (xt – 0)/

The first equation can be rewritten as follows:

where the sequence St cumulates standardized deviations of the subgroup averages from the 

target mean 0.

In many applications, the subgroup sample sizes ni are constant (ni = n), and the equation for 

St can be simplified:

In some applications, it might be preferable to compute St as follows:

which is scaled in the same units as the data. In this case, the procedure rescales the V-mask 

parameters h and k to  and , respectively. Some authors use the symbols 

F for kʹ and H for hʹ.

If the process is in control and the mean  is at or near the target 0, the random walk model 

applies. Therefore, the points might wander away from zero, but they will not exhibit a large 

trend since positive and negative displacements from 0 tend to cancel each other. If  shifts in 

the positive direction, the points exhibit an upward trend, and if  shifts in the negative 

direction, the points exhibit a downward trend.

Xt

St zi

i 1=

t

 Xi 0–  
Xi



i 1=

t

= =

St 1 
X

  Xi 0– 

i 1=

t

 n   Xi 0– 

i 1=

t

= =

St Xi 0– 

i 1=

t

=

h' h n= k' k n=
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Statistical Details for Weighted Moving Average Charts

This section describes how control limits are calculated in legacy weighted moving average 

charts.

Control Limits for UWMA Charts

Control limits for UWMA charts are computed for each subgroup i as follows:

LCLi = 

UCLi = 

where:

w is the span parameter (number of terms in moving average)

ni is the sample size of the ith subgroup

k is the number of standard deviations

 is the weighted average of the subgroup means

 is the estimated process standard deviation

Control Limits for EWMA Charts

Control limits for EWMA charts are computed as follows:

LCL = 

UCL = 

where:

r is the EWMA weight parameter (0 < r  1)

xij is the jth measurement in the ith subgroup, with j = 1, 2, 3,..., ni

0 k
̂

min i w 
------------------------ 1

ni

----- 1
ni 1–
-------------  1

n1 max i w 0– +
------------------------------------------+ + +–

0 k
̂

min i w 
------------------------ 1

ni

----- 1
ni 1–
-------------  1

n1 max i w 0– +
------------------------------------------+ + ++

0

̂

0 k̂r 1 r– 2j

ni j–
--------------------

j 0=

i 1–

–

0 k̂r 1 r– 2j

ni j–
--------------------

j 0=

i 1–

+
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ni is the sample size of the ith subgroup

k is the number of standard deviations

 is the weighted average of the subgroup means

 is the estimated process standard deviation

0

̂



Chapter 15
Pareto Plots

Focus Improvement Efforts on the Vital Few

A Pareto plot is a chart that shows the severity (measured by frequency) of problems in a 

quality-related process or operation. Pareto plots help you decide which problems to solve 

first by highlighting the frequency and severity of problems. This can help improve the 

statistical quality of your process or operation.

Figure 15.1  Pareto Plot Examples
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Overview of the Pareto Plot Platform

The Pareto Plot platform produces charts to display the relative frequency or severity of 

problems in a quality-related process or operation. The Pareto plot is displayed initially as a 

bar chart that shows the classification of problems arranged in decreasing order. The column 

whose values are the cause of a problem is assigned the Y role and is called the process variable.

You can also generate a comparative Pareto plot, which combines two or more Pareto plots for 

the same process variable. The single display shows plots for each value in a column assigned 

the X role, or combination of levels from two X variables. Columns assigned the X role are 

called classification variables.

The Pareto plot can chart a single Y (process) variable with no X classification variables, with a 

single X, or with two X variables. The Pareto function does not distinguish between numeric 

and character variables or between modeling types. You can switch between a bar chart and a 

pie chart. All values are treated as discrete, and bars or wedges represent either counts or 

percentages.

Example of the Pareto Plot Platform

In this example, you determine which factors contribute most toward process failure during 

the fabrication of integrated circuits. The data contain the types of failure defects and the 

number of times each type of defect occurred.

1. Select Help > Sample Data Folder and open Quality Control/Failure.jmp.

2. Select Analyze > Quality and Process > Pareto Plot.

3. Select failure and click Y, Cause.

This column lists the causes of failure. It is the variable that you want to inspect.

4. Select N and click Freq.

This column list the number of times that each type of failure occurred.

5. Click OK.
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Figure 15.2  Pareto Plot Report Window

The left axis represents the count of failures, and the right axis represents the percent of 

failures in each category. The bars are in decreasing order with the most frequently 

occurring failure to the left. The curve indicates the cumulative failures from left to right.

6. Click the Pareto Plot red triangle and select Label Cum Percent Points.

Note that Contamination accounts for approximately 45% of the failures. The point above 

the Oxide Defect bar shows that Contamination and Oxide Defect together account for 

approximately 71% of the failures.

7. Click the Pareto Plot red triangle and deselect Label Cum Percent Points and Show Cum 
Percent Curve.

8. Click the label for the y-axis labeled N and rename it Count.

9. Double-click the y-axis to display the Y Axis Settings window.

– In the Maximum field, type 15.

– In the Increment field, type 2.

– In the Axis Label Row panel, select Grid Lines for the Major grid line.

– Click OK.

10. Click the Pareto Plot red triangle and select Category Legend.
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Figure 15.3  Pareto Plot with Display Options

Figure 15.3 shows the counts of different types of failures and has a category legend. The 

vertical count axis is rescaled and has grid lines at the major tick marks.

11. To view the data as a pie chart, click the Pareto Plot red triangle and select Pie Chart.

Figure 15.4  Pareto Plot as a Pie Chart

Contamination and Oxide Defect clearly represent the majority of the failures.
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Launch the Pareto Plot Platform

Launch the Pareto Plot platform by selecting Analyze > Quality and Process > Pareto Plot.

Figure 15.5  The Pareto Plot Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

The Pareto Plot launch window contains the following options:

Y, Cause Identifies the column whose values are the cause of a problem. It is called the 

process variable and is the variable that you want to inspect.

X, Grouping Identifies the grouping factor. The grouping variable produces one Pareto plot 

window with side-by-side plots for each value. You can have no grouping variable, one 

grouping variable (see “Example of a One-Way Comparative Pareto Plot”), or two 

grouping variables (see “Example of a Two-Way Comparative Pareto Plot”).

Subcategory Assigns a variable that splits the causes into subcategories. The subcategories 

for each cause are shown as different colored bars on the Pareto plot.

Weight Assigns a variable to give the observations different weights.

Freq Identifies the column whose values hold the frequencies.

By Identifies a variable to produce a separate analysis for each value that appears in the 

column.

Threshold of Combined Causes Enables you to specify a threshold for combining causes by 

specifying a minimum rate or count. Select the option and then select Tail % or Count and 

enter the threshold value. The Tail percent option combines smaller count groups against 

the percentage specified of the total (combined small groups count/total group count). The 

Count option enables you to specify a specific count threshold. For an example, see 

“Example of a Threshold for Combined Causes”.
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Per Unit Analysis Enables you to compare defect rates across groups. JMP calculates the 

defect rate as well as 95% confidence intervals of the defect rate. Select the option and then 

select Constant or Value in Freq Column and enter the sample size value or cause code, 

respectively. The Constant option enables you to specify a constant sample size on the 

launch window. The Value In Freq Column option enables you to specify a unique sample 

size for a group through a special cause code to designate the rows as cause rows.

Although causes are allowed to be combined in Pareto plots, the calculations for these 

analyses do not change correspondingly.

For examples, see “Example of a Constant Sample Size across Groups” and “Example of a 

Non-Constant Sample Size across Groups”.

The Pareto Plot Report

The Pareto plot combines a bar chart displaying percentages of variables in the data with a 

line graph showing cumulative percentages of the variables.

Figure 15.6  Pareto Plot Example



440 Pareto Plots Chapter 15
Pareto Plot Platform Options Quality and Process Methods

The Pareto plot can chart a single Y (process) variable with no X classification variables, with a 

single X, or with two X variables. The Pareto plot does not distinguish between numeric and 

character variables or between modeling types. All values are treated as discrete, and bars 

represent either counts or percentages. The following list describes the arrangement of the 

Pareto plot:

• A Y variable with no X classification variables produces a single chart with a bar for each 

value of the Y variable. For an example, see “Example of the Pareto Plot Platform”.

• A Y variable with one X classification variable produces a row of Pareto plots. There is a 

plot for each level of the X variable with bars for each Y level. These plots are referred to as 

the cells of a comparative Pareto plot. There is a cell for each level of the X (classification) 

variable. Because there is only one X variable, this is called a one-way comparative Pareto 

plot. For an example, see “Example of a One-Way Comparative Pareto Plot”.

• A Y variable with two X variables produces rows and columns of Pareto plots. There is a 

row for each level of the first X variable and a column for each level of the second X 

variable. Because there are two X variables, this is called a two-way comparative Pareto plot. 

The rows have a Pareto plot for each value of the first X variable, as described previously. 

The upper left cell is called the key cell. Its bars are arranged in descending order. The bars 

in the other cells are in the same order as the key cell. You can reorder the rows and 

columns of cells. The cell that moves to the upper left corner becomes the new key cell and 

the bars in all other cells rearrange accordingly. For an example, see “Example of a 

Two-Way Comparative Pareto Plot”.

• Each bar is the color for which the rows for that Y level are assigned in the associated data 

table. Otherwise, a single color is used for all of the bars whose Y levels do not have rows 

with an assigned color. If the rows for a Y level have different colors, the bar for that 

Y level is the color of the first row for that Y level in the data table.

You can change the type of scale and arrangement of bars and convert the bars into a pie chart 

using the options in the Pareto Plot red triangle menu. See “Pareto Plot Platform Options”.

Pareto Plot Platform Options

The Pareto Plot red triangle menu contains options to customize the appearance of the 

individual bars in the plot and to perform different types of count analyses.

Configure Causes Shows a window that contains options to customize one or more of the 

individual bars in the Pareto plot. You can change the label, color, and marker of 

individual causes and specify if the bar value is shown. You can also combine, separate, or 

reorder the causes.
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Per Unit Rates Shows or hides a table that compares defect rates across groups. If a sample 

size is specified in the launch window, Defects Per Unit (DPU) and Parts Per Million (PPM) 

columns are included in the Per Unit Rates table.

Test Rate Within Groups Shows or hides a table of the results of a likelihood ratio chi-square 

test to determine whether the rates across causes are the same within a group. See 

“Statistical Details for the Pareto Plot Platform”.

Test Rates Across Groups (Available only when a Grouping variable is specified in the 

launch window.) Shows or hides a table of the results of a likelihood ratio chi-square test 

to determine whether the rate for each cause is the same across groups. See “Statistical 

Details for the Pareto Plot Platform”.

Note: By default, the statistics shown in the tables are calculated based on the raw counts of 

causes and do not take into account causes that have been combined or ordered in the Pareto 

plot. To calculate the statistics in a table based on the counts of causes as shown in the Pareto 

plot, select the Match Plot option from the corresponding table’s red triangle menu. If you 

press Ctrl and select the Match Plot option, the option is applied to all of the tables in the 

report.

See Using JMP for more information about the following options:

Local Data Filter Shows or hides the local data filter that enables you to filter the data used 

in a specific report.

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

Plots Options

In the Pareto Plot platform, the Plot red triangle menu contains options to customize the 

appearance of the plots.

Pareto Shows a submenu of options to change the appearance of the Pareto plot.
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Show Pareto Bars Shows or hides the bars that correspond to the value for each cause.

Subcategory Bar Style (Available only when a subcategory is specified in the launch 

window.) Sets the style of the Pareto bars to Side by Side, Stacked, Bullet, Nested, 

Single, Needle, or Float.

Bar Style (Not available when a subcategory is specified in the launch window.) Sets the 

style of the Pareto bars to Bar or Float.

Bar Label Format Opens a window that enables you to edit the format of the bar label.

Show Pareto Line Shows or hides a line that connects the values for each cause.

Pareto Line Connect Style (Available only when the Pareto Line is shown in the plot.) 

Sets the line style of the Pareto line to Line, Curve, or Step.

Show Pareto Markers Shows or hides markers at the value for each cause.

Show Error Bars Shows or hides error bars on the Pareto bars.

Pie Chart Shows the bars as a pie chart.

Cumulative Percent Shows a submenu of options that affect the appearance of the 

cumulative percent curve and labels on the Pareto plot.

Show Cum Percent Curve Shows or hides the cumulative percent curve above the bars 

and the cumulative percent axis on the vertical right axis.

Cum Line Connect Style Sets the line style of the cumulative percent curve to Line, 

Curve, or Step.

Cum Percent Curve Color Changes the color of the cumulative percent curve.

Show Cum Percent Points Shows or hides the points on the cumulative percent curve.

Label Cum Percent Points Shows or hides the labels for the points on the cumulative 

curve.

Cum Percent Label Format Shows a window that enables you to edit the format of the 

cumulative percent label.

Orientation Sets the orientation of the plot to be vertical or horizontal. The default 

orientation is vertical.

Note: When the orientation is horizontal, the scale of the X axis is always percent. The 

Percent Scale option that enables you to toggle between a percent scale and a count scale is 

disabled.

Legend Position Changes the position of the legend around the Pareto plot.
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Legend Settings Shows a window with options to edit legend settings such as the color, title 

position, and font of the legend text.

Show Cum Percent Axis Shows or hides the cumulative percent axis on the vertical right 

axis.

Synchronize Y Axes (Available only when the orientation is vertical.) Locks and unlocks the 

two Y axes. When this option is selected, zooming and panning of one axis is synchronized 

with the other axis.

Percent Scale Sets the scale of the left Y axis to count or percent. A percent scale is shown by 

default.

N Legend Shows or hides the total sample size in the plot area.

Reorder Horizontal (Available only when a grouping variable is specified.) Reorders 

horizontally grouped Pareto plots.

Reorder Vertical (Available only when a grouping variable is specified.) Reorders vertically 

grouped Pareto plots.

Swap Group Orientation (Available only when a grouping variable is specified.) Swaps the 

horizontal and vertical groups in the Pareto plot. If only one group is specified, the 

orientation of the plot is changed.

Ungroup Plots Separates grouped Pareto plots when there are two or more groups.

Selected Causes Shows a submenu of options to change the bars in the Pareto plot. These 

options are also available with a right-click anywhere in the plot area.

Combine Causes (Available only if at least two bars are selected in the Pareto plot.) 

Combines selected bars into a single cause bar.

Separate Causes Separates selected bars into their original component bars.

Move to First Moves one or more highlighted bars to the left (first) position.

Move to Last Moves one or more highlighted bars to the right (last) position.

Colors Shows the colors palette for coloring one or more highlighted bars.

Markers Shows the markers palette for assigning a marker to the points on the 

cumulative percent curve, when the Show Cum Percent Points command is in effect.

Label Displays the bar value at the top of all highlighted bars.

Subset Creates a subset data table from the selections in the Pareto Plot. If nothing is 

selected in the Pareto plot, all of the data from the plot is included in the data table.
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Additional Examples of the Pareto Plot Platform

This section contains examples of the Pareto Plot platform.

• “Example of a Threshold for Combined Causes”

• “Example of a Constant Sample Size across Groups”

• “Example of a Non-Constant Sample Size across Groups”

• “Example of a One-Way Comparative Pareto Plot”

• “Example of a Two-Way Comparative Pareto Plot”

• “Example of Subcategories”

Example of a Threshold for Combined Causes

This example uses a threshold value to combine causes with counts of 2 or fewer into one 

combined cause. The data table in this example lists causes of failure during the fabrication of 

integrated circuits and the number of times each type of defect occurred.

1. Select Help > Sample Data Folder and open Quality Control/Failure.jmp.

2. Select Analyze > Quality and Process > Pareto Plot.

3. Select failure and click Y, Cause.

4. Select N and click Freq.

5. Select Threshold of Combined Causes and then select Count.

6. Enter 2 as the threshold value.

7. Click OK.

Figure 15.7  Pareto Plot with a Threshold Count of 2
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Figure 15.7 displays the plot after specifying a count of 2. All causes with counts 2 or fewer 

are combined into the bar labeled 4 Others.

8. To separate the combined bars into original categories as shown in Figure 15.8, select the 

bar labeled 4 Others.

9. Click the Plots red triangle and select Selected Causes > Separate Causes.

Tip: Alternatively, you can right-click the bar labeled 4 Others and select Selected Causes 
> Separate Causes.

Figure 15.8  Pareto Plot with Separated Causes

Example of a Constant Sample Size across Groups

This example uses Pareto plots to compare the causes of failure during the fabrication of 

integrated circuits for two different processes. Each process has a constant sample size of 1000. 

The data table in this example lists the causes of failure and the number of times each type of 

defect occurred.

1. Select Help > Sample Data Folder and open Quality Control/Failures.jmp.

2. Select Analyze > Quality and Process > Pareto Plot.

3. Select Causes and click Y, Cause.

4. Select Process and click X, Grouping.

5. Select Count and click Freq.

6. Select Per Unit Analysis and then select Constant.

7. Enter 1000 in Sample Size.
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8. Click OK.

Figure 15.9  Pareto Plot Report Window

Process A indicates Contamination as the top failure while Process B indicates Oxide 

Defect as the leading failure.

9. Click the Pareto Plot red triangle and select Test Rates Across Groups.

Figure 15.10  Test Rates across Groups Results

Note that the DPU for Contamination across groups (Process A and B) is around 0.06.
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Example of a Non-Constant Sample Size across Groups

This example uses Pareto plots to compare the causes of failure during the fabrication of 

integrated circuits for two different processes. A unique sample size for each group is used by 

specifying size as the cause code, which designates the rows as size rows.The data table in this 

example lists the causes of failure the number of times each type of defect occurred.

1. Select Help > Sample Data Folder and open Quality Control/Failuressize.jmp.

2. Select Analyze > Quality and Process > Pareto Plot.

3. Select Causes and click Y, Cause.

4. Select Process and click X, Grouping.

5. Select Count and click Freq.

6. Select Per Unit Analysis and then select Value in Freq Column.

7. Enter size in Cause Code.

8. Click OK.

Figure 15.11  Pareto Plot Report Window

9. Click the Pareto Plot red triangle and select Per Unit Rates.

10. Click the Pareto Plot red triangle and select Test Rates Across Groups.
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Figure 15.12  Per Unit Rates and Test Rates across Groups Results

Note that the sample size of 101 is used to calculate the DPU for the causes in group A. 

However, the sample size of 145 is used to calculate the DPU for the causes in group B.

If there are two group variables, Per Unit Rates lists DPU or rates for every combination of 

the grouping variables for each cause. However, Test Rate Across Groups only tests overall 

differences between groups.

Example of a One-Way Comparative Pareto Plot

This example compares failures in samples of capacitors manufactured before and after 

cleaning a tube in the diffusion furnace.

1. Select Help > Sample Data Folder and open Quality Control/Failure2.jmp.

2. Select Analyze > Quality and Process > Pareto Plot.

3. Select failure and click Y, Cause.

4. Select clean and click X, Grouping.

The clean variable identifies samples as before and after cleaning.

5. Select N and click Freq.

6. Click OK.
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Figure 15.13  One-way Comparative Pareto Plot

There is a plot for each value of the variable clean. The horizontal and vertical axes are 

scaled identically for both plots. The bars in the first plot are in descending order of the Y 

axis values and determine the order for all cells.

7. Click the Plots red triangle and select Reorder Horizontal.

8. Click the down arrow once and then click OK.

This rearranges the order of the plots.
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Figure 15.14  One-way Comparative Pareto Plot with Reordered Cells

The plots are easier to interpret when presented as the before-and-after plot shown in 

Figure 15.14. Note that the order of the causes changes to reflect the order based on the 

first cell. A comparison of these two plots shows a reduction in oxide defects after 

cleaning.

Example of a Two-Way Comparative Pareto Plot

This example compares failures in production samples in a capacitor manufacturing process 

before and after a furnace cleaning on each of three consecutive days.

1. Select Help > Sample Data Folder and open Quality Control/Failure3.jmp.

2. Select Analyze > Quality and Process > Pareto Plot.

3. Select failure and click Y, Cause.

4. Select clean and date and click X, Grouping.

5. Select N and click Freq.

6. Click OK.

7. Click the Pareto Plot red triangle and select Configure Causes.

8. Select contamination, click the bar next to Color, and change the color to black.

9. Select metallization, click the bar next to Color, and change the color to black.

10. Click OK.
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Figure 15.15  Two-way Comparative Pareto Plot

The two-way layout of Pareto plots shows each level of both X variables. The bars in the 

upper left cell are arranged in descending order and the bars in the other cells match that 

order. In each cell of the two-way comparative plot, the bars representing the two most 

frequently occurring problems are colored black. Contamination and metallization are the 

two vital categories in all cells. After furnace cleaning, contamination is less of a problem.

Example of Subcategories

This example uses a Pareto plot to compare the causes of failure during the fabrication of 

integrated circuits for two different processes. To see both processes on the same plot, a 

subcategory is defined.

1. Select Help > Sample Data Folder and open Quality Control/Failures.jmp.

2. Select Analyze > Quality and Process > Pareto Plot.

3. Select Causes and click Y, Cause.

4. Select Process and click Subcategory.

5. Select Count and click Freq.

6. Click OK.
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Figure 15.16  Pareto Plot with Subcategories

The number of failures for each process and cause combination appears on the same 

Pareto plot. To change the bar style of the subcategories, click the Plots red triangle and 

select Pareto > Subcategory Bar Style.

Statistical Details for the Pareto Plot Platform

The likelihood ratio Chi-square test statistic computed in the Pareto Plot platform uses the 

following notation:

• nij is the count for Cause i in Group j.

• Ej is the expected count for Group j. This is the mean count of each group, across causes.

• Ei is the expected count for Cause i. This is the mean count of each cause, across groups.

Likelihood Ratio Chi-Square Test Statistic within Groups

Gj
2

2 nij nij Ej ln

i 1=

K

=
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Likelihood Ratio Chi-Square Test Statistic across Groups

Gi
2
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j 1=

J
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Chapter 16
Cause-and-Effect Diagrams

Identify Root Causes

Use the Diagram platform to construct cause-and-effect diagrams, also known as Ishikawa 

charts or fishbone charts. Use these diagrams to:

• Organize the causes of an effect (sources of a problem)

• Brainstorm

• Identify variables in preparation for further experimentation

Figure 16.1  Example of a Cause-and-Effect Diagram
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Example of a Cause-and-Effect Diagram

Use a diagram to examine the major factors and possible causes of the defects in a circuit 

board.

1. Select Help > Sample Data Folder and open Ishikawa.jmp.

2. Select Analyze > Quality and Process > Diagram.

3. Select Parent and click X, Parent.

4. Select Child and click Y, Child.

5. Click OK.

Figure 16.2  Ishikawa.jmp Diagram

The major factors are Inspection, Solder process, Raw card, Components, and Component 

insertion. From each major factor, possible causes branch off, such as Inspection, 

Measurement, and Test coverage for the Inspection factor.

You can focus on one area at a time to further examine the possible causes or sources of 

variation for each major factor.
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Prepare the Data

Before you launch the Diagram platform, your data should be in two columns of a data table.

Figure 16.3  Example of the Ishikawa.jmp Data Table

Notice that the Parent value Defects in circuit board (the effect) has five major factors, listed in 

the Child column. One of these major factors is Inspection, which has its own causes listed in 

the Child column. Parent values have children, and children can have their own children (and 

therefore be listed in both the Parent and Child columns.)

Launch the Diagram Platform

Launch the Diagram platform by selecting Analyze > Quality And Process > Diagram.

Figure 16.4  The Diagram Launch Window



Chapter 16 Cause-and-Effect Diagrams 459
Quality and Process Methods The Cause-and-Effect Diagram Report

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Tip: To create a basic diagram that is not based on a data table, leave the Y, Child, and X, 
Parent fields empty and click OK. Then edit the nodes using the options in the right-click 

menu. See “Right-Click Menus”.

Y, Child Represents the child factors contributing to the parent factors.

X, Parent Represents the parent factors (including the effect) that have child factors.

Label Includes the text from the Label columns in the nodes of the diagram.

By Produces separate diagrams for each value of the By variable.

The Cause-and-Effect Diagram Report

In Figure 16.5, the effect or problem, Defects in circuit board, appears on the right as the center 

line. The major contributing factors appear at the end of the branches (Inspection, Solder 

process, Raw Card, and so on.) Possible causes branch off each major factor.

Figure 16.5  Cause-and-Effect Diagram

Right-Click Menus

In the Cause and Effect Diagram, right-click a highlighted node to modify text, insert new 

nodes, change the diagram type, and more. Note the following:

• Right-click a title to change the font and color, positioning, visibility, or formatting.

• Click and highlight a node to rename it.

• Click and drag a node to move it.

effect

major factor

possible 
causes
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Text Menu

The Text menu contains the following options:

Font Select the font of the text or numeric characters.

Color Select the color of the text or numeric characters.

Rotate Left, Rotate Right, Horizontal Rotates the text or numbers to be horizontal, 90 

degrees left, or 90 degrees right.

Insert Menu

Use the Insert menu to insert items onto existing nodes. The Insert menu contains the 

following options:

Before Inserts a new node to the right of the highlighted node. For example, Figure 16.6 

inserts Child 1.5 before Child 2.

Figure 16.6  Insert Before

After Inserts a new node to the left of the highlighted node. For example, Figure 16.7 inserts 

Child 3 after Child 2.

Figure 16.7  Insert After

Above Inserts a new node at a level above the current node. For example, Figure 16.8 inserts 

Grandparent at a level above Parent.

Figure 16.8  Insert Above
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Below Inserts a new node at a level below the current node. For example, Figure 16.9 inserts 

Grandchild at a level below Child 2.

Figure 16.9  Insert Below

Move Menu

Use the Move menu to move nodes or branches. The Move menu contains the following 

options:

First Moves the highlighted node to the first position under its parent.

Last Moves the highlighted node to the last position under its parent.

Other Side Moves the highlighted node to the opposite side of its parent line.

Force Left Makes all horizontally drawn elements appear to the left of their parent.

Force Right Makes all horizontally drawn elements appear to the right of their parent.

Force Up Makes all vertically drawn elements appear above their parent.

Force Down Makes all vertically drawn elements appear below their parent.

Force Alternate Draws children on alternate sides of the parent line.
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Figure 16.10  Force Options

Other Menu Options

The right-click menu for a highlighted node also contains these options:

Change Type Changes the entire chart type to Fishbone, Hierarchy, or Nested.

Uneditable Disables all other commands except Move and Change Type.

Text Wrap Width Specifies the width of labels where text wrapping occurs.

Make Into Data Table Converts the currently highlighted node into a data table. Convert the 

all nodes by highlighting the whole diagram (effect).

Close Shows the highlighted node.

Delete Deletes the highlighted node and all of its children.

Cause and Effect Diagram Menu Options

The Cause and Effect Diagram red triangle menu contains options to redo the analysis and 

save scripts.

See Using JMP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Force Left Force Alternate Force Right

Force Up Force Down
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Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.

Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.

Save By-Group Script Contains options that enable you to save a script that reproduces the 

platform report for all levels of a By variable to several destinations. Available only when a 

By variable is specified in the launch window.

How to Save the Diagram

There are several different ways to save your Cause and Effect Diagram. Choose from one of 

the following options:

• “Save the Diagram as a Data Table”

• “Save the Diagram as a Journal”

• “Save the Diagram as a Script”

Save the Diagram as a Data Table

Saving the Cause and Effect Diagram as a data table is a good approach if you have other 

processes that need to update the data table. However, very little customization of the 

diagram is available because the data table cannot represent the customization.

To save the diagram as a data table, perform the following steps:

1. Highlight the entire diagram in the Cause and Effect Diagram report.

2. Right-click and select Make Into Data Table.

3. Save the new data table.

Save the Diagram as a Journal

Saving the Cause and Effect Diagram as a journal is a good choice for impromptu work. You 

can manually build the diagram, save it as a journal, then reopen the journal later and 

continue building and editing the diagram. However, since the journal is not connected to the 

data table, any customization of the diagram exists only in the journal.

To save the diagram as a journal, perform the following steps:

1. Highlight the entire diagram in the Cause and Effect Diagram report.
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2. Right-click and select Edit > Journal.

3. Save the new journal.

Save the Diagram as a Script

Saving the Cause and Effect Diagram as a script is a good approach if you have other 

processes that need to update the data table. If you created the diagram from a data table, a 

simple script appears that relaunches against the data table with no customization. If you 

created the diagram without using a data table (or from a journal), a more complex script 

appears that contains all the commands needed to add and customize each area of the 

diagram.

To save the diagram as a script, perform the following steps:

1. Click the Cause and Effect Diagram red triangle and select Save Script > To Script 
Window.

2. Save the new script.
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Manage Limits for Many Columns

The Manage Limits platform enables you to quickly add or edit many limits or column 

property metadata for several columns at once. The limits and metadata are then used in 

future analyses. You can also specify importance values for each process and indicate whether 

limits should appear in graphs as reference lines.

The following types of limits and metadata can be specified in Manage Limits:

• Specification limits

• Importance values

• Process Screening metadata, such as centerline, control chart sigma, and measurement 

sigma

• Measurement Systems Analysis metadata, such as tolerance range, lower tolerance, upper 

tolerance

• Measurement Systems Analysis metadata specific to Type 1 Gauge analysis, such as 

reference and resolution

• Detection limits
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Example of Manage Limits

Use Manage Limits to add specification limits to columns in a data table and then analyze 

those columns in the Distribution platform.

1. Select Help > Sample Data Folder and open Cities.jmp.

2. Select Analyze > Quality and Process > Manage Limits.

3. Specify the columns that you want to set specification limits on. For this example, select 

OZONE, CO, SO2, and NO, and click Process Variables.

4. Click OK.

5. Add your specification limits. You can do this by loading existing limits from a JMP data 

table (Load from Limits Table) or by entering limits manually. For this example, enter the 

following limits manually:

– OZONE: LSL 0.12, USL 0.2

– CO: LSL 6, USL 12

– SO2: LSL 0.015, USL 0.06

– NO: LSL 0.02, USL 0.04

6. Click the red triangle next to Manage Limits and select Show Limits All.

Specification limits for all columns will appear in graphs as reference lines for future 

analyses. If you want to show the specification limits as reference lines only for individual 

columns, check the Show Limits box next to those columns.

Figure 17.1  Set Specification Limits
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7. Choose how you want to save the specification limits. For this example, click Save to 
Column Properties. This saves them as column properties in the corresponding data table. 

You could also save them to a new data table (tall or wide format).

In the Cities.jmp data table Columns panel, notice that asterisks indicating the Spec Limits 

column property appear next to OZONE, CO, SO2, and NO.

8. To see values that are outside the limits in the data table, click the red triangle next to 

Manage Limits and select Color Out of Spec Values. Go to the Cities.jmp data table, and 

you can see that values below the lower specification limit are colored red and values 

above the upper specification limit are colored blue.

9. Now, you can run any analysis. For this example, select Analyze > Distribution.

10. Select OZONE, CO, SO2, and NO, and click Y, Columns.

11. Click OK.
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Figure 17.2  Specification Limits for OZONE in Distribution

The specification limits that you added to the OZONE column appear as reference lines in the 

histogram. When a column contains a Spec Limits column property, the Create Process 

Capability option is selected in the Distribution launch window. This adds the Process 

Capability report to the Distribution report.
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Launch the Manage Limits Platform

Launch the Manage Limits platform by selecting Analyze > Quality and Process > Manage 
Limits.

Figure 17.3  Manage Limits Launch Window

For more information about the options in the Select Columns red triangle menu, see Using 

JMP.

Process Variables The columns of process data containing the measurements. The columns 

must have a Numeric data type.

The Manage Limits Report

The Manage Limits report contains several tables that enable you to enter specification limits 

or other column property metadata for each process column that was specified in the Manage 

Limits launch window. The report also contains buttons to load and save specification limits 

and save the information to column properties.

• “Spec Limits”

• “Process Screening”

• “MSA”

• “Detection Limits”

• “Buttons”
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Spec Limits

The table in the Spec Limits section contains a row for each process column that was specified 

in the Manage Limits launch window. For each column, you can add specification limits as 

well as use the following options:

Show Limits Specifies that the Show as Graph Reference Lines option is selected in the Spec 

Limits column property for the specified column.

Process Importance Specifies the process importance value for each column. Process 

importance values provide a mechanism to sort processes in a preferred order. Process 

importance values are used to size markers in many platform graphs.

Units Specifies the units for each column.

Process Screening

The table in the Process Screening section contains a row for each process column that was 

specified in the Manage Limits launch window. For each column, you can specify the 

centerline, specified sigma, and measurement sigma. Once you save your specifications, you 

can use them when you launch the Process Screening platform. See “Limits Table”.

MSA

The table in the MSA section contains a row for each process column that was specified in the 

Manage Limits launch window. For each column, you can specify the lower and upper 

tolerance or tolerance range, reference, resolution, and historical process sigma. Once you 

save your specifications, you can use them in the Measurement Systems Analysis (MSA), 

Type 1 Gauge, and Variability Chart platforms. See “Measurement Systems Analysis”, “Type 

1 Gauge Analysis”, and “Variability Gauge Charts”.

Detection Limits

The table in the Detection Limits section contains a row for each process column that was 

specified in the Manage Limits launch window. For each column, you can add lower and 

upper detection limits.
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Buttons

There are several buttons at the bottom of the Manage Limits report that provide the 

following options:

Load from Limits Table Loads specification limits and metadata from a JMP data table.

Save to Column Properties Saves the specification limits and metadata as column 

properties in the associated data table.

Save to Tall Limits Table Saves the specification limits and metadata to a new data table in 

tall format.

Save to Wide Limits Table Saves the specification limits and metadata to a new data table in 

wide format.

Manage Limits Options

The Manage Limits red triangle menu contains the following options:

Show Limits All Selects all of the boxes under Show Limits in the Spec Limits table. If Show 

Limits is selected for a column, the Show as Graph Reference Lines option is selected in 

the Spec Limits column property. The Show as Graph Reference Lines option displays the 

specification limits and target that you specify as reference lines in select analysis plots.

Note: If all boxes under Show Limits are selected, the Show Limits All option deselects all 

of the boxes under Show Limits.

Round Decimals Sets the number of decimal places to round the limits or metadata values 

to.

Color Out of Spec Values Colors any values in the data table that are outside the 

specification limits for the columns. Values that are below the lower specification limit are 

colored red and values that are above the upper specification limit are colored blue.

See Using JMP for more information about the following options:

Redo Contains options that enable you to repeat or relaunch the analysis. In platforms that 

support the feature, the Automatic Recalc option immediately reflects the changes that 

you make to the data table in the corresponding report window.

Platform Preferences Contains options that enable you to view the current platform 

preferences or update the platform preferences to match the settings in the current JMP 

report.
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Save Script Contains options that enable you to save a script that reproduces the report to 

several destinations.
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Operating Characteristic Curves

Visualizing the Probability of Detecting Process Shifts

The Operating Characteristic (OC) Curves utility enables you to construct OC curves for 

control charts and attribute acceptance sampling plans. OC curves are available for XBar, P, 

NP, C, and U charts. For specified control charts, the OC curve shows the probability of failing 

to detect a shift of a particular size. In addition, there are OC curves for single and double 

attribute acceptance sampling plans. For a specified acceptance sampling plan, the OC curve 

shows how the probability of accepting a lot changes with the lot quality.

Note: The OC curves for control charts are two-sided curves. They are drawn for negative and 

positive shifts. Often OC curves display only one curve for the absolute shift.
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Example of Operating Characteristic Curves

Use the OC Curve platform to estimate the probability of identifying a process shift with the 

first sample collected after the shift.

1. Select Analyze > > Quality and Process > OC Curves.

2. Select XBar Shewhart Chart.

3. Click OK.

4. Set the control limits to -1.34 and 1.34. These are 3 sigma limits for s = 1 and n = 5 (3 times 1 

divided by the square root of 5).

5. Leave Sigma set to 1 and the sample size at 5.

6. Set Shift to 2.

Figure 18.1  OC Curve Example

The Y axis is the Beta risk, or the probability of not detecting a shift. The probability of 

detecting a shift of size 2s with a sample of size 5 is 1 - 0.07 = 0.93.
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Launch the Operating Characteristic Curves 
Platform

Launch the Operating Characteristic (OC) Curves by selecting Analyze > Quality and Process 
> OC Curves. Select the OC curve of interest and click OK to launch.

Figure 18.2  OC Curves Launch Window

The Operating Characteristic Curve Report

The Operating Characteristic Curve report if different depending on what you selected in the 

launch window.

• “OC Curves for Control Charts Report”

• “OC Curves for Acceptance Sampling Options”

OC Curves for Control Charts Report

For control charts, use OC curves to explore how chart parameter settings impact , the 

probability of failing to detect a specified shift of interest. Use the text boxes, sliders, or the 

LCL, Shift, and UCL handles on the OC curve to set and adjust chart parameters. The chart 

parameters are as follows:

Lower Control Limit Specifies the lower control limit from your control chart.

Upper Control Limit Specifics the upper control limit from your control chart.

Sigma (Available only for XBar charts.) Specifies your control chart sigma.

Sample Size (Not available for C charts.) Specifies the sample size used for your control 

chart measure.

Shift Specifies the shift to detect.
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Beta Specifies the probability of failing to detect the specified shift given the control chart 

specifications. Beta updates as the specifications are changed.

OC Curves for Acceptance Sampling Options

For attributes acceptance sampling, you can use OC curves to explore how sampling plans 

and assumed product quality impact the probability of accepting a lot. Use the text boxes, 

sliders, or fraction defective handle on the OC curve to set and adjust your sampling plan.

Single Sampling OC Curve Options

The following options are available for single sampling OC curves:

Sampling Type Enables you to select Lot Sampling or Binomial Sampling.

Lot Sampling Enables you to specify and explore an acceptance plan based on a fixed lot 

size.

Binomial Sampling Enables you to specify and explore an acceptance plan for a 

continuous process or other situation where the binomial distribution is appropriate.

Lot size (N) (Available only for Lot Sampling.) Specifies the size of the lot that you are 

sampling from.

Sample Size (n) Specifies the number of units for inspection.

Acceptable failures (c1) specifies the number of allowable failures. If the number of 

observed defects is greater than c1, then the lot is rejected.

Acceptable Quality Limit (AQL) Specifies the poorest quality limit that is acceptable. Enter 

the highest proportion of defects that is acceptable.

Rejectable Quality Limit (RQL) Specifies the poorest quality for an individual lot. Enter the 

highest proportion of defects that is acceptable for an individual lot. RQL must be less 

than or equal to AQL.

Fraction Defective Specifies the expected fraction defective in the lot.

Probability of Acceptance Specifies the probability of accepting the lot given the sampling 

plan as defined. The Probability of Acceptance updates as the specifications are changed, 

but you can also adjust this value directly. When you adjust the Probability of Acceptance 

directly, the Fraction Defective value is updated.

Alpha Specifies the Type I error. This is the probability of rejecting a lot that has a defect level 

equal to the AQL
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Beta Specifies the Type II error. This is the probability of accepting a lot that has a defect 

level equal to the RQL.

Double Sampling OC Curve Options

The following options are available for double sampling OC curves:

First Sample Contains the following settings for the first sample:

Number inspected (n1) Specifies the number of units inspected in the first sample.

Acceptable failures (c1) specifies the number of allowable failures in the first sample.

Second Sample Contains the following settings for the second sample:

Number inspected (n2) Specifies the number of units inspected in the second sample.

Acceptable failures (c1+c2) specifies the total number of allowable failures.

Acceptable Quality Limit (AQL) Specifies the poorest quality limit that is acceptable. 

Enter the highest proportion of defects that is acceptable.

Rejectable Quality Limit (RQL) Specifies the poorest quality for an individual lot. Enter 

the highest proportion of defects that is acceptable for an individual lot. RQL must be 

less than or equal to AQL.

Fraction Defective Specifies the expected fraction defective in the lot.

Probability of Acceptance Specifies the probability of accepting the lot given the sampling 

plan as defined. The Probability of Acceptance updates as the specifications are changed, 

but you can also adjust this value directly. When you adjust the Probability of Acceptance 

directly, the Fraction Defective value is updated.

Alpha Specifies the Type I error. This is the probability of rejecting a lot that has a defect level 

equal to the AQL

Beta Specifies the Type II error. This is the probability of accepting a lot that has a defect 

level equal to the RQL.
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• Scintilla is Copyright © 1998–2017 by Neil Hodgson <neilh@scintilla.org>.

All Rights Reserved.

Permission to use, copy, modify, and distribute this software and its documentation for 

any purpose and without fee is hereby granted, provided that the above copyright notice 

appear in all copies and that both that copyright notice and this permission notice appear 

in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING 

ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL 

HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY 

DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN 

ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN 

CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

• Progressë® Telerik® UI for WPF: Copyright © 2008-2019 Progress Software Corporation. 

All rights reserved. Usage of the included Progress® Telerik® UI for WPF outside of JMP is 

not permitted.

• ZLIB Compression Library is Copyright © 1995-2005, Jean-Loup Gailly and Mark Adler.

• Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.

• Packages is Copyright © 2009–2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 

permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of 

conditions and the following disclaimer in the documentation and/or other materials 

provided with the distribution.

Neither the name of the WhiteBox nor the names of its contributors may be used to 

endorse or promote products derived from this software without specific prior written 

permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND 

ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 

WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 

DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR 

ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
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(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF 

USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 

OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 

OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 

POSSIBILITY OF SUCH DAMAGE.

• iODBC software is Copyright © 1995–2006, OpenLink Software Inc and Ke Jin 

(www.iodbc.org). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 

permitted provided that the following conditions are met:

– Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.

– Redistributions in binary form must reproduce the above copyright notice, this list of 

conditions and the following disclaimer in the documentation and/or other materials 

provided with the distribution.

– Neither the name of OpenLink Software Inc. nor the names of its contributors may be 

used to endorse or promote products derived from this software without specific prior 

written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND 

ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 

WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 

DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, 

INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT 

NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 

PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 

WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) 

ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY 

OF SUCH DAMAGE.

• This program, “bzip2”, the associated library “libbzip2”, and all documentation, are 

Copyright © 1996–2019 Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 

permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.

2. The origin of this software must not be misrepresented; you must not claim that you 

wrote the original software. If you use this software in a product, an acknowledgment in 

the product documentation would be appreciated but is not required.

3. Altered source versions must be plainly marked as such, and must not be 

misrepresented as being the original software.



Appendix B Technology License Notices 487
Quality and Process Methods

4. The name of the author may not be used to endorse or promote products derived from 

this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR 

IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 

WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 

PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR 

ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 

CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 

PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 

PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 

USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 

DAMAGE.

Julian Seward, jseward@acm.org

bzip2/libbzip2 version 1.0.8 of 13 July 2019

• R software is Copyright © 1999–2012, R Foundation for Statistical Computing.

• MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and 

international patents. See www.mathworks.com/patents. MATLAB and Simulink are 

registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a 

list of additional trademarks. Other product or brand names may be trademarks or 

registered trademarks of their respective holders.

• libopc is Copyright © 2011, Florian Reuter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 

permitted provided that the following conditions are met:

– Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.

– Redistributions in binary form must reproduce the above copyright notice, this list of 

conditions and the following disclaimer in the documentation and / or other materials 

provided with the distribution.

– Neither the name of Florian Reuter nor the names of its contributors may be used to 

endorse or promote products derived from this software without specific prior written 

permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND 

ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 

WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 

DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR 

ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 

(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF 
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USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 

OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 

OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 

POSSIBILITY OF SUCH DAMAGE.

• libxml2 - Except where otherwise noted in the source code (e.g. the files hash.c, list.c and 

the trio files, which are covered by a similar license but with different Copyright notices) 

all the files are:

Copyright © 1998–2003 Daniel Veillard. All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this 

software and associated documentation files (the “Software”), to deal in the Software 

without restriction, including without limitation the rights to use, copy, modify, merge, 

publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to 

whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or 

substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, 

INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 

PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL DANIEL VEILLARD BE 

LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF 

CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE 

SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in 

advertising or otherwise to promote the sale, use or other dealings in this Software 

without prior written authorization from him.

• Regarding the decompression algorithm used for UNIX files:

Copyright © 1985, 1986, 1992, 1993

The Regents of the University of California. All rights reserved.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS 

OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT 

SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 

PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR 

BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN 

CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN 

ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 

DAMAGE.

1. Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.
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2. Redistributions in binary form must reproduce the above copyright notice, this list of 

conditions and the following disclaimer in the documentation and/or other materials 

provided with the distribution.

3. Neither the name of the University nor the names of its contributors may be used to 

endorse or promote products derived from this software without specific prior written 

permission.

• Snowball is Copyright © 2001, Dr Martin Porter, Copyright © 2002, Richard Boulton.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 

permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of 

conditions and the following disclaimer in the documentation and/or other materials 

provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors may be used 

to endorse or promote products derived from this software without specific prior written 

permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND 

CONTRIBUTORS \”AS IS\” AND ANY EXPRESS OR IMPLIED WARRANTIES, 

INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 

DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR 

CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 

EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED 

TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 

PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 

USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 

DAMAGE.

• Pako is Copyright © 2014–2017 by Vitaly Puzrin and Andrei Tuputcyn.

Permission is hereby granted, free of charge, to any person obtaining a copy of this 

software and associated documentation files (the “Software”), to deal in the Software 

without restriction, including without limitation the rights to use, copy, modify, merge, 

publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to 

whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or 

substantial portions of the Software.



490 Technology License Notices Appendix B
Quality and Process Methods

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, 

EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF 

MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 

NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT 

HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, 

WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, 

OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER 

DEALINGS IN THE SOFTWARE.

• HDF5 (Hierarchical Data Format 5) Software Library and Utilities are Copyright 

2006–2015 by The HDF Group. NCSA HDF5 (Hierarchical Data Format 5) Software 

Library and Utilities Copyright 1998-2006 by the Board of Trustees of the University of 

Illinois. All rights reserved. DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF 

GROUP AND THE CONTRIBUTORS “AS IS” WITH NO WARRANTY OF ANY KIND, 

EITHER EXPRESSED OR IMPLIED. In no event shall The HDF Group or the Contributors 

be liable for any damages suffered by the users arising out of the use of this software, even 

if advised of the possibility of such damage.

• agl-aglfn technology is Copyright © 2002, 2010, 2015 by Adobe Systems Incorporated. All 

Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are 

permitted provided that the following conditions are met:

– Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.

– Redistributions in binary form must reproduce the above copyright notice, this list of 

conditions and the following disclaimer in the documentation and/or other materials 

provided with the distribution.

– Neither the name of Adobe Systems Incorporated nor the names of its contributors 

may be used to endorse or promote products derived from this software without 

specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND 

CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, 

INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 

DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR 

CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 

EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED 

TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 

PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 

USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 

DAMAGE.
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• dmlc/xgboost is Copyright © 2019 SAS Institute.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file 

except in compliance with the License. You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the 

License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS 

OF ANY KIND, either express or implied. See the License for the specific language 

governing permissions and limitations under the License.

• libzip is Copyright © 1999–2019 Dieter Baron and Thomas Klausner.

This file is part of libzip, a library to manipulate ZIP archives. The authors can be 

contacted at <libzip@nih.at>.

Redistribution and use in source and binary forms, with or without modification, are 

permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of 

conditions and the following disclaimer in the documentation and/or other materials 

provided with the distribution.

3. The names of the authors may not be used to endorse or promote products derived from 

this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHORS ``AS ISʹʹ AND ANY EXPRESS OR 

IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 

WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 

PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR 

ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 

CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 

PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 

PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 

USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 

DAMAGE.

• OpenNLP 1.5.3, the pre-trained model (version 1.5 of en-parser-chunking.bin), and 

dmlc/xgboost Version .90 are licensed under the Apache License 2.0 are Copyright © 

January 2004 by Apache.org.

You may reproduce and distribute copies of the Work or Derivative Works thereof in any 

medium, with or without modifications, and in Source or Object form, provided that You 

meet the following conditions:
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– You must give any other recipients of the Work or Derivative Works a copy of this 

License; and

– You must cause any modified files to carry prominent notices stating that You changed 

the files; and

– You must retain, in the Source form of any Derivative Works that You distribute, all 

copyright, patent, trademark, and attribution notices from the Source form of the 

Work, excluding those notices that do not pertain to any part of the Derivative Works; 

and

– If the Work includes a “NOTICE” text file as part of its distribution, then any 

Derivative Works that You distribute must include a readable copy of the attribution 

notices contained within such NOTICE file, excluding those notices that do not pertain 

to any part of the Derivative Works, in at least one of the following places: within a 

NOTICE text file distributed as part of the Derivative Works; within the Source form or 

documentation, if provided along with the Derivative Works; or, within a display 

generated by the Derivative Works, if and wherever such third-party notices normally 

appear. The contents of the NOTICE file are for informational purposes only and do 

not modify the License. You may add Your own attribution notices within Derivative 

Works that You distribute, alongside or as an addendum to the NOTICE text from the 

Work, provided that such additional attribution notices cannot be construed as 

modifying the License.

– You may add Your own copyright statement to Your modifications and may provide 

additional or different license terms and conditions for use, reproduction, or 

distribution of Your modifications, or for any such Derivative Works as a whole, 

provided Your use, reproduction, and distribution of the Work otherwise complies 

with the conditions stated in this License.

• LLVM is Copyright © 2003–2019 by the University of Illinois at Urbana-Champaign.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file 

except in compliance with the License. You may obtain a copy of the License at:

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the 

License is distributed on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS 

OF ANY KIND, either express or implied. See the License for the specific language 

governing permissions and limitations under the License.

• clang is Copyright © 2007–2019 by the University of Illinois at Urbana-Champaign.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file 

except in compliance with the License. You may obtain a copy of the License at:

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the 

License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF 
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ANY KIND, either express or implied. See the License for the specific language governing 

permissions and limitations under the License.

• lld is Copyright © 2011–2019 by the University of Illinois at Urbana-Champaign.

Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file 

except in compliance with the License. You may obtain a copy of the License at:

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the 

License is distributed on an “AS IS”, WITHOUT WARRANTIES OR CONDITIONS OF 

ANY KIND, either express or implied. See the License for the specific language governing 

permissions and limitations under the License.

• libcurl is Copyright © 1996–2021, Daniel Stenberg, daniel@haxx.se, and many 

contributors, see the THANKS file. All rights reserved.

Permission to use, copy, modify, and distribute this software for any purpose with or 

without fee is hereby granted, provided that the above copyright notice and this 

permission notice appear in all copies.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, 

EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF 

MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 

NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE 

AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR 

OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR 

OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE 

OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in 

advertising or otherwise to promote the sale, use or other dealings in this Software 

without prior written authorization of the copyright holder.

• On the Windows operating system, JMP utilizes the OpenBLAS library. OpenBLAS is 

licensed under the 3-clause BSD license. Full license text follows: Copyright © 2011-2015, 

The OpenBLAS Project

All rights reserved. Redistribution and use in source and binary forms, with or without 

modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of 

conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of 

conditions and the following disclaimer in the documentation and/or other materials 

provided with the distribution.

3. Neither the name of the OpenBLAS project nor the names of its contributors may be 

used to endorse or promote products derived from this software without specific prior 

written permission.
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THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND 

CONTRIBUTORS ʺAS ISʺ AND ANY EXPRESS OR IMPLIED WARRANTIES, 

INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 

DISCLAIMED. IN NO EVENT SHALL THE OPENBLAS PROJECT OR CONTRIBUTORS 

BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 

CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 

PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 

PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 

USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 

DAMAGE.
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