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Introduction
JMP is a standalone, full-featured data visualization and statistical analysis software 
package from SAS for the Windows and Mac desktop. JMP has the interactivity and 
dynamic linkage that makes data exploration exciting and insightful and contains 
many advanced analytical options, fully satisfying the needs of data explorers and 
analysts. Still, there may be occasions where you’ll want (or need) to use JMP in 
conjunction with open source tools, like Python or R. 

Consider the following examples: 

•	 A corporate statistician prohibited from using non-validated software like R for 
primary analysis may nevertheless want to explore new methodology in an R 
package side-by-side with validated methods in JMP.

•	 A Python or R programmer may want to take advantage of the dynamic linkage, 
advanced visuals or powerful analytics available in JMP.

•	 A company’s data analysis department may want to develop an add-in to JMP 
that allows some R or Python code to be run as an add-in within JMP, so that 
future users can interact with the GUI add-in without needing to write the R or 
Python code themselves. 

•	 A statistical educator may want to introduce specific open source packages in the 
classroom but within a point-and-click environment that wouldn’t require coding 
by the student.  

Whatever your motivation for connecting open source (or other) tools with JMP 
software’s GUI, this guide will help you to get started using the Python and R 
connections in JMP.¹ 

JMP® and Python
Generating Python Code From a JMP Pro Model

With JMP Pro you can generate Python code for 
predictive models that you create in JMP. This 
is useful when you would like to build, explore 
and compare models in JMP Pro, but deploy them in a different production 
environment. JMP Pro provides an easy way to construct multiple and compare 
competing models, and to even create a model average (ensemble) in the Formula 
Depot platform.

First, fit a model using tools under the Analyze menu 
in JMP. To save the model to the Formula Depot, use 
either the options “Publish Probability Formula” (for 
classification models) or “Publish Prediction Formula” 
(for prediction models). Generally, both can be 
found in the red triangle options for the model results or under “Save Columns.” 

1 �JMP also connects to SAS and Matlab (in addition to R and Python), and JMP also generates C, 
JavaScript, SAS and SQL model scoring code (in addition to Python). To learn more about any of these 
JMP connections, and for even more Getting Started tips and examples, go to jmp.com/support/help/
en/15.1/#page/jmp/extending-jmp.shtml.

https://www.jmp.com/support/help/en/15.1/#page/jmp/extending-jmp.shtml
https://www.jmp.com/support/help/en/15.1/#page/jmp/extending-jmp.shtml
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Once you select that key word “Publish” (or use the “Add Formula from Column” 
option), your model is sent to the Formula Depot. The Formula Depot is a platform 
that allows you to save one or many competing models, compare them, create 
ensemble models and deploy them in a variety of production environments.  

“Generate Python Code” is an option under the red triangle for each individual 
model (i.e., this “Fit Least Squares” model for predicting weight) or under the 
Formula Depot red triangle for generating the code for the entire set of models 
saved in the Formula Depot window.

The resulting Python code, shown below, includes some required dependencies, 
which are called in the first section of the code. The copyright information follows, 
then some Python code to make the variable names and types, and finally the 
formula that will be used to predict the response variable for new observations with 
known values for the predictor variables (in this example, age, height and sex). 

You can read more about this topic at jmp.com/support/help/en/15.1/#page/jmp/
formula-depot.shtml.

https://www.jmp.com/support/help/en/15.1/#page/jmp/formula-depot.shtml
https://www.jmp.com/support/help/en/15.1/#page/jmp/formula-depot.shtml
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The Basics of Connecting JMP and Python

In addition to generating Python model scoring code from within JMP, you can also 
open the connection between JMP and Python and send and receive data and 
results and actions (using a combination of JMP and Python code) between Python 
and JMP. (The JMP and R connection works in the same way.) In order to use the 
Python connection in JMP, you will use JMP Scripting Language (JSL) as a wrapper 
for your Python code.  

Here is a simple example to illustrate. You will need Python² to be installed on your 
machine, but this is standard on most new computers.

(1) Open the Python connection from JMP.

(2) Perform an operation, like sending data from JMP to Python.

(3) �Perform another operation, such as submitting Python code directly to Python  
to create a new variable.

(4) �Perform yet another operation, such as bringing a result or data back from Python 
to JMP (perhaps visualize the result in JMP).

(5) Close the Python connection.

Here is the code for this simple example. To follow along, you’ll first need to open 
JMP. Next, go to File > New > New Script to open a new blank script window. Then 
type the following:

 

In the script above, there are nine pieces of JSL code (indicated in blue). The first 
line helps to ensure that any file or variable references we make will be related to 
this script. Line three of our script, “Python Init();”, opens Python.³ 

2 �python.org.

3 �The details of the Python installation and versioning can be found here: jmp.com/support/help/
en/15.1/#page/jmp/install-python.shtml# and jmp.com/support/help/en/15.1/#page/jmp/troubleshooting-
the-jmp-python-integration.shtml#ww822804.

http://www.python.org
https://www.jmp.com/support/help/en/15.1/#page/jmp/install-python.shtml#
https://www.jmp.com/support/help/en/15.1/#page/jmp/install-python.shtml#
https://www.jmp.com/support/help/en/15.1/#page/jmp/troubleshooting-the-jmp-python-integration.shtml#ww822804
https://www.jmp.com/support/help/en/15.1/#page/jmp/troubleshooting-the-jmp-python-integration.shtml#ww822804
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Line 5,  “dt = Open(“$SAMPLE_DATA/Big Class.jmp”);” asks JMP to open a 
data set that is in the JMP sample data directory and assigns the name “dt” to it.⁴  
The data set in this example is called “Big Class.jmp.” 

Line 7, “Python Send(dt);” sends the “dt” data table from JMP to Python.  
The JMP data table will be transferred to Python as a Pandas data frame. Line 8, 
“Python Submit(“print(dt)”);”, submits some Python code to Python. The 
information inside the quotation marks is the Python script; the rest of the line is the 
JSL code wrapper. It is useful to monitor your code submissions and troubleshoot, 
if needed, by using the JMP log window. Go to the JMP menu bar and choose 
Window  Log to open the JMP log. Here you can see any internal Python error 
messages or results. For example, if we check the log after running this code up  
to this point, we will see the following Python output in the log:

Lines 10-26 include a longer “Python Submit();” statement. This piece of Python 
code, embedded in the JSL code  “Python Submit()” statement, will print the 
column names (in the log) and then create a new column made of the formula 
“lb_inch = weight/height,” before finally printing the new data table, which adds this 
new column to our old data table, in the log:

 Lines 28 and 29 bring back the updated data table to the software’s working 
memory and opens it as a new JMP data table.

 The final line of code, “Python Term();” terminates the connection to Python.

4 �Note that we used a slightly different line of JSL code in the R example to point to an open data file.  
This is another way to point to data, in this case to open a data file, using JSL. 
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A bit of extra fun with JMP – adding an image marker to our graph

While the final section of this simple example does not make any further use of 
the JMP to Python connection, it does illustrate the potential benefits that using 
JMP with Python (or R or other connected software) can bring. Specifically, we 
can interactively work between JMP and Python, taking advantage of running 
prescripted Python code or special Python packages, then improving on our final 
analyses or visualizations by using the dynamic features of JMP.

After bringing the “dt” data table back into JMP, for example, we can use some  
nice JMP visualization features to improve our graphics in just a few clicks or short 
JSL scripts. To illustrate, let’s join our “dt” table with the Big Class Families sample 
data set, available from the Sample Data Library in JMP, to add a column of images 
to our new “dt.” First, open Big Class Families (by clicking on it from Help > Sample 
Data Library > Big Class Families or running the code “dt = Open(“$SAMPLE_
DATA/Big Class.jmp”);”) and use the Tables > Join (or the following script) to 
join the image column to our “dt” table. 

These steps add a column called “picture” to our data set and import the student 
images from the Big Class Families data table into our new combined data table. 
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Now we can build a visualization of the new pounds-per-inch variable, using the 
images as markers in our plot. First, make the image column a marker by clicking  
on the “picture” column and going to Cols > Use for Marker.

In this simple example, we used the JMP to Python connection to open data in JMP, 
send it to Python, create a new column in Python and add the new column to the 
Python pandas data frame, and then bring back the updated data as a JMP data 
table, which we could analyze and further manipulate in JMP.

Additional Simple JMP With Python Examples

You can find a few more simple examples of JMP with Python interactions in the JMP 
Help, under the Scripting Guide  Extending JMP  Working with Python, or by 
visiting jmp.com/support/help/en/15.1/#page/jmp/additional-python-integration-
examples.shtml. 

Here you will find the code for:

•	 Sending a data table to Python.

•	 Creating objects in Python.

•	 Matrix operations in Python.

http://www.jmp.com/support/help/en/15.1/#page/jmp/additional-python-integration-examples.shtml
http://www.jmp.com/support/help/en/15.1/#page/jmp/additional-python-integration-examples.shtml
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JMP® and R
Connecting JMP with the open source software R⁵ easily allows you to take 
advantage of R capabilities along with JMP software’s dynamic and interactive 
approach to analytics and visualization. You can also create easy-to-use menu 
interfaces for R packages and combine elements of JMP and R. These are all 
possible when you have both JMP and R installed on your computer. The R 
functions to perform these connections are listed and described (with examples)  
in the Scripting Index (Help > Scripting Index > R Functions). 

The Basics of Connecting JMP and R

In order to use the R connection in JMP, you’ll need to wrap your R code using  
the JMP Scripting Language (JSL). 

As an example, let’s move some data from JMP to R for an analysis and 
manipulation, then bring it back to JMP. The process is fairly straightforward.  
We’ll write a little bit of JSL code to open R, send data from JMP to R, send the  
R code to R, and bring back data from R into JMP. 

First, make sure that you have both R and JMP installed on the same machine.⁶  

Next, open a scripting window in JMP from File > New > New Script. 

Let’s also open a sample data set in JMP. Go to Help > Sample Data Library  
and open the Fitness.jmp data table. In order to send this to R, we need to use  
two simple lines of JSL. The first line essentially identifies the open data table, 
Fitness.jmp, and renames it “dt.” The second line converts the newly named “dt”  
data table into a matrix format. Because R has slightly different data structuring 
options than JMP, the matrix format is a simple framework that works easily in both 
JMP and R. Next, we call R from JMP. If R is installed on the same machine, JMP will 
find it; you do not need to set up a connection or point JMP to the R installation.  
You only need to type the JSL line “R Init();”. JMP will search for R on the 
machine, and then initialize (or open) it. 

5 �cran.r-project.org.  

6 �The details of the R installation and versioning can be found here: jmp.com/support/help/en/15.1/#page/
jmp/installing-r.shtml.  

http://cran.r-project.org
https://www.jmp.com/support/help/en/15.1/#page/jmp/installing-r.shtml
https://www.jmp.com/support/help/en/15.1/#page/jmp/installing-r.shtml
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Now we’re ready to send information back and forth between JMP and R. The first 
line of the following code sends our matrix version of the data, called dtmat, to R. 
The next line sends R code to be performed in R. 

The line “RlogRunTime<-log(dtmat[,6]);” takes the sixth column of the input 
data matrix (the “Mile Run Time” from this Fitness data set) and log-transforms 
it. Those results will now be called “RlogRunTime” (because that’s the name we 
assigned it in the R code snippet here). 

The line “R Submit(“hist(RlogRunTime)”);” generates a histogram in R, 
which will pop up on your desktop once you run this line of code.

To run the code, select one or more lines (each line must end with “;”)  
and click the “Run Script” button at the top of the script window: 

If we have a multiple-line bit of R code to send through our JSL wrapper,  
we can use “R Submit(EvalInsert(“\[____]\”))” in place of the simple  
“R Submit(“___”)”, as you’ll observe in the following R code, where we use the 
“ggplot2” package in R to create a histogram:
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This “EvalInsert()” is also generally helpful when you need to make substitutions 
or evaluate expressions inside a character string in JSL. For example, we could 
specify the bin width for the R histogram as a variable in the JSL script and then  
call that variable using the “EvalInsert()” code, like this:

Monitor your code submissions and troubleshoot, if needed, by using the JMP log 
window. Go to the JMP menu bar and choose Window  Log to open the JMP log. 
Here you can see any internal R error messages or results.
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Of course, we can also create this histogram in JMP using the Distribution platform. 
We can choose to use JMP functions in two ways, as follows. 

First, we need to bring the “RlogRunTime” back from R to JMP. This section of code 
takes the newly transformed data, called “RlogRunTime” in R, and brings it back to 
JMP, with the new name “JMPlogRunTime.”

We also need to move this new JMP data from the internal memory to a new 
data table in JMP so that we can save it and do further operations on it. The code 
below creates a new JMP data table with one column, composed of the data from 
“JMPlogRunTime.”

We can then choose to use further JMP functions in either of two ways, as follows.

(1) �Operating on the new JMP data table, use JMP functions from the point-and-
click menus. 

In our example, we can use the Analyze > Distribution option to create an interactive 
histogram in JMP. 
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(2) �Use JSL to continue working in a script window to call those same point-and-click 
JMP functions.

If you are familiar with JSL, you can write more JMP actions directly in your script 
window. If you are unfamiliar with the JSL that corresponds to your point-and-click 
actions, you can easily generate that JSL by using point-and-click to create the 
actions once. Then click the red triangle from the results window and choose Copy 
Script to Script Window. To update the script for a new data table, edit the JSL script 
to apply it to the appropriate variable(s). 

Additional Simple JMP With R Examples

You can find more simple examples of how JMP and R work together by searching 
“R” in the JMP Help menu and under the Scripting Guide  Extending JMP  
Working with R. 

 In the JMP Help you will find code for:

•	 Sending a Data Table to R.

•	 Creating Objects in R.

•	 Using R Functions and Graphics.

•	 Simple Matrix Addition in R.

•	 Getting Bootstrapped Confidence Intervals in R.

Advanced Examples

Once you understand the basics around using the JMP interfaces with R and Python, 
you can extend this in interesting and interactive ways.  

Here are links to a few examples: 

JMP to GGPlot Interactive Caller

This script utilizes the JMP connection to R to create smooth-curve density plots⁷ 
with the R package ggplot2,⁸ broken apart by the levels of a grouping variable.  

7 �Note that this type of histogram view is also a native option in the JMP Graph Builder, starting in version 15, 
so the use of R in this example is for illustration rather than necessity.

8 See cran.r-project.org/web/packages/ggplot2/index.html. 

https://cran.r-project.org/web/packages/ggplot2/index.html
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To execute, choose a data file and then open and run this script, which opens a 
dialog box filled with the columns from the open data table. By interacting with  
this prompt, the resulting R plot is created. 

To use this script, you do not need to write the R or JSL 
code. However, if you want to create something similar, 
the underlying JSL (containing snippets of R code) is 
shown here (downloadable from the link to this example):

To learn more, and to download this add-in, visit the JMP Community  
at community.jmp.com/docs/DOC-6472. 

Data Visualization With t-SNE and UMAP Add-In: 

This script, which makes use of the t-SNE and UMAP packages⁹ in R, is made even 
more user-friendly when packaged in a JMP add-in.  

The t-Distributed Stochastic Neighbor Embedding (t-SNE) and Uniform Manifold 
Approximation and Projection (UMAP) are nonlinear dimension-reduction and 
visualization algorithms becoming popular in fields like image processing, text 
mining and genomics. This add-in provides a user-friendly interface to these two 
R packages, enabling data table navigation, data quality control, sparsity handling, 
intuitive parameterization and interactive results interpretation.

9 See cran.r-project.org/web/packages/Rtsne/ and cran.r-project.org/web/packages/umap/.

https://community.jmp.com/docs/DOC-6472
http://cran.r-project.org/web/packages/Rtsne/
https://cran.r-project.org/web/packages/umap/


13

JMP® Synergies

When creating an add-in like this, you simply need one user 
to develop the R or Python code, plus the JSL code that wraps 
around it.  This user would then wrap it all up in a JMP add-in 
using the JMP Add-In Builder.10  The resulting .jmpaddin file 
can either be emailed to other users or posted on the web.11 
This process allows subsequent users to run the add-in without 
needing to write, view or edit the code − instead, interacting 
with the easy-to-use point-and-click display of JMP.

The code that we are not seeing, which is running in the background, begins like 
this (R code is in purple):

10 �To learn more about how to create a JMP add-in from your JSL script, see jmp.com/content/dam/jmp/
documents/en/academic/learning-library/01-add-in-builder.pdf.

11 Post it in our JMP User Community at community.jmp.com so that other users can find it.

https://www.jmp.com/content/dam/jmp/documents/en/academic/learning-library/01-add-in-builder.pdf
https://www.jmp.com/content/dam/jmp/documents/en/academic/learning-library/01-add-in-builder.pdf
https://community.jmp.com
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Once written, subsequent users won’t need to see or interact with this code at all. 
This feature allows you to write it once and wrap it in an add-in. Now you have a 
point-and-click interface to call R or Python functions.

To learn more, and to download this add-in, visit the JMP Community at  
community.jmp.com/t5/JMP-Add-Ins/Data-visualization-with-t-SNE-and-UMAP/
ta-p/177969.

SVM Add-In: 

This add-in calls the svm function from the e1071 R package.12 The user of the SVM 
Add-In interacts with this dialog box to get the resulting SVM13 classification report:

What the user does not see is the code running in the background:

Creating this add-in is even easier using the JMP to R Add-In Builder (see the next 
example). The JMP to R Add-In Builder allows you to skip the JSL coding entirely 
and simply interact with some dialog boxes, dropping in R or Python code in the 
prompt box.

12 �See cran.r-project.org/web/packages/e1071/index.html.

13 �JMP Pro added SVM to the predictive modeling suite in version 15, so, again, this example is illustrative of 
the power of the connection to R but is not needed for JMP Pro 15 users.

https://community.jmp.com/t5/JMP-Add-Ins/Data-visualization-with-t-SNE-and-UMAP/ta-p/177969
https://community.jmp.com/t5/JMP-Add-Ins/Data-visualization-with-t-SNE-and-UMAP/ta-p/177969
 https://cran.r-project.org/web/packages/Rtsne/ and https://cran.r-project.org/web/packages/umap/
https://cran.r-project.org/web/packages/e1071/index.html
 https://cran.r-project.org/web/packages/Rtsne/ and https://cran.r-project.org/web/packages/umap/
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The JMP to R Add-In Builder:  
Using the JMP to R Connection Without JSL

This tool allows users to define and use custom JMP add-ins that execute R 
functions. To use this interface builder, you first need to develop the R code that you 
want to send to R, but you do NOT need to write any JSL code. Similarly, end users 
of your new point-and-click interface will not need to use or see that R code − they 
will just see the easy-to-use, point-and-click interface. (Note: This add-in only works 
on Windows OS, not on Mac.)

This add-in allows you to skip the JSL part of using the JMP with R connection. 
Instead, you’ll interact with a few dialog prompts to create the boxes and buttons 
and prompts that you want to include in your add-in. Most steps are shown here:

The SVM Add-In example above was created using this JMP to R Add-In Builder.

To learn more, and to download this JMP to R Add-In Builder add-in, visit the JMP 
Community at community.jmp.com/t5/JMP-Add-Ins/The-JMP-to-R-Add-In-Builder/
ta-p/43879.

Conclusion
In this guide, we introduced the Python scoring-code generation, the Python  
in JMP scripting, and the R in JMP scripting. We also provided links to further 
examples, including some advanced R examples that make use of the Add-
In Builder feature in JMP. For more information on any of these topics, see the 
footnotes and links provided throughout this paper. If you have questions,  
need help implementing any of these techniques or just want to share a discovery, 
post to our JMP User Community at community.jmp.com. 

https://community.jmp.com/t5/JMP-Add-Ins/The-JMP-to-R-Add-In-Builder/ta-p/43879
https://community.jmp.com/t5/JMP-Add-Ins/The-JMP-to-R-Add-In-Builder/ta-p/43879
https://community.jmp.com
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