1.
[ヘルプ]>[サンプルデータライブラリ]を選択し、「Quality Control¥Steam Turbine Historical.jmp」を開きます。
4.
7.
8.
[構成]>[コンテナの追加]>[H List Box]を選択し、レポートを横方向に並べます。
10.
「アプリケーションビルダー」の赤い三角ボタンメニューから、[アプリケーションの実行]を選択します。
11.
「燃料」「蒸気量」「蒸気温度」「メガワット」の各変数を選択し、[Y]ボタンをクリックします。
12.
[OK]をクリックします。
図14.12 多変量アプリケーション
ヒント: データテーブルのプロパティには、デフォルトでは、データテーブルへの絶対パスが設定されます。サンプルデータをデータとして使った場合、パスに自動的に$SAMPLE_DATAパス変数が含まれます。絶対パスまたは相対パスを入力することもできます。パスは、ユーザにとってアクセス可能でなければなりません。
3.
アプリケーションビルダーの赤い三角ボタンのメニューから[アプリケーションの実行]を選択します。
図14.13 フィルタしたコンテンツの例
3.
リストから、[日付]>[m/d/y]を選択します。
6.
アプリケーションビルダーの赤い三角ボタンのメニューから[アプリケーションの実行]を選択します。
図14.14 日付セレクタの例
「Launcher with Report」サンプルアプリケーションは、プラットフォームの起動ウィンドウとレポートを組み合わせたものです。このサンプルアプリケーションを表示するには、[ファイル]>[新規作成]>[アプリケーション]を選択します。
1.
[ファイル]>[新規作成]>[アプリケーション]を選択し、「Launcher with Report」サンプルをクリックします。
2.
[ファイル]>[新規作成]>[アプリケーション]を選択し、「空白のアプリケーション」をクリックします。
図14.15 アプリケーションのカスタマイズ
3.
[Scripts]タブをクリックし、「名前空間」のリストから「Radviz」を選択します。
dt = Current Data Table();
このアプリケーションに追加するスクリプトの中には、dtを参照してデータテーブルを特定するものがあります。
5.
「オブジェクト」ペインで「Module1」を選択します。
図14.16 LaunchModuleのカスタマイズ
7.
[LaunchModule]タブをクリックし、V List Box(「コンテナ」の下)をワークスペース上にドラッグします。
図14.17 H List Boxの追加
11.
いろいろな変更を加えたので、ここで[ファイル]>[保存]を選択して保存しましょう。このときファイルの名前を変更できます。ファイルの種類として.jmpappsourceが選択されていることを確認します。
5.
「オブジェクト」ペインで「DataTable1」を選択します。
図14.18 Panel Boxの追加
メモ: Panel Boxは、図14.18 にあるH List Boxにドラッグします。
図14.19 Col List Boxの追加
図14.20 Panel Boxの追加
図14.21 キャンセルボタンの追加
11.
右クリックし、[隅に移動]を選択します。
12.
[ファイル]>[上書き保存]を選択し、.jmpappsourceファイルに変更を保存します。
6.
[ファイル]>[上書き保存]を選択し、.jmpappsourceファイルに変更を保存します。
11.
[ファイル]>[上書き保存]を選択し、.jmpappsourceファイルに変更を保存します。
6.
[ファイル]>[上書き保存]を選択し、.jmpappsourceファイルに変更を保存します。
図14.22 「Iris.jmp」のグラフ
3.
Windowsの場合は、[ファイル]>[名前を付けて保存]を選択し、「ファイルの種類」で「JMPアプリケーションファイル」を指定し、[保存]をクリックします。
Macintoshの場合は、[ファイル]>[書き出し]を選択し、「JMPアプリケーション」を指定し、[次へ]をクリックしてアプリケーションを保存します。
4.
「.jmpapp」ファイルを他のユーザに配布します。このファイルは変更ができません。
5.
アプリケーションを「.jmpappsource」ファイルとして保存すれば、編集を加え、JMPアプリケーションとして保存し直すことができます。
図14.23 スクリプトをインタラクティブに追加する
Button5Press=Function({this},
// This function is called when the button is pressed
name = this << Get Button Name;
);
プレースホルダースクリプトに、独自のJSLを書き込みます。先ほど作成したアプリケーションでは、2つの変数に「SetY」「ColumnList」という名前をつけました。プレースホルダースクリプトを次のように書き換えています。
SetY = Function({},
// This function will be called when the Y button is
// pressed
 
items = ColumnList << Get Selected;
YList << Append(items);
);
Get Selectedは、ColumnListに渡されます。なぜなら、オブジェクトの「プロパティ」ペインでCol List BoxにColumnListという変数名を付けたためです。Get Selectedは、選択されている列のリストを戻します。Append(items)は、選択されている列をYList(「Cast Selected Columns into Roles」パネルのCol List Box に割り当てられた変数)に追加します。