Windowsでは[ファイル]>[新規作成]>[アドイン]を選択します。
Macintoshでは[ファイル]>[新規]>[アドインの新規作成]を選択します。
ダッシュボードビルダーでは、赤い三角ボタンのメニューから[スクリプトの保存]>[アドインへ]を選択できるようになっています。
まず、[一般情報]タブで、アドインの識別と設定に必要な一般情報を入力します。
図14.24 アドインビルダーの[一般情報]タブ
これがアドインの登録名となり、[表示]>[アドイン]のウィンドウに表示されます。
一意のID文字列では、大文字と小文字が区別されます。一意であることを確実にするため、DNS名の逆(たとえばcom.mycompany.myaddin)を使用することを推奨します。ID文字列は、次の要件を満たす必要があります。
6.
(オプション)アドインを保存後にインストールする場合は、[保存後にインストール]のチェックボックスにチェックを入れます。
1.
[メニュー項目]タブをクリックします。
図14.25 アドインビルダーの[メニュー項目]タブ
2.
(オプション)[サブメニューの追加]をクリックします。
3.
サブメニューを追加するときは、[メニュー項目名]の隣にサブメニューの名前を入力します。
この名前が[アドイン]メニューに表示されます。
4.
[コマンドの追加]をクリックします。
5.
[メニュー項目名]の隣にアドインコマンドの名前を入力します。
6.
(オプション)ツールヒントを表示させたい場合には、「メニュー項目のツールヒント」の横に、ツールヒントのテキストを入力します。このテキストは、ユーザがメニュー項目の上にカーソルを置いたときに表示されます。
7.
スクリプトを追加します。[このJSLを実行]を選択し、スクリプトをコピーして貼り付けるか、[ファイルのJSLを実行]を選択し、[参照]をクリックしてスクリプトを含むファイルを選択します。
8.
(オプション)すべての非修飾のJSL変数がHere名前空間に含まれ、該当のスクリプトに対してのみローカルとなるようにするには、[非修飾のJSL変数名に“Here”名前空間を使用]を選択します。
メモ:  
Here名前空間の詳細については、「プログラミング手法」章の「高度な適用範囲指定と名前空間」を参照してください。
9.
(オプション)必要に応じて、アイコンを追加します。ここで設定されたアイコンは、[アドイン]メニューのメニュー項目の横に表示されます。
12.
[保存]をクリックし、アドインを任意のディレクトリに保存します。
13.
[閉じる]をクリックします。
[開始時のスクリプト]タブでは、JMP(とアドイン)の起動時に実行されるスクリプトを設定できます。既存のスクリプトを選択するか([ファイルのJSLを実行])、スクリプトをコピーして貼り付けます([このJSLを実行])。たとえば、起動の直後にアドインがインストールされていることを知らせるメッセージを表示できます。
[終了時のスクリプト]タブでは、JMPの終了時、または、アドインを無効にしたときに実行されるスクリプトを設定できます。既存のスクリプトを選択するか([ファイルのJSLを実行])、スクリプトをコピーして貼り付けます([このJSLを実行])。たとえば、アドインを終了するとき、または無効にするときに、開いているJMPデータテーブルを保存するかどうかを確認するプロンプトを表示できます。
いずれかのタブの[保存]ボタンをクリックすることで、アドインを保存します。この操作により、アドインのファイルが作成されます。
[一般情報]タブで[保存後にインストール]オプションが選択されている場合は、すぐに[アドイン]メニューにアドインメニュー項目が表示されます。
[保存後にインストール]オプションが選択されていない場合は、保存したアドインファイルを開いたときに、インストールするかどうかを確認するプロンプトが表示されます。
1.
2.
アドインを選択して、[登録解除]をクリックします。
3.
[ファイル]>[開く]を選択するか、.jmpaddinファイルをダブルクリックして、アドインを再インストールします。