Appendixes | Appendixes | Trouble Shooting

Trouble Shooting
This troubleshooting guide can help you diagnose and resolve problems that you might encounter when running JMP Life Sciences software. If problems persist after troubleshooting, contact JMP Technical Support at support@jmp.com. Select Genomics > Documentation and Help > Contacting Technical Support or Clinical > Documentation and Help > Contacting Technical Support in JMP, for additional information.
The message: Existing Client Found is displayed in the Install Shield Wizard window, indicating that a preexisting copy of SAS has been found on a network server.
A pre-existing copy of SAS has been found that is configured to run as a thin Client from a network server. JMP Genomics and JMP Clinical will work with a personal copy of SAS loaded on the same Client machine only and configured to work locally.
Contact JMP Technical Support (support@jmp.com) for instructions and assistance in resolving this problem.
3
Click Open License.
1
Click Start > Programs > SAS > SAS 9.3 License Renewal & Utilities > Renew SAS Software to open the renewal tool.
4
Click OK in the confirmation window.
The Starter window(s) does not appear and the menu bar lacks either the Genomics and/or Clinical menu(s)
2
Click View > Add-Ins... to open the Add-In Status window.
3
Select the Add-In to be activated and check the Enable check box.
4
Connecting to a SAS server using the File > SAS Server Profiles > Select Profile.
A JMP Alert window appears, displaying the following message:
This error is caused by having a 32-bit Java Runtime Environment is installed on a 64-bit machine. It is most frequently seen after adding a server profile using the File > SAS Server Profiles > Add Profile process on a 64-bit machine containing a fresh install of JMP Clinical.
Select and download the Windows Offline (64-bit) Java plug-in.
Make sure that the SDD URL, specified using the Configure Life Sciences Settings process, is correct. Click File > Life Sciences Settings and click the Integrations tab to inspect the specified URL. Correct if necessary.
Microsoft Word uses a Smart Quote feature that converts quotation marks from the format needed by SAS into a format more appropriate for English language text.
There is also the possibility of a bug in the SAS macro code. If you have found what appears to be a bug, please send the SAS log and explanation to support@jmp.com. Please describe your procedure in sufficient detail for us to reproduce the problem. If you are a SAS programmer, you might wish to view and even edit the original SAS code in the ProcessLibrary and/or MacroLib folders.
A WARNING dialog appears, telling you that SAS is connected and a process is already running.
JMP can run one only process at a time and does not queue jobs. Click OK in the dialog to wait, disregard the second Run, and let the current process continue running. Click View Log to view the current SAS log to get information about the current process. Click Stop to stop the current process. If the SAS process does not stop in a short period of time, it is okay to kill the sas.exe process directly from Windows Task Manager, and then click Stop again.
1
Click Run again. A WARNING: SAS is Connected window should appear.
2
Click View Log. If any SAS ERROR messages appear, click Stop to stop the current process. If not, proceed to the step below.
3
View the SAS log that is displayed in the JMP Log window to see the most recently executed code. You can continue to click View Log as many times as you like to check the status of the SAS program. Alternatively, you can monitor generated file activity in the SAS working folder. To open this folder while the analysis is running, click Open SAS Temporary Folder. You should see various files being generated as the process runs. On Windows, press F5 to refresh the folder while you are monitoring it.
4
Open the Windows Task Manager (press <Ctrl+Alt+Delete>), select the PROCESSES tab and watch sas.exe for activity (Click View>Select Columns... to add I/O Reads, I/O Writes, and I/O Other as columns to view).
2
Double-click on the sasclean.jsl script in the folder.
An ERROR message is displayed stating: User does not have appropriate authorization level for library OUTLIB.
This message is most frequently generated when certain general directories, such as the Desktop or My Documents, are specified as the output folder. To resolve this problem, specify another directory as the output folder and run the process again.
In either of these cases, an alternative way to debug the process is to open the .sas file in the SAS 9.3 Display Manager (right-click and select Open with SAS 9.3) and run it from there by pressing F3. The SAS Display Manager provides options for saving or deleting sections of long logs. On Windows operating systems, you can alternatively right-click on a .sas file and select Submit to SAS 9.3.
Numerous ERROR messages are generated in the SAS log.
3
Reduce the number of variables using K-Means Clustering, as follows. Transpose the data to tall form using Transpose Rectangular, run K-Means Clustering to generate a few thousand or fewer clusters, retain representatives from each cluster to use as the data, and then transpose back to wide form using Transpose Rectangular.
Opening a data file using the File > Open command in any JMP Genomics/Clinical process
The column names listed in the Available Variables box of a dialog appear different from the original column names in the data set.
SAS uses two ways to name a column: the variable label and the variable name. When a file is opened using the File > Open command from the JMP menu, SAS variable labels are displayed. These might differ from those displayed in the Available Variables list in the JMP process dialogs, which display SAS variable names for the available variables.
To solve the problem, open the data file using the Open button on the process dialogs. This displays the table with names the same as those in the Available Variables lists.
Alternatively, use the File > Open command from the JMP menu and, in the Open Data File dialog, change File of type to SAS Data Sets and click the Use SAS Variable Names for Column Names check box.
An ERROR message, indicating that the specified EDF does not exist, is generated.
This message has been observed when an .xls file has been specified as the EDF if either the EDF is open in Excel or has been saved using a legacy (Excel 4.0 or older) format. To resolve this problem, first make sure the file is not open. Second, open the file in Excel and save it in the most recent format. Alternatively, open the file in JMP and save it as a SAS data set using the command File > Save As SAS Data Set.
An ERROR message is displayed stating: The macro variable name is either all blank or missing.
Files selected on the Library Files tab have been mis-specified. Review your selections and correct as needed.
Agilent Import Engine
Running the process generates a long ERROR message along with a SAS Log and a SAS Message dialog indicating the successful generation of the SAS Data Set, EDDS, and an Annotation data set.
The process has run successfully despite the appearance of the ERROR message. The likely cause of the ERROR message is the presence of non-numeric character strings in numerical columns. For example, Agilent places the string #IND, in empty numeric cells to indicate missing values. When SAS imports the data from these files, it reports an error and replaces the character string with a period (.).
An ERROR message is generated when you try to choose an input data set using the Universal/
To avoid using a UNC formatted path, do not begin navigating to the desired files or folders by clicking on the directories shown in the box on the left side of the Open Data File window, as this formats the resulting path in the UNC. Instead, begin navigating by clicking within the Look in: box at the top of the window. The format of the resulting path (C:\Directory\Subdirectory\file) is acceptable to the BioConductor Expresso process.
An ERROR message is generated when you try to use an EDF generated by the EDF Builder and saved as a text file.
JMPs Text Data File default Import setting for the End of Field is set to Tab and Comma and the export settings preference for the End of Field is set to Comma. If the EDF is saved as a .txt file and the fields end with commas instead of tabs, the format of the EDF is not recognized by the input engines.
A long ERROR message beginning with ERROR: Limit set by ERRORS= option reached. Further errors of this type will not be printed.
You should check the initial data format before importing the data. Select File > Open. An Open Data File window opens. Select Text Import Preview from the Files of Type drop-down menu and click Open. Count the columns listing information and the columns listing SNP genotypes.
*
Complete the General and Option tabs of the dialog, as normal.
*
Type Column1-Columnxx (SNP1-SNPyy) ($) in the List of Variable Names and Types field on the Wide Data tab of the Import Individual Txt, CSV, or Excel Files dialog.
Note: xx indicates the right-most column containing non-marker information (assumes that marker information begins in columns xx+1); yy indicates the total number of columns containing marker information.
Note: This fix assumes that your data is in the wide format.
Any Import process
A SAS log is displayed in your JMP Genomics session along with a message preceded by ERROR or there are notes in the SAS log indicating invalid data for particular variables.
When importing a file to a SAS data set, SAS determines the type of variable (character or numeric) based on the first N observations, where N is the value provided in the Number of Rows to Scan parameter on the Options tab of most of the
Import processes. Sometimes, when a character value is present after the first N observations and the previous observations have all been numeric (so that the variable has already been defined as numeric), an error occurs when SAS attempts to read this character value.
Try increasing the value for N in the Options tab until you no longer see these notes in the log.
When importing a file to a SAS data set, SAS determines the length of variable (character or numeric) based on the first N observations, where N is the value provided in the Number of Rows to Scan parameter on the Options tab of most of the Import processes. Sometimes, when subsequent values are longer than those in the first N observations, SAS truncates those values to the length determined for the N observations.
You have saved the heat map with sample information under Compare Variables to a journal and closed JMP Clinical. When you open the journal, the sample information heat map displayed to the right of the main heat map does not display normal colors.
Note: This report cannot be run on machines running English-language operating systems if specified filters contain double-byte character sets (DBCS).
An error exists in the underlying JMP Clinical code. The code in these versions reads: random Bi ~ binary(P) subject = s monitor =(Bi);. Instead, this line of code should be: random Bi ~ binary(P) subject = e monitor =(Bi);. This bug has been corrected in JMP Clinical v5.1. You should update JMP Clinical to v5.1.
The following ERROR message is generated: ERROR: File OUTLIB.COMP_BIN_RANDOM_BY_MST_SBG cannot be update because its encoding does not match the session encoding or the file is in a format native to another host, such as WINDOWS_64.
The following ERROR message is generated: ERROR 180-322: Statement is not valid or it is used out of proper order.
Copy the catalog sasmacr.sas7bcat into the folder: C:\Program Files\SASHome\JMP\10\LifeSciences\MacroLib.
The results of TMM Normalization might be incorrect. There is no error message to indicate that this has occurred.
To fix this problem, open web browser and navigate to the JMP Problem Note 49141 page and follow the instructions to download and deploy a patch file.
The following ERROR message is generated: NEWRAP Optimization cannot be completed.
To remove selected rows, open the Statistics for Rows process and select either NZERO or NMISS as the Statistics to Compute. Specify selection criteria in the Delete rows satisfying this expression text field and run the process to delete the rows meeting the specified criteria.
Incorrect p-values are reported.
The ANOVA process can report -log10 p-values of 300 for tests in which the F test and t-test statistics are missing. The test statistics might be missing because the model failed to converge. In cases where the F test or t-test statistics are missing, the-log10 p-values are incorrect.
You should replace the MixedModelMacros.sas file to resolve this issue.
To fix this problem, open web browser and navigate to the JMP Problem Note 49354 page and follow the instructions to download and deploy the patch file.
After running an ANOVA or One-way ANOVA the following ERROR message is generated when you click Create a Subset with Mean Difference and P-Value Criteria, and choose a single comparison: Note: There is no significant difference found. You can change the cutoff values and recreate the subset table.
In the Radial Basis Machine predictive modeling process, the prior probabilities are calculated incorrectly when you include a test data set and set the Prior Probabilities / Prevalences option to Equal. This problem does not occur when you specify proportional priors, or when you omit the test data set.
To fix this problem, open web browser and navigate to the JMP Problem Note 47838 page and follow the instructions to download and deploy a patch file.
Any Workflow process
Attempts to run a second process or new Workflow fails. The JMP Log shows the following message: A second script is attempting to execute, possibly during a nested click event. It may be necessary to press Escape to terminate the previous script.
Press Esc to exit the JMP Script.
The following error message is surfaced: [Microsoft] [ODBC Excel Driver] Cannot modify the design of table 'Abrasion’. It is in a read-only database.
1
Click Start > Settings > Control Panel.
2
Double-click Administrative Tools.
3
Double-click Data Sources(ODBC) to open the ODBC Data Source Administrator dialog.
4
Select Excel Files in the Use Data Sources panel and click Configure... to open the ODBC Microsoft Excel Setup dialog.
5
Click Options and uncheck the Read Only check box.
6
Click OK on the open dialogs.
Files in the SAS Home directory cannot be deleted after running the Uninstaller.
2. Double click SASxxx to open the panel, highlight, and copy the service name.
3. Open the Starter window, and enter cmd in the text box and click Enter to open a command prompt.
4. At the prompt, type sc delete SASxxx and click Enter to delete SASxxx.
Note: You should delete all the SAS services before uninstalling SAS.