Using JMP > Reshape Data > Virtually Join Data Tables > Example of Merging Referenced Data in Virtually Joined Data Tables
Publication date: 10/01/2019

Example of Merging Referenced Data in Virtually Joined Data Tables

To share the data from virtually joined data tables with another user, you might want to merge the data so that the data tables are permanently joined. This option is helpful because you provide one data table, not the main and auxiliary data tables.

When you merge referenced data, the data are replicated from the auxiliary data table to the main data table. When you save the main data table, the actual data are also saved.

1. Select Help > Sample Data Library and open Pizza Profiles.jmp and Pizza Responses.jmp.

2. Right-click the ID column in Pizza Profiles.jmp and select Link ID.

3. Select the Choice1, Choice2, and Choice2 columns in Pizza Responses.jmp and then select Link Reference > Pizza Profiles.jmp.

The selected columns are linked to the ID column in Pizza Profiles.jmp.

Figure 6.40 Selected Column in Virtually Joined Data Table 

4. In Pizza Responses.jmp, select the Choice1 column if it’s not already selected.

Note: If you do not select the columns, then all columns will be in the merged data.

5. Click the red triangle next to the name of the data table and select Merge Referenced Data.

Figure 6.41 Merging Referenced Data 

A message confirms that the selected column was merged. Notice that the blue virtual join icon for Choice1 no longer appears in the Column list. The Link Reference column property was removed.

Figure 6.42 Merged Data 

If you place your cursor over one of the linked columns in the Columns panel, a tooltip indicates which data table that it is linked to.

Figure 6.43 Data Table that Contains the Linked Column 

Want more information? Have questions? Get answers in the JMP User Community.