Publication date: 10/01/2019

General

Most General preferences customize your JMP session at start-up. Others set preferences for file handling and the general appearance of the JMP workspace.

Figure 13.1 General Preferences 

Table 13.1 Preferences on the General Page

Preference

Description

Show Tip of the Day at startup

Select this option to show the Tip of the Day window at start-up. This option is selected by default.

Clear this option to prevent the Tip of the Day window from appearing at start-up.

Initial Splash Window

Select this option to show the initial splash window at start-up. This option is selected by default.

Clear this option to prevent the initial splash window from appearing at start-up.

Initial Log Window

Select this option to open the log when JMP opens.

Initial JMP Starter Window

(Mac only) Select this option to show the JMP Starter window every time you start JMP. This option is on by default.

Initial JMP Window

(Windows only) Select one of the listed windows as the default window. When JMP starts, this window appears.

Home Window

(Mac only) Select this option to show the JMP Home window when you start JMP on Mac.

Reopen the initial JMP window on last window close

(Windows only) Select this option to open whichever window you have set as the Initial JMP Window when you close the last JMP window. If this option is turned off, closing the last JMP window also quits JMP.

This option is on by default.

Show menu tips

(Windows only) Select this option to see tooltips on main menu options and options in red triangle menus. This option is selected by default.

Show log warnings for JSL compatibility changes in JMP 12

Select this option to print warnings about JSL compatibility to the log.

Allow Unquoted Strings in JSL

Select this option to print a warning to the log when a string value in a platform message is unquoted. Quoted string values are preferred over literal names.

Yes (no warning)

Allows unquoted string values and does not print a warning to the log. This option is selected by default.

Yes (warning)

Allows unquoted string values and prints a warning to the log.

No

Ignores the unquoted string value and does not print a warning to the log.

Save Journals GZ Compressed

Select this option to save JMP journals in a compressed format to save disk space.

Clear this option to save journals normally. This option is not selected by default.

Save Data Table Columns GZ Compressed

Select this option to allow JMP to save data tables using GZ compression. For backward compatibility, JMP 10 can read the compressed files but not save them. This option is not selected by default.

Save Scripts in English

Non-English versions of JMP can save scripts in either English or your local language. User-specified values (such as column names and text strings) in these scripts appear as they do in the data table. However, command words (such as Distribution and Set Value) appear in English rather than the local language in order for the script to run on JMP in English. JMP properly displays non-Roman characters (such as Japanese variable names) in JMP in English when the fonts support the necessary characters.

Select this option to save scripts in English no matter what language JMP is using.

Clear this option to save scripts in your local language. Note that these scripts run correctly only if JMP is running in the same language. This option is selected by default.

Display indexes in English

Shows sections of the JMP Indexes in English or the current locale’s language. The preference is selected by default. When you deselect it, the following items are displayed in the current locale’s language:

The message list for objects

The message list for display boxes.

The category list for JSL functions.

Note: The description of each index item is always displayed in the current locale’s language. Examples are always in English.

Report Invalid Display Box Messages

Sends information about invalid display box messages to the log. This option is off by default.

This option can be useful during script development, but can cause unwanted log messages for existing scripts.

Add files opened by scripts to the Recent Files list

(Windows only) Select this option to include files opened by the JSL Open() command in the Home Window Recent Files pane and the File > Recent Files list.

Autosave Timeout

Automatically saves the contents of opened data tables, journals, reports, projects, and scripts except for untitled files at the specified interval. The default value is 0 minutes, which indicates no autosave.

Autosave Maximum Data Table Rows

Autosaves data tables if the number of rows does not exceed the specified value. 10,000 is the default value.

Autosave Maximum Data Table Columns

Autosaves data tables if the number of columns does not exceed the specified value. 1,000 is the default value.

Save the session when exiting

This option enables you to save the state of the JMP window when existing JMP. When opening JMP, the saved state is restored, including any open files and windows.

Want more information? Have questions? Get answers in the JMP User Community.