Using JMP > Import Your Data > Import Data from SAS > Run Stored Processes
Publication date: 10/01/2019

Run Stored Processes

Stored processes are SAS DATA step code saved on the SAS server that you are connected to. You can run them from JMP and see the results of the script in JMP.

Note: Depending on the preferences that you have set for SAS, error messages are sent either to the JMP log or to a separate SAS log window.

You must be connected to a Metadata Server to view and run stored processes. If you select File > SAS > Browse SAS Folders without such a connection, you are prompted to either make a connection or cancel your action.

To select and run a stored process

1. Select File > SAS > Browse SAS Folders.

The Browse SAS Folders window appears.

2. Browse through the stored processes to find the one that you want to run.

3. Select it and click Run.

The data opens as a JMP data table.

On Windows, you can also right-click a stored process and select Copy Metadata Path. This option copies the path to the clipboard. You can then paste it into a script window to include it as a parameter for the JSL operator Meta Get Stored Process(). See Meta Get Stored Process("path") in the JSL Syntax Reference.

Note: Static graphs might not appear in the results returned from a SAS stored process when streaming output is selected.

Stored processes send reports to HTML by default, but you can select RTF or PDF instead on the SAS Integration page of the JMP preferences. Select File > Preferences (Windows) or JMP > Preferences (macOS) to view the JMP preferences.

Want more information? Have questions? Get answers in the JMP User Community.