Using JMP > Save and Share Data > Copy and Paste Reports
Publication date: 08/13/2020

Copy and Paste Reports

When you need to use JMP reports or data tables in another program, you can paste or drag parts of a report or table into another program. For example, you might want to send a colleague a copy of a JMP report in a Microsoft Word file.

1. Click the selection tool .

2. Click and drag (or hold down the Shift key and click) to select items in a report window or data table. Clicking near the edge of the report window selects the entire report.

3. Click the selected items and drag them from JMP to the other program. Or, copy the selected items in JMP and paste them into the other program. When you paste an element into another application, the format used depends on the application into which you paste. If you use the applications’ Paste Special command, you can select a format to use, such as text (.rtf), unformatted text (.txt), or bitmap (.bmp).

Notes:

To copy all text (no graphs) from the active report window as unformatted text, select Edit > Copy As Text. On macOS, select Paste > Special in Microsoft Word or Paste and Match Style in other macOS apps.

To copy a graph, which includes labels and axes, right-click the graph and select Edit > Copy Graph.

To copy anything other than a graph, right-click and select Edit > Copy Picture. For example, to copy a report, right-click the bar containing the report title and select the option.

To copy text from a text box onto the clipboard, right-click the text and select Copy Text.

To copy text from one column onto the clipboard, right-click the column and select Copy Column.

To copy and entire table onto the clipboard, right-click the table and select Copy Table.

The Reports preference Transparent background in report PNG images determines whether reports that are saved as PNG images have transparent backgrounds. The preference is deselected by default.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.