Publication date: 08/13/2020

Example of Creating an Application

Application Builder helps you create instant applications without writing JSL. One example is a JMP window in which you arrange reports, graphs, and other objects to make them easy to interact with at once.

This example shows how to create a simple instant application for a Distribution report. This application lets you analyze preselected variables rather than having to select them in a launch window.

1. Select Help > Sample Data Library and open Big Class.jmp.

2. Run the Distribution table script to generate the report.

3. Select File > New > Application (or File > New > New Application on macOS).

4. Click the Blank Application box.

A new blank application appears. Notice the Distribution report in the left column.

Figure 16.2 New Application with Distribution Report in the Sources PaneĀ 

5. In the Sources pane, drag the Distribution report onto the application workspace (the blank area on the Module1 tab).

6. Click the Application Builder red triangle and select Run Application.

The Distribution report appears in a new window. Note that the histograms are interactive and still associated with the data table. When the data changes, you run the application again, and the Distribution report is updated.

Figure 16.3 Example of an Instant ApplicationĀ 

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.