Publication date: 08/13/2020

Filter Data

Use the Data Filter to interactively select complex subsets of data, hide these subsets in plots, or exclude them from analyses. For example, look at profit per employee for computer and pharmaceutical companies.

1. Select Help > Sample Data Library and open Companies.jmp.

2. Select Analyze > Distribution.

3. Select profit/emp and click Y, Columns.

4. Click OK.

5. Click the red triangle next to profit/emp and select Display Options > Horizontal Layout.

Figure 3.16 Distribution of profit/emp 

6. Turn on Automatic Recalc by selecting Redo > Automatic Recalc from the Distributions red triangle.

When this option is on, every change that you make (for example, hiding or excluding points) causes your report window to automatically update itself.

7. In the data table, select Rows > Data Filter.

8. Select Type and click Add.

9. Make sure that Select is selected.

10. To filter out the Pharmaceutical companies from the Distribution results, and include only the Computer companies, click the Computer box in the Data Filter window.

The distribution results update to only include Computer companies.

Figure 3.17 Filter for Computer Companies 

Conversely, to change the Distribution results to include only the Pharmaceutical companies, click the Pharmaceutical box on the Data Filter window.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.