Using JMP > Import Your Data > Import SPSS Files
Publication date: 08/13/2020

Import SPSS Files

JMP opens SPSS files as data tables and maintains several SPSS features:

General numeric and character data with minimal formatting are supported.

SPSS date, datetime, and time formats are supported.

By default, labels are converted to column headings. When you select this option, and the data contains no labels, the columns are named Column 1, Column 2, and so on.

You also have the option of selecting the conversion method for column headings when opening an SPSS file. The method that you select then overrides the preferences.

To change the default conversion method, select File > Preferences (or JMP > Preferences on macOS). On the General page, deselect Use SPSS labels for column names during import. Variable names are then imported automatically as column headings.

The value labels that you defined in the SPSS file are saved as Value Labels column properties. The value label then appears in each data table cell instead of the original value. For more information about Value Label properties, see Value Labels in the The Column Info Window section.

SPSS can assign certain values in a variable to be treated as missing for analyses. For example, the value 64 could be regarded as missing for a Height variable. Then, the calculation of the distribution of height would ignore values of 64. When you import SPSS into JMP, these values are included in the Missing Value Codes column property for the appropriate variable.

Missing value ranges of up to 20 numbers are supported. If the range begins with a negative number, the numbers count down to the maximum value (for example, -10 through -5). If the range begins with a positive number, the numbers count up from the minimum value (for example, 1 through 12).

Custom currency formats selected in an SPSS file are not maintained on import. In addition, JMP does not read SPSS data that contains double-byte characters, such as non-Unicode Japanese characters.

Note: As with importing other files, you might experience a delay when opening and saving large SPSS files.

To open an SPSS file (Windows)

1. Select File > Open.

2. From the list next to File name, select SPSS Data Files (*.sav).

3. Select the SPSS file.

4. (Optional) To specify the column headings, select one of the following Set JMP column names from options:

SPSS Labels creates column headings from SPSS labels.

SPSS Variable Names creates column headings from variable names.

5. Click Open.

JMP opens the file as a data table.

To open an SPSS file (macOS)

1. Select File > Open.

2. Select the SPSS file.

3. (Optional) To specify the column headings, do one of the following

Deselect Use SPSS Labels as Headings to convert variable names to column headings.

Select Use SPSS Labels as Headings to convert labels to column headings.

4. Click Open.

JMP opens the file as a data table.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.