Using JMP > Get Started > Manage JMP Files and Open Windows
Publication date: 08/13/2020

Manage JMP Files and Open Windows

The JMP Home Window provides instant access to open window and files. Opening recently opened files, closing windows, and pinning frequently used files are a few of the options.

JMP Home Window on Windows

On Windows, the JMP Home Window appears when you open JMP.

Open recent files in the Recent Files list or pin a frequently used file.

Right-click files in the Recent Files list to perform common tasks.

Open or close active JMP windows in the Window List.

Set an open data table as the current data table by selecting it from the data table list at the top.

Figure 2.14 JMP Home Window Actions 

JMP Home Window Buttons

On Windows, the JMP Home Window panels can contain the following buttons:

The Open Selected button opens the selected files in the Recent Files list.

The Sort By Name button sorts recent files alphabetically.

The Filter button filters the types of files that appear in the Recent Files and Window List panels.

Enlarges the font size and icon size of items in the Recent Files list.

The Close button closes the panel.

Recent Files

On Windows, the Recent Files list provides quick access to files that you recently opened.

Keep your favorite files at the top of the list for quick access. Place your cursor over the filename and click the pin icon . To unpin a file, click the pin icon.

You can drag files from the Recent Files list as follows:

into the JMP Window List to open the file

into a Windows folder or on to your desktop to create a copy of the file

into applications such as Microsoft Notepad or Microsoft Word to edit the file

Right-click files to access the following options:

Open a file

Copy the location path to a file

Open a file within the folder that contains it

Sort files alphabetically by name or by most recent

Remove a selected file or files from the list

Remove a file or files that are no longer in the same location (Alternatively, you can select the files and press the DELETE key.)

(JSL scripts) Edit, run, or debug a script

(Text files) Change the import method or open as plain text

(SQL queries) Run an SQL query that you saved in Query Builder. You can also create a new query using an existing query as a template.

Run or edit a JMP application

When you open a non JMP file from the Recent Files list, JMP applies your import preferences to arrange the data. You can right-click a text file to change the import method or to open the file in a text editing window. Your import preference is bolded in the pop-up menu.

Tip: To prevent files that were opened by a script from appearing in the Recent Files window, select File > Preferences > General and de-select Add files opened by scripts to the Recent Files list.

Search the Recent Files List for JMP Files

To find a recently opened file in a long list of files, enter part of the file name in the Recent Files Filter box.

The following options are provided:

Enter part of the file name in the Filter box above the list of files.

Place your cursor over the Filter box to view search tips.

As the files are filtered, the Up and Down arrow keys change the selected file. Press Enter to open the selected file, or select the file with your cursor.

If a file is selected in the Recent Files list, press Ctrl and then F to activate the Filter box.

Press Esc or click the X button to exit the filtering mode after you typed a search term.

Window List

On Windows, the Window List shows open JMP windows, such as data tables, reports, and scripts. You can open, close, rearrange, and hide JMP windows.

If you place your mouse pointer over a file in the Window List, a thumbnail appears.

To open the Window List in its own window, select View > Window List.

To display windows side-by-side, right-click the selected windows and select Arrange.

To always automatically display the Window List inside maximized windows, select File > Preferences > Windows Specific and select Dock the Window List in maximized windows.

Right-click files to access the following options:

View a window

Close a window (Alternatively, you can select files and press the DELETE key.)

Close all windows except the currently selected window (if the selected window is a report window, the dependent data table also remains open)

Move a window to the back

Hide a window from the Windows taskbar or unhide a window

Select all windows, or clear all selections

Note: The active file is formatted with bold text.

Rearrange Panels in the Home Window

To rearrange the panels in the Home Window on Windows, click and drag the title bar of the panel. Drop the title bar onto a top, bottom, left, or right arrow to position the panel. A blue box indicates where the panel will be placed. To turn the panels into tabs, drag and drop any panel into the middle of the Home Window.

Tips:

To put the Home Window back into its original order, select View > Home Window Panes > Revert to Factory Layout.

If you close a panel and want to reopen it, select View > Home Window Panes and select the panel that you want to open.

Open the JMP Home Window by selecting View > Home Window or clicking the JMP Home Window button in the lower right corner of most JMP windows. If you cannot see the JMP Home Window button, select View > Status Bars.

If you prefer to see the JMP Starter or the Window List upon start-up, you can specify that in the Preferences (Windows only). Select File > Preferences > General and select an option from the Initial JMP Window list.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.