Publication date: 08/13/2020

Options for Saving Applications

JMP provides several options for saving application files.

When you select File > Save As on Windows, you can save the application as an application source file (.jmpappsource), an application (.jmpapp), or a script.

Selecting File > Export on macOS enables you to save the application as an application file or a script. To save the application as an application source file on macOS, select File > Save As.

The .jmpappsource file allows an application developer to save the application as is, in order to continue editing the application later. When reopened, the App Builder interface remains in same state as when it was saved. The data tables used to create the application must still be available.

The .jmpapp file is used to distribute applications for others to use. The application runs immediately after opening the file. The application resolves the data tables using the current data tables, files on disk, or by prompting the user, depending on the application settings.

The Save Script red triangle menu provides additional options for saving scripts. When an encrypted script is saved, JMP encloses the script in the JSL Encrypted() function to preserve white space and comments.

To Data Table

Saves the script to the data table that was used to produce the report. This enables you to run the script again from the data table to recreate the results. When you edit this script from the data table, the application opens in Application Builder, not the script editor.

To Journal

Saves a button that runs the script in a journal. The script is added to the current journal. The script contains the path to the data table. Note that if the data table cannot be found, the script does not run.

To Script Window

Opens a script editor window and adds the script to it. If you have already saved a script to a script window, additional scripts are added to the bottom of the same script window. Note that if you modify the application significantly in a script window, you might not be able to edit the application in Application Builder. This option is useful when you want to embed the application in a larger JSL process.

Tip: This can also be accomplished by saving as a .jmpapp file and using Open() to run the application. However, saving the script can reduce the number of files.

To Add-In

Lets JMP users install the application and launch it from a JMP menu. See Compile Add-Ins with the JMP Add-In Builder.

To Template

Saves the application as a template from which you can create new applications. The templates are saved in the following locations based on your operating system and JMP version:

Windows (JMP): "/C:/Users/<username>/AppData/Roaming/SAS/JMP/<version number>/ApplicationTemplates"

Windows (JMP Pro): "/C:/Users/<username>/AppData/Roaming/SAS/JMPPro/<version number>/ApplicationTemplates"

macOS: "/Users/<username>/Library/Application Support/JMP/<version number>/ApplicationTemplates"

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.