Using JMP > Personalize JMP > Personalize Menu Items on macOS
Publication date: 08/13/2020

Personalize Menu Items on macOS

Customize JMP menus to quickly access files or modify existing menu items. Selecting a menu item runs a JSL script from your computer or executes the JSL commands that you specify. For example, you can create a menu item to open a frequently used script. This option is an alternative to adding the script as a favorite on the Home Window.

Features include adding and renaming menu items, hiding menu items, inserting menu item separators, and associating a menu item with JSL.

JMP customizations are stored in <username>/Library/Application Support/JMP/15/usercust.jmpcust.

Note: You cannot delete default JMP menus or delete submenus (which open to reveal other menu items). Default and custom submenus also cannot be renamed.

Example of Adding a Menu Item

In this example, create a menu item that runs a script.

1. Select View > Customize Menus.

2. In the JMP Menu Editor, select File and then Open.

3. Press Control and then select Add New Menu Item after.

4. Type What is the Current Time? in the Menu Label box.

5. Select Run JSL in this file: and select Library/Application Support/JMP/15/Samples/Scripts/timeAnnouncer.jsl.

6. Click Add and close the Menu Editor window.

7. Select File > What is the Current Time?.

The Scheduler window appears, and the current time is spoken.

Example of Adding a Submenu Item

A submenu opens to reveal submenu items. In this example, create a submenu item that opens a data table.

1. Select View > Customize Menus.

2. In the JMP Menu Editor, select File and then Open.

3. Press Control and select Add New Submenu after.

4. Type Open My Data Tables and select JSL Commands.

Note: Selecting JSL Script lets you select a JSL script from your computer.

5. Click Add.

6. Select Open My Data Tables, delete Subitem placeholder in the Menu Label box, and then type Open Napoleons March.jmp.

7. In the Run this JSL box, type Open("$SAMPLE_DATA/Napoleons March.jmp");.

8. Click Save Changes.

9. Select the File menu to see the new menu item.

Tip: If the new menu item appears in the menu but not the menu editor, close the menu editor window and reopen it.

To delete a custom menu or submenu item

Delete one custom menu item by selecting the item and selecting Delete from the options list.

Delete all custom menu items by selecting Revert All from the options list.

To delete items within a submenu, you must delete the entire submenu. Empty menus are not permitted. Select the submenu and select Delete Selection from the options list.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.