Using JMP > Import Your Data > Import Data from Google Sheets > About Importing Google Sheets
Publication date: 04/12/2021

About Importing Google Sheets

Information that Google uses to authenticate your account is stored in C:/Users/<user name>/AppData/Roaming/SAS/JMP/OAuthTokens.jmp. (Your Google password is encrypted.) This enables you to import and export data using the same Google account without providing the authentication information again. Note that a user with access to your computer’s user account has access to all of your Google spreadsheets. If they contain confidential information, reconsider sharing your user account.

@gmail.com is not required for your account name. However, if you do use it, <user name>@gmail.com and <user name> are treated as separate accounts. You must enter the authentication code for both accounts when importing or exporting.

If other users have access to your computer’s user account, they can copy OAuthTokens.jmp to their computer and import your spreadsheets.

If Display intranet sites in Compatibility View in Internet Explorer on Windows is selected, the Google Sheet cannot be imported. To avoid this issue, follow these steps:

1. In Internet Explorer, select the Tools button Image shown here and then select Compatibility View settings.

2. Deselect Display intranet sites in Compatibility View.

Note: In Google Sheets, you can select File > Publish to the web to publish the sheet for an audience to view. In this case, the link to the published sheet includes the pubhtml suffix. Use File > Internet Open to open these sheets. See Import Data from the Internet or a Remote Computer.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).