Using JMP > Save and Share Your Data > Save and Share Data Tables > Save Data Tables as Microsoft Excel Files
Publication date: 04/12/2021

Save Data Tables as Microsoft Excel Files

There are two options for saving data tables as Microsoft Excel files:

Save one data table in Microsoft Excel format (.xls or .xlsx). Data from a single table is saved in a workbook named after the data table.

Generate a workbook in .xlsx format from multiple tables. Data from each table appear on a different worksheet in the workbook.

Saving an .xlsx file retains data table cell colors, hidden data, and excluded data. Formulas and most formatting are not included.

The maximum length of the Excel filename is determined by your computer’s operating system.

Save One Data Table as a Microsoft Excel Workbook

To save a data table as a Microsoft Excel workbook, follow these steps:

Windows

1. Select File > Export.

2. Select Microsoft Excel and click Next.

3. Enter a name for your file in the File name box.

4. (Optional) To save the file as an .xls file, select Use Excel 97-2003 Format (*.xls).

5. (Optional) To avoid opening the file in the default spreadsheet program after saving, deselect Open the file after saving on the Export window.

6. Click Save.

macOS

1. Select File > Export.

2. Select Microsoft Excel and select the format.

3. Click Next.

4. Enter a name for the file in the Save As box.

5. (Optional) To avoid opening the file in the default spreadsheet program after saving, deselect Open the file after saving.

6. Click Export.

Note: On Windows, data is split among several worksheets when the number of columns or rows exceeds the number that Excel supports.

Save Multiple Data Tables as a Microsoft Excel Workbook

To save multiple data tables in a new or existing Microsoft Excel workbook, follow these steps:

1. Open the data tables.

2. (Windows) Select File > Export > Microsoft Excel, select Export Multiple Data Tables, and then click Next.

3. (macOS) Select File > Export, select Export Multiple Data Tables from the Excel list, and then click Next.

4. In the JMP Data Table column, select only the data tables that you want to save.

5. In the Worksheet Name column, specify the name of the worksheet tab if necessary.

6. Enter a name for the workbook in the Workbook Name box.

The workbook is named after the current data table by default.

7. Click Choose and browse to select a directory to save the file in.

You can overwrite an existing workbook. Worksheets that already exist in the workbook are replaced. Worksheets that are not in the existing workbook appear at the end of the sheets.

8. Click Save (or Export on macOS).

The file is saved as an .xlsx file.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).