Using JMP > Save and Share Your Data > Save and Share Data Tables > Save JMP Data as a SAS Transport File
Publication date: 04/12/2021

Save JMP Data as a SAS Transport File

You can save a JMP data table in SAS transport file format. JMP replaces spaces in filenames and column names with underscores, converts column headings to uppercase SAS variables, and makes other changes to follow the transport file specifications.

When you save the data table as a transport file, you can opt to append it to an existing transport file. When you reopen the transport file in JMP, the two data tables open in separate windows.

Notes:

The maximum length for SAS transport filenames is 8 characters. JMP warns that characters beyond that limit are omitted.

Images in Expression columns cannot exceed 200 characters, otherwise they are not supported.

Windows

1. Select File > Export.

2. Select SAS Transport File.

3. Click Next.

4. Enter the file name in the File name box.

5. Click Save.

6. Click OK.

Alerts appear regarding other SAS format modifications.

7. Click OK on each alert.

8. (Optional) Append the data table to an existing SAS transport file. Select File > Export, select the Append check box, and then click Next. Select the file to which you want to append the data table and then click Save.

macOS

1. Select File > Export.

2. Select SAS Transport.

3. Click Next.

4. Enter a name for the file in the Save As box, and then click Export.

Alerts appear regarding SAS format modifications.

5. Click OK on each alert.

6. (Optional) Append the data table to an existing SAS transport file. Select File > Export, select the Append check box, and then click Next. Select the file to which you want to append the data table and then click Append.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).