Using JMP > JMP Reports > Red Triangle Options in JMP Reports > Save Script Menus in Reports
Publication date: 04/12/2021

Save Script Menus in Reports

After completing an analysis and receiving a report, you might want to save the process that you used to create the report as a JSL script. You do this by selecting an option from the Script red triangle menu. Most of the Save Script options are the same throughout JMP. A few platforms add extra options that are described in the specific platform chapters. The following Save Script menu options are common to all platforms.

To Clipboard

Saves the script to your computer’s clipboard. You can then copy the script to a script or another document.

To Data Table

Saves the script to the data table that was used to produce the report. This enables you to run the script again from the data table to re-create the results. Select this option to save a script to the data table.

To Journal

Saves a link in a journal window that runs the script for the analysis. If a journal window is already open, the script is added to that journal window. The script contains the path to the data table. Note that if the data table cannot be found, the script does not run.

To Script Window

Opens a script editor window and adds the script to it. If a script window is already open, the script is added to the bottom of that open window.

To Report

Adds the script to the top of the report window.

Script All By-Groups

If you specified a By variable in the launch window, the Save By-Group Script menu enables you to save a script for all levels of the By variable to the data table or script window.

In the Save Script menu, To Data Table (All Objects) and To Script Window (All Objects) save a script for all levels of the By variable.

Automatic Recalc

The Automatic Recalc feature immediately reflects changes that you make to the data table in the corresponding report window. You can make any of the following data table changes:

exclude or unexclude data table rows

delete or add data table rows

This powerful feature immediately reflects these changes to the corresponding analyses, statistics, and graphs that are located in a report window.

To turn on Automatic Recalc for a report window, click the platform red triangle and select Redo > Automatic Recalc. To turn it off, deselect the same option. You can also turn on Automatic Recalc using JSL.

Platforms that support Automatic Recalc include a preference in the Platforms preferences.

Note: For some platforms, the Automatic Recalc feature is not appropriate and therefore is not supported. These platforms include the following: DOE, Profilers, Choice, Partition, Nonlinear, Neural, Neural Net, Partial Least Squares, Fit Model (REML, GLM, Log Variance), Gaussian Process, Item Analysis, Cox Proportional Hazard, Response Screening, and Control Charts (except Run Chart).

Column Switcher

Within a report, use the Column Switcher to quickly analyze different variables without having to re-create your analysis. To activate the Column Switcher, from a report window, click the red triangle and select Redo > Column Switcher.

If you have multiple columns, use the buttons to animate the column switching or step through each column manually. Move the slider control to change the speed of the animation.

Note: You cannot copy or move the column switcher within a report. Also, a column switcher cannot be saved to a JMP journal.

Example of the Column Switcher

You have data about nutrition information for candy bars. You want to examine different factors, to see which factors best predict calorie levels.

1. Select Help > Sample Data Library and open Candy Bars.jmp.

2. Select Graph > Graph Builder.

3. Click Total fat g and drag to the X zone.

4. Click Calories and drag to the Y zone.

5. Click Cholesterol g and drag to the Wrap zone.

6. Click the Graph Builder red triangle and select Show Control Panel.

7. Click the Graph Builder red triangle and select Redo > Column Switcher.

8. Select Cholesterol g.

This chooses the initial column to switch.

9. Select Saturated fat g, Cholesterol g, Sodium mg, Carbohydrate g, Dietary fiber g, and Sugars g.

This chooses the replacement columns.

10. Click OK.

Figure 9.6 Column Switcher in Graph Builder Window 

Column Switcher in Graph Builder Window

11. Click the Play button to cycle between the different factors. Use the slider to control the speed of the animation. Alternatively, you can step through each factor individually.

Click the Looping button to specify the behavior of the animation when it reaches the last column in the Columns list.

You can see that the relationship between calories and fat is relatively strong for each level of carbohydrate. Therefore, Carbohydrate g appears to be the best predictor of calorie levels.

Notes:

To keep axis settings constant when switching columns, select Retain Axis Settings from the Column Switcher red triangle menu. This is useful when you have customized an axis, for example, by adding a reference line.

If a report has multiple column switchers, you can adjust the layout of the column switchers using the Layout options in the Column Switcher red triangle menu.

To add new columns, do one of these options:

In the Column Switcher, click the plus button, choose columns, and click OK.

In Graph Builder, drag columns from the Columns list into the Column Switcher list.

From a data table, drag columns from the Columns panel into the Column Switcher list.

To remove columns, click the minus button, choose the columns to remove, and click OK. Or, you can select the column and press the Delete key.

To revert changes, select Reset from the Columns red triangle menu.

The Record and Save buttons in the Column Switcher record the animation and then save it as an animated GIF. This feature is available only on Windows.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).