For the latest version of JMP Help, visit JMP.com/help.


Welcome to JMP > Learn about JMP > Documentation PDF Add-in
Publication date: 07/15/2025

Documentation PDF Add-in

You can download and install the JMP documentation add-in. The documentation add-in contains an individual PDF file of each document in the JMP library and the JMP Documentation Library file. The JMP Documentation Library file is one PDF file that contains all the individual book PDF files, which lets you search all individual books from a single PDF file, similar to the JMP Online Help.

When installed, the documentation add-in adds the Documentation PDFs option to the Help menu and installs the PDF files on your machine. This enables you to access the documentation locally by selecting Help > Documentation PDFs. Download the available documentation add-ins from https://www.jmp.com/doc-addin.

The following table describes the purpose and content of each document in the documentation add-in.

Document Title

Document Content

JMP Documentation Library

Provides one PDF file that includes the other individual JMP documentation book PDF files.

Discovering JMP

Provides a starting point if you are not familiar with JMP. The book introduces you to JMP and gets you started creating and analyzing data, and sharing your results.

Using JMP

Explains JMP data tables and how to perform basic operations. It covers general concepts and features that span all of JMP, including importing data, modifying column properties, sorting data, and using workflows.

Basic Analysis

Describes the following basic analyses that you can do from the Analyze menu:

• Distribution

• Fit Y by X

• Tabulate

• Text Explorer

It covers how to perform bivariate, one-way ANOVA, and contingency analyses using the Analyze > Fit Y by X platform. The book also addresses how to approximate sampling distributions using bootstrapping and how to perform parametric resampling with the Simulate platform.

Essential Graphing

Describes the following Graph menu platforms:

• Graph Builder

• Scatterplot 3D

• Contour Plot

• Bubble Plot

• Parallel Plot

• Cell Plot

• Scatterplot Matrix

• Ternary Plot

• Treemap

• Chart

• Overlay Plot

The book also explains how to create background and custom maps.

Profilers

Explains how to use interactive profiling tools, which enable you to view cross-sections of any response surface. It explains all profilers listed in the Graph menu. Analyzing noise factors is included along with running simulations using random inputs.

Design of Experiments Guide

Describes how to design experiments and determine appropriate sample sizes and covers all topics in the DOE menu.

Fitting Linear Models

Describes the following personalities, all available within the Analyze > Fit Model platform:

• Standard Least Squares

• Stepwise

• Generalized Regression

• Mixed Model

• Generalized Linear Mixed Model

• MANOVA

• Loglinear Variance

• Nominal Logistic

• Ordinal Logistic

• Generalized Linear Model

• Causal Treatment

Predictive and Specialized Modeling

Describes the following platforms in the Analyze > Predictive Modeling menu:

• Neural

• Partition

• Bootstrap Forest

• Boosted Tree

• K Nearest Neighbors

• Naive Bayes

• Support Vector Machines

• Model Comparison

• Model Screening

• Make Validation Column

• Formula Depot

Describes the following platforms in the Analyze > Specialized Modeling menu:

• Fit Curve

• Nonlinear

• Functional Data Explorer

• Gaussian Process

• Bayesian Optimization

• Time Series

• Time Series Forecast

• Matched Pairs

Describes the following Analyze > Screening menu platforms:

• Explore Outliers

• Explore Missing Values

• Explore Patterns

• Response Screening

• Predictor Screening

• Association Analysis

• Process History Explorer

Multivariate Methods

Covers how to analyze several variables simultaneously.

Describes the following Analyze > Multivariate Methods menu platforms:

• Multivariate

• Principal Components

• Discriminant

• Partial Least Squares

• Multiple Correspondence Analysis

• Structural Equation Models

• Factor Analysis

• Multidimensional Scaling

• Multivariate Embedding

• Item Analysis

Describes the following Analyze > Clustering menu platforms:

• Hierarchical Cluster

• K Means Cluster

• Normal Mixtures

• Latent Class Analysis

• Cluster Variables

Quality and Process Methods

Covers statistical tools for evaluating and improving processes.

Describes the following Analyze > Quality and Process menu platforms:

• Control Chart Builder and individual control charts

• Measurement Systems Analysis (EMP and Type 1 Gauge)

• Variability / Attribute Gauge Charts

• Process Screening

• Process Capability

• Model Driven Multivariate Control Chart

• Legacy Control Charts

• Pareto Plot

• Diagram

• Manage Limits

• OC Curves

Reliability and Survival Methods

Covers evaluating and improving reliability in a product or system and analyzing survival data for people and products.

Describes the following Analyze > Reliability and Survival menu platforms:

• Life Distribution

• Reliability Forecast

• Fit Life by X

• Fit Parametric Survival

• Cumulative Damage

• Fatigue Model

• Repeated Measures Degradation

• Destructive Degradation

• Recurrence Analysis

• Reliability Growth

• Reliability Block Diagram

• Repairable Systems Simulation

• Survival

• Degradation

• Fit Proportional Hazards

Consumer Research

Explains how to study consumer preferences and create better products and services.

Describes the following Analyze > Consumer Research menu platforms:

• Categorical

• Choice

• MaxDiff

• Uplift

• Multiple Factor Analysis

Life Sciences

Illustrates how to analyze your genetic data to simulate a breeding program to predict the optimum genetic crosses to make.

Describes the following Analyze > Life Sciences menu platforms:

• Marker Statistics

• Marker Simulation

• Marker Relatedness

• Marker Admixture

• Marker Imputation

• Normalization

• Distance Matrix

Scripting Guide

Defines the powerful JMP Scripting Language (JSL). Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications.

JSL Syntax Reference

Provides an overview of the JSL function arguments and messages. Includes syntax, examples, and notes for JSL commands.

Keyboard Shortcuts

Explains how to use your keyboard to quickly navigate JMP and complete tasks. Includes commands and the corresponding keystrokes for both Windows and Apple macOS.

Menu Descriptions

Covers JMP menu options for both Windows and Apple macOS.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).