公開日: 09/09/2026

ツールバーのカスタマイズ

JMPが標準で提供しているツールバーに新しいボタンを追加したり、独自のツールバーを作成したりできます。デフォルトでは、ウィンドウの種類によって表示されるバーが決まります。たとえば、[ファイル/編集]ツールバーはすべてのウィンドウに表示されます。データテーブルでは、[データテーブル]ツールバーも表示されます。

最初の操作

[最初の操作]メニューのボタンが表示されます。

Image shown here

プロジェクト

プロジェクトのボタンが表示されます。

Image shown here

ファイル/編集

[ファイル]メニューと[編集]メニューにあるオプションのボタンが表示されます。

Image shown here

分析

[分析]メニューにあるオプションのボタンが表示されます。

Image shown here

グラフ

[グラフ]メニューにあるオプションのボタンが表示されます。

Image shown here

ツール

カーソルの役割を変更するツールのボタンが表示されます。一部のウィンドウでは、ツールバーが非表示になり、代わりに青い線が表示されます。この青い線の上にカーソルを置くと、ツールバーが表示されます。

Image shown here

データテーブルリスト

開いているデータテーブルのリストが表示されます。データテーブルのリストから選択したものが、現在の(アクティブな)データテーブルになります。現在のデータテーブルは、常に最前面にあるとは限りません。テーブル(またはウィンドウ)を最前面に出すには、[ウィンドウ]メニューにあるウィンドウリストからウィンドウ名を選択します。

Image shown here

テーブル

[テーブル]メニューにあるオプションのボタンが表示されます。

Image shown here

実験計画(DOE)

[実験計画(DOE)]メニューにあるオプションのボタンが表示されます。

Image shown here

アプリケーションビルダー

アプリケーションビルダーにあるオプションのボタンが表示されます。

Image shown here

ホーム

[ファイル]メニューで頻繁に使うコマンドのボタンが表示されます。

Image shown here

データテーブル

データテーブルで行う一般的なタスク(「データフィルタ」、「モデルのあてはめ」、「再コード化」の各ウィンドウを開くなど)に対応するボタンが表示されます。

Image shown here

スクリプトエディタ

スクリプトの実行、デバッグ、再フォーマットを行うボタンが表示されます。

Image shown here

レポート

ローカルデータフィルタや列スイッチャーを開くボタン、スクリプトをデータテーブルに保存するボタンが表示されます。

Image shown here

よく利用するオプションが既存のツールバーに含まれていない場合などには、ツールバーをカスタマイズできます。ツールバーのボタンに、よく利用するオプションを割り当てます。ショートカットキーやボタンも変更できます。また、JMPスクリプト言語(JSL)のスクリプトも設定できます。

既存のツールバーに基づいて新しいツールバーを作成する場合は、既存のツールバーのコピーを作成してから、必要に応じて設定を適宜変更します。詳細については、メニュー・メニュー項目・ツールバー・ボタンのコピーと貼り付けを参照してください。

手順1: ツールバーの作成

1. [表示]>[カスタマイズ]>[メニューとツールバー]を選びます。

ウィンドウの左側にツールバーのリストが表示されます。

2. (オプション)カスタマイズした内容を表示できるユーザを指定します。

詳細については、カスタマイズセットのオプションを参照してください。

3. メニューエディタで、[ファイル/編集]など、ツールバーのいずれかを右クリックします。

どのツールバーを選択しても、新しいツールバーは「ツールバー」リストの末尾に表示されます。

4. [ツールバーの新規作成]を選びます。

新しいツールバーがリストの末尾に追加されます。ツールバーには少なくとも1つはボタンが必要なため、このツールバーには、名称未設定のボタンが含まれています。

手順2: キャプションと内部名の指定

ツールバーには基本的なプロパティがいくつかあります。

• キャプション。キャプションとして指定したテキストは、[表示]>[ツールバー]リストに表示されます。このリストで、各ツールバーの表示と非表示を切り替えることができます。各ツールバーに固有の名前を割り当ててください。同じ名前のツールバーは、メニューエディタを閉じて再び開くと、1つに統合されます。

• 内部名。内部名は、大文字と小文字が区別されません。項目の位置は、キャプションではなく、内部名で認識されます。

ツールバーのこれらのプロパティを指定するには、次の手順を行います。

1. メニューエディタでツールバーを選択します。

ウィンドウの右側に「一般」プロパティが右側に表示されます。

2. 「内部名」の横に内部名を入力します。

3. 「キャプション」ボックスに、ツールバーまたはボタンの固有の名前を入力します。

4. (オプション)各言語バージョンのJMPで表示されるキャプションを指定するには、次の操作を実行します。

– カスタマイズする項目の[ローカライズ]ボタンをクリックします。

– 言語を選択します。

– 「テキスト」の横に、翻訳した語句を入力します。

– [OK]をクリックします。

5. (オプション)ツールバーを作成した後、隠したままにしておく場合は[表示しない]をクリックします。

6. メニュー項目とツールバーボタンの作成で説明する手順に従って、無題のボタンをカスタマイズします。

7. [保存]をクリックし、変更内容を保存します。

より詳細な情報が必要な場合や、質問があるときは、JMPユーザーコミュニティで答えを見つけましょう (community.jmp.com).