データテーブルを表示させる必要がない場合は、2通りの方法でそれらのテーブルを非表示にできます。invisibleとして開く方法とprivateとして開く方法です。
invisibleで非表示にしたデータテーブルは、画面上では見えませんが、実行する分析にはリンクされています。次のようなコードによって、データテーブルを非表示の状態で開くことができます。
dt = Open( "$SAMPLE_DATA/Big Class.jmp", "invisible" );
次の例では、10行から成るAbcという非表示のデータテーブルを作成します。1つの列にXという名前をつけます。
dt = New Table( "Abc", "invisible", New Column( "X" ), Add Rows( 10 ) );
開いたデータテーブルが非表示かどうかを調べるには、データテーブルオブジェクトにブール値のHas Data Viewメッセージを送ります。次の式は、データテーブルが非表示の場合に0(偽)を戻します。
dt << Has Data View();
非表示のデータテーブルでの作業を終えたら、必ずClose()関数でデータテーブルを閉じてください。そうしないと、JMPを終了するまでデータテーブルがメモリに残ります。
非表示のデータテーブルは、Show Window()関数で表示できます。
dt = Open( "$SAMPLE_DATA/Big Class.jmp", "invisible" );
dt << Show Window( 1 );
ユーザはJMPのメニューからも、非表示(invisible)のデータテーブルを開くことができます。Windowsの場合、非表示(invisible)のデータテーブルはホームウィンドウのウィンドウリストと[ウィンドウ]>[再表示]メニューに表示されます。Apple macOSの場合も、非表示(invisible)のデータテーブルはJMPホームウィンドウと[ウィンドウ]>[表示しない]メニューに表示されます。
データテーブルを完全に非表示にするには、private引数を含めます。
dt = Open( "$SAMPLE_DATA/Big Class.jmp", "private" );
プライベート(private)なデータテーブルは、データテーブルを見えない状態にし、スクリプトの利用者がGUIから利用できないようにします。スクリプトの処理の途中で生成した、人の目に触れないようにしたいデータテーブルを格納しておきたい場合には、このプライベートなデータテーブルを用いるといいでしょう。プライベート(private)で大きなデータテーブルを開いても、メモリは節約されません。
詳細については、Private、Invisible、Visibleを参照してください。